道行般若经

    No. 224 [Nos. 220(4or5), 225-228, cf. 229]

    道行般若经序

        释道安撰

大哉智度。万圣资通。咸宗以成也。地合日照。无法不周。不恃不处。累彼有名。既外有名。亦病无形。两忘玄莫。喟然无主。此智之纪也。夫永寿莫美乎上干。而齐之殇子。神伟莫美于凌虚。而同之[仁-二+肙]滞。至德莫大乎真人。而比之朽种。高妙莫大乎世雄。而喻之幻梦。由此论之。亮为众圣宗矣。何者。执道御有。卑高有差。此有为之域耳。非据真如游法性冥然无名也。据真如游法性冥然无名者。智度之奥室也。名教远想者。智度之蘧庐也。然在乎证者。莫不[貝*賓]其生无而惶胘。存乎迩者。莫不忿其荡冥而诞诽。道动必反优劣致殊眩诽。不其宜乎。不其宜乎。要斯法也。与进度齐轸。逍遥俱游。千行万定。莫不以成。众行得字而智进全名。诸法参相成者。求之此列也。具其经也。进咨第一义。以为语端。退述权便。以为谈首。行无细而不历。数无微而不极。言以烦而各有宗。义似重而各有主。璅见者庆其迩教而悦寤。宏哲者望其远标绝目。陟者弥高而不能阶。陟者弥高而不能测。谋者虑不能规。寻者度不能尽。既窈冥矣。真可谓大业渊薮。妙矣者哉。然凡谕之者考文以微其理者。昏其趣者也。察句以验其义者。迷其旨者也。何则考文则异同每为辞。寻句则触类每为旨。为辞则丧其卒成之致。为旨则忽其始拟之义矣。若率初以要其终。或忘文以全其质者。则大智玄通居可知也。从始发意逮一切智。曲成决着八地无染。谓之智也。故曰远离也。三脱照空四非明有。统鉴诸法因后成用。药病双亡。谓之观也。明此二行。于三十万言。其如视诸掌乎。颠沛草次。无起无此也。佛泥曰后。外国高士。抄九十章。为道行品。桓灵之世。朔佛赍诣京师。译为汉文。因本顺旨转音如已。敬顺圣言。了不加饰也。然经既抄撮合成音投。音殊俗异。译人口传。自非三达。胡能一一得本缘故乎。由是道行颇有首尾隐者。古贤论之。往往有滞。仕行耻此寻求其本。到于阗乃得。送诣仓垣。出为放光品。斥重省删。务令婉便。若其悉文。将过三倍。善出无生。论空持巧。传译如是。难为继矣。二家所出。足令大智焕尔阐幽。支谶全本。其亦应然。何者抄经删削。所害必多。委本从圣。乃佛之至戒也。安不量末学庶几斯心。载咏载玩。未坠于地。检其所出。事本终始。犹令折伤玷缺[病-丙+((日/月)*戈)]然无际。假无放光。何由解斯经乎。永谢先哲所蒙多矣。今集所见为解句下。始况现首终隐现尾。出经见异铨其得否。举本证抄敢增损也。幸我同好饰其瑕讁也

道行般若经卷第一

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜道行品第一

佛在罗阅只耆阇崛山中。摩诃比丘僧不可计。诸弟子舍利弗。须菩提等。摩诃萨菩萨无央数。弥勒菩萨。文殊师利菩萨等。月十五日说戒时。佛告须菩提。今日菩萨大会。因诸菩萨故。说般若波罗蜜。菩萨当是学成。舍利弗心念言。今使须菩提为诸菩萨说般若波罗蜜。自用力说耶。持佛威神说乎。须菩提知舍利弗心所念。便语舍利弗言。敢佛弟子所说法。所成法。皆持佛威神。何以故。佛所说法。法中所学。皆有证。皆随法。展转相教。展转相成。法中终不共诤。何以故。时而说法。莫不喜乐者自恣。善男子善女人而学。须菩提白佛言。佛使我为诸菩萨说般若波罗蜜。菩萨当从中学成。佛使我说菩萨。菩萨有字便着菩萨。有字无字何而法中字菩萨。了不见有法菩萨。菩萨法字了无。亦不见菩萨。亦不见其处。何而有菩萨。当教般若波罗蜜。作是说般若波罗蜜。菩萨闻是心不懈怠。不恐不怯不难不畏。菩萨当念作是学。当念作是住。当念作是学。入中心不当念是菩萨。何以故。有心无心。舍利弗谓须菩提。云何有心无心。须菩提言。心亦不有。亦不无。亦不能得。亦不能知处。舍利弗谓须菩提。何而心亦不有亦不无。亦不能得。亦不能知处者。如是亦不有亦不无。亦不有有心。亦不无无心。须菩提言。亦不有有心。亦不无无心。舍利弗言。善哉须菩提。为佛学佛。而学者不说空身慧。空身慧而说最第一。菩萨从是中。已得阿惟越致。学字终不复失般若波罗蜜。如是菩萨以在般若波罗蜜中住。欲学阿罗汉法。当闻般若波罗蜜。当学当持当守。欲学辟支佛法。当闻般若波罗蜜。当学当持当守。欲学菩萨法。当闻般若波罗蜜。当学当持当守。何以故。般若波罗蜜法甚深。菩萨如学。须菩提白佛言。我熟念菩萨心不可得。亦不可知处。亦不可见何所。是菩萨般若波罗蜜。亦不能及说。亦不能逮说菩萨字。菩萨无有处处。了不可得。亦无而出。亦无如入。亦无如住。亦无如止。何以故。菩萨字了不可得故。无如住无如止。作是说般若波罗蜜。菩萨闻是心不懈倦。不难不恐不畏。以入阿惟越致中悉了知。不可复退

菩萨行般若波罗蜜。色不当于中住。痛痒思想生死识。不当于中住。何以故。住色中为行识。住痛痒思想生死识中为行识。不当行识。设住其中者。为不随般若波罗蜜教。何以故。行识故。是为不行般若波罗蜜。不行者。菩萨不得萨芸若。舍利弗谓须菩提。菩萨当云何行般若波罗蜜得般若波罗蜜。须菩提言。菩萨行般若波罗蜜。色不受。痛痒思想生死识不受。不受色者为无色。不受痛痒思想生死识者为无识。般若波罗蜜不受。何以故不受。如影无所取。无所得故不受。菩萨行般若波罗蜜。一切字法不受。是故三昧无有边。无有正。诸阿罗汉辟支佛。所不能及

复次舍利弗。萨芸若不受。何以故。菩萨不当持想视萨芸若。设想视者为不了为。如余道人不信萨芸若。何以故。反谓有身。正使余道人信佛。信佛已。反持小道入佛道中。入佛道中已不受。色痛痒思想生死识不受。不受已亦未晓。尚未成。亦不见慧。亦不于内见慧。亦不于外见慧。亦不于余处见慧。亦不于内痛痒思想生死识见慧。亦不于外痛痒思想生死识余处见慧。亦不于余处脱。以学成就佛。了知从法中以脱去。谓法等一泥洹。菩萨莫作是行。莫内外视法。吁与般若波罗蜜等。一切无所受无所从。谁得法。无所持无所收。亦无所泥洹想。是故菩萨般若波罗蜜亦不受。色痛痒思想生死识亦不受。亦不中道。般泥洹悉具十种力。四无所畏。佛十八事。是故菩萨般若波罗蜜。菩萨已入般若波罗蜜中行。当作是视何所。是般若波罗蜜在何所。般若波罗蜜中法。了不能得。了不能知处。是故般若波罗蜜。菩萨当作是念。闻是不懈不却不恐不畏不难。知是菩萨不离般若波罗蜜。菩萨当了知如是

舍利弗谓须菩提。菩萨何因晓般若波罗蜜。色离本色。痛痒思想生死识离本识。般若波罗蜜离本般若波罗蜜。须菩提言。如是。舍利弗言。善哉须菩提。菩萨设使出是中。便自致萨芸若。须菩提言。如是菩萨出是中。便自致萨芸若。何以故。萨芸若无所从生无所从生。如是菩萨疾近作佛。菩萨行般若波罗蜜。于萨芸若中无所挂碍。舍利弗言。善哉。菩萨精进作是语。设使行色为行想。设生色行为行想。设观色行为行想。设灭色行为行想。设空色行为行想。设识行立欲得为行想。痛痒思想生死识行为行想。生识行为行想。观识行为行想。灭识行为行想。空识行为行想。如是菩萨为反行想。作是守行者为不守般若波罗蜜。为不行般若波罗蜜。若想行者菩萨护行。当莫随其中。舍利弗谓须菩提。菩萨当云何行般若波罗蜜。须菩提言。不行色。不生色行。不观色行。不灭色行。不空色行。不痛痒思想生死识行。不生识行。不观识行。不灭识行。不空识行。不行色。不色想行。不色生行。不色观行。不识灭行。不识空行。亦无见亦无行。亦无见行。无行无见。亦复无行。亦无止行。如是为无见。何以故。一切法无所从来亦无所持。菩萨摩诃萨一切字法不受字。是故三昧无有边无有正。诸阿罗汉辟支佛所不能及知。菩萨摩诃萨随三昧者。疾得作佛持佛威神。须菩提说是语。菩萨皆得阿惟越致字。前过去佛时得作佛。随三昧亦不见三昧。亦无有三昧想。亦不作三昧。亦不念识三昧。亦不想识坐三昧。亦不言我三昧。已随是法者无有疑。舍利弗谓须菩提。何所三昧随行。菩萨已得阿惟越致字。前过去佛时得作佛。可得见三昧处不。须菩提言。不可得见也。舍利弗。善男子亦不知亦不了。舍利弗谓须菩提。何以故。不知不了。须菩提言。亦不得三昧。亦无有三昧。亦不得字。佛言。善哉须菩提。如我所说。空身慧作是为诸菩萨为随般若波罗蜜教。菩萨作是学为学般若波罗蜜也。舍利弗白佛言。天中天。菩萨学如是。为学般若波罗蜜。舍利弗问佛言。如是为学何法。佛言。如是菩萨。为学无所学法。何以故。法无所逮得。莫痴如小儿学。舍利弗言。谁能得是法。佛言。无所得。是故得无所得法。莫痴如小儿学者。谓有字不能得。欲学习入法中。适为两痴耳。亦不知亦不晓。亦不了法。何以故。学字是色欲得是致。是故不了法所念。亦不逮如是不晓不信故。不于法中住。反呼有身。是故痴如小儿学。舍利弗白佛言。菩萨作是学为不学。佛言。作是学为不学。佛不作是学为学。佛得作佛

须菩提言。天中天。若有问者。是幻为学。佛得作佛。或作是问。当何以教之。佛言。我故自问。若随所报之。于须菩提意云何。幻与色有异无。幻与痛痒思想生死识有异无。须菩提报佛言。尔天中天。幻与色无异也。色是幻。幻是色。幻与痛痒思想生死识等无异。佛言。云何须菩提。所想等不随法从五阴字菩萨。须菩提言。如是。天中天。菩萨学欲作佛为学幻耳。何以故。幻者当持此所有。当如持五阴幻如色色六衰五阴如幻痛痒思想生死识作是语字六衰五阴

须菩提白佛言。若有新学菩萨。闻是语得无恐怖。佛言。设使新学菩萨。与恶师相得相随。或恐或怖。与善师相得相随。不恐不怖。须菩提言。何所菩萨恶师者。当何以知之。佛言。其人不尊重摩诃般若波罗蜜者。教人弃舍去远离菩萨心。反教学诸杂经。随杂经心喜乐。复教学余经。若阿罗汉辟支佛道法。教学是事。劝乃令讽诵。为说魔事。魔因行坏败菩萨。为种种说生死勤苦言。菩萨道不可得。是故菩萨恶师。须菩提白佛言。何所菩萨善师。何行从知之。佛言。其人尊重摩诃般若波罗蜜。稍稍教人令学成教。语魔事令觉知令护魔。是故菩萨善师也

须菩提白佛言。天中天。何因为菩萨。何故正字呼菩萨。佛言。诸经法悉学悉晓。了知诸经法。尔故字为菩萨。须菩提言。悉晓了知诸经法。尔故字菩萨。何以故。复呼摩诃萨。佛言。摩诃萨者。天上天下最尊。尔故字为摩诃萨。舍利弗白佛言。我亦乐闻。何以故为摩诃萨。佛语舍利弗。若乐闻者。佛当为若说之。摩诃萨者。悉自了见悉了知。十方天下人十方所有悉晓了知。知人寿命。知有恶无恶。乐不乐。有志无志。悉晓了知见为说法。如是无所著。尔故字为摩诃萨

须菩提白佛言。请问摩诃萨者。何所字摩诃萨。设是菩萨心无有与等者。无有能逮心者。诸阿罗汉辟支佛。所不能及心。佛心如是。心无所著。心无所出无所入。设佛心无所出无所入。为无所著心。尔故复为摩诃萨。正上无有与等者。舍利弗问须菩提。何因菩萨心无所著。须菩提言。心无所生。尔故无所著

邠祁文陀弗白佛言。何因呼菩萨。为摩诃僧那僧涅。摩诃衍三拔致。佛说号如是。尔故为摩诃僧那僧涅。摩诃衍三拔致。须菩提复白佛言。何因菩萨摩诃萨为摩诃僧那僧涅。何从知菩萨摩诃萨。为摩诃僧那僧涅。佛言。菩萨摩诃萨。心念如是。我当度不可计阿僧祇人悉令般泥洹。如是悉般泥洹。是法无不般泥洹一人也。何以故。本无故。譬如幻师于旷大处化作二大城。作化人满其中。悉断化人头。于须菩提意云何。宁有所中伤死者无。须菩提言无。菩萨摩诃萨。度不可计阿僧祇人。悉令般泥洹。无不般泥洹一人也。菩萨闻是。不恐不畏不悉不舍。去就余道。知是则为摩诃僧那僧涅

须菩提白佛言。如我从佛闻。念其中事如是。不为摩诃僧那僧涅。何以故。作是为者。无有作萨芸若。无所供养。人无作者。为何等所人作摩诃僧那僧涅。色无著无缚无脱。痛痒思想生死识。无著无缚无脱。邠祁文陀弗谓须菩提。色无著无缚无脱。痛痒思想生死识。无著无缚无脱。何谓。须菩提言。色无著无缚无脱。痛痒思想生死识。无著无缚无脱。邠祁文陀弗言。何谓色无著无缚无脱。何谓痛痒思想生死识无著无缚无脱。须菩提语邠祁文陀弗。色如幻。无著无缚无脱。痛痒思想生死识如幻。无著无缚无脱。无有边。无著无缚无脱。譬如空无著无缚无脱。无所生。无著无缚无脱。是故菩萨摩诃萨摩诃僧那僧涅

须菩提白佛言。何因为摩诃衍三拔致。何所是摩诃衍。从何所当住衍中。何从出衍中。谁为成衍者。佛语须菩提。摩诃衍。摩诃衍者。无有正也。不可得边幅。须菩提问佛言。我欲知衍从何所出生。从三处出。自致萨芸若中住。亦无有从中出生者。无有甫当来出者。何以故。天中天。佛言。正使生已甫当来出者。假令有两法者不可得法。设不从得者。复从何法出。须菩提白佛言。摩诃衍。于天上天下人中正过上无有与等者。衍与空等。如空覆不可复计阿僧祇人。摩诃衍覆不可复计阿僧祇人。尔故呼摩诃衍。摩诃衍者。亦不见来时。亦不见去时。亦不见住处。亦不中边见。亦不于是闻见。亦无所见。亦不于三处见。字如是天中天。尔故为摩诃衍。佛言。善哉须菩提。尔故为摩诃衍

邠祁文陀弗白佛言。尊者须菩提。佛使说般若波罗蜜。及至说摩诃衍事为。须菩提白佛言。须菩提说般若波罗蜜得无过。天中天。佛言。若说般若波罗蜜不过也。适得其中。须菩提言。菩萨亦不念彼间。亦不于是间念。亦不无中央念。色亦无有边。菩萨亦无有边。色与菩萨。不可逮不可得。一切菩萨。不可得不可逮。何所是菩萨般若波罗蜜。当何从说菩萨。都不可得见。亦不可知处。当从何所说般若波罗蜜。菩萨转复相呼菩萨云何天中天想如字耳何如为意。意无处处。意无形形。意本是形法。何等为色。色不可得见。亦无有身。是中何所有色者。痛痒思想生死识。识不可得见。菩萨亦不可得见。菩萨识了不知处处。亦不可见。一切菩萨了无有处了不可见。何所为菩萨般若波罗蜜。如是说菩萨。都不可得见。亦不可知处处。了无所有。当从何所法中说般若波罗蜜。尔故字为菩萨

如是如是。字想亦无。字亦无想。何所为意意谁字意至本本意生意是无形。何因是识不可得。持至本亦无所持。何因有识。如是法形。形亦无有本。设无有本。法亦无谁作。亦无有本。本无有本。当何从说。般若波罗蜜。亦无有异处。亦无有本。菩萨法亦无所得。有行菩萨。闻是不恐不畏不难。则为行般若波罗蜜。行般若波罗蜜法。当熟思惟如是。是时为不入色。何以故。色无所生为非色。设尔非色为无色。亦无有生。从其中无所得。字为色法中本无。无是菩萨行般若波罗蜜视法思惟深入法。是时亦不入痛痒思想生死识。何以故。识无所生为非识故。亦不出识中。亦不入识中。法中计了无所有

舍利弗谓须菩提。我听须菩提所说法中事。如是菩萨无所出生。设菩萨无所出生者。菩萨如用何等故。谦苦行菩萨道。设用十方天下人故何能忍是谦苦。须菩提语舍利弗。我亦不使菩萨忍是谦苦也。行菩萨之道者。菩萨自念。我不录是谦苦行。何以故。菩萨心不当作是念言。我忍谦苦心未曾有念。是不当作是念。为用不可计阿僧祇人故。欲令安隐。念之如父。念之如母。念之如子。念之如身无异。常当慈念之。菩萨当作是持心。一切菩萨不见。亦不知处。如是内法外法。当作是念。当作是行。菩萨作是行不为忍谦苦。舍利弗。设使如是所语。菩萨不见出生。菩萨为无所出生。舍利弗谓须菩提。设使菩萨无所出生。萨芸若亦无所出生。须菩提言。如是萨芸若无所出生。舍利弗谓须菩提。设使菩萨如是所语。菩萨不见出生。菩萨为无所出生。舍利弗谓须菩提。设使菩萨无所出生。萨芸若亦无所出生。须菩提言。如是萨芸若无所出生。舍利弗谓须菩提。设使萨芸若无所出生。悉逮得禅亦无所生。须菩提言。如是悉逮得禅亦无所生。舍利弗谓须菩提。是中菩萨无所生。菩萨为无所生。萨芸若亦无所生。萨芸若法为无所生。悉逮得禅具足亦无所生。悉逮得禅法亦无所生。是为无所逮得菩萨。为无所逮得萨芸若

须菩提言。无所生法逮得无所生。亦无所生法逮得。亦无无无所生逮得。舍利弗谓须菩提。设使无无无所生逮得无所生法。是故无所生逮法。须菩提言。设使无所生法生。复无无所生。是故无所生逮得。舍利弗谓须菩提设使须菩提。无所生无无所生。是故无所生。须菩提。无所生。须菩提语舍利弗。无所生无所生乐闻。舍利弗。无所生乐是故为乐。须菩提语舍利弗。无所生闻是为闻。舍利弗谓须菩提。闻是语。须菩提语舍利弗。无无所语是为语无所语。是为乐无所乐。是故语是故乐。舍利弗言。善哉须菩提。于法中第一尊。何以故。如尊者须菩提。随所问则报。须菩提谓舍利弗。佛弟子所说法十方亦不知所化来。时随所问则解。何以故。十方法亦不知所生。舍利弗言。善哉须菩提。从何所法中度菩萨。须菩提言从般若波罗蜜中生。说是法时若读时。菩萨信不疑。菩萨当知之。有随是法不增。不随是法不减。舍利弗谓须菩提。随是法亦不增。不随是法亦不减。随法教一切人。随法者不失一切人。皆使得菩萨摩诃萨。何以故。一切人悉学法。其法俗如故。须菩提言。善哉舍利弗。所解法。如舍利弗言无异。何以故。人身当谛念。当作是了知。人身若干种空。其念亦若干种空当了。知是人身难了知。所念难了知舍利弗菩萨当作是学当作是行

    摩诃般若波罗蜜难问品第二

尔时释提桓因与四万天子。相随俱来共会坐。四天王与天上二万天子。相随来共会坐。梵迦夷天与万天子。相随来共会坐。梵多会天与五千天子。相随来共会坐。诸天子宿命有德光明巍巍。持佛威神持佛力。诸天子光明彻照。释提桓因白须菩提言。贤者须菩提。是若干千万天子大会。欲听须菩提说般若波罗蜜云何菩萨于般若波罗蜜中住。须菩提语释提桓因言。拘翼。是若干千万天子乐者听我当说。须菩提持佛威神持佛力。广为诸天子说般若波罗蜜。何所天子未行菩萨道。其未行者今皆当行。以得须陀洹道。不可复得菩萨道。何以故。闭塞生死道故。正使是辈行菩萨道者。我代其喜。我终不断功德法。我使欲取中正尊法。正欲使上佛。佛言。善哉须菩提。劝乐诸菩萨学乃尔。须菩提白佛言。须菩提当报恩。不得不报恩。何以故。过去时怛萨阿竭阿罗呵三耶三佛。皆使诸弟子为诸菩萨说般若波罗蜜。怛萨阿竭时亦在其中学。如是中法令自致作佛。用是故。当报佛恩。我亦复作是说般若波罗蜜。菩萨亦当复受菩萨法。我复劝乐。我皆受已。皆劝乐已。菩萨疾逮作佛。须菩提言。拘翼。当所问者听所问。菩萨云何住般若波罗蜜中。持空法菩萨。于般若波罗蜜中住。拘翼。菩萨摩诃萨摩诃僧那僧涅摩诃衍三拔致。色不当于中住。痛痒思想生死识不当于中住。须陀洹不当于中住。斯陀含不当于中住。阿那含不当于中住。阿罗汉不当于中住。辟支佛不当于中住。佛不当于中住。有色无色不当于中住。有痛痒思想生死识。无痛痒思想生死识不当于中住。有须陀洹无须陀洹不当于中住。有斯陀含无斯陀含不当于中住。有阿那含无阿那含不当于中住。有阿罗汉无阿罗汉不当于中住。有辟支佛无辟支佛不当于中住。有佛无佛不当于中住。色无无常不当于中住。痛痒思想生死识无无常不当于中住。色若苦若乐不当于中住。色若好若丑不当于中住。痛痒思想生死识若苦若乐不当于中住。痛痒思想生死识。若好若丑不当于中住。色我所非我所不当于中住。痛痒思想生死识我所非我所不当于中住。须陀洹道不动成就不当于中住。须陀洹道成已不当于中住。何以故。须陀洹道七死七生便度去。是故须陀洹道不当于中住。斯陀含道不动成就不当于中住。斯陀含道成已不当于中住。何以故。斯陀含道一死一生便度去。是故斯陀含道不当于中住。阿那含道不动成就不当于中住。阿那含道成已不当于中住。何以故。阿那含道成已。便于天上般泥洹。是故阿那含道不当于中住。阿罗汉道不动成就不当于中住。阿罗汉道成已不当于中住。何以故。阿罗汉道成已。便尽是间无处所。于泥洹中般泥洹。是故阿罗汉道不当于中住。辟支佛道不动成就不当于中住。何以故。辟支佛道成已。过阿罗汉道不能及佛道。便中道般泥洹。是故辟支佛道不当于中住。佛道不当于中住。何以故。用不可计阿僧祇人故作功德。以不可计阿僧祇人。我皆当令般泥洹正于佛中住。是故佛道不当于中住。舍利弗心念言。佛当云何住。须菩提知舍利弗心所念。便问舍利弗言。云何佛在何所在。舍利弗谓须菩提。佛无所住。怛萨阿竭阿罗呵三耶三佛。心无所住止。不在动处止。亦无动处止。须菩提言。如是如是。菩萨当作是学。如怛萨阿竭阿罗呵三耶三佛住亦不可住。当作是住学无所住。是时诸天子心中作是念。诸阅叉辈尚可知所念。阅叉若大若小所语悉可了知。尊者须菩提所语了不可知。须菩提知诸天子心中所念。谓诸天子言。是语难了。亦不可闻。亦不可知。诸天子心中复作是念。是语当解。今尊者须菩提深入深知须菩提复知诸天子心中所念语诸天子言。已得须陀洹道证。若于中住不乐因出去。已得斯陀含道证。若于中住不乐因去。以得阿那含道证。若于中住不乐因去。已得阿罗汉道证。若于中住不乐因去。已得辟支佛道证。若于中住不乐因去。以得佛道证。若于中住不乐因去。诸天子心中复作是念。尊者须菩提所说乃尔。当复于何所更索法师如须菩提言者。须菩提知诸天子心中所念。语诸天子言。法师如幻。欲从我闻法。亦无所闻。亦不作证。诸天子心中复作是念。云何法作是闻人如是。须菩提知诸天子心中复作是念。语诸天子言。幻如人。人如幻乎。我呼须陀洹斯陀含阿那含阿罗汉辟支佛道悉如幻。正使佛道我呼亦如幻。诸天子语须菩提。乃至佛道亦复呼如幻。须菩提言乃至泥洹亦复如幻。诸天子问须菩提。乃至泥洹泥洹及泥洹亦复如幻。须菩提语诸天子。设复有法出于泥洹亦复如幻。何以故。幻人泥洹赐如空无所有。舍利弗。邠祁文陀罗弗。摩呵拘私。摩呵迦旃延。问须菩提。何等为般若波罗蜜相。从何等法中出。须菩提报言。从是法中出阿惟越致菩萨。是为般若波罗蜜相。如是诸弟子闻法。悉具足疾成阿罗汉。须菩提言。般若波罗蜜中说相如是。从法中无所出。何以故。法中无所有无所闻无所得。如法比丘。无所闻法。无所得法。从是法中无所受。释提桓因心念言。尊者须菩提所说为雨法宝。我宁可作华持散尊者须菩提上。释提桓因则化作华散须菩提上。须菩提心则了知言。是华不出忉利天上。我曾见是华。是华所出生散我上者。化作耳化成耳。此华化华。亦不从树出。释提桓因所作华。用散我上者。从心树出。不从树生也。释提桓因谓须菩提言。此华无所从出生。尊者须菩提。不从心树出。须菩提言。拘翼说言。是华无所从出生。亦不从心树出。为非华。释提桓因言。尊者须菩提深知说不增不减。作是说法。如尊者须菩提教也。菩萨当作是学。须菩提语释提桓因。拘翼。是语无有异。菩萨当作是学入法中。菩萨作是学者。为不学须陀洹斯陀含陀那含阿罗汉辟支佛道。为学佛道。为学萨芸若道。作是学者。为学不可计阿僧祇经卷。不生色学。不生痛痒思想生死识学。不学受余法。亦不学受。亦不学失。不学失为学萨芸若。为出萨芸若

舍利弗谓须菩提。学是学亦不受亦不失。为学萨芸若。为出萨芸若。须菩提言。如是舍利弗。作是学亦不受亦不失。学是为学萨芸若。为出萨芸若。释提桓因问舍利弗。般若波罗蜜菩萨当云何行。舍利弗言。当问尊者须菩提。释提桓因问尊者须菩提。持何威神恩当学知。须菩提言。持佛威神恩当学知。拘翼。所问般若波罗蜜菩萨云何行。亦不可从色中行。亦不可离色行。亦不可从痛痒思想生死识中行。亦不可离痛痒思想生死识行。何以故。般若波罗蜜亦非痛痒思想生死识。般若波罗蜜亦不离痛痒思想生死识。释提桓因言。摩诃波罗蜜。无有边无有底波罗蜜云何。须菩提言。拘翼。摩诃波罗蜜。无有边波罗蜜。无有底波罗蜜。摩诃波罗蜜了不可得。无有边波罗蜜了不可见。无有底波罗蜜了不可得底。人无底复无无底。无底复无无底。波罗蜜等无底复无无底。波罗蜜无底复无无底。亦无有中边。亦无有本端。了不可量了不可逮知。拘翼。从法中底波罗蜜底无底复无无底。复次拘翼。法无底复无端。底无有中边无有尽时。底索无底复无无底波罗蜜。释提桓因言。云何尊者须菩提。何以故。人无底。波罗蜜无底。须菩提谓释提桓因。是事都卢不可计。正使计倍复倍。人无底。波罗蜜无底。释提桓因言。何缘尔人无底波罗蜜无底。须菩提言。于拘翼意云何。何所法中作是教人本所生。释提桓因言。无有法作是教者。亦无法作是教住置。设使有出者但字耳。设有住止者但字耳。但以字字着言耳。有所住止处但字耳。了无所有。但以字字着言耳。人复人所。本末空无所有。须菩提言。于拘翼意云何。人可得见不。释提桓因言。人不可得见。须菩提言。拘翼。何所有作意者。何所人底。正使怛萨阿竭阿罗呵三耶三佛。寿如恒边沙劫尽度人。人展转自相度。其所生者宁有断绝时不。释提桓因言。无有断绝时。何以故。人无有尽时。须菩提言。人无有底。般若波罗蜜无底。菩萨学当作是了。当作是知。行般若波罗蜜法如是

道行般若波罗蜜经卷第一道行般若经卷第二

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜功德品第三

尔时诸因坻天。诸梵天。诸波那和提天。诸伊沙天。诸那提干天。同时三反作是称誉法。贤者须菩提所说法甚深。怛萨阿竭皆从是生。其有闻者。若讽诵读有行者。我辈恭敬视如怛萨阿竭我辈恭敬视菩萨摩诃萨持般若波罗蜜者。佛语诸天人。如是如是。昔我于提和竭罗佛前。逮得般若波罗蜜。我便为提和竭罗佛。所受决言。却后若当为人中之导悉当逮佛智慧。却后无数阿僧祇劫。汝当作佛号字释迦文。天上天下于中最尊。安定世间法极明。号字为佛。诸天人同时白佛言。甚善。菩萨摩诃萨天中天。行般若波罗蜜自致到萨芸若

尔时佛在众会中央诸天中坐。佛告比丘比丘尼优婆塞优婆夷。今四部为证。欲天梵天阿会亘修天皆证知。佛语释提桓因。若有善男子善女人。其有学般若波罗蜜者。其有持者其有诵者。是善男子善女人。魔若魔天终不能得其便。拘翼。善男子善女人。若人若非人终不能得其便。拘翼。善男子善女人不得横死。拘翼。忉利天上诸天人。其有行佛道者。未得般若波罗蜜。未学者未诵者。是辈天人。皆往到善男子善女人所。拘翼。善男子善女人。学般若波罗蜜者。持者诵者。若于空闲处。若于僻隈处。亦不恐亦不怖亦不畏。四天王白佛言。我辈自共护是善男子善女人学般若波罗蜜者持者诵者。梵摩三钵天及梵天诸天人俱白佛言。我辈自共护是善男子善女人学般若波罗蜜者持者诵者。释提桓因白佛言。我自护是善男子善女人学般若波罗蜜者持者诵者。释提桓因复白佛言。难及也有学般若波罗蜜者。善男子善女人心无所动摇。般若波罗蜜其受者。为悉受六波罗蜜。佛言。如是拘翼。其受般若波罗蜜者。为悉受六波罗蜜。复次拘翼。般若波罗蜜学者持者诵者。善男子善女人且听。拘翼我说。上语亦善。中语亦善。下语亦善。当念听我所说。释提桓因从佛听言受教

佛语释提桓因。我法中有娆者有害者有乱者。欲娆者欲害者欲乱者。其人稍稍起恶意。欲往未至中道亡。欲娆者欲害者欲乱者。其后所作终不谐。何以故。用是善男子善女人学般若波罗蜜故。持故诵故。其人稍稍赍恶来未至便屈还。其后所愿终不得。拘翼。善男子善女人。所作为悉自见。得学般若波罗蜜者持者诵者。譬若拘翼有药名摩舐。有蛇饥行索食道逢虫。蛇欲啖虫。摩舐药香即到虫所。蛇闻药香即还去。何以故。药力所却蛇毒即歇。药力所厌如是。拘翼。善男子善女人。学般若波罗蜜者持者诵者。其有欲害者便自亡般若波罗蜜威神所却。般若波罗蜜力所厌也。佛言。设有谋作者。从所来处。便于彼间。自断坏不复成。四天王皆拥护是善男子善女人入般若波罗蜜者思惟者。自在所为。所语如甘露。所语不轻。嗔恚不生。自贡高不生。四天王皆护是善男子善女人学般若波罗蜜者持者诵者。所语无有异。所语如甘露。所语不轻。嗔恚不起。自贡高不生。何以故。用学般若波罗蜜故。不受自嗔恚。不受自贡高。不受自可。是善男子善女人心自生念。若有斗诤起。常当身远离。不喜是事。面自惭自念。是曹恶者不可近。自念我索佛道。不可随嗔恚语。疾使我逮得好心。善男子善女人。所作为悉自见。善般若波罗蜜学者持者诵者

释提桓因白佛言。般若波罗蜜能过诸恶上去。自在所作无有与等者。佛语释提桓因。复次拘翼。善男子善女人。般若波罗蜜学者持者诵者。或当过剧难之中。终不恐不怖。正使入军不被兵。佛言。我所语无有异。拘翼。如佛言无有能害者。善男子善女人。当是时若诵若持般若波罗蜜若念。正使死来至。若当于中死若怨家在其中欲共害者如佛所语无有异。是善男子善女人。终不于中横死。正使在其中。若有射者若兵向者终不中其身。何以故。是般若波罗蜜者。极大祝人中之猛祝。学是祝者。是善男子善女人不自念恶。亦不念他人恶。都无所念善为人中之雄自致作佛。为护人民蜎飞蠕动。学是祝者疾成佛道也

复次拘翼。般若波罗蜜书已。虽不能学不能诵者。当持其经卷。若人若鬼神不能中害。其有宿命之罪不可请。譬若拘翼初得佛之处。四面若有人。直从一面来入。若鬼神若禽兽无有能害者。若鬼神若禽兽。欲来娆人。欲来害人。终不能中。何以故。用佛得道处故。佛威神所护。过去当来今现在佛天中天。皆为人中尊。悉于其中作佛。甫当复出索佛道者。皆当于其中得佛道。若有人入是处者。不恐不怖无所畏惧。般若波罗蜜者如是。般若波罗蜜所止处。一切诸天人民阿须伦鬼神龙。皆为作礼恭敬护视。用是故般若波罗蜜威神所护。释提桓因白佛言。若有天中天。般若波罗蜜书者持经卷者。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。若般泥洹后。持佛舍利起塔。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。如是其福。何所为多者。佛言。我故问汝。拘翼。随所乐报我。云何拘翼。怛萨阿竭阿罗呵三耶三佛萨芸若。成是身出见。怛萨阿竭从何法中。学得阿耨多罗三耶三佛。释提桓因报佛言。怛萨阿竭从般若波罗蜜中。学得阿耨多罗三耶三佛。佛语释提桓因。不用身舍利。从萨芸若中得佛。怛萨阿竭为出般若波罗蜜中。如是拘翼。萨芸若身从般若波罗蜜中出。怛萨阿竭阿罗呵三耶三佛萨芸若身。萨芸若身生我作佛身。从萨芸若得作佛身。从萨芸若生我般泥洹后舍利。供养如故。若有拘翼善男子善女人书般若波罗蜜学持诵行。自归作礼承事供养。好华捣香泽香杂香缯彩华盖旗幡。萨芸若则为供养。以如是拘翼。般若波罗蜜写已。作是供养经卷。善男子善女人。从其法中得功德无比。何以故。萨芸若者。则为供养已。释提桓因白佛言。如是阎浮利人。不供养承事般若波罗蜜者。是曹之人为不知其尊耶。供养般若波罗蜜者。其福尊无比。般若波罗蜜者。当取供养之。佛语释提桓因。云何拘翼。阎浮利人中有几所人。信佛信法信比丘僧。释提桓因白佛言。阎浮利人。少所信佛信法信比丘僧者少少耳。及行须陀洹斯陀含阿那含阿罗汉辟支佛。至行佛道者复少少耳。佛言。如是拘翼。少少耳。人至有索佛道。行求佛道者甚多。至其然后作佛少少耳。如是不可计阿僧祇人。初行求佛道。至其然后从其中出。若一若两。在阿惟越致地住耳。如是拘翼。是善男子善女人。行求佛道。会后成佛如是。佛言。善男子善女人。学般若波罗蜜者持经者诵经者。当为作礼承事恭敬。何以故。用晓般若波罗蜜中事故。少有过去时怛萨阿竭阿罗呵三耶三佛。过去时菩萨行佛道者。皆于般若波罗蜜中学成。我时亦共在其中学。怛萨阿竭般泥洹后。诸菩萨摩诃萨悉当受是般若波罗蜜。拘翼。善男子善女人。怛萨阿竭般泥洹后。取舍利起七宝塔供养。尽形寿自归作礼承事。持天华天捣香天泽香天杂香天缯天盖天幡。如是于拘翼意云何。善男子善女人。作是供养其福宁多不。释提桓因言。甚多甚多天中天。佛言不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡得福多也

佛言。置是塔。拘翼。若复有阎浮利满中七宝塔。若有善男子善女人。尽形寿自归作礼承事供养天华天捣香天泽香天杂香天缯天盖天幡。云何拘翼。是善男子善女人。其福宁多不。释提桓因言。甚多甚多天中天。佛言不如是。善男子善女人。书般若波罗蜜持经卷自归作礼承事供养名华捣香泽香杂香缯彩华盖旗幡得福多。佛言。置阎浮利所作事。拘翼。满四天下七宝塔。若有善男子善女人。尽形寿自归作礼承事供养。天华天捣香天泽香天杂香天缯天盖天幡其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡得福多

佛言。置四天下塔。拘翼。譬如一天下。复次一天下。如是千天下四面皆满其中七宝塔。若有善男子善女人尽形寿自归作礼承事供养天华天捣香天泽香天杂香天缯天盖天幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡得福多佛言复置千天下。拘翼。如是中二千天下四面皆满其中七宝塔。若有善男子善女人。尽形寿自归作礼承事供养天华天捣香天泽香天杂香天缯天盖天幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养名华捣香泽香杂香缯彩华盖旗幡得福多。佛言。复置是中二千天下。拘翼。若三千天下四面皆满其中七宝塔。若有善男子善女人。尽形寿自归作礼承事供养。天华天捣香天泽香天杂香天缯天盖天幡。云何拘翼。是善男子善女人其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。得福多

佛言。复置是三千天下七宝塔。拘翼。若三千大国土中萨和萨。皆使得人道。了了皆作人已。令人人作七宝塔。是辈人尽形寿供养。持诸伎乐诸华诸捣香诸泽香诸杂香若干百种香诸缯诸盖诸幡。复持天华天捣香天泽香天杂香天缯天盖天幡。如是等萨和萨。及三千大国土中萨和萨。悉起是七宝塔。皆是伎乐供养。云何拘翼。其功德福祐宁多不。释提桓因言。作是供养者。其福祐功德甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。得福多

释提桓因白佛言。如是天中天。极安隐般若波罗蜜。天中天。自归作礼承事供养。过去当来今现在佛天中天萨芸若。则为供养作礼承事自归。为悉供养至。佛言。置是三千大国土中七宝塔。复如一恒边沙佛国土。一一萨和萨悉起作七宝塔。皆供养一劫。复过一劫。皆持天华天捣香天泽香天杂香天缯天盖天幡。都卢天上天下诸伎乐持供养。如是拘翼。其福祐功德宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。得福多

佛语释提桓因。如是拘翼。不如是。善男子善女人。从法中得福极多。不可复计。不可复议。不可复称。不可复量。不可复极。何以故。从般若波罗蜜中。出怛萨阿竭阿罗呵三耶三佛萨芸若。如是拘翼。善男子善女人。书般若波罗蜜持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。如是拘翼。功德所致。福祐所致。及前世功德所致。佛福祐所致。佛言。百倍恒边沙佛国中萨和萨。皆起七宝塔。不在计中。千倍不在计中。百千倍不在计中。万亿倍不在计中。无数倍不在般若波罗蜜供养计中

尔时四万天人与释提桓因。共来大会。诸天人谓释提桓因言。尊者当取般若波罗蜜。当讽诵般若波罗蜜。佛语释提桓因。当学。拘翼。般若波罗蜜。当持经卷。当讽诵。何以故。阿须伦心中作是生念。欲与忉利天共斗。阿须伦即起兵上天。是时拘翼当诵念般若波罗蜜。阿须伦兵众即还去。释提桓因因白佛言。极大祝天中天。般若波罗蜜。极尊祝般若波罗蜜。无有辈祝般若波罗蜜

佛言。如是拘翼。极大祝般若波罗蜜。极尊祝般若波罗蜜。无有辈祝般若波罗蜜。拘翼。持是祝者。过去诸怛萨阿竭阿罗呵三耶三佛。皆从是祝自致作佛。甫当来诸怛萨阿竭阿罗呵三耶三佛。皆学是祝自致作佛。今现在十方诸佛。皆起是祝自致作佛。拘翼。是祝故出十诫功德。照明于天下。四禅四谛四神足般遮旬。照明于世间。菩萨摩诃萨从般若波罗蜜中。生十诫功德。世间悉遍至。四禅四谛四神。足般遮旬悉照明于世间。今怛萨阿竭阿罗呵三耶三佛。未出世间时。菩萨悉照明四禅四谛四神足般遮旬。譬如月盛满时。拘翼。从空中出照明于星宿。如是拘翼。菩萨行功德盛满亦如是。怛萨阿竭未出世间时。菩萨为出照明。菩萨摩诃萨皆从沤和拘舍罗般若波罗蜜中出。当作是知

复次拘翼。若有善男子善女人。持般若波罗蜜学诵者。为至德悉具足。释提桓因问佛言。天中天。何谓至德悉具足。佛言。其人终不中毒死。不于水中溺死。不为兵刃所中死。若时有县官起。若横为县官所侵。当诵念般若波罗蜜。若坐若经行时。县官终不能危害。何以故。般若波罗蜜所拥护故。若复有余事。悉当诵念般若波罗蜜。往至彼间若王所若太子傍臣所。便与共好语。与共谈言。与共笑欢喜。何以故。用学般若波罗蜜故。念善思善。一切人民蜎飞蠕动。悉令其善持等心。闵伤慈哀。用是故人见之悉起立。如是拘翼。若有索方便者。不能危害。尔时有异道人。遥见佛大会。稍稍前行欲坏乱坐。稍来至佛所。释提桓因作是念。当云何尽我寿常在佛边受诵般若波罗蜜。异道人欲乱我断是法。释提桓因从佛所闻般若波罗蜜即受诵。彼异道人即遥远远绕佛一匝。便从彼间道径去。舍利弗作是念。是中云何令异道人从彼间道径便去。舍利弗心所念佛即知。佛语舍利弗。释提桓因念般若波罗蜜。如是异道人便还去。异道人无有善意来。都卢持恶意来故。是弊魔便作是念。怛萨阿竭阿罗呵三耶三佛。与四部弟子共坐。欲天梵天及诸天人。悉复在其中会。无有异人。悉菩萨摩诃萨受决者会。当为人中之将自致成作佛。我当行欲坏乱之。弊魔乘一辕之车驾。四马稍稍前行至佛所。释提桓因作是念。弊魔乘四马之车来欲到佛所。是弊魔车马无异。非国王洴沙。四马车不类。亦非国王波斯匿。四马车不类。亦非释种。四马车不类。亦非堕舍利。四马车不类。是弊魔所作。昼夜弊魔常索佛便。常乱世间人。释提桓因常作是愿。我会当念般若波罗蜜。常念常持心讽诵究竟。释提桓因心中诵念般若波罗蜜。且欲究竟。弊魔便复道还去

忉利迦翼天人。持天华飞在空中立便散佛上。及散四面。言般若波罗蜜断绝甚久。阎浮利人乃得闻乃得见。便复持天华若干种。四面散佛上。佛言。其有行般若波罗蜜者。守般若波罗蜜者。亦不为魔及魔官属所得便。释提桓因白佛言。是辈人其福祐功德不小。闻般若波罗蜜者。何况乃学持诵念。学已持已诵已。取学如是用是法住。其人前世时见佛般若波罗蜜耳闻者。何况乃学持诵。学已持已诵已。行如中事如是法住具足。则为供养怛萨阿竭已。是人如是。何以故。萨芸若从是行般若波罗蜜。譬如天中天。欲得极大宝者。当从大海索之。欲得萨芸若珍宝成怛萨阿竭阿罗呵三耶三佛者。当从般若波罗蜜中索之。佛言。如是。从其中出怛萨阿竭阿罗呵三耶三佛萨芸若

阿难白佛言。无有说檀波罗蜜者。亦不说尸波罗蜜。亦不说羼提波罗蜜。亦不说惟逮波罗蜜。亦不说禅波罗蜜。亦无有说是名者。但共说般若波罗蜜者。何以故。天中天。佛语阿难。般若波罗蜜于五波罗蜜中最尊。云何阿难。不作布施。当何缘为檀波罗蜜萨芸若。不作戒。当何缘为尸波罗蜜。不作忍辱。当何缘为羼提波罗蜜。不作精进。当何缘为惟逮波罗蜜。不作一心。当何缘为禅波罗蜜。不作智慧。当何缘为般若波罗蜜萨芸若。阿难言。如是天中天。不行布施。不为檀波罗蜜萨芸若。不行戒。不为尸波罗蜜。不行忍辱。不为羼提波罗蜜。不行精进。不为惟逮波罗蜜。不行一心。不为禅波罗蜜。不行智慧。不为般若波罗蜜萨芸若。为非般若波罗蜜。佛言。如是阿难。般若波罗蜜于五波罗蜜中最尊。譬如极大地。种散其中同时俱出其生大株。如是阿难。般若波罗蜜者是地。五波罗蜜者是种。从其中生。萨芸若者从般若波罗蜜成。如是阿难。般若波罗蜜于五波罗蜜中。极大尊自在所教。释提桓因白佛言。怛萨阿竭阿罗呵三耶三佛所说。善男子善女人功德未竟。学般若波罗蜜者。持者诵者云何。佛语释提桓因。我不说行者功德未竟。我自说善男子善女人。书般若波罗蜜者。持经卷自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。我说是供养功德耳。释提桓因白佛言。我身自护视善男子善女人书般若波罗蜜者。持经卷自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。我护是供养功德耳。佛语释提桓因。善男子善女人。诵般若波罗蜜者。若干千天人到经师所听法不解。于法中诸天人适欲问法师。天神语之。用慈于法中故。其人即自了知诸天所不解者便自解。善男子善女人。所作功德悉自见知

复次拘翼。善男子善女人书般若波罗蜜。于四部弟子中说时。其心都卢无所难。若有形者。欲若试者。终不畏。何以故。般若波罗蜜所拥护故其所欲形试者便自去。佛云我了不见人当般若波罗蜜者。人亦不见般若波罗蜜。般若波罗蜜所厌伏。善男子善女人。无有敢轻者。心亦不恐。不怖惧。亦无所畏。善男子善女人。所作功德悉自了见。复次拘翼。是善男子善女人父母皆重。若沙门道人皆哀。若知识兄弟外家宗亲。皆尊贵敬爱之。或时说恶事者。持中正法为解之。是善男子善女人。所作功德悉自见之

复次拘翼。善男子善女人。书般若波罗蜜。持经卷者天上四天王。天上诸天人。索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟以去。忉利天上诸天人索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟已去。盐天上诸天人。索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟已去。善男子善女人。心当作是知。十方无央数佛国。诸天人。诸龙。阿须伦。诸阅叉鬼神。诸迦楼罗鬼神。诸甄陀罗鬼神。诸乾陀罗鬼神。诸摩睺勒鬼神。诸人诸非人。都卢赐来到是间。问讯法师听受般若波罗蜜。作礼绕竟各自去。皆赐功德无异。兜术陀天上诸天人。索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟以去尼摩罗提罗怜耨天上诸天人。索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟已去。波罗尼蜜和邪拔致天上诸天人。索佛道者往到彼所。问讯听受般若波罗蜜。作礼绕竟已去。梵天上诸天人索佛道者。梵迦夷天。梵弗还天。梵波[病-丙+盍]天。摩呵梵天卢天。波利陀天。[病-丙+盍]波摩那天。阿会亘修天。首呵天。波栗多修呵天。阿波摩修天。修干天。惟呵天。波栗惟呵天。阿波修天。惟于潘天。阿惟潘天。阿陀波天。须[帶/足]天。须[帶/足]只耨天。阿迦贰吒天等。天上诸天人。皆往到彼所。问讯听受般若波罗蜜。作礼绕竟已各自去。及诸阿迦贰吒天。尚悉来下在诸天辈中。何况拘翼。三千大国土诸欲天人。诸色天人。悉来问讯听受般若波罗蜜。作礼绕已毕竟各各自去

是彼善男子善女人。彼所止处。当完坚无有娆者。除其宿罪不请。余不能动。善男子善女人。其功德悉受得。是时诸天人来当知之。释提桓因言。云何天中天。善男子善女人。当作是了知。诸天人来到是间。听受般若波罗蜜。作礼承事。佛言。善男子善女人。当作是知。诸天人来受般若波罗蜜。作礼承事。何用知诸天人来时。或时善男子善女人。欢喜踊跃意喜时知诸天人来。以知当舍去。若天若龙若阅叉鬼神若甄陀罗鬼神来到彼间。复次拘翼。善男子善女人。闻鬼神香以为曾知善男子善女人。小鬼神当避起去。大鬼神来前。复次拘翼。善男子善女人。常当净洁身体。用净洁身体故。鬼神皆大欢喜。小天见大天来到避去。大尊天威神巍巍。其光重明稍稍安徐往。是天人至师经所入至经所已。善男子善女人则踊跃欢喜。所止处悉当净洁住。善男子善女人。病终不着身。所止处常安隐。未常有恶梦。梦中不见余。但见佛但见塔。但闻般若波罗蜜。但见诸弟子。但见极过度。但见佛坐。但见自然法轮。但见且欲成佛时。但见诸佛成得佛已。但见新自然法轮。但见若干菩萨。但见六波罗蜜种种解脱。但见当作佛。但见余佛国。但见了了佛尊法无有与等者。但见某方某国土怛萨阿竭阿罗呵三耶三佛。若干百弟子。若干千弟子。若干万弟子。怛萨阿竭阿罗呵三耶三佛。在其中说法

拘翼。善男子善女人。梦如是见已。安隐觉身体净洁且轻。不欲复思食。身自软美饱。拘翼。譬如比丘得禅。从禅觉软心不大思食。自软美饱。如是拘翼。善男子善女人。觉已不大思食。自想身软美饱。何以故。拘翼。鬼神不敢近气故。欲取佛者其功德悉自见。欲取佛者当学般若波罗蜜。当持当诵。正使不学不持不诵。善男子善女人。但书写持经卷。自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡

复次拘翼。或时阎浮利地上怛萨阿竭舍利。满其中施与。般若波罗蜜书已举施与。欲取何所。释提桓因言。宁取般若波罗蜜。何以故。我不敢不敬舍利。天中天。从中出舍利供养。般若波罗蜜中出舍利从中得供养。如我有时与诸天共于天上坐。持异特座。乃至自我座。敢有天人来至我所承事我。我未及至座所。我不坐上时。诸天人皆为我坐作礼绕竟已便去。是坐尊。释提桓因于是间坐受法。忉利天上诸天人为作礼。如是天中天。般若波罗蜜出怛萨阿竭阿罗呵三耶三佛舍利萨芸若之智慧从中出生身。用是故。天中天。两分之中取般若波罗蜜。除是阎浮利地上。满其中怛萨阿竭舍利正使天中天三千大国土满其中舍利为一分。般若波罗蜜经为二分。我从二分中取般若波罗蜜。何以故。从中出舍利供养所致。譬如负债人。天中天。与王相随出入。王甚敬重之。无有问者亦无所畏。何以故。在王边有威力故。天中天。从般若波罗蜜中出舍利。从中出供养。是经天中天如王。般若波罗蜜。譬如是王雄猛得供养。怛萨阿竭舍利从萨芸若中出生得供养。如是天中天。萨芸若怛萨阿竭阿罗呵三耶三佛从般若波罗蜜中出生。当作是知。两分中我取般若波罗蜜

般若波罗蜜受持者。譬如无价摩尼珠。天中天。有是宝无有与等者。若持有所著。所著处者。鬼神不得其便。不为鬼神所中害。若男子若女人。持摩尼珠着其身上。鬼神即走去。若中热。持摩尼珠着身上。其热即除去。若中风。持摩尼珠着身上。其风不增即除去。若中寒。持摩尼珠着身上。其寒不复增即除去。夜时持摩尼珠着冥中即时明。热时持摩尼珠。所著处即为凉。寒时持摩尼珠。所著处即为热。所至处毒皆不行。余他辈亦尔。中有为蛇所啮者。若男子若女人持摩尼珠示之。见摩尼珠毒即去。如是天中天。摩尼珠极尊。若有人病若目痛若目冥。持摩尼珠近眼。眼病即除愈。如是天中天。摩尼珠德巍巍自在。持着何所。着水中水便随作摩尼珠色。持缯裹着水中。水便如摩尼珠色。正使持若干种缯裹着水中。水便如摩尼珠色。水浊即为清。摩尼珠德无有比

阿难问释提桓因。云何拘翼。天上亦有摩尼珠。阎浮利地上亦有摩尼珠。释提桓因语阿难言。天上亦有摩尼珠。阎浮利地上亦有摩尼珠。不足言。如我所说。异阎浮利地上宝轻耳。不如彼珠德尊十倍百倍千倍万倍亿亿万倍。我所语摩尼珠者。有所著处。若箧中若函中。其光明倍彻出。正使举珠出去余处。续明如故。般若波罗蜜萨芸若之德。至怛萨阿竭阿罗呵三耶三佛般泥洹去。舍利供养如故。萨芸若舍利遍分布天下。供养如故

复次阿难。十方无央数佛国现在诸佛欲见者。善男子善女人当行般若波罗蜜。当守般若波罗蜜。佛语释提桓因。如是拘翼。过去时怛萨阿竭阿罗呵三耶三佛。皆从般若波罗蜜中出。为人中之将。自致成作佛。如是出生。甫当来怛萨阿竭阿罗呵三耶三佛。悉从般若波罗蜜中出。为人中之将。自致成作佛。复如十方无央数佛国今现在诸佛。亦从般若波罗蜜中出。为人中之将。自致成作佛。释提桓因白佛言。摩诃波罗蜜天中天。一切人民蜎飞蠕动之类心所念。怛萨阿竭阿罗呵三耶三佛。从般若波罗蜜悉了知。佛言。用是故菩萨摩诃萨。昼夜行般若波罗蜜

释提桓因言。但行般若波罗蜜。不行余波罗蜜耶。佛言。都卢六波罗蜜皆行。菩萨摩诃萨般若波罗蜜。于菩萨摩诃萨最尊。菩萨与布施。般若波罗蜜出上。持戒忍辱精进一心分布诸经教人。不及菩萨摩诃萨行般若波罗蜜也。拘翼。譬如阎浮利地上种种好树。若色种种各异。叶叶各异。华华各异。实实各异。种种枝棭其影无有异。其影如一影相类。如是拘翼。五波罗蜜从般若波罗蜜出。般若波罗蜜出萨芸若。种种展转相得无有异

释提桓因白佛言。极大尊德般若波罗蜜。天中天。不可计德般若波罗蜜。天中天。无有极与等者般若波罗蜜。天中天。若有书般若波罗蜜者。持经卷自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。若有书经与他人者。其福何所为多者。佛言。我故问。若拘翼自恣说。云何。若有怛萨阿竭舍利自供养。复分布与他人令供养。若复有舍利自供养。亦不分与他人。其福何所多者

释提桓因言。天中天。善男子善女人自供养舍利。复分布与他人。其福大多。佛言。如是拘翼。善男子善女人书般若波罗蜜。持经卷自归作礼承事供养。名华捣香泽香杂香缯彩华盖旗幡。复分布与他人。其福大多复次拘翼。法师所至到处辄说经法。其德其福甚大多大多

复次拘翼。阎浮利人若善男子善女人皆令持十戒。云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书若为读之。其福倍益多。复次拘翼。置四天下。诸小国土中国土千国土。二千国土三千大国土。如恒边沙佛国人。善男子善女人皆令持十戒。云何拘翼。其福宁多不

释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书若为读。其福倍益多

复次拘翼。阎浮利人。善男子善女人皆令行四禅四谛四神足。及行般遮旬。云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书若为读。其福倍益多

复次拘翼。置阎浮利四天下。小国土中国土千国土。二千国土三千大国土。如恒边沙佛国人。善男子善女人皆令行四禅四谛四神足。及行般遮旬。皆令成得。云何拘翼。其福宁转倍多不。释提桓因言。大甚多大甚多天中天

佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书若为读。其福转倍多。复次拘翼。持般若波罗蜜经卷。授与他人使书。若令学若自学。其福甚倍多

复次拘翼。若有人自学般若波罗蜜解中慧。其福甚倍多

释提桓因白佛言。天中天。云何学般若波罗蜜。学解中慧。其福甚倍多释提桓因白佛言。天中天。云何学般若波罗蜜解中慧。佛言。善男子善女人不晓学。何以故。有当来善男子善女人。欲得阿耨多罗三耶三菩阿惟三佛。喜乐学般若波罗蜜。反得恶知识教枝棭般若波罗蜜。释提桓因问佛言。何等为枝棭般若波罗蜜。佛言。甫当来世比丘。得般若波罗蜜欲学。恶知识反教学色无常行色无常。作是曹学行般若波罗蜜。痛痒思想生死识学无常行识无常。作是曹学行般若波罗蜜。拘翼。是为枝棭般若波罗蜜。佛言。行般若波罗蜜者。不坏色无常视。不坏痛痒思想生死识无常视。何以故。本无故。拘翼。般若波罗蜜当黠慧学。其福倍益多

复次拘翼。置阎浮利地上。三千大国土如恒边沙佛国人。若善男子善女人皆令得须陀洹道。云何拘翼。其福宁多不

释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书。若令学若为读。其福倍益多。何以故。须陀洹道皆从般若波罗蜜中出生故

复次拘翼。阎浮利人若善男子善女人。皆教令得斯陀含阿那含阿罗汉。皆令成就。云何拘翼。其福宁转倍多不。释提桓因言。甚多甚多天中天。佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书。若令学若为读。其福倍益多。何以故。萨芸若德成法德。一切从般若波罗蜜中学成佛。便出生须陀洹道斯陀含道阿那含道阿罗汉道辟支佛道

置阎浮利。拘翼。置三千大国土。如恒边沙佛国中人。若善男子善女人皆令得须陀洹道斯陀含道阿那含道阿罗汉道辟支佛道云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天

佛言。不如是。善男子善女人书般若波罗蜜者。持经卷与他人使书。若令学若为读。其福倍益多。何以故。皆从般若波罗蜜中学。得成萨芸若成法德。用是故。得佛出生须陀洹道斯陀含道阿那含道阿罗汉道辟支佛道。用是故其福转倍多

复次拘翼。阎浮利人都卢皆使行佛道。已信入佛道。学佛道心已生。若善男子善女人持般若波罗蜜经卷。与他人使书。若令学若为说。及至阿惟越致菩萨。书经卷授与之。其人当从是学。深入般若波罗蜜中学智惠般若波罗蜜。转增多守无有极智悉成就。得其福转倍多。置阎浮利。拘翼。三千大国土及如恒边沙佛国中人。皆行阿耨多罗三耶三菩。皆发意行佛道。若善男子善女人持般若波罗蜜经卷。与他人使书。若令学若为说。及至阿惟越致菩萨。书经卷授与。其人当从是学深入般若波罗蜜中学智慧般若波罗蜜。转增多守无有极智慧悉成就。得其福转倍多

复次拘翼。阎浮利人都卢皆行阿耨多罗三耶三菩。阿耨多罗三耶三菩者。皆发意求佛。若善男子善女人持般若波罗蜜经卷。与他人使书。为解说其中慧。教令学及至阿惟越致菩萨摩诃萨。持般若波罗蜜经卷。授与使入黠慧中。其福转倍多。置阎浮利三千大国土及至恒边沙佛国中人。皆行阿耨多罗三耶三菩。阿耨多罗三耶三菩者。皆发意求佛。若善男子善女人持般若波罗蜜经卷。与他人使书。令学入黠慧中者。若有阿惟越致菩萨摩诃萨。持般若波罗蜜经卷。为书授与使学入黠慧中。其福转倍多

复次拘翼。阎浮利人都卢皆令行阿惟越致菩萨阿耨多罗三耶三菩。若有善男子善女人。教入般若波罗蜜中。云何拘翼。其福宁多不。释提桓因言。甚多甚多天中天。佛言。从是辈中若有一菩萨出便作是言。我欲疾作佛正使欲疾作佛。若有人持般若波罗蜜经卷书授与者。其福转倍多

置阎浮利三千大国土乃至恒边沙佛国中人。都卢皆令行阿惟越致菩萨阿耨多罗三耶三菩。若有善男子善女人。教入般若波罗蜜中。云何拘翼。其福宁多不

释提桓因言。甚多甚多天中天。佛言。若有一菩萨从其中出便作是言。我欲疾作佛。正使欲疾作佛。若有人持般若波罗蜜经卷书授与者。其福转倍多

释提桓因白佛言。如是天中天。极安隐菩萨摩诃萨疾近佛般若波罗蜜。若教人若授与人。其福转倍多。何以故。天中天。佛言。其得般若波罗蜜。疾近佛者近佛座。须菩提语释提桓因言。善哉善哉拘翼当所为尊弟子。菩萨摩诃萨作是受。疾作佛所为作者。当如佛弟子从中出。是辈人不索佛道者。菩萨摩诃萨不当于其中学六波罗蜜不学是法不得作佛。随法学疾作阿耨多罗三耶三佛。在所问

道行般若经卷第二道行般若经卷第三

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜沤和拘舍罗劝助品第四

尔时弥勒菩萨谓须菩提。若有菩萨摩诃萨。劝助为福。出人布施持戒自守者上。其福转尊极上无过。菩萨摩诃萨劝助福德。须菩提谓弥勒菩萨。复有菩萨摩诃萨。于阿僧祇刹土诸佛所而作功德。一一刹土不可计佛。其般泥洹者。乃从本发意已来。自致阿耨多罗三耶三菩。成至阿惟三佛者。乃至无余泥洹界而般泥洹者。然后至于法尽。于是中所作功德。其功德度无极。及诸声闻作布施持戒自守为福。于有余功德自致无余。诸有般泥洹佛。于其中所作功德。至有净戒身三昧身智慧身已脱身脱慧所现身。佛法极大哀。不可计佛天中天所说法。于其法中复学诸所有功德。乃于诸般泥洹佛所作功德。都计之合之。劝助为尊。种种德中为极是上。其劝助者。是为劝助。劝助已持作阿耨多罗三耶三菩。以是为阿耨多罗三耶三菩。署是菩萨有德之人。持心能作是求阿耨多罗三耶三菩。乃至作是心欲有所得。弥勒菩萨语须菩提其不作是求。乃能有所得。其作思想者。以为无黠。生是意用思想悔还。用信悔还。但用无黠故还堕四颠倒。无常谓有常。苦谓有乐。空谓有实。无身谓有身。以故思想悔还。心悔还信悔还。菩萨不当作是念心有所求。于所求无处所。云何求阿耨多罗三耶三菩。弥勒菩萨谓须菩提。不当于新学菩萨摩诃萨前说是语。何以故。或亡所信。亡所乐。亡所喜。亡所行。便从是修。当为阿惟越致菩萨摩诃萨说之。若久在善师边者。当为是菩萨摩诃萨可说。闻者不恐不怖不畏。是菩萨摩诃萨能劝助为作萨芸若持心。作是劝助。心亦尽灭无所有无所见。何等心当作阿耨多罗三耶三菩者。当以何心作之。心无两对。心之自然乃能所作。释提桓因语须菩提。新学菩萨摩诃萨。闻是或恐或怖。若菩萨摩诃萨欲作功德者。当云何劝助其福德作阿耨多罗三耶三菩。须菩提语弥勒菩萨。当作护是菩萨摩诃萨。于诸佛所。破坏众恶。而断爱欲。等行如一。降伏魔事。弃捐重檐。是即自从所有勤苦。悉为已尽。其知已脱心。即从计从阿僧祇刹土诸佛般泥洹曰者。于其中所作功德福。于诸声闻中复作功德。都计之合之劝助为尊。种种德中无过劝助。其劝助者能为劝助。劝助已持作阿耨多罗三耶三菩。何所是菩萨摩诃萨想不悔还。心不悔还。信所不悔还。正使菩萨摩诃萨。持心作阿耨多罗三耶三菩。其心无所想者。是菩萨摩诃萨心得作阿耨多罗三耶三菩。正使心念自了知。是心则为是作。是为想悔还心悔还所信悔还。正使菩萨摩诃萨。持心了知。当作是。学。知尽无所有。知尽者当持何心。有所作当了知心。何所心法。于法有所作。如法者为随法已。于作真为是作。即非邪作。是菩萨摩诃萨所作。若有菩萨摩诃萨。于过去当来今现在佛所作功德。若诸声闻下至凡人。所作功德。若畜生闻法者。及诸天龙阅叉健陀罗阿须伦迦楼罗。甄陀罗摩睺勒。诸人若非人闻法者。发心所作功德。及初学菩萨道者。都计之合之。积累为上。其劝助者能为劝助。是以极尊。种种德中无过劝助。是故劝助。所当劝助能为劝助。持劝助福用作阿耨多罗三耶三菩。正使复知是为尽法。于法无所生所灭。无处所。持无所生法。得作阿耨多罗三耶三菩。是法不与法有反用作阿耨多罗三耶三菩故。是为无想不悔还。心亦不悔还。所信不悔还。作是无所求。众所不逮。是为阿耨多罗三耶三菩所作

若有菩萨摩诃萨。不谛晓了知作福德者。所以者何。于身恍忽于劝助福亦复恍忽。菩萨了知恍忽无所有。是故为菩萨摩诃萨般若波罗蜜。若于诸般泥洹佛所而作功德。持是功德欲作所求。其智自然。能为阿耨多罗三耶三菩。诸佛天中天所知不着想。过去已灭。亦无有想。而不作想。其作想者为非德。菩萨摩诃萨当学沤和拘舍罗。未得般若波罗蜜者不得入。已得般若波罗蜜乃得入。勿为身作识。用之有灭。以是故无有身。有德之人。有想便碍反欲苦住。怛萨阿竭阿罗诃三耶三佛。不乐作是德持用劝助。何以故。用不正故。视般泥洹佛而反有想。以是故。为碍所作功德。为不及逮。为反苦住。其不作想者。是怛萨阿竭阿罗呵三耶三佛之德。其作想者。譬若杂毒。何以故。若设美饭以毒着中。色大甚好而香。无不喜者。不知饭中有毒。愚闇之人食之欢喜饱满。食欲消时。久久大不便身。不知行德者。甚之为难。不晓将护。不晓诵读。不晓中事。不能解知。作是行德者。为如杂毒之食。佛语善男子善女人。过去当来今现在佛。持戒身三昧身智慧身已脱身脱慧所现身。及于声闻中所作功德。佛天中天所说。若复于辟支佛所。而作功德都劝助之。劝助已持是福德。作阿耨多罗三耶三菩。持所作为想。用是故。譬若杂毒。菩萨摩诃萨当作是学。何所过去当来今现在佛功德。当云何劝助作福。成得阿耨多罗三耶三菩。是菩萨随怛萨阿竭教者。是即为作知佛功德所生自然。及其相法所有。持是福作劝助因其劝助自致得阿耨多罗三耶三菩。菩萨摩诃萨作是施者无有过上。终不离怛萨阿竭阿罗呵三耶三佛。作是施者为不杂毒。怛萨阿竭阿罗呵三耶三佛所说皆至诚

复次菩萨摩诃萨当作是施。如净戒。如三昧。如智慧。如已脱。如脱慧所现身。无欲界。无色界。无欲无色界。亦无过去当来今现在。亦无所有。所作施亦复无所有。其作是施为已如法。法亦无所有。作是施者为成所施无有杂毒。其作异施者。为作反施。是菩萨摩诃萨所施以如法者。佛天中天所知是则为施。得作阿耨多罗三耶三菩。佛言。善哉善哉须菩提。所作为如佛。是则为菩萨摩诃萨所施。三千大千国土人。悉念慈哀护等心。无过菩萨摩诃萨上头所施。是即为极尊

复次须菩提。三千大千国土人。悉作阿耨多罗三耶三菩。便如恒边沙佛刹人。皆供养是菩萨。震越衣服饮食床卧具病瘦医药。如恒边沙劫供养。随其喜乐作是布施。云何须菩提。其福宁多不。须菩提言。甚多甚多天中天。佛言。劝助功德。福过其上不可计。须菩提白佛言。代劝助功德福者。如恒边沙佛刹不能悉受。佛语。善哉善哉须菩提。若有菩萨持般若波罗蜜者。所作施为过其本所布施。上已无能过劝助所施上。百倍千倍万倍亿倍巨亿万倍

尔时四王天上二万人悉以头面着佛足。皆白佛言。极大施天中天菩萨摩诃萨沤和拘舍罗乃作是施。其功德甚大尊。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。忉利天上诸天人。持天华名香捣香泽香杂香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已。皆白佛言。极大施天中天。菩萨摩诃萨沤和拘舍罗乃作是施。大德之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。炎天上诸天人。持天华名香捣香泽香杂香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已。皆白佛言。极大施天中天。菩萨摩诃萨沤和拘舍罗乃作是施。极大德之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。兜术天上诸天人。持天华名香捣香泽香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已。皆白佛言。极大施天中天。菩萨摩诃萨沤和拘舍罗乃作是施。极大德之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。尼摩罗提天上诸天人持天华名香捣香泽香杂香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已。皆白佛言。极大施天中天。菩萨摩诃萨沤和拘舍罗乃作是施。极大尊之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。波罗蜜尼和耶拔致天上诸天人。持天华名香捣香泽香杂香烧香天缯华盖幢幡伎乐持用供养娱乐佛。供养已。皆白佛言。极大施天中天。菩萨摩诃萨沤和拘舍罗乃作是施。极大尊之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。梵天。梵迦夷天。梵富楼天。梵波利产天。摩诃梵天。[病-丙+盍]天。波利陀天。[病-丙+盍]波摩那天阿会亘修天。首诃天。波利首诃天。诃波摩首诃天。首诃迦天。比伊潘罗天。阿比耶陀天。须陀施尼天。乃至阿迦贰吒天等诸天人。悉以头面着佛足。皆言。甚善天中天。菩萨摩诃萨学般若波罗蜜。极为大施之功德。何以故。是菩萨摩诃萨学般若波罗蜜。于中劝助故。佛语首陀卫诸天人。置三千大千国土中菩萨摩诃萨。乃如恒边沙佛刹人。悉作阿耨多罗三耶三菩。复有异恒边沙佛刹人。都共供养是辈菩萨摩诃萨。震越衣被饮食床卧具病瘦医药。供养如恒边沙劫。随所喜乐作是施与。若复过是者。不及菩萨摩诃萨劝助之所施。为过去当来今现在佛。净戒身。三昧身。智慧身。已脱身。脱慧所现身。及诸声闻在其中者所作功德。都共计之合之。不及劝助者。若劝助者。以是极尊无能过者。作是劝助。劝助已。持作阿耨多罗三耶三菩

须菩提白佛言。属天中天所说。都共计之合之。极尊无过劝助。悉代劝助。劝助已。菩萨摩诃萨从是中得何等。佛语须菩提。菩萨道德之人。常知过去当来今现在。法无所取。亦无所舍。亦无所知。亦无所得。其法者为无所生法。亦无有灭法。亦无所从生法。亦无所从灭。于法中了无有生者。法亦无所从有而灭。是者法之所法。我代劝助之。是为劝助。作是施者。疾得作阿耨多罗三耶三菩。是故须菩提。菩萨摩诃萨劝助为尊

复次须菩提。菩萨摩诃萨于过去当来今现在佛所。代作布施者劝助之。代持戒忍辱精进一心智慧而劝助之。代已脱者劝助之。代脱慧所现身劝助之。作是代劝助。其脱者是为布施。其脱者是为持戒。其脱者是为忍辱。其脱者是为精进。其脱者是为一心。其脱者是为智慧。其脱者是为脱慧。其脱者是为脱慧所现身。其脱者是为已脱。其脱者代其劝助。其脱者是为法。是故当来有如其脱者。今阿僧祇刹土诸佛天中天现在者。其脱者是即诸佛弟子。其脱者以过去诸佛弟子。其脱者今现在诸佛弟子。于是法中无著无缚无脱。如是法者。持作阿耨多罗三耶三菩。所施为从中无有能过者。无有能坏者。是者须菩提。菩萨摩诃萨。劝助之为尊。如恒边沙佛刹中菩萨。悉寿如恒边沙佛劫。恒边沙佛刹人。都悉供养诸菩萨摩诃萨。震越衣被饮食床卧具病瘦医药。乃至恒边沙劫。须菩提。皆持戒成忍辱。于精进而不懈。于禅悉得三昧。百倍千倍万倍亿倍若干巨亿万倍。不如劝助之功德。福最尊出其上

    摩诃般若波罗蜜道行经泥犁品第五

舍利弗白佛言。般若波罗蜜者多所成。天中天。因般若波罗蜜无不得字者。天中天。般若波罗蜜为极照明。天中天。般若波罗蜜为去冥。天中天。般若波罗蜜为无所著。天中天。般若波罗蜜为极尊。天中天。无目者。般若波罗蜜为作眼目。天中天。其迷惑者。般若波罗蜜悉授道路。天中天。萨芸若者。即般若波罗蜜是。天中天。般若波罗蜜者。是菩萨摩诃萨母。天中天。无所生无所灭。即般若波罗蜜是。天中天。具足三合十二法轮。为转是般若波罗蜜。天中天般若波罗蜜其困苦者悉安隐之。天中天。般若波罗蜜。于生死作护。天中天。般若波罗蜜。于一切法悉皆自然。菩萨摩诃萨当云何于般若波罗蜜中住。天中天。佛谓舍利弗。世多罗者。因般若波罗蜜住。其敬佛者。当自归般若波罗蜜。释提桓因心念。尊者舍利弗。何因发是问。即时释提桓因谓舍利弗。何因尊者乃作是问。舍利弗谓释提桓因。拘翼。般若波罗蜜者是菩萨护。因其劝助功德。福持作萨芸若。过菩萨之所作为。若布施持戒忍辱精进禅上。譬若如人从生而盲。若百人若千人若万人若千万人无有前导。欲有所至。若欲入城者。不知当如行。如是拘翼。五波罗蜜者。亦如盲无所见。离般若波罗蜜者。如是欲入萨芸若中。不知当如行。般若波罗蜜者。即五波罗蜜之护。悉与眼目。般若波罗蜜是护。令五波罗蜜各得名字

舍利弗白佛言。当云何守入般若波罗蜜中。佛语舍利弗。色者不见所入。痛痒思想生死识亦不见所入。视五阴亦不见所入。是为守般若波罗蜜。如是者天中天。以为守般若波罗蜜。作是守者为还何法。佛语舍利弗。无所守是为还法守为般若波罗蜜释提桓因白佛言。般若波罗蜜不还萨芸若者。亦不能得逮。若所问般若波罗蜜。不逮萨芸若。亦不能得还。亦不还守于生死亦无所还。当云何还。天中天。佛言。无所还故能为还。释提桓因言。少有及者。天中天。如般若波罗蜜。于诸法无所生无所灭。当所可住无所住。须菩提白佛言。菩萨或时作是念。便离般若波罗蜜。佛语须菩提。菩萨傥有所因。于所因便念般若波罗蜜。知般若波罗蜜。空无所有无近无远。是故为菩萨摩诃萨般若波罗蜜。须菩提白佛言。信般若波罗蜜。为信何法。佛语须菩提菩提。信般若波罗蜜者。为不信色。亦不信痛痒思想生死识有。不信须陀洹道。不信斯陀含阿那含阿罗汉辟支佛佛道。须菩提白佛言。摩诃波罗蜜者。天中天。即般若波罗蜜是。佛语须菩提云何知摩诃波罗蜜因般若波罗蜜是。须菩提言。于色无大无小。不以色为证。亦不为色作证。痛痒思想生死识。亦无大亦无小。于识不以为证。亦不为识作证。便于怛萨阿竭阿罗呵三耶三佛。致十种力。即不复为弱萨芸若者。无广无狭。何以故无广无狭萨芸若。知于般若波罗蜜无所行。所以者何。般若波罗蜜无所有。若人于中有所求。谓有所有。是即为大非。何以故。人无所生。般若波罗蜜与人俱皆自然。人恍忽故。般若波罗蜜俱不可计人亦不坏。般若波罗蜜亦如是。人如般若波罗蜜者。便得成至阿惟三佛。人亦有力故。怛萨阿竭现而有力。舍利弗白佛言。般若波罗蜜甚深甚深。天中天。若有菩萨摩诃萨。信深般若波罗蜜者。不说中短。亦不狐疑。其人何所来而生是间。为行菩萨道已来几闻解般若波罗蜜事。随教入中者。佛语舍利弗。从他方佛刹来生是间。是菩萨摩诃萨于他方供养佛已。从受问闻深般若波罗蜜故。以是复闻般若波罗蜜。自念言。我如见佛无异。须菩提白佛言。般若波罗蜜可得见闻不。佛言。不可得见闻。须菩提问佛。是菩萨随深般若波罗蜜者。行已来为几闻。佛语须菩提。是非一辈学。各各有行。若有已供养若干百佛若干千佛。悉见已。于其所皆行清净戒已。若有于众中。闻般若波罗蜜弃舍去。为不敬菩萨摩诃萨法。佛说深般若波罗蜜。其人亦弃舍去不欲闻之。何以故。是人前世时闻说深般若波罗蜜。用弃舍去故。亦不以身心。是皆无知罪之所致。用是罪故。若闻深般若波罗蜜。复止他人不令说之。止般若波罗蜜者。为止萨芸若。其止萨芸若者。为止过去当来今现在佛。用是断法罪故。死入大泥犁中。若干百千岁。若干亿千万岁。当更若干泥犁中具受诸毒痛不可言。其中寿尽转生他方摩诃泥犁中。其寿复尽展转复到他方摩诃泥犁中生。舍利弗白佛言。其罪为随五逆恶。佛谓舍利弗。其罪虽有所喻不可引譬。若讽诵说深般若波罗蜜时。其心疑于法者。亦不肯学。念是言。非怛萨阿竭所说。止他人言。莫得学是。为以自坏复坏他人。自饮毒已复饮他人毒。是辈人为以自亡失复亡失他人。自不晓知深般若波罗蜜。转复坏他人。是曹人者不当见之。舍利弗。不当与共坐起言语饮食。何以故。是曹之人诽谤法者。自在冥中复持他人着冥中。其人自饮毒杀身无异。断法之人所语有信。用其言者。其人所受罪俱等无有异。所以者何。用诽谤佛语故。诽谤般若波罗蜜者。为悉诽谤诸法已。舍利弗白佛言。愿闻诽谤法者。受形何等像类讫。不知其身大如。佛语舍利弗。是诽谤法人。傥闻说是事其人沸血便从面孔出。或恐便死。因是被大痛。其人闻之心便愁毒如自消尽。譬如断华着日中即为萎枯。舍利弗白佛言。愿为人故当说之令知其身受形。云何当为后世人作大明。其有闻者畏惧当自念。我不可诽谤断法如彼人。佛语舍利弗。是为示人之大明。已所因罪受其身甚大丑恶。极勤苦臭处诚不可说。其苦痛甚大如久剧。是善男子善女人闻是语自足已。不敢复诽谤。须菩提白佛言。善男子善女人常当护身口意。人但坐口所言乃致是罪。佛语须菩提。是愚痴之人于我法中作沙门。反诽谤般若波罗蜜言非道。止般若波罗蜜者。为止佛菩萨已。止佛菩萨者。为断过去当来今现在佛萨芸若已。断萨芸若者。为断法已。断法者为断比丘僧已。断比丘僧者。为受不可计阿僧祇之罪

须菩提问佛。若有断深般若波罗蜜者。天中天。为有几事。佛语须菩提。以为魔所中。是男子女人不信不乐。用是二事故。能断深般若波罗蜜。复次须菩提断般若波罗蜜者。复有四事。何谓为四随恶师所言。一不随顺学。二不承至法。三主行诽谤。四索人短自贡高。是为四事

须菩提白佛言。少有信般若波罗蜜者。天中天。不晓了是法故。佛语须菩提。如是如是。少有信般若波罗蜜者。不晓了是法故。须菩提言。云何深般若波罗蜜少有信者

佛语须菩提。色无著无缚无脱。何以故。色之自然故为色。痛痒思想生死识无著无缚无脱。何以故。识之自然故为识。过去色无著无缚无脱。何以故。过去色之自然色故。当来色无著无缚无脱。何以故。当来色之自然色。故今现在色无著无缚无脱。何以故。色之自然色故。过去痛痒思想生死识无著无缚无脱。何以故。过去识之自然故。当来识无著无缚无脱。何以故。当来识之自然故。今现在识无著无缚无脱。何以故。识之自然故。用是故。须菩提。般若波罗蜜甚深。少有信者

    摩诃般若波罗蜜道行经清净品第六

须菩提白佛言。般若波罗蜜少有晓者。将未狎习故。佛语须菩提。如是如是。般若波罗蜜少有晓者。用未狎习之所致何以故。须菩提。色清净道亦清净故。言色清净道亦清净。痛痒思想生死识亦清净故言道清净是故识亦清净道俱清净。复次须菩提。色清净萨芸若亦清净故。言萨芸若清净色亦清净。是故色清净萨芸若亦清净等无异。今不断前前不断后故无坏。以是故。前为不断故。言痛痒思想生死识清净萨芸若亦清净。是故萨芸若清净识亦清净。萨芸若清净识亦清净等无异。今不断前前不断后故无坏。以是故前为不断

舍利弗白佛言。清净者。天中天。为甚深。佛言甚清净。舍利弗言。清净为极明。天中天。佛言。甚清净。舍利弗言。清净无有垢。天中天。佛言。甚清净。舍利弗言。清净无有瑕秽。天中天。佛言。甚清净。舍利弗言。清净无所有。天中天。佛言。甚清净。舍利弗言。于欲而无欲清净。天中天。佛言。甚清净。舍利弗言。于色而无色清净。天中天。佛言。甚清净。舍利弗言。无所生为无色甚清净。天中天。佛言。甚清净。舍利弗言。于有智而无智甚清净。天中天佛言。甚清净。舍利弗言。于智如无智者甚清净。天中天。佛言。甚清净。舍利弗言。于色如有智无有智者甚清净。天中天。佛言。甚清净。舍利弗言。于痛痒思想生死识。如有智无有智者。甚清净。天中天。佛言。甚清净。舍利弗言。般若波罗蜜甚清净。萨芸若者不增不减。天中天。佛言。甚清净。舍利弗言。般若波罗蜜甚清净。于诸法无所取。天中天。佛言。甚清净

须菩提白佛言。我者清净色亦清净。天中天。佛言。本清净。须菩提言。故曰我清净痛痒思想生死识亦清净。天中天。佛言。本清净。须菩提言。我者清净道亦清净。天中天。佛言。本清净。须菩提言。我者清净萨芸若亦清净。天中天。佛言。本清净。须菩提言。我者清净无端绪。天中天佛言。本清净。须菩提言。我者清净无有边。色亦无有边。天中天。佛言。本清净。须菩提言。我者清净无有边。痛痒思想生死识亦无有边。天中天。佛言。本清净。须菩提言。般若波罗蜜者。亦不在彼。亦不在是。亦不在中间。天中天。佛言本清净。须菩提白佛言。菩萨摩诃萨知是者。为行般若波罗蜜。有想者便离般若波罗蜜远已。佛言。善哉善哉。须菩提。有字者便有想。以故着。须菩提白佛言。难及般若波罗蜜。天中天。安隐决于着。舍利弗问须菩提。何所为着。须菩提言。知色空者。是曰为着。知痛痒思想生死识空者。是曰为着。于过去法知过去法。是曰为着。于当来法知当来法。是曰为着。于现在法知现在法。是曰为着。如法者为大功德。发意菩萨是即为着释提桓因问须菩提。何谓为着。须菩提言。心知拘翼。持是知心施与作阿耨多罗三耶三菩。心者本清净。能可有所作。善男子善女人以离诸着为弃本际。佛言。善哉善哉。须菩提。令菩萨摩诃萨知本际为觉着事。复次须菩提。有着甚深微妙。我今说之。谛听谛听。上中下言悉善。须菩提白佛。愿乐欲闻。佛言。若善男子善女人于怛萨阿竭阿罗呵三耶三佛。念欲作想。随所想者。是故为着。过去当来今现在佛天中天。于无余法代劝助之。是为劝助阿耨多罗三耶三菩。于法者而无法故。曰无过去当来今现在。以是不可有所作。亦不可有想。亦不可作因缘。有不可见闻。如心可知。须菩提白佛言。其本甚深清净。天中天。佛言。本清净。须菩提言。今自归般若波罗蜜。佛言。法无作者故。得阿惟三佛。须菩提言。诸法实无作阿惟三佛者。佛语须菩提。无有两法。用之本净故曰为一。其净者于一切无有作者乃至无净。于一切亦无作者。佛语须菩提。是以离诸着为弃本际

须菩提白佛言。般若波罗蜜者难了。天中天。佛言。如是无有得阿惟三佛者。须菩提言。般若波罗蜜不可计。天中天。佛言。如是须菩提。非心之所知。须菩提言。为无作者。天中天。佛言。无有作者故无所著。须菩提问佛。菩萨当云何行般若波罗蜜。佛言。不想色行。为行般若波罗蜜。不想痛痒思想生死识行。为行般若波罗蜜。不满色行。为行般若波罗蜜。不满痛痒思想生死识行。为行般若波罗蜜。色不满为非色行。为行般若波罗蜜。痛痒思想生死识不满为非识行。为行般若波罗蜜。须菩提白佛言。难及天中天。于着无所著。是着实为不着。佛言。不着色行者。为行般若波罗蜜。不着痛痒思想生死识行者。为行般若波罗蜜。是为菩萨摩诃萨行于色为不着。于痛痒思想生死识为不着。于须陀洹斯陀含阿那含阿罗汉辟支佛佛道亦不着。所以者何。以过诸着故复出萨芸若中。是为般若波罗蜜须菩提白佛言。所说法甚深难逮。天中天。若所说者不减。不说者亦不减。若所说者不增。不说者亦不增。佛言。如是如是。须菩提。譬如怛萨阿竭。尽寿称誉空。空不增。若不称誉空。空亦不减。譬如称誉幻人者亦不增。若不称誉者亦不减闻善不喜。闻恶不怒。如是须菩提。于法各各讽诵学之。法亦不增不减。须菩提白佛言。菩萨摩诃萨甚谦苦行般若波罗蜜。若有守般若波罗蜜者。其不懈不恐不怖不动不还。何以故。守般若波罗蜜者。为守空故。一切皆当为菩萨摩诃萨作礼。用被僧那大铠故。与空共战。为一切人故。着僧那铠与空共斗是菩萨摩诃萨被极大铠。用一切人故而举空。是菩萨摩诃萨为大勇猛。天中天。用空法故。自致阿耨多罗三耶三菩。得成阿惟三佛。有异比丘心念之。当自归般若波罗蜜。为无所生法。亦为无所灭法。释提桓因语须菩提。菩萨随般若波罗蜜教者为随何教。须菩提言。为随空教。释提桓因言。何所为随空教者。须菩提言。其欲寂静者。是菩萨摩诃萨为知般若波罗蜜。释提桓因言。其学般若波罗蜜者。当护几何间。须菩提谓释提桓因。云何拘翼。能见法当所护者不。而言欲护之。释提桓因言不须菩提言。随般若波罗蜜教住者。是为以得护。若人若非人终不能得其便。须菩提言。若菩萨摩诃萨护空者。为随般若波罗蜜行已。云何拘翼。能可护响不。释提桓因言。不能。须菩提言。拘翼。菩萨摩诃萨行般若波罗蜜者其法亦如响以知是者亦复无想。以无想念为行般若波罗蜜。用佛威神。三千大千国土诸四天王诸释梵及诸尊天。一切皆来到佛所。前为佛作礼。绕竟三匝各住一面。诸四天王诸释梵及诸尊天。悉承佛威神念诸千佛。皆字释迦文。其比丘者皆字须菩提。问般若波罗蜜者。皆如释提桓因

道行般若经卷第三道行般若经卷第四

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜叹品第七

佛言。弥勒菩萨摩诃萨。作阿耨多罗三耶三菩阿惟三佛时。亦当于是处说般若波罗蜜。须菩提白佛言。云何弥勒菩萨摩诃萨。于是处说般若波罗蜜佛语须菩提。弥勒菩萨摩诃萨。于是成阿惟三佛时。不受色说般若波罗蜜。不空色说般若波罗蜜。不受痛痒思想生死识说般若波罗蜜亦不空识说般若波罗蜜。亦不脱色说般若波罗蜜。亦不缚色说般若波罗蜜。亦不脱痛痒思想生死识说般若波罗蜜。亦不缚识说般若波罗蜜。须菩提白佛言。般若波罗蜜甚清净。天中天。佛言。色亦清净。须菩提言。故般若波罗蜜清净。佛言。痛痒思想生死识亦清净。须菩提言。故般若波罗蜜清净。佛言如是空之清净。须菩提言故般若波罗蜜清净。佛言。色清净无瑕秽。般若波罗蜜亦如是。痛痒思想生死识清净无瑕秽。般若波罗蜜亦如是。佛言。如空无瑕秽故般若波罗蜜亦清净。须菩提白佛言。其受学诵般若波罗蜜者终不横死。若干百天若干千天常随侍之。若善男子善女人为法师者。月八日十四日十五日。说法时得功德不可复计。佛言。如是如是。须菩提。得其功德不可复计。若守般若波罗蜜者。其功德出是上去。何以故。须菩提。般若波罗蜜者。即是珍宝故。于法无有作者。亦无有得法者。亦无有持者。何以故法甚深故。亦不可见。亦不可得。亦无有得者。须菩提。亦不见般若波罗蜜。何以故。须菩提。亦不可名。亦无有见。得般若波罗蜜者。所索不可得。亦不见般若波罗蜜。甚深如是亦无有生处。般若波罗蜜无所行。亦无所不行。般若波罗蜜亦无有持法者。亦无有守法者。如空无所取无所持。无所见。亦不无观。亦不无见。三千大千刹土诸天子飞在上俱皆观。便举声共叹曰。于阎浮利地上再见法轮转。佛谓须菩提。无两法轮为转。亦不想有一法轮转。不转是者即般若波罗蜜。须菩提言。如是天中天。极安隐摩诃波罗蜜是。于菩萨摩诃萨无所挂碍法。阿耨多罗三耶三菩阿惟三佛。是无有法成阿惟三佛者。何所法轮。惟三佛见法为转。无所还法为转。亦无法有恐者。无有法而忧者。何以故。若有两法为不可得。何所法忧。亦无法转者。故诸法如空无所转。亦无法有还者。乃至诸法亦为无所有。佛语须菩提。空者无所转。亦无转还。亦无想。亦无愿。亦无生死。亦无所从生。亦不有转。亦不转还。作是说者。是为说法。无所说者。亦无所得。亦无有证。作是说。法亦不般泥洹。作是说。法亦无有尽

须菩提白佛言。无极波罗蜜如空无有极。天中天。一等波罗蜜者于诸法悉平等。天中天。二恍忽波罗蜜者为本空。天中天。三无上波罗蜜于诸法无所著。天中天。四无人波罗蜜无有身。天中天五无所去波罗蜜无所至。天中天。六无所有波罗蜜无所持。天中天。七无有尽波罗蜜无有极。天中天。八无所从生波罗蜜无所灭。天中天。九无作波罗蜜无有造者。天中天。十不知波罗蜜无所得。天中天。十一无所至波罗蜜无所到。天中天。十二无垢波罗蜜用净故。天中天。十三无著波罗蜜无所得。天中天。十四梦波罗蜜无有我。天中天。十五清净波罗蜜无瑕秽。天中天。十六不可见波罗蜜无有处。天中天十七定波罗蜜不动摇。天中天。十八无念波罗蜜悉平等。天中天。十九不动摇波罗蜜法不移。天中天。二十无欲波罗蜜本无故天中天。二十一无所生波罗蜜无所向。天中天。二十二寂波罗蜜无有想。天中天。二十三无恚波罗蜜无有恨。天中天。二十四无人波罗蜜本无故。天中天。二十五不观波罗蜜法无所从起。天中天。二十六不至边波罗蜜无所止。天中天。二十七不腐波罗蜜无有败天中天。二十八无不入波罗蜜诸罗汉辟支佛所不及。天中天。二十九不乱波罗蜜无有误。天中天。三十不可量波罗蜜无有小法。天中天。三十一无形波罗蜜于诸法无所挂碍。天中天。三十二不可得波罗蜜无所生。天中天。三十三无常波罗蜜不有坏。天中天。三十四无苦波罗蜜诸法不相侵。天中天。三十五无我波罗蜜于诸法无所求。天中天。三十六空波罗蜜于诸法不可得。天中天。三十七无有想波罗蜜于诸法无所出。天中天。三十八力波罗蜜于诸法为有胜。天中天。三十九不可计佛法波罗蜜于诸法出计去。天中天。四十自然波罗蜜。般若波罗蜜是天中天。四十一于诸法亦无自然故

    摩诃般若波罗蜜道行经持品第八

释提桓因作是念。其闻般若波罗蜜者。皆过去佛时人。何况学持讽诵。学持讽诵已如教住者。是人前世供养若干佛已。今复闻深般若波罗蜜。学持讽诵如教住。其人从过去佛时问事已。是善男子善女人为更见过去三耶三佛。从闻深般若波罗蜜。以不疑不恐不难不畏。舍利弗白佛言。菩萨摩诃萨信受深般若波罗蜜者。当视之如阿惟越致。何以故。天中天。般若波罗蜜甚深。本用精进信般若波罗蜜故。设有轻般若波罗蜜。其人前世时亦轻般若波罗蜜已。所以者何。用不信乐深般若波罗蜜。为不问佛及弟子之所致。以是故。当知之

释提桓因语尊者舍利弗。般若波罗蜜者为甚深难及。其有说深般若波罗蜜。若不信者。其人为未行菩萨道。反持作难。自归般若波罗蜜者。为自归萨芸若慧已。舍利弗语释提桓因。如是如是。拘翼归萨芸若慧者。以为自归般若波罗蜜。何以故。从是中出怛萨阿竭阿罗呵三耶三佛萨芸若。萨芸若慧者。是般若波罗蜜之所照明。于般若波罗蜜中住者无不解慧。释提桓因白佛言。菩萨摩诃萨萨芸若。云何行般若波罗蜜。云何于般若波罗蜜中住。云何解般若波罗蜜中慧。佛言。善哉善哉。拘翼。乃作是问。今发汝者皆佛威神之所致。若菩萨摩诃萨行般若波罗蜜者。不住色中。如色不住者即为行。于痛痒思想生死识中不住。如是识不住者即为行。于色中不究竟。如色不究竟者。尔故不于色中住。痛痒思想生死识不究竟。如识不究竟者。尔故不于识中住。舍利弗白佛言。般若波罗蜜者甚深。天中天。般若波罗蜜者。难得见边幅。天中天。佛语舍利弗。色亦甚深不住。如色甚深不住。如是色甚深不住者。是即为解痛痒思想生死识甚深不住。如识甚深不住。如是识甚深不住者。是即为解色亦甚深不随。如是色甚深不随。如是色甚深不住。如色甚深不住。是为色甚深不随。痛痒思想生死识甚深不随。如是识甚深不随。如是识甚深不住是识甚深不住。是为识甚深不随。舍利弗白佛言。般若波罗蜜甚深。天中天。当于阿惟越致菩萨前说之。闻是慧法不疑亦不痴之。释提桓因问舍利弗菩萨摩诃萨未受决者。于前说之。将有何等异。舍利弗言。是菩萨求佛已来大久远。为已受决。若未受决闻之便于中受决亦复不久。若见一佛若见两佛便受决。作阿耨多罗三耶三菩。菩萨摩诃萨未受决者。闻是恐畏即舍还去。佛语舍利弗。如是如是。菩萨摩诃萨求佛道以来大久远。若受决未受决者。皆闻深般若波罗蜜。舍利弗白佛言。我亦乐喜闻是语。天中天。乐人令得安隐。佛语舍利弗。若乐者于我前说之。舍利弗言。譬若是菩萨摩诃萨。天中天。自见于梦中坐佛座知今近阿耨多罗三耶三菩成至阿惟三佛。如是天中天。菩萨摩诃萨得闻深般若波罗蜜者。是菩萨摩诃萨学已来大久远。今受决不复久。其功德欲成满。菩萨摩诃萨当作是知。其得深般若波罗蜜者。其功德欲成满。佛言。善哉善哉。舍利弗。乃乐作是说。皆佛威神之所致。舍利弗白佛言。譬如男子行万里。天中天。若数万里者。到大空泽中。是人遥相见牧牛者若牧羊者。若见界。若见庐舍。若见丛树。作是想念。如见郡。如见县。如见聚落。若欲见闻作是想。稍稍前行且欲近之。不复畏盗贼。菩萨摩诃萨得深般若波罗蜜者亦如是。天中天。今受决不复久。亦不畏当堕阿罗汉辟支佛道地。何以故。上头有想以闻见得深般若波罗蜜。譬若男子欲见大海。天中天。便行之大海。若见树有树想。若见山有山想当知大海尚远。稍稍前行。不见树亦无树想。不见山亦无山想。心亦念知大海且至亦不久。于中道无复有树亦无树想。无复山亦无山想。是男子尚未见大海。是应且欲为至。是菩萨摩诃萨当作是知。天中天。若闻得深般若波罗蜜。虽不见佛从受决者。是为今作佛不久。若闻得深般若波罗蜜者。譬如若春时树。天中天。其叶稍稍欲生。如是不久当有华实。何以故。是树本之瑞应。想知不久当有叶若华实。阎浮利人者皆大欢喜。曾见是树。想知不久叶华实当成熟。如是天中天。菩萨摩诃萨得见深般若波罗蜜者。其功德欲成满。今于般若波罗蜜中自致成就。是菩萨摩诃萨当知之。过去世时学般若波罗蜜。其功德欲成满之所致。以是故。复得闻深般若波罗蜜。天上诸天无不代喜者。想见过去菩萨摩诃萨受决时。知是菩萨摩诃萨今复受决。不久作阿耨多罗三耶三菩。譬如女人有。娠。天中天。稍稍腹大身重。不如本故所作不便。饮食欲少。行步不能。稍稍有痛。语言软迟。卧起不安。其痛欲转。当知是妇人今产不久。菩萨摩诃萨亦如是。天中天。其功德欲成满。若得闻见深般若波罗蜜。其念行者。当知是菩萨摩诃萨今受决不久。得作阿耨多罗三耶三菩。佛言。善哉善哉。舍利弗。若所说者悉佛威神之所致。须菩提白佛言。难及也。天中天怛萨阿竭阿罗呵三耶三佛。悉豫了了署菩萨摩诃萨。佛语须菩提。菩萨摩诃萨昼夜念世间悉使得安隐。伤念天上天下。以是故。自致阿耨多罗三耶三菩。成作佛时悉为说法

须菩提白佛言。如是菩萨摩诃萨。天中天。行般若波罗蜜者。当云何行得成就。佛语须菩提。菩萨摩诃萨行般若波罗蜜者。不观色过。为行般若波罗蜜。不观痛痒思想生死识过。为行般若波罗蜜。不观色无过。为行般若波罗蜜。不观痛痒思想生死识无过。为行般若波罗蜜。不见是法。为行般若波罗蜜。亦不见非法。为行般若波罗蜜。须菩提白佛言。天中天。所说不可计。佛语须菩提。色亦不可计。痛痒思想生死识亦不可计。不知色者。是为行般若波罗蜜。不知痛痒思想生死识者。是为行般若波罗蜜。须菩提白佛言。谁当信是者天中天。是为菩萨摩诃萨行。佛谓须菩提。何所为行。正使菩萨摩诃萨行者为得字耳。是菩萨摩诃萨行般若波罗蜜者。于力无所近。于四事无所畏亦无所近。于佛法亦无所近。于萨芸若亦无所近。何以故。力者不可计。四事无所畏亦不可计。佛法亦不可计。萨芸若亦不可计。色亦不可计。痛痒思想生死识亦不可计。诸法亦不可计。心亦不可计。正使菩萨摩诃萨作是行者。为无所行。是为行般若波罗蜜。正使作是行者为得字耳

须菩提白佛言。般若波罗蜜者。甚深珍宝中王。天中天。般若波罗蜜者。大将中王。天中天。般若波罗蜜与空共斗无能胜者。天中天。从是中不得断。佛言。如是如是。须菩提。欲疾书是经者。至一岁乃至竟。何以故。是善男子于珍宝中。多有起因缘至使中断。须菩提言。于般若波罗蜜中。弊魔常使欲断。佛语须菩提。正使弊魔欲断是经者。会不能得胜菩萨摩诃萨。舍利弗问佛言。持谁威神恩。弊魔不能中。道断之佛告舍利弗。皆佛威神。及十方阿僧祇刹土现在诸佛。复假威神之恩。诸佛悉共念之。悉共授之。悉共护之。菩萨摩诃萨已为得护佛所授者。舍利弗。弊魔不能得中道断之。何以故。十方阿僧祇刹土现在诸佛。皆共护般若波罗蜜。若有念说诵者。若有学受书者。皆是诸佛威神之所致

舍利弗白佛言。菩萨摩诃萨若有念诵者。若持学书者。以为诸佛威神之所拥护。佛语舍利弗。皆是诸佛威神恩。是菩萨摩诃萨学般若波罗蜜者。当知之为护佛所护舍利弗言。若有学持诵般若波罗蜜者。佛以眼悉视之。佛语舍利弗。怛萨阿竭以佛眼视学持诵般若波罗蜜者。最后若书持经卷者。当知是辈悉为怛萨阿竭眼所见已。佛语舍利弗。菩萨至德之人。学受持是经者。是菩萨摩诃萨今近佛坐。为阿耨多罗三耶三菩。最后若有书持是经者。是辈人极尊得大功德。如是舍利弗。怛萨阿竭去后。是般若波罗蜜当在南天竺。其有学已。从南天竺当转至西天竺。其有学已。当从西天竺转至到北天竺。其有学者当学之。佛语舍利弗。却后经法且欲断绝时。我悉知持般若波罗蜜者。若最后有书者佛悉豫见其人称誉说之。舍利弗问佛。最后世时是般若波罗蜜。当到北天竺耶。佛言。当到北天竺。其在彼者当闻般若波罗蜜复行问之。当知是菩萨摩诃萨作衍已来大久远。以故复受般若波罗蜜。舍利弗言。北天竺当有几所菩萨摩诃萨学般若波罗蜜者。佛语舍利弗。北天竺亦甚多菩萨摩诃萨。少有学般若波罗蜜者。若有说者。闻之不恐不难不畏。是人前世时闻怛萨阿竭阿罗呵三耶三佛。以是菩萨至德之人持净戒完具。欲为一切人作本多所度脱。是辈人索佛道者我知。是善男子善女人今近萨芸若作是学者在所生处常学是法。便行阿耨多罗三耶三菩。是善男子善女人为极尊贵。魔终无那何。不能动还令舍阿耨多罗三耶三菩。是善男子善女人闻是波罗蜜者。以得极尊。劝乐摩诃衍功德。还近阿耨多罗三耶三菩。是善男子善女人虽不见我。后世得深般若波罗蜜者。为已面见佛。说是语无异。是为菩萨行。当所施行。其有若干百人若干千人。索阿耨多罗三耶三菩者。当共教之。当共劝乐之。当为说法皆令欢喜学佛道。佛语舍利弗。我劝助是善男子善女人。至德学菩萨道。有作是教者。心心展转相明。是善男子善女人有代劝助者。是辈欲行菩萨道者。若干百人若干千人。索阿耨多罗三耶三菩者。当共教之当共劝乐之。当令劝喜学佛道。是辈善男子善女人心中踊跃欢喜者。愿生他方佛刹。以生异方者。便面见佛说法。复闻波罗蜜。皆悉了了知之。复于彼刹教若干百千人。皆行佛道。舍利弗白佛言。难及也。天中天。以过去当来今现在法无所不了。悉知当来菩萨摩诃萨行令是辈不懈精进学入六波罗蜜中。佛言。是善男子善女人有行是法者。所求者必得。若所不求会复自得。是善男子善女人本愿之所致。不离是法。虽不有所索者。自得六波罗蜜

舍利弗问佛。从是波罗蜜中可出经卷耶。佛语舍利弗。是善男子善女人深入般若波罗蜜者。于是中自解出一一深法以为经卷。何以故。舍利弗。其有如阿耨多罗三耶三菩教者。便能教一切人。劝助之为说法。皆令欢喜学佛道。是善男子善女人自复学是法。用是故。所生处转得六波罗蜜

    摩诃般若波罗蜜道行经觉品第九(丹觉魔品)

须菩提问佛言。善男子善女人于学中当有效验。天中天。当何以觉其难。佛语须菩提。心不乐喜者当觉知魔为。菩萨摩诃萨心卒妄起者觉知魔为。菩萨摩诃萨书是经时若有雷电畏怖。当觉知魔为菩萨摩诃萨书是经时展转调戏。当觉知魔为。菩萨摩诃萨书是经时展转相形。当觉知魔为。菩萨摩诃萨书是经时左右顾视。当觉知魔为。菩萨摩诃萨书是经时心邪念不一。当觉知魔为。菩萨摩诃萨心不在经上数从坐起。当觉知魔为。菩萨摩诃萨自念。我未受决在般若波罗蜜中。心乱便起去。当觉知魔为。菩萨摩诃萨自念。我字不在般若波罗蜜中。心不喜乐。当觉知魔为。菩萨摩诃萨自念。我乡里郡国县邑不闻般若波罗蜜。及所生处了不闻是。其意欲悔便即舍去。其人却后当复更劫数乃有所得。甫当于若干劫中喜学余经。不住萨芸若。弃舍深般若波罗蜜去。若学余经者。为以舍本取其末。有学般若波罗蜜者。亦知俗法。复知道法。譬若狗子从大家得食。不肯食之反从作务者索食。如是须菩提。当来有菩萨弃深般若波罗蜜。反索枝掖般若波罗蜜。为随异经术。便堕声闻辟支佛道地。譬若男子得象观其脚。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。是菩萨有德之人。为二辈中。有弃深般若波罗蜜去。反修学余经。得阿罗汉辟支佛道。于须菩提意云何。是菩萨为黠不。须菩提言。为不黠。佛言。如是当觉知魔为。佛语须菩提。譬若男子欲见大海者。常未见大海。若见大陂池水。便言是水将无是大海。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。如是菩萨有德之人。弃般若波罗蜜去。反学余经。堕声闻辟支佛道地。于须菩提意云何。是菩萨摩诃萨为黠不。须菩提言。为不黠。佛言。是菩萨摩诃萨当觉知魔为。譬若绝工之师能作殿舍。意欲揆作如日月宫殿令高无不见者。于须菩提意。乃能作不。须菩提言。日月宫殿甚高终不能作。佛言。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。如是须菩提。当来行菩萨道者。得闻深般若波罗蜜。不可意便弃舍去。反明声闻辟支佛法。于中求萨芸若。于须菩提意云何。是菩萨为黠不。须菩提言。为不黠。佛言。是菩萨摩诃萨当觉知魔为。譬若男子欲见遮迦越罗者。未见遮迦越罗反见小王。想其形容被服谛熟观之。便呼言是为遮迦越罗。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。如是须菩提。甫当来有菩萨得闻深般若波罗蜜。反不可意便弃去。入声闻法中欲求萨芸若。于须菩提意云何。是菩萨为黠不。须菩提言。为不黠。佛言。是菩萨摩诃萨当觉知魔为。譬若男子大饥。得百味之食不肯食之。更食六十味之食。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。如是须菩提。甫当来有菩萨摩诃萨得闻深般若波罗蜜。而不可意便弃舍去入声闻法中。求萨芸若欲得作佛。于须菩提意云何。是菩萨摩诃萨为黠不。须菩提言。为不黠。佛言。是菩萨摩诃萨当觉知魔为。譬如男子得无价摩尼珠。持水精比之欲令合同。于须菩提意云何。是男子为黠不。须菩提言。为不黠。佛言。如是甫当来有行菩萨道者。得闻深般若波罗蜜。反持比声闻法。于声闻法中欲得萨芸若作佛。于须菩提意云何。是菩萨摩诃萨为黠不。须菩提言。为不黠。佛言。是菩萨摩诃萨当觉知魔为

复次须菩提。书般若波罗蜜时。若有财利起闻是言便弃舍去。是菩萨摩诃萨为自作留难。须菩提问佛。如是得书成般若波罗蜜不。佛言。不能得书成之。是善男子当觉知魔为。佛言。须菩提。若善男子多少书是经者。其言我书般若波罗蜜。于是中想闻其决欲有所得。常觉知魔为。其作想求者为堕魔界

复次须菩提。书般若波罗蜜时。意念乡里。若念异方。若念异国。若念王者。若念有贼。若念兵。若念斗。意念父母兄弟姊妹亲属。复有余念。魔复益其念。乱菩萨摩诃萨意为作留难。当觉知魔为。复次须菩提。若有财利。震越衣服饮食床卧具病瘦医药悉具足来。闻菩萨耳令意乱。不得学诵书成般若波罗蜜。当觉知魔为。复次须菩提。有佛深法魔从次行乱之。令菩萨摩诃萨不复乐欲得沤和拘舍罗。便不可意问般若波罗蜜。佛言。我广说菩萨摩诃萨事。其欲学沤和拘舍罗者。当从般若波罗蜜索之。其不可般若波罗蜜便弃舍去。为反于声闻道中索沤和拘舍罗。于须菩提意云何。是菩萨为黠不。须菩提言。为不黠。佛言。如是菩萨摩诃萨当觉知魔为

复次须菩提。若受经之人欲闻般若波罗蜜法师身得不安。如是菩萨摩诃萨当觉知魔为。复次须菩提。法师适安欲与般若波罗蜜。其受经者欲复转去。两不和合亦不得书成般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。学经之人来欲受般若波罗蜜其心欢悦。法师欲至他方。如是两不和合不得学书成般若波罗蜜。如是菩萨摩诃萨当觉知魔为

复次须菩提。法师意欲有所得。若衣服财利。受经之人亦无与心。两不和合不得学成般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。受经之人无所爱惜。在所索者不逆其意。法师所有经卷。而不肯现亦不顺解。其受经者便不欢乐。两不和合不得学书成般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。法师适欲有所说。其受经之人不欲闻知。如是两不和合亦不得闻般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。法师若身疲极卧欲不起。不乐有所说。受经之人欲得闻般若波罗蜜。如是两不和合不得闻般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。若欲书般若波罗蜜若欲说时。于众中傥有来者反说诽谤。用是为学多负勤苦。言泥犁禽兽薜荔甚大勤苦。语人言。当早断生死根。如是者菩萨摩诃萨当觉知魔为

复次须菩提。若欲书般若波罗蜜若欲说时。其有来人坐于众中。称誉天上快乐五所欲悉可自恣。其作禅者可得在色天中。念空寂者可得在无色之天。是皆无常勤苦之法。不如于是索须陀洹道斯陀含阿那含阿罗汉道。便不复与生死从事。如是须菩提。菩萨摩诃萨当觉知魔为。复次须菩提。法师念我是尊贵。有来恭敬自归者。我与般若波罗蜜。若有不恭敬自归者。我不与之。受经之人自归作礼恭敬不避处难。法师意悔不欲与弟子经。闻异国中谷贵。语受经人言。善男子知不。能与我俱至彼间不。谛自念之莫得后悔。弟子闻其所言甚大愁毒。即自念言。我悉见经已不肯与我。当奈之何。如是两不和合。不得学书成般若波罗蜜。如是须菩提。菩萨摩诃萨当觉知魔为。复次须菩提。法师欲到极剧之处。语受经人言。善男子能知不。其处无谷有虎狼多贼。五空泽我乐往至彼间谛自思议。能随我忍是勤苦不。复以深好语与共语。弟子悉当厌已心不复乐稍稍赐还。如是须菩提。乃作是碍不得学般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。法师健行乞匈。多有方略。殊不肯与弟子经。反欲懈堕舍去。便语受经人言。善男子知不。我当有所至。则有所问言。如是两不和合不得学书成般若波罗蜜。如是菩萨摩诃萨当觉知魔为。复次须菩提。弊魔常索其方便。不欲令有学诵受般若波罗蜜者。须菩提问佛。弊魔何因常索其方便。不欲令有学诵受般若波罗蜜者。佛语须菩提。弊魔主行诽谤。是非波罗蜜言。我有一一深经。快不可言。是故为波罗蜜。如是须菩提。弊魔主行诽谤之。令新学菩萨辈心为狐疑。便不复学诵书是经。菩萨摩诃萨当觉知魔为。复次须菩提。魔事一起时。令深学菩萨为本际作证。便堕声闻中得须陀洹道。如是菩萨摩诃萨当觉知魔为

道行般若经卷第四道行般若经卷第五

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜照明品第十

佛言。于般若波罗蜜中。多有起魔因缘者至使得断。须菩提白佛言。如天中天所说。若有菩萨多有危害。所以者何。用极大尊为难得故至使有害。般若波罗蜜亦如是。天中天。多有起因缘者。及新学发意者所知甚少。其心不入大法。亦不讽诵般若波罗蜜。是人以为魔所得。佛语须菩提。如若所言。新发意者所知甚少。其心不入大法。亦不讽诵般若波罗蜜。是为魔所得已。自起魔因缘至使得断。若善男子善女人取持学般若波罗蜜讽诵读者。悉是佛威神。何以故。弊魔不能制令得断。是者以为怛萨阿竭阿罗呵三耶三佛之所制持。譬若母人一一生子。从数至于十人其子尚小。母而得病不能制护无有视者。若母安隐无他。便自养长其子令得生活。寒温燥湿将护视之。是者即世间之示现。如是须菩提。怛萨阿竭阿罗呵三耶三佛。念般若波罗蜜。其所持者。若有讽诵书者。复十方现在诸佛。常念般若波罗蜜。是者即。怛萨阿竭阿罗呵三耶三佛。于萨芸若而示现。怛萨阿竭阿罗呵三耶三佛者。从是中自致得萨芸若。其有以成佛者。若未成佛。甫当成佛。皆从般若波罗蜜。自致成阿惟三佛怛萨阿竭阿罗呵三耶三佛是萨芸若慧之所致照明。皆从般若波罗蜜。以是故示现世间。须菩提白佛言。怛萨阿竭阿罗呵三耶三佛。于般若波罗蜜中。照明于世间。何谓般若波罗蜜照明于世间。何所是怛萨阿竭持于世间。佛语须菩提。怛萨阿竭持五阴示现世间。须菩提言。云何于般若波罗蜜示现五阴。何所是般若波罗蜜示现于五阴者。佛语须菩提。无所坏者以是故得示现。亦无无坏而示现空者无坏亦无有坏。亦无想亦无愿。亦无坏亦无有坏。以是故示现于世间

佛语须菩提。及不可计人不可计心。怛萨阿竭悉晓知。皆是自然人。如是自然人。如是须菩提怛萨阿竭以般若波罗蜜晓知不可计人不可计心。怛萨阿竭以般若波罗蜜。示现持世间。复次须菩提。若疾心乱心。怛萨阿竭悉知之。何谓怛萨阿竭悉知之疾心乱心。其法本者无疾无乱。以是故知之。何谓知疾知乱。其有当尽者以尽。以是故知之。其有爱欲心者。知是为爱欲心。其有嗔恚心者。知是为嗔恚心。其有愚痴心者。知是为愚痴心。知爱欲心之本无爱欲心知嗔恚心之本无嗔恚心知愚痴心之本无愚痴心。是者须菩提。令我得萨芸若者般若波罗蜜。何以故。怛萨阿竭无爱欲心。用无爱欲心。悉知其心之本。亦无爱欲心。以是故。怛萨阿竭心无有爱欲。何以故。怛萨阿竭无嗔恚心。用无嗔恚心。悉知其心之本。亦无嗔恚心。以是故。怛萨阿竭心无有嗔恚。何以故。怛萨阿竭无愚痴心。用无愚痴心。悉知其心之本。亦无愚痴心。以是故。怛萨阿竭心无有愚痴。如是须菩提。怛萨阿竭阿罗呵三耶三佛因般若波罗蜜示现持世间

复次须菩提。怛萨阿竭用人故因般若波罗蜜其心广大无所不知。何谓怛萨阿竭用人故因般若波罗蜜其心广大无所不知。其心者亦无广亦无大。亦无去亦无所至来。以是故。怛萨阿竭用人故因般若波罗蜜其心广大无所不知。复次须菩提。怛萨阿竭用人故因般若波罗蜜广大其心无所不知。何谓怛萨阿竭用人故因般若波罗蜜广大其心无所不知。其心者无所从来亦无所住。如是须菩提。怛萨阿竭用人故因般若波罗蜜广大其心无所不知

复次须菩提。怛萨阿竭用不可计人不可计心故。因般若波罗蜜无所不知。何谓怛萨阿竭用不可计人不可计心故因般若波罗蜜无所不知。其心者无所住亦无所从来灭。以无余故无所不知。其心若空故知不可计人不可计心悉知。如是须菩提。怛萨阿竭以般若波罗蜜知不可计人不可计心悉知。复次须菩提。怛萨阿竭用人故因般若波罗蜜知不可见心悉知。何谓怛萨阿竭用人故因般若波罗蜜知不可见心悉知。其心者本净故亦无有想。如是须菩提。怛萨阿竭用人故因般若波罗蜜知不可见心悉知。复次须菩提。怛萨阿竭用人故因般若波罗蜜知不可见心悉知。何谓怛萨阿竭用人故因般若波罗蜜知不可见心悉知。其心者不可以眼见如所从来。如是须菩提。怛萨阿竭用人故因般若波罗蜜知不可见心悉知

复次须菩提。怛萨阿竭用人故因般若波罗蜜。知欲得是者致是悉知。何谓怛萨阿竭用人故因般若波罗蜜知欲得是者致是。知一切色从不可得获而生生。痛痒思想生死识亦不可得获而生生。如是须菩提。怛萨阿竭云何知欲得是者因致是。从死至死是即为色。从死至不死。是亦为色。从不死至不死。是亦为色。亦不有死亦不无死。是亦为色。痛痒思想生死识从死至死。是亦为色。识者从死至不死。是亦为色。识者从不死至不死。是亦为色。识者亦不有死亦不无死。是亦为色。识有人无我世者。是亦为色。无人有我世者。是亦为色。有望无望无我世者。是亦为色。亦不有望亦不无望亦无我世。是亦为色。有望有我有世痛痒思想生死识。是亦为色。无望无我无世无识。是亦为色。亦不无望亦不有望亦无我识。是亦为色。得我世与无世。是亦为色。我世不可极。是亦为色。我世有极无极。是亦为色。我与世亦不有极亦不无极。是亦为色。痛痒思想生死识亦尔。我与世识亦不可极。是亦为色。我与世识有极无极。是亦为色。我与世识亦不有极亦不无极。是亦为色是命是身。是亦为色。非命非身。是亦为色。痛痒思想生死识亦尔。如是须菩提。怛萨阿竭知欲得是者因致是。何谓怛萨阿竭知欲得是者因致是。怛萨阿竭知色之本无。如知色本无。痛痒思想生死识亦尔。何谓知识。知识之本无。何所是本无。是欲有所得者。是亦本无。怛萨阿竭亦本无因慧如住。何谓所本无。世间亦是本无。何所是本无者。一切诸法亦本无。如诸法本无。须陀洹道亦本无。斯陀含道亦本无。阿那含道亦本无。阿罗汉道辟支佛道亦本无。怛萨阿竭亦复本无。一本无无有异。无所不入。悉知一切。是者须菩提。般若波罗蜜即是本无。怛萨阿竭因般若波罗蜜。自致成阿耨多罗三耶三佛。照明持世间。是为示现。怛萨阿竭因般若波罗蜜。悉知世间本无无有异。如是须菩提。怛萨阿竭悉知本无。尔故号字为佛。须菩提白佛言。本无甚深。天中天。是佛菩萨事悉自晓了。谁当信是者。独有得阿罗汉道者。若阿惟越致。怛萨阿竭成阿惟三佛乃能说之。佛语须菩提。本无无有尽时。怛萨阿竭所说亦无有极尽。时释提桓因与诸欲万天子俱。梵迦夷天与二万天子俱前至佛所。头面着佛足却住一面。诸欲梵天子俱白佛言。天中天所说法者甚深。云何作其相。佛语诸天子言。且听作相着已。无想无愿无生死所生。无所有无所住。是者作其相。其相者若如空住。怛萨阿竭阿罗呵三耶三佛所住相。诸天阿须伦龙鬼神不能动移。何以故。是相不可以手作。色者不能作相。痛痒思想生死识亦不作相。是相若人若非人所不能作。佛语诸天子言。若说是空有作者宁能信不。诸天子白佛言。不信有作空者。何以故。无有能作空者。佛言。如是诸天子。其相者常住。有佛无佛相住如故。如是住者故。怛萨阿竭成阿惟三佛故。名怛萨阿竭即是本无如来。诸天子白佛言。是相者甚深。怛萨阿竭从是成阿惟三佛。其怛萨阿竭所知。无所挂碍慧皆从般若波罗蜜。是者即佛之藏。佛语须菩提。怛萨阿竭因般若波罗蜜示现持世间。如是须菩提怛萨阿竭恭敬承事是法自致得成。皆从般若波罗蜜。是故怛萨阿竭之所恭敬。因是得佛故。是为报恩。何谓是怛萨阿竭之所报恩者。怛萨阿竭为从是衍得阿耨多罗三耶三菩。成阿惟三佛。皆从是衍为无所著。以是故现于报恩

复次须菩提。怛萨阿竭知识法无有作者。以是故得阿惟三佛。亦不无作故成阿惟三佛。是为怛萨阿竭报恩故示现般若波罗蜜。怛萨阿竭阿罗呵三耶三佛。于诸法无所望。皆从般若波罗蜜。以是故示现持世间。须菩提白佛言。诸法不可知不可见。何谓般若波罗蜜出怛萨阿竭示现持世间。佛语须菩提。所说诸法不可知不可见者。谓诸法悉空。以是故不可知。诸法不可获持。以是故不可得见。诸法不可知不可见者。皆从般若波罗蜜。如是须菩提。诸法不可知不可见。为从般若波罗蜜出怛萨阿竭成阿惟三佛。示现持世间故。色为不可见。痛痒思想生死识亦不可见。是者般若波罗蜜示现持世间

须菩提言。何谓天中天。色不可见。何谓痛痒思想生死识为不可见。佛言。不见色因缘生识。是故色为不可见。亦不痛痒思想生死识因缘生识。是故识为不可见。如色痛痒思想生死识不见。是世间亦不见其相者。亦不见是世间示现所有皆从般若波罗蜜。何谓是般若波罗蜜示现持世间。其忧世间是亦为空。其忧世间是亦为恍忽。其忧世间是亦为寂。其忧世间是亦为净。是者即为世间示现

    摩诃般若波罗蜜道行经不可计品第十一

须菩提白佛言。极大究竟般若波罗蜜。不可计究竟。不可量究竟。无有与等者究竟。无有边究竟。佛言。极大究竟般若波罗蜜。不可计究竟。不可量究竟。无有与等者究竟。无有边究竟。安隐般若波罗蜜。不可计究竟。怛萨阿竭无师萨芸若。是故般若波罗蜜不可计究竟。何等般若波罗蜜不可量究竟。不可量怛萨阿竭无师萨芸若不可议不可称。是故般若波罗蜜不可量究竟。何等般若波罗蜜安隐究竟无有与等者。怛萨阿竭谁能过者。是故般若波罗蜜无有与等者究竟。何等般若波罗蜜无有边究竟。无有边怛萨阿竭无师萨芸若。是故般若波罗蜜无有边究竟

须菩提白佛言云何怛萨阿竭无师萨芸若不可计不可量无边。佛言。色痛痒思想生死识不可计。诸法亦不可计。诸法了无所法。正是中不可计。色痛痒思想生死识不可思。诸法亦不可量。色痛痒思想生死识无有边。诸法亦无有边色痛痒思想生死识边幅了不可得。诸法边幅了不可得。用何等故。色痛痒思想生死识无有边幅。诸法无有边幅。色痛痒思想生死识边幅了不可得无有尽处。诸法边幅了不可得无有尽处。用何等故。色痛痒思想生死识诸法了不可得。边幅无有尽处时云何。佛言。空处可计尽不耶。须菩提言。空不可计尽。佛言。诸法不可计不可称无有边幅用是故。怛萨阿竭法如是比。不可计不可称无有边。怛萨阿竭发心起学。不可计不可称无有边。本无心无念。譬如空无心无念。有心有念因随是生死无有边。怛萨阿竭法如空无有边。是法如空不可计。作是说不可计不可称无有边。佛说是经时五百比丘僧三十比丘尼。皆得阿罗汉。六十优婆塞三十优婆夷。皆得须陀洹道。三十菩萨皆逮得无所从生法乐。皆当于是婆罗劫中受决

须菩提白佛言。般若波罗蜜甚深极大安隐究竟。佛言。般若波罗蜜甚深极大安隐究竟。萨芸若须陀洹斯陀含阿那含阿罗汉辟支佛道。悉从是经出。譬如遮迦越王。所当为者。一切傍臣所有郡国人民皆属王。亦无所复忧。阿罗汉辟支佛佛若诸法。皆从般若波罗蜜中出。皆是经所立。佛言。色痛痒思想生死识。不受不入。须陀洹斯陀含阿那含阿罗汉辟支佛萨芸若道。不受不入。须菩提问佛言。何等萨芸若不受。何等萨芸若不入。佛言。云何须菩提见若罗汉所入处不。须菩提言。不见天中天。不见是法我所入处。佛言善哉。须菩提。我亦不见怛萨阿竭所入处。如我怛萨阿竭无所入。萨芸若无所入处。爱欲天子梵天子俱白佛言。天中天。般若波罗蜜甚深难了。过去佛时所作功德。是辈人于是间闻深般若波罗蜜信者。正使三千大千国土人。一切所当为者皆信。皆信已来行过一劫。于是深般若波罗蜜中乐一日念。无量深出彼德有余。佛语爱欲天子梵天子。正使复有人闻深般若波罗蜜。以得证决所信乐过一劫。其功德不及是辈。爱欲天子梵天子。皆前以头面着佛足。绕三匝而去。却行久远乃旋各归天上。歌叹佛说功德

须菩提白佛言。若有菩萨信深般若波罗蜜者。从何所来而生是间。佛言。如是信者心无有疑。不厌不喜乐闻念不欲远离经师。譬如新生犊子心终不远离其母。是菩萨从人道中来生是间。前世学人今来复得深般若波罗蜜。便信乐不远离也

须菩提白佛言。若有菩萨有时还其功德。若复从他方佛刹来。若供养佛。乃有从彼来生是间者无。佛言有。是辈菩萨于他方佛刹供养佛。复从彼来生是间。持是功德于是间便逮得深般若波罗蜜。若复有菩萨从兜术天上来生是间。或从弥勒菩萨闻是深经中慧。今来生是间。持是功德今逮得深般若波罗蜜。若复有菩萨前世佛时。闻深般若波罗蜜不问中慧。来生是间闻深般若波罗蜜。心便有疑不信乐不问中慧。何以故。前世有疑故。若复有菩萨前世闻深般若波罗蜜。问中慧一日二日三日若至七日。持是功德今复逮得深般若波罗蜜。常乐闻喜问信受。若复有菩萨有时欲闻般若波罗蜜。或不欲闻。其心乱数数转如称乍低乍仰。是辈人适学未发故。使少信不乐得深般若波罗蜜。便厌不欲学弃舍去。如是终不成就堕罗汉辟支佛道中

    摩诃般若波罗蜜道行经譬喻品第十二

佛言。譬如大海中船卒破坏知中人皆当堕水没死。终不能得度。是船中有板若樯。有健者得之。骑其上顺流堕深得出。知是人终不没水中死也。何以故。用得板樯故。菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。不得深般若波罗蜜。不学沤和拘舍罗。是菩萨便堕阿罗汉辟支佛道中。菩萨有信乐有定行有精进欲逮阿耨多罗三耶三菩得深般若波罗蜜。学沤和拘舍罗。是菩萨终不中道懈惰。过出阿罗汉辟支佛道去。正在阿耨多罗三耶三菩中住。譬如有人持坏瓶行取水。知是瓶不能久当道坏。何以故瓶未成故若有菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。不得深般若波罗蜜。不学沤和拘舍罗。是菩萨终不能逮萨芸若。便中道厌却。堕阿罗汉辟支佛道中。譬若有人持成瓶行取水。知当安隐持水来归至也。何以故。其瓶已成故。若有菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。得深般若波罗蜜。学沤和拘舍罗。知是菩萨终不中道懈墯休止恣心。正上阿耨多罗三耶三菩。譬若大海中有故坏船不补治之。便推着水中取财物置其中。欲乘有所至。知是船终不能至。便中道坏亡散财物。若有菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。不得深般若波罗蜜。不学沤和拘舍罗。知是菩萨中道厌便亡失名珍宝。更弃大珍宝去。何所为大珍宝。佛是也。是菩萨便中道堕阿罗汉辟支佛道中。譬若有黠人。拖张海边故坏船补治之。以推着水中。持财物置其中。便乘欲有所至。知是船不中道坏必到所至处。若有菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。得学深般若波罗蜜沤和拘舍罗。知是菩萨终不中道懈惰。正在阿耨多罗三耶三菩中住。何以故。是菩萨一心有信乐有定行有精进故。终不复堕罗汉辟支佛道中。正向佛门。譬若有人年百二十岁。老极身体不安。若病寒热寝卧床褥。此人宁能自起居不。须菩提言。不能也。何以故。是人老极无势力故。正使病愈由不能自起居行步。佛言。菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。不得学深般若波罗蜜沤和拘舍罗者。终不能至佛。当中道休堕阿罗汉辟支佛道中。何以故。不得学深般若波罗蜜沤和拘舍罗故。佛言。但是人风寒病愈身体强健意欲起行。有两健人各扶一掖。各持一臂徐共持行。其人语病者言。安意莫恐。我自相扶持在所至到。义不中道相弃。如是人能到所欲至处不。须菩提言。菩萨有信乐有定行有精进。欲逮阿耨多罗三耶三菩。得深般若波罗蜜。学沤和拘舍罗是菩萨终不中道懈墯。能究竟于是中得阿耨多罗三耶三菩

    摩诃般若波罗蜜道行经分别品第十三

须菩提白佛言。云何阿阇浮菩萨学般若波罗蜜。佛言。当与善知识从事。当乐善知识。当善意随般若波罗蜜教。何等为随般若波罗蜜教。是菩萨所布施。当施与作阿耨多罗三耶三菩。莫得着色痛痒思想生死识。何以故。深般若波罗蜜萨芸若无所著。若持戒忍辱精进禅智慧。当持是作阿耨多罗三耶三菩。莫得着色痛痒思想生死识。何以故。萨芸若无所著。无得乐阿罗汉辟支佛道。阿阇浮菩萨稍入般若波罗蜜中如是

须菩提言。菩萨谦苦。欲得阿耨多罗三耶三菩。佛言。菩萨谦苦安隐于世间护为世间自归。为世间舍。为世间度。为世间台。为世间导何等为菩萨为世间护死生勤苦悉护教度脱是为世间护。何等为世间自归。生老病死悉度之。是为世间自归。何等为世间舍。菩萨得阿耨多罗三耶三菩阿惟三佛。得怛萨阿竭名。时为世间说经无所著。是为世间舍。何等为无所著。色无著无缚。是色无所从生无所从灭。痛痒思想生死识亦尔。诸法亦无著无缚如是。何等为世间度。是色非色为度。痛痒思想生死识。是识非识为度。度为诸法。须菩提言。如佛所说。度为诸法得阿惟三佛。何以故。无所著耶。佛言。如是无所著菩萨为谦苦。念法不懈得阿耨多罗三耶三菩阿惟三佛因说经。是亦为世间度。何等为世间台。譬若水中台其水两避行。色痛痒思想生死识。过去当来今现在两断。如是断者诸法亦断。设使诸法断者。是为定。是为甘露。是为泥洹。菩萨念法不懈得阿惟三佛。是为世间台。何等为世间导。菩萨得阿惟三佛。便说色痛痒思想生死识空。说诸法空。是亦无所从来亦无所从去。诸法空。诸法无有想。诸法无有处。诸法无有识。诸法无所从生。诸法空。诸法如梦。诸法如一。诸法如幻。诸法无有边。诸法无有是。皆等无有异

须菩提白佛言。般若波罗蜜甚深。谁当了是耶。佛言。菩萨求以来大久远乃从过去佛时于其所作功德以来。如是辈人乃晓知深般若波罗蜜耳。须菩提言。何谓求以来大久远。佛言。去离于色痛痒思想生死识无复有。尔乃晓知是深般若波罗蜜。须菩提言。是菩萨为世间导耶。佛言。如是菩萨得阿惟三佛。为不可计阿僧祇人作导。须菩提言。菩萨为谦苦。是为摩诃僧那僧涅为般泥洹不可计阿僧祇人。佛言。如是菩萨为谦苦。是为摩诃僧那僧涅。是故为僧那僧涅无缚。色痛痒思想生死识无缚。亦不于阿罗汉辟支佛。亦不于萨芸若。诸法无缚。是故为僧那僧涅

须菩提言。菩萨求深般若波罗蜜。不当索三处。佛言。何因缘菩萨求深般若波罗蜜。不当索三处。须菩提言。般若波罗蜜甚深。亦不可有守者。亦不无守者。从般若波罗蜜中。为无所出法。守般若波罗蜜为守空。守般若波罗蜜为守诸法。守般若波罗蜜为守无所有。守般若波罗蜜为守无所著。佛言。在般若波罗蜜中者。当知是阿惟越致菩萨。于深般若波罗蜜中无所适着。终不随他人语不信余道。心不恐畏不懈怠。从过去佛问是深经中慧。今闻深般若波罗蜜。心续不恐畏不懈怠

须菩提白佛言。若有菩萨闻深般若波罗蜜。心不恐畏不懈怠。何因缘当念般若波罗蜜中观视。佛言。心向萨芸若。是为观视般若波罗蜜。须菩提言。何谓心向萨芸若。佛言。心向空。是为观萨芸若。观萨芸若是为不观。不可计萨芸若。如不可计色为非色。如不可计痛痒思想生死识为非识。亦不入亦不出。亦不得亦不知。亦不有知亦不无知。亦无所生亦无所败。亦无所作者。亦无所从来亦无所从去。亦无所见亦无所在。如是不可限空。不可计萨芸若。不可计无有作佛者。无有得佛者。无有从色痛痒思想生死识中得佛者。亦不从檀波罗蜜尸波罗蜜羼提波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜得佛也。爱欲天子梵天子白佛言。般若波罗蜜甚深。难晓难了难知。佛语诸天子。深般若波罗蜜甚深。难晓难了难知。怛萨阿竭安隐甚深是经悉知阿惟三佛无有作。阿惟三佛亦无有阿惟三佛。是经如空甚深。无有与等者。如诸法无所从来无所从去。爱欲天子梵天子等白佛言。诸世间人希有信是深经者。世间人所欲皆着。愍念之故当为说是深经耳佛言。如是诸天子。世间人希有信是深经者所欲皆着。悯念是世间人故。当为说深经耳

    摩诃般若波罗蜜道行经本无品第十四

须菩提。白佛言。诸法随次无所著。诸法无有想如空。是经无所从生。诸法索无所得。爱欲天子梵天子白佛言。弟子须菩提所说如是。怛萨阿竭教但说空慧。佛言。如是诸天子。随怛萨阿竭教。诸天子问佛。何谓怛萨阿竭教。如法无所从生。为随怛萨阿竭教乎。佛言。如是诸天子。诸法无所从生。为随怛萨阿竭教。随怛萨阿竭教是为本无。本无亦无所从来。亦无所从去。怛萨阿竭本无。诸法亦本无。诸法亦本无。怛萨阿竭亦本无。无异本无。如是须菩提随本无是为怛萨阿竭本无。怛萨阿竭本无住。如是须菩提。住随怛萨阿竭教。怛萨阿竭本无无异。本无无异也。诸法是无异。无异怛萨阿竭本无无所挂碍。诸法本无无所挂碍。怛萨阿竭本无。诸法本无碍。一本无等无异本无。无有作者。一切皆本无。亦复无本无。如是怛萨阿竭本无不坏亦不腐。诸法不可得。须菩提。随诸法教怛萨阿竭本无。诸法本无。等无异于真法中本无须菩提。随怛萨阿竭教。怛萨阿竭本无。无有过去当来今现在。诸法本无过去当来今现在。须菩提。随怛萨阿竭教。怛萨阿竭本无。过去本无。当来本无。今现在怛萨阿竭本无等无异。是等无异为真本无。菩萨得是真本无如来名。地为六反震动。怛萨阿竭说本无。须菩提。随怛萨阿竭教。须菩提。不受色痛痒思想生死识不受须陀洹斯陀含阿那含阿罗汉辟支佛。如是须菩提。为随怛萨阿竭教。舍利弗言。是本无甚深。天中天。佛言。是本无甚深甚深。当说本无时。二百比丘僧皆得阿罗汉。五百比丘尼皆得须陀洹道。五百诸天人皆逮无所从生法乐。于中立六十新学菩萨。皆得阿罗汉道。佛言。是六十菩萨过去世时。各各供养五百佛。布施求色。持戒忍辱精进求色。禅不知空离空。不得般若波罗蜜沤和拘舍罗。今皆取阿罗汉道。菩萨有道得空得无色得无愿。是菩萨不得般若波罗蜜。沤和拘舍罗。便中道得阿罗汉道不复还。譬若有大鸟。其身长八千里若二万里复无有翅。欲从忉利天上自投来下至阎浮利地上。未至是鸟悔。欲中道还上忉利天上。宁能复还不耶。舍利弗言。不能复还。佛言。是鸟来下至阎浮利地上。欲使其身不痛。宁能使不痛不耶。舍利弗言。不能也。是鸟来其身不得不痛。若当闷极若死。何以故。其身长大及无有翅。佛言。正使是菩萨如恒中沙劫。布施求色。持戒忍辱精进求色。禅亦不入空。不得深般若波罗蜜沤和拘舍罗。起心欲索佛道。一切欲作佛。中道得阿罗汉辟支佛道。是菩萨于过去当来今现在佛所。持戒精神三昧智慧。闻佛萨芸若。皆念求色是为不持怛萨阿竭戒精进三昧智慧。不晓知萨芸若。但想如闻声耳。便欲从是作阿耨多罗三耶三菩。会不能得。便中道得阿罗汉辟支佛道。何以故。不得深般若波罗蜜沤和拘舍罗故。舍利弗言。如佛所说。念中慧菩萨离般若波罗蜜沤和拘舍罗故。便得阿罗汉辟支佛道。若有菩萨庄严事。欲得阿耨多罗三耶三菩阿惟三佛者。当黠学般若波罗蜜沤和拘舍罗。爱欲天子梵天子白佛言。般若波罗蜜难晓难了难知。欲求阿耨多罗三耶三菩难得也。须菩提白佛言。般若波罗蜜甚深难晓难了难知。如我念是中慧。求阿耨多罗三耶三菩易得耳。何以故。无所有当何从得阿耨多罗三耶三菩。诸法皆空索之了不可得。当作阿惟三佛。索法无所得。无有作阿惟三佛。亦无有得阿惟三佛者。若有闻诸法空。求阿耨多罗三耶三菩易得耳。舍利弗谓须菩提。如须菩提所说者。阿耨多罗三耶三菩难得也。何以故。空不念我当作阿耨多罗三耶三菩。是法空设易得者何以故。如恒沙菩萨悉皆逮。须菩提言。云何舍利弗。用色逮乎不也离色法逮乎。不也。痛痒思想生死识逮乎。不也。色本无宁逮不。不也。色本无有法逮不。不也。痛痒思想生死识本无宁逮不。不也。离识本无有法逮不。不也是本无使逮不。不也。离本无有法使逮不。不也。设是法不可得。何所法使逮者。舍利弗言。如须菩提所说法。无有菩萨逮者。佛所说三有德之人。求阿罗汉辟支佛佛。是三不计三。如须菩提所说为一道耳。分漫陀尼弗谓舍利弗。须菩提。说一道当问。舍利弗谓须菩提。须菩提所说一道。我用是故问。须菩提言。云何于本无中见三道不。舍利弗言。不见也。何以故。从本无中不可得三事。须菩提言。本无一事得乎。不也。云何于本无中可得一道不。不也。设是谛不可得者。故复说阿罗汉辟支佛佛。为如是说。道本无无有异。若菩萨闻本无心不懈怠。是菩萨会当得佛也。佛言。如须菩提所说。皆持佛威神。使若说是耳。菩萨闻本无等无异心不懈怠会当得佛。舍利弗言。何等为菩萨成阿耨多罗三耶三菩者。须菩提白佛言。何等为成就于菩萨。佛言。一切人皆等视中与共语言。当善心不得有害意向。常当慈心与语不得嗔恚。皆当好心中心。菩萨当作是住

道行般若经卷第五道行般若经卷第六

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜阿惟越致品第十五

须菩提白佛言。阿惟越致菩萨当何以比。当何以观其行。当何以相。当何从知是阿惟越致菩萨。佛言。阿惟越致菩萨。如逮得禅者不动摇。如罗汉辟支佛地佛地。是佛地如本无终不动。佛说本无闻不言非。空是中本无入本无。是所本无如本无。亦不言非。如是入中。入中以闻是本无以。若转于余处闻心终不疑。亦不言是。亦不言非。如是本无如本无住。其所语不轻。所言不说他事但说他正。他人所作不观视。用是比用是相行具足。知是阿惟越致菩萨。阿惟越致终不形相沙门婆罗门面类。不祠祀跪拜天。不持华香施于天。亦不教他人为。身不生恶处。不作女人身。当持十戒。不杀生强盗淫泆两舌嗜酒恶口妄言绮语。不嫉妒嗔恚骂詈不疑。亦不教他人为。身自持十戒不疑。复教他人守十戒。于梦中自护十戒。亦复于梦中面目见十戒。阿惟越致心学诸法。皆安隐为世间人说经。持深经授与令得分德住。悉致愿使得经。令用分德住阿惟越致。闻说深经时终不疑。不言不信。亦不恐惧。所语柔软。微妙至密。少睡卧行步出入。心安谛无乱。时徐举足蹈地。安隐顾视所。斐服衣被净洁。无垢坋无蚤蟋。身中无八十种虫。所有功德稍稍欲成满。心极清净悉受得之。其功德过出于世间

须菩提白佛言。云何菩萨心清净。当何以知之。佛言。是菩萨所作功德转增多。其心极上。自在无所挂碍。悉逮得其功德是心甚清洁。清洁过于阿罗汉辟支佛道上。如是阿惟越致。有来供养者不受用喜一切无悭贪。说深经时未尝于中有厌极也。正在智中深入。若余所欲有问深经者。持是深般若波罗蜜为说之。其有他道所不能正者。持是深般若波罗蜜为正之。从是经中所出法。悉持无常之事相语之。诸世间经书所不能解者。持是深般若波罗蜜为解之。用是故。弊魔来到是菩萨所。便于边化作大八泥犁。其一泥犁中有若干千百千菩萨化作是以便指示之言。是辈皆阿惟越致菩萨。从佛受决以今皆堕泥犁中。佛为授若泥犁耳。设若作阿惟越致受决菩萨者。若当受疾悔之言。我非阿惟越致。若悔之言尔者。便不复堕泥犁中当生天上。佛言。设是菩萨心不动转者是阿惟越致弊魔复化作其师被服。往到菩萨所诡语。若前从我所闻受者今悉弃舍。是皆不可用也。若自悔过。受疾悔之随我言者。我日来问讯汝。不用我言者。终不复来视汝。若莫复说是事。我不复欲闻。是故说是皆非佛所说。余外事耳。汝今更受我所语。我所说皆佛语。佛言。菩萨闻是言其心动转者。不从过去佛受决。未上菩萨举中。未在阿惟越致地。设是菩萨心不动转者。知是深经空所致。作是思惟。终不信他人语。譬若比丘得阿罗汉。不复随他人语。悉明见经中证。是为空所致。终不可动。如阿罗汉辟支佛道所念法。终不可复还。是菩萨为在阿惟越致地住。正住向佛门。终不可复还。是为极度。用是比用是相行具足。知是阿惟越致菩萨。复有弊魔化作异人。往到菩萨所作是语。若所求为勤苦耳。不求佛法也。若空负是勤苦为用。是勤苦之难为求乎。若在恶道中以来大久。适今得为人。汝不当于是中思惟。不当自患厌耶。当复于何所更索是躯。汝何不早取阿罗汉道。用佛为求之。是菩萨心不动转者。知是阿惟越致。弊魔不能动转舍去。更作方便。化作若干菩萨在其边住。因指示言。若见不耶。是悉菩萨。皆供养如恒中沙佛。以皆与衣被饮食床卧具医药。悉具足皆从如恒中沙佛。受行法问慧。当所施行。如法住。如法求。皆入中作是学作是受作是行。悉以尚不能得佛。若学以来甫尔。当何因得佛。菩萨闻是言心不动转者。弊魔复舍去不远。复化作诸比丘示之言。是悉阿罗汉。过去世时皆求菩萨道。不能得佛。今皆取阿罗汉已。如是比丘当何从得佛。菩萨闻是语心不动转。当觉知魔为佛言。作是学作是求作是行。于是深般若波罗蜜中住。心不动转者。如是比相行具足。知是阿惟越致。佛言。菩萨当作是学作是求护是教受佛教。当念行于他方闻魔语如是。心不动转。不可移。觉知魔为。菩萨作是学不得佛者。佛语为有异。佛语终不欺也。弊魔复往到菩萨所。作是诡甥言。佛如空。是经不可得边幅。不可得极。是经中我悉知已皆空耳。若为是中勤苦。若不当觉知魔为此事。魔作是经。云何欲于中欲得作佛。是非佛所说。菩萨当谛觉知是魔所为。菩萨作第一禅第二禅第三禅第四禅三昧。越阿惟越致。不随录是四禅。是所禅作三昧。越用人入欲中故禅三昧。是菩萨终不随禅教。其功德极过禅上去。有共称誉名字者不用喜。不称誉者亦不用作忧。其心终不动乱。常念世间人。善出入行步坐起常端心正志。少淫意。在家者与妇人相见心不乐喜。常怀恐怖。与妇人交接。念之恶露臭处不净洁。非我法也。尽我寿命不复与相近。当脱是恶露中去。譬若有人行大荒泽中。畏盗贼心念言。我当何时脱出是阨道中去。当弃远是淫泆畏惧如行大荒泽中。亦不说其人恶。何以故。诸世间皆欲使安隐故也。佛言。如是菩萨其福具足得之。是皆深般若波罗蜜威神力。使作是念。是菩萨和夷罗洹化诸鬼神随后。亦不敢近附菩萨终不失志。心不妄起。身体完具无疮癞。极雄猛终不诱他人妇女。若有治道符祝行药身不自为。亦不教他人为。见他人为者心不喜也。终不说男子若女人为事。亦不说非法之事。亦不生恶处。用是比用是相行具足。知是阿惟越致菩萨。

须菩提白佛言。菩萨用何等故名为阿惟越致。佛言。菩萨不与国王若世俗城郭聚落会人从事。不与盗贼若军师兵刃从事。不与男子女人从事。不与余道人若祠祀诸鬼神酒肉谷食从事。不与香及烧香若缯彩利业调戏从事。不与海中若诸所欲从事。不与弊恶无反复好斗乱人者从事。但与深般若波罗蜜从事。心终不远离萨芸若。常在中不志常行中正。无不行时。常称誉贤善者上头。常随善知识。不与恶知识相随。常求佛法。愿欲生异方佛刹。用是故。常与佛相见供养之。从欲处色处空处。从彼间来生中国。常于善人黠慧中生。在工谈语晓经书家生。常不好豫世俗之事。生不犯法。常在大国中生。未常在边地生也用是比用是相行具足。用是故名为阿惟越致菩萨。终不言我是阿惟越致。亦不言我非。亦不疑我非阿惟越致地。亦不言我是阿惟越致地。譬若有人得须陀洹道。在其地终不疑魔事。适起即觉知。魔稍稍来不听随在阿惟越致地终不疑不懈怠。譬若有人作恶逆。尽其寿命心终不可转。使作善不念恶。是恶心至死终不休。是菩萨住中正。在阿惟越致地。心不可移动十方终不能复转其心。自有道地。终不疑无阿罗汉辟支佛。心不念佛难得。心大无有极。安隐坚住其地。无有能降之者。作是住。无有能过是黠者。用是故。弊魔大愁毒言。是菩萨心如刚铁不可转。便复更作佛形往语菩萨言。若何不于是间取阿罗汉证。若未受决得阿耨多罗三耶三菩。若不得是比。不得是相。菩萨用是比。用是相行具足。如是尚不得佛。若当何因得之。佛言。设是菩萨闻魔语。若心不动者。是菩萨从过去怛萨阿竭受决已。得阿耨多罗三耶三菩。是故觉知魔作佛形得来言。是非佛也魔耳。欲使我心摇。我心不可动。佛言。是菩萨心不可动转者。从过去怛萨阿竭受决已。授阿耨多罗三耶三菩。住阿惟越致地。何以故。用是比用是相行具足故。知是阿惟越致菩萨。悉得法者悉行中正。当代不惜身命。是菩萨一切法悉受得之。过去当来今现在。佛所有法悉得持护。用是故。当为不惜身命。未常懈怠。无有厌时。怛萨阿竭及诸弟子说经时心终不疑。亦不言非佛说。闻说深般若波罗蜜。终心不有疑。亦不言非。如是菩萨逮无所从生法。乐于中立。持是功德悉具足。用是比用是相行具足。是为阿惟越致菩萨

    摩诃般若波罗蜜道行经怛竭优婆夷品第十六

须菩提白佛言。阿惟越致菩萨极从大功德起。常为菩萨说深法教入深。佛言。善哉善哉须菩提。若乃内菩萨使入深。何等为深。空为深。无想无愿。无识无所从生灭。泥洹是为限。须菩提白佛言。泥洹是限。非是诸法。佛言。诸法甚深。色痛痒思想生死识甚深。何等为色痛痒思想生死识甚深。如本无。色痛痒思想生死识本无。尔故甚深。须菩提言。难及也。天中天。色痛痒思想生死识。妄消去便为泥洹佛言。甚深与般若波罗蜜相应。当思惟念。作是住学。如般若波罗蜜教。菩萨随是行。当思惟念。如中教应行一日。是菩萨为却几劫生死。譬如淫泆之人。有所重爱端正女人与共期会。是女人不得自在。失期不到。是人宁有意念之不耶。须菩提言。其人有念思想。当到欲与相见。坐起宿止言语。佛言。其人未到之间。能有几意起念。须菩提言。是意甚多甚多。佛言。菩萨念深般若波罗蜜。如是一日心不转者。却生死若干劫。菩萨学般若波罗蜜。如中教如中所说思念。随是行一日。为却恶除罪。若有菩萨远离深般若波罗蜜。正使布施如恒中沙劫。不如是菩萨随深般若波罗蜜教一日。其功德出彼上。若复有菩萨寿如恒中沙劫。并持前所布施。与须陀洹斯陀含阿那含阿罗汉辟支佛佛。不得深般若波罗蜜。若复有菩萨随深般若波罗蜜中行如中教。其功德出彼上。若复有菩萨寿如恒中沙劫布施如前。持戒具足。若复有菩萨求深般若波罗蜜。从念起说经。其功德出彼上。若复有菩萨持经布施。其功德转上。得阿耨多罗三耶三菩。是菩萨持经布施。以来深入是中随是教。其功德出彼上。若复有菩萨以经布施。不深入是中。转不及也。若复有菩萨持经布施。复深入是中。未常有离时。为般若波罗蜜所护。其功德甚多甚多

须菩提白佛言。所识有著者。此二何所功德为多。佛言。菩萨所识。若求深般若波罗蜜。乐于空。乐无所有。乐尽。乐无常。念是为不离般若波罗蜜。如是菩萨得功德不可计阿僧祇须菩提白佛言。不可计复言阿僧祇。有何等异。佛言。阿僧祇者。其数不可尽极也。不可计者。为不可量计之。了不可得边崖。尔故为不可计阿僧祇。须菩提言。佛说不可计。色痛痒思想生死识亦不可计。佛语须菩提。汝所问者。有何因使色痛痒思想生死识不可计不可量。须菩提问佛。何等为不可量。佛言。于空中计之为不可量。无想无愿计之。如是不可量。须菩提言。空计是法不可计。佛言。云何我常不言诸法空。须菩提言。如怛萨阿竭所说法悉空。佛言。诸法悉空不可尽不可计。经无有各各慧。无有各各异。怛萨阿竭但分别说耳。空不可尽不可量。是想是愿是识是生是欲是灭是泥洹。随所喜。作是为说。作是现示。作是为教。怛萨阿竭所说如是

须菩提言。难及也。天中天。经本空耳。云何复于空中。说经。是经不可逮。如我了佛语。诸法不可逮。佛言如是。诸法不可逮。佛言如是。诸法不可逮空耳。是为不可逮。须菩提言。如佛说本无不可逮。愿解不可逮慧有增有减。佛言。不也。须菩提言。若有不可逮慧有增有减。檀波罗蜜。尸波罗蜜。羼提波罗蜜。惟逮波罗蜜。禅波罗蜜。般若波罗蜜。不增不减。若不增波罗蜜者。菩萨何因近阿耨多罗三耶三菩。何缘得阿惟三佛。设不减波罗蜜者。菩萨何因近阿耨多罗三耶三菩。何缘近阿惟三佛佛坐。佛言。是不可逮慧不增不减。菩萨求深般若波罗蜜若守者。如是沤和拘舍罗菩萨不念檀波罗蜜增。亦不念减。复作是念。但名檀波罗蜜。所布施念持是功德施与作阿耨多罗三耶三菩。施如是尸波罗蜜。羼提波罗蜜。惟逮波罗蜜。禅波罗蜜。菩萨求般若波罗蜜若守者。得沤和拘舍罗。不念般若波罗蜜有增有减。是但名为般若波罗蜜。求之若守者。发心念持是功德施与作阿耨多罗三耶三菩。须菩提白佛言。何等为阿耨多罗三耶三菩。佛言。本无是也。是本无不增不减。常随是念不远离。是即为近阿耨多罗三耶三菩坐。不可逮法。不可逮慧。若般若波罗蜜皆不增不减。菩萨念是不远离。为近阿耨多罗三耶三菩。须菩提白佛言。菩萨持初头意。近阿耨多罗三耶三菩。若持后头意近之。佛言。初头意后来意。是两意无有对。须菩提言。后来意初头意无有对。何等功德出生长大。佛言。譬如然灯炷。用初出明然炷用后来明然炷。须菩提言。非初头明然炷。亦不离初头明然炷。亦非后明然炷。亦不离后明然炷。佛问须菩提。云何如是不。须菩提言。如是天中天。佛言。菩萨不用初意。得阿耨多罗三耶三菩。亦不离初意得。亦不用后意得。亦不离后意得也。佛言。云何是为得阿惟三佛不。须菩提言。阿惟三佛甚深是因缘。菩萨不用初意。得阿耨多罗三耶三菩。亦不离初意得。亦不用后意得。亦不离后意得也。佛言。云何心前灭后复生耶。须菩提言。不也。佛言。心初生可灭不。须菩提言。可灭。佛言。当所灭者宁可使不灭不。须菩提言。不也。佛言本无。宁可使住不。须菩提言。欲住本无。当如本无住。佛言。设令在本无中住。宁可使发坚固不。本无宁有心无心。不离本无宁有心不。见本无不。作是求为深求不。须菩提言。天中天。作是求为无所求。何以故。是法了不可得。亦不可见。佛言。菩萨求般若波罗蜜为求何等。须菩提言。为求空。佛言。设不空为求何等。须菩提言。为求想。佛言。云何去想不。不也。是菩萨为不去想。须菩提言。不作是求忘想。何以故。求想尽者。设想灭者。即可灭也。便得阿罗汉。是为菩萨沤和拘舍罗。不灭想得证。向无想随是教。舍利弗谓须菩提。若有菩萨有三种事。向三昧门。守三昧门。一者空。二者无相。三者无愿。是三者有益于般若波罗蜜。不但昼日益。夜梦中亦当复益。何以故。佛说昼夜梦中等无异。须菩提言。若有菩萨昼日有益于般若波罗蜜。夜梦中亦复有益。舍利弗言。云何若梦中有所作。宁有所得不。佛所说经。如梦中所有。须菩提言。梦中所作善。觉大喜为益。梦中所作恶。觉不喜为减。舍利弗言。设于梦中杀人其心喜。觉以言。我杀是人快乎。如是云何。须菩提言。不[歹*占]。尔皆有所因缘心不空。尔会有所因缘。若见若闻若念为因缘。尔故知耳。从是中令人心有所著。令人心无所著。是为不忘。尔皆有所因缘故。舍利弗言。所作皆空耳。何因心有所因缘。须菩提言。想因缘。是故心因缘从是起。舍利弗言。菩萨梦中布施持是施与作阿耨多罗三耶三菩。如是有施与无。须菩提言。弥勒菩萨近前在。旦暮当补佛处。是故知。当从问。舍利佛白弥勒菩萨。我所问。须菩提言。弥勒菩萨能解之。弥勒言。如我字弥勒当解乎。当以色痛痒思想生死识解慧乎。持是身解耶。若空若色痛痒思想生死识解慧。色痛痒思想生死识空无力。当所解是法了不见也。亦不见当。所解者。是法了不见当得阿耨多罗三耶三菩者。舍利弗言。弥勒菩萨所说为得证。弥勒言不也。我所说法不得证。舍利弗便作是念。弥勒菩萨所入慧甚深。何以故。常行般若波罗蜜以来大久远矣

佛问舍利弗。云何若自见作阿罗汉时不。舍利弗言。不见也。佛言。如是菩萨不作是念我受决。是法当于中得阿惟三佛。亦无有得阿惟三佛者。菩萨作是行。为求般若波罗蜜。终不恐我不得阿惟三佛。随是法中教。求般若波罗蜜。用是故我无所畏。菩萨至大剧难虎狼中时终不畏怖。心念言。设有啖食我者为当布施行檀波罗蜜。近阿耨多罗三耶三菩。愿我后作佛时。令我刹中无有禽兽道菩萨至贼中时终不怖惧。设我于中死。心念言。我身会当弃捐。正令我为贼所杀。我不当有嗔恚。为具忍辱行羼提波罗蜜。当近阿惟三佛。愿我后得佛时。令我刹中无有盗贼。菩萨至无水浆中时心不畏怖。自念言。人无德使是间无水浆。愿我后得阿惟三佛时。使我刹中皆有水浆。令我刹中人悉得萨芸若八味水。菩萨至谷贵中时心不恐怖。自念言。我当精进得阿惟三佛。使我刹中终无谷贵。令我刹中人在所愿所索饮食悉在前。如忉利天上食饮。菩萨在疾疫中时。心念言。我终无恐惧。正使我身死是中。会当行精进得阿惟三佛。令我刹中无有恶岁疾疫者。必当降伏魔官属。佛言。菩萨闻是阿耨多罗三耶三菩阿惟三佛。却后大久远乃得佛者心不恐怖。从本际起。意学以来用不为久也。譬如人意一转顷耳。何以故。无有本际故。佛说是时。有优婆夷。从坐起前至佛所。为佛作礼长跪白佛言。我闻是不恐不怖。必降恐怖之处。索阿耨多罗三耶三菩。得阿惟三佛已当说经。佛笑口中金色光出。优婆夷即持金华散佛上。持佛威神华皆不堕地。阿难从坐起更斐袈裟。前为佛作礼长跪问佛言。佛不妄笑。既笑当有所说。佛言。是怛竭优婆夷却后当来世名星宿劫。是中有佛名金华佛。是优婆夷后当弃女人身。更受男子形却后当世阿閦佛刹。从阿閦佛刹去复到一佛刹。从一佛刹复生一佛刹。如是无终极。譬如遮迦越王从一观复游一观。从生至终足不蹈地。是优婆夷从一佛刹复到一佛刹。未尝不见佛。阿难心念。如阿閦佛刹诸菩萨会者。是为佛会耳。佛知阿难心所念。佛言。是诸菩萨会者。悉度生死已。是优婆夷后当作金华佛。度不可计阿罗汉令般泥洹。是时佛刹中无有禽兽盗贼。无有断水浆若谷贵病疫者。其余恶事悉无有。阿难问佛。是优婆夷从何佛已来作功德。佛言。乃昔提和竭罗佛所作功德。初发意求佛。提和竭罗佛时。亦复持金华散佛上愿言。持是功德施与。作阿耨多罗三耶三菩者。佛言。如我持五华散提和竭罗佛上。即逮得无所从生法乐于中立。授我决言。却后无数劫。若当为释迦文佛是优婆夷尔时见我从佛授决。其心亦念。我亦当授决得阿耨多罗三耶三菩。如是菩萨受决佛语阿难。是怛竭优婆夷于提和竭罗佛所。初发起本阿耨多罗三耶三菩阿惟三佛。阿难白佛言。是怛竭优婆夷所求已度。佛言已度

道行般若经卷第六道行般若经卷第七

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜守空品第十七

须菩提白佛言。菩萨行般若波罗蜜。何等为入空。何等为守空三昧。佛言。菩萨行般若波罗蜜。色痛痒思想生死识空观。当作是观。一心作是观不见法。如是不见法。于法中不作证。须菩提言。佛所说不于空中作证。云何菩萨于三昧中住。于空中不得证。佛言。菩萨悉具足念空不得证。作是观不取证。作是观观入处。甫欲向是时不取证。不入三昧。心无所著。是时不失菩萨法本不中道得证。何以故本愿悉护萨和萨故。为极慈哀故。自念言。我悉具足于功德。是时不取证。菩萨得般若波罗蜜。获得极大功德。悉得智慧力。譬若人能勇悍却敌。为人极端正猛健无所不能。能晓兵法。六十四变皆知习之。为众人所敬。若有所至处。无不得其力者。有所得者转分布与人。其心欢欣。若有他事与父母妻子俱去。过大剧道厄难之中。安隐父母。语其妻子言。莫有恐惧。当俱出是难中。既出得送父母妻子归乡里。不逢邪恶到家莫不欢欣者。何以故。用是人勇悍多智慧黠健故。是菩萨行极大慈。心念十方萨和萨。是时持慈心悉施人上。是菩萨过阿罗汉地。出辟支佛地。于三昧中住。悉愍伤萨和萨无所见。于是中不取证。入空中深不作阿罗汉。菩萨作是行时。为行空三昧。向泥洹门不有想。不入空取证。譬若飞鸟飞行空中无所触碍。菩萨行甫欲向空。至空向无想。不堕空中。不堕无想。悉欲具佛诸法。譬若工射人射空中。其箭住于空中。后箭中前箭。各各复射。后箭各各中前箭。其人射欲令前箭堕尔乃堕。菩萨行般若波罗蜜。为沤和拘舍罗所护。自于其地不中道取证堕阿罗汉辟支佛地。持是功德逮得阿耨多罗三耶三菩。功德盛满便得佛。为菩萨于经本中观。不中道取证。须菩提白佛言。菩萨谦苦作是学。不中道取证。佛言。是菩萨悉为护萨和萨。守空三昧向泥洹门。心念分别。何等为分别。守空三昧无相三昧无愿三昧。是为分别沤和拘舍罗。使是菩萨不中道取证。何以故。沤和拘舍罗护之故。故心念一切萨和萨。持是所念故。得沤和拘舍罗。不中道取证。若菩萨深入观。守空三昧向泥洹门。无想三昧向泥洹门。无愿三昧向泥洹门。用是故分别久远已来人。所因缘想中。求得阿耨多罗三耶三菩为说经。当使远是因缘。守空三昧守无想三昧守无愿三昧。向泥洹门。皆不中道取证。菩萨如是念久远人。呼常有想。常有安想。常有我想。常有好想各各本我作阿耨多罗三耶三菩时。用人故为说经。使断有想有安想有我想有好想。悉断。求云何断。是常无常。是乐皆苦。是身非身是好皆丑。菩萨自心念。为得沤和拘舍罗。守空。守无想。守无愿三昧。向泥洹门。不中道取证。若有菩萨心念人发远已来。求因缘。求想。求欲。求聚想。求空想。求是想。皆现在。菩萨言。我一切欲使世间无有是。用是念人故得沤和拘舍罗。是法观空想愿识。无所从生齐限。是菩萨不中道取证。法当作是知。云何菩萨求般若波罗蜜。当晓习于法中。心当何缘求。心当云何入。守空三昧。守无相三昧。守无愿三昧。向泥洹门。皆不中道取证。守无识三昧。守无所从生三昧。是菩萨不得决故。守空三昧。无相三昧。无愿三昧。无识三昧。无所从生三昧。念是三昧。竟有来问者。不即持不可计心为解者。知是非阿惟越致菩萨。何以故。阿惟越致心无央数悉知。用是比行不具足。知是菩萨未得阿惟越致。须菩提白佛言。若有菩萨能解是者。便为阿惟越致。佛言。闻深般若波罗蜜若不闻能解者。即是阿惟越致。须菩提言。不可计人求菩萨道。少有能解者。佛言。能解者以受决以于是功德中。极姝所知法者。阿罗汉辟支佛所不能及。诸天阿须伦龙鬼神所不及。是为阿惟越致相

    摩诃般若波罗蜜道行经远离品第十八

佛言复次须菩提。梦中菩萨摩诃萨不入阿罗汉地。不入辟支佛地。不乐索其中。亦不教他人入其中。心亦不念般若中诸法。梦中视不般若中为证。心悉常在佛。如是须菩提。阿惟越致菩萨摩诃萨。当知是阿惟越致相。复次须菩提。菩萨摩诃萨梦中与若干百弟子。共会在中央坐。不可数千弟子。不可数百千弟子。共会在中央坐说经。与比丘僧相随。最在前头。怛萨阿竭阿罗呵三耶三佛说经悉见亦复是。须菩提。阿惟越致菩萨摩诃萨。当知是阿惟越致相。复次须菩提。菩萨摩诃萨梦中在极高虚空中坐。为比丘僧说经。还自见七尺光。自在所变化。于余处所作。为如佛说经。菩萨摩诃萨于梦中作是亦复是。须菩提。阿惟越致菩萨摩诃萨。当知是阿惟越致相。复次须菩提。菩萨摩诃萨梦中不恐不怖不难不畏。梦中若见郡县。其中兵起展转相攻。若火起。若见虎狼师子及余兽。若见断人头者。如是余变化大勤苦者。多困穷者。饥者渴者。都以厄难。悉作是见。其心不恐不怖不惊不摇。于梦中见。以觉即起坐。作是念。如梦中所见。都是三处。我作佛时悉为说经遍教亦复是。须菩提。阿惟越致菩萨摩诃萨。当知是阿惟越致相。复次须菩提。何从知是菩萨摩诃萨得阿耨多罗三耶三菩。成作佛时。其境内一切无有恶心。是时须菩提。菩萨摩诃萨梦中若见畜生相啖人民疾疫时。其心稍稍生逮得是愿。作是念我会当作佛。如我作佛时。使我界中一切无有恶。用是故知亦复是。须菩提。阿惟越致菩萨摩诃萨。当知阿惟越致相。诸恶悉除赐亦复是须菩提。阿惟越致相复次须菩提。是菩萨摩诃萨于梦中觉已。若见城郭火起时。便作是念。我于梦中所见。用是比用是相见不怖。用是比用是相行具足。菩萨摩诃萨如是。是为阿惟越致相。持是比持是相行具足。是为阿惟越致菩萨摩诃萨。今我审应审至审是所向者当无异。今是城郭火起。用我故。悉当灭。悉当消。悉当去不复现。佛言。假令火赐灭已。赐消已。赐去已。知是须菩提。菩萨摩诃萨受决已。过去怛萨阿竭阿罗诃三耶三佛。授阿耨多罗三耶三菩。知是阿惟越致相假令火不灭不消不去。知是菩萨摩诃萨未受决。设火神烧一舍置一舍。复越烧一里置一里。知是须菩提。其家人前世时断经故所致。是辈之人所作宿命悉自见。宿命所作恶于是悉除赐。从是以来断经余殃悉尽。是宿命恶悉消。如是须菩提。知是菩萨摩诃萨。未得阿惟越致阿耨多罗三耶三菩。复次须菩提。用是比用是相行具足。菩萨摩诃萨当作是视。持是比持是相。当为说令知之。或时须菩提。若男子女人为鬼神所下。若为所持。是彼菩萨作是念。或我受决。如过去怛萨阿竭阿罗诃三耶三佛。授我阿耨多罗三耶三菩阿惟三佛。是阿耨多罗三耶三菩。所念悉净洁故。设我当作阿耨多罗三耶三菩阿惟三佛。所念皆净洁。是阿耨多罗三耶三菩。却阿罗汉心。却辟支佛心。设却阿罗汉心。以设却辟支佛心。以阿耨多罗三耶三菩会当作佛不得不作佛。阿耨多罗三耶三菩当作佛者。十方阿僧祇刹现在诸佛。无不知者。无不见者。无不证者。今怛萨阿竭阿罗诃三耶三佛。悉知我所识念。我审当作阿耨多罗三耶三菩阿惟三佛。审如我所语。审如我所为。审如我所言。是鬼神当用我故去。便告言。是男子女人。何等鬼神所取持乎。鬼神即为去。设是不去者。是菩萨摩诃萨说是时。当知须菩提。是菩萨摩诃萨未受决。过去怛萨阿竭阿罗诃三耶三佛。不授阿耨多罗三耶三菩。佛语须菩提。其人审至诚者。弊魔往到是菩萨摩诃萨前住。作是语言若本作是住若本字某。若以受决。欲以乱之。是菩萨当说是语时。我是真者。鬼神当随我语。我审受决。为阿耨多罗三耶三菩。审如我至诚者。是鬼神即当去。是弊魔便作是念。我当使鬼神去。何以故。弊魔极尊有威神。鬼神不敢当。魔作是念。鬼神用魔威神故便舍去。如是菩萨作是念。用我威神故鬼神即去耳。佛言。不知用魔威神故去也。是彼菩萨摩诃萨以自谓审然。便自贡高。轻易人。形笑人。无所录。语人言。我于过去怛萨阿竭阿罗诃三耶三佛所。受决以其余人悉未受决。用是故自可自贡高。反嗔恚起恚怒。稍稍增多。则离萨芸若大远。失阿耨多罗三耶三菩智。是辈菩萨无有沤和拘舍罗。嗔怒更生。起是两地。当堕阿罗汉地。若堕辟支佛道地。是辈须菩提持不成。是菩萨摩诃萨当觉知魔为。舍善知识去。亦不与善知识语。亦不与善知识从事。亦不录善知识。用是故知为魔所固。如是须菩提。菩萨摩诃萨当知魔为何以故当觉是事。知魔来在菩萨前。魔时时变服。往作是语言。过去怛萨阿竭阿罗呵三耶三佛。授若受阿耨多罗三耶三菩。若本字某。若母字某。若父字某。若兄字某。若姊字某。若弟字某。若亲厚字某。若知识字某若父母兄字某。若七世祖父母字某。若母外家字某。若父外家字某。若在某城生。若在某国生。若在某郡生。若在某县生。若在某乡生。若常软语。若今作是语。若乃前世时。亦复作是软语。或时高才。便复随形言。若前世时亦复高明。或见自字。或见乞食。或时一处饭。或时就饭者。或时先啖果菜却食饭。或时在丘墓间。或时路靖。或时在树间止。或时有受请者。或时不受请或时少多取足。或时麻油不涂身。或时语声好。或时巧谈语。魔见如是因底诡言。若前世时亦复巧谈语如是。若前世时施行法亦复如是。何以故。若前世时净洁行今还得。若前世时行净洁故。功德所致。今若还是功德耳。若前世时某家子。若种姓亦复字某。前世有是行。若今世亦复净洁得是。彼菩萨心便作是念想。我得无尔乎。是弊魔便复作是语言。若以受决阿惟越致。过去怛萨阿竭阿罗诃三耶三佛。若授决已。用是故若得净洁。佛语须菩提。我所说阿惟越致菩萨摩诃萨持是比持是相持是行用占之。我所说者不具足得反自用是。当知是菩萨辈终不成就。当知为魔所坏。何以故。用是比用是相。阿惟越致菩萨摩诃萨。知是了不得。用魔说其功德故。说其字故。是辈菩萨摩诃萨闻魔所语。心欢欣自谓审然。便行形调人。轻易同学人。自贡高彼菩萨用受是字故。便失其本行堕魔罗网。复次须菩提。用受是字故。菩萨摩诃萨不觉魔为。反自呼得阿耨多罗三耶三菩。魔复作是语言。若当作阿耨多罗三耶三菩。若作佛时当字某。是菩萨闻是字心中作是念。我得无然乎。我亦先时念如是。我本作是生意。以我本作是念已。佛言。是菩萨如是于智中少。是菩萨无有沤和拘舍罗。反作是念。是所言我字当作佛时。亦如我先时所念。我定当作阿耨多罗三耶三菩字如是。佛言。如魔所教。若魔天共作。是比丘为魔所迷。佛语须菩提。我所署菩萨。用是比用是相。我不教令作是为。我所教了不得。亡是比失是相。反用是字故自意念。我是阿惟越致便轻余菩萨。用是轻易故离佛。远离萨芸若。远离阿耨多罗三耶三菩智。远是沤和拘舍罗。亡以般若波罗蜜。亡以善知识。以更得恶知识。是菩萨会堕阿罗汉辟支佛道中。若后大久远勤苦能复求佛者。用般若波罗蜜恩故。当复得阿耨多罗三耶三菩自致作佛。佛言。尔时发意受是字时。不即觉。不即改。不即悔。如是当堕阿罗汉辟支佛道。佛言。若有比丘教重禁四事法若复他事。所犯毁是禁。不复成沙门不复为佛子。是坏菩萨辈。罪过于比丘四事法。是菩萨言。我于某国某郡某县某乡生。作是意生念时。其罪最重。当作是知。置是四事重法。是为五逆恶。当意生是念时其罪重。是菩萨用受其字故。意信生是念故其罪大。当作是知。如是须菩提。用是字故。为魔入深罪。复次须菩提。远离之德。菩萨摩诃萨。弊魔复往作是语言。远离法正当尔。怛萨阿竭阿罗诃三耶三佛所称誉

佛语须菩提。我不作是说远离教菩萨摩诃萨。于独处止。于树间止。于闲处止。须菩提白佛言。云何天中天。菩萨摩诃萨远离何所。复有异远离乎。亦不于独处止。亦不于树间止。亦不于闲处止。何等为异远离。佛语须菩提。正使各各有阿罗汉。随是行念。各各有辟支佛。随是行念。各各有菩萨摩诃萨。城外行远离。各各行菩萨摩诃萨一切恶不得犯。各各行菩萨摩诃萨。若当于独处止。若于树间止。若于闲处止。了了行菩萨摩诃萨。是远离法。我乐使作是行。不使远行绝无人处于中也。菩萨摩诃萨持是远离。当昼夜行。当了了行。是故菩萨摩诃萨远离于城傍行。持是比菩萨摩诃萨当各各行。若于独处止。若于树间止。若于闲处止。各各行菩萨摩诃萨。我所说远离法如是。尔时弊魔。当往教行远离法语言。若当于独处止。若于树间止。若于闲处止。当作是行。是菩萨随魔教便亡远离法魔语言道等取阿罗汉法。作是念无有异。当随是行。辟支佛道作是念无有异。亦当随是行。菩萨道作是念无有异。亦当随是行。般若波罗蜜难了知入中。若当作是行舍般若波罗蜜。佛言。是菩萨所愿未得反随其行。于法中未了知。是菩萨摩诃萨反自用是。当轻易余菩萨。自念谁能过我者轻易城傍行菩萨。城傍行菩萨了了净洁心无所念。不入阿罗汉法中住。不入辟支佛法中住。所有恶心不受。禅悦弃定。于三昧中悉逮得所愿悉具足度。佛言。是无有沤和拘舍罗。菩萨正使于百千由旬空泽中。在其中行。禽兽所不至处。贼所不至处。罗刹所不至处。在彼间止。若百岁若百千岁。若百千万岁正使复过是。不知是远离法。会无所益。是远离菩萨不具足。自念自用悉得。以了不自知为亡也。自用在远离中立。是为两舌耳。不得远离也。我不喜是菩萨心尔也。我所道远离菩萨摩诃萨不尔也。是所远离不具足知。于是远离中了不得。如是为三远离耳。如是弊魔便往飞在虚空中立。作是语。善哉善男子。是真远离法。怛萨阿竭阿罗诃三耶三佛所说。正当随是远离行。如是疾得阿耨多罗三耶三菩阿惟三佛。是菩萨闻是语喜。便从远离起去。往到城傍远离菩萨所。是菩萨比丘成就有德人也。反往轻言。若所行法非也。佛言。如是诸仁者中。有了了随行菩萨摩诃萨反呼非。中有反行反呼是。不当敬者而敬之。当所敬者反嗔向。语是菩萨言。我行远离。有飞人来语我言。善哉善哉。若审是远离法。正当随是行。用是故我来相语耳。今若当随我所行。如我所行无有比。若有城傍行。谁当来语若谁当来告若善哉。佛言。是菩萨有德之人。而反轻如是。须菩提。菩萨当作是知。如担死人种无所复中直反呼。是菩萨有短是为菩萨怨家。是为厌菩萨。以是为天上天下之大贼也。正使如沙门被服。亦复是贼无异也。于菩萨有德人中。亦复是贼也。是曹辈。须菩提。不当与共从事也。不当与共语言也。亦不当恭敬视也。何以故。多嗔怒起败人好心。是辈人也。当作是知。何所须菩提。菩萨摩诃萨不舍萨芸若。不置阿耨多罗三耶三菩。是所菩萨摩诃萨不舍萨芸若故。是阿耨多罗三耶三菩阿惟三佛。为一切护萨和萨。是彼坏菩萨辈。不当与从事。不当敬。不当与会所当护法。一当自坚持。常当急持。净洁心立。心所狎习。常当谛持。常当正心。常当怖畏。勤苦处无得入其中。无得入三处。是彼坏菩萨辈所在彼处。常当持慈心向。常当哀之令安隐。愍伤之慈念之。常当自护自念。使我无得生是恶心。一切使我心无瑕秽。我设有是不善疾使我弃。如是须菩提。菩萨摩诃萨所有行极上。当作是知

    摩诃般若波罗蜜道行经善知识品第十九

复次须菩提。菩萨摩诃萨在事欲得阿耨多罗三耶三菩阿惟三佛。是彼当与善知识从事恭敬承事。须菩提问佛。菩萨摩诃萨善知识。当何以知之。佛语须菩提。佛天中天。是菩萨摩诃萨善知识。若有说般若波罗蜜者。教人入是经中。是菩萨摩诃萨善知识。六波罗蜜。是菩萨摩诃萨善知识。当作是知。六波罗蜜是舍怛罗。六波罗蜜是道。六波罗蜜是护。六波罗蜜是一。六波罗蜜是将。过去怛萨阿竭阿罗诃三耶三佛。皆从六波罗蜜出。甫当来怛萨阿竭阿罗诃三耶三佛。皆从六波罗蜜出。今现在十方阿僧祇刹。怛萨阿竭阿罗诃三耶三佛。亦皆从六波罗蜜出成萨芸若。皆于四事中取道。用四事护萨和萨。何等四事。一者布施于人。二者欢乐于人。三者饶益于人。四者等与。是为四。如是须菩提。菩萨摩诃萨是故为舍怛罗。是故为母。是故为父。是故为舍。是故为台。是故为度。是故为自归。是故为导。是故为六波罗蜜。是故为萨和萨之度。何因菩萨摩诃萨学六波罗蜜。用无有极处人民故。悉欲断其根。是菩萨摩诃萨皆于般若波罗蜜中学。须菩提问佛。何所是般若波罗蜜相。佛语须菩提。无所挂碍是般若波罗蜜相。须菩提言。是所相得般若波罗蜜。如是相得诸法。佛言。如是须菩提。无所有相得般若波罗蜜。是所相得诸法。何以故。须菩提。诸法各各异。诸法各各虚空。如是须菩提。是所相各各虚空。是为般若波罗蜜相。诸法各各虚空。如是须菩提。是所相般若波罗蜜各各虚空。随是相诸法各各虚空。须菩提问佛。正使天中天。诸法各各虚空。何缘人民欲生无有尽时。各各无有减时。各各无有尽处时。虚空无有增时。虚空无有息时。各各虚空无有阿耨多罗三耶三菩阿惟三佛。不从是中各各虚空。是法不得阿耨多罗三耶三菩阿惟三佛。云何天中天。是法当何以知决。佛语须菩提。尔须菩提。昼夜人民欲得是因致是作是求须菩提言。如是天中天。昼夜人民欲得是因致是作是求。佛言。云何须菩提。若见我欲得是空不。须菩提言。不也天中天。佛言。如是不。须菩提。自作是得是空不。须菩提言。如是天中天。空。佛言。云何须菩提。但用是故。欲得是因致是。人民用是故勤苦。无有解已时。须菩提言。如天中天。极安隐人民。欲得是因致是。勤苦无有休息时。佛言。如是须菩提人民所欲故便着。当作是知人。民所生本从是生。从是中无可取。无可取者不作是得。是了无所有。如是。须菩提无有减尽时。从是中了无有生增益者。作是晓知。是为菩萨摩诃萨行般若波罗蜜。须菩提白佛言。作是晓知者。菩萨摩诃萨为不求色。不求痛痒思想生死识。作是晓知。行般若波罗蜜菩萨摩诃萨。为悉等行。诸阿罗汉诸辟支佛所不能及。有德之人所行道。是彼极过上。是所得爱无有能逮者。是菩萨摩诃萨当作是念。得般若波罗蜜已。当作是行。菩萨摩诃萨昼夜行。疾近阿耨多罗三耶三菩阿惟三佛。佛言。云何须菩提。阎浮利人民。及四面蜎飞蠕动悉令作人。各各得人道已。皆令求阿耨多罗三耶三菩。以发意索佛道。各各尽寿作布施。持是布施施与作阿耨多罗三耶三菩。于须菩提意云何。是菩萨摩诃萨作是布施。其福宁多不。须菩提言。甚多甚多天中天。佛言。不如是菩萨摩诃萨得般若波罗蜜已守一日。正使最后守一日。如般若波罗蜜中教。作是念行。其福过彼上。或时菩萨摩诃萨得般若波罗蜜已。如是法作是念行。是都卢于众中极尊。何以故。其余人无有能及是慈者。舍诸佛。是菩萨摩诃萨无有与等者。是善男子深入知中晓了。是智悉具足。悉见世间勤苦者。尔时极大愍伤。念眼彻视见不可计人民。悉具足无有懈时。用不懈故得是行。当尔时极大感念。悉念萨和萨。不用是相住。亦不用余住是所。须菩提。菩萨摩诃萨其智极大明。虽未作阿耨多罗三耶三菩。明如是。随是行一切刹土皆共尊举。正上阿耨多罗三耶三菩。终不逮。若受人衣被饮食床卧具医药悉具足。是般若波罗蜜者。心在其中立。所受施悉除去近萨芸若。如是须菩提。菩萨摩诃萨所啖无有罪益。于萨和萨悉示道径。无有边。无有极处。悉明照诸在牢狱中者。悉欲度脱。萨和萨悉欲示眼。是般若波罗蜜中法。当念行。当随是教。用是念行。是般若波罗蜜有入中者。不动行。不摇行。何以故。随是不动摇行莫念想。莫得作异念持短入般若波罗蜜中。当作是行。昼夜入般若波罗蜜中莫懈止。譬若须菩提男子得摩尼珠。前时未得。却后得是摩尼珠。欢欣踊跃。得是摩尼珠已。却后复亡之。用是故大愁毒。坐起忧念想如亡七宝。作是念。云何我直亡是珍宝。如是须菩提。菩萨摩诃萨欲索珍宝者。常当坚持心无得失萨芸若。常当入是中念。须菩提白佛言。设使所念用身亡乎。云何菩萨摩诃萨念萨芸若不亡。佛语须菩提。设是菩萨摩诃萨作是知无为。不失般若波罗蜜。何以故。须菩提。般若波罗蜜虚空。是般若波罗蜜亦不增亦不减。须菩提言。是般若波罗蜜虚空。云何生菩萨摩诃萨。般若波罗蜜成就其行。近阿耨多罗三耶三菩。佛言。不也须菩提。菩萨摩诃萨亦不增亦不减。正使须菩提。是经中说时。菩萨摩诃萨闻是亦不恐亦不怖。当作是知。是善男子则为行般若波罗蜜。须菩提白佛言。如是般若波罗蜜为空行乎不。须菩提。有离般若波罗蜜行得不。须菩提。空行不。须菩提。离空行不。须菩提。败色行不。须菩提败痛痒思想生死识行不。须菩提。离色颇所有行不。须菩提。离痛痒思想生死识颇所有行不。须菩提言。云何天中天行般若波罗蜜。佛言。云何须菩提。见是法不。何所法行般若波罗蜜。须菩提言。不见也天中天。佛言。云何须菩提。遍见不。见般若波罗蜜。何所菩萨摩诃萨行。须菩提言。不见也天中天。佛言。设使须菩提。遍见不。是菩萨摩诃萨行般若波罗蜜。须菩提言。不见也。天中天。佛言。设使须菩提。不遍见法。有所生处不。须菩提言。不见也天中天。佛语须菩提。是菩萨摩诃萨逮无所从生法乐。如是乐悉具足。无所从生受决阿耨多罗三耶三菩。是怛萨阿竭阿罗诃三耶三佛所至处。无所复畏。悉作是护。菩萨摩诃萨作是求。作是行。作是力。为逮佛慧。极大慧。自在慧。萨芸若慧。怛萨阿竭慧。设见不得佛。佛语为有异。须菩提白佛言。设使诸法无所从生受决阿耨多罗三耶三菩。佛语须菩提不也。须菩提白佛言。云何菩萨摩诃萨得阿耨多罗三耶三菩。佛语须菩提。见不。所当受决阿耨多罗三耶三菩。须菩提言。我不见法当作阿耨多罗三耶三菩。佛言。如是须菩提。如是诸法。无无从中得菩萨不作是念。持是法当受决不受决

道行般若经卷第七道行般若经卷第八

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜释提桓因品第二十

释提桓因。于众中白佛言。甚深般若波罗蜜。难了难知。是人民功德不小闻是深般若波罗蜜书者持者学者。佛语释提桓因。云何拘翼。阎浮利人民。是都卢皆持十戒悉具足。其功德宁多不。持是功德。百倍千倍万倍。亿万倍巨亿万倍不如是善男子善女人闻是般若波罗蜜书持学者。时坐中有一异比丘语释提桓因。出拘翼上去已是善男子善女人功德乎。释提桓因报是比丘言。持心一反念。出我上去已。何况闻般若波罗蜜书持学者。闻般若波罗蜜以随是法。随是法教作是立。都卢出诸天阿须伦世间人民上。都卢于诸天阿须伦世间人民中极尊。菩萨摩诃萨行般若波罗蜜。不独过诸天阿须伦世间人民上也。乃至须陀洹斯陀含阿那含阿罗汉辟支佛都复过是上。菩萨摩诃萨行般若波罗蜜。不独过阿罗汉辟支佛上也。亦复至菩萨行檀波罗蜜。设无般若波罗蜜。无沤和拘舍罗。亦复过是上。不独过檀波罗蜜。亦复乃至尸波罗蜜。羼提波罗蜜。惟逮波罗蜜。禅波罗蜜。菩萨摩诃萨失般若波罗蜜。失沤和拘舍罗。亦复过是上去。菩萨摩诃萨行般若波罗蜜。正使菩萨摩诃萨狎习般若波罗蜜中行。都卢合会诸天诸阿须伦诸世间人民。终不得胜是菩萨摩诃萨。行般若波罗蜜菩萨摩诃萨。如中所狎习般若波罗蜜。作是坚持。是菩萨摩诃萨疾近萨芸若。是菩萨摩诃萨离怛萨阿竭名不远。是菩萨摩诃萨如是护。离佛坐不远。是菩萨摩诃萨所有懈怠不复生。是菩萨摩诃萨作是学为学佛。不学阿罗汉法。不学辟支佛法。当作是学菩萨摩诃萨。四天王当作问讯言疾学是。四部弟子当作所度。当于佛座上坐。作阿耨多罗三耶三菩。作是学菩萨摩诃萨。四天王常自往问讯。何况余天子。怛萨阿竭阿罗呵三耶三佛当念。菩萨摩诃萨行般若波罗蜜。当作是行。菩萨摩诃萨般若波罗蜜。或时世间所有勤苦之疾。是身了无有怨。是为菩萨摩诃萨般若波罗蜜。阿难作是念。是释提桓因。自持智说耶。持佛威神说乎。释提桓因知阿难心所念。语阿难言。持佛威神。我所说乎。佛言。如是阿难。持佛威神。释提桓因所说乎。正是忠阿难。或时菩萨摩诃萨。深念般若波罗蜜。行般若波罗蜜行。学般若波罗蜜。当是时三千大千国土中弊魔。一切心中皆愁毒欲共坏乱是菩萨摩诃萨。自共议言。当何以使是菩萨便中道取证阿罗汉辟支佛道。莫使成作佛

    摩诃般若波罗蜜道行经贡高品第二十一

佛语阿难。菩萨随时欲学般若波罗蜜。随法欲行般若波罗蜜。是时一佛界中魔。各各惊自念言。欲使菩萨中道得阿罗汉果。莫疾使得阿耨多罗三耶三菩疾使得佛。复次阿难。弊魔愁毒为忧。见菩萨习行于般若波罗蜜。复次阿难。是时诸弊魔四面放火风。恐怖是菩萨。若令畏惧。衣毛当起。使心一反乱念转复。佛语阿难。魔不遍行乱菩萨。若有行乱者。有不行乱者。阿难白佛言。何等菩萨为魔所乱。佛语阿难。若有菩萨闻深般若波罗蜜不乐者。弊魔便行住坏。复次阿难。若有菩萨闻深般若波罗蜜心狐疑者。自念若有无有耶。如是

阿难。菩萨为弊魔所得便。复次阿难若有菩萨远离于善师。是菩萨所闻般若波罗蜜深事不欲闻也。亦不了也。亦不知也。何因守般若波罗蜜。用是故阿难。是菩萨弊魔所得便者。复次阿难。若有菩萨与恶师从事。用是故。弊魔得菩萨便。是菩萨言。正是我所喜师也。当成我所愿。余多有菩萨非我善厚也。用是故。弊魔便复得菩萨。复次阿难。闻是深般若波罗蜜时。教余菩萨。用是为学。用是为写我尚不了其事。汝能了耶。若有时菩萨与异菩萨。转相轻易言。我所行是也。汝所行非也

尔时诸弊魔欢欣踊跃。是时弊魔便作异被服像来。叹菩萨言。汝于某国生某种姓家。是菩萨闻是语。便轻易余成就不贡高菩萨。是贡高菩萨功德薄少。无阿惟越致相也。是菩萨于阿惟越致中功德少。自贡高轻余菩萨言。卿不及我所行。用是故。弊魔大欢欣言。今泥犁禽兽薜荔堕者不少。弊魔当复增其念。所语所说。多有信用者。闻之者无不随其言者。作是学者嗔恚益增。心所作为颠倒。用是故。身口心所作为轻反。用是故。其人在泥犁禽兽薜荔中罪益增。用是故。弊魔大欢欣踊跃无有极。若求菩萨道家。与求罗汉道人共诤。尔时弊魔自念。菩萨离萨芸若远离远亦不大远。菩萨又与菩萨共诤。尔时弊魔念言两离佛远。佛语阿难。未得阿惟越致菩萨。与阿惟越致菩萨共诤。骂詈阿惟越致菩萨。是菩萨骂以随心所念转怀怨恨。心一转念听却一却菩萨虽有是恶念。不舍萨芸若却无数劫极甫当更复从发意起。阿难白佛言。心所念恶宁可得中悔不。当乃却就尔所劫乎。佛语阿难于我法中。广大极可得悔。佛语阿难若有菩萨念恶有恨。自欢欣复语他人。是人不可复使悔也。若有菩萨若骂詈嗔恨自念。咄我所作无拔。后终不敢复作是。复自考责人道难得。用是故。悉当忍于人。何况乃当与人共诤言乎。我当为十方人作桥令悉蹈我上度去。我有是意。宁当复与人共诤耶。住立当如聋羊。诸恶悉当忍。诸恶心不当犯。我作佛时悉当安十方人得般泥洹。我不复与人共诤嗔恚于人。为用罗汉道故。阿难白佛言。菩萨菩萨自相与共止。法当云何。佛语阿难。菩萨菩萨转相视。当如视佛。心念言共一师。共一船共一道。是所学我亦当学。如是若有余菩萨欲喜学罗汉辟支佛道。若与从事。设有是人者我不与从事。其有世世欲求佛道者。当与相随如是学。为共一法学

    摩诃般若波罗蜜道行经学品第二十二

须菩提白佛言。菩萨学无常为学萨芸若。学无所生为学萨芸若。学去离淫为学萨芸若。学灭为学萨芸若。佛语须菩提。汝所问。学无常为学萨芸若者。于须菩提意云何是怛萨阿竭本无随因缘得怛萨阿竭。本无字宁有尽时不

须菩提白佛言。不。佛言不。佛语须菩提。为学萨芸若。如是学为学般若波罗蜜。如是学为学怛萨阿竭陀。为学力。为学无所畏。为学诸佛法。菩萨学如是者。悉行诸学法。菩萨摩诃萨作是学魔及魔官属不能中道坏。菩萨如是学。为疾得阿惟越致。菩萨如是学者。为疾近佛树下坐。菩萨如是学。为悉学佛道菩萨如是学。为习法也。菩萨如是学。为极大慈哀。如是为学等心菩萨。学如是三合十二法轮为转。菩萨学如是。为学度灭十方天下人。菩萨学如是。为学甘露法门。佛语须菩提。不懈怠人乃能学是。作是学为学十方天下人道菩萨学如是者。不入泥犁禽兽薛荔中。菩萨学如是。终不生边地。如是学不复生愚痴贫穷中。如是学不复盲聋喑痾欧。如是学为不毁十戒。如是学为不随解除卜问。如是学远离不持戒人。菩萨如是学。不愿生尼惟先天上。何以故。菩萨有沤和拘舍罗故。般若波罗蜜。何等沤和拘舍罗。从般若波罗蜜中出沤和拘舍罗。持沤和拘舍罗。灭神入禅不随禅法。菩萨学如是。为得净力为得无所畏力。为得佛法净力。须菩提白佛言。佛所有诸法本皆净。何等为菩萨得法净。佛语须菩提。菩萨学如是。为学无所得净法诸法净。如是须菩提。菩萨行般若波罗蜜时不悔不厌。是为行般若波罗蜜。未得道者愚痴不晓是法。不见是事。菩萨用人故常精进。人见我亦当效我精进。用是故。菩萨得力精进无所畏。菩萨作是学。悉知十方天下人心意所念。无能过者。譬如地出金银少所处出耳。如是须菩提少所人随般若波罗蜜法教学。譬若须菩提少所人索遮迦越罗处。索小国王多。如是须菩提。少所人随般若波罗蜜法教学。从是中多索阿罗汉辟支佛者。有初发意菩萨。少有随般若波罗蜜教者。既有学般若波罗蜜。少有得阿惟越致者。菩萨当作是念。我当力学慕及阿惟越致。复次须菩提行般若波罗蜜。不持嗔恚意向人。不求他人短。心无悭贪。心不毁诫。心不怀恨。心不懈。心不迷乱。心不愚痴。时菩萨学般若波罗蜜时。诸波罗蜜皆悉属。学般若波罗蜜为照诸波罗蜜。为悉入诸波罗蜜。学般若波罗蜜。为具足余波罗蜜。譬如人言是我所便外着十二品。如是须菩提。菩萨学般若波罗蜜皆悉属。譬如须菩提人死时命尽身诸根悉灭。如是须菩提。菩萨学般若波罗蜜。为学诸波罗蜜皆悉属。菩萨欲学度诸波罗蜜。当学般若波罗蜜。菩萨欲学般若波罗蜜。为学无极。于须菩提意云何。一佛界中所有人宁多不。须菩提报佛言。甚多。佛言。若有菩萨供养一佛界中乃尔所人。供养自尽寿命。其福宁多不。须菩提白佛言。甚多。佛语须菩提。不如菩萨守般若波罗蜜如两指相弹顷。佛语须菩提。般若波罗蜜极尊。用是故疾得佛。如是须菩提。菩萨欲得阿耨多罗三耶三菩为十方人中独尊。给施十方贫穷孤独者。欲求佛境界者。欲得佛智慧所乐者。欲得如师子独鸣者。欲得佛处者。悉欲得是者当学般若波罗蜜。菩萨学般若波罗蜜者。为悉学余法。须菩提白佛言。菩萨为复学阿罗汉法耶。佛语须菩提。虽知阿罗汉法不乐行不学阿罗汉所作功德。云何当得也。阿罗汉所行菩萨悉知。不学不行不于中住。菩萨作是学。天上天下无有能过者。悉过阿罗汉辟支佛上。如是为近萨芸若。菩萨作是学。不离般若波罗蜜远也。为行般若波罗蜜。菩萨作是学。于萨芸若法中不增不减。离阿罗汉辟支佛道。菩萨若复作是念。持是般若波罗蜜。当得萨芸若。有小想为不行般若波罗蜜。亦不有般若波罗蜜之相。当持得萨芸若。亦无念。亦无见。亦无所想。是为行般若波罗蜜

    摩诃般若波罗蜜道行经守行品第二十三

是时释提桓因在大会中坐。作是念。菩萨行十方天下人无有能过者。何况自到至佛乎。十方人道难得。既得寿为安隐有一发意行佛道者难得。何况至心行佛道者乎。欲为十方天下人作导首。是人难得。是时释提桓因化作文陀罗华。取持散佛上。散已作是说行菩萨道者乃向佛道乎。所愿悉成。为近为悉护作是行者。为悉成佛。诸经法萨芸若经法。怛萨阿竭经法。悉具足。阿惟越致经法亦尔。释提桓因言。人有至心索佛。于是法中一反念终不远。释提桓因言。我欲使人于法中益念不厌生死之苦。一切天上天下为苦。用人故悉当忍勤苦之行。心作是念。诸未度者悉当度之。诸未脱者悉当脱之。诸恐怖者悉当安之。诸未般泥洹者悉皆当令般泥洹。释提桓因问佛言。新发意菩萨劝人助其欢欣。得何等福。随次第上菩萨劝人助其欢欣。得何等福。乃至阿惟越致上至阿惟颜。劝人助其欢欣。得何等福。佛语释提桓因。须弥山称之尚可知斤两。从劝助代初发意菩萨欢欣。其福不可量。佛语释提桓因。一佛境界尚可称知斤两。阿阇浮菩萨行劝人助其欢欣。其福无有科限。佛语释提桓因。一佛境界中诸海所有水取一发破为百分从中取一分。以一分之发取海水尽。尚可数知几渧。阿惟越致菩萨行劝人助其欢欣。其福不可数。佛语释提桓因。阿僧祇佛刹所有境界虚空。持一斛半斛。一斗半斗。一升半升。尚可量空知几所。阿惟颜菩萨行劝人助其欢欣。其福不可极释提桓因白佛言。为魔所乱闻是不助欢欣。魔官属人闻是不助欢欣者。从魔天上来下。闻是不助欢欣者。何以故。若有意索佛者。为怀魔境界也。有发意索佛者。当助其欢欣。是为怀魔境界。心不离佛。不离经。不离比丘僧。如是当助其欢欣。佛语释提桓因。如释提桓因所言。助其欢欣者为近佛。用是助欢欣之功德。世世所生处。为人共欲得供养。未尝有闻恶声时。不恐当归三恶道。常生天上在十方常尊。何以故。如是人助菩萨欢欣者。为悉施护十方人。何以故。初发意菩萨稍增自致至佛。成就作佛已。当度脱十方天下人。须菩提白佛言。心譬如幻。何因当得佛。佛语须菩提。于须菩提意云何。汝宁见幻不。须菩提言不。化幻亦不见。幻心离。化幻离。幻心虽离。是见异法。当得佛道不须菩提白佛言不见亦不离化幻。离幻心。亦不见当得佛。亦无法。亦无见。当说何等法耶得不得乎。是法本无远离。亦本无若得若不得。本无所生。亦无有作佛者。设无有法。亦不得作佛。须菩提白佛言。设尔般若波罗蜜离本无对法。离本亦无对亦无证。亦无守。亦无行。亦无有法当有所得。何以故。离般若波罗蜜本无形故。本无远离。何因当于般若波罗蜜中得佛。佛者离本无所有。何所本无所有当得佛者。佛语须菩提。如须菩提所言离。今般若波罗蜜无所有。离本萨芸若无所有。佛语须菩提。虽离般若波罗蜜本。本亦无所从生须菩提。当作是思惟。深入守是故离本无所有得作佛。佛语须菩提。虽知离本般若波罗蜜无所有。是为不守般若波罗蜜。不具足行般若波罗蜜者。不得作佛也。佛言。如须菩提所言。不用得般若波罗蜜故得佛也。亦不用离。无离得作佛。亦不可离般若波罗蜜得作佛。不得般若波罗蜜者。不得作佛。须菩提白佛言。菩萨行般若波罗蜜甚深难及。佛语须菩提。汝所言。菩萨行般若波罗蜜甚深难及。菩萨所言。勤苦行。深奥之法。不在取泥洹须菩提白佛言。如是所说事。菩萨不为勤苦行。何以故。亦无有作证者。亦无般若波罗蜜中得证者。亦无有经法得作证者。菩萨闻是。不恐不怠不难。是为行般若波罗蜜。虽作是行。亦不见行。是为行般若波罗蜜。虽近佛亦不见。是为行般若波罗蜜。远离罗汉辟支佛。亦不见亦不念。是为行般若波罗蜜。譬如空中无念若有近若有远。何以故。空本无有形故。行般若波罗蜜。无有离佛远离佛近。何以故。般若波罗蜜无有形故。譬如幻师作化人。化人不作是念。师离我近。观人离我远。何以故。化人无有形故。般若波罗蜜亦如是。不作是念。罗汉辟支佛道离我远。佛道离我近也。何以故。般若波罗蜜无有形故。譬如影现于水中。不作是念。何因影现于水中。若所有近者不念言近。若远者亦不念言远。何以故影无有形故。般若波罗蜜如是。亦无是念。罗汉辟支佛道为远耶。佛道为近乎。何以故。般若波罗蜜无有形故。般若波罗蜜。敌无所爱。敌无所憎。怛萨阿竭所有。无所著无所生。般若波罗蜜亦如是。亦无所生亦无所著。譬如怛萨阿竭化作人。不作是念。罗汉辟支佛道离我远。亦不言佛道离我近。何以故。化人无有形故。般若波罗蜜亦不作是念。罗汉辟支佛道离我远。亦不念佛道离我近。何以故。般若波罗蜜无有形故。譬如工匠黠师克作机关木人。若作杂畜木人。不能自起居。因对而摇。木人不作是念言。我当动摇屈伸低仰令观者欢欣。何以故。木人本无念故。般若波罗蜜亦如是。随人所行悉各自得之。虽尔般若波罗蜜亦无形亦无念。譬如造作海中大船。所以者何作欲度贾客。船亦不作是念言。我当度人。何以故。船本无念故。般若波罗蜜亦如是。随人所行悉各自得之。般若波罗蜜亦无形亦无念亦如是。譬如旷野之地万物百谷草木皆生其中。地亦不作是念言。我当生也不生也。般若波罗蜜生诸经法。亦不念言。从中生与不生。何以故。般若波罗蜜本无形故。譬如摩尼珠悉出其宝。般若波罗蜜悉出其经法分别教授。虽尔般若波罗蜜亦无念。譬如日照于四天下。其明亦不念言。我当悉照。般若波罗蜜悉照诸经法虽尔般若波罗蜜亦无念。譬如水无所不至。水亦不作是念言。我当有所至。般若波罗蜜悉至诸经法。虽尔般若波罗蜜亦无念。譬如风无所不至。风亦不作是念言。我当有所至。般若波罗蜜成就诸经法亦如是虽尔般若波罗蜜。亦无念。譬如须弥山巅以忉利天为庄饰。须弥山亦不作是念言。我当上治忉利天庄严。般若波罗蜜成就萨芸若。虽尔般若波罗蜜亦无念。譬如大海悉出诸珍琦宝物。海水不作是念言。我当从中出珍宝。般若波罗蜜悉出生诸经法亦如是。虽尔般若波罗蜜亦无念。譬如佛出生诸功德。悉覆辈等心加于十方人。般若波罗蜜成就于诸经法亦如是

    摩诃般若波罗蜜道行经强弱品第二十四

舍利弗问须菩提言。菩萨摩诃萨行般若波罗蜜。为高行耶。须菩提报言。我从佛所闻事。菩萨摩诃萨行般若波罗蜜为无高行也。若干百千爱欲诸天。作是念。当为十方人发意为菩萨道者作礼。何以故。行般若波罗蜜。不中般泥洹故。如是菩萨为勤苦行。不于是法中堕落取证。须菩提语诸天言。虽不中道堕落取证。是不为勤苦勤为十方不可计阿僧祇人被法铠。度令得泥洹是。乃为勤苦之难。是人本无。本无索不可得也。如是菩萨作是念。为欲度人。度十方人为欲度空。何以故。空亦无有远。亦无有近。亦无所有。用是以菩萨勤苦行。索人本无有。欲度人为度虚空被德铠。用人故被德铠欲过度人。是故菩萨为被德铠。如佛所说。人无有本晓知人本无所有。是为度人。菩萨闻是不恐不怖。是为行般若波罗蜜。离人本无本。无离色本无色。离痛痒思想生死识本无识。离诸经法本无诸经法。菩萨闻是不恐不懈。是为行般若波罗蜜。佛语须菩提。何因菩萨不恐不懈。须菩提白佛言。本无故不恐。本净故不懈。何以故。索懈怠本本无有所因懈亦复无有。菩萨闻说是不懈不恐不怖。是则为行般若波罗蜜。菩萨行是时。诸天皆为作礼。诸梵天皆为作礼。佛语须菩提。不但诸天诸梵天为菩萨作礼。上至阿会亘彼立。阿波摩那。阿会波罗。及上至阿迦腻吒诸天。皆为行般若波罗蜜菩萨作礼十方不可复计阿僧祇现在诸佛。悉念行般若波罗蜜菩萨悉共拥护。知是行般若波罗蜜菩萨阿惟越致。恒边沙佛刹其中所有人。悉使为魔。一魔者化如恒边沙人。悉使为官属。设使尔所魔各各乃尔所官属。欲共害行般若波罗蜜菩萨。不能中道坏。不能中道得便。菩萨有二事法行般若波罗蜜魔不能中道使得便。何谓二事。一者诸经法视皆空。二者不舍十方人悉护。是为二事。菩萨有二事诸魔不能动。何谓二事。一者不失本愿。二者十方诸佛悉护视。是为二事。菩萨行般若波罗蜜时。诸天往至菩萨所。问讯深经之事。诸天赞叹善之。今作佛不久当随是法教立。既随是法教立者。诸有困苦者皆得护。诸未得归者为得自归为人故作法舍。无目者。使得黠目。随是般若波罗蜜法教立者。十方不可复计阿僧祇现在诸佛。悉共拥护行般若波罗蜜者。诸佛各各于其刹四部弟子中。说是菩萨功德。各各赞叹善之。佛语须菩提。譬若我今赞叹说罗麟那杖那佛。佛复言。今我刹界中菩萨行般若波罗蜜。十方诸佛今亦赞叹说行般若波罗蜜菩萨。亦复如是。须菩提白佛言。诸佛悉赞叹诸菩萨如是耶。佛言。不赐赞叹。佛语须菩提。有行菩萨道未得阿惟越致者。诸佛亦复赞叹。须菩提复问佛。何等为行菩萨道为佛所赞叹。佛语须菩提。有菩萨随阿閦佛前世为菩萨时所行。及罗麟那杖那佛前世为菩萨时所行。有菩萨随是教。用是故。十方诸佛赞是菩萨。复次须菩提。菩萨摩诃萨行般若波罗蜜。诸经法信本无所从生。是菩萨尚未得无所从生法乐。于中立信。诸法本空。是菩萨尚未得阿惟越致信诸经法本无如泥洹。是菩萨尚未得入阿惟越致地。随是法教立。疾得阿惟越致。有应是法行者。是故十方诸佛共赞叹是菩萨。菩萨为度阿罗汉道地辟支佛道地。向佛道地。若有菩萨应般若波罗蜜行者。为诸佛所赞叹。知是菩萨不久在阿惟越致道地立

复次须菩提。菩萨闻深般若波罗蜜。信不狐疑菩萨作是念。如佛所说谛无异。是菩萨却后当复于阿閦佛所。闻是般若波罗蜜。及余菩萨所闻亦复尔。作是信般若波罗蜜者。以为在阿惟越致地立。若有闻般若波罗蜜信者。其德甚大不小。何况菩萨随般若波罗蜜法教立者。随是法教立者。为疾入萨芸若

须菩提白佛言。设离本本无法不得。何所法有作佛者。何所法说有说经者。佛言。如须菩提所言。设离本本无法不得。何所法有作佛者。亦无有法说经者。是本无无本。何所有于本无中立无者。有本无有当得佛者。亦无有本法有作佛者。本无无有。说经者亦不可得。释提桓因白佛言。般若波罗蜜甚深。菩萨勤苦行乃自致成佛。何以故。无有字法无所得在本无中立者。亦无有法当作佛者。亦无有说经者。菩萨闻是不恐不怖不疑不厌。须菩提语释提桓因言。如释提桓因所言。菩萨勤苦闻深般若波罗蜜。信不狐疑不厌。须菩提报释提桓因言。拘翼。诸经法皆空。何所有狐疑厌者。释提桓因语须菩提言。如须菩提所说。一切为说空事。为悉无所著。譬如射虚空了无所著。须菩提所说经亦如是了无所著。释提桓因白佛言。如我所说。为随佛法教耶。为有增减乎。佛语释提桓因。拘翼。如佛所说法教等无异。如须菩提所说但说空事。须菩提。亦不见般若波罗蜜者。亦不见行般若波罗蜜者。亦不见得佛者。亦不见萨芸若。亦不见得萨芸若者。亦不见怛萨阿竭。亦无有得怛萨阿竭者。亦不见无所从生。亦不见无所从生证得之者。亦不见十种力。亦无有索十种力者。亦不见四无所畏。亦不见索四无所畏者。经法本净亦无所得。须菩提。随无所得教立。如是须菩提。随无所得教立者。是菩萨为行般若波罗蜜。百倍千倍万倍。须菩提。菩萨行般若波罗蜜者。舍置佛道地。众罗汉辟支佛道地。不及是菩萨道地。欲为十方天下人持尊。当随佛法教立如是。是时忉利天上数千万天。持化作文陀罗华散佛上。散已作是说。诸天言。我曹亦当随法教立。时坐中百六十比丘。起整衣服为佛作礼。作礼已。各各手中有化文陀罗华。持是华散佛上。散已作是说。我曹亦当随法教立。是时佛笑。口中出若干色。其明至十方佛刹悉为明。其明还绕佛三匝从顶上入。阿难从坐起整衣服。为佛作礼长跪问佛。佛不妄笑。既笑当有意。佛告阿难。是百六十比丘及诸天。当于是波罗劫中作佛。皆同一字。字沤辰那拘尼摩。作佛时比丘僧数各各等。寿命亦各各等。其寿各十万岁随次稍稍作佛。作佛时各各尽世。雨五色华

道行般若经卷第八道行般若经卷第九

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜累教品第二十五

佛语阿难。作是立者。无有能过菩萨。作是立为如佛立。作是立无有为作师者。是为萨芸若立。欲作是立者。当随般若波罗蜜教。有应是般若波罗蜜行者。当知是人从人道中来。或从兜术天上来。是人或从人道中闻般若波罗蜜。或从兜术天上闻。或从人道中行。或从兜术陀天上行。何以故。佛般泥洹后。般若波罗蜜若于十方见。若于兜术天上见。有行是般若波罗蜜若书者。诸佛悉视护之。是菩萨复转教人。劝乐合偶。知是菩萨供养若干佛以来。不于罗汉辟支佛品中作功德。知是菩萨供养若干佛以来。学是般若波罗蜜不恐不怖。若有受般若波罗蜜。若有学。若有持。若有解中事。若有随。知是菩萨如面见佛无异。是菩萨不止亦不诽谤般若波罗蜜。知是菩萨供养若干佛以来。佛语阿难。虽有人于佛所作功德持用求罗汉辟支佛。会当得佛无异。若有菩萨摩诃萨行般若波罗蜜。常当远离罗汉辟支佛道。佛语阿难。持是般若波罗蜜嘱累汝。阿难。我为汝所说经。舍置般若波罗蜜摩诃沤和拘舍罗及诸摩诃惟曰罗。我每所说余经汝所受。说令悉散悉亡。虽有是其过少耳。汝所从佛受般若波罗蜜。设散设亡其过甚大不小。佛语阿难。复嘱累汝般若波罗蜜。受学持法。当谛学。悉具足受。悉念持书。字令正无缺减。过去当来今现在。佛经身等无异。阿难。当作是念。般若波罗蜜莫使缺减。何以故。今佛现在。有慈心佛恩德。欲报佛恩具足供养者。汝设有慈心于佛者。当受持般若波罗蜜。当恭敬作礼供养。设有是行。汝悉为供养佛报恩以汝为恭敬过去当来今现在佛已。汝慈孝于佛。恭敬思念于佛。不如恭敬于般若波罗蜜。慎莫亡失一句。佛语阿难。嘱累汝般若波罗蜜以为信。若有不欲离于佛离于经离于比丘僧。亦不欲离于过去当来今现在佛者。不当远离般若波罗蜜。是佛所教。佛语阿难。若有受般若波罗蜜持护。是为持过去当来今现在佛教法。何以故。过去当来今现在佛。皆从般若波罗蜜出生。菩萨欲得佛道者。当学六波罗蜜。何以故。六波罗蜜是诸菩萨摩诃萨母。佛语阿难。嘱累汝六波罗蜜。六波罗蜜者。佛不可尽经法之藏。过去当来今现在佛。皆从六波罗蜜出生。佛语阿难。汝日日教人。尽一佛境界中人。汝悉教令得阿罗汉道。虽有是教尚未报佛恩。不如具足为菩萨说般若波罗蜜。汝所教人悉使得阿罗汉。此所作功德。持戒精进守道。虽教乃尔所人。其福宁多不。阿难报佛言。甚多天中天。佛语阿难。不如持般若波罗蜜具足为菩萨说。虽不能多。一日可。虽不能一日。食时可。虽不能食时。为说须臾间可。其福胜度尔所阿罗汉。菩萨摩诃萨自于般若波罗蜜。念思惟其中事。菩萨虽思惟其中事。得其功德出众阿罗汉辟支佛上去。虽思惟其中事。会当得阿惟越致。设不中道还。说般若波罗蜜时。四部弟子。及诸天阿须伦及鬼神。一佛境界中。持释迦文佛威神。一切悉见阿閦佛。及见诸比丘不可计皆阿罗汉。诸菩萨亦无央数以后不复见。佛语阿难。譬如见国中人不复见。阿閦佛及诸菩萨阿罗汉。诸经法索眼不见亦如是。法不见法。法不念法。何以故。诸经法无念不见。亦无所益。佛语阿难。诸经法皆空。无所持。亦不可念。譬如幻师化作人。诸经法亦如是。无念亦无痛。何以故。无形故。菩萨作是行为行般若波罗蜜。作是学为学般若波罗蜜。悉欲得六波罗蜜者。当学般若波罗蜜。作是学在诸学中最尊无有及者。百倍千倍万倍。是为安十方天下作是学者。困厄苦者悉护视。是为随佛法学。是为随佛教有应学是者。持手举一佛境界。移着还复他方刹土以。其处人无有觉知者。佛语阿难。佛从是般若波罗蜜中学成。过去当来今现在佛。无所挂碍指智慧法。悉从般若波罗蜜具足成。欲得般若波罗蜜限者。为欲得虚空限何以故。般若波罗蜜不可尽。十方之事可计。般若波罗蜜事不可计。佛告阿难。般若波罗蜜事不可计不可尽。般若波罗蜜本净。何以故。过去不可复计佛悉从其中成就得佛。般若波罗蜜亦不增亦不减。甫当来不可复计佛悉从般若波罗蜜成就得佛。般若波罗蜜亦不增亦不减。十方今现在不可复计佛悉从般若波罗蜜成就得佛。般若波罗蜜亦不增亦不减。是故般若波罗蜜不可尽。虚空亦不可尽

    摩诃般若波罗蜜道行经不可尽品第二十六

是时须菩提作是念。佛所说般若波罗蜜事甚深。是须菩提当作是问。须菩提白佛言。般若波罗蜜不可尽。譬如虚空亦不可尽。菩萨当何因思惟般若波罗蜜。佛语须菩提。色不可尽。当作是思惟。般若波罗蜜。痛痒思想生死识不可尽。当作是思惟。般若波罗蜜。十二因缘不可尽。当作是思惟。般若波罗蜜。佛语须菩提。菩萨当作是思惟。般若波罗蜜。菩萨当作是思惟。十二因缘适得其中。菩萨初坐树下时。不共法思惟十二因缘。是时萨芸若智慧悉具足。佛语须菩提。若有菩萨行般若波罗蜜时。思惟十二因缘不可尽。作是思惟者。出过罗汉辟支佛道去。正住佛道。菩萨不作是思惟。行般若波罗蜜。及思惟十二因缘不可尽。设不作是思惟者。便中道得罗汉辟支佛。菩萨不中道还者。用思惟般若波罗蜜。思惟行摩诃沤和拘舍罗故。佛语须菩提。菩萨行般若波罗蜜时。思惟视十二因缘不可尽。作是视十二因缘。所视法生者灭者皆有因缘。法亦无有作者。作是思惟十二因缘。行般若波罗蜜时。不见色。不见痛痒思想生死识。不见佛境界。无有所因法。见佛境界。是为菩萨行般若波罗蜜。若有菩萨行般若波罗蜜。当尔时魔大愁毒。譬如父母新死啼哭愁毒忧思。菩萨行般若波罗蜜时。魔愁毒如是。须菩提白佛言。一魔愁毒耶。余魔复愁毒乎。佛语须菩提。一佛境界所有魔。各各于。其所止处不安。菩萨随般若波罗蜜教时。菩萨应行如是者。诸天阿须伦龙鬼神人若非人。不能害菩萨。若有菩萨欲得佛道者。当行般若波罗蜜。菩萨行般若波罗蜜。为行檀波罗蜜。具足行尸波罗蜜亦尔。行羼提波罗蜜亦尔。行惟逮波罗蜜亦尔。行禅波罗蜜亦尔。菩萨摩诃萨行般若波罗蜜。具足行沤和拘舍罗波罗蜜。菩萨摩诃萨行般若波罗蜜。若有魔事起。即觉使不至。菩萨悉欲得诸沤和拘舍罗波罗蜜者。当行般若波罗蜜。当守般若波罗蜜。若有菩萨行般若波罗蜜。守般若波罗蜜

尔时菩萨思惟十方不可计阿僧祇现在诸佛诸佛本行菩萨道时。悉从般若波罗蜜出生。菩萨作是念如诸佛悉得诸经法。我悉当得。如是菩萨行般若波罗蜜时。作是思惟念。如两指相弹顷。若有菩萨布施具足如恒边沙劫。不如是菩萨行般若波罗蜜如弹两指顷。菩萨如是行者。为住阿惟越致地。是菩萨为诸佛所念。菩萨终不还余道。会当得佛。终不归三恶道。是菩萨未曾离诸佛时。行般若波罗蜜菩萨。如两指相弹顷间。功德如是。何况一日守般若波罗蜜者。行当如是揵陀诃尽菩萨。揵陀诃尽菩萨。在阿閦佛刹最尊第一

    摩诃般若波罗蜜道行经随品第二十七

须菩提白佛言。菩萨何因随般若波罗蜜教。佛语须菩提。诸经法无有能坏者。菩萨随般若波罗蜜教。当如是。虚空不可尽。菩萨随般若波罗蜜教。当如是。五阴本无形。菩萨随般若波罗蜜教。当如是。四大本无形。菩萨随般若波罗蜜教。当如是。沙罗伊檀六事大虚空无形。菩萨随般若波罗蜜教。当如是。发心行佛道无有与等者。菩萨随般若波罗蜜教。当如是。发心行愿甚广大。菩萨等心于十方人无有极。佛有四事不护。各各异端无有极。菩萨随道般若波罗蜜教。当如是。菩萨为诸天阿须伦龙鬼神甄陀罗摩睺勒人及非人。作不可计之覆护。菩萨随般若波罗蜜教。当如是。十方天下人呼为是我所非我所悉断之。菩萨随般若波罗蜜教。当如是。虚空之中音响无形。菩萨随般若波罗蜜教。当如是。譬如大海水不可斗量。菩萨随般若波罗蜜教。当如是。譬如须弥山巅珍宝各各别异。菩萨随般若波罗蜜教。当如是。释梵各自有教。菩萨随般若波罗蜜教。当如是。譬如月盛满姝好。菩萨随般若波罗蜜教。当如是。譬如日明所照悉至。菩萨随般若波罗蜜教。当如是诸经法但有字耳。无有处所。菩萨随般若波罗蜜教。当如是。般若波罗蜜本无形但有字耳。菩萨随般若波罗蜜教。当如是般若波罗蜜本无所从生。菩萨随般若波罗蜜教。当如是。般若波罗蜜等无有异。菩萨随般若波罗蜜教。当如是幻化及野马但有名无形。菩萨随般若波罗蜜教。当如是地水火风是四事无有极。菩萨随般若波罗蜜教。当如是。佛身相本无色。菩萨随般若波罗蜜教。当如是。诸佛境界各各虚空。菩萨随般若波罗蜜教。当如是。佛诸经本无说无教。菩萨随般若波罗蜜教。当如是。譬如众鸟飞行空中而无足迹菩萨随般若波罗蜜教。当如是。生死根。波罗蜜力。诸觉禅。弃脱三昧定。入禅具足。悉脱爱欲。临作佛时乃得行是。菩萨随般若波罗蜜教。当如是。诸经法无有极不可尽。菩萨随般若波罗蜜教。当如是。诸经法无所从生。无所因出。菩萨随般若波罗蜜教。当如是。临作佛时诸经法悉具足成。菩萨随般若波罗蜜教。当如是。泥洹虚空无所有。菩萨随般若波罗蜜教。当如是。诸经法本无净适无所因。菩萨随般若波罗蜜教。当如是。佛所作为变化无有极。菩萨随般若波罗蜜教。当如是。一切无有索菩萨过者。亦无有得佛过者。脱无央数人。菩萨随般若波罗蜜教。当如是。诸佛说经法行道如是。菩萨随般若波罗蜜教。当如是。佛所教化等无有异。菩萨随般若波罗蜜教。当如是。佛语须菩提。若有菩萨行般若波罗蜜时。当作是随。当作是念。当作是入。当作是视。去离谀谄。去离贡高。去离强梁。去离非法。去离自用。去离财富。去离侥幸。去离世事。弃身不惜寿命。适无所慕。但念佛所行事安隐。菩萨行能如是者得佛不久。悉得萨芸若功德不久。如是辈菩萨不当字菩萨。当字为佛。何以故。今得佛不久故。若有菩萨随般若波罗蜜教。甫当来世为得佛字。佛在者亦当随般若波罗蜜教。佛般泥洹后亦当随般若波罗蜜教。当如是

    摩诃般若波罗蜜道行经萨陀波伦菩萨品第二十八

佛语须菩提。疾欲得佛者。索般若波罗蜜。当如萨陀波伦菩萨。于今在上方。过六百三十亿佛国。佛名揵陀罗耶。其国名尼遮揵陀波勿。萨陀波伦菩萨于彼间止。须菩提白佛言。萨陀波伦菩萨本何因缘索般若波罗蜜。佛语须菩提。乃往久远世有菩萨。名萨陀波伦。为前世施行功德所追逮。本愿所成。世世作功德所致。前世以供养数千万亿佛。时菩萨卧出。天人于梦中语言。汝当求索大法。觉起即行求索了不得。其意惆怅不乐。欲得见佛欲得闻经索之了不能得。亦无有菩萨所行法则。用是故。甚大愁忧啼哭而行。譬如人有过于大王所。其财产悉没入县官。父母及身皆闭在牢狱。其人啼哭愁忧不可言。萨陀波伦菩萨愁忧啼哭如是。时忉利天人来下在虚空中。观见菩萨日日啼哭。天人见菩萨至心啼哭。天人即于菩萨父母兄弟亲属交友中。字菩萨为萨陀波伦。是时世有佛。名昙无竭阿祝竭罗佛。般泥洹以来甚久。亦不闻经。亦不见比丘僧。时萨陀波伦菩萨于梦中。忉利天人语言。前世有佛。名昙无竭阿祝竭罗。是时菩萨于梦中闻佛名即觉。觉已即大欢喜踊跃。即弃捐家入深山中无人之处。弃身无所贪慕而大啼哭。自念言。我恶所致不见佛不闻经。不得菩萨所行法。是时萨陀波伦菩萨啼哭。时便闻虚空中有声言。善男子。可止莫复啼哭。有大法名般若波罗蜜。若有行者。若有守者。得佛疾。汝当求索是大法。汝闻是法若行若守。佛所有功德汝悉当得之。得佛三十二相八十种好。汝悉当得之。汝悉当持经法教十方天下人。萨陀波伦菩萨问虚空中声。当何因缘得般若波罗蜜。当到何方求索。当何等方便得之。虚空中声报菩萨言。从是东行莫得休息。汝行时莫念左莫念右。莫念前莫念后。莫念上莫念下。莫念行。行时莫念恐怖。莫念喜。莫念食。莫念饮。莫念坐。莫念行道。莫念中止。莫念淫。莫念怒。莫念痴。莫念守。莫念有所得。莫念内。莫念外。莫念色。莫念痛痒思想生死识。莫念眼。莫念耳。莫念鼻。莫念口莫念身。莫念心意。莫念地水火风。莫念空。莫念人。莫念我。莫念命。莫念有空莫念无空。莫念行菩萨道。莫念有经。莫念无经。莫念生天上。莫念生世间。莫念菩萨善。莫念菩萨恶。一切所向念悉断遍无所著。从是东行悉断念已。作是行不缺者。令得闻般若波罗蜜不久。过去诸佛行菩萨道时。索般若波罗蜜如是。得般若波罗蜜。随其教者得佛疾。作是精进行者。当疾得佛。萨陀波伦菩萨闻虚空中教声。大欢欣。当随天人之教。虚空中声复报言。莫失是教。作是语已。便不复闻声。是时萨陀波伦菩萨闻是教法。倍踊跃欢欣。随是教即东行。心适无所著。行中道作是念。去是几所乃当得般若波罗蜜。作是念已住复大啼哭。萨陀波伦菩萨作是啼哭时。上方虚空中化作佛。在空中立言。善哉善哉。如若所索者甚难。如汝作是精进者。今得般若波罗蜜不久。萨陀波伦菩萨叉手仰向视化佛。身有金色。身放十亿光炎。身有三十二相。见已大欢欣。叉手白化佛言。愿佛为我说经法。我从佛闻经。闻经已诸佛所有经法我皆欲悉得之。是时化佛语萨陀波伦菩萨受我所教法。悉当念持之。诸经法本无恐惧。本净无端绪住。诸经法。一切无所挂碍。本端无所因住。诸经法本无所因端绪无所说住。诸经法无所说教。如虚空无形。本无端绪。如泥洹无有异。诸经法如泥洹无有异。无所从生。无形住。诸经法无所从生无形计。如幻无形。如水中见影。诸经法如水中影现。如梦中所见等无有异。诸经法如梦中所见等无有异。佛声音都卢见如是。当随是经法教。善男子。当作是守念。从是东行索般若波罗蜜。去是间二万里。国名揵陀越。王治处其国丰熟。炽盛富乐人民众多。其城纵广四百八十里。皆以七宝作城。其城七重。其间皆有七宝琦树。城上皆有七宝。罗縠缇缦以覆城上。其间皆有七宝交露间垂铃。四城门外皆有戏卢。绕城有七重池水。水中有杂种。优钵莲花拘文罗华。不那利华。须揵提华。末愿揵提华。皆在池水中生间。陆地有占匐华。如是众华数千百种。其池中有众杂琦鸟凫雁鸳鸯异类琦鸟。数千百种。池中有七宝之船。其人乘船娱乐戏池中。城中皆行列五色幢幡。复悬五色幢幡。复有罗列杂色华盖。城中街巷各各周遍。譬若忉利天上帝释宫殿。悬幢幡音乐之声。数千百种日日不绝。譬如忉利天上难檀桓戏卢。其中有音乐之声。快乐不绝。其城快乐亦复如是。其城中无有异人。皆是菩萨。中有成就者。中有发意者。皆共居其中快乐不可言。其中所有服饰。玄黄琦珍不可复计。其国中有菩萨。名昙无竭。在众菩萨中最高尊。有六百八十万夫人采女共相娱乐。揵陀越国中诸菩萨。常共恭敬昙无竭。为于国中央施高座。随次转下施座。中有黄金座白银座琉璃座水精座。座皆有杂色文绣綩綖。座间皆散杂种香华。座上皆施杂宝交露之盖。中外周匝皆烧名香。昙无竭菩萨常于高座上。为诸菩萨说般若波罗蜜。中有听者。中有书者。中有学者。中有讽者。中有守者。汝从是去到揵陀越国昙无竭菩萨所。自当为汝说般若波罗蜜。当为汝作师教汝。何以故。前数千亿。世常为汝作师。是汝本发意时师。汝往至师所时。若见若闻莫得说其短。亦莫念其短。汝设见慎莫疑慎莫怠。何以故汝未晓沤和拘舍罗。当谛觉魔事。善男子。慎莫随魔教莫用。师在深宫尊贵教。敬当如敬佛无有异。当用经法故。莫念财利贪意心念。所有者当施与师。当乐好恭敬于师。作是行不缺者。今得闻般若波罗蜜不久

尔时萨陀波伦菩萨从化佛闻是教。即踊跃欢欣。用欢欣踊跃故。即得见十方诸佛三昧。尔时十方诸佛皆赞叹言。善哉善哉善男子。我曹本为菩萨时。用精进故。得闻般若波罗蜜便成就得萨芸若。亦复当得三十二相。八十种好。十种力。四无所畏。四事不护。十八事不共。我曹尔时亦复得是三昧。尔时诸佛亦复赞叹。我曹如是。汝行亦当复如我曹。作是行者菩萨所有功德。汝悉当具足得之。萨陀波伦菩萨从三昧觉。作是念。诸佛本从何所来去至何所。作是思惟已。便复举声大哭。复作是念。诸佛教我至昙无竭菩萨所。萨陀波伦菩萨便从是去。中道得一国。国名魔所乐国。萨陀波伦菩萨便于城外园中止宿自念。佛经实难得。何况乃闻耶。我当供养尽力于师今我一身加复贫穷。亦无有珍琦好物及华香持用供养于师。如我无所有者。请且自卖身持用供养于师。作是念已即入城街里。街里炫言。谁欲买我者。时魔在城外戏与五万婇女共游戏。遥见菩萨闻自炫卖声。魔即自念言。是萨陀波伦菩萨自卖身。欲供养昙无竭菩萨持用索佛。是人当出我境界。脱人众多。今我且坏乎。令一国中男女。当不见其形不闻其声。是时萨陀波伦菩萨卖身不售。便自宛转卧地啼哭大呼。欲自卖身持用供养于师。了无有买者。是时释提桓因遥于天上。见萨陀波伦菩萨精进乃尔。自念言。我当下试之。知为至诚索佛不但谀谄。是时释提桓因来下化作婆罗门。问萨陀波伦言。善男子。何其勤苦乃尔乎。用何等故宛转啼哭。萨陀波伦菩萨报言。不须问。道人婆罗门如是问至三。所欲敕使愿相语。我欲相佐助。萨陀波伦菩萨报言。道人欲知者。我自卖身。欲供养于师故。婆罗门语萨陀波伦菩萨。卿欲供养于师故。婆罗门语萨陀波伦菩萨善男子。今我欲大祠。欲得人血。欲得人肉。欲得人髓。欲得人心。卿设能与我者。我益与卿财。萨陀波伦菩萨大欢欣报言。愿相与。萨陀波伦菩萨即取刀自刺两臂。血大出持与之。复割两髀里肉持与之。复自破骨持髓与之。适复欲自刺胸时楼观上有长者女。遥见之伤愍哀之。时长者女与诸伎人婇女五百人。相随来至萨陀波伦菩萨所。问言。善男子。年尚幼少端正如是。何以故。自割截其身体。萨陀波伦菩萨报女言。我欲供养于师故。用是故。出血出肉髓欲卖。持欲供养于师。是时长者女问萨陀波伦菩萨言。设供养于师者。能得何等福。师名为谁。在何方止。萨陀波伦菩萨报女言。师在东方。师名昙无竭。当为我说般若波罗蜜。我闻者当行守之。当用疾得佛。我身当得三十二相。八十种好。十种力。四事不护。四事无所畏。十八事不共。当得法轮转。当度脱十方天下人。是时长者女语萨陀波伦菩萨。如善男子所言。天上天下无有比。汝莫自困苦乃尔。我自与汝金银珍宝琦物。我自与五百婇女相随行。我亦欲自供养昙无竭菩萨。复欲闻经。是时婆罗门语萨陀波伦菩萨言。善哉善哉善男子。如是精进难及。欲知我不。善男子。我是天王释提桓因故相试耳。欲求索何等愿我悉与卿。萨陀波伦菩萨天王释言。欲哀我者使我身体平复如故。菩萨身体即平复如故。释提桓因即自去。是时长者女语萨陀波伦菩萨言。共归至我父母所。索金银珍宝琦物。并报父母去。萨陀波伦菩萨即随至父母舍。女归以具为父母说是事。父母即报女言。汝所说甚快难得闻。我亦复欲与汝共行。自惟年老不能自行。汝所欲得便自说。女言。我欲得金银珍宝琦物。父母言。女自恣取之。女便自取金银杂宝珍琦好物盛捣栴檀名香及余杂碎诸宝蜜香甚多。以五百乘车载自重。五百侍女自副。是时五百侍女皆行报长者女父母。欲侍贵女随菩萨行。报已即相随俱行。是时萨陀波伦菩萨与五百女人辈。稍引导而去。遥见犍陀越国有幢幡。譬如忉利天上悬幢幡。遥闻犍陀越国音乐之声。复遥见揵陀越国。城上皆有七宝缇缦七重。其下有七宝交露七重。一重间者皆悬铃。城外周匝绕有七宝树七重。城外皆有戏卢。男子女人游戏娱乐其中。中有乘车伎自乐者。中有步行伎自乐者。香风四散分布四出无不闻者。譬如天香。用是故名为揵陀越国。是时萨陀波伦菩萨及五百女人。皆遥见如是。见已皆大欢欣踊跃。自念言。我曹义不可于车上载。当下步入国耳。萨陀波伦菩萨及五百女人。共从西城门入。萨陀波伦菩萨入城门里。遥见高台。雕文刻镂金银。涂错五色玄黄。光耀炳然。台四面四角。皆反羽向阳。悬铃旗幡。音乐相和。遥见已。问城中出人。是何等台交露七宝服饰姝好乃尔。其人报萨陀波伦菩萨言。贤者不知耶。是中有菩萨。名昙无竭。诸人中最高尊。无不供养作礼者。是菩萨用般若波罗蜜故作是台。其中有七宝之函。以紫磨黄金为素。书般若波罗蜜在其中。匣中有若干百种杂名香。昙无竭菩萨日日供养。持杂华名香。然灯悬幢幡。华盖杂宝。若干百种音乐。持用供养般若波罗蜜。余菩萨供养般若波罗蜜。亦复如是。忉利天人昼夜各各三。持文陀罗华摩诃文陀罗华。供养般若波罗蜜如是。萨陀波伦菩萨及五百女人。闻是大欢欣踊跃无极。俱往至般若波罗蜜台所。持杂华杂香散般若波罗蜜上。持金镂织成杂衣。中有持衣散上者。中有持衣作织者。中有持衣榻壁者。中有持衣布施者。是时萨陀波伦菩萨及五百女人。供养般若波罗蜜已。便行至昙无竭菩萨高座大会所。相去不远遥见昙无竭菩萨在高座上坐。为人幼少。颜貌姝好。光耀明照。为数千巨亿人中说般若波罗蜜。萨陀波伦菩萨及五百女人。见昙无竭菩萨已。皆大欢欣踊跃。持杂种华香散昙无竭菩萨上。复持若干种宝散其上。复持数百种杂色珍宝衣以上菩萨。为昙无竭菩萨作礼。绕八百匝已作是言。我曹亦当复逮得尊经。亦当复如是

尔时昙无竭菩萨持深经好语。语萨陀波伦菩萨及五百女人言。多贺来到。得无疲倦。他所敕使所欲得者。莫自疑难。我是度人之师。适无所爱惜。萨陀波伦菩萨白昙无竭菩萨言。我本索般若波罗蜜时。于空闲山中大啼哭。于上虚空中有化佛。身有三十二相。紫磨金色身有千亿光耀炎出。是时化佛嗟叹我言。善哉善哉。人索般若波罗蜜。当如是也。便语我言。去是东出二万余里。其国名揵陀越。广纵四百八十里。珍宝交露服饰。譬如忉利天上殿舍。有菩萨名昙无竭。于人中最尊。常反覆教人。汝往至彼间。当得闻般若波罗蜜。前世数千巨亿万世常为汝作师。是汝本发意时师。是时闻师名声。大欢欣踊跃不能自胜。用欢欣踊跃故。即得悉见十方诸佛三昧。是时诸佛悉赞叹我言。善哉善哉。索般若波罗蜜当如是。我曹本索佛时。索般若波罗蜜如是。得般若波罗蜜者自致得成佛。如是佛为我说经已。便不复见。我自念言。佛从何所来去至何所。持是事。师愿为我解之。佛为从何所来去至何所。尔时昙无竭菩萨报言。贤者善听。萨陀波伦菩萨报言。诺当善听。昙无竭菩萨报言。空本无所从来去亦无所至。佛亦如是。无想本无所从来去亦无所至。佛亦如是。无处所本无所从来去亦无所至。佛亦如是。无所从生本无所从来去亦无所至。佛亦如是。无形本无所从来去亦无所至。佛亦如是。幻本无所从来去亦无所至。佛亦如是。野马本无所从来去亦无所至。佛亦如是。梦中人本无所从来去亦无所至。佛亦如是。泥洹本无所从来去亦无所至。佛亦如是。想像本无所从来去亦无所至。佛亦如是。无有生无有长本无所从来去亦无所至。欲知佛亦如是。无所适本无所从来去亦无所至。欲知佛亦如是。虚空本无所从来去亦无所至。欲知佛亦如是。经果本无所从来去亦无所至。欲知佛亦如是。本端本无所从来去亦无所至。欲知佛亦如是。尔时萨陀波伦菩萨闻佛深事法。如是比。不可计。不可念。不可量。此大法如是。尔时即于坐上得六万三昧门。何等为三昧门。无处所三昧。无恐惧衣毛不起三昧。脱诸魔中不恐惧三昧。脱于爱欲之本三昧。脱出格战离患三昧。不可计向入三昧。譬如大海水不可量多慧所入三昧。在须弥山功德庄饰三昧。五阴六衰无形观三昧。入诸佛界三昧。悉见诸佛三昧。菩萨守道三昧。诸经法本无形见说三昧。珍宝庄饰三昧。悉学珍宝入三昧。悉念诸佛三昧。菩萨上高三昧。真阿惟越致及法轮为转三昧。庄佛功德三昧。无瑕秽悉及净三昧。所闻众事如大海三昧。无所护无有过三昧。乐经音声遍三昧。经法章显其幡三昧。怛萨阿竭身无形入三昧。诸经法无形遍视三昧。菩萨印三昧。怛萨阿竭目见三昧。照明诸境界佛界所愿具足三昧。解十方人难三昧。临成佛庄严三昧。种种杂华异色三昧。多珍宝三昧。法轮常转三昧。诸音声远闻入要三昧。入十方人本三昧。诸三界悉遍至三昧。成诸功德三昧。无有能过六波罗蜜三昧。菩萨坐树下时坏余外道罗网三昧。怛萨阿竭现飞三昧。不可复计功德度庄严三昧。诸珍宝智慧功德三昧。萨芸若地三昧。悉净因三昧。悉遍照三昧。悉入十方人生死之根智慧出中三昧。过去当来今现在悉等三昧。如是比等。萨陀波伦菩萨得六万三昧门如是。尔时昙无竭菩萨起入宫

道行般若经卷第九道行般若经卷第十

        后汉月支国三藏支娄迦谶译

    摩诃般若波罗蜜昙无竭菩萨品第二十九

是时萨陀波伦菩萨安隐从三昧觉起并与五百女人。共至昙无竭宫门外。门外立自念言。今我用经法起来。师入在内。我义不可卧不可坐。须我师来出上高座说般若波罗蜜。尔乃坐耳。及五百女人亦皆效萨陀波伦菩萨立。是时昙无竭菩萨适教殿中诸女。说经道已。沐浴澡洗已更着新衣。上般若波罗蜜之台坐思惟。种种三昧悉入。如是七岁不动不摇。是时萨陀波伦菩萨及五百女人。亦复常经行七岁不坐不卧七岁已后天人于上虚空中。语之言。却后七日。昙无竭菩萨当从三昧起。是时萨陀波伦菩萨闻天人语声。自念言今我当为师施座扫洒令净萨陀波伦菩萨及五百女人。共到说经处。至已特为昙无竭菩萨施高座。时五百女人各各自取着身衣布着座上。当时弊魔自念言。未尝有是。未尝见是。是萨陀波伦菩萨为昙无竭菩萨施高座。持用恭敬索佛道。精进勇健无有休懈。得道者出我界。度脱人不可计。今我且中道坏之。是时弊魔悉坏诸菩萨所坐座皆令曲戾。雨沙砾石荆蕀枯骨。是时萨陀波伦菩萨及五百女人。见座曲戾污泥不净。自念言。今昙无竭菩萨当坐说经。及诸弟子皆当来听。今我曹当更扫除整顿坐席。即共扫除整顿诸座已。自念言。今地大有土尘。恐来坌师及诸菩萨当共洒之。周行索水不能得。何以故。弊魔所作。自念言。今我曹索水了不能得。当自取身血洒之耳。是时萨陀波伦菩萨及五百女人各自取刀处处刺身出血持用洒地。用慈孝于经法故。是时释提桓因自念言世间乃有是人耶。精进恭敬慈孝经师故。是时释提桓因到萨陀波伦菩萨所。嗟叹言善哉善哉贤者精进诚难及。用精进慈孝于师故。今闻般若波罗蜜不复久。贤者。他所敕使愿相语。有是曹人者。我曹悉当护之。所欲得者悉当与之。是时萨陀波伦菩萨言我欲所得者。释提桓因自当知之。是时释提桓因。即化地悉使作琉璃。其上有金沙。释提桓因使萨陀波伦菩萨及五百女人身体完健平复如故。于坐四面化作琉璃池水。周匝池边皆有珍宝栏楯。及七宝池陛。侠陛两边皆珍宝之树。若干百种罗列姝好。是时萨陀波伦菩萨及五百女人。为诸菩萨储水。天文陀罗华。曼殊颜华摩诃曼殊颜华。都雨种种华凡四千石。释提桓因持用与萨陀波伦菩萨。语之言。持是华供养般若波罗蜜。及散昙无竭菩萨及诸菩萨上。及天衣五百领昙无竭在座上坐。持是上之。萨陀波伦菩萨即悉受之。便为祝愿。是时昙无竭菩萨七岁以后。从三昧觉起到高座上。并与四万亿菩萨共坐。有于前坐者甚众多。是时萨陀波伦菩萨及五百女人。俱皆散华。并持栴檀捣香蜜捣香。杂碎珍宝。都持散昙无竭菩萨及诸菩萨上。前持头面着足已。绕三匝却住。以微意视昙无竭菩萨。是时昙无竭菩萨。都大会壁方四十里。满其中人。是时昙无竭菩萨四向视诸来会者。萨陀波伦菩萨及五百女人。用欲得经法故。即为萨陀波伦菩萨说般若波罗蜜言。善男子且听。诸经法悉等。般若波罗蜜亦悉等如是。诸经法本端不可计如是。怛萨阿竭智慧无所挂碍般若波罗蜜亦无所挂碍如是。譬如幻人无形般若波罗蜜亦无形如是。譬如风无所挂碍般若波罗蜜亦无挂碍所有如是。本端不可计。般若波罗蜜亦不可计如是。一切我所悉断本净。般若波罗蜜亦本无如是。譬如梦中与女人通视之本无。般若波罗蜜亦本无如是。所名本无。般若波罗蜜亦本无如是。阿罗汉泥洹空无所生。般若波罗蜜亦空无所生如是。怛萨阿竭般泥洹。本等无有异。般若波罗蜜亦本等无有异如是。譬如然火。火即时灭之。本无所从来去亦无所至。般若波罗蜜本无从来去亦无所至如是。譬如梦中见须弥山本无。般若波罗蜜亦本无如是。譬如佛现飞。般若波罗蜜现无所有如是。前于爱欲中相娱乐计之无所有。般若波罗蜜计之亦无所有如是。人名及声无所有。怛萨阿竭亦无所有。于前见者念所作因见。般若波罗蜜念所作本无所有如是。譬如幻师化作象本无所有。般若波罗蜜亦本无所有如是。譬如虚空适无所住。般若波罗蜜亦适无所住如是。譬如幻师学无所不至。般若波罗蜜亦无所不至如是。过去当来今现在亦不可合为一。般若波罗蜜无过现当作是知。名本无形字无有形。般若波罗蜜亦无所不至。亦无所不入。亦无所至。亦无所入。何以故。般若波罗蜜空无所有故。譬如虚空。无所不至。无所不入。亦无所至。亦无所入何以故。空本无色。般若波罗蜜如是。般若波罗蜜如是。般若波罗蜜者。亦入于地。亦入于水。亦入于火。亦入于风。亦入于空。亦入于彼。亦入于此。亦入于色。亦入于痛痒。亦入于思想。亦入于生死。亦入于识。亦入于人。亦入于寿命。亦入于生。亦入于有德。亦入于无德。亦入于欲。亦入于不欲。亦入于有。亦入于无。亦入于想。亦入于无想。亦入于愿中。亦入于无愿中。亦入于无生中。亦入于不生中。亦入于日月。亦入于星宿。亦入于阿须伦。亦入于龙。亦入于鬼神。亦入于揵陀罗。亦入于迦留勒。亦入于甄陀罗。亦入于摩睺勒。亦入于罗刹。亦入于鸠垣。亦入于薜荔。亦入于禽兽。亦入于泥犁。亦入于蜎飞。亦入于蠕动。亦入于蚑行。亦入于喘息。亦入于贫贱。亦入于富贵。亦入于贤者。亦入于仙人。亦入于须陀洹。亦入于斯陀含。亦入于阿那含。亦入于阿罗汉。亦入于辟支佛。亦入于菩萨。亦入于佛。亦入于泥洹。亦入于四意止。亦入于四意断。亦入于五根。亦入于五力。亦入于七觉意。亦入于八道。亦入于有智。亦入于无智。亦入于十种力。亦入于四无所畏。亦入于佛经。亦入于世间经。亦入于巫祝。亦入于不巫祝。亦入于宿命。亦入于所行。亦入于展转生死中。亦入于勤苦。亦入于不勤苦。亦入于自在。亦入于不自在。亦入于度脱。亦入于不度脱。亦入于好中。亦入于不好中。亦入于善中。亦入于不善中。亦入于黠中。亦入于不黠中。亦入于明中。亦入于不明中。亦入于过去。亦入于当来。亦入于今现在。亦入于可见。亦入于不可见。亦入于教。亦入于法。亦入于有。亦入于无所有。亦入于一切有形。亦入于一切无形

佛语须菩提。如是比。昙无竭菩萨为萨陀波伦菩萨说般若波罗蜜所入处。如是说昼夜七日。是时人听经呼如饭时顷。何以故。昙无竭菩萨力恩。是时萨陀波伦菩萨闻说般若波罗蜜。大欢欣踊跃。及五百女人共持天衣及八百石杂宝。供养上昙无竭菩萨。释提桓因持天摩诃文陀罗华。散昙无竭菩萨上。及散诸菩萨上。持用增益功德。是时一佛境界中一切树木。药树果树。诸杂宝树。悉倾曲躬。为昙无竭菩萨作礼。天雨蜜香之华。其华之香闻一佛界中。一切人闻此华之香。各各遥见昙无竭菩萨在高座说经。并复见萨陀波伦菩萨及五百女人。一切人心皆柔弱欢欣。皆遥为昙无竭菩萨作礼。其国中悉震动。是时数千巨亿万人悉得无央数经法。不可复计菩萨皆得阿惟越致。长者女及五百女人。白萨陀波伦菩萨言。我曹辈愿为师作婢。愿持身命自归。愿为师给使。共持五百乘车珍宝所有以上师。何以故。今师为我故甚勤苦。我曹持师以当佛无有异。我曹蒙大恩。乃得闻尊经好语。既闻经已。无有狐疑大如毛发。今我曹持身为师给使。如是数千亿万劫。尚未能报须臾之恩。用得闻尊经故。是时萨陀波伦菩萨悉受五百女人及五百乘车珍宝既受。用道德故既受已。萨陀波伦菩萨欲持上师。白昙无竭菩萨言。愿持身自上。及五百女人五百乘车珍宝以上大师。哀我曹辈。愿当受之。当使我曹得功德。是时昙无竭菩萨欲使萨陀波伦菩萨成其功德故。悉受五百女人及五百乘车珍宝。既受已。复持反遗萨陀波伦菩萨。即自言。持五百女人为汝给使。及五百乘车珍宝。是时忉利天上诸天人。各各而嗟叹言。善哉善哉。萨陀波伦菩萨所有者悉施与师。是意难得。是时数千巨亿天人。共来到昙无竭菩萨所听经。是时萨陀波伦菩萨大欢欣踊跃。即于坐上得六万三昧门。何等为三昧门。愿乐三昧。威仪三昧。劝德三昧。月盛满三昧。日光焰三昧。怛萨阿竭行三昧。悉念佛三昧。菩萨所生三昧。乐智慧三昧。度脱坚住三昧。诸境界中无所住三昧。国土种种严入三昧。怛萨阿竭相无相入三昧。十方人无形印封三昧。怛萨阿竭出坐三昧。无所畏乐三昧。弃捐珍宝三昧。怛萨阿竭力庄严三昧。诸经法悉明乐三昧。说无所从来解事三昧。净如梵人三昧。过去当来今现在悉等入三昧。本端当来端无所住三昧。庄严佛藏三昧。佛音声响悉成三昧。如是三昧得六万门。萨陀波伦菩萨从三昧觉得智慧力。悉入诸菩萨经法中。萨陀波伦菩萨白昙无竭菩萨言。师愿说佛音声。当何以知之。昙无竭菩萨语萨陀波伦菩萨言。贤者明听。譬如箜篌不以一事成。有木有柱有弦。有人摇手鼓之。其音调好自在。欲作何等曲。贤者。欲知佛音声亦如是。菩萨有本初发意。世世行作功德。世世教授。世世问佛事。合会是事乃成佛身。佛音声亦如是。其法皆从因缘起。亦不可从菩萨行得。亦不可离菩萨行得。亦不可从佛身得。亦不可离佛身得。贤者。欲知佛身音声。共合会是事乃得佛耳。复次贤者。譬如工吹长箫师。其音调好与歌相入。箫者以竹为本。有人工吹。合会是事其声乃悲。成怛萨阿竭阿罗诃三耶三佛身。不以一事。不以二事成。以若干百千事。若世世作功德。本愿所致。亦复世世教人。用是故成佛身相。及诸好悉见如是。譬如佛般泥洹后有人作佛形像。人见佛形像无不跪拜供养者。其像端正姝好如佛无有异。人见莫不称叹。莫不持华香缯彩供养者。贤者呼佛。神在像中耶。萨陀波伦菩萨报言。不在中。所以作佛像者。但欲使人得其福耳。不用一事成佛像。亦不用二事成。有金有黠人。若有见佛时人佛。般泥洹后念。佛故作像。欲使世间人供养得其福。萨陀波伦菩萨报师言。用佛般泥洹后故作像耳。昙无竭菩萨报言。如贤者所言。成佛身亦如是。不用一事。亦不用二事。用数千万事。有菩萨之行。有本索佛。时人若有常见佛作功德。用是故成佛身。智慧变化飞行。及成诸相好。成佛如是。贤者复听。譬如鼓不用一事不用二事成。有师有革有桴。有人击之其声乃出。贤者。欲知佛。不用一事二事。用若干千众事乃成之。有初发意。有六波罗蜜行。晓知本无。本无无所从生之事。坐于树下降伏于魔。诸经法悉晓知。如幻无有异。用是故成佛身。贤者复听。譬如画师。有壁有彩有工师有笔合会是事乃成画人。欲知佛身。不用一事成。用数百千事。菩萨有本行布施。有持戒不犯十事。常随善师。常等心念十方人。无有能坏者。世世见佛。闻菩萨行事坚持不忘。世世不谀谄常行至诚。贤者欲知成佛身如是。贤者复听。譬如阿迦腻吒天上天人所止观殿。光耀悉照天上端正姝好。如天上殿舍。亦不自作。亦无有持来者。亦无有作者。本无所从来去亦无所至。因缘所生。其天人本作功德所致。用于此间布施故。得生其上。在殿舍中解止。用是故。其人得宫观。贤者欲知佛身。因缘所生。用世间人欲得见佛故。其人前世有功德。其人远离八恶处生。其人黠慧信于佛。贤者欲知成佛身。本无所从来去亦无所至。无有作者。亦无有持来者。本无有形。亦无所著。如阿迦腻吒天上宫殿。佛所以现身者。欲度脱世间人故。贤者复听。譬如山中响声。不用一事。亦不用二事所能成。有山有人有呼有耳听。合会是事乃成响声。贤者欲知成佛身。如是无有形。亦无有着。因缘所生。世世解空。习行空。一切生死。无死生为因缘。佛智悉晓本无死生。本亦无般泥洹者。佛作是现世间作是说。贤者欲知佛身如是。贤者复听。譬如幻师化作一人端正姝好。譬如遮迦越罗。无有异。所语众人闻之无不欢欣。人有从索金银珍宝者。皆悉与之有所爱重。被服人索者悉与之。王在众人中坐起行步皆安详。人有见者莫不恭敬作礼者。幻人不用一事二事成。有幻祝。有聚会人。随人所喜各化现。中有黠者。同知是为化人作。是现化无所从来去亦无所至。知之本空化所作。黠者恭敬作礼不着。贤者欲知成佛身如是。因缘所作。用数百千事乃共合成。有菩萨之行。有功德。有劝助德。令十方人使安隐。具足菩萨愿者。欲知成佛身者如是。贤者欲知佛。为人故分布经。无数授与人。各各使行禅三昧思惟分别。为人说经各各使学。如是诸天人民闻之莫不欢欣。中有自贡高者。中有不知惭者。中有淫乱者。中有悭贪者中有强梁者。中有自用者。中有喜斗者。中有不用谏者。中有为淫怒痴所覆者。中有行恶不可计者。佛在众人中央端正姝好。坐起行步安隐。佛众恶已尽。但有诸德。佛皆使人得安隐。佛亦自行佛事。佛本自空无所著。如幻人所作。菩萨现身如是端正姝好。虽见之不着。亦无诸想之意。虽知之无所有恭敬作礼供养无极。贤者欲知过去当来今现在诸佛。皆从数千万事各各有因缘而生。菩萨当作是念。当作是习。当作是守。菩萨作是行得佛疾。是时昙无竭菩萨说佛身时。四万八千菩萨即解得尽信之行。百亿菩萨悉得诸陀邻尼法。二百亿菩萨得无所挂碍问皆能报。四百亿菩萨皆得阿惟越致菩萨。八万亿菩萨皆得阿阇浮行住法。是时天文陀罗华。摩诃文陀罗华。雨散昙无竭菩萨及诸菩萨上。昙无竭菩萨持威神。都卢一佛之界。诸有音乐皆自作声。数千万天人从空中散天衣雨昙无竭菩萨及诸菩萨上。诸天于空中作音乐。共乐昙无竭菩萨。诸天衣皆行列覆一佛界中。天烧蜜香遍至。其分散亦悉遍至。一佛界中地悉动。诸菩萨悉见十方无央数佛。是时诸佛悉遥赞叹昙无竭菩萨言。善哉善哉。是时诸佛授萨陀波伦菩萨诀。当作佛时。汝却后当来世。作佛名迦摩迦提陀颇罗耶怛萨阿竭阿罗诃三耶三佛。汝作佛时。正当号如是。时五百女人却后稍稍皆当作佛。如是昙无竭菩萨世时五百女人即化作男子。后世世生者常不离诸佛国。萨陀波伦菩萨及五百人世世常高才。常当教天下人。佛语须菩提若有菩萨在事欲得佛者。若见现在佛。若佛般泥洹后。欲索般若波罗蜜者。常精进。常当恭敬于般若波罗蜜。当如是萨陀波伦菩萨

    摩诃般若波罗蜜道行经嘱累品第三十

佛以手抚阿难肩三反。佛语阿难。我嘱累汝是般若波罗蜜。谛持谛念。阿难。是般若波罗蜜以相累。常持谛了了取字。谛了了念书。作字莫使缺减。谛视书莫左右望。一切恐是有难。谛是经中莫令字少。我累汝阿难。是般若波罗蜜。何以故。是经。阿难。怛萨阿竭阿罗诃三耶三佛。过去当来今现在无有尽经藏。是经镇诸法。悉从是经中出诸所有。阿难。怛萨阿竭阿罗诃三耶三佛。过去当来今现在所为。人民说经所出不可计经卷。种种异慧。若干种经卷。所见人民。若干种所喜。各各随所行。人民道经所入慧所说。过去当来今现在所说。是一切皆从是般若波罗蜜藏中出诸所有经法。阿难。若干种所见相。种种所行。若干种根。若干种黠。若干种痴。若干种慧。人民辈所求尽。所求慧。怛萨阿竭。悉都卢。阿难。悉从般若波罗蜜中出。悉知晓如是。阿难。般若波罗蜜是怛萨阿竭呵罗诃三耶三佛母。是诸慧明。是我身。皆从是中出。从是中生。佛语阿难。汝敬我所语敬我法。若敬爱承事我。汝自敬身于佛。汝有慈于佛。汝有孝于佛。一切恭敬于佛所。汝持是慈孝恭敬于般若波罗蜜中。如是阿难。汝恭敬于是中。悉为供养诸佛已。持是累汝。阿难。汝所当作者悉为已。汝身亦有慈。口亦有慈。心亦有慈。汝有孝于佛。不言无有孝。汝常得佛时。不言不得时。汝常如法不言不如法。汝心常净洁无瑕秽。汝见佛不言不见佛。汝如是悉为报佛恩已。我语汝。阿难。是般若波罗蜜从中亡一字。汝舍汝拟不书。汝虚以无有慈孝于佛所。汝以不复见我。阿难。汝以不复恭敬于佛。阿难。汝以不复随佛教。阿难。汝以不复承事用。佛言阿难。汝所恭敬于佛以来。为了无复有供养佛。设从是般若波罗蜜中。亡一句一言若拟置以为背佛恩。佛语阿难。是般若波罗蜜汝谛受谛念。用慈孝于佛故。承用教故。都卢是过去当来今现在佛天中天所施教用是供养。若于萨和萨为极大慈具诸菩萨当视如见佛。当恭敬诸佛法。汝以亲近持

佛藏。作是谛念。于是般若波罗蜜。当谛取莫得失一字。佛般泥洹后汝当护是经莫令减少。当持授与菩萨摩诃萨是诸佛经藏。阿难。我手付汝。汝当持授与菩萨摩诃萨。持是。阿难。菩萨所作功德。勤苦死生牢狱悉破坏。诸无知者为系着悉得救解。诸魔官属无不降伏。诸所欲法悉除去。正上佛坐作阿耨多罗三耶三菩。以成佛道。诸人民无目者愚痴者悉当开解。佛语阿难。正第一大道无有两正。是阿耨多罗三耶三菩阿惟三佛慧。是为般若波罗蜜决。佛语阿难。我般泥洹后都卢三千大千国界。其中人民汝悉教入经法中。悉令成就得阿罗汉道。日日教乃尔所人。如是一劫若百劫。悉为说经令般泥洹。虽尔汝常不具足承事我。汝不如持是般若波罗蜜中一句教菩萨学。如是为具足承事佛已。为具足供养。佛言。我今于是称誉汝嘱累般若波罗蜜。至一劫百劫不能竟。我今粗演说耳。佛语阿难。我今问汝汝当说。佛从袈裟中出金色臂。举右手着阿难头上。摩阿难头。持手着阿难肩上。语阿难言。云何阿难。汝慈于佛不。阿难言。佛天中天。自当知。如是至三。佛复问阿难。云何阿难。汝孝于佛不。如是复三。阿难言佛天中天。自当知。佛言。如是阿难。汝有慈于佛。所以为报佛恩。阿难。汝极尊般若波罗蜜致重敬。慈于是句。心所念句。当令了了分明心所念。余悉弃之。一切心于是中书。具经正字头角所持时学时。当谛授与菩萨摩诃萨。与好长素卷。善书令经上下句相得。书时当得好笔书好素上。当自归承事作礼供养。好香成捣杂香泽香缯彩华盖旗幡。悉如天上所有香。着油麻中。所净洁油麻好灯炷。自归头面着地。却然灯炷。加敬作礼承事。佛说是般若波罗蜜时。在罗阅只耆阇崛山中。在众弟子央坐

佛年三十得佛。十二月十五日过食后说经。佛说经已。诸弟子诸菩萨。诸天诸阿须伦诸龙鬼神诸人民。皆大欢欣为佛作礼而去

道行般若经卷第十


放光般若经

    No. 221 [Nos. 220(2), 222, 223]

放光般若经卷第一

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜放光品第一

闻如是。一时佛在罗阅只耆阇崛山中。与大比丘众五千人俱。皆是阿罗汉。诸漏已尽意解无垢。众智自在已了众事。譬如大龙所作已办。离于重担逮得所愿。三处已尽正解已解。复有五百比丘尼诸优婆塞优婆夷。诸菩萨摩诃萨。已得陀邻尼空行三昧无相无愿藏。已得等忍。得无挂碍陀邻尼门。悉是五通。所言柔软无复懈怠。已舍利养无所希望。逮深法忍得精进力。已过魔行度于死地。所教次第于阿僧祇劫顺本所行。所作不忘颜色和悦。常先谦敬所语不粗。于大众中所念具足。于无数劫堪任教化。所说如幻如梦如响如光如影如化。如水中泡如镜中像。如热时炎如水中月常以此法用悟一切。悉知众生意所趣向。能以微妙慧。随其本行而度脱之。意无挂碍具足持忍。所入审谛。愿摄无数无量佛国。无量诸佛所行三昧皆现在前。能请诸佛为一切说法。种种诸见离于所著。已游戏于百千三昧而自娱乐。诸菩萨者德皆如是。其名曰护诸系菩萨。宝来菩萨。导师菩萨。龙施菩萨。所受则能说菩萨。雨天菩萨。天王菩萨。贤护菩萨。妙意菩萨。有持意菩萨。增益意菩萨。现无痴菩萨。善发菩萨。过步菩萨。常应菩萨。不置远菩萨。怀日藏菩萨。意不缺减菩萨。现音声菩萨。哀雅威菩萨。宝印手菩萨。常举手菩萨。慈氏菩萨。及余亿那术百千菩萨俱。尽是补处应尊位者。复有异菩萨无央数亿百千。及诸尊者子皆悉来会。尔时世尊自敷高座结跏趺坐。正受定意三昧。其三昧名三昧王。一切三昧悉入其中。作是三昧已持天眼观视世界。尔时世尊。放足下千辐相轮光明。从鹿腨肠上至肉髻。身中支节处处各放六十亿百千光明。悉照三千大千国土无不遍者。其光明复照东方西方南方北方四维上下。如恒边沙诸佛国土众生之类。其见光明者毕志坚固。悉发无上正真道意。尔时世尊复放身毛。一一诸毛孔皆放光明。复照三千大千国土。复照十方无数恒边沙国土。一切众生见光明者。毕志发无上正真道意。世尊。复以诸如来无所著等正觉法。放大光明悉遍三千大千国土。复照十方无数恒边沙国土。一切众生见光明者。亦毕志发无上正真道意。尔时世尊。出广长舌遍三千大千国土。遍已从其舌根。复放无央数亿百千光明。一一光明化为千叶宝华其色如金。一一华者上皆有坐佛。一一诸佛皆说六度无极。一切众生闻说法者。皆发无上正真道意。其舌光明一一华像。复照十方恒边沙国土。一切众生见其光明闻说法者。亦发无上正真道意。是时世尊于师子座三昧。其三昧者名师子游戏。身放神足感动三千大千国土六反震动。三昧威神令此三千大千国土地。皆柔软[跳-兆+叵][跳-兆+我]踊没。诸有地狱饿鬼蠕动之类。及八难处皆悉解脱。得生天上人中齐第六天。适生天上人中已皆大欢喜。即识宿命来诣佛所。稽首受法。如是十方恒边沙国土。诸三恶趣及八难处亦离对苦。生天上人中齐第六天。适生欢喜亦识宿命。各各自至其国佛所。稽首受法。尔时三千大千国土。诸盲者得视。聋者得听哑者能言。伛者得申。拘躄者得手足。狂者得正。乱者得定。病者得愈。饥渴者得饱满。羸者得力。老者得少。裸者得衣。一切众生皆得同志。相视如父如母如兄如弟。等行十善淳修梵事。无有瑕秽澹然快乐。譬如比丘得第三禅。一切众生皆逮于智。调已自守不娆众生。尔时世尊坐师子床。于此三千大千国土。其德特尊光明色像威德巍巍。譬如山王须弥。众山无能及者。尔时世尊。如诸如来无所著等正觉法。以大普音遍三千大千国土。诸首陀会天及诸梵天。第六天王释天四王天。其中诸天及诸众生。悉见师子座闻佛所说。各持天上所有种种名香种种名华。来诣佛所。供养如来无所著等正觉。于是三千大千国土。其中众生各持世间所有名香水陆诸华。来诣佛所。供养世尊。是时诸天香华众生香华。所可供养散如来上者。于空中合化成大台。于其台中垂诸幢幡。幢幡华盖五色缤纷。华盖光明悉遍照三千大千国土皆作金色。十方恒边沙诸佛国土亦复如是。是时阎浮提人意自念言。今日如来无所著等正觉。独为我等说法不在余处。诸三千大千国土中诸众生亦各念言。今日如来在我前坐。独为我等说法不在余国。尔时世尊于师子座复放光明。照于三千大千国土。其中众生见光明者。尽见东方恒边沙佛及弟子众。悉见是间沙诃国土释迦文佛及诸会众。十方国土各各相见亦复如是。东方度如恒边沙国有世界名宝迹。其佛号宝事如来无所著等正觉。今现在以般若波罗蜜教化一切。有菩萨名普明。见释迦文佛光明变化威神感动。便白宝事如来言。今日何缘。有是佛身光明变化感动如是。宝事如来告普明曰。西方极远有世界名沙诃。其佛号释迦文。今现在为诸菩萨说般若波罗蜜。是其瑞应。普明白佛言。唯然世尊。我欲诣彼见释迦文佛礼事供养。彼国菩萨皆得总持得诸三昧超越三昧。佛告普明。欲往随意。时宝事佛。便以千叶金色莲华与普明言。持是供养释迦文佛。重告普明。汝诣彼国。摄持威仪无失法度。所以者何。彼国菩萨奉持律行是以生彼。是时普明菩萨。与无央数百千菩萨无数比丘。诸善男子善女人众。从东方来所经诸佛皆以香华供养礼事。来诣忍界。见释迦文佛稽首作礼。普明菩萨白释迦文佛言。宝事如来致问殷勤问讯世尊。坐起轻利气力如常不。今奉此华供养世尊。佛即受之。释迦文佛。便以此华散于东方恒边沙佛国。其华遍至一一华者皆有坐佛。皆说般若波罗蜜教化众生。闻是教者皆发无上正真道意。彼善男子善女人。随普明菩萨来者。皆礼事释迦文佛足。所赍香华供养世尊。南方度如恒边沙国。有世界名度忧。其佛号无忧威如来无所著等正觉。有菩萨名离忧。西方度如恒边沙国有世界名灭恶。其佛号宝上如来无所著等正觉。有菩萨名意行。北方度如恒边沙有世界名胜。其佛号仁王如来无所著等正觉。有菩萨名施胜。下方度如恒边沙有世界名贤。其佛号贤威如来无所著等正觉。有菩萨名妙华。上方度如恒边沙有世界名思乐。其佛号思乐威如来无所著等正觉。有菩萨名思乐施。如是六方菩萨各白其佛。此何变化而现于此。其佛各报诸菩萨言。去是极远有忍世界。佛号释迦文。为诸菩萨说般若波罗蜜。是其瑞应。彼诸菩萨各白其佛。欲诣忍界见释迦文佛礼事供养。尔时诸佛各与宝华。及诸无数百千菩萨。诸比丘僧善男子善女人俱来诣此。所经诸国土。各以香华供养诸佛。次诣忍界见释迦文佛。供养礼事问讯。皆如东方诸菩萨比。尔时一时之顷三千大千国界。其地所有皆成为宝。诸树草木悉为香华。悬诸幢幡缯彩华盖。譬如华迹世界普华如来国土。文殊师利。善住意王天子。及诸大威神菩萨所处国土。此忍世界所有珍妙亦如彼国。尔时众会诸天魔梵诸龙鬼神。沙门婆罗门世界人民。诸菩萨摩诃萨。及新发意者皆悉来集。佛知众会已定。告舍利弗言。菩萨摩诃萨当习行般若波罗蜜。舍利弗白佛言。欲逮知一切诸法。当云何行般若波罗蜜。佛告舍利弗。菩萨摩诃萨行般若波罗蜜者。未曾不布施有财有施有受者。为行檀波罗蜜。知罪知福为行尸波罗蜜。不起恚意为行羼提波罗蜜。身口常精进意不懈怠。为行惟逮波罗蜜。于六情无所味为行禅波罗蜜。佛告舍利弗。菩萨摩诃萨行般若波罗蜜定意不起。当具四意止四意断四神足五根五力七觉意贤圣八品道。当具足空三昧无相三昧无愿三昧。具足四禅四等四无形三昧。具八解禅得九次第禅。当复知九相。新死相。筋缠束薪相。青瘀相。脓相。血相。食不消相。骨节分离相。久骨相。烧焦可恶相。已知诸相当念佛志法志比丘僧。志在施戒志在安般守意。志在无常苦空无我人想。无所乐想无生灭想。无道想无尽想。无所起想善想法想。豫知一切众生之意。是谓为慧。便得觉意三昧无畏三昧。有想有畏无想无畏。亦无想亦无畏。所不知根当知已知。当知欲过八患却十二衰。具足佛十力十八法四无所畏四无碍慧大慈大悲。觉知一切菩萨慧者。当习般若波罗蜜。菩萨摩诃萨欲具足萨云若。离于生死习绪者当学般若波罗蜜。如是舍利弗。是为菩萨摩诃萨行般若波罗蜜。复次舍利弗。菩萨摩诃萨欲上菩萨位者。欲过声闻辟支佛地。欲住阿惟越致地者。当学般若波罗蜜。欲住六通知一切人意所趣向者。当学般若波罗蜜。欲胜罗汉辟支佛慧者。当学般若波罗蜜。菩萨摩诃萨悉欲得诸陀邻尼三昧门诸众智门者。当学般若波罗蜜。诸声闻辟支佛家。所作布施持戒劝助种种功德。欲过其上者当学般若波罗蜜。菩萨摩诃萨欲知声闻辟支佛家诸所有戒三昧智慧解脱见解脱慧。欲过其上者。当学般若波罗蜜。菩萨摩诃萨欲少施少戒少忍少进少禅。所习行少而得大报功德无量者。当学般若波罗蜜。菩萨摩诃萨欲使亲族身体如佛形像者。当学般若波罗蜜。菩萨摩诃萨欲具足大士三十二相八十种好。成诸菩萨种姓逮得鸠摩罗浮者。当学般若波罗蜜。菩萨摩诃萨常不欲离诸佛世尊供养诸佛。种种所行欲成功德者。当学般若波罗蜜。菩萨摩诃萨欲满一切众生之愿。欲求饮食车乘象马履屣衣裘香求华幔饰床卧之具。给众所求能令具足。欲得是者当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲使恒边沙佛国中人。悉具足行六波罗蜜者。当学般若波罗蜜。菩萨摩诃萨欲行功德使正至佛者。当学般若波罗蜜。菩萨摩诃萨欲使十方恒边沙佛国土诸佛世尊。所赞叹功德者。当学般若波罗蜜。菩萨摩诃萨欲一发意。超越十方恒边沙诸佛国土悉遍至者。当学般若波罗蜜。菩萨摩诃萨欲发一音都使十方尽闻其声者。当学般若波罗蜜。菩萨摩诃萨欲护一切十方诸佛刹使不断者。当学般若波罗蜜。菩萨摩诃萨欲住内空外空大空最空空空有为空无为空至竟空无限空所有空自性空一切诸法空。无所猗空无所有空。欲知是空事法者。当学般若波罗蜜。菩萨摩诃萨欲觉知一切诸佛诸法如者。当学般若波罗蜜。欲知一切诸法性者。当学般若波罗蜜。欲知一切诸法真际者。当学般若波罗蜜。舍利弗。菩萨摩诃萨。如是为行般若波罗蜜当作是住。复次舍利弗。菩萨摩诃萨欲知三千大千国土其中尘数及诸树木生草枝叶茎节。悉欲知是数者当学般若波罗蜜。菩萨摩诃萨欲以一毛破为百分。以一分毛取三千大千国土。其中海水数知几渧。悉知其数不娆水性。欲得是者当学般若波罗蜜。三千大千国土其中火起譬如劫尽烧时。欲一时吹灭大火者。当学般若波罗蜜。三千大千国土其中大风起。吹须弥大山令如糠[(穀-(一/禾)+米)/會]。能以一指障其风力令不起者。当学般若波罗蜜。菩萨摩诃萨。欲以结跏趺坐悉遍满三千大千国土虚空。欲得是者当学般若波罗蜜。三千大千国土诸须弥山。能持一手举着他方无数佛国。欲得是者当学般若波罗蜜。菩萨摩诃萨能以一钵之饭。充饱十方恒边沙佛及弟子众。悉令满足者。当学般若波罗蜜。又以珍宝服饰幢幡缯盖香华。供养恒边沙佛及弟子众。欲得是者当学般若波罗蜜。欲使十方恒边沙国其中众生。悉具于戒三昧智慧解脱见解脱慧。沙门四道乃至无余泥洹。欲得是者当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜者。若布施当作是念。使我得大果报。得生尊者家梵志大姓家迦罗越家。生四王天上乃至第六天中。因是布施得第一禅上至四禅空无形禅。作是布施得贤圣八品道得须陀洹。上至阿罗汉辟支佛者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜。以慧方便具足六波罗蜜。舍利弗白佛言。菩萨摩诃萨云何布施具足六波罗蜜。佛言。菩萨摩诃萨行檀波罗蜜者。当习无所猗法其所布施及受者。令具足诸波罗蜜。是为具足檀波罗蜜。于善于恶不与罪福。是为尸波罗蜜。无嗔无喜是为羼提波罗蜜。意无懈怠是为惟逮波罗蜜。于无所著不起狐疑是为禅波罗蜜。离于诸法是为般若波罗蜜。复次舍利弗。菩萨摩诃萨欲知过去当来今现在诸佛世尊之法者。当学般若波罗蜜。欲度有为无为之法。当学般若波罗蜜。欲觉过去当来今现在诸佛诸法如者。法相所起欲逮觉灭际者。欲过声闻辟支佛前。欲为一切诸佛给所当者。欲为诸佛世尊内眷属者。图大眷属者欲得菩萨眷属者。报大施者欲行无相施者。欲不起恶意者。欲不起恚恨意者。欲不起懈怠意者。欲不起乱意者。欲不起恶智者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲使一切立于布施戒念。作务劝助功德者。当学般若波罗蜜。菩萨摩诃萨欲立五眼者。当学般若波罗蜜。何等为五眼。肉眼天眼智眼法眼佛眼。复次舍利弗。菩萨摩诃萨欲得天眼见十方诸佛者。天耳听十方诸佛所说法者。欲悉知诸佛意者。当学般若波罗蜜。菩萨摩诃萨欲闻十方诸佛所说不断乃至阿耨多罗三耶三菩者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲见过去诸佛现在诸佛世尊刹土者。当学般若波罗蜜。菩萨摩诃萨欲闻十方诸佛所说。十二部经欲讽诵者。及诸声闻所未曾闻者。当学般若波罗蜜。菩萨摩诃萨欲闻十方诸佛。所可说法甫当所说。悉欲识知遍教众生者。当学般若波罗蜜。过去当来今现在诸佛所说诸法。欲尽闻知闻已遍教一切读者。当学般若波罗蜜。十方恒边沙诸佛世界。有窈冥之处日月所不照。欲持光明悉遍照者。当学般若波罗蜜。十方恒沙诸佛世界。有初不闻佛音法音僧音者。能立众生皆使正见闻三宝音者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨愿欲令十方恒沙世界众生。盲者得视。聋者得听。狂者得志。裸者得衣。饥渴者得饱满。当学般若波罗蜜。菩萨摩诃萨欲令十方恒沙国其中众生。诸在罪地三恶趣者。欲令解脱皆得人身者。当学般若波罗蜜。欲使恒沙世界皆令众生。具足戒行三昧智慧解脱见解脱慧。从须陀洹至阿罗汉辟支佛。乃至阿耨多罗三耶三菩及诸佛威仪者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲悉知道事俗事者。当学般若波罗蜜。欲使行时足离地四寸而轮迹现。诸四天王及阿迦腻吒天。与无央数诸天眷属围绕共至佛树。当使诸天以天上叠为座。使我成阿耨多罗三耶三菩。所游行处所住处坐处悉为金刚。当学般若波罗蜜。菩萨摩诃萨。欲使出家之日即成阿耨多罗三耶三菩。即出家日便转法轮。使无央数阿僧祇人。远尘离垢诸法法眼净。无央数阿僧祇人漏尽意解。无央数阿僧祇人得阿惟越致。成阿耨多罗三耶三菩。如是菩萨摩诃萨当学般若波罗蜜。菩萨摩诃萨愿作佛时。为无央数弟子众一时说法。便于座上得阿罗汉。发菩萨意者得阿惟越致。成阿耨多罗三耶三菩。无央数菩萨为增其寿命无量。其光明随其寿不增减。当学般若波罗蜜。菩萨摩诃萨成阿耨多罗三耶三菩时。欲令国土无淫怒痴之名。众生智慧悉皆得等。常念布施常念净戒自调自检不娆众生。般泥洹后欲使法无灭尽之名。当学般若波罗蜜。菩萨摩诃萨自愿得阿耨多罗三耶三菩时。其有闻我声者。必至阿耨多罗三耶三菩。欲得如是者。当学般若波罗蜜

    摩诃般若波罗蜜无见品第二

复次舍利弗。菩萨摩诃萨行般若波罗蜜。发是念时。四天王皆欢喜意念言。我曹亦当复以四钵奉上菩萨。如前王法奉诸佛钵。忉利天王及第六天王。皆欢喜意念言。是菩萨成佛时我曹亦当奉侍给使。减损阿须伦种增益诸天众。三千大千国土中诸阿迦腻吒天。各各欢喜亦复念言。是菩萨摩诃萨行般若波罗蜜成作佛时。我曹亦当劝助请佛使转法轮。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。于六波罗蜜转增益具足。善男子善女人。各各欢喜意自念言。我当为是菩萨作父母兄弟妻子眷属朋友知识。尔时四天王及诸阿迦腻吒天各各念言。当使是菩萨常修梵行。从初发意至成作佛。莫使与色欲共会。犯欲者失梵行况行道者。是菩萨常修梵行者必成至佛。不从犯欲而得成道。舍利弗白佛言。菩萨要当有父母妻子眷属耶。佛告舍利弗。菩萨或有父母无妻子。或有菩萨从初发意作童男行。至成作佛不娶妻色。或有菩萨以沤和拘舍罗。于五欲中示现发阿耨多罗三耶三菩意出家。舍利弗。譬如幻师善于幻法。化作五乐色欲。于中自恣共相娱乐。于意云何。是幻师所作。宁有所服食者不。舍利弗言。不也世尊。幻无所有。如是舍利弗。菩萨以沤和拘舍罗示现有欲。于色欲中育养一切无所沾污。观欲如火譬如怨家。说欲之恶志常秽之。菩萨虽在欲中示现常作是念。行权菩萨尚作是意。何况新学发意者乎。舍利弗白佛言。菩萨当云何行般若波罗蜜。佛告舍利弗。菩萨行般若波罗蜜者。不见有菩萨亦不见字。亦不见般若波罗蜜。悉无所见亦不见不行者。何以故。菩萨空字亦空空无有五阴。何谓五阴。色阴痛阴想阴行阴识阴。五阴则是空空则是五阴。何以故。但字耳。以字故名为道。以字故名为菩萨。以字故名为空。以字故名为五阴。其实亦不生亦不灭。亦无著亦无断。菩萨作如是行者。亦不见生亦不见灭。亦不见着亦不见断。何以故。但以空为法立名假号为字耳。菩萨行般若波罗蜜。不见诸法之字。以无所见故无所入

    摩诃般若波罗蜜假号品第三

复次舍利弗。行般若波罗蜜菩萨当作是观。菩萨者但字耳。佛亦字耳。般若波罗蜜亦字耳。五阴者亦字耳。舍利弗。一切有言吾我者亦皆字耳。索吾我亦无有吾我。亦无众生亦无所生。亦无生者亦无自生。无人无生无作无造。亦无成者亦无受者亦无授者无见无得。何以故。一切诸法无所有用空故。是故菩萨于一切字法都无所见。于无所见中复不有见。菩萨作是行般若波罗蜜。除诸佛过一切诸声闻辟支佛上。用无所有空故。何以故。一切不见所入处故。舍利弗。菩萨如是者。为行般若波罗蜜。譬如一阎浮提内。其中所有树木生草稻麻竽蔗丛林竹苇。悉如舍利弗目揵连等。其数如是智慧神足其德无量。欲比行般若波罗蜜菩萨。终不可得比无数亿百千倍。不可以譬喻为比。何以故。舍利弗。菩萨持智慧。度脱一切众生故。复次舍利弗。菩萨行般若波罗蜜所念智慧。一日之中过诸声闻辟支佛上。舍利弗。置阎浮提。其中草木三千大千国土。如舍利弗目揵连等其数满中。复置是事。十方恒边沙悉如舍利弗目揵连等尽满其中。其数如是不可计量。欲比菩萨行般若波罗蜜者。百分千分巨亿万分不得为比。行般若波罗蜜菩萨持是智慧。比诸声闻辟支佛之智慧。百千万倍不以为比。舍利弗白佛言。唯世尊。弟子所有智慧。从须陀洹至声闻辟支佛。上至菩萨诸佛世尊。是诸众智不相违背。无所出生其实皆空。无有差别不出不生。其实空者无有差特优劣。云何世尊。言行般若波罗蜜菩萨一日之念。出过声闻辟支佛上乎。佛告舍利弗。所以出彼上者。是菩萨行般若波罗蜜一日之念言。我当以道法因缘。当为众生觉一切法度脱众生。云何舍利弗。诸声闻辟支佛。颇有是念不耶。舍利弗言唯世尊。诸声闻辟支佛初无是念。是故舍利弗。当作是知当作是念。诸声闻辟支佛所有之智。欲比菩萨之智。百分千分巨亿万倍不可为比。复次舍利弗。声闻辟支佛颇作是念言。我当行六波罗蜜。教授众生净佛国土。具足佛十种力四无所畏四无碍慧。具足佛十八法。当成阿惟三佛。使不可计阿僧祇人令得泥洹。颇有是念不。舍利弗言唯世尊。无有是念。佛言。菩萨能尔。菩萨行六波罗蜜。具足十八法。成阿惟三佛。当度脱一切众生。舍利弗。譬如萤火虫不作是念言。我光明照阎浮提普令大明。如是舍利弗。诸声闻辟支佛亦无是念言。我当行六波罗蜜。具足十八法。成阿惟三佛度脱众生。舍利弗。譬如日出遍照阎浮提莫不蒙明者。如是菩萨行六波罗蜜具足十八法。成阿惟三佛。度不可计一切众生。舍利弗白佛言。云何菩萨过罗汉辟支佛地。逮得阿惟越致地。严治佛道地。佛告舍利弗。菩萨从初发意以来。常行六波罗蜜。住空无相无愿之法。过阿罗汉辟支佛地。逮阿惟越致地。舍利弗白佛言。菩萨住何所地。为声闻辟支佛而作福田。佛告舍利弗。菩萨从初发意以来。常行六波罗蜜乃至道场。于其中间常为声闻辟支佛作护。何以故。舍利弗。世有菩萨。便知有五戒十善八斋。四禅四等意四无形定。乃至三十七品法尽现于世。便具足十八事佛十种力四无所畏。世间适有是法。便知有王者种梵志种长者种迦罗越种。便知有第一四天王上至三十三天。便知有须陀洹斯陀含阿那含阿罗汉辟支佛。上至佛皆现于世。舍利弗白佛言。云何菩萨毕报施恩。佛告舍利弗。菩萨不报施福。何以故。本已报故。菩萨常施。持何等施施诸善法。何等善法。十善之法。从十善之法上至诸佛世尊之法。十力四无所畏具佛十八法。以是为施与。舍利弗白佛言。菩萨云何与般若波罗蜜相应。佛告舍利弗。菩萨当知色与空合。是为应般若波罗蜜。当知痛想行识与空合。是为应般若波罗蜜。当知眼耳鼻舌身意与空合。当知色声香味细滑识法与空合。眼色识耳声识鼻香识舌味识身细滑识法性识亦尔。是为应。当知苦习尽道四谛之法亦与空合。当知十二因缘。何等十二。一者痴二者所作行三者识四者名色五者六入六者栽七者痛八者爱九者受十者有十一者生十二者死。此十二因缘亦与空合。当知一切诸法有为法无为法亦与空合。当知本性亦与空合。是为应般若波罗蜜。如是舍利弗。菩萨摩诃萨知七空合。何谓七。上七事是也。知此七事与般若波罗蜜相应者。亦不见五阴合亦不见不合。亦不见生五阴法。亦不见灭五阴法。亦不见着五阴法。亦不见断五阴法。亦不见色与痛合。亦不见痛与想合。亦不见想与识合。亦不见识与行合。所以者何。初不见有法与法合者。性本空故。舍利弗。用色空故为非色。用痛想行识空故为非识。色空故无所见。痛空故无所觉。想空故无所念。行空故无所行。识空故不见识。何以故。色与空等无异。所以者何。色则是空空则是色。痛想行识则亦是空。空则是识。亦不见生亦不见灭。亦不见着亦不见断。亦不见增亦不见减。亦不过去当来今现在。亦无五阴亦无色声香味细滑法。亦无眼耳鼻舌身意。亦无十二因缘亦无四谛。亦无所逮得。亦无须陀洹斯陀含阿那含阿罗汉辟支佛。亦无佛亦无道。如是舍利弗。菩萨摩诃萨以般若波罗蜜。当作是念。当作是知。当作是应。作是行者。亦不见应亦不见不应。于六波罗蜜亦不见合于五阴法乃至身法。亦不见合与不合。三十七品佛十种力四无所畏及佛十八法乃至萨云若法。亦不见应与不应。是故舍利弗。当知菩萨与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜不与空合。不与无相无愿合。无相无愿不与空合。所以者何。空亦不见合亦不不合。无相无愿亦复如是。是为应般若波罗蜜。舍利弗。菩萨行般若波罗蜜。度空法相已亦不与五阴合亦不不合。过去色亦不与过去色合。亦不见过去色。当来色亦不与当来色合。亦不见当来色。现在色亦不与现在色合。亦不见现在色。痛想行识亦复如是。所以者何。去来今三世名皆空故。作是合者为应般若波罗蜜。舍利弗。菩萨行般若波罗蜜。萨云若法。亦不见与过去当来今现在合。亦不见过去当来今现在。菩萨当作是念。当作是应。复次舍利弗。萨云若。亦不见与五阴合。五阴亦不见与萨云若合。萨云若亦不与六情合。六情亦不与萨云若合。色声香味细滑法亦不与萨云若合。萨云若亦不与色声香味细滑法合。亦不不合。是为应般若波罗蜜。舍利弗。菩萨行般若波罗蜜。于檀波罗蜜亦不见与萨云若合。尸波罗蜜羼提波罗蜜惟逮波罗蜜禅波罗蜜乃至般若波罗蜜亦不见与萨云若合。亦不见萨云若与六波罗蜜合。亦不见萨云若与三十七品十力合。三十七品十力亦不见与萨云若合。亦不见萨云若。是为应般若波罗蜜。舍利弗。行般若波罗蜜菩萨。佛亦不与萨云若合。萨云若亦不与佛合。道亦不与萨云若合。萨云若亦不与道合。所以者何。萨云若则是佛佛则是萨云若。道则是萨云若萨云若则是道。是为与般若波罗蜜合。复次舍利弗。菩萨行般若波罗蜜。知五阴不与有合有亦不与五阴合。五阴亦不与苦乐有我无我合。六情法亦复如是。五阴亦不与空无相无愿合。亦不不合。亦不见行亦不见不行。菩萨当作是行当作是应。复次舍利弗。菩萨亦不以般若波罗蜜故。行檀行尸行羼行惟逮行禅波罗蜜。亦不以五波罗蜜故。行般若波罗蜜。亦不以阿惟越致故。教授众生。亦不以净佛国土故。行般若波罗蜜。亦不以四无所畏四无碍慧佛十种力十八法不共故。行般若波罗蜜。亦不以内空外空。所有无所有空空空大空毕竟空故。行般若波罗蜜。亦不以有为空无为空无底空诸法相空。一切诸法空。亦不以生空。亦不无生空。亦不真空。亦不伪空。亦不如亦不法性。亦不真际故。行般若波罗蜜行。所以者何。不见法有所破坏者。复次舍利弗。菩萨行般若波罗蜜。亦不以神足彻视彻听知他人意。自知宿命故行般若波罗蜜。所以者何。行般若波罗蜜者。尚不见般若波罗蜜。何况见有菩萨神通众事。是为应般若波罗蜜。舍利弗。行般若波罗蜜菩萨。心不自念。我当以神足到十方见诸佛世尊。亦不念言。十方诸佛有所说法我当听受。亦不念言。我当尽知十方众生心中所念。亦不自念。我当自知不可计劫所从生之事。亦复不念见。十方众生生死所趣善恶之趣。是菩萨为应般若波罗蜜。舍利弗。菩萨自念。我当度不可计阿僧祇人令般泥洹。是为菩萨行般若波罗蜜。菩萨作是行者。众魔不能得其便。诸世间之事皆为降伏。十方恒沙诸佛皆共拥护是菩萨。令不堕声闻辟支佛地。四天王上至阿迦腻吒天。是诸天皆共护是菩萨。不令中道有碍。是菩萨身中所有众病现世为愈。所以者何。用有普慈加众生故。当知是为应般若波罗蜜。复次舍利弗。菩萨行般若波罗蜜者。疾得陀邻尼诸三昧门皆现在前。在所生处常见诸佛乃至道场常不离佛。是为应般若波罗蜜。菩萨行般若波罗蜜者。亦不念有法合与不合等与不等。所以者何。以不见法合亦不见法等。是为应般若波罗蜜。菩萨行般若波罗蜜者。亦不念。我当疾逮觉法性亦不不逮觉。何以故。法性者无所逮觉是为合。复次舍利弗。行般若波罗蜜菩萨。不见有法与法性别者亦不见合。亦不念言法性作若干差别。是为菩萨一切皆合。亦不作念言是法于法性现亦不不现。何以故。初不见于法性现者。当知是则为合。复次舍利弗。菩萨行般若波罗蜜者。于法性不与空合。空亦不与法性合。是为合。六情十八性亦不与空合。空亦不与六情十八性合。乃至法性不与空合。空亦不与法性合。舍利弗。如是空合最为第一。行空菩萨不堕声闻辟支佛地。净佛国土教授众生疾成至佛。舍利弗。诸所有应般若波罗蜜无过。是应最尊第一应无上。所以者何。为是空无相无愿无上正真应故。舍利弗。如是行者。当知是菩萨已受莂近于道场。如是行者。为不可计阿僧祇人而作益厚。菩萨亦不念言。我与般若波罗蜜相应。亦复不念。诸佛世尊当授我莂。亦不念。我受莂不久当净佛国土。亦不念。我当成至佛而转法轮。所以者何。与法性一体无有别。亦不见有法。行般若波罗蜜者。亦不见诸佛有所说。为阿耨多罗三耶三菩者。何以故。菩萨行般若波罗蜜。初不见有生众生相。亦不见灭众生相。何以故。一切众生初不见起灭故。一切众生不见有生。尚不见有生灭。云何行般若波罗蜜。菩萨作是行者。为行般若波罗蜜。不起众生相。不空众生相。不见众生行不别众生行。是为菩萨行第一空行。菩萨住是中者。为都合集。众合于其中住。菩萨如是住者。为处大慈大悲。无嫉慢意无乱怠意。无恚恨意无起恶意。不起恶智意也

放光般若经卷第一放光般若经卷第二

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜学五眼品第四

舍利弗白佛言。菩萨摩诃萨应般若波罗蜜者。从何所来而生是间。于是间去复生何所。佛告舍利弗言。菩萨与般若波罗蜜相应者。于兜率天上来生是间。或于他方佛国来生是间。或从人道中来生是间。从兜率天上来者。终不失般若波罗蜜。诸陀邻尼诸三昧门诸众智门悉皆在前。从他方佛国来者。便疾成般若波罗蜜。于智慧中日日增益。诸深法要皆现在前。却后乃成般若波罗蜜。所生常见诸佛不离诸佛。从人道中来者。是菩萨未及阿惟越致者。诸根闇钝不能疾得般若波罗蜜。不能便见陀邻尼门。舍利弗。汝所问菩萨习行般若波罗蜜者。于是间终当生何所。是菩萨当生他方佛国。从一佛国复生一佛国。常见诸佛不离诸佛。世尊。复有菩萨无有沤和拘舍罗。从四禅行六波罗蜜。持是禅福生长寿天。不尽天寿来生世间供养诸佛。是菩萨辈诸根闇钝不大聪明。舍利弗。复有菩萨行于四禅及四等意四无形禅念。三十七品大慈大悲。持沤和拘舍罗禅福不能稽留。常生诸佛所教授处。当生是拔陀劫中成逮觉者。常不离般若波罗蜜。复有菩萨以行四禅及四等意四无形定。以沤和拘舍罗不随禅生。生于种姓大豪贵家。生梵志家生迦罗越家。所可生处常教众生。复有菩萨行四禅四等意四无形定。以沤和拘舍罗不为禅所稽留。来生四王天生忉利天生第六天。常教授诸天净佛国土。教授众生供侍诸佛。复有菩萨行般若波罗蜜。以沤和拘舍罗行第一禅。生于梵天于梵天中尊。从梵天已至十方诸佛转法轮处。请诸佛世尊转于法轮。复生一生补处菩萨。行般若波罗蜜。以沤和拘舍罗。具于四禅具四等意四无形定。三十七品空无相无愿。具足三昧不随禅处常见诸佛供事世尊。持清净行便生兜术天。于其天上随其寿命诸根具足。为无央数诸天人眷属围绕而为说法。已复来生世间人中。作阿惟三佛。舍利弗。复有菩萨得六神通不生欲界形界无形界。从一佛国至一佛国礼事诸佛。复有菩萨得六神通游诸佛刹。其所至处。无有声闻辟支佛教名。复有菩萨持六神通生诸佛刹。其寿无量往生其国。复有菩萨以六神通游诸世界。到无佛处于其刹中叹佛法众。令彼众生闻三尊之功德。闻已欢喜皆得往生诸佛国土。复有菩萨从初发意得于四禅得四清净四无形定。三十七品乃至佛十八法。不生三界常生有益于众生之处。复有菩萨行六波罗蜜。从初发意便上菩萨位至阿惟越致地。复有菩萨从初发意便得阿惟三佛转于法轮。益于无数亿百千众生已。于无余界而般泥洹。其法留住或半劫一劫。复有菩萨适发道意便与般若波罗蜜相应。与诸无数亿百千诸菩萨。共游诸佛国净诸佛土。复有菩萨行六波罗蜜四禅四等至四无形定。皆于其中而自娱乐。住于四禅从四禅起还至解脱禅定。解脱禅起至无形定。从无形定起入解脱禅。从解脱禅起至无思想慧禅。复从是起还入解脱。以沤和拘舍罗入蒱佉阇三昧。是为行般若波罗蜜。复有菩萨以三十七品乃至佛十八法。不取声闻辟支佛证。复有菩萨行般若波罗蜜。以沤和拘舍罗入三十七品。诸发小道者各使得度。诸有声闻及辟支佛所得道慧。皆是菩萨之忍也。行般若波罗蜜者。当知是为阿惟越致。舍利弗。复有菩萨行六波罗蜜生兜术天者。当知是拔陀劫中诸菩萨等也。复有菩萨以四禅福乃至佛十八法。所可有道志不信受。当知是菩萨则一生补处。复有菩萨行六波罗蜜。从一佛刹复至一佛国。建立众生使至道场。知是菩萨从初发意以来。当更无数阿僧祇劫乃成佛耳。复有菩萨行六波罗蜜。为众生故不说无益之事。复有菩萨行六波罗蜜。为众生故。从一佛国复至一佛国断三恶趣。复有菩萨行六波罗蜜。常以惠施安乐一切。恣所求索象马车乘衣被财谷国城珍宝皆给与之。复有菩萨行般若波罗蜜。能自变身如佛形像。入三恶趣。随其语言而为说法皆度脱之。复有菩萨行六波罗蜜。变身如佛遍至十方。教授众生能净佛土。已至十方。悉观诸佛威仪法则好丑清浊。而便自起上妙最尊殊异之土。淳以一乘教诸一生补处菩萨。复有菩萨行六波罗蜜。便具大士三十二相诸根特异。众生见者莫不敬喜。因其欢喜以三乘法。而度脱之令般泥洹。舍利弗。菩萨行般若波罗蜜者。先当学清净身口意。便得诸根特异已得殊异亦不自举亦不下人。复有菩萨从初发意行檀波罗蜜尸波罗蜜。乃成阿惟三佛。初不堕三恶趣。复有菩萨从始发意至阿惟越致。初不忘舍十善之行。复有菩萨行檀尸波罗蜜。得作遮迦越罗。得化众生建立十善。所有财宝惠施众生。复有菩萨行檀尸波罗蜜。亿百千反作遮迦越罗。常供养诸佛恭敬启受。复有菩萨行六波罗蜜。为诸众生照明法化。乃至阿惟三佛不离照明。是故菩萨常明佛法。是为菩萨摩诃萨行般若波罗蜜。菩萨行者。常摄身口意不善之事不令妄起。舍利弗白佛言。何谓菩萨摄身口意。佛言。菩萨心念不持身口意。诸恶因缘用作罪事。菩萨行般若波罗蜜。亦不见身口意。虽有身口意。终不嫉恚邪见。不两舌恶口妄言绮语。无杀盗淫无懈慢意意初不起恶智之事。若有菩萨不能[僉*殳]此诸恶事者此非菩萨。复有菩萨行六波罗蜜者。除身恶行除口恶言除意恶念。舍利弗白佛言。何谓菩萨除身口意。佛言。菩萨不猗身口意是故能除。菩萨从初发意以来常奉十善。是故过诸声闻辟支佛上。菩萨行般若波罗蜜者。净于佛道净于六波罗蜜。舍利弗白佛言。云何菩萨净于佛道。佛言。菩萨不猗身口意。不猗六波罗蜜。不猗罗汉辟支佛。不猗菩萨亦不猗佛。所以者何。于一切法无所猗故。是为菩萨道。舍利弗。复有菩萨一一行诸波罗蜜。用是故无能伏者。舍利弗白佛言。云何菩萨行六波罗蜜无能伏者。佛言。菩萨行六波罗蜜者。不有念五阴六情。不有念色声香味细滑法。不有念十八性。不有念三十七品。不有念六波罗蜜。不有念佛十种力四无所畏佛十八法不共。不有念声闻辟支佛道。不有念佛道。不有念阿耨多罗三耶三菩。如是舍利弗。菩萨行六波罗蜜。于功德中展转增益。用是故无能伏者。复次舍利弗。菩萨住于般若波罗蜜具足萨云若。以诸慧不堕恶趣不堕贫贱中。所受身体诸根具足人不憎恶。常为诸天阿须伦所敬爱。舍利弗白佛言。云何菩萨摩诃萨慧。佛言。菩萨以具足诸慧尽见恒沙诸佛世尊。从诸世尊听受法教。悉闻诸佛德好之法。得慧菩萨无有佛想亦无菩萨想。亦无声闻辟支佛想。亦无我想亦无人想。亦无诸佛国想。慧行菩萨行檀波罗蜜。亦不见檀亦不见般若波罗蜜。行三十七品亦复不闻三十七品名。亦不见佛十八法。舍利弗。是为菩萨之慧。以是慧故具足诸法。亦不贡高见一切诸法。行般若波罗蜜菩萨净于五眼。肉眼天眼慧眼法眼佛眼。舍利弗白佛言。何谓菩萨净于肉眼。佛言。有菩萨以肉眼见百踰旬中二百踰旬。有菩萨以肉眼见一阎浮提见二阎浮提见四天下。有菩萨以肉眼见千世界见二千世界有见三千世界。是为菩萨于肉眼净。舍利弗白佛言。何谓天眼。佛言。菩萨以天眼见四王天上所有悉识悉知。从忉利天至第六天乃至阿迦腻吒天。菩萨悉见悉识悉知。从四王天上至阿迦腻吒天。此诸天人。皆不识不知不见菩萨天眼所见。菩萨天眼。悉见十方恒沙世界。众生生死善恶之事悉见悉知。是为菩萨于天眼净。舍利弗白佛言。何谓菩萨于慧眼净。佛言。菩萨慧眼不作是念。有为法无为法。有道法俗法。慧眼菩萨。无法不见无法不闻无法不识无法不觉。是为菩萨于慧眼净。舍利弗白佛言。何谓菩萨得法眼净。佛言。菩萨以法眼。见是人坚信坚住于法。是人无相无愿之脱立。于五根受不中止定。于不中止定成解脱慧。以解脱慧度于三碍。有身碍有狐疑碍有邪信碍。度是三碍得须陀洹便道得念于淫怒痴薄得斯陀含。精勤于道却淫怒痴得阿那含。便消五爱。一者色爱二者无色爱三者痴爱四者恨戾爱五者乱志爱。已度是者便得罗汉。如是行空菩萨便得空脱便成五根。疾近不中止禅至罗汉道。是人已得无相解脱。逮得五力乃至罗汉。是为菩萨得法眼净。菩萨所知生法即是灭法便逮五根。是为菩萨得法眼净。菩萨发意。从檀波罗蜜至般若波罗蜜。具足信根精进办根沤和拘舍罗根。持是三根及诸功德。便生王者家大种姓家梵志家迦罗越家。生四天王上至第六天。便于其中育养教化众生。随其所乐净佛国土礼事诸佛。不堕声闻辟支佛地当成三耶三佛。是为菩萨得法眼净。法眼菩萨悉知一切从佛受决未受决者。有动还者不动还者。有具足神通者未具足者已。具足神通游诸世界礼事诸佛者有未得是者。得佛国净者得不净者。菩萨教化众生者不教众生者。菩萨为诸佛所称誉者不称誉者。菩萨有亲近诸佛者有不亲近者。菩萨成佛其弟子众诸菩萨数。其数无限者有限者。是菩萨成佛时。以诸菩萨为僧者不以菩萨为僧者。有菩萨以勤苦行成佛者不以勤苦行成佛者。有菩萨一生补处者未补处者。有菩萨至道场者不至道场者。有菩萨坐树下降致魔者不致魔者。是诸众事一一悉知。是为菩萨得法眼净。舍利弗白佛言。何谓菩萨得佛眼净。佛言。已得金刚三昧得萨云若。佛十种力四无所畏。行四等心十八不共大慈大悲。是菩萨眼所见诸法一切众事。无事不见无声不闻无物不护无法不觉。舍利弗。是为菩萨得阿惟三佛得最正觉眼。菩萨欲得五眼净者。当习六波罗蜜。所以者何。诸所有善法悉含在六波罗蜜中故。一切菩萨声闻辟支佛法诸法等者。无过般若波罗蜜等。般若波罗蜜者。是五眼之母。菩萨学五眼者。疾成阿惟三佛

    摩诃般若波罗蜜度五神通品第五

复次舍利弗。菩萨行般若波罗蜜。当念具足度五神通。逮诸菩萨无量神足。能动天地变身无数更合为一。彻视无碍石壁皆过。譬如鸟飞无所触碍。能履水蹈虚身出水火手扪摸日月身至梵天。有是神通不自贡高不见贡高。用本空故。谁有能起是神足者。唯有得萨云若者乃能起是耳。舍利弗。菩萨学般若波罗蜜者。为已得神足之证。耳所彻听为过诸天人耳。虽得彻听亦不贡高。于有无之中了无所得。于有空无空无所生。菩萨行般若波罗蜜。得天耳慧神通之证。能知他人心中所念。知有淫怒痴者无淫怒痴者。知有爱欲意无爱欲意者。知有有者知无无者。知有乱意无乱意者。有多者有少者。有定意者无定意者。有脱者无脱者。有高者有下者。虽知是不自贡高。何以故。是意非意故意不可思议故。以神通灭宿命之证。识一意至百意。从一日至百日一月至百月一岁至百岁一劫至百劫。无数百劫无数千劫无数亿百千那术。尽自识知。名姓种族所作所习寿命长短。所受苦乐死此生彼从彼生此。所作事物威仪礼节都识所。更不以神通而自贡高。菩萨学如是为学般若波罗蜜。以神通明识宿命。以天眼见众生生死所趣善恶之道。所得高下各随本行。身行恶口言恶意念恶。谤毁圣贤信邪倒见。以邪见因缘自怀其身死堕地狱中。为人身善言念亦善。不谤圣贤正见信行得生天上。能见十方众生乃至五道。所见如是其一神通之德尽见十方。持神通灭漏尽之证。不取声闻辟支佛道。不持余法当成阿惟三佛。不以神通漏尽证故而自贡高。菩萨行般若波罗蜜具足神通。其功德转增上乃至阿惟三佛。有菩萨行般若波罗蜜。住檀波罗蜜净除萨云若迹计空无狐疑。菩萨住尸波罗蜜。净除萨云若迹不疑罪福以空无所起故。舍利弗。有菩萨住羼波罗蜜中。净除萨云若迹以空故不起嗔恚。菩萨住惟逮波罗蜜。净除萨云若迹于身精进不起懈怠。菩萨住禅波罗蜜。净除萨云若迹定志意不起。菩萨住般若波罗蜜中。净除萨云若迹不起愚痴。菩萨行般若波罗蜜。住六波罗蜜中。净除萨云若迹从空来往。不疑不犯。不嗔不忍。不进不怠。不定不乱。不智不愚。亦不施与亦不有贪。不戒不犯。不进不退。不忍不恚。不定不乱。不慧不痴。不谤不誉。不有为不无为。如是舍利弗。无所从生法。无有骂者无有叹者。无有为无无为。是为菩萨摩诃萨行般若波罗蜜。以得奇特之德。诸声闻辟支佛所不能及。具足之德以教众生净佛国土

    摩诃般若波罗蜜授决品第六

复次舍利弗。菩萨行般若波罗蜜。以发等意于一切人发等意。已便得一切诸法等。已得诸法等便能等意于一切法。便为现在诸佛菩萨罗汉辟支佛之所爱敬。所在生处眼终不见恶色意初无恶念。行般若波罗蜜菩萨终不耗减于阿耨多罗三耶三菩。尔时说般若波罗蜜行时。坐中有三万比丘。以身所著衣尽用奉佛。皆发无上正真道意。于是佛笑。时阿难从坐起正衣服右膝着地叉手白佛言。佛不妄笑会当有意。佛告阿难。是三万比丘于是寿终当生阿閦佛国。却后六十二劫皆当作佛号声闻支头。复有六万欲天子。皆当生弥勒佛前。皆当出家作沙门。佛之威神令会者见东方千佛及四部众及诸十方各千佛现。尔时沙诃楼陀刹土。不如彼佛国土严净。尔时坐中有十千人。皆发愿言。我曹皆当作功德生彼净国。尔时佛知善男子意所念佛复笑。阿难白佛愿闻笑意。佛告阿难。见是万人不。阿难言。唯然世尊已见。佛言。是万人寿终皆当往生彼诸佛国。皆不离诸佛世尊。后当作佛号庄严王如来无所著等正觉

    摩诃般若波罗蜜妙度品第七

尔时尊者舍利弗摩诃目揵连须菩提摩诃迦叶。及诸大神通比丘。复有余大神通菩萨摩诃萨。诸优婆塞优婆夷。俱白佛言。唯世尊。般若波罗蜜者。是菩萨摩诃萨之最大度上度妙度无上尊度。唯世尊辩才之度无与等者。复无无等度法度空度空无相度诸法空度有无空度具足诸德空度。唯世尊。是诸菩萨摩诃萨行般若波罗蜜。其功德普具无能伏者。唯世尊。令是菩萨摩诃萨成般若波罗蜜功德。行般若波罗蜜菩萨。已作是无等等之施。无与等者。种种具足檀波罗蜜。身体种种无有与等者。已得无等之利行般若波罗蜜。自致得成阿惟三佛。唯世尊。世尊亦复行般若波罗蜜。种种无与等法之本。种种无等之欲本。种种无与等五阴之利。转无上法轮。过去当来诸佛世尊。行般若波罗蜜亦复如是。亦复转于无上法轮。唯世尊。诸菩萨摩诃萨欲得度于诸法彼岸。当习行般若波罗蜜。唯世尊。若有菩萨摩诃萨行般若波罗蜜者。诸天龙鬼神诸阿须伦世间人民。皆当为作礼。佛告诸大会比丘及诸菩萨。当为善男子善女人行般若波罗蜜者作礼。诸天龙神皆当作礼。佛告舍利弗。世有菩萨摩诃萨。便有诸天帝王世间人民。便有梵志迦罗越种。便有转轮圣王。便有四大天王乃至阿迦腻吒天。便有须陀洹道罗汉辟支佛道。便有菩萨便有佛道。已有菩萨便有供养衣服饮食床卧七宝珠玑璎珞琉璃摩尼。舍利弗。天上世间人所娱乐便身之具。以菩萨故皆悉有是。所以者何。行菩萨之事。住于六波罗蜜中调伏众生。使布施乃成般若波罗蜜。菩萨摩诃萨欲安隐众生者。当行般若波罗蜜

    摩诃般若波罗蜜舌相光品第八

尔时世尊出广长舌相。普遍三千大千世界。于其舌根出种种无央数百千光明。彻照十方各一恒沙国。是时东方及十方国土无央数诸菩萨。见是光明各各自白其佛。是何瑞应有是大光明。佛告诸菩萨言。西方去是度一恒边沙。有佛世界名沙诃。其佛号释迦文。出舌相光明。为诸菩萨说般若波罗蜜。今有是应。于是十方恒沙国诸菩萨各白其佛言。我等欲往见释迦文及诸菩萨。并欲闻般若波罗蜜。诸佛各各告诸菩萨言。欲往随意。于是诸菩萨各各取诸名华名香。种种幢幡珍宝华盖。发其国土来诣忍界。诸四天王乃至阿迦腻吒天各持天上诸名香华来诣佛所。诸天人诸菩萨皆悉来至。见释迦文佛已。各各供养散诸名华。所散华宝即于佛上在虚空中化成四柱台。其台高显四面窗向。台遍三千大千刹土各各莫不见有好台。罗列分别不相障蔽。其台妙好交露庄严未曾所有。于是坐中诸亿百千人。各各从坐起长跪叉手前白佛言。唯世尊。愿使吾等于当来世逮得法利当如世尊。今于百千众围绕说法。所现感动亦当如是。佛于是知诸大众各已有仍堪任于诸法无所从生法忍。佛便笑。阿难白佛。何因缘笑愿闻其意。佛告阿难。是亿百千众皆得无所从生法忍。却后六十八亿劫劫名散华。皆当作佛号觉华如来无所著等正觉

    摩诃般若波罗蜜行品第九

于是世尊告须菩提言。为诸菩萨摩诃萨。说所从因成就般若波罗蜜。是时诸会菩萨大弟子诸天人意念言。今须菩提为诸菩萨说般若波罗蜜。自持辩才说耶是佛威神乎。须菩提知诸菩萨大弟子天人意之所念。语舍利弗言。敢佛弟子。所说法所出音声所可教授。皆是世尊大士之务。佛所说法事与法不相违背。是善男子。学法以法作证。舍利弗。我等当承佛威神为诸菩萨摩诃萨说般若波罗蜜。非我等所入境界也。声闻辟支佛。不能为菩萨摩诃萨说般若波罗蜜。于是舍利弗须菩提。共白佛言。唯世尊。言菩萨菩萨者。何所法中有言菩萨乎。我等初不见法有菩萨者。我初不见菩萨。亦不见菩萨字。亦不见般若波罗蜜。当为何所菩萨而说般若波罗蜜。佛告须菩提。般若波罗蜜菩萨及字。亦不在内亦不在外亦不在两间中止。佛告须菩提。譬如字众生为众生。言我人言生是男是士是夫是作是知是觉。佛告须菩提。设是名法但著名字。亦不生亦不灭。从久远以来但共传字耳。佛语须菩提。所谓般若波罗蜜。所谓菩萨及菩萨字。但着字法从久远以来但行其字。亦不生亦不灭。须菩提。譬如所有色痛想行识但着字法。从久远以来因缘合为数。诸因缘合数法。亦不生亦不灭也。所谓般若波罗蜜。所谓菩萨及菩萨字亦复如是。佛告须菩提。所谓眼耳鼻舌身意。从久远以来但着字法。亦不生亦不灭。色声香味细滑法亦复如是。亦不内亦不外。亦不生亦不灭。从久远以来但着字法。般若波罗蜜菩萨及字。亦不内亦不外。亦不在两中间止。佛告须菩提。譬如内身所有名为头。字为颈肩臂脊肋髀腨肠脚。是法亦不生亦不灭。亦不内亦不外。亦不两中间止。所谓般若波罗蜜菩萨及字亦复如是。佛告须菩提。譬如外诸所有草木枝叶茎节。从久远以来但著名字。是字亦不生亦不灭。亦不内亦不外。所谓般若波罗蜜菩萨及字亦复如是。佛告须菩提。譬如过去诸佛世尊。从久远来因字如住。是字亦不生亦不灭。亦不内亦不外。须菩提。譬如梦响幻热时之炎。如如来所化皆着字数法。所谓般若波罗蜜所谓菩萨及字。亦不生亦不灭。亦不内亦不外。亦不两中间止。佛告须菩提。菩萨摩诃萨行般若波罗蜜。当学字法合法及权法数。行般若波罗蜜。不见色痛想行识字有常无常。亦不见五阴字有苦有乐。亦不见五阴有我无我。亦不见五阴空无相无愿。亦不见五阴净亦不见寂。亦不见着亦不见断。亦不见五阴生亦不见灭。眼耳鼻舌身意。色声香味细滑法。及十八性亦复如是。行般若波罗蜜菩萨摩诃萨不于有为性中现般若波罗蜜。亦不见菩萨。亦不见菩萨字。亦复不于无为性中见。所以者何。须菩提。菩萨摩诃萨行般若波罗蜜。于诸法无想念故。行般若波罗蜜住于无想法。成三十七品行般若波罗蜜。亦不见般若波罗蜜。亦不见般若波罗蜜字。亦不见菩萨。亦不见菩萨字。行般若波罗蜜。成佛十八法。亦复不见般若波罗蜜。亦不见般若波罗蜜字。亦不见菩萨字。菩萨行般若波罗蜜。为已尽超越诸法之相。超越已亦不见亦不断。佛告须菩提。菩萨行般若波罗蜜。当学知字数合法。觉已不入色。亦不入痛想行识。亦不入眼耳鼻舌身意。亦不入色声香味细滑法。亦不入十八性。亦不入意识觉。亦不入苦乐。亦不入不苦不乐。亦不入有为性。亦不入无为性。亦不入檀尸羼惟逮禅。亦不入般若波罗蜜。亦不入相好。亦不入菩萨身。亦不入五根。亦不入慧度。亦不入度神通。亦不入度慧亦不入内外空。亦不入所有无所有空。亦不入教化众生。亦不入净佛国土。亦不入沤和拘舍罗。何以故。不见诸法当有可入者。佛告须菩提。菩萨摩诃萨行般若波罗蜜。于诸法无所入。便增益六波罗蜜便履菩萨位。履菩萨位过阿惟越致地。具足诸神通具足神通已游诸佛国。育养众生供养礼事。净佛国土尽见诸佛。从诸佛求愿即随其所欲而皆得之。从诸佛世尊闻法。得诸陀邻尼三昧门。乃至阿耨多罗三耶三菩。终无有断绝时。佛告须菩提。菩萨行般若波罗蜜。当具知是法数着字。于须菩提意云何。色痛想行识为是菩萨耶。眼耳鼻舌身意是菩萨耶。须菩提对曰。非也世尊。佛言。于须菩提意云何。以色声香味细滑法为是菩萨耶。眼识耳识鼻识舌识身识意识为是菩萨耶。对曰。非也世尊。佛告须菩提。于意云何。以地水火风空识为是菩萨耶。对曰非也。以痴为是菩萨耶。行识名色六入栽觉爱受有生死是菩萨耶。对曰非也世尊。佛告须菩提。于意云何。离五阴六衰六情十八性地水火风空。离十二因缘。是菩萨耶。对曰非也世尊。佛告须菩提。五阴十二因缘如。为是菩萨耶。对曰非也世尊。于须菩提意云何。可离如为菩萨耶。须菩提对曰。非也世尊。佛告须菩提。汝观何等义。而言五阴六衰十二因缘及如非菩萨。亦不离五阴六衰十二因缘及如为菩萨也。尊者须菩提白佛言。世尊。初不见有众生。当于何许有菩萨。云何以五阴六衰十二因缘为菩萨。云何当离五阴六衰十二因缘为菩萨。如如亦非菩萨。离如亦非菩萨。无有是处。世尊赞叹须菩提言。善哉善哉须菩提。菩萨学当作无所见学。不见众生不见般若波罗蜜。于须菩提意云何。以五阴常故言菩萨耶。以五阴无常故为菩萨耶。以五阴是我所为菩萨耶。非我所为菩萨耶。以五阴空无相无愿故言是菩萨耶。须菩提对曰。非也世尊。佛言。离五阴空无相无愿为是菩萨耶。须菩提对曰。非也世尊。佛告须菩提。汝观何等义。而言五阴空无相无愿非菩萨。亦不离五阴空无相无愿为菩萨乎。须菩提白佛言。初不见五阴。当云何以五阴故言菩萨。初不见有常。云何以无常故言菩萨。须菩提白佛言。世尊。初不见有乐。云何以五阴苦为菩萨。初不见有我。云何以五阴无我而为菩萨。初不见有人。云何以五阴空故而言有菩萨。世尊初不见有相。云何以五阴无相而为菩萨。世尊初不见愿。云何以五阴无愿而为菩萨。尔时世尊赞叹须菩提言。善哉善哉。菩萨摩诃萨学。当于五阴作空无相无愿无所见无所得。菩萨行般若波罗蜜。当作是学。佛告须菩提。汝向者所言。我不见法有菩萨。实如所言。须菩提。法法不相见。法不见法性。法性亦不见法。五阴性不见法性。法性不见五阴性。六情性不见法性。法性不见六情性。佛告须菩提。有为性不见无为性。无为性不见有为性。有为不离无为。无为亦不离有为。佛告须菩提。菩萨作是行般若波罗蜜。于诸法无所见。虽不见诸法。亦不恐亦不畏惧不悔亦不懈怠。何以故。以不见五阴。不见眼耳鼻舌身意。亦不见色声香味细滑法故。亦不见淫怒痴。亦不见十二因缘。亦不见吾我。亦不见知见事。亦不见三界。亦不见声闻辟支佛意。亦不见菩萨亦不见菩萨法。亦不见佛亦不见佛法。亦不见道。一切诸法尽不见。亦不恐亦不怖亦不畏惧。须菩提白佛言。世尊。菩萨何以故不恐不畏。佛告须菩提。以菩萨意识法不可得不可见。以是故不恐不畏。菩萨当于诸法。当作无所得无所见学行般若波罗蜜。亦不见般若波罗蜜。亦不见菩萨。亦不见菩萨字。亦不见菩萨意。是则菩萨学是则菩萨行

    摩诃般若波罗蜜学品第十

是时须菩提白佛言。世尊。菩萨摩诃萨欲具足檀波罗蜜当学般若波罗蜜。欲具足尸羼惟逮禅波罗蜜当学般若波罗蜜。菩萨摩诃萨欲知色痛想行识当学般若波罗蜜。欲知六情内外者当学般若波罗蜜。欲知十八性。欲消灭淫怒痴。欲消灭吾我想。当学般若波罗蜜。欲除狐疑。欲除犯戒望见。欲除三界淫诤。欲舍六衰习。欲除四食。欲舍四渊流四结四颠倒。欲舍十恶知十善之行。当学般若波罗蜜。欲知四禅三十七品四等心及佛十八法当学般若波罗蜜。欲得学意三昧者当学般若波罗蜜。欲知四禅及四空定。欲得师子游步师子奋迅三昧者。欲得诸陀邻尼三昧。首楞严三昧海宝三昧。月幢三昧。诸法普至三昧。观印三昧。真法性三昧。作无垢幢三昧。金刚三昧。诸法所入门三昧。三昧王三昧。王印三昧。力净三昧。月幢三昧。诸法所入真辩才三昧。诸法言所入照十方三昧。诸法陀邻尼门印三昧。不妄诸法三昧。诸法都聚印三昧。虚空所止三昧。净三昧。处三昧。不起神通三昧。作上幢三昧。菩萨欲得是诸三昧门及余三昧者。当学般若波罗蜜。须菩提白佛言。唯世尊。菩萨摩诃萨欲满一切众生之所愿者。当学般若波罗蜜。菩萨欲具足诸功德。持是具足之德不堕罪处。亦不生卑贱之家。亦不在罗汉辟支佛地住。亦不为菩萨顶诤。当学般若波罗蜜。舍利弗语须菩提言。云何为菩萨顶诤。须菩提报言。菩萨摩诃萨不以沤和拘舍罗行六波罗蜜。复不以沤和拘舍罗趣空无相无愿三昧。堕声闻辟支佛地亦不顺菩萨道。是为菩萨顶诤。舍利弗问须菩提。何以故。名为菩萨顶诤。须菩提报言。所谓法爱是。问言。何等为法爱。须菩提报言。菩萨摩诃萨行般若波罗蜜。入于五阴计校五阴空无相无愿。是为顺法爱。入于五阴计校五阴空寂无常苦空非我。是为菩萨法爱。计校言当灭五阴。是无为证是非证。是成道。是着是断。是可习是不可习是菩萨行。是非菩萨行。是道是非道。是菩萨学是非菩萨学。是六波罗蜜是非六波罗蜜。是沤和拘舍罗是非沤和拘舍罗。是菩萨顺法爱。须菩提语舍利弗言。菩萨行般若波罗蜜。入法中计校分别。是为菩萨顺法爱。舍利弗语须菩提言。何等为菩萨顺道。须菩提报言。菩提行般若波罗蜜。不以内空观外空。不以外空观内空。不持内外空观空空。不持空空观内外空。亦不以空空见大空。亦不以大空观空空。亦不以大空见最第一空。最第一空亦不见大空。第一空亦不观有为空。有为空亦不观第一空。亦不持有为空观无为空。亦不持无为空观有为空。亦不持无为空观无边际空。亦不以无边际空观作空。作空亦不观性空。性空亦不观作空。作空亦不观自空。自空亦不观性空。自空亦不观诸法空。不持诸法空观自空。诸法空亦不观无空。无空亦不观诸法空。诸法空亦不观有空。有空亦不观无空。有空亦不观无有空。无有空亦不观有空。舍利弗。菩萨作是行般若波罗蜜。转上便应菩萨之道。复次舍利弗。菩萨作是学般若波罗蜜。不念五阴。亦不贡高。亦不念眼耳鼻舌身意。不念色声香味细滑法。亦不念六波罗蜜乃至佛十八法。不念亦不贡高。作是学般若波罗蜜。亦不念道意妙无与等者。亦不念不贡高。所以者何。是意非意。意性广大而清净故。舍利弗问须菩提言。云何意性广大而清净。须菩提报言。于淫欲痴亦不合亦不散。不与尘劳合亦不散。不与恶行及六十二见合亦不散。亦不与声闻辟支佛意合亦不散。是为菩萨意性广大而清净。舍利弗复问言。意为有耶言是意非意。须菩提报言。意无所念时。有意无意宁可得可见可知不。舍利弗报言。唯须菩提。不可得不可见不可知。须菩提语舍利弗。若意无念时。亦不见有意亦不见无意。亦不可得亦不可见。是故即为清净。舍利弗问须菩提。何等为无意意。报言。于诸法无作无念是为无意意。舍利弗复问。无为无作亦是意耶。于五阴无为无作亦复是意。乃至道无为无作亦是意耶。须菩提报言。如是如是。如所问。是时舍利弗赞叹须菩提言。善哉善哉。如须菩提为是佛子为从佛生为从法化生。则为法施非为思欲施。随其证而为说法。实如佛所举乐空寂行第一。菩萨摩诃萨当作是学般若波罗蜜。便为阿惟越致。终不离般若波罗蜜。菩萨欲学知声闻辟支佛地。当学般若波罗蜜。当读当习当持。欲学菩萨地当学般若波罗蜜。当读当学当持当习。何以故。般若波罗蜜中广说三乘之教。菩萨摩诃萨声闻辟支佛。亦当从是中而学成

    摩诃般若波罗蜜本无品第十一

是时须菩提白佛言。世尊。如菩萨行般若波罗蜜。我亦不觉有菩萨亦不见菩萨。当为何等菩萨说般若波罗蜜。当教谁不见诸法终始。云何当为菩萨作字言菩萨耶。世尊。是字必不住亦不不住。所以者何。是字亦不见亦不可得。世尊。我亦不见五阴终始。云何当为菩萨作字。是故世尊。是字不住亦不不住。世尊。我亦不见六情六衰终始。当云何为菩萨作字。是字不住亦不不住。所以者何。是字亦不可见不可知。云何为菩萨建字。是字亦不可见亦不可知。是字不住亦不不住。世尊。亦不见十八性。亦不见十二因缘终始。世尊。我亦不见十二因缘生灭根本。亦不见淫怒痴终始。亦不见六十二见。亦不见六波罗蜜终始。亦不见吾我亦不见人亦不见寿。亦不见命众生终始。亦不见三十七品空无相无愿四禅四等四无形禅之终始。佛志法志僧志戒志施志天志。安般志死志终始。亦不可得见。我亦不见佛十八法终始。世尊。五阴如梦如响如光如影如幻如炎如化终始不可得。寂静不生不灭终始。不着不断终始。及如法性之法真际终始。皆不可见。世尊。我亦不见善恶之法终始。我亦不见有为无为有漏无漏之终始。世尊。我亦不见当来过去今现在之终始。我亦不见不当来不过去不现在法之终始。我亦不见世尊终始。我亦不见十方恒边沙国土。诸如来无所著等正觉。诸弟子及菩萨众终始。世尊。诸法之终始。尚不可得不可见。当教何等菩萨。当为谁说般若波罗蜜。见字亦不住亦不不住。是字不可得知。亦不可得亦不可见。是故字亦不住亦不不住。何为菩萨作字。何以故。诸字法皆不可见亦不可得。世尊。菩萨者合数建字法。亦无有与作字者。五阴十八性十二衰三十七品佛十八法。亦无有与作字者。世尊。譬如梦字响光影炎化名虚空。世尊。譬如言地水火风空。亦无有与作字者。言戒三昧智慧解脱见解脱慧。是字亦无有与作字者。言须陀洹斯陀含阿那含阿罗汉辟支佛。其字亦无有与作字者。言菩萨言道言佛佛法。其字亦无有与作者。言善恶言有常无常苦乐有我。言寂言寂静所有无所有。其字无有与作者。以是故我狐疑。所以者何。诸法终始不可得见而为菩萨作字。世尊。是字亦不住于法性。何以故。是字无所有不可得。是故字亦不住亦不不住。若菩萨摩诃萨闻作是说般若波罗蜜。不惋不悔不懈不怠不恐不怖。当知是菩萨审谛住阿惟越致地。住于无所住。复次世尊。菩萨行般若波罗蜜。色痛想行识不当于中住。眼耳鼻舌身意不当于中住。色声香味细滑法不当于中住。六识不当于中住。六栽不当于中住。六觉不当于中住。地水火风空识不当于中住。十二因缘不当于中住。何以故。以色痛想行识空故。世尊。若五阴空者为非五阴。五阴亦不离空。空亦不离五阴。空则是五阴。五阴则是空。是故世尊。菩萨摩诃萨行般若波罗蜜。不当于五阴中住。乃至十二因缘亦不当于中住。何以故。十二因缘空故。十二因缘则是空。空则是十二因缘。复次世尊。菩萨摩诃萨行般若波罗蜜。三十七品乃至佛十八法。不当于中住。佛十八法亦不离空。空则十八法。十八法则空。是故不当于中住。复次世尊。菩萨摩诃萨行般若波罗蜜。六波罗蜜不当于中住。何以故。六波罗蜜空故。住则非六波罗蜜。六波罗蜜不离空。空亦不离六波罗蜜。是故世尊。菩萨不当于六波罗蜜中住。复次世尊。菩萨摩诃萨行般若波罗蜜。文字数不当于中住。文字数若多若少不当于中住。何以故。文字数空故。复次世尊。行般若波罗蜜菩萨。神通亦不当于中住。何以故。神通则是空。空则是神通。复次世尊。行般若波罗蜜菩萨。色痛想行识无常。不当于中住。何以故。无常空故。假令无常不空则非无常。空亦不离无常。无常则是空。空则是无常。是故菩萨不当于中住。五阴苦五阴无我亦不当于中住。五阴空亦不当于中住。五阴寂静亦不当于中住。复次世尊。行般若波罗蜜菩萨。如不当于中住。法及法性不当于中住。真际不当于中住。复次世尊。菩萨行般若波罗蜜。诸三昧门陀邻尼门不当于中住。世尊。菩萨摩诃萨无有沤和拘舍罗。作吾我想着于五阴。有仍五阴受般若波罗蜜。亦不顺般若波罗蜜。不得具足般若波罗蜜。便不能得出生萨云若。复次世尊。菩萨行般若波罗蜜。着于吾我想。住于诸陀邻尼三昧门。以想识求陀邻尼三昧门。又复有仍受般若波罗蜜。亦不应不顺般若波罗蜜。不得具足般若波罗蜜。不能得出生萨云若。何以故。不受色痛想行识故。不受五阴则非五阴。所以者何。其性空故。诸陀邻尼三昧门不受。不受则非陀邻尼三昧门。其性空故。乃至般若波罗蜜亦复不受。本性空故。菩萨摩诃萨行般若波罗蜜。当观性空之法。虽观于诸法不当使有所著。是名为菩萨摩诃萨无所受三昧。积聚广大无限之用。诸罗汉辟支佛所不能及。萨云若亦不受。乃至内外空及有无空亦不受。何以故。不可以相行故。所以者何。相行有垢故。何等相。五阴相三昧相是谓垢相。当作是受当作是念。不尔者异道人先尼。终不有信于萨云若慧。何等信。信于般若波罗蜜不以相。信解受持观其所应。亦不以相亦不以无相。作是不受相先尼得解信要。便得度空性之慧。不复受痛想行识。所以者何。以见解空相之法。何以故。亦不于内见慧亦不于外见慧。亦不离内外事见慧。何以故。亦不见法当有可识知者。亦不于内五阴见慧亦不于外五阴见慧。亦不离五阴见慧。以是因缘先尼得解。得解已便得信要于萨云若。是谓比诸法等信以为证。而不见诸法。先尼作是解脱已。便于诸法无所受。不想不念故。是法亦无有得者亦无有受者亦无有解者。是法亦非受亦非持亦不可获亦无有念。一切诸法皆无念故。世尊。菩萨摩诃萨所以于般若波罗蜜通达来往于彼此岸者何。于诸法无所受。不受色痛想行识者于诸法无所受故。乃至三昧陀邻尼门无所受。于诸法亦无所受。不具足三十七品佛十力佛十八法不共终不中道般泥洹。何以故。三十七品非三十七品。乃至佛十八法非十八法。是法非法亦不非法。是为菩萨摩诃萨行般若波罗蜜不受五阴。复次世尊。菩萨摩诃萨行般若波罗蜜。当作是观。言何许是般若波罗蜜。般若波罗蜜为是谁。谁有是般若波罗蜜。菩萨行般若波罗蜜。当复作是念言。不可得法不可见法非为般若波罗蜜。于是舍利弗问尊者须菩提言。贤者何等法不可得不可见。须菩提报言。般若波罗蜜不可得不可见。禅惟逮羼尸檀波罗蜜。亦不可得亦不可见。以外空内空及有无空故。五阴亦不可得见。三十七品佛十八法神通。亦不有亦不可得见。法性法住真际佛萨云若。亦不有亦不可得见。以内外空有无皆空故。舍利弗。菩萨摩诃萨行般若波罗蜜。若作是观作是念。意不惓不厌不恐不怖。当知是菩萨终不离般若波罗蜜。舍利弗问尊者须菩提。何以当知菩萨不离般若波罗蜜。须菩提报言。如色之状貌离色。如痛想行识状貌离痛想行识。如檀波罗蜜状貌离檀波罗蜜乃至般若波罗蜜状貌离般若波罗蜜。乃至佛十八法乃至真际亦复如是。舍利弗问须菩提言。五阴状貌何类。六波罗蜜佛十八法状貌何类。法性及如真际其状貌何类。须菩提言。五阴无所有之状貌。六波罗蜜佛十八法真际亦无所有之状貌。其类非物之类。舍利弗。是故当如五阴状貌离五阴。如六波罗蜜状貌离六波罗蜜。乃至真际亦复如是。五阴离五阴相。乃至真际亦离其相。相亦离其真际。舍利弗问须菩提。菩萨摩诃萨于中便出生萨云若耶。报言。如所问无有异。何以故。诸法无所出亦无所生。舍利弗又问。何以故。诸法无有生无有出。须菩提报言。五阴空亦不见其出亦不见其生。般若波罗蜜佛十八法真际。亦不见其出亦不见其生。舍利弗。菩萨摩诃萨作是学般若波罗蜜。以渐近萨云若。已渐近萨云若便得身意相净。已得身意相净便无淫怒痴。意强梁贪意不复生。意终无六十二见事。终不于母人腹中生常得化生。从一佛国至一佛国育养众生普净佛国土。至成阿耨多罗三耶三菩终不离诸佛世尊。舍利弗。菩萨摩诃萨。行般若波罗蜜。当作是学当作是行

放光般若经卷第二放光般若经卷第三

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜空行品第十二

须菩提白佛言。菩萨摩诃萨行般若波罗蜜。无有沤和拘舍罗。于五阴为行相。若念五阴有常为行相。念五阴无常为行相。念五阴苦。言五阴是我所是为行相。念五阴寂静为行相。世尊。菩萨摩诃萨不以沤和拘舍罗行般若波罗蜜。学三十七品佛十八法。亦复为行相。世尊。若菩萨行般若波罗蜜自念言。我行般若波罗蜜。设欲有所得是亦为行相。若菩萨念言。有作是学者为学般若波罗蜜。是亦为行相。作是学者。当知菩萨未有沤和拘舍罗故。须菩提语舍利弗言。菩萨作是学般若波罗蜜。为住色为分别色坐。分别色便作行色求。已作是行不得离生老病死苦。菩萨复不以沤和拘舍罗行般若波罗蜜。处于眼耳鼻舌身意分别六情。复分别十八性。复住于三十七品及佛十八法。各分别计校作色求。亦复不能脱生老病死苦。是菩萨尚不能逮声闻辟支佛地证。况欲得阿耨多罗三耶三菩是事不然。以是故。当知菩萨行般若波罗蜜无沤和拘舍罗。舍利弗问须菩提。当云何知菩萨行般若波罗蜜。而是沤和拘舍罗。须菩提报言。菩萨摩诃萨行般若波罗蜜。于色痛想行识不作相行。亦不言五阴有常无常。于五阴亦不作苦乐行。亦不作是我所非我所行。于五阴不作空无相无愿行。于五阴亦不作寂静行。以是故。舍利弗。以五阴空为非五阴。五阴不离空。空不离五阴。五阴则是空。空则是五阴。六波罗蜜三十七品及佛十八法皆空。假令空者亦不离十八法。十八法亦不离空。菩萨如是行般若波罗蜜。则为是沤和拘舍罗。菩萨作是行般若波罗蜜。便成阿耨多罗三耶三菩。行般若波罗蜜。亦不见般若波罗蜜。亦不见行者亦不见不行者。舍利弗问须菩提。菩萨摩诃萨。何以故。行般若波罗蜜亦不见般若波罗蜜。须菩提报言。以般若波罗蜜状貌本实不可得见故。何以故。所有者无所有故。是故行般若波罗蜜无所见。所以者何。菩萨悉知诸法所有无所有。有三昧名于诸法无所生。是诸菩萨摩诃萨无量无限广大之用。非声闻辟支佛所知。菩萨摩诃萨不离是三昧便疾得阿耨多罗三耶三菩。舍利弗问须菩提。但是三昧使菩萨疾成阿耨多罗三耶三菩耶。颇复有余三昧。须菩提报言。亦复有余三昧令菩萨疾成得佛。舍利弗问言。何者是。须菩提言。有三昧名首楞严菩萨行。是三昧亦疾得佛。复有宝印三昧。师子游步三昧。月三昧。作月幢三昧。诸法印三昧。照顶三昧。真法性三昧。必造幢三昧。金刚三昧。诸法所入印三昧。三昧王所入三昧。王印三昧。力进三昧。宝器三昧。必入辩才三昧。如是等三昧。菩萨摩诃萨悉学已便疾得佛。舍利弗。复有无央数不可计三昧。菩萨所应学。亦复令菩萨疾得佛。须菩提承佛威神言。若有菩萨摩诃萨行是三昧者。已为过去佛所授决已。今现在诸佛亦授其决已。亦不见三昧亦不念三昧。亦不贡高念言我得是三昧。亦不念言我住是三昧。都无三昧想。舍利弗问须菩提言。诸有住是三昧者。为已从过去诸佛授记已耶。须菩提言。不也舍利弗。何以故。般若波罗蜜及三昧菩萨无有异。菩萨则是三昧。三昧则是菩萨。般若波罗蜜亦尔等无有异。而善男子不知诸法等三昧。何以故不知。菩萨以不见是三昧。是故不知。于是世尊赞叹须菩提言。善哉善哉。如我所叹誉。汝于诸空寂行者第一。菩萨摩诃萨当作是学六波罗蜜及三十七品及佛十八法。舍利弗白佛言。菩萨摩诃萨当作是学般若波罗蜜耶。佛言。当作是学六波罗蜜三十七品及佛十八法。亦不想有所得有所见。舍利弗白佛言。何等为无所得无所见。世尊报言。吾我及众生不可得见。以内外空故。五阴十八性十二衰。不可得不可见。本净故。十二因缘不可见。常净故。苦习尽道不可见。常净故。不可见欲性形性无形性。不可得见三十七品佛十八法。常净故。不可得见六波罗蜜。从须陀洹乃至佛。常净故不可见。舍利弗白佛言。何等为净。世尊报言。不生不有不可见。无所为是为净。舍利弗白佛言。菩萨摩诃萨作是学为学何法。世尊报言。菩萨作是学于诸法无所学。何以故。法不尔如凡人所入。舍利弗白佛言。法云何世尊。佛报言。法之所有如无所有作。是有故言无所有。舍利弗白佛言。何等为无所有而有。世尊报言。五阴无所有。内外所有无所有空故。三十七品佛十八法无所有。内外所有无所有空故。凡夫愚人随痴入爱。于中作痴行为两际所得而不知不见法所不痴者。而为入于名色入于六入入于三十七品及佛十八法。虽入其中法所无者及更念。亦复不知亦不见。不知不见何等。佛言。不知五阴不见五阴不见三十七品佛十八法。以是法堕于凡夫愚人之数而不出于何。不出于欲形无形界。不出于声闻辟支佛法。不出而复不信。不信何等。不信五阴空不信三十七品佛十八法空亦复不住。于何所不住。不住于六波罗蜜。不住于阿惟越致地。乃至佛十八法不住。以是故谓为凡夫愚人。便入于眼耳鼻舌身意。入于五阴六衰入于十八性入于淫怒痴入于诸见入于三十七品佛十八法入于道。舍利弗白佛言。世尊。菩萨作是学为不学般若波罗蜜。不成萨云若慧耶。佛言。如是学为不学般若波罗蜜。不出萨云若。舍利弗白佛言。何以故。菩萨不学般若波罗蜜。不成萨云若慧。佛言。以菩萨摩诃萨无沤和拘舍罗。以想念入六波罗蜜及三十七品佛十八法。以想念入萨云若。以是故菩萨摩诃萨不学般若波罗蜜不生萨云若慧。舍利弗白佛言。菩萨当云何学般若波罗蜜而令菩萨成萨云若慧。佛言。菩萨行般若波罗蜜不见般若波罗蜜。是为菩萨摩诃萨行般若波罗蜜者。学如成萨云若慧如应无所见无所得。舍利弗白佛言。何等为无所得无所见。佛言。不见一切法空故

    摩诃般若波罗蜜问幻品第十三

须菩提白佛言。世尊。若人问言。幻人布施持戒精进忍辱一心智慧学三十七品佛十八法学萨云若。当成萨云若不乎。我等当云何报。佛告须菩提。我自还问汝随须菩提意报我。于须菩提意云何。五阴与幻有异无。眼耳鼻舌身意色声香味细滑法十八性与幻有异不。须菩提对曰。无有异世尊。佛言三十七品佛十八法空无相无愿及道与幻有异不。须菩提答曰。无有异世尊。五阴则是幻幻则是五阴。十二衰及十八性皆是幻。三十七品及佛十八法亦是幻。幻则十八法。佛告须菩提。幻人颇有著有缚有生有死不。对曰无。于须菩提意云何。幻人亦不生亦不灭。学般若波罗蜜当成萨云若不。须菩提白佛言。不能得。于须菩提意云何。着字名合法五阴数字为菩萨不。对曰如是如是。世尊。着字五阴生灭可得见不。须菩提对曰。不可得见。亦无起亦无灭亦无字亦无身行亦无意行亦无著亦无缚。学般若波罗蜜宁成萨云若不。须菩提对曰。不能成。佛言。菩萨学般若波罗蜜应无所得。须菩提白佛言。菩萨如是学般若波罗蜜。及阿耨多罗三耶三菩为如幻人学。所以者何。当知五阴如幻人。于须菩提意云何。五阴为学般若波罗蜜当成萨云若不。须菩提白佛言。不也世尊。何以故。五阴所有无所有。无所有者亦不可得见。于须菩提意云何。五阴如梦如响如影如热时炎如化。当学般若波罗蜜耶。对曰非也。何以故。五阴六衰如梦如幻无所有不可得见。须菩提白佛言。新发大乘意菩萨。闻作是说。般若波罗蜜将无恐怖。佛言。新学大乘菩萨。未得般若波罗蜜沤和拘舍罗。不与善知识相随或恐或怖。须菩提白佛言。菩萨当行何等沤和拘舍罗。令菩萨不恐不怖。世尊。佛告言。菩萨行般若波罗蜜应萨云若行。观五阴无常亦不猗五阴。是为菩萨行般若波罗蜜沤和拘舍罗。复次须菩提。菩萨意应萨云若行。观五阴苦空非我。观五阴空无相无愿。观五阴寂静。应无所得无所猗。是为菩萨行般若波罗蜜沤和拘舍罗。菩萨当作念言。我当为一切众生说无常苦空非我。为说空无相无愿寂静之法。应无所得无所猗。是为菩萨檀波罗蜜。复次须菩提。菩萨亦不以罗汉辟支佛意。观五阴无常苦空非我。亦不以罗汉辟支佛意。观空无相无愿寂静。是为菩萨不越戒。以是故菩萨不恐不怖。菩萨尽能奉行能忍。是为菩萨行羼提波罗蜜。复次须菩提。菩萨意行应萨云若。观五阴无常应无所见无所著。不舍萨云若意。是为菩萨行惟逮波罗蜜。菩萨适作是行不起罗汉辟支佛意。羁他恶意亦不得生。是为菩萨摩诃萨行禅波罗蜜不恐不怖。复次须菩提。菩萨行般若波罗蜜。当作是观。言不以五阴空。空则五阴。六情十八性三十七品亦复如是。是故菩萨行般若波罗蜜不恐不怖。须菩提白佛言。菩萨行般若波罗蜜。当与何等善知识相得闻说般若波罗蜜不恐不怖。佛报言。菩萨说五阴无常苦空无我空无相无愿寂静而无所希望。持是无所希望之福。不作罗汉辟支佛地行。但求萨云若。是为菩萨善知识。为说六情十八性寂静而无所希望。持是功德不愿声闻辟支佛地。是为菩萨善知识。复次须菩提。菩萨念三十七品佛十八法。念萨云若念道。以为一切说法无所希望。持无所希望福。不为声闻辟支佛地。但为萨云若。是为菩萨善知识。须菩提白佛言。何等为菩萨学般若波罗蜜。无沤和拘舍罗为恶知识。闻说般若波罗蜜为恐怖。世尊报言。菩萨离萨云若意。猗般若波罗蜜而自贡高。行禅精进忍辱持戒行布施。以猗檀波罗蜜而自贡高。复次须菩提。菩萨离萨云若意。念五阴内外空以空贡高有所猗。念六情空念十八性空以是为贡高。念三十七品及佛十八法空。猗十八法而自贡高。是为菩萨不行般若波罗蜜无沤和拘舍罗闻说般若波罗蜜为恐怖。须菩提白佛言。何等为菩萨恶知识。佛言。教令远离六波罗蜜。语菩萨言。莫学是非佛所说。但合会作是不足听闻不当受持不当讽诵读。亦不当教他人。当知是菩萨恶知识。菩萨复有恶知识。与说魔所乐事。魔波旬作佛形像往到菩萨所。使菩萨远离六波罗蜜。语菩萨言。善男子。用是六波罗蜜学。为当知是菩萨恶知识。魔复作佛形像往到菩萨所。分别广说声闻所应行经但为说是魔事。当知是菩萨恶知识。魔复作佛形像往到菩萨所。语菩萨言。善男子汝亦无菩萨意。亦非阿惟越致。汝亦不能成阿耨多罗三耶三菩。假令不教菩萨令觉魔事者。是菩萨恶知识。魔波旬复作佛形像往到菩萨所。语菩萨言。善男子。眼耳鼻舌身意空六衰十八性皆空。六波罗蜜三十七品佛十八法皆空。用是阿耨多罗三耶三菩学为有作是教者。是为菩萨恶知识。复次须菩提。魔复作辟支佛形像往至菩萨所。语菩萨言。善男子。十方皆空无有佛。亦无有菩萨亦无有声闻。而为菩萨说是辈魔事。当知是则菩萨恶知识。魔复作声闻形像被服往到菩萨所。断菩萨萨云若意。为说声闻辟支佛行。有作是教者。则是菩萨恶知识。魔复作菩萨师和上被服到菩萨所。教令离菩萨行教令离萨云若。三十七品及佛十八法。持空无相无愿法授菩萨。汝当念是法受声闻地证当用是阿耨多罗三耶三菩学。为是但魔事耳。复次须菩提。魔复作菩萨母形像来至菩萨所言。子汝当受是须陀洹证。习罗汉果证。当用是阿耨多罗三耶三菩。为当受是无央数劫生死。当受是截手截脚之痛。向菩萨说是辈魔事是则魔所作。复次须菩提。魔复作比丘被服至菩萨所语菩萨言。眼耳鼻舌身意无常苦空非我空无相无愿寂静。为说三十七品佛十八法。皆为说相着事。当知是菩萨之恶知识。觉已当急远离之

    摩诃般若波罗蜜了本品第十四

须菩提白佛言。菩萨号为菩萨。其句义云何。佛告须菩提。菩萨句义无所有。所以者何。道者无有句义亦无我。菩萨义者亦如是。须菩提。譬如鸟飞虚空无有足迹。菩萨义者亦如是。譬如梦幻热时炎影。如来所化无所有。菩萨义者亦如是。譬如法性及如真际亦无所有。譬如幻士五阴不可得不可见。行般若波罗蜜菩萨摩诃萨其义亦如是。譬如幻士行内外空亦无所有。菩萨行般若波罗蜜其义亦如是。须菩提。譬如幻士行六波罗蜜三十七品及佛十八法无所有。菩萨义者亦如是。须菩提。譬如佛五阴不可得。何以故。无有五阴故。菩萨行般若波罗蜜。不见菩萨之句义。须菩提。譬如怛萨阿竭阿罗诃三耶三佛六情无所有菩萨行般若波罗蜜。其义亦如是。须菩提。譬如佛行内外空其际不可得见。行三十七品及佛十八法不可得见。菩萨其义亦如是。有为无为性亦无有义。须菩提。譬如不生不灭无所有无作无著无断。其义亦无所有。何等不生不灭不着不断不有不作。报言。五阴不生不灭亦不着亦不断亦不可见。十八性六情六衰五阴。无著三十七品佛十八法。无著无断义不可得。行般若波罗蜜菩萨其义亦如是。须菩提。譬如三十七品佛十八法本净无有义。菩萨义者亦如是。譬如吾我净。以吾我无有边际故。我人寿命净不可得见。众生无边际故。菩萨行般若波罗蜜其义亦如是。譬如日出时诸冥迹不复现。菩萨亦如是。譬如天地劫尽火烧时。世间诸所有皆烧尽其迹不可见。菩萨行般若波罗蜜其义亦如是。须菩提。譬如世尊戒具。本时恶戒迹不复现。得三昧乱意迹不复现。得智慧无有愚痴迹。得解脱不复见未解脱迹。已见解脱慧不复见不解脱慧。譬如佛光出时日月忉利诸天王。阿迦腻吒天光明不复现。菩萨行般若波罗蜜其句义不可见。何以故。道及菩萨菩萨义。是亦不合亦不散。无有形不可见。无有对一相。一相者则为非相。须菩提。菩萨于诸法。当学无所著亦当觉知诸法。须菩提白佛言。何等为诸法。何等为菩萨于诸法学无所著。何等为菩萨觉知诸法。佛告须菩提。诸法者谓善法恶法。记法未记法。俗法道法。有漏法无漏法。有为法无为法。是为菩萨当于是诸法学。无所著亦当学。须菩提白佛言。何等为世俗善法。佛告须菩提。俗善法者。谓孝顺父母供养沙门道人养育长老施诸福事。约身守节精勤念善意。崇方便修行十善。有俗内想腐败想青瘀想血想食不消想乱想骨想半燋想。四禅四等四无形禅想。佛想法想比丘僧想戒想施想天想。精勤想安般想身想死想。须菩提。是谓世间善法。何等为世俗恶法。杀盗淫怒恶口妄言绮语嫉妒邪见是为世俗恶法。何等为记法。若善法若不善法是为记法。何等为未记法。未有身口意未有四大未有五阴十八性十二衰。是为未记法。何等为世俗法。五阴十二衰十八性十善四禅四等四无形禅。是谓世俗法。何等为道法。三十七品三解脱门三根三三昧解脱摄意八解脱门九次第禅十八空佛十力四无所畏佛十八法。是为道法。何等为漏法。五阴十二衰十八性十二因缘四禅四无形禅。是为漏法。何等为无漏法。三十七品佛十八法。是为无漏法。何等为有为法。欲界形界无形界三十七品乃至佛十八法。是为有为法。何等为无为法。无为法者不生亦不灭不终亦不始常住而不改。淫怒痴尽如无有异法性及真际。是谓无为法。菩萨摩诃萨当于是空相之法无所著而不倾动觉。诸法而不二。须菩提白佛言。何等为摩诃萨。佛告须菩提。于诸大众必有上首。是故名为摩诃萨。须菩提白佛言。当为何等众生而作上首。佛告须菩提。大众者谓须陀洹斯陀含阿那含阿罗汉辟支佛初发意菩萨摩诃萨至阿惟越致地住者。是为大众之聚。菩萨当于是中作上首。于中当发金刚意便为上首。须菩提白佛言。世尊。何等为金刚意。佛告须菩提。菩萨摩诃萨发意言。我当受无央数生死作精进行。我当为众生故舍一切所有。我当等心于一切众生。我当以三乘度脱众生。当令般泥洹。亦不见众生般泥洹。我当觉诸法无所从生。常当以萨云若慧意行六波罗蜜。我当学当救济一切。须菩提。是为菩萨发金刚意。便为大众最上首。菩萨复发意言。我当为泥犁薜荔中罪人所受苦痛。我当为众生代受无央数劫苦痛。尽令众生于无余泥洹而般泥洹。然后我自为身作善本亿百千劫乃成阿耨多罗三耶三菩。须菩提。是为菩萨发金刚意于大众而为上首。菩萨当为妙意。以妙意故于众生为上首。从初发意已来亦不当生淫怒痴意。亦不当娆众生。亦不起声闻辟支佛意。是为菩萨摩诃萨妙意而为大众作上首。亦不念贡高。菩萨当于萨云若意而不动亦不贡高。菩萨常当起护念于众生亦不舍众生。菩萨摩诃萨当为法行当为法乐。何等为法乐。随其所知而讽诵受。菩萨行般若波罗蜜。住于诸法空为大众作导。亦无所倚亦无所得。菩萨住于三十七品及佛十八法。为大众作上首无所倚而无所见。菩萨行般若波罗蜜。住于行如金刚三昧。乃至尽虚空际无所染逮解脱三昧。便为大众作上首。而无所得亦无所倚。须菩提。菩萨住于是法地故。便能为众生而作上首。是故名为摩诃萨

    摩诃般若波罗蜜摩诃萨品第十五

是时舍利弗白佛言。我亦当复说所以为摩诃萨者何。佛告舍利弗便说。舍利弗言。菩萨于诸妄见悉断是故名为摩诃萨。何谓诸见妄见。吾我见有人见及众生见有断见有常见有见无见五阴见十八性见十二衰见有谛见十二因缘见有三十七品佛十八法见有育养众生见有净佛土见有道见有佛见转法轮见。一切诸见悉断。作如是说法。是故名为摩诃萨。须菩提问舍利弗言。菩萨摩诃萨。何以故。有五阴十二衰十八性十二因缘见。何以故。有三十七品佛十八法见及有妄见。舍利弗对曰。菩萨摩诃萨不以沤和拘舍罗行般若波罗蜜。如务五阴六情十八性十二因缘。猗六波罗蜜三十七品及佛十八法起诸见。菩萨摩诃萨行般若波罗蜜。沤和拘舍罗断是诸见。为人说法而无所猗。须菩提白佛言。我亦当说。所以为摩诃萨者何。佛告须菩提。乐说者便说。须菩提言。道意无有与等者。非声闻辟支佛所知。何以故。以萨云若意无漏故。意亦不着。是故为摩诃萨。舍利弗问须菩提。何等为菩萨意无有与等者。诸罗汉辟支佛所不能及者。须菩提报言。菩萨摩诃萨从初发意以来。不见法有生灭。亦不见有增减。亦不见着亦不见断。舍利弗。诸法不生不灭。不增不减。不着不断者。亦无罗汉辟支佛意。亦无道意亦无佛意。是为菩萨摩诃萨意无有与等者。非罗汉辟支佛所能及知者。舍利弗言。如须菩提意。不着罗汉辟支佛地。五阴亦不着。三十七品佛十八法亦不着。舍利弗语须菩提。假令萨云若意无漏者。凡人意亦当无漏性空故。罗汉辟支佛及诸佛世尊意亦当无漏。须菩提言。尔如所言。舍利弗言。五阴亦无漏其性本空故。三十七品佛十八法亦复无漏性空故。须菩提言。如舍利弗所言。舍利弗问须菩提言。无意为不与意合耶。无色痛想行识为不与识合耶。须菩提言。尔如所言。舍利弗复问。三十七品佛十八法与非十八法。为不着不合耶。须菩提报言。有无之事皆合。须菩提语舍利弗言。菩萨摩诃萨作如是行般若波罗蜜。不持道意及罗汉辟支佛。所不能及知。意亦不贡高而有所猗于猗于法而无所入

    摩诃般若波罗蜜问僧那品第十六

是时邠耨文陀尼子白佛言。世尊。我当说所以为摩诃萨者。佛言。汝乐欲说者便说之。邠耨言。菩萨为大功德所缠络乘于大乘。以是故谓为摩诃萨。舍利弗问邠耨言。何等为菩萨摩诃萨以大功德所缠络而为摩诃萨。邠耨报言。菩萨摩诃萨不为齐限于人故。住檀波罗蜜而为布施。普为一切众生故。行檀波罗蜜尸羼惟逮禅般若波罗蜜。普为众生故。作谦苦行。菩萨成僧那僧涅不限众生。亦不言我当限度若干人不能度余人。亦不言我当教若干人至道。亦不言我不能教余人。菩萨为众生故起大誓愿言。我自当具足六波罗蜜。亦当教他人使具足六波罗蜜。菩萨行檀波罗蜜所布施应萨云若。意愿言。持是功德与一切众生俱共得阿耨多罗三耶三菩。舍利弗。是为菩萨行般若波罗蜜而习布施。复次舍利弗。菩萨布施应萨云若。不求罗汉辟支佛地。是为菩萨行般若波罗蜜布施习于尸波罗蜜。复次舍利弗。菩萨布施时作萨云若念法所应行。是为习羼波罗蜜。如精进所应行。是为习惟逮波罗蜜。一心布施应萨云若。念终不起声闻辟支佛意。是为习禅波罗蜜。所可布施如幻相。不见施者亦不见所施亦不见受者。是为菩萨布施而习般若波罗蜜。菩萨以萨云若意。不想诸波罗蜜亦不猗。舍利弗。是故当知菩萨为僧那僧涅。复次舍利弗。菩萨摩诃萨行尸波罗蜜意应萨云若布施。持布施功德与众生。共求阿耨多罗三耶三菩。是为菩萨行尸波罗蜜而具檀波罗蜜。复次舍利弗。菩萨行尸波罗蜜尽能奉行能忍辱。是为菩萨行尸波罗蜜具足羼波罗蜜。复次舍利弗。菩萨行尸波罗蜜具足惟逮波罗蜜。是为菩萨习精进。菩萨行尸波罗蜜不受罗汉辟支佛意。菩萨行尸波罗蜜。于诸波罗蜜如幻相不贡高亦无所倚。舍利弗。是为菩萨行尸波罗蜜如习般若波罗蜜。是为菩萨行尸波罗蜜总持诸波罗蜜。是故名为僧那僧涅。菩萨行羼提波罗蜜应萨云若布施。菩萨入无形禅亦不处其中。是为菩萨行沤和拘舍罗而为般若波罗蜜。复次舍利弗。菩萨行禅分别空无相无愿。是为菩萨行僧那僧涅而为般若波罗蜜。以是故。名为僧那僧涅。舍利弗。菩萨作是僧那僧涅者。十方诸佛世尊。皆以大音声赞叹是菩萨言。某国土菩萨具诸功德为僧那僧涅。当育养众生净佛国土。于是舍利弗问邠耨文陀尼子。何等为菩萨摩诃萨摩诃衍三拔致。摩诃衍三拔致者。晋言发趣大乘。云何为发起大乘。邠耨报言。行六波罗蜜随诸禅所应行尽奉行。持求萨云若。菩萨以萨云若意。于八禅观其无常。观其苦空非我无愿。是为菩萨行般若波罗蜜为摩诃衍。菩萨念三十七品佛十八法是为菩萨摩诃衍。菩萨意不近罗汉辟支佛地。志但崇萨云若。是为菩萨行四等而为羼波罗蜜。菩萨行萨云若意无懈时。是为菩萨惟逮波罗蜜。菩萨虽行四禅慈悲喜护八禅。亦不能动摇菩萨。所以者何。以沤和拘舍罗故。菩萨行四等为众生消诸漏。是为菩萨行四等而为檀波罗蜜。诸法所作禅不持求罗汉辟支佛。何以故。常求萨云若故。是为菩萨行四等而不[打-丁+此]尸波罗蜜。菩萨复有摩诃衍。于内外空其慧不转。无所倚无所得无所见。是为菩萨摩诃衍。复有摩诃衍。不于诸法。慧不在乱亦不在定。慧亦不在有常亦不在无常。慧亦不在苦乐亦不在有我无我。是为菩萨摩诃衍而应无所倚。复有摩诃衍。慧不在当来过去今现在。慧亦不离三世。是为摩诃衍应无所倚。摩诃衍者。慧不在三界亦不离三界。复有摩诃衍。慧不在俗法亦不在道法。亦不在有为亦不在无为。亦不在有漏亦不在无漏。是为无所倚。舍利弗。是为菩萨摩诃萨摩诃衍

    摩诃般若波罗蜜摩诃衍品第十七

尔时舍利弗。问邠耨文陀尼子言。何等为菩萨摩诃萨乘于大乘。邠耨报舍利弗言。菩萨行般若波罗蜜。乘于檀尸羼惟逮禅波罗蜜。乘是六波罗蜜不见六波罗蜜。亦不倚菩萨而无所倚。是为乘于大乘。复次舍利弗。菩萨摩诃萨一心学萨云若。具足三十七品佛十八法。虽念欲成不有所倚。是为菩萨乘于大乘。复次舍利弗。菩萨作是念言。菩萨者但是字耳。五阴者但有字耳不倚五阴故。六情者但有字耳不倚六情故。三十七品者但有字耳不倚三十七品故。内外空者但有字耳不倚内外空故。佛十八法者但有字耳不倚佛十八法故。如来法者但有字耳不见法性故真际者但有字耳真际不可见故。佛及道者但有字耳不倚佛故。是为菩萨摩诃萨乘于大乘。复次舍利弗。菩萨摩诃萨从初发意以来具足菩萨之神通。具足已欲育养群生。从一佛国游至一佛国。供养礼拜事诸佛世尊。从诸佛听受法教。何谓法教。报言。菩萨大乘是菩萨乘是大乘。游诸佛刹净佛国土育养众生。初无佛国想亦无众生想亦不住二地。菩萨为众生故。随其所应而变其形像不得一切智。终不离菩萨乘逮一切智已便能转法轮。非罗汉辟支佛及诸天龙阅叉阿须伦及世间人所能转。是时闻十方恒边沙诸佛世尊。赞叹声。言某国某菩萨摩诃萨。乘于大乘逮萨云若转于法轮。舍利弗。是为菩萨摩诃萨乘于大乘

    摩诃般若波罗蜜僧那僧涅品第十八

尔时须菩提白佛言。何等为菩萨摩诃萨僧那僧涅。佛告须菩提。六波罗蜜三十七品内外空及有无空佛十八法及一切智。被诸功德之铠成佛身。光彻三千大千刹土。复以光普遍十方恒边沙佛国土。便为六反震动。三千大千刹土复六反震动。十方恒边沙佛国土菩萨。已受是光明住于檀波罗蜜。以大乘之铠便能变化三千大千刹土化为琉璃。自变其形为遮迦越王。布施一切随其所欲。饥渴与饮食欲得衣者与衣欲得香华医药布施。种种随众人身所便乐尽给与之。作是布施已便为众生说六波罗蜜行。众生闻菩萨教已。至得阿耨多罗三耶三菩。不离六波罗蜜行。是为菩萨被大乘之铠。须菩提。譬如工幻师在四要道头。于大众人前布施随人所欲。饮食衣被钱财。随人意所索幻人尽与。于须菩提意云何。是幻师颇有所布施于人不。须菩提白佛言。无所施亦无得者。佛告须菩提。菩萨自化身作遮迦越王布施。随人所乐而在所与。恣人所欲而施与。虽施而无所与亦无得者。何以故。须菩提。法之幻法应尔。复次须菩提。菩萨摩诃萨住于尸波罗蜜。示现作遮迦越罗。于中使人持十善法。教人使为四禅四等四无形禅。立于三十七品至佛十八法。众生闻是法教至得道终不离是法教。须菩提。譬如幻师化作大众人。教幻人持十善。立以三十七品至佛十八法。于须菩提意云何。颇有人立于十善四禅四无形禅。颇有人立于三十七品及佛十八法者不。须菩提对曰。无有立者也世尊。佛告须菩提。菩萨立诸众生于十善地三十七品佛十八法。亦不见有人住是法者。所以者何。法幻之法自应当尔。以是故须菩提。菩萨摩诃萨为被大乘之铠。复次须菩提。菩萨住羼波罗蜜。亦立众生于羼波罗蜜。菩萨从初发意以来作誓言。假令众生持刀杖害。我悉受终不起恶意如弹指之顷。当复立众生于忍辱地亦复如是。虽立众生于羼波罗蜜。亦复如幻师亦无众生想。须菩提。是为菩萨大乘之铠。复次须菩提。菩萨摩诃萨住于惟逮波罗蜜。立众生精进意应萨云若。亦复如幻师。是为菩萨大乘之铠。菩萨住于禅波罗蜜。亦复教一切人行一心。菩萨住于等法。不见法有乱者有一心者。须菩提。是为菩萨住于禅波罗蜜。亦复教一心人行禅。乃至阿耨多罗三耶三菩。终不离是一心。亦复如幻师。是故名为僧那僧涅。复次须菩提。菩萨摩诃萨。住于般若波罗蜜。亦复劝助教一切人。使立于般若波罗蜜。须菩提。是为菩萨摩诃萨行般若波罗蜜。于诸法不见有彼此岸。是为菩萨住于般若波罗蜜。亦复劝助众生化立人于般若波罗蜜。教化众生亦复如幻。不见有学者不见有受者。以是故须菩提。菩萨摩诃萨僧那僧涅。复次须菩提。菩萨被大乘铠。以安处十方恒边沙佛国众生。立于六波罗蜜。为众生说六波罗蜜法使众生闻之。闻已至阿耨多罗三耶三菩不离是法。亦复如幻亦不见受法者亦不见受是教者。以是故菩萨为大乘之铠。菩萨复被大乘之铠意应萨云若。菩萨不言我当教若干人立于六波罗蜜。亦不言我当教若干人行三十七品佛十八法。亦复不言我不能教若干人。亦复不言我教若干人得须陀洹乃至阿罗汉辟支佛。不言我不教若干人至阿罗汉。亦不言我立若干人至萨云若。不言我不悉教尔所人。何以故。菩萨所度无有限碍亦无适莫。菩萨所度亦无有数亦无有量。须菩提。菩萨譬如幻师教幻人。不见有所教亦不见有受者。是为菩萨摩诃萨僧那僧涅。须菩提白佛言。如我从佛所闻义。当知菩萨非为僧那僧涅。何以故。诸法空故色痛想行识空。眼耳鼻舌身意色声香味细滑法十八性各随其相各自空檀波罗蜜至般若波罗蜜亦自空。内外空皆自空。从三十七品至佛十八法皆空。菩萨亦空僧那僧涅亦自空。以是故世尊。当知菩萨为非僧那僧涅。佛告须菩提。如所言无有异。须菩提。萨云若非为非作。菩萨为众生作摩诃僧那僧涅者。是众生亦非为非作。须菩提白佛言。何以故。萨云若及众生非为非作。佛言。不见有人故。是故萨云若无为无作。何以故。须菩提。五阴亦不有所作亦非不作。六情六衰亦无所为亦无所作。我人寿命亦无所为亦无所作。何以故。边际不可得故。须菩提。梦响影幻热时炎化无所作亦无所为。内外空三十七品佛十八法亦无所为亦无所作。何以故。其本际不可得见故。如及法性真际亦无所作亦无所为。菩萨萨云若亦无所作亦无所为。何以故。无有本际故。以是故须菩提。萨云若及众生无所有无所作。以是当知菩萨非为摩诃僧那僧涅。须菩提白佛言。如观世尊所说义。五阴亦无缚无脱。邠耨文陀尼子问须菩提。何等五阴无缚无脱。须菩提报言。五阴如梦如响如影如幻如化如热时炎。当来过去今现在五阴无缚无脱。五阴无端绪无缚无脱。五阴寂无所生无缚无脱。五阴善不善俗五阴道五阴有漏无漏亦无缚无脱。一切诸法无缚无脱。无际寂净无缚无脱。六波罗蜜无缚无脱。无际寂静内外空无缚无脱。三十七品无缚无脱。佛十八法无缚无脱无际寂静故。道及菩萨萨云若一切智事。无际寂静无所生亦不缚亦不脱。如法性真际无为亦无缚无脱。无际寂静不生无缚无脱。如是邠耨。菩萨摩诃萨。于无缚无脱六波罗蜜中。住无缚无脱萨云若。于无缚无脱育养众生。无著无缚无脱净佛国土。无著无缚无脱见诸世尊。以无缚无脱闻法终不离。无缚无脱诸佛世尊终不离。无缚无脱诸神通终不离。无缚无脱五眼终不离。无缚无脱转无缚无脱法轮。无缚无脱安立众生于三乘。如是邠耨。菩萨摩诃萨。于无缚无脱六波罗蜜。于诸法得逮觉。无际寂静无所生故。邠耨当知。是为菩萨摩诃萨无缚无脱之僧那僧涅

放光般若波罗蜜经卷第三放光般若经卷第四

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜问摩诃衍品第十九

是时须菩提白佛言。何等为菩萨摩诃萨大誓。世尊。云何当知菩萨趣大乘。乘是乘当至何所。谁当成是乘者。佛告须菩提言。六波罗蜜是菩萨摩诃萨之大乘。何等为六。檀尸羼惟逮禅般若波罗蜜。须菩提白佛言。何等为菩萨檀波罗蜜。佛告言。菩萨摩诃萨布施意应萨云若。内外所有布施。已持是功德尽施众生与众生共发阿耨多罗三耶三菩是为菩萨摩诃萨檀波罗蜜。须菩提白佛言。何等为尸波罗蜜。佛言。菩萨持戒发意应萨云若。自持十善教他人行十善亦无所倚。是为菩萨不[打-丁+此]戒应无所倚。须菩提白佛言。何等为羼波罗蜜。佛言。菩萨自具足于忍地。复劝他人令行忍辱而无所倚。是为菩萨摩诃萨行羼波罗蜜。须菩提白佛言。何等为惟逮波罗蜜。佛言。菩萨意应萨云若。不废五波罗蜜。亦复立众生于五波罗蜜而无所倚。是为菩萨惟逮波罗蜜。须菩提白佛言。何等为禅波罗蜜。佛言。菩萨摩诃萨以萨云若意。自以沤和拘舍罗。入诸禅不随禅生。亦复教他人使行禅而无所倚。是为菩萨禅波罗蜜。须菩提白佛言。何等为菩萨般若波罗蜜。佛言。菩萨摩诃萨以萨云若意不入于诸法而观诸法之性而无所倚。亦复教他人令不入于诸法。而观诸法之性而无所倚。是为菩萨摩诃萨般若波罗蜜。是为菩萨摩诃萨摩诃衍。又须菩提。复有摩诃衍。内空外空乃至有无空是也。何等为内空。内法是。谓眼耳鼻舌身意。眼本空不着垢亦不坏。何以故。本性尔。耳耳本空。鼻鼻本空。舌舌本空。身身本空。意意本空。亦不着垢亦不坏。何以故。本性尔。是为内空。何等为外空。谓色声香味细滑法。色本空亦不着垢亦不坏。何以故。色本性尔。声香味细滑法皆尔。何以故。本性空故。是为外空。何等为内外空。内六衰外六衰。是为内外法。以外法故内法空。以内法故外法空。亦不着亦不坏。何以故。本性尔。是为内外空。何等为空空。诸法之空持诸法空空于空。是为空空。何等为大空。八方上下皆空是为大空。何等为最空。泥洹是不着不坏是为最空。何等为有为空。从不着不坏本至三界空。是为有为空。何等为无为空。不生不灭住于不异。从不着不坏皆空。何以故。本空故。是为无为空。何等为至竟空。所可不得边际者是为至竟空。何等为不可得原空。诸可来者不知所从来无有处故。是为无有原空。何等为无作空。于诸法无所弃。是为无作空。何等为性空。诸法所有性及有为无为性。非罗汉辟支佛诸佛世尊所不作。是为性空。何等为诸法空。诸法者谓五阴十二衰十八性有为法无为法。是为诸法。从不着不坏至诸法之性。是为诸法空。何等为自相空。色相所受相。是所持相为想。所有相便有所觉相是为识。乃至有为无为相。从有为无为相至诸法皆悉空。是为自相空。何等为无所得空。从无著无坏至无所得法。亦无所得。是为无所得空。何等为无空。于中无所见。是为无空。何等为有空。诸法无有偶者。于诸合会中皆无有实。是为有空。何等为有无空。于诸聚会中亦无有实。是为有无空。复次须菩提。有以有为空。无以无为空。异以异为空。何等为有。有者谓五阴性性以性为空是为有空。何等为无。以无为空无所成无所成为空。空者亦非知可作亦非见可作。何等为余事空。有佛无佛法性法寂如。及尔真际住如故。以是异空是为余事空。须菩提。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。何等为衍。百七三昧是各各有名。何等三昧名首楞严三昧。何等为首楞严三昧。诸三昧门之所趣聚皆来入其中。是故名首楞严。复有三昧名宝印。何等为宝印三昧。诸三昧所有印皆而印之。复有三昧名师子游戏。何等为师子游戏。住是三昧者尽游戏诸三昧中。复有月三昧。住是三昧者能以光明照诸三昧。复有月幢三昧。住是三昧者持诸三昧。复有在诸法上三昧。住是三昧者诸三昧悉从其中出。复有照顶三昧。住是三昧者能以光明照诸三昧上。复有法性毕三昧。住是三昧者能决了诸法。复有必造幢三昧。住是三昧者于诸三昧中必持坚固幢。复有金刚三昧。住是三昧者诸三昧无有敢当者。复有法所入印三昧。住是三昧者与诸法印相应。复有安住三昧。住是三昧者便能住诸三昧。复有放光明三昧。住是三昧者便能遍照诸三昧。复有势进三昧。住是三昧者能以力势教诸三昧。复有等步三昧。住是三昧者能等行诸三昧。复有入辩才教授三昧。住是三昧者能辩解诸三昧。复有过量音声三昧。住是三昧者得入无量名字三昧。复有照处处三昧。住是三昧者于诸三昧能遍照于诸方面。复有总持印三昧。住是三昧者能持诸三昧印。复有不忘三昧。住是三昧者不忘诸三昧。复有一切法所聚海三昧。住是三昧者能使一切诸三昧等行。复有虚空普三昧。住是三昧者能遍足诸三昧。复有金刚部三昧。住是三昧者持诸三昧部。复有宝胜三昧。住是三昧者降伏诸垢浊。复有炽炎三昧。住是三昧者能以光炎遍照诸三昧。复有无愿三昧。住是三昧者于诸法无所取。复有审住三昧。住是三昧者不见诸法有住处。复有选择三昧。住是三昧者于诸三昧无意念想。复有无垢灯三昧。住是三昧者为诸三昧作灯明。复有无限光三昧。住是三昧者于诸三昧无有限量。复有作光明三昧。住是三昧者能于诸三昧而有所照。复有普照明三昧。住是三昧者诸三昧皆在眼前现。复有净要三昧。住是三昧者逮得等净三昧。复有无垢光三昧。住是三昧者散诸三昧垢。复有造乐三昧。住是三昧者受诸三昧乐。复有电明三昧。住是三昧者为诸三昧作灯明。复有无尽三昧。住是三昧者不见尽以不尽。复有上威三昧。住是三昧者于诸三昧中威德独然。复有毕尽三昧。住是三昧者见诸三昧尽所可见如不见。复有不动三昧。住是三昧者令诸三昧不动不觉不戏。复有不别三昧。住是三昧者不见离别。复有日灯三昧。住是三昧者照诸三昧门。复有月无垢三昧。住是三昧者能去诸三昧冥。复有净光明三昧。住是三昧者于诸三昧分别四无碍慧。复有作明三昧。住是三昧者为诸三昧门作明。复有造作三昧。住是三昧者为诸三昧作毕竟。复有诸慧三昧。住是三昧者见诸三昧慧。复有金刚三昧。住是三昧者决断诸三昧。复有住意三昧。住是三昧者不动不摇不恐不怖亦无意想。复有现明三昧。住是三昧者于诸三昧悉遍见明。复有安立三昧。住是三昧者于诸三昧善处。复有宝积三昧。住是三昧者普见诸三昧宝。复有法印三昧。住是三昧者印诸三昧从印及不印。复有等三昧。住是三昧者不见法有等脱。复有弃乐三昧。住是三昧者悉弃诸乐。复有过法定三昧。住是三昧者灭诸法之冥在诸三昧上。复有散结三昧。住是三昧者能散用诸三昧。复有解诸法句三昧。住是三昧者能解诸三昧及诸法句。复有等文字三昧。住是三昧者得诸等字。复有毕字三昧。住是三昧者不见一字。复有断因缘三昧住是三昧者断诸因缘。复有无态三昧。住是三昧者不得诸法态。复有无行三昧。住是三昧者不见诸法行。复有无窟行三昧。住是三昧者未见诸三昧有窠窟之行。复有毕阴三昧。住是三昧者能净诸阴。复有主行三昧。住是三昧者见诸三昧行。复有不起三昧。住是三昧者不见诸三昧起。复有度境界三昧。住是三昧者过诸境界。复有聚诸善三昧。住是三昧者能得聚诸法诸三昧。复有止选三昧。住是三昧者意不堕落。复有清净华三昧。住是三昧者得诸三昧清净华。复有主觉三昧。住是三昧者于诸三昧有七觉意。复有无限辩三昧。住是三昧者逮得无量之辩。复有无等等三昧。住是三昧者便得无等等。复有度诸法三昧。住是三昧者越度三界。复有决断三昧。住是三昧者能见诸法见诸三昧决断事。复有散诸狐疑三昧。住是三昧者逮得散诸法三昧。复有无住三昧。住是三昧者不见诸法处。复有一行三昧。住是三昧者不见诸法有二。复有众生所入三昧。住是三昧者不见众生亦不见所入。复有一事三昧。住是三昧者不见诸三昧事。复有厌该众事三昧。住是三昧者不见有别复有散诸生死劳怨三昧。住是三昧者逮得诸厌三昧慧所入处无所觉。复有众行音所入三昧。住是三昧者众行音声皆悉随从。复有脱诸音响字三昧。住是三昧者见诸三昧脱于音字。复有然炬三昧。住是三昧者于诸三昧中威德独明。复有净相三昧。住是三昧者能净一切三昧相。复有无准三昧。住是三昧者于诸三昧不见于准。复有具足众事三昧。住是三昧者于诸三昧皆得具足。复有不愿苦乐三昧。住是三昧者不见诸三昧有苦乐。复有事不减三昧。住是三昧者不见诸三昧有尽。复有持迹三昧。住是三昧者尽看诸三昧。复有邪正聚三昧。住是三昧者于诸三昧不见邪正。复有灭恚诤三昧。住是三昧者于诸三昧不见恚诤。复有无恚三昧。住是三昧者不见于诸法于诸三昧有恚无恚。复有无垢光三昧。住是三昧者于诸三昧亦不见光亦不见垢。复有主要三昧。住是三昧者于诸三昧不见无要。复有明月满无垢炎三昧。住是三昧者能使诸三昧满具足。如月十五日时。复有大庄饰三昧。住是三昧者能使诸三昧严好。复有与世间作光明三昧。住是三昧者光明普照十方及诸法。复有三昧。名三昧等。住是三昧者于诸法亦不见有乱亦不见有定。复有无忿三昧。住是三昧者能使诸三昧而无有忿。复有无倚无窟无乐三昧。住是三昧者于诸三昧不见巢窟。复有最如三昧。住是三昧者于诸三昧不转于如。复有三昧名身骸。住是三昧者不见此三昧性。复有三昧。名断口行与空合。住是三昧者不见诸三昧有言。复有三昧。名虚空本脱无色。住是三昧者逮得诸法本空。须菩提。是为菩萨摩诃萨行般若波罗蜜摩诃衍

    摩诃般若波罗蜜陀邻尼品第二十

复次须菩提。复有摩诃衍。何所为衍。所谓四意止是。何等四意止。菩萨自观身观他人身观内外身已。亦无身想亦无所倚。若行若寂常念世间从痴有[病-丙+((句-口+夕)/心)]。观内痛意行法观外痛意行法观内外痛意行法若行若寂常念世间痴[病-丙+((句-口+夕)/心)]。须菩提。云何菩萨观内身行。菩萨自知可行知行可住知住。可坐知坐可卧知卧。随身所行皆能自知。是为菩萨自观身行若行若寂常念世间苦恼。又须菩提。菩萨出入进止安详瞻不忘。坐卧左右亦常安详。服三法衣不失威仪。行般若波罗蜜菩萨。自观内外身行如是而无所倚。菩萨常观息出入。息长亦知息短亦知。譬如陶轮调其缓急。菩萨息知意与息俱俱出俱入。是为菩萨观内身行。若行若寂常念世间痴苦受患。复次须菩提。用是行般若波罗蜜。常当观身分别四分地水火风。譬如屠牛分为四分。菩萨观身分别四事。本末从来亦复如是。是为菩萨观内外身亦无所倚。复次须菩提。菩萨观身从头至足但有不净。发毛爪齿筋骨五藏三十六物有何可贪。譬如田家器盛五谷。有目之士若开发器。分别识知。菩萨观身身中所有亦复如是。是为菩萨自观内身。若行若寂常念世间痴爱痛苦亦无所倚。复次须菩提。菩萨观人。初死之日至于五日。膖胀烂臭体坏汁流互相浇灒无有净处。或为飞鸟走兽所食。或啖其半恶露不净。或有死人筋缠骸骨血浇。或有死人血肉已尽筋骨相縺。中有骸骨已解离者节节异处。或见久死骸骨青白色者。或腐坏者或与地土共同色者。菩萨都作是观。作是观已。还自计校我身分未脱未离此法俱亦当尔。是为菩萨观内身法观他人身无所贪猗。若行若寂常念世间痴苦灾患。自观觉意法亦观他人觉意法。分别思念断痴惑意。须菩提。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。渐御四意断是。何谓为四。恶意法未生。乐御习精进摄意使不生。已起恶意法。亦复乐御精进摄意习使断。未生善事法持乐意精进习使得生。已生善法念欲处。具足广显欲使不忘。亦复乐习精进摄意御使得成。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓四神足是。何谓为四。已得乐定除诸所作行总摄神足。以精进定除诸所作行总摄神足。以持意定除诸所作行总摄神足。以智之定除诸所作行总摄神足。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓五根是。何谓五根。信根精进根志根定根智慧根。是为菩萨摩诃萨摩诃衍。须菩提复有摩诃衍谓五力是。何谓为五。信力精进力志力定力智慧力。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓七觉意是。何谓为七。以志觉意以法觉意以精进觉意以悦喜觉意以信觉意以定觉意以适无以着觉意。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓贤圣八品道是。何谓为八。正见正念正言正行正业正习正志正定。是为菩萨摩诃萨摩诃衍亦复无所倚。须菩提。复有摩诃衍。谓三三昧是。何谓为三。空三昧无相三昧无愿三昧。是为菩萨摩诃萨摩诃衍。复有摩诃衍。谓诸慧事是。苦慧习慧尽慧道慧消慧无所起慧法慧明慧各各知他人所念慧真慧。何等为苦慧。不生苦是为苦慧。何等为习慧。习灭已断是为习慧。何等为尽慧。灭诸苦事是为尽慧。何等为道慧。贤圣八品道是为道慧。何等为消慧。贪淫嗔恚愚痴尽是为消慧。何等为不起慧。不受生死处是为不起慧。何等为法慧。晓断五阴是为法慧。何等为明慧。眼耳鼻舌身意无常。色声香味细滑法亦复无常是为明慧。何等为各各知他人所念慧。一切众生心中所念所起种种悉知。是为各各知他人所念慧。何等为真慧。所谓如来萨云若智是为真慧。亦无所倚。须菩提。是为菩萨摩诃萨摩诃衍。复有摩诃衍。所谓三根是。何等为三根。谓学士从白衣至须陀洹五根。是未曾知当知。从斯陀含至阿那含。亦有五根应知当知。从阿罗汉辟支佛菩萨至佛亦有五根。谓已知无所复学。当知是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓三三昧也。何等为三。第一有觉有观第二无觉有观第三无觉无观。何等为有觉有观。谓第一禅是为有觉有观。何等为无觉有观。谓第一禅未至二禅在其中间。是为无觉有观。何等为无觉无观。从第二禅至。无思想无思想慧禅。是为无觉无观。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓十念是。佛念法念僧念戒念施念天念灭念安般念身苦念死亡念是亦无所倚。是为摩诃衍。须菩提。复有摩诃衍。谓四禅四等四无形禅八惟无禅九次第禅佛十种力四无所畏。十种力者谓佛现身相好神足变化。感动众邪回使入正一力也。口之所说在众智上。能变疑结开令解脱二力也。意入空定清明六达。邪神娆乱道志不摇三力也。默然断想神足无为。感动三千大千日月人无惊悚四力也。道意聪睿演法布化。流盈十方各得其所五力也。逆知众意晓人行趣。若缚若脱悉能解散六力也。三世所作殃福本际报受之未。大慧悉知无有挂碍七力也。一切人民众行根源种种各异受身不同。悉觉本际因缘起处八力也。慧眼以净所察无限。见诸生死往来所堕九力也。大慧已足方便已备生死已断着行已尽所作已讫不复还受。自然无师称一切智是谓十力也。四无所畏者。佛为正觉或有沙门婆罗门或魔或天或梵若复有余众。无有能来难诘我者。佛亦不见有起是意者。以是证故佛行安隐。逮无所畏一无畏也。逮精进行得知最处。在众人中得师子吼能转梵轮。诸沙门婆罗门诸天梵魔。一切余法所不能转。独佛能转二无畏也。佛漏已尽。若有沙门婆罗门或天魔梵。无有敢言佛漏未尽者三无畏也。如佛所说言真无讳善恶之报不失所行。一切余众诸天魔梵。不见能敢违佛言者。如佛所说贤圣八道行。是得道得度众苦。一切余众诸天魔梵。亦无有能戾此教者。佛亦不见有此处者四无所畏也。是为菩萨摩诃萨摩诃衍亦无所倚。须菩提。复有摩诃衍。谓四无碍慧是。何等为四。知诸法事其慧无碍。解诸句义其慧无碍。分别辩才其慧无碍。所说了了其慧无碍。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。谓佛十八法。何等为十八法。一者谓佛从得佛以来初无误时。二者从得佛以来言无粗无漏失。三者无忘志。四者无有种种想。五者意无有不定时。六者初无他观。七者自在无有减。八者精进无有减。九者志念无减。十者智慧无减。十一者解脱无减。十二者见解脱慧无减。十三者一切身所行智慧最在前。十四者口所言事智慧最在前。十五者意所行事智慧最在前。十六者见过去事其慧无碍。十七者见当来事其慧无碍。十八者见现在事其慧无碍。是为摩诃衍亦无所倚。须菩提。复有摩诃衍。所谓陀邻尼目佉是。何等为陀邻尼目佉。与字等与言等字所入门。何等为字门。一者阿阿者谓诸法来入不见有起者。二者罗罗者垢貌于诸法无有尘。三者波波者于诸法泥洹最第一教度。四者遮遮者于诸法不见有生死。五者那那者于诸法字已讫字本性亦不得亦不失。六者罗罗者得度世爱枝各因缘已灭。七者陀陀者诸法如无断绝时。八者波波者诸法已离狱。九者茶茶者诸法垢已尽。十者沙沙者诸法无有挂碍。十一者和和者诸法言行已断。十二者多多者诸法如不。动十三者夜夜者诸法谛无所生。十四者吒吒者诸法强垢不可见。十五者加加者诸法造作者亦不可得见。十六者娑娑者诸法不可得时不可转。十七者摩摩者诸法吾我不可得见。十八者伽伽者受持诸法者不可得见。十九者他他者诸法处不可得。二十者阇阇者诸法生者亦不可得。二十一者湿波湿波者诸法善不可得。二十二者大大者诸法性不可得。二十三者赦赦者诸法寂不可得。二十四者佉佉者诸法虚空不可得。二十五者叉叉者诸法消灭不可得。二十六者侈侈者诸法各在其所处不可动摇。二十七者若若者诸法慧不可得。二十八者伊陀伊陀者诸法义不可得。二十九者繁繁者诸法无有闲时。三十者车车者诸法无可弃者。三十一者魔魔者诸法无有丘墓。三十二者叵叵者诸法不可分别。三十三者蹉蹉者诸法死亡不可得三十四者峨峨者诸法无有朋党三十五者咃咃者诸法各有异无不有处。三十六者那那者诸法无来无去。亦不住亦不坐亦不卧亦不别。三十七者破破者诸法皆于三界不安。三十八者歌歌者诸法性不可得。三十九者嵯嵯者诸法不可得常。四十者嗟嗟者诸法分舍不可得。四十一者吒吒者诸法无有度者。四十二者嗏嗏者诸法边际尽竟处亦不生亦不死。诸字数无有过嗏上者。何以故。是字无有数。亦不念言是字有失。亦不可见亦无所说亦无所书亦不现。须菩提当知一切法譬如虚空。是字教所入皆是陀邻尼所入门。若有菩萨摩诃萨。晓了是字事者。不住于言数便晓知言数之慧。若有菩萨摩诃萨。闻是四十二字所入句。印者持讽诵者。若复为他人解说其义。不以望见持讽诵者当得二十功德。何等为二十。一者得强识念力。二者得惭愧羞耻力。三者得坚固行力。四者得觉知力。五者得辩才工谈语力。六者得陀邻尼不难力。七者所语不说不急之事。八者终不狐疑于经。九者闻善不喜闻恶不忧。十者亦不自贡高。亦不自卑。十一者进止安详不失威仪。十二者晓了五阴六衰。十三者善于四谛十二缘起事。十四者善知识因缘事。十五者善于法慧能满具诸根。十六者知他人所念吉凶报应。十七者善于天耳彻听自识宿命。十八者善知众生所生。十九者能消诸漏。二十者善于往来处处教授。须菩提。是为陀邻尼门。是为字门是为来入门。是为菩萨摩诃萨。是为摩诃衍

    摩诃般若波罗蜜治地品第二十一

佛告须菩提。如汝所问菩萨摩诃萨。摩诃僧那僧涅。摩诃衍三拔致者。菩萨行六波罗蜜。过从一地至一地。云何菩萨过从一地至一地。以诸法无所过法。无来者亦无去者。亦无有过亦无不过。诸法亦无有坏。亦不贡高亦不念。但治住地事亦不见地。何等菩萨为治地事。始从第一地住当行十事。何等为十。一者先当净于三垢亦无所倚。二者所作施与不自为身所念无倚。为一切众生净于四等心亦不有众生。三者为布施不有所与不有受者。四者当与善知识从事亦不贡高。五者欲得为法不有一切法。六者欲为出家不有爱欲。七者欲为佛身不有相好。八者欲为分流法教终不坏法。九者常欲灭于虏怙自用不有法财。十者欲为谛说不有言教故。须菩提。是治地菩萨当为是十事。须菩提。菩萨摩诃萨于二地中常当念八法亦当成之。何等为八。一者当净其戒。二者常念报恩。三者住于忍辱。四者得欢喜意。五者不舍一切。六者大慈为始。七者恭于师尊敬事笃信。八者于诸波罗蜜如奉世尊常欲崇习。须菩提。菩萨摩诃萨。于二地中当具足是八法。复次须菩提。菩萨于三地中当住于五法。何等为五。一者多学问无厌足。二者不入字法。分布法施亦不贡高。三者净佛国土。四者施于善本而不贡高。五者住于羞耻惭愧之地。须菩提。是为菩萨于三地中住于五法。须菩提。菩萨于四地中当不舍奉行十事法。一者不舍宴坐。二者少欲。三者知足。四者不舍沙门十二法行。五者不舍于戒。六者见欲污秽。七者于起意如泥洹。八者不惜身所有。九者无有懈慢。十者不慕所有。须菩提。是为菩萨于四地中当奉行十事而不舍离。须菩提。菩萨于五地中当离八法。何等为八。一者当远离家业。二者当远离比丘尼。三者善于功德远离嫉妒。四者远离世会。五者远离忿诤。六者远离斗讼。七者远离高住。八者远离蔑人。须菩提。是为菩萨住五地中远离八事。须菩提。菩萨于六住地当具足六法。何等为六。所谓六波罗蜜。复有六事所不应为。何等为六。一者不为声闻意。二者不为辟支佛意。三者不为小意。四者见有所索者。远离有厌足意。五者所有好物施与之。后远离悔意。六者远离吾我想。须菩提。是为菩萨于六住中当具足六事远离六事须菩提。菩萨于七住地有二十事所不当为。何等二十。有吾我有众生有寿有命想有断有常有念想有种想入阴入性入衰。欲生三界。不入依佛见。不入依法见。不入依僧见。不入依戒不入空。不入无相。不入无愿。不入道。是为二十事所不当为。当复具足二十事。何等为二十。觉空无相。证不愿慧。净身口意。慈哀一切众生。亦不念有众生。等视诸法。虽尔无所入。欲为导御。亦不贡高。无所生忍。一道教化。断诸分别。转于想。转于见。转于灭垢见。慧地自调。意慧无所碍。不染于欲事。须菩提。是为菩萨摩诃萨。于七住行地当具足是二十法。复次须菩提。菩萨当复于八住地具足四法。何等为四。以神通为游观入于众生之意。到诸佛国观其奇特。当自庄严其佛国土。往见礼敬供养诸佛如其实观佛身。当具足是四法。复次须菩提。菩萨摩诃萨。于八住地当复具足四法。何等四法。以智具足诸根。净佛国土。常坐如幻三昧知其众生本所作功德。所应得者各随其所而成就之。须菩提。菩萨于八住地具足四法。复次须菩提菩萨摩诃萨于九住地当具足十二法。何等为十二。持无限处广大之愿随所应各授其证。天龙阅叉犍陀罗悉皆具足。知其音声以辩才教授所因。胞胎成就。居家成就。父母成就。种姓成就。宗亲成就。得生成就。出家成就。庄严佛树成就。诸善功德成就。须菩提。菩萨摩诃萨九住地当成就十二法。须菩提。十住菩萨摩诃萨当名之为如来。须菩提白佛言。世尊。何等为菩萨净其所有。佛言。所作众善应萨云若意。是为菩萨净其所有。何等为菩萨等于众生。佛言。净于四等心等于众生。何等为菩萨施于所有。佛言。施与众生而不分别。何等为菩萨当与善知识从事。佛言。教人入萨云若勤修劝助。当与是人共从事恭敬师受。是为菩萨善知识。何等为欲得为法。佛言。所行法但求萨云若法。不堕罗汉辟支佛地是。何等为菩萨常欲出家为道。佛言。在所生处常欲作沙门。无能中道为作碍者。初不忘失出家之事。何等为意愿佛身相。佛言。若见佛形像意常在佛。至得萨云若未曾有离时。何等为分流法化。佛言。若佛在世若般泥洹后。菩萨持十二部经教授。上教亦真中教亦真竟教亦真。本末义解具足清净。何等为菩萨不虏怙自用。佛言。从灭恚怒以来。初不复堕下贱之处。何等为菩萨所说如谛。佛言。如口所说言行相应。是为菩萨十法事行。须菩提白佛言。何等为菩萨净戒。佛言。不念罗汉辟支佛意及余恶戒诽谤道者是为净戒。云何菩萨报恩念恩。佛言。行菩萨道者小恩尚不忘。何况于大者是为念恩。云何菩萨立忍辱力。佛言。于诸众生无侵无恚是为忍力。云何菩萨得欢喜乐。佛言。教授众生以是为乐。云何菩萨不舍众生。佛言。欲救一切故。云何菩萨而有大悲。佛言。菩萨心念我当为一一众生故在地狱中恒边沙劫代受勤苦。一一众生皆得佛道令般泥洹。以是劝乐是为大悲。云何菩萨顺尊师父于信恭敬。佛言。事于事父如世尊想。云何菩萨欲习诸波罗蜜。佛言。远离余事但求诸波罗蜜。何谓菩萨多学无厌。佛言。诸十方佛世尊所说尽当受持是为无厌。何谓菩萨持无所希望法施分布。佛言。持所法施不希望道何况其余。何谓菩萨净佛国土。佛言。为诸善本种种功德。持是功德净佛国土。何谓菩萨生死无量阿僧祇劫不以为限。佛言。以诸功德备具。持是育养众生净佛国土。至具足萨云若不厌不懈。何谓菩萨立于惭愧。佛言。耻于罗汉辟支佛意。何等为菩萨不舍宴坐。佛言。诸罗汉辟支佛所不能及。是为菩萨不舍宴坐。何谓菩萨少于所欲。佛言。菩萨道尚不欲何况余欲。何谓菩萨而自知足。佛言。得萨云若是为知足。何谓菩萨不舍沙门头陀德行。佛言。入深法忍者是。何谓菩萨不舍于戒。佛言。菩萨不复用戒是为不舍于戒。何谓菩萨污秽色欲。佛言。于淫妒无所生。何谓菩萨意与泥洹等佛言。菩萨不有一切诸法。何谓菩萨弃舍所有。佛言。不受内外所有是为弃舍。何谓菩萨不厌不懈。佛言。不生二识之处是为不厌。何谓菩萨于诸所有无所恋慕。佛言。于诸物无念故。须菩提白佛言。何等为菩萨远离居业。佛言。游诸佛国转所生处。常下须发被着袈裟。是为远离家业。何谓菩萨远离比丘尼众。佛言。弹指之顷不与共止。弹指之顷不得生意。是为菩萨离比丘尼。何谓菩萨离于妒嫉。佛言。菩萨当作是念。我当安隐众生不宜生嫉。何谓菩萨离于聚会。佛言。菩萨所住聚会。若有罗汉辟支佛意者常远离之。何谓菩萨远离嗔恚。佛言。不令恚害斗诤得其便。云何菩萨远离自举。佛言。内法不可得见故。云何菩萨远离訾蔑他人。佛言。亦不见外法故。何谓菩萨远离十恶。佛言。此十恶事常欲坏于贤圣之道。何况佛道而不远离。是故当远离十恶。何谓菩萨远离[怡-台+龍]戾。佛言。不见有法可贡高者。是为离于[怡-台+龍]戾。何谓菩萨远离自用。佛言。尚不见有形。当于何所而行自用何等为菩萨远离颠倒。佛言。以形不可得见故。云何菩萨离淫怒痴。佛言。不复见淫怒痴形故。云何菩萨在于六住具足六波罗蜜。佛言。住于六波罗蜜诸佛世尊及声闻辟支佛。所可度彼岸。是为菩萨具足六波罗蜜。云何菩萨不为声闻意。佛言。以声闻事非平等道故不为小意。何以故。亦非平等道故。云何不厌。厌者亦非平等道故弃舍不悔。悔者非平等道。初发意者便当施与亦不当惜。云何菩萨不当作吾我想。从本际以来不可见故。乃至众生有寿命想。从本以来亦不可见故。云何菩萨不断所生见。以诸法无有断截。从有本以来无所生故。云何菩萨不为常见。见法所不生者亦无有常故。云何菩萨不作念想以无有垢故。云何菩萨不作种相以诸见不可得见故。云何菩萨不入名色不见有形故。云何菩萨不入五阴亦不入性亦不入衰。其实不可得见故。云何菩萨不入三界。以三界亦无真故。云何菩萨不作住处。亦不与虚空作期无所依怙。何以故。无有形像故。云何菩萨不入佛见。不从所依得见佛故。云何菩萨不与空诤。一切法空空不与空诤故。云何菩萨具足于空。其欲具足相者是为具足空。云何菩萨得无相证。不念于诸相故。云何菩萨得无愿智不着三界故。云何菩萨净于三事具足十善故。云何菩萨以慧具足哀念众生。以大悲利之故。云何菩萨无众生念欲净佛国故。云何菩萨等观诸法。以不高下诸法故。云何菩萨得于道觉。随诸法所觉而度脱之故。云何菩萨得无所生忍。得诸法所有无生无灭无所忍故。云何菩萨得无所生慧。知名色无所起故。云何菩萨得一道之教。无有二教故。云何菩萨灭诸分别。于诸法无所分部故。云何菩萨不修转见。以不转求罗汉辟支佛意故。云何菩萨转于垢浊。灭诸所习漏故。云何菩萨得灭诸垢而得清净。所谓萨云若慧是。云何菩萨而自调意不厌三界故。云何菩萨而得灭意制六根故。云何菩萨慧无有碍谓得佛眼故。云何菩萨知情欲不坚固观六衰故。云何菩萨能入众生意。持一意悉知众生所念故。云何菩萨游于神通。从一佛国至一佛国。初无有佛国想故。云何菩萨得佛国观。于是国住遍见诸佛国亦无佛国想故。云何菩萨随其所见。诸佛国土自成其国。住于遮迦越罗地。游诸三千大千国土故。云何菩萨奉见诸佛以见法故是为见佛。云何菩萨真见佛身。逮法性故是为真见。云何菩萨以智具足力。已住世尊十力之地。便能具足众生力故。云何菩萨能净佛国。能净众生故。云何菩萨如幻三昧。所作随所应无有动转故。云何菩萨常住三昧。已得报应故。云何菩萨入诸功德。随其道法而度脱之故。云何菩萨不复思议。能自成立教授一切故。云何菩萨所愿谐偶。具足行六波罗蜜是故谐偶。云何菩萨知诸天龙鬼神所知所言。以辩才慧无所不了故。云何菩萨得胞胎成就。在所生常化生故。云何菩萨居家成就。生于豪贵家故。云何菩萨父母成就。得生刹利婆罗门家故。云何菩萨种姓成就。得继过去诸菩萨种故。云何菩萨宗亲成就。以众菩萨为眷属故。云何菩萨得生成就。生时光明普遍无量国土。震动无量国土故。云何菩萨出家成就。菩萨出家时安诸无央数百千众生。满具足是三乘之愿故。云何菩萨庄严佛树。以黄金为树七宝为枝叶。其枝叶光明悉遍照十方无央数刹土。是为佛树成就。云何菩萨诸善功德成就。菩萨摩诃萨净佛土净众生。是为成就净诸功德也。云何十住菩萨名为如来。用具足六波罗蜜。诸习绪尽得佛十八法。具足萨云若慧。须菩提。是故菩萨摩诃萨已得十住名为如来。云何菩萨已住十地。佛告须菩提。菩萨摩诃萨沤和拘舍罗行六波罗蜜。乃至三十七品行十八法。过灭净地种性地八地见地薄地灭淫怒痴地已作地辟支佛地菩萨地。须菩提。菩萨摩诃萨过是九地便住佛地。须菩提。是为菩萨摩诃萨十住之地。当知是为菩萨摩诃萨摩诃衍三拔致

    摩诃般若波罗蜜问出衍品第二十二

佛告须菩提。汝所问菩萨摩诃萨。从何所出衍中。当住何所者今当说之。佛言。当出三界随萨云若住而无所倚。何以故。摩诃衍与萨云若是法共等。亦不别亦不同亦无形亦非见亦非碍一相。一相者谓无相。何以故。须菩提。无相之法亦不出亦非不出。须菩提。若无相法出者法性亦当复出生。假令无相法出生者如亦当复出生。欲出生无相法者。为欲出生真际。若欲出生无相法者。为复欲出生不可思议性。欲出生无相法者。为复欲出生安隐之性。欲出生无相法者。为欲出生灭尽。欲出生无相法者。为欲出生灭尽之体。欲出生无相法者。为欲出生色空痛想行识空。何以故。色空者亦不出三界亦不住萨云若。痛想行识空亦尔。何以故。须菩提。色色自空。痛想行识识自空。欲出生无相法者。为欲出眼空为欲出意空。欲出生无相法者。为欲出六衰及十二因缘空。何以故。六衰空者亦不出三界。亦不住萨云若。欲出生无相法者。为欲出生梦幻炎响光影。欲出生无相法者。为欲出生如来之所作化。何以故。梦幻炎响光影及如来所化。亦不出三界亦不住萨云若。何以故。梦以梦事空。炎事幻事响光事影事。乃至如来所化事皆自空。欲出生无相法者。为欲出生檀波罗蜜。欲出生无相法者。为欲出生尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜。欲出生无相法者。为欲出生般若波罗蜜。何以故。须菩提。六波罗蜜事。亦不出三界亦不住萨云若。何以故。六波罗蜜六波罗蜜空故。欲出生无相法者。为欲出生内外空。欲出生无相法者。为欲出有空无空。何以故。须菩提。内外空事至有无空事自空。亦不出三界亦不住萨云若。何以故。内外空空乃至有无空空。欲出生无相法者。为欲出生四意止四意断四神足五根五力七觉意八正行。欲出生无相法者。为欲出生十八法。欲出生无相法者。为欲出生罗汉辟支佛。上至如来等正觉也。何以故。罗汉辟支佛事上至佛。亦不出三界亦不住萨云若。何以故。罗汉罗汉事空。辟支佛辟支佛事空。佛佛事空。欲出生无相法者。为欲出生须陀洹果斯陀含果阿那含果阿罗汉果辟支佛果佛果。欲出生无相法者。为欲出生萨云若。欲出生无相法者。为欲出生名相。欲出生行者。为欲出生设法教数。何以故。须菩提。名空及设教法行空空。何以故。名空空故。欲出生无相法者。为欲出生无所生无所灭无所著无所断无所有。以是故须菩提。摩诃衍从三界出。住萨云若不动处。须菩提。汝所问衍住何所。佛言。衍无所住。何以故。如诸法亦无所住。衍所住如无所住。譬如法性亦不住亦不不住。衍者不住亦不不住。无所生亦不住亦不不住。不生不灭不着不断。无所有亦不住亦不不住。衍亦如是。何以故。法性事亦不住亦不不住。法性事自空故。乃至无所有。无所有亦自空。须菩提。衍无所住。何以故。诸法无所住而住而不动。如须菩提所问。谁当出衍者。无有从衍中出者。何以故。须菩提。所可出者及衍甫当出者。亦无所有是亦不可见。诸法亦不可见当从何法出。何以故。吾我不可见故。乃至寿命知见之事从本至竟净。从我人至知见及法性。不可见如亦不可见。真际亦不可见至竟净。不可思议性阴衰不可见。六波罗蜜亦不可见至竟净。内外空至有无空亦不可见至竟净。三十七品佛十八法亦不可见至竟净。从须陀洹至罗汉辟支佛上至佛。亦不可见至竟净。从须陀洹道至罗汉辟支佛道。上至阿耨多罗三耶三菩。亦不可见至竟净。不生不灭不着不断。无所有不可见至竟净。过去当来今现在亦无所有至竟净。去住从此至彼亦无所有至竟净。增减亦不可见至竟净。何谁不生而不可见。法性不生不可见。何以故。法性亦不可见亦不不可见。如不可见无所见。空真际至般若波罗蜜无所有不可见。内外空至有无空无所见亦不可见。三十七品及十八法无所有不可见。从须陀洹至佛无所有不可见。从须陀洹道至佛道阿耨多罗三耶三菩。无所有不可见。无所生不可见。至无所有。从无所有无所有不可见。何以故。须菩提。无所有不可见。初住地亦不可见。至十住地无所有不可见。无所有不可见至竟常净。何等为初住地灭净地种性地第八地见地薄地除垢地所作已作地辟支佛地菩萨地佛地。于内外空亦不见。初地不可见至内外空有无空无所有。第二住地第三第四第五第六第七第八第九乃至第十。从内外空有无空至第十住亦不可见。何以故。须菩提。从一住至十住亦无所有亦不可见至竟净。内外空至有无空众生净无所有至竟净。内外空至有无空佛国净无所有至竟净。内外空有无空五眼无所有至竟净。须菩提。如是菩萨摩诃萨。以无所倚事令诸法以摩诃衍出萨云若

放光般若波罗蜜经卷第四放光般若经卷第五

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜叹衍品第二十三

须菩提白佛言。唯世尊摩诃衍。摩诃衍者。出诸天世间人阿须伦之上。衍与空等如虚空。与无量无央数众生而作救护。以此世尊为摩诃衍。菩萨摩诃萨亦不见来时亦不见去时亦不见住处。摩诃衍如是。亦不见前后亦不见中央。世尊。是故摩诃衍名为无有与等者。而无有双。是故名曰摩诃衍。佛告须菩提。如是如是。须菩提。摩诃衍者六波罗蜜是。复有摩诃衍。所谓诸陀罗尼门。诸三昧门首楞严三昧。乃至虚空际解脱无所著三昧。是为菩萨摩诃萨摩诃衍。须菩提。复有摩诃衍。内外空乃至无有空。是为摩诃衍复有摩诃衍。三十七品佛十八法。是为菩萨摩诃萨摩诃衍。如须菩提所言。摩诃衍者出诸天阿须伦世间人民之上。须菩提。假令欲界其中所有实有。不异谛不颠倒有常坚强。亦不变易非为空法。若当尔者。摩诃衍亦不能出过诸天龙阿须伦世间人民上。须菩提。当知欲界劫尽烧时所有皆尽。无常无强亦无坚固用。是故摩诃衍出过世间人民诸天阿须伦之上。若使色界亦当有常常坚固者。摩诃衍亦不能出其上。用色界空无常坚固亦当坏尽亦不久住。是故摩诃衍出过其上。至于无色界皆当灭尽亦如是。须菩提。若色湛然坚固。有常谛不颠倒为是坚固法者。摩诃衍亦复不能过诸天阿须伦世固人民上用色无常无强坚固不谛颠倒故。摩诃衍出过其上。痛想行识皆悉无常亦如是。若眼耳鼻舌身意。色声香味细滑法及十二因缘。湛然有常坚强牢固谛不颠倒常久安者。摩诃衍亦复不能出过其上。用诸法及十二因缘。无常无坚无强无牢无固不谛颠倒。皆如劫烧非安法故。摩诃衍德出过诸天龙鬼神世间人民上。须菩提。若法性中有所有者不为摩诃衍。以法性无所有故为摩诃衍。假令如真际不可思议。体有所有者亦不为摩诃衍。以如真际不可思议体无所有故为摩诃衍。须菩提。若六波罗蜜有所有者不为摩诃衍。以六波罗蜜无所有故为摩诃衍。出过诸天龙阿须伦世间人民上。若内外空及有无空有所有者不为摩诃衍。以内外空及有无空无所有故为摩诃衍。出过诸天阿须伦世间人民上。若三十七品及十八法有所有者不为摩诃衍。用三十七品及佛十八法无所有故为摩诃衍。出过诸天阿须伦世间人民上。须菩提。若八辈地法须陀洹法斯陀含法阿那含法阿罗汉法辟支佛法阿惟三佛法佛法有所有者。不为摩诃衍。用八辈法从须陀洹至佛法无所有故为摩诃衍。出过诸天阿须伦世间人民上。须菩提。若八辈从须陀洹斯陀含阿那含阿罗汉辟支佛阿惟三佛佛有所有者不为摩诃衍。用种性从须陀洹上至佛无所有故为摩诃衍。出过诸天阿须伦世间人民上。须菩提。若诸天阿须伦世间人民有所有者不为摩诃衍。用诸天阿须伦世间人民无所有故为摩诃衍。出过其上。须菩提。若有菩萨摩诃萨。从初发意乃至佛坐。中间诸可所作。发意以来有所有者不为摩诃衍。用菩萨摩诃萨初发意以来乃至佛坐无所有故为摩诃衍。出过诸天阿须伦世间人民上。须菩提。若菩萨摩诃萨金刚慧有所有者。菩萨不觉诸习绪不成萨云若。用金刚慧无所有故菩萨觉诸习绪者成萨云若。以是故出过诸天阿须伦世间人民上。须菩提。若如来无所著等正觉三十二大士之相有所有者。如来无所著等正觉。不能出诸天阿须伦世间人民上。无此威德神耀光明巍巍之事。用三十二相无所有故。如来无所著等正觉。威德神耀光明巍巍。出过诸天阿须伦世间人民上。须菩提。若如来无所著等正觉光明有所有者。如来光明不能遍至十方恒边沙国土。须菩提。用光明无所有故。能遍照恒沙国土。须菩提。若八种声有所有者。如来音声不能周遍十方恒边沙无量国土。若佛法轮有所有者。如来不能转法轮。诸沙门婆罗门世间人民。诸天鬼神龙诸魔诸梵所不能转者。须菩提。若众生有所有者。如来所能为众生转法轮。令诸众生于无余泥洹界而般泥洹。以众生非物无所有故。是以如来为转法轮令得泥洹。当来者亦当复般泥洹

    摩诃般若波罗蜜衍与空等品第二十四

佛告须菩提。如汝所言。衍与空等。如是如是。实与空等。譬如虚空亦不可知东亦不知西亦不知南亦不知北亦不知四维上下。须菩提。如来衍者。亦无有东西南北。亦无四维上下。须菩提。譬如虚空无长无短无方无圆。如来衍者亦如是。譬如虚空亦不青黄亦不赤白亦不红缥。如来衍者亦如是。是故须菩提。衍与空等。是故名为衍。譬如虚空不过去不当来亦不现在。如来衍者亦如是。衍与空等。譬如虚空不长亦不大不增亦不减。如来衍者亦如是。是故衍与空等。须菩提。譬如虚空亦不着亦不断。如来衍者亦如是。譬如虚空不生亦不灭亦不住亦无异是故名为衍与空等。譬如虚空亦不善亦不不善亦不言亦不语。衍亦如是不语亦不善恶。是故衍与空等。须菩提。譬如虚空亦不见亦不闻亦不有亦不识。衍者亦不闻亦不见亦不有亦不识。是故衍与空等。须菩提。譬如虚空不思亦不觉亦不作证。亦不弃亦不念。衍亦如是。譬如虚空亦不淫法亦不无淫。摩诃衍亦如是。须菩提。譬如虚空亦不属欲界亦不属形界亦不属无形界。衍亦如是亦不属三界。是故衍与空等。譬如虚空亦不初发意。亦不二三四五六七八九。亦不十住意。衍亦如是亦无十住意。是故衍与空等。譬如虚空亦无须陀洹道斯陀含道阿那含道阿罗汉道。衍亦如是。是故衍与空等。须菩提。譬如虚空亦非弟子地。亦非辟支佛地。亦非阿惟三佛地。衍亦如是。是故衍与空等。譬如虚空亦非形色亦不非形色。亦非碍亦不非碍。亦非应亦不非应。衍亦如是。是故衍与空等。须菩提。譬如虚空亦不有常亦不无常。亦非苦亦非乐。亦非我亦不非我。衍亦如是。是故衍与空等。譬如虚空亦非空亦不非空。亦不相亦非不相。亦不愿亦非不愿。衍亦如是。是故衍与空等。须菩提。譬如虚空亦不灭净亦不不灭净。亦非寂亦不非寂。衍亦如是。是故衍与空等。譬如虚空亦不明亦不冥。衍亦如是。须菩提。譬如虚空亦不可见亦非不见。衍亦如是。是故衍与空等。譬如虚空亦无行亦无不行。衍亦如是。是故衍与空等。以是故须菩提。摩诃衍与空等。如须菩提言。虚空覆护不可计阿僧祇人。摩诃衍亦如是。须菩提。众生无有绪。虚空亦无有绪。虚空无有绪。摩诃衍亦无有绪。当作是念。当作是知。须菩提。是故不可计阿僧祇人仰摩诃衍。何以故。须菩提。众生摩诃衍虚空俱无所有故。众生无有限量。虚空亦无有限量。摩诃衍亦不可限量。是故须菩提。无量阿僧祇众生望摩诃衍。须菩提。虚空摩诃衍众生俱不可得见。须菩提。如众生无有限。虚空无有限。当作是知。摩诃衍亦无有限。众生无有绪。法性亦无有绪。如法性无有绪。虚空亦无有绪。如虚空无有绪。摩诃衍亦无有绪。如摩诃衍无有绪。无量无限亦无有绪。如无限无有绪。不可计亦无有绪。以是须菩提。不可计众生望摩诃衍。何以故。众生及法性虚空摩诃衍阿僧祇无有量不可计皆不可得见。须菩提。如众生无绪。当知如来亦无绪。如佛无有绪。虚空亦无有绪。如虚空无有绪。当知摩诃衍亦无绪。如衍无绪。阿僧祇无有绪。如阿僧祇无绪。当知无量无限亦无绪。如无限无有绪。当知一切众生亦无有绪。如是须菩提。不可计阿僧祇人皆仰摩诃衍。何以故。众生及佛虚空摩诃衍阿僧祇无量无限一切诸法皆不可见。复次须菩提。吾我绪乃至知见绪真际绪如真际绪。当如是知诸法绪。是故须菩提。无央数阿僧祇人皆仰摩诃衍。何以故。众生及诸法皆不可见。须菩提。吾我众生绪及知见不可思议体。如不可思议当知五阴绪诸法绪。须菩提。不可计阿僧祇人望摩诃衍。何以故。所谓吾我及诸法皆不可见故。须菩提。如吾我绪知见绪。眼耳鼻舌身意亦无有绪。如六情无有绪。当知诸法亦无有绪。如是须菩提。不可计阿僧祇人皆仰摩诃衍。何以故。所谓吾我及诸法皆不可见故。须菩提。如吾我无绪及知见亦无有绪。当作是知。六波罗蜜亦无有绪。如般若波罗蜜无绪。当知诸法亦无有绪。须菩提。是故无央数阿僧祇人皆仰摩诃衍。何以故。吾我及诸法皆不可见。须菩提。以吾我无绪内外空无绪。及有无空亦复无绪。如有无空无端绪。诸法亦无端绪。以是故不可计阿僧祇众生皆望摩诃衍。何以故。吾我及诸法皆不可见故。须菩提。吾我众生及知见无端绪。及三十七品十八法亦无端绪。如十八法无端绪。须菩提。是故不可计阿僧祇人望摩诃衍。何以故。吾我诸法皆不可见故。须菩提。吾我无端绪。种性已辨及诸法无有绪。是故不可计众生望摩诃衍。何以故。吾我及诸法皆不可见。须菩提。须陀洹无有绪。斯陀含阿那含阿罗汉辟支佛上至佛萨云若及诸法无有绪。以是故一切众生望摩诃衍。何以故。吾我及诸法皆不可见。譬如泥洹性为一切众生而作覆护是故摩诃衍为一切众生而作覆护须菩提。所言摩诃衍。亦不见来时亦不见去时。亦不见住处。何以故。诸法不动摇故。诸法亦不去亦不来亦无有住处。何以故。五阴性五阴相五阴事五阴如。亦不来亦不去亦无住处。眼耳鼻舌身意。色声香味细滑识法性如事相。亦不来亦不去亦无住处。四大性如事相。识性空如事相。亦不来亦不去亦无住处。如真际不可思议性。亦不来亦不去亦无住处六波罗蜜性如事相亦不来亦不去亦无住处。三十七品十八法性如事相。亦不来亦不去亦无住处。道及佛性如事相。亦不来亦不去亦无住处。有为无为性如事相。亦不来亦不去亦无住处。须菩提。如汝所言摩诃衍亦不见东西南北四维上下者。名与三世等。是故为摩诃衍。须菩提。如汝所言审谛无异。何以故。过去世非世空。当来世非世空。现在世非世空。三世等等者空。摩诃衍衍自空。菩萨菩萨自空。须菩提。空者亦非数亦非多亦非少。是故菩萨摩诃萨。摩诃衍与三世等。无偶无只。无淫怒痴亦不离淫怒痴。亦不恚亦不可见。善恶亦不可见。有常无常及与吾我亦不可见。苦乐我非我亦不可见。三界亦不可见。度三界亦不可见。何以故。其形事不可见故。过去色以过去色自空。当来色以当来色自空。今现在色以现在色自空。痛想行识亦尔。过去色空不可见。过去空空不可见。现在五阴色空尚不可见。何况当来过去五阴空而可见者。空亦不见五阴。五阴亦不见空。假令空能见五阴者。五阴亦当见空。须菩提。过去六波罗蜜亦不见。当来六波罗蜜亦不见。现在六波罗蜜亦不见。三世等六波罗蜜亦不见。等亦不见。三世等亦复不见等。等不见等故三世不见。过去当来今现在三十七品十八法亦不见。三世等亦不见。须菩提。等亦不见。三十七品及十八法过去当来今现在等亦不于三世不可见。于三世中亦不见三十七品及十八法。何况于三世等而可见者。复次须菩提。过去凡人当来凡人现在凡人亦不可见。三世等凡人亦不可见。何以故。众生本不可见故。过去当来今现在弟子缘觉菩萨如来亦不可见。三世等弟子缘觉菩萨如来众生本不可见故。须菩提。菩萨摩诃萨。住般若波罗蜜中。当了三世事当具足萨云若。是为菩萨摩诃萨三世等学摩诃衍。菩萨摩诃萨已住其中者。便过诸天阿须伦世间人民上。出萨云若。须菩提白佛言。善哉善哉。世尊。菩萨摩诃萨从摩诃衍中学。自致具足萨云若慧。过去十方诸菩萨。皆从是摩诃衍得成逮萨云若慧。当来十方诸菩萨。亦当从是摩诃衍中学得成逮萨云若。今现在十方无央数不可计诸菩萨摩诃萨。亦皆从是摩诃衍得成具足萨云若。是故菩萨摩诃萨摩诃衍。佛告须菩提。如是如是。须菩提。过去当来今现在诸佛。皆当从是衍中学成萨云若。已逮者未逮者甫当逮者。皆当从是摩诃衍中学具足萨云若慧

    摩诃般若波罗蜜合聚品第二十五

于是邠耨文陀尼子白佛言。唯世尊。世尊使须菩提说般若波罗蜜。乃说摩诃衍教为。须菩提白佛言。唯世尊。须菩提说摩诃衍教。将无离般若波罗蜜耶。佛言不也。须菩提。汝所说摩诃衍教者。顺从无违不失般若波罗蜜教也。何以故。须菩提。诸所可有一切善法。及诸声闻辟支佛法上至佛法。皆共合集于般若波罗蜜中。须菩提白佛言。世尊。云何善法及声闻辟支佛法菩萨法。佛法皆共合在般若波罗蜜中。佛告须菩提。所谓六波罗蜜。四意止。四意断。四神足。五根。五力。七觉意。贤圣八品道。三脱门。四无碍慧。大慈大悲。十种力。四无所畏。十八不共。无所望法。常等行。须菩提。是为善法。三十七品声闻法辟支佛法菩萨法佛法。是为合聚般若波罗蜜中。须菩提。所谓摩诃衍六波罗蜜五阴十二衰十八性三十七品。乃至佛十八法三脱门。善法漏法有为法无为法苦习尽道法。欲界形界无形界。内空外空所有空无所有空。诸三昧门陀邻尼门佛十八法。如是如来所说法教律法性。及如真际不可思议性。泥洹一切诸法。亦不合亦不散。亦无有形亦不可见。亦无有对一相。一相者所谓无有相。以是故须菩提。汝所说摩诃衍教与般若波罗蜜。其义顺从不相违错。所以者何。摩诃衍与般若波罗蜜无别无异。摩诃衍与三十七品至十八法亦复不别。摩诃衍则佛法。佛法则摩诃衍。是事一无有二。亦不相违背。须菩提。以是故说摩诃衍教者。则为说般若波罗蜜

    摩诃般若波罗蜜不可得三际品第二十六

于是须菩提白佛言。菩萨摩诃萨。无有端绪无有边际亦无有底。色痛想行识亦无有端绪亦无有边际。当知菩萨亦复如是。欲言色是菩萨乎。非也。痛想行识是菩萨耶。非也。须菩提言。世尊。我都卢不见有菩萨。当为何谁说般若波罗蜜。当教何谁。须菩提言。所谓菩萨。菩萨但字耳。世尊。譬如自言我有无之法不生。云何色痛想行识不生。世尊。不生者为非色亦非痛想行识尚无所生。当为谁说般若波罗蜜。亦不离于生处。见菩萨行道作是说者。菩萨闻是不恐不怖不悔不怯。是为菩萨摩诃萨行般若波罗蜜。舍利弗问须菩提。若使菩萨前后边际中央际不可得。何以故。色与菩萨俱无有边。云何色痛想行识为非菩萨。云何言都卢不见有菩萨。当为谁说般若波罗蜜。何以故。言菩萨但有字耳。何以故。言我有无之法不生五阴何以生。何以故。言不生者为非五阴。云何言无生当教谁说般若波罗蜜。云何言不见有离生行菩萨道者。何以故。言菩萨闻是不恐不怖为行般若波罗蜜。须菩提语舍利弗言。用众生始终端绪不可得故。菩萨前后中央际不可得见。舍利弗。以众生空故菩萨端绪亦不可得见。用众生寂故菩萨端绪不可得见。用五阴无有边际。用五阴空用五阴寂用五阴不真故。是故菩萨端绪不可得见。以六波罗蜜无有底无有边际故。何以故。舍利弗。空及五阴菩萨等无异。是三事一无有二。是故舍利弗。菩萨端绪不可得见。以六波罗蜜空寂不真。是故菩萨端绪不可得见。何以故。舍利弗。空本际亦不可见。末际亦不可得见。中际亦不可得见。空与菩萨俱亦不可得见。舍利弗。空菩萨端绪一无有二。是故菩萨端绪不可见。内空外空及有无空边际不可见。是故菩萨端绪不可得见。复次舍利弗。三十七品及佛十八法皆无有端绪。佛法空佛法寂佛法不真。是故菩萨端绪不可得见。从六波罗蜜至佛十八法皆无有端绪。皆空皆寂皆不真。是故菩萨端绪不可得不可见。复次舍利弗。诸三昧门陀邻尼门皆无有端绪。皆空皆寂皆不真。是故菩萨端绪不可得见。复次舍利弗。法性及如真际不可思议性。皆无有端绪。空寂不真。是故菩萨端绪不可得见。复次舍利弗。声闻辟支佛如来皆无有端绪。皆空皆寂皆不真。是故菩萨端绪不可得见。道萨云若皆无有端绪。皆空皆寂皆不真。是故菩萨端绪不可得见。何以故。舍利弗。空始终端绪中边皆不可得见。故菩萨亦不可得见。舍利弗。空五阴菩萨是三事皆一无有二法。是故菩萨端绪不可见。如舍利弗所问。五阴无有底故。当知菩萨亦无有底。须菩提言。五阴如虚空。虚空亦无边亦无际亦不可量亦无有底。但以名字为虚空耳。舍利弗。色空无有边际。痛想行识识空无有边际亦不可得见。是故舍利弗。虚空底五阴底菩萨底亦不可得见。十二衰十二因缘三十七品佛十八法此诸法端绪。菩萨端绪皆不可得见。皆无有边际故。须菩提言。舍利弗。所问五阴是菩萨耶。不可得见亦无边亦无际亦不可量亦无有底。但以名字为虚空耳。舍利弗。色空无有边际。痛想行识识空无有边际亦不可得见。是故舍利弗。虚空底五阴底菩萨底亦不可得见。十二衰十二因缘三十七品佛十八法。此诸法端绪菩萨端绪。皆不可得见皆无有边际故。须菩提言。舍利弗所问五阴是菩萨耶不可得见。是故五阴与菩萨皆不可得见。舍利弗。六波罗蜜六波罗蜜自空。内外空内外空自空。乃至有无空有无空自空。三十七品三十七品自空。乃至佛十八法十八法自空。如及真际不思议性。陀邻尼三昧门。萨云若道事。声闻缘觉佛佛义各各自空。舍利弗。如来五阴空。亦不有亦不可见。以是故舍利弗。是故菩萨五阴不可得见。舍利弗所问。何以故菩萨不可见不可得。当为何谁说般若波罗蜜。须菩提语舍利弗。色不见色。色亦不见痛。痛亦不见色。痛亦不见行。行亦不见痛。痛亦不见想。想亦不见痛。想亦不见识。识亦不见想。色痛想行识亦如是。眼眼亦不有亦不可见。至意意亦不有亦不可见。眼识意识亦不有亦不可见。眼栽至意意栽至因缘法。亦不有亦不可见。至六波罗蜜亦不有亦不可见。内空外空至所有空无所有空。三十七品及佛十八法。亦不有亦不可见。诸三昧门陀邻尼门亦不有亦不可得见。从须陀洹法至罗汉法亦不有亦不可见。十住亦不有亦不可见。道法萨云若法亦不有亦不可见。须陀洹至罗汉辟支佛及佛。亦不有亦不可见。至教法亦不有亦不可见。舍利弗。以诸法无所有不可见。菩萨不可见。以是故无所教。须菩提语舍利弗。如所问何以故但以字为菩萨者。字法但以名字假号为菩萨耳。以是故但字为菩萨也。色痛想行识亦复假号有字耳。诸有名者亦无色痛想行识。何以故。空无有真名故。若使空者非是菩萨。是故言但以字为菩萨耳。复次舍利弗。六波罗蜜者但字耳。六波罗蜜亦非字。字亦非六波罗蜜。何以故。字菩萨诸波罗蜜俱等不可见故。是以菩萨但以假号为字耳。舍利弗。内外空有无空亦但以字着耳。字亦非空。空亦非字。何以故。字空内外空乃至有无空俱不可见故。舍利弗。是故但以字为菩萨耳。舍利弗。三十七品至十八法亦假名与字耳。诸三昧门陀邻尼门亦复如是。乃至萨云若普皆如是如是。舍利弗所问何以故名为吾我至本无所生。从本已来至于吾我。亦不可得见当那得生。从有生有命至于知见。常不可见当那得生。从有名以来五阴不可见知当那得生。从六情至十二因缘起亦不可见。何况有生。六波罗蜜亦不可见。何况有生。从内外空及有无空常不可见。何况有生。从有名以来三十七品及十八法亦不可见当从何生。从有名以来诸三昧门陀邻尼门亦不可见当从何生。从有名已来声闻辟支佛及佛亦不可见当从何生。舍利弗。是故名为吾我。诸法皆不生故。复次舍利弗。如所问诸法有无之事无有作者。舍利弗问须菩提。何等所有无有作者。须菩提言。五阴所有无有作者。六情内外至于十二缘起所有亦无作者。六波罗蜜所有亦无作者。以是因缘。舍利弗。诸法亦不有亦不无。复次舍利弗。一切诸法皆悉无常无能坏者。舍利弗问须菩提。何等诸法无有常无能坏者。答言。五阴无有常无能坏者。何以故。无常无所有消尽。是故诸法无常无能坏者。乃至有为法无为法有漏法无漏法。已记法未记法无常无能坏者。舍利弗。无常无所有消尽。以是故诸法无常无能坏者。舍利弗。诸法亦不聚亦不散。舍利弗言。何等不聚何等不散。须菩提言。五阴不聚不散。何以故。性自尔。乃至善法恶法有为法无为法有漏法无漏法。亦不聚亦不散。何以故。性自尔。以是故诸法亦不有亦不无。舍利弗。所问五阴无所生者。用五阴六衰无有作者不见有作者故。诸法皆无有作者。以是故无所生。舍利弗。所问无所生非五阴者。以五阴性自空故。亦不生亦不灭亦不住。乃至有为性性空故。性自空者亦不起亦不灭亦不住。是故无所生非五阴。舍利弗。所问无所生为谁说般若波罗蜜者。若无所生为非般若波罗蜜。般若波罗蜜亦非无所生。无所生般若波罗蜜一法无有二。是故言当为谁说般若波罗蜜。舍利弗。所问亦不离五阴生行菩萨道者。无所生则是般若波罗蜜。般若波罗蜜则是无所生。无所生则是五阴。五阴则是无所生。而不别是法亦不二。舍利弗。是故亦不离生行菩萨道也。舍利弗。所问云何闻是不恐不怖为行般若波罗蜜者。菩萨摩诃萨。见诸法皆空如梦如幻如炎如响如影如化。以是故菩萨闻是教不恐不怖。须菩提白佛言。菩萨行般若波罗蜜时作是观。是时亦不见色亦不入色亦不生色亦不住色亦不言是色。痛想行识亦不见识。亦不入识亦不生识亦不住识亦不言是识。眼耳鼻舌身意亦不见亦不入亦不生亦不住亦不言是我所。六波罗蜜亦不见亦不入亦不生亦不住亦不言是我所。内外空至有无空亦不见亦不入亦不生亦不住亦不言是我所。世尊。菩萨行般若波罗蜜至三十七品佛十八法。亦不见亦不入亦不生亦不住亦不言是我所。诸三昧门陀邻尼门。亦不见亦不入亦不生亦不住亦不言是我所。何以故。菩萨行般若波罗蜜亦不见色。乃至萨云若亦无所见。世尊。不生色者为非色。亦不生痛想行识者为非识。不生六衰者为非六衰。不生六波罗蜜者为非六波罗蜜。六波罗蜜至无所生一法无二。不生内外空为非空。不生有无空为非空。有无空及无所生一法耳无二。世尊。三十七品不生为非三十七品。佛十八法不生为非十八法无所生及佛十八法一法无二。世尊。无所生一法耳。亦非二亦非三亦非四亦非五亦不若干数。是故佛法无所生法一法无二。世尊。如及不思议性不生者。为非如为非不思议性。不生道者为非道。不生萨云若者为非萨云若。无所生萨云若一法无二。世尊。无所生亦不一无有若干数。是故不生。萨云若者为非萨云若。灭色者为非色。灭色者是一法无有二。世尊。灭者一无有二。是故灭色者为非色。灭痛想行识者为非识。是故生识者为非识。内空外空至有无空。及三十七品佛十八法亦如是。世尊。是为灭非若干也。从识至萨云若亦如是。是为行般若波罗蜜

    摩诃般若波罗蜜问观品第二十七

舍利弗问须菩提言。菩萨摩诃萨。云何行般若波罗蜜而观诸法。何等为菩萨。何等为般若波罗蜜。何等为观。尊者须菩提语舍利弗言。如所问何等为菩萨。菩萨者为道士也。故名为菩萨。以道故知诸法事而无所入。问曰。知何等诸法事。答曰。知色事不入色。知痛想行识事不入识。尽知佛十八法事不入十八法。舍利弗问。何等为诸法事。须菩提言。所可名者。诸法之貌色声香味细滑法。内法外法有为无为法像貌。所可名者是为诸法事也。舍利弗。所问何等为般若波罗蜜。般若波罗蜜者名为远离。问曰。何以故名为远离。须菩提言。远离五阴远离十八性远离六衰。远离檀波罗蜜至禅波罗蜜。远离内外空至有无空。远离三十七品至十八法。是名为远离。远离萨云若。远离萨云若事。尊者舍利弗。是故名为远离般若波罗蜜。舍利弗。所问何等为观行般若波罗蜜。菩萨亦不观五阴有常无常。亦不观五阴苦乐。亦不观五阴有我非我。亦不空亦非不空。亦不相亦非不相。亦不愿亦非不愿。亦不灭亦非不灭。亦不寂亦非不寂。亦不作是观。至六波罗蜜。从内外空至有无空。及佛十八法亦复如是。诸三昧门陀邻尼门至萨云若。乃至灭不灭。亦不作有常无常观。舍利弗。行般若波罗蜜菩萨当作是观。舍利弗问尊者须菩提。何以故。贤者作是言。五阴无所生为非五阴。乃至萨云若无所生为非萨云若。须菩提报言。五阴空空非五阴。是故五阴无所生为非五阴。六波罗蜜空。空亦非六波罗蜜亦非生是故六波罗蜜无所生为非六波罗蜜。从内外空至有无空亦复如是。从三十七品至佛十八法亦复如是。萨云若亦复尔。以是故五阴无所生为非五阴。五阴亦非生。乃至萨云若亦无所生。舍利弗问须菩提。何以故。言五阴不二为非五阴。乃至萨云若不二为非萨云若。须菩提报言。五阴不二亦不合亦不散。亦无有形不可见一相。一相者则无相。萨云若亦如是。以是故五阴无有二不为五阴。萨云若无有二不为萨云若。舍利弗问。何以故。五阴无有二为作数。乃至萨云若无有二为作数耶。须菩提言。无所生及五阴无有二。五阴则是无所生。无所生则是五阴。以是故五阴无有二为作数耳。乃至萨云若亦无有二为作数耳。须菩提白佛言。菩萨学般若波罗蜜观是法时。见五阴无所生常净故见吾我亦无所生常净故。见檀波罗蜜至般若波罗蜜亦无所生常净故。见内外空至有无空亦无所生常净故。见三十七品佛十八法亦无所生常净故。见诸陀邻尼三昧门亦无所生常净故。见萨云若无所从生常净故。见凡人凡人法亦无所生常净故。见须陀洹须陀洹法。斯陀含斯陀含法。阿那含阿那含法。阿罗汉阿罗汉法。辟支佛辟支佛法。见菩萨菩萨法。见佛佛法。皆无所生常净故。舍利弗问。如我从须菩提所闻。五阴为无所生。乃至道亦无所生。佛法亦无所生。亦无所逮得。须陀洹至阿罗汉。辟支佛亦复不逮。菩萨亦无所逮得。萨云若亦无所逮得。菩萨摩诃萨无所逮得。萨云若者。为坏五趣是为菩萨。不于五趣中得道。舍利弗言。若使诸法无所生。云何须陀洹三应灭而念成道。斯陀含三垢薄而念成道。阿那含五应灭而念成道。阿罗汉灭上五所得。辟支佛以因缘觉故而念成道。何以故。菩萨作勤苦行代众生受勤苦。为何等故如来无所著得等正觉转法轮乎。须菩提言。舍利弗。我亦不使无所生法有所逮得。我亦不使无所生得须陀洹道斯陀含阿那含阿罗汉辟支佛道。我亦不使菩萨有勤苦行。菩萨行亦无有勤苦想。舍利弗。菩萨亦不觉苦想。何以故。舍利弗。不可从觉苦想能为不可计阿僧祇众生作本。菩萨于众生如父想如母想如子想如身想无所有。菩萨于内外法当作是想当作是念。所言我及一切众生亦不有亦不可见。于内外法当作是念。作是想念不起勤苦想。何以故。一切无所有故。世尊。于无所生非我所。能令得如来阿惟三佛亦无所生。如来不从无所生逮转法轮。舍利弗问尊者须菩提言。欲使从无所生逮得。欲使从有所生逮得。须菩提言。我亦不使从无所生逮得。亦复不使从有所生逮得舍利弗言。如所言为无所逮无所得耶。须菩提言。有所逮有所得。不以二世俗之事有逮有得。但以世事故有须陀洹斯陀含阿那含阿罗汉辟支佛有佛。欲论最第一者。无有逮无有得。从须陀洹上至佛亦无逮亦无得。云何须菩提。但以世事故有逮有得。坏五趣者亦复如是耶。须菩提言。以世俗事故有逮有得。以世俗事故有五趣教。何以故。舍利弗。最第一法无有生死。无有善恶之报。亦无断亦无著。舍利弗言。云何须菩提。无所生有所生耶。有所生有所生乎。须菩提报言。我亦不使无所生有所生。亦不使有所生有所生也。舍利弗言。为欲使何所无所生法有所生。须菩提言。我不令五阴有无空有所生。乃至道有无空亦不令无所生。舍利弗言。不生为生耶。生为生乎。须菩提言。生亦不生。不生亦不生。何以故。诸可有所生无所生一耳。亦不别亦无形不可见不可得一相。一相者则无所有之貌。是故舍利弗。有所生亦不生。无所生亦不生。舍利弗言。当说无所生无所生法。说有所生无所生法。我乐欲闻。须菩提言。恣所乐。何以故。舍利弗。所可无所生法所可有所生法无所乐。所问无所生无所生。是诸法亦不合亦不散亦无形不可见不可得一相。一相者则无相。舍利弗言。所生亦复无所生。所乐亦复无所生。法亦无所生。所报亦复无所生。如是如是。舍利弗。诸法皆无所生。何以故。五阴无所生。六情亦无所生。六性地水火风空识是六性亦无所生。身口意行亦无所生。至萨云若亦无所生。是故舍利弗。所报亦无所生法。所因缘乐闻皆无所生。舍利弗言。如尊者须菩提。为是法师之上。何以故。随所问能发遣。何以故。于诸法无所依。舍利弗问长老须菩提。诸法云何无所依。答言。舍利弗。色性空亦不依内亦不依外亦不依两中间。痛想行识性空亦不依内亦不依外亦不依两中间。六情十二衰性空亦不依内外中间。六波罗蜜性空亦不依内外中间。从内外空至有无空性亦不依内外中间。三十七品至佛十八法性空亦不依内外中间。诸法性皆空者亦不依内外中间。舍利弗。是故无所依。是故行六波罗蜜菩萨。能净五阴至萨云若。舍利弗问须菩提。云何菩萨行六波罗蜜净菩萨道。答言。舍利弗。亦有道檀波罗蜜亦有俗檀波罗蜜。至般若波罗蜜亦有道亦有俗。复问。何等为俗檀波罗蜜。何等为道檀波罗蜜。答言。菩萨住于布施。若有沙门婆罗门。若有贫穷疾病形残。随其所索城国珍宝衣被饮食。妻子眷属。头目肌肉髓脑骨血。一切所有皆给与之。所可与者有所依倚。作是念言。我与彼受我不嫉他人与。言我是施主。言我与一切。言我随佛教。言我行檀波罗蜜。虽作是施与而有所倚所作。阿耨多罗三耶三菩与众生共之。以是施与欲令众生于无余泥洹而般泥洹。虽布施有三碍意。何等为三。有我想有彼想有施想。是为三碍。是为世俗布施。何以故。名为世俗布施。以不能离世俗亦不出世俗事故。是为世俗布施。何等为道施。以三事净。何等为三。菩萨布施亦不自见亦不见受者不望其报。是为菩萨于三事净。舍利弗。菩萨布施施与众生。亦不倚众生为阿耨多罗三耶三菩。亦不见有阿耨多罗三耶三菩之兆。是为道檀波罗蜜。何以故。名道檀波罗蜜。道檀波罗蜜者。胜出胜于世间故。从檀波罗蜜至般若波罗蜜。世俗有所依。道无所依。须菩提言。是为菩萨行六波罗蜜净菩萨道。舍利弗问须菩提。何等为菩萨摩诃萨道。答言。三十七品是菩萨摩诃萨道。空无相无愿三脱门。内外空乃至有无空。诸三昧门陀邻尼门。佛十种力四无所畏佛十八法。四无碍慧大慈大悲。是为菩萨摩诃萨道。舍利弗言。善哉善哉。须菩提。是为何等波罗蜜功德力。须菩提言。是般若波罗蜜功德力。何以故。般若波罗蜜者诸善法功德之母。般若波罗蜜者悉持三乘之法。诸过去佛世尊皆行般若波罗蜜。自致成阿惟三佛。当来诸佛世尊亦行般若波罗蜜。自致成阿惟三佛。现在十方恒边沙国诸佛世尊。亦行般若波罗蜜自致成阿惟三佛。须菩提言。若闻说般若波罗蜜不疑不惧。当知是菩萨能行菩萨道不舍众生。能为一切众生作护。亦无所猗终不离是念。所谓大慈大悲之念。舍利弗复问。欲使菩萨不舍大慈大悲之念。不离是者。以为一切众生。皆当为菩萨。何以故。一切众生终不离是念。须菩提赞言。善哉善哉。舍利弗。我已觉知所讥来迹。我当受之。如众生无所有念亦无所有。有无亦无所有。如众生寂念亦复寂。如众生空念亦复空。如众生无所觉念亦无所觉。如五阴无所有念亦无所有。如五阴无有实。如五阴空。如五阴寂。如五阴无所觉。当知念亦无所觉。眼耳鼻舌身意。色声香味细滑法。地水火风空识亦尔。六波罗蜜空。内外空至有无空。三十七品佛十八法。陀邻尼门诸三昧门。及萨云若萨云若事。乃至道与念等无所有。如道无所觉念亦无所觉。舍利弗。我欲使菩萨不离是行念。于是世尊赞叹须菩提言。善哉善哉。为诸菩萨摩诃萨说般若波罗蜜行。当如是如须菩提所言。如须菩提承佛威神说般若波罗蜜。菩萨摩诃萨亦当如是如须菩提所说。须菩提说是般若波罗蜜品时。三千大千刹土六反震动。前没后涌。前涌后没。八方上下皆悉如是。佛因是事便笑。时须菩提叉手白佛言。世尊。何因缘笑。佛告须菩提。今我说般若波罗蜜。东方恒边沙不可计诸佛。亦为诸菩萨说般若波罗蜜。十方诸如来等正觉无所著者。亦复为诸菩萨说般若波罗蜜亦复如是。须菩提。说是般若波罗蜜时。十二那术亿天及人阿须伦。皆得无所从生法忍。十方诸佛说般若波罗蜜时。不可计阿僧祇众生。皆发无上正真道意

放光般若波罗蜜经卷第五放光般若经卷第六

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜无住品第二十八

尔时三千大千刹土诸四天王与无央数亿百千诸天子皆来共会。诸释提桓因与诸无数亿百千诸天皆共来会。须炎天子上至首陀会天其中诸天各各与无数若干亿百千天子皆来共会。从四天王至首陀会天。诸天功德光明巍巍。虽尔不如世尊最下光明。百千万倍巨亿万倍。诸天光明及阎浮檀宝之光明悉不现也。诸天在佛边其形体光明如烧炷。是故诸天光明即不复现。释提桓因白尊者须菩提。今是三千大千刹土诸四天王诸首陀会天。欲听须菩提说般若波罗蜜教菩萨。云何住般若波罗蜜。何等为菩萨摩诃萨般若波罗蜜。当云何行般若波罗蜜。须菩提报释提桓因言。拘翼。今当承佛威神。为诸菩萨说般若波罗蜜。当为菩萨如所应住说。是诸天子未发意者今当应发菩萨心。已住于道捡者。力不堪发阿耨多罗三耶三菩意。何以故。为生死界作障隔故。假令是辈能发阿耨多罗三耶三菩意者。我亦代其欢喜从上转尊。我终不中道断其功德。拘翼。何等为般若波罗蜜。菩萨摩诃萨当持应萨云若意。当念色无常苦空非身。老病忧患恼结裁聚转变坏败恐畏斗讼不可恃怙。菩萨当念是亦无所倚。痛想行识六情六性。皆当念是苦。净亦无所倚。当念五阴净。当念六情六性净寂。以萨云若意当知从痴有爱习。十二因缘亦无所倚。当复念灭痴爱十二因缘得灭。众苦亦无所倚。复次拘翼。菩萨摩诃萨以萨云若意当念三十七品亦无所倚。亦当念乃至佛十八法亦无所倚。复次拘翼。菩萨摩诃萨以萨云若意。行檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜亦无所倚。如是拘翼。菩萨行般若波罗蜜作是观。使法法相续法法相得。皆使具足。菩萨于念亦无吾我。若作异念不应道念。拘翼。以不等念意。于道亦不可见亦不可得。道无意念意亦不可得亦不可见。拘翼。菩萨行般若波罗蜜。当作是观。于诸法无所得。释提桓因言。耆年须菩提。云何念意不与道意同。云何道意不与念意同。云何道意念意俱不可得不可得见。须菩提言。拘翼。所念意不成意。道意亦非意亦不成意不持非意。念非意意则是非意。非意亦是意。是为菩萨摩诃萨般若波罗蜜。于是佛叹须菩提言。善哉善哉。如汝为诸菩萨说般若波罗蜜教劝助之意。须菩提白佛言。唯世尊。我当报恩不得不报恩。我当报过去诸如来无所著等正觉恩。及弟子劝助安立诸菩萨等。世尊。尔时亦学六波罗蜜得阿惟三佛。世尊。我等亦当复劝助安立诸菩萨。学六波罗蜜亦当使成得阿惟三佛。须菩提言。拘翼。听我说菩萨摩诃萨住般若波罗蜜。如住亦不住。五阴五阴空。菩萨菩萨空。五阴空菩萨空一空无有二。拘翼。菩萨当作如是住般若波罗蜜。拘翼。六情六情空。菩萨菩萨空。六情空菩萨空等无有异。六性六性空。菩萨菩萨空。六性空菩萨空等无有异。菩萨摩诃萨当作如是于。般若波罗蜜当作是住。复次拘翼。十二因缘十二因缘空。灭十二因缘灭十二因缘空。菩萨菩萨空。十二因缘十二因缘灭空菩萨空一空无有二。拘翼。菩萨摩诃萨于般若波罗蜜当作是住。六波罗蜜六波罗蜜空。内外空及有无空。三十七品佛十八法诸三昧门陀邻尼门。声闻乘辟支佛乘亦尔。菩萨如来萨云若亦尔。菩萨空萨云若空一空无二。菩萨于般若波罗蜜当作是住。释提桓因言。云何须菩提。菩萨摩诃萨不于般若波罗蜜中住。须菩提言。拘翼。菩萨不住五阴有所倚。亦不住六情有所倚。不住于六情有所倚。从三十七品至萨云若皆不住有所倚。从须陀洹至阿罗汉辟支佛上至佛皆不住有所倚。从五阴至萨云若。是为不住亦无所倚。从须陀洹至佛亦不住有所倚。五阴无常不当于中住。五阴有常不当于中住。五阴苦乐不当于中住。净不净不当于中住。我非我不当于中住。空不空不当于中住。灭不灭不当于中住。寂不寂不当于中住有所倚。须陀洹不具足故不当于中住。至佛不具足故不当于中住。须陀洹成就德能福一切不当于中住。上至佛成就德能福一切不当于中住。复次拘翼。菩萨初地不当于中住。至第十地不当于中住有所倚也。从初地言我当具足檀波罗蜜不当于中住。于尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜不当于中住有所倚。我当具足成就三十七品不当于中住有所倚。菩萨道不当于中住。我从菩萨道至阿惟越致地住不当于中住。菩萨具足五通不当于中住有所倚住菩萨神通已言我当游无量阿僧祇佛国。见诸佛如来听受法教已。转复教授一切众生。亦不当于中住有所倚。言我亦当变化作如诸佛如来世界所有亦不当于中住有所倚也。般若波罗蜜不当于中住有所倚也。我当教授众生至道亦不当于中住。我当供养无央数阿僧祇诸佛时。诸幢幡香华缯盖无央数亿百千张叠不当于中住。我当成就无央数阿僧祇众生。令得阿耨多罗三耶三佛亦不当于中住。我当具足五眼肉眼天眼法眼慧眼佛眼亦不当于中住。我皆当起诸三昧亦不当于中住。亦不当愿言。我得是三昧时当于中游戏亦不当于中住。具足陀邻尼门不当于中住。我当具足四无碍慧四无所畏佛十种力佛十八法亦不当于中住。我当具足四等心大慈大悲亦不当于中住我当具足三十二大士之相八十种好不当于中住有所倚也。住八辈事成就信要法要不当于中住。须陀洹至第七不当于中住。斯陀含一种不当于中住。道等不当于中住。命终垢尽不当于中住。须陀洹中道般泥洹不当于中住。斯陀含未断诸苦本不当于中住。得阿那含道意不当于中住。于阿那含中中道般泥洹不当于中住。得阿罗汉证成阿罗汉。从是间于无余泥洹而般泥洹不当于中住。辟支佛不当于中住。过罗汉辟支佛至菩萨地不当于中住。道事慧不当于中住有所倚也。以众事成阿惟三佛不当于中住。从次诸垢消尽不当于中住。成如来等正觉无所著当转法轮不当于中住。我当为佛事度不可计一切众生不当于中住。以四神足于三昧住命恒边沙劫不当于中住。令我寿命无有数不当于中住。于三十二大士之相一相成百福功德不当于中住。使我一佛国大如十方恒边沙佛国不当于中住。使我三千大千刹土尽作金刚不当于中住。使我佛树中出香。一切众生闻其香者无有三毒。不起声闻辟支佛意。有闻是香者身病意病皆悉除愈令我佛土不闻五阴色痛想行识六波罗蜜之声不当于中住。令我佛国不闻三十七品及十八法。不闻须陀洹上至佛之声不当于中住。何以故。如来无所著等正觉成阿惟三佛。于诸法亦无所得。如是拘翼。菩萨于般若波罗蜜无所倚住。尔时尊者舍利弗意念。菩萨摩诃萨当云何住。须菩提知舍利弗意所念。便问舍利弗。于意云何。诸佛为住何所。舍利弗报言。诸佛无所住。不住意有所止。亦不于五阴住。亦不住于成就。亦不住于不成就。亦不住于有为无为。不于十八法萨云若有所住。须菩提言。菩萨摩诃萨住般若波罗蜜中。当如诸如来无所著等正觉住如不住。菩萨当作是住。住无处所住。于是会中有天子作是念。诸阅叉所语所说悉皆可知。尊者须菩提所说般若波罗蜜教了不可知。须菩提。知诸天子意所念。语诸天子言。不解不知耶。诸天子言尔须菩提。实不解不知也。须菩提语诸天子言。我所说者常不见一字教亦无听者。何以故。般若波罗蜜者非文字亦无听闻。何以故。诸天子。诸如来无所著等正觉道亦无文字。诸天子。譬如如来化作佛作四辈弟子。作是化已。为说化诸法。于诸天子意云何。是颇有教有说宁有受者不。诸天子言。唯须菩提。是无所有。须菩提言。诸法譬如化。亦无所说者。亦无受者。亦无知者。譬如士夫梦中见佛。佛为说法。于意云何。有说有受者不。诸天子言。无说无受。须菩提言。诸法如幻无说无受亦无所有。譬如有二人于彼深涧各住一面。俱发音声赞叹佛法及比丘僧。其声音响宁展转相知不。诸天子言。响无所知。譬如绝工幻师于四衢道化作如来及四辈众而说于法。诸天子。于意云何宁有说有教有受者不。诸天子报言。实无所有。诸天子复念。今须菩提敷演般若波罗蜜。其事甚深。所教转深。所说转妙。须菩提语诸天子言。色亦不深亦不微妙。不以五阴故微妙也。六情从内外空及有无空。乃至六波罗蜜佛十八法皆如是。诸三昧门陀邻尼门至萨云若。亦不深亦不妙。不以萨云若故深妙。诸天子意念。是中所说亦不说五阴六情。亦不说六波罗蜜。亦不说内外空及有无空。亦不说三十七品佛十八法。亦不说须陀洹道。亦不说阿罗汉辟支佛道。亦不说文字。是事云何。须菩提报言。如是如是。诸天子诸如来道者皆无所得亦无所说。是故诸法亦无说者亦无闻者。亦无受者亦无得者。须菩提言。诸天子。欲住须陀洹道者。取须陀洹证者。若住罗汉辟支佛上至佛欲取证者。作是住者。终不得是忍。菩萨从初发意以来。无所说无所闻当作是住

    摩诃般若波罗蜜如幻品第二十九

尔时诸天子意念。我等当云何从须菩提听受其教。尊者须菩提知诸天子意所念。语诸天子言。今诸会者观听我所说当如幻化人。所听受亦无所受。亦无所见亦不作证。诸天子言。云何须菩提众生为如幻化耶。来会者亦如幻化耶。须菩提言。如是如是。众生如幻。会者亦如幻。吾我亦复如幻如梦。五阴如幻如化。六情识栽如幻如化。内外空及有无空如幻如梦。三十七品佛十八法如幻如化。须陀洹道上至于佛三耶三佛亦复如幻。尔时诸天子问须菩提。云何乃至佛亦复如幻如梦。须菩提言。我说至佛亦复如幻。若复有法胜于泥洹者我亦复言如幻。诸天子梦幻化是一取无有二。是时舍利弗。大目揵连。摩诃拘絺罗。摩诃迦旃延。邠耨文陀尼子。大迦叶等。与无央数菩萨。是诸大众。俱问须菩提言。般若波罗蜜甚深甚广。难晓难了难见难解。谁能遏绝是者。是时阿难语众弟子诸菩萨言。般若波罗蜜者是深妙法。甚广难见难解难了不可思议。唯有阿惟越致菩萨摩诃萨。具足见谛阿罗汉。前世于无央数诸佛所而作功德与善知识相随者。善男子善女人有大智慧。如是辈人闻深般若波罗蜜乃能信乐终不能遏绝。不以空分别五阴。不以五阴分别空。亦不以五阴分别无相无愿。不以无相无愿分别五阴。亦不以无所生无所灭分别五阴。不以五阴分别无所生无所灭。亦不以寂净分别五阴。亦不以五阴分别寂净。乃至六情及诸缘起亦复如是。从檀波罗蜜至般若波罗蜜亦复如是。从内外空至有无空亦复如是。从三十七品至佛十八法亦复如是。诸三昧门陀邻尼门不以分别五阴。不以五阴分别三昧门陀邻尼门。从须陀洹至罗汉辟支佛乃至萨云若亦不以分别空。不以空分别萨云若。亦不以无相无愿分别萨云若。亦不以萨云若分别无相无愿。不以具足不具足性分别空。不以空分别具足不具足性。至无相无愿亦复如是。不以无所生无所灭分别寂净。不以寂净分别五阴。须菩提语诸天子言。是甚深般若波罗蜜。极有智者不能遏绝。何以故法无有忧者亦无有戚者。若无忧无戚众生亦无能遏绝者。舍利弗语须菩提言。般若波罗蜜为广说三乘之教及菩萨总持之教。从初发意至十住道地教。至六波罗蜜三十七品佛十八法。菩萨摩诃萨悉总持之教。是为菩萨行般若波罗蜜化生也。不耗于神通游诸佛国。随其所欲所作善本供养诸佛即得如愿。从诸世尊所听受法。至萨云若初不断绝。未曾离三昧时当为无所挂碍辩。不可断绝辩。如所应辩利辩义辩一切最辩。须菩提言。如是如是。如舍利弗言。广说三乘及菩萨乘。大乘菩萨摩诃萨所得最辩。亦无所倚亦不倚。吾我知见寿命五阴亦无所倚。从檀波罗蜜至般若波罗蜜亦无所倚。从内外空及有无空亦无所倚。从三十七品佛十八法至萨云若慧亦无所倚。舍利弗言。何以故。于般若波罗蜜说三乘之教而无所倚。何以故。说菩萨总持。何以故。得最妙之辩而无所倚。须菩提言。从内空乃至三乘。皆从般若波罗蜜教出亦无所倚。从外空至有无空。广说三乘之教亦无所倚。从内外空所说教及菩萨。总说一切世间最妙之辩亦无所倚。从有无空至菩萨。护一切世间最第一之辩而无所倚也

    摩诃般若波罗蜜雨法雨品第三十

于是释提桓因意念言。尊者须菩提所说法为雨法雨三千大千刹土。从四天王上至阿迦腻吒天各各念言。今须菩提所说法雨。我等宁可作花散佛世尊及诸菩萨大弟子众。及散须菩提上。尔时三千大千刹土诸释提桓因及诸四天王各化作花。散佛菩萨及比丘僧。及散须菩提上。持是供养般若波罗蜜。诸天散花。应时普遍三千大千国土地无空缺处。譬如敷坐也。虚空中花未堕地者。应时化成花交露台殊妙严事。时须菩提意念我数至天上初未曾所见如是花比。是诸天子所散花者。不从树生化花耳。释提桓因语须菩提。是花非生花亦非意树花。须菩提言。如拘翼所言。是花亦非生花亦非意树花。拘翼。若不生者是为非花。释提桓因语须菩提。但是花不生耶。五阴亦不复生耶。须菩提言。是花及五阴俱亦无所生。若使不生为非五阴。六情亦无所生。若使不生为非六情。六波罗蜜亦无所生。若使不生为非六波罗蜜。从内外空至有无空亦不生。若不生者为非有无空。三十七品佛十八法亦不生。若不生者为非十八法。至萨云若亦不生。若不生者为非萨云若。释提桓因意念言。今须菩提辩才深妙乃如是耶。随其所应如为说法而无违背。佛告释提桓因。如是如是。拘翼。须菩提实为深入辩才第一。随所应而为说法无有违错。释提桓因白佛言。唯世尊。云何须菩提随其所应而为说法而不违错。佛告拘翼。五阴六情但有数耳。以五阴六情但有数故。是故须菩提所说无错。何以故。如法者亦不违错亦不和合。以无和无错。是故须菩提所说无错。至六波罗蜜及内外空至有无空。三十七品佛十八法皆如是。从须陀洹道至辟支佛道至萨云若萨云若事亦如是。从须陀洹罗汉辟支佛上至佛三耶三佛。拘翼。亦复是法数所施耳。须菩提所说亦复如法数所施。是故所说无有违背。何以故。拘翼。如法者亦不和亦不错。以不和以不错故。须菩提作是说法。随其所应无有违错。须菩提言。如是如是。拘翼。如佛世尊施诸法教。菩萨摩诃萨行般若波罗蜜当知诸法亦复但是法数所施。拘翼。菩萨作是学者为不学色痛想行识。亦不见五阴当所学者。如是学者为不学六波罗蜜。何以故。不见六波罗蜜当所学者。如是学者不学内外空及有无空。何以故。不见空法有所学者。如是学者为不学三十七品佛十八法不学须陀洹道。不学罗汉辟支佛道。不学萨云若道。何以故。不见萨云若当所学者。释提桓因白须菩提言。何以故。不见五阴。至萨云若亦不见耶。须菩提言。是故拘翼。五阴五阴自空。萨云若萨云若自空。何以故。不可空色而学色空。不可以萨云若空学空萨云若。不作空学为学空。不以二学如是学。不以二事学五阴空。亦不以二事学萨云若空。拘翼。不以二事学空五阴者为学六波罗蜜。不以二事学萨云若空者为学六波罗蜜。为学内外空至有无空。为学三十七品。为学佛十八法。不以二事学为学须陀洹至罗汉辟支佛。不以二事学为学三耶三佛。亦不以二事学为学萨云若学佛。学萨云若者为学不可计阿僧祇诸佛法。学诸佛法者不学增五阴不学减五阴。亦不增萨云若学亦不减萨云若学。如是不增不减学者。亦不受五阴亦不中道灭五阴。学至萨云若亦不受学。亦不中道灭萨云若。舍利弗语须菩提。菩萨作是学亦不受萨云若学。亦不中道灭萨云若学耶。须菩提报言。如是如是。舍利弗复问。何以故。从五阴至萨云若亦不受学。亦不中道灭萨云若学报言。色自无受。亦无有受色者。萨云若亦自无受。亦无受萨云若者。从内外空至有无空亦自不受。亦无受空者。如是舍利弗。菩萨摩诃萨于诸法无所受。是故于萨云若中出生。舍利弗言。菩萨学般若波罗蜜。于诸法无所受。为出生萨云若耶。须菩提言。如是如是。舍利弗复问。菩萨作如是学。于诸法无所受。亦不学受亦不学灭。云何出生萨云若。须菩提报言。菩萨行般若波罗蜜。亦不见色生亦不见色灭。亦不受亦不不受。亦不着亦不断。亦不增亦不减。何以故。舍利弗。不以五阴故有。亦不见生亦不见灭。亦不见受亦不见不受。亦不见着亦不见断。亦不见增亦不见减。何以故。舍利弗。不见五阴有乃至萨云若。亦不见生灭亦不见受。亦不见着断。亦不见增减。何以故。萨云若空故无所得。是故菩萨于诸法无所生无所灭。无所受无著无断无增无减。学般若波罗蜜出萨云若。当作是念。亦无所学亦无所出。释提桓因问舍利弗。菩萨当从何所求般若波罗蜜。舍利弗报言。拘翼。菩萨摩诃萨当从须菩提所转品中求。释提桓因言。以须菩提因缘恩力。使舍利弗言菩萨摩诃萨般若波罗蜜。当于须菩提所转品中求。须菩提报言。拘翼。非我因缘恩力。释提桓因言。是谁之恩力所处。须菩提言。是佛威神恩力所处。释提桓因言。诸法皆无处所。云何言是佛之威神所处乎。如来亦不于异无处所法中见佛。亦不于异如中见。须菩提言。如是拘翼。如来亦不于余处中见。亦不于异处如中见。亦不以如来为如亦不以如为如来。亦不以五阴如为如来。亦不以如来为五阴如。亦不以五阴法为如来。亦不以如来为五阴法。亦不以萨云若如为如来。亦不以如来为萨云若如。亦不以萨云若法为如来。亦不以如来为萨云若法。拘翼。若佛与五阴法不合亦非不合者。亦不离五阴法有合不合。亦不离五阴如有合不合。乃至萨云若萨云若法。如亦不合亦不不合。亦不离萨云若萨云若法如亦不合亦不不合。拘翼。以是诸法不合不散神力之所处。是为无处所行。如拘翼向之所问。当于何所求般若波罗蜜。亦不于五阴中求亦不离五阴中求。何以故。拘翼。般若波罗蜜五阴是法亦不同亦不异。亦无有形亦不可见。亦无有碍一相。一相者则无相。复次拘翼。菩萨摩诃萨求般若波罗蜜。亦不离萨云若求。亦不于萨云若求。何以故。般若波罗蜜萨云若及所求者。亦不同亦不异亦无形亦不见。亦不碍一相。一相所谓无相。何以故。般若波罗蜜亦非五阴亦不离五阴。般若波罗蜜亦非萨云若亦不离萨云若。五阴如亦非般若波罗蜜。般若波罗蜜亦不离五阴如。般若波罗蜜亦非五阴法亦不离五阴法。般若波罗蜜亦非萨云若法亦不离萨云若法。何以故。拘翼。是诸法亦不有亦不可得。以诸法不可得故。五阴非般若波罗蜜。般若波罗蜜亦不离五阴。般若波罗蜜亦非五阴法亦不离五阴法。般若波罗蜜亦非五阴如亦不离五阴如。般若波罗蜜亦非萨云若亦不离萨云若。亦非萨云若如亦不离萨云若如。亦非萨云若法亦不离萨云若法。释提桓因言。摩诃波罗蜜是菩萨摩诃萨之大度。波罗蜜者。是诸菩萨无量无限之大度。于是中学得须陀洹。斯陀含。阿那含。阿罗汉。辟支佛。于中学成菩萨净佛国土教化众生。成得阿耨多罗三耶三佛。须菩提言。拘翼。如是如是。如释提桓因所言无异。已得者甫当得者。皆当从般若波罗蜜中成阿惟三佛。以五阴大故。般若波罗蜜亦广大。拘翼。五阴亦无前亦无后。亦无中亦无边际。至萨云若亦如是。拘翼。是为菩萨摩诃萨之大度。以五阴无有量。是故菩萨摩诃萨无量之度。何以故。五阴不可量故。譬如虚空不可度量。五阴亦不可度量。如空不可度量。五阴亦不可度量。以五阴不可度量。般若波罗蜜亦不可量。乃至萨云若不可量故。菩萨之度般若波罗蜜亦不可量。何以故。拘翼。萨云若亦不可量。如虚空不可平量。以萨云若不可平量。虚空不可平量。以虚空不可平量。般若波罗蜜亦不可平量。以是故。拘翼。菩萨摩诃萨般若波罗蜜不可平量。空亦不可平量。以五阴无底菩萨般若波罗蜜亦无底。何以故。五阴底边际不可得见故。乃至萨云若亦无有底。菩萨般若波罗蜜亦无有底。何以故。拘翼。萨云若亦不可得底亦不可得边际故。是故菩萨般若波罗蜜无有底。从五阴无有底。至萨云若亦无有底。复次拘翼。以因缘无有底故。菩萨般若波罗蜜亦无有底。释提桓因言。唯须菩提。云何因缘无底菩萨般若波罗蜜无底。报言。以萨云若因缘无底故。菩萨般若波罗蜜无底。法因缘无底。是故菩萨般若波罗蜜无底。又问。云何法因缘无底。菩萨般若波罗蜜无底。报言。拘翼。法性无底故菩萨般若波罗蜜无底。如因缘无底菩萨般若波罗蜜无底。复问。云何如因缘无底菩萨般若波罗蜜无底。答言。如如无底如因缘无底。以如因缘无底。菩萨般若波罗蜜无底。众生无底菩萨般若波罗蜜无底。复问云何众生无底菩萨般若波罗蜜无底。答言。于拘翼意云何。何所法言有菩萨者。亦不以法言亦不非法言。但假名举字耳。是名所举亦无有形所举名字亦无因缘。所举字及众生亦无因缘。于拘翼意云何。般若波罗蜜颇说有作众生者不。唯须菩提无有也。拘翼。若无有说作众生者何所众生有底。拘翼。如来无所著等正觉。住寿如恒边沙劫。言众生有生众生有灭。于拘翼意云何。颇有众生有生者有灭者不。答言。不也。须菩提。何以故。众生净故无所有净故。以是故。拘翼。当知众生无底。般若波罗蜜亦无有底。亦无有边际

    摩诃般若波罗蜜叹品第三十一

尔时诸梵王与诸梵天俱在会中。释提桓因与释眷属及婇女众亦在会中。释梵诸天子各各叹言。须菩提所说法快哉快哉。皆是佛之威神因缘能演布是教。若有不远离是般若波罗蜜行者。我等当视是辈菩萨摩诃萨当如如来。亦无有能得见是法者。亦无有能见色痛想行识者。至萨云若三乘教处罗汉辟支佛。及佛亦不可得。佛告诸天子。如是如是。如诸天子所言。法无可得者亦不可见。从色痛想行识至萨云若。皆不可得亦不可见。但有三乘之教耳。三乘之教亦不可得亦不可见。有行是般若波罗蜜无所猗者。当视如如来。何以故。于般若波罗蜜中广说三乘之教故。亦不离六波罗蜜而得佛者。亦不离内外空及有无空。亦不离三十七品佛十八法。亦不离萨云若而得佛者。诸天子。菩萨尽当学知诸法。从檀波罗蜜至萨云若。以是故。当知是菩萨为如如来。佛告诸天子。昔者我于花严国从提和竭佛以来。初不离六波罗蜜。内外空至有无空。三十七品四禅四等。及四空净诸三昧门陀邻尼门。佛十种力四无所畏四无碍慧大慈大悲佛十八法。余无央数诸佛上法。初不离此诸法亦无所倚。是时提和竭佛使记我言。后阿僧祇劫当来之世。汝当作佛号释迦文如来无所著等正觉无上士道法御天人师。于是诸天子白佛言。唯世尊。甚奇甚特。菩萨摩诃萨行般若波罗蜜。于萨云若无取无舍。于五阴法亦无所取亦无所舍。时佛于四辈弟子中。比丘比丘尼优婆塞优婆夷。诸菩萨摩诃萨。诸四天王上至阿迦腻吒诸天等。见诸众已定。佛告释提桓因。拘翼。若有菩萨摩诃萨。比丘比丘尼优婆塞优婆夷及诸天天女。受持般若波罗蜜者讽诵读者。复布现与人使讽诵习念。不离萨云若意者。魔及魔天子不能得其便。何以故。是善男子善女人。住五阴空无相无愿行故。无有能得空无相无愿便者。乃至萨云若空行。亦无能得萨云若空便者。不见是事可得便者。拘翼。是善男子善女人非人不能得其便。何以故。是善男子善女人有大慈大悲。以四等心加众生故。拘翼。是善男子善女人。随其寿命终不中错。何以故尔。用是善男子善女人行檀波罗蜜时。等为一切众生故。以是故。寿命不错。拘翼。是三千大千国土。诸四天王忉利天炎天兜术天尼摩罗天波罗尼蜜天梵天阿波会天首诃既那天惟于颇罗天。是诸天人发至阿耨多罗三耶三菩意者。是诸天子所未闻般若波罗蜜者。未讽诵读持者。是诸天子皆当习行般若波罗蜜讽诵读持。意常不离于萨云若者。拘翼。是善男子善女人行般若波罗蜜。若有受持讽诵读说。习念守行不离萨云若意者。是善男子善女人。若远出空寂处若露坐若在家。终不恐终不怖。何以故尔。用是善男子善女人明于内外空及有无空故亦无所倚。尔时三千大千国土。诸四天王上至首陀会天俱白佛言。唯世尊。我等当护是善男子善女人行般若波罗蜜讽诵读说习守持者。我当拥护使不离萨云若。何以故。以菩萨来往因缘断三恶趣断天人贫。断人中贫断是辈灾变。断诸饥饿谷贵。以菩萨摩诃萨来往因缘故。以十善之事现于世间。便知有四禅四等四空定六波罗蜜。从内外空至有无空。便知有三十七品佛十八法至萨云若。以菩萨来往因缘故。世间便知有刹利长者种。便知有婆罗门大姓种。便知有转轮圣王。便知有四天王上至阿迦腻吒天。菩萨来往因缘故。便知有须陀洹斯陀含阿那含阿罗汉辟支佛道。便知有教授众生。便知有净佛国土。以菩萨来往因缘故。便知有佛世尊如来无所著等正觉。便知有转法轮。便知有三宝。以是故。诸天阿须伦诸世间人。皆拥护是菩萨摩诃萨。佛告释提桓因。如是拘翼。用菩萨来往因缘故。三恶趣断佛三宝兴。以是故。诸天世人皆当共恭敬承事是菩萨摩诃萨。给其所当常拥护之。拘翼。供养承事是菩萨摩诃萨。当如恭敬承事供养我。当作是知。如供养如来无异。是故拘翼。诸天世间人当作是恭敬之。拘翼使。三千大千国土满中甘蔗竹苇稻麻丛林。皆为声闻辟支佛。其数如是。若有善男子善女人悉供养承事给其所当。不如是善男子善女人供养承事。发意行六波罗蜜菩萨者。何以故。拘翼。不以有罗汉辟支佛故。知有菩萨如来无所著等正觉。以有菩萨因缘故。乃知有罗汉辟支佛三耶三佛。是故拘翼。诸天世人当恭敬承事是菩萨摩诃萨。当拥护之

    摩诃般若波罗蜜降众生品第三十二

尔时释提桓因白佛言。唯世尊。甚奇甚特。受持般若波罗蜜讽诵习读守行念者。为得现世功德教授众生。净诸佛国从一佛刹至一佛刹。见诸佛已意欲供养。随其所愿辄得供养。具足善本所从诸佛闻经法者。至得三耶三佛初不中忘。便得家成就。得父母成就得生成就。得眷属成就。得相成就得光明成就。得眼成就得耳成就。得三昧成就得陀罗尼成就。以沤和拘舍罗变身。如佛从一国至一国。至无佛处到已便称叹六波罗蜜之功德。称叹内外空及有无空。四禅四等及四空净。皆称叹是之功德。又复称叹三十七品佛十八法之功德。以沤和拘舍罗为众生说法。以三乘降众生。释提桓因白佛言。快哉世尊。甚奇甚特。云何持般若波罗蜜总持五波罗蜜。亦复总持三十七品至佛十八法。亦复总持至声闻辟支佛法。亦复总持萨云若萨云若事。佛告释提桓因。如是拘翼。持般若波罗蜜者。为已总持诸波罗蜜已。为已总持三十七品佛十八法。声闻辟支佛法萨云若事悉总持已。复次拘翼。持般若波罗蜜者执者读者念者。诸所可得功德之应。且听谛听。是善男子善女人。所得功德今为汝说之。释提桓因言。唯世尊。愿乐欲闻。佛言。若有异学外道若魔及其部界项佷之人。念欲破坏者念欲乖错者。诸持恶意欲来坏者。皆不从愿便中道灭去。何以故。拘翼。是菩萨摩诃萨长夜行六波罗蜜。以众生贪诤于财故。菩萨悉弃舍内外所有法。安立众生故行檀波罗蜜。以诸众生行恶戒者故。菩萨弃舍内外法。安立众生于尸波罗蜜。以众生长夜有斗讼怨恚故。菩萨弃舍内外法。安立众生于羼波罗蜜。以众生懈怠故。菩萨弃舍内外法。安立众生行于惟逮波罗蜜。以众生常乱意故。菩萨弃舍内外法。安立众生使行禅波罗蜜。以众生耽于恶智故。菩萨弃舍内外法。安立众生使行般若波罗蜜。以众生住于生死恩爱故。是故菩萨波罗蜜沤和拘舍罗。于恩爱中拔擢于生死。安立于四禅四等四空定三十七品空无相无愿。劝助安立劝立众生。得须陀洹至阿罗汉。劝立众生得辟支佛。劝立众生使行菩萨得佛。拘翼。行菩萨之行。是为得现世奇特之德。后世便使得阿耨多罗三耶三菩阿惟三佛。便转法轮随众生所应而度脱之。是为菩萨后世奇异之德。复次拘翼。善男子善女人受持般若波罗蜜者。若讽诵读习守行般若波罗蜜者。其地处魔及魔天异学外道项佷之人。若欲坏乱者若欲中道断者。若有斗讼持恶意向者。终不得发是意。是菩萨其行功德。转更高显殊异无能逮者。以般若波罗蜜音声故。出生三乘而得度脱。譬如拘翼有药名摩只。有蛇蚖饥行求索虫欲食之。虫遥见蛇蚖走趣药所。蛇欲得往。以药气故不能得前。何以故。以药威德故。使蛇中道还拘翼。是摩只药威德乃尔。若有善男子善女人。行般若波罗蜜。若讽诵读习持守者。有欲乱者若欲断坏斗诤向者。以般若波罗蜜威德之力故。随其所趣处令于彼间便自灭去。何以故尔。般若波罗蜜者是诸法之定也。非诸法之诤。何等诸法。谓淫怒痴从无黠十二因缘。意有所著有我见有人见。有众生见有尽见。有常见无垢见。无有见众邪见。嫉恶戒见嗔恚见。懈怠乱意恶智常见。有乐想净想我想恩爱行。受色痛想行识。受六波罗蜜。受内外空。受有无空。受三十七品。受十八法。受萨云若。受于泥洹增益五根。是为诸法之空。三千大千刹土。诸四天王诸释提桓因及诸梵天。乃至阿迦腻吒天。是诸天人皆拥护是善男子善女人。行般若波罗蜜者。讽诵读说习持守者。十方诸现在佛皆共拥护是善男子善女人行般若波罗蜜者讽诵读说习持守者。诸恶悉消诸善增益。于六波罗蜜转复增益亦无所倚。于内外空亦复增益而无所倚。于三十七品佛十八法诸三昧门陀邻尼门萨云若慧悉转增益而无所倚。所言说者人皆信用。与诸众生共作朋友所语无失。终无嗔恚终不自用。亦不嫉妒。自不杀生教人行慈。为众生称叹不杀之德。常复赞叹诸不杀者。常自远离于不与取。教人不盗。常复称叹不盗之德。自行清净教人不淫。亦复称叹不淫之德。身自远离妄语粗言恶口绮语。亦常远离嫉恚邪见。教人正见。亦复赞叹正见之德。自行六波罗蜜。常劝助人行六波罗蜜。常复称说行六波罗蜜之大功德。自行内外空。劝人行空。亦复赞叹行空之德。有无空亦复如是。自行陀邻尼诸三昧门。教人行持学诸三昧。叹说总持三昧之德。自行四禅教人行禅。称说行禅定意之德。自行四等。教人行四等。亦复称说慈悲功德。自行四无形定。教人行之。称誉无形定功德。自行根力三十七品。教人使行。亦复称誉道品功德。自行三三昧八惟无禅九次第禅。如来十力四无所畏四无碍慧。大慈大悲佛十八法萨云若慧。教人行萨云若。赞叹称誉萨云若之功德。常行六波罗蜜。所可布施皆与众生。共为阿耨多罗三耶三菩亦无所倚。所作布施持戒精进忍辱一心智慧。但为一切众生之类。令得度脱阿耨多罗三耶三菩亦无所倚。善男子善女人。作如是行于六波罗蜜生念言。若我不布施者或生贫贱家。便不能得教授众生。亦不能得净佛国土。亦复不能得萨云若。我若不持戒者或生三恶趣不得人身。便不得教授众生净佛国土。亦不得萨云若。我若不行忍辱者。便毁坏诸根。亦不能得覆面舌相。形不成就。不得菩萨具足行身。教授众生净佛国土。亦不能得成萨云若。我不精进有懈怠者。或生恶处身不明了。亦复不能教授众生净佛国土成萨云若。若我不行禅意不定者。亦不能得诸三昧慧。教授众生净佛国土成萨云若。若我行恶智者。便不能得沤和拘舍罗。度罗汉辟支佛地。亦不能教授众生及净佛土成萨云若。善男子善女人当作是念。我不可随贪嫉之心而不具足行檀波罗蜜。我不可随恶戒故。而不具足行尸波罗蜜。我不可以嗔恚故。不具足行羼波罗蜜。我不可以懈怠故。不具足行惟逮波罗蜜。我不可以乱意故。不具足行禅波罗蜜。我不可从恶智故。不具足行般若波罗蜜。我不具足行六波罗蜜者终不生萨云若。是善男子善女人。受持讽诵守行般若波罗蜜者。当得现世后世功德意。终不离萨云若意。释提桓因白佛言。唯世尊。甚奇甚特。快哉般若波罗蜜者。是菩萨摩诃萨之所施为将导乃尔。佛言。拘翼。云何般若波罗蜜为菩萨摩诃萨作施为将导。释提桓因白佛言。诸所世俗布施。不以沤和拘舍罗。若与佛及声闻辟支佛及与贫穷乞丐者。无沤和拘舍罗者便堕贡高。言我具足行檀尸波罗蜜羼惟波罗蜜禅波罗蜜。言我具足。逮行般若波罗蜜。于世俗波罗蜜中便堕贡高。言我具足三十七品行三三昧。言我具足行陀邻尼诸三昧门。言我具足于十种力佛十八法。我当教授众生净佛国土。言我当得萨云若慧。以入吾我贡高者是为世俗般若波罗蜜。菩萨行是世俗法者。便入吾我贡高。菩萨摩诃萨行道檀波罗蜜者。亦无吾我想亦无施想亦无物想亦无受施者想。是为行般若波罗蜜菩萨摩诃萨之施为将导。菩萨行戒不有尸波罗蜜。行于忍辱亦不有羼。行于精进亦不有惟逮。行于定意亦不有禅波罗蜜。行大智者不有般若波罗蜜。行三十七品乃至佛十八法亦无所有亦无所倚。行大慈大悲行萨云若者。亦无所有亦无所猗。世尊。是为行般若波罗蜜菩萨之施为将导

放光般若经卷第六放光般若经卷第七

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜守行品第三十三

佛告释提桓因。若有善男子善女人。受是深般若波罗蜜。讽诵读持习行守者。拘翼。是善男子。若入斗战中终不中道损其寿命。若刀矛箭终不中其身。所以者何。是善男子长夜行六波罗蜜。已自降伏淫欲之剑恚痴之刺。复为他人降淫怒痴。已自降伏邪见剑刺。复为他人降邪见剑。又自降伏习绪剑刺及恩爱刺。复能为他人降伏习绪恩爱之剑。拘翼。用是故。善男子善女人。不为矛剑刀箭所中。复次拘翼。善男子善女人。受持讽诵守行般若波罗蜜。不远离萨云若意者。终不中毒终不中蛊终不中兵终不中水终不中火。众恶之事终不得忓。何以故。拘翼。是般若波罗蜜者无上之术。善男子善女人学是术者。亦不自念恶亦不念他人恶亦不念两恶。何以故。亦不自有亦不有彼。亦不有知见亦不有五阴。上至萨云若亦无所有亦无所得。无所有者亦不自念恶亦不念他人恶亦不念两恶。至得阿耨多罗三耶三佛观众生之意。何以故。学是术故。过去当来今现在诸如来无所著等正觉。悉从是术中自致得阿惟三佛。复次拘翼若有善男子善女人。学是般若波罗蜜者已书持者。若人若非人终不能得其便。所以者何。三千大千国土。及十方无央数阿僧祇诸国土中。诸四天王上至阿迦腻吒诸天。皆共拥护是善男子善女人。书持般若波罗蜜者。供养尊敬共礼事之。书持是者其德如是。若有但书持般若波罗蜜。不讽诵读亦不守行者。其处譬如道场坐四面左右。中有畜生若人其外若有人非人欲来害者终不能得其便。何以故。过去诸如来无所著等正觉皆于中得佛故。当来现在诸如来无所著等正觉。皆亦当于中得佛故。得佛道已使一切众生无恐无畏。已无恐无畏皆受天上人中之福。安立于三乘而度脱之。何以故。拘翼。是般若波罗蜜譬如道场之地为一切作护。应当作礼供养名花捣香泽香杂香缯彩花盖幢幡伎乐。释提桓因白佛言。世尊。若有善男子善女人。书般若波罗蜜已持经卷供养名花捣香泽香杂香缯彩花盖幢幡伎乐。作是供养。若世尊般泥洹后取舍利作是供养。名花捣香泽香杂香缯彩花盖幢幡伎乐。如是供养其福何所多者。佛告释提桓因。拘翼。我今问汝。随所问说之。于意云何。如来无所著等正觉成萨云若。得此相好。从何所学得。释提桓因白佛言。世尊。我闻如来无所著等正觉逮萨云若成相好。从般若波罗蜜中学得。佛言。如是如是。拘翼。不以是身数故名为如来。逮得萨云若慧故成为如来。是萨云若者从般若波罗蜜中出生。如是拘翼。如来所有身者是萨云若慧之屋室。如来因是室逮得萨云若。是故名为萨云若慧之室。我般泥洹以后舍利供养如是若善男子善女人书般若波罗蜜讽诵读说习持守行。供养经卷名花捣香泽香杂香缯彩花盖幢幡伎乐。恭敬作礼作是供养者为供养萨云若已。如是拘翼。是故善男子善女人。受持般若波罗蜜讽诵读说。当守习行当供养经卷名花捣香泽香杂香缯彩花盖幢幡伎乐。当恭敬作礼。若般泥洹后供养舍利安处竖立塔。名花捣香泽香杂香缯彩华盖幢幡伎乐。若有善男子善女人。书持般若波罗蜜。讽诵念守承事供养。名花捣香泽香杂香缯彩花盖幢幡伎乐作是供养。其福多于供养舍利。何以故。于是中出生舍利。内外空及有无空三十七品佛十八法皆从是中出生。诸三昧门陀邻尼门皆从是中出生。教化众生净佛国土亦从其中出生。菩萨摩诃萨居家成就色像成就。财成就眷属成就。大慈大悲皆从中出生。刹利种婆罗门种大姓长者种。四天王上至阿迦腻吒天皆从其中出生。从须陀洹至罗汉辟支佛菩萨佛三耶三佛。及萨云若皆从中出生。尔时释提桓因白佛言是阎浮提人不供养承事恭敬般若波罗蜜者。是曹之人为不知其尊当所供养。佛告释提桓因言。拘翼。于意云何。知阎浮提中有几所人。信佛信法信比丘僧者。有几所人狐疑于三尊者。有几所人恭敬三尊者。释提桓因白佛言。世尊。有信依佛依法依比丘僧者少少耳。佛言于拘翼意云何。阎浮提中有几所众生。应得三十七品三脱门八惟无九次第禅六通四等。及四空定四无碍慧。阎浮提中有几所众生。灭三疑应须陀洹者。几所众生三垢薄应斯陀含者。几所众生五疑断应阿那含者。几所众生上五处毕为阿罗汉者。有几所众生发生辟支佛道者。几所众生发阿耨多罗三耶三菩意者。释提桓因白佛言。世尊。少所众生应得三十七品。及三耶三佛者少少耳。佛告释提桓因言。如是拘翼。众生甚多有发道意者少少耳。何以故以前世时不见佛不闻法不识比丘僧之所致。不布施不持戒不护戒不忍辱不精进不闻有禅不闻般若波罗蜜。亦不闻内外空及有无空。亦不闻三十七品佛十八法。亦不闻亦不念。亦不闻有三昧。亦不闻有萨云若。亦不念其事。以是故。拘翼当知。少所众生信三尊者耳。于是中少所众生发意至辟支佛道者。于中复少所众生行菩萨道者虽有少少众生行菩萨道者。欲至阿耨多罗三耶三菩者复少少耳。拘翼。我于是间以佛眼见十方不可计阿僧祇众生。行阿耨多罗三耶三菩。不离般若波罗蜜沤和拘舍罗者。若一若二住阿惟越致地耳。多堕罗汉辟支佛道者。用离般若波罗蜜沤和拘舍罗故。是故拘翼。善男子善女人。欲发至阿耨多罗三耶三菩者。当受持般若波罗蜜。当讽诵读当念习行持。是般若波罗蜜者。书已以香花幢幡缯彩华盖。诸余功德入般若波罗蜜者。当复受持亦当讽诵学念守行。何等功德入般若波罗蜜者谓布施持戒忍辱精进一心。内外空所有空无所有空。诸三昧门陀邻尼门。三十七品佛十八法。大慈大悲。余无量佛法皆入般若波罗蜜。亦当复学持讽诵守行念其中事。何以故。拘翼。是善男子善女人当作是知。诸如来本行菩萨道时。亦复学般若波罗蜜。亦行禅波罗蜜。惟逮波罗蜜。羼波罗蜜。尸波罗蜜。檀波罗蜜。从内外空及有无空诸三昧门陀邻尼门。乃至佛十八法大慈大悲。余无央数诸佛法我等皆当受学。我等所尊仰者其般若波罗蜜。及诸佛法尽是诸佛如来之教。辟支佛阿罗汉阿那含斯陀含须陀洹至萨云若教。皆于般若波罗蜜中学成。度此岸至彼岸。拘翼。善男子善女人。如来在世若般泥洹。皆当恭敬礼事是六波罗蜜。亦当礼事萨云若。何以故。般若波罗蜜者。是诸菩萨声闻辟支佛之护世。人及诸天皆依是般若波罗蜜而得安隐。拘翼。若有善男子善女人。佛般泥洹已后取舍利。起七宝塔高四十里。尽其寿命自归承事。天花天香及天捣香天缯花盖天衣天幔作是供养。其福宁多不。释提桓因言。世尊。甚多甚多。佛言。不如是。善男子善女人受行般若波罗蜜。书持经卷讽诵读持。初不离萨云若意。复加供养名花捣香泽香杂香幢幡花盖。其福倍多不可计也。复次拘翼。置是一七宝塔。若善男子善女人。取舍利起七宝塔满一阎浮提。亦高四十里。供养承事天花天香及天捣香天缯花盖天衣天幔作是供养。其福宁多不。释提桓因言。甚多甚多世尊。佛言。不如是。善男子善女人供养般若波罗蜜其福转倍多。复次拘翼。置是阎浮提所作塔事。若善男子善女人。取舍利起七宝塔满四天下供养如前。不如是善男子善女人。供养般若波罗蜜其福转倍多。置是四天下。拘翼。若有善男子善女人。取舍利起七宝塔满小千国土供养如前。复置是小千国土所作七宝塔。若善男子善女人。取舍利起七宝塔满中千国土供养如前。复置是中千刹土所作七宝塔。若善男子善女人。取舍利起七宝塔满三千大千国土供养如上故。不如是善男子善女人。供养般若波罗蜜其福转倍多。拘翼。复置是三千大千刹土所作七宝塔。若三千大千国土。满其中人令一一人各各起七宝塔供养如上故。不如是善男子善女人供养般若波罗蜜其福转倍多。释提桓因白佛言。如是如是。世尊。供养般若波罗蜜者。为供养过去当来今现在诸佛如来已。佛言。假令如东方恒边沙刹土。满其中众生。一一佛泥洹后。取舍利起七宝塔弥满其中供养如上。从劫至劫复过一劫尽其寿命。云何拘翼。其人殖福宁转多不。释提桓因言。甚多甚多。佛言。故不如是善男子善女人供养般若波罗蜜书持经卷讽诵读习。供以名香泽香杂香缯彩花盖。得其福多。何以故。拘翼。一切诸善法皆在般若波罗蜜中。何谓善法。五戒。十善。四禅。四等及四空定。三十七品。三脱门。四谛。六通。八惟无。九次第禅。六波罗蜜。从内外空至有无空。诸三昧门陀邻尼门佛十种力佛十八法四无所畏四无碍慧大慈大悲道事萨云若事。是为诸如来无所著等正觉之法教。诸罗汉辟支佛过去当来今现在诸如来。皆从是般若波罗蜜中学成。度于彼岸

    摩诃般若波罗蜜供养品第三十四

佛告释提桓因言。如是拘翼。善男子善女人。供养般若波罗蜜。书持经卷受学讽诵念习守行者。若复能尽力供养。名花捣香泽香杂香缯彩花盖所有幢幡。所得功德不可计量不可思议不可称限。是善男子善女人所得如是。何以故。诸如来无所著等正觉。皆从般若波罗蜜中出生。萨云若五波罗蜜。皆从般若波罗蜜出生。从内外空至有无空。皆从般若波罗蜜出生。三十七品佛十八法如来五眼。教授众生净佛国土。道慧萨云若慧皆从般若波罗蜜出生。声闻辟支佛佛乘无上等正觉道。皆从般若波罗蜜出生。如是拘翼。若有善男子善女人。书写般若波罗蜜。持经卷学受讽诵念守习行。复加供养名花捣香缯彩幡盖。其功德福。过出前所供养舍利七宝塔上。百千万倍巨亿万倍。计空不及不可为譬喻。何以故。般若波罗蜜在于世者。三宝终无断绝时。般若波罗蜜不在世者。三宝便断绝。般若波罗蜜住于世者。便知有十戒功德四等四禅及四空定六波罗蜜三十七品佛十八法萨云若慧。便知有刹利种婆罗门种大姓长者种。便知有四天王及阿迦腻吒天。便知有须陀洹道至罗汉辟支佛道。便知有菩萨摩诃萨之径路。便知有无上佛慧。便知有转法轮。便知有教化众生净佛国土

    摩诃般若波罗蜜持品第三十五

尔时三千大千国土。诸四天王及诸阿迦腻吒诸天子。语释提桓因言。仁者。当受持般若波罗蜜。讽诵习念守行般若波罗蜜。供养讽诵念者。诸余恶法悉当消灭。诸善功德当具足生。受持般若波罗蜜者。增益诸天众减损阿须伦众。三宝之法终不断绝。以佛法不断绝故。世间便当有六波罗蜜三十七品佛十八法。皆当现于世间。便有行菩萨道者。便有三乘之教。佛告拘翼。汝当受持般若波罗蜜。讽诵读守念习行。何以故。若阿须伦聚会诸众。欲兴恶意与诸忉利天共战。拘翼。汝当诵念般若波罗蜜者。阿须伦适生是意。便即时灭不得究竟。拘翼。忉利天上若诸天子若诸天女。若福已尽寿欲终时或当堕落。汝当为讽诵说般若波罗蜜者。此诸天人天女。不至余趣即得还生忉利天上。以般若波罗蜜音声之功德故。此诸天人更生本处不复堕落。何以故。般若波罗蜜音声其德大故。拘翼。若善男子善女人。若诸天子若诸天女。闻是般若波罗蜜音声。径耳一时便过。以一径耳之德故。其人久后会当得阿耨多罗三耶三菩。终不复疑。何以故。拘翼。过去十方诸如来无所著等正觉及诸弟子众。皆悉从是般若波罗蜜中。于无余泥洹而般泥洹故。当来及今现在十方诸如来皆从般若波罗蜜中。成阿耨多罗三耶三菩。何以故。诸三十七品皆从般若波罗蜜中出生。声闻辟支佛法。菩萨法及佛法。皆从般若波罗蜜中出生。释提桓因白佛言。世尊。是般若波罗蜜为极大术。般若波罗蜜无上之术。般若波罗蜜者无等之术。何以故。世尊。是般若波罗蜜者。已弃诸不善之法。总持诸善之本。佛告释提桓因言。如是拘翼。是般若波罗蜜者。极大之术无上无等之术。何以故。过去诸如来无所著等正觉。皆由是术得阿耨多罗三耶三佛。当来今现在诸佛。亦当由是术得成阿耨多罗三耶三佛。何以故。由是术故。世间知有十善之德四禅四等及四空定。六波罗蜜三十七品佛十八法。知有法性法位真际。知有如。知有五眼。知有须陀洹道。知有罗汉辟支佛道。知有菩萨佛道。知有萨云若萨云若慧。由菩萨故。十善之德显于世间。乃至如来萨云若亦显现于世间。皆由菩萨来往因缘故而有是现。拘翼。譬如月来往因缘。为世除冥照于星宿。如是拘翼。菩萨从善行等行生。从十善功德生。从萨云若慧生。从无所从生法生。拘翼当知。诸菩萨摩诃萨。从般若波罗蜜出生。诸菩萨所行五波罗蜜。内外空及有无空。三十七品佛十八法。亦不于声闻辟支佛地中取证。教授众生净佛国土。欲得成就佛土成就菩萨成就逮萨云若。皆从般若波罗蜜出生。复次拘翼。若有善男子善女人。受持般若波罗蜜。若讽诵读习行其事者。即得现世之德。亦当得度世之德。释提桓因白佛言。善男子善女人何等为得现世之德。佛言。奉行般若波罗蜜者。终不中毒死。终不抂横水火中死。皆当尽其寿命而终。若有县官事往至县官。终无有能得其便者。何以故。皆是讽诵般若波罗蜜威神之力。若是善男子善女人。若至国王所若大子群臣。所语可国王大子意及诸群臣无不喜者。何以故。用是善男子善女人行大慈大悲以四等意向众生故。是为现世之德。何等为具足得度世之德。佛言。未曾离是十善功德。亦未曾离四禅四等及四空定六波罗蜜三十七品佛十八法。初不离是法。终不生三恶趣。受身完具诸根具足。终不生贫穷之家。终不于工师家生。亦不生于凡品之家。常当具足三十二大士之相。所生诸佛国常当化生。终不离菩萨神通愿。欲从一佛国至一佛国。恭敬礼事诸佛世尊。常欲听受诸佛上法。欲教化众生净佛国土。是故拘翼。善男子善女人受持般若波罗蜜。讽诵读念当守习行。不离萨云若意。至成阿耨多罗三耶三菩。初不断绝。是为后世度世之德

    摩诃般若波罗蜜遣异道士品第三十六

尔时有异道士。来至佛所欲索佛便释提桓因意念言。今日是诸异道士辈来欲谤佛欲中道断般若波罗蜜。如我从佛所受般若波罗蜜当讽诵念。释提桓因即讽诵般若波罗蜜。诸异道士欲来坏般若波罗蜜者。遥绕佛一匝复道而去。时舍利弗意作是念。云何此诸异道人辈遥绕佛一匝复道还去佛知舍利弗意所念。告舍利弗言。用释提桓因诵念般若波罗蜜故。异道人遥绕佛一匝复道还去。佛言。是异道士无一善意来至佛所。但持勃意索佛长短耳。佛告舍利弗。若讽诵般若波罗蜜时。若天若世间人。沙门婆罗门若异学士。持是勃意来欲求其长短者终不能得其便。何以故。是三千大千国土。诸四天王诸天子。乃至阿迦腻吒诸天子。及弟子诸菩萨。受持般若波罗蜜故。何以故是亦皆从般若波罗蜜中出生故。复次舍利弗。东方恒边沙国诸如来弟子众辟支佛菩萨天龙鬼神。是辈皆受持般若波罗蜜。何以故。是皆出生于般若波罗蜜故时魔波旬意念言今佛与诸四辈弟子及诸欲天子诸色天子共会。其中当有受菩萨记者必当成阿耨多罗三耶三佛今我宁可往至佛所中断其道。于是波旬化作四种兵来至佛所。尔时释提桓因意念言。今日魔将四种兵欲来至佛所是魔所化四种兵严饰洴沙王所无有。舍卫国王亦所无有。诸释种亦所无有。随耶利诸长者亦所无有。如是魔所化四种兵者。是魔波旬。长夜常索佛短而娆众生。我今宁可默诵念般若波罗蜜。释提桓因便定意稍稍诵念般若波罗蜜。时魔波旬亦复稍稍却行还去。尔时四天王诸天子及阿迦腻吒诸天子。化作天花于虚空中而散佛上。时诸天子同时叹言。令般若波罗蜜久在阎浮提。使阎浮提人常得受持般若波罗蜜。般若波罗蜜久在者。佛亦得久住无有灭时。佛久在者法亦当久住。如法久在者比丘僧常现于世间。如是三宝终无断绝时。般若波罗蜜亦当久在三千大千刹土。十方恒边沙刹土亦当如是。般若波罗蜜者是菩萨摩诃萨众行之上最。善男子善女人。受持般若波罗蜜书经卷者。随其方面其处最尊则为照明。当知是处已离于冥。是诸处中最尊之处佛告释提桓因言。如是拘翼。当知是众处之尊。复次拘翼。是般若波罗蜜。不但于人中其处最尊。亦复在天上其处最尊。是时诸天子化作天花散于佛上。皆同时举声言。若有善男子善女人受持般若波罗蜜讽诵读者。魔及魔天终不能得其便。我等世尊亦当拥护是善男子善女人。何以故。我等视是善男子善女人如视世尊。释提桓因白佛言。世尊。是善男子善女人以作无量善本。诵念受持是般若波罗蜜者。从过去佛时作功德所致。是善男子善女人已见无量诸佛所致。与善知识相随所致。何以故。欲得萨云若者当从般若波罗蜜索之。欲得般若波罗蜜者亦当从萨云若求。以是故般若波罗蜜则是萨云若。萨云若则是般若波罗蜜。是为一无有二。佛告释提桓因言。如是拘翼。萨云若诸如来无所著等正觉者。皆从般若波罗蜜出生。何以故。拘翼。萨云若般若波罗蜜者。一法耳无有二故

    摩诃般若波罗蜜无二品第三十七

尔时贤者阿难白佛言。唯世尊。世尊所说初不称誉五波罗蜜。亦不称誉佛十八法。但称誉般若波罗蜜。何以故。佛告阿难。般若波罗蜜者。于五波罗蜜佛十八法中最尊。云何阿难。不为萨云若布施。宁可称誉檀波罗蜜不。报言。不也世尊。不为萨云若戒忍精进一心智慧。宁可称誉般若波罗蜜不。不也世尊。阿难白佛言。云何布施为萨云若而为檀波罗蜜。至般若波罗蜜耶。佛告阿难。布施无有二。于萨云若是为檀波罗蜜。作无所生无所倚。布施于萨云若是为檀波罗蜜。无所生无所倚念。萨云若无有二。是为般若波罗蜜。阿难白佛言。云何念无有二布施应萨云若。佛言。于五阴无有二至道亦无有二。云何五阴无有二至道亦无有二。五阴五阴自空。何以故。五阴与诸波罗蜜一法耳无有二法。于道亦一法无有二。是故阿难。般若波罗蜜于五波罗蜜中最尊。乃至萨云若亦复于中最尊。譬如大地下五谷种。以散其中随时而生。般若波罗蜜者是地。诸波罗蜜三十七品至萨云若皆从其中出生。萨云若者。因般若波罗蜜出生。五波罗蜜者。亦复因萨云若出生。是故阿难。般若波罗蜜者是五波罗蜜之导。至五波罗蜜佛十八法皆随从。释提桓因白佛言。世尊所说称叹般若波罗蜜功德未尽。善男子善女人受持般若波罗蜜。若讽诵读习念守行尊奉供养者。其功德亦复未尽。以奉持般若波罗蜜故。十善现于世间。四禅四等及四空定至佛十八法皆现世间。以奉行般若波罗蜜故。便知有刹利梵志长者大姓种。便知有四天王上至阿迦腻吒天。便知有须陀洹道上至罗汉辟支佛道菩萨至佛道。佛告拘翼我所说善男子善女人。受持诵行供养般若波罗蜜者。其功德未竟。受持诵行供养。般若波罗蜜者。其功德不可称计不可限量何以故。是善男子善女人。奉行般若波罗蜜者。当得无量戒性。得无量三昧性智慧性解脱性见解脱慧性意。终不离萨云若意是善男子善女人皆当得是不可计诸功德。拘翼当知。是善男子善女人。奉行般若波罗蜜者。为承佛弟终不离萨云若。拘翼。声闻辟支佛所有戒性三昧智慧解脱见解脱慧持是五性比是善男子善女人五事性者其功德百倍千倍巨亿万倍。其功德最尊无有能为作譬喻者。何以故。拘翼。是善男子善女人意。已离罗汉辟支佛。初不见愿罗汉辟支佛故。拘翼。般若波罗蜜。若有书持受学诵念及华香缯盖供养者。我常叹说是善男子善女人今世后世至竟之德。释提桓因白佛言。我亦当常拥护是善男子善女人奉行般若波罗蜜者令意不离萨云若意。佛告释提桓因言。是善男子善女人诵说般若波罗蜜时。无央数百千诸天。皆往到是善男子善女人所。悉叉手听受般若波罗蜜。是诸天子复以威神加是善男子善女人。令疾开解益其识辩。是为善男子善女人得现世之德。复次拘翼。是善男子善女人于四辈弟子中。说般若波罗蜜时。终无疲倦懈怠之心。终无能形识者。何况欲有轻毁之者。何以故。般若波罗蜜所拥护故。般若波罗蜜者分别诸法故。何谓分别。是道是俗。是善是不善。是无漏是有漏。是具足是不具足。是声闻法是辟支佛法是佛法。是为分别。何以故。是善男子善女人。已住于内外空及有无空故。用般若波罗蜜无有短故。亦不见能得般若波罗蜜短者。如是奉持般若波罗蜜者。无有能得其便者。复次拘翼。善男子善女人般若波罗蜜。作如是持作如是行者。意终不懈怠终不恐怖。何以故。是善男子善女人。终不见恐怖懈怠之兆。是为善男子善女人现世之福德。复次拘翼。若有善男子善女人受持般若波罗蜜供养香华幢幡缯盖。作是供养者。是善男子善女人。为父母所敬爱。兄弟宗亲朋友知识皆恭敬之。十方诸罗汉辟支佛诸菩萨诸佛皆共爱敬。是善男子善女人世间人及诸天阿须伦亦所爱敬。行六波罗蜜无有断绝时。终不离内外空及有无空时。终不离三十七品佛十八法。终不离诸三昧门陀邻尼门终不离菩萨神通教授众生净佛国土。终无断绝时。其力堪任降伏外谤。拘翼。是为善男子善女人受行般若波罗蜜今世后世之德。拘翼。善男子善女人。书般若波罗蜜。持经卷讽诵者。三千大千刹土中诸四天王皆往到是善男子善女人所。听受般若波罗蜜。作礼恭敬已去。从忉利天上至阿迦腻吒天。是诸天人行菩萨道者。皆来到是善男子善女人所。听受般若波罗蜜。承事恭敬作礼已去。十方诸四天王诸阿迦腻吒天。及诸龙神诸阅叉揵沓和阿须伦迦楼罗真陀罗摩睺勒。皆来见般若波罗蜜。作礼供养承事恭敬。是善男子善女人。当作是知。是为法施。是三千大千刹土中及十方诸国土中。诸四天王天子。上至阿迦腻吒诸天子行菩萨道者。皆共拥护是善男子善女人行般若波罗蜜者。诸邪恶害不能得其便。除其宿命不债。如是拘翼是善男子善女人得现世之福。诸天子有欲来至是善男子善女人所者。为欲成阿耨多罗三耶三佛。欲救护众生安隐众生。欲乐众生。尔时释提桓因白佛言。是善男子善女人。当云何知十方诸四天王及诸阿迦腻吒诸天。来至般若波罗蜜所。恭敬受持作礼时。是善男子善女人当何以知之。佛告释提桓因言。是善男子善女人若见异色净光明者。是为知诸天人来听受般若波罗蜜作礼恭敬时。拘翼。是善男子善女人。所未曾闻香若闻异妙之香者。当知诸大尊天来听受般若波罗蜜恭敬作礼时。拘翼。是善男子善女人常当净洁自喜。用净洁自喜故。诸天皆大欢喜。来到是善男子善女人所。听受般若波罗蜜承事作礼。是大尊天来时。是间小小少威神诸天鬼神辈皆悉避去。用不堪任是尊天威神故。用是诸尊天神来故。是善男子善女人皆离众难。是善男子善女人所止处常当净洁住。然灯烧香悬缯花盖无量严饰常净洁供养。是善男子善女人。终无疲厌之心。身识轻便常得安隐卧起亦安。终无恶梦不见余梦。但梦见佛但梦闻法但见比丘僧。但见三十二相八十种好。但见诸弟子眷属围绕而为说法。但见听闻六波罗蜜。但见三十七品佛十八法。但见发遣六波罗蜜其义具足。但见坐佛树下。但见诸菩萨往至佛树成阿耨多罗三耶三佛时。但见已成阿惟三佛而转法轮。但见无央数百千诸菩萨众。但见当作是受萨云若慧。但见教化众生净佛国土。但闻十方无央数诸佛音声。但闻某方某国某佛字某。若干百千菩萨弟子眷属围绕而为说法。但见十方若干诸佛般泥洹者。但见已般泥洹取其舍利起七宝塔以名花香供养塔者。拘翼。是善男子善女人所梦如是。但见殊妙之像。是善男子善女人卧安起安身体亦安净洁且轻。不贪饮食不贪衣服。于诸供养无所希望。拘翼。譬如习行比丘。意在禅息不贪于食以禅知足。何以故。诸天鬼神取诸味之精来益其气故。十方诸佛国诸天鬼神。皆以诸饮食之精气亦来益之。佛告拘翼。若善男子善女人。欲得是现世之功德者。当受学是般若波罗蜜。书持讽诵意终不离萨云若。正使是善男子善女人。不能受持般若波罗蜜。不能讽诵行其中事。但书持作经卷恭敬承事。香花幡盖自归供养。其功德不可计。加复受学讽诵守行般若波罗蜜。意终不离萨云若者。其功德胜于供养十方恒边沙国诸佛功德者上。若有人供养十方现在诸佛。尽其形寿香花缯盖幢幡严饰衣钵真越。若佛般泥洹后取舍利起七宝塔供养如前故。不如是善男子善女人。受持般若波罗蜜。讽诵学习念其中事。得其功德。过出于彼供养者上。百倍千倍巨亿万倍

    摩诃般若波罗蜜舍利品第三十八

佛告释提桓因言。拘翼。如佛全身舍利。满一阎浮提持作一分。般若波罗蜜书持经卷复作一分。二分之中欲取何所。释提桓因白佛言。世尊。我宁取般若波罗蜜。所以者何。我于舍利不敢有慢意。不敢不恭敬。不为不欲供养。用诸佛身皆从般若波罗蜜出生故。诸佛如来舍利。皆因般若波罗蜜因缘故而得供养。舍利弗语释提桓因言。拘翼。是般若波罗蜜最第一无形。不可护持不可见无碍一相。一相者则无相。云何而欲受持。持是般若波罗蜜。亦不于所生处住。亦不增减处住。亦不希望处住。亦不无希望处住。亦不转处住。亦不于着断处住。亦不持佛法有所与。亦不舍凡人法。亦不持声闻辟支佛戒法有所与。亦不舍凡人法。亦不持无为法有所与。亦不舍有为法。亦不持内外空及有无空有所与。亦不持三十七品佛十八法萨云若法有所与。云何欲受持。释提桓因言。如是如是。舍利弗。有知是般若波罗蜜。于佛法无所与。于凡夫法而无所舍。有作是知者是为行念般若波罗蜜。是为于六波罗蜜而无二入故。于是世尊叹释提桓因言。善哉善哉。如汝所说。于六波罗蜜无有二入。所以者何。六波罗蜜无有二事故。拘翼。般若波罗蜜及法性亦无有二。六波罗蜜真际不可思议亦无有二。释提桓因白佛言。世尊。诸天及世间人。当为般若波罗蜜作礼。所以者何。菩萨摩诃萨。于般若波罗蜜中成阿惟三佛故。世尊。譬如我与诸天子共在快等正殿共会。诸天子来集为我作礼。若我不在坐。诸天子皆为我坐作礼。用受教处故。绕一匝已各各自去。若善男子善女人。有书持是般若波罗蜜。复为他人解说其义。时十方诸天。龙。鬼。神。阿须伦。揵沓和。迦楼罗。甄陀罗。摩睺勒。皆为般若波罗蜜处作礼绕已竟去。所以者何。诸佛如来皆从中生。诸世间人安隐快乐皆从中生。诸佛舍利诸菩萨行。皆来入萨云若中。皆因萨云若皆悉随从受其教令。用是故世尊。二分之中我取般若波罗蜜受持讽诵。我受持般若波罗蜜者。若使法欲尽时。我亦不恐畏。初无是相念何以故。般若波罗蜜无相无形亦不可得故。六波罗蜜上至萨云若。皆无有相无行无形亦不可见。是般若波罗蜜无相之法。用是故如来无所著等正觉。于无行无得无相法中。成得阿耨多罗三耶三佛。世尊。用般若波罗蜜无相故。为弟子说法亦无相无得无行。得成阿耨多罗三耶三佛。用是故世人及诸天鬼神龙。皆当承事恭敬名花名香缯幡花盖。供养般若波罗蜜。世尊。若有受持般若波罗蜜讽诵习行者。若复持诸经卷香花供养者。是辈之人终不复堕三恶之趣。亦不堕落罗汉辟支佛道。至成阿耨多罗三耶三佛。亦无是难所生常见佛不离诸佛国。从一佛国复至一佛国。香花宝饰供养诸佛世尊。正使三千大千国土全身舍利令满其中。二宝之中我故当取般若波罗蜜。何以故。世尊。是舍利于般若波罗蜜中出生得供养故。善男子善女人。因是供养断三恶趣。得生天上人中之福。于三乘法随其所愿各得度脱。世尊。书般若波罗蜜已。见其经卷如见佛等无有异。何以故。世尊。如来与般若波罗蜜等耳无有二故。如世尊以三事教及十二部经。若有善男子善女人。受书般若波罗蜜。持其经卷复以教人。与佛所教正等无异何以故。世尊。佛三法教及十二部经。皆从般若波罗蜜中出故。复次世尊及十方诸佛。以三事教十二部经。若复有善男子善女人。以般若波罗蜜经卷教人。其福亦等无异。何以故。十方诸佛十二部经及三事教。皆从般若波罗蜜中出生故。复次世尊。若有善男子善女人。供养十方如恒边沙诸佛真越。衣服所有名花供养严饰。若复有供养般若波罗蜜者。其功德福与彼无异。何以故。十方诸如来无所著等正觉。皆从般若波罗蜜中出故。复次世尊。若善男子善女人受学般若波罗蜜。讽诵读持习行中事。是人终不堕三恶趣。亦不堕罗汉辟支佛道地。正住阿惟越致地。何以故。世尊。般若波罗蜜者。远离众病故。复次世尊。若有善男子善女人。书持般若波罗蜜者。受学讽诵守行中事。加复供养名花捣香缯彩花盖幢幡。当知是善男子善女人已离诸恐怖。世尊。譬如负债之人常怀恐怖。与王相知不复恐怖。何以故。用依尊故。如是世尊。舍利从般若波罗蜜中得成而得供养。世尊。当知是般若波罗蜜如王。如来舍利者如负债人。依般若波罗蜜用得安隐。世尊。当知萨云若之慧皆从般若波罗蜜得成。是故我于二宝之中取般若波罗蜜。何以故。如来身者从般若波罗蜜中出生。大士三十二之相。佛十种力四无所畏佛十八法大慈大悲。皆从般若波罗蜜出生。五波罗蜜者亦从般若波罗蜜出生。各得名字。如来所得萨云若慧。皆从般若波罗蜜中出。世尊。三千大千刹土。所在有受持是般若波罗蜜讽诵学者。供养香花承事礼拜。人若非人终不能得其便。是众生等后皆当得泥洹之法。世尊。是般若波罗蜜大威神也。乃使三千大千世界众生皆建佛事。世尊。般若波罗蜜所止处。当知是处已为有佛。譬如世间无价摩尼之宝所在着处。人非人不能得其便。若男子女人为非人所持持摩尼宝往。非人见摩尼宝者。不堪其威即自然去。若男子女人有寒热之病。持摩尼宝示之其病即除。若持摩尼宝着冥中即时明。热时持摩尼宝所著处即时凉。寒时持摩尼宝所著处即时温。摩尼宝所置处诸邪之毒皆悉消除。若男子女人为蛇蚖所中。见摩尼宝者毒即除其处愈。世尊。摩尼宝其德如是。若男子女人若目冥若眼痛若身肿若有疮见摩尼宝者诸疮诸病皆悉除愈。世尊。此摩尼宝其德如是。若着水中水即随作摩尼宝色。世尊。若持杂色若干种缯裹。着水中水续作摩尼宝色。水浊即为清。摩尼宝其德如是。是时阿难语释提桓因言。拘翼所说者为是天上摩尼宝乎。为是世间宝耶。释提桓因报阿难言。我所说者天上之宝。世间亦有摩尼宝。不及天上之宝。其德不具足不如天上宝。其德不可以譬喻为比。我所说宝者。若着函中若着箧中。其光明彻出去。正使举珠去其处续明如故。若有书持受学般若波罗蜜者。其处则无众患之难。其处所尊譬如摩尼珠之处。当知般若波罗蜜如摩尼珠。其德无量五波罗蜜之德及萨云若。内外空及有无空。三十七品佛十八法。法性如真际不可思议萨云若慧之德。佛般泥洹后舍利得供养承事。萨云若慧从诸习绪尽。常悉守护不忘于法。萨云若者是诸法之器。是故如来无所著等正觉舍利得尊敬供养。舍利者是般若波罗蜜之宝器。无断无著波罗蜜。无生无灭波罗蜜。亦不着亦非不着波罗蜜。无生无灭波罗蜜亦不应亦非不应波罗蜜。亦不举亦不下波罗蜜。亦不来亦不去亦不住波罗蜜。是故如来无所著等正觉舍利得供养。舍利者是诸法波罗蜜之器。以诸法波罗蜜合成故。舍利得供养。世尊。置是三千大千刹土如来舍利。如恒边沙刹土舍利满中。我故取般若波罗蜜。所以者何。如来舍利皆出是中故得供养故。若善男子善女人。供养舍利恭敬承事者。得天上世间之福。得生刹利梵志长者大姓家。得生第一四天王。得第六天上功德之福。殖此福已因诸善本必度众苦。若复持是般若波罗蜜供养承事。便具足五波罗蜜三十七品佛十八法度罗汉辟支佛地住菩萨之德。便得神通从一佛国复至一佛国。随其所应而教化之各令得所。或作遮迦越罗。或作刹利梵志。或作长者大姓。随其习俗而教授之。是故世尊。我不为憍慢不恭敬承事。不为不欲受持舍利世尊。若有善男子善女人。恭敬承事般若波罗蜜者。则为供养诸如来无所著等正觉舍利已。世尊。若欲见十方现在无央数诸佛者。当奉行般若波罗蜜。讽诵受持教人习行供养是已。善男子善女人。便得见十方现在无央数诸佛。以善男子善女人供养般若波罗蜜故便得诸佛法。世尊。欲得见诸佛如来无所著等正觉者。是善男子善女人。当受持般若波罗蜜。世尊。复有二法。何等为二。谓有为法之法。无为法之法。何等为有为法之法。谓内外空之智及有无空之智。三十七品四无碍慧四无所畏佛十种力及十八法。恶法善法之智。有漏无漏之智。俗法道法之智。是名曰有为法之法。何等为无为法之法。谓不生不灭之法。亦不住住无有异。亦不着亦不断亦不增亦不减诸法之真。何等诸法之真。无所有者是法之真。是名为无为法之法。佛告释提桓因言。如是如是。过去诸如来无所著等正觉。皆由般若波罗蜜成阿惟三佛。诸弟子众亦各得其所成。须陀洹至罗汉辟支佛。甫当来今现在诸如来无所著等正觉。亦当由般若波罗蜜成阿惟三佛。诸弟子众亦各成其所得。须陀洹至罗汉辟支佛。何以故。此三乘法皆从般若波罗蜜中出故。虽出三乘亦无所生亦无相念亦无著亦无断亦无所有亦不应亦不不应亦不动转亦不不动转亦不取亦不舍。但以俗数不以最要。何以故。般若波罗蜜亦不在此亦不在彼亦不中流亦不近岸亦不偶亦不只亦非相亦非无相亦非道亦非俗亦不有为亦不无为亦不善亦不恶亦不过去当来今现在。何以故。拘翼般若波罗蜜亦不持佛法亦不持声闻辟支佛法亦不舍凡人法。释提桓因白佛言。世尊。般若波罗蜜者大度之度。菩萨摩诃萨行般若波罗蜜。尽知一切众生之意。亦不有众生及知见处。亦不见五阴亦不见六情。亦不有六衰亦不缘起。亦不有三十七品及佛十八法。亦不见道亦不有道法。亦不见佛亦不有佛法。何以故。般若波罗蜜亦不有所倚住。何以故。般若波罗蜜无有形不可见。何况当见有所倚者。佛告释提桓因言。如拘翼所说。菩萨摩诃萨长夜行般若波罗蜜尚不见道。何况及菩萨所行法。释提桓因白佛言。世尊。何以故。菩萨摩诃萨但行般若波罗蜜。不行余波罗蜜。佛告释提桓因言。菩萨尽行六波罗蜜。亦无所倚不有所施。不有受者不有与。不有戒亦不有犯。亦不有忍亦不有恚。亦不有精进亦不有懈怠。亦不有禅亦不有乱意。亦不有智亦不有愚。般若波罗蜜者是菩萨第一之行。于般若波罗蜜布施持戒忍辱精进一心者。欲具足五波罗蜜故。菩萨行般若波罗蜜者。欲观诸法无所倚故。从五阴至萨云若。是为诸法无所倚。譬如阎浮提种种好树。若干种色若干种叶若干种花若干种果其色各异。种种茎节枝叶花实其荫无异无有差别。拘翼。般若波罗蜜含五波罗蜜至萨云若。亦不若干无有差别亦无所倚。释提桓因白佛言。世尊。般若波罗蜜者。于诸功德皆具兄满。世尊。般若波罗蜜者。是无央数无量功德皆悉具足。世尊。般若波罗蜜者。含受一切诸法功德皆悉具足。世尊。若有善男子善女人。受持般若波罗蜜者。书其经卷。供养名华捣香缯盖幢幡奉行中事。若复有人书般若波罗蜜以为经卷。复与他人。如是其福何所为多者。佛告释提桓因言。我今问汝随所报我。若善男子善女人供养全身舍利。若复持如芥子者分与他人令供养者。其福何所为多。释提桓因白佛言。世尊。如我从佛所闻法中事。善男子善女人供养舍利。若复分持如芥子者与他人其福甚多。世尊。如我重察其义。如来住于金刚三昧。自坏其身下末舍利如芥子者而供养之。受无极福断诸苦之际。佛告释提桓因言。如是拘翼。若有人供养般若波罗蜜书持经卷。复与他人者其福德甚多甚多。拘翼。若持般若波罗蜜转复教余人。解其中慧事事分别。是善男子善女人所得福德。多于前所供养者上所从闻。是般若波罗蜜者。当知其尊在诸贤圣之上。当视是人如世尊无异。所以者何。得见般若波罗蜜者则为见世尊已。世尊则是般若波罗蜜。般若波罗蜜则是世尊。何以故。过去当来今现在诸如来无所著等正觉皆从般若波罗蜜中出。得成阿惟三佛故。诸贤圣智及诸阿惟越致菩萨。皆从是般若波罗蜜中出。得成阿惟佛。诸声闻者亦从其中皆得罗汉。辟支佛各得其所。发菩萨意者亦从是皆得诸菩萨德。是故拘翼。若善男子善女人。欲得见现在诸佛承事供养者。当供养般若波罗蜜。佛言。我奉持供养般若波罗蜜如是上事。自致成阿惟三佛于中最尊。谁复有尊可承供养从天上至世间过诸三界无复尊者。熟自思念我本从般若波罗蜜自致三耶三佛。般若波罗蜜者则是我之所尊。是故我今当供养般若波罗蜜所应恭敬。是故拘翼。我自供养承事是般若波罗蜜初不远离。我所作者皆因般若波罗蜜而行。若善男子善女人欲得阿耨多罗三耶三佛者。当供养般若波罗蜜受持奉行。何以故。诸菩萨摩诃萨皆从般若波罗蜜出生故。诸佛世尊皆从菩萨摩诃萨出生故。是故拘翼。若善男子善女人行三乘法者皆当供养般若波罗蜜。书持受学亦当如是

放光般若波罗蜜经卷第七放光般若经卷第八

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜功德品第三十九

佛告释提桓因。若有善男子善女人。教一阎浮提。其中众生使立十善。于拘翼意云何。其福宁多不。释提桓因白佛言。甚多甚多世尊。佛言。拘翼。不如是善男子善女人持般若波罗蜜经卷授与他人。使书持讽诵解其中事。得其功德甚倍多也。何以故。是般若波罗蜜中。广说无漏之法。使诸善男子善女人皆得而学。甫当来者。亦复得学等至于道。求罗汉辟支佛道者皆于是得。甫当求者亦于是得。求菩萨道者皆于中得。甫当求者皆悉当于中得。已成阿惟三佛者皆于中得。甫当求阿惟三佛者亦当于是中得。拘翼。何等为无漏之法。谓三十七品空及三脱门四谛。内外空。及有无空佛十种力无量佛法。使善男子善女人得成阿惟三佛。甫当求者亦当得成阿惟三佛。拘翼。教一阎浮提众生皆立于十善。不如使一人得须陀洹道。何以故。虽教一阎浮提众生使行十善未脱三恶趣。教一人得须陀洹者。已离三恶趣故。拘翼。若教一阎浮提其中众生使行十善尽得须陀洹。不如教一人使得辟支佛得福甚多。拘翼。尽教一阎浮提人立于十善。皆得须陀洹斯陀含阿那含阿罗汉辟支佛。不如教一人使发阿耨多罗三耶三菩意其德甚多。何以故。使一人发阿耨多罗三耶三菩意。为续佛种佛种不断故。拘翼。须陀洹至辟支佛及佛皆从菩萨生。是故当知。善男子善女人持般若波罗蜜经卷。授与他人所得甚多。何以故。诸广大之法。皆来入般若波罗蜜故。因是便知有刹利梵志长者大姓。因知有四天王上至无思想无思想慧天。因知有三十七品至萨云若。知有须陀洹上至三耶三佛。拘翼。置是一阎浮提众生。及四天下至小千天下。中千天下三千大千国土。及如恒边沙国土满中众生。悉教立于十善故。不如是善男子善女人书持般若波罗蜜。教他人使书持经卷讽诵解说。得其功德甚多甚多。复次拘翼。善男子善女人。教一阎浮提满中众生。令立四禅四等及四空定。得五神通其人得福宁为多不。释提桓因白佛言。甚多甚多。世尊。佛言。故不如是善男子善女人书持般若波罗蜜授与他人。使书持经卷讽诵解说。得其福多。何以故。拘翼。般若波罗蜜者。所说极广远故。拘翼。置是一阎浮提四天下小千国土中千国土三千大千国土。及如十方恒边沙国土满中众生。悉教令得四禅四等及四空定。得五神通其功德宁多不。释提桓因白佛言。甚多甚多世尊。佛言。故不如是善男子善女人书持般若波罗蜜授与他人。使书持讽诵解说中事。得其功德甚多甚多。复次拘翼。受持般若波罗蜜者。不以二事亦非不二。受行五波罗蜜。亦不以二道亦非不二。亦不以二事念内外空及有无空。亦不以二事道行三十七品。亦不以二事道行萨云若。复次拘翼。若善男子善女人。以无央数方便持般若波罗蜜。教化众生。使学受持讽诵解说广演其义。不以二事观般若波罗蜜。亦不以相亦不以无相。亦不合亦不散。亦不应非不应。亦不举亦不下。亦不着亦不断。亦不生亦不灭亦不持非不持。亦不处非不处。亦不实亦不虚。亦不垢亦不净。亦不信非不信。亦不法非不法。亦不如非不如。亦不真际非不真际。如是拘翼。善男子善女人受持般若波罗蜜。授与他人使讽诵学。事事分别解说其义章句分明。持是教人所得功德。胜自讽诵守行其事。若善男子善女人。自学般若波罗蜜。讽诵解说身自供养。复教他人令讽诵学为解中义分别。其慧明了具足者。是善男子善女人。所得功德最倍益多。释提桓因白佛言。世尊。是善男子善女人。受学般若波罗蜜者。当具足受解其句义。佛言。如是如是。拘翼善男子善女人受学般若波罗蜜者。当具足受解其句义。如是受学者。是善男子善女人。得无央数不可计善本之德。若有善男子善女人。尽其形寿供食十方诸佛如来随其所乐。其人殖福宁为多不。释提桓因言。甚多甚多。佛言。故不如是善男子善女人以无央数方便持般若波罗蜜授与他人。使学守行具足解慧了其句义者。所得功德福最甚多。何以故过去当来现在诸佛本行菩萨道时皆于般若波罗蜜中学。成得阿惟三佛。其有学者亦当复成阿惟三佛。复次拘翼。善男子善女人于阿僧祇劫行檀波罗蜜。不如是善男子善女人受持般若波罗蜜。广教众生而无所猗。拘翼。菩萨行檀波罗蜜若有所猗。生意念言我施与彼。作如是者为住布施。不成檀波罗蜜。言我持戒是我所戒。便住于戒不成尸波罗蜜。言我忍辱以是故忍。便住于忍为不成羼波罗蜜。言我精进有所为进便住于精进为不成惟逮波罗蜜。言我行禅有所为禅。便住于禅为不成禅波罗蜜。言我行智。便念于智以住于智。为不成般若波罗蜜。拘翼善男子善女人作是行者。不成六波罗蜜。释提桓因白佛言。菩萨摩诃萨作何等行当成六波罗蜜。佛告释提桓因言。菩萨布施亦不自有亦不有所施亦不有受者。是为行檀波罗蜜。至般若波罗蜜亦不有亦不得。是为菩萨具足行六波罗蜜。拘翼。若善男子善女人行六波罗蜜及其义解。当作是知。何以故。后当来世当有善男子善女人。发意欲得阿耨多罗三耶三菩。住于般若波罗蜜。不具足闻般若波罗蜜及其义解。或不成阿耨多罗三耶三菩。是故当为是辈人。具足解说般若波罗蜜中慧。释提桓因白佛言。何等为人说般若波罗蜜。佛告释提桓因言。若有善男子善女人说般若波罗蜜。说已当复说。释提桓因白佛言。云何善男子善女人说般若波罗蜜。说已当复说。佛语释提桓因言。若善男子善女人新入般若波罗蜜者。当为说般若波罗蜜。为说已当复说。为新入者说色无常。当为作如是说。如是行者为行般若波罗蜜。如是说者为念五阴无常。善男子善女人。作如是说五阴无常者。为欲初向行般若波罗蜜。说十二衰无常苦空行六波罗蜜。说十八性无常苦空行六波罗蜜。说五阴苦空行六波罗蜜。说四禅四等四空定无常苦空行六波罗蜜。说三十七品十八法至萨云若。说无常教非常苦空。作如是说作如是解。是为教新发意者行般若波罗蜜。拘翼。新学初发意者当作是行。复次拘翼。若善男子善女人。深入学者说般若波罗蜜时。当语是新学初发意者言。汝当受念六波罗蜜。受已当住第一菩萨地。从第一至第二至十住。作是想有着想有猗想。作是念般若波罗蜜。拘翼。是为新发意行般若波罗蜜者。复次拘翼。是善男子善女人复作是教言。汝当作是念般若波罗蜜。作是念已出过罗汉辟支佛上。是为新发意者行。复次拘翼。有行菩萨道者。当语新学者言。当受是般若波罗蜜。当得无所从生法忍。得是忍已便住神通。从一佛国至一佛国礼事恭敬诸佛世尊。复次拘翼。深入学者当教新学初发意者言善男子善女人汝当作是受学般若波罗蜜。作是持念。作是念已。汝便当得不可计无量之功德善福。是为教新发意者行。复次拘翼。深入学者。当教新学者言。善男子。汝当学过去当来今现在诸佛所行善本所作功德。当一心念至得阿耨多罗三耶三佛。是为教新学者行。释提桓因白佛言。作是念说已当复云何教新学者乎。佛告释提桓因言。深入学者。当复教新学者言。善男子当受念般若波罗蜜。念般若波罗蜜者。莫观五阴无常。何以故。五阴所有自空五阴所有者无所有也。无所有者非五阴。般若波罗蜜中五阴无有常与无常。般若波罗蜜中尚不见五阴。何况当有常无常耶。拘翼。善男子善女人。作如是说为不教新学著者。当复教新学著者。汝当受念般若波罗蜜。念般若波罗蜜于诸法莫有所过莫有所住。何以故。般若波罗蜜者亦无有法可过者有住者。何以故。法自空。有空者无所有。无所有者般若波罗蜜。般若波罗蜜中无有法可应不应者。亦无有生与不生法。善男子善女人作如是说。是为不教新学著者。拘翼善男子善女人说般若波罗蜜中义当如是。善男子善女人。作如是教所得功德多于前者。复次拘翼。善男子善女人。教一阎浮提众生令得须陀洹道其福多不。释提桓因言。甚多甚多世尊。佛言。不如是善男子善女人以般若波罗蜜授与他人使学书持为解说其义。得其功德甚多甚多。教是善男子善女人。般若波罗蜜随其上教习学守行。何以故。诸须陀洹道者皆从般若波罗蜜出生故。复次拘翼。置是阎浮提诸四天下及三千大千国土。东方如恒边沙国土。满中众生尽教令得须陀洹道。其福宁多不。释提桓因言。甚多甚多世尊。佛言。不如是善男子善女人以般若波罗蜜授与他人。使学书持讽诵行习解说其慧。得其功德甚多甚多。何以故。须陀洹道皆从般若波罗蜜出生故。复次拘翼。若阎浮提满中众生尽教令得须陀洹斯陀含阿那含阿罗汉。其福宁多不。释提桓因白佛言。甚多甚多世尊。佛言。不如是善男子善女人。以般若波罗蜜授与他人使学书持讽诵奉行。如其中教解说慧义。得其功德甚多甚多。何以故。须陀洹道至阿罗汉皆从般若波罗蜜出生故。复次拘翼。置是一阎浮提及三千大千国土如恒边沙国土满中众生。尽教令得须陀洹道至阿罗汉其福多不。释提桓因白佛言。甚多甚多。佛言。不如是善男子善女人以般若波罗蜜授与他人。使学书持讽诵奉行。随其中教解说慧义。得其功德甚多甚多。复次拘翼。一阎浮提满中众生。尽教令得辟支佛道其福多不。释提桓因言。甚多甚多世尊。佛言。不如是善男子善女人以般若波罗蜜授与他人。使学书持讽诵奉行。随其中教解说慧义。得其功德甚多甚多。何以故。诸辟支佛皆从般若波罗蜜出生故。复次拘翼。置是阎浮提及三千大千国土。如恒边沙国土众生。尽教令得辟支佛道福多不。释提桓因言。甚多甚多世尊。佛言。不如是善男子善女人以般若波罗蜜授与他人。使学书持讽诵奉行。随其中教为解慧义。得其功德甚多甚多。何以故。诸辟支佛皆从般若波罗蜜中出生故。复次拘翼。若有善男子善女人。教一阎浮提及恒边沙满中众生。劝助令发阿耨多罗三耶三菩意。不如是善男子善女人以般若波罗蜜授与他人。教使书持讽诵奉行。为解慧义其德甚多。语其人言。受般若波罗蜜当随中教。随是教已当得萨云若利。得是利已便具足般若波罗蜜。汝便当成阿耨多罗三耶三菩。何以故。初发意菩萨皆从般若波罗蜜出生故。复次拘翼。若有善男子善女人。教一阎浮提及恒边沙满中众生。教令立于阿惟越致。其福宁多不。释提桓因言。甚多甚多世尊。佛言拘翼。不如是善男子善女人持般若波罗蜜经卷授与他人解说中事。及其义慧使宣行之。语其人言。受持是般若波罗蜜经卷。如上所教皆习奉行。汝便当得诸法之利。至得阿耨多罗三耶三菩。何以故。菩萨摩诃萨阿惟越致地皆从般若波罗蜜出故。复次拘翼。尽一阎浮提其中众生。悉为阿耨多罗三耶三菩不复转还。若善男子善女人。为是辈人说般若波罗蜜及其义解。而为说之。若有一人言。我欲疾成阿耨多罗三耶三菩。若有善男子善女人。为是一人说般若波罗蜜。具足其义分别解说。其福最多。释提桓因白佛言。世尊。菩萨摩诃萨务欲成阿耨多罗三耶三菩者。务当教是菩萨令行六波罗蜜。当教内外空及有无空。三十七品佛十种力。四无所畏四无碍慧佛十八法。当以是法教是辈人。给其所须衣服真越所有供养。以是二事法。供食是辈菩萨摩诃萨。世尊。是善男子善女人所得福最尊。胜前所作者。所以者何。世尊。菩萨摩诃萨教人行六波罗蜜。当如是教人行内外空及有无空。三十七品乃至佛十八法。亦当如是。须菩提语释提桓因言。善哉善哉。拘翼。乃劝助是善男子善女人求菩萨道者。乃尔如卿为佛作贤弟子之法。当益于菩萨摩诃萨。以持法施及供养施护养菩萨。劝助使成阿耨多罗三耶三菩。何以故。诸佛及弟子众皆从是二事施中出。若菩萨不发阿耨多罗三耶三菩意者。是菩萨终不能学六波罗蜜及佛十八法。若菩萨不学六波罗蜜及佛十八法者。终不成阿耨多罗三耶三菩。亦不知有罗汉辟支佛。以菩萨学六波罗蜜及佛十八法故。得成阿耨多罗三耶三菩。三恶趣便断。世间乃知有刹利梵志长者大姓种便知有四天王及无思想无思想慧天。便知有六波罗蜜。从内外空及有无空三十七品佛十八法。世间便知有声闻辟支佛乘

    摩诃般若波罗蜜劝助品第四十

尔时弥勒菩萨摩诃萨语须菩提。菩萨摩诃萨所作劝助福祐之像。与众生共为阿耨多罗三耶三菩。无所希望出过众生。诸声闻辟支佛所作劝助福祐者上一切众生。发声闻辟支佛乘者。所作布施福祐之像。持戒自守一心福像。不如是菩萨摩诃萨劝助之福与众生俱共为阿耨多罗三耶三菩。其福最尊为最第一。具足无有过上者。所作劝助皆为众生成阿耨多罗三耶三菩。何以故。罗汉辟支佛所作布施之福持戒自守。但欲自调但欲自净但欲自度。念三十七品念三脱门。但以自调而欲自度。菩萨但欲调众生欲净众生欲度众生。劝助众生为阿耨多罗三耶三菩。须菩提白弥勒菩萨摩诃萨。是菩萨摩诃萨于东方无央数诸佛刹土。无央数般泥洹佛。从发意至阿耨多罗三耶三佛。至般泥洹乃至法灭尽。从其中间所作善本应六波罗蜜。及诸声闻缘觉。所作布施功德持戒自守及诸无漏之戒。从行戒至无戒善本。乃至诸佛净戒之福。三昧之福。智慧之福解脱之福见解脱慧之福。及大慈大悲无量阿僧祇佛所说法。从其法中所闻受者。有得须陀洹至得阿罗汉辟支佛。上至菩萨及诸般泥洹佛所作功德。都计之合之。劝助为尊最为无上最为具足。我亦复持是功德。如是劝助功德福。是为作阿耨多罗三耶三菩中劝助。是便为成阿耨多罗三耶三菩。是善男子善女人为菩萨道者。或当作是念。如过去诸佛世尊所作功德。使我得是意。使我发是意行。使我得是想念。弥勒菩萨告须菩提。善男子善女人发菩萨意者。不以是因缘不以是像不作是想。于阿耨多罗三耶三菩。须菩提语弥勒菩萨。若不以是得若不以是因缘。诸佛世尊何以故于想十方世界从十方佛。从初发意至于法尽。诸善本及发声闻乘。我所从戒至无戒功德尽计之合之。而求阿耨多罗三耶三菩。应无有想。将无作颠倒想。无常谓有常。用想颠倒用意颠倒。用见颠倒。不净谓净苦言有乐无我谓我。用想颠倒用意颠倒用见颠倒。其事虚空亦如因缘亦如。道意亦尔六波罗蜜亦尔。乃至十八法亦尔。若如事者亦如。道意六波罗蜜亦如是。五阴六情亦如是内外空及有无空三十七品及十种力佛十八法。何等为事何等为因缘。何等为道何等为诸善本。何等为劝助意。何等为劝助对意。所可求阿耨多罗三耶三菩者。弥勒菩萨语须菩提。若有菩萨行六波罗蜜。见过去佛供养承事诸佛。与善知识相得。若已自学身空。是辈之人不以事像。不以是因缘。不以是佛善本之相。不以劝助功德。不以是诸福作想求阿耨多罗三耶三菩。当复更作是意求。令不堕二法亦不不二。亦不以想亦不以无想。亦无所猗亦非不猗。亦不以着亦不以断。亦不以生亦不以灭。若是菩萨不学六波罗蜜。若不供事诸佛。若无诸善之本。若不与善知识相得。若不自学空。便以是事。以是因缘。以是劝助功德。以是诸事起想。求阿耨多罗三耶三菩。是故须菩提。不当为初发意菩萨前说六波罗蜜。及内外空有无空及诸法空。不当为新学菩萨说之。何以故。若新学者或亡所信或亡所乐。所有恭敬皆悉亡失。便坏诸善本。当为阿惟越致菩萨摩诃萨说之。若久与善知识相随者亦可与说。从前过去于诸佛所作功德者。当与是辈人可说空相法。是人闻是不恐不怖亦不畏惧。菩萨摩诃萨当作如是劝助。所可劝助意。所可求阿耨多罗三耶三菩。是意已灭尽无所复有。所可作者及诸因缘所作功德亦复灭尽。何等为劝助意。何等为众事。何等因缘。何等为善本功德。而求阿耨多罗三耶三菩者。持意有所求耶。意无两对如意之性而无所求。若有菩萨行般若波罗蜜。至六波罗蜜亦无所有。至于五阴亦无所有。至道亦无所有。若有菩萨求阿耨多罗三耶三菩。当作是知当作是求。当作是劝助。当作是善本。如是求为求阿耨多罗三耶三菩。弥勒菩萨语长老须菩提言。新学菩萨闻是将无恐怖。当云何作诸善本功德而有所求。云何劝助及诸功德持。作阿耨多罗三耶三菩。须菩提语弥勒菩萨。新学菩萨行般若波罗蜜受持六波罗蜜。无所猗受而无所想。当解内外空及有无空。解三十七品佛十八法。常与善知识相得得六波罗蜜及其义趣。教授令不离六波罗蜜。至得菩萨道。不离佛法教语魔事。闻魔事已不增不减。何以故。至得菩萨道常念诸法不离诸佛。于中作功德受持诸菩萨宗。至得阿耨多罗三耶三菩不离是功德新学菩萨于诸十方无央数佛如来无所著等正觉。及诸弟子所作功德。及诸刹利梵志大姓。及四天王首陀会诸天所作功德。皆劝助之。持是劝助功德。求阿耨多罗三耶三菩。其功德最上无过者。是时弥勒菩萨语须菩提言。若有新学菩萨。念诸佛及弟子所有劝助功德。持无上无比劝助无央数劝助功德。求阿耨多罗三耶三菩。于想念见而不颠倒。须菩提言。虽念诸佛及弟子众。于中无佛想亦无弟子众想亦无诸善本想意有所求亦无意想。菩萨作如是求。于想不倒于念不倒于见不倒。若菩萨念诸佛及众僧功德念所作善本。持想求阿耨多罗三耶三菩。是为菩萨想倒念倒见倒。菩萨虽有是念。念佛及众念诸善本。虽有是念。当知是念尽灭无所有。所可尽者无所求。意有所求是意之法。所可求法亦是其法。虽作是求是为正求不为邪求。菩萨摩诃萨当作是求。是为过去当来今现在诸佛及诸弟子所作功德。下至凡夫所作功德。所听受法及诸天阿须伦真陀罗摩睺勒所作功德。及诸刹利梵志大姓长者所作功德。及四天王上至首陀会天所作功德。所听受法所可发意求阿耨多罗三耶三菩。都卢合之聚之计之称之。是所作功德皆劝助之。持是劝助功德。求阿耨多罗三耶三菩。若当知是法已尽已灭。无所复有所可求法。亦复尽空。若作是求为求阿耨多罗三耶三菩。当作是知法不求法。何以故。诸法皆自空故。作是求者为求阿耨多罗三耶三菩。菩萨如是行六波罗蜜者。于想不倒于念见亦不倒。何以故。不入所求故。于诸善本及其道意不见当有所入处故。是为菩萨无上之求。菩萨摩诃萨于诸功德寂而无所生。于五阴十八性及六衰至六波罗蜜亦寂无所生。于内外空及有无空佛十八法亦寂而无所知。菩萨如是知寂无所得者。是为求阿耨多罗三耶三菩。若菩萨摩诃萨知劝助功德。劝助功德寂无所生。佛寂及佛事寂。诸善本事善本事寂。诸道意事道意事寂。诸所求事所求事寂。诸菩萨事菩萨事寂。六波罗蜜事六波罗蜜事寂。乃至佛十八法佛十八法寂。如是菩萨当寂净行般若波罗蜜。是为菩萨行般若波罗蜜。诸过去佛所作善本有所求索尽般泥洹。菩萨摩诃萨亦当作是求。所作善本及于所求当如泥洹。意有所索意与所求适等无异作如是求作如是知。是为求阿耨多罗三耶三菩。作如是求者想不颠倒念不颠倒见不颠倒。若复菩萨以想行般若波罗蜜。以想念诸佛功德。是为不求阿耨多罗三耶三菩。过去诸佛亦不有想亦不无想。若复作念若复作想。如是为不求阿耨多罗三耶三菩。是为想颠倒念颠倒见颠倒。若复不念诸佛善本诸所有发意亦不作知亦不作想。是则为求阿耨多罗三耶三菩。是为菩萨想不颠倒念见不颠倒。弥勒菩萨语须菩提。云何菩萨有所求而无有想。须菩提言。菩萨欲得沤和拘舍罗。当于般若波罗蜜中学。不求般若波罗蜜终不得诸善本功德。何以故。诸佛世尊亦不于般若波罗蜜中现。及诸善本亦不见众事亦不见意。可作阿耨多罗三耶三菩。所作已灭众事亦灭。我但以自起是诸想诸善功德及诸发意。诸佛世尊亦无想求。亦无有是劝助亦无是知。何以故。用想求无所得故。若想有可得者。我及诸佛所作分别想当有所得。是故菩萨功德菩萨有所求。亦不当作想亦不当有所倚。诸佛世尊不称誉倚想求者。何以故。想求者为杂毒。譬如净洁美食与毒相得。色虽香美故为杂毒。若有愚痴之人欲得食之。虽为当时贪其色好香。可口久后不便其身。作如是受不谛观。不谛知不知讽诵倒解中义自不能解。为他人说言。善男子。是教是过去当来今现在佛。从发意以来至得阿耨多罗三耶三菩。于有余泥洹至无余泥洹乃至法尽。于其中间行般若波罗蜜。所作功德及六波罗蜜。所可行三十七品。四禅四等及四空定。十种力十八法所作善本。及净佛国教授众生。诸佛戒品三昧品。智慧品解脱品见解脱慧品萨云若慧。无所亡法常等行于声闻中所作功德。诸佛世尊所记辟支佛。诸天尊神阿须伦迦留罗真陀罗摩睺勒所作功德。都卢合聚此诸功德。持求阿耨多罗三耶三菩。倚想求三耶三佛。是则譬如杂毒之食。有倚想者终无所成。何以故有倚有想而有形貌有杂毒。求为谤如来亦不受如来教亦不受法。善男子善女人。行菩萨道者。当作是念。过去当来今现在诸佛世尊。从发意以来至得佛。云何有所作求。及诸弟子至萨云若中事所作上亦如是。当云何有所作而求阿耨多罗三耶三菩。善男子善女人。求菩萨道。不欲高下如来者当作是求。如诸佛世尊所知识。以辩才慧诸善本之相与法相应者。我持是劝助。我所求阿耨多罗三耶三菩者。皆是诸佛所知。诸善男子善女人。求菩萨道者不倚诸善本功德。求阿耨多罗三耶三菩。如是求者为不高下如来。是为信佛信法菩萨。如是行者为不杂毒。所求为无有毒。若善男子善女人。求菩萨道行般若波罗蜜者。所为功德当作是求。五阴亦不着。欲界色界无色界亦不着。过去当来今现在六波罗蜜亦不着。三界亦不着。去来今内外空及有无空。三十七品佛十种力及十八法亦不着。三界亦不着。去来今如及尔法生法灭真际不思议性戒忍智解脱解脱见慧萨云若无所亡法。常等行亦不着。三界不着三界者亦无去来今。何以故以无所入故。有所求者亦无所入。所可求法亦复无所著。是人亦复无所著。诸佛世尊亦复无所著。诸余善本亦无所著。声闻辟支佛诸善本亦无所著。诸无所著者亦非去来今。若有菩萨行般若波罗蜜。知五阴不着。三界亦非去来今亦不可以倚想有所求。何以故。不见有所生者。诸无所生者亦无所有。无所有者不能有所为。六波罗蜜乃至无所亡法及常等行亦不着。三界亦非去来今。非去来今者亦不可以倚想有所为。何以故。是所生不可得故诸所生者为无所有。无所有者亦不能有所为。是为菩萨不杂毒求。若有善男子善女人。求菩萨道有倚想者。则为邪求所作善本倚想求者是为邪求。诸有邪求者诸佛世尊所不称誉。佛所不称誉者为不具足六波罗蜜。不具足六波罗蜜者则不具足三十七品。则不具足内外空及有无空佛十种力。及十八法则不具足。不具足十八法者则不能净佛国土。则不能教授众生。终不成阿耨多罗三耶三菩。所以者何。有杂毒求。故菩萨摩诃萨行般若波罗蜜者。当作是念。如诸佛所知善本功德法求。如所求为求阿耨多罗三耶三菩。我亦当以是法求阿耨多罗三耶三菩。是时佛赞叹须菩提言。善哉善哉。须菩提。乃作世尊之行。能为诸菩萨说所为所求之法。无想无所倚无所出。亦不断亦不着。亦不有亦不无。应空相。应法性。应如行。佛告须菩提。假令三千大千刹土中众生。悉得十善之利。悉得四禅四等四空定。及五通尽得是利于须菩提意云何。是众生所得福宁多不。须菩提白佛言。甚多甚多世尊。佛言。不如是善男子善女人。于诸善本无所生无所著。以为阿耨多罗三耶三菩。是功德。最为尊化无上正真之化具足之化。复次须菩提。若三千大千刹土中众生。尽得须陀洹上至罗汉辟支佛。若有善男子善女人。尽其寿命供养是辈。罗汉辟支佛随其所安饮食衣被床卧之具。病瘦医药尽诸所有。敬之养之。于须菩提意云何。其福宁多不。须菩提言。甚多甚多。佛言。不如是善男子善女人。住无所生无所著。于善本之德无所求。其福最尊最上。复次须菩提。假令三千大千刹土众生尽发阿耨多罗三耶三菩。十方恒边沙刹土中众生。一一众生供养是菩萨尽恒边沙劫。随其所安饮食衣服床卧医药瞻视恭敬承事。于须菩提意云何。其福宁多不。须菩提言。甚多甚多。世尊。其福多不可计不可数不可以譬喻比。若使福德当有形者。十方虚空所不能受。佛告须菩提。虽作尔所福德。不如是善男子善女人。所作善本无所生无所著。于善本之德无所求。是善男子善女人之功德。最尊最上无比无上之化。是无所生无所著之功德。与前功德百千亿万倍不相比。何以故。是善男子善女人有倚有想。于十善事及四禅四等四空定五通尽具足。何以故。是善男子善女人以倚想供养。诸声闻辟支佛上至菩萨故。尔时四王天上二万天子。皆叉手礼佛足白佛言。世尊。菩萨所施为沤和拘舍罗甚善快哉。所作已应无倚无著应空无相。所施善本为阿耨多罗三耶三菩。所施为不二入。是时释提桓因与无央数忉利诸天及诸天子。持天杂花香捣香泽香缯彩花盖。天衣天幔杂色幢幡。鼓天伎乐。来至佛所供养散佛。皆赞叹言。菩萨所施为沤和拘舍罗甚善快哉。所作已应无所倚无所著应空无想。所施善本为阿耨多罗三耶三菩。所施为不二入。上至梵迦夷天无央数百千。亦复叹誉菩萨沤和拘舍罗皆复如是阿迦腻吒天与无央数亿百千诸天。来至佛所为佛作礼。俱发大音声言。世尊。甚奇大哉。于般若波罗蜜行沤和拘舍罗。所作善本其德胜前过去善男子善女人之所作为。于是佛告四天王及阿迦腻吒诸天子言。假令三千大千刹土所有众生。尽作阿耨多罗三耶三菩。复代过去当来今现在诸如来无所著等正觉代其欢喜。及弟子众从初发意至般泥洹乃至法尽于其中间所作诸善之本代其欢喜。声闻辟支佛所作诸善之本代其欢喜。及众生所作诸善之本行檀波罗蜜至般若波罗蜜代其欢喜。诸贤圣所有戒品三昧品智慧品解脱品解脱见慧品代其欢喜余无量佛法都卢计校合聚。是上诸功德皆代其欢喜。倚是代欢喜功德。为阿耨多罗三耶三菩。若复有善男子善女人。欲发阿耨多罗三耶三菩。代过去当来今现在诸如来无所著等正觉及罗汉辟支佛。从发意至成阿耨多罗三耶三菩。从其中间行六波罗蜜。及余无央数佛法功德代其欢喜。而无所希望亦不二入。已应无相应无所著应空。是为最第一代其欢喜。为无上代欢喜也。持是代欢喜功德。为阿耨多罗三耶三菩。而无所倚者。其功德福祐胜于前善男子善女人所为代欢喜。比其功德百倍千倍巨亿万倍。是为菩萨摩诃萨最上代欢喜之所为也。尔时须菩提白佛言。如世尊所说合集是善男子善女人功德。于诸功德中无过代欢喜者。代欢喜之德无过是德。须菩提言。世尊。云何为最上。云何为最尊。佛告须菩提言。若善男子善女人于当来过去今现在法。无所取无所舍亦不贡高。亦不不贡高亦不有所倚。亦不无所倚。于是法亦无有生亦无有灭亦无著亦无断。于是法中亦不见增亦不见减。亦无往亦无反亦不道亦不俗。如去来今法。如反尔法所住法所灭法。我亦复代欢喜。持是代欢喜功德。为阿耨多罗三耶三菩。施菩萨摩诃萨。作如是施为代其欢喜最为第一。无过是代欢喜者。须菩提。作如是代欢喜。比余代欢喜之德。百倍千倍巨亿万倍。不及是代欢喜者。复次须菩提。善男子善女人。行菩萨道者欲代去来今诸佛及诸声闻辟支佛从初发意至于成佛。于其中间作诸善本。行六波罗蜜及余无数佛法善本。若欲代欢喜者。复欲代一切众生所作善本。当作是代欢喜。是代欢喜为最等。六波罗蜜与脱等。脱与五阴等。其脱之事与内外空等。解脱之事与有无空等。三十七品与解脱等。十力与解脱等。解脱与解脱见慧等。去来今法与解脱等。解脱则是过去当来今现在。解脱如诸佛世尊之所施为。解脱如诸佛弟子。诸佛弟子亦如解脱。解脱者与声闻辟支佛泥洹等。解脱事与诸佛世尊法等。解脱者亦如罗汉辟支佛。解脱亦如诸法之法。我于是无缚无脱之法。我于无著。如无污染清净之法。不生无所生不灭无所灭之法。我所施为于阿耨多罗三耶三菩者亦如是上诸法无所缚法无所败法无所坏法。佛告须菩提。是为菩萨摩诃萨无上代欢喜最为第一。佛言。菩萨摩诃萨具足作代如是欢喜者。疾逮阿耨多罗三耶三菩阿惟三佛。复次须菩提。若有善男子善女人。行菩萨道者。尽其形寿供养十方恒边沙佛及众弟子。随其所安饭食衣被床卧医药。尽诸佛形寿。般泥洹已后昼夜奉事舍利。幢幡花盖伎乐以为供养。常念行六波罗蜜而有所倚。复有善男子善女人。欲成阿耨多罗三耶三菩。行六波罗蜜沤和拘舍罗而无所倚。持是功德无所希望于阿耨多罗三耶三菩。比其善本功德。百倍千倍巨亿万倍。不及是代欢喜福德最尊最上。须菩提。菩萨摩诃萨行六波罗蜜。以沤和拘舍罗无所倚功德。为阿耨多罗三耶三菩而无所倚

放光般若波罗蜜经卷第八放光般若经卷第九

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜照明品第四十一

舍利弗白佛言。世尊。是般若波罗蜜耶。佛言是。舍利弗。舍利弗言。世尊。般若波罗蜜者作照明故。世尊。般若波罗蜜者至竟清净故。世尊。般若波罗蜜者为有名字。世尊。般若波罗蜜者于三界无沾污。世尊。般若波罗蜜者除诸垢冥。世尊。般若波罗蜜者于三十七品之最尊上。世尊。般若波罗蜜者安隐诸灾患恐怖者。世尊。般若波罗蜜者为五荒见蔽者作明故。世尊。般若波罗蜜者无际众生入邪径者而作正导。世尊。般若波罗蜜者萨云若。是能除诸习绪。世尊。般若波罗蜜者菩萨之母。生诸佛法故。世尊。般若波罗蜜者不生不坏。从有名至竟空故。世尊。般若波罗蜜者离于生死亦无所灭。不与作本故。世尊。般若波罗蜜者受诸孤穷者。为作珍宝施故。世尊。般若波罗蜜者具足初无能伏者。世尊。般若波罗蜜者三转十二事而转法轮。亦无能转者。所转终不动还故。世尊。般若波罗蜜者能现种种之本。及所有无所有空故。唯世尊。当云何住般若波罗蜜。世尊报言。当如世尊住。舍利弗。礼般若波罗蜜。当如礼世尊。何以故。般若波罗蜜者则是世尊。世尊与般若波罗蜜无有别。般若波罗蜜则是世尊。世尊则是般若波罗蜜。诸佛世尊因般若波罗蜜而得名字。菩萨辟支佛阿罗汉至须陀洹。皆因般若波罗蜜得其名字。十善四禅四等四空定五通。内外空及有无空。三十七品佛十种力及十八法乃至萨云若。皆因般若波罗蜜出生。于是释提桓因意念。何因尊者舍利弗乃生是问。释提桓因便问舍利弗言。尊者。何缘乃生是问。因何事有是问。舍利弗报言。拘翼。菩萨摩诃萨沤和拘舍罗。为般若波罗蜜所护持。及诸过去当来今现在诸佛世尊。从初发意以来至法欲尽。于其中间所作善本。尽持作萨云若。拘翼。是故菩萨摩诃萨持般若波罗蜜过五波罗蜜上。拘翼。譬如人生盲。或百人或千人或万人。欲有所至若欲入城。而无有导终不能有所至。拘翼。是五波罗蜜为如盲者。离般若波罗蜜如盲者无导。亦不能具足至道。亦不能成萨云若。五波罗蜜为般若波罗蜜所护。如盲者得眼目。般若波罗蜜护五波罗蜜。令五波罗蜜各得名字。释提桓因语舍利弗。如所言五波罗蜜因般若波罗蜜得名字者。五波罗蜜但有名而无度。舍利弗言。如是拘翼。五波罗蜜因般若波罗蜜而得名字。五波罗蜜但有名无有度也。菩萨住于般若波罗蜜者。为已具足五波罗蜜是故般若波罗蜜于五波罗蜜。为最上化妙化无比之化。舍利弗白佛言。世尊。当云何入般若波罗蜜中。佛言。如入五阴当作是入般若波罗蜜。如入五波罗蜜当作是入般若波罗蜜。如入内外空及有无空。如入三十七品佛十种力及十八法。如入萨云若如入诸法。当作是入般若波罗蜜中。舍利弗言。世尊。云何入五阴如入般若波罗蜜。云何如入诸法作是入般若波罗蜜。佛言。于五阴无所生无所得。无取无舍无所坏。当作是入般若波罗蜜。于诸法无所生无所得。无取无舍亦无所坏。是为入般若波罗蜜。舍利弗言。作如是入般若波罗蜜。为及何法。佛言。于诸法无所及是乃为般若波罗蜜名号。世尊。不逮何法。佛言。不逮善法亦不逮恶法。亦不逮道法亦不逮俗法。亦不逮有漏无漏法。亦不逮有为无为法。何以故。般若波罗蜜之兴。亦不为希望起。以是故于诸法无所及无所逮。释提桓因白佛言。云何世尊。是般若波罗蜜为不逮萨云若。佛言。如是拘翼。般若波罗蜜不逮萨云若。亦不逮亦不有。世尊。云何亦不逮亦不有佛言。般若波罗蜜者。亦不以字亦不以想亦不以生死。释提桓因言。世尊。亦不以字亦不以想亦不以生死云何为逮。佛言。如不入亦不受亦不舍亦不住。作是及如不及。拘翼。般若波罗蜜。如是逮诸法如无所逮。释提桓因白佛言。世尊。般若波罗蜜之兴甚奇甚特。于诸法无所生无所有无所倚无所坏。须菩提白佛言。若菩萨行般若波罗蜜。为逮诸法不逮诸法。菩萨闻是或恐或怖。便离般若波罗蜜。佛言。如是菩萨闻是或能恐怖。若有行般若波罗蜜菩萨。或作是念言。般若波罗蜜空。般若波罗蜜无有坚固。般若波罗蜜侵欺人。作是念者便能远离般若波罗蜜。以是因缘菩萨便远离般若波罗蜜。须菩提白佛言。信般若波罗蜜者。为不信何等法。佛言。信般若波罗蜜。为不信色。为不信痛想行识。为不信六情不信色声香味细滑法。为不信十八性及十二因缘乃至五波罗蜜。亦不信内外空及有无空。亦不信三十七品及十八法佛十种力。不信须陀洹至罗汉辟支佛。亦不信阿耨多罗三耶三菩。亦不信萨云若。佛告须菩提。若不有五阴及萨云若者。为不信般若波罗蜜。以是故须菩提。信般若波罗蜜者。为不信五阴诸法及萨云若。若不有五阴及诸法者。为不信般若波罗蜜。信般若波罗蜜者。为不信诸法。须菩提白佛言。世尊。般若波罗蜜者为大度。佛言。于意云何。何以知般若波罗蜜为大度。须菩提言。般若波罗蜜。亦不使五阴大。亦不令五阴小。亦不使五波罗蜜大。亦不令五波罗蜜小。从内外空至有无空亦不令大亦不使小。三十七品佛十八法亦不令大亦不令小。至道及佛法亦不令大亦不令小。亦不聚五阴亦不散五阴。乃至佛法亦不聚亦不散亦不平相。五阴亦不不平相。乃至佛法亦不平相亦不不平相。亦不广五阴亦不狭五阴。乃至佛法亦不广亦不狭。亦不使五阴强亦不使弱。乃至佛法亦不强亦不弱。世尊。以是故般若波罗蜜为菩萨之大度。世尊。若新发意菩萨。未习六波罗蜜者。闻是五阴及六波罗蜜无所增减无有广狭。闻是语者或能不行般若波罗蜜。何以故。不以般若波罗蜜故。五阴及佛法有大有小。不以般若波罗蜜故。五阴及佛法有强有弱。世尊。行般若波罗蜜。欲求大小五阴欲强弱佛法。是为大累。何以故。道初无有累想。何以故。众生不生般若波罗蜜不生。当作是见当作是知。五阴亦不生佛法亦不生。当作是观。观般若波罗蜜所有。如观众生所有。观般若波罗蜜所有。当如观五阴所有。观佛所有当如观般若波罗蜜所有。观般若波罗蜜无所有。亦如观五阴无所有。观般若波罗蜜无所有如观佛无所有。观般若波罗蜜无所有。如观众生亦无所有。观般若波罗蜜寂。观众生亦寂。观般若波罗蜜寂。观佛法亦寂。观五阴亦寂。观般若波罗蜜亦寂。观般若波罗蜜亦无有绪。当知众生亦无有绪。五阴及佛法亦无有绪。般若波罗蜜亦无有绪。般若波罗蜜不可思议。当知众生亦不可思议。五阴亦不可思议。及佛法亦不可思议。众生不败坏。当知般若波罗蜜亦不坏败。众生不逮阿惟三佛。当知般若波罗蜜亦不逮阿惟三佛。当知五阴亦不逮阿惟三佛。佛亦不逮阿惟三佛。众生力不具足。当知般若波罗蜜力不具足。五阴力不具足。佛力亦不具足。以是世尊大度者。是菩萨摩诃萨般若波罗蜜

    摩诃般若波罗蜜泥犁品第四十二

舍利弗白佛言。唯世尊。菩萨摩诃萨解般若波罗蜜者。为从何所来而生是间。发阿耨多罗三耶三菩为几何间。为更见供养几如来。行六波罗蜜为几时。云何解般若波罗蜜导入深义。佛告舍利弗。是菩萨摩诃萨供养十方诸如来无所著等正觉。从彼来生是间。是菩萨从发意以来。不可计阿僧祇劫。行六波罗蜜亦不可计。来到是间。从是以来不可复计。常供养诸佛而来生是间。是辈菩萨见般若波罗蜜时。如见世尊无有异。若闻般若波罗蜜时。如闻世尊所说亦无有异。是菩萨摩诃萨解般若波罗蜜导入深义。不以想入不以二入而无所倚。须菩提白佛言。世尊。般若波罗蜜可得见闻不。佛言。不可得见闻。何以故。须菩提。般若波罗蜜者亦非见事亦非闻事。般若波罗蜜者亦无所闻亦无所见。以诸法聋故。五波罗蜜者亦不见亦不闻。以诸法聋故。内外空及有无空无所闻无所见。以诸法聋故。三十七品十种力十八法无所见无所闻。以诸法聋故。须菩提。道及佛亦无所见无所闻。亦如聋法故。须菩提白佛言。菩萨摩诃萨学般若波罗蜜久如当与般若波罗蜜相应。佛语须菩提。是事应当分别。须菩提。有因缘令菩萨适发意。便应深般若波罗蜜。以沤和拘舍罗不见诸法荣冀。终不诽谤。终不离六波罗蜜。终不离诸佛世尊。若复欲作诸善之本供养承事诸佛世尊者。即如意愿从一佛国至一佛国。终不复受母人胎生。终不离五通。不与诸垢相近。亦不与声闻辟支佛意相近。教化众生净佛国土。菩萨如是行者为应深般若波罗蜜。须菩提。复有善男子善女人行菩萨道者。见无央数不可计阿僧祇诸佛。行六波罗蜜而有所倚。闻说深般若波罗蜜便弃舍去。如是菩萨更生慢意。便离诸佛世尊。便不得闻深般若波罗蜜。佛语须菩提。不乐闻深般若波罗蜜者。今亦在会中坐何以故。是善男子善女人行菩萨道时。从本闻深般若波罗蜜。不乐舍去。用是故今闻深般若波罗蜜。不乐复欲舍去。与身口意不和。积无黠之罪。以是罪重故拒逆深般若波罗蜜。拒逆深般若波罗蜜者。为拒逆过去当来今现在诸佛萨云若。已以逆萨云若罪故断萨云若。用断萨云若罪故当入泥犁中见煮。无央数百千岁从一泥犁出复至一泥犁。至劫尽火烧时。当复至他方大泥犁中。他方劫尽当复从他方一泥犁中复至一他方泥犁中。如是遍诸他方泥犁。以用是断法罪故当复更来生是间泥犁中。当受泥犁中剧痛之罪。至劫尽当堕他方畜生中。如是展转遍堕十方诸畜生中。从畜生中出当生炎楼。受薜荔形极剧勤苦。如是久后才得为人。所生之处。常当生盲家或生杀人家。或生鱼猎家屠杀家。或生下贱乞丐人家。或盲或聋或无手足。或喑哑不能言。受是罪已当复生边地无佛无法无弟子处。作是断法者皆当具足受是上罪。舍利弗白佛言。是断法者为入五无间罪。佛言。如是断法之罪不可具说。说是般若波罗蜜时。若断他人言。是非律是非尊教。是非如来无所著等正觉之教。自不修学。复断他人令远离之。自丧其意复丧他人意。自毒其意复毒他人意。为自亡失复亡失他人。自不解深般若波罗蜜而弃舍去。复教他人令远离之。舍利弗。是曹之人尚不当闻其音声。何况当与共从事而同处坐起。何以故。当知是辈人法中之大患。当知是人为堕衰冥。若闻是辈人所说有信受者。亦当复受不测之罪。舍利弗。断般若波罗蜜之人。当知是为法中之大病。舍利弗言。世尊。是谤法之人。在所生处受其身形宁可说不。佛言。置是谤法之人所生受形。何以故。是人傥闻其身热血从口中出。其人愁忧或病或死或痿黄。熟受是苦痛糜死之罪。若使无是辈罪者。世尊终不使舍利弗发是问也。有如是痛者所受身形。以是故如来不为舍利弗说。舍利弗言。世尊。当说是断法之人所受身形。世尊。所说者当为后世而作大明。佛言。我属所说诽谤断法所可受罪。所更泥犁展转劫数。受畜生身受薜荔形。所更劫数以受人身盲聋喑哑下贱乞丐。所更如是。则为后世作大明。已闻是教者则不敢复断法诽谤。舍利弗言。世尊。善男子善女人各当自念。我闻是语其心恐怖。我终不敢有是辈事。尽我形寿终不敢断法诽谤。如彼我若诽谤或堕恶处勤苦如是。须菩提白佛言。世尊。善男子善女人常当摄身口意行。意当念言。我等不当受是坏法之罪。不见如来而不见法不见众僧。或生无佛处或堕贫家。或生抵突不闻法处。须菩提白佛言。世尊。以口行故便受坏法深重之罪耶。佛言如是。以口过故便受坏法深重之罪。须菩提。当来之世或有愚人。于善法教为我作沙门。反诽谤远离深般若波罗蜜。诽谤远离深般若波罗蜜者。为已诽谤诸如来无所著等正觉之道。已诽谤如来道者。则为诽谤远离过去当来现在诸佛萨云若。已诽谤萨云若者则为远离法。已远离法者则为远离僧。已远离僧者则为远离世间正见已远离正见者则为远离三十七品萨云若已离萨云若者则为受不可计阿僧祇劫之罪身。受是罪身者则为受不可计阿僧祇劫愁悲苦恼。须菩提白佛言。世尊。愚痴之人远离深般若波罗蜜为有几事。佛言。有四事。何等为四。一者为魔所使二者不信不解深法不爱不乐三者与恶知识相得。不应顺行入于五阴。以是三事远离深法。四者是愚痴人多行嗔恚。喜自贡高訾蔑他人。以是四事故。愚痴之人远离深般若波罗蜜。须菩提白佛言。深般若波罗蜜难了。何以故。解不随顺。不应善本。恶友相得。佛言。如是须菩提如汝所言。须菩提复白佛言。世尊。云何深般若波罗蜜难了难知。佛报言。须菩提。五阴不缚不解。何以故。色色自有性。痛痛自有性。想想自有性。行行自有性。识识自有性。六波罗蜜亦不缚亦不解。何以故。六波罗蜜所有无所有故。内空外空及有无空亦不缚亦不解。何以故。内外空亦无所有故。须菩提三十七品至佛十八法乃至萨云若。萨云若事亦不缚亦不解。何以故。所有者皆无所有故。五阴过去亦不缚亦不解。何以故。诸阴过去空过去空故。须菩提。乃至萨云若过去亦不缚亦不解。何以故。萨云若过去空故。须菩提。当来五阴亦不缚亦不解。何以故。当来五阴空故。乃至萨云若亦复如是。现在五阴亦不缚亦不解。何以故。现在五阴空故。乃至萨云若亦复如是。须菩提言。世尊。解不随顺无有善本。恶友相得。懈怠之人无慧进者喜乱志者。是辈之人不能解深般若波罗蜜。佛言。如汝所言。是辈之人不能解说深般若波罗蜜。须菩提。五阴净者则道亦净。以道净故所得果净。须菩提。以五阴净则般若波罗蜜净。般若波罗蜜净则五阴净。以五阴净则萨云若净。以萨云若净则五阴净。五阴与萨云若则一无有二。亦不破亦不坏。须菩提。五阴无有二净。萨云若亦无二净。一法无二。众生知见寿命亦净。众生亦净萨云若净。一净无有二。须菩提。吾我净萨云若净知见寿命净五阴萨云若一净无二。亦不断亦不破。须菩提。淫怒痴五阴萨云若净一净无二。须菩提。痴净。已痴净则行净。已行净则识净。已识净则名色净。已名色净则六入净。已六入净则栽净。已栽净则觉净。已觉净则爱净。已爱净则受净已受净则有净。已有净则生净。已生净则死净。已死净则六波罗蜜净。已六波罗蜜净则内外空及有无空净。已有无空净则三十七品净。已三十七品净则萨云若净。萨云若净是为一净无有二。亦无破亦无断。须菩提。般若波罗蜜净五阴净萨云若净。一净无二净。五波罗蜜净萨云若净。内外空及有无空净萨云若净。三十七品净。萨云若净。十八法净萨云若净。须菩提。萨云若净乃至般若波罗蜜净等无有异。须菩提。有为净无为净一净无有二。须菩提。过去净当来净现在净。过去当来今现在净一净无二。亦不坏亦不断。以是故为净

    摩诃般若波罗蜜明净品第四十三

舍利弗白佛言。世尊。净为甚深。佛言。常净。舍利弗言。世尊。何以故。常净。佛言。五阴净故常净。舍利弗。三十七品十种力及十八法道净佛净。萨云若萨云若事净故净甚深。舍利弗言。明净世尊。佛言。常净故。舍利弗言。何以故。明净。佛言。六波罗蜜净萨云若净是故明净。舍利弗言。世尊。泥洹净耶。佛言。常净。世尊。何以故。泥洹净。佛言。以五阴无边福亦无来无去萨云若无边福亦无来亦无去故。舍利弗言。世尊。净无所著。佛言。常净。世尊。何谁无所著净。佛言。以五阴性猛无所著常净故。至萨云若性猛无所著常净故。世尊。无所逮无所得净耶。佛言。常净。世尊。何以故。无所逮无所得净耶。佛言。五阴无所逮无所得净。至萨云若无所逮无所得净。世尊。无所生净。佛言。常净。世尊。何以故。无所生无所生净。佛言。无所生者是无所生净。至萨云若无所生无所生净。舍利弗言。世尊。不生三界净耶。佛言。常净。世尊。何以故。不生三界净耶。佛言。不有三界所有故不生为净。世尊。无所知净。佛言。常净。世尊。何以故。无所知净。佛言。诸法聋故无所知净。世尊知净。佛言。常净。世尊。云何五阴无所知净。佛言。五阴相空故无所知净。世尊。诸法皆净耶。佛言。常净。世尊。云何诸法净故净。佛言。诸法无所得故诸法净。舍利弗言。世尊。般若波罗蜜于萨云若。亦不作增事亦不作损事净。佛言。常净。世尊。何以故。般若波罗蜜于萨云若不作增损事净。佛言。法常住故。世尊。般若波罗蜜净诸法无所取。佛言。常净。世尊。云何般若波罗蜜净诸法无所取耶。佛言。法性不动转故。须菩提白佛言。吾我五阴净耶。佛言。常净。须菩提言。世尊。何以故。吾我净五阴净。何以故。常净。佛言。吾我无所有五阴无所有故常净。须菩提言。世尊。吾我净六波罗蜜净三十七品净。吾我净十力净十八法净。佛言。常净。须菩提言。何以故。吾我净乃至十八法净。佛言。吾我无所有乃至佛十八法亦无所有故净。世尊。吾我净须陀洹净乃至罗汉辟支佛净吾我净道亦净。佛言。常净。世尊。何以故。吾我净声闻辟支佛净乃至道佛道亦净耶。佛言。诸法相空净。世尊。吾我净萨云若净。佛言。常净。世尊。云何吾我净萨云若净常净耶。佛言。无有相不变故。须菩提言。世尊。二净无所得无所逮。佛言。常净。世尊。云何二净无所逮无所得常净。佛言。不着不断故。世尊。吾我净无所陷溺。佛言。无所生净。须菩提言。世尊。云何吾我五阴净无所生常净耶。佛言。空无边际故。须菩提白佛言。若菩萨摩诃萨作是知者是为行般若波罗蜜。佛言。常净。世尊。云何作是知为行般若波罗蜜。佛言。常净。世尊。云何作是知为行般若波罗蜜。佛言。知道事故。须菩提白佛言。假令菩萨行般若波罗蜜。以沤和拘舍罗者作是念。色亦不知色。痛想行识亦不知识。过去法亦不知过去法。未来法亦不知未来法。现在法亦不知现在法。佛语须菩提。得般若波罗蜜。行沤和拘舍罗菩萨。不作是念。行六波罗蜜。言我布施持是施为是施。至般若波罗蜜亦复如是。亦不言我作功德我有功德。亦不言我当得菩萨道。亦不言我教化众生净佛国土。亦不言我逮萨云若。诸行般若波罗蜜沤和拘舍罗者。亦不有是念。内空外空至有无空无是念故。须菩提。是为菩萨摩诃萨行般若波罗蜜。沤和拘舍罗为无所著。释提桓因问须菩提。善男子善女人。行菩萨道者何等为着。报言。拘翼。行菩萨道者。有意想。有施想。有六波罗蜜想。有内空外空及有无空想。有三十七品想。有十八法想。有十力想。有诸佛如来想。有供养诸佛功德想。都卢计之合之。持是想作阿耨多罗三耶三菩。拘翼。善男子行菩萨道者是为着。不能得无碍慧行般若波罗蜜。何以故。五阴性不可旨有所造设。乃至萨云若性亦不可旨有所造设。拘翼。菩萨摩诃萨所为。阿耨多罗三耶三菩。为诸众生劝助众生。为众生行檀波罗蜜。念众生故亦复劝助他人。使为众生行檀波罗蜜。不当作想行六波罗蜜。亦不当想行内空外空及有无空。亦不当想行三十七品。亦不当想行道。善男子善女人。作如是行。复劝助他人令作阿耨多罗三耶三菩。作是劝助者为不自堕落。亦不令他人离诸佛之劝助。如是善男子善女人。离诸际着。佛告须菩提。善哉善哉。令诸菩萨解诸际着。须菩提。谛听谛听善思念之。当更为汝说微妙着。须菩提叉手言。唯世尊愿乐欲闻。佛言。善男子善女人。发阿耨多罗三耶三菩想念如来。须菩提。适有想念便着于诸如来。从发意至于法尽。于其中间所作功德皆作想念。作是想念求阿耨多罗三耶三菩。随其想念则为着诸佛。弟子众及诸众生所作功德。持是想念作阿耨多罗三耶三菩。如所想如所著。何以故。不当以想念诸佛之功德。须菩提白佛言。般若波罗蜜甚深。佛言。诸法性寂故。须菩提言。世尊。般若波罗蜜者大有名字。佛言。般若波罗蜜。无有作者无能成者。无能得者亦无能逮者亦无能觉者。须菩提言。世尊。一切诸法无能逮得者。佛言。法性无二也。须菩提。诸法性无有若干一性。一性者则非性。非性者则非作。非作者亦不造。须菩提。法性一非造作。佛言。菩萨摩诃萨知一切法非作非造。则弃一切着际。须菩提白佛言。般若波罗蜜难晓难知。佛言。亦无知者亦无见者亦无得者无有识者亦无逮觉者。须菩提白佛言。世尊。般若波罗蜜者不可思议。佛告须菩提言。亦非意所生亦非五阴所生。亦非三十七品所生。亦非十力十八法所生

    摩诃般若波罗蜜无作品第四十四

须菩提白佛言。世尊。般若波罗蜜为无所作。佛报言。无有作者故。须菩提。乃至诸法亦无所有。世尊。菩萨摩诃萨行般若波罗蜜当云何行。佛言。菩萨行般若波罗蜜。不行色为行般若波罗蜜。不行痛想行识为行般若波罗蜜。乃至萨云若无所行为行般若波罗蜜。于五阴不念有常无常为行般若波罗蜜。乃至萨云若亦不念有常无常为行般若波罗蜜。于五阴无苦无乐为行般若波罗蜜。乃至萨云若亦无苦无乐为行般若波罗蜜。于五阴不有我无我为行般若波罗蜜。乃至萨云若。亦不有我无我为行般若波罗蜜。于五阴无净无不净。为行般若波罗蜜。乃至萨云若亦无净无不净。为行般若波罗蜜。何以故。五阴者亦不见有常无常。亦不见有苦有乐有我无我好不好。乃至萨云若亦复如是。复次须菩提。菩萨行般若波罗蜜。不具足行五阴。为行般若波罗蜜。乃至萨云若不具足行。为行般若波罗蜜。何以故。五阴不具足为非五阴。不作是行为行般若波罗蜜。乃至萨云若不具足为非萨云若。不作是行为行般若波罗蜜。须菩提白佛言。世尊。甚可奇特。行菩萨道者善说菩萨着。佛言。如是。如是。如来无所著等正觉。善说菩萨着不着事。复次须菩提。菩萨于五阴无所著。为行般若波罗蜜。眼耳鼻舌身意。于六情无所著。为行般若波罗蜜。于六波罗蜜无所著。为行般若波罗蜜。乃至萨云若不着。为行般若波罗蜜。须菩提。菩萨作如是行者。便知五阴着不着。亦复知萨云若着不着。知须陀洹道着不着。知声闻辟支佛道着不着。知三耶三佛道着不着。须菩提白佛言。世尊。甚奇甚特法甚深乃尔。说亦不增亦不减。不说亦不增亦不减。佛告须菩提。如是如是。如汝所言。须菩提。譬如诸如来无所著等正觉。尽寿称誉虚空亦不增。若谤毁虚空亦不减。譬如称誉幻人亦不增。若毁訾幻人亦不减。闻善亦不喜。闻恶亦不怒。须菩提。诸法之法亦复如是。若说若不说亦不增亦不减。须菩提白佛言。世尊。菩萨行般若波罗蜜。念般若波罗蜜甚难甚难。世尊。菩萨行般若波罗蜜不恐不怯。应阿耨多罗三耶三菩不复动转。何以故。世尊。念般若波罗蜜者为欲念虚空。虚空亦无有六波罗蜜。虚空亦无有五阴。亦无内外空及有无空。亦无三十七品。亦无十力亦无四无所畏亦无十八法。亦无须陀洹道亦无斯陀含道。亦无阿那含道亦无阿罗汉道。亦无辟支佛道。虚空亦无三耶三佛道。世尊。菩萨摩诃萨作是僧那僧涅者。当应为作礼。世尊。为众生精进为众生展力。为众生斗为众生作要誓者。为欲为空作精进为欲为空作要誓。世尊。为众生作要誓者为欲度空。是菩萨为大要誓。为虚空等众生作要誓者。为欲举空着虚空中。诸菩萨摩诃萨发阿耨多罗三耶三菩意者。为建大精进力。世尊。菩萨为众生发阿耨多罗三耶三菩意者。为建大誓已。世尊。是菩萨摩诃萨为大勇猛为虚空等众生发阿耨多罗三耶三菩。何以故。世尊。假令三千大千刹土。其中所有尽为如来。譬如丛林甘蔗竹苇稻麻草木药果诸树尽为如来。一一诸佛各说经法。或至一劫复过一劫。一一如来各度众生。无央数众不可复计。不觉众生之性有增有减。何以故。众生无所有寂故。世尊。置是三千大千国土。十方恒边沙一沙为一佛国。尔所佛国其中所有皆为如来。教化众生不可计量不可称度。众生之性无增无减。所以者何。一切众生皆空寂故。是故众生无始无终与空等故。世尊。以是故我作是说。欲度众生者为欲度空耳。有异比丘意念言。当为般若波罗蜜作字。于般若波罗蜜中。亦无法可生者。亦无法可灭者。而于中有戒性三昧性智慧性解脱性见解脱慧性。而于其中现。有须陀洹斯陀含阿那含阿罗汉辟支佛三耶三佛。而有三宝有转法轮。于是释提桓因语须菩提。菩萨习般若波罗蜜为习何等。耆年须菩提报释提桓因言。学般若波罗蜜者为习空。释提桓因白佛言。若善男子善女人受持般若波罗蜜。讽诵读念习行中事者。世尊。我当为作何等护。须菩提语释提桓因言。拘翼。汝颇见法有可护者不。唯尊者。实不见法有可护者。须菩提言。拘翼。善男子善女人。如般若波罗蜜教住者。则为已得护。不离般若波罗蜜教。若人若非人终不得其便。如般若波罗蜜教住者。当知是善男子善女人终不离般若波罗蜜。若有人言。我欲护菩萨摩诃萨者。当知是人为欲护空。拘翼。宁能护梦及热时炎幻化影响。宁能护是辈事不。释提桓因言不能护。拘翼。若菩萨行般若波罗蜜亦如是。拘翼。宁能护佛及佛所化不。释提桓因言不能。菩萨行般若波罗蜜亦无能与作护也。拘翼。能护法性真际不可思议。能与作护不。唯须菩提不能。菩萨行般若波罗蜜。亦复如是无能与作护者。释提桓因问须菩提。菩萨行般若波罗蜜。当云何觉知梦法幻法热时之炎法响法化法。而不贡高。须菩提言。拘翼。菩萨行般若波罗蜜亦不念五阴。于五阴不贡高。至萨云若亦不念亦不贡高。于梦法乃至化亦不念亦不贡高。佛之威神。令三千大千国土诸四天王乃至首陀会天。各持天上碎末栴檀。遥散佛上散已来诣佛所。头面着地为佛作礼却住一面。尔时诸四天王诸释提桓因。诸梵天王及诸首陀会天。承佛威神各各意念。今我曹等当请十方面各千佛。使转般若波罗蜜品。诸四天王释梵诸尊天适作是念已。应时十方面各千佛。应时悉现皆说般若波罗蜜品。其弟子者亦如须菩提。其难问者皆如释提桓因亦如是问。与释迦牟尼佛说般若波罗蜜等无差特。佛言。弥勒菩萨摩诃萨。亦当于是处成阿耨多罗三耶三菩。成阿惟三佛。亦当于是处说般若波罗蜜。是贤劫中当来诸佛。亦当于是处成阿耨多罗三耶三佛。亦当于是处说般若波罗蜜。须菩提白佛言。以何事以何象以何意。弥勒菩萨摩诃萨。成阿耨多罗三耶三佛说般若波罗蜜。佛告须菩提言。弥勒菩萨摩诃萨成作佛时。亦不说五阴有常无常。亦不说五阴有苦有乐有净不净有我无我好不好。亦不说五阴有缚有解。亦不说五阴有过去当来今现在。五阴常净当说五阴常净。乃至萨云若常净当说萨云若常净。须菩提白佛言。般若波罗蜜清净世尊。佛言。以五阴清净故般若波罗蜜清净。世尊。云何以五阴清净故般若波罗蜜清净。佛言。五阴亦不生亦不灭亦不着亦不断。以是故五阴清净。须菩提。虚空清净故般若波罗蜜清净。世尊。云何虚空清净般若波罗蜜清净。佛言。虚空不生不灭无所有。是故虚空清净。世尊。云何虚空无所有般若波罗蜜清净。佛言。虚空不可护持故。般若波罗蜜清净如虚空事故般若波罗蜜清净。世尊。云何如虚空事故般若波罗蜜清净。佛言。如虚空无二寂。以是事般若波罗蜜清净。佛言。如虚空无行般若波罗蜜清净。世尊。云何虚空无行般若波罗蜜清净。佛言。以虚空无所行故般若波罗蜜清净。佛言。以虚空无所倚般若波罗蜜清净。世尊。云何虚空无所倚。般若波罗蜜清净。佛言。如虚空无所累故。般若波罗蜜清净。须菩提。以诸法不生不灭不着不断故。般若波罗蜜清净。世尊。云何诸法不生不灭不着不断故。般若波罗蜜清净。佛言。以诸法常清净故。般若波罗蜜清净。须菩提白佛言。世尊。若善男子善女人持般若波罗蜜。讽诵读习行中事者。是善男子善女人。终不病目耳鼻无病。虽身有老终不久衰随其寿终。终时不乱身意安隐。终不毒病误妄恶死。常有诸天随侍拥护。诸四天王至首陀会天常皆随护。善男子善女人为法师者。若月十四日十五日。说般若波罗蜜时。尔时诸天皆悉来会。善男子善女人作是说般若波罗蜜时。所得功德不可复计。不可复称量不可思议。佛告须菩提。善男子善女人。若六斋以说般若波罗蜜时诸天来会。所得功德不可计量。所以者何。般若波罗蜜者极大珍宝。须菩提。于般若波罗蜜珍宝中。断三恶趣断人中贫。施人天道人道。使一切人得生大姓梵志长者家。得生四王天上至三十三天。施人须陀洹道斯陀含阿那含阿罗汉辟支佛道。施人阿耨多罗三耶三菩道。何以故。于般若波罗蜜中广说十善事。于中学已。便知有刹利梵志大姓长者。知有四天王上至三十三天。便知有须陀洹道声闻辟支佛道。便知有三耶三佛道。便知有四禅四等及四空定三十七品佛十种力及十八法四无所畏。便知有六波罗蜜。知有内外空及有无空。便知有萨云若。以是故名为珍宝度。名为般若波罗蜜。于珍宝度中。亦无生者亦无灭者。亦无著者亦无断者。亦无取者亦无弃者。所以者何。亦无有法有生灭者。有着断者有取放者。须菩提。般若波罗蜜无有善法亦无恶法。亦无道法亦无俗法。亦无漏不漏亦无有为法亦无无为法。以是故须菩提。珍宝波罗蜜无所倚。是珍宝波罗蜜无有法能染者。无有法能逮者。所以者何。不可得法与相近者。是故无能染者。佛告须菩提。若有菩萨行般若波罗蜜。若不作是知不作是念。不作是倚不作是戏。为行般若波罗蜜。为念般若波罗蜜。为礼诸如来无所著等正觉。从佛国至佛国供养承事礼敬诸佛。教化众生净佛国土。须菩提。是般若波罗蜜无有法可见者。无有不可见者。亦不取亦不放亦不生亦不灭。亦不着亦不断亦不增亦不减。亦不过去当来今现在。亦不使欲界过亦不使住。亦不使形界过亦不使住。亦不使无形界过亦不使住。亦不与人六波罗蜜亦不教人弃。亦不与人内外空及有无空亦不弃。亦不与人三十七品亦不弃。亦不与人十力及十八法亦无所弃。亦不持声闻辟支佛上至萨云若。有所与亦不使弃。复次须菩提。般若波罗蜜者。亦不持罗汉法有所与亦不弃凡人法。亦不持辟支佛法有所与亦不弃罗汉法。亦不持佛法有所与亦不弃辟支佛法。亦不持佛法有所与有所弃。须菩提。般若波罗蜜。亦不持无为法有所与亦不弃有为法。何以故。有佛无佛法性住如故。法性者则是法身。亦不以忘住亦不以损住。是时诸天众于虚空欢喜踊跃大笑。持天忧钵罗华拘勿投华分陀利华而散佛上。俱发声言。我等今于阎浮提再见法轮转。所以者何。无央数天子于空中。得无所从生法忍故。佛告须菩提。转法轮亦不二亦不一。般若波罗蜜者。亦不为法故转。亦不有所为故不转。以有无空故。须菩提白佛言。何等有无空故。般若波罗蜜有所转有所逮。佛言。六波罗蜜空以六波罗蜜空空。内外空以内外空空。及有无空以有无空空。三十七品空以三十七品空空。十力空以十力空空。佛十八法空以十八法空空。声闻辟支佛空以声闻辟支佛空空。萨云若空以萨云若空空。须菩提白佛言。般若波罗蜜所谓空者。是菩萨之大度。菩萨有般若波罗蜜一切空故。得成阿耨多罗三耶三菩阿惟三佛。亦无所逮觉而转法轮。亦无有法可为转者。亦不复转还亦不见法。何以故。索法可为转者亦不可得。以诸法常无所有故。何以故。空无相无愿亦无所转亦无所还者般若波罗蜜有是教说有是施设有是分别分部。有是宣示分流。般若波罗蜜有是教者。如是为大清净教。般若波罗蜜教。亦无说者亦无受者亦无取证者。若无说无受无证。如是为无般泥洹者。若无般泥洹者。于是教法中。亦为无有尊祐福田

放光般若波罗蜜经卷第九放光般若经卷第十

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜等品第四十五

须菩提白佛言。世尊。是般若波罗蜜无有底。答言。虚空无有际故。世尊。波罗蜜等。答言。诸法等故。世尊。波罗蜜寂静。佛言。常空故。世尊。波罗蜜无能伏者。佛言。诸法无所有故。世尊。种种波罗蜜空。答言。亦无字亦无身故。世尊。波罗蜜空。答言。呼吸出入不可见故。世尊。波罗蜜无有事行。答言。无所觉无所行故。世尊。波罗蜜无有字。答言。痛想念不可见故。世尊。波罗蜜无有去。答言。诸法无有来故。世尊。波罗蜜无有等。佛言。诸法无所取故。世尊。波罗蜜消。答言。以诸法常尽故。世尊。波罗蜜不生。答言。诸法无所生故。世尊。波罗蜜无所为。答言。无有作者故。世尊。波罗蜜无有智。佛言。智者不可见故。世尊。波罗蜜无所越。答言。索生死不可见故。世尊。波罗蜜无所败。答言。诸法无有坏故。世尊。波罗蜜如梦。答言。梦中所有不可见故。世尊。波罗蜜如响。答言。无有闻声故。世尊。波罗蜜如光影。答言。面像不可见故。世尊。波罗蜜如炎。答言。水流不可得故。世尊。波罗蜜如幻。答言。术事不可得故。世尊。波罗蜜无著。佛言。绪不可见故。世尊。波罗蜜不断。答言。无有绪故。世尊。波罗蜜不出。答言。无有窟故。世尊。波罗蜜不戏。答言。诸戏已灭故。世尊。波罗蜜无贡高。答言。诸贡高已灭故。世尊。波罗蜜不动转。答言。法性住故。世尊。波罗蜜无住。答言。诸法审尔等故。世尊。波罗蜜无所住立。答言。诸法无念故。世尊。波罗蜜寂。答言。诸法想行不可见故。世尊。波罗蜜无淫。答言。淫不可见故。世尊。波罗蜜无恚。答言。无有恚不可见故。世尊。波罗蜜不痴。答言。灭诸冥故。世尊。波罗蜜无有垢。答言。无有狐疑故。世尊。波罗蜜非众生。答言。无有众生故。世尊。波罗蜜无所除。答言。诸法无所处故。世尊。波罗蜜两际不灭。答言。离于际故。世尊。波罗蜜不破。答言。诸法不受故。世尊。波罗蜜无所[打-丁+此]。答言。度诸声闻辟支佛地故。世尊。波罗蜜无所分别。答言。诸法无有择故。世尊。波罗蜜无有限。答言。诸法不可平相故。世尊。波罗蜜虚空。答言。诸法不可计故。世尊。波罗蜜无常。佛言。诸法坏败故。世尊。波罗蜜苦。答言。诸法无有党与师子战故。世尊。波罗蜜无有我。答言。诸法无所入故。世尊。波罗蜜空。答言。诸法不可见故。世尊。波罗蜜无有想。答言。诸法无所出生故。世尊。波罗蜜内空。答言。内空不可得故。世尊。波罗蜜外空。答言。外空法不可见故。世尊。波罗蜜内外空。答言。内外空不可见故。世尊。波罗蜜空空。答言。空空不可见故。世尊。波罗蜜大空。答言。诸法不可见故。世尊。波罗蜜至竟空。答言。无为法不可见故。世尊。波罗蜜有为空。答言。有为法空不可见故。世尊。波罗蜜常空。答言。常空不可见故。世尊。波罗蜜无有际空。答言。无有际不可见故。世尊。波罗蜜所作事空。答言。所作事不可见故。世尊。波罗蜜性空。答言。有为性法不可见故。世尊。波罗蜜诸法空。答言。内外空不可见故。世尊。波罗蜜自相空。答言。自相寂故。世尊。波罗蜜有无空空。答言。有无空不可得故。世尊。四意止波罗蜜。答言。身痛意法不可见故。世尊。四意断波罗蜜。答言。善恶法不可见故。世尊。神通波罗蜜。答言。四神足不可见故。世尊。五根波罗蜜。答言。五根不可见故。世尊。波罗蜜力。答言。五力不可得见故。世尊。波罗蜜觉。答言。七觉意不可见故。世尊。波罗蜜道。答言。八字不可见故。世尊。波罗蜜无愿。答言。愿不可见故。世尊。波罗蜜空。答言。空事寂不可见故。世尊。波罗蜜无相。答言。静事不可见故。世尊。波罗蜜脱。答言。八惟无不可见故。世尊。波罗蜜定。答言。九次第禅不可见故。世尊。波罗蜜檀。答言。妒嫉不可见故。世尊。波罗蜜戒。答言。恶戒不可见故。世尊。波罗蜜羼。答言。忍不可见故。世尊。波罗蜜惟逮。答言。精进懈怠不可见故。世尊。波罗蜜禅。答言。定以乱不可见故。世尊。波罗蜜慧。答言。恶智与慧不可见故。世尊。波罗蜜十力。答言。诸法无有可伏故。世尊。波罗蜜勇悍。答言。通事慧不可见故。世尊。波罗蜜分别智。答言。一切慧无碍故。世尊。佛法波罗蜜。答言。过诸法故。世尊。如来波罗蜜。答言。所说无有异故。世尊。波罗蜜自然。答言。般若波罗蜜自然诸法中得自在故。世尊。佛法波罗蜜。答言。诸法事阿惟三佛故

    摩诃般若波罗蜜真知识品第四十六

尔时释提桓因意念。善男子善女人闻般若波罗蜜过耳者。皆是过去佛时作功德人。为已与真知识相得。何况受持讽诵读说行中事者。是人已更供养若干诸佛。能为人问能为人解。今复受持般若波罗蜜如其中教。善男子善女人。闻般若波罗蜜不恐不怖者。其人已于若干百千劫中行六波罗蜜中事所致。舍利弗白佛言。世尊。若有善男子善女人。闻深般若波罗蜜不恐不怖不怯不惧。闻已便能受持讽诵行其中事。当视是辈菩萨。当如阿惟越致。何以故。般若波罗蜜甚深故。未能行六波罗蜜者终不能解。如是世尊。若复有善男子善女人。欲訾毁般若波罗蜜者。其人本以轻易般若波罗蜜已。所以者何。闻说深般若波罗蜜不信乐故。未曾从佛及弟子众。闻行六波罗蜜所致。不闻内外空及有无空所致。不闻三十七品佛十种力及十八法所致。释提桓因问舍利弗。般若波罗蜜有何等奇特。新学菩萨闻深般若波罗蜜。云何解六波罗蜜。云何解内外空及有无空。云何解三十七品十种力十八法。释提桓因语舍利弗言。般若波罗蜜者有大名称。诸不恭敬般若波罗蜜者。为不恭敬萨云若慧佛告释提桓因言。如是拘翼。不恭敬般若波罗蜜者。为不恭敬萨云若慧。何以故。诸佛如来萨云若慧皆于中生。拘翼。善男子善女人欲住萨云若者。当住般若波罗蜜。欲发道慧者当习行般若波罗蜜。善男子善女人欲离诸习绪。当习行般若波罗蜜。欲转诸佛法轮者。当习行般若波罗蜜。善男子善女人。欲得须陀洹斯陀含阿那含罗汉辟支佛道三耶三菩佛道者。当习行般若波罗蜜。欲总持比丘僧者。当习行般若波罗蜜。释提桓因白佛言。菩萨云何住六波罗蜜。云何习六波罗蜜。云何行般若波罗蜜。习内外空及有无空。云何行三十七品四无所畏十八法。佛告释提桓因言。善哉善哉。拘翼。承佛威神乃能作是问如来无所著等正觉。佛言。菩萨行般若波罗蜜者。不住于五阴。如五阴不住者为习五阴。不住于眼耳鼻舌身意。不住于色声香味细滑法。不住十二衰者为习十二衰。不住六波罗蜜者为习六波罗蜜。不住内外空及有无空者为习内外有无空。不住三十七品四无所畏十力至十八法者为习十八法。何以故。不见五阴有可住可习者。乃至十八法亦不见可住可习者。复次拘翼。菩萨于五阴不合者为习五阴。乃至佛十八法不合者为习佛十八法。何以故。菩萨索过去五阴不可得见。当来五阴不可得见。现在五阴亦不可得见。乃至佛十八法亦如是。舍利弗白佛言。般若波罗蜜甚深。佛言。五阴如亦甚深。舍利弗。乃至十八法如亦甚深。世尊。般若波罗蜜甚深难持难受。佛言。五阴难持难受故。般若波罗蜜难持难受。乃至十八法难持难受故。般若波罗蜜难持难受。世尊。般若波罗蜜不可平相。佛言。五阴不可平相故。般若波罗蜜不可平相。乃至十八法不可平相故。般若波罗蜜不可平相。佛告舍利弗。若菩萨行般若波罗蜜。不行深五阴。为行般若波罗蜜。乃至十八法深不行。为行般若波罗蜜。何以故。以五阴深为非五阴。乃至十八法甚深为非十八法。佛言。若菩萨行般若波罗蜜。不行五阴难持难受。为行般若波罗蜜。何以故。若五阴难持难受者为非五阴。若十八法难持难受者为非十八法。舍利弗。菩萨行般若波罗蜜。不行不可平相五阴。为行般若波罗蜜。何以故。若五阴不可平相者为非五阴。乃至佛十八法不可平相者为非十八法。舍利弗白佛言。般若波罗蜜甚深难解不可平相。不当于新学菩萨前说是深般若波罗蜜。闻者或恐或怖狐疑作碍不信不乐。当为阿惟越致菩萨摩诃萨说是深般若波罗蜜。闻是终不恐怖终不疑阂闻则信解。释提桓因问舍利弗。正使于新学菩萨前。说深般若波罗蜜有何等过。舍利弗语释提桓因言。若于新学菩萨前说者。便能恐怖便能诽谤。便不得度脱便受剧恶之罪。更倍久难乃能成阿耨多罗三耶三菩。释提桓因问舍利弗。颇有未受记莂菩萨闻是深般若波罗蜜不恐不怖者不。舍利弗言。有闻是深般若波罗蜜不恐不怖者。今受记莂不久。不过更见一佛两佛便受记莂。尔时世尊告舍利弗。如是如是。若有闻深般若波罗蜜不恐不怖者。当知是辈菩萨摩诃萨人发意。已久行六波罗蜜。已久供养诸佛。所行转转出于本所闻所行者上。舍利弗白佛言。世尊所说者。我已解所言。世尊。若善男子善女人发菩萨意者。若于梦中行六波罗蜜。若坐于佛座。当知是善男子善女人。不久近阿耨多罗三耶三菩。悉于梦中所作如是。当近阿耨多罗三耶三菩不久。何况行六波罗蜜。求阿耨多罗三耶三菩。而不疾成三耶三佛。善男子善女人。闻是深般若波罗蜜能奉行者。于善本功德为已成就。已曾供养过去无央数诸佛。为与真知识相得。受持讽诵般若波罗蜜。得阿耨多罗三耶三菩记莂不久。当知是菩萨于阿耨多罗三耶三菩不复动转。今现在信者亦当如是。甫当来信者亦复如是。世尊。譬如有人。若行百喻旬若二百喻旬至四百喻旬。所经过处饥馑贼寇梗涩剧难。遥见树木若放牧之地。当知居家去是不远。便自欢喜今我为得脱此诸难。不复恐畏不复饥饿。受持深般若波罗蜜者。当知是菩萨为已受记。成阿耨多罗三耶三菩不复久。是菩萨不畏当堕罗汉辟支佛地。是者则菩萨摩诃萨应成之兆。佛语舍利弗。汝所说辩才者皆是佛事。舍利弗白佛言。世尊。譬如有人欲见大海。便发往趣大海不懈止。亦不见树亦不见山。便作念言。今近大海不久。虽不见大海于中生想言。如我所见相知我今至海不久。世尊。菩萨摩诃萨当作是知。闻受持般若波罗蜜讽诵读者。虽不面于诸如来无所著等正觉前受阿耨多罗三耶三菩劫数之记。然自知成三耶三佛不久。何以故。已得见般若波罗蜜受持讽诵故。世尊。譬如人见春天诸树痱癗含气。当知是树枝叶花实将生不久。何以故。是树先有瑞应故。阎浮提人见瑞应莫不欢喜者。世尊。菩萨得见闻般若波罗蜜。闻已受持讽诵念习行中事。当知是菩萨功德已成满。已供养若干百千诸佛。逮前功德之所扶接。便成阿耨多罗三耶三菩。天上诸天曾见诸佛皆欢喜言。前过去诸菩萨皆受记莂瑞应亦如是。世尊。譬如母人怀妊稍稍长大。坐起不安行步无便。气力转微食饮损少。卧起不宁稍稍觉痛。厌本所习皆受诸恼。异母人观见瑞应。知是妇人今产不久。菩萨摩诃萨已作善本。供养若干百千诸佛从久远作行。常与真知识相得功德成就。菩萨摩诃萨行诸功德故。便得般若波罗蜜已。便受持讽诵习行中事如法住者。世尊。当知是菩萨摩诃萨受阿耨多罗三耶三菩记莂终不复久。佛言。善哉善哉。舍利弗。汝乃作是问者皆是佛事。须菩提白佛言。甚奇甚特。世尊。悉豫知菩萨所应。佛语须菩提。菩萨摩诃萨发阿耨多罗三耶三菩。欲益众生安隐一切及天与人。欲以四事受行菩萨道者。何等为四。一者施与二者仁爱三者利人四者同义。劝彼令行十善。自行四禅及四空定。劝彼使行四禅及四空定。自行六波罗蜜。劝彼令行六波罗蜜。以般若波罗蜜劝令人得须陀洹道。自于内不为劝人行罗汉辟支佛道。自于内不为不受罗汉辟支佛证。劝助无央数亿百千菩萨令行六波罗蜜。自过于阿惟越致地劝彼住阿惟越致地。自净佛国土劝彼净佛国土。自具神通劝彼修神通。自净陀邻尼门劝彼令净陀邻尼。门自行具足辩才劝彼令行辩才。自成就身相劝彼令成身相。自成童真地劝彼令修净洁行地。自得佛十力劝彼使行十力。自建萨云若劝彼令建萨云若。自离诸习绪劝彼令离习绪。自转法轮劝彼令转法轮。须菩提白佛言。世尊。甚奇甚特。菩萨摩诃萨为众生普具足作功德。行般若波罗蜜求阿耨多罗三耶三菩。世尊。菩萨摩诃萨念般若波罗蜜。云何当得具足。佛言。行般若波罗蜜。亦不见五阴有增有减。是故菩萨摩诃萨行般若波罗蜜得具足念。乃至萨云若亦不见有增有减。是为菩萨得具足念。复次须菩提。行般若波罗蜜菩萨亦不见是法亦不见非法。亦不见过去当来今现在恶法善法。亦不见受记莂亦不见不受。亦不见有为法亦不见无为法。亦不见三界。亦不见六波罗蜜。乃至萨云若亦无所见。是故菩萨般若波罗蜜得具足念。何以故。诸法法之相法不坏空。无坚固侵诳之貌。法亦无生无寿无命故。须菩提言。世尊所说不可思议。佛语须菩提。以五阴不可思议故。所说不可思议。六波罗蜜乃至萨云若不可思议故。所说不可思议。须菩提。若有菩萨行般若波罗蜜。知五阴不可思议。则知具足般若波罗蜜乃至萨云若。知不可思议则具足知般若波罗蜜。须菩提白佛言。世尊。深般若波罗蜜谁当信解者。佛言。菩萨久行六波罗蜜多。作诸善本已供养过去无央数诸佛。已与真知识相随者。是辈菩萨乃信解深般若波罗蜜。须菩提白佛言。世尊。是菩萨行六波罗蜜。作诸善本以来。几时供养若干佛与真知识相得。佛告须菩提。菩萨摩诃萨不有名五阴不分别五阴。亦不以想有名分别五阴。亦不有名分别五阴有实及诸六情三界。六波罗蜜内外空及有无空。三十七品佛十八法道慧及萨云若。亦不有名分别。亦不以想有名分别有虚有实。何以故。须菩提。以五阴不可思议。乃至萨云若亦不可思议。以是故。菩萨摩诃萨久行六波罗蜜多作诸善本与真知识相得。须菩提白佛言。世尊。般若波罗蜜者甚深。以五阴甚深故般若波罗蜜甚深。以萨云若甚深故般若波罗蜜甚深。世尊。般若波罗蜜者珍宝之积聚。是须陀洹及罗汉辟支佛宝之积聚。亦是阿耨多罗三耶三菩宝之积聚。亦是十力四无所畏四无碍慧。四等四空定五神通。三十七品佛十八法及萨云若。乃至诸法宝之积聚。世尊。般若波罗蜜者是清净之积聚。以五阴清净乃至萨云若清净故。世尊。深般若波罗蜜甚可奇怪。于是中云何而有留难。佛言。有是有留难。善男子善女人欲书是般若波罗蜜者当疾疾书之。若欲受持若欲讽诵若欲守行者亦当疾疾为之。所以者何或未受书行之顷能有留难。善男子善女人若能一月书成者。若二若三若四若五若一岁成者。要当书持受之讽诵学习。若一月书成持学受者亦当竟之。若至一岁亦当竟之。所以者何。多于珍宝中起诸因缘有留难故。须菩提言。世尊。是深般若波罗蜜。有书持学讽诵守行念中事者。诸魔波旬常念欲断绝之。佛语须菩提。正使波旬欲断绝者。会不能断绝令不守行书持学者。舍利弗白佛言。世尊。是何谁恩。令魔波旬不能断绝学深般若波罗蜜者。佛告舍利弗。是佛之事。令魔波旬不能断绝。亦复是十方诸佛之恩拥护是菩萨。受持般若波罗蜜者。令魔波旬不能断绝。所以者何。舍利弗。菩萨受持般若波罗蜜为佛所护持者。天魔波旬终不能断绝为作留难。何以故。舍利弗。诸有菩萨书持受学般若波罗蜜念讽诵者。诸佛之法当应拥护。令魔波旬不能中道令有留难者。舍利弗。是善男子善女人当作是念。我今书持受学般若波罗蜜者。皆是诸佛事。舍利弗白佛言。世尊。若有善男子善女人。书持受学般若波罗蜜者。皆为佛恩之所护持。佛言。如是如是。舍利弗言。世尊。十方现在诸如来无所著等正觉颇知是善男子善女人。书持受学般若波罗蜜念讽诵者不。颇持佛眼颇知颇见不。佛告舍利弗。诸有书持受学般若波罗蜜讽诵行者。十方诸如来无所著等正觉已见已知。诸善男子善女人行菩萨道者。书持受学般若波罗蜜讽诵行者。当知是人今近阿耨多罗三耶三菩不久。舍利弗。若复善男子善女人行菩萨道者。书持受学般若波罗蜜。讽诵守习行如中事。爱乐供养般若波罗蜜。名花捣香泽香杂香缯彩花盖幡幢所有作是供养者。诸佛以天眼悉见是善男子善女人已。是善男子善女人。有书持般若波罗蜜奉行学者。得最大福得大功德为得最行。善男子善女人。持善本功德终不堕恶趣至阿惟越致。终无有离诸佛。六波罗蜜时。终不离内外空及有无空时。至阿耨多罗三耶三菩。终不离三十七品佛十八法时。舍利弗。如来去之后。是般若波罗蜜当在南方。南方诸比丘比丘尼优婆塞优婆夷。亦当受学书持是深般若波罗蜜。持是功德终不至恶趣。受天上人中之福。以奉行六波罗蜜。明六波罗蜜已。当复供养承事诸佛。承事之后当以三乘而得度脱。舍利弗。般若波罗蜜所在方面所至到处。四辈学士亦当受持是深般若波罗蜜书持讽诵。持是功德不至恶趣。受天上人中之福。亦当复奉行六波罗蜜。明六波罗蜜已。当复供养承事诸佛。承事之后以三乘法而得度脱。舍利弗。是般若波罗蜜当转北去。北方四辈亦当复受书持讽诵行深般若波罗蜜。持是功德不生三恶趣。受二道之福。亦当奉行六波罗蜜。亦当承事诸佛世尊。复以三乘而得度脱。舍利弗。深般若波罗蜜是时当行佛事。所以者何。舍利弗。我泥曰后法欲尽时。我已豫知是善男子善女人。受持是深般若波罗蜜者。我复知是善男子善女人。尽意供养般若波罗蜜。所有名香缯彩华盖。持是功德不堕三恶趣。受二地之善福。行六波罗蜜供养诸佛。以三乘法而得度脱。何以故。舍利弗。如来已见是辈人已称誉是人。我已署是人所在。十方现在诸佛亦复称誉。亦见是人亦署是人已。舍利弗白佛言。世尊。是般若波罗蜜后当普在北方耶。佛言。如汝所说。乃后世时善男子善女人受学书持行般若波罗蜜者。当知是人久发大乘意已。更供养若干诸佛作诸善本。舍利弗白佛言。世尊。后北方面当有几所善男子善女人。行菩萨道受持般若波罗蜜讽诵解者。佛告舍利弗。后北方世虽多有善男子善女人受持般若波罗蜜者。少有成大乘者耳。舍利弗。是善男子善女人行菩萨道者。闻说深般若波罗蜜。不难不厌而不恐怖。所以者何。善男子善女人。已为见佛已从诸佛闻深法已。所以者何。是善男子善女人已为具足六波罗蜜。为已具足内空外空及有无空。已为具足佛十八法三十七品。是善男子善女人多作诸功德发阿耨多罗三耶三菩。为一切众生故。舍利弗。我为是善男子善女人说萨云若慧。过去诸如来无所著等正觉亦复说应萨云若慧。诸求阿耨多罗三耶三菩者。皆为生老病死故亦复为彼说阿耨多罗三耶三菩诸慧之事。是善男子善女人。从小至竟求阿耨多罗三耶三菩。魔及魔天终不能坏。何况其余有恶行者。而欲诽谤深般若波罗蜜。舍利弗。是善男子善女人闻深般若波罗蜜者。便得最妙欢喜。立多所人于阿耨多罗三耶三菩。佛言。我为菩萨时亦复作是誓。我等亦当立无央数众生劝令行菩萨道。我等亦当受阿耨多罗三耶三菩不动转记。若有菩萨发意者我代欢喜。诸有劝人使发阿耨多罗三耶三菩者我亦代欢喜。善男子善女人行般若波罗蜜者。为已于过去诸佛前作是誓已。今复于我前誓愿众生。我当饶益安隐众生。我当劝助一切众生。立阿耨多罗三耶三菩意使不动转。所以者何。过去诸佛亦复代诸发意菩萨作是誓者代其欢喜。舍利弗。我代欢喜者。善男子善女人亦为复欲安隐一切。劝助众生使立阿耨多罗三耶三菩。离于六衰得净妙行。已自清净复以净施。净妙施已便受净妙功德之福。受净妙福已。复为众生故分别内外所有。令众生得净妙福。持是功德遍至十方诸佛国土说般若波罗蜜处而得听受。闻受已亦复于彼劝发众生。令立阿耨多罗三耶三菩意。舍利弗白佛言。甚奇世尊。如来无所著等正觉所说。过去当来今现在之法。无所不知众生之行无事不知。乃复知诸当来过去现在佛事众僧之事。或有善男子善女人得六波罗蜜欲讽诵受。或意进退便不能得学六波罗蜜。若善男子善女人求六波罗蜜意不进退。精进不懈便能一时具足六波罗蜜。舍利弗白佛言。善男子善女人如是行者便得深经。为应般若波罗蜜耶。佛言。如是深经者为应般若波罗蜜。何以故。用能劝助安立众生。令发阿耨多罗三耶三菩故。舍利弗。是善男子善女人于六波罗蜜不舍生老病死。精进不怠如般若波罗蜜教。净佛国土教化众生。令立阿耨多罗三耶三菩志终不懈怠

    摩诃般若波罗蜜觉魔品第四十七

须菩提白佛言。世尊。叹说是善男子善女人。发阿耨多罗三耶三菩。行六波罗蜜者。摄取佛国教化众生其德乃尔。是善男子善女人云何而趣断绝留难。佛告须菩提言。辩不即者当知魔事。须菩提言。世尊。云何菩萨辩不即发知是魔事。佛言。菩萨行般若波罗蜜具足六波罗蜜久久乃成。以是故菩萨辩不即生当知魔事也。须菩提。菩萨辩才卒起亦是魔事。世尊。何以故。辩才卒起复是魔事。佛言。是菩萨行六波罗蜜卒起辩事。所以者何。学无本末。辩起咃卒不能究竟。是故当知魔事。菩萨书是经时转相形笑。志乱不定众意不和。如是菩萨则为魔事。书是经时意自念言。我不得是经中慈味便舍而去。当复知是魔事。须菩提。说是经时若受持之。贡高绮语隐置他人者复是魔事。受持讽诵学是经时。各自贡高转相形笑。菩萨当觉是为魔事。须菩提。受是经时各各志乱意不和同者。当知是为菩萨魔事。须菩提言。世尊。云何不得经中滋味便弃舍去当觉魔事。佛言。是辈菩萨未曾习行六波罗蜜。不闻般若波罗蜜自生意念言。我无有记莂于六波罗蜜。以是故。闻般若波罗蜜。不喜乐悦便弃舍去。当知是为菩萨魔事。世尊。云何菩萨言我无记莂不乐便去。佛言。未得菩萨道者。终不记阿耨多罗三耶三菩莂。是故言我无有莂于六波罗蜜。便弃舍去。当知是为菩萨魔事。若有菩萨意念言。我乡里不闻般若波罗蜜。及所生处亦不闻是。复弃舍去不复欲学般若波罗蜜。意转一念辄却一劫。随其转意多少之数。当更乃尔所劫。甫当复更学余经。不住萨云若亦不至萨云若。是辈菩萨为弃其根而攀枝条。当知是为菩萨魔事。须菩提言。世尊。何等经不从萨云若中出。而欲学诵余经。佛告须菩提。声闻所应三十七品法及三脱门。善男子善女人住是中。求取须陀洹道斯陀含阿那含阿罗汉道。不取萨云若然自作碍。须菩提。是为舍本攀枝者。所以者何。是菩萨亦复出生于般若波罗蜜中。般若波罗蜜者亦出道法俗法。菩萨学般若波罗蜜者。亦当学道法亦当学俗法。譬若有狗得大家所食不肯食之。得使人之食而更食之。须菩提。当来有学菩萨道者。得深般若波罗蜜更弃舍去反攀枝条。须菩提。当知是为菩萨魔事。复次须菩提。譬如有人欲得见象。得象舍去反求象迹。于意云何。是人为黠不。须菩提言。为不黠。当来之世有行菩萨道者。得深般若波罗蜜。反弃舍去更学声闻辟支佛经法。于意云何。是菩萨为黠不。须菩提言。为不黠。佛言。是菩萨当觉魔事。须菩提。譬如有人欲见大海已见舍去。反观牛迹之水。便言海之大小孰愈于此。于意云何。是人为黠不。须菩提言。世尊为不黠。佛言。当来有学菩萨道者得深般若波罗蜜亦弃舍去。反学声闻辟支佛经法。于中受学讽诵。须菩提。是辈菩萨当觉魔事。须菩提。譬如工匠。欲以揆则日月殿舍之模。竖立安造作释之殿。于意云何。彼匠虽巧宁能作不。须菩提言。世尊。此事甚难。非是凡夫世愚之士所能作者。佛言。当来之世有行菩萨道者得学深般若波罗蜜。中道而弃舍去。更于声闻辟支佛经法中。欲以具足萨云若萨云若事。于意云何。是人宁能成萨云若不。须菩提言。所不能成。佛言。是菩萨当觉魔事。须菩提。譬如有人欲见转轮圣王。见已反观小王谛熟视之。便言圣王之体与此何异。是人为黠不。须菩提言。世尊为不黠。佛言。当来有少德之人学菩萨道者。得闻深般若波罗蜜学持守行中道舍弃。更受罗汉辟支佛经法。复言。我当于中具萨云若。于意云何。是菩萨为黠不。须菩提言。世尊。为不黠。佛言。是为菩萨魔事。譬如饥人得百味食。更念欲得六十味食。舍百味去食六十味。于意云何。是为黠不。须菩提言。世尊。为不黠。佛言。当来有学菩萨道者。得深般若波罗蜜弃舍去已。更于声闻辟支佛经法中求萨云若。是菩萨为黠不。须菩提言。为不黠。佛言。是为菩萨魔事。譬如士夫得无价摩尼宝已反比水精。于意云何。是为黠不。须菩提言。世尊。为不黠。佛言。当来有学菩萨道者。得深般若波罗蜜已更弃舍去。反持比声闻辟支佛经法。于声闻辟支佛经法中欲得萨云若宁为黠不。须菩提言。为不黠。佛言。是为菩萨魔事。复次须菩提。若有善男子善女人。书般若波罗蜜已。于中他因缘起便不得书。或复有色声香味细滑法之留难。或复有檀波罗蜜留难尸波罗蜜留难羼波罗蜜留难惟逮波罗蜜留难。禅波罗蜜留难。乃至阿耨多罗三耶三菩皆为作留难。何以故。须菩提。般若波罗蜜者非是留难。不可思议亦非选择。不生不灭不着不断。无碍非见非行非猗。所以者何。须菩提。般若波罗蜜无是象法。若有菩萨书是经时。若有是辈留难事者当知是为魔事。须菩提白佛言。世尊。是般若波罗蜜可得书耶。佛言不也。何以故。般若波罗蜜者其实不可见。至檀波罗蜜实不可见。乃至萨云若亦不可见。诸所有者皆不可见。何以故。无所有故。无所有者不可书也。须菩提。善男子善女人行菩萨道者。作是念言。是深般若波罗蜜无所有者。是为菩萨魔事。须菩提言。世尊。诸行菩萨道者。书是深般若波罗蜜经字已入是字中。便言我书般若波罗蜜。世尊。是六波罗蜜无有字法。所以者何。六波罗蜜无有文字。五阴亦无有文字。乃至萨云若亦无文字。世尊。善男子善女人行菩萨道者。从六波罗蜜。乃至萨云若。作无文字入般若波罗蜜者。亦是菩萨魔事。须菩提。善男子善女人行菩萨道者。书般若波罗蜜时。若起想念郡国县邑丘聚村落。若闻父母所尊之声意念父母。若念兄弟姊妹。若念兵贼淫欲之事作是念已复生余念。魔波旬复益其念作是留难。欲令中断使不书持。须菩提。是为菩萨魔事。若善男子善女人行菩萨道者。书持般若波罗蜜时。若供养事起衣被财利饮食床卧病瘦医药。言我书般若波罗蜜故得是供养。于是乐者当觉魔事须菩提。书是经时魔波旬于菩萨前。说种种异深经之事。菩萨有沤和拘舍罗者不受魔所说。何以故。是经不能令人至萨云若故。须菩提。若是菩萨无沤和拘舍罗意者。闻深般若波罗蜜便欲舍去。佛言。我广为诸菩萨说沤和拘舍罗事。欲得沤和拘舍罗事者。当从深般若波罗蜜中索之。须菩提。善男子善女人求菩萨乘者。舍深般若波罗蜜。欲从声闻辟支佛经法中求沤和拘舍罗。须菩提。当知是为菩萨魔事

放光般若波罗蜜经卷第十放光般若经卷第十一

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜不和合品第四十八

佛告须菩提。有人乐听乐受般若波罗蜜。为法师者身体疲极不能所说。当觉魔事。佛言。若法师者身体安隐欲有所说。而受法者着余因缘各自罢散。当觉魔事。须菩提。受经之人欲书般若波罗蜜。为法师者欲有所至。是为魔事。为法师者欲得供养床卧饮食病瘦医药所有衣被。受经之人少欲知足寂无与心。便不和合是为魔事。须菩提。法师之人少欲知足守戒不贪。志常精进乐在禅定。受经之人不知厌足。贪求供养。两不和合是为魔事。须菩提。法师之人阿练寂晏行十二法。受经之人不能宴坐。又不奉行十二法事。须菩提。受经之人持十二法能独宴寂。为法师者永无此志。两不和合不得书学是为魔事。须菩提。受经之人。精进有信奉戒如法。乐般若波罗蜜。为法师者多欲犯律不能守戒。须菩提。为法师者精进信乐奉律禁戒行般若波罗蜜。受经之人多有所毁犯戒违律。两不和合是为魔事。须菩提。为法师者无所贪求。好喜施与志愿广普。受经之人多求有欲贪吝爱惜。志碍意狭两不和合。须菩提。若受经之人更无所欲。好施不贪志愿无碍。为法师者反更贪求无有止足。志意狭小。两不和合。是为魔事。须菩提。受经之人欲供养。与为法师者所有之具。为法师者不肯受之。不得学持般若波罗蜜。须菩提。为法师者悕望供养衣服所有。受经之人更廉洁守节不慕利养。复不和合是为魔事。须菩提。为法师者。明于经道勇辩智猛。然受经者。闇塞迟钝志不时寤。须菩提。受经之人志明意达智辩纤寤。为法师者。贪闇不达。而不和合是为魔事。须菩提。为法师者明十二部经。次第解说无所乏短。受经之人不知次第未了逆顺。须菩提。若受经者。明解次第解十二部经知逆顺事。为法师者更不能了。志不和合是为魔事。须菩提。为法师者具足六波罗蜜。受经之人不能具足。或受法者具足六波罗蜜。为法师者更不具足。两不和合是为魔事。须菩提。为法师者具足六度。兼有沤和拘舍罗。受经之人既无六事。复无沤和拘舍罗。两不和合是为魔事。须菩提。为法师者得陀邻尼。受经法者无。若受法者得陀邻尼。为法师者无。两不和合是为魔事。须菩提。受经之人欲书般若波罗蜜以为经卷。为法师者而不肯与。为法师者适欲与经。受法之人不欲书写。亦不和合是为魔事。须菩提。为法师者五阴盖所见缠裹。受经之人无有覆盖志不和合。若受经者迷于五蔽。为法师者阴盖已尽。两不和合是为魔事。须菩提。书是般若波罗蜜时。或有人来说三恶趣苦难之剧。语其人言。我能使卿离勤苦事。用是阿耨多罗三耶三菩学为。是为魔事。须菩提。书般若波罗蜜。若欲说时。反有人来称誉天上欲天快乐。五欲自恣饮食服御伎乐自然色天所有以禅为乐为食。无色天以寂为食为乐。从四王天至无有思想。无有思想慧天。三界虽乐是亦无常苦空无我。皆当灭尽不得久立。不如更受罗汉辟支佛法。莫乐三界受是生死。是为菩萨魔事。为法师者欲得寂志独处。其受经法者多将人众乐在愦闹。若法师者意乐人众。而受经者更乐寂独。亦不和同当觉魔事。若法师者意乐人众多畜弟子。受经之人不同比辈欲得独尔。若受法者欲乐多辈。法师欲寂。亦不和合是为魔事。为法师者而自尊重欲得恭敬。受经者慢意无恭敬。若法师者无欲于时不喜顺敬。然受法者好行恭敬。亦不和合是为魔事。若法师者书般若波罗蜜时意欲受取。受经之人永无与心意不和合是为魔事。若受经者书般若波罗蜜时。念欲转从般若波罗蜜。于中起意欲得财利。是为魔事。若法师者欲至危命谷贵之处。受经者不乐不能随从亦不和同是为魔事。法师之人欲至丰乐谷贱之处。其受经者皆悉乐从。法师中道更作留难。汝辈但欲贪于供养欲随我取。不知前至当得与不。其受经者见发遣相稍稍还去。是为魔事。若法师者语受经法者言。我欲所至。道过空泽彼有盗贼野人猎师。又多虎狼蛇虺毒虫。汝能随我忍此苦不。受法者闻意不喜乐不能随去。作是挂碍不得书成学受是经。是为魔事。法师之人曾所教授数往之处。其受法者欲随诣彼中道。法师语受经者言。今我暂当有所经过。卿且还去。受经者愁忧不得随从不闻不得受持般若波罗蜜。是为魔事。复次须菩提。彼魔波旬。意常计念。欲作沙门被服。常欲坏乱。不欲令有书持讽诵学般若波罗蜜者。须菩提白佛言。世尊。波旬何以故常作沙门被服坏败。不欲令人有受学般若波罗蜜者。佛语须菩提。波旬作沙门被服。欲败坏别离学般若波罗蜜者。复语人言。案我经中教法。观卿经中事非般若波罗蜜。须菩提。未受记莂闻是说者便有狐疑。适有疑意。便不复书持受学般若波罗蜜。是为菩萨魔事。须菩提。波旬复作比丘形像。语学般若波罗蜜者言。善男子善女人。有学讽诵受持般若波罗蜜者。得真际之证。得须陀洹罗汉辟支佛道。作是留难事。便不复学受书持般若波罗蜜。是为魔事。须菩提。说是深般若波罗蜜时。多有魔事起欲令断绝。是故须菩提。当觉魔事。须菩提言。世尊。菩萨云何当觉魔事。远离魔事。佛语须菩提。其事但像类六波罗蜜有觉是者。是则为护远离魔事。菩萨常当远离罗汉辟支佛。所应行经法当远离之。复次须菩提。波旬于菩萨前说内空外空及有无空三十七品至三脱门。是为罗汉所得道事。是为魔事。波旬复化作如来身金色光相。来至菩萨所。令诸菩萨起想。起想者于萨云若则为耗减。当知是为魔事。须菩提。波旬复作佛形像。诸比丘众相随。到是善男子善女人所。是善男子善女人便起想言。当来之世令我得身。诸弟子众于中说法亦如今日。作是想者于萨云若则为耗减。波旬复化作无央数百千菩萨行六波罗蜜者。于是善男子善女人前。见已复于中起想。起想者则为耗减萨云若。是为魔事。何以故。须菩提。般若波罗蜜者无有五阴。乃至于道亦无所有。无有五阴无有道者。亦无佛法及弟子众。所以者何。诸法尽空无所有故。须菩提。善男子善女人。书是般若波罗蜜时。若讽诵读。多有起因缘。譬如阎浮提大长者家。多有金银真珠琉璃上妙珍宝。多有憎嫉者。善男子善女人受持讽诵般若波罗蜜者。多有憎嫉而欲坏者。须菩提言。如是世尊。多有魔事多憎嫉者。何以故。愚痴少智之士为魔所使。专行断坏受学般若波罗蜜者。是辈坏法之人。意终不复在是妙法之中。佛言。如须菩提所言。是愚痴之士为魔所使。专行败坏。是辈愚痴坏法之人。新学适闻法所致。不作功德善本不多所致。未与真知识相得所致。不供养过去诸如来无所著等正觉所致。须菩提。若书持般若波罗蜜讽诵读说受行守时。无有留难魔事不起。无此难者便能具足六波罗蜜。至萨云若亦无有难。若有是善男子善女人。书持讽诵般若波罗蜜者。便具足五波罗蜜及萨云若已。当知是为佛事。若复具足内外空及有无空。三十七品佛十八法及十种力。具足萨云若者。当知是亦为佛事。十方现在诸如来无所著等正觉。亦以佛事。如是善男子善女人行般若波罗蜜者。十方现在诸阿惟越致菩萨摩诃萨。亦复拥护是善男子善女人行般若波罗蜜者。亦复劝助之

    摩诃般若波罗蜜大明品第四十九

佛告须菩提。譬如母人一一生子。从一数至于千人。母中得病。彼诸子等各各求救疗治。所进寒温燥湿将育所宜令母安隐。所以者何。长我曹等得见日月。我不孝养永不报恩。如是须菩提。诸如来无所著等正觉。常以佛眼视行般若波罗蜜者。何以故。深般若波罗蜜者为世间之大明也。十方诸如来无所著等正觉。亦以佛眼常视行般若波罗蜜者。何以故。深般若波罗蜜者。生诸如来无所著等正觉。使得见萨云若慧。以是故诸如来无所著等正觉。常等视行般若波罗蜜者。诸如来五波罗蜜者亦生是中内外空及有无空三十七品皆于中生。十力十八法萨云若亦皆于中生。须陀洹斯陀含阿那含阿罗汉辟支佛道三耶三佛道。皆从般若波罗蜜中出生。过去当来今现在诸佛。皆从深般若波罗蜜中出生。自致得成阿耨多罗三耶三菩阿惟三佛。须菩提。若有善男子善女人。书持受学般若波罗蜜者。诸佛常以佛眼视是辈行般若波罗蜜者。诸佛常拥护之使不动转。至阿耨多罗三耶三菩令不耗减。须菩提白佛言。如世尊所说般若波罗蜜者。是菩萨之母。为世间之大明。世尊。般若波罗蜜。云何是菩萨之母。云何是世间之大明。云何出生诸佛。云何为示现世间明。佛告须菩提。般若波罗蜜者。生佛十力及十八法。生萨云若。如来示现是诸法已具。是故诸如来从般若波罗蜜生世间者。谓如来说五阴。世尊。云何深般若波罗蜜示现五阴。佛言。般若波罗蜜亦不生。五阴示现亦不灭。五阴示现亦不着亦不断。亦不增亦不减。亦不持亦不舍。亦不过去当来今现在。何以故。空无相无愿亦不成败示现。亦不现有为亦不现无为。亦不示现无所生亦不示现无所有。亦不示现实诸法。如是不示现成败。须菩提。是为般若波罗蜜示现世间。须菩提。般若波罗蜜。亦知一切众生意行。般若波罗蜜不知众生之处。亦不知诸阴六情之处。乃至萨云若亦不知处。须菩提。是为深般若波罗蜜示现世间。深般若波罗蜜者。亦不示现五阴。乃至萨云若亦不示现。何以故深般若波罗蜜。亦不见深般若波罗蜜。何况当见五阴。乃至萨云若当有所见。须菩提。所谓名众生。欲界形界无形界是。普世及十方众生乱意定意如来悉知。复知一切无央数事。须菩提。云何如来悉知众生余无数事。以法故。有乱意无乱意如来悉知。以何等法知众生乱意定意。佛告须菩提。法尚不可得见。何况欲得众生有乱有定。以是故知。须菩提。如来无所著等正觉。知众生意有乱有定。云何而知。以无常故知。以脱故知。以寂故知。以尽故知。是故知有乱有定。复次须菩提。如来知众生有淫怒痴者尽知。须菩提白佛言。世尊。云何悉知。佛言。知淫怒痴所有意。为非淫怒痴意。何以故。所有及念不可见故。何况当有淫怒痴而可得者。以是故如来悉知。须菩提。如来复知众生无淫怒痴意者悉知。何以故。知所可知无淫怒痴意。意亦非有意。何以故。两意不合故。是故如来悉知。须菩提。如来因般若波罗蜜。悉知众生意。有广大者悉知。云何悉知。须菩提。如来亦不广大众生意。亦不狭众生意。亦不增众生意。亦不减众生意。亦不来众生意。亦不遣众生意。何以故。意不可得进退故。以是故悉知。复次须菩提。如来因般若波罗蜜悉知众生有大意者。何以故。知以众生意。无来无往无生无灭无住无变。以是故知。复次须菩提。如来以般若波罗蜜。悉知众生意无有限。云何悉知。须菩提。亦不见众生意有增有减有所住止。何以故。以众生意无有窟不可见故。以是故知。复次须菩提。如来因般若波罗蜜。悉知众生意不可见。云何悉知。以众生意意无有形无所有故悉知。复次须菩提。如来因般若波罗蜜悉知众生意不可观。云何而知。须菩提。如来以五眼悉见众生意之对故。以是故知。复次须菩提。如来因般若波罗蜜悉知众生屈申卷舒。云何而知。须菩提。众生意之屈申卷舒者。皆出五阴窟之所生生。不知五阴。但知出息入息有我及世。但知是事其余不识不知。五阴亦复不知出息入息。但知有我及世其余不识。身则是命。命则是身。是身非命。是命非身。是故须菩提。如来因般若波罗蜜悉知众生屈申卷舒。须菩提。佛知五阴。云何知知五阴如知如如。知无作如知无相如。知无进如知无戏如。知无我如知无猗如。是故须菩提如来以众生之如。屈申出入五阴之如。如五阴如者是诸法之如。诸法之如者则六波罗蜜如。六波罗蜜如者则三十七品如。三十七品如者则十八空如。十八空如者则八惟无禅九次第禅如。八惟无九次第禅如者则佛十力如。十力如者则四无碍慧四等心四无所畏大慈大悲佛十八法如。十八法如者则萨云若慧如。萨云若慧如者则一切诸善法恶法道法俗法有漏无漏之法如。此诸法如者则过去当来今现在之如。去来今如者则有为无为法如。有为无为法如者则须陀洹斯陀含阿那含阿罗汉之如。罗汉如者则辟支佛如。辟支佛如者则阿耨多罗三耶三菩之如。三菩如者则是道如。道如者则如来之如。如来如者则是一如。亦不可坏。亦不可别。亦无有尽。亦无有二不可令异。须菩提。是则诸法之如。如来因般若波罗蜜。悉皆逮觉诸法之如。须菩提。是般若波罗蜜者。则诸如来之母。则是世间之大明。是故须菩提。如来无所著等正觉。悉知诸法之如。尔非不尔无能令不尔。悉知诸如诸尔。以是故。诸佛世尊名曰如来。须菩提白佛言。世尊诸法之如及尔非不尔。甚深甚深。世尊。因如分流道化。如佛所说甚深之法谁当解者。唯有阿惟越致菩萨摩诃萨漏尽罗汉。乃能解之耳。佛语须菩提。无尽之如者是谁无尽之如。则是诸法无尽之如。须菩提。如来无所著等正觉。成阿耨多罗三耶三菩时。说是诸法之如

    摩诃般若波罗蜜问相品第五十

尔时三千大千刹土诸欲天子诸色天子。持诸名花名香而散佛上作礼却住。各白佛言。世尊。所说般若波罗蜜者。甚深甚深。何等是般若波罗蜜相。佛告诸天子言。深般若波罗蜜者。空则是相无相无愿相。无行之相无生灭相。无著无断相无所有之空相。无所依相虚空之相。诸天子。般若波罗蜜甚深如是。如来者。为世俗故。亦不为道不为灭尽。诸天子。是相者诸天龙鬼神世间人民。所不能作无能长养者。所以者何。诸天龙鬼神及世间人民亦是相也。是故相相不相长养。相相不相识。相亦不识无相。无相亦不识相。相以无相是二皆空。无能成者。无能答者。无能识者。诸天子。是相者非五阴所作。非六波罗蜜所成。亦非内外空及有无空所作。亦非萨云若所成诸天子。是相者亦非人亦非非人。亦非漏亦非不漏。亦非道亦非俗。亦非有为亦非无为。尔时佛告诸天子。若有人问是虚空是何等相。云何诸天子。是人所问为等问不。诸天子言。世尊。为不等问。所以者何。虚空无有相无有作者。佛告诸欲天子诸色天子言。有佛无佛相体性常住。以如来如实逮觉相性故名为如来。诸天子白佛言。如来所逮觉相甚深。如来从是阿耨多罗三耶三菩无碍之慧住于相。聚于般若波罗蜜甚奇。世尊。深般若波罗蜜者。是诸佛如来无所著等正觉之藏。于是藏成阿耨多罗三耶三菩阿惟三佛。于是藏中作行。逮诸法相。逮五阴相。逮萨云若相。佛告诸天子。色者形之相。所更者觉之相。所受者想之相。善恶者行之相。所知者识之相。如来以无所受相故。逮得正觉。无所爱惜者为檀波罗蜜相。无所腐败者尸波罗蜜相。不起恚意者羼波罗蜜相。无能伏者惟逮波罗蜜相。合聚众事者禅波罗蜜相。所闻即觉即知者般若波罗蜜相。如是诸天子。无所受相。是故如来得逮正觉。四禅四等四空定者则无恚之相。如来不以是相得逮正觉得出三界者是三十七品之相。如来不以是相逮得正觉。苦相者无愿脱门是。寂相者则空是。净相者则无相是。如来不以是相逮得正觉。寂相者无所起是。无所共相则十八法是。如来不以是相逮得正觉。露现相者则萨云若是。如来不以是相逮得正觉。如是诸天子。如来不以诸法相逮得正觉法。是故如来名为无碍慧。于是佛告须菩提言。般若波罗蜜者。是诸佛如来无所著等正觉之母。般若波罗蜜者是诸佛如来世间之大明。如来依是法而得有所作。以是故诸如来尊敬礼事是般若波罗蜜。何以故。诸佛如来皆从般若波罗蜜中出。是故如来之所报恩。须菩提。其报恩者无过如来。复次须菩提。云何如来为知恩云何为报恩。如来所可乘来法。所可成阿耨多罗三耶三菩阿惟三佛法。逮守持是所乘来法。恭敬承事作礼。须菩提。是为如来无所著等正觉之所知恩之所报恩。复次须菩提。如来之所逮法者。亦无作者。作者不可见故。如来尽逮是法得无作法者。是为无诤法。须菩提。如来知恩报恩因般若波罗蜜。于无作之法得逮觉法。复次须菩提。如来无所著等正觉行般若波罗蜜故。逮诸善法而无所逮。是故般若波罗蜜者。是诸佛之母。为世间之大明导。须菩提白佛言。世尊。诸法无所知无所见无所出生。云何般若波罗蜜是佛之母。云何生如来。云何为世间之大明导。佛告须菩提。如是如是。一切诸法无知无见。云何无知无见。以一切诸法空故。无所有不坚固无所生。以是故一切诸法无所出生。复次须菩提。诸法无知无见。云何无知无见。以诸法无所入无所著故。以是故般若波罗蜜是如来母世间之导。不见五阴是故为导。乃至萨云若亦无所见是故为导。以是故般若波罗蜜是诸佛母世间之导。须菩提问佛言。世尊。云何不见五阴为世间导。须菩提。不以五阴因缘起识者。是为不见五阴。不以萨云若起想者。是为不见萨云若。以是故般若波罗蜜诸如来母为世间导。复次须菩提。般若波罗蜜云何是如来之母为世间导。须菩提。般若波罗蜜示现世间空。云何示世间空示五阴空。十二衰十八性现世间十恶之法。从痴有爱十二因缘示吾我根本。六十二见示世间空。四禅四等及四空定示世间空。三十七品六波罗蜜内空外空及有无空示世间空。有为无为之性十种力佛十八法示世间空。至萨云若示世间空。是故须菩提。般若波罗蜜者是诸佛之母世间明导。复次须菩提。如来以空示于世间。以空念世间知世间空。以是故般若波罗蜜诸佛之母为世间导。复次须菩提。般若波罗蜜者。示现如来示世间空。示何等空。现五阴空十二衰空十八性空。现萨云若空。是故般若波罗蜜诸佛之母为世间导。是故须菩提。示现如来示现世间不可思议。示现五阴不可思议。乃至萨云若示世间不可思议。复次须菩提。深般若波罗蜜。示现如来世间之寂。示现何等寂。示现五阴寂及萨云若寂。以是故般若波罗蜜示现如来世间之寂。须菩提。般若波罗蜜示现如来世间常空。示何等空。从五阴至萨云若示现世间常空。复次须菩提。般若波罗蜜示现如来世间所有空。示何等空。从五阴乃至萨云若示世间所有空。复次须菩提。般若波罗蜜示现如来所有无所有空。从五阴乃至萨云若所有无所有空。复次须菩提。般若波罗蜜示现如来世间之灭。示何等灭。从五阴至萨云若。是为世间灭。以是故般若波罗蜜为如来母世间之导。般若波罗蜜示现世间无有今世后世之想。何以故。是法无有今世后世之相。须菩提白佛言。世尊。般若波罗蜜者为大事兴。为不可思议事兴。为不可称量事兴。为不可限事兴。为无有与等事兴。佛言。如是须菩提。是为大事不可思议事兴。云何为大事兴。答言。须菩提。诸如来无所著等正觉。救护一切众生故不舍众生。云何为不可思议事兴。诸佛事自然萨云若不可思议。是故般若波罗蜜为不可思议事兴。云何为不可称量事兴。佛告须菩提。一切众生受身有识。无有能知称量佛事及自然萨云若者。云何为不可限事兴。须菩提。佛事不可限。如来事亦无有限。一切无有与如来等者。况欲出其上。是故般若波罗蜜诸如来无所著等正觉为无有限事兴。须菩提白佛言。世尊。佛事如来事自然事。萨云若不可思议不可称量。为不可限耶。佛言。如是如是。须菩提。是佛事自然事如来事萨云若事不可思议不可称限

佛语须菩提。五阴乃至萨云若不可思议不可称限。须菩提。诸法之法。索意以想亦不可得。佛言。五阴不可思议不可称限。乃至萨云若不可思议。须菩提言。何以故。世尊言。五阴不可思议无有与等者。乃至萨云若亦不可思议无有与等者。佛言。五阴不可为作限。乃至萨云若亦不可为作限。须菩提言。世尊。何以故。五阴萨云若不可为作限。佛言。五阴乃至萨云若不可思议故。不可与作限。于须菩提意云何。不可思议不可限中。宁可得五阴及与道不。须菩提言。世尊。不可得。以是故须菩提。诸法不可思议不可得限。如来之法不可思议无有与等。不可得限亦不可量。是为不可思议。所说亦不可思议。虚空不可思议。亦无有与等者。须菩提。是如来之法。非世间人及诸天阿须伦所能思议。说如来不可思议不可称量不可得限。说无有与等品时。五百比丘二千比丘尼漏尽意解。六万优婆塞二万优婆夷。远尘离垢法眼生。二千菩萨得无所从生法忍。皆当于是贤劫中作佛

    摩诃般若波罗蜜大事兴品第五十一

尔时须菩提白佛言。世尊。是般若波罗蜜甚深甚深为大事兴。不可思议不可称量。无有与等不可得限。佛言。如是须菩提。般若波罗蜜为大事兴。为无有与等事兴。何以故。须菩提。五波罗蜜者。等从中得成。与般若波罗蜜相应。内空外空及有无空。等从般若波罗蜜中出。三十七品十力十八法。等从中出。与般若波罗蜜相应。佛地萨云若慧。等从中出。与般若波罗蜜相应。佛告须菩提。譬如转轮圣王。诸小国有事各自成办。转轮圣王亦无所忧。所以者何。诸小国王素已受圣王教令故。是故不复忧。诸弟子法辟支佛法诸菩萨法及诸佛法。等从般若波罗蜜出。般若波罗蜜者为办其事。是故须菩提。般若波罗蜜为大事兴。为无有与等事兴。不受五阴不入五阴。为应不受不入。乃至萨云若亦尔。须陀洹道至罗汉道辟支佛道亦不受不入。乃至阿耨多罗三耶三菩。不受不入。须菩提白佛言。世尊。云何五阴不受不入。乃至阿耨多罗三耶三菩不受不入。佛告须菩提。于意云何。颇见五阴有所入有所受不。须菩提言不见。世尊。乃至阿耨多罗三耶三菩亦不受不入。须菩提言。世尊。亦不见五阴有受有入。亦不见三耶三佛有受有入。佛言。善哉善哉。须菩提。我亦不见五阴我亦不受持五阴。乃至三耶三菩。我亦不见亦不受持。不见所入。须菩提。我于佛地亦不见。萨云若亦不见。如来事亦不受亦不持。是故须菩提。菩萨摩诃萨亦不当受五阴。亦不当入五阴。于佛事萨云若事如来事。亦不持亦不入。诸欲天子诸色天子俱白佛言。世尊。般若波罗蜜甚深难了。不可思议甚深微妙。是智者所知解。深般若波罗蜜者。世尊。皆是过去佛时。所作功德善本所致。与真知识相得所致。世尊。假令三千大千世界。一切众生皆信三尊。尽得须陀洹斯陀含阿那含阿罗汉辟支佛。是诸圣贤所可有慧所有道德。不如是善男子善女人。于是深般若波罗蜜中。可念观称乐一日之中。其德出彼上。何以故。从须陀洹上至辟支佛智。及信至无所从生法忍。诸天子。不如是善男子善女人于深般若波罗蜜中。书持讽诵守行一日。疾得泥洹。胜罗汉辟支佛道所作功德。或过一劫奉行余经。离般若波罗蜜不住萨云若也。何以故。于是深般若波罗蜜中。广说三乘令诸罗汉辟支佛。各得其信不失所应。诸菩萨摩诃萨。亦于中成阿耨多罗三耶三菩。于是诸色天子诸欲天子。同时叹言。世尊。是摩诃般若波罗蜜不可思议。于是中出信乐。使诸声闻各得所应。成须陀洹斯陀含阿那含阿罗汉辟支佛道。又使诸菩萨摩诃萨。得成阿耨多罗三耶三菩阿惟三佛。是深般若波罗蜜亦不增亦不减。诸色天子诸欲天子。各以头面着地。为佛作礼绕佛三匝已去。去是不远忽然不现。各还天上。须菩提白佛言。若有善男子善女人。闻是深般若波罗蜜。即解者于何所来而生是间。佛告须菩提。若菩萨摩诃萨。闻是深般若波罗蜜。即解不厌亦不狐疑又亦不碍。意常思念欲乐得闻终不远离。若行若起若坐若卧。常随法师意不远离。须菩提譬如新生犊子。意终不欲远离其母。是善男子善女人闻是深般若波罗蜜。讽诵上口乐喜守行解其中义。意亦不欲远离法师须臾之间。是善男子善女人。本从人道中来。今生是间复得为人。所以者何。以是善男子善女人。前世时闻是深般若波罗蜜。书持讽诵守行中事。供养花香缯盖幢幡。以是功德从人道中来。今得深般若波罗蜜闻便即解。须菩提白佛言。世尊。颇有菩萨摩诃萨。如佛所说所作功德。善本具足供养诸佛。复有从彼来生是间。复得深般若波罗蜜。书持讽诵信乐守行。有是者无。佛告须菩提。有从他方供养诸佛。从闻深般若波罗蜜。以是故来生是间复得深般若波罗蜜。闻便即解信乐守行。复次须菩提。当知是菩萨摩诃萨。从兜术天上。亦复具足功德善本。何以故。是菩萨从弥勒菩萨所闻是深经。以是故今来生是间。得深般若波罗蜜闻便即解信乐守行。须菩提若有菩萨于深般若波罗蜜。有狐疑厌意者是人前世时。闻深般若波罗蜜不问中慧。是故今来虽生是间闻六波罗蜜。意续狐疑不信不受亦不喜乐。复次须菩提。是人本闻内空外空及有无空。亦不问中事。是故今续不信不乐。是人前世闻三十七品佛十八法。不信不乐不问中事。是故今来闻般若波罗蜜。惊怪狐疑不信不乐。复次须菩提。若有菩萨闻般若波罗蜜。从一日至五日常问中事。用是故所生处。常得闻深般若波罗蜜。终不离所问。何以故。须菩提。是菩萨但能得闻问其中事于行未备。须菩提。若有人或时欲闻般若波罗蜜。若不欲闻。志不坚固。或能于中起余因缘。譬如轻衣随风东西。当知是菩萨适学未久。不得真知识。未供养过去诸佛。不作功德善本所致。不勤学讽诵所致。未得六波罗蜜所致。未得内外空及有无空所致。不学六通三十七品萨云若所致。当知是新学少乐于法。不能书持般若波罗蜜受学讽诵。亦未能习行其事。须菩提。若有善男子善女人行菩萨道者。得深般若波罗蜜。不念书持讽诵守行。乃至萨云若亦复不念学受亲近故。当知是辈或堕二地。所以者何。是善男子善女人见深般若波罗蜜。不念书持受学亲近故也。是故其人便入二地。当堕罗汉辟支佛道地

    摩诃般若波罗蜜譬喻品第五十二

佛告须菩提。譬如大海中船卒破坏。其船中人不取板木。及取死人而抱持者。知彼人终不能得渡皆当俱没。所以者何。用各不取所依持故。其人若取板木樯者。径便得渡身得安隐。用取所依而以自济。须菩提。若有善男子善女人。行菩萨道者。于信乐少虽得深般若波罗蜜。不讽诵受不依亲近不习行六波罗蜜。乃至萨云若亦不亲近。当知是人中道有碍。不能逮得至萨云若。当取罗汉辟支佛证。须菩提。若有善男子善女人行菩萨道。于阿耨多罗三耶三菩。有信乐。有能有念有解有施有行。得深般若波罗蜜。书持受学亲近讽诵。当知其人能受持深般若波罗蜜。成阿耨多罗三耶三菩。至萨云若终不中碍堕罗汉辟支佛道。能教化众生净佛国土。须菩提。譬如有人持坏瓶行取水。当知不久如是烂坏。所以者何。用未成熟故。须菩提。若有善男子善女人行菩萨道者。虽有信乐有念有施有解有亲近有行。于阿耨多罗三耶三菩。亦不受持六波罗蜜。无沤和拘舍罗。又不受持内空外空及有无空。不受五通三十七品。至萨云若亦不亲近。当知是人中道妨碍。须菩提。何等为中道妨碍。堕于罗汉辟支佛道。譬如有人持成熟瓶。若诣河井若诣陂池而行取水。当知是人得水来归安隐不失。所以者何。用瓶成故。须菩提。若有善男子善女人行菩萨道。于阿耨多罗三耶三菩。有至信乐有施念解有行有慧。受六波罗蜜沤和拘舍罗亲近萨云若。当知是人至阿耨多罗三耶三菩终无挂碍。须菩提。譬如大海有始成船。未牢敞治亦未庄算。便持财货着于船中乘有所诣。当知是船不久中道而坏。亡散财物各在一处。用是贾客无有方便。失所持物亡其大宝。须菩提。若有善男子善女人欲行菩萨事。于阿耨多罗三耶三菩。虽有信乐信施念解。于功德少得深般若波罗蜜。亦不书持讽诵受学。于六波罗蜜亦不受学。亦不亲近萨云若事。无沤和拘舍罗。须菩提。当知是人中道妨碍离失大宝。大宝者萨云若。是中道堕罗汉辟支佛道。譬如有智之人先治其船。算庄牢固。持物着中。乘有所至。当知是人必到所至。得其珍宝安隐无失。所以者何。用其船具牢强所致。若有善男子善女人行菩萨道。有大信乐。有施有念有解有行。于阿耨多罗三耶三菩。得深般若波罗蜜。便受学书持讽诵守行。于六波罗蜜皆有功德。于萨云若意常亲近。乃成阿耨多罗三耶三菩。终不挂碍。不堕罗汉辟支佛道。须菩提。譬如有人年百二十。其人有病若风若寒热。于意云何。其人宁能自起止行步不。须菩提言。世尊不能。所以者何。是人已老。正使无病。犹尚不能起止行步。况复有病。筋力消尽。岂复能行有所至到。须菩提。若有善男子善女人行菩萨道。于阿耨多罗三耶三菩。虽有信乐有施有念有能有行。于六波罗蜜功德中少。亦不亲近萨云若事。无沤和拘舍罗。当知是人中道妨碍。堕罗汉辟支佛道。何以故。不得深般若波罗蜜沤和拘舍罗故。须菩提。向者老公所病已愈。取两健人各扶一腋各持一臂。语老人言。安意莫惧。我当将公在所至处终不相弃。是人宁能有所至不。须菩提言。世尊。能至所处。佛言。若有善男子善女人行菩萨道。于阿耨多罗三耶三菩。有至信乐有能有施有行有慧。于六波罗蜜皆有功德。于萨云若意常亲近。有沤和拘舍罗。知是菩萨终不挂碍。堪任于阿耨多罗三耶三菩。而不动转堕声闻辟支佛道也。是时世尊叹须菩提言。善哉善哉。为诸菩萨摩诃萨今问如来是事。若有菩萨以吾我意想奉行六波罗蜜言。我所为行六波罗蜜。已便贡高菩萨。作是行者终不得度六波罗蜜。是善男子善女人亦不知彼岸亦不知此岸。不为六波罗蜜所持。不为萨云若所持。中道堕罗汉辟支佛地。亦不出生于萨云若。须菩提。云若菩萨无沤和拘舍罗。是善男子善女人行菩萨道。不以沤和拘舍罗。行六波罗蜜。于六波罗蜜皆有吾我想我有所为。行六波罗蜜而自贡高。何以故。六波罗蜜中初无有是念有所分别。有是念者常住此岸。但知此岸不知彼者。不为六波罗蜜所持。亦不为萨云若所持。中道堕罗汉辟支佛道。亦不出生萨云若中。须菩提。如是菩萨不为沤和拘舍罗所持。便堕罗汉辟支佛中。须菩提。云何菩萨行般若波罗蜜。为沤和拘舍罗所持。不堕罗汉辟支佛道。成阿耨多罗三耶三菩。须菩提。菩萨行六波罗蜜无吾我念。于六波罗蜜而不贡高。何以故。六波罗蜜中亦无有念亦不贡高。菩萨知此岸知彼岸者。为六波罗蜜所持。为沤和拘舍罗所持。出生萨云若。不堕罗汉辟支佛道。须菩提。菩萨作如是行者。为不堕罗汉辟支佛道。为六波罗蜜所持。为沤和拘舍罗所持。为萨云若之所护

放光般若经卷第十一放光般若经卷第十二

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜随真知识品第五十三

尔时须菩提白佛言。世尊。新学菩萨云何学六波罗蜜。佛告须菩提。新学菩萨欲学六波罗蜜者。当与真知识相随。常当承事。又复当与能解说般若波罗蜜者相随亦亲近。有能解说是般若波罗蜜者。常当呼人劝助。令学六波罗蜜。当守奉行。当持是得阿耨多罗三耶三菩。莫于阿耨多罗三耶三菩中[打-丁+此]于五阴。亦莫于阿耨多罗三耶三菩中[打-丁+此]六波罗蜜。莫[打-丁+此]于内外空及有无空。莫[打-丁+此]三十七品佛十八法。莫[打-丁+此]萨云若。所以者何。不[打-丁+此]五阴者便逮得萨云若。不[打-丁+此]六波罗蜜者便逮得萨云若。不[打-丁+此]内外空及有无空三十七品佛十八法者便逮得萨云若。当言善男子。行般若波罗蜜。于五阴中莫起想着之意。所以者何。善男子。是五阴非可著者。亦莫于六波罗蜜有所著。善男子。六波罗蜜亦非可著者。亦莫着于内空外空及有无空三十七品佛十八法。乃至萨云若亦莫有着。所以者何。萨云若者亦非有着。亦莫起着于须陀洹斯陀含阿那含阿罗汉辟支佛。亦莫起着于菩萨乘。亦莫起着于阿耨多罗三耶三菩。所以者何。善男子。是阿耨多罗三耶三菩非可著者。何以故。诸法之相皆悉空故。须菩提白佛言。世尊。菩萨摩诃萨甚谦苦于空无相之法。发阿耨多罗三耶三菩。欲得阿惟三佛。佛言。如是须菩提。菩萨甚谦苦于空无相之法。发阿耨多罗三耶三菩。得阿惟三佛。须菩提。为世间故。愍念世间。安隐世间。欲救世间一切众生。以众生故。发阿耨多罗三耶三菩。为世间归。为世间作护。为世间作灯明。故发阿耨多罗三耶三菩。为世间作将。为世间导。为世间舍。为世间趣。故发阿耨多罗三耶三菩。须菩提。云何菩萨为诸众生故发阿耨多罗三耶三菩。度脱五道安隐众生。着无畏岸坦然泥洹。以是故为世间发阿耨多罗三耶三菩。云何菩萨欲安隐世间。须菩提。菩萨摩诃萨。诸有众生有苦恼忧悲者。皆悉度着无忧之岸坦然泥洹。是故菩萨为世间安乐。须菩提。云何菩萨为世间作救。是菩萨摩诃萨世间诸有生死。勤苦救世众生令脱众苦。以法救化次以三乘而度脱之。是故菩萨为世间救。须菩提。云何菩萨为世间护。世间众生有生死之法护令不生。众生皆有老病死法。护使不老不病不死。有忧悲者护令得至无余泥洹。是故菩萨发阿耨多罗三耶三菩为世间护。须菩提。云何菩萨为世间舍。是菩萨摩诃萨。得阿耨多罗三耶三菩阿惟三佛时。为世间说诸法无碍。是故菩萨为世间舍。云何菩萨为世间灯明。菩萨摩诃萨于三界冥中。拔诸众生令立泥洹。是故菩萨为世间灯明。云何菩萨为世间将。是菩萨得阿惟三佛时。为世间说色。非我所是为非色。痛想行识亦非我所是为非识。乃至萨云若为非我所是为非萨云若。须菩提。如色非我是为非色。如色非我诸法亦尔。须菩提白佛言。如世尊所说。五阴非我所诸法亦尔。如是菩萨为不逮觉诸法。何以故。色者无所分别。乃至萨云若亦无所分别。亦不言是五阴亦不言是萨云若。佛告须菩提。如汝所言。五阴无所分别。至萨云若亦无所分别。亦不言是五阴。亦不言是萨云若。须菩提。是亦为大谦苦。常行是法而不厌倦亦不懈怠。菩萨言我亦当逮觉。亦当持是清净之法宣示未学者。须菩提。是故菩萨为世说非我所。须菩提。云何菩萨为世间渚。譬如江河洹海。断流绝域可止顿处。是谓为渚。于人有益。当来过去五阴两断。当来过去萨云若亦两断。如是断者诸法亦断。诸法断者当来过去亦断。如是断者。是则为净是则为快是则为真实是则为空。爱尽无猗无余无尘。是则为泥洹。须菩提。菩萨得阿耨多罗三耶三菩阿惟三佛时。便分流是清净法化真谛法化以济众生。是故菩萨为世间渚。须菩提。云何菩萨为世间将导。菩萨得阿耨多罗三耶三菩阿惟三佛时。为世间众生。说五阴法不生不灭不着不断。作是说法从须陀洹至阿罗汉辟支佛法。为是辈说五阴不生五阴不灭。持是法教流布世间。须菩提。是菩萨得阿惟三佛时作是说法。是为世间将导。须菩提。云何菩萨为世间趣。菩萨得阿耨多罗三耶三菩阿惟三佛时说五阴如趣空。说萨云若如趣空。五阴空者则无所趣。亦不趣亦不不趣。何以故。五阴与空亦不来亦不去。作是说法者。为众生说萨云若空。亦不来亦不去。所趣而无所趣。须菩提。是故菩萨为世间趣。须菩提。何以故。诸法过者。如空一趣不复还。何以故。空亦无来亦无去。诸法所至亦无有相亦无有愿。何以故。相愿一过不复还故。相愿亦不来亦不去。诸法所至亦无所至。亦无有行亦无有生亦无有灭。亦无有着亦无有断。如梦如幻如响如影如化如焰。诸法亦如是。一去亦不复还。何以故。化者亦无去亦无有来。须菩提。诸法所至无有边际亦不复还。诸法亦不动亦不不动。诸法亦不来亦不去。诸法亦不合亦不散。诸法无我无命无寿。须菩提。众生尚无所有。况当有往还。须菩提。诸法所住有常。诸法所住有乐。诸法所住有净。诸法所住有我。诸法无常苦无净非我。诸法所住者。有淫怒痴见有身见。是诸法住亦如如住如法性住。如真际住如普住。如不思议性住。如不动移住。是所住处亦不来亦不去。何以故。诸法亦不来亦不去。诸法住如五阴。何以故。五阴尚不可见。何况当有去来。诸法住如六波罗蜜。是住亦无有还。何以故。六波罗蜜尚不可见。何况当有往还。诸法住如内外空及有无空。如三十七品住。如十八法住。如十八法亦无去亦无来。诸法住如声闻辟支佛道住。如阿耨多罗三耶三菩住。亦无往还。何以故。阿耨多罗三耶三菩无往还无所有故。须菩提白佛言。世尊。是深般若波罗蜜谁能解者。佛言。菩萨摩诃萨从过去佛所作功德。供养无央数百千诸佛。久与真知识相得者。是辈人能解是深般若波罗蜜耳。须菩提白佛言。世尊。菩萨摩诃萨有何等相。能解是深般若波罗蜜。佛告须菩提。若有菩萨于淫怒痴断者。则是其相。须菩提。能解深般若波罗蜜者。淫怒痴像则为已断也

    摩诃般若波罗蜜解深品第五十四

须菩提白佛言。世尊。菩萨摩诃萨。解深般若波罗蜜者为至何趣。佛告须菩提。菩萨摩诃萨能解深般若波罗蜜者。当趣萨云若。须菩提白佛言。如萨云若所趣者。是为菩萨摩诃萨解深般若波罗蜜。趣萨云若者。则为一切众生作导。须菩提言。世尊。念般若波罗蜜者为不念诸法。念般若波罗蜜者为无所念。念般若波罗蜜者为无端绪。佛问须菩提。念般若波罗蜜者。何等为无所念。须菩提言。世尊。念般若波罗蜜者。五阴无所念。念般若波罗蜜者。吾我众生为无所念。念般若波罗蜜者。六波罗蜜为无所念。念般若波罗蜜者。内空外空及有无空三十七品佛十八法为无所念。念般若波罗蜜者。须陀洹至萨云若为无所念。佛言。善哉善哉。如须菩提所言。念般若波罗蜜者为不念五阴。乃至萨云若为无所念。须菩提。六波罗蜜者是阿惟越致菩萨摩诃萨之所应护。有菩萨行深般若波罗蜜。不入六波罗蜜。亦不入萨云若。行般若波罗蜜者不随他人语。不信余道亦不持作要。阿惟越致菩萨摩诃萨。行深般若波罗蜜。不杂淫怒痴。行深般若波罗蜜。阿惟越致菩萨摩诃萨。初不离六波罗蜜。闻说深般若波罗蜜时。亦不恐惧亦不厌倦。终不转还常思念闻。闻已受持讽诵守行。应般若波罗蜜教。须菩提。当知是阿惟越致菩萨。前世已曾闻般若波罗蜜中事。亦讽诵受持已行中事。何以故。不恐不惧。从久远以来。常行是深般若波罗蜜故。须菩提白佛言。世尊。菩萨摩诃萨闻说深般若波罗蜜。不恐不怖亦不动还者。云何于行倍复增益。佛言。行般若波罗蜜者如应萨云若。云何行般若波罗蜜应萨云若。佛言。如依应空无相无愿。为应依深般若波罗蜜。依深般若波罗蜜者。如依虚空。如依无所生如依无所灭。不依于着而依于断。如依于如。依于法性依于不思议依等无作如依梦。须菩提白佛言。世尊。依般若波罗蜜者。如依虚空如依梦者。菩萨行深般若波罗蜜者。不依五阴不依萨云若作行。佛语须菩提。菩萨行般若波罗蜜。亦不依五阴亦不依萨云若。五阴及萨云若。亦无有作者。亦非不作。亦无来亦无去。亦无所止亦无所依。亦无所出亦无所入。亦无有数亦无有限。无数无限者亦无有能逮觉者。从色至识无能逮觉者。亦不从六波罗蜜能逮觉者。亦非萨云若慧能逮觉者。何以故。五阴如萨云若如。五阴与萨云若如俱等无异。十八法如萨云若如。亦等无有异。一等无有二

    摩诃般若波罗蜜叹深品第五十五

尔时诸欲天子诸色天子。以天名花而散佛上。来诣佛所头面作礼。叉手白佛言。世尊。是般若波罗蜜甚深难晓难了。不可思议。是智者之所知。是一切世间所可信者。是诸如来无所著等正觉之道径。从是成阿耨多罗三耶三菩阿惟三佛者。皆是般若波罗蜜之恩。是为一教。一教者五阴则萨云然。萨云然则五阴。萨云然如五阴如。萨云然五阴一如无二。佛如及萨云然如亦无有二。佛告诸欲色天子。如是如是。如诸天子所言。五阴则萨云然。萨云然则五阴。佛则萨云然。萨云然则佛。一如无有二。以是故诸天子。如来坦然无为而不说法。何以故。是法甚深清净。难晓难了特可信故。诸如来之道于过去当来今现在无有逮觉者。于法无有二者是乃为法。诸天子。如虚空之甚深微妙。是法亦如是。以如法之深妙故。是法深妙。法性不可思议性真际无涯底无来无往无著无断不生不灭。甚深微妙无有逮觉者。以无有逮觉者甚深微妙故。般若波罗蜜甚深微妙。诸天子。以诸法甚深微妙故。众生我人寿命亦复甚深微妙。五阴深妙。六波罗蜜深妙。内空外空及有无空三十七品佛十八法至萨云若甚深微妙。以是甚深微妙故。诸天子。般若波罗蜜法甚深微妙。诸欲色天子俱白佛言。世尊。是法于世间特可信者。如是说者亦不受五阴亦不不受。乃至十八法亦无所受亦不不受。如是说者从须陀洹乃至萨云然。亦不受持亦不不受。持诸世间者皆是受持。云何受持。五阴是我所。我是五阴所。十八法是我所。我是十八法所。从须陀洹至萨云然皆是我所。我是萨云若所。是为世间受持。佛告诸天子。如诸天子所言。是法亦不受持五阴。亦不受持萨云然。诸天子。诸有受持行五阴者。受持萨云然行者。则不堪任行六波罗蜜。亦不堪任行萨云然。须菩提白佛言。世尊。是法不逆于诸法而有顺。何等法顺。是法顺六波罗蜜。是法顺内外空及有无空。顺三十七品至萨云然。是为顺法。是法于诸法无所碍。云何无碍。不碍于五阴。至萨云然亦无所碍。是法无碍之相。譬如虚空。何以故。其住如法性如真际如不思议性如空无相无愿。是般若波罗蜜法亦不生亦不灭。以五阴不生不有故。乃至萨云若亦不生亦不有。是法无有迹。以五阴迹不可见故。至萨云若迹亦不可见。尔时诸欲天子诸色天子俱白佛言。世尊。尊者须菩提诸弟子中佛之真子。何以故。所说但说空无缚之法。时须菩提语诸欲色天子言。如卿所说诸弟子中我为真弟子。云何为真子。诸天子报须菩提言。佛从如生无去无来。须菩提如亦不来亦不去。以是故。须菩提从佛生。佛之如者则为一切诸法之如。如诸法如则佛之如。如者亦复非如。是故须菩提为从佛生。如佛如住。须菩提如。亦如是住。如佛之如无作无为亦无所有。须菩提如亦复如是。如佛之如无所挂碍。诸法之如亦无所碍。如佛之如诸法之如。一如无二亦无作者。无作之如常尔无不不尔。从有如尔无不尔时常一无二。是故知尊者须菩提从如来生。如佛之如亦无所坏。须菩提之如亦无所坏亦不不坏。如佛之如。亦不可见不可破坏。须菩提如亦复如是。如佛之如。亦是诸法之如亦无他如。尊者须菩提亦复如是。以是故知。须菩提真从佛生如佛之如。不过去当来今现在。诸法之如亦无去来今。是故知。须菩提为从佛生。过去当来今现在如亦是佛如。佛如者亦是过去当来今现在如等一无二。五阴之如如来之如亦一无二。吾我寿命众生之如。如佛之如亦一无二。六波罗蜜如内外空如。及有无空如三十七品如。乃至萨云然如。如佛之如一如无二。何等为如。须菩提如者菩萨所可逮觉。得如来名号者是。说是如品时三千大千刹土地为六反震动。东踊西没。西踊东没。南踊北没。北踊南没。四面都踊则中央没。适中央踊四面都没。是为六反震动。是时三千大千刹土诸欲天子诸色天子。以天花名香栴檀。用散佛上及散须菩提上。同时叹言。世尊甚奇甚特。尊者须菩提。乃从如来如生真佛之子。是时须菩提。更为诸天子说言。诸天子须菩提者。亦不从五阴生。亦不从五阴如生。亦不离五阴如生。亦不从萨云然如生。亦不离萨云然如生。亦不从有为无为如生。亦不离有为无为如生。何以故。是诸法皆无所有故。亦无法可着乐者。舍利弗白佛言。世尊。如者及尔法住道法甚深甚深。五阴尚不可见况五阴如。乃至萨云然尚不可见况萨云然如。佛言。如是如是。舍利弗。如者甚深五阴及萨云然尚不可见况萨云然如。舍利弗。如者甚深说如及尔。尔时二百比丘僧漏尽意解。五百比丘尼远尘离垢法眼生。五千菩萨天及人得无所从生法忍。六十菩萨漏尽意解。佛告舍利弗。是六十菩萨已便供养五百佛已。尽行六波罗蜜。不持沤和拘舍罗。种种学五波罗蜜。离般若波罗蜜。不以沤和拘舍罗。行施行戒行忍行精进行禅。种种相行不得一定菩萨之道。便得须陀洹及罗汉辟支佛道。舍利弗。菩萨虽得空无相无愿之道。离般若波罗蜜。不持沤和拘舍罗。便证真际得弟子乘。舍利弗白佛言。世尊。云何得空无相无愿之法。离沤和拘舍罗。真际作证便得弟子乘。云何俱得空无相无愿之法。得沤和拘舍罗。便得阿耨多罗三耶三菩。佛告舍利弗言。诸有离萨云然意。念空无相无愿之法。不与沤和拘舍罗俱者。便为弟子乘。舍利弗。菩萨得空无相无愿之法。应萨云然不离沤和拘舍罗者。便得阿耨多罗三耶三菩。舍利弗。譬如大鸟身长一百俞旬二百俞旬三百俞旬。无有两翅。欲从忉利天上来下至阎浮提。已下中道。复欲还去至忉利天上。舍利弗。是鸟宁得如意周旋往反不。舍利弗言。世尊。不得。假令是鸟来下至地。欲使身不痛宁得不痛耶。舍利弗言。世尊。不得不痛或闷或死。所以者何。其身长大无有翅故。舍利弗。正使是菩萨如恒边沙劫。相行五波罗蜜。虽得大道欲发大意。欲逮无量觉慧。离般若波罗蜜无沤和拘舍罗者。便堕罗汉辟支佛道。何以故。离沤和拘舍罗。离萨云若。离般若波罗蜜。行五波罗蜜。便堕罗汉辟支佛道。舍利弗。菩萨虽于过去当来今现在佛所作功德。戒性忍辱精进一心智慧。皆作相着。是为不晓如来戒性三昧智慧解脱见解脱慧。亦不知亦不见。但遥闻空无相无愿之法但相闻声。以相欲为阿耨多罗三耶三菩。作相念言。是为菩萨所住处也。是为佛所住处。是为声闻辟支佛所住处。舍利弗。菩萨离般若波罗蜜沤和拘舍罗者。持是功德欲为阿耨多罗三耶三菩是为相。舍利弗。菩萨发意念萨云然。不离六波罗蜜。不离沤和拘舍罗。不离过去当来今现在诸佛戒性三昧智慧见解脱慧性。不以相着。于空无相无愿亦不以相。舍利弗当知。是菩萨不堕罗汉辟支佛道。何以故。是菩萨摩诃萨从发意以来。不以相行六波罗蜜。不以相于过去来今佛戒性三昧智慧见解脱慧性。皆无相着。舍利弗。不以相行六波罗蜜。不以相行萨云然。是则为菩萨沤和拘舍罗。舍利弗白佛言。世尊。如我今从如来所闻。菩萨不离般若波罗蜜沤和拘舍罗者。以为至阿耨多罗三耶三菩。何以故。以是菩萨从发意以来。初不见法有逮觉者。亦不见甫当逮觉者。亦不见已逮觉者。五阴至萨云然亦复如是。舍利弗言。世尊。若有行菩萨道者。离般若波罗蜜沤和拘舍罗。当知是辈于阿耨多罗三耶三菩便有狐疑。何以故。用离般若波罗蜜沤和拘舍罗故。行六波罗蜜皆于中有相。以是相故当知有狐疑。是故世尊。菩萨欲得阿耨多罗三耶三菩者。不当离般若波罗蜜沤和拘舍罗。住般若波罗蜜沤和拘舍罗亦无相无猗行五波罗蜜者。乃至萨云然亦无相猗。尔时诸欲天子诸色天子俱白佛言。世尊。欲求阿耨多罗三耶三菩者难得。所以者何。为菩萨者尽当逮觉诸法而无所得。佛言。如是如是。诸天子甚难。我亦成阿耨多罗三耶三菩。亦无所成亦无所得。亦不见法有所成得。所以者何。诸天子。诸法常净故。须菩提白佛言。如我今从佛所闻。求阿耨多罗三耶三菩者甚难得。如我意者快哉。得成阿耨多罗三耶三菩。何以故。诸法空无所逮觉故。于空法中诸法不可得。亦无有法逮觉不逮觉者。所以者何。随如法不增不减。学五波罗蜜至萨云然。是法皆空亦不可见亦不可得。以是故。世尊。快哉菩萨逮觉成阿耨多罗三耶三菩。所以者何。五阴五阴自空。萨云然慧事自空。舍利弗语须菩提言。以是故。阿耨多罗三耶三菩难解难得。虚空亦不有念言。我当成阿耨多罗三耶三菩。菩萨亦不念我当成阿耨多罗三耶三菩。何以故。诸法如虚空故。菩萨解诸法如虚空。乃成阿耨多罗三耶三菩。若菩萨知诸法如虚空。快哉难成成阿耨多罗三耶三菩。恒边沙等诸菩萨。求阿耨多罗三耶三菩终不动还。以是故。须菩提。甚快难成成阿耨多罗三耶三菩。须菩提语舍利弗言。于意云何。五阴于阿耨多罗三耶三菩为动还耶。舍利弗言不。乃至如于阿耨多罗三耶三菩为动还耶。舍利弗言不。于意云何。颇有异离五阴为还者无。颇有离萨云然还者不。舍利弗言无。须菩提言。舍利弗于意云何。五阴如为还不。萨云然如为还不。舍利弗言无。颇有离五阴如离萨云然如还者无。舍利弗言无。于舍利弗意云何。如法法性法住道法。真际不可思议性。于阿耨多罗三耶三菩有还者无。舍利弗言无。颇有离如乃至不可思议性有还者无。舍利弗言。无是义。是法亦不可得。何所法于阿耨多罗三耶三菩有还者。舍利弗语须菩提言。如尊者须菩提所说法忍。无有菩萨于阿耨多罗三耶三菩有动还者。如来所记菩萨三乘之行皆无有处。如须菩提所说为一乘耳。分耨曼陀尼子语舍利弗。须菩提为欲说一菩萨乘耶。当问须菩提。舍利弗问须菩提。云何为欲说菩萨一乘行耶。须菩提报言。卿欲于如中说三乘耶。罗汉乘辟支佛乘菩萨佛乘。舍利弗言不也。须菩提言。于舍利弗意云何。于如中颇有三乘不。答言。无有。须菩提言。颇于如中有一事二事三事不。舍利弗言无。颇于如中见一菩萨不。答言无也。是法名无为无所有法。云何欲于中求索三乘罗汉辟支佛三耶三佛。舍利弗。菩萨摩诃萨于如出生诸法。闻是不恐不厌不还。出生于阿耨多罗三耶三菩。尔时佛叹须菩提。善哉善哉。汝之所说皆是佛事。菩萨闻是诸法皆出于如。不恐不惧不厌不还。当知是菩萨成阿耨多罗三耶三菩。舍利弗白佛言。世尊。菩萨摩诃萨当出何道。佛言。是菩萨当出生阿耨多罗三耶三菩道。须菩提言。世尊。菩萨欲出成阿耨多罗三耶三菩。当云何住。佛言。常当等意于众生。大慈普念无有偏党。当为众生说营护念安隐。与语和顺无得中伤。视众生等如父如母如身如子。以慈劝人令不害生。常劝众生令行十善。见人行正离于邪见代其欢喜。菩萨摩诃萨欲得成阿耨多罗三耶三菩。当作是住。自行四谛四禅四等行四空定。劝人令行见人行者代其欢喜。自行六波罗蜜。常劝教人行六波罗蜜。见有行者代其欢喜。自行内外空及有无空三十七品。自行八惟无佛十种力大慈大悲。自行逆顺十二因缘。劝人行逆顺。见有行者代其欢喜。自行声闻辟支佛慧。劝人令行不证真际。见有行者代其欢喜。自上菩萨位教人令进。自行神通净佛国土。教化众生劝彼令学。见有学者代其欢喜。自灭习绪劝彼令灭。自寿命成就自受法住。劝彼住法见彼为者皆代欢喜。须菩提。菩萨摩诃萨欲成阿耨多罗三耶三菩者。当作是学当作是住。菩萨摩诃萨当作是学般若波罗蜜沤和拘舍罗。作如是学如是住者。于五阴无有挂碍。乃至法住亦无挂碍。所以者何。是菩萨摩诃萨。真际学不受五阴。乃至萨云若亦无所受。所以者何。不受五阴则非五阴。不受萨云然则非萨云然。说是菩萨住品时。二千菩萨得无所从生法忍

    摩诃般若波罗蜜阿惟越致品第五十六

于是须菩提白佛言。世尊。我等当以何貌相像。知是阿惟越致。佛告须菩提言。解知凡人地及弟子地辟支佛地乃至如来地。尽是一如而不分别。一无有二入。自身如等。一入不分别。闻是如已直过无狐疑。于如无所失。所说无增减。亦不视他人长短。以是貌像当知是为阿惟越致菩萨。世尊。当复以何相像之貌。知是阿惟越致菩萨。佛言。诸法亦无形亦无貌像亦无有相。须菩提言。世尊。若诸法无形无像亦无相为从何法转还。而为阿惟越致菩萨。佛言。于五阴转还。知是阿惟越致菩萨。须菩提。菩萨于六波罗蜜转还。于内空外空及有无空三十七品佛十八法转还。于声闻辟支佛地及阿耨多罗三耶三菩地转还。须菩提当知。是为阿惟越致菩萨。何以故。须菩提。五阴无有形道亦无有形。是故菩萨于五阴转还及于道。何以故。五阴及道无有处故。复次须菩提。菩萨摩诃萨亦不观视外道及沙门婆罗门所为所知所见。亦不观视诸外道家邪见直见。亦不狐疑。亦不[打-丁+此]外道沙门婆罗门戒。亦不狡戏堕诸邪见。不持香花缯盖幢幡奉诸天神。亦不教他人令奉邪见。以是像貌观其相行具足。知是阿惟越致菩萨。须菩提。阿惟越致不生下贱之家。不生八剧之处。不受女人身。以是像貌具足。知是阿惟越致菩萨。须菩提。阿惟越致常行十善而不毁犯。常于梦中守行十善教人令行。见人行者代其欢喜。以是像貌具足知是为阿惟越致菩萨。须菩提。阿惟越致为众生故。行六波罗蜜。自学十二部经。常作愿言。持是十二部经。劝勉众生满众生愿。持是功德皆施众生。成阿耨多罗三耶三菩。以是像貌具足知是为阿惟越致菩萨。须菩提。阿惟越致。于深经中亦不狐疑平相。须菩提白言。云何阿惟越致于深经法中无有狐疑。佛言。是菩萨亦不见有法。亦不见五阴亦不见道。有平相狐疑者。以是像貌具足知是为阿惟越致。须菩提。阿惟越致菩萨。身口意行常慈柔软。身口意业常施众生。以是像貌具足知是为阿惟越知菩萨。须菩提。阿惟越致菩萨不与五盖事俱。初无恋慕于恩爱意。以是相故。知是为阿惟越致菩萨。须菩提。阿惟越致坐起行步卧觉安详而不卒暴。以是相具足知是阿惟越致菩萨。须菩提。阿惟越致菩萨。净洁自喜无有尘垢。衣服床卧亦复净洁。少于疾病。凡人身中有八万种虫常侵食人。阿惟越致无复是虫。何以故。是菩萨功德。过出世间诸天鬼神阿须伦上。为诸善本。于功德中稍渐增益。身口意净。以是相行像貌具足。是为阿惟越致菩萨。须菩提白佛言。云何菩萨受身口意净。佛言。随诸善本身口意净瑕秽即除。功德稍增瑕秽转灭。是为身口意净。以是三事净。过于声闻辟支佛上。以是相行像貌具足。是为阿惟越致菩萨。须菩提。阿惟越致菩萨不贪利养不贪衣服。具足十二沙门法。行无嫉妒意。亦无愚痴贪利之意。无不等意无懈怠意无恶戒意。以是相行像貌具足。是为阿惟越致菩萨。须菩提。阿惟越致志常安隐。意常深入一意。听受所闻法教与般若波罗蜜俱等意奉行所有俗事。皆与般若波罗蜜俱。有不入法性者。皆见与般若波罗蜜合。以是相行像貌具足知是阿惟越致菩萨须菩提。阿惟越致菩萨。若魔波旬化作大小泥犁一一泥犁中有无数亿千菩萨。皆在其中受诸苦痛。波旬指示语菩萨言。是诸苦人皆过去佛所授记莂。皆是阿惟越致菩萨。今皆堕是中受诸苦痛。今卿若是阿惟越致受记莂者。佛为授卿泥犁记莂。不为授卿菩萨记莂。卿不如舍菩萨道可得生天。不复受是泥犁勤苦。须菩提。若是菩萨意不乱者终不堕泥犁中。当知是为阿惟越致菩萨。时魔波旬复作沙门被服。至菩萨所言。卿前可所受六波罗蜜。欲求阿耨多罗三耶三菩意者。诸可行法今疾悔之。疾悔过者可得解脱。汝前所可供养诸佛及弟子众。从初发意至于法尽。中间所作善本及劝助代欢喜之福。求阿耨多罗三耶三菩。汝疾舍是意早悔过若舍若悔者我便当语汝佛所说深经要法如来所教。汝所闻者皆非佛经非如来教。是异道人所撰集耳。若菩萨得是意乱狐疑者。当知是菩萨非如来所授记莂。是菩萨未正定住阿惟越致地。若菩萨不疑不乱不转意无所受。不信他事不用他教。行六波罗蜜便自具足。疾逮萨云然慧道。自归之不受他教。譬如漏尽罗汉。面自见法不信余教魔终不能耶。阿罗汉辟支佛终不能转阿惟越致菩萨。佛告须菩提。如汝所言罗汉辟支佛不能动转阿惟越致菩萨不能转者为不转还是菩萨必至阿耨多罗三耶三菩。正住阿惟越致地。尚不信如来无所著等正觉何况当信罗汉辟支佛及魔波旬诸异学语。所以者何。初不见有法当可信者亦不见五阴如有可信者。亦不见道如可信者。须菩提。当以是像貌观其相行知是为阿惟越致菩萨。须菩提。魔复化作比丘被服形像。来至菩萨前语菩萨言。善男子。如卿所行。皆世俗事非萨云然行。魔复语言。我当断卿勤苦之本。便为菩萨说像道法教。则是世事像道教者。或示尸解或说四禅及四空定言。善男子。是还正道。从是可得须陀洹道可至罗汉辟支佛道。从我教者可断生死勤苦根本。用是勤苦为学之乎。随我教者。可生欲天得生色天。须菩提。菩萨闻是便大欢喜。不乱不转亦不狐疑。意复念言。今是比丘持是像法来。为我说益我不少。所以者何。像法所说不于须陀洹取证。至于罗汉辟支佛道亦不取证。至阿耨多罗三耶三菩亦不取证。今受是比丘恩。我所应觉知之事今为我说。觉知是已当遍知三乘之事。时魔波旬知菩萨喜语菩萨言。善男子。欲得知供养如恒边沙佛。衣被饮食床卧医药菩萨者。不复从是过去恒边沙佛。受行五波罗蜜。从彼诸佛所闻所问。菩萨摩诃萨当云何住。当云何行。五波罗蜜三十七品大悲大慈。如诸佛所教。当作是行当作是住。如菩萨所应。从是成阿耨多罗三耶三菩。如其教住。如诸行者逮萨云然。诸过去菩萨作是辈行。乃作尔所功德。尚不能得阿耨多罗三耶三菩。卿学以来甫尔。便当那得阿耨多罗三耶三菩。若菩萨闻是意无有异不恐不惧。倍复欢喜言。是辈比丘重复益我。令我得须陀洹至萨云然时魔波旬知是菩萨意不动转。更便化作大比丘众示菩萨言。是辈比丘诸漏已尽。发意求佛不能得佛今皆取罗汉。如是辈人不能得成。况卿欲得阿耨多罗三耶三菩菩萨。觉知是魔事者不堕罗汉辟支佛道。当成阿耨多罗三耶三菩。若有菩萨行檀波罗蜜。至萨云然不动还者。成阿耨多罗三耶三菩。复次须菩提。若有菩萨行般若波罗蜜。作是念言。如佛所说菩萨尽奉持不离诸佛教。至萨云然终不耗减。须菩提。菩萨行般若波罗蜜当作念言。觉知魔事者。终不耗减于阿耨多罗三耶三菩。须菩提。以是相行像貌具足。当知是阿惟越致菩萨。须菩提言。世尊。菩萨于何所转。而言不转还。佛言。于五阴相还。于十二衰相还。于十八性相还。于淫怒痴相还。于见相还。于三十七品相还。于声闻辟支佛相还于佛相还。何以故。阿惟越致菩萨空像色貌法相上菩萨位。于不生法亦无所有。既无所有亦无所作。亦不作亦不生。是故名为无所从生法忍。菩萨得是忍者。则是阿惟越致菩萨摩诃萨。须菩提。以是相行像貌具足。知是阿惟越致菩萨摩诃萨

放光般若经卷第十二放光般若经卷第十三

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜坚固品第五十七

佛告须菩提。彼魔波旬至菩萨所言。萨云若者与虚空等。有无之事皆空。是法及形亦复空。于空无之法初无能得。已过去者亦不能得空无之法。甫当来者亦不能得。有无之相皆空。如空汝唐勤苦。成阿耨多罗三耶三菩者。是皆魔事非三耶三佛所说。诸贤者当觉魔事。卿作是意者。卿将无长夜堕恶趣中。佛言。是善男子善女人若闻是所言。便当觉知是为魔事。魔欲坏我阿耨多罗三耶三菩。是一切诸法有无之事虽与空等。一切众生无能见者无能知者。我当以有无之空为僧那僧涅。逮萨云若为众生说法使得度脱。当令众生得须陀洹道得阿罗汉辟支佛道。令得阿耨多罗三耶三菩。菩萨摩诃萨从发意以来。当坚其意不动不转。不信余事意已坚固。便行六波罗蜜便上菩萨之位。须菩提言。云何世尊。菩萨不动还者为阿惟越致耶。动还者为阿惟越致耶。佛报言。不动转者是阿惟越致。动转者亦是阿惟越致。须菩提言。是事云何世尊。佛言。从阿罗汉辟支佛地动转者。是则阿惟越致。从阿罗汉辟支佛地。虽不动转者是菩萨则为动转者。须菩提以是相行像貌具足是为阿惟越致。有如是相者。彼魔波旬。不能坏菩萨令不至阿耨多罗三耶三菩。须菩提。阿惟越致菩萨。欲得四禅则便能得。欲得灭脱禅亦复能得。欲得三十七品禅空无相无愿禅皆悉能得。欲得五神通者悉能得之。虽受诸禅不取禅证。不取声闻辟支佛证。自取所应以济众生。须菩提。以是相行像貌具足知是阿惟越致菩萨。复次须菩提。阿惟越致。常念于道不离于道。不贪形色。不贪身相。不贪巢窟不贪六波罗蜜。不贪四等亦不贪四空定。不贪神通不贪十力及十八法。不贪佛国亦不贪教授众生。不贪见佛不贪善本。所以者何。于空无法不见空无。无相之法有可贪者。何以故。一切诸法有无之事相皆空故。须菩提。阿惟越致菩萨。已具足菩萨念。具足四事行步坐起卧觉出处。安谛详审终不卒暴用意不忘。须菩提。以是相行像貌具足。是为阿惟越致菩萨。须菩提。阿惟越致菩萨为众生故。以沤和拘舍罗。现在居家五欲之中。施诸穷厄衣被饮食。随人所欲皆供给之。自行六波罗蜜劝彼使行六度。常称叹六度功德。见有行者代其欢喜。阿惟越致处于居家。满阎浮提珍宝。施于众生及三千大千国土珍宝。布施众生初不贪惜。无有淫欲之意。常等法行语言谦下不陵易于人。不使众生起于恚意。须菩提。以是相行像貌具足。是为阿惟越致。复次须菩提。和夷罗洹阅叉常随后护彼。阅叉等言。我常当护是菩萨。至成阿耨多罗三耶三菩。使意不乱终不远离。复有五性和夷阅叉。亦复侍护阿惟越致菩萨摩诃萨。令余小神及非人神无能得其便者。须菩提。阿惟越致菩萨。信根志根精进根三昧根智慧根。诸根具足人中勇猛不为怯弱。须菩提白佛言。云何为勇猛云何不为怯弱。佛语须菩提。于道意坚固不动还者。是则勇猛不为怯弱。当知是为阿惟越致相。复次须菩提。阿惟越致菩萨道念常具足。不学咒术符书不作蛊道。不作医师合和诸药。不学神仙外道卜相。知他男子及女人意。所以者何菩萨于空无法相不见是事。无有是相常愿清净。以是相行像貌具足知是阿惟越致。佛告须菩提。我今当说阿惟越致菩萨像貌相行。谛听谛受。须菩提言。唯世尊受教。佛告须菩提。菩萨行般若波罗蜜者不离于道行。顺应五阴顺应诸性顺应诸衰。所以者何。五阴空故性衰亦空。所行不逆国事。何以故。住于空法亦不见法有增有减者。不逆盗事。何以故。以住于空于空法中亦不见法有持来者亦不持去者。不逆兵事。何以故。住于空性于空法中亦不见法有多有少者。不逆斗事。何以故。住于空法亦不见法有憎有爱者。所语常顺。何以故。住于诸法空如亦不见有常无常故。须菩提。阿惟越致不说城郭事。何以故。住于虚空之空亦不见聚亦不见散。亦不见聚落之事。何以故。住于本际不见有得不见有失。亦不说吾我之事。亦不说种种俗事。但说般若波罗蜜不离萨云然事。行檀波罗蜜不为贪嫉。行尸波罗蜜不为恶戒。行羼波罗蜜不为嗔恚。行惟逮波罗蜜不为懈怠。行禅波罗蜜不为乱意。行般若波罗蜜不为愚痴。行诸法空为诸法主非为非法之主。行于法性赞叹不坏法者。与诸如来缘觉弟子。及诸菩萨及诸新发大道意者。族姓男女共为亲友。常愿欲得见诸如来无所著等正觉。常愿欲见十方诸佛。随所见佛愿往生彼。便得往生昼夜意常不离诸佛之念。何以故。诸阿惟越致菩萨。随顺入欲界。奉行十善得生十方佛前。起第一禅至四禅。从四禅至无形禅。便得生十方佛前。须菩提。以是像貌相行具足。知是阿惟越致菩萨。须菩提。行般若波罗蜜菩萨。住内空者住三十七品者住三脱门者。终不言我是阿惟越致。亦不言我非阿惟越致。自住其地终无有疑。何以故。初不见法有动转不动转者。譬如须陀洹自住其道亦不疑怪。阿惟越致亦譬如是。自住其地教化众生净佛国土。魔事适起即时觉知不随魔教破坏魔事。譬如下愚之人意。欲怀逆恶至死不移。须菩提。阿惟越致菩萨自住其地亦譬如是。诸天及人诸鬼神龙诸阿须伦诸魔波旬所不能移转。所以者何。出诸世间诸天龙鬼神一切之上。自于其地具足五通。教化众生净佛国土。从一佛国至一佛国。于诸佛所殖诸善本。问诸佛受诸教。所住处有魔事即觉知。以沤和拘舍罗处魔事着本际。自于其地亦不疑厌。所以者何。于真际无狐疑。知真际亦不一亦不二。以过罗汉辟支佛地。须菩提。菩萨于是空无法相。亦不见生亦不见灭。亦不见断亦不见着。亦不作念言。我当得阿惟三佛。亦不言我不得阿惟三佛。何以故。以阿耨多罗三耶三菩相自空故。是菩萨自住无所乏短之地。不复悕望余事。无能坏是地者。何以故。须菩提。阿惟越致菩萨。所有慧不与他人共。彼魔波旬化作佛像。来至菩萨所言。来取罗汉亦无有授卿阿耨多罗三耶三菩记者。卿亦未得无所从生法忍。诸如来无所著等正觉。不受卿记莂。卿亦未有是事。亦无是行亦无是相。亦无是像貌任受记莂者。须菩提。菩萨闻是不恐不怖不疑不厌。意无有二者。是菩萨当自知。我已从诸如来无所著等正觉受记莂已。所以者何。菩萨自知我有是事堪任受莂。为阿耨多罗三耶三菩。彼魔波旬复作佛形像来至菩萨所。便以魔事授与菩萨阿耨多罗三耶三菩记莂。是菩萨即觉知或能是魔或能为魔所使。作是像来非是佛。但欲使我堕于罗汉辟支佛耳。须菩提。若魔波旬复作佛像来至菩萨所。语菩萨言。汝所行者非佛所说。亦非弟子所说但魔事耳。须菩提。菩萨即知复是魔耳。或为魔所使是非佛也。欲坏我阿耨多罗三耶三菩意。我意终不可转。是菩萨意不可转者。以从过去诸佛受记莂已。以为住阿惟越致地。何以故。以是像貌相行具足堪任阿惟越致。以是当知阿惟越致相。复次须菩提。行般若波罗蜜菩萨者。欲护持诸法故不惜身命。若菩萨摩诃萨以沤和拘舍罗。乃能作是护法不惜身命者。则为护过去当来今现在诸佛法已。须菩提白佛言。菩萨不惜身命欲护法者。为欲护持何等法耶佛言。我说空法。愚痴之人骂詈诽谤言。是非法亦非律行又非尊教。须菩提。为是法故菩萨摩诃萨护持正法。菩萨当作是念。诸当来佛所可说法。我亦在是数中受记。是法亦复是我法。以是法故不惜身命。须菩提。菩萨为是法故不惜身命。以是像貌相行具足知是阿惟越致。复次须菩提。阿惟越致闻说深法。亦不狐疑亦不惊怪。诸佛所说皆能受持终不遗忘。所以者何。用得陀邻尼故。须菩提白佛言。世尊。菩萨得何等陀邻尼。能受持诸如来无所著等正觉法而不遗忘。佛言。菩萨以得闻持等陀邻尼。便能受持诸佛经法而不遗忘。世尊。如来所言非声闻所说。亦非天龙鬼神所说。亦非阿须伦真陀罗摩休勒所说。佛告须菩提。诸所有音声之名。是菩萨闻是初不惊怪意无狐疑。用得陀邻尼故。以是像貌相行具足。是为阿惟越致菩萨摩诃萨

    摩诃般若波罗蜜甚深品第五十八

须菩提白佛言。世尊。阿惟越致菩萨大功德具足。不可称量功德具足。佛告须菩提。如是如是。阿惟越致有大功德不可得称量功德具足。所以者何。以得无碍无限之慧。非诸罗汉辟支佛所能及故。阿惟越致住是慧中便受神通。亦非诸天世间人民所能及者。须菩提白佛言。世尊。能以恒边沙劫之寿。叹说阿惟越致菩萨摩诃萨功德。像貌相行具足。所入所住深奥之慧。行六波罗蜜具足三十七品及萨云然。可令人得知是阿惟越致菩萨摩诃萨功德者不。佛言。善哉善哉。须菩提。汝乃能问阿惟越致深奥之处。说甚深空无相无愿。说无所有说无所生灭。诸淫垢说泥洹净。说如说寂真际法性。是诸深法皆是泥洹之像。须菩提言。世尊。如是说者但是甚深泥洹非诸法之教耶。佛言。须菩提。甚深亦是诸法之教也。须菩提。五阴甚深六衰甚深乃至于道亦复甚深。须菩提。五阴云何甚深。五阴如如以是甚深亦如道如。是故五阴甚深道亦甚深。云何如如。夫如者亦非五阴亦不离五阴。如亦非道亦不离道。须菩提白佛言。世尊。阿惟越致菩萨摩诃萨。甚奇甚特甚深微妙乃尔。除五阴处泥洹。若道若俗之所有法。所作无作有漏无漏。皆悉已除处于泥洹。佛告须菩提。若菩萨摩诃萨应般若波罗蜜深妙之法若念若持自念所住当如般若波罗蜜教住。所学亦当如般若波罗蜜教。是菩萨尽具足如般若波罗蜜教。持是具足之念受无央数善本功德。舍无量劫生死之难何况至意守行与般若波罗蜜与道相应者。譬如士夫情多放逸。与彼端正女人克期。其女人有事不得时往。未到之间于意云何。彼人为有几意起想。须菩提言。世尊。是想甚多甚多。佛告须菩提。菩萨奉行般若波罗蜜如其中教。至念一日意不转者。却若干劫生死之垢。是菩萨应般若波罗蜜行。一日所受善本功德。胜于菩萨但行布施如恒边沙劫。复次须菩提。菩萨布施三尊如恒边沙劫于意云何。其人殖福宁为多不。须菩提言。世尊。甚多甚多不可称计。佛言。不如是菩萨摩诃萨念般若波罗蜜。应行一日如般若波罗蜜中教。其功德不可计。何以故。菩萨因是乘疾得成阿耨多罗三耶三菩故。须菩提。若有菩萨行般若波罗蜜。以恒边沙劫之寿。为须陀洹作功德。及罗汉辟支佛作功德。至三耶三佛作善本。于意云何。其人功德宁为多不。须菩提言。世尊。甚多甚多。佛言。不如是菩萨行般若波罗蜜如中教。其功德不可计。何以故。菩萨行般若波罗蜜。已过罗汉辟支佛地故。从菩萨位成至阿耨多罗三耶三菩故。须菩提。若有菩萨寿如恒边沙劫。行六波罗蜜。其人功德宁多不。须菩提言。甚多甚多。佛言。不如是菩萨随般若波罗蜜教。一日如中行六波罗蜜。其功德不可计。何以故。般若波罗蜜者。是菩萨摩诃萨之母。住是般若波罗蜜中。具足诸佛法故。须菩提。若有菩萨行般若波罗蜜如。恒边沙劫之寿行法之施。于意云何。其人功德宁多不。须菩提言。甚多甚多。佛言。不如是菩萨行般若波罗蜜如中教一日法施其功德不可计。何以故。菩萨不离般若波罗蜜者。则为不离萨云然。菩萨欲得成阿耨多罗三耶三菩。不当离般若波罗蜜。须菩提。若有菩萨行般若波罗蜜如恒边沙寿。行三十七品及空无相无愿。其人功德宁为多不。须菩提言。世尊甚多甚多。佛言。不如是菩萨行般若波罗蜜如其中教。一日如般若波罗蜜中教。行三十七品及十八法。其功德不可计。何以故。初不见有菩萨行般若波罗蜜。从萨云然有还者。离般若波罗蜜者便有动还故。须菩提。是故菩萨不当离般若波罗蜜。佛告须菩提。若有菩萨以恒边沙劫之寿。行六波罗蜜所有财物饮食布施以法布施及诸三昧事。欲为阿耨多罗三耶三菩。其人功德宁为多不。须菩提言。世尊甚多甚多。佛言。不如是菩萨行般若波罗蜜如中教。所可布施及法施与诸三昧事。欲为阿耨多罗三耶三菩。其功德不可计。所以者何。如般若波罗蜜教者。于诸功德中为最第一。离般若波罗蜜念者。是为非念亦为非求。复次须菩提。菩萨欲发阿耨多罗三耶三菩者。当善于智求。须菩提。若有菩萨习行六波罗蜜者。寿如恒边沙劫。劝助过去当求现在诸佛及僧所作功德代其欢喜。持是欢喜持作阿耨多罗三耶三菩。其功德宁多不。须菩提言。世尊甚多甚多。佛言。不如是菩萨一日与般若波罗蜜教相应。持是功德当成阿耨多罗三耶三菩。须菩提。菩萨欲得阿耨多罗三耶三菩者。当善于智求。须菩提白佛言。世尊。如佛所说。菩萨从无所作为为最第一。若无所作无所为者。云何而得正见须陀洹及罗汉辟支佛至萨云然。成阿惟三佛。佛言。如是如是。须菩提。不可从有所作。得须陀洹至萨云然。成阿惟三佛。行般若波罗蜜布施亦不求。有所作亦不有是布施意。常念言是布施空亦无所有。何以故是菩萨学善于内外空及有无空故。须菩提。菩萨住是空已。观诸所作作是空观。则已不离般若波罗蜜。不离般若波罗蜜则受无有数无有限无有量诸福功德。须菩提白佛言。无有数无有限无有量有何等异。佛言。阿僧祇者为无有数。有数身亦不可得。无有数身亦不可得。无有量者。当来过去今现在不可限不可量亦不可思议。须菩提白佛言。世尊。可使五阴不可量不可数不可限不。佛言有是。须菩提言。世尊。何因五阴不可量不可数不可限。佛言。五阴空不可数不可量。云何世尊。但五阴空诸法为不空耶。佛言。我初不说诸法空耶。世尊。亦说诸法空耳。世尊。空者为是不可尽。为是不可数。为是不可量。空者不可数不可量亦不可平相。世尊。是法义解亦不可得若干。佛言。如须菩提所说无异。以诸法不可得故。佛说若干不可得。是法空无相无愿无所有无所生。是为灭是为泥洹。是为如来无尽至于泥洹。须菩提白佛言。未曾有世尊。甚奇甚特。如世尊所说无所得法我听。世尊所说诸法亦不可得。以诸法不可得。空亦不可得。不可得义为有增减不。佛言。无有增减。须菩提言。六波罗蜜亦无增减。三十七品亦不增减。八惟无禅四无碍慧四等。佛十八法及十种力四无所畏。亦无增亦无减。须菩提言。世尊。若是法从六波罗蜜至四无所畏。若有增有减者便不成阿耨多罗三耶三菩。须菩提如是如是。不可得之法亦无增亦无减。若行般若波罗蜜。若念般若波罗蜜。若习般若波罗蜜沤和拘舍罗。亦不念言我增六波罗蜜。亦不念我减六波罗蜜。当作是念。但有名故有六波罗蜜。持是所念持是发意持是善本。施作阿耨多罗三耶三菩如诸法如。须菩提白佛言。云何为阿耨多罗三耶三菩如诸法如。世尊。何等为诸法之如。为阿耨多罗三耶三菩。佛言。五阴之如泥洹之如。是故为阿耨多罗三耶三菩。是亦不增亦不减。是故菩萨不离般若波罗蜜。倍复精进行般若波罗蜜。亦不见诸法有增有减者。是故不可得法亦无增减。须菩提。是故六波罗蜜亦不增减。至四无碍。亦不增减。菩萨行般若波罗蜜。当作是不增不减之意。须菩提白佛言。世尊。菩萨摩诃萨成阿耨多罗三耶三菩。为用初时意得成。为用后头意得成。前意后意各各不俱。云何善本得聚。成阿耨多罗三耶三菩。世尊。是不俱不同之意。云何有所成功德。不成不聚不得成阿耨多罗三耶三菩。佛告须菩提。我当为汝说譬喻。诸有智之士以譬喻得解。于意云何。譬如灯炷。始然之时。为用初明得然。为用后明得然。炷燋之时为用初时明燋。为用后时明燋。须菩提言世尊。亦不用初头焰得然。亦不离初焰因缘得然。亦不用后焰得然。亦不离后焰因缘。须菩提。菩萨亦不用初意得阿耨多罗三耶三菩。亦不离初意因缘。亦不用后意得。亦不离后意因缘得。须菩提。菩萨行般若波罗蜜。从初发意至十住地。成阿耨多罗三耶三菩。世尊。云何从十住地成阿耨多罗三耶三菩。佛言。先从智地观地。具足阿耨多罗三耶三菩。从八辈观地薄地离淫地已办地辟支佛地菩萨地阿耨多罗三耶三菩地佛地。具足佛地已。便成阿耨多罗三耶三菩。菩萨于是十地学。亦不从初发意得阿耨多罗三耶三菩。亦不离初发意得。亦不以后意得亦不离后意得。须菩提言。世尊。十二因缘起甚深。不以初发意得阿耨多罗三耶三菩。亦不离初发意因缘。亦不用后意得阿耨多罗三耶三菩。亦不离后意而成阿耨多罗三耶三菩。须菩提于意云何。意已灭可复使更生不。世尊。已灭不复生。须菩提。意已生为是灭法不。世尊。是实灭法。佛言。已灭法者是为灭不。世尊不也。须菩提于意云何。为正尔住不。世尊住如如住。佛告须菩提。若如住者。真际住当住如如耶。不也世尊。佛言。于须菩提意云何。如者为甚深不。世尊甚深甚深。须菩提。如者为是意耶。不也世尊。如非意。须菩提。意为离如耶。不也世尊。须菩提。如以如为相见不。不也世尊。如如不相见。须菩提。如是行者为行深般若波罗蜜不。须菩提言。世尊。如是行者为行深般若波罗蜜。须菩提言。作如是行为行何法世尊。佛言。作是行者为无所行。何以故。行般若波罗蜜者无若干行。世尊。夫如者亦无若干亦无作若干行。佛告须菩提。菩萨行般若波罗蜜为行何等。对曰。为行毕竟无有二处佛言。行毕竟者为有若干行为有相。行耶。无有世尊。佛言。无相为有相念耶。无有世尊。佛言。云何有相念。须菩提言。世尊。菩萨行般若波罗蜜。亦不作是念有相无相。菩萨行般若波罗蜜不具佛十种力及十八法。不成阿耨多罗三耶三菩。菩萨沤和拘舍罗于诸法无所念亦不不念。何以故。菩萨知一切诸法相皆空故。住空法为众生故行三三昧。持是三昧教化众生。世尊。菩萨摩诃萨何等三三昧。佛言。住是三昧者。与空无相无愿相应。一切众生皆着于空着于相愿。菩萨摩诃萨。安处众生以空无相无愿之法。行般若波罗蜜。菩萨以是三事教化众生

    摩诃般若波罗蜜梦中行品第五十九

尔时舍利弗语须菩提。菩萨于梦中行三事三昧空无相无愿。于梦中行是宁有益于般若波罗蜜不。须菩提报舍利弗言。若于昼日有益于般若波罗蜜者。夜梦中亦当复有益。所以者何。昼夜梦中等无异。舍利弗。菩萨行般若波罗蜜。若有般若波罗蜜者。于梦中便当念般若波罗蜜。舍利弗语须菩提。若菩萨于梦中有所作宁有所成受不。如佛所言。诸法如梦是故无所成无所受。何以故。梦中初不见有法有所成者。有所受者亦无所得。若梦觉已宁有所得不。须菩提言。若于梦中有所害杀。言我杀是快耶。觉已念梦中所作是云何。舍利弗言。皆有因缘。无因缘终不起须菩提言。如是如是。事有因缘。有缘有念。有念有事。事从闻见。便有觉意。便有着断。不从不闻不见而有缘起。是故舍利弗。以因缘故有事起有念生。舍利弗言。云何须菩提所念所作。佛言皆寂。云何所作有缘有起有所成受。须菩提言。起想便有因缘。有缘便有事。有事便有念。舍利弗言。若菩萨于梦中行六波罗蜜。持是功德念欲为阿耨多罗三耶三菩。是为有所施作不。须菩提言。今弥勒菩萨摩诃萨。为世尊所记在是可问。弥勒能解当从其问。舍利弗白弥勒言。我所问者。须菩提言弥勒能解。今仁者当为我等解。是时弥勒语舍利弗言。卿等欲使我当以名以色以痛想行识而发遣耶。当以何事而解说乎。当以色空而发遣耶。当以痛想行识空而发遣乎。色空亦无能发遣。痛想行识空亦无所发遣。我初不见法有能发遣法者。亦无有受记莂受阿耨多罗三耶三菩者。亦无受莂处者。是法都无有二。舍利弗言。如仁者所说为得证也。弥勒答言。虽作是说我亦不得证。舍利弗意念。弥勒菩萨辩才深入于六波罗蜜中。种种发遣而无所倚。佛告舍利弗。汝颇见是法得罗汉证者不。舍利弗言。世尊。不见是法有得证者。佛言。菩萨行般若波罗蜜。亦不念言是法已受莂。是法当受莂得阿耨多罗三耶三菩者。菩萨作是行。为行般若波罗蜜亦不有疑。我当得阿惟三佛亦不疑不得。复次须菩提。菩萨行檀波罗蜜时。若见众生有饥渴者衣不盖形孤贫穷厄不能自存者。当起大哀愿。我得阿耨多罗三耶三菩阿惟三佛时。使我境界无有是辈困苦之类。使我佛土所有衣服饮食之具。如四天上如忉利天第六天王。所有饮食衣服自然。须菩提。菩萨作是行者。便为具足檀波罗蜜。复次须菩提。菩萨行尸波罗蜜。若见众生有不慈意残杀众命。邪见疑网犯十恶者。见有短命多病。少威丑无颜色。形残羸劣极下贱者。起大悲意。使我奉行尸波罗蜜。我得佛时使我境内无有是辈。菩萨如是为具足戒。疾得阿惟三佛不久。须菩提。菩萨行羼波罗蜜时。若见众生有嗔恚意。捶杖刀矛瓦石相加。相伤杀者起大愿言。我当行忍至得佛时。令我境内无有是辈诸恶事者。我作佛时令我国土中一切众生。皆同慈意和志相视。如父如母若兄若弟相向无害。菩萨作是行者。为具足忍疾得阿惟三佛不久。复次须菩提。菩萨行惟逮波罗蜜时。若见众生于三乘法起相懈怠无精进者。复起大愿。我当自勉精进不懈。我得佛时令我国中众生精进于三乘法各得度脱。菩萨如是为具足精进疾得阿惟三佛不久。复次须菩提。菩萨行禅波罗蜜时。若见众生行五盖事。一者淫劮二者嗔恚三者睡卧四者调戏五者疑网。离于四禅离四空定者。起大意愿。令我常当行禅波罗蜜教化众生净佛国土。我得佛时令我国土一切众生无乱志者。菩萨如是为具足禅疾得阿惟三佛不久。复次须菩提。菩萨行般若波罗蜜时。若见众生有犯恶者。若俗若道离正见者。行无道之事者。言无报者。言便断者。言有众生者。作是见已起大愿言。我当勤力行六波罗蜜净佛国土教化众生。我作佛时令我国中无有是辈邪见之事。菩萨如是为具足般若波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见众生在于三际。一者直见际二者邪见际三者亦不在邪亦不在正见际。是以我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国人。不见邪见不闻邪见之声。菩萨如是是为具足六波罗蜜疾近萨云然。复次须菩提菩萨行六波罗蜜时。若见泥犁薜荔畜生蠕动之类。当发大慈。我当勤力行六波罗蜜。我作佛时令我国中。不闻有三恶道之名。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见大地山陵沟坑。荆棘草木不净秽恶。发普愿言。我当勤力行六波罗蜜。我得佛时令我国土皆平如掌。令我国人不见诸秽。菩萨如是为具足六波罗蜜疾近萨云然复次须菩提。菩萨行六波罗蜜时。若见大地无有金宝但淳以土发意愿言。我当勤力行六波罗蜜我得佛时令我土地从下际以上淳以黄金为地。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见众生有所恋著者发是愿言。我当勤力行六波罗蜜。我作佛时令我国人莫有所恋着。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见四姓刹利梵志。田家工师长吏将师发意愿言。我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国中无有四姓淳以一姓。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见众生有上中下家者复发愿言。我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国中一切众生。无是优劣有上中下。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见众生有种种色发意愿言。我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国人无若干色。皆悉端正得第一色。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见国主发意愿言。我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国土无有王者之号。但以如来无所著等正觉以为法王。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。若见五趣之行发意愿言。我当勤力行六波罗蜜教化众生净佛国土。我作佛时使我国人。皆令无有五趣之行。等以三十七品为行。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。见四种生卵生湿生胎生化生发意愿言。我当勤力行六波罗蜜。教化众生净佛国土。我作佛时令我国中。无有三生等一化生。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。见诸众生无有五通无有光明。复发愿言。我作佛时令我国中尽得五通。皆有光明远有所照。菩萨行六波罗蜜时。若见众生有大小便利。发意愿言。我作佛时令我国人等如天身无复便利之患。菩萨行六波罗蜜时发大愿言。我作佛时令我国土无有一日一月一岁十岁都无此数。菩萨行六波罗蜜时。若见众生短命发大愿言。我作佛时令我国中人寿命极长无有限数。菩萨如是便具足六波罗蜜。成阿耨多罗三耶三菩阿惟三佛。菩萨行六波罗蜜时。若见众生无有相者发大愿言。我当勤力行六波罗蜜。我作佛时令我国人普得具足三十二大人之相。菩萨如是为具足六波罗蜜疾近萨云然。菩萨行六波罗蜜时。若见众生无有善本。我成阿惟三佛时。令我国人具足善本。等如如来无所著等正觉。作是念者具足六度疾近萨云然。复次须菩提。菩萨行六波罗蜜时。言我当勤力疾成阿耨多罗三耶三菩。令我国中无有三垢四病。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜时。言我当勤力疾成阿耨多罗三耶三菩。我作佛时使我国中无有二道之名。普等至萨云然。复次须菩提。菩萨行六波罗蜜成阿惟三佛。使我国土中不闻项佷之名。须菩提菩萨行六波罗蜜当作是念。我未便成阿惟三佛。先当知我寿命光明比丘僧数。然后乃成阿惟三佛。一切无有能知我年寿劫数比丘数者。菩萨如是为具足六波罗蜜疾近萨云然。复次须菩提。菩萨行六波罗蜜作如是念言。我作佛时令我一国大如恒边沙佛国。菩萨如是为具足阿耨多罗三耶三菩疾近萨云然。复次须菩提。菩萨行六波罗蜜当作是愿。生死道长众生甚多。虚空无边。众生之性亦无有边。于中亦无生者亦无泥洹者。如是念者。为具足六波罗蜜疾近萨云然

    摩诃般若波罗蜜恒加调品第六十

尔时坐中有一女人名恒加调。从坐起整衣服。为佛作礼长跪叉手白佛言。我亦当奉行六波罗蜜摄取佛国。如世尊说般若波罗蜜事。是女人叹佛已。以金银花及水陆花着身璎珞金色之[疊*毛]。而以散佛。当头上化成四柱宝交露台。严事净如是未曾有。是女人言。持是功德施与众生。皆共发阿耨多罗三耶三菩。尔时世尊知女人意便笑。如诸佛法。若干色光从口中出。遍照诸十方无央数佛刹。绕身三匝还从顶入。时阿难从坐起整衣服长跪叉手白佛。佛何因笑。愿闻笑意。佛告阿难。是恒加调弟。当来之世当作佛。号名金华如来无所著等正觉。毕女人身受男子形。后当生于妙乐佛国。于彼国修梵行。是菩萨摩诃萨。在所生国常有金华名号。于彼刹尽其寿普游诸国。从一佛至一佛不离诸佛。阿难。譬如转轮圣王。从一观至一观。从生至竟足不蹈地。是金华菩萨亦复如是。至成阿惟三佛未曾不见佛。时阿难意念。是金华菩萨后作佛时。诸会菩萨为是佛会。佛知阿难意之所念。告阿难言。如是如是。当知彼时菩萨会者是为佛会。彼比丘僧甚多不可计。不可以千数万数亿数。无有限量。阿难。是金华菩萨成如来无所著等正觉时。其国土所有一切众恶诸不善事悉皆无有。如向所说般若波罗蜜净妙国土。等无有异。阿难白佛言。世尊。是弟从何佛以来殖功德本。佛告阿难。是弟乃从提和竭罗如来无所著等正觉所始发尊意。亦复以金花散提和竭佛。散彼佛时意亦愿言。持是功德成阿耨多罗三耶三菩。如我以五华散提和竭罗佛上。发阿耨多罗三耶三菩。于时彼佛知我功德具足。便记我阿耨多罗三耶三菩莂。是金华菩萨尔时见我受记便发愿言。我亦当受莂如是菩萨受莂。阿难。是金华菩萨乃从提和竭罗初始发意。阿难白佛言。世尊。是女人以办阿耨多罗三耶三菩。佛告阿难。如是如是。是弟以为成办阿耨多罗三耶三菩阿惟三佛

放光般若经卷第十三放光般若经卷第十四

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜问相行愿品第六十一

须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜。云何行空三昧无相三昧无愿三昧。当云何入当云何行。当云何行三十七品当云何念。佛告须菩提。菩萨摩诃萨行般若波罗蜜。观五阴空。乃至欲界色无色界观空。当作是观意而不乱于诸法无所见。适无所见于诸法不作证。何以故。善学于空法故。至于得证亦不断。诸法不决定。于诸法所可得证亦不见证亦不见是法。须菩提白佛言。世尊。云何如佛所说。菩萨不于空法取证。云何住空而复取证。佛告须菩提。观空具足无所乏短亦不念言。我当受证是亦非证。菩萨之法所应所行。不以证为期但以行为期。菩萨亦不定意亦不有所而系意。于三十七品而不耗减。亦不受漏尽之证。何以故。菩萨摩诃萨以具足于深妙之法故。何以故。菩萨已住于三十七品。作是知言。是为行时非为证时。菩萨行般若波罗蜜当作是观。言今正是行五波罗蜜时非是证时。今正是行三十七品时非是证时。今正是行三三昧时。行十种力四等大慈大悲。是行萨云若时。非是须陀洹罗汉辟支佛道证时。须菩提。菩萨行般若波罗蜜。因三三昧行空无相无愿三昧。因三十七品行根力觉意法亦不取证。因三十七品而作作行。不受声闻证。须菩提。譬如士夫端正勇健。猛于兵法。坚持铠杖具足悉晓六十四能皆明诸术。众人无不爱敬者。所作事物无不成办。见众敬侍倍复欢喜。若以他事当有所至。道过厄难危险之处多有怨憎。彼怨家者亦复勇猛。所将群从父母大小莫不惊怖。时勇猛者安隐父母慰诸群从言。莫有恐畏我有术能无所乏短。自当得脱此诸厄难。既得脱难降伏怨敌而无所害。以至所在安隐父母群从莫不欢喜。所以者何。用是男子勇健雄猛具足诸术无乏短故。佛告须菩提。菩萨以四等意。慈悲喜护。为众生故具足六度。未得漏尽。开萨云若之大径路以住于空无相无愿。亦不以空无相无愿随至为证。具足不堕罗汉辟支佛地。譬如众鸟飞行空中。而不堕地亦不住空。菩萨如是行空无相无愿三昧而不取证。度于罗汉辟支佛地。悉当具足佛十种力四无所畏及十八法萨云然慧。终不取证。须菩提。譬如士夫壮勇多力。善于射术仰射虚空。寻以后箭射于前箭。箭箭相柱不得令箭有堕地者。意欲令堕便止。后箭不复射者尔乃堕耳。须菩提。菩萨摩诃萨行般若波罗蜜。为沤和拘舍罗所持。殖诸功德具足一切众善之本。一事不具终不中道取证。至成阿耨多罗三耶三菩阿惟三佛。功德具足尔乃于真际作证。是故须菩提。菩萨行般若波罗蜜。当具足是上诸法。须菩提白佛言。世尊。菩萨学是谦苦甚难。作是学者为学真际。是为学如为学法性为学本空为学自空为学三脱。如是所学而不中道有厌。世尊。大哉甚奇甚特。佛告须菩提。所以者何。菩萨有愿志不舍一切众生故。须菩提。菩萨若有意不舍众生。尽当度脱一切众生于无端绪之法。出生三脱门。当知是为沤和拘舍罗。菩萨要当成萨云若慧。终不中道真际取证。复次须菩提。菩萨欲得观知诸深法处者。内空外空及有无空。三十七品及三脱门。当作是念。一切众生长夜常有我想人想。有寿命想有见知想。所念所作皆依是想。是故菩萨摩诃萨。普见众生有是辈想。欲为众生除是念想。成阿耨多罗三耶三菩而为说法。行空三昧无相无愿。虽作是行终不中道取罗汉辟支佛证。须菩提。用是菩萨有是愿故。功德具足故。亦不中道取证。不失四禅。不失四等及四空定。不失三十七品法及三脱门四无所畏四无碍慧。不失十力及十八法。便得具足诸所有之法。终不失阿耨多罗三耶三菩。诸有菩萨为沤和拘舍罗所护持者。具足功德善法转增。诸根通利过于罗汉辟支佛根。复次须菩提。菩萨常念众生行四颠倒。有常想有净想有乐想有我想。当为是辈我当行道。成阿惟三佛时当为说法。为说无常为说不净无乐无我。菩萨如是意行具足者。是为沤和拘舍罗行般若波罗蜜。悉当具足十力四无所畏大悲四等。三十七品无愿三昧。然后乃当坐佛三昧真际取证。菩萨作是念言。一切众生常有倚着。常着吾我着于寿命。着于五阴着于六衰着于十八法。着于四禅着于四空定着于四等。我成阿耨多罗三耶三菩阿惟三佛时。当使众生皆无有是倚着之病。持是意行以沤和拘舍罗行般若波罗蜜。未具足十力四无所畏四无碍慧无愿三昧终不中道取证。具足诸愿尔乃取证。复次须菩提。菩萨行般若波罗蜜。意复念言。众生长夜常着想行或想念。男女有色无色想。我当勤行成阿耨多罗三耶三菩时。令我众生无想着病。以具足是念以沤和拘舍罗行般若波罗蜜。十力不具足。及四无所畏佛十八法未具足者终不取证。成诸功德具足无相三昧尔乃取证。须菩提。菩萨行六波罗蜜。内空外空及有无空。三十七品佛十八法具足是行。不与三界共同行也。须菩提。菩萨行是三十七品。行三十七品已当问言。菩萨云何欲得阿耨多罗三耶三菩。不以空为证以觉真际得须陀洹斯陀含阿那含阿罗汉辟支佛道。亦不证无相无愿。亦不证灭。亦不证所作。亦不证所生。亦不证无所有。而念般若波罗蜜。须菩提。若有菩萨问诸菩萨。若闻说空则当念空。若闻无相无愿当念无相无愿。若闻无所作当念无所作。闻无所生无所有当念无所生无所有。但当行空三十七品。不行无相不行无愿不行无所作亦不行无所生。须菩提。当知是菩萨未受记莂。未从诸佛受记莂。何以故。阿惟越致菩萨亦不作是念。亦不作是行亦不作是说亦不作是想。但行阿惟越致菩萨事。但念是事但行但说但想是事。须菩提。当知是菩萨已过诸地。如阿惟越致地。以过阿惟越致地。须菩提白佛言。世尊。是菩萨为得阿惟越致不。佛言。若有菩萨闻六波罗蜜。若不闻所作行事。如阿惟越致菩萨。须菩提白佛言。多有人行佛道者。少有如阿惟越致菩萨所行者。何以故。少有菩萨受阿惟越致慧地记莂。受阿惟越菩萨莂者。为已远离上诸想着不具足事。是菩萨摩诃萨诸天世间人无能及者

    摩诃般若波罗蜜阿惟越致相品第六十二

佛告须菩提。菩萨梦中不近罗汉辟支佛地。亦不近三界亦不坏三界。亦不起意视诸法。如梦如响如幻如热时焰。视诸法如化而不作证。须菩提。是菩萨摩诃萨是为阿惟越致相。复次须菩提。菩萨梦中见佛。与若干百千不可计数四辈之众围绕说法。从佛闻法即解中义。所作常不离法。所说不失法则。须菩提。当知是为阿惟越致相。复次须菩提。菩萨梦中见佛。如来踊在虚空。身有三十二相八十种好变化神通。为比丘僧说法变化。使人诣他佛土施作佛事。须菩提。是为阿惟越致相。复次须菩提。菩萨梦中。若见郡县兵起相杀。若有火灾若见虎狼师子毒虫诸恐畏之事忧悲苦恼。若见饥饿若见丧失父母兄弟亲友知识。梦见是已不恐不怖。于梦觉已便作念言。三界所有皆如梦耳。我当精进成阿惟三佛已。当为三界众生说法。须菩提。是为阿惟越致相。佛告须菩提。一切人尽当云何知是菩萨成阿耨多罗三耶三菩。须菩提。菩萨若见泥犁薜荔禽兽三恶趣中诸勤苦者。当发愿言。我当成阿惟三佛时。使我国中无有三恶趣。何以故。梦中所有及一切诸法。一法无有二。当知是为阿惟越致相。复次须菩提。菩萨梦中见泥犁中火烧汤煮。觉已念言。我于梦中所见形像及其灾变。若于梦中自见阿惟越致相便作誓言。如我所见。泥犁中火即当灭去。若火灭汤冷。当知是菩萨以受记莂。当成阿耨多罗三耶三菩。是为阿惟越致相。若是火焰烧一家至一家。烧一里至一里。或烧一家不烧一家。或烧一里不烧一里。中有为火所烧者。当知被烧家人断法所致。皆是断法余殃。从是以来断法余殃悉毕。是为罪灭福生。是为阿惟越致相。佛告须菩提。今我当说阿惟越致像貌相行。若有男子女人为鬼神所持。是菩萨便作是念。过去诸佛如来无所著等正觉审授我莂者。所作愿行清净无秽。不应堕罗汉辟支佛地。亦无罗汉辟支佛念。当成阿惟三佛者。亦不成亦不不成。假令诸十方现在诸如来无所著等正觉。无所不知无所不见无所不觉。诸佛知我必当成阿耨多罗三耶三菩者。是鬼神当去。若是鬼神不去者。当知是菩萨不从过去诸佛受其记莂。须菩提。若是菩萨为说经已。鬼神即为去。当知是菩萨以从诸如来无所著等正觉受记莂已。须菩提。以是像貌相行具足。是为阿惟越致相。复次须菩提。菩萨行六波罗蜜。离沤和拘舍罗。未行三十七品及三脱门。未逮菩萨位。未得菩萨三昧处。亦不从过去诸佛受莂。是菩萨往至是男子女人所复言。我审受莂当为阿耨多罗三耶三菩者。是鬼神当去。鬼神不为去。是菩萨故为说经法不止者。时魔波旬往至彼所。波旬念言。我当令鬼神去。所以者何。波旬有威神胜是鬼神。时彼波旬便敕鬼神令去。是菩萨不知波旬令鬼神去。喜言鬼神用我故去。便自贡高轻蔑余人。语他人言。我已从过去诸佛受莂已。其余人皆未受莂。用是贡高轻易人故离萨云然。不得如来无所著等正觉之智慧。用是贡高失沤和拘舍罗。便堕二地罗汉辟支佛地。用至诚誓故便起魔事。远离真知识堕魔罗网。何以故。不行六波罗蜜。不持沤和拘舍罗故。须菩提。当知是菩萨为自作魔事。佛告须菩提。菩萨未行六波罗蜜。未得沤和拘舍罗。未逮菩萨位。以魔事故波旬复来至菩萨所。作异被服语菩萨言。善男子如来已授卿莂。当为阿耨多罗三耶三菩。卿父母字某。卿兄弟妹姊字某。卿朋友知识亲族字某。卿七世父母字某。卿从某国某县某村落生。若见菩萨体行和顺。卿前世时亦复柔软。若见才朗。若见行沙门十二法。若见节言。波旬随形语菩萨言。卿前世时皆有是行。卿前世时亦行此十二法。彼菩萨闻魔语说先世事。复自观所作行倍复贡高轻于同学。魔重语言。过去如来已授卿莂。如卿所作功德不复转还。波旬或作比丘形像。或作父母。或作迦罗越形像而来言。卿必当成阿耨多罗三耶三菩。所以者何。卿尽有阿惟越致相行具足故。佛告须菩提。我所说阿惟越致像貌相行。彼菩萨获无是相。当知是菩萨为魔所使。以闻是名誉贡高自可。轻易同学形笑他人无所复录。用贡高故。是为魔事。复次须菩提。菩萨于魔因缘当学魔事。何以故。是菩萨不行六波罗蜜故。不知魔事如。不知五阴如。彼菩萨用不觉魔事。闻前比丘说其记莂。今复闻是记莂名字。意中欢喜便自念言。以是证像我今定当得阿耨多罗三耶三菩。益复贡高轻易他人呼无所知。是菩萨无有阿惟越致相。便远离般若波罗蜜沤和拘舍罗。失阿耨多罗三耶三菩智。远离真知识更得恶知识。当知是菩萨终不成就堕二道地。若后久远更诸勤苦生死极远。乃当复得真知识得闻般若波罗蜜。尔乃悔本所著受字。用是悔故乃得罗汉辟支佛。譬如比丘犯四事禁。现世不能得成四道。须菩提。是彼菩萨其罪重于四事之禁。用受名字着贡高故。置是罪事。其有犯是贡高受字受伪号者。其罪过于五逆。须菩提。若有名字受想著者。急当护魔觉微因缘。复次须菩提。波旬复往至菩萨所。赞叹远离说其功德。如卿所行佛所称誉。正当如是。须菩提。如我所说。菩萨远离之法不尔。若在山间树下独处寂无人中。未必是为远离之法。须菩提白佛言。何等为菩萨异远离。佛告须菩提。菩萨远离。寂于声闻辟支佛念。寂于山间树下独处念。须菩提。菩萨如是是为大远离之法。菩萨如是当昼夜行。是为菩萨寂然远离。若在人间随我寂教者。虽在城傍为与山泽等无有异。若受魔教便止远离。堕于罗汉辟支佛地。不应般若波罗蜜。不具足萨云然事。作是行念者。非是清净之法。杂糅罗汉辟支佛意。更反形笑轻易人间清净行者。人间行者亦不杂糅罗汉辟支佛意。反更轻易之。亦复轻易得禅惟无三昧者。轻易得神通者。菩萨无沤和拘舍罗者。虽在绝旷百俞旬外。亿千万岁禽兽飞鸟所不至处。鬼神盗贼所不至处。虽久在中。不知菩萨远离之法。会无所益。受波旬教行远离者。不乐我所教远离也。亦复不能具足远离之法。亦复不在远离法中。何以故。以去是远离法远故。适去是远离法远已。时魔波旬在虚空中叹言。善哉善哉。善男子。是为佛之所说。是真远离法。汝行是远离法。可疾得阿耨多罗三耶三菩。彼妄远离菩萨得是赞叹已。便欢喜贡高。轻易是真远离者。反诽谤言是为愦乎。谓为不净愦闹志乱。有不净者反呼为净。不应敬者更敬之。应所敬者更轻慢之。何以故。我为诸天及人非人所见劝助恭敬。我所行者真为是行。汝在城傍谁当来恭敬赞叹汝者。是人于城傍善男子善女人求菩萨道者。于前贡高言。诸天来语我当得道时日数。须菩提。当知是贡高菩萨辈如旃陀罗([旃-方+示]陀罗者晋言主杀人狱卒)是辈之人在诸菩萨中为大瑕病。是为倚法像如菩萨。是为天上人中之大贼。亦复是沙门像法之中为大贼。复是善男子善女人之中大贼。如是辈人不当与共从事。亦不当与相见坐起语言饮食。何以故。是辈之人贡高顽佷故。若有菩萨不欲舍萨云然。不欲舍阿耨多罗三耶三菩者。庄事欲得求阿惟三佛者。欲救一切众生者。当远离是辈之人。不当与共从事自修其行。莫与往来常当有厌意。于世间不当受三界之乐。常当慈哀加于众生。当为是辈倒见之人起大悲意。当自念言。令我世世莫有是曹非法之事。若有是意疾令灭之。须菩提。当知是辈菩萨自起神通。复次须菩提。若有菩萨至诚庄事求阿耨多罗三耶三菩者。当与真知识从事。须菩提白佛言。何等为菩萨真知识。佛告须菩提。诸佛世尊是菩萨真知识。诸菩萨摩诃萨亦是菩萨真知识。诸弟子众亦是真知识。当知是为菩萨真知识。真知识者常为菩萨解说般若波罗蜜。分别其事。六波罗蜜三十七品佛十八法如真际法性。是为菩萨真知识也。六波罗蜜者是世多罗。六波罗蜜者是道。六波罗蜜者是大明。六波罗蜜者是为大炬。六波罗蜜者是大智光明。六波罗蜜者是护。六波罗蜜者是归。六波罗蜜者是父是母。六波罗蜜者是三十七品。六波罗蜜者是萨云然。六波罗蜜者除人诸习绪。何以故。须菩提。三十七品者是过去当来今现在十方诸佛之母。何以故。去来今诸如来无所著等正觉。皆从三十七品中出生故。是故须菩提。菩萨欲成阿耨多罗三耶三菩。净佛国土教化众生者。当以四事饶益摄众生。一者施。二者爱。三者利。四者同义。以是四恩事益于众生。须菩提。我观是义故说是事。三十七品者则是菩萨摩诃萨父母则为是舍。是则为护。是则为灯明。须菩提。菩萨不欲随他人教住者。欲断一切众生狐疑者。欲净佛国教化众生者。当学般若波罗蜜。何以故。般若波罗蜜者。广说菩萨之行。是诸菩萨所应当学者。须菩提白佛言。何等为般若波罗蜜相。佛言。般若波罗蜜如虚空相。亦非相亦不作相。须菩提言。世尊。颇有因缘可知般若波罗蜜相不。以相知诸法不。佛言如是。须菩提。欲知般若波罗蜜相。如诸法相。何以故。诸法寂故。诸法常净故。以是故须菩提。般若波罗蜜相。则诸法之相。以空寂故。须菩提白佛言。世尊。若诸法寂若诸法空。云何知诸法有著有断。空之寂亦不断亦不着。亦不成阿耨多罗三耶三菩。于空寂中。亦不有法。于空寂中亦不见得阿惟三佛者。世尊。我等云何当知是义。佛告须菩提。众生长夜着吾我行。须菩提言尔。世尊。众生长夜着吾我行。佛言。云何为知吾我空寂不。须菩提言尔。世尊。须菩提。知众生以吾我故久在生死不。须菩提言尔。世尊。以众生着吾我故。久在世间更受勤苦便知有着。须菩提。无吾无我无有受者。亦不久在世间。亦不久受勤苦。亦不着便不断。须菩提白佛言。世尊。菩萨作如是行者。不于五阴行。亦不于三十七品作行。亦不行四无碍慧。何以故。不见有法有可行者。亦不见法当可行者。菩萨如是行者。诸天世人无能动者。无能伏者。罗汉辟支佛无能及者。何以故。所住处无有能逮故。世尊行萨云然菩萨所住无有能及者。菩萨如是疾近萨云然。佛言。于须菩提意云何。阎浮提众生尽得人道已。皆为阿耨多罗三耶三菩。若有善男子善女人。供养承事尽其寿命。持是供养之福施为阿耨多罗三耶三菩。是善男子善女人其福宁多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人持般若波罗蜜教人具足为说解其中慧。意不远离应萨云然念。乃至三千大千国土众生皆得为人。若有善男子善女人。皆教使行十善地。立于四禅四等及四空定。又立于须陀洹斯陀含阿那含阿罗汉辟支佛阿耨多罗三耶三菩。持是功德施为阿耨多罗三耶三菩。是善男子善女人功德宁多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人持般若波罗蜜宣示他人具足为说解其中慧。意不远离萨云然念者。出于贤圣之表。何以故。除如来无所著等正觉。唯当有是菩萨摩诃萨。何以故。以是善男子善女人。行般若波罗蜜有大慈行故。行般若波罗蜜。见诸众生趣死地故便起大悲。以是行故便得大护不与想俱。便得大喜具足四等。须菩提。为菩萨大智之明。大智明者则六波罗蜜明是。是善男子善女人虽未得道。为一切众生作救。于阿耨多罗三耶三菩不动还。所受供养衣服饮食床卧医药一切珍宝。以行般若波罗蜜故。必报众生信施之福。疾近萨云然。须菩提。若不欲痴妄受人施者。若欲示众生之道径者。若欲解无所有者。若欲度脱牢狱中人者。若欲与一切众生眼者。身所行当应般若波罗蜜。有所语言。亦当应般若波罗蜜意。应般若波罗蜜者。他余之意亦不得其便。当作方便昼夜念般若波罗蜜莫有断绝。须菩提。譬如士夫曾得摩尼宝。后复得之大欢喜踊跃后复失之。失是宝已甚大愁忧。忆想是摩尼宝。坐起无忘不离须臾。自念我云何欻亡此大宝。佛告须菩提。菩萨离于萨云然念。亦如彼人失大珍宝。坐起不忘须臾之间。须菩提白佛言。云何世尊。一切诸念无有止处。皆空皆寂。云何菩萨不离萨云然念。亦不从离中。亦不从念中可得菩萨。亦不从萨云然中可得菩萨。佛告须菩提。若有菩萨知诸法自远离。法性常住。道法及如真际常住。非佛所作亦非罗汉辟支佛所可作。菩萨知是已终不复离般若波罗蜜。何以故。般若波罗蜜空寂故。亦不增亦不减。须菩提白佛言。世尊。若般若波罗蜜自空寂者。云何菩萨与般若波罗蜜等成阿惟三佛。佛言。菩萨亦不与般若波罗蜜等。亦不增亦不减。真际亦不增亦不减。法性亦不增不减。何以故。般若波罗蜜亦非一亦非二。若菩萨闻是不怖不难亦不恐畏。当知是菩萨已住于阿惟越致地。行般若波罗蜜。须菩提白佛言。云何世尊。念般若波罗蜜空。念般若波罗蜜无所有。为行般若波罗蜜耶。佛言不也。须菩提言。世尊。颇有离般若波罗蜜行般若波罗蜜者不。佛言不也。须菩提言。世尊。般若波罗蜜行般若波罗蜜不。佛言不也须菩提言。世尊。空可行空不。佛言不也。须菩提言。世尊。五阴行般若波罗蜜不。佛言不也。须菩提言。世尊。六波罗蜜行般若波罗蜜不。佛言不也。须菩提言。世尊。乃至四无碍慧行般若波罗蜜不。佛言不也。须菩提言。世尊。五阴之空如及尔法法性四无碍慧空行般若波罗蜜不。佛言不也。须菩提言。世尊。是诸法不行般若波罗蜜耶。若不行是法。菩萨云何行般若波罗蜜。佛言。于须菩提意云何。颇见有法行般若波罗蜜者不。须菩提言。不见也世尊。颇见般若波罗蜜菩萨有可行者不。须菩提言。不见也世尊。于须菩提意云何。汝所不见法为可得不。不也世尊。佛言。不可得法为有生灭不。不也世尊。佛告须菩提。如菩萨无所从生法忍阿耨多罗三耶三菩莂。亦复如是。若菩萨学承。用如来四无所畏四无碍慧。习行是法。终不离阿耨多罗三耶三菩慧。萨云然慧。摩诃衍慧。何以故。菩萨摩诃萨得无所从生法忍。至成阿耨多罗三耶三菩。终不耗减。须菩提白佛言。世尊。从诸法无所生中。授诸菩萨阿耨多罗三耶三菩记莂耶。佛言不也。须菩提言。世尊。从所生法中授诸菩萨莂耶。佛言不也。须菩提言。亦不从无所从生法授菩萨莂。亦不从有所生中授菩萨莂。如是云何授诸菩萨阿耨多罗三耶三菩记莂。佛告须菩提。颇见法受阿耨多罗三耶三菩记莂者不。须菩提言。世尊。我亦不见法有授记莂者。我亦不见得阿耨多罗三耶三菩。亦不见当得者。亦不见已得者。佛言。如是如是。须菩提。菩萨摩诃萨于诸法无所得。菩萨亦不念言有阿惟三佛。亦不念言我当得阿惟三佛。何以故。菩萨行般若波罗蜜。于诸法无所分别。般若波罗蜜亦无所分别故

    摩诃般若波罗蜜释提桓因品第六十三

尔时释提桓因白佛言。世尊。般若波罗蜜者。甚深微妙难晓难了难解难知不可思议。以本净故。闻是深般若波罗蜜书持学者。为已具足从大功德来。想着之意为不复生。至阿耨多罗三耶三菩亦无想着。佛告释提桓因言。如是如是。拘翼。有行般若波罗蜜者。不从小功德来。拘翼。阎浮提满中众生。皆行十善四等四禅及四空定。不如是善男子善女人。书持般若波罗蜜。讽诵受学如其教住。至阿耨多罗三耶三菩不听余念。其福百倍千倍巨亿万倍。不可以譬喻为比。尔时有异比丘语释提桓因言。拘翼。是善男子善女人。守行奉持般若波罗蜜。转复教人者。其功德出彼阎浮提众生所作者上。释提桓因语是比丘言。善男子善女人。于般若波罗蜜中一发意。胜阎浮提所作十善四禅四等五通者上。何况奉行书持讽诵如中教者。皆过诸天阿须伦世间人上。是菩萨不独过诸天世间人。乃过须陀洹斯陀含阿那含阿罗汉辟支佛上。不但过是上。乃至菩萨行五波罗蜜。无般若波罗蜜沤和拘舍罗者上。菩萨如般若波罗蜜教住者。出诸天世人上。诸天世人皆不能及。如般若波罗蜜教住者。为不断萨云然种地住。终不离如来名号菩萨行。如是终不失道场。菩萨摩诃萨所行如是。为欲拔出众生沉没长流者。如是学者为学菩萨所学。不学声闻辟支佛学。菩萨如是学者。诸四天王当来至是菩萨所言。善男子善女人。勤学疾学成阿耨多罗三耶三菩。坐于道场时。过去诸如来无所著等正觉所持四钵。今在是间当奉不久。如是行般若波罗蜜者。诸释提桓因亦当复来劝助是善男子善女人。须焰天子将诸焰天子来下。兜率天子将诸兜率天子来下。诸尼摩罗天皆悉来下。诸波罗尼蜜天亦悉来下。乃至首陀会诸天皆悉来下。至是行深般若波罗蜜菩萨所。十方现在诸如来无所著等正觉。皆常念是善男子善女人。行般若波罗蜜者。行是深般若波罗蜜者。诸可世间所有厄难勤苦之事了无复有。须菩提。是为行般若波罗蜜者现世功德之报。一切世间皆有四病。一事动者身中诸根无不受痛。以受痛故意便受恼。是诸病恼不复着是菩萨身。用行深般若波罗蜜故。是为现世功德之报。尔时阿难意念。释提桓因自持辩才说以佛事说。释提桓因。知阿难意之所念语阿难言。我之所说皆是佛事。佛告阿难。释提桓因所可说者。皆是佛事因缘。若菩萨学习念般若波罗蜜时。三千大千国土中魔皆生狐疑。今是菩萨当为真际作证。取声闻辟支佛道耶。当成阿耨多罗三耶三菩阿惟三佛乎。阿难。若有菩萨不离般若波罗蜜时。魔复大愁毒。尔时魔复起大风。欲使是菩萨恐怖。有难起懈怠之意。欲使菩萨于萨云然念中起一乱意。阿难白佛言。世尊。魔为都卢娆乱诸菩萨耶。有不娆者。佛告阿难。有行乱者有不乱者。阿难白佛言。有娆者谁不娆者谁。佛言。菩萨从本闻般若波罗蜜时。意中不乐不解者。波旬便往娆乱。若闻说深般若波罗蜜时。意中狐疑言为审有是耶为无有耶。用是故波旬往娆。复次阿难。若有菩萨远离真知识。便不闻不知般若波罗蜜。不解其事意便不乐。是故波旬复往娆乱。复次阿难。若有菩萨远离般若波罗蜜反持非法。用是故魔得其便。复次阿难。菩萨失般若波罗蜜更叹非法。魔即欢喜念言。彼说非法之事。当有若干伴辈。当满我愿。复并使余人堕于二地罗汉辟支佛是也。复次阿难。若有菩萨闻说深般若波罗蜜时。便意念言。是深不能大深耶。作是念者。魔便念言。我今已得子便。复次阿难。若有菩萨向余人贡高言。我能行六波罗蜜汝不能行。是菩萨为魔所得便。阿难。时魔波旬大欢喜踊跃。复次阿难。若有菩萨自怙智慧。自怙种姓。自怙其善。自怙知识。便起贡高下于他人。亦无阿惟越致相行像貌。专自贡高轻贱他人。便语人言。汝亦不在菩萨种姓之中现。汝亦不在摩诃衍中。尔时波旬欢喜念言。今我境界宫殿不空。增益三恶趣我种姓不损。魔常伺是菩萨欲使说非法之事。欲使众人皆闻非法。亦当邪见增益劳垢。造颠倒行颠倒于法。身口意错贪着邪福。从是因缘增益三恶趣。魔之眷属宫殿益多。尔时波旬倍欢喜踊跃而自娱乐。复次阿难。若行菩萨道者。与声闻道家共争。魔时念言。是善男子离萨云然远不近大智。所以者何。斗争怨恚非萨云然道。是三恶之业。复次阿难。菩萨菩萨自还共争。波旬念言。两离佛远失萨云然。是二菩萨俱不得成阿耨多罗三耶三菩。所以者何。是善男子所造。是三恶业非萨云然。复次阿难未受莂者。与得记莂菩萨共争。兴起恶意。随其意起多少之数却若干劫。虽起争意如故不舍萨云然者。当却劫数若干径路。然后乃成阿耨多罗三耶三菩。阿难白佛言。世尊。乃当更尔所劫数。于其中间宁有除不。佛告阿难。我为三乘说法。随其意起多少之数。各尽其事无有中间减少之除。佛告阿难。若菩萨菩萨共争。若恚若骂怀恨不悔者。我不说有除。当更劫数勤行僧那。然后乃成。若有菩萨斗争恚已便自悔言。是利难得。我今当为一切下屈。今世后世当使众生皆共和解。我今云何恶声加人而念人恶。我终不敢复作是事。当如聋羊当自除过。成阿耨多罗三耶三菩度脱众生。云何起恚而自陷溺。不当起恨不当陷溺。尔时菩萨适起是意已。魔波旬不能得其便。复次阿难。行菩萨者不当与声闻家共止。若共止者不当与争。所以者何。当自念言。我不应得与是辈人起恚共争。我当成就阿耨多罗三耶三菩度诸苦厄。阿难白佛言。世尊。菩萨菩萨自共住止其法云何。佛告阿难。菩萨菩萨共止之法。相视当如世尊共止。所以者何。当作念言。是我真伴共乘一船。彼学我学是为同学。共行檀波罗蜜至萨云然。若彼意愦不顺萨云然者我所不应。若彼意定不离萨云然者我亦应尔。菩萨摩诃萨作是学者为共等学

    摩诃般若波罗蜜问等学品第六十四

须菩提白佛言。世尊。何等为菩萨摩诃萨之等所应学者。佛告须菩提。内空外空是菩萨摩诃萨之等。五阴自空。乃至于道道亦自空。须菩提。是空为是菩萨摩诃萨之等。于是等空成阿耨多罗三耶三菩。须菩提言。世尊。菩萨学消五阴为学萨云然。五阴不染为学萨云然。学灭五阴为学萨云然。不生五阴为学萨云然。乃至四无碍学为学萨云然。佛告须菩提。如所言。学消五阴为学萨云然。乃至学无所生为学萨云然。佛言。于须菩提意云何。五阴所有如乃至道如及世尊如。是诸如颇有减尽灭时不。须菩提言。不也世尊。佛言。菩萨如是学。为学如为学萨云然。如亦不尽亦不减亦不灭。如是学为学如为学萨云然。菩萨如是学为学六波罗蜜。为学三十七品。为学佛十八法。为学萨云然。佛告须菩提。菩萨作如是学为度诸学。表为第一学。如是学者诸天及魔不能坏败。作如是学疾近阿惟越致。如是学者为习尊业为习如来。如是学者为导御众生。如是学者为净佛土。为学大慈大悲。为学教化众生。须菩提。菩萨如是学者。为学三合十二法轮转度脱众生。如是学者为学不断佛种。如是学者为学开甘露法门。作如是学为学示无为法。须菩提。下劣之人不能学是。作是学者为欲拔一切众生生死之根。如是学者为不入三恶趣。不生边地。不生栴陀罗家。如是学者不复聋盲喑哑跛蹇。如是学者诸根具足终不缺减。无恶音声不犯十恶终不学邪。以自生活不为无反。复不与恶者俱。须菩提。如是学者不生长寿天。用沤和拘舍罗故。何等为沤和拘舍罗。般若波罗蜜所说沤和拘舍罗。四禅四等及四空定不随禅计。如是学者为净一切诸法之力。净罗汉辟支佛力。须菩提白佛言。世尊诸法之性皆自清净。云何菩萨欲净诸法。佛告须菩提。如是如是。菩萨已净性之本。学般若波罗蜜不厌不懈。是为学般若波罗蜜。是法非是凡夫愚人之所能学所能知见。菩萨为众生故行檀波罗蜜至萨云然。菩萨学如是为学十力。为学无所畏力。如是学者出过众生所为之表。须菩提。譬如地之所出出金银异宝少少处出耳。如是须菩提。少少人学般若波罗蜜。多有发声闻辟支佛意。少少人能行遮迦越罗福者。作粟散小王行者多。少少众生能入萨云然者。多有人入罗汉辟支佛道。须菩提。多所人求阿耨多罗三耶三菩意者。得成就者少少耳。多住罗汉辟支佛地。须菩提。多有人行菩萨道。学般若波罗蜜者。至阿惟越致地者。亦少少耳。用是故须菩提。若欲坚住在阿惟越致地者。当学深般若波罗蜜。复次须菩提。菩萨学般若波罗蜜时。嫉意不生犯戒意不生。恚意不生乱意不生。懈怠意不生愚痴意不生。三毒意不生疑意不生。五阴意不生乃至道意不生。何以故。须菩提。是菩萨行深般若波罗蜜时。不见法有所生者。于无生法亦无所得亦无所起。是故菩萨学持深般若波罗蜜。为悉总持诸波罗蜜。何以故。菩萨学深般若波罗蜜时。诸波罗蜜皆悉随从。譬如着吾我之人悉总持六十二见。是故菩萨学般若波罗蜜诸波罗蜜皆悉随从。譬如人欲死时。风先命去诸根悉灭。须菩提。菩萨行深般若波罗蜜时。诸波罗蜜皆悉入中。菩萨欲出过诸波罗蜜表者。当学深般若波罗蜜。学深般若波罗蜜者为学人中最尊上。须菩提。三千大千刹土其中众生宁为多不。须菩提言。世尊。一阎浮提众生尚多。况乃三千大千刹土所有众生。佛言。令此众生尽得入道。悉得阿耨多罗三耶三菩。若有菩萨一一供养衣被饮食众所当得尽其寿命其福宁多不。须菩提言。甚多甚多。佛言。不如是善男子善女人至意念般若波罗蜜也。何以故。是深般若波罗蜜者。是诸菩萨摩诃萨之大益。能使菩萨成阿耨多罗三耶三菩。须菩提。菩萨欲在众生之上。一切众生为无所归无所依怙。欲受其归。欲为作依怙者。欲为盲人作明导者。欲求作佛者。欲得佛境界者。欲作佛游步者。欲为佛师子音响者。欲撞击佛钟鼓者。欲放大蠡音者。欲为佛会讲说佛法义。决断众人诸狐疑者。悉欲得是者。当学深般若波罗蜜。菩萨行般若波罗蜜者。所有三界诸善之福德无事不得。须菩提言。世尊。菩萨宁复得罗汉辟支佛之福德耶。佛言。亦得罗汉辟支佛之福德。但不于中作证耳。以智慧观察罗汉辟支佛慧即得过。不于中住自上菩萨位。菩萨作如是学者去萨云然不远。疾成阿耨多罗三耶三菩。须菩提。菩萨如是学者为诸天阿须伦之福祐。如是行者过诸罗汉辟支佛上。疾近萨云然。须菩提。如是学者不久行般若波罗蜜。不离般若波罗蜜。菩萨如是行深般若波罗蜜。当知是为不耗减法。不远萨云然疾近三乘慧。菩萨若复反作念言。彼此般若波罗蜜便不逮萨云然。作是念者为不行般若波罗蜜。若复此彼深般若波罗蜜。不知般若波罗蜜。亦不见般若波罗蜜。亦不知般若波罗蜜为谁。亦不知谁当于般若波罗蜜中得阿耨多罗三耶三菩。若复作是念。般若波罗蜜亦非彼亦非此亦无从中出者。法性常住如真际有佛无佛法性常住。菩萨摩诃萨作是学者。为学般若波罗蜜

放光般若经卷第十四放光般若经卷第十五

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜亲近品第六十五

尔时释提桓因意念言。菩萨行六波罗蜜乃至佛十八法。尚出众生之上。何况成阿耨多罗三耶三菩者。若有发意念萨云然者。为得寿命中之最人中之善利。何况发意欲为阿耨多罗三耶三菩者。发阿耨多罗三耶三菩意者。未发者当亲近之。释提桓因。以天曼陀罗花而散佛上。散已发愿言。若有发阿耨多罗三耶三菩意者。令具足法愿。具足萨云然愿。具足自然法愿。具足无漏法愿。释提桓因白佛言。世尊。如我意愿。其发阿耨多罗三耶三菩意者。不复欲令动还。堕罗汉辟支佛地。为下大乘终不堕于罗汉辟支佛乘。倍复发愿精进愿阿耨多罗三耶三菩。见三界中所有诸勤苦者悉为作护。如是具足。菩萨意念。我等已度当复度不度者。我已安隐当复安余。我已泥洹当复度余令得泥洹。释提桓因白佛言。世尊。善男子善女人。代初发意菩萨欢喜者。为得几所福。久发意菩萨复代欢喜。得何等福。阿惟越致菩萨代其欢喜复得几福。至一生补处菩萨代其欢喜。复得几福。佛告释提桓因言。拘翼。是四天下尚可称知斤两。代其欢喜者其福不可称。三千大千刹土亦可称知。代其欢喜者福不可称计。拘翼。三千大千刹土。其中海水取。一发破为百分以一分发尽渧。海水尚可数知几渧。从代欢喜功德(此间有三十五字重复书准丹本除)福不可计量。拘翼。阿僧祇佛刹所有境界虚空。持斛斗升合量空。尚可知几所。从代欢喜功德福不可计量。释提桓因白佛言。世尊。诸不代初发意菩萨欢喜者。是为魔之所使。不代欢喜者是魔官属人从魔中来。何以故。有代发意欢喜者是为坏魔故。诸欲不舍敬三尊。亦不一相亦不二者。当持是代欢喜意。求阿耨多罗三耶三菩。佛言如是。拘翼。发是代欢喜意者。得至佛国供养诸佛。所以者何。阿僧祇人初发意作功德代欢喜故。从初发意菩萨至于十住阿惟颜。菩萨所作功德皆代其欢喜。持是功德疾近阿耨多罗三耶三菩。成阿惟三佛已无央数不可说阿僧祇众生。皆当得度。以是故。拘翼。是善男子善女人。有初发意者当持代欢喜之功德求阿耨多罗三耶三菩。不以意求亦不离意。代阿惟越致及一生补处欢喜。以求阿耨多罗三耶三菩。不以意求而不离意。须菩提言。是意如幻。云何能得阿耨多罗三耶三菩。佛言。于汝意云何。汝见是意如幻不。须菩提言。不见也。世尊。我不见如幻亦不见意非幻。佛言。亦非法颇见是意不。颇非见幻不离意。见是法成阿耨多罗三耶三菩不。须菩提言。不见也。世尊。我不见法当持何等起为有为无。法常自寂不可以有得亦不可以无得。若法常寂不成阿耨多罗三耶三菩。无所有者亦复不成阿耨多罗三耶三菩何以故。世尊。一切诸法亦不可得亦无有故。世尊。六波罗蜜常寂乃至于道亦复常寂。法亦不应当念。亦无有法而将来有。般若波罗蜜常寂。成阿耨多罗三耶三菩。阿耨多罗三耶三菩常寂。须菩提言。世尊。般若波罗蜜三耶三菩。亦寂之中云何逮觉。佛言。善哉善哉。萨云然寂阿耨多罗三耶三菩亦寂。须菩提。般若波罗蜜及萨云然不寂者。亦非般若亦非萨云然。是故须菩提。般若波罗蜜萨云然寂。亦不因般若波罗蜜成阿惟三佛。不离般若波罗蜜得阿惟三佛。不得般若波罗蜜者。终不得阿惟三佛。须菩提言。世尊。菩萨所行甚深。佛言。如汝所说。菩萨所行入甚深苦行。虽谦苦行不于法中中道取证。堕于罗汉辟支佛地。须菩提白佛言。世尊。如我从佛所闻。菩萨不为谦苦。何以故。亦不见是可得证者。亦不见般若波罗蜜可取证者。亦不见法当取证者。诸法皆不可得者。有何等义有何等法有何等般若波罗蜜。当可取证成阿耨多罗三耶三菩者。须菩提言菩萨行者为无所得行。菩萨于无所得法中。还诸法无限之限事。世尊。若有菩萨闻说是事。不却不难亦不懈怠。是为行般若波罗蜜。亦不见行般若波罗蜜者。亦不见成阿耨多罗三耶三菩者。菩萨行般若波罗蜜亦不作是念。罗汉辟支佛地离我远。萨云然离我近。世尊。譬如虚空亦无近远之念。何以故。虚空无分别故。行般若波罗蜜菩萨亦无是念。二道离我远萨云然离我近。何以故。般若波罗蜜亦无所分别故。譬如幻人亦不自念。师离我近观人离我远。何以故。幻人无念故譬如光影无有念。我所因者离我近余离我远。菩萨行般若波罗蜜。如来无所著等正觉亦无所爱。世尊。般若波罗蜜亦如是。譬如如来无有念故。譬如如来所化亦不念二道。离我远佛离我近。何以故。化以如来无念故。般若波罗蜜无有念故。譬如如来所作亦不念二道。离我远佛道离我近。何以故。化如来亦无念故。般若波罗蜜亦无念二道。离我远佛离我近。譬所为作事亦无念可说。般若波罗蜜事亦如作亦无念故。尊者舍利弗。语耆年须菩提。但般若波罗蜜无有念耶。须菩提言。六波罗蜜亦无有念。五阴五情亦复无念。眼色六入亦复无念。四禅四等及四空定三十七品至三脱门佛十种力十八法四无所畏四无碍慧萨云然事亦无有念。乃至于道亦复无念。有为性亦无念。舍利弗言。若诸法无念。何从有五趣。云何复有须陀洹斯陀含阿那含阿罗汉辟支佛及佛世尊。须菩提言。诸众生因四颠倒而起四颠倒而造作事。身口意行随受其像。便有疑应故有泥犁薜荔兽人中天上。舍利弗言。云何有须陀洹乃至三耶三佛。须陀洹道亦无念。乃至三耶三佛道亦无念。诸过去当来无所著等正觉。及现在十方诸佛无念已尽灭。以是故。舍利弗。当作是知。一切诸法皆无念。信如是法性真际故。舍利弗。菩萨当以无念行般若波罗蜜。以无念行般若波罗蜜故。便得逮觉无念之法

    摩诃般若波罗蜜牢固品第六十六

于是舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜。为行不牢固耶。须菩提报言。如是如是。菩萨摩诃萨行般若波罗蜜者。为行不牢固。何以故。般若波罗蜜无有牢固。乃至萨云然亦无有牢固。亦无不牢固。何以故。菩萨行般若波罗蜜不牢固尚不可得。乃至萨云然亦不可得见。何况有牢固。若干百千色欲天子意念言。诸有善男子善女人。发阿耨多罗三耶三菩。行般若波罗蜜者当为作礼。既行般若波罗蜜而不中道取证。堕罗汉辟支佛地。以是故当为作礼。于等法不取证故。须菩提语诸天子言。菩萨于等法不取罗汉辟支佛证。不足为奇。为阿僧祇人盟誓。亦不见有人而欲度脱众生。是乃为奇。以是故。菩萨发意为阿耨多罗三耶三菩者为欲降伏众生。欲降伏众生者则为欲降伏虚空。何以故。当知虚空众生皆悉寂故。众生亦空虚空亦空。如虚空之无牢固。众生亦无牢固。诸天子。以众生无有牢固故而结盟誓。是故菩萨摩诃萨为甚奇特。为众生结盟誓者。则为与虚空共斗所。为众生结盟誓者亦不见众生。亦寂结盟誓亦寂故。菩萨闻是不恐不懈不难不怯。为行般若波罗蜜。何以故。五阴寂故众生亦寂。云何五阴寂故众生亦寂。以五阴寂故六波罗蜜寂。以五阴六衰寂故内外空寂及有无空亦寂。以五阴六衰寂故十八性亦寂。五阴寂故三十七品四禅四等及四空定四无碍慧亦寂。以五阴寂故佛十种力四无所畏大慈大悲及十八法萨云然亦寂。菩萨闻是诸法皆寂。意不恐怖不难不怯。是为行般若波罗蜜。佛告须菩提。何以故。菩萨不恐不懈为行般若波罗蜜。须菩提言。世尊。以无所有故不恐。以寂静故不懈。菩萨以是无所有寂静故。不恐不懈为行般若波罗蜜。何以故。恐畏懈怠亦不可得见故。菩萨闻是恐畏亦不可得复不恐怖。是为行般若波罗蜜。何以故。恐畏皆不可得见故菩萨摩诃萨如是行者。诸天梵释皆为作礼。不但诸天释梵为行般若波罗蜜菩萨作礼。乃至首陀会诸天皆为行般若波罗蜜菩萨作礼。须菩提。十方现在诸如来无所著等正觉。皆念是菩萨行般若波罗蜜者。菩萨行般若波罗蜜者。为具足五波罗蜜。为具足萨云若。须菩提。若十方诸佛念是行般若波罗蜜菩萨者。当知是菩萨成就佛不久。须菩提。一恒边沙人悉使为魔。一一魔者所将官属如一恒边沙。假令尔所魔及将尔所官属。欲共坏乱行般若波罗蜜菩萨者。终不能坏。有二事魔不能中道坏菩萨。何等为二。一者观诸法皆空。二者不舍众生。复有二事魔不能坏。何等为二。一者所作如所言。二者常念诸佛菩萨。如是行般若波罗蜜。诸天皆来劝助慰劳言。善男子。今成阿耨多罗三耶三菩不久。是故莫得舍空无相无愿之行。如是行者无所归仰者而受其归仰。无有依护者则为作依护。无有覆盖者而为作舍。为冥者作大明。为盲者作眼目。何以故。是菩萨行般若波罗蜜者。十方诸佛及众菩萨比丘僧众。皆共称扬说其名故。须菩提。譬如我说法时。称扬赞叹宝造菩萨及识挽菩萨。我说法时称誉妙乐佛国中诸菩萨修梵行者。我亦常称誉彼诸正士。亦如十方诸佛欢喜颜色。叹说菩萨行般若波罗蜜者。从初发意菩萨欲具足行佛道。至阿耨多罗三耶三菩成萨云然。十方诸佛亦复欢喜颜色称誉说之。所以者何。少有菩萨有能顺行应佛业者。须菩提白佛言。世尊。诸佛以欢喜颜色称誉诸菩萨。为赞叹动还者不动还者。佛告须菩提。有行阿惟越致菩萨行般若波罗蜜者。亦有未受记莂菩萨行般若波罗蜜有。佛为是辈说法。佛亦复赞叹说之。若有菩萨在妙乐佛国所学者。佛亦赞叹说之。诸佛所可欢喜颜色赞叹说者。复次须菩提。诸可行般若波罗蜜菩萨。知诸法无所生未得无所从生。知诸法空亦未得无所从生。知诸法净亦未得无所从生。知诸法无所有无有坚固亦复未得无所从生。诸佛欢喜颜色赞叹是辈菩萨。称誉说其名字。是辈菩萨摩诃萨。以为灭罗汉辟支佛地。当受记莂于阿耨多罗三耶三菩地。有行般若波罗蜜菩萨者。诸佛皆欢喜称誉赞叹之。亦当住于阿惟越致地逮萨云然。复次须菩提。闻说般若波罗蜜时。亦不狐疑不却不懈。如来无所著等正觉所说教。是菩萨当复至妙乐佛所。闻是般若波罗蜜妙乐佛土彼诸正士见是间。善男子善女人。亦复欢喜。是人曾行般若波罗蜜故来生是间。亦当复得深般若波罗蜜。如诸佛教住于阿惟越致地。须菩提。是故当知。般若波罗蜜音声多有所饶益。般若波罗蜜音声尚有所饶益乃尔。何况有行般若波罗蜜。所行如教住于萨云然者。须菩提白佛言。世尊。不离如教住。不离如者则为无所有。云何住萨云然。世尊。解脱如者无所得法。谁住如者。谁住如中。谁逮觉者。谁住于如。谁说法者。如尚不可得见。谁有住如者。谁逮觉者。是处不然。佛告须菩提。如汝所言。如者无生亦无有灭。如住无异不生灭者。谁当住是中成阿惟三佛者。谁说法者。是皆无所有。释提桓因白佛言。世尊。般若波罗蜜者甚深。菩萨欲成阿耨多罗三耶三菩甚难得。何以故。亦无住如者亦无成阿惟三佛者。亦无说法者。虽无所见无所有。闻是不恐不怖。须菩提语释提桓因言。拘翼。如拘翼所言。菩萨甚奇甚特。于深法中亦无狐疑亦无追喜。诸法皆空谁狐疑有进退意者。释提桓因语须菩提。如尊者所言。但说空事无所挂碍。譬如仰射空中箭去无碍。尊者须菩提所说亦无所著

    摩诃般若波罗蜜嘱累品第六十七

于是释提桓因白佛言。世尊。我所说者颇为随顺为应法不。佛言。如是如是。拘翼。汝所说问者为顺事形无有谬误。释提桓因言。世尊。尊者须菩提所说甚可奇异。所说不离空无相无愿。不离三十七品亦不离于道。佛告释提桓因言。拘翼。长老须菩提常行空行六波罗蜜亦不有。何况有行者。三十七品亦不有。何况有行者。禅惟无三昧三昧越亦不有。四无所畏四无碍慧四等大慈大悲十力佛十八法亦不有。何况有行者。道亦不有何况欲得者。萨云然亦然亦不有。何况有行者。如来尚不有。谁当为如来者。无所从生亦不有。何况有证欲得之者。相亦不有。何况有身有受三十二相者。诸好亦不有。何况有欲得八十种好者。所以者何。拘翼。须菩提者一切诸法以寂行故。须菩提者无所有行为以空行为无相行为无愿行。拘翼。是则为须菩提行。如须菩提所行。比菩萨摩诃萨行般若波罗蜜行。百倍千倍巨亿万倍不得为比。何以故。菩萨摩诃萨行般若波罗蜜者。比罗汉辟支佛菩萨摩诃萨为最上尊。除诸如来无有过者。是故菩萨摩诃萨。欲出诸天世间人民上者。当行般若波罗蜜。何以故。菩萨摩诃萨行般若波罗蜜。出声闻辟支佛上。住于菩萨地具足佛法。逮萨云然便得如来尔时坐中诸忉利天以文陀罗花而散佛上。尔时六千比丘整顿衣服已。从坐起为佛作礼长跪佛前。以佛威神诸文陀罗花各各满掬持散佛上。散花已讫。皆同时白言。我等世尊。当奉妙行如诸佛所行。诸罗汉辟支佛所不能及处。尔时世尊。知诸比丘意便笑。如诸佛常法五色光从口出。遍照十方还绕身三匝从顶而入。阿难。从坐起整衣服。先下右膝长跪白佛言。佛不妾笑愿闻其意。佛告阿难。是六千比丘后当来世。劫名多楼波尼。于彼劫中皆当成佛。号散花如来无所著等正觉。是诸如来国土皆等比丘僧数亦各各等。其佛寿命亦等其寿各千岁。作佛时各各尽世雨五色花。佛告阿难。是诸比丘于是寿命终在所生处。常当出家为道久久共俱。然后乃成阿耨多罗三耶三菩。复次阿难。菩萨摩诃萨欲得最妙之行者。当行般若波罗蜜。菩萨欲为如来者当行般若波罗蜜。阿难。若有善男子善女人行般若波罗蜜者。当知是人从人道中来。或从兜术天上来。当知是人从人道中。广闻般若波罗蜜。亦从兜术天上广闻般若波罗蜜。从本闻其中慧所致。若有善男子善女人。闻是深般若波罗蜜。书持受学讽诵行者。转复教人行菩萨道者说其中事。是善男子善女人当作是知。如从佛闻亦无有异。当知是人从过去诸佛作善本功德以来。是善男子善女人。不于声闻辟支佛法中作功德。亦不从声闻所闻是般若波罗蜜。阿难。若有善男子善女人。闻是深般若波罗蜜。读诵持受能解中义广宣教人。当知是人如面见佛无异。复次阿难。若善男子善女人。闻说是深般若波罗蜜时。不惊不怖倍复喜者。当知是人以从过去佛所作行所致久与善知识相得所致。是善男子善女人从过去佛作善本以来。终不失三乘之事。以精进意行六波罗蜜乃至萨云然。亦当庄事精勤。久当坚固行六波罗蜜至萨云然。不住罗汉辟支佛地。是故阿难。以般若波罗蜜嘱累汝阿难。我所说诸法。除般若波罗蜜。悉亡悉失其过可可耳。汝持是深般若波罗蜜。若忘失一句舍一句亡一句汝过甚多。是故阿难。以是深般若波罗蜜嘱累汝。当善持善受善讽诵念。若有善男子善女人。受持般若波罗蜜讽诵守行者。则为受持过去当来现在诸佛之道。若有善男子善女人。以名华名香缯盖幢幡用供养我者。当供养般若波罗蜜。其有供养般若波罗蜜者以为供养过去当来今现在诸佛已。若有善男子善女人。闻说深般若波罗蜜。于中起恭敬意者。则为供养过去当来今现在诸佛已。阿难。汝若恭敬慈于我者。当恭敬慈于般若波罗蜜。若书是般若波罗蜜时。亦当恭敬慎莫失一句。是故阿难。持般若波罗蜜嘱累于汝。如我今于三界中尊。般若波罗蜜亦复是尊。我所嘱累大有余事耳。我今持以般若波罗蜜嘱累汝。是故阿难。当宣语诸天龙神诸世间人。普令闻知。诸不欲舍如来三宝者。不欲弃去来今佛道者。慎莫弃舍般若波罗蜜。是者则我道之法御。若有善男子善女人。受持般若波罗蜜讽诵读习念守行者。转复教人演其中义分别解说者。是人疾得阿耨多罗三耶三菩。得萨云然不久。何以故。阿难。诸佛如来道者。皆出般若波罗蜜中。诸去来今佛皆从般若波罗蜜中出。是故阿难。菩萨欲得般若波罗蜜者。当学六波罗蜜。何以故。阿难。六波罗蜜者菩萨之母生诸菩萨故。诸学六波罗蜜者。皆当于中成阿耨多罗三耶三菩。是故阿难。持六波罗蜜倍嘱累汝。六波罗蜜者是诸如来无所著等正觉之法藏六波罗蜜者无尽之藏。诸去来今佛转法轮教化众生者。皆以六波罗蜜为藏。诸去来今佛皆于六波罗蜜中。学成阿耨多罗三耶三菩。诸去来今佛诸弟子。皆学六波罗蜜而般泥洹。甫当般泥洹者亦当学是六波罗蜜。阿难。汝若教三千大千刹土中为弟子者说法。皆令成就得阿罗汉。虽有是教未为我弟子之教。不如以般若波罗蜜一句如法教菩萨令学。是则为我弟子之教。阿难。我属所说三千大千国土。教满中人皆令得罗汉行。行六波罗蜜所作功德宁为多不。阿难言。甚多世尊。佛言。阿难。不如我弟子说般若波罗蜜一日教诸菩萨。若不能一日日中可。不能至日中食时可。不能至食时弹指顷。其福胜度尔所罗汉。所以者何。一菩萨之德。出过一切诸罗汉辟支佛上。何以故。是菩萨自欲成阿耨多罗三耶三菩。复劝助安慰一切众生。复欲令成阿耨多罗三耶三菩。阿难。行六波罗蜜三十七品。至萨云然增益功德。成阿耨多罗三耶三菩终不中还。说是般若波罗蜜时。四辈弟子及诸天龙阿须伦揵沓和甄陀罗摩睺勒。尔时佛于是大众之中。而现神足变化。令是会者大众皆见。阿閦如来彼大众围绕而为说法。众大会譬如大海。皆是罗汉诸漏已尽。无复尘垢。皆得自在。意已得脱。已出解慧。悉舍重担。众事已办。譬如大龙。所应已逮。习绪已讫。得等解脱。已度诸愿。彼会罗汉德皆如是。及诸菩萨摩诃萨数不可计。其德巍巍不可称量。佛摄神足已忽然不现。佛告阿难。诸法如是不可眼见。诸法无对。法法无等。法法不相见。法法不相知。如今诸众不见阿閦如来。彼佛国土亦不与眼作对故。诸法亦如是亦无对。法法不相知不相见故。阿难。法亦不知亦不见。诸法无所作。何以故。诸法空不可捉。诸法不可思议。诸法无有念。譬如幻士亦无所觉。用不要无坚固。菩萨摩诃萨如是行者。为行般若波罗蜜。于诸法无所入。阿难。菩萨如是学者。为学般若波罗蜜。欲逮诸波罗蜜者。当学般若波罗蜜。如是学者最尊最上出诸辩之上。无盖之盖为世覆盖。无所归者能为作归。佛以是学能以右手。举此三千大千刹土复还故处。一切众生无觉知想。所以者何。是般若波罗蜜诸去来今佛皆于中学成。去来今佛无碍诸慧。阿难。是般若波罗蜜学。于诸学中最尊最上过诸辩上。欲平相般若波罗蜜者。欲得虚空边际。何以故。般若波罗蜜不可平相。阿难。我初不说般若波罗蜜限。身体有数句体为有数义解为有数。般若波罗蜜者无有限数。阿难白佛言。世尊。何以故。般若波罗蜜无有限数。佛告阿难。般若波罗蜜。不可尽故无有限。般若波罗蜜寂故故无有限。过去当来今现在诸如来无所著等正觉。皆从是般若波罗蜜中学成。亦不能尽般若波罗蜜。是故阿难。般若波罗蜜不可尽。亦无能尽者。亦非尽者若有人言。我能尽般若波罗蜜者。为欲尽虚空。阿难。当知六波罗蜜不可尽亦不尽亦无能尽者。乃至萨云然亦不可尽无能尽者亦无有尽。是法亦无有生。尚无有生云何有尽。于是世尊。以广长舌相障面。告阿难言。持是般若波罗蜜。于四辈中广宣广说广分别解说。广演其事令分明。所以者何。是般若波罗蜜中广出诸法故。三乘学者皆当于中随其所应而得学成。阿难。是深般若波罗蜜者。是诸法之藏。一切诸字皆来入中。是般若波罗蜜者皆是诸陀罗尼之门。诸菩萨欲学陀罗尼者当学般若波罗蜜。诸有菩萨得陀罗尼者。悉为总持诸法之辩才。般若波罗蜜者是去来今佛法之所。是故我告语一切。其有受持般若波罗蜜讽诵学者。则为总持去来今佛之道。阿难。我今为汝说般若波罗蜜行。汝持般若波罗蜜者。则为总持一切诸法

    摩诃般若波罗蜜无尽品第六十八

是时须菩提意念言。诸佛之道大为甚深。我宁可问世尊。于是须菩提白佛言。世尊。般若波罗蜜云何不可尽。世尊报言。如虚空不可尽。是故般若波罗蜜不可尽。须菩提白佛言。世尊。菩萨当云何入般若波罗蜜中。佛言。如五阴不可尽。菩萨当作是入。如六波罗蜜不可尽。菩萨当作是入。乃至萨云然不可尽。菩萨当作是入般若波罗蜜。复次须菩提。痴如虚空不可尽。菩萨当作是入。所作行如虚空不可尽当作是入。识如虚空不可尽当作是入。名色如虚空不可尽当作是入。六衰如虚空不可尽当作是入。觉如虚空不可尽当作是入。爱如虚空不可尽当作是入。有如虚空不可尽当作是入。生如虚空不可尽当作是入。老病死忧悲勤苦如虚空不可尽当作是入。须菩提。菩萨摩诃萨当作是入般若波罗蜜中。菩萨摩诃萨于十二缘起作是观者。为舍痴际为应无所入。菩萨作是观十二缘起法者。则为得坐道场。作是观者便得萨云然。须菩提。若有菩萨知虚空不可尽事。为行般若波罗蜜观十二缘起者。终不堕罗汉辟支佛地。便得三耶三佛地。须菩提。诸有善男子善女人。行菩萨道而转还者。皆以无有般若波罗蜜念故。不知行般若波罗蜜故。不知十二缘起如虚空故。不知沤和拘舍罗故。以是故于阿耨多罗三耶三佛而转还。复次须菩提。诸有菩萨不转还者。皆以沤和拘舍罗入般若波罗蜜中。知虚空不可尽作是入般若波罗蜜故。须菩提。菩萨摩诃萨作如是观。十二缘起。不见有法无因缘而生者。不见有法。有常常生而不灭者。不见有法无不偶者。亦不见众生亦不见有我人寿命。亦不见有知见者。亦不见无常亦不见吾我。亦不见净亦不见不净。须菩提。菩萨摩诃萨行般若波罗蜜。当作是观十二缘起。须菩提。菩萨摩诃萨行般若波罗蜜。尔时不见五阴有常有无常有苦有乐有我无我有净无净。乃至萨云然亦不见法有常无常有苦有乐有我无我有净无净。须菩提。菩萨摩诃萨行般若波罗蜜时。亦不见有法可持见般若波罗蜜者。乃至于道亦不见有法可持见道者。须菩提。菩萨摩诃萨作是行般若波罗蜜者。于诸法无所倚。须菩提。菩萨摩诃萨行般若波罗蜜无所倚持。时魔波旬愁忧不乐。譬如士夫新丧父母。须菩提白佛言。世尊。独是间魔愁忧耶。三千大千刹土中魔复愁忧乎。佛言。三千大千刹土中魔皆大愁毒。各在其处不能自安。菩萨摩诃萨作是行时。诸天及魔不能得其便。须菩提。菩萨欲得阿耨多罗三耶三佛者。当行般若波罗蜜。菩萨学般若波罗蜜者。则为具足诸波罗蜜。须菩提白佛言。世尊。菩萨云何具足六波罗蜜念。佛告须菩提言。菩萨行六波罗蜜所可作。为萨云然念行。是为菩萨摩诃萨行六波罗蜜

    摩诃般若波罗蜜六度相摄品第六十九

于是须菩提白佛言。菩萨云何行檀波罗蜜而摄尸波罗蜜。佛言。菩萨布施求萨云然者。身口意常以三事净施众生。是为菩萨布施摄取尸波罗蜜。须菩提白佛言。菩萨云何布施摄羼波罗蜜。佛言。菩萨布施时受者逆骂詈轻易粗言加之。亦无恚恨之意向也。是为菩萨布施摄羼波罗蜜。云何菩萨布施摄惟逮波罗蜜。佛言。菩萨布施时。受者骂之亦复轻易。菩萨持意倍欲布施无所爱惜。常自念言。我常当布施不可废忘须臾之间。常开意施与不须。人来有所索者尔乃与之。常索受者不问远近。是为菩萨布施摄惟逮波罗蜜。云何菩萨布施摄禅波罗蜜。佛言。菩萨布施时求萨云然。其意不乱不求罗汉辟支佛道。是为菩萨布施摄禅波罗蜜。云何菩萨布施摄般若波罗蜜。佛言。菩萨布施时意常念言。我所布施如幻如梦虽有布施不见众生有增有减。亦不见有得我物者。亦不见不得者。是为菩萨行檀波罗蜜摄取般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨住尸波罗蜜摄取五波罗蜜。佛告须菩提。菩萨摩诃萨戒身口意。以戒不[打-丁+此]罗汉辟支佛地。自住于戒不害众生命。不犯不与取不犯梵行不犯十戒。住戒布施。随人所持戒布施。皆与众生共发羼提波罗蜜。佛言。菩萨行戒。若有人来节节解剥。其意亦无起恨。不嗔不恚倍欢喜言。我为得大利人来节节解我。是为菩萨住戒摄取羼提波罗蜜。云何菩萨行戒摄取惟逮波罗蜜。佛言。菩萨行戒时身口意不懈怠。常作念言。从生死中拔诸众生立甘露地。是为菩萨住戒摄取惟逮波罗蜜。云何菩萨行戒摄取禅波罗蜜。佛言。菩萨行戒。从第一禅至第四禅不倚二地。意常念言。我住于禅当度众生。是为菩萨住戒摄取禅波罗蜜。云何菩萨行戒摄取般若波罗蜜。佛言。菩萨行戒。亦不见法有所住止。不见法有以无。不见法过于如者。以般若波罗蜜沤和拘舍罗不堕二地。须菩提。是为菩萨住尸波罗蜜摄取般若波罗蜜。须菩提白佛言。世尊。云何菩萨行羼波罗蜜摄取檀波罗蜜。佛言。菩萨行忍从初发意至于道场。一切众生骂詈轻易节节支解。菩萨以住于忍地者。意常念言。虽人不取我当布施。不废须臾。持是功德与众生共发阿耨多罗三耶三菩。虽作是愿不住二处。何等二处。无有愿相无有作相。是为菩萨住忍摄取檀波罗蜜。云何菩萨住忍摄取尸波罗蜜。佛言。菩萨行忍从初发意坐于道场。初不犯十恶。从杀生至邪见。不犯十事奉行十善。意不想念二地。持是功德。愿与众生共发阿耨多罗三耶三菩。于三乘意适无所著。是为菩萨住忍摄取尸波罗蜜。云何菩萨行忍摄取惟逮波罗蜜。佛言。菩萨行忍起精进意言。我当去是百千俞旬或百千刹土或无数刹。若有一人不持戒者我当教令持。随其所应以三乘法而度脱之。持是功德与众生共发阿耨多罗三耶三菩。是为菩萨住忍摄取惟逮波罗蜜。云何菩萨行忍摄取禅波罗蜜。佛言。菩萨行忍从第一禅至于四禅所起善意。持是善意发阿耨多罗三耶三菩。所念意如无禅亦无禅者。是为菩萨住忍摄取禅波罗蜜。云何菩萨行忍摄取般若波罗蜜。佛言。菩萨行忍从初发意至于道场。观诸法寂观诸法净观诸法尽。以净法为证。坐道场已逮萨云然起便转法轮。是为菩萨住忍摄取般若波罗蜜。须菩提。菩萨所摄取。如不取。如不舍。须菩提白佛言。世尊。云何菩萨行惟逮波罗蜜摄取檀波罗蜜。佛言。菩萨精进从初发意至于道场。于其中间身口意行。无有须臾食息懈废。持是不懈之意我当成阿耨多罗三耶三菩不得不成住于精进。为众生故。过百千俞旬。从一佛土至一佛国。过百千刹为一切人故。假令一人未得度者。欲安此人以三乘法而度脱之。亦不见人有得度者。若无有一人能行佛菩萨道者。当以辟支佛事教之。若无有行辟支佛事者。当以十善事教之。趣得一人使入道检持是法。施众生。已复以具足所有布施。持是功德与众生共为阿耨多罗三耶三菩不为二地。是为菩萨住于精进摄取檀波罗蜜。云何菩萨精进摄取尸波罗蜜。佛言。菩萨精进从初发意至坐道场。自奉十善劝人令行。见行十善者代其欢喜。住于戒中不愿三界之乐。亦不愿二地。持是功德与众生。共为阿耨多罗三耶三菩。所为无有三念。于去来今不见有作者。是为菩萨住于精进摄取尸波罗蜜。云何菩萨精进摄取羼波罗蜜。佛言。菩萨精进从初发意至于道场。若人非人来取菩萨节节支解。作意念言。谁割我者劫者是谁。但念言。我得大利我为众生故受是身。今此众生自来取去。夫为法御之者。倍当欢喜不当有起。持是功德共与众生为阿耨多罗三耶三菩不为二地。是为菩萨住于精进摄取羼波罗蜜。云何菩萨精进摄取禅波罗蜜。佛言。菩萨精进从第一禅至于四禅。四等四无形禅亦不断亦不着。所生之处但欲救济众生。以六度之法度脱众生。往见诸佛从一佛刹至一佛刹礼敬供养殖诸善本是为菩萨住于精进摄取禅波罗蜜。云何菩萨精进摄取般若波罗蜜。佛言。菩萨精进不见五波罗蜜。亦不以相见。亦不以事见。亦不见三十七品。乃至萨云然亦无所见。亦不见诸法。亦不以事见。亦不以相见。亦不为法作巢窟。所语如所作亦无有二。是为菩萨住于精进摄取般若波罗蜜。须菩提白佛言。世尊。云何菩萨行禅波罗蜜摄取檀波罗蜜。佛言。菩萨行四禅四等四无形禅不以乱意。住于诸禅常行二施。法施财施自行二施。复劝助人令行二施。常赞叹二施之德。见人二施常赞叹之代其欢喜。持是功德共与众生为阿耨多罗三耶三菩不为二地。是为菩萨住禅摄取檀波罗蜜。云何菩萨行禅摄取尸波罗蜜。佛言。菩萨行禅不生淫怒痴意。亦不生有所害意。但生萨云然行意。持是功德共与众生为阿耨多罗三耶三菩不为二地。是为菩萨住禅波罗蜜摄取尸波罗蜜。云何菩萨行禅摄取羼波罗蜜。佛言。菩萨行禅观色如聚沫。观痛如泡。观想如野马。观所作行如芭蕉。观识如幻。作是观已于五阴作无坚固不要想。作是观已念言。是中谁有割剥我者。为是谁。色谁痛谁想谁行谁识谁。作是观已复自念言。既骂詈粗言轻易之。意亦不起恚。尚无起者谁有骂者。是为菩萨住禅摄取羼波罗蜜。云何菩萨行禅摄取惟逮波罗蜜。佛言。菩萨以四禅趣禅。趣禅之德便得无量之变化。以天耳彻闻二声。意如众生念。自识无数生死之事。以天眼见众生所得报应随行善恶。住五神通从一佛国至一佛国。礼敬供养殖诸善本。净佛国土教化众生。持是功德共与众生为阿耨多罗三耶三菩不为二地。是为菩萨住禅摄取惟逮波罗蜜。云何菩萨住禅波罗蜜摄取般若波罗蜜。佛言。菩萨行禅不有五阴六波罗蜜。亦不有三十七品。至萨云然及有为无为性。无所有亦无所作。虽无所作亦不生灭。所以者何。有佛无佛法性常如故。亦不生亦不灭。但有萨云然念。应萨云然行。须菩提。是为菩萨行禅波罗蜜摄取般若波罗蜜。须菩提白佛言。世尊。云何菩萨行般若波罗蜜摄取檀波罗蜜。佛告须菩提。菩萨行般若波罗蜜。自于内空不有内空。于外空亦不有外空。自于内外空亦不有内外空。空空大空第一最空有为空无为空亦不有空。亦不见至竟无底空行性空。一切诸法自空。菩萨摩诃萨住此十四空已。亦不见五阴空。以不空亦不知亦不有。亦不见三十七品空。以不空亦不知亦不有。乃至于道亦不见空。以不空亦不见。有为无为之性空以不空亦不知亦不见。菩萨摩诃萨行般若波罗蜜所作布施。人中天上所有所可布施皆悉见空。受者与者皆亦空。观贪嫉之意初不能得其便。所以者何。菩萨行般若波罗蜜。无有分别若干念故。从初发意至坐道场。贪嫉之意不生。亦如如来无所著等正觉无贪嫉意也。是故菩萨行般若波罗蜜无贪嫉之意。菩萨摩诃萨所可尊者则般若波罗蜜是。是为菩萨住于般若波罗蜜摄取檀波罗蜜。云何菩萨行般若波罗蜜摄取尸波罗蜜。佛言。菩萨行般若波罗蜜二地之意不能得其便。所以者何。无罗汉辟支佛意故。索作二地意亦不可得。从初发意至坐道场常住十善。复劝进人使行十善。见人行者亦赞叹之代其欢喜。持是戒意不[打-丁+此]诸法亦不[打-丁+此]二地。何况其余。是为菩萨住般若波罗蜜摄取尸波罗蜜。云何菩萨行般若波罗蜜摄取羼波罗蜜。佛言。菩萨行般若波罗蜜便生顺忍念言。诸法亦无生者亦无灭者。亦无生死亦无骂者。亦无割者亦无剥者。亦无挝捶亦无缚者。从初发意至坐道场。一切众生若挝若割刀仗支解。意生念言。哀哉诸法之法何所骂者。何所挝者何所剥者。是为菩萨住般若波罗蜜摄取羼波罗蜜。云何菩萨行般若波罗蜜摄取惟逮波罗蜜。佛言。菩萨行般若波罗蜜。为众生说法安立众生于六波罗蜜。立于三十七品。立于三乘之法。立于阿耨多罗三耶三菩。安立众生如不立。于有为无为之法。是为菩萨住般若波罗蜜摄取惟逮波罗蜜。云何菩萨行般若波罗蜜摄取禅波罗蜜。佛言。菩萨行般若波罗蜜除如来三昧。余二地三昧菩萨三昧皆悉能行。于八惟无禅九次第禅。能逆顺行三昧已竟。于是三昧起便入师子奋迅三昧。何等为师子奋迅三昧。佛言。悉总持四禅无形禅解脱禅九次第禅。悉能逆顺入诸三昧。于师子奋迅。三昧起便入满法阇(丹本佉闇)三昧逮诸法等。须菩提。是为菩萨摩诃萨住于般若波罗蜜摄取禅波罗蜜

放光般若经卷第十五放光般若经卷第十六

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜沤和品第七十

尔时须菩提白佛言。唯世尊。菩萨摩诃萨发意以来。为几时能具足。行沤和拘舍罗乃如是。佛告须菩提。是菩萨摩诃萨发意以来。不可计阿僧祇劫。须菩提言。世尊。能行沤和拘舍罗菩萨摩诃萨者。为供事几佛。佛告须菩提。是菩萨已供事如恒边沙佛以来。乃能逮得是沤和拘舍罗。须菩提言。世尊。是菩萨作何等功德。乃能具足沤和拘舍罗。佛言。菩萨所作功德。常具足六波罗蜜。于施于戒于忍于进于禅于智。于六德中无有不具足者。以是故能行沤和拘舍罗。须菩提言。世尊。甚奇甚特。是菩萨所作功德不可计量。乃能逮是沤和拘舍罗。佛言。如是如是。须菩提甚可奇特。乃能具足沤和拘舍罗。譬如日月宫殿。周流四域能有所益。般若波罗蜜亦复如是。遍入五波罗蜜中多所饶益。五波罗蜜因般若波罗蜜而得名字。离般若波罗蜜者亦不得五波罗蜜之名字。譬如转轮圣王。无七宝者亦不得为转轮圣王之名。五波罗蜜离般若波罗蜜者亦无有名字。譬如无夫之妇无不陵易者。五波罗蜜离般若波罗蜜。魔及魔天无不欲娆者。五波罗蜜不离般若波罗蜜者。魔及魔天无能得其便者。譬如郡国有勇健之士。参知五兵器仗具足常在其处者。邻国怨敌不敢侵近。五波罗蜜不离般若波罗蜜者。诸魔魔天若[旃-方+示]陀罗人。[旃-方+示]陀罗者晋言狱侍主杀人者若顽佷之人抵突之人诈称菩萨人。是辈之人无能得其便者。譬如转轮圣王治于世间。诸粟散小王随其教令无敢违者皆悉随。从五波罗蜜得般若波罗蜜者便至萨云若。譬如百川千流皆入于恒已俱入大海。般若波罗蜜者摄取五波罗蜜。亦复如是。般若波罗蜜者。譬如人之右手无事不为。五波罗蜜者如人左手佐助右手。譬如众流恒水江河。悉入大海合为一味。五波罗蜜与般若波罗蜜俱入萨云若合为一法。亦复如是。譬如转轮圣王将四种兵。圣王出时紫金轮转常在前导。若圣王意欲得宝时轮则为住。圣王取宝毕竟有所施与。其事讫竟轮尔乃去。若众人未遍不足轮不为转。般若波罗蜜导五波罗蜜至萨云若终不动转。譬如转轮圣王所有七宝。三宝常导在前。一者金轮。二者主兵臣。三者主藏臣。般若波罗蜜常导五波罗蜜至萨云若。住般若波罗蜜亦不念言五波罗蜜常随从我。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜亦不作念。我当随从般若波罗蜜。何以故。自空无所能作无所能为。如热时之焰。须菩提白佛言。世尊。云何诸法空。云何菩萨行六波罗蜜逮得阿耨多罗三耶三菩。佛报言。菩萨行六波罗蜜意念言。以三界众生皆着四颠倒。当以沤和拘舍罗而度脱之。我当为众生故行六波罗蜜。为众生故舍意所作。内外所有布施。布施时念言。我无所一施。何以故。所有财物及身会当坏故。菩萨作是观者便具足檀波罗蜜。为众生故不听恶戒。我亦不应犯十恶事。我亦不应堕于二地。菩萨作是观。便具足尸波罗蜜。为众生故意常不恚乱。是为菩萨具足羼波罗蜜。为众生故至阿耨多罗三耶三菩终不懈怠。是为菩萨具足惟逮波罗蜜。为众生故至阿耨多罗三耶三菩终不乱意。是为菩萨具足禅波罗蜜。为众生故至阿耨多罗三耶三菩初不离于智慧。是为菩萨具足般若波罗蜜。何以故。不可以异法度脱众生。唯当以智慧之事度脱众生耳。以是故菩萨当习行般若波罗蜜。须菩提白佛言。世尊。若诸波罗蜜无有差特者。云何般若波罗蜜。于五波罗蜜中最尊最胜。佛言。如是如是。诸波罗蜜无有差别。虽无差别者要五波罗蜜从般若波罗蜜而得名字。因般若波罗蜜故五波罗蜜各得名字。须菩提。譬如须弥山若干种杂色。至须弥山者皆与须弥山同色无复别异。五波罗蜜因般若波罗蜜而得名字入萨云然。与般若波罗蜜合亦无差特。以入般若波罗蜜亦无若干字。亦无檀之名字。亦无尸羼惟逮禅亦无是名。何以故。诸波罗蜜亦无有形故。以是无有差别。须菩提白佛言。世尊。所逮至处无有差特云何般若波罗蜜于五波罗蜜中最尊最上。佛言。如是所逮至处无有差别。以世俗生死故。知有六波罗蜜为世俗施耳。而众生不知亦不起灭亦不生死。众生及诸法无有边际亦无底。是故须菩提。般若波罗蜜于五波罗蜜而最上尊。譬如阎浮提众母人中玉女宝最第一。般若波罗蜜于诸波罗蜜中最上。须菩提言。世尊。是谁之威神。令般若波罗蜜于五波罗蜜中为最尊上。佛告须菩提。以般若波罗蜜总持诸善功德之法。以无处所住于萨云若。须菩提言。世尊。般若波罗蜜。颇有所取有所舍耶。佛言。般若波罗蜜于诸法无所取亦无所放。何以故。诸法亦无所持亦无所放。世尊。般若波罗蜜。不持何法不舍何法。佛言。般若波罗蜜亦不取五阴亦不舍五阴。及三十七品乃至于道。亦不取亦不舍。世尊。云何不取五阴亦不取道。佛言。不念五阴亦不念道。是故无所取。须菩提言。世尊。是事云何。不念五阴乃至于道。亦复不念。云何当得增益功德。若不增益功德。云何得具足诸波罗蜜。若不具足诸波罗蜜。云何逮萨云若。佛告须菩提。以不念五阴以不念萨云若故。便得增益功德逮得萨云然。何以故。以不念五阴以不念道。以是故便逮得道世尊。何以故。不念五阴不念道。佛言。以念故便着欲界形界无形界。以无所念故便得无所著。是故菩萨行般若波罗蜜。亦无所近亦无所著。世尊。菩萨行般若波罗蜜。如是为无所住。佛言。如是菩萨作如是行般若波罗蜜者。亦不住于五阴亦不住萨云若。世尊。何以故不住。佛言。以无所入故不住。何以故。亦不见法有所住有所入者。菩萨行般若波罗蜜。无所入便应无所住。菩萨作是住作是行。则为行般若波罗蜜。则为住般若波罗蜜。若有言我行般若波罗蜜。我念般若波罗蜜者。则为远离般若波罗蜜。已以远离般若波罗蜜者。则为远离五波罗蜜。则为远离萨云若已。何以故。般若波罗蜜无所入。亦无有能入般若波罗蜜者。何以故。无有形可入处故。若菩萨于般若波罗蜜有知者则为已堕。于般若波罗蜜堕者。则为于诸法已堕。若复作念。般若波罗蜜。受持五波罗蜜。并使持萨云若者。则复为已堕。为不行般若波罗蜜。不能成阿耨多罗三耶三菩。若复生念言。于是般若波罗蜜中受阿耨多罗三耶三菩记莂者。则复已堕。于般若波罗蜜堕者。不得阿耨多罗三耶三菩。若复作念。我当因般若波罗蜜行五波罗蜜。行于大慈则复为堕。堕者亦不能成五波罗蜜。亦不能成大慈。若复作念。如诸如来于诸法无受无所行。自然得逮觉。持是教授众生则复为堕。所以者何。如来者于诸法无所逮觉。是故不处法。何况有法可逮觉者。是者不然。须菩提白佛言。菩萨当云何行般若波罗蜜而无是瑕隙。佛告须菩提菩萨行般若波罗蜜者当念言。是诸法无所有。无所有法中法无所取亦无所逮觉。如是行者为行般若波罗蜜。若欲入无所有法者则离般若波罗蜜。何以故。般若波罗蜜无所入亦无有入者。须菩提言。世尊。若般若波罗蜜不离般若波罗蜜。檀波罗蜜不离檀波罗蜜。乃至萨云若不离萨云若。若不离云何入般若波罗蜜。乃至萨云若云何有入。佛言。菩萨行般若波罗蜜。亦不入五阴亦不[打-丁+此]五阴。亦不非五阴。乃至萨云若亦复如是。亦不言五阴有常无常有苦有乐有我无我有空有寂。乃至萨云若亦复如是。有常无常苦乐吾我空寂。是法亦不入有形亦不入无形。须菩提。菩萨行六波罗蜜行萨云若。譬如转轮圣王出时四种兵皆随从。五波罗蜜皆随从般若波罗蜜。至萨云若住。譬如善御驾驷初不失辙。般若波罗蜜御五波罗蜜。顺至萨云若。须菩提白佛言。何等是菩萨道。何等是非道。佛报言。声闻辟支佛道非菩萨道。萨云若者是菩萨道。须菩提白佛言。世尊。般若波罗蜜者。为诸菩萨兴大事也。乃能分别是道非道。佛言。如须菩提所说。般若波罗蜜者为不可计阿僧祇众生兴。虽赞叹行事。不受五阴亦不受二地。般若波罗蜜者众生之御。御众生令至萨云若。不与二地作御。是故般若波罗蜜。于诸法无所生无所灭。以法性等故。须菩提白佛言。世尊。若般若波罗蜜不生诸法亦不灭诸法。菩萨云何行六波罗蜜。佛言。因萨云若故。念六波罗蜜。持是功德与众生。共为阿耨多罗三耶三菩。菩萨持是功德求阿耨多罗三耶三菩。便具足六波罗蜜念菩萨所行慈。则为萨云然。菩萨有离六波罗蜜者。则为离萨云然。以是故菩萨欲得阿耨多罗三耶三菩者。当学六波罗蜜具足诸善功德。乃逮萨云若。是故菩萨当行六波罗蜜。世尊。菩萨云何习六波罗蜜。佛言。菩萨当作是观。五阴不习亦不不习。乃至萨云若亦复如是。菩萨当作是习六波罗蜜。复次须菩提。菩萨不习住于五阴。乃至萨云若亦不习住。何以故。五阴及萨云若无所住故。菩萨欲成阿耨多罗三耶三菩。当习无所住。须菩提。譬如士夫欲得甘果便种果树。深埋栽根随时溉灌。令得润泽萌牙得生。便有枝叶花实而得食之。菩萨欲得阿耨多罗三耶三菩者。当学六波罗蜜。以六波罗蜜摄取众生度脱众生。是故须菩提。菩萨欲独步于三界。欲净佛土。欲坐道场者。欲转法轮者。当学六波罗蜜。须菩提白佛言。世尊。当学般若波罗蜜耶。佛言。如是当学。佛言。欲于诸法中自在。当学般若波罗蜜。何以故。般若波罗蜜于诸法中独步故。般若波罗蜜者诸法之面。譬如大海为万川四流作面。诸欲学萨云若。当学般若波罗蜜。是故菩萨当学六波罗蜜。当学萨云若。譬如善射之人执持弓箭不畏怨敌。菩萨行般若波罗蜜不畏魔及魔天。是故菩萨欲得阿耨多罗三耶三菩者。当学般若波罗蜜。有行般若波罗蜜者。过去当来今现在诸佛皆悉念之。须菩提白佛言。世尊。云何菩萨行六波罗蜜为诸佛所念。佛言。所念不有六波罗蜜故念。不有萨云若故念。作是住者为诸佛所念。复次须菩提。亦不以五阴故念。不以乃至萨云若故念。须菩提言。世尊。菩萨所学甚多如无所学。佛言。如是多有所学亦无所学。何以故。不见有法菩萨当可学者。须菩提言。世尊。所说法多少菩萨皆当受行。菩萨欲得阿耨多罗三耶三菩者。六波罗蜜事若多若少皆当受行。当坚持常当观念令意不转。菩萨于六波罗蜜。皆当尽学。于诸法多者少者亦当尽学知。须菩提言。世尊。云何诸法多少尽当知诸法。佛言。五阴如萨云若如。以知五阴及萨云然如者。便知得诸法多少。世尊。云何得知五阴如萨云若如。亦不知生亦不知灭。亦不知耗常住不变。佛言。观真际故。便知诸法多少。世尊。云何为观真际。佛言。真际者非际。菩萨于非际学。便知诸法多少。以知法性便知诸法多少。知色性法性无有断绝。便知诸法多少。须菩提言。世尊。云何知诸法多少。佛言。诸法不偶非不偶。世尊。何等法不偶非不偶。佛言。五阴不合亦不不合。乃至有为性无为性亦不合亦不不合。所以者何。是法亦无形可得合者非不合者。何以故。所有者皆无所有。亦不合亦不散。当作是知诸法。须菩提言。世尊。菩萨从初发意至于十住。皆当作是学。计校然后皆知诸法多少。菩萨利根者所入。非钝根者所入。非中间者所入。非多少者所入。欲学入是御者。非懈怠者所入。非悕望者所入。是精进者所入。强识者所入。是阿惟越致逮萨云若者所入。受六波罗蜜所教便入萨云若。菩萨行般若波罗蜜者。若魔事起能觉能灭。欲得沤和拘舍罗者。当学般若波罗蜜。菩萨行般若波罗蜜时。若念若入时。十方现在诸佛皆念。是菩萨去来今诸佛。皆于般若波罗蜜中出生。菩萨行般若波罗蜜当作是念。去来今诸佛所逮法我亦当逮。菩萨行般若波罗蜜者当作是习。如是习者疾得阿耨多罗三耶三菩。是故菩萨不当离萨云若念。大千刹土其中众生。皆教令行六波罗蜜。尽令得须陀洹及罗汉。至辟支佛。不如是菩萨行般若波罗蜜如弹指顷。何以故。五波罗蜜须陀洹及罗汉辟支佛道。皆于中出生故。诸去来今诸佛皆亦于中出生。一恒边沙其中众生悉教令布施至声闻辟支佛。不如菩萨念般若波罗蜜应萨云若。念般若波罗蜜应萨云若。念一日至百日。若至百劫。何以故。用诸如来皆于中出。立于檀教及罗汉辟支佛教故。若有菩萨如般若波罗蜜教住。当知是如来所念阿惟越致菩萨。当知是菩萨已行六波罗蜜。已逮沤和拘舍罗。已供事若干佛。已得真知识。已得具足十八空。已成四无碍慧。已得六通。已住童男清净之行满足诸愿。当知是菩萨不离诸佛。不离诸善功德。不离诸佛之刹。不失辩才已得总持。诸根具足记莂成就。当知是菩萨三界八难诸处永绝。知是菩萨善入众事。善入无字义。亦善于言亦善于默。亦善多言亦善一言。善诲于男。善诲于女。善于五阴。善于泥洹。善于法相。善于有为无为之性。善于有无。善于此彼。善于合散。善于不合不散。亦善于如。亦善于净法。亦善于有缘无缘。善于五阴。善于六衰。善于十八性。善于四谛善于十二缘起。亦善于禅。亦善于四禅。亦善于四无形禅。亦善于六波罗蜜。善于三十七品。善于萨云若。善于有为无为性。亦善于身。亦善无身。亦善于五阴念乃至萨云若。亦善于念。善于五阴自空乃至于道。善于道空。善于信道空。善于不信道空。善于起灭。善于一定住。无复有变。亦善于淫怒痴。亦善无淫怒痴。善于正见。善于不正见。亦善于邪见。亦善于不邪见。亦善于诸见。善于名色。善于所作。善于尊事。亦善于相。亦善于苦。亦善于习。亦善于尽。亦善于道。善于泥犁。善于薜荔。善于畜生。亦善于三恶趣。亦善于人亦善于人趣。亦善于天趣。亦善于声闻辟支佛。亦善于声闻辟支佛道。亦善于萨云然。亦善于萨云若道。亦善于力。亦善于具足力。善于卒知。善于微知。善于厌知。善于大智。善于无涯底智。善于去来今三世之慧。亦善于权。善察众生。亦善于义。亦善于解。善断于三恶处。佛告须菩提。是为菩萨摩诃萨行般若波罗蜜。念般若波罗蜜。入般若波罗蜜之德

须菩提白佛言。世尊。云何为行般若波罗蜜。云何念。云何入。佛言。当知五阴有常无常有坚固无坚固有真无真。当作是知。是为行般若波罗蜜。入般若波罗蜜。当如入空观。诸所有皆无所有。当作是念。须菩提言。世尊。菩萨学般若波罗蜜当至久如。佛言。菩萨从初发意行般若波罗蜜至坐道场。当作是行。当作是念。当作是入。须菩提言。世尊。菩萨念般若波罗蜜当以一意念耶。佛言。菩萨常以一意至念般若波罗蜜。不得令他余之意中得其便。行般若波罗蜜。作是入作是念。不离萨云然念。念般若波罗蜜。当如意法随意不离。须菩提言。世尊。般若波罗蜜。持行持念持入逮萨云然。佛言不也。须菩提白佛言。世尊。持是不念得萨云然。佛言不也。须菩提白佛言。世尊。持念已不念得萨云然。佛言不也。须菩提白佛言。世尊。亦不念亦不不念得萨云然耶。佛言不也。须菩提言。当以云何得萨云然。佛言。如如。云何如如。佛言。如真际。云何如真际。佛言。如法性如众生性如寿性如命性。世尊。云何如法性如众生性如寿命性。佛言。于须菩提意云何。吾我寿命众生为可得不。须菩提言。世尊。不可得。佛言。吾我寿命众生不可得。云何有众生名众生。菩萨当作是知。不以有名入般若波罗蜜。不以有名入诸法得逮萨云然。须菩提言。世尊。是六波罗蜜不当以名耶。佛言。六波罗蜜及诸法。皆不以有为无为之法及三乘之法。须菩提言。世尊。若诸法不可名不可有名。云何有名。云何有五趣生死及须陀洹斯陀含阿那含阿罗汉辟支佛三耶三佛。佛言。于须菩提意云何。众生名处为可得见不。世尊。不可得见。佛言。众生处尚不可得。何况有五趣三乘之法。菩萨行般若波罗蜜者。当学无处所名诸法无处所。须菩提言。世尊。如世尊所说。为不当学五阴耶。乃至萨云若不当学耶。佛言。当学五阴。亦当学萨云然。虽学亦无所处。云何所学而无所处。佛言。学五阴萨云然亦无所生无所灭。复问。云何学无所生无所灭。佛言。当学所作无所有。云何当学所作无所有。佛言。观法如自观无所有相。是为学所作无所有。云何自观无所有相。佛言。如观五阴空如观六情空。如观内外空。如观有无空。如观禅空。如观灭脱禅空。如观三十七品空。如观道空。须菩提。菩萨行般若波罗蜜当作是观。当自观相法空。须菩提言。世尊。若五阴空乃至于道亦空。菩萨当云何行般若波罗蜜。佛言。菩萨行般若波罗蜜为不成之行。云何不成之行。佛言。般若波罗蜜不可得见故。菩萨亦不可得。行亦不可得。亦无有行者。亦无有当行者。亦无有已行者。是皆不可得。是菩萨般若波罗蜜无成之行。何以故。诸戏不可得见故。须菩提言。世尊。菩萨如是为不成行。新发意者当云何行般若波罗蜜。佛言。菩萨从发意当无所倚法。学行六波罗蜜皆当无所倚。乃至萨云然当念无所倚。云何为倚。云何为不倚。佛言。二者为倚。一者为不倚。云何为二。云何为一。佛言。眼色为二。六入念法为二。道与佛为二。是为二。云何世尊。从有倚中无倚。从无倚中有倚。佛言。亦不从有倚中有倚。亦不从无倚中有倚。倚与无倚而一等入者。是谓无倚。须菩提。菩萨于倚无倚等者是谓无倚。当作是学。菩萨如是学般若波罗蜜者。是为无有倚。须菩提言。世尊。菩萨行般若波罗蜜。亦不行倚亦不行不倚。云何行般若波罗蜜。具足诸地而逮萨云然。佛言。菩萨不住于倚具足诸地。何以故。般若波罗蜜亦不倚。道亦无所倚。行般若波罗蜜者亦不可得见。菩萨当作是行。世尊。般若波罗蜜不可得见。道亦不可得。行道者亦不可得。云何菩萨行般若波罗蜜。分别诸法是五阴是为道耶。佛言。菩萨行般若波罗蜜。亦不倚五阴亦不倚道。复问。若菩萨不倚五阴亦不倚道。云何具足六波罗蜜过菩萨位。云何净佛土化众生。云何逮萨云然。云何转法轮。云何当作佛事。云何脱众生生死。佛言。菩萨亦不为五阴故行般若波罗蜜。亦不为道故行般若波罗蜜。复问为何谁故行般若波罗蜜。佛言。适无所为故行般若波罗蜜。何以故。诸法无有作者。般若波罗蜜亦无有作者。亦无成者。道亦无作者亦无成者。菩萨亦无有作者。亦无有成者。菩萨当作是行。般若波罗蜜。应无所作应无所成者。须菩提言。世尊。若诸法无作无成者。亦无有三乘之处。佛言。无作无成之法处不可得。何以故。以凡愚痴之士入五阴。倚五阴自贡高。倚道贡高。便念言。我当得道度脱众生。何以故。须菩提。佛以五眼尚不能得五阴及道。况于凡夫愚痴无目。而入五阴欲度众生。须菩提言。世尊。以五眼不得众生不见可度者。云何成阿耨多罗三耶三菩。而云何处众生于三际。佛言。我亦不见得阿惟三佛。我亦不得众生我亦不见。三际亦不得亦不见。以众生无身。及有身想但以是戒之耳。所说教但以世俗故有是言教。非是最第一义无言之教。须菩提言。世尊。不住最第一要义。成阿惟三佛耶。佛言不也。须菩提言。从四颠倒。成阿惟三佛耶。佛言不也。须菩提白佛言。世尊。不从第一要义得。亦不从四颠倒得。将无世尊不逮正觉。佛言不也。佛言。如来逮正觉耳。亦不住有为性。亦不住无为性。譬如如来化作如来。亦无所住亦来亦去亦住亦坐。亦复行六波罗蜜。亦能行禅。亦行四等四无形禅。能行五通三十七品。能行三脱门。行内外空及有无空。亦行八解脱九次第禅十力四无所畏佛十八法。亦能转法轮。此化佛复化作无央数人。化佛语人言。有度有众生有三际。佛问须菩提。是化佛所化颇有三际众生不。须菩提言。不也世尊。佛告须菩提。是故如来无所著等正觉。知诸法如化无所度脱。菩萨于般若波罗蜜当作是行。当作是知。须菩提言。如世尊言。诸法如化。如来所化身与如来身。有何等异。有何等差别。佛言。亦无有异亦无有差别。何以故。如来亦有所作化亦有所作。复问。无有如来化独能有所作耶。佛言。能有所作。云何世尊。佛告须菩提。过去有佛名须扇头。(须扇头者晋言极净如来)彼佛世时。人无有行菩萨道者。则佛现般泥洹作化佛留住一劫。行佛事一劫已。后彼化佛授应菩萨行者莂。复般泥洹。人皆呼般泥洹不知是化。佛言。化亦无生亦无泥洹。须菩提。菩萨行般若波罗蜜者。当解诸法如化。须菩提言。世尊。若化所作如来所作无有差别者。所作功德云何毕施之恩。若供养化佛供养如来。彼供养者至般泥洹其福尽灭不。佛言。如来为一切天及人作福田。化如来亦复是一切之福田等无有异。佛言。置是供养如来化如来所作功德。若有人慈意常念佛其福至毕苦乃尽。佛言。置是慈意之福。若人但以一把之花散虚空中。须臾念佛。其福亦复至于毕苦。佛言。置是散花之福。但有人能称南无佛者。其功德福亦至于毕苦。须菩提。施如来之福甚大弘普。须菩提当作是知。诸法皆等化佛及佛无有差别。菩萨当作是行般若波罗蜜。当解诸法之法亦不当灭亦不当舍。是般若波罗蜜法亦不当别。乃至诸法亦当如是。须菩提言。世尊。若诸法不当别。如来云何言。是色是痛是想是行是识。云何说。是内法是外法是善是恶是漏是非漏是道是俗是生是死是有为法是无为法。世尊。如是诸法将无分别。佛言不也。但以名字数示众生。欲使解耳。亦无所分别。世尊。是无名号之法。云何以名相教授众生欲令得解。佛言。行亦无名亦无相亦无入。行亦无苦亦无相亦无入。诸佛及弟子亦不入相。若名有入名。相亦当入相。空亦当入空。无相亦当入无相。无愿亦当入无愿。真际亦当入真际。法性亦当入法性。无为法者亦当入无为法。是诸法但以字耳。字亦不入字。菩萨住于以名相行般若波罗蜜。亦不当入名相中。须菩提言。世尊。若诸有为法但以名相住者。菩萨为谁而发道意。为谁受若干勤苦行六波罗蜜。为谁行禅及无形禅。及行四等三十七品。总三脱门具足大慈皆为谁行。佛言。以名相数相。诸有为亦不以名相空。是故菩萨行菩萨道逮萨云若。及转法轮。以三乘法度脱众生。是名字及相亦不生灭。如所住无有异。须菩提言。世尊。说萨云然耶。佛言尔。我所说萨云然萨云然事。说道慧事。世尊。是者有何差别。佛言。萨云若者是诸声闻辟支佛事。道慧事是诸菩萨摩诃萨事。萨云若事者是诸佛如来事。复问。云何萨云若是声闻辟支佛事。佛言。诸内外法罗汉辟支佛悉知。虽知不住众道事。何等为菩萨道慧事。佛言。菩萨者一切诸道皆当说皆当知。及三乘道亦当具足知。亦当作三道之事。亦不受真际觉。复问。菩萨云何具足佛事不觉真际。佛言。未具足佛土未化众生不当受真际觉。复问。菩萨当住于道中受真际证耶。佛言不也。云何可从无道耶。佛言不也。世尊。可从道非道耶。佛言不也。亦不道亦非非道耶。佛言不也。须菩提言。世尊。当云何。佛言。于须菩提意云何。汝本住于道灭尽诸漏耶。须菩提言不也。佛言。汝从非道灭诸漏耶。世尊不也。佛言。汝以道非道灭诸漏耶。世尊不也。佛言。汝以道亦非道亦非非道灭诸漏耶。世尊不也。我无所住而灭诸漏。虽灭诸漏而无所住。佛告须菩提。菩萨亦复如是。虽为真际作证亦无所住。虽言萨云若萨云若事者。亦一事耳。世尊。何等为一事。佛言。寂静者是也。佛告须菩提。诸所言所有形貌之像。起灭之事佛悉觉之。是故名萨云若。须菩提白佛言。世尊。萨云若萨云若事道慧事。是三句绪际宁有差别不。绪有尽有余者不。佛言。绪尽无有差别也。但为佛诸习绪尽耳。声闻习绪不悉尽。世尊。尔为绪不尽得泥洹耶。佛言不也。世尊。泥洹者为有差别耶。佛言不也。若无差别。世尊。云何说诸习绪不尽。佛言。诸习者非习绪也。虽有淫怒痴为凡夫身作耗非为是绪。如来者无绪。须菩提言。世尊。道亦无所有泥洹亦无所有。云何说言是须陀洹是阿罗汉是辟支佛是三耶三佛乎。佛言。是皆因无为而有名。是须陀洹是阿罗汉是辟支佛是三耶三佛耳。世尊。从无为而有名耶。佛言不也。但以言说。有是言耳。不从最要第一之义也。所以者何。第一要中无若干行也。亦不施若干。为爱断者故施后际。世尊。诸法相各自空真际不可知。云何知有后际。佛言。如是诸法相空真际不可知。何况有后际。不知诸法相空者。我为是辈说前后际耳。诸法相者亦无前后。须菩提。菩萨行般若波罗蜜者。当知诸法相空。如是诸法行空于诸法无所入。亦不入内法亦不入外法。亦不入有为无为法。亦不入三乘法。复问。世尊。所言般若波罗蜜者。何以故。言般若波罗蜜。佛言得度第一诸法之度。最第一度三乘之道。诸如来无所著等正觉乘。皆乘般若波罗蜜得到彼岸。是故言般若波罗蜜。又复超越诸法之尘不得坚要。是故复言般若波罗蜜。真际法性及如皆入般若波罗蜜中。是故言般若波罗蜜。须菩提。般若波罗蜜。于是诸法亦不合亦不散。有见无见有碍无碍。于是诸法亦不合散。以般若波罗蜜无形不可见。亦无有对。一相则无相。所以者何。生诸法诸辩故。诸天及世间魔怨异学及声闻辟支佛家。一切无能断截菩萨摩诃萨行般若波罗蜜者。所以者何。一切魔怨及诸二地皆不可得故。须菩提。菩萨于般若波罗蜜义中。当作是知当作是行。复次须菩提。菩萨于般若波罗蜜义中。行无常义苦非我义。知苦习义知尽道义。知消灭义知不起义知法义。见一遍知义自知义知他人意义。行如所言。须菩提。菩萨于般若波罗蜜。当知是义当作是行。须菩提。白佛言。世尊。是深般若波罗蜜中义。以非义皆不可得。云何菩萨于般若波罗蜜当习诸义。佛言。菩萨深义者般若波罗蜜是当作是行。菩萨于淫怒痴有耗故。不当行邪见之义。亦不当行于六十二见。知其无义亦不当行。所以者何。淫怒痴如于法亦无所益亦无所耗。诸见之义如亦无所益亦无所耗。言五阴有所益无所益亦不当行。乃至道言有所益无所益亦不当行。何以故。如来得阿耨多罗三耶三菩时。亦不见有所益无所益。有佛无佛诸法湛然。亦无所益亦无所耗。须菩提。菩萨当除有益无益。当作是行般若波罗蜜。世尊。云何般若波罗蜜亦无所益亦无所损。佛言。诸有为法常闲亦无所作。是故般若波罗蜜亦无所益亦无所损。世尊。诸有为义。非是诸佛及佛弟子耶。佛言诸有为法皆是诸佛及佛弟子也。亦不以益亦不以耗。譬如虚空如不为所作兴亦不为无所作兴。般若波罗蜜亦如是。亦不为有所益兴亦不为有所耗兴。须菩提白佛言。世尊。菩萨不从不有为。般若波罗蜜学成阿耨多罗三耶三菩耶。佛言如是菩萨从不有为。深般若波罗蜜学成阿耨多罗三耶三菩。不以二应。世尊。云何一法为逮一法耶。佛言不也。世尊。不一者为从二法耶。佛言不也。世尊。云何亦不从一亦不从二。云何有逮。佛言。逮无所得亦不以得。故逮故得

    摩诃般若波罗蜜种树品第七十一

尔时须菩提白佛言。世尊。般若波罗蜜为甚深无众生。而菩萨摩诃萨为众生谦苦求阿耨多罗三耶三菩。譬如士夫欲于空中种树。菩萨为众生故欲逮萨云若。佛言。如是如是。须菩提。欲为众生逮萨云若。以想为众生而度脱之。须菩提。譬如有人欲种树者。而不知树根亦不知茎节枝叶花实。取其栽而种之。随时溉灌而长养之稍稍茎节枝叶花实各各具足。便取枝叶茎节。其中用者各取用之。又取其果而食之。须菩提。菩萨用一切众生发阿耨多罗三耶三菩。次行六波罗蜜逮萨云若。枝节茎叶花实益于众生。以叶度三恶趣。以有花故便有四性。尊者及诸四天乃至无思想无思想慧天。实者如菩萨成阿耨多罗三耶三菩逮萨云然。便有须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。有菩萨便成阿耨多罗三耶三菩。益众生果。以是果处众生。于三乘虽成阿惟三佛。亦不见众生处。从想度众生。亦不见得众生。亦无有处可为成阿惟三佛者。须菩提。菩萨当作是学行般若波罗蜜。当作是念。须菩提白佛言。世尊。当知是菩萨亦如如来。所以者何。有菩萨来往故。便断于三恶趣。八难处皆断。诸贫穷下贱处皆断。三界处皆断。佛言。如是如是。须菩提。当知是菩萨如如来无有异。菩萨若厌懈怠者。终不逮过去当来今现在诸佛之道。世间亦无有声闻辟支佛也。三恶之趣三界无有断时。佛言。当知是菩萨如如来如汝所言。何以故。以如如知有如来知有辟支佛知有众贤圣。以如知有五阴知有有为无为性。是诸如亦是如。是故名曰如。菩萨学是如逮萨云若。从是中来。是故名曰如来。以如等故。当知是菩萨便为是佛。须菩提。菩萨当学般若波罗蜜如。学般若波罗蜜如已。当学一切诸法如。学诸法如已。当学具足一切法如。具足如已逮于诸如得自在。逮如自在已善于诸法根。善诸根已便见众生随行之趣。知诸趣已便具足慧愿。具足慧愿已便净三世慧。净三世慧已便行菩萨道。行菩萨道已便饶益众生。饶益众生已便净佛土。净佛土已便逮萨云若。逮萨云若已便转法轮。转法轮已安立众生于三乘法。立众生已于无余泥洹而般泥洹。须菩提。菩萨摩诃萨。自观诸善之德及他人德。当发阿耨多罗三耶三菩。须菩提白佛言。唯世尊。诸天阿须伦及世间人民。皆当为应行般若波罗蜜菩萨作礼。佛言。如是如是。诸天世人皆当为之作礼。世尊。初发意菩萨为众生故。发阿耨多罗三耶三菩。得几所福。佛言。若有善男子善女人。教三千大千刹土中众生。皆立于罗汉辟支佛道。于意云何。得福宁多不。须菩提言。世尊。甚多甚多。佛言。不如是菩萨为众生发阿耨多罗三耶三菩意。其福倍多百倍千倍巨亿万倍。佛言。复置是三千大千刹土。若复有人教三千大千刹土中众生。令立黠地信地八地见地薄地净地已办地辟支佛地。其福不如发意菩萨为众生发阿耨多罗三耶三菩。其福甚多。百倍千倍巨亿万倍。须菩提。三千大千刹土中众生皆初发意。其福不如以正定菩萨功德。出彼上百千亿万倍。复令三千大千刹土满中成就菩萨。其福不如如来百千巨亿万倍。须菩提白佛言。新发意菩萨当念何等。佛言。当念萨云若。世尊。萨云若者。为何等务为何等尊相像。佛言。萨云若者无所有亦无有想。亦无无想。亦不生亦不现。须菩提言。世尊。但萨云若无所有。五阴内外空及有无空。四禅四等四无形禅。三十七品及三三昧。八惟无九次第十种力四无所畏。大慈大悲四无碍慧。佛十八法及六神通。诸有为无为性。复无所有耶。佛告须菩提。萨云若者自无所有。自无所有者空。世尊。何以故无所有。佛言。无所作者为无所有。以是故诸法所有无所有皆空。又须菩提。诸法空无相无愿。诸法如如诸法如真际诸法如法性。是故诸法所有皆无所有皆空。世尊。若诸法所有皆无所有者。何等是初发意菩萨沤和拘舍罗。行六波罗蜜行四禅四等四无形禅。行三十七品行内外空及有无空。行十八法行萨云若。净佛国土教化众生佛言。于诸空法有所作者。则是其沤和拘舍罗。能净佛土教化众生。知佛国土及众生所有皆无所有。菩萨行六波罗蜜为佛道作因缘。乃至萨云若亦为佛道作因缘。知道事所有皆无所有。菩萨行六波罗蜜与道场作因缘。至佛十力四无所畏四无碍慧四等佛十八法。为萨云若慧具足道事。一时一意。以智慧一时合。应便逮萨云若。尔时所作诸习之绪悉灭已。无所从生故。持佛眼观三千大千刹土。尚不见无所有。何况所有。须菩提。如是菩萨行般若波罗蜜。于诸法不见所有亦不见无所有。是为菩萨摩诃萨沤和。拘舍罗。尚不见无所有何况所有。又复菩萨行檀波罗蜜。布施无所有亦不知。受者无所有亦不知。道意无所有亦不知。乃至萨云若无所有亦不知。逮觉者当逮觉者已逮觉者无所有亦不知。何以故。一切诸法无所有非佛所作非弟子辟支佛所作。诸法无所作离诸所作故。须菩提言。世尊。将无法离法。佛言。虽言法为离法。须菩提言。世尊。若法法相离。云何知法离法。诸法所有无所有。无所有法不知无所有。有法亦不知有法。有法不知无所有法。无所有法不知有法。菩萨于无所知法。云何当知所有无所有法。佛言。菩萨以世事习故。现有所有现无所有。非第一最要义。须菩提白佛言。世尊。世事及最要义为有异耶。佛言。无有异。世事如最要义如。众生不知是如。以是故现世事有所有无所有。又须菩提。众生于五阴有相不知无所有。以是故作是分别说法。欲使众生知无所有。菩萨欲行般若波罗蜜者当作是学

    摩诃般若波罗蜜菩萨行品第七十二

于是须菩提白佛言。唯世尊。菩萨行菩萨行者为何事。佛告须菩提。菩萨行者道行也。是故名为菩萨行。须菩提言世尊。菩萨行者为在何处行。佛言。于五阴行空。于内外法于六波罗蜜行。于内外空及有无空作四禅行。于四无形禅行于四等行。于三十七品行。于三三昧行。于佛十力行。于四无所畏行。于四无碍行。于十八法行。净佛国土行。教化众生行。入于文字行。不入文字行。于陀邻尼行。于有为无为性行。作行不令道有二。是则为道行。是则为菩萨摩诃萨空行。须菩提白佛言。世尊。云何为佛。佛言。以道觉故言佛。又须菩提。逮审谛法。法觉故言佛。超越审谛法故。故名为佛。又须菩提。真觉诸法故名为佛。须菩提言。世尊觉者为何谓。佛言以空法觉以如觉以法觉。但以字为名。须菩提。觉之义是不可断义。如及尔一住无有变易。是故名为觉。又须菩提。但以名相故名为佛。诸佛如来之道故。是故名觉。诸佛世尊皆共觉故。故名为觉。须菩提言。世尊。菩萨行道为行六波罗蜜不。为行萨云若不。为成何等善增益何功德。有生有灭有著有断耶。佛言。菩萨行道行六波罗蜜至萨云若者。于诸法亦无所成亦无所败。亦无所增亦无所减。亦无所著亦无所断。佛言。菩萨行般若波罗蜜道者。不于诸法有所堕。于诸法亦不有所成败。有增有减。亦不生亦不灭。亦不着亦不断。须菩提言。世尊。若菩萨于诸法无所堕无所观。云何受持六波罗蜜。而自于相行空。云何行四禅。云何行四等四空定。云何行三十七品及三脱门。云何行十种力佛十八法。云何行大慈大悲。云何行菩萨十住。云何过二地。云何过于菩萨位。佛告须菩提。菩萨不以二事行六波罗蜜。亦不以二事行萨云若。须菩提言。世尊。若菩萨不以二事行六波罗蜜。行萨云若者。云何从初发意至后发意。云何得增益功德。佛言。诸有以二行者。是辈无所增益。何以故。二事行者。于凡愚人有所增益。菩萨从初发意至后发意。不以二事增益功德。以是故诸天及人不能坏菩萨令堕二地。其余众恶不能制菩萨令不行六波罗蜜及萨云若须菩提言世尊。菩萨为功德故行般若波罗蜜耶。佛言。亦不以功德故行。亦不以无功德故行般若波罗蜜。菩萨要当供养诸佛。要当具足诸善功德。要当与真知识相得。尔乃得成阿耨多罗三耶三菩。世尊云何菩萨供养诸佛具足功德得真知识乃逮萨云若。佛言。菩萨从初发菩萨意常供养诸佛。诸佛所说十二部经常当受持。坚持守念便得陀邻尼起诸无碍。起无碍已在所生处至萨云若。终不忘失所知所持所可供养诸佛功德。终不生恶趣八不闲之处。便受净意。已得净意已净佛土教化众生。以是功德终不离真知识。终不离诸佛诸菩萨诸真人及赞叹佛者。如是须菩提。菩萨摩诃萨。欲行般若波罗蜜。当供养诸佛当具足诸法受诸功德。当与真知识相随

    摩诃般若波罗蜜当得真知识品第七十三

于是须菩提白佛言。世尊。若有菩萨摩诃萨。不供养诸佛。不具足诸功德不遇真知识。将无不能逮萨云若。佛告须菩提。菩萨摩诃萨无不供养诸如来者。无不具足诸功德者。无不得真知识者。何以故。虽供养诸佛。虽作功德。虽得真知识。尚未逮萨云若。何况不供养佛。不作功德。不得真知识。而欲逮得萨云若。是事不然。是故须菩提。菩萨摩诃萨欲学般若波罗蜜者。当供养佛。当作功德当得真知识。须菩提言。世尊。菩萨何以故当供养佛作诸功德得真知识乃逮萨云若。佛言。以无有沤和拘舍罗故。不从诸佛闻沤和拘舍罗事。功德未具足未逮真知识故。世尊。菩萨当具足何等沤和拘舍罗。乃当逮得萨云若。佛言。菩萨从初发意已来。持萨云若意行檀波罗蜜。施于三乘亦施人及非人。皆具足萨云若念。亦无施想亦无受者想。亦无行檀波罗蜜想。何以故。诸想法者。亦无所有亦无所生亦无所灭。观见诸法亦无转还者。皆度诸法之相。不见诸法有所作。以具足沤和拘舍罗者便增益诸功德。已增益功德者便行檀波罗蜜。教化众生净佛国土。亦不自受其报。但欲益于众生所作不受其报。行檀波罗蜜但欲度脱一切众生

放光般若波罗蜜经卷第十六放光般若经卷第十七

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜教化众生品第七十四

复次须菩提。菩萨摩诃萨以萨云然念。从初发意不离萨云若念。行尸波罗蜜意初不堕淫怒痴。亦不念淫怒痴。亦不为所缠裹。诸不入道捡事。嫉妒恶戒恚意懈怠乱意愚痴项佷。自用着于吾我。及二地意悉无。何以故。皆知诸法相空皆知诸法无所有无所成。观见诸法皆无转还。皆解诸法相度诸世事。处于无为具足沤和拘舍罗增益功德。为行尸波罗蜜教化众生净佛国土。亦不于世受尸波罗蜜之报。至般若波罗蜜。但欲益于一切教化众生。复次须菩提。菩萨行四禅四等四无形禅。虽行诸禅不受禅福。何以故。以沤和拘舍罗。知诸禅相皆空。亦知动还者。复次须菩提。菩萨行般若波罗蜜。从初发意行沤和拘舍罗。行观行净亦不趣须陀洹。不取须陀洹果。至阿罗汉亦不取其果。何以故。知诸法相空及知不转还法。亦行三十七品过于二地。须菩提。是为菩萨摩诃萨无所从生法忍。菩萨行般若波罗蜜。行八惟无禅及九次第。亦不取须陀洹道。何以故。悉知诸法相空知不动还。复次须菩提菩萨行佛十力业及四无所畏四无碍慧佛十八法大慈大悲。净佛国土教化众生。然后乃逮萨云若。菩萨当作是行般若波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨其智甚广大乃行是深法。然不受其报。佛言。如是如是。须菩提。所以者何。菩萨于所有处不动不转。世尊。何等为于所有处不动不转。佛言。于无所有而不动转。于五阴所有不转。于六波罗蜜所有不动。于诸禅四等所有不转。于三十七品所有不转。于三脱门所有不转。于大慈大悲所有不转。于十力十八法所有不转。所以者何。是诸法所有皆无所有故。须菩提。不可以无所有逮觉所有须菩提言。世尊。宁可持所有逮觉所有不。佛言不也。须菩提言。世尊。宁可持无所有逮觉无所有不。佛言不也。如是世尊。将无所逮无所觉耶。佛言。有逮觉不以是四句。世尊。是逮觉当云何。佛言。诸逮觉者亦非所有亦非无所有。逮觉者亦非戏言亦非不戏言。须菩提言。世尊。何等是菩萨戏言。佛言。言五阴有常无常是菩萨戏言。五阴苦乐者是菩萨戏言。五阴是我所非我所是菩萨戏言。五阴净不净者是菩萨戏言。分别知五阴者是菩萨戏言。知四谛者是菩萨戏言。念四禅四等及四无形禅三十七品总三脱门八惟无九次第禅是菩萨戏言。我得须陀洹道至阿罗汉辟支佛道是菩萨戏言。我具足菩萨十住是菩萨戏言。我净佛国土教化众生是菩萨戏言。我具十力四无所畏四无碍慧佛十八法是菩萨戏言。我逮萨云若是菩萨戏言。我尽诸习绪是菩萨戏言。菩萨行般若波罗蜜。五阴有常无常。亦不戏亦不不戏。乃至萨云若有常无常。亦不戏亦不不戏。所以者何。于所有亦不戏所有。于无所有亦不戏无所有。于所有无所有中亦不戏无不戏。是故须菩提。五阴及萨云若为非戏也。菩萨于般若波罗蜜行亦不以戏。须菩提言。云何五阴不戏乃至萨云若不戏。佛告须菩提。五阴无所有乃至萨云若亦无所有。诸可无所有者皆非戏。以是故五阴及萨云若皆无有戏。须菩提。菩萨作是学般若波罗蜜者。得上菩萨位。须菩提言。世尊。诸法所有尚不可得。云何得菩萨位。为用二地为用佛道乎。持何等得位。佛言。菩萨亦不以二道亦不以佛道也。遍学诸道乃上菩萨位。如第八贤圣遍学诸道。虽在乎地未受果证。菩萨亦如是。皆行诸道得菩萨位。未及萨云若。未得金刚三昧。得功德时乃具足逮萨云若。须菩提言。世尊。若菩萨遍学诸道尔乃上位者。菩萨为复在第八地取须陀洹道耶。在斯陀含地得斯陀含道。在阿那含地得阿那含道。在阿罗汉地得阿罗汉道。在辟支佛地得辟支佛道。在佛地得佛道耶。此诸道各自异。世尊。云何菩萨皆当遍学诸道上菩萨位耶。若菩萨于是八地受八道者。是终不然。在菩萨位便逮萨云然者亦复不然。若菩萨得声闻辟支佛道至萨云然者。亦复不然。世尊。我当云何知菩萨遍入诸道上菩萨位。佛告须菩提。如汝所言。菩萨终不于八地得须陀洹及罗汉辟支佛道以逮萨云若。须菩提。菩萨从初发意常行六波罗蜜。以慧见八地。何等八。净地性地四贤圣八地观地薄地无垢地已办地辟支佛地。以慧观过于八地。以道慧过菩萨位。过位已以萨云若慧舍诸习绪。须菩提。第八地者是菩萨之忍。须陀洹斯陀含阿那含慧及习绪除。亦是罗汉慧观。亦是菩萨辟支佛慧。亦是菩萨忍。具足声闻辟支佛道。以道慧上菩萨位。以萨云若慧除诸习绪。以是故须菩提。菩萨当遍具足诸道。尔乃成阿耨多罗三耶三菩阿惟三佛。成阿惟三佛已为众生作道地。须菩提白佛言。世尊。所说三乘声闻辟支佛佛道。何等为道慧之道。佛言。当起诸道净于诸道遍观众生。及相貌像尽觉尽知。皆遍知已当教一切分流广化。遍采音声令得大声。遍三千大千刹土当如响相。以是故菩萨当遍具足诸道。当知道慧悉知众生之意。亦当知泥犁复知泥犁之趣。亦当知众生罪报。当断泥犁缘作罪之报。薜荔畜生亦当知之。薜荔畜生缘作报应悉当断之。当知真陀罗摩睺勒诸龙阅叉。当知人之因缘。人道果报。亦当知天从四天王上至三十三天。亦当知天人因缘天人果报。当知三十七品法三脱门法。亦当知十力。亦当知四禅四等及四空定大慈大悲佛十八法。尽知是已。立诸众生于三乘之道。须菩提。是为菩萨具足道慧。菩萨学是已皆知众生意之所愿。已知所愿如应说法初不断绝。所以者何。普知众生根生死之趣。菩萨当作是行般若波罗蜜。菩萨所可应行法。三十七品所行二地所行。尽入般若波罗蜜中故。须菩提白佛言。世尊。诸法及三十七品及道法。是诸法亦不合亦不散。亦无有形亦不见见一相。一相者则无相。云何能致道。是法亦不见亦无有形一相。一相者则无相。云何能致道。世尊。譬如虚空亦无所没亦无所致。佛言。如是如是。须菩提。是空法亦无所致亦无所趣。以众生不知法相无所有故。佛为说三十七品。及诸法有所致有所办。虽尔须菩提。所有五阴六波罗蜜内空外空及有无空。三十七品四禅四等及四空定。四无碍慧四无所畏。佛十力十八不共大慈大悲。至萨云若。于贤圣法律亦不合亦不散。亦无有形亦不可见。亦无有对一相无相。如来以是故欲度脱众生。以世俗因缘而说是教。非第一最义。是故菩萨当遍学诸道。以慧观随习俗。于法中有应用者不应用者。何等是菩萨应用何等是菩萨所不应用。罗汉辟支佛道以慧观学而所不用。以萨云若慧当用诸法。菩萨如是于贤圣法律。当学般若波罗蜜。须菩提白佛言。世尊。所说贤圣律。贤圣律者为何谓。佛告须菩提。声闻辟支佛菩萨摩诃萨如来无所著等正觉。亦不与淫怒痴合亦不不合。是我所非我所亦不合亦不散。亦不狐疑亦不不狐疑。于戒行亦不合亦不散。于欲于色于无色界亦不合亦不散。于不黠及顽佷亦不合非不合。凶暴亦不合非不合。于四禅四等及四空定三十七品大慈大悲及有为无为性。亦不合亦不散。何以故。以诸法无有形不可见。无有对一相无相。无色不与无色合亦不散。不可见不与不可见合亦不散。无有对不与无对合亦不散。一相不与一相合亦不散。无相不与无相合亦不散。须菩提。是名为贤圣律。亦无形不可得见。亦无对一相无相。是菩萨无相度。菩萨当作是学。作是学已当得诸法无相。须菩提白佛言。世尊。为不学色声香味细滑识法相耶。不学地水火风空识相耶。不学六波罗蜜相耶。不学有无空相耶。不学四禅四等及四空定三十七品三脱门相十力四无所畏四无碍慧佛十八法大慈大悲四谛相贤圣相。不学逆顺十二因缘相耶。不学有为无为性相耶。于是诸法无相亦不学。所作相亦不学。菩萨当云何过于二地上菩萨位。上菩萨位已云何逮萨云若。逮萨云若已云何转法轮。转法轮已云何以三乘法度脱众生。佛告须菩提。若诸法有相者。菩萨当学诸法相。诸法无形亦不可见。亦无有对一相。一相者则无相。是故菩萨亦不学相亦不学无相。云何作是问。佛言。若前有相后便有相。以前法无相故后亦无相。是故菩萨亦不学相亦不学无相。所以者何。有佛无佛一相性常住如故。须菩提白佛言。世尊。若诸法非相非无相云何。为念般若波罗蜜。菩萨若不念般若波罗蜜者。不能过于二地。不过二地者不能过菩萨位。不能过菩萨位者不得无所从生。不得无所从生者不得菩萨神通。不得神通者不能净佛土教化众生。不净佛土教化众生者。不能逮萨云若。未逮萨云若者。不能转法轮。不能转法轮者不能安立众生于三乘法。亦不能安立众生于三福地。一者施。二者戒。三者念诸善法。佛言。如是如是。须菩提。诸法亦非无相亦非一相。无相之法当云何念般若波罗蜜。须菩提。般若波罗蜜者非菩萨之念。菩萨以无念是为般若波罗蜜相。须菩提言。世尊。云何无念是般若波罗蜜相。佛言。于诸法无所念。是为般若波罗蜜相。云何于诸法无所念。佛言。不念五阴六情。是为般若波罗蜜念。不念色声香味细滑识法。是般若波罗蜜念。不念不净。是般若波罗蜜念。不念四禅四等及四空定。是般若波罗蜜念。不念三尊不念三福。是般若波罗蜜念。不念灭尽不念安般守意。是般若波罗蜜念。不念无常相苦相非我相。不念四颠倒十二因缘。不念吾我寿命及知见相。是般若波罗蜜念。不念三脱门。不念三十七品法。是般若波罗蜜念。不念八惟无九次第禅。不念四禅。是般若波罗蜜念。不念十慧不念六波罗蜜。不念内外空及有无空。是般若波罗蜜念。不念十力不念四无所畏四无碍慧佛十八法。不念大慈大悲。是般若波罗蜜念。不念须陀洹及罗汉辟支佛。是般若波罗蜜念。不念萨云若是般若波罗蜜念。不念断诸习绪。是般若波罗蜜念。须菩提白佛言。世尊。云何不念五阴。乃至断诸习绪复不念。是般若波罗蜜念。佛言。菩萨行般若波罗蜜亦不念五阴无所有。何以故。须菩提。诸有相者无有般若波罗蜜念。不念淫怒痴所有。不念无道之处所有。何以故。诸有想者为无般若波罗蜜念。诸有相者为无六波罗蜜。何以故。诸有贪者亦无有六波罗蜜。是名为着诸有。缚著者无有度脱。须菩提。著有者。无有三十七道品念。亦无三脱门念。乃至萨云若亦无念。何以故。缚着于有故。须菩提白佛言。何等为有何等为无有。佛言。有二者为有。世尊。何等为二。佛言。五阴相者为二。十二衰相者为二。有佛相者为二。有道相有为无为相者是则为二。须菩提。一切相乃至无有相是皆为二。适有二便有已有便有世间众生。不得离生老病死忧悲勤苦。以是故须菩提。当知有二者无有六波罗蜜。亦无有道亦无所逮亦无所觉。何况能舍五阴及萨云若者。佛告须菩提。尚无道念那得须陀洹至罗汉辟支佛道。那得离诸习绪

    摩诃般若波罗蜜无坚要品第七十五

尔时须菩提白佛言。世尊。假令有相者不得顺忍不得逮觉。若无相者当得顺忍不。当及声闻八地不。当及辟支佛地不。当及菩萨地不。可得度脱不。能得道念不。能令罗汉辟支佛习绪除不。能使菩萨得上菩萨位不。上菩萨位已能得萨云若不。得萨云若已能灭诸习绪不。世尊。若无意若不生意不起是法相。可逮萨云若不。佛告须菩提。如是如是。无有相者亦无有顺忍。亦不能除诸习绪。复问世尊。菩萨行般若波罗蜜有相意耶。于五阴有相耶。乃至萨云若有相耶。有淫怒痴相无有淫怒痴相耶。有六衰有六衰尽相耶。有近有近尽相耶。有觉有觉尽相耶。有爱有爱尽相耶。有受有受尽相耶。有有有有尽相耶。有生有生尽相耶。有死有死尽相耶。有忧悲勤苦有忧悲勤苦尽相耶。有苦有苦尽相耶。有四谛有四谛尽相耶。有萨云若有萨云若尽相耶。有习绪有习绪尽相耶。佛言不也。须菩提。菩萨行般若波罗蜜。亦无有相亦无无相。须菩提。菩萨顺忍者则无相。是菩萨无有相则为念道。无有有相无有无相。则是菩萨之果报。佛言。有相则是菩萨道。无相则逮觉。是故须菩提。当知诸法所有皆无所有。须菩提白佛言。世尊。若无所有云何于无所有中得逮觉。而于诸法得自在。佛告须菩提。我本为菩萨行六波罗蜜。从第一禅至第四禅。观禅性不念贡高。亦不倚禅亦不味禅。于四禅事寂净无所悕望。已安足于禅便处于神通。天眼彻视天耳彻听。意知他人宿命所从来。自识宿命便飞行。虽尔不以是神通贡高。不味不倚于六通无所分别。须菩提。我以应一合相智。成阿耨多罗三耶三菩。便觉四谛。具足如来十力四无所畏四无碍慧佛十八法。处众生于三乘。须菩提白佛言。世尊。如来云何于无所有中起四禅。六通无所有。众生为无所有。如来云何安立众生于三乘。佛告须菩提。若淫怒痴及余诸非法之事。若有所有无所有者。我为菩萨时不于有无中起四禅。是故须菩提。亦不有所有亦不无所有。是故我初发意行菩萨道时行四禅。佛告须菩提。若神通中当有所有无所有者。我终不于神通中觉所有无所有而成阿耨多罗三耶三菩。以于神通知所有无所有故。成阿耨多罗三耶三菩。须菩提白佛言。若菩萨于诸法所有无所有。于禅五通成阿耨多罗三耶三菩。云何菩萨于无所有法中。未曾所知能知未曾所学得学。从是中成阿耨多罗三耶三菩。佛告须菩提。菩萨已从过去诸佛所。供养若干佛菩萨。所从诸佛闻。无所有中无有佛无有辟支佛。无所有中无有罗汉。无所有中无有众贤圣。从无所有中无有毛发许所有。菩萨作是念言。无所有中亦无有须陀洹乃至佛皆无所有。以诸法无所有故。我或成阿耨多罗三耶三菩。我或不成阿耨多罗三耶三菩。假令我当成阿耨多罗三耶三菩者。诸可有行相众生我当立着无相地。须菩提。诸有菩萨成阿耨多罗三耶三菩者。欲度脱众生故。便习未曾习者。未曾学者未曾受者便学便受。于诸过去诸佛所学。先学六波罗蜜劝人令行六波罗蜜。见人行者代其欢喜。以布施无贪垢故便得大富。以布施故便守戒便得天上人中尊。以布施故便得三昧。以布施持戒忍辱精进禅故。便得智慧品解脱品见解脱慧品。持是诸品及六波罗蜜。得过二地上菩萨位。已上位已便净佛土化众生。便逮萨云若转法轮。以三乘度众生。须菩提。菩萨以是先当从檀波罗蜜起。次得诸慧是亦不可得。何以故。无有实故。复次须菩提。菩萨从初发意以来自持戒劝人持戒。见人持戒代其欢喜。以持戒得天上人中之豪。贫者以财施之。复以戒三昧智慧解脱见解脱慧而立之。以五品之德过出二地上菩萨位。度脱众生。便逮未曾所知所学所习。皆学知习之。何以故。欲习无所有故。复次须菩提。菩萨行忍劝人使行。见人行忍代其欢喜。饱足众生以财安立。或以五品之德过于二地上菩萨位。何以故。所施与亦无有要故。复次须菩提。菩萨自行精进于善劝人精进。见人精进代其欢喜。复以财物给足众生。以戒忍辱五品之德。过出二地上菩萨位。何以故。所施亦无有要故。复次须菩提。菩萨行四禅四等四无形定劝人令行。见人行者代其欢喜。以位于禅布施穷乏。教令智慧解脱见慧过出二地上菩萨位。何以故。所有者无有要故。复次须菩提。菩萨从发意以来。行般若波罗蜜以财给足众生。立以于戒三昧智慧解脱见慧。自行六度劝人令行。见人行者代其欢喜。以沤和拘舍罗过于二地上菩萨位。成阿耨多罗三耶三菩。何以故。无有形故须菩提。菩萨从是便得本所不学本所不知本所不应。皆学皆知皆得所应。复次须菩提。菩萨学诸未曾学者。从初发意以来。常有萨云若念解诸有无之事。便念三尊行。常念天行戒念施念。佛问须菩提。云何为念佛。念佛者不以色痛想行识念。何以故。五阴无有坚要故。无坚要者为无所有。佛念者为无念。复次须菩提。如来无所著等正觉。不当以三十二相八十种好念。不当以金色光明念。何以故。佛形无有坚要故。无坚要者为无所有。念佛者为无念。复次须菩提。如来无所著等正觉。不当戒性智慧品三昧品解脱品见解脱品。不当以是五品念如来。何以故。以是无有坚实故。无有坚者为无所有。念佛者为无念。复次须菩提。念如来不以十力念。不以四无所畏念四等大慈大悲佛十八法四无碍慧。不以是念如来。何以故。无有坚实故。不坚实者无所有。念佛者为无念。复次须菩提。念如来者不以十二因缘念。何以故。无有坚要。无坚要者为无所有。念佛者为无念。须菩提。菩萨行般若波罗蜜者。当作佛念。以是故。知次第学未曾学者习未曾应者具足悉应顺。至诸道应作是学。具足三十七品及三三昧。便具足萨云若慧。便应所有无所有。觉不坚固要。便得所有无所有处。须菩提。云何为法念。菩萨行般若波罗蜜。亦不当念善恶法。亦不念当受莂不受莂。亦不当念俗法道法。亦不念有漏无漏法。亦不念贤法愚法。亦不念三界法。亦不念有为无为性法。何以故。诸法无有坚要无有坚要者为无所有。念法为无所念。学法念以应所有无所有。便逮萨云若。便逮所有无所有处。须菩提。菩萨当念法念。须菩提。菩萨当云何念僧。菩萨从初发意至萨云若。常念僧为无念。如是须菩提。菩萨当作僧念。须菩提。菩萨云何念戒。行般若波罗蜜。从初发意以来不缺于戒。不差于戒。善摄于戒当念有无。如是念者为顺所应。便逮萨云若无有有无之处。须菩提。云何菩萨念施。所有无所有应施。所可物施及以法施。于中不起乱意。亦不念有所施无所施。虽持身命支节布施。于中。亦不起乱意。何以故。无有坚要故无坚要者则无所有。常念于施至成阿耨多罗三耶三菩。须菩提。菩萨云何当作天念。诸须陀洹。生四天上者至于六天。诸生天者无有坚要无坚要者为无所有。须菩提。当顺是念至成萨云若。须菩提。诸阿那含生于色天及无色天亦无坚要。无坚要者为无所有。菩萨当顺是念至成阿耨多罗三耶三菩。须菩提。菩萨常念六念顺其所应。复次须菩提。菩萨行般若波罗蜜。欲学所顺所习欲成诸功德。当学内外空及有无空。当学三十七品大慈大悲。当学菩萨道行。皆逮有无之要尚无毛发之相。何况有萨云若相。须菩提。是为菩萨行般若波罗蜜得随次第应。须菩提白佛言。世尊。若诸法所有皆无所有。乃至五阴六衰无所有诸性无所有三十七品无所有萨云若慧亦当无所有。亦无佛无法无比丘僧。亦无有道亦无果报。亦无著断亦无逮觉。诸法亦皆无所有。佛告须菩提。诸法有所有无所有可得见不。须菩提言。不可得世尊。须菩提。云何言诸法所有皆无所有五阴及逮觉耶。须菩提白佛言。世尊。我于是法无有狐疑。但为当来之世三乘道家。恐或言若诸法所有无所有。何谁著者何谁断者。不知着断之事。便能败戒毁戒不知所趣如是败戒行者各各趣三恶处。世尊。我不敢有狐疑。我畏当来之世。是故问如来耳

    摩诃般若波罗蜜无倚相品第七十六

于时须菩提白佛言。世尊。菩萨摩诃萨若诸所有者皆无所有。菩萨为见何等。为众生发阿耨多罗三耶三菩。佛告须菩提。菩萨以所有皆无所有故。能发阿耨多罗三耶三菩。何以故。诸有倚著者难得解脱。有倚相者不得逮觉。亦不能成阿耨多罗三耶三菩。须菩提白佛言。世尊。无倚相者为有逮觉成阿耨多罗三耶三菩耶。佛言。逮觉已阿耨多罗三耶三菩则是无所倚。以不别法性故。欲得无所倚逮觉阿耨多罗三耶三菩者。则为欲示一切法性。世尊。若无所倚者无有逮觉则无有阿耨多罗三耶三菩。何缘菩萨从第一住至十住耶。何因缘得无所从生法忍。何因有五通及六波罗蜜之德。而受诸法之德。摄取佛国教化众生供养诸佛。一切有至般泥洹。佛言。无所倚者与五通之报等。与十住等。与六波罗蜜等。及供养诸佛功德等。以是故至般泥洹供养不断。须菩提言。世尊。无所倚及五通六波罗蜜有何差别。佛言。无有差别说有差别。世尊。云何三事有差别。佛言。菩萨行般若波罗蜜亦不倚所施。亦不自倚亦不倚受者。至般若波罗蜜亦无所倚。行神通亦无所倚。行三十七品亦无所倚。行三三昧亦无所倚。教化众生净佛国土亦无所倚。逮觉诸佛法亦无所倚。须菩提。是为菩萨行般若波罗蜜为无所倚。菩萨摩诃萨如是行者。诸魔魔天无能坏者。须菩提言。世尊。云何菩萨行般若波罗蜜。一意受持六波罗蜜。受四禅四等大慈大悲。及四空定四无碍慧。四无所畏三十七品。总三脱门。佛十种力佛十八法。云何受持八十种好。佛言。菩萨行般若波罗蜜。所作施戒忍辱精进及诸禅事。皆以般若波罗蜜行。及三脱门四等大慈及三十七品。所作所念皆不离般若波罗蜜。及三三昧佛十种力。四无所畏四无碍慧。佛十八法八十种好。皆不离般若波罗蜜。须菩提言。世尊。云何菩萨一意行般若波罗蜜受持六波罗蜜。乃至八十种好。须菩提。菩萨行般若波罗蜜。行六波罗蜜初无二相。乃至八十种好亦无二相。世尊。云何行六波罗蜜至八十种好。不以二相。佛言。菩萨行般若波罗蜜。皆悉具足总持诸波罗蜜及三十七品而行布施。须菩提言。世尊。是事云何。佛言。菩萨行般若波罗蜜时。不以漏意行檀波罗蜜。于无漏作念言。我为是谁所施何物受者为谁。于是三事无相受念。尔时亦不见意及所施受者。至十八法亦复如是。复次须菩提。菩萨行般若波罗蜜。乃至般若波罗蜜亦无有相亦不见六波罗蜜。菩萨行般若波罗蜜乃至八十种好亦无有相亦无所见。须菩提言。世尊。以无相无所作法。云何得具足六波罗蜜云何具足三十七品云何具足三空及十种力。云何具足四无所畏佛十八法。佛言。菩萨行般若波罗蜜以无相施随众生所欲。或索肌肉妻子国城珍宝。所有财谷皆不逆人。作是施时或有人来问菩萨言。用是无相布施为作虽有是言我续。布施不可断绝。持是布施与众生共为阿耨多罗三耶三菩。亦无相念亦无施意亦无物意亦无受者意。亦不见阿耨多罗三耶三菩意。何以故。所见一切皆悉空故。如是谁为阿耨多罗三耶三菩者。如是作为则是真作。则能净佛国土教化众生。则为行六波罗蜜。则为具足三十七品及三脱门。则为具足佛十八法。如是行者则为不受布施之报譬如第六天王有所欲者但念即至。菩萨如是。但意念诸法皆具足至。以布施之德能供养诸佛悉能饱满诸天及人。以沤和拘舍罗行檀波罗蜜。安立众生于三乘法是为菩萨行般若波罗蜜具足檀波罗蜜

须菩提言。世尊。云何菩萨行般若波罗蜜具足尸波罗蜜佛言。菩萨悉知贤圣无漏道法之戒。不毁不乱奉贤圣戒。于诸法无所[打-丁+此]亦不[打-丁+此]五阴。亦不[打-丁+此]三十二相亦不[打-丁+此]四性。亦不[打-丁+此]四天王至三十三天。不[打-丁+此]须陀洹至罗汉辟支佛。亦不[打-丁+此]转轮圣王。所作功德但欲与众生共为萨云若。不相不倚亦不以二。但为世事非最要义具足戒已以沤和拘舍罗起四禅。不以贪受天眼。以天眼观十方诸佛。至成阿耨多罗三耶三菩初不离天眼。以天耳净尽闻诸佛所说经法不失所闻。至得自辩悉知诸佛之意。知诸佛意已便能饶益一切众生。持识宿命之慧。觉诸所作不失本行。以无漏之法立众生于三乘。随众生所欲而悉授之。须菩提。是为无相具足尸波罗蜜。佛言。菩萨云何具足于忍。从发意至坐道场。若众生来以刀杖捶加于菩萨。菩萨终不起意当起二忍。一者忍辱二者无所从生法忍。起意念言。以刀捶杖加我者为谁。受者为谁。当观法相。观法相者亦无所有亦无所观。无所观者便得无所从生法忍。住二忍已便具足四禅四等及四空定。便具足三十七品及三脱门。便具足十力四无所畏四无碍慧。菩萨已住是法便得神通。非是二地所能及者。具足神通已便具足六波罗蜜。以天眼慧见十方佛。至阿耨多罗三耶三菩不忘佛念。复以天耳慧闻十方佛所说教法悉知诸佛。诸佛所念悉复逮。知众生之意如应说法。自知宿命以慧皆识众生功德。持诸善本功德劝勉众生。以漏尽之慧立众生于三乘。菩萨摩诃萨行般若波罗蜜。以沤和拘舍罗行。教化众生净佛国土。具足萨云若慧逮得阿耨多罗三耶三菩转于法轮。是为菩萨行般若波罗蜜具足羼波罗蜜。佛言。云何菩萨行般若波罗蜜具足惟逮波罗蜜。须菩提。菩萨行般若波罗蜜。身意精进具足四禅。于四禅起便得无数神通。变化来往手扪摸日月。持是精进遍至十方无数刹土。供养诸佛一切所有供养之具。至阿耨多罗三耶三菩。诸天世人皆当恭敬。是菩萨至般泥洹。以神足到十方听受诸佛法言。所闻法至成阿耨多罗三耶三菩终不忘净佛国土教化众生。具足萨云若。是为行般若波罗蜜具足惟逮波罗蜜。复次须菩提。以无漏道法。具足意精进。口不言恶。身不行恶。意不念恶。亦不[打-丁+此]苦乐有常无常。不[打-丁+此]有我无我。不[打-丁+此]有为无为。不[打-丁+此]三界。不[打-丁+此]四禅及四空定四等三脱门三十七品。至十八法亦无所[打-丁+此]。亦不[打-丁+此]声闻辟支佛。不[打-丁+此]声闻辟支佛道。亦不[打-丁+此]菩萨。亦不[打-丁+此]菩萨地。亦不[打-丁+此]五趣。亦不分别是天是人是畜生是泥犁是薜荔。亦不分别是须陀洹道是罗汉道是辟支佛道。亦不分别。是菩萨道。亦不分别是萨云若。亦不[打-丁+此]诸法诸道亦不分别。所以者何。是诸法者。皆无有要无可[打-丁+此]者亦无可分别者。以具足意精进。便救一切魔怨众生。救众生已亦不见众生。具足精进已亦不见精进。具足佛法已亦不见佛法。净佛国土亦不见不得。具足精进便受诸善法。亦不于是善法中生念。遍游诸国救益众生。所作变化自恣无碍。或雨诸华或散诸香。或以伎乐鼓乐弦歌事。或震动事或以光明。或以国土七宝示现或以搏弈。或现水火随道而入。尽为因缘使行十善。或以施戒而摄取之。或以支解身体妻子国土。或以自身随众生意而摄取之。须菩提。菩萨以沤和拘舍罗无相。行惟逮波罗蜜。佛言。菩萨行般若波罗蜜住于无相之法行禅。菩萨行般若波罗蜜除如来三昧。一切余三昧皆当具足。具足四禅具足四等及四空定。皆当逆顺行八惟无及九次第禅。行空无相无愿三昧电光三昧金刚三昧直治三昧。住是禅波罗蜜便得三十七品。住于三昧具足道慧。诸三昧门皆来入是。具足道慧具足十住地作行。至萨云若终不中道取证。于三昧中住游诸佛刹供养诸佛。于诸佛所殖诸德本。净佛国土游诸四域教化众生。广立众生于六波罗蜜。或立于须陀洹斯陀含阿那含阿罗汉辟支佛。随其所欲而满其愿。于是禅波罗蜜者。悉总持诸陀邻尼门。便得四无碍慧便受神通。终不堕女人胞胎。不受色欲无生不生。虽生不着于生。何以故。善观于幻法知所有如幻。救济众生便得无众生之相。以无所得法立众生于无所得法。以世俗数不以最上要。以禅波罗蜜遍入诸禅及解脱禅。不得阿耨多罗三耶三菩。终不舍禅波罗蜜。行道慧入萨云若慧。便尽习绪为以自救当复救余。救他人已为诸天及人及阿须伦而作福田。如是须菩提。菩萨行般若波罗蜜。是为具足无相三昧。云何菩萨行般若波罗蜜。于无相法具足般若波罗蜜念。佛言。菩萨不见法有实成者。亦不见五阴实成者。亦不见五阴生。亦不见五阴来生处。乃至须陀洹道亦不见所生。亦不见来住处。以虚空故其实不可得。亦不见须陀洹漏尽法。行般若波罗蜜以解有要无要之法。如是解者便解内外及有无空。于诸法无所入。亦不入于五阴。乃至于道亦无所入。学无所有。般若波罗蜜便具足菩萨道。何等为菩萨道。则六波罗蜜是。三十七品十力四无所畏四无碍慧佛十八法三十二相八十种好。于无所有成佛道。具足六波罗蜜。具足三十七品及五神通。随众生所欲。于六度中有贪嫉者以檀波罗蜜授之。有恶戒者以道戒授之。有嗔恚者以忍授之。有懈怠者以精进劝之。有乱意者以禅救之。有愚痴者以慧授之。至解脱品解脱见品皆以授之。有声闻道意者随其本应。以须陀洹斯陀含阿那含阿罗汉辟支佛道。随本授之。有大乘者以佛道授之。以是方便能作无央数变化。乃至恒边沙诸佛国土。随人所欲则能变其刹土之好。满诸众生之愿。从一佛国至一佛国。所欲取国土随其愿。譬如第六天人所有衣食伎乐随意即至。菩萨以六波罗蜜行菩萨道。随意所愿尽皆具足。逮萨云若。于五阴无所受。于一切诸法道法俗法善法恶法。皆悉具足无所受。后成阿耨多罗三耶三菩阿惟三佛时。国土所有皆悉随意即得。无有持来者亦无有持往者。亦如第六天上。何以故。诸法无所恃亦无所倚。须菩提。菩萨行般若波罗蜜。以无所有相。是为具足般若波罗蜜

    摩诃般若波罗蜜无有相品第七十七

尔时须菩提白佛言。世尊。菩萨摩诃萨云何于无所破坏法无相法无所有法中。能具足六波罗蜜念。云何于是无形法而知差别入般若波罗蜜中。云何于无相法以一相而逮正觉。佛告须菩提言。菩萨摩诃萨行般若波罗蜜。五阴如幻如响如梦如影如热时焰如化。持是五阴行六波罗蜜。五阴无相如幻如响如梦如影如热时焰。何以故。梦幻之法无所有故。无所有者则一相。一相者则无有相以是故。须菩提。当知檀波罗蜜无有相。所布。施及主受者皆无有相。作是知者则为具足檀波罗蜜。作是具足檀波罗蜜已。终不于六波罗蜜转还。便于六波罗蜜中具足四禅四等四空定。悉具足三十七品。具足内外空及有无空。便具足三脱门。具足八惟无九次第禅。具足五通。具足诸陀邻尼门。具足四无碍慧四无所畏十种力。悉具足佛十八法。佛语须菩提。菩萨以住于贤圣无漏法。便能飞行供养诸佛。随其所安救济众生。或以布施摄取众生。或以戒或以忍或以精进摄取众生。或以禅或以智慧摄取众生。随其所善而教之。为众生故受生死法。不与同归。亦不受生死勤苦。为众生故种天上人中之福。欲以摄取众生故。知诸法无有相。便学须陀洹道法亦不于中住。及学罗汉辟支佛道法亦不于中住。何以故。悉知诸法已当逮萨云若慧故。非罗汉辟支佛之所知。佛语须菩提。如是如是诸法无有相。知六波罗蜜无有相。乃至诸佛法亦知无有相。复次须菩提。菩萨摩诃萨行般若波罗蜜。于五阴如梦如幻如响如影如热时焰如化。行尸波罗蜜知五阴如梦如幻化。便以无相具足尸波罗蜜。持戒不犯不毁。善持戒不犯不毁。善持不乱。习智慧贤圣业。遍护诸戒以法义。戒身口意以等于诸戒。不以戒[打-丁+此]四性及遮迦越王。亦不言我持是戒当生四天及第六天上。亦不念言持是戒得须陀洹道乃至罗汉辟支佛道。何以故。诸法一相为无有相故。无相之法终不逮无相法。有相之法亦不逮有相法。有相之法亦不逮无相之法。须菩提。是为菩萨摩诃萨行般若波罗蜜。以无相法具足尸波罗蜜上菩萨位。已上菩萨位便逮得无所从生法忍。便行道慧具足神通。住于诸陀邻尼门。便得四无碍慧。从一佛国游一佛国供养诸佛如来。摄取众生净佛国土教化众生。生五趣之世不着于生死行。譬如弥遮加越王坐起行来无有知者。育养众生不仰臣下不娆人民。譬如须延头(须延头者晋言甚净)如来转法轮。于三乘无有菩萨可教发阿耨多罗三耶三菩者。便般泥洹后令化佛教授众生一劫。须菩提。菩萨行般若波罗蜜具足尸波罗蜜。诸法便随从之。复次须菩提。菩萨行般若波罗蜜。于五阴如幻如梦如响。以无相法具足羼波罗蜜。须菩提。菩萨以二忍事具足羼波罗蜜。何等为二。从初发意至于道场。于其中间若有众生。持刀杖捶来挝打割刺。菩萨欲具足羼波罗蜜者意不起乱。当计念言。谁有骂者谁有割者谁有挝者。何以故。以诸法无有相。如是观者便具足羼波罗蜜。以具足是忍便得无所从生法忍。须菩提白佛言。世尊。无所从生法忍为是灭为是智耶。佛言。于忍不起毛发恶意者是为智。以是智得无所从生法忍。须菩提言。世尊。声闻辟支佛无所从生法忍。及菩萨摩诃萨无所从生法忍有何差别。佛言。须陀洹智及灭至罗汉辟支佛智及灭。是菩萨摩诃萨之忍。须菩提。是为声闻辟支佛之差别。菩萨摩诃萨有是忍者过出二地上。以住无所从生法忍者。便行菩萨道便具足道慧。不离三十七品。不离三脱门。不离神通。教化众生净佛国土逮萨云若。须菩提。菩萨以无相法具足羼波罗蜜。复次须菩提。菩萨住于五阴。如幻如梦如响如野马如热时之焰。于是无相法便行身意精进便办神通。游诸佛刹供养诸佛。以身精进教授众生。立众生于三乘。是为菩萨行般若波罗蜜。以无相法具足惟逮波罗蜜。意精进者。以意精进于圣贤无漏之法。具足诸善本法三十七品法。具足三脱门。具足四禅四等及四空定。具足十力四无所畏佛十八法。菩萨于中学已当具足萨云若慧。消诸习绪具足成相。得普遍光明三倒十二法轮转。能令三千大千刹土六反震动。能以光明照遍三千大千刹土。能出音声遍三千大千刹土。诸众生闻音者必至三乘之道。须菩提。菩萨精进所有饶益弘大如是。菩萨住精进。尽具足诸佛法逮萨云若慧。复次须菩提。菩萨行般若波罗蜜。于五阴如梦如幻。具足于禅波罗蜜。行四禅四等四无形禅及三脱门电光三昧金刚三昧真禅三昧除佛三昧。诸余无央数三昧意皆遍至。亦不味诸三昧。亦不受其果报。何以故。以菩萨尽知诸三昧相法空。所有者皆无所有。无相不味无相。无所有不味无所有。以不味故不随禅生至形无形处。何以故。不见其形故。亦不见三昧亦不见三昧相。亦无所见故便具足无相三昧。持是三昧过出二地上。须菩提白佛言。世尊。菩萨云何以禅波罗蜜出过罗汉辟支佛道上。佛告须菩提。菩萨以禅学内外空及有无空。于空法不见有住处。声闻辟支佛法及萨云若法皆空。以是空故上菩萨位。世尊。云何是菩萨位。云何非菩萨位。佛言。诸有倚着非菩萨位。无所倚着是菩萨位。世尊。云何为倚云何不倚。佛言。五阴十二衰是菩萨倚。乃至萨云若亦是菩萨倚位者须菩提。都不见诸法亦无有名字。尽无所倚是菩萨位。何以故。五阴所有事萨云若所有事。亦非行亦非说亦非见。须菩提。是为菩萨受是为菩萨位。菩萨以是上位便具足诸三昧尚不随禅生。何况随淫怒痴生而有所作。是事不然。但以幻法饶益众生。不见众生亦不见幻。于无所得法中摄取佛土教授众生。是为菩萨行般若波罗蜜具足禅波罗蜜转无倚法轮。复次须菩提。菩萨行般若波罗蜜。知诸法如幻如梦诸法如响如化如光影如热时焰。须菩提言。世尊。云何菩萨知诸法如幻如焰。佛言。菩萨行般若波罗蜜。亦不见持梦幻示人。亦不见响亦不见持响示人。亦不见光影幻化热时焰。亦不见持此示人。何以故。诸凡愚夫于梦幻诸法皆着颠倒。诸罗汉辟支佛诸菩萨诸如来无所著等正觉。于梦幻法亦不见。有亦不见可持示人者。所以者何。诸法所有者皆无所有。亦无所成亦无所有。菩萨行般若波罗蜜终无贪相。亦不成就相亦不生相。是事不然。何以故。般若波罗蜜亦不念法有生者有成者。菩萨如是行者。亦不生五阴。亦不生三界。亦不生诸禅。亦不生于解脱禅。亦不生三十七品。亦不生三脱门。亦不生六波罗蜜。当具足于第一地。至十住不于中生欲。何以故。是处不可得亦不可见。况当于中生欲意。虽行般若波罗蜜亦不见般若波罗蜜。于不见中尽见诸法。皆来入般若波罗蜜亦不见诸法。何以故。诸法及般若波罗蜜一无有二亦非二事。何以故。为如如教如法性教如真际教。是诸法无有别。须菩提白佛言。假令诸法无有别无有散。云何有善恶之教言。有漏无漏教言。道法俗法有为无为之法教。佛言。于须菩提意云何。如诸法之法。颇有善恶有漏无漏。若道若俗有为法无为法不。颇见有须陀洹及罗汉辟支佛法不。颇见有佛道不。须菩提言。不见也世尊。是故须菩提。诸法无有别无有相无所生无所有。须菩提。我本为菩萨初不见诸法有要者。亦不见五阴。亦不见有为无为。从须陀洹至佛道亦无所见亦无所得。须菩提。菩萨欲学般若波罗蜜。从初发意至成阿耨多罗三耶三菩阿惟三佛。当善于所有无所有。菩萨善于无所有者。则能具足道慧教授众生摄取佛国。成阿耨多罗三耶三菩。降诸众生不见于三界。须菩提。菩萨摩诃萨当作是行般若波罗蜜。应无所有

放光般若经卷第十七放光般若经卷第十八

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜住二空品第七十八

须菩提白佛言。世尊。云何是法如梦如响如幻如化如热时焰如光如影。是诸法皆空。云何为有造处所。言是道是俗是无为是有为有漏无漏。云何言是须陀洹斯陀含阿那含阿罗汉辟支佛。云何言是求阿耨多罗三耶三菩。佛告须菩提。凡夫愚痴少有所闻。依倚梦幻法而有所见。因身口意所作非法不善之事。或行善事至有善恶之报。受罪福于三界。菩萨摩诃萨行般若波罗蜜。住于二空。从有无本端空至毕竟空。教化众生说有五阴十二衰空十八性空。是法如梦如响如幻如化如影如热时焰。是中亦无五阴亦无诸衰亦无诸性亦无梦亦无响亦无幻化亦无焰影亦无有见。诸法皆无形所有皆无所有无有五阴。汝等见有五阴无十二衰。汝等见有诸衰无十八性。汝等见有诸性。以因缘颠倒故便有诸法随行所受。云何汝等于无所有法而有形相。行般若波罗蜜。菩萨以沤和拘舍罗。诸有众生在贪嫉者。教令布施令得大富。于中拔出教令持戒。以戒因缘得生天上。于戒拔之令住禅三昧。以禅因缘得生梵天。具足四禅及四空定因缘。施从戒以禅无数方便立之泥洹。复以三十七品及三脱门。八解脱。九次第禅。十种力。四无所畏及四等。劝令得十八法。持是无像之法立于三乘。为说菩萨道。须菩提白佛言。世尊。甚奇甚特未曾有。菩萨行深般若波罗蜜。为诸空无法作处所。言是善法恶法是道法俗法是漏法无漏法是有为法是无为法。佛言。如是须菩提。甚奇甚特所未曾有。为是空无之法而作处所。须菩提。汝等当知菩萨所行奇特。罗汉辟支佛所不能及者。汝等当应为菩萨摩诃萨作礼。须菩提白佛言。世尊。何等为菩萨摩诃萨所未曾有。诸罗汉辟支佛所不能及。佛告须菩提。若欲闻者善思念之。吾当解说。菩萨行般若波罗蜜者。住于六波罗蜜中及内外空三十七品四无碍慧及五神通。遍到十方观诸众生。可以布施摄者便以施取之。可以戒忍精进一心智慧随其所应以六波罗蜜而摄取之。应以四禅及四空定得解脱者。以禅因缘而摄取之。或应以慈悲喜护得度者以四等摄之。或应以三十七品得度者以根力觉意而摄取之。若应以三脱门得度者皆摄取之。须菩提白佛言。世尊。云何以布施摄取众生。佛言。菩萨行般若波罗蜜者。随人所索。若索衣被饮食疾病医药象马车乘金银珍宝。随人所欲皆施与之。及所施与若佛辟支佛阿罗汉及须陀洹。下至凡夫及蜎飞蠕动诸三恶趣。其意适等而无差别。无若干种意。何以故。诸法无有若干种意故其意平等。无若干者便得无差别萨云若慧。佛言。菩萨摩诃萨若见来求者当作念言。我所施者当与三耶三佛福祐不从畜生出生。有是念者非是菩萨法。何以故。菩萨发道意不作是念。我持布施当生四姓家。诸所施已摄取众生者。皆令至无余泥洹而般泥洹。菩萨以众生为亲族所施与无若干差别。亦不言当与是不与是。意无适莫所施众生无有碍意。何以故。为众生故发阿耨多罗三耶三菩。若有分别意者。便于诸如来无所著等正觉诸缘觉诸真人有大过失。何以故。诸天及人诸阿须伦无有倩。菩萨为众生作救护作桥梁者。为菩萨之法。自当救摄众生。复次须菩提。菩萨行般若波罗蜜者。若人若非人来至菩萨所。取节节支解菩萨身。菩萨亦不疑言当与不与。何以故。是菩萨欲救众生故受是形耳。我以是身饶益一切。菩萨当作是念。我为众生受是身形今来取之。须菩提。菩萨见来所求者当发意言。施者为谁受者为谁所施物为何等。是诸法实不可得见。何以故。是诸法常空。空亦无所与亦无所夺。须菩提。菩萨行般若波罗蜜当作是学。所谓内空外空及有无空。住是空者于中布施。便具足檀波罗蜜。具足檀已不断内外法。言谁有割者谁为截者。佛告须菩提。佛以天眼见十方恒边沙等刹土。诸菩萨摩诃萨入泥犁中。泥犁则为冷。以三事变化为泥犁中众生说法。一者神足二者随其所使三者四等之法。以神足灭火随意为说四等法。泥犁中众生便有爱敬归仰于菩萨。即得离苦痛。次为说三乘之教皆令脱苦。是故须菩提。我以佛眼见十方恒边沙。诸菩萨摩诃萨供养诸佛不以憍慢。爱好诸佛不以憎恶。欢喜无恚诸佛所说皆悉受持。至成阿耨多罗三耶三菩终不志失。须菩提。佛以佛眼见十方恒边沙刹土。诸菩萨等为众生故。割截身体支节分离布散四面。诸有飞鸟走兽来食菩萨肌肉者皆有慈意。于菩萨所以慈意故得离畜生即得为人。往见诸佛听受经法。随其所闻即得顺行。以三乘之法而度脱之。佛告须菩提。诸有菩萨摩诃萨发阿耨多罗三耶三菩者多所饶益。如是能使众生得无余泥洹。复次须菩提。我以佛眼见十方恒边沙诸菩萨等入薜荔中者。诸薜荔众见菩萨已便生慈意。恭敬菩萨。以恭敬故离诸勤苦。因是功德终不离诸佛至得泥洹。须菩提。菩萨摩诃萨行慈如是。使诸众生皆得泥洹。佛告须菩提。我见诸菩萨至四天王及第六天为彼诸天而广说法。以三乘教而度脱之令得泥洹。诸天人众有着五乐者。菩萨应时令殿舍悉皆烔然。以为说法言。诸仁者。一切所有皆悉无常无尊无卑谁常安者。佛告须菩提。我于是以佛眼观见恒边沙国土。诸有赞叹梵天上者。菩萨则为说法言。诸仁者。云何于是空无之法而生见意。是法为空无常无见为磨灭法。莫得于是而生见意。须菩提。菩萨摩诃萨已住于大慈为众生说法。是为菩萨甚奇甚特未曾有法。须菩提。十方恒边沙国土诸菩萨摩诃萨以四事饶益众生。何等为四。一者惠施二者仁爱三者利人四者等义。是为四恩。菩萨摩诃萨以二事施摄取众生。一者财物二者法施。何等财物施摄取众生。菩萨以金银璧玉珍奇异宝。以饮食衣被香花服饰病瘦医药床卧之具。所有奴婢象马车乘。令诸众生随意所欲不逆人意。诸有来者既施与已。皆悉教令自归三尊。或授五戒或教十善或教八斋或教令行四禅及四等四空定。或劝助之令念佛念法念比丘僧念天念施。诸行倒者教令行顺。诸不谛者教令行谛。劝助令行三十七道品及三脱门。八惟无。九次第禅。佛十种力。四无所畏。四无碍慧。大悲大慈。劝众生令行佛十八法八十种好。劝助人学三乘法教。是为菩萨摩诃萨以沤和拘舍罗行般若波罗蜜。以财布施摄取众生。立于无上无畏之地。是为菩萨奇特未曾有之法。何等为菩萨行般若波罗蜜。以法布施摄取众生。布施有二。一者道施二者俗施。何等俗法施。世俗所说所施行者谓为不净。欲得四禅四等四无形定。及余凡夫所行善法。是名为世俗法施。作是俗法施已便教众生令离世俗。以沤和拘舍罗安立于道法贤圣果报。何等为贤圣道法贤圣果报。贤圣法者。谓三十七品及三脱门。贤圣果者从须陀洹至罗汉辟支佛。佛言。菩萨贤圣道法者知须陀洹所有慧。知罗汉辟支佛慧及三十七道品慧。佛所有十力慧大慈大悲慧。及余道法俗法有漏无漏。及有为无为之法慧萨云若慧。是为菩萨贤圣之法。何等为菩萨贤圣果报。诸习绪皆尽。是为贤圣果报。须菩提白佛言。菩萨复逮萨云若。佛言。如是如是。须菩提。菩萨逮萨云若。须菩提白佛言。如是者世尊。菩萨摩诃萨如来有何差特。佛报言。有差别。差别云何。菩萨逮萨云若便名为如来。何以故。菩萨意亦不可得。如来意亦无有异。住于无限之冥为诸法作明。是名为菩萨。因俗之法施而续道法之施。佛告须菩提。是菩萨断于众生世俗之施。以沤和拘舍罗安住于萨云若。佛告须菩提。何等为菩萨道法之施。凡人所不能及者。所谓三十七品及三脱门八惟无九次第禅佛十力四无所畏四无碍慧佛十八法三十二大士之相八十种好诸陀邻尼门。是名为道法施。非是俗法。是为菩萨甚奇特未曾有之法。以爱意摄取众生。持六波罗蜜。布施持戒忍辱精进一心智慧。以和颜悦色摄取众生。何以故。六波罗蜜皆摄持诸善法数。云何菩萨饶益于人摄取众生。常以六波罗蜜摄持众生。以四事饶益一切。一者惠施二者仁爱三者利人四者等义。是为四事。菩萨以是四事救济众生。复次须菩提。菩萨以般若波罗蜜教新学菩萨。当语之言。善男子。受是文字之数。当善于一字从一字至四十二字。一字者皆入诸字义。诸字义者皆入四十二字。四十二字义皆入一字以为一义。是故菩萨当善于四十二字。如来无所著等正觉。善于诸法善于文字。已教化众生。如来说法不离文字。诸法亦不离文字。须菩提白佛言。世尊。众生不可得法亦不可得见。诸法空故。世尊。菩萨云何行六波罗蜜四禅四等及四空定。云何行三十七品。行十八空行空无相无愿。云何行八惟无九次第禅。云何行十力四无所畏佛十八法。云何行三十二相八十种好。云何行六神通为众生说法。亦不见众生亦不得其处。乃至于识亦不可得。六波罗蜜亦不可得见。乃至八十种好亦不可得亦不可得处。亦无有众生亦无有处。亦无有八十种好亦无有处。云何菩萨行般若波罗蜜为众生说法。须菩提言。世尊。将无菩萨以无端绪之事劝助众生令离四颠倒。住于四谛耶。行般若波罗蜜菩萨尚不可得见。何况行三十七品事佛告须菩提。如是如是。如汝所言。众生不可得。当知内外空及有无空。当知五阴空性空衰空。当知四谛十二因缘空。当知吾我空及知见空。当知四禅空四等空四空定亦空。当知三十七品空三脱门空。当知八惟无空九次第禅空。当知佛十八法空十种力空四无所畏空四无碍慧空。当知二地空。当知菩萨空。当知佛刹土空。当知道空。佛告须菩提。菩萨觉知诸法皆空。而为一切众生说法。既为说法不从是空有转还者。于诸法无所取无所舍亦无碍。真谛说法无有虚饰。譬如如来化作无央数人。或安立于六波罗蜜者。或安立于四禅四等者。于须菩提意云何。是化人宁有所得不。须菩提言。世尊不也。化无所得。须菩提。当知菩萨教化众生亦复如是。随其所能而为说法。皆令众生离于颠倒。亦不缚亦不解。何以故。五阴无缚亦不解。若五阴有缚有解者则非五阴。用五阴常自净故。乃至有为无为法亦常自净。菩萨为众生说法。初不见众生以诸法不可得故。菩萨住于无所住五阴空故无有处所。乃至有为无为亦无所住。何以故。无有实故。而无所住无所有亦不住于无所有。有所有亦不住于有所有。何以故。是皆不可得故。不可得者无有住处。须菩提。菩萨行般若波罗蜜皆明诸法分别诸空。菩萨作是行般若波罗蜜者。于诸如来无所著等正觉。于诸圣贤为无有过。何以故。诸佛世尊及诸圣贤皆逮觉是法教化众生。以得是法无转还者。何以故。法性真际及如无转还者。亦无形貌可转还者。须菩提白佛言。世尊。法性真际及如不转还者。五阴及如真际法性为有异耶。有为无为及道有漏无漏复有异耶。佛言不也。须菩提。五阴及如真际法性有为无为及道等无有异。复问世尊。假令五阴及如乃至有为无为等无有异者。云何有善恶之报及五道生死。云何有三乘之法耶。佛言。以众生习于世谛故便有道之名号。于第一最要义者无有分数。何以故。是法常寂无所分别亦无所说。五阴亦无生灭亦无著断。用本空末空故。须菩提白佛言。世尊。若习世谛便有道名者。一切凡夫皆为是道是三乘耶。佛告须菩提。一切凡夫尽知习谛及道谛者。若知是者当知是道。若使凡夫不知者。亦无道处亦无道报。复问。云何凡夫当得道之果报。佛言。诸贤圣者有道念故便有道报。复问世尊。以道念故便有道耶。佛言不也。须菩提。不以念故便能逮道也。亦不无念亦不离念。是故菩萨行般若波罗蜜。为众生故便处于道。道者亦无分部。亦无有为无为亦无分别。复问世尊。若不分别有道处者。云何佛说三习绪断得须陀洹。淫怒痴薄得斯陀含。于下欲界灭五习得阿那含。于上无形界灭五习者得阿罗汉。眼所见形色皆如是尽法得辟支佛。一切诸习绪尽便得三耶三佛。如是云何当知是事。若道无分数者。云何随行各得其道。佛告须菩提。须陀洹道乃至三耶三佛。为是有为耶为是无为耶。须菩提言。世尊。非是有为法。佛言。无为之法有分界不。须菩提言。无有分界。佛言。于意云何。善男子善女人。一时逮得有为无为之法。及得一相。是时宁见言是有为是无为不。须菩提言。世尊不也。佛言。菩萨行般若波罗蜜。为众生说法无有分界。以内外空及有无空故。菩萨于内自无所入。教一切人亦无所入。亦不入六波罗蜜。亦不入禅亦不入等。亦不入于三十七品亦不入萨云若。无所入者为无所生。譬如如来化作化人。化人布施亦不得报。欲度人故亦不住于六波罗蜜。亦不住于有漏无漏。亦不住道亦不住俗。亦不住有为不住于无为。适无所住。所以者何。超越诸法之相故也

    摩诃般若波罗蜜超越法相品第七十九

于是须菩提白佛言。世尊。云何超越诸法法相。佛告须菩提。譬如化人无淫怒痴亦无五阴行。亦无内外事无有挂碍处。亦无道事亦无俗事。有漏无漏有为无为。亦无道事亦无有果报。佛语须菩提。是为超越诸法相。须菩提白佛言。世尊。化者云何有道念。佛报言。道念者亦无断亦无著亦不于五趣现。佛言。于须菩提意云何。如来所化颇有形有来往有着断耶。须菩提言。世尊。如来所化无有来往亦无著断。亦不于五趣现。佛言。须菩提。是为超越诸法之相。须菩提白佛言。世尊。诸五阴皆如幻耶。佛言。如是如是。须菩提白佛言。若诸法如化。世尊。化者亦无有色亦无有痛亦无想亦无行亦无识。亦无著亦无断亦不于五趣有脱。菩萨摩诃萨有何等奇特事。佛言。于须菩提意云何。我本为菩萨时。颇见从五趣中得度脱众生者不。须菩提报言不见有所说。佛言。于三界不见有众生。何况当有五趣当有所度。何以故。菩萨观知诸法如幻如化。须菩提言。若菩萨观知诸法如幻如化者。用何等故行六波罗蜜四禅四等四空定。为何等故行三十七品。而净佛土教化众生。佛告须菩提。若众生自知诸法如幻如化者。菩萨终不于阿僧祇劫谦苦行菩萨之道。须菩提。以众生不能自知如幻如化故。菩萨谦苦行六波罗蜜。净佛国土教化众生。须菩提白佛言。世尊。假令诸法如梦如幻如化如响如热时之焰。于何许有众生菩萨行般若波罗蜜而拔济众生。佛言。众生者但共缚于名字数。着于无端绪。是故菩萨摩诃萨行般若波罗蜜。于名字相拔济之。须菩提白佛言。何等为名字相。佛告须菩提。名字者不真假号为名。假号为五阴。假名为人为男为女。假名为五趣及有为无为法。假名为须陀洹斯陀含阿那含阿罗汉辟支佛三耶三佛。佛语须菩提。诸吾我造作之法及道。但为名字数法故。凡诸愚人缚着于有为法。是故菩萨行般若波罗蜜。以沤和拘舍罗教授众生言。是名但从相起。但以相故生母人胞胎。所有者无端绪所有者无所有。诸智者不入于空。佛语须菩提以是故菩萨摩诃萨行般若波罗蜜。以沤和拘舍罗教授众生。佛言。何等为相须菩提。凡愚以二相着。何等为二。一者形相。二者无形相。何等为形相。诸有好形恶形微形。于是消耗之法。于中有所起相。是名为形相。何等为无形相。诸无形之法于中起相生垢。是名为无形相。菩萨学般若波罗蜜以沤和拘舍罗。于无形相出诸众生。建立于无相处令不二入。何等为二。是相是无相是为二。须菩提。是为菩萨摩诃萨于相中出诸众生建立于无相。须菩提白佛言。世尊。假令诸法但有名相。菩萨云何行般若波罗蜜。于诸善法云何有差别。而复劝他人于善法使有差别耶。以善法具足诸处建立众生于三乘。佛告须菩提言。假令菩萨念五阴名计校五阴相。菩萨为不行般若波罗蜜。于善法无有差别。亦不能令他人有差别。须菩提。若菩萨摩诃萨行般若波罗蜜。以无相行五波罗蜜。以无相具足四禅具足四等具足四空定。以无相具足三十七品。以无相具足内外空及有无空。以无相具足八惟无及九次第禅。具足佛十种力。以无相具足佛十八法。菩萨以自具足是善法。劝他人以无相具足诸善法。须菩提。若诸法有如毛厘之相者。菩萨行般若波罗蜜。终不逮空无相无愿之法。不能随众生所愿而建立之。不能令得空无相无愿漏尽之法。须菩提。菩萨摩诃萨以无相无念行般若波罗蜜。饶益一切如是。须菩提白佛言。世尊。假令诸法空无相无念。世尊。云何为法作分数。言是有漏是无漏。是能有所及是不能有所及。言是声闻法是辟支佛法是菩萨法是佛法。佛告须菩提言。于意云何。无相与声闻辟支佛法菩萨法佛法有异不。须菩提言。不也世尊。佛言。声闻辟支佛法及菩萨佛法皆不是无相耶。须菩提言。尔世尊。佛言。以是故当知诸法皆无相。佛言。菩萨于诸法作无相学者。则能增益善本功德。则能增益六波罗蜜四禅四等四空定三十七品佛十八法。何以故。菩萨者不学余。但学空无相无愿。所以者何。诸菩萨法皆来入三脱门故。三脱门自空。菩萨学空无相无愿。为学五阴为学十二衰为学十八性。为学四谛为学十二缘起。为学内外空及有无空。为学六波罗蜜为学三十七品。为学佛十力四无所畏四无碍慧佛十八法。须菩提白佛言。云何世尊。菩萨行般若波罗蜜。云何学五阴。佛报言。菩萨行般若波罗蜜。知色相知色起灭知色如。云何知色相。色无坚固。譬如聚沫。云何知色本末。色亦不来亦不去亦无还反。须菩提。是为知色本末。云何知色如。如亦不生亦不灭亦不来亦不去。亦不断亦不着。亦不增亦不减。作如是知是为知如。亦不变异是故名为如。是故名为知色如。云何知痛生灭。云何知痛如。知痛如泡故。云何知想如。知想如热时之焰至竟无水。亦不去亦不来。痛如及想如等。知想亦如是。云何知行如。譬如芭蕉叶叶分解中无有坚。云何知行起灭。行亦无有来往。知行如是知如亦如是。云何观识。譬如幻师化作四种兵。亦不往亦不来观识亦如是。云何观识如。观如如识是为知识如。云何观知眼性。眼所有空眼色空眼识空。乃至意识所有空。云何观知十二衰。知内外法如。知内外法所有空。云何观知苦谛。亦知苦亦知谛亦知有我无我。谛习尽空皆知谛。云何知四谛如。知如如四谛是为知四谛如。云何观知十二缘起如。十二缘起无所生。是故知十二缘起如。须菩提白佛言。菩萨学般若波罗蜜行般若波罗蜜。假令各各分别知是诸法如是。则为不分别法性色身。佛报言。若有异法离于法性者。是色身法性则为有别。何以故。须菩提。如来及如来弟子。不见有法离于法性与法性有别者。虽不见不处法无有二离法性者。佛告须菩提。菩萨行般若波罗蜜。当作是学法性。须菩提白佛言。世尊。菩萨学法性者为无所学。佛告须菩提。菩萨学法性者为尽学一切诸法。何以故。一切诸法皆是法性。须菩提白佛言。何以故。诸法皆是法性。诸有为法皆是法性。是故须菩提。菩萨学般若波罗蜜者。为学法性。须菩提白佛言。假令诸法皆是法性。菩萨用何等故行六波罗蜜。何以故。行四禅四等四空定。云何行三十七道品三脱门八惟无九次第禅十力四无所畏。何以故。学佛十八法。学六通三十二相。学成就八十种好。何以故。学生四姓家。何以故。学生四天上。从第四天至三十三天。何以故。从初发意至第十地。何以故。学三乘净佛国土教化众生。学陀邻尼门学辩才。何以故。学菩萨道。学诸法如。知一切众事。法性中无有是若干分数。世尊。将无菩萨行颠倒事。所以者何。法性亦非五阴。法性亦不离五阴。法性则是五阴。五阴则是法性。佛告须菩提。如是如是。须菩提如汝所言。法性则是五阴五阴则是法性。须菩提。菩萨行般若波罗蜜。若见法有离法性者。终不发阿耨多罗三耶三菩。菩萨行般若波罗蜜诸法之性则是道。是故菩萨行般若波罗蜜。知诸法则是法性。无名之法以名教授。从五阴至道皆以名号法数字说之。须菩提。譬如幻师持一镜现若干种像。若男若女若马若象若庐馆若浴池。于中示现若干种坐。氍氀毾[登*毛]綩綖帐幔香华伎乐种种食饮之具。以名伎乐娱乐众人。复现六波罗蜜。于中现四大姓现有须弥山有三十三天。于中现诸声闻辟支佛。现诸新发意行六波罗蜜菩萨。复现十住一生补处菩萨。现诸菩萨游戏于五通。现有净佛国土教化众生。现有行三昧三摩提以自娱乐。复现有行佛十力四无所畏大慈大悲。现有佛身相具足者。中有愚痴之士称叹言。快哉是人所作甚奇特。能食饮若干亿万人皆令欢喜。现若干种像世尊相好。中或有知者便大笑言。是幻师所作乃尔以空。无所有法。以无端绪之法乐众人令使有端绪。相无形与作形相。佛言。菩萨行般若波罗蜜。不见有法离法性者。以沤和拘舍罗为众生说法。亦不见众生亦不见其处。自行六波罗蜜。劝人习六波罗蜜。见有行者代其欢喜。自行十善劝人令行。见行十善者赞叹代其欢喜。自行五戒劝人令持。见有持者赞叹代其欢喜。自持八斋劝人令持。见有持者赞叹代其欢喜。自行四禅四等四空定。劝人令行。见有行者赞叹代其欢喜。自行三十七品三脱门及四无所畏佛十力佛十八法。劝人令行。见有行者赞叹代其欢喜。佛告须菩提言。法性前以后及中间无有增减。是故菩萨摩诃萨为众生故。谦苦行菩萨之行。若法性前后及中间有异者。菩萨终不以沤和拘舍罗。广宣法性教授众生

    摩诃般若波罗蜜信本际品第八十

尔时须菩提白佛言。假令初无有众生及其处。菩萨为何等故念行般若波罗蜜。佛告须菩提。菩萨信真际故。念般若波罗蜜。真际及众生际有异者。菩萨终不念般若波罗蜜。以真际众生际等无有异故。菩萨欲益众生故。念行般若波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。亦不分流分别真际。而建立众生于真际。须菩提白佛言。若建立众生于真际者。则为建立真际于真际。若建立真际于真际者。俱无所有。云何持无所有建立于无所有。世尊。如是者菩萨云何建立众生于真际。佛告须菩提。不可以真际建立于真际不可以所有建立于所有。亦不可以无所有建立于无所有。须菩提。菩萨行般若波罗蜜。以沤和拘舍罗建立众生于真际。真际及众生际一际无有二。须菩提白佛言。世尊。何等为菩萨沤和拘舍罗。行般若波罗蜜而建立众生于真际。而无所分现。佛告须菩提言。菩萨摩诃萨行般若波罗蜜。以沤和拘舍罗建立众生于檀。建立已为说檀本末空。为说所施及施者受者皆空受果报亦空。教言善男子。莫作若干相。汝所施及受者谓有果耶。等一空耳皆入真际。教言善男子。汝若不分别所施及受者及果报。是则甘露施。便逮甘露果。莫以是施受色。教言善男子。莫以施受痛。莫以施受想行识。何以故。汝所施及施者受者皆空受报亦空。以空施有所求。诸所施不可得见。何以故。所有者从本至竟常自空故。复次须菩提。菩萨摩诃萨行般若波罗蜜。以沤和拘舍罗。建立众生于尸。教言善男子舍是十恶行。是诸恶法无有实。当谛自思惟。是十恶本无所有。菩萨摩诃萨以是具足于沤和拘舍罗教授众生。便以檀及尸教于众生。檀及尸果报皆自空无所有。亦不入中。便逮寂静便生智慧。断诸蒙冥离诸苦恼。以世俗数般泥洹不以最第一义。何以故。从空中索般泥洹者。无有空终不般泥洹。泥洹者亦自至竟空。复次须菩提。菩萨见众生乱意志不定斗诤怨恚。便教令忍辱教令习羼。教人言。汝所入陷溺皆是空无所有。当熟思念言我空弊暴。为我为是谁。空弊暴意从何所来。空无有不空时。是空亦非如来菩萨罗汉辟支佛所作。亦非诸三十三天龙阿须伦鬼神甄陀罗摩睺勒所作。空自然空。菩萨行般若波罗蜜。以空法建立众生令入空。虽有报应不离阿耨多罗三耶三菩。虽劝进众生求道。但是俗数非是最第一义。何以故。空性亦非逮觉亦无有逮觉者。亦无有甫当逮觉者。是为真际性空。菩萨为众生故于中行般若波罗蜜。亦不得众生亦不见其处。何以故。众生寂如诸法。复次须菩提。菩萨行般若波罗蜜。以沤和拘舍罗。见众生中有懈怠者。菩萨便劝助身意行精进空无之法。于诸法无有懈怠亦不见有懈怠。空无法终不从空退转。莫于善法生懈怠意。莫于身意退。于六波罗蜜及四禅四等四空定莫退。于三十七品法及三脱门至佛十八法莫生懈怠念。莫于诸法作挂碍。观空无挂碍之法无有懈怠者。佛语须菩提。菩萨行般若波罗蜜。以空性之法劝进众生令住空行。虽住空行不以二事。何以故。空性者一无有二。不二之法无可入处。复次须菩提。菩萨行般若波罗蜜。持空性之法教众生令精进。教告之言。善男子。当善精进于施于戒于忍于进于禅于智随意所能。于三十七品乃至佛十八法。善男子。莫于是法起二念亦不离二念。何以故。是法性空空性之法。亦无有二亦不不二故。须菩提。是为菩萨行般若波罗蜜。以沤和拘舍罗习菩萨之行。教授众生净佛国土。次建立众生于须陀洹斯陀含阿那含阿罗汉辟支佛。建立众生乃至阿耨多罗三耶三菩。复次须菩提。菩萨行般若波罗蜜。以沤和拘舍罗祐利众生劝助之言。当念禅一心莫生乱想。亦莫生三昧想。何以故。诸法性皆空。空无法中亦无乱者。亦无有一心者。当住是三昧身口意所作事。若六波罗蜜三十七品。八惟无九次第禅。佛十力四无所畏四无碍慧大慈大悲。佛十八法八十种好。若声闻辟支佛道菩萨道佛道。若声闻果辟支佛果若萨云若。若净佛土教化众生。若行空者便得是诸善法事。佛告须菩提。菩萨行般若波罗蜜。以沤和拘舍罗祐利众生如是。从初发意以来未常不为众生多少作祐利时。从一佛国至一佛国。供养礼事诸佛世尊。从诸佛所受法教。至阿耨多罗三耶三菩终不忘失。常得诸总持身口意行。常具足无所乏少。何以故。善于萨云若念故。以菩萨云若者便善于诸道声闻辟支佛道及神通。菩萨诸所可应行道。终不废舍。立于神通救护众生。周旋五趣生死不耗减于神通。佛告须菩提。菩萨行般若波罗蜜。住于空性祐利众生如是。复次须菩提。菩萨行般若波罗蜜。以沤和拘舍罗住于空性祐利众生。以般若波罗蜜劝教众生言。诸仁者。净于身口意受甘露教。有受甘露教者终不离空性法。何以故。空性之法亦非是有法亦非是无法。佛告须菩提。菩萨行般若波罗蜜。使众生作是入作是学。未曾不精进时。自行十善劝人令行。自行五戒及八斋四禅四等四空定劝人令行。自行三十七道品法十力十八法劝人令行。自行八十种好劝人令行。自学须陀洹道慧复教人令学须陀洹。自不于中有所欲。自于罗汉法中取慧。亦教他人学阿罗汉辟支佛法。自于内无所欲。自发阿耨多罗三耶三菩。复教他人学阿耨多罗三耶三菩。佛告须菩提。菩萨摩诃萨习菩萨之行。以沤和拘舍罗初无有懈怠时。须菩提白佛言。假令诸法性本空。众生亦不可得。亦无有正法亦不见非法。云何菩萨逮得萨云若慧事。佛告须菩提言。如是如是。如汝所言。一切诸法性皆空。空法中亦无有众生。亦无有正法。亦无有非法。若诸法性不空者。菩萨不于空法中成阿耨多罗三耶三菩。为空性说法说五阴性空。是故菩萨行般若波罗蜜说五阴性空。以十八性空以十二缘起性空故。为众生说法。说四禅四等四空定。说三十七品性空说三脱门。说八惟无九次第禅空四无碍慧四无所畏。说十八空佛十八法大慈大悲八十种好空。以是故为众生说法。说声闻辟支佛道。说萨云若。说诸本习垢尽。以是空性说法。若内空外空及有无空。是性不空者菩萨终不以空性说法。若内空外空及有无空。非是性空者为坏败空矣。空不可坏亦不可上尊。何以故。空亦无有处亦不无处。亦不来亦不往。是故法常住无有增减。无有起灭无著无断。菩萨住是法者。为成阿耨多罗三耶三菩。亦不见法有所逮。亦不不有所逮。亦不无所逮。是为法之常住。菩萨行般若波罗蜜者。见诸法性皆空。于阿耨多罗三耶三菩终不转还。何以故。不见诸法挂碍。当何从有狐疑。阿耨多罗三耶三菩者性空无有众生。亦不见众生处。亦不见有吾我寿命及知见事。亦不见五阴乃至八十种好。亦无所见。须菩提。譬如化佛化作比丘比丘尼优婆塞优婆夷。为说法至那述劫不断绝。须菩提。化人于三乘法宁有所得不。须菩提言。不也世尊。何以故。无形故。诸法亦无有形。何所众生为菩萨入声闻辟支佛者。但为着余堕颠倒者建立于顺。如是倒者为非颠倒。无有颠倒及诸念处。亦无众生亦无吾我亦无寿命亦无知见之事。亦无五阴亦无有道。是名为空性。菩萨于中行般若波罗蜜。度诸颠倒及有人相及众生相。度脱有色无色相度脱有漏之法。以俗数度脱无漏之法。非最第一之义。何等无漏。三十七品是亦无所有亦无所生。亦不以行。是谓空性诸佛世尊之道。诸佛之道者。亦无众生亦无我人寿命。亦无知见亦无五阴。亦无三十二相八十种好。是者真是如来之道。亦不以菩萨道故。发阿耨多罗三耶三菩。但为空性故从本至竟及其中间无不空者。常一空故。菩萨所以行空波罗蜜。以众生有众生相。欲建立于萨云若故。是故菩萨行道慧。以道慧事便能入诸道亦入三乘道。菩萨具足入诸道已。教化众生净佛国土。便住于有为中成阿耨多罗三耶三菩。不断佛业及诸空性。住空性者是诸去来今佛之道业。生死之处及诸俗法不离于空性。诸菩萨皆当入于诸佛所习行空性。虽行空性于萨云若而不堕落。须菩提白佛言。世尊。诸菩萨摩诃萨甚奇甚特。行于空事不分别空。何等为不分别空。不言色异觉异想异行异识异空异。乃至于道亦不言异。空性则是道。道则是空性。佛告须菩提。假令空性异五阴异者。菩萨终不逮觉萨云若。空性与五阴等无有异。菩萨知诸法性皆空。是故发阿耨多罗三耶三菩。何以故。空性法亦无坏者亦不尊上。而世人迷惑言。五阴是我所我是五阴所。便入五阴行吾我事。复入内外形便生五阴。便有生老病死忧悲勤苦。堕五趣中不得度脱。是故菩萨习行空波罗蜜。不分别五阴。不观五阴空以不空。乃至于道亦不观空以不空。所以者何。不以五阴空而现五阴。亦不以道空而现道也。须菩提。譬如虚空不分别空。亦不分别内外空。如是须菩提。亦不以五阴空故现五阴。亦不以道空故现道。何以故。空者无所有。亦不分别是空是不空。乃至于道亦复如是。须菩提白佛言。世尊。假令诸法不可分别不可坏者。云何菩萨发阿耨多罗三耶三菩。世尊。于道有二者。不能发阿耨多罗三耶三菩。佛言。如是如是。须菩提。行二者无有道。道者无二亦非二也。菩萨学道不作二入。菩萨则是道。道则是菩萨。亦不色痛想行识亦不行道。何以故。道亦不言。汝当行五阴汝当行道。菩萨行道亦无所取。须菩提白佛言。菩萨行道亦不有所取亦不有所放。为作何等行于何所行道。佛言。于汝意云何。如来所作化。于何所行。有取有放不。须菩提言。世尊不也。无取无放。佛言。罗汉于梦中为有所取有所放不。答言不也。须菩提言。世尊。罗汉尚不眠那得有梦。佛言。如是如是须菩提。菩萨所行亦无所取亦无所放。须菩提言。世尊。菩萨意亦不于五阴亦不于道有所取放者。菩萨为不行十住地所应行耶。不行六波罗蜜耶。不行三十七品四禅四等及四空定八惟无九次第。不行十力四无所畏三十二相八十种好。不行五通。净佛国土教化众生不逮萨云若。可得成阿耨多罗三耶三菩不。佛言。如是如是须菩提。若菩萨不具足行十地。不具足六波罗蜜。不具足四禅四等及四空定八惟无禅九次第禅三十七品。乃至八十种好不具足者。终不得成阿耨多罗三耶三菩。不具足者不能逮萨云若。灭五阴空相。灭道空性。是性已灭住于灭性。不为法作损益。亦无所生亦无所灭。亦无著断亦不逮觉。须菩提。以世俗法教。菩萨成阿耨多罗三耶三菩。五阴及道以俗数故非最第一要义。菩萨从初发意以来。虽行道意亦不灭众生亦不灭。道亦不灭菩萨亦不灭。于须菩提意云何。汝等五阴除灭得无量三昧。得须陀洹乃至罗汉时。是时颇见意颇见道果不。须菩提言。世尊。不见也。佛言。汝弟子等云何有言有所逮得。须菩提言。但以世俗数耳。佛言。亦复以世俗数故。言有五阴言有菩萨言有萨云若。菩萨不于道有所得法有所损益者。以法性故不得。诸法性尚不得诸法性。何况当得十住地及六波罗蜜三十七品及三脱门乃至佛十八法。当有所得者是者不然。是故须菩提。菩萨摩诃萨行阿耨多罗三耶三菩。得阿惟三佛祐利众生

放光般若经卷第十八放光般若经卷第十九

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜无形品第八十一

须菩提白佛言。世尊。若菩萨摩诃萨于六波罗蜜三十七品佛十种力四无所畏四无碍慧佛十八法行十八空。不具足菩萨道。不成阿耨多罗三耶三菩者。云何菩萨摩诃萨得阿耨多罗三耶三菩。佛告须菩提。菩萨学般若波罗蜜以沤和拘舍罗行檀波罗蜜。亦不见所施物亦不自见亦不见受者。亦不离是法亦不见是法。作是行者便照明于菩萨道。以是故须菩提。菩萨行般若波罗蜜沤和拘舍罗故。逮觉阿耨多罗三耶三菩。菩萨行檀波罗蜜亦不见所施物亦不自见亦不见受者。行五波罗蜜乃至佛十八法亦复如是。舍利弗白佛言。世尊。菩萨行般若波罗蜜云何习般若波罗蜜。佛告舍利弗。菩萨行般若波罗蜜。以沤和拘舍罗。亦不习五阴亦不不习。何以故。五阴无形无有可习无不可习者。六波罗蜜亦不习亦不不习。何以故。六波罗蜜无有形故。乃至十八法亦不习亦不不习。何以故。十八法空无形故。舍利弗言。世尊。诸法无所有亦无形像不可得见亦无习与不习。云何入般若波罗蜜中学。菩萨不学般若波罗蜜。亦不得阿耨多罗三耶三菩。佛言。如汝所说。菩萨不学般若波罗蜜者不得阿耨多罗三耶三菩。以沤和拘舍罗。不离沤和拘舍罗。菩萨行般若波罗蜜诸法无所有。是故菩萨亦无所取。六波罗蜜亦无所有。五阴亦无所有。乃至十八法亦不可见当取何等。是故菩萨亦无所取。舍利弗。般若波罗蜜亦不可护持。乃至佛十八法亦不可护持。是般若波罗蜜则为不可护持。舍利弗。如是学者于学亦无所见。何况般若波罗蜜。何况菩萨何况佛法声闻辟支佛法。何况凡夫法。何以故。舍利弗。诸法无有形故。于无所有法中何所是凡夫愚人法。何所是声闻辟支佛法。何所是三耶三佛法。舍利弗白佛言。世尊。三乘及凡夫法尚不可见。谁当说言。凡愚人法是三乘法是无形之法。何因是凡愚人法是三乘法。佛告舍利弗。凡愚人所入五阴。有形有处有实不。舍利弗言。不也世尊。是者则为颠倒。佛言。凡愚人所入佛道为有形有处有实不。舍利弗言。不也世尊。但颠倒耳。是故舍利弗。菩萨行般若波罗蜜沤和拘舍罗。见诸法无有形。便发阿耨多罗三耶三菩。舍利弗言。世尊。何等为菩萨沤和拘舍罗见诸法无有形发阿耨多罗三耶三菩。佛告舍利弗。菩萨行般若波罗蜜。亦不见诸法有形可作碍者。不见有碍当可厌者。亦不见有懈怠者。佛告舍利弗言。以无有形无有寿命。以所有皆无所有。诸法性相空。以众生蒙冥入于五阴十二衰。菩萨见诸法所有皆无所有。行般若波罗蜜自立。如幻师为众生说法。有贪嫉者为说布施福。有恶行者为说持戒福。有恚怒者为说忍辱福。有懈怠者为说精进福。乱意者为说一心福。愚痴者为说智慧福。建立众生于六波罗蜜已。转为说贤圣上尊之法。使得三乘之道舍利弗白佛言。世尊。为有菩萨耶。而言菩萨为空无众生说六波罗蜜事。令逮得三乘之道。佛告舍利弗言。菩萨行般若波罗蜜。于诸法无所得。何以故。菩萨行般若波罗蜜。亦不见众生亦不见其处。但以道数故。菩萨摩诃萨于二谛为众生说法。舍利弗。不以二谛故得众生及其处也。菩萨行般若波罗蜜。但以沤和拘舍罗为众生说法。众生现在尚不自见。何况有得道已得方当得者。是故舍利弗。菩萨行般若波罗蜜。以沤和拘舍罗为众生说法。舍利弗白佛言。世尊。菩萨者是天上天下之大士。于法中亦不见一字。亦不见若干亦不见差别。作是比要誓亦不于三界现。亦不于有为无为性现。而度三界众生。亦不见众生亦无有众生相。众生亦不缚亦不解脱亦不着亦不断。五趣各异。亦无有合亦不见坏亦不有净亦不有垢。何况当有所受五道之趣。佛告舍利弗言。如是如是。舍利弗如汝所言。假令本有众生令无有者。菩萨及佛便当有咎。假令本无五道生死之趣令有者。亦是如来菩萨咎。有佛无佛生死法常住如及尔亦常住如故。于中亦无众生亦无吾我亦无寿命亦无知见之事。何况当有五趣。是法亦无端绪。何况有五趣生死而度脱众生。舍利弗。菩萨从过去佛所。闻诸法相空故发阿耨多罗三耶三菩。亦不言我于法中有所得。假令有所得众生所入颠倒处亦不能度脱。是故菩萨作大要誓。以要誓故阿耨多罗三耶三菩终不转还。会当成阿惟三佛。以法祐利众生令从颠倒得脱。譬如幻师化作数千亿万人。以若干百种味食。皆食若干化人令饱满。令饱满已大欢喜言。我今日所作福广大。于舍利弗意云何。颇有得饱满者不。舍利弗言不也世尊。佛言。舍利弗。菩萨亦如是。从初发意以来行六波罗蜜四禅四等四空定。行三十七品法。行十八空三脱门八惟无九次第禅。行佛十种力四无所畏四无碍慧至佛十八法。具足菩萨道以净佛土教授众生。而不见法可得降化者。须菩提白佛言。何等为菩萨摩诃萨道可教授众生净佛国土者。佛告须菩提。菩萨从初发意以来。行六波罗蜜乃至佛十八法。教授众生净佛国土。须菩提白佛言。何等为菩萨行檀波罗蜜教授众生。佛报言。菩萨行般若波罗蜜自布施教人布施言。善男子当习布施。可得大富可得离生死苦。莫着所施莫着施者及其受者。是三法性空。空法亦不受亦不不受无受性空。佛言。是为菩萨行檀波罗蜜施与众生。亦不见所施物亦不自见亦不见受者。檀波罗蜜者是无所倚度也。持是三无所见法建立众生于三乘。是为菩萨摩诃萨行檀波罗蜜教授众生自行布施劝助人令布施。见人布施赞叹代其欢喜。菩萨作如是施者。得生四大姓家。得为遮迦越罗。便以四事摄取众生。一者惠施二者仁爱三者利人四者同义。是为四事。以是四恩布施。建立众生于尸波罗蜜及禅波罗蜜。建立四禅四等四空定。建立三十七品三脱门。劝助令求三乘道。教人言。善男子当逮觉阿耨多罗三耶三菩。众生所系颠倒法中无所有。当自脱于颠倒转复教人离于此缚。当自受祐利亦当祐利余众生。佛语须菩提。菩萨当作是行檀波罗蜜。作是行者从初发意已来不堕恶趣。所在常得遮迦越罗福。何以故。随其所施而受果报。有从圣王所求索者。圣王念言。我所以求作转轮王者但为众生故。语求者言我所有者尽汝所有。所有福祐皆施众生。常持大悲饶益众生。亦不见众生但以俗数有众生名名号之事。譬如响也。须菩提。菩萨行檀波罗蜜。肌肉尚不爱惜。何况外物。但欲度脱众生生死。何等外事。六波罗蜜是。乃至十八法。奉行是已度脱众生。复次须菩提。菩萨住于檀波罗蜜布施众生劝令持戒。汝持戒者我使汝无所乏。随汝所欲当给足之。人但以财故专行犯戒。汝持戒者我断汝贪。以戒因缘。三乘之法度令脱苦。复次须菩提。菩萨住于檀波罗蜜。若见众生嗔恚争者。菩萨问言。善男子汝何为争。汝等若欲有所得者。金银宝物从我取之莫得共争。菩萨于檀建立众生行羼波罗蜜。语众生言。汝等共争空无有实皆无有本。莫得争空而相贼害以成怨结。莫以空无之事堕三恶业。起怨恚者尚不得复人身。况值佛世。人身难得佛世难值。莫舍佛世而堕无极之罪。菩萨行忍劝人令忍。见行忍者赞叹欢喜。建立众生行羼波罗蜜。以三乘之法而度脱之。须菩提。菩萨住施劝立众生行羼波罗蜜如是。何谓菩萨住檀波罗蜜劝令众生行惟逮波罗蜜。佛言。菩萨见众生懈怠。菩萨问言。汝何以懈怠。众生报言。以无所因故懈怠。菩萨住檀波罗蜜语众生言。善男子。有所乏短我当给汝。汝当精进我以布施持戒忍辱。与汝作因缘。众生闻是便以身口意行精进。便具足诸善法。便得贤圣无漏之意。随其善法以三乘法令得解脱。须菩提。是为菩萨住于施与。劝助众生行惟逮波罗蜜如是。何谓菩萨住于檀波罗蜜建立众生行禅波罗蜜。菩萨语众生言。汝等何以不学禅法。众生言。我等无因不能学禅。菩萨报言。我当与汝共作因缘令汝念断。菩萨便与众生作无念因缘令其念断。便得四禅四等念三十七品。以三乘法而度脱之。至阿耨多罗三耶三佛不耗于道事。须菩提。是为菩萨住于施与劝立众生行禅波罗蜜如是。何谓菩萨住檀波罗蜜。劝令众生行般若波罗蜜。菩萨语众生言。何以不念般若波罗蜜。众生报言。无所因由。菩萨复言。我为汝等作御。汝等布施持戒忍辱精进行禅令汝等具足是事。菩萨念言。颇复有法可得人者不。众生吾我及寿命者及诸三界为可得入不。六波罗蜜三十七品为可得入不。须陀洹至罗汉辟支佛及佛为可得入不。菩萨于般若波罗蜜中住。不见诸法有可得者有可入者可得处者。得无所入已不见法有生有灭有著有断。虽无所见亦不分别。亦不言是天是人是三恶趣。亦不言是戒无戒。亦不言是须陀洹斯陀含阿那含是阿罗汉辟支佛。亦不言是如来无所著等正觉。须菩提。是为菩萨住于施与劝立众生令行般若波罗蜜。何谓菩萨住于六波罗蜜劝立众生令行三十七品。菩萨以方便摄取众生。令行四意止四意断四神足五根五力七觉意贤圣八品道。有受是者便脱于生死。须菩提。以是贤圣之法摄取众生。复次须菩提。菩萨劝恤众生言。诸贤者我长夜布施今受其福。我所有者皆是诸贤所有。欲得金银七宝衣被财谷。有所欲者我当相给足。是所有可得长夜安隐。汝等当住六波罗蜜。并劝余人令住六度。汝等当建立众生令行三十七品佛十种力及十八法。当复转教一切众生三乘之道无漏之法。须菩提。是为菩萨住般若波罗蜜。当作是教化众生令度三恶趣及生死难。复次须菩提。菩萨住于尸波罗蜜教化众生言。汝等住于犯戒之地。当为汝作净戒因缘。便行布施随其方便而诱进之。劝令众生普行十善。持是十善住于无瑕。不犯贤圣之戒。渐以三乘而得尽苦。尸波罗蜜为首如檀波罗蜜说。余四波罗蜜亦如是

    摩诃般若波罗蜜建立品第八十二

尔时须菩提意念言。菩萨摩诃萨住于何道能作无畏坚誓。佛尔时知须菩提所念便告言。六波罗蜜是菩萨摩诃萨道。三十七品及十八空八惟无九次第禅十力佛十八法。须菩提。是诸法是菩萨道。于意云何。颇有法菩萨所不学者不。若不尽学诸法者不成萨云若。须菩提白佛言。世尊。诸法皆空云何菩萨当尽学诸法。亦无所有云何作念言。是道是俗是漏无漏是有为是无为是凡愚人法。是声闻辟支佛法。云何是佛法。佛告须菩提。如是如是。诸法实空。假令诸法不空菩萨终不逮觉阿耨多罗三耶三菩。以诸法空故菩萨逮觉阿耨多罗三耶三菩。佛告须菩提。云何作是问。假令诸法空者。菩萨云何作念。是道法是俗法。于须菩提意云何。若众生知一切诸法皆空。菩萨不逮觉阿耨多罗三耶三菩。以众生不知一切诸法皆空故。菩萨逮觉阿耨多罗三耶三菩。菩萨为诸法作处为众生说法。须菩提。菩萨行菩萨之道当作是观言。诸法不可但尔空得。皆当游行。观诸法之所有亦不有所入。亦不入六波罗蜜。亦不入三十七品。亦不入三乘法。何以故。诸法所有各自空故。空亦不入空。空尚不可得。何况入空者。是故菩萨于诸法无所入。住于学法以观众生作无端绪事。菩萨念言。众生虽作无端绪事易度耳。以沤和拘舍罗住于般若波罗蜜而度脱之。语众生言。行布施者可得饶财。亦莫于财贡高。财无坚固。建立众生于戒忍精进一心智慧皆悉如是。虽住三乘者亦莫贡高。亦无坚固。菩萨作是劝助已。虽行菩萨道亦无所入。何以故。诸法无所有故。诸法无有可入处。菩萨之道无有住处。行六波罗蜜亦无所住。行四禅亦无有所住。何以故。禅者各自空。行禅者亦空。禅事亦空。四等四空定八惟无九次第禅亦无所住。得声闻法亦不于中住。何以故不住。答言。以二事不住。何等二事。答言。道无有住处。亦无能住于道者。亦不欢喜言。我当得须陀洹不于中住。我当得阿罗汉辟支佛亦不于中住。我当逮觉阿耨多罗三耶三菩。何以故。我从发意以来初不向余道。志常在阿耨多罗三耶三菩。何以故。菩萨发意已来至于十住亦不在余道。但志阿耨多罗三耶三菩。须菩提。菩萨身口意但志于道。菩萨住于道不生因缘。须菩提白佛言。世尊。若诸法适无所生。云何菩萨得生道意。佛言。如是如是。诸法无所生。诸有无所作者。便于诸法无所生。须菩提言。世尊。有佛无佛法性常住耶。佛言。如是有佛无佛法性常住。以众生不知法性常住。是故菩萨生道因缘欲度脱之。须菩提言。世尊。以生道意故得道耶。佛言不也。不生道意得耶。佛言不也。亦从不生不灭得耶。佛言不也。若不尔者以何因缘得道。言道亦不从度亦不从不度。须菩提。道则是度度则是道。须菩提言。若道则是度度则是道者。菩萨为已逮道为已得度。云何言是如来三十二相八十种好十种力四无所畏四无碍慧四等四空定佛十八法。佛告须菩提。于意云何。佛为逮道耶。言不也世尊。佛则是道道则是佛。须菩提。云何作是言。菩萨为逮道菩萨具足六波罗蜜具足三十七品以具足十力四无所畏四无碍慧四禅四等具足十八法。于金刚三昧一相之智逮得阿耨多罗三耶三菩。以是次第故名为如来。于诸法得自在。须菩提白佛言。世尊。菩萨云何能净佛土。佛言。菩萨从初发意已来常净身口意。并化余人净身口意。须菩提言。世尊。何等为菩萨身行恶口言恶意念恶。佛言。菩萨身口意犯十恶。嫉妒犯戒嗔恚乱意懈怠恶智。须菩提。是为菩萨意念恶。戒不净是亦为恶。离三十七品离三脱门是亦为恶。近须陀洹道至辟支佛是亦为恶。是为菩萨之恶行。复次须菩提。菩萨有五阴十二衰相是亦为恶。有男子女人之相有三界相有善恶相有有为无为之相。是为菩萨身口意恶。是故菩萨舍众恶已。自行六波罗蜜。亦劝进人使行六度。持是功德。与众生共求佛国净。自持三千大千国土其中七宝。施与三尊作誓愿言。令我国土其中所有尽是七宝。复次须菩提。菩萨以持伎乐乐佛世尊。及精舍讲堂。复誓愿言。令我佛国常闻天乐。须菩提。菩萨以三千大千刹土所有众香施于三尊复誓愿言。使我佛土常有天香。复次须菩提。菩萨持百味之食供养如来及弟子众复誓愿言。我作佛时诸弟子众饮食自然百味之饭。复次须菩提。菩萨以涂身之香。施佛及众复誓愿言。我作佛时使我国人身体。细滑香洁皆如天身。复次须菩提。菩萨诸世所有五乐善愿。施佛及众复誓愿言。我作佛时令我国土一切众生。随意所愿五乐善愿皆令得之。复次须菩提。菩萨行般若波罗蜜复誓愿言。自行四禅四等及四空净。劝助众生令行四禅四等及四空净。自行三十七品复劝众生普令行之复誓愿言。我作佛时我国众生皆悉不离四禅及四空定三十七品。须菩提。是为菩萨能净佛土。菩萨行道满足诸愿。诸愿不具终不止行。自具足诸善法。亦复满足众生善愿。作是劝教行者身得百福功德之相。诸受教者亦复如是。是故菩萨净佛国土。何等为净。亦无三趣处无有邪见无淫怒痴。无有二地之名。无有无常无我苦空。无有家业亦无吾我。无有伺便处。无有果报处但闻空无相无愿之声。所闻内外音声譬如风过。所出音声如诸法之相。有佛无佛诸法常空。空者无相无有相者亦无有愿。所出音声其教如是。昼夜卧觉若坐若行常闻是音声。成阿耨多罗三耶三菩时。其刹如是。十方诸佛称叹其佛功德名字。一切众生闻佛名者。必至阿耨多罗三耶三菩。尔时如来普说法时。其有闻者无有狐疑是法非法。所以者何。诸法之法无有非法皆是正法。诸无德者亦于佛及弟子众不种善本。又亦不与真知识会。便作吾我见。有吾我已便入于六十二见。入诸见已便住边际。住边际已便著有常。著有常已便着既尽。于不平等有等觉想。于平等觉更无觉想。法言非法非法言法便诽谤法。诽谤法已便坏人身。坠其恶趣堕泥犁中。菩萨诸佛得成阿耨多罗三耶三菩已。乃度脱之。得度脱已。甫当建立三乘法不复堕恶趣。须菩提。是则为菩萨摩诃萨净佛土。净佛土已一切众生亦无是法。亦无非法有漏无漏有为无为。必至阿耨多罗三耶三菩

    摩诃般若波罗蜜毕竟品第八十三

于是须菩提白佛言。世尊。云何菩萨摩诃萨为毕竟耶为不毕竟。佛报言。菩萨摩诃萨为毕竟不为不毕竟。世尊。为毕竟何乘。报言。不毕竟于二乘毕竟于佛乘。世尊。毕竟佛乘者。是初发意菩萨耶。是十住菩萨耶。佛报言。初发意菩萨亦毕竟。阿惟越致亦毕竟。十住菩萨亦毕竟。须菩提言。世尊。毕竟菩萨趣恶趣不。佛言不也。于须菩提意云何。四双八辈至辟支佛为生恶趣不。对曰不也。佛言。菩萨初发意行六波罗蜜诸恶则灭。若生恶趣是事不然。亦不生长寿天亦不生边地无佛法处不生邪见家。若生彼处是亦不然。终不生无道见家。须菩提。新学菩萨发阿耨多罗三耶三菩意者。终不复犯十恶之事。须菩提言。世尊。若有菩萨能于一法便为具足不随恶者。云何世尊。自说宿命所可经历。或堕鹿中堕猕猴中马中象中亦遭勤苦。是事云何。佛告须菩提。菩萨不作恶行自生恶趣。随众生方便而受其身。欲祐利众生故。佛问须菩提。声闻辟支佛颇有是沤和拘舍罗。入畜生中度脱众生。还为所害其意不起。以大慈大悲续度如故。汝诸声闻颇有是不。以是故。当知菩萨具足大慈。以沤和拘舍罗入畜生中。救护众生成阿耨多罗三耶三菩。须菩提白佛言。世尊。菩萨住何等善本功德法。能得是辈随意形像。佛报言。于诸功德法皆当具足成就。尔乃成阿耨多罗三耶三菩。从初发意至坐道场。无有善法不具足者成阿惟三佛。菩萨发意当学具足诸善功德。作是学已当逮萨云若尽诸习绪。须菩提言。世尊。菩萨具足善法尽得贤圣无漏之法。而生恶趣至畜生道耶。佛问须菩提。如来者为是贤圣无漏法不。须菩提言是也。佛言。如来为自化作畜生像而作佛事耶。尔世尊。如来者化作畜生像而作佛事。佛言如是。如来为是畜生。受畜生苦耶。言不也。世尊不受诸苦。佛言。菩萨以受贤圣无漏之法。善权变形教化众生。如阿罗汉能变化作罗汉事。令众生欢喜不。须菩提言。世尊能尔。佛告须菩提。菩萨已受具足贤圣无漏之法。随众生意而受其形。为众生作福田亦不受形苦。佛语须菩提。譬如幻师或现象马若干变化。于意云何。是象是马不。言不也世尊。非象马也。菩萨如是以沤和拘舍罗祐利众生。随类而入而教化之。以是故。不复受众苦之恼。须菩提白佛言。世尊。菩萨摩诃萨者善于大方便。所以者何。谓菩萨具足贤圣无漏之慧。所在所在随其习俗形貌之法。安立众生而为作本世尊。菩萨住何善法。乃能作是善权方便不与同趣。佛言。菩萨住于般若波罗蜜者。能作是沤和拘舍罗。持是方便为十方恒沙众生作本。而不与同归。何以故。亦不见法有能近者。亦无有法而污染者何以故。诸法所有皆空故。是故空不污染空。空亦不污人。人亦不污空。何以故。空空不可得。是故无所得空。菩萨住于无所得空成阿惟三佛。须菩提言。世尊。菩萨但住般若波罗蜜不复住余法耶。佛告须菩提。诸法颇有不入般若波罗蜜者不。须菩提言。世尊。世尊自说般若波罗蜜空无所有。云何诸法入般若波罗蜜中。世尊。空亦无所入亦不不入。佛报言。云何诸法不入诸法空耶。须菩提言。世尊。实空。若诸法空者。诸法亦不入空。须菩提言。菩萨行般若波罗蜜。云何住于空具足神通之慧。以神通慧过东方恒沙刹土见诸如来。殖众善本听受法教。佛报言。菩萨行般若波罗蜜。见恒边沙诸佛皆空。但以名号示现其处。诸假名号之处皆空。若诸刹土诸佛不空者空为有偏。以空不偏故诸法皆空。是故菩萨行般若波罗蜜。以沤和拘舍罗具足神通。便得天眼天耳神足知他人意。自知所从来生死之事。菩萨不得神通者不成阿耨多罗三耶三菩。是故般若波罗蜜是菩萨摩诃萨之道。当作是求道。以道天眼自见诸善之法。并见余人住于善法。亦不入善法。何以故。诸法皆空。空无所入亦无有入空者。亦无乐空者空亦无所乐。是故菩萨行般若波罗蜜。以得天眼见诸法空。若无是法亦不能作佛事为众生说法。亦不得众生之处。以应无所得便得神通。所应作者便能作之。菩萨天眼见诸十方。飞到诸刹祐利众生。或以六度。或以三十七品。或以诸禅惟无。或以空定。或以声闻辟支佛法。或以菩萨法。或以三耶三佛法。为贪嫉者说施之德。说贫苦之法。贫者世间之苦尚不能自饶益身。何能益余。是故贤者当念惠施。既自安隐复安余人。莫以贫故转相食啖。而不能得离三恶趣。为犯恶者说戒法言。为恶者苦身自陷恶何能安余。犯恶之报不离三苦。汝等自堕三恶趣中那能拔余。是故仁者不当恣意。莫随恶趣后自烧身。若见众生有嗔恚意相贼害者。为说法言。汝等莫争莫随恚意入三恶趣。为懈怠者说精进法。为乱意者说禅定事。为恶智者说智慧法。淫者为说欲之不净。有邪见者指示正道令住三乘。为说法言。诸仁者所入者。皆无所有空无之法。亦不可入空无所入。须菩提。菩萨行般若波罗蜜住于神通。为众生作善本。菩萨不住神通不能为众生说法。譬如众鸟无有翅者不能高翔。菩萨如是。不住神通者亦不能为众生说法。是故菩萨行般若波罗蜜当学神通。已得神通便能祐利一切众生。以天眼见恒沙国土。尽见众生悉知其意。随高下应而为说法。或说六波罗蜜或说泥洹法。菩萨天耳闻一一音声。又闻东方恒边沙佛所说教法。广为众生说如所闻随意为说。或说六度或说泥洹。以清净意知众生念。自知本末所从来生及他人事。以是通慧忆识。过去诸佛如来弟子名号皆悉识知。又知众生宿命所行而为说法。或说六度或说泥洹。复能飞到恒边沙刹土。往见诸佛殖诸善本。复还本土净漏尽之慧。复以是慧为众生说法。或说六度或说泥洹。须菩提。菩萨行般若波罗蜜。当知神通如是。得净神通已随意所欲能变其形。三界苦乐不能污染。譬如佛所化人在所能办无有苦乐。须菩提。菩萨摩诃萨行般若波罗蜜。游戏神通净佛刹土教化众生。不具神通。不能教化净佛国土。菩萨不净佛国教化众生者。终不成阿耨多罗三耶三菩。菩萨支节不具足者。便无有道。须菩提白佛言。世尊。何等为菩萨支节具足。而成阿耨多罗三耶三菩。佛报言。诸所善法是菩萨支节。何等善法是菩萨支节。报言。从发意已来行檀波罗蜜中诸善法。不晓施为不能分别。于中生念是者可与是不可与。分别及念皆空无有。持是具足波罗蜜。自度彼岸复度他人。度脱众生于生死。是为菩萨阿耨多罗三耶三菩善法支节。过去当来今现在菩萨从是得度。亦复持是度脱众生。六波罗蜜亦复如是。四禅。四等及四空定。三十七品。十八诸空。八惟无。九次第禅。陀邻尼门。四无碍慧。佛十八法。是诸善法者。菩萨道之径路。具足是已便逮萨云若。逮萨云然已便转法轮

    摩诃般若波罗蜜分别品第八十四(丹本作分别四谛品)

须菩提白佛言。世尊。假令是法是菩萨法者。佛法复云何。佛报言。以是法具足者。便逮萨云若慧尽诸习绪。菩萨摩诃萨便尽逮觉是菩萨法。佛法者以一相慧应一切慧。而得正觉。是者佛法与菩萨法而有差特。须菩提。譬如向道已得道者。是二辈者皆是贤圣。菩萨住于两际中间。佛以过去如来无所著等正觉。以是差别。须菩提言。世尊。假令如佛所言者。空无之法为有差别有若干品耶。而言是者泥犁薜荔畜生。是者人道是者天道是者八数是者辟支佛是者菩萨是者为佛。如是诸道无所有。行亦无所有。如行无所有者罪福之报亦无所有。佛言。如是如是。须菩提。如汝所言空无之法亦无有行亦无有得。须菩提。不知空无之法者。或作善恶之行有漏无漏。由行所致便有三恶趣。作善行者便有天道人道。于三界中无断绝时。菩萨行六波罗蜜乃至佛十八法。行菩萨法亦无有瑕。是为具足菩萨支节。金刚三昧成阿耨多罗三耶三菩阿惟三佛。为众生作厚。其厚者终不腐败而生五道。须菩提言。世尊。成阿惟三佛时。为见五道生死耶。佛言不也。须菩提复问。如来为不见善恶法耶。佛言不也。世尊为不见善法耶。佛言不也。世尊亦不见善亦不见恶耶。佛言不也。须菩提言。若不以是四句。云何处有天道人道是三恶道。云何处有声闻辟支佛道处。有菩萨处有佛道。佛问须菩提。众生为知诸法相空不。若众生知诸法相空者。菩萨终不发阿耨多罗三耶三菩意。亦不能度众生令离恶趣。以众生不知诸法相空故。不能得离五道。菩萨于诸佛所闻诸法相空。是故便发阿耨多罗三耶三菩。凡夫所入之法如来无复有众生。不解空法所作各自得之。无有众生有众生相。无有五阴有五阴相。于无为作有为相。自无所有作颠倒想。以身口意所作颠倒。便堕五趣不能得脱。菩萨行般若波罗蜜。持诸善法皆内于般若波罗蜜行菩萨行以成阿惟三佛。持四谛法广演分别令众生习之。诸善之法三十七品四谛。便有三尊。其有众生因三尊者。无不得脱离诸勤苦。须菩提白佛言。世尊。众生得度为用四谛用四谛慧耶。佛报言。亦不以四谛得度。亦不以四谛慧得度。我说于四谛得等觉者。乃为度脱耳。复问。世尊。何等为四谛之等。报言。亦无苦亦无苦慧。亦无习亦无习慧。亦无尽亦无尽慧。亦无道亦无道慧。以四谛如及尔亦不变异法性之法。真际法事有佛无佛常住如故。是法不忘不失于诸法不耗减。菩萨行般若波罗蜜行四谛逮四谛慧。亦当作是觉。复问。世尊。菩萨行般若波罗蜜。云何行四谛而觉四谛。以觉随行亦不堕二地而上菩萨位。佛报言。诸法之要不可得见。正使得见亦无所有。既无所有见诸法皆空。在四谛者不在四谛者皆空无所有。作是见者便上菩萨位于种性住。住种性已。不与上争不堕二地。以住种性便起四禅四等及四空定。住灭尽定览知诸法知四谛慧。不生苦习尽道因缘。但起道意想观见诸法如。须菩提言。云何观见诸法如应。佛报言空。云何为空。报言。如自观身相空。作是比观者为见诸法空。不见有法逮觉道者。道者无所有。亦非佛所作。亦非罗汉辟支佛所作。亦非行菩萨者所作。一切众生不审是事。是故菩萨摩诃萨行般若波罗蜜。以沤和拘舍罗。为众生说法

    摩诃般若波罗蜜有无品第八十五

须菩提白佛言。世尊。假令诸法所有无所有。非佛所作亦非罗汉辟支佛及菩萨所作。云何有诸道分数善恶之差别。有三恶趣及于人道。从四天王上至长寿天高下之殊异。云何复言作是得是。行恶者入三恶趣。行善者得生人道。或生天上。云何行道得须陀洹至得阿罗汉辟支佛。作是行得菩萨法。作是得三耶三菩。世尊。无所有法者。亦无作亦无行亦无声闻辟支佛行。无有菩萨行亦无有三耶三佛行。亦无逮萨云若而度脱众生者。是事云何。佛报须菩提。如是如是。无所有者亦无作亦无行得。凡夫愚闇不能得知贤圣之法。又亦不知所有无所有之法。为四颠倒之见侵欺。作若干行得若干报。便有五趣生死。无所有法亦无有行亦不受。于须菩提意云何。须陀洹乃至阿耨多罗三耶三菩。为有所有不。须菩提言。世尊。从须陀洹乃至于道。皆无所有。佛告须菩提。无所有能逮无所有法不。对曰。不也世尊。是故须菩提。无所有及道一切诸法。亦不合亦不散。无有形不可见亦无对一相。一相者是无相。是故须菩提。菩萨摩诃萨行般若波罗蜜沤和拘舍罗见。于众生入。于颠倒入。于五阴无常有常想。苦谓有乐想。无我有我想。不净有净想。入于有为。菩萨以沤和拘舍罗。令众生离于有中。须菩提白佛言。世尊。众生所入不离五趣。有何因缘碍。颇有实要不。佛报须菩提。无有无有余行如毛发者。但以众生着四颠倒故有五趣耳。须菩提。谛听谛听。以是事故我今说之使汝得解。于意云何。梦中所见五乐自娱。有作者不。对曰。世尊。梦尚无所有。况有五乐。佛言。于汝意云何。诸法有为无为有漏无漏。颇有法不如梦者不。答曰。世尊。一切诸法皆如梦耳。无有诸法不如梦者。佛言。于意云何。梦中所见人颇有五趣不。无也世尊。须菩提。梦中人颇有道念有着断事不。对曰无有。何以故。世尊。无形之法无所造处。着断之法亦无有处。云何须菩提。镜有见像。颇为有行颇有五趣生死报不。对曰。不也世尊。所以者何。镜中像者无所有也。凡夫为惑自呼所有。镜中像者亦无五趣无作无行。须菩提。镜中像为有道念有着断不。对曰无有。所以者何。无形之法无所造作。亦无著断亦无有处。佛言。于须菩提意云何。响从山谷出。是响颇有行作生五趣者不。对曰不也。何以故。无形之法无行无作无生五趣者。于须菩提意云何。响颇有道念有着断不。对曰无有。所以者何。无所有之法无所造作。亦无著断亦无有处。于须菩提意云何。譬如热时之焰。无有河水有河水想。无有城郭有城郭想。无有园观有园观想。于意云何。是焰宁有所作有五趣不。对曰。焰无所有。但惑愚夫之眼但有像耳。须菩提。是焰颇有道念有着断不。对曰无有。无形之法。无所造作无有着断亦无处所。须菩提。譬如幻师化作象马。或作人众若干种现。是化人颇为有行有五趣不。对曰无有。何以故。幻无形故。须菩提。幻人所化颇有道念有着断不。对曰无有。无形之法无所造立。亦无著断亦无处所。须菩提。如来所化宁有行作有五趣不。对曰无有。何以故。化无所有故。须菩提。化有道念有着断不。对曰不也。无形之法无有道念亦无著断亦无处所。于须菩提意云何。是诸法颇有着断不。对曰不也。无有着断。佛言。假令无著断者是为无有着断。何以故。众生但住于吾我便有着断。审见谛者不着不断。众生所见不审谛故。便有着断

放光般若经卷第十九放光般若经卷第二十

        西晋于阗国三藏无罗叉奉　诏译

    摩诃般若波罗蜜诸法等品第八十六

须菩提白佛言。世尊。其审谛者不着不断。不审谛者亦不着不断。所有无所有无著无断。审谛不审谛俱不着不断。是事云何。佛报须菩提言。以诸法等故我言断。世尊。是何谓。佛报言。有佛无佛如及尔法性真际法事。初不变异常住如故。是名为断。但以俗为名号有言有教。俗之音声虽有言教皆无所有。须菩提言。世尊。假令诸法如梦如响如镜中像如野马如幻如化者。菩萨云何于空无之法发阿耨多罗三耶三菩意。言我当具足六波罗蜜。具足神通。具足慧度四禅四等及四空定三十七品及三脱门。具足八惟无九次第禅。言当具足十力佛十八法。言当具足三十二相八十种好。言当具足陀邻尼门。云何言我当作光明普照窈冥之处。云何知众生意如为说法耶。佛言。须菩提于意云何。如汝所问。为如幻如化不。须菩提言。假令诸法如梦如幻。菩萨云何行般若波罗蜜。世尊。梦以幻化非真实者。不真实法不能行六波罗蜜。乃至十八法亦不能行。佛言。如是如是。如汝所言。梦化不行六波罗蜜。不能成阿耨多罗三耶三菩。是法皆为是有为想法。有为想之法亦不可得萨云若。是法亦复是道亦复是泥洹。以是法无所生无有相。以是故。菩萨初发意以来习诸善法。六波罗蜜乃至十八法。知是法以如梦如化。不具足六波罗蜜十八法者。亦不能教化众生。菩萨习诸善法。观诸法如梦如化。菩萨观般若波罗蜜。观萨云若。观众生亦复如梦如化。菩萨行般若波罗蜜不于中受形。及幻化法不于中受形。言当逮萨云若。菩萨行般若波罗蜜无所取。于十八法亦无所取。菩萨知诸法无所取故。逮阿耨多罗三耶三菩。何以故。诸法无形故。无所取不可持。无所取法而有所得。亦不见是法。是故菩萨为众生故发阿耨多罗三耶三菩。从发意以来行六波罗蜜。但为一切不自为身。菩萨起阿耨多罗三耶三菩意者。但为众生故。以众生无所有。以众生有众生想。不见有见想不知有知想。是故菩萨于颠倒中拔出众生。于甘露地断诸习想。须菩提。菩萨行般若波罗蜜以沤和拘舍罗。于诸法无所入。建立众生于无所入。但以俗数非第一义。须菩提言。世尊。如来所逮觉法。为以世俗数为以第一义。佛报言。如来者以俗数得逮觉。亦无有法有所得者。所以者何。若言我得道者是为大耻。若有二者亦无逮亦无觉。复问世尊。假令有二不逮觉者。为从一得逮觉耶。佛报言。亦不从二亦不从一。逮觉者亦不一亦不二。不一不二则是逮觉。所以者何。逮觉者为戏则为贡高。等觉者无戏亦无贡高。须菩提言。世尊。诸法所有皆无所有。云何是等正觉。佛报言。亦不有有亦不无无亦无言说。是则等觉。等觉法者亦无言说。亦无有法说等觉者。等觉者以过于诸法。凡夫愚人去等觉远。复问。世尊。如来为离觉法远耶。佛报言。等正觉者非众圣贤声闻辟支佛菩萨及佛之处。复问。世尊如来于诸法中得自在耶。佛报言。凡夫之等及声闻辟支佛及如来皆共一等觉。一等觉者亦无有二。亦无凡夫亦无三耶三佛。乃至如来亦无若干。须菩提言。世尊。假令于等觉中无有分数者。凡夫声闻辟支佛无有差别。佛言。如是如是。凡夫乃至三耶三佛无有差别。假令凡夫乃至三耶三佛无有差别者。何以故有三尊。佛言。于须菩提意云何。佛宝法宝比丘僧宝等觉异耶。对曰。如我从世尊所闻。三宝及等觉无有异。三宝及等觉亦不合亦不散。无有形亦不可见。一相无相为无相法。作数作处者则为有近有处。佛告须菩提。如来无所著等正觉。得阿耨多罗三耶三菩时。为诸法作处。便知有三恶趣知有人道知有三十三天。便知三十七品乃至内外空及所有无所有空。知有十八法。是故须菩提。是为如来大士之所差特。不动于等觉法为诸法立处。须菩提言。世尊。如世尊于等觉不动耶。凡夫声闻辟支佛于等正觉亦复不动。佛法凡夫法声闻辟支佛法及如来法为一法耶。及无形法色法痛想法行法识法异耶。眼法耳法鼻法舌法身法意法有异耶。地水火风识空法有异耶。淫怒痴法有异耶。六十二见有异耶。四禅四等及四空定法有异耶。三十七品法三脱门法内外空及所有无所有空法。八惟无九次第禅四无畏四无碍慧十力。佛十八法有为无为法。是诸法皆有名。云何处不可得。若菩萨不住是处不分别诸法。菩萨终不能行般若波罗蜜。行般若波罗蜜菩萨游诸十处。尔乃上菩萨位。便过二地。已过二地具足神通。于诸神通具足五波罗蜜。游诸佛刹供事诸佛殖众善本。持是功德教化众生净佛国土。佛告须菩提。汝所问。如来及凡夫法及二地法。云何作是问。于汝意云何。五阴空法及如来法为有异耶。须菩提言等空。佛言。于空可见无相法不。五阴相及佛相为可见不。须菩提言。世尊。不可见也。是故须菩提。诸法之法亦无有。凡夫亦不离凡夫。亦非如来法。亦不离如来法。复问。世尊。是法为是有为法为是无为法。佛言。亦不离无为而得有为法。亦不离有为法而得无为法。须菩提。有为法无为法一法无二。亦不合亦不散。无有形不可见一相。一相者无相。以俗数故有所作耳。非最第一义。最第一义非身口意所作。亦不离身口意。得第一义以诸法之等。是故第一义菩萨行般若波罗蜜。亦不得最第一义而行菩萨事

    摩诃般若波罗蜜诸法妙化品第八十七

须菩提白佛言。世尊。假令诸法等空于诸法无所作。云何菩萨行般若波罗蜜。不得最第一义而行菩萨事。为众生作四恩耶。佛告须菩提。如汝所言。空者亦无有作亦无不作。若众生知空者无有如来及佛境界。不动于空度诸吾我有四大相。度诸五阴有知见相。度诸十二衰相。度诸有为相。建立不有为界。是不有为之性空。云何为空。佛报言。于诸相空。幻师所化作人空。不幻化及空不合不散以空空。空空及化人无能别者。何以故。俱空故。须菩提。五阴无不空者。以空故作是说言五阴空。复问。世尊。世俗之法如幻。道法亦复如幻耶。假令道法是幻者。从三十七品乃至佛十八法及三乘法亦复如幻。行三乘者亦复如幻。佛报言。是诸法化谁所化。为是声闻辟支佛所化耶。是菩萨佛之所化耶。是诸习绪所化。是行所化。对曰。无有化者。佛言。是故诸法如化。复问。世尊。须陀洹至罗汉辟支佛所灭。及佛诸习绪灭。亦复如化耶。佛报言。诸有所生者灭者。皆悉如化。复问。世尊。何等法不如化者。佛报言。不起不灭是则非化。复问。世尊。何等不起何等不灭非是化耶。佛报言。泥洹非化。须菩提言。世尊。常说空不动转。无有双法无不空者。是故泥洹亦复如化。佛言。如是如是。一切皆空。亦非声闻辟支佛所作。亦非菩萨佛之所作。审空者是泥洹。复问。世尊。于空过去人行。当云何入云何学云何说。佛报言。于须菩提意云何。但有过去世。无有当来世耶

    摩诃般若波罗蜜萨陀波伦品第八十八

佛告须菩提。菩萨摩诃萨欲求般若波罗蜜者。当如萨陀波伦菩萨。今现在在雷音如来无所著等正觉佛所。常修梵清净之行。须菩提白佛言。世尊。萨陀波伦菩萨云何求般若波罗蜜。佛报言。萨陀波伦菩萨求般若波罗蜜时。不惜身命不望供养不求名称。常在寂处闻空中之声。言住善男子莫起疲厌睡卧之意。莫念食饮莫念昼夜莫念寒热。莫令意着于内外。莫左右顾视。行时当作是意。当如不行。于身五阴莫有起相。何以故。有起相者便于佛法有稽留碍。有留碍者便在生死苦。在生死苦者不能逮得般若波罗蜜。尔时萨陀波伦报空中声言。我当从教。何以故。我欲为众生而作大明广宣佛法。我欲得阿耨多罗三耶三菩。作是语已便闻空中声。言善哉善哉。善男子。欲闻于空无相无愿之法。当求索般若波罗蜜。当离相念。当离命见。当离人见。当远离恶知识。当与善知识从事。当供养真知识。当为汝说空无相无愿之法。当说无生不灭之法。当劝助人求萨云若。作是行者闻般若波罗蜜不久。或从经中闻。或从菩萨摩诃萨口闻。善男子所从。得闻般若波罗蜜处。当视其人如世多罗。汝于法师当修反复莫得背恩。所从闻般若波罗蜜处则是真知识。得闻经已便得阿耨多罗三耶三菩不复动转。当自念言。我去诸如来无所著等正觉不远。所生之处常值诸佛。常当远离八不闲处。当得八乐之处。持是德行当敬法师如敬世尊。莫以世俗翼望之意。于法师所当起法想恭敬之想。冀望想者当知魔事。若魔波旬或持五乐。或以细滑色声香味来贡法师。法师以沤和拘舍罗。欲度众生能为受之。汝若见者莫起污意。但当念言。我未得是沤和拘舍罗。如法师所行。菩萨已逮沤和拘舍罗者无所挂碍。譬如金刚无所不入不受尘垢。当以一调法行而观法师。何等为一调法行。谓诸法无著无断。何以故。诸法皆空无我无人寿命。譬如幻化热时之焰。当作是观。法师导师作是观者。令得般若波罗蜜不久。善男子当护魔事。善男子若至法师所不见法师莫起碍意。当以法故恭敬法师。尔时萨陀波伦闻空中声已于是东行。东行不久意中念言。向者不问。我当于何去去是几所当从谁闻。于是大哭。哭已念言。我今于是不复饮食不复动转。从一日至七日。不闻般若波罗蜜终不起。佛告须菩提。譬如长者有一子其子而死。父母悲哀无复他念但念其子。须菩提。尔时萨陀波伦一无复余念。但念般若波罗蜜亦复如是。作是哭时。于前便有如来之像。三十二相八十种好。其佛叹言。善哉善哉。善男子。过去诸如来无所著等正觉行菩萨时。索般若波罗蜜亦如是。持是勇进之意从是东行。去是二万里。国名香氏。其城郭以七宝七重。绕城池水周流十重有七宝树罗列重行。及七宝堑。其城纵广四百八十里。其国丰乐人民炽盛。所有服饰珍宝异妙。其城中有五百栏楯。街巷市里行伍相当。以诸杂宝金银错涂悬缯幢幡。譬如天锦城上台观楼阁。陴[阿-可+兒]皆七宝作。城上宝树行列奇好。复以阎浮檀金为交露盖。以七宝铃悬其楼阁。风起之时吹其铃声。其音和雅譬如天乐。其有众生闻铃音者以自娱乐。绕城池水冷暖和适常满不减。其池水中有七宝船。其人乘船游戏池水中。其人宿命有福功德而得致是。其池水中有波昙花分陀利花拘文罗花优钵利花。复有余花杂种异色数千百种。三千大千国土所有妙花无不在彼。顺绕其城各有五百庐观。亦七宝作姝好严事。一一庐观有五百池水。其池纵广各二十里。亦以七宝杂色妙花。其花大如车盖。其花五色青黄赤白红各自分明其池中有凫雁鸳鸯孔雀鵁鶄。异类奇鸟数千百种。其城庐观所有宝物亦无有主亦无守者。以其国人宿福所致。常习行般若波罗蜜故。是以长夜受是福德。善男子。彼有菩萨名法上。在其国中央有宫殿舍。广纵四十里皆以七宝。作宫墙七重。所有栏楯七宝之树。园观浴池亦复七重。其楼阁栏楯宫殿门合。皆是七宝雕文刻镂七重。法上宫里有四庐观。一名常乐二名除忧三名杂花四名杂香。一一庐观有八池水。一名曰贤二名贤妙三名日乐四名妙乐五名吉祥六名吉上七名曰除八名不还。其池四边边各一宝。金银琉璃水精。纯以紫磨黄金为底。以金罗网为盖。其一一池中金为梯陛。种种杂色车磲玛瑙众宝杂成。其梯陛两边。复以紫金为芭蕉树。其花柔软随风委靡。其池水中亦有杂花如上所有。顺池水边又有花树。风吹诸花堕池水中便如根生。其池水香如天栴檀。法上宫中有六万八千夫人婇女围绕娱乐。香氏城中男女皆来会。于常乐池观共相娱乐。其化佛言。善男子。是法上菩萨与其眷属共相娱乐。以三时说法。香氏城中众人。为法上菩萨施设法座。于城中央金银水精琉璃为座。细软劫波育以为其蓐。以天杂香而着其蓐。其座高十里。当其座上有诸男女把持垂珠。又散名花烧诸名香。何以故。敬于法故。法上菩萨坐其座上。以般若波罗蜜为众生说法。化佛复言。善男子。香氏国人恭敬奉事法上菩萨其像如是。有若干百千诸天。来会听受般若波罗蜜。中有书者中有讽者中有口受者中有念者中有寂然念行之者。国中众生皆是阿惟越致。于阿耨多罗三耶三菩不复动还。善男子。汝从是东去到法上菩萨所。可得闻般若波罗蜜。是法上者是汝前世真知识也。常劝助汝于阿耨多罗三耶三菩。法上菩萨本求般若波罗蜜时亦如汝。今往善男子。昼夜莫断于念。得闻般若波罗蜜不久。尔时萨陀波伦。闻是语已踊跃欢喜言。我何时当得见法师从受闻般若波罗蜜

佛告须菩提。譬如有人被重毒箭无有余念。但念言。我何时当得良师拔我毒箭令其处愈。萨陀波伦无复余念。但欲得见法师从闻般若波罗蜜。闻般若波罗蜜已灭诸倚着。尔时萨陀波伦菩萨。即见诸法无挂碍慧。得无量三昧门。其三昧名曰见诸法所有三昧。于诸法无所得三昧。降伏诸无智三昧。得诸法无差别三昧。得于诸法无变异三昧。诸法无所有无所聚三昧。灭诸冥三昧。于诸法次第无异三昧。于诸法无所见三昧。散花三昧。得如是比无量种种三昧门。住是三昧已见诸十方无央数佛。以般若波罗蜜为诸菩萨说法。尔时十方诸佛皆赞叹言。善哉善哉善男子。我等本为菩萨时。索般若波罗蜜。亦复住是三昧所得如是。得是三昧已入于般若波罗蜜亦复如是。便成就沤和拘舍罗立于阿惟越致法。我等得是三昧时。亦不见有法行三昧者离三昧者。亦不见行道者。亦不见逮阿惟三佛者。般若波罗蜜者无有贡高。善男子。吾等住于不贡高故。得金色身三十二相无限之光。得不思议慧最无上觉三昧佛智。具足逮诸功德。诸佛所不能平量不能尽说。何况声闻辟支佛。是故善男子。于是法中当倍加敬。善男子。有志有进得阿耨多罗三耶三菩亦无有难。善男子。于真知识当起恭敬爱乐之意如视世尊。菩萨得真知识者。疾得阿耨多罗三耶三菩。尔时萨陀波伦菩萨白诸佛言。我常所敬真知识者为是何谁。诸佛报言。法上菩萨世世常以阿耨多罗三耶三菩用教授汝。法上菩萨常以般若波罗蜜。具足沤和拘舍罗。是者则是汝之尊师是真知识。卿善男子。取法上菩萨以顶戴之。从劫至劫若至百劫。以三千大千刹土所有以用供养。尚未能报须臾之恩。闻是尊法其福难报。使汝得般若波罗蜜沤和拘舍罗之利故。是诸如来无所著等正觉。说是已忽然不现。尔时萨陀波伦于三昧起。四向顾望意自念言。是诸如来从何所来去至何所。作是念已惆怅不乐。复更念言。法上菩萨常行般若波罗蜜沤和拘舍罗。总持诸陀邻尼门。于诸法得自在。已从过去佛而作功德。是我真师我当以问法上菩萨。是诸如来从何所来去至何所。于是萨陀波伦菩萨。念法上菩萨恭敬爱乐豫加谦恪。今我又贫无有珍宝香花奇异贡尊之具。以般若波罗蜜故供养法上菩萨者。不可空往至法上所。我有恭敬而无所有。不如卖身供养般若波罗蜜及师。前后以来坏身不少。今故不灭。前后坏身坐淫怒痴。更诸苦痛亦不为法亦不为师。但为贪欲五阴六衰。尔时菩萨道迳一城大唤呼言。我欲自卖谁欲买我者。时魔波旬意自念言。今是菩萨用般若波罗蜜故。自卖其身欲以供养法上菩萨。欲得闻般若波罗蜜沤和拘舍罗。菩萨云何行般若波罗蜜疾得阿耨多罗三耶三菩。闻已必当恭敬稽受。我不败坏者。当教无数百千菩萨及诸众生过我境界。今我当往坏之。波旬即使举国男女不见其形不闻其声。尔时萨陀波伦卖身不售愁忧啼哭言。我甚为剧欲自卖身供养于师而不能售。时释提桓因意念言。今是菩萨以般若波罗蜜故欲供养法上菩萨。我今试往看视其人。为用法故颇有谀谄。时释提桓因化作年少梵志。至菩萨所问萨陀波伦言。善男子。何以不乐愁忧啼哭。报言。年少我用法故。欲自卖身供养尊师而永不售。无问我者是以哭耳。自念薄德无财宝物可供师者。尔时年少谓菩萨言。我不用人。我今祠祀。欲得人血。欲得人髓。欲得人心。能与我者益与卿宝。是时菩萨欢喜报言。我得善利。年少。买我心髓及血。与我财宝得供养师。使我得闻般若波罗蜜及沤和拘舍罗真得我愿。年少重问言。卿卖髓血及心为索几许。菩萨报言。随年少意与我多少。萨陀波伦便以右手自刺左臂出血与之。复欲破骨出髓时。城中有一长者女。过于魔行魔不能屈。时长者女。于楼观上遥见菩萨乃尔自刑。我今当下问其意故。时长者女即下来到菩萨所。问言。男子。何为乃尔酷毒自割用是血为复欲破骨。萨陀波伦报长者女言。欲与少年卖得财宝供养于师。欲闻尊经般若波罗蜜。时长者女语菩萨言。供养于师当得何等奇特功德。菩萨报言。师当教我般若波罗蜜沤和拘舍罗。语我菩萨所行法。则我当得学为诸众生广作桥梁。成阿耨多罗三耶三菩阿惟三佛。我身当得三十二相八十种好无上之光。得四等意四无所畏佛十种力及十八法。逮六神通不思议净戒。成作佛已得无碍之慧。当得无上之宝除一切贫。我当得是如此之法。时长者女闻是语已。踊跃欢喜语菩萨言。善哉善哉贤者。甚奇甚特。乃说如是微妙之法。重言。贤者以是一法。当索无数恒边沙法。所以者何。是法甚深用微妙故。卿善男子。所欲得者莫自疑难。欲得琉璃摩尼杂宝真珠金银琥珀栴檀名香缯幡花盖。恣意所得今当与仁。可持供养法之尊师。莫尔自割毁坏其身。今我亦欲往至彼所与卿相随共殖善本。如卿属所可说者我悉欲得。时释提桓因即灭年少梵志形还复释身。住萨陀波伦菩萨前。赞叹言。善哉善哉。善男子。如卿建志。过去诸如来无所著等正觉。行菩萨道求般若波罗蜜沤和拘舍罗成阿惟三佛亦如贤者。今日我亦不用人心髓及血。我欲相试故来到是。欲得何愿。萨陀波伦报言。我不用余。与我阿耨多罗三耶三菩愿。释提桓因报言。善男子。是佛之境界非我所办。更索余愿多少福我。菩萨报言。假令大愿非卿境界者。复我身体使无疮[病-丙+槃]。以是相福。适作是语。萨陀波伦身复如故。于是帝释忽然不现。时长者女语菩萨言。随我共归见我父母。并报父母随卿所欲。供养之具当相给与。我亦当去侍从左右至法上所。尔时萨陀波伦。随长者女往到其家在门外住。长者女入白父母言。今当与我金银珍宝琉璃摩尼。名香栴檀花盖幢幡。杂色异衣供养之具。及诸奇异及五百侍女。欲以法故随萨陀波伦菩萨。行至香氏国法上菩萨所。欲闻尊经佛所有诸法。我当得之度脱众生。父母问女言。萨陀波伦今为是谁。女重白言。是人今在门外住。发坚誓之愿欲求阿耨多罗三耶三菩。欲为众生故救无极之苦。有大妙法名般若波罗蜜。是诸菩萨所应学者。是善男子但为是法故。自卖其身不惜躯命。而自割截欲以供养大师法上。是人至诚感致帝释。我见是变就往问之。有何奇特恶自割刺。便报我言。卖与年少欲得财物供养我师。我当得佛三十二相八十种好。当转法轮度脱众生。我闻是已甚大欢喜。谁闻是法而不乐者。我便许之当与珍宝供养之具随侍左右。是故父母当给与我珍宝所有及诸侍女。父母谓女。如汝所言。是人甚奇精进。乃尔不惜身命欲求不思议之法。如汝所言。是善男子必能办无上之法安隐众生建立大誓僧那僧涅。我当云何违汝是愿。欲得往见供养法上菩萨者。随汝意愿我代汝喜。自否年老不能得行。恣汝所欲珍琦宝物。我终不断一切之愿。尔时女取五百乘车以七宝校饰。及五百侍女庄严自副。种种诸花杂色宝衣如上所有载。以自重萨陀波伦别载一车。与五百女人围绕相随。于是东行稍稍引道。遥见香氏城郭。七宝玄黄珍琦众妙。未曾所有如上所说。复遥见其城中央法上菩萨。与诸大众数百千万围绕说法。遥见是已甚大欢喜。其身安隐譬如比丘得第四禅。又自念言。我今不可于车上载当下步耳。即与长者女及五百女人围绕。而前入城门里见七宝台。以赤栴檀而校饰之真珠交露。其台四角有四宝罂盛摩尼珠昼夜常明。有宝香炉常烧名香昼夜常香。当台中央有七宝塔。又以四色之宝作函。以紫磨金薄为素书般若波罗蜜。作经在其函中。又以七宝为织成幡互相参校。其色上妙随风缤纷。萨陀波伦及五百女人。见是七宝交露之台。见释提桓因与诸天子。持天曼陀罗花及天杂色栴檀名香。捣以为末其细如尘。于虚空中供养散其台上。又鼓天乐而供养之。尔时萨陀波伦。遥问释提桓因。汝何为供养以花散是台为。于是释提桓因报萨陀波伦言。卿善男子。为不知耶。是般若波罗蜜者生诸菩萨。一切菩萨当于是学。当成诸波罗蜜功德具足诸佛法逮萨云若。以是故我等而供养之。萨陀波伦闻是倍喜。复问释提桓因言。般若波罗蜜为在何所。释提桓因报言。在台中央七宝函中。法上菩萨以七宝印印之。汝等及我不得妄见。尔时萨陀波伦长者女及五百女人。各各取诸名花名香栴檀杂宝琉璃摩尼。供养般若波罗蜜已。别留一分持至法上菩萨高座所。复以法故供养法上大师。所散诸花当法上菩萨上。化作七宝台止于虚空。所散名花皆雨于法上菩萨。所散杂色宝衣在其台上。有化天人以手把持天幡而垂之。萨陀波伦及五百女人见是变化各念言。是法上菩萨摩诃萨所化。乃尔是未曾有。何况当成阿耨多罗三耶三菩阿惟三佛。时长者女及五百女人见。法上菩萨欢喜踊跃。皆发阿耨多罗三耶三菩意同时叹言。持是功德得于法利亦当如是。令我曹得供养般若波罗蜜。如法上菩萨。我等亦当广宣般若波罗蜜以度众生。亦如法上菩萨。愿我等得般若波罗蜜。成就沤和拘舍罗。所作变化逮阿耨多罗三耶三菩。于诸法得自在当如法上大师尔时萨陀波伦及长者女五百女人供养已讫。前以头面着地。为法上作礼却住一面。以恭敬意叉手白法上菩萨言。我昔于寂静之处。闻空中声言。善男子。从是东行可得闻般若波罗蜜。我即东去中道念。我当从谁得。闻般若波罗蜜。愁忧啼哭默住一处。七日不念饮食。但念何时当得般若波罗蜜。尔时便有化佛在我前住。即告我言。善男子。持是精进勇意。从是东行二万里有国名香氏。有菩萨名法上。常说般若波罗蜜。汝可从闻是汝真师。我从化佛闻是教已。即便东行遥见大师。意中欢喜踊跃安隐。譬如比丘得第四禅。以念般若波罗蜜故。便得无量三昧。即见十方诸佛。赞叹我言。善哉善哉。汝所得三昧者皆从般若波罗蜜生。我本行菩萨时索般若波罗蜜时亦复如是。赞叹我已便不复现。我三昧觉已自念。诸佛从何所来去至何所。复大愁忧我复念言。法上大师以般若波罗沤和拘舍罗。于诸法得自在。我当往问师。十方诸佛何所从来去至何所。今日大师为我解说。是诸如来所从来往愿欲知之。我等闻已常见诸佛不离世尊

    摩诃般若波罗蜜法上品第八十九

于是法上菩萨摩诃萨。报萨陀波伦菩萨言。善男子。诸如来常不动摇。亦不去亦不来。如来者如如无所起灭。不起者亦不来亦不去。不生者是如来。善男子真际者。亦不知来时亦不知去时。真际者则如来。虚空者亦无来亦无去。空者则如来。真谛者亦不知来时亦不知去时。真谛者则如来。无为者亦不来亦不去。无为者则如来。灭尽者亦无来亦无去。灭尽者则如来。善男子。如来者不离是法。此诸法者则是如来之如。善男子。如者一无有二。亦不三亦无若干之数。以法空故。善男子。譬如春节已过夏盛热时热有猛焰。愚夫逐之谓为是水。追之不息呼当得水。于贤者意云何。是人所逐水者。为从何所来。从东海西海南海北海从何海来。萨陀波伦菩萨对曰。热时焰者尚非是水。何况从海而有来往。法上复言。善男子。彼凡夫为热渴所迫而起水想。追逐疲劳竟不得水。诸有起想。谓诸如来有往来者。亦是凡夫与彼无异。所以者何。莫以色身而观如来。如来者法性。法性者亦不来亦不去。诸如来亦如是无来无去。善男子。譬如幻师化作象马车乘。谓呼是幻有来往者皆是愚夫。谓诸如来有来往者亦是凡夫。所以者何。法性者亦无来亦无去。萨陀波伦白法上言。梦幻所见悉空无实皆无所有。法上报言。善男子。如来无所著等正觉说言。诸法皆亦如梦有。于梦幻法有实相者。不知如来但入如来名色身耳。便作如来来往之相。是辈皆是无智凡夫。是辈凡夫于生死道当有反数。离般若波罗蜜大远。于诸佛法亦远。于诸梦幻法。知诸法如梦幻者为识如来。于诸法不求有来往之相。亦不求诸如来有生有灭。诸有知如来无来无往不生不灭者。为近阿耨多罗三耶三菩不久。是为行般若波罗蜜。是则为佛之弟子。是辈人应食国中施为世间之福田。善男子。譬如大海所有名宝。不从十方国土而来。以人福故海生此宝不为无缘。因缘故生是宝。灭时亦复不至十方。从因缘起从因缘灭。亦不从十方有来有往者。善男子。诸佛身者有行因缘便得合成。本行所致亦不用行往至十方。若使无行无因缘合者。若无因缘亦无有身也。善男子。譬如箜篌以因缘故有弦有柱。有人鼓之音声来往。声音断时亦无来往。是声出时亦无从来。灭亦无所至。欲知佛身亦复如是。有无量之德不以一事成皆有因缘而共合成。不离因缘而有去来。善男子。当知诸佛亦无来往。一切诸法皆复如是亦不生灭。汝知是已必至阿耨多罗三耶三菩。必究竟般若波罗蜜沤和拘舍罗。尔时释提桓因以天曼陀罗花。与萨陀波伦。持是供养法上菩萨当福于我。所以者何。一切众生当蒙仁者之恩。当得阿耨多罗三耶三菩。仁者上士世间少有甚难得值。乃为众生执劳。无央数劫都不以为劳。时萨陀波伦受释提桓因曼陀罗花。用散法上菩萨。散已白言。从今以去持身奉上于师供给所当。叉手却住一面。尔时长者女及五百侍女白萨陀波伦菩萨言。愿得以身奉上大师给所当得持是功德令得法利如今大师。当与大师常共供养诸佛世尊。尔时萨陀波伦告长者女及五百侍女。汝等随我教者我当受汝。诸女报言。身命自师不敢违教。萨陀波伦菩萨白法上菩萨言。愿持身自上。及五百女人及五百乘车。一切所有以上大师。哀我曹等愿当受之。尔时释提桓因叹言。善哉善哉。发菩萨意者。当持所有如贤者所为。菩萨如是施者疾得阿耨多罗三耶三菩。作是恭敬承事师者。疾可得闻般若波罗蜜沤和拘舍罗。过去诸如来无所著等正觉皆悉如是。舍意布施得般若波罗蜜沤和拘舍罗。成阿惟三佛。尔时法上菩萨即受萨陀波伦及长者女五百侍女。及五百乘车所有珍宝尽为受之。欲使萨陀波伦成其功德。虽受之还持与萨陀波伦菩萨。时日已冥。法上菩萨从高座起还入宫中。尔时萨陀波伦意念言。我为法来不宜坐卧。当以二事须师来出。一者经行二者住立。时法上菩萨入宫中正坐。以般若波罗蜜沤和拘舍罗。行无央数诸三昧至于七岁。萨陀波伦亦七岁不坐不卧常经行住立。不起三垢无诸欲味。但念法上菩萨何时当出为我说般若波罗蜜。七岁已后萨陀波伦意中念言。我当为师庄严高座。种种名花烧诸名香以待法师。当为大众说般若波罗蜜。萨陀波伦及五百女人各各布坐。身上好衣诸名綩綖柔软细叠以布坐上。萨陀波伦即行索水欲以洒地了不能得。是魔波旬之所蔽隐令水不现。欲坏菩萨令起乱意。不欲使成阿耨多罗三耶三菩。萨陀波伦意复念言。我当自刺其身出血以用洒地。所以者何。恐地有尘来坌师故。我不当惜是危脆之身。所以者何。前后以来无央数劫。弃是身体不可复计。初未值是无上之法。于是萨陀波伦菩萨即取利刀刺身血出持用洒地。五百女人各各亦尔。尔时波旬不能得其便。尔时释提桓因念言。是萨陀波伦菩萨及五百女人甚可奇特。贪德乃尔不惜身命恭敬法师。是魔波旬虽欲坏之不能得便。乃尔坚固誓于僧那不惜身命。于阿耨多罗三耶三菩。欲度众生无限之苦。是时帝释赞言。善哉善哉。贤者精进不可思议为无上之愿。过去诸佛本所行时精进如是。萨陀波伦意中念言。我今为师布坐已讫。当于何所得好名花。法师出时当散其上。尔时帝释知其所念。便以天上曼陀罗花千石与菩萨言。持是供养师并可散地。即取其花分布散地分留一分。七岁已后法上菩萨从宫中出往诣高座。萨陀波伦及五百女人。即持天花逆散法上。头面作礼却坐一面。法上菩萨告萨陀波伦菩萨。卿善男子谛听谛受善思念之。于是萨陀波伦菩萨受教而听。诸法等如金刚等诸法寂。诸法等寂不动故。般若波罗蜜等寂不动亦如金刚。诸法无倚诸法不恐诸法一味故。般若波罗蜜亦无所倚。诸法一味不恐诸法不生诸法不灭。诸法如空故。般若波罗蜜不生不灭亦如虚空。五阴无底无边际。诸法无底四大无底故。般若波罗蜜亦无有底。空无有边际大海无有边。诸法无边际故。般若波罗蜜亦无边际。譬如须弥山种种严好。般若波罗蜜亦复如是。诸法无所破坏。诸法不可得见。诸法无所受。诸法无所有。诸法不可思议故。般若波罗蜜无所破坏。亦不可得亦无所受。亦无所有。不可思议亦复如是。尔时萨陀波伦菩萨便于座上得诸法等三昧。诸法寂三昧。不动三昧。无倚三昧。无畏三昧。一味三昧。无生三昧。无灭三昧。虚空三昧。五阴无底三昧。诸法无底三昧。四大无边三昧。虚空性三昧。如海三昧。如须弥山三昧。金刚三昧。无所破坏三昧。无所得三昧。无所受三昧。无所有三昧。不可思议三昧。如是等三昧。得六万三昧门

    摩诃般若波罗蜜嘱累品第九十

佛告须菩提。尔时萨陀波伦菩萨得六万三昧已。便见十方如恒边沙三千大千国土。见诸如来无所著等正觉及比丘僧。大众围绕说般若波罗蜜。如我今日为汝等说般若波罗蜜。十方诸佛亦复如我字释迦文。萨陀波伦菩萨多闻具足其智如海。不离诸佛所生之处。在诸佛前。若于梦中未曾离佛。诸难已断已得自在。是故须菩提。当知般若波罗蜜。为诸菩萨摩诃萨致萨云若。菩萨欲学六波罗蜜者。欲得诸佛境界一切智者。当学行般若波罗蜜。当受当持当讽诵读。广为人说解其中事。亦当供养所有名花名香缯彩华盖。若干方便当供养之。所以者何。般若波罗蜜者。是诸佛所尊是尊道之御。佛告阿难。于汝意云何。汝为尊重爱敬如来不。阿难对曰。唯然世尊。爱敬如来。如来自知。佛语阿难。汝实爱敬于如来。阿难。汝前后侍我以来。汝身口意常有善慈。今吾年以老矣。弟子所应供养者。汝以为毕不为不毕。从今以往当恭敬承事般若波罗蜜。世尊。于是从一至三。如是嘱累于般若波罗蜜。所以殷勤郑重者何。欲令不断故若般若波罗蜜断者。一切众生永为盲冥。若般若波罗蜜在世不断绝者。诸佛如来亦不断绝。若般若波罗蜜有断绝者。诸佛如来亦当断绝。阿难。般若波罗蜜住于世者。当知如来常在说法。一切众生不离佛会不离说法。阿难。是般若波罗蜜。若有书持讽诵念守习行解说其义供养经卷。复教他人书持讽诵广为说者。当知是人常与佛俱不离诸佛。佛说是时。弥勒菩萨。耆年须菩提。尊者舍利弗大目犍连。分耨文陀尼子。摩诃拘絺罗。摩诃迦旃延。贤者阿难。一切会者诸天阿须伦。闻佛说已皆大欢喜。前为佛作礼

放光般若经卷第二十


佛说遍照般若波罗蜜经

    No. 242 [Nos. 240, 241, 243, 244]

    佛说遍照般若波罗蜜经

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时世尊。得一切如来金刚三昧智。得一切如来种种具足最上宝冠。得一切如来大自在相应金刚智。受三界灌顶一切如来智印乃至圆满一切众生所欲之愿种种变化大明平等智慧。此大毗卢遮那。常住三世平等一切如来金刚身语意业。称赞一切如来

尔时世尊住欲界他化自在天宫。而此宫殿以种种妙色大摩尼宝。种种真珠璎珞。种种幢幡宝盖。悬挂种种宝铃。如是具足一切庄严。有菩萨摩诃萨众。其名曰金刚手菩萨。观自在菩萨。虚空藏菩萨。金刚拳菩萨。发同心转法轮菩萨。誐誐曩巘惹菩萨。破一切魔王菩萨。文殊师利菩萨。如是等六十八俱胝菩萨摩诃萨众。恭敬围绕而为说法。初善中善后善。其义深远其语巧妙。纯一无杂具足清白。宣说菩萨一切清净法门。若诸有情于欲清净是菩萨故。爱缠清净是菩萨故。一切行清净是菩萨故。见性清净是菩萨故。爱乐清净是菩萨故。贪清净是菩萨故。嗔清净是菩萨故。痴清净是菩萨故。藏清净是菩萨故。文字清净是菩萨故。意乐清净是菩萨故。观清净是菩萨故。身清净是菩萨故。语清净是菩萨故。意清净是菩萨故。色清净是菩萨故。声清净是菩萨故。香清净是菩萨故。味清净是菩萨故。触清净是菩萨故。于意云何一切法自性空自性清净。般若波罗蜜亦自性空自性清净

佛告金刚手菩萨。于此般若波罗蜜一切清净法门。有秘密吽字摄尽一切法

佛告金刚手菩萨。一切清净法门般若波罗蜜。若人于此听受读诵。彼人即入菩提道场。所有业障报障烦恼障地狱恶趣。及一切盖缠皆悉不生。一切苦恼皆悉灭尽。若复有人日日受持读诵一心思惟。彼人现生得一切法平等金刚三昧。得一切自在爱乐。安乐。入菩萨位速证佛果。是故得名持金刚佛。如是所说一切法行。摄入秘密吽字义门

尔时遍照如来告金刚手菩萨。此般若波罗蜜经。说一切如来寂法菩提。所谓金刚平等菩提。金刚坚固义平等菩提。一义法坚等菩提。一切法自性清净菩提。皆是大菩提。能除一切妄想等。若有人听受读诵恭敬供养。所有一切罪障皆得消除。乃至得坐菩提道场。速证阿耨多罗三藐三菩提。如是所说一切法行。摄入秘密盎字义门

尔时释迦如来。为调伏一切恶。说一切法平等最胜般若波罗蜜经。贪所戏论应见其贪。痴所戏论应见其痴。一切法戏论应见一切法。般若波罗蜜应如是知。如是所说一切法行。摄入秘密[牟*含]字义门

佛告金刚手菩萨。若有人于此般若波罗蜜。听闻受持读诵忆念。假使彼人杀尽三界一切众生。彼所造罪无量无边。以此持诵功德之力速得消除。当证阿耨多罗三藐三菩提。如是所说一切法行。摄入秘密吽字义门

尔时自性清净如来。复说一切法聚集观自在智印般若波罗蜜经。世间一切贪清净故。一切嗔清净一切垢清净。一切罪清净一切众生清净。一切法清净一切智清净。般若波罗蜜清净

佛告金刚手菩萨。若有人于此般若波罗蜜。听闻受持读诵忆念。彼人虽在一切贪欲泥中。贪欲烦恼而不能染。如红莲华淤泥不着故。如是不久当成阿耨多罗三藐三菩提

尔时一切三界主如来。说一切如来灌顶生智藏般若波罗蜜经。若施灌顶当得三界之内一切王身。若施利行当得所欲之愿一切圆满。若以法施速证一切平等之法。若以财施于身口意一切快乐。如是所说一切法行。摄入秘密怛览字义门

尔时得一切智印常持一切密法如来。说一切如来住金刚智印般若波罗蜜经。若受一切如来身印。即成就一切如来。若受语印即成就一切法门。若受心印即成就一切三摩地。若受金刚印即成就一切如来最上金刚身口意业。佛告金刚手菩萨。若有人于此经中。听闻受持读诵思惟。彼人速得成就具足富贵。速得成就金刚身口意密。不久证成最上阿耨多罗三藐三菩提。如是所说一切法行。摄入秘密恶字义门

尔时一切法戏论如来。说转轮字般若波罗蜜经。一切法无性故无相。一切法无相故无作。无作故无愿。无愿故一切法本来清净。般若波罗蜜清净。如是所说一切法行。摄入秘密暗字义门

尔时一切内轮如来。说入大轮般若波罗蜜经。若入金刚平等故。亦得入一切如来轮。若利金刚平等入故。亦得入一切大菩萨轮。若法平等入故。亦得入一切法轮。若入一切平等故。亦得入一切轮。如是所说一切法行。摄入秘密囕字义门

尔时一切供养仪广大生如来。说一切如来最上供养般若波罗蜜经。发菩提心广伸供养一切如来。救度一切众生。令受一切如来妙法。书写供养受持读诵。复得一切如来广大供养。如是所说一切法行。摄入秘密唵字义门

尔时平等调伏一切如来。说金刚手调伏一切众生正智藏般若波罗蜜经。说一切众生平等故嗔亦平等。一切众生调伏故嗔亦调伏。一切法平等故嗔亦平等。一切众生平等故金刚亦平等。于意云何为菩提故。如是调伏一切众生。如是所说一切法行。摄入秘密憾字义门

尔时住一切法平等如来。说最上一切法平等般若波罗蜜经。说一切平等故。般若波罗蜜亦平等。一切利故般若波罗蜜亦利。一切法故般若波罗蜜亦法。一切业故般若波罗蜜亦业。如是所说一切法行。摄入秘密纥凌字义门

尔时世主如来。说一切众生住般若波罗蜜经。一切众生如来藏。即普贤大菩萨藏一切自性故。即金刚藏金刚灌顶故。即法藏转一切语故。即业藏作一切方便事故。如是所说一切法行。摄入秘密纥凌字义门。

尔时无量无边究竟如来。住无边究竟法。说一切法住平等究竟金刚般若波罗蜜经。般若波罗蜜无边故一切如来亦无边。一切如来无边故般若波罗蜜亦无边。乃至般若波罗蜜如一故一切法如一。般若波罗蜜究竟故一切法亦究竟。佛告金刚手菩萨。若有人于此般若波罗蜜。听闻受持读诵忆念。彼人得入究竟清净菩萨行位。一切盖障究竟不生。即得名为持金刚如来。如是所说一切法行。摄入秘密毗焰字义门

尔时大遍照如来。得一切如来秘密法。悟一切戏论法。说大乐不空金刚三昧平等般若波罗蜜经。最上法门本来无物无上中下。若能成就一切如来菩提法乐。降伏魔怨三界自在。乃至救度一切众生。令得最上利乐。是即名为大地菩萨。如是所说一切法行。摄入秘密娑鍐字义门

复次金刚手菩萨。彼大菩萨乃至住在轮回。亦作一切利益。度诸众生一住方便智慧。所作事业悉得清净。贪欲烦恼皆不能侵。如莲在水淤泥非染。自在安乐坚固不退。如是所说一切法行。摄入秘密贺字义门

复次金刚手菩萨。若人于此般若波罗蜜经。正心思惟日日读诵。乃至随喜听闻。是人得一切快乐。复能成就金刚三昧不空大乐。如是所说一切法行。摄入秘密吽字义门

尔时世尊遍照如来。白金刚手大秘密主言。我今复说二十五种般若波罗蜜秘密法门。汝今谛听。真言曰

唵(引)曩谟萨哩嚩(二合)没驮冒地萨埵喃(引)

唵(引)冒地唧多嚩日哩(二合)

唵(引)稣啰多娑怛鍐(三合)

唵(引)三满多跋捺啰(二合)左哩也(二合)尾部摩儞

唵(引)阿儞噜提

唵(引)惹(引)底尾嚩哩帝(二合引)

唵(引)摩贺(引)啰(引)誐达哩弥(二合引)

唵(引)尾哩也(二合)迦嚩唧(去)

唵(引)萨哩嚩(二合)誐(引)弥

唵(引)嚩日罗(二合)捺哩(二合)茶迦嚩左唧帝(引)吽(引)

唵(引)萨哩嚩(二合)怛他(引)誐帝(引)

唵(引)莎婆(引)嚩戍提

唵(引)达哩摩(二合)多(引)倪也(二合)曩尾戍驮

唵(引)迦哩摩(二合)尾输达儞吽(引)

唵(引)儞逊婆嚩日哩(二合)尼吽[口*癹]吒(半音)

唵(引)迦(引)摩啰(引)儗

唵(引)惹(引)贺嚩日哩(二合引)

唵(引)萨哩嚩(二合)那(引)曳儞

唵(引)纥凌(二合)

唵(引)阿迦(引)啰目契(去)

唵(引)钵啰(二合)倪也(二合)波(引)啰弥帝(引)惹敢(切)昂吽(引)

唵盎唵(引)萨哩嚩(二合)怛他(引)誐多迦(引)野誐哩(二合引)

唵(引)萨哩嚩(二合)怛他(引)誐多嚩(引)尾输驮儞

唵(引)萨(哩)嚩(二合)怛他(引)誐多唧多缚日哩(二合引)阿(入)

唵(引)三尾(引)誐野萨哩嚩(二合)萨埵喃谟叉野萨哩嚩(二合)播(引)野誐帝(引)毗也(二合)萨哩嚩(二合)三摩野嚩日啰(二合)吽怛啰(二合)吒(引音)

尔时世尊说此真言已。告金刚手菩萨言。如是印咒能破一切罪暗。能作一切吉祥。一切如来金刚秘密最上成就。若人得此持诵听闻是即名为持金刚清净如来。若有众生于此般若波罗蜜经。受持读诵随喜听闻。是人已曾于无量佛所。种诸善根植众德本

复次金刚手菩萨。若人闻此般若波罗蜜经一四句偈。得八万俱胝那由他恒河沙等如来恭敬供养。何况解义为他演说。彼人持经之处如佛塔庙。一切天人阿修罗等恒来作礼。若人流通此经展转读诵。获宿命智能知过去俱胝劫事。一切众魔诸恶患难皆不能侵。常有四大天王及诸贤圣而作卫护。彼人临命终时心不颠倒。一切诸佛及大菩萨俱来迎接。十方净土随意往生

复次金刚手菩萨。如是般若波罗蜜经圣要法门。成就如是最上法行胜妙功德。佛说是经已。金刚手菩萨摩诃萨。及天人阿修罗乾闼婆等。皆大欢喜信受奉行遍照般若波罗蜜经


佛说帝释般若波罗蜜多心经

    No. 249

    佛说帝释般若波罗蜜多心经

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。有无数大苾刍众。复十俱胝童子相菩萨摩诃萨

尔时世尊告帝释天主。憍尸迦。此般若波罗蜜。其义甚深。非一非异。非相非无相。非取非舍。非增非损。非有烦恼。非无烦恼。非舍非不舍。非住非不住。非相应非不相应。非烦恼非不烦恼。非缘非不缘。非实非不实。非法非不法。非有所归。非无所归。非实际非不实际。憍尸迦。如是一切法平等。般若波罗蜜亦平等。一切法寂静。般若波罗蜜亦寂静。一切法不动。般若波罗蜜亦不动。一切法分别。般若波罗蜜亦分别。一切法怖畏。般若波罗蜜亦怖畏。一切法了知。般若波罗蜜亦了知。一切法一味。般若波罗蜜亦一味。一切法不生。般若波罗蜜亦不生。一切法不灭。般若波罗蜜亦不灭。一切法虚空妄想。般若波罗蜜亦虚空妄想。色无边。般若波罗蜜亦无边。如是受想行识无边。般若波罗蜜亦无边。地界无边。般若波罗蜜亦无边。如是水界火界风界空界识界无边。般若波罗蜜亦无边。金刚平等。般若波罗蜜亦平等。一切法不坏。般若波罗蜜亦不坏。一切法性不可得。般若波罗蜜亦不可得。一切法性平等。般若波罗蜜亦平等。一切法无性。般若波罗蜜亦无性。一切法不思议。般若波罗蜜亦不思议。如是布施波罗蜜。持戒波罗蜜。忍辱波罗蜜。精进波罗蜜。禅定波罗蜜。方便波罗蜜。愿波罗蜜力波罗蜜。智波罗蜜亦不可思议。三业清净。般若波罗蜜亦清净。如是般若波罗蜜。其义无边

复次憍尸迦。所有十八空。何等十八空。内空。外空。内外空。空空。大空。胜义空。有为空。无为空。无际空。无变异空。无始空。本性空自相空。无相空。无性空。自性空。无性自性空。一切法空。颂曰

  如星如灯翳　　梦幻及泡露
  如电亦如云　　应作如是观
  我今略说此　　般若波罗蜜
  不生亦不灭　　不断亦不常
  非一非多义　　非来亦非去
  如是十二缘　　止息令寂静
  正等正觉说　　恭信最上师
  归依十方佛　　过现及未来
  三宝波罗蜜　　无量功德海
  供养诸如来　　大明真秘密

真言曰

怛儞也(二合)他(引)钵啰(二合)倪钵啰(二合)倪摩贺(引)钵啰(二合)倪钵啰(二合)倪嚩婆(引)细钵啰(二合)倪鲁迦迦哩(引)阿倪也(二合)曩尾驮摩儞(去)悉提(引)苏悉提悉[亭*夜](切身)睹[牟*含]婆誐嚩帝萨哩鑁(二合引)誐逊那哩(去)跋讫帝(二合)晚娑隶(引)钵啰(二合)娑(引)哩多贺悉帝(二合引)三摩(引)娑嚩(二合)娑迦哩悉[亭*夜](切身)悉[亭*夜](切身)没[亭*夜]没[亭*夜]剑波剑波左攞左攞啰(引)嚩啰(引)嚩阿(引)誐蹉阿(引)誐蹉婆誐嚩帝摩(引)尾攞莎娑嚩(二合引)贺(引)

曩谟达哩谟(二合)捺誐(二合)多写冒地萨埵写摩贺(引)萨埵写摩贺(引)迦噜尼迦写曩谟娑那(引)钵啰(二合)噜祢怛写冒地萨埵写摩贺(引)萨埵写摩贺(引)迦噜尼迦写曩谟(入)钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他牟儞达哩弥(二合合)僧誐啰(二合)贺达哩弥(二合)阿努誐啰(二合)贺达哩弥(二合)尾目讫多(二合)达哩弥(二合)萨埵(引)努誐啰(二合)贺达哩弥(二合)吠室啰(二合)嚩拏达哩弥(二合)三满多(引)努波哩嚩哩多(二合)曩达哩弥(二合引)虞拏誐啰(二合)贺僧誐啰(二合)贺达哩弥(二合引)萨哩嚩(二合)怛啰(二合引)努誐多达哩弥(二合引)萨哩嚩(二合)迦(引)罗波哩钵啰(二合引)波拏达哩弥(二合引)娑嚩(二合引)贺(引)钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他(引)阿佉儞曩佉儞阿佉曩儞佉儞阿嚩罗晚驮儞半那儞半那儞钵[打-丁+柰]哩裟嚩(二合引)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他(引)昂誐(引)昂誐(引)曩帝啰(引)昂誐(引)曩帝曩(引)嚩婆(引)裟昂誐(引)娑嚩(二合引)贺

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳怛儞也(二合)他(引)室哩(二合)曳(引)室哩(二合)曳(引)牟儞室哩(二合)曳(引)牟儞室哩(二合)野细娑嚩(二合引)贺(引)钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他唵(引)嚩[口*(曰/羅)](二合)未隶(引)娑嚩(二合引)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰祢多(引)曳(引)怛儞也(二合)他(引)唵纥凌(二合)室凌(二合)特凌(二合)室噜(二合)帝特哩(二合)帝娑蜜哩(二合)誐帝尾曳(引)惹娑嚩(二引合)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳怛儞也(二合)他(引)鑁嚩哩鑁嚩哩摩贺(引)鑁嚩哩度噜度噜摩贺(引)度噜娑嚩(二合引)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他(引)虎帝虎帝多(引)设儞萨哩嚩(二合)迦哩摩(二合)嚩啰挐儞娑嚩(二合引)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他(引)唵(引)阿噜黎迦娑嚩(二合引)贺(引)

曩谟钵啰倪也(二合)波(引)啰弥多(引)曳(引)怛儞也(二合)他(引)唵(引)萨哩嚩(二合)尾睹(入声)娑嚩(二合引)贺(引)

曩谟钵啰(二合)倪也(二合)波(引)啰弥多(引)曳怛儞也(二合)他(引)誐帝誐帝波(引)囕誐帝波(引)帝啰僧誐帝冒地娑嚩(二合引)贺

尔时世尊说此经已。帝释天主。及诸菩萨摩诃萨。天人乾闼婆阿修罗等。一切大众。闻佛所说皆大欢喜。信受奉行佛说帝释般若波罗蜜多心经


佛说佛母宝德藏般若波罗蜜经

    No. 229 [cf. No. 220(4or5) etc.]

佛说佛母宝德藏般若波罗蜜经卷上

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

    行品第一

尔时世尊。为令四众各得欢喜。说是般若波罗蜜经使获利乐。即说伽陀曰

  所有菩萨为世间　　灭除盖障烦恼垢
  发净信心住寂静　　当行智度彼岸行
  诸江河流阎浮提　　华果药草皆得润
  龙王主住无热池　　彼龙威力流江河
  亦如佛子声闻等　　说法教他方便说
  乐最圣行求果报　　此诸如来胜威德
  云何佛说此法眼　　令诸弟子如佛学
  自证教他及方便　　此亦佛力非自力
  最上般若不可知　　非心可知非菩提
  如是闻已不惊怖　　彼菩萨行知佛智
  色受想行识皆无　　不着纤尘无处所
  彼若不住一切法　　行无受想得菩提
  菩萨若求出家智　　照见五蕴无实相
  知此不求于寂静　　彼是菩萨之行智
  复次云何智所得　　照见一切法皆空
  不着不惊照见时　　自觉觉他诸菩萨
  色受想行及识蕴　　是蕴见行而不知
  菩萨照见蕴皆空　　行无相化不着句
  无色受想行识等　　不行是名无相行
  若行不得最上智　　无相寂静三摩地
  若菩萨行自寂静　　过去诸佛咸授记
  身苦乐等皆不及　　由知因果法本性
  若行于法不可得　　行如是行乃佛智
  行无所行了知已　　是行最上般若行
  彼无所有不可得　　愚痴着相谓有无
  有无二法皆非实　　出此了知乃菩萨
  菩萨若知诸幻化　　色受想行识亦然
  寂静行离种种相　　此名最上般若行
  善友方便令知觉　　使闻佛母不惊怖
  恶友同行及化他　　坏器盛水非坚牢
  云何得名为菩萨　　一切乐行皆无著
  求佛菩提无所著　　是故得名为菩萨
  云何得名摩诃萨　　得第一义众生中
  断众生界诸邪见　　是故得名摩诃萨
  大施大慧大威德　　佛乘最上而得乘
  发菩提心度众生　　是故得名摩诃萨
  幻化四足俱胝数　　多人众前悉截首
  一切世界皆幻化　　菩萨知已得无怖
  色受想行识缠缚　　知不实已不求解
  行菩提心无所著　　此名最上诸菩萨
  云何得名为菩萨　　乘大乘行度众生
  大乘体相如虚空　　菩萨由得安隐乐
  大乘之乘不可得　　乘涅盘往诸方所
  行已不见如火灭　　是故名为入涅盘
  菩萨所行不可得　　初后现在三清净
  清净无畏无戏论　　是行最上般若行
  大智菩萨行行时　　发大慈悲为众生
  为已不起众生相　　是行最上般若行
  菩萨起念为众生　　修诸苦行有苦相
  是有我相众生相　　此非最上般若行
  知自及诸众生等　　乃至诸法亦复然
  生灭无二无分别　　是行最上般若行
  乃至所说世界等　　名离一切生灭法
  最上无比甘露智　　是故得名为般若
  菩萨如是所行行　　了知方便无所求
  知此法本性非实　　是行最上般若行
  若不住色亦无受　　亦不住想亦无行
  复不住识住正法　　是名最上般若行

    佛母宝德藏般若伽陀帝释品第二

    欢喜地摄布施波罗蜜伽陀

  常与无常苦乐等　　我及无我悉皆空
  不住有为及无为　　住无相行佛亦然
  若求声闻缘觉等　　乃至佛果亦复然
  不住此忍不可得　　如渡大河不见岸
  若闻此法彼定得　　成等正觉证涅盘
  见于一切如自身　　是大智者如来说

佛子当住四补特伽罗。是行大智行。一真实善法。二不退心。三应供离垢无烦恼无求。四善友同等

  大智菩萨如是行　　不学声闻及缘觉
  乐学如来一切智　　是学非学名为学
  学不受色不增减　　亦复不学种种法
  摄受乐学一切智　　若此功德出离者
  色非有智非无智　　受想行识亦复尔
  色性自性如虚空　　平等无二无分别
  妄想本性无彼岸　　众生之界亦复然
  虚空自性亦同然　　智慧世间解亦尔
  智慧无色佛所说　　离一切想到彼岸
  若人得离诸想已　　是人语意住真如
  彼人住世恒沙劫　　不闻佛说众生声
  众生不生本清净　　是行最上般若行
  佛说种种之语言　　皆具最上般若义
  过去佛为我受记　　于未来世证菩提

    佛母宝德藏般若伽陀持无量功德建塔品第三

    无垢地摄持戒波罗蜜伽陀

  若人常受持般若　　所作上应诸佛行
  刀剑毒药水火等　　乃至诸魔不能为
  若人于佛灭度后　　建七宝塔以供养
  如是圆满千俱胝　　佛刹恒沙等佛塔
  众生无边千俱胝　　以妙香华涂香等
  供养三世无边劫　　所有功德之数量
  不及书写于佛母　　诸佛由此而得生
  若受持读诵供养　　功德倍胜于佛塔
  大明般若诸佛母　　能除苦恼遍世界
  所有三世十方佛　　学此明得无上师
  行般若行利有情　　使学大智证菩提
  有为无为诸快乐　　一切乐从般若生
  譬如大地植诸种　　得和合生种种色
  五波罗蜜及菩提　　皆从般若所生出
  又如轮王出行时　　七宝四兵为导从
  若依佛母最上行　　一切功德法集聚

    佛母宝德藏般若伽陀功德品第四

    发光地摄忍辱波罗蜜伽陀

  帝释有疑问佛曰　　恒河沙数等佛刹
  佛界圆满如芥子　　能受佛刹般若力
  如是了知般若已　　此界云何不供养
  譬如人王人所重　　住般若者合亦尔
  佛界般若摩尼宝　　具一切德价无比
  经函安处经有无　　供养悉获宝功德
  佛灭供养于舍利　　不及供养于般若
  若乐受持供养者　　是人速得证解脱
  首行布施波罗蜜　　次戒忍进及禅定
  受持善法不可坏　　彼一一生一切法
  如阎浮提种种树　　百千俱胝无数色
  虽一一树影皆别　　无量影同一名摄
  五波罗蜜五名异　　般若波罗复一名
  一切回施为菩提　　一味同归菩提名

    佛母宝德藏般若伽陀福量品第五

    焰慧地摄精进波罗蜜伽陀

  彼色受想行识等　　菩萨观照悉无常
  各各现行而不知　　非法非生智者见
  无色无受想行识　　是法无得复无生
  了知一切法皆空　　是名最上般若行
  如化恒沙等佛刹　　诸众生证罗汉果
  若能书写此般若　　令他受持功德胜
  如佛修行云何学　　信重般若诸法空
  速证声闻及缘觉　　乃至无上正觉尊
  世间无种不生树　　枝叶华果悉无有
  无佛谁指菩提心　　亦无释梵声闻果
  如日舒光照诸天　　普使成就种种业
  佛智菩提心亦然　　从智生诸功德法
  如无热池无龙主　　即无河流阎浮提
  无河华果悉不生　　亦无大海种种宝
  世间无佛无大智　　无智功德不增长
  亦无佛法诸庄严　　无菩提海等等宝
  譬如世间萤有光　　一切萤光集一处
  比日一光照世间　　微尘数分不及一

    佛母宝德藏般若伽陀随喜功德品第六

    难胜地摄定波罗蜜伽陀

  所有声闻众功德　　布施持戒观照行
  不及菩萨发一心　　随喜福蕴之少分
  所有俱胝那由他　　无边佛刹千俱胝
  过去现在佛说此　　法宝为断一切苦
  先发最上菩提心　　至成正觉及入灭
  彼量所有佛功德　　咸成方便波罗蜜
  及彼声闻学无学　　有漏无漏诸善法
  菩萨等一普回施　　当为世间证菩提
  菩萨施已不住心　　住心即名众生相
  有见有念名著相　　非是菩萨之回施
  如是施非无相施　　是法当知有灭尽
  若作非法非施心　　乃可得名为回施
  作有相施非真施　　无相回施证菩提
  如上妙食杂毒药　　自法着相亦如是
  是故回施应当学　　如佛众善悉当知
  若生若相若威力　　悉皆随喜而回施
  以功德施佛菩提　　菩萨之施皆无相
  此施佛许而印可　　如是得名勇猛施

    佛母宝德藏般若伽陀地狱品第七

    现前地摄智慧波罗蜜伽陀

  无量盲人不见道　　无一得入于城郭
  修六度行阙般若　　无力不能成菩提
  譬如画像不画眼　　因无眼界无功德
  若有受行于智慧　　得名有眼及有力
  有为无为黑白法　　如微尘等不可得
  智慧观照如虚空　　故名般若出世间
  菩萨谛信行佛行　　度那由他苦众生
  如是若着众生相　　此非般若最上行
  菩萨若行最上行　　过去未曾求大智
  今闻般若如佛想　　速证寂静佛菩提
  过去信佛那由他　　不信般若波罗蜜
  或生嗔恨或诽谤　　是人少智堕阿鼻
  若人乐证诸佛智　　不能信重诸佛母
  如商入海欲求宝　　返失于本而复还

    佛母宝德藏般若伽陀清净品第八(此品摄第九叹品)

    远行地摄方便波罗蜜伽陀

  色清净故果清净　　果色二同一切智
  若一切智清净时　　如虚空界不断坏
  菩萨出过于三界　　断尽烦恼而现生
  无老病死现灭度　　斯即是行般若行
  世间欲色之淤泥　　愚人处中如风旋
  亦如鹿在屋中转　　智者如禽飞虚空
  若不着色无受想　　亦无行识乃清净
  如是离诸烦恼垢　　解脱名佛大智行
  菩萨如是行大智　　得离诸相脱轮回
  如日解脱罗睺障　　光明普遍照世间
  火烧草木及树林　　如一切法性清净
  作如是观亦非观　　如是最上般若行

    佛母宝德藏般若伽陀称赞功德品第十

    不动地摄愿波罗蜜。善慧地摄力波罗蜜伽陀

  帝释天主问佛言　　云何菩萨行智慧
  佛答微尘数蕴界　　无此蕴界之菩萨
  菩萨久行应可知　　于俱胝佛作胜缘
  新学闻此生邪疑　　或不乐求而不学
  又如人行深恶道　　忽见边界牧牛人
  心得安隐无贼怖　　知去城郭而非遥
  若闻最上般若已　　复得乐求佛菩提
  如获安隐得无怖　　心超罗汉缘觉地
  譬如人住观大海　　先见大山大树林
  见此所爱祥瑞境　　必达大海知非远
  菩萨若发最上心　　闻此般若波罗蜜
  虽未授记于佛前　　此证菩提亦非远
  如见春生诸草木　　知有华实而非遥
  若人手得此般若　　得证菩提亦非远
  亦如女人怀其妊　　十月满足必诞生
  菩萨若闻宝德藏　　速成正觉之祥瑞
  若行般若波罗蜜　　见色非增亦非减
  见法非法如法界　　不求寂静即般若
  行者若不思佛法　　不思力足及寂静
  离思非思无相行　　是行最上般若行

    佛母宝德藏般若伽陀魔品第十一

    法云地摄智慧彼岸伽陀

  佛告善现汝谛听　　凡夫声闻缘觉地
  斯即名为如来地　　一切如一彼无疑
  所有称赞离言说　　从彼遍照如来时
  乃至成所之作智　　住持大金刚佛地
  观察无相住虚空　　应知不断佛种故
  善现白佛言世尊　　云何菩萨之魔事
  佛言菩萨魔事多　　我今为汝略宣说
  有无数魔种种变　　当书最上般若时
  速离天宫如电灭　　来于世间作魔事
  或有示现乐欲说　　或不听受返嗔恨
  不说名姓及氏族　　如是魔事咸应知
  愚痴无智无方便　　无根宁有枝叶等
  闻般若已别求经　　如弃全象返求足
  如人先得百味食　　或得稻饭为上味
  菩萨先得般若已　　弃舍乐求罗汉果
  或为乐求于利养　　心着族姓留种迹
  舍彼正法行非法　　是魔引入于邪道
  若人闻此最上法　　当于法师深信重
  法师知魔不应着　　身适悦及不适悦
  复有无数种种魔　　娆乱无数苾刍众
  欲求持诵此般若　　不能获得无价宝
  佛母般若实难得　　初心菩萨欲乐求
  若十方佛而摄受　　一切恶魔不能为

佛母宝德藏般若伽陀卷上佛母宝德藏般若波罗蜜经卷中

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

    般若伽陀现世品第十二

  如母爱子子疾病　　当令父母心忧恼
  十方诸佛般若生　　般若摄受亦复尔
  过现未来三世佛　　遍十方界亦复然
  皆从佛母般若生　　众生心行无不摄
  如是世间诸如来　　乃至缘觉及罗汉
  迨及般若波罗蜜　　皆一味法离分别
  过现大智诸菩萨　　各各住此法空行
  彼诸菩萨如实已　　是故如来名作佛
  般若园林华果盛　　佛依止故甚适悦
  十力诸根等净众　　乃至声闻众围绕
  般若波罗蜜高山　　十力诸佛而依止
  三涂众生悉救度　　度已不起众生相
  师子依山而大吼　　诸兽闻已皆恐惧
  人师子依般若吼　　外道邪魔悉惊怖
  如日千光住虚空　　普照大地诸相现
  法王住般若亦然　　说度爱河之妙法
  色无相以受无相　　乃至想行亦复然
  识亦如是五法同　　是法无相佛佛说
  起虚空见众生相　　虚空无相不可得
  佛说法法非相应　　不说非有非无相

    佛母宝德藏般若伽陀不思议品第十三

  若如是见一切法　　一切我见悉皆舍
  佛行法及声闻等　　皆从般若而成就
  如王不行于国邑　　所有王务而自办
  菩萨离相依般若　　自然获佛功德法

    佛母宝德藏般若伽陀譬喻品第十四

  若菩萨发坚固心　　修行最上般若行
  超过声闻缘觉地　　速能证得佛菩提
  如人欲渡于大海　　所乘船舫忽破坏
  不依草木命不全　　若得依附达彼岸
  若人不发坚信心　　依于般若求解脱
  溺轮回海无出期　　处生老死常苦恼
  若有信心持般若　　解有无性见真如
  是人获福智有财　　速证最上佛菩提
  如人担水用坏器　　知不坚牢速破坏
  若用坚牢器盛水　　而无破坏无忧怖
  不见具信诸菩萨　　远般若行求退堕
  能发信心持般若　　证大菩提超二地
  未有商人欲入海　　不造坚固大船舫
  依坚固船无怖畏　　获多珍宝到彼岸
  信心菩萨亦如是　　离般若行远菩提
  若修最上大智行　　当得无上菩提果
  如百岁人复病患　　是人不能自行立
  若得左右扶侍者　　随意行往无所怖
  菩萨般若力微劣　　往菩提岸不能到
  兼行最上方便行　　得佛菩提无挂碍

    佛母宝德藏般若伽陀天品第十五

  所有菩萨住初地　　发信心行般若行
  为求无上菩提故　　亲近善友及智者
  大智功德云何获　　当从般若波罗蜜
  如是一切诸佛法　　功德皆从善友得
  修行六度般若行　　一一回施于菩提
  佛蕴非有不可求　　勿为初地如是说
  菩萨修行功德海　　救度世间无度者
  求菩提意离颠倒　　说最上法如电光
  发于最上菩提心　　不求名称不嗔恚
  离蕴识界及三乘　　不退不动不可取
  于如是法得无碍　　达甚深理离妄想
  闻般若信及化他　　知此菩萨住不退
  彼甚深法佛难知　　无有人得不可得
  为利益故证菩提　　此非初心众生知
  众生愚痴复盲冥　　乐住世间求境界
  法无所住无取得　　从无所住生世间

    佛母宝德藏般若伽陀如实品第十六

  东方虚空界无边　　南西北方亦如是
  乃至上下及四维　　无种种相无分别
  过去未来及现在　　一切佛法及声闻
  一切如实不可得　　不可得故无分别
  菩萨乐求如是法　　应行方便般若行
  离种种相即菩提　　菩萨离此无由证
  如鸟能飞百由旬　　折翅翼故飞无半
  忉利天及阎浮人　　忘失般若故自坠
  难修前五波罗蜜　　经多俱胝那由劫
  复以广大愿资持　　离方便坠声闻位
  乐行佛智心平等　　犹如父母观一切
  当行利益及慈悲　　常宣善软妙言教

    佛母宝德藏般若伽陀不退地祥瑞品第十七此品摄普遍光明佛地

  时须菩提瞻仰问　　不退菩萨何殊胜
  离言声相云何说　　愿佛说彼功德藏
  不住沙门婆罗门　　及行十善离三涂
  大智离于种种相　　如山谷响声相应
  若欲法无碍行化　　一向善说诸言教
  行住坐卧四威仪　　一念观心悉通达
  三业清净如白衣　　不为利养故乐法
  降魔境界及化他　　观四禅定而不住
  不求名誉无嗔恚　　乃至在家尘不染
  或为富贵及脱命　　不染纤毫之欲尘
  本来寂静无所有　　更互相相业所缘
  若求清净不退时　　当行最上般若行
  求正遍知心柔顺　　不求二地离边地
  为法舍命如须弥　　是名不退之菩萨

    佛母宝德藏般若伽陀空品第十八

  色受想行识甚深　　本来寂静而无相
  如海之深杖莫测　　得般若蕴亦如是
  菩萨知此甚深法　　住真如乘不可染
  六尘十二界体空　　无蕴宁有所得福
  如人思彼染欲境　　心着女色如目见
  乃至日日心所行　　菩萨思觉亦如是
  若多俱胝劫布施　　罗汉缘觉持戒者
  不如说行般若法　　百千万分不及一
  若菩萨观般若理　　安住说法而无相
  回施一切证菩提　　彼三界师无有等
  所说成就而无相　　非空非实不可得
  若如是行名觉智　　得受成就义无边
  于一念知一切法　　信佛所说及他说
  演说俱胝那由劫　　法界不增亦不减
  此得名佛波罗蜜　　菩萨于中而说法
  如名施已心不着　　亦不言证无上觉

    佛母宝德藏般若伽陀昂誐天姊品第十九

  譬如灯光从众缘　　假以膏油芯火等
  光非芯火及膏油　　非火非芯光不有
  或有菩萨初发心　　不求无上菩提果
  岂唯不得证菩提　　亦复不得寂静故
  从种生树及华果　　无种华果悉皆无
  发心不为佛菩提　　修行终远菩提果
  从种子生麦谷等　　彼果非有亦非无
  佛菩提果亦如幻　　离彼有性及无性
  譬如涓滴水细微　　渐次必能盈大器
  初心为求无上果　　久修白法终能证
  行空无相无愿行　　不求寂静无行相
  亦如船师善济渡　　不着两岸非中流
  菩萨修行无所著　　乃得受佛菩提记
  若了菩提非所有　　此即是行佛般若
  譬如疾疫饥馑道　　菩萨中行无怖畏
  小人知已悉往来　　得无苦恼如微尘

    佛母宝德藏般若伽陀善解方便品第二十

  菩萨奉行佛般若　　了知本来蕴不生
  佛法众生界悉空　　以空三昧起悲智
  如人有德力最胜　　善解一切幻化法
  乃至器仗及工巧　　而能一向为世间
  彼人父母妻及子　　游行远路多冤中
  是人勇猛众所知　　安乐还家无怖畏
  大智菩萨为众生　　安住第一三摩地
  降伏四魔离二乘　　亦复不求佛菩提
  譬如虚空无所有　　风水火地皆依住
  世间众生得快乐　　虚空无意住非住
  菩萨住空亦如是　　现于世间种种相
  以众生智及愿力　　非彼寂静非空故
  若菩萨行大智时　　住空寂静三摩地
  此中不见一切相　　亦复不见彼非相
  菩萨行此解脱门　　非求寂静非行相
  如鸟飞空而往来　　非住虚空非住地
  亦如有人习射法　　习之不住经多岁
  射法久习得尽妙　　一一箭发无不中
  最上般若行亦尔　　修习智慧及方便
  直至众善悉圆满　　方获最上神通力
  若苾刍证神通力　　现神变化住虚空
  行住坐卧四威仪　　经俱胝劫不退倦
  住空菩萨亦如是　　修无相行到彼岸
  行种种行现世间　　经俱胝劫不退倦
  如人经险遇大风　　二手持盖心专注
  是人怖险不能行　　直至无风乃前进
  大智菩萨住大悲　　智慧方便为二手
  执空无相愿法盖　　见法不住于寂静
  如人求宝往宝洲　　获宝安隐而还家
  是人心足而快乐　　岂有眷属心苦恼
  诣空宝洲亦如是　　获得根力禅定宝
  菩萨不住欢喜心　　令诸众生离苦恼
  商人为利悉所经　　聚落国城诸里巷
  虽达宝所亦非住　　大智善道而复还
  大智菩萨悉了知　　声闻缘觉解脱智
  乃至佛智亦非住　　何况行彼有为道
  大智菩萨为世间　　住空无相愿三昧
  若得寂静无所著　　乃可得知于无为
  譬如人生人未识　　称其名故众乃知
  菩萨若行解脱门　　于解脱门众知识
  菩萨闻彼甚深法　　而于诸根悉照明
  住空无相无愿法　　无退无思无授记
  观于三界如梦幻　　不求声闻缘觉地
  如佛说法为世间　　名不退地应授记
  知诸众生堕三涂　　发愿刹那灭恶道
  以真实力灭火蕴　　名不退地应授记
  诸恶宿曜及鬼神　　作种种疫恼世间
  真实愿力悉灭除　　无我能作应授记

    佛母宝德藏般若伽陀魔业品第二十一

  我得授记非能所　　是实愿力得增长
  若见授记及能所　　是名执着及少智
  菩萨有执魔即知　　现亲友相来娆恼
  或作父母七代人　　言汝名此佛可证
  魔所现作无数相　　皆云愍汝作利乐
  菩萨闻已有所忻　　是名少智魔所著
  或住城隍及聚落　　山林旷野寂静处
  自称己德毁他人　　应知少智为魔作
  虽住城隍聚落中　　不求声闻缘觉证
  此心为度众生故　　我说是名为菩萨
  五百由旬山险深　　共诸恶兽多年住
  若见逼迫着我慢　　若无分别知菩萨
  菩萨住彼为世间　　得力解脱三摩地
  彼着山野寂静行　　此亦知彼魔所作
  虽住城隍及山野　　乐佛菩提离二乘
  修如是行利世间　　一念如秤名菩萨

    佛母宝德藏般若伽陀善友品第二十二

  有大智者依师学　　速疾得证无上觉
  亦如良医除众患　　学从善友心无疑
  菩萨行佛菩提行　　依彼善友波罗蜜
  此最上地能调伏　　为二种事证菩提
  过去未来十方佛　　行此正道无异路
  行佛菩提最上行　　说波罗蜜如电光
  如彼般若空无相　　知诸法相亦如是
  了知一切法皆空　　此即名行佛般若
  系着色欲及饮食　　常在轮回不休息
  此愚迷人所见倒　　于不实法生实想
  譬如得食疑有毒　　以虚妄见而不食
  愚人妄心生我想　　以我想故有生死
  亦如恒说诸烦恼　　于诸烦恼不着相
  烦恼清净俱无有　　如是菩萨知般若
  如阎浮提诸众生　　皆发无上菩提心
  多千俱胝劫布施　　回施一切证菩提
  若复有人于一日　　奉行最上般若行
  千俱胝施不及一　　行般若功无为故
  菩萨大悲行般若　　度众生故不起想
  恒行乞食于国城　　是得一切名大智
  菩萨欲度于人天　　乃至三涂极苦众
  皆令速到于彼岸　　昼夜勤行于般若
  如人欲求无价宝　　必过大海诸险难
  无心忽尔而获得　　忧恼皆除喜无量
  求菩提宝亦如是　　勤行般若诸功德
  得无取舍无上宝　　菩萨速证于菩提

佛母宝德藏般若经伽陀卷中佛母宝德藏般若波罗蜜经卷下

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

    法王品第二十三

  日出光明照世间　　云幻焰散黑闇灭
  所有萤光及众星　　乃至满月皆映蔽
  菩萨住空无相愿　　行于最上大智行
  罗汉缘觉证皆超　　一切邪见俱能破
  譬如王子施财宝　　自在能利诸众生
  众生欢喜悉随顺　　无疑当得嗣王位
  菩萨勤行大智行　　施甘露法利群生
  一切人天悉爱乐　　决定当证法王位

    佛母宝德藏般若伽陀我品第二十四

  魔恐菩萨证法王　　虽处天宫常忧恼
  放火掣电现诸相　　欲令菩萨生退惧
  大智菩萨心不动　　昼夜常观般若义
  如鸟飞空心泰然　　一切魔事无能为
  菩萨若起嗔怒心　　于昼夜分或斗诤
  时魔欢喜而精勤　　菩萨是远于佛智
  菩萨或诤或嗔怒　　毗舍左鬼得其便
  入彼菩萨身心中　　令退菩提魔所作
  菩萨授记未授记　　或起嗔怒或斗诤
  乃至心念皆过失　　知已倍更勤修行
  菩萨思念于诸佛　　皆从忍辱证菩提
  忏悔如说持正行　　是如佛法而修学

    佛母宝德藏般若伽陀戒品第二十五

  若学戒法有作相　　而于戒法不善学
  知戒非戒无二相　　如是乃名学佛法
  若有菩萨住无相　　受持不离名持戒
  于佛法学乐承事　　是名善学而无著
  是大智者如是学　　心永不生不善法
  如日虚空而往来　　放百千光破黑闇
  若学般若住无为　　能摄一切波罗蜜
  六十二见身见摄　　般若摄受亦复尔
  譬如有人具诸根　　命根灭故诸根灭
  若诸菩萨行大智　　亦行一切波罗蜜
  声闻缘觉诸功德　　大智菩萨悉皆学
  虽学非住亦非求　　所学之学此为义

    佛母宝德藏般若伽陀幻化品第二十六

  若发志心而随喜　　最上菩提不退行
  三千须弥重无量　　随喜善法重过彼
  众生为求解脱法　　一切随喜作福蕴
  作佛功德法回施　　当为世间尽诸苦
  菩萨不着诸法空　　了知无相无挂碍
  内心亦不求觉智　　是行最上波罗蜜
  如虚空界无障碍　　无所得故亦不有
  大智菩萨亦复然　　住寂静行如虚空
  如有幻师作幻人　　众人见幻而皆喜
  幻人虽现种种相　　名字身心俱不实
  行般若行亦复然　　为世间说证菩提
  乃至种种所作事　　如幻师现悉无著
  佛佛化现诸佛事　　所作皆无彼我相
  菩萨大智行亦然　　一切现行如幻化
  如木匠人心善巧　　一木造作种种相
  菩萨大智亦复然　　无著智行一切行

    佛母宝德藏般若伽陀妙义品第二十七

  大智菩萨行如是　　天人合掌恭敬礼
  乃至十方佛刹中　　亦得功德鬘供养
  假使恒河沙佛刹　　所有众生皆作魔
  一一毛变无边相　　不能娆动于菩萨
  大智菩萨有四力　　而彼四魔不能动
  空行亦不舍众生　　菩萨慈悲处利乐
  佛母般若波罗蜜　　菩萨了知深信重
  内心真实而奉行　　应知是行一切智
  法界如实不可得　　由如虚空无处所
  如天宫殿应念生　　亦如飞禽思果树
  大智菩萨如是行　　住彼寂静之功德
  法不可见亦无说　　菩提非得非不得
  所有声闻及缘觉　　修行寂静三摩地
  爱乐寂静得解脱　　唯佛超出于一切
  菩萨依禅到彼岸　　不住寂静行如空
  如禽飞翔不堕地　　如鱼水中行自在
  菩萨若为诸众生　　当求未曾有佛智
  施与最上第一法　　此名最上行行者

    佛母宝德藏般若伽陀散华品第二十八

  如来说戒波罗蜜　　一切戒中为第一
  智者欲奉一切戒　　当学佛戒波罗蜜
  今此法藏诸佛母　　为最第一快乐所
  过现未来十方佛　　生此法界而无尽
  一切树林华果等　　皆从大地而生长
  大地不厌亦不着　　不减不增复不倦
  佛及声闻缘觉等　　天及世间安隐法
  皆从般若之所生　　般若无增亦无减
  世间上中下众生　　一切皆从无明生
  因缘和合转苦身　　无明无增亦无减
  乃至方便诸法门　　皆从般若所生出
  彼方便法随缘转　　般若无增亦无减
  菩萨了知十二缘　　乃至般若无增减
  如日云中放光明　　破无明障证菩提

    佛母宝德藏般若伽陀聚集品第二十九

  大菩萨修四禅定　　如所爱乐而无住
  或复不住于四禅　　当得最上之菩提
  得最般若住禅定　　四无色等三摩地
  为得最上大禅定　　而复不学诸漏尽
  此功德藏未曾有　　行三摩地而无相
  住彼不破于我见　　有心所思生欲界
  譬如南阎浮提人　　未生诸天生北洲
  见彼境界而求生　　作彼住已而复还
  菩萨所修之功德　　三摩地行而相应
  虽同凡夫住欲界　　由如莲华不着水
  菩萨度脱于众生　　圆满净土波罗蜜
  不求生于无色界　　而求菩提波罗蜜
  譬如天人获宝藏　　虽得不生爱乐心
  或言天人而起心　　欲收彼宝不可得
  大智菩萨不乐住　　四禅寂静三摩地
  出彼寂静三摩地　　而入欲界为世间
  若菩萨行三摩地　　不乐罗汉及缘觉
  乃至散乱凶恶心　　无知迷乱无功德
  色声香味触五欲　　及彼缘觉声闻等
  如是之法悉远离　　等引不离菩提心
  菩萨一向为众生　　修行精进波罗蜜
  由如奴仆事其主　　利于众生亦如是
  如仆事主心专注　　虽被嗔辱而无对
  凡所动止常在心　　唯恐彼主责其过
  菩萨为求佛菩提　　如奴事主利众生
  证得无上菩提已　　利生如火烧草木
  昼夜勤行利他行　　利已内心无我相
  如母爱子常卫护　　寒暑虽苦心无倦

    佛母宝德藏般若伽陀常欢喜品第三十

  菩萨爱乐为众生　　修治佛刹清净行
  恒行精进波罗蜜　　无如微尘心退倦
  大智菩萨俱胝劫　　久修苦行为菩提
  不离精进波罗蜜　　无懈怠心终得证
  从初发心为菩提　　乃至得获寂静证
  恒于昼夜行精进　　大智菩萨应如是
  有言能破于须弥　　方证无上菩提果
  闻已懈怠而退心　　是彼菩萨之过失
  大智菩萨闻是言　　谓须弥卢甚微小
  于一念间可破坏　　亦不住证佛菩提
  于身心语行精进　　度脱世间作大利
  或着我相起懈怠　　而不能证佛菩提
  无身心相无众生　　离诸相住不二法
  为求无上佛菩提　　是行精进波罗蜜
  大智菩萨行利乐　　令人闻言悉欢喜
  说法无说无听人　　名最上忍波罗蜜
  譬如宝满三千界　　施佛缘觉及罗汉
  不如知法忍功德　　百千万分不及一
  持忍菩萨得清净　　三十二相到彼岸
  一切众生悉爱乐　　闻法信受而调伏
  或有众生以栴檀　　涂菩萨身为供养
  或有持火遍烧然　　行平等心无嗔喜
  大智菩萨持是忍　　或为缘觉及声闻
  乃至世间诸众生　　悉皆回向佛菩提
  譬如世间贪五欲　　甘忍三涂无边苦
  菩萨为求佛菩提　　今何不勤持忍辱
  割截首足劓耳鼻　　禁缚捶拷诸楚毒
  如是苦恼悉能忍　　是住忍辱波罗蜜

    佛母宝德藏般若伽陀出法品第三十一

  持戒当得高名称　　亦复证得三摩地
  持戒为利诸众生　　后当证于佛菩提
  心重缘觉及声闻　　及见破戒说他过
  虽实持戒为菩提　　是名持戒行五欲
  欲证菩提功德法　　持戒具足行利乐
  若行毁破于尸罗　　是则灭坏于菩提
  菩萨虽乐受五欲　　归命佛法及圣众
  念我当证一切智　　是住尸罗波罗蜜
  菩萨经历俱胝劫　　奉行十善无间断
  心乐缘觉及罗汉　　是犯波罗夷重罪
  持戒回向佛菩提　　而不作念求自益
  但念利他诸众生　　是则持戒波罗蜜
  菩萨若行诸佛道　　于众生离种种相
  不见破戒诸过患　　此为最上善持戒
  菩萨要离于诸相　　无我无人及寿者
  不着戒相及行相　　是则持戒之殊胜
  如是具足而持戒　　一切无碍无分别
  头目手足施无吝　　一切所爱皆无著
  了知法本空无我　　乃于此身无恋着
  况外财物而不舍　　及彼非处而嫉妒
  于内外施生我慢　　是菩萨病非为施
  或起嫉妒生鬼趣　　或得为人处贫贱
  知彼众生贫贱因　　菩萨发心恒布施
  施如四洲草木数　　如是广大亦无相
  大智菩萨行施已　　复念三有诸众生
  菩萨亦为彼众生　　悉皆回向于菩提
  如是行施无所著　　亦复不求于果报
  名大智者为一切　　施因虽少果无量
  乃至三有诸众生　　一切皆以尊重施
  如供养佛及菩萨　　缘觉声闻之功德
  大智菩萨以方便　　用彼施福行回向
  当令一切众生类　　皆悉证得无上觉
  如假琉璃宝大聚　　不及一真琉璃宝
  回施世间一切众　　不及回施无上觉
  菩萨行施于世间　　不作我慢无所爱
  修行而得大增长　　如月离障出云中

    佛母宝德藏般若伽陀善护品第三十二

  菩萨布施济贫乏　　令得富盛度苦恼
  果报永灭饿鬼趣　　及得断除诸烦恼
  持戒远离畜生趣　　舍八非念得正念
  忍辱当得最上色　　如金世间悉爱乐
  精进善法获无边　　所有功德不可尽
  修行禅定离五欲　　从等持得神通明
  智获无边佛法藏　　慧了诸法本来因
  佛知三界诸过咎　　为转法轮灭诸苦
  菩萨此法得圆满　　佛刹清净众生净
  受持佛种并法种　　圣众种及一切法
  医世间病最上师　　以智慧说菩提方
  宝德藏有种种药　　令众生服悉证道

佛母宝德藏般若波罗蜜经卷下


佛说佛母出生三法藏般若波罗蜜多经

    No. 228 [Nos. 220(4or5), 224-227, cf. 229]

佛说佛母出生三法藏般若波罗蜜多经卷第一

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    了知诸行相品第一之一

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众千二百五十人俱。皆是阿罗汉。一切漏尽无余烦恼。心善解脱慧善解脱如大龙王。诸有所作皆悉具足。舍彼重担得大善利。尽诸有结正智无碍。心住寂静已得自在。唯一尊者住补特伽罗。所谓阿难

尔时世尊告尊者须菩提言。随汝乐欲为诸菩萨摩诃萨。如其所应宣说般若波罗蜜多法门。是时尊者舍利子即起是念。今尊者须菩提为以自智慧辩才。而为宣说菩萨摩诃萨般若波罗蜜多耶。为以佛威神及加持力而为说耶

尔时尊者须菩提承佛威神知舍利子于如是色如是心有所思念。既知是已即告舍利子言。汝今当知。世尊所有声闻弟子。于诸法中若自宣说或为他说。一切皆是佛威神力。何以故。佛所说法若于是中能修学者。彼能证得诸法自性。以证法故有所言说。皆与诸法无所违背。是故舍利子。佛所说法顺诸法性。诸善男子当如是知

尔时尊者须菩提白佛言。世尊。佛作是言。令我随所乐欲。如其所应宣说菩萨摩诃萨般若波罗蜜多。世尊。以何等义名为菩萨。当说何法为菩萨法。世尊。我不见有法名为菩萨。亦不见有法名为般若波罗蜜多。以是义故。若菩萨及菩萨法。皆无所有不可见不可得。般若波罗蜜多亦无所有不可见不可得。我当为何等菩萨教何等般若波罗蜜多。世尊。若菩萨摩诃萨闻作是说。心无所动不惊不怖亦不退没。是即名为教菩萨摩诃萨般若波罗蜜多。是即了知般若波罗蜜多。是即安住般若波罗蜜多

复次世尊。菩萨摩诃萨行般若波罗蜜多时。观想般若波罗蜜多时。应如是学。而彼菩萨虽如是学。不应生心我如是学。何以故。彼心非心心性净故

尔时尊者舍利子白须菩提言。云何须菩提。有彼心非心不。须菩提言。舍利子。于汝意云何。若心非心于有于无为可得耶。舍利子言。不也须菩提。是时须菩提告舍利子言。若心非心于有于无不可得者。汝今何故作如是言有心非心耶。舍利子言。何名非心性。须菩提言。一切无所坏远离诸分别。是为非心性

尔时尊者舍利子赞须菩提言。善哉善哉。须菩提。诚如佛说。汝于无诤三昧行中最胜第一。若菩萨摩诃萨如是学者。即得不退转于阿耨多罗三藐三菩提。当知是菩萨摩诃萨不离般若波罗蜜多。若有人欲学声闻法者。当于此般若波罗蜜多听受读诵记念思惟如说修行。是即于此般若波罗蜜多修学相应。若欲学缘觉法者。当于此般若波罗蜜多听受读诵记念思惟如说修行。是即于此般若波罗蜜多修学相应。若欲学菩萨法者。当于此般若波罗蜜多听受读诵记念思惟如说修行。是即于此般若波罗蜜多善巧方便。而得具足诸菩萨法聚集相应。何以故。此般若波罗蜜多广说一切菩萨藏法。若菩萨摩诃萨如是学者于菩萨法是即相应。若欲修学阿耨多罗三藐三菩提法者。当于此般若波罗蜜多听受读诵记念思惟如说修行。是即于此般若波罗蜜多。方便具足集诸佛法。何以故。此般若波罗蜜多广说一切阿耨多罗三藐三菩提法。若菩萨摩诃萨如是学者。于无上法而得相应

尔时尊者须菩提白佛言。世尊。所言菩萨摩诃萨者。我不可见亦不可得。而菩萨但有名字。世尊。即此名字亦不可见不可得。般若波罗蜜多亦但有名字不可见不可得。当为何等菩萨教何等般若波罗蜜多。以是义故我即生疑。世尊。我于名字中求菩萨摩诃萨毕竟不可得。而彼名字无住处非无住处。无决定无不决定。何以故。彼名字性无所有故。是故无住处非无住处。无决定无不决定。若菩萨摩诃萨闻此甚深般若波罗蜜多。于无所动不惊不怖亦不退没。当知是菩萨摩诃萨不离般若波罗蜜多。住菩萨地而不退转。善住无住相应

复次世尊。若菩萨摩诃萨行般若波罗蜜多时。观想般若波罗蜜多时。不住于色不住受想行识。何以故。若住于色即行色行。非行般若波罗蜜多。若住受想行识即行受想行识。非行般若波罗蜜多。何以故。住于诸法即不能受般若波罗蜜多。与般若波罗蜜多而不相应。不能圆满般若波罗蜜多。不能成就一切智。何以故。般若波罗蜜多不受于色不受受想行识。若不受色即非色。不受受想行识即非受想行识。是故般若波罗蜜多亦无所受。菩萨摩诃萨于无受法中当如是行。此即名为菩萨摩诃萨。一切法无受三摩地。广大圆满无量决定。不为一切声闻缘觉所坏。世尊。彼一切智。无有相无所取。若有相可取者。彼室哩尼迦波哩没啰惹迦。如是等人于一切智不应生信。何以故。此人于一切智而生信解。以有量智入如是法。不受于色不受受想行识。不以喜乐法为智所观。不以内色为智所观。不以外色为智所观。不以内外色为智所观。亦不离内外色为智所观。如是不以内受想行识为智所观。不以外受想行识为智所观。不以内外受想行识为智所观。亦不离内外受想行识为智所观。而彼室哩尼迦等。于如是法及一切智智深生信解。于诸法性而得解脱。又于一切法无取无非取。乃至涅盘亦无取无非取。世尊。修菩萨法者。虽于色受想行识而无所受。彼未圆满如来十力四无所畏十八不共法。亦不中道取证涅盘。是故世尊。菩萨摩诃萨应如是了知般若波罗蜜多。

复次世尊。若菩萨摩诃萨行般若波罗蜜多时。观想般若波罗蜜多时应作是观。何法是般若波罗蜜多。般若波罗蜜多为何等相。诸法无所生亦复无所得。般若波罗蜜多其云何有。若菩萨作是观时。心无所动不惊不怖亦不退没。当知是菩萨摩诃萨不离般若波罗蜜多

尔时尊者舍利子白须菩提言。若诸色法离色自性。受想行识离受想行识自性。般若波罗蜜多离般若波罗蜜多自性。一切智复离般若波罗蜜多自性。般若波罗蜜多复离一切智自性。一切智离一切智自性者。云何说。菩萨摩诃萨不离般若波罗蜜多。须菩提言。舍利子。如是如是。一切色法离色自性。受想行识离受想行识自性。乃至一切智离一切智自性。般若波罗蜜多相离般若波罗蜜多相自性。诸相离诸相自性。无性亦离自性

尔时尊者舍利子复白须菩提言。云何须菩提。若菩萨摩诃萨是中学者彼能成就一切智不。须菩提言如是如是。舍利子。若菩萨摩诃萨如是学者彼能成就一切智。何以故。诸法无生亦非无生。菩萨摩诃萨能如是了知。如是行者即能随顺亲近彼一切智。身心清净诸相清净。在在处处严净佛土。成熟有情具诸佛法。是为菩萨摩诃萨修行般若波罗蜜多近一切智

复次尊者须菩提言。若有菩萨摩诃萨行于色法此为行相。若行色相此为行相。若生色行此为行相。若灭色行此为行相。若坏色行此为行相。若空色行此为行相。我行诸行亦是行相。我行菩萨行亦是行相。于菩萨法我有所得亦是行相。如是若行受想行识此为行相。若行受想行识相此为行相。若生受想行识此为行相。若灭受想行识此为行相。若坏受想行识此为行相。若空受想行识此为行相。我行诸行亦是行相。我行菩萨行亦是行相。于菩萨法我有所得亦是行相。若作是念能如是行乃名行般若波罗蜜多亦是行相

若如是行者当知此菩萨未能具足善巧方便尔时尊者舍利子白须菩提言。当云何行是为菩萨摩诃萨行般若波罗蜜多。须菩提言。舍利子。若菩萨摩诃萨不行于色不行色相。不行色生不行色灭。不行色坏不行色空。不行我行不起我行。菩萨行如是。不行受想行识。不行受想行识相。不行受想行识生。不行受想行识灭。不行受想行识坏。不行受想行识空。不行我行不起我行。菩萨行不作是念。若如是行乃名行般若波罗蜜多。若如是者是名菩萨摩诃萨行般若波罗蜜多。而彼菩萨摩诃萨虽如是行。即不念我行不念我不行。不念我亦行亦不行。不念我非行非不行。又复不念有所行。不念无所行。不念亦有所行亦无所行。不念非有所行非无所行。何以故。一切法无念无取无非取。此名菩萨摩诃萨一切法无受三摩地。广大圆满无量决定。不为一切声闻缘觉所坏。此三摩地遍入一切三摩地行。若菩萨摩诃萨能如是行者。速得成就阿耨多罗三藐三菩提

是时尊者须菩提。承佛威神作如是言。若菩萨摩诃萨虽行无数三摩地而无行相。虽见无数三摩地而无所见。彼菩萨不作是念。此三摩地我已入。此三摩地我当入。此三摩地我今入。如是一切时一切处一切种。离一切相而无所生。若如是者当知是菩萨已从先佛。得授阿耨多罗三藐三菩提记

尔时尊者舍利子白须菩提言。若菩萨摩诃萨于三摩地无所行相。彼得如来应供正等正觉。与授阿耨多罗三藐三菩提记者。而此三摩地为有所观不。须菩提言。不也舍利子。何以故。彼三摩地性无所有。离诸分别及所了知

尔时世尊赞言。善哉善哉。须菩提。如是如是。须菩提。如佛世尊威神辩才及加持力。如是宣说诸菩萨摩诃萨当如是行如是修学。何以故。若菩萨摩诃萨如是学者。是为修学般若波罗蜜多

是时尊者舍利子白佛言。世尊。若菩萨摩诃萨如是修学。是即修学般若波罗蜜多耶。佛言。舍利子。如是如是。若菩萨摩诃萨如是学者。是为修学般若波罗蜜多。舍利子白佛言。世尊。若菩萨摩诃萨如是修学当学何法。佛言。舍利子。若菩萨摩诃萨了法无所有亦复无所学。是为修学。何以故。彼一切法皆无所有。而诸愚异生于无法中分别执着。舍利子白佛言。世尊。若法无所有今云何有。佛言。舍利子。诸法无所有今如是有。彼诸愚异生于无法中以不了故说为无明。是故执着无明。以执着故起分别心。由分别故堕于二边。如是展转于一切法。种种分别起所得相。彼分别已依于二边而生执着。是故分别过去诸法。分别未来诸法。分别现在诸法。以诸分别故执著名色。舍利子。彼诸异生不了诸法无所有性起分别者。于如实道不能了知亦不能见。由不知见故不出三界。于实际法不能安住亦不生信。是故堕彼愚异生数

尔时尊者舍利子复白佛言。世尊。若菩萨摩诃萨如是学者是学一切智不。佛言。舍利子。菩萨摩诃萨如是学者非学一切智。菩萨摩诃萨如是学者亦学一切智。如是学者亦学一切法。得近一切智成就一切智

是时尊者须菩提白佛言。世尊。若有幻人作是问言。云何修学一切智。云何亲近一切智。云何成就一切智。彼若作是问我当云何答。佛言。须菩提。我今问汝随汝意答。须菩提言。善哉世尊。愿乐欲闻。佛言。须菩提。于汝意云何。幻异于色色异幻不。如是幻异受想行识。受想行识异于幻不。须菩提言。不也世尊。异幻非色异色非幻。彼幻即色彼色即幻。受想行识亦复如是。佛言。须菩提。于意云何。所有五取蕴是菩萨不。须菩提言。如是世尊。如是善逝。佛告须菩提。当知五取蕴即是幻人。何以故。说色如幻受想行识亦如幻。彼色受想行识。即是六根五蕴。是故菩萨摩诃萨亦如幻。若欲修学般若波罗蜜多者。当如幻学即得阿耨多罗三藐三菩提

须菩提白佛言。世尊。若有初住大乘菩萨。闻作是说得无惊怖耶。佛言。须菩提。彼初住大乘菩萨若随恶知识。即于是法闻已惊怖。而彼菩萨若随善知识。即闻是法不生惊怖。须菩提白佛言。世尊。云何名为菩萨摩诃萨恶知识。佛言。若有教令远离般若波罗蜜多者。是为菩萨恶知识。何名菩萨善知识。佛言。若于般若波罗蜜多。自所宣说转教他人。复为他人广示魔业及魔过失。劝令觉了觉已复令远离。又复劝令不离诸佛。须菩提当知。是人被大乘铠大乘庄严安住大乘。是为菩萨摩诃萨善知识。须菩提白佛言。世尊。如佛所说。菩萨摩诃萨被大乘铠大乘庄严安住大乘。世尊。当说何句义是菩萨义。佛言。须菩提。当知非句义是菩萨义。何以故。菩萨于一切法无所障碍。于一切法如实了知。乃至阿耨多罗三藐三菩提亦无障碍亦如实知。此说为菩萨义。又复世尊。云何得名摩诃萨。佛言。于有情聚中而为最上。以是义故名为摩诃萨

尔时尊者舍利子白佛言。世尊。我亦乐说摩诃萨义。佛言。随所乐说今正是时。舍利子言所有我见。众生见。命者见。补特伽罗见。诸有趣见。断见。常见。及有身见。若离如是等见为众生说法者是为摩诃萨。

尔时尊者须菩提白佛言。世尊。我亦乐说摩诃萨义。佛言。随所乐说今正是时。须菩提言。若菩提心。一切智心。无漏心。无等心。无等等心。于如是心无碍无著。不为一切声闻缘觉所坏。以是义故名为摩诃萨。由此入于菩萨摩诃萨数时尊者舍利子白须菩提言。云何彼心无碍无著须菩提言。以无心故心无障碍亦无所著。舍利子言。心义云何。须菩提言。舍利子。心于有无为可生耶。为可得耶。舍利子言。不也须菩提。是时须菩提告舍利子言。心于有无若不可得者。何故于心有所说耶。尊者舍利子赞须菩提言。善哉善哉。须菩提。诚如佛说。汝于无诤三昧行中最胜第一

尔时尊者满慈子白佛言。世尊。我亦乐说摩诃萨义。佛言。随所乐说今正是时。满慈子言。摩诃萨者所谓被大乘铠以大乘法而自庄严安住大乘。是故说为摩诃萨义。是时须菩提白佛言。世尊。所言菩萨摩诃萨被大乘铠者。以何义故名大乘铠。佛言。若菩萨摩诃萨作如是念。我应度无量无数众生令至涅盘。虽度如是众生。已于诸众生无所度想。而无一众生得涅盘者。何以故。一切法性本如是故离诸起作。须菩提。譬如幻师于四衢道以其幻法出多人聚出已即隐。须菩提。于汝意云何。是诸幻人有所从来有其实不。有所灭去有所坏不。须菩提言。不也世尊。佛言。须菩提。菩萨摩诃萨亦复如是。虽度无量无数众生令至涅盘。而实无众生有所度者若菩萨摩诃萨闻作是说不生惊怖。当知是菩萨摩诃萨被大乘铠而自庄严

尔时尊者须菩提白佛言。世尊。如我解佛所说义。菩萨摩诃萨若如是了知者。是为被大乘铠勇猛坚固而善庄严。佛言。须菩提。如是如是。何以故。彼一切智是无为无作法。为利众生故起诸方便。而彼众生亦是无为无作法。须菩提言。诚如佛说。所以者何。色无缚无解。受想行识亦无缚无解。世尊。色真如无缚无解。受想行识真如亦无缚无解

尔时尊者满慈子白须菩提言。如尊者所说。色无缚无解。受想行识无缚无解。色真如无缚无解。受想行识真如无缚无解者。此中何等是色无缚无解。何等是受想行识无缚无解。何等是色真如无缚无解。何等是受想行识真如无缚无解。须菩提答言。满慈子。汝今当知。幻人色无缚无解。幻人受想行识无缚无解。幻人色真如无缚无解。幻人受想行识真如无缚无解。何以故。无所有故无缚无解。离故无缚无解。不生故无缚无解。若菩萨摩诃萨如是了知者。是即安住大乘被大乘铠大乘庄严。即时尊者满慈子。闻是说已默然而住

尔时尊者须菩提白佛言。世尊。如佛所言。菩萨摩诃萨安住大乘被大乘铠大乘庄严。世尊以何义故为名大乘。菩萨云何了知。是乘从何所出。出已于何所住。佛告须菩提。大乘者无限量无分数无边际。以是义故名为大乘。菩萨摩诃萨即如是了知。又言大乘从何所出住何处者。是乘从三界出住波罗蜜多。彼无所著故即住一切智。从是出生菩萨摩诃萨

复次须菩提。若法无所出亦复无所住。以无住故即一切智无住相应。又此大乘亦无所有即无所出。无出故如是出。所以者何。若有所出若无所出。如是二法俱不可得而无所生。乃至一切法中。无法可出亦无非法可出。须菩提。菩萨摩诃萨般若波罗蜜多如是出生

尔时尊者须菩提白佛言。世尊。如佛所说。彼大乘法于一切世间天人阿修罗中。而为最胜与虚空等。如彼虚空能受无量无数众生。彼大乘法亦复如是。能受无量无数众生。世尊。菩萨摩诃萨于大乘法不见有来不见有去亦无住处。前际不可得后际不可得中际不可得。三世平等无所生故。是故大乘义如是说

尔时世尊赞言。善哉善哉。须菩提。如是如是。须菩提。菩萨摩诃萨于大乘法如是修学。彼菩萨摩诃萨即得成就一切智

佛说佛母出生三法藏般若波罗蜜多经卷第一佛说佛母出生三法藏般若波罗蜜多经卷第二

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    了知诸行相品第一之二

尔时尊者满慈子白佛言。世尊。佛令须菩提说般若波罗蜜多。何故于今说大乘法。时尊者须菩提即白佛言。世尊。我所说大乘将无违彼般若波罗蜜多耶。佛言。不也须菩提。如汝所说随顺般若波罗蜜多

是时须菩提承佛神力白佛言。世尊。我于前后中际求菩萨摩诃萨了不可得。何以故。色无边。故菩萨摩诃萨亦无边。受想行识无边故菩萨摩诃萨亦无边。色是菩萨无所有故不可得。受想行识是菩萨无所有故不可得。世尊。如是一切时一切处一切种。求菩萨摩诃萨毕竟不可得。般若波罗蜜多亦不可见不可得。乃至一切智亦不可见不可得。如是一切法于一切时一切处一切种。皆不可见不可得。云何为法云何为非法。当以何法教入般若波罗蜜多。世尊。菩萨但有名字。般若波罗蜜多亦但有名字。而彼名字亦无所生。世尊。如说我我法毕竟无所生。我无自性故一切法亦尔。此中云何色无著无生。云何受想行识无著无生。一切法无性故无著无生。以法无性故一切法无生。是故无生亦无生。我今即以无生法。教入般若波罗蜜多。世尊。若离无生法求一切法。乃至佛菩萨法了不可得。何以故。若离无生法者。菩萨摩诃萨无能成就彼菩提行。世尊。若菩萨摩诃萨闻作是说心无所动。不惊不怖亦不退没。当知是菩萨摩诃萨行般若波罗蜜多。观想般若波罗蜜多。世尊。若菩萨摩诃萨于般若波罗蜜多。若行若观想时不受于色。不见色生不见色灭。如是不受受想行识。不见受想行识生不见受想行识灭。何以故。若色无生即非色。若色无灭即非色。此无生与色无二无别。无灭与色亦无二无别。若说色即是无二法。若受想行识无生即非受想行识。若受想行识无灭即非受想行识。此无生与受想行识无二无别。无灭与受想行识亦无二无别。若说受想行识即是无二法。世尊。菩萨摩诃萨于般若波罗蜜多。如是观已。即于色受想行识。无所受无所生无所灭。乃至一切法一切相亦复如是。何以故。若色受想行识无生无灭即非色受想行识。此色受想行识与无生无灭无二无别。若说色受想行识即是无二法。

尔时尊者舍利子白须菩提言。如我解尊者须菩提所说义。菩萨即是无生法。若如是者云何菩萨为利众生故。有难行行及难行想。须菩提言。舍利子。我不欲令菩萨摩诃萨有难行行及难行想。何以故。若有难行想即不能利益无量无数众生。若于一切众生。生易想乐想父想母想及彼子想。如是即能利益无量无数众生。菩萨摩诃萨于一切众生当生如是想。我于一切时一切处解脱一切苦。一切众生亦如是。于一切时一切处解脱一切苦。于一切处不舍众生。普令众生解脱苦蕴。于诸心意不生过失。菩萨摩诃萨于诸众生若生如是心。即无难行行无难行想。舍利子。菩萨摩诃萨应生如是心。如我于一切时一切处一切种。毕竟无所有不可得故。彼一切法于一切时一切处一切种。亦毕竟无所有不可得。如是即于内外一切法生无所有想。若菩萨摩诃萨以如是心行。即无难行行无难行想

复次尊者舍利子。汝先所言菩萨无生。如是如是。菩萨实无生。舍利子言。若菩萨无生。彼菩萨法岂无生耶。须菩提言。菩萨法亦无生。舍利子言。若菩萨法无生者。彼一切智为无生不。须菩提言。一切智无生。舍利子言一切智法为无生不。须菩提言。一切智法亦无生。舍利子言。若一切智法亦无生者。彼诸异生是无生不。须菩提言。诸异生类亦复无生。又言彼异生法为无生不。须菩提言。诸异生法亦即无生。尊者舍利子白须菩提言。若菩萨菩萨法。一切智一切智法。异生异生法皆无生者。彼菩萨摩诃萨得一切智即是无生。得无生耶。尊者须菩提言。舍利子。我不欲令无生法有所得。何以故。无生法不可得故。舍利子言。无生法不得无生耶。须菩提言。如是如是。无生法不得无生。舍利子言。若彼法无生。无生亦无生不。须菩提言。生法无生。无生亦无生。舍利子言。若无生亦无生者。汝所言所乐说为生为无生。须菩提言。乐说亦无生。舍利子言。若乐说无生者所言无生不。须菩提言。所言所乐说一切皆无生。尊者舍利子赞须菩提言。善哉善哉。须菩提。汝于说法人中最胜第一。何以故。随有所问而悉能答。于诸法相无动无坏。须菩提言。舍利子。法本如是。佛诸弟子于无依止法中。随有所问而悉能答于诸法相无动无坏。何以故。一切法无所依止。舍利子白须菩提言。若一切法无所依止。菩萨摩诃萨依何波罗蜜多。须菩提言。依般若波罗蜜多。舍利子当如实知。彼一切法无依止故。诸波罗蜜多亦复如是。若菩萨摩诃萨闻此甚深般若波罗蜜多时应作是念。无说无示无闻无得。心无所动无所求相无所持相。当知是菩萨摩诃萨行无数般若波罗蜜多行不离是念

尔时尊者舍利子白须菩提言。云何菩萨摩诃萨行般若波罗蜜多不离是念。若菩萨摩诃萨不离是念。即得不离般若波罗蜜多行。若菩萨摩诃萨不离般若波罗蜜多行。即得不离是念。须菩提。若菩萨摩诃萨不离是行不离是念者。彼一切众生亦应得不离般若波罗蜜多行。何以故。一切众生亦不离是行不离是念。须菩提言。舍利子。如汝所说成就我义。何以故。众生无性故当知念亦无性。众生离故当知念亦离。众生无心故当知念亦无心。众生无觉了故当知念亦无觉了。众生知如实义故念亦知如实义。舍利子。我欲令诸菩萨摩诃萨如是行般若波罗蜜多

    帝释天主品第二

尔时帝释天主。与四十千天众俱来会中。四大天王与二十千天众。娑婆世界主大梵天王与十千梵众。净居天子与千天众。如是等皆来集会。彼诸天子所有业报光明。以佛威神胜光明故皆悉不现

是时帝释天主白尊者须菩提言。我等诸天乃至梵众。皆悉来集乐欲听受。尊者须菩提。为诸菩萨摩诃萨宣说般若波罗蜜多。令诸菩萨云何安住。云何修学云何相应。须菩提言。憍尸迦。今此天子众中。以佛威神加持力故。若有未发阿耨多罗三藐三菩提心者应当发心。若已入正位者。即不堪任发阿耨多罗三藐三菩提心。何以故。彼于轮回有所缚故。如是等人若有能发阿耨多罗三藐三菩提心者。我亦随喜劝令发心。于其善根使不断绝

尔时世尊赞言。善哉善哉。须菩提。汝善劝导诸菩萨摩诃萨。令于般若波罗蜜多而得相应。须菩提白佛言。世尊。佛于众生有大恩德。我今为报佛恩故如是劝导。何以故。过去如来应供正等正觉所有弟子。亦为报佛恩故劝导诸菩萨摩诃萨。令诸菩萨如其梵行住真实法。亦教成就般若波罗蜜多。以如是行故发生无上智。世尊。我今亦如是摄受护持诸菩萨摩诃萨。以我如是摄受护持因缘力故诸菩萨摩诃萨速得成就阿耨多罗三藐三菩提

尔时尊者须菩提告帝释天主言。汝等谛听。如理思惟。我今宣说菩萨摩诃萨般若波罗蜜多安住空法。令诸菩萨被大乘铠大乘庄严。当知般若波罗蜜多所谓不住五蕴。不住眼根不住色境。不住眼识不住眼触亦复不住眼触所生诸受。如是不住耳鼻舌身意根。不住声香味触法境。不住耳鼻舌身意识。不住耳触乃至意触。亦复不住耳触乃至意触所生诸受。不住地水火风空识界。不住念处正勤神足根力觉道。不住须陀洹果。不住斯陀含果。不住阿那含果。不住阿罗汉果。不住缘觉果。不住佛地。以如是不住五蕴乃至不住佛地故。不住色受想行识若常若无常。不住色受想行识若苦若乐。不住色受想行识若空若不空。不住色受想行识若我若无我。不住色受想行识若净若染。不住色法有所得空。不住受想行识有所得空。不住须陀洹无为果。不住斯陀含无为果。不住阿那含无为果。不住阿罗汉无为果。不住缘觉无为果。不住佛法。不住须陀洹福田。不住须陀洹七往来身。不住斯陀含福田。不住斯陀含毕竟一来此世尽苦边际。不住阿那含福田。不住阿那含不还此世于彼涅盘。不住阿罗汉福田。不住阿罗汉现世入于无余涅盘。不住缘觉福田。不住缘觉出过声闻不及佛地而趣涅盘。不住诸佛最上福田。不住佛法出过异生及声闻缘觉地。利益无量无数众生。复令无量无数百千俱胝那庾多众生。不趣声闻缘觉无余涅盘。决定趣证正等正觉无上涅盘建立佛事。诸如是等皆悉不住

尔时尊者舍利子即起是念。若诸如来出过异生及声闻缘觉地。利益无量无数众生。复令无量无数百千俱胝那庾多众生。不趣声闻缘觉无余涅盘。决定趣证正等正觉无上涅盘。建立佛事。于如是法皆不住者当于何住

是时尊者须菩提。承佛威神知其念已。即谓尊者舍利子言。舍利子。于汝意云何。如来应供正等正觉有法可住不。舍利子言。不也须菩提。如来应供正等正觉无法可住。何以故。彼无住心名为如来。不住有为界不住无为界。不住彼中故。须菩提告言。如是如是。舍利子。诸菩萨摩诃萨应当如彼如来应供正等正觉所住而住。如是住者非有所住非无所住。非为决定非不决定。菩萨摩诃萨如是学者。而善安住无住相应。菩萨摩诃萨如是学者。是行般若波罗蜜多行

尔时会中有诸天子作是思惟。诸夜叉众所有语言文字章句尚可了知。而尊者须菩提所说诸法。我等天众无能解了。时须菩提知诸天子于其色心所思念已。告诸天子言。汝等当知。彼一切法无说无示无闻无得。离诸分别无所了知。是时诸天子众复作是念。如尊者须菩提所说转复难解。广大深远最上微妙。我等天众难可得入

尔时尊者须菩提又复知诸天子心所念已。即时告言。汝等当知。若欲得须陀洹果。欲住须陀洹果者当住是忍。若欲得斯陀含果欲住斯陀含果。若欲得阿那含果欲住阿那含果。若欲得阿罗汉果欲住阿罗汉果。若欲得缘觉果欲住缘觉果。若欲得阿耨多罗三藐三菩提果。欲住阿耨多罗三藐三菩提果者皆住是忍。时诸天子闻是说已又复思惟。当有何人能听受尊者须菩提说法。时须菩提承佛威神。又知其念。重复告言。诸天子众汝等当知。彼诸幻人而能听受我所说法。何以故。彼于诸法无闻无证。是时诸天子众白须菩提言。云何尊者。一切众生为如幻不。须菩提言。一切众生皆悉如幻亦复如梦。所以者何。一切众生与其幻梦无二无别。以如是故彼一切法亦如幻梦。所有须陀洹须陀洹果。斯陀含斯陀含果。阿那含阿那含果。阿罗汉阿罗汉果。缘觉缘觉果。皆如幻如梦。彼阿耨多罗三藐三菩提果亦如幻如梦

尔时诸天子众复白尊者须菩提言。若阿耨多罗三藐三菩提。说如幻梦者。彼涅盘法亦如幻梦耶。须菩提言。如是涅盘亦如幻梦况余法耶。诸天子言。彼涅盘法何故亦说如幻梦耶。须菩提言。若复有法过涅盘者我亦说为如幻如梦。何以故。而彼幻梦与涅盘法无二无别故

尔时尊者舍利子。尊者满慈子。尊者摩诃俱絺罗。尊者摩诃迦旃延。尊者摩诃迦叶。如是等大声闻众。并诸菩萨摩诃萨众。俱白尊者须菩提言。如尊者所说般若波罗蜜多。何人能受其义。是时阿难。即告众言。所有不退转菩萨摩诃萨具正见人。及彼漏尽诸阿罗汉。当知是等。于须菩提所说般若波罗蜜多能受其义

尔时须菩提告诸众言。我所说般若波罗蜜多无能受者。何以故。此中无法宣说。无法表示无所分别无所了知。以无说示无了知故。般若波罗蜜多。如是宣说如是听受

是时帝释天主即作是念。今尊者须菩提。宣说如是甚深正法。我当化诸妙华以散其上。作是念已即时化出无数妙华。散于尊者须菩提上。是时须菩提即作是念。此所化出无数妙华。我于三十三天上曾所未见。此华殊妙非树所生。时帝释天主知尊者须菩提心所念已。即白须菩提言。此华非生法。何以故。不从心生不从树出。须菩提言。憍尸迦。此华若不从树生又非心出者即是无生。若其无生即不名华。帝释天主即作是念。此尊者须菩提智慧甚深。于名句文而善宣说。随其所说不坏假名说如实义。作是念已即白须菩提言。如尊者所说。菩萨摩诃萨应如是学

尔时尊者须菩提告帝释天主言。憍尸迦。如是如是。菩萨摩诃萨当如是学。如是学者不学须陀洹果。不学斯陀含果。不学阿那含果。不学阿罗汉果。不学缘觉果。若不学如是果是即学一切智安住佛法。如是安住者即学无量无边佛法。如是学者虽学色法无所增减。虽学受想行识亦无所增减。若于色受想行识不增减学者。即不取色学不取受想行识学。不舍色学不舍受想行识学。若法无取无舍即法无生无灭。若了一切法无取无舍无生无灭。如是学者是即名为学一切智。出生一切智

尔时尊者舍利子白须菩提言。若菩萨摩诃萨。于法无所取故。学无生灭故。学者彼一切智。亦无所取故。学无生灭故。学菩萨摩诃萨。若如是学者。当为修学一切智不。须菩提言。如是如是。彼一切智乃至一切佛法。无所取无生灭。如是修学者。是为菩萨摩诃萨学一切智

尔时帝释天主。白尊者舍利子言。菩萨摩诃萨。般若波罗蜜多当于何求。舍利子言。憍尸迦。菩萨摩诃萨般若波罗蜜多。当于须菩提所转中求。帝释天主言。尊者舍利子。彼须菩提所说般若波罗蜜多。是何神力所加持故。舍利子言。憍尸迦。当知是佛神力所加持故是时尊者须菩提。告帝释天主言。我所说般若波罗蜜多。当知皆是如来神力所加持故。所言菩萨摩诃萨般若波罗蜜多当于何求者。当知菩萨摩诃萨般若波罗蜜多。不应于色中求。不应离色中求。如是不应于受想行识中求。不应离受想行识中求。何以故。色非般若波罗蜜多。离色亦非般若波罗蜜多。受想行识非般若波罗蜜多。离受想行识亦非般若波罗蜜多。帝释天主言。尊者须菩提。大波罗蜜多是般若波罗蜜多耶。无量波罗蜜多是般若波罗蜜多耶。无边波罗蜜多是般若波罗蜜多耶。须菩提言。如是如是。憍尸迦。大波罗蜜多是谓般若波罗蜜多。无量波罗蜜多是谓般若波罗蜜多。无边波罗蜜多是谓般若波罗蜜多。何以故。色广大故般若波罗蜜多亦广大。受想行识广大故。般若波罗蜜多亦广大。色受想行识无量故。般若波罗蜜多亦无量。色受想行识无边故。般若波罗蜜多亦无边

复次憍尸迦。缘无边故即般若波罗蜜多无边。以般若波罗蜜多无边故众生亦无边。以何义故名缘无边。所谓色受想行识。前际不可得中际不可得后际不可得。乃至一切法于前后中际亦不可得。以是义故名缘无边。即般若波罗蜜多无边。又复以何义故说众生无边。憍尸迦当知。前后中际无众生可得。帝释天主言。云何须菩提。彼众生界岂无边耶。须菩提言。众生无量算数不及。以是义故众生无边。帝释天主。复白尊者须菩提言。所言众生者以何义故名为众生。须菩提言。一切法义是众生义。憍尸迦。于汝意云何。当说何义为众生义。帝释天主言。如我意者。非法义是众生义。非非法义是众生义。当知众生无本无因无我无缘。而以方便立彼名字。须菩提言。憍尸迦。我先所说众生无边。于汝意云何。实有众生可说可示不。帝释天主言。不也须菩提。时须菩提言。若诸众生无有其实不可说示者。是故我说众生无边。憍尸迦。假使如来应供正等正觉。住寿如兢伽沙劫。以方便语言。说一切众生若已生若现生若当生。若已灭若现灭若当灭。而能说其边际不。帝释天主言。不也须菩提。何以故。一切众生本来清净。须菩提言。如是众生无边故。当知般若波罗蜜多亦无边。是时会中帝释天主大梵天王。及大世主并余诸天。天女神仙众等。俱白佛言。快哉善哉。如来出世。尊者须菩提。能善宣说般若波罗蜜多。菩萨摩诃萨受持此法。若不离诸佛如来般若波罗蜜多者。我当尊敬如诸佛想

尔时世尊。告帝释天主大梵天王并余一切天仙众言。如是如是。汝等当知。我于往昔最上灯城燃灯如来应供正等正觉所修菩提行。我于尔时亦不离般若波罗蜜多。彼燃灯如来。即为我授阿耨多罗三藐三菩提记作如是言。汝于来世过阿僧祇劫当得成佛。号释迦牟尼如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。是时帝释天主并诸天众。俱白佛言。希有世尊。希有善逝。此般若波罗蜜多能摄一切智。菩萨摩诃萨当如是学

    宝塔功德品第三之一

尔时世尊。普告四众苾刍苾刍尼优婆塞优婆夷帝释天主等。欲界诸天众。大梵天王等。色界诸天众。乃至色究竟天。一切天子众。汝等当知。若有善男子善女人。于此甚深般若波罗蜜多法门能听受读诵。如说修行者。是人不为魔及魔民人非人等伺得其便。不为恶毒所能伤害。不以横夭舍其寿命

复次若有善男子善女人。于此般若波罗蜜多。未能听受读诵者。所有已发阿耨多罗三藐三菩提心。诸天子众往彼人所为作护念。劝令于此般若波罗蜜多。听受读诵如说修行

复次若有善男子善女人。于此般若波罗蜜多。受持读诵如说修行者。是人若在空室若入众中。若在树下及旷野处。若行道路及非道中乃至大海。如是等处若行若住若坐若卧。离诸怖畏诸天护念

尔时四大天王白佛言。世尊。若有善男子善女人。于此般若波罗蜜多。听受读诵如说修行者。我当往彼护念其人。使令精进不生退屈

尔时帝释天主白佛言。世尊。若善男子善女人。于此般若波罗蜜多。听受读诵如说修行者。我亦往护其人令无衰恼

尔时大梵天王并诸梵众。俱白佛言。世尊。若善男子善女人。于此般若波罗蜜多。听受读诵如说修行者。我当往护其人令无衰恼

尔时帝释天主复白佛言。希有世尊。此甚深般若波罗蜜多。善男子善女人受持读诵者。于现世中获如是功德。云何世尊。若人受持此般若波罗蜜多。而能摄诸波罗蜜多不。佛言。憍尸迦如是。若人受持此般若波罗蜜多。即能摄诸波罗蜜多。憍尸迦。此般若波罗蜜多。若人受持读诵者。所有功德广大甚深。汝当谛听。如善作意。当为汝说。帝释天主言。善哉世尊。愿为宣说。佛言。憍尸迦。我此般若波罗蜜多法门。不为一切恶法损恼破坏。若诸恶法起时欲生损恼。彼法即当渐自销灭。虽复暂起而不为害。何以故。憍尸迦当知。此善男子善女人。以受持读诵般若波罗蜜多功德力故。恶法虽生而自销灭。憍尸迦。譬如世间有诸毒蛇周行求食。见诸小虫即欲食啖。是时有药名为末只能销诸毒。而彼小虫即诣药所。是时毒蛇闻是药气即自退还。彼诸小虫不为所食。何以故。此末只药能销诸毒。憍尸迦。善男子善女人亦复如是。于此般若波罗蜜多受持读诵。自所宣说或为他说如说修行。是人不为一切恶法所能伤害恶法虽生即自销灭。何以故。当知皆是般若波罗蜜多功德力故。在在处处无所动转。般若波罗蜜多。能除贪等一切烦恼。而能趣证无上涅盘。憍尸迦。若有受持读诵此般若波罗蜜多者。彼四大天王。帝释天主。大梵天王。乃至诸佛菩萨。常护是人令无衰恼

复次憍尸迦。若善男子善女人。受持读诵此般若波罗蜜多者。是人常出信顺语言。柔软语言。白净语言。不杂语言。不生忿怒。不为我慢所覆。常生慈心。不起恨恚忿等烦恼不令增长。彼善男子善女人常作是念。我为趣求阿耨多罗三藐三菩提故。于损恼法不应生嗔。何以故。嗔法若生诸根变异。调善色相非所和合。作是念已安住正念。憍尸迦。彼善男子善女人。以受持读诵般若波罗蜜多故。于现世中获如是功德

佛说佛母出生三法藏般若波罗蜜多经卷第二佛说佛母出生三法藏般若波罗蜜多经卷第三

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    宝塔功德品第三之二

尔时帝释天主复白佛言。希有世尊。菩萨摩诃萨。为回向故修学般若波罗蜜多。不以高心而生取相。佛言。如是如是。憍尸迦。若善男子善女人。于此般若波罗蜜多法门。受持读诵自所宣说。或令他说如说修行者。是人以其功德力故。若入军阵无所怯惧。勇猛坚固胜伏他军。乃至行住坐卧皆得吉祥

复次憍尸迦。若善男子善女人。受持读诵此般若波罗蜜多者。是人于一切处。若行若止或遇刀杖等难。于彼人身无所伤害。乃至将失寿命不生怖畏。何以故。此般若波罗蜜多是广大明。此般若波罗蜜多是无量明。此般若波罗蜜多是无上明。此般若波罗蜜多是无等明。此般若波罗蜜多是无等等明。若善男子善女人修学如是明者。不念自恶不念他恶不念自他恶。憍尸迦当知。于此般若波罗蜜多受持读诵者。于现世中获是功德。又复菩萨摩诃萨学是明者。即能证得阿耨多罗三藐三菩提成就一切智智。以得阿耨多罗三藐三菩提故。即能观达一切众生种种心行。所言一切智智者谓诸明法。菩萨摩诃萨是中学者。无有少法而不能入。无有少法不能了知。无有少法不能证悟。是故得名一切智智

复次憍尸迦。若有人能以此般若波罗蜜多。书写经卷供养受持。若自读诵或复转劝他人。乃至为人解说其义。是人不为一切人非人等伺得其便。诸佛菩萨常所护念。唯除过去诸业报应。憍尸迦。譬如大菩提场及菩提树周匝方隅。若人非人乃至傍生异类。皆不能入亦不能住。不能破坏作其过恶。何以故。所有过去未来现在如来应供正等正觉。皆于是处证佛菩提。憍尸迦。善男子善女人。受持读诵书写供养般若波罗蜜多亦复如是。若人非人不得其便。不能破坏出其过恶。何以故。若供养此般若波罗蜜多经处。随其方地即同造诸宝塔尊重供养瞻礼称赞憍尸迦当知。此般若波罗蜜多。于现世中有是功德尔时帝释天主白佛言。世尊。若有善男子善女人。书此般若波罗蜜多经尊重恭敬。置诸妙华烧香涂香末香及诸华鬘。乃至诸妙幡盖燃诸油灯。作如是等种种供养

若复有善男子善女人。于如来应供正等正觉般涅盘后。收取舍利起妙宝塔。尊重恭敬瞻礼称赞。以诸香华灯涂幢幡宝盖。作如是等种种供养。彼善男子善女人所获福德。与前福德何者为多。佛言。憍尸迦。我今问汝随汝意说。于意云何。如来应供正等正觉。当学何法得如是身。证阿耨多罗三藐三菩提。成就一切智智。是时帝释天主白佛言。世尊。如来应供正等正觉。修学般若波罗蜜多法故。证得阿耨多罗三藐三菩提。成就一切智智。佛言憍尸迦。是故当知。佛不以是身故得如来果。以成就一切智智故得成如来。当知如来应供正等正觉。所有一切智智。从般若波罗蜜多生。复从般若波罗蜜多善巧方便生如来身。是故此身与一切智智而为依止。由一切智智为所依故即得佛身即得法身得僧伽身。是故一切众生。于如来身得瞻礼供养。乃至般涅盘后以佛舍利起塔供养。憍尸迦。彼善男子善女人。虽复如是起塔供养如来舍利。不如有人书此般若波罗蜜多经尊重恭敬。以香华灯涂幢幡宝盖种种供养。是善男子善女人得福甚多。何以故。供养此般若波罗蜜多者。是即供养一切智智。是故善男子善女人。若欲供养一切智智者。于此般若波罗蜜多。常当书写尊敬受持作诸供养

尔时帝释天主白佛言。世尊。若阎浮提人。于此般若波罗蜜多。不能书写受持读诵。不自宣说不令他说。又复不能以诸香华幢幡宝盖尊敬供养。世尊。如是等人失大善利。不能成就广大果报。佛告帝释天主言。憍尸迦。于汝意云何。阎浮提中有几所人。于佛法僧得不坏信。帝释天主白佛言。世尊。此阎浮提人于佛法僧。得不坏信者其数甚少。佛言憍尸迦。如是如是。阎浮提人。少有能于佛法僧宝得不坏信。若于须陀洹果。斯陀含果。阿那含果。阿罗汉果。及缘觉果。其所证者。而亦甚少。于其阿耨多罗三藐三菩提心。若已发者能住不退。若现发者勇猛精进。若未发者当能发起。如是等人转复甚少。又复阎浮提人。少能于此般若波罗蜜多善住相应。少能于此般若波罗蜜多依法修行。少能于此般若波罗蜜多。心不退转住菩萨地。少能于此般若波罗蜜多。修行趣证阿耨多罗三藐三菩提。憍尸迦。若有能于此般若波罗蜜多听受读诵。自所宣说。或令他说如说修行。乃至尊重恭敬。以诸香华灯涂幢幡宝盖种种供养者。当知皆是已发阿耨多罗三藐三菩提心。住不退转菩萨地者

又复憍尸迦。此阎浮提中有无量无数无边众生。发阿耨多罗三藐三菩提心行菩萨道。于汝意云何。憍尸迦。汝今当知。虽复有如是无量无数无边众生。发菩提心行菩萨道。于其中间若一若二住不退转地。何以故。此阎浮提有诸众生起下劣心生下劣想。智慧信解亦复下劣。是故起劣精进。于阿耨多罗三藐三菩提作难得想。不能起求而生懈怠。憍尸迦。若善男子善女人。乐欲速证阿耨多罗三藐三菩提果。成就最上乐者。是故应当于此般若波罗蜜多。发猛利心听受读诵。何以故。是善男子善女人应作是念。此般若波罗蜜多如来应供正等正觉。往昔修菩萨行时亦如是学。我今亦学是般若波罗蜜多。此般若波罗蜜多是我所师。憍尸迦。若佛住世若涅盘后。诸菩萨摩诃萨应当依止此般若波罗蜜多

复次憍尸迦。若有善男子善女人。于如来应供正等正觉般涅盘后。以佛舍利造俱胝数七宝妙塔。是人乃至尽寿已来。以香华灯涂幢幡宝盖诸妙衣服。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。是善男子善女人。以是供养因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众。各各受持宣布演说。即得法眼不坏不灭。又复书此般若波罗蜜多经。置清净处生尊重心。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦当知。此善男子善女人得福甚多

复次憍尸迦。如前所说俱胝宝塔。且置是数。假使有人以佛舍利造七宝塔满阎浮提。是人乃至尽寿已来。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼善男子善女人。以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众。各各受持宣布演说。即得法眼不坏不灭。又复书此般若波罗蜜多经。置清净处生尊重心。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦。当知此善男子善女人得福甚多

复次憍尸迦。如前所说造七宝塔满阎浮提。且置是数。假使有人以佛舍利造七宝塔满四大洲。是人乃至尽寿已来。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼善男子善女人。以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众。各各受持宣布演说。即得法眼不坏不灭。又复书此般若波罗蜜多经。置清净处生尊重心。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦当知。此善男子善女人得福甚多

复次憍尸迦。如前所说造七宝塔满四大洲。且置是数。憍尸迦。假使有人以佛舍利造七宝塔满小千世界。是人乃至尽寿已来。以诸香华灯涂幢幡宝盖。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众。各各受持宣布演说。即得法眼不坏不灭。又复书此般若波罗蜜多经置清净处。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦当知。此善男子善女人。得福甚多

复次憍尸迦。如前所说造七宝塔满小千世界。且置是数。憍尸迦。假使有人以佛舍利造七宝塔满中千世界。是人乃至尽寿已来。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得法眼不坏不灭。又复书此般若波罗蜜多经置清净处。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦当知。此善男子善女人得福甚多

复次憍尸迦。如前所说造七宝塔满中千世界。且置是数。憍尸迦。假使有人以佛舍利造七宝塔满三千大千世界。是人乃至尽寿已来。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得法眼不坏不灭。又复书此般若波罗蜜多经置清净处。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。憍尸迦。当知此善男子善女人。得福甚多

复次憍尸迦。如前所说造七宝塔。满三千大千世界。且置是数。憍尸迦。假使三千大千世界满中众生。各各以佛舍利造七宝塔。若住一劫若减一劫。以诸香华灯涂幢幡宝盖上妙衣服。乃至种种伎乐歌舞。作如是等广大供养。又复尊重瞻礼称赞。憍尸迦。于汝意云何。彼诸众生以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。若善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得法眼不坏不灭。又复书此般若波罗蜜多经置清净处。以诸香华灯涂幢幡宝盖。作如是等种种供养。憍尸迦当知。此善男子善女人得福甚多

尔时帝释天主白佛言。世尊。如是如是。诚如佛说。若人于此般若波罗蜜多经尊重供养者。当知是人即同供养过去未来现在诸佛了诸佛智。即同于彼一切世界广作最极无边供养。世尊。如佛所说三千大千世界如前数量。我今复置是数。世尊。假使如彼兢兢伽沙数三千大千世界。而彼世界满中众生。一一众生各各以佛舍利起七宝塔。若住一劫若减一劫。以诸香华灯涂幢幡宝盖上妙衣服乃至种种伎乐歌舞。如是供养。又复尊重瞻礼称赞。世尊。彼诸众生得福虽多。不如有人为欲趣求大菩提故。于此般若波罗蜜多发信解心。自当受持读诵记念。复为他人广说流布。普令众生得大善利。使其正法久住世间。以是因缘佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得法眼不坏不灭。又复书此般若波罗蜜多经置清净处。以诸香华灯涂幢幡宝盖上妙衣服。如是等种种供养

尔时世尊告帝释天主言。如是如是。憍尸迦。能于此般若波罗蜜多经尊重供养者。当知是人所获福德无量无数。无有边际无等无比。乃至其福不可思议。何以故。当知如来应供正等正觉一切智。从般若波罗蜜多生。复从一切智生如来身。憍尸迦。是故当知。若人以佛舍利起塔供养。与彼受持读诵尊重供养般若波罗蜜多经者。所作福行所获功德。较量是数百分不及一。千分不及一。百千分不及一。俱胝分不及一。百俱胝分。千俱胝分。百千俱胝分。百千俱胝那庾多分。不及其一。数分算分。及譬喻分乃至乌波尼杀昙分不及其一

尔时先从帝释天主同来会者。四十千天子众。俱白帝释天主言。今当于此甚深般若波罗蜜多法门。受持读诵记念思惟如说修行是时世尊。即告帝释天主言。憍尸迦。如诸天言。汝当于此般若波罗蜜多法门。受持读诵记念思惟如说修行。何以故。憍尸迦。若阿修罗与彼三十三天子众共相斗战。是时汝当思念于此般若波罗蜜多法门。彼阿修罗即当退屈而自隐没。帝释天主白佛言。世尊。此般若波罗蜜多。是广大明。此般若波罗蜜多。是无量明。是无上明。是最胜明。是无等明。是无等等明。

尔时佛告帝释天主言。如是如是。憍尸迦。此般若波罗蜜多。是广大明。是无量明。是无上明。是最胜明。是无等明。是无等等明。何以故。所有过去未来现在如来应供正等正觉。从是大明所出生故。诸佛阿耨多罗三藐三菩提。学是大明得成就故。乃至无量无数三千大千世界诸佛世尊。阿耨多罗三藐三菩提。皆学是般若波罗蜜多广大明故而得成就。憍尸迦当知。阿耨多罗三藐三菩提。从是般若波罗蜜多中来。所有十善法。因是大明故出现于世。四禅定分。四无量分。四无色定分。五神通分。三十七菩提分。如是等法皆因是大明故出现于世。如是略说。乃至八万四千法蕴。皆从般若波罗蜜多广大明句所出生故。所有佛智。自然智。不思议智。亦复由此大明生故

复次憍尸迦。若如来应供正等正觉不出世时。彼诸菩萨摩诃萨众出现世间。从先所闻般若波罗蜜多。出生种种善巧方便。悲愍世间诸众生故为作利益。是故十善法。四禅定分。四无量分。四无色定分。五神通分。三十七菩提分。如是等法出现世间开示众生。憍尸迦。譬如月不出时众星出现。如其力势光照世间。菩萨摩诃萨亦复如是。如来应供正等正觉不出世时。所有正法亦不隐灭。何以故。若诸法行。若平等行。若诸善行。一一皆从诸菩萨摩诃萨所出生故。于菩萨摩诃萨善巧方便中随顺而转。是诸菩萨摩诃萨善巧方便。当知皆从般若波罗蜜多生

复次憍尸迦。若有善男子善女人。能于此般若波罗蜜多法门。书写供养受持读诵记念思惟如说修行者。是人以是缘故。于现世中得大利益

帝释天主白佛言。世尊。是人于现世中当得何所利益。佛言。憍尸迦当知。是善男子善女人。不为诸毒损伤其命。不为火焚不为水溺。不遭刀剑杖苦乃至不为他力损伤其命。又复不为王法所加。设有是难。若能诵念般若波罗蜜多者即得解脱。又复憍尸迦。受持读诵般若波罗蜜多者。若诣国王及其王子王大臣所。时彼国王王大臣等见已欢喜。随其所欲一切如意。何以故。憍尸迦。此般若波罗蜜多。于一切众生是大慈心行。大慈行。是大悲心行大悲行。又复憍尸迦。受持读诵此般若波罗蜜多者。于一切处不为一切虎狼虫兽所能伤害。乃至人非人等。伺求短者不得其便。唯除先业定应受者

尔时有诸外道。于彼法中久出家者。数满百人来入会中。于佛世尊欲生恼乱

是时帝释天主。远见此人渐近佛会。即时天主观察彼心。知其所欲而作是念。此诸外道今来佛会欲生恼乱

我先从佛所受般若波罗蜜多法门宜应诵念。帝释天主作是思惟已。即诵般若波罗蜜多法门。时诸外道既入会中远见世尊。是时各各右绕世尊已。即离佛会复道而还

尔时尊者舍利子。即作是念。云何此诸外道来入会中。向佛世尊右绕而退。是时世尊。知舍利子心所思念。即告尊者舍利子言。汝今当知彼诸外道。于彼法中而各出家。今来佛会欲生破坏违诤损恼。帝释天主以诵般若波罗蜜多故。彼诸外道自生惭退。舍利子。是故当知。般若波罗蜜多法门有大威力。能除一切外道邪恶

尔时复有诸恶魔众咸作是念。今如来应供正等正觉。与其四众并欲色界诸天子等而共集会。彼佛世尊与诸菩萨摩诃萨。授阿耨多罗三藐三菩提记。我等今者宜应往彼。时诸魔众。作是念已即化四兵。种种庄严诣于佛所

是时帝释天主。见是四兵严整妙好来入佛会。即作是念。此四兵众庄严殊丽。非彼频婆娑罗王之所有。亦非胜军大王所有。又非诸余国王所有。亦复非其长者子有。此即是彼诸恶魔众化现故尔。何以故。彼诸魔众。于长夜中违背佛法。伺求其短欲生破坏。我今宜应诵佛所受般若波罗蜜多法门。帝释天主作是念已。即诵般若波罗蜜多法门。彼诸魔众。即时各各摄其化现复道而还。尔时三十三天子众。即于会中。化现无数天曼陀罗华等种种妙华散于佛上。其所散华住虚空中。时诸天子众散妙华已作如是言。愿此般若波罗蜜多正法久住世间。与阎浮提众生作大利益。发是言已重复散华。散已又言。唯愿一切众生。于此般若波罗蜜多法门。宣布演说如说修行。一切魔及魔天人与非人。伺求短者不得其便。普令众生善根具足。时帝释天主白佛言。世尊。若有人能于此般若波罗蜜多随喜听受者。当知是人已曾供养过去诸佛。何况受持读诵记念思惟。转为他人解说其义。如其所说依法修学。如所修行成就相应。何以故。诸佛一切智。皆于般若波罗蜜多法中求。从般若波罗蜜多所出生故。世尊。譬如有人欲求妙宝须入大海勤苦而求。方获无价诸妙珍宝。如来应供正等正觉一切智宝亦复如是。当于般若波罗蜜多大海中求。佛告帝释天主言。如是如是。诸佛如来应供正等正觉一切智宝。若欲求者。当于般若波罗蜜多大法海中勤苦而求。如是求者皆得如意

佛说佛母出生三法藏般若波罗蜜多经卷第三佛说佛母出生三法藏般若波罗蜜多经卷第四

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    宝塔功德品第三之三

尔时尊者阿难白佛言。云何世尊。而不称赞宣说布施波罗蜜多。持戒波罗蜜多。忍辱波罗蜜多。精进波罗蜜多。禅定波罗蜜多如是名字。何故唯说般若波罗蜜多称赞功德

佛告阿难言。如是如是。我于诸波罗蜜多中。唯说般若波罗蜜多最上称赞。何以故。阿难。汝今当知此般若波罗蜜多与五波罗蜜多为导首故。阿难。于汝意云何。若布施不回向一切智。得成波罗蜜多不。阿难白佛言。不也世尊。佛言阿难。若持戒忍辱精进禅定不回向一切智。得成波罗蜜多不。即此般若不回向一切智得成波罗蜜多不。阿难白佛言。不也世尊。佛言阿难。于汝意云何。所有不思议智慧善根。回向一切智不。阿难白佛言。世尊。如是如是。所有最上不思议智慧善根。而悉回向一切智。佛告阿难。是故当知。以诸善根回向一切智故。得诸波罗蜜多名。以第一义法回向一切智故。得般若波罗蜜多名。是故阿难。彼诸善根回向一切智故。般若波罗蜜多。与五波罗蜜多而为导首。彼五波罗蜜多。住般若波罗蜜多相应法中。由是般若波罗蜜多故。诸波罗蜜多皆悉圆满。阿难。是故我于般若波罗蜜多而最称赞。譬如大地散诸种子。如其时处随所和合各得生长。彼诸种子依地而住。若不依地不能生长。般若波罗蜜多亦复如是。而能摄彼五波罗蜜多。如是五法皆依般若波罗蜜多而住。由般若波罗蜜多而得增长。是故五法皆得名为波罗蜜多。阿难。是故当知般若波罗蜜多。与彼五法而为导首

尔时帝释天主白佛言。世尊。如佛所说般若波罗蜜多法门有大功德。假使如来应供正等正觉。以种种言词称扬赞叹亦不能尽。是故诸善男子善女人应当于此般若波罗蜜多法门。受持读诵记念思惟如说修行。佛言。憍尸迦。善哉善哉。如汝所言。此般若波罗蜜多法门。我不但说能受持读诵宣布演说者有大功德。若有善男子善女人。但能以此般若波罗蜜多。书写经卷置清净处尊重恭敬。以诸香华灯涂幢幡宝盖上妙衣服作诸供养者。当知是人宣布佛法久住世间。以是因缘。佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得法眼不坏不灭。憍尸迦。彼受持读诵般若波罗蜜多者。于现世中获是功德

尔时帝释天主白佛言。世尊。若有善男子善女人。但能于此般若波罗蜜多。书写经卷置清净处。以诸香华灯涂幢幡宝盖等随力供养者。我当往彼护念其人令无衰恼。何况于此般若波罗蜜多。受持读诵记念思惟。转为他人解说其义。是人功德无量无边。佛告帝释天主言。善哉善哉憍尸迦。若有善男子善女人。于诸方处说此般若波罗蜜多时。有无数百千天子。为听法故往诣其所听受正法。若说法人。有疲倦心不乐说者。彼诸天子。增益其力使不退没。令其精进乐欲宣说。憍尸迦。受持读诵般若波罗蜜多者。于现世中获是功德

复次憍尸迦。若受持此正法者。善男子善女人。于四众中说此般若波罗蜜多时。心无怯惧不畏难问。随问能答离诸过失。何以故。般若波罗蜜多力所护故。于此般若波罗蜜多。诸求过失者不得其便。所以者何。是般若波罗蜜多离诸过失。是故宣说般若波罗蜜多者。亦复不见有其过失。以如是故。彼善男子善女人。于说法时不生惊怖。憍尸迦。受持读诵般若波罗蜜多者于现世中获是功德

复次憍尸迦。若善男子善女人。受持读诵般若波罗蜜多者。是人即为父母亲友。乃至沙门婆罗门等尊重敬爱。若已起若未起一切言讼斗诤衰恼等事皆悉远离。憍尸迦。受持读诵般若波罗蜜多者。于现世中获是功德复次憍尸迦。若善男子善女人。以此般若波罗蜜多。书写经卷安置供养。随诸方地有是经处即有

四大王天。住阿耨多罗三藐三菩提心者。诸天子众为敬法故往诣其所。瞻礼称赞随喜顶受。得瞻礼顶受已即还彼天

所有三十三天中住菩提心诸天子众

夜摩天中住菩提心诸天子众

喜足天中住菩提心诸天子众

化乐天中住菩提心诸天子众

他化自在天中住菩提心诸天子众

如是等欲界诸天子众。各各为敬法故往诣其所。瞻礼称赞随喜顶受。得瞻礼顶受已。各各还复彼彼天中

又复憍尸迦。所有色界诸天

所谓梵众天。梵辅天。大梵天

少光天。无量光天。光音天

少净天。无量净天。遍净天

无云天。福生天。广果天

无烦天。无热天。善见天。善现天。色究竟天。如是等诸天中住菩提心者。诸天子众。为敬法故往诣其所。瞻礼称赞随喜顶受。得瞻礼顶受已。各各还复彼彼天中

复次憍尸迦。诸有受持读诵般若波罗蜜多者。善男子善女人应生如是心。所有十方无量阿僧祇世界中。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗迦人非人等。皆悉为敬法故。来诣般若波罗蜜多经所瞻礼听受。彼等若来我当以其法施。使令得法各各还复。憍尸迦。若有是般若波罗蜜多经处。我不但说一四大洲欲色界中。住菩提心诸天子众。为敬法故。往诣其所瞻礼顶受。憍尸迦。乃至三千大千世界诸欲色界中。住菩提心诸天子众。各各为敬法故。有是般若波罗蜜多经处。往诣其所瞻礼称赞随喜顶受。得瞻礼顶受已。各各还复彼彼天中

复次憍尸迦。受持读诵般若波罗蜜多者。诸善男子善女人。随所住处有是经卷。若诸殿堂及诸房舍。坚固安隐不能破坏。是处即有大威力者。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。常来其所听受正法

尔时帝释天主白佛言。世尊。诸天龙神等众若来。彼善男子善女人当云何知。佛告帝释天主言。憍尸迦。受持此正法者。善男子善女人。若见有大光明。当知即是诸天龙神等众。来至其所听受正法。又复若闻诸微妙香。当知此相亦是诸天龙神等众来至其所。是故憍尸迦。受持此正法者。善男子善女人。随所住处常应清净严洁其舍。去除一切秽恶等物。若彼诸天龙神等众。或时来至其所。见是清净等相。彼天龙神心生欢喜适悦快乐。是中有诸先住小力鬼神。皆悉远避出离其舍。何以故。彼小力鬼神。常所依附大威力者诸天龙神而彼小力诸鬼神等。常所随从大力诸天龙神等众往诸方处。是故憍尸迦。随有是般若波罗蜜多经处。若诸持法者。常能清净严洁其所。是即尊重正法眼故。憍尸迦。是善男子善女人。以尊敬受持般若波罗蜜多正法力故。于现世中获大功德

复次憍尸迦。是善男子善女人。受持般若波罗蜜多时。身无疲倦心不懈怠。离诸苦恼适悦快乐卧安觉安。于其梦中见胜境像。或见如来应供正等正觉安处道场。或见如来应供正等正觉转大法轮。或见如来舍利宝塔。或见诸声闻众。或见诸菩萨摩诃萨众。或闻宣说般若波罗蜜多甚深法音。或闻宣说菩提分法。或复见诸菩萨摩诃萨。方证阿耨多罗三藐三菩提。或见诸菩萨摩诃萨。受持此般若波罗蜜多法门。或闻宣说般若波罗蜜多摄一切智。或见佛刹广大清净。或闻诸佛世尊。以善巧方便说菩萨法。或见某如来应供正等正觉。于某方某处及某世界。与百千俱胝那庾多菩萨声闻众。恭敬围绕而为说法。憍尸迦。是善男子善女人。于其梦中见是胜相。觉已轻安身心适悦。彼人得是适悦快乐已。于诸甘美饮食不生贪想。譬如修相应行苾刍。从三摩地起。于诸甘美饮食不生念想。憍尸迦。受持般若波罗蜜多者。善男子善女人亦复如是。何以故。是善男子善女人。住般若波罗蜜多观行相应故。即得天龙神等增益色力。是故于诸饮食不生念想。憍尸迦。受持般若波罗蜜多者。善男子善女人。于现世中获是功德

复次憍尸迦。若善男子善女人。但能以此般若波罗蜜多。书写经卷安置供养者。当知是人获大功德。况复有人为欲趣求大菩提故。于此般若波罗蜜多法门。发信解心听受读诵。广为他人解说其义。使令正法久住世间。以是因缘。佛眼不断正法不灭。而诸菩萨摩诃萨众。各各受持宣布演说。即得法眼不坏不灭。又复尊重恭敬。以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。当知是人以是因缘。所获功德无量无边。是故憍尸迦。若善男子善女人。乐欲成就如是最胜功德者。应当于此般若波罗蜜多法门。发信解心受持读诵记念思惟。乃至为人广说其义。又复尊重恭敬。以诸香华灯涂种种供养

    称赞功德品第四

尔时世尊告帝释天主言。憍尸迦。若以满阎浮提如来舍利。而为一分。以此般若波罗蜜多书写经卷。而为一分。汝于此二分中当取何分。帝释天主白佛言。世尊。若以满阎浮提如来舍利。及般若波罗蜜多经卷。各为一分者。我于此二分中。当取般若波罗蜜多分。何以故。诸佛如来所有化相身。实义身。说法身。如是等身。皆从法身所出生故。从如实际所出现故。如实际者所谓般若波罗蜜多。诸佛世尊所有诸身。亦复从是般若波罗蜜多生。是故得于如来舍利瞻礼供养。虽复供养如来舍利。不如于此般若波罗蜜多尊重供养。所以者何。诸如来身。从是般若波罗蜜多所出生故。世尊。譬如我于三十三天善法堂中我处其座。为诸天子宣说法要。若时我以因缘起离彼座。有诸天子或时来者虽不见我。但向其座瞻礼恭敬旋绕而去。彼作是念。帝释天主于此座中。常为诸天宣说法要。是故我今瞻礼此座。世尊。如来应供正等正觉亦复如是。如来所有一切智依如来身。是身复由一切智得。以是缘故。从如实智出生如来一切智智。是智复从般若波罗蜜多所生。世尊。是故我当于二分中。但取般若波罗蜜多分。世尊。我非于佛舍利不生恭敬。以其如来舍利从般若波罗蜜多所生。是故我取般若波罗蜜多分。是即供养如来舍利。世尊。置是满阎浮提如来舍利。若满四大洲。若满小千世界。若满中千世界如来舍利。皆置是数。假使满三千大千世界如来舍利以为一分。此般若波罗蜜多。书写经卷以为一分。世尊。于二分中我亦但取般若波罗蜜多分。世尊。我于如来舍利非不恭敬。以其如来应供正等正觉所有舍利。从般若波罗蜜多生故。诸如来身与一切智为所依止。即此一切智复从般若波罗蜜多生。是故我于二分中。但取般若波罗蜜多分。世尊。譬如大摩尼宝具诸色相有大功德。在在处处诸非人类求不得便。彼诸非人住处。若有男子女人持是摩尼宝入其舍中。彼非人类即当出离其舍。又复此宝若人暂置身中。是人即能息诸恶毒苦恼等事。又复若有患风癀痰[病-丙+(企-止+(套-大))]等病者。当以此宝置其身上。是诸病苦皆悉销除。此摩尼宝。于夜闇中能为明照。若诸地方盛炎热时。此摩尼宝能作清凉。若诸地方极寒冷时。此摩尼宝而能温暖。若诸地方大毒虫等作诸恶毒。若有是大摩尼宝处。自当远去不能为害。又若有人为诸毒虫所伤害者。是人若见此摩尼宝毒即销灭。又复若人患诸眼病。不能观视诸境相者。当以此宝置其眼上。是人即能明照离诸苦恼。又复若以此宝置于水中。是宝即与水同一色。若以此宝置于青黄赤白众色水中。是宝亦能随种种色各同其一。又复若以此宝置于青黄赤白诸色衣中。是宝亦能随诸衣色各同其一。若以此宝置浊水中水即自清。世尊。彼摩尼宝具诸色相有是功德

尔时尊者阿难谓帝释天主言。如汝所说。大摩尼宝具诸功德者。此为天上所有宝耶。此为人间所有宝耶。帝释天主白阿难言。此是天上大摩尼宝。阎浮提人亦有是宝。但人少生尊重敬爱。唯天中宝人所爱重。具诸色相胜功德故。若或以其阎浮提宝比天宝者。百分不及一。千分不及一。百千分不及一。俱胝分不及一。百俱胝分不及一。千俱胝分不及一。百千俱胝分不及一。算分数分及譬喻分。乃至乌波尼杀昙分。皆不及一。是天摩尼宝圆满一切相。若以宝函盛此妙宝。若时取其宝去。而此宝函亦具诸功德人所尊敬。何以故。以盛大宝殊妙器故

尔时帝释天主白佛言。世尊。般若波罗蜜多亦复如是。具足一切智智功德。所有如来应供正等正觉般涅盘后所有舍利。亦得瞻礼供养。何以故。一切智智依如来身。是故如来舍利同彼宝器。一切智智如所盛宝。以是义故如来舍利得瞻礼供养。世尊。若佛如来于一切世界。宣说般若波罗蜜多。有是即出生真实供养。若说法师能为人说般若波罗蜜多者。亦即出生真实供养。世尊。譬如王臣受王命出于多人聚中不生怖畏。以依其王威德力故。诸说法师亦复如是。于一切众中宣说法要不生怖畏。以依大法功德力故。是故于说法师尊重供养。以供养法师故如来舍利亦得供养。世尊。如前所说满三千大千世界如来舍利。假使如兢伽沙数三千大千世界满中如来舍利。以为一分。般若波罗蜜多经卷以为一分。世尊。我于是二分中。亦取般若波罗蜜多分。世尊。我非于如来舍利不生尊重。但为如来舍利从般若波罗蜜多生故。与一切智而为所依。是故我当尊重供养般若波罗蜜多。是故世尊。若供养此般若波罗蜜多者。即同供养过去未来现在诸佛

复次世尊。若善男子善女人乐欲见彼十方无量阿僧祇世界现住说法诸佛如来真实身者。应当于此般若波罗蜜多如法修行。于此般若波罗蜜多。安住相应如实观想

尔时世尊。告帝释天主言。如是如是。憍尸迦。所有过去如来应供正等正觉。皆因修习是般若波罗蜜多故。得成就阿耨多罗三藐三菩提。未来世中。所有无量无数如来应供正等正觉。皆因修习是般若波罗蜜多故。得成就阿耨多罗三藐三菩提。憍尸迦。我今现在如来应供正等正觉。亦修习是般若波罗蜜多故。得阿耨多罗三藐三菩提。帝释天主白佛言。世尊。大波罗蜜多。是谓般若波罗蜜多。如来应供正等正觉。以修习是般若波罗蜜多故。如实了知一切众生种种心行。佛言。如是如是。憍尸迦。诸菩萨摩诃萨。于长夜中修行此般若波罗蜜多。而能了知一切众生种种心行

尔时帝释天主复白佛言。云何世尊。菩萨摩诃萨但行般若波罗蜜多耶。亦行余波罗蜜多耶。佛言。憍尸迦。菩萨摩诃萨皆行六波罗蜜多

复次憍尸迦。菩萨摩诃萨行此般若波罗蜜多。与诸波罗蜜多而为导首。所谓施波罗蜜多能舍。戒波罗蜜多能护。忍波罗蜜多能受。精进波罗蜜多能增长。禅定波罗蜜多能静住。般若波罗蜜多能了知诸法。以了诸法故而能开导诸波罗蜜多。善巧方便而为摄受。由般若波罗蜜多故。回向一切智。回向最胜清净法界。憍尸迦。譬如阎浮提中。有种种树。种种色相。种种茎干。种种枝叶。种种华果。虽复如是各各差别。而诸树阴同一无异。憍尸迦。诸波罗蜜多亦复如是。虽复差别而以般若波罗蜜多善巧方便。皆悉回向彼一切智。帝释天主白佛言。希有世尊。般若波罗蜜多具大功德。般若波罗蜜多具无量功德。般若波罗蜜多具无边功德

    正福品第五之一

尔时帝释天主白佛言。世尊。若有善男子善女人。为欲趣求大菩提故。于此般若波罗蜜多法门。发信解心听受读诵。乃至为人解释其义。使其正法久住世间。以是因缘能令佛眼不断正法不灭。而诸菩萨摩诃萨众各各受持。即得正法不坏不灭。又复闻已作是称赞。此般若波罗蜜多有大利益。是大果报具足无量广大功德正所了知。此般若波罗蜜多是大护持。此般若波罗蜜多是所尊重。此般若波罗蜜多最上难得。此般若波罗蜜多发生信解。是善男子善女人。于此般若波罗蜜多。自所称赞尊重恭敬。又复以诸香华灯涂幢幡宝盖上妙衣服。作如是等种种供养。若复有善男子善女人。以此般若波罗蜜多经卷。转授他人令其供养。世尊。如是善男子善女人。所获福德何者为多。佛告帝释天主言。憍尸迦。我当问汝随汝意答。于意云何。若善男子善女人。于佛如来般涅盘后。以其舍利尊重恭敬种种供养。若复有善男子善女人。以佛舍利自供养已转授他人。令其尊重恭敬供养。如是善男子善女人。所获福德何者为多。帝释天主白佛言。世尊。若善男子善女人。虽自供养如来舍利。不如有人以佛舍利转授他人令其供养。此所获福其数甚多。佛言。如是如是。憍尸迦。若善男子善女人。以此般若波罗蜜多书写经卷自所供养。不如有人以此般若波罗蜜多书写经卷。转授他人令其供养。此善男子善女人。以是因缘得福甚多

复次憍尸迦。若有善男子善女人。于彼满阎浮提所有众生。各各教令修十善业。憍尸迦。于汝意云何。是人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中应当修学。如是学者即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多

复次憍尸迦。置是满阎浮提所有众生。若人以满四大洲所有众生。各各教令修十善业。复置是数。若满小千世界所有众生。而复各各教修十善。亦置是数。若满中千世界所有众生。各各教修十善。亦置是数。若满三千大千世界所有众生教修善。亦置是数。如是乃至满兢伽沙数三千大千世界所有众生。一一教化令修十善。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中应当修学。如是学者即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人。得福甚多

佛说佛母出生三法藏般若波罗蜜多经卷第四佛说佛母出生三法藏般若波罗蜜多经卷第五

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    正福品第五之二

复次憍尸迦。若善男子善女人。以满阎浮提所有众生。各各教令修四禅定。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多

复次憍尸迦。置是满阎浮提所有众生。若满四大洲所有众生。各各教令修四禅定。复置是数。若满小千世界所有众生。各各教令修四禅定。亦置是数。若满中千世界所有众生。各各教令修四禅定。亦置是数。若满三千大千世界所有众生。各各教令修四禅定。亦置是数。如是乃至若满兢伽沙数三千大千世界所有众生。一一教令修四禅定。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。当知是人得福甚多。复次憍尸迦。若满阎浮提所有众生。各各教修四无量行四无色定。乃至普修一切神通梵行诸禅定法及诸福行。憍尸迦。于汝意云何。彼人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多

复次憍尸迦。置是满阎浮提所有众生。各各教修无量无边神通梵行诸禅定法及诸福行。憍尸迦。若满四大洲。若满小千世界。若满中千世界。若满三千大千世界所有众生。各各教修无量无边神通梵行诸禅定法及诸福行。一一皆置是数。憍尸迦。假使若满兢伽沙数三千大千世界所有众生。各各教修无量无边神通梵行诸禅定法及诸福行。憍尸迦。于汝意云何。是人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多

复次憍尸迦。若善男子善女人。以此般若波罗蜜多书写经卷。自当受持读诵。转劝他人使其读诵得福虽多。不如有人以此般若波罗蜜多法门。广为他人解释其义。憍尸迦。当知是善男子善女人得福甚多

尔时帝释天主白佛言。世尊。当为何等人解说此般若波罗蜜多。佛告帝释天主言。若有善男子善女人。于此般若波罗蜜多不能了知者当为彼说。何以故。憍尸迦。未来世中当有人说相似般若波罗蜜多。若有善男子善女人。为欲趣证阿耨多罗三藐三菩提者。闻是相似般若波罗蜜多于中学者。则为错乱非正了知。帝释天主白佛言。世尊。未来世中云何说彼相似般若波罗蜜多。又复云何悉能辩了。佛告帝释天主言。憍尸迦。未来世中有诸苾刍。作如是说。色是无常。若身若心及戒定慧。悉无所有离诸所观。作是说者。当知是说相似般若波罗蜜多。憍尸迦。云何名为相似般若波罗蜜多。彼作是说。坏色故观色无常。坏受想行识故观受想行识无常。若如是求是为行般若波罗蜜多。憍尸迦。当知此说皆得名为相似般若波罗蜜多。憍尸迦。汝今当知不坏色故观色无常。不坏受想行识故观受想行识无常。作是说者。是为如实宣说般若波罗蜜多。憍尸迦。以是义故。若善男子善女人。能为他人如实解说般若波罗蜜多义者。当知是善男子善女人得福甚多

复次憍尸迦。若善男子善女人。以满阎浮提所有众生。普令安住须陀洹果。憍尸迦。于汝意云何。是善男子善女人。以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有须陀洹果。从是般若波罗蜜多所出生故。憍尸迦。如前所说。若人以满阎浮提所有众生。普令安住须陀洹果。所作福行。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界所有众生。普令安住须陀洹果。所作福行。亦置是数。憍尸迦。假使若满兢伽沙数三千大千世界所有众生。普令安住须陀洹果。憍尸迦。于汝意云何。是人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有须陀洹果。从是般若波罗蜜多所出生故

复次憍尸迦。若善男子善女人。以满阎浮提所有众生。普令安住斯陀含果。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有斯陀含果。从是般若波罗蜜多所出生故。憍尸迦。如前所说。若人以满阎浮提所有众。普令安住斯陀含果。所作福行。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界所有众生。普令安住斯陀含果。皆置是数。憍尸迦。假使若满兢伽沙数三千大千世界所有众生。普令安住斯陀含果。憍尸迦。于汝意云何。是人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有斯陀含果。从是般若波罗蜜多所出生故

复次憍尸迦。若有善男子善女人。以满阎浮提所有众生。普令安住阿那含果。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有阿那含果。从是般若波罗蜜多所出生故。憍尸迦。如前所说。若人以满阎浮提所有众生。普令安住阿那含果。所作福行。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界所有众生。普令安住阿那含果。皆置是数。憍尸迦。假使有人以满兢伽沙数三千大千世界所有众生。普令安住阿那含果。憍尸迦。于汝意云何。是善男子善女人。以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有阿那含果。从是般若波罗蜜多所出生故

复次憍尸迦。若有善男子善女人。以满阎浮提所有众生。普令安住阿罗汉果。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有阿罗汉果。从是般若波罗蜜多所出生故。又此善男子善女人。随所宣说般若波罗蜜多即能随转。以随转故。如其所说即能修学。得先佛法成就阿耨多罗三藐三菩提。是故所有须陀洹斯陀含阿那含阿罗汉缘觉。及彼如来应供正等正觉。皆悉从是般若波罗蜜多出生。如所出生如理而得。憍尸迦。如前所说。若人以满阎浮提所有众生。普令安住阿罗汉果。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界所有众生。普令安住阿罗汉果。皆置是数。憍尸迦。假使若满兢伽沙数三千大千世界所有众生。普令安住阿罗汉果。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。世尊。是善男子善女人。其所得福转复甚多。算数譬喻所不能及。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有阿罗汉果。从是般若波罗蜜多所出生故。又此善男子善女人。随所宣说般若波罗蜜多即能随转。以随转故。如其所说即能修学。得先佛法成就阿耨多罗三藐三菩提。是故所有须陀洹斯陀含阿那含阿罗汉缘觉。及彼如来应供正等正觉。皆悉从是般若波罗蜜多出生。如所出生如理而得

复次憍尸迦。若有善男子善女人。以满阎浮提所有众生。若满四大洲。若满小千世界。若满中千世界。若满三千大千世界。乃至若满兢伽沙数三千大千世界所有众生。普令安住诸缘觉果。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。甚多世尊。佛言。憍尸迦。是善男子善女人。以是因缘得福虽多。不如有人于此般若波罗蜜多。发信解心发菩提心住菩萨法。以此般若波罗蜜多书写经卷。受持读诵生欢喜心为人演说。或复为人解释其义。于此正法生清净心离诸疑惑。转劝他人使其受持。作如是言。汝善男子。此般若波罗蜜多是菩萨道。汝于是中如所宣说应当修学。如是学者乃名得法。即能速证阿耨多罗三藐三菩提。能尽一切诸有情界。普令安住真如实际。憍尸迦。是善男子善女人得福甚多。何以故。所有缘觉果。从是般若波罗蜜多所出生故。又此善男子善女人。随所宣说般若波罗蜜多即能随转。以随转故即能修学。得先佛法成就阿耨多罗三藐三菩提。是故所有须陀洹乃至如来应供正等正觉。皆悉从是般若波罗蜜多出生。如所出生如理而得

复次憍尸迦。若满阎浮提中所有众生。皆发阿耨多罗三藐三菩提心。若有善男子善女人。以此般若波罗蜜多书写经卷。普施一切使其受持。不如有人以此般若波罗蜜多书写经卷。与一住不退转菩萨摩诃萨。令其于此般若波罗蜜多。修学相应坚固增长。广大圆满成就佛法。憍尸迦。当知是善男子善女人得福甚多。何以故。此般若波罗蜜多出生阿耨多罗三藐三菩提故。憍尸迦。如前所说。若满阎浮提所有众生。皆发阿耨多罗三藐三菩提心。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界。乃至若满兢伽沙数三千大千世界所有众生。皆发阿耨多罗三藐三菩提心。若善男子善女人。以此般若波罗蜜多书写经卷。普施一切使其受持。憍尸迦。不如有人以此般若波罗蜜多书写经卷。与一住不退转菩萨摩诃萨。令其于此般若波罗蜜多。修学相应坚固增长。广大圆满成就佛法。憍尸迦。当知是善男子善女人得福甚多。何以故。此般若波罗蜜多出生阿耨多罗三藐三菩提故

复次憍尸迦。若满阎浮提所有众生。一切皆住不退转地。若有善男子善女人。以此般若波罗蜜多法门。普为一切解释其义。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。世尊。是善男子善女人所获福德转复甚多无量无边。算数譬喻所不能及。佛言。憍尸迦。此人以是因缘得福虽多。不如有人为一将证阿耨多罗三藐三菩提者。以此般若波罗蜜多法门解释其义。当知是人得福甚多。憍尸迦。如前所说。满阎浮提所有众生。皆住不退转地。若人普为解释其义。且置是数。假使若满四大洲。若满小千世界。若满中千世界。若满三千大千世界。乃至若满。兢伽沙数三千大千世界所有众生。一切皆住不退转地。若善男子善女人。以此般若波罗蜜多法门。普为一切解释其义。憍尸迦。于汝意云何。此人以是因缘得福多不。帝释天主白佛言。世尊。是善男子善女人所获福德无量无边。算数譬喻所不能及。佛言。憍尸迦。此人以是因缘得福虽多。不如有人为一将证阿耨多罗三藐三菩提者。以此般若波罗蜜多法门解释其义。当知是人得福甚多。憍尸迦。菩萨摩诃萨修学是般若波罗蜜多故。速得阿耨多罗三藐三菩提

尔时帝释天主白佛言。世尊。菩萨摩诃萨随转般若波罗蜜多故。得近阿耨多罗三藐三菩提。随近阿耨多罗三藐三菩提故。当随教受般若波罗蜜多。如所教受故随近一切智。是故当以饮食衣服卧具医药种种供养般若波罗蜜多。随其所作一切福行。彼获福德无量无边。何以故。得近阿耨多罗三藐三菩提成就一切智

尔时尊者须菩提赞帝释天主言。善哉善哉。憍尸迦。汝善开导诸菩萨摩诃萨。复能护念诸菩萨摩诃萨。憍尸迦。佛诸弟子皆以阿耨多罗三藐三菩提法。护念诸菩萨摩诃萨。令发阿耨多罗三藐三菩提心。令住阿耨多罗三藐三菩提果。何以故。过去诸菩萨摩诃萨。皆因学是六波罗蜜多故。发菩提心住菩提果。今佛世尊亦学是六波罗蜜多故得菩提果。未来诸菩萨摩诃萨亦复如是。是故憍尸迦。若菩萨摩诃萨不学是六波罗蜜多。即不能得阿耨多罗三藐三菩提果

佛说佛母出生三法藏般若波罗蜜多经卷第五佛说佛母出生三法藏般若波罗蜜多经卷第六

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    随喜回向品第六之一

尔时慈氏菩萨摩诃萨告尊者须菩提言。若菩萨摩诃萨。于此甚深般若波罗蜜多法门。随喜回向所获功德。比余众生布施持戒修定功德。最上最极最胜最妙。广大无量无等无等等。是故于此甚深正法。应当随喜如理回向

是时尊者须菩提白慈氏菩萨言。若菩萨摩诃萨。于十方一切处无量无数无边不可思议不可称计三千大千世界。一一世界中。所有过法已入涅槃无量无数无边如来应供正等正觉。是诸如来从初发心乃至成就阿耨多罗三藐三菩提果。已入无余依大涅槃界。乃至法灭已来。于其中间所有诸佛世尊戒蕴定蕴慧蕴解脱蕴解脱知见蕴。及彼六波罗蜜多相应善根。诸佛功德相应善根。方便愿力智波罗蜜多广大神通相应善根。一切智智正行相应出生善根。乃至大慈大悲无量无边利益安乐一切众生佛功德聚。如是一切波罗蜜多法门。生出一切最胜神通离障无著种种行法。无能胜无等等无限量无所观。如来如实智力如来知见。乃至具足圆满如来十力四无所畏一切胜义法门。所有如来转大法轮。执大法炬。击大法鼓。吹大法螺。作大法乐。雨大法雨。了大法智。以大法财施诸众生。说诸佛法诸缘觉法及声闻法。普令众生于中修学所有一切最胜善根。及彼诸佛为诸菩萨摩诃萨众授记当得阿耨多罗三藐三菩提果。是诸菩萨所有六波罗蜜多相应善根。又复为诸缘觉乘人授缘觉记。而彼所有一切善根。又复有诸声闻乘人。行于布施持戒修定所有功德。及诸有学无漏无学无漏如是善根。又复所有诸愚异生所种善根。及其四众苾刍苾刍尼优婆塞优婆夷所行布施持戒修定功德。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人傍生异类。闻佛说法所种善根。乃至如来入涅槃后。一切众生于佛法僧所种善根。如是等种种善根种种功德。尽无尽相和合聚集称计较量。修菩萨者以最上最极最胜最妙广大无量无等无等等心皆悉随喜。以如是随喜功德。回向阿耨多罗三藐三菩提作如是言。愿我以此善根。当得阿耨多罗三藐三菩提果。而此修菩萨者。所有诸缘诸事诸相。从心所生如心取相为可得不

尔时慈氏菩萨告尊者须菩提言。不也须菩提。所有诸缘诸事诸相。从心所生如心取相皆不可得。须菩提复白慈氏菩萨言。若诸缘诸事诸相如心所取不可得者。是人将无想颠倒心颠倒见颠倒耶。何以故。有所生故。无常谓常。以苦谓乐。不净谓净。无我谓我。于疑惑心谓正思惟。由是于想心见皆成颠倒。若于诸缘诸事诸相。一一皆住如实法者。即无所生亦无所取。由如是故。心法亦然诸法亦然菩提亦然。若诸缘诸事诸相。菩提及心皆无异者。即于何所缘取于何相。当以何心随喜功德。又复以何善根。回向阿耨多罗三藐三菩提

尔时慈氏菩萨摩诃萨谓尊者须菩提言。如汝所说。此回向法。不应为彼新发意菩萨如是宣说。何以故。彼若闻是说已所有信解爱乐恭敬净心皆悉隐灭。以是义故不应为说。若有住不退转菩萨摩诃萨随顺善知识者。应当为彼如是宣说。而彼菩萨闻是法已。不惊不怖亦不退没。如是菩萨摩诃萨。能以随喜功德如实回向彼一切智

尔时尊者须菩提白慈氏菩萨言若菩萨起随喜心回向心。是心。即尽即灭即离。当以何心而能随喜。复以何心而用回向阿耨多罗三藐三菩提。若以心心能回向者。是二心不俱亦无所有。若诸心自性又不能回向。即以何心能回向耶

尔时帝释天主白尊者须菩提言。若有新发意菩萨。闻作是说将无惊怖生退没耶。尊者。今云何是如实随喜如实回向。应当云何是随喜法。又复云何是回向心

尔时尊者须菩提以慈氏菩萨摩诃萨威神加持力故。复白慈氏菩萨言。诸菩萨摩诃萨。于过去诸佛道悉已修习。已灭戏论去除棘刺。舍诸重担得大善利。诸有结缚皆悉已尽。正智无碍心得自在诸心善寂。是诸菩萨。于十方一切处无量无数三千大千世界。一一世界中所有过去无量无数已入涅槃诸佛如来。是诸如来从初发心乃至成就阿耨多罗三藐三菩提果。已入无余依大涅槃界。乃至法灭已来于其中间所有诸佛世尊诸波罗蜜多相应善根。及彼种种福行善根。诸佛戒定慧解脱解脱知见诸蕴善根。乃至大慈大悲无量无边利益安乐一切众生佛功德聚。及佛所说种种法门。一切众生于是中学。信解安住所有善根。及佛世尊为诸菩萨授阿耨多罗三藐三菩提记。是诸菩萨所有六波罗蜜多相应善根。又复为诸缘觉乘人授缘觉记。而彼所有一切善根。又复有诸声闻乘人。行于布施持戒修定所有功德。及诸有学无漏无学无漏如是善根。又复所有诸愚异生所种善根。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人傍生异类。闻佛说法所种善根。乃至如来入涅槃后。一切众生所种善根。如是等种种善根种种功德。和合聚集称计较量。是诸菩萨一一随喜。以此随喜功德。回向阿耨多罗三藐三菩提。慈氏。若菩萨摩诃萨作如是回向。云何当得不堕想颠倒心颠倒见颠倒

尔时慈氏菩萨告尊者须菩提言。若菩萨摩诃萨。所用心随喜及回向时于是心中不生心想。如实知心无所取相。若菩萨摩诃萨。能以如是随喜功德。回向阿耨多罗三藐三菩提者。是菩萨摩诃萨。即得不堕想心见倒。若复于心不如实知。以有得想而回向者。是菩萨摩诃萨。不能远离想心见倒。又复若诸菩萨摩诃萨。以有得心而回向者。是心即尽即灭即离。彼尽灭心不能回向。若以无所得心而回向者。是即如实回向法性。若法如是回向故即法性亦然。法性如是回向故即诸法亦然。若菩萨摩诃萨能如是回向者。是为正回向。不名邪回向。而此回向法菩萨摩诃萨应当如是学

复次尊者须菩提。若菩萨摩诃萨。如过去诸佛善根。如是随喜回向。若于未来诸佛道悉已修习。已灭戏论得大善利。是诸如来。从初发心乃至成就阿耨多罗三藐三菩提果。已入无余依大涅槃界。乃至法灭已来。于其中间所有诸佛世尊诸波罗蜜多相应善根。及彼诸佛戒定慧解脱解脱知见诸蕴善根。乃至大慈大悲无量无边利益安乐一切众生佛功德聚。及佛所说种种法门。一切众生于是中学信解安住所有善根。及佛世尊为诸菩萨授阿耨多罗三藐三菩提记。是诸菩萨所有六波罗蜜多相应善根。又复为诸缘觉乘人授缘觉记。而彼所有一切善根。又复有诸声闻乘人。行于布施持戒修定所有善根。及诸有学无漏无学无漏如是善根。又复所有诸愚异生所种善根。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人傍生异类。闻佛说法所种善根。乃至如来入涅槃后。一切众生所种善根。如是等种种善根种种功德。和合聚集称计较量。是诸菩萨一一随喜。以此随喜功德回向阿耨多罗三藐三菩提。尊者须菩提。而彼菩萨所用心。随喜及回向时。若于是心中不生心想。如实知心无所取相。能以如是随喜功德。回向阿耨多罗三藐三菩提者。是菩萨即得不堕想心见倒。若复于心不如实知。以有得想而回向者。是菩萨不能远离想心见倒。又复若诸菩萨。以有得心而回向者。是心即尽即灭即离。彼尽灭心不能回向。若以无所得心而回向者。是即如实回向法性。若法如是回向故即法性亦然。法性如是回向故即诸法亦然。若如是回向者。是为正回向。不名邪回向复次尊者须菩提。菩萨摩诃萨。如未来诸佛善根。如是随喜回向。若于现在诸佛如来。从初发心乃至成就阿耨多罗三藐三菩提果。已入无余依大涅槃界。乃至法灭已来。于其中间所有诸佛世尊一切善根。乃至如来入涅槃后一切众生所种善根。如是等种种善根种种功德。和合聚集称计较量。是诸菩萨一一随喜。以此随喜功德。回向阿耨多罗三藐三菩提。尊者须菩提。而彼菩萨所用心。随喜及回向时。于是心中不生心想。如实知心无所取相。若能如是随喜功德。回向阿耨多罗三藐三菩提者。是菩萨即得不堕想心见倒。若复以其有所得心而回向者。是菩萨不能远离想心见倒。而彼菩萨摩诃萨当如实知所用心。回向时是心即尽即灭即离。彼尽灭心即不能回向。若以无所得心而回向者。是即如实回向法性。若法如是回向故即法性亦然。法性如是回向故即诸法亦然。若菩萨摩诃萨。于如是过去未来现在法中。能如实知如实回向者。是为正回向。不名邪回向

复次须菩提。菩萨摩诃萨。若欲如实回向阿耨多罗三藐三菩提者。当观诸法犹如虚空离一切相。何以故。若于诸法如实了知。即无心无非心。是能知者。无法无非法。为所知相。若菩萨于如是法中能回向者。是名最上回向。是故得名菩萨摩诃萨正修福行。何以故。若种种法及种种行皆寂静故。所有随喜功德。回向阿耨多罗三藐三菩提亦复如是。若如实知诸行皆寂无所动者。是菩萨摩诃萨。即能具足般若波罗蜜多方便。于佛世尊入涅槃后。所有善根若体若相若自性若法性。皆如实知即能回向阿耨多罗三藐三菩提。何以故。诸佛世尊所有一切相应行法非三世故。若过去世彼法已离已灭已尽。若未来世当所未至。若现在世今即无住。复无所得非境界相。若取相者即于阿耨多罗三藐三菩提。住不平等邪念相应。生疑惑想不能安住正念正意。邪所思觉。如是即不名回向阿耨多罗三藐三菩提。若菩萨摩诃萨。于诸善根无所取相无所得心。以是心回向者。是为回向阿耨多罗三藐三菩提。如是回向法。菩萨应当学。若如是学者彼能具足善巧方便。若诸善根有是善巧方便而用回向者。即得近一切智。若诸菩萨摩诃萨。乐欲修学此方便者。应当于此般若波罗蜜多法门。听受读诵记念思惟请问其义。如所解了广为他说。是为般若波罗蜜多方便。若不得般若波罗蜜多方便。即不能以诸善根回向阿耨多罗三藐三菩提。何以故。我相已灭诸行已寂。远离种种有所得想。若复有人。于一切法而生取相堕疑惑见。不能安住如实法中。于如实法生有得想。若以如是善根。回向阿耨多罗三藐三菩提者。诸佛如来非所印可亦不随喜。何以故。如是回向名为大贪。于一切法生疑惑心。复于诸相不能寂静生有得想如来应供正等正觉。亦不说为有大利益。而此回向名为杂毒苦恼。譬如世间上味饮食。诸色香味皆悉具足。而彼食中为毒所杂。诸有智者知杂毒故而不取食。愚痴无智不能觉了。但取食之。彼初食时。色香美味虽所爱乐。食力销已苦报现前。以是缘故而趣命终。尊者须菩提。汝今当知。诸有随喜善根发回向心者。不能受持读诵般若波罗蜜多亦复如是何以故。不能具足般若波罗蜜多。方便故不能解了甚深正义。于如实道不能安住。自不了知彼如实法。复为他人展转教授作如是言。汝善男子。当于过去未来现在诸佛世尊所有戒定慧解脱解脱知见诸蕴善根。及彼所有过现未来诸佛世尊。从初发心乃至成就阿耨多罗三藐三菩提果。已入无余依大涅槃界。于其中间所有功德。及为诸菩萨摩诃萨授记当得阿耨多罗三藐三菩提果。是诸菩萨所有善根。又复为诸缘觉乘人授缘觉记。是诸缘觉所有善根。及诸声闻修施戒等。于佛灭后法灭已来。于其中间所种善根。乃至愚夫异生所有善根。如是等种种善根种种功德。和合聚集称计较量尽无尽相。汝等应当一一随喜。以此随喜善根。回向阿耨多罗三藐三菩提。须菩提。彼人若作是言。劝令如是随喜回向者。如美食中而杂诸毒。此回向法名为杂毒苦恼。诸修菩萨行者。于自所行尚不应起此回向心。况复如是转劝他人令修此法。若于是相取为实者。不名随喜诸佛功德。不名受持不名回向。若诸菩萨。乐欲如实随喜诸佛如来所有最上一切善根。如实回向阿耨多罗三藐三菩提者。应当随顺如来应供正等正觉。如其佛眼如实观察。如其佛智如实了知。于诸善根。若体若相若自性若法性。如实了知无所生无所得。若能如是随喜善根。佛所印可佛亦随喜。诸菩萨摩诃萨如是随喜者是正随喜。以此善根回向阿耨多罗三藐三菩提。如来应供正等正觉最上称赞。如是回向名大回向。回向法界善得圆满。内心清净解脱无碍

复次诸修菩萨乘善男子等。修习如是回向法者。于佛如来所有戒定慧解脱解脱知见。无系无著。不系欲界不系色界不系无色界。亦复不系过去未来现在三世。不系诸法不系回向法。修菩萨者如是知已不坏回向法。是大回向善得圆满回向法界。如是回向不取诸相。远离邪法名正回向。如来应供正等正觉。真实印可亦复随喜。菩萨摩诃萨应当如是学

尔时世尊。赞尊者须菩提言。善哉善哉。须菩提汝善作佛事。能为诸菩萨摩诃萨请问其义。须菩提。诸菩萨摩诃萨。若能如是回向法界法性。如佛世尊所有知见。于诸善根如实觉了。若体若相若自性若法性。了无所生复无所得如是回向我所印可。我亦随喜如是福蕴。无量无边不可称计。须菩提。假使三千大千世界所有一切众生。一一皆修十善业道。所获福蕴其数甚多。而此菩萨摩诃萨。发最胜心回向法界者所有福蕴。比前福蕴最上最极最胜最妙。广大无量无等无等等

复次须菩提。且置是数。假使三千大千世界所有一切众生。一一皆修四无量行。一一皆得四禅定法四无色定及五神通。如是福行其数甚多。而此菩萨摩诃萨。发最胜心回向法界所有福蕴。比前福蕴最上最极。最胜最妙广大无量无等无等等

佛说佛母出生三法藏般若波罗蜜多经卷第六佛说佛母出生三法藏般若波罗蜜多经卷第七

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    随喜回向品第六之二

复次须菩提。如前所说四无量行乃至五神通行。皆置是数。假使三千大千世界一切众生。一一皆得须陀洹斯陀含阿那含阿罗汉果。如是福蕴亦置是数。假使三千大千世界一切众生。一一皆得彼缘觉果。如是福蕴亦置是数。须菩提。假使三千大千世界一切众生。皆发阿耨多罗三藐三菩提心。是诸众生即得名为发心菩萨。而此菩萨一一皆于兢伽沙数劫中。以其饮食衣服卧具医药及余乐具。普施兢伽沙数世界一切众生。而诸菩萨作是施时。一一皆起最胜上心生尊重想。须菩提。于汝意云何。是诸菩萨得福多不。须菩提。白佛言。甚多世尊。而此福蕴无量无数无有边际。算分数分及譬喻分。乃至乌波尼杀昙分皆不能及。佛言。不也须菩提。若有住菩萨乘诸善男子。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。而能以少善根回向阿耨多罗三藐三菩提。是即如实回向法界。如是回向所有福蕴。比前菩萨布施福蕴。而彼百分不及此一。千分不及一。万亿俱胝那庾多分。乃至乌波尼杀昙分皆不及一。何以故。此般若波罗蜜多方便善根。胜前菩萨有所得心布施行故。以是福蕴不可等比。尔时四大王天。有二万天子。在佛会中闻作是说。合掌恭敬俱白佛言。世尊。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能以善根如实回向彼一切智。如是回向是大回向。所获福蕴。胜前菩萨有所得心布施福蕴

尔时三十三天。有十万天子。即时雨众天华天香涂香及末香等。并余种种幢幡宝盖天妙音乐。乃至一切宝严天衣天诸珍宝。以如是等恭敬供养而作是言。世尊。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能以善根回向法界。如是回向是大回向。所获福蕴胜前菩萨有所得心布施福蕴。世尊。我等诸天子众。皆于如是菩萨摩诃萨所生最胜心。恭敬供养尊重称赞。彼诸天子发是言时。其声普闻一切世界。是时夜摩天中十万天子。知足天中十万天子。化乐天中十万天子。他化自在天中十万天子。如是等欲界诸天子众。复有色界梵众天。梵辅天。大梵天。少光天。无量光天。光音天。少净天。无量净天。遍净天。无云天。福生天。广果天。无烦天。无热天。善见天。善现天。色究竟天。如是等天中诸天子众。各各合掌恭敬而白佛言。希有世尊。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能以善根回向法界。如是回向胜前菩萨有所得心布施福蕴

尔时世尊。告净居天等诸天子言。如前所说。三千大千世界所有发心菩萨。一一于其兢伽沙数劫中广施众生。如是福蕴且置是数。天子假使兢伽沙数三千大千世界一切众生。皆发阿耨多罗三藐三菩提心。是诸发心菩萨。一一于其兢伽沙数劫中。以其饮食衣服卧具医药及余乐具。普施兢伽沙数三千大千世界一切众生。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能于过去未来现在诸佛所有戒定慧解脱解脱知见诸蕴善根。及缘觉声闻所有善根。如是等种种善根。和合聚集称计较量。以最上最极最胜最妙。广大无量无等无等等心皆悉随喜。以此随喜善根。如实回向阿耨多罗三藐三菩提。须菩提。此菩萨如是随喜福蕴。比前菩萨布施福行。而彼百分不及此一。千分不及一。万亿俱胝那庾多分。乃至乌波尼杀昙分皆不及一。何以故。具足般若波罗蜜多方便者。胜前菩萨有所得心布施行故。尔时尊者须菩提白佛言。世尊。如佛所言。菩萨摩诃萨。修习般若波罗蜜多方便。为般若波罗蜜多所护者。于诸善根能以最上最极最胜最妙广大无量无等无等等心。如实随喜回向阿耨多罗三藐三菩提。世尊。当云何是最上最极。乃至无等等心。又复何名如实随喜。佛告须菩提。若菩萨摩诃萨。于过去未来现在诸法。不取不舍无念无得。离诸疑惑不生分别。无过去法已生已灭无未来法未生未灭。无现在法即生即灭。当观诸法犹如虚空。离一切相无所动转。不生不灭不来不去。彼诸法相即诸法性。如其法性如实随喜。如所随喜回向亦然。须菩提。若菩萨于一切法能起此心者。是即名为最上最极最胜最妙广大无量无等无等等心。即以此心而随喜者。乃可得名如实随喜。以此随喜善根回向阿耨多罗三藐三菩提者。是故名为如实回向

复次须菩提。如前所说。兢伽沙数三千大千世界。所有一切发心菩萨。一一于其兢伽沙数劫中修布施行。且置是数。须菩提。若兢伽沙数三千大千世界一切众生。皆发阿耨多罗三藐三菩提心。是诸发心菩萨。一一于其兢伽沙数劫中。修持净戒。身善所作。语善所作。意善所作。彼诸菩萨。于兢伽沙数劫中。如是持戒不生过失。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能于过去未来现在诸佛所有戒定慧解脱解脱知见诸蕴善根。及缘觉声闻所有善根。如是等种种善根和合聚集称计较量。以最上最极最胜最妙。广大无量无等无等等心皆悉随喜。以此随喜善根。回向阿耨多罗三藐三菩提。须菩提。此菩萨如是随喜福蕴。比前菩萨持戒福行。而彼百分不及此一。千分不及一。万亿俱胝那庾多分。乃至乌波尼杀昙分皆不及一。何以故。具足般若波罗蜜多方便者。胜前菩萨有所得心持戒行故

复次须菩提。如前所说兢伽沙数三千大千世界所有一切发心菩萨。一一于其兢伽沙数劫中持净戒行。且置是数。须菩提。若兢伽沙数三千大千世界一切众生皆发阿耨多罗三藐三菩提心。是诸发心菩萨。一一于其兢伽沙数劫中。持忍辱行不忿不恚。乃至不起一切恶念。彼诸菩萨于兢伽沙数劫中。如是忍辱不生忿恚若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能于过去未来现在诸佛所有戒定慧解脱解脱知见诸蕴善根。及缘觉声闻所有善根。如是等种种善根。和合聚集称计较量。以最上最极最胜最妙。广大无量无等无等等心皆悉随喜。以此随喜善根。回向阿耨多罗三藐三菩提。须菩提。此菩萨如是随喜福蕴。比前菩萨忍辱福行。而彼百分不及此一。千分不及一。百亿俱胝那庾多分。乃至乌波尼杀昙分。皆不及一。何以故。具足般若波罗蜜多方便者。胜前菩萨有所得心忍辱行故

复次须菩提。如前所说兢伽沙数三千大千世界所有一切发心菩萨。一一于其兢伽沙数劫中持忍辱行。且置是数。须菩提。若兢伽沙数三千大千世界一切众生。皆发阿耨多罗三藐三菩提心。是诸发心菩萨。一一于其兢伽沙数劫中修精进行。勇猛坚固不退不失。远离惛沉睡眠及诸障法。彼诸菩萨于兢伽沙数劫中。如是精进不生懈退。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能于过去未来现在诸佛所有戒定慧解脱解脱知见诸蕴善根。及缘觉声闻所有善根。如是等种种善根。和合聚集称计较量。以最上最极最胜最妙。广大无量无等无等等心皆悉随喜。以此随喜善根回向阿耨多罗三藐三菩提。须菩提。此菩萨如是随喜福蕴。比前菩萨精进福行。而彼百分不及此一。千分不及一。万亿俱胝那庾多分。乃至乌波尼杀昙分。皆不及一。何以故。具足般若波罗蜜多方便者。胜前菩萨有所得心精进行故

复次须菩提。如前所说兢伽沙数三千大千世界所有一切发心菩萨。一一于其兢伽沙数劫中修精进行。且置是数。须菩提。若兢伽沙数三千大千世界一切众生。皆发阿耨多罗三藐三菩提心。是诸发心菩萨。一一于其兢伽沙数劫中。修四禅定安住寂静。彼诸菩萨于兢伽沙数劫中如是修定。远离一切动乱等相。若菩萨摩诃萨。于此般若波罗蜜多修习方便。为般若波罗蜜多所护者。能于过去未来现在诸佛所有戒定慧解脱解脱知见诸蕴善根。及缘觉声闻所有善根。如是等种种善根。和合聚集称计较量。以最上最极最胜最妙。广大无量无等无等等心皆悉随喜。以此随喜善根回向阿耨多罗三藐三菩提。须菩提。此菩萨如是随喜福蕴。比前菩萨修定福行。而彼百分不及此一。千分不及一。万亿俱胝那庾多分乃至乌波尼杀昙分。皆不及一。何以故。具足般若波罗蜜多方便者。胜前菩萨有所得心修定行故

佛告须菩提。若诸菩萨摩诃萨。乐欲于其过去未来现在诸佛六波罗蜜多法门。如理修学如实随喜者。当于诸法住如实义。如实义者谓解脱性。如所解脱布施亦如是。如所解脱持戒忍辱精进禅定智慧皆亦如是。如所解脱解脱亦如是。如所解脱解脱知见亦如是。如所解脱随喜心及随喜福行亦如是。如所解脱回向心及回向法亦如是。如所解脱过去已灭法。未来未生法。现在无住法皆亦如是。如所解脱十方三世无量无数一切诸佛及诸佛法亦如是。如所解脱所有菩萨缘觉声闻及彼诸法亦如是。如是等乃至一切法。无缚无解无住无著所解脱性即诸法性。须菩提。菩萨摩诃萨于一切法如是知者。当于六波罗蜜多法门如是修学如是随喜。以此随喜善根。如实回向阿耨多罗三藐三菩提

    地狱缘品第七之一

尔时尊者舍利子白佛言。世尊。般若波罗蜜多出生一切智智。一切智性即般若波罗蜜多耶。佛言舍利子。如是如是。如汝所说。舍利子复白佛言。世尊。般若波罗蜜多所应敬礼。般若波罗蜜多所应尊重。般若波罗蜜多是大光明。般若波罗蜜多清净无染。般若波罗蜜多广大照曜。般若波罗蜜多摄三界相即三界性。般若波罗蜜多为清净眼。能照一切烦恼染法。般若波罗蜜多是所依止。般若波罗蜜多是无上法。般若波罗蜜多广摄一切菩提分法。般若波罗蜜多为大法炬。普照世间一切闇瞑。般若波罗蜜多是无所畏。能救一切怖畏众生。般若波罗蜜多是即五眼。能照一切世出世道。般若波罗蜜多为智慧光。照破一切痴闇等法。般若波罗蜜多为诸导首。引示众生趣入圣道。般若波罗蜜多是一切智藏。普摄烦恼等障为作断灭。般若波罗蜜多是无生法无灭法。无起法无作法。般若波罗蜜多自相本空。般若波罗蜜多是诸菩萨母。般若波罗蜜多为诸法眼。照明诸佛所有十力四无所畏。般若波罗蜜多是所依怙。能救一切无依众生。般若波罗蜜多是安乐法。能断众生生死苦恼。般若波罗蜜多能示诸法真实自性。般若波罗蜜多随顺法相。圆满三转十二行轮。世尊。般若波罗蜜多有如是等种种功德。诸菩萨摩诃萨于此法门应当云何瞻礼恭敬

佛告尊者舍利子言。菩萨摩诃萨于此般若波罗蜜多法门。应如师想如诸佛想。尊重恭敬瞻礼称赞。如是瞻敬般若波罗蜜多故。是即瞻敬诸佛世尊

尔时帝释天主。即起是念。尊者舍利子。今以何缘而生此问。作是念已。前白尊者舍利子言。尊者。有何因缘如是问佛。舍利子言。憍尸迦。如佛所说。诸菩萨摩诃萨修习般若波罗蜜多方便。为般若波罗蜜多所护者。即能于彼一切善根如实随喜如实回向。彼一切智。而此般若波罗蜜多有大功德。胜诸菩萨有所得心。布施持戒忍辱精进禅定福行。以是缘故我作此问。憍尸迦。汝今当知。此般若波罗蜜多与五波罗蜜多而为导首。引示令入一切智道。譬如世间有其盲人。虽聚百千万众欲有所往而皆不能知所行道。若无导师彼终不能进趣城邑聚落方处。若有目人为作先导。彼诸盲者即能达彼一切方处。憍尸迦。所有布施持戒忍辱精进禅定犹如盲人。虽复修习无量福行。欲至一切智果。若不以此般若波罗蜜多而为导首。毕竟不能如实趣向一切智道。况复能得一切智果。若此布施等法。得般若波罗蜜多为导首者。即得智慧之眼。而能照达一切智道。即得趣证一切智果。又复布施持戒忍辱精进禅定。为般若波罗蜜多力所助者。是故此五即得名为波罗蜜多

尔时尊者舍利子白佛言。世尊。般若波罗蜜多为何法故生。佛言舍利子。般若波罗蜜多。不见有色不为色故生。不见受想行识。不为受想行识故生。若此五蕴有所生相。即般若波罗蜜多为彼故生。而此五蕴既无所生。是故般若波罗蜜多不为诸法故生。

舍利子复白佛言。世尊。若般若波罗蜜多如是生者。当于何法有所成耶。佛言舍利子。般若波罗蜜多。虽如是生无少法可成。由无法成故乃得名为般若波罗蜜多

尔时帝释天主。闻是说已即白佛言。世尊。般若波罗蜜多。岂不成于一切智耶。佛言憍尸迦。如汝所言。般若波罗蜜多。亦成一切智。然非有所得故成。亦非名相起作故成。帝释天主言。世尊。当云何成。佛言憍尸迦。诸法无所成如是成

帝释天主复白佛言。希有世尊。今此般若波罗蜜多。无所生无所灭。彼一切法亦无生无灭无住无著。是即般若波罗蜜多

尔时尊者须菩提白佛言。世尊。若生如是心有所分别者。即远般若波罗蜜多。即失般若波罗蜜多。即不成就般若波罗蜜多佛言须菩提。如是如是。有是因缘。即远般若波罗蜜多。即失般若波罗蜜多。即不成就般若波罗蜜多。何以故。此般若波罗蜜多。于色无所表示。受想行识亦无所表示。须陀洹斯陀含阿那含阿罗汉缘觉菩萨及佛世尊。皆悉无所表示故

尊者须菩提复白佛言。世尊。大波罗蜜多是般若波罗蜜多耶。佛言须菩提。于汝意云何。以何因缘谓大波罗蜜多是般若波罗蜜多。须菩提白佛言。世尊。色无大无小无集无散离诸起作。受想行识。亦无大无小无集无散离诸起作。所有如来十力等法。不作有力不作无力亦无集散。乃至一切智。亦无大小集散诸起作等。何以故。一切法无大小无集散离起作住平等。若菩萨于一切法有所分别而作是念。我得具足一切智果。我为众生说诸法门。能度若干众生令至涅槃。而彼菩萨作是念者。即不名行般若波罗蜜多。所以者何。般若波罗蜜多无如是相。不见众生有所度者有所得者。以众生无性故般若波罗蜜多亦无性。众生离相故般若波罗蜜多亦离相。众生不生故般若波罗蜜多亦不生。众生不灭故般若波罗蜜多亦不灭。众生不思议故般若波罗蜜多亦不思议。众生无觉了故般若波罗蜜多亦无觉了。众生如实知胜义故般若波罗蜜多亦如实知胜义。众生力集故如来力亦集。世尊。我以如是因缘。谓大波罗蜜多是般若波罗蜜多

尔时尊者舍利子白佛言。世尊。若诸菩萨摩诃萨于此甚深般若波罗蜜多法门。闻已谛受不疑不难生净信解者。此诸菩萨于何处没而来生此。佛告舍利子。当知此菩萨已于他方诸佛刹中听受此法。请问其义随顺解了。从彼没已而来生此。复次舍利子。若人暂得闻此甚深般若波罗蜜多法门。即生信解踊跃欢喜。尊重恭敬如佛想者。当知是人已于无数佛世尊所听受此法。久修菩萨最胜妙行。如是等人佛所称赞

佛说佛母出生三法藏般若波罗蜜多经卷第七佛说佛母出生三法藏般若波罗蜜多经卷第八

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    地狱缘品第七之二

尔时尊者须菩提白佛言。世尊。般若波罗蜜多可闻可得耶。若声若相有所说耶。佛言。不也须菩提。般若波罗蜜多。无说无示无闻无得。非蕴处界有所见相。何以故。彼一切法离种种性。而蕴处界即般若波罗蜜多。何以故。由蕴处界空故离故寂灭故。般若波罗蜜多亦空亦离亦寂灭。而般若波罗蜜多。与蕴处界无二无二分无相无分别

尔时尊者须菩提白佛言。世尊。若有人于佛会中。闻说此甚深般若波罗蜜多法门。不生信解心无爱乐。从法会起不能听受者。彼人以何因缘起如是相

佛告须菩提。我今为汝如实分别。若有人闻此甚深般若波罗蜜多法门。不生信解不乐听受。当知是人虽于百千佛所修诸梵行。而不爱乐听受此法。于诸佛所。若闻说是般若波罗蜜多法门时从会起者。须菩提。彼人于先佛所已种如是障法因缘。是故今时于我法中。闻说甚深般若波罗蜜多法门。亦复不生爱乐信解。无尊重想舍离而去。当知是人若身若心不能和合。是故于此般若波罗蜜多法门。不生一念清净信解。不起如实正知见想。于甚深法生疑惑心造无智业由是积集无智业故。闻此般若波罗蜜多法门。生违背心起毁谤业。以违背毁谤般若波罗蜜多故。是即违背毁谤过去未来现在诸佛一切智。须菩提。我说是人少智少慧无正福业。不能成就净信善根。于一切时一切处。自坏其身复坏他身。断诸众生大利乐因。须菩提。彼人以是谤法因缘故。当来决定堕大地狱。经多百岁。多千岁。多百千岁。多俱胝百岁。多俱胝千岁。多俱胝百千岁。多俱胝那庾多百千岁中。受诸苦恼。从一大地狱至一大地狱。又复展转从一至一。若此大地狱劫火烧时。彼谤法人即于他方世界大地狱中受诸苦恼。亦复从一大地狱至一大地狱。若他方界所有地狱劫火烧时。又复展转于他方界大地狱中。受诸苦恼亦复如是。从一至一。又若彼界劫火烧时此界还成。而复来此大地狱中。亦复从一至一受诸苦恼。如是展转此界他界。一一狱中如前数量。经尔所岁受诸苦恼。乃至最后此界地狱劫火复起。所焚烧时受苦方尽。何以故。须菩提。彼人以语不善业。毁谤甚深般若波罗蜜多法门故获如是果

尔时尊者舍利子白佛言。世尊。所有众生造五无间极重罪业。与此谤法罪业而相似耶。佛言舍利子。汝勿谓彼五无间业与此谤法重罪而得相似。舍利子。违背毁谤甚深正法者。其罪甚重过五无间所有罪业。何以故。彼谤法者闻说般若波罗蜜多法门。即作是言此非佛说。我今不能于是中学。彼人自坏净信。复坏他人所有净信。自饮诸毒复令他人亦饮其毒。自所破坏亦复令他作其破坏。自于般若波罗蜜多法门。不信不受不知不解而不修习。复令他人不生信受不正知解亦不修习。舍利子。我说是人为破法者。其性浊黑而不清净。于白法中为羯商摩毁坏净信。又复得名为污法者。舍利子。以是因缘此谤法罪最极深重。五无间业不可等比。舍利子白佛言。世尊。如佛所说。彼谤法人堕大地狱。不知是人当受苦身其量云何。佛言。止舍利子。不须问其受苦身量。何以故。彼人若闻所受苦身大小分量。是时即有热血从口门出将及命终。如是转生忧愁苦恼。身分内外干枯销瘦生大怖畏。是故我今不说彼人受苦身量。舍利子重白佛言。世尊。愿为宣说彼谤法者受苦身量。与末世中一切众生。而为明照有所表示。令于正法不生毁谤。佛言舍利子。止不须说。尔时尊者舍利子。如是殷勤第二第三重复劝请。佛言。舍利子止止。是事汝今当知。如我所说若谤法者堕大地狱。尔所岁中受极重苦。即以是缘与诸众生足为明照。是故不应说其身量

尔时尊者须菩提白佛言。世尊。诸善男子善女人。于一切时常当善护身语意业。不令作诸不善业行。何以故。如佛所说堕地狱者。由其语不善业。能作如是最极广大非福蕴故。世尊。谤正法者实由语业感是罪报耶。佛言。如是如是。须菩提。由彼语业起不善故。即于正法而生毁谤。以是因缘受斯罪报。须菩提。我说是人于我法中不应出家。何以故。彼人违背毁谤般若波罗蜜多故是即毁谤阿耨多罗三藐三菩提。以谤阿耨多罗三藐三菩提故是即毁谤一切佛宝。谤佛宝故即谤过去未来现在诸佛一切智。谤一切智故是即毁谤一切法宝。谤法宝故即谤声闻一切僧宝。如是即于一切种一切时一切处毁谤三宝。积集无量无数不善业行。当堕地狱受大苦恼

须菩提白佛言。世尊。彼人以何因缘。于此般若波罗蜜多法门生轻谤心。佛告须菩提。当知彼人有四种因。何等为四。一者为魔所使。二者自所积集无智业因。破坏所有清净信解。三者随顺一切不善知识。于非法中生和合想。四者执着我相不生正见。随彼邪心作诸过失。须菩提。由是四种因缘故。于此甚深般若波罗蜜多法门而生毁谤。须菩提。是故诸善男子善女人。当于诸佛所说正法起净信解勿生轻谤。谤正法者是即破法。若破法者断灭寿命起无智业。当堕地狱受大苦恼

    清净品第八之一

尔时尊者须菩提白佛言。世尊。若有随顺恶知识。远离善根及不精进者。于此甚深般若波罗蜜多法门。极难信解耶。佛告须菩提。如是如是。如汝所言。如是等人。少见少闻远离善根。修劣智慧不能精进。又复随顺诸恶知识。是故于此甚深法门极难信解。须菩提白佛言。世尊。而此般若波罗蜜多法门。以何义故难信难解。佛言。须菩提。色受想行识无缚无解。何以故。色自性是色故无缚无解。受想行识自性是识故无缚无解。色前际无缚无解。何以故。前际色自性即是色故。色后际无缚无解。后际色自性即是色故。色中际无缚无解。中际色自性即是色故。受想行识前后中际无缚无解。何以故。前后中际识自性即是识故。般若波罗蜜多以是义故甚深难解。须菩提白佛言。世尊。般若波罗蜜多法门难信难解。如佛所说最极甚深转复难解。世尊。若有懈怠劣精进者失念无智慧者。应知此等于般若波罗蜜多法门难解难入。佛告须菩提。如是如是。如汝所言

复次须菩提。色清净故即果清净。果清净故即色清净。若色清净若果清净。无二无分别无断无坏故。受想行识清净故即果清净。果清净故即识清净。若识清净若果清净。无二无分别无断无坏故

复次须菩提。色清净故即一切智清净。一切智清净故即色清净。若色清净若一切智清净。无二无分别无断无坏故。受想行识清净故即一切智清净。一切智清净故即识清净。若识清净若一切智清净。无二无分别无断无坏故

尔时尊者舍利子白佛言。世尊。般若波罗蜜多最上甚深。佛言。性清净故。舍利子言。般若波罗蜜多是大光明。佛言。性清净故。舍利子言。般若波罗蜜多广大照曜。佛言。性清净故。舍利子言。般若波罗蜜多无和合。佛言。性清净故。舍利子言。般若波罗蜜多无所得。佛言。性清净故。舍利子言。般若波罗蜜多无所证。佛言。性清净故。舍利子言。般若波罗蜜多毕竟不生欲界色界无色界。佛言。性清净故。舍利子言。般若波罗蜜多毕竟不灭。佛言。性清净故。舍利子言。般若波罗蜜多无所了知。佛言。性清净故。舍利子言。般若波罗蜜多云何无所了知。佛言。舍利子。般若波罗蜜多不知色不知受想行识。何以故。色受想行识性清净故。舍利子言。般若波罗蜜多。于一切智无起无作。佛言。性清净故。舍利子言。般若波罗蜜多。无法可取无法可舍。佛言。性清净故

尔时尊者须菩提白佛言。世尊。我清净故色清净。佛言。毕竟净故。我清净故受想行识清净。佛言。毕竟净故。须菩提言。我清净故果清净。佛言。毕竟净故。须菩提言。我清净故一切智清净。佛言。毕竟净故。须菩提言。我清净故无所得无所证。佛言。毕竟净故。须菩提言。我无边故色亦无边。佛言。毕竟净故。须菩提言。我无边故受想行识亦无边。佛言。毕竟净故。须菩提言。菩萨摩诃萨于般若波罗蜜多。无所觉了。佛言。毕竟净故。须菩提言般若波罗蜜多非此岸非彼岸非中流自性无所住。佛言。毕竟净故

尔时尊者须菩提白佛言。世尊。若菩萨摩诃萨于一切法有所分别者。即失般若波罗蜜多。即远般若波罗蜜多

佛赞须菩提言。善哉善哉。须菩提。如是如是。如汝所言。何以故。若于一切法起分别者是即名相。有所著故。须菩提白佛言。世尊。若于所说般若波罗蜜多名中有所分别此说为着。是时尊者舍利子谓须菩提言。云何名为着相。须菩提言。若菩萨分别色空。分别受想行识空。是为着相。又若分别是过去法是未来法是现在法。是初发菩提心者得若干福蕴。是久修菩萨行者成几所功德。作此分别者名为着相

尔时帝释天主白尊者须菩提言。以何缘故菩萨得福蕴名为着相。须菩提言。憍尸迦。若初发心菩萨以心分别此是菩提心。即以发心。善根回向阿耨多罗三藐三菩提。若能回向即不名回向。如是分别乃为着相。憍尸迦。若有菩萨欲令诸善男子善女人安住菩萨乘者。应于阿耨多罗三藐三菩提。以真实法如理表示如实教授如所利益如理生喜。若菩萨能以如是法示教利喜者。自无所伤诸佛所印诸佛所教。彼善男子善女人亦复离着

尔时佛赞须菩提言。善哉善哉。须菩提。汝善宣说离着法门。令诸菩萨摩诃萨于一切法不生执着。须菩提。我复为汝宣说微妙离着法门。汝当善听如善作意。须菩提白佛言。善哉世尊。愿为宣说

佛告须菩提。若有人于如来应供正等正觉。作有得想而生取着。此即名为大贪着法。何以故。不离诸相故。须菩提。若有菩萨于过去未来现在诸佛世尊所有诸无漏法起随喜心。以此随喜善根。回向阿耨多罗三藐三菩提者亦即是着。何以故。须菩提。诸法非过去未来现在可得。彼随喜心亦非三世。当以何心随喜何法。是故当知一切法无相。无见无闻无觉无知。须菩提。白佛言。世尊。诸法性甚深。佛言。离种种性。须菩提言。般若波罗蜜多性甚深。佛言。般若波罗蜜多自性清净离种种性。须菩提言。般若波罗蜜多离性我今敬礼。佛言。一切法离性。须菩提。由一切法离性故即般若波罗蜜多离性。何以故。如来应供正等正觉如实证得一切法。无性

须菩提白佛言。世尊。如来应供正等正觉证法无性耶。佛告须菩提。无性亦非无性。彼一切法若性若无性。和合一相所谓无相。须菩提。是故诸佛如是证得彼一切法。何以故。诸佛法眼无分别故。一切法性唯一无二。彼一切法若性非性所谓无性。彼无性性是名一性。即此一性亦不可得。须菩提。若菩萨如是了知者得离诸着。须菩提白佛言。世尊。般若波罗蜜多最上甚深。佛言。如虚空甚深即般若波罗蜜多甚深。须菩提言。般若波罗蜜多难知。佛言。无知者故。须菩提言。般若波罗蜜多不可思议。佛言。非心所知出过心数故。须菩提言。般若波罗蜜多离诸所作。佛言。作者不可得故。须菩提白佛言。世尊。菩萨摩诃萨当云何行般若波罗蜜多。佛言。若菩萨摩诃萨不行于色是行般若波罗蜜多。不行受想行识是行般若波罗蜜多。不行色无常是行般若波罗蜜多。不行受想行识无常是行般若波罗蜜多。不行色空是行般若波罗蜜多。不行受想行识空是行般若波罗蜜多。不行色满足不满足相是行般若波罗蜜多。何以故。若行色满足不满足相即非色。不行受想行识满足不满足相是行般若波罗蜜多。何以故。若行受想行识满足不满足相即非识。若如是不行诸法是名行般若波罗蜜多

尔时尊者须菩提白佛言。希有世尊。善为诸菩萨摩诃萨于着法中说无著法。佛言。若不行色有着无著是行般若波罗蜜多。不行受想行识有着无著是行般若波罗蜜多。不行眼触乃至不行意触为缘所生诸受有着无著是行般若波罗蜜多。不行地界乃至不行识界有着无著是行般若波罗蜜多。不行布施持戒忍辱精进禅定智慧诸波罗蜜多有着无著是行般若波罗蜜多。不行三十七菩提分法及佛十力四无所畏十八不共诸功德聚有着无著是行般若波罗蜜多。不行须陀洹斯陀含阿那含阿罗汉缘觉如来有着无著是行般若波罗蜜多。不行一切智有着无著是行般若波罗蜜多。须菩提。若菩萨摩诃萨能如是于色不生着。受想行识不生着。眼触乃至意触为缘所生诸受不生着。地界乃至识界不生着。布施持戒忍辱精进禅定智慧诸波罗蜜多不生着。三十七菩提分法及佛十力四无所畏十八不共诸功德聚皆不生着。须陀洹斯陀含阿那含阿罗汉缘觉如来乃至一切智亦不生着。何以故。一切法无缚无解出过诸着。是故得名离着无碍一切智。须菩提。诸菩萨摩诃萨应如是行般若波罗蜜多。须菩提白佛言。希有世尊。般若波罗蜜多是甚深法。若说不增不说亦不减。说亦不减不说亦不增

佛赞须菩提言。善哉善哉。须菩提。如是如是。若如来应供正等正觉。尽其寿量称赞虚空。而彼虚空赞亦不增不赞亦不减。赞亦不减不赞亦不增。譬如称赞幻所化人。赞亦不喜不赞亦不恚。赞亦不增不赞亦不减。须菩提。诸法性如是离说非说不增不减。须菩提白佛言。世尊。般若波罗蜜多广大甚深。菩萨摩诃萨所行甚难。譬如虚空无动无转无相无作。般若波罗蜜多亦复如是。世尊。菩萨为众生故。被大铠甲而作庄严。何以故。菩萨为欲成就阿耨多罗三藐三菩提果度诸众生。是故修学般若波罗蜜多。世尊。如人被甲与彼虚空共相斗战。而彼虚空本来平等。法界平等众生平等。而诸菩萨虽复勇猛成就精进波罗蜜多。毕竟不能战空得胜。是故诸菩萨摩诃萨难行般若波罗蜜多

尔时帝释天主白尊者须菩提言。若如是者即般若波罗蜜多行而无所生。云何相应。须菩提言。憍尸迦。如虚空行所生。般若波罗蜜多行亦如是生。憍尸迦。诸菩萨摩诃萨欲学般若波罗蜜多行者当如虚空行。如是学者是即相应

尔时会中有一苾刍闻是法已从座而起。合掌向佛作如是言。般若波罗蜜多。无少法可生无少法可灭是故我今敬礼般若波罗蜜多

佛说佛母出生三法藏般若波罗蜜多经卷第八佛说佛母出生三法藏般若波罗蜜多经卷第九

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    清净品第八之二

尔时帝释天主白佛言。世尊。若有人受持此般若波罗蜜多法门者。我当守护其人及此法门。时尊者须菩提。谓帝释天主言。憍尸迦。汝见有法可守护耶。帝释天主言。不也须菩提。时须菩提言。天主。若菩萨摩诃萨。如所说般若波罗蜜多。如理而行随顺相应者。是即名为真实守护。若时过离般若波罗蜜多。于一切处即为人及非人伺得其便。复次憍尸迦。若菩萨摩诃萨。为欲守护般若波罗蜜多者。当如守护虚空。是为行般若波罗蜜多。憍尸迦。于汝意云何。彼呼声响能守护耶。帝释天主言。尊者须菩提。彼呼声响不能守护。须菩提言。如是如是。憍尸迦。当知一切法如声响。若如是知即于诸法无所观。无所示无所生无所得。是为菩萨摩诃萨行般若波罗蜜多

尔时三千大千世界一一界中。从四大王天。乃至大梵王天。彼彼所有娑婆界主大梵天王。帝释天主。并余天子。以佛威神加持力故。即时各各来诣佛所。头面着地礼世尊足。右绕三匝退住一面

是时世尊以威神力。令彼一切梵王帝释及诸梵众。并余四天王天诸天子等。各各得见千佛世尊。于诸方处一一如应宣说般若波罗蜜多法门。如是名句文皆同一说相。所有般若波罗蜜多。法门品类章句皆悉无异。彼受法者皆名须菩提。其请问者亦如帝释天主

尔时佛告彼诸梵王帝释天主等言。汝等于此地方今见诸佛。如是宣说般若波罗蜜多法门。所有慈氏菩萨摩诃萨。当成阿耨多罗三藐三菩提果。已于此地方亦复如是宣说般若波罗蜜多法门

    叹胜品第九

尔时尊者须菩提白佛言。世尊。般若波罗蜜多甚深微妙。于其名中毕竟不可得非彼语言。而能宣说如般若波罗蜜多。名不可得故。般若波罗蜜多法亦不可得。而此般若波罗蜜多。名字及法无二差别。皆无所生俱不可得。世尊。如佛所言。慈氏菩萨摩诃萨。当成阿耨多罗三藐三菩提果。已于此地方亦复如是。宣说般若波罗蜜多者。此法甚深彼云何说

尔时佛告尊者须菩提言。彼慈氏菩萨摩诃萨。当成阿耨多罗三藐三菩提果。已于此地方。说般若波罗蜜多时。不说色若常若无常若解若缚。不说受想行识若常若无常若解若缚说色受想行识毕竟清净。须菩提。彼菩萨以如是名句文。如实宣说般若波罗蜜多

尔时须菩提白佛言。世尊。般若波罗蜜多清净。佛言。须菩提。色清净故般若波罗蜜多清净。受想行识清净故。般若波罗蜜多清净。色不生不灭。不着烦恼不出世间故清净。般若波罗蜜多亦如是清净。受想行识不生不灭。不着烦恼不出世间故清净。般若波罗蜜多亦如是清净。色无染故般若波罗蜜多清净。受想行识无染故。般若波罗蜜多清净。一切法无染故。般若波罗蜜多清净。虚空清净故。般若波罗蜜多清净。一切法如虚空如声响故清净。般若波罗蜜多亦如是清净

尔时尊者须菩提白佛言。世尊。若有善男子善女人。于此般若波罗蜜多法门。发清净心听受读诵为人演说。当知是人得大善利。眼耳鼻舌身根清净。离诸病苦一切恶毒不能伤害。寿命增长无中夭难。常得千天子众或时导前或时从后。于一切处密为守护。世尊。诸持法者善男子善女人。应于白月八日十四日十五日。清净身语心业。于诸方处读诵此般若波罗蜜多法门或为他人解说其义。当知是善男子善女人得福甚多

佛告须菩提言。如是如是。如汝所说。若有善男子善女人。于一切处读诵解说此般若波罗蜜多法门时。常有千天子众往彼持法人所。为欲听受正法大利益故密护其人。何以故。此般若波罗蜜多法门。于天上人间为最胜宝。以是缘故善男子善女人。能受持者得福甚多

复次须菩提。若有受持读诵解说此甚深般若波罗蜜多法门者。于现世中得大善利获最胜宝。天上人间共所尊重。何以故。此般若波罗蜜多法门。能与众生广大利乐。须菩提。彼一切法不生不灭不染不净。无取无舍无所有无所得。般若波罗蜜多。亦不生不灭不染不净。无取无舍无所有无所得。何以故。色无染故般若波罗蜜多亦无染。受想行识无染故。般若波罗蜜多亦无染。菩萨摩诃萨。若于诸法不生分别。是为行般若波罗蜜多。须菩提般若波罗蜜多。非内非外不出不入。无法可示无法可观

尔时三千大千世界。所来集会一切梵王帝释。及诸天子。各各踊跃欢喜咸作是言。我等今日于阎浮提中。得闻世尊第二。转此甚深般若波罗蜜多法轮。彼当来世。慈氏菩萨成正觉已转此法轮时。愿我亦复得闻此法

佛告须菩提言。法非初转非第二转当知诸法毕竟无所有而不可转。须菩提。菩萨摩诃萨。修学般若波罗蜜多亦复如是

尔时尊者须菩提白佛言。世尊。大波罗蜜多。是般若波罗蜜多。所以者何。彼一切法离诸着故。而诸菩萨摩诃萨修一切法。乃至证得阿耨多罗三藐三菩提果亦无法可证。虽转法轮亦无法可示。无法可得。以无证无示无所得故。一切法空毕竟离着。由离着故即一切法无还无转。何以故。世尊。一切法离性。是故无还无转

佛告尊者须菩提言。如是如是。如汝所说。须菩提。彼空解脱门无还无转。无相无愿解脱门亦无还无转。须菩提。虽于诸法如是宣说。而诸法性毕竟寂灭。无说无示无闻无得无法可证。以无所证故亦无证者。是故诸法无灭无非灭

尔时尊者须菩提白佛言。世尊。无边波罗蜜多。是般若波罗蜜多虚空无边故。无等等波罗蜜多。是般若波罗蜜多一切法不可得故。离波罗蜜多。是般若波罗蜜多毕竟空故。不可破波罗蜜多。是般若波罗蜜多。一切法性不可得故。无句波罗蜜多。是般若波罗蜜多。诸法无名无相故。无性波罗蜜多。是般若波罗蜜多。诸法无来故。无言波罗蜜多。是般若波罗蜜多。诸法无分别故。无来波罗蜜多。是般若波罗蜜多。诸蕴不可得故。无去波罗蜜多。是般若波罗蜜多。诸法无来故。无集波罗蜜多。是般若波罗蜜多。诸法无取故。无尽波罗蜜多。是般若波罗蜜多。诸法无尽相故。无生波罗蜜多。是般若波罗蜜多。诸法无著故。无作波罗蜜多。是般若波罗蜜多。作者不可得故。无知者波罗蜜多。是般若波罗蜜多。诸法无主宰故。无所至波罗蜜多。是般若波罗蜜多。无退没故。不灭波罗蜜多。是般若波罗蜜多前后中际不可得故。梦幻影响阳焰等波罗蜜多。是般若波罗蜜多。诸法不生故。无烦恼波罗蜜多。是般若波罗蜜多。贪嗔痴等性清净故。无出世波罗蜜多。是般若波罗蜜多。所依止不可得故。无染污波罗蜜多。是般若波罗蜜多虚空清净故。无戏论波罗蜜多。是般若波罗蜜多。诸法平等故。无念波罗蜜多。是般若波罗蜜多。诸念不生故。无动波罗蜜多。是般若波罗蜜多。诸法性常住故。离欲波罗蜜多。是般若波罗蜜多。诸法性真实故。无起波罗蜜多。是般若波罗蜜多。诸法无疑故。寂静波罗蜜多。是般若波罗蜜多。诸法相不可得故。无过失波罗蜜多。是般若波罗蜜多。具足诸功德故。无众生波罗蜜多。是般若波罗蜜多。众生际不可得故。无断波罗蜜多。是般若波罗蜜多。诸法不起故。无二边波罗蜜多。是般若波罗蜜多。诸法离着故。无异波罗蜜多。是般若波罗蜜多。诸法无和合故。无著波罗蜜多。是般若波罗蜜多。不分别声闻缘觉地故。不分别波罗蜜多。是般若波罗蜜多。分别平等故。无量波罗蜜多。是般若波罗蜜多。量法平等故。如虚空波罗蜜多。是般若波罗蜜多。一切法无障碍故。无常波罗蜜多。是般若波罗蜜多。一切法有为故。苦波罗蜜多。是般若波罗蜜多。虚空平等故。空波罗蜜多。是般若波罗蜜多。一切法不可得故。无我波罗蜜多。是般若波罗蜜多。我不可得故。无相波罗蜜多。是般若波罗蜜多。一切法不可转故。空性波罗蜜多。是般若波罗蜜多。毕竟无边故。念处正勤神足根力觉道波罗蜜多。是般若波罗蜜多。三十七菩提分法不可得故。空无相无愿波罗蜜多。是般若波罗蜜多。三解脱门不可得故。内有色观外色等波罗蜜多。是般若波罗蜜多。八解脱不可得故。初禅定等波罗蜜多。是般若波罗蜜多。九先行法不可得故。苦集灭道波罗蜜多。是般若波罗蜜多。四圣谛法不可得故。布施等波罗蜜多。是般若波罗蜜多。十波罗蜜多不可得故。十力波罗蜜多。是般若波罗蜜多。不可破坏故。四无所畏波罗蜜多。是般若波罗蜜多。不怯不惧不退不没故。离系波罗蜜多。是般若波罗蜜多。一切智智无著无碍故。如来无量功德波罗蜜多。是般若波罗蜜多。过诸数法故。如来真如波罗蜜多。是般若波罗蜜多。一切法真如平等故。自然智波罗蜜多。是般若波罗蜜多。一切法自性平等故。一切智智波罗蜜多。是般若波罗蜜多。一切法性一切法相。不可得不可知故

    赞持品第十之一

尔时帝释天主作是念。诸善男子善女人。若得暂闻此般若波罗蜜多法门者。是人于诸佛所已种善根。何况有人于此般若波罗蜜多法门。能受持读诵记念思惟为人演说。如所说学如所说行如理相应。是人已于无量无数佛世尊所。恭敬供养种诸善根。又若有人。闻此般若波罗蜜多法门。不惊不怖不退不没者。是人久于过去如来应供正等正觉所。已曾听受此甚深法请问其义。于是法中如理修习。是故今闻不生惊怖。如所说学如所说行如理相应

尔时尊者舍利子。知帝释天主心所念已即白佛言。世尊。若有人闻此甚深般若波罗蜜多法门。发信解心尊重恭敬。受持读诵为人演说。如所说学如所说行如理相应者。是人应如不退转菩萨摩诃萨功德无异。何以故。此甚深般若波罗蜜多法门。若人以少善根不能得闻。又若于先佛所不曾修习者。是故今时即不能生清净信解。又复世尊。若有人闻此甚深般若波罗蜜多法门。生违背毁谤者。当知是人于先佛所曾闻是法。尔时已生违背毁谤。何以故。是人虽复以少善根。先得闻此甚深般若波罗蜜多法门。而为懈怠所覆。不起精进无信无忍。于甚深法不生爱乐。由不乐故不能解了。以其不了又复不能请问诸佛及佛弟子。由是缘故今闻此法起违谤者。当知往昔已生违谤

尔时帝释天主白佛言。世尊。若人敬礼般若波罗蜜多者。是即敬礼诸佛一切智智

佛告帝释天主言。如是如是。憍尸迦。若人敬礼般若波罗蜜多。是即敬礼诸佛一切智智。何以故。从一切智智。生般若波罗蜜多。般若波罗蜜多复生一切智智。诸菩萨摩诃萨行般若波罗蜜多时。当如是住般若波罗蜜多如是习般若波罗蜜多

尔时帝释天主复白佛言。世尊。菩萨摩诃萨行般若波罗蜜多时。云何得名如是住如是习。佛赞帝释天主言。善哉善哉。憍尸迦。汝今善问如来应供正等正觉此甚深义。然汝能问。皆是如来神力护念。憍尸迦。若菩萨摩诃萨行般若波罗蜜多时。不住色不住色相。菩萨若不住色不住色相。是为习色。不住受想行识不住识相。菩萨若不住识不住识相是为习识。憍尸迦。菩萨若不习色不习色相。是为不住色。若不习受想行识不习识相。是为不住识。憍尸迦。菩萨摩诃萨如是行般若波罗蜜多时。得名如是住如是习

尔时尊者舍利子白佛言。世尊。般若波罗蜜多最极甚深。般若波罗蜜多不能得其边际源底。般若波罗蜜多广大无量。佛言。舍利子。如是如是。若菩萨摩诃萨行般若波罗蜜多时。不住色甚深。不住色相甚深。菩萨若不住色甚深。不住色相甚深。是为习色甚深。不住受想行识甚深。不住识相甚深。菩萨若不住识甚深。不住识相甚深。是为习识甚深。舍利子。菩萨若不习色甚深。不习色相甚深。是为不住色甚深。若不习受想行识甚深。不习识相甚深。是为不住识甚深

尔时尊者舍利子白佛言。世尊。此甚深般若波罗蜜多法门。应为住不退转已得授记诸菩萨摩诃萨如理宣说。何以故。彼诸菩萨若闻所说。不疑不悔离诸障碍。帝释天主即白尊者舍利子言。如尊者所说。其事如是。设复为彼未得授记菩萨说者当有何咎。尊者舍利子言。憍尸迦。若为未授记菩萨说者而亦无咎。何以故。彼菩萨虽未授记。若得闻此般若波罗蜜多法门。随喜信受瞻礼恭敬。不惊不怖不退不没。当知是菩萨久已安住大乘法中成熟善根。不久当于一二三如来应供正等正觉所得授阿耨多罗三藐三菩提记。憍尸迦。彼菩萨虽于现在佛世尊所未得授记。未来世中决定得见诸佛如来应供正等正觉。瞻礼供养得授阿耨多罗三藐三菩提记修诸善法。乃至证得阿耨多罗三藐三菩提果

尔时尊者舍利子白佛言。世尊。若菩萨暂得闻此般若波罗蜜多法门瞻礼信受者。尚说此菩萨久已安住大乘法中成熟善根。何况有能于此法门读诵思惟为人演说如理修行者。其事云何

尔时佛告尊者舍利子言。如是如是。如汝所说。若菩萨暂得闻此般若波罗蜜多法门瞻礼信受者。我说是菩萨久已安住大乘法中成熟善根。况复有能于此法中读诵思惟为人演说如理修行者。决定速能成就阿耨多罗三藐三菩提果

尔时尊者舍利子白佛言。世尊。我今乐说譬喻以明其义。佛言。舍利子。随汝意说。舍利子言。世尊。譬如有住菩萨乘者勤求菩提。或时梦已处菩提座。世尊。彼菩萨得是梦已。当知渐近阿耨多罗三藐三菩提果。诸求菩提者亦复如是。若得闻此般若波罗蜜多法门随喜信受。当知是人久已安住大乘法中成熟善根。决定当得授菩提记。何况有能读诵思惟为人演说如理修行者。当知是人决定速证阿耨多罗三藐三菩提果。何以故。世尊。有诸众生以业障故背如实智。是故远离此般若波罗蜜多法门。不能发生清净信解。由是不能成熟善根。有诸众生久于此法。听受信解安住实际成熟善根。世尊。当知是人住如实际不复退转。渐近阿耨多罗三藐三菩提果

世尊。又如有人欲过百由旬乃至五百由旬旷野险路。于其路中若进若退怖畏疑惑是人渐行欲出险路。忽见有诸守牛羊人。即知此去城邑不远。是人即时心得安隐。无复起诸盗贼等怖。何以故。是人得见守牛羊者。即知渐近城邑聚落。世尊。求菩提者亦复如是。若得闻此般若波罗蜜多法门。当知渐近阿耨多罗三藐三菩提果。不久得授大菩提记。不复堕于声闻缘觉之地。何以故。得闻般若波罗蜜多法门瞻礼信受为前相故。是故诸菩萨摩诃萨。应当于此般若波罗蜜多法门。尊重恭敬如理修行

佛说佛母出生三法藏般若波罗蜜多经卷第九佛说佛母出生三法藏般若波罗蜜多经卷第十

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    赞持品第十之二

尔时世尊赞尊者舍利子言。善哉善哉。舍利子。如是如是。如汝所说。善引譬喻。汝今以佛神力。复说譬喻而明此义。舍利子白佛言。世尊。又如有人欲见大海渐次而行。若见有树或见树相。若见有山或见山相。当知是人去海尚远。又复前行。若不见树及树相。不见山及山相。当知是人去海渐近。何以故。大海深远广阔无涯。近大海边无有一切山树等相。是人虽未至海。以不见彼山树相故。即知渐次近于大海。世尊。菩萨摩诃萨亦复如是。若得闻此般若波罗蜜多法门瞻礼供养者。是人虽于现在如来应供正等正觉所未得授记。当知渐近阿耨多罗三藐三菩提而将授记。何以故。以闻此般若波罗蜜多法门为前相故。世尊。又如世间有种种树。于其春时枝叶繁茂青润可爱。阎浮提人见是相已皆生欢喜。即作是念。此树不久开华结实。何以故。彼开敷相先已现故。世尊。菩萨摩诃萨亦复如是。若得闻此般若波罗蜜多法门瞻礼供养者。当知是菩萨久已成熟最胜善根。以其宿世善因缘故。今于此般若波罗蜜多正法会中亲所听受。得见诸佛及众贤圣。复得诸佛贤圣以欢喜心作如是念。过去诸菩萨将得授记亦复如是。闻此正法为前相故。今此菩萨当知渐近阿耨多罗三藐三菩提不久得记。何以故。前相现故。又如世间女人怀妊。日月将满身力疲困心识动乱。饮食减少坐卧懈怠。凡诸所欲而不勤行。苦恼悉生厌本所习。见是相已。当知此人将产不久。何以故。前相现故。世尊。菩萨摩诃萨亦复如是。若得闻此般若波罗蜜多法门瞻礼供养者。当知是菩萨久已成熟善根。渐近阿耨多罗三藐三菩提不久得记。何以故。以闻正法为前相故。尔时世尊复赞尊者舍利子言。善哉善哉。舍利子。汝所乐说皆是如来神力所护

是时尊者须菩提白佛言。希有世尊。如来应供正等正觉。善所护念诸菩萨众。能善宣说诸菩萨法。佛告须菩提言。诸菩萨摩诃萨。于长夜中多所饶益一切众生。以善方便与其利乐。悲愍世间为救度故。而诸菩萨勤求阿耨多罗三藐三菩提果。得证果已。欲为一切众生如其所应宣说法要。是故诸佛共所护念

须菩提白佛言。世尊。诸菩萨摩诃萨行般若波罗蜜多时。当云何观即得般若波罗蜜多具足

佛言。须菩提。若菩萨摩诃萨行般若波罗蜜多时。不见色法有所增相。不见受想行识有所增相。是行般若波罗蜜多。不见色法有所减相。不见受想行识有所减相。是行般若波罗蜜多。乃至不见是法非法。是行般若波罗蜜多。须菩提。菩萨摩诃萨行般若波罗蜜多时。若如是观即得般若波罗蜜多具足

须菩提白佛言。世尊。如佛所说般若波罗蜜多不可思议。佛言。须菩提。色受想行识不可思议。若菩萨不分别色不可思议。是行般若波罗蜜多。不分别受想行识不可思议。是行般若波罗蜜多

尔时尊者舍利子白佛言。世尊。般若波罗蜜多法门最上甚深。何人当能如实信解

佛告舍利子言。若久行菩萨道者。闻此般若波罗蜜多法门即能信解。舍利子白佛言。世尊。何等是久行菩萨道者。佛言。舍利子。若菩萨摩诃萨。不分别如来十力四无所畏。不分别如来诸功德法。乃至不分别一切智。若如是不分别诸法。是为久行菩萨道者。何以故。所有如来十力四无所畏不可思议。诸功德法乃至一切智皆不可思议。是故菩萨于一切法无所分别。由如是故。菩萨摩诃萨于法无所行而行。是行般若波罗蜜多

尔时尊者须菩提白佛言。希有世尊。此甚深般若波罗蜜多法门。是大宝聚最上无染般若波罗蜜多。犹如虚空自性清净。世尊。有诸善男子善女人。于此般若波罗蜜多法门。受持读诵记念思惟。乃至为人演说者。云何多难事起而为障碍。佛告尊者须菩提言。如是如是。如汝所说。善男子善女人。于此般若波罗蜜多法门。受持读诵记念思惟。乃至为人说其义时。多难事起而为障碍。须菩提。汝今当知。难事起时是其恶魔作诸魔障。是故善男子善女人。诸有受持读诵乃至为人演说者。应当速疾如理所作

又复有诸善男子善女人。若欲自书。若使人书此般若波罗蜜多法门者。当于一月乃至一年速疾书成。何以故。此般若波罗蜜多大法宝中。多有怨贼常欲侵害

复次尊者须菩提白佛言。世尊。诸有善男子善女人。受持读诵乃至书写此般若波罗蜜多法门时。若诸魔众伺求其便欲生破坏。当于尔时作何远离

佛告须菩提。汝今当知。若有人受持读诵乃至书写此法门时。但当志心如理所作。彼诸恶魔虽复长时以坏法心于此法门欲作断灭。及持法者欲生破坏。纵经多劫彼终不能伺得其便

尔时尊者舍利子白佛言。世尊。诸善男子善女人。受持读诵此正法时。若得远离诸魔业者。是人即能读诵通利。乃至书写皆无障碍。世尊。如佛所说彼诸恶魔伺求其便不能得者。当以何力能致如是

佛告尊者舍利子言。汝今当知。皆是如来应供正等正觉威神之力。加持护念制伏诸魔不得其便。是故能令诸持法者读诵通利。乃至如所说学如所说行。如理相应皆悉无碍。何以故。今此甚深正法摄诸法相即诸法性。所有十方无量阿僧祇世界。现住说法诸佛如来。皆同宣说此般若波罗蜜多法门。是故诸佛如来。以其神通威力共所护念。诸持法者使令受持读诵通利。乃至书写供养。如所说学如所说行。如理相应皆得无碍。舍利子。诸有持法善男子善女人。若为诸佛所护念者。我不见有诸恶魔众而能为害

是时尊者舍利子白佛言。世尊。若诸菩萨摩诃萨。于此般若波罗蜜多法门。受持读诵书写供养。乃至如所说学如所说行如理相应。而能远离诸魔障者。亦是如来神通威力所护念耶

佛告尊者舍利子言。如是如是。诸菩萨摩诃萨。已得一切如来神通威力加持护念。是故于此甚深般若波罗蜜多法门。而能受持读诵通利。乃至如所说学如所说行如理相应。悉得远离一切魔障。舍利子当知。是菩萨得诸如来神力加持。是诸如来所知所念。为诸如来共所观察

复次舍利子。若菩萨摩诃萨于此般若波罗蜜多法门。能受持读诵记念思惟。广为他人解释其义。乃至如所说学如所说行如理相应者。当知是菩萨摩诃萨已近阿耨多罗三藐三菩提。不久得成阿耨多罗三藐三菩提果

又舍利子。若人于此般若波罗蜜多法门。但能受持读诵者。是人得福虽多。不如有人于此法门如所说学。如所说行如理相应。舍利子当知。是人得诸如来神力加持。是诸如来所知所念。为诸如来共所观察。是人现世有大威德有大名称。当来决定获大果报。何以故。此般若波罗蜜多是第一义胜妙法门。与一切法如理相应。普摄众生住真实际

复次舍利子。此般若波罗蜜多相应法门。如来应供正等正觉以威神力加持护念。后末世中先于南方广大流布。从是南方流布西方。复从西方流布北方。如是展转流布诸方。舍利子。佛涅盘后法欲灭时。为欲令诸善男子善女人于此般若波罗蜜多法门。受持读诵记念思惟。转为他人解释其义。乃至书写供养获大利益是故如来加持护念使令流布

又舍利子。若善男子善女人有能受持此正法者。当知是人得诸如来神力加持。是诸如来所知所念。为诸如来共所观察。舍利子白佛言。世尊。此般若波罗蜜多法门最上甚深。于后末世云何北方亦流布耶

佛言。舍利子。后末世中此法亦当流布北方。而彼方处有修菩萨行者诸善男子善女人。闻此甚深般若波罗蜜多法门。而能受持读诵记念思惟书写供养。舍利子白佛言。世尊。而彼北方有几所人。当能受持此甚深般若波罗蜜多法门。有几所人能读诵通利。如所说学如所说行如理相应

佛言。舍利子。而彼北方虽多有诸修菩萨行者善男子善女人。能受持此甚深般若波罗蜜多法门。少能于中读诵通利如所说学如所说行如理相应者

又舍利子。彼方若有善男子善女人。闻此般若波罗蜜多法门。不惊不怖不退不没者。当知是人久住大乘修菩萨行已曾于其过去如来应供正等正觉所请问其义。是人久已修习具足菩萨道法。为欲利乐诸众生故广修诸行。勤求阿耨多罗三藐三菩提果。何以故。我今已为是善男子善女人。宣说一切智相应般若波罗蜜多法门。是人转身亦复乐闻此般若波罗蜜多法门欢喜信受。勤修阿耨多罗三藐三菩提法。善住三摩呬多相应胜行。乃至诸魔不能坏其阿耨多罗三藐三菩提心。况复一切人非人等能破坏耶。何以故。是人坚固勇猛不退转于阿耨多罗三藐三菩提心。又复是人闻此般若波罗蜜多法门。心大欢喜心得清净。普令众生种诸善根如理修行。成就阿耨多罗三藐三菩提果。何以故。是善男子善女人能于佛前作如是言我当以此法门为无量百千万亿俱胝那庾多众生。如理表示如实教授。如所利益如理生喜。如实觉了无所退转。普令安住阿耨多罗三藐三菩提果。舍利子。是善男子善女人住菩萨乘广大利益我观其心则生随喜我亦以此甚深正法。示教利喜无量百千万亿俱胝那庾多众生。令住阿耨多罗三藐三菩提果。如是善男子善女人广大信解爱乐大乘。愿生诸佛刹中。现在佛前闻说妙法。相续得闻说此甚深般若波罗蜜多法门。于彼佛刹亦复以此甚深正法。示教利喜无量百千万亿俱胝那庾多众生。令住阿耨多罗三藐三菩提果

尔时尊者舍利子白佛言。希有世尊。如来应供正等正觉。于过去未来现在一切法中。无有少法不见不闻不知不解。一切众生种种行相皆悉了知。诸菩萨法无不通达。乃至未来世中有诸菩萨摩诃萨众。为菩提故发大精进。勤求此般若波罗蜜多。得是法门受持读诵。如所说学如所说行。如理相应者如来悉知。有诸菩萨摩诃萨众。于此般若波罗蜜多法门。不求而得者如来亦知

佛告尊者舍利子言。如是如是。如汝所说。舍利子。如来应供正等正觉。于过去未来现在一切法中。无有少法不见不闻不知不解。乃至未来世中诸菩萨摩诃萨。于此般若波罗蜜多法门。有求而得有不求而得者如来悉知。何以故。如来应供正等正觉。于诸菩萨过去善根及所乐欲乃至菩萨所行道法皆悉了知

复次舍利子白佛言。世尊。余诸深经与此般若波罗蜜多相应者。亦不勤求而自得耶

佛言。如是如是。舍利子。所有余诸深经与此般若波罗蜜多相应者。亦有不求而自获得

舍利子白佛言。世尊。所有余诸深经与六波罗蜜多相应者。未来世中善男子善女人。亦不勤求而自得耶

佛言。舍利子。所有余诸深经与六波罗蜜多相应者。未来世中亦有不求而自获得。何以故。法本如是。诸修菩萨道者善男子善女人。常当以法示教利喜无量百千万亿俱胝那庾多众生。令住阿耨多罗三藐三菩提果。亦自于中如理修学。是人转身于余深经与六波罗蜜多无所得相应。与一切法自性相应者。是人亦复不求自得

佛说佛母出生三法藏般若波罗蜜多经卷第十佛说佛母出生三法藏般若波罗蜜多经卷第十一

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    恶者障法品第十一之一

尔时尊者须菩提白佛言。世尊。佛先已说受持读诵般若波罗蜜多法者。诸善男子善女人所有功德。而彼善男子善女人受持读诵此法门时。将无恶魔为难事耶

佛告尊者须菩提言。如是如是。甚多须菩提。有诸恶魔而为难事。于一切时伺求其便。须菩提复白佛言。如佛所说诸难事者其相云何

佛告须菩提。若有住菩萨乘修习此般若波罗蜜多法者。欲为他人说此法时。不即为说及说不止。应当觉知是为魔事。又复若说法者。于说法时生其我慢贡高心者。应当觉知是为魔事。若有人书持读诵此法门时。生轻慢心而戏笑者。应当觉知是为魔事。若有诸持法者心生散乱。应当觉知是为魔事。若有诸持法者互相非说。应当觉知是为魔事。若有诸持法者。记念不明多所忘失。应当觉知是为魔事。若有诸持法者。互相障碍不能和合。于此法门不生敬信。应当觉知是为魔事。若人书持读诵此法门时。于自诸根不能调伏。应当觉知是为魔事。若有诸听法者忽作是念。我于此般若波罗蜜多法中。不得其味无所解了。弃舍此法从座而起。应当觉知是为魔事。又听法者若作是念。此般若波罗蜜多法中。不为我等说授记事。我不能生清净信解。念已弃舍从座而起。应当觉知是为魔事。又听法者若作是念。此般若波罗蜜多法中不说我名。不说我等所住城邑聚落方处。及不说我所生族姓父母名字。以是因缘不能听受此般若波罗蜜多法门。我当弃舍。随所起念即于若干劫数有所退堕。后复以其胜因缘故。于此般若波罗蜜多法门还得修习。何以故。诸菩萨摩诃萨若不听受此般若波罗蜜多法门。即不能成就世间出世间法。是故须菩提。若起退失心者。应当觉知是为魔事

复次须菩提。若有住菩萨乘者。不能于此般若波罗蜜多法中求一切智智。而返于彼声闻缘觉法中。修习趣求一切智智者。应当觉知是为魔事

复次须菩提。若有人欲学欲成就世间出世间法。而不学般若波罗蜜多法门。返于声闻缘觉法中而生趣求。须菩提。若不学般若波罗蜜多法者。即不能成就世间出世间法。是人起颠倒慧。于此般若波罗蜜多法中。不能修习如实了知。弃舍根本取其枝叶。须菩提。如世有人饥行求食。弃舍其主而返于彼作务人所求索饮食。须菩提。未来世中所有退失菩萨法者。诸善男子善女人亦复如是。弃舍般若波罗蜜多一切智智根本法门。而返于彼声闻缘觉法中取其枝叶。须菩提。此因缘者。应当觉知是为魔事。何以故。是人少智少慧。谓此般若波罗蜜多法门。不能至彼一切智智。以是因缘而生弃舍。返谓声闻缘觉法门。即能成就一切智智。是故于中取其枝叶。须菩提。菩萨摩诃萨应当觉知。如是等相觉已远离。不应于中爱乐修学。如是学者非所相应。若有爱乐声闻缘觉法者即如是学。云何彼等如是学耶。须菩提。所谓声闻法中而但修习调伏我相。证得我空寂静涅盘。自谓已得究竟果法。不能于彼最上法中精进修行。亦复不能广为众生作大利益。是故菩萨摩诃萨不应如是学。云何名为菩萨学耶。须菩提。若菩萨摩诃萨所行所学。皆自安住如实法已。广修一切相应善根。普摄世间无量无边一切众生。悉令安住真如实际。一一证得最上涅盘。是即名为菩萨学法

复次须菩提。譬如有人欲观其象。虽复得见不能真实观其形相是人即自返寻象迹观取象相。须菩提。于汝意云何。是人为智不。须菩提言。不也世尊。佛告须菩提。未来世中所有退失菩萨法者亦复如是是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门虽复修习。不能于中请问其义。不能如实了知胜行。于此法门生弃舍心。以弃舍般若波罗蜜多故。即不能取证阿耨多罗三藐三菩提果。是故返于声闻缘觉法中取证涅盘。自谓已得究竟果法。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。譬如世间诸求宝人。诣彼大海欲求珍宝。到已不能于大海中采取其宝。而返于彼牛迹水中求诸珍宝。自谓与其海水相等。须菩提。于汝意云何。是人为智不。须菩提言。不也世尊。佛告须菩提。未来世中所有退失菩萨法者亦复如是。是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门虽复修习。不能于中请问其义。不能如实了知胜行。于此法门生弃舍心。而返于彼声闻缘觉法中。爱乐趣求调伏我相。取证我空寂静涅盘。所谓须陀洹斯陀含阿那含阿罗汉及缘觉果。于诸果中见如是法证如是理。得诸漏尽心善解脱。于彼果中而得离系。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。菩萨摩诃萨即不生如是心。何以故。而诸菩萨已得安住大乘法中。被精进铠作大庄严。长时修习诸波罗蜜多相应法门。悲愍世间广为众生作大利益。是故须菩提。所有心不调柔起颠倒慧。于此甚深般若波罗蜜多法门不能修习。不觉不知生弃舍心。不能安住菩萨法中。不与诸波罗蜜多胜行相应。但乐声闻缘觉法者。当知此等皆是善根未成熟者

复次须菩提。又如世间有巧业者。本欲造立如天帝释殊胜宫殿。而返度量日月宫殿大小分量。须菩提。于汝意云何。彼日月宫殿。能胜帝释妙宫殿耶。须菩提言。不也世尊。佛告须菩提。未来世中所有退失菩萨法者亦复如是。是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门。虽复听受修习。不能于中请问其义。不能如实了知胜行。由不了故于此法门生弃舍心。而返于彼声闻缘觉法中。爱乐趣求调伏我相。取证我空寂静涅盘。自谓已得究竟果法。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。又如有人乐欲见彼转轮圣王。虽复得见不能真实观其色相威神福德。而返观彼诸小王等所有色相。自谓与彼转轮圣王等无有异。须菩提。于汝意云何。彼转轮圣王色相威德。与诸小王为相等不。须菩提言。不也世尊。佛告须菩提。未来世中。所有退失菩萨法者亦复如是。是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门。虽复听受修习。不能于中请问其义。不能如实了知胜行。由不了故于此法门生弃舍心。而返于彼声闻缘觉法中爱乐趣求。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。如来为诸菩萨摩诃萨故。而以种种善巧方便宣说甚深般若波罗蜜多法门。令诸菩萨于中修学即能成就阿耨多罗三藐三菩提果。须菩提。是故如来以此般若波罗蜜多法门。为诸菩萨摩诃萨如理表示如实教授。如所利益如理生喜。趣入安住胜义法门。令诸菩萨摩诃萨不退转于阿耨多罗三藐三菩提

复次须菩提。如是住不退转菩萨摩诃萨。于此大乘法中已安住者。设复弃舍而返于彼声闻缘觉下劣乘中起趣求心。于汝意云何。是人为智不。须菩提言。不也世尊。佛告须菩提。此因缘者。应当觉知是为魔事

复次须菩提。又如有人饥渴所逼周行求食。见彼百味精妙饮食。生弃舍心而不能取。返取于彼六十日饭食已爱乐。须菩提。于汝意云何。是人为智不。须菩提言。不也世尊。佛告须菩提。未来世中所有退失菩萨法者亦复如是。是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门。虽复听受修习。不能于中请问其义。不能如实了知胜行。由不了故于此法门生弃舍心。而返于彼声闻缘觉法中爱乐趣求。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。又如有人见彼无价摩尼珠宝。即不能取而返取其水精之宝。自谓与彼摩尼珠宝等无有异。须菩提。于汝意云何。是人为智不。须菩提言。不也世尊。佛告须菩提。未来世中所有退失菩萨法者亦复如是。是人先已安住菩萨乘中。于此甚深般若波罗蜜多法门。虽复听受修习。不能于中请问其义。不能如实了知胜行。由不了故于此法门生弃舍心。而返于彼声闻缘觉法中求一切智。自谓与彼菩萨法门等无有异。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。若有人书写受持读诵演说此般若波罗蜜多法门时。若进若退其心散乱。一一当知皆是魔事

尔时尊者须菩提白佛言。世尊。般若波罗蜜多为可书写耶。佛言。不也须菩提。般若波罗蜜多非文字可得。所有文字但为显示此法门故。而般若波罗蜜多离文字相。毕竟于文字中求不可得。若有人作是言。我书文字即是书写般若波罗蜜多。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。若有人书持读诵此般若波罗蜜多法门时。心不专一起诸思念。所谓城邑聚落园林池沼。父母师长及诸亲友。自身他身若内若外。一切所有饮食衣服。卧具医药歌舞戏笑。苦乐忧喜爱非爱境乃至贪嗔痴等。如是种种起思念者。一一当知皆是恶魔作诸障难。使令行者心生散乱。不得于此般若波罗蜜多法门书持读诵。须菩提。此因缘者。应当觉知是为魔事。是故诸菩萨摩诃萨觉已远离。不令诸魔伺得其便

又复若人书持读诵此般若波罗蜜多法门时思念王事。以此因缘而为障难。是故不能于此法门书持读诵。应当觉知是为魔事

又复若人书持读诵此般若波罗蜜多法门时。筹计财宝资生等物。以此因缘而为障难。是故不能于此法门书持读诵。应当觉知是为魔事

又复若人书持读诵此般若波罗蜜多法门时。思念世间语言章句。以此因缘而为障难。是故不能于此法门书持读诵。应当觉知是为魔事

复次须菩提。若有人书持读诵此般若波罗蜜多法门时。有诸恶魔现苾刍相。来住其前作如是言。我有法门汝等当学。如是书写受持读诵如是修习。即能至彼一切智果。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。若有住菩萨乘者。乐欲通达菩萨摩诃萨善巧方便者。不能于其菩萨法中如实了知。而返于彼声闻缘觉法门起趣求心。是人知彼法中亦说空无相无愿。谓与菩萨法门等无有异。须菩提。若欲了知菩萨摩诃萨善巧方便最胜智者。应当于此甚深般若波罗蜜多法中如实趣求。若复于余声闻缘觉法门而修习者。应当觉知是为魔事

复次须菩提。此般若波罗蜜多法门。若听者乐闻说者懈倦。应当觉知是为魔事

又复若时说者乐说听者懈倦。应当觉知是为魔事

又复若时彼听法者。乐欲听受此般若波罗蜜多法门。听已书写读诵。而说法者不即为说。以戏论心说余经法。由此因缘不能和合。令听法者不得般若波罗蜜多书持读诵。应当觉知是为魔事

又复若时彼说法者心不懈退。乐欲宣说般若波罗蜜多法门。而听法者住于异方。以此因缘不能和合。应当觉知是为魔事

又复若时彼说法者少欲欢喜。离无义语忻乐说法而听法者身力疲懈心识惛重。以此因缘不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

又复若时彼听法者有信乐心欲闻此法。而说法者作诸留难不欲为说。以此因缘不能和合。令听法者不得般若波罗蜜多书持读诵。应当觉知是为魔事

又复若时彼听法者欲闻此法。而说法者诵习不利。听者不喜乐闻。以此因缘不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

又复若时彼说法者乐欲为说。而听法者以余缘故不乐听受。由此因缘不能和合。不得般若波罗蜜多书持读诵应当觉知是为魔事又复若时彼说法者乐欲说法。而听法者睡眠所覆惛重疲懈不能听受。以此因缘不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

又复若时彼听法者乐欲闻法。而说法者睡眠所覆惛重疲懈不乐说法。以此因缘不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

复次须菩提。若有人书持读诵此般若波罗蜜多法门时。或有人来作如是说。汝等当知地狱饿鬼傍生及阿修罗。彼彼趣中有种种苦。如是苦受应当远离。不如修习出诸趣类尽苦边际取证涅盘。须菩提。作此说者。应当觉知是为魔事

复次须菩提。若有人书持读诵此般若波罗蜜多法门时。或有人来作如是说。诸天界中有胜妙乐。所谓欲界有五欲乐。色界有禅定乐。无色界有寂灭定乐。如是诸乐皆悉有为无常。败坏诸相毕竟无实。三界悉空诸法无我。汝诸智者应当了知。不如取证须陀洹斯陀含阿那含阿罗汉果。得是果已不复更受后身。须菩提。作此说者即为障碍菩萨胜行。应当觉知是为魔事

复次须菩提。若说法者独止一处。心念徒众即作是言。若人有能随从我者。我即当与般若波罗蜜多。不随我者我不与其般若波罗蜜多。有诸善男子等。为求法故尊重正法。尔时各往随从法师。而彼法师忽于异时。心不乐欲为诸徒众说般若波罗蜜多。即当往诣饥馑枯涸虎狼虫兽盗贼怖畏诸险难处。时彼法师告徒众言。诸善男子。此处饥馑险难极甚怖畏。汝等何能受是苦耶。应自筹量无宜后悔。其说法者以此微细因缘方便。远离诸听法众。尔时诸人知是事已。互相谓言。此远离相非与般若波罗蜜多相。是故诸人各各退还不复随从。须菩提。以是因缘不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

复次须菩提。若说法者或时欲诣极大怖畏诸恶虫兽非人聚中。或诣饥馑枯涸险难等处。谓听法者言。诸善男子。汝等当知。我所往处极大险恶。汝等不应随从于我。须菩提。说法者以是微细因缘方便远离。诸听法者不能和合。不得般若波罗蜜多书持读诵。应当觉知是为魔事

复次须菩提。若说法者于亲友家常所往返。而于后时谓听法者言。我有亲族汝等应往求乞所须饮食衣服受用等物。由此因缘妨废听受般若波罗蜜多法门。是故不得书持读诵。应当觉知是为魔事

佛告须菩提。如是等相一一当知皆是恶魔作诸方便而为障难。欲令诸修菩萨法者。不得此般若波罗蜜多法门听受修习书持读诵。是故诸修菩萨法者。于一切时常所觉知觉已远离。令彼诸魔不得其便

佛说佛母出生三法藏般若波罗蜜多经卷第十一佛说佛母出生三法藏般若波罗蜜多经卷第十二

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    恶者障法品第十一之二

尔时尊者须菩提白佛言。世尊。何故恶魔于其长时勤作方便起诸障难。而令诸修菩萨法者不得般若波罗蜜多正法听受修习书持读诵

佛告尊者须菩提言。汝今当知。此般若波罗蜜多出生诸佛一切智。从一切智而复出生诸佛正法。从诸佛法出生无量无数众生。诸佛以其方便智力。普令众生断诸烦恼。烦恼断故。彼诸恶魔伺不得便。由不得便作障难故。心生苦恼。以苦恼心是故长时勤作方便为诸难事。而令诸修菩萨法者。不得般若波罗蜜多正法听受修习书持读诵

复次须菩提。彼诸恶魔或作方便。于其初住大乘善男子前作如是言。汝所听受非真般若波罗蜜多。我有经法。是真般若波罗蜜多。汝当随我如是修学。须菩提。彼诸恶魔以是方便欲坏善法。而初住大乘善男子等。少智少信未得阿耨多罗三藐三菩提记。其心怯弱为魔所摄。魔所摄故。即不得此般若波罗蜜多正法。听受修习书持读诵。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。彼诸恶魔或时现身。作苾刍相以坏法心。妄修菩萨甚深胜行。而返于中以声闻果谓证实际。须菩提。此因缘者。应当觉知是为魔事

复次须菩提。彼诸恶魔。以如是等种种方便。于此般若波罗蜜多正法作诸障难。不令有人书持读诵。是故修菩萨法者。常当觉知觉已远离。即起勇猛胜精进心。坚固安住正念正知

尔时尊者须菩提白佛言。如是世尊。如是善逝。譬如大珍宝聚。多有怨贼常欲伺求而为窃盗。何以故。珍宝难得价直无量。以是因缘多诸怨贼。今此般若波罗蜜多大法宝聚。亦复如是多诸障难。常有恶魔伺求其便。是故所有初住大乘善男子等。少智少信其心怯弱。于此甚深广大法中。不得听受修习书持读诵者。知彼皆是魔力所加。世尊。若复有人于如是等诸难事中。勇猛精进心不懈退。于此法门坚固修习书持读诵者。岂非诸佛神通威力所加持耶

佛言。须菩提。如是如是。如汝所说。若有人能于如是等诸难事中。得此法门听受修习书持读诵者。当知皆是诸佛如来神通威力共所护念。何以故。彼恶魔众虽复长时勤作方便。于此法门起诸难事。如来应供正等正觉。亦复长时勤作方便。于此般若波罗蜜多法门。以威神力加持护念

    显示世间品第十二之一

佛告须菩提。如世母人生育诸子。若一若十若百若千。忽于一时其母有疾。诸子各各勤求方便。多所疗治。咸作是念。云何令母速得远离风癀痰[病-丙+(企-止+(套-大))]种种病苦。眼耳鼻舌身意诸根轻安调适。云何令母饮食增进色力坚固。离诸苦受得大快乐。云何令母寿命长远久住世间。何以故。今我此身处于世间。从母所生生育甚难。以是因缘母恩为重。须菩提。所有十方现在如来应供正等正觉亦复如是。各各以其神通威力加持护念。此般若波罗蜜多甚深法门。悲愍世间一切众生。普令得闻书持读诵。彼诸如来咸作是念。云何得此般若波罗蜜多正法久住世间。云何得此般若波罗蜜多正法离破坏相。云何得此般若波罗蜜多正法。普令世间书持读诵宣通流布。使诸恶魔不得其便。须菩提。如来应供正等正觉。于一切时勤作方便。称赞护念般若波罗蜜多法门。何以故。此般若波罗蜜多是诸佛母。彼诸如来应供正等正觉所有一切智。从般若波罗蜜多真实出生。而此般若波罗蜜多。能示诸佛及能显示诸世间相。所有过去未来如来应供正等正觉。若已得若当得。皆因是般若波罗蜜多故。成就阿耨多罗三藐三菩提果。及今现在十方无量阿僧祇世界。一切如来应供正等正觉。住世说法广为众生作利益者。亦因是般若波罗蜜多故。成就阿耨多罗三藐三菩提果。须菩提当知。三世诸佛皆从般若波罗蜜多中来。般若波罗蜜多能善出生。是故般若波罗蜜多。能示诸佛及能显示诸世间相

尔时尊者须菩提白佛言。世尊。如佛所说般若波罗蜜多而能显示世间相者。如来应供正等正觉。当云何说为世间相。愿佛世尊广为开示

佛告尊者须菩提言。佛说五蕴为世间相。所谓色受想行识。般若波罗蜜多显示如是相。须菩提复白佛言。世尊。云何般若波罗蜜多示五蕴法为世间耶。佛告须菩提。当知般若波罗蜜多。显示五蕴坏无坏相。五蕴自性无作无生坏无所坏。何以故。彼空自性无作无生坏无所坏。无相无愿自性无作无生坏无所坏。法界自性亦无作无生坏无所坏。而此五蕴亦复如是。是故如来应供正等正觉。说般若波罗蜜多示世间相

复次须菩提。如来从般若波罗蜜多中来。能随无量无数众生性悉如实知。云何如来如实知耶。所谓众生自性即如实性。从般若波罗蜜多出生。如来亦复从般若波罗蜜多出生。是故如来能随无量无数众生性皆如实知。由实了知众生性故。乃至无量无数众生一切心行亦如实知。以了知无量无数众生心行故。是故佛说般若波罗蜜多示世间相。

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生摄心乱心。云何如来知众生摄心耶。所谓若集若散住法性中如实了知。若如实知是即了知众生摄心。是故如来因般若波罗蜜多故。能知无量无数众生如是摄心。云何如来知众生乱心耶。所谓住法性中知心无相。心无相故即无尽无不尽。若如实了知尽无尽相。是即了知众生乱心。是故如来因般若波罗蜜多故。能知无量无数众生如是乱心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生无尽心。云何如来知众生无尽心耶。须菩提。所谓知心无坏。心无坏故即心无生灭。无生灭故即无住无依。无有尽相犹如虚空广大无尽。而心相亦然。是故如来因般若波罗蜜多故。能知无量无数众生如是无尽心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生染心。云何如来知众生染心耶。须菩提。所谓了知染心如实相即非染心。是故如来因般若波罗蜜多故。能知无量无数众生如是染心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生离染心。云何如来知众生离染心耶。须菩提。所谓了知染心自性。即离染心中无离染心相。是故如来因般若波罗蜜多故。能知无量无数众生如是离染心。复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生诸能缘心。云何如来知众生能缘心耶。须菩提。所谓了知阿赖耶等诸能缘心。无能缘心相。是故如来因般若波罗蜜多故。能知无量无数众生如是能缘心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生诸能取心。云何如来知众生能取心耶。须菩提。所谓了知无所取相。取相离故即不可取。是故如来因般若波罗蜜多故。能知无量无数众生如是能取心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生诸有漏心。云何如来知众生有漏心耶。须菩提。所谓了知心无自性。无自性故即无分别。是故如来因般若波罗蜜多故。能知无量无数众生如是有漏心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生诸无漏心。云何如来知众生无漏心耶。须菩提。所谓了知心无自性即非心分。是故如来因般若波罗蜜多故。能知无量无数众生如是无漏心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生贪心。云何如来知众生贪心耶。须菩提。所谓了知若住贪即心不如实。若心如实即不住贪。于平等法中无贪心可得。是故如来因般若波罗蜜多故。能知无量无数众生如是贪心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生离贪心。云何如来知众生离贪心耶。须菩提。所谓了知心如实相。若贪若离贪俱不可得。由不可得故即无离贪心相。是故如来因般若波罗蜜多故。能知无量无数众生如是离贪心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生恚心。云何如来知众生恚心耶。须菩提。所谓了知心住空寂。离所缘相无诸分别。是故如来因般若波罗蜜多故。能知无量无数众生如是恚心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生离恚心。云何如来知众生离恚心耶。须菩提。所谓了知心法无二从真实生。是故如来因般若波罗蜜多故。能知无量无数众生如是离恚心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生痴心。云何如来知众生痴心耶。须菩提。所谓了知若心住于痴即心不如实。若心如实即不住于痴。是故如来因般若波罗蜜多故。能知无量无数众生如是痴心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生离痴心。云何如来知众生离痴心耶。须菩提。所谓了知若心有所著即心随痴相若心住如实即不随痴相。由如是故无离痴心相可得。是故如来因般若波罗蜜多故。能知无量无数众生如是离痴心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生过失心。云何如来知众生过失心耶。须菩提。所谓了知若心生过失即心不如实。若心如实即不生过失。于平等法中无过失心可得。是故如来因般若波罗蜜多故。能知无量无数众生如是过失心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生离过失心。云何如来知众生离过失心耶。须菩提。所谓了知若心有所著即过失随生。若心住如实即不生过失。由如是故无离过失心相可得。是故如来因般若波罗蜜多故。能知无量无数众生如是离过失心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生广心。云何如来知众生广心耶。须菩提。所谓了知是心不增不减无住无著。是故如来因般若波罗蜜多故。能知无量无数众生如是广心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生非广心。云何如来知众生非广心耶。须菩提。所谓了知心无处所。无处所故即无起作亦无增广。是故如来因般若波罗蜜多故。能知无量无数众生如是非广心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生大心。云何如来知众生大心耶。须菩提。所谓了知是心平等自性无差别。是故如来因般若波罗蜜多故。能知无量无数众生如是大心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生非大心。云何如来知众生非大心耶。须菩提。所谓了知心无来去。是故如来因般若波罗蜜多故。能知无量无数众生如是非大心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生无量心。云何如来知众生无量心耶。须菩提。所谓了知心无依止。无依止故即无限量。是故如来因般若波罗蜜多故。能知无量无数众生如是无量心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生现心。云何如来知众生现心耶。须菩提。所谓了知诸心自性无所显现。是故如来因般若波罗蜜多故。能知无量无数众生如是现心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生非现心。云何如来知众生非现心耶。须菩提。所谓了知心无形相自性离故。由性离故非现非不现。是故如来因般若波罗蜜多故。能知无量无数众生如是非现心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生胜上心。云何如来知众生胜上心耶。须菩提。所谓了知若心住如实即无所生亦无所有是为胜上。是故如来因般若波罗蜜多故。能知无量无数众生如是胜上心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生无上心。云何如来知众生无上心耶。须菩提。所谓了知心无所得离诸戏论。是故如来因般若波罗蜜多故。能知无量无数众生如是无上心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生定心。云何如来知众生定心耶。须菩提。所谓了知是心平等。平等法中无定乱相。犹如虚空寂无所动。是故如来因般若波罗蜜多故。能知无量无数众生如是定心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生非定心。云何如来知众生非定心耶。须菩提。所谓了知心无等等即心平等。心平等故而不可得非定心相。是故如来因般若波罗蜜多故。能知无量无数众生如是非定心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生解脱心。云何如来知众生解脱心耶。须菩提。所谓了知众生自性解脱。彼众生性即解脱性。是故如来因般若波罗蜜多故。能知无量无数众生如是解脱心复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生非解脱心。云何如来知众生非解脱心耶。须菩提。所谓了知心性无来无去无住非过去未来现在三世可得解脱性离即不可得非解脱相。是故如来因般若波罗蜜多故。能知无量无数众生如是非解脱心

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生不可见心。云何如来知众生不可见心耶。须菩提。所谓了知彼众生心。无所生无所成。无分别无所取。离诸相不可见。慧眼天眼尚不能观。岂况肉眼是故如来因般若波罗蜜多故。能知无量无数众生如是不可见心

佛告须菩提。如是等诸心。如来因般若波罗蜜多故。一一如实了知。以是义故。般若波罗蜜多而能显示诸世间相

佛说佛母出生三法藏般若波罗蜜多经卷第十二佛说佛母出生三法藏般若波罗蜜多经卷第十三

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    显示世间品第十二之二

佛告须菩提。又复如来因般若波罗蜜多故。如实了知无量无数众生。及诸异见补特伽罗诸行出没。云何如来知诸众生。及诸异见补特伽罗诸行出没耶。须菩提。所谓了知众生所起诸行出没。依色而生依受想行识而生。云何依色受想行识生耶。谓诸异见补特伽罗起。如是见我及世间是常。色是常我及世间是无常。亦常亦无常。非常非无常。如是我及世间是常。受想行识是常。我及世间是无常。亦常亦无常。非常非无常。受想行识是无常。亦常亦无常。非常非无常。又复我及世间是有边。色是有边。我及世间是无边亦有边。亦无边。非有边非无边。色是无边。亦有边亦无边。非有边非无边。如是我及世间是有边。受想行识是有边。我及世间是无边。亦有边亦无边。非有边非无边。受想行识是无边。亦有边亦无边。非有边非无边。又复死后色如去不如去。亦如去亦不如去。非如去非不如去。如是受想行识死后如去不如去亦如去亦不如去非如去非不如去。又复身即是神。身异神异。如是色受想行识即身即神。色受想行识异身异神。是见皆依五蕴所起。此等皆是补特伽罗别异痴见。如来一一如实了知。须菩提。以是义故如来应供正等正觉。因般若波罗蜜多故。能知无量无数众生。及诸异见补特伽罗如是出没

复次须菩提。如来因般若波罗蜜多故。如实了知无量无数众生色受想行识相。云何如来知众生色相耶。须菩提。所谓了知色如如。云何如来知众生受想行识相耶。须菩提。所谓了知受想行识如如。须菩提。以是义故如来所说众生出没如即五蕴如。五蕴如即世间如。何以故。五蕴及世间如无异故。是故五蕴如如世间如。世间如如一切法如。一切法如如须陀洹果如。须陀洹果如如斯陀含果如。斯陀含果如如阿那含果如。阿那含果如如阿罗汉果如。阿罗汉果如如。缘觉果如。缘觉果如如如来如。是故如来与彼声闻缘觉果。及五蕴世间。乃至一切法。同一如。如是诸如如非一性非多性。即种种性离种种性。无二无分别无作而无尽。须菩提。如来因般若波罗蜜多故得是如如。证是如故故名如来。以是因缘如来应供正等正觉。说般若波罗蜜多能示世间。般若波罗蜜多为诸佛母出生诸佛。由从是生故即如实了知彼一切法如如无异。证是如故出现世间。成就阿耨多罗三藐三菩提果

尔时须菩提白佛言。世尊。如佛所说如如法者最上甚深。佛因是如故得菩提果。世尊。此法甚深何人能信解。岂非住不退转菩萨摩诃萨。满愿阿罗汉。正见补特伽罗。乃能信解耶。佛言。须菩提。如是如是。如汝所说

复次须菩提。如如法者是无尽相最胜甚深。如来应供正等正觉。如实宣说彼无尽相

尔时帝释天主及欲界中余天子众。色界二万梵众天子来诣佛所。到已头面礼佛双足退住一面。时诸天子各白佛言。世尊。佛所说法最上甚深。此中云何作相耶

佛言。诸天子。诸法以空为相无相无愿为相。是相无生无灭无染无净。法界寂静犹如虚空。无所依止即相无相。如来应供正等正觉。说色受想行识亦如是相。即相无相。而此诸相相不能坏。世间天人阿修罗等所不能坏。何以故。彼天人阿修罗等是有相故。诸天子。若有人问虚空谁所作。是人为正问不。诸天子白佛言。不也世尊。虚空无所作。何以故。虚空无为谁能作者。佛告诸天子言。如是如是。如来应供正等正觉。从无二法生。说诸法相亦无二相。何以故。如来得是相故即无所住。是故佛说诸法无作相

尔时尊者须菩提白佛言。世尊。是相甚深。如来得是相故成等正觉。以无碍智说般若波罗蜜多。而此般若波罗蜜多乃是诸佛之所行处

佛告尊者须菩提言。如是如是。如来应供正等正觉。因般若波罗蜜多故。如实显示彼世间相。须菩提。如来应供正等正觉依止于法。供养恭敬尊重赞叹于法。所谓法者即般若波罗蜜多。有佛无佛此法常住。是故如来依止般若波罗蜜多。由依止故如来修习般若波罗蜜多。以修习故得一切智

复次须菩提。汝今当知。佛是知恩能报恩者。正使有人作是问言。谁是知恩能报恩者。应当答言。佛是知恩能报恩者。何以故。如来因所行道所学法故。得阿耨多罗三藐三菩提。今复护念是道是法。须菩提。如来所行所学者即是般若波罗蜜多。以是义故如来名为真报恩者

复次须菩提。如来知一切法无作。无作相故得阿耨多罗三藐三菩提。今复如实说一切法无作无作相。亦是如来真报恩者

复次须菩提。如来知一切法皆从般若波罗蜜多中来。今复如实说般若波罗蜜多显示世间。亦是如来真报恩者

须菩提白佛言。世尊。彼一切法无知者无见者。云何如来应供正等正觉。说般若波罗蜜多显示世间

佛告尊者须菩提言。善哉善哉。汝能问佛此甚深义。须菩提。如是如是。一切法无知者。一切法无见者。云何一切法无知者无见者。所谓一切法空一切法无依止。是故一切法无知者无见者。如来应供正等正觉得是法故。乃说般若波罗蜜多能示世间。云何示世间耶。须菩提。若不见色不见受想行识是为显示世间

须菩提白佛言。世尊。云何名不见色不见受想行识。佛言。须菩提。若不缘色生识是名不见色。若不缘受想行识生识。是名不见受想行识。须菩提。若不见色受想行识即不见世间。若如是不见世间是名真见世间。云何真见世间耶。所谓世间空故。世间离相故。世间寂静故。世间无染故。般若波罗蜜多如是显示。如来应供正等正觉亦如是说

    不思议品第十三

尔时尊者须菩提白佛言。世尊。此般若波罗蜜多最上甚深。为大事故出。为不可思议事不可称事不可量事不可数事无等等事故出佛言。须菩提。如是如是。般若波罗蜜多最上甚深。为大事故出。为不可思议事不可称事不可量事不可数事无等等事故出

须菩提。云何为不可思议事故出。所谓如来法佛法自然智法一切智法。如是诸法不可思议。非心非心数法可转。此中无分别。是故般若波罗蜜多。为不可思议事故出

须菩提。云何为不可称事故出。所谓如来法佛法自然智法一切智法。如是诸法非心所称。是故般若波罗蜜多为不可称事故出

须菩提。云何为不可量事故出。所谓如来法佛法自然智法一切智法。如是诸法出过诸量无有限量是故般若波罗蜜多为不可量事故出

须菩提。云何为不可数事故出。所谓如来法佛法自然智法一切智法。如是诸法出过诸数非数所及。是故般若波罗蜜多为不可数事故出

须菩提。云何为无等等事故出。所谓如来法佛法自然智法一切智法。如是诸法无有等者况复过上。是故般若波罗蜜多为无等等事故出

复次须菩提白佛言。世尊。若如来法佛法自然智法一切智法。如是诸法不可思议不可称不可量不可数无等等者。彼色亦不可思议不可称不可量不可数无等等。受想行识亦不可思议不可称不可量不可数无等等耶佛告尊者须菩提言。如是如是。须菩提。色不可思议不可称不可量不可数无等等故。受想行识不可思议不可称不可量不可数无等等。乃至一切法亦不可思议不可称不可量不可数无等等。何以故。色于法性中无心无心数法故。受想行识于法性中无心无心数法。乃至一切法于法性中亦无心无心数法

须菩提。色受想行识。于法性中以无心无心数法故。不可思议不可称。乃至一切法亦不可思议不可称。须菩提。色受想行识不可量故。乃至一切法亦不可量。何以故。色受想行识量不可得。乃至一切法量亦不可得。以不可得故即色受想行识乃至一切法无所作。以无所作故。即色受想行识乃至一切法无所生。以无所生故。是故色受想行识乃至一切法皆不可量。须菩提。色受想行识不可数故。乃至一切法亦不可数。何以故。出过数分故。须菩提。色受想行识无等等故。乃至一切法亦无等等。何以故。如虚空平等故。一切法亦然

复次须菩提。于汝意云何。虚空有心心数法不。须菩提言。不也世尊。佛言。须菩提。彼一切法亦复如是。虚空不可思议故一切法亦不可思议。虚空不可称故一切法亦不可称。虚空不可量故一切法亦不可量。虚空不可数故一切法亦不可数。虚空无等等故一切法亦无等等。是故诸法离诸分别。若分别者皆是识业

须菩提。灭诸筹量名不可思议。非所称故名不可称。无有量故名不可量。过诸数故名不可数。如虚空故名无等等。以是缘故。当知如来法佛法自然智法一切智法。乃至一切法皆如虚空。不可思议不可称不可量不可数无等等。说是不可思议乃至无等等法门时。会中有五百苾刍二十苾刍尼。不受诸法得诸漏尽心善解脱。六十优婆塞三十优婆夷。远尘离垢得法眼净。即于佛前皆得授记。二十菩萨悉证无生法忍。而诸菩萨于此贤劫。当得成就阿耨多罗三藐三菩提果

尔时尊者须菩提白佛言。世尊。般若波罗蜜多最上甚深。佛先所说为大事故出。其相云何。佛言。须菩提。般若波罗蜜多为大事故出者。汝今当知。所谓佛法缘觉法声闻法。皆住般若波罗蜜多中。须菩提。譬如世间刹帝利王子。得灌顶已处于王位。所有王事及国城事人民事等皆付大臣。臣受命已统摄而行。般若波罗蜜多亦复如是。所有佛法缘觉法声闻法。皆住般若波罗蜜多中。而般若波罗蜜多统摄诸法。如是等法名为大事。是故般若波罗蜜多为大事故出

复次须菩提。般若波罗蜜多不受不着色故出。不受不着受想行识故出。不受不着须陀洹果斯陀含果阿那含果阿罗汉果故出。不受不着缘觉果故出。不受不着一切智故出。须菩提。白佛言。世尊。云何般若波罗蜜多不受不着一切智故出耶。佛言须菩提。于汝意云何。汝所证得阿罗汉法有所见耶可受可着耶。须菩提言。不也世尊。我所证法是中无见亦不可受亦不可着。佛言。须菩提。般若波罗蜜多亦复如是。所有如来法乃至一切智法。是诸法中悉无所见不受不着。是故般若波罗蜜多。不受不着一切智故出

尔时尊者须菩提。白佛言。世尊。如佛所说般若波罗蜜多不受不着。最上甚深希有难得。世尊。彼初住大乘菩萨摩诃萨。若闻是说不惊不怖亦不退失生信解者。当知是菩萨具足正因。于先佛所已种善根。是故于今得闻此甚深般若波罗蜜多。亦复不生惊怖心净信解。佛言。须菩提。如是如是。如汝所说

尔时欲色界诸天子等。白佛言。世尊。此般若波罗蜜多正法。最上甚深难解难入。若人得闻此甚深般若波罗蜜多正法生信解者。当知是人于先佛所已种善根。世尊。正使三千大千世界所有众生。一一已住信行地者。是诸众生若满一劫若减一劫如理修行。不如有人能一日中于此般若波罗蜜多正法。如理思惟安住忍法。是人功德倍胜于前

佛告诸天子言。如是如是。般若波罗蜜多正法最上甚深。正使三千大千世界所有众生。一一已住信行地者。若满一劫若减一劫如理修行。不如有人于此般若波罗蜜多正法。如理思惟安住忍法。是人功德倍胜于前。是故汝等于此正法。尊重恭敬如理修行。是时欲色界中诸天子等各白佛言。世尊。大波罗蜜多是般若波罗蜜多。最上甚深希有难得。我等各各随喜顶受。彼诸天子如是称赞已。即各头面礼世尊足。右绕三匝出离佛会。去此不远隐身不现。各各还复彼彼天中

佛说佛母出生三法藏般若波罗蜜多经卷第十三佛说佛母出生三法藏般若波罗蜜多经卷第十四

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    譬喻品第十四

尔时尊者须菩提白佛言。世尊。若菩萨摩诃萨。闻此甚深般若波罗蜜多正法。不惊不怖不退不失不疑不难不悔不没心生信解者。是菩萨于何处没而来生此

佛告须菩提。若菩萨摩诃萨。闻此甚深般若波罗蜜多正法。不惊不怖不退不失不疑不难不悔不没。心生信解者。是菩萨于彼最上人中没已而来生此。复得闻是甚深般若波罗蜜多正法爱乐听受不暂舍离彼说法者。譬如新生犊子不离其母。须菩提。菩萨摩诃萨亦复如是。于此甚深般若波罗蜜多正法。心净信解爱乐听受。而不暂离彼说法者。以不离其说法者故。即不弃舍般若波罗蜜多。须菩提白佛言。世尊。若有菩萨摩诃萨。具足如是功德者。岂不从于他方佛刹没已生此耶。佛言须菩提。如是如是。若有菩萨摩诃萨。具足如是功德者。当知已于他方佛刹彼彼佛所。恭敬听受此甚深法。而复于中请问其义。从彼没已而来生此。以是因缘。今得闻此甚深般若波罗蜜多正法时。亦复具足如是功德

复次须菩提。有诸菩萨。于知足天上慈氏菩萨摩诃萨所。闻此甚深般若波罗蜜多正法不疑不难。而复于中请问其义。以是因缘。于彼没已而来生此。今得闻此甚深般若波罗蜜多正法时。亦复具足如是功德

复次须菩提。若菩萨摩诃萨。于先世中虽复曾闻此甚深法。不能如实请问其义。心生疑悔者。当知是菩萨转身生此。设得闻是甚深正法。亦复于中心生疑悔。何以故。以其先世不问所致故

复次须菩提。若菩萨摩诃萨。于先世中闻此甚深般若波罗蜜多正法时。能一日二日三四五日。发生净信请问其义者。是菩萨转身生此。闻是正法心即信解离诸疑悔。亦复于中请问其义。何以故。法尔如是故

复次须菩提。若有菩萨于先世中。虽得闻此甚深般若波罗蜜多正法。不能决定请问其义。亦复不能随所说行。是故今时于此甚深般若波罗蜜多正法。或时乐闻或不乐闻。其心轻动不能决定。犹如轻妙[疊*毛]衣随风所转。须菩提。当知此菩萨初住大乘法中心不清净不能发生决定信解。不取般若波罗蜜多。不随般若波罗蜜多行。是故于彼声闻缘觉二地之中随堕一处

复次须菩提。譬如有人乘船入海船忽破坏。是人若不取彼浮囊或木或板等。当知是人即于中路没水而死。由此因缘不到彼岸。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍有爱有欲。有解有行有喜有乐有舍有精进。有尊重有深心有净心。离放逸不散乱。虽具如是功德。若不得般若波罗蜜多善巧方便所护念者。是菩萨即不能成就一切智果。于其中路有所退失。须菩提。云何名为中路。又复退失何法。须菩提。中路者所谓声闻缘觉之地。所退失者谓一切智果

须菩提。又如有人乘船入海。于其中路船忽破坏。是人即时取彼浮囊或木或板等。当知是人得离难事。不为海水所溺而死。获大安隐到于彼岸

须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍有爱有欲。有解有行有喜有乐。有舍有精进有尊重有深心有净心。离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。是菩萨于其中路无所退失。不堕声闻缘觉之地。即能成就一切智果

复次须菩提。又如有人持以坏瓶诣于河池井泉欲取其水。是瓶不久中路破坏。以是因缘水不能得。何以故。瓶未成熟。是故破坏还归于地。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍有爱有欲。有解有行有喜有乐。有舍有精进。有尊重有深心有净心。离放逸不散乱。虽具如是功德。若不得般若波罗蜜多善巧方便所护念者。是菩萨于其中路有所退失。堕于声闻缘觉之地。不能成就一切智果

须菩提。又如有人持以熟瓶诣于河池井泉欲取其水。是人随所往处即能得水得已持归。是瓶坚牢无所破坏。何以故。瓶已熟故。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍有欲有爱。有解有行有喜有乐。有舍有精进有尊重。有净心有深心。离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路无所退失。不堕声闻缘觉之地。即能成就一切智果

复次须菩提。又如世间有诸商人少智少慧。于大海边随取一船。载诸财物入于海中。是船不久疏漏破坏。何以故。本所造作不能坚牢。船诸所用亦不能备。由彼商人无智慧故。不能觉了取以载物。于其中路船既破坏财复散没。商人尔时徒自忧恼。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有忍有信乃至离放逸不散乱。虽具如是功德。若不得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路有所退失。须菩提。中路退者所谓堕于声闻缘觉之地。失者所谓失彼一切智宝。于自利行及利他行皆不成就

须菩提。又如有诸商人有智有慧。于大海边求妙好船。知本造作坚固圆满。船诸所用悉已备者取以载物。入于大海。是船无难。随所往处皆悉得至。而彼财物亦不散没。何以故。由彼商人有智慧故。于其中路不生忧恼。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍。乃至离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路无所退失。不堕声闻缘觉之地。即能成就一切智果

复次须菩提。又如世间百二十岁老人。忽于一时为彼风癀痰[病-丙+(企-止+(套-大))]诸病侵恼。以是因缘忍苦于床。须菩提。于意云何。是人若时无人扶侍。当能从床而自起不。须菩提言。不也世尊。佛言。须菩提。是人设或能从床起。亦不能行一里二里乃至由旬。何以故。已为老病所侵恼故。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提有信有忍。乃至离放逸不散乱。虽具如是功德。若不得般若波罗蜜多善巧方便所护念者。当知是菩萨。于其中路有所退失。堕于声闻缘觉之地。不能成就一切智果

又须菩提。而彼百二十岁老人。虽复有疾忍苦于床。若时有二力士。来谓其言。我等二人各于左右扶侍于汝。汝速当起随有所往。令汝得至勿忧中路有所退失。时老病人受其语故。能从床起随往得至。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍乃至离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路无所退失。不堕声闻缘觉之地。即能成就一切智果。何以故。法尔如是故。须菩提。若诸菩萨摩诃萨。于阿耨多罗三藐三菩提。有信有忍。乃至离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨决定不堕声闻缘觉之地。即能成就一切智果。皆悉以是功德。回向阿耨多罗三藐三菩提

    贤圣品第十五之一

尔时尊者须菩提白佛言。世尊。彼初学菩萨于此甚深般若波罗蜜多当云何学

佛告尊者须菩提言。诸初学菩萨。若欲学此甚深般若波罗蜜多者。应当亲近彼善知识。尊重恭敬修学般若波罗蜜多。是善知识应当为彼初学菩萨如理教授。如实宣说般若波罗蜜多义。作如是言。善男子。汝所修习布施波罗蜜多持戒忍辱精进禅定智慧波罗蜜多所有功德。皆当回向阿耨多罗三藐三菩提。又善男子。汝以布施功德。回向阿耨多罗三藐三菩提时。不应取着阿耨多罗三藐三菩提果。勿取着色谓是菩提。勿取着受想行识谓是菩提。何以故。彼一切智无取着故。善男子。汝所修习于戒能护。于忍能受。精进不懈。禅定寂静。智慧胜解。以如是等功德。回向阿耨多罗三藐三菩提时。不应取着阿耨多罗三藐三菩提果。勿取着色谓是菩提。勿取着受想行识谓是菩提。何以故。彼一切智无取着故。善男子。以是义故汝亦不应取着声闻缘觉之地。须菩提。彼善知识应为初学菩萨如是教授。使令渐入甚深般若波罗蜜多中

须菩提复白佛言。世尊。菩萨摩诃萨趣求阿耨多罗三藐三菩提。为欲普令一切众生断诸苦恼安住涅盘。而诸菩萨所为甚难。谓布施波罗蜜多如是相。持戒忍辱精进禅定智慧波罗蜜多如是相。诸相甚深所为甚难。是故菩萨摩诃萨为欲成就阿耨多罗三藐三菩提者。于轮回中当发精进勿生惊怖

佛言须菩提。如是如是。菩萨摩诃萨所为甚难。须菩提。而诸菩萨摩诃萨为欲利益安乐悲愍诸世间故。趣求阿耨多罗三藐三菩提。彼作是念。我若成就阿耨多罗三藐三菩提时。当为世间作大救护。当为世间作所归向。当为世间作所住舍。当为世间作究竟道。当为世间作广大洲。当为世间作大光明。当为世间作善导师。当为世间作真实趣。以是义故菩萨摩诃萨于阿耨多罗三藐三菩提发大精进

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作大救护。所谓菩萨摩诃萨欲令世间一切众生断轮回苦。是名菩萨摩诃萨能为世间作大救护

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作所归向。所谓菩萨摩诃萨欲令世间一切众生悉得解脱生老病死忧悲苦恼。如是等法是名菩萨摩诃萨能为世间作所归向

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作所住舍。所谓菩萨摩诃萨得菩提时。为诸众生以不着故说法。须菩提白佛言。世尊。云何名为不着耶

佛言须菩提。若色不缚即色不着。若色不着即色不缚。色不缚故即色不生不灭。由色不生不灭故即无所著。以无所著故无缚亦无解。受想行识亦复如是。若识不缚即识不着。若识不着即识不缚。识不缚故即识不生不灭。由识不生不灭故即无所著。以无所著故无缚亦无解。彼一切法亦复如是。于诸知见悉无所著。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是说法。是名菩萨摩诃萨能为世间作所住舍

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作究竟道。所谓菩萨摩诃萨得菩提时。为诸众生作如是说。若色究竟即非色。若受想行识究竟即非识。由色受想行识如是故一切法亦然。须菩提白佛言。世尊。若色受想行识究竟一切法亦然者。彼菩萨摩诃萨皆不应得阿耨多罗三藐三菩提耶。何以故。一切法中无分别故。佛言须菩提。如是如是。彼一切法无所分别及分别者。由如是故菩萨摩诃萨得阿耨多罗三藐三菩提。是故一切法最上甚深微妙难入。安住寂静无得无证无动无转。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是说法。是名菩萨摩诃萨能为世间作究竟道

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作广大洲。此复云何名为洲耶。须菩提。譬如水中陆地断流之处故名为洲。彼一切法亦复如是。色前际断故后际亦断。受想行识前际断故后际亦断。乃至一切法前际断故后际亦断。以如是断故即一切法皆断。而此断相非颠倒相。涅盘寂静。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是说法。是名菩萨摩诃萨能为世间作广大洲

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作大光明。所谓菩萨摩诃萨于长夜中广为众生作大方便。欲令众生拔无明箭出生死苦。以一切智光破诸痴暗。是名菩萨摩诃萨能为世间作大光明

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作善导师。所谓菩萨摩诃萨得菩提时。为诸众生说色自性不生不灭。说受想行识自性不生不灭。说异生法自性不生不灭。说声闻缘觉法自性不生不灭。说菩萨法自性不生不灭。说诸佛法自性不生不灭。乃至说一切法自性不生不灭。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是说法。是名菩萨摩诃萨能为世间作善导师

须菩提。云何菩萨摩诃萨得阿耨多罗三藐三菩提时。能为世间作真实趣。所谓菩萨摩诃萨得菩提时。说色趣空。说受想行识趣空。说一切法趣空。即一切法不来不去。如彼虚空不来不去无作无相无住无所住无住法无生无灭。而一切法亦不来不去无作无相无住无所住无住法无生无灭。以是义故即无分别及分别者。何以故。色住空性故不来不去。受想行识住空性故不来不去。乃至一切法住空性故不来不去。此中云何而彼空趣即一切法趣是趣无转。无相趣即一切法趣是趣无转。无愿趣即一切法趣是趣无转。无作趣即一切法趣是趣无转。无生趣即一切法趣是趣无转。无趣趣即一切法趣是趣无转。无性趣即一切法趣是趣无转。梦趣即一切法趣是趣无转。我趣即一切法趣是趣无转。无我趣即一切法趣是趣无转。无边趣即一切法趣是趣无转。寂静趣即一切法趣是趣无转。涅盘趣即一切法趣是趣无转。无起趣即一切法趣是趣无转。无还趣即一切法趣是趣无转。无往趣即一切法趣是趣无转。不动趣即一切法趣是趣无转。色趣即一切法趣是趣无转。受想行识趣即一切法趣是趣无转。阿罗汉果趣。缘觉果趣。阿耨多罗三藐三菩提果趣。即一切法趣是趣无转。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是宣说诸法趣空。尔时须菩提白佛言。世尊。此般若波罗蜜多最上甚深。何人当能如实信解。佛告须菩提言。若有菩萨摩诃萨。已于过去如来应供正等正觉所成熟善根。久修菩萨甚深胜行者。于此甚深般若波罗蜜多即能信解。须菩提言。能信解者当云何相。佛言须菩提。若离贪嗔痴性是信解相。具是相者即能信解甚深般若波罗蜜多。须菩提白佛言。世尊。菩萨摩诃萨所得甚深般若波罗蜜多亦如是趣。得是趣已为诸众生如实宣说。令诸众生亦得是趣。佛告须菩提言。如是如是。须菩提甚深般若波罗蜜多亦如是趣。菩萨摩诃萨得是趣已。为诸众生如实宣说。令诸众生亦得是趣。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为诸众生如是说法。是名菩萨摩诃萨能为世间作真实趣

佛说佛母出生三法藏般若波罗蜜多经卷第十四佛说佛母出生三法藏般若波罗蜜多经卷第十五

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    贤圣品第十五之二

尔时尊者须菩提白佛言。世尊。菩萨摩诃萨所为甚难。为无量无数众生故被精进铠作大庄严。普令众生得大涅盘。而众生相了不可得。佛告须菩提言。如是如是。须菩提。菩萨摩诃萨所为甚难。为无量无数众生故被精进铠作大庄严。普令众生得大涅盘。而众生相了不可得。须菩提。菩萨摩诃萨不为色若解若缚故作大庄严。不为受想行识若解若缚故作大庄严。不为声闻地缘觉地佛地若解若缚故作大庄严。何以故。菩萨摩诃萨不为庄严一切法故而作庄严。是名作大庄严。须菩提白佛言。世尊。菩萨摩诃萨若如是行甚深般若波罗蜜多。是即菩萨摩诃萨作大庄严。而诸菩萨摩诃萨虽行是甚深般若波罗蜜多。不于三处而生取着。何等为三。所谓声闻地缘觉地佛地。佛言须菩提。如汝所说。菩萨摩诃萨若如是行甚深般若波罗蜜多是大庄严而诸菩萨摩诃萨虽行是甚深般若波罗蜜多。不于声闻地缘觉地佛地而生取著者。须菩提。汝见何义作如是说。须菩提白佛言。世尊。般若波罗蜜多最上甚深。无有少法可得修习无所修无修者。何以故。甚深般若波罗蜜多。是中无法可出生故。即无所修。如修虚空是修般若波罗蜜多。不修一切法是修般若波罗蜜多。修无著是修般若波罗蜜多。修无边是修般若波罗蜜多。即修无修是修般若波罗蜜多。修无取是修般若波罗蜜多。佛告尊者须菩提言。如是如是。此般若波罗蜜多微妙甚深。须菩提。诸菩萨摩诃萨能修习者当以此法而为试验表示其相。若有菩萨摩诃萨。于此甚深般若波罗蜜多。不生贪着无所希望。亦复不随他所言论。其心清净不起异信。闻说此甚深般若波罗蜜多时。不惊不怖不退不失。不疑不难不悔不没。心大欢喜清净信解者。当知是菩萨摩诃萨于阿耨多罗三藐三菩提得不退转。于先佛所已曾得闻此甚深法。而复于中请问其义。由此因缘今复得闻此甚深法。不惊不怖乃至心生欢喜信解。须菩提白佛言。世尊。若菩萨摩诃萨闻此甚深般若波罗蜜多不惊怖已。应当云何。观此甚深般若波罗蜜多。佛言须菩提。菩萨摩诃萨欲观般若波罗蜜多者。当随一切智心观。须菩提言。云何名为随一切智心观。佛言须菩提。若随虚空观即随一切智心观。云何名为随虚空观。须菩提。随虚空观者即无所观。由如是故乃得名为随一切智心观般若波罗蜜多。何以故。无量是一切智。须菩提。若无量即无色。无受想行识。无得无证无道法无道果。无智无识无生无灭。无成无坏无观无所观。无作无作者无去无来。无方无趣无住非无住是即无量。若见是无量即堕无量数。若不见是无量。即如虚空无量。一切智亦无量。如是无量即无得无证。是故不可以色得。不可以受想行识得。不可以布施波罗蜜多得。不可以持戒波罗蜜多忍辱波罗蜜多精进波罗蜜多禅定波罗蜜多智慧波罗蜜多得。此中云何。所谓色即是一切智。受想行识即是一切智。布施波罗蜜多即是一切智。持戒波罗蜜多忍辱波罗蜜多精进波罗蜜多禅定波罗蜜多智慧波罗蜜多即是一切智

尔时娑婆世界主大梵天王。与色界天子众俱。帝释天王与欲界天子众俱来诣佛所。到已头面各礼佛足。右绕三匝退住一面。各白佛言。世尊。般若波罗蜜多最上甚深。不能得其边际源底难见难解。如来应供正等正觉。以何义故安处道场。成就阿耨多罗三藐三菩提果。说此甚深般若波罗蜜多耶。佛告梵王帝释诸天子言。如是如是。般若波罗蜜多最上甚深。不能得其边际源底难见难解。如来应供正等正觉。于此甚深般若波罗蜜多。见是义故安处道场。成就阿耨多罗三藐三菩提果。宣说甚深般若波罗蜜多。诸天子。如来虽得菩提。而无得者及无所得。虽说般若波罗蜜多。无能说者无法可说。何以故。我法甚深非所演说如虚空甚深故此法甚深。我甚深故此法甚深。一切法无来故此法甚深。一切法无去故此法甚深。是时梵王帝释及诸天子复白佛言。希有世尊。希有善逝。佛所说法世间诸行。难可得信难可得解。何以故。世间行有着。佛说法无著。是故一切法离诸有着

    真如品第十六

尔时尊者须菩提白佛言。世尊。佛所说法随顺一切法离诸障碍。而一切法了不可得。犹如虚空离障碍相。世尊。诸法如虚空故一切句不可得。诸法平等故二法不可得。诸法无生故生法不可得。诸法无灭故灭法不可得。诸法无相故取相不可得。诸法无处故一切处不可得

尔时梵王帝释及诸天子俱白佛言。世尊。长老须菩提。随如来生。何以故。长老须菩提。诸所说法皆悉空故。是时长老须菩提。即谓梵王帝释及诸天子言。汝等所言须菩提。随如来生者。当知随如如行故如如无生。是故须菩提随如来生。诸天子。如如来真如不来不去故。须菩提真如亦不来不去。如来真如本来不生故。须菩提真如亦本来不生。何以故。如来真如即是一切法真如。一切法真如即是如来真如。一切法真如亦是须菩提真如。是诸真如无所生故。是故须菩提。于是真如法中随如来生。而彼真如即非真如。诸天子。如如来真如无住非无住须菩提真如亦无住非无住。如如来真如无作非无作。无分别非无分别。须菩提真如亦无作非无作。无分别非无分别。以须菩提真如无作非无作无分别非无分别故。即如来真如无作非无作无分别非无分别无障碍以无障碍故。一切法亦无作非无作无分别非无分别离诸障碍。何以故。以如来真如以一切法真如。同一真如。是如无二无二分无相无分别。彼无二真如即非真如非不真如。即彼非真如非不真如。是如无二无二分无相无分别。是故须菩提随如来生。诸天子。如来无作真如非无作真如。无所有真如非无所有真如。是如无二无二分无相无分别。是故须菩提随如来生。诸天子。如如来真如一切处常不断不坏。须菩提真如亦一切处常不断不坏。一切法真如亦一切处常不断不坏。如来真如无相无动无所得。须菩提真如亦无相无动无所得。一切法真如亦无相无动无所得。是故须菩提随如来生。诸天子。如来真如不异一切法真如。须菩提真如不异一切法真如。彼一切法不异真如即非真如。彼非真如即一切法真如。如是真如无来无去无二无别。是故须菩提随如来生。诸天子。如如来真如非过去未来现在。须菩提真如亦非过去未来现在。一切法真如亦非过去未来现在。是故须菩提随如来生。诸天子。如来真如即不来不去不住真如。如来真如即过去真如不去。过去真如即如来真如不去。如来真如即未来真如不来。未来真如即如来真如不来。如来真如即现在真如不住。现在真如即如来真如不住。如来真如即过去未来现在真如。过去未来现在真如即如来真如。若如来真如。若过去未来现在真如。若须菩提真如。是诸真如无二无二分无相无分别。一切法真如亦无二无二分无相无分别。诸天子。若如来真如。若菩萨地真如。若阿耨多罗三藐三菩提真如。是诸真如无二无二分无相无分别。了不可得。皆是名字所分别故。须菩提复谓诸天子言。汝等当知。须菩提随如来生者。不随色生。不随受想行识生。不随须陀洹果生。不随斯陀含果生。不随阿那含果生。不随阿罗汉果生。不随缘觉果生。不随佛果生。何以故。诸法无生非无所生。诸法无得非无所得。诸天子。以是义故。须菩提随如来生。须菩提说是真如法时。而此大地六种震动。有十八相。所谓震遍震等遍震。动遍动等遍动。踊遍等等遍击。爆遍爆等遍爆。吼遍吼等遍吼。现如是等十八相已。即时大地还复如故

尔时尊者舍利子白佛言。世尊。真如法者。最上甚深微妙难解。佛告尊者舍利子言。如是如是。真如法者。最上最胜甚深微妙难解难入。当佛赞是真如法时。会中有三百苾刍。不受诸法证得漏尽心善解脱。五百苾刍尼远尘离垢得法眼净。五千天子得无生法忍。六千菩萨不受诸法证得漏尽心善解脱

尔时尊者舍利子。知彼六千菩萨证得漏尽心解脱已。即白佛言。世尊。此诸菩萨修菩萨行。以何因缘今此会中返得漏尽心解脱耶。佛言舍利子。汝今当知。此诸菩萨往昔曾于五百佛所亲近供养。而各修习布施持戒忍辱精进禅定等法。虽复如是修诸行法。而不得般若波罗蜜多善巧方便所护念故。以是因缘返证此果。又舍利子。有诸菩萨虽修空无相无愿法门行菩萨道。若不得般若波罗蜜多善巧方便所护念者。当知是菩萨得声闻果谓证实际。舍利子。譬如世间有彼飞鸟其身长大。或一由旬至五由旬。翅羽未成飞不能远。而欲从彼三十三天上投身下至阎浮提地。而彼飞鸟于其中道心生是念。我今欲还三十三天上。或作是念。愿我得至阎浮提地。身无损伤离诸苦恼。舍利子于汝意云何。而彼飞鸟欲还天上可得还不。愿至阎浮提地身无损伤。可得如愿不。舍利子言。不也世尊。何以故。而彼飞鸟身量既大翅复未成。身必损伤或复至死。佛告舍利子言。菩萨亦复如是。虽复有能发阿耨多罗三藐三菩提心。已于兢沙伽沙数劫中广修诸行。于施能舍于戒能护于忍能受精进不懈禅定寂静。而复能于阿耨多罗三藐三菩提发大心大愿。若不得般若波罗蜜多善巧方便所护念者。是菩萨必堕声闻缘觉之地

复次舍利子。有诸菩萨。虽念过去未来现在诸佛世尊所有戒定慧解脱解脱知见诸蕴善根。是菩萨取相念故。即不能知亦不能见诸佛世尊所有戒定慧解脱解脱知见诸蕴善根。以不知不见故。闻说一切法空。是菩萨取音声相而生信解。即以是取相功德。回向阿耨多罗三藐三菩提。是菩萨必堕声闻缘觉之地。何以故。不得般若波罗蜜多善巧方便所护念故。舍利子白佛言。世尊。如我解佛所说义。有诸菩萨。虽复长时广修诸行。若或远离彼善知识。不得般若波罗蜜多善巧方便所护念者。是菩萨即不能成就阿耨多罗三藐三菩提果。是故诸菩萨若欲成就阿耨多罗三藐三菩提果者。应当修习此般若波罗蜜多善巧方便

佛告舍利子言。如是如是。若诸菩萨欲成就阿耨多罗三藐三菩提果者。应当亲近彼善知识。即能修习此般若波罗蜜多善巧方便。以是义故乃能成就阿耨多罗三藐三菩提果

尔时梵王帝释及诸天子俱白佛言。世尊。般若波罗蜜多甚深。阿耨多罗三藐三菩提难得

尔时世尊告梵王帝释及诸天子言。如是如是。般若波罗蜜多甚深。阿耨多罗三藐三菩提难得。若诸无智起劣精进生劣信解。无善巧方便亲近恶知识者。即于阿耨多罗三藐三菩提转复甚难

尔时尊者须菩提白佛言。世尊。佛言阿耨多罗三藐三菩提难得者。如我解佛所说义。阿耨多罗三藐三菩提不为难得。何以故。一切法空无法可得无能得者。佛所宣说诸法皆空。为有所断而所断法是法亦空。彼阿耨多罗三藐三菩提。若所得法若所用法若知若解。一切皆空无得无证。是故阿耨多罗三藐三菩提不为难得。佛告须菩提言。阿耨多罗三藐三菩提无所得故难得。无得者故难得。无分别故难得

尔时尊者舍利子。即谓尊者须菩提言。如汝所说阿耨多罗三藐三菩提不为难得者彼兢沙伽沙数求菩提者。诸菩萨摩诃萨不应于阿耨多罗三藐三菩提有所退转。何以故。汝说菩提不难得故。须菩提言尊者舍利子。色于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。受想行识于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。离色有法于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。离受想行识有法于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。色真如于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。受想行识真如于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。离色真如有法于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。离受想行识真如有法于阿耨多罗三藐三菩提有退转不。舍利子言。不也须菩提。须菩提言。色于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。受想行识于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。离色有法于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。离受想行识有法于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提须菩提言。色真如于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。受想行识真如于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。离色真如有法于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。离受想行识真如有法于阿耨多罗三藐三菩提有所证不。舍利子言。不也须菩提。须菩提言。色于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。受想行识于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。离色有法于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。离受想行识有法于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。色真如于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。受想行识真如于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。离色真如有法于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。离受想行识真如有法于阿耨多罗三藐三菩提有所觉了不。舍利子言。不也须菩提。须菩提言。乃至一切法一切法真如于阿耨多罗三藐三菩提可退转不。舍利子言。不也须菩提。须菩提言。舍利子于汝意云何。若有法于阿耨多罗三藐三菩提可退转者。是法即有所住。以一切法无住。当有何法而可退转。舍利子。真如可退转不。舍利子言。不也须菩提。须菩提言。舍利子。如是一切法实求不可得。即无法于阿耨多罗三藐三菩提可得退转

尔时尊者舍利子白尊者须菩提言。如尊者所说义。即无菩萨于阿耨多罗三藐三菩提有所退转。须菩提。若如是者如佛所说求三乘人应无差别耶

尔时尊者满慈子。语尊者舍利子言。汝当问尊者须菩提。如须菩提意。欲令唯有一乘人耶。是时舍利子即如所说语尊者须菩提言。汝须菩提。欲令唯有一乘人耶。须菩提言。舍利子。汝于真如法中有一乘人而可见不。舍利子言。不也须菩提。须菩提言。又舍利子。汝于真如法中有三乘人而可见不。舍利子言。不也须菩提。须菩提言。舍利子。真如法中有一相三相而可得不。舍利子言。不也须菩提。须菩提言。舍利子汝今当知。真如法中一菩萨法尚不可得。何况声闻缘觉之法而可得耶。是故无有少法于阿耨多罗三藐三菩提有所退转。舍利子。若菩萨摩诃萨闻作是说不惊不怖不退失者。当知是菩萨摩诃萨即能成就菩提

尔时世尊赞尊者须菩提言。善哉善哉。须菩提。汝所乐说皆是如来威神护念。如汝所说。如是如是。若菩萨摩诃萨闻作是说不惊不怖不退失者。当知是菩萨摩诃萨即能成就菩提。尔时尊者舍利子白佛言。世尊。若菩萨摩诃萨闻作是说不惊怖退失者。当得成就何等菩提。佛言舍利子。当得成就阿耨多罗三藐三菩提。尔时尊者须菩提白佛言。世尊。若菩萨摩诃萨欲得成就阿耨多罗三藐三菩提者。应云何住云何修学。佛言须菩提。若菩萨摩诃萨欲得成就阿耨多罗三藐三菩提者。当于一切众生起平等心。无毒心慈心利益心善知识心无障碍心谦下心无恼心不害心。当生如是等心。又于一切众生作父想母想诸亲友想。又复长时广修诸行。所谓于施能舍于戒能护于忍能受精进无懈禅定寂静智慧胜解。修如是等种种胜行。随顺缘生观察诸法。不于诸法取断灭相。如是了知诸法真实。即能过菩萨地具诸佛法。成熟无量无数有情。普令安住大涅盘界。菩萨摩诃萨若如是修学即无障碍相。乃至一切法亦得无障碍。须菩提。是故菩萨摩诃萨欲得阿耨多罗三藐三菩提者。当如是住如是修学。如是学者。能为一切众生作大依怙

佛说佛母出生三法藏般若波罗蜜多经卷第十五佛说佛母出生三法藏般若波罗蜜多经卷第十六

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    不退转菩萨相品第十七

尔时尊者须菩提白佛言。世尊。不退转菩萨摩诃萨当有何相。我等云何而能识知是不退转者。佛告须菩提言。汝今当知。不退转菩萨摩诃萨有种种相。须菩提。所有异生地声闻地缘觉地菩萨地如来地。如是诸地于真如中无二无别无疑无坏。菩萨从是真如入诸法性。虽入是法而亦于中不生分别。此是真如此真如相。出是如已设闻余法。亦复于中不疑不难不悔不没。无是法无非法。菩萨随诸法相入诸法性。须菩提。当知不退转菩萨摩诃萨于一切时诸所言说有义有利。而终不说无益语言。亦不观察他人美恶长短。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。当知彼不退转菩萨摩诃萨虽闻诸余沙门婆罗门外道等众所说语言。而不取为实知实见。是菩萨亦不礼事诸余天等。不以香华灯涂饮食衣服种种供具供养彼等。亦复于彼不生信敬。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。毕竟不堕诸恶趣中。不受女人之身。又须菩提。是菩萨于一切时常行十善道。所谓自不杀生复教他人持不杀生。自不偷盗复教他人持不偷盗。自不邪染复教他人持不邪染。自不妄言复教他人持不妄言。自不两舌复教他人持不两舌。自不恶口复教他人持不恶口。自不无义语复教他人持不无义语。自不贪爱复教他人持不贪爱。自不嗔恚复教他人持不嗔恚。自不邪见复教他人不起邪见。如是不退转菩萨摩诃萨自行十善道。复以此法广为他人如理表示如实教授。如所利益如理生喜。是菩萨于十善法坚固而行无所退失。于一切行一切种一切时一切处不生嗔恚心。乃至梦中亦行十善。而不暂起十不善行。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。随自所闻所得一切法门。即为一切众生如理宣说。令诸众生得大利乐。菩萨以是法施随诸众生心所乐欲。普令众生圆满意愿。菩萨自所得法与一切众生共之。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。闻甚深法不疑不悔心生信解。是菩萨于一切时语言柔和善顺少于惛沉睡眠。行住坐卧威仪具足。诸根调寂离诸动乱。行不卒疾平足履地。安详徐步视地而行。所向方处离诸过失。又须菩提。彼不退转菩萨摩诃萨。身所著衣及诸卧具。清净香洁无有垢秽。身得安隐离诸病恼。又人身中有八万户大小诸虫。菩萨身中无是诸虫。何以故。菩萨善根超出世间广大增长。随其善根所增长已。菩萨即得身清净。身既清净心亦清净。须菩提白佛言。世尊。云何名为菩萨心清净。佛言须菩提。随其菩萨所有善根既增长已。即彼一切谄曲欺诳诸不善法而自销灭。以是灭故得心清净。由心清净故即能过于声闻缘觉之地。如是名为菩萨心清净。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。远离贪爱无悭嫉心。不求世间名闻利养。不乐多畜饮食衣服卧具医药及余资具。而但爱乐甚深正法。于深法门能一心听不生惊怖。智慧坚固谛信谛受。随所闻法皆与般若波罗蜜多相应。菩萨因般若波罗蜜多故。乃至世间一切种事。而不见有与般若波罗蜜多不相应者。皆悉安住实相法中。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。有诸恶魔来菩萨所。化作八大地狱。一一地狱。其中各有百千万数不退转菩萨。魔作是言。汝今当知此诸菩萨皆是住不退转者。如来一一已为授记。今还生此大地狱中。汝今亦复如是住不退转地如来已为授记。汝亦当生此大地狱。汝今若能悔是心者。当得不堕地狱转生天上。须菩提。若菩萨闻是语已。心不动转即作是念。若不退转菩萨摩诃萨。堕地狱者无有是处。我今觉知斯为魔事。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。有诸恶魔化沙门相。来菩萨所作如是言。汝先所闻可读诵者。皆不真实非佛所说。汝应悔舍勿复受持。汝今若能悔先所闻。我当常时来诣汝所。以我所闻共相习诵。我所闻者真是佛说。若菩萨闻是说已心动转者。当知是菩萨未从诸佛得授阿耨多罗三藐三菩提记。未能安住不退转性。若有菩萨闻是说已。心不动转住法实相。不生不灭不起不作。其心坚固不随他语。譬如漏尽阿罗汉现前证法实相。不生不灭不起不作。不随他语不为恶魔所能动转。菩萨亦然。已得安住不退转者。不为声闻缘觉法门而能动转。终不取证声闻缘觉之果。决定趣求阿耨多罗三藐三菩提。成就一切智安住不退转性。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。有诸恶魔来菩萨所作如是言。汝所修行是轮回行非菩萨行。汝今宜应于现生中尽苦边际取证涅盘。勿复于是生死法中受诸苦恼。汝今若不此生尽苦取涅盘乐。何能更受后世身耶。须菩提。若菩萨闻是说已觉知魔事心无动转。其魔即时复作是言。汝岂不见彼诸菩萨摩诃萨众。各各于其兢伽沙数劫中亲近诸佛。以其饮食衣服卧具医药。供养兢伽沙数诸佛世尊。于诸佛所修持梵行。敬事诸佛听受正法。为菩提故于诸佛所。请问菩萨所行道法。应云何住云何行云何学。随其所应诸佛为说。菩萨当如是住如是行如是学。是诸菩萨随诸佛教。如理修行求一切智。如是勤行尚不能得。况复汝今云何能得阿耨多罗三藐三菩提耶。须菩提。若菩萨闻是说已。觉知魔事心无动转。其魔即时复化作彼诸苾刍众。住菩萨前魔作是言。此等苾刍皆是漏尽阿罗汉。先发道意各各为求阿耨多罗三藐三菩提而不能得。今还取证如是阿罗汉果。况复汝今云何能得阿耨多罗三藐三菩提耶。须菩提。是菩萨闻是说已无所动转不生异想。而能觉知斯为魔事。即作是念。若菩萨摩诃萨随诸佛教如理修学如实安住。诸有所作应诸波罗蜜多。不离是道不离是念。若不得一切智者无有是处。菩萨作是思惟已。其心决定转复坚固。而诸恶魔不得其便。是菩萨觉知如是诸魔事已。于彼所闻而无所失。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。于诸法中不作色想。不生色想。不作受想行识想。不生受想行识想。何以故。是菩萨了知诸法自相空故。于一切法毕竟无所得无作无生。于诸法中得无生忍。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。有诸恶魔化苾刍相。来菩萨所作如是言。当知一切智同彼虚空。无所生无所成无所得法无所用法。无知者无证者无得法者无用法者。如是观一切智同虚空已。汝所趣求为无义利。若有人言得阿耨多罗三藐三菩提者。当知彼说是为魔事非佛所说。须菩提。彼菩萨闻是说已即起是念。今此说者令我远离一切智果是为魔事。菩萨即时起坚固心无动心无坏心。彼诸魔众不得其便。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。为求一切智故。不随声闻缘觉地转。是菩萨若欲入初禅二禅三禅四禅诸定。于是诸定心转调柔随意能入。虽入是诸定而不随禅生还取欲界法。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。不着世间名闻利养。亦不爱乐称扬赞叹。于诸众生心无恚碍。常于众生起利乐心。若来若去若动若止。心不散乱威仪具足。菩萨虽复在家不着诸欲。于诸欲境不生爱乐。设受诸欲常生怖畏。譬如有人经过险难多诸贼盗。于险难中虽有饮食常生怖畏。但念何时过斯险难。彼不退转菩萨摩诃萨亦复如是。虽复在家受诸欲境。而常觉知诸欲过失为众苦本。不生爱乐常所怖畏而生厌舍。不以邪命非法自活。宁失身命于诸众生而不损恼。何以故。在家菩萨是名正士。亦名大丈夫。亦名可爱士夫。亦名最上士夫。亦名善相士夫。亦名士夫中仙。亦名吉祥士夫。亦名士夫中众色莲华。亦名士夫中白莲华。亦名士夫正知者。亦名人中龙。亦名人中师子。亦名调御者。菩萨虽复在家而能成就种种功德。常乐利乐一切众生。菩萨以其般若波罗蜜多力故。获得一切胜相成就。须菩提。若有具足。如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。于一切时有执金刚大药叉主常随卫护。不令非人伺得其便。是菩萨心不散乱威仪寂静。诸根具足无所缺减。人中牛王诸相圆满。修贤善行常行正法。不以世间邪幻咒术药草等事引接于人。不为他人占相所有若吉祥事不吉祥事。亦不与人占相世间男女生长如是相如是事若善若恶。亦复不于女人而生敬爱。常修净命不邪命活。远离一切斗战诤讼。不坏正见戒行具足。菩萨于诸恶法不自所作。不劝他作。于一切时离诸过失。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。于一切时不说世间种种杂事。所谓不说王事。不说盗贼事。不说军众事。不说战阵事。不说国城聚落方处等事。不说父母亲族男女等事。不说园林台观池沼诸悦意事。不说龙神夜叉鬼魅非人等事。不说饮食衣服香华璎珞庄严等事。不说歌舞倡伎嬉戏等事。不说大海洲渚江河等事。不说诸异生事。菩萨不说如是世间种种杂事。但乐宣说蕴处界等与般若波罗蜜多相应诸法。常不离一切智如理作意。常乐正法不乐非法。乐和诤讼不乐谗谤。乐近善友不乐怨恶。乐说利益语。不说无义语。乐生他方清净佛刹。亲近诸佛如来瞻礼恭敬尊重供养。常得见佛不暂远离。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。当知不退转菩萨摩诃萨。多从欲界色界诸天命终。而来生此阎浮提中。当知是菩萨少生边地。设复生者亦在大国。明解世间经书伎术工巧等事无不通达。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。不自生疑。我是不退转者我非不退转者。菩萨于其自地所证法中决定无疑。譬如须陀洹人于自地中证所得果决定无疑。须菩提。不退转菩萨摩诃萨亦复如是。自所证法已得安住决定不退无复生疑。随诸魔事悉能觉知。觉已不随。须菩提。又如有人造无间罪。常生疑惧乃至命尽。不能舍离如是罪心。彼不退转菩萨摩诃萨亦复如是。已得安住不退转性。于其自地所证法中。决定坚固无所退失。不为世间天人阿修罗等而能动转。随诸魔事悉能觉知。觉已不随。乃至转身亦复不疑。更发声闻缘觉之心。乃至转身亦复不疑。不得阿耨多罗三藐三菩提。何以故。菩萨已得不坏智已住不坏心故。又须菩提。若诸恶魔化作佛身。来菩萨所作如是言。汝当取证阿罗汉果。何用勤求阿耨多罗三藐三菩提耶。何以故。诸求阿耨多罗三藐三菩提者有菩提相。汝今无如是相。唐设其功终不可得。是菩萨闻作是说。若于自心有异转者。当知未从先佛如来应供正等正觉所而得授记。未能安住不退转性。须菩提。若菩萨闻作是说心无异转。即作是念。此为异相非佛所说。是佛说者应无有异。当知皆是彼恶魔众。化作佛身来住我前作如是说。意欲令我远离阿耨多罗三藐三菩提。菩萨作是念已。其魔即时伺不得便隐复魔身。须菩提当知。是菩萨已从先佛如来得授阿耨多罗三藐三菩提记。已能安住不退转性。

复次须菩提。彼不退转菩萨摩诃萨作是念。我常护持过去现在诸佛正法为菩提故。勤行精进为正法故。不惜身命以守护正法故。是即尊重恭敬诸佛法身。须菩提。是菩萨摩诃萨而不但护过去现在诸佛正法。亦护未来诸佛正法。何以故。彼菩萨作是念。我亦在于未来数中。亦当得授阿耨多罗三藐三菩提记。是故我当守护未来诸佛正法。纵经长时亦不懈怠。乃至不惜身命而不退转。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨

复次须菩提。彼不退转菩萨摩诃萨。得闻如来应供正等正觉宣说正法。随所闻已不疑不悔深生信解。须菩提白佛言。世尊。彼菩萨摩诃萨但闻佛所说法不生疑悔。亦闻余法不疑悔耶。佛告须菩提言。彼菩萨摩诃萨设闻声闻人所说诸法亦不疑悔。何以故。彼菩萨摩诃萨已得无生法忍。于一切法离诸疑悔。入诸法性住法平等。须菩提。若有具足如是相者。是为不退转菩萨摩诃萨。须菩提。若菩萨摩诃萨成就如是等种种相者。当知是菩萨佛所护念。先佛如来应供正等正觉已为授记。而能决定坚固安住不退转性。何以故。恶魔所作皆为异相。菩萨随诸异相悉能觉知觉已不随。不为诸魔而能动转。须菩提。以是相故汝当识知。是为不退转菩萨摩诃萨

佛说佛母出生三法藏般若波罗蜜多经卷第十六佛说佛母出生三法藏般若波罗蜜多经卷第十七

        西天译经三藏传法大师赐紫臣施护奉　诏译

    空性品第十八

尔时尊者须菩提复白佛言。希有世尊。彼不退转菩萨摩诃萨乃能成就如是功德。又复世尊能善宣说诸菩萨摩诃萨无量无边不退转相。佛告须菩提言。如是如是。何以故。彼不退转菩萨摩诃萨。已能成就无边智故。须菩提白佛言。世尊。如佛所说。彼不退转菩萨摩诃萨兢伽沙等不退转相。是即显示诸菩萨摩诃萨甚深胜相。甚深相者即般若波罗蜜多相。佛赞须菩提言。善哉善哉。须菩提。如是如是。甚深相者即般若波罗蜜多相。般若波罗蜜多相者即是空义无相无愿无生无作无性无染涅槃寂静等义。须菩提白佛言。世尊。如佛所说甚深相者。但是空义乃至涅槃寂静等义。非一切法义耶。佛言须菩提。一切法义亦即甚深相。何以故。色甚深受想行识甚深。云何名为色甚深。如如甚深故色甚深。云何名为受想行识甚深。如如甚深故受想行识甚深。须菩提。若无色是为色甚深。若无受想行识是为受想行识甚深。须菩提言。希有世尊。能以微妙方便。障色显示涅槃。障受想行识显示涅槃。佛言须菩提。若菩萨摩诃萨于此甚深般若波罗蜜多相。如般若波罗蜜多住如是住。如般若波罗蜜多教如是学。如般若波罗蜜多行如是行。须菩提。菩萨摩诃萨能一日中如是思惟如是观察。如是修习如是相应。是菩萨摩诃萨一日所有功德。不可思议不可称量

须菩提。譬如世间有多欲人欲觉亦多。而于一时与端正女人共为期会。是时女人以余缘故障碍失期。须菩提。于汝意云何。彼多欲人当于是时为与何法相应。须菩提白佛言。世尊。是人但与欲觉邪思而共相应。彼作是念。我于何时当得此女而为集会。快哉相与嬉戏娱乐。佛言须菩提。于汝意云何。彼人于一日中所起欲念而为多不。须菩提言。甚多世尊。佛言须菩提。菩萨摩诃萨亦复如是。于此甚深般若波罗蜜多法门。能一日中如是思惟如是观察。如是修习如是相应者。能舍若干劫数轮回苦恼。复得远离诸退转失。毕竟得成阿耨多罗三藐三菩提。何以故。须菩提。菩萨摩诃萨能一日中思惟修习般若波罗蜜多不离是念。与般若波罗蜜多相应。是菩萨一日所有最胜功德。过余菩萨于兢伽沙数劫中远离般若波罗蜜多普于一切广行布施所有功德

复次须菩提。若菩萨摩诃萨于兢伽沙数劫中远离般若波罗蜜多。布施供养须陀洹斯陀含阿那含阿罗汉缘觉菩萨如来应供正等正觉。不如菩萨能一日中于此甚深般若波罗蜜多法门。思惟修习如所说行。此所获福无量无边不可称计

复次须菩提。若菩萨摩诃萨于兢伽沙数劫中远离般若波罗蜜多。于须陀洹乃至如来应供正等正觉所布施供养已。又复修持戒行具足。不如菩萨能一日中随顺般若波罗蜜多行。如理作意思惟修习宣说是法。此所获福无量无边不可称计

复次须菩提。若菩萨摩诃萨于兢伽沙数劫中远离般若波罗蜜多。于须陀洹乃至如来应供正等正觉所布施持戒已。复能修习忍辱精进禅定等法。不如菩萨能一日中随顺般若波罗蜜多行法施众生。此所获福无量无边不可称计

复次须菩提。若菩萨摩诃萨于兢伽沙数劫中远离般若波罗蜜多。于须陀洹乃至如来应供正等正觉所。修行布施持戒忍辱精进禅定如是法已。又复修习三十七菩提分法。不如菩萨能一日中随顺般若波罗蜜多行。以是法施功德回向阿耨多罗三藐三菩提此所获福无量无边不可称计。又须菩提。若菩萨摩诃萨能一日中随顺般若波罗蜜多行。以是法施功德如般若波罗蜜多相。回向阿耨多罗三藐三菩提。是菩萨所获福德无量无边不可称计。又须菩提。若菩萨摩诃萨能一日中随顺般若波罗蜜多行。以是法施功德如般若波罗蜜多相。回向阿耨多罗三藐三菩提已。复能如所说行修习相应。是菩萨所获福德无量无边不可称计。又须菩提。若菩萨摩诃萨能一日中随顺般若波罗蜜多行。以是法施功德如般若波罗蜜多相。回向阿耨多罗三藐三菩提。如所说行修习相应已。复能护持般若波罗蜜多。不暂远离般若波罗蜜多。是菩萨所获福德无量无边不可称计

尔时须菩提白佛言。世尊。诸起作法是相分别。云何世尊。作如是说得福多耶。佛言须菩提。诸菩萨摩诃萨行般若波罗蜜多时。而自了知诸起作法是相分别。虚妄不实空无所有。于是法中无所分别。须菩提。菩萨摩诃萨了一切法求不可得。随其菩萨了一切法求不可得故。即不离般若波罗蜜多。随其菩萨不离般若波罗蜜多故。是即无量无数。须菩提白佛言。世尊。无量与无数有何差别。佛言须菩提。无量者过诸分量。无数者不可数尽。须菩提白佛言。世尊。颇有因缘。色无量受想行识亦无量。佛言须菩提。如是如是。色无量受想行识亦无量。须菩提白佛言。世尊。无量者何义。佛言须菩提。无量者是空义无相义无愿义。须菩提白佛言。世尊。无量者但是空无相无愿义。非一切法义耶。佛言须菩提。于意云何。汝岂不闻佛说一切法空耶。须菩提白佛言。如是世尊。佛说一切法空。佛言须菩提。空即是无量。是故此中一切法义。无所分别离诸所作。须菩提。如是说者是佛所说。何以故。若如是说即是无量。无量即无数。无数即空。空即无相。无相即无愿。无愿即无生。无生即无灭。无灭即无作。无作即无知。无知即无性。无性即无染。无染即涅槃寂静。如是法门是即如来应供正等正觉所说。如是说者是即一切法无所说。须菩提白佛言。世尊。如我解佛所说义。彼一切法皆不可说。佛言须菩提。如是如是。一切法无说。何以故。一切法空性不可以言说。须菩提白佛言。世尊。不可说义有增减不。佛言。不也须菩提。不可说义无增无减。须菩提白佛言。若不可说义无增无减者。即布施波罗蜜多。持戒波罗蜜多。忍辱波罗蜜多。精进波罗蜜多。禅定波罗蜜多。智慧波罗蜜多。亦无增无减。世尊。若诸波罗蜜多无增无减者。云何菩萨摩诃萨以是无增无减诸波罗蜜多法。得近阿耨多罗三藐三菩提。成就阿耨多罗三藐三菩提。若不圆满诸波罗蜜多。菩萨摩诃萨即不能近阿耨多罗三藐三菩提。不成就阿耨多罗三藐三菩提。佛言须菩提。如是如是。诸波罗蜜多义无所增减。何以故。须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时。能行布施波罗蜜多而不作念。我行布施波罗蜜多有所增减。作是念。彼布施波罗蜜多但以名字所分别故。而不见彼施相可得。菩萨以是善根回向阿耨多罗三藐三菩提。以是阿耨多罗三藐三菩提如相回向故名为真实回向

复次须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时。能行净戒波罗蜜多而不作念。我行净戒波罗蜜多有所增减。作是念。彼净戒波罗蜜多。但以名字所分别故。而不见彼戒相可得。菩萨以是善根回向阿耨多罗三藐三菩提。以阿耨多罗三藐三菩提如相回向故名为真实回向

复次须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时。能行忍辱波罗蜜多而不作念。我行忍辱波罗蜜多有所增减。作是念。彼忍辱波罗蜜多但以名字所分别故。而不见彼忍相可得。菩萨以是善根回向阿耨多罗三藐三菩提。以阿耨多罗三藐三菩提如相回向故名为真实回向

复次须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时。能行精进波罗蜜多而不作念。我行精进波罗蜜多有所增减。作是念。彼精进波罗蜜多但以名字所分别故。而不见彼有相可得。菩萨以是善根回向阿耨多罗三藐三菩提。以阿耨多罗三藐三菩提如相回向故名为真实回向

复次须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时。能行禅定波罗蜜多而不作念。我行禅定波罗蜜多有所增减。作是念。彼禅定波罗蜜多但以名字所分别故。而不见彼定相可得。菩萨以是善根回向阿耨多罗三藐三菩提。以阿耨多罗三藐三菩提如相回向故名为真实回向

复次须菩提。具善巧方便菩萨摩诃萨。修行般若波罗蜜多时而不作念。是法有所增减。作是念。彼般若波罗蜜多但以名字所分别故。而不见彼可修可行。菩萨以是善根回向阿耨多罗三藐三菩提。以阿耨多罗三藐三菩提如相回向故名为真实回向

尔时尊者须菩提白佛言。世尊。阿耨多罗三藐三菩提者是何义。佛言须菩提。阿耨多罗三藐三菩提者即如如义。如如者无所增无所减菩萨摩诃萨于是法中应如实住。如理作意修习相应。是菩萨即近阿耨多罗三藐三菩提。即成就阿耨多罗三藐三菩提无所增减。须菩提是故当知。不可说义无增无减。乃至一切法亦无增无减。须菩提。菩萨摩诃萨知如是相如是作意如是修行。即近阿耨多罗三藐三菩提。即成就阿耨多罗三藐三菩提

    甚深义品第十九之一

尔时尊者须菩提白佛言。世尊。菩萨摩诃萨所得阿耨多罗三藐三菩提。为前心得耶为后心得耶。世尊。若前心得者。彼前心后心而各不俱。若后心得者。后心前心亦各不俱。云何菩萨摩诃萨而能增长诸善根耶。佛言须菩提。于汝意云何。譬如世间燃以灯炷。为前焰燃为后焰燃。须菩提言。不也世尊。非前焰燃亦不离前焰。非后焰燃亦不离后焰。佛言须菩提。于汝意云何。是炷实燃不。须菩提言。是炷实燃。佛言须菩提。如是如是。菩萨摩诃萨所得阿耨多罗三藐三菩提其义亦然。菩萨非前心得阿耨多罗三藐三菩提亦不离前心。非后心得阿耨多罗三藐三菩提亦不离后心。又非此心得非异心得亦非无得。于中亦复不坏善根

尔时尊者须菩提。白佛言。世尊。如佛所说。菩萨摩诃萨所得阿耨多罗三藐三菩提。非前心得亦不离前心。非后心得亦不离后心。又非此心得非异心得亦非无得不坏善根。是缘生法微妙甚深最上甚深

佛告尊者须菩提言。于汝意云何。若心灭已是心更生不。须菩提言。不也世尊。佛言须菩提。若心生已是灭相不。须菩提言。是灭相。佛言须菩提。彼灭相法而可灭不。须菩提言。不也世尊。佛言须菩提。是心有法可生可灭不。须菩提言。不也世尊。心无法可生亦无法可灭。佛言须菩提。即心生法及心灭法是二可灭不。须菩提言。不也世尊。佛言须菩提。一切法自性而可灭不。须菩提言。不也世尊。佛言须菩提。如如所住汝亦如是住耶。须菩提言。如如所住亦如是住。佛言须菩提。若如如所住亦如是住者即是常耶。须菩提言。不也世尊。佛言须菩提。于汝意云何。真如甚深耶。须菩提言。不也世尊。佛言。须菩提。真如即是心耶。心即是真如耶。须菩提言。不也世尊。佛言须菩提。异真如是心耶。须菩提言。不也世尊。佛言须菩提。汝于真如有所见耶。须菩提言。不也世尊。佛言须菩提。若菩萨摩诃萨如是行者是甚深行不。须菩提言。若如是行是无处所行。何以故。菩萨不行一切行如是行。佛言须菩提。若菩萨摩诃萨行般若波罗蜜多当于何处行。须菩提言。当于第一义中行。佛言须菩提。于汝意云何。菩萨摩诃萨若于第一义中行是菩萨相行不。须菩提言。不也世尊。佛言须菩提。于汝意云何。菩萨坏诸相不。须菩提言。不也世尊。菩萨不坏诸相。佛言须菩提。云何名为菩萨摩诃萨行般若波罗蜜多时得不坏诸相。须菩提白佛言。世尊。若菩萨摩诃萨作如是念。我修菩萨行而断诸相者。当知是菩萨未能具足诸佛法分。若菩萨摩诃萨有善巧方便心不住相。虽了是诸相。菩萨过诸相而不取无相。是为菩萨不坏诸相

尔时尊者舍利子白尊者须菩提言。若菩萨摩诃萨于其梦中修三解脱门。所谓空无相无愿。以是善根能增益般若波罗蜜多不。须菩提言。尊者舍利子。若菩萨摩诃萨修般若波罗蜜多。即有般若波罗蜜多相。是故于其梦中亦可增益。又舍利子。若昼日增益梦中亦增益。何以故。佛说昼夜梦中等无异故。舍利子言。若有男子女人于其梦中作善恶业。是人当有善恶报不。须菩提言。如佛所说。一切法如梦即不应有报。若复是人于梦觉已有分别想生。彼善恶报而亦应有。舍利子。若人梦中造杀生业。是人当得杀生罪不。舍利子言须菩提。是人从梦觉已有分别想生。作如是言。我于梦中所杀是快。当知是人随梦所杀亦得杀罪。舍利子言。尊者须菩提。如佛所说乃至一切法不应分别。若起分别即有想生。想从分别生罪从想心现。须菩提言。尊者舍利子。若彼一切分别断故即心如虚空。是故当知有缘则有业有缘则思生。无缘则无业无缘思不生。若心行于见闻觉知法中。有心取垢有心取净。即有因缘起业非无因缘。有因缘思生非无因缘。舍利子言尊者须菩提。如佛所说一切法离诸所缘。云何今说有因缘思生非无因缘耶。须菩提言。佛所说者离所作相故。说有因缘思生非无因缘。舍利子。诸缘法离相是相亦离。如是无明缘行行缘识。乃至生缘老死等。因缘诸法皆悉离相。是故佛说一切法离诸所缘

舍利子言尊者须菩提。若菩萨摩诃萨于其梦中而行布施。以是功德回向阿耨多罗三藐三菩提是为回向不。须菩提言尊者舍利子。今慈氏菩萨在此会中。如来为授阿耨多罗三藐三菩提记。知如是义证如是法。汝今以如是义而自请问。是时尊者舍利子即白慈氏菩萨言。如我所问须菩提法。彼尊者作是言。慈氏菩萨知如是义。遣我伸问唯愿菩萨为我宣说。尔时慈氏菩萨摩诃萨告尊者须菩提言。彼舍利子所问。如汝所言我知是义。我今不知以何法答。须菩提。不可以慈氏名字而答。不可以色空答。不可以受想行识空答。须菩提。彼色受想行识空中悉无所答。须菩提。我不见有能答法及能答者。亦不见有所答法及所答者。乃至所用答法皆不可见。乃至一切法皆无所见。法无见故而无所答。亦无法可得授阿耨多罗三藐三菩提记。尔时尊者舍利子白慈氏菩萨摩诃萨言。如菩萨所说证是法耶。慈氏菩萨言。舍利子。我不证是法。我于诸法中不见有法而可得证。不可以身得不可以心得。亦非语言分别思惟可得。于是义中毕竟无得。是故舍利子。一切法无性法自性如是

佛说佛母出生三法藏般若波罗蜜经卷第十七佛说佛母出生三法藏般若波罗蜜多经卷第十八

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    甚深义品第十九之二

尔时尊者舍利子作是念。慈氏菩萨摩诃萨已得甚深智慧。于长夜中勤行般若波罗蜜多。尔时世尊知舍利子心所念已。即告舍利子言。汝今何故起如是念。汝于自法中有法可见。而取证阿罗汉果耶。舍利子言。无法可见亦无所证。佛言舍利子。菩萨摩诃萨亦复如是。虽行般若波罗蜜多。而无法可得授记。亦无法得阿耨多罗三藐三菩提。是故不应有法取甚深相。菩萨摩诃萨如是行般若波罗蜜多时。不惊不怖诸力具足。应作是念。我于法无所得无所证。是中如理修习相应。若有如是行者。是行般若波罗蜜多

复次舍利子。菩萨摩诃萨若在恶兽难中不生惊怖。何以故。菩萨一切皆悉能舍。普为众生作大利益。是菩萨当于尔时作如是念。若诸恶兽欲食啖我。我当施与。愿我当得圆满布施波罗蜜多。得近阿耨多罗三藐三菩提。如是勤行精进。当得阿耨多罗三藐三菩提时。佛刹清净。国土无有诸恶虫兽牛畜等类。一切众生不相食啖

复次舍利子。菩萨摩诃萨若在怨贼难中不生惊怖。何以故。菩萨一切所有乃至己身。皆悉能舍无所吝惜。是菩萨当于尔时作如是念。若诸怨贼来相劫取。一切所有随彼所欲我悉施与。乃至于我夺命我亦不生嗔恨怨恶。尔时不起身业不发语业不动意业。于是三业离诸过失。愿我当得圆满持戒波罗蜜多忍辱波罗蜜多。得近阿耨多罗三藐三菩提。如是勤行精进。当得阿耨多罗三藐三菩提时。佛刹清净国土无有一切怨贼及余诸恶。而彼众生不相劫夺

复次舍利子。菩萨摩诃萨若在无水难中不生惊怖。何以故。菩萨善为众生说法除渴。是菩萨当于尔时作如是念。我应为众生宣说法要。令诸众生断除渴爱心得清净。设我此身为渴所逼趣命终者。我转生于他世界中。亦复于彼一切众生起大悲心作如是念。此诸众生薄福德故。还复生此无水难中。我时为诸众生说法除渴。如是坚固勤行精进。愿我当得圆满精进波罗蜜多。得近阿耨多罗三藐三菩提。如是勤行精进得阿耨多罗三藐三菩提时。佛刹清净国土众生无所渴乏。彼诸众生福德具足。自然而有八功德水适悦充足

复次舍利子。菩萨摩诃萨若在饥馑难中不生惊怖。何以故。菩萨被精进铠身心清净。是菩萨当于尔时作如是念。今此众生受饥馑苦深所悲愍。愿我当得圆满禅定波罗蜜多。得近阿耨多罗三藐三菩提。如是勤行精进得阿耨多罗三藐三菩提时。佛刹清净国土众生无饥馑苦。随意所欲一切皆得适悦快乐。譬如三十三天自在快乐。一切所欲随心即现。愿我当来彼土众生。亦得成就如是乐事。于一切时身心清净。正命坚固不邪命活。心住寂静离诸散乱

复次舍利子。菩萨摩诃萨若在疾疫难中不生惊怖。何以故。菩萨已能思惟观察。是中无法可病。是菩萨当于尔时作如是念。今此众生受诸病苦深所悲愍。愿我当得圆满智慧波罗蜜多。得近阿耨多罗三藐三菩提。如是勤行精进得阿耨多罗三藐三菩提时。佛刹清净国土众生离诸病苦。舍利子。菩萨摩诃萨若能如是勤修众行。即得阿耨多罗三藐三菩提

复次舍利子。菩萨摩诃萨不应。于阿耨多罗三藐三菩提生如是心。久远修习乃得成就。又复于中。不应惊怖。何以故。世界前际即是久远前际。菩萨若心刹那相应。虽为久远而非久远。是故菩萨摩诃萨不应生难行想。不应起久远念又复于中不应退没。又舍利子。菩萨摩诃萨于如是法及余诸法。若见若闻不应惊怖。是诸菩萨摩诃萨。应当坚固发精进行如所说学如所说行。即得般若波罗蜜多相应圆满

尔时会中有一女人名昂誐襧嚩。从座而起前诣佛所。偏袒右肩右膝着地。合掌恭敬顶礼佛足而白佛言。世尊。如所闻法我于是中不生惊怖。于未来世我亦当为一切众生说如是法。作是语已即持金华散于佛上。佛神力故其华自然住虚空中

尔时世尊即放金色净妙光明。普遍无量无边一切刹土。乃至梵界广大照耀。其光旋复绕佛三匝。还从世尊顶门而入

尔时尊者阿难从座而起。偏袒右肩右膝着地。合掌恭敬而白佛言。世尊。何因何缘放是光明。诸佛如来应供正等正觉。若无因缘不放光明

佛言。阿难。今此昂誐襧嚩女人终此身已。转生当得男子之身生于妙乐世界阿閦佛刹中。于彼如来应供正等正觉所。恭敬供养修持梵行。于彼没已复生他方诸佛刹中。如是从一佛刹至一佛刹。世世所生不离诸佛常得瞻礼亲近供养。譬如转轮圣王尊贵自在。从一宫殿至一宫殿。自生至终足不履地。今此女人亦复如是。从一佛刹至一佛刹不离诸佛。乃至于未来世星宿劫中当得成佛。号金华如来应供正等正觉明行足。善逝世间解无上士调御丈夫天人师佛世尊出现世间

尔时尊者阿难作如是念。今此女人当成佛时。于彼刹中所有众会诸菩萨等。如诸佛会等无异不

尔时世尊知彼阿难心所念已。告阿难言。汝今当知。此昂誐襧嚩女人得成佛已。彼佛刹中所有菩萨声闻众会其数甚多。无量无边不可称计。如诸佛会等无有异。又复阿难。彼佛刹中所有众生。安隐快乐无诸恶兽盗贼饥馑诸恶病恼枯涸等难。于一切时离诸怖畏。阿难。是金华如来应供正等正觉得阿耨多罗三藐三菩提时。而能成就如是功德

尔时尊者阿难白佛言。世尊。此昂誐襧嚩女人最初于何佛世尊所。发菩提心种诸善根。佛言。阿难。此昂誐襧嚩女人最初于彼燃灯如来应供正等正觉所。发阿耨多罗三藐三菩提心。尔时我于燃灯如来应供正等正觉所。持以五茎优钵罗华而为供养。我时证得无生法忍。彼燃灯如来知我善根成熟。即为授阿耨多罗三藐三菩提记作是言。善男子。汝于未来世当得作佛。号释迦牟尼如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。阿难。尔时此女在彼佛会。闻佛授我阿耨多罗三藐三菩提记。时彼女人即持金华亦供养佛。华供养已即作是念。快哉此善男子今得授记。愿我当来得授记时。亦如此人今日无异。阿难。是故当知此昂誐襧嚩女人发菩提心而甚久远。阿难白佛言。世尊。善哉善哉。今此女人久已修习阿耨多罗三藐三菩提行。佛言。阿难。如是如是。今此女人久已修习阿耨多罗三藐三菩提行。是故我今为授阿耨多罗三藐三菩提记

    善巧方便品第二十之一

尔时尊者须菩提白佛言。世尊。若菩萨摩诃萨欲行般若波罗蜜多。应云何学空云何入空三摩地。佛言。须菩提。若菩萨摩诃萨欲行般若波罗蜜多。应观色空观受想行识空。应以不散乱心谛观诸法空无所有。若一切法若一切法性悉不可见。虽复如是观法性空。不应于中证空实际。须菩提白佛言。世尊。如佛所说。菩萨摩诃萨不应证空者。世尊。菩萨住空三摩地。而复云何不证空耶。佛言。须菩提。菩萨摩诃萨虽于一切相具足观空。但修学空而不于中取空为证。彼菩萨如是观时应作是念。我今但是学时非是证时。是故不住三摩呬多。不深摄心系于缘中。彼菩萨摩诃萨以般若波罗蜜多力所护故。虽不证空亦不退失菩提分法。亦不尽漏住寂灭心。是故菩萨摩诃萨虽行空三摩地解脱门而不证空。虽入无相三摩地解脱门亦不证无相不住有相。何以故。是菩萨摩诃萨智慧甚深善根具足能作是念。今是学时非是证时。是故虽复观空而无所碍。虽住空三摩地亦不于中证空实际。以得般若波罗蜜多力所护故

须菩提。譬如有人色相端正最上勇猛。精进坚固富乐自在。自他语言有所义利。辩才无碍智慧明了。知时知方知处所向所行。通达善恶明解算数一切伎术善能成就。勇健多力能敌他军。乃至世间一切种事而悉晓了。人所爱乐瞻视亲近尊重恭敬。此人以是缘故一切所向皆得大利。心意调柔适悦快乐。是人一时有小因缘。与其父母妻子眷属。经过旷野极大怖畏险恶道中。彼有盗贼非人等类。时诸眷属皆悉惊怖毛竖战掉。是人即时谓其父母诸眷属言。汝诸眷属勿生惊怖。我有方便能令安乐过诸险难。即化多人执持种种锋利器仗。卫护眷属过是险难。彼诸盗贼非人等类。皆悉退散无所侵恼。彼诸眷属过是难已。安乐吉祥到彼所向州城聚落。何以故。是人有智有慧最胜勇猛。大力成就坚固不退。彼盗贼等不能敌故。菩萨摩诃萨亦复如是。悲愍利乐一切众生。常行慈悲喜舍四无量行。得般若波罗蜜多力所护故具善巧方便。以诸善根回向一切智。虽修空无相无作三摩地解脱门而不证实际。菩萨摩诃萨过诸烦恼及烦恼分。过诸恶魔及助魔者。过声闻地及缘觉地。住三摩地亦不尽漏。何以故。菩萨摩诃萨诸力具足精进坚固。得般若波罗蜜多力所护故。菩萨不舍一切众生。普令成就阿耨多罗三藐三菩提。又菩萨摩诃萨缘一切众生入慈心三昧。复入最上无缘慈三昧。修习最上波罗蜜多。又须菩提。菩萨摩诃萨虽行空三摩地解脱门。而于是中不证无相不堕有相。须菩提。譬如飞鸟行于虚空而不堕地。虽行于空而不依空亦不住空。菩萨摩诃萨亦复如是。虽行空学空行无相学无相行无作学无作。未具足佛法终不堕空无相无作。须菩提。又如有人于射师所学彼射法。学已精熟而复巧妙。即时仰射虚空。初箭发已后箭即发箭箭相注随意久近是箭不堕菩萨摩诃萨亦复如是。为欲成就阿耨多罗三藐三菩提善根。得般若波罗蜜多力所护故。若未成就阿耨多罗三藐三菩提善根终不取证实际。乃至善根成已得圆满阿耨多罗三藐三菩提。菩萨尔时乃证实际。是故须菩提。菩萨摩诃萨行般若波罗蜜多时。修般若波罗蜜多时。应如是谛观诸法甚深实相。虽复观已而不取证

尔时尊者须菩提白佛言。世尊菩萨摩诃萨所为甚难最上甚难。虽行空学空入空三摩地。而不于中证空实际。世尊。甚为希有。甚为希有

佛告尊者须菩提言。如是如是。菩萨摩诃萨虽行空学空入空三摩地。而不于中证空实际。斯为甚难最上甚难。斯为希有最上希有。何以故。须菩提。彼菩萨发如是最胜大愿。我应度一切众生。不舍一切众生。菩萨发是愿已。即入空三摩地解脱门。无相三摩地解脱门。无作三摩地解脱门。菩萨虽入是诸解脱门。而不于中取证实际。何以故。是菩萨已得善巧方便力所护故。能作是念。我不舍一切众生。未具足佛法。终不于中证空实际

复次须菩提。菩萨摩诃萨若欲入甚深空性者。所谓应入空三摩地解脱门。无相三摩地解脱门。无作三摩地解脱门。菩萨若欲入是诸三摩地解脱门者应生如是心。一切众生于长夜中。着众生相起有所得见。我得阿耨多罗三藐三菩提已。当为众生宣说法要断除是相。即入空三摩地解脱门。无相三摩地解脱门。无作三摩地解脱门。菩萨以如是心及先方便力故。不于诸三摩地中取证实际。亦不减失慈悲喜舍诸三昧法。何以故。是菩萨已得善巧方便力所护故。转复增益所有善法诸根通利。诸力觉道亦悉增益

复次须菩提。又菩萨摩诃萨若欲入空三摩地解脱门者应生如是心。一切众生于长夜中。而生我相著有所得。我得阿耨多罗三藐三菩提已。当为众生宣说法要断除我相。即入空三摩地解脱门。菩萨以如是心及先方便力故。不证实际亦不减失慈悲喜舍诸三昧法。何以故。是菩萨已得善巧方便力所护故。转复增益所有善法诸根通利。诸力觉道亦悉增益

复次须菩提。又菩萨摩诃萨若欲入无相三摩地解脱门者应生如是心。一切众生于长夜中。着诸有相生取相想。我得阿耨多罗三藐三菩提已。当为众生宣说法要断除有相。即入无相三摩地解脱门。菩萨以如是心及先方便力故。不证实际亦不减失慈悲喜舍诸三昧法。何以故。是菩萨已得善巧方便力所护故。转复增益所有善法诸根通利。诸力觉道亦悉增益

复次须菩提。又菩萨摩诃萨若欲入无作三摩地解脱门者应生如是心。一切众生于长夜中。着常想乐想我想净想。起如是等诸颠倒想是所作相。我得阿耨多罗三藐三菩提已。当为众生宣说法要。所谓是无常非常是苦非乐是无我非我是不净非净。如是当令断除常想乐想我想净想。离所作相即入无作三摩地解脱门。菩萨以如是心及先方便力故不证实际。亦不减失慈悲喜舍诸三昧法。何以故。是菩萨已得善巧方便力所护故。转复增益所有善法诸根通利。诸力觉道亦悉增益。又须菩提。菩萨摩诃萨应生如是心。一切众生于长夜中着诸有相。所谓先行有所得今行有所得。先行常想今行常想。先行颠倒行今行颠倒行。先行和合想今行和合想。先行不实想今行不实想。先起邪见今起邪见。先作诸过失行今作诸过失行。如是一切众生。于一切时一切处作如是行。我得般若波罗蜜多力所护故具足善巧方便。如是勤行精进得阿耨多罗三藐三菩提时当为众生说如是法。令诸众生得入诸法甚深实相。所谓空无相无愿无作无起无生无性。须菩提。若菩萨摩诃萨生如是心具足是智慧。返堕起作法住三界者无有是处。又须菩提。若菩萨摩诃萨修相应行者。应问余菩萨言。若欲成就阿耨多罗三藐三菩提者。应云何学空当云何生心。即得入空不证空。入无相无愿无作无起无生无性。不证无相乃至无性。而能修习般若波罗蜜多耶。若菩萨作是言。欲成就阿耨多罗三藐三菩提者。但应念空念无相无愿无作无起无生无性。如是答者是即舍离一切众生。未能具足善巧方便。当知是菩萨未于先佛如来应供正等正觉所得授阿耨多罗三藐三菩提记。未住不退转地。何以故。是菩萨不能宣说不退转菩萨摩诃萨不共相。不能于其所问法中正示正答。须菩提白佛言。世尊。应云何知是不退转菩萨摩诃萨。佛言。须菩提。当知彼不退转菩萨摩诃萨者。于此甚深般若波罗蜜多法门。若闻若不闻。随有所问皆能于中正示正答。具是相者是为不退转菩萨摩诃萨。须菩提白佛言。世尊。菩萨多行菩提少能正答。佛言。须菩提。少有住不退转者。是故不能正答。须菩提。若有已住不退转者彼能正答。当知是菩萨善根明净具足方便。不为一切世间天人阿修罗等而能动坏。是菩萨能善观察一切法如梦。而于是中不证实际。须菩提当知。此为不退转菩萨摩诃萨相

佛说佛母出生三法藏般若波罗蜜多经卷第十八佛说佛母出生三法藏般若波罗蜜多经卷第十九

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    善巧方便品第二十之二

尔时世尊告尊者须菩提言。我今复说不退转菩萨摩诃萨种种相貌。汝当谛听如善作意。须菩提言。善哉世尊。愿乐欲闻。佛言。须菩提。若菩萨摩诃萨。乃至梦中亦不爱乐声闻缘觉之地。亦不生彼住三界心。须菩提。有是相者当知是为不退转菩萨摩诃萨相

复次须菩提。若菩萨摩诃萨于其梦中见百千俱胝那庾多数菩萨声闻人天大众。恭敬围绕如来应供正等正觉听其说法。须菩提。若彼梦中见是相者。当知是为不退转菩萨摩诃萨相

复次须菩提。若菩萨摩诃萨于其梦中自见其身。处虚空中为人说法。及见自身放大光明。化苾刍相往彼他方诸世界中。施作佛事及为说法。须菩提。若彼梦中见是相者。当知是为不退转菩萨摩诃萨相

复次须菩提。若菩萨摩诃萨于其梦中见州城聚落。悉为火焚一切破坏。诸恶虫兽四散驰走。一切人众皆大惊怖生苦恼。心菩萨见已不惊不怖。从梦觉已作是思惟。三界无实皆悉如梦。愿我当得阿耨多罗三藐三菩提时。以如是法为众生说。须菩提。若彼梦中见是相者。当知是为不退转菩萨摩诃萨相

复次须菩提。若菩萨摩诃萨于其梦中见地狱中有诸众生随受众苦。菩萨见已作是思惟。愿我当得阿耨多罗三藐三菩提时。佛刹清净无有地狱。乃至不闻其名况复可见。又须菩提。若菩萨摩诃萨于其梦中见诸饿鬼受饥渴苦。菩萨见已作是思惟。愿我当得阿耨多罗三藐三菩提时。佛刹清净无有饿鬼。乃至不闻其名况复可见。又须菩提。若菩萨摩诃萨于其梦中见诸畜生受极重苦。菩萨见已作是思惟。愿我当得阿耨多罗三藐三菩提时。佛刹清净无有畜生。乃至不闻其名况复可见。须菩提。若彼梦中见是相者。当知是为不退转菩萨摩诃萨相

复次须菩提。若菩萨摩诃萨于诸方处或见州城聚落忽为火焚。菩萨见已即作是言。如我梦中先所见相等无有异。我若已得安住不退转者。愿我以是实语力故。速令此火自然息灭。不复展转遍诸方处。须菩提。彼菩萨作是言已。即时若能火自息灭。当知是菩萨已从先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记已住不退转地。若菩萨作是言已火不灭者。当知是菩萨未得授记。未能安住不退转地。又须菩提。若或是火不能灭。已而复焚烧诸余方处。从一舍至一舍。从一里至一里。如是展转火不灭者。当知是处众生先世有破法重罪。彼之余殃今世现受。须菩提。以是因缘。若菩萨摩诃萨随愿能满者。当知是为不退转菩萨摩诃萨相

复次须菩提。若有男子女人等。或为非人所执魅者。是时菩萨见是事已即作是言。若我已于先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记。深心清净为欲成就阿耨多罗三藐三菩提故。远离声闻缘觉之心所行清净。我当决定于阿耨多罗三藐三菩提。是所应得非不应得。又今十方无量阿僧祇世界诸佛世尊现住说法者。彼诸如来应供正等正觉。无所不知无所不见无所不了。无所不证无所不得。是诸佛世尊。若知我深心决定成就阿耨多罗三藐三菩提者。愿我以是实语力故。令彼非人舍离远去。其所执魅若男若女速得解脱。若菩萨作是语时。而彼非人不即远去。其所执魅未得解脱者。当知是菩萨未从先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记。未住不退转地。须菩提。若菩萨作是语时。而彼非人即速远去。其所执魅即得解脱者。当知是菩萨已从先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记。已得安住不退转地

    辩魔相品第二十一

复次须菩提。亦有初住大乘诸菩萨等。见是男子女人为彼非人所执魅时即作是言。若我已于先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记者。愿我以是实语力故。令彼非人舍离远去。其所执魅若男若女速得解脱。作是语已。时彼恶魔隐伏其形来菩萨所。潜以魔力即令非人舍离而去。何以故。诸恶魔力胜非人故。由是非人力不能为舍离而去

尔时菩萨不能觉知斯为魔力。但作是念。我从先佛已得授记已能安住不退转地。何以故。随我所愿即得成就。彼诸菩萨未得授记无是力故。菩萨于此起增上慢及诸慢心。由慢心故增长贡高。以贡高故轻易恶贱诸余菩萨。自谓已从先佛得记。余悉未得从佛授记。由此因缘。远离佛无上智自然智一切智一切智智。乃至远离阿耨多罗三藐三菩提。菩萨于此若不亲近诸善知识。不得善法而为开导。为诸恶友共所护助。于自身心又复不具善巧方便。增上慢心转复坚固。以是因缘为魔所缚不能解脱。于二地中随堕一处。若声闻地若缘觉地。须菩提。如是相者是彼初住大乘诸菩萨等。以少见少闻故。不能亲近诸善知识。不得般若波罗蜜多善巧方便力所护故。以小因缘增长慢心。乃至远离阿耨多罗三藐三菩提。须菩提。是故当知斯亦名为菩萨魔事

复次须菩提。有诸恶魔复以名字因缘坏乱诸菩萨摩诃萨。云何为名字因缘。所谓恶魔化诸异相。或时来诣彼菩萨所作如是言。菩萨当知。汝父如是名母如是名。余亲里朋友各各如是名字。乃至七世大祖父母各如是名。汝于某方某处某国某城。某族所生其。姓某氏。又复若性柔软刚猛。性缓性急根利根钝。恶魔即时一一能说。又作是言。汝于先世亦曾修习头陀功德。所谓受阿啰拏法。常行乞食着粪扫衣。饭食已后不复饮浆。常一坐食常随敷座。但持三衣住尸陀林。坐于树下坐于空地。常节量食常坐不卧。具修如是头陀功德。又复少语喜足远离愦闹。若语言时柔软可爱。乃至不受涂足油等。汝于先世具修如是种种功德。今世亦有如是功德见法知法。汝已决定于先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记。安住不退转地。何以故。汝已具有诸功德故。汝既具足如是功德相貌。是故应知于先佛所已得授记。尔时菩萨闻是语已即作是念。我已从彼先佛如来应供正等正觉所。得授阿耨多罗三藐三菩提记已。是安住不退转者。何以故。今此所说我有如是头陀功德诚无异故。是时恶魔知彼心所念已。又复别化种种异相。所谓苾刍苾刍尼优婆塞优婆夷婆罗门长者。乃至菩萨父母兄弟亲里朋友。随所化已住菩萨前咸作是言。汝从先佛如来应供正等正觉所。已得授阿耨多罗三藐三菩提记已。住不退转地。何以故。汝已具足如是功德相貌故。须菩提。彼菩萨闻诸化人如是语已。不能觉知是魔所化。即时起增上慢及诸慢心。由慢心故增长贡高。以贡高故轻易恶贱诸余菩萨。自谓已从先佛得记。余诸菩萨悉所未得从佛授记。由此因缘远离佛无上智自然智一切智一切智智。乃至远离阿耨多罗三藐三菩提。菩萨于此若不亲近诸善知识。不得善法而为开导。为诸恶友共所护助于自身心又复不具善巧方便。增上慢心转复坚固。是菩萨于二地中随堕一处。若声闻地若缘觉地。须菩提。我先所说不退转菩萨摩诃萨真实相貌。而此菩萨不能成就不能安住。不得般若波罗蜜多力所护助。由此因缘为魔所缚。须菩提。是故当知斯亦名为菩萨魔事

复次须菩提。有诸恶魔复以名字因缘坏乱诸菩萨摩诃萨。此复云何。所谓恶魔或时化现诸苾刍相。来菩萨所作如是言。汝当得阿耨多罗三藐三菩提时名字如是。而彼苾刍所说名字。与其菩萨本所愿乐得菩提时名字无异。是菩萨以无智故。又复不具善巧方便。闻此语已即作是念。今此苾刍快哉所说。我得阿耨多罗三藐三菩提时名字。如我所愿无异无别。我今无复起诸疑惑。是时菩萨作是念已。随魔所化苾刍语言而生信受。以是因缘为魔所著。魔所著故起增上慢及诸慢心。由慢心故增长贡高。以贡高故轻易恶贱诸余菩萨。自谓已从先佛得记。余诸菩萨悉所未得从佛受记。由此因缘远离佛无上智自然智一切智一切智智。乃至远离阿耨多罗三藐三菩提。菩萨于此若不亲近诸善知识。不得善法而为开导。为诸恶友共所护助。于自身心又复不具善巧方便增上慢心。转复坚固。是菩萨于二地中随堕一处。若声闻地若缘觉地。须菩提。我先所说不退转菩萨摩诃萨真实相貌。而此菩萨不能成就不能安住。不得般若波罗蜜多力所护助。由此因缘为魔所缚。须菩提。是菩萨应当悔舍如先所起种种慢心。菩萨设能悔是心已。亦复久久堕生死中。若复后时得善知识而为开导。还因般若波罗蜜多故。渐能趣向阿耨多罗三藐三菩提何以故。菩萨起诸慢心罪极重故。譬如苾刍犯四根本最极重罪若一若二。即非沙门非释种子。菩萨以名字因缘起诸慢心。其所获罪亦复如是。须菩提。且置是四根本罪。当知所有五无间罪最极深重。若菩萨以名字因缘起诸慢心者。其所获罪过复深重。而此菩萨是即名为大无方便。不能如应觉了魔事。须菩提。是故当知彼诸恶魔。能以如是微细因缘。作彼魔业坏乱诸菩萨摩诃萨。菩萨于此应当觉知觉已远离

复次须菩提。若菩萨摩诃萨厌彼愦闹乐欲远离时。诸恶魔即化异相。来菩萨所作如是言。若远离者应当往彼山岩树下空寂旷野。如是修习是真远离。此远离行佛所称赞。须菩提。我不说诸菩萨摩诃萨住山岩树下空寂旷野。是真远离。须菩提白佛言。世尊。若菩萨摩诃萨住山岩树下空寂旷野不名远离者。复有何相说名菩萨摩诃萨是真远离。佛告须菩提言。若菩萨摩诃萨行般若波罗蜜多有善巧方便。为一切众生行大慈大悲行。远离声闻缘觉之心。虽近聚落亦名远离。或在山岩树下空寂旷野亦名远离。须菩提。诸菩萨摩诃萨若能远离声闻缘觉心者是真远离。如是远离我所听许。菩萨应当于昼夜中。常修如是真远离行。须菩提。若如恶魔所赞。菩萨但住山岩树下空寂旷野为远离者。而彼菩萨虽如是远离。不能远离声闻缘觉之心非真远离虽修般若波罗蜜多。不能圆满一切智智。当知是为杂乱行者。身语心业不得清净。无慧方便无大悲行。由自三业不清净故。而返于彼近聚落住者生轻慢心。须菩提。彼菩萨虽近聚落非杂乱行。何以故。以能远离声闻缘觉心故。身语心业皆悉清净。有慧方便具大悲行。虽近聚落是真远离。若于如是修真远离行者返生轻慢。当知是菩萨虽得禅定解脱神通智慧三昧等法。而亦不具善巧方便。须菩提。菩萨虽在百由旬外旷野空寂等处。纵经一岁百岁乃至百千俱胝那庾多岁。设过是岁修远离行终无利益。如我所说真远离行彼不能知。不能深固安住阿耨多罗三藐三菩提心。无善巧方便但以寂静为真远离。若求佛道者贪着依止。如是远离我不听许。亦不能令我心生喜。何以故。如我所说远离行中即不见有如是远离行人名真远离。又须菩提。有诸恶魔见彼住空寂处修远离行者。即到其所于虚空中作如是言。善哉善哉。善男子。汝所修者真远离行。如来称赞汝修是行故。令汝速得阿耨多罗三藐三菩提。是菩萨闻空中声所称赞已。从彼空寂旷野等处来至聚落。见余菩萨柔和善顺修持梵行。远离声闻缘觉之心三业清净者。即起轻慢作如是言。汝等是为愦闹行者。汝所修行非远离行。须菩提。彼住空寂菩萨以真远离行为愦闹行。以愦闹行为真远离行。以其过恶故所应恭敬者而返轻慢。不应恭敬者而返恭敬。何以故。彼作是念。我住空寂旷野等处有诸非人念我故来助我故来。汝近聚落住者。何有非人来助念汝。作是念已于余菩萨起轻慢心。须菩提。当知此人是为菩萨中旃陀罗。菩萨中过恶者。菩萨中污行者。是为形像菩萨。亦名贼住沙门。亦名沙门形贼。亦名不净法者。亦名非礼法者。以是相故当知是为初发心者。是故一切世间诸天人等所不恭敬。何以故。我说彼人是增上慢者。须菩提。菩萨摩诃萨于如是人不应亲近。又须菩提。若诸菩萨摩诃萨不舍一切众生爱乐一切智。深发阿耨多罗三藐三菩提心。为欲成就阿耨多罗三藐三菩提。利益安乐一切众生者。不应亲近如是等人。须菩提。求菩提者于诸魔事常应觉知觉已远离。于一切时常生厌离怖三界心。但为利乐一切众生。引示众生所有正道。令诸众生圆满正果住法实性。又复于诸众生起大慈心大悲心大喜心大舍心。菩萨常作是愿。愿我当于一切时一切处远离如是一切魔事。设或暂起速令除灭。须菩提。若菩萨摩诃萨能如是学者。是菩萨摩诃萨神通智力。须菩提当知如是等皆说菩萨摩诃萨觉知魔事真远离相

    善知识品第二十二之一

尔时世尊告尊者须菩提言。若菩萨摩诃萨深心欲得阿耨多罗三藐三菩提者应当亲近恭敬诸善知识。须菩提白佛言。世尊。有诸菩萨摩诃萨深心欲得阿耨多罗三藐三菩提。若能爱乐善知识者。云何是菩萨摩诃萨善知识耶。佛言。须菩提。当知诸佛如来是菩萨善知识。何以故。诸佛能说菩萨行法及诸波罗蜜多。教示菩萨入般若波罗蜜多。是故诸佛如来为菩萨善知识。又须菩提。般若波罗蜜多是菩萨善知识。何以故。般若波罗蜜多是诸波罗蜜多毕竟处。以般若波罗蜜多为菩萨善知识故。即六波罗蜜多皆为菩萨善知识。又复六波罗蜜多是菩萨大师。六波罗蜜多为所行正道。六波罗蜜多为世间光明六波罗蜜多为大法炬。六波罗蜜多为大法光明。六波罗蜜多为真救护。六波罗蜜多为所归趣。六波罗蜜多为所住舍。六波罗蜜多为究竟道。六波罗蜜多为大洲渚。六波罗蜜多为父为母。乃至阿耨多罗三藐三菩提。皆因六波罗蜜多故而能成就。又须菩提。所有过去诸佛如来应供正等正觉。已得阿耨多罗三藐三菩提已入涅盘者。是诸如来皆从六波罗蜜多生。所有未来诸佛如来应供正等正觉。当得阿耨多罗三藐三菩提者。是诸如来亦从六波罗蜜多生。于今现在十方无量阿僧祇世界。教化众生诸佛如来应供正等正觉。今得阿耨多罗三藐三菩提者。是诸如来亦从六波罗蜜多生。又三世诸佛一切智亦从六波罗蜜多生。何以故。诸佛本行菩萨道时皆修习是六波罗蜜多。三十七菩提分法。四无量行。四摄法。乃至一切佛法故。得阿耨多罗三藐三菩提。是诸佛法皆从六波罗蜜多生。又佛智自然智。不可思议智。不可称量智。无等智无等等智。亦复从是六波罗蜜多生。须菩提。是故六波罗蜜多为菩萨善知识。六波罗蜜多为菩萨大师。为所行正道。为世间光明。为大法炬。为大法光明。为真救护。为所归趣。为所住舍。为究竟道。为大洲渚。为父为母。乃至出生阿耨多罗三藐三菩提又须菩提。若菩萨摩诃萨为欲利益安乐一切众生者。应学是六波罗蜜多。若欲学是诸波罗蜜多者。应当于此般若波罗蜜多如理修学。解了其义如实思惟如实观察何以故。般若波罗蜜多与五波罗蜜多而为先导开示显了故。又五波罗蜜多若离般若波罗蜜多。即不得波罗蜜多名。是故须菩提。菩萨摩诃萨若欲不起他信不随他语者。应当修学是般若波罗蜜多。须菩提白佛言。世尊。何等相是般若波罗蜜多。佛言。须菩提。无著相是般若波罗蜜多。须菩提言。颇有因缘如般若波罗蜜多无著相。一切法亦无著相耶。佛言。须菩提。有因缘如般若波罗蜜多无著相。一切法亦无著相。何以故。须菩提。一切法空故离故。是故须菩提。如一切法无著相空故离故。般若波罗蜜多无著相亦空亦离

须菩提白佛言。世尊。若一切法空故离故者。云何佛说一切众生有染有净。世尊。空法中无染无净。离法中无染无净。世尊。即此空法离法不可得。阿耨多罗三藐三菩提异此空法离法。亦无法可得阿耨多罗三藐三菩提。世尊。我今不能解如是义。愿佛世尊。为我宣说

佛言。须菩提。于汝意云何。一切众生于长夜中着我我所不。须菩提言。如是世尊。众生长夜着我我所。佛言。须菩提。于汝意云何。我我所空不。须菩提言。如是世尊。我我所空。佛言。须菩提。于汝意云何。众生着我我所故轮转生死不。须菩提言。如是世尊。众生着我我所故轮转生死。佛言。须菩提。当知诸染法者。但随众生所受所著故说名为染。若诸众生不受不着。即无染可得亦无受染者。是故无我我所。以无我我所故说名为净。若诸众生不受不着。亦无净可得亦无受净者。须菩提。以是义故于一切法空中一切法离中。说名为染说名为净。须菩提。诸菩萨摩诃萨行般若波罗蜜多者应如是行。须菩提白佛言。希有世尊。善说斯义。于一切法空中一切法离中。说染说净不受不着。菩萨摩诃萨行般若波罗蜜多者应如是行。世尊。若菩萨摩诃萨如是行者。是为不行色不行受想行识。若菩萨摩诃萨如是行者。普令一切世间天人阿修罗等所共敬伏。不为彼等而能动乱。又菩萨摩诃萨若如是行者。不杂声闻缘觉行。不住声闻缘觉地。何以故。如是行者是无所行而行无所住而住。能入佛性入如来性自然智性一切智性。世尊。如是行者最上无胜。与般若波罗蜜多胜行相应。是故诸菩萨摩诃萨于昼夜中如是勤行。即能近阿耨多罗三藐三菩提。乃至速能成就阿耨多罗三藐三菩提

佛说佛母出生三法藏般若波罗蜜多经卷第十九佛说佛母出生三法藏般若波罗蜜多经卷第二十

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    善知识品第二十二之二

尔时世尊告尊者须菩提言。如是如是。须菩提。菩萨摩诃萨行般若波罗蜜多。若如是行者是为不行色不行受想行识。如是行者普令一切世间天人阿修罗等所共敬伏。不为彼等而能动乱。如是行者不杂声闻缘觉行。不住声闻缘觉地。如是行者是无所行而行无所住而住。能入佛性入如来性自然智性一切智性。如是行者最上无胜。与般若波罗蜜多胜行相应。若诸菩萨摩诃萨于昼夜中如是勤行。即能近阿耨多罗三藐三菩提。乃至速能成就阿耨多罗三藐三菩提。又须菩提。假使阎浮提中一切众生一一皆得人身。悉发阿耨多罗三藐三菩提心。发是心已乃至尽寿。尊重恭敬供养诸佛。又复普于一切广行布施。即以如是布施功德。回向阿耨多罗三藐三菩提。须菩提。此诸人等以是因缘得福多不。须菩提言。甚多世尊。甚多善逝。佛言。须菩提。此诸人等以是因缘得福虽多。不如菩萨摩诃萨。能一日中起般若波罗蜜多相应正念。随其菩萨所起般若波罗蜜多相应正念故。能为一切众生作大福田。何以故。菩萨能起平等慈心。余诸众生无有是心如菩萨摩诃萨者。唯除如来慈心具足。所以者何。诸佛如来应供正等正觉。已能圆满不思议法。而常不离慈悲喜舍。须菩提。云何菩萨能为众生作大福田。须菩提。所谓菩萨因般若波罗蜜多故具足正慧。得是慧已见诸众生。如在牢狱受彼系缚。菩萨尔时得大悲心所护助故。即复以净天眼普遍观察无量无数无边众生。见有众生造无间业者。当受苦报堕诸见网不得出离。菩萨如是观已。深发大慈心大悲心怜愍众生以是大慈大悲光明普遍照耀。而彼菩萨作如是念。我当为一切众生作大依怙。广为一切众生解脱诸苦。作是念已不住是相亦不住余相。须菩提。此名菩萨摩诃萨大慧光明。是即能为众生作大福田。若菩萨摩诃萨如是行者。即不退转于阿耨多罗三藐三菩提。堪受一切世间信心所施。谓饮食衣服卧具医药。菩萨虽复受施。以一心修习般若波罗蜜多故。于彼施者受者及其所施皆悉清净得近一切智。是故须菩提诸菩萨摩诃萨若欲不虚受其国中信施。若欲引示众生所行正道。若欲救度众生脱三界缚。若欲拔济众生出轮回苦。若欲开导众生清净慧眼者。应当发起般若波罗蜜多相应正念。若起是念即与般若波罗蜜多言说相应。何以故。菩萨有所言说皆随顺般若波罗蜜多念。若有所念亦随顺言说。即得不离般若波罗蜜多。是故菩萨于昼夜中不应离是般若波罗蜜多相应正念。须菩提。譬如有人得未曾有大摩尼宝。得是宝已心大欢喜。后于异时或有因缘而失此宝。须菩提。彼人以是缘故心生愁恼。忧苦追悔常作是念。我今何故失此大宝。如是思念无有间断。须菩提。菩萨亦复如是。大法宝者所谓般若波罗蜜多。菩萨得是般若波罗蜜多大法宝故。常起般若波罗蜜多相应正念。常不离一切智心。须菩提白佛言。世尊。若一切法自性空故离故。一切念亦空亦离者。云何佛说菩萨摩诃萨常不离般若波罗蜜多相应念耶。佛言。须菩提。若菩萨摩诃萨能如是知一切法自性空故离故。一切念亦空亦离者。即是般若波罗蜜多相应正念。即是不离一切智心。何以故。般若波罗蜜多空中无增无减故。须菩提白佛言。世尊。般若波罗蜜多空中无增无减者。菩萨摩诃萨云何能增长般若波罗蜜多。云何得阿耨多罗三藐三菩提耶。佛告须菩提言。若菩萨摩诃萨行般若波罗蜜多时。于是中有增有减。即般若波罗蜜多空中亦增亦减。若菩萨摩诃萨空中无增无减者。即般若波罗蜜多空中亦无增无减。须菩提。菩萨摩诃萨空中无所增减故。菩萨摩诃萨以是无增减法得阿耨多罗三藐三菩提。须菩提。若菩萨摩诃萨闻是说已不惊不怖者。当知是菩萨摩诃萨名为行般若波罗蜜多。须菩提言。般若波罗蜜多相是行般若波罗蜜多不。佛言。不也须菩提。须菩提言。般若波罗蜜多空相是行般若波罗蜜多不。佛言。不也须菩提。须菩提言。离般若波罗蜜多空相有法可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。空可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。离空有法可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。空可行空不。佛言。不也须菩提。须菩提言。色可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。受想行识可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。离色有法可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。离受想行识有法可行般若波罗蜜多不。佛言。不也须菩提。须菩提言。菩萨摩诃萨当云何行是行般若波罗蜜多。佛言。须菩提。汝见有法可行般若波罗蜜多不。须菩提言。不也世尊。佛言。须菩提。汝见般若波罗蜜多。是菩萨摩诃萨所行处不。须菩提言。不也世尊。佛言。须菩提。若法无所得即法不可见。是中有生可生有灭可灭不。须菩提言。不也世尊。佛言。须菩提。若菩萨摩诃萨了如是相即得无生法忍。菩萨摩诃萨具是忍者。即得授阿耨多罗三藐三菩提记。须菩提。此名如来无所畏行。菩萨摩诃萨若如是行。即得佛无上智广大智最上利智一切智智。如是行者是无处所行。须菩提白佛言。世尊。以是无生法可得授阿耨多罗三藐三菩提记不。佛言。不也须菩提。须菩提言。当以何法得授阿耨多罗三藐三菩提记。佛言。须菩提。汝见有法可得授阿耨多罗三藐三菩提记不。须菩提言。不也世尊。佛言。须菩提。汝见有阿耨多罗三藐三菩提是所记不。须菩提言。我不见是法有所记别。亦复不见有授记法。何以故。一切法无所得故。世尊。以是义故。我知一切法无证是中无证者。一切法无得是中无所得

    帝释天主赞叹品第二十三

尔时帝释天主在大会中。即从座起前白佛言。世尊。如佛所说般若波罗蜜多最上甚深。难可得见难可得闻。亦复于中难解难入。佛告帝释天主言。憍尸迦。如是如是。般若波罗蜜多最上甚深。难见难闻难解难入。憍尸迦。如虚空甚深故般若波罗蜜多亦甚深。虚空空故般若波罗蜜多亦空。虚空离故般若波罗蜜多亦离。虚空难见故般若波罗蜜多亦难见。虚空难解故般若波罗蜜多亦难解。帝释天主白佛言。世尊。若有人得是甚深般若波罗蜜多法门。听受读诵为人演说乃至书写者。当知是人具足最上善根。佛言。憍尸迦。如是如是。若有人得此甚深般若波罗蜜多法门。听受读诵为人演说乃至书写者。我说是人已能具足最上善根。憍尸迦。于汝意云何。正使阎浮提一切众生皆得人身。一一众生具修十善。彼诸善男子善女人等。以是缘故得福多不。帝释天主言。甚多世尊。甚多善逝。佛言。憍尸迦。彼善男子善女人得福虽多。不如有人于此甚深般若波罗蜜多法门。听受读诵为人演说乃至书写者。百分不及一。千分不及一。百千俱胝那庾多分。算分数分及譬喻分。乃至乌波尼杀昙分皆不及一尔时会中有一苾刍。闻是说已谓帝释天主言。若有善男子善女人。暂得闻此甚深般若波罗蜜多法门。而能一念生净信者。当知是善男子善女人胜过仁者。是时帝释天主谓彼苾刍言。若善男子善女人。一发心顷生净信者尚胜于我。何况广能听受读诵为人演说乃至书写。又复何况随听受已。如所说学如所说行修习相应。当知是善男子善女人修菩萨行。胜过一切世间天人阿修罗等。苾刍非但胜彼一切世间天人阿修罗等。亦复胜于须陀洹斯陀含阿那含阿罗汉及其缘觉。非但胜于须陀洹乃至缘觉。亦复胜余菩萨远离般若波罗蜜多无善巧方便行布施者。非但胜彼菩萨如是布施。亦复胜余菩萨远离般若波罗蜜多无善巧方便持净戒者。非但胜彼菩萨如是持戒。亦复胜余菩萨远离般若波罗蜜多无善巧方便修忍辱者。非但胜彼菩萨如是忍辱。亦复胜余菩萨远离般若波罗蜜多无善巧方便发精进者。非但胜彼菩萨如是精进。亦复胜余菩萨远离般若波罗蜜多无善巧方便修禅定者。何以故。是菩萨摩诃萨闻此甚深般若波罗蜜多法门。能如说学能如说行。而能具足善巧方便。是故胜过一切世间天人阿修罗乃至声闻缘觉及余菩萨。当知是菩萨善行般若波罗蜜多。是菩萨能近一切智不远离诸佛。是菩萨成熟善根当坐道场。是菩萨能断众生诸烦恼苦。若菩萨摩诃萨能如是学者。是为学菩萨法不学声闻缘觉法。是学般若波罗蜜多。又菩萨摩诃萨如是学时。当有护世四大天王。来菩萨所作如是言。善男子。汝当精勤疾学是般若波罗蜜多。疾证阿耨多罗三藐三菩提。汝当坐道场时。我等四王各持宝钵奉上于汝。世尊。非但护世四王现菩萨前作如是说。我亦常往彼菩萨所而为护助况复诸余天子。何以故。是菩萨能如是学般若波罗蜜多。学已能行甚为希有。世间众生有诸苦恼。菩萨已能远离诸苦。于一切处作大利乐。世尊。此为菩萨学般若波罗蜜多。现世功德

尔时尊者阿难即作是念。此帝释天主快说是语。为自辩才如是说耶。为佛威神所护念耶。尔时帝释天主承佛威神知其念。即谓言尊者当知。如我所说皆是世尊威神建立

尔时世尊告尊者阿难言。如是如是。如帝释天主此所乐说当知皆是佛威神力而为护念

    增上慢品第二十四

尔时世尊复告尊者阿难言。当知菩萨摩诃萨修般若波罗蜜多时。行般若波罗蜜多时。所有三千大千世界一切恶魔皆生疑念。菩萨摩诃萨修行是般若波罗蜜多。为当中道取证声闻缘觉果耶。为当决定直至阿耨多罗三藐三菩提耶。阿难。彼诸恶魔或时若见菩萨摩诃萨修行般若波罗蜜多故。决定直至阿耨多罗三藐三菩提者。诸魔即时忧愁苦恼如箭入心

复次阿难。菩萨摩诃萨修般若波罗蜜多时。行般若波罗蜜多时。有诸恶魔来菩萨所生娆乱心。以彼魔力化诸雷雹风雨等相。周遍方处欲令菩萨怖畏散乱。乃至欲令菩萨于一念中退失阿耨多罗三藐三菩提心。阿难当知。恶魔不必普能娆乱一切菩萨。阿难白佛言。世尊。何等菩萨为魔所娆。佛言。阿难。若菩萨于先世中。曾得闻是般若波罗蜜多法门。虽复闻已不生信解。阿难当知。是菩萨即有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨摩诃萨闻此甚深般若波罗蜜多法门时心生疑念。有是般若波罗蜜多法门耶。无是般若波罗蜜多法门耶。阿难当知。是菩萨即有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨摩诃萨远离善知识亲近恶知识。以近恶知识故。闻此甚深般若波罗蜜多法门不生信解。又复不能请问其义。但作是念。我今何能修此般若波罗蜜多。阿难当知。是菩萨即有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨摩诃萨受彼邪法随邪法行。彼诸恶魔知是事已心生欢喜。即作是念。此人助我亦令余人同来助我。而复令我圆满所愿随顺我意。阿难当知。是菩萨即有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨摩诃萨闻此甚深般若波罗蜜多法门已。谓余菩萨言。此般若波罗蜜多甚深难解。我尚不能得其源底。汝今何用更修习耶。但于余经佛所说者。听受修习必当于彼而得法味。由此菩萨作是说已。诸余菩萨即起远离般若波罗蜜多心。阿难当知。作是说者即有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨摩诃萨作如是念。我是修真远离行者。余诸菩萨非远离行。即时恶魔知是念已。生大欢喜适悦庆快。何以故。彼菩萨随所起念。即退失阿耨多罗三藐三菩提。以如是退失故魔心生喜。又复阿难。有诸恶魔来菩萨所。称赞菩萨名字族氏。头陀功德乃至种种功德相貌。菩萨闻是称赞已随有所著。起增上慢及诸慢心。贡高自大轻余菩萨。由是因缘增长烦恼。而此菩萨为彼恶魔力所加故。诸有言说人皆信受。随信受已如所说学如所说行。若见若闻如是学者。如是行者皆不真实。以不实故起颠倒心。由是心故身语心业皆不清净。以此因缘而能增长地狱饿鬼畜生等趣。彼恶魔众见是利故。心大欢喜适悦庆快即作是念。今我宫殿诚所不空。由彼因缘能增长故。阿难当知。是菩萨不能具足功德相貌。非行般若波罗蜜多。非是住不退转者。何以故。增上慢心起诸过失。是菩萨当有恶魔而来娆乱。为彼诸魔伺得其便

复次阿难。若菩萨乘人与声闻乘人共相斗诤。互出恶言轻易呵毁。尔时恶魔知是事已即作是念。彼菩萨乘人由此因缘虽复远离一切智。其所远离非大非久。若菩萨乘人与菩萨乘人共相斗诤。互出恶言轻易呵毁者。尔时恶魔知是事已。心大欢喜适悦庆快而作是念。此菩萨乘人由是因缘。久久远离彼一切智

复次阿难。若有未得授记菩萨。于余已得授记菩萨起嗔恨心。随所起心有退转失。起一念退一劫而后毕是随念劫数。若不舍一切智心。或遇善知识故还复发起被精进铠

尔时尊者阿难白佛言。世尊。若起是罪者佛听悔不。佛言阿难。今我法中说有出罪法。所有声闻缘觉菩萨乘中。我各说有彼出罪法。阿难当知。若菩萨乘人与菩萨乘人共相斗诤。互出恶言轻易呵毁已。不相悔舍复怀嗔恨结缚于心者。我不说彼有出罪法。阿难。若菩萨乘人与菩萨乘人共相斗诤。乃至呵毁已即相悔舍者。我当为彼说出罪法阿难。又菩萨应作是念。我于一切众生当行慈忍。设彼起恶来相陵辱。我尚不生一念嗔心况复加报。我或暂起嗔恨心者深为大失。何以故。我当为一切众生作大桥梁普令得度。我常于彼一切众生如善作意。设闻恶言不生恚心。于自于他皆悉平等。自有过失勿加于他。他有过失如自所作常生悔惧。何以故。我欲普令一切众生得大安乐。若有众生多嗔恼者。愿我当得阿耨多罗三藐三菩提时。度脱彼等。我于一切处见彼所有求菩提者。我于尔时欢喜瞻视。面目熙怡无颦蹙相。我心坚固不为一切嗔恼所动。阿难。若菩萨乘人能生如是心者。当知是为修菩萨行者。又复阿难。诸菩萨摩诃萨于声闻人所不应生起诸轻慢心。乃至一切众生亦复不应生轻慢想。阿难白佛言。世尊。菩萨与菩萨云何共住。佛言阿难。菩萨共住当互观视犹如佛想。是我大师同载一乘同行一道。彼菩萨摩诃萨若有所学我亦随学。平等安住菩萨乘中。如菩萨法如理修学。彼若杂学非我所学。彼若清净学能与一切智如理相应者。我亦如是学。阿难。菩萨摩诃萨能如是学者。是为同学所应共住。如是学者必证阿耨多罗三藐三菩提

佛说佛母出生三法藏般若波罗蜜多经卷第二十佛说佛母出生三法藏般若波罗蜜多经卷第二十一

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    学品第二十五

尔时尊者须菩提白佛言。世尊。菩萨摩诃萨欲学一切智当云何学。佛言。须菩提。菩萨摩诃萨若尽学则学一切智。若离学则学一切智。若无生无灭无起无染无性。如虚空法界寂静等学则学一切智

须菩提白佛言。世尊。若菩萨摩诃萨尽学离学乃至法界寂静等学。则学一切智者。是等当云何作。佛言。须菩提。汝若如是说是等云何作者。须菩提。于汝意云何。如来证如如故得名如来。是如有尽有所作不。须菩提言。不也世尊。何以故。如无尽相亦无所作。佛言。须菩提。于汝意云何。如来证如如故得名如来。是如有生有灭有起有染有得有证不。须菩提言。不也世尊。佛言。须菩提。菩萨摩诃萨学一切智亦复如是。须菩提。是故菩萨摩诃萨若如是学者不尽如相。如是学者是学一切智。如是学者是学般若波罗蜜多。如是学者是学佛地。如是学者是学佛十力四无所畏等一切佛法乃至一切智智。如是学者能到诸学彼岸。如是。学者普能降伏魔及魔众。如是学者速得不退转法。如是学者速坐道场。如是学者是学三转十二行相法轮。如是学者学自所行。如是学者学为他作所依怙法。如是学者是学大慈大悲大喜大舍。如是学者学度众生界如是学者是学不断佛种。如是学者学开甘露门。须菩提。此广大学是最上学。凡夫下劣人不能如是学。若有能调御一切众生。欲与一切众生为依怙者。欲出过一切众生界者彼能如是学。若如是学者不堕地狱饿鬼畜生等趣。不生阿修罗界。不生边地。不生旃陀罗族。不生下姓种族。不生种种卑贱巧业等族。如是学者不失一目不盲两目。亦不角睐。不聋不哑不伛偻不挛躄。不丑陋不粗恶不形残不异相。亦无疥癞痈疽干痟等病。不坏诸根人相圆满。音声清巧众所爱乐。须菩提。又菩萨摩诃萨如是学者。不害他命不盗他物。不行邪染不虚妄言。亦不两舌复不恶口。不无义语。不生贪着。不起嗔恼。不住邪见。不邪命活。不修邪命法。不畜破戒眷属。不近非法者。不生长寿天。虽入诸禅而不随禅生。何以故。菩萨以能成就善巧方便故。而菩萨成就何等善巧方便。所谓从般若波罗蜜多相应出生善巧方便。是故菩萨虽入诸禅而不随禅生。须菩提。菩萨摩诃萨能如是学者即得清净十力清净四无所畏乃至清净一切佛法

须菩提白佛言。世尊。一切法自性本来清净。菩萨摩诃萨云何复得清净十力清净四无所畏乃至清净一切佛法耶。佛告须菩提言。如是如是。须菩提。一切法自性本来清净。菩萨摩诃萨于是一切法自性本来清净中。如理修学般若波罗蜜多。不惊不怖不退不没。须菩提。彼诸愚异生等于如是法不知不见。以不知不见故无所觉了。是故菩萨摩诃萨发勤精进于中修学。自所学已令诸异生等于是法中如理修学实知实见。菩萨摩诃萨由如是学故。即得清净十力清净四无所畏乃至清净一切佛法。须菩提。菩萨摩诃萨如是学者。悉能了知一切众生心心所行。须菩提。譬如大地少出阎浮檀金多诸荆棘砂砾草木等类。一切众生亦复如是。于众生聚中少能爱乐修学般若波罗蜜多者。多有爱乐修学声闻缘觉法门。须菩提。又如众生聚中少有修彼轮王业者。但多修彼诸小王业。须菩提当知。众生聚中少有行于般若波罗蜜多道者。多有行于声闻缘觉道者亦复如是

须菩提。又如众生聚中少有修彼帝释福业。但多修彼诸天子业。须菩提当知。众生聚中少有修习般若波罗蜜多行者。多有修习声闻缘觉行者。亦复如是。须菩提。又如众生聚中少有修彼梵王福业。但多修彼诸梵众业。须菩提当知。众生聚中少有不退转于阿耨多罗三藐三菩提者。多有退转于阿耨多罗三藐三菩提者亦复如是。须菩提。以是义故当知众生聚中。少有能发阿耨多罗三藐三菩提心者。于少能发心中又复少能如理修行者。于少能修行中。又复少能修习般若波罗蜜多相应行者。于少能修习相应行中。又复少能于阿耨多罗三藐三菩提住不退转者。须菩提。是故诸菩萨摩诃萨若欲在少中少者应当修习般若波罗蜜多

复次须菩提。若菩萨摩诃萨修学是般若波罗蜜多者。不生杂染心。不生疑惑心。不生憎嫉心。不生悭吝心。不生破戒心。不生嗔恼心。不生懈怠心。不生散乱心。不生愚痴心。又须菩提。菩萨摩诃萨应修学是般若波罗蜜多。何以故。此般若波罗蜜多能护诸波罗蜜多。能受诸波罗蜜多。能取诸波罗蜜多。能集诸波罗蜜多。能摄诸波罗蜜多。须菩提。譬如六十二见身见中摄诸波罗蜜多。于般若波罗蜜多中摄亦复如是。须菩提。又如士夫所有诸根。皆悉于其命根中摄。一切善法皆于般若波罗蜜多中摄。亦复如是。须菩提。又如士夫命根灭时诸根皆灭。菩萨摩诃萨亦复如是。若智慧灭时一切善法而亦随灭。须菩提。是故菩萨摩诃萨若欲护诸波罗蜜多。若欲摄诸波罗蜜多者。应当修学是般若波罗蜜多。又菩萨摩诃萨若欲于一切众生中福德最胜为上首者。应当修学是般若波罗蜜多

复次佛言。须菩提。于汝意云何。三千大千世界一切众生是为多不。须菩提白佛言。世尊。但此阎浮提中所有众生尚多无数。何况三千大千世界一切众生。佛言。须菩提。假使如是三千大千世界一切众生。一一修行皆住菩萨地。或有一人尽其寿命。以诸饮食衣服卧具医药及余乐具。供养如是三千大千世界诸菩萨众。此人以是因缘得福多不。须菩提言。甚多世尊。甚多善逝。佛言。须菩提。若复有人于一弹指顷。能修行是般若波罗蜜多者。其所得福倍胜于前。何以故。般若波罗蜜多广大利益诸菩萨摩诃萨复能护助阿耨多罗三藐三菩提故。须菩提。是故诸菩萨摩诃萨若欲于一切众生中最胜无上。若欲与一切众生为所依怙。若欲偏入诸佛境界。若欲具足佛功德法。若欲得佛游戏神通。若欲作佛大师子吼。若欲得佛诸所行处。若欲普以三千大千世界大会说法。须菩提。菩萨摩诃萨若欲成就如是等功德利者。应学是般若波罗蜜多。学是般若波罗蜜多。不能圆满诸功德利者无有是处。须菩提白佛言。世尊。菩萨摩诃萨亦具足声闻功德利耶。佛言。须菩提。菩萨摩诃萨亦学是声闻法。亦具足声闻功德之利。须菩提。菩萨摩诃萨虽如是学如是知得如是利。而不于中生住着心。菩萨摩诃萨亦说彼声闻法而不取是法。须菩提。若菩萨摩诃萨如是学者。能为一切世间天人阿修罗等作大福田。而菩萨所作福田最上最胜。过余声闻缘觉所有福田。须菩提。如是学者是行般若波罗蜜多。得近一切智。不舍般若波罗蜜多。不离般若波罗蜜多。如是学者不退失一切智。远离声闻缘觉心。得近阿耨多罗三藐三菩提。须菩提。若菩萨摩诃萨作是念。此是般若波罗蜜多。此名般若波罗蜜多。学是般若波罗蜜多故当得一切智。须菩提。若如是分别者不名修学般若波罗蜜多。若菩萨摩诃萨于般若波罗蜜多不生分别。无知无见亦无所得。以如是不分别无知见无所得故。是名修学般若波罗蜜多

    幻喻品第二十六

尔时帝释天主即起是念。若菩萨摩诃萨修学是般若波罗蜜多者。尚能胜过一切众生。何况成就阿耨多罗三藐三菩提者。是故当知若有人爱乐一切智者。彼人得大善利善自活命。何况能发阿耨多罗三藐三菩提心者。当知是人为一切众生共所敬爱。普能调御一切众生。帝释天主作是念已。即时化诸曼陀罗华。满自掌中散于佛上。华散佛已合掌向佛作如是言。世尊。若有发阿耨多罗三藐三菩提心者。普愿得成阿耨多罗三藐三菩提。普愿圆满一切佛法。圆满一切智相应之法。圆满自然智法。圆满无漏法。普愿一切众生度生死岸证涅槃道。摄众生心普令圆满。世尊。我见生死中有种种苦。我不欲令初发阿耨多罗三藐三菩提心者。于一念中有所退转。又不欲令已得安住阿耨多罗三藐三菩提者。于一念中或生退转。是故我欲普令成就阿耨多罗三藐三菩提。何以故。能发心者广大利益。悲愍一切世间天人阿修罗等。自得度已复于一切众生起如是心。未解脱者普令解脱。未得度者普令得度。未涅槃者普令涅槃。世尊。若有善男子善女人。于初发心菩萨所。以彼所有诸功德法生随喜心。若于久修习菩萨所生随喜心。若于住不退转菩萨所生随喜心。若于一生补处菩萨所生随喜心。于如是等能生随喜心。善男子善女人。当说何者得福德多

佛告帝释天主言。憍尸迦。妙高山王尚可称量知其限数。彼善男子善女人。以是诸随喜心所获福德。不可称量知其限数

憍尸迦。又如四大洲界。亦可称量知其限数。彼善男子善女人。以是诸随喜心所获福德。不可称量知其限数。憍尸迦。又如小千世界。亦可称量知其限数。彼善男子善女人。以是诸随喜心所获福德。不可称量知其限数。憍尸迦。又如中千世界亦可称量知其限数。彼善男子善女人。以是诸随喜心所获福德。不可称量知其限数。憍尸迦。又如三千大千世界亦可称量知其限数。彼善男子善女人。以是诸随喜心所获福德。不可称量知其限数

帝释天主白佛言。世尊。若有人不能于初发心菩萨所。乃至不能于一生补处菩萨所生随喜心者。当知是人恶魔所著为魔眷属。从彼魔天命终而来生此。何以故。是诸随喜心而能破坏诸恶魔故。又复若人能生诸随喜心者。是人应以随喜功德回向阿耨多罗三藐三菩提。以是回向故而能增长阿耨多罗三藐三菩提。是故当知。能生如是诸随喜心者。是人不离佛不离法不离僧。增长一切最胜功德

佛告帝释天主言。如是如是。憍尸迦。若有人能生如是诸随喜心者。是人不离佛不离法不离僧。增长一切最胜功德。又憍尸迦。若善男子善女人。能生如是诸随喜心者。当知是善男子善女人速得值佛

帝释天主白佛言。如是世尊。如是善逝。善男子善女人。能生如是诸随喜心者。是善男子善女人速得值佛。又复以是随喜善根力故。在在所生人所尊重恭敬赞叹。是善男子善女人。眼根清净不观恶色。耳根清净不闻恶声。鼻根清净不嗅恶香。舌根清净不了恶味。身根清净不染非触。又复不堕恶趣生人天道。何以故。是善男子善女人。成就无量无数随喜善根故。常乐利乐一切众生。以能生是随喜心故。而能增长阿耨多罗三藐三菩提行。渐渐得成阿耨多罗三藐三菩提。是善男子善女人。得菩提已广度无量无数众生普令涅槃

佛告帝释天主言。憍尸迦。如汝所说皆是如来威神护念。若善男子善女人。能生如是诸随喜心者。是善男子善女人深种善根。以是善根广为无量无数众生作大利益。此因缘故而能增长一切善法。渐渐得成阿耨多罗三藐三菩提

尔时尊者须菩提白佛言。世尊。心如幻故。云何以是心得阿耨多罗三藐三菩提耶。佛告尊者须菩提言。于意云何。汝见有心如幻耶。须菩提言。不也世尊。佛言。须菩提。汝见幻相可得耶。须菩提言。不也世尊。我不见有心如幻。亦不见幻相可得。佛言。须菩提。言汝以是心相可得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。佛言须菩提于意云何。若不见有心。如幻。及幻相者。离是心是相。汝见有法可得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。离如幻心及彼幻相。亦不见有法可得阿耨多罗三藐三菩提。世尊。若离如幻心及离幻相有法可见者。是法亦不可说是有是无。是故一切法毕竟离中不可说有不可说无。若一切法毕竟离故。阿耨多罗三藐三菩提亦毕竟离。般若波罗蜜多亦毕竟离。以一切法毕竟离故。即无法可修亦无法可得。以一切法无所得故。阿耨多罗三藐三菩提亦不可得。以是毕竟离故菩萨摩诃萨亦毕竟离。世尊。菩萨摩诃萨因般若波罗蜜多故。得阿耨多罗三藐三菩提。而菩萨摩诃萨毕竟离。阿耨多罗三藐三菩提亦毕竟离。若菩萨摩诃萨得阿耨多罗三藐三菩提者。云何以离得离耶

佛赞须菩提言。善哉善哉。须菩提。如是如是。一切法毕竟离。般若波罗蜜多亦毕竟离。阿耨多罗三藐三菩提亦毕竟离。菩萨摩诃萨亦毕竟离。而诸菩萨摩诃萨于是法中。如实了知般若波罗蜜多毕竟离故。即非般若波罗蜜多。须菩提。是故诸菩萨摩诃萨。虽因般若波罗蜜多故。得阿耨多罗三藐三菩提。而于是中无法可取。无法可得。以无取无得故。菩萨摩诃萨。虽得阿耨多罗三藐三菩提。而非以离得离

须菩提白佛言。世尊。如我解佛所说义。此甚深义菩萨摩诃萨行者是为甚难。佛言。须菩提。如是如是。此甚深义菩萨摩诃萨行者是为甚难。须菩提。若菩萨摩诃萨行此甚深义者。不于中道取证声闻缘觉之果斯为甚难。须菩提白佛言。世尊。如我解佛所说义。菩萨摩诃萨所为非难。何以故。一切法无所得无所证。以无得无证故。是中无证者无所证无所用证法。是故菩萨摩诃萨所为非难。世尊。若菩萨摩诃萨闻作是说。不惊不怖不退不没者。当知彼菩萨摩诃萨。是为行般若波罗蜜多。虽如是行亦不见我行般若波罗蜜多。若如是不见所行般若波罗蜜多相故。是菩萨摩诃萨。得近阿耨多罗三藐三菩提。即能远离声闻缘觉之地。是行般若波罗蜜多。世尊。譬如虚空不作是念。是远是近。何以故。虚空无分别故。般若波罗蜜多亦复如是不作是念。阿耨多罗三藐三菩提去我近。声闻缘觉地去我远。何以故。般若波罗蜜多无分别故。又如幻所化人不作是念。彼幻师去我近余观者去我远。何以故。幻所化人无分别故。般若波罗蜜多亦复如是不作是念。阿耨多罗三藐三菩提去我近。声闻缘觉地去我远。何以故。般若波罗蜜多无分别故。又如诸影不作是念。影所因者去我近。非所因者去我远。何以故。影无分别故。般若波罗蜜多亦复如是不作是念。阿耨多罗三藐三菩提去我近。声闻缘觉地去我远。何以故。般若波罗蜜多无分别故。又如如来于一切众生无憎无爱。何以故。如来一切憎爱断故。般若波罗蜜多亦复如是无憎无爱。何以故。般若波罗蜜多非憎爱法。又如如来离诸分别。何以故。如来一切分别断故。般若波罗蜜多亦复如是离诸分别。何以故。般若波罗蜜多无分别故。又如佛所化人不作是念。阿耨多罗三藐三菩提去我近。声闻缘觉地去我远。何以故。化人无分别故。般若波罗蜜多亦复如是不作是念。阿耨多罗三藐三菩提去我近。声闻缘觉地去我远。何以故。般若波罗蜜多无分别故。又如佛所化人随所作事悉能成办。虽所成办而无分别。何以故。化人无分别故。般若波罗蜜多亦复如是。若一切法随所修习悉能成办。何以故。般若波罗蜜多无分别故。又如工巧师。以其方便用机关木作男女相。随所作事悉能成办。虽所成办而无分别。何以故。巧幻所作故。世尊。般若波罗蜜多亦复如是。若一切法随所修习悉能成办。虽有所成而无分别。何以故。般若波罗蜜多无分别故

佛说佛母出生三法藏般若波罗蜜多经卷第二十一佛说佛母出生三法藏般若波罗蜜多经卷第二十二

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    坚固义品第二十七

尔时尊者舍利子。谓尊者须菩提言。若菩萨摩诃萨。行此甚深般若波罗蜜多者是行坚固义。须菩提言。如是如是。舍利子。菩萨摩诃萨行此甚深般若波罗蜜多者是行坚固义

尔时有欲界千天子众作如是念。菩萨摩诃萨为阿耨多罗三藐三菩提故。行此甚深般若波罗蜜多。虽复了诸法相入诸法性。而不安住声闻缘觉所证实际。以是缘故所应敬礼。尔时尊者须菩提。知其念即谓言诸天子。菩萨摩诃萨行此甚深般若波罗蜜多。而不证彼声闻缘觉实际者亦未足为难。何以故。若菩萨摩诃萨。被精进铠欲度无量无数无边众生。普令安住大般涅槃斯为难事。所以者何。众生毕竟离故无所有。以无所有故不可得众生相。是故众生不可得度。诸天子。若菩萨欲度众生者为欲度虚空。何以故。虚空离故众生亦离。虚空无所有故众生亦无所有。毕竟无有众生可得。诸菩萨摩诃萨。为欲度者是为难事。诸天子。如人与彼虚空共斗佛说众生相不可得亦复如是。何以故。众生离故色亦离。众生离故受想行识亦离。众生离故乃至一切法亦离。诸天子。若菩萨摩诃萨闻作是说。不惊不怖不退不没者。当知是为行般若波罗蜜多。尔时世尊。告尊者须菩提言。何因缘故。菩萨摩诃萨闻作是说。不惊不怖不退不没耶。须菩提言。一切法离故不没。何以故。世尊。没者不可得没法不可得。而所没处亦不可得。以是因缘菩萨摩诃萨闻作是说。不惊不怖不退不没。佛言。须菩提。如是如是。若菩萨摩诃萨闻作是说。不惊不怖不退不没者。是行般若波罗蜜多

须菩提白佛言。世尊。若菩萨摩诃萨。修行是般若波罗蜜多者。常得大梵天王。帝释天主。大自在天。并余欲界诸天子众。尊重恭敬顶礼称赞佛言。须菩提。非但大梵天王帝释天主。大自在天。并余欲界诸天子众。尊重恭敬顶礼称赞。所有梵众天。梵辅天。大梵天。少光天。无量光天。光音天。少净天。无量净天。遍净天。无云天。福生天。广果天。无烦天。无热天。善见天。善现天。色究竟天。如是等天上诸天子众。亦常尊重恭敬顶礼称赞。是修行般若波罗蜜多菩萨摩诃萨。又十方无量阿僧祇世界。诸佛如来应供正等正觉现住说法者。常以佛眼观察是修行般若波罗蜜多菩萨摩诃萨。又复以佛威神常所护念。须菩提。是菩萨摩诃萨。以修行般若波罗蜜多故。即得不退转于阿耨多罗三藐三菩提。诸恶魔众伺不得便。须菩提。假使三千大千世界所有众生。一一皆化作诸恶魔。是诸魔众亦复不能于彼修行般若波罗蜜多菩萨摩诃萨所伺得其便。又须菩提。且置是三千大千世界。如前所说。假使如兢伽沙数世界一切众生。一一皆化作诸恶魔。是诸魔众亦复不能于彼修行般若波罗蜜多菩萨摩诃萨所伺得其便。须菩提当知。修行般若波罗蜜多菩萨摩诃萨。成就二法不为诸魔伺得其便。何等为二。所谓观一切法空。不舍一切众生。是为二法。须菩提。复有二法。菩萨摩诃萨能成就故。不为诸魔伺得其便。何等为二。所谓如说能行。诸佛称赞。是为二法。又须菩提。若菩萨摩诃萨。如是行般若波罗蜜多者。有诸天子常来其所。瞻礼恭敬作如是言。善男子。汝速修行是般若波罗蜜多。速证阿耨多罗三藐三菩提。何以故。善男子。汝修行是般若波罗蜜多故。能与无依众生而作依怙。无救众生而为救度。无归众生为作所归。无舍众生为作住舍。无趣众生而为作趣。无洲众生而为作洲。不识毕竟道者为示毕竟道。不识正道者为示正道。在黑闇者为作光明。菩萨摩诃萨行般若波罗蜜多者。成就如是功德。须菩提。又菩萨摩诃萨行是般若波罗蜜多者。现在十方无量阿僧祇世界诸佛世尊。与彼菩萨声闻大众围绕演说法时。常所称赞是菩萨所有功德。及其名字族氏色相威力。须菩提。如我今时集会说法。常所称赞阿閦佛刹中。宝幢菩萨及彼刹中余诸菩萨修梵行者。所有功德名字族氏色相威力。须菩提。诸佛刹中亦复如是。彼彼佛会演说法时。亦常称赞我刹土中修行般若波罗蜜多者。及余菩萨修梵行者所有功德名字族氏色相威力。须菩提白佛言。世尊。诸佛世尊演说法时。普皆称赞诸菩萨摩诃萨所有功德名字族氏色相威力耶。佛言。不也须菩提。诸佛世尊演说法时。于诸菩萨摩诃萨。有称赞者有不称赞者。须菩提言。何等菩萨是称赞者。佛言。须菩提。所有住不退转菩萨摩诃萨。诸佛世尊常所称赞。须菩提言。若未住不退转者。诸佛世尊所称赞不。佛言。须菩提。有菩萨摩诃萨。虽未安住不退转地。诸佛世尊亦常称赞。彼复云何。所谓菩萨摩诃萨。若学阿閦如来本为菩萨时所行道法者。是菩萨虽未安住不退转地。亦为诸佛常所称赞。又须菩提。若菩萨摩诃萨。学宝幢菩萨所行道法者。是菩萨虽未安住不退转地。亦为诸佛常所称赞。又须菩提。若菩萨摩诃萨行般若波罗蜜多故。信解一切法无生。而未能证得无生法忍。又信解一切法寂静。而于不退转地中。未能自在得一切法寂静。是菩萨亦为诸佛常所称赞。又须菩提。若菩萨摩诃萨得诸佛世尊共所称赞者。必当安住不退转地。远离声闻缘觉之心。决定得授阿耨多罗三藐三菩提记。何故菩萨摩诃萨。得彼诸佛共称赞耶。为菩萨摩诃萨能行是般若波罗蜜多故

复次须菩提。若菩萨摩诃萨闻此甚深般若波罗蜜多。不疑不悔不难不没者。是菩萨摩诃萨。当于阿閦如来应供正等正觉所。及彼刹中诸菩萨所。亦得闻是般若波罗蜜多法门。闻已信解随信解已得不退转。须菩提。若有闻是法门生信解者尚获如是功德。何况若能随所信解。如理安住如理而行。如如所住住一切智。须菩提白佛言。世尊。离如无法可得。当以何法于如中住。当以何法得阿耨多罗三藐三菩提。当以何法可说。佛言。须菩提。如汝所说离如无法可得。当以何法于如中住。当以何法得阿耨多罗三藐三菩提。当以何法可说者。如是如是。须菩提。离如无法可得。于如中住如尚不可得。何况有住如者。如中尚无阿耨多罗三藐三菩提。何况。有证者。是故无所证无证者无所用证法。如中尚无法可得。何况有说法者

尔时帝释天主白佛言。世尊。般若波罗蜜多最上甚深。若菩萨摩诃萨。为欲成就阿耨多罗三藐三菩提故。若闻是说无法可住无法可证无法可说。于是中不疑不悔不难不没者。当知是菩萨摩诃萨所为甚难。时尊者须菩提。即谓帝释天主言。憍尸迦。如汝所言。菩萨摩诃萨若闻此甚深法。不疑不悔不难不没是为甚难者。憍尸迦。于一切法空中有何法可得疑悔难没耶。帝释天主。白尊者须菩提言。尊者有所乐说皆因于空。而于是中亦无所碍。譬如仰射虚空箭去无碍。尊者所说无碍亦然。帝释天主作是说已即白佛言。世尊。如我所说是随如来说是随法语答不。佛告帝释天主言。憍尸迦。如是如是。如汝所说。是随如来说名为正说。是随法语答名为正答。憍尸迦。彼须菩提有所乐说皆因于空。而般若波罗蜜多尚不可得。何况有行般若波罗蜜多者。阿耨多罗三藐三菩提尚不可得。何况有证阿耨多罗三藐三菩提者。一切智尚不可得。何况有证一切智者。真如尚不可得。何况有住如者。无生法尚不可得。何况有证无生者。菩萨尚不可得。何况有求菩提者。十力尚不可得。何况有具是力者。四无所畏尚不可得。何况有成就无所畏者。法尚不可得。何况有说法者。憍尸迦。彼须菩提如是乐行一切法远离。行一切法无所得行。须菩提。行如是行。比诸菩萨摩诃萨行般若波罗蜜多行。百分不及一。千分不及一。百千分不及一。俱胝分不及一。百千俱胝分不及一。百千俱胝那庾多分不及一。算分数分及譬喻分。乃至乌波尼杀昙分皆不及一。憍尸迦。唯除如来所行。余诸菩萨摩诃萨。行是般若波罗蜜多行者。于一切行中最上最大最胜最妙。无上中无上无等无等等。非一切声闻缘觉而能等比。是故憍尸迦。若善男子善女人。欲于一切众生中。最上最大最胜最妙。无上中无上无等无等等者。当学菩萨摩诃萨行。是般若波罗蜜多

    散华缘品第二十八之一

尔时复有三十三天诸天子众。各各持以曼陀罗华摩诃曼陀罗华。来诣佛所而散是华。即时会中有六万苾刍俱从座起。偏袒右肩右膝着地。合掌恭敬住立佛前。时诸苾刍以佛威神力故。各各掌中自然盈满曼陀罗华摩诃曼陀罗华。即以此华散于佛上。华散佛已咸作是言。世尊。我等皆修是般若波罗蜜多。皆行如是无上胜行

尔时世尊。即从口门放大光明。所谓青黄赤白等种种色光。遍照无量无边佛刹乃至梵界。普遍照耀已其光旋还。绕佛三匝却从世尊顶门而入

尔时尊者阿难。即从座起偏袒右肩右膝着地。合掌向佛作如是言。何因何缘放斯光明。若无因缘如来应供正等正觉不放光明。佛告尊者阿难言。汝今当知此六万苾刍。于未来世星宿劫中皆得成佛。同名散华如来应供正等正觉出现世间。是诸如来所有寿量二万劫数皆悉同等。正法住世亦二万劫。是诸佛会有声闻众。彼彼数量亦复相等。阿难当知。此六万苾刍从是已后在在所生。于佛法中出家修道。所向方处王城聚落。悉以正法为人演说。随说法处彼彼世界。常雨五色种种妙华而为供养。是诸苾刍在在处处作大利益。乃至最后得成正觉。是故阿难。若菩萨摩诃萨。乐欲行彼最上行者。应当行是般若波罗蜜多。又复阿难。若能行是般若波罗蜜多者。当知皆从人间命终。或知足天命终已后而来生此。何以故。人间及知足天。于般若波罗蜜多易所修行故。又复阿难。若菩萨摩诃萨。行此般若波罗蜜多者。当知是菩萨摩萨。常得诸佛共所观察。又复阿难。若菩萨摩诃萨。于此般若波罗蜜多法门。受持读诵记念思惟乃至书写已。复为他人如理表示如实教授。如所利益如理生喜。如是行者。当知是菩萨摩诃萨。于如来应供正等正觉所深种善根。非于声闻缘觉所而种善根。何以故。般若波罗蜜多善根胜故。又复阿难。若菩萨摩诃萨。于此般若波罗蜜多法门。受持读诵记念思惟。为人演说乃至书写者。是菩萨摩诃萨常得亲近现在诸佛听受正法。又复阿难。若菩萨摩诃萨。闻此般若波罗蜜多法门。而于是中不违不逆不毁不谤者。当知是菩萨摩诃萨。于先佛所已种善根。何以故。菩萨摩诃萨行是般若波罗蜜多故。而能成就阿耨多罗三藐三菩提。是故阿难。我今于一切世间天人阿修罗众中。以是般若波罗蜜多正法嘱累于汝汝当于此般若波罗蜜多正法。忆念受持宣通流布。令得久住而不断灭。阿难于我所说一切法中。唯除般若波罗蜜多不可忘失。若有人受持此法门时。乃至一字一句错误忘失者其罪甚重。是人不令我心生喜。若于余法有所忘失其罪乃轻。何以故。般若波罗蜜多微妙甚深。若人于此法门。不生尊重恭敬。不能瞻礼供养者。当知是人于过去未来现在诸佛世尊。不生尊重恭敬。不能瞻礼供养。是人不令我心生喜。何以故。般若波罗蜜多。即是过去未来现在佛母。出生诸佛及一切智。是故阿难。我今以是般若波罗蜜多正法嘱累于汝。若此正法欲断灭时。汝当受持宣通流布使不断灭。又复汝于此法所有文字章句。分明记忆无令忘失。如理作意思惟修习。广为他人解释其义。劝令受持读诵书写。何以故。此般若波罗蜜多。即是过去未来现在诸佛法身故。又复阿难。若人于我生欢喜心尊重恭敬瞻礼供养者。是人即以此心。当于般若波罗蜜多法门尊重恭敬瞻礼供养。即同供养于我。亦同供养过去未来现在诸佛。又复阿难。若人于我爱乐不舍者。当于般若波罗蜜多爱乐不舍。忆念受持宣通流布使不断灭。阿难。我今以是嘱累因缘付嘱于汝但且略说。欲广说者若一劫若过一劫。乃至百千俱胝劫数说不能尽。又复阿难。所有过去未来现在诸佛世尊。于一切世间天人阿修罗众中而为大师。般若波罗蜜多亦复如是。于一切世间天人阿修罗众中而为大师。何以故。此般若波罗蜜多。有大因缘能为一切世间天人阿修罗等作大利益。又复阿难。若人不离此般若波罗蜜多法门。能于其中受持读诵记念思惟。为人演说乃至书写者。此即是我所行教化。是人即为不离佛不离法不离僧。而能护助过去未来现在诸佛世尊阿耨多罗三藐三菩提。何以故。所有诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜多所出生故。阿难。若过去诸佛如来应供正等正觉。阿耨多罗三藐三菩提。皆从是般若波罗蜜多生。若未来诸佛如来应供正等正觉。阿耨多罗三藐三菩提。亦从是般若波罗蜜多生。于今现在十方无量阿僧祇世界现住说法者如来应供正等正觉。阿耨多罗三藐三菩提。亦从是般若波罗蜜多生。是故阿难。若菩萨摩诃萨。欲得阿耨多罗三藐三菩提者。当善学诸波罗蜜多。学是诸波罗蜜多者。即学般若波罗蜜多。何以故。般若波罗蜜多而能出生诸波罗蜜多故。又此般若波罗蜜多。是诸菩萨母。而能出生诸菩萨故。而诸波罗蜜多亦能出生阿耨多罗三藐三菩提。何以故。诸波罗蜜多。皆从般若波罗蜜多中来。由是般若波罗蜜多所生诸波罗蜜多。亦能助阿耨多罗三藐三菩提。是故诸菩萨摩诃萨。欲得阿耨多罗三藐三菩提者。应当善学诸波罗蜜多

复次阿难。汝当谛听。我今以是般若波罗蜜多正法第二第三重。复嘱累于汝。汝当忆念受持慎勿忘失。此法若欲灭时。汝可护助宣通流布无令断灭。阿难。此般若波罗蜜多。是诸如来应供正等正觉无尽法藏。何以故。所有过去诸佛如来应供正等正觉。广为一切众生说此般若波罗蜜多无尽法藏。令诸众生普得阿耨多罗三藐三菩提。未来诸佛如来应供正等正觉。亦为一切众生说此般若波罗蜜多无尽法藏。令诸众生普得阿耨多罗三藐三菩提。于今现在十方无量阿僧祇世界现住说法者。诸佛如来应供正等正觉。亦为一切众生。说此般若波罗蜜多无尽法藏。令诸众生普得阿耨多罗三藐三菩提。又复阿难。若声闻乘人以声闻法。普为三千大千世界一切众生。如应宣说悉令证得阿罗汉果是利不虚。阿难。彼诸阿罗汉所有布施持戒修定功德。于汝意云何。是为多不。阿难白佛言。甚多世尊。甚多善逝。佛言阿难。彼福虽多。不如菩萨以此般若波罗蜜多中相应一法。普为众生如理宣说。是菩萨摩诃萨得福甚多。又菩萨摩诃萨。于此般若波罗蜜多法门。能一日中为余菩萨摩诃萨如理宣说者得福倍多。阿难。且置一日。若能从旦至于食时。复置从旦至于食时。若能一漏刻间。置是一漏刻间。若能一须臾。置一须臾。若能一罗嚩。置一罗嚩。若能一刹那。如是一刹那间。以此般若波罗蜜多法门。为余菩萨摩诃萨如理宣说者。当知是菩萨摩诃萨。其所得福亦复倍多。阿难。若菩萨摩诃萨。能如是法施众生者。不可以声闻缘觉善根福德而相等比。何以故。是菩萨摩诃萨。不退转于阿耨多罗三藐三菩提

佛说佛母出生三法藏般若波罗蜜多经卷第二十二佛说佛母出生三法藏般若波罗蜜多经卷第二十三

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    散华缘品第二十八之二

尔时世尊。说是般若波罗蜜多正法时。于大会中现神通相。而此众会菩萨摩诃萨。苾刍苾刍尼优婆塞优婆夷天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。以佛威神力故。忽然得见阿閦如来应供正等正觉在此会中。犹如大海深固无动。有无量无数具足不可思议种种功德。菩萨摩诃萨并阿罗汉诸漏已尽无复烦恼心善解脱慧善解脱。如大龙王所作已办。舍诸重担善得己利尽诸有结。正智无碍心得自在。一切功德皆悉具足者诸大声闻。又有无量无数苾刍苾刍尼优婆塞优婆夷。及诸天龙八部。如是等众而共围绕。乃至阿閦佛国庄严等相皆悉得见。此诸众会。虽于是相起希有心。但乐瞻睹而悉不知其所从来。于是世尊摄其神力。此诸众会忽然不见阿閦如来及彼诸相

尔时世尊。告阿难言。此诸大众皆不复见阿閦如来及诸相者。当知一切法亦复如是。不与眼作对法不可对法。法不可见法。是故无所从来亦无所去。何以故。阿难。一切法无知者无见者。无造者无作者。何以故。一切法如虚空无分别故。一切法甚深不可思议。譬如幻士不受诸法。无坚牢故。一切法无所受亦复如是。阿难。诸菩萨摩诃萨若如是行。是行般若波罗蜜多。而于是中亦无法可着。若如是学是学般若波罗蜜多。如是学者能到诸学彼岸。又复阿难。若菩萨摩诃萨。欲得阿耨多罗三藐三菩提者。应当学是般若波罗蜜多。何以故。是般若波罗蜜多学。于诸学中最上最大最胜最妙无上中无上无等无等等。而能利益安乐一切世间。无依怙者为作依怙。如是学者诸佛许可诸佛称赞。阿难。诸佛如来应供正等正觉。学是法已能以足指按地。震动三千大千世界。乃至举足下足皆悉能现诸神通相。何以故。诸佛具足无量无数胜功德故。又复阿难。诸佛学是般若波罗蜜多故。于过去未来现在一切法中得无碍知见。是故阿难。我说般若波罗蜜多学。最上最大最胜最妙无上中无上无等无等等。阿难当知。般若波罗蜜多无量无尽无有边际。若人欲称量般若波罗蜜多者。是即称量虚空。何以故。虚空无量故般若波罗蜜多无量。虚空无尽故般若波罗蜜多无尽。虚空无边际故般若波罗蜜多无边际。阿难。我不说般若波罗蜜多有所限量。何以故。若名句文是有量法。般若波罗蜜多非名句文即无限量。阿难白佛言。世尊。何因缘故佛说般若波罗蜜多无量。佛言阿难。般若波罗蜜多无尽故无量。般若波罗蜜多离故无量。以无尽故离故即法不可得。不可得中当何有量。是故我说般若波罗蜜多无量。阿难。过去诸佛如来应供正等正觉。皆从般若波罗蜜多出生。是般若波罗蜜多即无尽。未来诸佛如来应供正等正觉。皆从般若波罗蜜多出生。是般若波罗蜜多亦无尽。于今现在十方无量阿僧祇世界现住说法者。诸佛如来应供正等正觉。皆从般若波罗蜜多出生。是般若波罗蜜多亦无尽。阿难。我亦从般若波罗蜜多出生。是般若波罗蜜多亦无尽。以是缘故般若波罗蜜多。已无尽当无尽今无尽。何以故。若能尽虚空。即能尽般若波罗蜜多。是故阿难。般若波罗蜜多无尽。尔时尊者须菩提作是念。如佛所说是义甚深我当问佛。作是念已即白佛言。世尊。般若波罗蜜多无尽耶。佛言。须菩提。般若波罗蜜多无尽。何以故。一切法无生。如虚空故无尽。须菩提白佛言。世尊。若一切法无生者。般若波罗蜜多当云何生。佛言。须菩提。色无尽故般若波罗蜜多如是生。受想行识无尽故般若波罗蜜多如是生。须菩提。若菩萨摩诃萨如是了知。即般若波罗蜜多如是生。又菩萨摩诃萨。当观无明无尽故。般若波罗蜜多如是生。如是行无尽。识无尽。名色无尽。六处无尽。触无尽。受无尽。爱无尽。取无尽。有无尽。生无尽。老死忧悲苦恼等无尽故。般若波罗蜜多如是生。须菩提。若菩萨摩诃萨。以如是无尽法观诸缘生者。是行般若波罗蜜多。即不住声闻缘觉之地。必证阿耨多罗三藐三菩提安住一切智。菩萨坐道场时。应当如是观缘生法。如是观已不堕二边不住中道。是为菩萨不共之法。如是观者得一切智智。又须菩提。若菩萨摩诃萨。于阿耨多罗三藐三菩提有所退转者。是菩萨摩诃萨。即不能成就如是善巧方便。亦不能知。云何是菩萨摩诃萨。行般若波罗蜜多云何是无尽法生般若波罗蜜多。云何是无尽法观诸缘生。须菩提。若菩萨摩诃萨。不退转于阿耨多罗三藐三菩提者。即能成就如是善巧方便。亦能了知。菩萨摩诃萨如是行。是行般若波罗蜜多。以如是无尽法生般若波罗蜜多。以如是无尽法观诸缘生。须菩提。菩萨摩诃萨。能如是观诸缘生时。即不见有法非因缘生。亦不见有法是常是究竟是坚牢。亦不见法有作者有受者。须菩提。菩萨摩诃萨如是行般若波罗蜜多时念无尽法。如理出生般若波罗蜜多。以如是无尽法观诸缘生时。即不见色。不见受想行识。亦复不见无明行识名色六处触受爱取有生老死忧悲苦恼等。不见此佛刹亦不见彼佛刹。不见有法是此佛刹。亦不见有法是彼佛刹。须菩提。若菩萨摩诃萨。如是行般若波罗蜜多时。魔心大怖忧愁苦恼。须菩提。譬如有人丧失父母。极大悲痛忧愁苦恼。魔心生苦亦复如是。须菩提白佛言。世尊。但有一魔心生苦恼。为多恶魔皆苦恼耶。佛告须菩提言。菩萨摩诃萨如是行般若波罗蜜多时。所有三千大千世界一切恶魔。皆悉心生忧愁苦恼。各各不能安处其座。何以故。菩萨摩诃萨。行是般若波罗蜜多故。一切世间天人阿修罗等所不能动。一切恶魔伺不得便。是故须菩提。菩萨摩诃萨。欲得阿耨多罗三藐三菩提者。当行是般若波罗蜜多。菩萨摩诃萨。行是般若波罗蜜多故。即能圆满布施波罗蜜多。持戒波罗蜜多。忍辱波罗蜜多。精进波罗蜜多。禅定波罗蜜多。如是圆满诸波罗蜜多已。即能圆满一切善法。具足一切方便愿力。又须菩提。菩萨摩诃萨。若欲摄诸善巧方便者。当行是般若波罗蜜多。又复当念无尽法。如理出生般若波罗蜜多。菩萨摩诃萨。如是行如是念时应生如是心。所有十方无量阿僧祇世界现住说法者诸佛如来应供正等正觉。及诸佛一切智。皆从是般若波罗蜜多生。如诸佛所得法我悉应得。须菩提。菩萨摩诃萨行般若波罗蜜多时。于一弹指间能生如是心者。胜余菩萨摩诃萨。于兢伽沙数劫中布施功德。当知是菩萨摩诃萨。已得安住不退转地诸佛护念。须菩提。当知。菩萨摩诃萨。于一弹指间能生如是心者。具足如是一切功德。又菩萨摩诃萨。于一日中若过一日能生如是心者。当知是菩萨摩诃萨诸佛护念。在在所生生诸佛刹。具诸功德诸佛称赞。于一切处。广为众生作大利乐。须菩提。菩萨摩诃萨。行般若波罗蜜多时。能生如是心又复念无尽法。如理出生般若波罗蜜多者。譬如香象菩萨。于阿閦如来应供正等正觉所。行般若波罗蜜多。及修梵行。我诸菩萨亦复如是

    随知品第二十九

复次须菩提。菩萨摩诃萨。应随知般若波罗蜜多相。所谓一切法无碍。当知般若波罗蜜多亦如是。一切法无分别。当知般若波罗蜜多亦如是。一切法无坏。当知般若波罗蜜多亦如是。一切法无作相。当知般若波罗蜜多亦如是。一切法无我无表慧所觉了。当知般若波罗蜜多亦如是。一切法但有假名字。当知般若波罗蜜多亦如是。一切法语言分别。即此语言无所有不可得。当知般若波罗蜜多亦如是。一切法无说。当知般若波罗蜜多亦如是。色无量当知般若波罗蜜多亦如是。受想行识无量。当知般若波罗蜜多亦如是。一切法无量。当知般若波罗蜜多亦如是。一切法无相当知般若波罗蜜多亦如是。一切法是通达相。当知般若波罗蜜多亦如是。一切法自性清净。当知般若波罗蜜多亦如是。一切法寂默。当知般若波罗蜜多亦如是。一切法无灭同于断。当知般若波罗蜜多亦如是。一切法得涅槃同真如。当知般若波罗蜜多亦如是。一切法无来无去无生无所生。毕竟生不可得。当知般若波罗蜜多亦如是。一切法无自相无他相。当知般若波罗蜜多亦如是。一切贤圣自性清净。当知般若波罗蜜多亦如是。一切法舍诸誓愿。当知般若波罗蜜多亦如是。一切法无方无处。当知般若波罗蜜多亦如是。何以故。色无方无处自性清净。当知般若波罗蜜多亦如是。受想行识无方无处自性清净。当知般若波罗蜜多亦如是。一切法喜乐性。当知般若波罗蜜多亦如是。一切法无染无离染。当知般若波罗蜜多亦如是。一切法非爱非离爱。当知般若波罗蜜多亦如是。色非尘非离尘自性清净。当知般若波罗蜜多亦如是。受想行识非尘非离尘自性清净。当知般若波罗蜜多亦如是。一切法无系着。当知般若波罗蜜多亦如是。菩萨一切法佛智所觉了。当知般若波罗蜜多亦如是。一切法空无相无愿。当知般若波罗蜜多亦如是。一切法是大良药慈心为首。当知般若波罗蜜多亦如是。一切法住慈悲喜舍行。当知般若波罗蜜多亦如是。一切法净行住离诸过失。当知般若波罗蜜多亦如是。大海无边。当知般若波罗蜜多亦如是。须弥山庄严。当知般若波罗蜜多亦如是。色无边。当知般若波罗蜜多亦如是。受想行识无边。当知般若波罗蜜多亦如是。日轮光明照耀无边。当知般若波罗蜜多亦如是。一切音声无边。当知般若波罗蜜多亦如是。集一切佛法无边。当知般若波罗蜜多亦如是。一切众生界福智生无边。当知般若波罗蜜多亦如是。地界无边。当知般若波罗蜜多亦如是。水界火界风界空界识界无边。当知般若波罗蜜多亦如是。善不善法无边。当知般若波罗蜜多亦如是。一切佛法藏无边。当知般若波罗蜜多亦如是。一切法无边。当知般若波罗蜜多亦如是。空性无边。当知般若波罗蜜多亦如是。心心所法无边。当知般若波罗蜜多亦如是。心所行无边。当知般若波罗蜜多亦如是。集一切法无量。当知般若波罗蜜多亦如是。一切法三摩地无量不可得。当知般若波罗蜜多亦如是。善不善法无量。当知般若波罗蜜多亦如是。一切法如师子吼。当知般若波罗蜜多亦如是。一切法不可坏。当知般若波罗蜜多亦如是。何以故。色如大海受想行识如大海。色如须弥山庄严。受想行识如须弥山庄严。色如日轮光明照耀无边。受想行识如日轮光明照耀无边。色如一切音声无边。受想行识如一切音声无边。色如集一切佛法无边。受想行识如集一切佛法无边。色如众生界无边。受想行识如众生界无边。色如地界无边。受想行识如地界无边。色如水界火界风界空界识界无边。受想行识如水界火界风界空界识界无边。色离集善相。受想行识离集善相。色离和合相受想行识离和合相。色如一切法三摩地无边。受想行识如一切法三摩地无边。色色离色自性。色真如是为佛法。受想行识识离识自性。识真如是为佛法。色相无边受想行识相无边。色空无边受想行识空无边。色于心心所法无边。受想行识于心心所法无边。色于心所行无生。受想行识于心所行无生。色于善不善法中不可得。受想行识于善不善法中不可得。色如师子吼受想行识如师子吼。色毕竟不可坏。受想行识毕竟不可坏。以如是义故一切法不可坏。般若波罗蜜多亦如是。须菩提。若菩萨摩诃萨。能如是随知般若波罗蜜多。即于般若波罗蜜多中。无所行无所作无所证。非思惟观察筹量可及。远离一切谄诳作意。远离一切懈怠作意。远离一切悭嫉作意。远离我取作意。远离自他作意。远离我想人想众生想等。远离世间名闻利养。远离五盖等法。乃至远离一切非理作意。须菩提。菩萨摩诃萨。若如是行般若波罗蜜多。即于诸法中难得而得乃能圆满一切功德。生诸佛刹成无上智

    常啼菩萨品第三十之一

复次须菩提。诸菩萨摩诃萨。欲求般若波罗蜜多者。当如常啼菩萨摩诃萨。往昔于雷吼音王如来应供正等正觉法中修习梵行。勤求般若波罗蜜多。须菩提白佛言。世尊。常啼菩萨摩诃萨。作何方便而能求是般若波罗蜜多

佛告须菩提言。汝今当知。常啼菩萨摩诃萨。往昔求般若波罗蜜多时。不怖时长不念世事不惜身命。不乐世间名闻利养。于诸世间不生依着。但一心念求般若波罗蜜多。即于林中思惟方便。尔时空中有声作如是言。善男子。汝可东行求是般若波罗蜜多。汝当往时若身若心勿生疲倦。勿念睡眠勿念饮食。勿念昼夜勿念寒热。勿念一切违碍等事。又复勿念内法外法。勿念于前亦勿念后。勿念四方四维上下。又复行时不得左右顾视。但一心念般若波罗蜜多。如是念时不应动色。不应动受想行识。若动五蕴即不行佛法是行生死行。若行生死行即不行般若波罗蜜多即不成就般若波罗蜜多。是故汝今离如是相但一心求。须菩提。尔时常啼菩萨摩诃萨。闻是空中声已即答空中声言。我今如所教行。何以故。我欲为一切众生作大光明。欲集一切佛法故。时空中声即复赞言。善哉善哉。善男子。汝若东行求是般若波罗蜜多时。应信解一切法空无相无愿。当离诸相远离我见人见众生等见。远离恶知识亲近善知识。随所亲近应当尊重恭敬供养善知识者。能为汝说一切法空无相无愿无生无灭无性。汝若生如是尊重恭敬供养心者。应当不久得闻般若波罗蜜多。若于经卷中闻。若于法师所闻。汝随所闻般若波罗蜜多处。当生大师想尊重恭敬承事供养。是即知恩为报恩者。应作是念此即是我真善知识。我闻此般若波罗蜜多故。不退转于阿耨多罗三藐三菩提。得近阿耨多罗三藐三菩提。不离如来应供正等正觉。生诸佛刹不生无佛刹中。远离诸难不生难处。善男子。汝应为求如是功德利故随从法师。不应为世间财利名誉故随从法师。又复以重法心故于法师所尊重恭敬。承事供养如大师想。常应觉知所有魔事。或时恶魔有因缘故。于说法者以好上妙色声香味触而为供养。彼说法者以方便力故受是五欲。汝于尔时不应生起不清净心而为障碍。但作是念。我无如是方便力故。而说法师为欲利乐一切众生令种善根故。虽受是五欲。于菩萨摩诃萨。无有少法可为障碍。善男子。汝于尔时应当安住诸法实相。何等名为诸法实相。所谓一切法无染无净。何以故。一切法自性空故。是中无我无人。无众生无寿者。一切法如梦如幻如影如响。如是名为诸法实相。汝若如是安住。即不久得闻般若波罗蜜多。善男子。又复应当觉知魔事。或时魔因缘故。令说法者于听法者心生嫌恶。汝于尔时为求法故。不应暂起诸违碍想。于其法师益加尊重爱乐恭敬。汝当不久得闻般若波罗蜜多

尔时常啼菩萨摩诃萨。闻空中声为教示已。即随所教东行求般若波罗蜜多。东行未久即作是念。我于向者云何。不能问空中声东行远近至何方处。从谁得闻般若波罗蜜多。作是念已忧愁啼泣。即于彼住复作念言。我住于此一日二日乃至七日。若身若心无疲倦想。不念睡眠不念饮食。不念寒热不念昼夜。但一心念般若波罗蜜多。譬如有人唯生一子爱念甚重而忽丧殁。是时父母无复余念唯大苦恼忧愁啼泣。须菩提。常啼菩萨摩诃萨亦复如是。当于尔时无复余念。但念何时于何方处。从谁得闻般若波罗蜜多

佛说佛母出生三法藏般若波罗蜜多经卷第二十三佛说佛母出生三法藏般若波罗蜜多经卷第二十四

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    常啼菩萨品第三十之二

尔时佛告须菩提。彼常啼菩萨摩诃萨。如是忧愁啼泣时忽然见有如来形像住立其前作是赞言。善哉善哉。善男子。诸佛如来应供正等正觉。本行菩萨道时。求般若波罗蜜多亦如汝今。如是勤求等无有异。是故汝应益加精进勇猛坚固。从此东行五百由旬。有一大城名曰众香。其城七重。七重垣墙纵广十二由旬。广博清净妙好殊丽。人民炽盛安隐丰乐。有五百街道处处连接。桥津平正人所爱乐。其七重城七宝严饰。一一城上皆以阎浮檀金而为楼阁。七宝行树周匝围绕。复有七多罗树。彼七宝行树各有种种宝华宝果。一一树间众宝间错。有诸宝网互映交络。弥覆城上垂诸宝铃。风吹铃声甚可爱乐。如五种乐巧出音声。清妙和雅闻者适悦。其城四边流泉浴池清净具足。中有诸船七宝装铰。池水自然冷暖调适人所爱乐。是诸池中有众色华。所谓优钵罗华。俱母陀华。奔拏利迦华等。及余种种妙色香华乃至三千大千世界所有一切诸妙华等皆悉具足。其城四边有五百园一一园中有五百池。其池纵广一俱卢舍。彼一一池七宝装铰甚可爱乐。是诸池中亦有种种妙色香华。所谓优钵罗华俱母陀华奔拏利迦华等是一一华大如车轮。青色青光黄色黄光。赤色赤光白色白光。一一池中复有白鹤凫雁鸳鸯等种种异鸟游集其上。是诸园林浴池。城中人民自在游适无所系属。但以众生先业所感。彼诸众生于长夜中。修行般若波罗蜜多。清净信解甚深法门故。获如是最胜果报。善男子。彼众香城中有大高台。法上菩萨摩诃萨所止宫舍在于其上。其台分量纵广正等各一由旬。七重垣墙七宝庄严殊特妙好。七重行树周匝围绕。复有七多罗树。于其宫中有四大园。一名常喜。二名无忧。三名适悦。四名华庄严。一一园中有八大池。一名贤。二名贤上。三名欢喜。四名喜上。五名安乐。六名妙乐。七名决定。八名阿嚩诃。彼一一池四边皆以四宝庄严。东黄金宝南白银宝。西吠琉璃宝北颇胝迦宝。玟瑰为底金沙布上。一一池侧有八梯陛七宝庄严。以众宝物而为层级。其层级间有阎浮檀金芭蕉行树。彼诸池中亦有种种妙色香华。所谓优钵罗华俱母陀华奔拏利迦华等。亦复有诸白鹤凫雁鸳鸯等种种异鸟游集其上。彼一一池四边各有妙香华树香如栴檀色味具足。风吹其华堕池水中。而彼宫舍园林池沼如是严饰。法上菩萨摩诃萨处其宫内。与六万八千婇女眷属俱。于如是等园林池沼游玩适悦。五欲娱乐嬉戏自在。众香城中所有人民。若男若女亦复皆入常喜等园贤等诸池游戏娱乐。彼法上菩萨摩诃萨既娱乐已。于自宫内日三时中。说般若波罗蜜多又复众香城中一切人民。于其城内多人聚处。为法上菩萨摩诃萨敷大法座。其座四足黄金白银吠琉璃颇胝迦四宝所成。复有种种真珠璎珞而为装铰。座高半俱卢舍。于其座上敷以茵褥。及憍尸迦衣上妙细[疊*毛]种种严饰。于座周匝散五色华。烧众妙香严好殊特清净可爱。法上菩萨摩诃萨处其法座。天人四众集会一处恭敬围绕以重法故。各各烧香散华供养法上菩萨摩诃萨。是时菩萨广为一切天人四众。宣说般若波罗蜜多随应说已。中有受持者有读诵者。有思惟者有书写者有如说行者。有不退转于阿耨多罗三藐三菩提者。善男子。彼法上菩萨摩诃萨。说法会中有如是等功德利益。是故汝今宜应东行往彼法上菩萨摩诃萨所。汝当从彼得闻般若波罗蜜多。而彼菩萨摩诃萨。能以此法为汝示教利喜。汝今东行勿计昼夜。勇猛精进一心勤求。即当不久决定得闻般若波罗蜜多

尔时常啼菩萨摩诃萨。闻是说已心生欢喜适悦庆快。譬如有人为箭所中苦痛斯甚。是人尔时无复余念。但念何时得大良药而为救疗。使我得脱如是苦恼。须菩提。常啼菩萨摩诃萨。亦复如是而无余念。但念何时得瞻礼亲近法上菩萨摩诃萨。从彼得闻般若波罗蜜多。即于是处一心谛想法上菩萨摩诃萨。思惟般若波罗蜜多。常啼菩萨摩诃萨作是思惟时。于一切法中生无所依想。得入无量无数三摩地门。所谓观一切法自性三摩地。一切法自性无所得三摩地。一切法自性智生三摩地。破一切法无明三摩地。一切法不坏见三摩地。一切法作光明三摩地。一切法离痴瞑三摩地。破一切法无智三摩地。一切法离闇三摩地。一切法相不可得三摩地。散华三摩地。一切法无我相三摩地。离幻三摩地。如镜像出生三摩地。一切众生语言三摩地。离尘三摩地。一切众生欢喜三摩地。随一切众生善巧语言三摩地。种种语言文字章句出生三摩地。无畏三摩地。自性三摩地。离障得解脱三摩地。无染三摩地。名句文庄严三摩地。等观一切法三摩地。一切法离境界相三摩地。一切法无碍际三摩地。如虚空三摩地。金刚喻三摩地。清净相王三摩地。无负三摩地。得胜三摩地。不退观三摩地法界决定三摩地。法界寂静三摩地。安隐三摩地。师子吼三摩地。胜一切众生三摩地。离垢三摩地。清净三摩地。莲华庄严三摩地。断爱三摩地。随一切坚固三摩地。一切法最上三摩地。得神通力无所畏三摩地。一切法通达三摩地。坏一切法印三摩地。一切法无差别见三摩地。离一切见三摩地。大法光明三摩地。一切法离相三摩地。解脱一切着三摩地。一切法无懈三摩地。甚深法光明三摩地。等高三摩地。不可夺三摩地。破魔境界三摩地。三界最胜三摩地。光明门三摩地。见一切如来三摩地。须菩提。彼常啼菩萨摩诃萨。得入如是等诸三摩地门。于三摩地中见十方无量阿僧祇世界诸佛如来。各各为诸菩萨摩诃萨。说般若波罗蜜多。是诸如来皆悉安慰赞叹常啼菩萨摩诃萨言。善哉善哉。善男子。汝能勤求般若波罗蜜多。我等本行菩萨道时。求般若波罗蜜多。亦如汝今。得是诸三摩地等无有异。汝今得是诸三摩地已。而能通达般若波罗蜜多。方便安住不退转法。我等得是诸三摩地已。即得阿耨多罗三藐三菩提。我等于诸三摩地中。观察自性无法可见。从诸三摩地出已。于一切法生无住想。善男子。无住法者是谓般若波罗蜜多。我等于是无住法中。得金色身种种光明。三十二大人相八十种随形好皆悉具足。得不思议佛无上智佛无上慧。成就一切佛法功德。到一切法彼岸。善男子。如是功德诸佛如来犹尚不能称量赞叹说其边际。何况声闻缘觉。是故汝今于是法中。益加恭敬尊重爱乐精进勤求。以是义故阿耨多罗三藐三菩提不为难得。又善男子。汝今宜应于善知识极生恭敬尊重爱乐。何以故。菩萨摩诃萨。为善知识所护助者。速得阿耨多罗三藐三菩提。尔时常啼菩萨摩诃萨。白诸如来言。谁当是我真善知识。愿诸如来示教于我。即时诸佛如来谓言。善男子当知。法上菩萨摩诃萨者是汝善知识。而彼菩萨世世已来常教化汝。今汝通达般若波罗蜜多方便。学诸佛法成就。汝于阿耨多罗三藐三菩提。汝应知彼重恩当念报恩。善男子。汝于法上菩萨摩诃萨欲报恩者。假使一劫百劫。乃至百千劫中恭敬顶戴。以一切乐具。乃至三千大千世界所有上妙色声香味触等而为供养。亦未能报一少分恩。何以故。汝以法上菩萨摩诃萨因缘故。令汝得入诸三摩地门。通达般若波罗蜜多方便是故当知彼恩深重尔时如来作是说已忽然不现。彼常啼菩萨摩诃萨。从三摩地出已。不复见彼诸佛如来。心生悲恼啼泣而住。即作是念。向者如来从何所来去至何所。彼为我说法上菩萨摩诃萨甚为希有。而彼菩萨摩诃萨。已得陀罗尼及五神通。已曾供养无量诸佛彼即是我真善知识。世世已来常所教化利益于我。我今于彼益加恭敬尊重爱乐。是故宜应往彼瞻礼亲近供养听受般若波罗蜜多。及问向者如来从何所来去至何所。然我今者自念贫乏一无所有。金银珍宝衣服卧具。幢幡宝盖香华灯涂。如是等物悉不能办。乃至一华亦不能及。当以何物而为供养我若空往心非所安。如是忧愁思惟方计。尔时常啼菩萨摩诃萨。作是念已未即东行。且于中路别入一城。于其城中静住思惟。我欲东行为求法故。供养法上菩萨摩诃萨是大利益。我今宜应自卖其身。随所得价当买香华。自持往彼供养法上菩萨摩诃萨。何以故。我从世世已来。为欲因缘故于轮回中受生死身。历无量苦流转诸趣。破坏其身终无利益。不曾为此清净法故舍自身命。是故我今为求法故无所吝惜。作是思惟已。即于城中多人聚处如是唱言。我今卖身。谁当买我谁当买我。尔时诸魔知是事已即作是念。今常啼菩萨以乐法故自卖其身。欲买香华供养法上菩萨。为求般若波罗蜜多。何故诸菩萨行般若波罗蜜多。皆能成就阿耨多罗三藐三菩提。犹如大海无所倾动。我等诸魔不能坏乱。彼因缘故空我境界。是故我今宜设方便坏其道意。尔时恶魔如是念已。当彼常啼菩萨作此唱时。即以魔力隐蔽城中一切人众。皆不令闻常啼菩萨所唱之声。尔时常啼菩萨摩诃萨。如是三唱皆无买者。菩萨尔时心生愁恼啼泣而言。苦哉苦哉。我所卖身为供养法上菩萨摩诃萨。今无买者故知我身深为罪咎

尔时帝释天主。知是事已即作是念。我应往彼常啼菩萨摩诃萨所。当诚其心可能坚固深心乐法。真实能舍如是身不。帝释天主作是念已。即是变身为婆罗门。来住常啼菩萨摩诃萨前作是问言。汝今何故如是忧愁啼泣苦恼。常啼菩萨言。我今欲卖此身无有买者。以是缘故啼泣而住。婆罗门言。汝所卖身欲何所作。常啼菩萨言。我为爱乐法故。今自卖身买诸香华。欲供养法上菩萨摩诃萨。为求般若波罗蜜多。而我此身薄福德故卖无售者。尔时婆罗门谓常啼菩萨摩诃萨言。我不须人无所施作。我于今时将欲大祠。须用人心人血人髓。汝今可能而相与不。尔时常啼菩萨摩诃萨闻此语已。踊跃欢喜即作是念。我于今时得最上利。定当得闻般若波罗蜜多圆满所愿。此婆罗门而肯须我心及血髓。我应欢喜一一授与。作是念已即谓婆罗门言。仁者所须我当相奉。婆罗门言汝欲价直其数几何。常啼菩萨言。随所相与我即当受。尔时常啼菩萨摩诃萨。即执利刀刺其右臂出血。次欲于其右髀破骨出髓。是时有一长者女在高楼上。遥见常啼菩萨摩诃萨先自刺臂出血又欲破骨出髓。即作是念。此善男子何故如是苦楚其身。我应往彼询问其故。时长者女作是念已。即下高楼来菩萨所发是问言。善男子。汝何缘故于其自身受是苦楚所出血髓欲将何用。常啼菩萨言。善女人当知。我今贫乏无有财宝。所出血髓卖与此婆罗门。所得价直当买香华。供养法上菩萨摩诃萨。长者女言。汝以香华供养彼菩萨摩诃萨。当有何等功德利益。常啼菩萨言。汝善女人当知。彼法上菩萨摩诃萨。能为我说般若波罗蜜多及方便门。学彼法已能为众生作所归趣。即能成就阿耨多罗三藐三菩提。得金色身三十二大人相八十种随形好。常光无量光大慈大悲大喜大舍十力四无所畏四无碍智十八不共法等。不可思议无量无数佛功德法悉能圆满。及以一切无上法宝。分布施与一切众生。是故我今为欲成就如是功德故。往供养彼菩萨摩诃萨。听受般若波罗蜜多及方便门。尔时长者女白常啼菩萨摩诃萨言。善男子。如汝所说甚为希有。若人为求如是法故。假使如兢伽沙数身命尽以供养是所应作。功不唐捐有大利益。善男子。我家具有金银琉璃砗磲玛瑙珊瑚琥珀及颇胝迦等种种珍宝。乃至衣服卧具幢幡宝盖香华灯涂。随汝所须我悉当与。汝当持以供养法上菩萨摩诃萨。勿复卖身受诸苦楚。我今亦欲同汝往彼法上菩萨摩诃萨所。瞻礼亲近随喜供养种诸善根。时长者女作是说已住于一面。尔时帝释天主。隐其婆罗门身还复本相。住常啼菩萨摩诃萨前作如是言。善哉善哉。善男子。汝能坚固深心乐法勇猛勤求。善男子。过去诸佛如来应供正等正觉。本行菩萨道时。求般若波罗蜜多。亦如汝今等无有异。汝当决定得成阿耨多罗三藐三菩提。圆满一切佛功德法。善男子。我实不须人心血髓故来相试。汝今有何所须我当授汝。常啼菩萨言。天主。汝可与我阿耨多罗三藐三菩提。帝释天主言。善男子。此是诸佛境界非我境界。诸佛如来可能成办我不能辨。余有所须我皆相奉。常啼菩萨言。我今无复余愿。以汝帝释天主实语力故。又复以我自所愿力自实语力。及佛世尊威神力故。若我决定不退转于阿耨多罗三藐三菩提。诸佛如来应供正等正觉知我深心者。愿我此身平复如故。尔时常啼菩萨摩诃萨发是言已。于须臾间身即平复。乃至无有瘢痕等相。尔时帝释天主见是相已。赞叹希有隐身不现。尔时彼长者女即白常啼菩萨摩诃萨言。善男子。汝今应可同往。我舍。白我父母求索所须。持以供养法上菩萨摩诃萨。尔时常啼菩萨摩诃萨谓长者女言。善哉同往今正是时。于是彼长者女。与常啼菩萨摩诃萨同诣父舍。到其舍已。常啼菩萨摩诃萨住于门侧。彼长者女。即入其舍白父母言。父母我家具有金银珍宝及种种物。愿以少分见赐于我。及所供给我五百侍女听许从我。我当与一菩萨摩诃萨名曰常啼。同往供养一菩萨摩诃萨名曰法上。而彼法上菩萨摩诃萨。能为我等说甚深法。闻彼法已即能成就一切佛法功德利益。是故父母愿赐听许。是时父母即告女言。汝所说者常啼菩萨摩诃萨今在何处。彼女答言。今在门外。父母当知。彼菩萨摩诃萨者。深心乐法勇猛坚固。为欲成就阿耨多罗三藐三菩提。广度一切众生出生死苦。欲往供养法上菩萨摩诃萨。求般若波罗蜜多故自卖其身。于此城中高声唱言。谁当买我。如是三唱无有买者。是时常啼菩萨。忧愁苦恼。啼泣而住。我于尔时在高楼上。见一婆罗门来菩萨所互言。谓已即时菩萨手执利刀刺其右臂出血。复欲割其右髀破骨出髓。我时见是事已即作是念。此善男子。何故如是苦楚其身。我宜往彼询问其故。念已即往。我问彼言。汝何缘故受斯苦楚。所出血髓欲将何用。彼答我言。我欲买诸香华持往供养法上菩萨摩诃萨。我贫乏故无有财宝。故出血髓卖与此婆罗门。其得价直当买香华供养菩萨。父母我闻彼说深所赞叹。复问彼言。汝今如是供养彼菩萨。当有何等功德利益。彼答我言。供养彼菩萨故。从彼得闻般若波罗蜜多及方便门。学是法已乃能成就不可思议无量无数佛功德法。我闻是说已心生欢喜即谓彼言。善男子。为求法故行难行行。甚为希有。汝今不须如是苦楚其身。我家具有金银珍宝及种种物。随汝所欲我当相与。我亦乐欲同汝往彼法上菩萨摩诃萨所。瞻礼亲近随喜供养。我复谓言。今且同汝往我父舍。白我父母求索财宝。与汝俱持供养法上菩萨摩诃萨。彼即答言。善哉可行今正是时。父母以是缘故。常啼菩萨摩诃萨同我至此。是故父母若欲令我成就一切无上功德法者。如我所欲种种财宝及侍女等。愿赐见听。勿复为碍。尔时父母即告女言。汝所说者彼善男子甚为希有。为求法故行难行行。而欲成就不可思议佛功德法。欲为一切众生作大利益。此因缘者。是为一切世间胜上事业。今听汝往。凡诸所欲自当随意。我等亦欲往彼法上菩萨摩诃萨所。瞻礼亲近随喜供养。尔时彼长者女。为供养法上菩萨摩诃萨因缘故白父母言。我亦不敢障人功德。父母欲往自当随意

尔时长者女。即时严整五百乘车众宝庄严。令五百侍女各严身已人乘一车。所有金银珍宝衣服卧具幢幡宝盖香华灯涂。及种种物载以一车。时长者女与常啼菩萨摩诃萨共乘一车。父母眷属亦乘宝车。如是庄严导从围绕出所住舍。东行往诣法上菩萨摩诃萨所。如是行经五百由旬。常啼菩萨摩诃萨与长者女。遥见一城。其城七重七重垣墙。七宝行树周匝围绕。其城纵广十二由旬。广博清净。五百街巷处处连接。桥津平正安隐丰乐。人民炽盛甚可爱乐。于其城中多人聚处。有大法座高广妙好众宝庄严。遥见法上菩萨摩诃萨处于座上。有无量百千天人四众。恭敬围绕听受说法。如是见已。常啼菩萨摩诃萨。心生庆快踊跃欢喜。譬如苾刍得第三禅乐。一心专注尊重恭敬。即谓长者女言。此城名为众香。彼菩萨者。是谓法上菩萨摩诃萨。我等今时不应乘车前诣其所。发是言已即各下车。欢喜肃恭步进于前

佛说佛母出生三法藏般若波罗蜜多经卷第二十四佛说佛母出生三法藏般若波罗蜜多经卷第二十五

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

    常啼菩萨品第三十之三

尔时常啼菩萨摩诃萨。与长者女及诸侍女父母眷属等导从围绕。并持种种珍宝供具入众香城。一心渴仰欲见法上菩萨摩诃萨。是时常啼菩萨摩诃萨等。既入城已诣菩萨所。其去不远。常啼菩萨摩诃萨。见帝释天主与无数百千天子。散天曼陀罗华摩诃曼陀罗华。及余种种殊妙天华天金银华等散于虚空。及散栴檀香末。又复广作微妙天乐。其所散华住在空中。常啼菩萨摩诃萨。如是见已即问帝释天主言。憍尸迦。汝何缘故于虚空中。与无数百千天子。散众天华。及散栴檀香末。广作天乐。帝释天主白常啼菩萨摩诃萨言。善男子。汝不知耶。有法名摩诃般若波罗蜜多。是诸佛母。亦是诸菩萨母。学是法者即能成就一切智。圆满一切佛功德法。汝今当知。于法上菩萨摩诃萨演说法处。别有七宝台高广妙好种种严饰。真珠宝网间错垂布。于其台中有七宝床。而彼床上安七宝函。以黄金鍱书是摩诃般若波罗蜜多正法置于函内。种种珍宝周匝围绕。其台四角安四白银香炉烧黑沉水香。供养摩诃般若波罗蜜多正法。以是缘故我等诸天于虚空中散华供养

尔时常啼菩萨摩诃萨白帝释天主言。憍尸迦。如汝所说是诸佛母及菩萨母。摩诃般若波罗蜜多正法。微妙甚深最上希有。汝以方便可能示我。帝释天主言。善男子。彼摩诃般若波罗蜜多正法在七宝函内。彼法上菩萨摩诃萨以七宝印印之。我无方便可能示汝。尔时常啼菩萨摩诃萨与长者女等。渐复前行到法上菩萨摩诃萨所。即以所持金银珍宝衣服卧具幢幡宝盖香华灯涂等。分作二分。先持一分而共供养摩诃般若波罗蜜多。次持一分亦共供养法上菩萨摩诃萨。作是供养已。复以种种妙色香华。向法上菩萨摩诃萨所而用散掷。以法上菩萨摩诃萨。威神力故。其所散华于菩萨上住虚空中。变成种种妙宝楼阁。是诸楼阁自然皆有真珠璎珞间错垂布。尔时常啼菩萨摩诃萨并长者女。见是相已咸作是念。善哉此相。甚为希有。法上菩萨摩诃萨现住菩萨地。神通威德尚能如是。何况成就阿耨多罗三藐三菩提已。彼诸功德不可称计。尔时长者女作是念已。于法上菩萨摩诃萨。益加恭敬尊重爱乐。并五百侍女亦各恭敬尊重爱乐。时长者女及五百。侍女。皆发阿耨多罗三藐三菩提心咸作是言。愿我以此善根因缘。于未来世当得成佛。为菩萨时亦如法上菩萨摩诃萨。爱乐尊重般若波罗蜜多等无有异。及广为人宣说般若波罗蜜多。成就般若波罗蜜多善巧方便。皆如法上菩萨摩诃萨今日无异。作是言已。彼长者女并五百侍女。即时头面礼菩萨足。礼已合掌退住一面。尔时常啼菩萨摩诃萨。如前所作供养事已。即时头面礼菩萨足。礼已旋绕种种称赞。欢喜瞻仰合掌而住。问法上菩萨摩诃萨言。大士当知。我善因缘故来至此。我本为求般若波罗蜜多故。于空寂林中思惟方便。时空中有声而谓我言。汝可东行求般若波罗蜜多。我如所教寻即东行。东行未久我复作念。向者云何而不能问彼空中声。东行远近于何方处。从谁得闻般若波罗蜜多。我于尔时忧愁啼泣即于彼住经七昼夜。当是忧愁啼泣之时。忽然见有如来形像。住于我前作如是言。善男子。从是东行五百由旬有城名众香。彼有菩萨摩诃萨名曰法上。汝可往彼。当得闻般若波罗蜜多。我时闻是说已心大欢喜。即于彼处一心谛想大士。思惟般若波罗蜜多。我于尔时住一切法无依止想。即时得入无量无数三摩地门。于三摩地中。见十方无量阿僧祇世界诸佛如来应供正等正觉。各各为诸菩萨摩诃萨。宣说般若波罗蜜多。是诸如来咸赞我言。善哉善哉。善男子。汝以求般若波罗蜜多因缘故。得入诸三摩地门。时诸如来如是乃至种种示教利喜。安慰我已忽然不现。我于尔时从三摩地出已。不复得见诸佛如来。我心苦恼。即作是念。向者如来。从何所来去至何所。我复思惟。彼法上菩萨摩诃萨。于先佛所深种善根。通达般若波罗蜜多具诸方便。我当往彼听受般若波罗蜜多及问斯义。以是缘故我今至此。而得瞻礼菩萨大士。我心欢喜深自庆快。犹如苾刍得第三禅乐。大士。如我向于三摩地中所见如来。而不知彼从何所来去至何所。唯愿大士。示教于我。令我常得见佛世尊

    法上菩萨品第三十一

尔时法上菩萨摩诃萨谓常啼菩萨摩诃萨言。善男子。如来者。无所从来亦无所去。何以故。真如无动。真如即是如来。不生法无来无去。不生法即是如来。实际无来无去。实际即是如来。空性无来无去。空性即是如来。无染法无来无去无染法即是如来。寂灭无来无去。寂灭即是如来。虚空无来无去。虚空即是如来。善男子。离如是等法无别有法可名如来。此复云何。所谓如来真如。一切法真如。同是一真如。是如无分别无二亦无三。善男子。譬如春末夏初。于日中分阳焰动发。若时有人于中求水于汝意云何。彼水从何所来。为从东海来耶。南西北海来耶。其去亦然。常啼菩萨言。彼阳焰中无水可得。况复有来及有去耶。但是愚痴无智虚妄所见。法上菩萨言。善男子。一切如来亦复如是。若人着于色相及以音声。观诸如来若来若去起分别者。当知是人愚痴无智虚妄所见。何以故。如来者是即法身。非色身可见。善男子。法性无来无去。一切如来亦复如是无来无去。又如幻师幻化所作象兵马兵车兵步兵。如是四兵幻所作故无来无去。一切如来亦复如是无来无去。又如有人于其梦中。或见一佛二佛三四五佛乃至百千诸佛。善男子。而彼诸佛从何所来去至何所。常啼菩萨言。大士。梦所不实无决定法。于是法中何有去来。法上菩萨言。一切如来亦复如是。如佛所说。一切法如梦。有人不能如实了知一切法如梦故。即以色相音声语言名字。执着分别诸佛如来若来若去。善男子。若于是法中不如实知虚妄分别者。当知是等名愚异生。受生死身轮转诸趣。远离般若波罗蜜多。远离一切佛法。善男子。若人如实了知。如佛所说一切法如梦。于是法中即无有法若来若去。是故无所分别。如实了知一切如来无来无去不生不灭。如是知者。是为见法。是为知法。是人即近阿耨多罗三藐菩提。是行般若波罗蜜多。不虚受其国中信施。能与世间作大福田。善男子。又如大海出种种宝。是宝不从东方而来。亦复不从南西北方四维上下诸方而来。但是一切众生所作福业共感报应。是故大海出诸珍宝是宝一一从因缘生。亦不无因缘生。因缘和合即有。因缘散灭即无。有亦不从十方来。无亦不至十方去。诸如来身亦复如是。不从十方来不至十方去。但以因缘和合。所生不住。因缘法亦不无因缘生。因缘和合即生。因缘离散即灭。生亦不从十方来。灭亦不至十方去。善男子。又如箜篌有弦有槽有棍。若人以手鼓击出声。是声无所从来。不从弦出不从槽出。不从棍出不从手出。但以因缘和合有声。因缘散灭即无有声。是声灭已亦无所至。善男子。诸佛如来亦复如是。从一切相应善根种种因缘如理出生。非一因一缘一善根生。亦不无因缘生。缘合故生。生而无来。缘散故灭。灭而无去。善男子。汝当如是如实了知诸佛如来无来无去。若知诸佛无来去故。即住一切法无生无灭。如是知者。是行般若波罗蜜多善巧方便。决定得成阿耨多罗三藐三菩提

尔时法上菩萨摩诃萨。说是诸佛如来无来无去法时。三千大千世界六种震动现十八相。所谓动遍动等遍动。吼遍吼等遍吼。震遍震等遍震。踊遍踊等遍踊。爆遍爆等遍爆。击遍击等遍击。现如是等十八相已。一切魔宫隐蔽不现。非时开敷种种异华。大地一切华树果树皆悉倾向法上菩萨摩诃萨。帝释天主四大天王。及欲界诸天子众。于虚空中雨天妙华。向法上菩萨摩诃萨散掷供养。又复以诸天华散于常啼菩萨摩诃萨上。作如是言。善哉善哉。常啼菩萨。我等因仁者故。今日于法上菩萨摩诃萨所。得闻最上甚深正法。我等今日得大善利。斯为世间第一希有。尔时常啼菩萨摩诃萨白法上菩萨摩诃萨言。以何因缘大地震动及现诸相。法上菩萨言。善男子。我向为汝说诸佛如来无来去法乃有是相。尔时有八千人得无生法忍。八十千那庾多人发阿耨多罗三藐三菩提心。六万四千人远尘离垢得法眼净。尔时常啼菩萨摩诃萨。闻此法已心大庆快踊跃欢喜。作如是言。我于今日得最上利。以求般若波罗蜜多因缘故。于善知识所得闻诸佛如来无来去法。我今已得圆满如是善根。决定不退转于阿耨多罗三藐三菩提。作是语已转复欢喜。踊身虚空高七多罗树。于虚空中作是思惟。我今复从何得上妙香华。供养法上菩萨摩诃萨。尔时帝释天主知常啼菩萨心所念已。即以天曼陀罗华。奉上常啼菩萨摩诃萨。天主作是言。善男子。汝可持此妙华供养法上菩萨摩诃萨。我今助成于汝。利益无量无数众生。时常啼菩萨摩诃萨受帝释天主所奉华已。即以此华向法上菩萨摩诃萨散掷供养。华供养已合掌恭敬作如是言。菩萨大士。我从今日当以己身。奉事菩萨给侍供养。作是说已从空中下住菩萨前。尔时长者女并五百侍女。俱白常啼菩萨摩诃萨言。我等各以己身奉上于汝给侍供养。并其五百乘车亦同奉上。愿我世世所生。常得与汝同种善根常相值遇。常同亲近诸佛菩萨恭敬供养。我所献身愿垂纳受。尔时常啼菩萨摩诃萨告长者女等言。汝等若以诚心奉我。我有所行皆随顺者我即纳受。长者女等言。我等诚心奉上于汝。凡诸所作我等随顺。尔时常啼菩萨摩诃萨为纳受已。即白法上菩萨摩诃萨言。今此长者女并五百侍女。乃至宝严五百乘车。悉回奉上。菩萨大士愿垂纳受。尔时帝释天主赞常啼菩萨摩诃萨言。善哉善哉。善男子。如是喜舍甚为希有。若菩萨摩诃萨能如是舍者。速得阿耨多罗三藐三菩提。通达般若波罗蜜多善巧方便。善男子。过去诸佛如来应供正等正觉。本行菩萨道时。皆如汝今行是舍行。勤求般若波罗蜜多因缘。亦如汝今等无有异。尔时法上菩萨摩诃萨。为欲成就常啼菩萨摩诃萨善根故。即受是长者女等。受已即时复与常啼菩萨摩诃萨

尔时法上菩萨摩诃萨。过日后分。从法座起即入宫舍。是时常啼菩萨摩诃萨即作是念。我今为求法故宜应精进。当于二事若行若立。待法上菩萨摩诃萨还出宫舍复登法座。我当听受甚深正法。尔时法上菩萨摩诃萨。常入般若波罗蜜多三摩地。及无量无数菩萨三摩地。于是诸三摩地中住经七岁。常啼菩萨摩诃萨。亦于七岁中。若行若立未尝坐卧。不念饮食不生疲倦。但念法上菩萨摩诃萨。当于何时出三摩地还登法座。令我得闻般若波罗蜜多。是时常啼菩萨于法座所散种种华。彼长者女及五百侍女。亦学常啼菩萨。于七岁中若行若立未尝坐卧。不念饮食不生疲倦。亦复一心待彼菩萨出三摩地。尔时常啼菩萨摩诃萨。以乐法心勤精进故。忽闻空中有声告曰。法上菩萨后当七日出三摩地。常啼菩萨闻是空中声已。心大庆快踊跃欢喜。于法座所。与长者女并五百侍女。以种种宝清净严饰。时长者女等各各脱身所著妙衣积以为座。当令法上菩萨摩诃萨安处其座。尔时常啼菩萨即于是处周行求水为洒其地。是时诸魔隐蔽诸水悉令不现。魔作是念。常啼菩萨求水不得心当生苦。心生苦故退失道意善根不增。尔时常啼菩萨摩诃萨。知是魔力所隐蔽已即作是念。我今应自破身出血。于法座所为洒其地。何以故。尘土坌污菩萨当座非所清净。我今为求无上法故。设破己身何所吝惜。又复我从世世已来。以欲因缘受生死身轮转诸趣。唐捐其功终无利益。不曾为此清净法故舍自身命。是故今时宜应精进。作是念已即执利刀破身出血而洒其地。彼长者女并五百侍女。亦学常啼菩萨。破身出血而洒其地。彼常啼菩萨并长者女等勇猛坚固。作是事已善根增长。彼诸恶魔不得其便。尔时帝释天主。以其天眼观是事已即作是念。常啼菩萨摩诃萨。甚为希有。发大勇猛被坚固铠不惜身命。为求法故。为欲成就阿耨多罗三藐三菩提。广度一切众生出轮回苦。发大精进甚为希有。帝释天主作是念已。即令其地血所洒处。变成赤栴檀香水。面百由旬皆栴檀香。尔时帝释天主。即赞常啼菩萨摩诃萨言。善哉善哉。善男子。汝今为求无上法故发大精进。过去诸佛如来应供正等正觉。本行菩萨道时。亦如汝今等无有异。尔时常啼菩萨摩诃萨复作是念。法上菩萨摩诃萨当说法时。我无香华将何供养。帝释天主知所念已。即以千斛天曼陀罗华。奉上常啼菩萨摩诃萨。尔时常啼菩萨摩诃萨受是华已。等分其半先散座侧

尔时法上菩萨摩诃萨。过是七岁已从三摩地出。还诣法座安处其上。与无数百千大众恭敬围绕。时常啼菩萨摩诃萨。见法上菩萨摩诃萨处于座已心大欢喜。譬如苾刍得第三禅乐。即持帝释所奉天曼陀罗华先所分者。向法上菩萨摩诃萨散掷供养已。合掌谛心听受宣说般若波罗蜜多甚深正法

尔时法上菩萨摩诃萨。因常啼菩萨摩诃萨故谓诸众言。汝等当知。一切法平等。般若波罗蜜多亦平等。一切法离。般若波罗蜜多亦离。一切法无动。般若波罗蜜多亦无动。一切法无念。般若波罗蜜多亦无念。一切法无畏。般若波罗蜜多亦无畏。一切法无味。般若波罗蜜多亦无味。一切法无边。般若波罗蜜多亦无边。一切法无生。般若波罗蜜多亦无生。一切法无灭。般若波罗蜜多亦无灭。虚空无边。般若波罗蜜多亦无边。大海无边。般若波罗蜜多亦无边须弥山庄严。般若波罗蜜多亦庄严。虚空无分别。般若波罗蜜多亦无分别。色无边。般若波罗蜜多亦无边。受想行识无边。般若波罗蜜多亦无边。地界无边。般若波罗蜜多亦无边。水界火界风界空界识界无边。般若波罗蜜多亦无边。金刚喻法平等般若波罗蜜多亦平等。一切法无分别。般若波罗蜜多亦无分别。一切法无所得。般若波罗蜜多亦无所得。一切法平等无性。般若波罗蜜多亦平等无性。一切法无坏。般若波罗蜜多亦无坏。一切法不可思议。般若波罗蜜多亦不可思议

尔时常啼菩萨摩诃萨闻是法已。即于会中得入一切法平等三摩地。一切法离三摩地。一切法无动三摩地。一切法无。念三摩地。一切法无畏三摩地。一切法无味三摩地。一切法无边三摩地。一切法无生三摩地。一切法无灭三摩地。虚空无边三摩地。大海无边三摩地。须弥山庄严三摩地。虚空无分别三摩地。色无边三摩地。受想行识无边三摩地。地界无边三摩地。水火风空识界无边三摩地。金刚喻法平等三摩地。一切法无分别三摩地。一切法无所得三摩地。一切法平等无性三摩地。一切法无坏三摩地。一切法不可思议三摩地。常啼菩萨摩诃萨得入如是等六万三摩地门。于是诸三摩地中得见十方如兢伽沙数三千大千世界如兢伽沙数诸佛。世尊。各与菩萨声闻人天大众。以如是名字如是章句。宣说般若波罗蜜多。如法上菩萨摩诃萨。今此会中有诸大众恭敬围绕。以如是名字如是章句。宣说般若波罗蜜多。等无有异

尔时佛告须菩提言。如我所说。彼常啼菩萨摩诃萨。以如是等种种方便精进坚固。勤求般若波罗蜜多。而彼菩萨于彼法上菩萨摩诃萨所。得闻般若波罗蜜多。得入诸三摩地门。从三摩地出已即得多闻具足。如大海水深广无边。于现生中常得见佛。世世所生生诸佛刹。乃至于刹那间亦不暂离诸佛世尊。须菩提。当知求般若波罗蜜多者。有如是等功德利益。是故今我法中菩萨摩诃萨。诸求般若波罗蜜多者。亦应如是求

    嘱累品第三十二

尔时佛告尊者阿难言。汝今当知。般若波罗蜜多者是诸佛母。出生诸佛一切智智。阿难。若欲行般若波罗蜜多者。应当于此甚深正法受持读诵记念思惟为人演说。乃至书写一句一偈置清净处。以宝函盛尊重恭敬。即以种种金银珍宝香华灯涂幢幡宝盖等广大供养。乃至一香一华一礼一赞。随其所应恭敬供养。当知是人则受我教我所称赞。阿难。佛是汝大师不。阿难白佛言。世尊。佛是我大师。我是佛弟子。佛言。阿难。汝今是我弟子。汝于现世给侍恭敬尊重于我。我涅槃后汝当恭敬尊重供养此般若波罗蜜多甚深正法。是即恭敬尊重于我。是为最大报佛恩者。阿难。我今以是般若波罗蜜多甚深正法付嘱于汝。汝当受持慎勿忘失。宣通流布使不断绝。阿难。汝当精进助宣此法。莫作末后断佛种人。第二第三如是嘱累。阿难白佛言。如世尊敕。我当奉持。如世尊敕。我当奉持。如是三白已。佛言。阿难。当知随尔所时此般若波罗蜜多正法在世。即尔所时诸佛世尊在世说法。又复阿难。若有善男子善女人。于此般若波罗蜜多甚深正法。爱乐恭敬受持读诵。记念思惟为人演说。乃至书写尊重供养者。当知是善男子善女人。世世所生常得见佛听受正法

佛说此经已。慈氏等诸菩萨摩诃萨。尊者须菩提。尊者舍利子。尊者阿难等。诸大声闻众。并帝释天主等。乃至一切世间天人阿修罗等。闻佛所说皆大欢喜。信受奉行

佛说佛母出生三法藏般若波罗蜜多经卷第二十五


佛说观想佛母般若波罗蜜多菩萨经

    No. 259

    佛说观想佛母般若波罗蜜多菩萨经

        西天译经三藏朝散大夫试鸿胪少卿明教大师臣天息灾奉　诏译

灌顶真言

唵(引)曩莫舍吉野(二合)母曩曳(引)怛他誐哆野(引)啰贺(二合)帝三藐三没[馬*犬]野

诵此真言七遍。以手于头上灌顶。及摩触遍身然后息念志心。作佛母般若波罗蜜多菩萨观行。想此菩萨三面三眼身真金色。坐吉祥藏师子座。座有千叶金莲。身有六臂。右边三臂第一臂执数珠。第二臂执箭。第三臂作施愿相。左边三臂第一臂执经。第二臂执弓。第三臂执如意宝。如是六臂种种庄严。于其身上复放无数百千那由他俱胝光明。遍满一切世界。复想一切如来及多罗菩萨等一切菩萨。具足相好庄严其身。以诸香花而亲供养。如是观想已复念心真言

唵(引)曩莫舍吉野(二合)母曩曳怛他(引)誐哆野(引)啰贺(二合)谛(引)三藐三没[馬*犬](引)野怛儞野(二合)他(引)唵(引)母儞(引)母儞摩贺(引)母儞(引)曳(引)娑嚩(二合引)贺

次诵根本真言

怛儞野(二合)他(引)唵惹曳(引)惹曳(引)钵纳摩(二合引)鼻阿嚩弭(引)阿嚩弭(引)娑啰娑罗尼地里地里啰(引)地里地啰(引)地里儞嚩哆(引)努波(引)罗儞没度(引)哆(引)啰尼布啰野布啰野婆誐嚩底萨里嚩(二合引)舍(引)摩摩波里布啰野娑波里嚩啰写萨里嚩(二合引)萨怛鑁(二合)左萨里嚩(二合)迦里摩(二合引)嚩啰拏儞尾输[馬*犬]野尾输[馬*犬]野没[馬*犬](引)地瑟姹(二合引)儞曩娑嚩(二合引)贺(引)

诵此真言已复作观行。想彼佛母般若波罗蜜多菩萨右边。有释迦世尊燃灯世尊。无量寿世尊智决定世尊。光明王世尊雷声吼音世尊。金花世尊散花世尊。于菩萨左边。毗婆尸世尊羯俱忖那世尊。迦诺迦牟尼世尊迦叶世尊宝手世尊。于菩萨前面。大遍照世尊宝生世尊。阿弥陀世尊不空成就世尊阿閦世尊。于菩萨后面。最上莲华世尊最上宝世尊。喜吉祥世尊琉璃光世尊不思议吉祥世尊于菩萨前。复有圣观自在菩萨慈氏菩萨。普贤菩萨妙吉祥菩萨。归命菩萨不思议吉祥声菩萨。金刚手菩萨无尽意菩萨。辩积菩萨无边辩菩萨。虚空藏菩萨无垢称菩萨。自在行菩萨法生菩萨。常啼菩萨月光菩萨。法云菩萨地藏菩萨。宝藏菩萨宝幢菩萨。尸弃菩萨香象菩萨金毗罗菩萨。如是等一切菩萨摩诃萨遍满佛刹。复有颦眉明王等。亦在菩萨前。如是圣众一一观想已。复想人间天上殊妙香花珍宝供具。以用供养佛母般若波罗蜜多菩萨。并诸眷属一切菩萨。作此观已。是人不久当成正觉佛说观想佛母般若波罗蜜多菩萨经


佛说开觉自性般若波罗蜜多经

    No. 260

佛说开觉自性般若波罗蜜多经卷第一

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

如是我闻。一时世尊在王舍城鹫峰山中。与大苾刍众并菩萨摩诃萨众俱。是时佛告尊者须菩提言。须菩提。色无性假性实性。受想行识无性假性实性。须菩提。如是乃至眼色眼识。耳声耳识。鼻香鼻识。舌味舌识。身触身识。意法意识。无性假性实性

复次须菩提。色于如是三性中转愚。是所行当知是为菩萨正行。如是行者。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。若菩萨摩诃萨于诸识中解无相法。苦自止息诸相寂静。如是所行。当知是为菩萨正行。如是行者。是菩萨速疾证得阿耨多罗三藐三菩提果

尔时世尊重说颂曰

  若解无相法　　诸苦自止息
  众相皆寂静　　是菩萨所行

复次须菩提。于诸色中闇之与明平等依止菩萨若能如实了知。解入此者诸法亦然。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提受想行识亦复如是。于诸识中闇之与明平等依止。菩萨若能如实了知。解入此者诸法亦然。是菩萨速疾证得阿耨多罗三藐三菩提果

尔时世尊重说颂曰

  若法闇与明　　平等性如是
  依止及解入　　知已得菩提

复次须菩提。若菩萨摩诃萨于诸色须菩提。受想行识于三性转。若有智者如实了知。即于识中不生取着。亦不现转其心开明。由彼于识不生取着心开明已。即于大乘法中而能出离何况声闻缘觉乘中。又由如是不生取着心开明故。不于长时在彼地狱畜生饿鬼人天诸趣受生死苦

复次须菩提。色为生邪为灭邪。若谓色有生。彼色即无生。若谓色无生。彼色即是无生自性。若复菩萨如实了知彼色即是无生自性。是故于色无生可有

须菩提。受想行识亦复如是。识为生邪为灭邪。若谓识有生。彼识即无生。若谓识无生。彼识即是无生自性。若复菩萨如实了知彼识即是无生自性。是故于识无生可有

复次须菩提。若有人言。色是我是我所。作此说者。我说彼是外中之外。愚夫异生邪见分位

须菩提。若有人言。受想行识是我是我所。作此说者。我说彼是外中之外。愚夫异生邪见分位

复次须菩提。若有人言。色是先世因所成作。或大自在天所化因作。或无因缘。作此说者。我说彼是外中之外。愚夫异生邪见分位

须菩提。若有人言。受想行识是先世因所成作。或大自在天所化因作。或无因缘。作此说者。我说彼是外中之外。愚夫异生邪见分位

复次须菩提。若有人言。色以色像为相。受以领纳为相。想以遍知为相。行以造作为相。识以了别为相。作此说者。我说彼是外中之外。愚夫异生邪见分位

复次须菩提。若有人言。苦不寂静。若彼色灭此乐寂静。作此说者我说彼是外中之外。愚夫异生邪见分位

须菩提。若有人言。受想行识。亦复如是。苦不寂静若彼识灭。此乐寂静。作此说者我说彼是外中之外。愚夫异生邪见分位

复次须菩提。若有人言。彼色是无。受想行识亦悉是无。作此说者。我说彼是外中之外。愚夫异生邪见分位

复次须菩提若有人言。如佛所说。色无自性不生不灭。本来寂静自性涅槃。作是说者。彼于一切法即无和合亦无乐欲。随其言说作是知解。我说彼是外中之外。愚夫异生邪见分位

须菩提。若有人言。受想行识亦复如是。如佛所说。皆无自性不生不灭。本来寂静自性涅槃。作是说者。彼于一切法即无和合亦无乐欲。随其言说作是知解。我说彼是外中之外。愚夫异生邪见分位

复次须菩提。若复有人计色为有。取着于色有所生起。随言说转。又复计色为有。即于彼色杂染依止。有相随转。又复计色为有。即于彼色修习净法。成立随转

须菩提。受想行识亦复如是。若复有人计识为有。取着于识有所生起。随言说转。又复计识为有。即于彼识杂染依止。有相随转。又复计识为有。即于彼识修习净法。成立随转

复次须菩提。若诸菩萨计色为有。于彼色中有断有知。于大乐行言说成办。随有所转。又诸菩萨计色为有。于彼色中有断有知。表示成办随有所转。又诸菩萨计色为有。于彼色中以能了知白法具足。谓于诸法得自在已。于大乐行而能随转

须菩提。受想行识亦复如是。若诸菩萨计受想行识为有。于彼识中有断有知。于大乐行言说成办。随有所转。又诸菩萨计识为有。于彼识中有断有知。表示成办随有所转。又诸菩萨计识为有。于彼识中以能了知白法具足。谓于诸法得自在已。于大乐行而能随转

复次须菩提。若复有人于色中色所有分量。于苦中苦所有分量。不能如实平等观者。即于色中我有所得若于色中我有所得。即于色中我见有所得。若于色中我见有所得。即于色中众生见有所得。若于色中众生见有所得。即于色中彼众生见而无所得。若于色中彼众生见无所得时。即彼众生亦无所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

须菩提。受想行识亦复如是。若复有人于识中识所有分量。于苦中苦所有分量。不能如实平等观者。即于识中我有所得若。于识中我有所得。即于识中我见有所得。若于识中我见有所得。即于识中众生见有所得。若于识中众生见有所得。即于识中彼众生见而无所得。若于识中彼众生见无所得时。即彼众生亦无所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

复次须菩提。若复有人于色中色所有分量。于苦中苦所有分量。而能如实平等观者。即于色中我无所得。若于色中我无所得。即于色中我见无所得。若于色中我见无所得。即于色中众生见无所得。若于色中众生见无所得。即于色中彼众生见而有所得。若于色中彼众生见有所得时。即彼众生亦有所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

须菩提。受想行识亦复如是。若复有人于识中识所有分量。于苦中苦所有分量。而能如实平等观者。即于识中我无所得。若于识中我无所得。即于识中我见无所得。若于识中我见无所得。即于识中众生见无所得。若于识中众生见无所得即于识中彼众生见而有所得。若于识中彼众生见有所得时。即彼众生亦有所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

复次须菩提。若人于色中不能如实平等观察。不实分别分量及疑动分量故。即于色中色而有所得。若于色中色有所得时。即于色中色见有所得。若于色中色见有所得。即于色中众生有所得。若于色中众生有所得。即于色中一切有所得。若一切有所得时。即一切无所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

须菩提。若人于受想行识中。不能如实平等观察。不实分别分量及疑动分量故。即于识中识而有所得。若识中识有所得。即识中识见有所得。若识中识见有所得。即识中众生有所得。若识中众生有所得。即识中一切有所得。若识中一切有所得时。即一切无所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼声闻缘觉乘中不能出离。何况大乘

佛说开觉自性般若波罗蜜多经卷第一佛说开觉自性般若波罗蜜多经卷第二

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次须菩提。若人于色中所有不实分别分量及疑动分量。而能如实平等观者。即于色中色而无所得。若于色中色无所得时。即于色中色见无所得。若于色中色见无所得。即于色中众生无所得。若于色中众生无所得。即于色中一切无所得。若于色中一切无所得时。即一切有所得。若或于法有所得相可成立者。即有所得相而有依止。是故于彼大乘法中不能出离。何况声闻缘觉乘中。须菩提。若人于受想行识中所有不实分别分量及疑动分量。而能如实平等观者。即识中识而无所得。若识中识无所得时。即识中识见无所得。若识中识见无所得。即识中众生无所得。若识中众生无所得。即识中一切无所得。若识中一切无所得时。即一切有所得若或于法有所得。相可成立者。即有所得相而有依止。是故于彼大乘法中不能出离。何况声闻缘觉乘中

复次须菩提。若菩萨于诸色中随其言说。即生取著作用而行。如是行者是行有身见亦复行于有爱。若或离有寻求而有所行。是于色中不了知相。须菩提。受想行识亦复如是。若菩萨于诸识中随其言说。即生取著作用而行。如是行者是行有身见。亦复行于有爱。若或离有寻求而有所行。是于识中不了知相

复次须菩提。若菩萨于诸色中随其言说。不生取着不作用而行。是不行有身见。亦复不行有爱。离有寻求亦无所行。是于色中善了知相

须菩提。受想行识亦复如是。若菩萨于诸识中随其言说。不生取着不作用而行。是不行有身见。亦复不行有爱。离有寻求亦无所行。是于识中善了知相

复次须菩提。若菩萨摩诃萨于诸色中能具三种心种子缘而摄受者。是为净法。何等为三。一信解心种子。二厌离心种子。三不坏心种子

须菩提。受想行识亦复如是。若菩萨摩诃萨于诸识中能具三种心种子缘而摄受者。是为净法。何等为三。一信解心种子。二厌离心种子。三不坏心种子

复次须菩提。菩萨摩诃萨于诸色中应当发起三种之心。何等为三。一无取着心。二无和合心。三清净心。是故须菩提。菩萨摩诃萨。于彼色中若心有生。若心无生。大生平等生。悉应如实平等观察。由能如是平等观故。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨。于诸识中应当发起三种之心。何等为三。一无取着心。二无和合心。三清净心。是故须菩提。菩萨摩诃萨于彼识中。若心有生若心无生。大生平等生。悉应如实平等观察。由能如是平等观故。是菩萨速疾证得阿耨多罗三藐三菩提果

复次须菩提。若菩萨摩诃萨。于诸色中见有见无者。当知是菩萨不实知解。须菩提。受想行识亦复如是。若菩萨摩诃萨。于诸识中见有见无者。当知是菩萨不实知解

复次须菩提。若菩萨摩诃萨起心欲住平等界中。彼心于色求解脱时。即于色中其心动转。有动遍动。由如是故。当知此菩萨难得解脱

须菩提。受想行识亦复如是。若菩萨摩诃萨起心欲住平等界中。彼心于识求解脱时。即于识中其心动转。有动遍动。由如是故。当知此菩萨难得解脱

复次须菩提。若菩萨摩诃萨起心欲住平等界中。彼心于色求解脱时。若于色中心无系着无不系着。由如是故。当知此菩萨善得解脱

须菩提。受想行识亦复如是。若菩萨摩诃萨起心欲住平等界中。彼心于识求解脱时。若于识中心无系着无不系着。由如是故。当知此菩萨善得解脱

复次须菩提。若菩萨摩诃萨于诸色中解无相法。苦自止息诸相寂静。如夫异生不能如实了知色故。即于色中而生取着现转覆蔽。由彼于色生取着心现覆蔽已。即于声闻缘觉乘中不能出离。何况大乘。又由如是取着覆蔽因故。长时在于地狱畜生饿鬼人天诸趣。受生死苦轮转无尽

须菩提。受想行识亦复如是。乃至眼色眼识。耳声耳识。鼻香鼻识。舌味舌识。身触身识。意法意识。亦悉无性假性实性。须菩提。如是意识于三性转。愚夫异生不能如实了知识故。于识等中而生取着现转覆蔽。由彼于识生取着心现覆蔽已。即于声闻缘觉乘中不能出离。何况大乘。又由如是取着覆蔽因故。长时在于地狱畜生饿鬼人天诸趣。受生死苦轮转无尽

复次须菩提。如是色于三性中转。若有智者如实了知。即于色中不生取着。亦不现转其心开明。由彼于色不生取着心开明已。即于大乘法中而能出离。何况声闻缘觉乘中。又由如是不生取着心开明故。不于长时在彼地狱畜生饿鬼人天诸趣受生死苦。中推求于色无所得时。色即一切都无照发。色无照已。即于色法平等性中如实了知。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。若菩萨摩诃萨于诸识中推求于识无所得时。识即一切都无照发。识无照已。即于识法平等性中如实了知。是菩萨速疾证得阿耨多罗三藐三菩提果

尔时世尊重说颂曰

  推求无异法　　物境无照心
  智了于法性　　此即得菩提

复次须菩提。菩萨摩诃萨若于色中善解无性法者。即于色中色修作具足。而于色界亦无所动。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨若于识中善解无性法者。即于识中识修作具足。而于法界亦无所动。是菩萨速疾证得阿耨多罗三藐三菩提果

尔时世尊重说颂曰

  智善解无性　　修作悉具足
  亦不动法界　　即得一切智

复次须菩提。色中无义无句义大义。菩萨摩诃萨若能如实正了知者。是菩萨速疾证得阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。识中无义无句义大义。菩萨摩诃萨若能如实正了知者。是菩萨速疾证得阿耨多罗三藐三菩提果

尔时世尊重说颂曰

  无义无句义　　大义亦复然
  菩萨善了知　　速得菩提果

复次须菩提。菩萨摩诃萨于诸色中应当了知五种贪法。知已舍离。何等为五。一寻求贪。二遍寻求贪。三分别贪。四贪。五大贪

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中应当了知五种贪法。知已舍离。何等为五。一寻求贪。二遍寻求贪。三分别贪。四贪。五大贪

须菩提。菩萨摩诃萨于诸色中若能舍离此五贪已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得若无所得。诸种类色而悉超越。即能出离成就阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中若能舍离此五贪已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得。诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于诸色中应当了知五种嗔法。知已舍离。何等为五。一寻伺嗔。二遍寻伺嗔。三分别伺嗔。四嗔。五大嗔

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中应当了知五种嗔法。知已舍离。何等为五。一寻伺嗔。二遍寻伺嗔。三分别伺嗔。四嗔。五大嗔

须菩提。菩萨摩诃萨于诸色中若能舍离此五嗔已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得若无所得。诸种类色而悉超越。即能出离。成就阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中若能舍离此五嗔已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于诸色中应当了知五种痴法。知已舍离。何等为五。一动乱痴。二动乱相痴。三无动乱相痴。四痴。五大痴

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中应当了知五种痴法。知已舍离。何等为五。一动乱痴。二动乱相痴。三无动乱相痴。四痴。五大痴

须菩提。菩萨摩诃萨于诸色中若能舍离此五痴已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得若无所得。诸种类色而悉超越。即能出离成就阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中若能舍离此五痴已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得。诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于诸色中应当了知五种慢法。知已舍离。何等为五。一多闻慢。二高胜慢。三增上慢。四慢。五大慢

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中应当了知五种慢法。知已舍离。何等为五。一多闻慢。二高胜慢。三增上慢。四慢。五大慢

须菩提。菩萨摩诃萨于诸色中若能舍离此五慢已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得若无所得。诸种类色而悉超越。即能出离成就阿耨多罗三藐三菩提果

须菩提。受想行识亦复如是。菩萨摩诃萨于诸识中若能舍离此五慢已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得。诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

佛说开觉自性般若波罗蜜多经卷第二佛说开觉自性般若波罗蜜多经卷第三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

复次须菩提。菩萨摩诃萨于色法中应当了知五种见法。知已舍离。何等为五。一自性颠倒见。二有见。三诬谤见。四见。五大见。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知五种见法。知已舍离。何等为五。一自性颠倒见。二有见。三诬谤见。四见。五大见。须菩提。菩萨摩诃萨于色法中若能舍离此五见已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得。若无所得诸种类色而悉超越。即能出离成就阿耨多罗三藐三菩提果。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中若能舍离此五见已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得。诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于色法中应当了知五种疑法。知已舍离。何等为五。一法疑。二诸趣苦疑三佛菩萨法寂静疑。四疑五大疑。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知五种疑法。知已舍离。何等为五。一法疑。二诸趣苦疑。三佛菩萨法寂静疑。四疑。五大疑。须菩提。菩萨摩诃萨于色法中若能舍离此五疑已。即于诸色自性无所得。若色自性无所得时。即色中色亦无所得。若色中色无所得时。即色中色而有所得。若色中色有所得者。即彼色中色而无所得。由如是故。于诸色中若有所得若无所得。诸种类色而悉超越。即能出离成就阿耨多罗三藐三菩提果。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中若能舍离此五疑已。即于诸识自性无所得。若识自性无所得时。即识中识亦无所得。若识中识无所得时。即识中识而有所得。若识中识有所得者。即彼识中识而无所得。由如是故。于诸识中若有所得若无所得。诸种类识而悉超越。即能出离成就阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于色法中若有所求。或于色中有所说法。或于色中清净身语意业。乃于彼色如言所说如所称赞。以如是求故。如是说法故。如是清净身语意业故。而是菩萨摩诃萨于彼色中返求于苦。当知是菩萨摩诃萨不正说法。不能清净身语意业。须菩提。若菩萨摩诃萨虽求于色。色中说法。色中清净身语意业。而于色中不如言如说。不如所称赞。以不如是求故。不如是说法故。不如是清净身语意业故。菩萨摩诃萨能于色中如是求者。当知是菩萨摩诃萨能正说法。能于色中清净身语意业。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中若有所求。或于识中有所说法。或于识中清净身语意业。乃于彼识如言如说如所称赞。以如是求故。如是说法故。如是清净身语意业故。而是菩萨摩诃萨于彼识中返求于苦。当知是菩萨摩诃萨不正说法。不能清净身语意业。须菩提。若菩萨摩诃萨虽求于识。识中说法。识中清净身语意业。而于识中不如言如说。不如所称赞。以不如是求故。不如是说法故。不如是清净身语意业故。菩萨摩诃萨若于识中如是求者。当知是菩萨摩诃萨能正说法。能于识中清净身语意业

复次须菩提。若菩萨摩诃萨起心欲住平等界中。于彼色法起信解时。即二中二而有所得。谓所信解色及能信解色。是菩萨摩诃萨乃于色中随所信解说能信解。随能信解说所信解。当知是菩萨摩诃萨于诸色中不正说法。何以故。须菩提。以所信解色与能信解色无有异相。须菩提。若于色中能所信解有异相者。即一切众生种种信解。平等法中有差别相可见可得。即非梦等无所缘信解可得。由是愚夫异生。于诸色中而起实见。不与无分别信解如理相应。须菩提。若于色中无所信解转者。是故一切众生种种信解而悉平等。于所信解中无差别相可见可得。即如梦等无所缘信解而有所得。由是愚夫异生。于诸色中不起实见。即与无分别信解如理相应。是故应知能信解色与所信解色无有异相。诸菩萨摩诃萨当如是见。如是见者即无异相可见。乃于色中随能信解所起。即是所信解。此中所说是义明显。若菩萨摩诃萨如是观者。诸有所说是为正说。由如是故。当知色中能所信解二法和合。离能无所非不有故。诸菩萨摩诃萨先于能信解色想如实而观。次复于二色想亦如实观。如是观已即于一切色悉无所得。若一切色无所得时。即色中动乱而有所得。若色中动乱有所得时。即色动乱相而有所得。若色动乱相有所得时。即色动乱法有所合集。色动乱法有所集故。即彼色中无动乱平等法而有所集。诸菩萨摩诃萨若于如是如前所说色中。所有动乱及无动乱法。不合集者。即于色中无彼动乱法及无动乱平等法而为依止。即当修集一切佛法。成熟有情严净佛土。速疾成就阿耨多罗三藐三菩提果。诸菩萨摩诃萨于诸色中若能如是善开觉时。诸有所说是为正说。须菩提。受想行识亦复如是。若菩萨摩诃萨起心欲住平等界中。于彼识法起信解时。即二中二而有所得。谓所信解识及能信解识。是菩萨摩诃萨乃于识中随所信解说能信解。随能信解说所信解。当知是菩萨摩诃萨于诸识中不正说法。何以故。须菩提。以所信解识与能信解识无有异相。须菩提。若于识中能所信解有异相者。即一切众生种种信解。平等法中有差别相可见可得。即非梦等无所缘信解可得。由是愚夫异生。于诸识中而起实见。不与无分别信解如理相应。须菩提。若于识中无所信解转者。是故一切众生种种信解而悉平等。于所信解中无差别相可见可得。即如梦中无所缘信解而有所得。由是愚夫异生。于诸识中不起实见。即与无分别信解如理相应。是故应知能信解识与所信解识无有异相。诸菩萨摩诃萨当如是见。如是见者即无异相可见。乃于识中随能信解所起。即是所信解。此中所说是义明显。若菩萨摩诃萨如是观者。诸有所说是为正说。由如是故。当知识中能所信解二法和合。离能无所非不有故。诸菩萨摩诃萨先于能信解识想如实而观。次复于二识想亦如实观。如是观已。即于一切识悉无所得。若一切识无所得时。即识中动乱而有所得。若识中动乱有所得时。即识动乱相而有所得。若识动乱相有所得时。即识动乱法有所合集。识动乱法有所集故。即彼识中无动乱。平等法而有所集。诸菩萨摩诃萨若于如是如前所说识中。所有动乱及无动乱法。不合集者。即于识中无彼动乱法及无动乱。平等法而为依止。即当修集一切佛法。成熟有情严净佛土。速疾成就阿耨多罗三藐三菩提果。诸菩萨摩诃萨于诸识中若能如是善开觉时。诸有所说是为正说

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行慈法。何等为五。一摄受正法慈。二摄受世间诸乐慈。三摄受出世胜妙乐慈。四慈。五大慈。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相修行慈法。何等为五。一摄受正法慈。二摄受世间诸乐慈。三摄受出世胜妙乐慈。四慈。五大慈

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相修行悲法。何等为五。一无取着悲。二和合悲。三离散悲。四悲。五大悲。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相修行悲法。何等为五。一无取着悲。二和合悲。三离散悲。四悲。五大悲

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相修行喜法。何等为五。一正法清净不坏随喜摄受喜。二世间诸乐不坏随喜摄受喜。三出世妙乐不坏随喜摄受喜。四喜。五大喜。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相修行喜法。何等为五。一正法清净不坏随喜摄受喜。二世间诸乐不坏随喜摄受喜。三出世妙乐不坏随喜摄受喜。四喜。五大喜

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相修行舍法。何等为五。一蠲除诸不正见及诸杂染舍。二远离一切过失蠲除诸杂染舍。三摄聚一切功德蠲除诸杂染舍。四舍。五大舍。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相修行舍法。何等为五。一蠲除诸不正见及诸杂染舍。二远离一切过失蠲除诸杂染舍。三摄聚一切功德蠲除诸杂染舍。四舍。五大舍

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行布施波罗蜜多。何等为五。一誓愿施。二财及无畏施。三法施。四施。五大施。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行布施波罗蜜多。何等为五。一誓愿施。二财及无畏施。三法施。四施五大施

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行持戒波罗蜜多。何等为五。一饶益有情戒。二定法戒。三无漏法戒。四戒。五大戒。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行持戒波罗蜜多。何等为五。一饶益有情戒。二定法戒。三无漏法戒。四戒。五大戒

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行忍辱波罗蜜多。何等为五。一耐怨害忍。二安受苦忍。三谛察法忍。四忍。五大忍。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行忍辱波罗蜜多。何等为五。一耐怨害忍。二安受苦忍。三谛察法忍。四忍。五大忍

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行精进波罗蜜多。何等为五。一解说读诵思惟精进。二远离一切过失精进。三摄聚一切功德精进。四精进。五大精进。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行精进波罗蜜多。何等为五。一解说读诵思惟精进。二远离一切过失精进。三摄聚一切功德精进。四精进。五大精进

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行禅定波罗蜜多。何等为五。一善解不离文字定。二善离文字最初清净世间定。三出世间定。四定。五大定。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行禅定波罗蜜多。何等为五。一善解不离文字定。二善离文字最初清净世间定。三出世间定。四定。五大定

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。修行般若波罗蜜多。何等为五。一善解不离文字定所依止慧。二善离文字最初清净世间定所依止慧。三出世间定所依止慧。四慧。五大慧。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。修行般若波罗蜜多。何等为五。一善解不离文字定所依止慧。二善离文字最初清净世间定所依止慧。三出世间定所依止慧。四慧。五大慧

佛说开觉自性般若波罗蜜多经卷第三佛说开觉自性般若波罗蜜多经卷第四

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相。亲近善知识。何等为五。一听受亲近。二承事作用学法亲近。三修行进向亲近。四亲近。五大亲近。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相。亲近善知识。何等为五。一听受亲近。二承事作用学法亲近。三修行进向亲近。四亲近。五大亲近。如是亲近善知识时。菩萨摩诃萨以解脱方便而为摄受。即能生多福。疾成阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于色法中应当了知有五种相供养如来。何等为五。一种种赞叹恭信供养。二以清净利养恭信供养。三修行进向供养。四供养。五大供养。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中应当了知有五种相供养如来。何等为五。一种种赞叹恭信供养。二以清净利养恭信供养。三修行进向供养。四供养。五大供养。须菩提。菩萨摩诃萨若能如是供养如来如理相应者。即得无边世界诸佛菩萨共所称赞。亦得世间天人阿修罗等利养供给。成熟无量无边众生严净佛土。疾成阿耨多罗三藐三菩提果

复次须菩提。菩萨摩诃萨于色法中能与布施波罗蜜多如理相应者。若修有相施。亦速圆满布施波罗蜜多。若修无相施。亦速圆满布施波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相施或无相施。须菩提。若菩萨摩诃萨于色法中修行布施求解脱时。有所解脱布施可得。有能解脱布施可得。如是修者。当知是菩萨摩诃萨于色法中修有相施。若菩萨摩诃萨于色法中修行布施求解脱时。无所解脱布施可得。无能解脱布施可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相施。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中能与布施波罗蜜多如理相应者。若修有相施。亦速圆满布施波罗蜜多。若修无相施。亦速圆满布施波罗蜜多。须菩提。云何是菩萨摩诃萨于识法中修有相施或无相施。须菩提。若菩萨摩诃萨于识法中修行布施求解脱时。有所解脱布施可得。有能解脱布施可得。如是修者。当知是菩萨摩诃萨于识法中修有相施。若菩萨摩诃萨于识法中修行布施求解脱时。无所解脱布施可得。无能解脱布施可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相施

复次须菩提。菩萨摩诃萨于色法中能与持戒波罗蜜多如理相应者。若修有相持戒。亦速圆满持戒波罗蜜多。若修无相持戒。亦速圆满持戒波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相持戒或无相持戒。须菩提。若菩萨摩诃萨于色法中修行持戒求解脱时。有所解脱持戒可得。有能解脱持戒可得。如是修者。当知是菩萨摩诃萨于色法中修有相持戒。若菩萨摩诃萨于色法中修行持戒求解脱时。无所解脱持戒可得。无能解脱持戒可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相持戒。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中能与持戒波罗蜜多如理相应者。若修有相持戒。亦速圆满持戒波罗蜜多。若修无相持戒。亦速圆满持戒波罗蜜多。须菩提。云何是菩萨摩诃萨于识法中修有相持戒或无相持戒。须菩提。若菩萨摩诃萨于识法中修行持戒求解脱时。有所解脱持戒可得。有能解脱持戒可得。如是修者。当知是菩萨摩诃萨于识法中修有相持戒。若菩萨摩诃萨于识法中修行持戒求解脱时。无所解脱持戒可得。无能解脱持戒可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相持戒

复次须菩提菩萨摩诃萨于色法中能与忍辱波罗蜜多如理相应者。若修有相忍辱。亦速圆满忍辱波罗蜜多。若修无相忍辱。亦速圆满忍辱波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相忍辱或无相忍辱。须菩提。若菩萨摩诃萨于色法中修行忍辱求解脱时。有所解脱忍辱可得。有能解脱忍辱可得。如是修者。当知是菩萨摩诃萨于色法中修有相忍辱。若菩萨摩诃萨于色法中修行忍辱求解脱时。无所解脱忍辱可得。无能解脱忍辱可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相忍辱。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中能与忍辱波罗蜜多如理相应者。若修有相忍辱。亦速圆满忍辱波罗蜜多。若修无相忍辱。亦速圆满忍辱波罗蜜多。须菩提云何是菩萨摩诃萨于识法中修有相忍辱或无相忍辱。须菩提。若菩萨摩诃萨于识法中修行忍辱求解脱时。有所解脱忍辱可得。有能解脱忍辱可得。如是修者。当知是菩萨摩诃萨于识法中修有相忍辱。若菩萨摩诃萨于识法中修行忍辱求解脱时。无所解脱忍辱可得。无能解脱忍辱可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相忍辱

复次须菩提。菩萨摩诃萨于色法中。能与精进波罗蜜多如理相应者。若修有相精进。亦速圆满精进波罗蜜多。若修无相精进。亦速圆满精进波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相精进或无相精进。须菩提。若菩萨摩诃萨于色法中修行精进求解脱时。有所解脱精进可得。有能解脱精进可得。如是修者。当知是菩萨摩诃萨于色法中修有相精进。若菩萨摩诃萨于色法中。修行精进求解脱时。无所解脱精进可得。无能解脱精进可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相精进。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中能与精进波罗蜜多如理相应者。若修有相精进。亦速圆满精进波罗蜜多。若修无相精进。亦速圆满精进波罗蜜多。须菩提。云何是菩萨摩诃萨于识法中修有相精进或无相精进。须菩提。若菩萨摩诃萨。于识法中修行精进求解脱时。有所解脱精进可得。有能解脱精进可得。如是修者。当知是菩萨摩诃萨于识法中修有相精进。若菩萨摩诃萨于识法中修行精进求解脱时。无所解脱精进可得。无能解脱精进可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相精进

复次须菩提。菩萨摩诃萨于色法中能与禅定波罗蜜多如理相应者。若修有相禅定。亦速圆满禅定波罗蜜多。若修无相禅定。亦速圆满禅定波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相禅定或无相禅定。须菩提。若菩萨摩诃萨于色法中修行禅定求解脱时。有所解脱禅定可得。有能解脱禅定可得。如是修者。当知是菩萨摩诃萨于色法中修有相禅定。若菩萨摩诃萨于色法中修行禅定求解脱时。无所解脱禅定可得。无能解脱禅定可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相禅定。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中。能与禅定波罗蜜多如理相应者。若修有相禅定。亦速圆满禅定波罗蜜多。若修无相禅定。亦速圆满禅定波罗蜜多。须菩提。云何是菩萨摩诃萨于识法中。修有相禅定或无相禅定。须菩提。若菩萨摩诃萨于识法中修行禅定求解脱时。有所解脱禅定可得。有能解脱禅定可得。如是修者。当知是菩萨摩诃萨于识法中修有相禅定。若菩萨摩诃萨于识法中修行禅定求解脱时。无所解脱禅定可得。无能解脱禅定可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相禅定

复次须菩提。菩萨摩诃萨于色法中能与般若波罗蜜多如理相应者。若修有相般若。亦速圆满般若波罗蜜多。若修无相般若。亦速圆满般若波罗蜜多。须菩提。云何是菩萨摩诃萨于色法中修有相般若或无相般若。须菩提。若菩萨摩诃萨于色法中修行般若求解脱时。有所解脱般若可得。有能解脱般若可得。如是修者。当知是菩萨摩诃萨于色法中修有相般若。若菩萨摩诃萨于色法中修行般若求解脱时。无所解脱般若可得。无能解脱般若可得。何以故。谓色自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于色法中修无相般若。须菩提。受想行识亦复如是。菩萨摩诃萨于识法中能与般若波罗蜜多如理相应者。若修有相般若。亦速圆满般若波罗蜜多。若修无相般若。亦速圆满般若波罗蜜多。须菩提。云何是菩萨摩诃萨于识法中修有相般若或无相般若。须菩提。若菩萨摩诃萨于识法中。修行般若求解脱时。有所解脱般若可得。有能解脱般若可得。如是修者。当知是菩萨摩诃萨于识法中修有相般若。若菩萨摩诃萨于识法中修行般若求解脱时。无所解脱般若可得。无能解脱般若可得。何以故。谓识自性无所得故。本性无所得故。观诸如来亦无所得。本性无所得故。如是修者。当知是菩萨摩诃萨于识法中修无相般若

复次须菩提。菩萨摩诃萨于色法中应当了知空三摩地。须菩提。云何是色中空三摩地。菩萨摩诃萨谓于色中观无性空。性空亦然。本性空亦然。诸所缘事。皆当安住心一境性。此即是为色中空三摩地。须菩提。菩萨摩诃萨若于色中如是如实了知空三摩地已。受想行识亦复如是

复次须菩提。菩萨摩诃萨于色法中应当了知无相三摩地。须菩提。云何是色中无相三摩地菩萨摩诃萨谓于色中观无性空。性空亦然。本性空亦然。若能如是诸作意灭。即于色中观无性相。有性相亦然。有性无性相亦然。如是乃得无性相离识随逐。有性相亦然离识随逐。有性无性相亦然离识随逐。故能安住心一境性。此即是为色中无相三摩地。须菩提。菩萨摩诃萨若于色中。如是如实了知无相三摩地已。受想行识亦复如是

复次须菩提。菩萨摩诃萨于色法中。应当了知无愿三摩地。须菩提。云何是色中无愿三摩地。菩萨摩诃萨谓于色中得空无相三摩地已。即于色中观无性相。而不随逐所缘行相有性相亦然。而不随逐所缘行相。有性无性相亦然而不随逐所缘行相。故能安住心一境性。此即是谓色中无愿三摩地。须菩提。菩萨摩诃萨若于色中如是如实了知无愿三摩地已。受想行识亦复如是

复次须菩提。菩萨摩诃萨于色法中应当了知有三种义诸行无常何等为三。一不实义。二破坏义。三有垢无垢义。须菩提。受想行识亦复如是。菩萨摩诃萨应当了知有三种义诸行无常

复次须菩提。菩萨摩诃萨于色法中应当了知有三种义诸行是苦。何等为三。一无取着义。二三种相义。三相续义。须菩提。受想行识亦复如是。菩萨摩诃萨应当了知有三种义诸行是苦

复次须菩提。菩萨摩诃萨。于色法中应当了知。有三种义诸法无我。何等为三。一无性无我义。二有性无性无我义。三本性清净无我义。须菩提。受想行识亦复如是。菩萨摩诃萨应当了知有三种义诸法无我

复次须菩提。菩萨摩诃萨于色法中应当了知有三种义涅槃寂静。何等为三。一色中无性毕竟寂静义。二有性无性寂静义。三本性清净寂静义。须菩提。受想行识亦复如是。菩萨摩诃萨应当了知有三种义涅槃寂静。佛说此经已。诸菩萨摩诃萨。尊者须菩提。及诸苾刍苾刍尼。优婆塞优婆夷。一切世间天人阿修罗乾闼婆等。闻佛所说皆大欢喜。信受奉行

佛说开觉自性般若波罗蜜多经卷第四


佛说了义般若波罗蜜多经

    No. 247

    佛说了义般若波罗蜜多经

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时世尊。告尊者舍利子言。汝今当知。诸有菩萨摩诃萨乐欲修习般若波罗蜜多相应行者。当于诸法如实了知诸有所作离一切相。是时尊者舍利子。合掌恭敬前白佛言。世尊。如世尊言。诸有菩萨摩诃萨。乐欲修习般若波罗蜜多相应行者。云何了知诸法自性。于诸所作云何离相。佛言舍利子。若诸菩萨摩诃萨。乐欲圆满相应胜行及于诸法离所作相者。当了诸法住无所住。即能圆满相应胜行。复次舍利子。若诸菩萨摩诃萨。于诸法中行施行者。无能施无所施施无所得。若如是者。即能圆满施波罗蜜。又复修习诸戒法者。无能持无所持无起作。若如是者。即能圆满戒波罗蜜。又复修习忍辱法者。于诸法中无所动转离诸起作。若如是者。即能圆满忍波罗蜜。又复当于相应行中精进修习。若身若心无有懈倦无起作相。若如是者。即能圆满精进波罗蜜。又复于诸法中无有散乱离所得相。若如是者。即能圆满定波罗蜜

舍利子。若诸菩萨摩诃萨。乐欲安住般若波罗蜜多相应者。应当圆满四念处。四正断。四神足。五根。五力。七觉支。八正道法

又复观想空三摩地。无相三摩地。无愿三摩地。四禅定法。四无量法。四无色定法。八解脱法。九先行法。九想法。何名九想。所谓内法想尾布野迦想。离赤想。离青想。尾佉祢多想。无住想。离散想。无热恼想。离饮食想。如是名为九想法

又复念佛想。念法想。念僧想。念戒施天等想。离烦恼想。念生灭想。念无常苦无我等想。念诸世间不究竟想。念苦智想。集智想。灭智想。道智想。尽智想。无生智想。法智想。无我智想。和合智想。如实智想。语言分别想。离语言分别想。未知当知根想。已知根想。具知根想。不净想。清净想。奢摩他毗钵舍那想。三明想。四了知想。四无畏想。五神通想。六波罗蜜想。七种住心想。八大人法想。九众生住想。如来十力想。十八不共法想。大慈想。大悲想。乃至一切智智想。于如是等法当作如是想

又复诸菩萨摩诃萨。乐欲圆满一切智一切种智者。当于般若波罗蜜多如实观想

又复若欲圆满道相智一切相智。了达一切众生心行相等。断除一切众生诸杂染者。应当修习般若波罗蜜多相应胜行。舍利子。如我上说诸法想门。菩萨摩诃萨当如是学

尔时尊者舍利子复白佛言。世尊。诸菩萨摩诃萨。修般若波罗蜜多者当断何法。佛言舍利子。修般若波罗蜜多者。应当断除十种疑惑。何等为十。所谓有性疑。无性疑。诸法差别疑。毁谤疑。一法疑。多法疑。同异疑。上品疑。如名疑。如名义疑。此等十疑应当除断。若如是者。即菩萨摩诃萨于一切相悉无所观。以相无所观故。名亦无所观般若波罗蜜多。亦无所观诸行。无所观色。无所观受想行识。皆无所观。何以故。色自性空空离性故。色体即空离色无别空。空体即色离空无别色。是义云何。名分别故。舍利子当知。色法自性不生不灭非染非净。彼名自性。亦非缘法离诸疑惑。无所从来亦无所住。如实所生离三际故。色法如是。受想行识亦复如是。是故菩萨摩诃萨。于诸名相皆无所观。以无所观故而无所入。无所入者。即能圆满般若波罗蜜多相应胜行佛说了义般若波罗蜜多经


佛说能断金刚般若波罗蜜多经

    No. 239 [Nos. 220(9), 235-238]

    佛说能断金刚般若波罗蜜多经

        唐三藏沙门义净译

如是我闻。一时薄伽梵。在名称大城战胜林施孤独园。与大苾刍众千二百五十人俱。及大菩萨众。尔时世尊于日初分时。着衣持钵入城乞食。次第乞已还至本处。饭食讫收衣钵洗足已。于先设座加趺端坐正念而住。时诸苾刍来诣佛所。顶礼双足右绕三匝。退坐一面。尔时具寿妙生在大众中。承佛神力即从座起。偏袒右肩右膝着地。合掌恭敬白佛言。希有世尊。希有善逝。如来应正等觉。能以最胜利益。益诸菩萨。能以最胜付嘱。嘱诸菩萨。世尊。若有发趣菩萨乘者。云何应住。云何修行。云何摄伏其心

佛告妙生。善哉善哉。如是如是。如汝所说。如来以胜利益益诸菩萨。以胜付嘱嘱诸菩萨。妙生。汝应谛听极善作意。吾当为汝分别解说。若有发趣菩萨乘者。应如是住如是修行。如是摄伏其心。妙生言。唯然世尊。愿乐欲闻。佛告妙生。若有发趣菩萨乘者。当生如是心。所有一切众生之类。若卵生胎生湿生化生。若有色无色。有想无想。非有想非无想。尽诸世界所有众生。如是一切。我皆令入无余涅槃而灭度之。虽令如是无量众生证圆寂已。而无有一众生入圆寂者。何以故。妙生。若菩萨有众生想者。则不名菩萨。所以者何。由有我想众生想寿者想。更求趣想故

复次妙生。菩萨不住于事应行布施。不住随处应行布施。不住色声香味触法应行布施。妙生。菩萨如是布施。乃至相应亦不应住。何以故。由不住施福聚难量

妙生。于汝意云何。东方虚空可知量不。妙生言。不尔世尊。南西北方四维上下十方虚空可知量不。妙生言。不尔世尊。妙生。菩萨行不住施。所得福聚不可知量。亦复如是

妙生。于汝意云何。可以具足胜相观如来不。妙生言。不尔世尊。不应以胜相观于如来。何以故。如来说胜相即非胜相。妙生。所有胜相皆是虚妄。若无胜相即非虚妄。是故应以胜相无相观于如来。妙生言。世尊。颇有众生。于当来世后五百岁正法灭时。闻说是经生实信不

佛告妙生。莫作是说。颇有众生。于当来世后五百岁正法灭时。闻说是经生实信不。妙生。当来之世有诸菩萨。具戒具德具慧。而彼菩萨非于一佛承事供养植诸善根。已于无量百千佛所。而行奉事植诸善根。是人乃能于此经典生一信心

妙生。如来悉知是人悉见是人。彼诸菩萨当生当摄无量福聚。何以故。由彼菩萨无我想众生想寿者想更求趣想。彼诸菩萨非法想非非法想。非想非无想。何以故。若彼菩萨有法想。即有我执。有情执寿者执更求趣执。若有非法想。彼亦有我执。有情执寿者执更求趣执。妙生。是故菩萨不应取法不应取非法。以是义故。如来密意。宣说筏喻法门。诸有智者法尚应舍何况非法

妙生。于汝意云何。如来于无上菩提有所证不。复有少法是所说不。妙生言。如我解佛所说义。如来于无上菩提。实无所证亦无所说。何以故。佛所说法不可取不可说。彼非法非非法。何以故。以诸圣者皆是无为所显现故。妙生。于汝意云何。若善男子善女人。以满三千大千世界七宝。持用布施得福多不。妙生言。甚多世尊。何以故。此福聚者则非是聚。是故如来说为福聚福聚

妙生。若有善男子善女人。以满三千大千世界七宝。持用布施。若复有人能于此经乃至一四句颂。若自受持为他演说。以是因缘。所生福聚极多于彼无量无数。何以故。妙生。由诸如来无上等觉从此经出。诸佛世尊从此经生。是故妙生。佛法者如来说非佛法是名佛法

妙生。于汝意云何。诸预流者颇作是念。我得预流果不。妙生言。不尔世尊。何以故。诸预流者无法可预故名预流。不预色声香味触法故名预流。世尊。若预流者作是念。我得预流果者。则有我执有情寿者更求趣执。妙生。于汝意云何。诸一来者颇作是念。我得一来果不。妙生言。不尔世尊。何以故。由彼无有少法证一来性故名一来。妙生。于汝意云何。诸不还者颇作是念。我得不还果不。妙生言。不尔世尊。何以故。由彼无有少法证不还性故名不还。妙生。于汝意云何。诸阿罗汉颇作是念。我得阿罗汉果不。妙生言。不尔世尊。由彼无有少法名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉果者。则有我执有情寿者更求趣执。世尊。如来说我得无诤住中最为第一。世尊。我是阿罗汉离于欲染。而实未曾作如是念我是阿罗汉。世尊。若作是念我得阿罗汉者。如来即不说我妙生得无诤住最为第一。以都无所住。是故说我得无诤住得无诤。住妙生。于汝意云何。如来昔在然灯佛所。颇有少法是可取不。妙生言。不尔世尊。如来于然灯佛所实无可取。妙生。若有菩萨作如是语。我当成就庄严国土者。此为妄语。何以故。庄严佛土者如来说非庄严。由此说为国土庄严。是故妙生。菩萨不住于事。不住随处。不住色声香味触法。应生其心。应生不住事心。应生不住随处心。应生不住色声香味触法心。妙生。譬如有人身如妙高山王。于意云何。是身为大不。妙生言。甚大世尊。何以故。彼之大身如来说为非身。以彼非有说名为身

妙生。于汝意云何。如弶伽河中所有沙数。复有如是沙等弶伽河。此诸河沙宁为多不。妙生言。甚多世尊。河尚无数况复其沙。妙生。我今实言告汝。若复有人以宝满此河沙数量世界。奉施如来得福多不。妙生言。甚多世尊。妙生。若复有人于此经中受持一颂并为他说。而此福聚胜前福聚无量无边妙生。若国土中有此法门。为他解说乃至四向伽他。当知此地即是制底。一切天人阿苏罗等。皆应右绕而为敬礼。何况尽能受持读诵。当知是人则为最上第一希有。又此方所即为有佛及尊重弟子

妙生。于汝意云何。颇有少法是如来所说不。妙生言。不尔世尊。无有少法是如来所说。妙生。三千大千世界所有地尘是为多不。妙生言。甚多世尊。何以故。诸地尘佛说非尘故名地尘。此诸世界佛说非界。故名世界。妙生。于汝意云何。可以三十二大丈夫相观如来不。妙生言。不尔世尊。不应以三十二相观于如来。何以故。三十二相佛说非相。是故说为大丈夫相。妙生。若有男子女人以弶伽河沙等身命布施。若复有人于此经中受持一颂并为他说。其福胜彼无量无数。尔时妙生闻说是经。深解义趣涕泪悲泣而白佛言。希有世尊。我从生智以来。未曾得闻如是深经。世尊。当何名此经。我等云。何奉持。佛告妙生是经名为般若波罗蜜多。如是应持。何以故。佛说般若波罗蜜多则非般若波罗蜜多。世尊。若复有人闻说是经生实想者。当知是人最上希有。世尊。此实想者即非实想。是故如来说名实想实想。世尊。我闻是经心生信解未为希有。若当来世有闻是经能受持者。是人则为第一希有。何以故。彼人无我想众生想寿者想更求趣想。所以者何世尊。我想众生想寿者想更求趣想即是非想。所以者何。诸佛世尊离诸想故

妙生。如是如是。若复有人得闻是经。不惊不怖不畏。当知是人第一希有。何以故。妙生。此最胜波罗蜜多。是如来所说诸波罗蜜多。如来说者即是无边佛所宣说。是故名为最胜波罗蜜多。妙生。如来说忍辱波罗蜜多即非忍辱波罗蜜多。何以故。如我昔为羯陵伽王割截支体时。无我想众生想寿者想更来趣想。我无是想亦非无想。所以者何。我有是想者应生嗔恨。妙生。又念过去于五百世。作忍辱仙人。我于尔时无如是等想。是故应离诸想发趣无上菩提之心。不应住色声香味触法。都无所住而生其心。不应住法。不应住非法。应生其心。何以故。若有所住即为非住。是故佛说菩萨应无所住而行布施

妙生。菩萨为利益一切众生。应如是布施。此众生想即为非想。彼诸众生即非众生。何以故。诸佛如来离诸想故。妙生。如来是实语者。如语者。不诳语者。不异语者

妙生。如来所证法及所说法。此即非实非妄。妙生。若菩萨心住于事而行布施。如人入闇则无所见。若不住事而行布施。如人有目日光明照见种种色。是故菩萨不住于事应行其施。妙生。若有善男子善女人。能于此经受持读诵为他演说。如是之人佛以智眼悉知悉见。当生当摄无量福聚。妙生。若有善男子善女人。初日分以弶伽河沙等身布施。中日分复以弶伽河沙等身布施。后日分亦以弶伽河沙等身布施。如是无量百千万亿劫以身布施。若复有人闻此经典不生毁谤。其福胜彼。何况书写受持读诵为人解说

妙生。是经有不可思议不可称量无边功德。如来为发大乘者说。为发最上乘者说。若有人能受持读诵广为他说。如来悉知悉见是人皆得成就不可量不可称不可思议福业之聚。当知是人则为以肩荷负如来无上菩提。何以故。妙生。若乐小法者则着我见众生见寿者见更求趣见。是人若能读诵受持此经。无有是处。妙生。所在之处若有此经。当知此处则是制底。一切世间天人阿苏罗。所应恭敬作礼围绕以诸香花供养其处

妙生。若有善男子善女人。于此经典受持读诵演说之时。或为人轻辱。何以故。妙生当知。是人于前世中造诸恶业应堕恶道。由于现在得遭轻辱。此为善事能尽恶业。速至菩提故。妙生。我忆过去过无数劫。在然灯佛。先得值八十四亿那庾多佛。悉皆供养承事无违背者。若复有人于后五百岁正法灭时。能于此经受持读诵解其义趣广为他说。所得功德。以前功德比此功德。百分不及一。千万亿分算分势分比数分因分乃至譬喻亦不能及。妙生。我若具说受持读诵此经功德。或有人闻心则狂乱疑惑不信妙生当知。是经不可思议。其受持者应当希望不可思议所生福聚

复次妙生白佛言。世尊。若有发趣菩萨乘者。应云何住。云何修行。云何摄伏其心。佛告妙生。若有发趣。菩萨乘者。当生如是心。我当度脱一切众生悉皆令入无余涅槃。虽有如是无量众生证于圆寂。而无有一众生证圆寂者。何以故。妙生。若菩萨有众生想者则不名菩萨。所以者何。妙生。实无有法可名发趣菩萨乘者

妙生。于汝意云何。如来于然灯佛所。颇有少法是所证不。妙生言。如来于然灯佛所。无法可证而得菩提。佛言。如是如是。妙生。实无有法如来于然灯佛所有所证悟得大菩提。若证法者然灯佛则不与我授记。摩纳婆。汝于来世当得作佛号释迦牟尼。以无所得故。然灯佛与我授记。当得作佛号释迦牟尼。何以故。妙生。言如来者即是实性真如之异名也。妙生。若言如来证得无上正等觉者。是为妄语。何以故。实无有法如来证得无上正觉。妙生。如来所得正觉之法此即非实非虚。是故佛说一切法者即是佛法。妙生。一切法一切法者。如来说为非法。是故如来说一切法者即是佛法。妙生。譬如丈夫其身长大。妙生言。世尊。如来说为大身者。即说为非身是名大身。佛告妙生。如是如是。若菩萨作是语。我当度众生令寂灭者。则不名菩萨。妙生。颇有少法名菩萨不。答言。不尔世尊。妙生。是故如来说一切法无我无众生无寿者无更求趣。妙生。若有菩萨言。我当成就佛土严胜。佛土严胜者如来说为非是严胜。是故如来说为严胜。妙生。若有信解一切法无性。一切法无性者。如来说名真是菩萨菩萨。妙生。于汝意云何。如来有肉眼不。妙生言。如是世尊。如来有肉眼。如来有天眼不。如是世尊。如来有天眼。如来有慧眼不。如是世尊。如来有慧眼。如来有法眼不。如是世尊。如来有法眼。如来有佛眼不。如是世尊。如来有佛眼

妙生。于汝意云何。如弶伽河中所有沙数。复有如是沙等弶伽河随诸河沙。有尔所世界是为多不。妙生言。甚多世尊。妙生。此世界中所有众生种种性行其心流转。我悉了知。何以故。妙生。心陀罗尼者。如来说为无持。由无持故心遂流转。何以故。妙生。过去心不可得。未来心不可得。现在心不可得。妙生。于汝意云何。若人以满三千大千世界七宝布施。是人得福多不。妙生言。甚多世尊。妙生。若此福聚是福聚者。如来则不说为福聚福聚

妙生。于汝意云何。可以色身圆满观如来不。不尔世尊。不应以色身圆满观于如来。何以故。色身圆满色身圆满者。如来说非圆满。是故名为色身圆满。妙生。可以具相观如来不。不尔世尊。不应以具相观于如来。何以故。诸具相者如来说非具相。是故如来说名具相

妙生。于汝意云何。如来作是念我说法耶。汝勿作是见。若言如来有所说法者。则为谤我何以故。言说法说法者。无法可说是名说法。妙生白佛言。世尊。于当来世颇有众生闻说是经生信心不。佛告妙生。有生信者彼非众生非非众生。何以故。众生众生者。如来说非众生是名众生

妙生。于汝意云何。佛得无上正等觉时。颇有少法所证不。妙生言。实无有法是佛所证。佛告妙生。如是如是。此中无有少法可得故。名无上正等菩提。妙生。是法平等无有高下故。名无上正等菩提。以无我无众生无寿者无更求趣性。其性平等故。名无上正等菩提。一切善法皆正觉了故。名无上正等正觉。妙生。善法者如来说为非法故名善法

妙生。若三千大千世界中所有诸妙高山王。如是等七宝聚。有人持用布施。若复有人于此经中乃至一四句颂。若自受持及为他说。以前福聚比此福聚。假令分此以为百分。彼亦不能及一分。或千分亿分算分势分数分因分乃至譬喻亦不能及一

妙生。于汝意云何。如来度众生不。汝莫作是见。如来度众生。何以故。曾无有一众生是如来度者。若有众生是如来度者。如来则有我见众生见寿者见更求趣见。妙生。我等执者如来说为非执。而诸愚夫妄为此执。妙生。愚夫众生如来说为非生。故名愚夫众生

妙生。于汝意云何。应以具相观如来不。不尔世尊。不应以具相观于如来。妙生。若以具相观如来者。转轮圣王应是如来。是故不应以具相观于如来。应以诸相非相观于如来。尔时世尊而说颂曰

  若以色见我　　以音声求我
  是人起邪觐　　不能当见我
  应观佛法性　　即导师法身
  法性非所识　　故彼不能了

妙生。诸有发趣菩萨乘者。其所有法是断灭不。汝莫作是见。何以故。趣菩萨乘者其法不失。妙生。若有男子女人。以满弶伽河沙世界七宝布施。若复有人。于无我理不生法中得忍解者。所生福聚极多于彼无量无数

妙生。菩萨不应取其福聚。妙生言。菩萨岂不取福聚耶。佛告妙生。是应正取不应越取。是故说取。妙生。如有说言如来若来若去若坐若卧者。是人不解我所说义。何以故。妙生。都无去来故名如来

妙生。若有男子女人。以三千大千世界土地碎为墨尘。妙生。于汝意云何。是极微聚宁为多不。妙生言。甚多世尊。何以故。若聚性是实者如来不说为极微聚极微聚。何以故。极微聚者。世尊说为非极微聚。故名极微聚。世尊。如来所说三千大千世界。说为非世界故。名三千大千世界。何以故。若世界实有。如来则有聚执。佛说聚执者。说为非聚执。是故说为聚执妙生。此聚执者是世言论然。其体性实无可说。但是愚夫异生之所妄执。妙生如有说云。佛说我见众生见寿者见更求趣见者。是为正说为不正耶。妙生言。不尔世尊。何以故。若有我见如来说者。即是非见故名我见。妙生。诸有发趣菩萨乘者。于一切法应如是知如是见如是解。如是解者乃至法相亦无所住。何以故。妙生。法想法想者。如来说为非想。故名法想法想

妙生。若有人以满无量无数世界七宝持用布施。若复有人能于此经乃至受持读诵四句伽他令其通利。广为他人正说其义。以是因缘所生福聚极多于彼无量无数。云何正说。无法可说是名正说。尔时世尊说伽他曰

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观

尔时薄伽梵说是经已。具寿妙生。及诸菩萨摩诃萨。苾刍苾刍尼。邬波索迦邬波斯迦。一切世间天人阿苏罗等。皆大欢喜。信受奉行佛说能断金刚般若波罗蜜多经


佛说仁王般若波罗蜜经

    No. 245 [No. 246]

佛说仁王般若波罗蜜经卷上

        姚秦三藏鸠摩罗什译

    序品第一

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众八百万亿。学无学皆阿罗汉。有为功德无为功德。无学十智。有学八智。有学六智。三根十六心行。法假虚实观。受假虚实观。名假虚实观。三空观门。四谛十二缘。无量功德皆成就。复有八百万亿大仙缘觉。非断非常。四谛十二缘皆成就。复有九百万亿菩萨摩诃萨。皆阿罗汉实智功德。方便智功德。行独大乘。四眼五通三达十力。四无量心。四辩四摄。金刚灭定。一切功德皆成就。复有千万亿五戒贤者。皆行阿罗汉十地回向五分法身具足。无量功德皆成就。复有十千五戒清信女。皆行阿罗汉十地皆成就。始生功德住生功德终生功德。三十生功德皆成就。复有十亿七贤居士。德行具足。二十二品。十一切入。八除入。八解脱。三慧。十六谛。四谛。四三二一品。观得九十忍一切功德皆成就。复有万万亿九梵。三净三光三梵。五喜乐天。天定功德。定味常乐神通十八生处功德皆成就。复有亿亿六欲诸天子。十善果报神通功德皆成就。复有十六大国王。各各有一万二万乃至十万眷属。五戒十善三归功德清信行具足。复有五道一切众生。复有他方不可量众。复有变十方净土现百亿高座。化百亿须弥宝华。各各坐前华上。复有无量化佛。有无量菩萨比丘八部大众。各各坐宝莲华。华上皆有无量国土。一一国土佛及大众如今无异。一一国土中一一佛及大众。各各说般若波罗蜜。他方大众及化众。此三界中大众十二大众。皆来集会坐九劫莲华座。其会方广九百五十里大众佥然而坐。尔时十号三明大灭谛金刚智释迦牟尼佛。初年月八日方坐十地。入大寂室三昧思缘放大光明照三界中。复于顶上出千宝莲华。其华上至非想非非想天。光亦复尔。乃至他方恒河沙诸佛国土。时无色界雨无量变大香华香如车轮华。如须弥山王。如云而下。十八梵天王雨百变异色华。六欲诸天雨无量色华。其佛座前自然生九百万亿劫(丹本作级)华。上至非想非非想天。是时世界其地六种震动

尔时诸大众俱共佥然生疑。各相谓言。四无所畏十八不共法五眼法身大觉世尊。前已为我等大众。二十九年说摩诃般若波罗蜜。金刚般若波罗蜜。天王问般若波罗蜜。光赞般若波罗蜜。今日如来放大光明斯作何事。时十六大国王中。舍卫国主波斯匿王名曰月光。德行十地。六度三十七品。四不坏净。行摩诃衍化。次第问居士宝盖法净名等八百人。复问须菩提舍利弗等五千人。复问弥勒师子吼等十千人。无能答者

时波斯匿王即以神力作八万种音乐。十八梵六欲诸天亦作八万种音乐。声动三千乃至十方恒河沙佛土。有缘斯现。彼他方佛国中南方法才菩萨共五百万亿大众俱来入此大会。东方宝柱菩萨共九百万亿大众俱来入此大会。北方虚空性菩萨共百千万亿大众俱来入此大会。西方善住菩萨共十恒河沙大众俱来入此大会。六方亦复如是。作乐亦然。亦复共作无量音乐觉悟如来。佛即知时得众生根。即从定起方坐莲华师子座上如金刚山王。大众欢喜。各各现无量神通。地及虚空大众而住

    仁王般若波罗蜜护国经观空品第二

尔时佛告大众。知十六大国王意欲问护国土因缘。吾今先为诸菩萨。说护佛果因缘护十地行。因缘。谛听谛听善思念之。如法修行。时波斯匿王言。善大事因缘故。即散百亿种色华。变成百亿宝帐盖诸大众。尔时大王复起作礼白佛言。世尊。一切菩萨云何护佛果。云何护十地行因缘。佛言。菩萨化四生不观色如。受想行识如。众生我人常乐我净如。知见寿者如。菩萨如。六度四摄一切行如。二谛如。是故一切法性真实空。不来不去无生无灭。同真际等法性。无二无别如虚空。是故阴入界无我无所有相。是为菩萨行化十地般若波罗蜜

白佛言。若诸法尔者。菩萨护化众生。为化众生耶。大王。法性色受想行识常乐我净。不住色不住非色不住非非色。乃至受想行识亦不住非非住。何以故。非色如。非非色如。世谛故三假故名见众生。一切生性实故。乃至诸佛三乘七贤八圣亦名见。六十二见亦名见。大王。若以名名见一切法乃至诸佛三乘四生者。非非见一切法也

白佛言。般若波罗蜜有法非非法。摩诃衍云何照。大王。摩诃衍见非非法。法若法非非法是名非非法空。法性空。色受想行识空。十二入十八界空。六大法空。四谛十二缘空。是法即生即住即灭。即有即空。刹那刹那亦如是。法生法住法灭。何以故。九十刹那为一念。一念中一刹那经九百生灭。乃至色一切法亦如是。以般若波罗蜜空故。不见缘不见谛。乃至一切法空内空外空内外空有为空无为空无始空性空第一义空般若波罗蜜空因空佛果空空空故空。但法集故有。受集故有。名集故有。因集故有。果集故有。十行故有。佛果故有。乃至六道一切有。善男子。若有菩萨见法众生我人知见者。斯人行世间不异于世间。于诸法而不动不到不灭。无相无无相。一相法亦如也。诸佛法僧亦如也。是即初地一念心。具足八万四千般若波罗蜜。即载名摩诃衍。即灭为金刚。亦名定。亦名一切行。如光赞般若波罗蜜中说。大王。是经名味句。百佛千佛百千万佛说名味句。于恒河沙三千大千国土中。成无量七宝施三千大千国中众生。皆得七贤四果。不如于此经中起一念信。何况解一句者。句非句非非句故。般若非句。句非般若。般若亦非菩萨。何以故。十地三十生空故。始生住生终生不可得。地地中三生空故。亦非萨婆若。非摩诃衍。空故

大王。若菩萨见境见智见说见受者。非圣见也。倒想见法凡夫人也。见三界者众生果报之名也。六识起无量欲无穷。名为欲界藏空。或色所起业果名为色界藏空。或心所起业果名无色界藏空。三界空。三界根本无明藏亦空。三地九生灭。前三界中余无明习果报空。金刚菩萨得理尽三昧故。或果生灭空。有果空因空故空。萨婆若亦空。灭果空。或前已空故。佛得三无为果。智缘灭。非智缘灭。虚空萨婆若果空也。善男子。若有修习听说。无听无说。如虚空。法同法性。听同说同。一切法皆如也。大王。菩萨修护佛果为若此。护般若波罗蜜者为护萨婆若。十力十八不共法。五眼五分法身。四无量心一切功德果为若此。佛说法时无量人天众得法眼净。性地信地有百千人。皆得大空菩萨大行

    仁王般若波罗蜜护国经菩萨教化品第三

白佛言。世尊。护十地行菩萨云何行可行。云何行化众生。以何相众生可化。佛言。大王。五忍是菩萨法。伏忍上中下。信忍上中下。顺忍上中下。无生忍上中下。寂灭忍上下。名为诸佛菩萨修般若波罗蜜。善男子初发想信。恒河沙众生修行伏忍。于三宝中生习种性十心。信心精进心念心慧心定心施心戒心护心愿心回向心。是为菩萨能少分化众生。已超过二乘一切善地。一切诸佛菩萨长养十心为圣胎也。次第起干慧性种性有十心。所谓四意止。身受心法。不净苦无常无我也。三意止。三善根。慈施慧也。三意止。所谓三世。过去因忍。现在因果忍。未来果忍。是菩萨亦能化一切众生。已能过我人知见众生等想。及外道倒想所不能坏。复有十道种性地。所谓观色识想受行。得戒忍知见忍定忍慧忍解脱忍。观三界因果。空忍无愿忍无想忍观二谛虚实。一切法无常名无常忍一切法空得无生忍。是菩萨十坚心作转轮王。亦能化四天下。生一切众生善根。又信忍菩萨所谓善达明。中行者断三界色烦恼缚。能化百佛千佛万佛国中。现百身千身万身神通无量功德。常以十五心为首。四摄法。四无量心。四弘愿。三解脱门。是菩萨从善地至于萨婆若。以此十五心为一切行根本种子。又顺忍菩萨所谓见胜现法。能断三界心等烦恼缚故。现一身于十方佛国中无量不可说神通化众生。又无生忍菩萨所谓远不动观慧。亦断三界心色等烦恼习故。现不可说不可说功德神通。复次寂灭忍佛与菩萨。同用此忍入金刚三昧。下忍中行名为菩萨。上忍中行名为萨婆若。共观第一义谛。断三界心习无明。尽相为金刚。尽相无相为萨婆若。超度世谛第一义谛之外。为第十一地萨婆若。觉非有非无。湛然清净常住不变。同真际等法性。无缘大悲教化一切众生。乘萨婆若乘来化三界。善男子。一切众生烦恼不出三界藏。一切众生果报二十二根不出三界。诸佛应化法身亦不出三界。三界外无众生。佛何所化。是故我言。三界外别有一众生界藏者。外道大有经中说非七佛之所说。大王。我常语。一切众生断三界烦恼果报尽者名为佛。自性清净名觉萨婆若性。众生本业是诸佛菩萨本业本所修行。五忍中十四忍具足。白佛言。云何菩萨本业清净化众生。佛言。从一地乃至后一地。自所行处及佛行处。一切知见故。本业者。若菩萨住百佛国中。作阎浮四天王。修百法门。二谛平等心化一切众生若菩萨住千佛国中。作忉利天王。修千法门。十善道化一切众生。若菩萨住十万佛国中。作炎天王。修十万法门。四禅定化一切众生。若菩萨住百亿佛国中。作兜率天王。修百亿法门。行道品化一切众生。若菩萨住千亿佛国中。作化乐天王。修千亿法门。二谛四谛八谛化一切众生。若菩萨住十万亿佛国中。作他化天王。修十万亿法门。十二因缘智化一切众生。若菩萨住百万亿佛国中。作初禅王。修百万亿法门。方便智愿智化一切众生。若菩萨住百万微尘数佛国中作二禅梵王。修百万微尘数法门。双照方便神通智化一切众生。若菩萨住百万亿阿僧祇微尘数佛国中。作三禅大梵王。修百万亿阿僧祇微尘数法门。以四无碍智化一切众生。若菩萨住不可说不可说佛国中。作第四禅大静天王三界主。修不可说不可说法门。得理尽三昧同佛行处。尽三界原教化一切众生如佛境界。是故一切菩萨本业化行清净。若十方诸如来亦修是业登萨婆若果。作三界王。化一切无量众生

尔时百万亿恒河沙大众。各从座起。散无量不可思议华。烧无量不可思议香。供养释迦牟尼佛及无量大菩萨。合掌听波斯匿王说般若波罗蜜。今于佛前以偈叹曰

  世尊导师金刚体　　心行寂灭转法轮
  八辩洪音为众说　　时众得道百亿万
  时六天人出家道　　成比丘众菩萨行
  五忍功德妙法门　　十四正士能谛了
  三贤十圣忍中行　　唯佛一人能尽原
  佛众法海三宝藏　　无量功德摄在中
  十善菩萨发大心　　长别三界苦轮海
  中下品善粟散王　　上品十善铁轮王
  习种铜轮二天下　　银轮三天性种性
  道种坚德转轮王　　七宝金光四天下
  伏忍圣胎三十人　　十信十止十坚心
  三世诸佛于中行　　无不由此伏忍生
  一切菩萨行本原　　是故发心信心难
  若得信心必不退　　进入无生初地道
  教化众生觉中行　　是名菩萨初发心
  善觉菩萨四天王　　双照二谛平等道
  权化众生游百国　　始登一乘无相道
  入理般若名为住　　住生德行名为地
  初住一心足德行　　于第一义而不动
  离达开士忉利王　　现形六道千国土
  无缘无相第三谛　　无死无生无二照
  明慧空照炎天王　　应形万国导群生
  忍心无二三谛中　　出有入无变化生
  善觉离明三道人　　能灭三界色烦恼
  还观三界身口色　　法性第一无遗照
  炎慧妙光大精进　　兜率天王游亿国
  实智缘寂方便道　　达无生照空有了
  胜慧三谛自达明　　化乐天王百亿国
  空空谛观无二相　　变化六道入无间
  法现开士自在王　　无二无照达理空
  三谛现前大智光　　照千亿土教一切
  焰胜法现无相定　　能洗三界迷心惑
  空慧寂然无缘观　　还观心空无量报
  远达无生初禅王　　常万亿土教众生
  未度报身一生在　　进入等观法流地
  始入无缘金刚忍　　三界报形永不受
  观第三义无二照　　二十一生空寂行
  三界爱习顺道定　　远达正士独谛了
  等观菩萨二禅王　　变生法身无量光
  入百恒土化一切　　圆照三世恒劫事
  返照乐虚无尽原　　于第三谛常寂然
  慧光开士三禅王　　能于千恒一时现
  常在无为空寂行　　恒沙佛藏一念了
  灌顶菩萨四禅王　　于亿恒土化群生
  始入金刚一切了　　二十九生永已度
  寂灭忍中下忍观　　一转妙觉常湛然
  等慧灌顶三品士　　除前余习无明缘
  无明习相故烦恼　　二谛理穷一切尽
  圆智无相三界王　　三十生尽等大觉
  大寂无为金刚藏　　一切报尽无极悲
  第一义谛常安隐　　穷原尽性妙智存
  三贤十圣住果报　　唯佛一人居净土
  一切众生暂住报　　登金刚原居净土
  如来三业德无极　　我今月光礼三宝
  法王无上人中树　　覆盖大众无量光
  口常说法非无义　　心智寂灭无缘照
  人中师子为众说　　大众欢喜散金华
  百亿万土六大动　　含生之类受妙报
  天尊快说十四王　　是故我今略叹佛

时诸大众闻月光王叹四王无量功德藏。得大法利。即于坐中。有十恒河沙天王。十恒河沙梵王。十恒河沙鬼神王。乃至三趣得无生法忍。八部阿须轮王现转鬼身天上受道。三生入正位者。或四生五生乃至十生得入正位。证圣人性得一切无量报

佛告诸得道果实天众。善男子。是月光王已于过去十千劫中龙光王佛法中。为四住开士。我为八住菩萨。今于我前大师子吼。如是如是。如汝所言。得真义说不可思议不可度量。唯佛与佛乃知斯事。善男子。其所说十四般若波罗蜜。三忍地地上中下三十忍。一切行藏一切佛藏不可思议。何以故。一切诸佛是中生是中灭是中化。无生无灭无化。无自无他。第一无二。非化非不化。非相非无相。无来无去。如虚空故。一切众生无生无灭无缚解。非因非果非不因果。烦恼我人知见受者我所者。一切苦受行空故。一切法集幻化五阴。无合无散法同法性。寂然空故。法境界空。空无相不转不颠倒。不顺幻化。无三宝。无圣人无六道。如虚空故。般若无知无见。不行不缘不因不受。不得一切照相故。行道斯行道相如虚空故。法相如是。何可有心得无心得。是以般若功德。不可众生中行而行。不可五阴法中行而行。不可境中行而行。不可解中行而行。是故般若不可思议。而一切诸佛菩萨于中行。故亦不可思议。一切诸如来于幻化无住法中化。亦不可思议。善男子。此功德藏。假使无量恒河沙第十三灌顶开士。说是功德。百千亿分中。如王所说如海一渧。我今略述分义功德。有大利益一切众生。亦为过去来今无量诸如来之所述可。三贤十圣赞叹无量。是月。光王分义功德。善男子。是十四法门。三世一切众生一切三乘一切诸佛之所修集。未来诸佛亦复如是。若一切诸佛菩萨不由此门得萨婆若者无有是处。何以故。一切佛及菩萨无异路故。是故一切诸善男子。若有人闻诸忍法门信忍止忍坚忍善觉忍离达忍明慧忍焰慧忍胜慧忍法现忍远达忍等觉忍慧光忍灌顶忍圆觉忍者。是人超过百劫千劫无量恒河沙生生苦难。入此法门现身得报。时诸众中有十亿同名虚空藏海菩萨。欢喜法乐。各各散华于虚空中。变成无量华台。上有无量大众。说十四正行。十八梵六欲天王。亦散宝华各坐虚空台上。说十四正行。受持读诵解其义理。无量诸鬼神。现身修行般若波罗蜜

佛告大王。汝先言。云何众生相可化。若以幻化身。见幻化者。是菩萨真行化众生。众生识初一念识异木石。生得善生得恶。恶为无量恶识本。善为无量善识本。初一念金刚终一念。于中生不可说不可说识。成众生色心是众生根本。色名色盖。心名识盖想盖受盖行盖。盖者阴覆为用。身名积聚。大王。此一色法生无量色。眼所得为色。耳所得为声。鼻所得为香。舌得为味。身得为触。坚持名地。水名润。火名热。轻动名风。生五识处名根。如是一色。一心有不可思议色心。大王。凡夫六识粗故。得假名青黄方圆等无量假色法。圣人六识净故。得实法色香味触一切实色法。众生者。世谛之名也。若有若无但生众生忆念。名为世谛。世谛假诳幻化故有。乃至六道幻化众生见幻化。幻化见幻化。婆罗门刹利毗舍首陀。神我等色心。名为幻谛。幻谛法无。佛未出世前无名字无义名。幻法幻化无名字无体相。无三界名字。无善恶果报六道名字

大王。是故佛佛出现于世。为众生故。说作三界六道名字。是名无量名字。如空法四大法心法色法。相续假法非一非异。一亦不续异亦不续非一非异故。名相续谛。相待假法一切名相待。亦名不定相待。如五色等法。有无一切等法。一切法皆缘成假成众生。俱时因果异时因果。三世善恶一切幻化。是幻谛众生。大王。若菩萨如上所见众生幻化。皆是假诳如空中华。十住菩萨诸佛五眼。如幻谛而见。菩萨化众生。为若此。说此法时有无量天子及诸大众得伏忍者。得空无生忍乃至一地十地不可说德行

    仁王般若波罗蜜护国经二谛品第四

尔时波斯匿王言。第一义谛中有世谛不。若言无者。智不应二。若言有者智不应一。一二之义其事云何。佛告大王。汝于过去七佛已问一义二义。汝今无听。我今无说。无听无说。即为一义二义故。谛听谛听善思念之。如法修行。七佛偈如是

  无相第一义　　无自无他作
  因缘本自有　　无自无他作
  法性本无性　　第一义空如
  诸有本有法　　三假集假有
  无无谛实无　　寂灭第一空
  诸法因缘有　　有无义如是
  有无本自二　　譬若牛二角
  照解见无二　　二谛常不即
  解心见不二　　求二不可得
  非谓二谛一　　非二何可得
  于解常自一　　于谛常自二
  通达此无二　　真入第一义
  世谛幻化起　　譬如虚空华
  如影三手无　　因缘故诳有
  幻化见幻化　　众生名幻谛
  幻师见幻法　　谛实则皆无
  名为诸佛观　　菩萨观亦然

大王。菩萨摩诃萨于第一义中。常照二谛化众生。佛及众生一而无二。何以故。以众生空故得置菩提空。以菩提空故得置众生空。以一切法空故空空。何以故。般若无相。二谛虚空般若空。从无明乃至萨婆若。无自相无他相故。五眼成就时见无所见。行亦不受。不行亦不受。非行非不行亦不受。乃至一切法亦不受。菩萨未成佛时以菩提为烦恼。菩萨成佛时以烦恼为菩提。何以故。于第一义而不二故。诸佛如来乃至一切法如故

白佛言。云何十方诸如来一切菩萨不离文字而行诸法相。大王。法轮者。法本如。重诵如。受记如。不诵偈如。无问而自说如。戒经如。譬喻如。法界如。本事如。方广如。未曾有如。论议如。是名味句音声果文字记句一切如。若取文字者不行空也

大王。如如文字修诸佛智母。一切众生性根本智母。即为萨婆若体。诸佛未成佛。以当佛为智母。未得为性。已得为萨婆若。三乘般若。不生不灭自性常住。一切众生。以此为觉性故。若菩萨无受无文字。离文字非非文字。修无修为修文字者。得般若真性般若波罗蜜。大王。若菩萨护佛。护化众生。护十地行为若此

白佛言。无量品众生根亦无量。行亦无量。法门为一为二。为无量耶。大王。一切法观门。非一非二。乃有无量一切法。亦非有相非非无相。若菩萨见众生见一见二。即不见一不见二。一二者第一义谛也。大王。若有若无者即世谛也。以三谛摄一切法。空谛色谛心谛故。我说一切法不出三谛。我人知见五受阴空乃至一切法空。众生品品根行不同故。非一非二法门。大王。七佛说摩诃般若波罗蜜。我今说般若波罗蜜。无二无别。汝等大众。应当受持读诵解说是经。功德有无量不可说。不可说诸佛。一一佛教化无量不可说众生。一一众生皆得成佛。是佛复教化无量不可说众生。皆得成佛。是上三佛说般若波罗蜜经八万亿偈。于一偈中复分为千分。于一分中说一分句义不可穷尽。况复于此经中起一念信。是诸众生超百劫千劫十地等功德。何况受持读诵解说者功德。即十方诸佛等无有异。当知是人即是如来得佛不久。时诸大众闻说是经。十亿人得三空忍。百万亿人得大空忍十地性。

大王。此经名为仁王问般若波罗蜜经。汝等受持般若波罗蜜经。是经复有无量功德。名为护国土功德。亦名一切国王法药服行无不大用护舍宅功德。亦护一切众生身。即此般若波罗蜜。是护国土。如城堑墙壁刀剑鉾楯。汝应受持般若波罗蜜。亦复如是

佛说仁王般若波罗蜜经卷上佛说仁王般若波罗蜜经卷下

        姚秦三藏鸠摩罗什译

    护国品第五

尔时佛告大王。汝等善听。吾今正说护国土法用。汝当受持般若波罗蜜。当国土欲乱破坏劫烧贼来破国时。当请百佛像百菩萨像百罗汉像。百比丘众。四大众七众共听请百法师讲般若波罗蜜。百师子吼高座前燃百灯。烧百和香。百种色花。以用供养三宝。三衣什物供养法师。小饭中食亦复以时。大王。一日二时讲读此经。汝国土中有百部鬼神。是一一部复有百部乐闻是经。此诸鬼神护汝国土。大王。国土乱时先鬼神乱。鬼神乱故万民乱。贼来劫国百姓亡丧。臣君太子王子百官共生是非。天地怪异二十八宿。星道日月失时失度。多有贼起。大王。若火难水难风难一切诸难。亦应讲读此经。法用如上说。大王。不但护国亦有护福求富贵官位七宝如意行来。求男女。求慧解名闻。求六天果报人中九品果乐。亦讲此经。法用如上说。大王不但护福。亦护众难。若疾病苦难。杻械枷锁检系其身。破四重罪。作五逆因。作八难罪。行六道事。一切无量苦难。亦讲此经。法用如上说

大王。昔日有王。释提桓因为顶生王。来上天欲灭其国。时帝释天王即如七佛法用。敷百高座请百法师。讲般若波罗蜜。顶生即退。如灭罪经中说。大王。昔有天罗国王。有一太子欲登王位。一名班足。太子为外道罗陀师受教。应取千王头以祭家神自登其位。已得九百九十九王少一王。即北行万里。即得一王名普明王。其普明王白班足王言。愿听一日饭食沙门顶礼三宝。其班足王许之一日。时普明王即依过去七佛法。请百法师敷百高座。一日二时讲般若波罗蜜八千亿偈竟。其第一法师。为普明王而说偈言

  劫烧终讫　　乾坤洞燃　　须弥巨海
  都为灰炀　　天龙福尽　　于中雕丧
  二仪尚殒　　国有何常　　生老病死
  轮转无际　　事与愿违　　忧悲为害
  欲深祸重　　疮疣无外　　三界皆苦
  国有何赖　　有本自无　　因缘成诸
  盛者必衰　　实者必虚　　众生蠢蠢
  都如幻居　　声响俱空　　国土亦如
  识神无形　　假乘四驰　　无明宝象
  以为乐车　　形无常主　　神无常家
  形神尚离　　岂有国耶

尔时法师说此偈已。时普明王眷属得法眼空。王自证虚空等定。闻法悟解。还至天罗国班足王所众中。即告九百九十九王言。就命时到。人人皆应诵过去七佛仁王问般若波罗蜜经中偈句。时班足王问诸王言。皆诵何法。时普明王。即以上偈答王。王闻是法得空三昧。九百九十九王亦闻法已皆证三空门定。时班足王极大欢喜。告诸王言。我为外道邪师所误。非君等过。汝可还本国各各请法师讲般若波罗蜜名味句。时班足王以国付弟。出家为道证无生法忍。如十王地中说五千国王常诵是经现世生报。大王。十六大国王修护国之法。法应如是。汝当奉持。天上人中六道众生。皆应受持七佛名味句。未来世中有无量小国王欲护国土亦复尔者。应请法师说般若波罗蜜

尔时释迦牟尼佛说般若波罗蜜时。众中五百亿人得入初地。复有六欲诸天子八十万人得性空地。复有十八梵王得无生忍。得无生法乐忍。复有先以学菩萨者。证一地二地三地乃至十地。复有八部阿须轮王得十三昧门。得三三昧门得转鬼身天上正受。在此会者皆得自性信乃至无量空信。吾今略说天等功德。不可具尽

    仁王般若波罗蜜护国经散华品第六

尔时十六大国王。闻佛说十万亿偈般若波罗蜜欢喜无量。即散百万亿茎华。于虚空中变为一座。十方诸佛共坐此座。说般若波罗蜜。无量大众共坐一座。持金罗华散释迦牟尼佛上。成万轮华盖大众上。复散八万四千般若波罗蜜华于虚空中变成白云台。台中光明王佛。共无量众说般若波罗蜜。台中大众持雷吼华。散释迦牟尼佛及诸大众。复散妙觉华于虚空中。变作金刚城。城中师子吼王佛共十方佛大菩萨论第一义谛。时城中菩萨持光明华散释迦牟尼佛上成一华台。台中十方佛。诸天散天华于释迦牟尼佛上。虚空中成紫云盖覆三千大千世界。盖中天人散恒河沙华如云而下。时诸国王散华供已。愿过去佛现在佛未来佛常说般若波罗蜜。愿一切受持者比丘比丘尼信男信女所求如意常行般若波罗蜜。佛告大王。如是如是。如王所说。般若波罗蜜应说应受。是诸佛母诸菩萨母。神通生处

时佛为王现五不思议神变。一华入无量华无量华入一华。一佛土入无量佛土无量佛土入一佛土。无量佛土入一毛孔土一毛孔土入无量毛孔土。无量须弥无量大海入芥子中。一佛身入无量众生身无量众生身入一佛身。入六道身。入地水火风身。佛身不可思议。众生身不可思议。世界不可思议。佛现神足时。十方诸天人。得佛华三昧。十恒河沙菩萨现身成佛。三恒河沙八部王成菩萨道。十千女人现身得神通三昧。善男子。是般若波罗蜜有三世利益。过去已说现在今说未来当说。谛听谛听善思念之如法修行

    仁王般若波罗蜜护国经受持品第七

尔时月光心念口言。见释迦牟尼佛现无量神力。亦见千华台上宝满佛。是一切佛化身主。复见千华叶世界上佛。其中诸佛各各说般若波罗蜜。白佛言。如是无量般若波罗蜜。不可说不可解。不可以识识。云何诸善男子。于是经中明了觉解。如法为一切众生开空法道。大牟尼言。有修行十三观门诸善男子。为大法王。从习忍至金刚顶。皆为法师依持建立。汝等大众应如佛供养而供养之。应持百万亿天华天香而以奉上

善男子。其法师者是习种性菩萨。若在家婆差忧婆差若出家比丘比丘尼修行十善自观己身地水火风空识分分不净。复观十四根。所谓五情五受男女意命等。有无量罪过故即发无上菩提心。常修三界一切念念皆不净。故得不净忍观门。住在佛家修六和敬。所谓三业同戒同见同学。行八万四千波罗蜜道。善男子。习忍以前行十善菩萨。有退有进。譬如轻毛随风东西。是诸菩萨亦复如是。虽以十千劫行十正道发三菩提心乃当入习忍位。亦常学三伏忍法。而不可名字。是不定人。是定人者入生空位。圣人性故。必不起五逆六重二十八轻。佛法经书作返逆罪言非佛说无有是处。能以一阿僧祇劫。修伏道忍行。始得入僧伽陀位

复次性种性行十慧观。灭十颠倒。及我人知见分分假伪。但有名但有受。但有法不可得。无定相无自他相故。修护空观。亦观亦行百万波罗蜜。念念不去心。以二阿僧祇劫。行十正道法住波罗陀位。

复次道种性住坚忍中。观一切法无生无住无灭。所谓五受三界二谛无自他相。如实性不可得故。而常入第一义谛。心心寂灭而受生三界。何以故。业习果报未坏尽故顺道生。复以三阿僧祇劫。修八万亿波罗蜜。当得平等圣人地故。住阿毗跋致正位

复次善觉摩诃萨。住平等忍修行四摄念念不去。心入无相舍灭三界贪烦恼。于第一义谛而不二。为法性无为。缘理而灭一切相故。为智缘灭无相无为。住初忍时。未来无量生死不由智缘而灭故。非智缘灭。无相无为无自他相。无无相故。无量方便皆现前。观实相方便者。于第一义谛。不沈不出不转不颠倒。遍学方便者。非证非不证而一切学。回向方便者。非住果非不住果而向萨婆若。魔自在方便者。于非道而行佛道。四魔所不动。一乘方便者。于不二相。通达众生一切行故。变化方便者。以愿力自在生一切净佛国土。如是善男子。是初觉智于有无相而不二。是实知照功用不证。不沈不出不到。是方便观。譬如水之与波不一不异。乃至一切行波罗蜜禅定陀罗尼。不一不二故。而一一行成就。以四阿僧祇劫行行故。入此功德藏门。无三界业习生故毕故不造新。以愿力故变化生一切净土。常修舍观故。登鸠摩罗伽位。以四大宝藏常授与人

复次德慧菩萨。以四无量心。灭三有嗔等烦恼住中忍中。行一切功德故。以五阿僧祇劫行大慈观。心心常现在前入无相阇陀波罗位化一切众生。复次明慧道人。常以无相忍中行三明观。知三世法无来无去无住处。心心寂灭尽三界痴烦恼。得三明一切功德观故。常以六阿僧祇劫。集无量明波罗蜜故。入伽罗陀位。无相行受持一切法。

复次尔焰圣觉达菩萨。修行顺法忍。逆五见流。集无量功德住须陀洹位。常以天眼天耳宿命他心身通达念念中灭三界一切见。亦以七阿僧祇劫行五神通。恒河沙波罗蜜常不离心

复次胜达菩萨。于顺道忍以四无畏。观那由他谛内道论外道论药方工巧咒术故。我是一切智人。灭三界疑等烦恼故。我相已尽知地地有所出故名出道。有所不出故名障道。逆三界疑。修习无量功德故。即入斯陀含位。复集行八阿僧祇劫中行诸陀罗尼门故。常行无畏观不去心

复次常现真实住顺忍中。作中道观。尽三界集因集业一切烦恼故。观非有非无一相无相而无二故。证阿那含位。复于九阿僧祇劫集照明中道故。乐力生一切佛国土

复次玄达菩萨。十阿僧祇劫中。修无生忍法乐忍者名为缚忍。顺一切道生而一心忍中灭三界习因业果。住后身中无量功德皆成就。无生智尽智五分法身皆满足。住第十地阿罗汉梵天位。常行三空门观百千万三昧。具足弘化法藏

复次等觉者。住无生忍中。观心心寂灭而无相相无身身无知。知而用心乘于群方之方。憺怕住于无住之住。在有常修空。处空常万化。双照一切法故。知是处非是处。乃至一切智十力观故。而登摩诃罗伽位。化一切国土众生。千阿僧祇劫行十力法。心心相应常入见佛三昧

复次慧光神变者。住上上无生忍灭心心相。法眼见一切法净三眼色空见。以大愿力常生一切净土。万阿僧祇劫集无量佛光三昧。而能现百万恒河沙诸佛神力。住婆伽梵位。亦常入佛华三昧

复次观佛菩萨。住寂灭忍者。从始发心至今经百万阿僧祇劫。修百万阿僧祇劫功德故。登一切法解脱住金刚台。善男子。从习忍至顶三昧。皆名为伏一切烦恼。而无相信。灭一切烦恼生解脱智。照第一义谛。不名为见。所谓见者是萨婆若。是故我从昔以来常说唯佛所知见觉。顶三昧以下至于习忍。所不知不见不觉。唯佛顿解不名为信。渐渐伏者。慧虽起灭。以能无生无灭。此心若灭则累无不灭。无生无灭入理尽金刚三昧。同真际等法性。而未能等无等等。譬如有人登大高台下观一切无不斯了。住理尽三昧。亦复如是。常修一切行满功德藏。入婆伽度位。亦复常住佛慧三昧善男子。如是诸菩萨。皆能一切十方诸如来国土中化众生。正说正义受持读诵解达实相。如我今日等无有异。佛告波斯匿王。我当灭度后法欲灭时。受持是般若波罗蜜大作佛事。一切国土安立万姓快乐。皆由般若波罗蜜。是故付嘱诸国王。不付嘱比丘比丘尼清信男清信女。何以故。无王力故。故不付嘱。汝当受持读诵解其义理。大王。吾今所化百亿须弥百亿日月。一一须弥有四天下。其南阎浮提有十六大国。五百中国十千小国。其国土中有七可难。一切国王为是难故讲读般若波罗蜜。七难即灭七福即生。万姓安乐帝王欢喜。云何为难。日月失度。时节返逆。或赤日出黑日出。二三四五日出。或日蚀无光。或日轮一重二三四五重轮现。当变怪时读说此经。为一难也。二十八宿失度。金星慧星轮星鬼星火星水星风星刀星南斗北斗五镇大星一切国主星三公星百官星如是诸星各各变现。亦读说此经。为二难也。大火烧国万姓烧尽。或鬼火龙火天火山神火人火树木火贼火如是变怪。亦读说此经。为三难也。大水[漂*寸]没百姓。时节返逆。冬雨夏雪。冬时雷电霹雳。六月雨冰霜雹雨赤水黑水青水。雨土山石山。雨沙砾石。江河逆流浮山流石。如是变时亦读说此经。为四难也。大风吹杀万姓。国土山河树木一时灭没。非时大风黑风赤风青风天风地风火风。如是变时亦读此经。为五难也。天地国土亢阳炎火洞燃百草亢旱五谷不登。土地赫然万姓灭尽。如是变时亦读此经。为六难也。四方贼来侵国内外贼起。火贼水贼风贼鬼贼。百姓荒乱刀兵劫起。如是怪时亦读此经。为七难也

大王。是般若波罗蜜。是诸佛菩萨一切众生心识之神本也。一切国王之父母也。亦名神符。亦名辟鬼珠。亦名如意珠。亦名护国珠。亦名天地镜。亦名龙宝神王。佛告大王。应作九色幡长九丈。九色华高二丈。千支灯高五丈。九玉箱九玉巾。亦作七宝案以经置上。若王行时常于其前足一百步。是经常放千光明。令千里内七难不起罪过不生。若王住时作七宝帐。中七宝高座以经卷置上。日日供养散华烧香。如事父母如事帝释

大王。我今五眼明见三世。一切国王皆由过去侍五百佛。得为帝王主。是故一切圣人罗汉。而为来生彼国作大利益。若王福尽时。一切圣人皆为舍去。若一切圣人去时七难必起。大王。若未来世有诸国王护持三宝者我使五大力菩萨往护其国。一金刚吼菩萨。手持千宝相轮往护彼国。二龙王吼菩萨。手持金轮灯往护彼国。三无畏十力吼菩萨。手持金刚杵往护彼国。四雷电吼菩萨。手持千宝罗网往护彼国。五无量力吼菩萨。手持五千剑轮往护彼国。五大士五千大神王。于汝国中大作利益。当立像形而供养之。大王。吾今三宝付嘱汝等一切诸王。憍萨罗国。舍卫国。摩竭提国。波罗奈国。迦夷罗卫国。鸠尸那国。鸠睒弥国。鸠留国。[罽-厂]宾国。弥提国。伽罗干国。乾陀卫国。沙陀国。僧伽陀国。揵拏掘阇国。波提国。如是一切诸国王等皆应受持般若波罗蜜

时诸大众及阿须轮王。闻佛说未来世七可畏。身毛为竖。呼声大叫而言。愿不生彼国。时十六大国王。即以国事付弟出家修道。观四大四色胜出相。四大四色不用识空入行相。三十忍初地相。第一义谛九地相。是故大王舍凡夫身入六住身。舍七报身入八法身。证一切行般若波罗蜜。十八梵天阿须轮王。得三乘观同无生境。复散华供养空华法性华圣人华顺华无生华法乐华金刚华缘观中道华三十七品华。而散佛上及九百亿大菩萨众。其余一切众证道迹果。散心空华心树华六波罗蜜华妙觉华。而散佛上及一切众。十千菩萨念来世众生。即证妙觉三昧。圆明三昧。金刚三昧。世谛三昧。真谛三昧。第一义谛三昧。此三谛三昧。是一切三昧王三昧。亦得无量三昧。七财三昧。二十五有三昧。一切行三昧。复有十亿菩萨登金刚顶现成正觉

    仁王般若波罗蜜护国经嘱累品第八

佛告波斯匿王。我诫敕汝等。吾灭度后。八十年八百年八千年中。无佛无法无僧。无信男无信女时。此经三宝。付嘱诸国王四部弟子受持读诵解义。为三界众生开空慧道。修七贤行十善行。化一切众生。后五浊世比丘比丘尼四部弟子。天龙八部一切神王国王大臣太子王子。自恃高贵灭破吾法。明作制法制我弟子比丘比丘尼。不听出家行道。亦复不听造作佛像形佛塔形。立统官制众安籍记僧。比丘地立白衣高坐。兵奴为比丘受别请法。知识比丘。共为一心亲善比丘为作斋会。求福如外道法。都非吾法。当知尔时正法将灭不久

大王。坏乱吾道。是汝等作。自恃威力。制我四部弟子。百姓疾病无不苦难。是破国因缘。说五浊罪穷劫不尽

大王。法末世时有诸比丘四部弟子。国王大臣多作非法之行。横与佛法众僧作大非法。作诸罪过非法非律。系缚比丘如狱囚法。当尔之时法灭不久。大王。我灭度后未来世中四部弟子。诸小国王太子王子。乃是住持护三宝者。转更灭破三宝。如师子身中虫自食师子。非外道也。多坏我佛法得大罪过。正教衰薄民无正行。以渐为恶。其寿日减至于百岁。人坏佛教无复孝子。六亲不和天神不祐。疾疫恶鬼日来侵害。灾怪首尾连祸纵横。死入地狱饿鬼畜生。若出为人兵奴果报如响应声。如人夜书火灭字存。三界果报亦复如是

大王。未来世中一切国王太子王子四部弟子。横与佛弟子书记制戒。如白衣法如兵奴法。若我弟子比丘比丘尼。立籍为官所使。都非我弟子。是兵奴法。立统官摄僧典主僧籍。大小僧统共相摄缚。如狱囚法兵奴之法。当尔之时佛法不久

大王。未来世中诸小国王四部弟子。自作此罪破国因缘。身自受之非佛法僧。大王。未来世中流通此经。七佛法器十方诸佛常所行道。诸恶比丘多求名利。于国王太子王子前。自说破佛法因缘破国因缘。其王不别信听此语。横作法制不依佛戒。是为破佛破国因缘。当尔之时正法不久

尔时十六大国王。闻佛七诫所说未来世事。悲啼涕出声动三千。日月五星二十八宿失光不现。时诸王等各各至心受持佛语。不制四部弟子出家行道。当如佛教

尔时大众十八梵天王。六欲诸天子叹言。当尔之时世间空虚是无佛世。尔时无量大众中。百亿菩萨弥勒师子月等。百亿舍利弗须菩提等。五百亿十八梵王。六欲诸天。三界六道。阿须轮王等。闻佛所说护佛果因缘护国土因缘。欢喜无量为佛作礼。受持般若波罗蜜

佛说仁王般若波罗蜜经卷下


佛说濡首菩萨无上清净分卫经

    No. 234 [No. 220(8)]

佛说濡首菩萨无上清净分卫经卷上

        宋沙门翔公于南海郡译

一名决了诸法如幻化三昧经

闻如是。一时世尊。游舍卫祇树给孤独园。与大比丘五百人俱。舍利弗。摩诃目揵连。摩诃迦叶。须菩提。阿难揵等。率自耆年素行修行。皆弃瑕疵垢除清净。宿树众德所作已办。了厌身弊解识因缘。睹彼五道受有苦器。漏脑诸患种种之秽。无乐三界常欲舍离。见诸流转缩心畏恶。断灭求空志毕泥洹。处往无还永彼静安。悉断生死结网索尽。都无诸漏已离重担获四神足致六通行。能住身命存亡从志。度于彼岸坦然为乐

又与菩萨千人俱。悉尊菩萨摩诃萨。皆一生补处被大德铠显有佛称降现菩萨班宣道化布诸佛藏。神智异达已通圣慧。等住大乘志如虚空。以立广法过度无极具足普智明晓权要。总持所览统摄无限。积众辩才不可测量随俗顺导为大桥梁。无上道德而无挂碍。散演深邃无极微妙。悉降魔怨都伏外道。独步十方周流往还。游于五道而无去来。如日月殿。若梦幻化影响野马。等无进止。感动一切济度生死。三宝之化使永不断。道普兴显德皆具足

其诸菩萨。悉皆各有。名曰濡首童真菩萨。龙首菩萨。妙首菩萨。大首菩萨。普首菩萨。慧首菩萨。明首菩萨。甘首菩萨。英首菩萨。宝首菩萨。是等菩萨千人俱也

是时坐中英首菩萨。承佛神旨而从坐起。严齐法服肃恭已礼。偏袒其肩右膝着地。而跪白佛唯然世尊。濡首童真者。古今诸佛。无数如来及众仙圣有道神通。所共称赞。去来现在诸成大业菩萨之等。导进无由为一切师。了深睹远。道度渊懿明踰日月智过江海。达越虚空慧辩无极。德显无上四等普育。慈悲利安仁泰宽济。弘雅汪洋德无崖边。如无底泓憺怕旷定。如无像体。居于静寂。仪容无量。于十方土现佛广化。为诸菩萨所见戴奉。一切释梵及四天王。咸率礼敬委仰尊重。诸天龙神阿须伦众迦留罗辈。真陀罗摩睺勒等莫不供事。睹世帝王所共奉遵。圣相满具光好湛然。吾瞻濡首众德具备。诸善若。斯为难思议。愿常歌咏显赞无极咨嗟叹美流着十方于百千劫永无懈也。其时濡首谓英首曰云何族姓子。法身有烦乎。曰其法身无处无像。又法身者都无烦劳。曰云何英首。仁了法身乎。曰法身者岂有处所言声迹耶。又法身者无了不了。若响如影。宁所了乎。曰知法身如幻化影。无了不了亦无言说。而仁云何举声说耶曰向所言如。响之声。为诸文说着行者耳。曰如仁言。则其法身为有内外有其彼此处于中间。为有数观。已在二数则有处所。又曰英首于法身者都无响应亦无影像。无心无意无念无识。无言无说无异无同。无二之趣亦无一归。于一无一亦无所处。是者英首。本无法身。微妙印说极世所归。无上无比道要之藏。于时佛叹濡首曰。善哉善哉。如濡首所言。乃应清净法身说也。时座中五百比丘五百比丘尼。闻濡首所说。皆逮无所从生法乐忍又舍卫国清信士女二千人。本不发心于大乘行。闻此要说。即自坚固于无上正真道意。万二千天子意亘踊跃。发菩萨心。各在虚空而歌濡首。积德过劫功成无量

是时濡首童真菩萨。以其平旦欲入城分卫。整圣无上清净道服。执御应器持法锡杖。粗顺如佛。机检典制度量俨然。庠行安步进止端严。回旋顾眄光色无量。诸根静寂常应道定。威仪述叙礼法肃齐。众德悉备靡不雅然。如猛师子。如大龙王。景福之祚[火*霍]出树园。威相无量德好卓异。晖颜炜晔光曜炳然。濡首童真方出只门。即自念言。今入舍卫必有十方诸土菩萨普来之众。应承圣旨所感动者。便当如佛寻以其像不移所住。己身一一毛孔之相。出化菩萨。其诸化者。睹于十方悉现其化。一一国土化所化者。各称言曰。濡首菩萨稽首世尊。恭问游居。佛祚康强景福无量乎。又诸如来所侍弟子悦目遑喜。各问其佛。斯从何方乃来现此诸土。世尊。各告侍曰。有土名忍。佛号能仁如来至真等正觉。彼有菩萨名曰濡首。道慧难测权辩无量。悉于诸国博现佛事。今于彼土。兴显大道。故身毛相而现其化。唱此感动。进诸疑惑。普土菩萨及诸众生。见所变化。各闻佛语。亿垓菩萨悉得无所从生法乐忍。万亿之众在生死流。闻濡首名又睹化应。皆发无上正真道意。十方菩萨莫不乐喜。愿见濡首。听禀清异上闻之说微妙法像。得睹其佛及彼菩萨。诸士寻随无数菩萨。各启世尊。欲之忍界睹能仁佛礼事供养。又见濡首观听变说。诸佛默然。即应受教。各承圣力。迁飞彼土忽升忍界。到濡首所。诸来菩萨咸怀敬仰。或持天华或擎明宝或执垂珠。或直叉手或作天乐。或列虚空散华末香吹噭鸣。珂或复歌颂濡首童真。道显普祐无上之德。或欲宾导侍卫濡首。肃恭而行瞻睹无厌

是时释梵及四镇王日月天子。诸龙鬼神各与所辅亦寻忽至。释与四王俱同有念。今濡首童真。与无数菩萨诸尊天人。当入舍卫显大感动。宜应尽化向舍卫城道。令其坦平而无高下。侠道两边列七宝树。一树之间有七玉女。各现半身而作倡伎。女容委靡姿媚面照华色目若明珠。端正妙异清声美辞。以歌濡首大吉祥福清纯。道品菩萨众德。步置熏炉烧天蜜香。处有杂华以为供养。登于尔时。道之左侧。舍毒螫虫蟒蝮蛇蚖蜂蝎众类。应时咸然消缩毒气。吉兽瑞鸟进集嬉翔。彼时濡首。为无数百千菩萨众及诸天人。而所围卫。特独堂堂光色无量。譬日始出高山之岳。若月盛满在众星中。又若须弥异于众山。如猛师子出于深林。晖颜灼然遂而进焉。适侧城门寻足蹑阃。尽境震动。登尔之时莫不惊愕。所在伎器率自鼓鸣。咸曰此何吉祥大变瑞应之异。乃未曾有。将佛入城所感然乎。举国大小靡不惊喜。心豫忻忻肃恭无量或上楼阁或攀垣墙。或窥窗牖或出门户。竞有悦怿。向佛冀睹神异。时王波斯匿。与宫正后美妃婇女八千人俱。诸子群臣眷属万人围卫从行。各怀忻悦惶喜出迎。斯须之顷濡首忽至。为诸菩萨及尊众天而所卫从。大人相具众好普备。金颜圣容见皆喜悦莫不前礼。诸来之众中有散华或烧妙香或散衣宝。检心恭向瞻睹无量。于是濡首遂前入城。诸尊菩萨有势天神佥然恭肃。追随所旋观见神变。又欲禀受道诲故也

尔时于是龙首菩萨。见其濡首童真菩萨为无数众而所围绕堂堂祥仪并共入城。曰族姓子。为所之耶。濡首菩萨答龙首曰。吾适此城欲行分卫。多所愍念广其慧利。为拯世众一切天人度义故。现行分卫耳。普为诸众成大导故。龙首问曰。云何濡首。仁尊于今分卫想未断耶。曰族姓子。吾断矣。于有见分卫想行者。至于无见无断不断。斯谓菩萨清净分卫。所以者何。若此龙首。一切诸法无断不断。譬如虚空无断不断。以是言之为不可断。普悉是世尽魔梵界。一切众寂及诸梵志王与庶民。亦无能断也。何则龙首以其诸法若如虚空本无所有。无起无动无持无获。空本无获亦无所持亦不可得。以要言之。一切众类及世余法。外邪杂术悉无所有。无持无得亦无能获。诸法如此皆不可得亦不可持。以本空故故不可断。云何濡首。菩萨摩诃萨当与诸魔为敌耶。答曰龙首。法本无诤。不见菩萨当与诸魔而有战者。若其菩萨与魔为敌。起见法想而有所诤。是菩萨便为恐怯。何则然者。以彼菩萨自兴恐弱也。譬如龙首幻师现化而幻所化了无恐怯。如是龙首。此菩萨解本空法无著之行则无恐怖。若有菩萨有恐怖者。是菩萨便不为极世福田也。是菩萨不了空法故。自起恐怯之心耳。于时龙首问濡首曰。菩萨为可得道乎。答曰菩萨可得道也龙首又问。云何濡首。其谁可得至于道耶。曰其无名无性亦无号字亦无处所。永无所为亦无得者。斯可至道。曰云何菩萨当得道乎。答曰龙首。若有菩萨欲得道者。当以无发心。亦无念道不想道场不念人界。心亦无处无念无得亦无识着以无见心。是行菩萨可得至道。曰仁以何心而发道意。答曰龙首。吾无数心亦无当发。又无甫发无发不发。又吾亦复不至道矣。不念道场不坐佛树。亦不得道不转法轮。亦不化过生死之类所以者何。若此龙首。以诸法无所有故。无动无摇无出无入亦无所持。以本空故。吾以斯法可得至道。曰濡首。是为正要无上无比之至说也。其诸于斯解如是法彼则长脱一切尘劳。其已脱于尘劳数者。乃至应永脱于魔波旬。曰非可脱于魔波旬也。何则然者。以其诸魔亦道之数。所以者何。魔及魔天皆悉本无。无取无得无想无念。以故言之魔亦道也。曰何谓为道。濡首答曰。道乎龙首。在乎一切一切亦道。道像虚空道体广荡。亘然恢廓普大含容。靡不周至亦无限碍。如是龙首。道至一切一切亦道斯谓无上真本无道也曰仁龙首。欲得道乎曰吾欲得不可获道。曰欲得道宁非戏行耶。所以者何。如龙首言。欲得不可获道。道何可得乎。若道可得道为有处。譬如有人兴念此言吾使幻化坐于道树然致正觉。如是言者岂非响声耶。其幻化人亦不可得。亦不与诸法有合有离。亦无所著。以本空故。若龙首。一切诸法如幻如化。而起有想念欲得道耶又如来说诸法本无无念无想无所著。其解是者斯乃得道。诸法无所入亦无能毁。法不与法有合有离。况法与法当有毁乎。法无附合亦不离散。所以者何。若此龙首。诸法无合以其本无都亦无我。又若虚空亦无所有。无像无念无动无摇亦无戏行。诸法本无寂寞如空。如幻如梦无喻无比。诸法若此都无等伦亦无像也。诸来之众听濡首所说微妙。踊跃欣喜各怀无倦。渴仰悚恭专心思受。说是如化深妙法时。八万菩萨逮得无退转。无量天人发无上意

是时龙首答濡首曰。善哉善哉。童真菩萨快说是像深邃妙法。为未曾有。如吾从仁逮闻此要。始今日明为已得道。曰族姓子。法无言说亦无见闻。吾不说深又无浅说。仁亦不得道无得不得。何则然者。如卿龙首。念欲得道为想戏行处乎。受者堕有望见。使其云有深浅法耳。吾无所说法无言说。亦无宣畅亦无所行。亦无能说诸法本者。又龙首。譬如有人而言曰吾为幻化广说识法。其化无识言当说识耶。彼则缘此起劳诤想。何则然者。以化无识不可为所说。如是龙首。诸法本无无所有亦无处所。是族姓子。当了如此解。谓具足法行者也

尔时于是妙心菩萨神彻视听。睹闻濡首在异别处讲上要菩萨之谈。忽到其所见大会场。喜而叹曰。善哉善哉。诸上正士大士之等普众会。此为何谈讲乎。濡首答曰族姓子于诸如来深要法中。获无正士大士之名。又菩萨者。不自名言我是菩萨正士大士。其有想着住戏行众自称菩萨。复言大士。又云吾为法之大讲。又复妙心。其响者宁有言声出不。响复有耳识所著不。于响法为有所受持不乎。龙首答曰。都无也。如是龙首。诸法若响无名无像。其取著者则有戏行。缘戏行故便有流转。长不解诸法。如本无响也。则于生死而行诤想。已起诤行便堕躁动。已在躁动即无生死流于五道。便由不解其无故也。于是濡首谓龙首曰。又族姓子如世尊告。诸比丘曰。是比丘。汝等无著戏乐想行。为汝辈说寂寞之行。念释师子说法如是。专心一意听受随法。入要行忍当无所著。若此族姓子。其菩萨解顺是说晓本空净。于本寂寞明了如是。此乃长脱五道之趣。时龙首曰。谁于生死而有脱者。濡首答曰。族姓子。何谓如来所化生死为脱者乎。宁复有去来今耶。若是龙首。圣师十力。以此要言。化度生死。曰如世尊常所说教。诸法如化。又仁亦说诸法无所有。以是言之。一切众生为当皆成无上觉道耶。答曰龙首。若一切解如是者。此乃至道要行之言。故吾不说法。法无说念无受无持。无得无失无言无语。何则然者。以诸法为无所持。亦无所有无念无识。以无处所故。又若一切解诸法如幻如化无所有者。则众生类皆至觉道。譬如龙首幻师所化然幻者自了化之本末。为化化耳。于诸法亦无所化亦无住置。普悉是世天龙鬼神魔。及梵天沙门梵志。至于极世无能令幻者于其所化有坚固想。何则然者。以彼幻士自达。所化化本自耳。无幻无化都无所有。而幻者明知一切为化所惑。于无所有而起有想无常想常无我想我著有想念求无想法。望念无色住无所有。由不解本不了无故。续流生死。若有明晓诸法本者。彼众一切则于佛法即无还转而成正觉。所以者何。若此龙首。以彼众生皆在觉道法之数故。故诸一切于佛法而无挂碍。是故众生悉住佛法也。然众生等心亦不寤本空清法。无名无识亦无所住。无戏行无倚无著寂如虚空亦不巢窟无上寂定亦无所生又无身法。其有忍于深空法者。此则不离于佛法矣。所以者何。若此龙首。诸佛之法终不可以想行而至。其有想著有言有说有宣有广。殊不可以得佛道法也

于是龙首谓濡首曰。善哉善哉。仁乃快说无思议法。谁当信此一切众生不离佛法。濡首答曰。族姓子。其世尊子坚住信法。八等之地及须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨阿惟越致无动转者。斯诸菩萨已住清净行空法者。是等当信耳。所以者何。此龙首。其诸菩萨行如是者。便自誓愿。必绍大业吾升趺定坐终不动转。至于得成无上平等觉必将来一切诸天龙鬼神极世之前。成其大导当师子吼。所以者何。若是龙首。菩萨了空无想行法。住如门阃。坚喻须弥无能动者。如是龙首其菩萨住空无想愿法。一切众生无能动者。又是菩萨处于佛树。乃至道场无能动摇。问曰濡首。何谓佛树道场之处。濡首答曰。何谓龙首如来化处化所依坐。何谓如来化之觉法及现神变化度说法。谁为如来。其谁化者。龙首答曰。吾尚不见如来之化及法身像处。何况所化复现威神。又所说法及所变化乎。一切如化本无亦化。其化亦化亦如化耳。濡首曰。善哉善哉。龙首菩萨。为吾发遣应慎之法。为如彼诸深妙无著法忍说者。是为无上无比之说也

彼时龙首谓濡首曰于斯妙像要法之说。亦无起行又无入忍者。所以者何若此濡首。以诸法本净。其相本空亦无处所。亦无巢窟无色无像。诸法悉等如虚空。若此濡首。其有法当起法忍者。则如来化亦逮法忍。影响梦幻野马泡沫芭蕉之属。亦悉当复成其法忍。所以者何。以其忍处悉空如空。都无起法忍之者。又忍者亦无其起。亦不已起又无当起亦无甫起。又其忍者。亦无是处亦非彼处亦无中处。此乃无上无比要忍。若此菩萨于是慧心不恐不怖亦无畏惧。是则菩萨摩诃萨。便应无上法忍之行。十方诸来神通菩萨其闻濡首所说深妙。咸悉踊跃皆逮此定

是时濡首谓龙首曰。云何族姓子。其菩萨者以无著行得入法忍乎。答曰濡首。若有菩萨想念所向则为着行。言吾解深。云我深忍明达晓了吾已至道。其语此言。皆亦着行。濡首又问。菩萨何行修应得道。答曰。于诸法都无所入。不念诸法了诸法无。其诸法者依着因缘。于本为空获无所有。是行菩萨便应道忍。设如此行为无所行。譬人寝寐于梦所行。龙首又曰。然其梦者。不行方隅亦无所行。亦无去来无住无坐。其寐寤已则达而信。所梦空身无持无舍都无执持。无像无相亦无处所。亦无所有其若虚空。如是濡首。菩萨之行当无所著亦无所入。如空本无亦无戏行。此则极世无上福田。斯乃应受一切供养为无量导。是最福地。为应最上法忍之行。普来众会率怀喜敬。各所赍华宝以散濡首。瞻睹欣踊悦豫无量

于是龙首谓濡首曰。宜可俱进入城分卫。曰仁去矣。行分卫时无念。举足下足躇步无念。动摇亦当无处无住无游。无屈无申无心无念。无所发行行无所想。亦无城想游无路想。又无城郭县邑丘聚想。亦无里巷无家居想无门户念。无想男女无想幼弱。都无心想行当无念。所以者何。以其法行当如是故。亦无所著无色无像。无起无灭都无诸想。如此行者。乃应菩萨无上分卫。清净寂寞要道行也

尔时龙首菩萨摩诃萨忽然于处以如海定三昧正受。其定之德。譬如大海湛然无移憺怕清澄更无异味。其底深邃不可测度。琦珍英宝普无不有。而海汪洋包罗弘广。含受万物渊懿博泰。无边无崖大水澹满。诸德神龙而皆居之。众生巨体所依长育。若此龙首。其诸菩萨以如海定正受之处。所住要旨无能动摇者。如是龙首。其斯菩萨以法身海。含容一切道宝智慧三十七品。十方依之莫不长育。应无上微妙之法。为无动摇无言说要行。当知。是应如是者得无退转定行之地也

尔时于是。妙心菩萨欲动龙首大士所坐如海慧定正受之处。尽其神力永不能动。时此三千大千世界。普悉六反乃大震动。而龙首身及所坐处都不动摇。何则然者。以其龙首住无动摇。住地处所。住无所有。住无想念。住无戏行。住无劳静。住无言辞。住无所住。斯谓道住。时龙首菩萨摩诃萨寻从定寤。敬向如来无所著平等正觉。雨拘文华趣散世尊而叹赞曰。自归于佛天中之天。乃使一切诸会菩萨十方来众诸大士等众尊大天及龙鬼神咸悉逮闻如是之法。无上要旨深妙慧说。为无倚着无巢窟说。为应本空寂寞故也。是时妙心谓龙首曰。仁为觉地六反震动乎。曰族姓子。其有动者当觉地动地。复为之上下四震。唯由其觉动不动故耳。又如十方诸佛世尊。普大菩萨不退转等极世都动。岂能动摇此上尊处。观诸声闻缘觉之众。彼虽离动。未晓本空在动之地。自谓无动了本无者。于此诸法永无动摇无念无著。如是妙心。其菩萨以空无想不愿之行清净法要逮无动摇。彼乃永静安无动摇。又曰龙首。可行分卫。答曰濡首。吾今已解无上最要分卫之慧。何则然者。缘其逮致如海大定正受之处。始乃自明。为以得无上平等正真觉道。以于生死兴显佛事。为转法轮以度众生。为济因缘离垢根本。唯然濡首。如吾遇仁。乃为逮值无上善友。遭蒙矜念心怀悦豫。成立大德喜自光慰。濡首。于吾为覆载首。大无量过度之首。无垢广普微妙吉首。亦应最上不可议首。愿布五体稽首恭礼无上仙圣甘露之首。濡首答曰。善哉善哉。如仁龙首。已为果达野马梦幻影响之行。无名无像无所有法。仁今乃应无上大道不可思议来法之祠。以得如海定正受行。共应如此。当知是辈在一生补处。斯者乃为菩萨辩慧。其致是像深妙定法如海定等则离诸想也。曰仁可行从分卫。龙首答曰思齐其德当与仁行。二圣龙游不亦宜乎。濡首曰。吾无所行亦无去来。又无进止亦无侣游。不住不坐亦复不行。行无所至来无所由。住无所处。坐无所据。行无所趣。譬若龙首。如来现化。宁有去来坐起行游卧寝寐寤不耶。曰化者都无去来坐寝之处矣。吾于诸法亦复如是。无住不住无起不起。亦无已起又无中起。亦无当起亦无甫起。龙首答曰。如仁所言。此为极世难信之说。谁当信仁此尽要慧耶。答曰龙首。仁者且听。岂为无目设举锭烛乎。夫然炬燎唯为明目耳。如此是像深妙之法。正为向达彻远菩萨摩诃萨乃能信受是道要耳。其了如此至要之慧。斯则晓解本无行者。此等菩萨为应清净无上久修梵行之徒。是曹正士深住于法。信法受法持法说法之辈也。为在鹿聚已转法轮。为应贤圣亦大导师。施惠明眼。为应无量雄猛之者。此则无上最妙法者。濡首童真发说是时。普大众中八万菩萨悉得无所从生法乐忍也

于是正士妙心菩萨居大众前广然踊跃。掬满手宝。以恭肃心向散世尊。又散濡首童真菩萨。散讫忻喜重叹咏曰。自归诸佛。为慧圣达擿雾寤寐。碎散痴本解众颠倒。释疑除网顺入道明。致无上觉者。自归于法。法之最法。法治多济疗捞雾龙。援雪生死[卄/好]莇众秽。荡除心垢通导迷惑。法为无上。修蒙永度。其诸菩萨久履梵行。无上清净仙圣明类。大神通等弘显德者。无上之徒。于此乃逮信向是像深妙法众。今普自归之。濡首答曰。若此妙心。其无脱者。斯当果致无上等觉。曰云何濡首。其谁无脱耶。曰其有执持。斯当求脱。如是妙心。法无执持亦无系着。又族姓子。法都无脱亦无执持。当谁有脱。无缚无脱。诸法无持无取无舍。譬如人语幻者言。善男子。为深入人解之脱之所可执持。幻答人曰。吾亦非男亦非凡人吾无所持。当何所脱。是者妙心。道无执脱当观其无无本空净矣

佛说濡首菩萨无上清净分卫经卷上佛说濡首菩萨无上清净分卫经卷下

        宋沙门翔公于南海郡译

时龙首菩萨谓濡首曰。去矣族姓子。东行分卫。答曰龙首。其幻化野马宁有东西南北方乎。曰吾于仁前尚不能言。况敢所说。何则然者。以其诸辩从尊所问。仁即应顺如法发遣。一一解散而无挂碍。故吾无辞莫知所对。曰夫达者都无言取。况共乃复有所说乎。是者诸法之无由矣。曰何谓为诸法之无。答曰龙首。无所无者。斯诸法无是诸法要。以此之慧。乃能通彼众音声耳。无所宣布乃为要义。是岂非至要义说哉。曰此续在想行者也。曰何所行应离诸想。答曰龙首。菩萨不于色痛想行识界有想。又于法本亦无所行。其本无者亦无所行。以是之行得离诸想。说是深邃微妙法时。五千菩萨逮致此慧。二千天人发菩萨心

时龙首曰。吾将退矣。以童真非我侣故。濡首报曰。吾无去来亦非有侣亦无所俱。何则然者。以道无侣故。亦不想念与诸法侣。又亦不与欲行为侣。于本无法。亦不见而有其侣复与所俱。又本无者都不言有。吾我性有人寿命及身养育法。人物言说识觉所倚着。及其所作行趣之事。诸法之本本无如此。当与其谁而为侣俱耶。其有侣者是欲侣俱也。譬如龙首。有明达人而念言曰。如来所化幻士所化。如是此化等一无异化。而斯人化各各言曰。吾与汝侣汝与我俱。于仁龙首意云何。其此人化为有侣无。答濡首曰。化无侣也。所以者何。用化本无无所有无形像不可得故。曰如是龙首。于其生死都亦无侣亦无所俱。其有侣俱斯则有别。若起侣想是便与欲俱。明达菩萨当解侣想。何则然者。以其诸法如幻如化无侣不侣。欺哉诸法慌忽无信。若梦影响。所有如空。想识无安无处无持无意。无念无所有。已离诸念。于念无念应本无念。曰濡首。仁为曾与幻士化人。对共语言行来坐起。又共谈会有所思惟不。濡首答曰。不见也。龙首曰。幻士何像貌。曰其幻者似人像类。幻之化像亦复若此。合同像耳。所以者何。如其幻化亦不彼脱亦不此脱。幻化亦不与人而异。人亦不与幻化有异人便幻化。如幻化者以幻化法而问幻事。诸法亦尔。又问濡首。仁为自曾与幻化复共坐起有所言谈交游讲会相对住不。曰云何龙首。幻士及化与欲有异耶。至于吾我及人寿命养育之法有异乎。吾以此幻化之说。欲试问仁。知大士于斯有异辩才。当敷何法也。曰仁如所试。为欲试虚空之幻化法耳。仁便念幻化为有想也。幻者本无。无想无念亦无形像。亦无所有已离众念。濡首曰。若此龙首。法亦如幻幻化本空。其空无像亦不可见。曰濡首。诸法无像不可见乎。如仁所言。一切菩萨摩诃萨等当云何受其封拜得成无上正真道意。为谁知度受封拜者。濡首答曰。云何龙首。曾行山中为闻响声。于山中为有响声出不乎。其声为有所住处不。以何耳识闻其声耶。彼声为有所说不。宁有受持响声者耶。又复谁共谁闻响声者。龙首菩萨答曰。无也。濡首曰。如此若菩萨解诸法。若如响空者。则一切诸音声如响离彼众声。其诸菩萨以此封拜于无上正真之道。于斯亦无受封莂者。十方诸来大菩萨众咸闻濡首童真所说。莫不喜踊叹歌无量

尔时龙首谓濡首曰。宜时侣行入城分卫。念其日时得无过耶。答曰龙首。诸法无过亦不有时。其处于想行之者。彼则有时不时之想耳。明达菩萨于本了无解空法者。岂其有时不时言哉。凡诸余法有时不时。无时非时乃应无上如佛法律矣。其在算数计时节者斯则有过时之想。如诸世尊贤圣弟子。常自饱足以道智慧。慧无想识于想无想行无诸作。亦无想念无念不念。以此智慧而常饱足。世尊圣众都无食念。亦不复想有食之事。其如此食而为食者。是谓贤圣应无杂食。若永服食如此食者。是则长演甘露法食者。彼以此食用之为力。能住身命至于一劫复过一劫。所以者何。其如此者彼已觉了诸法之行故。都无想念解空清净。晓了如此。是不复有求食之识。如其凡夫未达者也。又诸如来无上正觉及普世贤圣之等。有大慈悲喜护之心。惠施仁爱愍念众生。使兴于世耳。唯欲济度五道勤苦故。现入郡国县邑聚落行受分卫。而彼众圣已离诸食不食于食。唯以慧解诸定正受为常充足。其于杂食而续食者。斯受流转便数生死。用是之故诸佛世尊。以于诸食而悉明了。都无复杂食之想。慷慨喟然安和住身。能如恒沙复过是数。从始发意。永常无复诸饥渴杂想念也。至在佛树明星出时。从始所可受食者。彼因此食。其于正士及大丈夫英雄龙猛。又至师子诸调儒夫及众华孚正士秀异种种莲华男子无上丈夫法御天人师。应所当得。应所明了。应所觉达。悉已了而具足。等于一像合会智慧。得成无上正真道意也。以是龙首。一切菩萨普诸如来及贤圣等。唯以此食升致无上正真觉道。便能住寿如恒沙劫。又能踰此复倍无数。而诸如来永无其劳。所以者何。以其应于无想食故。无念不念无合不合。亦不想合贤圣之行。恒便随顺出诸香气。自然清净无想无念无诸巢窟。亦无戏行本空自净。如是龙首。菩萨摩诃萨当作此食乃应法食。

龙首答曰。善哉善哉。濡首所说法之微妙。吾已饱足于是上食。但闻此法食之要说。便为已甚具足矣。况其长食无杂食者。岂当复食思欲食哉。云何龙首。虚空之体宁当有杂食之食。又言饱足乎。对曰濡首。空无所有也。又曰龙首。为能饱足幻士所化不。答曰不也。云何龙首。宁可以食饱足中现像耶。答曰不也。又曰龙首。夫大海者宁复饱足于众流乎。答曰不也。濡首复曰。如是龙首。诸法无厌若如虚空。而仁向言有饱想乎。诸法如空无想无愿。无起无行亦无所作无所造。永然无欲以定以脱。无色无像无坚无固。了如虚空都无所持。诸法如此。云何而起有饱想耶。龙首又曰。若是濡首。有此行者一切不复食于食乎。而仁说食本空耶。濡首曰。若此龙首。则一切众生而无食也。譬如龙首。世尊化作恒边沙人以食食诸化人。云何族姓子。彼诸化人以何为食。宁复有食者不乎。答曰。化者无想不识无所有亦复无食。何况言当有食者耶。若此龙首。一切诸法有见无见如幻化也。普诸众生而不解此。以其不解便即流转受生死矣。于中观之亦无所有亦无所得亦无流转。解生死无如本无者。则一切无受亦无生死。不晓本空便有生死。其生死者亦无生死。于其生死亦无所受亦无所得。何生死法者乎。答曰濡首。斯言甚善。宜知其时可共行矣。还于祇树给孤独园。吾诸饥渴永为已断。答曰龙首。譬如幻士所可化人。而化人言吾饥渴。斯宁为饥野马法耶。如是龙首。一切若此。其诸法者皆如野马。解此乃解。而族姓子言。吾饥渴以为断乎。当食斯食。如诸法食不断无坏亦无饥渴。一切诸法本已饱足。以故彼诸凡夫下士不了其本。则作此言。吾饥我渴又言饱足。如诸贤圣解其法本。彼无饥渴亦无想足。解诸饥渴亦无生死。亦无戏行亦无想念。彼已无动亦无倚着。诸法已脱本无著故

龙首又曰。如仁濡首。诸所可说彼之要言。但说法界也。濡首复谓龙首曰。其法界者。亦无说不说。亦无言趣无屈无申。所以者何。如是龙首。法界无所有。言者无说亦不所说。亦无戏行无所著无合偶。彼无想念亦不有念。亦无所起亦无灭行。譬如龙首。虚空之界无想无念无起无灭。诸法亦尔同如虚空其本相空。本不可得亦不可知。其相如是亦不可得有能得其相。彼诸如来般泥洹者亦当可得。若此龙首。一切诸法都无处所。无色无像亦不可见。以是之故。恒边沙诸如来般泥洹者。其于法中亦复无般泥洹者。亦无地水火风界而般泥洹。亦无空界亦无识界。般泥洹者泥洹如是。于泥洹中亦无泥洹。若诸法有泥洹想者。则虚空界有泥洹想耶所以者何。以其诸法本定而空。诸法静寂。而复寂于此凡夫下士之类起有泥洹想念者。因便有吾。言我有受。有吾我受。有寿命受。有人物受。有想识共来。解真无法者。即起是想想念泥洹。以此故而不得脱。便生老病死。取要言之十二因缘至于大苦众患集会。为彼之故言有泥洹。为诸有二想。行者以其不解诸法本无。已不晓了不觉悟故。与诸如来诸佛世尊。明解深入权行菩萨。宿树众善立不退转。积累功德有大威神。为极唱导无上大师。与如是等菩萨摩诃萨行。而违反起有诤想。又与声闻缘觉之众。与其相违而起忿诤。与彼诤故当受大罪。以其诤故长流生死。当归不净极臭处矣。一切众圣永所不叹。诸上明达所可远离。譬如族姓子有城郭若复聚落。去其不远积众臭秽。于其彼处人众趣往昼夜不息。遂增污秽不净臭处不洁之物也。诸愚凡夫处于五道。起灭不竟众想无。断广其生死如彼增臭也。以其不明又不晓了。不解其元不达本无。雾笼茷盛痴冥积故。广受流转增长生死五道之趣。或生地狱或即饿鬼。复归畜生。或天或人。神变无常五道勤苦。灾患颠倒痛痒创楚。众恼之元诸苦所由。遂增臭秽流不净气。使彼明达贤圣之众乃以为灭所共贪疾。又诸慧士所可远离。用是杂垢长不解脱。复使斯类是趣其生。是归有老生老苦。极忧恼万端。是致病死殃福追之。善则荣乐罪则祸随。以要言之患变猛集至其痛热众苦合会。而彼以故不脱生死。但由未了其本无故。长受生死如其增臭也。龙首复谓濡首曰。云何濡首。得了其本。曰以无心想以寂寞行。以起静定向入清净。其住是者则晓其本。曰云何濡首。何谓为幻之寂寞曰其解了如幻者。此则幻之寂寞清净也

尔时耆年须菩提至濡首所睹其大众。即而问曰。诸正士等普来会此。为何讲乎。答曰贤者。吾于诸言都无所说。又贤者。宁闻诸幻人有所说不。山中之响梦影野马。为有言谈耶。复闻有其说者不乎。又贤者。如来所化宁有耳声。其复有闻者不为有识。若受持语言名字句说者不。答曰不也。时须菩提。[火*霍]然于所坐慌惚之间。寂而灭定

时舍利弗诣濡首所。睹其普众大会之场。率多菩萨咸听濡首所讲之说。见须菩提在于彼坐寂而灭定。问濡首曰。此贤者为何志故居斯便灭定。曰舍利弗。是须菩提离灭定不与法而有其诤。如是贤者。此以无诤行。无住无著无巢无处。过诸窟法而三摩越。时须菩提作是灭定。从定寤起而向世尊。即偏袒右肩。叉手跪作是言。自归诸佛无上觉者。其有显演如是深邃微妙法像难见之文。不可议说。已断所著等离诸想。已得寂安。其不退转大士等及诸初发意菩萨。逮闻如此劝发之说。岂不快哉。濡首又谓须菩提曰。不于此法有说有劝有彼所向也。何则然者。以诸法无劝无说无谈无识。又此要义无言无语。无住无动无去无来。无坐无卧无倚无处亦无所有。所以者何。是诸法本空无所有。其本不可得故。曰何谓濡首其本行法。曰惟贤者。诸法无行是行之要。当作是行。晓行是行乃为至行也。若此可共都行求食。曰濡首。吾不复入于聚落分卫。所以者何。逮闻是要已离聚落。亦离城想亦离色想。以要言之。亦离声香味细滑法想。都离诸想而无想念。曰唯须菩提。如此离其想行者。所是云何而进止乎。云何濡首。何谓如来所化色痛想行识。以何识法。如来所现化。化以何想而有进止。有所瞻视复有屈申乎。曰善哉善哉。须菩提。如世尊所叹仁为最晓空闲行者

濡首又曰。唯须菩提。可共诣佛礼事供养。濡首重曰。唯贤者。吾以清净食而请于仁。时舍利弗谓濡首曰。于何所与吾等食。为当施设何等之食。曰唯贤者。其所食者亦不有食。亦不吞食。又所吞食。亦不色声亦不香味亦不细滑。其所食处不在欲界。又不色界亦不无色。不处三界亦不离其中。是则诸佛世尊食处。时舍利弗谓濡首曰。善哉善哉。如仁所说吾已饱足。于时是无上食叹之名。况其已食如此食者。曰唯贤者。其食不以肉内外眼见。亦不天眼亦不慧眼处有所见。其食如此乃应等食也。尔时耆年须菩提及舍利弗并诸众生。闻是叹食之说。即于其处寂而灭定。时妙心谓濡首菩萨曰。当以何食食。须菩提舍利弗等。为以何食而三摩越。曰以无漏食。行无倚着食。行无众食。以此行而行。其作此食者。不复于三界食于食也

尔时贤者须菩提舍利弗。从灭定寤各行分卫。时须菩提。入大长者家分卫。其长者妇为优婆夷。见须菩提默然而住。即请贤者为何之乎。答曰姊。来求分卫。曰贤者。仁续分卫想。来止了耶。曰姊。吾从本际已了分卫想。曰须菩提。其本际宁有了未了。言从本际已了分卫想乎。曰姊。如本际空未际亦空悉如本空。优婆夷曰。若此贤者。已悉空者奚为复说了不了乎。仁便伸手当施卿分卫。须菩提即自伸手曰贤者。是为罗汉不了其本反取灭证者手非。须菩提曰姊。罗汉手无形不可见亦无屈伸。譬如幻士为幻化人作此言。何所是幻者手乎。复言可伸幻者手耶。曰姊。幻手为可见不。又可伸乎。答曰不也。须菩提曰。若此姊。世尊说一切诸法如幻本空。若是贤者。世尊说一切空。何为贤者续求食。时优婆夷未寻与须菩提分卫。重曰贤者。可前钵。适当前钵。钵忽然不现。时优婆夷。以手索钵钵而无处。手亦不近于须菩提。优婆夷曰。善哉善哉。此则无著清净之身。应佛所叹空闲行者。优婆夷适作是言。钵即自出。时须菩提便前授钵。优婆夷取钵盛满饭授须菩提。便谓之言。贤者。是为释迦文佛所称叹。处闲居第一者钵非。曰姊。如佛所说空闲行者非有钵矣。曰如贤者空闲行者非有钵耶。曰姊无也。曰又贤者。闲居尚无钵。岂当复有受食缘乎。曰贤者。已记闲居。亦当无罗汉取灭证耶。又贤者。食此饭已。当了知食者如幻所食如化。又如化人食于幻者。亦当如以野马饮于渴者。其食所食当了如此。明解是者乃应如来达三世本无分卫之行也。若贤者。其起施念。有想受者。便造有众分数也。已受数者则有二见。以有二见便与凡夫流转五道。生死同归也

时优婆夷复谓须菩提。又如贤者。诸佛要法不但受食。及与施者。当应了如幻如化为本无为无有至于生死与泥洹法。亦当晓了如梦幻化野马影响亦如本无。于诸法亦悉当尔。诸法清净都无所有。无施无受。无戒无犯。无忍无诤。无进无懈。无定无乱。无慧无愚。于一切法都无所有。是行乃应世尊如法受食。弟子行法其如此解分卫行者。则于三界无杂食之想。亦复不处泥洹之乐也。须菩提闻优婆夷所说。即惘漠不知所言。曰贤者。泥洹为寂耶。岂无言而不对乎。曰姊。斯何言乃如此。须菩提曰姊。了幻法耶。答曰贤者。吾了诸法悉如幻化。幻者及化亦皆本无无所有。时须菩提。便于所处忽而灭定。欲知优婆夷志求何乘。以为其证。勇辩乃尔敢师子吼。明解幻法所说自恣。而无挂碍。尽力观察处。优婆夷为阿那含。曰姊。已得阿那含乎。优婆夷曰。云何贤者。如来法本宁有阿那含行法乎。又贤者。法无形色。亦复无来想像之迹。无彼此识无中间行。亦无所想无取无证。亦无处所。乃为明了道之行耳。向贤者。云何处阿那含毕。乐罗汉证法乎。又贤者。法无去来。其有去来有所趣向。有所有趣有起有灭有念有想。皆堕凡夫流转未解数也。是时优婆夷忽于所处。于须菩提前化于高广大人交露之座。普现感动光明相像。显转无上阿惟越致法轮。令普舍卫境界之内及十方土。莫不闻见此之所兴感变也。尔时空中万二千天。闻彼所说悉逮一生补处。舍卫国内志菩萨行者二万八千人。承宿众德皆得不退转。十方之众诸来大士其闻是说。百亿菩萨本得无所从生法忍。复闻是上要说即皆逮一生补处。于是濡首龙首菩萨。并诸土普来之众。及舍利弗须菩提等。俱从舍卫国甫出城门。[火*霍]然轻举忽升虚空。濡首菩萨寻扬身光。威神炜炜照耀暐晔。明影玓瓅踰于日月。普蔽余光暠然晃昱乃彻窈冥。如金翅王飞而行焉。一切众生莫不见者。其所经由彼众天人。皆闻诸法如梦幻化野马影响泡沫芭蕉之。要言深邃像说。各怀欢喜慈心相向。一切天人但闻梦幻声。而化幻法于见无见亦不可得。诸逮闻是像微妙说者。合百千众得不退转。时所经游于其中间。有长者子其名善意。宿立德本。亦闻濡首无上幻化之要说言。并复睹见神景变化。即发无上正真道意。寻自誓愿。吾于来世得为如来无上平等最正觉道。时所现感动亦当如是。濡首见彼族姓子有决得妙岐嶷之质。欲绍佛种乃发大志心在菩萨口咏誓愿声畅一切如师子吼。即请善意而告之曰。族姓子。汝解诸法如幻化者。必离劳乘声闻缘觉之地也。便当成致无上正真道意。又当晓了诸法梦幻之妙法说悉为无所有。时长者子跪而对曰。蒙解说诸法如幻如化。濡首重以诸法要言劝发长者子。长者子忻乐之心遂而踊跃。时彼大姓心巨旷解逮致法忍。八千天人发无上正真道意。时五千天子在于虚空。闻濡首劝进之说。[火*霍]然心解逮得无从生法乐之忍。咸悉肃然恭敬之至。已礼濡首忽升虚空各还本土。是时濡首龙首菩萨。舍利弗须菩提等。还于祇树给孤独园。俱诣世尊。稽首佛足却坐一面。龙首菩萨便从坐起。向佛叉手已濡首童真诸所讲谈法要之说。具启世尊。时佛赞曰。善哉善哉。濡首童真。善说诸法无上微妙。如梦如幻如化野马影响之声。则是诸慧深奥之至。是诸佛要。斯乃应如无形无像本无幻说。时佛顾告贤者阿难。受是濡首诸法要文。阿难敬前长跪白佛。唯然世尊。如教受之。当何名此经。云何奉持。时佛重复敷演濡首妙心菩萨等所说慧要。及舍卫国长者优婆夷。为须菩提所现感动。乃至转一生补处之轮。佛复告阿难。当受是上要之慧。又是贤者。此名濡首无上清净分卫经。亦名决了诸法如幻如化三昧。勤念受持。当广宣传普布演说。又是阿难。若善男子善女人等。闻斯要专心信向。是者阿难。则应面见诸佛世尊。又为濡首童真菩萨。必所感致无上正真之道。会成至佛。况其受持诵习讽读奉行应者。德极无上。是善男子善女人等。为逮诸佛之慧藏。为得诸佛最上要镇。又为诸佛之所拥护。普为十方诸现在佛所授封莂。诸佛为手授其决。当成无上正真道慧。佛说是已。濡首童真龙首妙心及诸菩萨。舍利弗须菩提等及众比丘。一切会者诸天龙神阿须伦人与非人。闻佛所说莫不欢喜。前为佛作礼而退

佛说濡首菩萨无上清净分卫经卷下


佛说圣佛母般若波罗蜜多经

    No. 257 [Nos. 250-255]

    佛说圣佛母般若波罗蜜多经

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

如是我闻。一时世尊。在王舍城鹫峰山中。与大苾刍众千二百五十人俱。并诸菩萨摩诃萨众。而共围绕

尔时世尊。即入甚深光明宣说正法三摩地。时观自在菩萨摩诃萨在佛会中。而此菩萨摩诃萨。已能修行甚深般若波罗蜜多。观见五蕴自性皆空

尔时尊者舍利子。承佛威神。前白观自在菩萨摩诃萨言。若善男子善女人。于此甚深般若波罗蜜多法门。乐欲修学者。当云何学

时观自在菩萨摩诃萨。告尊者舍利子言。汝今谛听为汝宣说。若善男子善女人。乐欲修学此甚深般若波罗蜜多法门者。当观五蕴自性皆空。何名五蕴自性空耶。所谓即色是空即空是色。色无异于空。空无异于色。受想行识亦复如是。舍利子。此一切法如是空相。无所生。无所灭。无垢染。无清净。无增长。无损减。舍利子。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。无眼识界。乃至无意界。无意识界。无无明。无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。无所得。亦无无得。舍利子。由是无得故。菩萨摩诃萨。依般若波罗蜜多相应行故。心无所著。亦无挂碍。以无著无碍故。无有恐怖。远离一切颠倒妄想。究竟圆寂。所有三世诸佛。依此般若波罗蜜多故。得阿耨多罗三藐三菩提。是故应知。般若波罗蜜多。是广大明。是无上明。是无等等明。而能息除一切苦恼。是即真实无虚妄法。诸修学者。当如是学。我今宣说般若波罗蜜多大明曰

怛[寧*也](切身)他(引一句)唵(引)誐帝(引)誐帝(引引二)播(引)啰誐帝(引三)播(引)啰僧誐帝(引四)冒提莎(引)贺(引五)

舍利子。诸菩萨摩诃萨。若能诵是般若波罗蜜多明句。是即修学甚深般若波罗蜜多尔时世尊。从三摩地安详而起。赞观自在菩萨摩诃萨言。善哉善哉。善男子。如汝所说。如是如是。般若波罗蜜多。当如是学。是即真实最上究竟。一切如来亦皆随喜

佛说此经已。观自在菩萨摩诃萨。并诸苾刍。乃至世间天人阿修罗乾闼婆等。一切大众。闻佛所说皆大欢喜。信受奉行佛说圣佛母般若波罗蜜多经


佛说圣佛母小字般若波罗蜜多经

    No. 258

    佛说圣佛母小字般若波罗蜜多经

        西天中印度惹烂[馬*犬]罗国密林寺三藏赐紫沙门臣天息灾奉　诏译

如是我闻。一时世尊。在王舍城鹫峰山中。与大比丘众千二百五十人俱。并诸百千俱胝那庾多菩萨。复有百千俱胝那庾多梵王帝释护世。诸大众等恭敬围绕

尔时世尊于吉祥宝藏师子座上结跏趺坐。是时圣观自在菩萨摩诃萨即从座起。偏袒右肩右膝着地。瞻仰尊头目不暂舍。合掌恭敬欢喜踊跃。头面礼足而白佛言。世尊唯愿世尊为我说是小字般若波罗蜜多经。令诸众生得闻是法获大福德。一切业障决定消除。当来速获无上菩提。若有众生发至诚心。受持读诵此真言者。随所求愿决定成就无诸魔难

尔时世尊告圣观自在菩萨摩诃萨。善哉善说是言。善哉善哉善男子。汝能如是至心。为诸众生令得安乐长寿。善男子汝应谛听。至心听我说是小字般若波罗蜜多经。若诸众生闻说是法获大福德。一切业障皆悉消除。决定速证无上正等菩提。若有众生发心受持此真言者。无诸魔事皆得成就

是时圣观自在菩萨摩诃萨。复白佛言世尊善逝今说。为诸众生令得安乐

尔时世尊而于一时。入三摩地名解脱一切众生。从定起已眉间毫相。放百千俱胝那庾多光明。此大光明普照一切诸佛刹土。所有无量众生蒙光照曜。皆得决定速证阿耨多罗三藐三菩提。所有地狱一切众生皆获安乐诸佛刹土六种震动。于诸佛上又雨上妙栴檀沉水细粖之香以用供养

尔时世尊说此般若波罗蜜多经。是时所有一切菩萨摩诃萨。各各发起平等之心。发起慈愍心。发起忆念利他心。发起远离一切罪障心。发起种种利益之心。发起般若波罗蜜多心。是时世尊告圣观自在菩萨摩诃萨。汝等谛听我今为汝。说是圣佛母小字般若波罗蜜多真言曰

曩莫(入一)舍(引)吉也(二合反二)母曩曳(引三)怛他(去引)誐哆(引)野(引四)[口*栗]喝(二合)帝(引五)三么药(二合反)讫三(二合)没[馬*犬](引)野(六)怛儞也(二合反)他(引八)母[寧*頁](引)母[寧*頁](引九)摩贺(引)母曩曳(引十)娑嚩(二合引)贺(引十)

佛告圣观自在菩萨摩诃萨言。此圣佛母小字般若波罗蜜多真言。一切诸佛由是得阿耨多罗三藐三菩提。我亦由是小字般若波罗蜜多真言故。得成无上正等菩提。往昔有佛亦名释迦牟尼如来。于彼佛所闻说是法。彼佛说言如是三世一切诸佛。由斯法故方得成佛

佛复告圣观自在菩萨摩诃萨言。我今为汝授其记别。汝于人间未来世中得成佛道。号普放光明吉祥。宝峰王如来应正等觉。汝得听闻如是妙法。应当受持读诵若自书写若教人书思惟解了。复能为他一切众生广说其义。令彼书写是经。于己舍宅受持读诵。于未来世速成无上正等菩提。是时一切如来同证汝等。我今为汝复说般若波罗蜜多陀罗尼曰

怛儞也(二合反)他(引一)唵(引二)惹(仁左反下同)野惹野(二)钵讷么(二合引)避(引三)遏嚩(无可反)铭(引四)萨啰(来假反下同)萨哩抳(尼贞反下同五)尾哩尾哩(六)尾啰(引)尾哩(七)企哩企哩(八)儞嚩哆(去)弩(鼻音九)播(引)攞[寧*吉](宁吉反十)没度(引)哆(引)啰抳(十一)布啰抳(十二)布啰野(十三)婆(去)誐嚩(武末反)帝(十四)萨[口*栗]嚩(二合引)[口*商](引十五)么么(此处称名十六)布啰野(十七)萨[口*栗]嚩(二合)萨怛嚩(二合引)难(上)左(十八)萨[口*栗]嚩(二合)嚩[口*栗]么(二合引十九)嚩啰拏(引)[寧*吉](二十)尾戍(引)驮野(二十一)尾戍(引)[馬*犬]野(二十二)没[馬*犬](引)地瑟姹(二合引)[寧*頁]曩(引二十三)娑嚩(二合引)贺(二十四引)

佛告圣观自在菩萨摩诃萨。此胜妙法般若波罗蜜多陀罗尼。是能出生一切诸佛菩萨之母。若有众生暂闻是法。所作罪障悉皆消灭。此法一切诸佛及众菩萨。经百俱胝劫说其功德不能得尽。若能受持读诵此陀罗尼者。便同入一切曼拏攞中得受灌顶。又如受持一切真言皆获成就。是时圣观自在菩萨而白佛言。世尊何故复说此般若波罗蜜多陀罗尼。世尊告言我为愍念一切少善方便懈怠众生。是故说此般若波罗蜜多陀罗尼。令彼受持读诵。若自书写若教他书。此等一切众生。速疾证得无上菩提。如是如是世尊善说是般若波罗蜜多陀罗尼。是时圣观自在菩萨摩诃萨复白佛言。世尊此法实未曾有。世尊此法实未曾有。善逝世尊大慈。为欲救度一切少善方便懈怠众生。令得利益安乐说斯妙法。是时世尊说此经已。诸大声闻并诸菩萨摩诃萨。一切世间天人阿苏啰彦达嚩等。闻佛所说皆大欢喜。信受奉行作礼而退佛说圣佛母小字般若波罗蜜多经


佛说五十颂圣般若波罗蜜经

    No. 248

    佛说五十颂圣般若波罗蜜经

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众千二百五十人俱。皆得阿罗汉。诸漏已尽无复烦恼。心善解脱通达智慧。如大龙王断诸有结。去除重担所作已办。逮得已利心得自在

尔时佛告尊者须菩提。若有善男子善女人及诸声闻缘觉。爱乐修学无上菩提者。汝等之人。于此般若波罗蜜经。听受读诵分别演说速获正觉。须菩提。此般若波罗蜜经。具足方便通达一切。诸佛菩萨甚深法藏应如是学如是修行。须菩提。若有菩萨摩诃萨。于此般若波罗蜜经。随喜听闻受持读诵。应如是学如是修行何以故。此经广说一切诸佛菩萨阿耨多罗三藐三菩提甚深法藏。须菩提。又此般若波罗蜜经。所有声闻法缘觉法菩萨法菩提分法。及一切诸佛一切般若波罗蜜法。聚集摄受平等如一。尔时须菩提白佛言。世尊。云何所有声闻法缘觉法菩萨法菩提分法。及一切诸佛一切般若波罗蜜法。聚集摄受平等如一

佛告须菩提。所有布施波罗蜜。持戒波罗蜜。忍辱波罗蜜。精进波罗蜜。禅定波罗蜜。智慧波罗蜜。内空。外空。内外空。大空。胜义空。有为空。无为空。无变异空。无相空。自相空。有际空。无际空。性空。本性空。无性空。自性空。无性自性空。一切法空。四念处。四正断。四神足。五根。五力。七觉支。八圣道。四圣谛。四无色。八解脱。九分法。空解脱门。无相解脱门。无愿解脱门。一切三摩地总持门。四智。五通。一切如来十力。四无所畏。大慈。大悲。十八不共法。须陀洹果。斯陀含果。阿那含果。阿罗汉果。缘觉果。菩萨一切道智。如是一切善法。一切般若波罗蜜。悉皆聚集平等摄受。如一无异

尔时须菩提。闻佛所说。白世尊言。今此经典。聚集摄受一切善法。一切般若波罗蜜多。平等如一。甚深微妙。意趣深远。难解难知。佛言须菩提。如是如是。如汝所说。须菩提。若有不种善根诸恶朋友。钝根懈怠。无智愚痴。少解少闻。初学浅识。及乐小乘。智慧狭劣者。于此般若波罗蜜经。难解难入。而不信受。汝等当知

复次须菩提。若有善男子善女人。于此般若波罗蜜经。随喜听受。读诵演说。如持过去未来现在诸佛。不久速成阿耨多罗三藐三菩提。佛说是经已。尊者须菩提及诸菩萨。天人阿修罗等。闻佛所说。皆大欢喜。信受奉行佛说五十颂圣般若波罗蜜经


佛说最上根本大乐金刚不空三昧大教王经

    No. 244 [Nos. 240-243]

佛说最上根本大乐金刚不空三昧大教王经卷第一

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    大三昧金刚真实理仪轨分第一

如是我闻。一时世尊大毗卢遮那佛。在他化自在天宫。而彼天宫众宝所成。悬铃璎珞幢幡珠珍种种宝盖。如是庄严遍满虚空。是佛世尊安住诸佛金刚三昧智众圣之尊。戴诸佛冠受三界法王灌顶。成就诸佛一切智智。是最相应自在无碍。具诸佛平等印。善作种种事业。尽诸众生界圆满一切愿。三界平等究竟法身。摄诸如来金刚三业诸佛称赞。是大慈悲大毗卢遮那如来。与八俱胝大菩萨俱。其名曰金刚手菩萨摩诃萨。观自在菩萨摩诃萨。虚空藏菩萨摩诃萨。金刚拳菩萨摩诃萨。妙吉祥菩萨摩诃萨。同心生转法轮菩萨摩诃萨。誐誐那巘惹菩萨摩诃萨。降诸魔菩萨摩诃萨。如是诸大菩萨众而共围绕。宣说一切清净法门。初中后善文义深远。纯一无杂具足圆满。所谓妙乐清净句是即菩提句。贪欲清净句是即菩提句。亲法清净句是即菩提句。一切富乐清净句是即菩提句。见清净句是即菩提句。爱乐清净句是即菩提句。染法清净句是即菩提句。庄严清净句是即菩提句。悦意清净句。是即菩提句。明照清净句是即菩提句。身清净句是即菩提句。色清净句是即菩提句。声清净句是即菩提句。香清净句是即菩提句。味清净句是即菩提句。触清净句是即菩提句。所以者何。诸法自性清净亦复如是。诸法自性清净故。般若波罗蜜多亦清净。佛告金刚手菩萨。若人得闻此一切清净法门般若波罗蜜多者。是人即得销除诸障。谓烦恼障法障业障。诸障道法悉皆销灭。设造地狱之业亦不复受。所有苦恼于刹那顷灭尽无余。速能至于菩提道场。若人受持读诵记念思惟。是人现世得一切法平等三摩地。得一切法自在。获一切爱乐适悦。历十六大菩萨生而成正觉

尔时世尊大毗卢遮那佛。欲令宣说诸佛最上大乘三昧法。金刚界等一切曼拏罗最上之法。一切有情最胜法。尽无尽调伏法。一切义成就法。金刚手大三昧法。无量秘密众妙法。如是等法。是般若波罗蜜多清净法门

尔时大毗卢遮那佛。先现微笑。左作高举势。戏掷金刚杵。复以金刚杵作钩召势。安于本心。说大乐不空金刚本心真理三昧明曰

吽(引)

说此明时。所有三界一切佛刹。一切如来及诸菩萨悉皆悦乐。钩召入大毗卢遮那佛大曼拏罗中。住佛三昧皆悉敬爱。所有一切成就法皆令成就

尔时世尊大毗卢遮那佛。结大乐金刚印已。即入一切如来秘密金刚三摩地。从定出已。告金刚手菩萨言。汝今宣说曼拏罗法。是时金刚手菩萨受佛旨已。即入大秘密金刚三昧出生曼拏罗安想智印三摩地。从定出已。说大三昧真实之理金刚安想大曼拏罗法。即说颂曰

  我今依佛旨　　略说曼拏罗
  三昧真实理　　金刚安想法
  四方与四隅　　宝装四门楼
  尾提炽盛光　　曼拏罗周围
  四隅门左右　　安置半月相
  种种宝严饰　　悬铃珠璎珞
  宝盖及幢幡　　明镜众花鬘
  安外曼拏罗　　内置八辐轮
  分列八尊位　　中位金刚手
  是名金刚轮　　于此曼拏罗
  依法安尊像　　月色及月相
  炽盛光普照　　手持金刚杵
  而现高举势　　处于莲华座
  周匝金刚围　　炽盛光焰照
  持本尊心明　　想起曼拏罗
  乃至诸贤圣　　亦持本心明
  依金刚出生　　宝像及画像
  安本尊周匝　　先于中尊前
  安金刚萨埵　　身相红白色
  顶戴诸佛冠　　手执金刚杵
  现大钩召势　　于右边安置
  枳里枳罗尊　　身色如大日
  众宝严身相　　于后复安置
  念金刚大尊　　其身青白色
  手持摩竭幢　　于左边安置
  金刚拳大尊　　身如紫金色
  二手金刚拳　　四隅安四尊
  执持花幖帜　　莲钵与佛顶
  外曼拏罗隅　　安祢嚩建拏
  四门各中间　　或像或幖帜
  内曼拏罗位　　安金刚手等
  尽彼金刚轮　　遍满佛世尊
  复外曼拏罗　　安欲界天众
  前置三界主　　谓释梵自在
  依如是等仪　　作曼拏罗法

复入曼拏罗仪轨。当依法选择。是大金刚阿阇梨入于道场。夫阿阇梨者。须善一切曼拏罗仪。知一切三昧法。于诸法相善能了知。于诸轨仪悉能成就。常自安想金刚手尊。备受一切灌顶法。通达一切智。了种种供养事。善知世出世间曼拏罗法已。成诸密印。结印皆成就。设误有过。常在三昧所作现前。不经师受而自了知一切供养。如上诸相今略说之

若金刚阿阇梨心所愿求。最上成就法现世皆得。乃至菩萨及一切智智皆能成就。所以者何。是大阿阇梨。观想金刚手尊常在本心。复从于心钩召入曼拏罗。安住三昧欢喜悦乐。自圆满已召入曼拏罗。现身爱敬所作皆成。时阿阇梨结金刚印已。作金刚观视。常持诵心明。作大曼拏罗成就法。后结金刚嬉戏印。持诵心明作顶礼相。阿阇梨先须洁净。着红色衣种种庄严作金刚合掌金刚舞势。手持香花安心入曼拏罗中。又复作嬉戏相持诵心明。然后以金刚视。瞻仰于金刚手。敷座而坐。依法求金刚手成就。是时金刚手作大欢喜而现瑞相。眉间微动身遍红色。面门出大光明。复现种种神通。现神通已。方现本身施最上成就。从是已后日日得一切法成就。是人若坐若行。诸天不能见。不受诸禁制。具足诸成就。获一切富乐。通达无上智。如是等事。是金刚手皆令成就。然后自作供养。作供养已。以金刚灌顶法自受灌顶。次当观想求请。金刚手菩萨金刚杵。既求请已。金刚手菩萨即现本身亲授与之。是阿阇梨持此金刚杵。求诸最上成就。于一刹那中皆悉获得。若自持金刚杵。持诵作最上成就者。经其六月方得成就。然后亦受如前金刚灌顶。即作供养随意所求。当依此仪。应如是常持此大曼拏罗成就法

又复宣说弟子入曼拏罗仪。金刚智阿阇梨。先须结妙乐金刚三昧印。引弟子入曼拏罗而作礼敬。有所愿求应当思念。求金刚手成就法。当结大印而作成就见其祥瑞。诸成就法皆令得成。如是弟子入曼拏罗已。所得成就与阿阇梨等无有异。然后如前持金刚杵。是名金刚弟子。当得受印法诸佛三昧法入诸贤圣法。是时持以种种供养出生诸天食等。入曼拏罗中。如是随力而献供养。及献戏鬘歌舞。依法昼夜绝于睡眠志心专注求法成就。起平等心发大誓愿。普为一切众生令证菩提

又复宣说金刚手成就法。行人当从十五日起首。于金刚手菩萨前。结妙乐金刚印。随意结界。以金刚语持诵一月而得精熟。从是已后所作成就法。皆得成就。如金刚手真实之语。时行人依法造[巾*((ㄇ@人)/登)]像。如曼拏罗仪。当画金刚手菩萨及八大菩萨。行人于[巾*((ㄇ@人)/登)]像前。从十五日起首。先结大印持诵精熟。满十五昼夜不解其印。持诵相续心心不断。至明旦时金刚手菩萨现其本身。作大笑容身如月色。住行人前施所求愿

复说成就法。当于[巾*((ㄇ@人)/登)]内画佛世尊及金刚手菩萨与八大菩萨。周匝复画诸佛如来。还依前法持诵。即得一切成就

又复[巾*((ㄇ@人)/登)]内。以妙香画金刚手菩萨。行人于[巾*((ㄇ@人)/登)]像前。结印持诵一洛叉数。得数满已。行人即成金刚萨埵

又复如前仪式。唯画佛世尊持诵。即得佛成就

又复行人入曼拏罗。持诵中间。一切意愿悉皆成就

又复行人依法持诵本心明。天人皆爱敬。持诵数满一洛叉已。身得拥护。加持白芥子与他作拥护法。加持金刚杵而作旋转。即一切人皆得拥护

又法作观想如前曼拏罗想法。结印现金刚视。亦用芥子。令一切魔众皆被禁缚

若不出息持诵者。诸魔迷乱皆悉制伏

若依金刚坚固法持诵者皆令钩召

若闭目持诵一切魔众自然除灭

若结金刚锁印持诵。一切魔众皆悉印之

若结金刚拏吉儞印持诵。钩召诸魔之心

若速疾持诵。魔众皆怖畏

若结金刚陪啰嚩印持诵。即得一切义成

若欲求大财宝者。当结金刚瑜儗儞印

若欲一切有情皆适悦者。当作微妙音声持诵。即一切有情皆得适悦

若求十方诸佛如来作忻乐爱敬者。当结金刚箭印持诵心明

若欲亲爱坚固者。当作坚固拳安本心持诵

若欲解诸恚怒者。当作高举势结印持诵

若欲有情悦意者。当作金刚拳安心持诵

若欲去除昏闇者。当面东以金刚轮旋转

若欲身安乐者。当加持己身

若欲现诸色像者。当结金刚色相印

若欲闻诸声音者。当加持金刚琴

若欲闻诸妙香者。当想于香加持

若欲了最上味者。当加持金刚杵

若欲作入寤法者。当用加持二手。或抚掌或弹指

若欲解除诸执曜者当结金刚没讷誐啰印

若欲令诸星曜作执持者。当于频那夜迦天像前。作忿怒相高声持诵

若欲解诸虐病者。当现金刚视

若欲解诸毒者。当用孔雀拂

若欲解诸毒药者。当用甘露印

若欲灭除诸恶魔者。当现忿怒势。持诵相续不令间断

若欲解除诸鬼魅者。当用金刚戏掷印

若欲破诸邪印者。当作忿怒势

若欲召集一切拏吉儞者。当用金刚朅桩誐印若欲破母鬼及曼拏罗诸邪三昧咒法者。

当用金刚忿怒明王足下之尘

若欲使诸鬼神作仆从者。当于神祠中现大忿怒相持诵

若欲降诸魔军者。当作金刚大忿怒相复现大笑相

若欲破他军者。当加持金刚杵掷之

若欲入军阵求胜者。当用金刚计睹印

若欲作禁缚者。当用加持衣服系之若要解除当称其名

若欲破吠多拏鬼城者。当用金刚畔惹[寧*也]印

若欲解诸枷锁者。当用金刚卜羯娑印

若欲出生火者。当加持金刚日精宝

若欲枯涸处令出水者。当加持金刚月精宝

若欲求种种饮食衣服等者。当观视虚空持诵一洛叉数

若欲见诸佛如来遍虚空者。当须忆念诸佛一心持诵

若欲空中现文字相见三世事者。当书阿字持诵一洛叉。即见三世之事。眼得见已。意法所知亦复如是若持一洛叉加持于眼。即能观于三世色像。若加持于耳。即闻三世之声。若加持于鼻。即能分别三世之香。若加持于舌。即善说三世之事。若加持于意。即能了别真实妙理

若欲成就诸佛像及见希有事者。当加持一洛叉数

若欲见幻化事者。当用孔雀拂

若欲求一切受用之具者。当往大自在天祠中持诵一洛叉数

若欲见诸圣迹处者。当用降三界之印

若欲成就一切法者。当用金刚智印

若欲见五通仙者。当用金刚定印

若欲自身成就佛菩萨果位。及四威仪中现种种事者。当用金刚戏通印

若欲觉悟诸天者。当用金刚力印

若欲降诸龙者。当往龙潭中持诵

若欲令诸夜叉无仆从者。当用金刚旨印

若欲令诸部多调伏者。当以足蹋大自在天像。现大忿怒势持诵心明

若欲止雷雹者。当用金刚他嚩拏印

若欲息除灾火者。当用颦眉菩萨印

若欲降雨者。当往龙潭中持诵

若欲止雨者。当用萎花于水中作护摩

若欲起风云者。当画龙形以香薰之

若欲求晴者。当用金刚虚空佛眼印

若欲令枯涸处出泉水者。当用究竟金刚龙印

若欲出现伏藏者。当用金刚朅[寧*吉]多印

若欲求诸伏藏者。当用金刚义印

若欲成就一切曼拏罗者。当用金刚轮印

若欲成就诸印法者。当用大乐金刚三昧印

若欲成就诸三昧法者当用妙乐金刚印

若欲成就诸持明天者当用金刚印

若欲成就金刚部菩萨者。当用最上根本金刚印

若欲成就诸菩萨者。当用金刚心印

若欲成就金刚菩萨者。当用金刚大印

若欲求成就诸佛者。当用金刚智拳印

如上诸法皆须以心明加持

    一切如来真实理金刚三昧仪轨分第二

尔时大毗卢遮那佛。复自说此般若波罗蜜多教诸佛菩提法门。所谓金刚平等菩提故。是即菩提。金刚坚固义平等菩提故。是即菩提。第一义平等菩提故。是即菩提。自性清净诸法平等菩提故。是即菩提。诸法无分别亦复如是。此四法门若人听闻受持读诵。所有诸障皆悉销灭。乃至道场证得阿耨多罗三藐三菩提。是时世尊大毗卢遮那佛。说此真理法门已。复作智拳现大笑容。说诸法平等心明曰

阿(引)

说此心明中间。所有诸佛如来悉皆云集。围绕大毗卢遮那佛。依金刚萨埵曼拏罗位。次第而坐。复有八大菩萨。在外曼拏罗八方而坐现大笑容

尔时大毗卢遮那佛。入一切如来曼拏罗安想三摩地。从定出已。即说诸佛如来金刚真实理大曼拏罗法。依前金刚萨埵曼拏罗仪。当作外曼拏罗。于此曼拏罗内。画金刚轮。于其轮内画众色莲。于彼莲上安佛世尊。于世尊周围复安八佛。各坐日轮持金刚杵。又复外曼拏罗四方四隅。依法安置八大菩萨。于其四门各安阏伽瓶。其瓶须依法选择满盛香水。以妙花果插于瓶内。及以五宝五谷五药等安于瓶中。以上色缯帛盖覆瓶上。然后结诸佛金刚印。献于诸佛已。方以其瓶置于四门。时阿阇梨依法观想。己身同诸佛之身。自谓我成金刚阿阇梨。从是已后于诸佛教中。得一切成就销除诸障。然后令其弟子入曼拏罗。依法以金刚杵灌顶五处。是名金刚灌顶。即说此三昧誓颂曰

  汝受灌顶已　　当普为众生
  增长诸佛法　　住于平等心

然后随其根性与四种幖帜。当依法而作如是。说此三昧曼拏罗已。复说成就[巾*((ㄇ@人)/登)]像法。于其[巾*((ㄇ@人)/登)]内画大毗卢遮那佛。光明照曜二手结诸佛智拳印。余佛菩萨皆依前曼拏罗仪画。然后于此[巾*((ㄇ@人)/登)]前。随意作成就法。悉得最上成就

又说[巾*((ㄇ@人)/登)]像法。于其[巾*((ㄇ@人)/登)]内唯画大毗卢遮那佛。于此[巾*((ㄇ@人)/登)]前随意持诵。然后以二手结智拳印尽夜持诵即得般若波罗蜜多成就。证菩萨位转生。即成正等正觉。如上皆为已成就曼拏罗者作如是说。若为未成就曼拏罗者。今复说之

若欲求受佛供养者。当施一切乐

若欲如菩萨受供养者。当以妙华供养三宝。并须持诵心明

若欲求一切众生作供养者。当以慈心持诵

若欲摄一切法者。当持诵般若波罗蜜多四句之偈

若欲降魔者。当以坚固定心持诵

若欲求诸佛灌顶者。当舍己身庄严之具

若欲具足诸法者。当用金刚莲观视印

若欲求诸佛羯磨成就法者。当用诸金刚羯磨印

若欲求成就诸佛者。当用金刚智拳大印

如上诸法皆须持诵心明

佛说最上根本大乐金刚不空三昧大教王经卷第一佛说最上根本大乐金刚不空三昧大教王经卷第二

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    降伏三界金刚三昧大仪轨分第三

尔时释迦牟尼佛。说一切法平等最胜摄般若波罗蜜多法门。谓贪无性故。嗔亦无性。嗔无性故。痴亦无性。痴无性故。诸法亦无性。诸法无性故。般若波罗蜜多亦无性。若人于如是般若波罗蜜多法门。听闻受持读诵记念者。是人设造杀害三界一切众生。所有之业亦不复受。不堕诸恶趣。速证阿耨多罗三藐三菩提

尔时金刚手菩萨。闻佛说此真实理法门已。即现颦眉利牙喜怒之相。于莲花上立。如张弩势。结降三界印而说心明曰

吽(引)

说此心明时。三界诸天主及三界主乃至大自在天。悉皆钩召入于曼拏罗中。以调伏法皆令调伏。与作安慰令住三昧复现大忿怒相。于是大自在天及三界天主并诸眷属。见金刚手菩萨作大忿怒相降伏三界。皆悉惊怖发声告言。金刚手菩萨救护我等。我等归依于佛受佛圣旨安住三昧。所有诸摩怛哩等。见菩萨现忿怒相。皆大惊怖苦恼迷闷。彼邪明邪印咸皆破坏。乃至宿曜执持及诸病苦。一切毒药皆令销除。是时诸摩怛哩等。亦发声告言。金刚手菩萨救护我等。从今已后归依于佛愿赐加被

尔时金刚手菩萨现微笑相。引诸天等入曼拏罗令住三昧。以宝部法授与灌顶。复以金刚部法授其灌顶。令尽众生界作大饶益事。安外金刚部中。是时金刚手菩萨。化一明王作忿怒降三界相。具种种庄严作大威猛。利牙咬唇须发赤竖。执金刚杵钩剑刀杖刍哩迦等。是大明王依金刚手曼拏罗仪法而住。彼诸天等安置于外曼拏罗。此曼拏罗外安诸宿曜

尔时金刚手菩萨。即入一切如来大悲方便金刚三摩地。从定出已。说此降三界最胜安想金刚大曼拏罗仪法颂曰

  我今略说此　　最胜曼拏罗
  名降伏三界　　能调难调者
  依前说法仪　　画外曼拏罗
  而于内轮中　　分列八尊位
  中安忿怒尊　　身如青莲色
  具种种庄严　　颦眉出利牙
  作忿怒微笑　　立如张弩势
  是降三界相　　而于两足下
  左蹋自在天　　右蹋于天后
  炽盛光普照　　内画八辐轮
  光明普照耀　　依前外坛仪
  画外曼拏罗　　四门各安置
  大忿怒之相　　弓箭与剑轮
  是为四幖帜　　于外曼拏罗
  安诸曜幖帜　　种种上味食
  满钵为出生　　安置青色铃
  并众色幢旛　　是时阿阇梨
  当着青色衣　　而现忿怒相
  即结三昧印　　入于曼拏罗
  阿阇梨当须　　依法作佛事
  从是日已后　　诸天不能见
  能成坏一切　　得其诸最胜
  所有成就法　　皆令得成就
  是时引弟子　　入于曼拏罗
  当结金刚印　　授金刚灌顶
  即授金刚杵　　而施与誓愿
  此金刚手杵　　能调难调者
  汝当常受持　　成就最上法
  施其誓愿已　　出于曼拏罗

说是颂已复说拏像法。当依金刚曼拏罗仪。画金刚忿怒尊。及画大菩萨诸天与摩怛哩众等。是为最上成就[巾*((ㄇ@人)/登)]像法。然后于[巾*((ㄇ@人)/登)]前依法供养。敷座而坐结根本印持诵百千遍。如是持诵所有世间出世间一切之法皆悉成就。设复于法未得精熟。但常持诵者是人能作敬爱钩召入寤禁缚解除等种种之法。复说诸成就法若欲破坏诸恶者。当依金刚忿怒明王法。若欲破诸邪印者。当现忿怒顾视而持诵之

若欲灭坏诸魔者。当持金刚杵现大忿怒相持诵

若欲作禁制者。当现忿怒相持诵。复以金刚杵打其方位

若欲作诸离散者。当依微妙金刚尾提[寧*也]尊法

若欲钩召诸恶宿曜者。当现忿怒调伏相旋转金刚杵

若欲令他憎恚者。当以铁末作护摩法

若欲发遣诸药刹者。当依大笑尊法持诵

若欲降诸龙者。当以金刚杵打于地面持诵

若欲调伏诸天者。当依金刚儞波多尊法持诵

若欲钩召诸天及降伏破坏者。当依降三界尊法持诵

若欲求毗沙门天王成就法者。当以手按毗沙门天像。而作忿怒相持诵

若欲求增长天王成就法者。当依金刚补噜沙法持诵

若欲成就欲天者。当于欲天像前作忿怒相持诵

若欲成就大梵天者。当用妙乐金刚印

若欲成就那罗延天者。当用金刚轮锁印

若欲成就大自在天者。当用金刚戍罗锁印

若欲成就诸魔怛哩众者。当依金刚众啰刹法

若欲破坏诸外道邪坛咒法等者。当依金刚大忿怒畔惹那尊法

若欲摧折一切山林乃至天祠者。当现忿怒明王而顾视之。若欲令复如故者。当依金刚忿怒明王法

若欲坏灭诸魔者。当依金刚忿怒明王拳法若欲令生诸怖畏者。当依金刚忿怒明王法现大恶相

若欲坏灭他军者。当依金刚忿怒药刹法

若欲破散他军者。当依金刚忿怒啰刹法

若欲破坏诸天者。当用钉诸天像。若成就天主者亦依此法

若欲令三界惊怖者。当用金刚钵啰罗印

若欲三界中胜者。当依金刚忿怒明王法

若欲令三界作入寤禁缚敬爱者。当用金刚忿怒明王印

若欲令三界作钩召敬爱成就者。当依大乐金刚忿怒明王法

    清净诸烦恼三昧大仪轨分第四

尔时世尊释迦牟尼佛。复说一切法平等观自在智印般若波罗蜜多法门。谓烦恼清净故。诸垢亦清净。一切垢清净故。一切罪亦清净。诸法清净故。一切众生亦清净。一切智清净故。般若波罗蜜多亦清净。若人于此清净法门。受持读诵记念思惟。是人虽常处贪欲法中。离诸烦恼譬如清净莲花不染诸垢。当速得证阿耨多罗三藐三菩提

尔时观自在菩萨。闻释迦牟尼佛说此真实理清净法门已。即现微笑。说此观照诸法无染一切清净法门众色莲花心明曰

纥哩(二合引)

说此心明时出现一切如来。皆如观自在相手持莲花。咸依观自在菩萨本曼拏罗仪安住。是时观自在菩萨。即入观照诸法智自在印三摩地。从定出已。说此调伏一切世间曼拏罗法。若人作此大曼拏罗成就法者。当于外曼拏罗中画内曼拏罗。四方四隅列八尊位。依法具足。于其中间画红色莲花。其花八叶。于其花上画观自在菩萨。于菩萨前画大莲色天。如天魔相其色红赤。手持莲花俱稣摩花并持弓箭。右侧画大莲忿怒自在天。色相如大自在天。于其后面画大莲黑天。如那罗延天色相。于左侧画大莲娑婆主。如梵天王色相。东南隅画大莲持世天。如持世天色相。西南隅画大莲水天。如大海龙王色相。西北隅画大莲日天。如大日天色相。东北隅画大莲风天。如风天色相。又复外曼拏罗四隅。画四天像谓。纥哩(二合)室哩(二合)儗(引)提(引)如是诸天。皆以左手持莲花。右手持本幖帜。于其四门各安幖帜。一者悉帝哩尾屹啰贺。二者萨哩嚩尾屹啰贺。三者稣葛啰尾屹啰贺。四者钵讷摩尾屹啰贺。如是画曼拏罗已。阿阇梨当令弟子着白衣。以净帛覆面。即持妙花而结莲花印。引入于曼拏罗中。令其弟子当至心郑重以花散掷。花所堕处即是本尊。得本尊已。依莲花部灌顶之法当作灌顶。然后诫其弟子曰。汝观诸法当如莲花。诸染烦恼清净如此。即说伽陀曰

  譬如妙色莲　　处泥常清净
  贪嗔痴本性　　无染亦如是
  所有一切法　　应如是观察
  诸法本清净　　当灭诸烦恼
  常在诸三昧　　成佛一切智
  证如是法已　　是名观自在

说是伽陀已又复告言。从是已后汝身清净。所求成就皆随意愿乃至成佛。如是弟子欲成就智曼拏罗者。亦依[巾*((ㄇ@人)/登)]像法皆得成就

复说未精熟求成就法者。若欲令悦乐一切人者。当加持莲花八千遍

若欲灭散诸恶者。当用大忿怒王莲花印

若欲令魔魅迷乱者。当用大莲花嚩啰贺印

若欲净诸烦恼者。当用大莲花观想印

若欲降雨者。当画龙形。行人坐其龙上持诵一洛叉数

若欲去除冥暗者。当用大莲花日光印

若欲起风及止息者。当用莲花摩噜多印

    一切宝灌顶大三昧仪轨分第五

尔时世尊释迦牟尼佛。复说一切如来灌顶出生智藏般若波罗蜜多教。若施灌顶者。获证三界法王位。若施珍财者。获满一切愿。若施妙法者。得诸法平等。若施饮膳者。得一切身口意快乐

尔时虚空藏菩萨。闻佛说此真理法门已。现大笑容。于自顶上结宝金刚灌顶鬘印。结是印已。说此一切灌顶三昧宝心明曰

怛囕(二合引)

说此心明时。出现一切灌顶义句等相。如是出已。依宝部曼拏罗仪。现于菩萨像各处本位

尔时虚空藏菩萨。入一切灌顶宝金刚三摩地。从定出已。说圆满一切愿大摩尼宝三昧大曼拏罗。若人成就此曼拏罗者。当依外曼拏罗法画内曼拏罗。于其中间画八角宝柱。如八曼拏罗相。宝鬘为严饰宝金刚作围。置种种庄严幢幡伞盖等。然后于曼拏罗中画虚空藏菩萨。乘车驾马现大笑容。身深红色二手结灌顶印。于菩萨前安诸如来及宝灌顶菩萨。顶戴宝冠。右侧安持诸宝藏菩萨。于后面复安持法宝藏菩萨。左侧安持诸饮膳菩萨。于其四隅安供养菩萨。宝盖幢幡种种妙乐等。于外曼拏罗四门四隅。依法安置阏伽瓶及灌顶幖帜供养等。如是画曼拏罗已。阿阇梨当结宝印。依法引弟子入曼拏罗。以宝灌顶法。授与灌顶及印相幖帜等。从是已后所求成就皆得圆满。如上所说引弟子入曼拏罗法仪。其宝金刚部中所作成就法亦应如是若未精熟法欲受诸灌顶者。当授宝金刚灌顶印

若欲圆满意愿者。当于日出时持诵

若欲了诸法义智者。当观诸法清净皆如虚空而持诵之

若欲求种种上味者。当想本身如虚空日诵千遍

若欲圆满大愿者。当执宝盖持诵百千遍

若欲求最胜者。当用宝幢金刚印

若欲求大名称者。日常持诵

    一切拳印三昧大仪轨分第六

尔时释迦牟尼佛。得诸佛智印持诸佛智拳。是诸佛究竟者。复说一切如来智印安想金刚般若波罗蜜多教。谓摄一切如来身印故。即是一切如来身。摄一切如来语印故。即得一切法自在。摄一切如来心印故。即得一切三摩地。摄一切如来金刚印故。即得金刚三业最上成就

若人于此法门。听闻受持记念思惟。及为他宣说者。是人得成就一切法。通达一切智。圆满一切事。乃至金刚三业得最上成就。速证阿耨多罗三藐三菩提

尔时金刚拳菩萨。闻佛说此摄大三昧金刚印真实法已。即现欢喜相。即说一切坚固金刚印成就三昧心明曰

恶

说此心明时。一切如来及诸众会。化如金刚萨埵。皆结金刚萨埵印。以诸佛如来最上成就印印之。依金刚拳菩萨金刚三业及大印三昧等。依此曼拏罗安住。尔时金刚拳菩萨。入一切如来智印三摩地。从定出已。说此一切印金刚三昧大曼拏罗法。若人建此曼拏罗者。依前曼拏罗仪法。画外曼拏罗。于此中间画八辐轮。于其轮中分列八位。于中位安金刚拳菩萨。现欢喜相结三昧拳印。于此菩萨前。安最上金刚身菩萨。手持金刚杵。于金刚拳菩萨右。安金刚舌菩萨。于金刚拳菩萨后面。安金刚定菩萨。手持金刚杵。于金刚拳菩萨左。安最上金刚菩萨。持金刚杵。复于曼拏罗东南隅。安印拳菩萨。西南隅安义拳菩萨。西北隅安智拳菩萨。东北隅安羯磨拳菩萨。如是菩萨皆结本印及持自幖帜。复于四门安金刚香等四菩萨。如是画曼拏罗已。设复有人未成就此法者。入此中已得具一切印成就阿阇梨。从是已后决定得一切法成就。速证阿耨多罗三藐三菩提。若阿阇梨当传授弟子者。即结金刚拳印。引弟子入曼拏罗中。以金刚灌顶法当授灌顶。授灌顶已。为说伽陀曰

  金刚身口意　　当观如影像
  诸印亦如是　　此名三昧誓

如上所说弟子入曼拏罗仪。所有此部印相及成就曼拏罗法。皆亦如是。复为未精熟者说成就法。若欲成就诸印相者。当结金刚拳安心持诵

又复欲成一切印者。当结大金刚拳印

若欲得一切众生爱敬者。当结金刚大乐拳印

若欲降诸众生者。当结金刚大拳印

若欲成就一切三昧者。当结金刚吒枳印

若欲禁缚诸恶者。当结金刚缚印

若欲禁缚一切者当结金刚索印

若欲令昝婆那者。当结金刚隶波拳印

若欲令卑拏那者。当结金刚缚拳印

若欲灭坏诸恶者。当结金刚忿怒拳印

若欲跋叉那者。当结金刚药刹拳印

若欲破坏诸魔者。当结金刚[寧*吉]卑拏那拳印

若欲开通一切者。当用金刚锁拳印

若欲令一切入寤者。当结金刚阿吠舍拳印

若欲令作[寧*吉]哩爹者。当结金刚[寧*吉]哩爹拳印

若欲令一切语言者。当结金刚语拳印

若欲禁伏一切者。当结金刚定拳印

若欲令他军母枳羯啰那者。当结大金刚语拳印

若欲解诸邪印者。当结金刚解脱拳印

若欲解诸拏吉儞印者。当结降三界金刚拳印

若欲破诸恶印者。亦结降三界金刚拳印

若欲禁制诸印者。当结金刚散提拳印

若欲令一切印坚固如金刚者。当结金刚拳印

若欲令印一切者。当结金刚摩怛哩拳印

若欲摧破诸魔者。当结妙金刚拳印

若欲破诸恶者。当结大恶忿怒金刚拳印

若欲入水行住者。当结金刚禁拳印

若欲现种种色像者。当结众羯磨金刚拳印

若欲求隐身法者。当结不可见金刚拳印

若欲成一切行住所作事者。当结虚空金刚拳印

若欲腾空自在者。当结金刚缚拳印

若欲成就持明天者。当结金刚剑拳印

若欲成就诸如来供养者。当结金刚羯磨拳印

若欲通达一切智者。当结金刚智拳印

若欲成一切义者。当结金刚义拳印

若欲求成一切印主者。当结金刚拳印

若欲成就一切事者。当结诸金刚拳印

若欲成就一切曼拏罗者。当结金刚手拳印

若欲令说三世事者。当结金刚舌拳印

若欲成就金刚手者。当结金刚高举印

若欲求成就佛者。当结诸佛金刚拳印

    金刚字轮三昧大仪轨分第七

尔时释迦牟尼佛。复说诸法无性转字轮般若波罗蜜多教。所谓诸法空无自性故。诸法无相。以无相故生一切法。诸法无愿故。从无愿生一切法。诸法自性清净故。般若波罗蜜多清净

尔时妙吉祥菩萨。闻佛说此真理法门已。即现笑容。以智慧剑表示诸佛。说此最上般若波罗蜜多心明曰

阿

说此心明时。一切如来皆悉云集。依前曼拏罗仪安住。尔时妙吉祥菩萨。入一切法自性无性剑三摩地。从定出已。说转字轮三昧曼拏罗法。若建此曼拏罗者。当于外曼拏罗中。依法画八辐轮。于此轮围中。次第书心明。后四方四隅分列八位。于其中位安妙吉祥菩萨。如童子相。身色莹净犹如虚空。有其四臂。以智慧剑作表示法。光明普照。于菩萨外安诸佛如来。四隅依法安四般若波罗蜜多经。四门安四幖帜。谓剑烁吉帝宝钵经。然后阿阇梨结剑印或经印。依法引弟子入曼拏罗中。授与智剑而作灌顶。作灌顶已。为说法誓颂曰

  汝当受智剑　　等般若真理
  观佛如虚空　　所表示速成
  护持于佛法　　广度诸众生
  以剑断业障　　令永尽无余

说此颂已又复告言。由是妙法令汝成就般若波罗蜜多。速证阿耨多罗三藐三菩提若欲成就法曼拏罗者。亦如前仪

复说成就法。若欲证空三摩地者。当观诸法如虚空故

若欲证无相三摩地者。当观诸法皆无相故

若欲证无愿三摩地者。当观诸法皆无愿故

若欲证自性清净智法者。当观想般若波罗蜜多理趣故

若欲断一切烦恼者。当观想正法故

若欲得一切文字真实智者。当观想无性法故

若欲于一切处不著文字观法身者。当依摩字等自性。观想于空故

若欲证诸佛菩提者。当结金刚剑印

    一切曼拏罗金刚轮三昧大仪轨分第八

尔时释迦牟尼佛。复说摄一切如来轮入大轮中般若波罗蜜多教。所谓入金刚平等故。是即入一切如来轮。入义平等故。是即入大菩萨轮。入法平等故。是即入妙法轮。入一切平等故。是即入一切轮

尔时同心生转法轮菩萨摩诃萨。闻佛说此真理法门已。即现笑容。而说转金刚轮入一切金刚三昧心明曰

吽(引)

说此心明时。所有一切如来。及三界一切有情。皆悉云集曼拏罗中。复从菩萨心。出生一切曼拏罗三昧。是时诸佛菩萨依法安住

尔时同心生转法轮菩萨。入一切轮印三摩地。从定出已。说此入一切三昧轮大曼拏罗法。建是曼拏罗者。当于外曼拏罗中画金刚轮。于其轮中画同心生转法轮菩萨。所有诸佛如来及金刚手等菩萨众。亦依前曼拏罗仪画。其曼拏罗四隅。画金刚部四大菩萨。谓金刚萨埵菩萨。金刚忿怒明王菩萨。观自在菩萨。虚空藏菩萨。于四门画四幖帜。如是画曼拏罗已。然后阿阇梨依法结金刚轮印。引弟子入曼拏罗。授以金刚轮令受灌顶。传与四种曼拏罗及本部所有三昧等法。弟子仪法既尔。金刚轮曼拏罗所作成就亦应如是

复说成就法。欲入一切曼拏罗者。当结金刚轮印安于面门

若欲入大曼拏罗者。当结大轮印

若欲入诸印曼拏罗者。当结一切如来金刚印

若欲入三昧曼拏罗者。当结大三昧轮印

若欲入羯磨曼拏罗者。当结诸金刚轮印

又复作敬爱法降伏法印法破坏法入一切处法供养法调伏诸恶法等。皆结八大菩萨印。或结轮印

    众金刚三昧大仪轨分第九

尔时释迦牟尼佛。复说最上供养般若波罗蜜多教。所谓发生菩提心故。是即一切如来广大供养。救度一切众生界故。是即一切如来广大供养。摄一切法故。是即一切如来广大供养。若人于般若波罗蜜多教。书持读诵记念思惟者。是即一切如来广大供养

尔时誐誐那巘惹菩萨。闻佛说此真实法门已。即现微笑。说此一切羯磨不空三昧心明曰

唵(引)

说此心明时。所有一切供养遍满虚空界。复从空中化菩萨相。还于誐誐那巘惹菩萨前。依曼拏罗而住

尔时誐誐那巘惹菩萨。入一切供养安想三摩地。从定出已。即说最上羯磨金刚不空三昧曼拏罗。作是法者。当于外曼拏罗中间画八角宝柱。于此中间画誐誐那巘惹菩萨。身如月色现微笑容手持器仗

又复依法画诸菩萨。谓金刚手菩萨观自在菩萨等八大菩萨。各具本相印法具足。复于四隅画四供养菩萨。四门画四幖帜及种种宝具。如是画已。阿阇梨当结羯磨金刚印。依法引弟子入曼拏罗中。以众羯磨金刚灌顶法。当授灌顶。授灌顶已作四种供养。一者身业礼拜。二者语业称赞真实妙理。三者意业观想法界之内皆成供养。四者手结金刚印。是名弟子入羯磨曼拏罗仪轨

复说成就法。若欲以菩提心供养者。当观想心金刚故

若欲以三摩地供养者。当观想诸法清净故

若欲以灌顶供养者。当观想众羯磨金刚故

若欲以印供养者。当观想众金刚故

若欲以虚空供养者。当以阿字观想故

若欲供养一切曼拏罗者。当以众金刚轮观想故

若欲以一切具供养者。当以众金刚观想故

若欲调伏诸恶成供养者。当现忿怒相加持。以花掷之

    金刚忿怒三昧大仪轨分第十

尔时释迦牟尼佛能调难调者。作大智拳印。复说调伏一切有情藏般若波罗蜜多教。所谓一切有情平等故。是即忿怒平等。一切有情调伏故。是即忿怒调伏。一切有情依法故。是即忿怒依法。一切有情自性坚固故。是即忿怒自性坚固。所以者何。如是一切调伏是即菩提故

尔时降诸魔金刚药刹菩萨。闻佛说此调伏法门已。即现笑容。复现金刚药刹相。结金刚利牙印。即说金刚忿怒大欢喜心明曰

郝

说此心明时。所有诸恶皆悉调伏。一切有情从菩萨心出。依曼拏罗仪住

尔时金刚药刹菩萨。入一切方便调伏忿怒金刚三摩地。从定出已。说此调伏诸恶安想金刚药刹曼拏罗法。若成就此法者。当依前外曼拏罗仪画曼拏罗。于其中间。以五色画四方曼拏罗。四门四隅画八宝柱。光炎炽盛。于曼拏罗中。依法画金刚药刹菩萨。身大青色作大怖畏复大笑相。利牙外出光明照耀。于菩萨周匝。画金刚药刹众。亦现大恶相。及画金刚部众幖帜。复于外曼拏罗隅。画金刚利牙印。于其四门各画金刚幖帜。如是画已。阿阇梨结金刚利牙印或大笑印。依法引弟子入曼拏罗。当以金刚利牙灌顶法授其灌顶授灌顶已。阿阇梨即作金刚药刹势。以金刚杵打之。即时金刚药刹画像作大笑声。若见此瑞相时。阿阇梨定知得成金刚手菩萨大药刹主。阿阇梨即作成就法。依法结印持诵。献种种供养。及读诵般若波罗蜜多教。如是依法作供养已。出于曼拏罗

复说成就法。如金刚手菩萨曼拏罗仪。所作成就法亦应如是

若欲调伏诸恶者。当结金刚利牙印

若欲调伏一切有情者。当作忿怒势现大笑声持诵心明

若欲印于一切者。当结金刚拳印

若欲破坏诸恶者当作彼形加持已即能破坏

若欲破诸邪坛者。当手持金刚杵入其坛中

若欲坏彼供养者。当现忿怒势持诵

若欲惊怖诸恶者。当以陪啰嚩目顾视之

佛说最上根本大乐金刚不空三昧大教王经卷第二佛说最上根本大乐金刚不空三昧大教王经卷第三

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    一切乐三昧大仪轨分第十一

尔时释迦牟尼佛。复说一切法最上般若波罗蜜多教。所谓一切行平等故。是即般若波罗蜜多行平等。一切义平等故。是即般若波罗蜜多义平等。一切法平等故。是即般若波罗蜜多法平等。成就一切事业故。是即般若波罗蜜多事业成就

尔时金刚手菩萨。闻佛说此真实法门已。即入一切佛菩萨不空曼拏罗安想三摩地。从定出已。说此一切不空三昧心明曰

吽(引)

说此心明时。所有一切如来诸曼拏罗法。从心而出依于大三昧真实理大曼拏罗住。是时金刚手菩萨。头面礼世尊足。复说大三昧曼拏罗法仪

若欲成就此法者。当画大曼拏罗内分列八位。安降三界尊等诸菩萨。如是画已。然后依法献诸供养。此名三昧曼拏罗法

金刚手菩萨。又复宣说一切三昧金刚安想大曼拏罗仪法。当画外曼拏罗已。于此中间画金刚轮。分列八位依法安诸尊像。复于外曼拏罗四隅。依法安金刚部诸菩萨。四门各安本部幖帜。如是画已。然后依大三昧法。献种种供养

    外金刚部仪轨分第十二

尔时释迦牟尼佛。复说安乐一切有情般若波罗蜜多教。所谓一切有情如来藏故。是即普贤菩萨。一切有情金刚藏故。是即金刚藏灌顶。一切有情法藏故。是即转一切语轮。一切有情事业藏故。是即成一切事

尔时外金刚部众。闻佛说此真理法门已。俱发大声。即说此金刚大自在心明曰

讷哩(二合引)

说此心明已。复说曼拏罗法仪。当依本法画大曼拏罗。四方四门。四隅分量圆满。于其中间依法画大自在天。外四方四隅画八会主。谓东方摩贺哥罗。南方难祢计说啰。西方摩贺健吒。北方乃哩爹说啰。东南隅噜捺啰葛波罗。西南隅赞尼说啰。西北隅朅桩誐播尼。东北隅仵割啰拏。复于东门画难提说啰。南门画扪尼说啰。西门画健吒葛啰拏。北门画摩贺劳捺啰。于此外画诸部多众。如是画曼拏罗已。阿阇梨当灌沐着新净衣。入曼拏罗献种种供养。手持三叉持诵心明。然后依法引弟子入曼拏罗。授与三叉为说三昧法颂曰

  汝持此幖帜　　当利益众生
  诸欲中自在　　所作皆成就

说是颂已。阿阇梨即以智印及出生供养等法。授其弟子。从是已后弟子当离诸怖畏。获本部中一切成就。得大富贵获诸适悦安隐快乐。是时外金刚部众。说此摩呬说啰天三叉曼拏罗已。复有诸摩怛哩众。各以头面礼释迦牟尼佛足。异口同音。即说钩召一切成就三昧心明曰

毗踰(二合引)

说此心明已。复说曼拏罗法。当画四方曼拏罗。四门四隅依法列诸分位。于其中间画摩贺哥罗主。如作舞势。于其像外四方四隅。画八摩怛哩。所谓东方劳捺哩手持三叉。南方没啰吽弥手持数珠。西方吠瑟弩尾手持轮。北方憍摩哩手持铃。东南隅哥哩手持刀。西南隅摩贺哥里手持刍哩。西北隅薄叉尼手持能瑟吒啰。东北隅啰刹细手持朅桩誐。复于外曼拏罗四隅。画四噜捺啰拏吉儞。所谓东南隅室嚩。西南隅毗噜尼。西北隅赞尼。东北隅跋焬葛哩。复于四门画四幖帜。谓东门钵讷摩婆惹那。南门遏悉帝商羯罗。西门屹哩特啰。北门尾啰攞。如是画曼拏罗已。阿阇梨当沐浴香洁着新净衣。入曼拏罗依法献诸供养。即结室嚩讷帝印。持诵心明。时若闻毗踰(二合)字大声。即是诸贤圣皆已云集。阿阇梨即解前印。复结摩贺哥罗三昧印。即令弟子手持妙花净帛覆面。当引入曼拏罗中阿阇梨近弟子前。高呼毗踰(二合)字之声。是时弟子即生警悟。遂将花散掷。花所堕处即是本尊。得本尊已除其覆面之帛。令遍观视于曼拏罗。即献香花而伸供养。阿阇梨然后传授。与本尊心明印相幖帜等法。复为说三昧誓曰

  当审诸众生　　勿妄传心明
  精进者成就　　坏法者除灭
  违是三昧者　　须臾即破毁

说此颂已。然后依法以饮食伎乐等而献供养。如是法事毕已当出曼拏罗。是时诸摩怛哩众。说此一切成就诸印曼拏罗已。复有摩度迦啰众。即于佛前头面礼世尊足。异口同声说自心明曰

莎

说此心明已。复说曼拏罗法。当画外曼拏罗。四方四门。于其中间复画半月相曼拏罗。于此曼拏罗内。画摩度迦啰三尊之像。各现喜怒相。身被甲胄手持器仗。复以种种庄严处师子座光明炽盛。于其四门画四会主。一悉驮没哩提。二摩贺刹怛啰。三赞拏噜沙屹啰。四摩啰拏。于四门外依法安置铃幢幡阏伽瓶等。复置饮食香花伎乐种种供养。如是安布已。阿阇梨入于曼拏罗中。依法献诸供养礼拜。复以梵音而伸赞曰

底哩(二合)路哥悉底哩(三合)婆嚩悉底哩野(四合)屹哩野(三合一句)悉底哩野(四合)播(引)野悉底哩野(四合引)摩呬悉底哩(三合)驮(引二句)仵必都婆誐鑁悉[亭*也](三句)萨哩嚩(二合)悉提数[寧*吉]爹舍(四句)

阿阇梨作是赞已。依法引弟子入曼拏罗中。授与三昧印法等。即为说誓颂曰

  越此三昧者　　如杀父母罪
  当堕恶趣中　　无由得解脱
  常近善知识　　远离诸恶者
  精进求成就　　勿妄传心明

说此颂已。弟子以饮食香花伎乐等而献供养。作供养毕。从是已后所作成就。是时摩度迦啰众。说此曼拏罗法已复有四贤圣。异口同声说自心明曰

萨鑁(二合引)

说此心明已。复说曼拏罗成就法。当画曼拏罗。圆满如月轮。分其四门列于四位。画彼四贤圣。东位啰帝其身红色手持弓箭。南位摩啰尼其身黑色手持利剑及契吒哥。西位嚩啰呬其身金色手持宝藏。北位悉提迦尸其身白色手持拶沙迦及刀。于其四门各画幖帜。如是画已。阿阇梨右手执铃左手持朅桩誐。入于曼拏罗持诵心明。当献饮食香花伎乐等种种供养。即得所求成就获如意事。受诸供养感大富贵。乃至所作敬爱成法之种。及取伏藏等皆悉获得。其弟子入曼拏罗仪法亦应如是

    般若波罗蜜多教称赞分第十三

尔时释迦牟尼佛。复说无量无边不可尽如来真实之义诸法平等金刚般若波罗蜜多教。所谓般若波罗蜜多无量无边故。一切如来亦无量无边。般若波罗蜜多无量无边故。一切法自性坚固亦无量无边。般若波罗蜜多无二故。诸法亦无二。般若波罗蜜多究竟故。一切事业亦究竟。若人于此法门。听闻受持读诵记念者。是人所修诸佛菩萨行愿。未圆满者即得圆满。诸业障累灭尽无余。即证如来正等菩提。是时释迦牟尼佛说是法时一切如来皆悉云集。为欲显发此正法不空愿力作成就故。咸皆称赞金刚手菩萨而说颂曰

  善哉金刚手　　善哉大乐尊
  善哉大乘理　　善哉大智者
  常住金刚界　　能说此大教
  诸佛真实法　　善调诸有情
  最上大教王　　若能受持者
  诸天不能见　　诸魔所称赞
  获最上成就　　乃至佛菩萨
  如佛真实语　　不久咸成就

诸佛称赞已。金刚手菩萨即生大欢喜

    金刚手菩萨最上秘密大曼拏罗仪轨分第十四

尔时世尊大毗卢遮那佛。复说一切法无性大乐金刚不空三昧决定般若波罗蜜多教最上根本无性法门。所谓最上大乐成就故。是即诸菩萨最上大乐成就。诸菩萨最上大乐成就故。是即一切如来最上菩提成就。一切如来最上菩提成就故。是即诸菩萨摩诃萨降伏众魔最上成就。诸菩萨摩诃萨降魔成就故。是即三界主最上成就。三界主最上成就故。是即尽无尽众生界清净。如是众生界清净故。菩萨常处轮回发大精进。于无尽众生界作大救护。令得安乐最上成就。是时世尊大毗卢遮那佛复说颂曰

  菩萨无数劫　　处在轮回中
  皆为利众生　　令证寂静地
  智慧方便力　　发起真实智
  了诸法清净　　诸有亦清净
  贪欲使调伏　　所造业无性
  彼既清净故　　三有自调伏
  譬如妙色莲　　清净性无染
  智者亦如是　　妄想不能染
  贪欲清净故　　诸法亦清净
  诸佛真实智　　具圣财富乐
  为三界中主　　坚固利众生

尔时世尊说此颂已。复告金刚手菩萨言。若人闻此最上根本般若波罗蜜多正法已。常于清旦时能读诵受持思惟者。是人即获一切适悦快乐。见世得大乐金刚三昧最上成就。又复得一切如来金刚秘密最上成就。乃至诸大菩萨法皆得成就。亦复圆证此大乐金刚不空三昧根本一切如来般若波罗蜜多法门

尔时金刚手菩萨。闻佛说此真理法门已。即现笑容作大自在相。掷金刚杵如钩召势安于本心。即说此大秘密最上成就大乐金刚不空三昧等一切仪轨。及灭诸障法。降伏诸魔法。敬爱成就法。最上成就大秘密法如是无性最上根本大教王。是一切法中最胜无比大自在法。是时金刚手菩萨复说颂曰

  此大安乐天　　是圣曼拏罗
  安住若虚空　　金刚宝常照
  严净而无垢　　四方与四门
  具四祢踰贺　　尾提殊妙相
  诸天等恭敬　　微妙宝庄严
  具足半月相　　金刚普照耀
  悬种种宝铃　　珠缨与明镜
  光照无穷尽　　种种妙花鬘
  幢幡并伞盖　　大乐金刚等
  诸菩萨称赞　　是诸佛境界
  金刚众所居　　号摩尼胜宝
  于此宝宫中　　大乐而安住
  萨埵性清净　　是金刚大乐
  即是普贤身　　金刚手大主
  常住三摩地　　决定金刚性
  如是众方便　　勤行菩萨道
  为利众生故　　号金刚萨埵
  亦名降魔主　　亦名一切智
  是金刚赞拏　　亦名金刚手
  亦名如来部　　亦名金刚部
  莲花及宝部　　大乐羯磨部
  亦名诸解脱　　了三时无碍
  亦号三有尊　　亦为胜三世
  三界中最胜　　一切处为最
  具圣财坚固　　心所愿所行
  诸作皆如是　　从初大菩萨
  施根本大乐　　处妙莲花上
  跏趺坐三昧　　即现勇猛势
  戏掷金刚杵　　众贤圣围绕
  成就大乐故　　清净诸烦恼
  调伏有情界　　一切法圆满
  最上尊三昧　　诸佛所护持
  印法清净故　　成金刚萨埵
  行诸大方便　　大福所增长
  摄平等智印　　最上大心明
  是为大福聚　　阿阇梨所行
  亦复皆如是　　所作诸成就
  决定皆获得　　最上大乐法
  金刚大秘密　　坚固三昧法
  能成一切事　　一切义亦然
  无初无后故　　是名为根本
  如心之所欲　　随诸境界生
  皆受而不着　　归于胜义智
  即诸佛境界　　圆融法性故

尔时金刚手菩萨说是颂已。即说自心明曰

吽(引)

说此心明时。所有一切诸佛及诸菩萨摩诃萨诸明王等。于刹那时皆悉云集。遍满三界俱发声言。金刚手菩萨云何世间得成就法。是时金刚手菩萨即说明曰

嚩曰啰(二合)特哩(二合)俱(一句)

此即世间得自成就。善能成坏一切事业。说此明已又说颂曰

  离欲调世间　　未为清净法
  云何清净法　　谓大欲大乐
  是时诸如来　　及诸明王等
  闻菩萨语已　　俱发声告言
  汝善设方便　　菩提心为主
  是究竟清净　　真调伏之法
  菩萨无数劫　　常处轮回中
  为利益众生　　令证寂静地
  若起诸分别　　菩提是三有
  菩萨饶益故　　说金刚大乐
  尽法界边际　　是大曼拏罗
  初后而相应　　以金刚三昧
  依法作成就　　由是诸如来
  求成于大乐　　诸欲清净故
  劝请金刚手　　说大欲大乐
  此大心明王　　能成大妙乐
  于是金刚手　　复白诸如来
  我今说大乐　　金刚曼拏罗
  阿阇梨先须　　受三种三昧
  然结金刚印　　持金刚铃杵
  入其三摩地　　安想曼拏罗
  三种三昧印　　当用作成就
  一切成就中　　最胜成就法
  当振金刚铃　　警发诸贤圣
  设或于仪轨　　误有所违缺
  不生诸过咎　　皆悉得圆满
  作是曼拏罗　　依法得成就
  以香花伎乐　　随意而供养
  此最上根本　　遍无量无边
  无上无与等　　尽诸虚空界
  悉化微妙字　　前后际究竟
  诸佛所出生　　不增亦不减
  一切平等故　　无中亦无边
  离相如虚空　　离中边相已
  是为作成就　　建想曼拏罗
  尽法界为量　　法线作絣界
  内生众色莲　　四方与四门
  宝庄四楼阁　　具四祢踰贺
  尾提殊妙相　　四隅并四门
  四祢踰贺侧　　安置半月相
  及安种种宝　　四方表四智
  四门四念处　　楼阁四禅定
  尾提为定门　　金刚柱总持
  所有众宝饰　　表圆满诸愿
  羯磨杵表示　　诸佛之律仪
  宝铃幢幡盖　　为诸妙法藏
  明镜大圆智　　妙花七觉支
  珠璎及花鬘　　是成就心明
  如是表诸法　　大乐曼拏罗
  依法而建立　　最上解脱门
  根本无性法　　一切处平等
  复外曼拏罗　　内分八尊位
  表其八解脱　　发起菩提心
  转此最胜轮　　善施诸成就
  法线絣界道　　想画金刚轮
  众色莲花中　　安想金刚手
  或安本心明　　或置本标帜
  或安诸宝像　　雕镂或画像
  五色光晃耀　　如是安布已
  即时阿阇梨　　洁净庄严身
  入于曼拏罗　　而结跏趺坐
  手执金刚杵　　现大高猛势
  然以本心明　　安置金刚手
  而彼心明曰

唵(引)稣啰多萨怛鑁(三合一句)

  复以四菩萨　　围绕金刚手
  前大乐菩萨　　身遍深红色
  持金刚器仗　　金刚手之右
  枳哩枳罗尊　　二手结智印
  金刚手之后　　安念金刚尊
  手持摩竭幢　　金刚手之左
  安欲自在尊　　手作金刚拳
  如是四菩萨　　以心明安置
  而彼心明曰

[口*弱]嚩日啰(二合)嚩日啰(二合)涅哩(二合)瑟致(二合一句)娑(引)野计(引)末吒(二句)

吽(引)嚩日啰(二合)枳里枳里(引)吽(引一句)

鑁嚩日哩(二合)尼三摩(二合)啰啰吒(半音一句)呼(引)嚩日啰(二合)哥(引)弥说哩(引)怛囕(二合引一句)

  于四隅安置　　四供养菩萨
  妙乐与大乐　　佛眼及吉祥
  手持四供养　　谓香花灯涂
  如是四菩萨　　以心明安置
  而彼心明曰

呬(引)嚩日啰(二合)啰底(一句)

摩贺(引)啰多嚩日哩(二合)呼(引一句)

唵(引)嚩日啰(二合)路(引)左儞(一句)

摩贺(引)室哩(二合引)嚩日哩(二合)系(引一句)

  外四隅复安　　戏鬘及歌舞
  如是四菩萨　　以心明安置
  而彼心明曰

系(引)啰底(一句)嚩日啰(二合)尾逻(引)洗儞怛啰(二合)吒(半音)(二合)

系(引)啰底(一句)嚩日啰(二合)贺(引)细(引)郝郝(二句)

系(引)啰底(一句)嚩日啰(二合)儗(引)帝(引)帝(引)帝(引二句)

系(引)啰底(一句)嚩日啰(二合)儞哩(二合)帝(引)吠(引)波吠(引)波(二句)

  四门安四尊　　谓钩索锁铃
  如是四菩萨　　以心明安置
  而彼心明曰

嚩日朗(二合引)酤室[口*弱](一句)

嚩日啰(二合)播(引)尸(引)吽(引一句)

嚩日啰(二合)商葛梨(引)鑁(引一句)

嚩日啰(二合)健致(引)呼(引一句)

  如是最上尊　　依法而现前
  由是金刚众　　获大成就法

如是安布贤圣位已。然后阿阇梨入曼拏罗。依法以明召请金刚部诸贤圣众。召请明曰

[口*弱]吽(引)鑁(引)呼(引)钵啰(二合)嚩哩多(二合)炀(一句)

召请贤圣已。复以大明请召本尊。明曰

吽(引)摩贺(引)稣珂嚩日啰(二合)萨埵(引)野(引)呬(引)尸竭啰(二合一句)摩贺(引)稣珂嚩日啰(二合)阿目伽三摩野(二句)摩耨播(引)攞野(三句)钵啰(二合)没[亭*也]钵啰(二合)没[亭*也](四句)稣啰多萨怛鑁(三合五句)阿耨啰讫都(二合引)弥(引)婆嚩(六句)稣都输(引)弥(引)婆嚩(七句)稣补输(引)弥(引)婆嚩(八句)那那(引)儞祢达那萨埵(九句)萨哩嚩(二合)悉提弥(引)钵啰(二合)野蹉莎(十句)萨埵摩(引)讫里(二合)设钵啰(二合)吠(引)舍(十一句)三摩曳哩嚩(二合)特嚩(二合引)嚩尸(引)葛噜弥(十二句)壹味哩母(二合)捺啰(二合)钵乃(十三句)[口*弱]吽(引)鑁(引)呼(引十四句)

此大明召请本尊降曼拏罗已。是时本尊即施欢喜。而现祥瑞及希有事。金刚阿阇梨先献阏伽净水。后作金刚合掌献众妙花。复以宝铃及红色幢幡。如是献已置于四隅。又复依法献五阏伽瓶。盛五宝五药五谷插妙花果。以明加持香水充满。其瓶献已即置四隅。唯以一瓶置本尊前。说此加持香水大乐金刚不空三昧明曰

唵(引)摩贺(引)稣珂嚩曰啰(一句一合)阿目伽三摩踰(引)捺哥(二句)悉[亭*也]毗诜蹉(三句)萨哩嚩(二合)稣珂骚摩那写呜咄播(二合引)捺野(四句)酤噜酤噜(五句)[口*弱]吽(引)鑁(引)呼(引)阿(引六句)

以此大明。加持所献阏伽瓶香水二十一遍。若阿阇梨以此阏伽香水灌自顶者。即得清净一切苦。若用洒净或饮用者。即得增长一切快乐。设复有人未成就阿阇梨法者。得入此曼拏罗已。自然获具金刚阿阇梨法。复说阿阇梨入曼拏罗颂曰

  复次阿阇梨　　出于曼拏罗
  沐浴而洁净　　着于新净衣
  以众宝严身　　依法持妙花
  复入曼拏罗　　献种种供养
  若或阿阇梨　　入曼拏罗时
  迷误不审知　　懈怠及忘失
  蓦越金刚界　　名破于三昧
  是故须至心　　专注于等引
  此大曼拏罗　　倍复加精进
  何谓破三昧　　为此金刚界
  皆是诸佛印　　违越于境界
  是堕诸佛法　　如是了知已
  方入曼拏罗　　依法而供养
  旋绕礼敬已　　复还于本座
  即以妙伽陀　　至诚伸赞叹
  赞叹伽陀曰

  大欲大乐法　　金刚妙圣财
  大智事业主　　愿成金刚手

阿阇梨以此伽陀。伸赞叹已散花礼敬。复以金刚手菩萨根本百八名赞。而称叹曰

波啰摩(引)[寧*也]摩贺(引)萨埵(一句)摩贺(引)啰多摩贺(引)啰底(二句)三满多跋捺啰(二合)萨哩嚩(二合引)怛摩(二合引三)(句)嚩日啰(二合)誐哩嚩(二合引)钵帝钵帝(四句)唧多萨埵萨摩[亭*也]屹啰也(三合五句)嚩日啰(二合)嚩日啰(二合)摩贺驮啰(六句)三满多跋捺啰(二合)左哩野(二合引)屹啰野(三合七句)摩(引)啰摩(引)啰钵啰(二合)摩哩捺(二合)哥(八句)萨哩嚩(二合)冒地摩贺(引)没驮(九句)没驮(引)屹啰(二合)惹纳摩(二合)惹(十句)嚩日啰(二合)吽哥(引)啰吽哥(引)啰(十一句)路吉说啰摩尼钵啰(二合)捺(十二句)摩贺(引)啰(引)誐摩贺(引)骚契(十三句)哥(引)摩目叉摩贺(引)驮那(十四句)帝哩(二合)哥(引)罗帝哩(二合)跋嚩厮爹啰(三合)屹啰野(三合十五句)厮怛哩(三合)路哥(引)屹啰野(三合)厮怛哩驮(引)睹哥(十六句)塞他(二合)(引)嚩啰钵啰(二合)跋鑁咩葛怛(二合十七句)苏速叉摩(二合)厮吐(二合)罗萨散拶野(十八句)穰誐摩钵啰(二合)嚩啰钵啰(二合引)补姤(二合十九句)跋嚩散娑(引)啰戍驮哥(二十句)阿那(引)祢儞驮那(引)[寧*也]多(二十一句)干(引)多钵啰(二合引)萨哩嚩(二合)僧悉体多(二十二句)屹哩(二合)母捺啰(二合引)踰誐三摩野(二十三句)多埵萨爹摩贺(引)摩郝(二十四句)怛他(引)誐多摩贺(引)悉地(二十五句)达哩摩(二合)葛哩摩(二合)摩贺(引)没驮(二十六句)萨达哩摩(二合)萨葛哩摩(二合)拽他(二十)(七句)冒地唧多苏冒达葛(二十八句)嚩日啰骨噜(二合)驮摩贺(引)骨噜(一合)驮(二十九句)入嚩(二合引)罗(引)钵啰(二合)罗野捺(引)摩葛(三十句)摩贺(引)尾那野耨瑟吒(二合引)屹啰(二合三十一)噜捺啰(二合)劳捺啰(二合)叉焬葛啰(三十二句)萨哩嚩(二合)戍地摩贺(引)钵讷摩(二合三十三句)钵啰(二合)倪踰(二合)播野摩贺(引)那野(三十四)啰(引)誐戍地萨摩(引)[亭*也]屹啰野(三合三十五)尾说啰(引)誐摩呬说罗(三十六句)阿(引)哥(引)舍难多儞怛踰(二合)吠(三十七)萨哩嚩(二合)普多摩贺(引)罗野(三十八)尾普帝室哩(二合)哩尾(二合)睹啰(引)惹(三十九)萨哩嚩(二合引)舍钵哩布啰葛(四十)那莫悉帝(二合)窣睹(二合)那谟悉帝(二合)窣睹(二合四十一)那谟那莫(四十二句)跋骨姤(二合)[亢*欠]怛网(二合)钵啰(二合)钵[寧*也](引)弥(四十三)嚩日啰(二合)萨埵(引)[寧*也]悉[亭*也]忙(四十四句)野伊忙窣睹(二合)怛啰(二合)啰(引)惹难(四十五)钵啰(二合)爹[亢*欠]钵啰(二合引)钵啰(二合)嚩哩多(二合)野(四十六)达哩摩(二合)嚩(引)在萨讫哩(二合)捺誐(二合引)难(四十七句)悉地罗具多啰(引)跋尾(引四十八)阿体砌悉驮踰儞(引)那(四十九句)钵啰(二合引)怛哩(二合)散达焬(二合)祢儞祢儞(五十句)窣睹(二合)捶(引)萨哩啰(二合引)伽儞目讫多(二合五十一句)戍驮叱怛哩(二合)数悉[亭*也]底(五十二句)萨哩嚩(二合)耨珂喝囕儞怛焬(二合五十三句)萨讫哩(二合)挼(引)啰钵啰(二合)嚩哩多(二合)那(引五十四句)萨哩嚩(二合)悉地数骚婆誐焬(二合五十五)室哩(二合)三钵捺鼻嚩哩驮(二合)那(五十)(六句)

  是时阿阇梨　　以最上秘密
  一百八名赞　　如是称赞已
  然以秘密具　　嬉戏歌舞等
  而供养菩萨　　伸此供养已
  以宝灌顶法　　自受其灌顶
  灌顶已作礼　　即持诵本明
  或诵大心明　　乃执金刚杵
  诵灌顶明曰

[口*弱]吽(引)鑁(引)呼(引一句)摩贺(引)稣珂嚩日啰(二合)萨埵(二句)阿鼻尸(引)计(引)拏埵(引)摩(引)鼻洗左(引三句)萨哩嚩(二合)嚩日啰(二合引)地钵底怛尾(二合四句)捺哩(二合)除弥婆嚩悉[亭*也](五句)那莫悉帝(二合)婆誐鑁摩贺(引)嚩日啰(二合)达啰(六合)酥啰多萨怛网(三合七句)摩贺(引)嚩日啰(二合)萨埵(八句)唵普哩普(二合)嚩莎(九句)

  诵如是明已　　当复作此念
  我从金刚手　　亲受灌顶法
  今成阿阇梨　　所作皆成就
  随所求意愿　　当作最上法
  金刚歌舞等　　供养皆得成
  从是日已后　　于金刚部中
  德如金刚手　　如是阿阇梨
  速成一切法　　金刚手善成
  一切印自在　　一切智金刚
  已尽诸业障　　其相不可见
  善于一切法　　所作皆成就
  三界诸有情　　皆令得成坏
  亦一切爱敬　　正智断诸疑
  受一切妙乐　　具圣财自在
  诸天及世人　　令证一切智
  常见金刚手　　见获成就法
  常起清净心　　信乐真实理
  本尊施欢喜　　成就阿阇梨

金刚手菩萨说此入曼拏罗仪已。复说弟子入曼拏罗仪法。阿阇梨令弟子发大菩提心。发菩提心已。即当授与诸佛菩萨发菩提心明曰

唵(引)萨哩嚩(二合)怛他(引)誐多(一句)波啰摩摩贺(引)瑜誐(二句)冒地唧多母怛波(二合)捺夜(引)藐(三句)阿尸(引)沙(引)那嚩尸(引)沙(四句)萨哩嚩(二合)萨埵驮(引)睹(五句)钵哩怛啰(二合引)拏醯多(六句)稣库多摩悉地儞弥多(七句)摩爹多婆(引)嚩三悉地(八句)摩咍室左(二合)哩也(二合引)地钵带也(二合九句)野(引)嚩萨哩悔(二合)多摩摩贺(引)悉地(十句)摩咍室左(二合)哩也(二合引)地钵爹(引)野济多野底(十一句)

  当以此大明　　发大菩提心
  弟子恭敬师　　等同诸如来
  欲入曼拏罗　　令弟子依法
  净帛覆其面　　即举金刚步
  入于曼拏罗　　师举金刚步
  当如金刚手　　登此殊胜坛
  一切皆成就　　弟子入坛界
  若迷惑无知　　懈怠或忘失
  踰越金刚界　　是名破三昧
  当须专注心　　安想金刚步
  智者应精进　　依大法仪轨
  况复曼拏罗　　萎花与坛界
  是诸佛印藏　　若蓦越足步
  是不成三昧　　阿阇梨复须
  结其阏伽印　　入于曼拏罗
  信心礼本尊　　绕坛界三匝
  以妙颂赞叹

颂曰

  大欲大妙乐　　成就诸世间
  愿我于今时　　成就亦如是
  然后以众具　　供养大乐尊
  当引其弟子　　入于曼拏罗
  如阿阇梨仪　　随意献供养
  依于金刚部　　求受灌顶法
  是时其弟子　　求请本尊曰

摩贺(引)啰多稣涅哩(二合)茶(一句)稣睹舍也(二合)萨稣枯(引二句)嚩日啰(二合)萨埵(引)[寧*也]悉[亭*也][牟*含](引三句)

  如是求请已　　即散掷妙花
  随花所堕处　　是弟子本尊
  是时阿阇梨　　与去其面帛
  依五部法中　　授弟子灌顶
  传诸灌顶明　　诸灌顶明曰

唵(引)萨哩嚩(二合)嚩日啰(二合引)地钵底(一句)埵(引)摩鼻诜左(引)弥(二句)摩贺(引)嚩日啰(二合)达啰(三句)呬嚩日啰(二合)那莫(四句)悉[亭*也]三摩野萨怛鑁(三合五句)普哩普(二合)嚩莎(六句)

  传授此明已　　复传诸密印
  具足如是法　　所作皆成就
  诸求成就法　　皆依金刚手
  及弟子本尊　　成其三昧法
  乃至入坛仪　　并诸世间法
  及于出世间　　悉皆得圆满
  依如是仪轨　　入此坛场者
  即证不退地　　具大菩萨行
  成就大乐故　　如是阿阇梨
  及灌顶弟子　　随意作供养
  及与成就法　　所作速圆满

尔时金刚手菩萨说此曼拏罗已复说颂曰

  此普遍成法　　所说如虚空
  无喻大乐理　　根本最上轮

佛说最上根本大乐金刚不空三昧大教王经卷第三佛说最上根本大乐金刚不空三昧大教王经卷第四

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    大乐金刚不空三昧大明印相成就仪轨分第十五

尔时金刚手菩萨复说成就法颂曰

  今说成就法　　是最胜究竟
  由此最胜故　　见获究竟法
  是以诸菩萨　　悉远离轮回
  得成就自在　　能成一切义
  修诸菩萨行　　而成正等觉
  广习诸余法　　莫能越此教
  世间诸有情　　无福难度者
  虽遇佛菩萨　　而不能度脱
  此教最胜故　　过诸佛菩萨
  见闻者获益　　广大如虚空
  清净出三有　　得大欲大乐
  利益广无边　　所作皆成就
  设复诸有情　　无福懈怠者
  见世得圆满　　此最上成就

金刚手菩萨说此法已。复说不空最胜成就法颂曰

  若欲作成就　　当作金刚手
  塑像及画像　　金银诸宝等
  雕镂及彩画　　作如是像已
  行人于像前　　依法作成就
  当于清旦时　　以众秘密具
  依法献供养　　然后想己身
  如彼金刚手　　即时结大印
  持诵吽字明　　即成金刚手
  其法欲成时　　尊像现祥瑞
  或闻大笑声　　放光或动摇
  随愿皆成就　　以此成就法
  所作皆圆满　　诸持明自在
  最上最无碍　　具一切圣财
  是大欲大乐　　能调难调者
  善化度有情　　成就中最胜
  一切印自在　　是金刚成就
  一切大智海　　其相不可见
  善摄一切法　　胜出于三界
  能作诸成坏　　一切爱敬首
  通达一切智　　能施诸成就
  一切世界中　　以神通变化
  所作皆大胜　　圣财得自在
  色力等坚固　　无比金刚手
  世间咸恭敬　　诸菩萨称赞
  若或诸有情　　得遇金刚手
  脱老病死苦　　成佛菩萨道
  随欲而成就　　见世获安隐
  世间出世间　　所作诸仪轨
  自作若他作　　速成一切法

金刚手菩萨说此法已。复说一切仪轨不空大明印相成就法

若依法结大根本印。安于本心而诵明曰

涅哩(二合)茶素(引)都(引)舍(一句)萨啰讫多(二合)苏布(引)输(引)弥(引)婆嚩(二)

此名根本印成就。诵此明者。速成就根本印故

若依法以众香花妓乐等。随力供养而发誓愿。志心持诵吽字大明者。速得一切成就

若复依法当结金刚手印。发大精进令作成就速得如意。是名金刚手一切印成就法

若复依法结三昧印。而诵明曰

三摩野萨怛嚩(三合)弥底(一句)

此大明能成就三昧印。是名一切三昧成就法

若复以金刚歌舞等。起大精进而作成就。是名一切羯磨最上成就。所有一切供养事。见世得圆满德如金刚手。乃至成就诸佛菩萨。及诸余法皆速圆满

金刚手菩萨说此如上法已。复说一切仪轨。及一切智成就法

若欲作敬爱法者。日日依法结大印。而作成就决定如意

若欲钩召作成就者。当依大乐金刚视法若欲得一切悦乐增长成就法者。当依大乐金刚法

若欲增长色力寿命者。当依根本金刚啰娑野那法

若欲求吉祥大富贵者。当依根本金刚成就法

若欲具大势力者。当依金刚摩贺咄摩法

若欲常成就一切法者。当依根本金刚尾俱哩尾多法

若欲一切文字。及形像出见。闻语言等者。当依不空金刚真实法

若欲诸根圆满闻正法者。当依根本金刚不空真实三昧法

若欲圆满胜义者。当依出生金刚法

若欲出见伏藏者。当依根本金刚祢波法若欲圆满诸根发五神通者。当依金刚化药刹法

若欲令谷稼丰稔雨泽不[億-音+(夫*夫)]。令诸有情获大饶益者。当依金刚自在法

若欲一切处行住作诸法者。当依根本金刚不空羯磨法

若欲见诸佛菩萨者。当依根本金刚高举势法

若欲身如金刚手菩萨现种种相。乃至腾空自在者。当依金刚羯磨法

若欲为三界主。而作种种事业者。当依根本降三界法

若欲出见诸天调伏敬爱。令作种种事者。当依根本金刚萨埵法

若欲救护一切有情调伏敬爱。令作种种利益事者。当依根本金刚祢钵多法

若欲钩召诸药刹调伏敬爱者。当依根本金刚钵啰婆调伏法

若欲作诸善法。入曼拏罗供养成就者。当依根本金刚萨埵法

若欲钩召诸印法。禁缚法。坚固成就等法者。当依金刚成就法

若欲钩召一切三昧。入曼拏罗作成就者。当依金刚最上三昧法

若欲成一切事业令破魔冤。得己身坚固具大名称者。当依根本最上金刚羯磨法

若欲一切金刚部贤圣钩召入曼拏罗。安置坚固作敬爱成就者。当依根本金刚法

若欲大金刚萨埵钩召入曼拏罗。安置坚固敬爱作成就者。当依金刚萨埵法

若欲请召诸佛如来入曼拏罗。安住敬爱作成就者。当依根本金刚如来法

若欲召请金刚手菩萨入曼拏罗。安住敬爱作成就者。当依金刚手菩萨法

说此成就法已复说颂曰

  若复有行人　　未入曼拏罗
  设造诸罪业　　志心求所作
  最上不空法　　一切皆成就

尔时金刚手菩萨。复说不空心明法。决定作一切事。此金刚手菩萨是大毗首羯磨。善作诸法与诸佛等。所作成就刹那圆满

若欲广为救护一切众生。息灾安乐增长寿命者。当依金刚舞金刚萨埵顶法

若欲作曼拏罗结界。安住三昧坚固拥护者。当依金刚舞随求法

若欲解除诸疟及风黄痰癊等疾者。当依金刚舞入嚩啰法

若欲灭诸烦恼忧愁等苦者。当依金刚舞耨枯钵扇爹法

若欲解除诸毒令如甘露者。当依金刚舞解毒法

若欲令诸宿曜入寤及禁缚。令受三昧法作拥护者。当依金刚舞宿曜解脱法

若欲脱诸禁缚。破坏一切令起伏者。当依金刚舞金刚忿怒法

若欲破一切拏吉儞印。及脱宿曜执持。令死者还命。及救护国城者。当依金刚舞随印法

若欲销除一切罪业。及恶梦不祥等事者。当依金刚舞真实法

若欲令一切有情入寤。及语言敬爱发心成就者。当用金刚舞一切入寤印

若欲令一切魔冤起伏。及成坏等事者。当依金刚舞大拏吉儞法

若欲令一切魔冤禁缚迷惑起伏者。当依金刚舞大恶啰刹娑法

若欲令他军降伏爱敬者。当依金刚舞讫哩爹法

若欲息诸恚怒令作喜悦免诸怖畏。及论义战阵皆得胜者。当依金刚舞幢庄严法

若欲起云降雨及止息雷电风雹。去除寒热等者。当依金刚舞主法

若欲求种种色声香味触等者。当依金刚舞欲自在法

若欲一切处行住。令作爱敬钩召及降伏等事者。当依金刚舞法

若欲作一切成就法。谓出见一切贤圣降伏诸龙。乃至息除一切药刹部多摩怛哩等者。当依金刚舞最上金刚身法

若欲坚固成就一切供养。及调伏诸魔禁缚一切邪印。乃至尽无尽最上成就法者。当依金刚舞不空毗首羯磨最胜法

金刚手菩萨说此法已。复说一切印成就仪。行人当于清旦时面东而坐。依法结大印持诵本心明即成一切印。然后依法作成就所作决定。此大金刚手印能成一切印

设复有人未入曼拏罗者。结此大印亦皆成就

若复阿阇梨欲传此大印。当观根性而传授之。何以故传此印已即成菩萨。设不依法而无诸过。设作诸罪业者。结大印时诸业销除。有所愿求皆得圆满

    一切如来金刚菩提大仪轨分第十六

  尔时金刚手　　大秘密主尊
  以大乐坚固　　令有情清净
  摄诸有情界　　皆令得清净
  以平等心化　　令入如来部
  无量无边刹　　一切诸如来
  充满如胡麻　　皆广利众生
  令世间清净　　以众生之业
  有种种差别　　竟不能清净
  佛为彼众生　　自业清净故
  哀愍而不舍　　金刚手菩萨
  以大秘密教　　转大舍法轮
  此大金刚手　　最上大乐尊
  利益诸有情　　令刹那觉悟
  坚固菩提心　　欲转大法轮
  尽诸有情界　　令菩提坚固
  时诸佛如来　　以金刚语言
  告彼金刚手　　以大悲方便
  当说菩提心　　是时金刚手
  受诸佛劝请　　即发如是言
  我今说大乐　　最上曼拏罗
  其量等三界　　是根本大轮
  能清净诸有　　说如是语时
  三界诸有情　　诸业皆清净
  悉得成就法　　即时皆云集
  亦如诸如来　　劝请金刚手
  宣说如来部　　最上大舍轮
  由是诸众生　　住金刚三业
  金刚手菩萨　　以自性三业
  平等为众生　　说是大明曰

唵(引)部(引)亢

  说此大明时　　复有诸如来
  即时皆云集　　住菩提道场
  尔时金刚手　　即说曼拏罗
  利益有情故　　诸法中大乐
  其大舍轮者　　依外曼拏罗
  画八辐大轮　　于此大轮中
  当安佛尊像　　用此大明曰

三摩野萨怛鑁(三合)呼(引一句)悉[亭*也][牟*含](引二)

  于佛尊像前　　复安佛尊像
  降伏诸魔相　　于佛右安置
  灌顶大菩萨　　佛后复安置
  转法轮菩萨　　于佛左安置
  成最胜菩萨　　各说心明曰

嚩日啰(二合)萨埵(一句)

嚩日啰(二合)啰怛那(二合一句)

嚩日啰(二合)达哩摩(二合一句)

嚩日啰(二合)羯哩摩(二合一句)

  而于四隅位　　安四金刚宝
  用四大心明　　而彼心明曰

萨埵嚩日哩(二合一句)

嚩日啰(二合)啰怛儞(二合一句)

嚩日啰(二合)钵纳弥(二合)儞(一句)

尾说嚩日哩(二合一句)

  复于外四隅　　安祢嚩建拏
  钩索锁铃等　　如次安四门
  画此大轮已　　先当起心业
  出生及香华　　志心而供养
  手持众妙华　　结佛三昧印
  而安于本心　　顶礼本尊已
  然以华散掷　　次旋绕三匝
  当召请贤圣　　其召请明曰

唵(引)阿哥(引)噜(引)目亢萨哩嚩(二合)达哩摩(二合)拏(引一句)阿(引)[寧*也]阿耨怛半(二合)那埵(引二)

  诵此大明已　　复以华供养
  依法以妙言　　志心而诵曰

惹誐那(引)他没驮冒提苏悉驮曳(引一句)

  以此普召集　　一切诸如来
  以诸无生法　　施一切成就
  入此曼拏罗　　善得诸成就
  如是法圆满　　现种种瑞应
  若传授弟子　　令入此坛者
  其仪亦如是　　作诸供养已
  然后出道场　　可求成就法
  复说成就法　　依法造[巾*((ㄇ@人)/登)]像
  当画佛世尊　　降伏诸魔众
  行人于像前　　依法结智印
  以金刚语业　　诵明百千遍
  其数满足已　　随意皆成就
  见诸佛菩提　　无复诸疑惑

复次金刚手菩萨。说此诸三昧最上成就仪法。而说颂曰

  当想金刚手　　专注于本心
  即诵三昧明　　其三昧明曰

三摩野萨怛嚩(三合一句)

  诵满洛叉数　　善获诸成就

又复宣说一切羯磨成就法。颂曰

  佛降众魔军　　转大妙法轮
  广利益众生　　羯磨印成就

复说一切如来金刚三业诸佛最上成就法。所谓能除诸障累忧恼病苦。恶疮诸毒疟疾重病。复能破诸邪咒。辟除诸恶梦寐不祥魔娆等事。无其中[乏-之+(犮-乂+又)]之难。解诸宿曜执持及拏吉儞。如是灾害皆悉除灭。能令具善三业。获大威力色相圆满。名称吉祥人所恭敬。增长智慧精进勇猛。诸见闻法记念不忘。具修善行住三摩地。长养殊胜三业。圆满十波罗蜜布施持戒忍辱精进禅定慧方便愿力智。满足十地行入坚固出生陀罗尼门。具诸佛大乐印。通达四智十八不共法。作毗首羯磨。明了诸义性。成就诸佛金刚三业。得诸佛最上成就。以大菩提心。遍修普贤行。令诸有情获大利益。复现童真住出生嬉戏。以难胜行坐菩提场。证佛十力降伏魔军。转大法轮摧诸外道。胜出三界现诸神通。作大集会调伏诸恶。住柔顺地净诸恶趣。演妙法义说三密藏。示其仪轨作一切诸成就法。如是等事。皆依一切如来毗首羯磨印法所成。即说颂曰

  如是羯磨印　　速证菩提道
  诸修菩提行　　不越此法印
  具足大圣财　　能作诸事业
  难成义能成　　所作皆无碍
  诸佛最上教　　当授诸有情
  有能信解者　　为传此法印
  设未入坛场　　刹那亦成就

    大金刚火焰日轮仪轨分第十七

  金刚手菩萨　　善作众事业
  降诸有情界　　使令得调伏
  如来部所生　　常住如来定
  以最上成就　　寂静于诸有
  尘沙诸如来　　皆起大悲愿
  欲广利众生　　令居安乐地
  以众生诸行　　有种种差别
  不善之果报　　随业无定止
  纵经无数劫　　度脱难穷尽
  是故诸如来　　劝请金刚手
  为作调伏故　　宣说最胜法

尔时金刚手菩萨。即说大明曰

乌底瑟吒(二合)三摩野骨噜(二合引)驮(一句)儞逊婆入嚩(二合)罗嚩日啰(二合)吽(引二)

  金刚手菩萨　　说此大明时
  以金刚三业　　出生大明王
  住金刚手前　　而结跏趺坐
  光明普照曜　　如劫火炽盛
  现大威猛势　　手持金刚杵
  亦现大光明　　猛焰如火聚
  戏掷金刚杵　　变化于三界
  犹大劫火中　　出现忿怒相
  以金刚语业　　说金刚部明

唵(引)嚩日啰(二合)特哩(二合)俱(半音一句)怛帝哩(二合引)曩摩贺(引)嚩日啰(二合)入嚩(二合引)攞(引)那攞(引)哩哥(二)纥哩(二合)那炀吽(引三)

  说此大明时　　息除诸业障
  如盛火焚薪　　大千皆振动
  是时诸天众　　及大自在天
  光明皆洞然　　而不能安隐
  声闻及缘觉　　皆求入涅盘
  三界诸天众　　亦皆求救护
  诸佛菩提力　　不动而坚固
  唯佛大慈悲　　为有情方便
  是时大明王　　出金刚利牙
  立如张弩势　　忿怒大恶相
  发髻如螺文　　顶冠半月相
  风火焰交炽　　内现诸事业
  结印作舞势　　出生大秘密
  最上曼拏罗　　相应拏吉儞
  安住于周匝　　诸佛各依位
  皆是金刚部　　诸圣之轨仪
  为成毗首行　　复有诸圣众
  是时皆出现　　亦光明炽盛
  安住如诸佛　　无量无边界
  所有诸有情　　悉皆令觉寤
  利益而召集　　令成最上教
  时三界天主　　迷闷而擗地
  不复还本心　　金刚手菩萨
  最上大自在　　哀愍诸天故
  为说最上法　　还命大明曰

唵(引)母底瑟吒(二合)摩贺(引)祢钵多(二合)嚩日哩(二合)尼(引一句)尸(引)竭啰(二合)母他(引)钵野吽(引二)

  说此大明已　　诸天即能起
  皆复得本心　　死者还其命
  佛未调伏者　　金刚手菩萨
  悉令调伏之　　复现忿怒相
  戏掷金刚杵　　即敕于诸天
  令住我三昧　　诸天受命已
  而未能复知　　告白金刚手
  圣者不思议　　我等咸惊惧
  观此忿怒尊　　敕住于三昧
  不知三昧法　　云何而安住
  是时金刚手　　而白诸天曰
  诸佛之所化　　汝所不能知
  故号金刚手　　为汝作依怙
  汝归命诸佛　　及法与圣贤
  然后归于我　　当依我三昧
  是时诸天主　　及彼诸天众
  闻如是言已　　而白金刚手
  依菩萨圣言　　愿垂哀愍故
  尔时金刚手　　复现颦眉相
  作大忿怒威　　以高举威势
  而以大音声　　降伏于三界
  说最胜明曰

呬(引)

  说此心明时　　所有三界主
  及其诸天众　　皆以降伏心
  而住于三昧　　授本部灌顶
  受灌顶法已　　劝请金刚手
  说心明仪轨　　是大坛场法
  金刚手菩萨　　即当为说之
  于外曼拏罗　　内画金刚轮
  具光明炽盛　　中安降三界
  其身大青色　　而现喜怒相
  出金刚利牙　　当结跏趺坐
  戏掷金刚杵　　光焰普照曜
  而复于四方　　安金刚贤圣
  手各持标帜　　谓大金刚杵
  三叉及宝藏　　众色莲华等
  于四隅安置　　箭及朅桩誐
  轮并众色幡　　金刚部贤圣
  依此大轮仪　　各依位安置
  先安七种圣　　一谓金刚印
  二号金刚明　　三名金刚王
  并余诸眷属　　四持明歌舞
  五护门明王　　六金刚讷多
  七谓药刹王　　于外曼拏罗
  依法安诸天　　摩度等三尊
  亦安置本位　　四隅及四门
  安诸天女众　　钩索等明王
  各安于本位　　画此曼拏罗
  如是安布已　　是时阿阇梨
  而作忿努势　　戏掷金刚杵
  入于曼拏罗　　即诵吽字明
  作大高举势　　调伏忿怒者
  得本尊欢喜　　忿怒者成就
  然后阿阇梨　　手持众妙花
  结金刚钩印　　请召于本尊
  及金刚贤圣　　其请召明曰

唵(引)摩贺(引)嚩日啰(二合)攞(引)那攞(引)哩哥(二合)夜(引)呬[口*弱](一句)萨哩嚩(二合)嚩日啰(二合)酤攞(引)儞钵啰(二合)吠(引)舍野吽(引二)萨哩嚩(二合)母捺啰(二合引)誐赦鑁驮那怛啰(二合)吒(半音三)萨哩嚩(二合)三摩炀(引)娑(引)达野摩吒(半音四)萨哩嚩(二合)讷瑟啖(二合引)贺那捺郝钵左跋悉铭(二合)骨噜(五)摩贺(引)骨噜(二合)驮(引)屹儞(二合)嚩日哩(二合引)拏吽(引)发吒(半音六)阿阿阿阿(七)

  如是召请已　　明王即降临
  及金刚贤圣　　施一切成就
  是时曼拏罗　　即现诸瑞相
  或闻吽字声　　或复有警觉
  时彼阿阇梨　　结降三界印
  引弟子入坛　　而授诸大明
  金刚钩明曰

吽(引)吽(引)嚩日啰(二合)钵啰(二合)贺啰尾(引)摩吒(半音一句)　三叉大明曰

吽(引)嚩日啰(二合)戍逻(引)屹儞(二合)频捺摩吒(半音一句)

  金刚藏明曰

吽(引)嚩日啰(二合)酤(引)尸(引)亲捺摩吒(半音一句)

  莲花大明曰

吽(引)嚩日啰(二合)阿摩罗钵讷弥(二合引)摩吒(半音一句)

  复说密印明　　而有大威力
  善印诸众生　　所作成就法
  决定皆成就　　而说大明曰

吽(引)嚩日啰(二合)玉呬也(二合)悉驮钵啰摩瑜(引)诣(引)说哩讷弥(二合一句)

吽(引)嚩日啰(二合)赞尼(引)说哩朅桩誐阿悉摩贺(引)嚩日啰(二合)葛播(引)罗摩(引)逻(引)末酤致(引)噜卢噜梨(引)恨泥(二合一句)

吽(引)嚩日啰(二合)那(引)啰(引)野拏[口*爾](一句)

吽(引)嚩日啰(二合)钵多(引)计(引)[口*爾](一句)

  此四拏吉儞　　最胜心印明
  各以此本明　　安置曼拏罗
  说诸大明已　　然以三昧誓
  诫示于弟子　　使之令谛听
  广利益众生　　增长于佛法
  调伏令得度　　作金刚成就
  说三昧誓已　　当令其弟子
  诵吽字大明　　加持于头指
  使彼诸有情　　及彼恶魔者
  由是大明力　　皆悉令调伏
  然后当依法　　授弟子灌顶
  明王四种法　　次第而传授
  印及印所用　　坏灭并还命
  当以此印明　　而为作拥护
  如是调伏已　　诸恶不复生
  既从是已后　　诸善法增长
  见成就诸法　　复说成就法
  行人于像前　　戏掷金刚杵
  诵明洛叉数　　持诵其数满
  德如金刚手　　忿怒大明王
  离老病死苦　　善调一切恶
  于一切世间　　无复诸怖畏
  欲成就大明　　于四威仪中
  诵一洛叉数　　所作成就法
  现世得圆满　　诸成就自在
  远离诸苦恼　　堪受妙供养
  难调者能调　　行住无所畏
  若欲印成就　　当结最上印
  随意诵大明　　行人见世中
  成大忿怒王　　所作皆成就
  若欲成三昧　　行人当面东
  结彼三昧印　　持诵三昧明
  随意作诸法　　皆速得圆满
  若欲求成就　　最上羯磨法
  诵明利乐故　　速成诸事业

复次宣说最上成就法。所谓发遣诸魔禁伏邪法。印诸有情调伏众恶。解脱枷锁差诸疟病。解诸毒药散诸宿曜。欲作此等诸法者。皆依降三界尊仪法

又复若欲作一切入寤。及动摇嬉戏歌舞书写旋转。乃至钩召三界等。皆依金刚忿怒明王印

若欲钩召一切入于曼拏罗。及破他军见幻化事。改易时节开敷花果。或令谷稼滋茂。及解诸恶病毒药宿曜拏吉儞。令战阵得胜。结界拥护解脱系缚。乃至敬爱等法。皆依金刚忿怒明王毗首羯磨印

若欲成就诸天降伏龙众。遣诸药刹而为仆使。令一切啰刹生大惊怖。调伏拏吉儞众及摩怛哩哥。宿曜执持魔魅军众。邪坛咒术悉令破灭。使诸勇猛皆令怖畏。及能成就四大天王帝释大梵那罗延天大自在天等。及成就菩萨诸佛敬爱等事。钩召有情令住三昧。如是等种种之法。皆依金刚忿怒明王最上成就法。即说颂曰

  如是最上法　　若欲成就者
  当持诵心明　　而见忿怒相

佛说最上根本大乐金刚不空三昧大教王经卷第四佛说最上根本大乐金刚不空三昧大教王经卷第五

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    除诸业障一切智金刚仪轨分第十八

  尔时观自在　　复说三摩地
  最上清净法　　是即金刚手
  调伏于诸恶　　而现莲花部
  诸佛方便力　　利益众生故
  忿怒大明王　　清净诸三有
  以众生性欲　　未远离诸染
  诸佛无碍力　　起大悲愍心
  尚未能救度　　是故观自在
  说此三摩地　　是三世诸佛
  大三摩地王　　诸法之自性
  名金刚智明　　由是三摩地
  诸佛所观照　　令一切有情
  皆得大自在　　菩萨摩诃萨
  以大智悲愍　　自在度众生
  现作自在相　　左手持妙莲
  右手开莲叶　　观照于自性
  住此三摩地　　犹众妙色莲
  自性无诸染　　无染清净故
  不着诸烦恼　　三界贪欲生
  贪欲亦清净　　一切众生类
  当随其所应　　此三摩地门
  得诸佛自在　　金刚手菩萨
  及与诸菩萨　　皆依胜定力
  起大总持教　　即说观想明

纥哩(二合引)

  当想此心明　　即自性清净
  所有金刚手　　至于观自在
  观想此心明　　清净如宝山
  次观众色莲　　出生诸贤圣
  遍清净法界　　成调伏大轮
  众业调伏已　　三界皆清净
  为利诸有情　　说曼拏罗法
  为大法仪轨　　安置佛圣贤
  得如上清净　　成就无量法
  时诸佛菩萨　　劝请观自在
  说本莲花部　　金刚大法王
  最胜自在者　　即说曼拏罗
  于外曼拏罗　　内画八叶莲
  于此莲华中　　安其观自在
  左持金莲华　　作大自在相
  以众宝严身　　顶戴五佛冠
  于菩萨周回　　画八佛世尊
  妙定及大莲　　定与观照等
  复于八佛外　　当画八贤圣
  大力自在天　　大梵与欲天
  大莲与马头　　钩兼妙法语
  即说莲华部　　诸贤圣心明

萨哩嚩(二合)怛他(引)誐多钵讷摩(二合)[口*弱]吽(引一句)

嚩日啰(二合)钵讷摩(二合)系(引一句)

嚩日啰(二合)钵讷摩(二合)鑁(引一句)

呼(引)钵讷摩(二合)摩尼啰(引)惹(一句)

吽(引)钵讷摩(二合)赞尼(引)说啰吽(引)发吒(半音一句)

系(引)摩贺(引)钵讷摩(二合)尾说兰拏(二合)悉[亭*也]吽(引)发吒(半音一句)

纥哩(二合引)钵讷摩(二合)钵讷摩(二合)吽(引)阿(引一句)

呼(引)钵讷摩(二合)室作(二合)讫啰(二合)摩(引)讫啰(二合)摩吽(引)[口*弱](一句)

  复于其四门　　用钩索锁铃
  四心明如次　　依大曼拏罗
  仪法而安置　　入曼拏罗已
  观彼开敷莲　　想心而顶礼
  当以此大明　　安置于本尊
  即说大明曰

唵(引)尾输(引)达野戍提(引一句)萨埵驮(引)都(引)萨哩嚩(二合)啰(引)誐(引)祢散左曳(引二)唧旦弥(引)萨哩嚩(二合)达哩弥(二合引)数嚩日哩(二合)尼(引三)

  闻此大明已　　观自在欢喜
  所求诸成就　　皆悉得如意
  然后结钩印　　诵此最上明

唵(引)萨哩嚩(二合)怛他(引)誐多(引)啰路吉帝(引)说啰(一句)钵捺摩(二合)贺娑多(二合引)野(二)醯尸伽啰(二合)弥昧嚩日啰(二合)母捺啰(二合引)钵乃(三)啰(引)讫哩(二合)沙也(二合)钵啰(二合)尾(引)设也(二合四)三摩曳哩嚩(二合)驮(引)嚩尸葛噜弥(五)[口*弱]吽鑁呼(六)输驮野萨哩嚩(二合)萨达野(七)钵捺[牟*含](二合)摩贺(引)嚩日啰(二合)达啰萨怛鑁(三合八)

  如是召请已　　即时观自在
  降赴曼拏罗　　所作皆成就
  然后依仪法　　引弟子入坛
  传授秘密教　　善施诸成就
  此三昧印明　　根本圆满故
  速成观自在　　行人求此法
  于随所住处　　乃至四威仪
  想大莲华尊　　随时以自力
  而作成就法　　任意之所欲
  见世皆圆满　　及大胜欲乐
  远离老病苦　　当证佛菩萨
  与金刚手等　　皆依观自在
  即得悉圆满　　若求印成就
  当结印入定　　成就三昧者
  当结三昧印　　求诸羯磨法
  当结羯磨印　　若诸成就法
  有所难成者　　皆依三摩地
  依法得成就

若有一切业障恶梦不祥。及诸灾害忧悲苦恼。散失财宝贫穷所逼。斗诤触娆疾病缠绵中[乏-之+(犮-乂+又)]之难。如是等事欲远离者。皆依大莲华真实三摩地法

又复欲除风黄痰癊及诸疟病。疥癞痈疽水肿干痟。乃至宿曜拏吉儞等。令灭除销散者。当依大莲华印明法

若欲坚固一切者。当依被甲佛顶印

若欲拥护己身结界曼拏罗作金刚围等。及置饮食衣服庄严等具者。皆依大莲华印法

若欲拥护一切增长色力寿命。勇猛精进吉祥无病。求财宝丰盈有大名称一切爱敬。通达三摩地有大智慧等者。当依大莲华最上成就法

    圆满一切愿金刚宝仪轨分第十九

  尔时金刚手　　现大文字相
  遍满于虚空　　施灌顶胜义
  变化于宝部　　安住三摩地
  观照清净故　　觉寤于诸法
  根本诸胜义　　尽空界有情
  如水见星象　　入宝三摩地
  观彼虚空界　　如净琉璃色
  金刚宝菩萨　　从虚空藏生
  是时以坚固　　依本相而住
  观想三摩地　　成就有情故
  依诸佛轨仪　　及与金刚手
  欲以宝金刚　　而作灌顶法
  授贤圣灌顶　　令满一切愿
  诸贤圣灌顶　　诵此灌顶明
  即说大明曰

唵(引)萨哩嚩(二合)嚩日啰(二合引)地钵底埵(引一句)摩毗诜左(引)弥部(引)哩部(二合)嚩莎(二)

  说此大明时　　本部最上法
  从宝金刚尊　　出生诸贤圣
  依宝金刚法　　灌顶诸世间
  授诸灌顶已　　安住曼拏罗
  佛菩萨随喜　　宝金刚部主
  说最上仪轨　　于外曼拏罗
  内画大月轮　　其色如虚空
  依法画宿曜　　于其月轮中
  画虚空藏尊　　净如琉璃色
  以众光普照　　左手持宝珠
  安心如钩召　　右手作施愿
  于此尊四面　　画四亲近尊
  而复于四隅　　当画四菩萨
  灌顶及宝藏　　供养与吉祥
  各持本幖帜　　四亲近明曰

嚩日啰(二合)萨埵[口*弱](一句)

嚩日啰(二合)啰怛那(二合)吽(引一句)

嚩日啰(二合)达哩摩(二合)鑁(一句)

嚩日啰(二合)羯哩摩(二合)呼(引一句)

四菩萨明曰

嚩日啰(二句)阿毗试(引)计(引)[口*弱](一句)

摩贺(引)嚩日啰(二合)儞驮(引)泥(引)吽(引一句)

嚩日啰(二合)摩尼啰怛那(二合一句)

特嚩(二合)惹阿屹啰(二合)计(引)喻(引)哩鑁(一句)

摩贺(引)嚩日啰(二合)摩系(引)呼(引一句)

如是诸所作法。皆依大曼拏罗仪已。然后阿阇梨持众宝花入于曼拏罗。依法献供养敬礼本尊。而诵三昧明曰

唵(引)悉[亭*也]部(引一句)悉[亭*也]部嚩(二)悉[亭*也]莎(三)悉[亭*也]摩贺(引)嚩日啰(二合)啰怛那(二合四)嚩左吒吒怛囕(二合引五)

诵此大明时。虚空藏菩萨施一切成就。然后阿阇梨依法结摩尼拳钩曰。而作请召虚空藏菩萨请召明曰

唵(引)部(引)阿(引)夜(引)呬[口*弱](一句)部嚩钵啰(二合)尾舍吽(引二)莎屹哩(二合)恨拏(二合)鑁(三)嚩嚩誐誐悉[亭*也]呼(引)怛囕(二合引四)

诵此大明时。虚空藏菩萨速降曼事罗。阿阇梨所求法皆悉得成就。然后令弟子持众妙花结如前印。引入曼拏罗传诸真实法。弟子从是已后。得诸富乐所作皆成。乃至出世间法如佛菩萨皆速成就

  复说成就法　　是金刚宝印
  行人作成就　　欲利益世间
  由此大印故　　一切皆如意
  宝自在印力　　远离老病苦
  如世大宝聚　　能随意欲成
  三昧印亦然　　能成种种事
  当结三昧拳　　献众妙供养
  依法作成就　　所作悉圆满
  复说成就法　　诸仪轨中最
  难成者能成　　如是令当说

若欲钩召诸部多令入三昧。安住坚固敬爱随所愿求。净诸恶趣成就最上法等。皆依金刚宝灌顶印明

若欲钩召作诸吉祥。安住坚固敬爱等法。皆依金刚宝吉祥印明

若欲钩召求诸富乐。安住坚固等诸成就法。皆依金刚宝富乐印明

若欲钩召作诸供养。安住坚固乃至敬爱等法。皆依金刚宝供养印明。即说颂曰

  金刚手哀愍　　利益诸有情
  说此成就法　　行人当受持

    一切仪轨中最上成就仪轨分第二十

  尔时金刚手　　三界最上尊
  欲净贪等法　　为说此成就
  灭此三毒已　　世间成甘露
  复为摄诸龙　　而说曼拏罗

说此心明曰

普

  当作曼拏罗　　四方与四门
  画八大龙形　　门各画其二
  龙首皆向门　　引尾至坛隅
  曼拏罗中画　　阿难陀龙王
  其龙王八首　　于外曼拏罗
  画八族龙王　　如是安布已
  即时阿阇梨　　作大忿怒相
  当想于己身　　即为大龙王
  速入曼拏罗　　诵钩召大明
  钩召诸龙王　　而彼大明曰

唵(引)纥哩(二合引)阿儞罗惹嚩吠(引)誐(一句)必哩(二合)体尾埵啰试(引)沙(引)夜(引)呬普(二)

萨哩嚩(二合)那(引)誐酤逻(引)[寧*也](引)那野普(一句)

三摩曳(引)钵啰(二合)吠(引)舍夜(引)吠(引)誐野普(一句)萨哩鑁(二合)娑(引)达野普(一句)

萨哩嚩(二合)那(引)誐补怛啰(二合)哥(引)普(一句)

  诵召请明已　　诸龙皆云集
  入于曼拏罗　　阿阇梨所有
  三毒诸烦恼　　即时皆销灭
  当为彼诸龙　　说三昧誓曰
  世间贪嗔痴　　为汝等三毒
  安住于三昧　　三毒即销灭
  尔后阿阇梨　　诸恶不能害
  设服诸毒药　　而亦成甘露
  具大力勇猛　　如和修吉龙
  一切诸毒法　　亦皆能销灭
  复次金刚手　　为利有情故
  说降诸宿曜　　诸恶宿曜等
  以三毒所恼　　不能利众生
  为执持等害　　诸罪业皆生
  降伏恶曜故　　即说心明曰

吽(引)

  当画曼拏罗　　四方安四门
  于曼拏罗中　　依法画宿曜
  如是安布已　　然后阿阇梨
  入其曼拏罗　　作法而钩召
  召已设供养　　而作忿怒相
  金刚手立势　　持诵此心明
  所有诸恶曜　　即时皆调伏
  尔后阿阇梨　　得尽一切苦
  众恶不能侵　　诸善皆增长
  金刚手菩萨　　于法大自在
  为利益有情　　复说曼拏罗
  先说此明曰

吽(引)阿(引)呬(引)纥哩(二合引)怛览(二合引一句)

  说此大明时　　最上大自在
  一切最胜者　　以五秘密法
  为作调伏故　　调伏世最上
  我今当宣说　　是大毗首法
  最上曼拏罗　　诸法中自在
  依法画坛场　　内画金刚手
  及金刚部众　　四边四菩萨
  各持本幖帜　　前谓那罗延
  手持金刚轮　　右赞尼说啰
  手执于三叉　　左金刚莲华
  手持金色莲　　后安虚空藏
  手持金刚杵　　复于其四隅
  当画四贤圣　　谓金刚吉祥
  与金刚偶梨　　及金刚多罗
  虚空金刚等　　各有本心明
  诸贤圣明曰

唵(引)嚩日啰(二合)那(引)啰(引)野拏亲捺亲捺(一句)阿钵啰(二合)底贺多嚩日啰(二合)嚩讫哩(二合)拏呼(引二)婆誐鑁嚩日啰(二合)怛他(引)誐多[口*弱]吽(引)鑁呼(引三)嚩日啰(二合)怛他(引)誐多吽(引一句)嚩日啰(二合)骨噜(二合)驮摩贺(引)瑜(引)诣(引)儞(引)誐尼(引)说啰(二)摩贺(引)嚩日啰(二合)戌逻阿屹啰(二合)播(引)尼(引)呼(引三)婆誐鑁嚩日啰(二合)赞尼说啰阿(四)贺贺贺贺系(引五)

嚩日啰(二合)达啰纥哩(二合引一句)嚩日啰(二合)钵讷摩(二合引)讷婆(二合)嚩呼(引一)婆誐嚩鑁日啰(二合)阿嚩路(引)吉帝(引)说啰摩贺(引)没啰(二合)吽摩(二合三)悉[亭*也]唵(引)部哩部(二合)嚩莎(四)莎悉帝(二合)那莫莎贺(引五)

嚩日啰(二合)酤稣摩(引)欲驮(一句)萨哩嚩(二合)哥(引)摩(引)弥(引)娑(引)达野呼(引)婆誐鑁嚩日啰(二合)阿哥(引)舍誐哩婆(二合三)嚩嚩吒吒怛囕(二合引四)

那谟曳那萨帝也(二合)那婆誐嚩帝(引)钵啰(二合)倪也(二合引)播(引)啰弥多(引一句)萨怖(二合)吒(引)亲捺嚩日哩(二合)尼作讫哩(二合)拏(二)帝那萨帝也(二合)那播钵刚(引三)唵(引)地室哩(二合)输噜(二合)底萨蜜哩(二合)底尾惹曳(引)莎(引)贺(引四)

唵(引)嚩日啰(二合)偶哩摩贺(引)尾儞踰(二合一句)怛哩(二合)路哥尾惹曳说哩(二)嚩日啰(二合)骨噜(二合)驮(引)儗儞(二合)三摩曳(三)嚩日啰(二合)驮(引)哩那谟窣睹(二合)帝(引四)怛[寧*也]他(引五)醯隶弥隶(六)隶(引)隶罗隶啰(引)隶(七)嚩日啰(二合)哥(引)哩母(二合)哥曳莎(引)贺(引八)

那谟曳那萨帝也(二合引)那婆誐嚩帝(引一句)没驮冒地啰耨多啰(引二)嚩日啰(二合)达哩摩(二合)钵啰(二合)踰儗拏帝那萨帝也(二合)那悉[亭*也][牟*含](四)唵(引)多(引)哩睹多(引)哩(引)睹哩(引)莎(引)贺(引五)

唵(引)哥(引)摩嚩日哩(二合)尼悉驮(引)悉(一句)尾戍驮(引)悉(二)誐誐怒讷婆(二合)嚩踰儗那悉[亭*也][牟*含](引三)钵啰摩(引)叉哩(引四)怛[寧*也]他(引五)誐誐怒讷婆(二合)尾(引六)誐誐那尾输提(七)萨哩嚩(二合引)鼻钵啰(二合引)野钵哩布啰尼(引)莎(引)贺(引八)

  于外曼拏罗　　依位安幖帜
  天及摩怛哩　　并护世天等
  各依位安住　　四隅及四门
  安其十会主　　各持歌乐具
  皆以本心明　　各安于本位
  如是曼拏罗　　安诸贤圣已
  然后阿阇梨　　依法入坛场
  请召诸贤圣　　当结钩召印
  诵召请明曰

唵(引)摩贺(引)苏珂嚩日啰(二合)萨埵悉[亭*也]吽(一句)萨哩嚩(二合)怛他(引)誐旦萨摩(引)哥哩沙(二合)野[口*弱](二)萨哩嚩(二合)嚩日啰(二合)俱攞地半(三)捺摩曳埵(引)钵啰(二合)尾(引)设野吽(四)萨哩嚩(二合)路计说囕钵啰(二合)尾设也(二合五)三摩拽哩嚩(二合)驮(引)那野鑁(六)萨哩嚩(二合)啰怛那(二合引)地半摩尼啰(引)惹(引)难(七)嚩尸(引)俱噜呼(八引)吽恶醯纥哩(二合)咄笼(二合九)

  诵召请明时　　五大秘密主
  最上金刚手　　并余诸贤圣
  即降曼拏罗　　令坚固安住
  于是诸贤圣　　施最上成就
  然后阿阇梨　　当依前仪法
  作成曼拏罗　　及作诸成就
  圆满一切事　　尽无量无边
  调伏无与等　　以如上章句
  一切义清净　　诸佛善宣说
  甚深如来部　　善获诸妙乐
  是最上寂静　　诸佛之随喜

    一切相应诸佛三昧曼拏罗仪轨分第二十一

  金刚手菩萨　　复说甚深法
  微妙不思议　　广大最上明
  清净本无相　　无作而无尽
  是真实究竟　　最胜无有上
  大适悦妙乐　　以真净法界
  而利益众生　　最上义妙字
  施一切成就　　善施安乐法
  以金刚入寤　　而觉寤众生
  是秘密胜义　　决定金刚具
  为第一仪轨　　最上无能胜
  诸佛大三昧　　而此大乐界
  不思议所成　　众宝王庄严
  依妙寂静地　　大牟尼所居
  大适悦妙乐　　自然天乐音
  是最上爱乐　　具种种供养
  是最上适悦　　无比宝宫殿
  是最上安住　　度无量众生
  是最上成就　　演说微妙字
  即金刚萨埵　　修习普贤行
  而引道众生　　证诸佛菩萨
  最上诸成就　　金刚手大主
  所有妙欲乐　　悉圆满自在

金刚手菩萨即说最上心明曰

吽(引)

  说是大明时　　金刚手菩萨
  五秘密出生　　真实印贤圣
  常施诸欲乐　　最上大自在
  四大贤圣众　　皆化利众生
  此法于世间　　最胜诸成就
  胜义增长故　　富有大圣财
  能作大成就　　施广大利乐
  无数诸贤圣　　即金刚萨埵
  令说诸贤圣　　最上秘密明

怛[寧*也]他(引)摩贺(引)啰多室哩(二合)嚩日啰(二合引)谟伽啰底(一句)三摩野(引)那(引)莫嚩日哩(二合)尼(引二)摩贺(引)啰多室哩(二合引)嚩日啰(二合引)谟伽啰底(三)三摩野嚩日罗(二合)计隶(引)吉攞摩贺(引)啰多(四)室哩(二合引)嚩日啰(二合)谟伽啰底三摩野(五)尾惹野嚩日啰(二合引)摩贺(引)多啰(六)室哩(二合引)嚩日啰(二合引)谟伽(引)啰底三摩野(七)嚩日啰(二合)哥(引)弥说啰(引)弥底(八)

  如是秘密明　　若有人受持
  是人获诸印　　及成一切法
  复说此究竟　　是上成就法
  由如是法故　　所作得究竟
  若有诸行人　　误犯诸罪业
  亦未曾成就　　于诸秘密法
  若依此法行　　即得皆圆满
  欲作成就者　　一日或一月
  乃至于一年　　但随分随力
  先当依法仪　　画金刚手像
  其身如月色　　于大莲花上
  而结跏趺坐　　作大高举势
  种种庄严身　　众色光炽盛
  如佛灌顶仪　　左手持宝铃
  右执金刚杵　　于前莲华上
  复画四贤圣　　左右各安二
  皆作高举势　　此名四亲近
  一作白莲色　　余三如青莲
  金刚手后面　　枳哩枳罗尊
  而复于右边　　画大金刚尊
  右手捻箭势　　左手持宝幢
  而复于左边　　画波哩贺娑
  如是诸贤圣　　如宝灌顶相
  画此[巾*((ㄇ@人)/登)]像已　　或复作观想
  或复作供养　　或能随喜者
  得究竟解脱　　所作皆如意
  如是金刚手　　[巾*((ㄇ@人)/登)]像秘密法
  是最上大乐　　若有爱乐者
  当得最上乐　　成就清净法
  以此清净法　　是真秘密义
  复说曼拏罗　　当择清净处
  或上好园林　　或伽蓝精舍
  择如是处已　　以众宝庄严
  悬铃及璎珞　　幢幡并伞盖
  香花众伎乐　　依法而严饰
  然后作成就　　秘密曼拏罗
  作成就法已　　诸贤圣皆成
  入此曼拏罗　　大秘密中者
  成金刚阇梨　　诸所欲愿乐
  皆速得圆满　　阿阇梨先当
  沐浴而洁净　　以妙香涂身
  着新净上衣　　以宝鬘严身
  手持众妙花　　诵金刚歌明
  入于曼拏罗　　即说歌明曰

钵啰(二合)尾舍婆誐鑁(一句)摩贺(引)稣珂谟(引)叉补囕(二)萨哩嚩(二合)悉提稣亢啰咩(三)钵啰摩稣枯(引)怛摩悉[亭*也](引四)[口*弱]吽(引)鑁(引)鑁(引)呼(引)钵啰(二合)悉[亭*也]莎(五)

  入曼拏罗已　　手持众妙花
  而结佛眼印　　即诵此心明
  掷花而礼拜　　其礼拜明曰

唵(引)波啰摩稣珂(引)舍野(一句)萨啰哩多尾逻(引)娑那弥带(引二)那摩(引)弥婆誐嚩当(三)[口*弱]吽(引)鑁(引)呼(引四)呬呬呬呬(五)钵啰(二合)帝(引)蹉酤稣[牟*含](引)惹里那(引)他(六)

  掷华作礼已　　依金刚萨埵
  如作灌顶势　　持金刚铃杵
  诵灌顶三昧　　其灌顶明曰

唵(引)萨哩嚩(二合)没驮嚩啰啰怛那(二合)散左野(一句)钵啰(二合)怛踰(二合)钵多(二合)祢咩摩酤吒(引)野那摩(二)阿毗诜左[牟*含](引三)钵啰(二合)嚩啰啰日啰(二合)达囕(四)室哩(二合引)嚩日啰(二合)萨埵三摩野萨怛鑁(三合)摩[亢*欠](呼郎切五)

  杵表真实理　　振铃为法音
  三昧是大印　　安住诵心明
  持此铃杵者　　即成金刚手
  是大阿阇梨　　金刚手无异
  此最上秘密　　三种三昧法
  成就曼拏罗　　最胜无伦比
  复说成就法　　最甚深究竟
  由究竟法故　　得决定成就
  若复有行人　　三业不清净
  未得成就者　　皆悉得圆满
  行人当依法　　先作菩萨像
  塑画或雕镂　　于菩萨像前
  献种种供养　　执金刚铃杵
  以三种三昧　　诸钩召大明
  依仪轨作法　　所有三三昧
  诸钩召大明　　皆以钩召印
  亦用最上明　　而彼大明曰

萨哩嚩(二合)怛他(引)誐多乌多摩悉[亭*也](引)哥哩沙(二合)拏(一句)钵啰摩啰喝写三摩野(二)嚩日啰(二合)儗睹钵贺(引)啰[口*弱](三)钵罗摩[寧*也]嚩日啰(二合)达啰(四)嚩日啰(二合)萨埵萨稣亢钵罗(二合)没[亭*也](五)稣啰多萨怛[亭*也](三合)摩[亢*欠](六)钵啰(二合)底没[亭*也]没驮呬吽(七)嚩啰嚩日啰(二合)哥哩摩(二合)钵啰摩(引)叉啰(八)恶叉焬婆嚩(九)钵啰(二合)悉地稣珂骚摩那写(十)三摩野(引)[寧*也]悉[亭*也][牟*含](引)鑁(十一)钵啰摩(引)萨母哩底(二合)达啰(十二)萨哩嚩(二合)踰誐尾惹踰蹉啰(二合)野(十三)钵啰(二合)嚩啰戍地稣契婆嚩(十四)钵捺摩(二合)啰(引)惹呬呼(引十五)钵啰(二合)嚩啰钵囕钵啰摩(十六)萨哩嚩(二合)悉地钵啰弥说啰(十七)钵啰(二合)婆嚩呬珂誐哩婆(二合十八)萨多旦萨蜜哩(二合)[亭*也]弥(十九)[口*弱]吽鑁呼(引二十)虎卢虎卢(二十一)悉[亭*也]萨摩(引)哥哩尸(二合)睹(二十二)摩贺(引)三摩拽(二十三)萨哩嚩(二合)怛他(引)誐多三摩野(二十四)苏啰多萨怛鑁(三合)摩[亢*欠](二十五)

  根本大秘密　　三种三昧法
  然当依本尊　　成就诸供养
  以供养大明　　而作歌舞等
  即说诸如来　　圣最上成就
  大供养仪轨　　大秘密三昧
  金刚歌舞等　　最上大明曰

萨哩嚩(二合引)耨啰(引)誐苏珂三摩那三(引一句)怛鑁(二合)嚩日啰(二合)萨埵苏啰多(二)三摩焬婆嚩弥(三)摩贺(引)苏珂担哩(二合)除蹉啰(二合)野捺(四)钵啰(二合)底钵[亭*也]悉[亭*也]左(五)罗虞钵啰(二合)拏多(六)

  最上大秘密　　三种三昧法
  安住诸成就　　此大法仪轨
  如彼本尊法　　用印亦皆然
  持诵于心明　　即说诸如来
  安住成就法　　最上真实义
  大秘密三昧　　金刚歌舞等
  诸大胜法明　　而说彼明曰

唵(引)阿(引)哥(引)输怛波(二合)捺唧贺那(二合)埵(引一句)捺那(引)祢儞驮那钵囕(二)摩贺(引)嚩日啰(二合)三摩野萨怛侮(二合引三)嚩日啰(二合)萨埵钵啰(二合)悉[亭*也]弥(四)萨哩侮(二合)怛摩摩贺(引)悉地(五)摩咍说哩也(二合引)地乃嚩多(六)萨哩嚩(二合)嚩日啰(二合)驮噜啰(引)惹(引七)悉[亭*也]弥钵啰摩(引)叉啰(八)儞哩祢(二合)设设(引)说多室左(二合)悉(九)萨哩嚩(二合)啰(引)誐(引)耨啰(引)誐拏(十)怛怛尾(二合引)那悉[亭*也]婆誐鑁(十一)摩贺(引)啰(引)誐摩贺(引)啰多(十二)阿爹焬(二合)怛戍戍驮哩嚩(二合十三)誐啰阿祢目讫多(二合)萨怛(二合)他誐多(十四)三满多婆捺啰(二合)萨哩嚩(二合引)怛摩(二合)(引十五)冒地萨埵钵啰(二合)悉[亭*也]祢(引十六)萨哩侮(二合)怛摩摩贺(引)悉地(十七)哩摩(二合)咍说哩也(二合引)誐啰(二合)母捺啰(二合)野(引十八)悉[亭*也]嚩日啰(二合)摩呼(引)怛哥(二合)哩沙(二合十九)嚩日啰(二合)誐哩嚩(二合)阿钵底摩摩(二十)

  此根本大明　　真实之理法
  若人依法诵　　是人成诸圣
  得圣财自在　　能成诸难事
  此金刚萨埵　　成最上秘密
  摄诸大成就　　依胜法仪轨
  速召金刚手　　所成就诸法
  而集大富乐　　此胜法当就
  即见众色光　　或出余祥瑞
  阿阇梨见已　　即获大富乐
  诸仪轨成就　　皆随心所作
  此名为根本　　三种三昧法
  作此成就事　　诸贤圣降临
  依此本尊法　　诸贤圣亦然
  歌舞等诸仪　　亦同前本尊
  本尊生警寤　　当以根本明
  振铃及歌舞　　而以羯磨印
  或用三昧印　　如是诸仪轨
  以金刚入寤　　皆当令警觉
  成一切三昧　　出过本尊法
  此最上秘密　　三种真实法
  金刚歌舞等　　是为最成就
  行人作法者　　当随意随力
  选择殊胜地　　宫殿及园林
  或宝或众花　　严饰其胜地
  行人当沐浴　　着新净妙衣
  然后安尊像　　彩画或塑像
  敷设布坛场　　依法严佛事
  行人于像前　　以本尊仪法
  持金刚铃杵　　而作于警觉
  钩召各安置　　供养作成就
  既作成就已　　于四威仪中
  语言及戏笑　　处处皆随意
  最上秘密轮　　随所欲皆成
  诸成就自在　　脱老病死苦
  即如金刚手　　是金刚部王
  一切印自在　　其相不可见
  解脱诸禁缚　　摄一切有情
  能作大主宰　　善为诸成坏
  作一切爱敬　　诸成就最胜
  世间大自在　　最上第一乐
  如清净莲海　　若能修习者
  是即建法幢　　高显出三界
  皆得善胜利　　如是金刚手
  说根本最上　　三种三昧法
  供养成就仪　　及诸钩召等
  秘密大安乐　　诸佛皆随喜
  金刚手心印　　摄诸众生心
  是金刚萨埵　　广修普贤行
  自在若虚空　　从自性真理
  一法生无边　　如清净莲海
  此最上妙乐　　甚深大秘密
  能作诸成就　　是建妙法幢
  获如是成就　　最上妙法乐

佛说最上根本大乐金刚不空三昧大教王经卷第五佛说最上根本大乐金刚不空三昧大教王经卷第六

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    一切如来大三昧曼拏罗仪轨分第二十二

尔时金刚手菩萨摩诃萨。复说诸佛大三昧法弟子灌顶仪轨。凡当欲受诸佛大三昧秘密灌顶法者。先须发起诸佛最上秘密阿耨多罗三藐三菩提心等。同诸佛自性清净

阿阇梨先授弟子此最上秘密心明曰

唵(引)萨哩嚩(二合)踰(引)诣哥(引)野嚩(引)讫唧(二合)多母怛波(二合引)[打-丁+柰]夜(引)弥(一句)

授此菩提心明已。即得诸佛不退转地。降伏一切邪魔外道。即成诸佛菩萨次授此明曰

鸟怛波(二合)[打-丁+柰]曳埵波啰[牟*含]冒地唧多摩耨多啰(一句)嚩日啰(二合)摩[亭*也]写钵啰(二合)底瑟吒(二合引)必炀(二合二)纥哩(二合)[打-丁+柰]曳(引)纥哩(二合)[打-丁+柰]曳(引)那睹(三)稣啰帝(引)三摩野萨怛嚩(三合)呼(引四)嚩日啰(二合)悉[亭*也]野他(引)稣亢(五)

授此大明已。欲求最上成就法者。金刚手菩萨皆悉施之。阿阇梨当依法传授弟子。令其弟子以净帛覆面。手持种种妙花。然后引入曼拏罗内。弟子当一心恳切发大誓愿。将所持花任意散掷。随花堕处即是本尊。得本尊已乃去其面帛。时阿阇梨即依佛部灌顶法。以金刚净水灌弟子顶。次授三种三昧法。然后授其三昧誓曰

  汝受灌顶已　　常住于三昧
  即成一切法　　此金刚铃杵
  当执持信受　　住坚固三昧
  发起真实行　　今此所传授
  秘密灌顶法　　诸佛之密印
  若生轻慢心　　即堕于地狱

说此誓已。即以金刚杵授其弟子。为说持金刚杵明曰

唵(引)萨哩嚩(二合)怛他(引)誐多(一句)摩贺(引)三摩野(二)怛埵(引)地钵底埵(引)摩鼻诜左(引)弥(三)摩贺(引)嚩日啰(二合)达啰(四)伊捺旦萨哩嚩(二合)没驮怛鑁(二合五)嚩日朗(二合)嚩日啰(二合)达啰写咄(六)埵野(引)毕醯萨捺(引)驮哩炀(二合七)摩贺(引)嚩日啰(二合)达囕没啰(二合)多弥底(八)多祢难多萨哩嚩(二合)怛他(引)誐多(九)钵啰摩摩贺(引)冒地唧多(十)摩写(引)钵哩爹(引)誐(引十一)捺写萨奈(引)驮(引)啰拏弥底啰喝萨炀(二合十二)醯(引)嚩日啰(二合)誐哩嚩(二合引)地钵底(十三)室哩(二合引)呬嚩日啰(二合)那(引)莫悉[亭*也]三摩野萨怛鑁(三合十四)普哩普(二合)嚩莎(十五)

传此明已。当随弟子本尊灌顶而为立名。立其名已。至于菩提道场。不退转于阿耨多罗三藐三菩提故。所以者何。但由受此三种三昧法故。此三昧法者。实无所有不可得知。大乐金刚萨埵普贤之行。根本最上所出生故。为说此最上真实五种秘密法已。复诫其弟子曰。此法最上是三有主。一切自在首无上真实道。诸佛如来清净自性。了一切众生自性清净故。三有自性亦清净显真实理。此最上秘密法即是金刚铃。而能觉悟诸佛如来及诸贤圣。是法供养复能觉悟一切法。复以此法觉悟诸有情。销除一切诸业障。此名金刚觉悟法。能作成就敬爱等事。清净三有最妙方便。汝当于此最上秘密三昧诸仪轨中深生信受。此法于三有中。能尽诸苦际令获诸妙乐。是大方便教而利益世间。信受行之决定真实。行人修习此胜法者设在五欲受诸乐境。但能依法修行而无障碍。何以故一切如来无比秘密最上大乘妙三昧法。是故应当勤修行之。若不违此诸佛如来密印三昧者。是人必住坚固地生不退心。是名金刚萨埵得证阿耨多罗三藐三菩提。即说颂曰

  菩萨住世间　　无量无数劫
  为诸有情故　　作广大利益
  住方便三昧　　成就大福业
  持明大自在　　欲利益众生
  以此三昧法　　随意皆得成
  设有罪业者　　亦无诸障碍
  当得成所欲　　是金刚部王
  最上自在者　　尽成诸密法
  若依此法行　　能利益自他
  善印于诸法　　及作诸成就
  决定皆圆满　　作诸相应法
  得尽苦边际　　而获无量乐
  如是金刚手　　秘密金刚杵
  若能手持者　　获诸成就事

复次阿阇梨。当为弟子授记。依诸佛金刚灌顶授记仪。及用诸佛大印法。弟子得记已。即离诸有趣入诸佛境界。即说授记明曰

唵(引)伊数(引)[亢*欠]咩(引)哥噜弥怛鑁(二合引一句)嚩日啰(二合)萨埵萨怛(二合)他(引)誐多(二)婆誐鑁(引)讷哩誐(二合)多踰(引)特哩(二合)爹(三)遏典多婆嚩悉驮曳(引四)系(引)嚩日啰(二合)那(引)摩怛他(引)誐多(五)悉[亭*也]三摩野萨怛鑁(三合六)普哩普(二合)嚩莎(七)

若人得此诸佛授记大明印。尊重信受。是人即得诸佛如来诸大菩萨金刚手等。皆悉降于曼拏罗。授与阿耨多罗三藐三菩提记。是人得受记已。诸佛如来大菩萨众。皆悉敬爱施诸成就法。诸佛如来安住法界。犹如虚空广大无边。是时诸佛同时安慰。咸皆称赞作如是言。此阿阇梨得诸佛三昧同诸如来。若人得此最上秘密安慰称赞者。所有一切罪业应时销散。灭尽无余永离苦恼。诸天不能见所行无畏。尽三有苦成最上法。而此最胜调伏之法。常当护持安于三昧。是即诸佛平等宣说。不应舍离菩提之心。金刚密印定成菩提。此诸佛法勿暂弃舍。设有迷惑纵舍己身。不得暂舍诸佛最上之法。金刚铃杵及诸密印。亦勿舍离而生轻慢。敬阿阇梨等同诸佛。若轻阿阇梨者是轻诸佛。当受众苦无有威德。被诸疟病恶毒拏吉儞魅。宿曜执持及诸魔众。如是灾害常所娆乱。命终之后当堕地狱。是故当知阿阇梨者是为大师。常当尊重爱敬供养。如前所说众苦恼等皆不能侵。应当恭敬供养阿阇梨。何以故此阿阇梨。经阿僧祇俱胝劫数实难值遇。由此阿阇梨开发菩提道得成佛果。是故弟子依本法仪而常供养。是即供养诸佛如来故。成最上法见获善果。与诸贤圣等无有异。见受灌顶证法王位。作三界主降伏魔军。住寂静地佛果菩提定无疑惑。金刚手菩萨。如是说此一切如来及诸菩萨灌顶曼拏罗已。复作是言如先所说一切如来最上秘密。安慰住一切如来三昧。阿阇梨及弟子令发大菩提心即住不退地。应当观想如佛最上究竟。所以者何。谓阿阇梨及弟子。能发诸佛最上大菩提心。由此发大心故。即住不退地。无复退转。由不退故决定证于阿耨多罗三藐三菩提。由是见在证菩提故。未来决定平等证彼阿耨多罗三藐三菩提

又复阿阇梨及弟子。所有金刚萨埵相应之法皆悉具足。所以诸佛如来。以最上秘密而作安慰

又复如先所说。住诸佛如来三昧者。即证阿耨多罗三藐三菩提。所谓诸佛如来根本三昧。是最上成就法。若住此三昧者。即证诸佛如来。是故若欲尽诸苦恼。应于阿阇梨生贵重心。常作护持信奉称赞爱敬供养。尽其形寿无暂懈退。复令他人转生信重承事供养。当知此阿阇梨。已具金刚三业。常住诸佛三昧最上究竟。此大秘密法。唯除邪魔外道及声闻缘觉等勿令传授。金刚手菩萨。说此诸佛及诸菩萨真实法已。复说颂曰

  当于阿阇梨　　起大信重心
  其阿阇梨者　　是无尽三昧
  最上大乐本　　诸佛等无异
  由阿阇梨故　　获最上究竟

复次阿阇梨。但当受诸富乐。及种种饮食上味。乃至歌舞戏笑等事。而依法持诵用根本印。作秘密供养。得所求成就即说金刚萨埵秘密歌舞等供养明曰

吽(引)

诸佛如来秘密供养明曰

阿

降三界尊秘密供养明曰

呬(引)

莲花藏尊秘密供养明曰

怛览(二合引)

虚空藏尊秘密供养明曰

朅

如是等供养。以此五心明得成秘密供养法

复说最上秘密毗首印供养。及金刚萨埵等诸贤圣仪轨幖帜印法。所有幖帜。皆以金银及吉祥木等。各依本法而作安于曼拏罗。是时弟子依毗首印法当作供养。由此毗首仪故。弟子所有苦恼疟等。诸疾恶毒拏吉儞魅。恶曜执持诸魔灾害。恶趣等业皆悉销灭。增长善业得究竟相应诸佛无上菩提。依此金刚萨埵最上秘密毗首印供养仪。所有诸贤圣各以入三昧歌而作供养。是名一切毗首三昧最上成就供养即说根本金刚萨埵羯磨部入三昧金刚歌曰

萨哩嚩(二合引)耨啰(引)誐稣珂素(引)摩那散怛鑁(二合一句)嚩日啰(二合)萨埵稣啰多三摩野婆嚩弥(二)摩贺(引)稣珂涅哩(二合)除(引)卒野捺(三)钵啰(二合)底钵[亭*也]悉[亭*也]左罗具钵啰(二合)拏多(四)

复说一切如来部最上秘密入三昧金刚歌曰

嚩日啰(二合)萨埵僧屹啰贺(一句)

嚩日啰(二合)啰怛那(二合)摩努多啰(一句)

嚩日啰(二合)达哩摩(二合)誐(引)野乃(一句)

嚩日啰(二合)羯哩摩(二合)羯噜婆嚩(一句)

复说一切金刚部最上秘密入三昧金刚歌曰

吽(引)嚩日啰(二合)哥(引)哩母(二合)哥设啰(引)野那摩(一句)

室哩(二合引)嚩日啰(二合)啰(引)誐三摩夜野那摩(一句)朅桩誐(引)嚩日啰(二合)补罗夜野那摩(一句)

室哩(二合引)嚩日啰(二合)健吒葛罗婆(引)野那摩(一句)复说一切莲华部最上秘密入三昧金刚歌曰

聒唧捺鼻噜捺啰(二合)唠捺啰(二合)多耨(一句)母誐啰(二合)惹那(引)稣喝哩(引二)钵啰(二合)钵[寧*也]西聒唧鼻帝叉拏(二合)作讫啰(二合)达啰母哩底(二合二)惹誐地儞野散多多(四)聒唧捺鼻骚摩也(二合)扇(引)多嚩布啰叉啰难(五)哥摩攞摩那写吠(六)聒唧捺鼻祢(引)钵多(二合)哥(引)摩三摩野(引)钵啰(二合)悉[亭*也](七)摩摩钵捺摩(二合)啰(引)惹呬(八)

复说一切宝部最上秘密入三昧金刚歌曰

萨哩嚩(二合引)鼻尸哥钵啰弥说啰多(一句)僧悉[亭*也]左(引)叉野儞地(二)钵啰摩萨哩嚩(二合引)誐啰(二合)计睹(三)尾惹踰蹉啰(二合)野多(四)室哩(二合引)嚩日啰(二合)啰怛那(二合)婆嚩弥苏珂捺(五)

复说摩度迦啰三尊歌曰

普哩普(二合)嚩莎(一句)

复说四贤圣歌曰

纥哩(二合)吽室哩(二合)毗踰(二合一句)

复说诸龙王歌曰

普普

复说金刚手大药刹主诸阏伽供养金刚歌曰

萨哩嚩(二合引)哩伽(二合)曼拏罗祢难(一句)嚩日啰(二合)达啰(引)讫啰(二合)摩(二)尾摩哩捺(二合)尾吉啰尾吉啰(三)伴儒(仁祚切)蹉(引)捺野那(引)设野(四)喝那捺喝钵左(五)婆悉弥(二合引)俱噜骨噜(二合)驮(六)吽哥(引)啰摩(引)怛哩(二合)拏盎(七)

复说最上自在大曼拏罗最上秘密入三昧金刚歌曰

聒唧捺摩朗耨曼拏罗萨喝萨啰(二合)噜左(引)嚩布沙(引)尾啰(引)惹西(引一句)钵啰(二合)罗野那罗(引)哩哥(二合)酤致哥啰奔惹摩贺婆野祢(引)必底(二合)那(引)聒唧(二)聒唧捺尾哥(引)底祢必底(二合)稣珂扇(引)多摩那(引)祢惹那噜钵驮(引)哩拏(引三)萨哩嚩(二合)惹誐蹉摩(引)哩闭(二合)多稣噜钵勃哩(二合)多(引)达啰播(引)尼那(引)聒唧(四)誐誐那弥嚩萨哩嚩(二合)僧悉体睹惹誐旦尾那踰[寧*也]睹尾戍达那(引)野(五)怛鑁(二合)嚩日啰(二合)萨埵悉[亭*也]摩拽尸沙尾那野尾捺誐驮(二合)萨稣契毗药(二合六)

复说最上秘密仪中最上秘密三种三昧金刚歌曰

唵(引)钵啰(二合)尾设婆誐鑁(一句)摩贺(引)稣珂谟(引)叉布囕(二)萨哩嚩(二合)悉提稣珂波啰摩囕摩炀(二合三)波啰摩稣枯(引)怛摩悉[亭*夜](引四)[口*弱]吽(引)鑁(引)呼(引)钵啰(二合)悉[亭*也]莎(五)

以如是等最上甚深秘密三种三昧真实理金刚歌而作供养。所求成就皆得圆满。此一切如来最上秘密诸仪轨中大毗首三昧供养。以此供养者。金刚萨埵即时降赴。得毗首相应自在成就。即说颂曰

  此根本仪轨　　善作诸事业
  大秘密神通　　能建大法幢
  得无尽义味　　果决成就事
  获具足圣财　　圆满究竟法
  毗首大秘密　　难成者能成
  所有三摩地　　静住自在乐
  得心之所欲　　一切无挂碍
  设或世间人　　不修诸福业
  无其胜善力　　以罪业障故
  入此曼拏罗　　求所作成就
  依根本仪轨　　随意所愿乐
  皆悉得圆满　　此法殊胜力
  诸法无能胜　　设复越三昧
  及造诸罪业　　或宿曜加临
  若诸魔娆事　　入此曼拏罗
  所作皆成就　　依法得大利
  若或未曾入　　成就曼拏罗
  若作此坛法　　而实胜数倍

    一切相应仪轨分第二十三

尔时金刚手菩萨。复说一切如来三种大三昧最上秘密成就法。三种大三昧者。所谓佛宝法宝僧宝。是大妙乐是大究竟。最上寂静平等安住诸法出生。若有行人依法造[巾*((ㄇ@人)/登)]像。内画三宝。如菩萨相被金刚甲。执金刚器仗持众妙宝。以此画像即成最上曼拏罗。然后选择胜处宫殿精舍。严饰其地香花罗列行人依法而作成就即得圆满

即说一切如来三种大三昧最上心明曰

唵(引)部(引)亢(一句)

说此明已复说此大明曰

怛堆那婆誐嚩睹醯(一句)冒地萨埵萨怛(二合)他誐多(二)耨捺哩(二合)瑟致(二合)难醯多(引)哩他(二合引)野(三)儞哩蜜哩(三合)钉捺哩设(二合)炀爹弥(四)阿尸沙尾那踰女誐(五)祢哩(二合)茶儞室左(二合)野嚩哩弥(二合)多(引六)阿颠多婆嚩嚩(引)萨(引)誐啰(二合七)儞嚩驮哥嚩左(引)捺野(八)怛哩(二合)啰怛那(二合)多(引)目钵誐多(引九)没驮达哩摩(二合)誐拏(引)伊底(十)阿颠多婆嚩僧悉驮(十一)尾戍驮室哩(二合)哥啰(引)钵啰(引十)(二)伊底萨哩嚩(二合)怛他(引)誐多钵啰摩虞呬也(二合)嚩日朗(二合十三)阿他钵啰摩虞呬也(二合)达哩摩(二合)多(引十四)健吒(引)阿(引)哥(引)舍洛叉赧(十五)萨哩嚩(二合)摩(引)哥(引)商左(引)必也(二合)洛叉赧(十六)阿(引)哥(引)舍三摩多(引)踰(引)誐(引十七)萨哩嚩(二合引)誐啰(二合)三摩多(引)塞普(二合)致(引)底(十八)钵啰(二合)倪也(二合)播(引)啰蜜多(引十九)阿他摩贺(引)三摩野嚩啰弥底(二十)萨哩嚩(二合)部(引)仵(引)钵部碍萨睹(二合)细(引)咩摩(引)乃莎摩(引)咄摩(二合)那(二十一)底哩(二合)啰怛那(二合)布(引)惹(引)波囕摩(引)葛噜弥(引)底嚩捺(引)摩贺弥底(二十二)

如是诸佛心明能作成就法。以此方便设诸仪轨。依法而作随意成就。若人设受五欲乐。建此曼拏罗随其所愿皆得成就

又复此诸佛最上秘密三种三昧心明及印相等法。当传诸弟子亦令随意而求成就。若时弟子依此秘密仪。当设种种微妙供养于佛法僧及阿阇梨。以殷重心求诸成就。若自作若为他作。皆令得成

复说金刚手忿怒明王最上秘密仪。行人依本法画忿怒明王。色如金刚火大日轮。坐众色莲华。于莲华上明王左右。画四亲近菩萨。其左一作绿色。第二作金色。其右一作红白色。第二青白色。复于左右画四菩萨各持本幖帜。谓金刚杖轮铃幡等。各作喜怒相安住本法。即说彼心明曰

吽(引一句)乌波纥哩(二合)捺野呬(引二)

行人当手持金刚铃杵诵此心明。安置贤圣时。即得[巾*((ㄇ@人)/登)]像法圆就。如是安置已。即成最上秘密曼拏罗。然后依仪法当诵三昧明曰

[寧*也]爹啰(引)瞿捺婆(二合)嚩骨噜(二合)驮(一句)嚩日啰(二合)(引)儗儞(二合)塞健(二合)驮母哩多(二合)野(二)钵啰(二合)祢(引)钵多(二合)嚩日啰(二合)摩贺(引)喻誐(三)拏(引)吉儞也(二合引)萨哩嚩(二合)睹入嚩(二合)攞伊底嚩日朗(二合)(四)阿他达哩摩(二合)阿(引)哥(引)舍洛叉赧(五)萨哩嚩(二合)摩(引)哥(引)商左(引)鳖洛叉拏(六)摩(引)哥(引)舍三满多踰儗(七)萨哩嚩(二合)弥嚩(引)怛啰(二合)娑(引)达曳(八)萨哩嚩(二合引)哥(引)舍(引)誐啰(二合)踰儗那(九)萨哩嚩(二合引)哥(引)舍弥底没噜(二合)鑁(十)母捺哩(二合)旦嚩日啰(二合)母捺啰(二合引)鼻(十一)怛哩(二合)路哥摩毕婆叉曳祢底(十二)

此金刚贤圣最上秘密三昧明诵已。然后依如来部仪轨而用本印。献金刚歌舞等供养。行人依法作此成就者。悉得如意

复说观自在菩萨最上秘密调伏仪。行人当作[巾*((ㄇ@人)/登)]像内画观自在菩萨。如闪电光轮作金刚舞势。具足百臂圆如轮相。手持莲华等诸幖帜。于菩萨周匝画颦眉等贤圣。皆作忿怒相。亦持莲华并诸幖帜。如是依法画已。即成曼拏罗。然后于像前诵此一切法金刚三昧明曰

怛堆那婆誐鑁(引)没驮(一句)阿嚩路吉帝说啰(二)哥噜底尾那踰播(引)野(三)戍地讫哩(二合)拏(引)钵啰(二合)那哩底(二合)多(四)弥底钵啰忙嚩日朗(二合五)拽他(引)啰葛旦(二合)醯哥摩朗(六)啰(引)誐奴晒哩那(二合)隶鳖帝(七)哩嚩(二合引)萨奴晒哩嚩(二合)虎尾台(八)萨怛(二合)他(引)戍唐怛哩(二合)驮(引)睹(引)哥(九)弥底钵啰摩虞呬也(二合)达哩摩(二合)多(十)健吒(引)曳那曳乃嚩尾地那(十一)惹誐地那野摩(引)嚩呬钵捺摩(二合)戍[亭*也]誐啰(二合)踰誐(引)怛摩(二合引十二)帝那帝乃嚩输达曳祢底(十三)

如是一切法金刚三昧大明诵已。依莲华部法作种种供养。所作皆成就

复说虚空藏菩萨成就一切仪轨[巾*((ㄇ@人)/登)]像法。当于[巾*((ㄇ@人)/登)]内依法画大日轮。于轮中画虚空藏菩萨。身如琉璃色。而坐众色莲华。于其华上菩萨左右。画四亲近菩萨。谓灌顶菩萨。宝藏菩萨。宝幢菩萨。大供养菩萨。如是画已。即成最上曼拏罗。此微妙金刚大日轮普照如来虚空藏菩萨。善满一切愿法宝秘密铃。善施一切欲。所有胜义意愿最上成就等。皆由此法。获诸解脱妙乐遂诸意欲。若自作或为他作。悉皆圆满此最上三昧。以此法故速能成就金刚萨埵。此法于诸仪轨中成就最胜故

复说一切成就金刚萨埵最上大印三昧仪轨。若有下根众生。造诸罪业作不饶益行者。见此法已罪业销灭。得成大菩萨而能饶益众生起大方便。如金刚萨埵住坚固真实三业。不越于三昧安住金刚界。然后当传大印。受大印已获得一切成就。此大印法。至如诸佛亦不敢越于三昧。诸求金刚萨埵乃至求成佛者。纵经俱胝劫而不能得。若以此最上大印力故。速能得成就诸佛菩萨。而能随其所化众生所有意愿。当为说诸成就法。此大印者是大方便。善能圆满诸法故。所以者何。结此大印时。诸佛菩萨皆悉云集。于刹那间施诸所欲。如是施已复赞叹言。金刚萨埵是最上善巧微妙甚深。广大清净无所有性。无尽无竭最上至极。出生尽虚空界大乐适悦。决定不空尽诸众生。最胜成就是大自在。以微妙字出生一切义。以金刚觉悟法令诸众生悟最上大乐。以金刚秘密具令诸众生安住第一法。即说一切如来三昧成就最上秘密仪。行人常于清旦时。依法结大印持诵心明。即得成就一切印

又复最上秘密成就法。行人依法执金刚铃杵。当诵三种三昧明。所求成就皆得圆满

又复依法执持金刚铃杵。当结毗首印持诵明者。即得诸印相成就。其身得如金刚萨埵。所有大自在成就法。皆悉施之。其诸印相速得圆满。乃至诸成就法皆亦得成。随其意愿无不成者

复说最上秘密一切相应仪轨法门。所言相应者谓诸法之用。谓从相应法出生诸界故。云何出生。谓从本尊正念出生故。又复云何名为相应。谓即语也。语体即声。声者即大相应理也。相应理者即是本尊正念。由是相应是即本尊出生。本尊出生故是名相应成就。又此相应者。所谓聚集相应一切印法相应等。言聚集相应者。谓诸法和合是名聚集相应。譬如世间多财聚集。诸法和合亦复如是。聚集一切印法三昧等。是名聚集相应

又复一切印法相应者。谓十方诸佛如体如相名一切印法。此用者即最上成就故。谓诸贤圣所有本印。由此本印当各用故。从是出生大相应法最上秘密成就。行人当观如本尊印法相应。次想己身亦复如是。即得圆证诸佛菩萨位故。诸最上秘密成就仪。是甚深最上成就法。当如本尊相应摄大毗首印。行人当观己身亦复如是。得成微妙字。此诸法中最胜。是大毗首三昧最上相应摄诸悦乐法。又此最上秘密成就仪法中最上成就法。当如金刚萨埵根本相应如体如相。行人当想己身亦如是。得成微妙字义。由是获诸佛清净三昧。即成一切相应主。诸成就中最如是相应法。诸有所作无不成者。设受五欲乐但想如本尊相应。此即一切如来最上秘密无上大乘清净大三昧。所有诸如来大乐根本相应。即是金刚决定三昧。此相应法是大良药。有最胜功能故。是成就中一切得自在。行人当知若修此相应者。即得如金刚萨埵精进悦乐而能增长。色力寿命。所有一切成就仪法。于刹那间皆悉圆满。何以故修如是相应大印。住如是相应。即依本尊相应成就仪。而作相应三昧成就事故。又复行人当知。心如幻化而无定止。身如器具造作所成。身非觉知与心相离故亦非相离故。此印法相应亦复如是。譬如色心之法本非一故。身心合和作诸事业。印法相应和合亦尔。如是三昧及此相应互作成就。若诸行人以无我法。修诸相应成就事者。此诸行人即是如来

又复一切印相应者。谓印体具大乐坚固。由是大乐坚固。成就诸乐相应事。若诸行人勤求此最上秘密成就法者。但当精进发菩提心至意专勤。勿以苦节加行。而令疲极则生退转。但以悦乐心与大乐相应当作成就。是名一切印相应法

又复乐相应者。能作成就事。谓诸乐法随宜而受。如本尊相应大乐法故。一切如来最上秘密无上大乘大教王。是金刚萨埵最上大乐相应法故

又复一切适悦相应者。谓一切三昧相应成就故。行人修此法者。当与适悦心相应。何以故若勤苦加行。即于自体而生困苦。由是于法而生散乱。不能专注作诸成就。是故修相应行者。随意随力而于饮食受用。乃至四威仪中戏笑语言。于一切处无复挂碍。设有未入曼拏罗及有诸障恼。但当依本尊相应行修成就法者。于刹那间。皆悉圆满此大欲乐三昧自在主诸金刚部王。若求证诸佛及诸大菩萨。由此相应法尚得成就。何况求诸成就事。此决定成就法。一切皆得成。能成诸密印能尽苦边际。以此相应微妙。是名金刚萨埵最上适悦法

又复一切坚固相应者。谓一切法自性坚固。原始至终唯一真智。自性坚固自体无别故

又复一切坚固授记相应者。谓依本尊相应大智方便。当作一切法求诸成就事决定圆满。是为坚固授记相应。又最上秘密坚固授记相应者。即金刚萨埵大相应法。作诸供养求种种事皆得圆满。是名授记相应。即说颂曰

  此真理最上　　微妙相应法
  甚深秘密中　　最尊胜无比
  若大阿阇梨　　及上智弟子
  有大菩提心　　授此相应法
  若遇无智人　　虽爱乐成就
  于法无信解　　勿得传授之
  此法非难成　　非勤苦加行
  但依法轨仪　　而善作成就
  起精进所修　　是人获大利
  解脱诸魔事　　诸天不能见
  是金刚萨埵　　成佛菩萨道
  此最上相应　　皆悉得圆满

佛说最上根本大乐金刚不空三昧大教王经卷第六佛说最上根本大乐金刚不空三昧大教王经卷第七

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

    最上成就印相分第二十四

尔时金刚手菩萨。宣说此决定不空最上善巧微妙广大不可思议甚深之法。所有尽无尽成就法。皆悉能成。行人当随意随处。结跏趺坐心意调柔。然后以左手结坚固一切智印。安于左胯之侧。右手戏掷金刚杵。以金刚三业成就故。是即金刚萨埵。依如是法仪。速成坚固不退。乃至诸大菩萨及如来地。于诸成就得大自在。如是金刚萨埵一切处坚固。行人设复未入曼拏罗。修此大印者。得诸佛恭敬供养。获一切圣财大乐自在。此大秘密印三界中最上。成就此大印。与金刚萨埵等无有异。所有诸成就及种种事业大妙乐等。以此大印故皆悉圆满。所求之法无不成就

复说金刚萨埵根本大印。以此印故。于一切曼拏罗。所有三昧钩召入寤敬爱等。种种成就法皆得圆满。亦名金刚秘密三昧印。其印当十指相合。名为金刚合掌。又复十指相交如拳。名为金刚缚。以此金刚缚。展二头指及二拇指。复屈二中指入于掌内。与二拇指相捻。二头指平正如金刚杵。是名金刚萨埵根本大印。即此根本大印。复二中指如钩。安于本心如作钩召势。是名金刚钩印。此金刚钩印。与金刚萨埵作大爱乐。若用此钩印及心明作钩召时。金刚萨埵生大爱敬。速降曼拏罗。当得金刚萨埵大欲大乐。如是钩召已。所有一切如来及诸菩萨乃至一切有情。悉皆平等速得钩召。若钩召不降赴者速得破坏

复说大乐金刚三昧心阏伽印。先当二手作如金刚钵相。然结前金刚印。后以二中指如花枝。当以心明加持。以此三昧阏伽印。若授灌顶者。是人得一切自在。此印功用亦如前印。于一切法皆得用之

复说入曼拏罗幡印。当右手竖三指如幡。拇指与小指头相捻。作嬉戏歌舞。入于曼拏罗而先顶礼本尊。若结此印入曼拏罗者。即成金刚阿阇梨定成供养事。然后随力随意。以香华幖帜等当献供养。复用结幡印。顶礼于本尊而发是言。我今顶礼本尊。言已即作金刚合掌安于顶上。顶礼金刚萨埵及诸如来而伸称赞。然后二手作金刚缚。拇指相交。各屈头指。安自顶上如戴宝冠。复改金刚拳。于顶左右而作系鬘相。复如垂带势。作是印法已。当想如金刚萨埵授已灌顶。然后以大乐金刚甘露水自灌其顶。作灌顶已。所有金刚阿阇梨法皆得成就

又复若为弟子授灌顶者。当以金刚合掌作顶礼印。以众妙花授与灌顶。如是印法及诸曼拏罗仪。即成一切成就自在。是名金刚萨埵印成就仪

复说印法。若欲召请金刚萨埵者。行人当跏趺而坐。结大乐秘密金刚钩印。及诵心明而作钩召。然后依法献种种歌舞等供养而伸称赞。复结嬉戏印作礼持诵。以金刚歌舞等供养故。所作之法即得成就。即说最上秘密金刚歌曰

萨哩嚩(二合引)努啰(引)誐稣珂素(引)怛摩(二合)那娑(引一句)怛鑁(二合)嚩日啰(二合)萨埵波啰摩稣啰多(二)婆嚩弥(引)摩贺(引)稣珂涅哩(二合)除(引)萨啰(二合)野捺(三)钵啰(二合)底钵爹悉[亭*也]左罗具钵啰(二合)拏多(四)

如是金刚歌。若常赞咏者。得大乐尊坚固爱敬作诸成就。此大秘密歌常持于本心。若于赞叹时令唇齿相合。依诸仪轨不离金刚语。善成诸部法咏吽字等歌。随力而作随其所欲。以调顺语业微出其声。令梵音和雅歌咏金刚萨埵法。此最上成就歌。当于一切处随意持诵。当用金刚萨埵大印。其印左手作智拳。右手持金刚杵。以此印明当作成就法

如是等印皆依本尊法。及用心明所作皆成复说一切如来印相。其印以二手。先作一切如来金刚智拳。如金刚宝灌顶法而作灌顶。灌于五处。复作合掌如供养势。磔开其手却作二拳。左拳向外竖立头指。右拳向内安于本心。成印。此一切如来智拳大印。是决定不空。结此印时获不退地。当证阿耨多罗三藐三菩提。是人不可见远离诸禁缚。乃至诸魔军亦不能娆乱又复结此印者。当观如佛。若供养此人。当如供养诸佛菩萨。如是大印仪。所有三昧印莲华印金刚印。皆亦如是所谓羯磨印者。先二手平仰。二拇指舒向于头指。安于本心已。复作如宝灌顶成印

又复如前二手平仰各微屈头节。二中指相结如金刚莲华。即成法印。即说此印明曰

阿(引)呼(引)怛囕(二合引)纥哩(二合引)吽(引一句)

又复改羯磨印。以左手作金刚拳。屈拇指入拳内。此成一切如来智拳大印

又复以右手如捻衣角。钩于本心。而复展手作触地相。此成降诸魔军印

又复不改此印。而复仰手成印。是名出生印。亦名施愿印。亦名授记印。复以此印作捻衣角。如开莲华势成印。是名出生法印。亦名清净诸法印。复以此印。竖三指如幡即成幡印。结此印。时所有愿求决定成就

复说一切如来智拳大羯磨印成就。若用此印安病人身其病即差。若安于心诸毒销除。乃至邪印法等悉皆灭坏。即说明曰

唵(引)吽(引一句)

用此明同前羯磨印法。功能成就。若结印持诵此明。旋转于身获大辩才。所有一切如来最上大密印。悉得坚固。如是若安于诸根得诸根圆满。若称念诸佛已。旋转诸方复安于本心。或自求成就或为他作。皆悉得大悦乐。乃至证佛菩提。若结此印观想诸佛。当了五蕴如陶师轮。然后身作礼敬口诵大明一心正念观想。住于舍念戒精进慈定智慧方便力。坚固出生陀罗尼门。满足十地行四无碍解十八不共法。以毗首羯磨法广饶益众生。以金刚三业作大佛事。即说诸大明曰

唵(引)冒地唧多嚩日哩(二合引一句)

唵(引)三满多跋[打-丁+柰]啰(二合)左哩曳(二合一句)

唵(引)进多(引)摩尼(一句)

唵(引)阿[寧*也]噜提(一句)

唵(引)惹(引)底尾嚩哩帝(二合引一句)

唵(引)萨哩嚩(二合)尾倪也(二合)儞(引一句)

唵(引)尾啰(引)誐达哩摩(二合)帝(一句)

唵(引)尾(引)哩也(二合)葛嚩济(引一句)

唵(引)萨哩嚩(二合)誐(引)弥儞(引一句)

唵(引)嚩日啰(二合)[打-丁+柰]哩(二合)茶唧帝吽(一句)

唵(引)萨哩嚩(二合)怛他(引)誐帝(一句)

唵(引)莎婆(引)嚩戍驮达哩摩(二合)多(引)倪也(二合引)那尾戍地(一句)

唵(引)达哩摩(二合)尾输驮[寧*也](一句)

唵(引)尾逊婆嚩日哩(二合)尼发吒(半音一句)

唵(引)哥(引)摩啰(引)儗(引一句)

唵(引)[口*弱]嚩日哩(二合引一句)

唵(引)吽萨哩嚩(二合)[打-丁+柰](引)摩[寧*也]

唵(引)纥哩(二合一句)

唵(引)阿哥(引)啰目契(引一句)

唵(引)钵啰(二合)倪也(二合引)播(引)啰弥帝(引一句)阿鑁吽唵(引)阿(引一句)

唵(引)萨哩嚩(二合)怛他(引)誐多哥(引)野(引)儗哩(二合引一句)

唵(引)萨哩嚩(二合)怛他(引)誐多嚩(引)儗尾(二合)戍地(引一句)

唵(引)萨哩嚩(二合)怛他(引)誐多唧多嚩日哩(二合引)

阿(引一句)

如是一切如来语印法鼓。出微妙之音有微妙之义。是大法语是诸佛心。能决定成就所作事业。当依法持诵念诸佛已。然后以一切如来正念及一切如来印。而作成就

复说金刚火焰日轮印相。先结金刚大印。复改作三昧印。后复作金刚缚已。诸指皆如火焰轮。二中指如金刚杵成印。此印能调伏三界。亦能作敬爱金刚萨埵

又复不改前印。左手作拳。头指竖立如期克相。右手如钩成印。是名降三界印。此印能钩召一切

又复二手作忿怒拳已。复作金刚钩。如期克相成印。是名金刚钩印。此印善作一切事。能作诸成就

又复作金刚合掌。十指如火焰成印。是名颦眉菩萨印。此印善作种种事。善调伏诸恶

又复作金刚合掌。复左手如钩势成印。此印能钩召一切。亦能作入寤法。悉得成就

又复左手作金刚拳。右手如三叉成印。此印能脱一切枷锁禁缚

又复二手如开敷莲华成印。此印能断一切烦恼

又复二手作金刚缚。二拇指相并成印。亦名降三界印。此印善作钩召调伏最上成就

又复右手头指。钩左手头指。如挽弓势成印。此印善作钩召。亦能作诸敬爱

又复如降三界印。右手作金刚拳展臂。以小指安左手背成印。此印善破诸恶邪印。善作诸成就

又复二手作金刚缚。柔软紧密成印。是名金刚成就印

又复二手作金刚缚。二拇指与头指。如金刚杵成印。此印能破坏诸恶。所有幡印与铃印。皆作最胜法。亦能破坏诸恶。三界中殊胜。是金刚萨埵灌顶印

又复金刚部贤圣印。二手作金刚拳。依此法仪本部贤圣。以金刚宝作灌顶。作金刚合掌。以净帛覆面。二拇指如金刚。当作金刚灌顶已。然后依法作礼。受持金刚杵。乃随力献阿阇梨供养。即得成一切法

如是等诸部印相。皆依法结同大明用。即得所作成就

    最上秘密仪轨分第二十五

  尔时诸如来　　及大菩萨众
  金刚贤圣等　　共异口同音
  发如是问言　　金刚手菩萨
  如仁者所说　　最上羯磨法
  善作诸成就　　其所说仪轨
  微妙真实理　　从无相之法
  而现诸仪轨　　是仪轨云何
  何名最上教　　复何为根本
  何名本无有　　复名金刚手
  以何为大欲　　复何名大乐
  何名为善贤　　何名高举势
  何名诸法中　　自在金刚手
  内外大心明　　云何而出生
  根本微妙歌　　何说复何义
  大金刚三昧　　此法名何等
  云何菩提心　　云何三摩地
  云何菩提行　　以何降魔军
  云何证菩提　　云何本部生
  云何欲解脱　　何者三种名
  云何一切处　　大金刚大乐
  何不空三昧　　何八曼拏罗
  当有何果利　　及成就仪轨
  大秘密真理　　以何而演说
  云何本尊法　　诸部复云何
  云何灌顶理　　云何贤圣众
  云何五秘密　　何名虚空藏
  如何幖帜法　　一切钩召法
  云何诸供养　　云何见前法
  云何成就仪　　云何非勤苦
  如是诸秘密　　最上真实理
  为成微妙字　　而广利众生
  如上为宣说　　是时金刚手
  受诸佛劝请　　为利众生故
  而说如上法

  所言仪轨者　　谓诸法仪轨
  是无仪轨法　　饶益诸众生
  而现诸仪轨　　由如是仪轨
  清净诸法故

  言最上教者　　谓摄一切法
  出生佛菩萨　　秘密真实理
  是名最上教

  所言根本者　　谓即真实智
  遍满虚空界　　如金刚坚固
  是大欲大乐　　最上微妙字
  即金刚萨埵　　诸仪轨实理
  所言本无者　　如虚空本性
  谓金刚萨埵　　是大坚固身
  是名本无有　　言金刚手者
  是即大自在　　善施诸成就
  是金刚部主　　爱乐微妙字
  所言大欲者　　谓离诸过失
  了达究竟法　　是名为大欲
  所言大乐者　　谓真实妙理
  即金刚萨埵　　出生所依故
  所言善贤者　　谓清净法界
  解脱诸如来　　遍满普贤身
  其高举势者　　谓所有成就
  最上自在印　　钩召诸成就
  是名高举势

  所言诸法中　　自在金刚手
  谓即根本教　　真实微妙理
  若至心诵持　　获一切功德
  是名诸法中　　自在金刚手
  所言菩提心　　谓不可思议
  广大甚深法　　成就诸妙乐
  能变化一切　　清净菩提心
  由是而坚固　　作诸殊胜业
  安住三摩地　　即此三摩地
  金刚智出生　　从金刚所生
  名金刚萨埵　　此即诸佛身
  是名菩提心

  所言大金刚　　谓摄诸有情
  令修我教法　　秘密真实理
  若常修习者　　即成大金刚
  所言菩提行　　谓观诸有情
  染着诸烦恼　　为利益彼故
  常行普贤行　　是名菩提行
  所言降魔者　　谓即诸魔心
  是心即如来　　若能调伏心
  无复诸魔娆　　是即降魔军
  所言证菩提　　谓解悟本心
  坚固菩提智　　了真实妙理
  即成等正觉　　是名证菩提
  又言金刚手　　谓调伏诸恶
  令迷者悟解　　诸佛金刚杵
  坚固菩提心　　诸佛所付授
  是法界真理　　受持为器仗
  成就诸法故　　是名金刚手
  所言本部生　　谓智度为母
  方便解为父　　从金刚手法
  出生诸部法　　是名本部生
  所言欲解脱　　谓大欲大乐
  善获诸成就　　诸成就乐句
  是即大乐法　　是名欲解脱
  所言三种名　　谓三世无边
  而悉能调伏　　而作三界主
  复名为三宝　　复名为三界
  能作诸成坏　　是为三种名
  所言一切处　　大金刚大乐
  谓一切有情　　欲广大利益
  其心无定止　　若于一切处
  安住坚固心　　了达真实义
  是名一切处

  所言根本歌　　及内外心明
  谓三有最胜　　成就大自在
  菩萨利有情　　是大欲大乐
  秘密微妙句　　吽字歌心明
  乃至外心明　　皆真实理智
  以外秘密心　　而生悦乐故
  所作皆成就　　名根本歌等
  其不空三昧　　谓作成就法
  以微妙大乐　　所作获成就
  非勤苦而得　　此大三昧法
  诸佛不能越　　名不空三昧
  八曼拏罗者　　谓随其处所
  但以随分力　　各称彼根性
  随时作诸法　　即现贤圣众
  其所得果报　　获大究竟福
  作此曼拏罗　　先观察十方
  当从北起首　　而乃絣四线
  分列八坛相　　皆依本仪法
  依本尊相应　　想成曼拏罗
  作诸成就法　　即此曼拏罗
  是大真实理

  所言大秘密　　谓诸秘密法
  而本无所有　　是大乐金刚
  即同普贤身　　金刚众大主
  是名大秘密
  所言本尊法　　谓根本最胜
  曼拏罗之主　　是最上大欲
  是大适悦心　　而常现笑容
  其身如月色　　众宝严身相
  光明普照耀　　是三有最胜
  施诸妙乐境　　善成微妙句
  故号为本尊

  所言灌顶理　　谓佛宝功德
  三界无比法　　唯此宝最胜
  受佛灌顶者　　而证法王位
  是名灌顶理

  所言三摩地　　当结跏趺坐
  而结禅定印　　以左手押右
  观想金刚手　　是名三摩地
  所言贤圣众　　谓金刚贤圣
  是真实义智　　善悟解一切
  诸成就最胜　　一切大吉祥
  具诸法圣财　　一切法中最
  所有成就法　　皆贤圣印相
  即金刚萨埵　　秘密大主宰
  所言五秘密　　谓毗卢遮那
  及不动如来　　宝生无量寿
  不空成就等　　是名五秘密
  所言诸部者　　谓一切如来
  真实之妙理　　成金刚萨埵
  毗卢遮那佛　　不动如来部
  宝生无量寿　　不空成就等
  真理亦如是　　又金刚部主
  善调诸恶者　　以纯善方便
  如日而普照　　此金刚部尊
  饶益诸有情　　善成诸教法
  毗首金刚部　　是摄大方便
  观自在菩萨　　依众莲华部
  获最上成就　　观自在菩萨
  即金刚萨埵　　莲华部真理
  摄三摩地智　　莲华部清净
  能净诸有情

  所言虚空藏　　谓即大圣财
  遍满于虚空　　虚空藏菩萨
  是大灌顶法　　所有宝生部
  是无尽宝藏　　大灌顶法幢
  善摄一切愿　　即金刚萨埵
  于诸曼拏罗　　常施真实理
  金刚部灌顶　　宝生无量寿
  真理亦如是

  根本诸幖帜　　是最上成就
  以妙真实理　　是自在器仗
  五种大秘密　　即是金刚杵
  其诸部幖帜　　谓真实理智
  诸佛毗首行　　即证大菩提
  而彼金刚部　　宝部莲华部
  善摄一切义　　成就秘密法
  所言钩召法　　谓诸秘密仪
  以金刚钩铃　　而作于钩召
  所言诸供养　　谓诸秘密仪
  适悦而供养　　种种歌舞等
  所言见前法　　谓诸秘密仪
  各用于本印　　然后当一心
  持诵真实理　　又复诸如来
  诸成就见前　　以大三昧法
  真实微妙理　　是根本真空
  金刚萨埵性　　是即普贤身
  亦为金刚主

  所言成就法　　谓诸仪轨中
  所作成就事　　当依本尊法
  而作诸成就　　但随所住处
  诸仪轨皆成　　依法持铃杵
  觉悟于世间　　欲成就诸法
  速成根本教

  所言非勤苦　　谓所作成就
  而不须加行　　随意随处所
  随欲随饮食　　乃至四威仪
  语言及戏笑　　但发至诚心
  住等引相应　　依本尊仪法
  如是相应理　　速成一切法
  此根本大教　　是甚深秘密
  若依法修习　　所愿皆圆满
  所有诸如来　　及诸大菩萨
  常受持此法　　是最上大乐
  真实微妙句　　大欲大妙乐

佛说最上根本大乐金刚不空三昧大教王经卷第七


光赞经

    No. 222 [Nos. 220(2), 221, 223]

光赞经卷第一

        西晋三藏竺法护译

    摩诃般若波罗蜜光赞品第一

闻如是。一时佛游罗阅只耆阇崛山中。与摩诃比丘僧五千俱。皆阿罗汉也。诸漏已尽无有尘垢。而得自在心安解脱智慧善度逮得仁和。为大开导所作已办。所设究竟弃捐重担。逮得己利除终始患。平等解脱济一切想得度无极。唯除一人贤者阿难学须陀洹。复与五百比丘俱。及比丘尼优婆塞优婆夷皆悉现在。并诸菩萨摩诃萨。得诸总持逮成三昧。修于空行尊于无想。不念众愿以得等忍。制览无数皆得五通。所言聪捷无有懈怠。蠲舍家利所慕之心。所说经法不侥供养。致深妙法度于无极。得无所畏超越魔事。脱于一切阴盖之碍。讲诸因缘心志所趣。从无数劫精进行愿。其意所向喜悦问讯常先于人。离于结恨入于无数众会之中。威势巍巍无所畏难。忆念无量垓劫之事。若说经法晓练众义。犹如幻化野马水月梦与影响若镜中像勇猛无侣。以微妙慧知众生心所起所行。超度分别。意不怀害殷勤忍辱具足所行晓了审谛所当度者。摄取佛土无限之愿。常三昧定。目睹无数诸佛世界。畅达宜便启请无量诸佛世尊。进退能决若干种见所著之处。定意自娱解百千行。诸菩萨者德皆如是。其名曰颰陀和菩萨。罗邻那竭菩萨。摩诃须菩和菩萨。那罗达菩萨。娇日兜菩萨。和轮调菩萨。因坻菩萨。贤守菩萨。妙意菩萨。持意菩萨。增意菩萨。不虚见菩萨。立愿菩萨。周旋菩萨。常精进应菩萨。不置远菩萨。日盛菩萨。无吾我菩萨光世音菩萨。渐首菩萨。宝印首菩萨。常举手菩萨。常下手菩萨。慈氏菩萨。诸菩萨众如是难限。不可计数亿百千垓。一切妙德清净同真。尔时世尊。坐于自然师子床座而结加趺正身而处。心有所向制立其意。有三昧名定意王。以时三昧自然正受。则皆普入一切定意。救摄平等御而趣之。佛适三昧其心安寂。而以道眼观斯世界。其身湛然而笑。从其足心放六万亿百千光明。十足指放十亿百千光明。两胁放二亿百千光明。两膝放二亿百千光明。两脚放二亿百千光明。两肩放二亿百千光明。两肘放二亿百千光明。脐放二亿百千光明。头放亿百千光明。两手指放十亿百千光明。两臂放二亿百千光明。两眉放二亿百千光明。项放亿百千光明。两眼放二亿百千光明。两耳放二亿百千光明。鼻放亿百千光明。四面放四百亿百千光明。四十齿放四十亿百千光明。眉间相放亿百千光明顶结相放六万亿百千光明。照此三千大千世界无所不周。普曜东方江河沙等诸佛国土。南方西方北方四隅上下皆亦如是。其有众生蒙值光明心皆恬怕。悉发无上正真之道。于是世尊即时欣笑。从诸毛孔放众光明。照此三千大千世界。普遍十方无不周接。江河沙等诸佛世界。其有群萌为光所照悉皆寂然。存于无上正真之道。是时世尊。则演如来清净真妙志性光明。照此三千大千世界。普及十方各江河沙等诸佛国土。假令人民逮斯光者。则皆究竟至于无上正真之道。于是世尊。从其舌本悉覆佛土。而出无数亿百千光明。照此三千大千世界。周遍十方各江河沙等诸佛国土。其光明中自然而。殖金宝莲华。其莲华上各有诸佛。结加趺坐宝莲华。讲说经法演于六波罗蜜。十方一切亦复如是。若有众生闻斯法讲。一切究竟皆得坚住阿耨多罗三耶三菩。于是世尊坐师子床。有三昧名师子娱乐。以斯定意自然正受。如其色像。咸演威曜示现神足。三千大千世界六反震动。边际亦摇。中顺至边安和柔软。愍伤一切众生之类。令获安隐快乐无患。尔时三千大千世界地狱饿鬼畜生。诸不闲者恐懅厄者。自然为断三涂除已悉自致来。得生为人四天王忉利天盐天兜术天尼摩罗天波罗尼蜜天。于时诸天适生彼间人中天上。即识宿命欢喜悦豫。往诣佛所稽首足下叉手归命。十方一切亦复如是等无差特。尔时此三千世界众生之类。盲者得目而睹色像。聋者彻听闻诸音声。志乱意惑还复其心。迷愤者则时得定。其裸形者自然衣服。其饥虚者自然饱满。其消渴者无所思侥。其疾病者而得除愈。身瑕玼者诸根具足。其疲极者自然得解。久猗身者则无所猗。一切众生得平等心。展转相瞻如父如母如兄如弟如姊如妹。各各同心等无偏邪皆行慈心。一切群萌悉修十善清净梵行无有尘埃。一切黎庶悉获安隐。所得安隐犹如比丘得第三禅。于时众生而致智慧。而悉具足善快调定。离于卑劣逮得和雅。于是世尊。在师子床处于三千大千世界。而最超异威神巍巍。光耀煌煌无有畏惧。圣明辉赫尊颜具足。无不周普照于东方江河沙等诸佛世界。八维上下各江河沙等世尊国土。如须弥山超踰一切诸山之上。明在所通。于是世尊承如来旨已自然圣。令三千大千世界众生悉共瞻睹。时此世界。首陀卫净居诸天梵天波罗尼蜜天尼摩罗天兜术天盐天忉利天四天王天。及三千大千世界所居人民。自然见身亲近如来。皆得自然天华傅饰天香天杂香天捣香天青莲芙蓉鲜华。诸妙天华茎叶具足。各各发行赍诣如来。稽首佛足各散佛上。及于人间。水陆诸花各各手执。往诣世尊而为供养。诸天人民。所散供养诸华之具上在虚空。三千大千世界化为宫殿自然楼观。从其宫殿垂诸天华缯盖幢幡。纷葩飘扬显灼普现。其诸花香庄严三千大千佛国。自然巍巍。形像众色如紫磨金。八维上下芬馥晃昱亦复如是。于是阎浮提城所有人民。瞻睹如来现身威变不可称计。各心念言。今日如来坐于我前。普佛国土亦复如是。各各心念。今日如来在我前坐而说经法。于时世尊。在师子床更复欣笑。加复重照三千大千世界。弘光赫弈。此土人民悉共睹见东方江河沙等诸佛国土现在如来至真等正觉与诸菩萨声闻之众。又复东方江河沙等诸佛世界所有众生。悉亦遥见此佛国土释迦文佛与比丘僧及诸菩萨而坐说经。八维上下亦复如是。悉遥见此等无差特。于是过东方江河沙等诸佛世界。最边国土名宝迹。其佛号宝事如来至真等正觉。今现在为诸众生。亦复讲说摩诃般若波罗蜜经。彼时其佛世界。而有菩萨号曰普明。睹大光明及地大动。即便往诣宝事如来。稽首问曰。唯然世尊。以何因缘。其大光明照此佛土地大震动。诸如来身自然为见。会当有意。彼佛告于普明菩萨曰。族姓子。欲知西方极远有忍世界。其佛号曰释迦文如来。今现在为诸菩萨说般若波罗蜜。是其威神光也。普明菩萨。白宝事如来。唯然世尊。我欲诣彼见释迦牟尼如来。稽首作礼。及诸菩萨摩诃萨众童真等。得总持究竟三昧。定意自在得度无极。释迦牟多阿竭阿罗诃三耶三佛。宝事如来阿罗呵三耶三佛。告普明菩萨曰。往善男子。汝知是时宝事如来赐普明菩萨金色莲华而有千叶。取善男子。此宝莲华以用供散释迦牟如来。善男子。欲往修寂然行。忍界菩萨生彼土者。甚有患难亦难值遇。普明菩萨。即受其金色莲华。与无央数亿百千垓诸菩萨众男女大小居家出家。则以供养东方诸佛天中天。承事归命。上诸华香杂香捣香。次复诣释迦牟如来。稽首足下却住一面。普明菩萨白世尊曰。唯然大圣。宝事如来敬问无量。乞求轻便力行安乎。又复遣进金色莲华。佛受莲华。寻以遥散东方江河沙诸佛国土。其华即时周遍东方诸佛世界。有佛坐于自然金色莲华讲说经法。亦复演斯六波罗蜜。其有众生闻此说者。一切究竟即时坚住于阿耨多罗三耶三菩。男女大小悉礼佛足。各以功德。供养多阿竭阿罗呵三耶三菩。南方去此江河沙等最极边际。有佛世界名曰离一切忧。其佛号无忧首多阿竭阿罗呵三耶三佛。彼有菩萨名离戚。启辞其佛。佛赐莲华。与无数菩萨俱。经诸国土供养诸佛。来诣释迦牟尼如来。稽首供养却坐听经。西方去此江河沙等。有世界名曰寂然。其佛号宝龙多阿竭阿罗呵三耶三佛。彼有菩萨名曰意行。启辞其佛。佛赐莲华。与无数菩萨俱。经诸国土供养诸佛。来诣释迦牟尼如来。稽首供养。却坐听经。北方去此江河沙等。有世界名曰致胜。其佛号胜诸根多阿竭阿罗诃三耶三佛。彼有菩萨名曰施胜。启辞其佛。佛赐莲华。与无数菩萨俱。经诸国土供养诸佛。诣释迦牟如来。稽首供养却坐听经。下方去此江河沙等。有世界名曰仁贤。其佛号贤首多阿竭阿罗呵三耶三佛。彼土有菩萨名曰莲华上。启辞其佛。佛赐莲华。与无数菩萨俱。经诸国土供养诸佛。诣释迦牟如来。稽首供养却坐听经。上方去此江河沙等。有世界名曰欣乐。其佛号乐首多阿竭阿罗呵三耶三佛。彼有菩萨名施乐。启辞其佛。佛赐莲华。与无数菩萨俱。经诸国土供养诸佛。诣释迦牟如来。稽首供养却坐听经。其四维者亦复如是等无差特。尔时于此三千大千世界。寻即而雨诸宝华香幡盖。自然庄严香树花树。譬如莲华迹世界普华多阿竭阿罗诃三耶三佛佛土。溥首菩萨所游居处。善住意诸天子及余大神。尊势无极菩萨之众。世尊所与。及余诸天世间人民皆来聚会。诸魔梵天并声闻众。揵沓和阿须伦神人民悉普来会。此诸菩萨摩诃萨。为童子时所服饮食功德自然。尔时世尊告贤者舍利弗。于斯若有菩萨摩诃萨。便当精修学般若波罗蜜。舍利弗白佛。唯然世尊。云何菩萨摩诃萨一切具足晓解诸法。学般若波罗蜜乎。佛告舍利弗。菩萨摩诃萨住于般若波罗蜜已修无处所。即便具足檀波罗蜜令不缺减。有所施与无所爱逆。尸波罗蜜当令具足。从是因缘。未曾住于罪不罪。亦当具足羼波罗蜜兴无嗔恚。当学惟逮波罗蜜。便得受决。从其身意兴诸精进。不起诸漏当具足禅波罗蜜。由是之故无所求慕。佛言。舍利弗。若菩萨摩诃萨住般若波罗蜜。则自具足于四意止。发无所发又当具足。得四意断四神足五根五力七觉八由行悉令具足。空无三昧。无想三昧。无愿三昧。而决具足。四禅四等四无色三昧及八脱门渐渐具足。而以正受以此为脱无所思想。无有内想。若供养想若光明想。无绛赤想。无腐败想。无有青想。无食啮创烂想。亦无乱想。无枯骨想。无星散想。无处所想。悉离诸想。常志于佛。念于经典。念于众僧。念于戒禁。意在惠施。志前诸天。出入之意死亡之意。无常之想苦乐之想。无非身之想。终始之想。一切世界无可乐想。诸习之想。灭尽之想。道慧尽慧。无热诸慧无所起慧。法慧于诸经法亦无所慧。亦无我慧无有内慧。微妙意慧晓了诸慧。如所谓慧悉以思念所行三昧。无想无念无行定者。而无有异。诸根为异异根异行。又复有行难所获致如来十力四无所畏四分别辩佛十八法不共之事大慈大悲。欲得晓了此一切缘。菩萨摩诃萨当行般若波罗蜜。若有具足诸道慧者。菩萨摩诃萨当行般若波罗蜜。欲晓了慧具足充备诸通慧者。当行般若波罗蜜。菩萨摩诃萨。若欲明了一切得近蠲除尘劳。菩萨摩诃萨当行般若波罗蜜。如是舍利弗菩萨摩诃萨。则为修学般若波罗蜜。佛复告舍利弗。若有菩萨摩诃萨。欲入寂然当学般若波罗蜜。菩萨摩诃萨。欲度声闻辟支佛地住阿惟越地者。当学般若波罗蜜。菩萨摩诃萨欲处六通。学般若波罗蜜。菩萨摩诃萨。欲知一切众生萨和萨心根所行者。当学般若波罗蜜。菩萨摩诃萨。欲过诸声闻辟支佛慧者。当学般若波罗蜜。菩萨摩诃萨欲逮总持门。若男子劝助布施。声闻辟支佛超越彼等。当学般若波罗蜜。菩萨摩诃萨。欲过一切声闻辟支佛戒禁劝助心意。当学般若波罗蜜。若欲具足三昧智慧解脱度知见慧。菩萨摩诃萨。当学般若波罗蜜。菩萨摩诃萨。欲成显于禅定三昧三摩越。劝助合集解心之念所。当学般若波罗蜜。菩萨摩诃萨。若欲劝助布施分别无限无量成就功德。当学般若波罗蜜。菩萨摩诃萨。若欲具足成就无限无量持戒忍辱精进一心智慧。当学般若波罗蜜。佛复语舍利弗。若有菩萨摩诃萨。欲具足立檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜行。一切所生得见诸佛自致成佛。当学般若波罗蜜。欲成三十二相八十种好。具足菩萨性若为真童。欲立此地不离诸佛世尊。所欲志念诸善德本供养如来奉持顺命其愿辄成。若欲具足一切众生心之所侥。饮食衣服车乘香华杂香涂香床卧灯火手巾履袜。所当得者充满诸财。当学般若波罗蜜。复次舍利弗。若菩萨摩诃萨。欲具足江河沙等众生劝立于檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜。当学般若波罗蜜。复次舍利弗。若菩萨摩诃萨。以一善本顺如来德。无有尽耗亦不缺减。乃至成阿耨多罗三耶三菩者。当学般若波罗蜜。复次舍利弗。若菩萨摩诃萨学般若波罗蜜。八维上下诸佛天中天。皆共歌诵其人功德。发意之顷东方江河沙等诸佛国土。欲游此界及至十方。当学般若波罗蜜。以一切音声。欲告江河沙诸佛国土东西南北四维上下。当学般若波罗蜜。复次舍利弗。若菩萨摩诃萨。欲建立诸佛国土令不断绝。欲住内空。若处外空。若内外空。若于空空。若于大空。究竟之空。所有空。无有空。有为空。无为空。若真空者。无祠祀空。无因缘空。因缘空。自然相空。一切法空。不可得空。无所有空。若自然空。无形自然空。因缘威神空。诸行相欲至此者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得亲近一切如来。欲得观解一切诸法。欲了诸法在于本际。当学般若波罗蜜。如是舍利弗。菩萨摩诃萨。欲成般若波罗蜜。当如是住。复次舍利弗。菩萨摩诃萨。欲计数知三千大千世界沙石树花一切诸尘众疑不决。当学般若波罗蜜。三千大千世界有如大海江河川流泉原。欲知有几渧多少之数。无所伤害度海虫类。当学般若波罗蜜。复次舍利弗。假使三千大千世界所有火者一时普然犹如劫烧。一面一时悉欲灭者令无所然。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。三千大千世界所有诸风。有时国土吹拔。崩碎诸须弥山令无有余。譬如灰尘净灭。有如然荩如然蒿草。若以一指手指足指。欲令灭尽三界火者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。三千大千世界所有虚空。欲以普身一加趺坐周遍虚空者。当学般若波罗蜜。自在变化无近无远无大无小。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲取三千大千世界诸须弥山。以一手举诸须弥山。置于殊异无量诸佛世界。无往反想不增不减。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。东方江河沙等诸佛世界。佛天中天声闻辟支佛。皆欲一时同时合集以供养者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。若一衣服香花捣香涂香缯盖幢幡以持供养多阿竭阿罗呵三耶三佛及声闻众。奉事归命一时应集。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。三千大千世界所有众生。皆欲建立于尸波罗蜜三昧智慧解脱见慧。须陀洹果斯陀含果阿那含果。至于无余住泥洹果。而般泥洹。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜。若布施者波罗蜜。当作是学。如此施者获大果报。如是施者。生于君子傲姓家梵志大族姓长者。如此施者。生于四天王上忉利天兜术天尼摩天波罗尼蜜天。如是施者。依于斯施思第一禅第二第三至第四禅。无量虚空定意正受。无量空慧。无量不用慧天。无想有想三昧禅。如此施者。兴八圣路。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛果。若晓了此。当于是学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜。常以权慧有所施与。为具檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。舍利弗白佛言。云何菩萨摩诃萨。具足六波罗蜜。答曰。其布施主。无所著念。所施受者亦不忘恩。是为檀波罗蜜。无所犯负。不以禁戒而自绮饰。是为尸波罗蜜。常怀忍辱无嗔恚恨心向于众生。是为羼波罗蜜。精进不怠欲度一切。是为惟逮波罗蜜。一心寂然而无愦乱。是为禅波罗蜜。智慧解空不计吾我。是为般若波罗蜜。取要言之复重解议。于罪无罪亦无无罪。是尸波罗蜜。无有嗔恨。是羼波罗蜜。身心精进不以疲倦。是惟逮波罗蜜。兴于不乱无所想念。是禅波罗蜜。解一切法而无所著。是般若波罗蜜。复次舍利弗菩萨摩诃萨。欲得成就过去当来今现在诸佛世尊功德之谊。当学般若波罗蜜。欲得超度有为无为诸法行者。去来今法至于无本。诸法所兴不起本际。欲逮此者。一切声闻辟支佛诸菩萨法。欲行诸佛世尊而供养者。欲得具足诸佛眷属无量群从。欲得获致菩萨枝党。欲得净毕众祐之德。欲致布施心无所受。不起犯戒想无嗔恚心无懈怠心。不欲发起于乱心者。又不欲起愚痴心者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲立众生于布施德持戒智慧劝令修治。所受福德当所兴者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲兴五眼。当学般若波罗蜜。何谓五眼。肉眼天眼慧眼法眼佛眼。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲见东方江河沙国土八维上下诸佛世尊。所说经法皆以天耳欲得闻者。又欲得知诸佛世尊心之所念。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。诸佛世尊。普在十方说经法者。欲得听闻而不断绝至阿耨多罗三耶三菩者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。若欲得见过去多阿竭阿罗诃三耶三佛。欲得见于诸佛国土者当来现在十方世界今现在佛。欲得追见国土所有。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得解知如来所说十二部经。闻经。分别经。颂经。诗歌经。初经。此应经。生经。受经。方等经。未曾有法经。譬喻经。注解章句经。诸声闻所不闻者。皆欲得玩习诵者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得听闻八维上下如来所说经法皆念不失。欲得执持已得执持而为众会他人说者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得启问过去当来如所说谊者。已得闻者为他人说。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得照明东方江河沙等诸佛世界。窈窈冥冥不见日月光明之耀。欲得照斯及十方界。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲得开化东方江河沙等诸佛国土。及十方界愚痴闇冥。不闻佛名不得听经不睹众僧。欲得开化众生类立于正见令得睹佛逮闻经法及与圣众。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。欲令东方江河沙等诸佛世界及十方佛土所有众生。其生盲者得目睹形。聋者逮听。狂者复意。裸者获衣。饥者致食。渴得水浆。吾愿得力皆蒙斯恩。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。其有于斯三千大千世界在恶趣者。地狱饿鬼畜生群萌之类。吾欲加恩使此[黍-禾+利]庶逮得其所。八维上下各江河沙亦复如是。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。江河沙等诸佛世界所有众生。欲得建立于禁戒者。三昧智慧解脱度知见慧。须陀洹果斯陀含果阿那含果阿罗汉果辟支佛证。至成阿耨多罗三耶三菩。又欲修多诃竭威仪礼节。菩萨摩诃萨当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜。当作是观。假令我身所不得睹而欲察之。当学般若波罗蜜。设使我身四寸之地而以足指靡不周遍。从四天王天。欲界色界阿迦腻吒天。无央数亿百千垓眷属周匝。往诣佛树处于道场。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨或坐佛树。四天王天上诸天人上乃至于净居诸天等。无差特皆来具足布施。或当成就阿耨多罗三耶三菩阿惟三佛。往来住立坐卧。则于其地自为金刚。欲得获斯。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜。当作斯观。吾当何日出去弃国舍家。即日当成阿耨多罗三耶三菩得至阿惟三佛。以至阿惟三佛即日转法轮。以转法轮。令无央数不可称计众生之类。远尘离垢诸法法眼净。无量无限群萌之党。得无起余漏尽意解。无量无限众生含血得阿惟越致阿耨多罗三耶三菩。是菩萨摩诃萨当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。心念欲得我成阿耨多罗三耶三菩得至阿惟三佛。有无央数比丘圣众声闻学者。或以一反演说经法。于一坐上得阿罗汉。诸菩萨摩诃萨皆逮阿惟越致阿耨多罗三耶三菩有无央数不可称限不可计量诸菩萨众。其寿无量。光明照远无有边际。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨或欲得致阿耨多罗三耶三菩逮成阿惟三佛。欲令其佛国土无有淫怒痴音响之名。使一切众生皆获如是色像。如般若波罗蜜具足成就。所施善哉调顺快哉。妙哉智慧善修梵行。而顺游不居众生。则为快哉。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨。愿我当获具足圣达。而以正法则富之定无有音声。当学般若波罗蜜。心自愿言。吾清声闻。令江河沙等世界众生之类。逮得阿耨多罗三耶三菩。当学般若波罗蜜

    摩诃般若波罗蜜顺空品第二

佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。兴斯之德。四天王即时欢喜。我等当立四枚之钵。四天王前以所奉进。过去怛萨阿竭阿罗诃三耶三佛。亦当贡上学道法者。时忉利天亦复踊跃。焰天兜率天尼摩罗天波罗尼蜜天。吾等悉当奉事供养此善男子。阿须伦身则为减损。长益诸天身。三千大千世界。上至阿迦腻吒天莫不踊跃。吾等请劝使转法轮。舍利弗。菩萨摩诃萨行般若波罗蜜时。则为长益具六波罗蜜。善男子善女人欢喜悦豫。吾等当为父母之慈妻子亲属朋友亲厚之慈。父母兄弟妻子亲厚知友爱敬喜见之。四天王忉利天。焰天兜率天尼摩罗天波罗尼蜜天。上至阿迦腻吒天。不令菩萨与尘欲相值。发心往诣承事作礼。吾等亦当使得清净梵天行离秽浊行。无习淫欲致生于梵天。无有放逸而绩放逸。诸有色者。不能进至阿耨多罗三耶三菩。是故菩萨以净梵行弃捐家业。乃逮阿耨多罗三耶三菩阿惟三佛。不以秽浊而得佛道。贤者舍利弗白世尊曰。菩萨之法。必当有父母妻子亲厚知友耶。佛告舍利弗。若有菩萨。必当有父母不应有妻子。或初发意净修梵行成为童真。至成阿耨多罗三耶三菩阿惟三佛。或有菩萨。以沤和拘舍罗习于五欲。然后舍家逮得阿耨多罗三耶三菩阿惟三佛。譬如巧黠幻师及与弟子。善学幻术化造五欲。以此五乐而用自娱戏笑为行。于舍利弗意云何。其幻师者宁为服习于五欲乎。舍利弗白。不也天中天。佛言。如是舍利弗。菩萨摩诃萨以沤和拘舍罗。习于五欲劝化众生。其菩萨摩诃萨不为五欲之所沾污。菩萨摩诃萨以无央数事嗟叹爱欲。或有毁呰欲为然炽。爱欲瑕秽。欲为仇怨。欲为怨敌。如是舍利弗。菩萨摩诃萨度众生故。而为分别此五欲事。舍利弗白佛。唯天中天。云何菩萨摩诃萨行般若波罗蜜。佛告舍利弗。菩萨摩诃萨行般若波罗蜜。不见菩萨。亦不见菩萨字。亦不见般若波罗蜜。亦不见行般若波罗蜜字。亦不见非行。所以者何。菩萨之字自然空。其为空者无色。无痛痒思想生死识。不复异色空。不复异痛痒思想生死识空。如色空痛痒思想生死识亦空。所谓空者色则为空。痛痒思想生死识亦自然。所以者何。所谓菩萨但假号耳。所谓道者则亦假号。所谓空者则亦假号。其法自然不起不灭。亦无尘劳无所依倚无所诤讼。若有菩萨所行如是。不见所起亦不见所灭。不见所猗不见所讼。所以者何。诳诈立字因游客想。或想念故而致此法。从何立字但托虚言。晓了如是。菩萨摩诃萨则为行般若波罗蜜一切不见有名号也已无所见亦非不见。则无所猗。则为行般若波罗蜜

    摩诃般若波罗蜜行空品第三之一

佛复告舍利弗菩萨摩诃萨行般若波罗蜜时。当作斯观所号菩萨所谓佛者亦假号耳所谓名色痛痒思想生死识亦假号耳。皆由吾我。所谓我者。适无所有。无我无人无命无寿。及含血蠕动。无心无意。若作所造。自然所习所更所见知见之事。如此辈类。皆不可得空无所著。悉由假号但有虚言。如是菩萨摩诃萨为行般若波罗蜜。不见众生。设无所见亦不有见。亦复不见所托言也。菩萨摩诃萨所行如是。为随怛萨阿竭所教行般若波罗蜜。舍怛萨阿竭已其智慧过诸声闻辟支佛所兴空行而不迷惑。所以者何。其人所修不见于字所当猗者。菩萨摩诃萨行如是者。为行般若波罗蜜。佛言。譬如舍利弗摩诃目揵连诸比丘等。使满阎浮提犹如竹芦甘蔗稻麻丛林。智慧具足。终不能及行般若波罗蜜菩萨。百倍千倍万倍亿倍。不住以前。所以者何。菩萨智慧欲度一切众生之类之所致也。复次舍利弗。菩萨摩诃萨行般若波罗蜜。一日行智皆过声闻辟支佛所立之上。置是满阎浮提舍利弗摩诃目揵连等比丘空。正使三千大千世界。满中舍利弗摩诃目揵连诸比丘等所有智慧。不及行菩萨摩诃萨。置是三千大千世界舍利弗摩诃目揵连诸比丘等。譬如东方江河沙等诸佛国土。悉满其中舍利弗摩诃目揵连诸比丘等普及十方。斯等不及行般若波罗蜜菩萨智慧一日。过一切声闻辟支佛智慧。百倍千倍巨亿万倍不相属逮。于是贤者舍利弗。白世尊曰。唯然其声闻智慧。须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨怛萨阿竭阿罗诃三耶三佛智慧。计此一切所有智慧。无所破坏。无所诤讼。而无所起自然为空。唯天中天。其无所坏无所诤讼无起自然空者。宁可获致若干差特不乎。云何菩萨一日行智。而复于此过一切声闻辟支佛乎。佛告舍利弗。于舍利弗意云何。菩萨所以行般若波罗蜜者何。一日之中所行智慧所建立愿。修于幻术而行愍哀。皆为一切众生之类。悉了诸法以化群萌欲令灭度。诸声闻辟支佛。宁为兴立如是之缘智慧不乎。答曰。不也天中天。佛言。于舍利弗意云何。诸声闻辟支佛岂有此念。我等当逮阿耨多罗三耶三菩阿惟三佛。教化众生至泥洹界令灭度耶。答曰不也。佛言。以是故。当复知此一切声闻辟支佛所有智慧。百倍千倍智慧百千倍巨亿万倍终不相及。于意云何。声闻辟支佛宁有此念。吾等当行六波罗蜜。教化众生严净佛土。具足怛萨阿竭十种力四无所畏四分别辩十八不共诸佛之法。得成阿耨多罗三耶三菩阿惟三佛。度脱灭度无量无限不可计数众生之类不乎。答曰。不也天中天。佛言。菩萨摩诃萨发心念言。吾当奉行六波罗蜜具一切法成阿耨多罗三耶三菩。度脱不可计数众生之类。佛言。譬如日之宫殿奋其光明一时普照阎浮提地无不周遍。如是舍利弗。菩萨摩诃萨行六波罗蜜。具十种力四无所畏四分别辩十八不共诸佛之法。逮成阿耨多罗三耶三菩。开化度脱无量无限不可计数众生之类。贤者舍利弗白佛言。云何菩萨摩诃萨越于声闻辟支佛地。而便逮及阿惟越致地净修佛道。佛告舍利弗。于是菩萨摩诃萨。从初发意行六波罗蜜。过于空法无想无愿。则为超越声闻辟支佛地。住阿惟越致地贤者舍利弗复白佛言。云何菩萨摩诃萨。于一切声闻辟支佛为最众祐。佛告舍利弗。菩萨摩诃萨从初发意行六波罗蜜至坐佛树。常于一切声闻辟支佛为最众祐。所以者何。菩萨摩诃萨若来现者。则自然兴真妙之法。具足十善又成五戒。立八等事及八关斋。四禅四等心四无色三昧。四意止四意断五根五力七觉意八由行现于世间如来十力四无所畏四分别辩十八不共诸佛之法。如是辈类。众善之德兴现于世。则分别君子族姓梵志长者傲族大姓及忉利天上至三十三处想无想天。须陀洹斯陀含阿那含阿罗汉辟支佛。怛萨阿竭阿罗呵三耶三菩。缘此别知有此事耳。舍利弗白佛言。云何菩萨摩诃萨净毕众祐。世尊告曰。菩萨摩诃萨于众祐中无所净毕。所以者何。究竟于空则为菩萨摩诃萨成众祐也。所以者何。舍利弗。菩萨摩诃萨为布施士何所施者。以善法施开化众生。何谓善法十善之事五戒六波罗蜜。十力四无所畏四分别辩十八不共诸佛之法。开化须陀洹斯陀含阿那含阿罗汉辟支佛。怛萨阿竭阿罗呵三耶三佛布施之士。舍利弗复白佛言。唯然世尊。菩萨摩诃萨遵修何行。为行般若波罗蜜。佛告舍利弗。于是菩萨设行色空者。则为行般若波罗蜜。设行痛痒思想生死识空者。是则为行。复次舍利弗。菩萨摩诃萨解知眼空耳鼻舌身意空者。此则为行。解色空声香味触法空者。此则为行。解眼界空者。此则为行。解色界眼识界。解耳鼻舌身意界空者。此则为行。解耳声耳识鼻香鼻识舌味舌识身细滑身识意所欲意识空者。此则为行。解苦空者。习亦复空尽亦复空八由亦空。此则为行。解无黠亦空。行亦空。识亦空。名色亦空。六入亦空。所更亦空。痛痒亦空。思爱亦空。所受亦空。所有亦空。生老死亦空。此则为行。解一切法空。此则为行。诸所自然有为无为悉能解空。此则为行菩萨摩诃萨行般若波罗蜜。解本净空志性亦然。此则为行。舍利弗。是为菩萨摩诃萨行般若波罗蜜。当解是七空。此乃为行。以此七空行般若波罗蜜。色无应不应无行不行。不作此观。不见痛痒思想生死识应不应行不行。不见色法有所起有所灭。不见痛痒思想生死识法有所起法有所灭。不见色法有所依着法有所诤讼。不见痛痒思想生死识法有所著法有所诤。不见与色而俱游居。不见与痛痒思想生死识而俱游居。不见与生死而俱游。亦不见不与生死而游居也。所以者何。永无有法而与俱。缘起诸事本净为空。舍利弗。色则为空则无有色。痛痒思想生死识空则无有识。佛语舍利弗。其为空者。无有起者无有灭者。假使色空则无有色。假使痛痒思想生死识空则无有识。设使色空则不有见。设痛痒空则无所患。设思想空则无所念。设使行空则无所造。设识空者无所分别。所以者何。舍利弗。色者则异不与空同。空不为异色不为分别。色自然空色则为空。痛痒思想生死识。不为别异空亦不异。设空不异识亦不异。识自然空识则为空。佛语舍利弗。其为空者。不起不灭无所依着无所诤讼。无所增无所损。无过去无当来无现在。彼亦无色痛痒思想生死识。亦无眼耳鼻舌身心。亦无色声香味细滑。所欲法彼则无。无黠不灭无黠不行。不识不名色不六入不细滑不痛不爱不受不有不生不老不病不死亦不灭。除生老病死。彼亦不苦亦无习亦无所尽亦无所由。彼亦无得亦无有时。彼无须陀洹果。无斯陀含果。无阿那含果。无阿罗汉果。无辟支佛觉。亦无得道亦无佛道。菩萨摩诃萨行般若波罗蜜。如是者则为菩萨摩诃萨行般若波罗蜜。不见般若波罗蜜应不应行不行。不见施不戒不忍不进不禅不智。不见是六波罗蜜。不见色痛痒思想生死识应不应行不行。不见眼应不应行不行。不见耳鼻舌身心应不应行不行。不见色声香味细滑所欲法应不应行不行。不见四意止应不应行不行。不见四意断四神足五根五力七觉八由应不应行不行。不见十种力四无所畏四分别辩十八不共诸佛之法应不应行不行。不见怛萨阿竭萨云然慧应不应行不行。是为舍利弗菩萨摩诃萨行般若波罗蜜。此乃应行。佛语舍利弗。菩萨摩诃萨行般若波罗蜜。空不与空斗。空不与空行。无相不与无相斗。无想不与无想行。无愿不与无愿斗。无愿不与无愿行。空不与空相应无相不与无相相应。无愿不与无愿相应所以者何。空者无行不行。无相者亦无行不行。无愿者亦无行不行。菩萨摩诃萨行般若波罗蜜。能如斯者此乃为行。佛复语舍利弗。菩萨摩诃萨行般若波罗蜜。诸法自然相则得度空。已得度空不与色诤。亦无所行。不与痛痒思想生死识诤。亦无所行。不与过去色诤。亦不见过去色。不与过去色诤。亦不见当来色。不与当来色诤。亦不见现在色。不与现在色诤。亦不与过去痛痒思想生死识诤。亦不与当来现在痛痒思想生死识诤。亦不见过去当来现在痛痒思想生死识。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不与过去当来诤。不与当来过去诤。不与现在过去当来诤。不与过去当来现在诤。不见三世与于空行般若波罗蜜。如是行者此乃为行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。所行如是如所应行。不与过去萨芸若讼行。亦不见过去何所萨芸若。过去安有萨芸若及行讼行。不与当来萨芸若讼行。亦无所行。亦不见当来安有萨芸若与行讼行乎。亦不与现在萨芸若讼行。亦不见现在萨芸若。安有萨芸若讼行乎。行般若波罗蜜如是者。此乃为行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不行萨芸若色。亦不见萨芸若色。亦不见行萨芸若色痛痒思想生死识。亦不见萨芸若痛痒思想生死识。不行萨芸若眼。亦不见眼。亦不行萨芸若耳鼻舌身心。亦不见耳鼻舌身心。不行萨芸若色。亦不见色不见色。不行萨芸若声香味细滑所欲法。亦无所现。佛语舍利弗。行般若波罗蜜能如是者。此乃应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。亦不遵萨芸若檀波罗蜜。亦不见檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。亦复如是。亦不行萨芸若般若波罗蜜。亦不见萨芸若般若波罗蜜。亦不遵萨芸若四意止。亦不见萨芸若四意止。亦不遵萨芸若四意断四神足五根五力七觉意八由行。亦不见萨芸若意止意断神足根力觉意由行。亦不遵萨芸若十种力四无所畏四分别辩十八不共诸佛之法。亦无所见。亦不见萨芸若怛萨阿竭诸力法。行般若波罗蜜。如是此乃为行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不行萨芸若佛。佛亦不行萨芸若。不行萨芸若道。道亦不行萨芸若。所以者何。佛则萨芸若。萨芸若则佛。道则萨芸若。萨芸若则道。十种力四无所畏四分别辩十八不共诸佛之法。亦复如是。佛语舍利弗。行般若波罗蜜。能如是者此乃为行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不行色有不行色无有。不行痛痒思想生死识有。不行痛痒思想生死识无有。不计色有常亦不计色无常。不计色苦不计色乐。不计色有我不计色无我。五阴六衰亦复如是。不计五阴空无空。不计五阴有相无相。不计五阴有愿无愿。行般若波罗蜜。今我所行亦无所受。亦无所行亦无所取。不有所行亦不不行。不有所受亦不不受。不有所取亦不不取。佛语舍利弗。菩萨摩诃萨行般若波罗蜜。能如是者此乃为行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不用檀波罗蜜尸波罗蜜羼提波罗蜜惟逮波罗蜜禅波罗蜜故。行般若波罗蜜。不用阿惟越致地。教化众生故。行般若波罗蜜。不用净佛国土故。行般若波罗蜜不用怛萨阿竭十力故。行般若波罗蜜。不用四无所畏四分别辩十八不共诸佛之法。行般若波罗蜜。不究竟空。不用内空。不用外空。不用内外空。不用空空故。不用大空故。不用真空故。不用有为空故。不用无为空故。不用究竟空故。不用无品空故。不用本净空故。不用自然相空故。不以一切法空故。不以无起空故。不以无灭空故。不以无形空故。不以自然空故。不以有形无形空故。不无本故。不以法界故。不以本际故。行般若波罗蜜。所以者何。菩萨摩诃萨行般若波罗蜜时。于诸法无所破坏亦无所见。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不用神足故。行般若波罗蜜。不用天眼故。不用天耳故。不用观他人心故。不用念过去事故。所以者何。行般若波罗蜜时。亦不见般若波罗蜜。何况当睹菩萨诸神通乎。行般若波罗蜜。能如是者此乃应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。心不念言。我当以神足往诣东方江河沙等见诸如来稽首礼。亦不自念。到八方上下亦复如是。等无有异。行般若波罗蜜。能如是者此乃应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不自念言。诸佛世尊所可畅说。吾则当以天耳皆听。吾当察见众生之心所可念者。当念过去所游居处。我以天眼见诸群萌在所之处。佛言。行般若波罗蜜。能如是者此乃应行。如是舍利弗。行如是者。则为度脱无央数不可计会众生之类。菩萨摩诃萨能如是者。魔及官属不能得便。又复见及他方世界诸人民遥闻其德皆为作礼。复次东方江河沙等诸佛世界。八方上下诸佛世尊。皆共拥护于是菩萨。终不堕坠于声闻辟支佛地。四天王上至阿迦腻吒天。悉共拥护是菩萨摩诃萨。将无伺求得其便者。所可兴发所当作者。得现在福。所以者何。而以慈心向诸众生。如是舍利弗。菩萨摩诃萨行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。而以微劳得总持门三昧门。速疾近此怛萨阿竭阿罗呵三耶三菩。一切所生常值见佛不离诸佛。至逮成阿耨多罗三耶三佛。佛言。行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不自念言宁有诸法。所谓法者一切为应若不应乎。为平等不平等乎。所以者何。于时行者。不见诸法应若不应行若不行等与不等。佛言。行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不自念言。我当速解诸法之界至阿惟三佛。亦无阿惟三佛。所以者何。逮法界者亦无所觉。行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不见诸法及与法界有诸疾病及与空寂。行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不自念言。诸法法界有若干种不计别异。行般若波罗蜜。能如是者此能应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不自念言。于是诸法及与法界。观与不观见与不见。所以者何。彼则不见诸法所有可持诸法分别观也。行般若波罗蜜。能如是乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不念法界忧行空事。其空事者不忧法界。行般若波罗蜜。能如是者乃为应行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不念眼界为空空乎。亦不忧眼界。色不忧空。空不忧色。色界不忧空。空界不忧色。眼识界不忧空。识界不忧眼识空。耳鼻舌身心声香味细滑。所欲法亦如是。心界不忧空空界不忧心。法界不忧空。空界不忧法。识界不忧空。空界不忧识。佛言。舍利弗。是为第一行。所谓空行。菩萨摩诃萨能行空者。则不堕落声闻辟支佛地。能净佛国开化众生。疾逮阿耨多罗三耶三菩。成阿惟三佛。计诸所行般若波罗蜜行。般若波罗蜜行为最极尊为长为上无底无比。所以者何。般若波罗蜜行为无上行。空无相无愿行。菩萨摩诃萨应行如是。当作斯持。速得近于受莂之地。菩萨摩诃萨应此行者。为无数不可计众生开度利谊。若不念言。我行般若波罗蜜。诸佛世尊当受决也。亦不念言。我得亲近也于受决也。我当清净于佛国土得至阿耨多罗三耶三菩阿惟三佛。当转法轮。所以者何。彼其行者。不着法界亦不虚寂不见异法。当行般若波罗蜜。诸佛天中天。受我决及逮阿耨多罗三耶三菩阿惟三佛。所以者何。菩萨摩诃萨行般若波罗蜜者。不起人想。不起我想。不起寿想。不起命想。不起众诸想。不起见知想。所以者何。计于吾我众生。不起不灭。又计人本不起不灭。其不起不灭者。何所行般若波罗蜜。菩萨摩诃萨行。能如是人无所起属。行般若波罗蜜。众生为空众生不得众生寂寞。为行般若波罗蜜。如是舍利弗。菩萨摩诃萨。遵修于空为第一行。复次舍利弗。菩萨摩诃萨行般若波罗蜜。能如是者则皆超踰一切诸行。置是所可遵行。为大慈行为大悲行。菩萨摩诃萨行于此者。终不起贪嫉之心。无毁戒心。无嗔恚心。无懈怠心。无乱意心。无邪智心

光赞经卷第一光赞经卷第二

        西晋三藏竺法护译

    摩诃般若波罗蜜行空品第三之二

贤者舍利弗白佛言。菩萨摩诃萨行是般若波罗蜜。从何所退没而生于是。佛语舍利弗。是菩萨摩诃萨行般若波罗蜜者。从他方佛国终而生于此。若兜术天上迁移生此人间。或于人中来生。疾逮是般若波罗蜜行。其行般若波罗蜜者。此于现世而得成就。其人速近深妙法门。然后究竟般若波罗蜜。常值见怛萨阿竭阿罗呵三耶三佛。所在国土不离诸佛。或有菩萨摩诃萨。从兜术天化没其身。一生补处则不失六波罗蜜。所至到处诸总持门一切悉具。疾近三昧门。佛言舍利弗。菩萨从人中终还生人间。此菩萨者则为阿惟越致。其人睹彼诸根寂定。不能速逮般若波罗蜜之行定也。亦不得近诸总持门。无三昧门。又舍利弗问言。菩萨摩诃萨行是般若波罗蜜者。于此寿终当生何所。佛言。于此寿终从一佛国游一佛国。诸佛世尊所现在处。未曾离诸天中天。或有菩萨摩诃萨。无沤和拘舍罗。修第一禅至于四禅。行六波罗蜜。由此禅故生长寿天上。假使从彼寿终之后逮得人身。值见诸佛世尊。诸根寂定而不聪明

佛告舍利弗。或有菩萨摩诃萨。行第一禅至于四禅。行般若波罗蜜。而无沤和拘舍罗。然后舍禅生于欲界。是菩萨摩诃萨诸根寂定而不聪明。佛告舍利弗。或有菩萨摩诃萨。行第一禅至于四禅。不离般若波罗蜜。观于空慧而入于定。至于识意慧而入于定。至于无用慧而入于定。至于有想无想而入于定。过是四天。修四意止四意断四神足五根五力七觉意八由行。行于大哀有沤和拘舍罗。所生之处不随禅教。不从慈悲喜护。不顺无色之禅。自在所生。所生之处常见现在怛萨阿竭阿罗呵三耶三佛。不离般若波罗蜜。是拔地劫中。当得阿耨多罗三耶三佛得成阿惟三佛。佛告舍利弗。或有菩萨摩诃萨。行第一禅至于四禅。行四等心过是四天。修四意止四意断四神足五根五力七觉意八由行。行于大哀有沤和拘舍罗。而不禅定所生之处。不得自在。其人而生于此欲界君子贵人姓梵志长者。欲教化众生有所利益。佛告舍利弗。或有菩萨摩诃萨。行第一禅至于四禅行四等心。观于空慧识慧无用慧有想无想。过是四天。修三十七品。行大哀沤和拘舍罗。不随禅教而有所生。其人即生四大天王天上忉利天上焰天上兜术天上尼摩罗天上波罗尼蜜天上。生于彼间教化众生净于佛土。见诸佛世尊不离道教

佛告舍利弗。或有菩萨摩诃萨行般若波罗蜜。有沤和拘舍罗。修第一禅行四等心。于是寿终。生梵身天上梵具天上梵度着天上大梵天上。在彼梵天及大梵天。从一佛国游一佛国。诸佛所现之土。成阿耨多罗三耶三菩。至阿惟三佛转法轮者。其菩萨摩诃萨。劝助诸佛令转法轮。佛告舍利弗。一生补处开士大士。行智度无极。以善权方便。现行第一禅至四禅慈悲喜护三昧。至于空慧识慧无用慧有想无思。过是四天。修三十七品行大哀。行空三昧无想三昧无愿三昧。开士交游自在所生也。其人面自见诸佛世尊。在其佛所净修梵行生兜术天上。在于其上为开导师。所度如船。诸根无瑕常安寂定。为无央数亿百千垓诸天眷属围绕。俱下于此。得成无上正真之道成最正觉。佛告舍利弗。开士大士得六神通。不生欲天色天无色天。从一佛国游一佛国。稽首奉事诸如来至真等正觉。佛告舍利弗。开士大士得六神通而自娱乐。从一佛国游一佛国。所在佛国。不闻声闻缘觉声。亦不闻名。佛告舍利弗。开士大士得六神通而自娱乐。普游十方。从一佛国到一佛国。所至佛土。寿命极长不可称限劫数之底。佛告舍利弗。开士大士得六神通而自娱乐。从一佛界到一佛界。所至佛土无有佛法及与圣众。便为歌颂分别解说佛法圣众功德之事。众生应时闻佛法圣众音声。心怀欣豫。寿终之后皆生有佛世尊现在国土。佛告舍利弗。开士大士从始发意。不得第一禅至于四禅。四等梵行四无色定。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法者。终不曾生欲界色界无色界。所生之处在于众生求名誉之士。佛告舍利弗。开士大士行六度无极。从初发意度于灭寂。得不退转住不动转地。当至无上正真之道成最正觉。佛告舍利弗。开士大士从初发意。得无上正真之道。成最正觉便转法轮。为无央数不可称计众生之类。开导利谊有所加益。然后至于无余于泥洹界而般泥曰。般泥曰后。其法则住一劫若复过劫。复次舍利弗。开士大士从初发意。行智慧度无极。与无央数亿百千垓诸开士俱。从一佛国游一佛国。所生佛土严净境界。佛告舍利弗。开士大士行智慧度无极。逮得四禅及四等心无色定。而自娱乐。得第一禅。从一禅起入寂然定。而以正受。从灭定禅起至于四禅。而以思惟。从四禅起灭寂禅定。从灭寂禅起至无量空禅。从无量空禅起以灭定禅。从灭定禅起至有想无想而入禅定。从有想无想禅定起。以灭寂禅定。是为舍利弗开士大士行智慧度无极。以善权方便而现所行三昧正受。佛告舍利弗。开士大士。得四意止四意断四神足根力觉意。至于八由十种力四无所畏四分别辩十八不共诸佛之法。不得流布果往来果不还果无著果缘觉果。行智慧度无极。以善权方便与八圣路。开化众生。令得流布果往来果不还果无著果缘觉果。佛告舍利弗。其声闻缘觉果慧。则比开士逮得法忍。则知开士为不退转行是智慧度无极。佛告舍利弗。开士大士行六度无极住六度无极。在兜术天而具足众空便毕。其开士大士则当知之。在贤劫开士数中当成佛。佛告舍利弗。开士大士。逮得四禅及四等心四无色定四意止四意断四神足根力觉意。至于八由十种力四无所畏四分别辩十八不共诸佛之法。其有众人行佛道者。终不建立于四圣谛。其开士大士。则为应在一生补处。佛告舍利弗。开士大士。行六度无极。从一佛界度一佛界。普游诸国。所至之处教化众生使立佛道。其开士大士。无央数不可称计劫。逮得无上正真之道成最正觉。佛告舍利弗。开士大士住度无极。常为众生遵修精进。未曾发意口说无益之事。佛告舍利弗。开士大士行六度无极。常精进欲救众生。从一佛国游一佛国。开化群萌使度勤苦。断于三恶考治之趣。佛告舍利弗。开士大士住六度无极。行布施度无极。眷属围绕导御众生令趣永安。饥者与食。渴者与浆。无衣与衣。无香与香杂香捣香。床卧之具奴婢车乘金银七宝所求索生活之业。终不逆人随其所侥。佛告舍利弗。开士大士行智慧度无极。自化其身如如来入于地狱。为地狱中人而说经法。及畜生饿鬼分别演谊。佛告舍利弗。开士大士行六度无极。自化身心犹如佛像。度于东方江河沙等佛土。为诸众生说说经法。稽首如来净其佛土。其闻经者悉发道意。如是之比普至十方诸佛世界。观诸佛国。择取上士自净国土。令其微妙五事有胜于其佛。开士大士。具足成就一生补处。佛告舍利弗。开士大士行六度无极。应时具足三十二大人之相。诸根上妙而悉通达。则以此精进诸根。无数人所见敬爱。令不可计众生之类发悦豫心。稍稍使入三涂者令得灭度。佛言舍利弗。开士大士行智慧度无极。当清净其身口意。佛告舍利弗。开士大士行六度无极。诸根上妙形类端正。不自咨嗟不说他人瑕。常省己过不讼他阙。佛告舍利弗。开士大士从初发意。行布施度无极戒度无极。已得住立此二度无极。摄取无数转轮圣王极尊之位。不可计限。转轮圣王彼所在处。见无央数百千诸佛。便稽首礼。承事供养诸佛世尊。佛告舍利弗。开士大士住六度无极。为诸众生演法光明自照已。以此法曜未曾亡失。至于无上正真之道成最正觉。如是舍利弗。开士大士。多所照明于诸佛法。是故舍利弗。开士大士行智慧度无极。常当精修护身口意。令身口意无所犯负也。贤者舍利弗言。唯然世尊。何所开士大士精修众行。护身口意无所犯负。佛告舍利弗。开士大士。心自念言。是为彼身所作身所兴造有所成立。是则为言是六为心。其心所为有所成立。是为开士大士护身口意。开士大士行智慧无极。亦无得身亦不得言亦不得心。设使开士大士行智慧度无极。得身口意。所固身口意。则有贪嫉之心。则亦复起犯戒之心嗔恚之心懈怠之心乱意之心邪智之心。佛言舍利弗。如是行者不当名之为开士。是开士大士行六度无极。净身瑕秽净口瑕秽净心瑕秽。令无缺减。是言开士。贤者舍利弗白佛言。云何开士大士净身口意之瑕秽。世尊答曰。假使开士大士不自得身。亦复不得口言心念。佛言。如是舍利弗。开士大士净身口意。设使身口意瑕恶则为利养。假令开士大士从初发意。奉行十善报应之向。不发声闻缘觉意。如是开士大士净除身口意瑕秽。佛告舍利弗。开士大士行智慧度无极。欲求佛道。行布施度无极戒忍度无极精进度无极一心度无极。舍利弗白佛言。云何开士大士欲求佛道。佛告舍利弗。开士大士。假使不得身口行言心念。不得布施度无极戒度无极忍度无极精进度无极一心度无极智慧度无极。不得声闻缘觉。不得开士。不得佛道。是故开士求于佛道。于一切法无所得故。佛告舍利弗。开士大士行六度无极已。有所至到亦无所到。无能得便。舍利弗白佛言。云何开士大士行六度无极。有至到亦无所到无能得便。佛告舍利弗。开士大士行六度无极时。不念色。不念痛痒思想生死识。不念眼耳鼻舌身意。不念色声香味细滑法。不念眼不念色不念眼色识。不念耳不念声不念耳声识。不念鼻不念香不念鼻香识。不念舌不念味不念舌味识。不念身不念细滑不念身细滑识。不念意不念法不念意法识。不念四意止四意断四神足五根五力七觉意八由行。不念布施度无极戒忍精进一心智慧度无极。不念如来十力四无所畏四分别辩十八不共诸佛之法。不念流布往来不还无著缘觉无上正真之道成最正觉。佛言舍利弗。开士大士如是行者。则能具足长益六度无极。所至到处亦无所到无能得便。佛告舍利弗。或有开士大士。住智慧度无极具足诸通慧。则以其慧所行之谊。终不堕落至于无余。不为众人所见憎恶。亦不贫匮。亦不身故而受于色。所以身故。而自破坏诸天世人阿须伦。舍利弗白佛言。何所开士大士慧。佛告舍利弗。开士大士所用承慧。见东方江河沙等如来至真等正觉。闻所说法睹于圣众。见诸佛国清净清净之法。所以开士大士。从所顺慧。无有佛想无开士想。无声闻想无缘觉想。不为己慧有佛土想。所以者何。开士大士行布施度无极。不得布施度无极。行戒忍精进一心智慧度无极。不得戒忍精进一心智慧度无极。所以慧致四意止四意断四神足五根五力七觉意八由行十种力四无所畏四分别辩十八不共诸佛之法。是为开士大士慧。以用斯慧。具足一切诸法之本。于一切法亦无所念。佛告舍利弗。开士大士智慧度无极净于五眼。何等五眼。肉眼天眼慧眼法眼佛眼。舍利弗白佛言。唯然世尊。云何开士净肉眼。佛告舍利弗。开士大士或以肉眼见四千里。或有开士大士。自以肉眼见八千里。有开士大士或以肉眼见阎浮提。有开士大士或以肉眼见二阎浮提。或有开士大士。以肉眼见四天下。有开士大士以肉眼见千世界。有开士大士以肉眼见二千世界。有开士大士以肉眼见三千大千世界。佛语舍利弗。是为开士大士得肉眼净。舍利弗又问。何谓开士大士得天眼净。佛告舍利弗。其四大天王天上诸天眼。开士大士皆知之。忉利天焰天兜术天尼摩罗天波罗尼蜜天。上至阿迦腻吒天诸天之眼。开士大士皆知之。其开士天眼。及四大天王。上至阿迦腻吒天。开士皆知之。其开士大士天眼。以此天眼。睹见东方江河沙等佛世界众生。终始皆悉知。乃至十方诸佛世界。悉睹见众生生死。佛言舍利弗。是开士大士天眼净。舍利弗又问。唯然世尊。云何开士大士慧眼净。佛告舍利弗。其开士大士智慧眼者。不作是念。法有所有。有为无为有形无形。世间法度世法。有漏无漏。其开士慧眼者。睹于诸法。无不见闻无量无数。是为开士大士慧眼净。舍利弗又问。唯然世尊。云何开士大士法眼净。佛告舍利弗。于是开士大士。则以法眼作是分别。某行信某行法。某行空某行无想某行无愿。以是脱门也。得五根得无见三昧。已得无见三昧则兴发度智之慧。已得度智之慧则断三结。何等为三。一者贪身二者狐疑三者毁戒。是为三结。能除贪身无有狐疑。不毁禁戒则无有结。无有结者则流布人也。彼得行由路。除淫欲嗔恚怒痴薄。是谓往还人也。以此所由路。加以殷勤。淫欲嗔恚淫怒痴断。是谓不还人也。彼于由路。益加勤行。少于色欲无色欲无明憍慢断除。是谓无著人也。是谓行空人也。空于脱门而获五根。致无见三昧。以无见三昧。兴发度慧至得缘觉。又此人者。已无想脱门得于五根。取要言之至得无著。是为开士法眼之净。假使开士能分别解。其有合会法皆归尽宗。见诸法尽得于五根。是为开士法眼净。复次舍利弗。开士大士分别如是。此初发意开士。行布施度无极戒度无极忍度无极精进度无极一心度无极智慧度无极及信根精进根。而根所行具足善权方便。己身常立于善德根本。其开士生于君子贵姓梵志长者。四王天上忉利天焰天兜术天尼摩罗天波罗尼蜜天上。生于彼天。所住之表开化众生。皆令群萌入于安行。净于佛土值见如来至真等正觉。供养奉事。不堕声闻缘觉地。某开士大士退转。某不退转。至于无上正真之道成最正觉。是开士大士法眼净。复次舍利弗。开士大士。分别如是。开士已受决者。得无上之道成最正觉。某开士未受决于无上正真之道。某开士无所造立。某开士是不退转。某开士非不退转。某开士神通具足。某开士神通不具足。某开士神通具足。往诣东方江河沙等诸佛国土。稽首礼于如来至真等正觉。供养奉事。某开士未得神通。某开士当得神通。某开士佛土所有则当清净。某开士国土所有不能清净。某开士当教化众生。某开士不教化。某开士为诸佛世尊所叹。某开士诸佛世尊当近立在前。某开士诸佛世尊不现立前。某开士寿命当有限。某开士寿命无有量。某开士比丘众当有限。某开士比丘众当无限。某开士得无上正真之道成最正觉。以众开士为僧。某开士得为佛时无开士众。某开士当以勤苦行成。某开士当以安隐行成。某开士当究竟终始穷尽。某开士不究竟终始穷尽。某开士当坐道场树下。某开士不坐道场树下。某开士当有魔试。某开士无魔试。某开士如是。舍利弗。是为开士大士法眼净。舍利弗白佛言。云何开士大士佛眼净。佛告舍利弗。开士大士所用因与无上道意。金刚之喻三昧正受。具足一切诸通慧如来十力四无所畏四分别辩十八不共诸佛之法大慈大悲。至于开士大士眼。普达一切佛法。于一切佛法无所不见无所不闻。无有限量无所不通。是舍利弗。开士大士逮得无上正真之道。成最正觉时。乃能具足得佛眼净。佛告舍利弗。如是开士大士欲得五眼。当奉行六度无极。所以者何。是故六度无极。皆入一切诸善德法。皆悉解了声闻法缘觉法开士法。是故舍利弗。得平等心至斯行者。则便救摄一切诸法。当观智慧度无极。智慧度无极是五眼之亲母也。开士大士学是五眼。以逮得无上正真之道成最正觉

佛告舍利弗。或有开士大士。修于神通至度无极。无央数神通因缘之事。住于斯地以一身之化若干形。还复为一身。于是墙壁隔碍山陵嵩高。越之无碍。如虚空中水品流行处为云气。譬如飞鸟游行空中。出入于地。出无间入无孔。譬如入水。履行水上其由如地。身出焰光犹如大火。此诸日月光明威神巍巍难及。则以手掌扪其日月而捉光明。犹得自在。身至梵天。不以神足而自贡高。意不慢恣亦无所念。其神足亦无所得亦无憍逸。起亦无所想亦无念者。兴自然空。自然空者则为寂寞。其自然者亦无所起。又如斯者。不发神足及神足行。唯以专思诸通慧事。是开士智度无极神足证慧神足所由。佛告舍利弗。其开士大士净于天耳越天人耳。得闻一一音诸天人声。亦不想念天耳之种。不作是念我闻其声。亦无所得。自然之空自然寂寞。其自然者。则无所起亦无所得亦无所念。亦不自念我得天耳。唯以志于诸通事。开士大士。是为行智慧度无极天耳证慧神通之行。佛告舍利弗。其开士大士。则知他人众生心念虚实所趣。有欲心无欲心。有欲想无欲想。嗔恚心嗔恚想。离嗔恚心离嗔恚想。愚痴心愚痴想。离愚痴心离愚痴想。有思爱心离思爱心。有所受无所受。若举若下。卒暴心安祥心。若大心若小心。若定心若不定心。若脱心若不脱心。其彼心污染甫当污染。其心染想甫当染想。如审晓了分别虚实。有无上心念于无上。亦无所念亦无所想。所以者何。诸心无心所由起。诸心无想念。则忧忆念往古游居慧所证明所以神通游于居。慧所证明所以神通以此御之。一心念识百日事百月事百岁事。一劫百劫无央数劫。无数百劫无数千劫。无央。数亿百千垓。悉识念之本。所在处。其字为其种姓为某。所生如斯。食饮亦然。久住如此。寿命长短苦乐善恶。从彼终没生于某处。此众此生彼所说如是。能识念无央数过去游居。亦不想念所获神通佛语舍利弗。开士大士。智慧度无极能如是者。则为识念往古游居神通明证之慧。是为神通慧行。佛告舍利弗。其开士大士则以天眼。睹于众生生死终始善根恶根祸福善恶趣安趣苦微妙瑕秽。由其所作悉了知之。某可愍之。了身行恶口言恶心念恶。具足恶行。诽谤贤圣奉于邪见。以此缘故碎身寿命。趣于勤苦堕于地狱。此仁贤等众生之类。其身行善口言善心念善。众行具足不谤贤圣奉遵正见。缘此行故碎身寿终。趣于安隐升生天上。睹见八方上下可愍之了。身行恶口言恶心念恶。具足恶行诽谤贤圣奉于邪见。以此缘故碎身寿命。趣于勤苦堕地狱。此仁圣等众生之类。其身行善口言善心念善。众善具足不谤圣贤奉遵正见。缘此行故碎身寿终。趣于安隐升生天上。睹见八方上下。神通已达皆然。睹见十方无有蔽碍。佛告舍利弗。其开士大士逮得知人心念。一日百日一岁百岁。一劫百劫千劫万劫亿劫无央数劫。无央数亿亿百千劫至于无限。十方世界诸佛国土。所念无量不可称限心无蔽碍。是谓开士大士知他人心所念往古游居神通明证之慧神通慧行。佛告舍利弗。开士大士自知身所从来。一生百生千生万亿生无央数亿生。一劫百劫千劫万劫亿劫无数亿劫。善恶祸福善恶所趣。父母兄弟宗室妻子。势贵富乐贫贱困苦。愚智穷达名字种姓。是为开士大士知身所从来往古游居神明证之慧神通慧行。五道自然睹见十方无有蔽碍。佛告舍利弗。开士大士有漏尽慧证神通为达。不堕声闻缘觉地。亦不想念他异之法。亦不想念我逮得无上正真之道成最正觉。亦不以漏尽之尽神通之慧为慢逸念。设如来十力四无所畏四分别辩十八不共诸佛之法。解十二因缘无根本三十七品无端绪教化一切。如是舍利弗。开士大士智慧度无极。为具足神通。已能具足则有长益。逮得无上正真之道为最正觉。佛告舍利弗。或有开士大士行智慧度无极。住布施度无极。见能严净诸通道究竟真空。从其兴受而行恩德。佛告舍利弗。或有开士大士行智慧度无极。住戒度无极。具足严净诸通道究竟空。无信不信。无起不起。兴立于谊永无所生。佛告舍利弗。或有开士行智慧度无极。住忍度无极。具足严净诸通道究竟真空。兴于忍辱无有嗔恨。解知无本一切悉空。佛告舍利弗。或有开士大士行智慧度无极。住精进度无极。具足严净诸通道究竟真空。身意精进专于一谊。所行精进无有诸漏。兴立此进。佛告舍利弗。或有开士大士行智慧度无极。住一心度无极。具足严净诸通道究竟真空。其心不乱不举不下。不起不灭兴立斯禅。佛告舍利弗。或有开士大士行智慧度无极。住智慧度无极。具足严净诸通道究竟真空。除邪见心。劝发无智兴无所与。佛告舍利弗。如是开士大士行智慧度无极。住六度无极。具足严净诸通道究竟真空。来不来者若无去来。与无所受。不施不悭。不戒不犯。不忍不怒。不进不怠。不禅不乱。不智不愚。其所施者亦无所念亦无想念。布施悭贪持戒犯禁。忍辱嗔恚。精进懈怠。一心乱意。智慧愚痴。不念骂詈不念歌叹。有为亦不想念。无起者。无所嗔者。无所骂者。亦不想念有所言谈。亦不念有亦不念无。佛言。舍利弗。是开士大士行智慧度无极名德之称。声闻缘觉所不能及。备斯德已教化众生严净土。行于大慈得诸通道慧。佛告舍利弗。开士大士智慧度无极。常发等心向于众生。已能等心向于众生。则便获致等于诸法。已能护致等诸法者。则能得立等诸众生。一切诸法应时现在。则为佛世尊所见爱敬。及诸开士一切声闻缘觉所见钦奉。然复在在所生处。目未曾见不可之事。耳不闻恶声。鼻不闻臭。口无恶味。身无粗坚。心无邪法。开士大士行智慧度无极。能如是者。终不亡失无上正真之道。佛说是智慧度无极品时。三百比丘悉修行者。皆以璎珞奉散佛上。发无上正真之道心。佛尔时笑。贤者阿难。即从坐起更整衣服。右膝着地叉手白佛。何因缘笑。既笑当有意。佛告阿难。此三百比丘六十一劫。当得作佛号曰大英如来至真等正觉明行成为善逝无上士道御天人师号佛众祐。于是终没当生阿閦如来至真等正觉国土。六万欲行天当在弥勒佛世时。出家为沙门承佛圣旨。于彼世时寻见千佛所行在于众生。八方上下亦复如是。各见千佛及诸国土。又复睹见此忍世界严净无瑕。如彼诸佛如来至真等正觉世界。于彼万人各自发愿。吾等各兴行意欲现在现在佛国。时佛即知善男子心之所念。即复笑。阿难长跪重问佛言。何因缘笑。笑必有意。佛告阿难。见是万人建立愿不。对曰唯然。世尊告曰。此万人于此寿终所生佛国。未曾远离诸佛如来。然后得佛号严净如来至真等正觉也

    摩诃般若波罗蜜叹等品第四

于是贤者舍利弗。摩诃目揵连。大迦叶。此等及余无数圣通明达比丘及菩萨摩诃萨。清信士清信女。悉白佛言。唯然世尊。如是行者为是菩萨摩诃萨大度无极微妙波罗蜜无能胜者。最超波罗蜜无能越者。甚尊波罗蜜则而有持。势名波罗蜜无能及者。无上波罗蜜无能过者。无量波罗蜜无能过者。是诸菩萨摩诃萨无伦波罗蜜所度无极。无双波罗蜜空度无限。唯然世尊。是菩萨摩诃萨已相为空而度无极。无想波罗蜜所度无念。无愿波罗蜜所度无著。一切诸法空。悉自然无所有故。空波罗蜜自然空故。一切德具足波罗蜜所度无极。唯然世尊。诸菩萨摩诃萨一切德备般若波罗蜜。无能当者。无所行波罗蜜。谓菩萨摩诃萨波罗蜜也。于是菩萨摩诃萨能等无等。其所施与假能具足。等无等波罗蜜则能到已还等。已能获到等无等。至于阿耨多罗三耶三菩。尸波罗蜜能还致等无等。羼惟逮禅般若波罗蜜。譬如菩萨行檀波罗蜜应所当为。天中天。不但有般若波罗蜜。便能获致等于无等。则于真法。色痛痒思想生死识。若转法轮等无所等。过去佛天中天。当来现在诸佛。悉行是般若波罗蜜。转等于无等之法轮者。是故世尊。菩萨摩诃萨欲度一切诸法之表。当行般若波罗蜜。菩萨摩诃萨当为作礼。诸天人民阿须伦。悉为行般若波罗蜜者稽首作礼。佛即告是于无央数诸声闻菩萨摩诃萨。如是如是。善男子。当为菩萨摩诃萨作礼。诸天人民阿须伦。若有行般若波罗蜜者皆来归命。佛语舍利弗。若菩萨摩诃萨来现于世化现人间。若在天上。现君子族姓梵志长者。若现在转轮圣王。四王天上忉利天焰天兜率天尼摩罗天波罗尼蜜天。上阿迦腻吒天。须陀洹斯陀含阿那含阿罗汉现出世间。辟支佛怛萨阿竭阿罗呵三耶三佛现在世间。佛言。以是故。舍利弗。菩萨摩诃萨而来现耳。若能致获饮食衣服床卧具屋宅灯火。明月珠宝水精琉璃。璧玉金银珊瑚琥珀砗磲码瑙以给众生。佛语舍利弗。不以是故出现世间。以持斯语救护世间使得安隐。诸天人民所会伎乐。皆是菩萨摩诃萨怀来致现。所以者何。菩萨摩诃萨设有所行修六波罗蜜者。住六波罗蜜。欲劝众生布施之故便自施与。持戒忍辱精进一心智慧亦复如是。以劝群萌修般若波罗蜜。是故舍利弗。菩萨摩诃萨安一切众生之类

    摩诃般若波罗蜜授决品第五

于是世尊即出舌本。覆三千大千世界。从其舌本出无央数光明之耀。照于东方诸佛世界。应时东方江河沙等诸佛国土。而无央数不可计会诸菩萨摩诃萨。睹光明各各在其佛土。自往咨启诸佛世尊而问斯谊。唯天中天。是何威神而令此土光明普照。于时其国诸如来众。各各告菩萨摩诃萨。善男子。欲知此变西方去此江河沙等诸佛世界。有佛土名曰忍界。其佛号释迦文怛萨阿竭阿罗诃三耶三佛。出舌本光明。照于东方江河沙等世尊世界。普令照曜周及十方。所以然者。为诸菩萨摩诃萨讲般若波罗蜜。于时彼土菩萨摩诃萨各自启佛。唯然大圣。我等欲往稽首归命释迦文如来及诸菩萨摩诃萨。并欲听省般若波罗蜜。其佛告曰。往善男子。从仁择时如尔所欲。时诸菩萨启佛见听。各各自取众盖幢幡香华敷饰杂香捣香金花银花。往诣释迦文怛萨阿竭阿罗呵三耶三佛稽首佛足。各以所赍众盖幢幡香华敷饰杂香捣香金华银华。用散佛上及诸菩萨诸声闻上。八方上下亦无央数不可计会诸菩萨摩诃萨。各各自于其国启白世尊。此之威曜何所从来。诸佛告曰。有佛号名释迦文尼怛萨阿竭阿罗呵三耶三佛。出舌本光明之德。各照十方江河沙等诸佛国土。是其威曜。时诸菩萨各启其佛。欲往稽首释迦文见诸菩萨。诸佛告曰。往族姓子。从仁择时如志所欲。诸菩萨众各赍供养。往诣释迦文怛萨阿竭阿罗诃三耶三佛稽首作礼。进上所赍却坐一面。听佛所说。于时四大王天上诸天人忉利天焰天兜率天尼摩罗天波罗尼蜜天。上至阿迦腻吒天。各赍天花天香天捣香天杂香青莲华红莲花黄莲华白莲华。皆以天上微妙香华。各各执持往诣佛所。于时诸天上及诸菩萨。各各赍持香花杂香捣香。各各供养奉散如来至真等正觉上。于时所散华香。上在虚空化为宫殿。在于四方而于虚空中向于四面微妙分明。皆以众宝人所悦乐。于众会亿百千垓。皆共叉手自归命佛。而问世尊。唯天中天。我等之身当来之世。愿得法利亦复如是。如怛萨阿竭阿罗呵三耶三佛。诸声闻众亦当如是。为诸会者讲说经法如今所演。尔时世尊知善男子心之所念。睹一切法永无所起亦无所行。一切诸法无所逮得。见心所忍佛应时笑。贤者阿难前白佛言。佛何因笑。笑当有意。佛告阿难。今此众会亿百千垓人。皆悉逮得不起法忍。过于当来六十八亿劫。当得作佛号曰觉华怛萨阿竭阿罗诃三耶三佛明行成为善逝世间解无上士道法御天人师号佛世尊。劫名华事。世界曰严华

    摩诃般若波罗蜜分别空品第六

尔时佛告贤者须菩提。岂非堪任。为诸菩萨摩诃萨缘发般若波罗蜜。菩萨摩诃萨因此得生。于是诸菩萨摩诃萨众声闻及天人各心念言。今须菩提自以辩才。为诸菩萨摩诃萨。说般若波罗蜜乎。乘佛圣旨说耶。又须菩提。知诸菩萨摩诃萨众大声闻诸天人心之所念。谓贤者舍利弗。敢佛弟子有所说者。分别光曜一切皆乘如来威德。怛萨阿竭所可说法。彼一切法于本无诤。诸善男子当学斯法。则证其法学者。皆顺如来慧证境界。诸菩萨摩诃萨说般若波罗蜜。非声闻辟支佛之境界。所以者何。说法得时莫不喜悦。舍利弗谓须菩提。斯谓菩萨。时须菩提白世尊曰。所谓菩萨者。天中天。何谓菩萨。于此法中何因有菩萨之言。我亦不见菩萨之法。何谓菩萨。唯天中天。我永不见般若波罗蜜及于菩萨。当云何说菩萨摩诃萨般若波罗蜜。当以何谊为诸菩萨讲般若波罗蜜而开导乎。佛告贤者须菩提。所谓般若波罗蜜及菩萨者。但假号耳。其名无名。其名不在于内不在于外不处两间。譬如须菩提所见人者但假托号。彼亦无名。其法不起不灭。因缘和合随俗所名。但音声言及我人寿命蚑行喘息蜎飞蠕动众生之类。所作所造所兴劝助。所见所睹所知所观。一切皆为假号之法。一切不起不灭。诸天人民所可言诲亦复如是。如此须菩提。计般若波罗蜜及菩萨名。悉为假号。皆不起不灭。至于天中天。所可言名等无有异。譬如须菩提于内所有所与我色斯亦假名法。为假托作斯字也。其假号法不起不灭。欲得了此因缘之合。有言声耳。痛痒思想生死识法为假号。其法所名不起不灭。若以因缘假托之现而有言声。如是须菩提。所谓般若波罗蜜。有言菩萨及菩萨名。但所托者。其法不起不灭。所谓菩萨般若波罗蜜及菩萨名。悉无他倚因缘猗号而有斯言。眼则恍惚虚寂。至于假名法为托字。亦皆不起不灭。因缘假号而有言声。所谓眼空。其眼无内无外不处两间。耳鼻舌身意亦复如是。法为假托。其法不起不灭。因缘合名而有言声。其号心者。心不在内亦不在外不处两间。所谓色者。须菩提。法所假号不起不灭。亦不内外不处两间。其眼界者亦为假号。因法托名。其曰眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界细滑界身识界。意界法界意识界。法为借号而有言声。其法无内无外不处两间。如是须菩提。所谓菩萨及般若波罗蜜因法假号。其号不起不灭。猗托为名而有言声。般若波罗蜜菩萨字。其名无内无外不处两间。譬如须菩提所谓其内是我身因字头首。其名但言声。又复名颈项五阴两臂背脐胁两膑两脚。但假号耳。托首声言因缘法为号。计其法者不起不灭。计此所有悉为假托而立言声。计其名者不起不灭。无内无外不处两间。如是须菩提。般若波罗蜜菩萨名者皆为假号。其法不起不灭。尽为假托而有言声。其名亦不起不灭。无内无外不处两间。譬如须菩提于此外有草木枝叶华实。计此一切。悉为假号而有言声。其名无名。其名不起不灭。假托为名而有言声。计其名者。无内无外不处两间。如是须菩提。般若波罗蜜及菩萨字。一切皆因法假号。其法不起不灭。其名无内无外不处两间。譬如须菩提过去诸佛世尊。皆共假传其号。当来现在亦复如是。譬如须菩提呼声之响。又如镜像幻化野马。如来解说一切诸法。皆犹如化但假有号。其号不起不灭。倚托为名而有言声。其名无内无外不处两间。如是须菩提。所谓菩萨般若波罗蜜但假号耳。其号不起不灭。无内无外不处两间。如是须菩提。所谓菩萨摩诃萨般若波罗蜜。因缘合会而假虚号。所号善权所号法皆假托耳。当作是学行般若波罗蜜。不住名色亦无所见。不住痛痒思想生死识。不住于名。不睹名色不常。不见名色安乐不见名色苦恼。不见名色而有内者。不见名色而有外者。不见名色而有空者。不见名色无想之变。不见名色无愿之事。不见名色而寂寞。不见名色而慌忽者。不见名色而有欲尘。不见名色而诤讼者。不见名色而有起者。不见名色而有灭者。痛痒思想生死识亦复如是。眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界细滑界身识界。意界法界意识界一切皆尔。因缘合成而为假号。有是五阴。所以者何。菩萨摩诃萨行般若波罗蜜及菩萨行。并于名号不有不无。不处有为界。不处无为界。亦无所见。所以者何。须菩提。菩萨摩诃萨行般若波罗蜜。于一切法无所想念。无应不应。亦不想念。行般若波罗蜜。处无想法行诸意止。修般若波罗蜜。亦不见般若波罗蜜。不见般若波罗蜜名。亦不见菩萨号。亦不见十种力四无所畏四分别辩十八不共诸佛之法。行般若波罗蜜时。不见般若波罗蜜。亦不见般若波罗蜜名。亦不见菩萨。亦不见菩萨名。谁见菩萨行般若波罗蜜。菩萨摩诃萨晓了分别诸法之本诸法相者。计诸法本诸法相者。亦无所著亦无诤讼。如是须菩提。菩萨摩诃萨行般若波罗蜜。不因猗名。为法造号。其于佛道亦缘号不为假托。悉晓了之不猗于色。不猗痛痒思想生死识。不猗于眼耳鼻舌身意。亦不猗眼色识。不猗耳声识。不猗鼻香识。不猗舌味识。不猗身细滑识。不猗意法识。不猗眼习五阴之事。而无所猗不起痛痒。无苦无乐无不苦乐。乃至意识所习因缘。则有痛痒及与苦乐不苦不乐行者。于彼都无所猗。亦不猗着于有为界。亦不猗着于无为界。亦不猗着檀波罗蜜。亦不猗着尸波罗蜜。亦不猗着羼提波罗蜜。亦不猗着惟逮波罗蜜。亦不猗着禅波罗蜜。亦不猗着般若波罗蜜。亦不猗着相。亦不猗着菩萨之身。亦不猗着于肉眼亦不猗着天眼慧眼法眼佛眼。亦不猗着慧度无极。亦不猗着神通之意所度无极。亦不猗着内外。亦不猗着处于两间。亦不猗着于内之空。亦不猗着于外之空。亦不猗着无形之缘。亦不猗着自然之空。亦不猗着开化众生。亦不猗着佛土严净。亦不猗着沤和拘舍罗。所以者何。用一切法悉无所有故。当所著者。亦无所著亦无所有。当可持者。如是须菩提。菩萨摩诃萨于一切法而无所著。为行般若波罗蜜檀波罗蜜尸波罗蜜羼提波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。便得长益入于寂然得菩萨道。入于阿惟越致神通具足。神通以具则游佛国教化众生。已化众生。则便供养诸佛世尊。则能严净诸佛国土。已能严净诸佛国土。诸佛世尊皆睹见。于时菩萨亦复遥见诸佛大圣。亦欲逮得功德善本。便当供养诸佛世尊稽首归命。则逮自然无量之德。亲近诸佛。便得从闻所说经典。已逮闻法未曾断绝。逮得阿耨多罗三藐三菩阿惟三佛。诸总持门诸三昧门。如是须菩提。菩萨摩诃萨行般若波罗蜜行。分别晓了一切诸法因缘假号。于须菩提意云何。色为菩萨乎。痛痒思想生死识为菩萨乎。须菩提答曰。不也天中天。云何须菩提。眼为菩萨乎。耳鼻舌身意为菩萨乎。答曰不也。天中天。色声香味细滑法为菩萨乎。答曰不也。天中天。又问于须菩提意云何。眼色识为菩萨乎。耳声识鼻香识舌味识身细滑识意法识为菩萨乎。答曰不也。天中天。于须菩提意云何。地种为菩萨乎。答曰不也。天中天。水种火种风种空种识种为菩萨乎。答曰不也。天中天。于须菩提意云何。无明为菩萨乎。答曰不也。天中天。识名色六入所习爱痛受有生老病死为菩萨乎。答曰不也。天中天。于须菩提意云何。宁有异色为菩萨乎。答曰不也。天中天。宁有异痛痒思想生死识为菩萨乎。答曰不也。天中天。宁有异眼耳鼻舌身意为菩萨乎。答曰不也。天中天。宁有异色声香味细滑法为菩萨乎。答曰不也。天中天。宁有异眼色识耳声识鼻香识舌味识身细滑识意法识为菩萨乎。答曰不也。天中天。宁有异十二因缘从无明至病老死为菩萨乎。答曰不也。天中天。于须菩提意云何。色无本为菩萨乎。答曰不也。天中天。五阴六衰十八种四大十二因缘无本为菩萨乎。答曰不也。天中天。于须菩提意云何。宁有异无本为菩萨乎。答曰不也。天中天。佛告须菩提。于须菩提意解何等谊。以何等观察而答。佛言。色非菩萨。痛痒思想生死识非菩萨。六衰十八种四大十二因缘从无明至生老病死非菩萨。其无本者谓非菩萨。若异无本亦非菩萨。须菩提白佛言。唯天中天。吾我人寿亦不可得。云何当名为菩萨者。云何名五阴六衰十八种四大十二因缘终始之患为菩萨耶。云何名异色异痛痒思想生死识为菩萨耶。云何名异六衰十八种四大十二因缘为菩萨耶。云何名无本之事为菩萨耶。云何名异无本为菩萨耶。斯无处所。佛言。善哉善哉。须菩提。菩萨摩诃萨学般若波罗蜜。当观众生人物无所有不可得。般若波罗蜜亦无所有不可得。菩萨当作是学。于须菩提意云何。口言色者为菩萨乎。答曰不也。天中天。口言痛痒思想生死识为菩萨乎。答曰不也。天中天。计色常计痛痒思想生死识常为菩萨乎。答曰不也。天中天。于须菩提意云何。计色无常计痛痒思想生死识无常为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色乐痛痒思想生死识乐为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色苦痛痒思想生死识苦为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色是我所痛痒思想生死识是我所为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色非我所痛痒思想生死识非我所为菩萨耶。答曰不也。天中天。于须菩提意云何。口言色空痛痒思想生死识空为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色无想痛痒思想生死识无想为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色无愿痛痒思想生死识无愿为菩萨乎。答曰不也。天中天。于须菩提意云何。口言色不空不无想不无愿痛痒思想生死识不空不无想不无愿为菩萨乎。答曰不也。天中天。于须菩提意云何。五阴六衰十八种四大十二因缘无所有为菩萨乎。答曰不也。天中天。佛告须菩提。仁见何谊而反云口所说。言五阴六衰十八种四大十二因缘终始之患。苦乐善恶空无想无愿有与无悉非菩萨。须菩提白佛言。唯天中天。究竟求色了不可得。何况甫复口言色者为菩萨乎。痛痒思想生死识亦尔。究竟求常而不可得。何况无常而可得当为菩萨乎。究竟苦乐而不可得。何况口言苦乐为菩萨乎。究竟索是我所不可得。何况口言我非我为菩萨乎色痛痒思想生死识亦复然。究竟所有色不可得。何况口言色空为菩萨乎。痛痒思想生死识亦复然。究竟求想不可得。何况口言色无想为菩萨乎。痛痒思想生死识亦复如是。究竟求愿不可得。何况口言色无愿为菩萨乎。痛痒思想生死识亦复如是。佛言。善哉善哉。须菩提。菩萨摩诃萨欲学般若波罗蜜当作是学。口所言色不可得者。痛痒思想生死识者。空无想无愿不得者。则为学般若波罗蜜。向者须菩提所言我于法中永不睹见为菩萨者。须菩提。欲知法不可见法。法不可见法界。法界不见法。色界痛痒思想生死识亦然。色界不见法界。法界不见色界。眼界不见法界。法界不见眼界。耳鼻舌身意。亦复如是。意界不见法界。法界不见意界。十八种界不见法界。法界不见十八种界。有为界不见无为界。无为界不见有为界。有为界者亦不可两。无为界者亦不可名。无为者不可两。有为者亦不可名。如是须菩提。行般若波罗蜜能如此者。于一切法永无所见。已无所见不恐不畏不难不惧。心不怯弱亦无所恨。所以者何。须菩提。已不见色痛痒思想生死识。不见眼耳鼻舌身意。不见色声香味细滑法。不见色欲。至于法欲亦无所见。不见贪怒痴不见无明。至于行识名色六入所更痛爱受有生老病死。亦无所见。不见吾我。不见人寿命。不见欲界。不见色界。不见无色界。不见声闻辟支佛。不见菩萨法。亦不见佛。亦不见法。不见菩萨众。已不见一切法。不恐不畏不难不惧。心不怯弱。须菩提白佛言。唯然世尊。何因菩萨摩诃萨心不怯弱而无所著。佛告须菩提。菩萨摩诃萨不得心所念法。亦无所见。是故菩萨摩诃萨心不怯弱亦无所著。须菩提白佛言。云何菩萨摩诃萨而不恐怖。佛告须菩提。菩萨不得心畏。亦无所见。是故菩萨摩诃萨而不恐怖。须菩提白佛言。云何菩萨摩诃萨于一切法而无所得。行般若波罗蜜乎。佛告须菩提。菩萨摩诃萨一切所行般若波罗蜜。彼亦不得般若波罗蜜。亦复不得菩萨之心。其是为今设菩萨之为敕命

光赞经卷第二光赞经卷第三

        西晋三藏竺法护译

    摩诃般若波罗蜜了空品第七

于是须菩提白佛言。菩萨摩诃萨欲具足檀波罗蜜。当学般若波罗蜜。欲具足尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜。当学般若波罗蜜。菩萨摩诃萨欲蠲除色者。当学般若波罗蜜。欲除痛痒思想生死识者。当学般若波罗蜜。欲除眼耳鼻舌身意者。当学般若波罗蜜。欲除色声香味细滑法。当学般若波罗蜜。欲除眼色识耳声识鼻香识舌味识身细滑识意法识。当学般若波罗蜜。欲除眼更耳更鼻舌身意更。当学般若波罗蜜。欲除色更痛痒思想生死识更因缘之习。当学般若波罗蜜。菩萨摩诃萨欲除贪淫嗔恚愚痴。当学般若波罗蜜。欲除贪身见已。当学般若波罗蜜。菩萨摩诃萨欲除狐疑犯戒。当学般若波罗蜜。欲除欲诸着色欲无色欲。当学般若波罗蜜。菩萨摩诃萨欲除因缘会缚结之着所受之处。当学般若波罗蜜。欲除四果须陀洹斯陀含阿那含阿罗汉。当学般若波罗蜜。菩萨摩诃萨欲除四忧四着及四凶受四颠倒。当学般若波罗蜜。欲除五盖六入七识八邪九恼十恶罪福之业。当学般若波罗蜜。菩萨摩诃萨欲除十善四禅四谛五神通。欲除四意止四意断四神足正根五力七觉意八由行。当学般若波罗蜜。菩萨摩诃萨欲除十种力四无所畏四分别辩四等心四无色定一切诸意止十八不共诸佛之法。当学般若波罗蜜。菩萨摩诃萨欲了觉意三昧正受。当学般若波罗蜜。欲分别虚空慧三昧者识慧三昧不用慧三昧有想无想慧三昧正受灭定。当学般若波罗蜜。菩萨摩诃萨欲成师子娱乐三昧师子震吼三昧。欲逮得总持门者。当学般若波罗蜜。欲得首楞严三昧宝海三昧慧印三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得月耀三昧月幢英三昧入一切诸法三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得睹明印三昧生诸法三昧出于劝祠幢幡恶三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得金刚喻三昧入一切诸法门三昧定意王三昧帝王印三昧正受当学般若波罗蜜。菩萨摩诃萨欲得势力清净三昧超诸平等三昧顺生诸法所归入三昧入一切诸法言声三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得观十方三昧。欲得一切诸法总持门印三昧一切诸法平等印(丹本云御)造印三昧住于空处三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得严净三昧道场三昧超越神通三昧正受。当学般若波罗蜜。菩萨摩诃萨欲得超挎出三昧等幢护英三昧欲致是三昧正受及余三昧门。当学般若波罗蜜也。复次天中天。菩萨摩诃萨欲令一切众生之类得具足愿。当学般若波罗蜜。复次天中天。菩萨摩诃萨欲得具足功德之本。因其具足所在善本不堕恶趣。不见下贱下归声闻辟支佛地。不以诤讼菩萨上法。当学般若波罗蜜。贤者舍利弗。谓贤者须菩提。云何菩萨摩诃萨不诤上法。须菩提谓舍利弗。菩萨摩诃萨不与沤和拘舍罗。不起无所从生。沤和拘舍罗行六波罗蜜。晓了无所从生空无想无愿。怀来三昧门。不堕声闻辟支佛地。亦不度人菩萨灭定。是谓菩萨摩诃萨生不淳淑。舍利弗谓须菩提。何谓菩萨生不淳淑。须菩提谓舍利弗。所以曰不淳淑者。谓爱着法也。又曰舍利弗。菩萨摩诃萨行般若波罗蜜。立于色空而知想识有所依倚。痛痒思想生死识亦然。立之于空。而知想识有所依倚。是谓菩萨摩诃萨柔顺法忍之爱着也。生不淳淑。复次舍利弗。菩萨摩诃萨立色于无想。而知想识有所依倚。立色于无愿。而知想识有所依倚。是为菩萨摩诃萨柔顺法忍之爱着也。色痛痒思想生死识亦然。立无所有而知想识有所依倚。眼色识耳声识鼻香识舌味识身细滑识意法识。而知想识有所依倚。是菩萨摩诃萨柔顺法忍之爱着也。色无常痛痒思想生死识无常。色苦痛痒思想生死识苦。色无我痛痒思想生死识无我。而立于斯。而知想著有所依倚。舍利弗。是谓菩萨摩诃萨柔顺法忍爱着。生死不淳淑。当断是色痛痒思想生死识。此色非色则为除色。痛痒思想生死识亦然。是为灭尽。当为设证。是非灭尽而为造证。当修斯路。此为染尘诤戒。当习行是。不当习此。是为菩萨之所应行。是非菩萨之所应行。是为菩萨道。是为菩萨学戒不当学某。某是菩萨檀波罗蜜。某是菩萨尸波罗蜜。某是菩萨羼波罗蜜。某是菩萨惟逮波罗蜜。某是菩萨禅波罗蜜。某是菩萨般若波罗蜜。某是菩萨沤和拘舍罗。某是菩萨无沤和拘舍罗。某是菩萨入寂然。某是菩萨生不淳淑。须菩提谓舍利弗。说菩萨行般若波罗蜜。住此建立如是诸法。而知想识有所依倚。是谓菩萨摩诃萨柔顺法忍之爱着生不淳淑。舍利弗谓须菩提。何谓菩萨摩诃萨寂然。须菩提谓舍利弗。于是菩萨摩诃萨行般若波罗蜜。不见内空。不见外空。不见内外空。不见内外空空。而空无内外空。空不见内外空。不见空大空。空大空不见空。空大空不见究竟真空。究竟真空不见大空。究竟真空不见有为空。不见究竟真空。有为空不见无为空。无为空不见有为空。无为空不见终始长远空。终始长远空不见无为空。终始长远空不见未分别空。未分别空不见旷野长远空。未分别空不见本净空。净空不见未分别空。本净空不见自然想空。自然想空不见本净空。自然相空不见一切诸法空。一切诸法空不见自然相空。一切诸法空不见无所有空。无所有空不见一切诸法空。无所有空不见自然空。自然空不见无所有空。自然空空不见无所有空。无所有空不见自然空空。如是舍利弗。菩萨摩诃萨行般若波罗蜜。能如是者则菩萨至于寂然。复次舍利弗。菩萨摩诃萨欲行般若波罗蜜者。当作是学。则当如顺。不当念色。痛痒思想生死识。亦复如是。于识不当念识。不当念眼耳鼻舌身意。不当念色声香味细滑法。不当念檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。亦不当倚着四意止四意断四神足五根五力七觉意八由行十种力四无所畏四分别辩四等心十八不共诸佛之法。如是舍利弗。菩萨摩诃萨行般若波罗蜜。不当念菩萨摩诃萨。又当念等无等心入微妙心。所以者何。其心无心。心者本净。本净心者。自然而乐清明而净。舍利弗谓须菩提。云何心清明而净。须菩提谓舍利弗。假使心不与欲合亦不离欲。不与怒合亦不离怒。不与痴合亦不离痴。不处因缘无有结缚。无所转缀亦无不缀。于一切疑六十二见不合不离。不与声闻辟支佛心行合。亦不离合。是为舍利弗菩萨摩诃萨心本清净清明而净。贤者舍利弗谓须菩提。有此心乎。其心无心。须菩提谓舍利弗。云何舍利弗。为有心耶。岂有此心宁可知有心无心乎。为可得不。为可获不。答曰不也。仁者。假使舍利弗。其心不可复知有与无也。亦不可得亦不可获。又有此者。由因缘而有此言。有此心有心无心。舍利弗谓须菩提。云何须菩提。此为无心那。答曰。无所造无所念。是谓一切诸法无心无念。舍利弗谓须菩提。云何须菩提。其发心者无所造无所念乎。假使色造无所念。痛痒思想生死识亦复然。假使无所造无所念。至于声闻辟支佛意。上至菩萨悉为无心无念乎。答曰唯然。舍利弗。如是心者无所造无所念。是故菩萨摩诃萨亦复如是。无所造无所念。舍利弗赞贤者须菩提言。善哉善哉。须菩提。审如仁者为世尊子。从法门生常以顺法为法所化。因法而与不为荣冀。自然因缘登于法身。仁者则为行空第一。世尊赞仁了空最上难及难及。如是须菩提。菩萨摩诃萨学般若波罗蜜。当顺如斯。如是菩萨摩诃萨则当观之。为阿惟越致欲学声闻地者。当学般若波罗蜜。当闻当受当持讽诵常当思念。念欲学辟支佛地者。当学般若波罗蜜。常闻当受持讽诵当常思念。欲学菩萨地者。当学般若波罗蜜当闻当受持讽诵常当思念。所以者何。此般若波罗蜜者。广普具足致于三乘者。谓菩萨声闻辟支佛。菩萨悉学了无所挂碍也

    摩诃般若波罗蜜假号品第八

于是贤者须菩提白佛言。唯然世尊。如圣所云。菩萨摩诃萨我亦不见亦不能得。行者如我不见不行。菩萨摩诃萨行般若波罗蜜者当云何说。菩萨般若波罗蜜。云何教行者乎。我设使说一切法而可得者。为造名号菩萨之字。设如是者则堕狐疑。又计其名则无所有亦无所住。所以者何。从无明故而致此名。其名如是。亦无有处亦无有住。亦无有处亦无有住。色谓我所而不可得。痛痒思想生死识。谓是我所亦不可得。所以者何。为假名耳。以是之故。其所因缘及计号字。亦无所住亦不不住。所以者何。从无明意致此名号。其所名者。亦不住亦不不住。唯然世尊。我观于眼。永不能得所言我所。耳鼻舌身心。亦复如是。而察于心。亦不能得所言我所。既观于眼耳鼻舌身心永不能得根原本末言是我所者。当因何所而为菩萨立于名号。又察其眼虚无慌忽。其名不住亦不不住。所以者何。因从无明假号而立。计其名者。如是所假亦不住亦不不住。唯然世尊。我求色形本末我所都不能得。六情亦然。求其名号本末所兴言是我所永不得。痛痒思想生死识。亦复如是。求其本末言是我所永不可得。如是眼色识耳声识鼻香识舌味识身细滑识意法识。察其本末所言我所都不可得。设使察眼色本末言是我所不可得。六情色声香味细滑法十八种。亦复如是。当复何因为立号言菩萨乎。其眼耳鼻舌身意色声香味细滑法十八种。计无有名。亦无所住亦不不住。所以者何。因无明故而有名字。又察名字。亦无所住亦无不住。眼所习更耳鼻舌身意所习更者。亦复如是。从眼习缘至于心行。色痛痒思想生死识。缘习所更而致此痛。察其本末言我所永不可得。六情色声香味细滑法色痛痒思想生死识及十八种。察其本末言是我所永不可得。亦无名字。其假号者。亦无所住亦不不住。因其无明而兴致此。是我所者都不可得。行识名色六入所更痛爱受有生老病死。察其本末。言是我所都不可得。亦无所住亦不不住。无明以灭。行识名色六入所更痛爱受有生老病死灭。观其本末。是我所灭都不可得。淫嫉嗔怒愚痴。察其本末。言我所都不可得。因其名字而兴立此。计其名者。亦无所住亦不不住。色痛痒思想生死识眼耳鼻舌身意色声香味细滑法十八种。灭尽除已。察其本末。索言我所永不可得。因从名号而兴。致此。又其名号。亦无所住亦不不住。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。观其本末。言是我所永不可得。因从名字而兴。致此。又察吾我省其本末。言是我所因从名号。其假号者都不可得。亦无所住亦不不住。人寿命所造所观所见亦复如是。察其本末。言是我所永不可得。因从名号而兴。致此。又其名号。亦无所住亦不不住。四意止四意断四神足五根五力七觉意八由行。察其本末言是我所永不可得。因此名号而兴。致此。又其假号。亦无所住亦无不住。空无想无愿。察其本末。言是我所都不可得。因从名号而兴。致此。又其假号亦无所住亦不不住。四禅四等心四无色三昧正受。察其本末。言是我所者都不可得。因从名号而兴。致此。又其假号亦无所住亦不不住。念佛念法念圣众念识念施念博闻。念出入守意念老病死。察其本末。是我所者都不可得。亦不可见。因从名号而兴。致此。又其假号亦无所住亦不不住。十种力四无所畏四分别辩十八不共诸佛之法。察其本末。言我所者都不可得。因从名号而兴。致此。又其假号。亦无所住亦不不住。不见本末。无有处所亦不可得。云何当为菩萨而立名号言菩萨乎。有其名号亦无所住亦不不住。因从无明而致名字。又其名字亦无所住亦不不住。计其名号致五盛阴。察其本末亦不可得。因从名号而兴。致此。又其名号。亦无所住亦不不住。察色痛痒思想生死识眼耳鼻舌身意色声香味细滑法十八种十二因缘。如呼声响影现野马水月幻化。察其五阴及五盛阴亦复如是。省其本末。言是我所都不可得。因从名号而兴。致此。又其名号亦无所住亦不不住虚无慌忽。色痛痒思想生死识。空无想无愿。察其本末。言是我所都不可得。从其名号而兴。致此。又其名号亦无所住亦不不住。犹如呼声响影野马芭蕉水月幻化。察其本末都不可得。不起不灭。犹如水影。无所染污亦无恚恨。眼耳鼻口身意色声香味细滑法。十八种十二因缘。法界本际法法所趣。及寂然法善恶祸福诸法之名。有为法无为法。有所为无所有。有漏无漏。察其本末。法所从兴都不可得。亦无所住亦不不住。犹如影响水月野马芭蕉幻化。过去当来今现在法。察其本末。亦不可得。亦无所住亦不不住。去来今法不可睹原。何谓无所有法。所可谓无所有法者。无有过去当来今现在。求无为法察其本末都不可见。唯然世尊。我察东方江河沙等诸佛世界。省其本末永不可见。又察怛萨阿竭阿罗呵三耶三佛诸菩萨众及声闻辟支佛众。省其本末都无所见。南方西方北方东南方西南方西北方东北方上方下方九方。诸怛萨阿竭阿罗呵三耶三佛。诸菩萨众及声闻辟支佛。省其本末都无所见。何所是菩萨般若波罗蜜。何因当说菩萨之号。又其名号亦无所住亦不不住。所以者何。众生之类从无黠心假名号行。行识名色六入所更痛受爱有生老病死。亦复如是假而有字。其字之本都无所住亦不不住。所以者何。唯然世尊。以一切法悉无有本。以是之故。求其本末了不可得。当何因缘而为菩萨立名号乎。又天中天。其无本者。无名无住亦不不住。所以者何。众生无明。从无明心而致此字。又其名字亦无所住亦不不住。因缘法合而有假号。名曰菩萨。彼无言说。无诸阴众种诸入无明。十八种十二因缘及诸佛法。缘是假号。唯然世尊。假引譬喻。影响野马芭蕉幻化但有假号。若如字空而空无名。譬如名地水火风空。地水火风而自不名。所以名曰戒定慧解脱知见事须陀洹斯陀含阿那含阿罗汉但有名号。声闻辟支佛亦复如是。但有假号所谓菩萨及菩萨字但假号耳。所名曰佛。诸佛之法。亦无实字但假号耳。善恶祸福。若常无常苦乐。若我非我。寂寞恬怕。所有无有福。若常无常苦乐。我观此谊。是之所谓悉由因缘。假使当为菩萨摩诃萨而立名号者。于一切法则有狐疑。察其本末。亦不可得。唯然世尊。有其名号无有法界。亦无所住。所以者何。众生之类。从无明心致此名字。又其名号亦无所住亦不不住。亦无有处。须菩提白佛言。唯然世尊。菩萨摩诃萨假使闻说般若波罗蜜如是比类瑞应所起。不恐不怖不畏不难心不怀懅。其菩萨摩诃萨即当知之。住阿惟越致果。住无所住。行无所行。复次天中天。菩萨摩诃萨不当住于色。不当住痛痒思想生死识。不当住眼。不当住耳鼻舌身意。不当住色声香味细滑法。不当住眼色识耳声识鼻香识舌味识身细滑识意法识。不当住眼。所习更。不当住耳鼻舌身意所习更。不当住眼因缘习痛痒耳鼻舌身意因缘习痛痒。不当住地水火风种。不当住空种。不当住诸识种。不当住无明行识名色六入所更痛爱受有生老病死。所以者何。天中天。色则为空。痛痒思想生死识亦空。所言空者。色则为空非名异空。彼色则空空者假色菩萨摩诃萨。欲求自缘想行般若波罗蜜。当住于色。当住痛痒思想生死识。当住眼耳鼻舌身意色声香味细滑法十八种十二因缘。所以者何。色痛痒思想生死识空。十二因缘亦空。十二因缘生死之原无有异空。无有异住。其十二因缘老病死者。此则为空。生老病死十二因缘自然为空。本自然空。以是之故。天中天。不当住色痛痒思想生死识眼耳鼻舌身意色声香味细滑法十八种十二因缘之端绪也。复次天中天。菩萨摩诃萨行般若波罗蜜。不当住于四意止。所以者何。观四意止亦复是空。不为有异四意止空。也不他空。其四意止自然为空。亦不当住四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。所以者何。其意止断神足根力觉意所由之路。十种力四无所畏四分别辩十八不共诸佛之法。亦复为空。十八不共诸佛之法。自然为空无有异空。十八不共诸佛之法。本性则空无有异空。所以者何。计佛法者则复空。空故曰佛法。唯天中天。以是之故。菩萨摩诃萨行般若波罗蜜。不当住五阴六衰及十八种十二因缘三十七品十种力四无所畏四分别辩十八不共诸佛之法。复次天中天。菩萨摩诃萨行般若波罗蜜。不当住檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。所以者何。般若波罗蜜者亦复是空。设般若波罗蜜空者。则非异般若波罗蜜空。所以者何。无异般若波罗蜜空。般若波罗蜜自空。设般若波罗蜜自然空。唯以文字为假号耳。文字则空。乃为般若波罗蜜。以故菩萨摩诃萨行般若波罗蜜。于般若波罗蜜而无所住。五阴六衰十八种十二因缘三十七品十种力四无所畏四分别辩十八不共诸佛之法空。行般若波罗蜜菩萨不当住中。复次天中天。菩萨摩诃萨行般若波罗蜜。不当住于文字。不当住文字说。不当住一食二食。至于三食四食揣食心食识食。所以者何。谓文字文字则空。无有异空。文字自然为空。其为空者无有文字。文字本空。其为空者无有名字。复次天中天。菩萨摩诃萨行般若波罗蜜。不当住神通。所以者何。其神通者神通自空。神通本空。无有异通而为空者。神通为空无有异空。神通自空空故曰神通是以之故。唯天中天。菩萨摩诃萨行般若波罗蜜。不当住神通。复次天中天。菩萨摩诃萨行般若波罗蜜。不当住色想。不当住痛痒思想生死识想。所以者何。其非常者非常为空。其非常者自然为空。则无非常。无异非常而为空者。无有他空非常自空。其为空者无有非常。以是故天中天。菩萨摩诃萨行般若波罗蜜。不当住色空。不当住痛痒思想生死识空。不当住色无常。不当住痛痒思想生死识无常。不当住眼耳鼻舌身意无常。不当住色声香味细滑法无常。不当住十八种十二因缘终始无常不当住苦。不当住乐不当住色我所非我所。不当于中住痛痒思想生死识我所非我所不当于中住色空痛痒思想生死识空。不当住眼耳鼻舌身意空。不当住色声香味细滑法空。不当住十八种十二因缘生死之患空。不当住有为无为。不当住于本际法。不当住于色寂然。不当住痛痒思想生死识寂然。不当住色空无慌忽。不当住痛痒思想生死识虚无慌忽。六衰十八种十二因缘。亦复如是。复次天中天。菩萨摩诃萨行般若波罗蜜。不住无本所以者何。其无本者。尽无所有亦复为空。无本无异。无本为空无有异空。无有异空为无本也。无本自然空。空是以无本。以是故菩萨摩诃萨行般若波罗蜜不住无本。色痛痒思想生死识不住无本。至于诸法及诸法界诸寂然法乃至本际亦无所住复次天中天。菩萨摩诃萨行般若波罗蜜。不住一切诸总持门。亦不住一切诸三昧门。所以者何。所谓总持门。其总持门亦复为空。所谓三昧门。三昧门者亦复为空。三昧门总持门。自然为空无有异空。自然空者无有他空。总持门三昧门本净本净空法自然空。譬如天中天。菩萨摩诃萨行般若波罗蜜无有沤和拘舍罗。谓有吾为是我所。而念如此则住于色。在于色中有所造作生死之行。住痛痒思想生死识。而有所造而为行者。不除造作生死之所因。而反受般若波罗蜜。不肯精勤于般若波罗蜜。则为不具般若波罗蜜所生之事至于萨芸若。譬如天中天。菩萨摩诃萨无沤和拘舍罗。其心发念。吾我是非所。色痛痒思想生死识苦乐善恶。及总持门三昧门。不能修行总持之门。亦不能顺三昧门。不能造无想行。受般若波罗蜜。亦不能精勤。于般若波罗蜜。以不具足于般若波罗蜜者。不能成就萨芸若慧。所以者何。犹以菩萨摩诃萨行般若波罗蜜无沤和拘舍罗故。不当受色。不受痛痒思想生死识。而彼菩萨反更受色。色者本净了则为空。以此言之。若受痛痒思想生死识。言教本净亦复为空。不受诸总持门诸三昧门。设不受三昧门总持门。则能兴立本净为空。亦不受般若波罗蜜。缘知本净为空之故。菩萨摩诃萨行般若波罗蜜。如是者观察诸法则本净空。当住是观。不念法我所为行。是为菩萨摩诃萨为无所受。名曰无受三昧。道场具足。广普无有边无有量。一切声闻辟支佛所不能及。复不受萨芸若。犹察内空外亦复空。有内外空。求空亦空则为大空。乃为真空空。有所有空。无所有空。究竟尽空。广远之空。有所造空。其本净空。自然相空。一切诸法空。无所有空。自然之空。因从发起自然之空。所以者何。辄趣于化。其所化者则为尘劳。何谓为化。何谓为想。色则为化。痛痒思想生死识。此便为想。十八种十二因缘总持门三昧门。是谓尘劳之想。当受奉行。无所寄倚无所养育。声闻辟支佛。所不信乐萨芸若。何谓信乐。信是般若波罗蜜。笃乐无疑思惟分别。观其要谊则无想。行亦无想是故不受想。专一依倚。而欢喜乐行于笃信。其本净空则便得度。不复受色。亦不受痛痒思想生死识。所以者何。其相自然现在法空。所受空者亦无所得。所以者何。其三昧定。内不可得者为时慧。亦不于外亦不内外可得。时慧亦无所见。内外悉空。除其因缘犹如外道。所学所信彼乐此已。御于笃信。是故曰萨芸若。以恨诸法计一切法。都不可得所从起者。作是信已无有受法者。不复想念有所者也。亦不能获无央数法。当所受者受与。不受亦复不念。所可游居以能修习。于一切法无所念者。是为菩萨摩诃萨般若波罗蜜。亦无去来。度无所度而复周游。所由然者。用不受色不受痛痒思想生死识。于一切法亦无所受。亦不受诸总持门。不受诸三昧门。于一切法无所起受。亦无中间而般涅槃。悉以具足十种力四无所畏四分别辩十八不共诸佛之法四意止四意断四神足念五根五力七觉意八由行。所以者何。其四意止者止无所止。四意断神足根力觉意八由行。亦复如是。其所断者断无所断。十种力四无所畏四分别辩十八不共诸佛之法。觉无所觉法。计其法者亦非法。是为菩萨摩诃萨般若波罗蜜。不受色。亦不受痛痒思想生死识。至于总持门诸三昧门。等无有异。复次天中天。菩萨摩诃萨行般若波罗蜜。当作是观。何所是般若波罗蜜。何以故。谓是为般若波罗蜜。谁为此般若波罗蜜。何以有是般若波罗蜜。用是般若波罗蜜。为亦无所得。亦无所见亦无所不见。是故菩萨摩诃萨般若波罗蜜。复次天中天。菩萨摩诃萨行般若波罗蜜。当作是思惟。其无所有法亦不可得。亦无般若波罗蜜。舍利弗谓须菩提。仁者何所法。谓无所有而不可得。答曰。般若波罗蜜法。亦无所有亦不可得。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。亦复如是。则无所有亦不可得。于内为空。于外亦空。内外亦空。彼空者得致大空。至于真空。无所有空。因其空者。至无有空无常亦空。惶慌亦空。所作事空。本净亦空。自然相空。一切法空。无所有空。自然亦空。所有自然亦空。缘是之故色无所有亦不可得。痛痒思想生死识。亦无所有亦不可得。其内空者。则无所有亦不可得。其所有空无所有空自然之空。悉无所有亦不可得。其四意止。悉无所有亦不可得。四意断四神足五根五力七觉意八由行。悉无所有亦不可得。十种力四无所畏四分别辩十八不共诸佛之法。悉无所有亦不可得。其六神通悉无所有亦不可得。其无有本者。悉无所有亦不可得。所谓法者而住于法。若寂然法及察本际。悉无所有亦不可得。所谓佛者。悉无所有亦不可得。萨芸若者。悉无所有亦不可得。一切具慧。悉无所有亦不可得。其内亦空。计外亦空。内外亦空。所有亦空。自然亦空。唯舍利弗。菩萨摩诃萨行般若波罗蜜。作是思惟。如是观察者。作是思惟已。则不可见心。心无所著无所染污。不恐不惧不畏不难。心不怀懅。则当知是菩萨摩诃萨不离般若波罗蜜。舍利弗谓须菩提。云何菩萨摩诃萨。知之不离般若波罗蜜。须菩提谓舍利弗。所谓离色者。色之自然故。所谓离痛痒思想生死识者。识之自然故也。所谓离檀波罗蜜。檀波罗蜜之自然故。所谓离尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。六波罗蜜自然故也。所谓离意止意断神足根力觉意八由行。三十七品之自然故也。所谓离十种力四无所畏四分别辩十八不共诸佛之法者。诸佛之法自然故也。谓离诸总持门诸三昧门及离本际者。本际自然故也。舍利弗谓须菩提。何谓色自然。何谓痛痒思想生死识自然。何谓十二因缘三十七品十八不共诸佛之法自然乎。须菩提答曰。已无所有故谓自然。色无所有故曰色自然。痛痒思想生死识无所有故。曰痛痒思想生死识自然。无所有至于本际故曰自然。舍利弗。以是故作此观者。则知离色色之自然。则知离痛痒思想生死识之自然。五阴六衰十八种十二因缘三十七品十种力四无所畏四分别辩十八不共诸佛之法。至所本净悉无所有。故曰本净自然。所谓离色色之本相。所谓离痛痒思想生死识痛痒思想生死识之本相一切诸法及诸佛法。离本际者本际相故。色自然相自然相故。谓相自然而得远离。舍利弗谓须菩提。其有菩萨摩诃萨。学此法者。皆当归趣萨芸若不。须菩提谓舍利弗。如是如是。贤者其学此者。归趣萨芸若。所以者何。一切诸法无所起无所灭。舍利弗谓须菩提。何故须菩提。一切诸法不起不灭。答曰。舍利弗。所谓色者。其色则空。以是之故不起不灭亦不可得。痛痒思想生死识则为空。以是之故不起不灭。眼耳鼻舌身意色声香味细滑法十八种十二因缘三十七品。十种力四无所畏四分别辩十八不共诸佛之法。诸总持门一切三昧。至于本际不起不灭亦不可得。菩萨摩诃萨行般若波罗蜜。能如是者则近萨芸若。假使能近萨芸若者。其身口意则自然净。诸相清净自然具足。其身口意以能清净。具足诸相。致清净者应时菩萨即不复起淫怒痴心。淫怒痴心已清净者。则便无有憍慢恚贪。亦不复起六十二见。诸所邪疑贪恚之心已不复兴。则能除于六十二见诸所疑意。诸所生处不造常见。所生之处诸佛国土。从一佛国游一佛国。教化众生严净佛土。常怀专一不离诸佛世尊。至于逮得阿耨多罗三耶三佛。成至阿惟三佛。如是菩萨摩诃萨为行般若波罗蜜

光赞经卷第三光赞经卷第四

        西晋三藏竺法护译

    摩诃般若波罗蜜行品第九

于是贤者须菩提白佛言唯天中天。假使菩萨摩诃萨。无沤和拘舍罗。行般若波罗蜜。若行色者则为行想。行痛痒思想生死识者。则为行想。若行色常则为行想。若行痛痒思想生死识常者。则为行想。若行色无常则为行想。若行痛痒思想生死识无常。则为行想。若行色苦则为行想。若行痛痒思想生死识苦。则为行想。若行色乐则为行想。若行痛痒思想生死识乐者。则为行想。若行色我所者则为行想。若行痛痒思想生死识我所者。则为行想。若行色非我所者则为行想。若行痛痒思想生死识非我所者。则为行想。若行色虚无者则为行想。若行痛痒思想生死识虚无者。则为行想。若使天中天。菩萨摩诃萨行般若波罗蜜。行色寂寞则为行想。行痛痒思想生死识寂寞者。则为行想。假使天中天。菩萨摩诃萨行般若波罗蜜。无沤和拘舍罗。若行四意止则为行想。四意断四神足五根五力七觉意八由行。则为行想。若行十种力四无所畏四分别辩十八不共诸佛之法。则为行想。唯天中天。假使菩萨摩诃萨行般若波罗蜜。而自念言。我行般若波罗蜜。是为菩萨摩诃萨而反行想。假使菩萨摩诃萨。心自念言。作是行者。则为行般若波罗蜜。亦为行想。是为菩萨摩诃萨行般若波罗蜜无沤和拘舍罗。舍利弗问须菩提。菩萨摩诃萨。当云何行般若波罗蜜得般若波罗蜜。须菩提谓舍利弗。假使贤者。菩萨摩诃萨行般若波罗蜜。立色想则不信解。若立色者则不脱想。为行生死想。若行色想。则不得脱无明行识六入所更痛爱受有生老病死忧戚恼会。彼菩萨摩诃萨。为不行般若波罗蜜。则无沤和拘舍罗。立于眼想则不信脱。假使菩萨摩诃萨。立于耳鼻舌身意想。则不信脱。设立于眼色识耳声识鼻香识舌味识身细滑识意法识想。则不信脱。若习眼更耳鼻舌身意所习更。立是诸想则不信脱。假使立四意止四意断四神足五根五力七觉意八由行想。则不信脱。设立于十种力四无所畏四分别辩十八不共诸佛之法想者。则不信脱。而于佛法念行着想。念行想者。则不信脱十二因缘苦恼之患。彼菩萨摩诃萨。不应为声闻辟支佛造证。何况逮得阿耨多罗三耶三菩阿惟三佛乎。所不能及也。如是舍利弗。菩萨摩诃萨行般若波罗蜜。为无沤和拘舍罗。舍利弗谓须菩提。云何菩萨摩诃萨行般若波罗蜜。而有沤和拘舍罗耶。须菩提谓舍利弗。设使菩萨摩诃萨行般若波罗蜜。不行色。不行痛痒思想生死识。不行色想。不行痛痒思想生死识想。不行色常。不行痛痒思想生死识常。不行色无常。不行痛痒思想生死识无常。不行色苦。不行痛痒思想生死识苦。不行色乐。不行痛痒思想生死识乐。不行色我所。不行痛痒思想生死识我所。不行色非我所。不行痛痒思想生死识非我所。不行色虚无。不行痛痒思想生死识虚无。不行色空。不行痛痒思想生死识空。不行色无想。不行痛痒思想生死识无想。不行色无愿。不行痛痒思想生死识无愿。不行色寂寞。不行痛痒思想生死识寂寞。不行色无想。不行痛痒思想生死识无想。所以者何。色者则空。色无异空。色则为空。空者为色。色自然空。痛痒思想生死识空。则无有识。无有异空。识则为空。空者为识。四意止四意断四神足五根五力七觉意八由行为空。无有异空。三十七品计则为空。无别异空。三十七品空。空者三十七品。十种力四无所畏四分别辩十八不共诸佛之法则为空。无有异空。佛法则空无他别异空。空者则法法者则空。如是舍利弗。菩萨摩诃萨行般若波罗蜜。为成沤和拘舍罗。菩萨摩诃萨行般若波罗蜜。如是者逮得阿耨多罗三耶三菩阿惟三佛。彼行般若波罗蜜已。无所受无所行。不受不行。不行不受。不有所行亦非不行。是故无所受亦不有所受。贤者舍利弗谓须菩提。何故菩萨摩诃萨行般若波罗蜜已无所受。须菩提答曰。所以菩萨摩诃萨行般若波罗蜜。自然不可得。由是之故。般若波罗蜜为无所有则为自然。以是故。舍利弗。菩萨摩诃萨行般若波罗蜜。无所受无所行。不受不行。不行不受。不有所行亦不非不行。是故无所受亦不有所受。所以者何。一切诸法为无所有。则谓自然。是故无所至无所犯负。是名曰一切不受三昧之定。菩萨摩诃萨广普玄远而无所量。诸声闻辟支佛所不能及。菩萨摩诃萨以是三昧。疾得阿耨多罗三耶三菩阿惟三佛。舍利弗谓须菩提。菩萨摩诃萨不离是三昧。疾得阿耨多罗三耶三菩阿惟三佛者。复有余三昧乎。须菩提答舍利弗。复有余三昧疾得阿耨多罗三耶三菩阿惟三佛。舍利弗谓须菩提。何所余三昧行。菩萨摩诃萨疾得阿耨多罗三耶三菩阿惟三佛。须菩提谓舍利弗。菩萨摩诃萨行首楞严三昧。疾得阿耨多罗三耶三菩阿惟三佛。须菩提谓舍利弗。复有三昧名曰宝印。复有三昧名曰师子娱乐。复有三昧名曰月曜。复有三昧名曰月幢英。复有三昧名曰一切印。复有三昧名曰无能见顶。复有三昧名曰了法界。复有三昧名曰分别幢英。复有三昧名曰喻金刚。复有三昧名曰入法印。复有三昧名曰立定意王。复有三昧名曰印王。复有三昧名曰势力精进。复有三昧名曰超等。复有三昧名曰入应顺分别。复有三昧名曰入辩于十方界。复有三昧名曰总持意。复有三昧名曰度无为。复有三昧名曰等御诸法海印。复有三昧名曰普周虚空。复有三昧名金刚道场。复有三昧名曰执英幢。复有三昧名曰帝英如门阃。复有三昧名曰起本。复有三昧名曰师子吼。复有三昧名曰精进立。复有三昧名曰胜宝。复有三昧名曰照明。复有三昧名曰不眴。复有三昧名曰不住于下。复有三昧名曰决了。复有三昧名曰灯明广普。复有三昧名曰无量行。复有三昧名曰光造。复有三昧名曰有所照曜。复有三昧名曰庄严净。复有三昧名曰离垢光。复有三昧名曰有所造乐。复有三昧名曰电灯明。复有三昧名曰尽索。复有三昧名曰威神迹。复有三昧名曰离尽索。复有三昧名曰无能胜。复有三昧名曰开通。复有三昧名曰灯明。复有三昧名曰离灯垢。复有三昧名曰严净辩才。复有三昧名曰有所光耀。复有三昧名曰造事。复有三昧名曰慧英。复有三昧名曰住惟。复有三昧名曰普明。复有三昧名曰善立。复有三昧名曰宝积。复有三昧名曰超诸法印。复有三昧名曰普法。复有三昧名曰胜娱乐。复有三昧名曰度法顶。复有三昧名曰有所毁坏。复有三昧名曰一切明句。复有三昧名曰等字所作。复有三昧名曰趣字。复有三昧名曰断因缘。复有三昧名曰无事。复有三昧名曰无墙。复有三昧名曰决了入号。复有三昧名曰无卑行。复有三昧名曰除冥。复有三昧名曰修行迹。复有三昧名曰无动。复有三昧名曰广界。复有三昧名曰决一切德。复有三昧名曰住无心。复有三昧名曰净于严整。复有三昧名曰度觉意。复有三昧名曰无量灯明。复有三昧名曰等不等。复有三昧名曰度一切。复有三昧名曰断诸事。复有三昧名曰离意了除。复有三昧名曰离建立。复有三昧名曰一胜。复有三昧名曰行诸事。复有三昧名曰一事。复有三昧名曰除怨事。复有三昧名曰灭诸所有不当。复有三昧名曰入随因缘音。复有三昧名曰声迹言无尽度。复有三昧名曰威神迹。复有三昧名曰光耀炽盛。复有三昧名曰清净树。复有三昧名曰清证而闲。复有三昧名曰一切胜。复有三昧名曰不乐一切诸苦乐。复有三昧名曰无尽事。复有三昧名曰总持句。复有三昧名曰等于正邪师子座。复有三昧名曰入响离响。复有三昧名曰无响得响。复有三昧名曰离垢明。复有三昧名曰御迹。复有三昧名曰满月离垢光。复有三昧名曰电锭光。复有三昧名曰大严净。复有三昧名曰普照世间。复有三昧名曰普定意。复有三昧名曰应无染离染。复有三昧名曰御空一切等御。复有三昧名曰无青不青宝。复有三昧名曰立无本念。复有三昧名曰身时第一。复有三昧名曰言时除空念。复有三昧名曰脱虚空碍灭护。舍利弗。菩萨摩诃萨行是诸三昧。疾得阿耨多罗三耶三菩阿惟三佛。及余不可计会无有限量。诸三昧门诸总持门。菩萨摩诃萨所当学者。疾逮得阿耨多罗三耶三菩阿惟三佛。于是须菩提。承佛圣旨而叹颂曰。舍利弗。欲知往古怛萨阿竭阿罗诃三耶三佛。则为授此等菩萨摩诃萨决。及今现在十方世界诸现在怛萨阿竭阿罗呵三耶三佛。悉已授此诸菩萨摩诃萨决。其行是三昧者。彼不见三昧。亦不念三昧。亦无所三昧。亦不想我当三昧吾当三昧乎。亦不念我空三昧。是菩萨摩诃萨无想念。舍利弗谓须菩提。菩萨摩诃萨住是三昧。为住古三耶三佛所授决乎。答曰不也。舍利弗。所以者何。唯舍利弗。般若波罗蜜三昧不为异也。菩萨摩诃萨亦不为异。菩萨摩诃萨则为三昧。三昧则为菩萨摩诃萨。舍利弗谓须菩提。如仁者所云。菩萨摩诃萨般若波罗蜜及诸三昧。不为各异。菩萨则三昧。三昧则菩萨。一切法皆平等则不知三昧。以是故。舍利弗。于是三昧。善男子亦不知亦不了。舍利弗又问。何故不知不了。用无明故而为三昧。以是故。菩萨不知不了。尔时世尊赞贤者须菩提。善哉善哉。须菩提。如吾赞仁。行空第一叹之最尊。菩萨摩诃萨学般若波罗蜜。当如是檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。舍利弗白佛言。菩萨摩诃萨学如是。为学般若波罗蜜乎。佛言如是。菩萨摩诃萨如是学。为学般若波罗蜜。所学者亦无所得。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。亦复如是。四意止四意断四神足五根五力七觉意八由行十种力四无所畏四分别辩十八不共诸佛之法。自然具足。虽有所得亦无所得。舍利弗白佛言。菩萨摩诃萨学如是作是学。为学般若波罗蜜得般若波罗蜜乎。佛言。如是学。为学般若波罗蜜得无所得。舍利弗白佛。云何得无所得。世尊答曰。不得吾我。亦不得人寿命。亦不得所见。五阴究竟本末普悉清净。亦不得见也。阴种诸入本末究竟如是悉清净亦不得。无明之原本末究竟而悉清净。行识六入名色所更痛爱受有生老病死。本末究竟而悉清净。苦无所得本末究竟而悉清净。习尽之路亦不可得。本末究竟而悉清净。欲界亦不可得。本末究竟而悉清净。色界无色界亦不可得。本末究竟而悉清净。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法亦不可得。本末究竟而悉清净。六波罗蜜亦不可得。本末究竟而悉清净。须陀洹斯陀含阿那含阿罗汉辟支佛。亦不可得。本末究竟而悉清净。菩萨亦不可得。本末究竟而悉清净。佛亦不可得。本末究竟而悉清净。舍利弗白佛言。何所清净。世尊答曰。无所起无所生。无所得无所行。则为清净。舍利弗言。唯然世尊。菩萨摩诃萨如是学者为学何法。佛言。菩萨摩诃萨学如是者。为学无所学法。所以者何。舍利弗。是诸法者。计其所有而愚凡夫之所倚立。舍利弗白佛言。唯然世尊。谁致是法。佛言。如无所得。以是故得如是逮者。故曰无所逮。又问。世尊。谁无所得而有所得。佛言。色无所得。其内亦空外亦复空内外亦空。所谓所有自然无有而悉为空。色痛痒思想生死识亦无内无外亦无内外。所有自然无有悉空。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。亦无内亦无外亦无内外。所有自然无有悉空。彼愚凡夫从无明教依倚着爱。而有想念。以依无明明为两盲俱。则为不知而无所见。已不知不见。彼则思想不可得。名色。又着于佛法。已有所倚。而欲了知无所有法故不知不见。何谓不知不见。色痛痒思想生死识亦不知不见。十二入十八种。三十七品。十二因缘。十种力四无所畏四分别辩十八不共诸佛之法。亦复不知不见。由是之故名曰为愚。彼不舍施。何所不舍。不舍欲界不舍色界不舍无色界。不舍声闻辟支佛地。则不笃信。何所不信。不信色空。不信痛痒思想生死识空。不信十二入十八种十二因缘三十七品十种力四无所畏四分别辩十八不共诸佛之法为空。不能建立。不建立檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。不住阿惟越致地。复不建立诸佛之法。以是之故名曰为愚。有所倚着眼耳鼻舌身意。倚着诸种诸阴入。倚着依求于淫怒痴。倚着依慕诸疑邪见。倚着依慕于佛道也。舍利弗白佛言。菩萨摩诃萨作是学。为不学般若波罗蜜乎。不生萨芸若耶。佛言。菩萨摩诃萨。作是学般若波罗蜜。不得萨芸若。舍利弗白佛言。唯然世尊。菩萨摩诃萨作是学。不得萨芸若。佛告舍利弗。是菩萨摩诃萨。作是学般若波罗蜜。无沤和拘舍罗。有所思想有所依倚。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。而反想求依倚六波罗蜜三十七品十种力四无所畏四分别辩十八不共诸佛之法。而复想求萨芸若慧。已想求萨芸若而依倚。是故舍利弗。菩萨摩诃萨不学般若波罗蜜。不得萨芸若慧。舍利弗白佛言。菩萨摩诃萨作是学般若波罗蜜。为不学般若波罗蜜。为不行萨芸若慧乎。佛言。如是舍利弗。作是学般若波罗蜜。为不得萨芸若。舍利弗问。唯天中天。菩萨摩诃萨。当云何学般若波罗蜜。而随顺学得萨芸若慧。佛告舍利弗。假使菩萨摩诃萨行般若波罗蜜。不见般若波罗蜜。如是菩萨摩诃萨为行般若波罗蜜。为学般若波罗蜜得萨芸若慧。得无所得无所得无所得。亦复不得檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。亦不得须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。亦不复得萨芸若。如是舍利弗。菩萨摩诃萨作是行。为行般若波罗蜜。为学般若波罗蜜得萨芸若得无所得。舍利弗白佛言。何谓无所得。世尊答曰。于内亦空于外亦空内外亦空。一切法空

    摩诃般若波罗蜜幻品第十

于是贤者须菩提白佛言。唯然世尊。假使问者。此幻士学般若波罗蜜。欲得萨芸若。问者如此以何报答。又斯幻士。学檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜。欲用逮得萨芸若慧。学四意止四意断四神足五根五力七觉意八由行。欲用逮得萨芸若慧。又学萨芸若慧欲以逮得萨芸若。假使来问如此谊者。以何报答。佛告须菩提。我故问汝。于须菩提意云何。从其所知而报答吾。于须菩提意云何。色异乎幻异乎。痛痒思想生死识异乎幻异耶。须菩提。答曰不也。天中天。于须菩提意云何。幻为异乎。眼复异乎。耳鼻舌身意异乎。幻复异乎。眼色识耳声识鼻香识舌味识身细滑识意法识异乎。幻复异耶。所习因缘痛痒之乐异乎。幻复异耶。答曰不也。天中天。于须菩提意云何。四意止异乎。幻复异耶。四意断四神足五根五力七觉意八由行异乎。幻复异耶。空无想无愿异乎。幻复异耶。答曰不也。天中天。于须菩提意云何。幻为异乎。十种力四无所畏四分别辩十八不共诸佛之法。复为异耶。答曰不也。天中天。于须菩提意云何。幻为异乎道复异耶。答曰不也。天中天。幻不为异色亦不异。色则为幻幻则为色。唯天中天。幻不为异。痛痒思想生死识亦不为异。识则为幻幻则为识。唯天中天。幻不为异。眼耳鼻舌身心亦不为异。幻则为眼眼则为幻。眼色识耳声识鼻香识舌味识身细滑识意法识。识则为幻幻则为识。所习因缘痛痒之乐不为异也。痛乐则幻幻则痛乐。唯天中天。幻不为异。四意止亦不异。四意止则为幻幻则四意止意断神足根力觉意由行。则为幻幻则由行。唯天中天。十种力四无所畏四分别辩十八不共诸佛之法。法则为幻幻则为法。于须菩提意云何。所谓幻者。为有尘垢及嗔恨乎。答曰不也。天中天。于须菩提意云何。所谓幻者。有所起有所灭乎。答曰不也。天中天。于须菩提意云何。其不起不灭者。彼学般若波罗蜜已。逮得萨芸若慧。获致一切大哀乎。答曰不也。天中天。于须菩提意云何。于此兴乎所知思想。从习俗教因五盛阴为菩萨乎。答曰如是。唯天中天。于须菩提意云何。有知思想。随其习俗而发言教。以五盛阴。而有所起而有所灭。宁可复得尘劳嗔恨。答曰不也。天中天。于须菩提意云何。其无思想无习俗。无所言教。无所兴立。无有名号。无身无身事。无言无言事。无意无意事。不起不灭。无有尘劳无有嗔恨。又以此事学般若波罗蜜成萨芸若乎。答曰不也。天中天。佛言。如是须菩提。菩萨摩诃萨作是学般若波罗蜜。成萨芸若者则无所有。须菩提白佛言。菩萨摩诃萨当作是学般若波罗蜜及学阿耨多罗三耶三菩。若欲学者当如学幻。所以者何。唯天中天。当观五阴亦如幻士。于须菩提意云何。又此五阴学般若波罗蜜成萨芸若慧乎。答曰不也。天中天。所以者何。其五阴者自然无所有。其有自然无所有者亦不可得。又问。于须菩提意云何。自然之喻五阴如梦。学般若波罗蜜成萨芸若乎。答曰不也。天中天。所以者何。计于梦者自然无所有。其为自然无所有者则不可得。于须菩提意云何。呼声之响喻于五阴。又复譬如水影野马所化之喻。譬如五阴学般若波罗蜜逮成萨芸若耶。答曰不也。天中天。所以者何。其呼声响水影野马所化。自然无所有。其为自然无所有者则不可得。所以者何。唯天中天。分别了色犹如幻也。痛痒思想生死识及十八种六根五阴及五盛阴自然如梦。唯天中天。色痛痒思想生死识十八种六根五盛阴犹如梦也。于内则空了不可得。而无自然则为空矣了不可得。须菩提白佛言。今说于此般若波罗蜜。新学大乘菩萨摩诃萨闻斯说者。得无恐惧畏难怀懅。佛告须菩提。假使新学大乘菩萨摩诃萨于般若波罗蜜不解沤和拘舍罗者。不亲善师。或恐或怖或怀畏懅。须菩提问佛言。唯天中天。何谓菩萨摩诃萨善师。行般若波罗蜜有沤和拘舍罗。菩萨摩诃萨不恐不怖而不怀懅。佛言。此菩萨摩诃萨行般若波罗蜜。志在专精。于萨芸若慧不观色无常。色亦不可得。不观痛痒思想生死识无常。识亦不可得。志观萨芸若。不察无常亦不可得。是菩萨摩诃萨行般若波罗蜜有沤和拘舍罗。复次须菩提。菩萨摩诃萨志在萨芸若慧。不观色苦亦不得色。不观痛痒思想生死识苦。亦不得识。不观色是我所。亦不得我所。不观痛痒思想生死识是我所。亦不得我所。不观色非我所。亦不得非我所。不观痛痒思想生死识非我所。亦不得非我所。复次须菩提。菩萨摩诃萨志学萨芸若。观于色空亦不得空。观痛痒思想生死识空。亦不得空。不观色有常。亦不得常。不观痛痒思想生死识有常。亦不得常。不观色非常。亦不得无常。不观痛痒思想生死识非常。亦不得无常。观色寂寞。亦不得色寂寞。观痛痒思想生死识寂寞。亦不得识寂寞。观色虚无。亦不得色虚无。观痛痒思想生死识虚无。亦不得识虚无。是为菩萨摩诃萨行般若波罗蜜有沤和拘舍罗。复次须菩提。菩萨摩诃萨不观无常亦无所得。苦空无我非身亦无所得。不观无常亦无所得。空无想无愿寂寞虚无。亦无所得。痛痒思想生死识。不观无常亦无所得。眼耳鼻舌身意色声香味细滑法。不观无常亦无所得。非常苦空无我非身。空无想无愿寂然虚无。观于斯事了无所得。彼为众生如此意。吾为一切众生之类。说无常法。为颠倒施令不迷惑。又分别法。为苦无我空无想无愿寂寞虚无。为颠倒者令不迷惑。是菩萨摩诃萨行般若波罗蜜有沤和拘舍罗。复次须菩提。菩萨摩诃萨行般若波罗蜜学行萨芸若慧。思惟其谊。不观色无常。不堕颠倒亦无所得。不观痛痒思想生死识无常。不堕颠倒亦无所得。无苦无我为空。空无想无愿寂寞虚无不令颠倒亦无所得。色痛痒思想生死识离四非常。空无想愿寂寞虚无。观此诸事。不令颠倒亦无所得。假使在于萨芸若慧。念此不舍。此则菩萨摩诃萨惟逮波罗蜜菩萨摩诃萨行般若波罗蜜时。志不思惟声闻辟支佛事。亦不听志劝随其行。是为菩萨摩诃萨行禅波罗蜜不恐不怖亦不畏懅。复次须菩提。菩萨摩诃萨行般若波罗蜜。当造斯观。不用色空而为空也。色则为空空者则色痛痒思想生死识。不专为空。色者则空识自然识。空者为识。眼不专空眼自然空。眼者则空空者则眼。不专为空。耳声识鼻香识舌味识身细滑识意法识。不专空识自然空。识者则空空者则识所习因缘痛痒之乐则为空矣。所习因缘痛痒之乐。自然为空。所习因缘痛痒之乐。观之则空。其心自空。所习因缘痛痒之乐。则亦为空。其四意止不专为空。四意止空故由是为空。其四意止自然为空。四意断四神足五根五力七觉意八由行。不专为空。三十七品则自然。空者则三十七品。三十七品则空。十种力四无所畏四分别辩十八不共诸佛之法不专为空。则自然空。空者则为佛。法则空空者则法。是为菩萨摩诃萨行般若波罗蜜不恐不怖亦不畏懅。须菩提白佛言。何所菩萨摩诃萨善师。说般若波罗蜜。有所拥护。闻之不恐不怖不懅不畏。于是须菩提。菩萨摩诃萨善师。为其说法。不论色不常。色亦不可得亦无所著。以是德本。不以劝助令立声闻辟支佛地。唯学萨芸若慧。是菩萨摩诃萨善师。色痛痒思想生死识。不说无常。亦不可得亦无所著。以是德本。不用劝助令立声闻辟支佛地。常建立之萨芸若慧。复次须菩提。菩萨摩诃萨善师者。为说经法。不论色苦。色不可得亦无所著。痛痒思想生死识。不可得亦无所著。色我所非我所。痛痒思想生死识。我所非我所。不可得亦无所著。又为说法论。色空无想无愿。不可得亦无所著。痛痒思想生死识。空无想无愿。不可得亦无所著。眼耳鼻舌身意。不可得亦无所著。色声香味细滑法及十八种。我所非我所。不可得亦无所著。复次须菩提。菩萨摩诃萨善师者。为其说法论。色寂寞虚无。不可得亦无所著。痛痒思想生死识。寂寞空无。不可得亦无所著。以是德本。不用劝助于声闻辟支佛地。常以劝助萨芸若慧。是谓须菩提菩萨摩诃萨善师。又复讲说。眼寂寞虚无。不可得亦无所著。耳鼻舌身意寂寞虚无。不可得亦无所著。色声香味细滑法寂寞虚无。不可得亦无所著。眼之所习因缘痛痒。说法无常。眼色识耳声识鼻香识舌味识身细滑识意法识。所习因缘痛痒之乐。说无常法。寂寞虚无。不可得亦无所著。以此德本。不用劝助于声闻辟支佛地。常以建立萨芸若慧。是菩萨摩诃萨善师。复次须菩提。菩萨摩诃萨善师。为人说法不论无常。四意止四意断四神足五根五力七觉意八由行。其所行者。无苦无我为空。空无想无愿寂寞虚无。虽说此法。不可得亦无所著。以此德本。不用劝助于声闻辟支佛地。常以建立萨芸若慧。是菩萨摩诃萨善师。复次须菩提。菩萨摩诃萨善师。为人说法。十种力四无所畏四分别辩十八不共诸佛之法。不论无常苦空非身。空无想无愿寂寞虚无。而不可得亦无所著。是菩萨摩诃萨善师。以此德本。不用劝助于声闻事辟支佛地。常以建立萨芸然慧。是菩萨摩诃萨善师。复次须菩提。菩萨摩诃萨善师者。为人讲法。现说色无常苦空非身痛痒思想生死识无常苦空非身。现说眼耳鼻舌身意无常苦空非身。色声香味细滑法无常苦空非身。眼色识耳声识鼻香识舌味识身细滑识意法识无常苦空非身。现说无明无常苦空非身。行识名色六入所更痛爱受有生老病死无常苦空非身。色我所非我所寂寞虚无。痛痒思想生死识我所非我所。空无想无愿寂寞虚无。虽说此法以开化人。而无所得亦无所著。以此德本。不用劝助于声闻事辟支佛地。常以建立萨芸然慧。是菩萨摩诃萨善师。复次须菩提。菩萨摩诃萨为人说经法。现论四意止四意断四神足五根五力七觉意八由行无常苦空非身空无想无愿。是我所非我所寂寞虚无。以此德本。不用劝助于声闻事辟支佛地。常以建立萨芸若慧。是菩萨摩诃萨善师。复次须菩提。菩萨摩诃萨为人说法。现论十种力四无所畏四分别辩十八不共诸佛之法。色无常苦空非身。痛痒思想生死识无常苦空非身。我所非我所空无想无愿寂寞虚无。以此功德本。不用劝助于声闻辟支佛地。常以建立萨芸若慧。是菩萨摩诃萨善师。于是须菩提白佛言。何谓菩萨摩诃萨于般若波罗蜜无沤和拘舍罗。亲近恶师而闻说此般若波罗蜜。或恐或怖而心畏懅。世尊告须菩提曰。是菩萨摩诃萨离萨芸若行。而不亲近般若波罗蜜。假使遇此般若波罗蜜。而心着念禅波罗蜜惟逮波罗蜜羼波罗蜜尸波罗蜜。以檀波罗蜜逮得所施。而以念着檀波罗蜜。是菩萨摩诃萨恶师。复次须菩提菩萨摩诃萨离萨芸若而不思惟。念着内色而想为空。谓色无有自然。念之为空。痛痒思想生死识念着内空。而谓识无有自然。想念于空。又得内色无有自然。想着于空。已想着空谓有所得。念眼内空。自然无有自然为空。又睹得空想念逮致。是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨离于萨芸若。亦不肯于诸通慧。而反于内念色为空。色无所有。念着思惟色自然空。痛痒思想生死识念于内空志于识想。而无所有念自然空。而于内空得内外空。至无所有自然之空。有所获致想念所得。念眼内空。至无所有自然为空。念逮于空想有所得。耳鼻舌身意亦复如是。念于内空思惟着想。于无所有自然得空。是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨行般若波罗蜜。思四意止而得四意止。即自念着而获于斯。四意断四神足五根五力七觉意八由行得三十七品。即自念着而获于斯。是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨行十种力四无所畏四分别辩十八不共诸佛之法。自谓逮得诸佛之法。已有望想。离萨芸若心所当惟念。是菩萨摩诃萨行般若波罗蜜无沤和拘舍罗。闻说般若波罗蜜。或恐或怖而心怀懅。于是须菩提白佛言。唯天中天。云何菩萨摩诃萨而为恶师之所摄录。随恶师教。闻说般若波罗蜜。或恐或怖而心怀懅。佛告须菩提。于是须菩提。菩萨摩诃萨恶师。制止行者。令不得学般若波罗蜜禅波罗蜜惟逮波罗蜜羼波罗蜜尸波罗蜜檀波罗蜜。而反教之不当教此六波罗蜜。是非怛萨阿竭阿罗诃三耶三佛所说。人所合祸横作此经不当听。是不当受持讽诵读。已不当思惟为他人说。是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨恶师者。而不肯为分别觉事。不令观见魔之瑕秽。于是弊魔波旬化作佛像。而即往诣菩萨摩诃萨所。而抑制之。令不修学六波罗蜜。言善男子。用为学此般若波罗蜜。用为学此禅波罗蜜惟逮波罗蜜羼波罗蜜尸波罗蜜檀波罗蜜。何为奉行。当知是菩萨摩诃萨恶师。复次须菩提。于时弊魔化作佛像。为菩萨摩诃萨。说声闻辟支佛经。而为讲论当捐施与。为分别解谊理所趣。敷演美辞。令离菩萨摩诃萨大乘之法堕于声闻辟支佛地。当知是菩萨摩诃萨恶师。复次须菩提。于是弊魔化作佛像。往诣菩萨摩诃萨所。而谓之言。唯善男子。今仁所学非为道心。非阿惟越致。卿之所学。终不逮阿耨多罗三耶三菩阿惟三佛。如是色像魔之罪缘。不能观察亦不觉了知。是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨为精进行。于时弊魔化作佛像。往诣菩萨摩诃萨所。而谓之言。善男子。知眼则为空。便是吾许。亦是我身耳鼻舌身意。则亦为空便是吾许。亦是我身为说经法。色则为空色是吾许。亦是我身痛痒思想生死识是吾许。亦是我身色声香味细滑法是吾许。亦是我身眼所习者因缘痛痒。计则为空。谓是吾许。亦是我身耳鼻舌身意。所习因缘痛痒之乐十八种。计则为空谓是吾身许。亦是我身檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。计则为空谓是吾许。亦是我身。四意止四意断四神足五根五力七觉意八由行。计则为空谓是吾许。亦是我身十种力四无所畏四分别辩十八不共诸佛之法。计则为空谓是吾许。亦是我身用此求慕阿耨多罗三耶三菩阿惟三佛乎。其不分别如是色像魔之所兴。所分别说亦不觉了。如是菩萨摩诃萨恶师。复次须菩提。弊魔复变化作佛像。往诣菩萨摩诃萨所言。善男子。东方诸佛世尊及诸菩萨声闻辟支佛。亦无诸佛声闻辟支佛及与十方世界。其如是辈兴魔事者。不能分别。亦不识知。不能觉了。当知是菩萨摩诃萨恶师。弊魔波旬复化作声闻像。往诣菩萨摩诃萨所。而谓之言。此辈往古皆学精进萨芸若慧。思惟空事。亦复修学声闻辟支佛事。思惟分别而见教授。不为分别如是魔事。当知是菩萨摩诃萨为恶师。复次须菩提。弊魔波旬化作和上形体被服。往诣菩萨摩诃萨所。为菩萨行空寂。志于精进萨芸若慧。思空寂寞。色痛痒思想生死识为空寂寞。眼耳鼻舌身意亦空寂寞。十八种十二因缘。四意止四意断四神足五根五力七觉意八由行。亦复寂寞。十种力四无所畏四分别辩十八不共诸佛之法。亦复寂寞。空无想无愿而为教授。善男子。觉了是法在声闻地。何所造求。不如于是自求灭度。用阿耨多罗三耶三菩阿惟三佛乎。当知是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨恶师者。弊魔波旬化作父母形像。往诣菩萨摩诃萨所。而谓之言。此善男子已得证须陀洹果斯陀含果阿那含果阿罗汉果。而精进行阿耨多罗三藐三菩提阿惟三佛。乃往古世不可计会无央数劫。周旋生死布施手足而修精进。不为分别。如是色像无所益谊。当知是菩萨摩诃萨恶师。复次须菩提。菩萨摩诃萨以是比像观其恶师。已逮见者以得见者。而远离之。为分别说苦空无常非身无想无愿。则为寂寞。为其分别颠倒之事。有所思惟。四意止四意断神足根力觉意由行。亦无所得。十种力四无所畏四分别辩十八不共诸佛之法。不为解说。如是之法魔所兴事而不分别。当知是菩萨摩诃萨恶师。是菩萨摩诃萨所以恶师。有十二缘常当弃之。何况其余

光赞经卷第四光赞经卷第五

        西晋三藏竺法护译

    摩诃般若波罗蜜摩诃萨品第十一

于是贤者须菩提白佛言。唯然天中天。何故号菩萨之谊。何所趣乎。佛告须菩提。无谊之句为菩萨号。所以者何。其菩萨者。无有句迹无有吾我。故曰无句谊为菩萨号。譬如须菩提。飞鸟飞虚空中无有足迹。如是须菩提。欲求菩萨无有句谊。譬如梦中无足迹。如是须菩提。欲求菩萨句谊而无所取。譬如幻变野马呼响现影。如来之化无有足迹。如是须菩提。欲求菩萨无有句谊。譬如须菩提其无本者无有足迹。又察法界则亦无本。其法法者。亦复寂然无有足迹。如是菩萨无有句谊。譬如本际无有句谊。须菩提。菩萨者无有句谊。譬如幻师所化作人彼无足迹。化人无色痛痒思想生死识。如是须菩提。菩萨行般若波罗蜜。为菩萨者无有句谊。譬如幻士无有眼耳鼻舌身意。亦复如是。心无迹色声香味细滑法亦复如是。无有菩萨之句谊也。譬如须菩提欲求内空无有行迹。菩萨摩诃萨行般若波罗蜜。察其菩萨无有句谊。我所非我所。苦乐善恶。若有所有自然空。其所行者无有行迹。菩萨摩诃萨行般若波罗蜜。不能逮得菩萨句谊。譬如幻士。化现四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法无有足迹。如是须菩提。菩萨摩诃萨行般若波罗蜜。无有菩萨之句谊也。譬如怛萨阿竭阿罗诃三耶三佛所现色像无有足迹。如是须菩提。菩萨摩诃萨行般若波罗蜜。则无有菩萨句谊。譬如须菩提怛萨阿竭阿罗诃三耶三佛无有内空之足迹也。如是须菩提。无菩萨句谊也。譬如须菩提我所非我所苦乐善恶。及其所有自然空者无有足迹。如是须菩提。菩萨摩诃萨无有菩萨之句谊也。譬如须菩提菩萨摩诃萨行般若波罗蜜无菩萨句谊。譬如须菩提怛萨阿竭无四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。如是须菩提。菩萨摩诃萨行般若波罗蜜。如是无有菩萨之句谊也。譬如须菩提无为之界。其无为界无有足迹。有为界有为界无有足迹。如是须菩提。菩萨摩诃萨行般若波罗蜜亦复如是。无菩萨之句谊也。譬如须菩提无所生者无有足迹。如是菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如所灭者无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。亦无有行无所作者无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如不可得者。无有尘劳无有嗔恨无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如无所起者不有处所无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如无有诤讼不为嗔恨无有足迹菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。须菩提白佛言。何谓无有色而无所起无有足迹。佛言。色无所起。痛痒思想生死识无所起则无足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如色者。无有尘劳亦无嗔恨无有足迹。痛痒思想生死识。无有尘劳亦无嗔恨无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如眼耳鼻舌身意色声香味细滑法诸种衰入。本无所趣无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如四大六衰之入。无有尘劳嗔恨亦无足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如四意止四意断四神足五根五力七觉意八由行无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如十种力四无所畏四分别辩十八不共诸佛之法无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如四意止自然究竟无有能为致清净者。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如四意止四意断四神足五根五力七觉意八由行。自然究竟无有能为致清净者。菩萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如十种力四无所畏四分别辩十八不共诸佛之法。自然究竟无有能为致清净者。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如身清净者则无所有。其吾我者虚无有实。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如无知无见则为清净无有足迹。用无知无见虚无无有。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如日之宫殿在于虚空。照于众冥无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如火起劫烧坏时天地灰尽。一切万物悉无遗余。不知足迹之所趣。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭阿罗诃三耶三佛遵于戒法无有毁禁。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭阿罗诃三耶三佛有三昧定志无愦乱。菩萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭志妙智慧。无有邪知之足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭而得解脱。无有不脱之足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭度知见慧。无有不度知见慧之足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如怛萨阿竭之光明。日月光明俱无足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如四大天王忉利天焰天兜率天所有光明无有足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如尼摩罗天波罗尼蜜天及于魔界光明。与怛萨阿竭光明俱无足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。譬如梵天梵迦夷天梵具天梵天有光天少光天无量光天光阴天清净天少净天无量净天难及净天善见天所见善天于是见天一善天所有光明。如来光明复无足迹。菩萨摩诃萨行般若波罗蜜亦复如是。无有菩萨之句谊也。所以者何。须菩提。其为道心及菩萨者。其为菩萨之句谊号。于一切法无顺不顺。无应不应。无有不有。无色不见。亦无所取。则为一相谓无有相。菩萨摩诃萨于一切法而无所著。学当作是学。菩萨摩诃萨于一切法。不当觉知一切法谊。须菩提白佛言。唯天中天。何谓一切法。何谓菩萨摩诃萨于一切法而无所著而当学者。云何菩萨摩诃萨不当觉了于诸法义。佛告须菩提。所谓一切法者。谓诸善事若不善事。所可分别。世间事度世事。所有诸漏无有诸漏。有为无为。其有怨敌无有怨敌。是谓须菩提为一切法。菩萨摩诃萨于是诸法不当有着因当学矣。是为菩萨摩诃萨解一切法而无觉知。须菩提白佛言。唯天中天。何所善法在世间者乎。佛告须菩提。其善法者处于世间。谓孝顺父母。奉事沙门梵志。尊敬长老。布施功德遵修经戒。劝念功德。有所修治。善权方便。世间所行十善之本。所谓定想腐败之想。梨秽之想。烂坏之想。啖食之想。愦乱之想。无住之想。烧炙之想。而作此观。四禅四等四无色定。念佛念法及圣众。念于禁戒念于布施念于天上。念于寂然安般守意。志在于身念老病死。是谓须菩提世间善法。何谓世间不善之法。杀生盗窃邪媱妄言两舌恶口绮语贪嫉邪见十恶之事。是谓世间不善之法。何谓不分别法。不能分别身之所行。不能分别口之所言。不能分别心之所念。不能分别四大之本。不能分别五根之原所。不能分别六衰所在。不能分别色阴之事诸种诸入。不能分别善恶所归。是谓不分别法彼谓世间之法。五阴之事及十二入十八诸种。十善之事。四禅四等心四无色定。是谓世间善法之事。彼则何谓度世之法。四意止四意断四神足五根五力七觉意八由行。及三脱门空无想无愿。无他特异及差别者。谓根异根及诸别根。所念所行三昧。无念所行志趣三昧。无念无行三昧。以慧解脱其心安详。所念随顺八解脱门。何等为八。见诸色色。是为第一脱门。内无色想而外见色。虽处于空而不解脱。则不能越一切诸想。是为第二脱门。得于众想在于根本。无有若干众多之念。是为第三脱门。行于无量虚空。虚空成就。是为第四脱门。悉得越度一切虚空。虚空之智。在于无量识慧之行而为成就。是为第五脱门。皆得越度无量慧智之天。而处无有不量。无量之慧成就成行。是为第六脱门。而悉越度一切不用无量之慧。在于有想成就之行。是为第七脱门。而悉越度一切有想无想。悉蠲诸想安寂然行。是为第八脱门。而不复禅亦不学定。渐渐进前入于三昧。何谓渐前入三昧乎。寂然于欲蠲除众恶不善之法。有想有行寂寞得安。行第一禅。除于想念无想无念。其内安详寂然得安。行第二禅。常行安隐无有瑕。所造立行不违圣贤而欢喜安。行第三禅。断苦除安前所曾更。意安意患诸可不可悉以灭尽。无苦无安其志寂然志于清净。行第四禅。应时悉度一切色想。除所集众想之念。无复若干诸想之思。在于无量虚空之慧具足之行。悉度一切诸虚空之慧。在于无量识慧具足之行。悉度一切无量识慧之行。在于无有无量不用慧具足之行。悉度一切无量不用慧已。在于有想无想无量之处具足之行。悉度一切有想无想无量行已。已蠲诸想成寂灭行。度于我所非我所。无苦无乐。一切所更。苦习尽道。四意止四意断四神足五根五力七觉意八由行。至无所有自然之空怛萨阿竭十力四无所畏四分别辩十八不共诸佛之法。何谓为法诸漏未尽。五阴诸事十二诸入。十八诸种十二因缘。四禅四等心四无色定。是谓诸漏不尽法。何谓无漏之法。谓四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。是谓无漏之法。何谓有为之法。欲界色界无色界。及其余事不能分别。不尽其原诸法之本。此复何谓四意止四意断四神足五根五力七觉意八由行十种力四无所畏四分别辩十八不共诸佛之法。是谓有为之法。何谓无为之法。其法不起不灭。亦无所作亦无所住。无有异义。淫怒痴尽则为无本。其无本者则无异法。其于法界于寂然。其审本际。是谓无为之法。何谓怨敌之法。四禅四等心四无色定。是谓怨敌之法。何谓无怨敌法。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。是谓无怨敌法。彼时菩萨于己身想空无所著之法。了无所著而不可动。于一切法所向法门而无有二。悉不觉了一切诸法。由不动摇。须菩提白佛言。云何天中天。何因名菩萨为摩诃萨乎。何故正号摩诃萨。佛告须菩提。摩诃萨者。除诸积聚得至究竟。而为最尊有所成就。以故名曰摩诃萨。须菩提白佛言。唯天中天。所谓摩诃萨者。离于积聚而得究竟。其于菩萨摩诃萨。而为最尊有所成就。佛告须菩提。摩诃萨者。诸所积聚为种姓者。八等之人。须陀洹斯陀含阿那含阿罗汉辟支佛。初发意菩萨至阿惟越致地住者。其摩诃萨者。于是积聚究竟之中。为菩萨行。于中最尊有所成就。菩萨摩诃萨游处其中。心如金刚有所兴发。其摩诃萨于诸积聚究竟之中。而为最尊有所成就。是则名曰为摩诃萨。须菩提白佛言。唯天中天。何谓心如金刚。世尊告须菩提。菩萨摩诃萨发心如是。在于生死无有限量。被僧那铠。一切所有舍而不舍。吾当等心于此一切众生之类发平等志。一切众生。当以三乘而般泥曰。灭度一切众生类已。亦无有人般泥曰者。吾当觉了一切诸法而无所起。而当亲近萨芸若慧。心常存在六波罗蜜行。悉当普学在所归慧。学当具足。当分别觉一乘之法。又当晓了不可计从所入音声。学此诸法。是为菩萨摩诃萨发金刚心。菩萨摩诃萨所住之处而得究竟。而为最尊有所成就。彼无颠倒亦无所得。复次须菩提。菩萨发心如是。其有众生。在于地狱饿鬼畜生勤苦毒痛考掠之处。吾为此类。忍勤苦患令得安隐。彼菩萨摩诃萨。当发此心。吾身为一一人故。在于地狱受勤苦痛考掠之毒。百千亿垓诸劫之数不以为剧。当令彼人至于无余泥洹之界而得灭度。以是方便。一一人故众生之类。更若干苦终不休息。各令人人至于无余泥洹之界而得灭度。然后吾身能为他故殖众德本。于亿千劫。逮得阿耨多罗三耶三菩阿惟三佛。是为须菩提菩萨摩诃萨发金刚心。其摩诃萨所住之处。于诸积聚而得究竟。而为最尊有所成就。复次须菩提。菩萨摩诃萨常当修建微妙之心。当以此心令诸众生得至尊处。彼菩萨摩诃萨所谓微妙心者。从初发意。未曾起生淫欲之心。亦复不起嗔恚之心。亦复不生愚痴之心。心无所起。不发声闻辟支佛心。是为须菩提菩萨摩诃萨修建微妙之心。令诸众生而为最尊有所成就亦无所念。复次须菩提。菩萨摩诃萨常当建心令不动摇。彼菩萨摩诃萨心不动已所思惟萨芸若心亦不念。是为菩萨摩诃萨心不动摇。复次须菩提。菩萨摩诃萨志在一切众生之类。欲令获安。菩萨摩诃萨于众生建立安已。欲诸群萌不舍三乘。亦无所念无所轻慢。是为须菩提菩萨摩诃萨建立安心于诸众生。是为须菩提菩萨摩诃萨行般若波罗蜜。令诸众生至于最尊有所成就。复次须菩提。菩萨摩诃萨当爱于法喜法乐法精进为行。彼何谓爱法。若于诸法而无所畏无所破坏。是谓爱法。何谓喜法。志乐经典不离所乐。是谓喜法。彼何谓乐法。思惟于法多所分别而令广闻。是谓乐法。是为须菩提菩萨摩诃萨行般若波罗蜜。谓摩诃萨。于诸积聚而为究竟。而为最尊有所成就。无有颠倒亦无所得。复次须菩提。菩萨摩诃萨行般若波罗蜜。住于内空住于外空住内外空亦无内外至无所有自然之空。谓摩诃萨。于诸积聚而得究竟。而为最尊有所成就。无所颠倒亦无所得。复次须菩提。菩萨摩诃萨行般若波罗蜜。住四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。住于此法。谓摩诃萨。于诸积聚逮得究竟。而为最尊而所成就。不为颠倒亦无所得。复次须菩提。菩萨摩诃萨建立住金刚三昧。越度过于无量空慧无量识慧无量不用慧无量有想无想。至于虚空无为无色戒定慧解脱知见品三昧之定住度三昧。谓摩诃萨。于诸积聚逮得究竟。而为最尊有所成就。不在颠倒。佛言。须菩提。菩萨摩诃萨住于法已。在于积聚逮得究竟。而为最尊所成就故。谓摩诃萨为摩诃萨

    摩诃般若波罗蜜等无等品第十二

尔时贤者舍利弗白佛。唯天中天。我为堪任讲摩诃萨义乎。所因谓何为摩诃萨者。世尊告言。应讲之耳。舍利弗言。弃损一切所见。吾我见人寿命见。凡夫之事。有志含血有作无作。常见无见。阴见种见。诸衰入见。虚见实见。十二因缘见。四意止四意断四神足五根五力七觉意八由行见。十种力四无所畏四分别辩十八不共诸佛之法。若复睹见教化众生。睹见佛土清净庄严。见于佛道观睹于觉见转法轮。皆悉蠲除如此诸见。而为说法。以故名曰为摩诃萨。摩诃萨义也。须菩提谓舍利弗。何故贤者。菩萨摩诃萨。而见于色痛痒思想生死识。眼耳鼻舌身意色声香味细滑法。吾我人寿命四种衰入十八种。四意止意断神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。舍利弗答曰。贤者且听。此菩萨摩诃萨行般若波罗蜜。无沤和拘舍罗。已遭遇色而兴发见。谓可致得。痛痒思想生死识而兴发见。谓可致得。眼耳鼻舌身意。色声香味细滑法。吾我人寿命四种衰入十八种。三十七品。十种力四无所畏四分别辩十八不共诸佛之法。已遭遇此以兴发诸见。谓有可得。菩萨摩诃萨游于其中。行般若波罗蜜。以沤和拘舍罗。除是诸见而为说法。令离颠倒不求所获。须菩提白佛言。唯天中天。我应堪任说摩诃萨号摩诃萨义之所趣乎。世尊告曰。应说之耳。如我心解承世尊旨。菩萨心者。等无所等无怨敌心。诸声闻辟支佛心所不能及。所以者何。则萨芸若心。无有诸漏亦无因缘。假使如是萨芸若心。无有诸漏亦无因缘。则于彼心而无所著。故曰摩诃萨。摩诃萨假号也。舍利弗谓须菩提。何所菩萨摩诃萨者。所谓心者。等无所等无怨敌心。诸声闻辟支佛心所不能及。须菩提谓舍利弗。仁舍利弗。是菩萨摩诃萨从初发意。未曾见法起者灭者。无所怀来。不增不减无有尘垢。亦无结恨。假使贤者。不起不灭无所怀来。不增不减无有尘垢。亦无结恨。彼无声闻辟支佛心。无菩萨心。亦无佛心。舍利弗。是为菩萨摩诃萨心。等无所等心无怨敌。声闻辟支佛心所不能及。舍利弗谓须菩提。唯须菩提。仁莫但讲声闻辟支佛心所不能及。心不着声闻辟支佛。当复不着于色所求痛痒思想生死识所求。答曰。如是舍利弗。实不着色痛痒思想生死识。亦不着眼耳鼻舌身意色声香味细滑法。不着十八种诸衰入十二因缘。不着四意止四意断四神足五根五力七觉意八由行。不着十种力四无所畏四分别辩十八不共诸佛之法。舍利弗谓须菩提。如向者须菩提之所讲论。其萨芸若心者。无有诸漏亦无因缘。云何贤者。愚凡夫心。不亦无漏无因缘乎。本净为空。至于声闻辟支佛世尊心。无有诸漏无有因缘耶。答曰如是。舍利弗又问。须菩提。色亦不为无漏乎。无因缘乎。本净空乎。痛痒思想生死识。亦不为无漏乎。无因缘乎。本净空乎。答曰如是。舍利弗又问。须菩提。眼耳鼻舌身意。色声香味细滑法。十八种四大衰入十二因缘。不为无漏无因缘本净空乎。四意止四意断四神足五根五力七觉意八由行。不为无漏无因缘本净空乎。十种力四无所畏四分别辩十八不共诸佛之法。无为无漏无因缘本净空乎。答曰如是。舍利弗。诚如所云。愚凡夫心声闻辟支佛心。亦无有漏亦无因缘本净为空。阴种入四大十二因缘。三十七品。十种力四无所畏四分别辩十八不共诸佛之法。亦无有漏亦无因缘本净为空。舍利弗谓须菩提。于此诸心当无所著。又复不当不着无色色乎。不当不着无痛痒思想生死识识乎。又须菩提。不当不着无意止意止乎。无意断意断乎。无神足神足乎。无五根五根乎。无五力五力乎。无七觉意七觉意乎。无八由行由行乎。无十种力种力乎。无四无所畏所畏乎。无四分别辩分别辩乎。无十八不共不共乎。须菩提答曰。如是舍利弗。不当着无色色也。不当着无痛痒思想生死识识也。不当着无眼耳鼻舌身意意也。不当着无色声香味细滑法法也。不当着无四大衰入入也。不当着无十二因缘缘也。不当着无三十七品品也。不当着无十种力力也。不当着无四无所畏畏也。不当着无四分别辩辩也。不当着无十八不共诸佛之法法也。如是舍利弗。行般若波罗蜜。以是之故。其道之心无怨敌心。诸声闻辟支佛心所不及也。亦不想念声闻辟支佛。无所依猗不随颠倒。亦无所得。是故逮成一切诸法

    摩诃般若波罗蜜大乘品第十三

于是贤者分耨文陀尼弗白佛言。唯天中天。我应堪任讲论摩诃萨号义之所趣乎。世尊曰。应所论也。分耨文陀尼弗言。摩诃僧那僧涅。被大德铠菩萨摩诃萨。为摩诃衍志大乘乎。彼其人者为乘大乘。是故天中天。摩诃萨号摩诃萨也。舍利弗谓分耨文陀尼弗。以何因缘。谓菩萨摩诃萨为摩诃僧那僧涅摩诃衍三拔致乎。分褥答曰。于是贤者。菩萨摩诃萨。不为学者。独人众生之类住檀波罗蜜有所施与也。则为一切群萌之故。住檀波罗蜜有所施与耳。不为学者。众生独人住尸波罗蜜所获禁戒。则为一切群萌之故。住尸波罗蜜而获禁戒耳。不为学者。众生独人住羼提波罗蜜能有所忍。则为一切群萌之故。住羼提波罗蜜。而行忍辱耳。不为学者。众生独人住惟逮波罗蜜而为精进。则为一切群萌之故。住惟逮波罗蜜精进耳。不为学者。众生独人住禅波罗蜜而不乱意。则为一切群萌之故。住禅波罗蜜。为一心耳。不为学者。众生独人住般若波罗蜜而行智慧。则为一切群萌之故。住般若波罗蜜。而遵智慧耳。菩萨摩诃萨行般若波罗蜜。不为断绝群萌之类限量众生被僧那铠也。我当灭度若干众生。不灭度若干众生。立若干人于佛道。不立若干人于佛道。又菩萨摩诃萨。则为一切群萌之类。被僧那铠而自惟行。吾身自当具足成满檀波罗蜜。劝助众生。令入一切业檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。吾身自当具足成行般若波罗蜜。劝助众生。一切令入智度无极。复次舍利弗。菩萨摩诃萨。假使行檀波罗蜜所可施与。一切皆为萨芸若遵修其心。以诸众生而为伴侣。是我子也。犹以劝助阿耨多罗三耶三菩。是为舍利弗菩萨摩诃萨行般若波罗蜜僧那之铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜。所可施与。为萨芸若遵修其心。所发心者。不为劝助声闻辟支佛地。是为舍利弗菩萨摩诃萨行檀波罗蜜被僧那铠复次舍利弗。菩萨摩诃萨行檀波罗蜜。所可施与。为萨芸若遵修其心。而常思念。护于禁戒无所犯负。不以劝助声闻辟支佛地。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行尸波罗蜜被僧那铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜。所可施与。为萨芸若遵修其心。而常思念。忍于诸法而以忍辱劝勉众生。而为伴侣。是我子也。而以忍辱劝助。不为声闻辟支佛。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行羼波罗蜜被僧那铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜。所可施与。为萨芸若遵修其心。常奉精进不舍殷勤。所行精进无有诸漏。不以劝助声闻辟支佛。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行惟逮波罗蜜被僧那铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜。所可施与。萨芸若遵修其心。若布施者常一其心无若干念。唯业思惟萨芸若慧。思惟不舍。不听声闻辟支佛行。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行禅波罗蜜被僧那铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜。有所施与。为萨芸若遵修其心。常奉智慧离于邪黠。所业智慧开发一切。无有诸漏。不以劝助声闻辟支佛地。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行般若波罗蜜被僧那铠。复次舍利弗。菩萨摩诃萨行檀波罗蜜所可施与。为萨芸若遵修其心。若施与者。建幻化心无所施与。亦无施者亦无受者。菩萨摩诃萨如是施者。不为劝助声闻辟支佛。逮得阿耨多罗三耶三菩。是为菩萨摩诃萨行般若波罗蜜被僧那铠。分耨文陀尼弗谓舍利弗。设使菩萨摩诃萨其心遵崇萨芸若。于诸波罗蜜无有想求亦无所得。是为菩萨摩诃萨僧那僧涅之谓也。复次舍利弗。菩萨摩诃萨行尸波罗蜜。其心遵崇在萨芸若。而以布施。遵崇萨芸若心。摄护众生。则以劝助阿耨多罗三耶三菩心。是为菩萨摩诃萨行尸波罗蜜为檀波罗蜜。复次舍利弗。菩萨摩诃萨行尸波罗蜜。于此诸法无所忍者不能忍者。无所不忍。是为菩萨摩诃萨行尸波罗蜜为羼波罗蜜。复次舍利弗。菩萨摩诃萨行尸波罗蜜。则自然发精进之事无有懈废。是为菩萨摩诃萨行尸波罗蜜为惟逮波罗蜜。复次舍利弗。菩萨摩诃萨行尸波罗蜜。其心遵崇于萨芸若。思惟所行。不信声闻辟支佛心。常一其心专思禅定无有众乱。是为菩萨摩诃萨行尸波罗蜜为禅波罗蜜。复次舍利弗。菩萨摩诃萨行尸波罗蜜。建行一切诸所有法。观念如幻。亦不念戒亦无所得。不信声闻辟支佛心。分别微妙智慧。是为菩萨摩诃萨行尸波罗蜜为般若波罗蜜。如是舍利弗。菩萨摩诃萨行尸波罗蜜。则为摄取。皆为具足诸波罗蜜。是为摩诃僧那僧涅之谓也。复次舍利弗。菩萨摩诃萨行羼波罗蜜。有所施与。专崇发起萨芸若心。不信声闻辟支佛心。普能忍辱而无结恨。皆以劝助阿惟三佛。复次舍利弗。菩萨摩诃萨行惟逮波罗蜜。有所施与。遵崇发起萨芸若心。不信声闻辟支佛心。常行精进不进不退。逮得阿惟三佛。复次舍利弗。菩萨摩诃萨行禅波罗蜜。有所施与。遵崇发起萨芸若心。不信声闻辟支佛心。其心常定不处于诸乱。无乱不乱。亦不见乱不见定意。复次舍利弗。菩萨摩诃萨行般若波罗蜜。遵崇发起萨芸若心。不信声闻辟支佛心。其心恢大无所不通。不在生死不在灭度。复次舍利弗。菩萨摩诃萨以无色定而行三昧。不随禅教而有所生。是为菩萨摩诃萨沤和拘舍罗般若波罗蜜。复次舍利弗。假使菩萨摩诃萨或行禅定。若四等心。其无色定而以三昧。不失禅定及四等心无色三昧。是为菩萨摩诃萨沤和拘舍罗般若波罗蜜。复次舍利弗。菩萨摩诃萨又修禅思。行四等心无色三昧。而在寂然有所观见。空无相无愿。见斯然后。是为菩萨摩诃萨摩诃僧那僧涅般若波罗蜜。如是舍利弗菩萨摩诃萨。为摩诃僧那僧涅之谓也。如是舍利弗。菩萨摩诃萨设使被如此僧那。八方上下诸佛世界佛天中天。所可宣扬微妙之教。赞颂功德申畅其音。于某世界有菩萨摩诃萨。被大德铠教化众生严净佛土。舍利弗问分耨文陀尼弗。何谓菩萨摩诃萨三拔致等乘大乘。分耨答曰。于是贤者。菩萨摩诃萨行六波罗蜜。寂除众欲。灭去诸恶不善之法。顺想有行而处寂然。存在安隐。便能具足行第一禅。已离于欲无有众恶。蠲除众想所可念者。寂然安隐。则能具足行第二禅。除去众想无念无想。而心自修如圣贤教。不违明达得欣悦安。则便具足得第三禅。除安去苦。前所更历善恶可不可意。无苦无乐。而在寂然得欣悦安。则便具足第四之禅。行四等心。心常慈俱无怨无结亦无颠倒。广大无边遵善无量。普诸世间心之所行而不舍此。悲喜护心亦复如是。护心常俱无怨无结亦无颠倒。广大无边遵善无量。普诸世间心之所行而不舍此。是为菩萨摩诃萨禅思。菩萨摩诃萨以此禅思行四等心。以此瑞应行三昧定。行斯已后。皆以劝助萨芸若慧。是为菩萨摩诃萨六波罗蜜檀波罗蜜之本。尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。皆各各如是。是为菩萨摩诃萨僧那僧涅之谓也。复次舍利弗。菩萨摩诃萨与慈心俱广远弘普。而无有二无有边崖无有结。而无有斯在于一处。信第一第二第三第四。亦复如是。至下无际上去无限。八方上下无不周遍。具足四禅。是为菩萨摩诃萨三昧。假使菩萨摩诃萨遵崇其心在萨芸若。行第一禅而以救摄一切众生。悉劝助之于诸通慧。其菩萨摩诃萨。具足萨芸若而发慧心。然以方便畅发谊意。为人说经。是为菩萨摩诃萨檀波罗蜜。又菩萨摩诃萨其心至于萨芸若慧。思惟遵修度第一禅。假使能住第一禅者。不复信乐发异心者。不随声闻辟支佛心。是为菩萨摩诃萨不犯于他为尸波罗蜜。假使菩萨摩诃萨其心志在萨芸若慧。遵修思惟即自发念。令一切人众生之类勤苦灭尽。为说经法。随其心念所喜乐者。观其根原而开化之。是为菩萨摩诃萨行羼波罗蜜。假使菩萨摩诃萨其心遵修萨芸若慧。劝助一切功德之本。于诸通慧。不见精进之所归趣。是为菩萨摩诃萨行惟逮波罗蜜。假使菩萨摩诃萨其心遵修萨芸若慧。从第一禅至于四禅。而复观察无常苦空非身空无相无愿。是为菩萨摩诃萨行禅波罗蜜。假使菩萨摩诃萨其心遵崇萨芸若慧。观一切法譬如幻化。无有三界为人说经。是为菩萨摩诃萨行般若波罗蜜。贤者舍利弗。是为菩萨摩诃萨摩诃衍事。复次舍利弗。菩萨摩诃萨摩诃衍者。建立一切四意止四意断四神足五根五力七觉意八由行。又复建立一切具足于空三昧无相无愿三昧。十种力四无所畏四分别辩十八不共诸佛之法。是为菩萨摩诃萨摩诃衍。复次舍利弗。菩萨摩诃萨不告无求此二地声闻地辟支佛地。其心唯乐萨婆若慧。是菩萨摩诃萨行无放逸为四等心。成羼波罗蜜。假使菩萨摩诃萨其心遵修。而自兴发一切哀慧。所行无限无所破坏。是为菩萨摩诃萨行惟逮波罗蜜。假使菩萨摩诃萨。于四等心而行禅定。不从禅定及四等心。有所忘失。是为菩萨行无放逸四等之心沤和拘舍罗。复次舍利弗。菩萨摩诃萨慈心三昧。我当救护一切众生。则以遵崇行哀三昧。愍伤行悲而顺趣此。行喜三昧。我当度脱众生之类。转渐进前至护三昧。加于众生至诸漏尽。是为菩萨摩诃萨无有放逸行四等心檀波罗蜜。假使禅思无有放逸行四等心。因缘瑞应。不以劝助声闻辟支佛地。则顺专于一切哀慧。是为菩萨摩诃萨四等心行无所犯负尸波罗蜜。复次舍利弗。菩萨摩诃萨摩诃衍者。晓了内空不堕颠倒。亦无所求不有所得。苦乐善恶。有所有所自然空。于诸通慧亦无所得。无有内外不得中间。是为菩萨摩诃萨摩诃衍。复次舍利弗。菩萨摩诃萨摩诃衍者。于一切法亦无有乱无三昧慧。是为菩萨摩诃萨摩诃衍。复次舍利弗。菩萨摩诃萨摩诃衍者。常志大乘其慧自由。其慧不在有常不在无常。不计苦不苦乐不乐。其不由慧。在于我所及非我所。是为菩萨摩诃萨摩诃衍。为无所得不堕颠倒。复次舍利弗。菩萨摩诃萨摩诃衍者。其慧自由。不在于过去不在于当来不在于现在。不在三世无慧之处。是为菩萨摩诃萨摩诃衍常无所得不堕颠倒。复次舍利弗。菩萨摩诃萨摩诃衍者。其慧不由着于欲界。不在色界不在无色界。而慧自在。悉知欲界色界无色界。而得自在。亦无所得不堕颠倒。是为菩萨摩诃萨大乘。复次舍利弗。菩萨摩诃萨摩诃衍者。而慧自在。不与世慧同。亦不在没世慧。不在有为不在无为。不在有漏不在无漏。于此法慧而得自由。悉知世俗慧度世慧。不为不及。悉知有为无为法。不为不及。亦无所得不堕颠倒。是为菩萨摩诃萨大乘

光赞经卷第五光赞经卷第六

        西晋三藏竺法护译

    摩诃般若波罗蜜乘大乘品第十四

贤者舍利弗问分耨文陀尼弗。云何菩萨摩诃萨乘于摩诃衍。分耨谓舍利弗。唯贤者。菩萨摩诃萨。于是行般若波罗蜜乘檀波罗蜜。亦复不得檀波罗蜜。亦无菩萨。不见受者有所得也。亦无所获也。乘檀波罗蜜。则谓菩萨摩诃萨。尸波罗蜜羼提波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。乘般若波罗蜜。则亦不得般若波罗蜜。亦不得菩萨亦无所获。是为菩萨摩诃萨乘般若波罗蜜。亦无所得。复次舍利弗。菩萨摩诃萨。亦不毁失萨芸若遵修之心。则寻奉行于四意止。所念无念所行无行。于此众谊亦无所得。是为菩萨摩诃萨乘摩诃衍。复次舍利弗。菩萨摩诃萨。亦不毁失萨芸若慧遵修之心。于四意断四神足五根五力七觉意八由行。于此之谊亦无所得。是为菩萨摩诃萨乘摩诃衍。复次舍利弗。菩萨摩诃萨。亦不毁失萨芸若遵修之心。十种力四无所畏四分别辩十八不共诸佛之法。于此之谊皆无所得。是为菩萨摩诃萨乘摩诃衍。复次舍利弗。菩萨摩诃萨分别了此。所谓菩萨者随俗假号。欲求人亦不可得亦无有起。所谓色者但假号耳。所谓痛痒思想生死识者但假号耳。亦不可得亦无所起。所谓眼耳鼻舌身意但假号耳。亦不可得亦无所起。所谓色声香味细滑法但假号耳。亦无可得亦无所起。所谓四意止四意断四神足五根五力七觉意八由行但假号耳。亦不可得亦无所起。所谓十种力四无所畏四分别辩十八不共诸佛之法但假号耳。亦不可得亦无所起。所谓内空外空及于空空但假号耳。亦不可得亦无所起。谓所有空自然空所有自然空但假号耳。所谓怛萨阿竭法无本之法诸法之界。其法寂然及于本际。其本际者。亦不可得亦无所起。所谓佛道有所觉者。又其佛道亦不可得亦无所起。是为菩萨摩诃萨乘摩诃衍。复次舍利弗。菩萨摩诃萨从初发意。则具足此菩萨神通开化众生。从一佛国游一佛国。供养奉事诸佛世尊。殷勤亲近诸佛世尊。而听经法求菩萨乘。其人于彼乘菩萨行。从一佛国游一佛国。严净佛土教化众生。亦不相着诸佛国土。亦无人相处无二地。而其身力。常为众生之故导利群[黍-禾+利]。彼何谓为自身故。有所摄取。心未曾离如此之乘。逮得至于萨芸若慧。已能逮得萨芸若慧。便转法轮。已转法轮。则为一切声闻辟支佛天龙鬼神世间人民。有所加益。于是八方上下诸怛萨阿竭阿罗诃三耶三佛。悉共赞叹宣扬其音。某菩萨摩诃萨在某世界。乘摩诃衍得萨芸若慧。已得萨芸若慧则转法轮。是为舍利弗菩萨摩诃萨乘摩诃衍也

    摩诃般若波罗蜜无缚品第十五

须菩提白佛言。所谓摩诃僧那僧涅。菩萨摩诃萨被大德铠。何谓菩萨摩诃萨僧那僧涅者。佛告须菩提。于是菩萨摩诃萨被戒德铠。行檀波罗蜜尸波罗蜜羼波罗蜜禅波罗蜜般若波罗蜜。为摩诃僧那僧涅。四意四断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。内空僧那僧涅。外空僧那僧涅。其诸所有自然之空僧那僧涅。萨芸若慧僧那僧涅。被佛形像僧那僧涅已。则以光明照三千大千世界。八方上下亦复如是。其大光明靡不周遍。又复能动三千大千世界。至于东方江河沙等佛土。八方上下各亦如是。莫不涌震。其菩萨摩诃萨。以是光明住檀波罗蜜。被摩诃衍大僧那铠。变现三千大千世界。悉为绀琉璃。这变三千大千世界。为绀琉璃已。则复变为转轮圣王。已变现为转轮圣王庄严之像。则能广施。饥者与食。渴者给浆。无衣与衣。无香与香。华饰杂香捣香车乘象马僮仆侍使。恣人所求。屋宅居止所当得者。生活之业。及余众人所欲得者。悉令得所。饮食衣服香华象马屋宅。所当得者皆施众人。令各得所已。则为众生分别说法宣义具足。遵修六波罗蜜。斯诸萌类闻所说法。则便寻迹行波罗蜜。至使逮得阿耨多罗三耶三菩阿惟三佛。是为菩萨摩诃萨摩诃衍僧那僧涅。譬如须菩提明慧幻士及慧弟子。于四大衢化作众人生活之业。所以者何。诸幻师法自应当然。以此为术。施于无数众生人之所乏。饮食衣服香华诸饰象马屋宅。于须菩提意云何。其幻师者。宁有所施给众乏乎。答曰。不也天中天。佛言。如是须菩提。菩萨摩诃萨行六波罗蜜。三十七品内空外空及内外空及诸所有自然之空。所被僧那铠。十种力四无所畏四分别辩十八不共诸佛之法僧那之铠。及萨芸若僧那僧涅。化为佛像被大德铠。其光普照三千大千世界。及于东方八方上下江河沙等诸佛国土。靡不周遍。十方各如江沙等诸佛世界六反震动。以大光住檀波罗蜜。随人所求。饮食衣服香华诸饰象马舍宅生活之业。虽化所施竟无所与。众人各来有所受取生活之具。亦无施者亦无受者。所以者何。须菩提。是诸法者亦复如幻幻不离法。是为菩萨摩诃萨摩诃僧那僧涅。复次须菩提。菩萨摩诃萨住尸波罗蜜。欲以救护诸受生者。故复现生转轮王种。彼这立于转轮王位。便以十善建发众生。四禅四等心四无色定四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。为诸众生广说经典。未曾令其离斯道谊。能使安隐至得佛道。是为僧那。譬如须菩提明达幻师若慧弟子。于大四衢化无数众不可称计。为诸化人讲说经法建立十善三十七品十种力四无所畏四分别辩十八不共诸佛之法。于须菩提意云何。宁有众人住十善乎。及三十七品十种力四无所畏四分别辩十八不共诸佛之法乎。答曰。不也天中天。如是须菩提。菩萨摩诃萨开化众生。令住十善三十七品十八不共诸佛之法。亦无所劝立于众生也。所以者何。须菩提。是谓诸法者亦复如幻幻不离法。如是须菩提。是为菩萨摩诃萨摩诃衍僧那僧涅也。复次须菩提。菩萨摩诃萨住羼波罗蜜。劝化众生立忍度无极。何谓菩萨住羼波罗蜜。开化一切众生之类立于忍辱无极之法。于是须菩提。菩萨摩诃萨从初发意。等被德铠而自誓愿。假使一切群萌之类刀杖加我。使菩萨摩诃萨不当兴发嗔恨之意须臾间也。亦复教化一切众生使立此忍。譬如须菩提明达幻师及慧弟子。于大四衢化作无数不可计人。寻而捶挝以刀斫害。宁有所挝所斫害乎。答曰。不也天中天。佛言。如是须菩提。菩萨摩诃萨行羼波罗蜜。若有刀杖加其身者皆而忍之。又化众生令立此忍。亦无挝者亦无忍者。是为须菩提菩萨摩诃萨羼波罗蜜摩诃衍僧那僧涅也。复次须菩提。菩萨摩诃萨住惟逮波罗蜜。劝化一切众生之类。皆令建立惟逮波罗蜜。佛言。云何菩萨摩诃萨。建立众生于精进度无极。于是须菩提。菩萨摩诃萨其心遵修萨芸若慧而发道意。亦无相念亦无精进。劝发众生令履其行。譬如须菩提明达幻师若慧弟子。于大四衢化作无数不可计人。令行精进护身口意。亦无是人亦无身口意亦无所行。如是须菩提。菩萨摩诃萨立于惟逮波罗蜜。劝化众人令行精进。无精进相亦无所行。亦不开化众生之类立于精进。是为菩萨摩诃萨惟逮波罗蜜摩诃衍僧那僧涅。复次须菩提。菩萨摩诃萨住禅波罗蜜。劝化一切群萌之类以禅波罗蜜。云何须菩提。菩萨摩诃萨住禅波罗蜜。等住诸法诸法无乱。亦不睹见诸法烦愦。菩萨摩诃萨以能住此。于禅波罗蜜等在无本。劝助众生于平等法。彼所教化。未曾违远于诸佛教。至得阿耨多罗三耶三菩阿惟三佛。亦无至于阿惟三佛者。譬如明达幻师若慧弟子。于大四衢化作无数不可计人。皆令坐禅。心定意而无所定亦无乱。如是须菩提。菩萨摩诃萨劝化众生。令作等法。不见诸法有一心者若乱意者。是为菩萨摩诃萨禅波罗蜜摩诃衍僧那僧涅也。复次须菩提。菩萨摩诃萨住般若波罗蜜。开发众人群萌之类。悉令住于智度无极。云何自住般若波罗蜜。劝化众生智度无极。如是须菩提。菩萨摩诃萨亦无有法而所行者亦无所护。是菩萨摩诃萨住般若波罗蜜已。亦以此法开化一切。使得度去无所拘碍。譬如明达幻师若慧弟子。化作无数不可计人。智慧辩才多所分别。无有智慧亦无所说。于须菩提意云何。宁有所说有所听乎。答曰。不也天中天。佛言。是为菩萨摩诃萨摩诃衍僧那僧涅也。复次须菩提。菩萨摩诃衍僧那僧涅。自住于自然之法。开化东方江河沙等一切众生。皆使履行檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。为讲说法。假使众生得闻于此六波罗蜜。终不复离六度无极阿耨多罗三耶三菩阿惟三佛。十方一切皆悉如是。犹如东方诸佛国土。十方一切皆悉如是等无差特。譬如须菩提明达幻师若慧弟子。于四大衢化作无数不可计人。布施持戒忍辱精进一心智慧。亦无施与。亦无持戒。亦无忍辱。亦无精进。亦无一心。亦无智慧。如是须菩提。菩萨摩诃萨摩诃衍僧那僧涅也

复次须菩提。菩萨摩诃萨三拔致遵崇其心。于萨芸若未曾起发于他异心。亦无所信无所听受。或开化人立檀波罗蜜。或开化人立尸波罗蜜。或开化人立羼波罗蜜。或开化人立惟逮波罗蜜。或开化人立禅波罗蜜。或开化人立般若波罗蜜。于开化人至无所立。于无所化。化若干人立四意止。化若干人立四意断。化若干人立四神足。化若干人立五根五力七觉意八由行。化若干人立十种力四无所畏四分别辩十八不共诸佛之法。或不开化。或开化人立须陀洹果。或开化人立斯陀含果。或开化人立阿那含果。或开化人立阿罗汉果。或开化人立辟支佛果。或若干人不可开化。立若干人于萨芸若慧。若干人不当开化。有所不可计会不可限量群萠之类。当化立之于檀波罗蜜尸羼惟逮禅那般若波罗蜜。四意止四意断四神足五根五力七觉意八由行。十种力四无所畏四分别辩十八不共诸佛之法。开化众生不可计会不可限量于萨芸若慧。于须菩提意云何。开化若干不可计人。各有所趣各有所起各使得度。宁有所起有度者不。答曰。不也天中天。佛言。如是菩萨摩诃萨以六波罗蜜。有所开化。三十七品及诸佛法。四道缘觉。亦无所趣亦无所度。是为须菩提菩萨摩诃萨摩诃衍僧那僧涅。须菩提白佛言。唯天中天。若我闻法察其中谊。当观菩萨摩诃萨则不复为僧那僧涅。所以者何。因从空兴诸自然相。以是故。天中天。诸色色空。诸痛痒思想生死识空。察眼眼空。耳鼻舌身意意空。察眼色识耳声识鼻香识舌味识身细滑识意法识。十八之种皆亦复空。眼之所习。耳鼻舌身意所习。如是六情所习亦复如是。皆为空习。一切悉空所习法空。唯天中天。檀波罗蜜亦空。尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。皆亦悉空。察内亦空内空亦空。其无所有自然亦空。其空亦空。四意止亦空。四意断四神足五根五力七觉意八由行亦空。十种力四无所畏四分别辩十八不共诸佛之法亦空。所谓菩萨亦空。僧那僧涅亦空。唯天中天。以是之故。当观菩萨摩诃萨为无僧那僧涅。佛告须菩提。如是如是。须菩提。诚如所云。佛告须菩提。萨芸若有为无所作亦非不作亦无所有。一切众生亦无作亦无所有。菩萨摩诃萨为众生故。被大僧那铠。亦无所作亦非不作亦无所有。须菩提白佛言。唯天中天。何以故。萨芸若慧。亦无所作亦非不作亦无所有。此众生类。亦无有作亦非不作亦无所有。及诸菩萨摩诃萨僧那僧涅。亦如是也。世尊答曰。有所作有所得。则有所兴。而萨芸若。亦无所作亦非不作亦无所有。是诸众生。亦无有作亦非不作亦无所有。所以者何。色无造者亦无不造。亦无所行亦无所作。痛痒思想生死识。无有造者亦无不造。亦无所行亦无所作。眼者亦无所造亦无不造。亦无所行亦无所作。耳鼻舌身意。亦无有造亦无不造。亦无所行亦无所作。色声香味细滑法。亦无所造亦无不造。亦无所行亦无所作。十八种六情所习因致痛痒。亦无有造亦无不造。亦无所行亦无所作。吾我须菩提亦无有造亦无不造。亦无所行亦无所作及有所知有所见。亦无有造亦无不造。亦无所行亦无所作。以是之故。究竟本末无有根原而不可得。众生及梦。亦无有造亦无不造。亦无所行亦无所作。所以者何。究竟本末无有根原亦不可得。如呼声响水中之月幻化野马。亦无有造亦无不造。亦无所作亦无所行。所以者何。究竟本末无有根原亦不可得。其内空者。须菩提。亦无有造亦无不造。亦无所行亦无所作。外空亦然。其有所有及自然空。亦无有造亦无不造。亦无有行亦无所作。三十七品十种力四无所畏四分别辩十八不共诸佛之法。亦无有造亦无不造。亦无所行亦无所作。所以者何。究竟本末无有根原亦不可得。其无本者。须菩提。亦无有造亦无不造。亦无所行亦无所作。无本亦复如是。亦无有异法其法种者。住于法界诸法寂然。其本际者。亦无有造亦无不造。亦无所行亦无所作。所以者何。究竟本末无有根原亦不可得。其菩萨者。亦无有造亦非不造。亦无所行亦无所作。萨芸若慧一切哀慧。亦非有造亦非不造。亦无所行亦无所作。所以者何。究竟本末无有根原亦不可得。其菩萨者。亦无有造亦非不造。亦无所行亦无所作。萨芸若慧一切哀慧。亦无有造亦非不造。亦无所行亦无所作。所以者何。究竟本末无有根原亦不可得。以是故。须菩提。无所作。萨芸若。亦无所作亦非不作。众生如是。亦无所作亦非不作。菩萨摩诃萨所因摩诃衍僧那僧涅。以是故。须菩提。当察菩萨摩诃萨亦无摩诃衍僧那僧涅也。须菩提白佛言。如是世尊。教分别其谊。我分别谊。色无著无缚无脱。痛痒思想生死识。无著无缚无脱。分耨文陀尼弗问须菩提。色为无著无缚无脱痛痒思想生死识。为无著无缚无脱。须菩提谓分耨文陀尼弗。如是贤者。色无著无缚无脱。痛痒思想生死识。无著无缚无脱。分耨又问。须菩提。何所色。无著无缚无脱。何所痛痒思想生死识。无著无缚无脱。须菩提答曰。色自然。无著无缚无脱。痛痒思想生死识自然。无著无缚无脱。色如呼响。无著无缚无脱。痛痒思想生死识如呼响。无著无缚无脱。色如野马。无著无缚无脱。痛痒思想生死识如野马。无著无缚无脱。色如幻。无著无缚无脱。痛痒思想生死识如幻。无著无缚无脱。色如化。无著无缚无脱。痛痒思想生死识如化。无著无缚无脱。过去色。无著无缚无脱。过去痛痒思想生死识。无著无缚无脱。当来色。无著无缚无脱。当来痛痒思想生死识。无著无缚无脱。现在色。无著无缚无脱。现在痛痒思想生死识。无著无缚无脱。色无实。无著无缚无脱。痛痒思想生死识无实。无著无缚无脱。色憺怕。无著无缚无脱。痛痒思想生死识憺怕。无著无缚无脱。色无所生。无著无缚无脱。痛痒思想生死识无所生。无著无缚无脱。分耨。色善无著无缚无脱。痛痒思想生死识善。无著无缚无脱。色不善无著无缚无脱。痛痒思想生死识不善。无著无缚无脱。色无记。无著无缚无脱。痛痒思想生死识无记。无著无缚无脱。色不分别。无著无缚无脱。痛痒思想生死识不分别。无著无缚无脱。分耨。世俗色。无著无缚无脱。世俗痛痒思想生死识。无著无缚无脱。度世色。无著无缚无脱。度世痛痒思想生死识。无著无缚无脱。有漏无漏色。无著无缚无脱。有漏无漏痛痒思想生死识。无著无缚无脱。虚无。无著无缚无脱。恍忽。无著无缚无脱。一切诸法。无著无缚无脱。无所有。无著无缚无脱。寂然。无著无缚无脱。檀波罗蜜。无著无缚无脱。尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。无著无缚无脱。发至实。无著无缚无脱。发至寂寞。无著无缚无脱。内空无著无缚无脱。外空无著无缚无脱。其所有自然空。无著无缚无脱。四意止。无著无缚无脱。四意断四神足五根五力七觉意八由行。无著无缚无脱。十种力四无所畏四分别辩十八不共诸佛之法。无著无缚无脱从虚无起。无著无缚无脱。佛道无著无缚无脱。萨芸若。无著无缚无脱。学菩萨道。无著无缚无脱。从虚无生。无著无缚无脱。寂然无所生。无著无缚无脱。其无本者。无著无缚无脱。又无本者无有异。顺法住。无著无缚无脱。其寂定法无著无缚无脱。其本际者及于无为。无著无缚无脱。无实所兴。无著无缚无脱。空寂不起所兴。无著无缚无脱。是为贤者分耨菩萨摩诃萨无著无缚无脱波罗蜜也。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。无著无缚无脱。萨芸若无本慧一切哀慧转上所作。皆亦无著无缚无脱。转进上升。布施持戒忍辱精进一心智慧。转进上升。无著无缚无脱。转升上至。住萨芸若慧一切哀慧。无著无缚无脱。教化众生。无著无缚无脱。严净佛土。无著无缚无脱。奉事诸佛世尊。无著无缚无脱。听省经典。无著无缚无脱。未曾离诸佛。无著无缚无脱。未曾亡失神通。无著无缚无脱。不离五根。无著无缚无脱。不释总持。无著无缚无脱。不舍三昧。无著无缚无脱。于道发哀。无著无缚无脱。萨芸若慧。无著无缚无脱。所转法轮。无著无缚无脱。开化众生存于三乘。无著无缚无脱。须菩提谓分耨文陀尼弗。是为菩萨摩诃萨六波罗蜜无著无缚无脱。觉了一切诸正觉法。从虚无起。寂寞恬怕与无从生。是为分耨菩萨摩诃萨无著无缚无脱摩诃僧那僧涅也

    摩诃般若波罗蜜三昧品第十六

贤者须菩提白佛言。唯天中天。何谓菩萨摩诃萨摩诃衍僧那。何谓菩萨摩诃萨摩诃衍。学大乘者何所誓志于衍。衍何所住从何生。衍中谁为成衍者。佛告须菩提。如须菩提之所问也。何所菩萨摩诃萨衍者。六波罗蜜则为菩萨摩诃萨摩诃衍也。何等六。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。彼何谓檀波罗蜜。于是须菩提。菩萨摩诃萨遵崇发心存萨芸若而行布施。内外所有一切不惜以给众生以为坚固。不备怨敌则以劝助阿耨多罗三耶三菩。是为菩萨摩诃萨檀波罗蜜。何等菩萨摩诃萨尸波罗蜜。于是菩萨摩诃萨。遵崇发心存萨芸若。身自奉行十善之事。复以十善劝助人不堕颠倒。亦无所得。是为菩萨摩诃萨于尸波罗蜜无所亡失不堕颠倒亦无所得。须菩提白佛言。唯天中天。何谓菩萨摩诃萨羼波罗蜜。佛告须菩提。于是菩萨摩诃萨。己身能具足忍辱。教化他人立于忍辱不堕颠倒亦无所得。是为菩萨摩诃萨羼波罗蜜。须菩提白佛言。唯天中天。何谓菩萨摩诃萨惟逮波罗蜜。佛告须菩提。菩萨摩诃萨其心遵崇萨芸若慧。于五波罗蜜不以疏远。以五波罗蜜教化众生不堕颠倒亦无所得。是为菩萨摩诃萨惟逮波罗蜜。须菩提又问。世尊。唯天中天。何谓菩萨摩诃萨禅波罗蜜。佛告须菩提。菩萨摩诃萨遵崇发心存萨芸若慧。己身常以沤和拘舍罗行禅三昧。不随顺从三昧而生也。亦教人令学禅定不堕颠倒亦无所得。是为菩萨摩诃萨禅波罗蜜。须菩提白佛言。唯天中天。何等为菩萨摩诃萨般若波罗蜜。佛告须菩提。菩萨摩诃萨遵崇发心萨芸若慧。于一切法无依倚。观于诸法一切本净。不堕颠倒亦无所得。于一切法以无所著。以观诸法一切本净。则以斯法教化众生。不堕颠倒亦无所得。是为菩萨摩诃萨般若波罗蜜。是为菩萨摩诃萨摩诃衍也。复次须菩提。菩萨摩诃萨摩诃衍者。诸内为空。外亦为空。内外悉空。空亦复空。至号大空。真妙之空。清净之空。有为空无为空。自然相空。一切法空。无所得空。无有空而自为空。而有所见无所有空。彼何谓为内空。谓内法者。眼耳鼻舌身意。彼所谓眼眼所见者则亦为空。不可毁伤不可坏起。所以者何。本净故也。其耳耳所听者则亦为空。不可毁伤不可坏起。所以者何。本净故也。其鼻鼻所嗅者则亦为空。不可毁伤不可坏起。所以者何。本净故也。其舌舌所尝味者则亦为空。不可毁伤不可坏起。所以者何。本净故也。其身身所受者亦复为空。不可毁伤不可坏起。所以者何。本净故也。其心心所念者亦复为空。不可毁伤不可坏起。所以者何。本净故也。是谓内空。彼何谓外空。外所云法色声香味细滑念也。其色色者亦复为空。不可毁伤不可坏起。所以者何。本净故也。是色声香味细滑法空。不可毁伤不可坏起。所以者何。本净故也。彼何谓内外法空。内六入外六入。是为内外法空。彼何谓外法空。不可毁伤不可坏起。所以者何。本净故也。是内法外法则悉空故。故不可毁伤不可坏起。所以者何。本净故也。是为内外法空。彼何谓空亦空。谓一切法空诸法空亦此空空。是谓空空。彼何谓为大空。所谓东方亦空。南方西方北方东南西南西北东北方上方下方。皆亦悉空。不可毁伤不可坏起。所以者何。本净故也。何谓真妙空者。曰无为者也其无为者无为亦空。不可毁伤不可坏起。所以者何。本净故也。是谓真妙空。彼何谓所有空。所有空者。谓欲界色界无色界空。不可毁伤不可坏起。所以者何。本净故也。彼何谓无为空。所谓无为空者。不起不灭亦不自在。亦无所住存在真谛。是为无为空。彼所谓无为空。其无为空者。不可毁伤不可坏起。所以者何。本净故也。彼何谓究竟空。究竟空者。谓不可得崖际。所以者何。本净故也。是谓究竟空。彼何谓广远空。谓不见来亦无所得。所以者何。本净故也。是谓广远空。彼何谓不分别空。彼无能舍法亦无所住。所以者何。本净故也。是为不分别空。彼何谓本净空。悉能解了一切诸法。悉为本净。有为无为。非声闻所作非辟支佛所作。是谓本净空。彼何谓一切法空。一切法者。谓色痛痒思想生死识。眼耳鼻舌身意。色声香味细滑之法。眼色识耳声识鼻香识舌味识身细滑识意法识。眼所更耳鼻舌身意所更。痛痒之事。有为法无为法。是谓为一切法空。诸法法空。无所毁伤不可坏起。所以者何。用本净故。是谓一切法空。彼何谓自然相空。为色相故色无所有相。受痛痒思相造生死相。知生死识相。痛痒思想生死识。亦复如是。眼耳鼻舌身意。色声香味细滑法。及十八种一切所更。有为法相无为法相。是一切法自然相空。彼何谓不可得无所有空。一切诸法亦不可得。无所毁害不可坏起。所以者何。本净故也。是谓不可得无所有空。彼何谓无所有空。索所有形貌而不可得。是谓无所有空。彼何谓自然空。无有合会为自然。是为自然空。彼何谓其无所有自然空者。其自然者无有合会。是谓其无所有自然空也。复次须菩提。其所有者所有空。无所有者无所有空。自然者自然空。为他故者他故亦空。彼何谓所有所有空。谓五阴也。彼五阴者所有所有空。是谓所有所有空。何谓无所有无所有空。谓无为也。彼无为者无为故空。是谓无所有无所有空。何谓自然自然空。其为空者。则无有相亦无所作亦无所见。是谓自然空。彼何谓为他故空。假使怛萨阿竭兴出现者。若怛萨阿竭不兴出现。其法常住。其法界亦寂灭故无本。无本斯则本际。其于此者为他空。是谓为他故空。是谓须菩提菩萨摩诃萨摩诃衍也。复次须菩提。菩萨摩诃萨摩诃衍者。谓首楞严三昧。复有三昧名曰实印。复有三昧名师子娱乐。有三昧名善月。有三昧名月幢英。有三昧名一切法超上。有三昧名观顶。有三昧名分别一切法。有三昧名了幢英。有三昧名金刚喻。有三昧名入法印。(丹本云有三昧名善住王)有三昧名放光无所夺。有三昧名定意王。有三昧名善住。有三昧名放光。有三昧名力精进。有三昧名等超。有三昧名分别随顺。有三昧名入诸语。有三昧名照诸方面。有三昧名总持印。有三昧名无所夺。有三昧名等御诸法海印。有三昧名普遍虚空。有三昧名金刚道场。有三昧名胜诸宝。有三昧名照明。有三昧名不眴。有三昧名住不究竟。有三昧名决了。有三昧名离垢灯明。有三昧名无量光。有三昧名光造。有三昧名普照。有三昧名净御定。有三昧名离垢明。有三昧名为娱乐故。有三昧名慧灯。有三昧名无尽。有三昧名威神具。有三昧名除尽。有三昧名无特。有三昧名开通。有三昧名日灯明。有三昧名月离垢。有三昧名净照明。有三昧名有所照曜。有三昧名作当所作。有三昧名慧英。有三昧名譬金刚。有三昧名善建志。有三昧名宝积。有三昧名超法印。有三昧名法普。有三昧名胜娱乐。有三昧名度法顶。有三昧名有所破坏。有三昧名分别诸句。有三昧名等造字。有三昧名离文字。有三昧名除断缘。有三昧名离所作。有三昧名无所作。有三昧名行不使了。有三昧名除冥。有三昧名行迹。有三昧名无动。有三昧名度境界。有三昧名决一切德。有三昧名决所住。有三昧名清净严华。有三昧名觉意句。有三昧名无量灯明。有三昧名等无等。有三昧名度一切法。有三昧名断绝故。有三昧名离所作。有三昧名离所住。有三昧名一严净。有三昧名御行事。有三昧名一事故。有三昧名制诸事。有三昧名除厌一切所作。有三昧名入缘合像音。有三昧名脱音教文字言。有三昧名光[火*僉]炽盛。有三昧名相严净。有三昧名无相。有三昧名造一切诸具。有三昧名不悦一切苦乐。有三昧名无尽故。有三昧名总持句。有三昧名爱护一切正邪。有三昧名入一切诸色无色。有三昧名无音断音。有三昧名离垢曜。有三昧名御固要。有三昧名离垢满月。有三昧名大严净。有三昧名一切光世明故。有三昧名普明。有三昧名御空。有三昧名等御。有三昧名无青究竟无所娱乐。有三昧名究竟无本住。有三昧名身时安详。有三昧名口言时蠲除虚空念。有三昧名脱虚无色无所著百一十定。彼何谓名曰首楞严三昧。其定意者。皆入一切诸三昧行。是谓首楞严三昧。彼何谓实印三昧。时以斯定意。印一切三昧。是谓实印三昧。彼何谓师子娱乐三昧。住此定意时。皆娱乐一切定意。是谓师子娱乐三昧。彼何谓善月三昧。住是定意时。一切平等而无所有。是谓善月三昧。彼何谓月幢英三昧。住是定意三昧。以此定意普执一切诸三昧幢。是谓月幢英三昧。彼何谓超一切法上三昧。住是定意时。一切悉至于平等事。是谓一切法超上三昧。彼何谓观顶三昧。住是定意时。则便观睹一切三昧。诸定意顶。是谓观顶三昧。彼何谓分别法界三昧。住是定意时。则能分别诸有法界。是谓分别法界三昧。彼何谓决了幢英三昧。住是定意时。一切定意究竟执幢。是谓决了幢英三昧。彼何谓金刚三昧。住是定意时一切平等无能破坏。是谓金刚三昧彼何谓入法印三昧。住是定意时。寻则得入一切法印。是谓法印三昧。彼何谓善住王三昧。住是定意时一切诸法王三昧之所建立。是谓善住王三昧。彼何谓放光明三昧。住是定意时。一切三昧皆演光明。是谓放光明三昧。彼何谓精进力三昧。住是定意时。一切三昧。精进力所发起。是谓精进力三昧。彼何谓等度三昧。住是定意时。一切三昧皆至平等。是谓等度三昧。彼何谓顺入言教三昧。住是定意时。皆得普入顺应意声。是谓顺言教三昧。彼何谓入诸言教三昧。住是定意时。一切皆从三昧言教。是谓入言教三昧。彼何谓照诸方面三昧。住是定意时。皆照一切诸方面定意。是谓照诸方面三昧。彼何谓总持印三昧。住是定意时。总持一切诸三昧印。是谓总持印三昧。彼何谓无所夺三昧。住是定意时。寻即不忘一切定意。是谓无所夺三昧。彼何谓等御诸法海印三昧。住是定意时。行平等事思摄等御。是谓等御海印三昧。彼何谓普遍虚空三昧。住是定意时。一切三昧普遍虚空无所不周。是谓普遍虚空三昧。彼何谓金刚道场三昧。住是定意三昧时。总持一切定意道场。是谓金刚道场三昧。彼何谓胜诸宝三昧。住是定意时。蠲除一切尘垢诸欲不可瑕疵。是谓胜诸宝三昧。彼何谓照明三昧。住是定意三昧时。致一切等则无所照曜诸道。是谓照明三昧。彼何谓不眴三昧。住是定意时。于诸三昧不求诸法。是谓不眴三昧。彼何谓不究竟住三昧。住是定意时。不见诸法三界所住。是谓不究竟住三昧。彼何谓决了三昧。住是定意时。无心无念法所趣。是谓决了三昧。彼何谓离垢明三昧。住是定意时。一切三昧转相照曜。是谓离垢明三昧。彼何谓无量光三昧。住是定意时。其光明者无所不照。是谓无量光三昧。彼何谓造所为光三昧。住是定意时。若得三昧一切定意皆放光明。是谓造所为光三昧。彼何谓普照三昧。这获此定。一切诸三昧门自然演光。是谓普照三昧。彼何谓御诸净三昧。住是定意时。则便逮得一切三昧清净普等。是谓御诸净三昧。彼何谓离垢光三昧。住是定意时。于诸三昧除一切垢悉令灰尽。是谓离垢光三昧。彼何谓所娱乐三昧。住是定意时。则便娱乐一切三昧。是谓所娱乐三昧。彼何谓慧灯明三昧。住是定意时。照明一切诸所三昧。是谓慧灯明三昧。彼何谓无尽三昧。住是定意时。于一切三昧亦无有尽亦无不尽。亦复不见尽与不尽。是谓无尽三昧。彼何谓威神句三昧。住是定意时。一切平等威神巍巍光曜远照。是谓威神句三昧。彼何谓除诸尽三昧。住是定意时。见诸三昧一切无尽。见而无本而无所见。是谓除诸尽三昧。彼何谓无特异三昧。住是定意时。一切平等不着不念。无所患苦亦无因缘。是谓无特特异三昧。彼何谓开通三昧。住是定意时。不见诸法有所通达。亦无颠倒。是谓开通三昧。彼何谓日灯明三昧。住是定意时。开发一切诸三昧门而奋光明。是谓日灯明三昧。彼何谓离月垢三昧。住是定意时。于诸三昧以光除冥。是谓离月垢三昧。彼何谓清净灯明三昧。住是定意时。于诸三昧普护一切四分别辩。是谓清净灯明三昧。彼何谓有所照曜三昧。住是定意时。则皆照明诸三昧门。是谓有所照曜三昧。彼何谓所造作三昧。住是定意时。趣一切三昧成办所当。又复所造作三昧所立定时。普见一切诸三昧慧英。是谓所造作三昧。彼何谓金刚喻三昧。住是定意时。灭除一切所作诸法。不复睹见诸苦恼患。是谓金刚喻三昧。彼何谓心住三昧。住是定意时。心不动摇亦不开闭。亦不照明亦不见所起。亦不念言有此心也。是谓心住三昧。彼何谓普世三昧。住是定意时。普见一切诸三昧定靡所不照。是谓普世三昧。彼何谓善志住三昧。住是定意时。一切普安立诸三昧。彼何谓宝积三昧。住是定意时。普见一切诸三昧者。悉为积宝。是谓宝积三昧。彼何谓胜法印三昧。住是定意时等印诸法。未遭印者皆见印印悉能究竟。是谓胜法印三昧。彼何谓法平等三昧。住是定意时。不见诸法平等若崄岨。是谓法平等三昧。彼何谓胜娱乐三昧。住是定意时。降伏一切诸所乐法。是谓胜娱乐三昧。彼何谓度诸法顶三昧。住是定意时。调定一切诸法之上。皆复越度诸所三昧。是谓度诸法顶三昧。彼何谓坏除三昧。住是定意时除诸三昧坏一切法。是谓坏除三昧。彼何谓分别诸法三昧。住是定意时。皆能分别于诸三昧。晓了一切诸法之句。是谓分别诸法三昧。彼何谓等造文字三昧。住是定意时。分别晓了三昧致等文字。是谓等造文字三昧。彼何谓除诸文字三昧。住是定意时。于诸三昧无一文字亦无所得。是谓除诸文字三昧。彼何谓除断因缘三昧。住是定意时。断诸三昧缘无有众乱。是谓除断因缘三昧。彼何谓无所作三昧。住是定意时。不得诸法有所作为。亦无所造。是谓无所作三昧。彼何谓离所作三昧。住是定意时。不得诸法因缘所造。是谓离所作三昧。彼何谓不究竟行三昧。住是定意时。不得一切诸三昧行究竟边际。是谓不究竟行三昧。彼何谓除诸冥三昧。住是定意时。一切三昧除诸闇冥。灭尽诸乱令致清净。是谓除诸冥三昧。彼何谓行诸句三昧。住是定意时。普见一切诸三昧行。是谓行诸句三昧。彼何谓无动三昧。住是定意时。不见一切诸三昧有震动者。是谓不动三昧彼何谓度诸界三昧。住是定意时。一切三昧度诸邪反。亦无差错顺其正谊。是谓度诸界三昧。彼何谓分别诸德三昧。住是定意时。决一切诸法了众生三昧。是谓分别诸德三昧。彼何谓所住究竟三昧。住是定意时。于一切定求于心本而不可得。是谓所住究竟三昧。彼何谓净华严饰三昧。住是定意时。得诸三昧一切清净普严诸华。是谓净华严饰三昧。彼何谓觉意句三昧。住是定意时。一切三昧疾逮觉意。是谓觉意句三昧。彼何谓无量辩三昧。住是定意时。寻即逮得无量辩才随行分别。是谓无量辩三昧。彼何谓等无等三昧。住是定意时。一切定逮得等无等三昧。能令诸邪皆至平等。是谓等无等三昧。彼何谓度一切诸法三昧。住是定意时。皆能越度一切三界。是谓度一切诸法三昧。彼何谓断诸作三昧。住是定意时。见一切法诸三昧定。悉为断绝之。是谓断诸所作三昧。彼何谓无意无毁三昧。住是定意时。已逮诸定。得致诸法皆归坏败。是谓无意无毁三昧。彼何谓无所住三昧。住是定意时。不见诸法有所住处。是谓无所住三昧。彼何谓一清净三昧。住是定意时。不见诸法而有二事。是谓一清净三昧。彼何谓御诸事行三昧。住是定意时。不见诸法有因缘趣。是谓御诸事行三昧。彼何谓胜诸事三昧。住是定意时。一切三昧不睹二事亦无所见。是谓胜诸事三昧。彼何谓除灭一切所有断诸根三昧。住是定意时。于一切三昧灭除诸事。而逮得慧所入之处无所遭遇。是谓除灭一切所有断诸根三昧。彼何谓入合随音三昧。住是定意时。不随三昧诸音声。是谓入合随音三昧。彼何谓度诸言字音声三昧。住是定意时。则悉度脱一切诸行文字之事。亦无所见。是谓度诸言字音声三昧。彼何谓炽盛光曜三昧。住是定意时。普照降伏光明惟曜。是谓炽盛光曜三昧。彼何谓诸相严净三昧。住是定意时。庄严一切诸相功德。是谓诸相严净三昧。彼何谓无相三昧。住是定意时。一切三昧永不睹一切相。是谓无相三昧。彼何谓一切具足三昧。住是定意时。一切所求普悉具足是谓一切具足三昧。彼何谓不悦苦安三昧。住是定意时。不睹三昧一切苦安。是谓不悦苦安三昧。彼何谓无尽故三昧。住是定意时。于一切三昧。亦无有尽亦无所见。是谓无尽故三昧。彼何谓总持句三昧。住是定意时。总持一切诸三昧事。是谓总持句三昧。彼何谓护诸正邪三昧。住是定意时。于诸三昧。永不睹见正等与邪。是谓护诸正邪三昧。彼何谓灭除诸声色无声色三昧。住是定意时。于诸三昧一切不见有声色。永无声色。是谓灭除诸声色无声色三昧。彼何谓无音断音三昧。住是定意时。见一切法无声无音。是谓无音三昧。彼何谓离垢明三昧。住是定意时。不得一切三昧光明诸垢。是谓离垢明三昧。彼何谓要御三昧。住是定意时。不见诸三昧有要无要有御无御。是谓要御三昧。彼何谓满月离垢明三昧。住是定意时。一切平等具足成满功德之福。譬如月盛满十五日时。是谓满月离垢明三昧。彼何谓大严净三昧。住是定意时。皆悉平等无极清净庄严普备。是谓大严净三昧。彼何谓普照世间三昧。住是定意时。一切平等皆能光照一切诸法。是谓普照世间三昧。彼何谓普定意三昧。住是定意时。一切定亦无所乱。不得一心。是谓普定意三昧。彼何谓御空三昧。住是定意时。等御一切不乐法者。而令得乐。是谓御空三昧。彼何谓御萨芸若空等御三昧。住是定意时。于一切御平等之事。亦无所御。是谓御萨芸若空等御三昧。彼何谓无青究竟无乐三昧。住是定意时。不得名号亦无所获。是谓无青究竟无乐三昧。彼何谓住于无本无心三昧。住是定意时。住于诸三昧。普入无本无所转求。是谓住于无本无心三昧。彼何谓身时安详三昧。住是定意时。于诸三昧永无所得亦无见身。是谓身时安详三昧。彼何谓口言时坏除虚空念三昧。住是定意时。一切三昧不得口言之所归趣。是谓口言时坏除虚空念三昧。彼何谓脱虚无无色三昧。住是定意时。逮得虚空无为无数一切法寂。是谓脱虚无无色三昧。是为须菩提菩萨摩诃萨般若波罗蜜摩诃衍也

光赞经卷第六光赞经卷第七

        西晋三藏竺法护译

    摩诃般若波罗蜜观品第十七

佛告须菩提。菩萨摩诃萨摩诃衍者。谓四意止。何谓四意止。内自观身不与身俱。亦不想念亦不得身。观于外身不与身俱。亦不想念亦不得身。于是安详调御其意。观于世间无明愁戚。内观痛痒彼心法者。于是安详调御其意。睹于世间无明愁戚。观外痛痒不与痛痒俱。亦不想念亦不得身。观内思想不与想俱。亦无想念不得思想。观外思想不与想俱。亦无想念不得思想。观于内法不与法俱。亦无法想亦不得法。观于外法不与法俱。亦无法念亦不得法。于是寂然调御其意。于世无明愁戚之事。何谓须菩提菩萨摩诃萨内观身。于此菩萨摩诃萨。知心所行若住已住。亦知已坐当坐。亦知行卧已当行卧。如身应住所志所趣。皆悉知之。是为菩萨摩诃萨观内身也。于是安详调御其意。于世无明愁戚之事。复次须菩提。菩萨摩诃萨往反安详观察视瞻而不卒暴。进止屈伸着衣持钵。饮食卧寐懈息所从。律行去来坐起卧觉。有所说者。常怀徐详。喜在闲居心不驰骋。是为须菩提菩萨摩诃萨行般若波罗蜜自观内身而不可得。复次须菩提。菩萨摩诃萨其心专一睹出入息。息长息短亦悉知之。意息若近若远亦悉知之。意息若迟若疾亦悉知之。意息卒暴柔和亦悉知之。譬如转轮圣王知土地长短广狭。譬如瓦师作器知大小深浅。如是须菩提。菩萨摩诃萨知息出入长短迟疾刚柔。菩萨如是观其内身。知其安详调御其心令顺法教。是为须菩提菩萨摩诃萨内自观身调御其意于世无明愁戚之事。复次须菩提。菩萨摩诃萨自观其身四分诸种今身有是地种水种火种风种。譬如屠儿以持利刀。杀害牛畜解为四段。为四段已坐起省察则无牛因缘合成。如是须菩提。菩萨摩诃萨行般若波罗蜜。自观是身。而身有此地种水种火种风种。菩萨摩诃萨行般若波罗蜜。自观内身亦不见身亦无所得。复次须菩提。菩萨摩诃萨自察其身从头至足。有身发髓脑恶秽不净具足充满。有此身者。有发毛爪齿皮革筋脉。骨节肠胃腹肝肺心肾五脏血肉脂髓涕唾。垢浊不净大便小便。譬如佃家以囊器盛若干种谷麻米粟豆大麦小麦稻穬。明目之人写之置地分别知之。是为麻油。是为粳米。是为豆粟。是为稻穬。如是须菩提。菩萨摩诃萨今此身者。从足至头发毛爪齿皮革筋脉骨节肠胃腹肝肺心肾五脏血肉脂髓[口*弟]唾垢浊不净大便小便如是须菩提。菩萨摩诃萨内自观身调御其意。于世无明愁戚之事亦无所得。复次须菩提。菩萨摩诃萨如今观身。遭诸寒热若其寿终。一日若三日四日五日。其身膖胀。其色变青。臭烂脓血流出。计如此身。则不能离无常之法。如是须菩提。菩萨摩诃萨自观内身。知其安详调御其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。菩萨摩诃萨观人寿终。遭是寒热日炙风飘。死至一日。若至二日三日四日五日六日七日。为鸟乌所食。狐狼熊罴虎豹鸱枭狗犬所食。无央数虫从其身出还食其体。其人自察身所游处。法无有常分散离别。无脱此者。内自观身调御其意。于世无明愁戚之事。亦无所见。复次须菩提。菩萨摩诃萨假使见身非常之后。寒热所遭。日炙风飘膖肿青胀。鸟兽所啖臭处不净。还自观身亦当如是。调御其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。菩萨摩诃萨假使观身终亡之后。遭于寒热日炙风飘。骨节相连譬如交璅。肉涂血浇筋缠革裹皮覆。自观身调定其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。菩萨摩诃萨假使见人终亡之后。但白骨钩璅相连。有血脉皮肉筋髓。则而察之。今此躯体其法如是。分散别离此非常法。无有脱者。如是须菩提。菩萨摩诃萨观身调定其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。菩萨摩诃萨假使见骨髓筋缠碎坏分散还与土合。观察如是。今此躯体其法如是。内自观身调御其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。假使睹见骨散在地。东西南北脚骨异处。膝膑项颈胸胁头颅各自异处。则而察之。今此躯体其法如是。手足分散别离此非常法。无脱此者。内观其身调定其意。于世无明愁戚之事。亦无所得亦无所见。复次须菩提。菩萨摩诃萨便观身死来久远骨散在地。积有年岁。不可称数难量之载。青骨碎坏与灰土合。今此躯体其法如是。分散别离此非常法。无有脱者。如是须菩提。菩萨摩诃萨内自观身调定其意。于世无明愁戚之事。亦无所得亦无所见。痛痒思想观法亦复如是。以持诱进初发意者。为无常观。稍稍入空乃知无本。以为发意达者。观内外身亦无有身。观内外想亦无有想。观内外法亦无有法。亦无所观亦无所见。道不离俗俗不离道。二者俱空亦无所获。复次须菩提。菩萨摩诃萨行摩诃衍者。四意断。何等为四意断。于是菩萨摩诃萨。诸恶未起不善之法。设来兴者制令不生。殷勤精进摄其心本令断诸瑕。诸恶不善非法之事。适兴寻断。殷勤精进自摄其心。使平等断。诸善德本设来兴者。假欲断者。殷勤精进救摄其心。平等解脱。怀善法生坚住不失。思惟具足。广普令备益加欢乐。殷勤精进救摄其心。平等解脱。有所得亦无所得亦无所见。是为须菩提。菩萨摩诃萨摩诃衍也。复次须菩提。菩萨摩诃萨行摩诃衍。谓五根。信根精进根意根定根慧根。是为菩萨摩诃萨摩诃衍。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍者。谓五力也。何谓五力。信力精进力意力定力慧力。是为菩萨摩诃萨摩诃衍五力也。有所得亦无所得亦无所获也。复次须菩提。菩萨摩诃萨摩诃衍。谓七觉意。何谓七觉意。于是须菩提。菩萨摩诃萨专修思觉意。依于寂然。无有贪欲亦无所依。除于诤讼舍诸法。是谓思觉意。有行精进觉意。依于寂然。无有贪欲亦无所依。除诤讼舍诸法。是谓精进觉意。又行悦豫觉意。行信觉意。行安觉意。定觉意。行观觉意。依于寂然。无有贪欲亦无所依。除诤讼舍诸法。是谓菩萨摩诃萨摩诃衍行七觉也。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓八由行贤圣之路。何谓八。正见正念正语正治正业正方便正意正定。是为八由行贤圣之法。有所得亦无所得亦无所获。是为菩萨摩诃萨摩诃衍也。复次须菩提。菩萨摩诃萨摩诃衍者。谓三品三昧。何谓为三。空三昧无相无愿三昧。彼何谓空三昧。已相法空。空者脱门。则为无相。其无相者便为脱门。其所行者无所行也。是为无愿脱门也是为须菩提菩萨摩诃萨摩诃衍也。逮得此已亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。当分别若晓了所习决断灭尽。觉知由路知所尽者。知元所起晓了诸法。分别无我。晓了柔和终没之事。自知其心了他人心。是谓为慧。彼何谓分别。于苦知苦。无所从生亦无所起。是谓分别苦。何谓为晓了所习。谓蠲除所习令不复生。何等为决断灭尽。谓苦已尽令无根本。何等觉知由路。谓贤圣之法八由路也。何谓知所尽者。谓淫怒痴灭。何谓知无所起。谓无所从生不起之慧。何谓晓了法慧。谓于五阴所造罪福断绝为慧。何谓分别无我。谓色非常痛痒思想生死识非常。眼耳鼻舌身心。非我所有。色声香味细滑法。非我所有。眼色识耳声识鼻香识舌味识身细滑识意法识。亦非我所有。何谓晓了柔和终没之事。有所咨嗟多所发起。何谓自知其心。自知古来根原。何谓知人心。能别他人众生心之所念。彼何谓如所慧心。谓怛萨阿竭萨芸若慧。是谓如所慧心已得。是以亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓有三根。异人根异根别根。彼何谓异人根。谓有诸学士。未得平等信根精进根意根定根慧根。何谓异根。其学士者。无有异信信根精进根意根定根慧根。是谓异根。彼何谓别根。谓未学士。而发大意辟支佛菩萨怛萨阿竭阿罗诃三耶三佛。信根精进根意根定根慧根。是谓菩萨摩诃萨别根摩诃衍也。有所得者。亦无所得亦无所获也。复次须菩提。菩萨摩诃萨摩诃衍者。谓平等定也。有三事。有想有行三昧。无想有行三昧。无想无行三昧。彼何谓有想有行三昧。脱诸欲寂除诸恶不善之法。有想有行行第一寂。是谓有想有行三昧。彼何谓无想有行三昧。谓其心之内无想有行。亦无所著至第二寂。亦无内外。是谓无想有行三昧。彼何谓无想无行三昧。过第二第三寂。度于无量有慧之定。越于无量识慧之宜。过于无量不用慧定。越于无量有想无想之定。是谓无想无行。是谓须菩提菩萨摩诃萨摩诃衍也。复次须菩提。菩萨摩诃萨摩诃衍者。当行十念。何谓十念。念佛念法念圣众念戒念布施念天念恬怕念无所起念观身念当终亡。是为十念。是为菩萨摩诃萨摩诃衍。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓四禅四无色定四等心八脱门。未曾所获味之定。是谓须菩提菩萨摩诃萨摩诃衍也。有所得者。亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓怛萨阿竭十种力也。何谓十种力。谓知他人众生之类。处处非处处有限无限。如审悉知。过去当来今现在因缘罪福所行之处有所报应。如审悉知。世间之人有若干种其体不同。如审悉知。他人众生若干种心所喜各异。如审悉知。他人众生根原所趣本末各异。如审悉知。一切五道终始所归。如审悉知。知于众人行者之心。根力觉意一心脱门三昧正受。结缚嗔恨斗讼之事。能慧分别如审悉知。无数寂然。悉识过去无数亿劫之事。识过去无数亿劫之所。游居众生察其终没之所归趣。道眼彻视于十方一切佛界。五道生死善恶祸福起灭终始。如审悉知。诸漏已尽无有尘垢。度于想念。以知慧脱现在造行。自以神通证知诸行。生死已断。称举梵行。所作已办知未度者。是为须菩提。菩萨摩诃萨摩诃衍。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓四无所畏。何谓四无所畏。今吾已逮成平等觉。若有沙门梵志诸天人民。若复异天异觉之人。来欲讼理求佛之短。谓为不成平等之觉。不见瑞应。敢有发意当如来者。无敢发念。故佛安隐所行。无难亦无畏。勇猛行达无所著。而为他人师子之吼。讲说分别清净法轮。沙门梵志诸天宫魔及诸梵天天上世间。无有能及道法之谊。诸漏已尽无有终始。沙门梵志诸天魔梵天上世间。欲求佛短谓不然者。诸漏未尽。都了不见发心求短者。故佛安隐无有恐惧。则为众人而师子吼。悉知内法。无有内外不见吾我。沙门梵志诸天魔梵天上世间。欲求佛短谓不然者。不知内法计有吾我。都了不见发心求短者。故佛安隐无有恐惧。则为众人而师子吼讲说贤圣。不解者解。不达者达。无乘者乘。而以平等普除苦恼。终不能求得佛短也。以奉法故不违道谊勇猛无恐无惧。而为他人讲说清净法轮。为师子吼。是为须菩提菩萨摩诃萨摩诃衍也。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍。谓四分别辩。何谓为四。一曰分别谊。二曰分别法。三曰所归顺分别。四曰分别辩。是谓须菩提菩萨摩诃萨摩诃衍。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍者。谓十八不共诸佛之法。何谓十八。一者如来无有瑕短。所说应时无有短乏心。无忘失无有若干想。无有不定心。无有不辩。分别所观无有所乐。断精进无失。终无失意。智慧无损解脱不阙。度知见不减。一切诸身之事无所不达。一切口所言说无所不通。各令得所。一切心所念。以智慧心悉知其原。又知过去不可计会无央数劫事。智慧悉见。又知当来不可计会无央数劫事。智慧悉见。又知现在不可计会无央数劫事。智慧悉见。是为须菩提菩萨摩诃萨摩诃衍。有所得亦无所得亦无所获。复次须菩提。菩萨摩诃萨摩诃衍者。谓总持门。彼何谓总持门。诸文字等所说平等。文字之门文字所入。何谓文字门文字所入因缘之门。一切诸法。以过去者亦无所起。其门所作是罗之门。法离诸垢是波之门。分别诸谊是遮之门。逮得一切诸法之行亦无所得亦无所没者亦无所生者。是那之门。一切法离诸号字。计其本净而不可得。是罗之门。皆悉超度一切世法恩爱报应因缘。是陀之门。一切诸法悉为本无有无断绝。是为波之门。皆悉解结诸法所缚。是咤之门。烧尽诸法逮至清净。是沙之门。一切诸法无有挂碍不得诸事。是和之门。断除一切诸法音声句迹所趣。是多之门。一切诸法而无有本不可动摇。是计之门。一切诸法而无所起。是吒之门。一切诸法得至究竟。是阿之门。一切诸法所当作为皆悉逮得。是娑之门。一切诸法皆已时得通不悉节。是摩之门。解知诸法从吾我起。是迦之门。一切诸法逮得拥护。是瘅之门。一切诸法逮得诸法之处。是阇之门。一切诸法而无所起。是波之门。一切诸法而无所起。是陀呵之门。一切诸法诸种无所起会。是奢之门。一切诸法寂然不起。是呿之门。一切诸法犹如虚空而无所生。是叉之门。一切诸法皆悉灭尽而不可得。是尸瘅之门。一切诸法坚住于处而不可动亦不可得。是惹之门。一切诸法慧不可得。是咤呵之门。一切诸法逮得所持。是披何之门一切诸法已得闲静。是车之门。一切诸法皆已焚烧。是那之门。一切诸法而无所作。是沙波之门。一切诸法而得至信。是嗟之门。一切诸法皆得尽灭。是迦何之门。一切诸法得轮数所在。是咤徐之门。一切诸法。有所住处得无所住。是那之门。一切诸法。不来不去不立不坐不卧不寐。无应不应无想不想。是颇之门。一切诸法不可所奏。是尸迦之门。一切诸法不得五阴。是磋之门。一切诸法不得他念。是伊陀之门。舍一切法而无所得。伊陀之门。一切诸法不得所在。是吒之门。一切诸法究竟边际尽其处所。无生无死无有无作。拔去文字音声之说。所以者何。厌诸挂碍无彼无名无处所言。亦不可得亦不可说。亦不可尽亦不可见。譬如须菩提虚空虚无。一切诸法亦悉如是。是为须菩提总持所入因缘文字分别所入。其有菩萨摩诃萨知是一切因缘文字方便分别。则不复着音声言说。则能次第晓了诸法之所归趣也

    摩诃般若波罗蜜十住品第十八

佛告须菩提。如汝所言。何谓菩萨摩诃萨为摩诃衍三拔致。如是须菩提。菩萨摩诃萨行六波罗蜜。入于道地。云何菩萨入于道地。入一切诸法。无来亦无所去。无去亦无所坏。一切诸法不可知处亦无想念。行十道地不见道地。何谓菩萨行十道地者。是菩萨摩诃萨行第一住者。当行十事。何谓为十。修治志性不为颠倒。修治愍哀除去众想。等心众生不得众生。行布施事受者无异。敬善知识无有轻慢。求法为业而无所得。殷勤出学无所贪慕。求于佛身不想相好。开阐法事悉于众生无所希望。弃除贡高则于诸法而无所著。口之所言至诚为业。是为十事。须菩提。菩萨摩诃萨行第一道地也。复次须菩提。菩萨摩诃萨行第二住者。当行八法。何谓为八。其戒清净。而有反复能知报恩。住于忍力常行欢喜。不舍众生勤于大哀。受尊长教。其出家者。视如世尊。行波罗蜜。慕求善权。是为八事。复次须菩提。菩萨摩诃萨行第三住者。行五法。何谓为五。博问无厌不著文字。开化法施无衣食想。净于佛土劝众德本。亦无所望。是为五事。复次须菩提。菩萨摩诃萨行第四住者。当行十法终不为舍。何谓为十。不舍闲居。志在少求。而知止足。不离宴坐。不毁禁戒。不厌受欲。不止灭度。一切所有施而不惜。而不怯弱。于诸所有而无所慕。是为十事。复次须菩提。菩萨摩诃萨行第五住者。当弃八事。何谓为八。弃捐家居。离比丘尼。舍弃动性。不贪功德。舍于睡卧。离于嗔争。不自称誉。不毁他人。是为八事。复次须菩提。菩萨摩诃萨行第六住者。以具六法。何谓为六。谓六波罗蜜。不为六法。不求声闻。无缘觉想。不念于小。见贫乞者心色和悦。有所施与不以忧戚心不怀恨。是为六事。复次须菩提。菩萨摩诃萨行第七住者。为以离二十法。何谓二十。无所受。无吾我。不计人。不有命。不念寿。不念常。不着断灭。无诸想着。离因缘见。不倚诸阴。不慕诸种。舍于诸种。舍于诸入。无三界想。不着于佛。不着于法。不着圣众。护禁舍见不猗念空。舍诸邪见无所染污。是为二十事。当复具足二十法事。何谓二十。晓了于空。不证无相。惠无所愿。净于三场。愍哀众生。不见众生。无所轻慢。等观诸法。体解法义。无所分别。晓了真正。亦无所著。无从生忍。讲说一品。灭除众想。弃捐尘劳。寂然离邪。其心调定。不离智慧。无有卒暴。是为二十。复次须菩提。菩萨摩诃萨行第八住者。以为具足四法。何谓为四。入众生心神通自乐。现诸佛土随所观察。具成己土稽首诸佛。以真谛观诸佛之身。是为四法。复次须菩提。菩萨摩诃萨行第九住者。当复具足四法。何谓为四。晓了诸根成诸佛土。殷勤奉修于幻三昧。顺化众生令其造德本处于淳淑。为众示现具足之身为说道义。是为四事。复次须菩提。菩萨摩诃萨行第十住者。于十二事悉具足。何谓十二。为无量处而设拥护。随众所愿各令得所。口所演说诸天龙神揵沓和阿须伦迦楼罗真陀罗摩烋勒。闻其音各各解了。辩才如是。胞胎众事。种姓尊贵。所生之处。眷属国土。弃国捐家。诣于佛树。清净具足一切名德。皆为备悉。是为十二。复次须菩提。第十菩萨摩诃萨者。即谓是佛。须菩提白佛言。何谓菩萨遵修志性。佛言。所作德本心皆劝助萨芸若慧故。何谓菩萨等心。一切志萨芸若。行四等心慈悲喜护故。何谓菩萨为布施业。施于一切无所想念故。何谓菩萨结善知识。劝化一切令立正道。稽首问信恭敬尊长故。何谓菩萨具足求法。诸所求法心常在于萨芸若慧。而不堕落声闻辟支佛地故。何谓菩萨殷勤出家。所生之处世世舍业无所毁坏。随怛萨阿竭教。其出家者修无上行故。何谓菩萨遵求佛身。若见佛形其心未曾离佛。尔乃至于萨芸若慧故。何谓菩萨开阐诸法。假使菩萨现在见佛若般泥洹。而为众生讲说经法。初语亦善中语亦善竟语亦善。其义备悉微妙具足清净之行。及十二部经。闻经德经听经分别经示现经譬喻经所说经所生经方等经未曾有经章句经所行经。是为菩萨十二部经开阐诸法。何谓菩萨弃捐憍慢心。未曾怀自大。终不生小姓家故。何谓菩萨所言至诚。若有所说言行相副故。佛语须菩提。是为菩萨摩诃萨行第一住奉行十事。须菩提白佛言。何谓菩萨戒品清净。佛言。心不念求声闻辟支佛乘。亦不毁訾于诸菩萨。若犯戒者。而以劝喻令不堕堑故。何谓菩萨而有反复知报恩者。设使菩萨行菩萨道时。若施少者不以废忘。何况于多。何谓菩萨住于忍力。常于众生无有乱心。志不怀害故。何谓菩萨心色和悦。念化众生不违正行故。何谓菩萨不舍众生。能救济护一切人故。何谓菩萨近于大悲。假使菩萨行道之时。心自念言。因一切人故。恒河沙劫在于地狱。若见考署终不懈怠。当令彼人成于佛乘以得灭度。如是比类一切众生。其心自劝微妙如是。何谓菩萨受尊长教。其有出家若见师父视之如佛。何谓菩萨求波罗蜜。若使菩萨不志余业不念他法。无所轻慢求无极故。何谓菩萨博闻无厌。诸佛天中天。所可言说于此所讲。及十方佛口所演说。悉奉受持故。何谓菩萨所说法施无衣食想。以此法施。心念如是不想佛道故。何谓菩萨净于佛土。所殖德本皆以劝助严净佛土故。何谓菩萨不厌生死。常欲具足一切功德。成就善本开化众生。净于佛土未曾懈惓。至令具足萨芸若慧故。何谓菩萨而知惭愧。常无声闻辟支佛心故。何谓菩萨不舍闲居。不入声闻辟支佛地故。何谓菩萨志在少求。行菩萨道无所贪慕。志在佛道故。何谓菩萨而知止足。用成萨芸若故。何谓菩萨不舍节限。谓能分别晓深法故。何谓菩萨不舍学戒。所持禁戒而不放逸故。何谓菩萨不厌受欲。其心未曾起贪欲故。何谓菩萨心不灭度。于一切法而无所行故。何谓菩萨一切所有。能以布施而悉将护。内外诸法无所贪故。何谓菩萨志不怯弱。心未曾发而为二识故。何谓菩萨观诸所有而无所贪。于诸万物无所念故。何谓菩萨弃国捐家。从一佛国复游一国。所生之处除其须发而被袈裟。现作沙门故。何谓菩萨舍比丘尼。弹指之顷不与从事。于彼因缘心无所起故。何谓菩萨舍弃种姓。菩萨当念。令众生处在安隐以自然安。若使见者终不起嫉心故。何谓菩萨弃捐众贪及与睡卧。假使菩萨所在众会。若有兴发声闻辟支佛心者。不当于彼与从事故。何谓菩萨离嗔恚。不从恨怒危害之心。无斗讼意无所争故。何谓菩萨不自称誉。不见内法无所观故。何谓菩萨不毁他人。于外一切无所见故。何谓菩萨弃于十恶。习贤圣道为上行净身口意故。何谓菩萨弃捐憍慢。如是所行不见诸法而有慢故。何谓菩萨舍于自大。所行不见形貌及与所有故。何谓菩萨离于颠倒。察诸所有而不可得故。何谓菩萨弃淫怒痴。永不睹见淫怒痴垢之所在故。何谓菩萨具足六法。第六住者当具六法。何谓为六。谓六波罗蜜当具足之。云何具足六波罗蜜。住六波罗蜜则能超越声闻辟支佛故。何谓菩萨不起声闻辟支佛心。此等所行不应为道。行小乘者不顺佛道。若见乞求者则怀怯弱。行菩萨者。当舍离之心无忧戚。所以者何。斯等所行为不入道。从初发意常行布施心不忘舍故。何谓菩萨不自贪身所以尔者。推求本末无有吾我。计人寿命亦复如是所以者何。谛观察之心无所有故。何谓菩萨不堕灭见。所以尔者。一切诸法心无所断本末不起。一切诸法亦无所生故。何谓菩萨不计有常。所以尔者。假使诸法悉无所起则无有常故。何谓菩萨不为想着。所以尔者。如是计之无有尘劳无因缘见。所以尔者。彼所见者不见诸见故。何谓菩萨不猗名色。所以尔者。一切有所为无所有故。何谓菩萨不着诸阴。不猗诸种不慕诸入。所以尔者。如是行者悉为自怨而无所有。以是故。不当猗着阴种诸入故。何谓菩萨不猗三界。其三界者自然无形。虽在三界而无所猗故。何谓菩萨不处所有。不以克期而为虚空。一切所有悉无所有故。何谓菩萨见佛不着。不以猗见为见诸佛故。何谓菩萨不争于空。一切诸法悉为空无空不乱空无所争故。何谓菩萨具足于空。身相虚空则为菩萨具足于空故。何谓菩萨不证无相。于一切相而无所念故。何谓菩萨志无愿慧。而于三界皆无所行故。何谓菩萨净于三场。便能具足十善德故。何谓菩萨愍哀一切众生之类便能行德无极大哀故。何谓菩萨不慢众生。而欲具足佛土故。何谓菩萨等观诸法。察于诸法无高无下。故何谓菩萨谛观道地。于一切法而无所习无所动转故。何谓菩萨无从生忍。一切诸法悉无所起。亦无所灭忍无所有故。何谓菩萨无所生慧。其于名色慧无所起故。何谓菩萨说于一品。不行二事故。何谓菩萨不念诸念。于一切法而无所念故。何谓菩萨弃捐诸见。能舍离声闻辟支佛地故。何谓菩萨灭除尘劳。一切诸漏所习止处欲垢悉断故。何谓菩萨寂离见地。谓能逮成萨芸若慧故。何谓心调。于三界无所患难故。何谓心寂。能御六根故。何谓菩萨不舍智慧。谓能逮得明眼故。何谓菩萨无有卒暴。观于六入无染着故。何谓菩萨心有所入。则以一心普见一切众生之念故。何谓菩萨神通自娱。则以神通而自娱乐。从一佛国复至一国。所游之处无佛土想故。何谓菩萨见诸佛国。住此佛国则见十方无量佛国。于诸佛国亦无所著故。何谓菩萨如所观察。见诸佛国具足严净。三千世界所游之处。辄为转轮圣王故。何谓菩萨稽首诸佛供事归念。一切经法分别义趣故。何谓菩萨而常审谛观诸佛身。以真正见诸佛则为法身故。何谓菩萨晓了诸根。若能住于怛萨阿竭十种力者。则能晓了一切众生诸根本故。何谓菩萨佛土清净。人民清净是则名曰佛土清净故。何谓菩萨如幻三昧。住此三昧菩萨则能变现一切无所不入。心无所处故。何谓菩萨而等三昧。菩萨于诸三昧无所希望故。何谓菩萨能教众生。所造德本各随其行而开化。菩萨摩诃萨则以至诚而护己身。随其众生而开度之。何谓菩萨至诚。自然有所劝发。欲以度脱一切众生故。何谓菩萨如其志愿必能得之。菩萨常具足六波罗蜜故。何谓菩萨所演出音诸天龙神及揵沓和闻其音者各得解了而顺化之。用有大哀普等音故。何谓菩萨入于胞胎。菩萨摩诃萨世世所生诸无所生故。何谓菩萨在于尊贵。菩萨所生在诸种姓则能化之故。何谓菩萨所生具足。假使菩萨在君子种。在梵志种。在居士种。则能劝化故。何谓菩萨在于尊姓。诸以过去众菩萨性等无差别故。何谓菩萨眷属具足。菩萨所从诸眷属侍使无所乏故。何谓菩萨土地严净。始生之时。光明照曜无数世界。其蒙光者皆得安隐故。何谓菩萨弃国捐家。菩萨摩诃萨舍家学道时。化无央数亿。百千人而与从俱。能令众生立于三乘故。何谓菩萨诣诸佛树。其树则为根茎枝叶华实。皆为七宝紫磨金色。照于十方无数佛土悉为大明。是为菩萨诣佛树严净。何谓菩萨一切名德而悉具足。设使菩萨人清净者则佛国净。是为菩萨名德具足。何谓菩萨住十道地成为如来。菩萨摩诃萨具足六波罗蜜十力无畏十八不共诸佛之法。得萨芸若慧。断除尘劳无所挂碍。是为菩萨住十道地成为如来。如是须菩提。菩萨摩诃萨沤和拘舍罗。行六波罗蜜意止意断神足根力七觉八道三十七品十力无畏四分别辩十八不共诸佛之法。寂然离见现入种性八等之地。若有所处离欲之地所作办地。离于声闻辟支佛地菩萨之地。是为菩萨摩诃萨入第九住于佛地。是为菩萨摩诃萨第十行住。是为菩萨摩诃萨三拔致

光赞经卷第七光赞经卷第八

        西晋月支国三藏竺法护译

    摩诃般若波罗蜜所因出衍品第十九

佛告须菩提。如汝所问。何从出衍中。何从住衍中。谁为成衍者。从三界生住萨芸若。有本无生无甫当生。所以者何。其摩诃衍萨芸若慧。于此二事。法无所合亦无所散。无色无见无所取舍。则为一相则无有相。所以者何。其无相法无所出生。法有生者。则为欲令法界出生。其无相法有所生者。则为欲令本无出生。其无相法则无所生。欲令生者则为欲令真本际生。其有欲令无相生者。则为欲令不可思议法界出生。其有欲令无相法生。则为欲令专精修行而出生。其有欲令无相法生。则便欲令断界出生。取要言之。须菩提。则为欲令离欲界生。其有欲令无相法生者。则为欲令灭度界生。须菩提。彼为欲令寂然空无而出生矣。其有欲令色痛痒思想生死识无相法生者。则为欲令有相法生。所以者何。色则为空。从三界生住萨芸若。痛痒思想生死识。亦无有空。从三界生萨芸若者则无所住。所以者何。若解色者色则为空。解痛痒思想生死识者识则为空。眼耳鼻舌身心亦空。欲令生者。则为欲令虚空出生。眼色识耳声识鼻香识舌味识身更识意欲识。此十八种因缘所见则为空。无欲令生者。则为欲令无相法生。所以者何。须菩提。眼之所视悉皆为空。耳鼻舌身意。亦如是习皆空。须菩提。三界为空眼所视空。从三界生萨芸若者。则无所住六情亦空。因三界生萨芸若者。则无所住。六情所受所习皆空无有相。欲令生者则为欲令生者。则为欲令梦幻出生。所以者何。梦幻水月芭蕉野马深山之响。皆悉自然。自然之事如来之化。三界自然则无所生。萨芸若者则无所住。所以者何。须菩提。如梦自然。梦自然者悉无所有。幻化之事亦复如是。须菩提。其欲令檀波罗蜜有尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜生者。则为欲令无相法生。所以者何。须菩提。六波罗蜜者悉皆自然。从三界生萨芸若者亦无所住。所以者何。须菩提。六波罗蜜者则为自然。其自然者故曰为空。其有欲令无相法生者。则为欲令内空外空有空无空近空远空真空出生。所以者何。须菩提。其七空者则为自然。以自然故。因三界生萨芸若者则无所住。所以者何。须菩提。用七空自然故名曰为空。故空为空。须菩提。其有欲令无相法生者。则为欲令四意止四意断四神足念五根五力七觉八道行生。所以者何。皆自然空。因三界生萨芸若者则无所住。须菩提。其有欲令三十七品出生者。则为欲令无相法生。所以者何。须菩提。三十七品则为自然。不生三界萨芸若者。则无所住。所以者何。三十七品自然空。空故曰空。须菩提。其有欲令十力无畏十八不共诸佛之法四分别辩悉自然空。空故曰空。须陀洹斯陀含阿那含阿罗汉辟支佛。上至怛萨阿竭阿罗诃三耶三佛生者。则为欲令无相法生。所以者何。须菩提。其三乘者亦复自然。不出三界萨芸若者则无所住。所以者何。须菩提。阿罗汉者则为自然。自然故空故曰为空。辟支佛者则为自然。自然故空故曰为空。怛萨阿竭则为自然。自然故空故曰为空。须菩提。其有欲令名号生者。则为欲令无相法生。空无相无愿亦复如是。其欲令因缘言辞生者。则为欲令无相法生。所以者何。须菩提。其名号空。不生三界萨芸若者则无所住。所以者何。名号则空。用名号空故曰为空。因缘言辞诸可处所悉皆为空。诸法处空故曰为空。其有欲令无所生生。则为欲令无相法生。所以者何。无相法空悉无处所。处所空故故曰为空。其有欲令无灭无想无尘无嗔无所有生者。则为欲令无相法生。所以者何。此诸事空空故曰空。名号因缘言辞所处。三十七品十种力四无畏十八不共诸佛之法四分别辩。亦复如是。是故须菩提摩诃衍者从三界生为无所生。生萨芸若生亦无所生无有动处。又须菩提所问。在何所住者。心无所住衍无有处。所以者何。无所住故。一切诸法亦无所住。又须菩提。衍所住者住无所住。其法界者。亦无所住住无所住。衍亦如是住无所住。如上虚空无所由转。衍亦如是住无所住。又譬如无生住无所住。衍亦如是住无所住。譬如无灭无尘无嗔及无所有住无所住。衍亦如是住无所住。所以者何。法界自然住无所住。所以者何。法界自然用自然故自然为空。及与七空悉无所有自然为空。空无所有故曰为空。是故须菩提。衍无所住住无所住故无动转。须菩提所问。从何所住而成衍者。衍无所生。所以者何。无有从中生者。无有甫当生者。一切诸法悉无所有。以此无故。一切诸法亦复如是。何所有法当有生者。所以者何。我人寿命亦复如是。亦无有如亦无所见。亦无所得本末清净。是故我人寿命。如是法界悉不可得本末悉空。是故怛萨阿竭悉不可得。其本际者亦不可得本末悉净。是故诸界不可思议。悉不可得本末清净。是故阴种诸入悉不可得本末清净。阴种诸入不可得故本末清净。六波罗蜜者悉不可得本末清净。是故七空亦不可得本末清净。意止意断神足根力七觉八道三十七品十种力四无所畏十八不共诸佛之法四分别辩。亦不可得本末清净。须陀洹斯陀含阿那含阿罗汉辟支佛。上至怛萨阿竭阿罗诃三耶三佛。悉不可得本末清净。三乘之法萨芸若慧。不可得故本末清净。其无所有生悉不可得本末清净。无灭无尘无嗔无争。诸无所有及诸所有。悉不可得本末清净。其过去当来今现在事。往来所住住止所生。悉不可得本末清净。所益所损悉不可得本末清净。谁当逮得不可得者。其法界者亦不可逮无有得者。所以者何。欲逮法界则不可得。若求阿罗汉辟支佛怛萨阿竭。欲得此者悉不可得。若有欲得三十七品十力无畏十八不共诸佛之法四分别辩者。亦不可得无能逮者。若有欲逮得阿耨多罗三耶三菩悉不可得。本际悉空而不可得。六波罗蜜及与七空。亦复如是悉不可得。其无所生亦无所灭。无尘无嗔无所有者悉不可得。所以者何。正真观之悉无所有悉不可得。其欲逮得第一住者亦不可得。至于十住。亦不可得本末清净。何所有第一住者。其清净观者及种性八等所示现地是所有地离欲之地所作办地辟支佛地菩萨道地三耶三佛地及第一地悉不可得。其七空者悉不可得。计于内空上至十住悉不可得。七空十住悉无所有悉不可得。所以者何。须菩提。其第一住但名字耳。为不可得。上至十住亦复如是。假有所得为不可得本末清净。而为众生讲说内空悉不可得。一切众生亦不可得。而为众生说七品空事。所可说者悉不可得本末清净。以内空故佛土清净悉无所得。七空自然自然空故佛土清净。悉不可得本末清净。是故内空及与五眼悉不可得。皆无所有自然。自然空为其五眼。悉无处所本末清净。是故须菩提。菩萨摩诃萨于一切悉无所得。则为逮得成摩诃衍三拔致萨芸若慧

    摩诃般若波罗蜜无去来品第二十

尔时贤者须菩提白佛言。所言摩诃衍者。其摩诃衍义之所趣。唯天中天。于天上人中世间而最为尊。莫不归者。衍与空等。譬如虚空容覆无量阿僧祇人莫不戴仰。唯天中天。摩诃衍者亦复如是。菩萨摩诃萨覆不可计阿僧祇人悉因得度。摩诃衍者。不见来时不见去时不见住处。如是天中天。摩诃衍者。不得过去当来现在。亦无中间见亦无所得。其名等于三世。故曰为衍是故为摩诃衍。于是世尊告须菩提。如是如是。所谓摩诃衍者。是为菩萨摩诃萨六波罗蜜檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。是为须菩提菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍者。谓一切诸陀罗尼门诸三昧门首楞严三昧。取要言之。空等三昧。解脱三昧。无著三昧。寂灭三昧。是谓菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍者。晓了七空三十七品十力无畏十八不共诸佛之法四分别辩。是为菩萨摩诃萨摩诃衍也。又须菩提。所言摩诃衍者。天上天下世间最上莫不归仰者。譬如须菩提欲界本无而无本无。等无有异不可分别。无有颠倒诚谛自然。久长坚固无有别离法。无合无散未曾所有。是为摩诃衍。天上天下人中最尊莫不归仰者。假使须菩提。劫尽烧时悉为现之。教化一切令知无常。无有长久无坚固者悉无所有。是故摩诃衍。天上天下世间最尊莫不归仰者。又须菩提。欲界如是等无有异。无有颠倒诚谛自然。无本坚固无别离法无有因缘。其无所有终不所有。是为摩诃衍。天上天下最尊。设使须菩提。欲界有想无常颠倒而现破坏。一切无常无有长久不可坚固。别离之法悉无所有。是故须菩提。摩诃衍天上天下。于无色界亦复如是。设使须菩提。诸色本无悉无所有亦复如是。等亦无差别无有若干诚谛自然。本无坚固无别离法。其无有者不可令有。是为摩诃衍。天上天下最尊。假使须菩提。色有所念而应清净。而为颠倒悉令饱满。皆当无常无有久存不得坚固。别离之法悉无所有。是故摩诃衍色痛痒思想生死识亦复如是。眼耳鼻舌身心等无有异。眼色识耳声识鼻香识舌味识身更识意欲识。等无有异悉无所有。所可分别。至诚真谛。计有常者久长坚固是非摩诃衍。用习六事心有想念。因缘所习迷惑多求以自饱满。是一切法皆悉无常无有长存不可久固。是故摩诃衍天上天下最尊。设使须菩提。法界所有悉无所有。是为摩诃衍。天上天下最尊坚固无所有生。如须菩提法界所有悉无所有。行无所有。是故摩诃衍天上天下最尊。设使须菩提。怛萨阿竭现有所有悉无所有。其真本际不可思议。其界所有悉无所有。是为摩诃衍。天上天下最尊。正使须菩提。诸界者不可思议。其所有者悉无所有。是故摩诃衍天上天下最尊。设使须菩提。六波罗蜜所有悉无所有亦复不无。是为摩诃衍。正使须菩提。其内空者不有不无自然为空。不有不无是为摩诃衍。所以须菩提。其内空者自然无有。有了空者不有不无。故曰摩诃衍。设使须菩提。三十七品。十力无畏十八不共诸佛之法四分别辩。不有不无亦不不无。是为摩诃衍。正使须菩提。其种性法不有不无亦不不无。用种性法不有不无亦不不无。是故摩诃衍。正使须菩提。其八等法不有不无。须陀洹法斯陀含法阿那含法阿罗汉法辟支佛法诸佛之法不有不无。用不有不无亦不无无。是故摩诃衍。正使须菩提。其八等法及与佛法。不有不无亦不无无。是故摩诃衍。用须菩提其诸种性不有不无亦不无无。用诸八等不有不无亦不无无。须陀洹斯陀含阿那含阿罗汉辟支佛。上至怛萨阿竭阿罗诃三耶三佛不有不无亦不无无。是故摩诃衍。须菩提。欲知以诸八等怛萨阿竭阿罗诃三耶三佛。不有不无亦不无无。是故摩诃衍。设使须菩提。诸天人民阿须伦及与世间。不有不无亦不无无。以诸天人民及阿须伦世间所有不有不无亦不无无。是故摩诃衍。假使须菩提。菩萨从初发意。乃至道场坐于佛树于中发心。不有不无亦不无无。如须菩提。菩萨摩诃萨从初发意乃至道场。于中发心一切不有不无亦不无无。是故摩诃衍。假使须菩提。菩萨摩诃萨。其智慧尊犹如金刚。不有不无亦不无无。是为菩萨摩诃萨晓了达见一切诸碍及众尘劳得萨芸若。以须菩提菩萨摩诃萨了诸挂碍一切尘劳悉无所有逮萨芸若。是故摩诃衍。正使须菩提。怛萨阿竭阿罗诃三耶三佛。其三十二大人之相。不有不无亦不无无。是故怛萨阿竭阿罗诃三耶三佛。天上天下最尊。威神圣德光明微妙。靡所不照无有畴匹。是故怛萨阿竭阿罗诃三耶三佛。威神巍巍圣德光明。照于十方恒沙诸佛世界。及诸天上天下诸天人民。诸阿须伦光明普遍。用不有不无亦不无无。是故怛萨阿竭阿罗诃三耶三佛光明。照于十方恒沙世界。又须菩提。怛萨阿竭有八部之音。不有不无亦不无无。是故怛萨阿竭阿罗诃三耶三佛。声告十方于阿僧祇无量世界。用怛萨阿竭其八部声。不有不无亦不无无。是故有八种音声。告于十方不可思议无量世界。又须菩提。怛萨阿竭所转法轮。不有不无亦不无无。是为怛萨阿竭转于法轮。沙门婆罗门诸梵天众。天上天下莫能当者。皆令如法各得其所。是故怛萨阿竭为转法轮。沙门婆罗门天上天下。及诸人民莫能当者。又须菩提。一切众生不有不无亦不无无。是故怛萨阿竭数转法轮。令诸众生不至无余于泥洹界。又须菩提。此诸众生不有不无亦不无无。悉了是已故。怛萨阿竭转于法轮。是故众生至无余界。于泥洹界而般泥洹

    摩诃般若波罗蜜衍与空等品第二十一

佛告须菩提。如汝所言。衍与空等者。所说至诚。如是如是。衍与空等。譬如虚空不可计知东方里数。南方西方北方四隅上下亦不可知。无远无近无有边际。怛萨阿竭慧亦如是。不可尽极八方上下。无有边际无有远近。慧不可尽。譬如虚空无长无短无有方面无增无减。怛萨阿竭慧亦如是。无长无短不圆不方无增无减。又须菩提。譬如虚空无有五色青黄赤白。衍亦如是。又须菩提。譬如虚空无有过去当来现在。衍亦如是无去来今。又须菩提。譬如虚空无能增者无能减者。衍亦如是不增不减。故言衍与空等。又须菩提。譬如虚空无有尘劳无嗔恨。无有生者亦无所灭。亦无所住亦无不住亦无所念。衍亦如是。是故言衍与空等。又须菩提。譬如虚空无有善恶。无有言辞亦无不言。譬如虚空无见无闻无念无知。衍亦如是。是故言衍与空等。又须菩提。譬如虚空亦无有异亦无不异。亦无所断亦无所造证亦无所除。衍亦如是。又须菩提。譬如虚空无有欲法不离欲法。无嗔恚法不离嗔恚。无愚痴法不离愚痴。衍亦如是。又须菩提譬如虚空不与欲界合同。不与色界及无色界合同。亦不离三界。衍亦如是。又须菩提。譬如虚空无初发意从第一住衍亦如是无有十住。又须菩提。譬如虚空无有清浊无所观见无有处所。无种性地八人等地无示现地。无我所地无所欲地。无所作不作地。衍亦如是。又须菩提。譬如虚空无须陀洹果。无斯陀含果。无阿那含果。无阿罗汉果。又须菩提。譬如虚空无声闻地。无辟支佛地。无三耶三佛地。衍亦如是。又须菩提。譬如虚空无有形像亦无不像。亦无有见亦不无见无受无舍无合无散。衍亦如是。又须菩提。譬如虚空则无有常亦无不常。无苦无乐无我不我衍亦如是。又须菩提。譬如虚空亦无有空亦无不空。无有异空无有异想。亦无无想亦无有愿亦无不愿。衍亦如是。故言衍与空等。又须菩提。譬如虚空无有寂然无不寂然。无有惔怕亦无不怕。又须菩提。譬如虚空无有光明亦无闇冥。衍亦如是。又须菩提。譬如虚空无所逮得亦无不得。衍亦如是。是故言衍与空等。又须菩提。譬如虚空无言无说亦无不言。衍亦如是。是故言衍与空等。是故须菩提。虚空平等衍亦平等。如须菩提所言。譬如虚空无有边际。覆不可计阿僧祇人。衍亦如是。安不可计阿僧祇人。如是须菩提。譬如虚空覆不可计阿僧祇人。衍亦如是。护不可计阿僧祇人计人无人。譬如虚空不可得有空以无有。摩诃衍者亦复如是。是故须菩提。摩诃衍者。安护无数阿僧祇人。所以者何。人与虚空及摩诃衍。此一切法都不可得故。复次须菩提。人不可计空亦不可计。虚空亦不可计。摩诃衍亦不可计。是故摩诃衍覆不可计阿僧祇人。所以者何。须菩提。人与虚空及摩诃衍。悉不可计悉不可得。复次须菩提。不可计是故摩诃衍覆护不可计阿僧祇人。复次须菩提。人无所有法界亦无所有一切诸法亦无所有。故曰虚空亦无所有。人与虚空及摩诃衍悉无所有。阿僧祇无所有。无有量无所有。无有底无所有。是故摩诃衍覆护不可计阿僧祇人。所以者何。众生法界及摩诃衍。又阿僧祇不可限量无有崖底。悉不可得故。复次须菩提。人无所有。怛萨阿竭亦无所有。虚空亦无所有。摩诃衍亦无所有。阿僧祇亦无所有。不可计亦无所有。无底亦无所有。一切诸法亦无所有。是故须菩提。摩诃衍者。为不可计阿僧祇崖底人而设拥护。所以者何。怛萨阿竭虚空众生及摩诃衍。其阿僧祇不可计议无有崖底。悉不可得故。复次须菩提。吾我无所有。所知所见亦无所有。本际无所有。当作是了本际以无。至不可计及阿僧祇无央数者亦无所有。以无所有一切诸法亦无所有。是故摩诃衍名曰不可计阿僧祇覆护无央数人。所以者何。须菩提。一切众生所知所见及与本际。至阿僧祇无央数不可计皆不可得。复次须菩提。吾我及人悉无所有。所知所见亦无所有。不可思议境界亦无所有。色痛痒思想生死识亦无所有。虚空亦无所有。摩诃衍亦无所有。阿僧祇亦无所有。不可计亦无所有。无央数亦无所有。一切诸法亦无所有。是故摩诃衍为不可计阿僧祇人之覆护。所以者何。如须菩提。吾我诸法悉不可逮。复次须菩提。吾我及人悉为虚空。所知所见亦复虚无。眼亦虚无。耳鼻舌身意亦复虚无。以虚无虚空亦虚无。空以虚无摩诃衍者亦复虚无。以无二虚阿僧祇无央数不可计亦复虚无。不可计以虚无。一切诸法亦复虚无。是故摩诃衍。覆无央数不可计阿僧祇人。所以者何。须菩提。吾我及人一切诸法悉不可得。复次须菩提。吾我无所有。所知所见亦无所有。所知所见以无所有。檀波罗蜜亦无所。有尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜亦无所有。般若波罗蜜以无所有。虚空亦无所有。摩诃衍亦无所有。是故摩诃衍覆护无央数不可计阿僧祇人。所以者何。须菩提。吾我及寿一切诸法悉不可得故。复次须菩提。吾我及人则无所有。世间所知内空外空近空远空真空所有空无所有空亦无所有。七空以无有。虚空亦无所有。摩诃衍亦无所有。无央数不可计阿僧祇亦无所有。一切诸法亦无所有。是故摩诃衍。覆护不可计无央数阿僧祇人。所以者何。须菩提。我人及寿一切诸法悉不可得故。复次须菩提。我人知见悉无所有。意止意断神足根力七觉八道三十七品亦无所有。十力无畏十八不共诸佛之法亦无所有。虚空摩诃衍亦无所有。是故摩诃衍覆护不可计无央数阿僧祇人。所以者何。吾我及人一切诸法悉不可得故。复次须菩提。我人知见悉无所有。种性诸法亦无所有。所作之地以无所有。虚空亦无所有。摩诃衍亦无所有。不可计阿僧祇人一切诸法。亦无所有。是故摩诃衍覆护不可计无央数阿僧祇人。复次须菩提。我人知见亦无所有。须陀洹斯陀含阿那含阿罗汉辟支佛亦无所有。一切诸法亦无所有。是故摩诃衍覆护不可计无央数阿僧祇人。所以者何。吾我及人一切诸法悉不可得。

复次须菩提。声闻辟支佛上至怛萨阿竭亦无所有。萨芸若亦无所有。一切诸法亦无所有。是故摩诃衍覆护不可计无央数阿僧祇人所以者何。须菩提。我人诸法悉不可得故。又须菩提。泥洹之界覆护不可计阿僧祇人。衍亦如是。是故衍与空等。覆护不可计阿僧祇人。如须菩提所问。摩诃衍者。亦不见来时亦不见去时。亦不见住处。衍亦如是。所以者何。一切诸法不可转动。是故无有住者无有来者亦无所住。所以者何。须菩提。色痛痒思想生死识。亦无所从来亦无所从去亦无所住。须菩提。色痛痒思想生死识亦清净。无所从来无所从去亦无所住。色痛痒思想生死识者无本。无所从来无所从去亦无所住。色痛痒思想生死识自然。无所从来无所从去亦无所住。色痛痒思想生死识自然相。无所从来无所从去亦无所住。眼耳鼻舌身意自然相者。无所从来无所从去亦无所住。其地水火风空是诸种者。无有清净亦无无本。其自然者亦无地种。自然相者。无所从来无所从去亦无所住。水火风种虚空识种亦复如是。怛萨阿竭本无自然及自然相。无所从来无所从去亦无所住。须菩提。本际清净本际无本。本原自然本自然相。不可计议及清净界者。无所从来无所从去亦无所住。不可思议及与无本。无所念界及与自然。无思议界自然之相。无所从来无所从去亦无所住。须菩提。六波罗蜜亦清净。般若波罗蜜亦无无本亦无自然。自然之相。无所从来无所从去亦无所住。三十七品十力无畏十八不共诸佛之法道德清净。佛与正觉。无所从来无所从去亦无所住。其无所有及与无本。其无为者不为自然。其无为者无自然相。无所从来无所从去亦无所住。如须菩提所言。摩诃衍者。不得过去不得当来不得中间。三世平等。摩诃衍者但有字耳。如是须菩提所言。摩诃衍者。无去来今三世平等。摩诃衍者但有字耳。所以者何。须菩提。过去亦空当来亦空现在亦空。三世平等三世空等。摩诃衍者亦复空等。菩萨亦空。其以空者。无一无二无三无四不多不少。是故名曰三世平等。为摩诃衍。菩萨功德巍巍。无有等侣无正无邪。亦不于欲亦不离欲。亦不嗔恚不离嗔恚。亦不愚痴不离愚痴。不得憍慢不离憍慢。不得贪悭妒嫉亦无所离。不得善法恶法。不得有常无常。不得苦乐。不得我不我。欲界色界无色界亦不可得。不度欲界不度色界不度无色界。所以者何。不得自然。过去色空当来色空现在色空。痛痒思想生死识。亦复如是。色不可得。用过去当来现在色空故。不可得空故曰空。空不可得。何况念空有去来今。痛痒思想生死识。亦复如是。又须菩提。六波罗蜜。不得过去不得当来不得现在。须菩提。六波罗蜜亦不可得。三世平等故。六波罗蜜为不可得。其平等者无去来今。用平等故。复次须菩提。其三十七品十力无畏十八不共诸佛之法亦不可得。过去当来现在三世平等故。三十七品十力无畏诸佛之地亦不可得。其平等者无去来今。十力无畏十八不共诸佛之法无去来今。以平等故。故曰平等。何况平等去来今三十七品十力无畏十八不共诸佛之法。而可得乎。复次须菩提。过去当来现在凡夫亦不可得。三世平等。故故凡夫等。所以者何。推求人永不可得。须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨怛萨阿竭亦不可得。当来现在亦复如是。三世平等故。诸声闻辟支佛菩萨怛萨阿竭亦不可得。推极人本不可得故。如是须菩提。故菩萨摩诃萨。作是住般若波罗蜜。觉了三世。为以具足萨芸若慧。是为菩萨摩诃萨。为摩诃衍三世平等。菩萨摩诃萨以住是者。天上天下世间最尊。因得出生萨芸若慧。须菩提白佛言。善哉善哉。唯天中天。摩诃衍者。是菩萨摩诃萨学此衍者。过去菩萨摩诃萨。亦因学是得萨芸若慧。当来菩萨摩诃萨。亦因是学得萨芸若慧。今现在十方不可计无央数阿僧祇世界。诸菩萨摩诃萨。亦复学是摩诃衍。得萨芸若慧。是故天中天。菩萨摩诃萨摩诃衍也。佛告须菩提。如是如是。过去未来当今现在。怛萨阿竭阿罗诃三耶三佛。悉学是法得萨芸若慧

光赞经卷第八光赞经卷第九

        西晋月氏国三藏竺法护译

    摩诃般若波罗蜜分曼陀尼弗品第二十二

尔时贤者分曼陀尼弗白佛言。尊者须菩提。佛使说般若波罗蜜。乃说摩诃衍事为。须菩提白佛言。唯我说摩诃衍得无过。天中天。佛言。不过也。汝说摩诃衍为随般若波罗蜜教。所以者何。须菩提。诸所有善法声闻辟支佛法。佛正觉法。皆从般若波罗蜜出生。本从其教。须菩提白佛言。云何天中天。诸所善法声闻辟支佛法。诸佛之法及菩萨法。皆从般若波罗蜜出生。皆从其教乎。佛告须菩提。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜。四意止四意断四神足念五根五力七觉意八道行。空无相无愿诸解脱门。如来十力四无所畏十八不共。诸佛之法四分别辩。大慈大哀无忘失法慈悲喜护。晓了道品所施行法。声闻辟支佛法菩萨法。一切诸法皆从般若波罗蜜中出生。皆从其教。又须菩提。其摩诃衍般若波罗蜜及五波罗蜜。色痛痒思想生死识。眼色识耳声识鼻香识舌味识身更识意法识。所更因缘所习因缘。诸可不可意所习种。意止意断神足根力。七觉八道。十力无畏十八不共诸佛之法。空无想愿诸解脱门。一切善法有漏无漏。有所有无所有。有为无为。苦习尽道。欲界色界无色界。内空外空近空远空真空所有空无所有空一切平等。及诸三昧陀罗尼门。怛萨阿竭所晓了法自到成就。诸佛法界如来本际不可思议界。若合若散无合无散。有色无色有见无见。有形无形有相无相。是一切诸法皆从摩诃衍出生。为顺般若波罗蜜教。所以者何。须菩提。摩诃衍般若波罗蜜等无异。六波罗蜜复无有异。十力无畏诸佛之法亦无有异。是故摩诃衍诸佛之法。则无有异亦无有二亦无若干。是故须菩提。所说摩诃衍者。则说般若波罗蜜

    摩诃般若波罗蜜等三世品第二十三

须菩提白佛言。菩萨亦不念过去亦不念当来亦不念中间。色痛痒思想生死识亦无有边。菩萨亦无有边。色与菩萨俱无所有亦不可得。痛痒思想生死识。识与菩萨俱无所有亦不可得。如是天中天。一切菩萨摩诃萨皆不可得。当云何教菩萨摩诃萨般若波罗蜜。一切求菩萨悉不可得亦不可见。当云何说般若波罗蜜教菩萨耶。菩萨而复号菩萨但有字耳。譬如人自言吾有我。本末求之悉无所有诸法自然何所生色。色之所生。何所生痛痒思想生死识。识之所生。唯天中天。其无所生则无有色亦无有识也。何所有说般若波罗蜜者。当云何教菩萨。亦无有异处。亦无有出生。亦不可得菩萨者。亦不得行道者。菩萨闻是不恐不怖无所畏惧。菩萨摩诃萨则为行般若波罗蜜。舍利弗谓须菩提。云何过去当来中间。菩萨而不可得。何以故。色无有边。痛痒思想生死识亦无有边。菩萨亦无有边。色痛痒思想生死识。俱无所有亦不可得。一切菩萨皆不可得。云何教菩萨摩诃萨般若波罗蜜。何所说吾我都不可见。菩萨亦不可得处。云何教菩萨摩诃萨般若波罗蜜。何以故。说是言菩萨摩诃萨。但有字耳。求索吾我而无本末。诸法自然色从何生。痛痒思想生死识从何出生。唯天中天。其无所生则无有色。其无所生者则无痛痒思想生死识。向者须菩提作是说言。其无所生。当云何教般若波罗蜜。何故说言亦无异处。有所生者而可得菩萨耶。其行道者。何故须菩提而说此言。菩萨摩诃萨闻是心不恐怖。则为行般若波罗蜜。所说云何。须菩提谓舍利弗。人无所有故。过去菩萨而不可得众生悉空。是故过去菩萨而无所受。众生恍忽。是故过去菩萨而无所受。色无所有。是故菩萨不受过去痛痒思想生死识。空无所有。是故菩萨不受过去受。过去色空。痛痒思想生死识亦空。色恍忽痛痒思想生死识恍忽。色自然痛痒思想生死识自然。是故菩萨不受过去。檀波罗蜜尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜。悉无所有。是故菩萨不得过去。所以者何。舍利弗。其以空者不可得过去当来中间。无有异空无有菩萨。无有过去空菩萨及过去事。皆悉无二无若干也。是故菩萨不受过去。当来中间亦复如是。取要言之。檀波罗蜜亦复恍忽。檀波罗蜜自然。尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜般若波罗蜜亦复悉空。般若波罗蜜亦复恍忽则无自然。是故菩萨不受过去。是故舍利弗。其以空者无有过去当来中间。空与菩萨及已过去。亦无有二亦无有若干。是故舍利弗。菩萨不受过去。其七空者亦无所有。是故菩萨不受过去。复次舍利弗。其意止意断神足根力七觉八道三十七品。亦复为空亦复恍忽。其七空者亦复如是。是故菩萨不受过去。十力无畏十八不共诸佛之法悉空恍忽。是故菩萨不受过去。六波罗蜜亦无所有亦复恍忽亦无自然。是故菩萨不受过去。复次舍利弗。一切三昧悉无所有。陀罗尼门皆无所有。诸三昧门陀罗尼门。亦复悉空亦复恍忽。诸三昧门陀罗尼门皆无所有。诸三昧门陀罗尼门。亦复悉空亦复恍忽。诸三昧门陀罗尼门皆无自然。是故菩萨不受过去。六波罗蜜亦复如是。复次舍利弗。及诸法界亦无所有。法界悉空法界恍忽法界自然。法界亦无七空。是故菩萨不受过去。复次舍利弗。恍萨阿竭亦无所有亦悉无本。无本恍忽无本亦空。其本无者亦无自然。是故菩萨不受过去。其本际者亦无所有。本际悉空本际恍忽。亦无自然不可思议。一切诸界亦无自然。是故菩萨不受过去。复次舍利弗。诸声闻辟支佛怛萨阿竭亦无所有。怛萨阿竭则空恍忽亦无自然。是故菩萨不受过去。道无所有亦空恍忽亦无自然。萨芸若者亦空恍忽亦无自然。是故菩萨不受过去。所以者何。舍利弗。空与恍忽过去当来中间亦复如是不可得。菩萨亦不可得。是故舍利弗。空与恍忽过去当来。而无有二亦无若干。是故菩萨不受过去。又舍利弗。所问何故色无有边。痛痒思想生死识无有边。菩萨亦无有边。痛痒思想生死识如空空。譬如虚空无有边际。无有中间无有崖底。空虚但有字。舍利弗。色痛痒思想生死识亦如是无有边际。无有中间无有崖底。以色空故。其以空者无际无间不可得底。痛痒思想生死识者亦复如是。是故舍利弗。色无有边痛痒思想生死识无有边。菩萨亦无边。皆无所有亦不可得。是故舍利弗。色与菩萨亦无所有亦不可得。痛痒思想生死识亦复如是。复次舍利弗。六波罗蜜空故曰为空。内空亦空外空亦空。以空故空。近空远空真空及七空。三十七品十力无畏诸佛之法。亦复悉空。以空故空。无有本际不可思议。一切诸界亦复为空。以空故空。诸三昧门陀罗尼门亦复为空。其萨芸若亦复为空。其所晓了道品道慧亦复为空。以空故空。其三乘法亦复为空。怛萨阿竭亦复为空。故舍利弗。怛萨阿竭空亦无有。色亦不可得。色与菩萨亦无所有。悉不可得。痛痒思想生死识者。亦复如是。舍利弗。所问何故一切菩萨悉不可得。云何为菩萨说般若波罗蜜。色痛痒思想生死识亦不可得。色不可得痛痒思想不可得。色色痛痒思想生死识不可得。其所思想想亦无所有所想痛痒亦无所有。所想生死亦无所有。所想行识亦无所有亦不可得。所识识者。亦无所有亦不可得。所识色所识痛痒所识思想所识生死。悉无所有亦不可得。舍利弗。其六情者。亦无所有亦不可得。其眼耳鼻舌身意者。悉无所有亦不可得。其耳者。悉无所有亦不可得。耳与眼者。悉无所有亦不可得。耳与鼻悉无所有亦不可得。鼻与嗅者。悉无所有亦不可得。其鼻及眼。悉无所有亦不可得。其鼻与舌。悉无所有亦不可得。计于舌者。悉无所有亦不可得。舌眼耳鼻悉无所有亦不可得。其香及身。悉无所有亦不可得。身及与身。悉无所有亦不可得。意及与意。悉无所有亦不可得。眼耳鼻舌身意。悉无所有亦不可得。眼色耳声鼻香舌味身更意欲。六情六识六味十八诸入因缘。一切诸事悉无所有亦不可得。内色外色痛痒诸法亦复如是。六波罗蜜及与七空。三十七品十力无畏诸佛之法。诸三昧门陀罗尼门种性诸法。阿罗汉法辟支佛法怛萨阿竭菩萨法。十住事法萨芸若慧及诸道慧上至怛萨阿竭及与菩萨。悉无所有亦不可得。菩萨与般若波罗蜜。悉无所有亦不可得。又般若波罗蜜于般若波罗蜜。悉无所有亦不可得。般若波罗蜜及与菩萨。悉无所有亦不可得。般若波罗蜜无言无说无教无化。不可得故。于菩萨者无言无说无教无化。亦无所有亦不可得。般若波罗蜜亦无所有亦不可得。是故舍利弗。一切诸法亦无所有。亦无得者不可得故。菩萨摩诃萨亦不可得亦无所说。如舍利弗所言。何以故。字而字菩萨从何来。其名字者。为在何所而为菩萨。是故名为菩萨。言菩萨者。但以字耳。从何所来。色痛痒思想生死识者。但以字耳。但字字着言耳。而无有色无有痛痒思想生死识。所以者何。字者亦空字自然空。不以是故名为菩萨。亦无己字(丹本亦不以空)为菩萨也。复次舍利弗。六波罗蜜但以字耳。不以字故为六波罗蜜。是所言菩萨者。但以字耳。是以言般若波罗蜜。但以字耳。不以字故为般若波罗蜜。般若波罗蜜者无有字也。所以者何。字与般若波罗蜜。二者俱空不可得故。舍利弗。所言菩萨但假号耳。所言内空外空近空远空真空所有空无所有空。但以字耳。其七空者不以字空。所以者何。不以字故为空也。此诸空者为不可得。是故舍利弗。所言菩萨但假号耳。舍利弗。此所名字为假号耳。意止意断根力觉意八道三十七品十力无畏十八不共。诸佛之法但假号耳。不以字故。为诸佛法诸佛法空。是故舍利弗。所言菩萨但假号耳。诸三昧门陀罗尼门。须陀洹斯陀含阿那含阿罗汉。辟支佛菩萨上至佛。亦假号耳。不以字为字。所言吾我我所。推其本末亦无所有无所成。吾我不可得。何况于道有所得者。所知所见亦不可得。何况欲令有所成者。舍利弗。色痛痒思想生死识本末亦不可得。何况欲令识有成眼。眼更因缘痛痒。耳鼻舌身意。六情所入亦不可得。六波罗蜜七空。本末空亦不可得。何况欲令有所成者。三十七品十力四无畏诸佛之法。推其本末亦不可得。何况欲令有所成者。诸三昧门陀罗尼门。推其本末悉不可得。何况欲令有所成者。声闻辟支佛怛萨阿竭阿罗诃三耶三佛都不可得。是故舍利弗。所言吾我悉无所有。一切诸法亦无所有悉为自然。所以者何。自然无合无散。舍利弗问须菩提。何谓自然无合无散。答曰色痛痒思想生死识者。用自然故无合无散。眼耳鼻舌身意六情。所受所生痛痒所合。悉为自然无合无散。六波罗蜜亦无合无散悉为自然。是故舍利弗。一切诸法皆无所有悉为自然。复次舍利弗。一切诸法亦无有常亦无所至。舍利弗问须菩提。何谓一切诸法无常无至。须菩提言。色痛痒思想生死识亦无有常无所归趣。所以者何。其无常者。悉无所有亦无有眼。是故一切诸法皆无有常无所归趣。诸所有法亦复如是。悉无有常无所归趣。一切诸漏乃至无漏。所可说者无所说法。其有常者。则为无所有亦无有眼。是故舍利弗。一切万物悉无有常无所归趣。复次舍利弗。一切诸法无所积聚亦无有坏。又问须菩提。云何一切诸法亦无积聚亦无有坏。答曰色痛痒思想生死识者。亦无积聚亦无有坏。所以者何。用清净故。诸善不善所有法无所有法。有漏法无漏法。悉无积聚亦无有坏。所以者何。用清净故。是故舍利弗。一切所有悉无所有。舍利弗。所问色何所生。色无所生。痛痒思想生死识者。亦无所生。所以者何。舍利弗色痛痒思想生死识亦无所有。晓了行者则无有色亦无所生。痛痒思想生死识亦无所生。色痛痒思想生死识亦无所有。所以者何。晓了行者则为无有眼。眼无所有。所以者何。晓了行者悉无所有。六情亦然。复次舍利弗。一切诸法悉无所有。所以者何。晓了行者不造所有。是故舍利弗。色痛痒思想生死识者。亦无所生。又舍利弗。所问者色无所生则为非色。亦非痛痒思想生死识。何以故。色清净空无起灭。亦无所住亦无别异。以痛痒思想生死识亦清净空清净故。故曰清净。亦无起灭亦无所住不可分别。一切所有亦复清净。空清净故曰清净。亦无所起亦无所灭。亦无所住不可别知。是故舍利弗。色痛痒思想生死识者。亦无所生。如舍利弗所问。何故说此悉无所生。当何从说般若波罗蜜。所以者何。般若波罗蜜亦无所生。设无所生般若波罗蜜亦无所出。无有二法亦无若干。是故说此。而当从何所说般若波罗蜜。舍利弗问。亦不从异处出生菩萨而得道行。所以者何。菩萨摩诃萨行般若波罗蜜者。不从异生亦复不见异。般若波罗蜜亦复不别异处而悉等见。诸菩萨行亦无所生。又菩萨者无有二法亦无若干。亦不见色痛痒思想行生死识有异处生。所以者何。用无生故。色无有二亦无若干。亦不从异而有所生。亦不见色从异处生。所以者何。色无所生识无有名亦无若干。其十八种三十七品诸佛之法。及与七空三乘之法。不见所生。所以者何。无所生故无有二法亦无若干。是故舍利弗。不得菩萨有异处生而行道者。又舍利弗。向者所问。假使菩萨摩诃萨闻是说者无所恐。不畏亦无所惧。则为行般若波罗蜜。所以者何。菩萨摩诃萨观一切诸法。皆悉如梦如幻野马芭蕉影响。是故舍利弗。菩萨摩诃萨闻是不恐不怖亦不畏惧。是为行般若波罗蜜。须菩提白佛言。天中天。菩萨摩诃萨行般若波罗蜜时。观法如是。便不受色痛痒思想生死识。亦无所舍。亦无所住。亦无所著般若波罗蜜。则无有色痛痒思想生死识。亦不受亦不舍亦无住。亦无著无所分别。亦不受眼耳鼻舌身意六情所依。不受吾我。亦不受檀波罗蜜。亦无所舍亦无所住。亦无所著不处吾我。尸羼惟逮禅般若波罗蜜亦不受七空。亦无所舍亦无所住。亦无所著不处吾我。复次天中天。行般若波罗蜜者。于三十七品十力无畏十八不共诸佛之法亦复如是。亦无所受亦无所舍。亦无所住亦无所著不处吾我。复次天中天。菩萨不受一切诸三昧门陀罗尼门。亦无所受亦无所舍。亦无所住亦无所著不处吾我。所以者何。菩萨行般若波罗蜜。不见色痛痒思想生死识。不见十八种三十七品及与七空。声闻辟支佛上至佛及萨芸若。亦无所见。所以者何。无色痛痒思想生死识。亦无所起亦无有识。六情无所起亦无有六情。六波罗蜜亦无所起。亦无六波罗蜜。般若波罗蜜亦无所起。亦无有二亦无若干。内空外空亦无所起。近空远空真空所有空无所有空亦复如是。所以者何。其七空者亦无所起。亦无有二亦无若干。是故天中天。其七空三十七品十力无畏十八不共诸佛之法亦无所起。亦无有二亦无若干。所以者何。天中天。是无所起。是故为无二无三。无有若干故。诸佛之法悉无所起。有所起者非为佛法。唯天中天。其无本者亦不可思议。诸法境界亦无所起。其不可思议界。则无有二亦无若干。唯天中天。须陀洹斯陀含阿那含阿罗汉辟支佛菩萨。上至萨芸若慧。悉无所起亦无所有。故萨芸若为无所起。所以者何。无有精进是为无二无三亦无若干。色痛痒思想生死识者。则为灭尽亦无有色。是故识亦灭尽。则无有二亦无若干。所以者何。天中天。其精进者无一无二无三亦无若干。其精进识亦无有识。是为檀波罗蜜。亦无所起无所精进。无二无三亦无若干。尸羼惟逮禅般若波罗蜜亦复如是。及诸七空三十七品十力无畏十八不共诸佛之法亦复如是。其言天中天。无所精进。于此行中无能计者。五阴六衰六波罗蜜三乘之法。上至萨芸若慧。亦复如是

    摩诃般若波罗蜜观行品第二十四

尔时须菩提谓舍利弗言。云何菩萨摩诃萨行般若波罗蜜而观诸法。何谓菩萨行道。为一切人而言。菩萨而悉晓了一切道法。于一切法为无所著。晓了诸法。则为晓了色痛痒思想生死识。而于识事亦无所著。晓了三十七品十力无畏诸佛之法。亦无所著。何谓一切诸法事者。须菩提谓舍利弗。其观诸法形像瑞应色声香味细滑之法。其内外法有为无为。所有无所有。形像瑞应了无因缘。是为观法。又舍利弗。所问何谓般若波罗蜜。尽无所乐。是名为般若波罗蜜。何谓为尽而无所乐。舍利弗。不乐阴种诸入。不乐六波罗蜜尸羼惟逮禅般若波罗蜜。不乐七空。不乐三十七品十力无畏十八不共诸佛之法。是名曰尽无所乐。是为般若波罗蜜。于萨芸若亦无所乐。是为般若波罗蜜。是为名曰尽无所乐。是为般若波罗蜜。所问何谓为观。是菩萨摩诃萨行般若波罗蜜时。不观色有常无常。不观色苦乐。不观色有我无我。不观色有空无空有相无相有愿无愿。不观色寂与不寂。不观色恍忽不恍忽。痛痒思想生死识及与七空。并三脱门亦复如是。不观三十七品意止意断神足根力七觉八道诸佛之法。苦乐善恶有我无我有常无常。诸三昧门陀罗尼门萨芸若慧。有常无常苦乐善恶。有我无我有空无空及三脱门。舍利弗。是为菩萨摩诃萨观行般若波罗蜜。舍利弗问须菩提。何谓色痛痒思想生死识。亦无所起则无有识。根力觉意三十七品七空四非常法。萨芸若慧悉无所起。萨芸若则无所有。须菩提谓舍利弗。谓色七空。其以空者则无有形。是故色为无所起。则无有色痛痒思想生死识亦尔。六波罗蜜空。其已空者非般若波罗蜜。慧无所起。是故舍利弗。般若波罗蜜则无所起。非般若波罗蜜。及与七空三十七品十力无畏诸佛之法。诸三昧门陀罗尼门萨芸若慧。亦复如是。色无所起则为无色痛痒思想生死识。乃至萨芸若慧亦复如是。无所起者则为无慧。舍利弗谓须菩提。何谓色痛痒思想生死识。上至萨芸若慧而无有二。须菩提言。如是如是。其无二者。色则无二。痛痒思想生死识一切识法。无合无散无色无见无所取舍。如是相者则为无想。及其七空三十七品四非常法萨芸若慧。亦复如是。五阴六衰上至萨芸若。悉无有二。舍利弗问须菩提。何谓色无有二。清净无来痛痒思想生死识上至萨芸若慧。须菩提谓舍利弗。如是如是。色不为异无所起者。亦复无异色无所起。痛痒思想生死识上至萨芸若慧亦复如是。如是舍利弗。色无有二。五阴六衰上至萨芸若慧。亦无有二。一切清净无所从来。须菩提白佛言。菩萨摩诃萨行般若波罗蜜观诸法。见一切色亦无所起本末清净。痛痒思想生死识亦复如是。吾我知见悉无所起本末清净。檀尸羼惟逮禅般若波罗蜜亦复如是。悉无所起本末清净。及与七空三十七品根力觉意十力无畏诸佛之法。不见所起本末清净。观诸三昧门陀罗尼门萨芸若慧。不见所起本末清净。观凡夫法见凡夫法。悉无所起本末清净。观须陀洹斯陀含阿那含阿罗汉。声闻辟支佛及与菩萨。见此诸法悉无所起本末清净。观一切佛法。见无所起本末清净不见所起。舍利弗问须菩提。今所说者。当云何解。五阴六衰三乘之法及萨芸若。悉无所起者。亦无五道亦无菩萨摩诃萨。亦无得神通。设须菩提。一切诸法悉无所起。何以故。成须陀洹断于三结而修行道。斯陀含者亦断三结。淫怒痴薄而修行道。阿那含者捐弃重担。断除众结而修行道。阿罗汉者除断众结及五根。无有生死而修行道。辟支佛乘以因缘觉而修行道。何故菩萨勤苦行道。为无央数众生勤苦。何故逮成阿耨多罗三藐三菩而转法轮。须菩提言。我不欲令无所起法而有所得。亦不欲令无所起法至须陀洹斯陀含阿那含阿罗汉辟支佛。亦复如是。我亦不使菩萨摩诃萨勤苦行。不令菩萨精勤苦行。所以者何。舍利弗。不以别相勤苦故。度不可计阿僧祇人。又舍利弗。行菩萨道者。当度不可计阿僧祇人。念之如母念之如父念之如子念之如身。所行亦无所起。菩萨当作是念。求于吾我皆无所有亦不可得。观内外法当作是了。设起想者不念勤苦亦不起想。所以者何。一切诸法悉无所起亦不可得。又舍利弗。我亦不欲令怛萨阿竭而无所起。无阿耨多罗三耶三菩。亦不欲令转于法轮。亦不欲令得无所起法。舍利弗问须菩提。所说云何欲令有起而逮法乎。而云无起不逮诸法。须菩提言。不以无起而逮诸法。亦不以起而逮诸法。又问须菩提。云何无所起法。亦不无起而逮诸法。须菩提言。我不欲令无所起生而逮诸法。亦不欲令无无所逮。舍利弗言。于须菩提意云何。无有逮得无成道乎。须菩提言。有得有道实无有二。又舍利弗。逮得成道方俗言耳。所言须陀洹斯陀含阿那含阿罗汉辟支佛。皆因俗教而有此言。推其本末无有逮得。无有成道无有三乘。舍利弗问须菩提。所逮成道因方俗乎。如是五道方俗所言。所有悉坏不为真谛。答曰。如是所言因于世俗。言有所得而逮成道。五道亦然。方俗尽坏不为真谛。所以者何。欲成真谛。无有善恶不起不灭。无诸尘劳亦无恚恨。乃为真谛。舍利弗问须菩提。其无生法宁有起乎。若所生法而起生乎。须菩提。无所生法亦无所生。其所生法亦复不生。舍利弗言。云何欲令无所生法而有所生。须菩提言。色痛痒思想生死识亦无所生。自然为空不欲令生。声闻辟支佛上至佛道。悉无所生。自然为空不欲令生。舍利弗言。其所生者复有生乎。无所生者而起生耶。须菩提言。其所生者亦无所生。其无所生亦无所生。所以者何。舍利弗。所生无所生。此二法者。无合无散无色无见。无所受持则为一相。无所有相。是故舍利弗。所生无所生。其无生者亦复不生。舍利弗言。谁能堪任无所生法。是须菩提。无所生法其无所生。无所生法亦无所生。须菩提言。其无所生无所生法为无所生。堪任无生无所生法为无所生。所以者何。其无生法无所生者。及与辩才悉无所生。此一切法无合无散无色无见。不可受持则为一相无所有相。舍利弗言。无所生无所生辩。无所生法亦无所生。是故堪任。须菩提言。如是如是。无所生故无所生辩。无所生法亦无所生。乃为堪任。所以者何。色痛痒思想生死识者亦无所生。六情四大是眼耳鼻舌身意亦无所生。地水火风空及诸识种亦无所生。身口意行亦无所生。声闻辟支佛上至佛亦无所生。是故舍利弗。无所生辩无无所生。无所生法故无所生其行。此者乃能堪任无所生法。舍利弗谓须菩提。贤者须菩提。所说法为第一尊。所以者何。若有问者随所问说。于一切诸法亦无所著。舍利弗言。云何于一切法而无所著。须菩提言。色痛痒思想生死识。清净空亦无所著。亦无内外亦无两间。六情所更十八诸种亦空清净。不着内外亦无两间。六波罗蜜及与七空。三十七品十力无畏十八不共诸佛之法。亦清净空不着内外亦无两间。是舍利弗。于一切法而无所著。菩萨摩诃萨行六波罗蜜者。于色痛痒思想生死识清净。上至萨芸若皆清净。舍利弗言。何谓菩萨摩诃萨纯行六波罗蜜净菩萨道。须菩提言。其檀波罗蜜。有俗间施不为度世。尸波罗蜜羼波罗蜜惟逮禅般若波罗蜜。俗间之智亦度世智。舍利弗问曰。何谓世俗檀波罗蜜度世檀波罗蜜。须菩提言。菩萨摩诃萨多所施与沙门婆罗门贫穷乞丐。饥者与食。渴者与浆。香华伎乐宅舍七宝生活之业。病瘦医药各各随人之所思欲。男女妻子头目肌体人所贪者。而不爱惜恣意与之。悉呼授之无有悭嫉。吾为施主一切放舍。从佛之教行檀波罗蜜。如是施已有所望想。于诸众生志在颠倒以为坚要。持用劝助阿耨多罗三耶三菩。以此所施令诸群生现世安隐。至无余界而般泥洹。彼合三事而有所施。何谓为三。自想。吾我想。计他人有施报想。是为三。是为俗间檀波罗蜜。不为度世。何故名之世俗檀波罗蜜。不为度世。在俗不移。不得度脱至无挂碍。是名为世俗檀波罗蜜。能净三品。何谓为三。菩萨摩诃萨有所施与。不得吾我。不见受者。而有所取亦不想报。是为菩萨摩诃萨净于三品。复次舍利弗。菩萨摩诃萨施与众生亦无有人。而以劝助阿耨多罗三耶三菩。无有众想悉无所见。亦为度世檀波罗蜜。所以名檀波罗蜜者。以度世故不着于世。尸羼惟逮禅般若波罗蜜亦复如是。有所望想为俗间智。无所望想为度世智。舍利弗。是为菩萨摩诃萨纯行六波罗蜜成菩萨道。舍利弗复问须菩提。何谓菩萨摩诃萨成菩萨道。须菩提言。意止意断神足根力七觉意八道十力无畏十八不共。空无相无愿三脱之门。及与七空一切三昧陀罗尼门。四分别辩大慈大哀。是为菩萨摩诃萨道。舍利弗言。善哉善哉。须菩提。何所波罗蜜能成勇猛。为第一上而得度乎。须菩提言。般若波罗蜜勇猛之恩而得度矣。所以者何。般若波罗蜜是一切诸法之母。护度声闻辟支佛。令得成就菩萨故。曰般若波罗蜜。般若波罗蜜悉入三乘。过去当来今现在十方世界诸怛萨阿竭阿罗诃三耶三佛。皆因般若波罗蜜。得阿耨多罗三耶三菩。逮成阿惟三佛。若有菩萨摩诃萨闻说般若波罗蜜。不以狐疑不怀犹豫。当知是菩萨摩诃萨。则为将从一切众生为一切故。无所爱惜悉能施与无有颠倒。是则不离菩萨摩诃萨行。如是念者则为思惟无极大哀。舍利弗语尊者须菩提。菩萨摩诃萨思惟乐于大哀大悲。是菩萨摩诃萨则为舍离一切众生。所以者何。一切众生不离念故。须菩提言。善哉善哉。舍利弗。吾今赞叹贤者所说。为真为谛。人无所有。其所念者亦无所有。人无自然其所念者亦无自然。人为空为念亦空。为人恍忽念亦恍忽。人身空无念亦空。无人无所觉念亦无觉。色痛痒思想生死识者。亦无所有所念亦无所有。七空亦无所有。无所有色空恍忽。色无所觉。念亦无所觉。十八诸种地水火风识界。檀尸羼惟逮禅般若波罗蜜。三十七品十力无畏诸佛之法。一切三昧陀罗尼门萨芸若慧。晓了是者悉无所有则为是道。所念无所有。人无所觉。所念亦无所觉。当晓了是乃成正觉。菩萨摩诃萨当作是行。菩萨摩诃萨不离是念乃成正觉。尔时佛赞须菩提言。善哉善哉。菩萨摩诃萨当作是说。般若波罗蜜如汝所说。悉承怛萨阿竭威神。菩萨摩诃萨当作是行般若波罗蜜。贤者须菩提说般若波罗蜜时。三千大千世界六反震动。东西南北上下皆动。于时佛笑。须菩提白佛言。今天中天。何以故笑。会当有意。佛告须菩提。如吾今日于此忍土说般若波罗蜜。十方现在诸怛萨阿竭阿罗诃三耶三佛。亦各说般若波罗蜜。佛说是语时。十二那术诸天人民。皆得无所从生法忍。应时悉得见十方诸佛皆说般若波罗蜜。说是语时。无央数阿僧祇人。皆发阿耨多罗三耶三菩心

光赞经卷第九光赞经卷第十

        西晋月氏国三藏竺法护译

    摩诃般若波罗蜜问品第二十五

尔时三千大千世界诸释提桓因诸四天王。诸焰天诸兜术天诸尼摩罗天诸波罗尼蜜天诸梵天诸梵迦夷天诸首陀卫天。各各无央数亿百千天人。俱诸天人宿命有德光明巍巍。比怛萨阿竭光百亿千亿万倍巨亿万倍。为尊为上为无等伦。为无殊匹靡不通达。尔时释提桓因白贤者须菩提。今三千大千世界诸四天王诸首陀卫诸天人等皆来大会欲听须菩提说般若波罗蜜法。云何菩萨摩诃萨住般若波罗蜜中。当云何行。须菩提谓释提桓因。诸天子乐听。我当说。须菩提承佛威神蒙佛恩助说般若波罗蜜。如诸菩萨所应立行。何所天子未发阿耨多罗三藐三菩提心者。今皆当发。其入正见者不能得发大道意也。所以者何。以塞生死道故。正使是辈人行菩萨道。我代其喜劝助令发阿耨多罗三藐三菩提心。我终不断功德。吾欲使取中正尊法。正欲使上佛无极之道。须菩提谓释提桓因。向者所问云何菩萨住般若波罗蜜中。菩萨摩诃萨发萨芸若心。不计色有常无常。若苦若乐有我无我。不计疹病忧恼之患。有害无害有缚无缚有度无度。破坏恐惧习会达于空无之身。尽无所信无所诤讼。亦无所念无有颠倒。痛痒思想生死识亦复如是。眼耳鼻舌身意。地水火风空。及诸识界不见有常无常。有我无我若苦若乐。疹病忧恼之患。诸所声色无所思念亦无颠倒。五阴六衰及识诸种。寂然恍忽诸所想念察于佛法。悉为颠倒也。复次拘翼菩萨摩诃萨欲应萨芸若心。行檀波罗蜜而无所著。尸羼惟逮禅悉无所著。复次拘翼。菩萨摩诃萨行般若波罗蜜。观察诸法了知诸法。了知诸法展转相成因得具足。展转相成晓了诸法。无有吾我亦无有身。菩萨所用劝助道心。其道心者亦无所有。须菩提谓拘翼。所劝道心知无所有则知道心。而无所有便不可得。设使劝助道心不可得已。是为拘翼菩萨摩诃萨般若波罗蜜观一切法。不见诸法有可得者。释提桓因问尊者须菩提。云何劝助道心而无所有。云何劝助道心而不可得。云何劝助道心而无所有而不可得耶。须菩提谓释提桓因。拘翼。其劝助心及与心本道心。如是无有异心。无有心则以无心而劝助之。无有无念以无念而劝助之。若以无心则以无心。便无有念以无有念。则为菩萨摩诃萨般若波罗蜜。佛言。善哉善哉。须菩提。若能劝助菩萨摩诃萨说般若波罗蜜。乃如是乎。须菩提白佛言。我身天中天。当报佛恩行反复事。所以者何。过去怛萨阿竭阿罗诃三耶三佛。使诸弟子为诸菩萨说般若波罗蜜。过去佛时为诸菩萨劝助讲说六波罗蜜。赞叙诱进而化建立于是道品。彼时世尊。本与诸菩萨兴六波罗蜜。得阿耨多罗三藐三菩逮阿惟三佛。今我如是天中天。亦当劝助诸菩萨摩诃萨。发起信乐受六波罗蜜。开化建立于是佛道。我皆受已皆劝乐已。殷勤劝立当令菩萨摩诃萨。疾成阿耨多罗阿惟三佛。须菩提谓释提桓因。且听拘翼。如向者问。菩萨当云何于般若波罗蜜中住。而无所住。拘翼。所言色者。色则为空。痛痒思想生死识亦复为空。所言菩萨。菩萨则空。以色空故菩萨空耳。悉无有二亦无若干。痛痒思想生死识空故。菩萨为空。悉无有二亦无若干。是为拘翼菩萨摩诃萨于般若波罗蜜中住。复次拘翼。所言眼者。眼则为空。耳鼻舌身意亦复如是。所言菩萨菩萨亦空。眼耳鼻舌身意空。故菩萨空。无有二亦无若干。地水火风诸为空。以是故菩萨为空。身中六事悉无所有本末悉空。亦无有二亦无若干。如是者。拘翼。菩萨摩诃萨住般若波罗蜜中复次拘翼。菩萨摩诃萨行般若波罗蜜者。解痴为空。色六入更乐痛爱受有生老病死亦复为空。十二因缘灭尽之故。故言曰空。十二因缘空故菩萨空。十二因缘空菩萨空。悉无有二亦无若干。如是拘翼。菩萨摩诃萨住般若波罗蜜中。复次拘翼。檀波罗蜜空故菩萨空。尸羼惟逮禅般若波罗蜜空。亦复如是。六波罗蜜空故菩萨空。是为菩萨摩诃萨住般若波罗蜜中。复次拘翼。内空外空近空远空真空所有空无所有空。故曰菩萨空。四意止四意断四神足五根五力七觉意八道行十力无畏十八不共诸佛之法。一切三昧陀罗尼门空。故菩萨空。六波罗蜜三十七品空。七空空诸佛法空。诸三昧空陀罗尼空。悉无有二亦无若干。是为拘翼菩萨摩诃萨住般若波罗蜜中。复次拘翼。须陀洹斯陀含阿那含阿罗汉辟支佛菩萨。怛萨阿竭阿罗诃三耶三菩空。故菩萨空。其四空声闻辟支佛空。怛萨阿竭空及菩萨空。悉无有二亦无若干是为拘翼菩萨摩诃萨住般若波罗蜜中。复次拘翼。萨芸若空。用萨芸若空故菩萨空。其萨芸若空及菩萨空。悉无有二亦无若干。是为拘翼菩萨摩诃萨住般若波罗蜜中。尔时释提桓因问尊者须菩提。云何菩萨摩诃萨于般若波罗蜜中住。须菩提谓释提桓因。菩萨摩诃萨行般若波罗蜜。不当住色中。不当住痛痒思想生死识中。不当住眼所更习中。耳鼻舌身意亦复如是。无所更悉无所住。地水火风种亦无所习亦无所住。不当住意止意断根力觉意八行。不当住萨芸若。不当住须陀洹斯陀含阿那含阿罗汉辟支佛及佛道。不当住色有常无常。不当住痛痒思想生死识有常无常。不当住色苦乐。不当住色净不净。不当住色我所非我所。不当住色空不空。不当住寂不寂。不当住恍忽不恍忽。不当住有须陀洹无须陀洹。不当住有斯陀含无斯陀含。不当住有阿那含无阿那含。不当住有阿罗汉无阿罗汉。不当住有辟支佛无辟支佛。不当住有佛无佛。不当住四道众祐。不当住辟支佛佛众祐。复次拘翼。菩萨摩诃萨行般若波罗蜜。不当住第一第二第三第四第五第六第七第八第九第十菩萨。从初发意至阿惟越致。亦无所住。菩萨不当住具足檀波罗蜜。尸羼惟逮禅般若波罗蜜。亦复如是。不当住三十七品十力无畏十八不共诸佛之法。菩萨摩诃萨不当作是念言。我入菩萨法不当作是住。我入阿惟越致地。菩萨摩诃萨不当住五旬。亦不当住菩萨五旬。以得五旬诸无央数阿僧祇诸佛国土。见诸佛天中天稽首作礼听所说法。如所受法为众会说。菩萨摩诃萨不当作是住。如彼佛天中天所现国土。我当如是化世界。菩萨摩诃萨不当作是住。我当开化一切众生。不当念言。我当住诸无数阿僧祇世界。见诸怛萨阿竭。供养华香捣香杂香缯盖幢幡。不当念言。我当开化无央数阿僧祇人。令起阿耨多罗三耶三菩提心。菩萨摩诃萨不当作是念言。我当成立具足五眼。何谓为五。肉眼天眼慧眼法眼佛眼。不当念言。我当兴立一切平等。乃能成就诸三昧门以此自娱。不当自念。得陀罗尼门如来十力四无所畏四分别辩四事不护十八不共诸佛之法。不当念言。我当具足大慈大悲。不当住于三十二相具足严身八十种好。不当住于八等笃信持法。不当住于须陀洹斯陀含阿那含阿罗汉辟支佛。不当住须陀洹七死七生而度。不当住缚只一种等首真人尽诸尘劳。不当住须陀洹中般泥洹。不当住斯陀含。何以故。往还于世尽苦灭度。不当住阿那含果证。何以故。阿那含成已便于天上般泥洹。不当住罗汉果证。何以故。阿罗汉道成已。便于是间无余泥洹界于中住。不当而般泥曰。是故不当住。辟支佛道过声闻地不能及佛道般泥洹。是故辟支佛道不当于中住。不当住道事。在于道慧而无所著。不当住于萨芸若慧。何以故。萨芸若慧了一切法成阿惟三佛。断诸挂碍尘劳之结。何以故。怛萨阿竭成阿惟三佛便转法轮。则作佛事度不可计阿僧祇人令般泥洹。是故佛不当于中住。住四神足以是色像三昧。三昧越而得存在恒沙劫。不当住无央数寿命。不当住三十二相。一一相百福功德而得成就。不当住恒沙诸佛世界。不当住东西南北四维上下及一佛土。不当住十方佛界为一土。不当住坐佛树下。而出香时如是色像令诸众生闻此香熏。不为淫怒痴所见缚。不发声闻辟支佛意。悉志阿耨多罗三耶三菩提心。其有众生闻此香已。其身口心悉无有病。于彼佛土亦无所住。则无色声无痛痒思想生死识声。不当住檀尸羼惟逮禅般若波罗蜜声。不当住四意断四神足五根五力七觉意八道行十力无畏十八不共声。不当住须陀洹斯陀含阿那含阿罗汉辟支佛般泥洹声。怛萨阿竭阿罗诃三耶三菩声。成阿惟三佛诸法声。如是拘翼。菩萨摩诃萨行般若波罗蜜。不当住此诸所著声。尔时贤者舍利弗心自念言。菩萨摩诃萨行般若波罗蜜云何。须菩提知舍利弗心所念。便谓舍利弗。于意云何。怛萨阿竭在何所住。舍利弗谓须菩提。怛萨阿竭无所住亦不无住。佛无心无色。不住于色不住痛痒思想生死识。不住有为界不住无为界。不住诸空三十七品十力无畏十八不共诸佛之法。不住萨芸若慧。须菩提谓舍利弗。如是如是。菩萨行般若波罗蜜当作是住。如怛萨阿竭阿罗诃三耶三佛住亦不有住。菩萨摩诃萨学般若波罗蜜。当作是住无所住。尔时会中诸天子等各心念言。诸悦叉辈所语所念。悉可了知音声所奏书者。须菩提所语言辞不可了知。须菩提知诸天子心中所念。谓诸天子言。不知乎。诸天子答曰。不知也。时须菩提为诸天子分别说言。无一文字而可说者。不可分别亦无闻者。所以者何。般若波罗蜜无文字说也。亦无听者。所以者何。怛萨阿竭无文字也。说喻如天子。怛萨阿竭化作化人。有彼化人化四部众比丘比丘尼优婆塞优婆夷。为化四部而说法。于诸天子意趣云何。岂有说者有解者乎。答曰无也。须菩提言。如是天子。一切诸法亦化彼无说者亦无听者。譬如梦中闻佛说经。于意云何。宁有说者听解者乎。答曰不也。须菩提言。天子。一切诸法悉亦如梦。无说无闻无有知者。譬如天子二人住地狱门叹佛法僧。二人之声俱而出现。于意云何。其二声报第二声。答曰不也。譬如幻师于四衢路化作如来。为四部众而说法。于意云何。宁有说法听解者乎。诸天子心中复作是念。须菩提所说般若波罗蜜。甚深甚深遂至微妙。须菩提知诸天子心中所念。谓天子言。色不甚深非微妙乎。痛痒思想生死识不甚深非微妙乎。色不自然深微妙乎。痛痒思想生死识。不自然深微妙乎。眼耳鼻舌身意亦复如是。檀尸羼惟逮般若波罗蜜慧。不自然深妙乎。内空外空近空远空真空所有空无所有空。十力无畏十八不共诸佛之法。一切三昧诸陀罗尼门萨芸若慧。不为自然微妙乎。时诸天子心自念言。其说法者。不决怒于色痛痒思想生死识乎。不决怒六波罗蜜七空三十七品十力无畏诸佛之法乎。不决怒须陀洹斯陀含阿那含阿罗汉辟支佛乎。不决怒佛慧无尽慧乎。须菩提知诸天子心中所念。谓诸天子言。如是诸天子。佛道无得。如来亦不说法。亦无听者无有解者。其有欲得须陀洹果证须陀洹果。斯陀含阿那含阿罗汉果证。不忍便出去。辟支佛道亦复如是。佛道亦复如是。不忍便出去。如是诸天子。初发意菩萨摩诃萨住般若波罗蜜。无有言说则亦无闻

    摩诃般若波罗蜜法师如幻品第二十六

尔时诸天子心中念言。尊者须菩提说法乃尔。当以何听。须菩提知诸天子心中所念。谓天子言。法师如幻听者如化。此等所闻亦不作证。诸天子心中复作是念。云何须菩提人如幻法师如幻。人如化听者如化。须菩提言。如是如是。诸天子。人如幻法师如幻。人如化法师如化。吾我如梦色亦如是。痛痒思想生死识亦复如梦。眼色如梦。耳鼻舌身意亦复如是。所习诸更亦复如梦。内空外空近空远空真空所有空无所有空悉亦如梦。三十七品十种力四无所畏四分别辩十八不共诸佛之法。亦复如梦如幻如化。须陀洹斯陀含阿那含阿罗汉果亦如幻梦。辟支佛上至三耶三佛亦复如幻梦。诸天子谓须菩提。乃至佛道亦复如幻梦乎。须菩提言。乃至泥洹亦复如幻梦。诸天子问须菩提。乃至泥洹。泥洹亦如梦。须菩提言。其泥洹本末法最为尊。而无所有。我亦谓之如幻如梦。所以者何。幻梦及泥洹。则无有二亦无若干。空无所有。于是贤者舍利弗。摩诃目犍连。摩诃拘絺罗。摩诃迦旃延。邠耨文陀弗。摩诃迦叶。及无央数众千菩萨。问尊者须菩提。是般若波罗蜜甚深难晓难了寂然微妙。何所深妙难及之人能受者乎。须菩提谓诸弟子及诸菩萨。阿惟越致菩萨摩诃萨。乃能受是深奥无念无思议行出于玄远。难及难了寂然巍巍。止于贤圣知明识慧。乃能受此般若波罗蜜。见谛之人为阿罗汉。志愿具足于过去佛已造之行。供养无数百千诸佛。殖众德本为善知识所见将护。善男子善女人乃能受是深般若波罗蜜。听受此教解知色空不想。色空不想。痛痒思想生死识空不想。神识空不想。着色亦不想。若念于无色。不念着五阴无相。不念神识无相。不念识无愿。不念色无愿。痛痒思想生死识。亦复如是。不念五阴无想。不念五阴无无想。不念色无所生。不念色无所灭。不念寂然恍惚。痛痒思想生死识亦复如是。不念眼耳鼻舌身意无所生无所灭。寂然恍惚不念所更所习众缘。檀尸羼惟逮禅般若波罗蜜。不念所生亦无所灭寂然恍惚。乃至七空三十七品十力无畏十八不共诸佛之法。一切三昧陀罗尼门亦复如是。不念所生亦无所灭。须陀洹斯陀含阿那含阿罗汉果及辟支佛萨芸若慧。悉了知空。萨芸若慧不想念空。萨芸若慧亦无所愿。其无所愿亦不想念萨芸若慧。其所有者不想于空。其空亦不想于有。无愿无想亦复如是。其无为界不想于空。其空亦不想于无为界。无想无愿亦复如是。无无所生亦无不灭。亦无寂然无恍惚悉无想念。须菩提谓诸天子。是般若波罗蜜甚深微妙。非贤圣明智所见受者。所以者何。法无所受亦无所闻亦无显说。设无所闻无说法者。由是之故则无有人而无所受。舍利弗谓尊者须菩提。此般若波罗蜜。不为广说罗汉辟支佛三耶三佛乘事乎。将护菩萨摩诃萨行从新发意至到十住菩萨之道。六波罗蜜三十七品十力无畏诸佛之法。菩萨摩诃萨行般若波罗蜜。所生神通无所忘失顺法。如是从一佛刹到一佛刹。德本所致欲得供养诸佛世尊。如其所志悉而得之。供事已竟则从诸佛听受经法未曾忘失。自到逮成萨芸若慧。常三昧定心未曾乱。未常思念辩无挂碍。有所说道无能中断。辩才如应义趣尊妙。越于一切世间之明。舍利弗谓须菩提。如是如是。如仁所言。般若波罗蜜解说三乘。则为菩萨摩诃萨辩才之智过于世间。尊无能及心无所著。自晓了身无有颠倒。亦不猗着所见所见于色痛痒思想生死识。亦不猗着于六波罗蜜。不着七空三十七品十力无畏诸佛之法。亦不依猗萨芸若慧。舍利弗谓须菩提。般若波罗蜜以何等故广说三乘。则为菩萨摩诃萨获菩萨之辩。越一切世而无所著乎。须菩提报舍利弗。以内外空故。广说三乘七空亦尔。悉无所有故说三乘。菩萨摩诃萨悉了诸空。故讲说此护于行者。以是之故越一切世。辩才最尊而无所著

    摩诃般若波罗蜜雨法宝品第二十七

尔时释提桓因心自念言。尊者须菩提今所说者。为雨法宝三千大千世界诸四天王上至阿迦腻吒天。今须菩提所说法为雨法宝。我宁可化作华雨佛菩萨及诸圣众及须菩提上。释提桓因及三千大千世界诸天之众。各化作华散于世尊诸菩萨摩诃萨比丘圣众须菩提上供养。自归般若波罗蜜。适散此已其华遍布二千佛土。在上虚空化为重阁。巍巍甚高。快不可言。尊者须菩提心自念言。昔吾曾游遍诸天宫。初未睹见如此辈华。向所散华。此为化华不从树生也。向诸天子所散华者。从心树生不从树生。释提桓因报须菩提。此华无所从出生。不从心树出。须菩提言。如拘翼言。此华无所从出生。不从心树生。设使拘翼无所从生则为非华。释提桓因报须菩提。华实为无所从出。为色无所从出。痛痒思想生死识无所从出。须菩提言。拘翼。此华不为无所从出。色无所生。无所生者则无有色。痛痒思想生死识无所从出。其无所生则无有识。眼无所生。其无所生则无有眼。耳鼻舌身意亦复如是。檀波罗蜜亦无所生。其无所生则为无檀。尸羼惟逮禅般若波罗蜜亦无所生。其无所生则为无般若波罗蜜及与七空三十七品。拘翼。无所从生。其无所生则无七空三十七品。十力无畏诸佛之法。无所从生。其无所生则无诸法。须陀洹斯陀含阿那含阿罗汉辟支佛佛萨芸若慧亦无所生。其无所生则无萨芸若。释提桓因心自念言。尊者须菩提所入慧甚深。所可说法悉无所争亦不错乱。时佛告释提桓因。如是拘翼。须菩提所入慧甚深。所可入慧所说经法。悉无所争亦不错乱。释提桓因白佛言。尊者须菩提。云何深入慧所可入慧所说经法。悉无所争亦不错乱。佛告释提桓因。所入于色以入此法所可说法。悉无所争亦不错乱。痛痒思想生死识亦复如是所以者何。如法者无和无争。须菩提所说亦复如是不同不乱。六波罗蜜亦复如是。及与七空三十七品十力无畏诸佛之法不同不乱。须陀洹斯陀含阿那含阿罗汉辟支佛佛萨芸若慧。亦复如是不同不乱。所以者何。须菩提所说法不和不争。其无和争则无所争。如是拘翼。须菩提所入慧。所说微妙巍巍如此。须菩提谓释提桓因。如世尊言。说一切法菩萨摩诃萨。晓了如是解一切法。学般若波罗蜜亦当如是。菩萨摩诃萨学如是者。为不学色痛痒思想生死识。所以者何。不见色故。不见痛痒思想生死识有所学故。菩萨摩诃萨如是学者。不学檀尸羼惟逮禅般若波罗蜜。所以者何。不见学般若波罗蜜故。不学七空三十七品。所以者何。不见七空三十七品故。不学十力四无所畏十八不共诸佛之法。不学须陀洹斯陀含阿那含阿罗汉辟支佛佛萨芸若慧。所以者何。不见学萨芸若慧故。释提桓因谓尊者须菩提。唯须菩提。何以故。不见色痛痒思想生死识。七空三十七品声闻辟支佛佛萨芸若慧。须菩提言。用色空故。痛痒思想生死识空故。上至萨芸若亦复空故。拘翼。以色空故不学空色。痛痒思想生死识空故。以识空故不学空识。上至萨芸若慧亦复空故不学空慧。拘翼。是为以空。其以空者不学于空故。设学空者。不为一法则为二法。若学色空则不为一。上至萨芸若慧。若学慧者则不为一。是故拘翼。用色痛痒思想生死识空故。则无有二。上至萨芸若慧悉皆空故无有二也。六波罗蜜亦复如是悉无有二。七空三十七品十力无畏诸佛之法。声闻辟支佛。上至三耶三佛亦无有二。萨芸若慧亦无有二。其能学佛萨芸若慧。则为悉学不可计数阿僧祇法。其已能学不可称数阿僧祇佛法。则不学色有益有损。痛痒思想生死识亦复如是。上至萨芸若慧不增不减。学五阴不增不减已。则便能学萨芸若慧。已能学于萨芸若慧不增不减已。不学受色亦无所失。不学受痛痒思想生死识。亦无所失。不学受声闻辟支佛。上至萨芸若慧亦无所失。舍利弗谓须菩提。菩萨摩诃萨学如是者。为不学受亦无所失。须菩提言。如是舍利弗。菩萨摩诃萨如是学者为不学受。色痛痒思想生死识亦无所失不学受。萨芸若亦无所失。舍利弗谓须菩提。何故菩萨摩诃萨不受五阴亦无所失。不受学萨芸若亦无所失。须菩提言。色无所有不可受持无受色者。痛痒思想生死识萨芸若慧。悉无所有不可受持。无受萨芸若者。是为舍利弗菩萨摩诃萨于一切法悉无所受成萨芸若。舍利弗谓须菩提。菩萨摩诃萨作是学者。为学般若波罗蜜出生萨芸若乎。须菩提言。如是舍利弗。菩萨摩诃萨学如是者。为学般若波罗蜜出生萨芸若。于一切法无所受故。舍利弗谓须菩提。菩萨摩诃萨学如是者。于一切法无所受学亦无所失。菩萨摩诃萨学如是为出萨芸若。须菩提言。菩萨摩诃萨行般若波罗蜜。不见色有所生亦无所灭。不受不舍无持无争不增不减所以者何。舍利弗。色自然故则无有色痛痒思想生死识。不见所生亦无所灭。不受不舍无尘无恨。无放无不放无增无减。所以者何。萨芸若慧则为自然悉无所有。是故舍利弗。菩萨摩诃萨于一切法而无所生亦无所灭。无受无舍无尘无恨。无放无不放无增无减。学般若波罗蜜已出生萨芸若。则以无学无所生故。释提桓因谓舍利弗。菩萨摩诃萨当于何所求般若波罗蜜。舍利弗言。拘翼。当从尊者须菩提求。释提桓因问须菩提。仁威神仁所建立。使舍利弗作是说言。须菩提说般若波罗蜜。当从求之。须菩提谓释提桓因。非我威神之所建立也。又问。谁威神恩之所建立。答曰。拘翼。怛萨阿竭威神之恩之所建立。释提桓因谓须菩提。一切诸法悉无所立。云何如是怛萨阿竭威神之所建立。亦无异处之所建立。计于诸法不得如来。亦无异处可得如来。尊者须菩提谓释提桓因。如是拘翼。怛萨阿竭则无所住亦无异处。所当可住无异如来。当有所得亦不离住。怛萨阿竭亦无所住。于一切法不离所住。不以于色怛萨阿竭为如来也。不以无本为怛萨阿竭。不以色无本为怛萨阿竭。不以怛萨阿竭无本色。为无本色法为怛萨阿竭。不以怛萨阿竭为无本。法无本故诸色无本。痛痒思想生死识无本故。怛萨阿竭无本。不用怛萨阿竭无本痛痒思想生死识不以识。无本怛萨阿竭法也。不以怛萨阿竭法为识法也。声闻辟支佛上至萨芸若。无本怛萨阿竭也不以怛萨阿竭无本。萨芸若无本。不以萨芸若法为怛萨阿竭法也。不以怛萨阿竭法为萨芸若法。又拘翼。怛萨阿竭于诸色法无合无散。于痛痒思想生死识法无合无散。不于异五阴有合有散。不于怛萨阿竭有合有散。不于萨芸若法有合有散。于萨芸若怛萨阿竭无合无散。不于萨芸若法有合有散。不于异萨芸若怛萨阿竭有合有散。又拘翼。于此诸法不合不散。以此威神之所建立。而有所住。向者拘翼而复问言。菩萨摩诃萨当于何所求般若波罗蜜。不求于色不求异色。不求痛痒思想生死识不求异识。般若波罗蜜于色痛痒思想生死识一切诸法。无合无散无色无见不可受持。则为一相无所有相。复次拘翼。菩萨摩诃萨为行般若波罗蜜。上至萨芸若悉无所求。不于异处求萨芸若。所以者何。求般若波罗蜜萨芸若。于一切法无合无散无色无见不可受持。则为一相无所有相。所以者何。拘翼。般若波罗蜜则无有色亦无异色。无有痛痒思想生死识亦无异识。识不为异般若波罗蜜。亦无有异萨芸若。非般若波罗蜜无异萨芸若。般若波罗蜜怛萨阿竭般若波罗蜜。无色亦无异色。亦无异痛痒思想生死识。般若波罗蜜亦无异识。萨芸若非般若波罗蜜。般若波罗蜜无异萨芸若。怛萨阿竭般若波罗蜜无有色亦无异色。痛痒思想生死识亦复如是。为无异识亦无无本。般若波罗蜜无色法亦无异色法。痛痒思想生死识亦复如是。般若波罗蜜无色无本。亦无异色无本。般若波罗蜜无有色法亦无异色法。痛痒思想生死识亦复如是。声闻辟支佛上至萨芸若亦复如是。无萨芸若色法。亦无异萨芸若色法。般若波罗蜜无萨芸若无本亦无异萨芸若无本。般若波罗蜜无萨芸若无本。亦无异萨芸若无本。释提桓因谓须菩提。是为诸菩萨摩诃萨摩诃般若波罗蜜无异波罗蜜无限。菩萨摩诃萨所可学者。须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。应是而学。菩萨摩诃萨学此法。以开化众生严净佛土。得阿耨多罗三耶三菩提。须菩提谓释提桓因。如是拘翼。是为诸菩萨摩诃萨摩诃般若波罗蜜无异波罗蜜无限波罗蜜。应如是学。以其三乘者皆由是生。菩萨摩诃萨自致阿耨多罗三耶三菩。成至阿惟三佛。色无有边。是为诸菩萨摩诃萨波罗蜜无有极。所以者何。不可得过去色。亦不可得中间色。亦不可得当来色。痛痒思想生死识亦复如是。识无有边。波罗蜜无有极。所以者何。不可得过去识。亦无中间识。亦无当来识。声闻辟支佛上至佛无极无边。亦复如是。是故拘翼。是诸菩萨摩诃萨无极波罗蜜。色无有量。般若波罗蜜亦无有量。所以者何。色不可得限故。譬如拘翼虚空不可得边限。色无有量亦复如是。虚空无限故色无有限。色无有限故般若波罗蜜无有限。上至萨芸若亦无有限故。般若波罗蜜无有限。是为诸菩萨摩诃萨行。所以者何。拘翼。萨芸若慧不可得边限故。譬如虚空不可得边。萨芸若慧亦复如是。虚空无限故萨芸若亦无有限。萨芸若无限故般若波罗蜜无限。是故拘翼。般若波罗蜜无限。是为诸菩萨摩诃萨虚空无边。色无有底波罗蜜无有底。所以者何。拘翼。色无边际亦无中间。痛痒思想生死识。亦无边际亦无有中间。是故诸菩萨摩诃萨波罗蜜。无有边际无有端底。所以者何。神识不可得底无有中间。上至萨芸若亦无有底。波罗蜜亦无有底。是为诸菩萨摩诃萨行。所以者何。拘翼。萨芸若者。不可得边亦无中间。波罗蜜无底。是为菩萨摩诃萨色无有底故萨芸若亦无有底。复次拘翼。事无端底波罗蜜无底。能了是者则为菩萨摩诃萨。释提桓因问须菩提。用何等故。事无端底波罗蜜无底。须菩提言。拘翼。萨芸若事无端底故。诸菩萨摩诃萨波罗蜜无底。复次拘翼。法无端底。是故诸菩萨摩诃萨波罗蜜无底。释提桓因谓须菩提。用何等故。法无端底。菩萨摩诃萨波罗蜜无底。须菩提言。法界无底故。诸菩萨摩诃萨波罗蜜无底。复次拘翼。无本之事悉无端底故。菩萨摩诃萨波罗蜜无底。释提桓因问须菩提。用何等故。无本之事悉无端底。诸菩萨摩诃萨波罗蜜无底。拘翼。无本无底是故无底。事以无端。无本无底无本无底。以事则无底。事无底。以故诸菩萨摩诃萨波罗蜜无底。复次人无有底故。诸菩萨摩诃萨波罗蜜无底。释提桓因问须菩提。用何等故。人无有底。诸菩萨摩诃萨波罗蜜无底。须菩提言。于拘翼意云何。何所法中作是教者。谓菩萨摩诃萨耶。释提桓因报须菩提言。此无法教亦无非法教。此名字者。从缘客来。悉无所有无本形像。但似假名。所谓言人。人无因缘横为立字。于拘翼意所见云何。是般若波罗蜜。宁为显扬说人处乎。答曰不也。须菩提言。拘翼。设不说人。岂无底乎。云何拘翼。怛萨阿竭阿罗诃三耶三佛。寿如恒沙劫。口说人人。彼宁有人而有所生有所灭乎。答曰不也。须菩提。所以者何。人本清净。是故拘翼。人无有底。般若波罗蜜无底。菩萨学当作是知。行般若波罗蜜法如是

光赞经卷第十


金刚般若波罗蜜经

    No. 235 [Nos. 220(9), 236-239]

    金刚般若波罗蜜经

        姚秦天竺三藏鸠摩罗什译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊食时著衣持钵入舍卫大城乞食。于其城中次第乞已。还至本处饭食讫。收衣钵洗足已敷座而坐。时长老须菩提在大众中。即从座起偏袒右肩右膝著地。合掌恭敬而白佛言。希有世尊。如来善护念诸菩萨。善付嘱诸菩萨。世尊。善男子善女人。发阿耨多罗三藐三菩提心。应云何住云何降伏其心。佛言。善哉善哉。须菩提。如汝所说。如来善护念诸菩萨。善付嘱诸菩萨。汝今谛听。当为汝说。善男子善女人。发阿耨多罗三藐三菩提心。应如是住如是降伏其心。唯然世尊。愿乐欲闻

佛告须菩提。诸菩萨摩诃萨应如是降伏其心。所有一切众生之类。若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若非有想非无想。我皆令入无余涅槃而灭度之。如是灭度无量无数无边众生。实无众生得灭度者。何以故。须菩提。若菩萨有我相人相众生相寿者相。即非菩萨

复次须菩提。菩萨于法应无所住行于布施。所谓不住色布施。不住声香味触法布施。须菩提。菩萨应如是布施不住于相。何以故。若菩萨不住相布施。其福德不可思量。须菩提。于意云何。东方虚空可思量不。不也世尊。须菩提。南西北方四维上下虚空可思量不。不也世尊。须菩提。菩萨无住相布施福德。亦复如是不可思量。须菩提。菩萨但应如所教住

须菩提。于意云何。可以身相见如来不。不也世尊。不可以身相得见如来。何以故。如来所说身相即非身相。佛告须菩提。凡所有相皆是虚妄。若见诸相非相则见如来

须菩提白佛言。世尊。颇有众生得闻如是言说章句生实信不。佛告须菩提。莫作是说。如来灭后后五百岁。有持戒修福者。于此章句能生信心以此为实。当知是人不于一佛二佛三四五佛而种善根。已于无量千万佛所种诸善根。闻是章句乃至一念生净信者。须菩提。如来悉知悉见是诸众生得如是无量福德。何以故。是诸众生无复我相人相众生相寿者相。无法相亦无非法相。何以故。是诸众生。若心取相则为著我人众生寿者。若取法相即著我人众生寿者。何以故。若取非法相。即著我人众生寿者。是故不应取法。不应取非法。以是义故。如来常说汝等比丘。知我说法如筏喻者。法尚应舍何况非法

须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛所说义。无有定法名阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法皆不可取不可说。非法非非法。所以者何。一切贤圣皆以无为法而有差别。须菩提。于意云何。若人满三千大千世界。七宝以用布施。是人所得福德宁为多不。须菩提言。甚多世尊。何以故。是福德即非福德性。是故如来说福德多。若复有人于此经中。受持乃至四句偈等为他人说。其福胜彼。何以故。须菩提。一切诸佛及诸佛阿耨多罗三藐三菩提法皆从此经出。须菩提。所谓佛法者即非佛法

须菩提。于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。须陀洹名为入流而无所入。不入色声香味触法。是名须陀洹。须菩提。于意云何。斯陀含能作是念。我得斯陀含果不。须菩提言。不也世尊。何以故。斯陀含名一往来。而实无往来。是名斯陀含。须菩提。于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。阿那含名为不来而实无不来。是故名阿那含。须菩提。于意云何。阿罗汉能作是念。我得阿罗汉道不。须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉道。即为著我人众生寿者。世尊。佛说我得无诤三昧人中最为第一。是第一离欲阿罗汉。我不作是念。我是离欲阿罗汉。世尊。我若作是念我得阿罗汉道。世尊则不说须菩提是乐阿兰那行者。以须菩提实无所行。而名须菩提是乐阿兰那行

佛告须菩提。于意云何。如来昔在然灯佛所。于法有所得不。世尊。如来在然灯佛所。于法实无所得。须菩提。于意云何。菩萨庄严佛土不。不也世尊。何以故。庄严佛土者则非庄严。是名庄严。是故须菩提。诸菩萨摩诃萨应如是生清净心。不应住色生心。不应住声香味触法生心。应无所住而生其心。须菩提。譬如有人身如须弥山王。于意云何。是身为大不。须菩提言。甚大世尊。何以故。佛说非身是名大身。须菩提。如恒河中所有沙数。如是沙等恒河。于意云何。是诸恒河沙宁为多不。须菩提言。甚多世尊。但诸恒河尚多无数。何况其沙。须菩提。我今实言告汝。若有善男子善女人。以七宝满尔所恒河沙数三千大千世界。以用布施得福多不。须菩提言。甚多世尊。佛告须菩提。若善男子善女人。于此经中乃至受持四句偈等。为他人说。而此福德胜前福德

复次须菩提。随说是经乃至四句偈等。当知此处一切世间天人阿修罗。皆应供养如佛塔庙。何况有人尽能受持读诵。须菩提。当知是人成就最上第一希有之法。若是经典所在之处。则为有佛若尊重弟子

尔时须菩提白佛言。世尊。当何名此经。我等云何奉持。佛告须菩提。是经名为金刚般若波罗蜜。以是名字汝当奉持。所以者何。须菩提。佛说般若波罗蜜。则非般若波罗蜜。须菩提。于意云何。如来有所说法不。须菩提白佛言。世尊。如来无所说。须菩提。于意云何。三千大千世界所有微尘是为多不须菩提言。甚多世尊。须菩提。诸微尘如来说非微尘。是名微尘。如来说世界非世界。是名世界。须菩提。于意云何。可以三十二相见如来不。不也世尊。不可以三十二相得见如来。何以故。如来说三十二相即是非相。是名三十二相。须菩提。若有善男子善女人。以恒河沙等身命布施。若复有人于此经中乃至受持四句偈等。为他人说其福甚多

尔时须菩提闻说是经深解义趣。涕泪悲泣而白佛言。希有世尊。佛说如是甚深经典。我从昔来所得慧眼。未曾得闻如是之经。世尊。若复有人得闻是经。信心清净则生实相。当知是人成就第一希有功德。世尊。是实相者则是非相。是故如来说名实相。世尊。我今得闻如是经典。信解受持不足为难。若当来世后五百岁。其有众生得闻是经信解受持。是人则为第一希有。何以故。此人无我相人相众生相寿者相。所以者何。我相即是非相。人相众生相寿者相即是非相。何以故。离一切诸相则名诸佛。佛告须菩提。如是如是若复有人得闻是经。不惊不怖不畏。当知是人甚为希有。何以故。须菩提。如来说第一波罗蜜非第一波罗蜜。是名第一波罗蜜。须菩提。忍辱波罗蜜如来说非忍辱波罗蜜。何以故。须菩提。如我昔为歌利王割截身体。我于尔时无我相无人相无众生相无寿者相。何以故。我于往昔节节支解时。若有我相人相众生相寿者相应生嗔恨。须菩提。又念过去于五百世作忍辱仙人。于尔所世无我相无人相无众生相无寿者相。是故须菩提。菩萨应离一切相发阿耨多罗三藐三菩提心。不应住色生心。不应住声香味触法生心。应生无所住心。若心有住则为非住。是故佛说菩萨心不应住色布施。须菩提。菩萨为利益一切众生。应如是布施。如来说一切诸相即是非相。又说一切众生则非众生。须菩提。如来是真语者。实语者。如语者。不诳语者。不异语者。须菩提。如来所得法此法无实无虚。须菩提。若菩萨心住于法而行布施。如人入闇则无所见。若菩萨心不住法而行布施。如人有目日光明照见种种色。须菩提。当来之世若有善男子善女人。能于此经受持读诵。则为如来以佛智慧悉知是人。悉见是人。皆得成就无量无边功德

须菩提。若有善男子善女人。初日分以恒河沙等身布施。中日分复以恒河沙等身布施。后日分亦以恒河沙等身布施。如是无量百千万亿劫以身布施。若复有人闻此经典信心不逆其福胜彼。何况书写受持读诵为人解说。须菩提。以要言之。是经有不可思议不可称量无边功德。如来为发大乘者说。为发最上乘者说。若有人能受持读诵广为人说。如来悉知是人悉见是人。皆得成就不可量不可称无有边不可思议功德。如是人等则为荷担如来阿耨多罗三藐三菩提。何以故。须菩提。若乐小法者。著我见人见众生见寿者见。则于此经不能听受读诵为人解说。须菩提。在在处处若有此经。一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼围绕以诸华香而散其处

复次须菩提。善男子善女人受持读诵此经。若为人轻贱。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提。须菩提。我念过去无量阿僧祇劫。于然灯佛前。得值八百四千万亿那由他诸佛。悉皆供养承事无空过者。若复有人于后末世。能受持读诵此经所得功德。于我所供养诸佛功德。百分不及一。千万亿分乃至算数譬喻所不能及。须菩提。若善男子善女人于后末世。有受持读诵此经。所得功德我若具说者。或有人闻心则狂乱狐疑不信。须菩提。当知是经义不可思议果报亦不可思议

尔时须菩提白佛言。世尊。善男子善女人。发阿耨多罗三藐三菩提心。云何应住云何降伏其心佛告须菩提。善男子善女人发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生。灭度一切众生已而无有一众生实灭度者。何以故。须菩提。若菩萨有我相人相众生相寿者相则非菩萨。所以者何。须菩提。实无有法发阿耨多罗三藐三菩提心者。须菩提。于意云何。如来于然灯佛所有法得阿耨多罗三藐三菩提不。不也世尊。如我解佛所说义。佛于然灯佛所无有法得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。实无有法如来得阿耨多罗三藐三菩提。须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我受记。汝于来世当得作佛。号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故然灯佛与我受记作是言。汝于来世当得作佛号释迦牟尼。何以故。如来者即诸法如义。若有人言如来得阿耨多罗三藐三菩提。须菩提。实无有法佛得阿耨多罗三藐三菩提。须菩提。如来所得阿耨多罗三藐三菩提。于是中无实无虚。是故如来说一切法皆是佛法。须菩提。所言一切法者。即非一切法。是故名一切法。须菩提。譬如人身长大。须菩提言。世尊。如来说人身长大则为非大身。是名大身。须菩提。菩萨亦如是。若作是言。我当灭度无量众生则不名菩萨。何以故。须菩提。实无有法名为菩萨。是故佛说一切法无我无人无众生无寿者。须菩提。若菩萨作是言。我当庄严佛土。是不名菩萨。何以故。如来说庄严佛土者。即非庄严是名庄严。须菩提。若菩萨通达无我法者。如来说名真是菩萨

须菩提。于意云何。如来有肉眼不。如是世尊。如来有肉眼。须菩提。于意云何。如来有天眼不。如是世尊。如来有天眼。须菩提。于意云何。如来有慧眼不。如是世尊。如来有慧眼。须菩提。于意云何。如来有法眼不。如是世尊。如来有法眼。须菩提。于意云何。如来有佛眼不。如是世尊。如来有佛眼。须菩提。于意云何。恒河中所有沙佛说是沙不。如是世尊。如来说是沙。须菩提。于意云何。如一恒河中所有沙有如是等恒河。是诸恒河所有沙数佛世界。如是宁为多不。甚多世尊。佛告须菩提。尔所国土中所有众生若干种心如来悉知。何以故。如来说诸心皆为非心是名为心。所以者何。须菩提。过去心不可得。现在心不可得。未来心不可得

须菩提。于意云何。若有人满三千大千世界七宝以用布施。是人以是因缘得福多不。如是世尊。此人以是因缘得福甚多。须菩提。若福德有实。如来不说得福德多。以福德无故。如来说得福德多。

须菩提。于意云何。佛可以具足色身见不。不也世尊。如来不应以具足色身见。何以故。如来说具足色身。即非具足色身。是名具足色身。须菩提。于意云何。如来可以具足诸相见不。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足即非具足。是名诸相具足。须菩提。汝勿谓如来作是念。我当有所说法。莫作是念。何以故。若人言如来有所说法即为谤佛。不能解我所说故。须菩提。说法者无法可说。是名说法

尔时慧命须菩提白佛言。世尊。颇有众生于未来世。闻说是法生信心不。佛言。须菩提。彼非众生非不众生。何以故。须菩提。众生众生者。如来说非众生。是名众生

须菩提白佛言。世尊。佛得阿耨多罗三藐三菩提。为无所得耶。如是如是。须菩提。我于阿耨多罗三藐三菩提。乃至无有少法可得是名阿耨多罗三藐三菩提。

复次须菩提。是法平等无有高下。是名阿耨多罗三藐三菩提。以无我无人无众生无寿者。修一切善法则得阿耨多罗三藐三菩提。须菩提。所言善法者。如来说非善法是名善法

须菩提。若三千大千世界中所有诸须弥山王。如是等七宝聚有人持用布施。若人以此般若波罗蜜经乃至四句偈等。受持读诵为他人说。于前福德百分不及一。百千万亿分乃至算数譬喻所不能及

须菩提。于意云何。汝等勿谓如来作是念。我当度众生。须菩提。莫作是念。何以故。实无有众生如来度者。若有众生如来度者。如来则有我人众生寿者须菩提。如来说有我者则非有我。而凡夫之人以为有我。须菩提。凡夫者如来说则非凡夫

须菩提。于意云何。可以三十二相观如来不。须菩提言。如是如是。以三十二相观如来。佛言。须菩提。若以三十二相观如来者。转轮圣王则是如来。须菩提白佛言。世尊。如我解佛所说义。不应以三十二相观如来。尔时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来

须菩提。汝若作是念。如来不以具足相故。得阿耨多罗三藐三菩提。须菩提。莫作是念。如来不以具足相故。得阿耨多罗三藐三菩提。须菩提。若作是念。发阿耨多罗三藐三菩提心者说诸法断灭相。莫作是念。何以故。发阿耨多罗三藐三菩提心者。于法不说断灭相。须菩提。若菩萨以满恒河沙等世界七宝布施。若复有人知一切法无我得成于忍。此菩萨胜前菩萨所得功德。须菩提。以诸菩萨不受福德故。须菩提白佛言。世尊。云何菩萨不受福德。须菩提。菩萨所作福德不应贪著。是故说不受福德

须菩提。若有人言如来若来若去若坐若卧。是人不解我所说义。何以故。如来者无所从来亦无所去故名如来

须菩提。若善男子善女人。以三千大千世界碎为微尘。于意云何。是微尘众宁为多不。甚多世尊。何以故。若是微尘众实有者。佛则不说是微尘众。所以者何。佛说微尘众则非微尘众。是名微尘众。世尊。如来所说三千大千世界则非世界。是名世界。何以故。若世界实有者则是一合相。如来说一合相则非一合相。是名一合相。须菩提。一合相者则是不可说。但凡夫之人贪著其事

须菩提。若人言佛说我见人见众生见寿者见。须菩提。于意云何。是人解我所说义不。世尊。是人不解如来所说义。何以故。世尊说我见人见众生见寿者见即非我见人见众生见寿者见。是名我见人见众生见寿者见。须菩提。发阿耨多罗三藐三菩提心者。于一切法。应如是知如是见如是信解不生法相。须菩提。所言法相者。如来说即非法相。是名法相。须菩提。若有人以满无量阿僧祇世界七宝持用布施。若有善男子善女人发菩萨心者。持于此经乃至四句偈等。受持读诵为人演说其福胜彼。云何为人演说。不取于相如如不动。何以故

  一切有为法　　如梦幻泡影
  如露亦如电　　应作如是观

佛说是经已。长老须菩提及诸比丘比丘尼优婆塞优婆夷。一切世间天人阿修罗。闻佛所说皆大欢喜。信受奉行金刚般若波罗蜜经

    真言

那谟婆伽跋帝　钵喇坏　波罗弭多曳　唵伊利底　伊室利　输卢驮　毗舍耶　毗舍耶　莎婆诃


金刚般若波罗蜜经a

    No. 236 [Nos. 220(9), 235, 237-239]

    金刚般若波罗蜜经

        元魏天竺三藏菩提流支译

如是我闻。一时婆伽婆。在舍婆提城祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊食时着衣持钵。入舍婆提大城乞食。于其城中次第乞食已。还至本处饭食讫。收衣钵洗足已。如常敷座结加趺坐。端身而住正念不动

尔时诸比丘来诣佛所。到已顶礼佛足。右绕三匝退坐一面。尔时慧命须菩提。在大众中即从座起。偏袒右肩右膝着地。向佛合掌恭敬而立。白佛言。希有世尊。如来应供正遍知。善护念诸菩萨善付嘱诸菩萨世尊云何。菩萨大乘中发阿耨多罗三藐三菩提心。应云何住。云何修行。云何降伏其心

尔时佛告须菩提。善哉善哉。须菩提。如汝所说。如来善护念诸菩萨。善付嘱诸菩萨。汝今谛听。当为汝说。如菩萨大乘中发阿耨多罗三藐三菩提心。应如是住如是修行如是降伏其心。须菩提白佛言。世尊。如是愿乐欲闻。佛告须菩提。诸菩萨生如是心。所有一切众生众生所摄。若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若非有想非无想。所有众生界众生所摄。我皆令入无余涅槃而灭度之。如是灭度无量无边众生。实无众生得灭度者。何以故。须菩提。若菩萨有众生相即非菩萨。何以故。非须菩提。若菩萨起众生相人相寿者相。则不名菩萨

复次须菩提。菩萨不住于事行于布施。无所住行于布施。不住色布施。不住声香味触法布施。须菩提。菩萨应如是布施不住于相想。何以故。若菩萨不住相布施。其福德聚不可思量。须菩提。于汝意云何。东方虚空可思量不。须菩提言。不也世尊。佛言。如是须菩提。南西北方四维上下虚空可思量不。须菩提言。不也世尊。佛言。如是如是。须菩提。菩萨无住相布施福德聚。亦复如是不可思量。佛复告须菩提。菩萨但应如是行于布施须菩提。于意云何可以相成就见如来不。须菩提言。不也世尊。不可以相成就得见如来。何以故。如来所说相即非相。佛告须菩提。凡所有相皆是妄语。若见诸相非相则非妄语。如是诸相非相则见如来。须菩提白佛言。世尊。颇有众生于未来世末世。得闻如是修多罗章句。生实相不。佛告须菩提。莫作是说。颇有众生于未来世末世。得闻如是修多罗章句。生实相不佛复告须菩提。有未来世末世。有菩萨摩诃萨。法欲灭时有持戒修福德智慧者。于此修多罗章句。能生信心以此为实。佛复告须菩提。当知彼菩萨摩诃萨。非于一佛二佛三四五佛所修行供养。非于一佛二佛三四五佛所而种善根。佛复告须菩提。已于无量百千万诸佛所修行供养。无量百千万诸佛所种诸善根。闻是修多罗。乃至一念能生净信。须菩提。如来悉知是诸众生。如来悉见是诸众生。须菩提。是诸菩萨生如是无量福德聚。取如是无量福德。何以故。须菩提是诸菩萨无复我相众生相人相寿者相。须菩提。是诸菩萨无法相亦非无法相。无相亦非无相。何以故。须菩提。是诸菩萨若取法相则为着我人众生寿者。须菩提。若是菩萨有法相。即着我相人相众生相寿者相。何以故。须菩提。不应取法非不取法。以是义故。如来常说筏喻法门。是法应舍非舍法故

复次佛告慧命须菩提。须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛所说义。无有定法如来得阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法。皆不可取不可说。非法非非法。何以故一切圣人皆以无为法得名须菩提于意云何若满三千大千世界七宝以用布施。须菩提。于意云何。是善男子善女人所得福德宁为多不须菩提言。甚多婆伽婆。甚多修伽陀。彼善男子善女人得福甚多。何以故。世尊。是福德聚即非福德聚。是故如来说福德聚福德聚。佛言须菩提。若善男子善女人。以满三千大千世界七宝持用布施。若复于此经中受持乃至四句偈等为他人说。其福胜彼无量不可数。何以故。须菩提。一切诸佛阿耨多罗三藐三菩提法。皆从此经出。一切诸佛如来皆从此经生。须菩提。所谓佛法。佛法者即非佛法

须菩提。于意云何。须陀洹能作是念我得须陀洹果不。须菩提言。不也世尊。何以故。实无有法名须陀洹。不入色声香味触法。是名须陀洹。佛言须菩提。于意云何。斯陀含能作是念我得斯陀含果不。须菩提言。不也世尊。何以故。实无有法名斯陀含。是名斯陀含。须菩提。于意云何。阿那含能作是念我得阿那含果不。须菩提言。不也世尊。何以故。实无有法名阿那含。是名阿那含。须菩提。于意云何。阿罗汉能作是念我得阿罗汉不须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊。若阿罗汉作是念我得阿罗汉。即为着我人众生寿者。世尊。佛说我得无诤三昧最为第一。世尊。说我是离欲阿罗汉。世尊。我不作是念。我是离欲阿罗汉。世尊。我若作是念我得阿罗汉。世尊。则不记我无诤行第一。以须菩提实无所行。而名须菩提无诤无诤行

佛告须菩提。于意云何。如来昔在燃灯佛所。得阿耨多罗三藐三菩提法不。须菩提言。不也世尊。如来在燃灯佛所。于法实无所得阿耨多罗三藐三菩提

佛告须菩提。若菩萨作是言。我庄严佛国土。彼菩萨不实语。何以故。须菩提。如来所说庄严佛土者则非庄严。是名庄严佛土。是故须菩提。诸菩萨摩诃萨。应如是生清净心而无所住。不住色生心。不住声香味触法生心。应无所住而生其心。须菩提。譬如有人身如须弥山王。须菩提。于意云何。是身为大不。须菩提言。甚大世尊。何以故。佛说非身是名大身。彼身非身是名大身

佛言须菩提。如恒河中所有沙数。如是沙等恒河。于意云何。是诸恒河沙宁为多不。须菩提言。甚多世尊。但诸恒河尚多无数。何况其沙。佛言须菩提。我今实言告汝。若有善男子善女人。以七宝满尔数恒沙数世界。以施诸佛如来。须菩提。于意云何。彼善男子善女人得福多不。须菩提言。甚多世尊。彼善男子善女人得福甚多。佛告须菩提。以七宝满尔数恒河沙世界。持用布施。若善男子善女人于此法门乃至受持四句偈等。为他人说。而此福德胜前福德。无量阿僧祇

复次须菩提。随所有处。说是法门乃至四句偈等。当知此处一切世间天人阿修罗皆应供养如佛塔庙。何况有人尽能受持读诵此经。须菩提。当知是人成就最上第一希有之法。若是经典所在之处。则为有佛若尊重似佛

尔时须菩提白佛言。世尊。当何名此法门。我等云何奉持。佛告须菩提。是法门名为金刚般若波罗蜜。以是名字汝当奉持。何以故。须菩提。佛说般若波罗蜜。则非般若波罗蜜须菩提。于意云何。如来有所说法不。须菩提言。世尊。如来无所说法。须菩提。于意云何。三千大千世界所有微尘是为多不。须菩提言。彼微尘甚多世尊。须菩提。是诸微尘如来说非微尘。是名微尘。如来说世界非世界。是名世界。佛言须菩提。于意云何。可以三十二大人相见如来不。须菩提言。不也世尊。何以故。如来说三十二大人相即是非相。是名三十二大人相

佛言须菩提。若有善男子善女人。以恒河沙等身命布施。若复有人于此法门中。乃至受持四句偈等为他人说。其福甚多无量阿僧祇。尔时须菩提闻说是经。深解义趣涕泪悲泣。扪泪而白佛言。希有婆伽婆。希有修伽陀。佛说如是甚深法门。我从昔来所得慧眼。未曾得闻如是法门。何以故。须菩提。佛说般若波罗蜜即非般若波罗蜜。世尊。若复有人得闻是经。信心清净则生实相。当知是名成就第一希有功德。世尊。是实相者则是非相。是故如来说名实相实相。世尊。我今得闻如是法门。信解受持不足为难。若当来世其有众生得闻是法门。信解受持。是人则为第一希有。何以故。此人无我相人相众生相寿者相。何以故。我相即是非相。人相众生相寿者相即是非相。何以故。离一切诸相则名诸佛。佛告须菩提。如是如是。若复有人得闻是经不惊不怖不畏。当知是人甚为希有。何以故。须菩提。如来说第一波罗蜜非第一波罗蜜。如来说第一波罗蜜者。彼无量诸佛亦说波罗蜜。是名第一波罗蜜

须菩提。如来说忍辱波罗蜜即非忍辱波罗蜜。何以故。须菩提。如我昔为歌利王割截身体。我于尔时无我相无众生相无人相无寿者相。无相亦非无相。何以故。须菩提。我于往昔节节支解时。若有我相众生相人相寿者相。应生嗔恨。须菩提。又念过去。于五百世作忍辱仙人。于尔所世。无我相无众生相无人相无寿者相。是故须菩提。菩萨应离一切相发阿耨多罗三藐三菩提心。何以故。若心有住则为非住。不应住色生心。不应住声香味触法生心。应生无所住心。是故佛说菩萨心不住色布施。须菩提。菩萨为利益一切众生。应如是布施。须菩提言。世尊。一切众生相即是非相。何以故。如来说一切众生即非众生。须菩提。如来是真语者实语者如语者不异语者。须菩提。如来所得法所说法。无实无妄语。须菩提。譬如有人入闇则无所见。若菩萨心住于事而行布施。亦复如是。须菩提。譬如人有目夜分已尽日光明照见种种色。若菩萨不住于事行于布施。亦复如是。复次须菩提。若有善男子善女人。能于此法门受持读诵修行。则为如来以佛智慧。悉知是人悉见是人悉觉是人。皆得成就无量无边功德聚。须菩提。若有善男子善女人。初日分以恒河沙等身布施中。日分复以恒河沙等身布施。后日分复以恒河沙等身布施如是舍恒河沙等无量身。如是百千万亿那由他劫以身布施。若复有人闻此法门信心不谤。其福胜彼无量阿僧祇。何况书写受持读诵修行为人广说

须菩提。以要言之。是经有不可思议不可称量无边功德。此法门如来为发大乘者说。为发最上乘者说。若有人能受持读诵修行此经广为人说。如来悉知是人悉见是人。皆成就不可思议不可称无有边无量功德聚。如是人等则为荷担如来阿耨多罗三藐三菩提。何以故。须菩提。若乐小法者。则于此经不能受持读诵修行为人解说。若有我见众生见人见寿者见。于此法门能受持读诵修行为人解说者。无有是处。须菩提。在在处处若有此经。一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼围绕以诸华香而散其处。复次须菩提。若善男子善女人受持读诵此经。为人轻贱。何以故。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提。须菩提。我念过去无量阿僧祇阿僧祇劫。于然灯佛前。得值八十四亿那由他百千万诸佛。我皆亲承供养无空过者。须菩提。如是无量诸佛。我皆亲承供养无空过者。若复有人于后世末世。能受持读诵修行此经所得功德。我所供养诸佛功德。于彼百分不及一。千万亿分乃至算数譬喻所不能及。须菩提。若有善男子善女人。于后世末世有受持读诵修行此经。所得功德若我具说者。或有人闻心则狂乱疑惑不信。须菩提。当知是法门不可思议。果报亦不可思议

尔时须菩提白佛言。世尊。云何菩萨发阿耨多罗三藐三菩提心。云何住。云何修行。云何降伏其心。佛告须菩提。菩萨发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生令入无余涅槃界。如是灭度一切众生已。而无一众生实灭度者。何以故。须菩提。若菩萨有众生相人相寿者相。则非菩萨。何以故。须菩提。实无有法名为菩萨发阿耨多罗三藐三菩提心者。须菩提。于意云何。如来于燃灯佛所。有法得阿耨多罗三藐三菩提不。须菩提白佛言。不也世尊。如我解佛所说义。佛于燃灯佛所。无有法得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。实无有法如来于燃灯佛所得阿耨多罗三藐三菩提。须菩提。若有法如来得阿耨多罗三藐三菩提者。燃灯佛则不与我受记。汝于来世当得作佛号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故燃灯佛与我受记。作如是言。摩那婆。汝于来世当得作佛号释迦牟尼。何以故。须菩提。言如来者即实真如。须菩提。若有人言如来得阿耨多罗三藐三菩提者。是人不实语。须菩提。实无有法佛得阿耨多罗三藐三菩提。须菩提。如来所得阿耨多罗三藐三菩提。于是中不实不妄语。是故如来说一切法皆是佛法。须菩提。所言一切法。一切法者即非一切法。是故名一切法。须菩提。譬如有人其身妙大。须菩提言。世尊。如来说人身妙大则非大身。是故如来说名大身

佛言须菩提。菩萨亦如是。若作是言。我当灭度无量众生。则非菩萨。佛言须菩提。于意云何。颇有实法名为菩萨。须菩提言。不也世尊。实无有法名为菩萨。是故佛说一切法无众生无人无寿者。须菩提。若菩萨作是言。我庄严佛国土。是不名菩萨。何以故。如来说庄严佛土。庄严佛土者即非庄严。是名庄严佛国土。须菩提。若菩萨通达无我无我法者。如来说名真是菩萨菩萨

须菩提。于意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。佛言须菩提。于意云何。如来有天眼不。须菩提言。如是世尊。如来有天眼。佛言须菩提。于意云何。如来有慧眼不。须菩提言。如是世尊。如来有慧眼。佛言须菩提。于意云何。如来有法眼不。须菩提言。如是世尊。如来有法眼。佛言须菩提。于意云何。如来有佛眼不。须菩提言。如是世尊。如来有佛眼。佛言须菩提。于意云何。如恒河中所有沙佛说是沙不。须菩提言。如是世尊。如来说是沙。佛言须菩提。于意云何。如一恒河中所有沙。有如是等恒河。是诸恒河所有沙数佛世界。如是世界宁为多不。须菩提言。彼世界甚多世尊。佛告须菩提。尔所世界中所有众生若干种心住。如来悉知。何以故。如来说诸心住皆为非心住。是名为心住。何以故。须菩提。过去心不可得。现在心不可得。未来心不可得。须菩提。于意云何。若有人以满三千大千世界七宝。持用布施。是善男子善女人以是因缘得福多不。须菩提言。如是世尊。此人以是因缘得福甚多。佛言。如是如是。须菩提。彼善男子善女人以是因缘得福德聚多。须菩提。若福德聚有实。如来则不说福德聚福德聚。须菩提。于意云何。佛可以具足色身见不。须菩提言。不也世尊。如来不应以色身见。何以故。如来说具足色身。即非具足色身。是故如来说名具足色身。佛言须菩提。于意云何。如来可以具足诸相见不。须菩提言。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足即非具足。是故如来说名诸相具足。佛言须菩提。于意云何。汝谓如来作是念我当有所说法耶。须菩提。莫作是念。何以故。若人言如来有所说法。即为谤佛。不能解我所说故。何以故。须菩提。如来说法说法者。无法可说是名说法

尔时慧命须菩提白佛言。世尊。颇有众生于未来世。闻说是法生信心不。佛言须菩提。彼非众生非不众生。何以故。须菩提。众生众生者。如来说非众生。是名众生

佛言须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。世尊无有少法如来得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。我于阿耨多罗三藐三菩提。乃至无有少法可得。是名阿耨多罗三藐三菩提。复次须菩提。是法平等无有高下。是名阿耨多罗三藐三菩提。以无众生无人无寿者。得平等阿耨多罗三藐三菩提。一切善法得阿耨多罗三藐三菩提。须菩提。所言善法善法者。如来说非善法。是名善法。须菩提。三千大千世界中所有诸须弥山王。如是等七宝聚。有人持用布施。若人以此般若波罗蜜经乃至四句偈等。受持读诵为他人说。于前福德百分不及一。千分不及一。百千万分不及一。歌罗分不及。一数分不及一。优波尼沙陀分不及一乃至算数譬喻所不能及

须菩提。于意云何。汝谓如来作是念我度众生耶。须菩提。莫作是念。何以故。实无有众生如来度者。佛言须菩提。若有实众生如来度者。如来则有我人众生寿者相。须菩提。如来说有我者则非有我。而毛道凡夫生者以为有我。须菩提。毛道凡夫生者。如来说名非生。是故言毛道凡夫生

须菩提。于意云何。可以相成就得见如来不。须菩提言。如我解如来所说义。不以相成就得见如来。佛言如是如是。须菩提。不以相成就得见如来。佛言须菩提。若以相成就观如来者。转轮圣王应是如来。是故非以相成就得见如来。尔时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来
  彼如来妙体　　即法身诸佛
  法体不可见　　彼识不能知

须菩提。于意云何。如来可以相成就得阿耨多罗三藐三菩提。须菩提。莫作是念。如来以相成就得阿耨多罗三藐三菩提。须菩提。汝若作是念。菩萨发阿耨多罗三藐三菩提心者。说诸法断灭相。须菩提。莫作是念何以故。菩萨发阿耨多罗三藐三菩提心者。不说诸法断灭相

须菩提。若善男子善女人以满恒河沙等世界七宝。持用布施。若有菩萨知一切法无我得无生法忍。此功德胜前所得福德。须菩提。以诸菩萨不取福德故。须菩提白佛言。世尊。菩萨不取福德。佛言须菩提。菩萨受福德不取福德。是故菩萨取福德。须菩提。若有人言。如来若去若来若住若坐若卧。是人不解我所说义。何以故。如来者无所至去无所从来故名如来。须菩提。若善男子善女人以三千大千世界微尘。复以尔许微尘世界。碎为微尘阿僧祇。须菩提。于意云何。是微尘众宁为多不。须菩提言。彼微尘众甚多世尊。何以故。若是微尘众实有者。佛则不说是微尘众。何以故。佛说微尘众则非微尘众。是故佛说微尘众世尊。如来所说三千大千世界则非世界。是故佛说三千大千世界。何以故。若世界实有者。则是一合相。如来说一合相则非一合相。是故佛说一合相。佛言须菩提。一合相者。则是不可说。但凡夫之人。贪着其事。何以故。须菩提。若人如是言。佛说我见人见众生见寿者见。须菩提。于意云何。是人所说为正语不。须菩提言。不也世尊。何以故。世尊。如来说。我见人见众生见寿者见。即非我见人见众生见寿者见。是名我见人见众生见寿者见。须菩提。菩萨发阿耨多罗三藐三菩提心者。于一切法。应如是知如是见如是信如是不住法相。何以故。须菩提。所言法相法相者。如来说即非法相是名法相。须菩提。若有菩萨摩诃萨。以满无量阿僧祇世界七宝。持用布施。若有善男子善女人。发菩萨心者。于此般若波罗蜜经乃至四句偈等。受持读诵为他人说。其福胜彼无量阿僧祇。云何为人演说。而不名说。是名为说而说偈言

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观

佛说是经已。长老须菩提及诸比丘比丘尼优婆塞优婆夷。菩萨摩诃萨。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

    金刚般若波罗蜜经金刚般若前后六翻。按开元录此第二译。思溪经本竟失其传。误将陈朝真谛三藏者重出。标作魏朝留支所译。大有迳庭。今于留支三藏所翻论中。录出经本刊版流通。庶期披阅知有源矣。时至元辛已冬孟望日南山普宁经局谨记


金刚般若波罗蜜经b

    金刚般若波罗蜜经

        元魏留支三藏奉　诏译

如是我闻。一时佛婆伽婆。住舍卫国只陀树林给孤独园。与大比丘众千二百五十人俱。尔时世尊。于日前分着衣持钵。入舍卫大国而行乞食。于其国中次第行已。还至本处饭食事讫。于中后时收衣钵洗足已。如常敷座跏趺安坐。端身而住正念现前。时诸比丘俱往佛所至佛所已顶礼佛足。右绕三匝却坐一面。尔时净命须菩提。于大众中共坐聚集。时净命须菩提。即从座起偏袒右肩。顶礼佛足右膝着地。向佛合掌而白佛言。希有世尊。如来应供正遍觉知。善护念诸菩萨摩诃萨。由无上利益故善付嘱诸菩萨摩诃萨。由无上教故。世尊。若善男子善女人。发阿耨多罗三藐三菩提心行菩萨乘。云何应住。云何修行。云何发起菩萨心。净命须菩提作是问已。尔时世尊告须菩提。须菩提。善哉善哉。如是善男子。如来善护念诸菩萨摩诃萨无上利益故。善付嘱诸菩萨摩诃萨无上教故。须菩提。是故汝今一心谛听。恭敬善思念之。我今当为汝说。如菩萨发菩提心行菩萨乘。如是应住。如是修行。如是发心。须菩提言。唯然世尊。佛告须菩提。须菩提。若善男子善女人。发菩提心行菩萨乘。应如是发心。所有一切众生类摄。若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若非有相若非无想。乃至众生界及假名说。如是众生我皆安置于无余涅槃。如是般涅槃无量众生已。无一众生被涅槃者。何以故。须菩提。若菩萨有众生想。即不应说名为菩萨。何以故。须菩提。一切菩萨无我想众生想寿者想受者想。复次须菩提。菩萨不着己类而行布施。不着所余行于布施。不着色声香味触法应行布施。须菩提。菩萨应如是行施不着相想。何以故。须菩提。若菩萨无执着心行于布施。是福德聚不可数量。须菩提。汝意云何。东方虚空可数量不。须菩提言。不可世尊。佛言。如是须菩提。南西北方四维上下十方虚空可数量不。须菩提言。不可世尊。佛言。如是须菩提。若菩萨无执着心行于布施。是福德聚亦复如是。不可数量。须菩提。汝意云何。可以身相胜德见如来不。不也世尊。何以故。如来所说身相胜德。非相胜德。何以故。须菩提。凡所有相皆是虚妄。无所有相即是真实。由相无相应见如来。如是说已。净命须菩提白佛言。世尊。于今现时及未来世。颇有菩萨听闻正说如是等相此经章句生实想不。佛告须菩提。莫作是说。于今现时及未来世。颇有菩萨听闻正说如是等相此经章句生实想不。何以故。须菩提。于未来世实有众生得闻此经能生实想。复次须菩提。于未来世后五十岁正法灭时。有诸菩萨摩诃萨持戒修福及有智慧。须菩提。是诸菩萨摩诃萨非事一佛。非于一佛种诸善根。已事无量百千诸佛。已于无量百千佛所而种善根。若有善男子善女人。听闻正说如是等相此经章句。乃至一念生实信者。须菩提。如来悉知是人悉见是人。须菩提。是善男子善女人。生长无量福德之聚。何以故。须菩提。是诸菩萨无复我想众生想寿者想受者想。是诸菩萨无法想无非法想无想非无想。何以故。须菩提。是诸菩萨若有法想。即是我执。及众生寿者受者执。须菩提。是故菩萨不应取法不应取非法。为如是义故如来说。若观行人解筏喻经。法尚应舍何况非法。佛复告净命须菩提。须菩提。汝意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛所说义。无所有法如来所得名阿耨多罗三藐三菩提。亦无有法如来所说。何以故。是法如来所说。不可取不可言。非法非非法。何以故。一切圣人皆以无为真如所显现故。须菩提。汝意云何。以三千大千世界遍满七宝。若人持用布施。是善男子善女人。因此布施生福多不。须菩提言。甚多世尊。甚多修伽陀。是善男子善女人。因此布施得福甚多。何以故。世尊。此福德聚即非福德聚。是故如来说福德聚。佛言。须菩提。若善男子。善女人。以三千大千世界遍满七宝持用布施。若复有人从此经中受四句偈。为他正说显示其义。此人以是因缘所生福德。最多于彼无量无数。何以故。须菩提。如来无上菩提从此福成。诸佛世尊从此福生。何以故。须菩提。所言佛法者。即非佛法是名佛法。须菩提。汝意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。世尊。实无所有能至于流。故说须陀洹。乃至色声香味触法亦复如是。故名须陀洹。斯陀含名一往来。实无所有能至往来。是名斯陀含。阿那含名为不来。实无所有能至不来。是名阿那含。佛言。须菩提。汝意云何。阿罗汉能作是念我得阿罗汉果不。须菩提言。不也世尊。何以故。实无所有名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉果。即是我执众生执寿者执受者执。世尊。如来阿罗诃三藐三佛陀赞我。住无诤三昧人中最为第一。世尊。我今已成阿罗汉离三有欲。世尊。我亦不作是念。我是阿罗汉。世尊。我若有是念。我已得阿罗汉果。如来则应不授我记住无诤三昧人中。须菩提。善男子最为第一。实无所住住于无诤住于无诤。佛告须菩提。汝意云何。昔从然灯如来阿罗诃三藐三佛陀所。颇有一法如来所取不。须菩提言。不也世尊。实无有法昔从燃灯如来阿罗诃三藐三佛陀所如来所取。佛告须菩提。若有菩萨作如是言。我当庄严清净佛土。而此菩萨说虚妄言。何以故。须菩提。庄严佛土者。如来说非庄严。是故庄严清净佛土。须菩提。是故菩萨应生如是无住着心。不住色声香味触法生心。应无所住而生其心。须菩提。譬如有人体相胜大如须弥山王。须菩提。汝意云何。如是体相为胜大不。须菩提言。甚大世尊。何以故。如来说非有名为有身。此非是有故说有身。佛告须菩提。汝意云何。于恒伽江所有诸沙。如其沙数所有恒伽。诸恒伽沙宁为多不。须菩提言。甚多世尊。但诸恒伽尚多无数。何况其沙。佛言。须菩提。我今觉汝我今示汝。诸恒伽中所有沙数尔许世界。若有善男子善女人。以七宝遍满持施如来应供正遍觉知。须菩提。汝意云何。此人以是因缘得福多不。须菩提言。甚多世尊。甚多修伽陀。此人以是因缘生福甚多。须菩提。若善男子善女人以七宝遍满尔所恒伽沙世界。持用布施。若善男子善女人。从此经典乃至四句偈等。恭敬受持为他正说。是人所生福德。最胜于彼无量无数。复次须菩提。随所在处。若有人能从是经典。乃至四句偈等读诵讲说。当知此处于世间中即成支提。一切人天及阿修罗等皆应恭敬。何况有人尽能受持读诵如此经典。当知是人则与无上希有之法而共相应。是土地处大师在中。或随有一可尊重人。佛说是已。净命须菩提白佛言。世尊。如是经典名号云何。我等云何奉持。佛告须菩提。此经名金刚般若波罗蜜。以是名字汝当奉持。何以故。须菩提。是般若波罗蜜。如来说非般若波罗蜜。须菩提。汝意云何。颇有一法一佛说不。须菩提言。不也世尊。无有一法一如来说。佛告须菩提。三千大千世界所有微尘。是为多不。须菩提言。此世界微尘。甚多世尊。甚多修伽陀。何以故。世尊。此诸微尘。如来说非微尘故名微尘。此诸世界。如来说非世界故说世界。佛告须菩提。汝意云何。可以三十二大人相见如来不。须菩提言。不也世尊。何以故。此三十二大人相。如来说非相故说三十二大人相。佛告须菩提。若有善男子善女人。如诸恒伽所有沙数。如是沙等身命舍以布施。若有善男子善女人。从此经典乃至四句偈等。恭敬受持为他正说。此人以是因缘。生福多彼无量无数。尔时净命须菩提由法利。疾即便悲泣抆泪而言。希有世尊。希有修伽陀。如此经典如来所说。我从昔来至得圣慧。未曾闻说如是经典。何以故。世尊。说般若波罗蜜即非般若波罗蜜。故说般若波罗蜜。世尊。当知是人。则与无上希有之法而共相应。闻说经时能生实想。世尊。是实想者实非有想。是故如来说名实想说名实想。世尊。此事于我非为希有。正说经时我生信解。世尊。于未来世若有众生。恭敬受持为他正说。当知是人。则与无上希有之法而共相应。世尊。此人无复我想众生想寿者想受者想。何以故。我想众生想寿者想受者想即是非想。何以故。诸佛世尊。解脱诸想尽无余故。说是言已。佛告须菩提如是。须菩提如是。当知是人。则与无上希有之法而共相应。是人闻说此经。不惊不怖不畏。何以故。须菩提。此法如来所说是第一波罗蜜。此波罗蜜如来所说。无量诸佛亦如是说。是故说名第一波罗蜜。复次须菩提。是如来忍辱波罗蜜。即非波罗蜜。何以故。须菩提。昔时我为迦陵伽王。斩斫身体骨肉离碎。我于尔时。无有我想众生想寿者想受者想无想非无想。何以故。须菩提。我于尔时。若有我想众生想寿者想受者想。是时则应生嗔恨想。须菩提。我忆过去五百生中。作大仙人名曰说忍。于尔生中心无我想众生想寿者想受者想。是故须菩提。菩萨摩诃萨舍离一切想。于无上菩提应发起心。不应生住色心。不应生住声香味触心。不应生住法心。不应生住非法心。不应生有所住心。何以故。若心有住则为非住。故如来说。菩萨无所住心应行布施。复次须菩提。菩萨应如是行施。为利益一切众生。此众生想即是非想。如是一切众生。如来说即非众生。何以故。诸佛世尊远离一切想故。须菩提。如来说实说谛说如说非虚妄。复次须菩提。是法如来所觉。是法如来所说。是法非实非虚。须菩提。譬如有人在于盲闇。如是当知菩萨堕相行堕相施。须菩提。如人有目夜已晓时。昼日光照见种种色。如是当知菩萨不堕于相行无相施。复次须菩提。于未来世若有善男子善女人。受持读诵修行。为他正说如是经典。如来悉知是人悉见是人。生长无量福德之聚。复次须菩提。若有善男子善女人。于日前分布施身命。如上所说诸河沙数。于日中分布施身命。于日后分布施身命。皆如上说诸河沙数。如是无量百千万亿劫以身命布施。若复有人闻此经典不起诽谤。以是因缘生福德多彼无数无量。何况有人书写受持读诵。教他修行为人广说。复次须菩提。如是经典不可思量无能与等。如来但为怜愍利益能行无上乘及行无等乘人说。若复有人于未来世受持读诵。教他修行正说是经。如来悉知是人悉见是人。与无数无量不可思议无等福聚而共相应。如是等人由我身分。则能荷负无上菩提。何以故。须菩提。如是经典若下愿乐人。及我见众生见寿者见受者见。如此等人能听能修读诵教他正说。无有是处。复次须菩提。随所在处显说此经。一切世间天人阿修罗等。皆应供养作礼右绕。当知此处于世间此即成支提。须菩提。若有善男子善女人。受持读诵教他修行。正说如是等经。此人现身受轻贱等。过去世中所造恶业。应感生后恶道果报。以于现身受轻苦故。先世罪业及苦果报则为消灭。当得阿耨多罗三藐三菩提。须菩提。我忆往昔无数无量过于算数过去。燃灯如来阿罗诃三藐三佛陀后。八万四千百千俱胝诸佛如来已成佛竟。我皆承事供养恭敬无空过者。若复有人于后末世五十岁时。受持读诵教他修行正说此经。须菩提。此人所生福德之聚。以我往昔承事供养诸佛如来所得功德。以此功德百分不及一。千万亿分不及一。穷于算数不及其一。乃至威力品类相应譬喻所不能及。须菩提。若善男子善女人。于后末世受持读诵如此等经。所得功德我若具说。若有善男子善女人。谛听忆持尔所福聚。或心迷乱及以颠狂。复次须菩提。如是经典不可思议。若人修行及得果报。亦不可思议。尔时须菩提白佛言。世尊。善男子善女人。发阿耨多罗三藐三菩提心行菩萨乘。云何应住。云何修行。云何发起菩萨心。佛告须菩提。善男子善女人。发阿耨多罗三藐三菩提心者。当生如是心。我应安置一切众生令入无余涅槃。如是槃涅槃无量众生已。无一众生被涅槃者。何以故。须菩提。若菩萨有。众生想。则不应说名为菩萨。何以故。须菩提。实无有法名为能行菩萨上乘。须菩提。汝意云何。于燃灯佛所。颇有一法如来所得名阿耨多罗三藐三菩提不。须菩提言。不也世尊。于燃灯佛所。无有一法如来所得名阿耨多罗三藐三菩提。佛言如是。须菩提如是。于燃灯佛所。无有一法如来所得名阿耨多罗三藐三菩提。须菩提于燃灯佛所。若有一法如来所得名阿耨多罗三藐三菩提。燃灯佛则不授我记婆罗门汝于来世当得作佛号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。须菩提。由实无有法如来所得名阿耨多罗三藐三菩提。是故然灯佛与我授记作如是言。婆罗门汝于来世当得作佛号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。何以故。须菩提。如来者真如别名。须菩提。若有人说如来得阿耨多罗三藐三菩提。是人不实语。何以故。须菩提。实无有法如来所得名阿耨多罗三藐三菩提。须菩提。此法如来所得无实无虚。是故如来说一切法皆是佛法。须菩提。一切法者非一切法。故如来说名一切法。须菩提。譬如有人遍身大身。须菩提言。世尊。是如来所说遍身大身则为非身。是故说名遍身大身。佛言。如是须菩提。如是须菩提。若有菩萨说如是言。我当般涅槃一切众生。则不应说名为菩萨。须菩提。汝意云何。颇有一法名菩萨不。须菩提言。不也世尊。佛言。须菩提。是故如来说一切法无我无众生无寿者无受者。须菩提。若有菩萨说如是言。我当庄严清净佛土如此菩萨说虚妄言。何以故。须菩提。庄严佛土者。如来说则非庄严。是故庄严清净佛土。须菩提。若菩萨信见诸法无我诸法无我。如来应供正遍觉说。是名菩萨是名菩萨。须菩提。汝意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。佛言。须菩提。汝意云何。如来有天眼不。须菩提言。如是世尊。如来有天眼。佛言。须菩提。汝意云何。如来有慧眼不。须菩提言。如是世尊。如来有慧眼。佛言。须菩提。汝意云何。如来有法眼不。须菩提言。如是世尊。如来有法眼。佛言。须菩提。汝意云何如来有佛眼不。须菩提言。如是世尊。如来有佛眼。须菩提。汝意云何。于恒伽江所有诸沙。如其沙数所有恒伽。如诸恒伽所有沙数世界。如是宁为多不。须菩提言。如是世尊。此等世界其数甚多。佛言。须菩提。尔所世界中所有众生。我悉见知心相续住有种种类。何以故。须菩提。心相续住。如来说非续住故说续住何以故。须菩提。过去心不可得。未来心不可得。现在心不可得。须菩提。汝意云何。若有人以满三千大千世界七宝。而用布施。是善男子善女人。以是因缘得福多不。须菩提言。甚多世尊。甚多修伽陀。佛言如是。须菩提如是。彼善男子善女人。以是因缘福聚多。佛言。须菩提。若福德聚但名为聚。如来则不应说是福德聚是福德聚。须菩提。汝意云何。可以具足色身观如来不。须菩提言。不也世尊。不可以具足色身观于如来。何以故。此具足色身。如来说非具足色身。是故如来说名具足色身。佛言。须菩提。汝意云何。可以具足诸相观如来不。须菩提言。不也世尊。不可以具足诸相观于如来。何以故。此具足相。如来说非具足相。是故如来说具足相。佛言。须菩提。汝意云何。如来有如是意。我今实说法耶。须菩提。若有人言如来实能说法。汝应当知是人由非实有。及以邪执起诽谤我。何以故。须菩提。说法说法实无有法名为说法。尔时须菩提白佛言。世尊。颇有众生于未来世。听闻正说如是等相此经章句。生实信不。佛告须菩提。彼非众生非非众生。何以故。须菩提。彼众生者如来说非众生。非非众生故说众生。须菩提。汝意云何。颇有一法如来所得名阿耨多罗三藐三菩提不。须菩提言。不也世尊。无有一法如来所得名阿耨多罗三藐三菩提。佛言如是。须菩提如是。乃至无有如微尘法如来所舍如来所得。是故说名阿耨多罗三藐三菩提平等平等。复次须菩提。诸佛诸佛觉知无有差别。是故说名阿耨多罗三藐三菩提。复次须菩提。此法平等无有高下。是名阿耨多罗三藐三菩提。复次须菩提。由无我无众生无寿者无受者等。此法平等故名阿耨多罗三藐三菩提。复次须菩提。由实善法。具足圆满得阿耨多罗三藐三菩提。须菩提。所言善法善法者。如来说非法故名善法。须菩提。三千大千世界所有诸须弥山王。如是等七宝聚满此世界。有人持用布施。若人从此般若波罗蜜经乃至四句偈等。受持读诵为。他正说所得功德。以前功德比此功德。百分不及一。千万亿分不及一。穷于算数不及其一。乃至威力品类相应譬喻所不能及。须菩提。汝意云何。如来作是念我度众生耶。须菩提。汝今不应作如是念。何以故。实无众生如来所度。须菩提。若有众生如来所度。即是我执众生执寿者执受者执。须菩提。此我等执如来说非执。婴儿凡夫众生之所执故。须菩提。婴儿凡夫众生者如来说非众生。故说婴儿凡夫众生。须菩提。汝意云何。可以具足相观如来不。须菩提言。如我解佛所说义。不以具足相应观如来。佛言如是。须菩提如。是不以具足相应观如来。何以故。若以具足相观如来者。转轮圣王应是如来。是故不以具足相应观如来。是时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不应得见我
  由法应见佛　　调御法为身
  此法非识境　　法如深难见

须菩提。汝意云何。如来可以具足相得阿耨多罗三藐三菩提不。须菩提。汝今不应作如是见。如来以具足相得阿耨多罗三藐三菩提。何以故。须菩提。如来不由具足相得阿耨多罗三藐三菩提。须菩提。若汝作是念。如来有是说行菩萨乘人有法可灭。须菩提。汝莫作此见。何以故。如来不说行菩萨乘。人有法可灭及以永断。须菩提。若有善男子善女人。以满恒伽沙等世界七宝。持用布施。若有菩萨于一切法无我无生得无生忍。以是因缘所得福德。最多于彼。须菩提。行大乘人不应执取福德之聚。须菩提言。此福德聚可摄持不。佛言。须菩提。此福德聚。可得摄持不可执取。是故说此福德之聚应可摄持。须菩提。若有人言如来行住坐卧。是人不解我所说义。何以故。须菩提。如来者无所行去无所从来。是故说名如来应供正遍觉知。须菩提。若善男子善女人。以三千大千世界地大微尘。烧成灰末合为墨丸。如微尘聚。须菩提。汝意云何。是邻虚聚宁为多不。须菩提言。彼邻虚聚。甚多世尊。何以故。世尊。若邻虚聚是实有者。世尊则不应说名邻虚聚。何以故。世尊。所说此邻虚聚。如来说非邻虚聚。是故说名为邻虚聚。如来所说三千大千世界则非世界。故说三千大千世界。何以故。世尊。若执世界为实有者是聚一执。此聚一执如来说非执。故说聚一执。佛世尊言。须菩提。此聚一执但世言说。须菩提。是法非可言法。婴儿凡夫偏言所取。须菩提。若有人言如来说我见众生见寿者见受者见。须菩提。汝意云何。是人言说为正语不。须菩提言。不也世尊。不也修伽陀。何以故。如来所说我见众生见寿者见受者见即是非见。是故说我见众生见寿者见受者见。须菩提。若人行菩萨乘。如是应知应见应信。一切诸法如是应修。为令法想不得生起。何以故。须菩提。是法想法想者。如来说即非想故说法想。须菩提。若有菩萨摩诃萨。以满无数无量世界七宝。持用布施。若有善男子善女人。从此般若波罗蜜经乃至四句偈等受持读诵。教他修行为他广说。是善男子善女人。以是因缘所生福德最多于彼无量无数。云何显说此经。如无所显说故言显说。如如不动恒有正说应观有为法如闇翳灯幻露泡梦电云。尔时世尊说是经已大德须菩提心进欢喜。及诸比丘比丘尼优婆塞优婆夷众人天阿修罗等一切世间踊跃欢喜信受奉行金刚般若波罗蜜经


金刚般若波罗蜜经c

    No. 237 [Nos. 220(9), 235, 236, 238, 239]

    金刚般若波罗蜜经

        陈天竺三藏真谛译

如是我闻。一时佛婆迦婆住舍卫国只陀树林给孤独园。与大比丘众千二百五十人俱。尔时世尊于日前分。着衣持钵入舍卫大国而行乞食。于其国中次第行乞。还至本处饭食事讫。于中后时。收衣钵洗足已。如常敷座加趺安坐。端身而住。正念现前。时诸比丘俱往佛所。至佛所已顶礼佛足。右绕三匝却坐一面

尔时净命须菩提。于大众中共坐聚集。时净命须菩提。即从座起偏袒右肩。顶礼佛足右膝着地。向佛合掌。而白佛言。希有世尊。如来应供正遍觉知。善护念诸菩萨摩诃萨。由无上利益故。善付嘱诸菩萨摩诃萨。由无上教故。世尊。若善男子善女人发阿耨多罗三藐三菩提心。行菩萨乘。云何应住。云何修行。云何发起菩萨心。净命须菩提作是问已。尔时世尊告须菩提。须菩提。善哉善哉。如是善男子。如来善护念诸菩萨摩诃萨。无上利益故。善付嘱诸菩萨摩诃萨。无上教故。须菩提。是故汝今一心谛听。恭敬善思念之。我今当为汝说。如菩萨发菩提心行菩萨乘。如是应住。如是修行。如是发心。须菩提言。唯然世尊

佛告须菩提。须菩提善男子善女人发菩提心行菩萨乘。应如是发心。所有一切众生类摄。若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若非有想若非无想。乃至众生界及假名说。如是众生我皆安置于无余涅槃。如是涅槃无量众生已。无一众生被涅槃者。何以故。须菩提。若菩萨有众生想。即不应说名为菩萨。何以故。须菩提。一切菩萨无我想众生想寿者想受者想

复次须菩提。菩萨不着己类而行布施。不着所余行于布施。不着色声香味触法应行布施。须菩提。菩萨应如是行施不着相想。何以故。须菩提。若菩萨无执着心行于布施。是福德聚不可数量。须菩提。汝意云何。东方虚空可数量不。须菩提言。不可世尊。佛言。如是须菩提。南西北方四维上下十方虚空可数量不。须菩提言。不可世尊。佛言。如是须菩提。若菩萨无执着心行于布施。是福德聚亦复如是不可数量。须菩提。汝意云何。可以身相胜德见如来不。不能世尊。何以故。如来所说身相胜德非相胜德。何以故。须菩提。凡所有相皆是虚妄无所有相。即是真实。由相无相应见如来。如是说已

净命须菩提白佛言。世尊。于今现时及未来世。颇有菩萨听闻正说如是等相此经章句。生实想不。佛告须菩提。莫作是说。于今现时及未来世。颇有菩萨听闻正说如是等相此经章句。生实想不。何以故。须菩提。于未来世实有众生。得闻此经能生实想。复次须菩提。于未来世后五百岁正法灭时。有诸菩萨摩诃萨。持戒修福及有智慧。须菩提。是诸菩萨摩诃萨非事一佛。非于一佛种诸善根。已事无量百千诸佛。已于无量百千佛所而种善根。若有善男子善女人。听闻正说如是等相此经章句。乃至一念生实信者。须菩提。如来悉知是人悉见是人。须菩提。是善男子善女人生长无量福德之聚。何以故。须菩提。是诸菩萨无复我想众生想寿者想受者想。是诸菩萨无法想非无法想。无想非无想。何以故。须菩提。是诸菩萨若有法想即是我执及众生寿者受者执。须菩提是故菩萨不应取法。不应取非法。为如是义故。如来说若观行人解筏喻经。法尚应舍何况非法

复次佛告净命须菩提。须菩提。汝意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛说义。无所有法如来所得。名阿耨多罗三藐三菩提。亦无有法如来所说。何以故。是法如来所说。不可取不可言。非法非非法。何以故。一切圣人皆以无为真如所显现故。须菩提。汝意云何。以三千大千世界遍满七宝。若人持用布施。是善男子善女人因此布施生福多不。须菩提言。甚多世尊。甚多修伽陀。是善男子善女人因此布施得福甚多。何以故。世尊。此福德聚即非福德聚。是故如来说福德聚。佛言。须菩提。若善男子善女人。以三千大千世界遍满七宝。持用布施。若复有人从此经中受四句偈。为他正说显示其义。此人以是因缘。所生福德最多于彼无量无数。何以故。须菩提。如来无上菩提从此福成。诸佛世尊从此福生。何以故。须菩提。所言佛法者即非佛法。是名佛法。须菩提。汝意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不能世尊。何以故。世尊。实无所有能至于流。故说须陀洹。乃至色声香味触法亦复如是。故名须陀洹。斯陀含名一往来。实无所有能至往来。是名斯陀含。阿那含名为不来。实无所有能至不来。是名阿那含。佛言。须菩提。汝意云何。阿罗汉能作是念。我得阿罗汉果不。须菩提言。不能世尊。何以故。实无所有名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉果。此念即是我执众生执寿者执受者执。世尊如来阿罗诃三藐三佛陀。赞我住无诤三昧人中最为第一。世尊。我今已得阿罗汉离三有欲。世尊。我亦不作是念。我是阿罗汉。世尊。我若有是念我已得阿罗汉果。如来则应不授我记。住无诤三昧人中须菩提善男子最为第一。实无所住住于无诤住于无诤

佛告须菩提。汝意云何。昔从然灯如来阿罗诃三藐三佛陀所。颇有一法如来所取不。须菩提言。不取世尊。实无有法昔从然灯如来阿罗诃三藐三佛陀所如来所取。佛告须菩提。若有菩萨作如是言。我当庄严清净佛土。而此菩萨说虚妄言。何以故。须菩提。庄严佛土者。如来说非庄严。是故庄严清净佛土。须菩提。是故菩萨应生如是无住着心。不住色声香味触法生心。应无所住而生其心。须菩提。譬如有人体相胜大如须弥山。须菩提。汝意云何。如是体相为胜大不。须菩提言。甚大世尊。何以故。如来说非有名为有身。此非是有故说有身

佛告须菩提。汝意云何。于恒伽所有诸沙。如其沙数所有恒伽。诸恒伽沙宁为多不。须菩提言。甚多世尊。但诸恒伽尚多无数。何况其沙。佛言。须菩提。我今觉汝我今示汝。诸恒伽中所有沙数尔许世界。若有善男子善女人。以七宝遍满持施如来应供正遍觉知。须菩提。汝意云何。此人以是因缘得福多不。须菩提言。甚多世尊。甚多修伽陀。有人以是因缘生福甚多。须菩提。若善男子善女人以七宝遍满尔所恒伽沙世界。持用布施。若善男子善女人从此经典乃至四句偈等。恭敬受持为他正说。是人所生福德最胜于彼无量无数。复次须菩提。随所在处。若有人能从是经典乃至四句偈等。读诵讲说。当知此处于世间中即成支提。一切人天阿修罗等皆应恭敬。何况有人尽能受持读诵如此经典。当知是人则与无上希有之法而共相应。是土地处。大师在中。或随有一可尊重人。佛说是已。净命须菩提白佛言。世尊。如是经典名号云何。我等云何奉持。佛告须菩提。此经名般若波罗蜜。以是名字汝当奉持。何以故。须菩提。是般若波罗蜜如来说非般若波罗蜜。须菩提。汝意云何。颇有一法一佛说不。须菩提言。无有世尊。无有一法一如来说。佛告须菩提。三千大千世界所有微尘是为多不。须菩提言。此世界微尘甚多世尊。甚多修伽陀。何以故。世尊。此诸微尘如来说非微尘。故名微尘。此诸世界如来说非世界。故说世界。佛告须菩提。汝意云何。可以三十二大人相见如来不。须菩提言。不可世尊。何以故。此三十二大人相如来说非相。故说三十二大人相

佛告须菩提。若有善男子善女人。如诸恒河所有沙数。如是沙等身命舍以布施。若有善男子善女人。从此经典乃至四句偈等。恭敬受持为他正说。此人以是因缘生福多彼无量无数。尔时净命须菩提。由法利疾即便悲泣。收泪而言。希有世尊。希有修伽陀。如此经典如来所说。我从昔来至得圣慧。未曾闻说如是经典。何以故。世尊。说般若波罗蜜即非般若波罗蜜。故说般若波罗蜜。世尊当知。是人则与无上希有之法而共相应。闻说经时能生实想。世尊。是实想者实非有想。是故如来说名实想说名实想。世尊。此事于我非为希有。正说经时我生信解。世尊。于未来世若有众生。恭敬受持为他正说。当知是人则与无上希有之法而共相应。世尊。此人无复我想众生想寿者想受者想。何以故。我想众生想寿者想受者想。即是非想。何以故。诸佛世尊。解脱诸想尽无余故。说是言已。佛告须菩提。如是须菩提。如是当知是人则与无上希有之法而共相应。是人闻说此经不惊不怖不畏。何以故。须菩提。此法如来所说是第一波罗蜜。此波罗蜜如来所说。无量诸佛亦如是说。是故说名第一波罗蜜

复次须菩提。如来忍辱波罗蜜即非波罗蜜。何以故。须菩提。昔时我为迦陵伽王。斩斫身体骨肉虽碎。我于尔时无有我想众生想寿者想受者想无想非无想。何以故。须菩提。我于尔时若有我想众生想寿者想受者想。是时则应生嗔恨想。须菩提。我忆过去五百生作大仙人名曰说忍。于尔所生中心无我想众生想寿者想受者想。是故须菩提。菩萨摩诃萨舍离一切想。于无上菩提应发起心。不应生住色心。不应生住声香味触心。不应生住法心。不应生住非法心。不应生有所住心。何以故。若心有住则为非住故。如来说菩萨无所住心应行布施。复次须菩提。菩萨应如是行施。为利益一切众生。此众生想即是非想。如是一切众生如来说即非众生。何以故。诸佛世尊远离一切想故。须菩提。如来说实说谛说如说非虚妄。复次须菩提。是法如来所觉。是法如来所说。是法非实非虚。须菩提。譬如有人在于盲暗。如是当知菩萨堕相行堕相施。须菩提。如人有目夜已晓昼日光照见种种色。如是当知菩萨不堕于相行无相施

复次须菩提。于未来世若有善男子善女人受持读诵修行。为他正说如是经典。如来悉知是人悉见是人。生长无量福德之聚

复次须菩提。若有善男子善女人。于日前分布施身命。如上所说诸河沙数。于日中分布施身命。于日后分布施身命。皆如上说诸河沙数。如是无量百千万亿劫以身命布施。若复有人闻此经典不起诽谤。以是因缘生福多彼无数无量。何况有人书写受持读诵教他修行为人广说

复次须菩提。如是经典不可思量无能与等。如来但为怜愍利益能行无上乘及行无等乘人说。若复有人于未来世受持读诵。教他修行正说是经。如来悉知是人悉见是人。与无数无量不可思议无等福聚而共相应。如是等人由我身分。则能荷负无上菩提。何以故。须菩提。如是经典若下愿乐人。及我见众生见寿者见受者见。如此等人能听能修读诵教他正说无有是处。复次须菩提。随所在处显说此经。一切世间天人阿修罗等。皆应供养作礼右绕。当知此处于世间中即成支提。须菩提。若有善男子善女人。受持读诵教他修行。正说如是等经。此人现身受轻贱等过去世中所造恶业。应感生后恶道果报。以于现身受轻苦故。先世罪业及苦果报则为消灭。当得阿耨多罗三藐三菩提。须菩提。我忆往昔无数无量过于算数大劫过去然灯如来阿罗诃三藐三佛陀。后八万四千百千俱胝诸佛如来已成佛竟。我皆承事供养恭敬无空过者。若复有人于后末世五百岁时。受持读诵教他修行正说此经。须菩提。此人所生福德之聚。以我往昔承事供养诸佛如来所得功德。比此功德百分不及一。千万亿分不及一。穷于算数不及其一。乃至威力品类相应。譬喻所不能及。须菩提。若善男子善女人于后末世。受持读诵如此等经。所得功德我若具说。若有善男子善女人。谛听忆持尔所福聚。或心迷乱及以颠狂。复次须菩提。如是经典不可思议。若人修行及得果报亦不可思议

尔时须菩提白佛言。世尊。善男子善女人发阿耨多罗三藐三菩提心。行菩萨乘。云何应住。云何修行。云何发起菩萨心。佛告须菩提。善男子善女人发阿耨多罗三藐三菩提心者。当生如是心。我应安置一切众生令入无余涅槃。如是般涅槃无量众生已。无一众生被涅槃者。何以故。须菩提。若菩萨有众生想。则不应说名为菩萨。何以故。须菩提。实无有法名为能行菩萨上乘

须菩提。汝意云何。于然灯佛所。颇有一法如来所得名阿耨多罗三藐三菩提不。须菩提言。不得世尊。于然灯佛所。无有一法如来所得名阿耨多罗三藐三菩提。佛言。如是须菩提。如是于然灯佛所。无有一法如来所得名阿耨多罗三藐三菩提。须菩提。于然灯佛所。若有一法如来所得名阿耨多罗三藐三菩提。然灯佛则不授我记。婆罗门。汝于来世当得作佛号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。须菩提。由实无有法如来所得名阿耨多罗三藐三菩提。是故然灯佛与我授记。作如是言。婆罗门。汝于来世当得作佛号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。何以故。须菩提。如来者真如别名。须菩提。若有人说如来得阿耨多罗三藐三菩提。是人不实语。何以故。须菩提。实无有法如来所得名阿耨多罗三藐三菩提。

须菩提。此法如来所得无实无虚。是故如来说一切法皆是佛法。须菩提。一切法者非一切法故。如来说名一切法。须菩提。譬如有人遍身大身。须菩提言。世尊。是如来所说遍身大身则为非身。是故说名遍身大身。佛言。如是须菩提。如是须菩提。若有菩萨说如是言。我当般涅槃一切众生则不应说名为菩萨。须菩提。汝意云何。颇有一法名菩萨不。须菩提言。无有世尊。佛言。须菩提。是故如来说一切法无我无众生无寿者无受者。须菩提。若有菩萨说如是言。我当庄严清净佛土。如此菩萨说虚妄言。何以故。须菩提。庄严佛土者如来说则非庄严。是故庄严清净佛土。须菩提。若菩萨信见诸法无我诸法无我。如来应供正遍觉说是名菩萨是名菩萨

须菩提。汝意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。佛言。须菩提。汝意云何。如来有天眼不。须菩提言。如是世尊。如来有天眼。佛言。须菩提。汝意云何。如来有慧眼不。须菩提言。如是世尊。如来有慧眼。佛言。须菩提。汝意云何。如来有法眼不。须菩提言。如是世尊。如来有法眼。佛言。须菩提。汝意云何。如来有佛眼不。须菩提言。如是世尊。如来有佛眼

须菩提。汝意云何。于恒伽江所有诸沙。如其沙数所有恒伽。如诸恒伽所有沙数世界。如是宁为多不。须菩提言。如是世尊。此等世界其数甚多。佛言。须菩提尔所世界中所有众生。我悉见知心相续住有种种类。何以故。须菩提。心相续住如来说非续住。故说续住。何以故。须菩提。过去心不可得未来心不可得现在心不可得。须菩提。汝意云何。若有人以满三千大千世界七宝。而用布施。是善男子善女人以是因缘得福多不。须菩提言。甚多世尊。甚多修伽陀。佛言。如是须菩提。如是彼善男子善女人以是因缘得福聚多。佛言。须菩提。若福德聚但名为聚。如来则不应说是福德聚是福德聚

须菩提。汝意云何。可以具足色身观如来不。须菩提言。不可世尊。不可以具足色身观于如来。何以故。此具足色身如来说非具足色身。是故如来说名具足色身。佛言。须菩提。汝意云何。可以具足诸相观如来不。须菩提言。不可世尊。不可以具足诸相观于如来。何以故。此具足相如来说非具足相。是故如来说具足相。佛言。须菩提。汝意云何。如来有如是意我今实说法耶。须菩提。若有人言如来实能说法。汝应当知。是人由非实有及以邪执。起诽谤我。何以故。须菩提。说法说法实无有法名为说法。尔时须菩提白佛言。世尊。颇有众生于未来世听闻正说如是等相此经章句。生实信不。佛告须菩提。彼非众生非非众生。何以故。须菩提。彼众生者如来说非众生非非众生故说众生

须菩提。汝意云何。颇有一法如来所得名阿耨多罗三藐三菩提不。须菩提言。不得世尊。无有一法如来所得名阿耨多罗三藐三菩提。佛言。如是须菩提。如是乃至无有如微尘法如来所舍如来所得。是故说名阿耨多罗三藐三菩提平等平等。复次须菩提。诸佛觉知无有差别。是故说名阿耨多罗三藐三菩提。复次须菩提。此法平等无有高下。是名阿耨多罗三藐三菩提。复次须菩提。由法无我无众生无寿者无受者等。此法平等故。名阿耨多罗三藐三菩提。复次须菩提。由实善法具足圆满。得阿耨多罗三藐三菩提。须菩提。所言善法。善法者如来说非法故名善法。须菩提。三千大千世界所有诸须弥山王。如是等七宝聚满此世界。有人持用布施。若人从此般若波罗蜜经乃至四句偈等。受持读诵为他正说所得功德。以前功德比此功德。百分不及一。千万亿分不及一。穷于算数不及其一。乃至威力品类相应譬喻所不能及。须菩提。汝意云何。如来作是念。我度众生耶。须菩提。汝今不应作如是念。何以故。实无众生如来所度。须菩提。若有众生如来所度。即是我执众生执寿者执受者执。须菩提。此我等执如来说非执。婴儿凡夫众生之所执故。须菩提。婴儿凡夫众生者。如来说非众生故。说婴儿凡夫众生。须菩提汝意云何。可以具足相观如来不。须菩提言。如我解佛所说义。不以具足相应观如来佛言。如是须菩提。如是不以具足相应观如来。何以故。若以具足相观如来者。转轮圣王应是如来。是故不以具足相应观如来。是时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不应得见我
  由法应见佛　　调御法为身
  此法非识境　　法如深难见

须菩提。汝意云何。如来可以具足相得阿耨多罗三藐三菩提不。须菩提。汝今不应作如是见。如来以具足相得阿耨多罗三藐三菩提。何以故。须菩提。如来不由具足相得阿耨多罗三藐三菩提。须菩提。若汝作是念。如来有是说行菩萨乘人有法可灭。须菩提。汝莫作此见。何以故。如来不说行菩萨乘人有法可灭及以永断。须菩提。若有善男子善女人。以满恒伽沙等世界七宝。持用布施。若有菩萨于一切法无我无生。得无生忍。以是因缘所得福德最多于彼。须菩提。行大乘人不应执取福德之聚。须菩提言。此福德聚可摄持不。佛言。须菩提。此福德聚可得摄持不可执取。是故说此福德之聚应可摄持

须菩提。若有人言如来行住坐卧。是人不解我所说义。何以故。须菩提。如来者无所行去亦无所从来。是故名如来应供正遍觉知。须菩提。若善男子善女人。以三千大千世界地大微尘。烧成灰末。合为墨丸。如微尘聚。须菩提。汝意云何。是邻虚聚宁为多不。须菩提言。彼邻虚聚。甚多世尊。何以故世尊。若邻虚聚是实有者。世尊则不应说名邻虚聚。何以故。世尊所说此邻虚聚。如来说非邻虚聚。是故说名为邻虚聚。如来所说三千大千世界则非世界。故说三千大千世界。何以故。世尊若执世界为实有者。是聚一执。此聚一执如来说非执故。说聚一执。佛世尊言须菩提。此聚一执但世言说。须菩提。是法非可言法。婴儿凡夫偏言所取

须菩提。若有人言如来说我见众生见寿者见受者见。须菩提。汝意云何。是人言说为正语不。须菩提言。不正世尊。不正修伽陀。何以故。如来所说我见众生见寿者见受者见即是非见。是故说我见众生见寿者见受者见。须菩提。若人行菩萨乘。如是应知应见应信一切诸法。如是应修。为令法想不得生起。何以故。须菩提。是法想法想者如来说即非想。故说法想。须菩提。若有菩萨摩诃萨。以满无数无量世界七宝。持用布施。若有善男子善女人。从此般若波罗蜜经乃至四句偈等。受持读诵教他修行为他广说。是善男子善女人。以是因缘所生福德最多于彼无量无数。云何显说此经。如无所显说故言显说

  如如不动　　恒有正说　　应观有为法
  如暗翳灯幻　　露泡梦电云

尔时世尊说是经已。大德须菩提心进欢喜。及诸比丘比丘尼优婆塞优婆夷众。人天阿修罗等。一切世间踊跃欢喜。信受奉行

    金刚般若波罗蜜经西天竺优禅尼国三藏法师。号拘罗那他。此云真谛。梁武皇帝。远遣迎接。经游闽越。暂憩梁安。太守王方赊。乃勤心正法。性爱大乘。仍于建造伽蓝。请弘兹典。法师不乖本愿。受三请而默然。寻此旧经。甚有脱误。即于壬午年五月一日。重翻天竺定文。依婆薮论释。法师善解方言。无劳度语。瞩彼玄文。宣此奥说。对偕宗法师法虔等。并共笔受。至九月二十五日。文义都竟。经本一卷。文义十卷。法虔尔目。仍愿造一百部。流通供养。并讲之十遍。普愿众生。因此正说。速至涅槃。常流应化


金刚顶瑜伽理趣般若经

    No. 241 [Nos. 220(10), 240, 242-244]

    金刚顶瑜伽理趣般若经

        唐南天竺三藏金刚智依梵本于中天译

如是我闻。一时薄伽梵妙善成就如来金刚住持平等性智种种希有殊胜功德。已能善护一切如来无上法王灌顶宝冠。过三界。已能善得一切如来遍金刚智摩诃瑜伽自在无碍。决定清净一切如来妙法智。已善圆证一切如来毕竟空寂平等性印所作事业皆得善巧成办。余一切有情种种希愿。随其无罪皆能满足。已善安住三世平等常无断尽广大周遍身语心性犹若金刚等诸如来无动无坏。是薄伽梵住欲界顶他化自在天王宫中一切如来常所游处咸共称美大宝藏殿。其殿无价摩尼所成。种种珍奇间杂严饰众生交映放大光明。宝铎金铃处处悬列微风吹动出和雅音。绮盖缯幡花幢彩拂。宝珠璎珞半满月等。种种杂饰而用庄严。贤圣天仙之所爱乐。与八十亿大菩萨俱。一切皆具陀罗尼门三摩地门无碍妙辩。如是等类无量功德。设经多劫赞不能尽。其名曰金刚手菩萨摩诃萨。观自在菩萨摩诃萨。虚空库菩萨摩诃萨。金刚拳菩萨摩诃萨。文殊师利菩萨摩诃萨。发心即转法轮菩萨摩诃萨。虚空藏菩萨摩诃萨。降伏一切魔怨菩萨摩诃萨。如是上首有八十亿大菩萨众。前后围绕宣说正法。初中后善文义巧妙。纯一圆满清白梵行

尔时世尊为诸菩萨。说一切法自性清净般若波罗蜜多理趣法门。此门即是菩萨句义。云何名为菩萨句义。所谓极妙清净句义是菩萨句义。诸见永寂清净句义是菩萨句义。微妙适悦清净句义是菩萨句义。渴爱永息清净句义是菩萨句义。胎藏超越清净句义是菩萨句义。众德庄严清净句义是菩萨句义。意极适悦清净句义是菩萨句义。意清净句义是菩萨句义。色清净句义是菩萨句义。声清净句义是菩萨句义。香清净句义是菩萨句义。味清净句义。是菩萨句义。触清净句义是菩萨句义。何以故乃至一切法自性清净故。一切法自性清净即般若波罗蜜多最胜清净。佛说如是菩萨句义般若理趣清净法已。告金刚手菩萨等言。金刚手菩萨若有得闻此一切法自性清净般若波罗蜜多理趣法门。一经于耳。所有烦恼障业极重诸罪皆自消灭。乃至菩提不生恶道。若能日日受持读诵正念思惟。即于此生定得一切法平等性金刚三摩地。经十六大菩萨生。定得如来执金刚性。疾证无上正等菩提即说密语

吽

尔时世尊复依毗卢遮那如来之相。为诸菩萨。说一切如来寂静法性般若波罗蜜多甚深理趣现等觉门。所谓金刚平等成正觉大菩提坚固性如金刚故。义平等成正觉。大菩提一义性故。法平等成正觉。大菩提自性清净故。一切业平等成正觉。大菩提离一切分别故。佛说如是法性门已。告金刚手菩萨言。金刚手若有得闻此四种寂静性成正觉般若波罗蜜多理趣现等觉门。信解受持读诵正念思惟。则能超越一切恶道。疾证无上正等菩提。复说密语

闇(引)

尔时世尊复依一切如来能调伏难调有情释迦牟尼之相。为诸菩萨。说一切法普胜平等般若波罗蜜多理趣法门。所谓贪无戏论性。嗔无戏论性。爱无戏论性。何以故乃至一切无戏论性故。一切无戏论性即般若波罗蜜多无戏论性。佛说如是调伏众恶般若理趣普胜法已。告金刚手菩萨等言。金刚手若有得闻一切法普胜平等般若波罗蜜多理趣法门。信解受持读诵正念思惟。假使杀害三界一切有情。终不因斯堕于恶道。何以故已受调伏心律仪故。常生善趣修菩提行。疾证无上正等菩提。复说密语

吽

尔时世尊复依一切如来自性清净相。为诸菩萨。说一切法平等性观自在智印般若波罗蜜多理趣法门。所谓一切贪性清净嗔性清净。一切贪性清净故。一切垢性清净罪性清净一切垢性清净罪性清净故。一切法性清净有情性清净。一切法性清净有情性清净故。一切智性清净。一切智性清净故即般若波罗蜜多最胜清净。佛说如是平等智印般若理趣清净法已。告金刚手菩萨等言。金刚手若有闻此一切法平等观自在智印般若波罗蜜多理趣法门。信解受持读诵正念思惟。虽在五欲尘中。不为客尘烦恼诸过所染。譬如莲华虽在淤泥终不染着。乃至疾证无上正等菩提。复说密语

颉唎(二合长声)

尔时世尊复依一切如来为三界之相。为诸菩萨。说一切如来灌顶出现智藏般若波罗蜜多理趣法门。所谓灌顶施。令得一切三界法王位故。财宝施。令得一切所愿满足故。净法施。令得一切法宝性故。饮食施。令得一切身口意获安乐故。佛说如是灌顶般若理趣智藏已。告金刚手菩萨等言。若有得闻如是灌顶甚深理趣智藏法门。信解受持读诵正念思惟。速能满足菩萨行。疾证无上正等菩提。复说密语

怛嚂(二合)

尔时世尊复依一切如来常住智印密藏相。为诸菩萨。宣说一切如来金刚智印甚深般若波罗蜜多理趣法门。所谓执持一切如来金刚身印。得一切如来真实体性故。执持一切如来金刚语印。得一切门自在故。执持一切如来金刚心印。得一切三摩地具足故。执金刚持一切如来金刚智印。得最上身语心如金刚故。佛说如是智印法已。告金刚手等言。金刚手若有得闻此一切如来金刚智甚深般若波罗蜜多理趣法门信解受持读诵正念思惟。即得成就最上金刚智印于一切智及众事业皆得圆满。身语心性犹若金刚不可破坏。疾证无上正等菩提。复说密语

恶

尔时世尊复依一切无戏论法如来之相。为诸菩萨。说文字转轮品般若波罗蜜多理趣法门。所谓一切法空。无自性故。一切法无相。离众相故。一切法无愿。离诸愿故。乃至一切法自性清净。即般若波罗蜜多自性清净。佛说如是离诸戏论文字法已。告金刚手菩萨等言。若有得闻此无戏论般若理趣轮字法门。信解受持读诵正念思惟。于此一切法。得无碍智。疾证无上正等菩提。复说密语

暗(上声引)

尔时世尊复依一切如来入广大转轮相。为诸菩萨。说入广大转轮般若波罗蜜多甚深理趣平等性门。所谓入金刚平等性。得入一切如来转轮故。入义平等性。得入一切菩萨法转轮故。入法平等性。得入妙法转轮故。乃至入一切法平等性。得入一切法平等性。得入一切法轮转故。佛说如是入广大转轮般若理趣平等性已告金刚手菩萨等言。若有得闻如是轮性甚深理趣平等性门。信解受持读诵正念思惟。善能悟入诸平等性。疾证无上正等菩提。复说密语

吽

尔时世尊复依一切如来广大供养种种供具。为诸菩萨。宣说最胜第一广大供养种种供具般若波罗蜜多甚深理趣无上法门。所谓发菩提心。即成广大供养一切如来。救护一切有情。即成广大供养一切如来。住持妙法。即成广大供养一切如来。乃至书写受持读诵。正念思惟供养般若波罗蜜多。即成广大供养一切如来。佛说如是真净供养甚深理趣无上法已。告金刚手等言。若有得闻如是供养般若理趣无上法门。信解受持读诵正念思惟。速能圆满诸菩萨行。疾证无上正等菩提。复说密语

唵

尔时世尊复依一切如来能调伏一切有情相。为诸菩萨。宣说能伏一切有情秘密智藏般若波罗蜜多理趣法门。所谓一切有情平等性。即忿怒平等性。一切有情调伏性。即忿怒调伏性。一切有情真法性。即忿怒真法性。一切有情如金刚性。即忿怒如金刚性。何以故调伏一切有情。令得菩提故。佛说如是能善调伏甚深理趣智藏已。告金刚手菩萨等言。若有得闻如是调伏般若理趣智藏法门。信解受持读诵正念思惟。能自调伏忿怒等过。亦能调伏一切有情。常生善趣受诸妙乐。现世怨敌皆起慈心。善能修行诸菩萨行。疾证无上正等菩提。复说密语

郝

尔时世尊复依一切如来住平等相。为诸菩萨。说一切法最胜平等性甚深般若波罗蜜多理趣法门。所谓一切法即平等性故。甚深般若波罗蜜多亦即平等性。一切法即第一义性故。甚深般若波罗蜜多亦即第一义性。一切法即法性故。甚深般若波罗蜜多亦即法性。乃至一切有业用性故当知甚深般若波罗蜜多亦有业用性。佛说如是性平等性甚深理趣最胜法已。告金刚手菩萨等言若有得闻如是平等甚深般若理趣最胜法门。信解受持读诵正念思惟。则能通达平等法性甚深般若波罗蜜多。于诸有情心无挂碍。疾证无上正等菩提。复说密语

颉唎(二合引)

尔时世尊复依一切如来为诸有情作加持相。为诸菩萨。说一切有情加持故般若波罗蜜多理趣法门。所谓一切有情即是如来藏。普贤菩萨性遍故。一切有情即是金刚。灌顶圆满性故。一切有情即正法藏性。能转一切正法语轮故。一切有情即是事业藏性。能作一切事业相应故。佛说如是加持有情甚深理趣胜藏法已。告金刚手菩萨等言。若有得闻如是遍满般若理趣胜藏法门。信解受持读诵正念思惟。则能通达胜藏法性。疾证无上正等菩提。复说密语

底利(二合引)

尔时世尊复依一切如来无量无边际究竟尽相。为诸菩萨。宣说一切法无量无边际究竟尽平等般若波罗蜜多理趣法门。所谓甚深般若波罗蜜多无量故。一切如来亦无量。甚深般若波罗蜜多无边故。一切如来亦无边。甚深般若波罗蜜多一性故。一切诸法亦一性。甚深般若波罗蜜多究竟尽故。一切诸法亦究竟尽。佛说如是无边无际究竟理趣金刚已。告金刚手菩萨等言。金刚手若有得闻如是究竟般若波罗蜜多理趣金刚法门。信解受持读诵正念思惟。所有一切障碍。皆得消灭究竟无余。定得如来执金刚性。疾证无上正等菩提。复说密语

毗药(二合)

尔时世尊复依一切如来离戏论秘密法性毗卢遮那相。为诸菩萨。宣说普贤大乐金刚不空神咒无量决定入诸法性无初中后最胜第一甚深般若波罗蜜多理趣法门。所谓诸菩萨能广大承事供养故得最上大乐。能得最上大乐故。能得诸佛无上大菩提。得诸佛无上大菩提故。悉能降伏一切魔军。降伏一切魔军故。得于三界自在最胜成就。于三界自在最胜成就故。能遍饶益一切有情。悉与究竟最上安乐。复说密语

萨梵

  有最胜者智　　常在生死中
  广度诸众生　　而不入涅槃
  般若波罗蜜　　究竟方便智
  能成清净业　　普净于诸有
  又以于贪等　　调伏诸世间
  乃至有顶天　　清净无为果
  在于生死中　　世法不能染
  如莲华妙色　　尘垢所不污
  大欲清净人　　大施安乐人
  于三界自在　　作坚固利益

复说密语

诃

唵娜么萨婆没[馬*犬]母地萨埵喃

唵步地质多跋折嚟(二合)

唵三曼多跋陀罗(二合)者利耶

唵真多么抳(埵)

唵过儞嚧提(陀)

唵　若(引)底尾[竺-二+戍]帝(空)

唵么诃啰伽达[繼-糸+言]

唵寐(引)哩耶迦嚩制(王)

唵萨婆伽弭儞

唵跋折罗(二合)儞哩茶迦嚩折坻吽

唵萨婆怛他孽帝(藏)

唵婆嚩婆(去声引)嚩秫提(光)

唵达么多娘娜尾秫提(幢)

唵羯么尾戌(引)达(你)唵(笑)

唵儞苏皤跋折哩抳吽泮

唵羯么逻霓(利)

唵惹呼跋折囇(因)

唵萨婆娜(一引)以儞

唵　顿唎(二合)羯

唵　阿迦罗目契护

唵　钵利若波罗帝(叉)郝(拳)鑁(去声)吽(刚)

唵([土*缶])闇(磨)

唵萨婆怛他孽多么(引)只尾戍(引)达儞(语)

唵萨婆怛他孽多迦[薛/女]囇(佛)

唵萨婆怛他孽多质多跋折囇(心)

唵跋折啰萨埵微塞普吒耶萨婆播耶满[馬*犬]娜儞钵啰慕乞叉耶萨婆播耶[薜/女]底弊萨嚩萨怛晚萨嚩怛他[薜/女]多三昧耶跋啰吽怛啰吒

佛说如是秘密语已。告金刚手菩萨秘密主言。若诸有情。得闻此二十五甚深般若波罗蜜多理趣秘密法门。信解受持读诵正念思惟。现世即得一切如来金刚秘密最胜成就。不久当得一切如来大执金刚法性之身。尔时世尊谓诸菩萨。宣说如上诸法门已。复告金刚手菩萨言。金刚手我此经典难可得闻。乃至极少至于一字。应知是人过去已曾供养诸佛。于诸佛所种诸善根。何况具足听闻。受持读诵正念思惟。当知是人决定已曾供养恭敬尊重赞叹八十亿那庾多恒河沙等诸佛。若是经典所在之处。此地则为有诸佛塔。若诸有情爱重此经。常随守护不离身者。是人应受一切世间恭敬供养。是人当得宿命智通。能知过去无量劫事。不为一切诸天魔波旬之所扰乱。四天大王及诸余天常随卫护。一切诸佛及诸菩萨。恒常供养摄受。十方净土随愿往生。金刚手我今略说般若波罗蜜多理趣法门功德如是若广说者穷劫不尽。佛说此经已。金刚手等诸菩萨。天龙夜叉乾闼婆阿素罗[薛/女]噜拏紧那罗摩护啰伽人非人等。一切众会皆大欢喜信受奉行金刚顶瑜伽理趣般若经


金刚能断般若波罗蜜经

    No. 238 [Nos. 220(9), 235-237, 239]

    金刚能断般若波罗蜜经

        隋大业年中三藏笈多译

归命一切佛菩萨海等如是我闻。一时世尊。闻者游行胜林中无亲搏施与园中。大比丘众共半三十比丘百。尔时世尊前分时。上裙著已。器上给衣持。闻者大城搏为入。尔时世尊闻者大城。搏为行已。作已食作已后食。搏堕过器上给衣收摄。两足洗。坐具世尊施设如是座中。跏趺结直身。作现前念近住。尔时多比丘。若世尊彼诣到已。世尊两足顶礼。世尊边三右绕作已。一边坐彼。复时命者善实。彼所如是众聚集会坐。尔时命者善实起坐。一肩上著作已。右膝轮地著已。若世尊彼合掌。向世尊边如是言。希有世尊。乃至所有如来应正遍知。菩萨摩诃萨顺摄。最胜顺摄。乃至所有如来应正遍知。菩萨摩诃萨付嘱。最胜付嘱。彼云何世尊菩萨乘发行住应。云何修行应。云何心降伏应。如是语已。世尊命者善实边如是言。善善。善实如是如是。善实如是如是。顺摄如来菩萨摩诃萨。最胜顺摄。付嘱如来菩萨摩诃萨。最胜付嘱。彼善实听。善善意念作。说当如菩萨乘发行住应。如修行应。如心降伏应。如是世尊。命者善实。世尊边愿欲闻。世尊于此言。此善实。菩萨乘发行如是心发生。应。所有善实众生。众生摄。摄已卵生若胎生。若湿生若化生。若色若无色。若想若无想。若非想非无想。所有众生界施设已。彼我一切无受余涅槃界灭度应。如是无量虽众生灭度。无有一众生灭度有。彼何所因。若善实。菩萨摩诃萨。众生想转。不彼菩萨摩诃萨名说应。彼何所因不彼善实菩萨名说应。若众生想转。寿想若人想若转。虽然复次时善实。不菩萨摩诃萨事住施与应。无所住施与应。不色住施与应。不声香味触法中住施与应。如是此善实菩萨摩诃萨施与应。如不相想亦住。彼何所因。若善实。菩萨摩诃萨。不住施与彼所善实福聚不可量受取。彼何意念。善实。可前方虚空量受取。善实言。不如此世尊。世尊言。如是右(南)后(西)高(北)下上方。顺不正方。普十方可虚空量受取。善实言。不如此世尊。世尊言。如是如是。善实。如是如是。若菩萨摩诃萨。不住施与。彼所善实福聚不可量受取。虽然复次时。善实。如是菩萨乘发行施与应。如不相想亦住。彼何意念。善实。相具足如来见应善实言。不世尊相具足如来见应。彼何所因若彼如来相具足说。彼如是非相具足。如是语已。世尊。命者善实边。如是言。所有善实相具足。所有妄。所有不相具足。所有不妄名。此相不相如来见应。如是语已。命者善实。世尊边如是言。虽然世尊。颇有众生。当有未来世。后时。后长时。后分五十。正法破坏时中。转时中。若此中。如是色类经中说中。实想发生当有。世尊言。莫善实汝如是语。虽然世尊。颇有众生当有未来世。后时后长时。后分五十。正法破坏时中。转时中。若此中。如是色类经中说中。实想发生当有。虽然复次时。善实。当有未来世。菩萨摩诃萨。后分五十。正法破坏时中。转时中。戒究竟。功德究竟。智慧究竟。不复次时彼善实菩萨摩诃萨一佛亲近供养当有。不一佛种植善根。虽然复次时。善实。不一佛百千亲近供养。不一佛百千种植善根。彼菩萨摩诃萨当有。若此中。如是色类中。经句中说中。一心净信亦得当知。彼善实如来佛智见。彼善实如来佛眼。一切彼善实无量福聚。生当取当。彼何所因。不善实彼等菩萨摩诃萨我想转。不众生想。不寿想。不人想转。不亦彼等。善实。菩萨摩诃萨。法想转无法想转不。亦彼等想无想转不。彼何所因。若善实。彼等菩萨摩诃萨法想转。彼如是彼等我取有。众生取寿取人取有。若无法想转。彼如是彼等我取有。众生取。寿取。人取有。彼何所因。不复次时。善实。菩萨摩诃萨。法取应不非法取应。彼故此义意如来说筏喻法本。解法如是舍应。何况非法。复次世尊。命者善实边。如是言。彼何意念。善实。有如来应正遍知无上正遍知证觉。有复法如来说。善实言。如我世尊。世尊说义解。我无有一法若如来无上正遍知证觉。无有一法若如来说。彼何所因。若彼如来法说不可取。彼不可说。不彼法非不法。彼何因。无为法显明圣人。世尊言。彼何意念。善实。若有善家子若善家女。若此三千大千世界。七宝满作已。如来等应等正遍知。等施与。彼何意念。善实。虽然彼善家子。若善家女。若彼缘多福聚生。善实言。多世尊。多善逝。彼善家子。若善家女。若彼缘多福聚生。彼何所因。若彼世尊。福聚如来。说非聚。彼世尊如来说福聚。福聚者。世尊言。若复善实。善家子。若善家女。若此三千大千世界。七宝满作已。如来等应等正遍知等施与。若此法本。乃至四句等偈。受已为他等分别广说。此彼缘多过。福聚生无量不可数。彼何所因。此出善实如来应正遍知。无上正遍知。此生佛世尊。彼何所因。佛法。佛法者。善实非佛法。如是彼。彼故。说名佛法者。世尊言。彼何意念。善实。虽然流入如是念我流入果得到。善实言。不如此世尊。彼何所因。不彼世尊一人彼故。说名流入。不色入。不声不香不味不触不法入彼故。说名流入者。彼若世尊。流入如是念我流入果得到。彼如是彼所我取有。众生取。寿取。人取有。世尊言。彼何意念。善实虽然。一来如是念我一来果得到。善实言。不如此。世尊。彼何所因。不一来如是念我一来果得到。彼何所因。不彼有法若一来人彼。故说名一来者。世尊言。彼何意念。善实。虽然不来如是念我不来果得到。善实言。不如此世尊。彼何所因。不彼有法若不来入彼。故说名不来者。世尊言。彼何意念。善实。虽然应如是念我应得到。善实言。不如此世尊。彼何所因。不彼世尊有法若应名彼故说名应者。彼若世尊应如是念我应得到。如是彼所我取有。众生取。寿取。人取有。彼何所因。我此世尊如来应正遍知无诤行最胜说。我此世尊。应离欲。不我世尊如是念我此应者。若我世尊如是念。我应得到。不我如来记说无诤行最胜。善实。善家子无所行彼故。说名无诤行。无诤行者。世尊言。彼何意念。善实。有一法若如来灯作如来应正遍知受取。善实言。不如此世尊。无一法若如来灯作如来应正遍知受取。世尊言。若有善实菩萨摩诃萨。如是语。我国土庄严成就。我者彼不如语。彼何所因。国土庄严者善实不庄严。彼如来说彼故。说名国土庄严者彼故。此善实菩萨摩诃萨。如是不住心发生应。不色住心发生应。不声香味触法住心发生应。无所住心发生应。譬如善实。丈夫有此如是色我身有。譬如善高山王。彼何意念。善实。虽然彼大我身有。善实言。大世尊大善逝。彼我身有。彼何所因。我身我身者。世尊。不有彼。如来说彼。故说名我身者。不彼世尊有彼。故说名我身者。世尊言。彼何意念。善实。所有恒伽大河沙。彼所有。如是恒伽大河有。彼中若沙。虽然彼多沙有。善实言。彼如是所有世尊多。恒伽大河有。何况若彼中沙。世尊言。欲我汝善实知我汝所有彼中恒伽大河中沙有。彼所有世界有。如是妇女若丈夫。若七宝满作已。如来等应等正遍知。等施与。彼何意念。善实。虽然彼妇女若丈夫。若彼缘多福聚生。善实言。多世尊。多善逝。彼妇女若丈夫。若彼缘多福聚生无量不可数。世尊言。若复时。善实。善家子。若善家女。若彼所有世界七宝满作已。如来等应等正遍知。等施与。若此法本。乃至四句等偈。受已为他等分别广说。此如是彼缘多过。福聚生无量不可数。虽然复次时。善实。此中地分。此法本乃至四句等偈。为他等说。若分别。若广说。若彼地分支帝有天人阿修罗世何复言。善实。若此法本。持当读当诵当。他等及分别广说当。最胜彼希有具足当。有此中善实地分。教师游行别异尊重处。相似共梵行。如是语已。命者善实。世尊边如是言。何名此世尊法本云何及如此持我。如是语已。世尊。命者善实边如是言。智慧彼岸到名。此善实法本如是此持。彼何所因。若如是善实。智慧彼岸到。如来说彼如是。非彼岸到。彼故说名智慧彼岸到者。彼何意念。善实。虽然有法若如来说。善实言。不如此世尊。不有世尊法若如来说。世尊言。所有善实。三千大千世界地尘有多有。善实言。多世尊。多善逝。彼地尘。彼何所因。若彼世尊。地尘如来说非尘。彼如来说彼故。说名地尘者。若彼世界。如来说非界。如来说彼故。说名世界者。世尊言。彼何意念。善实。三十二大丈夫相。如来应正遍知见应。善实言。不如此世尊。不三十二大丈夫相。如来应正遍知见应。彼何所因。所有世尊。三十二大丈夫相。如来说非相。所有如来说彼故。说名三十二大丈夫相者。世尊言。若复时。善实。妇女若丈夫。若日日恒伽河沙等我身舍。如是舍。恒伽河沙等劫。所有我身舍。若此法本。乃至四句等偈。受已为他等分别。此如是彼缘多过。福聚生无量不可数。尔时命者善实。法疾转力泪出。彼泪拭已。世尊边如是言。希有世尊。最胜希有善逝。所有此法本。如来说此我世尊智生。不我曾生来。如是色类法本闻。先最胜彼世尊希有。具足众生有当。若此经中说中实想发生当。彼何所因。若此世尊实想彼如是非想。彼故如来说。实想实想者。不我世尊希有。若我此法本说中。信我解我。若彼世尊。众生有当。未来世此法本。受当持当读当诵当。他等及分别广说当。彼最胜希有具足有当。虽然复次时。世尊。不彼等菩萨摩诃萨我想转当。不众生想。不寿想。不人想转当彼何所因。若彼世尊。我想彼如是非想。若及如是众生想。寿想。人想。彼如是非想。彼何所因。一切想远离。此佛世尊。如是语已。世尊。命者善实边如是言。如是如是善实。如是如是如言汝。最胜希有具足彼众生有当。若此经中说中不惊当。不怖当。不畏当。彼何所因。最胜彼岸到此善实如来说。若及善实如来最胜彼岸到说。彼无量亦佛世尊说彼。故说名最胜彼岸到者。虽然复次时。善实。若如来忍彼岸到。彼如是非彼岸到。彼何所因。此时我善实。恶王分别。分肉割断。不时我彼中时我想。若众生想。若寿想。若人想。若不我有想非想有。彼何所因。若我善实彼中时我想有。嗔恨想亦我彼中时有。众生想。寿想。人想有。嗔恨想亦我彼中时有。念知我善实。过去世五百生。若我忍语仙人有。彼中亦我不想有。不众生想。不寿想。不人想。不亦我有。想非想有。彼故。此善实。菩萨摩诃萨。一切想舍离。无上正遍知心发生应。不色住心发生应。不声香味触住心发生应。不法住非无法住心发生应。无所住心发生应。彼何所因。若无所住。彼如是住彼故。如是如来说不色住菩萨摩诃萨施与应。不声香味触法住施与应。虽然复次时。善实菩萨摩诃萨。如是舍施应。一切众生为故。彼何所因。若如是善实众生想。彼如是非想。若如是彼一切众生如来说。彼如是非众生。彼何所因。真语善实如来。实语如来。不异语如来。如语如来。非不如语如来。虽然复次时。善实。若如来法证觉说。若思惟。若不彼中实不妄。譬如善实丈夫。闇舍入不一亦见。如是。事堕菩萨见应。若事堕施与。譬如善实眼者。丈夫显明夜月出种种色见。如是菩萨摩诃萨见应。若事不堕施与。虽然复次时。善实。若善家子善家女。若此法本。受当持当读当诵当。为他等及分别广说当。知彼善实如来佛智见。彼善实如来佛眼。一切彼善实众生无量福聚生当取当。若复时。善实。妇女若丈夫。若前分时。恒伽河沙等我身舍。如是中分时。如是晚分时。恒伽河沙等我身舍。以此因缘。劫俱致那由多百千我身舍。若此法本。闻已不谤。此如是彼缘多过。福聚生无量不可数。何复言。若写已。受持读诵。为他等及分别广说。虽然复次时。善实。不可思。不可称。此法本彼不可思。如是果报观察应。此善实。法本如来说。胜乘发行众生为故。最胜乘发行众生为故。若此法本。受当持当读当诵当。为他等及分别广说当。知彼善实如来佛智见。彼善实如来佛眼。一切彼善实众生无量福聚具足有当。不可思不可称。亦不可量福聚具足有当。一切彼善实众生我肩菩提持当有。彼何所因。不能善实此法本小信解者。众生闻。不我见者。不众生见者。不寿见者。不人见者。不菩萨誓。众生能闻受。若持若读若诵若无是处有。虽然复次时。善实。此中地分此经广说供养。彼地分有当。天人阿修罗世礼右绕作。及彼地分有当。支帝彼地分有当。若彼善实善家子若善家女。若此如是色类经。受当持当读当诵当。为他等及分别广说当。彼轻贱有当。极轻贱。彼何所因。所有彼众生前生不善业作已。恶趣转堕所有现。如是法中。轻贱尽当。佛菩提得当。彼何所因。念知我善实过去世不可数劫不可数过。灯作如来应正遍知。他他过四八十佛俱致那由多百千有。若我亲承供养。亲承供养已。不远离。若我善实彼佛世尊。亲承供养已。不远离。若后时。后长时。后分五百。正法破坏时中。转时中。此经。受当持当读当诵当。为他等及分别广说当。此复时。善实。福聚边。此前福聚。百上亦数不及。千上亦百千上。亦俱致百千上。亦俱致那由多百千上。亦僧企耶。亦迦罗。亦算。亦譬喻。亦忧波泥奢。亦乃至譬喻亦不及。若复善实。彼等善家子善家女。我福聚说。此所有彼善家子善家女。若彼中时中。福聚取当。猛众生顺到心乱到。虽然复次时。善实。不可思。不可称。法本如来说。彼不可思。如是果报观察应。尔时命者善实。世尊边如是言。云何世尊。菩萨乘发行住应。云何修行应。云何心降伏。世尊言。此善实。菩萨乘发行如是心发生应。一切众生无我受余涅槃界灭度应。如是一切众生灭度。无有一众生灭度有。彼何所因。若善实。菩萨众生想转。彼不菩萨摩诃萨名说应。乃至人想转。不彼菩萨摩诃萨名说应。彼何所由。无有善实一法菩萨乘发行名。彼何意念。善实有一法若如来灯作如来应正遍知边无上正遍知证觉。如是语已。命者善实。世尊边如是言。无有彼世尊一法若如来灯作如来应正遍知边无上正遍知证觉。如是语已世尊。命者善实如是言。如是如是。善实。如是如是。无有彼一法若如来灯作如来应正遍知边无上正遍知证觉。若复善实。一法如来证觉有。不我灯作如来应正遍知记说有当。汝行者未来世。释迦牟尼名如来应正遍知者。是故。此善实。如来应正遍知。无有一法若无上正遍知证觉。彼故灯作如来应正遍知记说有当。汝行者。未来世。释迦牟尼名如来应正遍知。彼何所因。如来者善实真如故。此即是如来者。善实不生法故此即是世尊者。善实道断此即是如来者。善实毕竟不生故。此即是。彼何所因。如是彼实不生若最胜义。若有善实如是语。如来应正遍知无上正遍知证觉。彼不如语诽谤我。彼善实不实取。彼何所因。无有彼善实一法若如来应正遍知无上正遍知证觉。若善实。如来法证觉说。若不彼中实不妄。彼故如来说一切法佛法者。彼何所因。一切法。一切法者。善实。一切彼非法。如来说彼故。说名一切法者。譬如善实丈夫有具足身大身。命者善实言。若彼世尊。如来丈夫说具足身大身非身。彼世尊如来说彼故。说名足身大身者。世尊言。如是如是。善实。如是如是。若菩萨如是语有众生般涅槃灭度。我不彼菩萨名说应。彼何所因。有善实有一法若菩萨名。善实言。不如此世尊。世尊言。众生。众生者。善实非众生。彼如来说彼故。说名众生者。彼故如来说。无我一切法。无众生。无寿者。无长养者。无人一切法者。若善实。菩萨如是语。我佛土庄严成就。彼亦如是不名说应。彼何所因。国土庄严。国土庄严者。善实非庄严。彼如来说彼故。说名国土庄严者。若善实。菩萨摩诃萨。无我法。无我法者。信解彼如来应正遍知。菩萨摩诃萨名说。彼何意念。善实。有如来肉眼。善实言。如是如是世尊有如来肉眼。世尊言。彼何意念。善实。有如来天眼。善实言。如是如是世尊有如来天眼。世尊言。彼何意念。善实。有如来慧眼。善实言。如是如是世尊有如来慧眼。世尊言。彼何意念。善实。有如来法眼。善实言。如是如是世尊有如来法眼。世尊言彼何意念。善实。有如来佛眼。善实言。如是如是世尊有如来佛眼。世尊言。善善善实。彼何意念。善实。所有恒伽大河沙。虽然彼沙彼如来说。善实言。如是如是世尊。如是如是善逝。说彼如来彼沙。世尊言。彼何意念。善实。所有恒伽大河沙。彼所有恒伽大河有。所有彼中沙彼所有。及世界有。多彼世界有。善实言。多世尊。多善逝。彼世界有。世尊言。所有。善实。彼中世界中众生。彼等我种种有心流注知。彼何所因。心流注。心流注者。善实。非流注。此如来说彼故说名心流注者。彼何所因。过去善实心不可得。未来心不可得。现在心不可得。彼何意念。善实。若有善家子若善家女。若三千大千世界七宝满作已施与。虽然彼善家子若善家女。若彼缘多福聚生。善实言。多世尊。多善逝。世尊言。如是如是。善实。如是如是多。彼善家子若善家女若彼缘多福聚生。无量不可数福聚。福聚者。善实。非聚。彼如来说彼故。说名福聚者。若复善实。福聚有。不如来说福聚。福聚者。彼何意念。善实色身成就。如来见应。善实言。不如此世尊。非色身成就如来见应。彼何所因色身成就。色身成就者。世尊非成就。此如来说彼故。说名色身成就者。世尊言。彼何意念。善实。相具足如来见应。善实言。不如此世尊。非相具足如来见应。彼何所因。此世尊。相具足。如来说非相具足。如来说彼故。说名相具足者。世尊言。彼何意念。善实。虽然如来如是念我法说。善实言。不如此世尊。不如来如是念我法说。世尊言。若我善实如是语如来法说。诽谤我。彼善实不实取。彼何所因。法说法说者。善实。无有法若法说名可得。尔时命者善实。世尊边如是言。虽然世尊。当有未来。颇有众生。后时。后长时。后分五十。正法破坏时中转时中。若此。如是色类法说闻已信当有。世尊言。不彼善实众生非不众生。彼何所因。众生众生者。善实一切彼非众生。彼如来说彼故。说名众生者。彼何意念。善实虽然有法若如来无上正遍知证觉。命者善实言。无有彼世尊有法若如来无上正遍知。世尊言。如是如是。善实。如是如是。微小彼中法无有不可得彼。故说名无上正遍知者。虽然复次时。善实。平等正法。彼不中有不平等。彼故说名无上正遍知者。无我故。无寿故。无众生故。无人故。平等无上正遍知。一切善法证觉。善法善法者。善实非法。如是。彼如来说彼。故说名善法者。若复善实。所有三千大千世界。须弥山王彼所有聚七宝。普散如来应等正遍知施与。若此智慧彼岸到。乃至四句等偈受已。为他等分别。此善实。福聚彼前者福聚百上亦数不及。千上亦百千上。亦俱致百千上。亦俱致那由他百千上。亦僧企耶。亦迦罗。亦算。亦譬喻。亦忧波泥奢。亦乃至譬喻亦不及。彼何意念。善实。虽然如来如是念我众生度脱不。复彼善实。如是见应。彼何所因。有无。善实无有一众生若如来度脱。若复善实。有如是众生。有若彼如来度脱彼。如是如来。我取有。众生取。寿取。人取有。我取我取者。善实非取。此如来说彼小儿凡夫生取。小儿凡夫生小儿凡夫生者。善实非生。彼如来说彼。故说名小儿凡夫生者。彼何意念善实。相具足如来见应。善实言。不如此世尊。如我世尊说义解。我不相具足如来见应。世尊言。善善善实。如是如是善实。如如语汝。不相具足如来见应。彼何所因。彼复善实。相具足如来见应。有彼王转轮如来有彼。故不相具足如来见应。此相非相故。如来见应。尔时命者善实。世尊边如是言。如我世尊。世尊说义解。我不相具足如来见应。尔时世尊。彼时此伽陀说

  若我色见　　若我声求　　邪解脱行　　不我见彼

  法体佛见应　　法身彼如来
  法体及不识　　故彼不能知

彼何意念。善实。相具足如来无上正遍知证觉。不复彼。善实。如是见应。彼何所因。不善实相具足如来无上正遍知证觉。复时彼善实。有如是语。菩萨乘发行有。法破灭施设断。不复善实如是见应。彼何所因。不菩萨乘发行有法破灭施设不断。若复善实。善家子若善家女。若恒伽河沙等世界。七宝满作已施与。若菩萨摩诃萨无我无生中法中忍。得此如是。彼缘多过福聚生。不复善实菩萨福聚取应。命者善实言。不世尊菩萨福聚取应。世尊言取应。善实不取应彼故说名取应。虽然复次时。善实。若有如是语如来去若不去。若住若坐。若卧若如法。不我善实说义解。彼何所因。如来者。善实。说名无所去。无所来。彼故说名如来应正遍知者。若复善实。善家子若善家女。若所有三千大千世界地尘。彼如是色类墨作已。乃至如是不可数。譬如最小聚。彼何意念。善实。虽然彼多最小聚有。善实言。如是如是世尊。多彼最小聚有。彼何所因。彼世尊聚有。不世尊说最小聚者。彼何所因。若彼世尊。最小聚说非聚。彼如来说彼。故说名最小聚者。若及如来说三千大千世界者非界。如来说彼故。说名三千大千世界者。彼何所因。彼世尊界有。彼如是搏取有。若如是如来搏取说非取。彼如来说彼故。说名搏取者。世尊言。搏取如是。善实。不世俗语不可说非法非非法。彼小儿凡夫生取。彼何所因。若此有善实如是说。我见如来说众生见。寿见。人见。如来说。虽然彼善实。正说语。善实言。不如此世尊不如此善逝。彼何所因。若彼世尊我见如来说非见。彼如来说彼故。说名我见者。世尊言。如是此善实。菩萨乘发行一切法。知应见应信解应。如信解如无法想亦住。彼何所因。法想法想者。善实非想。此如来说彼故。说名法想者。若复时善实。菩萨摩诃萨无量无数世界七宝满中作已。如来等应等正遍知等施与。若善家子若善家女。若如是智慧彼岸到。乃至四句等偈。受持分别。读诵为他等。及分别广说。此如是彼缘多过福聚生无量不可数。云何及广说。如不广说。彼故说名广说

  星翳灯幻　　露泡梦电　　云见如是
  此有为者

此语。世尊欢喜。上座善实。彼及比丘比丘尼。优婆塞优婆夷。彼天人阿修罗乾闼婆等。闻世尊说大欢喜

归命一切佛菩萨海等金刚能断般若波罗蜜经


摩诃般若波罗蜜大明咒经

    No. 250 [Nos. 251-255, 257]

    摩诃般若波罗蜜大明咒经

        姚秦天竺三藏鸠摩罗什译

观世音菩萨。行深般若波罗蜜时。照见五阴空。度一切苦厄。舍利弗色空故无恼坏相。受空故无受相。想空故无知相。行空故无作相。识空故无觉相。何以故。舍利弗非色异空。非空异色。色即是空。空即是色。受想行识亦如是。舍利弗是诸法空相。不生不灭。不垢不净。不增不减。是空法。非过去非未来非现在。是故空中。无色无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界乃至无意识界。无无明亦无无明尽。乃至无老死无老死尽。无苦集灭道。无智亦无得。以无所得故。菩萨依般若波罗蜜故。心无挂碍。无挂碍故无有恐怖。离一切颠倒梦想苦恼。究竟涅槃。三世诸佛依般若波罗蜜故。得阿耨多罗三藐三菩提。故知般若波罗蜜是大明咒。无上明咒。无等等明咒。能除一切苦真实不虚故说般若波罗蜜咒即说咒曰

竭帝竭帝　波罗竭帝　波罗僧竭帝　菩提僧莎呵摩诃般若波罗蜜大明咒经


摩诃般若波罗蜜经

    No. 223 [Nos. 220(2), 221, 222]

摩诃般若波罗蜜经卷第一

        后秦龟兹国三藏鸠摩罗什译

    序品第一

如是我闻。一时佛住王舍城耆阇崛山中。共摩诃比丘僧大数五千分。皆是阿罗汉诸漏已尽无复烦恼心得好解脱慧得好解脱。其心调柔软摩诃那伽。所作已办。弃担能担逮得己利。尽诸有结正智已得解脱。唯阿难在学地得须陀洹。复有五百比丘尼优婆塞优婆夷等。皆得圣谛。复有菩萨摩诃萨。皆得陀罗尼及诸三昧行空无相无作。已得等忍得无阂陀罗尼悉是五通言必信受无复懈怠。已舍利养名闻。说法无所悕望。度深法忍得无畏力过诸魔事。一切业障悉得解脱。巧说因缘法。从阿僧祇劫以来发大誓愿。颜色和悦常先问讯所语不粗。于大众中而无所畏。无数亿劫说法巧出。解了诸法如幻如焰如水中月如虚空如响如揵闼婆城如梦如影如镜中像如化。得无阂无所畏。悉知众生心行所趣。以微妙慧面度脱之。意无挂阂大忍成就如实巧度。愿受无量诸佛国土。念无量国土诸佛三昧常现在前。能请无量诸佛。能断种种见缠及诸烦恼。游戏出生百千三昧。诸菩萨如是等种种无量功德成就其名曰颰陀婆罗菩萨。罽那伽罗菩萨。导师菩萨。那罗达菩萨。星得菩萨。水天菩萨。主天菩萨。大意菩萨。益意菩萨。增意菩萨。不虚见菩萨。善进菩萨。势胜菩萨。常勤菩萨。不舍精进菩萨。日藏菩萨。不缺意菩萨。观世音菩萨。文殊师利菩萨。执宝印菩萨。常举手菩萨。弥勒菩萨。如是等无量百千万亿那由他诸菩萨摩诃萨一切菩萨。皆是补处绍尊位者。尔时世尊自敷师子座结跏趺坐直身系念在前。入三昧王三昧一切三昧悉入其中。是时世尊。从三昧安详而起。以天眼观视世界举身微笑。从足下千辐相轮中。放六百万亿光明。足十指两踝两[跳-兆+尃]两膝两髀腰脊腹胁背脐心胸德字。肩臂手十指。项口四十齿。鼻两孔。两眼两耳。白毫相肉髻。各各放六百万亿光明。从是诸光出大光明。遍照三千大千国土。从三千大千国土。遍照东力如恒河沙等诸佛国土。南西北方四维上下亦复如是。若有众生遇斯光者。必得阿耨多罗三藐三菩提。光明出过东方如恒河沙等诸佛国土。南西北方四维上下亦复如是。尔时世尊举身毛孔。皆亦微笑而放诸光。遍照三千大千国土。复至十方如恒河沙等诸佛国土。若有众生遇斯光者。必得阿耨多罗三藐三菩提。尔时世尊以常光明。遍照三千大千国土。亦至东方如恒河沙等诸佛国土。乃至十方亦复如是。若有众生遇斯光者。必得阿耨多罗三藐三菩提。尔时世尊出广长舌相。遍覆三千大千国土熙怡微笑。从其舌根放无量千万亿光。是一一光化成千叶金色宝花。是诸花上皆有化佛。结跏趺坐说六波罗蜜。众生闻者必得阿耨多罗三藐三菩提。复至十方如恒河沙等诸佛国土皆亦如是。尔时世尊故在师子座入师子游戏三昧。以神通力感动三千大千国土。六种震动东踊西没西踊东没南踊北没北踊南没。边踊中没中踊边没。地皆柔软令众生和悦。是三千大千国土中。地狱饿鬼畜生及八难处。即时解脱得生天上。从四天王天处乃至他化自在天处。是诸天人自识宿命。皆大欢喜来诣佛所。头面礼佛足却住一面。如是十方如恒河沙等国土地。皆六种震动。一切地狱饿鬼畜生及八难处即时解脱。得生天上齐第六天。尔时三千大千国土众生盲者得视聋者得听哑者能言狂者得正乱者得定裸者得衣饥渴者得饱满。病者得愈形残者得具足。一切众生皆得等心。相视如父如母如兄如弟如姊如妹。亦如亲族及善知识。是时众生等行十善业道。净修梵行。无诸瑕秽恬然快乐。臂如比丘入第三禅皆得好慧。持戒自守不娆众生。尔时世尊在师子座上坐。于三千大千国土中其德特尊。光明色像威德巍巍。遍至十方如恒河沙等诸佛国土。譬如须弥山王光色殊特众山无能及者。尔时世尊以常身示此三千大千国土一切众生。是时首陀会天梵众天。他化自在天化乐天兜率陀天夜摩天三十三天四天王天及三千大千国土人与非人。以诸天花天璎珞天泽香天末香天。青莲花赤莲花白莲花红莲花天树叶香持诣佛所。是诸天花乃至天树叶香以散佛上。所散宝花于此三千大千国土上。在虚空中化成大台。是花台边垂诸璎珞。杂色花盖五色缤纷。是诸花盖璎珞遍满三千大千世界。以是花盖璎珞严饰故。此三千大千国土皆作金色。及十方如恒河沙等诸佛国土皆亦如是。尔时三千大千国土及十方众生各各自念佛独为我说法不为余人。尔时世尊在师子座。熙怡微笑光从口出。遍照三千大千国土。以此光故此间三千大千国土中众生。皆见东方如恒河沙等诸佛及僧。彼间如恒河沙等国土中众生亦见此间三千大千国土中释迦牟尼佛及诸大众。南西北方四维上下亦复如是是时东方过如恒河沙等诸佛国土。其国最在边国名多宝。佛号宝积。今现在为诸菩萨摩诃萨说般若波罗蜜。彼国有菩萨名曰普明。见大光明见地大动又见佛身。到宝积佛所白佛言。世尊。今何因缘。有此光明照于世间地大震动又见佛身。宝积佛报普明言。善男子。西方度如恒河沙等国。有世界名娑婆。佛号释迦牟尼。今现在欲为诸菩萨摩诃萨说般若波罗蜜。是其神力。是时普明菩萨白宝积佛言。世尊。我今当往见释迦牟尼佛礼拜供养。及见彼诸菩萨摩诃萨绍尊位者。皆得陀罗尼及诸三昧。于诸三昧而得自在。佛告普明。欲往随意宜知是时。尔时宝积佛。以千叶金色莲花与普明菩萨。而告之曰。善男子。汝以此花散释迦牟尼佛上。生彼娑婆国中诸菩萨难胜难及。汝当一心以游彼国。尔时普明菩萨从宝积佛受千叶金色光明莲花。与无数出家在家菩萨及诸童男童女。俱共发引皆供养恭敬尊重赞叹东方诸佛。持诸花香璎珞泽香末香涂香衣服幢盖。向释迦牟尼佛所。到已头面礼佛足一面立白佛言。世尊。宝积如来致问。世尊少恼少患起居轻利气力安乐不。又以此千叶金色莲花供养世尊。尔时释迦。牟尼佛受是千叶金色莲花。以散东方如恒河沙等诸国土中。佛所散宝花满东方如恒河沙等诸佛国土。一一花上皆有菩萨。结跏趺坐说六波罗蜜。闻此法者必至阿耨多罗三藐三菩提。诸出家在家菩萨及诸童男童女。头面礼释迦牟尼佛足各以供养具。供养恭敬尊重赞叹释迦牟尼佛。是诸出家在家菩萨及诸童男童女。各各以善根福德力故。得供养释迦牟尼佛多陀阿伽度阿罗诃三藐三佛陀。南方度如恒河沙等诸佛国土。其国最在边国名离一切忧。佛号无忧德。菩萨名离忧。西方度如恒河沙等诸佛国土。其国最在边国名灭恶。佛号宝山。菩萨名仪意。北方度如恒河沙等诸佛国土。其国最在边国名胜。佛号胜王。菩萨名德胜。下方度如恒河沙等诸佛国土。其国最在边国名善。佛号善德。菩萨名花上。上方度如恒河沙等诸佛国土。其国最在边国名喜。佛号喜德。菩萨名德喜。如是一切皆如东方。尔时是三千大千国土。皆成为宝花遍[雨/復]地悬缯幡盖。香树花树皆悉庄严。譬如花积世界普花佛国。妙德菩萨。善住意菩萨。及余大威神诸菩萨皆在彼住。尔时佛知一切世界。若天世界若魔世界若梵世界若沙门婆罗门。及天若犍闼婆人阿修罗等。及诸菩萨摩诃萨绍尊位者。一切皆集

佛知众会已集。佛告舍利弗。菩萨摩诃萨欲以一切种智知一切法。当习行般若波罗蜜。舍利弗白佛言。世尊。菩萨摩诃萨云何欲以一切种智知一切法。当习行般若波罗蜜。佛告舍利弗。菩萨摩诃萨以不住法住般若波罗蜜中。以无所舍法应具足檀那波罗蜜。施者受者及财物不可得故。罪不罪不可得故。应具足尸罗波罗蜜。心不动故。应具足羼提波罗蜜。身心精进不懈怠故。应具足毗梨耶波罗蜜。不乱不味故。应具足禅那波罗蜜。于一切法不着故。应具足般若波罗蜜。菩萨摩诃萨以不住法住般若波罗蜜中。不生故。应具足四念处四正勤四如意足五根五力七觉分八圣道分。空三昧无相三昧无作三昧。四禅四无量心四无色定八背舍八胜处九次第定十一切处。九相。胀相坏相血涂相脓烂相青相啖相散相骨相烧相。念佛念法念僧念戒念舍念天念入出息念死。十想。无常想苦想无我想食不净想一切世间不可乐想死想不净想断想离欲想尽想。十一智。法智比智他心智世智苦智集智灭智道智尽智无生智如实智。三三昧。有觉有观三昧无觉有观三昧。无觉无观三昧。三根。未知欲知根知根知已根。舍利弗。菩萨摩诃萨欲遍知佛十力四无所畏四无阂智。十八不共法大慈大悲。当习行般若波罗蜜。菩萨摩诃萨欲具足道慧。当习行般若波罗蜜。菩萨摩诃萨。欲以道慧具足道种慧。当习行般若波罗蜜。欲以道种慧具足一切智。当习行般若波罗蜜。欲以一切智具足一切种智。当习行般若波罗蜜。欲以一切种智断烦恼习。当习行般若波罗蜜。舍利弗。菩萨摩诃萨应如是学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲上菩萨位。当学般若波罗蜜。欲过声闻辟支佛地住阿惟越致地。当学般若波罗蜜。菩萨摩诃萨。欲住六神通。当学般若波罗蜜。欲知一切众生意所趣向。当学般若波罗蜜。菩萨摩诃萨欲胜一切声闻辟支佛智慧。当学般若波罗蜜。欲得诸陀罗尼门诸三昧门。当学般若波罗蜜。一切求声闻辟支佛人布施时。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人持戒时。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人。三昧智慧解脱解脱知见。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人。诸禅定解脱三昧。欲以随喜心过其上者。当学般若波罗蜜。菩萨摩诃萨行少施少戒少忍少进少禅少智。欲以方便力回向故而得无量无边功德者。当学般若波罗蜜。菩萨摩诃萨欲行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。当学般若波罗蜜。菩萨摩诃萨欲使世世身体与佛相似。欲具足三十二相八十随形好。当学般若波罗蜜。欲生菩萨家。欲得童真地。欲得不离诸佛者。当学般若波罗蜜。欲以诸善根供养诸佛。恭敬尊重赞叹随意成就。当学般若波罗蜜。欲满一切众生所愿饮食衣服卧具涂香车乘房舍床榻灯烛等。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲使如恒河沙等国土众生。立于檀那波罗蜜。立于尸罗羼提毗梨耶禅那般若波罗蜜。当学般若波罗蜜。欲植一善根于佛福田中。至得阿耨多罗三藐三菩提不尽者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲令十方诸佛称赞其名。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲一发意到十方如恒河沙等诸佛国土。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲发一音使十方如恒河沙等诸佛国土闻声。当学般若波罗蜜。复次舍利弗。菩萨欲使诸佛国土不断者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲住内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空。当学般若波罗蜜。菩萨摩诃萨欲知诸法因缘次第缘缘缘增上缘。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲知诸法如法性实际。当学般若波罗蜜。舍利弗。菩萨摩诃萨应如是住般若波罗蜜。复次舍利弗。菩萨摩诃萨欲数知三千大千国土中大地诸山微尘。当学般若波罗蜜。菩萨摩诃萨析一毛为百分。欲以一分毛尽举三千大千国土中大海江河池泉诸水而不娆水性。当学般若波罗蜜。三千大千国土中诸火一时皆然譬如劫尽烧时。菩萨摩诃萨欲一吹令灭者。当学般若波罗蜜。三千大千国土中诸大风起。欲吹破三千大千国土及诸须弥山如摧腐草。菩萨摩诃萨欲以一指障其风力令不起者。当学般若波罗蜜。菩萨摩诃萨欲一结跏趺坐。遍满三千大千国土虚空。当学般若波罗蜜。菩萨摩诃萨欲以一毛举三千大千国土中诸须弥山王。掷过他方无量阿僧祇诸佛国土不娆众生。欲以一食供养十方各如恒河沙等诸佛及僧。当学般若波罗蜜。欲以一衣花香璎珞末香涂香烧香灯烛幢幡花盖等。供养诸佛及僧。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲使十方各如恒河沙等国土中众生。悉具于戒三昧智慧解脱解脱知见。令得须陀洹果斯陀含果阿那含果阿罗汉果。乃至令得无余涅槃。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜布施时应如是分别。如是布施得大果报。如是布施得生刹利大姓婆罗门大姓居士大家。如是布施得生四天王天处三十三天夜摩天兜率陀天化乐天他化自在天。因是布施得入初禅二禅三禅四禅无边空处无边识处无所有处非有想非无想处。因是布施得生八圣道分。因是布施能得须陀洹道乃至佛道。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜布施时。以慧方便力故。能具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。舍利弗白佛言。世尊。菩萨摩诃萨云何布施时。以慧方便力故。具足檀那波罗蜜乃至般若波罗蜜。佛告舍利弗。施人受人财物不可得故。能具足檀那波罗蜜。罪不罪不可得故。具足尸罗波罗蜜。心不动故。具足羼提波罗蜜。身心精进不懈怠故。具足毗梨耶波罗蜜。不乱不味故。具足禅那波罗蜜。知一切法不可得故。具足般若波罗蜜。复次舍利弗。菩萨摩诃萨欲得过去未来现在诸佛功德当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲到有为无为法彼岸。当学般若波罗蜜。菩萨摩诃萨欲知过去未来现在诸法如法相无生际者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲在一切声闻辟支佛前。欲给侍诸佛。欲为诸佛内眷属。欲得大眷属。欲得菩萨眷属。欲净报大施。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲不起悭心破戒心嗔恚心懈怠心乱心痴心者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲使一切众生立于布施福处持戒福处修定福处劝导福处。欲令众生立于财福法福者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲得五眼当学般若波罗蜜。何等五眼。肉眼天眼慧眼法眼佛眼。菩萨摩诃萨欲以天眼见十方如恒河沙等国土中诸佛。欲以天耳闻十方诸佛所说法。欲知诸佛心当学般若波罗蜜。欲闻十方诸佛所说法。闻已乃至阿耨多罗三藐三菩提不忘者。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲见过去未来诸佛国土。及见现在十方诸佛国土。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲闻十方诸佛所说。十二部经修多罗祇夜受记经伽陀忧陀那因缘经阿波陀那如是语经本生经方广经未曾有经论议经。诸声闻等闻与不闻。尽欲诵受持者。当学般若波罗蜜。十方如恒河沙等世界中。诸佛所说法已说今说当说。闻已欲一切信持自行亦为他人说。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨过去诸佛已说。未来诸佛当说。欲闻闻已自利亦利他人。当学般若波罗蜜。十方如恒河沙等诸世界中间闇处。日月所不照处。欲持光明普照者。当学般若波罗蜜。十方如恒河沙等世界中。无有佛名法名僧名。欲使一切众生皆得正见闻三宝名者。当学般若波罗蜜。菩萨摩诃萨。欲令十方如恒河沙等诸世界中众生。以我力故盲者得视聋者得听。狂者得念裸者得衣。饥渴者得饱满。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨若欲令十方如恒河沙等世界中众生诸在三恶趣者。以我力故皆得人身。当学般若波罗蜜。欲令十方如恒河沙等世界中众生。以我力故立于戒三昧智慧解脱解脱知见。令得须陀洹果乃至阿耨多罗三藐三菩提。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲学诸佛威仪者。当学般若波罗蜜。菩萨摩诃萨欲得如象王视观。当学般若波罗蜜。菩萨作是愿。使我行时离地四指足不蹈地。我当共四天王天乃至阿迦尼吒天无量千万亿诸天众。围绕恭敬至菩提树下。当学般若波罗蜜。我当于菩提树下坐。四天王天乃至阿迦尼吒天。以天衣为座。当学般若波罗蜜。我得阿耨多罗三藐三菩提时。行住坐卧处欲使悉为金刚。当学般若波罗蜜。复次舍利弗。菩萨摩诃萨欲出家日即成阿耨多罗三藐三菩提。即是日转法轮。转法轮时无量阿僧祇众生远尘离垢。诸法中得法眼净。无量阿僧祇众生一切法不受故。诸漏心得解脱。无量阿僧祇众生于阿耨多罗三藐三菩提得不退转。当学般若波罗蜜。我得阿耨多罗三藐三菩提时。以无量阿僧祇声闻为僧。我一说法时。便于座上尽得阿罗汉。当学般若波罗蜜。我当以无量阿僧祇菩萨摩诃萨为僧我一说法时。无量阿僧祇菩萨。皆得阿惟越致。欲得寿命无量光明具足。当学般若波罗蜜。我成阿耨多罗三藐三菩提时。世界中无淫欲嗔恚愚痴。亦无三毒之名。一切众生成就如是智慧善施善戒善定善梵行善不娆众生。当学般若波罗蜜。使我般涅槃后法无灭尽。亦无灭尽之名。当学般若波罗蜜。我得阿耨多罗三藐三菩提时。十方如恒河沙等世界中众生闻我名者。必得阿耨多罗三藐三菩提。欲得如是等功德者。当学般若波罗蜜

    摩诃般若波罗蜜经奉钵品第二

佛告舍利弗。若菩萨摩诃萨行般若波罗蜜。能作是功德。是时四天王皆大欢喜意念言。我等当以四钵奉上菩萨。如前天王奉先佛钵。三十三天乃至他化自在天亦皆欢喜意念言。我等当给侍供养菩萨。减损阿修罗种。增益诸天众。三千大千国土。四天王天乃至阿迦尼吒天皆大欢喜意念言。我等当请是菩萨转法轮。舍利弗。是菩萨摩诃萨行般若波罗蜜。增益六波罗蜜时。诸善男子善女人。各各欢喜念言。我等当为是人作父母妻子亲族知识。尔时四天王天乃至阿迦尼吒天皆大欢喜。各自念言。我等当作方便。令是菩萨离于淫欲。从初发意常作童真。莫使与色欲共会。若受五欲障生梵天。何况阿耨多罗三藐三菩提。以是故。舍利弗。菩萨摩诃萨断淫欲出家者。应得阿耨多罗三藐三菩提非不断。舍利弗白佛言。世尊。菩萨摩诃萨要当有父母妻子亲族知识耶。佛告舍利弗。或有菩萨有父母妻子亲族知识。或有菩萨从初发心断淫欲修童真行。乃至得阿耨多罗三藐三菩提不犯色欲。或有菩萨方便力故受五欲已。出家得阿耨多罗三藐三菩提。譬如幻师若幻弟子。善知幻法幻作五欲于中共相娱乐。于汝意云何。是人于此五欲颇有实受不。舍利弗言。不也世尊。佛告舍利弗。菩萨摩诃萨以方便力故化作五欲。于中受乐成就众生亦复如是。是菩萨摩诃萨不染于欲。种种因缘毁呰五欲。欲为炽然欲为秽恶。欲为毁坏欲为如怨。是故舍利弗。当知菩萨为众生故受五欲

舍利弗白佛言。菩萨摩诃萨云何应行般若波罗蜜。佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。不见菩萨不见菩萨字。不见般若波罗蜜亦不见我行般若波罗蜜。亦不见我不行般若波罗蜜。何以故。菩萨菩萨字性空。空中无色无受想行识。离色亦无空。离受想行识亦无空。色即是空。空即是色。受想行识即是空。空即是识。何以故。舍利弗。但有名字故谓为菩提。但有名字故谓为菩萨。但有名字故谓为空。所以者何。诸法实性。无生无灭无垢无净故。菩萨摩诃萨如是行。亦不见生亦不见灭。亦不见垢亦不见净。何以故。名字是因缘和合作法。但分别忆想假名说。是故菩萨摩诃萨行般若波罗蜜时。不见一切名字。不见故不着

    摩诃般若波罗蜜经习应品第三(丹本名为习相应品)

佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。应如是思惟。菩萨但有名字佛亦但有字。般若波罗蜜亦但有字。色但有字受想行识亦但有字。舍利弗。如我但有字。一切我常不可得。众生寿者命者生者。养育众数人者。作者使作者。起者使起者。受者使受者。知者见者。是一切皆不可得。不可得空故。但以名字说。菩萨摩诃萨亦如是行般若波罗蜜。不见我不见众生。乃至不见知者见者。所说名字亦不可见。菩萨摩诃萨作如是行般若波罗蜜。除佛智慧。过一切声闻辟支佛上。用不可得空故。所以者何。是菩萨摩诃萨诸名字法。名字所著处。亦不可得故。舍利弗。菩萨摩诃萨能如是行。为行般若波罗蜜。譬如满阎浮提竹麻稻茅。诸比丘其数如是。智慧如舍利弗目揵连等。欲比菩萨行般若波罗蜜智慧百分不及一。千分百千亿分乃至算数譬喻所不能及。何以故。菩萨摩诃萨用智慧度脱一切众生故。舍利弗。置满阎浮提如舍利弗目揵连等。若满三千大千国土如舍利弗目揵连等。复置是事。若满十方如恒河沙等国土。如舍利弗目揵连等智慧。欲比菩萨行般若波罗蜜智慧。百分不及一。千分百千亿分。乃至算数譬喻所不能及。复次舍利弗。菩萨摩诃萨行般若波罗蜜。一日修智慧。出过一切声闻辟支佛上。舍利弗白佛言。世尊。声闻所有智慧。若须陀洹斯陀含阿那含阿罗汉辟支佛智慧佛智慧。是诸众智无有差别。不相违背无生性空。若法不相违背无生性空。是法无有别异。云何世尊言菩萨摩诃萨行般若波罗蜜一日修智慧出过声闻辟支佛上。佛告舍利弗。于汝意云何。菩萨摩诃萨行般若波罗蜜一日修智慧。心念我行道慧益一切众生。当以一切种智知一切法。度一切众生。诸声闻辟支佛智慧。为有是事不。舍利弗言。不也世尊。舍利弗。于汝意云何。诸声闻辟支佛颇有是念。我等当得阿耨多罗三藐三菩提度一切众生。令得无余涅槃不。舍利弗言。不也世尊。佛告舍利弗。以是因缘故。当知诸声闻辟支佛智慧。欲比菩萨摩诃萨智慧。百分不及一千分百千亿分。乃至算数譬喻所不能及。舍利弗。于汝意云何。诸声闻辟支佛颇有是念。我行六波罗蜜成就众生庄严国土。具佛十力四无所畏四无阂智十八不共法。度脱无量阿僧祇众生。令得涅槃不。舍利弗言。不也世尊。佛告舍利弗。菩萨摩诃萨能作是念。我当行六波罗蜜乃至十八不共法。成阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃。譬如萤火虫不作是念。我力能照阎浮提普令大明。诸阿罗汉辟支佛亦如是不作是念。我等行六波罗蜜乃至十八不共法。得阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃。舍利弗。譬如日出时。光明遍照阎浮提。无不蒙明者。菩萨摩诃萨亦如是。行六波罗蜜乃至十八不共法。得阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃。舍利弗白佛言。云何菩萨摩诃萨。过声闻辟支佛地。住阿惟越致地。净于佛道。佛告舍利弗。菩萨摩诃萨从初发意行六波罗蜜。住空无相无作法。能过一切声闻辟支佛地。住阿惟越致地。净于佛道。舍利弗白佛言。菩萨摩诃萨住何等地。能为诸声闻辟支佛作福田。佛告舍利弗。菩萨摩诃萨从初发意行六波罗蜜。乃至坐道场。于其中间。常为诸声闻辟支佛作福田。何以故。以有菩萨摩诃萨因缘故。世间诸善法生。何等是善法。所谓十善道五戒八分成就斋。四禅四无量心四无色定。四念处四正勤四如意足。五根五力七觉分八圣道分。尽现于世。以菩萨因缘故。六波罗蜜十八空佛十力四无所畏四无阂智。十八不共法大慈大悲一切种智。尽现于世。以菩萨因缘故。有刹利大姓婆罗门大姓居士大家。四天王天乃至非有想非无想天。皆现于世。以菩萨因缘故。有须陀洹斯陀含阿那含阿罗汉辟支佛佛皆现于世。舍利弗白佛言。菩萨摩诃萨净毕施福不。佛言不也。何以故。本已净毕故。舍利弗。菩萨摩诃萨为大施主。施何等。施诸善法。何等善法。十善道五戒乃至十八不共法一切种智。以是施与。舍利弗白佛言。世尊。菩萨摩诃萨云何习应般若波罗蜜与般若波罗蜜相应。佛告舍利弗。菩萨摩诃萨习应色空。是名与般若波罗蜜相应。习应受想行识空。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨习应眼空。是名与般若波罗蜜相应。习应耳鼻舌身心空。是名与般若波罗蜜相应。习应色空。是名与般若波罗蜜相应。习应声香味触法空。是名与般若波罗蜜相应。习应眼界空色界空眼识界空。是名与般若波罗蜜相应。习应耳声识。鼻香识。舌味识。身触识。意法识界空。是名与般若波罗蜜相应。习应苦空。是名与般若波罗蜜相应。习应集灭道空。是名与般若波罗蜜相应。习应无明空。是名与般若波罗蜜相应。习应行识名色六入触受爱取有生老死空。是名与般若波罗蜜相应。习应一切诸法空。若有为若无为。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨习应性空。是名与般若波罗蜜相应。如是舍利弗。菩萨摩诃萨行般若波罗蜜。习应七空。所谓性空自相空诸法空无所得空无法空有法空无法有法空。是名与般若波罗蜜相应。佛告舍利弗。菩萨摩诃萨习应七空时。不见色若相应若不相应。不见受想行识若相应若不相应。不见色若生相若灭相。不见受想行识若生相若灭相。不见色若垢相若净相。不见受想行识若垢相若净相。不见色与受合。不见受与想合。不见想与行合。不见行与识合。何以故。无有法与法合者。其性空故。舍利弗。色空中无有色。受想行识空中无有识。舍利弗。色空故无恼坏相。受空故无受相。想空故无知相。行空故无作相。识空故无觉相。何以故。舍利弗。色不异空空不异色。色即是空空即是色。受想行识亦如是。舍利弗。是诸法空相。不生不灭。不垢不净不增不减。是空法非过去非未来非现在。是故空中无色无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界乃至无意识界。亦无无明亦无无明尽。乃至亦无老死亦无老死尽。无苦集灭道。亦无智亦无得。亦无须陀洹无须陀洹果。无斯陀含无斯陀含果。无阿那含无阿那含果。无阿罗汉无阿罗汉果。无辟支佛无辟支佛道。无佛亦无佛道。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。舍利弗。是菩萨摩诃萨行般若波罗蜜。不见般若波罗蜜。若相应若不相应。不见檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。若相应若不相应。亦不见色若相应若不相应。不见受想行识。若相应若不相应。不见眼乃至意色乃至法。眼色识界乃至意法识界。若相应若不相应。不见四念处乃至八圣道分。佛十力乃至一切种智。若相应若不相应。如是舍利弗。当知菩萨摩诃萨与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。空不与空合。无相不与无相合。无作不与无作合。何以故。空无相无作。无有合与不合。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。入诸法自相空。入已色不作合不作不合。受想行识不作合不作不合。色不与前际合。何以故。不见前际故。色不与后际合。何以故。不见后际故。色不与现在合。何以故。不见现在故。受想行识亦如是。复次舍利弗。菩萨摩诃萨行般若波罗蜜。前际不与后际合。后际不与前际合。现在不与前际后际合。前际后际亦不与现在合。三际名空故。舍利弗。菩萨摩诃萨如是习应者。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。萨婆若不与过去世合。何以故。过去世不可见。何况萨婆若与过去世合。萨婆若不与未来世合。何以故。未来世不可见。何况萨婆若与未来世合。萨婆若不与现在世合。何以故。现在世不可见。何况萨婆若与现在世合。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。色不与萨婆若合。色不可见故。受想行识亦如是。眼不与萨婆若合。眼不可见故。耳鼻舌身意亦如是。色不与萨婆若合。色不可见故。声香味触法亦如是。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。檀那波罗蜜不与萨婆若合。檀那波罗蜜不可见故。乃至般若波罗蜜亦如是四念处不与萨婆若合。四念处不可见故。乃至八圣道分亦如是。佛十力乃至十八不共法。不与萨婆若合。佛十力乃至十八不共法不可见故。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。佛不与萨婆若合。萨婆若不与佛合。菩提不与萨婆若合。萨婆若不与菩提合。何以故。佛即是萨婆若。萨婆若即是佛。菩提即是萨婆若。萨婆若即是菩提。舍利弗。菩萨摩诃萨行般若波罗蜜如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不习色有不习色无。受想行识亦如是。不习色有常。不习色无常。受想行识亦如是不习色苦不习色乐。受想行识亦如是。不习色我不习色非我。受想行识亦如是。不习色寂灭不习色不寂灭。受想行识亦如是。不习色空不习色非空。受想行识亦如是。不习色有相不习色无相。受想行识亦如是。不习色有作不习色无作。受想行识亦如是。是菩萨摩诃萨行般若波罗蜜时不作是念。我行般若波罗蜜不行般若波罗蜜。非行非不行般若波罗蜜。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨不为般若波罗蜜故行般若波罗蜜。不为檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜故行般若波罗蜜。不为阿惟越致地故行般若波罗蜜。不为成就众生故行般若波罗蜜。不为净佛国土故行般若波罗蜜。不为佛十力四无所畏。四无阂智十八不共法故行般若波罗蜜。不为内空故行般若波罗蜜。不为外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空诸法空自相空不可得空无法空有法空无法有法空故行般若波罗蜜。不为如法性实际故行般若波罗蜜。何以故。是菩萨摩诃萨行般若波罗蜜时。不坏诸法相故。如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不为如意神通故行般若波罗蜜。不为天耳故。不为他心智故。不为宿命智故。不为天眼故。不为漏尽神通故行般若波罗蜜。何以故。菩萨摩诃萨行般若波罗蜜。尚不见般若波罗蜜。何况见菩萨神通。舍利弗。菩萨摩诃萨如是行。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我以如意神通飞到东方。供养恭敬如恒河沙等诸佛。南西北方四维上下亦如是。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我以天耳闻十方诸佛所说法。不作是念。我以他心智知十方众生心所念。不作是念。我以宿命通知十方众生宿命所作。不作是念。我以天眼见十方众生死此生彼。舍利弗。菩萨摩诃萨如是行。是名与般若波罗蜜相应。亦能度无量阿僧祇众生。舍利弗。菩萨摩诃萨能如是行般若波罗蜜。恶魔不能得其便。世间众事所欲随意。十方各如恒河沙等诸佛。皆悉拥护是菩萨。令不堕声闻辟支佛地。四天王天乃至阿迦尼吒天。皆亦拥护是菩萨不令有阂。是菩萨所有重罪现世轻受。何以故。是菩萨摩诃萨用普慈加众生故。舍利弗。菩萨摩诃萨如是行。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。疾得诸陀罗尼门诸三昧门。所生处常值诸佛。乃至阿耨多罗三藐三菩提初不离见佛。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。有法与法若合若不合若等若不等。何以故。是菩萨摩诃萨不见是法与余法。若合若不合。若等若不等。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我当疾得法性若不得。何以故。法性非得相故。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不见有法出法性者。如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。法性分别诸法。如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。是法能得法性若不得。何以故。是菩萨不见用是法能得法性若不得。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。法性不与空合。空不与法性合。如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。眼界不与空合。空不与眼界合。色界不与空合。空不与色界合。眼识界不与空合。空不与眼识界合。乃至意界不与空合。空不与意界合。法界不与空合。空不与法界合。意识界不与空合。空不与意识界合。是故舍利弗。是空相应名为第一相应。舍利弗。空行菩萨摩诃萨。不堕声闻辟支佛地。能净佛土成就众生。疾得阿耨多罗三藐三菩提。舍利弗。诸相应中般若波罗蜜相应。为最第一。最尊最胜最妙为无有上。何以故。是菩萨摩诃萨行般若波罗蜜相应。所谓空无相无作故。当知是菩萨如受记无异若近受记。舍利弗。菩萨摩诃萨如是相应者。能为无量阿僧祇众生作益厚。是菩萨摩诃萨亦不作是念。我与般若波罗蜜相应。诸佛当授我记。我当近受记。我当净佛土我得阿耨多罗三藐三菩提当转法轮。何以故。是菩萨摩诃萨不见有法出法性者。亦不见有法行般若波罗蜜。亦不见有法诸佛授记。亦不见有法得阿耨多罗三藐三菩提。何以故。菩萨摩诃萨行般若波罗蜜时。不生我相众生相。乃至知者见者相。何以故。众生毕竟不生不灭故。众生无有生无有灭。若法无有生相无有灭相。云何有法当行般若波罗蜜。如是舍利弗。菩萨摩诃萨不见众生故。为行般若波罗蜜。众生不受故众生空故。众生不可得故众生离故。为行般若波罗蜜。舍利弗。菩萨摩诃萨于诸相应中。为最第一相应。所谓空相应。是空相应胜余相应。菩萨摩诃萨如是习空。能生大慈大悲。菩萨摩诃萨。如是习相应。不生悭心。不生犯戒心。不生嗔心。不生懈怠心。不生乱心。不生无智心

摩诃般若经卷第一摩诃般若波罗蜜经卷第二

        后秦龟兹国三藏鸠摩罗什译

    往生品第四

舍利弗白佛言。世尊。菩萨摩诃萨行般若波罗蜜。能如是习相应者。从何处终来生此间。从此间终当生何处。佛告舍利弗。是菩萨摩诃萨行般若波罗蜜。能如是习相应者。或从他方佛国。来生此间。或从兜率天上来生此间。或从人道中来生此间。舍利弗。从他方佛国来者。疾与般若波罗蜜相应。与般若波罗蜜相应故。舍身来生此间。诸深妙法皆现在前。后还与般若波罗蜜相应。在所生处常值诸佛。舍利弗。有一生补处菩萨。兜率天上终来生是间。是菩萨不失六波罗蜜。随所生处。一切陀罗尼门诸三昧门。疾现在前。舍利弗。有菩萨人中命终还生人中者。除阿惟越致。是菩萨根钝不能疾与般若波罗蜜相应。诸陀罗尼门诸三昧门。不能疾现在前。舍利弗。汝所问菩萨摩诃萨。与般若波罗蜜相应。从此间终当生何处者。舍利弗。此菩萨摩诃萨。从一佛国至一佛国。常值诸佛终不离诸佛。舍利弗。有菩萨摩诃萨不以方便入初禅乃至第四禅。亦行六波罗蜜。是菩萨摩诃萨得禅故生长寿天。随彼寿终来生是间。得人身值遇诸佛。是菩萨诸根不利。舍利弗。有菩萨摩诃萨入初禅乃至第四禅。亦行般若波罗蜜。不以方便故舍诸禅生欲界。是菩萨诸根亦钝。舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。入慈心乃至舍。入虚空处乃至非有想非无想处。修四念处乃至八圣道分。行佛十力乃至大慈大悲。是菩萨用方便力不随禅生。不随无量心生。不随四无色定生。在所有佛处于中生。常不离般若波罗蜜行。如是菩萨贤劫中当得阿耨多罗三藐三菩提。舍利弗。有菩萨摩诃萨入初禅乃至第四禅。入慈心乃至舍。入虚空处乃至非有想非无想处。以方便力故。不随禅生还生欲界。若刹利大姓婆罗门大姓居士大家生。为成就众生故。舍利弗。有菩萨摩诃萨入初禅乃至第四禅。入慈心乃至舍入虚空处乃至非有想非无想处。以方便力故。不随禅生或生四天王天处。或生三十三天。夜摩天兜率陀天化乐天他化自在天。于是中成就众生亦净佛土。常值诸佛。舍利弗。有菩萨摩诃萨行般若波罗蜜。以方便力故入初禅。此间命终生梵天处作大梵王。从梵天处游一佛国。至一佛国。在所有诸佛得阿耨多罗三藐三菩提。未转法轮者劝请令转。舍利弗。有菩萨摩诃萨一生补处行般若波罗蜜。以方便力故入初禅乃至第四禅。入慈心乃至舍。入虚空处乃至非有想非无想处。修四念处乃至八圣道分。入空三昧无相无作三昧。不随禅生。生有佛处修梵行。若生兜率天上随其寿终。具足善根不失正念。与无数百千亿万诸天。围绕恭敬来生此间。得阿耨多罗三藐三菩提。复次舍利弗。有菩萨摩诃萨得六神通。不生欲界色界无色界。从一佛国至一佛国。供养恭敬尊重赞叹诸佛。舍利弗。有菩萨摩诃萨游戏神通。从一佛国至一佛国。所至到处无有声闻辟支佛乘。乃至无二乘之名。舍利弗。有菩萨摩诃萨游戏神通。从一佛国至一佛国。所至到处其寿无量。舍利弗。有菩萨摩诃萨游戏神通。从一国土至一国土。所至到处有无佛法僧处。赞佛法僧功德。诸众生用闻佛名法名僧名故。于此命终生诸佛前。舍利弗。有菩萨摩诃萨初发意时得初禅乃至第四禅。得四无量心。得四无色定。修四念处乃至十八不共法。是菩萨不生欲界色界无色界中。常生有益众生之处。舍利弗。有菩萨摩诃萨初发意时行六波罗蜜。上菩萨位得阿惟越致地。舍利弗。有菩萨摩诃萨初发意时。便得阿耨多罗三藐三菩提转法轮。与无量阿僧祇众生作益厚。已入无余涅槃。是佛般涅槃后。余法若住一劫若减一劫。舍利弗。有菩萨摩诃萨初发意时与般若波罗蜜相应。与无数百千亿菩萨。从一佛国至一佛国。为净佛国土故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。得四禅四无量心。四无色定。游戏其中入初禅。从初禅起入灭尽定。从灭尽定起乃至入四禅。后四禅起入灭尽定。从灭尽定起入虚空处。从虚空处起入灭尽定。从灭尽定起乃至入非有想非无想处。从非有想非无想处起入灭尽定。如是舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力故入超越定。舍利弗。有菩萨摩诃萨行般若波罗蜜时。修四念处乃至十八不共法。不取须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。以方便力为度众生故。起八圣道分。以是八圣道分令得须陀洹果乃至辟支佛道。佛告舍利弗。一切阿罗汉辟支佛果及智。是菩萨摩诃萨无生法忍。舍利弗是菩萨摩诃萨。如是行般若波罗蜜。当知是阿惟越致地中住。舍利弗。有菩萨摩诃萨住六波罗蜜。庄严兜率天道。当知是贤劫中菩萨。舍利弗。有菩萨摩诃萨修四禅乃至十八不共法。未证四谛。当知是菩萨一生补处。舍利弗。有菩萨摩诃萨无量阿僧祇劫修行得阿耨多罗三藐三菩提。舍利弗。有菩萨摩诃萨住六波罗蜜。常勤精进利益众生。不说无益之事。舍利弗。有菩萨摩诃萨行六波罗蜜。常勤精进利益众生。从一佛国至一佛国。断众生三恶道。舍利弗。有菩萨摩诃萨住六波罗蜜。以檀那为首安乐一切众生。须饮食与饮食。衣服卧具璎珞花香房舍灯烛。随人所须尽给与之。舍利弗。有菩萨摩诃萨行般若波罗蜜时。变身如佛为地狱中众生说法。为畜生饿鬼中众生说法。舍利弗。有菩萨摩诃萨行六波罗蜜时变身如佛。遍至十方如恒河沙等诸佛国土。为众生说法。亦供养诸佛及净佛国土。闻诸佛说法。观采十方净妙国相。而已自起殊胜国土。其中菩萨摩诃萨。皆是一生补处。舍利弗。有菩萨摩诃萨行六波罗蜜时。成就三十二相诸根净利。诸根净利故。众人爱敬。以爱敬故渐以三乘法而度脱之。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。应学身清净口清净。舍利弗。有菩萨摩诃萨行六波罗蜜时得诸根净。以是净根而不自高亦不下他。舍利弗。有菩萨摩诃萨从初发心。住檀那波罗蜜尸罗波罗蜜乃至阿惟越致地。终不堕三恶道。舍利弗。有菩萨摩诃萨。从初发心乃至阿惟越致地。常不舍十善行。舍利弗。有菩萨摩诃萨。住檀那波罗蜜尸罗波罗蜜中。作转轮圣王。安立众生于十善道。亦以财物布施众生。舍利弗。有菩萨摩诃萨。住檀那波罗蜜尸罗波罗蜜。无量千万世作转轮圣王。值遇无量百千诸佛。供养恭敬尊重赞叹。舍利弗。有菩萨摩诃萨。常为众生以法照明。亦以自照乃至阿耨多罗三藐三菩提。终不离照明。舍利弗。是菩萨摩诃萨。于佛法中已得尊重。舍利弗。以是故菩萨摩诃萨行般若波罗蜜时。身口意不净不令妄起。舍利弗白佛言。世尊。云何菩萨身业不净口业不净意业不净。佛告舍利弗。若菩萨摩诃萨作是念。是身是口是意。如是取相作缘。舍利弗。是名身口意不净。舍利弗。菩萨摩诃萨行般若波罗蜜时。不得身不得口不得意。舍利弗。菩萨摩诃萨行般若波罗蜜时。若得身若得口若得意。用是得身口意故。能生悭心犯戒心嗔心懈心乱心愚心。当知是菩萨行六波罗蜜时。不能除身口意粗业。舍利弗白佛言。世尊。菩萨摩诃萨。云何除身口意粗业。佛告舍利弗。若菩萨摩诃萨不得身口意。如是菩萨摩诃萨。能除身口意粗业。复次舍利弗。若菩萨摩诃萨从初发意行十善道。不生声闻心不生辟支佛心。如是菩萨摩诃萨。能除身口意粗业。复次舍利弗。有菩萨摩诃萨行般若波罗蜜净佛道时。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。是名菩萨摩诃萨除身口意粗业。舍利弗白佛言。世尊。何等是菩萨摩诃萨佛道。佛告舍利弗。佛道者。若菩萨摩诃萨不得身不得口不得意。不得檀那波罗蜜。不得尸罗波罗蜜不得羼提波罗蜜。不得毗梨耶波罗蜜。不得禅那波罗蜜。不得般若波罗蜜。不得声闻不得辟支佛。不得菩萨不得佛。舍利弗。是名菩萨摩诃萨佛道。所谓一切诸法不可得故。舍利弗。有菩萨摩诃萨。行六波罗蜜时无能坏者。舍利弗白佛言。世尊。云何菩萨摩诃萨行六波罗蜜时无能坏者。佛告舍利弗。若菩萨摩诃萨行六波罗蜜时。不念有色乃至识不念有眼乃至意。不念有色乃至法。不念有眼界乃至意识界。不念有四念处乃至八圣道分。不念有檀那波罗蜜乃至般若波罗蜜。不念有佛十力乃至十八不共法。不念有须陀洹果乃至阿罗汉果。不念有辟支佛乃至阿耨多罗三藐三菩提。舍利弗。菩萨摩诃萨如是行增益六波罗蜜。无能坏者。舍利弗。有菩萨摩诃萨住般若波罗蜜中具足智慧。用是智慧常不堕恶道。不生弊恶人中。不作贫穷人。所受身体不为人天阿修罗所憎恶。舍利弗白佛言。世尊。何等是菩萨摩诃萨智慧。佛告舍利弗。菩萨摩诃萨用是智慧成就见十方如恒河沙等诸佛听法见僧。亦见严净佛土。菩萨摩诃萨以是智慧。不作佛想不作菩萨想。不作声闻辟支佛想。不作我想不作佛国想。用是智慧。行檀那波罗蜜亦不得檀那波罗蜜。乃至行般若波罗蜜亦不得般若波罗蜜。行四念处亦不得四念处。乃至行十八不共法亦不得十八不共法。舍利弗。是名菩萨摩诃萨智慧。用是智慧能具足一切法。亦不得一切法。舍利弗。有菩萨摩诃萨行般若波罗蜜时。净于五眼肉眼天眼慧眼法眼佛眼。舍利弗白佛言。世尊。云何菩萨摩诃萨肉眼净。佛告舍利弗。有菩萨肉眼见百由旬。有菩萨肉眼见二百由旬。有菩萨肉眼见一阎浮提。有菩萨肉眼见二天下三天下四天下。有菩萨肉眼见小千国土。有菩萨肉眼见中千国土。有菩萨肉眼见三千大千国土。舍利弗。是为菩萨摩诃萨肉眼净。舍利弗白佛言。世尊。云何菩萨摩诃萨天眼净。佛告舍利弗。有菩萨摩诃萨天眼见一切四天王天所见。见三十三天夜摩天兜率陀天化乐天他化自在天所见。见梵天王所见乃至阿迦尼吒天所见。菩萨天眼所见者。四天王天乃至阿迦尼吒天所不知不见。舍利弗。是菩萨摩诃萨天眼。见十方如恒河沙等诸国土中。众生死此生彼。舍利弗。是名菩萨摩诃萨天眼净。舍利弗白佛言。世尊。云何菩萨摩诃萨慧眼净。佛告舍利弗。慧眼菩萨不作是念。有法若有为若无为。若世间若出世间。若有漏若无漏。是慧眼菩萨。亦无法不见无法不闻。无法不知无法不识。舍利弗。是名菩萨摩诃萨慧眼净。舍利弗白佛言。世尊。云何菩萨摩诃萨法眼净。佛告舍利弗。菩萨摩诃萨。以法眼知是人随信行。是人随法行。是人无相行。是人行空解脱门。是人行无相解脱门。是人行无作解脱门得五根。得五根故得无间三昧。得无间三昧故得解脱智。得解脱智故断三结我见疑戒取。是人名须陀洹。是人得思惟道。薄淫恚痴当得斯陀含。增进思惟道。断淫恚痴得阿那含。增进思惟道。断色染无色染无明慢掉得阿罗汉。是人行空无相无作解脱门得五根。得五根故得无间三昧。得无间三昧故得解脱智。得解脱智故知所有集法皆是灭法。作辟支佛。是为菩萨摩诃萨法眼净。复次舍利弗。菩萨摩诃萨知是菩萨初发意。行檀那波罗蜜乃至行般若波罗蜜。成就信根精进根善根纯厚用方便力故。为众生受身。若生刹利大姓。若生婆罗门大姓。若生居士大家。若生四天王天处。乃至他化自在天处。是菩萨于其中住成就众生。随其所乐皆给施之。亦净佛国土值遇诸佛。供养恭敬尊重赞叹。乃至阿耨多罗三藐三菩提。亦不堕声闻辟支佛地。是名菩萨摩诃萨法眼净。复次舍利弗。菩萨摩诃萨。知是菩萨于阿耨多罗三藐三菩提退。知是菩萨于阿耨多罗三藐三菩提不退。知是菩萨受阿耨多罗三藐三菩提记。知是菩萨未受阿耨多罗三藐三菩提记。知是菩萨到阿惟越致地。知是菩萨未到阿惟越致地。知是菩萨具足神通。知是菩萨未具足神通。知是菩萨以具足神通。飞到十方如恒河沙等世界。见诸佛供养恭敬尊重赞叹。知是菩萨未得神通当得神通。知是菩萨当净佛土。不净佛土。是菩萨成就众生未成就众生。是菩萨为诸佛所称誉所不称誉。是菩萨亲近诸佛不亲近诸佛。是菩萨寿命有量寿命无量。是菩萨得佛时。比丘众有量比丘众无量。是菩萨得阿耨多罗三藐三菩提时。以菩萨为僧。不以菩萨为僧。是菩萨当修苦行难行。不修苦行难行。是菩萨一生补处。未一生补处。是菩萨受最后身。未受最后身。是菩萨能坐道场。不能坐道场。是菩萨有魔无魔。如是舍利弗。是为菩萨摩诃萨法眼净。舍利弗白佛言。世尊。云何菩萨摩诃萨佛眼净。佛告舍利弗。有菩萨摩诃萨求佛道心。次第入如金刚三昧。得一切种智。尔时成就十力四无所畏四无阂智十八不共法。大慈大悲。是菩萨摩诃萨用一切种智。一切法中无法不见无法不闻。无法不知无法不识。舍利弗。是为菩萨摩诃萨。得阿耨多罗三藐三菩提时佛眼净。如是舍利弗。菩萨摩诃萨欲得五眼。当学六波罗蜜。何以故。舍利弗。是六波罗蜜中摄一切善法。若声闻法辟支佛法菩萨法佛法。舍利弗。若有实语能摄一切善法者。般若波罗蜜是。舍利弗。般若波罗蜜能生五眼。菩萨学五眼者。得阿耨多罗三藐三菩提。舍利弗。有菩萨摩诃萨行般若波罗蜜时。修神通波罗蜜。以是神通波罗蜜受种种如意事。能动大地变一身为无数身无数身还为一身。隐显自在。山壁树木皆过无阂如行空中履水如地陵虚如鸟。出没地中如出入水。身出烟焰如大火聚。身中出水如雪山水流。日月大德威力难当而能摩扪。乃至梵天身得自在。亦不着是如意神通。神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我得如意神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得如意神通智证。是菩萨以天耳净过于人耳。闻二种声天声人声。亦不着是天耳神通。天耳与声及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是天耳。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得天耳神通智证。是菩萨。如实知他众生心若欲心。如实知欲心。离欲心。如实知离欲心。嗔心。如实知嗔心。离嗔心。如实知离嗔心。痴心。如实知痴心。离痴心。如实知离痴心。渴爱心。如实知渴爱心。无渴爱心。如实知无渴爱心。有受心。如实知有受心。无受心。如实知无受心。摄心。如实知摄心。散心。如实知散心。小心。如实知小心。大心。如实知大心。定心。如实知定心。乱心。如实知乱心。解脱心。如实知解脱心。不解脱心。如实知不解脱心。有上心。如实知有上心。无上心。如实知无上心。亦不着是心。何以故。是心非心相不可思议故。自性空故。自性离故。自性无生故。不作是念。我得他心智证。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得他心神通智证。是菩萨以宿命智证通。念一心乃至百心。念一日乃至百日。念一月乃至百月。念一岁乃至百岁。念一劫乃至百劫无数百劫。无数千劫。无数百千劫。乃至无数百千万亿劫世。我是处。如是姓。如是名字。如是生。如是食。如是久住。如是寿限。如是长寿。如是受苦乐。我是中死生彼处。彼处死生是处。有相有因缘。亦不着是宿命神通。宿命神通事及己身。皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是宿命神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨。行般若波罗蜜时。得宿命神智证。是菩萨以天眼。见众生死时生时端正丑陋。恶处好处。若大若小。知众生随业因缘。是诸众生身恶业成就口恶业成就意恶业成就故。谤毁贤圣人。受邪见因缘故。身坏堕恶道生地狱中。是诸众生。身善业成就口善业成就意善业成就。不谤毁贤圣人。受正见因缘故。命终入善道生天上。亦不着是天眼通。天眼通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是天眼神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得天眼神通智证。亦见十方如恒河沙等世界中众生生死。乃至生天上。四神通亦如是。是菩萨摩诃萨漏尽神通。虽得漏尽神通。不堕声闻辟支佛地。乃至阿耨多罗三藐三菩提。亦不依异法。亦不着是漏尽神通。漏尽神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我得漏尽神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得漏尽神通智证。如是舍利弗。菩萨摩诃萨。行般若波罗蜜时具足神通波罗蜜。具足神通波罗蜜已。增益阿耨多罗三藐三菩提。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住檀那波罗蜜净萨婆若道毕竟空不生悭心故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住尸罗波罗蜜净萨婆若道毕竟空罪不罪不着故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住羼提波罗蜜净萨婆若道毕竟空。不嗔故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住毗梨耶波罗蜜净萨婆若道毕竟空。身心精进不懈怠故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住禅那波罗蜜。净萨婆若道毕竟空。不乱不味故。舍利弗。有菩萨摩诃萨行般若波罗蜜时。住般若波罗蜜净萨婆若道毕竟空。不生痴心故。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。住六波罗蜜净萨婆若道毕竟空故。不来不去故。不施不受故。非戒非犯故。非忍非嗔故。不进不怠故。不定不乱故。不智不愚故。尔时菩萨摩诃萨。不分别布施不布施。持戒犯戒。忍辱嗔恚。精进懈怠。定心乱心。智慧愚痴。不分别毁害轻慢恭敬。何以故。舍利弗。无生法中无有受毁者。无有受害者。无有受轻慢恭敬者。舍利弗。菩萨摩诃萨行般若波罗蜜得如是诸功德。声闻辟支佛所无有得。是功德具足成就众生净佛国土。得一切种智。复次舍利弗。菩萨摩诃萨。行般若波罗蜜时。一切众生中生等心。一切众生中生等心已。得一切诸法等。得一切诸法等已。立一切众生于诸法等中。是菩萨摩诃萨。现世为十方诸佛所爱念。亦为一切菩萨一切声闻辟支佛所爱念。是菩萨在所生处。眼终不见不爱色。乃至意不觉不爱法。如是舍利弗。菩萨摩诃萨行般若波罗蜜。不减于阿耨多罗三藐三菩提。说是般若波罗蜜品时。三百比丘从座起。以所著衣上佛。发阿耨多罗三藐三菩提心。佛尔时微笑。种种色光从口中出。尔时慧命阿难。从座起整衣服。合掌右膝着地。白佛言。佛何因缘微笑。佛告阿难。是三百比丘。从是已后六十一劫当作佛。皆号名大相。是三百比丘舍此身。当生阿閦佛国。及六万欲天子皆发阿耨多罗三藐三菩提心。于弥勒佛法中出家行佛道。是时佛之威神故。此间四部众见十方面各千佛。是十方国土严净。此娑婆国土所不及。尔时十千人作愿。我等修净愿行。修净愿行故当生彼佛世界。尔时佛知是善男子深心。而佛微笑。种种光从口中出。阿难。整衣服合掌白佛。佛何因缘微笑。佛告阿难。汝见是十千人不。阿难言见。佛言。是十千人于此寿终。当生彼世界终不离诸佛。后当作佛皆号庄严王佛

    摩诃般若波罗蜜经叹度品第五

尔时慧命舍利弗。慧命大目揵连。慧命须菩提。慧命摩诃迦叶。如是等诸多知识比丘。及诸菩萨摩诃萨。诸优婆塞优婆夷。从座起合掌白佛言。世尊。摩诃波罗蜜是菩萨摩诃萨般若波罗蜜。尊波罗蜜。第一波罗蜜。胜波罗蜜。妙波罗蜜。无上波罗蜜。无等波罗蜜。无等等波罗蜜。如虚空波罗蜜。是菩萨摩诃萨般若波罗蜜。世尊。自相空波罗蜜。是菩萨摩诃萨般若波罗蜜。世尊。自性空波罗蜜。是菩萨摩诃萨般若波罗蜜。诸法空波罗蜜。无法有法空波罗蜜。开一切功德波罗蜜。成就一切功德波罗蜜。不可坏波罗蜜。是诸菩萨摩诃萨般若波罗蜜。诸菩萨摩诃萨。行是般若波罗蜜无等等布施。具足无等等檀那波罗蜜。得无等等身。得无等等法。所谓阿耨多罗三藐三菩提尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜亦如是。世尊。本亦复行此般若波罗蜜。具足无等等六波罗蜜。得无等等法。得无等等色。得无等等受想行识。佛转无等等法轮。过去佛亦如是。行此般若波罗蜜。具足无等等布施。乃至转无等等法轮。未来世佛亦行此般若波罗蜜。当作无等等布施。乃至当转无等等法轮。以是故。世尊。菩萨摩诃萨欲度一切彼岸。当习行般若波罗蜜。世尊。是行般若波罗蜜菩萨摩诃萨。一切世间天及人阿修罗应当礼敬供养。佛告众弟子及诸菩萨摩诃萨。如是如是。诸善男子。是行般若波罗蜜者。一切世间天及人阿修罗。应当作礼恭敬供养。何以故。因菩萨来故。出生人道天道刹利大姓。婆罗门大姓。居士大家。转轮圣王四天王天。乃至阿迦尼吒天。出生须陀洹乃至阿罗汉辟支佛诸佛。因菩萨来故。世间便有饮食衣服卧具房舍灯烛摩尼真珠颇梨琉璃珊瑚金银等诸宝物生。舍利弗。世间所有乐具。若人中若天上若离欲乐。是一切乐具皆由菩萨有。何以故。舍利弗。菩萨摩诃萨行菩萨道时。住六波罗蜜自行布施。亦以布施成就众生。乃至自行般若波罗蜜。亦以般若波罗蜜成就众生。舍利弗。是故菩萨摩诃萨为安乐一切众生故。出现于世

    摩诃般若波罗蜜经舌相品第六

尔时世尊出舌相遍覆三千大千世界从其舌相出无数无量色光明。普照十方如恒河沙等诸佛世界。是时东方如恒河沙等世界中无量无数诸菩萨见是大光明。各各白其佛言。世尊。是谁力故有是大光明普照诸佛世界。诸佛告诸菩萨言。诸善男子。西方有世界名娑婆。是中有佛名释迦牟尼。是其舌相出大光明。普照东方如恒河沙等诸佛世界。南西北方四维上下亦复如是。为诸菩萨摩诃萨说般若波罗蜜故。是时诸菩萨各白其佛言。我欲往供养释迦牟尼佛及诸菩萨摩诃萨。并欲听般若波罗蜜。诸佛告诸菩萨善男子。汝自知时。是时诸菩萨摩诃萨持诸供养具无量花盖幢幡璎珞众香金银宝花。向娑婆世界诣释迦牟尼佛所。尔时四天王诸天乃至阿迦尼吒诸天。各持天上天香末香泽香天树香叶香。天种种莲花青赤红白。向释迦牟尼佛所。是诸菩萨摩诃萨及诸天。所散诸花。于三千大千世界虚空中。化成四柱大宝台。种种异色庄严分明。是时释迦牟尼佛众中有十万亿人。皆从座起合掌白佛言。世尊。我等于未来世中亦当得如是法。如今释迦牟尼佛弟子侍从大众说法亦尔。是时佛知善男子至心于一切诸法不生不灭不出不作得是法忍。佛便微笑。种种色光从口中出。阿难白佛言。世尊。何因缘故微笑。佛告阿难。是众中十万亿人于诸法中得无生忍。是诸人于未来世。过六十八亿劫当作佛。劫名花积。佛皆号觉花

    摩诃般若波罗蜜经三假品第七

尔时佛告慧命须菩提。汝当教诸菩萨摩诃萨般若波罗蜜。如诸菩萨摩诃萨所应成就般若波罗蜜。即时诸菩萨摩诃萨及声闻大弟子诸天等作是念。慧命须菩提。自以智慧力。当为诸菩萨摩诃萨说般若波罗蜜耶。为是佛力。慧命须菩提。知诸菩萨摩诃萨大弟子诸天心所念。语慧命舍利弗。诸佛弟子所说法。所教授皆是佛力。佛所说法。法相不相违背。是善男子。学是法得证此法。佛说如灯。舍利弗。一切声闻辟支佛。实无是力。能为菩萨摩诃萨说般若波罗蜜。尔时慧命须菩提白佛言。世尊。所说菩萨菩萨字何等法名菩萨。世尊。我等不见是法名菩萨。云何教菩萨般若波罗蜜。佛告须菩提。般若波罗蜜亦但有名字。名为般若波罗蜜。菩萨菩萨字亦但有名字。是名字不在内不在外不在中间。须菩提。譬如说我名。和合故有。是我名不生不灭。但以世间名字故说。如众生寿者命者生者养育者。众数人作者使作者。起者使起者。受者使受者。知者见者等。和合法故有。是诸名不生不灭。但以世间名字故说般若波罗蜜。菩萨菩萨字亦如是。皆和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如身和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如色受想行识。亦和合故有。是亦不生不灭。但以世间名字故说。须菩提。般若波罗蜜。菩萨菩萨字亦如是。皆是和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如眼和合故有。是亦不生不灭。但以世间名字故说。是眼不在内不在外不在中间。耳鼻舌身意和合故有。是亦不生不灭。但以世间名字故说。色乃至法亦如是。眼界和合故有。是亦不生不灭。但以世间名字故说。乃至意识界亦如是。须菩提。般若波罗蜜菩萨菩萨字亦如是。皆和合故有。是亦不生不灭。但以世间名字故说。是名字不在内不在外不在中间。须菩提。譬如内身名为头但有名字。项肩臂脊胁髀膞脚皆和合故有。是法及名字亦不生不灭。但以名字故说。是名字亦不在内亦不在外不在中间。须菩提。般若波罗蜜菩萨菩萨字亦如是。皆和合故有。但以名字故说。是亦不生不灭。不在内不在外不在中间。须菩提。譬如外物草木枝叶茎节。如是一切但以名字故说。是法及名字亦不生不灭。非内非外非中间住。须菩提。般若波罗蜜菩萨菩萨字亦如是。皆和合故有。是法及名字亦不生不灭。非内非外非中间住。须菩提。譬如过去诸佛名。和合故有。是亦不生不灭。但以名字故说。是亦非内非外非中间住。般若波罗蜜菩萨菩萨字亦如是。须菩提。譬如梦响影幻焰。佛所化皆是和合故有。但以名字说。是法及名字不生不灭。非内非外非中间住。般若波罗蜜菩萨菩萨字亦如是。如是须菩提。菩萨摩诃萨行般若波罗蜜。名假施设。受假施设。法假施设。如是应当学。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不见色名字是常。不见受想行识名字是常。不见色名字无常。不见受想行识名字无常。不见色名字乐。不见色名字苦。不见色名字我。不见色名字无我。不见色名字空。不见色名字无相。不见色名字无作。不见色名字寂灭。不见色名字垢。不见色名字净。不见色名字生。不见色名字灭。不见色名字内。不见色名字外。不见色名字中间住。受想行识亦如是。眼色眼识眼触。眼触因缘生诸受。乃至意法意识意触。意触因缘生诸受亦如是。何以故。菩萨摩诃萨行般若波罗蜜。般若波罗蜜字。菩萨菩萨字。有为性中亦不见。无为性中亦不见。菩萨摩诃萨行般若波罗蜜。是法皆不作分别。是菩萨行般若波罗蜜。住不坏法中。修四念处时。不见般若波罗蜜。不见般若波罗蜜字。不见菩萨。不见菩萨字。乃至修十八不共法时。不见般若波罗蜜。不见般若波罗蜜字。不见菩萨。不见菩萨字。菩萨摩诃萨如是行般若波罗蜜时。但知诸法实相。诸法实相者。无垢无净。如是须菩提。菩萨摩诃萨行般若波罗蜜时。当作是知名字假施设。知假名字已。不着色不着受想行识。不着眼乃至意。不着色乃至法。不着眼识。乃至不着意识。不着眼触。乃至不着意触。不着眼触因缘生受。若苦若乐若不苦不乐。乃至不着意触因缘生受。若苦若乐若不苦不乐。不著有为性。不着无为性。不着檀那波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅那波罗蜜。般若波罗蜜。不着三十二相。不着菩萨身。不着菩萨肉眼。乃至不着佛眼。不着智波罗蜜。不着神通波罗蜜。不着内空。乃至不着无法有法空。不着成就众生。不着净佛国土。不着方便法。何以故。是诸法无著者。无著法。无著处。皆无故。如是须菩提。菩萨摩诃萨行般若波罗蜜时。不着一切法。便增益檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。入菩萨位得阿惟越致地。具足菩萨神通。游一佛国至一佛国成就众生。恭敬尊重赞叹诸佛。为净佛国土。为见诸佛供养。供养之具。善根成就故随意悉得。亦闻诸佛所说法。闻已乃至阿耨多罗三藐三菩提终不忘失得诸陀罗尼门诸三昧门。如是须菩提。菩萨摩诃萨行般若波罗蜜时。当知诸法名假施设。须菩提。于汝意云何。色是菩萨不。受想行识是菩萨不。不也世尊。眼耳鼻舌身意是菩萨不。不也世尊。色声香味触法是菩萨不。不也世尊。眼识乃至意识是菩萨不。不也世尊。须菩提。于汝意云何。地种是菩萨不。不也世尊。水火风空识种是菩萨不。不也世尊。于须菩提意云何。无明是菩萨不。不也世尊。乃至老死是菩萨不。不也世尊。于须菩提意云何。离色离受想行识乃至离老死是菩萨不。不也世尊。须菩提于汝意云何。色如相是菩萨不。不也世尊。乃至老死如相是菩萨不。不也世尊。离色如相乃至离老死如相是菩萨不。不也世尊。佛告须菩提。汝观何等义。言色非菩萨。乃至老死非菩萨。离色非菩萨。乃至离老死非菩萨。色如相非菩萨。乃至老死如相非菩萨。离色如相非菩萨。乃至离老死如相非菩萨。须菩提言。世尊。众生毕竟不可得。何况当是菩萨。色不可得。何况色离色。色如离色如。是菩萨。乃至老死不可得。何况老死离老死。老死如离老死如。是菩萨。佛告须菩提。善哉善哉。如是须菩提。菩萨摩诃萨众生不可得故。般若波罗蜜亦不可得。当作是学。于须菩提意云何。色是菩萨义不。不也世尊。受想行识是菩萨义不。不也世尊。于须菩提意云何。色常是菩萨义不。不也世尊。受想行识常。是菩萨义不。不也世尊。色无常是菩萨义不。不也世尊。受想行识无常。是菩萨义不。不也世尊。色乐是菩萨义不。不也世尊。受想行识乐。是菩萨义不。不也世尊。色苦是菩萨义不。不也世尊。受想行识苦。是菩萨义不。不也世尊。色我是菩萨义不。不也世尊。受想行识我。是菩萨义不。不也世尊。色非我是菩萨义不。不也世尊。受想行识非我。是菩萨义不。不也世尊。于须菩提意云何。色空是菩萨义不。不也世尊。受想行识空。是菩萨义不。不也世尊。色非空是菩萨义不。不也世尊。受想行识非空。是菩萨义不。不也世尊。色相是菩萨义不。不也世尊。受想行识相。是菩萨义不。不也世尊。色无相。是菩萨义不。不也世尊。受想行识无相。是菩萨义不。不也世尊。色作是菩萨义不。不也世尊。受想行识作。是菩萨义不。不也世尊。色无作是菩萨义不。不也世尊。受想行识无作。是菩萨义不。不也世尊。乃至老死亦如是。佛告须菩提。汝观何等义。言色非菩萨义。受想行识非菩萨义。乃至色受想行识无作。非菩萨义。乃至老死亦如是。须菩提白佛言。世尊。色毕竟不可得。何况色是菩萨义。受想行识亦如是。世尊。色常毕竟不可得。何况色无常是菩萨义。乃至识亦如是。世尊。色乐毕竟不可得。何况色苦是菩萨义。乃至识亦如是。世尊。色我毕竟不可得。何况色非我是菩萨义。乃至识亦如是。世尊。色有毕竟不可得。何况色空是菩萨义。乃至识亦如是。世尊。色相毕竟不可得。何况色无相是菩萨义。乃至识亦如是。世尊。色作毕竟不可得。何况色无作是菩萨义。乃至识亦如是。佛告须菩提。善哉善哉。如是须菩提。菩萨摩诃萨行般若波罗蜜。色义不可得。受想行识义不可得乃至无作义不可得。当作是学般若波罗蜜。须菩提。汝言我不见是法名菩萨。须菩提。诸法不见诸法。诸法不见法性。法性不见诸法。法性不见地种。地种不见法性。乃至识种不见法性。法性不见识种。法性不见眼色眼识性。眼色眼识性不见法性。乃至法性不见意法意识性。意法意识性不见法性。须菩提。有为性不见无为性。无为性不见有为性。何以故。离有为不可说无为。离无为不可说有为。如是须菩提。菩萨摩诃萨行般若波罗蜜。于诸法无所见。是时不惊不畏不怖。心亦不没不悔。何以故。是菩萨摩诃萨不见色受想行识故。不见眼乃至意。不见色乃至法。不见淫怒痴。不见无明乃至老死。不见我乃至知者见者。不见欲界色界无色界。不见声闻心辟支佛心。不见菩萨不见菩萨法。不见佛不见佛法不见佛道。是菩萨一切法不见故。不惊不畏不怖不没不悔。须菩提白佛言。世尊。何因缘故。是菩萨心不没不悔。佛告须菩提。菩萨摩诃萨一切心心数法。不可得不可见。以是故。菩萨摩诃萨心不没不悔。世尊。云何菩萨心不惊不畏不怖。佛告须菩提。是菩萨意及意识。不可得不可见。以是故。不惊不畏不怖。如是须菩提。菩萨摩诃萨一切法不可得故。应行般若波罗蜜。须菩提。菩萨摩诃萨一切行处。不得般若波罗蜜。不得菩萨。不得菩萨名。亦不得菩萨心。即是教菩萨摩诃萨

摩诃般若经卷第二摩诃般若波罗蜜经卷第三

        后秦龟兹国三藏鸠摩罗什译

    劝学品第八

尔时须菩提白佛言。世尊。菩萨摩诃萨欲具足檀那波罗蜜。当学般若波罗蜜。欲具足尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。当学般若波罗蜜。菩萨摩诃萨欲知色。当学般若波罗蜜。乃至欲知识。当学般若波罗蜜。欲知眼乃至意。欲知色乃至法。欲知眼识乃至意识。欲知眼触乃至意触。欲知眼触因缘生受乃至意触因缘生受。当学般若波罗蜜。欲断淫怒痴。当学般若波罗蜜。菩萨摩诃萨欲断身见戒取疑淫欲嗔恚。色爱无色爱。调慢无明等。一切结使及缠。当学般若波罗蜜。欲断四缚四结四颠倒。当学般若波罗蜜。欲知十善道。欲知四禅。欲知四无量心四无色定四念处乃至十八不共法。当学般若波罗蜜。菩萨摩诃萨欲入觉意三昧。当学般若波罗蜜。欲入六神通九次第定超越三昧。当学般若波罗蜜。欲得师子游戏三昧。当学般若波罗蜜。欲得师子奋迅三昧。欲得一切陀罗尼门。当学般若波罗蜜。菩萨摩诃萨欲得首楞严三昧。宝印三昧。妙月三昧。月幢相三昧。一切法印三昧。观印三昧。毕法性三昧。毕住相三昧。如金刚三昧。入一切法门三昧。三昧王三昧。王印三昧。净力三昧。高出三昧。必入一切辩才三昧。入诸法名三昧。观十方三昧。诸陀罗尼门印三昧。一切法不忘三昧。摄一切法聚印三昧。虚空住三昧。三分清净三昧。不退神通三昧出钵三昧。诸三昧幢相三昧。欲得如是等诸三昧门。当学般若波罗蜜。复次世尊。菩萨摩诃萨欲满一切众生愿。当学般若波罗蜜。欲得具足如是善根常不堕恶趣。欲得不生卑贱之家。欲得不住声闻辟支佛地中。欲得不堕菩萨顶者。当学般若波罗蜜。尔时慧命舍利弗问须菩提。云何为菩萨摩诃萨堕顶。须菩提言舍利弗。若菩萨摩诃萨不以方便行六波罗蜜。入空无相无作三昧。不堕声闻辟支佛地。亦不入菩萨位。是名菩萨摩诃萨法生故堕顶。舍利弗问须菩提。云何名菩萨生。须菩提答舍利弗言。生名法爱。舍利弗言。何等法爱。须菩提言。菩萨摩诃萨行般若波罗蜜。色是空受念着。受想行识是空受念着。舍利弗。是名菩萨摩诃萨顺道法爱生。复次舍利弗。菩萨摩诃萨色是无相受念着。受想行识是无相受念着。色是无作受念着。受想行识是无作受念着。色是寂灭受念着。受想行识是寂灭受念着。色是无常乃至识。色是苦乃至识。色是无我乃至识。受念着。是为菩萨顺道法爱生。是苦应知。集应断。尽应证。道应修。是垢法是净法。如应近是不应近。是菩萨所应行。是非菩萨所应行。是菩萨道是非菩萨道。是菩萨学是非菩萨学。是菩萨檀那波罗蜜。乃至般若波罗蜜。是非菩萨檀那波罗蜜。乃至般若波罗蜜。是菩萨方便是非菩萨方便。是菩萨熟是非菩萨熟。舍利弗。菩萨摩诃萨行般若波罗蜜。是诸法受念着。是为菩萨摩诃萨顺道法爱生。舍利弗问须菩提。云何名菩萨摩诃萨无生。须菩提言。菩萨摩诃萨行般若波罗蜜时。内空中不见外空。外空中不见内空。外空中不见内外空。内外空中不见外空。内外空中不见空空。空空中不见内外空。空空中不见大空。大空中不见空空。大空中不见第一义空。第一义空中不见大空。第一义空中不见有为空。有为空中不见第一义空。有为空中不见无为空。无为空中不见有为空。无为空中不见毕竟空。毕竟空中不见无为空。毕竟空中不见无始空。无始空中不见毕竟空。无始空中不见散空。散空中不见无始空。散空中不见性空。性空中不见散空。性空中不见诸法空。诸法空中不见性空。诸法空中不见自相空。自相空中不见诸法空。自相空中不见不可得空。不可得空中不见自相空。不可得空中不见无法空。无法空中不见不可得空。无法空中不见有法空。有法空中不见无法空。有法空中不见无法有法空。无法有法空中不见有法空。舍利弗。菩萨摩诃萨行般若波罗蜜。得入菩萨位。复次舍利弗。菩萨摩诃萨欲学般若波罗蜜应如是学。不念色受想行识。不念眼乃至意。不念色乃至法。不念檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜乃至十八不共法。如是舍利弗。菩萨摩诃萨行般若波罗蜜。得是心不应念不应高。无等等心不应念不应高。大心不应念不应高。何以故。是心非心。心相常净故。舍利弗语须菩提。云何名心相常净。须菩提言。若菩萨知是心相。与淫怒痴不合不离。诸缠流缚若诸结使。一切烦恼不合不离。声闻辟支佛心不合不离。舍利弗。是名菩萨心相常净。舍利弗语须菩提。有是无心相心不。须菩提报舍利弗言。无心相中。有心相无心相可得不。舍利弗言。不可得。须菩提言。若不可得。不应问有是无心相心不。舍利弗复问。何等是无心相。须菩提言。诸法不坏不分别。是名无心相。舍利弗复问须菩提。但是心不坏不分别。色亦不坏不分别。乃至佛道亦不坏不分别耶。须菩提言。若能知心相不坏不分别。是菩萨亦能知色乃至佛道不坏不分别。尔时慧命舍利弗赞须菩提言。善哉善哉。汝真是佛子从佛口生。从见法生从法化生。取法分不取财分。法中自信身得证。如佛所说。得无诤三昧中汝最第一。实如佛所举。须菩提。菩萨摩诃萨应如是学般若波罗蜜。是中亦当分别知。菩萨如汝所说行。则不离般若波罗蜜。须菩提。善男子善女人。欲学声闻地亦当应闻般若波罗蜜。持诵读正忆念如说行。欲学辟支佛地亦当应闻般若波罗蜜。持诵读正忆念如说行。欲学菩萨地亦当应闻般若波罗蜜。持诵读正忆念如说行。何以故。是般若波罗蜜中广说三乘。是中菩萨摩诃萨声闻辟支佛当学

    摩诃般若波罗蜜经集散品第九

尔时慧命须菩提白佛言。世尊。我不觉不得是菩萨行般若波罗蜜。当为谁说般若波罗蜜。世尊。我不得一切诸法集散。若我为菩萨作字言菩萨或当有悔。世尊。是字不住亦不不住。何以故。是字无所有故。以是故。是字不住亦不不住。世尊。我不得色集散乃至识集散。若不可得云何当作名字。世尊。以是因缘故。是字不住亦不不住。何以故。是字无所有故。世尊。我亦不得眼集散乃至意集散。若不可得云何当作名字言是菩萨。世尊。是眼名字乃至意名字。不住亦不不住。何以故。是名字无所有故。以是故。是字不住亦不不住。世尊。我不得色集散乃至法集散。若不可得云何当作名字言是菩萨。世尊。是色字乃至法字不住亦不不住。何以故。是字无所有故。以是故。是字不住亦不不住。眼识乃至意识。眼触乃至意触。眼触因缘生受。乃至意触因缘生受亦如是。世尊。我不得无明集散。乃至不得老死集散。世尊。我不得无明尽集散。乃至不得老死尽集散。世尊。我不得淫怒痴集散诸邪见集散。皆亦如是。世尊。我不得六波罗蜜集散四念处集散乃至八圣道分集散。空无相无作集散。四禅四无量心四无色定集散。念佛念法念僧念戒念舍念天。念善念入出息念身念死集散。我亦不得佛十力。乃至十八不共法集散。世尊。我若不得六波罗蜜。乃至十八不共法集散。云何当作字言是菩萨。世尊。是字不住亦不不住。何以故。是字无所有故。以是故。是字不住亦不不住。世尊。我不得如梦五阴集散。我亦不得如向如影如焰如化五受阴集散。亦如上说。世尊。我不得离集散。我不得寂灭不生不灭。不示不垢不净集散。世尊。我不得如法性实际法相法位集散。亦如上说。我不得诸善不善法集散。我不得有为无为法有漏无漏法集散。过去未来现在法集散。不过去不未来不现在法集散。何等是不过去不未来不现在。所谓无为法。世尊。我亦不得无为法集散。世尊。我亦不得佛集散。世尊。我亦不得十方如恒河沙等世界诸佛。及菩萨声闻集散。世尊。若我不得诸佛集散。云何当教菩萨摩诃萨般若波罗蜜。世尊。是菩萨字不住亦不不住。何以故。是字无所有故。以是故。是字不住亦不不住。世尊。我不得是诸法实相集散。云何当与菩萨作字言是菩萨世尊。是诸法实相。名字不住亦不不住。何以故。是名字无所有故。以是故。是名字不住亦不不住。世尊。诸法因缘和合假名施设。所谓菩萨是名字。于五荫中不可说。十二入十八界乃至十八不共法中不可说。于和合法中亦无可说。世尊。譬如梦于诸法中不可说。向影焰化于诸法中。亦不可说。譬如名虚空。亦无法中可说。世尊。如地水火风名。亦无法中可说。戒三昧智慧解脱解脱知见名。亦无法中可说。如须陀洹名字。乃至阿罗汉辟支佛名字。亦无法中可说如佛名法名。亦无法中可说。所谓若善若不善。若常若无常。若苦若乐。若我若无我。若寂灭若离。若有若无。世尊。我以是义故。心悔一切诸法集散相不可得。云何为菩萨作字言是菩萨。世尊。是字不住亦不不住。何以故。是字无所有故。以是故。是字不住亦不不住。世尊。若菩萨摩诃萨闻作是说般若波罗蜜。如是相如是义。心不没不悔不惊不畏不怖。当知是菩萨必住阿惟越致性中。住不住法故。复次世尊。菩萨摩诃萨欲行般若波罗蜜。色中不应住。受想行识中不应住。眼耳鼻舌身意中不应住。色声香味触法中不应住。眼识乃至意识中不应住。眼触乃至意触中不应住。眼触因缘生受。乃至意触因缘生受中不应住。地种。水火风种空识种中不应住。无明乃至老死中不应住。何以故。世尊。色色相空。受想行识识相空。世尊。色空不名为色。离空亦无色。色即是空空即是色。受想行识。识空不名为识离空亦无识。识即是空空即是识。乃至老死老死相空。世尊。老死空不名老死。离空亦无老死。老死即是空。空即是老死。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。不应色中住。乃至老死中不应住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。四念处中不应住。何以故。四念处四念处相空。世尊。四念处空不名四念处。离空亦无四念处。四念处即是空。空即是四念处。乃至十八不共法亦如是。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。四念处乃至十八不共法中不应住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。檀那波罗蜜中不应住。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜中不应住。何以故。檀那波罗蜜檀那波罗蜜相空。乃至般若波罗蜜般若波罗蜜相空。世尊。檀那波罗蜜空不名檀那波罗蜜。离空亦无檀那波罗蜜。檀那波罗蜜即是空。空即是檀那波罗蜜。乃至般若波罗蜜亦如是。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。不应六波罗蜜中住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。文字中不应住。一字门二字门。如是种种字门中不应住。何以故。诸字诸字相空故。亦如上说。复次世尊。菩萨摩诃萨欲行般若波罗蜜。诸神通中不应住。何以故。诸神通诸神通相空。神通空不名神通。离空亦无神通。神通即是空。空即是神通。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。诸神通中不应住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。色是无常不应住。受想行识是无常不应住。何以故。无常无常相空。世尊。无常空不名无常。离空亦无无常。无常即是空。空即是无常。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。色是无常不应住。受想行识是无常不应住。色是苦不应住。受想行识是苦不应住。色是无我不应住。受想行识是无我不应住。色是空不应住。受想行识是空不应住。色是寂灭不应住。受想行识是寂灭不应住。色是离不应住。受想行识是离不应住。亦如上说。复次世尊。菩萨摩诃萨欲行般若波罗蜜。如中不应住。何以故。如如相空。世尊。如相空不名如。离空亦无如。如即是空空即是如。世尊。菩萨摩诃萨欲行般若波罗蜜。法性法相法位实际中不应住。何以故。实际实际空。世尊。实际空不名实际。离空亦无实际。实际即是空。空即是实际。复次世尊。菩萨摩诃萨欲行般若波罗蜜。一切陀罗尼门中不应住。一切三昧门中不应住。何以故。陀罗尼门陀罗尼门相空。三昧门三昧门相空。世尊。陀罗尼门三昧门空。不名陀罗尼门三昧门。离空亦无陀罗尼三昧门。陀罗尼三昧门即是空。空即是陀罗尼三昧门。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜如乃至陀罗尼三昧门中不应住。世尊。如菩萨摩诃萨欲行般若波罗蜜无方便故。以吾我心于色中住。是菩萨作色行。以吾我心于受想行识中住。是菩萨作识行。若菩萨作行者。不受般若波罗蜜。亦不具足般若波罗蜜。不具足般若波罗蜜故。不能得成就萨婆若。世尊。如菩萨摩诃萨欲行般若波罗蜜无方便故。以吾我心于十二入乃至陀罗尼三昧门中住。是菩萨作十二入乃至作陀罗尼三昧门行。若菩萨作行者。不受般若波罗蜜。亦不具足般若波罗蜜。不具足般若波罗蜜。故。不能得成就萨婆若。何以故。色是不受。受想行识是不受。色不受则非色。性空故。受想行识不受则非识。性空故。十二入是不受。乃至陀罗尼三昧门是不受。十二入不受则非十二入。乃至陀罗尼三昧门不受则非陀罗尼三昧门。性空故。般若波罗蜜亦不受。般若波罗蜜不受则非般若波罗蜜。性空故。如是菩萨摩诃萨欲行般若波罗蜜。应观诸法性空。如是观心无行处。是名菩萨摩诃萨不受三昧广大之用。不与声闻辟支佛共。是萨婆若慧。亦不受内空故。外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空故。何以故。是萨婆若不可以相行得相行有垢故。何等是垢相。色相乃至陀罗尼三昧门相。是名垢相。是相若受若修。可得萨婆若者。先尼梵志。于一切智中终不生信。云何为信。信般若波罗蜜。分别解知称量思惟。不以相法。不以无相法。如是先尼梵志。不取相住信行中。用性空智入诸法相中。不受色不受受想行识。何以故。诸法自相空故不可得受。是先尼梵志。非内观得故见是智慧。非外观得故。见是智慧。非内外观得故。见是智慧。亦不无智慧观得故见是智慧。何以故梵志不见是法。智者知法知处故。此梵志非内色中见是智慧。非内受想行识中见是智慧。非外色中见是智慧。非外受想行识中见是智慧。非内外色中见是智慧。非内外受想行识中见是智慧。亦不离色受想行识中见是智慧。内外空故。先尼梵志此中心得信解于一切智。以是故。梵志信诸法实相。一切法不可得故。如是信解已无法可受。诸法无相无忆念故。是梵志于诸法亦无所得。无取无舍。取舍不可得故。是梵志亦不念智慧。诸法相无念故。世尊。是名菩萨摩诃萨般若波罗蜜。此彼岸不度故。是菩萨色受想行识不受。一切法不受故。乃至诸陀罗尼三昧门亦不受。一切法不受故。是菩萨于是中亦不取涅槃。未具足四念处乃至八圣道分。未具足十力乃至十八不共法故。何以故。是四念处非四念处。乃至十八不共法。非十八不共法。是诸法非法亦不非法。是名菩萨摩诃萨般若波罗蜜。色不受乃至十八不共法不受。复次世尊。菩萨摩诃萨欲行般若波罗蜜。应如是思惟。何者是般若波罗蜜。何以故。名般若波罗蜜。是谁般若波罗蜜。若菩萨摩诃萨行般若波罗蜜如是念。若法无所有不可得是般若波罗蜜。尔时舍利弗问须菩提。何等法。无所有不可得。须菩提言。般若波罗蜜是法无所有不可得。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。是法无所有不可得。内空故。外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空故。舍利弗。色法无所有不可得。受想行识法无所有不可得。内空法无所有不可得。乃至无法有法空法。无所有不可得。舍利弗。四念处法无所有不可得。乃至十八不共法。无所有不可得。舍利弗。诸神通法无所有不可得。如如法无所有不可得。法性法相法位法住实际法。无所有不可得。舍利弗。佛无所有不可得。萨婆若法无所有不可得。一切种智法无所有不可得。内空乃至无法有法空故。舍利弗。若菩萨摩诃萨如是思惟如是观时。心不没不悔不惊不畏不怖。当知是菩萨不离般若波罗蜜行。舍利弗问须菩提。何因缘故。当知菩萨不离般若波罗蜜行。须菩提言。色离色性。受想行识离识性。六波罗蜜离六波罗蜜性。乃至实际离实际性。舍利弗复问须菩提。云何是色性。云何是受想行识性。云何乃至实际性。须菩提言。无所有是色性。无所有是受想行识性。乃至无所有是实际性。舍利弗。以是因缘故。当知色离色性。受想行识离识性。乃至实际离实际性。舍利弗。色亦离色相。受想行识亦离识相。乃至实际亦离实际相。相亦离相。性亦离性。舍利弗问须菩提。菩萨摩诃萨若如是学。得成就萨婆若耶。须菩提言。如是如是。舍利弗。若菩萨摩诃萨如是学得成就萨婆若。何以故。以诸法不生不成就故。舍利弗问须菩提。何因缘故诸法不生不成就。须菩提言。色色空。是色生成就不可得。受想行识识空。是识生成就不可得。乃至实际实际空。是实际生成就不可得。舍利弗。菩萨摩诃萨如是学渐近萨婆若。渐得身清净心清净相清净。渐得身清净心清净相清净故。是菩萨不生染心不生嗔心不生痴心。不生憍慢心不生悭贪心不生邪见心。是菩萨不生染心。乃至不生邪见心故。终不生母人腹中。常得化生。从一佛国至一佛国。成就众生净佛国土。乃至阿耨多罗三藐三菩提。终不离诸佛。舍利弗。菩萨摩诃萨当作是行般若波罗蜜。当作是学般若波罗蜜

    摩诃般若波罗蜜经相行品第十

尔时须菩提白佛言。世尊。若菩萨摩诃萨无方便欲行般若波罗蜜。若行色为行相。若行受想行识为行相。若色是常行为行相。若受想行识是常行为行相。若色是无常行为行相。若受想行识是无常行为行相。若色是乐行为行相。若受想行识是乐行为行相。若色是苦行为行相。若受想行识是苦行为行相。若色是有行为行相。若受想行识是有行为行相。若色是空行为行相。若受想行识是空行为行相。若色是我行为行相。若受想行识是我行为行相。若色是无我行为行相。若受想行识是无我行为行相。若色是离行为行相。若受想行识是离行为行相。若色是寂灭行为行相。若受想行识是寂灭行为行相。世尊。若菩萨摩诃萨无方便行四念处为行相。乃至行十八不共法为行相。世尊。若菩萨摩诃萨行般若波罗蜜时作是念。我行般若波罗蜜。有所得行亦是行相。世尊。若菩萨摩诃萨作是念。能如是行是修行般若波罗蜜。亦是行相。当知是菩萨摩诃萨行般若波罗蜜无方便。须菩提语舍利弗。若菩萨摩诃萨行般若波罗蜜时。色受念妄解。若色受念妄解为色故作行。若为色故作行不能得离生老病死忧悲苦恼及后世苦。若菩萨摩诃萨行般若波罗蜜时无方便。眼受念妄解乃至意。色乃至法。眼识界乃至意识界。眼触乃至意触。眼触因缘生受乃至意触因缘生受。四念处乃至十八不共法受念妄解。为十八不共法故作行。若为作行。是菩萨不能得离生老病死忧悲苦恼及后世苦。如是菩萨尚不能得声闻辟支佛地证。何况得阿耨多罗三藐三菩提无有是处。舍利弗。当知是菩萨摩诃萨行般若波罗蜜无方便。舍利弗问须菩提。云何当知菩萨摩诃萨行般若波罗蜜有方便。须菩提语舍利弗。若菩萨摩诃萨欲行般若波罗蜜时。不行色不行受想行识。不行色相不行受想行识相。不行色受想行识常。不行色受想行识无常。不行色受想行识乐。不行色受想行识苦。不行色受想行识我。不行色受想行识无我。不行色受想行识空。不行色受想行识无相。不行色受想行识无作。不行色受想行识离。不行色受想行识寂灭。何以故。舍利弗。是色空为非色。离空无色离色无空。色即是空空即是色。受想行识空为非识。离空无识离识无空。空即是识识即是空。乃至十八不共法空。为非十八不共法。离空无十八不共法。离十八不共法无空。空即是十八不共法。十八不共法即是空。如是舍利弗。当知是菩萨摩诃萨行般若波罗蜜有方便。是菩萨摩诃萨如是行般若波罗蜜。能得阿耨多罗三藐三菩提。是菩萨摩诃萨行般若波罗蜜时。行亦不受不行亦不受。行不行亦不受。非行非不行亦不受。不受亦不受。舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜时。何因缘故不受。须菩提言。是般若波罗蜜自性不可得故不受。何以故。无所有法是般若波罗蜜。舍利弗。以是故。菩萨摩诃萨行般若波罗蜜。行亦不受不行亦不受。行不行亦不受。非行非不行亦不受。不受。亦不受。何以故。一切法性无所有。不随诸法行。不受诸法相故。是名菩萨摩诃萨诸法无所受三昧广大之用。不与声闻辟支佛共。是菩萨摩诃萨行是三昧不离。疾得阿耨多罗三藐三菩提。舍利弗言。但不离是三昧。令菩萨摩诃萨疾得阿耨多罗三藐三菩提。更有余三昧。须菩提语舍利弗言。更有诸三昧。菩萨摩诃萨行是三昧。疾得阿耨多罗三藐三菩提。舍利弗言。何等三昧菩萨摩诃萨行是。疾得阿耨多罗三藐三菩提。须菩提言。诸菩萨摩诃萨有三昧。名首楞严行是三昧令菩萨摩诃萨疾得阿耨多罗三藐三菩提。有名宝印三昧。师子游戏三昧。妙月三昧。月幢相三昧。出诸法印三昧。观顶三昧。毕法性三昧。毕幢相三昧。金刚三昧。入法印三昧。三昧王安立三昧。王印三昧。放光三昧。力进三昧。出生三昧。必入辩才三昧。入名字三昧。观方三昧。陀罗尼印三昧。不忘三昧。摄诸法海印三昧。遍覆虚空三昧。金刚轮三昧。宝断三昧。能照耀三昧。不求三昧。三昧无处住三昧。无心三昧。净灯三昧。无边明三昧。能作明三昧。普遍明三昧。坚净诸三昧。三昧无垢明三昧。作乐三昧。电光三昧。无尽三昧。威德三昧。离尽三昧。不动三昧。庄严三昧。日光三昧。月净三昧。净明三昧。能作明三昧。作行三昧。知相三昧。如金刚三昧。心住三昧。遍照三昧。安立三昧。宝顶三昧。妙法印三昧。法等三昧。生喜三昧。到法顶三昧。能散三昧。坏诸法处三昧。字等相三昧。离字三昧。断缘三昧。不坏三昧。无种相三昧。无处行三昧。离闇三昧。无去三昧。不动三昧。度缘三昧。集诸德三昧。住无心三昧。妙净花三昧。觉意三昧。无量辩三昧。无等等三昧。度诸法三昧。分别诸法三昧。散疑三昧。无住处三昧。一相三昧。生行三昧。一行三昧。不一行三昧。妙行三昧。达一切有底散三昧。入言语三昧。离音声字语三昧。然炬三昧。净相三昧。破相三昧。一切种妙足三昧。不喜苦乐三昧。不尽行三昧。多陀罗尼三昧。取诸邪正相三昧。灭憎爱三昧。逆顺三昧。净光三昧。坚固三昧。满月净光三昧。大庄严三昧。能照一切世三昧。等三昧。无诤行三昧。无住处乐三昧。如住定三昧。坏身三昧。坏语如虚空三昧。离着如虚空不染三昧。舍利弗。是菩萨摩诃萨行是诸三昧。疾得阿耨多罗三藐三菩提。复有无量阿僧祇三昧门陀罗尼门。菩萨摩诃萨学是三昧门陀罗尼门。疾得阿耨多罗三藐三菩提。慧命须菩提。随佛心言。当知诸菩萨摩诃萨行是三昧者。已为过去诸佛所授记。今现在十方诸佛亦授是菩萨记。是菩萨不见是诸三昧。亦不念是三昧。亦不念我当入是三昧我今入是三昧我已入是三昧。是菩萨摩诃萨都无分别念。舍利弗问须菩提。菩萨摩诃萨住是诸三昧已。从过去佛受记耶。须菩提报言。不也舍利弗。何以故。般若波罗蜜不异诸三昧。诸三昧不异般若波罗蜜。菩萨不异般若波罗蜜及三昧。般若波罗蜜及三昧不异菩萨。般若波罗蜜即是三昧。三昧即是般若波罗蜜。菩萨即是般若波罗蜜及三昧。般若波罗蜜及三昧即是菩萨。舍利弗语须菩提。若三昧不异菩萨。菩萨不异三昧。三昧即是菩萨。菩萨即是三昧。菩萨云何知一切诸法等三昧。须菩提言。若菩萨入是三昧。是时不作是念。我以是法入是三昧。以是因缘故。舍利弗。是菩萨于诸三昧。不知不念舍利弗言。何以故。不知不念。须菩提言。诸三昧无所有故。是菩萨不知不念。尔时佛赞言。善哉善哉。须菩提。如我说汝行无诤三昧第一。与此义相应。菩萨摩诃萨应如是学般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。四念处乃至十八不共法亦应如是学。舍利弗白佛言。世尊。菩萨摩诃萨如是学。为学般若波罗蜜耶。佛告舍利弗。菩萨摩诃萨如是学。为学般若波罗蜜。是法不可得故。乃至学檀那波罗蜜。是法不可得故。学四念处乃至十八不共法。是法不可得故。舍利弗白佛言。世尊。如是菩萨摩诃萨学般若波罗蜜。是法不可得耶。佛言。如是菩萨摩诃萨学般若波罗蜜。是法不可得。舍利弗言。世尊。何等法不可得。佛言。我不可得。乃至知者见者不可得。毕竟净故。五阴不可得。十二入不可得。十八界不可得。毕竟净故。无明不可得。毕竟净故。乃至老死不可得。毕竟净故。苦谛不可得。毕竟净故。集灭道谛不可得。毕竟净故。欲界不可得。毕竟净故。色界无色界不可得。毕竟净故。四念处不可得。毕竟净故。乃至十八不共法不可得。毕竟净故。六波罗蜜不可得。毕竟净故。须陀洹不可得。毕竟净故。斯陀含阿那含阿罗汉辟支佛不可得。毕竟净故。菩萨不可得。毕竟净故。佛不可得。毕竟净故。舍利弗。白佛言。世尊。何等是毕竟净。佛言。不出不生无得无作。是名毕竟净。舍利弗白佛言。世尊。菩萨摩诃萨若如是学。为学何等法。佛告舍利弗。菩萨摩诃萨如是学于诸法无所学。何以故。舍利弗。诸法相不如凡人所著。舍利弗白佛言。世尊。诸法实相云何有。佛言。诸法无所有。如是有如是无所有。是事不知名为无明。舍利弗白佛言。世尊。何等无所有。是事不知名为无明。佛告舍利弗。色受想行识无所有。内空乃至无法有法空故。四念处乃至十八不共法无所有。内空乃至无法有法空故。是中凡夫以无明力渴爱故。妄见分别说是无明。是凡夫为二边所缚。是人不知不见诸法无所有。而忆想分别着色乃至十八不共法。是人着故于无所有法而作识知见。是凡人不知不见。何等不知不见。不知不见色。乃至十八不共法亦不知不见。以是故。堕凡夫数如小儿。是人不出。于何不出。不出欲界不出色界不出无色界。不出声闻辟支佛法中。是人亦不信。不信何等。不信色空。乃至不信十八不共法空。是人不住。不住何等。不住檀那波罗蜜。乃至不住般若波罗蜜。不住阿惟越致地乃至十住十八不共法。以是因缘故。名为凡夫如小儿。亦名著者。何等为着。着色乃至识。着眼入乃至意入。着眼识界乃至意识界。着淫怒痴。着诸邪见。着四念处。乃至着佛道。舍利弗白佛言。世尊。菩萨摩诃萨作如是学。亦不学般若波罗蜜不得萨婆若。佛语舍利弗。菩萨摩诃萨作如是学。亦不学般若波罗蜜。不得萨婆若。舍利弗白佛言。世尊。何以故。菩萨摩诃萨亦不学般若波罗蜜。不得萨婆若。佛告舍利弗。菩萨摩诃萨无方便故。想念分别着般若波罗蜜。着禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。乃至十八不共法一切种智。想念分别着。以是因缘故。菩萨摩诃萨如是学。亦不学般若波罗蜜。不得萨婆若。舍利弗白佛言。世尊。若菩萨摩诃萨如是学。不学般若波罗蜜。不得萨婆若。佛告舍利弗。菩萨摩诃萨如是学。不学般若波罗蜜不得萨婆若。舍利弗白佛言。世尊。菩萨摩诃萨今云何应学般若波罗蜜得萨婆若。佛告舍利弗。若菩萨摩诃萨学般若波罗蜜时。不见般若波罗蜜。舍利弗。菩萨摩诃萨如是学般若波罗蜜得萨婆若。以不可得故。舍利弗白佛言。世尊。云何名不可得。佛言。诸法内空乃至无法有法空故

摩诃般若经卷第三摩诃般若波罗蜜经卷第四

        后秦龟兹国三藏鸠摩罗什译

    幻学品第十一(丹本云幻人品)

尔时慧命须菩提白佛言。世尊。若当有人问言。幻人学般若波罗蜜当得萨婆若不。幻人学禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。学四念处乃至十八不共法及一切种智。得萨婆若不。我当云何答。佛告须菩提。我还问汝。随汝意答我。须菩提。于汝意云何。色与幻有异不。受想行识与幻有异不。须菩提言。不也世尊。佛言。于汝意云何。眼与幻有异不。乃至意与幻有异不。色乃至法与幻有异不。眼界乃至意识界与幻有异不。眼触乃至意触。眼触因缘生受。乃至意触因缘生受。与幻有异不。须菩提言。不也世尊。于汝意云何。四念处与幻有异不。乃至八圣道分与幻有异不。不也世尊。于汝意云何。空无相无作与幻有异不。不也世尊。须菩提。于汝意云何。檀那波罗蜜与幻有异不。乃至十八不共法与幻有异不。不也世尊。须菩提。于汝意云何。阿耨多罗三藐三菩提与幻有异不。不也世尊。何以故。色不异幻幻不异色。色即是幻幻即是色。世尊。受想行识不异幻。幻不异受想行识。识即是幻幻即是识。世尊。眼不异幻幻不异眼。眼即是幻幻即是眼。眼触因缘生受。乃至意触因缘生受亦如是。世尊。四念处不异幻。幻不异四念处。四念处即是幻。幻即是四念处。乃至阿耨多罗三藐三菩提不异幻。幻不异阿耨多罗三藐三菩提。阿耨多罗三藐三菩提即是幻。幻即是阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。幻有垢有净不。不也世尊。须菩提。于汝意云何。幻有生有灭不。不也世尊。若幻不生不灭。是法能学般若波罗蜜当得萨婆若不。不也世尊。于汝意云何。五受荫假名是菩萨不。如是世尊。于汝意云何。五受荫假名有生灭垢净不。不也世尊。于汝意云何。若法但有名字。非身非身业。非口非口业。非意非意业。不生不灭不垢不净。如是法能学般若波罗蜜得萨婆若不。不也世尊。菩萨摩诃萨若能如是学般若波罗蜜。当得萨婆若。以无所得故。须菩提白佛言。世尊。菩萨摩诃萨应如是学般若波罗蜜。得阿耨多罗三藐三菩提如幻人学。何以故。世尊。当知五荫即是幻人。幻人即是五荫。佛告须菩提。于汝意云何。是五荫学般若波罗蜜当得萨婆若不。不也世尊。何以故。是五荫性无所有。无所有性亦不可得。佛告须菩提。于汝意云何。如梦五荫学般若波罗蜜。当得萨婆若不。不也世尊。何以故。梦性无所有。无所有性亦不可得。于汝意云何。如向如影如焰如化五荫。学般若波罗蜜当得萨婆若不。不也世尊。何以故。向影焰化性无所有无所有性亦不可得。六情亦如是世尊。五荫即是六情六情即是五荫。如是法皆内空故不可得。乃至无法有法空故不可得。须菩提白佛言。世尊。新发大乘意菩萨闻说般若波罗蜜将无恐怖。佛告须菩提。若新发大乘意菩萨于般若波罗蜜。无方便亦不得善知识。是菩萨或惊或怖或畏。须菩提白佛言。世尊。何等是方便。菩萨行是方便。不惊不畏不怖。佛告须菩提。有菩萨摩诃萨行般若波罗蜜。应萨婆若心。观色无常相。是亦不可得。观受想行识无常相。是亦不可得。须菩提。是名菩萨摩诃萨行般若波罗蜜有方便。复次须菩提。菩萨摩诃萨应萨婆若心。观色苦相。是亦不可得。受想行识亦如是。应萨婆若心。观色无我相。是亦不可得。受想行识亦如是。复次须菩提。菩萨摩诃萨应萨婆若心。观色空相是亦不可得。受想行识亦如是。观色无相相是亦不可得。受想行识亦如是。观色无作相是亦不可得。乃至识亦如是。观色寂灭相是亦不可得。乃至识亦如是。观色离相是亦不可得。乃至识亦如是。是名菩萨摩诃萨行般若波罗蜜有方便。复次须菩提。菩萨摩诃萨行般若波罗蜜。观色无常相是亦不可得。观色苦相无我相空相无相相无作相寂灭相离相。是亦不可得。受想行识亦如是。是时菩萨作是念。我当为一切众生说是无常法。是亦不可得。当为一切众生说苦相说无我相空相无相相无作相寂灭相离相。是亦不可得。是名菩萨摩诃萨檀那波罗蜜。复次须菩提。菩萨摩诃萨不以声闻辟支佛心。观色无常亦不可得。不以声闻辟支佛心。观识无常亦不可得。不以声闻辟支佛心。观色苦无我空无相无作寂灭离。亦不可得。受想行识亦如是。是名菩萨摩诃萨尸罗波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。是诸法无常相。乃至离相忍欲乐。是名菩萨摩诃萨羼提波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。应萨婆若心。观色无常相亦不可得。乃至离相亦不可得。受想行识亦如是。应萨婆若心不舍不息。是名菩萨摩诃萨毗梨耶波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。不起声闻辟支佛意及余不善心。是名菩萨摩诃萨禅那波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。如是思惟。不以空色故色空。色即是空空即是色。受想行识亦如是。不以空眼故眼空。眼即是空空即是眼。乃至意触因缘生受。不以空受。故受空。受即是空空即是受。不以空四念处故。四念处空。四念处即是空。空即是四念处。乃至不以空十八不共法故。十八不共法空。十八不共法即是空。空即是十八不共法。如是须菩提。菩萨摩诃萨行般若波罗蜜。不惊不畏不怖。须菩提白佛言。世尊。何等是菩萨摩诃萨善知识守护故。闻说是般若波罗蜜不惊不畏不怖。佛告须菩提。菩萨摩诃萨善知识者。说色无常亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。说受想行识无常亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说色苦亦不可得。说受想行识苦亦不可得。说色无我受想行识无我亦不可得。说色空无相无作寂灭离亦不可得。受想行识空无相无作寂灭离亦不可得。持是善根不向声闻辟支佛道。但向一切智。须菩提。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说眼无常乃至离亦不可得。乃至意触因缘生受。说无常乃至离亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说修四念处法乃至离亦不可得。持是善根不向声闻辟支佛道。但向一切智。须菩提是名菩萨摩诃萨善知识。乃至说修十八不共法。修一切智亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。须菩提白佛言。云何菩萨摩诃萨行般若波罗蜜无方便。随恶知识闻说是般若波罗蜜惊畏怖。佛告须菩提。菩萨摩诃萨离一切智心。修般若波罗蜜。得是般若波罗蜜。念是般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。皆得皆念。复次须菩提。菩萨摩诃萨离萨婆若心。观色内空乃至无法有法空。观受想行识内空乃至无法有法空。观眼内空乃至无法有法空。乃至意触因缘生受内空。乃至无法有法空。于诸法空有所念有所得。复次须菩提。菩萨摩诃萨行般若波罗蜜。离萨婆若心修四念处亦念亦得。乃至修十八不共法亦念亦得。如是须菩提。菩萨摩诃萨行般若波罗蜜。以无方便故闻是般若波罗蜜惊畏怖。须菩提白佛言。世尊。云何菩萨摩诃萨随恶知识闻般若波罗蜜惊畏怖。佛告须菩提。菩萨摩诃萨恶知识教离般若波罗蜜离禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。须菩提。是名菩萨摩诃萨恶知识。须菩提。菩萨摩诃萨复有恶知识。不说魔事不说魔罪不作是言。恶魔作佛形像来。教菩萨离六波罗蜜。语菩萨言。善男子。用修般若波罗蜜为。用修禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜为。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔复作佛形像到菩萨所。为说声闻经。若修妒路乃至忧波提舍。教诏分别演说如是经。不为说魔事魔罪。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔作佛形像到菩萨所作是语。善男子。汝无真菩萨心。亦非阿惟越致地。汝亦不能得阿耨多罗三藐三菩提。不为说如是魔事魔罪。当知是菩萨恶知识。复次须菩提。恶魔作佛形像到菩萨所语菩萨言。善男子。色空无我无我所受想行识空无我无我所。眼空无我无我所。乃至意触因缘生受空无我无我所。檀那波罗蜜空乃至般若波罗蜜空。四念处空。乃至十八不共法空。汝用阿耨多罗三藐三菩提为。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作辟支佛身到菩萨所语菩萨言。善男子。十方皆空是中无佛无菩萨无声闻。如是魔事魔罪不说不教。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔作和上阿阇梨身来到菩萨所。教离菩萨道。教离一切种智。教离四念处乃至八圣道分。教离檀那波罗蜜。乃至教离十八不共法。教入空无相无作。作是言。善男子。汝修念是诸法得声闻证。用阿耨多罗三藐三菩提为。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作父母形像到菩萨所语菩萨言。子汝为须陀洹果证故勤精进。乃至阿罗汉果证故勤精进。汝用阿耨多罗三藐三菩提为。求阿耨多罗三藐三菩提。当受无量阿僧祇劫生死截手截脚受诸苦痛。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作比丘形像到菩萨所语菩萨言。眼无常可得法。乃至意无常可得法。眼苦眼无我眼空。无相无作寂灭离说可得法。乃至意亦如是。用有所得法说四念处。乃至用有所得法说十八不共法。须菩提。如是魔事魔罪不说不教。当知是菩萨恶知识。知已当远离之

    摩诃般若波罗蜜经句义品第十二

尔时须菩提白佛言。世尊。云何为菩萨句义。佛告须菩提。无句义是菩萨句义。何以故。阿耨多罗三藐三菩提无有义处亦无我。以是故。无句义是菩萨句义。须菩提。譬如鸟飞虚空无有迹。菩萨句义无所有亦如是。须菩提。譬如梦中所见无处所。菩萨句义无所有亦如是。须菩提。譬如幻无有实义。如焰如响如影如佛所化无有实义。菩萨句义无所有亦如是。须菩提。譬如如法性法相法位实际无有义。菩萨句义无所有亦如是。须菩提。譬如幻人色无有义。幻人受想行识无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人眼无有义乃至意无有义。须菩提。如幻人色无有义乃至法无有义。眼触因缘生受。乃至意触因缘生受无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人行内空时无有义。乃至行无法有法空无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人行四念处乃至十八不共法无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如多陀阿伽度阿罗诃三藐三佛陀。色无有义是色无有故。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如多陀阿伽度阿罗诃三藐三佛陀。受想行识无有义是识无有故。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛眼无处所乃至意无处所。色乃至法无处所。眼触乃至意触因缘生受无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛内空无处所。乃至无法有法空无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛四念处无处所。乃至十八不共法无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如有为性中无无为性义。无为性中无有为性义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如不生不灭义无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如不作不出不得不垢不净无处所。菩萨句义无所有亦如是。须菩提白佛言。何法不生不灭故无处所。何法不作不出不得不垢不净故无处所。佛告须菩提。色不生不灭故无处所。受想行识不生不灭故无处所。乃至不垢不净亦如是。入界不生不灭故无处所。乃至不垢不净亦如是。四念处不生不灭故无处所。乃至不垢不净亦如是。乃至十八不共法不生不灭故无处所。乃至不垢不净亦如是。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如四念处净义。毕竟不可得。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如四正勤乃至十八不共法净义。毕竟不可得。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如净中我不可得。我无所有故。乃至净中知者见者不可得。知见无所有故。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如日出时无有黑闇。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如劫烧时无一切物。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。佛戒中无破戒。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛定中无乱心。佛慧中无愚痴。佛解脱中无不解脱。佛解脱知见中无不解脱知见。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如佛光中日月光不现。佛光中四王天三十三天夜摩天兜率陀天化乐天他化自在天梵众天。乃至阿迦贰吒天光不现。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。何以故。是阿耨多罗三藐三菩提菩萨。菩萨句义是一切法皆不合不散。无色无形无对一相。所谓无相。如是须菩提。菩萨摩诃萨一切法无阂相中。应当学亦应当知。须菩提白佛言。世尊。何等是一切法。云何一切法中无阂相应学应知。佛告须菩提。一切法者善法不善法。记法无记法。世间法出世间法。有漏法无漏法。有为法无为法。共法不共法。须菩提。是名一切法。菩萨摩诃萨是一切法无阂相中应学应知。须菩提白佛言。世尊。何等名世间善法。佛告须菩提。世间善法者。孝顺父母。供养沙门婆罗门。敬事尊长。布施福处。持戒福处。修禅福处。劝导福事。方便生福德。世间十善道。九相。胀相血相坏相脓烂相青相啖相散相骨相烧相。四禅四无量心四无色定。念佛念法念僧念戒念舍念天。念善念安般念身念死。是名世间善法。何等不善法。夺他命不与取邪淫妄语两舌恶口非时语贪恼害邪见。是十不善道等。是名不善法。何等记法。若善法若不善法。是名记法。何等无记法。无记身业口业意业。无记四大。无记五荫十二入十八界。无记报。是名无记法。何等名世间法。世间法者。五荫十二入十八界。十善道。四禅四无量心四无色定。是名世间法。何等名出世间法。四念处四正勤四如意足五根五力七觉分八圣道分。空解脱门。无相解脱门。无作解脱门。三无漏根。未知欲知根。知根。知已根。三三昧。有觉有观三昧。无觉有观三昧。无觉无观三昧。明解脱念慧正忆八背舍。何等八色观色是初背舍。内无色相外观色。是二背舍。净背舍身作证。是三背舍。过一切色相故。灭有对相故。一切异相不念故。入无边虚空处。是四背舍。过一切无边虚空处。入一切无边识处。是五背舍。过一切无边识处。入无所有处。是六背舍。过一切无所有处。入非有想非无想处。是七背舍。过一切非有想非无想处。入灭受想定。是八背舍。九次第定。何等九。离欲离恶不善法有觉有观。离生喜乐。入初禅。灭诸觉观内清净故。一心无觉无观定生喜乐。入第二禅。离喜故行舍受身乐。圣人能说能舍念行乐。入第三禅。断苦乐故。先灭忧喜故。不苦不乐舍念净。入第四禅。过一切色相故。灭有对相故。一切异相不念故。入无边虚空处。过一切无边虚空处。入无边识处。过一切无边识处。入无所有处。过一切无所有处。入非有想非无想处。过一切非有想非无想处。入灭受想定。复有出世间法。内空乃至无法有法空。佛十力四无所畏。四无碍智。十八不共法一切智。是名出世间法。何等为有漏法。五受荫十二入十八界。六种六触六受四禅乃至四无色定。是名有漏法。何等为无漏法。四念处乃至十八不共法及一切智。是名无漏法。何等为有为法。若法生住灭。欲界色界无色界。五荫乃至意触因缘生受。四念处乃至十八不共法及一切智。是名有为法。何等为无为法。不生不住不灭。若染尽嗔尽痴尽如不异。法相法性法位实际。是名无为法。何等为共法。四禅四无量心四无色定。如是等是名共法。何等名不共法。四念处乃至十八不共法。是名不共法。菩萨摩诃萨于是自相空法中。不应着不动故。菩萨亦应知一切法不二相不动故。是名菩萨义

    摩诃般若波罗蜜经金刚品第十三(丹本云摩诃萨品)

尔时须菩提白佛言。世尊。何以故。名为摩诃萨。佛告须菩提。是菩萨于必定众中为上首。是故名摩诃萨。须菩提白佛言。世尊。何等为必定众。是菩萨摩诃萨而为上首。佛告须菩提。必定众者。性地人八人须陀洹斯陀含阿那含阿罗汉辟支佛。初发心菩萨乃至阿惟越致地菩萨。须菩提。是为必定众菩萨。为上首菩萨摩诃萨于是中生大心。不可坏如金刚。当为必定众作上首。须菩提白佛言。世尊。何等是菩萨摩诃萨生大心。不可坏如金刚。佛告须菩提。菩萨摩诃萨应生如是心。我当于无量生死中大誓庄严。我应当舍一切所有。我应当等心于一切众生。我应当以三乘度脱一切众生。令入无余涅槃。我度一切众生已。无有乃至一人入涅槃者。我应当解一切诸法不生相。我应当纯以萨婆若心行六波罗蜜。我应当学智慧了达一切法。我应当了达诸法一相智门。我应当了达乃至无量相智门。须菩提。是名菩萨摩诃萨生大心。不可坏如金刚。是菩萨摩诃萨住是心中。于诸必定众而为上首。是法用无所得故。须菩提。菩萨摩诃萨应生如是心。我当代十方一切众生若地狱众生若畜生众生若饿鬼众生受苦痛。为一一众生。无量百千亿劫代受地狱中苦。乃至是众生入无余涅槃。以是法故为是众生受诸勤苦。是众生入无余涅槃已。然后自种善根。无量百千亿阿僧祇劫当得阿耨多罗三藐三菩提。须菩提。是为菩萨摩诃萨生大心。不可坏如金刚。住是心中为必定众作上首。复次须菩提。菩萨摩诃萨生大快心。住是大快心中。为必定众作上首。须菩提白佛言。世尊。何等是菩萨摩诃萨大快心。佛言。菩萨摩诃萨从初发意乃至阿耨多罗三藐三菩提。不生染心嗔恚心愚痴心。不生慢心。不生声闻辟支佛心。是名菩萨摩诃萨大快心。住是心中为必定众作上首。亦不念有是心。复次须菩提。菩萨摩诃萨应生不动心。须菩提白佛言。云何名不动心。佛言。常念一切种智心。亦不念有是心。是名菩萨摩诃萨不动心。复次须菩提。菩萨摩诃萨于一切众生中。应生利益安乐心。云何名利益安乐心。救济一切众生。不舍一切众生。是事亦不念有是心。是名菩萨摩诃萨于一切众生中生利益安乐心。如是须菩提。是菩萨摩诃萨行般若波罗蜜。于必定众中最为上首。复次须菩提。菩萨摩诃萨应当行欲法喜法乐法心。何等是法。所谓不破诸法实相。是名为法。何等名欲法喜法。信法忍法受法。是名欲法喜法。何等名乐法。常修行是法是名乐法。如是须菩提。菩萨摩诃萨行般若波罗蜜。于必定众中能为上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住内空乃至无法有法空。能为必定众作上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住四念处中。乃至住十八不共法中。能为必定众作上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住如金刚三昧。乃至离着虚空不染三昧中住。于必定众作上首。是法用无所得故。如是须菩提。菩萨摩诃萨住是诸法中。能为必定众作上首。以是因缘故名为摩诃萨

    摩诃般若波罗蜜经乐说品第十四(丹本作断见品)

尔时慧命舍利弗白佛言。世尊。我亦欲说所以为摩诃萨。佛告舍利弗。便说。舍利弗言。我见众生见寿见命见。生见养育见。众数见人见。作见使作见。起见使起见。受见使受见。知者见见者见。断见常见。有见无见。荫见入见界见。谛见因缘见。四念处见乃至十八不共法见。佛道见成就众生见。净佛国土见。佛见转法轮见。为断如是诸见故而为说法。是多摩诃萨。须菩提语舍利弗言。何因缘故。色见是妄见。何因缘故。受想行识乃至转法轮见。是名妄见。舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜时。无方便故得色生见。用有所得故。得受想行识乃至转法轮生见。用有所得故。是中菩萨摩诃萨行般若波罗蜜。以方便力断诸见网故而为说法。用无所得故。尔时须菩提白佛言。世尊。我亦欲说所以为摩诃萨。佛言。便说。须菩提言。世尊。是阿耨多罗三藐三菩提心。无等等心。不共声闻辟支佛心。何以故。是一切智心无漏不系故。是一切智心无漏不系中亦不着。以是因缘故名摩诃萨。舍利弗语须菩提。何等为菩萨摩诃萨无等等心。不共声闻辟支佛心。须菩提言。菩萨摩诃萨从初发意以来。终不见法有生有灭。有增有减有垢有净。舍利弗。若法无生无灭。乃至无垢无净。是中无声闻心无辟支佛心。无阿耨多罗三藐三菩提心无佛心。舍利弗。是名菩萨摩诃萨无等等心。不共声闻辟支佛心。舍利弗语须菩提。如须菩提说。一切智心无漏心不系心中亦不着。须菩提。色亦不着。受想行识亦不着。四念处亦不着。乃至十八不共法亦不着。何以但说是心不着。须菩提言。如是如是。舍利弗。色亦不着乃至十八不共法亦不着。舍利弗语须菩提。凡夫人心亦无漏不系性空故。诸声闻辟支佛心诸佛心亦无漏不系性空故。须菩提言。如是舍利弗。舍利弗言须菩提。若色亦无漏不系性空故。受想行识亦无漏不系性空故。乃至意触因缘生受。亦无漏不系性空故。须菩提言尔。舍利弗言。四念处亦无漏不系性空故。乃至十八不共法。亦无漏不系性空故。须菩提言尔。如舍利弗所言。凡夫人心亦无漏不系性空故。乃至十八不共法。亦无漏不系性空故。舍利弗语须菩提。如须菩提所说。空无心故不着是心。须菩提。色无故不着色。受想行识乃至意触因缘生受无故不着受。四念处无故不着四念处。乃至十八不共法无故。不着十八不共法。须菩提言。如是舍利弗。色无故色中不着。乃至十八不共法无故。十八不共法中不着。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。以阿耨多罗三藐三菩提心无等等心。不共声闻辟支佛心。不念有是心亦不着是心。用一切法无所有故。以是故名摩诃萨

    摩诃般若波罗蜜经辩才品第十五(丹本名为富楼那品)

尔时富楼那弥多罗尼子白佛言。世尊。我亦乐说所以为摩诃萨。佛言。便说。富楼那弥多罗尼子言。是菩萨大誓庄严是菩萨发趣大乘。是菩萨乘于大乘。以是故。是菩萨名摩诃萨。舍利弗语富楼那言。云何名菩萨摩诃萨大誓庄严。富楼那语舍利弗。菩萨摩诃萨不分别为尔所人故住檀那波罗蜜行檀那波罗蜜。为一切众生故。住檀那波罗蜜行檀那波罗蜜。不为尔所人故。住尸罗波罗蜜行尸罗波罗蜜。羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。为一切众生故。住般若波罗蜜行般若波罗蜜。菩萨摩诃萨大誓庄严。不齐限众生。我当度若干人不度余人。不言我令若干人至阿耨多罗三藐三菩提。余人不至。是菩萨摩诃萨普为一切众生故大誓庄严。复作是念。我当自具足檀那波罗蜜。亦令一切众生行檀那波罗蜜。自具足尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。自具足般若波罗蜜。亦令一切众生行般若波罗蜜。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。所有布施应萨婆若心。共一切众生回向阿耨多罗三藐三菩提。舍利弗。是名菩萨摩诃萨行檀那波罗蜜时檀那波罗蜜大誓庄严。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。应萨婆若心布施。不向声闻辟支佛地。舍利弗。是名菩萨摩诃萨行檀那波罗蜜时尸罗波罗蜜大誓庄严。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。应萨婆若心布施。是诸施法信忍欲。是名行檀那波罗蜜时羼提波罗蜜大誓庄严。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。应萨婆若心布施勤修不息。是名行檀那波罗蜜时毗梨耶波罗蜜大誓庄严。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。应萨婆若心布施。摄心不起声闻辟支佛意。是名行檀那波罗蜜时禅那波罗蜜大誓庄严。复次舍利弗。菩萨摩诃萨行檀那波罗蜜时。应萨婆若心布施。观诸法如幻。不得施者。不得所施物。不得受者。是名行檀那波罗蜜时般若波罗蜜大誓庄严。如是舍利弗。菩萨摩诃萨应萨婆若心。不取不得诸波罗蜜相。当知是菩萨摩诃萨大誓庄严。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。应萨婆若心布施。共一切众生回向阿耨多罗三藐三菩提。是名菩萨摩诃萨行尸罗波罗蜜时檀那波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。是诸法信忍欲。是名菩萨摩诃萨行尸罗波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时勤修不息。是名菩萨摩诃萨行尸罗波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。不受声闻辟支佛心。是名菩萨摩诃萨行尸罗波罗蜜时禅那波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。观一切法如幻。亦不念有是戒。用无所得故是名菩萨摩诃萨行尸罗波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行尸罗波罗蜜时摄诸波罗蜜。以是故名大誓庄严。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心布施。共一切众生回向阿耨多罗三藐三菩提。是为菩萨摩诃萨行羼提波罗蜜时檀那波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。不受声闻辟支佛心。但受萨婆若心。是名菩萨摩诃萨行羼提波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心身心精进不休息。是名菩萨摩诃萨行羼提波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。摄心一处。虽有苦事心不散乱。是名菩萨摩诃萨行羼提波罗蜜时禅那波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心观诸法空。无作者无受者。若有呵骂割截者。心如幻如梦。是名菩萨摩诃萨行羼提波罗蜜时般若波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时应萨婆若心布施。时不令身心懈怠。是名菩萨摩诃萨行毗梨耶波罗蜜时檀那波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心。始终具足清净持戒。是名菩萨摩诃萨行毗梨耶波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心修行忍辱。是名菩萨摩诃萨行毗梨耶波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心摄心离欲入诸禅定。是名菩萨摩诃萨行毗梨耶波罗蜜时禅那波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心不取一切诸法相。于不取相亦不着。是名菩萨摩诃萨行毗梨耶波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时摄诸波罗蜜。复次舍利弗。菩萨摩诃萨行禅那波罗蜜时。应萨婆若心定心布施不令心乱。是名菩萨摩诃萨行禅那波罗蜜时檀那波罗蜜。复次舍利弗。菩萨摩诃萨行禅那波罗蜜时。应萨婆若心持戒禅定力故。破戒诸法不令得入。是名菩萨摩诃萨行禅那波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行禅那波罗蜜时。应萨婆若心慈悲定故忍诸恼害。是名菩萨摩诃萨行禅那波罗蜜时羼提波罗蜜复次舍利弗。菩萨摩诃萨行禅那波罗蜜时。应萨婆若心于禅不味不着常求增进。从一禅至一禅。是名菩萨摩诃萨行禅那波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行禅那波罗蜜时。应萨婆若心于一切法无所依止。亦不随禅生。是名菩萨摩诃萨行禅那波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行禅那波罗蜜时摄诸波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心。布施内外所有无所爱惜。不见与者受者及以财物。是名菩萨摩诃萨行般若波罗蜜时檀那波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心持戒破戒二事不见故。是名菩萨摩诃萨行般若波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心不见呵者骂者打者杀者亦不见用是空能忍辱。是名菩萨摩诃萨行般若波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心观诸法毕竟空。以大悲心故行诸善法。是名菩萨摩诃萨行般若波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心入禅定。观诸禅离相空相无相相无作相。是名菩萨摩诃萨行般若波罗蜜时禅那波罗蜜。如是舍利弗。菩萨摩诃萨行般若波罗蜜时摄诸波罗蜜。舍利弗。如是名为菩萨摩诃萨大誓庄严。是大誓庄严菩萨。十方诸佛欢喜。于大众中称名赞叹。某国土某菩萨摩诃萨大誓庄严。成就众生净佛国土。慧命舍利弗问富楼那弥多罗尼子。云何菩萨摩诃萨发趣大乘。富楼那语舍利弗。菩萨摩诃萨行六波罗蜜时。离诸欲离诸恶不善法有觉有观。离生喜乐入初禅。乃至入第四禅中。以慈广大无二无量。无怨恨无恼心行。遍满一方二三四方四维上下。遍一切世间。悲喜舍心亦如是。是菩萨入禅时起时。诸禅无量心及支共一切众生回向萨婆若。是名菩萨摩诃萨禅那波罗蜜发趣大乘。是菩萨摩诃萨住禅无量心作是念。我当得一切种智。为断一切众生烦恼故当说法。是名菩萨摩诃萨行禅那波罗蜜时檀那波罗蜜。若菩萨摩诃萨应萨婆若心。修初禅住初禅。二三四禅亦如是不受余心。所谓声闻辟支佛心。是名菩萨摩诃萨行禅那波罗蜜时尸罗波罗蜜。若菩萨摩诃萨。应萨婆若心入诸禅作是念。我为断一切众生烦恼故当说法。是诸心欲乐忍。是名菩萨摩诃萨行禅那波罗蜜时羼提波罗蜜。若菩萨摩诃萨应萨婆若心入诸禅。诸善根皆回向萨婆若勤修不息。是名菩萨摩诃萨行禅那波罗蜜时毗梨耶波罗蜜。若菩萨摩诃萨应萨婆若心入四禅及支。观无常相苦相无我相空相无相相无作相。共一切众生回向萨婆若。是名菩萨摩诃萨行禅那波罗蜜时般若波罗蜜。舍利弗是名菩萨摩诃萨发趣大乘。复次菩萨摩诃萨发趣大乘行慈心作是念。我当安乐一切众生入悲心。我当救济一切众生入喜心我当度一切众生入舍心我当令一切众生得诸漏尽。是名菩萨摩诃萨行无量心时檀那波罗蜜。复次菩萨摩诃萨是诸禅无量心。不向声闻辟支佛地。但回向萨婆若。是名菩萨摩诃萨行无量心时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行四无量心。不贪声闻辟支佛地。但忍乐欲萨婆若。是名菩萨摩诃萨行无量心时羼提波罗蜜。若菩萨摩诃萨应萨婆若心。行四无量心但行清净行。是名菩萨摩诃萨行无量心时毗梨耶波罗蜜。复次菩萨摩诃萨入禅入无量心时。亦不随禅无量心生。是名菩萨摩诃萨行无量心时方便般若波罗蜜。舍利弗。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨发趣大乘。一切种修四念处。乃至一切种修八圣道分。一切种修三解脱门。乃至十八不共法。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨内空中智慧用无所得故。乃至无法有法空中智慧用无所得故。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨一切法中不乱不定智慧。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨发趣大乘。非常非无常智慧。非乐非苦非实非空非我非无我智慧。是名菩萨摩诃萨发趣大乘。用无所得故。复次舍利弗。菩萨摩诃萨智不行过去世。不行未来世。不行现在世亦非不知三世。是名菩萨摩诃萨发趣大乘。用无所得故。复次菩萨摩诃萨发趣大乘智不行欲界。不行色界。不行无色界。亦非不知欲界色界无色界。用无所得故。是名菩萨摩诃萨发趣大乘。复次菩萨摩诃萨发趣大乘智不行世间法。不行出世间法。不行有为法。不行无为法。不行有漏法。不行无漏法。亦非不知世间法出世间法。有为无为法有漏无漏法。用无所得故。舍利弗。是名菩萨摩诃萨发趣大乘

    摩诃般若波罗蜜经乘乘品第十六

尔时慧命舍利弗问富楼那云何名菩萨摩诃萨乘于大乘。富楼那答舍利弗言。菩萨摩诃萨行般若波罗蜜时乘檀那波罗蜜。亦不得檀波罗蜜。亦不得菩萨亦不得受者。是法用无所得故。是名菩萨摩诃萨乘檀那波罗蜜。菩萨摩诃萨行般若波罗蜜时。乘尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。乘般若波罗蜜亦不得般若波罗蜜。亦不得菩萨。是法用无所得故。是为菩萨摩诃萨乘于般若波罗蜜。如是舍利弗。是为菩萨摩诃萨乘于大乘。复次舍利弗。菩萨摩诃萨摩诃衍一心应萨婆若。修四念处法法坏故。乃至一心应萨婆若。修十八不共法法坏故是亦不可得。如是舍利弗。是名菩萨摩诃萨乘于大乘。复次舍利弗。菩萨摩诃萨作是念。菩萨但有名字。众生不可得故。是名菩萨摩诃萨乘于大乘。复次舍利弗。若菩萨摩诃萨作是念。色但有名字色不可得故。受想行识但有名字。识不可得故。眼但有名字眼不可得故。乃至意亦如是。四念处但有名字。四念处不可得故。乃至八圣道分但有名字。八圣道分不可得故。内空但有名字。内空不可得故。乃至无法有法空但有名字。无法有法空不可得故。乃至十八不共法但有名字。十八不共法不可得故。诸法如但有名字。如不可得故。法相法性法位实际但有名字。实际不可得故。阿耨多罗三藐三菩提及佛但有名字。佛不可得故。如是舍利弗。是名菩萨摩诃萨乘于大乘。复次舍利弗。若菩萨摩诃萨从初发意以来。具足菩萨神通成就众生。从一佛国至一佛国。恭敬供养尊重赞叹诸佛。从诸佛听受法教。所谓菩萨大乘。是菩萨乘是大乘。从一佛国至一佛国。净佛国土成就众生。初无佛国想亦无众生想。此人住不二法中。为众生受身随其所应。自变其形而教化之。乃至一切智终不离菩萨乘。是名菩萨乘是乘。得一切种智已转法轮。声闻辟支佛及天龙鬼神阿修罗世间人民所不能转。尔时十方如恒河沙等诸佛。皆欢喜称名赞叹作是言。某方某国某菩萨摩诃萨。乘于大乘得一切种智转法轮。舍利弗。是名菩萨摩诃萨乘于大乘

摩诃般若波罗蜜经卷第四摩诃般若波罗蜜经卷第五

        后秦龟兹国三藏鸠摩罗什译

    庄严品第十七

尔时须菩提白佛言。世尊。菩萨摩诃萨大庄严。何等是大庄严。何等菩萨能大庄严。佛语须菩提。菩萨摩诃萨摩诃衍大庄严。所谓檀那波罗蜜乃至般若波罗蜜庄严。四念处庄严。乃至八圣道分内空庄严。乃至无法有法空。十力乃至十八不共法及一切种智庄严。变身如佛庄严。光明遍照三千大千国土。亦照东方如恒河沙等国土。南西北方四维上下亦复如是。三千大千国土六种震动。亦动东方如恒河沙等诸国土。南西北方四维上下亦复如是。是菩萨摩诃萨住檀那波罗蜜摩诃衍大庄严。是三千大千国土变为琉璃。化作转轮圣王。须食与食须饮与饮。衣服卧具花香璎珞捣香泽香房舍灯烛医药。种种所须尽给与之。与已而为说法。所谓应六波罗蜜。众生闻是法者终不离六波罗蜜。乃至阿耨多罗三藐三菩提。如是须菩提。是名菩萨摩诃萨摩诃衍大庄严。须菩提。譬如工幻师若幻师弟子。于四衢道中化作大众。于前须食与食须饮与饮。乃至种种所须尽给与之。于须菩提意云何。是幻师实有众生有所与不。须菩提言。不也世尊。须菩提。菩萨摩诃萨亦如是。化作转轮圣王。种种具足须食与食须饮与饮。乃至种种所须尽给与之。虽有所施实无所与。何以故。须菩提诸法相如幻故。复次须菩提。菩萨摩诃萨住尸罗波罗蜜。现生转轮圣王家。以十善道教化众生。有以四禅四无量心四无色定四念处。乃至十八不共法教化众生。众生闻是法者。至阿耨多罗三藐三菩提终不离是法。譬如幻师若幻师弟子。于四衢道中化作大众。以十善道教化令行。又以四禅四无量心四无色定四念处。乃至十八不共法教化令行。须菩提于汝意云何。是幻师实有众生教令行十善道。乃至行十八不共法不。须菩提言。不也世尊。须菩提。菩萨摩诃萨亦如是。以十善道教化众生令行乃至十八不共法实无众生行十善道乃至十八不共法。何以故。诸法相如幻故。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住羼提波罗蜜。教化众生令行羼提波罗蜜。须菩提。云何菩萨摩诃萨住羼提波罗蜜。教化众生令行羼提波罗蜜。须菩提。菩萨摩诃萨从初发心已来如是大庄严。若一切众生骂詈刀杖伤害。菩萨摩诃萨于此中不起一念。亦教一切众生行此忍辱。譬若幻师若幻师弟子。于四衢道中化作大众。令行忍辱余如上说。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住毗梨耶波罗蜜。教一切众生令行毗梨耶波罗蜜。须菩提。云何菩萨摩诃萨住毗梨耶波罗蜜。教一切众生令行毗梨耶波罗蜜。须菩提。菩萨摩诃萨应萨婆若心。身心精进教化众生。譬如幻师若幻师弟子。于四衢道中化作大众。教令行身心精进余如上说。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住禅那波罗蜜。教一切众生令行禅那波罗蜜。须菩提。云何菩萨摩诃萨住禅那波罗蜜。教一切众生令行禅那波罗蜜。须菩提。菩萨摩诃萨住诸法等中。不见法若乱若定。如是须菩提。菩萨摩诃萨住禅那波罗蜜。教一切众生令行禅那波罗蜜。乃至阿耨多罗三藐三菩提。终不离禅那波罗蜜。譬如工幻师若幻师弟子。于四衢道中化作大众。教令行禅那波罗蜜余如上说。须菩提是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住般若波罗蜜。教一切众生令行般若波罗蜜。须菩提。云何菩萨摩诃萨住般若波罗蜜教一切众生令行般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时。无有法得此岸彼岸。如是菩萨摩诃萨住般若波罗蜜中。教一切众生令行般若波罗蜜。譬如工幻师若幻师弟子。于四衢道中化作大众。教令行般若波罗蜜。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨大庄严。十方如恒河沙等国土中众生随其所应自变其身。住檀那波罗蜜乃至般若波罗蜜。亦教众生令行檀那波罗蜜乃至般若波罗蜜。是众生行是法乃至阿耨多罗三藐三菩提终不离是法。须菩提。譬如工幻师若幻师弟子。于四衢道中化作众生。教令行六波罗蜜余如上说。如是须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨大庄严。应萨婆若心不生是念。我教若干人住檀那波罗蜜。不教若干人住檀那波罗蜜。乃至般若波罗蜜亦如是。不生是念。我教若干人住四念处。不教若干人住四念处。乃至十八不共法亦如是。亦不生是念。我教若干人令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道一切种智。亦不教若干人令得须陀洹果乃至一切种智。我当令无量无边阿僧祇众生。住檀那波罗蜜乃至般若波罗蜜。立众生于四念处乃至十八不共法。令无量无边阿僧祇众生得须陀洹果乃至一切种智。譬如工幻师若幻师弟子。于四衢道中化作大众。教令行六波罗蜜乃至得一切种智。余如上说。须菩提。是名菩萨摩诃萨大庄严。尔时须菩提白佛言。世尊。如我从佛所闻义。菩萨摩诃萨无大庄严为大庄严。诸法自相空故。所谓色色相空。受想行识识相空。眼眼相空。乃至意意相空。色色相空。乃至法法相空。眼识眼识相空。乃至意识意识相空。眼触眼触相空。乃至意触意触相空。眼触因缘生受受相空。乃至意触因缘生受受相空。世尊。檀那波罗蜜檀那波罗蜜相空。乃至般若波罗蜜般若波罗蜜相空。内空内空相空。乃至无法有法空。无法有法空相空。四念处四念处相空。乃至十八不共法十八不共法相空。菩萨菩萨相空。世尊。以是因缘故。当知菩萨摩诃萨无大庄严为大庄严。佛告须菩提。如是如是如汝所言。须菩提。萨婆若非作法。众生亦非作法。菩萨为是众生大庄严。须菩提白佛言。世尊。何因缘故。萨婆若非作法。是众生亦非作法。菩萨为是众生大庄严。佛语须菩提。作者不可得故。萨婆若非作非起法。是诸众生亦非作非起法。何以故。须菩提。色非作非不作。受想行识非作非不作。眼非作非不作。乃至意非作非不作。色乃至法。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受。非作非不作。须菩提。我非作非不作。乃至知者见者非作非不作。何以故。是诸法毕竟不可得故。须菩提。梦非作非不作。何以故。毕竟不可得故。幻响影焰化非作非不作。何以故。毕竟不可得故。须菩提。内空非作非不作。毕竟不可得故。乃至无法有法空非作非不作。毕竟不可得故。须菩提。四念处非作非不作。毕竟不可得故。乃至十八不共法非作非不作。何以故。是法皆毕竟不可得故。须菩提。诸法如。法相法性法住法位实际。非作非不作。毕竟不可得故。须菩提。菩萨非作非不作。毕竟不可得故。萨婆若及一切种智。非作非不作。毕竟不可得故。以是因缘故。须菩提。萨婆若非作非起法。是众生亦非作非起法。菩萨为是众生大庄严。尔时须菩提白佛言。如我观佛所说义。世尊。色无缚无脱。受想行识无缚无脱。尔时富楼那弥多罗尼子语须菩提。色是无缚无脱。受想行识是无缚无脱。须菩提言。如是如是。色是无缚无脱。受想行识是无缚无脱。富楼那问须菩提。何等色无缚无脱。何等受想行识无缚无脱。须菩提言。如梦色无缚无脱。如梦受想行识无缚无脱。如向如影如幻如焰如化。色受想行识无缚无脱。富楼那弥多罗尼子。过去色无缚无脱。过去受想行识无缚无脱。未来色无缚无脱。未来受想行识无缚无脱。现在色无缚无脱。现在受想行识无缚无脱。何以故无缚无脱。是色无所有故。无缚无脱。受想行识无所有故无缚无脱。离故寂灭故不生故无缚无脱。富楼那。善色受想行识亦无缚无脱。不善色受想行识无缚无脱。无记色无缚无脱无记受想行识无缚无脱。世间出世间有漏无漏色无缚无脱。受想行识亦无缚无脱。何以故。无所有故离故寂灭故不生故无缚无脱。富楼那。一切法亦无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。檀那波罗蜜无缚无脱。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜无缚无脱无所有故离故寂灭不生故无缚无脱。富楼那。内空亦无缚无脱。乃至无法有法空亦无缚无脱。四念处无缚无脱。乃至十八不共法无缚无脱。无所有故离故寂灭故不生故无缚无脱。阿耨多罗三藐三菩提无缚无脱。一切智一切种智无缚无脱。菩萨无缚无脱。佛亦无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。诸法如法相法性法住法位实际无为法无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。是名菩萨摩诃萨无缚无脱檀那波罗蜜。乃至般若波罗蜜四念处。乃至一切种智。无缚无脱。是菩萨摩诃萨住无缚无脱檀那波罗蜜中。乃至住无缚无脱般若波罗蜜。住无缚无脱四念处。乃至住无缚无脱一切种智。无缚无脱成就众生。无缚无脱净佛国土。无缚无脱诸佛当供养。无缚无脱当听法。无缚无脱诸佛终不离。无缚无脱诸神通终不离。无缚无脱五眼终不离。无缚无脱陀罗尼门终不离。无缚无脱诸三昧门终不离。无缚无脱当生道种智。无缚无脱当得一切种智。无缚无脱法轮转。无缚无脱众生安立三乘。如是富楼那。菩萨摩诃萨行无缚无脱六波罗蜜。当知一切法无缚无脱。无所有故离故寂灭故不生故。富楼那。是名菩萨摩诃萨无缚无脱大庄严

    摩诃般若波罗蜜经问乘品第十八(丹本名为摩诃衍品)

尔时须菩提白佛言。世尊。何等是菩萨摩诃萨摩诃衍。云何当知菩萨摩诃萨发趣大乘。是乘发何处。是乘至何处。当住何处。谁当乘是乘出者。佛告须菩提。汝问何等是菩萨摩诃衍。须菩提。六波罗蜜是菩萨摩诃萨摩诃衍。何等六。檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。云何名檀那波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。内外所有布施共一切众生回向阿耨多罗三藐三菩提用无所得故。须菩提。是名菩萨摩诃萨檀那波罗蜜。云何名尸罗波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。自行十善道亦教他行十善道。以无所得故。是名菩萨摩诃萨尸罗波罗蜜。云何名羼提波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。自具足忍辱亦教他行忍辱。以无所得故。是名菩萨摩诃萨羼提波罗蜜。云何名毗梨耶波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。行五波罗蜜勤修不息。亦安立一切众生于五波罗蜜。以无所得故。是名菩萨摩诃萨毗梨耶波罗蜜。云何名禅那波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。自以方便入诸禅不随禅生。亦教他令入诸禅。以无所得故。是名菩萨摩诃萨禅那波罗蜜。云何名般若波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。不着一切法亦观一切法性。以无所得故。亦教他不着一切法。亦观一切法性。以无所得故。是名菩萨摩诃萨般若波罗蜜。须菩提。是为菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨复有摩诃衍。所谓。内空。外空。内外空。空空。大空。第一义空。有为空。无为空。毕竟空。无始空。散空。性空。自相空。诸法空。不可得空。无法空。有法空。无法有法空。须菩提白佛言。何等为内空。佛言。内法名眼耳鼻舌身意。眼眼空非常非灭故。何以故。性自尔。耳耳空鼻鼻空舌舌空身身空意意空。非常非灭故。何以故。性自尔。是名内空。何等为外空。外法名色声香味触法。色色空非常非灭故。何以故。性自尔。声声空香香空味味空触触空法法空。非常非灭故。何以故。性自尔。是名外空。何等为内外空。内外法名内六入外六入。内法内法空非常非灭故。何以故。性自尔。外法外法空非常非灭故。何以故。性自尔。是名内外空。何等为空空。一切法空是空亦空非常非灭故。何以故。性自尔。是名空空。何等为大空。东方东方相空。非常非灭故。何以故。性自尔。南西北方四维上下。南西北方四维上下空。非常非灭故。何以故。性自尔。是名大空。何等为第一义空。第一义名涅槃。涅槃涅槃空非常非灭故。何以故。性自尔。是名第一义空。何等为有为空。有为法名欲界色界无色界。欲界欲界空。色界色界空。无色界无色界空。非常非灭故。何以故。性自尔。是名有为空。何等为无为空。无为法名若无生相无住相无灭相。无为法无为法空非常非灭故。何以故。性自尔。是为无为空。何等为毕竟空。毕竟名诸法毕竟不可得。非常非灭故。何以故。性自尔。是名毕竟空。何等为无始空。若法初来处不可得。非常非灭故。何以故。性自尔。是名无始空。何等为散空。散名诸法无灭。非常非灭故。何以故。性自尔。是为散空。何等为性空。一切法性。若有为法性若无为法性。是性非声闻辟支佛所作。非佛所作亦非余人所作。是性性空非常非灭故。何以故。性自尔。是名性空。何等为自相空。自相名色坏相。受受相。想取相。行作相。识识相。如是等有为无为法各各自相空。非常非灭故。何以故。性自尔。是名自相空。何等为诸法空。诸法名色受想行识。眼耳鼻舌身意。色声香味触法。眼界色界眼识界。乃至意界法界意识界。是诸法诸法空。非常非灭故。何以故。性自尔。是为诸法空。何等为不可得空。求诸法不可得是不可得空。非常非灭故。何以故。性自尔。是名不可得空。何等为无法空。若法无是亦空。非常非灭故。何以故。性自尔。是名无法空。何等为有法空。有法名诸法和合中有自性相。是有法空非常非灭故。何以故。性自尔。是名有法空。何等为无法有法空。诸法中无法。诸法和合中有自性相。是无法有法空非常非灭故。何以故。性自尔。是名无法有法空。复次须菩提。法法相空。无法无法相空。自法自法相空。他法他法相空。何等名法法相空。法名五荫。五荫空是名法法相空。何等名无法无法相空。无法名无为法。是名无法无法空。何等名自法自法空。诸法自法空。是空非知作非见作。是名自法自法空。何等名他法他法空。若佛出若佛未出。法住法相法位法性如实际。过此诸法空。是名他法他法空。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓名首楞严三昧。宝印三昧。师子游戏三昧。妙月三昧。月幢相三昧。出诸法三昧。观顶三昧。毕法性三昧。毕幢相三昧。金刚三昧。入法印三昧。三昧王安立三昧。放光三昧。力进三昧。高出三昧。必入辩才三昧。释名字三昧。观方三昧。陀罗尼印三昧。无诳三昧。摄诸法海三昧。遍覆虚空三昧。金刚轮三昧。宝断三昧。能照三昧。不求三昧。无住三昧。无心三昧。净灯三昧。无边明三昧。能作明三昧。普照明三昧。坚净诸三昧三昧。无垢明三昧。欢喜三昧。电光三昧。无尽三昧。威德三昧。离尽三昧。不动三昧。不退三昧。日灯三昧。月净三昧。净明三昧。能作明三昧。作行三昧。知相三昧。如金刚三昧。心住三昧。普明三昧。安立三昧。宝聚三昧。妙法印三昧。法等三昧。断喜三昧。到法顶三昧。能散三昧。分别诸法句三昧。字等相三昧。离字三昧。断缘三昧。不坏三昧。无种相三昧。无处行三昧。离朦昧三昧。无去三昧。不变异三昧。度缘三昧。集诸功德三昧。住无心三昧。净妙华三昧。觉意三昧。无量辩三昧。无等等三昧。度诸法三昧。分别诸法三昧。散疑三昧。无处三昧。一庄严三昧。生行三昧。一行三昧。不一行三昧。妙行三昧。达一切有底散三昧。入名语三昧。离音声字语三昧。然炬三昧。净相三昧。破相三昧。一切种妙足三昧。不喜苦乐三昧。无尽相三昧。陀罗尼三昧。摄诸邪正相三昧。灭憎爱三昧。逆顺三昧。净光三昧。坚固三昧。满月净光三昧。大庄严三昧。能照一切世三昧。三昧等三昧。摄一切有诤无诤三昧。不乐一切住处三昧。如住定三昧。坏身衰三昧。坏语如虚空三昧。离着虚空不染三昧。云何名首楞严三昧。知诸三昧行处。是名首楞严三昧。云何名宝印三昧。住是三昧能印诸三昧。是名宝印三昧。云何名师子游戏三昧。住是三昧能游戏诸三昧中如师子。是名师子游戏三昧。云何名妙月三昧。住是三昧能照诸三昧如净月。是名妙月三昧。云何名月幢相三昧。住是三昧能持诸三昧相。是名月幢相三昧。云何名出诸法三昧。住是三昧能出生诸三昧。是名出诸法三昧。云何名观顶三昧。住是三昧能观诸三昧顶。是名观顶三昧。云何名毕法性三昧。住是三昧决定知法性。是名毕法性三昧。云何名毕幢相三昧。住是三昧能持诸三昧幢。是名毕幢相三昧。云何名金刚三昧。住是三昧能破诸三昧。是名金刚三昧。云何名入法印三昧。住是三昧入诸法印。是名入法即三昧。云何名三昧王安立三昧。住是三昧一切诸三昧中安立住如王。是名三昧王安立三昧。云何名放光三昧。住是三昧能放光照诸三昧。是名放光三昧。云何名力进三昧。住是三昧。于诸三昧能作势力。是名力进三昧。云何名高出三昧。住是三昧能增长诸三昧。是名高出三昧。云何名必入辩才三昧。住是三昧能辩说诸三昧。是名必入辩才三昧。云何名释名字三昧。住是三昧能释诸三昧名字。是名释名字三昧。云何名观方三昧。住是三昧能观诸三昧方。是名观方三昧。云何名陀罗尼印三昧。住是三昧持诸三昧印。是名陀罗尼印三昧。云何名无诳三昧。住是三昧于诸三昧不欺诳。是名无诳三昧。云何名摄诸法海三昧。住是三昧能摄诸三昧如大海水。是名摄诸法海三昧。云何名遍覆虚空三昧。住是三昧遍覆诸三昧如虚空。是名遍覆虚空三昧。云何名金刚轮三昧。住是三昧能持诸三昧分。是名金刚轮三昧。云何名断宝三昧。住是三昧断诸三昧烦恼垢。是名断宝三昧。云何名能照三昧。住是三昧能以光明显照诸三昧。是名能照三昧。云何名不求三昧。住是三昧无法可求。是名不求三昧。云何名无住三昧。住是三昧中不见一切法住。是名无住三昧。云何名无心三昧。住是三昧心心数法不行。是名无心三昧。云何名净灯三昧。住是三昧于诸三昧中作明如灯。是名净灯三昧。云何名无边明三昧。住是三昧与诸三昧作无边明。是名无边明三昧。云何名能作明三昧。住是三昧即时能为诸三昧作明。是名能作明三昧。云何名普照明三昧。住是三昧即能照诸三昧门。是名普照明三昧。云何名坚净诸三昧三昧。住是三昧能坚净诸三昧相。是名坚净诸三昧三昧。云何名无垢明三昧。住是三昧能除诸三昧垢。亦能照一切三昧。是名无垢明三昧。云何名欢喜三昧。住是三昧能受诸三昧喜。是名欢喜三昧。云何名电光三昧。住是三昧照诸三昧如电光。是名电光三昧。云何名无尽三昧。住是三昧于诸三昧不见尽。是名无尽三昧。云何名威德三昧。住是三昧于诸三昧威德照然。是名威德三昧。云何名离尽三昧。住是三昧不见诸三昧尽。是名离尽三昧。云何名不动三昧。住是三昧令诸三昧不动不戏。是名不动三昧。云何名不退三昧。住是三昧能不见诸三昧退。是名不退三昧。云何名日灯三昧。住是三昧放光照诸三昧门。是名日灯三昧。云何名月净三昧。住是三昧能除诸三昧闇。是名月净三昧。云何名净明三昧。住是三昧于诸三昧得四无闇智。是名净明三昧。云何名能作明三昧。住是三昧于诸三昧门能作明。是名能作明三昧。云何名作行三昧。住是三昧能令诸三昧各有所作。是名作行三昧。云何名知相三昧。住是三昧见诸三昧知相。是名知相三昧。云何名如金刚三昧。住是三昧能贯达诸法亦不见达。是名如金刚三昧。云何名心住三昧。住是三昧心不动不转不恼。亦不念有是心。是名心住三昧。云何名普明三昧。住是三昧普见诸三昧明。是名普明三昧。云何名安立三昧。住是三昧于诸三昧安立不动。是名安立三昧。云何名宝聚三昧。住是三昧普见诸三昧如见宝聚。是名宝聚三昧。云何名妙法印三昧。住是三昧能印诸三昧以无印印故。是名妙法印三昧。云何名法等三昧。住是三昧观诸法等无法不等。是名法等三昧。云何名断喜三昧。住是三昧断一切法中喜。是名断喜三昧。云何名到法顶三昧。住是三昧灭诸法闇亦在诸三昧上。是名到法顶三昧。云何名能散三昧。住是三昧中能破散诸法。是名能散三昧。云何名分别诸法句三昧。住是三昧分别诸三昧诸法句。是名分别诸法句三昧。云何名字等相三昧。住是三昧得诸三昧字等。是名字等相三昧。云何名离字三昧。住是三昧诸三昧中乃至不见一字。是名离字三昧。云何名断缘三昧。住是三昧断诸三昧缘。是名断缘三昧。云何名不坏三昧。住是三昧不得诸法变异。是名不坏三昧。云何名无种相三昧。住是三昧不见诸法种种。是名无种相三昧。云何名无处行三昧。住是三昧不见诸三昧处。是名无处行三昧。云何名离蒙昧三昧。住是三昧离诸三昧微闇。是名离朦昧三昧。云何名无去三昧。住是三昧不见一切三昧去相。是名无去三昧。云何名不变异三昧。住是三昧不见诸三昧变异相。是名不变异三昧。云何名度缘三昧。住是三昧度一切三昧缘境界。是名度缘三昧。云何名集诸功德三昧。住是三昧集诸三昧功德。是名集诸功德三昧。云何名住无心三昧。住是三昧于诸三昧心不入。是名住无心三昧。云何名净妙花三昧。住是三昧令诸三昧得净妙如花。是名净妙花三昧。云何名觉意三昧。住是三昧诸三昧中得七觉分。是名觉意三昧。云何名无量辩三昧。住是三昧于诸法中得无量辩。是名无量辩三昧。云何名无等等三昧。住是三昧诸三昧中得无等等相。是名无等等三昧。云何名度诸法三昧。住是三昧度一切三界。是名度诸法三昧。云何名分别诸法三昧。住是三昧诸三昧及诸法分别见。是名分别诸法三昧。云何名散疑三昧。住是三昧得散诸法疑。是名散疑三昧。云何名无住处三昧。住是三昧不见诸法住处。是名无住处三昧。云何名一庄严三昧。住是三昧终不见诸法二相。是名一庄严三昧。云何名生行三昧。住是三昧不见诸行生。是名生行三昧。云何名一行三昧。住是三昧不见诸三昧此岸彼岸。是名一行三昧。云何名不一行三昧。住是三昧不见诸三昧一相。是名不一行三昧。云何名妙行三昧。住是三昧不见诸三昧二相。是名妙行三昧。云何名达一切有底散三昧。住是三昧入一切有一切三昧。智慧通达亦无所达。是名达一切有底散三昧。云何名入名语三昧。住是三昧入一切三昧名语。是名入名语三昧。云何名离音声字语三昧。住是三昧不见诸三昧音声字语。是名离音声字语三昧。云何名然炬三昧。住是三昧威德照明如炬。是名然炬三昧。云何名净相三昧。住是三昧净诸三昧相。是名净相三昧。云何名破相三昧。住是三昧不见诸三昧相。是名破相三昧。云何名一切种妙足三昧。住是三昧一切诸三昧种皆具足。是名一切种妙足三昧。云何名不喜苦乐三昧。住是三昧不见诸三昧苦乐。是名不喜苦乐三昧。云何名无尽相三昧。住是三昧不见诸三昧尽。是名无尽相三昧。云何名多陀罗尼三昧。住是三昧能持诸三昧。是名多陀罗尼三昧。云何名摄诸邪正相三昧。住是三昧。于诸三昧不见邪正相。是名摄诸邪正相三昧。云何名灭憎爱三昧。住是三昧不见诸三昧憎爱。是名灭憎爱三昧。云何名逆顺三昧。住是三昧不见诸法诸三昧逆顺。是名逆顺三昧。云何名净光三昧。住是三昧不得诸三昧明垢。是名净光三昧。云何名坚固三昧。住是三昧不得诸三昧不坚固。是名坚固三昧。云何名满月净光三昧。住是三昧诸三昧满足如月十五日。是名满月净光三昧。云何名大庄严三昧。住是三昧大庄严成就诸三昧。是名大庄严三昧。云何名能照一切世三昧。住是三昧诸三昧及一切法能照。是名能照一切世三昧。云何名三昧等三昧。住是三昧于诸三昧不得定乱相。是名三昧等三昧。云何名摄一切有诤无诤三昧。住是三昧能使诸三昧不分别有诤无诤。是名摄一切有诤无诤三昧。云何名不乐一切住处三昧。住是三昧不见诸三昧依处。是名不乐一切住处三昧。云何名如住定三昧。住是三昧不过诸三昧如相。是名如住定三昧。云何名坏身衰三昧。住是三昧不得身相。是名坏身衰三昧。云何名坏语如虚空三昧。住是三昧不见。诸三昧语业如虚空。是名坏语如虚空三昧。云何名离着虚空不染三昧。住是三昧。见诸法如虚空无阂。亦不染是三昧。是名离着虚空不染三昧。须菩提。是名菩萨摩诃萨摩诃衍

    摩诃般若波罗蜜经广乘品第十九(丹本名为四念处品)

佛告须菩提。菩萨摩诃萨摩诃衍。所谓四念处。何等四。须菩提。菩萨摩诃萨内身中循身观亦无身觉。以不可得故。外身中内外身中循身观亦无身觉。以不可得故。勤精进一心除世间贪忧。内受内心内法。外受外心外法。内外受内外心内外法。循法观亦无法觉。以不可得故。勤精进一心除世间贪忧。须菩提。菩萨摩诃萨云何内身中循身观。须菩提。若菩萨摩诃萨行时知行。住时知住。坐时知坐。卧时知卧。知身所行如是知。须菩提。菩萨摩诃萨如是内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若来若去。视瞻一心屈申俯仰。服僧伽梨执持衣钵。饮食卧息坐立睡觉。语默入出禅定。亦常一心。如是须菩提。菩萨摩诃萨行般若波罗蜜。内身中循身观以不可得故。复次须菩提。菩萨摩诃萨内身中循身观时。一心念入息时知入息。出息时知出息。入息长时知入息长。出息长时知出息长。入息短时知入息短。出息短时知出息短。譬如旋师若旋师弟子。绳长知长绳短知短。菩萨摩诃萨亦如是。一心念入息时知入息。出息时知出息。入息长时知入息长。出息长时知出息长。入息短时知入息短。出息短时知出息短。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨观身四大作是念。身中有地大水大火大风大。譬如屠牛师若屠牛弟子。以刀杀牛分作四分。作四分已若立若坐观此四分。菩萨摩诃萨亦如是。行般若波罗蜜时。种种观身四大地大水大火大风大。如是须菩提。菩萨摩诃萨内身中循身观。以不可得故。复次须菩提。菩萨摩诃萨观内身。从足至顶周匝薄皮。种种不净充满身中。作是念。身中有发毛爪齿薄皮厚皮筋肉骨髓脾肾心胆肝肺小肠大肠胃脬。屎尿垢汗泪涕涎唾脓血黄白淡癊肪[月*冊]脑膜。譬如田夫仓中隔盛杂谷。种种充满稻麻黍粟豆麦。明眼之人开仓即知。是麻是黍是稻是粟是麦是豆。分别悉知。菩萨摩诃萨亦如是。观是身从足至顶周匝薄皮种种不净充满身中。发毛爪齿乃至脑膜。如是须菩提。菩萨摩诃萨观内身。恳精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若见是弃死人身。一日二日至于五日。膖胀青瘀脓汁流出。自念我身亦如是相如是法未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提菩萨摩诃萨若见是弃死人身。若六日若七日。乌鸱雕鹫豺狼狐狗。如是等种种禽兽攫裂食之。自念我身如是相如是法未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若见是弃死人身。种种禽兽食已不净烂臭。自念我身如是相如是法未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见是弃死人身。骨璅血肉涂染筋骨相连。自念我身如是相如是法未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见是弃死人身。骨璅血肉已离筋骨相连。自念我身如是相如是法未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见是弃死人身。骨璅已散在地。自念我身如是相如是法未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见是弃死人身。骨散在地脚骨异处。[跳-兆+尃]骨髀骨腰骨胁骨。脊骨手骨项骨髑髅各各异处。自念我身如是相如是法未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。复次须菩提。菩萨摩诃萨见是弃死人。骨在地岁久。风吹日曝。色白如贝。自念我身如是相如是法未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨见是弃死人。骨在地岁久其色如鸽。腐朽烂坏与土共合。自念我身如是相如是法未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。外身内外身亦如是。受念处心念处法念处。亦应如是广说。须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四正勤。何等四。须菩提。菩萨摩诃萨未生诸恶不善法为不生故。欲生勤精进摄心行道。已生诸恶不善法为断故。欲生勤精进摄心行道。未生诸善法为生故。欲生勤精进摄心行道。已生诸善法为住不失修满增广故。欲生勤精进摄心行道。以不可得故。须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四如意分。何等四。欲定断行成就修如意分。心定断行成就修如意分。精进定断行成就修如意分。思惟定断行成就修如意分。以不可得故。须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓五根。何等五。信根精进根念根定根慧根。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓五力。何等五。信力精进力念力定力慧力。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓七觉分。何等七。菩萨摩诃萨修念觉分。依离依无染向涅槃。择法觉分。精进觉分。喜觉分。除觉分。定觉分。舍觉分。依离依无染向涅槃。以不可得故。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓八圣道分。何等八。正见正思惟正语正业正命正精进正念正定。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三三昧。何等三。空无相无作三昧。空三昧名诸法自相空。是名空解脱门。无相名坏诸法相不忆不念。是名无相解脱门。无作名诸法中不愿作。是名无作解脱门。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓苦智集智灭智道智尽智无生智法智比智世智他心智如实智。云何名苦智。知苦不生是名苦智。云何名集智。知集应断是名集智。云何名灭智。知苦灭是名灭智。云何名道智。知八圣道分是名道智。云何名尽智。知诸淫恚痴尽是名尽智。云何名无生智。知诸有中无生是名无生智。云何名法智。知五荫本事是名法智。云何名比智。知眼无常乃至意触因缘生受无常是名比智。云何名世智。知因缘名字是名世智。云何名他心智。知他众生心是名他心智。云何名如实智。诸佛一切种智是名如实智。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三根。未知欲知根知根智者根。云何名未知欲知根。诸学人未得果信根精进根念根定根慧根。是名未知欲知根。云何名知根。诸学人得果信根乃至慧根。是名知根。云何名智者根。诸无学人若阿罗汉若辟支佛诸佛信根乃至慧根。是名智者根。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三三昧。何等三。有觉有观三昧。无觉有观三昧。无觉无观三昧。云何名有觉有观三昧。离诸欲离恶不善法。有觉有观离生喜乐入初禅。是名有觉有观三昧。云何名无觉有观三昧。初禅二禅中间。是名无觉有观三昧。云何名无觉无观三昧。从二禅乃至非有想非无想定。是名无觉无观三昧。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓十念。何等十。念佛念法念僧念戒念舍念天念善念出入息念身念死。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四禅四无量心四无色定八背舍九次第定。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓佛十力。何等十。佛如实知一切法是处不是处相。一力也。如实知他众生过去未来现在诸业诸受法。知造业处知因缘知报。二力也。如实知诸禅解脱三昧定垢净分别相。三力也。如实知他众生诸根上下相。四力也。如实知他众生种种欲解。五力也。如实知世间种种无数性。六力也。如实知一切至处道。七力也。知种种宿命有相有因缘。一世二世乃至百千世劫。初劫尽我在彼众生中生。如是姓如是名。如是饮食苦乐寿命长短。彼中死是间生。是间死还生是间。此间生名姓饮食苦乐寿命长短亦如是。八力也。佛天眼净过诸天眼。见众生死时生时。端正丑陋若大若小。若堕恶道若堕善道。如是业因缘受报。是诸众生恶身业成就。恶口业成就。恶意业成就。谤毁圣人受邪见。业因缘故。身坏死时入恶道生地狱中。是诸众生身善业成就。口善业成就。意善业成就。不谤毁圣人受正见因缘故。身坏死时入善道生天上。九力也。佛如实知诸漏尽故。无漏心解脱。无漏慧解脱。现在法中自证知入是法。所谓我生已尽梵行已作。从今世不复见后世。十力也。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四无所畏。何等四。佛作诚言。我是一切正智人。若有沙门婆罗门若天若魔若梵。若复余众如实难言。是法不知乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵。若复余众实不能转。一无畏也。佛作诚言。我一切漏尽。若有沙门婆罗门若天若魔若梵。若复余众如实难言。是漏不尽乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵。若复余众实不能转。二无畏也。佛作诚言。我说障法。若有沙门婆罗门若天若魔若梵。若复余众如实难言。受是法不障道。乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵。若复余众实不能转。三无畏也。佛作诚言。我所说圣道。能出世间随是行能尽苦。若有沙门婆罗门若天若魔若梵。若复余众如实难言。行是道不能出世间不能尽苦。乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵。若复余众实不能转。四无畏也。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四无阂智。何等四。义无阂法无阂辞无阂乐说无阂。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓十八不共法。何等十八。一诸佛身无失。二口无失。三念无失。四无异相。五无不定心。六无不知己舍心。七欲无减。八精进无减。九念无减。十慧无减。十一解脱无减。十二解脱知见无减。十三一切身业随智慧行。十四一切口业随智慧行。十五一切意业随智慧行。十六智慧知见过去世无阂无障。十七智慧知见未来世无阂无障。十八智慧知见现在世无阂无障。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓字等语等诸字入门。何等为字等语等诸字入门。阿字门。一切法初不生故。罗字门。一切法离垢故。波字门。一切法第一义故。遮字门。一切法终不可得故。诸法不终不生故。那字门。诸法离名性相不得不失故。逻字门。诸法度世间故。亦爱支因缘灭故。陀字门。诸法善心生故。亦施相故。婆字门。诸法婆字离故。荼字门。诸法荼字净故。沙字门。诸法六自在王性清净故。和字门入诸法语言道断故。多字门。入诸法如相不动故夜字门。入诸法如实不生故。咤字门。入诸法折伏不可得故。迦字门。入诸法作者不可得故。娑字门。入诸法时不可得故。诸法时来转故。磨字门。入诸法我所不可得故。伽字门。入诸法去者不可得故。他字门。入诸法处不可得故。阇字门。入诸法生不可得故。[其*皮]字门。入诸法[其*皮]字不可得故。驮字门。入诸法性不可得故。赊字门。入诸法定不可得故。呿字门。入诸法虚空不可得故。叉字门。入诸法尽不可得故。哆字门。入诸法有不可得故。若字门。入诸法智不可得故。拖字门。入诸法拖字不可得故。婆字门。入诸法破坏不可得故。车字门。入诸法欲不可得故。如影五阴亦不可得故。摩字门。入诸法摩字不可得故。火字门。入诸法唤不可得故。嗟字门。入诸法嗟字不可得故。伽字门。入诸法厚不可得故。他字门。入诸法处不可得故。拏字门。入诸法不来不去不立不坐不卧故。颇字门。入诸法遍不可得故。歌字门。入诸法聚不可得故。醝字门。入诸法醝字不可得故。遮字门。入诸法行不可得故。咤字门。入诸法伛不可得故。荼字门。入诸法边竟处故不终不生。过荼无字可说。何以故。更无字故。诸字无碍无名亦灭。不可说不可示。不可见不可书。须菩提。当知一切诸法如虚空。须菩提。是名陀罗尼门。所谓阿字义。若菩萨摩诃萨。是诸字门印阿字印。若闻若受若诵若读若持若为他说。如是知当得二十功德。何等二十得强识念。得惭愧。得坚固心。得经旨趣。得智慧。得乐说无碍。易得诸余陀罗尼门。得无疑悔心。得闻善不喜闻恶不怒。得不高不下住心无增无减。得善巧知众生语。得巧分别五阴十二入十八界十二因缘四缘四谛。得巧分别众生诸根利钝。得巧知他心。得巧分别日月岁节。得巧分别天耳通。得巧分别宿命通。得巧分别生死通。得能巧说是处非处。得巧知往来坐起等身威仪。须菩提。是陀罗尼门字门阿字门等。是名菩萨摩诃萨摩诃衍

摩诃般若经卷第五摩诃般若波罗蜜经卷第六

        后秦龟兹国三藏鸠摩罗什译

    发趣品第二十

佛告须菩提。汝问云何菩萨摩诃萨大乘发趣。若菩萨摩诃萨行六波罗蜜时。从一地至一地。是名菩萨摩诃萨大乘发趣。须菩提白佛言。世尊。云何菩萨摩诃萨从一地至一地。佛言。菩萨摩诃萨知一切法无来去相。亦无有法若来若去若至若不至。诸法相不灭故。菩萨摩诃萨于诸地。不念不思惟。而修治地业亦不见地。何等菩萨摩诃萨治地业。菩萨摩诃萨住初地时行十事。一者深心坚固。用无所得故。二者于一切众生中等心。众生不可得故。三者布施施者受者不可得故。四者亲近善知识亦不自高。五者求法一切法不可得故。六者常出家。家不可得故。七者爱乐佛身。相好不可得故。八者演出法教。诸法分别不可得故。九者破憍慢法生慧不可得故。十者实语。诸语不可得故。菩萨摩诃萨如是初地中住。修治十事治地业。复次须菩提。菩萨摩诃萨住二地中。常念八法。何等八。一者戒清净。二者知恩报恩。三者住忍辱力。四者受欢喜。五者不舍一切众生。六者入大悲心。七者信师恭敬咨受。八者勤求诸波罗蜜。须菩提。是名菩萨摩诃萨住二地中满足八法。复次须菩提。菩萨摩诃萨住三地中行五法。何等五。一者多学问无厌足。二者净法施亦不自高。三者净佛国土亦不自高。四者受世间无量勤苦不以为厌。五者住惭愧处。须菩提。是名菩萨摩诃萨住三地中。应满足五法。复次须菩提。菩萨摩诃萨住四地中。应受行不舍十法。何等十。一者不舍阿兰若住处。二者少欲。三者知足。四者不舍头陀功德。五者不舍戒。六者秽恶诸欲。七者厌世间心顺涅槃心。八者舍一切所有。九者心不没。十者不惜一切物。须菩提。是名菩萨摩诃萨住四地中不舍十法。复次须菩提。菩萨摩诃萨住五地中。远离十二法。何等十二。一者远离亲白衣。二者远离比丘尼。三者远离悭惜他家。四者远离无益谈说。五者远离嗔恚。六者远离自大。七者远离蔑人。八者远离十不善道。九者远离大慢。十者远离自用。十一者远离颠倒。十二者绕离淫怒痴。须菩提。是为菩萨摩诃萨住五地中远离十二事。复次须菩提。菩萨摩诃萨住六地中当具足六法。何等六。所谓六波罗蜜。复有六法所不应为。何等六。一者不作声闻辟支佛意。二者布施不应生忧心。三者见有所索心不没。四者所有物布施。五者布施之后心不悔。六者不疑深法。须菩提。是名菩萨摩诃萨住六地中。应满具六法远离六法。复次须菩提。菩萨摩诃萨住七地中应远离二十法所不应着。何等二十。一者不着我。二者不着众生。三者不着寿命。四者不着众数乃至知者见者。五者不着断见。六者不着常见。七者不应作相。八者不应作因见。九者不著名色。十者不着五阴。十一者不着十八界。十二者不着十二入。十三者不着三界。十四者不作着处。十五者不作所期处。十六者不作依处。十七者不着依佛见。十八者不着依法见。十九者不着依僧见。二十者不着依戒见。是二十法所不应着。复有二十法应具足满。何等二十。一者具足空。二者无相证。三者知无作。四者三分清净。五者一切众生中慈悲智具足。六者不念一切众生。七者一切法等观。是中亦不着。八者知诸法实相。是事亦不念。九者无生法忍。十者无生智。十一者说诸法一相。十二者破分别相。十三者转忆想。十四者转见。十五者转烦恼。十六者等定慧地。十七者调意。十八者心寂灭。十九者无阂智。二十者不染爱。须菩提。是名菩萨摩诃萨住七地中应具足二十法。复次须菩提。菩萨摩诃萨住八地中应具足五法。何等五。顺入众生心。游戏诸神通见诸佛国。如所见佛国自庄严其国。如实观佛身自庄严佛身。是五法具足满。复次须菩提。菩萨摩诃萨住八地中。复具足五法。何等五。知上下诸根。净佛国土。入如幻三昧。常入三昧随众生所应善根受身。须菩提。是为菩萨摩诃萨住八地中具足五法。复次须菩提。菩萨摩诃萨住九地中应具足十二法。何等十二。受无边世界所度之分。菩萨得如所愿。知诸天龙夜叉揵闼婆语而为说法。处胎成就家。成就所生。成就姓。成就眷属。成就出生。成就出家。成就庄严佛树。成就一切诸善功德成满具足。须菩提。是名菩萨摩诃萨住九地中应具足十二法。须菩提。十地菩萨当知如佛。尔时慧命须菩提白佛言。世尊。云何菩萨摩诃萨。深心治地业。佛言。菩萨摩诃萨应萨婆若心集一切善根。是名菩萨摩诃萨深心治地业。云何菩萨于一切众生中等心。佛言。若菩萨摩诃萨应萨婆若心生四无量心。所谓慈悲喜舍。是名于一切众生中等心。云何菩萨修布施。佛言。菩萨施与一切众生无所分别。是名修布施。云何菩萨亲近善知识。佛言。能教人入萨婆若中住。如是善知识亲近咨受恭敬供养。是名亲近善知识。云何菩萨求法。佛言。菩萨应萨婆若心求法。不堕声闻辟支佛地。是名求法。云何菩萨常出家治地业。佛言。菩萨世世不杂心出家。佛法中出家无能障阂者是名常出家治地业。云何菩萨爱乐佛身治地业。佛言。若菩萨见佛身相。乃至阿耨多罗三藐三菩提终不离念佛。是名爱乐佛身治地业。云何菩萨演出法教治地业。佛言。菩萨若佛现在若佛灭度后。为众生说法初中后善。妙义好语净洁纯具。所谓修多罗乃至忧波提舍。是名演出法教治地业。云何菩萨破于憍慢治地业。佛言。菩萨破是憍慢故终不生下贱家。是名破于憍慢治地业。云何菩萨实语治地业。佛言。菩萨如所说行。是名实语治地业。是为菩萨摩诃萨初住地中修行十事治地业。云何菩萨戒清净。若菩萨摩诃萨不念声闻辟支佛心。及诸破戒障佛道法。是名戒清净。云何菩萨知恩报恩。若菩萨摩诃萨行菩萨道。乃至小恩尚不忘何况多。是名知恩报恩。云何菩萨住忍辱力。若菩萨于一切众生无嗔无恼。是名住忍辱力。云何菩萨受欢喜。所谓成就众生以此为喜。是名受欢喜。云何菩萨不舍一切众生。若菩萨念欲救一切众生故。是名不舍一切众生。云何菩萨入大悲心。若菩萨如是念我为一一众生故。如恒河沙等劫地狱中受勤苦。乃至是人得佛道入涅槃。如是名为为一切十方众生忍苦。是名入大悲心。云何菩萨信师恭敬咨受。若菩萨于诸师如世尊想。是名信师恭敬咨受。云何菩萨勤求诸波罗蜜若菩萨一心求诸波罗蜜无异事。是名勤求诸波罗蜜。是为菩萨摩诃萨住二地中满足八法。云何菩萨摩诃萨多学问无厌足。诸佛所说法。若此间世界若十方世界诸佛所说法尽欲闻持。是名多学问无厌足。云何菩萨净法施。有所法施乃至不求阿耨多罗三藐三菩提何况余事。是名不求名利法施。云何菩萨净佛国土。以诸善根回向净佛国土。是名净佛国土。云何菩萨受世间无量勤苦不以为厌。诸善根备具故。能成就众生亦庄严佛土。乃至具足萨婆若终不疲厌。是名受无量勤苦不以为厌。云何菩萨住惭愧处。耻诸声闻辟支佛意。是名住惭愧处。是为菩萨摩诃萨住三地中满足五法。云何菩萨不舍阿练若住处。能过声闻辟支佛地。是名不舍阿练若住处。云何菩萨少欲。乃至阿耨多罗三藐三菩提尚不欲何况余欲。是名少欲。云何菩萨知足。得一切种智是名知足。云何菩萨不舍头陀功德。观诸深法忍。是名不舍头陀功德。云何菩萨不舍戒。不取戒相。是名不舍戒。云何菩萨秽恶诸欲。欲心不生故。是名秽恶诸欲。云何菩萨厌世间心顺涅槃心。知一切法不作故。是名厌世间心顺涅槃心。云何菩萨舍一切所有。不惜内外诸法故。是名舍一切所有。云何菩萨心不没。二种识处心不生故。是名心不没。云何菩萨不惜一切物。于一切物不着不念。是名不惜一切物。是为菩萨于四地中不舍十法。云何菩萨远离亲白衣。菩萨出家所生。从一佛国至一佛国。常出家剃头着染衣。是名远离亲白衣。云何菩萨远离比丘尼。不共比丘尼住。乃至弹指顷亦不生念。是名远离比丘尼。云何菩萨远离悭惜他家。菩萨如是思惟我应安乐众生。他今助我安乐云何生悭。是名远离悭惜他家。云何菩萨远离无益谈处。若有谈处或生声闻辟支佛心。我当远离。是名远离无益谈处。云何菩萨远离嗔恚。不令嗔心恼心斗心得入。是名远离嗔恚。云何菩萨远离自大。所谓不见内法故。是名远离自大。云何菩萨远离篾人。所谓不见外法故。是名远离篾人。云何菩萨远离十不善道。是十不善道能障八圣道。何况阿耨多罗三藐三菩提。是名远离十不善道。云何菩萨远离大慢。是菩萨不见法可作大慢者。是名远离大慢。云何菩萨远离自用。是菩萨不见是法可自用者。是名远离自用。云何菩萨远离颠倒。颠倒处不可得故。是名远离颠倒。云何菩萨远离淫怒痴。淫怒痴处不可见故。是名远离淫怒痴。是为菩萨住五地中远离十二法。云何菩萨住六地中具足六法。所谓六波罗蜜。诸佛及声闻辟支佛。住六波罗蜜中能度彼岸。是名具足六法。云何菩萨不作声闻辟支佛意。作是念声闻辟支佛意非阿耨多罗三藐三菩提道。云何菩萨布施不生忧心。作是念此非阿耨多罗三藐三菩提道。云何菩萨见有所索心不没。作是念此非阿耨多罗三藐三菩提道。云何菩萨所有物布施。菩萨初发心时布施。不言是可与是不可与。云何菩萨布施之后心不悔。慈悲力故。云何菩萨不疑深法。信功德力故。是为菩萨住六地中远离六法。云何菩萨不着我。毕竟无我故。云何菩萨不着众生不着寿命不着众数乃至知者见者。是诸法毕竟不可得故。云何菩萨不着断见。无有法断。诸法毕竟不生故。云何菩萨不着常见。若法不生是不作常。云何菩萨不应取相。无诸烦恼故。云何菩萨不应作因见。诸见不可见故。云何菩萨不著名色。名色处相无故。云何菩萨不着五阴。不着十八界。不着十二入。是诸法性无故。云何菩萨不着三界。三界性无故。云何菩萨不应作着心。云何菩萨不应作愿。云何菩萨不应作依止。是诸法性无故。云何菩萨不着依佛见。作依见不见佛故。云何菩萨不着依法见。法不可见故。云何菩萨不着依僧见。僧相无为不可依故。云何菩萨不着依戒见。罪无罪不着故。是为菩萨住七地中。二十法所不应着。云何菩萨应具足空。具足诸法自相空故。云何菩萨无相证。不念诸相故。云何菩萨知无作。于三界中不作故。云何菩萨三分清净。十善道具足故。云何菩萨一切众生中慈悲智具足。得大悲故。云何菩萨不念一切众生。净国土具足故。云以菩萨一切法等观。于诸法不损益故。云何菩萨知诸法实相。诸法实相无知故。云何菩萨无生忍。为诸法不生不灭不作忍故。云何菩萨无生智。知名色不生故。云何菩萨说诸法一相。心不行二相故。云何菩萨破分别相。一切法不分别故。云何菩萨转忆想。小大无量想转故。云何菩萨转见。于声闻辟支佛地见转故。云何菩萨转烦恼。断诸烦恼故。云何菩萨等定慧地。所谓得一切种智故。云何菩萨调意。于三界不动故。云何菩萨心寂灭。制六根故。云何菩萨无阂智。得佛眼故。云何菩萨不染爱。舍六尘故。是为菩萨住七地中具足二十法。云何菩萨顺入众生心。菩萨以一心知一切众生心及心数法。云何菩萨游戏诸神通。以是神通从一佛国至一佛国。亦不作佛国想。云何菩萨观诸佛国。自住其国见无量诸佛国。亦无佛国想。云何菩萨如所见佛国自庄严其国。住转轮圣王地。遍至三千大千世界。以自庄严。云何菩萨如实观佛身。如实观法身故。是为菩萨住八地中具足五法。云何菩萨知上下诸根。菩萨住佛十力。知一切众生上下诸根。云何菩萨净佛国土。净众生故。云何菩萨如幻三昧。住是三昧能成办一切事。亦不生心相故。云何菩萨常入三昧。菩萨得报生三昧故。云何菩萨随众生所应善根受身。菩萨知众生所应生善根而为受身。成就众生故。是为菩萨住八地中具足五法。云何菩萨受无边世界所度之分。十方无量世界中众生。如诸佛法所应度者而度脱之。云何菩萨得如所愿。得六波罗蜜具足故。云何菩萨知诸天龙夜叉揵闼婆语。辞辩力故。云何菩萨胎生成就。菩萨世世常化生故。云何菩萨家成就。常在大家生故。云何菩萨所生成就。若刹刹家生若婆罗门家生故。云何菩萨姓成就。如过去菩萨所生姓。从此中生故。云何菩萨眷属成就。纯诸菩萨摩诃萨为眷属故。云何菩萨出生成就。生时光明遍照无量无边世界。亦不取相故。云何菩萨出家成就。出家时无量百千亿诸天侍从。出家是一切众生必至三乘。云何菩萨庄严佛树成就。是菩提树以黄金为根。七宝为茎节枝叶。茎节枝叶光明。遍照十方阿僧祇三千大千世界。云何菩萨一切诸善功德成满具足。菩萨得众生清净佛国亦净。是为菩萨住九地中具足十二法。云何菩萨住十地中当知如佛。若菩萨摩诃萨。具足六波罗蜜四念处乃至十八不共法。一切种智具足满。断一切烦恼及习。是名菩萨摩诃萨住十地中当知如佛。须菩提。菩萨摩诃萨住是十地中。以方便力故行六波罗蜜。行四念处乃至十八不共法。过干慧地性地八人地见地薄地离欲地已作地辟支佛地菩萨地。过是九地住于佛地。是为菩萨十地。如是须菩提。是名菩萨摩诃萨大乘发趣

    摩诃般若波罗蜜经出到品第二十一

佛告须菩提。汝所问是乘何处出至何处住者。佛言。是乘从三界中出。至萨婆若中住。以不二法故。何以故。摩诃衍萨婆若是二法。不合不散无色无形。无对一相。所谓无相。若人欲使实际出。是人为欲使无相法出。若人欲使如法性不可思议性出。是人为欲使无相法出。若人欲使色空出。是人为欲使无相法出。若人欲使受想行识空出。是人为欲使无相法出。何以故。须菩提。色空相不出三界。亦不住萨婆若。受想行识空相不出三界。亦不住萨婆若。所以者何。色色相空。受想行识识相空故。若人欲使眼空出。是人为欲使无相法出。若人欲使耳鼻舌身意空出。是人为欲使无相法出。若人欲使乃至意触因缘生受空出。是人为欲使无相法出。何以故。须菩提。眼空不出三界亦不住萨婆若。乃至意触因缘生受空。不出三界亦不住萨婆若。所以者何。眼眼相空。乃至意触因缘生受。意触因缘生受相空故。若人欲使梦出。是人为欲使无相法出。若人欲使幻焰响影化出。是人为欲使无相法出。何以故。须菩提。梦相不出三界亦不住萨婆若。幻焰响影化相。亦不出三界亦不住萨婆若。须菩提。若人欲使檀那波罗蜜出。是人为欲使无相法出。若人欲使尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜出。是人为欲使无相法出。何以故。檀那波罗蜜相。不出三界亦不住萨婆若。尸罗波罗蜜乃至般若波罗蜜。不出三界亦不住萨婆若。所以者何。檀那波罗蜜檀那波罗蜜相空。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜般若波罗蜜相空故。若人欲使内空出乃至无法有法空出。是人为欲使无相法出。何以故。须菩提。内空相乃至无法有法空相。不出三界亦不住萨婆若。所以者何。内空内空性空。乃至无法有法空无法有法空性空故。若人欲使四念处出。是人为欲使无相法出。何以故。四念处性。不出三界亦不住萨婆若。所以者何。四念处性四念处性空故。若人欲使四正勤四如意足五根五力七觉分八圣道分出。是人为欲使无相法出。何以故。八圣道分性。不出三界不住萨婆若。所以者何。八圣道分性八圣道分性空故。乃至十八不共法亦如是。须菩提。若人欲使阿罗汉出生处。是人为欲使无相法出。若人欲使辟支佛出生处。是人为欲使无相法出。若人欲使多陀阿伽度阿罗诃三藐三佛陀出生处。是人为欲使无相法出。何以故。阿罗汉性辟支佛性佛性。不出三界亦不住萨婆若。所以者何。阿罗汉性阿罗汉性空。辟支佛性辟支佛性空。佛性佛性空故。若人欲使须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道一切种智出。是人为欲使无相法出。如上说。若人欲使名字假名施设相但有语言出。是人为欲使无相法出。何以故。名字空。不出三界亦不住萨婆若。所以者何。名字相名字相空故。乃至施设亦如是。是人欲使不生不灭法不垢不净无作法出。是人为欲使无相法出。何以故。不生乃至无作法性。不出三界亦不住萨婆若。所以者何。不生性乃至无作性性空故。须菩提。以是因缘故。摩诃衍从三界中出。至萨婆若中。住不动故。须菩提。汝所问是乘至何处住者。须菩提。是大乘无住处。何以故。一切法无住相故。是乘若住不住法住。须菩提。譬如法性不生不灭。不垢不净无相无作。非住。非不住。须菩提。是乘亦如是。非住非不住。何以故。法性相非住非不住。所以者何。法性相空故。乃至无作性无作性空故。诸余法亦如是。须菩提。以是因缘故。是乘无所住。以不住法不动法故。须菩提。汝所问谁当乘是乘出者。无有人乘是乘出者。何以故。是乘及出者。所用法及出时。是一切法皆无所有。若一切法无所有。用何等法当出。何以故。我不可得乃至知者见者不可得。毕竟净故。不可思议性不可得。毕竟净故。阴入界不可得。毕竟净故。檀那波罗蜜不可得。毕竟净故。乃至般若波罗蜜不可得。毕竟净故。内空不可得。毕竟净故。乃至无法有法空不可得。毕竟净故。四念处不可得。乃至十八不共法不可得。毕竟净故。须陀洹不可得。乃至阿罗汉辟支佛菩萨佛不可得。毕竟净故。须陀洹果乃至阿罗汉果辟支佛道佛道一切种智不可得。毕竟净故。不生不灭不垢不净无起无作不可得。毕竟净故。过去世未来现在世生住灭不可得。毕竟净故。增减不可得。毕竟净故。何法不可得故不可得。法性不可得故不可得。如实际不可思议性法相法位檀那波罗蜜不可得故不可得。乃至般若波罗蜜。不可得故不可得。内空不可得故不可得。乃至无法有法空不可得故不可得。四念处不可得故不可得。乃至十八不共法不可得故不可得。须陀洹不可得故不可得。乃至佛不可得故不可得。须陀洹果不可得故不可得。乃至佛道不可得故不可得。不生不灭乃至不起不作。不可得故不可得。复次须菩提。初地不可得故不可得。乃至第十地不可得故不可得。毕竟净故。云何为初地乃至十地。所谓干慧地性地八人地见地薄地离欲地已作地辟支佛地菩萨地佛地。内空中初地不可得。乃至无法有法空中初地不可得。内空乃至无法有法空中。第二第三第四第五第六第七第八第九第十地不可得。何以故。须菩提。初地非得非不得。乃至十地非得非不得。毕竟净故。内空乃至无法有法空中。成就众生不可得。毕竟净故。内空乃至无法有法空中。净佛国土不可得。毕竟净故。内空乃至无法有法空中五眼不可得。毕竟净故。如是须菩提。菩萨摩诃萨以一切诸法不可得故。乘是摩诃衍出三界。住萨婆若

    摩诃般若波罗蜜经胜出品第二十二

慧命须菩提白佛言。世尊。摩诃衍摩诃衍者。胜出一切世间及诸天人阿修罗。世尊。是摩诃衍与虚空等。如虚空受无量无边阿僧祇众生。摩诃衍亦如是。受无量无边阿僧祇众生。世尊。是摩诃衍不见来处不见去处不见住处。是摩诃衍前际不可得后际不可得中际不可得。三世等是摩诃衍。世尊。以是故是乘名摩诃衍。佛告须菩提。如是如是。菩萨摩诃萨摩诃衍。所谓六波罗蜜。檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。一切陀罗尼门。一切三昧门。所谓首楞严三昧。乃至离着虚空不染三昧。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓内空乃至无法有法空。是名。菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四念处乃至十八不共法。是名菩萨摩诃萨摩诃衍。如须菩提所言。是摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若欲界当有实不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以欲界虚妄忆想分别和合名字等有一切无常想无法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。色界无色界若当实有不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以色界无色界虚妄忆想分别和合名字等。有一切无常破坏相无法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若色当实有不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以色虚妄忆想分别和合名字等有一切无常破坏相无法。以是故。是摩诃衍胜出一切世间及诸天人阿修罗。受想行识亦如是。须菩提。若眼乃至意。色乃至法。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受。若当实有不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以眼乃至意触因缘生受虚妄忆想分别和合名字等。有一切无常破坏相无法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若法性是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以法性无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若如实际不可思议性。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以如实际不可思议性无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若檀那波罗蜜。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以檀那波罗蜜无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。若尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以尸罗波罗蜜乃至般若波罗蜜无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若内空乃至无法有法空。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以内空乃至无法有法空无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若四念处乃至十八不共法。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以四念处乃至十八不共法无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若性人法是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以性人法无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若八人法须陀洹法斯陀含法阿那含法阿罗汉法辟支佛法佛法。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以八人法乃至佛法无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若性地人是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以性地人无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若八人法须陀洹乃至佛。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以八人乃至佛无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若一切世间及诸天人阿修罗。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以一切世间及诸天人阿修罗无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若菩萨摩诃萨从初发心乃至道场。于其中间诸心若是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以菩萨从初发心乃至道场于其中间诸心无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若菩萨摩诃萨如金刚慧是有法非无法者。是菩萨摩诃萨不能知一切结使及习无法非法得一切种智。须菩提。以菩萨摩诃萨如金刚慧无法非法。是故菩萨知一切结使及习无法非法得一切种智。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若诸佛三十二相。是有法非无法者。诸佛威德不能照然胜出一切世间及诸天人阿修罗。须菩提。以诸佛三十二相无法非法。以是故。诸佛威德照然胜出一切世间及诸天人阿修罗。须菩提。若诸佛光明是有法非无法者。诸佛光明不能普照如恒河沙等国土。须菩提。以诸佛光明无法非法。以是故。诸佛能以光明普照如恒河沙等国土。须菩提。若诸佛六十种庄严音声是有法非无法者。诸佛不能以六十种庄严音声遍至十方无量阿僧祇国土。须菩提。以诸佛六十种庄严音声无法非法。以是故。诸佛能以六十种庄严音声遍至十方无量阿僧祇国土。须菩提。诸佛法轮若当是有法非无法者。诸佛不能转法轮诸沙门婆罗门若天若魔若梵。及世间余众所不能如法转者。须菩提。以诸佛法轮无法非法。以是故。诸佛转法轮诸沙门婆罗门若天若魔若梵及世间余众不能如法转者。须菩提。诸佛为众生转法轮。是众生若实有法非无法者。不能令是众生于无余涅槃而般涅槃。须菩提。以诸佛为众生转法轮是众生无法非法。以是故。能令众生于无余涅槃中。已灭今灭当灭

    摩诃般若波罗蜜经等空品第二十三(丹本作含受品)

佛告须菩提。汝所言衍与空等。如是如是。须菩提。摩诃衍与虚空等。须菩提。如虚空无东方。无南方西方北方四维上下。须菩提。摩诃衍亦如是。无东方。无南方西方北方四维上下。须菩提。如虚空非长非短非方非圆。须菩提。摩诃衍亦如是。非长非短非方非圆。须菩提。如虚空非青非黄非赤非白非黑。摩诃衍亦如是。非青非黄非赤非白非黑。以是故。说摩诃衍与空等。须菩提。如虚空非过去非未来非现在。摩诃衍亦如是。非过去非未来非现在。以是故。说摩诃衍与空等。须菩提。如虚空不增不减。摩诃衍亦如是。亦不增亦不减。须菩提。如虚空无垢无净。摩诃衍亦如是无垢无净。须菩提。如虚空无生无灭无住无异。摩诃衍亦如是无生无灭无住无异。须菩提。如虚空非善非不善非记非无记。摩诃衍亦如是。非善非不善非记非无记。以是故。说摩诃衍与空等。如虚空无见无闻无觉无识。摩诃衍亦如是无见无闻无觉无识。如虚空不可知不可识。不可见不可断。不可证不可修。摩诃衍亦如是。不可知不可识。不可见不可断。不可证不可修。以是故。说摩诃衍与空等。如虚空非染相非离相。摩诃衍亦如是。非染相非离相。如虚空不系欲界不系色界不系无色界。摩诃衍亦如是。不系欲界不系色界不系无色界。如虚空无初发心亦无二三四五六七八九第十心。摩诃衍亦如是。无初发心乃至无第十心。如虚空无干慧地性人地八人地见地薄地离欲地已作地。摩诃衍亦如是。无干慧地乃至已办地。如虚空无须陀洹果无斯陀含果无阿那含果无阿罗汉果。摩诃衍亦如是。无须陀洹果乃至无阿罗汉果。如虚空无声闻地无辟支佛地无佛地。摩诃衍亦如是。无声闻地乃至佛地。以是故。说摩诃衍与虚空等。如虚空非色非无色。非可见非不可见。非有对非无对。非合非散。摩诃衍亦如是。非色非无色。非可见非不可见。非有对非无对。非合非散。以是故。说摩诃衍与空等。须菩提。如虚空非常非无常非乐非苦非我非无我。摩诃衍亦如是。非常非无常非乐非苦非我非无我。以是故说摩诃衍与空等。须菩提。如虚空非空非不空非相非无相非作非无作。摩诃衍亦如是。非空非不空非相非无相非作非无作。以是故。说摩诃衍与空等。须菩提。如虚空非寂灭非不寂灭非离非不离。摩诃衍亦如是。非寂灭非不寂灭非离非不离。以是故。说摩诃衍与空等。须菩提。如虚空非闇非明。摩诃衍亦如是。非闇非明。以是故。说摩诃衍与空等。须菩提如虚空非可得非不可得。摩诃衍亦如是。非可得非不可得。以是故。说摩诃衍与空等。须菩提。如虚空非可说非不可说。摩诃衍亦如是。非可说非不可说。以是故。说摩诃衍与空等。须菩提。以是诸因缘故。说摩诃衍与空等。须菩提。如汝所言。如虚空受无量无边阿僧祇众生。摩诃衍亦受无量无边阿僧祇众生。如是如是。须菩提。众生无有故。当知虚空无有。虚空无有故。当知摩诃衍亦无有。以是因缘故。摩诃衍受无量无边阿僧祇众生。何以故。是众生虚空摩诃衍。是法皆不可得故。复次须菩提。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。是众生虚空摩诃衍阿僧祇无量无边。是一切法不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知如法性实际无所有。如法性实际无所有故。当知乃至无量无边阿僧祇无所有。无量无边阿僧祇无所有故。当知一切法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。是众生乃至知者见者实际乃至无量无边阿僧祇。是一切法不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知不可思议性无所有。不可思议性无所有故。当知色受想行识无所有。色受想行识无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。当知摩诃衍受无量无边阿僧祇众生。何以故。须菩提。我乃至知者见者等一切法皆不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知眼无所有。耳鼻舌身意无所有。眼乃至意无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。须菩提我乃至一切诸法皆不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知檀那波罗蜜无所有。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜无所有。般若波罗蜜无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知无量无边阿僧祇无所有。无量无边阿僧祇无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知内空无所有。乃至无法有法空无所有。无法有法空无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生乃至知者见者无所有故。当知四念处无所有。四念处无所有故。乃至十八不共法无所有。十八不共法无所有故。当知虚空无所有虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生无所有乃至知者见者。无所有故。当知性地无所有。乃至已作地无所有。已作地无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生乃至知者见者无所有故。当知须陀洹无所有。须陀洹无所有故。当知斯陀含无所有。斯陀含无所有故。当知阿那含无所有。阿那含无所有故。当知阿罗汉无所有。阿罗汉无所有故。当知乃至一切诸法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。须菩提。我乃至一切诸法皆不可得故。复次须菩提。我乃至知者见者无所有故。当知声闻乘无所有。声闻乘无所有故。当知辟支佛乘无所有。辟支佛乘无所有故。当知佛乘无所有。佛乘无所有故。当知声闻人无所有。声闻人无所有故。当知须陀洹无所有。须陀洹无所有故。乃至佛无所有。佛无所有故。当知一切种智无所有。一切种智无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知乃至一切诸法无所有。以是因缘故。是摩诃衍受无量无边阿僧祇众生。何以故。我乃至一切诸法皆不可得故。须菩提。譬如涅槃性中受无量无边阿僧祇众生。是摩诃衍亦受无量无边阿僧祇众生。以是因缘故。须菩提。如虚空受无量无边阿僧祇众生。是摩诃衍亦如是。受无量无边阿僧祇众生。须菩提。汝所言是摩诃衍不见来处不见去处不见住处。如是如是。须菩提。是摩诃衍不见来处不见去处不见住处。何以故。须菩提。一切诸法不动相故。是法无来处无去处无住处。何以故。须菩提。色无所从来亦无所去亦无所住受想行识无所从来亦无所去亦无所住。须菩提。色法无所从来亦无所去亦无所住。受想行识法无所从来亦无所去亦无所住。须菩提。色如无所从来亦无所去亦无所住。受想行识如无所从来亦无所去亦无所住。须菩提。色性无所从来亦无所去亦无所住。受想行识性无所从来亦无所去亦无所住。须菩提。色相无所从来亦无所去亦无所住。受想行识相无所从来亦无所去亦无所住。须菩提。眼眼法眼如眼性眼相无所从来亦无所去亦无所住。耳鼻舌身意。意法意如意性意相。无所从来亦无所去亦无所住。色声香味触法亦如是。须菩提。地种地种法地种如地种性地种相。无所从来亦无所去亦无所住。水火风空识种。识种法识种如识种性识种相亦如是。须菩提。如如法如如如性如相。无所从来亦无所去亦无所住。须菩提。实际实际法实际如实际性实际相。无所从来亦无所去亦无所住。须菩提。不可思议。不可思议法。不可思议如。不可思议性。不可思议相。无所从来亦无所去亦无所住。须菩提。檀那波罗蜜。檀那波罗蜜法。檀那波罗蜜如。檀那波罗蜜性。檀那波罗蜜相。无所从来亦无所去亦无所住。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。般若波罗蜜法。般若波罗蜜如。般若波罗蜜性。般若波罗蜜相。无所从来亦无所去亦无所住。须菩提。四念处四念处法四念处如四念处性四念处相。无所从来亦无所去亦无所住。乃至十八不共法亦如是。须菩提。菩萨菩萨法菩萨如菩萨性菩萨相。无所从来亦无所去亦无所住。佛佛法佛如佛性佛相。无所从来亦无所去亦无所住。阿耨多罗三藐三菩提。阿耨多罗三藐三菩提法如性相。无所从来亦无所去亦无所住。须菩提。有为法有为法法有为法如有为法性有为法相。无所从来亦无所去亦无所住。须菩提。无为法无为法法无为法如无为法性无为法相。无所从来亦无所去亦无所住。以是因缘故。须菩提。是摩诃衍不见来处不见去处不见住处。须菩提。汝所言是摩诃衍前际不可得后际不可得中际不可得。是衍名三世等。以是故。说名摩诃衍。如是如是。须菩提。是摩诃衍前际不可得后际不可得中际不可得。是衍名三世等。以是故。说名摩诃衍。何以故。须菩提。过去世过去世空。未来世未来世空。现在世现在世空。三世等三世等空。摩诃衍摩诃衍空。菩萨菩萨空。何以故。须菩提。是空非一非二非三非四非五非异。以是故。说名三世等。是菩萨摩诃萨摩诃衍。是衍中等不等相不可得故。染不染不可得。嗔不嗔不可得痴不痴不可得。慢不慢不可得。乃至一切善法不善法不可得。是衍中常不可得无常不可得。乐不可得苦不可得。实不可得空不可得。我不可得无我不可得。欲界不可得色界不可得无色界不可得。度欲界不可得度色界不可得度无色界不可得。何以故。是摩诃衍自法不可得故。须菩提。过去色过去色空。未来现在色。未来现在色空。过去受想行识。过去受想行识空。未来现在受想行识。未来现在受想行识空。空中过去色不可得。何以故。空中空亦不可得。何况空中过去色可得。空中未来现在色不可得。何以故。空中空亦不可得。何况空中未来现在色可得。空中过去受想行识不可得。何以故。空中空亦不可得。何况空中过去受想行识可得。空中未来现在受想行识不可得。何以故。空中空亦不可得。何况空中未来现在受想行识可得。须菩提。过去檀那波罗蜜不可得。未来檀那波罗蜜不可得。现在檀那波罗蜜不可得。三世等中檀那波罗蜜亦不可得。何以故。等中过去世不可得。未来世不可得。现在世不可得。等中等亦不可得。何况等中过去世未来世现在世可得。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜亦如是。复次须菩提。过去世中四念处不可得。乃至过去世中十八不共法不可得。未来世现在世亦如是。复次须菩提。三世等中四念处不可得。三世等中乃至十八不共法亦不可得。何以故。等中过去世四念处不可得。等中未来世四念处不可得。等中现在世四念处不可得。乃至十八不共法亦如是。等中等亦不可得。何况等中过去世四念处。未来现在世四念处可得。等中等亦不可得。何况等中过去世乃至十八不共法可得。未来现在世乃至十八不共法亦如是。复次须菩提。过去世凡夫人不可得。未来世现在世中凡夫人不可得。三世等中凡夫人亦不可得。何以故。众生不可得。乃至知者见者不可得故。过去世中声闻辟支佛菩萨佛不可得。未来现在世。声闻辟支佛菩萨佛不可得。三世等中声闻辟支佛菩萨佛不可得。何以故。众生不可得乃至知者见者不可得故。如是须菩提。菩萨摩诃萨住般若波罗蜜中。学三世等相。当具足一切种智。是名菩萨摩诃萨摩诃衍。所谓三世等相。菩萨摩诃萨住是衍中。胜一切世间及诸天人阿修罗。成就萨婆若。尔时须菩提白佛言。世尊。善哉善哉。是菩萨摩诃萨摩诃衍。何以故。过去诸菩萨摩诃萨。是衍中学得一切种智。未来世诸菩萨摩诃萨。亦是衍中学当得一切种智。世尊。今十方无量阿僧祇国土中诸菩萨摩诃萨。亦是衍中学得一切种智。以是故。世尊。是衍实是菩萨摩诃萨摩诃衍。佛告须菩提。如是如是。过去未来现在诸佛是摩诃衍中学。已得一切种智。当得今得

摩诃般若经卷第六

佛告须菩提。汝所问是乘何处出至何处住者。佛言。是乘从三界中出。至萨婆若中住。以不二法故。何以故。摩诃衍萨婆若。是二法俱不合不散无色无形。无对一相。所谓无相。若人欲出无相法。为欲出实际。若欲出无相法。为欲出如法性不可思议性。若欲出无相法。为欲出色空。为欲出受想行识空。何以故。须菩提。色空相不出三界。亦不住萨婆若。受想行识空相不出三界。亦不住萨婆若。所以者何。色色相空。受想行识识相空故。若欲出无相法。为欲出眼空。为欲出耳鼻舌身意空。为欲出乃至眼触因缘生受空。耳鼻舌身意触因缘生受空。何以故。须菩提。眼空不出三界。亦不住萨婆若。乃至意触因缘生受空。不出三界。亦不住萨婆若。所以者何。眼眼相空。乃至意触因缘生受。意触因缘生受相空故。若欲出无相法。为欲出梦。为欲出幻焰响影佛所化。何以故。须菩提。梦相不出三界。亦不住萨婆若。幻焰响影化相不出三界。亦不住萨婆若。须菩提。若欲出无相法。为欲出檀那波罗蜜。若欲出无相法。为欲出尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。何以故。檀那波罗蜜相。不出三界。亦不住萨婆若。尸罗波罗蜜乃至般若波罗蜜。不出三界。亦不住萨婆若。何以故。檀那波罗蜜檀那波罗蜜性空。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。般若波罗蜜性空。若欲出无相法。为欲出内空乃至无法有法空。何以故。须菩提。内空性乃至无法有法空性。不出三界。亦不住萨婆若。所以者何。内空性内空性空。乃至无法有法空性。无法有法空性空故。若欲出无相法。为欲出四念处。何以故。四念处性。不出三界。亦不住萨婆若。所以者何。四念处性四念处性空。若欲出无相法。为欲出四正勤四如意足五根五力七觉分八圣道分。何以故。八圣道分性。不出三界。亦不住萨婆若。所以者何。八圣道分性八圣道分性空故。乃至十八不共法亦如是。须菩提。若欲出无相法。为欲出阿罗汉生处。为欲出辟支佛生处。为欲出多陀阿伽度阿罗呵三藐三佛陀生处。何以故。阿罗汉性辟支佛性佛性。不出三界。亦不住萨婆若。所以者何。阿罗汉性阿罗汉性空。辟支佛性辟支佛性空。佛性佛性空。若欲出无相法。为欲出须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道一切种智。何以故。须陀洹果乃至一切种智性。不出三界。亦不住萨婆若。所以者何。须陀洹果乃至一切种智。一切种智性空故。若欲出无相法。为欲出名字假名施设相但有言语。何以故。名字不出三界。亦不住萨婆若。所以者何。名字相名字相空故。乃至施设亦如是。若欲出无相法。为欲出不生不灭不垢不净无起无作法摩诃般若波罗蜜经卷第七

        后秦龟兹国三藏鸠摩罗什译

    会宗品第二十四

尔时慧命富楼那弥多罗尼子白佛言。世尊。佛使须菩提为诸菩萨摩诃萨说般若波罗蜜。今乃说摩诃衍为。须菩提白佛言。世尊。我说摩诃衍。将无离般若波罗蜜耶。佛言不也。须菩提。汝说摩诃衍。随般若波罗蜜不离。何以故。一切所有善法助道法。若声闻法若辟支佛法若菩萨法若佛法。是一切法皆摄入般若波罗蜜中。须菩提白佛言。世尊。何等诸善法助道法声闻法辟支佛法菩萨法佛法。皆摄入般若波罗蜜中。佛告须菩提。所谓檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。四念处四正勤四如意足五根五力七觉分八圣道分。空无相无作解脱门。佛十力四无所畏四无阂智大慈大悲十八不共法。无错谬相常舍行。须菩提。是诸余善法助道法。若声闻法若辟支佛法若菩萨法若佛法。皆摄入般若波罗蜜中。须菩提。若菩萨摩诃萨摩诃衍。若般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。若色受想行识。眼色眼识。眼触眼触因缘生诸受。乃至意法意识。意触意触因缘生诸受。地种乃至识种。四念处乃至八圣道分。空无相无作解脱门及诸善法。若有漏若无漏。若有为若无为。若苦谛集谛灭谛道谛。若欲界若色界若无色界。若内空乃至无法有法空。诸三昧门诸陀罗尼门。佛十力乃至十八不共法。若佛法佛法性如实际不可思议性涅槃。是一切诸法皆不合不散无色无形无对无阂。无等一相。所谓无相。须菩提。以是因缘故。汝所说摩诃衍随顺般若波罗蜜。何以故。须菩提。摩诃衍不异般若波罗蜜。般若波罗蜜不异摩诃衍。般若波罗蜜摩诃衍无二无别。檀那波罗蜜不异摩诃衍。摩诃衍不异檀那波罗蜜。檀那波罗蜜摩诃衍无二无别。乃至禅那波罗蜜亦如是。须菩提。四念处不异摩诃衍。摩诃衍不异四念处。四念处摩诃衍无二无别。乃至十八不共法不异摩诃衍。摩诃衍不异十八不共法。十八不共法摩诃衍无二无别。以是因缘故。须菩提。汝说摩诃衍即是说般若波罗蜜

    摩诃般若波罗蜜经十无品第二十五

慧命须菩提白佛言。世尊。菩萨摩诃萨前际不可得。后际不可得中际不可得色无边故。当知菩萨摩诃萨亦无边。受想行识无边故。当知菩萨摩诃萨亦无边。色是菩萨摩诃萨。是亦不可得。受想行识是菩萨摩诃萨。是亦不可得。如是世尊。于一切种一切处。求菩萨不可得。世尊。我当教何等菩萨摩诃萨般若波罗蜜。世尊。菩萨摩诃萨但有名字。如说我名字我毕竟不生。如我诸法亦如是无自性。何等色毕竟不生。何等受想行识毕竟不生。世尊。是毕竟不生不名为色。是毕竟不生不名为受想行识。世尊。若毕竟不生法。当教是般若波罗蜜耶。离毕竟不生亦无菩萨行阿耨多罗三藐三菩提。若菩萨闻作是说。心不没不悔不惊不怖不畏。当知是菩萨摩诃萨。能行般若波罗蜜。舍利弗问须菩提。何因缘故。言菩萨摩诃萨前际不可得后际不可得中际不可得。须菩提。何因缘故。言色无边故。当知菩萨亦无边。受想行识无边故。当知菩萨亦无边。须菩提。何因缘故。言色是菩萨是亦不可得。受想行识是菩萨是亦不可得。须菩提。何因缘故。言于一切种一切处菩萨不可得。当教何等菩萨般若波罗蜜。须菩提。何因缘故。言菩萨摩诃萨但有名字。须菩提。何因缘故。言如说我名字我毕竟不生。如我诸法亦如是无自性。何等色毕竟不生。何等受想行识毕竟不生。须菩提。何因缘故。言毕竟不生不名为色。毕竟不生不名为受想行识。须菩提。何因缘故。言若毕竟不生法。当教是般若波罗蜜耶。须菩提。何因缘故。言离毕竟不生亦无菩萨行阿耨多罗三藐三菩提。须菩提。何因缘故。言若菩萨闻作是说。心不没不悔不惊不怖不畏。若能如是行。是名菩萨摩诃萨行般若波罗蜜。尔时须菩提报舍利弗言。众生无所有故菩萨前际不可得。众生空故菩萨前际不可得。众生离故菩萨前际不可得。舍利弗。色无有故菩萨前际不可得。受想行识无有故菩萨前际不可得。色空故菩萨前际不可得。受想行识空故菩萨前际不可得。色离故菩萨前际不可得。受想行识离故菩萨前际不可得。舍利弗。色性无故菩萨前际不可得。受想行识性无故菩萨前际不可得。舍利弗檀那波罗蜜无有故菩萨前际不可得。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜无有故菩萨前际不可得。何以故。舍利弗。空中前际不可得后际不可得中际不可得。空不异菩萨。菩萨不异前际。舍利弗。空菩萨前际。是诸法无二无别。以是因缘故。舍利弗。菩萨前际不可得。舍利弗。檀那波罗蜜空故。檀那波罗蜜离故。檀那波罗蜜性无故。菩萨前际不可得。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜空故。般若波罗蜜离故。般若波罗蜜性无故。菩萨前际不可得。何以故。舍利弗。空中前际不可得后际不可得中际不可得。空不异菩萨亦不异前际。舍利弗。空菩萨前际无二无别。以是因缘故。舍利弗。菩萨前际不可得。复次舍利弗。内空无所有故。菩萨前际不可得。乃至无法有法空无所有故。菩萨前际不可得。内空空故内空离故内空性无故。乃至无法有法空空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。四念处无所有故。菩萨前际不可得。四念处空故离故性无故。菩萨前际不可得。乃至十八不共法无所有故。菩萨前际不可得。十八不共法空故离故性无故。菩萨前际不可得。余如上说。以是因缘故。舍利弗。菩萨前际不可得。复次舍利弗。一切三昧门。一切陀罗尼门无有故。菩萨前际不可得。三昧门陀罗尼门。空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。法性无有故。菩萨前际不可得。法性空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。如无有故空故离故性无故。实际无有故空故离故性无故。不可思议性无有故空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。声闻无有故菩萨前际不可得。声闻空故离故性无故菩萨前际不可得。辟支佛无有故空故离故性无故菩萨前际不可得。佛无有故空故离故性无故菩萨前际不可得。阿耨多罗三藐三菩提无有故。乃至性无故菩萨前际不可得。复次一切种智无有故乃至性无故菩萨前际不可得。何以故。舍利弗。空前际不可得后际不可得中际不可得。菩萨不可得。舍利弗。空不异菩萨亦不异前际。空菩萨前际。是诸法无二无别。以是因缘故。舍利弗。菩萨前际不可得后际中际亦如是。如舍利弗言。色无边故当知菩萨亦无边。受想行识无边故当知菩萨亦无边。舍利弗。色如虚空受想行识如虚空。何以故。舍利弗。如虚空边不可得中不可得。无边无中故但说名虚空如是舍利弗。色边不可得中不可得。是色空故。空中亦无边亦无中。受想行识边不可得中不可得。识空故。空中亦无边亦无中。以是因缘故。舍利弗。色无边故当知菩萨亦无边。受想行识无边故当知菩萨亦无边。乃至十八不共法亦如是。如舍利弗言。色是菩萨是亦不可得。受想行识是菩萨是亦不可得。舍利弗。色色相空。受想行识识相空。檀那波罗蜜檀那波罗蜜相空。乃至般若波罗蜜亦如是。内空内空相空。乃至无法有法空无法有法空相空。四念处四念处相空。乃至十八不共法十八不共法相空。如法性实际不可思议性不可思议性相空。三昧门三昧门相空。陀罗尼门陀罗尼门相空。一切智一切智相空。道智道智相空。一切种智一切种智相空。声闻乘声闻乘相空。辟支佛乘辟支佛乘相空。佛乘佛乘相空。声闻人声闻人相空。辟支佛人辟支佛人相空。佛佛相空。空中色不可得。受想行识不可得。以是因缘故。舍利弗。色是菩萨是亦不可得。受想行识是菩萨是亦不可得。如舍利弗言。何因缘故。于一切种一切处菩萨不可得。当教何等菩萨般若波罗蜜。舍利弗。色色中不可得。色受中不可得。受受中不可得。受色中不可得。受想中不可得。想想中不可得。想色受中不可得。想行中不可得。行行中不可得。行色受想中不可得。行识中不可得。识识中不可得。识色受想行中不可得。舍利弗。眼眼中不可得。眼耳中不可得。耳耳中不可得。耳眼中不可得。耳鼻中不可得。鼻鼻中不可得。鼻眼耳中不可得。鼻舌中不可得。舌舌中不可得。舌眼耳鼻中不可得。舌身中不可得。身身中不可得。身眼耳鼻舌中不可得。身意中不可得。意意中不可得。意眼耳鼻舌身中不可得。六入六识六触。六触因缘生受亦如是。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门一切陀罗尼门。性法乃至辟支佛法。初地乃至十地。一切智道种智一切种智亦如是。须陀洹乃至阿罗汉辟支佛菩萨佛亦如是。菩萨菩萨中不可得。菩萨般若波罗蜜中不可得。般若波罗蜜般若波罗蜜中不可得。般若波罗蜜菩萨中不可得。般若波罗蜜中教化无所有不可得。教化中教化无所有不可得。教化中菩萨及般若波罗蜜无所有不可得。舍利弗。如是一切法无所有不可得。以是因缘故。于一切种一切处菩萨不可得。当教何等菩萨般若波罗蜜。如舍利弗言。何因缘故。说菩萨摩诃萨但有假名。舍利弗。色是假名。受想行识是假名。色名非色。受想行识名非识。何以故。名名相空。若空则非菩萨。以是因缘故。舍利弗。菩萨但有假名。复次舍利弗。檀那波罗蜜但有名字。名字中非有檀那波罗蜜。檀那波罗蜜中非有名字。以是因缘故。菩萨但有假名。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜但有名字。名字中无有般若波罗蜜。般若波罗蜜中无有名字。以是因缘故。菩萨但有假名。舍利弗。内空但有名字。乃至无法有法空但有名字。名字中无内空。内空中无名字。何以故。名字内空俱不可得。乃至无法有法空亦如是。以是因缘故。舍利弗。菩萨但有假名。舍利弗。四念处但有名字。乃至十八不共法但有名字。一切三昧门一切陀罗尼门。乃至一切种智亦如是。以是因缘故。舍利弗。我说菩萨但有假名。如舍利弗言。何因缘故。说我名字毕竟不生。舍利弗。我毕竟不可得云何当有生。乃至知者见者毕竟不可得云何当有生。舍利弗。色毕竟不可得云何当有生。受想行识毕竟不可得云何当有生。眼毕竟不可得。乃至意触因缘生受毕竟不可得云何当有生。檀那波罗蜜毕竟不可得。乃至般若波罗蜜毕竟不可得云何当有生。内空毕竟不可得。乃至无法有法空毕竟不可得云何当有生。四念处毕竟不可得。乃至十八不共法毕竟不可得云何当有生。诸三昧门诸陀罗尼门毕竟不可得云何当有生。声闻乃至佛毕竟不可得云何当有生。以是因缘故。舍利弗。我说如我名字我亦毕竟不生。如舍利弗所言。如我诸法亦如是无自性。舍利弗。诸法和合生故无自性。舍利弗。何等和合生无自性。舍利弗。色和合生无自性。受想行识和合生无自性眼和合生无自性。乃至意和合生无自性。色乃至法。眼界乃至法界。地种乃至识种。眼触乃至意触。眼触因缘生受乃至意触因缘生受。和合生无自性。檀那波罗蜜乃至般若波罗蜜。和合生无自性。四念处乃至十八不共法。和合生无自性。复次舍利弗。一切法无常亦不失。舍利弗问须菩提。何等法无常亦不失。须菩提言。色无常亦不失。受想行识无常亦不失。何以故。法若无常即是动相即是空相。以是因缘故。舍利弗。一切有为法无常亦不失。复次舍利弗。若有漏法若无漏法。若有记法若无记法。何以故。若法无常即是动相即是空相。以是因缘故。舍利弗。一切作法无常亦不失。复次舍利弗。一切法非常非灭。舍利弗言。何等法非常非灭。须菩提言。色非常非灭。何以故。性自尔。受想行识非常非灭。何以故。性自尔。乃至意触因缘生受非常非灭。何以故。性自尔。以是因缘故。舍利弗。诸法和合生无自性。如舍利弗所言。何因缘故色毕竟不生。受想行识毕竟不生。须菩提言。色非作法。受想行识非作法。何以故。作者不可得故。舍利弗。眼非作法。何以故。作者不可得故。乃至意亦如是。眼界乃至意触因缘生受亦如是。复次舍利弗。一切诸法皆非起非作。何以故。作者不可得故。以是因缘故。舍利弗。色毕竟不生。受想行识毕竟不生。如舍利弗所言。何因缘故。毕竟不生是不名为色。毕竟不生是不名受想行识。须菩提言。色性空是空无生无灭无住异。受想行识性空是空无生无灭无住异。眼乃至一切有为法性空。是空无生无灭无住异。以是因缘故。舍利弗。毕竟不生不名色。毕竟不生不名受想行识。如舍利弗所言。何因缘故。毕竟不生法当教是般若波罗蜜耶。须菩提言。毕竟不生即是般若波罗蜜。般若波罗蜜即是毕竟不生。般若波罗蜜毕竟不生无二无别。以是因缘故。舍利弗。我说毕竟不生当教是般若波罗蜜耶。如舍利弗所言。何因缘故。离毕竟不生无菩萨行阿耨多罗三藐三菩提。须菩提言。菩萨摩诃萨行般若波罗蜜时。不见毕竟不生异般若波罗蜜。亦不见毕竟不生异菩萨。毕竟不生及菩萨无二无别。不见毕竟不生异色。何以故。是毕竟不生及色无二无别。不见毕竟不生异受想行识。何以故。毕竟不生受想行识无二无别。乃至一切种智亦如是。以是因缘故。舍利弗。离毕竟不生无菩萨行阿耨多罗三藐三菩提。如舍利弗所言。何因缘故。菩萨闻作是说。心不没不悔不惊不怖不畏。是名菩萨行般若波罗蜜。须菩提言。菩萨摩诃萨不见诸法有觉知想。见一切诸法如梦如响如幻如焰如影如化。舍利弗。以是因缘故。菩萨闻作是说。心不没不悔不惊不怖不畏。须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜如是观诸法。是时菩萨摩诃萨不受色不示色不住色不着色。亦不言是色。受想行识亦不受不示不住不着。亦不言是受想行识。眼不受不示不住不着亦不言是眼。耳鼻舌身意不受不示不住不着。亦不言是意。檀那波罗蜜不受不示不住不着。亦不言是檀那波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。不受不示不住不着。亦不言是般若波罗蜜。内空不受不示不住不着。亦不言是内空。乃至无法有法空亦如是。复次世尊。菩萨摩诃萨行般若波罗蜜时。四念处不受不示不住不着。亦不言是四念处。乃至十八不共法不受不示不住不着。亦不言是十八不共法。一切三昧门一切陀罗尼门乃至一切种智。不受不示不住不着。亦不言是一切种智。复次世尊。菩萨摩诃萨行般若波罗蜜时。不见色乃至不见一切种智。何以故。色不生是非色。受想行识不生是非识。眼不生是非眼。耳鼻舌身意不生是非意。檀那波罗蜜不生是非檀那波罗蜜。乃至般若波罗蜜不生是非般若波罗蜜。何以故。色不生不二不别。乃至般若波罗蜜不生不二不别。内空不生是非内空。乃至无法有法空不生是非无法有法空。何以故。内空乃至无法有法空不生不二不别。世尊。四念处不生非四念处。何以故。四念处不生不二不别。何以故。世尊。是不生法非一非二非三非异。以是故。四念处不生不二不别。乃至十八不共法不生非十八不共法。何以故。十八不共法不生不二不别。何以故。世尊。是不生法非一非二非三非异。以是故。十八不共法不生非十八不共法。世尊。如不生是非如。乃至不可思议性不生是非不可思议性。世尊。是阿耨多罗三藐三菩提不生。一切智一切种智不生是非一切种智。何以故。是阿耨多罗三藐三菩提乃至一切种智不生不二不别。何以故。世尊。是不生非一非二非三非异。以是故。乃至一切种智不生非一切种智。世尊。色不灭相是非色。何以故。色及不灭相不二不别。何以故。世尊。是不灭法非一非二非三非异。以是故。色不灭相是非色。受想行识不灭相是非识。何以故。识及不灭不二不别。何以故。世尊。是不灭法非一非二非三非异。以是故。识不灭是非识。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法亦如是。世尊。以是故。色入无二法数。受想行识入无二法数。乃至一切种智入无二法数

    摩诃般若波罗蜜经无生品第二十六

尔时慧命舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜观诸法。何等是菩萨。何等是般若波罗蜜。何等是观。须菩提语舍利弗。汝所问何等是菩萨。为阿耨多罗三藐三菩提是人发大心。以是故名为菩萨。亦知一切法一切种相。是中亦不着。知色相亦不着。乃至知十八不共法相亦不着。舍利弗问须菩提。何等为一切法相。须菩提言。若以名字因缘和合等知诸法。是色是声香味触法是内是外。是有为法是无为法。以是名字相语言知诸法。是名知诸法相。如舍利弗所问何等是般若波罗蜜。远离故是名般若波罗蜜。何等法远离。远离阴界入。远离檀那波罗蜜乃至禅那波罗蜜。远离内空乃至无法有法空。以是故远离名般若波罗蜜。复次远离四念处。乃至远离十八不共法。远离一切智。以是因缘故。远离名般若波罗蜜。如舍利弗所问何等是观。舍利弗。菩萨摩诃萨行般若波罗蜜时。观色非常非无常。非乐非苦。非我非无我。非空非不空。非相非无相。非作非无作。非寂灭非不寂灭。非离非不离。受想行识亦如是。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门一切陀罗尼门。乃至一切种智。观非常非无常非乐非苦。非我非无我非空非不空。非相非无相非作非无作。非寂灭非不寂灭非离非不离。舍利弗。是名菩萨摩诃萨行般若波罗蜜时观诸法。舍利弗问须菩提。何因缘故。色不生是非色。受想行识不生是非识。乃至一切种智不生是非一切种智。须菩提言。色色相空。色空中无色无生。以是因缘故。色不生是非色。受想行识识相空。识空中无识无生。以是因缘故。受想行识不生是非受想行识。舍利弗。檀那波罗蜜檀那波罗蜜相空。檀那波罗蜜空中无檀那波罗蜜无生。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。般若波罗蜜相空。般若波罗蜜空中无般若波罗蜜无生。以是因缘故。舍利弗。般若波罗蜜不生是非般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切种智亦如是。以是因缘故。内空不生是非内空。乃至一切种智不生是非一切种智。舍利弗问须菩提。汝何因缘故。言色不二是非色。受想行识不二是非识。乃至一切种智不二是非一切种智。须菩提答言。所有色所有不二。所有受想行识所有不二。是一切法皆不合不散无色无形无对一相所谓无相。眼乃至一切种智亦如是。以是因缘故。舍利弗。色不二是非色。受想行识不二是非识。乃至一切种智不二是非一切种智。舍利弗问须菩提。何因缘故。言是色入无二法数。受想行识入无二法数。乃至一切种智入无二法数。须菩提答言。色不异无生无生不异色。色即是无生无生即是色。受想行识不异无生。无生不异识。识即是无生无生即是识。以是因缘故。舍利弗。色入无二法数。受想行识入无二法数。乃至一切种智亦如是。尔时须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜如是观诸法。是时见色无生毕竟净故。见受想行识无生毕竟净故。见我无生乃至知者见者无生毕竟净故。见檀那波罗蜜无生乃至般若波罗蜜无生毕竟净故。见内空无生乃至无法有法空无生毕竟净故。见四念处无生乃至十八不共法无生毕竟净故。见一切三昧一切陀罗尼无生毕竟净故。乃至见一切种智无生毕竟净故。见凡人凡人法无生毕竟净故。见须陀洹须陀洹法斯陀含斯陀含法阿那含阿那含法阿罗汉阿罗汉法辟支佛辟支佛法菩萨菩萨法佛佛法无生毕竟净故。舍利弗语须菩提。如我闻须菩提所说义。色是不生受想行识是不生。乃至佛佛法是不生。若尔者今不应得须陀洹须陀洹果斯陀含斯陀含果阿那含阿那含果阿罗汉阿罗汉果辟支佛辟支佛道。不应得菩萨摩诃萨一切种智。亦无六道别异。亦不得菩萨摩诃萨五种菩提。须菩提。若一切法不生相。何以故。须陀洹为断三结故修道。斯陀含为薄淫恚痴故修道。阿那含为断五下分结故修道。阿罗汉为断五上分结故修道。辟支佛为辟支佛法故修道。何以故。菩萨摩诃萨作难行为众生受种种苦。何以故。佛得阿耨多罗三藐三菩提。何以故。佛转法轮。须菩提语舍利弗。我不欲令无生法有所得。我亦不欲令无生法中得须陀洹须陀洹果。乃至不欲令无生法中得阿罗汉阿罗汉果辟支佛辟支佛道。我亦不欲令菩萨作难行为众生受种种苦。菩萨亦不以难行心行道。何以故。舍利弗。生难心苦心不能利益无量阿僧祇众生。舍利弗。今菩萨怜愍众生。于众生如父母兄弟想。如儿子及己身想。如是能利益无量阿僧祇众生。用无所得故。所以者何。菩萨摩诃萨应生如是心。如我一切处一切种不可得。内外法亦如是。若生如是想则无难心苦心。何以故。是菩萨于一切种一切处一切法不受故。舍利弗。我亦不欲令无生中佛得阿耨多罗三藐三菩提。亦不欲令无生中转法轮。亦不欲令以无生法得道。舍利弗语须菩提。今欲令以生法得道以无生法得道。须菩提语舍利弗。我不欲令以生法得道。舍利弗言。今须菩提欲令以无生法得道。须菩提言。我亦不欲令以无生法得道。舍利弗言。如须菩提所说无知无得。须菩提言。有知有得不以二法。今以世间名字故有知有得。世间名字故有须陀洹乃至阿罗汉辟支佛诸佛。第一实义中无知无得。无须陀洹乃至无佛。须菩提。若世间名字故有知有得。六道别异亦世间名字故有。非以第一实义耶。须菩提言。如是如是。舍利弗。如世间名字故有知有得。六道别异亦世间名字故有。非以第一实义。何以故。舍利弗。第一实义中无业无报无生无灭无净无垢。舍利弗语须菩提。不生法生。生法生。须菩提言。我不欲令不生法生。亦不欲令生法生。舍利弗言。何等不生法不欲令生。须菩提言。色是不生法。自性空不欲令生。受想行识是不生法。自性空不欲令生。乃至阿耨多罗三藐三菩提是不生法。自性空不欲令生。舍利弗语须菩提。生生不生生。须菩提言。非生生亦非不生生。何以故。舍利弗。生不生是二法。不合不散无色无形无对一相所谓无相。舍利弗。以是因缘故。非生生亦非不生生。尔时舍利弗语须菩提。须菩提。乐说无生法及无生相。须菩提语舍利弗。我乐说无生法亦乐说无生相。何以故。诸无生法无生相及乐说语言。是一切法皆不合不散无色无形无对一相所谓无相。舍利弗语须菩提。汝乐说不生法亦乐说不生相。是乐说语言亦不生。须菩提言。如是如是舍利弗。何以故。舍利弗。色不生受想行识不生。眼不生乃至意不生。地种不生乃至识种不生。身行不生口行不生意行不生。檀那波罗蜜不生。乃至一切种智不生。以是因缘故。舍利弗。我乐说不生法亦乐说不生相。是乐说语言亦不生。尔时舍利弗语须菩提。须菩提于说法人中应最在上。何以故。须菩提。随所问皆能答。须菩提言。诸法无所依故。舍利弗语须菩提。云何诸法无所依。须菩提言。色性常空。不依内不依外不依两中间。受想行识性常空。不依内不依外不依两中间。眼耳鼻舌身意性常空。不依内不依外不依两中间。色性常空乃至法性常空。不依内不依外不依两中间。檀那波罗蜜性常空。乃至般若波罗蜜性常空。不依内不依外不依两中间。内空性常空。乃至无法有法空性常空。不依内不依外不依两中间。舍利弗。四念处性常空。乃至一切种智性常空。不依内不依外不依两中间。以是因缘故。舍利弗。一切诸法无所依性常空故。如是舍利弗。菩萨摩诃萨行六波罗蜜时。应净色受想行识乃至应净一切种智。舍利弗问须菩提。菩萨摩诃萨云何行六波罗蜜时净菩萨道。须菩提言。有世间檀那波罗蜜。有出世间檀那波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。有世间有出世间。舍利弗问须菩提。云何世间檀那波罗蜜。云何出世间檀那波罗蜜。须菩提言。若菩萨摩诃萨作施主。能施沙门婆罗门贫穷乞人。须食与食须饮与饮须衣与衣。卧具床榻房舍香华璎珞医药。种种所须资生之物。若妻子国土头目手足支节等。内外之物尽以给施。施时作是念。我与彼取我不悭贪。我为施主我能舍一切。我随佛教施我行檀那波罗蜜。作是施已。用得法与一切众生共之。回向阿耨多罗三藐三菩提。念言。是布施因缘。令众生得今世乐。后当令得入涅槃乐。是人布施有三碍。何等三。我相他相施相。着是三相布施。是名世间檀那波罗蜜。何因缘故名世间。于世间中不动不出。是名世间檀那波罗蜜。云何名出世间檀那波罗蜜。所谓三分清净。何等三。菩萨摩诃萨布施时。我不可得不见受者。施物不可得亦不望报。是名菩萨摩诃萨三分清净檀那波罗蜜。复次舍利弗。菩萨摩诃萨布施时。施与一切众生。众生亦不可得。以此布施回向阿耨多罗三藐三菩提。乃至不见微细法相。舍利弗。是名出世间檀那波罗蜜。何以故。名为出世间。于世间中能动能出。是故名出世间檀那波罗蜜。尸罗波罗蜜有所依是名世间尸罗波罗蜜。无所依是为出世间尸罗波罗蜜。余如檀那波罗蜜说。羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜有所依是名世间无所依是名出世间。余亦如檀那波罗蜜中说。如是舍利弗。菩萨摩诃萨行六波罗蜜时净菩萨道。舍利弗问须菩提。云何菩萨摩诃萨为阿耨多罗三藐三菩提道。须菩提言。四念处。是菩萨摩诃萨为阿耨多罗三藐三菩提道。乃至八圣道分空解脱门无相解脱门无作解脱门。内空乃至无法有法空。一切三昧门一切陀罗尼门。佛十力四无所畏四无碍智。十八不共法大慈大悲。舍利弗。是名菩萨摩诃萨为阿耨多罗三藐三菩提道。尔时舍利弗赞须菩提言。善哉善哉。何等波罗蜜力。须菩提言。是般若波罗蜜力。所以者何。般若波罗蜜能生一切诸善法若声闻法辟支佛法菩萨法佛法。舍利弗。般若波罗蜜能受一切诸善法声闻法辟支佛法菩萨法佛法。舍利弗。过去诸佛行般若波罗蜜得阿耨多罗三藐三菩提。未来诸佛亦行般若波罗蜜当得阿耨多罗三藐三菩提。舍利弗。今现在十方诸国土中。诸佛亦行是般若波罗蜜得阿耨多罗三藐三菩提。舍利弗。若菩萨摩诃萨闻说般若波罗蜜时不疑不难。当知是菩萨摩诃萨行菩萨道。行菩萨道者救一切众生故。心不舍一切众生。以无所得故。是菩萨常应不离是念。所谓大悲念。舍利弗复问。欲使菩萨摩诃萨常不离是念。所谓大悲念。若菩萨摩诃萨常不离大悲念。今一切众生皆当作菩萨。何以故。须菩提。一切众生亦不离诸念故。须菩提言。善哉善哉舍利弗。汝欲难我而成我义。何以故。众生无故念亦无。众生性无故念性亦无。众生法无故念法亦无。众生离故念亦离。众生空故念亦空。众生不可知故念亦不可知。舍利弗。色无故念亦无。色性无故念性亦无。色法无故念法亦无。色离故念亦离。色空故念亦空。色不可知故念亦不可知。受想行识亦如是。眼乃至意。色乃至法。地种乃至识种。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门一切陀罗尼门。一切智一切种智乃至阿耨多罗三藐三菩提无故念亦无。乃至阿耨多罗三藐三菩提不可知故念亦不可知。舍利弗。菩萨摩诃萨行是道。我欲使不离是念。所谓大悲念。尔时佛赞须菩提言。善哉善哉。是菩萨摩诃萨般若波罗蜜其有说者亦当如是说。汝所说般若波罗蜜皆是承佛意故。菩萨摩诃萨学般若波罗蜜应如汝所说学。须菩提说是般若波罗蜜品时。三千大千国土六种震动。东踊西没西踊东没。南踊北没北踊南没。中踊边没边踊中没。尔时佛微笑。须菩提白佛。何因缘故笑。佛告须菩提。如我于此国土说般若波罗蜜。东方无量阿僧祇国土中诸佛。亦为诸菩萨摩诃萨说般若波罗蜜。南西北方四维上下亦说是般若波罗蜜。说是般若波罗蜜品时。十二那由他诸天人得无生法忍。十方诸佛说是般若波罗蜜时。无量阿僧祇众生亦发阿耨多罗三藐三菩提心

    摩诃般若波罗蜜经问住品第二十七(丹本作天主品)

尔时三千大千世界诸四天王天等。各与无数百千亿诸天俱来在会中。三千大千世界诸释提桓因等。诸忉利天须夜摩天王等。诸夜摩天兜率陀天王等。诸兜率陀天须涅蜜陀天王等。诸妙化天婆舍跋提天王等。诸自在行天各与无数百千亿诸天俱来在会中。三千大千世界诸梵天王等。乃至首陀婆诸天等。各与无数百千亿诸天俱来在会中。是诸四天王天乃至首陀婆诸天业报生身光明。于佛常光百分千分千万亿分不能及一。乃至不可以算数譬喻为比。世尊光明最胜最妙最上第一。诸天业报光明。在佛光边不照不现。譬如燋柱比阎浮檀金。尔时释提桓因白大德须菩提。是三千大千世界诸四天王天乃至首陀婆诸天。一切和合欲听须菩提说般若波罗蜜义。须菩提。菩萨摩诃萨云何应住般若波罗蜜中。何等是菩萨摩诃萨般若波罗蜜。云何菩萨摩诃萨应行般若波罗蜜。须菩提语释提桓因言。憍尸迦。我今当承顺佛意承佛神力。为诸菩萨摩诃萨说般若波罗蜜。如菩萨摩诃萨所应住般若波罗蜜中。诸天子。今未发阿耨多罗三藐三菩提心者应当发心。诸天子若入声闻正位。是人不能发阿耨多罗三藐三菩提心。何以故。与生死作障隔故。是人若发阿耨多罗三藐三菩提心者我亦随喜。所以者何。上人应更求上法。我终不断其功德。憍尸迦。何等是般若波罗蜜。菩萨摩诃萨应萨婆若心。念色无常念色苦念色空念色无我。念色如病如败痈疮。如箭入身痛恼衰坏忧畏不安。以无所得故。受想行识亦如是。眼耳鼻舌身意。地种水火风空识种。观无常乃至忧畏不安。是亦无所得故。观色寂灭离不生不灭不垢不净。受想行识亦如是。观地种乃至识种寂灭离不生不灭不垢不净亦无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心。观无明缘诸行。乃至老死因缘大苦聚集亦无所得故。观无明灭故诸行灭。乃至生灭故老死灭。老死灭故忧悲苦恼大苦聚灭。以无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心修四念处。以无所得故。乃至修佛十力十八不共法。以无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心行檀那波罗蜜。以无所得故。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。以无所得故。复次憍尸迦。菩萨摩诃萨行般若波罗蜜时。作是观。但诸法诸法共相因缘润益增长分别校计。是中无我无我所。菩萨回向心不在阿耨多罗三藐三菩提心中。阿耨多罗三藐三菩提心不在回向心中。回向心于阿耨多罗三藐三菩提心中不可得。阿耨多罗三藐三菩提心于回向心中不可得。菩萨虽观一切法亦无法可得。是名菩萨摩诃萨般若波罗蜜。释提桓因问大德须菩提云何菩萨回向心不在阿耨多罗三藐三菩提心中。云何阿耨多罗三藐三菩提心不在回向心中。云何回向心于阿耨多罗三藐三菩提心中不可得。云何阿耨多罗三藐三菩提心于回向心中不可得。须菩提语释提桓因言。憍尸迦。回向心阿耨多罗三藐三菩提心。非心是非心相。非心相中不可回向。是非心相常非心相。不可思议相常不可思议相。是名菩萨摩诃萨般若波罗蜜。尔时佛赞须菩提言。善哉善哉。须菩提。汝为诸菩萨摩诃萨说般若波罗蜜。安慰诸菩萨摩诃萨心。须菩提白佛言。世尊。我应报恩不应不报恩。过去诸佛及诸弟子为诸菩萨说六波罗蜜示教利喜。世尊。尔时亦在中学得阿耨多罗三藐三菩提。我今亦当为诸菩萨说六波罗蜜示教利喜。令得阿耨多罗三藐三菩提。尔时须菩提语释提桓因言。憍尸迦。汝今当听菩萨摩诃萨般若波罗蜜中。如所应住所不应住。憍尸迦。色色空受想行识受想行识空。菩萨菩萨空。是色空菩萨空不二不别。受想行识空菩萨空不二不别。憍尸迦菩萨摩诃萨般若波罗蜜中应如是住。复次眼眼空乃至意意空菩萨菩萨空。眼空乃至菩萨空不二不别。六尘亦如是。地种地种空。乃至识种识种空。菩萨菩萨空。憍尸迦。地种空乃至识种空。菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。无明无明空。乃至老死老死空。无明灭无明灭空。乃至老死灭老死灭空。菩萨菩萨空。憍尸迦。无明空乃至老死空。无明灭空乃至老死灭空。菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门一切陀罗尼门。声闻乘辟支佛乘佛乘。声闻辟支佛菩萨佛亦如是。一切种智一切种智空。菩萨菩萨空。一切种智空菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。尔时释提桓因问须菩提。云何般若波罗蜜中所不应住。须菩提言。憍尸迦。菩萨摩诃萨不应色中住。以有所得故。不应受想行识中住。以有所得故。不应眼中住乃至不应意中住。不应色中住乃至不应法中住。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受中不应住。以有所得故。地种乃至识种中不应住。以有所得故。檀那波罗蜜乃至般若波罗蜜。四念处乃至十八不共法中不应住。以有所得故。须陀洹果中不应住。以有所得故。乃至阿罗汉果辟支佛道菩萨道佛道一切种智中不应住。以有所得故。复次憍尸迦。菩萨摩诃萨色是常不应住。色是无常不应住。受想行识亦如是。色若乐若苦若净若不净。若我若无我若空若不空。若寂灭若不寂灭若离若不离不应住。以有所得故。受想行识亦如是。复次憍尸迦。菩萨摩诃萨须陀洹果无为相。斯陀含果无为相。阿那含果无为相。阿罗汉果无为相不应住。辟支佛道无为相佛道无为相不应住。须陀洹福田不应住。斯陀含阿那含阿罗汉辟支佛佛福田不应住。复次憍尸迦。菩萨摩诃萨初地中不应住。以有所得故。乃至十地中不应住。以有所得故。复次菩萨摩诃萨住初发心中。我当具足檀那波罗蜜不应住。乃至我当具足般若波罗蜜不应住。具足六波罗蜜当入菩萨位不应住。入菩萨位已当住阿惟越致地不应住。菩萨当具足五神通不应住。以有所得故。菩萨住五神通已。我当游无量阿僧祇佛国土。礼敬供养诸佛听法。听法已为他人说。菩萨摩诃萨如是不应住。以有所得故。如诸佛国土严净。我亦当庄严国土不应住。以有所得故。成就众生令入佛道不应住。到无量阿僧祇国土诸佛所。尊重爱敬供养。以香华璎珞泽香捣香幢幡华盖百千亿种宝衣供养诸佛不应住。以有所得故。我当令无量阿僧祇众生发阿耨多罗三藐三菩提心。如是菩萨不应住。我当生五眼肉眼天眼慧眼法眼佛眼不应住。我当生一切三昧门不应住。随所欲游戏诸三昧不应住。我当生一切陀罗尼门不应住。我当得佛十力不应住。我当得四无所畏四无碍智十八不共法不应住。我当具足大慈大悲不应住。我当具足三十二相不应住。我当具足八十随形好不应住。以有所得故。是八人是信行人。是法行人如是不应住。须陀洹极七世生不应住。家家不应住。须陀洹命终垢尽不应住。须陀洹中间入涅槃不应住。是人向斯陀含果证不应住。是人斯陀含一来入涅槃不应住。是人向阿那含果证不应住。斯陀含一种不应住。是人阿那含彼间入涅槃不应住。是人向阿罗汉果证不应住。是人阿罗汉今世入无余涅槃不应住。是辟支佛不应住。过声闻辟支佛地我当住菩萨地不应住。道种智中不应住。以有所得故。一切种一切法知已断诸烦恼及习不应住。佛得阿耨多罗三藐三菩提当转法轮不应住。作佛事度无量阿僧祇众生入涅槃不应住四如意足中不应住。入是三昧住如恒河沙等劫寿不应住。我当得寿命无央数劫不应住。三十二相一一相百福庄严不应住。我一世界如十方恒河沙等世界不应住。我三千大千世界纯是金刚不应住。我菩提树当出如是香。众生闻者无有淫欲嗔恚愚痴。亦无声闻辟支佛心。是一切人必当得阿耨多罗三藐三菩提。若众生闻是香者。身病意病皆悉除尽不应住。当使我世界中无有色受想行识名字不应住。当使我世界中无有檀那波罗蜜名字。乃至无有般若波罗蜜名字。当使我世界中无有四念处名字。乃至无有十八不共法名字。亦无须陀洹名字乃至无有佛名字不应住。以有所得故。何以故。诸佛得阿耨多罗三藐三菩提时。一切诸法无所得故。如是憍尸迦。菩萨于般若波罗蜜中不应住。以有所得故。尔时舍利弗心念。菩萨今云何应住般若波罗蜜中。须菩提知舍利弗心所念。语舍利弗言。于汝意云何。诸佛何所住。舍利弗语须菩提。诸佛法无有住处。诸佛不色中住。不受想行识中住。不有为性中住。不无为性中住。不四念处中住。乃至不十八不共法中住。不一切种智中住。舍利弗。菩萨摩诃萨般若波罗蜜中应如是住。如诸佛住。于诸法中非住非不住。舍利弗。菩萨摩诃萨般若波罗蜜中应如是学。我当住不住法故。尔时会中有诸天子。作是念。诸夜叉语言字句所说尚可了知。须菩提所说语言论议解释般若波罗蜜了不可知。须菩提知诸天子心所念。语诸天子。不解不知耶。诸天子言。大德。不解不知。须菩提语诸天子。汝等法应不知我无所论说。乃至我不说一字亦无听者。何以故。诸字非般若波罗蜜。般若波罗蜜中无听者。诸佛阿耨多罗三藐三菩提无字无说。诸天子。如佛化作化人。是化人复化作四部众比丘比丘尼优婆塞优婆夷。化人于四部众中说法。于汝意云何。是中有说者有听者有知者不。诸天子言。不也大德。须菩提言。一切法皆如化。此中无说者无听者无知者。诸天子。譬如人梦中见佛说法。于汝意云何。是中有说者有听者有知者不。诸天子言。不也大德。须菩提语诸天子。一切诸法皆如梦。无说无听无知者。诸天子。譬如二人在大深涧。各住一面赞佛法众有二响出。于诸天子意云何。是二响展转相解不。诸天子言。不也大德。须菩提语诸天子。一切法亦如是。无说无听无知者。诸天子。譬如工幻师。于四衢道中化作佛及四部众于中说法。于诸天子意云何。是中有说者有听者有知者不。诸天子言。不也大德。须菩提语诸天子。一切诸法如幻无说者无听者无知者。尔时诸天子心念。须菩提所说欲令易解转深转妙。须菩提知诸天子心所念。语诸天子言。色非深非妙。受想行识非深非妙。色性非深非妙。受想行识性非深非妙。眼性乃至意性色性乃至法性。眼界性乃至意界性。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切诸三昧门一切诸陀罗尼门。乃至一切种智一切种智性非深非妙。诸天子复作是念。是所说法中不说色。不说受想行识。不说眼乃至意触因缘生受。不说檀那波罗蜜乃至般若波罗蜜。不说内空乃至无法有法空。不说四念处乃至十八不共法。不说陀罗尼门三昧门乃至一切种智。不说须陀洹果乃至阿罗汉果。不说辟支佛道。不说阿耨多罗三藐三菩提道。是法中不说名字语言。须菩提知诸天子心所念。语诸天子言。如是如是诸天子。是法中诸佛阿耨多罗三藐三菩提不可说相。是中无说者无听者无知者。以是故。诸天子。善男子善女人欲住须陀洹果依证须陀洹果者。是人不离是忍。斯陀含阿那含阿罗汉果辟支佛道佛道。欲住欲证不离是忍。如是诸天子。菩萨摩诃萨从初发心般若波罗蜜中应作如是住。以无说无听故

摩诃般若经卷第七摩诃般若波罗蜜经卷第八

        后秦龟兹国三藏鸠摩罗什译

    幻听品第二十八(丹本作幻人听法品)

尔时诸天子心念。应用何等人听须菩提所说法。须菩提知诸天子心所念。语诸天子言。如幻化人听法。我应用如是人。何以故。如是人无闻无听无知无证故。诸天子语须菩提。是众生如幻听法者亦如幻。众生如化听法者亦如化耶。如是如是。诸天子。众生如幻听法者亦如幻。众生如化听法者亦如化。诸天子。我如幻如梦。众生乃至知者见者亦如幻如梦。诸天子。色如幻如梦。受想行识如幻如梦。眼乃至意触因缘生受如幻如梦。内空乃至无法有法空。檀那波罗蜜乃至般若波罗蜜。如幻如梦。诸天子。四念处乃至十八不共法如幻如梦。须陀洹果如幻如梦。斯陀含果阿那含果阿罗汉果辟支佛道如幻如梦。诸天子。佛道如幻如梦。尔时诸天子问须菩提。汝说佛道如幻如梦。汝说涅槃亦复如幻如梦耶。须菩提语诸天子。我说佛道如幻如梦。我说涅槃亦如幻如梦。若当有法胜于涅槃者。我说亦复如幻如梦。何以故。诸天子。是幻梦涅槃不二不别。尔时慧命舍利弗。摩诃目揵连。摩诃拘絺罗。摩诃迦旃延。富楼那弥多罗尼子。摩诃迦叶。及无数千菩萨问须菩提。般若波罗蜜如是甚深难见难解难知寂灭微妙。谁当受者。尔时阿难语诸大弟子及诸菩萨阿惟越致诸菩萨摩诃萨。能受是甚深难见难解难知寂灭微妙般若波罗蜜。正见成就人。漏尽阿罗汉所愿已满亦能信受。复次善男子善女人。多见佛于诸佛所多供养种善根。亲近善知识有利根。是人能受不言是法非法。须菩提言。不以空分别色。不以色分别空。受想行识亦如是。不以无相无作分别色。不以色分别无相无作。受想行识亦如是。不以无生无灭寂灭离分别色。不以色分别无生无灭寂灭离。受想行识亦如是。眼乃至意触因缘生受亦如是。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法一切三昧门一切陀罗尼门。须陀洹乃至阿罗汉辟支佛佛一切智。不以空分别一切智。不以一切智分别空。不以空分别一切种智。不以一切种智分别空。无相无作无生无灭寂灭离亦如是。须菩提语诸天子言。是般若波罗蜜甚深谁能受者。是般若波罗蜜中无法可示无法可说。若无法可示无法可说。受人亦不可得。尔时舍利弗语须菩提言。般若波罗蜜中广说三乘之教及护持菩萨之教。从初发意地乃至十地。檀那波罗蜜乃至般若波罗蜜。四念处乃至八圣道分。佛十力乃至十八不共法护持菩萨之教。菩萨摩诃萨如是行般若波罗蜜。常化生不失神通。游诸佛国具足善根。随其所欲供养诸佛即得如愿。从诸佛所听受法教乃至萨婆若初不断绝。未曾离三昧时。当得揵疾辩利辩不尽辩不可断辩随应辩义辩一切世间最上辩。须菩提言。如是如是。如舍利弗言。般若波罗蜜广说三乘之教及护持菩萨之教。乃至菩萨摩诃萨得一切世间最上辩。不可得故。我乃至知者见者不可得。色受想行识檀那波罗蜜乃至般若波罗蜜不可得。内空乃至无法有法空不可得四念处乃至八圣道分。佛十力乃至一切种智亦不可得故。舍利弗语须菩提。何因缘故般若波罗蜜中广说三乘而不可得。何因缘故。般若波罗蜜中护持菩萨。何因缘故。菩萨摩诃萨得捷疾辩乃至一切世间最上辩。不可得故。须菩提语舍利弗言。以内空故般若波罗蜜广说三乘不可得。外空乃至无法有法空故。广说三乘不可得。内空故护持菩萨乃至一切世间最上辩。不可得故。外空乃至无法有法空故。护持菩萨乃至一切世间最上辩。不可得故

    摩诃般若波罗蜜经散花品第二十九

尔时释提桓因及三千大千世界中四天王天乃至阿迦尼吒诸天。作是念。慧命须菩提为雨法雨。我等宁可化作花散佛菩萨摩诃萨比丘僧须菩提及般若波罗蜜上。即时释提桓因。及三千大千世界中诸天。化作花散佛菩萨摩诃萨比丘僧及须菩提上。亦供养般若波罗蜜。是时三千大千世界花悉周遍于虚空中。化成花台端严殊妙。须菩提心念。是诸天子所散花天上未曾见如是花比。是花是化花非树生花。是诸天子所散花。从心树生非树生花。释提桓因知须菩提心所念。语须菩提言。大德。是花非生花亦非意树生。须菩提语释提桓因言。憍尸迦。汝言是华非生花亦非意树生。憍尸迦。是花若非生法不名为花。释提桓因语须菩提言。大德。但是花不生色亦不生。受想行识亦不生。须菩提言。憍尸迦。非但是花不生色亦不生。若不生是不名为色。受想行识亦不生。若不生是不名为识。六入六识六触。六触因缘生诸受亦如是。檀那波罗蜜不生。若不生是不名檀那波罗蜜乃至般若波罗蜜不生。若不生是不名般若波罗蜜。内空不生。若不生是不名内空。乃至无法有法空不生。若不生是不名无法有法空。四念处不生。若不生是不名四念处。乃至十八不共法不生。若不生是不名十八不共法。乃至一切种智不生。若不生是不名一切种智。尔时释提桓因心念是。慧命须菩提。其智甚深不坏假名而说诸法相。佛知释提桓因心所念语释提桓因言。如是如是。憍尸迦。须菩提其智甚深不坏假名而说诸法相。释提桓因白佛言。世尊。大德须菩提云何不坏假名而说诸法相。佛告释提桓因。色但假名。须菩提不坏假名而说诸法相。受想行识但假名。须菩提亦不坏假名而说诸法相。所以者何。是诸法相无坏不坏故。须菩提所说亦无坏不坏。眼乃至意触因缘生诸受亦如是。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法亦如是。须陀洹果乃至阿罗汉果。辟支佛道菩萨道佛道。一切智一切种智亦如是。须陀洹乃至阿罗汉辟支佛佛是但假名。须菩提不坏假名而说诸法相。何以故。是诸法相无坏不坏故。须菩提所说亦无坏不坏。如是憍尸迦。须菩提不坏假名而说诸法相。须菩提语释提桓因言。如是如是。憍尸迦。如佛所说诸法但假名。菩萨摩诃萨当作是知诸法但假名。应如是学般若波罗蜜。憍尸迦。菩萨摩诃萨作如是学。为不学色不学受想行识。何以故。不见色当可学者。不见受想行识当可学者。菩萨摩诃萨如是学为不学檀那波罗蜜。何以故。不见檀那波罗蜜当可学者。乃至不学般若波罗蜜。何以故。不见般若波罗蜜当可学者。如是学为不学内空乃至无法有法空。何以故。不见内空乃至无法有法空当可学者。如是学为不学四念处乃至十八不共法。何以故。不见四念处乃至十八不共法当可学者。如是学为不学须陀洹果乃至一切种智。何以故。不见须陀洹果乃至一切种智当可学者。尔时释提桓因语须菩提言。菩萨摩诃萨何因缘故。不见色乃至不见一切种智。须菩提言。色色空乃至一切种智一切种智空。憍尸迦。色空不学色空。乃至一切种智空不学一切种智空。憍尸迦。若如是不学空是名学空以不二故。是菩萨摩诃萨学色空以不二故。乃至学一切种智空不二故。若学色空不二故。乃至学一切种智空不二故。是菩萨摩诃萨能学檀那波罗蜜不二故。乃至能学般若波罗蜜不二故。能学四念处不二故。乃至能学十八不共法不二故。能学须陀洹果不二故。乃至能学一切种智不二故。是菩萨能学无量无边阿僧祇佛法。若能学无量无边阿僧祇佛法。是菩萨不为色增学不为色减学。乃至不为一切种智增学。不为一切种智减学。若不为色增减学。乃至不为一切种智增减学。是菩萨不为色受学。不为色灭学。亦不为受想行识受学亦不为灭学。乃至一切种智亦不为受学亦不为灭学。舍利弗语须菩提。菩萨摩诃萨如是学不为受色学不为灭色学。乃至一切种智亦不为受学亦不为灭学。须菩提言。菩萨摩诃萨若如是学不为受色学不为灭色学。乃至一切种智亦不为受学亦不为灭学。须菩提。何因缘故。菩萨摩诃萨不为受色学不为灭色学。乃至一切种智亦不为受学亦不为灭学。须菩提言。是色不可受亦无受色者。乃至一切种智不可受亦无受者。内外空故。如是舍利弗。菩萨摩诃萨一切法不受故。能到一切种智。是时舍利弗语须菩提。菩萨摩诃萨如是学般若波罗蜜能到一切种智耶。须菩提言。菩萨摩诃萨如是学般若波罗蜜能到一切种智。一切法不受故。舍利弗语须菩提。若菩萨摩诃萨于一切法不受不灭学者。菩萨摩诃萨云何能到一切种智。须菩提言。菩萨摩诃萨行般若波罗蜜。不见色生不见色灭。不见色受不见色不受。不见色垢不见色净。不见色增不见色减。何以故。舍利弗。色色性空故。受想行识亦不见生亦不见灭。亦不见受亦不见不受。亦不见垢亦不见净。亦不见增亦不见减。何以故。识识性空故。乃至一切种智。亦不见生亦不见灭。亦不见受亦不见不受。亦不见垢亦不见净。亦不见增亦不见减。何以故。一切种智一切种智性空故。如是舍利弗。菩萨摩诃萨为一切法。不生不灭不受不舍不垢不净不合不散不增不减故。学般若波罗蜜能到一切种智。无所学无所到故。尔时释提桓因语舍利弗。菩萨摩诃萨般若波罗蜜当于何处求。舍利弗言。菩萨摩诃萨般若波罗蜜。当于须菩提品中求。释提桓因语须菩提。是汝神力使舍利弗言。菩萨摩诃萨般若波罗蜜。当于须菩提品中求。须菩提语释提桓因。非我神力。释提桓因语须菩提。是谁神力。须菩提言。是佛神力。释提桓因言。一切法皆无受处。何以故。言是佛神力。离无受处相如来不可得。离如如来亦不可得。须菩提语释提桓因言。如是如是。憍尸迦。离无受处相如来不可得。离如如来亦不可得。无受处相中如来不可得。如中如来不可得。色如中如来如不可得。如来如中色如不可得。色法相中如来法相不可得。如来法相中色法相不可得。受想行识法相中。乃至一切种智如法亦如是。憍尸迦。如来色如中不合不散。受想行识如中不合不散。如来离色如不合不散。离受想行识如不合不散。乃至一切种智亦如是。如来色法相中不合不散。受想行识法相中不合不散。如来离色法相中不合不散。离受想行识法相中不合不散。乃至一切种智亦如是。憍尸迦。如是等一切法中不合不散。是佛神力用无所受法故。如憍尸迦言。菩萨摩诃萨般若波罗蜜当于何处求。憍尸迦。不应色中求般若波罗蜜。亦不应离色求般若波罗蜜。不应受想行识中求。亦不应离受想行识求。何以故。是般若波罗蜜。色受想行识。是一切法皆不合不散无色无形无对一相。所谓无相。乃至一切种智中不应求般若波罗蜜。亦不应离一切种智求般若波罗蜜。何以故。是般若波罗蜜。一切种智是一切法皆不合不散无色无形无对一相。所谓无相。何以故。般若波罗蜜。非色亦非离色。非受想行识亦非离受想行识。乃至非一切种智亦非离一切种智。般若波罗蜜。非色如亦非离色如。非受想行识如亦非离受想行识如。般若波罗蜜。非色法亦非离色法。非受想行识法亦非离受想行识法。乃至非一切种智如。亦非离一切种智如。般若波罗蜜。非一切种智法亦非离一切种智法。何以故。憍尸迦。是一切法皆无所有不可得。以无所有不可得故。般若波罗蜜非色亦非离色。非色如亦非离色如。非色法亦非离色法。乃至非一切种智亦非离一切种智。非一切种智如亦非离一切种智如。非一切种智法亦非离一切种智法。释提桓因语须菩提。是摩诃波罗蜜。是菩萨摩诃萨般若波罗蜜。无量波罗蜜。无边波罗蜜。是菩萨摩诃萨般若波罗蜜。诸须陀洹须陀洹果。从是般若波罗蜜中学成。乃至诸阿罗汉阿罗汉果诸辟支佛辟支佛道诸菩萨摩诃萨。皆从是般若波罗蜜中学成。能成就众生净佛国土。得阿耨多罗三藐三菩提皆从是学成。须菩提语释提桓因言。如是如是。憍尸迦是摩诃波罗蜜。是菩萨摩诃萨般若波罗蜜。无量波罗蜜。无边波罗蜜。是菩萨摩诃萨般若波罗蜜。从是中学成须陀洹果乃至阿罗汉果辟支佛道。诸菩萨摩诃萨从是般若波罗蜜中学成。能成就众生净佛国土。得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。色大故般若波罗蜜亦大。何以故。是色前际不可得后际不可得中际不可得。受想行识大故般若波罗蜜亦大。何以故。受想行识前际不可得后际不可得中际不可得。乃至一切种智亦如是。以是因缘故。憍尸迦。是摩诃波罗蜜是菩萨摩诃萨般若波罗蜜憍尸迦。色无量故般若波罗蜜无量。何以故。色量不可得故。憍尸迦。譬如虚空量不可得。色亦如是量不可得。虚空无量故色无量。色无量故般若波罗蜜无量。受想行识乃至一切种智无量故。般若波罗蜜无量。何以故。一切种智量不可得。譬如虚空量不可得。一切种智亦如是量不可得。虚空无量故一切种智无量。一切种智无量故般若波罗蜜无量。以是因缘故。憍尸迦。是菩萨摩诃萨般若波罗蜜无量。憍尸迦。色无边故诸菩萨摩诃萨般若波罗蜜无边。何以故。憍尸迦。是色前际不可得后际不可得中际不可得。受想行识无边故般若波罗蜜无边。何以故。受想行识前际后际中际皆不可得故。乃至一切种智无边故般若波罗蜜无边。何以故。一切种智前后中际皆不可得故。以是因缘故。憍尸迦。是般若波罗蜜无边。色无边乃至一切种智无边。复次憍尸迦。缘无边故般若波罗蜜无边。须菩提。云何缘无边故般若波罗蜜无边。须菩提言。缘一切无边法故般若波罗蜜无边。云何缘一切无边法故般若波罗蜜无边。须菩提言。缘无边法性故般若波罗蜜无边。复次憍尸迦。缘无边如故般若波罗蜜无边。释提桓因言。云何缘无边如故般若波罗蜜无边。须菩提言。如无边故缘亦无边。缘无边故如亦无边。以是因缘故。诸菩萨摩诃萨般若波罗蜜无边。复次憍尸迦。众生无边故般若波罗蜜无边。释提桓因问须菩提。云何众生无边故般若波罗蜜无边。须菩提言。于意云何。何等法名众生。释提桓因言。无有法名众生。假名故为众生。是名字本无有法亦无所趣。强为作名。憍尸迦。于汝意云何。是般若波罗蜜中说众生有实不。释提桓因言无也。憍尸迦。若般若波罗蜜实不说众生。无边亦不可得。憍尸迦。于汝意云何。佛如恒河沙劫寿。说众生众生名字。颇有众生法有生有灭不。释提桓因言不也。何以故。众生从本已来常清净故。以是因缘故。憍尸迦。众生无边故当知般若波罗蜜亦无边

    摩诃般若波罗蜜经三叹品第三十(丹本作顾视品)

尔时诸天王及诸天。诸梵王及诸梵天。伊赊那天及诸神仙并诸天女。同时三反称叹快哉快哉慧命须菩提所说法。皆是佛出世间因缘恩力演布是教。若有菩萨摩诃萨行是般若波罗蜜不远离者。我辈视是人如佛。何以故。是般若波罗蜜中虽无法可得。所谓色受想行识乃至一切种智。而有三乘之教。所谓声闻乘辟支佛乘佛乘。尔时佛告诸天子。如是如是。诸天子如汝所言。是般若波罗蜜中虽无法可得。所谓色受想行识乃至一切种智。而有三乘之教。所谓声闻乘辟支佛乘佛乘。诸天子。若有菩萨摩诃萨行是般若波罗蜜不远离者。视是人当如佛。以无所得故。何以故。是般若波罗蜜中广说三乘之教。所谓声闻辟支佛佛乘。檀那波罗蜜中佛不可得。离檀那波罗蜜佛亦不可得。乃至般若波罗蜜中佛不可得。离般若波罗蜜佛亦不可得。内空乃至无法有法空。四念处乃至十八不共法。一切种智亦如是佛语诸天子。菩萨摩诃萨若能学是一切法。所谓檀那波罗蜜乃至一切种智。以是事故当视是菩萨摩诃萨如佛。诸天子。我昔于然灯佛时。花严城内四衢道头见佛闻法。即得不离檀那波罗蜜行不离尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜行。不离内空乃至无法有法空。四念处乃至八圣道分。不离四禅四无量心四无色定。一切三昧门一切陀罗尼门。不离四无所畏佛十力四无碍智十八不共法大慈大悲。及余无量诸佛法行。无所得故。是时然灯佛。记我当来世过一阿僧祇劫当作佛。号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。毗侈遮罗那修伽度路伽惫无上士调御丈夫天人师佛世尊。尔时诸天子白佛言。世尊。甚希有是般若波罗蜜。能令诸菩萨摩诃萨得萨婆若。于色不取不舍故。于受想行识不取不舍故。乃至一切种智不取不舍故

尔时佛观四众和合比丘比丘尼优婆塞优婆夷。及诸菩萨摩诃萨。并四天王天乃至阿迦尼吒诸天皆会坐。普观是已。佛告释提桓因言。憍尸迦。若菩萨摩诃萨。若比丘若比丘尼若优婆塞若优婆夷。若诸天子若诸天女。是般若波罗蜜若听受持亲近读诵。为他说正忆念不离萨婆若心。诸天子。是人魔若魔民不能得其便。何以故。是善男子善女人。谛了知色空。空不能得空便。无相不能得无相便。无作不能得无作便。谛了知受想行识空。空不能得空便。乃至无作不能得无作便。乃至谛了知一切种智空。空不能得空便。乃至无作不能得无作便。何以故。是诸法自相性不可得。无事可得便。谁受恼者。复次憍尸迦。是善男子善女人。人非人不能得其便。何以故。是善男子善女人。一切众生中善修慈心悲喜舍心。以无所得故。憍尸迦。是善男子善女人终不横死。何以故。是善男子善女人行檀那波罗蜜。于一切众生等心供给故。复次憍尸迦。三千大千世界四天王天三十三天。夜摩天兜率陀天化乐天他化自在天。梵天光音天遍净天广果天。是诸天中有发阿耨多罗三藐三菩提心者。未闻是般若波罗蜜未受持亲近。是诸天子。今应闻受持亲近读诵正忆念不离萨婆若心。复次憍尸迦。诸善男子善女人。闻是般若波罗蜜。受持亲近读诵正忆念不离萨婆若心。是诸善男子善女人。若在空舍若在旷野若人住处终不怖畏。何以故。是善男子善女人明于内空以无所得故。明于外空乃至无法有法空。以无所得故。尔时三千大千世界中诸四天王天三十三天。夜摩天兜率陀天化乐天他化自在天。乃至首陀婆诸天。白佛言。世尊。是善男子善女人能受持般若波罗蜜。亲近读诵正忆念不离萨婆若心者。我等常当守护。何以故。世尊。以菩萨摩诃萨因缘故。断三恶道断天人贫断诸灾患疾病饥饿。以菩萨因缘故。便有十善道现于世间。四禅四无量心四无色定。檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。内空乃至无法有法空。四念处乃至一切种智。以菩萨因缘故。世间便有刹利大姓婆罗门大姓。居士大家诸王及转轮圣王。四天王天乃至阿迦尼吒天。以菩萨因缘故有须陀洹须陀洹果乃至阿罗汉阿罗汉果辟支佛辟支佛道。以菩萨因缘故。有成就众生净佛国土。便有诸佛出现于世。便有转法轮知有佛宝法宝比丘僧宝。世尊。以是因缘故。一切世间诸天及人阿修罗。应守护是菩萨摩诃萨。佛语释提桓因。如是如是。憍尸迦。以菩萨摩诃萨因缘故。断三恶道乃至三宝出现于世。以是故。诸天及人阿修罗常应守护供养恭敬尊重赞叹是菩萨摩诃萨。憍尸迦。供养恭敬尊重赞叹是菩萨摩诃萨。即是供养我。以是故。是诸菩萨摩诃萨诸天及人阿修罗常应守护供养恭敬尊重赞叹。憍尸迦。若三千大千世界满中声闻辟支佛譬如竹苇稻麻丛林。若有善男子善女人供养恭敬尊重赞叹。不如供养恭敬尊重赞叹初发心菩萨摩诃萨。不离六波罗蜜所得福德。何以故。不以声闻辟支佛因缘故。有菩萨摩诃萨及诸佛出现于世。以有菩萨摩诃萨因缘故。有声闻辟支佛诸佛出现于世。以是故。憍尸迦。是诸菩萨摩诃萨。一切世间诸天及人阿修罗。常应守护供养恭敬尊重赞叹

    摩诃般若波罗蜜经灭诤品第三十一(丹本名为现功德品)

尔时释提桓因白佛言。世尊。甚奇希有诸菩萨摩诃萨是般若波罗蜜。若闻受持亲近读诵为他说正忆念时。得如是今世功德。亦成就众生严净佛国土。从一佛国至一佛国供养诸佛。所欲供养之具随意即得。从诸佛闻法至得阿耨多罗三藐三菩提终不中忘。亦得家成就母成就生成就眷属成就相成就光明成就眼成就耳成就三昧成就陀罗尼成就。是菩萨以方便力故变身如佛。从一国至一国到无佛处。赞檀那波罗蜜乃至般若波罗蜜。赞四禅四无量心四无色定。赞四念处乃至十八不共法。以方便力而为说法。以三乘法度脱众生。所谓声闻辟支佛佛乘。世尊。快哉希有。受持般若波罗蜜为已总摄五波罗蜜。乃至十八不共法。亦摄须陀洹果乃至阿罗汉果辟支佛道佛道。一切智一切种智。佛告释提桓因。如是如是。憍尸迦。持般若波罗蜜为已总摄五波罗蜜乃至一切种智。复次憍尸迦。是般若波罗蜜受持亲近读诵为他说正忆念。是善男子善女人所得今世功德汝一心谛听。释提桓因言。唯然世尊受教。佛告释提桓因言。憍尸迦。若有外道诸梵志若魔若魔民若增上慢人。欲乖错破坏菩萨般若波罗蜜心。是诸人适生此心。即时灭去终不从愿。何以故。憍尸迦。菩萨摩诃萨。长夜行檀那波罗蜜行尸罗羼提毗梨耶禅那般若波罗蜜。以众生长夜贪诤故。菩萨悉舍内外物。安立众生于檀那波罗蜜中。以众生长夜破戒故。菩萨悉舍内外法。安立众生于戒。以众生长夜斗诤故。菩萨悉舍内外法。安立众生于忍辱。以众生长夜懈怠故。菩萨悉舍内外法。安立众生于精进。以众生长夜乱心故。菩萨悉舍内外法。安立众生于禅那。以众生长夜愚痴故。菩萨悉舍内外法。安立众生于般若波罗蜜。以众生长夜为爱结故流转生死。是菩萨摩诃萨以方便力断众生爱结。安立众生于四禅四无量心四无色定。四念处乃至八圣道分空无相无作三昧。安立众生于须陀洹果乃至阿罗汉果辟支佛道佛道。憍尸迦。是为菩萨摩诃萨行般若波罗蜜得现世功德后世功德。得阿耨多罗三藐三菩提转法轮。所愿满足入无余涅槃。憍尸迦。是为菩萨摩诃萨后世功德。复次憍尸迦。善男子善女人。是般若波罗蜜若闻受持亲近读诵为他说正忆念。其所住处魔若魔民若外道梵志增上慢人。欲轻毁难问破坏般若波罗蜜终不能成。其人恶心转灭功德转增。闻是般若波罗蜜故渐以三乘道得尽众苦。譬如憍尸迦有药名摩只。有蛇饥行索食。见虫欲啖。虫趣药所。药气力故蛇不能前即自还去。何以故。以是药力能胜毒故。憍尸迦。摩只药有如是力。是善男子善女人。是般若波罗蜜若闻受持亲近读诵为他说正忆念。若有种种斗诤起欲来破坏者。以般若波罗蜜威力故。随所起处即疾消灭。其人即生善心增益功德。何以故。是般若波罗蜜能灭诸法诤乱。何等诸法。所谓淫怒痴无明乃至大苦聚诸盖结使缠。我见人见众生见。断见常见垢见净见有见无见。如是一切诸见。悭贪犯戒嗔恚懈怠乱意无智。常想乐想净想我想。如是等爱行。着色着受想行识。着檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。着内空外空内外空乃至无法有法空。着四念处乃至十八不共法。着一切智一切种智着涅槃。是一切法诤乱尽能消灭不令增长。复次憍尸迦。三千大千世界中诸四天王天诸释提桓因诸梵天王乃至阿迦尼吒天。常守护是善男子善女人能闻受持般若波罗蜜。供养读诵为他说。正忆念般若波罗蜜者。十方现在诸佛亦共拥护是善男子善女人能闻受持供养读诵为他说。正忆念般若波罗蜜者。是善男子善女人。不善法灭善法转增。所谓檀那波罗蜜转增以无所得故。乃至般若波罗蜜转增以无所得故。内空转增。乃至无法有法空转增。以无所得故。四念处乃至十八不共法转增。以无所得故。诸三昧门诸陀罗尼门。一切智一切种智转增。以无所得故。是善男子善女人所说人皆信受。亲友坚固不说无益之语。不为嗔恚所覆。不为憍慢悭贪嫉妒所覆。是人自不杀生。教人不杀生赞叹不杀生法。亦欢喜赞叹不杀生者。自远离不与取。亦教人远离不与取。赞远离不与取法。亦欢喜赞叹远离不与取者。自不邪淫教人不邪淫。赞不邪淫法。亦欢喜赞叹不邪淫者。自不妄语教人不妄语。赞不妄语法。亦欢喜赞叹不妄语者。两舌恶口无利益语亦如是。自不贪教人不贪。赞不贪法。亦欢喜赞叹不贪者。不嗔恼不邪见亦如是。自行檀那波罗蜜。教人行檀那波罗蜜。赞檀那波罗蜜法。亦欢喜赞叹行檀那波罗蜜者。自行尸罗波罗蜜。教人行尸罗波罗蜜。赞尸罗波罗蜜法。亦欢喜赞叹行尸罗波罗蜜者。自行羼提波罗蜜。教人行羼提波罗蜜。赞羼提波罗蜜法。亦欢喜赞叹行羼提波罗蜜者。自行毗梨耶波罗蜜。教人行毗梨耶波罗蜜。赞毗梨耶波罗蜜法。亦欢喜赞叹行毗梨耶波罗蜜者。自行禅那波罗蜜。教人行禅那波罗蜜。赞禅那波罗蜜法。亦欢喜赞叹行禅那波罗蜜者。自行般若波罗蜜。教人行般若波罗蜜。赞般若波罗蜜法。亦欢喜赞叹行般若波罗蜜者。自修内空教人修内空。赞内空法亦欢喜赞叹修内空者。乃至自修无法有法空。教人修无法有法空。赞无法有法空法。亦欢喜赞叹修无法有法空者。自入一切三昧中。教人入一切三昧中。赞一切三昧法。亦欢喜赞叹行一切三昧者。自得陀罗尼。教人得陀罗尼。赞陀罗尼法。亦欢喜赞叹得陀罗尼者。自入初禅。教人入初禅。赞初禅法。亦欢喜赞叹入初禅者。二禅三禅四禅亦如是。自入慈心中教人入慈心。赞慈心法。亦欢喜赞叹入慈心者。悲喜舍心亦如是。自入无边空处。教人入无边空处。赞无边空处法。亦欢喜赞叹入无边空处者。无边识处无所有处非有想非无想处。亦如是。自修四念处。教人修四念处。赞四念处法。亦欢喜赞叹修四念处者。四正勤四如意足五根五力七觉分八圣道分亦如是。自修空无相无作三昧教人修空无相无作三昧。赞空无相无作三昧法。亦欢喜赞叹修空无相无作三昧者。自入八背舍。教人入八背舍。赞八背舍法。亦欢喜赞叹入八背舍者。自入九次第定。教人入九次第定。赞九次第定法。亦欢喜赞叹入九次第定者。自修佛十力四无所畏四无碍智大慈大悲十八不共法亦如是。自行无谬错法自行常舍法。教人行无谬错法常舍法。赞无错谬法常舍法法。亦欢喜赞叹行无错谬法常舍法者。自得一切种智。教人得一切种智。赞一切种智法。亦欢喜赞叹得一切种智者。是菩萨摩诃萨行六波罗蜜时。所有布施与众生共已回向阿耨多罗三藐三菩提以无所得故。所有持戒忍辱精进禅定智慧。与众生共已回向阿耨多罗三藐三菩提以无所得故。是善男子善女人。如是行六波罗蜜时作是念。我若不布施当生贫穷家。不能成就众生净佛国土。亦不能得一切种智。我若不持戒当生三恶道中。尚不得人身。何况能成就众生净佛国土得一切种智。我若不修忍辱。则当诸根毁坏色不具足。不能得菩萨具足色身。众生见者必至阿耨多罗三藐三菩提。亦不能得以具足色身成就众生净佛国土得一切种智。我若懈怠不能得菩萨道。亦不能得成就众生净佛国土得一切种智。我若乱心不能得生诸禅定。不能以此禅定成就众生净佛国土得一切种智。我若无智不能得方便智。以方便智过声闻辟支佛地。成就众生净佛国土得一切种智。是菩萨复如是思惟。我不应随悭贪故不具足檀那波罗蜜。不应随犯戒故不具足尸罗波罗蜜。不应随嗔恚故不具足羼提波罗蜜。不应随懈怠故不具足毗梨耶波罗蜜。不应随乱意故不具足禅那波罗蜜。不应随痴心故不具足般若波罗蜜。若不具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。我终不能成就一切种智。如是善男子善女人。是般若波罗蜜受持亲近读诵为他说正忆念亦不离萨婆若心。得是今世后世功德。释提桓因白佛言。世尊。希有是菩萨摩诃萨般若波罗蜜。为回向萨婆若心故亦为不高心故。佛告释提桓因言。憍尸迦。云何菩萨摩诃萨般若波罗蜜。为回向萨婆若心故亦为不高心故。释提桓因白佛言。世尊。菩萨摩诃萨。若行世间檀那波罗蜜。布施诸佛辟支佛声闻。及诸贫穷乞丐行路人。是菩萨无方便故生高心。若行世间尸罗波罗蜜言我行尸罗波罗蜜我能具足尸罗波罗蜜。无方便故生高心。言我行羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。我行般若波罗蜜。我修般若波罗蜜。以是世间般若波罗蜜无方便故生高心。世尊。菩萨修世间四念处时自念言。我修四念处我具足四念处。无方便力故生高心。我修四正勤四如意足五根五力七觉分八圣道分。自念言。我修空无相无作三昧。我修一切三昧门当得一切陀罗尼门。我修佛十力四无所畏十八不共法。我当成就众生我当净佛国土。我当得一切种智。着吾我无方便力故生高心。世尊。如是菩萨摩诃萨行世间善法。着吾我故生高心。世尊。若菩萨摩诃萨行出世间檀那波罗蜜。不得施者不得受者不得施物。如是菩萨摩诃萨行出世间檀那波罗蜜。为回向萨婆若故亦不生高心。行尸罗波罗蜜。尸罗不可得。行羼提波罗蜜羼提不可得。行毗梨耶波罗蜜毗梨耶不可得。行禅那波罗蜜禅那不可得。行般若波罗蜜般若不可得。修四念处四念处不可得。乃至修十八不共法。十八不共法不可得。修大慈大悲。大慈大悲不可得。乃至修一切种智。一切种智不可得。世尊。如是菩萨摩诃萨般若波罗蜜。为回向萨婆若故。亦为不生高心故

摩诃般若经卷第八摩诃般若波罗蜜经卷第九

        后秦龟兹国三藏鸠摩罗什译

    大明品第三十二(丹本作宝塔品)

尔时佛告释提桓因言。若有善男子善女人闻是深般若波罗蜜。受持亲近读诵正忆念不离萨婆若心。两阵战时。是善男子善女人诵般若波罗蜜故。入军阵中终不失命刀箭不伤。何以故。是善男子善女人长夜行六波罗蜜。自除淫欲刀箭亦除他人淫欲刀箭。自除嗔恚刀箭亦除他人嗔恚刀箭。自除愚痴刀箭亦除他人愚痴刀箭。自除邪见刀箭亦除他人邪见刀箭。自除缠垢刀箭亦除他人缠垢刀箭。自除诸结使刀箭亦除他人结使刀箭。憍尸迦。以是因缘。是善男子善女人不为刀箭所伤。复次憍尸迦。是善男子善女人闻是深般若波罗蜜。受持亲近读诵正忆念不离萨婆若心。若以毒药熏。若以蛊道若以火坑若以深水若欲刀杀若与其毒。如是众恶皆不能伤。何以故。是般若波罗蜜是大明咒是无上明咒。若善男子善女人。于是明咒中学。自不恼身亦不恼他亦不两恼。何以故。是善男子善女人。不得我不得众生不得寿命。乃至知者见者皆不可得。不得色受想行识。乃至一切种智亦不可得。以不得故。不自恼身亦不恼他亦不两恼。学是大明咒故得阿耨多罗三藐三菩提。观一切众生心随意说法。何以故。过去诸佛学是大明咒得阿耨多罗三藐三菩提。当来诸佛学是大明咒当得阿耨多罗三藐三菩提。今现在诸佛学是大明咒得阿耨多罗三藐三菩提。复次憍尸迦。般若波罗蜜若有但书写经卷于舍供养。不受不读不诵不说不正忆念。是处若人若非人不能得其便。何以故。是般若波罗蜜为三千大千世界中诸四天王诸天。乃至阿迦尼吒诸天子。及十方无量阿僧祇世界中诸四天王天。乃至阿迦尼吒诸天所守护故。是般若波罗蜜所止处。诸天皆来供养恭敬尊重赞叹礼拜已去。是善男子善女人但书写般若波罗蜜于舍供养。不受不读不诵不说不正忆念。今世得如是功德。譬如若人若畜生来入菩提树下诸边内外。设有人非人持恶意来。不能得其便。何以故。是处过去诸佛于中得阿耨多罗三藐三菩提。未来诸佛现在诸佛亦于中得阿耨多罗三藐三菩提。得佛已施一切众生无恐无畏。令无量阿僧祇众生受天上人中福乐。亦令无量阿僧祇众生得须陀洹果。乃至得阿耨多罗三藐三菩提。以般若波罗蜜力故。是处得恭敬礼拜。花香璎珞捣香泽香幢盖伎乐供养。释提桓因白佛言。世尊。若善男子善女人书写般若波罗蜜。花香璎珞乃至伎乐供养。若有人佛般涅槃后。若供养舍利若起塔供养恭敬尊重赞叹。花香璎珞乃至伎乐供养。是二何者得福多。佛告释提桓因。我还问汝随汝意答我。于汝意云何。如佛得一切种智及得是身从何道。学得是一切种智得是身。释提桓因白佛言。佛从般若波罗蜜中。学得一切种智及相好身。佛告释提桓因言。如是如是。憍尸迦。佛从般若波罗蜜中。学得一切种智。憍尸迦。不以相好身名为佛。得一切种智故名为佛。憍尸迦。是佛一切种智。从般若波罗蜜中生。以是故。憍尸迦。是佛身一切种智所依处。佛因是身得一切种智。善男子。当作是思惟。是身一切种智所依处。是故我涅槃后舍利当得供养。复次憍尸迦。善男子善女人若闻是般若波罗蜜。书写受持亲近读诵正忆念。花香璎珞捣香泽香幢盖伎乐。恭敬供养尊重赞叹。是善男子善女人。则为供养一切种智。以是故。憍尸迦。若有善男子善女人书是般若波罗蜜。若受持亲近读诵说正忆念。恭敬尊重赞叹花香璎珞乃至伎乐供养。若复有善男子善女人。佛般涅槃后供养舍利起塔。香花乃至伎乐恭敬尊重赞叹。若有善男子善女人。书持是般若波罗蜜恭敬尊重赞叹。花香璎珞乃至伎乐供养。是人得福多。何以故。是般若波罗蜜中生五波罗蜜。生内空乃至无法有法空。四念处乃至十八不共法。一切三昧一切禅定。一切陀罗尼门。皆从般若波罗蜜中生。成就众生净佛国土。皆从般若波罗蜜中生。菩萨家成就色成就。资生之物成就。眷属成就。大慈大悲成就。皆从般若波罗蜜中生。刹利大姓婆罗门大姓居士大家。皆从般若波罗蜜中生。四天王天乃至阿迦尼吒天。须陀洹乃至阿罗汉辟支佛。诸菩萨摩诃萨诸佛诸佛一切种智。皆从般若波罗蜜中生。尔时释提桓因白佛言。世尊。阎浮提人不供养是般若波罗蜜。不恭敬不尊重不赞叹。为不知供养多所利益耶。佛告释提桓因言。憍尸迦。于汝意云何。阎浮提中几所人。信佛不坏。信法信僧不坏。几所人于佛无疑于法无疑于僧无疑。几所人于佛决了于法于僧决了。释提桓因白佛言。世尊。阎浮提人于佛法僧得不坏信少。于佛法僧无疑决了亦少。憍尸迦。于汝意云何。阎浮提几所人。得三十七品三解脱门八背舍九次第定四无碍智六神通。阎浮提几所人。断三结故得须陀洹道。几所人断三结。亦淫嗔痴薄故得斯陀含道。几所人断五下分结得阿那含道。几所人断五上分结故得阿罗汉道。阎浮提几所人求辟支佛。几所人发阿耨多罗三藐三菩提心。释提桓因白佛言。世尊。阎浮提中少所人得三十七品。乃至少所人发阿耨多罗三藐三菩提心。佛告释提桓因言。如是如是。憍尸迦。少所人信佛不坏信法不坏信僧不坏。少所人于佛无疑于法无疑于僧无疑。少所人于佛决了于法决了于僧决了。憍尸迦。亦少所人得三十七品三解脱门八背舍九次第定四无碍智六神通。憍尸迦。亦少所人断三结得须陀洹。断三结亦淫嗔痴薄得斯陀含。断五下分结得阿那含。断五上分结得阿罗汉。少所人求辟支佛。于是中亦少所人发阿耨多罗三藐三菩提心。于发心中亦少所人行菩萨道。何以故。是众生前世不见佛不闻法不供养比丘僧。不布施不持戒不忍辱不精进不禅定不智慧。不闻内空外空。乃至无法有法空亦不闻不修四念处。乃至十八不共法亦不闻不修诸三昧门诸陀罗尼门。亦不修一切智一切种智。憍尸迦。以是因缘故。当知少所众生信佛不坏信法不坏信僧不坏。乃至少所众生。求辟支佛道。于是中少所众生发阿耨多罗三藐三菩提心。于发心中少所众生行菩萨道。于是中亦少所众生得阿耨多罗三藐三菩提。憍尸迦。我以佛眼见东方无量阿僧祇众生。发心行阿耨多罗三藐三菩提行菩萨道。是众生远离般若波罗蜜方便力故。若一若二住阿惟越致地。多堕声闻辟支佛地。南西北方四维上下亦复如是。以是故。憍尸迦。善男子善女人发心求阿耨多罗三藐三菩提者。应闻般若波罗蜜。应受持亲近读诵说正忆念。受持亲近读诵说正忆念已。当书经卷恭敬供养尊重赞叹。花香璎珞乃至伎乐。诸余善法入般若波罗蜜中者。亦应闻受持乃至正忆念。何等是诸余善法。所谓檀那波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。内空外空乃至无法有法空。诸三昧门诸陀罗尼门。四念处乃至十八不共法大慈大悲。如是等无量诸善法。皆入般若波罗蜜中。是亦应闻受持乃至正忆念。何以故。是善男子善女人当如是念。佛本为菩萨时如是行如是学。所谓般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。内空乃至无法有法空。诸三昧门诸陀罗尼门。四念处乃至十八不共法大慈大悲。如是等无量诸佛法。我等亦应随学。何以故。般若波罗蜜是我等所尊。禅那波罗蜜乃至无量诸余善法。亦是我等所尊。此是诸佛法印。诸辟支佛阿罗汉阿那含斯陀含须陀洹法印。诸佛学是般若波罗蜜乃至一切种智得度彼岸。诸辟支佛阿罗汉阿那含斯陀含须陀洹。亦学是般若波罗蜜乃至一切智得度彼岸。以是故。憍尸迦。若善男子善女人。若佛在世若般涅槃后。应依止般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。乃至一切种智亦应依止。何以故。是般若波罗蜜乃至一切种智。是诸声闻辟支佛菩萨摩诃萨。及一切世间天人阿修罗所可依止。憍尸迦。若有善男子善女人。佛般涅槃后为供养佛故作七宝塔高一由旬。天香天花天璎珞天捣香天泽香天衣天幢盖天伎乐。供养恭敬尊重赞叹。憍尸迦。于汝意云何。是善男子善女人从是因缘得福多不。释提桓因言。世尊。甚多甚多。佛言。不如是善男子善女人闻是般若波罗蜜书写受持亲近正忆念不离萨婆若心。亦恭敬尊重赞叹。若华香璎珞捣香泽香幢盖伎乐供养。是善男子善女人福德多。佛告憍尸迦。置一七宝塔。若善男子善女人供养佛故。佛般涅槃后满阎浮提起七宝塔。皆高一由旬。恭敬尊重赞叹。香花璎珞幢盖伎乐供养。憍尸迦。于汝意云何。是善男子善女人得福多不。释提桓因言。世尊。其福甚多。佛言。不如是善男子善女人如前供养般若波罗蜜其福多。憍尸迦。复置一阎浮提满中七宝塔。有善男子善女人供养佛故。佛般涅槃后满四天下起七宝塔。皆高一由旬供养如前。憍尸迦。于汝意云何。是善男子善女人其福多不。释提桓因言。甚多甚多。佛言。不如是善男子善女人书持般若波罗蜜恭敬尊重赞叹。花香乃至伎乐供养其福甚多。憍尸迦。复置四天下满中七宝塔。若有善男子善女人。供养佛故佛般涅槃后满小千国土起七宝塔。皆高一由旬。供养如前。憍尸迦。于汝意云何。是善男子善女人其福多不。释提桓因言。甚多。佛言。不如是善男子善女人书是般若波罗蜜受持恭敬尊重赞叹花香乃至伎乐供养其福甚多。憍尸迦。复置小千国土满中七宝塔。若有善男子善女人。供养佛故佛般涅槃后满二千中国土起七宝塔。皆高一由旬供养如前。故不如供养般若波罗蜜其福甚多。复置二千中国土七宝塔。若有善男子善女人。供养佛故佛般涅槃后。万三千大千国土中起七宝塔。皆高一由旬。尽形寿供养天华天香天璎珞乃至天伎乐供养。于汝意云何。是善男子善女人得福多不。释提桓因言。世尊。甚多甚多。佛言。不如是善男子善女人书是般若波罗蜜。受持恭敬尊重赞叹。香花乃至伎乐供养其福甚多。复置三千大千国土中七宝塔。若三千大千国土中众生。一一众生供养佛故。佛般涅槃后各起七宝塔。恭敬尊重赞叹华香乃至伎乐供养。若有善男子善女人书持般若波罗蜜。乃至正忆念不离萨婆若心。亦恭敬尊重赞叹花香璎珞乃至伎乐供养。是人得福甚多。释提桓因白佛言。如是如是。世尊。若人供养恭敬尊重赞叹是般若波罗蜜。则为供养过去未来现在诸佛。世尊。若十方如恒河沙等国土中众生。一一众生供养佛故。佛般涅槃后各起七宝塔高一由旬。是人若一劫若减一劫。恭敬尊重赞叹花香乃至伎乐供养。世尊。是善男子善女人得福多不。佛言甚多。释提桓因言。若有善男子善女人书持是般若波罗蜜。乃至正忆念亦恭敬尊重赞叹。花香乃至伎乐供养其福大多。何以故。世尊。一切善法皆入般若波罗蜜中。所谓十善道四禅四无量心四无色定。三十七品三解脱门空无相无作。四谛苦谛集谛灭谛道谛。六神通八背舍九次第定。檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。内空乃至无法有法空。诸三昧门诸陀罗尼门。佛十力四无所畏四无碍智。大慈大悲十八不共法。一切智道种智一切种智。世尊。是名一切诸佛法印。是法中一切声闻及辟支佛。过去未来现在诸佛学是法得度彼岸

    摩诃般若波罗蜜经述成品第三十三

尔时佛告释提桓因言。如是如是。憍尸迦。是诸善男子善女人书持是般若波罗蜜经卷。受学亲近读诵说正忆念。加复供养华香璎珞捣香泽香幢盖伎乐。当得无量无数不可思议不可称量无边福德。何以故。诸佛一切智一切种智。皆从般若波罗蜜中生。诸菩萨摩诃萨禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。皆从般若波罗蜜中生。内空乃至无法有法空。四念处乃至十八不共法。皆从般若波罗蜜中生。诸佛五眼皆从般若波罗蜜中生。成就众生净佛国土。道种智一切种智诸佛法。皆从般若波罗蜜中生。声闻乘辟支佛乘佛乘。皆从般若波罗蜜中生。以是故。憍尸迦。善男子善女人书持是般若波罗蜜经卷。亲近读诵说正忆念。加复供养花香乃至伎乐。过出前供养七宝塔。百分千分万分百千万分不及一。乃至算数譬喻所不能及。何以故。憍尸迦。若般若波罗蜜在于世者。佛宝法宝比丘僧宝终不灭。若般若波罗蜜在于世者。十善道四禅四无量心四无色定。檀那波罗蜜乃至般若波罗蜜。四念处乃至十八不共法。一切智一切种智皆现于世。若般若波罗蜜在于世者。世间便有刹利大姓婆罗门大姓居士大家。四天王天乃至阿迦尼吒诸天。须陀洹果乃至阿罗汉果。辟支佛道菩萨摩诃萨无上佛道转法轮。成就众生净佛国土

    摩诃般若波罗蜜经劝持品第三十四

尔时三千大千国土所有四天王天。乃至阿迦尼吒天。语释提桓因诸天言。应受是般若波罗蜜。应持应亲近应读诵说正忆念。何以故。受持般若波罗蜜乃至正忆念故。一切所修集善法当具足满。增益诸天众减损阿修罗。诸天子受持般若波罗蜜乃至正忆念故。佛种不断法种僧种不断。佛种法种僧种不断故。便有檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜皆现于世。四念处乃至十八不共法菩萨道皆现于世。须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道。须陀洹乃至佛皆现于世。尔时佛告释提桓因言。憍尸迦汝当受是般若波罗蜜持读诵说正忆念。何以故。若诸阿修罗生心。欲与三十三天共斗。憍尸迦。汝尔时当诵念般若波罗蜜。诸阿修罗恶心即灭更不复生。憍尸迦。若诸天子天女五死相现时。当堕不如意处。汝当于其前诵读般若波罗蜜。是诸天子天女。闻般若波罗蜜功德故还生本处。何以故。闻般若波罗蜜有大利益故。复次憍尸迦。若有善男子善女人若诸天子天女。闻是般若波罗蜜经耳。是功德故渐当得阿耨多罗三藐三菩提。何以故。憍尸迦。过去诸佛及弟子皆学是般若波罗蜜。得阿耨多罗三藐三菩提入无余涅槃。憍尸迦。未来世诸佛今现在十方诸佛及弟子。皆学是般若波罗蜜得阿耨多罗三藐三菩提入无余涅槃。何以故。憍尸迦。是般若波罗蜜摄一切善法。若声闻法若辟支佛法。若菩萨法若佛法。释提桓因白佛言。世尊。般若波罗蜜是大明咒无上明咒无等等明咒。何以故。世尊。是般若波罗蜜能除一切不善。能与一切善法。佛语释提桓因言。如是如是。憍尸迦般若波罗蜜是大明咒无上明咒无等等明咒。何以故憍尸迦。过去诸佛因是明咒故得阿耨多罗三藐三菩提。未来世诸佛今现在十方诸佛。亦因是明咒得阿耨多罗三藐三菩提。因是明咒故世间便有十善道。便有四禅四无量心四无色定。便有檀那波罗蜜乃至般若波罗蜜四念处乃至十八不共法。便有法性如法相法住法位实际。便有五眼须陀洹果乃至阿罗汉果辟支佛道一切智一切种智。憍尸迦。菩萨摩诃萨因缘故。十善出于世间。四禅四无量心乃至一切种智。须陀洹乃至诸佛出于世间。譬如月满照明星宿亦能照明。如是憍尸迦。一切世间善法正法十善乃至一切种智。若诸佛不出时皆从菩萨生。是菩萨摩诃萨方便力。皆从般若波罗蜜生。是菩萨摩诃萨以是方便力。行檀那波罗蜜乃至禅那波罗蜜。内空乃至无法有法空。四念处乃至十八不共法不证声闻辟支佛地。亦能成就众生净佛国土。寿命成就国土成就菩萨眷属成就得一切种智。皆从般若波罗蜜生。复次憍尸迦。若善男子善女人闻般若波罗蜜。受持亲近乃至正忆念。是人当得今世后世功德成就。释提桓因白佛言。世尊。何等是善男子善女人受持般若波罗蜜。乃至正忆念得今世功德。佛告释提桓因言。若有善男子善女人受持般若波罗蜜。乃至正忆念终不中毒死兵刃不伤水火不害。乃至四百四病所不能中。除其宿命业报。复次憍尸迦。若有官事起。是善男子善女人读诵是般若波罗蜜故。往至官所无能谴责者。何以故。是般若波罗蜜威力故。若善男子善女人诵读是般若波罗蜜。到王所若太子大臣所。王及太子大臣皆欢喜问讯和意共语。何以故。是诸善男子善女人常有慈悲喜舍心向众生故。憍尸迦。若善男子善女人受持般若波罗蜜乃至正忆念。得如是等种种今世功德。憍尸迦。何等是善男子善女人得后世功德。是善男子善女人终不离十善道四禅四无量心四无色定。六波罗蜜四念处乃至十八不共法。是人终不堕三恶道受身貌具。终不生贫穷下贱工师除厕人担死人家。常得三十二相。常得化生生诸现在佛国。终不离菩萨神通。若欲从一佛国至一佛国。供养诸佛听诸佛法。即得随意所游佛国。能成就众生净佛国土。渐得阿耨多罗三藐三菩提。憍尸迦。是名后世功德。以是故。憍尸迦。善男子善女人应当受持是般若波罗蜜。亲近读诵说正忆念。花香乃至伎乐供养。常不离萨婆若心。是善男子善女人乃至阿耨多罗三藐三菩提。得今世后世功德成就

    摩诃般若波罗蜜经遣异品第三十五(丹梵志品)

尔时诸外道异学梵志来向佛所欲求佛短。是时释提桓因心念。是诸外道梵志来向佛所欲求佛短。我今当诵念从佛所受般若波罗蜜。是诸外道梵志等。终不能中道作碍断说般若波罗蜜。释提桓因作是念已。即诵般若波罗蜜。是时诸外道梵志。遥绕佛复道还去。时舍利弗心念。是中何因缘。诸外道梵志遥绕佛复道还去。佛知舍利弗心念。告舍利弗。是释提桓因诵念般若波罗蜜。以是因缘故。诸外道梵志遥绕佛复道还去。舍利弗。是诸外道梵志我不见一念善心。是诸外道梵志持恶心来欲索佛短。舍利弗。我不见说般若波罗蜜时一切世间若天若魔若梵若沙门众婆罗门众中。有持恶意来能得短者。何以故。舍利弗。是三千大千国土中。诸四天王天乃至阿迦尼吒天。诸声闻辟支佛诸菩萨摩诃萨。守护是般若波罗蜜。所以者何。是诸天人皆从般若波罗蜜中生故。复次舍利弗。十方如恒河沙等国土中。诸佛及声闻辟支佛菩萨摩诃萨诸天龙鬼神等。皆守护是般若波罗蜜。所以者何。是诸佛等皆从般若波罗蜜中生故。尔时恶魔心念。今佛四众现前集会。亦有欲界色界诸天子。是中必有菩萨摩诃萨受记当得阿耨多罗三藐三菩提。我宁可至佛所破坏其意。是时恶魔化作四种兵来至佛所。尔时释提桓因心念。是四种兵或是恶魔化作欲来向佛。何以故。是四种兵严饰。频婆娑罗王四种兵所不类。波斯匿王四种兵所不类。诸释子四种兵所不类。诸梨昌四种兵皆所不类。此是恶魔化作四种兵。是恶魔长夜索佛便欲恼众生。我宁可诵念般若波罗蜜。释提桓因。即时诵念般若波罗蜜。恶魔闻其所诵渐渐复道还去。尔时会中四天王诸天子。乃至阿迦尼吒诸天子。化作天花于虚空中而散佛上作是言。世尊。愿令般若波罗蜜久住阎浮提。所以者何。阎浮提人受持般若波罗蜜随所住时。佛宝亦住不灭法宝僧宝亦住不灭。尔时十方如恒河沙等世界中。诸天亦皆散花作是言。世尊。愿令般若波罗蜜久住阎浮提。若般若波罗蜜久住。佛法僧亦当久住。亦分别知菩萨摩诃萨道。复次所在住处。善男子善女人有书持般若波罗蜜经卷是处则为照明已离诸冥。佛告释提桓因等诸天子。如是如是。憍尸迦及诸天子。阎浮提人。受持般若波罗蜜随所住时。佛宝如是住法宝僧宝亦如是住。乃至在所住处。善男子善女人。有书持般若波罗蜜经卷。是处则为照明以离诸冥。尔时诸天子。化作天花散佛上作是言。世尊。若有善男子善女人受持般若波罗蜜乃至正忆念。魔若魔民不能得其便。世尊。我等亦当拥护。是善男子善女人。何以故。若善男子善女人受持般若波罗蜜乃至正忆念。我等视是人如佛若次佛。是时释提桓因白佛言。世尊。善男子善女人受持般若波罗蜜乃至正忆念者。当知是人先世于佛所作功德多。亲近供养诸佛。为善知识所护。世尊。诸佛一切智应当从般若波罗蜜中求。般若波罗蜜亦当从一切智中求。所以者何。般若波罗蜜不异一切智。一切智不异般若波罗蜜。般若波罗蜜一切智不二不别。是故我等视是人。即是佛若次佛。佛告释提桓因言。如是如是。憍尸迦。诸佛一切智即是般若波罗蜜。般若波罗蜜即是一切智。何以故。憍尸迦。诸佛一切智皆从般若波罗蜜中生。般若波罗蜜不异一切智。一切智不异般若波罗蜜。般若波罗蜜一切智不二不别

    摩诃般若波罗蜜经尊导品第三十六(丹阿难称誉品)

尔时慧命阿难白佛言。世尊。何以不称誉檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜乃至十八不共法。但称誉般若波罗蜜。佛告阿难。般若波罗蜜于五波罗蜜乃至十八不共法。为尊导。阿难。于汝意云何。不回向萨婆若布施。得称檀那波罗蜜不。不也世尊。不回向萨婆若。尸罗羼提毗梨耶禅那智慧是般若波罗蜜不。不也世尊。以是故知。般若波罗蜜于五波罗蜜乃至十八不共法为尊导。是故称誉。阿难白佛言。世尊。云何布施回向萨婆若作檀那波罗蜜。乃至作般若波罗蜜。佛告阿难。以无二法布施回向萨婆若。是名檀那波罗蜜。以不生不可得故。回向萨婆若布施。是名檀那波罗蜜。乃至以无二法智慧回向萨婆若。是名般若波罗蜜。以不生不可得故。回向萨婆若智慧。是名般若波罗蜜。阿难白佛言。世尊。云何以不二法回向萨婆若布施。是名檀那波罗蜜。乃至以不二法回向萨婆若智慧。是名般若波罗蜜。佛告阿难。以色不二法故。受想行识不二法故。乃至阿耨多罗三藐三菩提不二法故。世尊。云何色不二法乃至阿耨多罗三藐三菩提不二法。佛言。色色相空。何以故。檀那波罗蜜色不二不别。乃至阿耨多罗三藐三菩提檀那波罗蜜不二不别。五波罗蜜亦如是。以是故阿难。但称誉般若波罗蜜。于五波罗蜜乃至一切种智为尊导。阿难。譬如大地以种散中得因缘和合便生。是诸种子依地而生。如是阿难。五波罗蜜依般若波罗蜜得生。四念处乃至一切种智亦依般若波罗蜜得生。以是故阿难。般若波罗蜜于五波罗蜜乃至十八不共法为尊导。尔时释提桓因白佛言。世尊。佛说善男子善女人受持般若波罗蜜乃至正忆念者功德未尽。何以故。受持般若波罗蜜。乃至正忆念则受三世诸佛无上道。所以者何。欲得萨婆若当从般若波罗蜜中求。欲得般若波罗蜜当从萨婆若中求。世尊受持般若波罗蜜乃至正忆念故。十善道现于世间。四禅四无量心四无色定乃至十八不共法。现于世间。受持般若波罗蜜乃至正忆念故。世间便有刹利大姓婆罗门大姓居士大家四天王天乃至阿迦尼吒诸天。受持般若波罗蜜乃至正忆念故。便有须陀洹乃至阿罗汉辟支佛菩萨摩诃萨受持般若波罗蜜乃至正忆念故。诸佛出于世间。尔时佛告释提桓因言。憍尸迦。善男子善女人受持般若波罗蜜乃至正忆念。我不说但有尔所功德。何以故。憍尸迦。是善男子善女人受持般若波罗蜜乃至正忆念不离萨婆若心。无量戒众成就。定众慧众解脱众解脱知见众成就。复次憍尸迦。是善男子善女人能受持般若波罗蜜乃至正忆念不离萨婆若心。当知是人为如佛。复次憍尸迦。一切声闻辟支佛。所有戒众定众智众解脱众解脱知见众。不及是善男子善女人戒众乃至解脱知见众。百分千分百千万亿分乃至算数譬喻所不能及。何以故。是善男子善女人。于声闻辟支佛地中心得解脱。更不求大乘法故。复次憍尸迦。若有善男子善女人书持般若波罗蜜经卷。供养恭敬尊重。华香璎珞乃至伎乐。亦得今世后世功德。尔时释提桓因白佛言。世尊。是善男子善女人受持般若波罗蜜乃至正忆念。不离萨婆若心供养般若波罗蜜。恭敬尊重华香乃至伎乐。我常当守护是人。佛告释提桓因。憍尸迦。是善男子善女人欲读诵说是般若波罗蜜时。无量百千诸天皆来听法。是善男子善女人说般若波罗蜜法诸天子益其胆力。是诸法师若疲极不欲说法。诸天益其胆力故。便能更说。善男子善女人受是般若波罗蜜乃至正忆念。供养花香乃至伎乐故。亦得是今世功德。复次憍尸迦。是善男子善女人于四部众中。说般若波罗蜜时心无怯弱。若有论难亦无畏想。何以故。是善男子善女人。为般若波罗蜜所护持故。般若波罗蜜中亦分别一切法。若世间若出世间。若有漏若无漏。若善若不善。若有为若无为。若声闻法若辟支佛法。若菩萨法若佛法。善男子善女人住内空乃至住无法有法空故。不见有能难般若波罗蜜者。亦不见受难者亦不见般若波罗蜜。如是善男子善女人。为般若波罗蜜所拥护故。无有能难坏者。复次善男子善女人受持般若波罗蜜乃至正忆念时。不没不畏不怖。何以故。是善男子善女人不见是法没者恐怖者。憍尸迦。善男子善女人受持般若波罗蜜乃至正忆念。花香供养乃至幡盖。亦得是现世功德。复次憍尸迦。善男子善女人受持般若波罗蜜乃至正忆念。书持经卷花香供养乃至幡盖。是人为父母所爱。宗亲知识所念。诸沙门婆罗门所敬。十方诸佛及菩萨摩诃萨。辟支佛阿罗汉乃至须陀洹所爱敬。一切世间若天若魔若梵及阿修罗等。皆亦爱敬。是人行檀那波罗蜜。檀那波罗蜜无有断绝时。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。亦无有断绝时。修内空不断。乃至修无法有法空不断。修四念处不断。乃至修十八不共法不断。修诸三昧门不断。修诸陀罗尼门不断。修诸菩萨神通不断。成就众生净佛国土不断。乃至修一切种智不断。是人亦能降伏难论毁谤。善男子善女人受持般若波罗蜜乃至正忆念。不离萨婆若心。书持经卷香花供养乃至幡盖。亦得是今世后世功德。复次憍尸迦。善男子善女人书持经卷。在所处三千大千世界中所有诸四天王天。发阿耨多罗三藐三菩提心者。皆来到是处。见般若波罗蜜受读诵说。供养礼拜还去。三十三天夜摩天兜率陀天化乐天他化自在天。梵众天梵辅天梵会天大梵天。光天少光天无量光天光音天。净天少净天无量净天遍净天。无荫行天福德天广果天。发阿耨多罗三藐三菩提心者。皆来到是处。见般若波罗蜜受读诵说。供养礼拜还去。净居诸天所谓无诳天无热天妙见天喜见天色究竟天。皆来到是处。见是般若波罗蜜受读诵说。供养礼拜还去。复次憍尸迦。十方世界中诸四天王天乃至广果天发阿耨多罗三藐三菩提心。及净居天并余诸天龙鬼神揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽亦来。见般若波罗蜜受读诵说。供养礼拜还去。是善男子善女人应作是念。十方世界中诸四天王天乃至广果天。发阿耨多罗三藐三菩提心。及净居天并余诸天龙鬼神揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽来。见般若波罗蜜受读诵说。供养礼拜。我则法施已。憍尸迦。三千大千世界中所有诸四天王天乃至阿迦尼吒天。及十方世界中诸四天王天。乃至阿迦尼吒天。发阿耨多罗三藐三菩提心者拥护是善男子善女人。诸恶不能得便。除其宿命重罪。憍尸迦。是善男子善女人亦得是今世功德。所谓诸天子发阿耨多罗三藐三菩提心。皆来到是处。何以故。憍尸迦。诸天子发阿耨多罗三藐三菩提心。欲救护一切众生。不舍一切众生。安乐一切众生故。尔时释提桓因白佛言。世尊。善男子善女人云何当知诸四天王天乃至阿迦尼吒天来。及十方国土中诸四天王天乃至阿迦尼吒天来。见般若波罗蜜受读诵说供养礼拜。时佛告释提桓因。憍尸迦。若善男子善女人见大净光明。必知有大德诸天来见般若波罗蜜受读诵说供养礼拜时。复次憍尸迦。善男子善女人若闻异妙香。必知有大德诸天来。见般若波罗蜜受读诵说。供养礼拜时。复次憍尸迦。善男子善女人行净洁故。诸天来到其处。见般若波罗蜜受读诵说。供养欢喜礼拜。是中有小鬼辈即时出去。不能堪任是大德诸天威德故。以是大德诸天来故。是善男子善女人生大心。以是故。般若波罗蜜所住处。四面不应有诸不净。应当然灯烧香。散众名花众香涂地。众盖幢幡种种严饰。复次憍尸迦。善男子善女人说法时终无疲极。自觉身轻心乐。随法偃息卧觉安隐无诸恶梦。梦中见诸佛三十二相八十随形好。比丘僧恭敬围绕而为说法。在诸佛边听受法教。所谓六波罗蜜四念处乃至十八不共法。分别六波罗蜜义。分别四念处乃至十八不共法亦分别其义。亦见菩提树庄严殊妙。见诸菩萨趣菩提树得阿耨多罗三藐三菩提。见诸佛成已转法轮。见百千万菩萨共集法论议。应如是求萨婆若。应如是成就众生。应如是净佛国土。亦见十方无数百千万亿诸佛。亦闻其名号某方某国某佛。若干百千万菩萨若干百千万声闻。恭敬围绕说法。复见十方无数百千万亿诸佛般涅槃。复见无数百千万亿诸佛七宝塔。见供养诸塔恭敬尊重赞叹香花乃至幡盖。憍尸迦。是善男子善女人。见如是善梦卧安觉安。诸天益其气力。自觉身体轻便。不大贪着饮食衣服卧具汤药。于四供养其心轻微。譬如比丘坐禅从禅定起心与定合。不贪着饮食其心轻微。何以故。憍尸迦。诸天法应以诸味之精益其气力故。十方诸佛及天龙鬼神阿修罗揵闼婆迦楼罗紧那罗摩睺罗伽。亦益其气力。如是憍尸迦。善男子善女人欲得今世如是功德。应当受持般若波罗蜜亲近读诵说。正忆念亦不离萨婆若心。憍尸迦。善男子善女人虽不能受持乃至正忆念。应当书持经卷恭敬供养尊重赞叹香花璎珞乃至幡盖。憍尸迦。若善男子善女人闻是般若波罗蜜受持读诵说正忆念。书经卷恭敬供养尊重赞叹花香乃至幡盖。是善男子善女人功德甚多。胜于供养十方诸佛及弟子。恭敬尊重赞叹衣服饮食卧具汤药诸佛及弟子般涅槃后起七宝塔。恭敬供养尊重赞叹花香乃至幡盖

摩诃般若经卷第九摩诃般若波罗蜜经卷第十

        后秦龟兹国三藏鸠摩罗什译

    法称品第三十七

佛告释提桓因言。憍尸迦。若满阎浮提佛舍利作一分复有人书般若波罗蜜经卷作一分。二分之中汝取何所。释提桓因白佛言。世尊。若满阎浮提佛舍利作一分。般若波罗蜜经卷作一分。二分之中我宁取般若波罗蜜经卷。何以故。世尊。我于佛舍利非不恭敬非不尊重。世尊。以是舍利从般若波罗蜜中生。般若波罗蜜修熏故。是舍利得供养恭敬尊重赞叹。尔时舍利弗问释提桓因。憍尸迦。是般若波罗蜜不可取。无色无形无对一相。所谓无相。汝云何欲取。何以故。是般若波罗蜜不为取故出不为舍故出。不为增减聚散损益垢净故出。是般若波罗蜜不与诸佛法不舍凡人法。不与辟支佛法阿罗汉法学法。不舍凡人法。不与无为性不舍有为性。不与内空乃至无法有法空。不与四念处乃至一切种智。不舍凡人法。释提桓因语舍利弗。如是如是。舍利弗。若有人知是般若波罗蜜。不与诸佛法不舍凡人法。乃至不与一切种智不舍凡人法。是菩萨摩诃萨能行般若波罗蜜能修般若波罗蜜。何以故。般若波罗蜜不行二法相故。不二法相是般若波罗蜜。不二法相是禅那波罗蜜乃至檀那波罗蜜。尔时佛赞释提桓因言。善哉善哉。憍尸迦。如汝所说。般若波罗蜜不行二法相故。不二法相是般若波罗蜜。不二法相是禅那波罗蜜乃至檀那波罗蜜。憍尸迦。若人欲得法性二相者。是人为欲得般若波罗蜜二相。何以故。憍尸迦。法性般若波罗蜜无二无别。乃至檀那波罗蜜亦如是若人欲得实际不可思议性二相者。是人为欲得般若波罗蜜二相。何以故。般若波罗蜜不可思议性无二无别。释提桓因白佛言。世尊。一切世间人及诸天阿修罗。应礼拜供养般若波罗蜜。何以故。诸菩萨摩诃萨般若波罗蜜中。学得阿耨多罗三藐三菩提。世尊。我常在善法堂上坐。若我不在座时。诸天子来供养我故。为我坐处作礼绕竟还去。诸天子作是念。释提桓因在是处坐。为诸三十三天说法故。如是世尊。在所处书是般若波罗蜜经卷。受持读诵为他演说。是处十方世界中诸天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。皆来礼拜般若波罗蜜供养已去。何以故。是般若波罗蜜中生诸佛。及生一切众生乐具故。诸佛舍利亦是一切种智住处因缘。以是故。世尊。二分中我取般若波罗蜜。复次世尊。我若受持读诵般若波罗蜜心深入法中。我是时不见怖畏相。何以故。世尊。是般若波罗蜜无相无貌无言无说。世尊。无相无貌无言无说。是般若波罗蜜乃至是一切种智。世尊。般若波罗蜜若当有相非无相者。诸佛不应知一切法无相无貌无言无说。得阿耨多罗三藐三菩提。为弟子说诸法亦无相无貌无言无说。世尊。以般若波罗蜜实是无相无貌无言无说故。诸佛知一切诸法无相无貌无言无说。得阿耨多罗三藐三菩提为弟子说诸法亦无相无貌无言无说。以是故。世尊。是般若波罗蜜一切世间诸天人阿修罗。应恭敬供养尊重赞叹香华璎珞乃至幡盖。复次世尊。若有人受持般若波罗蜜。亲近读诵说正忆念。及书供养华香乃至幡盖。是人不堕地狱畜生饿鬼道中。不堕声闻辟支佛地。乃至得阿耨多罗三藐三菩提常见诸佛。从一佛国至一佛国供养诸佛。恭敬尊重赞叹华香乃至幡盖。复次世尊。满三千大千世界佛舍利作一分。书般若波罗蜜经卷作一分。是二分中我故取般若波罗蜜。何以故。世尊。是般若波罗蜜中生诸佛舍利。以是故。舍利得供养恭敬尊重赞叹。是善男子善女人供养恭敬舍利故。受天上人中福乐。常不堕三恶道。如所愿渐以三乘法入涅槃。是故世尊。若有见现在佛。若见般若波罗蜜经卷等无异。何以故世尊。是般若波罗蜜与佛无二无别故。复次世尊。如佛住三事示现说十二部经修多罗祇夜乃至优波提舍。复有善男子善女人受持诵说是般若波罗蜜等无异。何以故世尊。是般若波罗蜜中生三事示现及十二部经修多罗乃至优波提舍故。复次世尊。十方诸佛住三事示现。说十二部经修多罗乃至优波提舍。复有人受般若波罗蜜为他人说等无有异。何以故。般若波罗蜜中生诸佛。亦生十二部经修多罗乃至优波提舍。复次世尊。若有供养十方如恒河沙等世界中诸佛恭敬尊重赞叹华香乃至幡盖。复有人书般若波罗蜜经卷恭敬尊重赞叹华香乃至幡盖。其福正等。何以故。十方诸佛皆从般若波罗蜜中生。复次世尊。善男子善女人闻是般若波罗蜜。受持读诵正忆念亦为他人说。是人不堕地狱道畜生饿鬼道。亦不堕声闻辟支佛地。何以故。当知是善男子善女人正住阿惟越致地中故。是般若波罗蜜远离一切苦恼衰病。复次世尊。若有善男子善女人书是般若波罗蜜经卷受持亲近。供养恭敬尊重赞叹。是人离诸恐怖。世尊。譬如负债人亲近国王供给左右。债主反更供养恭敬是人。是人不复畏怖。何以故。世尊。此人依近于王凭恃有力故。如是世尊。诸佛舍利般若波罗蜜修熏故。得供养恭敬。世尊。当知般若波罗蜜如王。舍利如负债人。负债人依王故得供养。舍利亦依般若波罗蜜修熏故得供养。世尊。当知诸佛一切种智亦以般若波罗蜜修熏故得成就。以是故。世尊。二分中我取般若波罗蜜。何以故。世尊。般若波罗蜜中生诸佛舍利三十二相。般若波罗蜜中亦生佛十力四无所畏四无碍智十八不共法大慈大悲。世尊。般若波罗蜜中生五波罗蜜使得波罗蜜名字。般若波罗蜜中生诸佛一切种智。复次世尊所在三千大千世界中。若有受持供养恭敬尊重赞叹般若波罗蜜。是处若人若非人不能得其便是人渐渐得入涅槃。世尊。般若波罗蜜为大利益如是。于三千大千世界中能作佛事。世尊。在所处有般若波罗蜜则为有佛。世尊。譬如无价摩尼珠宝。在所住处非人不得其便。若男子女人有热病以是宝着身上。热病即时除愈。若有风病若有冷病。若有杂热风冷病。以宝着身上皆悉除愈。若闇中是宝能令明。热时能令凉寒时能令温。宝所住处其地不寒不热时节和适。其处亦无诸余毒螫。若男子女人为毒蛇所螫。以宝示之毒即除灭。复次世尊。若男子女人眼痛肤翳盲瞽以宝近之即时除愈。若有癞疮恶肿。以宝着身上病即除愈。复次世尊。是摩尼宝所在水中。水随作一色。世尊是宝若以青物裹着水中。水色则为青。若黄赤白红缥物裹着水中。水随作黄赤白红缥色。如是等种种色物裹着水中。水随作种种色。世尊。若水浊以宝着中水即为清。是宝其德如是。尔时阿难问释提桓因言。憍尸迦。是摩尼宝。为是天上宝为是阎浮提宝。释提桓因语阿难。是天上宝阎浮提人亦有是宝。但功德相少不具足。天上宝清净轻妙不可以譬喻为比。复次世尊。是摩尼宝。若着箧中举宝出。其功德薰箧故人皆爱敬。如是世尊在所在处。有书般若波罗蜜经卷。是处则无众恼之患。亦如摩尼宝所著处则无众难。世尊。佛般涅槃后舍利得供养。皆是般若波罗蜜力。禅那波罗蜜乃至檀那波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切智法相法住法位法性。实际不可思议性一切种智是诸功德力。善男子善女人作是念。是佛舍利一切智一切种智大慈大悲。断一切结使及习。常舍行不错谬法等诸佛功德住处。以是故。舍利得供养。世尊。舍利是诸功德宝波罗蜜住处。不垢不净波罗蜜住处。不生不灭波罗蜜。不入不出波罗蜜不增不损波罗蜜。不来不去不住波罗蜜。是佛舍利。是诸法相波罗蜜住处。以是诸法相波罗蜜修薰故舍利得供养。复次世尊。置三千大千世界满中舍利。如恒河沙等诸世界满其中舍利作一分。有人书般若波罗蜜经卷作一分。二分之中我取般若波罗蜜。何以故。是般若波罗蜜中生诸佛舍利。是般若波罗蜜修薰故舍利得供养。世尊。若有善男子善女人供养舍利恭敬尊重赞叹。其功德报不可得边。受人中。天上福乐。所谓刹利大姓婆罗门大姓居士大家四天王天处。乃至他化自在天中受福乐。亦以是福德因缘故当得尽苦。若受是般若波罗蜜读诵解说正忆念。是人能具足禅那波罗蜜乃至能具足檀那波罗蜜。能具足四念处乃至能具足十八不共法。过声闻辟支佛地住菩萨位。住菩萨位已得菩萨神通。从一佛国至一佛国。是菩萨为众生故受身。随其所应成就众生。若作转轮圣王若作刹利大姓。若作婆罗门大姓成就众生以是故。世尊。我不为轻慢不恭敬故不取舍利。以善男子善女人供养般若波罗蜜则为供养舍利故。复次世尊。有人欲见十方无量阿僧祇诸世界中现在佛法身色身。是人应闻受持般若波罗蜜读诵正忆念为他人演说。如是善男子善女人。当见十方无量阿僧祇世界中诸佛法身色身。是善男子善女人行般若波罗蜜。亦应以法相修念佛三昧。复次善男子善女人欲见现在诸佛。应当受是般若波罗蜜乃至正忆念。复次世尊。有二种法相。有为诸法相。无为诸法相云何有为诸法相。所谓内空中智慧。乃至无法有法空中智慧。四念处中智慧。乃至八圣道分中智慧。佛十力四无所畏四无碍智。十八不共法中智慧。善法中不善法中。有漏法中无漏法中。世间法中出世间法中智慧。是名有为诸法法相。云何名无为诸法法相。若法无生无灭无住无异。无垢无净无增无减诸法自性。云何名诸法自性。诸法无所有性是诸法自性。是名无为诸法相。尔时佛告释提桓因。如是如是。憍尸迦。过去诸佛因是般若波罗蜜得阿耨多罗三藐三菩提。过去诸佛弟子亦因般若波罗蜜得须陀洹道乃至阿罗汉辟支佛道。未来现在世十方无量阿僧祇诸佛。因是般若波罗蜜得阿耨多罗三藐三菩提。未来现在诸佛弟子亦因是般若波罗蜜得须陀洹道乃至辟支佛道。何以故般若波罗蜜中广说三乘义。以无相法故。无生无灭法故。无垢无净法故。无作无起不入不出。不增不损不取不舍法故。以俗法故非第一义。何以故。是般若波罗蜜非此非彼非高非下。非等非不等。非相非无相。非世间非出世间。非有漏非无漏。非有为非无为。非善非不善。非过去非未来非现在。何以故。憍尸迦。般若波罗蜜不取声闻辟支佛法亦不舍凡人法。释提桓因白佛言。世尊。菩萨摩诃萨行般若波罗蜜。知一切众生心。亦不得众生乃至知者见者亦不得是菩萨不得色不得受想行识。不得眼乃至意不得色乃至法。不得眼触因缘生受乃至意触因缘生受。不得四念处乃至十八不共法。不得阿耨多罗三藐三菩提。不得诸佛法不得佛。何以故。般若波罗蜜不为得法故出。何以故。般若波罗蜜性无所有不可得。所用法不可得处亦不可得。佛告释提桓因言。如是如是。憍尸迦。如汝所说。菩萨摩诃萨长夜行般若波罗蜜。阿耨多罗三藐三菩提不可得。何况菩萨及菩萨法。尔时释提桓因白佛言。世尊。菩萨摩诃萨但行般若波罗蜜。不行余波罗蜜耶。佛告释提桓因言。憍尸迦。菩萨尽行六波罗蜜法以无所得故。行檀那波罗蜜不得施者不得受者不得财物。行尸罗波罗蜜不得戒不得持戒人不得破戒人。乃至行般若波罗蜜不得智慧不得智慧人不得无智慧人。憍尸迦。菩萨摩诃萨行布施时。般若波罗蜜为作明导。能具足檀那波罗蜜。菩萨摩诃萨行持戒时。般若波罗蜜为作明导能具足尸罗波罗蜜。菩萨摩诃萨行忍辱时。般若波罗蜜为作明导能具足羼提波罗蜜。菩萨摩诃萨行精进时。般若波罗蜜为作明导能具足毗梨耶波罗蜜。菩萨摩诃萨行禅那时。般若波罗蜜为作明导能具足禅那波罗蜜。菩萨摩诃萨观诸法时。般若波罗蜜为作明导能具足般若波罗蜜。一切法以无所得故。所谓色乃至一切种智。憍尸迦。譬如阎浮提诸树。种种叶种种华种种果种种色。其荫无差别。诸波罗蜜入般若波罗蜜中。至萨婆若无差别亦如是。以无所得故。释提桓因白佛言。世尊。般若波罗蜜大功德成就。世尊。般若波罗蜜一切功德成就。世尊。般若波罗蜜无量功德成就。无边功德成就。无等功德成就。世尊。若有善男子善女人书是般若波罗蜜经卷。恭敬供养尊重赞叹华香乃至幡盖。如般若波罗蜜所说正忆念。复有善男子善女人书般若波罗蜜经卷与他人。其福何所为多。佛告释提桓因。憍尸迦。我还问汝随汝意报我。若有善男子善女人供养诸佛舍利。恭敬尊重赞叹华香乃至幡盖。若复有人分舍利如芥子许与他人。令供养恭敬尊重赞叹华香乃至幡盖。其福何所为多。释提桓因白佛言。世尊。如我从佛闻法中义。有善男子善女人自供养舍利乃至幡盖。若复有人分舍利如芥子许与他人令供养其福甚多。世尊。佛见是福利众生故。入金刚三昧中。碎金刚身作末舍利。何以故。有人佛灭度后。供养佛舍利乃至如芥子许。其福报无边乃至尽苦。佛告释提桓因言。如是如是。憍尸迦。若善男子善女人书般若波罗蜜经卷。供养恭敬香花乃至幡盖。若复有人书般若波罗蜜经卷与他人令学。是善男子善女人其福甚多。复次憍尸迦。善男子善女人。如般若波罗蜜中义为他人说。开示分别令易解。是善男子善女人。胜于前善男子善女人功德所从闻般若波罗蜜当视其人如佛。亦如高胜梵行人。何以故。当知般若波罗蜜即是佛。般若波罗蜜不异佛。佛不异般若波罗蜜。过去未来现在诸佛。皆从般若波罗蜜中学得阿耨多罗三藐三菩提及高胜梵行人。高胜梵行人者。所谓阿惟越致菩萨摩诃萨。亦学是般若波罗蜜当得阿耨多罗三藐三菩提。声闻人学是般若波罗蜜得阿罗汉道。求辟支佛道人学是般若波罗蜜得辟支佛道。菩萨学是般若波罗蜜得入菩萨位。以是故。憍尸迦。善男子善女人欲供养现在佛。恭敬尊重赞叹花香乃至幡盖。当供养般若波罗蜜。我见是利益初得阿耨多罗三藐三菩提时作是念。谁有可供养恭敬尊重赞叹依止住者。憍尸迦。我于一切世间中若天若魔若梵若沙门婆罗门中。不见与我等者。何况有胜者。我又自思念。我所得法自致作佛。我供养是法。恭敬尊重赞叹当依止住。何等是法。所谓般若波罗蜜。憍尸迦。我自供养是般若波罗蜜恭敬尊重赞叹已依止住。何况善男子善女人欲得阿耨多罗三藐三菩提。而不供养般若波罗蜜恭敬尊重赞叹花香璎珞乃至幡盖。何以故。般若波罗蜜中生诸菩萨摩诃萨。诸菩萨摩诃萨中生诸佛。以是故。憍尸迦。善男子善女人若求佛道若求辟支佛道若求声闻道。皆应供养般若波罗蜜恭敬尊重赞叹花香乃至幡盖

    摩诃般若波罗蜜经法施品第三十八(丹十善品)

佛告释提桓因言。憍尸迦。若有善男子善女人。教一阎浮提人行十善道。于汝意云何。以是因缘故得福多不。答言。甚多世尊。佛言。不如是善男子善女人书持般若波罗蜜经卷与他人令读诵说得福多。何以故。是般若波罗蜜中广说诸无漏法。善男子善女人从是中学已学今学当学入正法位中。已入今入当入得须陀洹果已得今得当得乃至阿罗汉果。求辟支佛道亦如是。诸菩萨摩诃萨求阿耨多罗三藐三菩提入正法位中。已入今入当入得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。何等是无漏法所谓四念处乃至八圣道分四圣谛。内空乃至无法有法空。佛十力乃至十八不共法。善男子善女人学是法得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。若有善男子善女人。教一人令得须陀洹果。是人得福德胜教一阎浮提人行十善道。何以故。憍尸迦。教一阎浮提人行十善道。不离地狱畜生饿鬼苦。憍尸迦。教一人令得须陀洹果离三恶道故。乃至阿罗汉果辟支佛道亦如是。憍尸迦。若善男子善女人。教一阎浮提人令得须陀洹果斯陀含阿那含阿罗汉辟支佛道。不如善男子善女人教一人令得阿耨多罗三藐三菩提得福多。何以故。憍尸迦。以菩萨因缘故生须陀洹乃至阿罗汉辟支佛。以菩萨因缘故生诸佛。以是因缘故。憍尸迦。当知善男子善女人书般若波罗蜜经卷。与他人令书持读诵说得福多。何以故。是般若波罗蜜中广说诸善法。是善法中学便出生刹利大姓婆罗门大姓居士大家四天王天乃至非有想非无想天。便有四念处乃至一切种智。便有须陀洹乃至阿罗汉辟支佛。便有诸佛。憍尸迦。置一阎浮提人。若有善男子善女人教四天下国土中众生令行十善道。于汝意云何。是人以是因缘故得福多不。答言。甚多世尊。佛言。不如善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。余如上说。憍尸迦。置四天下国土中众生。若教小千国土中众生令行十善道亦如是。憍尸迦。置小千国土中众生。若教二千中国土中众生令行十善道。若有善男子善女人书般若波罗蜜经卷。与他人令书持读诵说是人得福多。余如上说。憍尸迦。置二千中国土中众生。若教三千大千国土中所有众生令行十善道。复有人书般若波罗蜜经卷。与他人令书持读诵说是人福德多。憍尸迦。置三千大千国土中众生。若教如恒河沙等国土中所有众生令行十善道。若复有人书般若波罗蜜经卷。与他人令书持读诵说其福多。余如上说。复次憍尸迦。有人教一阎浮提众生。令立四禅四无量心四无色定五神通。于汝意云何。是善男子善女人福德多不。释提桓因言。甚多世尊。佛言。不如是善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。何以故。是般若波罗蜜中广说诸善法。余如上说。憍尸迦。置阎浮提中众生。复置四天下国土中众生。小千国土中众生。二千中国土中众生。三千大千国土中众生。憍尸迦。若有人教十方如恒河沙等国土中众生。令立四禅四无量心四无色定五神通。于汝意云何。是人福德多不。答言。甚多世尊。佛言。不如是善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。何以故。是般若波罗蜜中广说诸善法。余如上说。复次憍尸迦。若有善男子善女人。受是般若波罗蜜持读诵说正忆念。是人福德胜教阎浮提人行十善道。立四禅四无量心四无色定五神通正忆念者。受持亲近般若波罗蜜乃至正忆念。不以二法不以不二法。受持亲近禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜乃至正忆念。不以二法不以不二法。为阿耨多罗三藐三菩提正忆念。内空乃至一切种智。不以二法不以不二法。复次憍尸迦。若有善男子善女人为他人种种因缘。演说般若波罗蜜义。开示分别令易解。憍尸迦。何等是般若波罗蜜义。憍尸迦。般若波罗蜜义者。不应以二相观。不应以不二相观。非有相非无相。不入不出不增不损。不垢不净不生不灭。不取不舍不住非不住。非实非虚非合非散。非着非不着。非因非不因。非法非不法。非如非不如。非实际非不实际。憍尸迦。若善男子善女人能以是般若波罗蜜义。为他人种种因缘演说。开示分别令易解。是善男子善女人所得福德甚多。胜自受持般若波罗蜜亲近读诵说正忆念。复次憍尸迦。善男子善女人自受持般若波罗蜜。亲近读诵说正忆念。亦为他人种种因缘。演说般若波罗蜜义开示分别令易解。是善男子善女人所得功德甚多。释提桓因白佛言。世尊。善男子善女人应如是演说般若波罗蜜义开示分别令易解。佛语释提桓因言。如是憍尸迦。是善男子善女人应如是演说般若波罗蜜义开示分别令易解。憍尸迦。善男子善女人如是演说般若波罗蜜义开示分别令易解。得无量无边阿僧祇福德。若有善男子善女人供养十方无量阿僧祇诸佛。尽其寿命随其所须。恭敬尊重赞叹花香乃至幡盖供养。若复有善男子善女人种种因缘。为他人广说般若波罗蜜义开示分别令易解。是善男子善女人功德甚多。何以故。诸过去未来现在佛皆于是般若波罗蜜中学。得阿耨多罗三藐三菩提已得今得当得。复次憍尸迦。若善男子善女人于无量无边阿僧祇劫行檀那波罗蜜。不如是善男子善女人以般若波罗蜜为他人演说其义开示分别令易解其福甚多。以无所得故。云何名有所得。憍尸迦。若菩萨摩诃萨用有所得故布施。布施时作是念。我与彼受所施者物。是名得檀那不得波罗蜜。我持戒此是戒。是名得戒不得波罗蜜。我忍辱为是人忍辱。是名得忍辱不得波罗蜜。我精进为是事勤精进。是名得精进不得波罗蜜。我修禅那所修是禅那是名得禅那不得波罗蜜。我修慧所修是慧。是名得慧不得波罗蜜。憍尸迦。是善男子善女人如是行者不得具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。释提桓因白佛言。世尊。菩萨摩诃萨云何修具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。佛告释提桓因言。菩萨摩诃萨布施时。不得与者。不得受者。不得所施物。是人得具足檀那波罗蜜。乃至修般若波罗蜜时不得智不得所修智。是人得具足般若波罗蜜。憍尸迦。是为菩萨摩诃萨。具足檀那波罗蜜乃至般若波罗蜜。善男子善女人如是行般若波罗蜜。当为他人演说其义开示分别令易解。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。演说其义开示分别令易解。何以故。憍尸迦。未来世当有善男子善女人。欲说般若波罗蜜而说相似般若波罗蜜有善男子善女人发阿耨多罗三藐三菩提心。闻是相似般若波罗蜜失正道。善男子善女人应为是人具足演说般若波罗蜜义开示分别令易解。释提桓因白佛言。世尊。何等是相似般若波罗蜜。佛言。有善男子善女人说有所得般若波罗蜜。是为相似般若波罗蜜。释提桓因白佛言。世尊。云何善男子善女人说有所得般若波罗蜜。是为相似般若波罗蜜。佛言。善男子善女人说有所得般若波罗蜜。是为相似般若波罗蜜。相似般若波罗蜜者说色无常。作是言能如是行。是行般若波罗蜜。行者求色无常。是为行相似般若波罗蜜。说受想行识无常。作是言能如是行。是行般若波罗蜜。行者求受想行识无常。是为行相似般若波罗蜜。说眼无常乃至说意无常。说色无常。乃至。说法无常。说眼界无常色界眼识界无常。乃至说意界法界意识界无常。说地种无常。乃至说识种无常。说眼识界无常。乃至说意识界无常。说眼触无常。乃至说意触无常。说眼触因缘生受无常。乃至说意触因缘生受无常。广说如五阴。说色苦乃至说意触因缘生受苦。说色无我乃至说意触因缘生受无我。皆如五阴说。行者行檀那波罗蜜时。为说色无常苦无我乃至意触因缘生受说无常苦无我。尸罗波罗蜜乃至般若波罗蜜亦如是。行四禅四无量心四无色定为说无常苦无我。行四念处为说无常苦无我。乃至行萨婆若时为说无常苦无我。作如是教能如是行者。是为行般若波罗蜜。憍尸迦。是名相似般若波罗蜜。复次憍尸迦。若是善男子善女人当来世说相似般若波罗蜜。作是言。汝善男子善女人修行般若波罗蜜。汝修行般若波罗蜜时当得初地。乃至当得十地。禅那波罗蜜乃至檀那波罗蜜亦如是。行者以相似有所得。以总相修是般若波罗蜜。憍尸迦。是名相似般若波罗蜜。复次憍尸迦。善男子善女人欲说般若波罗蜜。作是言。汝善男子善女人修行般若波罗蜜已。当过声闻辟支佛地。是名相似般若波罗蜜。复次憍尸迦。善男子善女人为求佛道者如是说。汝善男子善女人修行般若波罗蜜已。入菩萨位得无生法忍。得无生忍已便住菩萨神通。从一佛国至一佛国供养诸佛恭敬尊重赞叹。如是说者。是名相似般若波罗蜜。复次憍尸迦。善男子善女人为求佛道者如是说。汝善男子善女人学是般若波罗蜜。受持读诵说正忆念。当得无量无边阿僧祇功德。如是说者是名相似般若波罗蜜。复次善男子善女人为求佛道者如是说。如过去未来现在诸佛功德善本。从初发心至成得佛。都合集回向阿耨多罗三藐三菩提。如是说者是名相似般若波罗蜜。释提桓因白佛言。世尊。云何善男子善女人为求佛道者。不说相似般若波罗蜜。佛言。若善男子善女人为求佛道者说般若波罗蜜。善男子。汝修行般若波罗蜜莫观色无常。何以故。色色性空。是色性非法若非法。即名为般若波罗蜜。般若波罗蜜中色非常非无常。何以故。是中色尚不可得。何况常无常。憍尸迦。善男子善女人如是说者。是名不说相似般若波罗蜜。受想行识亦如是。复次憍尸迦。善男子善女人为求佛道者说。汝善男子。修行般若波罗蜜。于诸法莫有所过莫有所住。何以故。般若波罗蜜中无有法可过可住。所以者何。一切法自性空。自性空是非法若非法即是般若波罗蜜。般若波罗蜜中无有法可入可出可生可灭。憍尸迦。是善男子善女人如是说。是名不说相似般若波罗蜜。广说如上与相似相违。是名不说相似般若波罗蜜。如是憍尸迦。善男子善女人应如是演说般若波罗蜜义。若如是说般若波罗蜜义。所得功德胜于前者。复次憍尸迦。阎浮提中所有众生皆教令得须陀洹。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。善男子善女人汝来受是般若波罗蜜。勤诵读说正忆念。如般若波罗蜜中所说行。何以故。是般若波罗蜜中出生诸须陀洹。憍尸迦。置阎浮提中众生。复置四天下众生小千国土二千中国土三千大千国土众生。若有人教十方如恒河沙国土中众生。尽教令得须陀洹。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。善男子。汝来受是般若波罗蜜。勤诵读说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中出生诸须陀洹。复次憍尸迦。若有善男子善女人教阎浮提中人。令得斯陀含阿那含阿罗汉。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜。为他人种种因缘演说其义开示分别令易解。如是言。善男子。汝来受是般若波罗蜜。勤诵读说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中出生诸斯陀含阿那含阿罗汉故。乃至十方如恒河沙等国土中众生亦如是。复次憍尸迦。若善男子善女人教一阎浮提中众生令得辟支佛道。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。善男子。汝来受是般若波罗蜜。勤读诵解说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中出生诸辟支佛道故。四天下乃至十方如恒河沙等国土中众生亦如是。复次憍尸迦。善男子善女人教一阎浮提中众生。令发阿耨多罗三藐三菩提心。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。亦如是言。汝当随般若波罗蜜中学。当得一切智法。汝若得一切智法。汝便得修行般若波罗蜜增益具足。若得修行般若波罗蜜增益具足。汝当得阿耨多罗三藐三菩提。何以故。憍尸迦。般若波罗蜜中。生诸初发意菩萨摩诃萨故。乃至十方如恒河沙等国土亦如是。复次憍尸迦。善男子善女人教一阎浮提中众生。令住阿惟越致地。于汝意云何。是人福德多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。亦如是言。汝来善男子。受是般若波罗蜜乃至如般若波罗蜜中所说行。汝便得一切智法。得一切智法已乃至便得阿耨多罗三藐三菩提。何以故。般若波罗蜜中生诸菩萨摩诃萨阿惟越致地故。乃至十方如恒河沙等国土亦如是。复次憍尸迦。一阎浮提中众生发意求阿耨多罗三藐三菩提。若有善男子善女人为是人广说般若波罗蜜及其义解。开示分别。如是言。汝来善男子。受是般若波罗蜜。乃至如般若波罗蜜中所说行。学已汝当得阿耨多罗三藐三菩提。复有人为一阿惟越致菩萨演说般若波罗蜜。及其义解开示分别。汝来受是般若波罗蜜。乃至如般若波罗蜜中所说行。学已汝当得阿耨多罗三藐三菩提。是善男子所得功德甚多。乃至十方如恒河沙等国土中亦如是。复次憍尸迦。若有一阎浮提中众生皆得阿惟越致阿耨多罗三藐三菩提。复有善男子善女人以般若波罗蜜。为是人演说其义于是中有一菩萨疾欲得阿耨多罗三藐三菩提。若有善男子善女人。为此菩萨说般若波罗蜜及其义解。是人功德最多。乃至十方如恒河沙等国土亦如是。释提桓因白佛言。世尊。如菩萨摩诃萨转转近阿耨多罗三藐三菩提者。如是应转转教行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。应教内空乃至无法有法空。四念处乃至八圣道分佛十力四无所畏四无碍智。十八不共法。亦应供养衣服卧具饮食汤药随其所须。是善男子善女人。法施财施供养是菩萨。所得功德胜于前者。何以故。世尊。是菩萨摩诃萨疾得阿耨多罗三藐三菩提故。尔时慧命须菩提语释提桓因言。善哉善哉。憍尸迦。汝为圣弟子。安慰诸菩萨摩诃萨为阿耨多罗三藐三菩提者。以法施财施利益法应尔。何以故。菩萨中生诸佛圣众。若菩萨不发阿耨多罗三藐三菩提心者。是菩萨不能学六波罗蜜乃至十八不共法。若不学六波罗蜜乃至十八不共法。不能得阿耨多罗三藐三菩提。若不能得阿耨多罗三藐三菩提者。则无声闻辟支佛。以是故。憍尸迦。诸菩萨摩诃萨学六波罗蜜乃至十八不共法。学六波罗蜜乃至十八不共法时。得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提故。断地狱畜生饿鬼道。世间便有刹利大姓婆罗门大姓居士大家。四天王天乃至非有想非无想天。乃至檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法出现于世。声闻乘辟支佛乘佛乘皆现于世

摩诃般若波罗蜜经卷第十摩诃般若波罗蜜经卷第十一

        后秦龟兹国三藏鸠摩罗什译

    随喜品第三十九(丹随喜回向品)

尔时弥勒菩萨摩诃萨语慧命须菩提。有菩萨摩诃萨随喜福德与一切众生共之。回向阿耨多罗三藐三菩提。以无所得故。若声闻辟支佛福德。若一切众生福德。若布施若持戒若修定若随喜。是菩萨摩诃萨随喜福德与一切众生共之。回向阿耨多罗三藐三菩提。其福德最上第一。最妙无上无与等。何以故。声闻辟支佛及一切众生。布施持戒修定随喜。为自调为自净为自度故起。所谓四念处乃至八圣道分空无相无作。菩萨随喜福德回向阿耨多罗三藐三菩提。持是功德为调一切众生。为净一切众生。为度一切众生故起。尔时慧命须菩提白弥勒菩萨言。诸菩萨摩诃萨念十方无量无边阿僧祇国土中。无量无边阿僧祇诸灭度佛。从初发心至得阿耨多罗三藐三菩提。入无余涅槃乃至法尽。于其中间诸善根应六波罗蜜。及诸声闻人善根。若布施福德持戒修定福德。及诸学人无漏善根。无学人无漏善根。诸佛戒众定众慧众解脱众解脱知见众。一切智大慈大悲。及余无量阿僧祇诸佛法。及诸佛所说法。是法中学得须陀洹果。乃至得阿罗汉果辟支佛道。入菩萨摩诃萨位。及余众生种诸善根。是诸善根一切和合随喜福德。回向阿耨多罗三藐三菩提。最上第一最妙无上无与等如是随喜已。持是随喜福德回向阿耨多罗三藐三菩提。若有善男子行菩萨乘者作是念。我是心回向阿耨多罗三藐三菩提。是生心缘事。若善男子。取相回向阿耨多罗三藐三菩提。如所念可得不。弥勒菩萨语须菩提。是善男子行菩萨乘回向阿耨多罗三藐三菩提心是缘事。若善男子。取相不得如所念。须菩提语弥勒菩萨。若诸缘诸事无所有。是善男子行菩萨乘者。取相于十方诸佛诸善根。从初发心乃至法尽。及声闻诸善根。学无学善根。一切和合随喜功德。回向阿耨多罗三藐三菩提。以无相故。是菩萨将无颠倒。无常谓常。想颠倒心颠倒见颠倒。不净谓净。苦谓为乐。无我谓我。想颠倒心颠倒见颠倒。若如缘如事。为阿耨多罗三藐三菩提亦如是。回向心亦如是。檀那波罗蜜尸罗羼提毗梨耶禅那般若波罗蜜乃至十八不共法亦如是。若尔者。何等是缘。何等是事。何等是阿耨多罗三藐三菩提。何等是善根。何等是随喜心回向阿耨多罗三藐三菩提。弥勒菩萨语须菩提。若诸菩萨摩诃萨久行六波罗蜜。多供养诸佛种善根。与善知识相随。善学自相空法。是诸菩萨是缘是事。诸佛诸善根随喜福德。不取相回向阿耨多罗三藐三菩提。以不二法非不二法。非相非不相。非可得法非不可得法非净非垢不生不灭法。是名回向阿耨多罗三藐三菩提。若诸菩萨不久行六波罗蜜。不多供养诸佛。不种善根。不与善知识相随。不善学自相空法。是诸菩萨是诸缘是诸事。诸佛诸善根随喜福德诸心取相。回向阿耨多罗三藐三菩提。是不名回向。须菩提。如是般若波罗蜜义。乃至一切种智义。所谓内空乃至无法有法空。不应为新学菩萨说。何以故。是菩萨所有少许信乐恭敬清净心皆忘失。当在阿惟越致菩萨摩诃萨前说。若有为善知识所护。若久供养诸佛种诸善根。应为是人说如是般若波罗蜜义。乃至一切种智义。所谓内空乃至无法有法空。是人闻是法不没不惊不畏不怖须菩提。菩萨摩诃萨随喜福德。应如是。回向阿耨多罗三藐三菩提。所谓菩萨用心随喜福德。回向阿耨多罗三藐三菩提。是心尽灭变离。是缘是事是诸善根。亦尽灭变离。是中何等是随喜心。何等是诸缘。何等是诸事。何等是诸善根。随喜回向阿耨多罗三藐三菩提。二心不俱。是心性亦不可得回向。菩萨云何随喜心回向阿耨多罗三藐三菩提。若菩萨摩诃萨行般若波罗蜜时。如是知是般若波罗蜜无有法。乃至檀那波罗蜜亦无有法。色无有法受想行识乃至阿耨多罗三藐三菩提无有法。菩萨摩诃萨应如是随喜功德。回向阿耨多罗三藐三菩提。若能如是回向。是名随喜功德回向阿耨多罗三藐三菩提。尔时释提桓因语须菩提。新发意菩萨闻是事将无惊惧怖畏。须菩提。云何新发意菩萨。作诸善根回向阿耨多罗三藐三菩提。复云何随喜福德回向阿耨多罗三藐三菩提。须菩提语释提桓因。若新发意菩萨行般若波罗蜜。不受是般若波罗蜜。以无所得故无相故。乃至檀那波罗蜜亦如是。多信解内空。乃至多信解无法有法空。多信解四念处乃至十八不共法。常与善知识相随。是善知识为说六波罗蜜义。开示分别如是教授。令常不离般若波罗蜜。乃至得入菩萨法位终不离般若波罗蜜。乃至不离檀那波罗蜜。不离四念处乃至十八不共法。亦教语魔事。闻种种魔事已不增不减。何以故。是菩萨摩诃萨不受一切法故。是菩萨亦常不离诸佛。乃至得菩萨位于中种善根。以是善根故生菩萨家。至得阿耨多罗三藐三菩提终不离是善根。复次新发意菩萨摩诃萨于过去十方无量无边阿僧祇国土中诸佛。断生死道断诸戏论道。尽弃重担灭聚落刺。断诸有结正智解脱。及弟子所作功德。于是中若刹利大姓婆罗门大姓居士大家。四天王天乃至净居天所种善根。是一切和合称量。以随喜心最上第一最妙无上无与等应随喜。随喜已回向阿耨多罗三藐三菩提。尔时弥勒菩萨语须菩提。若新发意菩萨摩诃萨念诸佛及弟子诸善根随喜功德。最上第一最妙无上无与等。随喜已应回向阿耨多罗三藐三菩提。云何菩萨不堕想颠倒心颠倒见颠倒。须菩提言。若菩萨摩诃萨念诸佛及僧。于是中不生佛想。不生僧想无善根想。用是心回向阿耨多罗三藐三菩提。是心中亦不生心想。菩萨如是回向想不颠倒心不颠倒见不颠倒。若菩萨摩诃萨念诸佛及僧善根取相。取相已回向阿耨多罗三藐三菩提。菩萨。如是名为想颠倒心颠倒见颠倒。若菩萨摩诃萨用是心念诸佛及僧诸善根。是心念时即知尽灭。若尽灭是法不可得。回向所用回向心亦是尽灭相。所回向处及法亦如是相。若如是相回向。是名正回向非邪回向。菩萨摩诃萨应如是回向阿耨多罗三藐三菩提。复次若菩萨摩诃萨过去诸佛善根及弟子善根。是中凡夫人闻法种善根。若诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。闻法种善根。若刹利大姓波罗门大姓居士大家。四天王天乃至阿迦尼吒天。闻法种善根。发阿耨多罗三藐三菩提心。是一切福德和合称量随喜功德。最上第一最妙无上无与等。回向阿耨多罗三藐三菩提。是时菩萨若如是知是诸法尽灭。所回向处及法亦自性空能如是回向。是名真回向阿耨多罗三藐三菩提。复次若菩萨如是知无有法能回向法。何以故。一切法自性空故。若如是回向。是名正回向阿耨多罗三藐三菩提。如是菩萨摩诃萨行般若波罗蜜乃至檀那波罗蜜。不堕想颠倒心颠倒见颠倒。何以故。菩萨不着是回向。亦不见以诸善根回向菩提心处。是名菩萨摩诃萨无上回向。复次若菩萨摩诃萨知所作福德离五阴十二入十八界。亦知般若波罗蜜是离相。乃至檀那波罗蜜是离相。内空乃至无法有法空是离相。四念处乃至十八不共法是离相。如是菩萨摩诃萨随喜心起福德。名回向阿耨多罗三藐三菩提。复次若菩萨摩诃萨随喜福德。知随喜福德自性离。亦知诸佛离。佛性诸善根亦离。善根性菩提心菩提心性亦离。回向回向性亦离。菩萨菩萨性亦离。般若波罗蜜般若波罗蜜性亦离。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜檀那波罗蜜性亦离。乃至十八不共法十八不共法性亦离。菩萨摩诃萨应如是行离相般若波罗蜜。是名菩萨摩诃萨般若波罗蜜中生随喜福德。复次菩萨摩诃萨诸过去灭度佛诸善根。若欲回向应如是回向。作是念如诸佛灭度相。诸善根相亦如是。灭度法相亦如是。我用心回向是心相亦如是。若能如是回向当知是回向阿耨多罗三藐三菩提。如是回向不堕想颠倒心颠倒见颠倒。若菩萨摩诃萨行般若波罗蜜时。取诸佛善根相回向阿耨多罗三藐三菩提。是不名为回向。何以故。诸过去佛及善根。非相缘非无相缘。若菩萨摩诃萨作如是取相。是不名善根回向阿耨多罗三藐三菩提。如是菩萨摩诃萨堕想颠倒心颠倒见颠倒。若菩萨摩诃萨诸佛及诸善根及诸心不取相。是名以诸善根回向阿耨多罗三藐三菩提。如是菩萨摩诃萨不堕想颠倒心颠倒见颠倒。尔时弥勒菩萨问须菩提。云何菩萨摩诃萨于诸善根不取相。能回向阿耨多罗三藐三菩提。须菩提言。以是事故。当知菩萨摩诃萨所学般若波罗蜜中。应有般若波罗蜜方便力。若是福德离般若波罗蜜。不得回向阿耨多罗三藐三菩提。何以故。般若波罗蜜中诸佛不可得。诸善根不可得。回向阿耨多罗三藐三菩提心亦不可得。于是中菩萨摩诃萨行般若波罗蜜时。应如是思惟。过去诸佛及弟子身皆灭诸善根亦灭。我今取相分别诸佛诸善根及诸心。以是取相回向阿耨多罗三藐三菩提。诸佛所不许。何以故。取相有所得故。所谓于过去诸佛取相分别。是故菩萨摩诃萨欲以诸善根回向阿耨多罗三藐三菩提。不应有得不应取相如是回向。若有得取相回向。诸佛不说有大利益。何以故。是回向杂毒故。譬如美食杂毒。虽有好色好香为人所贪而其中杂毒。愚痴之人食之欢喜。贪其好色香美可口。饭欲消时受若死若死等苦。若善男子善女人。不谛受不谛取相。不谛诵读不解中义。如是教他言。汝善男子。过去未来现在十方诸佛。从初发意已来至得阿耨多罗三藐三菩提。入无余涅槃乃至法尽。于其中间行般若波罗蜜时作诸善根。行禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜时作诸善根。修四禅四无量心四无色定四念处乃至八圣道分佛十力。乃至修十八不共法时作诸善根。净佛国土成就众生作诸善根。及诸佛戒众定众慧众解脱众解脱知见众一切种智。无错谬法常舍行。及诸弟子是中所种善根。及诸佛所记当作辟支佛。是中诸天龙阿修罗迦楼罗紧陀罗摩睺罗伽等所种善根。是诸福德称量和合随喜。回向阿耨多罗三藐三菩提。是回向以取相得法故如杂毒食。得法者终无正回向。何以故。是得法杂毒有相有动有戏论。若如是回向。则为谤佛不随佛教不随法说。是善男子善女人。求佛道应如是学。过去未来现在诸佛。从初发意乃至法尽。及弟子行般若波罗蜜时作善根乃至修一切种智。余如上说。云何诸善根回向阿耨多罗三藐三菩提正回向。有求佛道善男子善女人行般若波罗蜜不欲谤诸佛者。诸福德应如是回向。如诸佛所知以无上智慧。是诸善根相是诸善根性我亦如是随喜。如诸佛所知我亦如是回向阿耨多罗三藐三菩提。求菩萨道善男子善女人。应如是回向阿耨多罗三藐三菩提。若如是回向则为不谤佛。如佛所教如佛法说。是菩萨摩诃萨回向则无杂毒。复次求佛道善男子善女人行般若波罗蜜时。诸善根应如是回向。如色不系欲界。不系色界。不系无色界。不系法者。不名过去不名未来不名现在。如受想行识。不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。十二入十八界亦如是。如般若波罗蜜。不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。禅那波罗蜜乃至檀那波罗蜜亦如是。内空乃至无法有法空亦如是。如四念处不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。乃至八圣道分亦如是。佛十力乃至十八不共法亦如是如法性法相法住法位。实际不可思议性。戒定慧解脱解脱知见众一切种智无错谬法常舍行。不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。是回向所回向处。行者不系皆亦如是。是诸佛亦不系。诸善根亦不系。是诸声闻辟支佛善根亦不系。不系法者。不名过去未来现在。若菩萨摩诃萨行般若波罗蜜时。如是知色不系三界。不系法者。不名过去未来现在。若法过去未来现在者。不可以取相有所得法回向阿耨多罗三藐三菩提。何以故。是色无生。若法无生则无法。无法中不可回向。受想行识亦如是。檀那波罗蜜乃至般若波罗蜜。四念处乃至无错谬法常舍行不系三界。不系法者。亦非过去未来现在。若非过去未来现在法者。不可以取相有所得法回向阿耨多罗三藐三菩提。何以故。是法无生。若无生则无法。无法中不可回向。菩萨摩诃萨如是回向则无杂毒。若求佛道善男子善女人。以取相得法。以诸善根回向阿耨多罗三藐三菩提。是名邪回向。若邪回向诸佛所不称誉。用是邪回向不能具足檀那波罗蜜乃至般若波罗蜜。不能具足四念处乃至八圣道分。内空乃至无法有法空。佛十力乃至无错谬法常舍行。不能具足净佛国土成就众生。若不能净佛国土成就众生。则不能得阿耨多罗三藐三菩提。何以故。是回向杂毒故。复次菩萨摩诃萨行般若波罗蜜时。应作是念。如诸佛所知诸善根回向。是真回向。我亦应以是法相回向。是名正回向。尔时佛赞须菩提。善哉善哉。如汝所为为作佛事。为诸菩萨摩诃萨说所应回向法。以无相无得无出无垢无净。无法性自相空常自性空。如法性如实际故。须菩提。若三千大千国土中众生。皆行十善道四禅四无量心四无色定五神通。于须菩提意云何。是众生得福多不。甚多世尊。佛言。不如是善男子善女人于诸善根心不着。回向阿耨多罗三藐三菩提。须菩提。是善男子善女人福德。最上第一。最妙无上无与等。复次须菩提。若三千大千国土中众生皆得须陀洹乃至阿罗汉辟支佛。若有善男子善女人尽形寿供养恭敬尊重赞叹。衣服饮食卧具医药供给所须。于须菩提意云何。是善男子善女人。是因缘故得福德多不。甚多世尊。佛言。不如是善男子善女人于诸善根心不着。回向阿耨多罗三藐三菩提。最上第一。最妙无上无与等。复次须菩提。若三千大千国土中众生皆发阿耨多罗三藐三菩提心。十方如恒河沙等国土中一一众生。如恒河沙等劫。恭敬尊重赞叹供养是菩萨。衣服饮食卧具医药供给所须。于须菩提意云何。是善男子善女人是因缘故得福多不。甚多世尊。无量无边阿僧祇不可以譬喻为比世尊。若是福德有形者。十方如恒河沙等国土所不受。佛告须菩提。善哉善哉。如汝所言。虽尔不如善男子善女人于诸善根心不着。回向阿耨多罗三藐三菩提。最上第一。最妙无上无与等。是无著回向功德。比前功德百倍千倍百千万亿倍。乃至算数譬喻所不能及。何以故。是善男子善女人取相得法。行十善道四禅四无量心四无色定五神通。取相得法供养须陀洹。恭敬尊重赞叹。衣服饮食卧具医药供给所须。乃至取相供养菩萨故。尔时四天王天与二万诸天。合掌礼佛作是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提。如是回向不堕二法。尔时释提桓因。亦与无数百千亿三十三天及余诸天子。持天华璎珞捣香泽香天衣幡盖鼓天伎乐以供养佛。如是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提。如是回向不堕二法。须夜摩天王与千天子。删兜率陀化乐他化自在诸天王。各与千天子俱。供养佛已。作如是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提。如是回向不堕二法。尔时诸梵天。与无数百千亿那由他诸天俱。诣佛所头面礼佛足。发大音声如是言。未曾有也。世尊。菩萨摩诃萨为般若波罗蜜所护以方便力故。胜前善男子善女人取相有所得者。光音天乃至阿迦尼吒天。与无数百千亿那由他诸天俱。诣佛所头面礼足。发大音声如是言。未曾有也。世尊。菩萨摩诃萨为般若波罗蜜所护以方便力故。胜前善男子善女人取相有所得者。尔时佛告四天王天乃至阿迦尼吒诸天子。若三千大千世界中所有众生。皆发阿耨多罗三藐三菩提心。是一切菩萨念过去未来现在诸佛及声闻辟支佛诸善根。从初发意乃至法住。于其中间所有善根。并余一切众生所有善根。所谓布施持戒忍辱精进一心智慧。檀那波罗蜜乃至般若波罗蜜。戒众定众慧众解脱众解脱知见众。如是等诸余无量佛法一切和合随喜。随喜已回向阿耨多罗三藐三菩提。以取相有所得故。复有善男子善女人发阿耨多罗三藐三菩提心。念过去未来现在诸佛及声闻辟支佛。从初发意乃至法住。于其中间所有善根。并余一切众生所有善根。所谓布施持戒忍辱精进一心智慧。檀那波罗蜜乃至无量诸佛法。一切和合称量。以无所得故。无二法故。无有相法故。不着法故。无觉法故。是最上随喜。第一最妙无上无与等随喜。随喜已回向阿耨多罗三藐三菩提。是善男子善女人功德。胜前善男子善女人功德百倍千倍百千万亿倍。乃至算数譬喻所不能及。尔时须菩提白佛言。世尊。世尊说善男子善女人和合诸善根称量随喜回向最上第一最妙无上无与等。世尊。云何名随喜最上。乃至无与等。佛言。若善男子善女人于过去未来现在诸法。不取不舍不念非不念不得非不得。是诸法中亦无有法生者灭者若垢若净。诸法不增不减不来不去。不合不散不入不出。如过去未来现在诸法相。如如相法性法住法位。我亦如是随喜。随喜已回向阿耨多罗三藐三菩提。如是回向最上第一。最妙无上无与等。须菩提。是随喜法比余随喜。百倍千倍百千万亿倍。乃至算数譬喻所不能及。复次须菩提。求佛道善男子善女人。于过去未来现在诸佛及声闻辟支佛。从初发心乃至法住于其中间所有善根。若布施乃至智慧。檀那波罗蜜乃至无量诸佛法。及余一切众生所有善根。若欲随喜者应如是随喜。作是念布施与解脱等。戒忍精进禅智与解脱等。色与解脱等。受想行识亦与解脱等。内空与解脱等。乃至无法有法空亦与解脱等。四念处与解脱等。乃至八圣道分亦与解脱等。佛十力与解脱等。乃至一切种智亦与解脱等。戒众定众慧众解脱众解脱知见众亦与解脱等。随喜与解脱等。过去未来现在诸法与解脱等。十方诸佛与解脱等。诸佛回向与解脱等。诸佛与解脱等。诸佛灭度与解脱等。诸佛弟子声闻辟支佛与解脱等。诸佛弟子灭度与解脱等。诸佛法相与解脱等。诸声闻辟支佛法相与解脱等。一切诸法相亦与解脱等。我以是诸善根相随喜功德。回向阿耨多罗三藐三菩提。亦与解脱等。不生不灭故须菩提。是名诸菩萨摩诃萨随喜功德最上第一最妙无上无与等。须菩提。菩萨成就是随喜功德。当疾得阿耨多罗三藐三菩提。复次须菩提。十方如恒河沙等现在诸佛及诸弟子。现在若有求佛道善男子善女人尽形寿供养是诸佛及弟子一切所须。供养恭敬尊重赞叹。衣服饮食卧具医药。是诸佛灭度后昼夜勤修。供养恭敬尊重赞叹华香乃至幡盖伎乐。以取相有所得故。持戒忍辱精进禅定修智慧。以取相有所得故。复有善男子善女人发意求阿耨多罗三藐三菩提。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。以不取相无所得法方便力诸善根。回向阿耨多罗三藐三菩提。是福德最上第一最妙无上无与等。胜前福德百倍千倍百千万倍。乃至算数譬喻所不能及。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜时。以方便力故诸善根应回向阿耨多罗三藐三菩提。以不取相无所得法故

    摩诃般若波罗蜜经照明品第四十(丹本名大度品)

尔时慧命舍利弗白佛言。世尊。是般若波罗蜜。佛言。是般若波罗蜜。世尊。般若波罗蜜能照一切法。毕竟净故。世尊。应礼般若波罗蜜。世尊。般若波罗蜜不着三界。世尊。般若波罗蜜除诸闇冥。一切烦恼诸见除故。世尊。般若波罗蜜一切助道法中最上。世尊。般若波罗蜜安隐。能断一切怖畏苦恼故。世尊。般若波罗蜜能与光明。五眼庄严故。世尊。般若波罗蜜能示导堕邪道众生。离二边故。世尊。般若波罗蜜是一切种智。一切烦恼及习断故。世尊。般若波罗蜜是诸菩萨摩诃萨母。能生诸佛法故。世尊。般若波罗蜜不生不灭。自相空故。世尊。般若波罗蜜远离生死。非常非灭故。世尊。般若波罗蜜无救者作护。施一切珍宝故。世尊。般若波罗蜜具足力。无能破坏故。世尊。般若波罗蜜能转三转十二行法轮。一切诸法不转不还故。世尊。般若波罗蜜能示诸法性。无法有法空故。世尊。应云何供养般若波罗蜜。佛言。当如供养世尊。礼般若波罗蜜当如礼世尊。何以故。世尊不异般若波罗蜜。般若波罗蜜不异世尊。世尊即是般若波罗蜜。般若波罗蜜即是世尊。是般若波罗蜜中。出生诸佛菩萨辟支佛阿罗汉阿那含斯陀含须陀洹。般若波罗蜜中生十善道四禅四无量心四无色定五神通。内空乃至无法有法空。四念处乃至八圣道分。是般若波罗蜜中生佛十力十八不共法。大慈大悲一切种智。尔时释提桓因心念。何因缘故。舍利弗问是事。念已语舍利弗。何因缘故问是事。舍利弗语释提桓因言。憍尸迦。诸菩萨摩诃萨。为般若波罗蜜守护。以沤和拘舍罗力故。于过去未来现在诸佛。从初发心乃至法住。于其中间所作善根一切和合随喜。回向阿耨多罗三藐三菩提。以是因缘故我问是事。憍尸迦。菩萨摩诃萨般若波罗蜜。胜檀那波罗蜜尸罗羼提毗梨耶禅那波罗蜜。譬如生盲人若百若千若百千。而无前导不能趣道入城。憍尸迦。五波罗蜜亦如是。离般若波罗蜜如盲无导不能趣道。不能得一切智。憍尸迦。若五波罗蜜得般若波罗蜜将导。是时五波罗蜜名为有眼。般若波罗蜜将导得波罗蜜名字。释提桓因语舍利弗。如所言。般若波罗蜜将导五波罗蜜故。得波罗蜜名字。舍利弗。若无檀那波罗蜜助五波罗蜜。不得波罗蜜名字。若无尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。五波罗蜜不得波罗蜜名字。若尔者何以故。独赞般若波罗蜜。舍利弗言。如是如是。憍尸迦。无檀那波罗蜜。五波罗蜜不得波罗蜜名字。无尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜五波罗蜜不得波罗蜜名字。但菩萨摩诃萨住般若波罗蜜中。能具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。以是故。憍尸迦。般若波罗蜜。于五波罗蜜中最上第一。最妙无上无与等。舍利弗白佛言。世尊。云何应生般若波罗蜜。佛告舍利弗。色不生故般若波罗蜜生。受想行识不生故般若波罗蜜生。檀那波罗蜜不生故般若波罗蜜生。乃至禅那波罗蜜不生故般若波罗蜜生。内空乃至无法有法空。四念处乃至八圣道分。佛十力乃至一切智。一切种智不生故。般若波罗蜜生。如是诸法不生故般若波罗蜜应生。舍利弗言。世尊。云何色不生故般若波罗蜜生。乃至一切诸法不生故般若波罗蜜应生。佛言。色不起不生不得不失故。乃至一切诸法不起不生不得不失故。般若波罗蜜生。舍利弗白佛言。如是生般若波罗蜜。与何等法合。佛言。无所与合。以是故。得名般若波罗蜜。世尊。不与何等法合。佛言。不与不善法合。不与善法合。不与世间法合。不与出世间法合。不与有漏法合。不与无漏法合。不与有罪法合。不与无罪法合。不与有为法合。不与无为法合。何以故。般若波罗蜜不为得法故生。以是故于诸法无所合。尔时释提桓因白佛言。世尊。是般若波罗蜜亦不合萨婆若。佛言。如是憍尸迦。般若波罗蜜亦不合萨婆若亦不得故。释提桓因言。世尊。云何般若波罗蜜亦不合萨婆若亦不得。佛言。般若波罗蜜不如名字不如相。不如起作法合。释提桓因言。今云何合。佛言。若菩萨摩诃萨如不取不受不住不着不断。如是合亦无所合。如是憍尸迦。般若波罗蜜一切法合亦无所合。尔时释提桓因白佛言。未曾有也。世尊。是般若波罗蜜力。为一切法不起不生不得不失故生。须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜时。作是念。般若波罗蜜若一切法合若不合。是菩萨摩诃萨则舍般若波罗蜜。远离般若波罗蜜。佛告须菩提。复有因缘。菩萨摩诃萨舍般若波罗蜜。远离般若波罗蜜。若菩萨摩诃萨作是念。是般若波罗蜜无所有。空虚不坚固。是菩萨摩诃萨则舍般若波罗蜜。远离般若波罗蜜。须菩提。以是因缘故。舍离般若波罗蜜。须菩提白佛言。世尊。信般若波罗蜜。为不信何法。佛告须菩提。信般若波罗蜜。则不信色不信受想行识。不信眼乃至意。不信色乃至法。不信眼识界乃至意识界。不信檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。不信内空乃至无法有法空。不信四念处乃至八圣道分。不信佛十力乃至十八不共法。不信须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。不信菩萨道。不信阿耨多罗三藐三菩提乃至一切种智。须菩提白佛言。世尊。云何信般若波罗蜜时不信色乃至一切种智。佛告须菩提。色不可得故。信般若波罗蜜不信色。乃至一切种智不可得故。信般若波罗蜜不信一切种智。以是故。须菩提。信般若波罗蜜时。不信色乃至不信一切种智。须菩提白佛言。世尊。是般若波罗蜜。名为摩诃波罗蜜。须菩提。何因缘故。是般若波罗蜜。名为摩诃波罗蜜。须菩提言。世尊。是般若波罗蜜不作色大不作色小。受想行识不作大不作小。眼乃至意。色乃至法。眼识界乃至意识界。不作大不作小。檀那波罗蜜乃至禅那波罗蜜。不作大不作小。内空乃至无法有法空。不作大不作小。四念处乃至阿耨多罗三藐三菩提。不作大不作小。诸佛法不作大不作小。诸佛不作大不作小。是般若波罗蜜不作色合不作色散。受想行识不作合不作散。乃至诸佛不作合不作散。不作色无量。不作色非无量。乃至诸佛不作无量。不作非无量。不作色广不作色狭。乃至诸佛不作广不作狭。不作色有力。不作色无力。乃至诸佛不作有力不作无力。世尊。以是因缘故。是般若波罗蜜名摩诃波罗蜜。世尊。若新发意菩萨摩诃萨。若不远离般若波罗蜜。不远离禅那波罗蜜。不远离毗梨耶波罗蜜。不远离羼提波罗蜜。不远离尸罗波罗蜜。不远离檀那波罗蜜。如是念是般若波罗蜜。不作色大不作色小。乃至诸佛不作大不作小。不作色合不作色散。不作色无量。不作色非无量。不作色有力。不作色无力。乃至诸佛不作有力不作无力。世尊。菩萨摩诃萨若如是知。是为不行般若波罗蜜。何以故。是非般若波罗蜜相。所谓作色大小。乃至诸佛作大小。色有力无力。乃至诸佛有力无力。世尊。是菩萨摩诃萨。用有所得故有大过失。所谓行般若波罗蜜时。作色大作色小。乃至诸佛作有力作无力。何以故。有所得相者无阿耨多罗三藐三菩提。所以者何。众生不生故般若波罗蜜不生。色不生故般若波罗蜜不生。乃至佛不生故般若波罗蜜不生。众生性无故般若波罗蜜性无。色性无故般若波罗蜜性无。乃至佛性无故般若波罗蜜性无。众生非法故般若波罗蜜非法。色非法故般若波罗蜜非法。乃至佛非法故般若波罗蜜非法。众生空故般若波罗蜜空。色空故般若波罗蜜空。乃至佛空故般若波罗蜜空。众生离故般若波罗蜜离。色离故般若波罗蜜离。乃至佛离故般若波罗蜜离。众生无有故般若波罗蜜无有。色无有故般若波罗蜜无有。乃至佛无有故般若波罗蜜无有。众生不可思议故般若波罗蜜不可思议。色不可思议故般若波罗蜜不可思议。乃至佛不可思议故般若波罗蜜不可思议。众生不灭故般若波罗蜜不灭。色不灭故般若波罗蜜不灭。乃至佛不灭故般若波罗蜜不灭。众生不可知故般若波罗蜜不可知。色不可知故般若波罗蜜不可知。乃至佛不可知故般若波罗蜜不可知。众生力不成就故般若波罗蜜力不成就。色力不成就故般若波罗蜜力不成就。乃至佛力不成就故。般若波罗蜜力不成就。世尊。以是因缘故。诸菩萨摩诃萨般若波罗蜜。名为摩诃波罗蜜

    摩诃般若波罗蜜经信毁品第四十一(丹泥梨品)

尔时慧命舍利弗白佛言。世尊。有菩萨摩诃萨信解是般若波罗蜜者。从何处终来生是间。发阿耨多罗三藐三菩提心。来为几时为供养几佛。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。供养几佛来为几时能随顺解深般若波罗蜜义

佛告舍利弗。是菩萨摩诃萨供养十方诸佛来生是间。是菩萨发阿耨多罗三藐三菩提心来。无量无边阿僧祇百千万亿劫。是菩萨摩诃萨从初发心。常行六波罗蜜。供养无量无边不可思议阿僧祇诸佛。来生是间。舍利弗。是菩萨摩诃萨若见若闻般若波罗蜜。作是念。我见佛从佛闻法。舍利弗。是菩萨摩诃萨能随顺解深般若波罗蜜义。以无相无二无所得故。须菩提白佛言。世尊。是般若波罗蜜可闻可见耶。佛告须菩提。是般若波罗蜜无有闻者无有见者。般若波罗蜜无闻无见诸法钝故。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。无闻无见诸法钝故内空无闻无见诸法钝故。乃至无法有法空无闻无见诸法钝故。四念处无闻无见诸法钝故乃至八圣道分无闻无见诸法钝故。佛十力乃至十八不共法无闻无见诸法钝故。须菩提。佛及佛道无闻无见诸法钝故。须菩提白佛言。世尊。是菩萨几时行佛道。能习行如是深般若波罗蜜。佛告须菩提。是中应分别说。须菩提。有菩萨摩诃萨初发意习行深般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。以方便力故于法无所破坏。不见诸法无利益者。亦终不远离行六波罗蜜。亦不远离诸佛。从一佛国至一佛国。若欲以善根力供养诸佛随意即得。终不生母人腹中。终不离诸神通。终不生诸烦恼。及声闻辟支佛心。从一佛国至一佛国。成就众生净佛国土。须菩提。如是等诸菩萨摩诃萨能习行深般若波罗蜜。须菩提。有菩萨摩诃萨多见诸佛若无量百千万亿。从诸佛所行布施持戒忍辱精进一心智慧。皆以有所得故。是菩萨闻说深般若波罗蜜时。便从众中起去。不恭敬深般若波罗蜜及诸佛。是菩萨今在此众中坐。闻是甚深般若波罗蜜。不乐故便舍去。何以故。是善男子善女人等。先世闻深般若波罗蜜时弃舍去。今世闻深般若波罗蜜亦弃舍去。身心不和是人种愚痴因缘业种是愚痴因缘罪故。闻说深般若波罗蜜呰毁。呰毁深般若波罗蜜故。则为呰毁过去未来现在诸佛一切智一切种智。是人毁呰三世诸佛一切智故起破法业。破法业因缘集故。无量百千万亿岁堕大地狱中。是破法人辈从一大地狱至一大地狱。若火劫起时。至他方大地狱中生在彼间。从一大地狱至一大地狱。彼间若火劫起时。复至他方大地狱中生在彼间。从一大地狱至一大地狱。如是遍十方。彼间若火劫起故从彼死。破法业因缘未尽故。还来是间大地狱中生此间。亦从一大地狱至一大地狱受无量苦。此间火劫起时。复生十方他国土。生畜生中。受破法罪业苦。如地狱中说。重罪转薄或得人身。生盲人家生旃陀罗家。生除厕担死人种种下贱家。若无眼若一眼若眼瞎。无舌无耳无手。所生处无佛无法无佛弟子处。何以故。种破法业积集厚重具足故受是果报。尔时舍利弗白佛言。世尊。五逆罪与破法罪相似耶。佛告舍利弗。不应言相似。所以者何。若有人听说是甚深般若波罗蜜时。毁呰不信般若波罗蜜作是言。不应学是法。是非法非善非佛教。诸佛不说是语。是人自呰毁般若波罗蜜。亦教他人毁呰般若波罗蜜。自坏其身亦坏他人身。自饮毒杀身亦饮他人毒。自失身亦失他人身。自不知不信毁呰深般若波罗蜜。亦教他人令不信不知。舍利弗。如是人我不听闻其名字。何况眼见共住。何以故。当知是人名为污法人。为堕衰浊黑性。如是人若有听其言信用其语。亦受如是苦。舍利弗。若人破般若波罗蜜。当知是名为坏法人。舍利弗白佛言。世尊。世尊说坏法之人所受重罪。不说是人所受身体大小。佛告舍利弗。不须说是人受身大小。何以故。是坏法人若闻自所受身体大小。便当吐热血若死若近死苦。是破法人闻如是身有如是重罪。是人便大愁毒。如箭入心渐渐干枯。作是念。破法罪故得如是大丑身。受如是无量苦。以是故。佛不听舍利弗问是人所受身体大小。舍利弗白佛言。愿佛说之。为未来世作明。令知破法业积集故。得如是大丑身受如是苦。佛告舍利弗。后世人若闻是破法业积集厚重具足。受大地狱中久久无量苦。闻是久久无量时苦。足为未来世作明诫。舍利弗白佛言。世尊。若白净性善男子善女人。闻是法足作依止。宁失身命不坏法。自念我若破法当受如是苦。尔时须菩提白佛言。世尊。善男子善女人。应好摄身口意业。无受如是诸苦。或不见佛或不闻法或不亲近僧。或生无佛国土中。或生人中堕贫穷家。或人不信受其言。须菩提白佛言。世尊。以积集口业故。有如是破法重罪耶。佛告须菩提。以积集口业故有是破法重罪。须菩提。是愚痴人在佛法中出家受戒。破深般若波罗蜜毁呰不受。须菩提。若破般若波罗蜜。毁呰般若波罗蜜。则为破十方诸佛一切智。一切智破故。则为破佛宝。破佛宝故破法宝。破法宝故破僧宝。破三宝故。则破世间正见。破世间正见故。则破四念处。乃至破一切种智法。破一切种智法故。则得无量无边阿僧祇罪。得无量无边阿僧祇罪已。则受无量无边阿僧祇忧苦。须菩提白佛言。世尊。是愚痴人毁呰破坏是深般若波罗蜜。有几因缘。佛告须菩提。有四因缘。是愚痴人毁呰破是深般若波罗蜜。须菩提言。世尊。何等四。佛言。是愚痴人为魔所使故。欲毁呰破坏深般若波罗蜜。是名初因缘。是愚痴人不信深法不信不解心不得清净。是第二因缘故。是愚痴人欲毁呰破坏深般若波罗蜜。是愚痴人与恶知识相随心没懈怠。坚着五受阴。是第三因缘故。是愚痴人欲毁呰破坏深般若波罗蜜。是愚痴人多行嗔恚自高轻人。是第四因缘故。是愚痴人欲毁呰破坏深般若波罗蜜。须菩提。以是四因缘故。愚痴人欲破坏深般若波罗蜜。须菩提白佛言。世尊。是般若波罗蜜。不勤精进种不善根恶友相得。此人难信难解。佛言。如是如是。须菩提。深般若波罗蜜不勤精进种不善根恶友相得。此人难信难解。须菩提白佛言。世尊。是般若波罗蜜。云何甚深难信难解。须菩提。色不缚不解。何以故。无所有性是色。受想行识不缚不解。何以故。无所有性是受想行识。檀那波罗蜜。不缚不解。何以故。无所有性是檀那波罗蜜。尸罗波罗蜜不缚不解。何以故。无所有性是尸罗波罗蜜。羼提波罗蜜不缚不解。何以故。无所有性是羼提波罗蜜。毗梨耶波罗蜜不缚不解。何以故。无所有性是毗梨耶波罗蜜。禅那波罗蜜不缚不解。何以故。无所有性是禅那波罗蜜般若波罗蜜不缚不解。何以故。无所有性是般若波罗蜜。须菩提。内空不缚不解。何以故。无所有性是内空。乃至无法有法空不缚不解。何以故。无所有性是无法有法空。四念处不缚不解。何以故。无所有性是四念处。乃至一切智一切种智不缚不解。何以故。无所有性是一切智一切种智。须菩提。色本际不缚不解。何以故。色本际无所有性是色。受想行识乃至一切种智本际不缚不解。何以故。本际无所有性是一切种智。须菩提。色后际不缚不解。何以故。后际无所有性是色。受想行识乃至一切种智后际不缚不解。何以故。后际无所有性是一切种智。须菩提。现在色不缚不解。何以故。现在色无所有性是色。受想行识乃至现在一切种智不缚不解。何以故。现在无所有性是一切种智。须菩提白佛言。世尊。是般若波罗蜜不勤精进。不种善根恶友相得。懈怠少进喜忘无巧便慧。如此之人实难信难解。佛言。如是如是。须菩提。是般若波罗蜜不勤精进。不种善根恶友相得系属于魔。懈怠少进喜忘无巧便慧。如此之人实难信难解。何以故。色净果亦净。受想行识净果亦净。乃至阿耨多罗三藐三菩提净果亦净。复次须菩提。色净故即般若波罗蜜净。般若波罗蜜净即色净。受想行识净故即般若波罗蜜净。般若波罗蜜净即受想行识净。乃至一切种智净即般若波罗蜜净。般若波罗蜜净即一切种智净。色净般若波罗蜜净。无二无别无断无坏。乃至一切种智净般若波罗蜜净。无二无别无断无坏。复次须菩提。不二净故色净。不二净故乃至一切种智净。何以故。是不二净色净。乃至一切种智净。无二无别故。我净众生净。乃至知者见者净故。色净受想行识净。乃至一切种智净。色净乃至一切种智净故。我净众生乃至知者见者净。何以故。是我众生乃至知者见者净。色净乃至一切种智净。不二不别无断无坏。复次须菩提。淫净故色净。乃至一切种智净。何以故。淫净色净乃至一切种智净不二不别。嗔痴净故色净。乃至一切种智净。何以故。嗔痴净色净乃至一切种智净。不二不别。复次须菩提。无明净故诸行净。诸行净故识净。识净故名色净。名色净故六入净。六入净故触净。触净故受净。受净故爱净。爱净故取净。取净故有净。有净故生净。生净故老死净。老死净故般若波罗蜜净。般若波罗蜜净故。乃至檀那波罗蜜净。檀那波罗蜜净故内空净。内空净故乃至无法有法空净。无法有法空净故四念处净。四念处净故乃至一切智净。一切智净故一切种智净。何以故。是一切智净一切种智净。不二不别无断无坏。复次须菩提。般若波罗蜜净故色净。乃至般若波罗蜜净故一切智净。是般若波罗蜜净一切智净。不二不别故。须菩提。禅那波罗蜜净故乃至一切智净。毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜净故。乃至一切智净。内空净故乃至一切智净。四念处净故乃至一切智净。复次须菩提。一切智净故乃至般若波罗蜜净。如是一一如先说。复次须菩提有为净故无为净。何以故。有为净无为净。不二不别不断不坏故。复次须菩提。过去净故未来现在净。未来净故过去现在净。现在净故过去未来净。何以故。现在净过去未来净。不二不别不断不坏故

摩诃般若波罗蜜经卷第十一摩诃般若波罗蜜经卷第十二

        后秦龟兹国三藏鸠摩罗什译

    叹净品第四十二

尔时舍利弗白佛言。世尊。是净甚深。佛言。毕竟净故。舍利弗言。何法净故是净甚深。佛言。色净故是净甚深。受想行识净故。四念处净故。乃至八圣道分净故。佛十力净故。乃至十八不共法净故。菩萨净佛净故。一切智一切种智净故。是净甚深。世尊。是净明。佛言。毕竟净故。舍利弗言。何法净故是净明。佛言。般若波罗蜜净故是净明。乃至檀那波罗蜜净故是净明。四念处乃至一切智净故是净明。世尊。是净不相续。佛言。毕竟净故。舍利弗言。何法不相续故是净不相续。佛言。色不去不相续。故是净不相续。乃至一切种智不去不相续故。是净不相续。世尊。是净无垢。佛言。毕竟净故。舍利弗言。何法无垢故是净无垢。佛言。色性常净故是净无垢。乃至一切种智性常净故是净无垢。世尊。是净无得无著。佛言。毕竟净故。舍利弗言。何法无得无著故是净无得无著。佛言。色无得无著故。是净无得无著。乃至一切种智无得无著故。是净无得无著。世尊。是净无生。佛言。毕竟净故。舍利弗言。何法无生故是净无生。佛言。色无生故是净无生。乃至一切种智无生故是净无生。世尊。是净不生欲界中。佛言。毕竟净故。舍利弗言。云何是净不生欲界中。佛言。欲界性不可得故。是净不生欲界中。世尊。是净不生色界中。佛言。毕竟净故。舍利弗言。云何是净不生色界中。佛言。色界性不可得故。是净不生色界中。世尊。是净不生无色界中。佛言。毕竟净故。舍利弗言。云何是净不生无色界中。佛言。无色界性不可得故。是净不生无色界中。世尊。是净无知。佛言。毕竟净故。舍利弗言。云何是净无知。佛言。诸法钝故是净无知。世尊。色无知是净净。佛言。毕竟净故。舍利弗言。云何色无知是净净。佛言。色自性空故。色无知是净净。世尊。受想行识无知是净净。佛言。毕竟净故。舍利弗言。云何受想行识无知是净净。佛言。受想行识自性空故无知是净净。世尊。一切法净故是净净。佛言。毕竟净故。舍利弗言。云何一切法净故是净净。佛言。一切法不可得故一切法净是净净。世尊。是般若波罗蜜于萨婆若无益无损。佛言。毕竟净故。舍利弗言。云何般若波罗蜜于萨婆若无益无损。佛言。法常住相故。般若波罗蜜于萨婆若无益无损。世尊。是般若波罗蜜净于诸法无所受。佛言。毕竟净故。舍利弗言。云何般若波罗蜜净于诸法无所受。佛言。法性不动故。是般若波罗蜜净于诸法无所受。尔时慧命须菩提白佛言。世尊。我净故色净。佛言。毕竟净故。须菩提言。以何因缘。我净故色净毕竟净。佛言。我无所有故。色无所有毕竟净。世尊。我净故受想行识净。佛言。毕竟净故。须菩提言。何因缘故。我净受想行识净毕竟净。佛言。我无所有故。受想行识无所有毕竟净。世尊。我净故檀那波罗蜜净。我净故尸罗波罗蜜净。我净故羼提波罗蜜净。我净故毗梨耶波罗蜜净。我净故禅那波罗蜜净。世尊。我净故般若波罗蜜净。世尊。我净故四念处净。世尊。我净故乃至八圣道分净。世尊。我净故佛十力净。世尊。我净故乃至十八不共法净。佛言。毕竟净故。须菩提言。何因缘故。我净檀那波罗蜜净。我净乃至十八不共法净。佛言。我无所有故。檀那波罗蜜无所有故净。乃至十八不共法无所有故净。世尊。我净故须陀洹果净。我净故斯陀含果净。我净故阿那含果净。我净故阿罗汉果净。我净故辟支佛道净。我净故佛道净。佛言。毕竟净。须菩提言。何因缘故。我净须陀洹果净。斯陀含果净。阿那含果净。阿罗汉果净。辟支佛道净。佛道净。佛言。自相空故。世尊。我净故一切智净。佛言。毕竟净故。须菩提言。何因缘故。我净故一切智净。佛言。无相无念故。世尊。以二净故无得无著。佛言。毕竟净。须菩提言。何因缘故。以二净故无得无著是毕竟净。佛言。无垢无净故。世尊。我无边故色净受想行识净。佛言。毕竟净。须菩提言。何因缘故。我无边故色净受想行识净。佛言。毕竟空无始空故。须菩提白佛言。世尊。若菩萨摩诃萨能如是知。是名菩萨摩诃萨般若波罗蜜。佛言。毕竟净故。须菩提言。何因缘故。菩萨摩诃萨能如是知。是名菩萨摩诃萨般若波罗蜜。佛言。知道种故

世尊。若菩萨摩诃萨行般若波罗蜜。以方便力故作是念。色不知色。受想行识不知识。过去法不知过去法。未来法不知未来法。现在法不知现在法。佛言。菩萨摩诃萨行般若波罗蜜。以方便力故不作是念。我施与彼人。我持戒如是持戒。我修忍如是修忍。我精进如是精进。我入禅如是入禅。我修智慧如是修智慧。我得福德如是得福德。我当入菩萨法位中。我当净佛国土成就众生。我当得一切种智。须菩提。是菩萨摩诃萨行般若波罗蜜。以方便力故无诸忆想分别。内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空诸法空自相空故。须菩提。是名菩萨摩诃萨行般若波罗蜜。以方便力故无所碍。尔时释提桓因问须菩提。云何是求菩萨道善男子碍法。须菩提报释提桓因言憍尸迦。有求菩萨道善男子善女人取心相。所谓取檀那波罗蜜相。取尸罗波罗蜜相羼提波罗蜜相毗梨耶波罗蜜相禅那波罗蜜相般若波罗蜜相。取内空相外空内外空乃至无法有法空相。取四念处相乃至八圣道分相。取佛十力相乃至十八不共法相。取诸佛相。取于诸佛种善根相。是一切福德和合取相。回向阿耨多罗三藐三菩提。憍尸迦。是名求菩萨道善男子善女人碍法。用是法故。不能无碍行般若波罗蜜。何以故。憍尸迦。是色相不可回向。受想行识相不可回向。乃至一切种智相不可回向。复次憍尸迦。若菩萨摩诃萨示教利喜他人阿耨多罗三藐三菩提。应示教利喜一切诸法实相。若求菩萨道善男子善女人。行檀那波罗蜜时。不应作是分别言。我施与我持戒我忍辱我精进我入禅定我修智慧。我行内空外空内外空。乃至我行无法有法空。我修四念处。乃至我行阿耨多罗三藐三菩提。善男子善女人应如是示教利喜他人阿耨多罗三藐三菩提。若如是示教利喜阿耨多罗三藐三菩提。自无错谬。亦如佛所说法示教利喜。令是善男子善女人远离一切碍法。尔时佛赞须菩提。善哉善哉。如汝为诸菩萨说诸碍法。须菩提。汝今更听我说微细碍相。须菩提。汝一心好听。佛告须菩提。有善男子善女人发阿耨多罗三藐三菩提心取相念诸佛。须菩提。所可有相皆是碍相。又于诸佛从初发意乃至法住。于其中间所有善根取相忆念。取相忆念已回向阿耨多罗三藐三菩提。须菩提。所可有相皆是碍相。又于诸佛及弟子所有善根及余众生善根。取相回向阿耨多罗三藐三菩提。须菩提。所可有相皆是碍相。何以故。不应取相忆念诸佛。亦不应取相忆念诸佛善根。须菩提白佛言。世尊。是般若波罗蜜甚深。佛言。一切法常离故。须菩提言。世尊。我当礼般若波罗蜜。佛告须菩提。是般若波罗蜜无起无作故。无有能得者。须菩提言。世尊。一切诸法亦不可知不可得。佛言。一切法一性非二性。须菩提。是一法性是亦无性。是无性即是性。是性不起不灭。如是须菩提。菩萨摩诃萨若知诸法一性。所谓无性无起无作。则远离一切碍相。须菩提白佛言。世尊。是般若波罗蜜难知难解。佛言。如所言。是般若波罗蜜无见者无闻者无知者无识者无得者。世尊。是般若波罗蜜不可思议。佛言。如所言。是般若波罗蜜不从心生。不从色受想行识生。乃至不从十八不共法生

    摩诃般若波罗蜜经无作品第四十三(丹面各千佛品)

须菩提白佛言。是般若波罗蜜无所作。佛言。作者不可得故色不可得。乃至一切法不可得故。世尊。若菩萨摩诃萨欲行般若波罗蜜。应云何行。佛告须菩提。菩萨摩诃萨欲行般若波罗蜜。不行色是行般若波罗蜜。不行受想行识。是行般若波罗蜜。乃至不行一切种智。是行般若波罗蜜。不行色常无常。是行般若波罗蜜。乃至一切种智不行常无常。是行般若波罗蜜。不行色若苦若乐。是行般若波罗蜜。乃至不行一切种智若苦若乐。是行般若波罗蜜。不行色是我非我。是行般若波罗蜜。乃至不行一切种智是我非我。是行般若波罗蜜。不行色净不净。是行般若波罗蜜。乃至不行一切种智净不净。是行般若波罗蜜。何以故。是色无所有性。云何有常无常苦乐我无我净不净。受想行识亦无所有性。云何有常无常乃至净不净。乃至一切种智无所有性。云何有常无常乃至净不净。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不行色不具足。是行般若波罗蜜。不行受想行识不具足。是行般若波罗蜜。乃至不行一切种智不具足。是行般若波罗蜜。何以故。色不具足者是不名色。如是亦不行为行般若波罗蜜。受想行识不具足者。是不名识。如是亦不行为行般若波罗蜜。乃至不行一切种智不具足者。是不名一切种智。如是亦不行为行般若波罗蜜。须菩提白佛言。未曾有也世尊。善说求菩萨道善男子善女人碍不碍相。佛言。如是如是。须菩提。佛善说求菩萨道。善男子善女人碍不碍相。复次须菩提。若菩萨摩诃萨行般若波罗蜜时。不行色不碍是行般若波罗蜜。不行受想行识不碍是行般若波罗蜜。不行眼不碍是行般若波罗蜜。不行耳鼻舌身不碍是行般若波罗蜜。不行意不碍是行般若波罗蜜。不行檀那波罗蜜不碍是行般若波罗蜜。不行尸罗波罗蜜不碍是行般若波罗蜜。不行羼提波罗蜜不碍是行般若波罗蜜。不行毗梨耶波罗蜜不碍是行般若波罗蜜。不行禅那波罗蜜不碍是行般若波罗蜜。不行般若波罗蜜不碍是行般若波罗蜜。乃至不行一切种智不碍是行般若波罗蜜。须菩提。菩萨摩诃萨如是行般若波罗蜜时。知色是不碍。知受想行识是不碍。乃至知一切种智是不碍。知须陀洹果不碍。知斯陀含果不碍。知阿那含果不碍。知阿罗汉果不碍。知辟支佛道不碍。知阿耨多罗三藐三菩提道不碍。尔时慧命须菩提白佛言。未曾有也世尊。是甚深法若说亦不增不减。若不说亦不增不减。佛语须菩提。如是如是。是甚深法若说亦不增不减。若不说亦不增不减。譬如佛尽形寿若赞若毁虚空。赞时亦不增不减。毁时亦不增不减。须菩提。如幻人。若赞时不增不减。毁时亦不增不减。赞时不喜毁时不忧。须菩提。诸法法相亦如是。若说亦如本不异。若不说亦如本不异。须菩提白佛言世尊。诸菩萨摩诃萨所为甚难。修行是般若波罗蜜时。不忧不喜而能习般若波罗蜜。于阿耨多罗三藐三菩提亦不转还。何以故。世尊。修般若波罗蜜如修虚空。如虚空中无般若波罗蜜。无禅那无毗梨耶无羼提无尸罗无檀那波罗蜜。如虚空中无色无受想行识。亦无内空外空内外空乃至无法有法空。无四念处乃至无八圣道分。无佛十力乃至无十八不共法。无须陀洹果斯陀含果阿那含果阿罗汉果。无辟支佛道无阿耨多罗三藐三菩提。修般若波罗蜜亦如是。世尊。应礼是诸菩萨摩诃萨能大誓庄严。世尊。是人为众生大誓庄严勤精进如为虚空大誓庄严勤精进。世尊。是人欲度众生如欲度虚空。世尊。是诸菩萨摩诃萨大誓庄严。如为虚空等众生大誓庄严。世尊。是人大誓庄严。欲度众生为如举虚空。世尊。诸菩萨摩诃萨得大精进力。欲度众生故发阿耨多罗三藐三菩提心。世尊。诸菩萨摩诃萨大誓庄严。欲度众生故发阿耨多罗三藐三菩提心。世尊。诸菩萨摩诃萨大勇猛为度如虚空等众生故。发阿耨多罗三藐三菩提心。何以故。世尊。若三千大千世界满中诸佛。譬如竹苇甘蔗稻麻丛林诸佛。若一劫若减一劫常说法。一一佛度无量无边阿僧祇众生令入涅槃。世尊。是众生性亦不减亦不增。何以故。众生无所有故。众生离故。乃至十方世界中。诸佛所度众生亦如是。世尊。以是因缘故我如是说。是人欲度众生故发阿耨多罗三藐三菩提心。为欲度虚空。是时有一比丘。作是言。我礼般若波罗蜜。般若波罗蜜中虽无法生无法灭。而有戒众定众慧众解脱众解脱知见众。而有诸须陀洹诸斯陀含诸阿那含诸阿罗汉诸辟支佛有诸佛。而有佛宝法宝比丘僧宝而有转法轮。尔时释提桓因语须菩提。若菩萨摩诃萨习般若波罗蜜。为习何法。须菩提语释提桓因言。憍尸迦。是菩萨摩诃萨习般若波罗蜜。为习空法。释提桓因白佛言。世尊若善男子善女人受持是般若波罗蜜。亲近读诵说正忆念。我当作何等护。尔时须菩提语释提桓因言。憍尸迦。汝颇见是法可守护者不。释提桓因言。不也须菩提。我不见是法可守护者。须菩提言。憍尸迦。若善男子善女人。如般若波罗蜜中所说行即是守护。所谓常不远离如所说般若波罗蜜行。是善男子善女人。若人若非人不得其便。当知是善男子善女人。不远离般若波罗蜜。憍尸迦。若人欲护行般若波罗蜜菩萨。为欲护虚空。憍尸迦。于汝意云何。汝能护梦焰影响幻化不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨。亦如是但自疲苦。憍尸迦。于汝意云何。能护佛所化不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨亦如是。憍尸迦。于汝意云何。能护法性实际如不可思议性不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨亦如是。尔时释提桓因问须菩提。云何菩萨摩诃萨行般若波罗蜜。知见诸法如梦如焰如影如响如幻如化。诸菩萨摩诃萨如所知见故。不念梦不念是梦。不念用梦不念我梦。焰影响幻化亦如是。须菩提言。憍尸迦。若菩萨摩诃萨行般若波罗蜜。不念色不念是色。不念用色不念我色。是菩萨摩诃萨亦能不念梦不念是梦。不念用梦不念我梦。乃至化亦不念化不念是化。不念用化不念我化。受想行识亦如是。乃至一切智。不念一切智不念是一切智。不念用一切智不念我一切智。是菩萨摩诃萨亦能不念梦不念是梦。不念用梦不念我梦。乃至化亦如是。如是憍尸迦。菩萨摩诃萨知诸法如梦如焰如影如响如幻如化。尔时佛神力故。三千大千世界中诸四天王天三十三天夜摩天兜率陀天化乐天他化自在天梵身天梵辅天梵众天大梵天。少光天乃至净居天。是一切诸天以天栴檀华遥散佛上。来诣佛所头面礼佛足却住一面。尔时四天王天。释提桓因及三十三天。梵天王乃至诸净居天。佛神力故见东方千佛说法。亦如是相如是名字说是般若波罗蜜品。诸比丘皆字须菩提。问难般若波罗蜜品者。皆字释提桓因。南西北方四维上下亦如是各千佛现。尔时佛告须菩提。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。亦当于是处说般若波罗蜜。贤劫中诸菩萨摩诃萨得阿耨多罗三藐三菩提时。亦当于是处说般若波罗蜜。须菩提白佛言。世尊。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。用何相何因何义说是般若波罗蜜义。佛告须菩提。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。色非常非无常。当如是说法。色非苦非乐。色非我非无我。色非净非不净。当如是说法。色非缚非解。当如是说法。受想行识非常非无常。乃至非缚非解。当如是说法。色非过去色非未来色非现在。当如是说法。受想行识亦如是。色毕竟净。当如是说法。受想行识毕竟净。当如是说法。乃至一切智毕竟净。当如是说法。须菩提白佛言。世尊。是般若波罗蜜清净。佛言。色清净故般若波罗蜜清净。受想行识清净故般若波罗蜜清净。世尊。云何色清净故般若波罗蜜清净。云何受想行识清净故般若波罗蜜清净。佛言。若色不生不灭不垢不净。是名色清净。受想行识不生不灭不垢不净。是名受想行识清净。复次须菩提。虚空清净故般若波罗蜜清净。世尊。云何虚空清净故般若波罗蜜清净。佛言。虚空不生不灭故清净。般若波罗蜜亦如是复次须菩提。色不污故般若波罗蜜清净受想行识不污故般若波罗蜜清净。世尊。云何色不污故般若波罗蜜清净。受想行识不污故般若波罗蜜清净。佛言。如虚空不可污故虚空清净。世尊。云何如虚空不可污故虚空清净。佛言。虚空不可取故虚空清净。虚空清净故般若波罗蜜清净。复次须菩提。虚空可说故般若波罗蜜清净。世尊。云何虚空可说故般若波罗蜜清净。佛言。因虚空中二声出故。般若波罗蜜亦如虚空可说故清净。须菩提。虚空不可说故般若波罗蜜清净。世尊。云何虚空不可说故般若波罗蜜清净。佛言。如虚空无可说故般若波罗蜜清净。复次如虚空不可得故般若波罗蜜清净。世尊。云何如虚空不可得故般若波罗蜜清净。佛言。如虚空无所得相。般若波罗蜜亦如虚空无所得故清净。复次须菩提。一切法不生不灭不垢不净故般若波罗蜜清净。世尊。云何一切法不生不灭不垢不净故般若波罗蜜清净。佛言。一切法毕竟清净故般若波罗蜜清净。须菩提白佛言世尊。若善男子善女人受持是般若波罗蜜亲近正忆念者终不病眼。耳鼻舌身亦终不病。身无形残亦不衰老终不横死。无数百千万诸天。四天王天乃至净居诸天。皆悉随从听受。六斋日。月八日二十三日十四日二十九日十五日三十日。诸天众会。善男子善女人为法师者。在所说般若波罗蜜处皆悉来集。是善男子善女人在大众中说是般若波罗蜜。得无量无边阿僧祇不可思议不可称量福德。佛告须菩提。如是如是。是善男子善女人。若六斋日。月八日二十三日十四日二十九日十五日三十日。在诸天众前说是般若波罗蜜义。是善男子善女人得无量无边阿僧祇不可思议不可称量福德。何以故。须菩提。般若波罗蜜是大珍宝。何等是大珍宝。是般若波罗蜜能拔地狱畜生饿鬼及人中贪穷。能与刹利大姓婆罗门大姓居士大家。能与四天王天处乃至非有想非无想处。能与须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。何以故。是般若波罗蜜中广说十善道四禅四无量心四无色定四念处。乃至八圣道分檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。广说内空乃至无法有法空。广说佛十力乃至一切智。从是中学出生刹利大姓婆罗门大姓居士大家。出生四天王天三十三天夜摩天兜率陀天化乐天他化自在天。梵身天梵辅天梵众天大梵天。光天少光天无量光天光音天净天少净天无量净天遍净天。阿那婆迦天得福天广果天无想天。阿浮诃那天不热天快见天妙见天阿迦尼吒天。虚空无边处天。识无边处天。无所有处天。非有想非无想处天。是法中学得须陀洹果斯陀含果阿那含果阿罗汉果。得辟支佛道得阿耨多罗三藐三菩提。以是故。须菩提。般若波罗蜜名为大珍宝。珍宝波罗蜜中无有法可得。若生若灭若垢若净若取若舍。珍宝波罗蜜亦无有法若善若不善。若世间若出世间。若有漏若无漏。若有为若无为。以是故。须菩提是名无所得珍宝波罗蜜。须菩提。是珍宝波罗蜜无有法能染污。何以故。所用染法不可得故。须菩提。以是故。名无染珍宝波罗蜜须菩提。若菩萨摩诃萨行般若波罗蜜时。亦如是不知。亦如是不分别。亦如是不可得。亦如是不戏论。是为能修行般若波罗蜜。亦能礼觐诸佛从一佛国至一佛国。供养恭敬尊重赞叹诸佛。游诸佛刹成就众生净佛国土。须菩提。是般若波罗蜜于诸法无有力无非力。亦无受亦无与。不生不灭不垢不净不增不减。是般若波罗蜜亦非过去非未来非现在。不舍欲界不住欲界。不舍色界不住色界。不舍无色界不住无色界。是般若波罗蜜。不与檀那波罗蜜亦不舍。不与尸波罗蜜亦不舍。不与羼提波罗蜜亦不舍。不与毗梨耶波罗蜜亦不舍。不与禅那波罗蜜亦不舍。不与般若波罗蜜亦不舍。不与内空亦不舍。乃至不与无法有法空亦不舍。不与四念处亦不舍。乃至不与八圣道分亦不舍。不与佛十力亦不舍。乃至不与十八不共法亦不舍。不与须陀洹果亦不舍。乃至不与阿罗汉果亦不舍。不与辟支佛道亦不舍。乃至不与一切智亦不舍。是般若波罗蜜不与阿罗汉法不舍凡人法。不与辟支佛法不舍阿罗汉法。不与佛法不舍辟支佛法。是般若波罗蜜亦不与无为法不舍有为法。何以故。若有诸佛若无诸佛。是诸法相常住不异。法相法住法位常住不谬不失故。尔时诸天子。虚空中立发大音声踊跃欢喜。以沤钵罗华波头摩华拘物头华分陀利华而散佛上。作如是言。我等于阎浮提见第二法轮转。是中无量百千天子得无生法忍。佛告须菩提。是法轮转非第一转非第二转。是般若波罗蜜不为转不为还故。出无法有法空故。须菩提白佛言。世尊。云何无法有法空故。般若波罗蜜不为转不为还故出。佛言。般若波罗蜜。般若波罗蜜相空。乃至檀那波罗蜜。檀那波罗蜜相空。内空内空相空。乃至无法有法空。无法有法空相空。四念处四念处相空。乃至八圣道分八圣道分相空。佛十力佛十力相空。乃至十八不共法十八不共法相空。须陀洹果须陀洹果相空。斯陀含果斯陀含果相空。阿那含果阿那含果相空。阿罗汉果阿罗汉果相空。辟支佛道辟支佛道相空。一切种智一切种智相空。须菩提白佛言。世尊。诸菩萨摩诃萨般若波罗蜜。是摩诃波罗蜜。何以故。虽一切法自性空。而诸菩萨摩诃萨因般若波罗蜜得阿耨多罗三藐三菩提。亦无法可得转法轮。亦无法可转。亦无法可还。是摩诃波罗蜜中亦无有法可见。何以故。是法不可得。若转若还一切法毕竟不生故。何以故。是空相不能转不能还。无相相不能转不能还。无作相不能转不能还。若能如是说般若波罗蜜。教照开示分别显现解释浅易。有能如是教者。是名清净说般若波罗蜜。亦无说者亦无受者亦无证者。若无说无受无证亦无灭者。是说法中亦无毕定福田

    摩诃般若波罗蜜经遍叹品第四十四(丹百波罗蜜品)

尔时慧命须菩提白佛言。世尊。无边波罗蜜是般若波罗蜜。佛言。如虚空无边故。世尊。等波罗蜜是般若波罗蜜。佛言。诸法等故。世尊。离波罗蜜是般若波罗蜜。佛言。毕竟空故。世尊。不坏波罗蜜是般若波罗蜜。佛言。一切法不可得故。世尊。无彼岸波罗蜜是般若波罗蜜。佛言。无名无身故。世尊。空种波罗蜜是般若波罗蜜。佛言。入出息不可得故。世尊。不可说波罗蜜是般若波罗蜜。佛言。觉观不可得故。世尊。无名波罗蜜是般若波罗蜜。佛言。受想行识不可得故。世尊。不去波罗蜜是般若波罗蜜。佛言。一切法不来故。世尊。无移波罗蜜是般若波罗蜜。佛言。一切法不可伏故。世尊。尽波罗蜜是般若波罗蜜。佛言。一切法毕竟尽故。世尊。不生波罗蜜是般若波罗蜜。佛言。一切法不灭故。世尊。不灭波罗蜜是般若波罗蜜。佛言。一切法不生故。世尊。无作波罗蜜是般若波罗蜜。佛言。作者不可得故。世尊。无知波罗蜜是般若波罗蜜。佛言。知者不可得故。世尊。不到波罗蜜是般若波罗蜜。佛言。生死不可得故。世尊。不失波罗蜜是般若波罗蜜。佛言。一切法不失故。世尊。梦波罗蜜是般若波罗蜜。佛言。乃至梦中所见不可得故。世尊。响波罗蜜是般若波罗蜜。佛言。闻声者不可得故。世尊。影波罗蜜是般若波罗蜜。佛言。镜面不可得故。世尊。焰波罗蜜是般若波罗蜜。佛言。水流不可得故。世尊。幻波罗蜜是般若波罗蜜。佛言。术事不可得故。世尊。不垢波罗蜜是般若波罗蜜。佛言。诸烦恼不可得故。世尊。无净波罗蜜是般若波罗蜜。佛言。烦恼虚诳故。世尊。不污波罗蜜是般若波罗蜜。佛言。处不可得故。世尊。不戏论波罗蜜是般若波罗蜜。佛言。一切戏论破故。世尊。不念波罗蜜是般若波罗蜜。佛言。一切念破故。世尊。不动波罗蜜是般若波罗蜜。佛言。法性常住故。世尊。无染波罗蜜是般若波罗蜜。佛言。知一切法无妄解故。世尊。不起波罗蜜是般若波罗蜜。佛言。一切法无分别故。世尊。寂灭波罗蜜是般若波罗蜜。佛言。一切法相不可得故。世尊。无欲波罗蜜是般若波罗蜜。佛言。欲不可得故。世尊。无嗔波罗蜜是般若波罗蜜。佛言。嗔恚不实故。世尊。无痴波罗蜜是般若波罗蜜。佛言。无明黑闇灭故。世尊。无烦恼波罗蜜是般若波罗蜜。佛言。分别忆想虚妄故。世尊。无众生波罗蜜是般若波罗蜜。佛言。众生无所有故。世尊。无断波罗蜜是般若波罗蜜。佛言。诸法不起故。世尊。无二边波罗蜜是般若波罗蜜。佛言。离二边故。世尊。不坏波罗蜜是般若波罗蜜。佛言。一切法不相离故。世尊。不取波罗蜜是般若波罗蜜。佛言。过声闻辟支佛地故。世尊。不分别波罗蜜是般若波罗蜜。佛言。诸妄想不可得故。世尊。无量波罗蜜是般若波罗蜜。佛言。诸法量不可得故。世尊。虚空波罗蜜是般若波罗蜜。佛言。一切法无所有故。世尊。无常波罗蜜是般若波罗蜜。佛言。一切法破坏故。世尊。苦波罗蜜是般若波罗蜜。佛言。一切法苦恼相故。世尊。无我波罗蜜是般若波罗蜜。佛言。一切法不着故。世尊。空波罗蜜是般若波罗蜜。佛言。一切法不可得故。世尊。无相波罗蜜是般若波罗蜜。佛言。一切法不生故。世尊。内空波罗蜜是般若波罗蜜。佛言。内法不可得故。世尊。外空波罗蜜是般若波罗蜜。佛言。外法不可得故。世尊。内外空波罗蜜是般若波罗蜜。佛言。内外法不可得故。世尊。空空波罗蜜是般若波罗蜜。佛言。空空法不可得故。世尊。大空波罗蜜是般若波罗蜜。佛言。一切法不可得故。世尊。第一义空波罗蜜是般若波罗蜜。佛言。涅槃不可得故。世尊。有为空波罗蜜是般若波罗蜜。佛言。有为法不可得故。世尊。无为空波罗蜜是般若波罗蜜。佛言。无为法不可得故。世尊。毕竟空波罗蜜是般若波罗蜜。佛言。诸法毕竟不可得故。世尊。无始空波罗蜜是般若波罗蜜。佛言。诸法无始不可得故。世尊。散空波罗蜜是般若波罗蜜。佛言。散法不可得故。世尊。性空波罗蜜是般若波罗蜜。佛言。有为无为性不可得故。世尊。诸法空波罗蜜是般若波罗蜜。佛言。一切法不可得故。世尊。无所得空波罗蜜是般若波罗蜜。佛言。无所有故。世尊。自相空波罗蜜是般若波罗蜜。佛言。诸法自相离故。世尊。无法空波罗蜜是般若波罗蜜。佛言。无法不可得故。世尊。有法空波罗蜜是般若波罗蜜。佛言。有法不可得故。世尊。无法有法空波罗蜜是般若波罗蜜。佛言。无法有法相不可得故。世尊。念处波罗蜜是般若波罗蜜。佛言。身受心法不可得故。世尊。正勤波罗蜜是般若波罗蜜。佛言。善不善法不可得故。世尊。如意足波罗蜜是般若波罗蜜。佛言。四如意足不可得故。世尊。根波罗蜜是般若波罗蜜。佛言。五根不可得故。世尊。力波罗蜜是般若波罗蜜。佛言。五力不可得故。世尊。觉波罗蜜是般若波罗蜜。佛言。七觉分不可得故。世尊。道波罗蜜是般若波罗蜜。佛言。八圣道分不可得故。世尊。无作波罗蜜是般若波罗蜜。佛言。无作不可得故。世尊。空波罗蜜是般若波罗蜜。佛言。空相不可得故。世尊。无相波罗蜜是般若波罗蜜。佛言。寂灭相不可得故。世尊。背舍波罗蜜是般若波罗蜜。佛言。八背舍不可得故。世尊。定波罗蜜是般若波罗蜜。佛言。九次第定不可得故。世尊。檀那波罗蜜是般若波罗蜜。佛言。悭贪不可得故。世尊。尸罗波罗蜜是般若波罗蜜。佛言。破戒不可得故。世尊。羼提波罗蜜是般若波罗蜜。佛言。忍不忍不可得故。世尊。毗梨耶波罗蜜是般若波罗蜜。佛言。懈怠精进不可得故。世尊。禅那波罗蜜是般若波罗蜜。佛言。定乱不可得故。世尊。般若波罗蜜是般若波罗蜜。佛言。痴慧不可得故。世尊。十力波罗蜜是般若波罗蜜。佛言。一切法不可伏故。世尊。四无所畏波罗蜜是般若波罗蜜。佛言。道种智不没故。世尊。无碍智波罗蜜是般若波罗蜜。佛言。一切法无障无碍故。世尊。佛法波罗蜜是般若波罗蜜。佛言。过一切法故。世尊。如实说者波罗蜜是般若波罗蜜。佛言。一切语如实故。世尊。自然波罗蜜是般若波罗蜜。佛言。一切法中自在故。世尊。佛波罗蜜是般若波罗蜜。佛言。知一切法一切种智故

摩诃般若波罗蜜经卷第十二摩诃般若波罗蜜经卷第十三

        后秦龟兹国三藏鸠摩罗什译

    闻持品第四十五(丹本耳品)

尔时释提桓因作是念。若善男子善女人得闻般若波罗蜜经耳者。是人于前世佛作功德。与善知识相随。何况受持亲近读诵正忆念如说行。当知是善男子善女人多亲近诸佛。能得听受亲近读诵。乃至正忆念如说修行能问能答当知是善男子善女入于前世多供养亲近诸佛故。闻是深般若波罗蜜不惊不怖不畏。当知是人亦于无量亿劫。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。尔时舍利弗白佛言。世尊。若有善男子善女人闻是深般若波罗蜜不惊不怖不畏。闻已受持亲近如说习行。当知是善男子善女人如阿惟越致菩萨摩诃萨。何以故。世尊。是般若波罗蜜甚深。若先世不久行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。终不能信解深般若波罗蜜。世尊。若有善男子善女人呰毁深般若波罗蜜者。当知是人前世亦呰毁深般若波罗蜜。何以故。是善男子善女人闻说深般若波罗蜜时。无有信乐心不清净。是善男子善女人先世不难不问诸佛及弟子。云何应行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。云何应修内空。乃至云何应修无法有法空。云何应修四念处。乃至云何应修八圣道分。云何应修佛十力。乃至云何应修十八不共法。释提桓因语舍利弗。是深般若波罗蜜若有善男子善女人。不久行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜不行内空外空乃至无法有法空。不行四禅四无量心四无色定。不行四念处乃至八圣道分。不行佛十力乃至十八不共法。如是人不信解是般若波罗蜜有何可怪。大德舍利弗。我礼般若波罗蜜。礼般若波罗蜜是礼一切智。佛告释提桓因言。如是如是。憍尸迦。礼般若波罗蜜是礼一切智。何以故。憍尸迦。诸佛一切智皆从般若波罗蜜生。一切智即是般若波罗蜜。以是故。憍尸迦。善男子善女人欲住一切智。当住般若波罗蜜。善男子善女人欲生道种智。当习行般若波罗蜜。欲断一切诸结及习。当习行般若波罗蜜。善男子善女人欲转法轮。当习行般若波罗蜜。善男子善女人欲得须陀洹果斯陀含果阿那含果阿罗汉果当习行般若波罗蜜。欲得辟支佛道。当习行般若波罗蜜。欲教众生令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。当习行般若波罗蜜。若善男子善女人欲教众生令得阿耨多罗三藐三菩提。若欲总摄比丘僧。当习行般若波罗蜜。释提桓因白佛言。世尊。菩萨摩诃萨欲行般若波罗蜜时。云何名住般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。云何住内空外空乃至无法有法空。云何住四禅四无量心四无色定五神通。云何住四念处乃至八圣道分。云何住佛十力乃至十八不共法。世尊。菩萨摩诃萨云何习行般若波罗蜜乃至檀那波罗蜜内空乃至十八不共法。佛语释提桓因言。善哉善哉。憍尸迦。汝能乐问是事皆是佛神力。憍尸迦。若菩萨摩诃萨行般若波罗蜜时。若不住色中为习行般若波罗蜜。若不住受想行识中为习行般若波罗蜜。眼耳鼻舌身意。色声香味触法。眼界乃至意识界亦如是。憍尸迦。若菩萨摩诃萨不住般若波罗蜜中。为习般若波罗蜜。不住禅那波罗蜜中为习禅那波罗蜜。不住毗梨耶波罗蜜中为习毗梨耶波罗蜜。不住羼提波罗蜜中为习羼提波罗蜜。不住尸罗波罗蜜中为习尸罗波罗蜜。不住檀那波罗蜜中为习檀那波罗蜜。如是憍尸迦。是名菩萨摩诃萨不住般若波罗蜜中。为习般若波罗蜜。憍尸迦。不住内空中为习内空。乃至不住无法有法空中为习无法有法空。不住四禅中为习四禅。不住四无量心中为习四无量心。不住四无色定中为习四无色定。不住五神通中为习五神通。不住四念处中为习四念处。乃至不住八圣道分中为习八圣道分。不住佛十力中为习佛十力。乃至不住十八不共法中为习十八不共法。何以故。憍尸迦。是菩萨不得色可住可习处。乃至十八不共法。不得十八不共法可住可习处。复次憍尸迦。菩萨摩诃萨不习色。若不习色是名习色。受想行识乃至十八不共法亦如是。何以故。是菩萨摩诃萨色前际不可得中际不可得后际不可得。乃至十八不共法亦如是。舍利弗白佛言。世尊。是般若波罗蜜甚深。佛言。色如甚深故。般若波罗蜜甚深。受想行识如甚深故。般若波罗蜜甚深。乃至十八不共法亦如是。舍利弗言。世尊。是般若波罗蜜难可测量。佛言。色难可测量故。般若波罗蜜难可测量。受想行识乃至十八不共法难可测量故。般若波罗蜜难可测量。世尊。是般若波罗蜜无量。佛言。色无量故般若波罗蜜无量。受想行识乃至十八不共法无量故般若波罗蜜无量。佛告舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色甚深。为行般若波罗蜜。不行受想行识乃至不行十八不共法甚深。为行般若波罗蜜。何以故。色甚深相为非色。受想行识乃至十八不共法甚深相。为非十八不共法。如是不行为行般若波罗蜜。舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色难测量。为行般若波罗蜜不行受想行识乃至不行十八不共法难测量为行般若波罗蜜。何以故。色难测量相为非色。受想行识乃至十八不共法难测量相。为非十八不共法。舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色无量为行般若波罗蜜。不行受想行识乃至不行十八不共法无量为行般若波罗蜜。何以故。色是无量相为非色。受想行识乃至十八不共法无量相为非十八不共法。舍利弗白佛言。世尊。是般若波罗蜜甚深甚深相。难见难解不可思量。不应在新发意菩萨前说。何以故。新发意菩萨闻是甚深般若波罗蜜。或当惊怖心生疑悔不信不行。是甚深般若波罗蜜。当在阿惟越致菩萨摩诃萨前说。是菩萨闻是甚深般若波罗蜜。不惊不怖心不疑悔则能信行。释提桓因问舍利弗。若在新发意菩萨摩诃萨前。说是深般若波罗蜜有何等过。舍利弗报释提桓因言。憍尸迦。若在新发意菩萨前说是深般若波罗蜜。或当惊怖呰毁不信。是新发意菩萨或有是处。若新发意菩萨闻是深般若波罗蜜。毁呰不信种三恶道业。是业因缘故。久久难得阿耨多罗三藐三菩提。释提桓因问舍利弗。颇有未受记菩萨摩诃萨闻是深般若波罗蜜不惊不怖者不。舍利弗言。如是憍尸迦。若有菩萨摩诃萨。闻是深般若波罗蜜不惊不怖。当知是菩萨得受阿耨多罗三藐三菩提记不久不过一佛两佛。佛告舍利弗。如是如是。是菩萨摩诃萨久发意行六波罗蜜多供养诸佛。闻是深般若波罗蜜不惊不怖不畏。闻即受持如般若波罗蜜中所说行。尔时舍利弗白佛言。世尊。我欲说譬喻。如求菩萨道善男子善女人。梦中修行般若波罗蜜入禅定勤精进。具足忍辱守护于戒行布施。修行内空外空乃至坐于道场。当知是善男子善女人近阿耨多罗三藐三菩提。何况菩萨摩诃萨欲得阿耨多罗三藐三菩提。觉时修行般若波罗蜜入禅定勤精进。具足忍辱守护于戒行布施。而不疾成阿耨多罗三藐三菩提坐于道场。世尊。善男子善女人善根成就。得闻般若波罗蜜受持乃至如说修行。当知是菩萨摩诃萨久发意种善根。多供养诸佛与善知识相随。是人能受持般若波罗蜜乃至正忆念。当知是人近受阿耨多罗三藐三菩提记。当知是善男子善女人如阿惟越致菩萨摩诃萨。于阿耨多罗三藐三菩提不动转。能得深般若波罗蜜。得已能受持读诵乃至正忆念。世尊。譬如人欲过百由旬若二百三百四百由旬旷野崄道。先见诸相若放牧者若疆界若园林。如是等诸相故知近城邑聚落。是人见是相已作是念。如我所见相当知城邑聚落不远。心得安隐不畏贼难恶虫饥渴。世尊。菩萨摩诃萨亦如是。若得是深般若波罗蜜受持读诵乃至正忆念。当知近受得阿耨多罗三藐三菩提记不久。当知是菩萨摩诃萨。不应畏堕声闻辟支佛地。是诸先相。所谓甚深般若波罗蜜得闻得见得受持。乃至正忆念故。佛告舍利弗。如是如是。汝更乐说者便说。世尊。譬如人欲见大海发心往趣。不见树相不见山相。是人虽未见大海知大海不远。何以故。大海处平无树相无山相故。如是世尊。菩萨摩诃萨闻是深般若波罗蜜。受持乃至正忆念时。虽未佛前受劫数之记若百劫千劫百千万亿劫。是菩萨自知近受阿耨多罗三藐三菩提记不久何以故。我得闻是深般若波罗蜜。受持读诵。乃至正忆念故。世尊。譬如初春诸树故叶已堕。当知此树新叶华果出在不久。何以故。见是诸树先相故。知今不久华叶果出。是时阎浮提人见树先相皆悉欢喜。世尊。菩萨摩诃萨得闻是深般若波罗蜜。受持读诵乃至正忆念如说行。当知是菩萨善根成就多供养诸佛。是菩萨应作是念。先世善根所追趣阿耨多罗三藐三菩萨。以是因缘故得见得闻是深般若波罗蜜。受持读诵乃至正忆念如说行。是中诸天子。曾见佛者欢喜踊跃。作是念言。先诸菩萨摩诃萨亦有如是受记先相。今是菩萨摩诃萨受阿耨多罗三藐三菩提记亦不久。世尊。譬如母人怀妊。身体苦重行步不便。坐起不安眠食转少。不喜语言厌本所习。受苦痛故有异母人见其先相。当知产生不久。菩萨摩诃萨亦如是。种善根多供养诸佛久行六波罗蜜。与善知识相随善根成就。得闻深般若波罗蜜受持读诵乃至正忆念如说行。诸人亦知是菩萨摩诃萨得阿耨多罗三藐三菩提记不久。佛告舍利弗言。善哉善哉。汝所乐说皆是佛力。尔时须菩提白佛言。希有世尊。诸多陀阿伽度阿罗诃三藐三佛陀。善付诸菩萨摩诃萨事。佛告须菩提。诸菩萨摩诃萨发阿耨多罗三藐三菩提心安隐多众生。令无量众生得乐。怜愍饶益诸天人故。是诸菩萨行菩萨道时。以四事摄无量百千众生。所谓布施爱语利益同事。亦以十善道成就众生。自行初禅亦教他人令行初禅。乃至自行非有想非无想处。亦教他人令行乃至非有想非无想处。自行檀那波罗蜜亦教他人令行檀那波罗蜜。自行尸罗波罗蜜亦教他人令行尸罗波罗蜜。自行羼提波罗蜜亦教他人令行羼提波罗蜜。自行毗梨耶波罗蜜亦教他人令行毗梨耶波罗蜜。自行禅那波罗蜜亦教他人令行禅那波罗蜜。自行般若波罗蜜亦教他人令行般若波罗蜜。是菩萨得般若波罗蜜。以方便力教众生。令得须陀洹果。自于内不证。教众生令得斯陀含果阿那含果阿罗汉果。自于内不证。教众生令得辟支佛道。自于内不证。自行六波罗蜜亦教无量百千万诸菩萨令行六波罗蜜。自住阿惟越致地亦教他人住阿惟越致地。自净佛国土亦教他人净佛国土。自成就众生亦教他人成就众生。自得菩萨神通亦教他人令得菩萨神通。自净陀罗尼门亦教他人净陀罗尼门。自具足乐说辩才亦教他人具足乐说辩才。自受色成就亦教他人受色成就。自成就三十二相亦教他人成就三十二相。自成就童真地亦教他人成就童真地。自成就佛十力亦教他人令成就佛十力。自行四无所畏亦教他人行四无所畏。自行十八不共法亦教他人令行十八不共法。自行大慈大悲亦教他人行大慈大悲。自得一切种智亦教他人令得一切种智。自离一切结使及习亦教他人令离一切结使及习。自转法轮亦教他人转法轮。须菩提白佛言。希有世尊。诸菩萨摩诃萨大功德成就。所谓为一切众生行般若波罗蜜。欲得阿耨多罗三藐三菩提。世尊。云何诸菩萨摩诃萨具足修行般若波罗蜜。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。不见色增相亦不见减相。不见受想行识增相亦不见减相。乃至一切种智不见增相亦不见减相。菩萨摩诃萨是时具足般若波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不见是法是非法不见是过去法是未来现在法。不见是善法不善法有记法无记法。不见是有为法无为法不见欲界色界无色界。不见檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。乃至不见一切种智。如是菩萨摩诃萨具足修行般若波罗蜜。何以故。诸法无相故。诸法空欺诳无坚固。无觉者无寿命者。须菩提言。世尊。世尊所说不可思议。佛告须菩提。色不可思议故所说不可思议。受想行识不可思议故所说不可思议。六波罗蜜不可思议故所说不可思议。乃至一切种智不可思议故所说不可思议。须菩提。若菩萨摩诃萨行般若波罗蜜时。知色是不可思议。受想行识是不可思议。乃至知一切种智是不可思议。是菩萨则不能具足般若波罗蜜。须菩提白佛言。世尊。是深般若波罗蜜谁当信解者。佛言。若有菩萨摩诃萨久行六波罗蜜。种善根多亲近供养诸佛与善知识相随。是菩萨能信解深般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨久行六波罗蜜。种善根多亲近供养诸佛。与善知识相随。佛言。若菩萨摩诃萨不分别色。不分别色相。不分别色性。不分别受想行识。不分别识相。不分别识性。眼耳鼻舌身意。色声香味触法。眼界乃至意识界亦如是。不分别欲界色界无色界。不分别三界相性。不分别檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至八圣道分佛十力乃至十八不共法。不分别檀乃至十八不共法相。不分别十八不共法性。不分别道种智。不分别道种智相性。不分别一切种智。不分别一切种智相。不分别一切种智性。何以故。须菩提。色不可思议受想行识不可思议。乃至一切种智不可思议。如是须菩提。是名菩萨摩诃萨久行六波罗蜜。种善根多亲近供养诸佛。与善知识相随。须菩提白佛言。世尊。色甚深故般若波罗蜜甚深。受想行识甚深乃至一切种智甚深故般若波罗蜜甚深。世尊。是般若波罗蜜珍宝聚。有须陀洹果宝故。有斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提宝故。有四禅四无量心四无色定五神通四念处乃至八圣道分。佛十力四无所畏四无碍智。大慈大悲十八不共法。一切智一切种智宝故。世尊。是般若波罗蜜清净聚。色清净故般若波罗蜜清净聚。受想行识清净乃至一切种智清净故般若波罗蜜清净聚。须菩提言。世尊。甚可怪说是般若波罗蜜时多有留难。佛言。如是如是。须菩提。是甚深般若波罗蜜多有留佛。以是事故。善男子善女人若欲书是般若波罗蜜时应当疾书。若读诵思惟说正忆念修行时亦应疾修行。何以故。是甚深般若波罗蜜。若书读诵思惟说正忆念修行时。不欲令诸难起故。善男子善女人。若能一月书成当应勤书。若二月三月四月五月六月七月若一岁书成亦当勤书。读诵思惟说正忆念修行。若一月得成就乃至一岁得成就。应当勤成就。何以故。须菩提。是珍宝中多有难起故。须菩提言。世尊。是甚深般若波罗蜜中。恶魔喜作留难故。不得令书。不得令读诵思惟说正忆念修行。佛告须菩提。恶魔虽欲留难是深般若波罗蜜令不得书读诵思惟说正忆念修行。亦不能破坏是菩萨摩诃萨书般若波罗蜜乃至修行。尔时舍利弗白佛言。世尊。谁力故令恶魔不能留难菩萨摩诃萨书深般若波罗蜜乃至修行。佛言。是佛力故。恶魔不能留难菩萨摩诃萨书深般若波罗蜜乃至修行。舍利弗。亦是十方国土现在诸佛力故。是诸佛拥护念是菩萨故。令魔不能留难菩萨摩诃萨令不书成就般若波罗蜜乃至修行。何以故。十方国土中。现在无量无边阿僧祇诸佛。拥护念是菩萨书深般若波罗蜜乃至修行法应尔亦无能作留难。舍利弗。善男子善女人应当作是念。我书是深般若波罗蜜。乃至修行。皆是十方诸佛力。舍利弗言。世尊。若有善男子善女人书是深般若波罗蜜乃至修行。皆是佛力故。当知是人是诸佛所护。佛言。如是如是。舍利弗。当知若有善男子善女人。书是深般若波罗蜜乃至修行。皆是佛力故。当知亦是诸佛所护。舍利弗言。世尊。十方现在无量无边阿僧祇诸佛。皆识皆以佛眼见是善男子善女人书深般若波罗蜜时乃至修行时。佛言。如是如是。舍利弗。十方现在无量无边阿僧祇诸佛。皆识皆以佛眼见是善男子善女人书深般若波罗蜜时乃至修行时。舍利佛。是中求菩萨道善男子善女人。若书是深般若波罗蜜。受持读诵正忆念如说修行。当知是人近阿耨多罗三藐三菩提不久。舍利弗。善男子善女人书是深般若波罗蜜。受持读诵乃至正忆念。是人于深般若波罗蜜多信解相。亦供养恭敬尊重赞叹是深般若波罗蜜。华香璎珞乃至幡盖供养。舍利弗。诸佛皆识皆以佛眼见是善男子善女人。是善男子善女人供养功德当得大利益大果报。舍利弗。是善男子善女人以是供养功德因缘故终不堕恶道中。乃至阿惟越致地终不远离诸佛。舍利弗。是善男子善女人是善根因缘故。乃至阿耨多罗三藐三菩提终不远离六波罗蜜。终不远离内空乃至无法有法空。终不远离四念处乃至八圣道分。终不远离佛十力乃至阿耨多罗三藐三菩提。舍利弗。是深般若波罗蜜佛般涅槃后当至南方国土是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故终不堕恶道中受天上人中乐增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜从南方当转至西方。所在处是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故终不堕恶道中。受天上人中乐增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜从西方当转至北方。所在处是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故终不堕恶道中。受天上人中乐增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜是时北方当作佛事。何以故。舍利弗。我法盛时无灭相。舍利弗。我已念是善男子善女人。受是深般若波罗蜜乃至修行。是善男子善女人能书是般若波罗蜜。恭敬供养尊重赞叹华香乃至幡盖。舍利弗。是善男子善女人。以是善根因缘故终不堕恶道中。受天上人中乐增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。何以故。舍利弗。我以佛眼见是人我亦称誉赞叹。十方国土中无量无边阿僧祇诸佛。亦以佛眼见是人亦称誉赞叹。舍利弗白佛言。世尊。是深般若波罗蜜后时当在北方广行耶。佛言。如是如是。舍利弗。是深般若波罗蜜后时在北方当广行。舍利弗。后时于北方是善男子善女人。若闻是深般若波罗蜜。若书受持读诵思惟说正忆念如说修行。当知是善男子善女人久发大乘心。多供养诸佛种善根。久与善知识相随。舍利弗白佛言。世尊。后时北方当有几所善男子善女人求佛道。书深般若波罗蜜乃至如说修行。佛告舍利弗。后时北方虽多有求佛道善男子善女人。少有闻是深般若波罗蜜不没不惊不怖不畏。何以故。是人多亲近供养诸佛多咨问诸佛。是人必能具足般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。具足四念处。乃至具足十八不共法。舍利弗。是善男子善女人善根纯熟故。能多利益众生为阿耨多罗三藐三菩提。何以故。我今为是善男子善女人说应萨婆若法。过去诸佛亦为是善男子善女人说应萨婆若法。以是因缘故。是人后生时续得阿耨多罗三藐三菩提心。亦为他人说阿耨多罗三藐三菩提法。是善男子善女人皆一心和合。魔若魔民不能沮坏阿耨多罗三藐三菩提心。何况恶行人毁呰行深般若波罗蜜者。能坏其阿耨多罗三藐三菩提心。舍利弗。是求菩萨道诸善男子善女人。闻是深般若波罗蜜得大法喜法乐。亦立多人于善根为阿耨多罗三藐三菩提。是善男子善女人于我前立誓愿。我行菩萨道时当度无数百千万亿众生。令发阿耨多罗三藐三菩提心示教利喜。乃至阿惟越致地受记。我知其心我亦随喜是善男子善女人亦于过去诸佛前立誓愿。我行菩萨道时当度无数百千万亿众生。令发阿耨多罗三藐三菩提心示教利喜。乃至阿惟越致地受记。诸过去佛亦知其心而随喜。舍利弗。是诸善男子善女人所为心大。所受色声香味触法亦大亦能大施。能大施已种大善根。种大善根已得大果报。为摄众生故受身。能于众生中舍内外所有物。以是善根因缘。发愿欲生他方国土现在诸佛说深般若波罗蜜处。于诸佛前闻是深般若波罗蜜已。亦于彼示教利喜百千万亿众生。令发阿耨多罗三藐三菩提心。舍利弗白佛言。希有世尊。佛于过去未来现在法。无法不知。无法如相不知。众生之行无事不知。今佛悉知过去诸佛及菩萨声闻。亦知今现在十方诸佛国土菩萨及声闻。亦知未来诸佛及菩萨声闻。世尊。未来世有善男子善女人勤求六波罗蜜。受持读诵乃至修行。有得有不得。佛告舍利弗。若善男子善女人一心精进勤求。当得应六波罗蜜诸经。舍利弗白佛言。善男子善女人如是勤行者。得是应六波罗蜜深经耶。佛语舍利弗。是善男子善女人得是应六波罗蜜深经。何以故。善男子善女人为阿耨多罗三藐三菩提故。与众生说法示教利喜令住六波罗蜜。以是因缘故。是善男子善女人后身转生。易得应六波罗蜜深经。得已如六波罗蜜所说修行精勤不息。乃至净佛国土成就众生。得阿耨多罗三藐三菩提

    摩诃般若波罗蜜经魔事品第四十六

尔时慧命须菩提白佛言。世尊。是善男子善女人发阿耨多罗三藐三菩提心。行六波罗蜜成就众生净佛国土。佛已赞叹说其功德。世尊。云何是善男子善女人求于佛道生诸留难。佛告须菩提。乐说辩不即生。当知是菩萨魔事。须菩提言。世尊。何因缘故。乐说辩不即生是菩萨魔事。佛言。有菩萨摩诃萨行般若波罗蜜时。难具足六波罗蜜。以是因缘故乐说辩不即生是菩萨魔事。复次须菩提。乐说辩卒起。当知亦是菩萨魔事。世尊。何因缘故。乐说辩卒起复是魔事。佛言。菩萨摩诃萨行檀那波罗蜜乃至般若波罗蜜着乐说法。以是因缘故乐脱辩卒起。当知是菩萨魔事。复次须菩提。书是般若波罗蜜经时偃蹇骜慢。当知是菩萨魔事。复次须菩提。书是经时戏笑乱心。当知是菩萨魔事。复次须菩提。若书是经时轻笑不敬。当知是菩萨魔事。复次须菩提。若书是经时心乱不定。当知是菩萨魔事。复次须菩提。书是经时各各不和合。当知是为菩萨魔事。复次须菩提。善男子善女人作是念。我不得是经中滋味便弃舍去。当知是为菩萨魔事。复次须菩提。受持般若波罗蜜读诵说若正忆念时偃蹇骜慢。当知是为菩萨魔事。复次须菩提。若受持般若波罗蜜经时。亲近正忆念时转相形笑。当知是为菩萨魔事。复次须菩提。若受持般若波罗蜜经读诵正忆念修行时共相轻蔑。当知是为菩萨魔事。若受持般若波罗蜜读诵乃至正忆念时散乱心。当知是为菩萨魔事。若受持般若波罗蜜读诵乃至正忆念时心不和合。当知是为菩萨魔事。须菩提白佛言。世尊。世尊说善男子善女人作是念。我不得经中滋味便弃舍去。当知是为菩萨魔事。世尊。何因缘故。菩萨不得经中滋味便弃舍去。佛言。是菩萨摩诃萨前世不久行般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。是人闻说是般若波罗蜜。便从座起作是念言。我于般若波罗蜜中无记心不清净。便从座起去。当知是为菩萨魔事。须菩提白佛言。世尊。何因缘故不与受记。闻说是般若波罗蜜时便从座起去。佛告须菩提。若菩萨未入法位中。诸佛不与受阿耨多罗三藐三菩提记。复次须菩提。闻说般若波罗蜜时。菩萨作是念。我是中无名字心不清净。当知是为菩萨魔事。须菩提言。何因缘故是深般若波罗蜜中不说是菩萨名字。佛言。未受记菩萨诸佛不记名字。复次须菩提。是菩萨摩诃萨作是念。是般若波罗蜜中。无我生处名字若聚落城邑。是人不欲听闻般若波罗蜜。便从会中起去。是人如所起念时念念却一劫。补当更勤精进求阿耨多罗三藐三菩提。复次须菩提。菩萨学余经弃舍般若波罗蜜终不能至萨婆若。善男子善女人为舍其根而攀枝叶。当知是为菩萨魔事。须菩提白佛言。世尊。何等是余经。善男子善女人所学不能至萨婆若。佛言。是声闻所应行经。所谓四念处四正勤四如意足五根五力七觉分八圣道分。空无相无作解脱门。善男子善女人住是中得须陀洹果斯陀含果阿那含果阿罗汉果。是名声闻所行不能至萨婆若。如是善男子善女人。舍般若波罗蜜亲近是余经。何以故。须菩提。般若波罗蜜中出生诸菩萨摩诃萨。成就世间出世间法。须菩提。菩萨摩诃萨学般若波罗蜜时。亦学世间出世间法。须菩提。譬如狗不从大家求食反从作务者索。如是须菩提。当来世有善男子善女人弃深般若波罗蜜而攀枝叶。取声闻辟支佛所应行经。当知是为菩萨魔事。须菩提。譬如有人欲得见象见已反观其迹。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。诸求佛道善男子善女人亦复如是。得深般若波罗蜜弃舍去。取声闻辟支佛所应行经。须菩提。当知是为菩萨魔事。须菩提。譬如人欲见大海反求牛迹水。作是念。大海水能与此等不。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人亦如是。得深般若波罗蜜弃舍去。取声闻辟支佛所应行经。当知是亦菩萨摩诃萨魔事。须菩提。譬如工匠若工匠弟子。欲拟作帝释胜殿而揆则日月宫殿。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。如是须菩提。当来世有薄福德善男子善女人求佛道者。得是深般若波罗蜜便弃舍去。于声闻辟支佛所应行经中求萨婆若。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当知亦是菩萨魔事。须菩提。譬如有人欲见转轮圣王见而不识。后见诸小国王取其相貌。如是言转轮圣王与此何异。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。须菩提。当来世有薄福德善男子善女人求佛道者。得是深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。当知是为菩萨魔事须菩提。譬如饥人得百味食弃舍去。反食六十日谷饭。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人。得闻深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。于汝意云何。是人为黠不。须菩提言。为不黠。当知是亦菩萨魔事。须菩提。譬如人得无价摩尼珠反持比水精珠。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人。得闻深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。是人为黠不。须菩提言。为不黠。当知是亦菩萨魔事。复次须菩提。是求佛道善男子善女人。书是深般若波罗蜜时。乐说不如法事。不得书成般若波罗蜜。所谓乐说色声香味触法。乐说持戒禅定无色定。乐说檀那波罗蜜乃至般若波罗蜜。乐说四念处乃至阿耨多罗三藐三菩提。何以故。须菩提。是般若波罗蜜中无乐说相。须菩提。般若波罗蜜不可思议相。般若波罗蜜不生不灭相。般若波罗蜜不垢不净相。般若波罗蜜不乱不散相。般若波罗蜜无说相。般若波罗蜜无言无义相。般若波罗蜜无所得相。何以故。须菩提。般若波罗蜜中无是诸法。须菩提。若有善男子善女人求菩萨道者。书是般若波罗蜜经时。以是诸法散乱心。当知亦是菩萨魔事。须菩提白佛言。世尊。是般若波罗蜜可书耶。佛言。不可书。何以故。般若波罗蜜自性无故。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。乃至一切种智自性无故。若自性无是不名为法。无法不能书无法。须菩提。若求菩萨道善男子善女人作是念。无法是深般若波罗蜜。当知即是菩萨魔事。世尊。是求菩萨道善男子善女人。用字书般若波罗蜜。自念我书是般若波罗蜜。以字着般若波罗蜜。当知亦是菩萨魔事。何以故。世尊。是般若波罗蜜无文字。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜无有文字。世尊。色无文字受想行识无文字。乃至一切种智无文字。世尊。若求菩萨道善男子善女人。着无文字般若波罗蜜。乃至着无文字一切种智。当知是亦菩萨魔事。读诵说正忆念如说修行亦如是。复次须菩提。求佛道善男子善女人。书是般若波罗蜜时。国土念起聚落念起城郭念起方念起。若闻毁谤其师起念。若念父母及兄弟姊妹诸余亲里。若念贼若念旃陀罗。若念众女若念淫女。如是等种种诸余异念。留难恶魔复益其念。破坏书般若波罗蜜。破坏读诵说正忆念如说修行。须菩提。当知是亦菩萨魔事。复次须菩提。求佛道善男子善女人。得名誉恭敬布施供养。所谓衣服饮食卧床疾药种种乐具善男子善女人书是般若波罗蜜经受读诵乃至正忆念时。受着是事不得书成般若波罗蜜乃至正忆念。当知是亦菩萨魔事。复次须菩提。求佛道善男子善女人书般若波罗蜜。乃至如说修行时。恶魔方便持诸余深经与是菩萨摩诃萨。有方便力者。不应贪着恶魔所与诸余深经。何以故。是经不能令人至萨婆若故。是中无方便菩萨摩诃萨闻是诸余深经。便舍深般若波罗蜜。须菩提。我是般若波罗蜜中广说诸菩萨摩诃萨方便道。诸菩萨摩诃萨应当从是中求。须菩提今善男子善女人求菩萨道舍是深般若波罗蜜。于魔所与声闻辟支佛深经中求方便道。当知亦是菩萨魔事

摩诃般若波罗蜜经卷第十三摩诃般若波罗蜜经卷第十四

        后秦龟兹国三藏鸠摩罗什译

    两过品第四十七(丹两不和合品)

复次须菩提。听法人欲书持般若波罗蜜读诵问义正忆念。说法人懈惰不欲为说。当知是为菩萨魔事。须菩提。说法之人心不懈惰。欲令书持般若波罗蜜。听法者不欲受之。二心不和。当知是为魔事。复次须菩提。听法人欲书持般若波罗蜜读诵乃至正忆念。说法者欲至他方。当知是为魔事。须菩提。说法人欲令书持般若波罗蜜。听法者欲至他方。二心不和。当知是为魔事。复次须菩提。说法人贵重布施衣服饮食卧具医药资生之物。听法人少欲知足行远离行。摄念精进一心智慧。两不和合。不得书持般若波罗蜜受持读诵问义正忆念。当知是为魔事。须菩提。说法人少欲知足行远离行。摄念精进一心智慧。听法者贵重布施衣服饮食卧具医药资生之物。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事。复次须菩提。说法者受十二头陀。一作阿兰若。二常乞食。三纳衣。四一坐食。五节量食六中后不饮浆。七冢间住。八树下住。九露地住。十常坐不卧。十一次第乞食。十二但三衣。听法人不受十二头陀。不作阿兰若。乃至不受但三衣。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事。须菩提。听法者受十二头陀。作阿兰若。乃至但受三衣。说法人不受十二头陀。不作阿兰若。乃至不受但三衣。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事。复次须菩提。说法者有信有善。欲书深般若波罗蜜乃至正忆念。听法者无信破戒恶行。不欲书受深般若波罗蜜乃至正忆念。当知是为魔事。须菩提。听法者有信有善持戒。说法者无信破戒恶行。两不和合。当知是为魔事。复次须菩提。说法者能一切施心不悭惜。听法者吝惜不舍。当知是为魔事。须菩提。听法者一切能施心不悭惜。说法者吝法不施。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。听法者欲供养说法人衣服饮食卧具医药资生所须说法者不欲受之。当知是为魔事。须菩提。说法者欲供给听法人衣服乃至资生所须。听法者不欲受之。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事复次须菩提。说法者易悟。听法人闇钝。当知是为魔事。须菩提。听法者易悟。说法人闇钝。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者知十二部经次第义。所谓修妒路乃至优波提舍。听法者不知十二部经次第义。当知是为魔事。听法者知十二部经次第义。说法人不知十二部经次第义。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者。成就六波罗蜜。听法人不成就六波罗蜜。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者有六波罗蜜。说法人无六波罗蜜。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者于六波罗蜜有方便力。听法人于六波罗蜜无方便力。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者于六波罗蜜有方便力。说法人于六波罗蜜无方便方。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者得陀罗尼。听法人无陀罗尼。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者得陀罗尼。说法者无陀罗尼。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲令书持般若波罗蜜读诵乃至正忆念。听法人不欲书持般若波罗蜜读诵乃至正忆念。两不和合。不得书般若波罗蜜乃至正忆念。当知是为魔事。听法者欲书读诵说般若波罗蜜。说法者不欲令书般若波罗蜜乃至不欲令说。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者离贪欲嗔恚睡眠掉悔疑。听法人贪欲嗔恚睡眠掉悔疑。当知是为魔事。听法者离贪欲嗔恚睡眠掉悔疑。说法人贪欲嗔恚睡眠掉悔疑。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。书是深般若波罗蜜乃至正忆念时。或有人来说三恶道中苦剧。汝何不于是身尽苦速入涅槃。何用是阿耨多罗三藐三菩提为。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。书是深般若波罗蜜受持读诵说正忆念时。或有人来赞四天王诸天。赞三十三天夜摩天兜率陀天化乐天他化自在天梵天乃至非有想非无想天。赞初禅乃至非有想非无想定。作是言。善男子。欲界中受五欲快乐。色界中受禅生乐。无色界中受寂灭乐。是事亦无常苦空无我。变相尽相散相离相灭相。汝何不于是身中取须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。何用是世间生死中受种种苦求阿耨多罗三藐三菩提为。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者一身无累自在无碍。听法人多将人众。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者一身无累自在无碍。说法者多将人众。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者如是言。汝能随我意者。当与汝般若波罗蜜令书读诵说正忆念。若不随我意者则不与汝。两不和合。不得书深般若波罗蜜读诵说正忆念。当知是为魔事。复次须菩提。听法者欲得追随如其意。说法者不听。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲得财利故。与般若波罗蜜令书持乃至正忆念。听法者以是因缘故不欲从受。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者为财利故。欲书深般若波罗蜜读诵说。说法者以是因缘故不欲与。两不和合。不得书深般若波罗蜜读诵说。当知是为魔事。复次须菩提。说法者欲至他方危命之处。听法者不欲随去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者欲至他方危命之处。说法者不欲去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲至他方饥饿谷贵无水之处。听法者不欲随去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者欲至他方饥饿谷贵无水之处。说法者不欲去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲至他方丰乐之处。听法者欲随从去。说法者言。善男子。汝为利养故追随我。汝善自思惟。若得若不得无令后悔。以是小因缘故两不和合。听法者闻之心厌作是念。是为拒逆。不欲与我相随。便即止不去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲过旷野。贼怖旃陀罗怖猎师怖恶兽毒蛇怖。听法者欲随逐去。说法者言。善男子。汝何用到彼。彼中多有诸怖贼怖乃至毒蛇怖。听法者闻之知其不欲与般若波罗蜜书持乃至正忆念。心厌不欲追随。以是少因缘故两不和合。当知是为魔事。复次须菩提。说法者多有檀越数往问讯。以是因缘故。语听法者。我有因缘应往到彼。听法人知其意便止不去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作比丘形像来。方便破坏般若波罗蜜。不得令书持读诵说正忆念。须菩提白佛言。世尊。何因缘故。恶魔作比丘形像。方便破坏般若波罗蜜。不得令书持乃至正忆念。佛言。恶魔作比丘形像来坏善男子善女人心。令远离般若波罗蜜作是言。如我所说经即是般若波罗蜜。此经非般若波罗蜜。须菩提。是中破坏诸比丘时。有未受记菩萨便堕疑惑。堕疑惑故不得书深般若波罗蜜。不受不持乃至不作正忆念。两不和合。不得书成般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作比丘身。到菩萨所如是言。若菩萨行般若波罗蜜。于实际作证得须陀洹果斯陀含果阿那含果阿罗汉果。得辟支佛道。以是不和合。不得书般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说是深般若波罗蜜时。多有魔事起留难般若波罗蜜是为魔事。菩萨摩诃萨应当觉知知已远离。须菩提言。世尊。何等是魔事留难。菩萨应当觉知知已远离。佛言。似般若波罗蜜诸魔事起。似禅那波罗蜜似毗梨耶波罗蜜似羼提波罗蜜似尸罗波罗蜜似檀那波罗蜜魔事起。菩萨应当觉知知已远离。复次须菩提。声闻辟支佛所应行经。是菩萨摩诃萨应当知是魔事而远离之。复次须菩提。内空外空乃至无法有法空。四念处乃至八圣道分。空无相无作解脱门。用是法得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。如是等诸经。恶魔作比丘形像。方便与菩萨摩诃萨以是不和合故。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作佛身金色丈光。到菩萨所是菩萨贪着。贪着因缘故耗减萨婆若。以是不和合故。不得书般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作佛身及比丘僧到菩萨前。是菩萨起贪着意作是念。我于当来世亦当如是从比丘僧为说法。是菩萨贪着魔身故。耗减萨婆若。不得书成般若波罗蜜。当知是为魔事。复次须菩提。恶魔化作无数百千万亿菩萨。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。指示善男子善女人。善男子善女人见已贪着。贪着故耗减萨婆若。不得书深般若波罗蜜乃至正忆念。当知是为魔事。何以故。是深般若波罗蜜中。无有色无有受想行识。乃至无阿耨多罗三藐三菩提。须菩提。是般若波罗蜜若无有色。乃至无阿耨多罗三藐三菩提。是中无佛无声闻无辟支佛无菩萨。何以故。一切诸法自性空故。复次须菩提。善男子善女人书是深般若波罗蜜。受读诵说正忆念时多有留难起。须菩提。譬如阎浮提中珍宝金银琉璃车磲玛瑙珊瑚等多难多贼。如是须菩提。善男子善女人。书是深般若波罗蜜乃至正忆念时。多贼多留难起。须菩提白佛言。如是世尊。阎浮提中珍宝金银琉璃车磲玛瑙珊瑚等多贼多难。世尊。善男子善女人亦如是。书是深般若波罗蜜乃至正忆念时。多留难起多有魔事。何以故。是愚痴人为魔所使。善男子善女人书是深般若波罗蜜。乃至正忆念时破坏令远离。世尊。是愚痴人少智少慧。是善男子善女人书深般若波罗蜜。乃至正忆念时。破坏令远离。是愚痴人心不乐大法。是故不书是深般若波罗蜜不受不读不诵。不正忆念不如说修行。亦坏他人令不得书深般若波罗蜜乃至如说修行。佛言。如是如是。须菩提。新发大乘意善男子善女人为魔所使。不种善根不供养诸佛。不随善知识故。不书深般若波罗蜜。乃至不正忆念而作留难。是善男子善女人少智少慧心不乐大法。是故不能书是深般若波罗蜜乃至正忆念。魔事起故。须菩提。若善男子善女人能书是深般若波罗蜜。乃至正忆念时魔事不起。能具足禅那波罗蜜乃至檀那波罗蜜。能具足四念处乃至一切种智。须菩提当知。佛力故是善男子善女人能书是深般若波罗蜜乃至正忆念。亦能具足禅那波罗蜜乃至檀那波罗蜜。具足内空乃至无法有法空。具足四念处乃至八圣道分佛十力乃至一切种智。须菩提。十方现在无量无边阿僧祇诸佛。亦助是善男子善女人。令得书是深般若波罗蜜乃至正忆念。十方阿惟越致诸菩萨摩诃萨亦拥护祐助是善男子善女人。书深般若波罗蜜乃至正忆念

    摩诃般若波罗蜜经佛母品第四十八

佛告须菩提。譬如母人有子若五若十若二十若三十若四十若五十若百若千。母中得病。诸子各各勤求救疗。作是念。我等云何令母安隐无诸苦患不乐之事。风寒冷热蚊虻蛇蚖侵犯母身是我等忧。其诸子等常求乐具供养其母。所以者何。生育我等示我世间。如是须菩提。佛常以佛眼视是深般若波罗蜜。何以故。是深般若波罗蜜能示世间相。十方现在诸佛亦以佛眼常视是深。般若波罗蜜。何以故。是深般若波罗蜜能生诸佛。能与诸佛一切智。能示世间相。以是故。诸佛常以佛眼视是深般若波罗蜜。又以般若波罗蜜能生禅那波罗蜜乃至檀那波罗蜜。能生内空乃至无法有法空。能生四念处乃至八圣道分。能生佛十力乃至一切种智。如是般若波罗蜜能生须陀洹斯陀含阿那含阿罗汉辟支佛诸佛。须菩提。所有诸佛已得阿耨多罗三藐三菩提今得当得。皆因深般若波罗蜜因缘故得。须菩提。若求佛道善男子善女人。当书是深般若波罗蜜乃至正忆念。诸佛常以佛眼视是人。须菩提。是求菩萨道善男子善女人。诸十方佛常守护。令不退阿耨多罗三藐三菩提。须菩提白佛言。如世尊所说。般若波罗蜜能生诸佛。能示世间相。世尊。般若波罗蜜云何能生诸佛云何能示世间相。云何诸佛从般若波罗蜜生。云何诸佛说世间相。佛告须菩提。是深般若波罗蜜中生佛十力乃至十八不共法一切种智。须菩提。得是诸法因缘故名为佛。须菩提。以是故深般若波罗蜜能生诸佛。须菩提。诸佛说五阴是世间相。须菩提言。世尊。云何深般若波罗蜜中说五阴相。云何深般若波罗蜜中示五阴如。须菩提。般若波罗蜜不示五阴破。不示五阴坏不示生不示灭。不示垢不示净。不示增不示减。不示入不示出。不示过去不示未来不示现在。何以故。空相不破不坏。无相相无作相不破不坏。不起法不生法无所有法性法不破不坏。相如是示。如是须菩提。佛说深般若波罗蜜能示世间相。复次须菩提。诸佛因般若波罗蜜。悉知无量无边阿僧祇众生心所行。须菩提。是深般若波罗蜜中。无众生无众生名。无色无色名。无受想行识无受想行识名。无眼乃至无意。无眼识乃至无意识。无眼触乃至无意触。乃至无一切种智。无一切种智名如是须菩提。是深般若波罗蜜能示世间相。须菩提。是深般若波罗蜜亦不示色。不示受想行识。乃至不示一切种智。何以故。须菩提。是深般若波罗蜜中尚无般若波罗蜜。何况色乃至一切种智。复次须菩提。所有众生名数。若有色若无色。若有想若无想。若非有想若非无想。若此间国土若遍十方国土。是诸众生若摄心若乱心。是摄心乱心佛如实知。须菩提。云何佛知众生摄心乱心相。以法相故知。用何等法相故知。须菩提。是法相中尚无法相相。何况有摄心乱心。须菩提。以是法相故。佛知众生摄心乱心。复次须菩提。佛知众生摄心乱心。云何知。须菩提。以尽相故知。以无染相故知。以灭相故知。以断相故知。以寂相故知。以离相故知。如是须菩提。佛因般若波罗蜜知众生摄心乱心。复次须菩提。佛因般若波罗蜜知众生染心。如实知染心嗔心痴心如实知嗔心痴心。须菩提白佛言。世尊。云何佛知众生染心。如实知染心。嗔心痴心如实知嗔心痴心。佛告须菩提。染心如实相则无染心相。何以故。如实相中心心数法尚不可得。何况当得染心不染心。须菩提。嗔心痴心如实相。则无嗔心无痴心相。何以故。如实相中心心数法尚不可得。何况当得嗔心不嗔心痴心不痴心。如是须菩提。佛因般若波罗蜜。众生染心如实知染心。嗔心痴心如实知嗔心痴心。复次须菩提。佛因般若波罗蜜。众生无染心。如实知无染心。无嗔心无痴心。如实知无嗔心无痴心。须菩提白佛言。世尊。云何众生无染心如实知无染心。无嗔心如实知无嗔心无痴心如实知无痴心。佛告须菩提。是心无染相中。染相不染相不可得。何以故。须菩提。二心不俱故。如是须菩提。佛因般若波罗蜜。众生无染心如实知无染心。须菩提。是无嗔心无痴心相中。痴心不痴心不可得。何以故。二心不俱故。如是须菩提。佛因般若波罗蜜。众生无嗔心无痴心如实知。复次须菩提。佛因般若波罗蜜。是众生广心如实知广心。须菩提白佛言。世尊。云何佛因般若波罗蜜。是众生广心如实知广心。须菩提。佛知诸众生心相不广不狭不增不减不来不去。心相离故是心不广不狭乃至不来不去。何以故。是心性无故。谁作广谁作狭乃至来去。如是须菩提。佛因般若波罗蜜。是众生广心如实知广心。复次须菩提。佛因般若波罗蜜。是众生大心如实知大心。须菩提白佛言。世尊。云何佛因般若波罗蜜。是众生大心如实知大心。佛告须菩提。佛因般若波罗蜜。不见众生心来相去相。不见众生心生相灭相住异相。何以故。是诸心性无故。谁来谁去谁生灭住异。如是须菩提。佛因般若波罗蜜。是众生大心如实知大心。复次须菩提。佛因般若波罗蜜。众生无量心如实知无量心。须菩提白佛言。世尊。云何佛因般若波罗蜜。众生无量心如实知无量心。佛告须菩提。佛因般若波罗蜜。知是众生心不见住不见不住。何以故。是无量心相无依止故。谁有住不住处。如是须菩提。佛因般若波罗蜜。众生无量心如实知无量心。复次须菩提。佛因般若波罗蜜。众生不可见心如实知不可见心。须菩提白佛言。世尊。云何佛因般若波罗蜜。众生不可见心如实知不可见心。佛告须菩提。众生心是无相。佛如实知无相。自相空故。复次须菩提。佛知众生心五眼不能见。如是须菩提。佛因般若波罗蜜。众生不可见心如实知不可见心。复次须菩提。佛因深般若波罗蜜。众生心数出没屈申如实知。世尊。云何佛因深般若波罗蜜。众生心数出没屈申如实知。佛言。一切众生心数出没屈申等。皆依色受想行识生。须菩提。佛于是中知众生心数出没屈申。所谓神及世间常。是事实余妄语。是见依色。神及世间无常。是事实余妄语。是见依色。神及世间常亦无常。是事实余妄语。是见依色。神及世间非常非无常。是事实余妄语。是见依色。神及世间常。是事实余妄语。是见依受。神及世间无常。是事实余妄语。是见依受。神及世间常亦无常。是事实余妄语。是见依受。神及世间非常非无常。是事实余妄语。是见依受。神及世间常。是事实余妄语。是见依想。神及世间无常。是事实余妄语。是见依想。神及世间常亦无常。是事实余妄语。是见依想。神及世间非常非无常。是事实余妄语。是见依想。神及世间常。是事实余妄语。是见依行。神及世间无常。是事实余妄语。是见依行。神及世间常亦无常。是事实余妄语。是见依行。神及世间非常非无常。是事实余妄语。是见依行。神及世间常。是事实余妄语。是见依识。神及世间无常。是事实余妄语。是见依识。神及世间常亦无常。是事实余妄语。是见依识。神及世间非常非无常。是事实余妄语。是见依识。世间有边。是事实余妄语。是见依色。世间无边。是事实余妄语。是见依色。世间有边无边。是事实余妄语。是见依色。世间非有边非无边。是事实余妄语。是见依色。依受想行识亦如是。神即是身是见依色。神异身异是见依色。依受想行识亦如是。死后有如去。是事实余妄语。是见依色。死后无如去。是事实余妄语。是见依色。死后或有如去或无如去。是事实余妄语。是见依色。死后非有如去非无如去。是事实余妄语。是见依色。依受想行识亦如是。如是须菩提。佛因般若波罗蜜。众生出没屈申如实知。复次须菩提。佛知色相。云何知色相。知色如如相不坏。无分别无相无忆无戏论无得。色相亦如是。须菩提。佛知受想行识相。云何知受想行识相知识如如相不坏。无分别无相无忆无戏论无得。受想行识相亦如是。如是须菩提。佛知众生如相及众生心数出没屈申如相。是五阴如相诸行如相。即是一切法如相。何等是一切法如相。所谓六波罗蜜如相。六波罗蜜如相即是三十七品如相。三十七品如相即是十八空如相。十八空如相即是八背舍如相。八背舍如相即是九次第定如相。九次第定如相即是佛十力如相。佛十力如相即是四无所畏四无碍智大慈大悲乃至十八不共法如相。十八不共法如相即是一切种智如相。一切种智如相即是善法不善法。世间法出世间法。有漏法无漏法如相。有漏法无漏法如相。即是过去未来现在诸法如相。过去未来现在诸法如相。即是有为法无为法如相。有为法无为法如相。即是须陀洹果如相。须陀洹果如相。即是斯陀含果如相。斯陀含果如相。即是阿那含果如相。阿那含果如相。即是阿罗汉果如相。阿罗汉果如相。即是辟支佛道如相。辟支佛道如相。即是阿耨多罗三藐三菩提如相。阿耨多罗三藐三菩提如相。即是诸佛如相。诸佛如相皆是一如相。不二不别不尽不坏。是名一切诸法如相。佛因般若波罗蜜得是如相。以是因缘故。般若波罗蜜能生诸佛能示世间相。如是须菩提。佛知一切法如相。非不如相不异相。得是如相故佛名如来。须菩提白佛言。世尊。是诸法如相。非不如相不异相甚深。世尊。诸佛用是如。为人说阿耨多罗三藐三菩提。世尊。谁能信解是者。唯有阿惟越致菩萨及具足正见人漏尽阿罗汉。何以故。佛得是甚深如法为人说故佛告须菩提。是如无尽相故甚深。须菩提言。何法无尽相故甚深。佛言。一切法无尽故。如是须菩提。佛得是一切诸法如已。为众生说

    摩诃般若波罗蜜经问相品第四十九

尔时三千大千世界中。所有欲界天子色界天子。遥散华香来至佛所。顶礼佛足却一面住。白佛言。世尊。所说般若波罗蜜甚深。何等是深般若波罗蜜相。佛告欲界色界诸天子。诸天子。空相是深般若波罗蜜相。无相无作无起无生无灭无垢无净。无所有法无相。无所依止虚空相。是深般若波罗蜜相。诸天子。如是等相是深般若波罗蜜相。佛为众生用世间法故说。非第一义。诸天子。如是诸相一切世间天人阿修罗不能破坏。何以故。是一切世间天人阿修罗。亦是相故。诸天子。相不能破相。相不能知相。相不能知无相无相不能知相。是相是无相。相无相皆无所有。谓知相知者知法皆不可得故。何以故。诸天子。是诸相非色作。非受想行识作。非檀那波罗蜜作。非尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜作。非内空作非外空作。非内外空作。非无法空作。非有法空作。非无法有法空作。非四念处作。乃至非一切种智作。诸天子。是相非人所有。非非人所有。非世间非出世间。非有漏非无漏。非有为非无为。佛复告诸天子。譬如有人问何等是虚空相。此人为正问不。诸天子言。世尊。此不正问。何以故。世尊。是虚空无有相可说。虚空无为无起故。佛告欲界色界诸天子。有佛无佛相性常住。佛得如实相性故。名为如来。诸天子白佛言。世尊。世尊所得诸相性甚深。得是相故得无碍智。住是相中以般若波罗蜜集诸法自相。诸天子言。希有世尊。是深般若波罗蜜是诸佛常所行道处。行是道得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。通达一切法相若色相若受想行识相。乃至一切种智相。佛言如是如是。诸天子。恼坏相是色相。佛得是无相。觉者受相。取者想相。起作者行相。了别者识相。佛得是无相。能舍者檀那波罗蜜相。无热恼者尸罗波罗蜜相。不变异者羼提波罗蜜相。不可伏者毗梨耶波罗蜜相。摄心者禅那波罗蜜相。舍离者般若波罗蜜相。佛得是无相。心无所娆恼者。是四禅四无量心四无色定相。佛得是无相。出世间者三十七品相。佛得是无相。苦者无作脱门相。集者空脱门相。寂灭者无相脱门相。佛得是无相。胜者十力相。不恐怖者无所畏相。遍知者四无碍智相。余人无得者十八不共法相。佛得是无相。愍念众生者大慈大悲相。实者无错谬相。无所取者常舍相。现了知者一切种智相。佛得是无相。如是诸天子。佛得一切诸法无相。以是因缘故。佛名无碍智。尔时佛告须菩提。般若波罗蜜是诸佛母。般若波罗蜜能示世间相。是故佛依止是法行。供养恭敬尊重赞叹是法。何等是法。所谓般若波罗蜜。诸佛依止般若波罗蜜住。恭敬供养尊重赞叹是般若波罗蜜。何以故。是般若波罗蜜出生诸佛。佛知作人。若人正问知作人者。正答无过于佛。何以故。须菩提。佛知作人故。须菩提。佛所乘来法佛所从来道。得阿耨多罗三藐三菩提是乘是道。佛还恭敬供养尊重赞叹受持守护。须菩提。是名佛知作人。复次须菩提。佛知一切法无作相。作者无所有故。一切法无起相。形事不可得故。须菩提。佛因般若波罗蜜知一切法无作相。以是因缘故佛知作人。复次须菩提。佛因般若波罗蜜得一切法不生以无所得故。以是因缘故。般若波罗蜜能生诸佛能示世间相。须菩提言。世尊。若一切法无知者无见者。云何般若波罗蜜能生诸佛能示世间相。佛告须菩提。如是如是。一切法实无知者无见者。云何无知者无见者。一切法空虚诳不坚固。是故一切法。无知者无见者。复次须菩提。一切法云何无知者无见者。一切法无依止无所系。以是故一切法无知者无见者。如是须菩提。般若波罗蜜能生诸佛能示世间相。不见色故示世间相。不见受想行识故示世间相。乃至不见一切种智故示世间相。如是须菩提。般若波罗蜜能生诸佛能示世间相。须菩提言。世尊。云何不见色故般若波罗蜜示世间相。不见受想行识乃至一切种智故示世间相。佛告须菩提。若不缘色生识。是名不见色相故示。不缘受想行识生识。乃至不缘一切种智生识。是名不见一切种智相故示。如是须菩提。是深般若波罗蜜能生诸佛能示世间相。复次须菩提。般若波罗蜜云何能生诸佛能示世间相。须菩提。般若波罗蜜示世间空。云何示世间空。示五阴世间空。示十二入世间空。示十八界世间空。示十二因缘世间空。示我见根本六十二见世间空。示十善道世间空。示四禅四无量心四无色定世间空。示三十七品世间空。示六波罗蜜世间空。示内空世间空。示外空世间空。示内外空世间空。示无法空世间空。示有法空世间空。示无法有法空世间空。示有为空世间空。示无为空世间空。示佛十力世间空。示十八不共法世间空。乃至示一切种智世间空。如是须菩提。般若波罗蜜能生诸佛能示世间相。复次须菩提。佛因是般若波罗蜜。示世间空。知世间空。觉世间空。思惟世间空。分别世间空。如是须菩提。般若波罗蜜能生诸佛能示世间相。复次须菩提。般若波罗蜜示佛世间空。云何示佛世间空。示五阴世间空。乃至示一切种智世间空。如是须菩提。般若波罗蜜能生诸佛能示世间相。复次须菩提。般若波罗蜜示佛世间不可思议。云何示世间不可思议。示五阴世间不可思议。乃至示一切种智世间不可思议。复次须菩提。般若波罗蜜示佛世间离。云何示世间离。示五阴世间离。乃至示一切种智世间离。如是须菩提。般若波罗蜜示佛世间离。复次须菩提。般若波罗蜜示佛世间寂灭。云何示世间寂灭。示五阴世间寂灭。乃至示一切种智世间寂灭。复次须菩提。般若波罗蜜示佛世间毕竟空。云何示世间毕竟空。示五阴世间毕竟空。乃至示一切种智世间毕竟空。复次须菩提。般若波罗蜜示佛世间性空。云何示世间性空。示五阴世间性空。乃至示一切种智世间性空。复次须菩提。般若波罗蜜示佛世间无法空。云何示世间无法空。示五阴世间无法空。乃至示一切种智世间无法空。复次须菩提。般若波罗蜜示世间有法空。云何示世间有法空。示五阴世间有法空。乃至示一切种智世间有法空。复次须菩提。般若波罗蜜示佛世间无法有法空。云何示世间无法有法空。示五阴世间无法有法空。乃至示一切种智世间无法有法空。复次须菩提。般若波罗蜜示佛世间独空。云何示世间独空。示五阴世间独空。乃至示一切种智世间独空。如是须菩提。般若波罗蜜能生诸佛能示佛世间相。须菩提。是深般若波罗蜜示世间相。所谓不生今世后世相。何以故。诸法无可用生今世后世相故。须菩提白佛言。世尊。是般若波罗蜜为大事故起。世尊。是般若波罗蜜为不可思议事故起。世尊。是般若波罗蜜为不可称事故起。世尊。是般若波罗蜜为无量事故起。世尊。是般若波罗蜜为无等等事故起。佛言。如是如是。须菩提。般若波罗蜜为大事故起。为不可思议事故起。为不可称事故起。为无量事故起。为无等等事故起。须菩提。云何是般若波罗蜜为大事故起。须菩提。诸佛大事者。所谓救一切众生。不舍一切众生。须菩提。云何是般若波罗蜜为不可思议事故起。须菩提。不可思议事者。所谓诸佛法如来法。自然人法。一切智人法。以是故。须菩提诸佛般若波罗蜜。为诸佛不可思议事故起。须菩提。云何般若波罗蜜为不可称事故起。须菩提。一切众生中。无有能思惟称佛法如来法自然人法一切智人法。以是故。须菩提。般若波罗蜜为不可称事故起。须菩提。云何般若波罗蜜为无量事故起。须菩提。一切众生中无有能量佛法如来法自然人法一切智人法。以是故。须菩提。般若波罗蜜为不可量事故起。须菩提。云何般若波罗蜜为无等等事故起。须菩提。一切众生中无有能与佛等者。何况过。以是故。须菩提。般若波罗蜜为无等等事故起。须菩提白佛言。世尊。但佛法如来法自然人法一切智人法。不可思议不可称无有量无等等事起耶。佛告须菩提。如是如是。佛法如来法自然人法一切智人法。不可思议不可称无有量无等等。色亦不可思议不可称无有量无等等。受想行识亦不可思议不可称无有量无等等。乃至一切种智法性法相。不可思议不可称无有量无等等。是中心心数法不可得。复次须菩提。色不可思议是亦不可得。乃至色无等等。是亦不可得。受想行识乃至一切种智无等等。是亦不可得。须菩提白佛言。世尊。何因缘色不可思议乃至无等等。是亦不可得。受想行识乃至一切种智无等等。是亦不可得。佛语须菩提。色量不可得故。受想行识量不可得故。乃至一切种智量不可得故。须菩提白佛言。世尊。何因缘色量不可得。乃至一切种智量不可得。佛告须菩提。色不可思议故。乃至色无等等故。量不可得。乃至一切种智不可思议故。乃至一切种智无等等故。量不可得。须菩提。于汝意云何。不可思议乃至无等等。宁可得不。色受想行识乃至一切种智可得不。须菩提言。世尊。不可得。以是故。须菩提。一切法不可思议乃至无等等亦如是。须菩提。诸佛法不可思议不可称无有量无等等。须菩提。是名诸佛法不可思议乃至无等等。须菩提。是诸佛法不可思议过思议相故。不可称过称故。无有量过量故。无等等过等等故。须菩提。是因缘故。一切法亦不可思议乃至无等等。须菩提。不可思议。名是义不可思议。不可称。名是义不可称。无有量。名是义不可量。无等等。名是义无等等。须菩提。是诸佛法不可思议乃至无等等。不可思义如虚空不可思识。不可称如虚空不可称。无有量如虚空无有量。无等等如虚空无等等。须菩提。是亦名诸佛法不可思议乃至无等等。佛法如是无量。一切世间天及人阿修罗。无能思议筹量者。说是诸佛法不可思议不可称无有量无等等品时。五百比丘一切法不受故。漏尽心解脱得阿罗汉。二十(丹千)比丘尼亦不受一切法故漏尽得阿罗汉。六万优婆塞三万优婆夷诸法中远尘离垢。诸法中法眼生。二十(丹千)万菩萨摩诃萨得无生法忍。于是贤劫中当受记

摩诃般若波罗蜜经卷第十四复次须菩提。色不可得故不可思议。乃至色不可得故无等等。受想行识不可得故不可思议。乃至识不可得故无等等。乃至一切种智不可得故不可思议。乃至一切种智不可得故无等等。须菩提白佛言。世尊。何因缘色不可得故不可思议。乃至无等等。受想行识不可得故不可思议。乃至无等等。乃至一切种智不可得故不可思议。乃至无等等。佛告须菩提。色无能量故不可得。受想行识无能量故不可得。乃至一切种智无能量故不可得。须菩提白佛言。世尊。何因缘色无能量故不可得。乃至一切种智无能量故不可得。佛告须菩提。色相不可思议故无能量。乃至色相无等等故无能量。乃至一切种智相不可思议故无能量。乃至一切种智相无等等故无能量摩诃般若波罗蜜经卷第十五

        后秦龟兹国三藏鸠摩罗什译

    成办品第五十(丹本大事起品)

尔时须菩提白佛言。世尊。是深般若波罗蜜为大事故起。不可思议事故起。不可称事故起。无有量事故起。世尊。是深般若波罗蜜无等等事故起。佛告须菩提。如是如是。是深般若波罗蜜为大事故起。乃至无等等事故起。何以故。般若波罗蜜中含受五波罗蜜。般若波罗蜜中含受内空外空乃至无法有法空。含受四念处乃至八圣道分。是深般若波罗蜜中含受佛十力乃至一切种智。譬如灌顶王国土中尊。诸有官事皆委大臣。国王安乐无事自恣。如是须菩提所有声闻辟支佛法若菩萨法若佛法。一切皆在般若波罗蜜中。般若波罗蜜能成办其事。以是故须菩提。般若波罗蜜为大事故起。乃至无等等事故起。复次须菩提。是般若波罗蜜。不取色不着色故能成办受想行识不取不着故能成辨。乃至一切种智不取不着故能成办。须陀洹果乃至阿罗汉果辟支佛道。乃至阿耨多罗三藐三菩提。不取不着故能成办。须菩提白佛言。云何色不取不着故。般若波罗蜜能成办。云何受想行识乃至阿耨多罗三藐三菩提不取不着故。般若波罗蜜能成办。佛告须菩提。于汝意云何。颇见是色可取。可着不。须菩提言。不也世尊。须菩提。于汝意云何。颇见受想行识乃至阿耨多罗三藐三菩提可取可着不。须菩提言。不也世尊。佛言。善哉善哉。须菩提。我亦不见是色可取可着。不见故不取。不取故不着。我亦不见受想行识乃至阿耨多罗三藐三菩提及一切种智可取可着。不见故不取。不取故不着。须菩提。我亦不见佛法如来法自然人法一切智人法可取可着。不见故不取。不取故不着。以是故。须菩提。诸菩萨摩诃萨色亦不应取亦不应着。受想行识乃至佛法如来法。自然人法一切智人法。亦不应取亦不应着。尔时欲界色界诸天子白佛言。世尊。是般若波罗蜜甚深难见难解。不可思惟比类知。微妙善巧智慧寂灭者可知。能信是般若波罗蜜者当知是菩萨多供养诸佛多种善根。与善知识相随能信解深般若波罗蜜。世尊。若三千大千世界中所有众生。皆作信行法行人八人须陀洹斯陀含阿那含阿罗汉辟支佛若智若断。不如是菩萨一日行深般若波罗蜜忍欲思惟筹量。何以故。是信行法行人八人须陀洹斯陀含阿那含阿罗汉辟支佛若智若断。即是菩萨摩诃萨无生法忍。佛告欲色界诸天子。如是如是。诸天子。若信行法行人八人须陀洹乃至阿罗汉辟支佛。即是菩萨摩诃萨无生法忍。诸天子。若善男子善女人闻是深般若波罗蜜。书持受读诵说正忆念。是善男子善女人疾得涅槃。胜求声闻辟支佛乘善男子善女人。远离深般若波罗蜜。行余经若一劫若减一劫。何以故。是深般若波罗蜜中广说上妙法。是信行法行人八人须陀洹斯陀含阿那含阿罗汉辟支佛所应学菩萨摩诃萨亦所应学。学已得阿耨多罗三藐三菩提。是时欲色界诸天子。俱发声言。世尊。是般若波罗蜜名摩诃波罗蜜。世尊。是般若波罗蜜名不可思议不可称无有量无等等波罗蜜。信行法行人八人学是深般若波罗蜜。得成须陀洹斯陀含阿那含阿罗汉辟支佛。学是深般若波罗蜜。得成菩萨摩诃萨。是深般若波罗蜜中学得阿耨多罗三藐三菩提。是深般若波罗蜜亦不增亦不减。是时欲色界诸天子。顶礼佛足绕佛而去。去是不远忽然不现各还本处。须菩提白佛言。世尊。若菩萨摩诃萨闻是深般若波罗蜜。即时信解者从何处终来生是间。佛告须菩提。若菩萨摩诃萨闻是深般若波罗蜜。即时信解不没不却不难不疑不悔欢喜乐听。听已忆念不远离是深般若波罗蜜。若行若住若坐若卧。终不废忘常随法师。譬如新生犊子不离其母。菩萨摩诃萨亦如是。为闻深般若波罗蜜故终不远离法师。乃至得是深般若波罗蜜。口诵心解正见通达。须菩提。当知是菩萨从人道中终还生是间人中。何以故。是求佛道者。前世时闻深般若波罗蜜。书持恭敬尊重赞叹华香乃至幡盖供养。以是因缘故。人中命终。还生人中。闻是深般若波罗蜜即时信解。须菩提白佛言。世尊。颇有菩萨摩诃萨如是功德成就。他方国土供养诸佛。于彼命终来生是间。闻深般若波罗蜜即时信解。书持读诵正忆念有是者不。佛言有。菩萨如是功德成就。他方国土供养诸佛。于彼命终来生是间。闻是深般若波罗蜜即时信解。书持读诵正忆念。何以故。是菩萨摩诃萨从他方诸佛所。闻是深般若波罗蜜信解书持读诵说正忆念。于彼间终来生此间。当知是人是先世功德成就。复次须菩提。有菩萨从弥勒菩萨摩诃萨。闻是深般若波罗蜜。以是善根因缘故来生此间。须菩提。复有菩萨摩诃萨前世时。虽闻深般若波罗蜜。不问中事。来生人中闻是深般若波罗蜜心有疑悔难悟。须菩提。如是菩萨当知先世虽闻是深般若波罗蜜。不问故今续疑悔难悟。须菩提。若菩萨先世虽闻禅那波罗蜜不问中事。今世闻般若波罗蜜时。不问故续生疑悔。须菩提。若菩萨先世虽闻毗梨耶波罗蜜不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世虽闻羼提波罗蜜不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世虽闻尸罗波罗蜜不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世虽闻檀那波罗蜜不问中事。今世闻般若波罗蜜。不问故续复疑悔。复次须菩提。菩萨摩诃萨先世虽闻内空外空内外空乃至无法有法空不问中事。来生人中闻是深般若波罗蜜。不问故续复疑悔难悟。复次须菩提。菩萨摩诃萨先世虽闻四念处乃至八圣道分四禅四无量心四无色定五神通佛十力乃至一切种智不问中事。来生人中闻是深般若波罗蜜。不问故续复疑悔难悟。复次须菩提。菩萨摩诃萨先世闻深般若波罗蜜。问中事而不行。舍身生时闻是深般若波罗蜜。若一日二日三日四日五日。其心坚固无能坏者。若离所闻时便退失。何以故。先世闻是深般若波罗蜜时。虽问中事不如说行。是人或时欲闻或时不欲闻。心轻不固志乱不定。譬如轻毛随风东西。须菩提。当知是菩萨发意不久。不与善知识相随。不多供养诸佛。先世不书是深般若波罗蜜。不读不诵不正忆念。不学般若波罗蜜。不学禅那波罗蜜。不学毗梨耶波罗蜜。不学羼提波罗蜜。不学尸罗波罗蜜。不学檀那波罗蜜。不学内空乃至无法有法空。不学四念处乃至八圣道分。不学四禅四无量心五神通佛十力。乃至不学一切种智。如是须菩提。当知是菩萨摩诃萨。新发大乘意少信少乐故。不能书是深般若波罗蜜。不能受持读诵说正忆念。须菩提。若求佛道善男子善女人。不书是深般若波罗蜜。不受持读诵不说不正忆念。亦不为深般若波罗蜜所护。乃至不为一切种智所护。是人亦不如说行深般若波罗蜜乃至不如说行一切种智。是人或堕二地。若声闻地若辟支佛地。何以故。是善男子善女人不书是深般若波罗蜜。不读不诵不说不正忆念。是人亦不为深般若波罗蜜所护。亦不如说行。以是故。是善男子善女人于二地中当堕一地

    摩诃般若波罗蜜经譬喻品第五十一

佛告须菩提。譬如大海中船破坏。其中人若不取木不取器物。不取浮囊不取死尸。须菩提。当知是人不到彼岸没海中死。须菩提。若船破时其中人取木取器物浮囊死尸。当知是人终不没死。安隐无碍得到彼岸。须菩提。求佛道善男子善女人亦复如是。若但有信乐不依深般若波罗蜜。不书不读不诵不正忆念。不依禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。不书不读不诵不正忆念。乃至不依一切种智。不书不读不诵不正忆念。须菩提。当知是善男子。中道衰耗是人未到一切种智。于声闻辟支佛地取证。须菩提。若有求佛道善男子善女人。为阿耨多罗三藐三菩提故。有信有忍有净心有深心。有欲有解有舍有精进。是人依深般若波罗蜜书持读诵说正忆念。是善男子善女人为阿耨多罗三藐三菩提故。有诸信忍净心深心欲解舍精进。为深般若波罗蜜所护。乃至一切种智所护。为深般若波罗蜜守护故。乃至一切种智守护故。终不中道衰耗过声闻辟支佛地。能净佛国土成就众生。当得阿耨多罗三藐三菩提。须菩提。譬如男子女人持坏瓶取水。当知是瓶不久烂坏。何以故。是瓶未熟故还归于地。如是须菩提。善男子善女人虽有为阿耨多罗三藐三菩提心。有信有忍有净心有深心有欲有解有舍有精进不为般若波罗蜜方便力所守护。不为禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜所守护。不为内空乃至无法有法空四念处乃至八圣道分佛十力乃至一切种智所守护。须菩提。当知是人中道衰耗堕声闻辟支佛地。须菩提。譬如男子女人持熟瓶取水若河若井若池若泉。当知是瓶持水安隐。何以故。是瓶成熟故。如是须菩提。善男子善女人求阿耨多罗三藐三菩提。有诸信忍净心深心欲解舍精进。为般若波罗蜜方便力所护。为禅定精进忍辱持戒布施乃至一切种智所护故。须菩提。当知是人不中道衰耗过声闻辟支佛地。能净佛国土成就众生得阿耨多罗三藐三菩提。须菩提。譬如大海边船未装治。便持财物着上。须菩提。当知是船中道坏没。人船财物各在一处。是贾客无方便力故亡其重宝。如是须菩提。是求佛道善男子善女人。虽有为阿耨多罗三藐三菩提心。有信忍净心深心欲解舍精进。不为般若波罗蜜方便力所守护。乃至不为一切种智所守护故。当知是人中道衰耗失大珍宝。大珍宝者所谓一切种智。衰耗者堕声闻辟支佛地。须菩提。譬如人有智方便装治海边大船然后推着水中。持财物着上上船而去。当知是船不中道没坏。必得安隐到所至处。如是须菩提。善男子善女人为阿耨多罗三藐三菩提有信忍净心深心欲解舍精进。为般若波罗蜜方便力所守护。为禅定精进忍辱持戒布施乃至一切种智所护故。当知是菩萨得到阿耨多罗三藐三菩提。不中道堕声闻辟支佛地。须菩提。譬如有人年百二十岁年耆根熟。又有风冷热病若杂病。须菩提。于汝意云何。是人能从床起不。须菩提言。不能。佛言。是人或有能起者云何。须菩提言。是人虽能起不能远行若十里若二十里。以其老病故。如是须菩提。善男子善女人虽有为阿耨多罗三藐三菩提心有信忍净心深心欲解舍精进不为般若波罗蜜方便力所守护。乃至不为一切种智所守护故。当知是人中道堕声闻辟支佛地。何以故。不为般若波罗蜜方便力所守护故。须菩提。如向老人百二十岁年耆根熟。又有风冷热病若杂病。是人而欲起行有两健人各扶一掖。语老人言。莫有所难随所欲至我等二人终不相舍。如是须菩提。若善男子善女人为阿耨多罗三藐三菩提。有信忍净心深心欲解舍精进。为般若波罗蜜方便力所护。乃至为一切种智所护。当知是人不中道堕声闻辟支佛地能到是处。所谓阿耨多罗三藐三菩提。尔时佛复赞须菩提言。善哉善哉。须菩提。汝为诸菩萨摩诃萨问佛是事。须菩提。若有求佛道善男子善女人。从初发意已来以我我所心。布施持戒忍辱精进禅定智慧。是善男子善女人布施时作是念。我是施主我施是人我施是物。我持戒我修忍辱我精进我入禅我修智慧。是善男子善女人念有是施是我施。乃至念有是慧是我慧。何以故。檀那波罗蜜中无如是分别。远离此彼岸。是檀那波罗蜜相尸波罗罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜中。无如是分别。何以故。远离此彼岸是般若波罗蜜相。是人不知此岸不知彼岸。是人不为檀那波罗蜜。乃至不为一切种智所护故。堕声闻辟支佛地不能到萨婆若。须菩提。云何求佛道人无方便。须菩提。求佛道人从初发心以来。无方便行布施持戒忍辱精进禅定修智慧。是人作如是念。我布施施是人以是物施。我持戒修忍辱勤精进入禅定修智慧。如是修智慧。是人念有是施是我施以是施自高。念有是戒是我戒以是戒自高。念有是忍是我忍以是忍自高。念有是精进是我精进以是精进自高。念有是禅定是我禅定以是禅定自高。念有是慧是我慧以是慧自高。何以故。檀那波罗蜜中无如是分别。远离此彼岸是檀那波罗蜜相。远离此彼岸是尸罗波罗蜜相。远离此彼岸是羼提波罗蜜相。远离此彼岸是毗梨耶波罗蜜相。远离此彼岸是禅那波罗蜜相。远离此彼岸是般若波罗蜜相。何以故。般若波罗蜜中无是忆念分别。是求佛道善男子善女人。不知此岸不知彼岸。是人不为檀那波罗蜜所护。不为尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜所护。乃至不为一切种智所护故。或堕声闻道中或堕辟支佛道中不能得到萨婆若。如是须菩提。菩萨摩诃萨不为般若波罗蜜方便力所守护故。或堕声闻地或堕辟支佛地。须菩提。云何菩萨摩诃萨为般若波罗蜜方便力所护故。不堕声闻辟支佛道中疾得阿耨多罗三藐三菩提。须菩提。菩萨从初已来以方便力布施无我我所心布施。乃至无我我所心修智慧。是人不作是念。我有是施是我施。不以是施自高。乃至般若波罗蜜亦如是。是菩萨不念我布施。不念我施是人用是物施。不念我持戒有是戒。不念我忍辱有是忍辱。不念我精进有是精进。不念我禅定有是禅定。不念我修智慧有是智慧。何以故。是檀那波罗蜜中无如是分别。远离此彼岸是檀那波罗蜜相。远离此彼岸是尸罗波罗蜜相。远离此彼岸是羼提波罗蜜相。远离此彼岸是毗梨耶波罗蜜相。远离此彼岸是禅那波罗蜜相。远离此彼岸是般若波罗蜜相。何以故。是般若波罗蜜中无如是忆念分别。是菩萨摩诃萨知此岸知彼岸是人为檀那波罗蜜所护。为尸罗波罗蜜所护。为羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜所护。乃至为一切种智所护故。不堕声闻辟支佛地得到萨婆若。如是须菩提。菩萨摩诃萨为般若波罗蜜方便力所护故。不堕声闻辟支佛地疾得阿耨多罗三藐三菩提

    摩诃般若波罗蜜经知识品第五十二

尔时慧命须菩提白佛言。世尊。新学菩萨摩诃萨。云何应学般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。佛告须菩提。新学菩萨摩诃萨若欲学般若波罗蜜禅那精进忍辱持戒檀那波罗蜜。先当亲近供养善知识能说是深般若波罗蜜者。是人作是教。汝善男子。所有布施一切回向阿耨多罗三藐三菩提。善男子。所有持戒忍辱精进禅定智慧。一切回向阿耨多罗三藐三菩提。汝莫以色是阿耨多罗三藐三菩提。莫以受想行识是阿耨多罗三藐三菩提。莫以檀那波罗蜜是阿耨多罗三藐三菩提莫以尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜是阿耨多罗三藐三菩提。莫以内空乃至无法有法空是阿耨多罗三藐三菩提。莫以四念处四正勤四如意足五根五力七觉分八圣道分是阿耨多罗三藐三菩提。莫以四禅四无量心四无色定五神通是阿耨多罗三藐三菩提。莫以佛十力乃至十八不共法是阿耨多罗三藐三菩提。所以者何。不取色便得阿耨多罗三藐三菩提。不取受想行识便得阿耨多罗三藐三菩提。不取檀那波罗蜜乃至般若波罗蜜便得阿耨多罗三藐三菩提。不取内空乃至无法有法空四念处乃至十八不共法。便得阿耨多罗三藐三菩提。善男子。行是深般若波罗蜜时莫贪色。何以故。善男子。是色非可贪者。莫贪受想行识。何以故。受想行识非可贪者。善男子。莫贪檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。莫贪内空乃至无法有法空。莫贪四念处乃至八圣道分。莫贪四禅四无量心四无色定五神通。莫贪佛十力乃至一切种智。何以故。一切种智非可贪者。善男子。莫贪须陀洹果乃至阿罗汉果。莫贪辟支佛道。莫贪菩萨法位。莫贪阿耨多罗三藐三菩提。何以故。阿耨多罗三藐三菩提非可贪者。所以者何。诸法性空故。须菩提白佛言。世尊。诸菩萨摩诃萨能为难事。于一切性空法中求阿耨多罗三藐三菩提。欲得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。菩萨摩诃萨能为难事。于一切性空法中求阿耨多罗三藐三菩提。欲得阿耨多罗三藐三菩提。须菩提。诸菩萨摩诃萨为安隐世间故。发阿耨多罗三藐三菩提心。为乐世间故为救世间故。为世间归故为世间依处故。为世间洲故为世间究竟道故。为世间将导故为世间趣故。发阿耨多罗三藐三菩提心。须菩提。云何菩萨摩诃萨为安隐世间故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出六道众生着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为安隐世间故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为乐世间故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出众生种种忧苦愁恼。着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为乐世间故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为救世间故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。救众生生死中种种苦。亦为断是苦故而为说法。众生闻法渐以三乘而得度脱。须菩提。是为菩萨摩诃萨为救世间故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间归故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出众生生老病死相忧悲愁恼法。着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为世间归故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间依处故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说一切法无依处。须菩提。是为菩萨摩诃萨为世间依处故发阿耨多罗三藐三菩提心。须菩提白佛言。世尊。云何一切法无依处。佛言。色不相续即是色无生。色无生即是色不灭。色无灭即是色无依处。受想行识乃至一切种智亦如是。须菩提。是为菩萨摩诃萨为世间依处故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间究竟道故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说如是法。色究竟相非是色。受想行识乃至一切种智究竟相非是一切种智。须菩提。如究竟相一切法相亦如是。须菩提言。世尊。若一切法相如究竟相者。云何诸菩萨摩诃萨皆应得阿耨多罗三藐三菩提。何以故。世尊。色究竟相中无有分别。受想行识究竟相中无有分别。乃至一切种智究竟相中无有分别。所谓是色是受想行识。乃至是一切种智。佛告须菩提。如是如是。色究竟相中无有分别。受想行识乃至一切种智究竟相中无有分别。所谓是色乃至是一切种智。须菩提。是为菩萨摩诃萨难事。如是观诸法寂灭相而心不没不却。何以故。菩萨摩诃萨作是念。是诸深法我应如是知得阿耨多罗三藐三菩提。如是寂灭微妙法当为众生说。是为菩萨摩诃萨为世间究竟道故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间洲故。发阿耨多罗三藐三菩提心。须菩提。譬如江河大海四边水断是名为洲。须菩提。色亦如是前后际断。受想行识前后际断。乃至一切种智前后际断。以是前后际断故一切法亦断。须菩提。是一切法前后际断故。即是寂灭即是妙宝。所谓空无所得爱尽无余离欲涅槃。须菩提。若菩萨摩诃萨得阿耨多罗三藐三菩提时。以寂灭微妙法为众生说。须菩提。是为菩萨摩诃萨为世间洲故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间将导故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说色不生不灭不垢不净。说受想行识不生不灭不垢不净。说十二入十八界四念处乃至八圣道分四禅四无量心四无色定五神通不生不灭不垢不净。说须陀洹果乃至阿罗汉果辟支佛道不生不灭不垢不净。说佛十力乃至一切种智不生不灭不垢不净。须菩提。是为菩萨摩诃萨为世间将导故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间趣故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说色趣空。说受想行识趣空。乃至说一切种智趣空。为众生说色非趣非不趣。何以故。是色空相非趣非不趣。说受想行识非趣非不趣。何以故。是受想行识空相非趣非不趣。乃至一切种智非趣非不趣。何以故。是一切种智空相非趣非不趣。如是须菩提。菩萨摩诃萨为世间趣故。发阿耨多罗三藐三菩提心。何以故。一切法趣空是趣不过。何以故。空中趣不趣不可得故。须菩提。一切法趣无相是趣不过。何以故。无相中趣不趣不可得故。须菩提。一切法趣无作是趣不过。何以故。无作中趣不趣不可得故。须菩提。一切法趣无起是趣不过。何以故。无起中趣不趣不可得故。须菩提。一切法趣无所有。不生不灭不垢不净是趣不过。何以故。无所有不生不灭不垢不净中。趣不趣不可得故。须菩提。一切法趣梦是趣不过。何以故。梦中趣不趣不可得故。须菩提。一切法趣幻趣响趣影趣化是趣不过。何以故。是化等中趣不趣不可得故。须菩提。一切法趣无量无边是趣不过。何以故。无量无边中趣不趣不可得故。须菩提。一切法趣不与不取是趣不过。何以故。不与不取中趣非趣不可得故。须菩提。一切法趣不举不下是趣不过。何以故。不举不下中趣不趣不可得故。须菩提。一切法趣不来不去是趣不过。何以故。不来不去中趣不趣不可得故。须菩提。一切法趣不入不出。不合不散不着不断是趣不过。何以故。不着不断中趣不趣不可得故。须菩提。一切法趣我众生寿命人起使起作使作者知者见者是趣不过。何以故。我乃至知者见者毕竟不可得。云何当有趣不趣。须菩提。一切法趣有常是趣不过。何以故。有常毕竟不可得。云何当有趣不趣。须菩提。一切法趣乐净我是趣不过。何以故。乐净我毕竟不可得。云何当有趣不趣。须菩提。一切法趣无常苦不净无我是趣不过。何以故。无常苦不净无我毕竟不可得。云何当有趣不趣。须菩提。一切法趣欲事是趣不过。何以故。欲事毕竟不可得。云何当有趣不趣。须菩提。一切法趣嗔事痴事见事是趣不过。何以故。嗔事痴事见事毕竟不可得。云何当有趣不趣。须菩提。一切法趣如是趣不过。何以故。如中无来无去故。须菩提。一切法趣法性实际不可思议性是趣不过。何以故。法性实际不可思议性中无来无去故。须菩提。一切法趣平等是趣不过。何以故。平等中趣非趣不可得故。须菩提。一切法趣不动相是趣不过。何以故。不动相中趣不趣不可得故。须菩提。一切法趣色是趣不过。何以故。色毕竟不可得。云何当有趣不趣。须菩提。一切法趣受想行识是趣不过。何以故。受想行识毕竟不可得。云何当有趣不趣。十二入十八界亦如是。须菩提。一切法趣檀那波罗蜜是趣不过。何以故。檀那毕竟不可得。云何当有趣不趣。须菩提。一切法趣尸罗波罗蜜是趣不过。何以故。尸罗毕竟不可得故。云何当有趣不趣。须菩提。一切法趣羼提波罗蜜是趣不过。何以故。羼提毕竟不可得故。云何当有趣不趣。须菩提。一切法趣毗梨耶波罗蜜是趣不过。何以故。毗梨耶毕竟不可得故。云何当有趣不趣。须菩提。一切法趣禅那波罗蜜是趣不过。何以故。禅那毕竟不可得故。云何当有趣不趣。须菩提。一切法趣般若波罗蜜是趣不过。何以故。般若波罗蜜毕竟不可得故。云何当有趣不趣。须菩提。一切法趣内空是趣不过。何以故。内空毕竟不可得故。云何当有趣不趣。须菩提。一切法趣外空是趣不过。何以故。外空毕竟不可得故。云何当有趣不趣。须菩提。一切法趣内外空是趣不过。何以故。内外空毕竟不可得故。云何当有趣不趣。乃至一切法趣无法有法空是趣不过。何以故。无法有法空毕竟不可得故。云何当有趣不趣。须菩提。一切法趣四念处乃至八圣道分是趣不过。何以故。四念处乃至八圣道分毕竟不可得故。云何当有趣不趣。须菩提。一切法趣佛十力乃至一切种智是趣不过。何以故。一切种智中趣不趣不可得故。须菩提。一切法趣须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道是趣不过。何以故。须陀洹果乃至辟支佛道中趣不趣不可得故。须菩提。一切法趣阿耨多罗三藐三菩提是趣不过。何以故。阿耨多罗三藐三菩提中趣不趣不可得故。须菩提。一切法趣须陀洹乃至佛是趣不过。何以故。须陀洹乃至佛中趣不趣不可得故。须菩提白佛言。世尊。是深般若波罗蜜谁能信解者。佛告须菩提。有菩萨摩诃萨。先于诸佛所久行六波罗蜜善根纯熟。供养无数百千万亿诸佛。与善知识相随。是辈人能信解是深般若波罗蜜。须菩提白佛言。世尊。能信解是深般若波罗蜜者。有何等性何等相何等貌。佛言。欲嗔痴断离是性相貌。是菩萨摩诃萨则能信解深般若波罗蜜

    摩诃般若波罗蜜经趣智品第五十三

须菩提白佛言。世尊。是诸菩萨摩诃萨解深般若波罗蜜者。当趣何所。佛告须菩提。是菩萨摩诃萨解深般若波罗蜜当趣一切种智。须菩提白佛言。世尊。是菩萨摩诃萨能趣一切种智者。则为一切众生所归趣修般若波罗蜜故。世尊修般若波罗蜜即是修一切法。世尊。无所修是修般若波罗蜜。不受修坏修是修般若波罗蜜。佛告须菩提。何法坏故。般若波罗蜜为坏修。世尊。色坏故般若波罗蜜为坏修。受想行识十二处十八界坏故。般若波罗蜜为坏修。我乃至知者见者坏故。般若波罗蜜为坏修。世尊。檀那波罗蜜坏故。般若波罗蜜为坏修。乃至般若波罗蜜坏故。般若波罗蜜为坏修。内空乃至无法有法空。四念处乃至十八不共法。须陀洹果乃至一切种智坏故。般若波罗蜜为坏修。佛言。如是如是。须菩提。色坏故般若波罗蜜为坏修。乃至一切种智坏故。般若波罗蜜为坏修。尔时佛告须菩提。是深般若波罗蜜中阿惟越致菩萨摩诃萨应当验知。若菩萨摩诃萨于是深般若波罗蜜中不着。当知是阿惟越致相禅那波罗蜜乃至檀那波罗蜜中不着。四念处乃至一切种智中不着。当知是阿惟越致。若阿惟越致菩萨摩诃萨行深般若波罗蜜时。不以他语为坚要。亦不随他教行。阿惟越致菩萨摩诃萨不为欲心嗔心痴心所牵。若阿惟越致菩萨摩诃萨不远离六波罗蜜。若阿惟越致菩萨摩诃萨闻说深般若波罗蜜时。心不惊不没不怖不畏不悔。欢喜乐闻受持读诵正忆念如说行。须菩提。当知是菩萨先世已问是深般若波罗蜜中事已受持读诵说正忆念。何以故。是菩萨摩诃萨有大威德故。闻是深般若波罗蜜心不惊不怖不畏不没不悔。欢喜乐闻受持读诵正忆念。须菩提白佛言。世尊。若菩萨摩诃萨闻深般若波罗蜜。不惊不怖乃至正忆念。世尊。是菩萨摩诃萨云何行是般若波罗蜜。佛言。随顺一切种智心。是菩萨摩诃萨应如是行般若波罗蜜。世尊云何名随顺一切种智心。是菩萨摩诃萨应如是行般若波罗蜜。佛言。以空随顺。是为菩萨摩诃萨行深般若波罗蜜。以无相无作无所有不生不灭不垢不净随顺。是菩萨摩诃萨应如是行般若波罗蜜。以如梦幻焰响化随顺。是行般若波罗蜜。须菩提白佛言。佛说以空随顺乃至如梦如幻随顺。是行般若波罗蜜。世尊。是菩萨摩诃萨行何法。若色若受想行识乃至一切种智。佛告须菩提。菩萨摩诃萨不行色不行受想行识。乃至不行一切种智。何以故。是菩萨行处无作法无坏法。无所从来亦无所去无住处。是法不可数无有量。若无数无量是法不可得。不可以色得乃至不可以一切种智得。何以故。色即是萨婆若。萨婆若即是色。乃至一切种智即是萨婆若。萨婆若即是一切种智若色如相乃至一切种智如相。皆是一如无二无别。色如相萨婆若如相。一如无二无别。乃至一切种智亦如是

摩诃般若波罗蜜经卷第十五天监十一年壬辰岁使持节散骑常侍都尉江州诸军镇南将军开府仪同三司江州刺吏建安王萧伟敬造众经一千卷流通愿神徽鉴于六道清猷□□□□□明灵聿辅景福咸臻深信坚明大悲增上照[王*眾]中之奥理得象□□□□□情舍身命财护持正修菩提行专向一乘苞举群生导达形□□□□□真实相俱憩道场摩诃般若波罗蜜经卷第十六

        后秦龟兹国三藏鸠摩罗什译

    大如品第五十四(丹本大如相品)

尔时欲界诸天子色界诸天子。以天末栴檀香。以天青莲华赤莲华红莲华白莲华遥散佛上。来至佛所顶礼佛足一面住白佛言。世尊。诸佛阿耨多罗三藐三菩提。甚深难见难解不可思惟知。微妙寂灭智者能知。一切世间所不能信。何以故。是深般若波罗蜜中如是说。色即是萨婆若。萨婆若即是色。乃至一切种智即是萨婆若。萨婆若即是一切种智。色如相萨婆若如相。是一如无二无别。乃至一切种智如相萨婆若如相。一如无二无别。佛告欲色界诸天子。如是如是。诸天子。色即是萨婆若。萨婆若即是色。乃至一切种智即是萨婆若。萨婆若即是一切种智。色如相乃至一切种智如相。一如无二无别。诸天子。以是义故佛初成道时。心乐默然不乐说法。何以故。是诸佛阿耨多罗三藐三菩提法甚深难见难解不可思惟知。微妙寂灭智者能知。一切世间所不能信。何以故。阿耨多罗三藐三菩提。无得者无得处无得时。是名诸法甚深相。所谓无有二法。诸天子。如虚空甚深故是法甚深。如甚深故是法甚深。法性甚深实际甚深。不可思议无边甚深故是法甚深。无来无去甚深故是法甚深。不生不灭无垢无净无知无得甚深故是法甚深。诸天子。我甚深乃至知者见者甚深故是法甚深。诸天子。色甚深受想行识甚深故是法甚深。檀那波罗蜜甚深乃至般若波罗蜜甚深故是法甚深。内空乃至无法有法空甚深故是法甚深四念处甚深乃至一切种智甚深故是法甚深。尔时欲色界诸天子白佛言。世尊。是所说法一切世间所不能信。世尊。是甚深法不为受色故说。不为舍色故说。不为受受想行识故说。不为舍受想行识故说。不为受须陀洹果故说。不为舍须陀洹果故说。乃至不为受一切种智故说。不为舍一切种智故说。说诸世间皆受着行。所谓色是我是我所。受想行识是我是我所。乃至十八不共法是我是我所。须陀洹果是我是我所。乃至一切种智是我是我所。佛告诸天子。如是如是。诸天子。是法非为受色故说。非为舍色故说。乃至非为受一切种智故说。非为舍一切种智故说。诸天子。若有菩萨为受色故行。乃至为受一切种智故行。是菩萨不能修般若波罗蜜。不能修禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜。不能修檀那波罗蜜。乃至不能修一切种智。须菩提白佛言。世尊。是法随顺一切法。云何是法随顺一切法。是法随顺般若波罗蜜。乃至随顺檀那波罗蜜。是法随顺内空。乃至随顺无法有法空。是法随顺四念处。乃至随顺一切种智。是法无碍。不碍于色不碍受想行识。乃至不碍一切种智。诸天子。是法名无碍相。如虚空等故。如法性法住实际不可思议性等故。空无相无作等故。是法不生相。色不生不可得故。受想行识不生不可得故。乃至一切种智不生不可得故。是法无处色处不可得故。受想行识处不可得故。乃至一切种智处不可得故。是时欲色界诸天子白佛言。世尊。须菩提是佛子随佛口生。何以故。须菩提所说皆与空合。尔时须菩提语诸天子。汝等言。须菩提是佛子随佛生。云何为随佛生。诸天子。如相故须菩提随佛生。何以故。如来如相不来不去。须菩提如相亦不来不去。是故须菩提随佛生。复次须菩提。从本以来随佛生。何以故。如来如相即是一切法如相。一切法如相即是如来如相。是如相中亦无如相。是故须菩提为随佛生。复次如来如常住相。须菩提如亦常住相。如来如相无异无别。须菩提如相亦如是无异无别。是故须菩提为随佛生。如来如相无有碍处。一切法如相亦无碍处。是如来如相一切法如相。一如无二无别。是如相无作终不不如。是故是如相一如无二无别。是故须菩提为随佛生。如来如相一切处无念无别。须菩提如相亦如是。一切处无念无别。如来如相不异不别不可得。须菩提如相亦如是。以是故须菩提为随佛生。如来如相不远离诸法如相。是如终不不如。是故须菩提。如不异故为随佛生亦无所随。复次如来如相不过去不未来不现在。诸法如相亦不过去不未来不现在。是故须菩提为随佛生。复次如来如不在过去如中。过去如不在如来如中。如来如不在未来如中。未来如不在如来如中。如来如不在现在如中。现在如不在如来如中。过去未来现在如如来如。一如无二无别。色如如来如。受想行识如如来如是色如受想行识如如来如。一如无二无别。我如乃至知者见者如如来如。一如无二无别。檀那波罗蜜如。乃至般若波罗蜜如。内空如乃至无法有法空如。四念处如乃至一切种智如如来如。一如无二无别。须菩提。菩萨摩诃萨得是如故名为如来。说是如相品时。是三千大千世界大地六种震动。东踊西没西踊东没。南踊北没北踊南没。中央踊四边没。四边踊中央没。是时诸欲天子诸色天子。以天末栴檀香。散佛上及散须菩提上。白佛言。未曾有也。世尊。须菩提以如来如随佛生。须菩提。复为诸天子说言。诸天子。须菩提不从色中随佛生。亦不从色如中随佛生。不离色随佛生。亦不离色如随佛生。须菩提。不从受想行识中随佛生。亦不从受想行识如中随佛生。不离受想行识随佛生。亦不离受想行识如随佛生。乃至不从一切种智中随佛生。亦不从一切种智如中随佛生。亦不离一切种智中随佛生。亦不离一切种智如中随佛生。须菩提。不从无为中随佛生。亦不从无为如中随佛生。亦不离无为中随佛生。亦不离无为如中随佛生。何以故。是一切法皆无所有不可得。无随生者亦无随生法。尔时舍利弗白佛言。世尊。是如实不虚。法相法住法位甚深。是中色不可得。色如不可得。何以故。色尚不可得。何况色如当可得。受想行识不可得。受想行识如不可得。何以故。受想行识尚不可得。何况受想行识如当可得。乃至一切种智不可得。一切种智如不可得。何以故。一切种智尚不可得。何况一切种智如当可得。佛告舍利弗。如是如是。舍利弗。是如实不虚。法相法住法位甚深。是中色不可得。色如不可得。何以故。色尚不可得。何况色如当可得。乃至一切种智不可得。一切种智如不可得。何以故。一切种智尚不可得。何况一切种智如当可得。舍利弗说是如相时。二百比丘不受一切法故。漏尽得阿罗汉。五百比丘尼远尘离垢。诸法中得法眼生天人中。五千菩萨摩诃萨得无生法忍。六十菩萨诸法不受故。漏尽心得解脱成阿罗汉。舍利弗。是六十菩萨先世值五百佛亲近供养。于五百佛法中行布施持戒忍辱精进禅定。无般若波罗蜜无方便力故。行别异相作是念。是布施是持戒是忍辱是精进是禅定。无般若波罗蜜无方便力故。布施持戒忍辱精进禅定行异别相。行异别相故不得无异相。不得无异相故不得入菩萨位。不得入菩萨位故。得须陀洹果乃至得阿罗汉果。舍利弗。菩萨摩诃萨虽有道若空若无相若无作法。远离般若波罗蜜无方便力故。便于实际作证取声闻乘。舍利弗白佛言。世尊。何因缘故。俱行空无相无作法远离方便力。于实际作证取声闻乘。菩萨摩诃萨亦修空无相无作法。有方便力故得阿耨多罗三藐三菩提。佛告舍利弗。有菩萨远离萨婆若心修空无相无作法。无方便力故取声闻乘。舍利弗。复有菩萨摩诃萨不远离萨婆若心。修空无相无作法。有方便力故入菩萨位。得阿耨多罗三藐三菩提。舍利弗。譬如有鸟身长百由旬。若二百三百由旬而无有翅。从三十三天自投阎浮提。舍利弗。于汝意云何。是鸟中道作是念。欲还上三十三天能得还不。不得也世尊。舍利弗。是鸟复作是愿。到阎浮提欲使身不痛不恼。舍利弗。于汝意云何。是鸟得不痛不恼不。舍利弗言。不得也世尊。是鸟到地若痛若恼若死若死等苦。何以故。世尊。是鸟身大而无翅故。舍利弗。菩萨摩诃萨亦如是。虽如恒河沙等劫修布施持戒忍辱精进禅定。发大事生大心。为得阿耨多罗三藐三菩提故受无量愿。是菩萨远离般若波罗蜜方便力故。若堕阿罗汉。若堕辟支佛道。何以故。是菩萨远离萨婆若心布施持戒忍辱精进禅定。无般若波罗蜜无方便力故。堕声闻地若辟支佛道中。舍利弗。菩萨摩诃萨虽念过去未来现在诸佛。持戒禅定智慧解脱解脱知见取相受持。是人不知不解诸佛戒定慧解脱解脱知见。但闻空无相无作名字声而取名字声。回向阿耨多罗三藐三菩提。菩萨摩诃萨若如是回向。住声闻辟支佛地中不能得过。何以故。远离般若波罗蜜方便力。持诸善根回向阿耨多罗三藐三菩提故。舍利弗。有菩萨摩诃萨从初发意以来。不远离萨婆若心。行布施持戒忍辱精进禅定。不远离般若波罗蜜方便力故。不取相于过去未来现在诸佛戒定慧解脱解脱知见。不取空解脱门相。不取无相无作解脱门相。舍利弗。当知是菩萨摩诃萨不堕声闻辟支佛道。直至阿耨多罗三藐三菩提。何以故。是菩萨摩诃萨从初发意以来行布施不取相。持戒忍辱精进禅定不取相。过去未来现在诸佛戒定慧解脱解脱知见不取相。舍利弗。是名菩萨方便力以离相心。行布施持戒忍辱精进禅定。乃至离相心行一切种智。舍利弗白佛言。世尊。如我解佛所说义。若菩萨摩诃萨不远离般若波罗蜜方便力。当知是菩萨近阿耨多罗三藐三菩提。何以故。是菩萨摩诃萨从初发心以来。无法可知若色若受想行识。乃至一切种智。世尊。有求菩萨道善男子善女人远离般若波罗蜜及方便力。当知是人于阿耨多罗三藐三菩提或得或不得。何以故。世尊。是求菩萨道善男子善女人。所有布施皆取相。所有持戒忍辱精进禅定皆取相。以是故。是善男子善女人于阿耨多罗三藐三菩提不定。世尊。以是因缘故菩萨摩诃萨欲得阿耨多罗三藐三菩提。不应远离般若波罗蜜方便力。是菩萨摩诃萨住般若波罗蜜方便力中。以无得无相心应布施持戒忍辱精进禅定。乃至以无得无相心应修一切种智。尔时欲色界诸天子白佛言。世尊。阿耨多罗三藐三菩提难得。何以故。是菩萨摩诃萨应知一切诸法。是法亦不可得。佛言如是如是。诸天子。阿耨多罗三藐三菩提难得。我不得一切法。一切种智。亦无所得无能知。无可知无知者。何以故。诸法毕竟净故。须菩提白佛言。世尊。如佛所说。阿耨多罗三藐三菩提难得。如我解佛所说义。我心思惟是阿耨多罗三藐三菩提易得。何以故。无有得阿耨多罗三藐三菩提者。亦无可得法。一切法一切法相空。无法可得无能得者。何以故。一切法空故。亦无法可增亦无法可减。所谓布施持戒忍辱精进禅定乃至一切种智。是法皆无可得者无能得者。世尊。以是因缘故。我意谓阿耨多罗三藐三菩提为易得。何以故。世尊。色色相空受想行识识相空。乃至一切种智一切种智相空。舍利弗语须菩提。若一切法空如虚空。虚空不作是念我当得阿耨多罗三藐三菩提。若菩萨摩诃萨信解一切诸法空如虚空。是阿耨多罗三藐三菩提易得者。今恒河沙等诸菩萨摩诃萨。求阿耨多罗三藐三菩提何以退还。须菩提。以是故知阿耨多罗三藐三菩提不易得。须菩提语舍利弗。于意云何。色于阿耨多罗三藐三菩提退还不。舍利弗言不。受想行识于阿耨多罗三藐三菩提退还不。舍利弗言不。乃至一切种智于阿耨多罗三藐三菩提退还不。舍利弗言不。离色有法于阿耨多罗三藐三菩提退还不。舍利弗言不。离受想行识有法于阿耨多罗三藐三菩提退还不。舍利弗言不。乃至离一切种智有法于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗。于意云何。色如相于阿耨多罗三藐三菩提退还不。舍利弗言不。受想行识如相乃至一切种智如相。于阿耨多罗三藐三菩提退还不。舍利弗言不。离色如相有法于阿耨多罗三藐三菩提退还不。舍利弗言不。离受想行识如相。乃至离一切种智如相有法于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗于意云何。如于阿耨多罗三藐三菩提退还不。舍利弗言不。法性法住法位实际不可思议性。于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗。于意云何。离如有法于阿耨多罗三藐三菩提退还不。舍利弗言不。离法性法住法位实际不可思议性有法于阿耨多罗三藐三菩提退还不。舍利弗言不。须菩提语舍利弗。若诸法毕竟不可得。何等法于阿耨多罗三藐三菩提退还。舍利弗语须菩提。如须菩提所说。是法忍中无有菩萨于阿耨多罗三藐三菩提。退还者若不退还。佛说求道者有三种。阿罗汉道。辟支佛道。佛道。是三种为无分别。如须菩提说。独有一菩萨摩诃萨求佛道。是时富楼那弥多罗尼子语舍利弗。应当问须菩提。为有一菩萨乘不。尔时舍利弗问须菩提。须菩提。为欲说有一菩萨乘。须菩提语舍利弗。于诸法如中。欲使有三种乘声闻乘辟支佛乘佛乘耶。舍利弗言不也。舍利弗。如中可得分别有三乘不。舍利弗言不也。舍利弗。是如有若一相若二相若三相不。舍利弗言不也。舍利弗。汝欲于如中乃至有一菩萨不。舍利弗言不也。如是四种中三乘人不可得。舍利弗。云何作是念。是求声闻乘人。是求辟支佛乘人。是求佛乘人。舍利弗。菩萨摩诃萨闻是诸法如相。心不惊不没不悔不疑。是名菩萨摩诃萨能成就阿耨多罗三藐三菩提。尔时佛赞须菩提言。善哉善哉。须菩提。汝所说者皆是佛力。须菩提。若菩萨摩诃萨闻说是如无有诸法别异。心不惊不怖不畏不难不没不悔。当知是菩萨能成就阿耨多罗三藐三菩提。舍利弗白佛言。世尊。成就何等菩提。佛言。成就佛阿耨多罗三藐三菩提。须菩提白佛言。世尊。若菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应云何行。佛言。应起等心。于一切众生亦等心与语无有偏党。于一切众生中起大慈心。亦以大慈心与语。于一切众生中下意。亦以下意与语。于一切众生中应生安隐心。亦以安隐心与语。于一切众生中应生无碍心。亦以无碍心与语。于一切众生中应生无恼心。亦以无恼心与语。于一切众生中应生爱敬心。如父如母如兄如弟。如姊妹如儿子。如亲族如知识。亦以爱敬心与语。是菩萨摩诃萨应自不杀生亦教人不杀生。赞不杀生法。欢喜赞叹诸不杀者。乃至自不行邪见亦教他人不行邪见。赞叹不邪见法。欢喜赞叹不邪见者。如是须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提当如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应自行初禅亦教他人行初禅。赞叹行初禅法。欢喜赞叹行初禅者。二禅三禅四禅亦如是。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应自行慈心亦教人行慈心。赞叹行慈心法。欢喜赞叹行慈心者。悲喜舍心亦如是。自行虚空处亦教人行虚空处。赞叹行虚空处法。欢喜赞叹行虚空处者。识处无所有处非有想非无想处亦如是。自具足檀那波罗蜜。亦教人具足檀那波罗蜜。赞叹具足檀那波罗蜜法。欢喜赞叹具足檀那波罗蜜者。尸罗波罗蜜羼提毗梨耶禅那般若波罗蜜亦如是。复次菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自行内空亦教人行内空。赞叹行内空法。欢喜赞叹行内空者。乃至无法有法空亦如是。自行四念处亦教人行四念处。赞叹行四念处法。欢喜赞叹行四念处者。乃至八圣道分亦如是。自修空三昧无相无作三昧。亦教人修空无相无作三昧。赞叹修空无相无作三昧法。欢喜赞叹修空无相无作三昧者。自行八背舍亦教人行八背舍。赞叹行八背舍法。欢喜赞叹行八背舍者。自行九次第定亦教人行九次第定。赞叹行九次第定法。欢喜赞叹行九次第定者。自具足佛十力亦教人具足佛十力。赞叹具足佛十力法。欢喜赞叹具足佛十力者。自行四无所畏四无碍智十八不共法大慈大悲。亦教人行四无所畏乃至大慈大悲。赞叹行四无所畏乃至大慈大悲法。欢喜赞叹行四无所畏乃至大慈大悲者。自逆顺观十二因缘。亦教人行逆顺观十二因缘。赞叹逆顺观十二因缘法。欢喜赞叹逆顺观十二因缘者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提应如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自应知苦断集证灭修道。亦教人知苦断集证灭修道。赞叹知苦断集证灭修道法。欢喜赞叹知苦断集证灭修道者。自生须陀洹果证智亦不证实际。亦教人着须陀洹果中。赞叹须陀洹果法。欢喜赞叹得须陀洹果者。斯陀含果阿那含果阿罗汉果亦如是。自生辟支佛道证智。亦不证辟支佛道。亦教人着辟支佛道中。赞叹得辟支佛道法。欢喜赞叹得辟支佛道者。自入菩萨位亦教人入菩萨位。赞叹入菩萨位法。欢喜赞叹入菩萨位者。自净佛国土成就众生。亦教人净佛国土成就众生。赞叹净佛国土成就众生法。欢喜赞叹净佛国土成就众生者。自起菩萨神通亦教人起菩萨神通。赞叹起菩萨神通法。欢喜赞叹起菩萨神通者。自生一切种智亦教人生一切种智。赞叹生一切种智法。欢喜赞叹生一切种智者。自断一切结使习亦教人断一切结使习。赞叹断一切结使习法。欢喜赞叹断一切结使习者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自取寿命成就。亦教人取寿命成就。赞叹取寿命成就法。欢喜赞叹取寿命成就者。自成就法住亦教人成就法住。赞叹成就法住法。欢喜赞叹成就法住者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应如是行。亦应如是学般若波罗蜜方便力。是菩萨如是学如是行时。当得无碍色。得无碍受想行识。乃至得无碍法住。何以故。是菩萨摩诃萨从本以来不受色。不受受想行识。乃至不受一切种智。何以故。色不受者为非色。乃至一切种智不受者。为非一切种智。说是菩萨行品时。二千菩萨得无生法忍

    摩诃般若波罗蜜经不退品第五十五

须菩提白佛言。世尊。以何等行何等类何等相貌。知是阿惟越致菩萨摩诃萨。佛告须菩提。若菩萨摩诃萨能知凡夫地声闻地辟支佛地佛地。是诸地如相中无二无别。亦不念亦不分别。入是如中闻是事直过无疑。何以故。是如中无一无二相故。是菩萨摩诃萨亦不作无益语。但说利益相应语。不视他人长短。须菩提。以是行类相貌。知是阿惟越致菩萨摩诃萨。须菩提言。世尊。复以何行类相貌。知是阿惟越致菩萨摩诃萨。佛告须菩提。若菩萨摩诃萨能观一切法。无行无类无相貌。当知是名阿惟越致菩萨摩诃萨。须菩提白佛言。世尊。若一切法无行无类无相貌。菩萨于何等法转名不转。佛言。若菩萨摩诃萨色中转。受想行识中转。是名菩萨不转。复次须菩提。菩萨摩诃萨檀那波罗蜜中转。乃至般若波罗蜜中转。内空中乃至无法有法空中转。四念处中乃至十八不共法中转。声闻辟支佛地中转。乃至阿耨多罗三藐三菩提中转。当知是菩萨摩诃萨不转。何以故。须菩提。色性无。是菩萨何所住。乃至阿耨多罗三藐三菩提性无。是菩萨何所住。复次须菩提。菩萨摩诃萨不观相外道沙门婆罗门面貌言语。不作是念是诸外道若沙门若婆罗门实知实见。若说正见无有是事。复次菩萨不生疑不着戒取不堕邪见。亦不求世俗吉事以为清净。不以华香璎珞幡盖伎乐礼拜供养余天。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨常不生下贱家。乃至不生八难之处。常不受女人身。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨常行十善道。自不杀生不教人杀生。赞叹不杀生法。欢喜赞叹不杀生者。乃至自不邪见不教人邪见。不赞叹邪见法。不欢喜赞叹行邪见者。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨乃至梦中。亦不行十不善道。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨为益一切众生故行檀那波罗蜜。乃至为益一切众生故行般若波罗蜜。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨所有诸法。受读诵说正忆念。所谓修妒路乃至忧波提舍。是菩萨法施时作是念。是法施因缘故满一切众生愿。以是法施功德与一切众生共之。回向阿耨多罗三藐三菩提。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨于甚深法中不疑不悔。须菩提言。世尊。菩萨于甚深法中何因缘故不疑不悔。佛言。是阿惟越致菩萨都不见有法可生疑处。若色受想行识乃至阿耨多罗三藐三菩提。不见是法可生疑处悔处。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨身口意业柔软。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨以慈身口意业成就。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨不与五盖俱淫欲嗔恚睡眠掉悔疑。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨一切处无所爱着。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨出入去来坐卧行住常念一心。出入去来坐卧行住举足下足安隐详序。常念一心视地而行。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨所著衣服及诸卧具。人不恶秽。好乐净洁少于疾病。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。常人身中有八万户虫侵食其身。是阿惟越致菩萨摩诃萨身无是虫。何以故。是菩萨功德出过世间。以是故。是菩萨无是户虫。是菩萨功德增益。随其功德得身清净。得心清净。须菩提。以是行类相藐。当知是名阿惟越致菩萨摩诃萨。须菩提白佛言。世尊。云何菩萨摩诃萨。得身清净得心清净。佛言。菩萨摩诃萨随其所得增益善根。灭除心曲心邪。须菩提。是名菩萨摩诃萨身清净心清净。以是身心清净故。能过声闻辟支佛地入菩萨位中。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨不贵利养。虽行十二头陀。不贵阿兰若法。乃至不贵但三衣法。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨常不生悭贪心。不生破戒心嗔动心懈怠心散乱心。不生愚痴心。不生嫉妒心。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨心住不动智慧深入。一心听受所从闻法。及世间事皆与般若波罗蜜合。是菩萨摩诃萨不见产业之事不入法性者。是事一切皆见与般若波罗蜜合。以是因缘故须菩提。是名阿惟越致菩萨阿惟越致相。复次须菩提若恶魔于阿惟越致菩萨前化作八大地狱。一一地狱中有千亿万菩萨。皆被烧煮受诸辛酸苦毒。语菩萨言。是诸菩萨皆是阿惟越致。佛所授记堕大地狱中。汝若为佛授阿惟越致记者。当入是大地狱中。佛为授汝地狱记。汝不如还舍菩萨心。可得不堕地狱得生天上。须菩提。若是菩萨见是事闻是事。心不动不疑不惊。作是念。阿惟越致菩萨若堕地狱畜生饿鬼中。终无是处。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。恶魔化作比丘被服来至菩萨所。语菩萨言。汝先闻应如是净修六波罗蜜。乃至应如是净修得阿耨多罗三藐三菩提。是事汝疾悔舍。汝先于过去未来现在诸佛所。从初发心乃至法住。于其中间所作善根。随喜回向阿耨多罗三藐三菩提是事汝亦疾放舍。若汝疾舍我当语汝真佛法。汝先所闻皆非佛法非佛教。皆是文饰合集作耳。我所说是真佛法。若是菩萨闻作是说心惊疑悔。当知是菩萨未得诸佛授记。未定住阿惟越致性中。若是菩萨心不动不惊不疑不悔。随顺依止无作无生法。不信他语不随他行。行六波罗蜜时不随他语。乃至行阿耨多罗三藐三菩提时亦不随他语。须菩提。譬如漏尽阿罗汉。不信他语不随他行。现见诸法实相恶魔不能转。如是须菩提。阿惟越致菩萨摩诃萨亦如是。求声闻道辟支佛道人。不能破坏不能折伏其心。须菩提。是菩萨摩诃萨。必定住阿惟越致地中。不随他语乃至佛语不直信取。何况求声闻辟支佛人。及恶魔外道梵志语。终无是处。何以故。是菩萨不见有法可随信者。所谓若色受想行识。若色如乃至识如。乃至不见若阿耨多罗三藐三菩提。阿耨多罗三藐三菩提如。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。魔作比丘身来到菩萨所。语菩萨言。汝所行者是生死法非萨婆若道。汝今身取苦尽证。是时恶魔为菩萨。用世间行说似道法。是似道法三界系。所谓骨相若初禅乃至非有想非无想语。善男子。用是道用是行。当得须陀洹果。乃至当得阿罗汉果。汝行是道今世苦尽。汝用受生死中种种苦恼为。今是四大身尚不用受。何况当更受来身。须菩提。若是菩萨摩诃萨心不惊不疑不悔作是念。是比丘益我不少。为我说似道法。行是似道法。不至须陀洹果证。不得至阿罗汉辟支佛道证。何况得至阿耨多罗三藐三菩提。是菩萨摩诃萨益复欢喜作是念。是比丘益我不少。为我说遮道法。我知是遮道法。是不遮学三乘道。是时恶魔知菩萨欢喜作是言。善男子。汝欲见是菩萨摩诃萨供养如恒河沙等诸佛。衣被饮食卧具医药资生所须。亦于如恒河沙等诸佛所。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。亦亲近如恒河沙等诸佛。咨问菩萨摩诃萨道。世尊。菩萨摩诃萨云何住菩萨摩诃萨乘。云何行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。四念处乃至大慈大悲。是菩萨摩诃萨如佛所教。如是住如是行如是修。是菩萨摩诃萨如是教如是学。尚不得阿耨多罗三藐三菩提不得萨婆若。何况汝当得阿耨多罗三藐三菩提。若菩萨摩诃萨闻是事。心不异不惊。益复欢喜作是念。是比丘益我不少。为我说遮道法。是遮道法不得须陀洹道。乃至不得阿罗汉辟支佛道。何况得阿耨多罗三藐三菩提。是时恶魔知是菩萨心不没不惊。即于是处化作多比丘。语菩萨言。此皆是发意求佛道菩萨。今皆住阿罗汉地。是辈尚不能得阿耨多罗三藐三菩提。汝云何能得。若菩萨摩诃萨即作是念。此是恶魔说似道行。菩萨摩诃萨行般若波罗蜜。不应转阿耨多罗三藐三菩提心。亦不应堕声闻辟支佛道中。复作是念。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜乃至一切种智。不得阿耨多罗三藐三菩提无有是处。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。菩萨摩诃萨作是念。若菩萨能如佛所说。不远离般若波罗蜜心乃至一切种智。是菩萨终不退阿耨多罗三藐三菩提若菩萨觉知魔事。亦不失阿耨多罗三藐三菩提。以是行类相貌。当知是阿惟越致菩萨摩诃萨相。须菩提白佛言。世尊。于何法转名为不转。佛言。于色相转于受想行识相转。于十二入相十八界相淫欲嗔恚愚痴相。邪见相四念处相。乃至声闻辟支佛相。乃至佛相转。以是名为不退转菩萨摩诃萨相。何以故。是阿惟越致菩萨摩诃萨。以是自相空法。入菩萨位得无生法忍。何以故。名无生法忍。是中乃至少许法不可得。不可得故不作。不作故无生。是名无生法忍。菩萨摩诃萨以是行类相貌。当知是阿惟越致菩萨摩诃萨

摩诃般若波罗蜜经卷第十六摩诃般若波罗蜜经卷第十七

        后秦龟兹国三藏鸠摩罗什译

    坚固品第五十六(丹本转不转品)

复次须菩提。恶魔到菩萨所坏其心作是言。萨婆若与虚空等空无所有相。诸法亦与虚空等。空无所有相。是虚空等诸法。空无所有相中无有得阿耨多罗三藐三菩提者。亦无有不得者。是诸法皆如虚空。空无所有相。汝唐受勤苦。汝所闻阿耨多罗三藐三菩提皆是魔事非佛所说。汝当放舍是愿。汝莫长夜受是不安隐忧苦堕恶道中。是诸善男子善女人。闻是语时应如是念。是恶魔事坏我阿耨多罗三藐三菩提心。诸法虽如虚空无所有自相空。而众生不知不见不解。我亦以如虚空等无所有自相空。大誓庄严得一切种智。为众生说法令得解脱。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨。从初发意已来闻如是法。应坚固其心不动不转。菩萨摩诃萨以是坚固心不动不转心。行六波罗蜜当入菩萨位中。须菩提白佛言。世尊。不转故名阿惟越致。转故名阿惟越致。佛言。不转故名阿惟越致。转故亦名阿惟越致。须菩提白佛言。世尊。云何不转故名阿惟越致。转故亦名阿惟越致。佛告须菩提。若菩萨摩诃萨于声闻地辟支佛地不转。是故名不转。若菩萨摩诃萨于声闻地辟支佛地转。是故亦名不转。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨相。以是行类相貌故。恶魔不能坏其心令离阿耨多罗三藐三菩提。复次须菩提。阿惟越致菩萨若欲入初禅第二第三第四禅乃至灭定禅即得入。复次须菩提。阿惟越致菩萨摩诃萨。若欲修四念处乃至修八圣道分。空无相无作三昧乃至五神通即得修。是菩萨虽修四念处乃至五神通。是人不受四念处果。虽修诸禅不受诸禅果。乃至不受灭定禅果。不证须陀洹果。乃至不证辟支佛道。是菩萨故为众生受身。随其所应而利益之。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨。常忆念阿耨多罗三藐三菩提。终不远离萨婆若心。不远离萨婆若心故。不贵色不贵相。不贵声闻辟支佛。不贵檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜不贵四禅四无量心四无色定。不贵五神通。不贵四念处乃至八圣道分。不贵佛十力乃至十八不共法。不贵净佛国土。不贵成就众生。不贵见佛。不贵种善根。何以故。一切法自相空。不见可贵法能生贵心者。何以故。是一切法与虚空等。无所有自相空。须菩提。是阿惟越致菩萨摩诃萨成就是心。于四种身威仪中。出入来去坐卧行住一心不乱。须菩提。以是行类相貌。当知是阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨若在居家。以方便力为利益众生故受五欲。布施众生。须食与食须饮与饮。衣服卧具乃至资生所须尽给与之。是菩萨自行檀那波罗蜜教人行檀那。赞叹行檀那法。欢喜赞叹行檀那波罗蜜者。尸罗波罗蜜乃至般若波罗蜜亦如是。须菩提。阿惟越致菩萨摩诃萨在家时。能以满阎浮提珍宝施与众生。乃至三千大千世界满中珍宝给施众生。亦不自为常修梵行。不陵易虏掠他人令其忧恼。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨复次须菩提。阿惟越致菩萨摩诃萨。执金刚神王常随逐。作是愿是菩萨摩诃萨。当得阿耨多罗三藐三菩提。我常随逐乃至五性执金刚神常随守护。以是故若天若魔若梵。若余世间大力者不能破坏。是名菩萨摩诃萨萨婆若心。乃至得阿耨多罗三藐三菩提。须菩提。是名菩萨摩诃萨阿惟越致相

复次须菩提。菩萨摩诃萨常具足菩萨五根。信根精进根念根定根慧根。是名阿惟越致相。复次须菩提。阿惟越致菩萨摩诃萨为上人不为下人。须菩提白佛言。世尊。云何为上人。佛告须菩提。若菩萨摩诃萨一心行阿耨多罗三藐三菩提。心不散乱是名上人。以是行类相貌当知是名阿惟越致相。复次须菩提。阿惟越致菩萨一心常念佛道。为净命故。不作咒术合和诸药。不咒鬼神令着男女。问其吉凶男女。禄相寿命长短。何以故。须菩提。是菩萨摩诃萨知诸法自相空。不见诸法相故。不行邪命行净命。须菩提。以是行类相貌当知是名阿惟越致菩萨摩诃萨相。复次须菩提。今当更说阿惟越致菩萨摩诃萨行类相貌。一心谛听。佛苦须菩提。菩萨摩诃萨行般若波罗蜜。常不远离阿耨多罗三藐三菩提心故。不说五阴事。不说十二入事。不说十八界事。何以故。常念观五阴空相十二入十八界。空相故。是菩萨摩诃萨不好说官事。何以故。是菩萨诸法空相中住不见法若贵若贱。不好说贼事。何以故。诸法自相空故不见若得若失。不好说军事。何以故。诸法自相空故不见若多若少。不好说斗事。何以故。是菩萨摩诃萨住诸法如中不见法有憎有爱。不好说妇女事何以故。住诸法空中不见好丑故。不好说聚落事。何以故。诸法自相空故不见法若合若散。不好说城邑事。何以故。住诸法实际中不见有胜有负。不好说国事。何以故。住实际中不见法有所属有不属。不好说我事。何以故。法性中住不见法有我无我。乃至不见知者见者。如是等不说种种世间事。但好说般若波罗蜜不远离萨婆若心。若行檀那波罗蜜时不为悭贪事。行尸罗波罗蜜时不为破戒事。行羼提波罗蜜时不为嗔诤事。行毗梨耶波罗蜜。时不为懈怠事。行禅那波罗蜜时不为散乱事。行般若波罗蜜时不为愚痴事。是菩萨虽行一切法空。而爱乐法。是菩萨虽行法性常赞不坏法而爱乐善知识。所谓诸佛及菩萨声闻辟支佛。诸能教化令乐住阿耨多罗三藐三菩提者。是人常愿欲见诸佛闻在所处。佛国土中有现在佛随愿往生如是心常昼夜行。所谓念佛心。如是须菩提。阿惟越致菩萨摩诃萨。行初禅乃至非有想非无想处。以方便力故起欲界心。若众生能行十善道者。及现在有佛处在中生。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨行般若波罗蜜时。住内空外空乃至无法有法空。住四念处乃至空无相。无作解脱门。于自地中了了不疑我是阿惟越致非阿惟越致。何以故。乃至不见少许法于阿耨多罗三藐三菩提中若转若不转。须菩提。譬如人得须陀洹果住须陀洹地中。自了了知终不疑不悔。阿惟越致菩萨摩诃萨亦如是。住阿惟越致地中终不疑。住是地中净佛国土成就众生。种种魔事起即时觉知。亦不随魔事破坏魔事。须菩提。譬如有人作五逆罪。五逆罪心乃至死时常逐不舍。虽有异心不能障隔。须菩提。阿惟越致菩萨摩诃萨亦如是。自住其地心常不动。一切世间天人阿修罗不能动转。何以故。是菩萨摩诃萨出一切世间天人阿修罗上。入正法位中自证地中住。具足诸菩萨神通。能净佛国土成就众生。从一佛国至一佛国。于十方佛所殖诸善根亲近咨问诸佛。是菩萨如是住。种种魔事起觉而不随。以方便力处魔事着实际中。自证地中不疑不悔。何以故。实际中无疑相故。知是实际非一非二。以是因缘故。是人乃至转身终不向声闻辟支佛地。是菩萨摩诃萨诸法自相空中。不见法若生若灭若垢若净。须菩提。是菩萨摩诃萨乃至转身亦不疑我当得阿耨多罗三藐三菩提若不得。何以故。须菩提。诸法自相空即是阿耨多罗三藐三菩提。须菩提。是菩萨摩诃萨住自证地中。不随他语无能坏者。何以故。是阿惟越致菩萨摩诃萨。成就不动智慧故。须菩提。以是行类相貌。当知是名阿惟越致菩萨摩诃萨。复次须菩提菩萨摩诃萨。若恶魔作佛身来。语菩萨言。汝今于是间取阿罗汉道。汝亦无阿耨多罗三藐三菩提记。汝亦未得无生忍法。汝亦无是阿惟越致行类相貌。亦无是相得受阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨闻是语。心不异不没不惊不怖不畏。是菩萨应自知我必从诸佛受阿耨多罗三藐三菩提记。何以故。诸菩萨以是法受记。我亦有是法得受记。须菩提。若恶魔若为魔所使作佛形像。来与菩萨受声闻辟支佛记。须菩提。是菩萨作是念。是恶魔若魔所使作佛形像来。诸佛不应教菩萨远离阿耨多罗三藐三菩提。教住声闻辟支佛道。须菩提。以是行类相貌。当知是名阿惟越致相。复次须菩提。恶魔复作佛身来到菩萨所。作是言。汝所学经书非佛所说。亦非声闻说是魔所说。须菩提。是菩萨摩诃萨当作是知是恶魔若魔所使。教我远离阿耨多罗三藐三菩提。须菩提。当知是菩萨已为过去佛所受记。住阿惟越致地。何以故。诸菩萨所有阿惟越致行类相貌。是菩萨亦有是行类相貌。是名阿惟越致菩萨相。复次须菩提阿惟越致菩萨摩诃萨行般若波罗蜜时。为护持诸法故不惜身命何况余物。是菩萨护持法故作是念。我不为护持一佛法。我为护持三世十方诸佛法故。须菩提。云何菩萨摩诃萨护持法故不惜身命。须菩提。如佛说一切诸法真空。是时有愚痴人破坏不受。作是言是非法非善非世尊教。须菩提。菩萨护持如是法故不惜身命。菩萨亦应作是念。未来世诸佛我亦在是数中。在中受记是法亦是我法。以是故不惜身命。须菩提。菩萨见是利益故。护持法不惜身命。须菩提。以是行类相貌知是阿惟越致相。复次须菩提。阿惟越致菩萨摩诃萨。闻佛说法不疑不悔。闻已受持终不忘失。何以故。得陀罗尼故。须菩提言。世尊。得何等陀罗尼闻佛所说诸经而不忘失。佛告须菩提。菩萨得闻持等陀罗尼故。佛说诸经不忘不失不疑不悔。须菩提白佛言。世尊。但闻佛说法不忘不失不疑不悔。声闻辟支佛说天龙鬼神阿修罗紧那罗摩睺罗伽说。亦复不忘不失不疑不悔耶。佛告须菩提。所有言说众事。得陀罗尼菩萨皆不忘不失不疑不悔。须菩提。如是行类相貌成就。当知是阿惟越致菩萨摩诃萨

    摩诃般若波罗蜜经深奥品第五十七(丹本灯炷品)

须菩提白佛言世尊。是阿惟越致菩萨摩诃萨大功德成就。世尊。是阿惟越致菩萨摩诃萨无量功德成就无边功德成就。佛告须菩提。如是如是。是阿惟越致菩萨摩诃萨大功德成就。是阿惟越致菩萨摩诃萨无量无边功德成就。何以故。是菩萨摩诃萨得无量无边智慧。不与一切声闻辟支佛共故。阿惟越致菩萨住是智慧中生四无阂智。得是无阂智故。一切世间天及人无能穷尽。须菩提白佛言。世尊。佛能以恒河沙等劫。叹说阿惟越致菩萨摩诃萨行类相貌。须菩提言。世尊。何等深奥处。阿惟越致菩萨摩诃萨。住是中行六波罗蜜时。具足四念处乃至具足一切种智。佛赞须菩提。善哉善哉。须菩提。汝为阿惟越致菩萨摩诃萨。问是深奥处。须菩提。深奥处者空是其义。无相无作无起无生无染。寂灭离如法性实际涅槃。须菩提。如是等法是为深奥义。须菩提白佛言。世尊。但空乃至涅槃是深奥。非一切法深奥耶。佛言。一切法亦是深奥义。须菩提。色亦深奥受想行识亦深奥。眼亦深奥乃至意色乃至法。眼界乃至意识界。檀那波罗蜜乃至般若波罗蜜。四念处乃至阿耨多罗三藐三菩提亦深奥。世尊。云何色深奥乃至阿耨多罗三藐三菩提亦深奥。佛言。色如深奥故色深奥。受想行识如。乃至阿耨多罗三藐三菩提如深奥故。阿耨多罗三藐三菩提深奥。世尊。云何色如深奥。乃至阿耨多罗三藐三菩提如深奥。须菩提。是色如非是色非离色。乃至识如非是识非离识。乃至阿耨多罗三藐三菩提如。非是阿耨多罗三藐三菩提。非离阿耨多罗三藐三菩提。须菩提白佛言。希有世尊。微妙方便力故。令阿惟越致菩萨摩诃萨离色处涅槃。亦令离受想行识处涅槃。亦令离一切法若世间若出世间。若有诤若无诤。若有漏若无漏法处涅槃。佛言。如是如是。须菩提。佛以微妙方便力故。令阿惟越致菩萨离色处涅槃。乃至离有漏无漏法处涅槃。复次须菩提。若菩萨摩诃萨如是甚深法。与般若波罗蜜相应观察筹量思惟。作是念。我应如是行如般若波罗蜜中教。我应如是学如般若波罗蜜中说。须菩提。若是菩萨摩诃萨能如说行如说学。如般若波罗蜜中。观具足勤精进一念生时。当得无量无边阿僧祇福德。是菩萨摩诃萨超越无量劫。近阿耨多罗三藐三菩提。何况常行般若波罗蜜。应阿耨多罗三藐三菩提念。须菩提。譬如多淫欲人与端正净洁女人共期。此女人限阂不得时往。于须菩提意云何。是人所念为在何处。世尊。是人念念常在彼女人所。恒作是念。忆想当来与共坐卧欢乐。须菩提。是人一日一夜为有几念生。须菩提言。世尊。是人一日一夜。其念甚多甚多。佛告须菩提。菩萨摩诃萨念般若波罗蜜。如般若波罗蜜中说行是道。一念顷超越劫数。亦如彼人一日一夜心念之数。是菩萨摩诃萨行般若波罗蜜远离众罪。所谓离阿耨多罗三藐三菩提罪。是菩萨摩诃萨行般若波罗蜜。一日所得善根功德。假令满如恒河沙等三千大千世界中。功德犹亦不减。于余残功德百分不及一分。千分千亿万分乃至算数譬喻所不能及。复次须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙等劫布施三宝佛宝法宝比丘僧宝。须菩提。于汝意云何。是菩萨摩诃萨以是因缘故得福多不。须菩提言。世尊甚多。无量无边阿僧祇。佛告须菩提。不如菩萨摩诃萨深般若波罗蜜中。一日如说修行得福多。何以故。般若波罗蜜是诸菩萨摩诃萨道。乘是道疾得阿耨多罗三藐三菩提。须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙等劫。供养须陀洹斯陀含阿那含阿罗汉辟支佛及诸佛。于须菩提意云何。是菩萨摩诃萨以是因缘故得福多不。须菩提言。世尊。甚多甚多。佛言。不如是菩萨摩诃萨。深般若波罗蜜如说修行一日得福多。何以故。菩萨摩诃萨行是般若波罗蜜。过一切声闻辟支佛地入菩萨位。渐渐得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨远离般若波罗蜜。如恒河沙等劫。行布施持戒忍辱精进禅定智慧。于汝意云何。是人以是因缘故得福多不。须菩提言。世尊。甚多甚多。佛言。不如是菩萨摩诃萨行般若波罗蜜如说修行。一日布施持戒忍辱精进禅定智慧得福多。何以故须菩提。般若波罗蜜是菩萨摩诃萨母故。是般若波罗蜜能生诸菩萨摩诃萨。诸菩萨摩诃萨住般若波罗蜜中。能具足一切佛法故。须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙劫寿行法施。须菩提。于汝意云何。是人得福多不。须菩提言。甚多世尊。佛言。不如是善男子善女人。深般若波罗蜜如说修行。乃至一日法施得福多。何以故。须菩提。是菩萨摩诃萨不远离般若波罗蜜。则不远离一切种智。不远离一切种智。则不远离般若波罗蜜。以是故。须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。不当远离般若波罗蜜。须菩提。若菩萨摩诃萨。如恒河沙等劫远离般若波罗蜜。修行四念处乃至八圣道分内空乃至一切种智。须菩提。于汝意云何。是善男子善女人得福多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人。深般若波罗蜜如说。一日修行四念处乃至一切种智得福多。何以故。须菩提。若菩萨摩诃萨不远离般若波罗蜜。于萨婆若转者无有是处。须菩提。若菩萨摩诃萨远离般若波罗蜜。于萨婆若转则有是处。须菩提。以是故。菩萨摩诃萨常不应远离般若波罗蜜行。须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙等劫寿。财施法施及禅定福德。回向阿耨多罗三藐三菩提。于汝意云何。是人得福多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人。深般若波罗蜜如说修行。乃至一日财施法施禅定福德回向阿耨多罗三藐三菩提得福多。何以故。是第一回向。所谓般若波罗蜜回向。若远离般若波罗蜜回向。是不名回向。须菩提。以是故。若菩萨摩诃萨。欲得阿耨多罗三藐三菩提。应方便学般若波罗蜜回向。须菩提。若善男子善女人。远离般若波罗蜜如恒河沙劫寿。过去未来现在诸佛及弟子善根。和合随喜回向阿耨多罗三藐三菩提。须菩提。于汝意云何。是人得福多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人深般若波罗蜜如说修行。乃至一日随喜善根回向阿耨多罗三藐三菩提得福多。须菩提。以是故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学般若波罗蜜中方便。回向阿耨多罗三藐三菩提。须菩提白佛言。世尊。如佛所说。因缘起法从妄想生非实。云何善男子善女人得大福德。世尊。以是因缘起法。不应得正见入法位。不应得须陀洹果。乃至不应得阿耨多罗三藐三菩提果。佛告须菩提。如是如是。须菩提。以是因缘起法。不应得正见入法位。乃至不应得阿耨多罗三藐三菩提。须菩提。行般若波罗蜜菩萨摩诃萨。知因缘起法亦空无坚固虚诳不实。何以故。须菩提。是菩萨摩诃萨善学内空。乃至善学无法有法空故。是菩萨摩诃萨住是十八空。种种观作法空。即不远离般若波罗蜜。若菩萨摩诃萨如是渐渐不离般若波罗蜜。渐渐得无数无量无边福德。须菩提白佛言。世尊。无数无量无边有何等异。须菩提。无数者。名不堕数中若有为性中若无为性中。无量者。量不可得。若过去若未来若现在。无边者。诸法边不可得。须菩提言。世尊。颇有色亦无数无量无边。颇有受想行识亦无数无量无边。须菩提。有因缘色亦无数无量无边。受想行识亦无数无量无边。世尊。何等因缘故。色亦无数无量无边。受想行识亦无数无量无边。佛告须菩提。色空故无数无量无边。受想行识空故无数无量无边。世尊。但色空受想行识空。非一切法空耶。须菩提。我不常说一切法空耶。须菩提言。世尊。佛说一切法空世尊。诸法空即是不可尽。无有数无量无边。世尊。空中数不可得量不可得边不可得。以是故。世尊。是不可尽。无数无量无边义无有是异。佛告须菩提。如是如是。是法义无别异。须菩提。是法不可说。佛以方便力故分别说。所谓不可尽无数无量无边无著。空无相无作无起无生无灭无染涅槃。佛种种因缘以方便力说。须菩提白佛言。希有世尊。诸法实相不可说。而佛以方便力故说。世尊。如我解佛所说义。一切法亦不可说。佛言。如是如是。须菩提。一切法不可说。一切法不可说相即是空。是空不可说。世尊。不可说义有增有减不。佛言。不也须菩提。不可说义无增无减。世尊。若不可说义无增无减。檀那波罗蜜亦当无增无减。乃至般若波罗蜜亦当无增无减。四念处乃至八圣道分亦当无增无减。四禅四无量心四无色定。五神通八背舍八胜处九次第定。佛十力四无所畏四无阂智十八不共法。亦当无增无减。世尊。若菩萨摩诃萨。六波罗蜜不增。乃至十八不共法不增者。云何菩萨摩诃萨得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。不可说义无增无减。菩萨摩诃萨习行般若波罗蜜有方便力故。不作是念我增般若波罗蜜乃至增檀那波罗蜜。当作是念但名字故名檀那波罗蜜。是菩萨摩诃萨行檀那波罗蜜时。是心及诸善根如阿耨多罗三藐三菩提相回向。乃至行般若波罗蜜时。是心及诸善根如阿耨多罗三藐三菩提相回向。须菩提白佛言。世尊。何等是阿耨多罗三藐三菩提。佛言。一切法如相。是名阿耨多罗三藐三菩提。须菩提白佛言。世尊。何等是一切法如相。是阿耨多罗三藐三菩提。佛告须菩提。色如相受想行识如相。乃至涅槃如相。是阿耨多罗三藐三菩提是如相。亦不增不减。须菩提。是菩萨摩诃萨不离般若波罗蜜。常观是如法。不见有增有减。以是因缘故。须菩提。不可说义无增无减。檀那波罗蜜亦不增不减。乃至十八不共法亦不增不减。须菩提。菩萨摩诃萨以是不增不减法故。应般若波罗蜜行。须菩提白佛言。世尊。菩萨摩诃萨用初心得阿耨多罗三藐三菩提。用后心得阿耨多罗三藐三菩提。世尊。是初心不至后心。后心不在初心。世尊。如是心心数法不具。云何善根增益。若善根不增。云何当得阿耨多罗三藐三菩提。佛告须菩提。我当为汝说譬喻。智者得譬喻则于义易解。须菩提。譬如然灯。为用初焰燋炷。为用后焰燋炷。须菩提言。世尊。非初焰燋炷亦非离初焰。世尊。非后焰燋炷亦非离后焰。须菩提。于汝意云何。炷为燋不。世尊。炷实燋。佛告须菩提。菩萨摩诃萨如是。不用初心得阿耨多罗三藐三菩提。亦不离初心得阿耨多罗三藐三菩提。不用后心得阿耨多罗三藐三菩提。亦不离后心得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。须菩提。是中菩萨摩诃萨从初发意行般若波罗蜜具足十地得阿耨多罗三藐三菩提须菩提白佛言。世尊。何等是十地。菩萨具足已得阿耨多罗三藐三菩提。佛言。菩萨摩诃萨具足干慧地性地八人地见地薄地离欲地已作地辟支佛地菩萨地佛地。具足是地得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨学是十地已。非初心得阿耨多罗三藐三菩提亦不离初心得阿耨多罗三藐三菩提。非后心得阿耨多罗三藐三菩提。亦非离后心得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。须菩提言。世尊。是因缘法甚深。所谓非初心非离初心。非后心非离后心得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。若心灭已是心更生不。不也世尊。须菩提。于汝意云何。心生是灭相不。世尊是灭相。须菩提。于汝意云何。心灭相是灭不。不也世尊。佛告须菩提。于汝意云何。亦如是住不。须菩提言。世尊。亦如是住如如住。佛告须菩提。于汝意云何。若是心如如住。当作实际证不。不也世尊。佛告须菩提。于汝意云何。是如甚深不。世尊。甚深甚深。须菩提。于汝意云何。但如是心不。不也世尊离如是心不。不也世尊。须菩提。于汝意云何。如见如不。不也世尊。须菩提。于汝意云何。若菩萨能如是行。为行深般若波罗蜜不。须菩提言。世尊。若菩萨摩诃萨能如是行。为行深般若波罗蜜。须菩提。于汝意云何。若菩萨摩诃萨如是行是何处行。须菩提言。世尊。若菩萨摩诃萨作如是行。为无处所行。何以故。菩萨摩诃萨。行般若波罗蜜住诸法如中。无如是念无念处亦无念者。佛告须菩提。若菩萨摩诃萨如是行为何处行。须菩提言。世尊。是菩萨摩诃萨如是行。为第一义中行。二行不可得故。须菩提。于汝意云何。若菩萨第一义无念中行为行相不。不也世尊。于汝意云何。是菩萨摩诃萨坏相不。不也世尊。佛告须菩提。云何名不坏相。须菩提言。世尊是菩萨摩诃萨行般若波罗蜜。不作是念我当坏诸法相。世尊。菩萨摩诃萨行般若波罗蜜。未具足佛十力四无所畏四无碍智大慈大悲十八不共法。不得阿耨多罗三藐三菩提。世尊。菩萨摩诃萨以方便力故。于诸法亦不取相亦不坏相。何以故。世尊。是菩萨摩诃萨知一切诸法自相空故。菩萨摩诃萨住是自相空中。为众生故入三三昧。用是三三昧成就众生。须菩提言。世尊。云何菩萨摩诃萨入三三昧成就众生。佛言。菩萨住是三三昧。见众生作法中行。菩萨以方便力教令得无作。见众生我相中行。以方便力教令行空。见众生一切相中行。以方便力故教令行无相。如是须菩提。菩萨摩诃萨行般若波罗蜜。入三三昧以三三昧成就众生

    摩诃般若波罗蜜经梦行品第五十八(丹梦入三昧品)

尔时舍利弗问须菩提。若菩萨摩诃萨。梦中入三三昧空无相无作三昧。宁有益于般若波罗蜜不。须菩提报舍利弗。若菩萨昼日入三三昧。有益于般若波罗蜜。夜梦中亦当有益。何以故。昼夜梦中等无有异。舍利弗。若菩萨摩诃萨昼日行般若波罗蜜有益。是菩萨梦中行般若波罗蜜亦应有益。舍利弗问须菩提。菩萨摩诃萨若梦中所作业。是业有集成不。如佛所说一切法如梦。以是故不应集成。何以故。梦中无有法集成。若觉时忆想分别应有集成。须菩提语舍利弗。若人梦中杀众生。觉已忆念取相分别我杀是快耶。舍利弗。是事云何。舍利弗言。无缘业不生。无缘思不生。有缘业生。有缘思生。舍利弗。如是如是。无缘业不生。无缘思不生。有缘业生。有缘思生。于见闻觉知法中心生。不从不见闻觉知法中心生。是中心有净有垢。以是故。舍利弗。有缘故业生。不从无缘生。有缘故思生。不从无缘生。舍利弗语须菩提。如佛说一切诸业诸思自相离。云何言有缘故业生。无缘业不生。有缘故思生。无缘思不生。须菩提语舍利弗。取相故有缘业生。不从无缘生。取相故有缘思生。不从无缘生。舍利弗语须菩提。若菩萨摩诃萨梦中有布施持戒忍辱精进禅定智慧。是善根福德回向阿耨多罗三藐三菩提。是实回向不。须菩提语舍利弗。弥勒菩萨今现在前。佛授不退转记当作佛。当问弥勒。弥勒当答。舍利弗白弥勒菩萨。须菩提言。弥勒菩萨今现在前。佛授不退转记当作佛。弥勒当答。弥勒菩萨语舍利弗。当以弥勒名答耶。若色受想行识答耶。若色空答耶。若受想行识空答耶。是色不能答。受想行识不能答。色空不能答。受想行识空不能答。我不见是法可答。不见能答者。我不见是人受记。亦不见法可受记者。亦不见受记处。是一切法皆无二无别。舍利弗语弥勒菩萨。如仁者所说。如是为得法作证不。弥勒答舍利弗。如我所说法如是不证。尔时舍利弗作是念。弥勒菩萨智慧甚深。久行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。用无所得故能如是说。尔时佛告舍利弗。于汝意云何。汝用是法得阿罗汉见是法不。舍利弗言。不见也。舍利弗。菩萨摩诃萨行般若波罗蜜亦如是。不作是念。是法当得受记是法已受记。是法当得阿耨多罗三藐三菩提。如是舍利弗。菩萨摩诃萨行般若波罗蜜。不疑我若得若不得。自知实得阿耨多罗三藐三菩提

佛告须菩提。有菩萨摩诃萨行檀那波罗蜜时。若见众生饥寒冻饿衣服弊坏。菩萨摩诃萨当作是愿。我随尔所时行檀那波罗蜜。我得阿耨多罗三藐三菩提时。令我国土众生无如是事。衣服饮食资生之具。当如四天王天三十三天夜摩天兜率陀天化乐天他化自在天。须菩提。菩萨摩诃萨作如是行。能具足檀那波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行尸罗波罗蜜时。见众生杀生乃至邪见。短命多病颜色不好。无有威德贫乏财物。生下贱家形残丑陋。当作是颜。我随尔所时行尸罗波罗蜜。如我得佛时令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足尸罗波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行羼提波罗蜜时。见诸众生互相嗔恚骂詈刀杖瓦石共相残害夺命。当作是愿。我随尔所时行羼提波罗蜜。我作佛时令我国土众生无如是事。相视如父如母如兄如弟如姊妹。如善知识皆行慈悲。须菩提。菩萨摩诃萨作如是行。能具足羼提波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行毗梨耶波罗蜜时。见众生懈怠不勤精进。弃舍三乘声闻辟支佛佛乘。当作是愿。我随尔所时行毗梨耶波罗蜜。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。一切众生勤修精进。于三乘道各得度脱。须菩提。菩萨摩诃萨作如是行。能具足毗梨耶波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行禅那波罗蜜时。见众生为五盖所覆淫欲嗔恚睡眠调悔疑。失于初禅乃至第四禅。失慈悲喜舍虚空处识处无所有处非有想非无想处。当作是愿。我随尔所时行禅那波罗蜜。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足禅那波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行般若波罗蜜时。见众生愚痴失世间出世间正见。或说无业无业因缘。或说神常或说断灭。或说无所有。当作是愿。我随尔所时行般若波罗蜜。净佛国土成就众生。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足般若波罗蜜疾近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生住于三聚。一者必正聚。二者必邪聚。三者不定聚。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我得佛时令我国土众生无邪聚乃至无其名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜疾近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见地狱中众生畜生饿鬼中众生。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我得佛时令我国土中乃至无三恶道名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见是大地株杌荆棘山陵沟坑秽恶之处。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土无如是恶地平如掌。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见是大地纯土无有金银珍宝。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土以黄金沙布地。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有所恋着。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无所恋着。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行六波罗蜜时。见四姓众生刹帝利婆罗门毗舍首陀罗。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无四姓之名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有下中上下中上家。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无如是优劣。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生种种别异色。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无种种别异色。一切众生皆端正净洁妙色成就。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时见众生有主。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无有主名。乃至无其形像。除佛法王。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时见众生有六道别异。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无六道之名是地狱是畜生是饿鬼是神是天是人。一切众生皆同一业。修四念处乃至八圣道分。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜疾近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有四生卵生胎生湿生化生。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生无三种生等一化生。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无五神通。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我国土众生一切皆得五通。乃至疾近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有大小便患。当作是愿。我作佛时令我国土中众生皆以欢喜为食无有便利之患。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无有光明。当作是愿。我作佛时令我国土中众生皆有光明。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见有日月时节岁数。当作是愿。我作佛时令我国土中无有日月时节岁数之名。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生短命。当作是愿。我作佛时令我国土中众生寿命无量劫。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无有相好。当作是愿。我作佛时令我国土中众生皆有三十二相成就。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生离诸善根当作是愿。我作佛时令我国土中众生诸善根成就以是善根故能供养诸佛。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有三毒四病。当作是愿。我作佛时令我国土众生无四种病冷热风病。三种杂病及三毒病。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有三乘。当作是愿。我作佛时令我国土中众生无二乘之名纯一大乘。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有增上慢。当作是愿。我作佛时令我国土中众生无增上慢之名。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时应作是愿。若我光明寿命有量僧数有限。当作是愿。我行六波罗蜜净佛国土成就众生。我作佛时令我光明寿命无量僧数无限。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。应作是愿。若我国土有量。当作是愿。我随尔所时行六波罗蜜。净佛国土成就众生。我作佛时令我一国土如恒河沙等诸佛国土。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。当作是念。虽生死道长众生性多。尔时应如是正忆念。生死边如虚空。众生性边亦如虚空。是中实无生死往来亦无解脱者。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智

摩诃般若波罗蜜经卷第十七摩诃般若波罗蜜经卷第十八

        后秦龟兹国三藏鸠摩罗什译

    河天品第五十九

尔时有女人字恒伽提婆。在众中坐。是女人从座起。偏袒右肩右膝着地合手白佛言世尊我当行六波罗蜜取净佛国土。如佛般若波罗蜜中所说我尽当行。是时女人以金银华及水陆生华种种庄严供养之具。金缕织成[疊*毛]两张以散佛上。散已于佛顶上虚空中。化成四柱宝台端正严好。是女人持是功德与一切众生共之。回向阿耨多罗三藐三菩提。尔时世尊。知是女人深心因缘即时微笑。如诸佛法种种色光从口中出。青黄赤白红缥。遍照十方无量无边佛国。还绕佛三匝从顶上入。尔时阿难从座起。右膝着地合手白佛。佛何因缘微笑。诸佛法不以无因缘而笑。佛告阿难。是恒伽提婆姊。未来世中当作佛。劫名星宿。佛号金华阿难。是女人毕是女身受男子形。当生阿閦佛阿鞞罗提国土。于彼净修梵行。阿难。是菩萨在彼国土亦号金华。是金华菩萨于彼寿终复至他方佛国。从一佛国至一佛国不离诸佛。譬如转轮圣王从一观至一观。从生至终足不蹈地。阿难。是金华菩萨摩诃萨。亦如是从一佛国至一佛国。乃至阿耨多罗三藐三菩提未常不见佛。时阿难作是念言。是金华菩萨摩诃萨。后作佛时诸菩萨摩诃萨会。当知为如佛会。佛知阿难意所念。告阿难言。如是如是。金华佛时菩萨摩诃萨会。当知为如佛会。阿难。是金华佛。比丘僧无量无边不可称不可数若干百千万亿那由他。阿难。是金华菩萨作佛时其国土无有众恶如上所说。阿难白佛言。世尊。是女人从何处殖德本种善根。佛告阿难。是女人。从然灯佛种善根初发阿耨多罗三藐三菩提心。以是功德回向阿耨多罗三藐三菩提。亦以金华散然灯佛上。求阿耨多罗三藐三菩提。阿难。如我尔时以五华散然灯佛上。求阿耨多罗三藐三菩提。然灯佛知我善根成就。与我受阿耨多罗三藐三菩提记。是女人。闻我受记发心言。愿我当来世亦如是菩萨。得受阿耨多罗三藐三菩提记。阿难当知是女人。于然灯佛初发心。阿难白佛言。世尊。是女人。久习行阿耨多罗三藐三菩提。佛言。如是如是。是女人。久习行阿耨多罗三藐三菩提

    摩诃般若波罗蜜经不证品第六十(丹学空不证品)

须菩提白佛言世尊。若菩萨摩诃萨欲行般若波罗蜜云何学空三昧。云何入空三昧。云何学无相无作三昧。云何入无相无作三昧。云何学四念处。云何修四念处。乃至云何学八圣道分。云何修八圣道分。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。应观色空受想行识空十二入十八界空。乃至应观欲色无色界空。作是观时不令心乱。是菩萨摩诃萨若心不乱则不见是法。若不见是法则不作证。何以故。是菩萨摩诃萨善学自相空故。不有余不有分。证法证者皆不可见。须菩提白佛言。世尊。如佛所说菩萨摩诃萨不应空法作证。世尊。云何菩萨住空法中而不作证。佛告须菩提。若菩萨摩诃萨具足观空先作是愿。我今不应空法作证。我今学时非是证时。菩萨摩诃萨。不专摄心系在缘中。以是故。菩萨摩诃萨于阿耨多罗三藐三菩提中不退。亦不取漏尽证。须菩提。若菩萨摩诃萨。如是大善妙法成就。何以故。住是空中作是念。我今是学时非是证时。须菩提。菩萨摩诃萨应如是念。我是学檀那波罗蜜时非是证时。学尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜时。修四念处时乃至修八圣道分时非是证时。修空三昧无相三昧无作三昧时非是证时。修佛十力四无所畏四无碍智十八不共法大慈大悲时非是证时。我今学一切种智时。非是得须陀洹果证乃至阿罗汉果辟支佛道证时。如是须菩提。菩萨摩诃萨行般若波罗蜜。学空观住空中。学无相无作观住无相无作中。修四念处不证四念处。乃至修八圣道分不证八圣道分。是菩萨虽学三十七品。虽行三十七品而不作须陀洹果证乃至辟支佛道。须菩提。譬如壮夫劲勇猛健善于兵法六十四能。坚持器仗安立不动巧诸伎术端正净洁人所爱敬。少修事业得报利多。以是因缘故。众所恭敬尊重赞叹。见人敬重倍复欢喜。少有因缘当至他处。扶将老弱过诸崄难恐怖之处。安慰父母晓喻妻子。莫有恐懅我能过此必无所苦。崄难道中多有怨贼潜伏劫害。其人智力具足故。能度恶道还归本处。不遇贼害欢喜安乐。须菩提。菩萨摩诃萨亦如是。于一切众生中慈悲喜舍心遍满足。尔时菩萨摩诃萨。住四无量心具足六波罗蜜。不取漏尽证学一切种智。入空无相无作解脱门。是时菩萨不随一切诸相。亦不证无相三昧。以不证无相三昧故。不堕声闻辟支佛地。须菩提。譬如有翼之鸟飞腾虚空而不堕坠。虽在空中。亦不住空。须菩提。菩萨摩诃萨亦如是学空解脱门学无相无作解脱门亦不作证。以不证故不堕声闻辟支佛地。未具足佛十力大慈大悲无量诸佛法一切种智。亦不证空无相无作解脱门。须菩提。譬如健人学诸射法善于射术。仰射空中复以后箭射于前箭。箭箭相拄不令前堕随意自在。若欲令堕便止后箭尔乃堕地。须菩提。菩萨摩诃萨亦如是。行般若波罗蜜以方便力故。为阿耨多罗三藐三菩提。诸善根未具足不于实际作证。若善根成就是时便于实际作证。以是故。须菩提。菩萨摩诃萨行般若波罗蜜时。应如是观诸法法相

须菩提白佛言。世尊。菩萨摩诃萨所为甚难。何以故。虽学是诸法相学实际学如学法性学毕竟空乃至学自相空及三解脱门。终不中道堕落。世尊。是甚希有。佛告须菩提。是菩萨摩诃萨不舍一切众生故作如是愿。须菩提。若是菩萨摩诃萨作是念。我不应舍一切众生。一切众生没在无所有法中我应当度。尔时即入空解脱门无相解脱门无作解脱门。须菩提。当知是菩萨摩诃萨。成就方便力未得一切种智。行是解脱门亦不中道取实际证

复次须菩提。菩萨摩诃萨欲观是诸甚深法。所谓内空乃至无法有法空。四念处乃至三解脱门。尔时菩萨摩诃萨应生如是心。是诸众生长夜行我相乃至知者见者相。着于得法。为众生断是诸相故。得阿耨多罗三藐三菩提时当说法。尔时菩萨行空解脱门无相无作解脱门。亦不应取实际证。以不证故不堕须陀洹果乃至辟支佛道。须菩提。是菩萨摩诃萨以是心。欲成就善根故。不中道实际作证。不失四禅四无量心四无色定。四念处乃至八圣道分空无相无作。佛十力四无所畏四无碍智。大慈大悲十八不共法是时菩萨摩诃萨成就一切助道法。乃至阿耨多罗三藐三菩提终不耗减。是菩萨有方便力故常增益善法。诸根通利胜于阿罗汉辟支佛根

复次须菩提。若菩萨摩诃萨作是念。众生长夜着四颠倒。常相乐相净相我相为是众生故求萨婆若。我得阿耨多罗三藐三菩提时。为说无常法苦不净无我法。是菩萨成就是心。以方便力行般若波罗蜜不得佛三昧。未具足佛十力四无所畏四无碍智大慈大悲十八不共法。亦不实际作证。尔时菩萨修无作解脱门。虽未得阿耨多罗三藐三菩提亦不实际作证。复次须菩提。若菩萨摩诃萨作是念。众生长夜着得法。所谓我众生乃至知者见者。是色是受想行识。是入是界。是四禅四无量心四无色定。我如是行。如我得阿耨多罗三藐三菩提时。令众生无是得法。菩萨是心成就以方便力行般若波罗蜜。未具足佛十力四无所畏四无碍智。大慈大悲十八不共法。不于实际作证。尔时菩萨具足修空三昧。复次须菩提。若菩萨摩诃萨作是念。众生长夜行诸相。所谓男相女相色相无色相。我如是行。如我得阿耨多罗三藐三菩提时。令众生无是诸相过失。是心成就以方便力行般若波罗蜜。未具足佛十力乃至十八不共法。不于实际作证。尔时菩萨摩诃萨。具足修无相三昧。须菩提。若菩萨摩诃萨学六波罗蜜。学内空乃至无法有法空。学四念处乃至空无相无作解脱门。学佛十力四无所畏四无碍智大慈大悲。学十八不共法。如是智慧成就。若著作法若住三界无有是处。是菩萨摩诃萨学助道法行助道法时应当试问。菩萨摩诃萨欲得阿耨多罗三藐三菩提。云何学是法观空不证空实际。以不证故不堕须陀洹果乃至辟支佛道。观无相无作无起无生无所有。亦不取证实际。而修行般若波罗蜜。应如是问。须菩提。若诸菩萨摩诃萨若试问时。是菩萨若如是答。菩萨摩诃萨但应观空。但应观无相无作无起无生无所有。是菩萨摩诃萨不应学空无相无作无起无生无所有。不应学是助道法。须菩提。当知是菩萨诸佛未授阿耨多罗三藐三菩提记。何以故。是人不能说阿惟越致菩萨所学相。不能示不能答。若是菩萨摩诃萨能说能示能答阿惟越致所学相。当知是菩萨摩诃萨已习学菩萨道入薄地。如余阿惟越致菩萨摩诃萨阿惟越致地。须菩提白佛言。世尊。颇有未得阿惟越致菩萨能如是答不。佛言有。须菩提。是菩萨摩诃萨。六波罗蜜若闻若不闻能如是答如阿惟越致菩萨摩诃萨。须菩提言。世尊。多有菩萨求佛道。少有菩萨能如是答如阿惟越致菩萨摩诃萨学道无学道中。佛语须菩提。如是如是。是菩萨甚少。何以故。菩萨摩诃萨少有如是得受记阿惟越致慧地。若有得受记是人能如是答。是人善根明了。诸天世人所不能坏

    摩诃般若波罗蜜经梦誓品第六十一(丹中不梦证品)

佛告须菩提。若菩萨摩诃萨乃至梦中不贪声闻辟支佛地亦不贪三界。观诸法如梦如幻如响如焰如化亦不作证。须菩提。当知是阿惟越致菩萨摩诃萨阿惟越致相。复次须菩提。菩萨摩诃萨梦中见佛与无数百千万亿比丘比丘尼优婆塞优婆夷。天龙鬼神紧那罗等说法。从佛闻法即解中义随法行。须菩提。当知是阿惟越致菩萨摩诃萨阿惟越致相

复次须菩提。菩萨摩诃萨梦中见佛三十二相八十随形好。放大光明踊在虚空。于大比丘僧中说法。现大神力化作化人。到他国土施作佛事。须菩提。当知是阿惟越致菩萨摩诃萨阿惟越致相。复次须菩提。若菩萨摩诃萨梦中见兵起。若破聚落若破城邑。若失火时。若见虎狼师子猛害之兽。若见欲来断其头者。若见父母丧亡兄弟姊妹及诸亲友知识死者。见如是等种种愁苦之事。而不惊不怖亦不忧恼。从梦觉已。即时思惟三界虚妄皆如梦耳。我得阿耨多罗三藐三菩提时。亦当为众生说三界如梦。须菩提。当知是阿惟越致菩萨摩诃萨阿惟越致相。复次须菩提。云何当知是阿惟越致菩萨摩诃萨。得阿耨多罗三藐三菩提时国中无三恶道。须菩提。菩萨摩诃萨若梦中见地狱畜生饿鬼。作是念我当勤精进得阿耨多罗三藐三菩提时。令我国中无一切三恶道。何以故。是梦及诸法无二无别。须菩提。当知是阿惟越致菩萨摩诃萨阿惟越致相。复次须菩提。菩萨摩诃萨。梦中见地狱火烧众生。作是誓若我实是阿惟越致者是火当灭。是火即灭若地狱火即灭是阿惟越致相。复次若菩萨昼日见城郭火起。作是念我梦中见阿惟越致行类相貌。我今实有是者。自立誓言是火当灭。若火灭者当知是菩萨得受阿耨多罗三藐三菩提记住阿惟越致地。若火不灭烧一家置一家。烧一里置一里。须菩提。当知被烧家破法业因缘厚集。以是故烧一家置一家。是诸众生今世受破法余殃故被烧。须菩提。以是因缘故。当知是阿惟越致菩萨摩诃萨阿惟越致相。佛告须菩提。今当更为汝说阿惟越致行类相貌。须菩提。若男子若女人为非人所持。是时菩萨摩诃萨作是念。若我为过去诸佛所受记我心清净求阿耨多罗三藐三菩提。行清净正道远离声闻辟支佛心。远离声闻辟支佛念。应当成阿耨多罗三藐三菩提。我必得阿耨多罗三藐三菩提。非不得。十方国土中现在无量诸佛。无所不知无所不见。无所不解无所不证。诸佛知我深心。审定必当得阿耨多罗三藐三菩提。以是至诚誓故是男子女人为非人所持为非人所恼。是非人当远去。须菩提。是菩萨摩诃萨如是誓。若非人不去者。当知是菩萨摩诃萨未从过去诸佛受阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨如是誓若非人去者。当知是菩萨摩诃萨已从过去诸佛受阿耨多罗三藐三菩提记。须菩提。以是行类相貌。当知是阿惟越致菩萨摩诃萨阿惟越致相。复次须菩提。菩萨摩诃萨远离六波罗蜜及方便力。不久行四念处乃至不久行空无相无作三昧。未入菩萨位是菩萨为恶魔所娆菩萨作是誓。若我实从诸佛受记者。是非人当去。是时恶魔即作方便敕非人令去。恶魔有威力胜诸非人故非人即去。是时菩萨作是念。以我誓力故非人去。不知是恶魔力。恃是证故轻弄毁蔑诸余菩萨。作是言我已从诸佛受记汝等未得。用是空誓无方便力故生增上慢。以是事故远离萨婆若。远离阿耨多罗三藐三菩提。须菩提。当知是人堕于二地。若声闻地若辟支佛地。以是誓因缘故起于魔事。是人以不亲近依止善知识不问阿惟越致相故。为魔所缚益复坚固。所以者何。是菩萨不久行六波罗蜜无方便力故。须菩提。当知是为菩萨魔事。须菩提。云何菩萨摩诃萨不久行六波罗蜜。乃至未入菩萨位为恶魔所娆。须菩提。恶魔变化作种种身。语菩萨言。汝于诸佛所得受阿耨多罗三藐三菩提记。汝字某汝父字某。汝母字某。汝兄弟姊妹字某。汝七世父母名字如是。汝在某方某国某城某聚落中生。若见菩萨性行和柔。语菩萨言。汝先世亦复柔和。若见急性卒暴便言。汝先世亦尔。若见菩萨修阿兰若行语言。汝先世亦修阿兰若行。若见菩萨乞食纳衣中后不饮浆。一坐食一钵他食。死尸间住露地住树下止。常坐不卧如敷座。但受三衣若少欲若知足。若远离住若不涂脚若少言语。便语言汝先世亦有是行。何以故。汝今有此头陀功德。汝先世亦必有是功德。是菩萨闻是先世事及名姓。闻今赞头陀功德即欢喜生憍慢心。是时恶魔语菩萨言。汝有如是功德如是相。汝实从诸佛受阿耨多罗三藐三菩提记。须菩提。恶魔或作比丘被服。或作居土形或作父母身来到菩萨所。如是言汝已得受阿耨多罗三藐三菩提记。何以故。是阿惟越致功德相。汝尽具足有之。须菩提。我所说实阿惟越致行类相貌是人永无。须菩提。当知是菩萨摩诃萨为魔所持。何以故。是阿惟越致行类相貌是人永无以闻是名字故。生憍慢心轻弄毁蔑余人。须菩提。是名菩萨摩诃萨为魔所持。当知是为菩萨魔事。复次须菩提。菩萨摩诃萨不久行六波罗蜜不知名字相。不知色相不知受想行识相。恶魔来语言。汝当来世得阿耨多罗三藐三菩提时有如是名字。随其本念说其名号。是无智无方便菩萨作是念。我先亦有是成佛名号。念是人如我所念说。是人所说合我本念。我必为诸佛所受记。须菩提。我所说阿惟越致行类相貌是人永无。但以空名字轻弄毁蔑余人。以是事故远离阿耨多罗三藐三菩提。是菩萨摩诃萨远离般若波罗蜜无方便力。远离善知识。与恶知识相得故堕二地声闻辟支佛地。若有即是身悔过久久往来生死中。然后还依止般若波罗蜜。若值善知识常随逐亲近故。当得阿耨多罗三藐三菩提。是人于是身若不即悔。当堕二地若阿罗汉地若辟支佛地。须菩提。譬如比丘于四重禁法若犯一事。非沙门非释子。是人现身不得四沙门果。须菩提。是菩萨着空名字菩萨心亦如是。轻弄毁蔑余人故。当知是罪重于比丘四禁。须菩提。置是重罪其罪过于五逆。以受是名字故。生高心轻弄毁蔑余人。若生是心当知其罪甚重。如是名字等微细魔事菩萨皆当觉知。复次须菩提。菩萨在空闲山泽旷远之处。魔来到菩萨所赞叹远离法。作是言。善男子。汝所行者是佛所称誉远离法。须菩提。我不赞是远离。所谓但在空闲山泽旷远之处。名为远离。须菩提言。世尊。若空闲山泽旷远之处。非远离法者。云何更有异远离法。佛告须菩提。若菩萨摩诃萨远离声闻辟支佛心。住空闲山泽旷远之处。是佛所许远离法。须菩提。如是远离法。菩萨摩诃萨应所修行。昼夜行是远离法。是名远离行菩萨。须菩提若恶魔所说远离法。空闲山泽旷远之处。是菩萨心在愦闹。所谓不远离声闻辟支佛心。不勤修般若波罗蜜。是菩萨摩诃萨不能具足一切种智。是菩萨行恶魔所说远离法。心不清净而轻余菩萨城傍心净无声闻辟支佛愦闹心。亦无诸余杂恶心具足禅定解脱智慧神通者。是离般若波罗蜜无方便菩萨摩诃萨。虽在绝旷百由旬外禽兽鬼神罗刹所住之处。若一岁百千万亿岁若过万亿岁。不知是菩萨远离法。所谓诸菩萨以是远离法。深心发阿耨多罗三藐三菩提不杂行。是菩萨愦闹行而依受着是远离。是人所行佛所不许。须菩提。我所说实远离法。是菩萨不在是中。亦不见是远离相。何以故。但行是空远离故尔时恶魔来在虚空中住赞言。善哉善哉。善男子。此是佛所说真远离法。汝行是远离疾得阿耨多罗三藐三菩提。是菩萨摩诃萨念着是远离。而轻易诸余求佛道清净比丘以为愦闹。以愦闹为不愦闹。以不愦闹为愦闹。应恭敬而不恭敬。不应恭敬而恭敬。是菩萨作是言。非人念我来称赞我。我所行者是真远离。住城傍者谁当称美汝。以是因缘故轻余菩萨摩诃萨。须菩提。当知是名菩萨旃陀罗污染诸菩萨。是人以像菩萨实是天上人中之大贼。亦是沙门被服中贼。如是人诸求佛道者。所不应亲近不应供养恭敬。何以故。须菩提当知是人堕增上慢。以是故。若菩萨摩诃萨。欲不舍一切智。欲得阿耨多罗三藐三菩提。一心欲求阿耨多罗三藐三菩提。欲利益一切众生。不应亲近是人恭敬供养。菩萨摩诃萨法常应勤求自利厌患世间。心常远离三界。于是人当起慈悲喜舍心。我行菩萨道不应生如是过罪。若生当疾灭。须菩提。菩萨摩诃萨当善觉是事。是事中善自勉出。复次须菩提。菩萨摩诃萨深心欲得阿耨多罗三藐三菩提者。当亲近恭敬供养善知识。须菩提白佛言。世尊。何等是菩萨摩诃萨善知识。佛告须菩提。诸佛是菩萨摩诃萨善知识。诸菩萨摩诃萨亦是菩萨善知识。须菩提。阿罗汉亦是菩萨善知识。是为菩萨摩诃萨善知识。复次须菩提。六波罗蜜亦是菩萨善知识。四念处乃至十八不共法亦是菩萨善知识。须菩提。如实际法性亦是菩萨善知识。须菩提。六波罗蜜是菩萨。世尊。六波罗蜜是菩萨摩诃萨道。六波罗蜜是大明。六波罗蜜是炬。六波罗蜜是智。六波罗蜜是慧。六波罗蜜是救。六波罗蜜是归六波罗蜜是洲。六波罗蜜是究竟道。六波罗蜜是父是母。四念处乃至一切种智亦如是。何以故。六波罗蜜三十七道法。亦是过去诸佛父母。六波罗蜜三十七道法。亦是未来现在十方诸佛父母。何以故。须菩提六波罗蜜三十七道法中。生过去未来现在十方诸佛故。以是故。须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。净佛国土成就众生。当学六波罗蜜三十七道法。及四摄法摄取众生。何等四。布施爱语利益同事须菩提。以是利益故我言六波罗蜜及三十七道法是诸菩萨摩诃萨。世尊。是道是大明是炬是智是慧是救是归是洲是究竟道是父是母。须菩提。以是故。菩萨摩诃萨欲不随他人教住。欲断一切众生疑。欲净佛国土成就众生。当学是般若波罗蜜。所以者何。是般若波罗蜜中广说诸法。是菩萨摩诃萨所应学处。尔时须菩提白佛言。世尊。何等是般若波罗蜜相。佛告须菩提。如虚空相是般若波罗蜜相。须菩提。般若波罗蜜无所有相。须菩提白佛言。世尊。颇有因缘如般若波罗蜜相。诸法相亦如是耶。佛告须菩提。如是如是。如般若波罗蜜相诸法相亦如是。何以故。须菩提。一切法离相自性空相。以是因缘故。须菩提。如般若波罗蜜相诸法相亦如是。所谓离相空相故。须菩提白佛言。世尊。若一切法一切法离。一切法一切法空。云何知众生若垢若净世尊。离相法无垢无净。空相法无垢无净。离相空相法不能得阿耨多罗三藐三菩提。离相空相无法可得。世尊。离相中空相中。无有菩萨得阿耨多罗三藐三菩提者。世尊。我云何当知佛所说义。佛告须菩提。于汝意云何。是众生长夜行我我所心不。如是世尊。众生长夜行我我所心。于汝意云何。是我我所心。离相不空相不。须菩提言。世尊。我我所心离相空相。于汝意云何。以此我我所心。众生往来生死中不。如是世尊。以此我我所心。众生往来生死中。如是须菩提。众生往来生死中故知有垢恼。须菩提。若众生无我我所心无著心。是众生不复往来生死中。若不往来生死中则无垢恼。如是须菩提。众生有净。须菩提白佛言。世尊。若菩萨摩诃萨如是行为不行色不行受想行识。为不行四念处乃至八圣道分。为不行内空乃至无法有法空。为不行佛十力乃至一切种智。何以故。是法不可得。亦无行者亦无行处亦无行法。世尊。菩萨摩诃萨如是行。一切世间诸天人阿修罗。不能降伏是菩萨摩诃萨。一切声闻辟支佛所不能及。何以故。所住处无能及故。所谓菩萨位。世尊。是菩萨摩诃萨行应萨婆若心无能及者。须菩提。菩萨摩诃萨如是行疾近萨婆若。须菩提。于汝意云何。若阎浮提众生尽得人身。得人身已皆得阿耨多罗三藐三菩提。若有善男子善女人。尽其形寿供养恭敬尊重赞叹。持是善根回向阿耨多罗三藐三菩提。是人以是因缘得福多不。须菩提言。甚多世尊。佛言。不如是善男子善女人。于大众中说是般若波罗蜜。显示分别照明开演。亦应般若波罗蜜行正忆念其福多。乃至三千大千世界中众生亦如是。须菩提。于汝意云何。阎浮提中众生一时皆得人身。得人身已若善男子善女人。教行十善道四禅四无量心四无色定。教令得须陀洹道乃至阿罗汉辟支佛道。教令得阿耨多罗三藐三菩提。持是善根回向阿耨多罗三藐三菩提。须菩提。于汝意云何。是善男子善女人得福多不。须菩提言。甚多世尊。佛言。不如是善男子善女人。以是甚深般若波罗蜜为众生说。显示分别照明开演。亦不离萨婆若得福多。乃至三千大千世界亦如是。是菩萨摩诃萨不远离应萨婆若心。则到一切福田边。何以故。除诸佛无有余法如菩萨摩诃萨势力。何以故。诸菩萨摩诃萨行般若波罗蜜时。于一切众生中起大慈心。见诸众生趣死地故而起大悲。行是道时欢悦而生大喜。不与想俱便得大舍。须菩提。是为菩萨摩诃萨大智光明。大智明者。所谓六波罗蜜。须菩提。是诸善男子善女人虽未作佛。能为一切众生作大福田。于阿耨多罗三藐三菩提亦不转。所受供养衣服饮食卧床疾药资生所须。行应般若波罗蜜念。能必报施主之恩。疾近萨婆若。以是故。须菩提。若菩萨摩诃萨欲不虚食国中施。欲示众生三乘道。欲为众生作大明。欲拔出三界牢狱。欲与一切众生眼。应常行般若波罗蜜。常行般若波罗蜜时。若欲有所说但说般若波罗蜜。说般若波罗蜜已。常忆念般若波罗蜜。常忆念般若波罗蜜已。常行般若波罗蜜。不令余念得生。昼夜勤行般若波罗蜜相应念不息不休。须菩提。譬如士夫未曾得摩尼珠后时得。得已大欢喜踊跃。后复失之便大忧愁。常忆念是摩尼珠。作是念我奈何忽忘此大宝。须菩提。菩萨摩诃萨亦如是。常忆念般若波罗蜜。不离萨婆若心。须菩提白佛言。世尊。一切念性自离。一切念性自空。云何菩萨摩诃萨行般若波罗蜜。不离应萨婆若念。是远离空法中无菩萨亦无念。无应萨婆若。佛告须菩提。若菩萨摩诃萨如是知一切法性自离。一切法性自空。非声闻辟支佛作亦非佛作。诸法相常住法相法住法位如实际。是名菩萨行般若波罗蜜不离萨婆若念。何以故。般若波罗蜜性自离性自空不增不减故。须菩提白佛言。世尊。若般若波罗蜜性自离性自空。云何菩萨摩诃萨与般若波罗蜜等。得阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨与般若波罗蜜等不增不减。何以故。如法性实际不增不减故。所以者何。般若波罗蜜非一非异故。若菩萨闻如是般若波罗蜜相。心不惊不没不畏不怖不疑。须菩提。当知是菩萨摩诃萨行般若波罗蜜。当知是菩萨摩诃萨必住阿惟越致地中。须菩提白佛言。世尊。般若波罗蜜空无所有不坚固。是行般若波罗蜜不。不也须菩提。世尊。离空更有法行般若波罗蜜不。不也须菩提。世尊。是般若波罗蜜行般若波罗蜜不。不也须菩提。世尊。离般若波罗蜜行般若波罗蜜不。不也须菩提。世尊。色是行般若波罗蜜不。不也须菩提。世尊。受想行识是行般若波罗蜜不。不也须菩提。世尊。六波罗蜜是行般若波罗蜜不。不也须菩提。世尊。四念处乃至十八不共法是行般若波罗蜜不。不也须菩提。世尊。色空相虚诳不实无所有不坚固相。色如相法相法住法位实际。是行般若波罗蜜不。不也须菩提。世尊。受想行识乃至十八不共法。空相虚诳不实无所有不坚固相。如相法相法住法位实际。是行般若波罗蜜不。不也须菩提。世尊。若是诸法皆不行般若波罗蜜。云何行名菩萨摩诃萨行般若波罗蜜。佛告须菩提。于汝意云何。汝见有法行般若波罗蜜者不。不也世尊。须菩提。汝见般若波罗蜜菩萨摩诃萨可行处不。不也世尊。须菩提。汝所不见法。是法可得不。不也世尊。须菩提。若法不可得是法当生不。不也世尊。须菩提。是名菩萨摩诃萨无生法忍。菩萨摩诃萨成就是忍。得受阿耨多罗三藐三菩提记。须菩提。是名诸佛无所畏无碍智。菩萨摩诃萨行是法勤精进。若不得大智一切种智。所谓阿耨多罗三藐三菩提智。若不得者无有是处。何以故。是菩萨摩诃萨得无生法忍故。乃至阿耨多罗三藐三菩提不减不退。须菩提白佛言。世尊。诸法无生相。此中得阿耨多罗三藐三菩提记不。不也须菩提。世尊。诸法生相此中得阿耨多罗三藐三菩提记不。不也须菩提。世尊。诸法非生非不生相。得阿耨多罗三藐三菩提记不。不也须菩提。世尊。诸菩萨摩诃萨云何知诸法。得阿耨多罗三藐三菩提记。佛告须菩提。汝见有法得阿耨多罗三藐三菩提记不。不也世尊。我不见有法得阿耨多罗三藐三菩提记。我亦不见法有得者得处。佛言。如是如是。须菩提若菩萨摩诃萨于一切法无所得时。不作是念。我当得阿耨多罗三藐三菩提。用是事得阿耨多罗三藐三菩提。是名阿耨多罗三藐三菩提处。何以故。诸菩萨摩诃萨行般若波罗蜜。无诸忆想分别。所以者何。般若波罗蜜中无诸分别忆想故

摩诃般若波罗蜜经卷第十八摩诃般若波罗蜜经卷第十九

        后秦龟兹国三藏鸠摩罗什译

    魔愁品第六十二(丹云同学品)

尔时释提桓因白佛言。世尊。是般若波罗蜜甚深难见。无诸忆想分别毕竟离故。世尊。是众生闻是般若波罗蜜。能持读诵说正忆念。亲近如说行。乃至阿耨多罗三藐三菩提。不杂余心心数法者。不从小功德来。佛言。如是如是。闻是深般若波罗蜜。乃至不杂余心心数法者。不从小功德来。憍尸迦。于汝意云何。若阎浮提众生。成就十善道四禅四无量心四无色定。复有善男子善女人受持深般若波罗蜜。读诵亲近正忆念如说行。胜于阎浮提众生成就十善道乃至四无色定。百倍千倍千万亿倍。乃至算数譬喻所不能及。尔时有一比丘语释提桓因。憍尸迦。是善男子善女人行般若波罗蜜功德胜于仁者。释提桓因言。是善男子善女人一发心胜于我。何况闻是般若波罗蜜。书持读诵正忆念如说行。是善男子善女人行般若波罗蜜非但胜我。亦胜一切世间天及人阿修罗。非但胜一切世间天及人阿修罗。亦胜诸须陀洹斯陀含阿那含阿罗汉辟支佛。非但胜是须陀洹乃至辟支佛。亦胜菩萨行五波罗蜜远离般若波罗蜜者。非但胜菩萨行五波罗蜜远离般若波罗蜜者。亦胜菩萨行般若波罗蜜无方便力者。是菩萨摩诃萨如说行般若波罗蜜。不断佛种常见诸佛。疾近道场菩萨如是行。为欲拔出众生沉没长流者。是菩萨如是学。为不学声闻辟支佛学。菩萨如是学。四天王天来至菩萨所如是言。善男子。当勤疾学坐道场成阿耨多罗三藐三菩提时。如过去诸佛所受四钵亦当应受。我当持来奉上菩萨。及诸余天四天王天三十三天。夜摩天兜率陀天化乐天他化自在天。梵天乃至首陀会天。亦当供养十方诸佛亦常念是菩萨摩诃萨如说行是深般若波罗蜜者。是菩萨诸所有世间危难勤苦之事永无复有。一切世间有四百四病。是菩萨身中无是诸病。以行深般若波罗蜜故得是现世功德。尔时阿难作是念。释提桓因自以力说耶。以佛神力说乎。释提桓因知阿难意所念。语阿难言。我之所说皆佛威神。佛告阿难。如是如是如释提桓因所说皆佛威神。阿难。是菩萨摩诃萨习学是深般若波罗蜜时。三千大千世界中诸恶魔皆生狐疑。今是菩萨为当得阿耨多罗三藐三菩提。当中道于实际作证。堕声闻辟支佛地。复次阿难。若菩萨摩诃萨不离般若波罗蜜时。魔复大愁毒如箭入心。是时魔复放大火风四方俱起。欲令菩萨心没恐怖懈怠。于萨婆若中乃至起一乱念。阿难白佛言。世尊。魔为都娆乱诸菩萨。有不娆乱者。佛告阿难。有娆者有不娆者。阿难白佛言。世尊。何等菩萨为恶魔所娆。佛言。有菩萨摩诃萨。先世闻是深般若波罗蜜心不信解。如是菩萨魔得其便。复次阿难。菩萨闻说是深般若波罗蜜时意疑是般若波罗蜜为实有为实无。如是菩萨魔得其便。复次阿难。有菩萨远离善知识。为恶知识所摄故。不闻深般若波罗蜜。不闻故不知不见不问。云何应行般若波罗蜜。云何应修般若波罗蜜。是菩萨恶魔得其便。复次阿难。若菩萨远离般若波罗蜜受恶法。是菩萨为恶魔得便。魔作是念。是辈当有伴党当满我愿。是菩萨自堕二地。亦使他人堕于二地。复次阿难。若菩萨闻说深般若波罗蜜时。语他人言。是般若波罗蜜甚深我尚不能得底。汝复用闻用学是般若波罗蜜为。如是菩萨魔得其便。复次阿难。若菩萨轻余菩萨言。我行般若波罗蜜行远离空。汝无是功德。是时恶魔大欢喜踊跃。若有菩萨自恃名姓多人知识故轻余行善菩萨。是人无实阿惟越致行类相貌功德。无是功德故生诸烦恼。但着虚名故轻贱余人言。汝不在如我所得法中。尔时恶魔作是念。今我境界宫殿不空增益三恶道。恶魔助其威力令余人信受其语。信受其语故受行其经。如说修学。如说修学时。增益诸结使。是诸人心颠倒故身口意业所作皆受恶报。以是因缘增益三恶道。魔之眷属宫殿益多。阿难。魔见是利故大欢喜踊跃。阿难。若行菩萨道者。与求声闻道家共诤斗。魔作是念。是远离萨婆若。阿难。若菩萨菩萨共诤斗嗔恚骂詈。是时恶魔便大欢喜踊跃言。两离萨婆若远。复次阿难。若未受记菩萨向得记菩萨。生恶心诤斗骂詈。随起念多少劫若干劫数。若不舍一切种智。然后乃补尔所劫大庄严。阿难白佛言。世尊。是恶心乃经尔所劫数。于其中间宁得出除不。佛言阿难。我虽说求菩萨道及声闻人得出罪。阿难。若求菩萨道人。共诤斗嗔恚骂詈怀恨。不悔不舍者我不说有出。必当更尔所劫数。若不舍一切种智然后乃大庄严。阿难。若是菩萨斗诤嗔恚骂詈。便自改悔作是念我为大失。我当为一切众生下屈。今世后世皆使和解我当忍受一切众生履践。如桥梁如聋如哑。云何以恶语报人。我不应坏是甚深阿耨多罗三藐三菩提心。我得阿耨多罗三藐三菩提时。应当度是一切苦恼众生。云何当起嗔恚。阿难白佛言。世尊。菩萨菩萨共住云何。佛告阿难。菩萨菩萨共住。相视当如世尊。何以故。是菩萨摩诃萨应作是念。是我真伴共乘一舡。彼学我学所谓檀那波罗蜜乃至一切种智。若是菩萨杂行离萨婆若心。我不应如是学。若是菩萨不杂行不离萨婆若心。我亦应如是学。菩萨摩诃萨如是学者是为同学

    摩诃般若波罗蜜经等学品第六十三

须菩提白佛言。世尊。何等是菩萨摩诃萨等法。菩萨所应学。须菩提。内空是菩萨等法。外空乃至无法有法空。是菩萨等法。须菩提。色色相空。受想行识识相空。乃至阿耨多罗三藐三菩提阿耨多罗三藐三菩提相空。须菩提。是名菩萨摩诃萨等法。住是等法得阿耨多罗三藐三菩提。须菩提白佛言。世尊。若菩萨摩诃萨为色尽故学。为学萨婆若。为色离故学为色灭故学。为学萨婆若。为色不生故学为学萨婆若。受想行识亦如是。修行四念处乃至十八不共法。尽离灭不生故学为学萨婆若。佛告须菩提。如须菩提所说。为色尽离灭不生故学为学萨婆若。受想行识乃至十八不共法尽离灭不生故学为学萨婆若。佛告须菩提。于汝意云何。色如受想行识如。乃至阿耨多罗三藐三菩提如佛如。是诸如尽灭断不。须菩提言。不也世尊。佛告须菩提。菩萨摩诃萨如是学如为学萨婆若。是如不作证不灭不断。须菩提。菩萨摩诃萨如是学如为学萨婆若。须菩提。菩萨摩诃萨如是学为学六波罗蜜。为学四念处乃至十八不共法。若学六波罗蜜乃至十八不共法为学萨婆若。须菩提。如是学为尽诸学边。如是学魔若魔天所不能坏。如是学直到阿惟越致地。如是学为学佛所行道。如是学为得拥护法。为学大慈大悲。为学净佛国土成就众生。须菩提。如是学为学三转十二行法轮故。如是学为学度众生。如是学为学不断佛种。如是学为学开甘露门。如是学为学欲示无为性。须菩提。下劣之人不能作是学。如是学者。为欲拔沉没生死众生。菩萨摩诃萨如是学。终不堕地狱饿鬼畜生中。终不生边地。终不生旃陀罗家。终不聋盲喑哑拘癖诸根不缺眷属成就终不孤穷。菩萨如是学。终不杀生乃至终不邪见。如是学不作邪命活。不摄恶人及破戒者。如是学以方便力故不生长寿天。何等是方便力。如般若波罗蜜品中所说。菩萨摩诃萨以方便力故。入四禅四无量心四无色定。不随禅无量无色定生。须菩提。菩萨如是学一切法。中得清净。所谓净声闻辟支佛心。须菩提白佛言。世尊。一切法本性清净。云何言菩萨一切法中得清净。佛告须菩提。如是如是。一切诸法本性清净。若菩萨摩诃萨于是法中。心通达不没即是般若波罗蜜。如是诸法一切凡夫人不知不见。菩萨摩诃萨为是众生故。行檀那波罗蜜乃至般若波罗蜜。行四念处乃至一切种智。须菩提。菩萨如是学。于一切法中得智力无所畏。如是学为了知一切众生心所趣向。譬如大地少所处出金银珍宝。须菩提。众生亦如是。少所人能学般若波罗蜜。多堕声闻辟支佛地。须菩提。譬如少所人受行转轮圣王业。多受行小王业。如是须菩提。少所众生行般若波罗蜜求一切智。多行声闻辟支佛道。须菩提。诸菩萨摩诃萨发心求阿耨多罗三藐三菩提中少有如说行。多住声闻辟支佛地。多有菩萨摩诃萨行般若波罗蜜。无方便力故少所人住阿惟越致地。须菩提。以是故菩萨摩诃萨欲在阿惟越致地。欲在阿惟越致数中。应当学是深般若波罗蜜。复次须菩提。菩萨摩诃萨学是般若波罗蜜时。不生悭贪心。不生破戒嗔恚懈怠散乱愚痴心。不生诸余过失心。不生取色相心取受想行识相心。不生取四念处相心。乃至不生取阿耨多罗三藐三菩提相心。何以故。是菩萨摩诃萨行是深般若波罗蜜无有法可得。以不可得故于诸法不生心取相。须菩提。菩萨摩诃萨如是学深般若波罗蜜总摄诸波罗蜜。令诸波罗蜜增长。诸波罗蜜悉随从。何以故。须菩提。是深般若波罗蜜诸波罗蜜悉入中。须菩提。譬如我见中悉摄六十二见。如是须菩提。是深般若波罗蜜悉摄诸波罗蜜。须菩提。譬如人死命根灭故余根悉随灭。如是须菩提。菩萨摩诃萨行深般若波罗蜜时。诸波罗蜜悉随从。须菩提。菩萨摩诃萨欲令诸波罗蜜度彼岸。应学深般若波罗蜜。须菩提。菩萨摩诃萨学是深般若波罗蜜者。出一切众生之上。须菩提。于汝意云何。三千大千世界中众生多不。须菩提言。一阎浮提中众生尚多。何况三千大千世界。佛告须菩提。若三千大千世界中众生一时皆得人身。悉得阿耨多罗三藐三菩提。若有菩萨尽形寿。供养尔所佛衣服饮食卧具汤药资生所须须菩提。于汝意云何。是人以是因缘故得福德多不。须菩提言。甚多甚多。佛言。不如是善男子善女人学般若波罗蜜如说行正忆念得福多。何以故。般若波罗蜜有势力。能令菩萨摩诃萨得阿耨多罗三藐三菩提。须菩提。以是故菩萨摩诃萨欲出一切众生之上当学般若波罗蜜。欲为无救护众生作救护。欲与无归依众生作归依。欲与无究竟道众生作究竟道。欲与盲者作目。欲得佛功德。欲作诸佛自在游戏。欲作诸佛师子吼。欲撞击佛钟鼓。欲吹佛贝。欲升佛高座说法。欲断一切众生疑。当学深般若波罗蜜。须菩提。菩萨摩诃萨若学深般若波罗蜜。诸善功德无事不得。须菩提白佛言。世尊。宁复得声闻辟支佛功德不。佛言。声闻辟支佛功德皆能得。但不于中住以智观已。直过入菩萨位中。须菩提。菩萨摩诃萨如是学近萨婆若。疾得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨如是学。为一切世间天及人阿修罗作福田。须菩提。菩萨摩诃萨如是学。过诸声闻辟支佛福田之上。疾近萨婆若。须菩提。菩萨摩诃萨如是学。是名不舍不离般若波罗蜜常行般若波罗蜜。须菩提。菩萨摩诃萨如是学深般若波罗蜜。当知是不退转菩萨疾近萨婆若。远离声闻辟支佛。近阿耨多罗三藐三菩提。须菩提。是菩萨摩诃萨行般若波罗蜜时。若作是念是般若波罗蜜。我以是般若波罗蜜得一切种智。若如是念不名行般若波罗蜜。须菩提。若不作是念。是般若波罗蜜。是人般若波罗蜜。是般若波罗蜜法。是人行是般若波罗蜜得阿耨多罗三藐三菩提。是名行般若波罗蜜。须菩提。若菩萨作是念。无是般若波罗蜜。无人有是般若波罗蜜。无有行是般若波罗蜜得阿耨多罗三藐三菩提。何以故。一切法如法性实际常住故。如是行。是为菩萨摩诃萨行般若波罗蜜

    摩诃般若波罗蜜经净愿品第六十四(丹随喜品)

尔时释提桓因作是念。萨萨摩诃萨行般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜乃至十八不共法时出一切众生之上。何况得阿耨多罗三藐三菩提时。是诸众生闻是萨婆若信解者。得人中之善利寿命中最。何况发阿耨多罗三藐三菩提意。是众生能发阿耨多罗三藐三菩提意者。其余众生应当愿乐。尔时释提桓因以天文陀罗华而散佛上。发是言以是福德。若有求阿耨多罗三藐三菩提者。令此人具足佛法。具足一切智。具足自然法。若求声闻者令具足声闻法。世尊。若有菩萨发阿耨多罗三藐三菩提意者。我终不生一念令其转还。我亦不生一念令其转还堕声闻辟支佛地。世尊。我愿诸菩萨倍复精进于阿耨多罗三藐三菩提。见众生生死中种种苦恼。欲利益安乐一切世间天及人阿修罗。以是心作是愿。我既自度亦当度未度者。我既自脱当脱未脱者。我既安隐当安未安者。我既灭度当使未入灭度者得灭度。世尊。善男子善女人于初发意菩萨功德。随喜心得几许福德。于久发意菩萨功德。随喜心得几许福德。于阿惟越致菩萨功德。随喜心得几许福德。于一生补处菩萨功德。随喜心得几许福德。佛告释提桓因言。憍尸迦。四天下国土可称知斤两。是随喜福德不可称量。复次憍尸迦。是三千大千世界皆可称知斤两。是随喜心福德不可称量。复次憍尸迦。三千大千世界满中海水。取一发破为百分。以一分发渧取海水可知渧数。是随喜心福德不可数知。释提桓因白佛言。世尊。若众生心不随喜阿耨多罗三藐三菩提者。皆是魔眷属。诸心不随喜者从魔中来生。何以故。世尊。是诸发随喜心菩萨。为破魔境界故生。是故欲爱敬三尊者应生随喜心。随喜已应回向阿耨多罗三藐三菩提。以不一不二相故。佛言。如是如是。憍尸迦。若有人于菩萨心能如是随喜回向者。常值诸佛终不见恶色。终不闻恶声。终大嗅恶香。终不食恶味。终不触恶触。终无不随念。终不远离诸佛。从一佛土至一佛土亲近诸佛种善根。何以故。善男子善女人为无量阿僧祇初发意菩萨。诸善根随喜回向。为无量阿僧祇第二地第三地乃至第十地一生补处诸菩萨摩诃萨善根。随喜回向阿耨多罗三藐三菩提。以是善根因缘故疾近阿耨多罗三藐三菩提。是诸菩萨得阿耨多罗三藐三菩提已。度无量无边阿僧祇众生。憍尸迦。以是因缘故善男子善女人于初发意菩萨善根。应随喜回向阿耨多罗三藐三菩提。非心非离心。于久发意阿惟越致一生补处善根。随喜回向阿耨多罗三藐三菩提。非心非离心。须菩提白佛言。世尊。是心如幻。云何能得阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。汝见是心如幻不。不也世尊。我不见幻亦不见心如幻。须菩提。于汝意云何。若无幻亦无心如幻。汝见是心不。不也世尊。须菩提。于汝意云何。离幻离心如幻。汝见更有法得阿耨多罗三藐三菩提不。不也世尊。我不见离幻离心如幻更有法得阿耨多罗三藐三菩提。世尊。我不见更有法何等法可说若有若无。是法相毕竟离故不随有不堕无。若法毕竟离者。不能得阿耨多罗三藐三菩提。无所有法。亦不应得阿耨多罗三藐三菩提。何以故。世尊。一切法无所有是中无垢者无净者。世尊。以是故。般若波罗蜜毕竟离。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜毕竟离。乃至阿耨多罗三藐三菩提亦毕竟离。若法毕竟离则不应修不应坏。行般若波罗蜜亦无有法可得毕竟离故。世尊。若般若波罗蜜毕竟离者。云何因般若波罗蜜得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提亦毕竟离。二离中云何能有所得。佛告须菩提。善哉善哉。是般若波罗蜜毕竟离。禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜毕竟离。乃至一切种智毕竟离。须菩提。若般若波罗蜜毕竟离。乃至一切种智毕竟离。以是故能得阿耨多罗三藐三菩提。须菩提。若般若波罗蜜非毕竟离。乃至一切种智非毕竟离。是不名般若波罗蜜。不名禅波罗蜜乃至一切种智。须菩提。若般若波罗蜜毕竟离。乃至一切种智毕竟离。以是故。须菩提。非不因般若波罗蜜得阿耨多罗三藐三菩提。亦不以离得离。而得阿耨多罗三藐三菩提。非不因般若波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨所行义甚深。佛言。如是须菩提。菩萨摩诃萨所行义甚深。须菩提。诸菩萨摩诃萨能为难事。所谓行是深义。而不证声闻辟支佛地。须菩提白佛言。世尊。如我从佛闻义。菩萨摩诃萨所行不为难。何以故。是菩萨摩诃萨不得是义可作证。亦不得般若波罗蜜作证。亦无作证者。世尊。若一切法不可得。何等是义可作证。何等是般若波罗蜜作证。何等是作证者。作证已得阿耨多罗三藐三菩提。世尊。是名菩萨摩诃萨无所得行菩萨行。是于一切法皆得明了。世尊。若菩萨摩诃萨闻是法心不惊不没不怖不畏。是名为行般若波罗蜜。是菩萨摩诃萨行般若波罗蜜时。不见我行般若波罗蜜。亦不见是般若波罗蜜。亦不见我当得阿耨多罗三藐三菩提。何以故。菩萨摩诃萨行般若波罗蜜时。不作是念声闻辟支佛地去我远。萨婆若去我近。世尊。譬如虚空不作是念。有法去我远去我近。何以故。世尊。虚空无分别故。世尊。行般若波罗蜜菩萨亦不作是念。声闻辟支佛地去我远。萨婆若去我近。何以故。般若波罗蜜中无分别故。世尊。譬如幻人不作是念。幻师去我近观人去我远。何以故。幻人无分别故。行般若波罗蜜菩萨不作是念。声闻辟支佛地去我远。萨婆若去我近。世尊。譬如镜中像不作是念。所因者去我近。余者去我远。何以故。像无分别故。行般若波罗蜜菩萨亦不作是念。声闻辟支佛地去我远。萨婆若去我近。何以故。般若波罗蜜中无分别故。世尊。行般若波罗蜜菩萨无爱无憎。何以故。般若波罗蜜自性不可得故。世尊。譬如佛无爱无憎。行般若波罗蜜菩萨无爱无憎亦如是。何以故般若波罗蜜中无憎无爱故。世尊。譬如佛一切分别想断。行般若波罗蜜菩萨亦如是。一切分别想断毕竟空故。世尊。譬如佛所化人不作是念。声闻辟支佛去我远。阿耨多罗三藐三菩提去我近。何以故。佛所化人无分别故。行般若波罗蜜菩萨亦如是。不作是念声闻辟支佛去我远。阿耨多罗三藐三菩提去我近。世尊。譬如有所为故作化所化事无分别。世尊。般若波罗蜜亦如是。有所为事而修是事成就。而般若波罗蜜亦无分别。世尊。譬如工匠若工匠弟子有所为故。作木人若男若女象马牛羊。是所作亦能有所作。是牛马无分别。世尊。般若波罗蜜亦如是。有所为故说是事成就。而般若波罗蜜亦无分别。舍利弗问须菩提。但般若波罗蜜无分别。禅那波罗蜜乃至檀那波罗蜜亦无分别。须菩提语舍利弗。禅那波罗蜜无分别。乃至檀那波罗蜜亦无分别。舍利弗问须菩提。色无分别乃至识亦无分别。眼乃至意无分别。色乃至法无分别。眼识触乃至意识触无分别。眼触因缘生受乃至意触因缘生受。四禅四无量心四无色定四念处。乃至八圣道分空无相无作。佛十力四无所畏四无碍智。大慈大悲十八不共法。阿耨多罗三藐三菩提无为性亦无分别。须菩提。若色无分别。乃至无为性无分别。若一切法无分别。云何分别有六道生死。是地狱是饿鬼是畜生是天是人是阿修罗。云何分别是须陀洹斯陀含阿那含阿罗汉辟支佛诸佛。须菩提报舍利弗。众生颠倒因缘故。造作身口意业。随欲本业报受六道身。地狱饿鬼畜生人天阿修罗身。如汝言。云何分别有须陀洹乃至佛道。舍利弗。须陀洹即是无分别故有。须陀洹果亦是无分别故有。乃至阿罗汉阿罗汉果。辟支佛辟支佛道佛佛道。亦是无分别故有。舍利弗。过去诸佛亦是无分别断分别故有。以是故。舍利弗。当知一切法无有分别。不坏相诸法如法性实际故。舍利弗。如是菩萨摩诃萨应行无分别般若波罗蜜。行无分别般若波罗蜜已。便得无分别阿耨多罗三藐三菩提

    摩诃般若波罗蜜经度空品第六十五(丹称扬品)

舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜。为行真实法。为行无真实法。须菩提报舍利弗。菩萨摩诃萨行般若波罗蜜。为行无真实法。何以故。是般若波罗蜜无真实。乃至一切种智无真实故。菩萨摩诃萨行般若波罗蜜。无真实不可得何况真实。乃至行一切种智。无真实法不可得何况真实法。尔时欲色界诸天子作是念。诸有善男子善女人发阿耨多罗三藐三菩提意。如深般若波罗蜜所说义。行于等法不作实际证。不堕声闻辟支佛地。应当为作礼。须菩提语诸天子。诸菩萨摩诃萨于等法不证声闻辟支佛地不为难。诸菩萨摩诃萨大庄严。我当度无量无边阿僧祇众生。知众生毕竟不可得而度众生。是乃为难。诸天子。诸菩萨摩诃萨发阿耨多罗三藐三菩提心。作是愿我当度一切众生。众生实不可得。是人欲度众生如欲度虚空。何以故。虚空离故当知众生亦离。虚空空故当知众生亦空。虚空无坚固当知众生亦无坚固。虚空虚诳当知众生亦虚诳。诸天子。以是因缘故当知菩萨所作为难。为利益无所有众生故而大庄严。是人为众生结誓。为欲与虚空共斗。是菩萨结誓已。亦不得众生而为众生结誓。何以故。众生离故当知大誓亦离。众生虚诳故当知大誓亦虚诳。若菩萨摩诃萨闻是深法心不惊不没。当知是菩萨摩诃萨行般若波罗蜜。何以故。色离即是众生离。受想行识离即是众生离。色离即是六波罗蜜离。受想行识离即是六波罗蜜离。乃至一切种智离即是六波罗蜜离。若菩萨摩诃萨闻是一切诸法离相。心不惊不没不怖不畏。当知是菩萨摩诃萨行般若波罗蜜。佛告须菩提。何因缘故。菩萨摩诃萨于深般若波罗蜜中心不没。须菩提白佛言。世尊。般若波罗蜜无所有故不没。般若波罗蜜离故不没。般若波罗蜜寂灭故不没。世尊。以是因缘故。菩萨于深般若波罗蜜中心不没。何以故。是菩萨不得没者。不得没事不得没处。是一切法皆不可得故。世尊。若菩萨摩诃萨闻是法。心不惊不没不怖不畏。当知是菩萨为行般若波罗蜜。何以故。没者没事没处。是法皆不可得故。菩萨摩诃萨如是行般若波罗蜜。诸天及释提桓因天。梵天王天及世界主天皆为作礼。佛告须菩提。不但释提桓因诸天梵王。及诸天世界主及诸天。礼是菩萨摩诃萨行般若波罗蜜者。过是上光音天遍净天广果天净居天。皆为是菩萨摩诃萨作礼。须菩提。今现在十方无量诸佛。亦念是行般若波罗蜜菩萨摩诃萨。当知是菩萨为如佛。须菩提。若如恒河沙等国土中众生悉使为魔。是一一魔复化作魔。如恒河沙等魔。是一切魔不能留难。菩萨行般若波罗蜜。须菩提。菩萨摩诃萨成就二法魔不能坏。何等二。观一切法空。不舍一切众生。须菩提。菩萨成就此二法魔不能坏。复次须菩提。菩萨摩诃萨复有二法成就魔不能坏。何等二。所作如所言。亦为诸佛所念。菩萨成就此二法魔不能坏。须菩提。菩萨如是行。是诸天皆来倒菩萨所亲近咨问劝喻安慰作是言。善男子。汝疾得阿耨多罗三藐三菩提不久。善男子。汝常当行是空无相无作行。何以故。善男子。汝行是行。无护众生汝为作护。无依众生为作依。无救众生为作救无究竟道众生为作究竟道。无归众生为作归。无洲众生为作洲。冥者为作明。盲者为作眼。何以故。是菩萨摩诃萨行般若波罗蜜。十方现在无量阿僧祇诸佛。在大众中说法时。自赞叹称扬是菩萨摩诃萨名姓。言某甲菩萨成就般若波罗蜜功德。须菩提。如我今说法时。自称扬宝相菩萨尸弃菩萨。复有诸菩萨摩诃萨在阿閦佛国中。行般若波罗蜜净修梵行。我亦称扬是菩萨名姓。须菩提。亦如东方现在诸佛说法时。是中有菩萨摩诃萨净修梵行。佛亦欢喜自称扬赞叹是菩萨。南西北方四维上下亦如是。复有菩萨从初发意。欲具足佛道乃至得一切种智。诸佛说法时亦欢喜。自称扬赞叹是菩萨。何以故。是诸菩萨摩诃萨所行甚难不断佛种行。须菩提白佛言。世尊。何等菩萨摩诃萨诸佛说法时自赞叹称扬。佛告须菩提。阿惟越致菩萨。诸佛说法时自赞叹称扬。须菩提言何等阿惟越致菩萨为佛所赞。佛言。如阿閦佛为菩萨时所行所学诸菩萨亦如是学。是诸阿惟越致菩萨诸佛说法时欢喜赞叹。复次须菩提。有菩萨行般若波罗蜜。信解一切法无生未得无生忍法。信解一切法空未得无生忍法。信解一切法虚诳不实无所有不坚固。未得无生忍法。须菩提。如是等诸菩萨摩诃萨诸佛说法时欢喜自赞叹称扬名字。须菩提。若诸菩萨摩诃萨诸佛说法时欢喜自赞叹者。是菩萨灭声闻辟支佛地。当得阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨诸佛说法时欢喜自赞叹者。是菩萨当住阿惟越致地。住是地已当得萨婆若。复次须菩提。菩萨摩诃萨闻是深般若波罗蜜。其心明利不疑不悔。作是念是事如佛所说。是菩萨亦当于阿閦佛及诸菩萨所。广闻是深般若波罗蜜亦信解。信解已如佛所说。当住阿惟越致地如是须菩提。但闻般若波罗蜜得大利益何况信解。信解已如说住如说行如说住。如说行已住一切种智中。须菩提白佛言。世尊。若佛说菩萨摩诃萨如所说住。如所说行住萨婆若若。菩萨摩诃萨无所得法。云何住萨婆若。佛告须菩提。菩萨摩诃萨住诸法如中。住萨婆若。须菩提言。世尊。除如更无法可得谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法。如尚不可得。何况住如得阿耨多罗三藐三菩提。谁住如中而说法无有是处。佛告须菩提。如汝所言。除如更无法谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法如尚不可得。何况住如得阿耨多罗三藐三菩提。谁住如中而说法无有是处。佛言。如是如是。须菩提。除如更无有法可得谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法。如尚不可得。何况住如得阿耨多罗三藐三菩提。谁住如中而说法。何以故。是如生不可得灭不可得。住异不可得。若法生灭住异不可得是中谁当住如。谁当住如已得阿耨多罗三藐三菩提。谁当住如而说法无有是处。释提桓因白佛言。世尊。诸菩萨摩诃萨所为甚难。深般若波罗蜜中欲得阿耨多罗三藐三菩提。何以故。世尊。无有如中住者。亦无当得阿耨多罗三藐三菩提者亦无说法者。菩萨摩诃萨于是处。心不惊不没不怖不畏不疑不悔。尔时须菩提语释提桓因。汝憍尸迦。说菩萨摩诃萨所为甚难。是甚深法中。心不惊不没不怖不畏不疑不悔。憍尸迦。诸法空中谁惊谁没谁怖谁畏谁疑谁悔。是时释提桓因语须菩提。须菩提所说。但为空事无挂碍。譬如仰射空中箭去无碍。须菩提。说法无碍亦如是

摩诃般若波罗蜜经卷第十九摩诃般若波罗蜜经卷第二十

        后秦龟兹国三藏鸠摩罗什译

    累教品第六十六(丹嘱累品)

尔时释提桓因白佛言。世尊。我如是说如是答。为随顺法不为正答不。佛告释提桓因言。憍尸迦。汝所说所答实皆随顺。释提桓因言希有世尊。须菩提所乐说。皆是为空为无相为无作。为四念处乃至为阿耨多罗三藐三菩提。佛告释提桓因。须菩提比丘行空时檀那波罗蜜不可得。何况行檀那波罗蜜者。乃至般若波罗蜜不可得何况行般若波罗蜜者。四念处不可得何况修四念处者。乃至八圣道分不可得何况修八圣道分者。禅解脱三昧定不可得何况修禅解脱三昧定者。佛十力不可得何况修佛十力者四无所畏。不可得何况能生四无所畏者。四无碍智不可得何况生四无碍智者。大慈大悲不可得何况行大慈大悲者。十八不共法不可得何况生十八不共法者。阿耨多罗三藐三菩提不可得何况得阿耨多罗三藐三菩提者。一切智不可得何况得一切智者。如来不可得何况当作如来者。无生法不可得何况得无生法作证者。三十二相不可得何况得三十二相者。八十随形好不可得何况得八十随形好者。何以故。憍尸迦。须菩提比丘一切法离行。一切法无所得行。一切法空行。一切法无相行。一切法无作行。憍尸迦。是为须菩提比丘所行。欲比菩萨摩诃萨般若波罗蜜行者。百分不及一。千分千万亿分乃至算数譬喻所不能及。何以故。除佛行。是菩萨摩诃萨行般若波罗蜜。于声闻辟支佛诸行中最尊最妙最上。以是故。菩萨摩诃萨欲得于一切众生中最上。当行是般若波罗蜜行。何以故。憍尸迦。诸菩萨摩诃萨行般若波罗蜜时。过声闻辟支佛地入菩萨位。能具足佛法得一切种智。断一切烦恼习作佛。是时会中诸三十三天。以天曼陀罗华散佛及僧。是时八百比丘从座起以华散佛。偏袒右肩合掌右膝着地白佛言。世尊。我等当行是无上行声闻辟支佛所不能行。尔时佛知诸比丘心行。便微笑如诸佛法。种种色光青黄赤白红缥从口中出。遍照三千大千世界。绕佛三匝还从顶入。尔时阿难偏袒右肩右膝着地白佛言。世尊。何因缘微笑。诸佛不以无因缘而笑。佛告阿难。是八百比丘于星宿劫中。当得阿耨多罗三藐三菩提。佛名散华皆同一字。比丘僧国土寿命皆等。各各过十万岁出家作佛是时诸国土常雨五色天华。以是故。阿难。菩萨摩诃萨欲行最上行。应当行般若波罗蜜。佛告阿难。若有善男子善女人能行是深般若波罗蜜。当知是菩萨人中死此间生。若兜率天上死来生此间。若人中若兜率天上广闻是深般若波罗蜜。阿难。我见是诸菩萨摩诃萨能行是深般若波罗蜜。阿难。若有善男子善女人。闻是深般若波罗蜜受持读诵亲近正忆念。转复以般若波罗蜜教行菩萨道者。当知是菩萨面从佛闻深般若波罗蜜。乃至亲近亦从诸佛种善根。善男子善女人当作是念。我等非声闻所种善根。亦不从声闻所闻是深般若波罗蜜。阿难。若有善男子善女人受持是深般若波罗蜜。读诵亲近随义随法行。当知是善男子善女人则为面见佛。阿难。若有善男子善女人闻是深般若波罗蜜。信心清净不可沮坏。当知是善男子善女人曾供养佛种善根与善知识相得。阿难于诸佛福田种善根。虽不虚诳。要得声闻辟支佛佛而得解脱。应当深了了行六波罗蜜乃至一切种智。阿难。若菩萨深了了行六波罗蜜乃至一切种智。是人若住声闻辟支佛道。不得阿耨多罗三藐三菩提无有是处。是故阿难。我以般若波罗蜜嘱累汝。阿难。汝若受持一切法。除般若波罗蜜若忘若失其过小小无有大罪。阿难。汝受持深般若波罗蜜若失一句其过甚大。阿难。汝若受持深般若波罗蜜还忘失其罪甚多。以是故。阿难。嘱累汝是深般若波罗蜜。汝当善受持读诵令利。阿难。若有善男子善女人受持般若波罗蜜。则为受持过去未来现在诸佛阿耨多罗三藐三菩提阿难若善男子善女人现在供养我恭敬尊重赞叹。华香璎珞捣香泽香衣服幡盖。应当受持般若波罗蜜读诵说。亲近供养恭敬尊重赞叹华香乃至幡盖。阿难。供养般若波罗蜜。则为供养我。亦供养过去未来现在佛已若有善男子善女人闻说深般若波罗蜜。信心清净恭敬爱乐。则为信心清净恭敬爱乐过去未来现在诸佛已。阿难。汝爱乐佛不舍离。当爱乐般若波罗蜜莫舍离。阿难。深般若波罗蜜乃至一句不应令失。阿难。我说嘱累因缘甚多今但略说。如我为世尊。般若波罗蜜亦是世尊。以是故。阿难。种种因缘嘱累汝般若波罗蜜。阿难。今我于一切世间天人阿修罗中。嘱累汝诸欲不舍佛不舍法不舍僧。不舍过去未来现在诸佛阿耨多罗三藐三菩提者。慎莫舍般若波罗蜜。阿难。是我所教化弟子法。阿难。若善男子善女人受持深般若波罗蜜。读诵说正忆念。复为他人种种广说其义。开示演畅分明令易解。是善男子善女人疾得阿耨多罗三藐三菩提。疾近萨婆若。何以故。般若波罗蜜中生诸佛阿耨多罗三藐三菩提。阿难。过去未来诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜中生。今现在东方南方西方北方四维上下诸佛阿耨多罗三藐三菩提。亦从般若波罗蜜生。以是故。阿难。诸菩萨摩诃萨欲得阿耨多罗三藐三菩提。应当学六波罗蜜。何以故。阿难。六波罗蜜是菩萨摩诃萨母。生诸菩萨故。阿难。若有菩萨摩诃萨学是六波罗蜜。皆得阿耨多罗三藐三菩提。以是故。我以六波罗蜜倍复嘱累汝。阿难。是六波罗蜜是诸佛无尽法藏。阿难。十方诸佛现在说法。皆从六波罗蜜法藏中出。过去诸佛亦从六波罗蜜中。学得阿耨多罗三藐三菩提。未来诸佛亦从六波罗蜜中。学得阿耨多罗三藐三菩提。过去未来现在诸佛弟子。皆从六波罗蜜中学得灭度。已得今得当得灭度。阿难。汝为声闻人说法。令三千大千世界中众生。皆得阿罗汉果证。犹未为我弟子事。汝若以般若波罗蜜相应一句义。教菩萨摩诃萨则为我弟子事。我亦欢喜胜教三千大千世界中众生令得阿罗汉。复次阿难。是三千大千世界中众生。不前不后一时皆得阿罗汉果证。是诸阿罗汉。行布施功德持戒禅定功德。是功德多不。阿难言。甚多世尊。佛言。不如弟子以般若波罗蜜相应法。为菩萨摩诃萨说乃至一日其福甚多。置一日但半日。置半日但一食顷。置一食顷但须臾间说。其福甚多。何以故。菩萨摩诃萨善根胜一切声闻辟支佛故。菩萨摩诃萨自欲得阿耨多罗三藐三菩提。亦示教利喜他人令得阿耨多罗三藐三菩提。阿难。如是菩萨行六波罗蜜。行四念处乃至行一切种智。增益善根若不得阿耨多罗三藐三菩提。无有是处。说是般若波罗蜜品时。佛在四众中天人龙鬼神紧陀罗摩睺罗伽等。于大众前而现神足变化。一切大众皆见阿閦佛。比丘僧围绕说法。大众譬如大海水。皆是阿罗汉漏已尽无复烦恼皆得自在得俱解脱心解脱慧解脱。其心调柔譬如大象。所作已办逮得己利。尽诸有结正智得解脱。一切心心数法中得自在。及诸菩萨摩诃萨无量功德成就。尔时佛摄神足。一切大众不复见阿閦佛声闻人菩萨摩诃萨。及其国土不与眼作对。何以故。佛摄神足故。尔时佛告阿难。如是阿难。一切法不与眼作对。法法不相见。法法不相知。如是阿难。如阿閦佛弟子菩萨国土。不兴眼作对。如是阿难。一切法不与眼作对。法法不相知。法法不相见。何以故。一切法无知无见无作无动。不可捉不可思议。如幻人无受无觉无真实。菩萨摩诃萨如是行。为行般若波罗蜜。亦不着诸法。阿难。菩萨摩诃萨如是学。名为学般若波罗蜜。欲得诸波罗蜜当学般若波罗蜜。何以故。如是学名为第一学最上学微妙学。如是学安乐利益一切世间。无护者为作护。如是学诸佛所学。诸佛住是学中。能以右手举三千大千世界还着本处。是中众生无觉知者。何以故。阿难。诸佛学是般若波罗蜜。过去未来现在法中得无阂智见。阿难。般若波罗蜜。于诸学中最尊第一微妙无上。阿难。有人欲得般若波罗蜜边际。为欲得虚空边际。何以故。阿难。般若波罗蜜无有量。我初不说般若波罗蜜量。名众句众字众是有量。般若波罗蜜无有量。阿难白佛言。世尊。般若波罗蜜。何以故。无有量。佛告阿难。般若波罗蜜无尽故无有量。般若波罗蜜离故无有量阿难。过去诸佛皆学是般若波罗蜜得度是般若波罗蜜故不尽。未来世诸佛亦学是般若波罗蜜得度。是般若波罗蜜故不尽。现在十方诸佛皆学是般若波罗蜜得度。是般若波罗蜜故不尽。已不尽今不尽当不尽。阿难。欲尽般若波罗蜜为欲尽虚空。般若波罗蜜不可尽。已不尽今不尽当不尽。禅那波罗蜜乃至檀那波罗蜜不可尽。已不尽今不尽当不尽。乃至一切种智亦如是。何以故。是一切法皆无生。若法无生云何有尽。尔时佛出覆面舌相。告阿难。从今日于四众中广演开示分别般若波罗蜜。当令分明易解。何以故。是深般若波罗蜜中广说诸法相。是中求声闻辟支佛求佛者皆当于中学。学已各得成就。阿难。是深般若波罗蜜则是一切字门。行是深般若波罗蜜。能入陀罗尼门。学是陀罗尼诸菩萨得一切乐说辩才。阿难。般若波罗蜜是三世诸佛妙法。以是故。阿难。我为汝了了说。若有人受持深般若波罗蜜读诵亲近。是人则能持三世诸佛阿耨多罗三藐三菩提。阿难。我说般若波罗蜜是行者足。汝持是般若波罗蜜得陀罗尼故则能持一切诸法

    摩诃般若波罗蜜经无尽品第六十七

尔时须菩提作是念。是诸佛阿耨多罗三藐三菩提甚深。我当问佛。作是念已。白佛言。世尊。是般若波罗蜜不可尽。佛言。虚空不可尽故。般若波罗蜜不可尽。世尊。云何应生般若波罗蜜。佛言。色不可尽故。般若波罗蜜应生。受想行识不可尽故。般若波罗蜜应生。檀那波罗蜜不可尽故。般若波罗蜜应生。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜不可尽故。般若波罗蜜应生。乃至一切种智不可尽故。般若波罗蜜应生。复次须菩提。痴空不可尽故。菩萨摩诃萨般若波罗蜜应生。行空不可尽故。菩萨般若波罗蜜应生。识空不可尽故。菩萨般若波罗蜜应生。名色空不可尽故。菩萨般若波罗蜜应生。六处空不可尽故。菩萨般若波罗蜜应生。六触空不可尽故。菩萨般若波罗蜜应生。受空不可尽故。菩萨般若波罗蜜应生。爱空不可尽故。菩萨般若波罗蜜应生。取空不可尽故。菩萨般若波罗蜜应生有空不可尽故。菩萨般若波罗蜜应生。生空不可尽故。菩萨般若波罗蜜应生。老死忧悲苦恼空不可尽故。菩萨般若波罗蜜应生。如是须菩提。菩萨摩诃萨般若波罗蜜应生。须菩提。是十二因缘是独菩萨法。能除诸边颠倒。坐道场时应如是观当得一切种智。须菩提。若有菩萨摩诃萨。以虚空不可尽法。行般若波罗蜜观十二因缘。不堕声闻辟支佛地。住阿耨多罗三藐三菩提。须菩提。若求菩萨道而转还者。皆离般若波罗蜜念故。是人不知云何行般若波罗蜜。应以虚空不可尽法观十二因缘。须菩提。若求菩萨道而转还者。皆不得是方便力故。于阿耨多罗三藐三菩提而转还。须菩提。若菩萨摩诃萨。于阿耨多罗三藐三菩提不转还者皆得是方便力故。须菩提。菩萨摩诃萨应以虚空不可尽法观般若波罗蜜。应以虚空不可尽法生般若波罗蜜。如是须菩提。菩萨摩诃萨观十二因缘时。不见法无因缘生。不见法常不灭。不见法有我人寿者命者众生乃至知者见者。不见法无常。不见法苦。不见法无我。不见法寂灭非寂灭。如是须菩提。菩萨摩诃萨行般若波罗蜜。应如是观十二因缘。须菩提。若菩萨摩诃萨能如是行般若波罗蜜。是时不见色若常若无常若苦若乐。若我若无我若寂灭若非寂灭。受想行识亦如是。须菩提。菩萨摩诃萨是时亦不见般若波罗蜜。亦不见以是法见般若波罗蜜。禅那波罗蜜。乃至阿耨多罗三藐三菩提。亦不见阿耨多罗三藐三菩提。亦不见以是法见阿耨多罗三藐三菩提。如是须菩提。一切法不可得故。是为应般若波罗蜜行。若菩萨行无所得般若波罗蜜时。恶魔愁毒如箭入心。譬如人新丧父母。如是须菩提。恶魔见菩萨行无所得般若波罗蜜时。便大愁毒如箭入心

须菩提白佛言。世尊。但一魔愁毒。三千大千世界中魔亦复愁毒。佛告须菩提。三千大千世界中诸恶魔。皆愁毒如箭入心。各于其坐不能自安。须菩提。菩萨摩诃萨能如是行般若波罗蜜。是时一切世间天及人阿修罗。不能得其便令其忧恼。须菩提。以是故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。当行是般若波罗蜜。菩萨摩诃萨行般若波罗蜜时。具足修檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时具足诸波罗蜜

须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜时。云何具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜

佛告须菩提。菩萨摩诃萨所有布施。皆回向萨婆若。如是须菩提。菩萨摩诃萨行般若波罗蜜时。具足檀那波罗蜜。须菩提。菩萨摩诃萨所有持戒。皆回向萨婆若。是为具足尸罗波罗蜜。菩萨摩诃萨所有忍辱。皆回向萨婆若。是为具足羼提波罗蜜。菩萨摩诃萨所有精进。皆回向萨婆若。是为具足毗梨耶波罗蜜。菩萨摩诃萨所有禅定。皆回向萨婆若。是为具足禅那波罗蜜。菩萨摩诃萨所有智慧。皆回向萨婆若。是为具足般若波罗蜜。如是须菩提。菩萨摩诃萨行般若波罗蜜具足六波罗蜜

    摩诃般若波罗蜜经摄五品第六十八(丹本六度相摄品)

须菩提白佛言。世尊。云何菩萨摩诃萨住檀那波罗蜜。取尸罗波罗蜜。佛告须菩提。菩萨摩诃萨布施时。持是布施回向萨婆若。于众生中住慈身口意业。是为菩萨住檀那波罗蜜取尸罗波罗蜜。世尊。云何菩萨住檀那波罗蜜取羼提波罗蜜。佛告须菩提。菩萨布施时。受者嗔恚骂辱恶言加之。是时菩萨忍辱不生嗔恚心。是为菩萨住檀那波罗蜜取羼提波罗蜜。世尊。云何菩萨住檀那波罗蜜取毗梨耶波罗蜜。佛言。菩萨布施时受者嗔恚骂辱恶言加之。菩萨增益布施心作是念。我应当施不应有所惜。即时生身精进心精进。是为菩萨住檀那波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住檀那波罗蜜取禅那波罗蜜。佛言。菩萨布施时回向萨婆若。不趣声闻辟支佛地但一心念萨婆若。是为菩萨住檀那波罗蜜取禅那波罗蜜。世尊。云何菩萨摩诃萨住檀那波罗蜜取般若波罗蜜。佛言。菩萨布施时知布施空如幻。不见为众生布施有益无益。是为菩萨住檀那波罗蜜取般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨住尸罗波罗蜜。取檀那波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜

佛告须菩提。菩萨摩诃萨住尸罗波罗蜜中。身口意生布施福德。助阿耨多罗三藐三菩提。持是功德不取声闻辟支佛地。住尸罗波罗蜜中。不夺他命。不劫夺他物。不行邪淫。不妄语不两舌不恶口不绮语。不贪嫉不嗔恚不邪见。所有布施。饥者与食渴者与饮。须乘与乘须衣与衣。须香与香须璎珞与璎珞。涂香卧具房舍灯烛资生所须。尽给与之。持是布施与众生共之。回向阿耨多罗三藐三菩提。如是回向不堕声闻辟支佛地。须菩提。是为菩萨摩诃萨住尸罗波罗蜜取檀那波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取羼提波罗蜜。佛言。菩萨摩诃萨住尸罗波罗蜜中。若有众生来节节支解。菩萨于是中不生嗔恚心乃至一念。作是言。我得大利。众生来取我支节用。我无一念嗔恚。是为菩萨住尸罗波罗蜜中取羼提波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取毗梨耶波罗蜜。佛言。若菩萨摩诃萨身精进心精进常不舍作是念。一切众生在生死中。我当拔着甘露地。是为菩萨住尸罗波罗蜜中取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取禅那波罗蜜。佛言。菩萨入初禅第二第三第四禅。不贪声闻辟支佛地。作是念。我当住禅那波罗蜜中。度一切众生生死。是为菩萨住尸罗波罗蜜取禅那波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜。取般若波罗蜜。佛言。菩萨住尸罗波罗蜜中。无有法可见若作法若无作法。若数法若相法若有若无。但见诸法不过如相。以般若波罗蜜沤和拘舍罗力故。不堕声闻辟支佛地。是为菩萨住尸罗波罗蜜取般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨住羼提波罗蜜取檀那波罗蜜。佛言。菩萨从初发心乃至道场。于其中间若一切众生来。嗔恚骂詈若节节支解。菩萨住于忍辱作是念。我应布施一切众生不应不与。是众生须食与食须饮与饮。乃至资生所须尽皆与之。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是菩萨回向时不生二心。谁回向者回向何处。是为菩萨住羼提波罗蜜取檀那波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取尸罗波罗蜜。佛言。菩萨从初发心乃至道场。于其中间终不夺他命。不与不取。乃至不邪见。亦不贪声闻辟支佛地。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是菩萨回向时三种心不生。谁回向阿耨多罗三藐三菩提。用何法回向。回向何处。是为菩萨住羼提波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取毗梨耶波罗蜜。佛言菩萨住羼提波罗蜜生精进作是念。我当往一由旬若十由旬百千万亿由旬。过一国土乃至过百千万亿国土。乃至教一人令持五戒。何况令得须陀洹果乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是为菩萨住羼提波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取禅那波罗蜜。佛言。菩萨住羼提波罗蜜离欲离恶不善法有觉有观。离生喜乐。入初禅乃至入第四禅。是诸禅中净心心数法。皆回向萨婆若。回向时是菩萨诸禅及禅支皆不可得。是为菩萨住羼提波罗蜜取禅那波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取般若波罗蜜。佛言。菩萨住羼提波罗蜜。观诸法若离相若寂灭相若无尽相。不以寂灭相作证。乃至坐道场得一切种智。从道场起便转法轮。是为菩萨住羼提波罗蜜取般若波罗蜜。不取不舍故

须菩提白佛言。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取檀那波罗蜜。佛告须菩提。菩萨住毗梨耶波罗蜜。身心精进不懈不息作是念。我必当应得阿耨多罗三藐三菩提不应不得。是菩萨为利益众生故。往一由旬若百千万亿由旬。若过一国土若过百千万亿国土。住毗梨耶波罗蜜中。若不得一人教令入佛道中。若声闻道中若辟支佛道中。或得一人教令行十善道精进不懈。法施及以财施令具足。持是功德与众生共之。回向阿耨多罗三藐三菩提。不回向声闻辟支佛地。是为菩萨住毗梨耶波罗蜜取檀那波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取尸罗波罗蜜。佛言。菩萨住毗梨耶波罗蜜。从初发意乃至坐道场自不杀生不教他杀。赞不杀生法。欢喜赞叹不杀生者。乃至自远离邪见教他远离邪见。赞不邪见法。欢喜赞叹不邪见者。是菩萨行尸罗波罗蜜因缘。不求欲界色界无色界福。不求声闻辟支佛地。持是功德与众生共之。回向阿耨多罗三藐三菩提不生三种心。不见回向者。不见回向法。不见回向处。是为菩萨住毗梨耶波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取羼提波罗蜜。佛言。菩萨住毗梨耶波罗蜜。从初发意乃至坐道场。于其中间若人若非人来节节支解。菩萨作是念。割我者谁截我者谁夺我者谁。复作是念。我大得善利。我为众生故受身。众生还自来取。是时菩萨正忆念诸法实相。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住毗梨耶波罗蜜取羼提波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取禅那波罗蜜。佛言。菩萨住毗梨耶波罗蜜。离欲离恶不善法有觉有观。离生喜乐。入初禅第二第三第四禅。入慈悲喜舍。乃至入非有想非无想处。持是禅无量无色定不受果报。生于利益众生之处。以六波罗蜜成就众生。所谓檀那波罗蜜乃至般若波罗蜜。从一佛国至一佛国。亲近供养诸佛种善根故。是为菩萨住毗梨耶波罗蜜取禅那波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取般若波罗蜜。佛言。菩萨住毗梨耶波罗蜜。不见檀那波罗蜜法不见檀那波罗蜜相。乃至不见禅那波罗蜜法不见禅那波罗蜜相。四念处乃至一切种智。亦不见法亦不见相。见一切法非法非非法。于法中无所著。是菩萨所作如所言。是为菩萨住毗梨耶波罗蜜取般若波罗蜜

须菩提白佛言。世尊。云何菩萨摩诃萨住禅那波罗蜜取檀那波罗蜜。佛言。菩萨摩诃萨住禅那波罗蜜离诸欲离恶不善法。有觉有观离生喜乐。入初禅第二第三第四禅。入慈悲喜舍乃至非有想非无想处。住禅那波罗蜜中心不乱。行二施以施众生法施财施。自行二施教他行二施。赞叹二施法。欢喜赞叹行二施者。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住禅那波罗蜜。取檀那波罗蜜。世尊。云何菩萨摩诃萨住禅那波罗蜜取尸罗波罗蜜

佛言。菩萨住禅那波罗蜜。不生淫欲嗔恚愚痴心。不生恼他心。但修行一切智相应心。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住禅那波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住禅那波罗蜜取羼提波罗蜜。佛言。菩萨住禅那波罗蜜。观色如聚沫。观受如泡。观想如野马。观行如芭蕉。观识如幻。作是观时。见五阴无坚固相作是念。割我者谁。截我者谁。谁受谁想谁行谁识。谁骂者谁受骂者。谁生嗔恚。是为菩萨住禅那波罗蜜取羼提波罗蜜。世尊云何菩萨摩诃萨住禅那波罗蜜取毗梨耶波罗蜜。佛言。菩萨住禅那波罗蜜。离欲离恶不善法。有觉有观离生喜乐。入初禅第二第三第四禅。是诸禅及支不取相。生种种神通。履水如地入地如水。如先说。天耳闻二种声。若天若人。知他心。若摄心若乱心。乃至有上心无上心。忆种种宿命。如先说。以天眼净过人眼。见众生乃至如业受报。如先说。菩萨住是五神通。从一佛国至一佛国。亲近供养诸佛种善根。成就众生净佛国土。持是功德与众生共之。回向阿耨多罗三藐三菩提。是为菩萨住禅那波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住禅那波罗蜜取般若波罗蜜

佛言。菩萨住禅那波罗蜜。不得色不得受想行识。不得檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。不得般若波罗蜜不得四念处。乃至不得一切种智。不得诸法有为性。不得诸法无为性。不得故不作。不作故不生。不生故不灭。何以故。有佛无佛是如法相法性常住不生不灭。常一心应萨婆若行。是为菩萨住禅那波罗蜜取般若波罗蜜。

须菩提白佛言。世尊。云何菩萨摩诃萨住般若波罗蜜取檀那波罗蜜

佛言。菩萨住般若波罗蜜。内空内空不可得。外空外空不可得。内外空内外空不可得空空空空不可得。乃至一切法空一切法空不可得。菩萨住是十四空中。不得色相若空若不空。不得受想行识相若空若不空。不得四念处若空若不空。乃至不得阿耨多罗三藐三菩提若空若不空。不得有为性无为性若空若不空。是菩萨摩诃萨如是住般若波罗蜜中。有所布施若饮食衣服种种资生之具。观是布施空。何等空。施者受者及财物空。不令悭着心生。何以故。菩萨摩诃萨行般若波罗蜜。从初发意乃至坐道场无有妄想分别。如诸佛得阿耨多罗三藐三菩提时无悭着心。菩萨摩诃萨亦如是。行般若波罗蜜时无悭着心。是菩萨所可尊者般若波罗蜜是。是为菩萨住般若波罗蜜取檀那波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取尸罗波罗蜜。佛言。菩萨住般若波罗蜜不生声闻辟支佛心。何以故。是菩萨声闻辟支佛地不可得。趣向声闻辟支佛心亦不可得。是菩萨摩诃萨从初发意乃至坐道场。于其中间自不杀生不教他杀。赞不杀法。欢喜赞叹不杀生者。乃至自不邪见不教他邪见。赞叹不邪见法。欢喜赞叹不邪见者。以是持戒因缘。无法可取若声闻若辟支佛地。何况余法。是为菩萨住般若波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取羼提波罗蜜

佛言。菩萨住般若波罗蜜随顺法忍生。作是念。诸法中无有法若起若灭若生若死。若受骂詈若受恶口。若割若截若破若缚若打若杀。是菩萨从初发意乃至道场。若一切众生来骂詈恶口。刀杖瓦石割截伤害。心不动恚作是念甚可怪。此法中无有法受骂詈恶口割截伤害者。而众生受诸苦恼。是为菩萨住般若波罗蜜取羼提波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取毗梨耶波罗蜜

佛言。菩萨住般若波罗蜜为众生说法。令行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。教令行四念处乃至八圣道分。令得须陀洹果斯陀含阿那含阿罗汉果辟支佛道。令得阿耨多罗三藐三菩提。不住有为性中。不住无为性中。是为菩萨住般若波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取禅那波罗蜜。佛言。菩萨住般若波罗蜜除诸佛三昧。入余一切三昧。若声闻三昧若辟支佛三昧若菩萨三昧皆行皆入。是菩萨住诸三昧。逆顺出入八背舍。何等八。内有色相外观色。是初背舍。内无色相外观色。二背舍。净背舍身作证。三背舍。过一切色相灭有对相。不念种种相故。入无量虚空处。四背舍。过一切虚空处入无边识处。五背舍。过一切识处。入无所有处。六背舍。过一切无所有处。入非有想非无想处。七背舍。过一切非有想非无想处。入灭受想处。八背舍。于是八背舍。逆顺出入九次第定。何等九。离诸欲离诸恶不善法。有觉有观离生喜乐。入初禅乃至过非有想非无想处。入灭受想定。是名九次第定逆顺出入。是菩萨依八背舍九次第定。入师子奋迅三昧。云何名师子奋迅三昧。须菩提。菩萨离欲离恶不善法。有觉有观。离生喜乐。入初禅乃至入灭受想定。从灭受想定起。还入非有想非无想处。非有想非无想处起。乃至还入初禅。是菩萨依师子奋迅三昧。入超越三昧。云何为超越三昧。须菩提。菩萨离欲离诸恶不善法。有觉有观离生喜乐入初禅。从初禅起乃至入非有想非无想处。非有想非无想处起。入灭受想定。灭受想定起还入初禅。从初禅起入灭受想定。灭受想定起入二禅。二禅起入灭受想定。灭受想定起入三禅。三禅起入灭受想定。灭受想定起入四禅。四禅起入灭受想定。灭受想定起入空处。空处起入灭受想定。灭受想定起入识处。识处起入灭受想定。灭受想定起入无所有处。无所有处起入灭受想定。灭受想定起入非有想非无想处。非有想非无想处起入灭受想定。灭受想定起入散心中。散心中起入灭受想定。灭受想定起还入散心中。散心中起入非有想非无想处。非有想非无想处起还住散心中。散心中起入无所有处。无所有处起住散心中。散心中起入识处。识处起住散心中。散心中起入空处。空处起住散心中。散心中起入第四禅中。第四禅中起住散心中。散心中起入第三禅中。第三禅中起住散心中。散心中起入第二禅中。第二禅中起住散心中。散心中起入初禅中。初禅中起住散心中是菩萨摩诃萨住超越三昧。得诸法等相。是为菩萨住般若波罗蜜取禅那波罗蜜

摩诃般若波罗蜜经卷第二十摩诃般若波罗蜜经卷第二十一

        后秦龟兹国三藏鸠摩罗什译

    方便品第六十九

尔时须菩提白佛言。世尊。是菩萨摩诃萨如是方便力成就者。发意以来几时。佛告须菩提。是菩萨摩诃萨能成就方便力者。发意以来无量亿阿僧祇劫。须菩提言。世尊。是菩萨摩诃萨如是成就方便力者。为供养几佛。佛言。是菩萨成就方便力者。供养如恒河沙等诸佛。须菩提白佛言。世尊。菩萨得如是方便力者种何等善根。佛言。菩萨成就如是方便力者。从初发意以来。于檀那波罗蜜无不具足。于尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜无不具足。须菩提白佛言。世尊。菩萨摩诃萨成就如是方便力者甚希有。佛言。如是如是。须菩提。菩萨摩诃萨成就如是方便力者甚希有。须菩提。譬如日月周行照四天下多有所益。般若波罗蜜亦如是。照五波罗蜜多有所益。须菩提。譬如转轮圣王若无轮宝不得名为转轮圣王。轮宝成就故。得名转轮圣王。五波罗蜜亦如是。若离般若波罗蜜不得波罗蜜名字。不离般若波罗蜜故。得波罗蜜名字。须菩提。譬如无夫妇人易可侵陵。五波罗蜜亦如是。远离般若波罗蜜。魔若魔天坏之则易。譬如有夫妇人难可侵陵。五波罗蜜亦如是。得般若波罗蜜。魔若魔天不能沮坏。须菩提。譬如军将铠仗具足。邻国强敌所不能坏。五波罗蜜亦如是。不远离般若波罗蜜。魔若魔天若增上慢人。乃至菩萨旃陀罗所不能坏。须菩提。譬如诸小国王随时朝侍转轮圣王。五波罗蜜亦复如是。随顺般若波罗蜜。譬如众川万流皆入于恒河随入大海。五波罗蜜亦如是。般若波罗蜜所守护故随到萨婆若。譬如人之右手所作事便。般若波罗蜜亦如是。如人左手造事不便。五波罗蜜亦如是。譬如众流若大若小俱入大海合为一味。五波罗蜜亦如是。为般若波罗蜜所护。随般若波罗蜜入萨婆若。得波罗蜜名字。譬如转轮圣王四种兵。轮宝在前导。王意欲住轮则为住。令四种兵满其所愿。轮亦不离其处。般若波罗蜜亦如是。导五波罗蜜到萨婆若。常是中住不过其处。譬如转轮圣王常四种兵。轮宝在前导。般若波罗蜜亦如是。导五波罗蜜到萨婆若。住般若波罗蜜。亦不分别檀那波罗蜜随从我。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜不随我。檀那波罗蜜亦不分别我随从般若波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜不随从。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。亦如是。何以故。诸波罗蜜性无所能作。自性空虚诳如野马。尔时须菩提白佛言。世尊。若一切法自性空。云何菩萨摩诃萨行六波罗蜜。当得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨行六波罗蜜时作是念。是世间心皆颠倒。我若不行方便力。不能度脱众生生死。我当为众生故。行檀那波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。是菩萨为众生故舍内外物。舍时作是念。我无所舍。何以故。是物必当坏败。菩萨作如是思惟。能具足檀那波罗蜜。为众生故终不破戒。何以故。菩萨作是念。我为众生发阿耨多罗三藐三菩提。若杀生是所不应。乃至我为众生发阿耨多罗三藐三菩提。若作邪见若贪着声闻辟支佛地。是所不应。菩萨摩诃萨如是思惟。能具足尸罗波罗蜜。菩萨为众生故不嗔心乃至不生一念。菩萨如是思惟。我应利益众生。云何而起嗔心。菩萨如是能具足羼提波罗蜜。菩萨为众生故乃至阿耨多罗三藐三菩提。常不生懈怠心。菩萨如是行能具足毗梨耶波罗蜜。菩萨为众生故乃至得阿耨多罗三藐三菩提不生散乱心。菩萨如是行能具足禅那波罗蜜。菩萨为众生故乃至阿耨多罗三藐三菩提终不离智慧。何以故。除智慧不可以余法度脱众生故。菩萨如是行能具足般若波罗蜜。须菩提白佛言。世尊。若诸波罗蜜无差别相。云何般若波罗蜜。于五波罗蜜中第一最上微妙。佛告须菩提。如是如是。诸波罗蜜虽无差别。若无般若波罗蜜。五波罗蜜不得波罗蜜名字。因般若波罗蜜。五波罗蜜得波罗蜜名字。须菩提。譬如种种色身。到须弥山王边皆同一色。五波罗蜜亦如是。因般若波罗蜜到萨婆若中一种无异。不分别是檀那波罗蜜是尸罗波罗蜜是羼提波罗蜜是毗梨耶波罗蜜是禅那波罗蜜是般若波罗蜜。何以故。是诸波罗蜜无自性故。以是因缘故。诸波罗蜜无差别。须菩提白佛言。世尊。若随实义无分别。云何般若波罗蜜。于五波罗蜜中最上微妙。佛言。如是如是。须菩提。虽实义中无有分别。但以世俗法故。假说檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。为欲度众生生死。是众生实不生不死不起不退。须菩提。众生无所有故。当知一切法无所有以是因缘故。般若波罗蜜于五波罗蜜中最上最妙。须菩提。譬如阎浮提众女人中玉女宝第一最上最妙。般若波罗蜜亦如是。于五波罗蜜中第一最上最妙。须菩提白佛言。世尊。佛以何意故。说般若波罗蜜最上最妙。佛告须菩提。是般若波罗蜜取一切善法。到萨婆若中住不住故。须菩提白佛言。世尊。般若波罗蜜有法可取可舍不。佛言。不也须菩提。般若波罗蜜无法可取无法可舍。何以故。一切法不取不舍故。世尊。般若波罗蜜于何等法不取不舍。佛言。般若波罗蜜于色不取不舍。于受想行识乃至阿耨多罗三藐三菩提不取不舍。世尊。云何不取色。乃至不取阿耨多罗三藐三菩提。佛言。若菩萨不念色乃至不念阿耨多罗三藐三菩提。是名不取色乃至不取阿耨多罗三藐三菩提。须菩提言。世尊。若不念色乃至不念阿耨多罗三藐三菩提。云何得增益善根。善根不增。云何具足诸波罗蜜。若不具足诸波罗蜜。云何得阿耨多罗三藐三菩提。佛告须菩提。若菩萨不念色乃至不念阿耨多罗三藐三菩提。是时善根增益。善根增益故具足诸波罗蜜。诸波罗蜜具足故得阿耨多罗三藐三菩提。何以故。不念色乃至不念阿耨多罗三藐三菩提时。便得阿耨多罗三藐三菩提。世尊。何因缘故色不念时乃至阿耨多罗三藐三菩提不念时。便得阿耨多罗三藐三菩提。佛言。以念故着欲界色界无色界。不念故无所著。如是须菩提。菩萨摩诃萨行般若波罗蜜不应有所著世尊。菩萨摩诃萨如是行般若波罗蜜当住何处。佛言。菩萨摩诃萨如是行。不住色乃至不住一切种智。世尊。何因缘故色中不住乃至一切种智中不住。佛言。不着故不住。何以故。是菩萨不见有法可着可住。如是须菩提。菩萨摩诃萨以不着不住法。行般若波罗蜜。须菩提。若菩萨摩诃萨作是念。若能如是行如是修。是行般若波罗蜜。我今行般若波罗蜜修般若波罗蜜。若如是取相。则远离般若波罗蜜。若远离般若波罗蜜。则远离檀那波罗蜜。乃至远离一切种智。何以故。般若波罗蜜无有着处亦无著者。自性无故。菩萨摩诃萨若复如是取相。则于般若波罗蜜退。若退般若波罗蜜则是退阿耨多罗三藐三菩提不得受记。菩萨摩诃萨复作是念。住是般若波罗蜜。能生檀那波罗蜜。乃至能生大悲。若作是念则为失般若波罗蜜。失般若波罗蜜者则不能生檀那波罗蜜。乃至不能生大悲。菩萨若复作是念。诸佛知诸法无受相故。得阿耨多罗三藐三菩提。菩萨若作如是演说开示教诏。则失般若波罗蜜。何以故。诸佛于诸法无所知无所得。亦无法可说。何况当有所得。无有是处。须菩提白佛言。世尊。菩萨行般若波罗蜜。云何无是过失。佛言。若菩萨摩诃萨行般若波罗蜜作是念。诸法无所有不可取。若法无所有不可取。则无所得。若如是行为行般若波罗蜜。若菩萨摩诃萨着无所有法。则远离般若波罗蜜。何以故。般若波罗蜜中无有着法故。须菩提白佛言。世尊。般若波罗蜜远离般若波罗蜜耶。檀那波罗蜜远离檀那波罗蜜耶。乃至一切种智远离一切种智耶。世尊。若般若波罗蜜远离般若波罗蜜。乃至一切种智远离一切种智。菩萨云何得般若波罗蜜。乃至得一切种智。佛言。菩萨摩诃萨行般若波罗蜜时。不生色是色谁色。乃至一切种智不生是一切种智谁一切种智。如是菩萨能生般若波罗蜜。乃至能生一切种智。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不观色若常若无常。若苦若乐。若我若非我。若空若不空。若离若非离。何以故。自性不能生自性。乃至一切种智亦如是。若菩萨摩诃萨行般若波罗蜜。如是观色乃至观一切种智。能生般若波罗蜜乃至能生一切种智。譬如转轮圣王有所至处四种兵皆随从。般若波罗蜜亦如是。有所至处五波罗蜜皆悉随从。到萨婆若中住。譬如善御驾驷不失平道随意所至。般若波罗蜜亦如是。御五波罗蜜不失正道至萨婆若。须菩提言。世尊。何等是菩萨摩诃萨道。何等是非道。佛言。声闻道非菩萨道。辟支佛道非菩萨道。一切智道是菩萨摩诃萨道。须菩提。是名菩萨摩诃萨道非道。须菩提言。世尊。诸菩萨摩诃萨般若波罗蜜。为大事故兴。所谓示是道是非道。佛言。如是如是。须菩提。般若波罗蜜为大事故兴。所谓示是道是非道。须菩提。是般若波罗蜜为度无量众生故兴。为利益阿僧祇众生故兴。般若波罗蜜虽作是利益。亦不受色亦不受受想行识。亦不受声闻辟支佛地。须菩提。般若波罗蜜是诸菩萨摩诃萨导示阿耨多罗三藐三菩提。能令远离声闻辟支佛地。住萨婆若。般若波罗蜜无所生无所灭。诸法常住故。须菩提言。世尊。若般若波罗蜜无所生无所灭菩萨摩诃萨行般若波罗蜜时应云何布施。云何应持戒。云何应忍辱。云何应勤精进。云何应入禅定。云何应修智慧。佛告须菩提。菩萨摩诃萨。念萨婆若应布施。念萨婆若应持戒忍辱精进禅定智慧。是菩萨摩诃萨持是功德与众生共之。应回向阿耨多罗三藐三菩提。若如是回向则具足修六波罗蜜及慈悲心诸功德。须菩提。若菩萨摩诃萨不远离六波罗蜜。则不远离萨婆若。以是故。须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学应行六波罗蜜。菩萨摩诃萨行六波罗蜜。具足一切善根。当得阿耨多罗三藐三菩提。以是故。须菩提。菩萨摩诃萨应习行六波罗蜜。须菩提言。世尊。云何菩萨摩诃萨应习行六波罗蜜。佛言。菩萨摩诃萨应如是观。色不合不散。受想行识不合不散。乃至一切种智不合不散。是名菩萨摩诃萨习行六波罗蜜。复次须菩提。菩萨摩诃萨应作是念。我当不住色中。不住受想行识中。乃至不住一切种智中。如是应习行六波罗蜜。何以故。是色无所住乃至萨婆若无所住。如是须菩提。菩萨摩诃萨以无住法习行六波罗蜜。应当得阿耨多罗三藐三菩提。须菩提。譬如士夫欲食庵罗果若波那婆果。当种其子随时溉灌。守护渐渐生长。时节和合便有果实得而食之。须菩提。菩萨摩诃萨亦如是。欲得阿耨多罗三藐三菩提。当学六波罗蜜以布施摄取众生。持戒忍辱精进禅定智慧摄取众生。度众生生死。如是行当得阿耨多罗三藐三菩提。以是故。须菩提。菩萨摩诃萨欲不随他人语。当学般若波罗蜜。欲净佛国土成就众生。欲坐道场欲转法轮。当学般若波罗蜜。须菩提白佛言。世尊。应如是学般若波罗蜜耶。佛言。菩萨应如是学般若波罗蜜。欲于诸法得自在。当学般若波罗蜜。何以故。学是般若波罗蜜。于一切诸法中得自在故。复次须菩提。般若波罗蜜于一切诸法中最大。譬如大海于万川中最大。般若波罗蜜亦如是。于一切诸法中最大。以是故。诸欲求声闻辟支佛及菩萨道。应当学般若波罗蜜。檀那波罗蜜乃至一切种智。须菩提。譬如射师执如意弓箭不畏怨敌。菩萨摩诃萨亦如是。行般若波罗蜜乃至一切种智魔若魔天所不能坏。以是故。须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学般若波罗蜜。是行般若波罗蜜菩萨为十方诸佛所念。须菩提白佛言。世尊。云何十方诸佛念是菩萨摩诃萨。佛告须菩提。菩萨摩诃萨行檀那波罗蜜时。十方诸佛皆念。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜时。十方诸佛皆念。云何念。布施不可得。持戒忍辱精进禅定智慧不可得。乃至一切种智不可得。菩萨能如是不得诸法故。诸佛念是菩萨摩诃萨。复次须菩提。诸佛不以色故念。不以受想行识故念。乃至不以一切种智故念。须菩提言。世尊。菩萨摩诃萨多有所学实无所学。佛言。如是如是。须菩提。菩萨多有所学实无所学。何以故。是菩萨所学诸法皆不可得。须菩提白佛言。世尊。佛所说法若略若广。于此法中诸菩萨摩诃萨欲求阿耨多罗三藐三菩提。六波罗蜜若略若广。应当受持亲近读诵。读诵已思惟正观。心心数法不行故。佛告须菩提。如是如是。菩萨摩诃萨略广学六波罗蜜。当知一切法略广相。须菩提言。世尊。云何菩萨摩诃萨知一切法略广相。佛言。知色如相。知受想行识乃至知一切种智如相。如是能知一切法略广相。须菩提言。世尊。云何色如相。云何受想行识乃至一切种智如相。佛告须菩提。是色如无生无灭无住异。是名色如相。乃至一切种智如相。无生无灭无住异。是名一切种智如相。是中菩萨摩诃萨应学。复次须菩提。菩萨摩诃萨知诸法实际时。知一切法略广相。世尊。何等是诸法实际。佛言。无际是名实际。菩萨学是际。知一切诸法略广相。须菩提。若菩萨摩诃萨知诸法法性。是菩萨能知一切法略广相。世尊。何等是诸法法性。佛言。色性是名法性。是性无分无非分。须菩提。菩萨摩诃萨知法性故。知一切法略广相。须菩提白佛言。世尊。复云何应知一切法略广相。佛言。若菩萨摩诃萨知一切法不合不散。须菩提言。世尊。何等法不合不散。佛言。色不合不散。受想行识不合不散。乃至一切种智不合不散。有为性无为性不合不散。何以故。是诸法自性无。云何有合散。若法自性无是为非法。法与非法不合不散。如是应当知一切法略广相。须菩提言。世尊。是名菩萨摩诃萨略摄般若波罗蜜。世尊是略摄般若波罗蜜中。初发意菩萨摩诃萨应学。乃至十地菩萨摩诃萨亦应学。是菩萨摩诃萨学是略摄般若波罗蜜。则知一切法略广相世尊。是门利根菩萨摩诃萨所入。佛言。钝根菩萨亦可入是门。中根菩萨散心菩萨亦可入是门。是门无碍。若菩萨摩诃萨一心学者皆入是门。懈怠少精进妄忆念乱心者所不能入。精进不懈怠正忆念摄心者能入。欲住阿惟越致地。欲逮一切种智者能入。是菩萨摩诃萨如般若波罗蜜所说当学。如禅波罗蜜所说当学乃至如檀波罗蜜所说当学。是菩萨摩诃萨当得一切智。是菩萨摩诃萨行般若波罗蜜。所有魔事欲起。即灭。以是故。菩萨摩诃萨欲得方便力当行般若波罗蜜。若菩萨摩诃萨如是行如是习如是修般若波罗蜜。是时无量阿僧祇国土中现在诸佛。念是行般若波罗蜜菩萨。何以故。是般若波罗蜜中生过去未来现在诸佛故。以是故。菩萨摩诃萨应如是思惟。过去未来现在诸佛所得法我亦当得如是须菩提。菩萨摩诃萨应习般若波罗蜜。若如是习般若波罗蜜疾得阿耨多罗三藐三菩提。以是故。菩萨摩诃萨常应不远离萨婆若念。若菩萨摩诃萨如是行般若波罗蜜。乃至弹指顷是菩萨福德甚多。若有人教三千大千国土中众生。自恣布施。教令持戒禅定智慧。教令得解脱。得解脱知见。教令得须陀洹果乃至阿罗汉果辟支佛道。不如是菩萨修般若波罗蜜乃至弹指顷。何以故。是般若波罗蜜中。生布施持戒禅定智慧须陀洹果乃至辟支佛道。十方现在诸佛亦从般若波罗蜜中生。过去未来诸佛亦从般若波罗蜜中生故。复次须菩提。菩萨摩诃萨应萨婆若念行般若波罗蜜若须臾时若半日若一日若一月若百日。若一岁若百岁若一劫若百劫乃至无量无边阿僧祇劫。是菩萨修是般若波罗蜜福德甚多。胜于教十方恒河沙等世界中众生。布施持戒禅定智慧解脱解脱知见。教令得须陀洹果乃至辟支佛道。何以故。诸佛从般若波罗蜜中生。说是布施持戒禅定智慧解脱解脱知见。须陀洹果乃至辟支佛道。若有菩萨摩诃萨如般若波罗蜜所说住。当知是菩萨摩诃萨是阿惟越致。为诸佛所念。如是方便力成就。当知是菩萨亲近供养无量千万亿诸佛种善根。与善知识相随久行六波罗蜜。久修十八空四念处乃至八圣道分佛十力乃至一切种智。当知是菩萨住法王子地满足诸愿。常不离诸佛不离诸善根。从一佛国至一佛国。当知是菩萨辩才无尽具足得陀罗尼。身色具足受记具足故为众生受身。当知是菩萨善知字门善知非字门。善于言善于不言。善于一言善于二言善于多言。善知女语善知男语。善知色乃至识。善知世间性。善知涅槃性。善知法相。善知有为相善知无为相。善知有法善知无法。善知自性善知他性。善知合法善知散法。善知相应法善知不相应法。善知相应不相应法。善知如善知不如。善知法性善知法位。善知缘善知无缘。善知阴善知界善知入。善知四谛善知十二因缘。善知四禅。善知四无量心。善知无色定。善知六波罗蜜。善知四念处。乃至善知一切种智。善知有为性善知无为性。善知有性善知无性。善知色观善知受想行识观。乃至善知一切种智观。善知色色相空。善知受想行识识相空。乃至善知菩提菩提相空。善知舍道善知不舍道。善知生善知灭善知住异。善知欲善知嗔善知痴。善知不欲善知不嗔善知不痴。善知见善知不见。善知邪见善知正见。善知一切见。善知名善知色善知名色。善知因缘。善知次第缘。善知缘缘。善知增上缘。善知行相。善知苦善知集善知灭善知道。善知地狱善知饿鬼善知畜生善知人善知天。善知地狱趣善知饿鬼趣善知畜生趣。善知人趣善知天趣。善知须陀洹善知须陀洹果善知须陀洹道。善知斯陀含善知斯陀含果善知斯陀含道。善知阿那含善知阿那含果善知阿那含道。善知阿罗汉善知阿罗汉果善知阿罗汉道。善知辟支佛善知辟支佛果善知辟支佛道。善知佛善知一切智善知一切智道。善知诸根善知诸根具足。善知慧善知疾慧。善知有力慧。善知利慧。善知出慧。善知达慧。善知广慧。善知深慧。善知大慧。善知无等慧。善知实慧。善知过去世善知未来世善知现在世。善知方便善知待众生。善知心善知深心。善知义善知语。善知分别三乘。须菩提。菩萨摩诃萨行般若波罗蜜生般若波罗蜜修般若波罗蜜。得如是等利益

    摩诃般若波罗蜜经三慧品第七十

须菩提白佛言。世尊。菩萨摩诃萨云何行般若波罗蜜。云何生般若波罗蜜。云何修般若波罗蜜。佛言。色寂灭故色空故色虚诳故色不坚实故。应行般若波罗蜜。受想行识亦如是。如汝所问云何生般若波罗蜜。如虚空生故应生般若波罗蜜。如汝问云何修般若波罗蜜。修诸法破坏故应修般若波罗蜜。须菩提言。世尊。行般若波罗蜜生般若波罗蜜。修般若波罗蜜应几时。佛言。从初发意乃至坐道场。应行应生应修般若波罗蜜。须菩提白佛言。世尊。次第心应行般若波罗蜜。佛言。常不舍萨婆若心不令余念得入为行般若波罗蜜为生般若波罗蜜为修般若波罗蜜。若心心数法不行故。为行般若波罗蜜为生般若波罗蜜为修般若波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨修般若波罗蜜。当得萨婆若不。佛言不。世尊。不修般若波罗蜜。得萨婆若不。佛言不。世尊。修不修得萨婆若不。佛言不。世尊。非修非不修得萨婆若不。佛言不。世尊。若不尔云何当得萨婆若。佛言。菩萨摩诃萨得萨婆若如如相。世尊。云何如如相。如实际。云何如实际。如法性。云何如法性。如我性众生性寿命性。世尊。云何我性众生性寿命性。佛告须菩提。于汝意云何。我众生寿命法可得不。须菩提言。不可得。佛言。若我众生寿命不可得。云何当说有我性众生性寿命性。若般若波罗蜜中不说有一切法当得一切种智。须菩提言。世尊。但般若波罗蜜是不可说。禅那波罗蜜乃至檀那波罗蜜亦不可说。佛告须菩提。般若波罗蜜不可说。檀那波罗蜜乃至一切法。若有为若无为。若声闻法若辟支佛法。若菩萨法若佛法亦不可说。世尊。若一切法不可说。云何说是地狱是畜生是饿鬼。是人是天。是须陀洹是斯陀含阿那含阿罗汉。辟支佛是诸佛。佛告须菩提。于汝意云何。是众生名字实可得不。须菩提言。世尊。不可得。佛言。若众生不可得。云何当说有地狱饿鬼畜生人天。须陀洹乃至佛。如是须菩提。菩萨摩诃萨行般若波罗蜜时。应当学一切法不可说。须菩提言。世尊。菩萨摩诃萨行般若波罗蜜时。应学色。应学受想行识。乃至应学一切种智。佛告须菩提。菩萨摩诃萨学般若波罗蜜时应学色不增不减。乃至应学一切种智不增不减。须菩提言。世尊。云何色不增不减学。乃至一切种智不增不减学。佛言。不生不灭故学。世尊。云何名不生不灭学。佛言。不起不作诸行业若有若无故。世尊。云何名不起不作诸行业若有若无。佛言。观诸法自相空故。世尊。云何应观诸法自相空。佛言。应观色色相空。应观受想行识识相空。应观眼眼相空乃至意色乃至法眼识界乃至意识界意识界相空。应观内空内空相空。乃至应观自相空自相空相空。应观四禅四禅相空。乃至灭受想定灭受想定相空。应观四念处四念处相空。乃至阿耨多罗三藐三菩提阿耨多罗三藐三菩提相空。如是须菩提。菩萨行般若波罗蜜时。应行诸法自相空。世尊。若色色相空。乃至阿耨多罗三藐三菩提阿耨多罗三藐三菩提相空。云何菩萨摩诃萨应行般若波罗蜜。佛言。不行是名行般若波罗蜜。世尊。云何不行是行般若波罗蜜。佛言。般若波罗蜜不可得故。菩萨不可得。行亦不可得。行者行法行处亦不可得故。是名菩萨摩诃萨行不行般若波罗蜜。一切诸戏论不可得故。世尊。若不行是菩萨摩诃萨行般若波罗蜜。初发意菩萨云何行般若波罗蜜。须菩提。菩萨从初发意以来应学空无所得法。是菩萨用无所得法故布施持戒忍辱精进禅定。用无所得法故修智慧乃至一切种智亦如是。须菩提白佛言。世尊。云何名有所得。云何名无所得。佛告须菩提。诸有二者是有所得。无有二者是无所得。世尊。何等是二有所得。何等是不二无所得。佛言。眼色为二乃至意法为二。乃至阿耨多罗三藐三菩提佛为二。是名为二。世尊。从有所得中无所得。从无所得中无所得。佛言。不从有所得中无所得。不从无所得中无所得。须菩提。有所得无所得平等。是名无所得。如是须菩提。菩萨摩诃萨于有所得无所得平等法中应学。须菩提。菩萨摩诃萨如是学般若波罗蜜。是名无所得者无有过失。须菩提白佛言。世尊。若菩萨行般若波罗蜜。不行有所得。不行无所得。云何从一地至一地得一切种智。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不住有所得中从一地至一地。何以故。有所得中住。不能从一地至一地。何以故。须菩提。无所得是般若波罗蜜相。无所得是阿耨多罗三藐三菩提相。无所得亦是行般若波罗蜜者相。须菩提。菩萨摩诃萨应如是行般若波罗蜜。须菩提白佛言。世尊。若般若波罗蜜不可得。阿耨多罗三藐三菩提亦不可得。行般若波罗蜜者亦不可得。云何菩萨摩诃萨分别诸法相是色是受想行识。乃至是阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不得色不得受想行识。乃至不得阿耨多罗三藐三菩提。世尊。若菩萨摩诃萨行般若波罗蜜。色不可得乃至阿耨多罗三藐三菩提不可得。云何具足檀那波罗蜜乃至具足般若波罗蜜入菩萨法位中。入已净佛国土成就众生得一切种智。得一切种智已转法轮。作佛事度众生生死。佛告须菩提。菩萨摩诃萨不为色故行般若波罗蜜。乃至不为阿耨多罗三藐三菩提故行般若波罗蜜。须菩提白佛言。世尊。菩萨为何事故行般若波罗蜜。佛言。无所为故行般若波罗蜜。何以故。一切诸法无所为无所作。般若波罗蜜亦无所为无所作。阿耨多罗三藐三菩提亦无所为无所作。菩萨亦无所为无所作。如是须菩提。菩萨摩诃萨应行般若波罗蜜无所为无所作。须菩提白佛言。世尊。若诸法无所为无所作。不应分别有三乘声闻辟支佛佛乘。佛告须菩提。诸法无所为无所作中无有分别。有所为有所作中有分别。何以故。凡夫愚人不闻圣法着五受阴。所谓色受想行识。着檀那波罗蜜乃至着阿耨多罗三藐三菩提。是人念有是色得是色。乃至念有是阿耨多罗三藐三菩提。得是阿耨多罗三藐三菩提。是菩萨作是念。我当得阿耨多罗三藐三菩提。我当度众生生死。须菩提。我以五眼观。尚不得色乃至阿耨多罗三藐三菩提。何况是狂愚人无目而欲得阿耨多罗三藐三菩提度脱众生生死。须菩提白佛言。世尊。若佛以五眼观。不见众生生死中可度者。今世尊云何得阿耨多罗三藐三菩提。分别众生有三聚正定邪定不定。须菩提。我得阿耨多罗三藐三菩提。初不得众生三聚若正定若邪定若不定。须菩提。以众生无法有法想。我以除其妄着世俗法故。说有得非第一义。世尊。非住第一义。得阿耨多罗三藐三菩提耶。佛言不也。世尊。住颠倒得阿耨多罗三藐三菩提耶。佛言不也。世尊。若不住第一义中得。亦不住颠倒中得。将无世尊不得阿耨多罗三藐三菩提耶。佛言不也。我实得阿耨多罗三藐三菩提。无所住若有为相。若无为相。须菩提。譬如佛所化人。不住有为相不住无为相。化人亦有来有去亦坐亦立。须菩提。是化人若行檀那波罗蜜。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。行四禅四无量心四无色定五神通。行四念处乃至行八圣道分。入空三昧无相三昧无作三昧。行内空乃至无法有法空。行八背舍九次第定佛十力四无所畏四无碍智大慈大悲。得阿耨多罗三藐三菩提转法轮。是化人化作无量众生有三聚。须菩提。于汝意云何。是化人有行檀那波罗蜜。乃至有三聚众生不。须菩提言不也。须菩提。佛亦如是。知诸法如化如化人度化众生。无有实众生可度。如是须菩提。菩萨摩诃萨行般若波罗蜜。如佛所化人行。须菩提白佛言。世尊。若一切法如化。佛与化人有何等差别。佛告须菩提。佛与化人无有差别。何以故。佛能有所作。化人亦能有所作。世尊。若无佛化独能有所作不。佛言。能有所作。须菩提言。世尊。云何无佛化能有所作。须菩提。譬如过去有佛名须扇多。为欲度菩萨故化作佛而自灭度。是化佛住半劫作佛事。授应菩萨行者记已灭度。一切世间众生谓佛实灭度。须菩提。化人实无生无灭。如是须菩提。菩萨行般若波罗蜜。当信知诸法如化。世尊。若佛佛所化人无差别者。云何令布施清净。如人供养佛是众生乃至无余涅槃福德不尽。若供养化佛。是人乃至无余涅槃福德。亦应不尽耶。佛语须菩提。佛以诸法实相故。与一切众生天及人作福田。化佛亦以诸法实相故。与一切众生天及人作福田。佛告须菩提。置是化佛及于化佛所种福德。若有善男子善女人但以敬心念佛。是善根因缘乃至毕苦其福不尽。须菩提。置是敬心念佛。若有善男子善女人但以一华散虚空中念佛。乃至毕苦其福不尽。须菩提。置是敬心念佛散华念佛。若有人一称南无佛。乃至毕苦其福不尽。如是须菩提。佛福田中种其福无量。以是故。须菩提。当知佛与化佛无有差别。诸法相无异故。须菩提。菩萨摩诃萨应如是行般若波罗蜜入诸法实相中。是诸法实相不应坏。所谓般若波罗蜜相乃至阿耨多罗三藐三菩提相。须菩提白佛言。世尊。若诸法实相不应坏。佛何以坏诸法相。言是色是受想行识。是内法是外法。是善法是不善法。是有漏是无漏。是世间是出世间。是有诤法是无诤法。是有为法是无为法等。世尊。将无坏诸法相。佛告须菩提。不也以名字相故示诸法。欲令众生解佛不坏诸法法相。须菩提白佛言。世尊。若以名字相故。说诸法令众生解。世尊。若一切法无名无相。云何以名相示众生欲令解。佛告须菩提。随世俗法有名相实无著处。须菩提。如凡人闻说苦著名随相。须菩提。诸佛及弟子不著名不随相。须菩提。若名著名相着相。空亦应着空。无相亦应着无相。无作亦应着无作。实际亦应着实际法性亦应着法性。无为性亦应着无为性。须菩提。是一切法但有名相。是法不住名相中。如是须菩提。菩萨摩诃萨但名相中住。应行般若波罗蜜。是名相中亦不应着。世尊。若一切有为法但名相者。菩萨摩诃萨为谁故发阿耨多罗三藐三菩提心受种种勤苦。菩萨行道时布施持戒行忍辱勤精进入禅定修智慧。行四禅四无量心。四无色定四念处。乃至八圣道分。行空行无相行无作。行佛十力乃至具足大慈悲。佛言如须菩提所说。若一切有为法但有名相者。菩萨摩诃萨为谁故行菩萨道。须菩提。若有为法但有名相。等是名相名相亦空。以是故。菩萨摩诃萨行菩萨道得一切种智。得一切种智已转法轮转法轮已以三乘法度脱众生。是名相亦无生无灭无住异。尔时须菩提白佛言。世尊。世尊说一切种智。佛告须菩提。我说一切种智。须菩提言。佛说一切智说道种智说一切种智。是三种智有何差别。佛告须菩提。萨婆若是一切声闻辟支佛智。道种智是菩萨摩诃萨智。一切种智是诸佛智。须菩提白佛言。世尊。何因缘故。萨婆若是声闻辟支佛智。佛告须菩提。一切名所谓内外法。是声闻辟支佛能知。不能用一切道一切种智。须菩提言。世尊。何因缘故道种智是诸菩萨摩诃萨智。佛告须菩提。一切道菩萨摩诃萨应知。若声闻道辟支佛道。菩萨道应具足知。亦应用是道度众生。亦不作实际证。须菩提白佛言。世尊。如佛说菩萨摩诃萨应具足佛道。不应以是道实际作证耶。佛告须菩提。是菩萨未净佛土未成就众生。是时不应实际作证。须菩提白佛言。世尊。菩萨住道中应实际作证。佛言不也。世尊。住非道中实际作证。佛言不也。世尊。住道非道实际作证。佛言不也。世尊。住非道亦非非道实际作证。佛言不也。世尊。菩萨摩诃萨住何处应实际作证。佛告须菩提。于汝意云何。汝住道中不受诸法故。漏尽得解脱不。须菩提言。不也世尊。汝住非道漏尽得解脱不。不也世尊。汝住道非道漏尽得解脱不。不也世尊。汝住非道亦非非道漏尽得解脱不。不也世尊。我无所住不受诸法漏尽心得解脱。佛告须菩提菩萨摩诃萨亦如是。无所住应实际作证。须菩提言。世尊。云何为一切种智相。佛言。一相故名一切种智。所谓一切法寂灭相。复次诸法行类相貌。名字显示说佛如实知。以是故名一切种智。须菩提白佛言。世尊。一切智道种智一切种智。是三智结断有差别有尽有余不。佛言。烦恼断无差别。诸佛烦恼习一切悉断。声闻辟支佛烦恼习不悉断。世尊。是诸人不得无为法。得断烦恼耶。佛言不也。世尊。无为法中可得差别不。佛言不也。世尊。若无为法中不可得差别。何以故。说是人烦恼习断是人烦恼习不断。佛告须菩提。习非烦恼。是声闻辟支佛身口。有似淫欲嗔恚愚痴相。凡夫愚人为之得罪。是三毒习诸佛无有。须菩提白佛言。世尊。若道无法。涅槃亦无法。何以故。分别说是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是菩萨是佛。佛告须菩提。是皆以无为法而有分别是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是菩萨是佛。世尊。实以无为法故分别有须陀洹乃至佛。佛告须菩提。世间言说故有差别非第一义。第一义中无有分别说。何以故。第一义中无言说道断结故说后际。须菩提言。世尊。诸法自相空中前际不可得。何况说有后际。佛告须菩提如是如是。诸法自相空中无有前际。何况有后际无有是处。须菩提。以众生不知诸法自相空故。为说是前际是后际。诸法自相空中前际后际不可得。如是须菩提。菩萨摩诃萨应以自相空法行般若波罗蜜。须菩提。若菩萨行自相空法。则无所著若内法若外法。若有为法若无为法。若声闻法若辟支佛法若佛法。须菩提白佛言。常说般若波罗蜜般若波罗蜜以何义故名般若波罗蜜。佛言。得第一义度一切法到彼岸。以是义故名般若波罗蜜。复次须菩提。诸佛菩萨辟支佛阿罗汉。用是般若波罗蜜得度彼岸。以是义故名般若波罗蜜。复次须菩提。分别筹量破坏一切法乃至微尘。是中不得坚实。以是义故名般若波罗蜜复次须菩提。诸法如法性实际。皆入般若波罗蜜中。以是义故名般若波罗蜜。复次须菩提。是般若波罗蜜无有法若合若散。若有色若无色。若可见若不可见。若有对若无对。若有漏若无漏。若有为若无为。何以故。是般若波罗蜜无色无形无对一相。所谓无相。复次须菩提。是般若波罗蜜。能生一切法一切乐说辩一切照明。须菩提。是般若波罗蜜。魔若魔天求声闻辟支佛人。及余异道梵志怨仇恶人。不能坏菩萨行般若波罗蜜。何以故。是人辈般若波罗蜜中皆不可得故。须菩提。是菩萨摩诃萨应如是行般若波罗蜜义。复次须菩提。菩萨摩诃萨欲行深般若波罗蜜义。应行无常义苦义空义无我义。亦应行苦智义集智义灭智义道智义。法智义比智义。世智义他心智义。尽智义无生智义如实智义。如是须菩提。菩萨摩诃萨为般若波罗蜜义故。应行般若波罗蜜。须菩提白佛言。世尊。是深般若波罗蜜中。义与非义皆不可得。云何菩萨为深般若波罗蜜义故。应行般若波罗蜜。佛告须菩提。菩萨摩诃萨为深般若波罗蜜义故应如是念。贪欲非义如是义不应行。嗔恚愚痴非义如是义不应行。一切邪见无义如是义不应行。何以故。三毒如相无有义无有非义。一切邪见如相无有义无有非义。复次须菩提。菩萨摩诃萨应作是念。色非义非非义。乃至识非义非非义。檀那波罗蜜乃至阿耨多罗三藐三菩提非义非非义。何以故。须菩提。佛得阿耨多罗三藐三菩提时。无有法可得若义若非义。须菩提。有佛无佛诸法法相常住。无有义无有非义如是须菩提菩萨摩诃萨行般若波罗蜜。应离义及非义。须菩提白佛言。世尊。何以故。般若波罗蜜非义非非义。佛告须菩提。一切有为法无作相。以是故般若波罗蜜非义非非义。世尊。一切贤圣若佛若佛弟子。皆以无为为义。云何佛言般若波罗蜜无有义非义。佛言。虽一切贤圣若佛若佛弟子皆以无为为义。亦不以增亦不以损。须菩提。譬如虚空如不能益众生不能损众生。如是须菩提。菩萨摩诃萨般若波罗蜜无有增无有损。世尊菩萨摩诃萨不学无为般若波罗蜜得一切种智耶。佛言。如是如是。须菩提。菩萨摩诃萨学是无为般若波罗蜜当得一切种智。不以二法故。世尊。不二法能得不二法耶。佛言不也。须菩提言。二法能得不二法耶。佛言不也。须菩提言世尊。菩萨摩诃萨若不以二法不以不二法。云何当得一切种智。须菩提。无所得即是得。以是得无所得

摩诃般若波罗蜜经卷第二十一摩诃般若波罗蜜经卷第二十二

        后秦龟兹国三藏鸠摩罗什译

    道树品第七十一(丹种树品)

须菩提白佛言。世尊。是般若波罗蜜甚深。世尊。诸菩萨摩诃萨不得众生。而为众生求阿耨多罗三藐三菩提。是为甚难。世尊。譬如人欲于虚空中种树。是为甚难。世尊。菩萨摩诃萨亦如是。为众生故求阿耨多罗三藐三菩提。众生亦不可得。佛告须菩提。如是如是。诸菩萨摩诃萨所为甚难。为众生故求阿耨多罗三藐三菩提。度着吾我颠倒众生。须菩提。譬如人种树。不识树根茎枝叶华果而爱护溉灌。渐渐长大华叶果实成就皆得用之。如是须菩提。诸菩萨摩诃萨为众生故求阿耨多罗三藐三菩提。渐渐行六波罗蜜得一切种智成佛树。以叶华果实益众生。须菩提。何等为叶益众生。因菩萨摩诃萨得离三恶道。是为叶益众生。何等为华益众生。因菩萨得生刹利大姓婆罗门大姓。居士大家。四天王天处。乃至非有想非无想处。是为华益众生。何等为果益众生。是菩萨得一切种智。令众生得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道。是众生渐渐以三乘法。于无余涅槃而般涅槃。是为果益众生。是菩萨摩诃萨不得众生实法。而度众生令离我颠倒着。作是念。一切诸法中无众生我所。为众生求一切种智。是众生实不可得。须菩提白佛言。世尊。当知是菩萨为如佛。所以者何。是菩萨因缘故。断一切地狱种一切畜生种一切饿鬼种。断一切诸难。断一切贫穷下贱道。断一切欲界色界无色界。佛言。如是如是。须菩提。当知是菩萨摩诃萨如佛。须菩提。若菩萨摩诃萨不发心求阿耨多罗三藐三菩提。世间则无过去未来现在诸佛。世间亦无辟支佛阿罗汉阿那含斯陀含须陀洹。三恶趣及三界亦无断时。须菩提。汝所说。是菩萨摩诃萨当知如佛。如是如是。须菩提。当知是菩萨实如佛。何以故。以如故说如来。以如故说辟支佛阿罗汉一切贤圣。以如故说为色乃至识。以如故说一切法乃至有为性无为性。是诸如如实无异。以是故说名为如。诸菩萨摩诃萨学是如得一切种智得名如来。以是因缘故说菩萨摩诃萨当知如佛以如相故如是须菩提。菩萨摩诃萨应学如般若波罗蜜。菩萨学如般若波罗蜜则能学一切法如。学一切法如则得具足一切法如。具足一切法如已。住一切法如得自在。住一切法如得自在已。善知一切众生根。善知一切众生根已。知一切众生根具足。知一切众生根具足已。亦知一切众生业因缘。知一切众生业因缘已。得愿智具足。得愿智具足已净三世慧。净三世慧已饶益一切众生。饶益一切众生已净佛国土。净佛国土已得一切种智。得一切种智已。转法轮。转法轮已安立众生于三乘令入无余涅槃。如是须菩提。菩萨摩诃萨欲得一切功德自利利人。应发阿耨多罗三藐三菩提心。须菩提白佛言。世尊。是诸菩萨摩诃萨能如说行深般若波罗蜜。一切世间天及人阿修罗应当为作礼。佛告须菩提。如是如是。菩萨摩诃萨能如说行般若波罗蜜。一切世间天及人阿修罗应当为作礼。世尊。是初发意菩萨摩诃萨为众生故求阿耨多罗三藐三菩提。得几所福德。佛告须菩提。若千世界中众生皆发声闻辟支佛意。于汝意云何其福多不。须菩提言。甚多无量。佛告须菩提。其福不如初发意菩萨摩诃萨百倍千倍巨亿万倍。乃至算数譬喻所不能及。何以故。发声闻辟支佛意者。皆因菩萨出故。菩萨终不因声闻辟支佛出二千世界三千大千世界中亦如是。置是三千大千世界中发意求声闻辟支佛者。若三千大千世界中众生皆住干慧地其福多不。须菩提言。甚多无量。佛言。不如初发意菩萨百倍千倍巨亿万倍。乃至算数譬喻所不能及。置是住干慧地众生。若三千大千世界中众生。皆住性地八人地见地薄地离欲地已辨地辟支佛地。是一切福德欲比初发意菩萨百倍千倍巨亿万倍。乃至算数譬喻所不能及。须菩提。若三千大千世界中初发意菩萨。不如入法位菩萨百倍千倍巨亿万倍。乃至算数譬喻所不能及。若三千大千世界中入法位菩萨。不如向佛道菩萨百千万倍巨亿万倍。乃至算数譬喻所不能及。若三千大千世界中向佛道菩萨。不如佛功德百千万倍巨亿万倍乃至算数譬喻所不能及。须菩提白佛言。世尊。初发心菩萨摩诃萨当念何等法。佛言。应念一切种智。须菩提言。何等是一切种智。一切种智何等缘。何等增上。何等行。何等相佛告须菩提。一切种智。无所有无念无生无示。如须菩提所问。一切种智何等缘。何等增上。何等行。何等相。须菩提。一切种智无法缘。念为增上。寂灭为行无相为相。须菩提。是名一切种智缘增上行相。须菩提白佛言。世尊。但一切种智无法。色受想行识亦无法。内外法亦无法。四禅四无量心四无色定四念处。四正勤四如意足五根五力七觉分八圣道分。空三昧无相三昧无作三昧。八背舍九次第定。佛十力四无所畏四无碍智十八不共法。大慈大悲大喜大舍。初神通第二第三第四第五第六神通。有为相无为相亦无法。佛告须菩提。色亦无法乃至有为相无为相亦无法。须菩提言。世尊。何因缘故。一切种智无法。色无法乃至有为无为相亦无法。佛言。一切种智自性无故。若法自性无是名无法。色乃至有为无为相亦如是世尊。何因缘故。诸法自性无。佛言。诸法和合因缘生法中无自性。若无自性是名无法。以是故。须菩提。菩萨摩诃萨当知一切法无性。何以故。一切法性空故。以是故。当知一切法无性。须菩提白佛言。世尊。若一切法无性。初发意菩萨以何等方便力。能行檀那波罗蜜净佛国土成就众生。能行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。行初禅乃至第四禅。行慈心乃至舍心。行空处乃至非有想非无想处。内空乃至无法有法空。四念处乃至八圣道分。空三昧无相三昧。无作三昧八背舍九次第定。佛十力四无所畏。四无碍智十八不共法大慈大悲。能行一切种智净佛国土成就众生。佛告须菩提。菩萨摩诃萨能学诸法无性。亦能净佛国土成就众生。知国土众生亦无性。即是方便力。须菩提。是菩萨摩诃萨行檀那波罗蜜修学佛道。行尸罗波罗蜜修学佛道。行羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜修学佛道。乃至行一切种智修学佛道。亦知佛道无性。是菩萨摩诃萨。行六波罗蜜修学佛道。乃至未成就佛十力四无所畏四无碍智。十八不共法大慈大悲一切种智。是为修学佛道。能具足是佛道因缘已。以一念相应慧得一切种智。尔时一切烦恼习永尽以不生故。是时以佛眼观三千大千世界。无法尚不可得何况有法。如是须菩提。菩萨摩诃萨应行无性般若波罗蜜。须菩提。是名菩萨摩诃萨方便力。无法尚不可得何况有法。须菩提。是菩萨摩诃萨若布施时。布施无法尚不可知何况有法。受者及菩萨心。无法尚不可知何况有法。乃至一切种智得者得法得处。无法尚不可知何况有法。何以故。一切法本性尔。非佛作非声闻辟支佛作。亦非余人作。一切法无作者故。须菩提白佛言。世尊。诸法诸法性离耶。佛言。如是如是。诸法诸法性离。世尊。若诸法诸法性离。云何离法能知离法若有若无。何以故。无法不能知无法。有法不能知有法。无法不能知有法。有法不能知无法。世尊。如是一切法无所有相。云何菩萨摩诃萨作是分别。是法若有若无。佛言。菩萨摩诃萨以世谛故。示众生若有若无。非以第一义。世尊。世谛第一义谛有异耶。须菩提。世谛第一义谛无异也。何以故。世谛如。即是第一义谛如。以众生不知不见是如故。菩萨摩诃萨以世谛示若有若无。复次须菩提。众生于五受阴中有着相故。不知无所有为是众生故示若有若无。令知清净无所有。如是须菩提菩萨摩诃萨应当作是行般若波罗蜜

    摩诃般若波罗蜜经道行品第七十二

须菩提白佛言。世尊。世尊说菩萨行。何等是菩萨行。佛言。菩萨行者。为阿耨多罗三藐三菩提行。是名菩萨行。世尊。云何菩萨摩诃萨为阿耨多罗三藐三菩提行。是名菩萨行。佛言。若菩萨摩诃萨行色空。行受想行识空。行眼空乃至意。行色空乃至法。行眼界空乃至意识界。行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。行内空行外空。行内外空行空空。行大空第一义空有为空无为空毕竟空无始空散空诸法空性空自相空无法空有法空无法有法空。行初禅第二第三第四禅。行慈悲喜舍。行无量虚空处无量识处无所有处非有想非无想处。行四念处四正勤四如意足五根五力七觉分八圣道分。行空三昧。行无相三昧。行无作三昧。行八背舍九次第定。行佛十力。行四无所畏。行四无碍智行十八不共法。行大慈大悲。行净佛国土。行成就众生。行诸辩才。行文字入无文字。行诸陀罗尼门。行有为性行无为性。如阿耨多罗三藐三菩提不作二。如是须菩提。菩萨摩诃萨行般若波罗蜜。名为阿耨多罗三藐三菩提行。是名菩萨行。须菩提白佛言。世尊。说言佛何义故名佛。佛告须菩提。知诸法实义故名为佛。复次得诸法实相故名为佛。复次通达实义故名为佛。复次如实知一切法故名为佛。须菩提言。何义故名菩提。须菩提。空义是菩提义。如义法性实际义是菩提义。复次须菩提。名相言说是菩提义。菩提实义不可坏。不可分别是菩提义。复次须菩提。诸法实相不诳不异。是菩提义。以是故名菩提。复次须菩提。是菩提是诸佛所有故名菩提。复次须菩提。诸佛正遍知故名菩提。须菩提白佛言。世尊。若菩萨摩诃萨。为是菩提行六波罗蜜。乃至行一切种智。于诸法何得何失何增何减。何生何灭何垢何净。佛告须菩提。若菩萨摩诃萨为菩提行六波罗蜜。乃至行一切种智。于诸法无得无失无增无减。无生无灭无垢无净。何以故。菩萨摩诃萨行般若波罗蜜。不为得失增减生灭垢净故出。须菩提言。世尊。若菩萨摩诃萨行般若波罗蜜。若不为得失乃至不为净垢故出。菩萨摩诃萨。云何行般若波罗蜜。能取檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。云何行内空乃至无法有法空。云何行禅无量心无色定。云何行四念处乃至八圣道分。云何行空无相无作解说门。云何行佛十力四无所畏四无碍智十八不共法大慈大悲。云何行菩萨十地。云何过声闻辟支佛地入菩萨位中。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不以二法故行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。不以二法乃至行一切种智。须菩提言。世尊。若菩萨摩诃萨。不以二法故行檀那波罗蜜乃至般若波罗蜜。不以二法故乃至行一切种智。菩萨从初发意乃至后意。云何善根增益。佛告须菩提。若行二法者善根不得增益。何以故。一切凡夫人皆依二法。不得增益善根。菩萨摩诃萨行不二法。从初发意乃至后意。于其中间增益善根。以是故。菩萨摩诃萨。一切世间天及人阿修罗无能伏。无能坏其善根令堕声闻辟支佛地。及诸众恶不善法。不能制菩萨令不能行檀那波罗蜜增益善根乃至般若波罗蜜亦如是。须菩提。菩萨摩诃萨应如是行般若波罗蜜。世尊。菩萨摩诃萨为善根故行般若波罗蜜不。佛言不也。须菩提。菩萨亦不为善根故行般若波罗蜜。亦不为非善根故行般若波罗蜜。何以故。须菩提。菩萨摩诃萨法未供养诸佛。未具足善根。未得真知识。不能得一切种智。须菩提言。世尊。云何菩萨摩诃萨。供养诸佛具足善根。得真知识。能得一切种智。佛告须菩提。菩萨摩诃萨从初发意供养诸佛。诸佛所说十二部经修妒路乃至忧波提舍。是菩萨闻持诵利心观了达。了达故得陀罗尼。得陀罗尼故能起无碍智。起无碍智故所生处乃至萨婆若终不忘失。亦于诸佛所种善根。为是善根所护终不堕恶道诸难。以是善根因缘故得深心清净。得深心清净故能净佛国土成就众生。以善根所护故常不离真知识。所谓诸佛诸菩萨摩诃萨。及诸声闻能赞叹佛法众者。如是须菩提。菩萨摩诃萨。应供养诸佛种善根亲近善知识

    摩诃般若波罗蜜经三善品第七十三(丹本种善根品)

须菩提白佛言。世尊。菩萨摩诃萨若不供养诸佛。不具足善根。不得真知识。当得萨婆若不。佛告须菩提。菩萨摩诃萨供养诸佛种善根得真知识。一切种智尚难得。何况不供养诸佛不种善根不得真知识。须菩提白佛言。世尊。菩萨摩诃萨供养诸佛种善根得真知识。何以故。不能得一切种智。佛告须菩提。是菩萨摩诃萨远离方便力。不从诸佛闻方便力。所种善根不具足。不常随善知识教。世尊。何等是方便力。菩萨摩诃萨行是方便力。得一切种智。佛言。菩萨摩诃萨从初发意。行檀那波罗蜜应萨婆若念。布施佛若辟支佛若声闻若人若非人。是时不生布施想受者想。何以故。观一切法自相空无生无定相。无所转入诸法实相。所谓一切法。无作无起相。菩萨以是方便力故增益善根。增益善根故行檀那波罗蜜。净佛国土成就众生。布施不受世间果报。但欲救度一切众生故行檀那波罗蜜。复次须菩提。菩萨摩诃萨从初发意。行尸罗波罗蜜应萨婆若念。持戒时不堕淫怒痴中。亦不堕诸烦恼缠缚及诸不善破道法。若悭贪破戒嗔恚。懈怠乱意愚痴慢大慢慢慢我慢增上慢不如慢邪慢。若声闻心若辟支佛心。何以故。是菩萨摩诃萨。观一切法自相空无生无定相。无所转入诸法实相。所谓一切法无作无起相。菩萨成就是方便力故增益善根。增益善根故行尸罗波罗蜜。净佛国土成就众生。持戒不受世间果报。但欲救度一切众生故行尸罗波罗蜜。复次须菩提。菩萨摩诃萨从初发意。行羼提波罗蜜应萨婆若念。方便力成就故行见谛道思惟道。亦不取须陀洹果斯陀含阿那含阿罗汉果。何以故。是菩萨摩诃萨知诸法自相空。无生无定相无所转。虽行是助道法。而过声闻辟支佛地。须菩提。是名菩萨无生法忍。复次须菩提。菩萨摩诃萨从初发意。行毗梨耶波罗蜜入初禅乃至入第四禅。入四无量心四无色定。虽出入诸禅而不受果报。何以故。是菩萨成就是方便力故。知诸禅定自相空无生无定相无所转。净佛国土成就众生精进不受世间果报。但欲救度一切众生故行毗梨耶波罗蜜。复次须菩提。菩萨摩诃萨从初发意。行禅那波罗蜜应萨婆若念。入八背舍九次第定。亦不证须陀洹果乃至不证阿罗汉果。何以故。是菩萨摩诃萨知诸法自相空无生无定相无所转。复次须菩提。菩萨摩诃萨从初发意。行般若波罗蜜。学佛十力四无所畏四无碍智十八不共法大慈大悲。乃至未得一切种智。未净佛国土。未成就众生。于其中间应如是学。何以故。是菩萨摩诃萨知诸法自相空无生无定相无所转。须菩提。菩萨摩诃萨应如是行般若波罗蜜。不受果报

    摩诃般若波罗蜜经遍学品第七十四

尔时须菩提白佛言。世尊。是菩萨摩诃萨。大智慧成就。行是深法亦不受果报。佛告须菩提。如是如是。菩萨摩诃萨。大智慧成就。行是深般若波罗蜜。亦不受果报。何以故。是菩萨摩诃萨。诸法性中不动故。世尊。何等诸法性中不动。佛言。于无所有性中不动。复次须菩提。菩萨摩诃萨。色性中不动。受想行识性中不动。檀那波罗蜜性中不动。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅那波罗蜜。般若波罗蜜性中不动。四禅性中不动。四无量性中不动。四无色定性中不动。四念处性中不动。乃至八圣道分性中不动。空三昧无相三昧无作三昧。乃至大慈大悲性中不动。何以故。须菩提。是诸法性即是无所有。须菩提。以无所有法。不能得所有法。须菩提言。世尊。所有法能得所有法不。佛言不也。世尊。所有法能得无所有法不。佛言不也。世尊。无所有法能得无所有法不。佛言不也。世尊。若无所有不能得所有。所有不能得所有。所有不能得无所有。无所有不能得无所有。将无世尊不得道耶。佛言有得。不以此四句。世尊云何有得。佛言。非所有。非无所有。无诸戏论是名得道。须菩提白佛言。世尊。何等是菩萨摩诃萨戏论。佛告须菩提。菩萨摩诃萨观色若常若无常。是为戏论。观受想行识若常若无常。是为戏论。观色若苦若乐受想行识若苦若乐。是为戏论。观色若我若非我。受想行识若我若非我色若寂灭若不寂灭受想行识若寂灭若不寂灭。是为戏论。苦圣谛应见。集圣谛应断。灭圣谛应证。道圣谛应修。是为戏论。应修四禅四无量心四无色定。是为戏论。应修四念处四正勤四如意足五根五力七觉分八圣道分。是为戏论。应修空解脱门无相解脱门无作解脱门。是为戏论。应修八背舍九次第定。是为戏论。我当过须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。是为戏论。我当具足菩萨十地。是为戏论。我当入菩萨位。是为戏论。我当净佛国土。是为戏论。我当成就众生是为戏论。我当生佛十力四无所畏四无碍智十八不共法。是为戏论。我当得一切种智。是为戏论。我当断一切烦恼习。是为戏论。须菩提。是菩萨摩诃萨行般若波罗蜜时。色若常若无常。不可戏论故不戏论。受想行识若常若无常。不可戏论故不戏论。乃至一切种智。不可戏论故不戏论。何以故。性不戏论性。无性不戏论无性。离性无性更无法可得所谓戏论者戏论法戏论处。以是故。须菩提。色无戏论。受想行识乃至一切种智无戏论。如是须菩提。菩萨摩诃萨应行无戏论般若波罗蜜。须菩提白佛言。世尊。云何色不可戏论。乃至一切种智不可戏论。佛告须菩提。色性无乃至一切种智性无。须菩提。若法性无。即是无戏论。以是故色不可戏论。乃至一切种智不可戏论。须菩提。若菩萨摩诃萨能如是行无戏论般若波罗蜜。是时得入菩萨位。须菩提白佛言。世尊。若诸法无有性。菩萨行何等道入菩萨位。为用声闻道。为用辟支佛道。为用佛道。佛告须菩提。不以声闻道不以辟支佛道不以佛道。得入菩萨位。菩萨摩诃萨遍学诸道得入菩萨位。须菩提。譬如八人先学诸道然后入正位。未得果而先生果道。菩萨亦如是。先遍学诸道然后入菩萨位。亦未得一切种智而先生金刚三昧。尔时以一念相应慧。得一切种智。须菩提白佛言。世尊。若菩萨摩诃萨遍学诸道入菩萨位者。八人向须陀洹得须陀洹。向斯陀含得斯陀含。向阿那含得阿那含。向阿罗汉得阿罗汉。辟支佛道佛道。是诸道各各异。世尊。若菩萨摩诃萨遍学诸道然后入菩萨位者是菩萨若生八道应作八人。生见道应作须陀洹。生思惟道应作斯陀含。作阿那含。作阿罗汉。若生辟支佛道作辟支佛。世尊。若菩萨摩诃萨作八人然后入菩萨位无有是处。不入菩萨位得一切种智亦无是处。作须陀洹乃至作辟支佛。然后入菩萨位亦无是处。不入菩萨位得一切种智亦无是处。世尊。我云何当知菩萨摩诃萨。遍学诸道得入菩萨位。佛告须菩提。如是如是。若菩萨摩诃萨作八人得须陀洹果。乃至得阿罗汉果得辟支佛道。然后入菩萨位无有是处。不入菩萨位当得一切种智无有是处。须菩提。若菩萨摩诃萨从初发意。行六波罗蜜时。以智观过八地。何等八地干慧地性地八人地见地薄地离欲地已办地辟支佛地。直过以道种智入菩萨位。入菩萨位已以一切种智断一切烦恼习。须菩提。是八人若智若断。是菩萨无生法忍。须陀洹若智若断。斯陀含若智若断。阿那含若智若断。阿罗汉若智若断。辟支佛若智若断。皆是菩萨无生忍。菩萨学如是声闻辟支佛道。以道种智入菩萨位。入菩萨位已以一切种智断一切烦恼习得佛道。如是须菩提。菩萨摩诃萨遍学诸道具足。应得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。以果饶益众生。须菩提白佛言。世尊。世尊所说道。声闻道辟支佛道佛道。何等是菩萨道种智。佛告须菩提。菩萨摩诃萨应生一切道种净智。须菩提。何等是道种净智。若诸法相貌所可显示法。菩萨应正知。正知已为他演说开示。令诸众生得解。是菩萨摩诃萨应解一切音声语言。以是音声说法。遍满三千大千世界。如响相以是故须菩提。菩萨摩诃萨应先具足学一切道。道智具足已。应分别知众生深心。所谓地狱众生。地狱道地狱因地狱果应知应障。畜生饿鬼道。畜生饿鬼因畜生饿鬼果应知应障。诸龙鬼神犍闼婆紧陀罗摩睺罗伽阿修罗道因果。应知应障。人道因果应知。诸天道因果应知。四天王天三十三天夜摩天兜率陀天化乐天他化自在天梵天光音天遍净天广果天无想天阿婆罗呵天无热天易见天喜见天阿迦尼吒天道。因果应知。无边虚空处无边识处无所有处非有想非无想处道。因果应知。四念处四正勤四如意足五根五力七觉分八圣道分。因果应知。空解脱门无相解脱门无作解脱门佛十力四无所畏四无碍智十八不共法大慈大悲。因果应知。菩萨以是道令众生入须陀洹道。乃至阿罗汉。辟支佛道。乃至阿耨多罗三藐三菩提道。须菩提。是名菩萨摩诃萨净道种智。菩萨学是道种智已。入众生深心相。入已随众生心如应说法所言不虚。何以故。是菩萨摩诃萨善知众生根相。知一切众生心心数法生死所趣。须菩提。菩萨摩诃萨如是应行般若波罗蜜。何以故。一切诸助善道法。皆入般若波罗蜜中。诸菩萨摩诃萨。声闻辟支佛所应行。须菩提白佛言。世尊。若四念处乃至阿耨多罗三藐三菩提。是一切法皆不合不散。无色无形无对一相。所谓无相。世尊。云何是助道法能取阿耨多罗三藐三菩提。世尊。是不合不散无色无形无对一相。所谓无相法无所取无所舍。譬如虚空无取无舍。佛言。如是如是。须菩提。诸法自相空。无所取无所舍。须菩提。有众生不知诸法自相空。为是众生故显示助道法。令至阿耨多罗三藐三菩提。复次须菩提。所有色受想行识。所有檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜。般若波罗蜜。所有内空外空乃至无法有法空。初禅乃至非有想非无想处。四念处乃至八圣道分三解脱门。八背舍九次第定。佛十力四无所畏。四无碍智十八不共法。大慈大悲一切种智等诸法。于是圣法中皆不合不散。无色无形无对一相。所谓无相。以世俗法故为众生说令解。非以第一义。须菩提。于是一切法中。菩萨摩诃萨以智见如法应学。学已分别诸法应用。不应用。须菩提言。世尊。何等法菩萨分别已应用。不应用。佛言。声闻辟支佛法分别知不应用。一切种智分别知应用。如是须菩提。菩萨摩诃萨。于是圣法中应学般若波罗蜜。须菩提白佛言。世尊。何以故。说名圣法。何等是圣法。佛告须菩提。诸声闻辟支佛法。诸菩萨摩诃萨及诸佛。于欲嗔痴不合不散。身见戒取疑不合不散。欲染嗔恚不合不散。色染无色染悼慢无明不合不散。初禅乃至第四禅不合不散。慈悲喜舍虚空处乃至非有想非无想处不合不散。四念处乃至八圣道分不合不散。内空乃至大悲有为性无为性不合不散。何以故。是一切法皆无色无形无对一相。所谓无相。无色法与无色法不合不散。无形法与无形法不合不散。无碍法与无碍法不合不散。一相法与一相法不合不散。无相法与无相法不合不散。须菩提。是无色无形无碍一相。所谓无相。般若波罗蜜诸菩萨摩诃萨应学。学已不得诸法相。须菩提白佛言。世尊。菩萨摩诃萨不学色相耶。不学受想行识相耶。不学眼相乃至意相。不学色相乃至法相。不学地种相乃至识种相。不学檀那波罗蜜相尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜相。不学内空乃至无法有法空。不学初禅相乃至第四禅相。不学慈相乃至舍相。不学无边空相乃至非有想非无想相。不学四念处相乃至八圣道分相。不学空三昧相无相无作三昧相。不学八背舍九次第定相。不学佛十力相四无所畏相四无碍智相十八不共法相大慈大悲相。不学苦圣谛相集灭道圣谛相。不学逆顺十二因缘相。不学有为性相无为性相耶。世尊。若不学诸法相。菩萨摩诃萨。云何学诸法相若有为若无为。学已过声闻辟支佛地。若不过声闻辟支佛地云何入菩萨位。若不入菩萨位云何当得一切种智。若不得一切种智云何当转法轮。若不转法轮云何以三乘度众生生死。佛告须菩提。若诸法实有相菩萨应学是相。须菩提。以一切法实无相无色无形无碍一相。所谓无相。以是故。须菩提。菩萨摩诃萨不学相不学无相。何以故。有佛无佛诸法一相性常住。须菩提白佛言。世尊。若一切法非有相非无相。菩萨摩诃萨云何修般若波罗蜜。若不修般若波罗蜜不能过声闻辟支佛地。若不过声闻辟支佛地不能入菩萨位。若不入菩萨位不得无生法忍。若不得无生法忍不能得诸菩萨神通。若不得菩萨神通不能净佛国土成就众生。若不净佛国土成就众生不能得一切种智。若不得一切种智不能转法轮。若不转法轮不能令众生得须陀洹果斯陀含阿那含阿罗汉果辟支佛道。不能令得阿耨多罗三藐三菩提。亦不能令众生得布施福。亦不能令得持戒修定福。佛告须菩提。如是如是。诸法无相非一相非异相。若修无相是修般若波罗蜜。须菩提言。世尊。云何修无相是修般若波罗蜜。佛言。修诸法坏是修般若波罗蜜。世尊。云何修诸法坏是修般若波罗蜜。佛言。修色坏是修般若波罗蜜。修受想行识坏。是修般若波罗蜜。修眼坏耳鼻舌身意法坏。是修般若波罗蜜。修色法坏声香味触法坏。是修般若波罗蜜。修不净观坏。是修般若波罗蜜。修初禅坏第二第三第四禅坏。是修般若波罗蜜。修慈悲喜舍坏。是修般若波罗蜜。修无边空处无边识处无所有处非有想非无想处坏。是修般若波罗蜜。修念佛念法念僧念戒念舍念天念灭念阿那般那坏。是修般若波罗蜜。修无常相苦相无我相空相。集相因相生相缘相。闭相灭相妙相出相。道相正相迹离相坏。是修般若波罗蜜修十二因缘坏。修我相众生寿命相坏。乃至修知者见者相坏。是修般若波罗蜜。修常相乐相净相我相坏。是修般若波罗蜜。修四念处乃至修八圣道分坏。是修般若波罗蜜。修空三昧无相三昧无作三昧坏。是修般若波罗蜜。修八背舍九次第定坏。是修般若波罗蜜。修有觉有观三昧。无觉有观三昧。无觉无观三昧坏。是修般若波罗蜜。修苦圣谛集圣谛灭圣谛道圣谛坏。是修般若波罗蜜。修苦智集智灭智道智坏。是修般若波罗蜜。修尽智无生智坏。是修般若波罗蜜。修法智比智世智他心智坏。是修般若波罗蜜。修檀那波罗蜜坏。是修般若波罗蜜。修尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜坏。是修般若波罗蜜。修内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空诸法空自相空不可得空无法空有法空无法有法空坏。是修般若波罗蜜。修佛十力四无所畏四无碍智十八不共法坏。是修般若波罗蜜。修须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道坏。是修般若波罗蜜。修一切智坏。是修般若波罗蜜。修断一切烦恼习坏。是修般若波罗蜜。须菩提白佛言。世尊。云何名修色坏。乃至修断一切烦恼习坏。是修般若波罗蜜。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不念有色法。是修般若波罗蜜。不念有受想行识。乃至不念有断一切烦恼习法。是为修般若波罗蜜。何以故。有法念者。不修般若波罗蜜。须菩提。有法念者。不修檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。何以故。须菩提。是人着法不行檀那波罗蜜乃至般若波罗蜜。如是著者。无有解脱无有道无有涅槃。有法念者。不修四念处四正勤四如意足五根五力七觉分八圣道分。不修空三昧乃至不修一切种智。何以故。是人着法故。须菩提白佛言。世尊。何等是有法。何等是无法。佛告须菩提。二是有法。不二是无法。世尊。何等是二。佛言。色相是二。受想行识相是二。眼相乃至意相是二。色相乃至法相是二。檀那波罗蜜乃至佛相。阿耨多罗三藐三菩提相。有为无为性相是二。须菩提。一切相皆是二。一切二皆是有法。适有有法便有生死。适有生死不得离生老病死忧悲苦恼。以是因缘故。须菩提。当知二相者无有檀那波罗蜜乃至般若波罗蜜。无有道无有果。乃至无有顺忍。何况见色相乃至见一切种智相。若无修道云何得须陀洹果乃至阿罗汉果辟支佛道。阿耨多罗三藐三菩提及断一切烦恼习

摩诃般若波罗蜜经卷第二十二摩诃般若波罗蜜经卷第二十三

        后秦龟兹国三藏鸠摩罗什译

    三次品第七十五(丹本次第行品)

尔时须菩提白佛言。世尊。若有法相者。尚不得顺忍何况得道。世尊。若无法相者当得顺忍不。若干慧地若性地若八人地若见地若薄地若离欲地若已办地。若辟支佛地若菩萨地若佛地。若修道因是修道当断烦恼不。以是烦恼故不得过声闻辟支佛地入菩萨位。若不入菩萨位则不得一切种智不得一切种智则不能得断一切烦恼习。世尊。若无有法相。是诸法则不生。若不生是诸法。则不能得一切种智。佛告须菩提。如是如是。若无有法者则有顺忍。乃至断一切烦恼习。须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜时有法相不。所谓色相乃至识相。眼相乃至意相。色相乃至法相。眼界相乃至意识界相。四念处相乃至一切种智相。若色相若色断相。乃至识相识断相。十二入十八界亦如是。若无明相若无明断相。乃至忧悲愁恼相。忧悲愁恼断相。若欲相若欲断相。若嗔相若嗔断相。若痴相若痴断相。若苦相若苦断相。若集相若集断相。若尽相若尽断相。若道相若道断相。乃至一切种智相。断一切烦恼习相。佛言。不也须菩提。菩萨摩诃萨行般若波罗蜜时。无有法相非法相。即是菩萨顺忍。若无有法相无有非法相。即是修道。亦是道果。须菩提。菩萨摩诃萨有法是菩萨道。无法是菩萨果。以是因缘故。当知一切法无所有性。须菩提白佛言。世尊。若一切法无所有性。佛云何知一切法。无所有性故得成佛。于一切法得自在力。佛告须菩提。如是如是。一切法无所有性。我本行菩萨道修六波罗蜜离诸欲。离恶不善法。有觉有观。离生喜乐。入初禅乃至入第四禅。于是诸禅及支不取相。不念有是禅不受禅味不得是禅。无染清净行四禅。我于是诸禅不受果报。依四禅住起五神通。身通天耳知他人心宿命通天眼通。于诸神通不取相。不念有是神通。不受神通味。不得是神通。我于是五神通不分别行。须菩提。我尔时用一念相应慧得阿耨多罗三藐三菩提。所谓是苦圣谛是集是灭是道圣谛。成就十力四无所畏四无碍智十八不共法大慈大悲得作佛。分别三聚众生正定邪定不定

须菩提白佛言。云何世尊。于诸法无所有性中起四禅六神通。亦无众生而分别作三聚。佛告须菩提。若诸欲恶不善法。若有性若自性若他性我本为菩萨行时。不能观诸欲恶不善法无所有性入初禅。以诸欲恶不善法无有性若自性若他性皆是无所有性故。我本行菩萨道时。离诸欲恶不善法。入初禅乃至入第四禅。须菩提。若诸神通有性若自性若他性。我不能知是神通无所有性。得阿耨多罗三藐三菩提。须菩提。以神通无有性若自性若他性皆是无所有性。以是故。诸佛于神通知无所有性。得阿耨多罗三藐三菩提。须菩提言。世尊。若菩萨摩诃萨知诸法无所有性。因四禅五神通。得阿耨多罗三藐三菩提。世尊。新学菩萨摩诃萨。云何于诸法无所有性中。次第行次第学次第道。以是次第行次第学次第道。得阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨若初从诸佛闻。若从多供养诸佛菩萨闻。若诸阿罗汉若诸阿那含若诸斯陀含若诸须陀洹所闻。得无所有故是佛。得无所有故。是阿罗汉阿那含斯陀含须陀洹。一切贤圣皆以得无所有故有名。一切有为作法无所有性。乃至无有如毫末许所有。是菩萨摩诃萨闻是已作是念。若一切法无有性。得无所有性故是佛。乃至得无所有性故是须陀洹。我若当得阿耨多罗三藐三菩提。若不得一切法常无有性。我何以不发心得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。一切众生行于有相。当令住无所有中。须菩提。菩萨摩诃萨如是思惟已。发阿耨多罗三藐三菩提心。为度一切众生故。菩萨摩诃萨所行。次第行次第学次第道者。如过去诸菩萨摩诃萨所行道。得阿耨多罗三藐三菩提。是新发意菩萨应学六波罗蜜。所谓檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。是菩萨摩诃萨若行檀那波罗蜜时。自行布施亦教人布施。赞叹布施功德。欢喜赞叹行布施者。以是布施因缘故得大财富。是菩萨远离悭心。布施众生食饮衣服香华璎珞房舍卧具灯烛种种资生所须尽给与之。菩萨摩诃萨行是布施及持戒。生天人中得大尊贵。以是持戒布施故得禅定众。以是布施持戒禅定故得智慧众解脱众解脱知见众。是菩萨因是布施持戒禅定众智慧众解脱众解脱知见众故。过声闻辟支佛地入菩萨位。入菩萨位已得净佛国土成就众生得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生生死。如是须菩提。菩萨以是布施次第行次第学次第道。是事皆不可得。何以故。自性无所有故。复次须菩提。菩萨摩诃萨从初发意以来。自行持戒教人持戒。赞叹持戒功德。欢喜赞叹行持戒者。持戒及布施因缘故。生天人中得大尊贵。见贫穷者施以财物。不持戒者教令持戒。乱意者教令禅定。愚痴者教令智慧。无解脱者教令解脱。无解脱知见者。教令解脱知见。以是持戒禅定智慧解脱解脱知见故。过声闻辟支佛地入菩萨位。入菩萨位。已得净佛国土。净佛国土已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生。如是须菩提。菩萨以是持戒。次第行次第学次第道。是事皆不可得。何以故。一切法自性无所有故。复次须菩提。菩萨摩诃萨从初已来。自行羼提波罗蜜教人行羼提。赞叹羼提功德。欢喜赞叹行羼提者。行羼提波罗蜜时。布施众生各令满足。教令持戒教令禅定乃至解脱知见。以是布施持戒禅定智慧因缘故。过阿罗汉辟支佛地入菩萨位中。入菩萨位中已得净佛国土。得净佛国土已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生生死。如是须菩提。菩萨以羼提波罗蜜。次第行次第学次第道。是事皆不可得。何以故。一切法自性无所有故。复次须菩提。菩萨摩诃萨从初已来。自行毗梨耶教人行毗梨耶。赞叹行毗梨耶功德。欢喜赞叹行毗梨耶者。乃至是事皆不可得。自性无所有故。复次须菩提。菩萨摩诃萨从初已来。自入禅入无量心入无色定。亦教人入禅入无量心入无色定。赞叹入禅入无量心入无色定功德。欢喜赞叹行禅无量心无色定者。是菩萨住诸禅定无量心。布施众生各令满足。教令持戒教令禅定智慧。以是布施禅定智慧解脱解脱知见因缘故。过声闻辟支佛地入菩萨位。入菩萨位已净佛国土。净佛国土已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱一切众生。乃至是事皆不可得。自性无所有故。复次须菩提。菩萨摩诃萨从初以来。行般若波罗蜜布施众生各令满足。教令持戒禅定智慧解脱解脱知见。是菩萨行般若波罗蜜时自行六波罗蜜。亦教他人令行六波罗蜜。赞叹六波罗蜜功德。欢喜赞叹行六波罗蜜者。是菩萨以是檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜因缘及方便力。过声闻辟支佛地入菩萨位乃至是事不可得。自性无所有故。须菩提。是名初发意菩萨摩诃萨次第行次第学次第道。复次须菩提。菩萨摩诃萨次第行次第学次第道。菩萨摩诃萨从初已来。以一切种智相应心。信解诸法无所有性修六念。所谓念佛念法念僧念戒念舍念天。须菩提。云何菩萨摩诃萨修念佛。菩萨摩诃萨念佛。不以色念。不以受想行识念。何以故。是色自性无。受想行识自性无。若法自性无。是为无所有。何以故。无忆故。是为念佛。复次须菩提。菩萨摩诃萨念佛。不以三十二相念。亦不念金色身。不念丈光不念八十随形好何以故。是佛身自性无故。若法无性是为无所有。何以故。无忆故是为念佛。复次须菩提。不应以戒众念佛。不应以定众智慧众解脱众解脱知见众念佛。何以故。是众无有自性。若法无自性是为无所有。何以故。无忆故是为念佛。复次须菩提。不应以十力念佛。不应以四无所畏四无碍智十八不共法念佛。不应以大慈大悲念佛。何以故是诸法自性无。若法自性无是为非法。无所念是为念佛。复次须菩提。不应以十二因缘法念佛。何以故。是因缘法自性无。若法自性无是为非法无所念是为念佛。如是须菩提。菩萨摩诃萨行般若波罗蜜时应念佛。是为菩萨初发意次第行次第学次第道。是菩萨摩诃萨次第行次第学次第道中住。能具足四念处四正勤四如意足五根五力七觉分八圣道分。修行空三昧无相无作三昧。乃至一切种智。诸法性无所有故。是菩萨知诸法性无所有。是中无有性无无性。须菩提。云何菩萨摩诃萨应修念法。须菩提。菩萨摩诃萨行般若波罗蜜时。不念善法不念不善法。不念有记法。不念无记法。不念世间法。不念出世间法。不念净法不念不净法。不念圣法不念凡夫法。不念有漏法不念无漏法。不念欲界系法色界系法无色界系法。不念有为法无为法。何以故。是诸法自性无。若法自性无是为非法无所念是为念法。念法中学无所有性故。乃至当得一切种智。是菩萨得阿耨多罗三藐三菩提时。得诸法无所有性。是无所有性中非有相非无相。如是须菩提。菩萨摩诃萨应修念法。于是法中乃至无少许念何况念法。须菩提。菩萨摩诃萨。云何应修念僧。须菩提。菩萨摩诃萨念僧无为法故。分别有佛弟子众。是中乃至无少许念何况念僧。如是菩萨摩诃萨应念僧。须菩提。菩萨摩诃萨云何应修念戒。须菩提。菩萨摩诃萨从初发意已来。应念圣戒。无缺戒无隙戒。无瑕戒无浊戒无著戒自在戒。智者所赞戒。具足戒随定戒。应念是戒无所有性。乃至无少许念何况念戒。须菩提。菩萨摩诃萨从初发意已来应念舍。若自念舍若念他舍。若舍财若舍法。若舍烦恼。观是舍不可得故。乃至无少许念何况念舍。如是须菩提。菩萨摩诃萨应念舍。须菩提。云何菩萨摩诃萨应念天。须菩提。菩萨作是念。四天王诸天所有信戒施闻慧。此间命终生彼天处。我亦有是信戒施闻慧。乃至他化自在天所有信戒施闻慧。此间命终生彼天处。我亦有是信戒施闻慧。如是须菩提。菩萨摩诃萨应念是天。无所有性中尚无少许念何况念天。须菩提。菩萨摩诃萨行是六念。是名次第行次第学次第道。尔时须菩提白佛言。世尊。若一切法无所有性。所谓念色乃至识眼乃至意色乃至法。眼界乃至意识界是无所有性。檀那波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至八圣道分。佛十力乃至一切种智。是无所有性。世尊。若一切法无所有性者。是则无道无智无果。佛告须菩提。汝见是色性实有不。乃至一切种智性实有不。须菩提言。不见也世尊。佛告须菩提。汝若不见诸法实有。云何作是问。须菩提言。世尊。我于是法不敢有疑。但为当来世诸比丘求声闻辟支佛道菩萨道者。是人当如是言。若一切法无所有性。谁垢谁净谁缚谁解。是不知不解故。而破于戒破正见。破威仪破净命。是人破此事故当堕三恶道。世尊。我畏当来世有如是事。以是故问佛世尊。我于是法中信不疑不悔

    摩诃般若波罗蜜经一念品第七十六(丹无漏行六度品)

须菩提白佛言。世尊。若一切法性无所有。菩萨见何等利益故。为众生发阿耨多罗三藐三菩提。佛告须菩提。以一切法性无所有故。菩萨以是故为众生求阿耨多罗三藐三菩提。何以故。须菩提。诸有得有著者难可解脱。须菩提。诸得相者。无有道无有果无阿耨多罗三藐三菩提。须菩提白佛言。世尊。无得相者。有道有果有阿耨多罗三藐三菩提不须菩提。无所得即是道即是果。即是阿耨多罗三藐三菩提。法性不坏故。若无所得法欲得道欲得果。欲得阿耨多罗三藐三菩提。为欲坏法性。须菩提白佛言。世尊。若无所得法。即是道即是果。即是阿耨多罗三藐三菩提云何有菩萨初地乃至十地。云何有无生法忍。云何有报得神通。云何有报得布施持戒忍辱精进禅定智慧。住是果报法中能成就众生能净佛国土。及供养诸佛衣服饮食香华璎珞房舍卧具灯烛。种种资生所须之具。乃至得阿耨多罗三藐三菩提。不断是福德。乃至般涅槃后舍利及弟子得供养。尔乃灭尽。佛告须菩提。以诸法无所得相故。得菩萨初地乃至十地。有报得神通布施持戒忍辱精进禅定智慧。成就众生净佛国土。亦以善根因缘故能利益众生。乃至般涅槃后舍利及弟子得供养。须菩提白佛言。世尊。若诸法无所得相。布施持戒忍辱精进禅定智慧诸神通有何差别。佛告须菩提。无所得法布施持戒忍辱精进禅定智慧神通无有差别。以众生着布施乃至神通故分别说。世尊。云何无所得法布施乃至神通无有差别。须菩提。菩萨摩诃萨行般若波罗蜜时。不得布施施者受者。皆不可得而行布施。不得戒而持戒。不得忍而行忍。不得精进而行精进。不得禅而行禅。不得智慧而行智慧。不得神通而行神通。不得四念处而行四念处。乃至不得八圣道分而行八圣道分。不得空三昧无相无作三昧而行空无相无作三昧。不得众生而成就众生。不得净佛国土而净净国土。不得诸佛法而得阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨应如是行无所得般若波罗蜜。菩萨摩诃萨行是无所得般若波罗蜜时。魔若魔天不能破坏

须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜时。一念中具足六波罗蜜。四禅四无量心四无色定。四念处四正勤四如意足五根五力七觉分八圣道分。三解脱门佛十力四无所畏四无碍智。十八不共法大慈大悲。三十二相八十随形好。佛告须菩提。菩萨摩诃萨所有布施。不远离般若波罗蜜。所修持戒戒忍辱精进禅定不远离般若波罗蜜。四禅四无量心四无色定修四念处乃至八十随形好不远离般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨不远离般若波罗蜜。一念中具足行六波罗蜜乃至八十随形好。佛言。菩萨行般若波罗蜜时。所有布施不远离般若波罗蜜以不二相。持戒时亦不二相。修忍辱勤精进入禅定亦不二相。乃至八十随形好亦不二相。须菩提白佛言。世尊。云何菩萨摩诃萨布施时不二相。乃至修八十随形好不二相。须菩提。菩萨摩诃萨行般若波罗蜜时。欲具足檀那波罗蜜。檀那波罗蜜中摄诸波罗蜜及四念处乃至八十随形好。世尊。云何菩萨布施时摄诸无漏法。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。住无漏心布施。于无漏心中不见相。所谓谁施谁受所施何物。以是无相心无漏心。断爱断悭贪心而行布施。是时不见布施乃至不见阿耨多罗三藐三菩提法。是菩萨无相心无漏心。持戒不见是戒。乃至不见一切佛法。无相心无漏心。忍辱不见是忍辱。乃至不见一切佛法。以无相心无漏心。精进不见是精进。乃至不见一切佛法。以无相心无漏心。入禅定不见是禅定。乃至不见一切佛法。以无相心无漏心。修智慧不见是智慧。乃至不见一切佛法。以无相心无漏心。修四念处不见是四念处乃至八十随形好。世尊。若诸法无相无作。云何具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。云何具足四念处四正勤四如意足五根五力七觉分八圣道分。云何具足空三昧无相三昧无作三昧佛十力四无所畏四无碍智十八不共法大慈大悲。云何具足三十二相八十随形好。佛告须菩提。菩萨摩诃萨行般若波罗蜜。以无相心无漏心布施。须食与食。乃至种种所须尽给与之。若内若外若支解其身若国城妻子布施众生若有人来语菩萨言。何用是布施为是无所益行般若波罗蜜。菩萨作是念。是人虽来呵我布施我终不悔。我当勤行布施不应不与。施已与一切众生共之回向阿耨多罗三藐三菩提。亦不见是相谁施谁受所施何物。回向者谁。何等是回向法。何等是回向处。所谓阿耨多罗三藐三菩提。是相皆不可见。何以故。一切法以内空故空。外空故空内外空故空。空空有为空无为空毕竟空无始空散空性空一切法空自相空故空。如是观作是念。回向者谁回向何处用何法回向。是名正回向。尔时菩萨能成就众生净佛国土。能具足檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。乃至三十七助道法空无相无作三昧。乃至十八不共法。是菩萨如是具足檀那波罗蜜。而不受世间果报。譬如他化自在诸天。随意所须即皆得之。菩萨亦如是。心生所愿随意即得。是菩萨摩诃萨。以是布施果报故能供养诸佛。亦能满足一切众生天及人阿修罗。是菩萨以檀那波罗蜜摄取众生。用方便力以三乘法度脱众生生死。如是须菩提。菩萨摩诃萨于无相无得无作诸法中具足檀那波罗蜜。须菩提。菩萨摩诃萨云何于无相无得无作法中具足尸罗波罗蜜。须菩提。是菩萨摩诃萨行尸罗波罗蜜时持种种戒。所谓圣无漏入八圣道分戒自然戒报得戒受得戒心生戒。如是等不缺不破。不杂不浊。不着自在戒智所赞戒。用是戒无所取若色若受想行识。若三十二相八十随形好。若刹利大姓若婆罗门大姓居士大家。若四天王天三十三天夜摩天兜率陀天化乐天他化自在天梵众天光音天遍净天广果天无想天无烦天无热天妙见天喜见天阿迦腻吒天。虚空处天识处天无所有处天非有想非无想处天。若须陀洹果若斯陀含果若阿那含果若阿罗汉果若辟支佛道若转轮圣王若天王。但为一切众生共之回向阿耨多罗三藐三菩提。以无相无得无二回向。为世俗法故非第一实义。是菩萨具足尸罗波罗蜜以方便力。起四禅不味着故得五神通。因四禅得天眼。是菩萨住二种天眼修得报得。得天眼已见东方现在诸佛。乃至得阿耨多罗三藐三菩提。如所见事不失。南西北方四维上下现在诸佛。乃至得阿耨多罗三藐三菩提。菩提。如所见不失。是菩萨用天耳净过于人耳。闻十方诸佛说法如所闻不失。能自饶益亦益他人。是菩萨以知他心智知十方诸佛心。及知一切众生心。亦能饶益一切众生。是菩萨用宿命智知过去诸业因缘。是业因缘不失故。是众生在在处处所生悉知是菩萨用是漏尽智。令众生得须陀洹果乃至阿罗汉果辟支佛道。在在处处皆令众生入善法中。如是须菩提。菩萨摩诃萨于诸法无相无得无作中具足。尸罗波罗蜜。世尊。云何诸法无相无作无得。菩萨摩诃萨能具足羼提波罗蜜。须菩提。菩萨摩诃萨从初发意以来乃至坐道场。于其中间。若一切众生来以瓦石刀杖加是菩萨。菩萨是时不起嗔心乃至不生一念。尔时菩萨应修二种忍。一者一切众生恶口骂詈若加刀杖瓦石。嗔心不起。二者一切法无生无生法忍。菩萨若人来恶口骂詈。或以瓦石刀杖加之尔时菩萨应如是思惟。骂我者谁讥诃者谁。谁打掷者谁有受者。即时菩萨应思惟诸法实性。所谓毕竟空。无法无众生。诸法尚不可得。何况有众生。如是观诸法相时。不见骂者不见割截者。是菩萨如是观诸法相时。即得无生法忍。云何名无生法忍。知诸法相常不生。诸烦恼从本以来亦常不生。是菩萨摩诃萨住是二忍。能具足四禅四无量心四无色定四念处乃至八圣道分。三解脱门佛十力四无所畏四无碍智十八不共法大慈大悲。是菩萨住是圣无漏出世间法。不共一切声闻辟支佛。具足圣神通。住圣神通已以天眼见东方诸佛。是人得念佛三昧。乃至阿耨多罗三藐三菩提终不断绝。南西北方四维上下亦复如是。是菩萨用天耳闻十方诸佛所说法如所闻为众生说。是菩萨亦知十方诸佛心。及知一切众生念。知已随其心而说法。是菩萨以宿命智。知一切众生宿世善根。为众生说法令其欢喜。是菩萨以漏尽神通。教化众生令得三乘。是菩萨摩诃萨行般若波罗蜜。以方便力成就众生具足一切种智。得阿耨多罗三藐三菩提转法轮。如是须菩提。菩萨摩诃萨无相无得无作法中具足羼提波罗蜜。须菩提言。世尊。菩萨摩诃萨云何于诸法无相无作无得法中能具足毗梨耶波罗蜜。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。成就身精进心精进。入初禅乃至入第四禅。受种种神通力。能分一身为多身。乃至手扪摸日月。成就身精进故。飞至东方过无量百千万诸佛世界。供养诸佛饮食衣服医药卧具华香璎珞种种所须。乃至阿耨多罗三藐三菩提。福德果报终不灭尽。是菩萨得阿耨多罗三藐三菩提时。一切世间天及人勤设供养衣服饮食。乃至入无余涅槃后。舍利及弟子得供养。亦以是神通力故。至诸佛所听受法教。乃至阿耨多罗三藐三菩提终不违失。是菩萨修一切种智时。净佛国土成就众生。如是须菩提。菩萨摩诃萨行般若波罗蜜。成就身精进能具足毗梨耶波罗蜜。须菩提。云何菩萨成就心精进能具足毗梨耶波罗蜜。须菩提。菩萨摩诃萨心精进以是心精进圣无漏入八圣道分。不令身口不善业得入。亦不取诸法相。若常若无常。若苦若乐。若我若无我。若有为若无为。若欲界若色界若无色界。若有漏性若无漏性。若初禅乃至第四禅。若慈悲喜舍。若无边虚空处乃至非有想非无想处。若四念处四正勤四如意足五根五力七觉分八圣道分。若空无相无作。若佛十力乃至十八不共法。不取相。若常若无常若苦若乐若我若无我。若须陀洹果若斯陀含果若阿那含果若阿罗汉果。若辟支佛道若菩萨道。若阿耨多罗三藐三菩提。若是须陀洹斯陀含阿那含阿罗汉。若是辟支佛是菩萨是佛。不取相。是众生断三结故得须陀洹。是众生三毒薄故得斯陀含。是众生断下分结故得阿那含。是众生断上分结故得阿罗汉。是众生以辟支佛道故作辟支佛。是众生行道种智故名菩萨。亦不取是诸法相。何以故。不可以性取相。是性无故。是菩萨以是心精进故。广利益众生。亦不得众生。是为菩萨具足毗梨耶波罗蜜具足诸佛法净佛国土成就众生。不可得故。是菩萨身精进心精进成就故。摄取一切诸善法。是法亦不着故。从一佛国至一佛国为利益众生。所作神通随意无碍。若雨诸华若散诸香若作伎乐。若动大地若放光明。若示七宝庄严国土。若现种种身若放大智光明令知圣道。令远离杀生乃至邪见。或以布施利益众生或以持戒。或以支解身体。或以妻子或以国土。或以己身给施。随所方便利益众生。如是须菩提。菩萨摩诃萨行般若波罗蜜。无相无作无得诸法中用身心精进。能具足毗梨耶波罗蜜。世尊。云何菩萨摩诃萨行般若波罗蜜。住无相无作无得法中能具足禅那波罗蜜。须菩提。菩萨摩诃萨除佛诸禅定。余一切诸禅三昧。皆能具足。是菩萨离诸欲诸恶不善法。离生喜乐有觉有观。入初禅乃至入第四禅。以是慈悲喜舍心。遍满一方乃至十方。一切世间遍满。是菩萨过一切色相灭有对相。不念别异相故入无边空处。乃至入非有想非无想处。是菩萨于禅那波罗蜜中住。逆顺入八背舍九次第定。入空三昧无相无作三昧。或时入无相三昧。或时入如电光三昧。或时入圣正三昧。或时入如金刚三昧。是菩萨住禅那波罗蜜中。修三十七助道法。用道种智入一切禅定。过干慧地性地八人地见地薄地离欲地已办地辟支佛地。入菩萨位。入菩萨位已具足佛地。是诸地中行乃至阿耨多罗三藐三菩提。不中道取道果。是菩萨住是禅那波罗蜜中。从一佛国至一佛国供养诸佛。从诸佛所殖诸善根净佛国土。从一国至一国利益众生。以布施摄取众生。或以持戒或以三昧。或以智慧或以解脱。或以解脱知见摄取众生。教众生令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。诸有善法能令众生得道皆教令得。是菩萨住此禅那波罗蜜中。能生一切陀罗尼门。得四无碍智报得诸神通。是菩萨终不入母人胞胎。终不受五欲无生不生。虽生不为生法所污。何以故。是菩萨见一切作法如幻而利益众生。亦不得众生及一切法。教众生令得无所得处。是世俗法故非第一实义。住是禅那波罗蜜一切行禅定解脱三昧。乃至阿耨多罗三藐三菩提。终不离禅那波罗蜜。是菩萨行如是道种智时。得一切种智断一切烦恼习。断已自益其身亦益他人。自益益他已。为一切世间天及人阿修罗作福田。如是须菩提。菩萨摩诃萨行般若波罗蜜时。能具足无相禅那波罗蜜。世尊。云何菩萨摩诃萨行般若波罗蜜时。住无相无作无得法中。修具足般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时。于诸法不见定实相。是菩萨见色不定非实相。乃至见识不定非实相。不见色生乃至不见识生。若不见色生乃至不见识生。一切法若有漏若无漏。不见来处不见去处亦不见集处。如是观时。不得色性乃至识性。亦不得有漏无漏法性。是菩萨行般若波罗蜜时。信解一切诸法无所有性。如是信解已行内空乃至无法有法空。于诸法无所著。若色若受想行识。乃至阿耨多罗三藐三菩提。是菩萨行无所有般若波罗蜜。能具足菩萨道。所谓六波罗蜜乃至三十七助道法。佛十力四无所畏四无碍智。十八不共法三十二相八十随形好。是菩萨住空净佛道中。所谓六波罗蜜三十七助道法。报得神通以是法饶益众生。宜以布施摄教令布施。宜以持戒摄教令持戒。宜以禅定智慧解脱解脱知见摄教令修禅定智慧解脱解脱知见。宜以诸道法教者。教令得须陀洹果得斯陀含果阿那含果阿罗汉果辟支佛道。宜以佛道化者。教令得菩萨道具足佛道。如是等随其所应道地。而教化之各令得所。是菩萨现种种神通力时。过无量恒河沙等国土度脱众生生死。随其所须皆供给之各各满足。从一国土至一国土。见净妙国土以自庄严己佛国土。譬如他化自在天中资生所须随意自至。亦如诸净佛国离于求欲。是人以是报得檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。报得五神通行菩萨道。道种智成就一切功德。当得阿耨多罗三藐三菩提。是菩萨尔时不受色法乃至识。不受一切法若善若不善。若世间若出世间。若有漏若无漏。若有为若无为。如是一切法皆不受。是菩萨得阿耨多罗三藐三菩提时。国土一切所有资生之物皆无有主。何以故。是菩萨行一切法不受。以不可得故。如是须菩提。菩萨摩诃萨无相法中能具足般若波罗蜜

    摩诃般若波罗蜜六喻品第七十七(丹梦化六度品)

须菩提白佛言。世尊。云何无相不可分别自相空。诸法中具足修六波罗蜜。所谓檀那波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。世尊。云何无异法中而分别说异相。云何般若波罗蜜摄檀尸羼精进禅。云何行异相法。以一相道得果。佛告须菩提。菩萨摩诃萨住五阴。如梦如响如影如焰如幻如化。住是中行布施持戒修忍辱勤精进入禅定修智慧。知是五阴实如梦如响如影如焰如幻如化五阴如梦无相乃至如化无相。何以故。梦无自性响影焰幻化皆无自性。若法无自性是法无相。若法无相是法一相。所谓无相。以是因缘故。须菩提。当知菩萨布施无相施者无相受者无相。能如是知布施。是能具足檀那波罗蜜。乃至能具足般若波罗蜜。能具足四念处乃至八圣道分。能具足内空乃至无法有法空。能具足空三昧无相无作三昧。能具足八背舍九次第定五神通五百陀罗尼门。能具足佛十力四无所畏四无碍智十八不共法。是菩萨住是报得无漏法中。飞到东方无量国土。供养诸佛衣服饮食。乃至随其所须而供养之。亦利益众生。应以布施摄者而布施摄之。应以持戒摄者教令持戒。应以忍辱精进禅定智慧摄者。教令忍辱精进禅定智慧而摄取之。乃至应以种种善法摄者。以种种善法而摄取之。是菩萨成就是一切善法。受世间身不为世间生死所污。为众生故于天上人中受尊贵富乐。以是尊贵富乐摄取众生。是菩萨以知一切法无相故。知须陀洹果亦不于中住。知斯陀含果阿那含果阿罗汉果亦不于中住。知辟支佛道亦不于中住。何以故。是菩萨用一切种智。知一切法已应当得一切种智。不与声闻辟支佛共。如是须菩提。菩萨摩诃萨知一切法无相已。知六波罗蜜无相。乃至知一切佛法无相。复次须菩提。是菩萨摩诃萨住五阴。如梦如响如影如焰如幻如化。能具足无相尸罗波罗蜜。具足戒不缺不破不杂不着。圣人所赞无漏戒入八圣道分。住是戒中持一切戒。所谓名字戒自然戒律仪戒。作戒无作戒。威仪戒非威仪戒。是菩萨摩诃萨成就诸戒。不作是愿。我以此戒因缘。故。生刹利大姓婆罗门大姓居士大家若小王家若转轮圣王家若四天王天处。生若三十三天夜摩天兜率陀天化乐天他化自在天。不作是愿。我持戒因缘故。当得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。何以故。一切法无相。所谓一相。无相法不能得无相法。有相法不能得有相法。无相法不能得有相法。有相法不能得无相法。如是须菩提。菩萨摩诃萨行般若波罗蜜时。能具足无相尸罗波罗蜜而入菩萨位。入菩萨位已得无生法忍。行道种智得报得五神通。住五百陀罗尼门得四无阂智。从一佛国至一佛国供养诸佛。成就众生净佛国土。虽入五道中生死业报不能染污。须菩提。譬如化转轮圣王。虽坐卧行住不见来处不见去处。不见住处坐处卧处。而能利益众生亦不得众生。菩萨亦如是。须菩提。譬如须扇多佛。得阿耨多罗三藐三菩提为三乘转法轮。无有得菩萨记者。化作佛已舍身寿命入无余涅槃。须菩提。菩萨亦如是。行般若波罗蜜时能具足尸罗波罗蜜。能具足尸罗波罗蜜已摄一切善法。复次须菩提。菩萨摩诃萨行般若波罗蜜时住五阴。如梦如响如影如焰如幻如化。具足无相羼提波罗蜜。世尊。云何菩萨摩诃萨具足无相羼提波罗蜜。须菩提。菩萨摩诃萨住二忍中。能具足羼提波罗蜜。何等二忍。生忍法忍。从初发意乃至坐道场。于其中间若一切众生来骂詈粗恶语。或以瓦石刀杖加是菩萨。是菩萨欲具足羼提波罗蜜故。乃至不生一念恶。是菩萨如是思惟。骂我者谁割我者谁。以恶言加我者谁。以瓦石刀杖害我者谁。何以故。是菩萨于一切法得无相忍故。云何作是念。是人骂我害我。若菩萨摩诃萨如是行。能具足羼提波罗蜜。以是羼提波罗蜜具足故得无生法忍。须菩提白佛言。世尊。云何为无生法忍。是忍何所断何所知。佛告须菩提。得法忍乃至不生少许不善法。是故名无生忍。一切菩萨所断烦恼尽。是名断。用智慧知一切法不生。是名知。须菩提白佛言。世尊。诸声闻辟支佛无生法忍。菩萨无生法忍。有何等异。佛告须菩提。诸须陀洹若智若断。是名菩萨忍。斯陀含若智若断。是名菩萨忍。阿那含若智若断。是名菩萨忍。阿罗汉若智若断。是名菩萨忍。辟支佛若智若断。是名菩萨忍。是为异。须菩提。菩萨摩诃萨成就是忍。胜一切声闻辟支佛。住是报得无生忍中。行菩萨道能具足道种智。具足道种智故常不离三十七助道法。及空无相无作三昧。常不离五神通。不离五神通故能成就众生净佛国土。能成就众生净佛国土已。当得一切种智。如是须菩提。菩萨摩诃萨具足无相羼提波罗蜜。复次须菩提。菩萨摩诃萨住无相五阴。如梦如响如影如焰如幻如化。行身精进心精进。以身精进故起神通。起神通故到十方国土。供养诸佛饶益众生。以身精进力教化众生令住三乘。如是须菩提。菩萨摩诃萨行般若波罗蜜。能具足无相精进波罗蜜。是菩萨以心精进圣无漏精进。入八圣道分中能具足毗梨耶波罗蜜。是毗梨耶波罗蜜皆摄一切善法。所谓四念处四正勤四如意足五根五力七觉分八圣道分。四禅四无量心四无色定。八背舍九次第定。佛十力四无所畏四无碍智十八不共法。是中菩萨行是法应具足一切种智。具足一切种智已断一切烦恼习。具足满三十二相身放无等无量光明。放光明已三转十二行法轮。法轮转故三千大千国土六种震动。光明遍照三千大千国土三千大千国土中众生闻说法声。皆以三乘法而得度脱。如是须菩提。菩萨摩诃萨住精进波罗蜜中。能大饶益及能具足一切种智。复次须菩提。菩萨住无相五阴。如梦如响如影如焰如幻如化。能具足禅那波罗蜜。世尊。云何菩萨住五阴。如梦如响如影如焰如幻如化。能具足禅那波罗蜜。须菩提。菩萨摩诃萨入初禅乃至入第四禅。入慈悲喜舍入无量心。入无边虚空处乃至非有想非无想处。入空三昧无相无作三昧。入如电光三昧。入如金刚三昧。入圣正三昧。除诸佛三昧。诸余三昧若共声闻辟支佛三昧。皆证皆入。亦不受三昧味。亦不受三昧果。何以故。是菩萨知是三昧无相无所有性。当云何于无相法受无相法味。无所有法受无所有法味。若不受味。则不随禅定力生若色界。若无色界。何以故。是菩萨不见是二界。亦不见是禅亦不见入禅者。亦不见用是法入禅者。不见入禅处。若不得是法。尔时菩萨能具足无相禅那波罗蜜。菩萨用是禅那波罗蜜。能过声闻辟支佛地。须菩提白佛言。世尊。云何菩萨具足无相禅那波罗蜜故。能过声闻辟支佛地。佛告须菩提。是菩萨善学内空善学外空。乃至善学无法有法空。于是诸空无法可住处。若须陀洹果斯陀含阿那含阿罗汉果乃至一切种智。是诸法空亦空。菩萨摩诃萨行如是诸空能入菩萨位中。须菩提白佛言。世尊。云何菩萨摩诃萨位。云何非位。须菩提。一切有所得是非菩萨位。一切无所得是菩萨位。世尊。何等是有所得。何等是无所得。须菩提。色是有所得。受想行识是有所得。眼耳鼻舌身意乃至一切种智。是有所得。是非菩萨位。须菩提。菩萨位者。是诸法不可示不可说。何等法不可示不可说。若色乃至一切种智。何以故。须菩提。色性是不可示不可说。乃至一切种智性是不可示不可说。须菩提。如是名菩萨位。是菩萨入位中。一切禅定三昧具足。尚不随禅定三昧力生。何况住淫怒痴于中起罪业生。菩萨但住如幻法中饶益众生。亦不得众生亦不得幻。若无所得是时能成就众生净佛国土。如是须菩提。是名菩萨具足无相禅那波罗蜜。乃至能转法轮。所谓不可得法轮。复次须菩提。菩萨摩诃萨行般若波罗蜜。知一切法如梦如响如影如焰如幻如化。须菩提白佛言。世尊。菩萨摩诃萨云何知一切法如梦如响如影如焰如幻如化。须菩提。菩萨摩诃萨行般若波罗蜜时。不见梦不见见梦者。不见响不见闻响者不见影不见见影者。不见焰不见见焰者。不见幻不见见幻者。不见化不见见化者。何以故。是梦响影焰幻化。皆是凡夫愚人颠倒法故。阿罗汉不见梦不见见梦者。乃至不见化不见见化者。辟支佛菩萨摩诃萨诸佛亦不见梦亦不见见梦者。乃至不见化亦不见见化者。何以故。一切法无所有性不生不定。若法无所有性不生不定。菩萨摩诃萨当云何行般若波罗蜜。是中取生相定相。是处不然。何以故。若诸法少多有性有生有定。不名般若波罗蜜。如是须菩提。菩萨摩诃萨行般若波罗蜜。不着色乃至不着识。不着欲色无色界。不着诸禅解脱三昧。不着四念处乃至八圣道分。不着空三昧无相无作三昧。不着檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。不着故能具足菩萨初地。于初地中亦不生着。何以故。是菩萨不得是地云何生着。乃至十地亦如是。是菩萨行般若波罗蜜亦不得般若波罗蜜。若行般若波罗蜜时不得般若波罗蜜。是时见一切法皆入般若波罗蜜中。亦不得是法。何以故。是诸法与般若波罗蜜无二无别。何以故。诸法入如法性实际故无分别。须菩提白佛言。世尊。若诸法无相无分别。云何说是善是不善。是有漏是无漏。是世间是出世间。是有为是无为。须菩提。于汝意云何。诸法实相中有法可说是善是不善乃至是有为是无为。是须陀洹果乃至阿罗汉。是辟支佛是菩萨。是阿耨多罗三藐三菩提不。世尊。不可说也。须菩提。以是因缘故。当知一切法无相无分别。无生无定不可示。须菩提。我本行菩萨道时。亦无有法可得性。若色若受想行识乃至若有为若无为。须陀洹果乃至阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行般若波罗蜜。从初发意乃至阿耨多罗三藐三菩提。应善学诸法性。善学诸法性是名阿耨多罗三藐三菩提道。行是道能具足六波罗蜜。成就众生净佛国土。住是法中得阿耨多罗三藐三菩提。以三乘法度脱众生亦不着三乘。如是须菩提。菩萨摩诃萨以无相法应学般若波罗蜜

摩诃般若波罗蜜经卷第二十三摩诃般若波罗蜜经卷第二十四

        后秦龟兹国三藏鸠摩罗什译

    四摄品第七十八

须菩提白佛言。世尊。若诸法如梦如响如影如焰如幻如化无有实事无所有性自相空者。云何分别是善法是不善法。是世间法是出世间法。是有漏法是无漏法。是有为法是无为法。是法能得须陀洹果斯陀含果阿那含果阿罗汉果。能得辟支佛道。能得阿耨多罗三藐三菩提。佛告须菩提。凡夫愚人得梦得见梦者。乃至得化得见化者。起身口意善业不善业无记业。起福业若罪业。作不动业。是菩萨摩诃萨行般若波罗蜜住二空中。毕竟空无始空。为众生说法作是言。诸众生是色空无所有。受想行识空无所有。十二入十八界空无所有。色是梦受想行识是梦。十二入十八界是梦。色是响是影是焰是幻是化。受想行识亦如是。十二入十八界是梦是响是影是焰是幻是化。是中无阴入界。无梦亦无见梦者。无响亦无闻响者。无影亦无见影者。无焰亦无见焰者。无幻亦无见幻者。无化亦无见化者。一切法无根本实性无所有。汝等于无阴中见有阴。无入见有入。无界见有界。是一切法皆从因缘和合生。以颠倒心起属业果报。汝等何以故。于诸法空无根本中而取根本相。是时菩萨摩诃萨行般若波罗蜜。以方便力故于悭法中拔出众生教行檀那波罗蜜。持是布施功德得大福报。从大福报拔出教令持戒。持戒功德生天上尊贵处。复拔出令住初禅。初禅功德生梵天处。二禅三禅四禅。无边空处识处无所有处。非有想非无想处亦如是。众生行是布施及布施果报。持戒及持戒果报。禅定及禅定果报。种种因缘。拔出安置无余涅槃及涅槃道中。所谓四念处四正勤四如意足五根五力七觉分八圣道分。空解脱门无相无作解脱门。八背舍九次第定。佛十力四无所畏四无碍智十八不共法。安隐众生令住圣无漏法。无色无形。无碍法中。有可得须陀洹果者。安隐教化令住须陀洹果。可得斯陀含果阿那含果阿罗汉果辟支佛道者。令住斯陀含果阿那含果阿罗汉果辟支佛道。可得阿耨多罗三藐三菩提者。安隐教化令住阿耨多罗三藐三菩提中。须菩提白佛言。世尊。诸菩萨摩诃萨甚希有难及。能行是深般若波罗蜜。诸法无所有性。毕竟空无始空而分别诸法。是善是不善。是有漏是无漏。乃至是有为是无为。佛告须菩提。如是如是。诸菩萨摩诃萨甚希有难及。能行是深般若波罗蜜。诸法无所有性。毕竟空无始空而分别诸法。须菩提。汝等若知是菩萨摩诃萨希有难及法。则知一切声闻辟支佛不能报。何况余人。须菩提白佛言。世尊。何等是菩萨摩诃萨希有难及法。诸声闻辟支佛所无有。佛告须菩提。一心谛听。有菩萨摩诃萨行般若波罗蜜。住报得六波罗蜜中。及住报得五神通三十七助道法。住诸陀罗尼诸无碍智到十方国土。可以布施度者以布施摄之。可以持戒度者以持戒摄之。可以忍辱精进禅定智慧度者。随其所应而摄取之。可以初禅度者以初禅摄之。可以二禅三禅四禅无边空处无边识处无所有处非有想非无想处度者。随其所应而摄取之。可以慈心悲喜舍心度者。以慈悲喜舍心而摄取之。可以四念处四正勤四如意足五根五力七觉分八圣道分空三昧无相无作三昧度者。随而摄之。世尊。菩萨摩诃萨云何以布施饶益众生。须菩提。菩萨行般若波罗蜜时。布施随其所须。饮食衣服车马香华璎珞种种所须尽给与之。若供养佛辟支佛阿罗汉阿那含斯陀含须陀洹等无异。若施入正道中。人及凡人下至禽兽。皆无分别等一布施。何以故。一切法不异不分别故。是菩萨无异无别。布施已当得无分别法报。所谓一切种智。须菩提。若菩萨摩诃萨见乞匈者。若生是心。佛是福田我应供养。禽兽非福田不应供养。是非菩萨法。何以故。菩萨摩诃萨发阿耨多罗三藐三菩提心。不作是念。是众生应以布施饶益。是不应布施是众生。布施因缘故。生刹利大姓婆罗门大姓居士大家。乃至以是布施因缘。以三乘法度之令入无余涅槃。若众生来从菩萨乞。亦不生异心分别应与是不应与是。何以故。是菩萨为是众生故。发阿耨多罗三藐三菩提心。若分别简择。便堕诸佛菩萨辟支佛学无学人。一切世间天及人呵责处。谁请汝救一切众生。汝为一切众生舍。一切众生护。一切众生依。而分别简择应与不应与。复次若菩萨摩诃萨行般若波罗蜜时。若人若非人。来欲求乞菩萨身体支节。是时不应生二心若与若不与。何以故。是菩萨摩诃萨为众生故受身。众生来取何可不与。我以饶益众生故受是身。众生不乞自应与之。何况乞而不与。菩萨摩诃萨行般若波罗蜜应如是学。复次须菩提。若菩萨摩诃萨见有乞者应生是念。是中谁与谁受所施何物。是一切法自性皆不可得。以毕竟空故。空相法无与无夺。何以故。毕竟空故。内空外空内外空大空第一义空自相空故。住是诸空布施。是时具足檀那波罗蜜。具足檀那波罗蜜故。若断内外法时作是念。截我者谁割我者谁。复次须菩提。我以佛眼见东方如恒河沙等诸菩萨摩诃萨。入大地狱令火灭汤冷。以三事教化。一者神通二者知他心三者说法。是菩萨以神通力。令大地狱火灭汤冷。知他心以慈悲喜舍随意说法。是众生于菩萨生清净心。从地狱得脱。渐以三乘法得尽苦际。南西北方四维上下亦如是。复次须菩提。我以佛眼观十方世界。见如恒河沙等国土中诸菩萨。为诸佛给使供给诸佛。随意爱乐尊敬。若诸佛所说尽能受持。乃至阿耨多罗三藐三菩提终不忘失。复次须菩提。我以佛眼观十方如恒河沙等国土中诸菩萨摩诃萨。为畜生故舍其寿命。割截身体分散诸方。诸有众生食是诸菩萨摩诃萨肉者皆爱敬菩萨。以爱敬故。即得离畜生道值遇诸佛。闻佛说法如说修行。渐以三乘声闻辟支佛佛法。于无余涅槃而般涅槃。如是须菩提。诸菩萨摩诃萨所益甚多。教化众生令发阿耨多罗三藐三菩提心。如说修行乃至于无余涅槃而般涅槃。复次须菩提。我以佛眼见十方如恒河沙等国土中。诸菩萨摩诃萨除诸饿鬼饥渴苦。是诸饿鬼皆爱敬菩萨。以爱敬故得离饿鬼道。值遇诸佛闻诸佛说法如说修行。渐以三乘声闻辟支佛佛法。而般涅槃乃至无余涅槃。如是须菩提。菩萨摩诃萨为度众生故行大悲心。复次须菩提。我以佛眼见诸菩萨摩诃萨在四天王天上说法。在三十三天夜摩天兜率陀天化乐天他化自在天上说法。诸天闻菩萨说法。渐以三乘而得灭度。须菩提。是诸天众中有耽着五欲者。是菩萨示现火起烧其宫殿而为说法。作是言。诸天一切有为法悉皆无常。谁常安者。复次须菩提。我以佛眼观十方世界。见如恒河沙等国土中。诸梵天着于邪见。诸菩萨摩诃萨教令远离邪见。作是言。汝等云何于空相虚妄诸法中而生邪见。如是须菩提。菩萨摩诃萨住大慈心为众生说法。须菩提。是为诸菩萨希有难及法。复次须菩提。我以佛眼观十方世界。如恒河沙等国土中诸菩萨摩诃萨。以四事摄取众生。何等四。布施爱语利益同事。云何菩萨以布施摄取众生。须菩提。菩萨以二种施摄取众生。财施法施。何等财施摄取众生。须菩提。菩萨摩诃萨以金银琉璃颇梨真珠珂贝珊瑚等诸宝物。或以饮食衣服卧具房舍灯烛华香璎珞。若男若女若牛羊象马车乘。若以己身给施众生。语众生言。汝等若有所须各来取之。如取己物莫得疑难。是菩萨施已。教三归依。归依佛归依法归依僧。或教受五戒或教一日戒。或教初禅。乃至教非有想非无想定。或教慈悲喜舍。或教念佛念法念僧念戒念舍念天。或教不净观。或教安那般那观或相或触。或教四念处四正勤四如意足五根五力七觉分八圣道分。空三昧无相无作三昧。八背舍九次第定。佛十力四无所畏四无碍智。十八不共法大慈大悲。三十二相八十随形好。或教须陀洹果斯陀含果阿那含果阿罗汉果。或教辟支佛道。或教阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力教众生财施已。复教令得无上安隐涅槃。须菩提。是名菩萨摩诃萨希有难及法。须菩提。菩萨云何以法施摄取众生。须菩提。法施有二种。一者世间二者出世间。何等为世间法施。敷演显示世间法。所谓不净观安那般那念。四禅四无量心四无色定。如是等世间法。及诸余共凡夫所行法。是名世间法施。是菩萨如是世间法施已。种种因缘教化令远离世间法。远离世间法已。以方便力令得圣无漏法及圣无漏法果。何等是圣无漏法。何等是圣无漏法果。圣无漏法者。三十七助道法三解脱门。圣无漏法果者。须陀洹果乃至阿罗汉果辟支佛道。阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨圣无漏法。须陀洹果中智慧。乃至阿罗汉果中智慧辟支佛道中智慧。三十七助道法中智慧。六波罗蜜中智慧。乃至大慈大悲中智慧。如是等一切法若世间若出世间智慧。若有漏若无漏若有为若无为。是法中一切种智。是名菩萨摩诃萨圣无漏法。何等为圣无漏法果。断一切烦恼习相续。是名圣无漏法果。须菩提白佛言。世尊。菩萨摩诃萨得一切种智。不。佛言。如是如是。须菩提。菩萨摩诃萨得一切种智。须菩提言。菩萨与佛有何等异。佛言。有异。菩萨摩诃萨得一切种智。是名为佛。所以者何。菩萨心与佛心无有异。菩萨住是一切种智中。于一切法无不照明。是名菩萨摩诃萨世间法施。须菩提。菩萨摩诃萨因缘世间法施。得出世间法施。如是须菩提。菩萨摩诃萨教众生令得世间法。以方便力故教令得出世间法。须菩提。何等是菩萨出世间法。不共凡夫法同。所谓四念处四正勤四如意足五根五力七觉分八圣道分。三解脱门八背舍九次第定。佛十力四无所畏四无碍智十八不共法。三十二相八十随形好。五百陀罗尼门。是名出世间法。须菩提。云何为四念处。菩萨摩诃萨观内身循身观。观外身循身观。观内外身循身观。勤精进以一心智慧观。观身集因缘生。观身灭。观身集生灭行。是道无所依。于世间无所受。受心法念处亦如是。须菩提。云何为四正勤。未生恶不善法为不生故勤生欲精进。已生恶不善法为断故勤生欲精进。未生善法为生故勤生欲精进。已生诸善法为增长修具足故勤生欲精进。是名四正勤。须菩提。云何为四如意足。欲三昧断行成就初如意足。精进三昧。心三昧。思惟三昧断行成就如意足。云何为五根。信根进根念根定根慧根。云何为五力。信力精进力念力定力慧力。云何为七觉分。念觉分择法觉分精进觉分喜觉分除息觉分定觉分舍觉分。云何为八圣道分。正见正思惟正语正业正命正精进正念正定。云何为三三昧。空三昧门无相无作三昧门。云何为空三昧。以空行无我行摄心。是名空三昧。云何为无相三昧。以寂灭行离行摄心。是名无相三昧。云何为无作三昧。无常行苦行摄心。是名无作三昧。云何为八解脱。内色相外观色是初解脱。内无色相外观色是二解脱。净解脱是三解脱。过一切色相灭一切有对相。不念一切异相故。观无边虚空入无边虚空处。乃至过一切非有想非无想处。入灭受想解脱。是名八解脱。云何九次第定。行者离欲恶不善法。有觉有观离生喜乐。入初禅第二第三第四禅。乃至过非有想非无想处。入灭受想定。是名九次第定。云何为佛十力。是处不是处。如实知众生过去未来现在诸业诸法诸受。知造业处。知因缘知报。诸禅定解脱三昧定。垢净分别相如实知。知他众生诸根上下相。知他众生种种欲解。知世间种种无数性。知一切到道相。知种种宿命。一世乃至无量劫如实知。天眼见众生乃至生善恶道。漏尽故无漏心解脱如实知。是为佛十力。云何为四无所畏。佛作诚言。我是一切正智人。若有沙门婆罗门若天若魔若梵若复余众。如实言是法不知。乃至不见是微畏相。以是故。我得安隐得无所畏。安住圣主处。在大众中作师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。一无所畏。佛作诚言。我一切漏尽。若有沙门婆罗门若天若魔若梵若复余众。如实言是漏不尽。乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中作师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。二无畏也。佛作诚言。我说障法。若有沙门婆罗门若天若魔若梵若复余众。如实言受是法不障道。乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中作师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。三无畏也。佛作诚言。我所说圣道能出世间。随是行能尽苦。若有沙门婆罗门若天若魔若梵若复余众。如实言行是道不能出世间不能尽苦乃至不见是微畏相。以是故。我得安隐得无所畏安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。四无畏也。云何为四无碍智。一者义无碍智。二者法无碍智。三者辞无碍智。四者乐说无碍智。云何为义无碍智。缘义智慧是为义无碍智。云何为法无碍智。缘法智慧是为法无碍智。云何为辞无碍智。缘辞智慧是为辞无碍智。云何为乐说无碍智。缘乐说智慧是为乐说无碍智。云何为十八不共法。一诸佛身无失。二口无失。三念无失。四无异想。五无不定心。六无不知已舍心。七欲无减。八精进无减。九念无减。十慧无减。十一解脱无减。十二解脱知见无减。十三一切身业随智慧行。十四一切口业随智慧行。十五一切意业随智慧行。十六智慧知过去世无碍。十七智慧知未来世无碍。十八智慧知现在世无碍。云何三十二相。一者足下安平立平如奁底。二者足下千辐辋轮轮相具足。三者手足指长胜于余人。四者手足柔软胜余身分。五者足跟广具足满好。六者手足指合缦网妙好胜于余人。七者足趺高平好与跟相称。八者伊泥延鹿[跳-兆+專][跳-兆+專]纤好。如伊泥延鹿王。九者平住两手摩膝。十者阴藏相如马王象王。十一者身踪广等如尼俱卢树。十二者一一孔一毛生。色青柔软而右旋。十三者毛上向青色柔软而右旋。十四者金色相其色微妙胜阎浮檀金。十五者身光面一丈。十六者皮薄细滑。不受尘垢不停蚊蚋。十七者七处满。两足下两手中两肩上项中。皆满字相分明。十八者两腋下满。十九者上身如师子。二十者身广端直。二十一者肩圆好。二十二者四十齿。二十三者齿白齐密而根深。二十四者四牙最白而大。二十五者方颊车如师子。二十六者味中得上味。咽中二处津液流出。二十七者舌大软薄。能覆面至耳发际。二十八者梵音深远。如迦兰频伽声。二十九者眼色如金精。三十者眼睫如牛王。三十一者眉间白毫相软白如兜罗绵。三十二者顶髻肉骨成。是三十二相佛身成就。光明遍照三千大千国土。若欲广照则遍满十方无量阿僧祇国土。为众生故受丈光。若放无量光明。则无日月时节岁数。佛音声遍满三千大千国土。若欲大声则遍满十方无量阿僧祇国土。随众生多少音声遍至。云何为八十随形好。一者无见顶。二者鼻直高好孔不现。三者眉如初生月绀琉璃色。四者耳轮埵成。五者身坚实如那罗延。六者骨际如钩锁。七者身一时回如象王。八者行时足去地四寸而印文现。九者爪如赤铜色薄而润泽。十者膝骨坚着圆好。十一者身净洁。十二者身柔软。十三者身不曲。十四者指长纤圆。十五者指文庄严。十六者脉深。十七者踝不现。十八者身润泽。十九者身自持不逶迤。二十者身满足。二十一者识满足。二十二者容仪备足。二十三者住处安无能动者。二十四者威震一切。二十五者一切乐观。二十六者面不大长。二十七者正容貌不挠色。二十八者面具足满。二十九者唇赤如频婆果色。三十者音响深。三十一者脐深圆好。三十二者毛右旋。三十三者手足满。三十四者手足如意。三十五者手文明直。三十六者手文长。三十七者手文不断。三十八者一切恶心众生见者和悦。三十九者面广姝好。四十者面净满如月。四十一者随众生意和悦与语。四十二者毛孔出香气。四十三者口出无上香。四十四者仪容如师子。四十五者进止如象王。四十六者行法如鹅王。四十七者头如摩陀那果。四十八者一切声分具足。四十九者牙利。五十者舌色赤。五十一者舌薄。五十二者毛红色。五十三者毛洁净。五十四者广长眼。五十五者孔门相具。五十六者手足赤白如莲华色。五十七者脐不出。五十八者腹不现。五十九者细腹。六十者身不倾动。六十一者身持重。六十二者其身大。六十三者身长。六十四者手足洁净软泽。六十五者边光各一丈。六十六者光照身而行。六十七者等视众生。六十八者不轻众生。六十九者随众生音声不过不减。七十者说法不着。七十一者随众语言而为说法。七十二者一发音报众声。七十三者次第有因缘说法。七十四者一切众生不能尽观相。七十五者观无厌足。七十六者发长好。七十七者发不乱。七十八者发旋好。七十九者发色如青珠。八十者手足有德相。须菩提。是为八十随形好佛身成就。如是须菩提。菩萨摩诃萨以二施摄取众生。所谓财施法施。是为菩萨希有难及事。云何为菩萨摩诃萨爱语摄取众生。菩萨摩诃萨以六波罗蜜为众生说法。作是言。汝行六波罗蜜摄一切善法。云何为菩萨摩诃萨利行摄取众生。菩萨摩诃萨长夜教众生令行六波罗蜜。云何为菩萨摩诃萨同事摄取众生。菩萨摩诃萨以五神通力故。种种变化入五道中与众生同事。以此四事而摄取之。复次须菩提。菩萨摩诃萨行般若波罗蜜时教化众生。善男子。当善学分别诸字亦当善知一字乃至四十二字。一切语言皆入初字门。一切语言亦入第二字门。乃至第四十二字门。一切语言皆入其中。一字皆入四十二字。四十二字亦入一字。是众生应如是善学四十二字。善学四十二字已能善说字法。善说字法已善说无字法。须菩提。如佛善知字法。善知字善知无字。为无字法故说字法。何以故。须菩提。过一切名字法故名为佛法。须菩提白佛言。世尊。若众生毕竟不可得。法亦不可得。法性亦不可得。毕竟空无始空故。世尊。菩萨摩诃萨云何行般若波罗蜜。行禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜时。行四禅四无量心四无色定三十七助道法十八空。行空无相无作三昧八解脱九次第定。佛十力四无所畏四无碍智十八不共法。三十二相八十随形好。云何住报得五神通为众生说法。众生实不可得。众生不可得故。色不可得乃至识亦不可得。五阴不可得故。六波罗蜜乃至八十随形好皆不可得。是不可得中无众生无色乃至无八十随形好。世尊。云何菩萨摩诃萨行般若波罗蜜。为众生说法。世尊。菩萨行般若波罗蜜时。菩萨尚不可得。何况当有菩萨法。佛告须菩提。如是如是。如汝所言。众生不可得故。当知是内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空诸法空自相空性空不可得空无法空有法空无法有法空。众生不可得故。当知五阴空十二入十八界空十二因缘空四谛空我空寿者命者生者养育者众数者人者作者使作者起者使起者受者使受者知者见者皆空。众生不可得故。当知四禅空四无量心空四无色定空。当知四念处空乃至八圣道分空空空无相空无作空。八解脱空九次第定空。众生不可得故。当知佛十力空四无所畏空四无碍智空十八不共法空。当知须陀洹果空斯陀含果空阿那含果空阿罗汉果空辟支佛道空。当知菩萨地空阿耨多罗三藐三菩提空。须菩提。菩萨摩诃萨如是见一切法空。为众生说法不失诸空相。是菩萨如是观时知一切法无碍。知一切法无碍已不坏诸法相不二不分别。但为众生如实说法。譬如佛所化人。化人复化作无量千万亿人。有教令布施者有教持戒。有教忍辱有教精进。有教禅定有教智慧。有教四禅四无量心四无色定者。于汝意云何。佛所化人。有分别破坏诸法不。须菩提言。不也世尊。是化人无心无心数法。云何分别破坏诸法。以是故。须菩提当知。菩萨摩诃萨行般若波罗蜜为众生如应说法拔出众生于颠倒地。令众生各得如所应住地。以不缚不脱法故。何以故。须菩提。是色不缚不脱受想行识不缚不脱。色无缚无脱不是色。受想行识无缚无脱不是识。何以故。色毕竟清净故。受想行识乃至一切法若有为若无为。亦毕竟清净故。如是须菩提。菩萨摩诃萨为众生说法。亦不得众生及一切法。一切法不可得故。菩萨以不住法故住诸法相中。所谓色空乃至有为无为法空。何以故。色乃至有为无为法。自性不可得故无有住处。无所有法不住无所有法。自性法不住自性法。他性法不住他性法。何以故。是一切法皆不可得故。不可得法当住何处。如是须菩提。菩萨摩诃萨行般若波罗蜜。以是诸空能如是说法。如是行般若波罗蜜。于诸佛及声闻辟支佛无有过。何以故。诸佛及菩萨辟支佛阿罗汉得是法已。为众生说法。亦不转诸法相。何以故。如法性实际不可转故。所以者何。诸法性无故。须菩提白佛言。世尊。若法性如实际不转。色与法性异不。色与如实际异不。受想行识乃至有为无为法。世间出世间有漏无漏异不。佛言不也。色不异法性不异如不异实际。受想行识乃至有漏无漏亦不异。须菩提白佛言。世尊。若色不异法性不异如不异实际。受想行识乃至有漏无漏不异者。云何分别黑法有黑报。所谓地狱饿鬼畜生。白法有白报。所谓诸天及人。黑白法有黑白报。不黑不白法有不黑不白报。所谓须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。阿耨多罗三藐三菩提。佛告须菩提。世谛故分别说有果报。非第一义。第一义中不可说因缘果报。何以故。是第一义。实无有相无有分别亦无言说。所谓色乃至有漏无漏法。不生不灭相不垢不净。毕竟空无始空故。须菩提白佛言。世尊。若以世谛故分别说有果报。非第一义者。一切凡夫人。应有须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。凡夫人为知是世谛是第一义谛不。若知是凡夫人应是须陀洹果乃至阿耨多罗三藐三菩提。须菩提。以凡夫人实不知世谛。不知第一义谛。不知道不知分别道果。云何当有诸果。须菩提。圣人知世谛知第一义谛有道有修道。以是故。圣人差别有诸果。须菩提白佛言。世尊。修道得果不。佛言不也。须菩提。修道不得果。不修道亦不得果。亦不离道得果。亦不住道中得果。如是须菩提。菩萨摩诃萨行般若波罗蜜时。为众生故分别果。亦不分别是有为性无为性。世尊。若不分别有为性无为性。得诸果者。云何世尊自说三结尽故名须陀洹。淫怒痴薄故名斯陀含果。五此间结尽故名阿那含果五彼间结尽故名阿罗汉。所有集法皆灭散相故名辟支佛道。一切烦恼习断故名阿耨多罗三藐三菩提。世尊。我当云何知不分别有为性无为性得诸果。佛告须菩提。汝以须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。是诸果是有为是无为。须菩提言。世尊。皆是无为。须菩提。无为法中有分别不。不也世尊。若善男子善女人。通达一切法若有为若无为一相。所谓无相。是时有分别若有为若无为不。不也世尊。如是须菩提。菩萨摩诃萨为众生说法不分别诸法。所谓内空故乃至无法有法空故。是菩萨自得无所著法。亦教人令得无所著法。若檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。初禅乃至第四禅慈悲喜舍无边虚空处乃至非有想非无想处。若四念处乃至一切种智是。菩萨自不着故。亦教他人令得无所著。无所著故无所碍。譬如佛所化人布施亦不受布施报。但为度众生故。乃至行一切种智不受一切种智报。菩萨摩诃萨亦如是。行六波罗蜜乃至一切法有漏无漏有为无为。不住亦不受报。但为度众生故。何以故。是菩萨摩诃萨善达一切诸法相故

    摩诃般若波罗蜜经善达品第七十九

须菩提白佛言。世尊。云何菩萨善达诸法相。佛告须菩提。譬如化人不行淫怒痴。不行色乃至识。不行内外法。不行诸烦恼结使。不行有漏法无漏法世间法出世间法有为法无为法。亦无圣果。菩萨亦如是。无有是法。亦不分别是法。是名善达诸法相。须菩提言。世尊。化人云何有修道。佛言。化人修道不垢不净。亦不在五道生死。须菩提。于汝意云何。佛所化人有根本实事不。有垢有净不。须菩提言不也。佛所化人无有根本实事。亦无垢亦无净。亦不在五道生死。如是须菩提。菩萨摩诃萨善达诸法相亦如是。须菩提言。世尊。一切色如化不。受想行识如化不。佛言。一切色如化。一切受想行识如化。世尊。若一切色如化。一切受想行识如化。一切法如化。化人无色无受想行识无垢无净。无五道生死亦无解脱处。菩萨有何等功用。佛告须菩提。于汝意云何。菩萨摩诃萨本行菩萨道时。颇见有众生从地狱饿鬼畜生天人中得解脱不。须菩提言。不也世尊。佛言。如是如是。须菩提。菩萨摩诃萨亦如是。不见众生从三界得解脱。何以故。菩萨摩诃萨见知一切法如幻如化。世尊。若菩萨摩诃萨见知一切法如幻如化。为何事故行六波罗蜜四禅四无量心四无色定三十七助道法。乃至行大慈悲净佛国土成就众生。佛告须菩提。若众生自知诸法如幻如化。菩萨摩诃萨终不于阿僧祇劫为众生。行菩萨道。须菩提。以众生自不知诸法如幻如化。以是故。菩萨摩诃萨于无量阿僧祇劫行六波罗蜜。成就众生净佛国土。得阿耨多罗三藐三菩提。须菩提白佛言。世尊。若一切法。如梦如响如影如焰如幻如化。众生在何处住。菩萨行六波罗蜜而拔出之。须菩提。众生但住名相虚妄忆想分别中。是故菩萨行般若波罗蜜。于名相虚妄中拔出众生。须菩提白佛言。世尊。何等是名。何等是相。佛言。此名强作但假施设。所谓此色此受想行识。此男此女。此大此小。此地狱此畜生此饿鬼此人此天。此有为此无为。此是须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道此佛道。须菩提。一切和合法皆是假名。以名取诸法。是故为名。一切有为法但有名相。凡夫愚人于中生着。菩萨摩诃萨行般若波罗蜜。以方便力故于名字中教令远离。作是言。诸众生是名但有空名。虚妄忆想分别中生。汝等莫着虚妄忆想。此事本末皆无自性空故。智者所不着。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力故为众生说法。须菩提。是为名。何等为相。须菩提。有二种相。凡夫人所著处。何等为二。一者色相。二者无色相。须菩提。何等名色相。诸所有色若粗若细若好若丑皆是空。是空法中忆想分别着心取相。是名为色相。何等是无色相。诸无色法忆想分别着心取相故生烦恼。是名无色相。是菩萨摩诃萨行般若波罗蜜。以方便力故教众生远离是相着。无相法中令不堕二法。所谓是相是无相。如是须菩提。菩萨摩诃萨行般若波罗蜜。教众生远离相令住无相性中。须菩提白佛言。世尊。若一切法但有名相。云何菩萨行般若波罗蜜。能自饶益亦教他人令得善利。云何菩萨具足诸地。从一地至一地。教化众生令得三乘。佛告须菩提。若诸法根本定有。非但名相者。菩萨摩诃萨行般若波罗蜜时。不能自利益。亦不能利益他人。须菩提。诸法无有根本实事但有名相。是故菩萨行般若波罗蜜时。能具足禅那波罗蜜无相故。毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜无相故。具足四禅波罗蜜。四无量心波罗蜜。四无色定波罗蜜无相故。具足四念处波罗蜜无相故。乃至具足八圣道分波罗蜜无相故。具足内空波罗蜜无相故。乃至具足无法有法空波罗蜜无相故。具足解脱波罗蜜无相故。具足九次第定波罗蜜无相故。具足佛十力波罗蜜。乃至具足十八不共法波罗蜜无相故。是菩萨无相故。自具足是诸善法。亦教他人令具足善法无相故。须菩提。若诸法相当实有如毫厘许者。菩萨摩诃萨行般若波罗蜜时。不能知诸法无相无忆念得阿耨多罗三藐三菩提。亦教众生令得无漏法。何以故。一切无漏法无相无忆念故。如是须菩提。菩萨摩诃萨行般若波罗蜜。以无漏法利益众生。须菩提白佛言。世尊。若一切法无相无忆念。云何数是声闻法是辟支佛法是菩萨法是佛法。佛告须菩提。于汝意云何。无相法与声闻法异不。不也世尊。无相法与辟支佛法菩萨法佛法异不。不也世尊。佛告须菩提。无相法即是须陀洹果斯陀含果阿那含果阿罗汉果辟支佛法菩萨法佛法。须菩提言。如是世尊。须菩提。以是因缘故当知一切法皆是无相。须菩提。菩萨摩诃萨学是一切法无相。得增益善法。所谓六波罗蜜四禅四无量心四无色定四念处。乃至十八不共法。何以故。菩萨不以余法为要。如三解脱门所谓空无相无作。所以者何。一切善法皆入三解脱门。何以故。一切法自相空是名空解脱门。一切法无相是名无相解脱门。一切法无作无起相是名无作解脱门。若菩萨摩诃萨学三解脱门。是时能学五阴相。能学十二入相。能学十八界相。能学四圣谛十二因缘法。能学内空外空乃至无法有法空。能学六波罗蜜四念处乃至八圣道分。能学佛十力四无所畏四无碍智十八不共法。须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜。能学五受阴相。佛告须菩提。菩萨摩诃萨行般若波罗蜜。知色相知色生灭知色如。云何知色相。知色毕竟空。内分分异虚无实。譬如水沫无坚固。是为知色相。云何知色生灭。色生时无所从来去无所至。若不来不去是为知色生灭相。云何知色如。是色如不生不灭不来不去。不增不减不垢不净。是名知色如。须菩提。如名如实不虚。如前后中亦尔。常不异是为知色如。云何知受相。云何知受生灭。云何知受如。菩萨知诸受相。如水中泡一起一灭。是为知受相。知受生灭者。是诸受无所从来去无所至。是为知受生灭。知受如者。是如不生不灭不来不去。不增不减不垢不净。是为知受如。云何知想相。云何知想生灭。云何知想如。知想相者。是想如焰水不可得而妄生水想。是为知想相。知想生灭者。是想无所从来去无所至。是为知想生灭。知想如者。诸想如不生不灭不来不去不增不减不垢不净。不转于实相。是为知想如。云何知行相。云何知行生灭。云何知行如。知行相者。行如芭蕉叶叶除却不得坚实。是为知行相。知行生灭者。诸行生无所从来去无所至。是为知行生灭。知行如者。诸行不生不灭不来不去不增不减不垢不净。是为知行如。云何知识相。云何知识生灭。云何知识如。知识相者。识如幻师幻作四种兵无有实。识相亦如是。是为知识相。知识生灭者。是识生时无所从来灭时无所去。是为知识生灭。知识如者。知识不生不灭不来不去不垢不净不增不减。是为知识如。云何知诸入。眼眼性空乃至意意性空。色色性空乃至法法性空。云何知界。眼眼界空。色色界空。眼识眼识界空。乃至意识界亦如是。云何知四圣谛。知苦圣谛时远离二法。知苦谛不二不别。是名苦圣谛。集尽道亦如是。云何知苦如。知苦圣谛即是如。如即是苦圣谛。集尽道亦如是。云何知十二因缘。知十二因缘不生相。是名知十二因缘。须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜时。各各分别知诸法。将无以色性坏法性乃至一切种智性坏法性耶。佛告须菩提。若法性外更有法者应坏法性。法性外法不可得。是故不坏。何以故。须菩提。佛及佛弟子。知法性外法不可得。不可得故不说法性外有法。如是须菩提。菩萨摩诃萨行般若波罗蜜应学法性。须菩提白佛言。世尊。菩萨摩诃萨。若学法性为无所学。佛告须菩提。菩萨摩诃萨学法性则学一切法。何以故。一切法即是法性。须菩提白佛言。世尊。何因缘故一切法即是法性。佛言。一切法皆入无相无为性中。以是因缘故学法性则学一切法。须菩提白佛言。世尊。若一切法即是法性。菩萨摩诃萨何以学般若波罗蜜禅那波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀那波罗蜜。菩萨摩诃萨。何以学初禅第二第三第四禅。菩萨摩诃萨。何以学慈悲喜舍。何以学无边虚空处无边识处无所有处非有想非无想处。何以学四念处四正勤四如意足五根五力七觉分八圣道分。何以学空无相无作解脱门。何以学八背舍九次第定佛十力四无所畏四无碍智十八不共法。何以学六神通。何以学三十二相八十随形好。何以学生刹利大姓婆罗门大姓居士大家。何以学生四天王天处三十三天夜摩天兜率陀天化乐天他化自在天。何以学生梵天王住处光音天遍净天广果天无想天净居天。何以学生无边空处。生无边识处。无所有处。生非有想非无想处。何以学初发意地第二第三第四第五第六第七第八第九第十地。何以学声闻地辟支佛地菩萨法位。何以学成就众生净佛国土。何以学诸陀罗尼。何以学乐说法。何以学阿耨多罗三藐三菩提。学已得一切种智知一切法。世尊。诸法法性中无是分别。世尊。将无菩萨堕非道中。何以故。世尊。法性中无如是分别。法性中无色无受想行识诸法性亦不远离色受想行识。色即是法性法性即是色。受想行识亦如是。一切法亦如是。佛告须菩提。如是如是。如汝所言。色即是法性受想行识即是法性。须菩提。菩萨摩诃萨行般若波罗蜜时。若法性外见有法者。为不求阿耨多罗三藐三菩提。菩萨摩诃萨行般若波罗蜜时。知一切法性即是阿耨多罗三藐三菩提。以是故。菩萨摩诃萨行般若波罗蜜时。知一切法即是法性已。以无名相法以名相说。所谓是色是受想行识。乃至是阿耨多罗三藐三菩提。须菩提。譬知工幻师若幻弟子。多人处立幻作种种形色男女象马端严园林。及诸庐馆流泉浴池。衣服卧具香华璎珞肴膳饮食。作众伎乐以乐众人。又复幻作人。令布施持戒忍辱精进禅定修智慧。是幻师复幻作刹利大姓婆罗门大姓居士大家。四天王天处须弥山。三十三天夜摩天兜率陀天化乐天他化自在天以示众人。复幻作梵众天乃至非有想非无想天。又幻作须陀洹斯陀含阿那含阿罗汉辟支佛菩萨摩诃萨。从初发意行檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。行初地乃至行十地。入菩萨位游戏神通。成就众生净佛国土游戏诸禅解脱三昧。行佛十力四无所畏四无碍智十八不共法大慈大悲。具足佛身三十二相八十随形好以示众人。是中无智之人叹未曾有。是人多能巧为众事娱乐众人。种种形色乃至三十二相八十随形好庄严佛身。其中有智之土思惟言。未曾有也是中无有实事。而以无所有法娱乐众人令有形相。无事事相无有有相。如是须菩提。菩萨摩诃萨不见离法性有法行般若波罗蜜。以方便力故虽不得众生。而自布施亦教人布施。赞叹布施法欢喜赞叹行布施者。自持戒亦教人持戒。自忍辱亦教人忍辱。自精进亦教人精进。自行禅亦教人行禅。自修智慧亦教人修智慧。赞叹修智慧法。欢喜赞叹修智慧者。自行十善亦教他人行十善。赞叹行十善法。欢喜赞叹行十善者。自受行五戒亦教他人受行五戒。赞叹五戒法。欢喜赞叹受行五戒者。自受八戒斋亦教他人受八戒斋。赞叹八戒斋法。欢喜赞叹行八戒斋者。自行初禅乃至自行第四禅。自行慈悲喜舍。自行无边空处乃至非有想非无想处亦教他人行。自行四念处乃至八圣道分。自行三解脱门佛十力。乃至自行十八不共法。亦教他人行十八不共法。赞叹十八不共法。欢喜赞叹行十八不共法者。须菩提。若法性前后中有异者。是菩萨摩诃萨不能以方便力故示法性成就众生。须菩提。以法性前后中无异。是故菩萨行般若波罗蜜。为利益众生故行菩萨道

摩诃般若波罗蜜经卷第二十四摩诃般若波罗蜜经卷第二十五

        后秦龟兹国三藏鸠摩罗什译

    实际品第八十

须菩提白佛言。世尊。若众生毕竟不可得。菩萨为谁故行般若波罗蜜。佛告须菩提。菩萨为实际故行般若波罗蜜。须菩提。实际众生际异者。菩萨不行般若波罗蜜。须菩提。实际众生际不异。以是故。菩萨摩诃萨为利益众生故行般若波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜时。以不坏实际法立众生于实际中。须菩提白佛言。世尊。若实际即是众生际。菩萨则为建立实际于实际。世尊。若建立实际于实际。则为建立自性于自性。世尊。不应建立自性于自性。世尊。云何菩萨摩诃萨行般若波罗蜜时。建立众生于实际。佛告须菩提。实际不可建立于实际。自性不可建立于自性。须菩提。今菩萨摩诃萨行般若波罗蜜时。以方便力故建立众生于实际。实际亦不异众生际。实际众生际无二无别。须菩提白佛言。世尊。何等是诸菩萨摩诃萨方便力。用是方便力。菩萨摩诃萨行般若波罗蜜时。建立众生于实际亦不坏实际相。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。以方便力故建立众生于布施。建立已说布施先后际相空。作是言。如是布施前际空后际空中际亦空。施者亦空施报亦空受者亦空。诸善男子。是一切法实际中不可得。汝等莫念布施异施者异施报异受者异。若汝等不念布施异施者异施报异受者异。是时布施能取甘露味得甘露味果。汝善男子。以是布施故。莫着色莫着受想行识。何以故。是布施布施相空。施者施者空。施报施报空。受者受者空。空中布施不可得。施者不可得施报不可得受者不可得。何以故。是诸法毕竟自性空故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。以方便力故教众生持戒。语众生言。汝善男子。除舍杀生法。乃至除舍邪见法。何以故。善男子。如汝所分别法是诸法无如是性。汝善男子。当谛思惟何等是众生而欲夺命。用何等物夺命。乃至邪见亦如是。须菩提。菩萨摩诃萨如是方便力成就众生。是菩萨摩诃萨。即为众生说布施持戒果报。是布施持戒果报自性空。知布施持戒果报自性空已是中不着。不着故心不散能生智慧。以是智慧断一切结使烦恼习。入无余涅槃。是世俗法非第一实义。何以故。空中无有灭亦无使灭者。诸法毕竟空即是涅槃。复次须菩提。菩萨摩诃萨。见众生嗔恚恼心教言。汝善男子。来修行忍辱。作忍辱人当乐忍辱。汝所嗔者自性空。汝来善男子。如是思惟我于何所法中嗔。谁为嗔者所嗔者谁。是法皆空是性空法无不空时。是空非诸佛作。非辟支佛声闻作。非菩萨摩诃萨作。非诸天鬼神龙王阿修罗紧陀罗摩睺罗伽。非四天王天乃至非他化自在天。非梵众天乃至非净居天。非无边空处乃至非有想非无想诸天所作。汝当如是思惟嗔谁。谁是嗔者。何等是嗔事。是一切法性空性。空法无有所嗔。如是须菩提。菩萨摩诃萨行般若波罗蜜时。以是因缘建立众生于性空。次第渐渐示教利喜。令得阿耨多罗三藐三菩提。是世俗法非第一实义。何以故。是性空中无有得者。无有得法无有得处。须菩提。是名实际性空法。菩萨摩诃萨为众生故行是法。众生亦不可得。何以故。一切法离众生相。复次须菩提。菩萨摩诃萨行般若波罗蜜时。方便力故见众生懈怠教令身精进心精进。作是言。诸善男子。诸法性空中。无懈怠法无懈怠者无懈怠事。是一切法性皆空。无过性空者。汝等生身精进心精进。为生善法故莫懈怠。善法者。若布施若持戒若忍辱若精进若禅定若智慧。若诸禅定解脱三昧。若四念处乃至八圣道分。若空解脱门无相无作解脱门乃至十八不共法莫懈怠。诸善男子。是一切法性空中。当知无碍相。无碍法中无懈怠者无懈怠法。如是须菩提。菩萨摩诃萨行般若波罗蜜时。教众生令住性空不堕二法。何以故。是性空中无二无别故。是无二法则无可着处。复次须菩提。菩萨摩诃萨行性空般若波罗蜜时。教众生令精进。作是言。诸善男子。勤精进若布施若持戒若忍辱若精进若禅定若智慧。若禅定解脱三昧。若四念处乃至八圣道分。若空解脱门无相无作解脱门。若佛十力若四无所畏若四无碍智。若十八不共法若大慈大悲。是诸法汝等莫念二相。莫念不二相。何以故。是法性皆空是性空法。不应用二相念。不应用不二相念。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力故成就众生。成就众生已。次第教令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道菩萨位。令得阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行般若波罗蜜时。见众生乱心。以方便力为利益众生故。作是言。诸善男子。当修禅定汝莫生乱想当生一心。何以故。是法性皆空性。空中无有法可得若乱若一心。汝等住是三昧。所有作业若身若口若意。若布施若持戒若行忍辱若勤精进若行禅定若修智慧。若行四念处乃至若行八圣道分。若行诸解脱次第定。若行佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好。若声闻道若辟支佛道若菩萨道若佛道。若须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。若一切种智。若成就众生若净佛国土。汝等皆当应随所愿得住性空故。如是须菩提。菩萨摩诃萨行般若波罗蜜方便力。为利益众生故。从初发意终不懈废。常求善法利益众生。徒一佛国至一佛国。供养诸佛从诸佛闻法舍身受身。乃至阿耨多罗三藐三菩提终不忘失。是菩萨常得诸陀罗尼法。诸根具足。所谓身根语根意根。何以故。是菩萨摩诃萨常修一切种智。修一切种智故一切诸道皆修。若声闻道若辟支佛道若菩萨神通道。行神通道菩萨常利益众生终不忘失。是菩萨住报得神通利益众生。入生死五道终不耗减。如是须菩提。菩萨摩诃萨行般若波罗蜜住性空。以禅定利益众生。复次须菩提。菩萨摩诃萨行般若波罗蜜住性空。以方便力故利益众生。作是言。汝等诸善男子。观一切法性空。善男子。汝等当作诸业。若身业若口业若意业。取甘露味得甘露果。性空中无有法退。何以故。性空不退亦无退者。以性空非法亦非非法。于无所有法中云何当有退。须菩提。菩萨摩诃萨行般若波罗蜜时。如是教众生常不懈废。是菩萨自行十善。亦教他人行十善。五戒八戒成就斋亦如是。自行初禅亦教他人令行初禅。乃至第四禅亦如是。常自行慈心亦教他人令行慈心。乃至舍心亦如是。自行无边空处亦教他人令行无边空处。乃至非有想非无想处亦如是。自行四念处亦教他人令行四念处。乃至八圣道分佛十力乃至八十随形好亦如是。自于须陀洹果中生智慧。亦不住是中。亦教他人令得须陀洹果。乃至阿罗汉亦如是。自于辟支佛道中生智慧亦不住是中。亦教他人令得辟支佛道。自生阿耨多罗三藐三菩提道。亦教他人令生阿耨多罗三藐三菩提道。如是须菩提。菩萨摩诃萨行菩萨道时。方便力故终不懈废。须菩提白佛言。世尊。若诸法性常空。常空中众生不可得。法非法亦不可得。菩萨摩诃萨云何求一切种智。佛告须菩提。如是如是。如汝所言。诸法性皆空。空中众生不可得。法非法亦不可得。须菩提。若一切法性不空。菩萨摩诃萨。不依性空成阿耨多罗三藐三菩提。为众生说性空法。须菩提。色性空受想行识性空。菩萨摩诃萨。行般若波罗蜜时。说五阴性空法。说十二入十八界性空法。说四禅四无量心四无色定四念处乃至八圣道分性空法。说三解脱门八背舍九次第定佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好性空法。说须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道一切种智断烦恼习性空法。须菩提。若内空性不空。外空乃至无法有法空性不空者。则坏空性。是性空不常不断。何以故。是性空无住处。亦无所从来亦无所从去。须菩提。是名法住相。是中无法无聚无散无增无减。无生无灭无垢无净。是为诸法相。菩萨摩诃萨住是中发阿耨多罗三藐三菩提心。不见法有所发。无发无住是名法住相。是菩萨摩诃萨行般若波罗蜜时。见一切法性空。不转阿耨多罗三藐三菩提。何以故。是菩萨不见有法能障碍。当何处生疑。是名阿耨多罗三藐三菩提性空。不得众生。不得我不得人。不得寿不得命。乃至不得知者见者。性空中色不可得。受想行识不可得。乃至八十随形好不可得。须菩提。譬如佛化作四众比丘比丘尼优婆塞优婆夷。常为是诸众说法千万亿劫不断。佛告须菩提。是诸化众。当得须陀洹果斯陀含果阿那含果阿罗汉果。得阿耨多罗三藐三菩提记不。须菩提言。不也世尊。何以故。是诸化众。无有根本实事故。一切诸法性空亦无根本实事。何等是众生。得须陀洹果乃至阿罗汉果。得阿耨多罗三藐三菩提记。须菩提。菩萨摩诃萨亦如是。为众生说性空法。是众生实不可得。以众生堕颠倒故。拔众生令住不颠倒。颠倒即是无颠倒。颠倒不颠倒虽一相。而多颠倒少不颠倒。无颠倒处中则无我无众生。乃至无知者见者。无颠倒处中亦无色无受想行识。无十二入乃至无阿耨多罗三藐三菩提。是名诸法性空。菩萨摩诃萨住是中行般若波罗蜜时。于众生相颠倒中拔出众生。所谓无众生。有众生相中拔出。乃至知者见者相中拔出。于无色色相中无受想行识受想行识相中拔出众生。十二入十八界乃至一切有漏法亦如是。须菩提。亦有诸无漏法。所谓四念处四正勤四如意足五根五力七觉分八圣道分。如是等法虽无漏法。亦不如第一义相。第一义相者。无作无为无生无相无说。是名第一义亦名性空亦名诸佛道。是中不得众生乃至不得知者见者。不得色受想行识乃至不得八十随形好。何以故。菩萨摩诃萨。非为道法故求阿耨多罗三藐三菩提心。为诸法实相性空故求阿耨多罗三藐三菩提。是性空前际亦是性空。后际亦是性空。中际亦是性空。常性空无不性空时。菩萨摩诃萨行是性空般若波罗蜜。为众生种种着相欲拔出故求道种智。求道种智时遍行一切道。若声闻道若辟支佛道若菩萨道。是菩萨具足一切道。拔出众生于邪想着。净佛国土已随其寿命。得阿耨多罗三藐三菩提。须菩提。过去十方诸佛道所谓性空。未来现在十方诸佛道亦性空。离性空世间无道无道果。要从亲近诸佛闻是诸法性空。行是法不失萨婆若。须菩提白佛言。世尊。甚希有诸菩萨摩诃萨。有行是性空法亦不坏性空相。所谓色与性空异。受想行识与性空异。乃至阿耨多罗三藐三菩提与性空异。须菩提。色即是性空性空即是色。乃至阿耨多罗三藐三菩提。阿耨多罗三藐三菩提即是性空。性空即是阿耨多罗三藐三菩提。佛告须菩提。若色与性空异。若受想行识与性空异。乃至阿耨多罗三藐三菩提与性空异。菩萨摩诃萨不能得一切种智。须菩提。今色不异性空。乃至阿耨多罗三藐三菩提不异性空。以是故。菩萨摩诃萨知一切法性空。发意求阿耨多罗三藐三菩提。何以故。是中无有法若实若常。但凡夫着色受想行识。凡夫取色相取受想行识相。有我心着内外法故。受后身色受想行识。以是因缘故。不得脱生老病死愁忧苦恼往来五道。以是事故。菩萨摩诃萨行性空波罗蜜。不坏色等诸法相若空若不空。何以故。色性空相不坏色。所谓是色是空是受想行识。乃至阿耨多罗三藐三菩提亦如是。譬如虚空不坏虚空。内虚空不坏外虚空。外虚空不坏内虚空。如是须菩提。色不坏色空相。色空相不坏色。何以故。是二法无有性能有所坏。所谓是空是非空。乃至阿耨多罗三藐三菩提亦如是。须菩提白佛言。世尊。若一切法空无分别。云何菩萨摩诃萨从初发意以来。作是愿。我当得阿耨多罗三藐三菩提。世尊。若一切法无分别。云何菩萨发心言。我当得阿耨多罗三藐三菩提。世尊。若分别诸法。不能得阿耨多罗三藐三菩提。佛告须菩提。如是如是。若菩萨摩诃萨行二相者。无阿耨多罗三藐三菩提。若分别作二分者。无阿耨多罗三藐三菩提。若不二不分别诸法。则是阿耨多罗三藐三菩提。菩提是不二相不坏相。须菩提。是菩提不色中行。不受想行识中行。乃至菩提亦不菩提中行。何以故。色即是菩提菩提即是色。不二不分别。乃至十八不共法亦如是。是菩提非取故行非舍故行。须菩提白佛言。世尊。若菩萨摩诃萨菩提非取故行非舍故行。菩萨摩诃萨菩提何处行。佛告须菩提。于汝意云何。如佛所化人。在何处行。若取中行若舍中行。须菩提言。世尊。非取中行非舍中行。佛言。菩萨摩诃萨菩提亦如是。非取中行非舍中行。须菩提。于汝意云何。阿罗汉梦中菩提何处行。若取中行若舍中行不。不也世尊。非取中行非舍中行。世尊。阿罗汉毕竟不眠。云何梦中菩提若取中行若舍中行。须菩提。菩萨摩诃萨阿耨多罗三藐三菩提亦如是。非取中行非舍中行。所谓色中行乃至一切种智中行。世尊。将无菩萨摩诃萨不行十地。不行六波罗蜜。不行三十七助道法。不行十四空。不行诸禅定解脱三昧。不行佛十力乃至八十随形好。住五神通。净佛国土成就众生。得阿耨多罗三藐三菩提。佛告须菩提。如是如是如汝所言。今菩萨离菩提无处行。若不具足十地六波罗蜜四禅四无量心四无色定四念处。乃至八圣道分空无相无作。佛十力乃至八十随形好。常舍行不诳法不错谬法。不具足是诸法。终不得阿耨多罗三藐三菩提。是菩萨摩诃萨住色相中。住受想行识相中。乃至住阿耨多罗三藐三菩提相中。能具足十地。乃至得阿耨多罗三藐三菩提。是相常寂灭。无有法能增能减能生能灭能垢能净能得道能得果。世谛法故。菩萨摩诃萨得阿耨多罗三藐三菩提。非第一实义。何以故。第一义中无有色乃至无阿耨多罗三藐三菩提。亦无行阿耨多罗三藐三菩提者。是一切法皆以世谛故说。非第一义。须菩提。菩萨摩诃萨。从初发意以来。行阿耨多罗三藐三菩提。菩提亦不增众生亦不减。菩萨亦不增减。须菩提。于意云何。若人初得道时。住无间三昧得无漏根成就若须陀洹果若斯陀含果若阿那含果若阿罗汉果。汝尔时有所得若梦若心若道若道果不。须菩提言。世尊不得也。佛言须菩提。云何当知得阿罗汉道者。世尊。世谛法故分别名阿罗汉道。佛言。如是如是。须菩提。世谛故说名菩萨。说名色受想行识乃至一切种智。是菩提中无法可得若增若减。以诸法性空故。诸法性空尚不可得。何况得初地心乃至十地心六波罗蜜三十七助道法空三昧无相无作三昧。乃至一切佛法当有所得无有是处。如是须菩提。菩萨摩诃萨行阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提利益众生

    摩诃般若波罗蜜经具足品第八十一(丹照明品)

须菩提白佛言。世尊。若菩萨摩诃萨行六波罗蜜十八空三十七助道法。佛十力四无所畏四无碍智十八不共法。不具足菩萨道不能得阿耨多罗三藐三菩提。世尊。菩萨摩诃萨。当云何具足菩萨道。能得阿耨多罗三藐三菩提。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。以方便力故行檀那波罗蜜。不得施不得施者不得受者。亦不远离是法行檀那波罗蜜。是则照明菩萨道。如是须菩提。菩萨以方便力故具足菩萨道。具足已能得阿耨多罗三藐三菩提。持戒忍辱精进禅定智慧。乃至十八不共法亦如是。舍利弗白佛言。世尊。云何菩萨摩诃萨习般若波罗蜜。佛告舍利弗。若菩萨摩诃萨行般若波罗蜜。以方便力故。不坏色不随色。何以故。是色性无故不坏不随。乃至受想行识亦如是。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力故檀那波罗蜜不坏不随。何以故。檀那波罗蜜性无故。乃至十八不共法亦如是。舍利弗白佛言。世尊。若诸法无自性可坏可随者。云何菩萨摩诃萨。能习般若波罗蜜诸菩萨摩诃萨所学处。何以故。菩萨摩诃萨不学般若波罗蜜。不能得阿耨多罗三藐三菩提。佛告舍利弗。如汝所言。菩萨不学般若波罗蜜。不能得阿耨多罗三藐三菩提。不离方便力故可得。舍利弗。若菩萨摩诃萨行般若波罗蜜。若有一法性可得应当取。若不可得何所取。所谓此是般若波罗蜜。是禅那波罗蜜。是毗梨耶波罗蜜。是羼提波罗蜜尸罗波罗蜜檀那波罗蜜。是色受想行识乃至是阿耨多罗三藐三菩提。舍利弗。是般若波罗蜜不可取相。乃至一切诸佛法不可取相。舍利弗。是名不取般若波罗蜜乃至佛法。是菩萨摩诃萨所应学。菩萨摩诃萨于是中学时。学相亦不可得。何况般若波罗蜜。佛法菩萨法辟支佛法声闻法凡夫人法。何以故。舍利弗。诸法无一法有性。如是无性诸法。何等是凡夫人须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。若无是诸贤圣云何有法。以是法故分别说是凡夫人须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。舍利弗白佛言。世尊。若诸法无性无实无根本。云何知是凡夫人乃至是佛。佛告舍利弗。凡夫人所著处。色有性有实不。不也世尊。但以颠倒心故。受想行识乃至十八不共法亦如是。舍利弗。菩萨摩诃萨。行般若波罗蜜时。以方便力故。见诸法无性无根本故。能发阿耨多罗三藐三菩提心。舍利弗白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜时。以方便力故。见诸法无性无根本故。能发阿耨多罗三藐三菩提心。佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。不见诸法根本住中退没生懈怠心。舍利弗。今诸法根本。实无我无所有性常空。但颠倒愚痴故众生着阴入界。是菩萨摩诃萨见诸法无所有性常空自相空时。行般若波罗蜜自立。如幻师为众生说法。悭者为说布施法。破戒者为说持戒法。嗔者为说忍辱法。懈怠者为说精进法。乱者为说禅定法。愚痴者为说智慧法。令众生住布施乃至智慧。然后为说圣法能出苦。用是法故得须陀洹果。乃至得阿罗汉果辟支佛道乃至阿耨多罗三藐三菩提。舍利弗白佛言。世尊。菩萨摩诃萨得是众生无所有。教令布施持戒乃至智慧。然后为说圣法能出苦。以是法故得须陀洹果乃至阿耨多罗三藐三菩提。佛告舍利弗。菩萨摩诃萨。行般若波罗蜜时。无有有所得过罪。何以故。舍利弗。是菩萨摩诃萨行般若波罗蜜时不得众生。但空法相续故。名为众生。舍利弗。菩萨摩诃萨住二谛中。为众生说法世谛第一义谛。舍利弗。二谛中众生虽不可得。菩萨摩诃萨行般若波罗蜜。以方便力故。为众生说法。众生闻是法今世吾我尚不可得。何况当得阿耨多罗三藐三菩提者及所用法。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。以方便力故为众生说法。舍利弗白佛言。世尊。是菩萨摩诃萨心旷大无有法可得若一相若异相若别相。而能如是大誓庄严。用是庄严故。不生欲界不生色界。不生无色界。不见有为性不见无为性。而于三界中度脱众生亦不得众生。何以故。众生不缚不解。众生不缚不解故无垢无净。无垢无净故无分别五道。无分别五道故无业无烦恼。无业无烦恼故亦不应有果报。以是果报故生三界中。佛告舍利弗。如是如是。如汝所言。若众生先有后无。诸佛菩萨则有过罪。诸法五道生死亦如是。若先有后无。诸佛菩萨则有过罪。舍利弗。今有佛无佛。诸法相常住不异。是法相中。尚无我无众生无寿命乃至无知者无见者。何况当有色受想行识。若无是法。云何当有五道往来拔出众生处。舍利弗。是诸法性常空。以是故。诸菩萨摩诃萨从过去佛闻是法相。发阿耨多罗三藐三菩提意。是中无有法我当得亦无有众生定着处法不可出。但以众生颠倒故着。以是故。菩萨摩诃萨发大誓庄严。常不退阿耨多罗三藐三菩提。是菩萨不疑我当不得阿耨多罗三藐三菩提。我必当得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。用实法利益众生令出颠倒。舍利弗。譬如幻师幻作百千万亿人。与种种饮食令饱满。欢喜唱言我得大福。于汝意云何。是中有人食饮饱满不。不也世尊。佛言如是。舍利弗。菩萨摩诃萨从初发意以来。行六波罗蜜四禅四无量心四无色定四念处乃至八圣道分十四空三解脱门八背舍九次第定。佛十力乃至十八不共法。具足菩萨道成就众生净佛国土。无众生法可度。须菩提白佛言。世尊。何等是菩萨摩诃萨道。菩萨行是道能成就众生净佛国土。佛告须菩提。菩萨摩诃萨。从初发意以来。行檀那波罗蜜。行尸罗羼提毗梨耶禅那般若波罗蜜。乃至行十八不共法。成就众生净佛国土。须菩提白佛言。世尊。云何菩萨摩诃萨。行檀那波罗蜜成就众生。佛告须菩提。有菩萨摩诃萨。行檀那波罗蜜时。自布施亦教众生布施。作是言诸善男子。汝等莫着布施。汝着布施故当更受身。受身故多受众苦。诸善男子。诸法相中无所施无施者无受者。是三法性皆空是性空法不可取。不可取相是性空。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。布施众生。是中不得布施不得施者不得受者。何以故。无所得波罗蜜是名为檀那波罗蜜。是菩萨不得是三法故。能教众生令得须陀洹果。乃至令得阿罗汉果辟支佛道阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀那波罗蜜时成就众生。是菩萨自行布施亦教他人行布施。赞叹布施法。欢喜赞叹行布施者。是菩萨如是布施已。生刹利大姓婆罗门大姓居士大家。若作小王若转轮圣王。是时以四事摄取众生。何等四。布施爱语利行同事。是四事摄取众生已。众生渐渐住于戒四禅四无量心四无色定四念处八圣道分空无相无作三昧。得入正位中。得须陀洹果。乃至得阿罗汉果。若得辟支佛道。若教令得阿耨多罗三藐三菩提。作是言。诸善男子。汝等当发阿耨多罗三藐三菩提心是阿耨多罗三藐三菩提易得耳。何以故。无有定法众生所著处。但颠倒故众生着处。是故汝等自离生死亦当教他离生死。汝等当发心能自利益亦当得利益他人。须菩提。菩萨摩诃萨应如是行檀那波罗蜜。是行檀那波罗蜜因缘故。从初发意以来终不堕恶道。常作转轮圣王。何以故。随其所种得大果报。是菩萨作转轮圣王时。见有乞者不作是念。我为余事故受转轮圣王果。但为利益一切众生故。是时作是言。此是汝物汝自取之。莫有所难我无所惜。我为众生故受生死。怜愍汝等故具足大悲。行是大悲饶益众生。亦不得实定众生相。但有假名字故。可说是众生。是名字亦空如响声实不可说相。须菩提。菩萨摩诃萨应如是行檀那波罗蜜。于众生中无所惜。乃至不惜自身肌肉何况外物。以是法故能出众生生死。何等是法。所谓檀那波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜乃至十八不共法。令众生从生死中得脱。复次须菩提。菩萨摩诃萨住檀那波罗蜜中。布施已作是言。诸善男子。汝等持戒来。我当供给汝等令无所乏短。衣食卧具乃至资生所须。尽当给汝。汝等乏少故破戒。我当给汝所须令无所乏。若饮食乃至七宝。汝等住是戒律仪中渐渐当得尽苦。成于三乘而得度脱。若声闻乘辟支佛乘佛乘。复次须菩提。菩萨摩诃萨住檀那波罗蜜中若见众生嗔恼。作是言。诸善男子。汝等以何因缘故嗔恼。我当与汝所须。汝等所欲从我取之。悉当给汝令无所乏。若饮食衣服乃至资生所须。是菩萨住檀那波罗蜜中教众生忍辱。作是言。一切法中无有坚实。汝等所嗔是因缘亦空无坚实。皆从虚妄忆想生。汝以无根本嗔恚坏心。恶口骂詈刀杖相加以至害命。汝等莫以是虚妄法起嗔。故堕地狱畜生饿鬼中及余恶道受无量苦。汝等莫以是虚妄无实诸法故而作罪业。以是罪业故尚不得人身。何况得生佛世。诸人佛世难值人身难得。汝等莫失好时。若失好时则不可救。是菩萨摩诃萨如是教化众生。自行忍辱亦教他人令行忍辱。赞叹忍辱法欢喜赞叹行忍辱者。是菩萨令众生住忍辱中。渐以三乘得尽众苦。如是须菩提。菩萨摩诃萨住檀那波罗蜜。令众生住忍辱。须菩提。云何菩萨摩诃萨住檀那波罗蜜。令众生精进。须菩提。菩萨见众生懈怠如是言。汝等何以懈怠。众生言因缘少故。是菩萨行檀那波罗蜜时语诸人言。我当令汝因缘具足。若布施若持戒若忍辱。如是等因缘故令汝具足。是众生得菩萨利益因缘故。身精进口精进心精进。身精进口精进心精进故。一切善法具足修圣无漏法。修圣无漏法故当得须陀洹果乃至阿罗汉果辟支佛道。若得阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。住精进波罗蜜摄取众生。须菩提。云何菩萨摩诃萨行檀那波罗蜜时。教化众生令修禅那波罗蜜。佛告须菩提言。菩萨见众生乱心作是言。汝等可修禅定。众生言。我等因缘不具足故。菩萨言。我当与汝等作因缘。以是因缘故令汝心不随觉观心不驰散众生以是因缘故。断觉观入初禅二禅三禅四禅。行慈悲喜舍心。众生以是禅无量心因缘故。能修四念处乃至八圣道分。修三十七助道法时。渐入三乘而般涅槃终不失道。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。以檀那波罗蜜摄取众生令行禅那波罗蜜。须菩提。云何菩萨摩诃萨行檀那波罗蜜。以般若波罗蜜摄取众生。须菩提。菩萨见众生愚痴无有智慧作是言。汝等何以故不修智慧。众生言因缘未具足故。菩萨住檀那波罗蜜中。作是言。汝等所须得智慧具足从我取之。所谓布施持戒忍辱精进入禅定。是因缘具足已。汝等如是思惟。思惟般若波罗蜜时有法可得不。若我若众生若寿命乃至知者见者可得不。若色受想行识若欲界色界无色界。若六波罗蜜若三十七助道法。若须陀洹果若斯陀含阿那含阿罗汉果辟支佛道。若阿耨多罗三藐三菩提可得不。是众生如是思惟时。于般若波罗蜜中无有法可得可着处。若不着诸法是时不见法有生有灭有垢有净。不分别是地狱是畜生是饿鬼是阿修罗众是天是人。是持戒是破戒。是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是佛。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。以般若波罗蜜摄取众生。须菩提。云何菩萨摩诃萨住檀那波罗蜜中。以尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜乃至三十七助道法摄取众生。须菩提。菩萨摩诃萨住檀那波罗蜜中以供养具利益众生。以是利益因缘故。众生能修四念处四正勤四如意足五根五力七觉分八圣道分。众生行是三十七助道法于生死中得解脱。如是须菩提。菩萨摩诃萨以无漏圣法摄取众生。复次须菩提。菩萨摩诃萨教化众生时。如是言。诸善男子汝等从我取所须物。若饮食衣服卧具香华。乃至七宝等种种资生所须汝当以是摄取众生。汝等长夜利益安乐莫作是念。是物非我所有。我长夜为众生故集此诸物。汝等当取是物如己物无异。教化众生令行布施持戒忍辱精进禅定智慧。乃至令得三十七助道法佛十力乃至十八不共法。亦令得诸无漏果。所谓须陀洹果乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀那波罗蜜时。应如是教化众生令得离三恶道及一切生死往来苦。复次须菩提。菩萨摩诃萨住尸罗波罗蜜。教化众生作是语。众生汝等少何因缘故破戒。我当与汝作具足因缘。若布施乃至智慧。及种种资生所须。是菩萨摩诃萨住尸罗波罗蜜。利益众生令行十善远离十不善道。是诸众生持诸戒不破戒不缺戒不浊戒不杂戒不取戒。渐以三乘而得尽苦。尸罗波罗蜜为首。如檀那波罗蜜说。余四波罗蜜亦如是

摩诃般若波罗蜜经卷第二十五摩诃般若波罗蜜经卷第二十六

        后秦龟兹国三藏鸠摩罗什译

    净土品第八十二(丹本净佛国品)

尔时须菩提作是念。何等是菩萨摩诃萨道。菩萨住是道能作如是大誓庄严。佛知须菩提心所念。告须菩提。六波罗蜜是菩萨摩诃萨道。三十七助道法是菩萨摩诃萨道。十八空是菩萨摩诃萨道。八解脱九次第定是菩萨摩诃萨道。佛十力乃至十八不共法是菩萨摩诃萨道。一切法亦是菩萨摩诃萨道。须菩提。于汝意云何。颇有法菩萨所不学。能得阿耨多罗三藐三菩提不。须菩提。无有法菩萨所不应学者。何以故。若菩萨不学一切法。不能得一切种智。须菩提白佛言。世尊。若一切法空。云何言菩萨学一切法。将无世尊无戏论中作戏论耶。所谓是法是非法。是世间法是出世间法。是有漏是无漏。是有为是无为。是凡夫人法是阿罗汉法。是辟支佛法是佛法。佛告须菩提。如是如是。一切法实空。须菩提。若一切法不空者。菩萨摩诃萨不得阿耨多罗三藐三菩提。须菩提。今一切法实空故。菩萨摩诃萨能得阿耨多罗三藐三菩提。须菩提。如汝所言。若一切法空。将无佛于无戏论中作戏论。分别此彼是世间法是出世间法乃至是佛法。须菩提。若世间众生知一切法空。菩萨摩诃萨。不学一切法得一切种智。须菩提。今众生实不知一切法空。以是故。菩萨摩诃萨得阿耨多罗三藐三菩提已分别诸法为众生说。须菩提。于是菩萨道从初以来应如是思惟。一切诸法中定性不可得。但从和合因缘起法故有名字诸法。我当思惟诸法实性无所著。若六波罗蜜性若三十七助道法。若须陀洹果乃至阿罗汉果若辟支佛道若阿耨多罗三藐三菩提。何以故。一切法一切法性空。空不着空。空亦不可得。何况空中有着。须菩提。菩萨摩诃萨如是思惟。不着一切法而学一切法。住是学中观众生心行。是众生心在何处行。知众生虚妄不实中行。是时菩萨作是念。是众生着不实虚妄法易度耳。是时菩萨摩诃萨住般若波罗蜜中。以方便力故如是教化众生言。汝诸众生当行布施可得饶财。亦莫恃布施果而自贡高。何以故。是中无坚实法。持戒忍辱精进禅定智慧亦如是。诸众生行是法。可得须陀洹果乃至阿罗汉果辟支佛道佛道。莫念有是法。如是教化是名行菩萨道。于诸法无所著故。何以故。一切法无著相。以性无故性空故。须菩提。是菩萨摩诃萨如是行菩萨道时无所住。是菩萨用不住法故。行檀那波罗蜜亦不住是中。行尸罗波罗蜜亦不住是中。行羼提波罗蜜亦不住是中。行毗梨耶波罗蜜亦不住是中。行禅那波罗蜜亦不住是中。行般若波罗蜜亦不住是中。行初禅亦不住是中。何以故。是初禅初禅相空。行禅者亦空。所用法亦空。第二第三第四禅亦如是。慈悲喜舍四无色定八解脱九次第定亦如是。得须陀洹果亦不住是中。得斯陀含果阿那含果阿罗汉果亦不住是中。得辟支佛道亦不住是中。须菩提白佛言。世尊。何因缘故不住是中。佛言。二因缘故不住是中。何等二。一者诸道果性空无住处。亦无所用法亦无住者。二者不以少事为足。作是念。我不应不得须陀洹果。我必应当得须陀洹果。我但不应是中住。乃至辟支佛道我不应不得。我必应当得。我但不应是中住。乃至得阿耨多罗三藐三菩提不应住。何以故。我从初发意以来更无余心。一心向阿耨多罗三藐三菩提。须菩提。菩萨一心向阿耨多罗三藐三菩提中远离余心。所作身口意业皆应阿耨多罗三藐三菩提。须菩提。是菩萨摩诃萨住是一心能生菩提道。须菩提白佛言。世尊。若一切诸法不生。云何菩萨摩诃萨能生菩提道。佛告须菩提。如是如是。一切法无生。云何无生。无所作无所起者。一切法不生。须菩提白佛言。世尊。有佛无佛诸法法相不常住耶。佛言。如是如是。有佛无佛是诸法法相常住。以众生不知是法住法相。为是故菩萨摩诃萨为众生故生菩提道。用是道拔出众生生死。须菩提白佛言。世尊。用生道得菩提。佛言不也。世尊。用不生道得菩提。佛言不也。世尊。用不生非不生得菩提。佛言不也。须菩提言。世尊。云何当得菩提。佛言。非用道得菩提。亦不用非道得菩提。须菩提。菩提即是道。道即是菩提。须菩提白佛言。世尊。若菩提即是道。道即是菩提。若尔者今菩萨未作佛时。应当得阿耨多罗三藐三菩提。云何说诸佛多陀阿伽度阿罗诃三藐三佛陀。有三十二相八十种随形好十力四无所畏四无碍智十八不共法大慈大悲。佛告须菩提。于汝意云何。佛得菩提不。不也世尊。佛不得菩提。何以故。佛即是菩提。菩提即是佛。如须菩提所问。菩萨时亦应得菩提。须菩提。是菩萨摩诃萨具足六波罗蜜。具足三十七助道法。具足佛十力四无所畏四无碍智十八不共法。具足住如金刚三昧。用一念相应慧得阿耨多罗三藐三菩提。是时名为佛一切法中得自在。须菩提白佛言。世尊。云何菩萨摩诃萨净佛国土。佛言。有菩萨从初发意以来。自除身粗业除口粗业。除意粗业。亦净他人身口意粗业。世尊。何等是菩萨摩诃萨身粗业口粗业意粗业。佛告须菩提。不善业若杀生乃至邪见。是名菩萨摩诃萨身口意粗业。复次须菩提。悭贪心破戒心嗔心懈怠心乱心愚痴心。是名菩萨意粗业。复次戒不净。是名菩萨身口粗业。复次须菩提。若菩萨远离四念处行。是名菩萨粗业。远离四正勤四如意足五根五力七觉分八圣道分空三昧无相无作三昧。亦名菩萨粗业。复次须菩提。菩萨摩诃萨贪须陀洹果证。乃至贪阿罗汉果证辟支佛道。是名菩萨摩诃萨粗业。复次须菩提。菩萨取色相受想行识相。眼耳鼻舌身意相。色声香味触法相男相女相。欲界相色界相无色界相。善法相不善法相。有为法相无为法相。是名菩萨粗业。菩萨摩诃萨皆远离如是粗业相。自布施亦教他人布施。须食与食须衣与衣。乃至种种资生所须尽给与之。亦教他人种种布施。持是福德与一切众生共之。回向净佛国土故。持戒忍辱精进禅定智慧亦如是。是菩萨摩诃萨或以三千大千国土满中珍宝施与三尊。作是愿言。我以善根因缘故令我国土皆以七宝成。复次须菩提。菩萨摩诃萨以天妓乐。乐佛及塔作是愿言。以是善根因缘。令我国土中常闻天乐。复次须菩提。菩萨摩诃萨以三千大千国土满中天香。供养诸佛及诸佛塔作是愿言。以是善根因缘。令我国土中常有天香。复次须菩提。菩萨摩诃萨以百味食。施佛及僧作是愿言。以是善根因缘故令我国土中众生皆得百味食。复次须菩提。菩萨摩诃萨以天香细滑施佛及僧作是愿言。以是善根因缘故令我国土中一切众生受天香细滑。复次须菩提。菩萨摩诃萨以随意五欲。施佛及僧并一切众生作是愿言。以是善根因缘故。令我国土中弟子及一切众生皆得随意五欲。是菩萨以随意五欲。共一切众生回向净佛国土。作是愿。言。我得佛时是国土中如天五欲应心而至。复次须菩提。菩萨摩诃萨行般若波罗蜜时。作是愿言。我当自入初禅亦教一切众生入初禅第二第三第四禅慈悲喜舍心。乃至三十七助道法亦如是。我得阿耨多罗三藐三菩提时。令一切众生不远离四禅。乃至不远离三十七助道法。如是须菩提。菩萨摩诃萨能净佛国土。是菩萨随尔所时行菩萨道满足诸愿。是菩萨自成就一切善法。亦成就一切众生善法。是菩萨受身端正。所化众生亦得端正。所以者何。福德因缘厚故。须菩提。菩萨摩诃萨应如是净佛国土。是国土中乃至无三恶道之名。亦无邪见三毒二乘声闻辟支佛之名。耳不闻有无常苦空之声。亦无我所有。乃至无诸结使烦恼之名。亦无分别诸果之名。风吹七宝之树随所应度而出音声。所谓空无相无作。如诸法实相之音。有佛无佛一切法相一切法相空。空中无有相。无相中则无可作出。如是法音。若昼若夜若坐若卧若立若行常闻此法。是菩萨得阿耨多罗三藐三菩提时。十方国土中诸佛赞叹众生闻是佛名。必至阿耨多罗三藐三菩提。是佛得阿耨多罗三藐三菩提时说法。众生闻者。无有不信而生疑言是法是非法。何以故。诸法实相中皆是法无有非法。诸有薄福之人于诸佛及弟子中。不种善根不随善知识。没在我见中。乃至没在一切种种见中。堕在边见若断若常。如是人以邪见故。非佛言佛佛言非佛。如是人非法言法法言非法。如是人破法故身坏命终堕恶道地狱中。诸佛得阿耨多罗三藐三菩提时。见此众生往来五道。令离邪聚立正定聚中更不堕恶道。如是须菩提。菩萨摩诃萨净佛国土中众生无杂秽心。若世间法若出世间法。若有漏若无漏。若有为若无为。乃至是国土中众生必至阿耨多罗三藐三菩提。须菩提。是为菩萨摩诃萨净佛国土

    摩诃般若波罗蜜经毕定品第八十三

须菩提白佛言。世尊是菩萨摩诃萨为毕定为不毕定。佛告须菩提。菩萨摩诃萨毕定非不毕定。世尊。何处毕定。为声闻道中。为辟支佛道中。为佛道中。佛言。菩萨摩诃萨非声闻辟支佛道中毕定。是佛道中毕定。须菩提白佛言。世尊。为初发意菩萨毕定。为最后身菩萨毕定。佛言。初发意菩萨亦毕定。阿惟越致菩萨亦毕定。后身菩萨亦毕定。世尊。毕定菩萨堕恶道中生不。不也须菩提。于汝意云何。若八人若须陀洹斯陀含阿那含阿罗汉辟支佛生恶道中不。不也世尊。如是须菩提。菩萨摩诃萨从初发意已来布施持戒忍辱精进行禅定修智慧断一切不善业。若堕恶道若生长寿天。若不得修善法处。若生边国若生恶邪见家无作见家。是中无佛名无法名无僧名无有是处。须菩提。初发意菩萨于阿耨多罗三藐三菩提。以深心行十不善道无有是处。世尊。若菩萨摩诃萨有如是善根功德成就。如佛自说本生受不善果报。是时善根为何所在。佛告须菩提。菩萨摩诃萨为利益众生故随而受身。以是身利益众生。须菩提。菩萨摩诃萨作畜生时有是方便力。若怨贼欲来杀害。以是无上忍辱无上慈悲心。舍身不恼恶贼。汝诸声闻辟支佛无有是力。以是故。须菩提。当知菩萨摩诃萨欲具足大慈心。为怜愍利益众生故受畜生身。须菩提白佛言。世尊。菩萨摩诃萨住何等善根中受如是诸身。佛告须菩提。菩萨摩诃萨从初发意乃至道场。于其中间无有善根不具足者。具足已当得阿耨多罗三藐三菩提。以是故。菩萨摩诃萨从初发意。应当学具足一切善根。学善根已当得一切种智。当断一切烦恼习。须菩提白佛言世尊。云何菩萨摩诃萨成就如是白净无漏法。而生恶道畜生中。佛告须菩提。于汝意云何。佛成就白净无漏法不。须菩提言。佛一切白净无漏法成就。须菩提。若佛自化作畜生身。作佛事度众生实是畜生不。须菩提言不也。佛言。菩萨摩诃萨亦如是。成就白净无漏法。无度众生故受畜生身。用是身教化众生。佛告须菩提。如阿罗汉作变化身。能使众生欢喜不。须菩提言能。佛言。如是如是。须菩提。菩萨摩诃萨用是白净无漏法。随应度众生而受身。以是身利益众生亦不受苦。须菩提。于汝意云何。幻师幻作种种形若象马牛羊男女。如是等以示众生。须菩提。是象马牛羊男女等有实不。须菩提言。不也世尊。佛言。如是须菩提。菩萨摩诃萨白净无漏法成就。现作种种身以示众生故。以是身饶益一切亦不受苦。须菩提白佛言。世尊。菩萨摩诃萨大方便力。得圣无漏智慧而随所应度众生身。而作种种形以度众生。世尊。菩萨摩诃萨住何等白净法。能作如是方便而不受染污。佛言。菩萨用般若波罗蜜作如是方便力。于十方如恒河沙等国土中。饶益众生亦不贪着是身。何以故。著者着法着处。是三法皆不可得自性空故。空不着空空中无著者亦无著处。何以故。空中空相不可得。须菩提。是名不可得空。菩萨住是中能得阿耨多罗三藐三菩提。世尊。菩萨但住般若波罗蜜中得阿耨多罗三藐三菩提。不住余法中耶。须菩提。颇有法不入般若波罗蜜者不。世尊。若般若波罗蜜自性空。云何一切法皆入般若波罗蜜中。世尊。空中无有法若入若不入。须菩提。一切法一切法相空不。世尊空。须菩提。若一切法一切法相空。云何言一切法不入空中。须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜时。住一切法空中能起神通波罗蜜。住是神通波罗蜜中。到十方如恒河沙等国土。供养现在诸佛闻诸佛说法。于诸佛所种善根。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。观是十方如恒河沙等国土皆空。是国土中诸佛性亦空。但假名字故诸佛现身。所假名字亦空。若十方国土及诸佛性不空者空为有偏。以空不偏故一切法一切法相空。以是故。一切法一切法相空。是故菩萨摩诃萨行般若波罗蜜。用方便力生神通波罗蜜。住是神通波罗蜜中。起天眼天耳如意足知他心宿命智知众生生死。若菩萨远离神通波罗蜜不能得饶益众生。亦不能得阿耨多罗三藐三菩提。是菩萨摩诃萨神通波罗蜜。是阿耨多罗三藐三菩提利益道。何以故。用是天眼自见诸善法。亦教他人令得诸善法。于善法亦不着。诸善法自性空故。空无所著若着则受味。是空中无有味。是菩萨摩诃萨行般若波罗蜜时能生如是天眼。用是眼观一切法空。见是法空不取相不作业。亦为人说是法。亦不得众生相不得众生名。如是菩萨摩诃萨用无所得法故。起神通波罗蜜。用是神通波罗蜜。神通所应作者能作。是菩萨用天眼过于人眼见十方国土。见已飞到十方饶益众生。或以布施或以持戒或以忍辱或以精进或以禅定或以智慧饶益众生。或以三十七助道法。或以诸禅解脱三昧。或以声闻法或以辟支佛法或以菩萨法或以佛法饶益众生。为悭者如是说法。诸众生当行布施。贫穷是苦恼法。贫穷之人自不能益何能益他。以是故。汝等当勤布施。自身得乐亦能令他得乐。莫以贫穷故共相食啖不得离三恶道。为破戒者说法。诸众生破戒法大苦恼。破戒之人自不能益何能益他。破戒法受苦果报。若在地狱若在饿鬼若在畜生。汝等堕三恶道中。自不能救何能救人。以是故。汝等不应堕破戒心死时有悔。若有共相嗔诤者如是说法。诸众生莫共相嗔。嗔乱人心不顺善法。汝等今共相嗔乱心。或堕地狱若饿鬼畜生中。以是故。汝等不应生一念嗔恚心何况多。为懈怠众生说法令得精进。散乱众生令得禅定。愚痴众生令得智慧亦如是。行淫欲者令观不净。嗔恚令观慈心。愚痴众生令观十二因缘。行非道众生令入正道。所谓声闻道辟支佛道佛道。为是众生如是说法。如汝等所著是法性空。性空法中不可得着。不着相是空相。如是须菩提。菩萨摩诃萨行般若波罗蜜时。住神通波罗蜜中。为众生作利益。须菩提。菩萨若远离神通。不能随众生意善说法。以是故。须菩提。菩萨摩诃萨行般若波罗蜜时应起神通。须菩提。譬如鸟无翅不能高翔。菩萨无神通不能随意教化众生。以是故。须菩提。菩萨摩诃萨行般若波罗蜜应起诸神通。起诸神通已若欲饶益众生随意能益。是菩萨用天眼见如恒河沙等诸国土。及见是国土中众生。见已。以神通力往到其所。知众生心随其所应而为说法。或说布施或说持戒或说禅定。乃至说涅槃法。是菩萨用天耳闻二种音声若人若非人。用天耳闻十方诸佛所说法皆能受持。如所闻法为众生说。或说布施乃至说涅槃。是菩萨净他心智。用他心智知众生心。随其所应而为说法。或说布施乃至或说涅槃。是菩萨宿命智种种本生处忆念。亦自忆亦忆他人。用是宿命智念过去在在处处诸佛名字及弟子众。有众生信乐宿命者。为现宿命事而为说法。或说布施乃至或说涅槃。用如意神通力到种种无量诸佛国土。供养诸佛从诸佛种善根还来本国。是菩萨漏尽神通智证。用是漏尽神通智证故。为众生随应说法。或说布施乃至或说涅槃。如是须菩提。菩萨摩诃萨行般若波罗蜜时。应如是起诸神通。菩萨用修是神通故。随意受身苦乐不染。譬如佛所化人作一切事苦乐不染。菩萨摩诃萨行般若波罗蜜时。应如是游戏神通。能净佛国土成就众生。复次须菩提。菩萨摩诃萨不净佛国土不成就众生。不能得阿耨多罗三藐三菩提。何以故。因缘不具足故不能得阿耨多罗三藐三菩提。须菩提白佛言。世尊。何等是菩萨摩诃萨因缘具足已。得阿耨多罗三藐三菩提。佛告须菩提。一切善法是菩萨阿耨多罗三藐三菩提因缘。须菩提白佛言。世尊。何等是善法。以是善法故得阿耨多罗三藐三菩提。佛告须菩提。菩萨从初发意已来。檀那波罗蜜是善法因缘。是中无分别是布施者是受者性空故。用是檀那波罗蜜能自利益亦能利益众生。从生死拔出令得涅槃。是诸善法皆是菩萨摩诃萨阿耨多罗三藐三菩提因缘。行是道过去未来现在诸菩萨摩诃萨得度生死。已度今度当度。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜。四禅四无量心四无色定四念处乃至八圣道分十八空八解脱九次第定陀罗尼门佛十力四无所畏四无碍智十八不共法。如是等功德。皆是阿耨多罗三藐三菩提道。须菩提是名善法。菩萨摩诃萨具足是善法已当得一切种智。得一切种智已当转法轮。转法轮已当度众生

    摩诃般若波罗蜜经差别品第八十四(丹本作四谛品)

须菩提白佛言。世尊。若是诸法是菩萨法。何等是佛法。佛告须菩提。如汝所问。是诸法是菩萨法何等是佛法者。须菩提。菩萨法亦是佛法。若知一切种是得一切种智断一切烦恼习。菩萨当得是法。佛以一念相应慧知一切法已。得阿耨多罗三藐三菩提。须菩提。是为菩萨佛之差别。譬如向道得果异。是二人俱为圣人。而有得向之异。如是须菩提。若菩萨摩诃萨无碍道中行。是名菩萨。解脱道中无一切闇蔽。是名为佛。须菩提白佛言。世尊。若一切法自相空。自相空法中云何有差别之异。是地狱是饿鬼是畜生是天是人。是性地人是八人地是须陀洹人是斯陀含阿那含阿罗汉人是辟支佛是菩萨是多陀阿伽度阿罗诃三藐三佛陀。世尊。如诸人不可得。业因缘亦不可得。果报亦不可得。佛言。如是如是。如汝所言。自相空法中无众生。无业因缘无果报。须菩提。若有众生不知是诸法自相空。是众生作业因缘。若善若。恶若无动。罪业因缘故堕三恶道中。福业因缘故在人天中生。无动业因缘故色无色界中生。是菩萨摩诃萨行檀那波罗蜜乃至十八不共法时。尽受行是助道法入如金刚三昧。得阿耨多罗三藐三菩提。得已饶益众生。是利当不失故不堕五道生死中。须菩提白佛言。世尊。佛得阿耨多罗三藐三菩提已得六道生死不。佛言。不得也。须菩提言。世尊。得业若黑若白若黑白若不黑不白不。佛言不也。世尊。若不得云何说是地狱饿鬼畜生人天须陀洹乃至阿罗汉辟支佛菩萨诸佛。须菩提。若众生知诸法自相空。菩萨摩诃萨不求阿耨多罗三藐三菩提。亦不拔众生于三恶趣乃至五道往来生死中。须菩提。以众生实不知诸法自性空故。不得脱五道生死。是菩萨从诸佛所闻诸法自相空。发意求阿耨多罗三藐三菩提。须菩提。诸法不尔。如凡人所著是众生于无所有法中。颠倒妄想分别得法无众生有众生相。无色有色相。无受想行识有受想行识相。乃至一切有为法无所有。用颠倒妄想心。作身口意业因缘。往来五道生死中不得脱。是菩萨摩诃萨行般若波罗蜜时。一切善法内般若波罗蜜中。行菩萨道得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。为众生说四圣谛苦集苦灭苦灭道开示分别。一切助道善法皆入四圣谛中。用是助道善法故分别有三宝。何等三。佛宝法宝僧宝。不信拒逆是三宝故。不得离五道生死。须菩提白佛言。世尊。用苦圣谛得度。用苦智得度。用集圣谛得度。用集智得度。用灭圣谛得度。用灭智得度。用道圣谛得度。用道智得度。佛告须菩提。非苦圣谛得度。亦非苦智。乃至非道圣谛得度。亦非道智。须菩提。是四圣谛平等故我说即是涅槃。不以苦圣谛不以集灭道圣谛。亦不以苦智不以集灭道智得涅槃。须菩提白佛言。世尊。何等是四圣谛平等相。须菩提。若无苦无苦智。无集无集智。无灭无灭智。无道无道智。是名四圣谛平等相。复次须菩提。是四圣谛如。不异法相法性法住法位实际。有佛无佛法相常住为不诳不失故。是菩萨摩诃萨行般若波罗蜜时。为通达实谛故行般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨为通达实谛故。行般若波罗蜜如。通达实谛故不堕声闻辟支佛地。直入菩萨位中。佛告须菩提。若菩萨摩诃萨如实见诸法。见已得无所有法。得无所有法已见一切法空。四圣谛所摄四圣谛所不摄法皆空。若如是观是时便入菩萨位中。是为菩萨住性地中不从顶堕。用是顶堕故堕声闻辟支佛地。是菩萨住性中能生四禅四无量心四无色定。是菩萨住是初定地中分别一切诸法。通达四圣谛。知苦不生缘苦心。乃至知道不生缘道心。但顺阿耨多罗三藐三菩提心观诸法如实相。世尊。云何观诸法如实相。佛言。观诸法空。世尊。何等空观。佛言。自相空。是菩萨用如是智慧观一切法空。无法性可见。住是性中得阿耨多罗三藐三菩提。何以故。无性相是阿耨多罗三藐三菩提。非诸佛所作非辟支佛所作。亦非阿罗汉所作亦非向道人所作。亦非得果人所作亦非菩萨所作。但众生不知不见诸法如实相。以是事故菩萨摩诃萨行般若波罗蜜。以方便力故为众生说法

    摩诃般若波罗蜜经七譬品第八十五

须菩提白佛言。世尊。若诸法性无所有非佛所作。非辟支佛所作非阿罗汉所作。非阿那含斯陀含须陀洹所作。非向道人非得果人非菩萨所作。云何分别有诸法异是地狱是畜生是饿鬼是人是天。乃至是非有想非无想天。用是业因缘故知有生地狱者。是业因缘故知有生畜生饿鬼者。是业因缘故知有生人中生四天王天。乃至生非有想非无想天者。是业因缘故知有得须陀洹斯陀含阿那含阿罗汉辟支佛者。是业因缘故知是诸菩萨摩诃萨。是业因缘故知是多陀阿伽度阿罗诃三藐三佛陀。世尊。无性法中无有业用。作业因缘故若堕地狱饿鬼畜生。若人若天乃至生非有想非无想天。以是业因缘故得须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨摩诃萨行菩萨道当得一切种智。得一切种智故能拔出众生于生死中。佛告须菩提。如是如是。无性法中无业无果报。须菩提。凡夫人不入圣法。不知诸法无性相。颠倒愚痴故起种种业因缘。是诸众生随业得身。若地狱身若畜生身若饿鬼身若人身若天身四天王天身。乃至非有想非无想天身。是无性法无业无果报。无性常是无性。如须菩提所言。若一切法无性。云何是须陀洹乃至诸佛得一切种智。须菩提。于汝意云何。道是无性不。须陀洹果乃至诸佛一切种智是无性不。须菩提言。世尊。道无性须陀洹果亦无性。乃至诸佛一切种智亦无性。须菩提。无性法能得无性法不。不也世尊。佛告须菩提。有性法能得有性法不。不也世尊。须菩提。无性法及道是一切法皆不合不散。无色无形无对一相。所谓无相。须菩提。是菩萨摩诃萨行般若波罗蜜时。以方便力见众生。以颠倒故着五阴。无常中常相。苦中乐相。不净中净相。无我中我相。着无所有处。是菩萨以方便力故。于无所有中拔出众生。须菩提白佛言。世尊。凡夫人所著。颇有实不异不。着故起业。业因缘故五道生死中不得脱。佛告须菩提。凡夫人所著起业处。无如毛发许实事。但颠倒故。须菩提。今为汝说譬喻。智者以譬喻得解。须菩提。于汝意云何。如梦中所见人受五欲乐有实住处不。须菩提白佛言。世尊。梦尚虚妄不可得。何况住梦中受五欲乐。于汝意云何。诸法若有漏若无漏。若有为若无为。颇有不如梦者不。世尊。诸法若有漏若无漏若有为若无为。无不如梦者。佛告须菩提。于汝意云何。梦中有五道生死往来不。世尊无也。于汝意云何。梦中有修道用是修道若着垢若得净不。不也世尊。何以故。是梦法无有实事。不可说垢净。于汝意云何。镜中像有实事不。能起业因缘用是业因缘。堕地狱饿鬼畜生。若人若天四天王天处乃至非有想非无想天处不。须菩提言。不也世尊。是像无有实事但诳小儿。是事云何当有业因缘。用是业因缘当堕地狱乃至非有想非无想处。于汝意云何是镜中像有修道用是修道若着垢若得净不。须菩提言。不也世尊。何以故。是像空无实事。不可说垢净。于汝意云何。如深涧中有响。是响有业因缘。用是业因缘。若堕地狱乃至生非有想非无想处不。须菩提言。不也世尊。是事空无有实音声。云何当有业因缘用是业因缘。堕地狱乃至生非有想非无想处。于汝意云何。是响颇有修道用是修道若着垢若得净不。不也世尊。是事无实不可说是垢是净。于汝意云何。如焰非水水相非河河相。是焰颇有业因缘。用是业因缘堕地狱乃至生非有想非无想处不。不也世尊。焰中水毕竟不可得。但诳无智人眼。云何当有业因缘。用是业堕地狱乃至生非有想非无想处。于汝意云何。是焰有修道。用是修道若着垢若得净不。不也世尊。是焰无有实事不可说垢净。于汝意云何。犍闼婆城如日出时见犍闼婆城。无智人无城有城想。无庐馆有庐馆想。无园有园想。是揵闼婆城颇有业因缘。用是业因缘堕地狱乃至生非有想非无想处不。不也世尊。是揵闼婆城毕竟不可得。但诳愚夫眼。云何当有业因缘。用是业因缘堕地狱乃至生非有想非无想处。于汝意云何。如揵闼婆城有修道。用是修道若着垢若得净不。不也世尊。是揵闼婆城无有实事不可说垢净。须菩提。于汝意云何。幻师幻作种种物。若象若马若牛若羊若男若女。于汝意云何。是幻有业因缘。用是业因缘堕地狱乃至生非有想非无想处不。不也世尊。是幻法空无实事。云何当有业因缘。用是业因缘。堕地狱乃至生非有想非无想处。于汝意云何。是幻有修道。用是修道若着垢若得净不。不也世尊。是法无有实事不可说垢净。须菩提。于汝意云何。如佛所化人。是化人有业因缘。用是业因缘堕地狱乃至生非有想非无想处不。不也世尊。是化人无有实事。云何当有业因缘。用是业因缘。堕地狱乃至生非有想非无想处。于汝意云何。是化人有修道。用是修道若着垢若得净不。不也世尊。是事无有实不可说垢净。佛告须菩提。于汝意云何。于是空相中有垢者有净者不。不也世尊。是中无所有。无有着垢者无有净者。须菩提。如无有着垢者无有净者。以是因缘故亦无垢净。何以故。住我我所众生有垢有净。实见者不垢不净。如实见者不垢不净。如是亦无垢净

    摩诃般若波罗蜜经平等品第八十六

须菩提白佛言。世尊。见实者不垢不净。见不实者亦不垢不净。何以故。一切法性无所有故。世尊。无所有中无垢无净。有所有中亦无垢无净。世尊。无所有中有所有中亦无垢无净。世尊。云何如实语者不垢不净。不实语者亦不垢不净。佛告须菩提。是诸法平等相。我说是净。须菩提。何等是诸法平等。所谓如不异不诳法相法性法住法位实际。有佛无佛法性常住。是名净。世谛故说非最第一义。最第一义过一切语言论议音声。须菩提白佛言。世尊。若一切法空不可说。如梦如响如焰如影如幻如化。云何菩萨摩诃萨。用是如梦如响如焰如影如幻如化法。无有根本定实。云何能发阿耨多罗三藐三菩提心。作是愿我当具足檀那波罗蜜乃至具足般若波罗蜜。我当具足神通波罗蜜。具足智波罗蜜具足四禅四无量心四无色定四念处。乃至具足八圣道分。我当具足三解脱门八解脱九次第定。我当具足佛十力。乃至具足十八不共法。我当具足三十二相八十随形好。具足诸陀罗尼门诸三昧门。我当放大光明遍照十方。知诸众生心如应说法。佛告须菩提。于汝意云何。汝所说诸法。如梦如响如焰如影如幻如化不。须菩提言尔。世尊。世尊若一切法如梦乃至如化。菩萨摩诃萨云何行般若波罗蜜。世尊。是梦乃至化虚妄不实。世尊。不应用不实虚妄法能具足檀那波罗蜜乃至十八不共法。佛告须菩提。如是如是。不实虚妄法。不能具足檀那波罗蜜乃至十八不共法。行是不实虚妄法。不能得阿耨多罗三藐三菩提。须菩提。是一切法皆是忆想思惟作法。用是思惟忆想作法。不能得一切种智。须菩提。是一切法能助道。不能得益果。所谓是诸法无生无出无相。菩萨从初发心已来所作善业。若檀那波罗蜜乃至一切种智。何以故。知诸法皆如梦乃至如化。如是等法不具足檀那波罗蜜乃至一切种智。不能得成就众生净佛国土得阿耨多罗三藐三菩提。是菩萨摩诃萨所作善业。檀那波罗蜜乃至一切种智如梦乃至如化。亦知一切众生如梦中行。乃至知如化中行。是菩萨摩诃萨不取般若波罗蜜是有法。用是不取故得一切种智。知是诸法如梦无所取。乃至诸法如化无所取。何以故。般若波罗蜜是不可取相。禅那波罗蜜乃至十八不共法是不可取相。是菩萨摩诃萨知一切法是不可取相已。发心求阿耨多罗三藐三菩提。何以故。一切法不可取相。无根本定实。如梦乃至如化。用不可取相法。不能得不可取相法。但以众生不知不见如是诸法相。是菩萨摩诃萨为是众生故。求阿耨多罗三藐三菩提。是菩萨从初发意已来所有布施为一切众生故。乃至有所修智慧皆为一切众生不为己身。菩萨摩诃萨不为余事故。求阿耨多罗三藐三菩提。但为一切众生故。是菩萨行般若波罗蜜时。见众生无众生。但众生相中住乃至无知者无见者。知见相中住令众生远离颠倒。远离已置甘露性中。住是中无有妄想。所谓众生相乃至知者见者相。是时菩萨动心念心戏论心皆舍。常行不动心不念心不戏论心。须菩提。以是方便力故。菩萨摩诃萨行般若波罗蜜时自无所著。亦教一切众生令得无所著。世谛故非第一义。须菩提白佛言。世尊。世尊得阿耨多罗三藐三菩提时得诸佛法。以世谛故得。以第一义中得。佛言。以世谛故说佛得是法。是法中无有法可得。是人得是法。何以故。是人得是法是为大有所得。用二法无道无果。须菩提白佛言。世尊。若行二法无道无果。行不二法有道有果不。佛言。行二法无道无果。行不二法亦无道无果。若无二法无不二法。即是道即是果。何以故。用如是法得道得果。用如是法不得道不得果。是为戏论。诸平等法中无有戏论。无有戏论是诸法平等。须菩提白佛言。世尊。诸法无所有性。是中何等是平等。佛言。若无有有法无有无法。亦不说诸法平等相。除平等更无余法。离一切法平等相。平等相者若凡夫若圣人。不能行不能到。须菩提白佛言。世尊。乃至佛亦不能行亦不能到。佛言。是诸法平等一切圣人。皆不能行亦不能到。所谓诸须陀洹斯陀含阿那含阿罗汉辟支佛。诸菩萨摩诃萨及诸佛。须菩提白佛言。世尊。佛者一切诸法中行力自在。云何说佛亦不能行亦不能到。佛告须菩提。若诸法平等与佛有异。应当如是问。须菩提。今诸凡夫人平等。诸须陀洹斯陀含阿那含阿罗汉辟支佛。诸菩萨摩诃萨诸佛。及圣法皆平等。是一平等无二。所谓是凡夫人是须陀洹乃至佛。是一切法等中皆不可得。须菩提白佛言。世尊若诸法等中皆不可得。是凡夫人乃至是佛。世尊。凡夫人须陀洹乃至佛为无有分别。佛告须菩提。如是如是。诸法平等中无有分别。是凡夫人是须陀洹乃至是佛。世尊。若无分别诸凡夫人须陀洹乃至佛。云何分别有三宝。现于世佛宝法宝僧宝。佛言。于汝意云何。佛宝法宝僧宝与诸法等异不。须菩提白佛言。如我从佛所闻义。佛宝法宝僧宝与诸法等无异。世尊。是佛宝法宝僧宝即是平等。是法皆不合不散。无色无形无对一相。所谓无相。佛有是力能分别无相诸法处所。是凡夫人是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛。是菩萨摩诃萨是诸佛。佛告须菩提。如是如是。若诸佛得阿耨多罗三藐三菩提不分别诸法。当知是地狱是饿鬼是畜生是人是天。是四天王天乃至是他化自在天梵天。乃至是非有想非无想天处。是四念处乃至八圣道分。内空乃至无法有法空。佛十力乃至十八不共法不。须菩提言。不知也世尊。以是故。须菩提。当知佛有大恩力。于诸法等中不动而分别诸法。须菩提白佛言。世尊。如佛于诸法平等中不动。凡夫人亦于诸法平等中亦不动。须陀洹乃至辟支佛。亦于诸法平等中不动。世尊。若诸法等相即是凡夫人相即是须陀洹相。乃至诸佛即是平等相。世尊。今诸法各各相。所谓色相异受想行识相异。眼相异耳鼻舌身意相异。地相异水火风空识相异。欲相异嗔痴相异。邪见相异禅相异。无量心相异无色定相异。四念处相异乃至八圣道分相异。檀那波罗蜜相异。乃至般若波罗蜜相异。三解脱门相异十八空相异。佛十力相异四无所畏相异四无碍智相异十八不共法相异。有为法相异无为法相异。是凡夫人相异乃至佛相异。诸法各各相。云何菩萨摩诃萨行般若波罗蜜时。诸法异相中不作分别。若不作分别不能行般若波罗蜜。若不行般若波罗蜜不能从一地至一地。若不从一地至一地不能入菩萨位。不能入菩萨位故不能过声闻辟支佛地。不能过声闻辟支佛地故不能具足神通波罗蜜。不具足神通波罗蜜故不能具足檀那波罗蜜。乃至不能具足般若波罗蜜从一佛国至一佛国供养诸佛。于诸佛所种善根。用是善根能成就众生净佛国土。佛告须菩提。如汝所问。是诸法相亦是凡夫人亦是须陀洹乃至佛。世尊。是诸法各各相。所谓色相异乃至有为无为法相异。云何菩萨摩诃萨观一切相不作分别。须菩提。于汝意云何。是色相空不。乃至诸佛相空不。世尊实空。须菩提。空中各各相法可得不。所谓色相乃至诸佛相。须菩提言。不可得。佛言。以是因缘故。当知诸法平等中。非凡夫人亦不离凡夫人。乃至非佛亦不离佛。须菩提白佛言。世尊。是平等为是有为法为是无为法。佛言。非有为法非无为法。何以故。离有为法无为法不可得。离无为法有为法不可得。须菩提。是有为性无为性。是二法不合不散。无色无形无对一相。所谓无相。佛亦以世谛故说非以第一义。何以故。第一义中无身行无口行无意行。亦不离身口意行得第一义。是诸有为法无为法。平等相即是第一义。菩萨摩诃萨行般若波罗蜜时。第一义中不动。而行菩萨事饶益众生

    摩诃般若波罗蜜经如化品第八十七

须菩提白佛言。世尊。若诸法平等无可为作。云何菩萨摩诃萨行般若波罗蜜。于平等法中不动而行菩萨事。以布施爱语利益同事。佛告须菩提。如是如是如汝所言。是诸法平等无所作。若是众生自知诸法平等。佛不用神力于诸法平等中不动而拔出众生。吾我想以空。度五道生死乃至知者见者相。度色相乃至识相眼相乃至意相。地种相乃至识种相。远离有为性相令得无为性相。无为性相即是空。须菩提言。世尊。用何等空故一切法空。佛言。菩萨远离一切法相。用是空故一切法空。须菩提。于汝意云何。若有化人作化人。是化颇有实事不空者不。须菩提言。不也世尊。是化人无有实事而不空。是空及化人二事不合不散。以空故空不应分别是空是化。何以故。是二事等空中不可得。所谓是空是化。何以故。须菩提。色即是化受想行识即是化。乃至一切种智即是化。须菩提白佛言。世尊。世间法是化出世间法亦复是化不。所谓四念处四正勤四如意足五根五力七觉分八圣道分三解脱门佛十力四无所畏四无碍智十八不共法。并诸法果及贤圣人。所谓须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨摩诃萨诸佛。世尊。是法亦是化不。佛告须菩提。一切法皆是化。于是法中有声闻法变化。有辟支佛法变化。有菩萨摩诃萨法变化。有诸佛法变化。有烦恼法变化。有业因缘法变化。以是因缘故。须菩提。一切法皆是变化。须菩提白佛言。世尊。是诸烦恼断。所谓须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。断诸烦恼习断皆是变化不。佛告须菩提。若有法生灭相者。皆是变化。须菩提言。世尊。何等法非变化。佛言。若法无生无灭是非变化。须菩提言。何等是不生不灭非变化。佛言。不诳相涅槃是法非变化。世尊。如佛自说诸法平等。非声闻作非辟支佛作。非诸菩萨摩诃萨作非诸佛作。有佛无佛诸法性常空。性空即是涅槃。云何言涅槃一法非如化。佛告须菩提。如是如是。诸法平等非声闻所作。乃至性空即是涅槃。若新发意菩萨闻是一切法毕竟性空。乃至涅槃亦皆如化心则惊怖。为是新发意菩萨故。分别生灭者如化不生不灭者不如化。须菩提白佛言。世尊。云何教新发意菩萨令知性空。佛告须菩提。诸法本有今无耶

摩诃般若波罗蜜经卷第二十六摩诃般若波罗蜜经卷第二十七

        后秦龟兹国三藏鸠摩罗什译

    常啼品第八十八

佛告须菩提。菩萨摩诃萨求般若波罗蜜。应如萨陀波仑菩萨摩诃萨。是菩萨今在大雷音佛所行菩萨道。须菩提白佛言。世尊。萨陀波仑菩萨摩诃萨。云何求般若波罗蜜。佛言。萨陀波仑菩萨摩诃萨。本求般若波罗蜜时。不惜身命不求名利。于空闲林中闻空中声言。汝善男子。从是东行莫念疲极莫念睡眠。莫念饮食莫念昼夜。莫念寒热莫念内莫念外。善男子。行时莫观左右。汝行时莫坏身相。莫坏色相莫坏受想行识相。何以故。若坏是诸相于佛法中则为有碍。若于佛法中有碍。便往来五道生死中。亦不能得般若波罗蜜。尔时萨陀波仑菩萨报空中言。我当从教。何以故。我欲为一切众生作大明。欲集一切诸佛法。欲得阿耨多罗三藐三菩提故。萨陀波仑菩萨复闻空中声言。善哉善哉。善男子。汝于空无相无作之法应生信心。以离相心求般若波罗蜜。离我相乃至离知者见者相。当远离恶知识。当亲近供养善知识。何等是善知识。能说空无相无作无生无灭法及一切种智。令人心入欢喜信乐。是为善知识。善男子。汝若如是行不久当闻般若波罗蜜。若从经卷中闻。若从菩萨所说闻。善男子。汝所从闻是般若波罗蜜处应生心如佛想。善男子。汝当知恩应作是念。所从闻是般若波罗蜜者。即是我善知识。我用闻是法故。疾得不退转于阿耨多罗三藐三菩提。亲近诸佛常生有佛国土中。远离众难得具足无难处。善男子。当思惟筹量是功德。于所从闻法处。生心如佛想。汝善男子。莫以世利心故随逐法师。但为爱法恭敬法故。随逐说法菩萨。尔时当觉知魔事。若恶魔与说法菩萨作五欲因缘。假为法故令受。若说法菩萨入实法明。以功德力故。受而无所染。又以三事故受是五欲。以方便力故。欲令众生种善根故。欲与众生同其事故受。汝于是中莫生污心当起净想。自念我未得沤和拘舍罗。大师以方便法。为度众生令获福德故受是诸欲。于菩萨智慧。无著无碍不为欲染。善男子。即当观诸法实相。何等诸法实相。所谓一切法不垢不净。何以故。一切法自性空无众生无人无我。一切法如幻如梦如响如影如焰如化。善男子。观是诸法实相已当随法师。汝不久当成就般若波罗蜜。复次善男子。汝当复觉知魔事。若说法菩萨见欲受般若波罗蜜人。意不存念汝不应起心怨恨。汝但当以法故生恭敬心。莫起厌懈意。常应随逐法师。尔时萨陀波仑菩萨。受是空中教已从是东行。不久复作是念。我云何不问空中声。我当何处去。去当远近。当从谁闻般若波罗蜜。是时即住啼哭忧愁作是念。我住是中过一日一夜。若二三四五六七日七夜。于此中住不念疲极。乃至不念饥渴寒热。不闻听受般若波罗蜜因缘终不起也。须菩提。譬如人有一子卒死忧愁苦毒。唯怀[怡-台+夭]恼不生余念。如是须菩提。萨陀波仑菩萨尔时无有异心。但念我何时当闻般若波罗蜜。我云何不问空中声。我应何处去。去当远近。当从谁闻般若波罗蜜。须菩提。萨陀波仑菩萨如是愁念时。空中有佛语萨陀波仑菩萨言。善哉善哉。善男子过去诸佛行菩萨道时。求般若波罗蜜亦如汝今日。善男子。汝以是勤精进爱乐法故。从是东行。去此五百由旬。有城名众香。其城七重七宝庄严。台观栏楯皆以七宝校饰。七宝之堑七宝行树周匝七重。其城纵广十二由旬。丰乐安静人民炽盛。五百市里街巷相当。端严如画桥津如地宽博清净。七重城上皆有七宝楼橹。宝树行列以黄金白银砗磲码瑙珊瑚琉璃颇梨红色真珠。以为枝叶。宝绳连绵金为铃网以覆城上。风吹铃声其音和雅。譬如巧作五乐甚可喜乐。金网宝铃其音如是以乐众生。其城四边流池清净冷暖调适。中有诸船七宝严饰。是诸众生宿业所致。乘此宝船娱乐游戏。诸池水中种种莲华青黄赤白。众杂好华遍覆水上。是三千大千国土。所有众华皆在其中。其城四边有五百园观。七宝庄严甚可爱乐。一一园中各有五百池水。池水各各纵广十里。皆以七宝校成杂色庄严。诸池水中亦有青黄赤白莲华弥覆水上。是诸莲华大如车轮。青色青光黄色黄光。赤色赤光白色白光。诸池水中凫雁鸳鸯。异类众鸟音声相和。是诸园观适无所属。是诸众生宿业果报。长夜信乐深法行般若波罗蜜因缘故受是果报。善男子。是众香城中有大高台。昙无竭菩萨摩诃萨宫舍在上。其宫纵广一由旬。皆以七宝校成。杂色庄严甚可喜乐。垣墙七重皆亦七宝。七宝栏楯七宝楼阁。宝堑七重皆以七宝周匝。深堑七宝累成。七重行树七宝枝叶七重围绕。其宫舍中有四种娱乐园。一名常喜。二名离忧。三名华饰。四名香饰。一一园中各有八池。一名贤。二名贤上。三名欢喜。四名喜上。五名安隐。六名多安隐。七名远离。八名阿惟越致。诸池四边面各一宝。黄金白银琉璃颇梨。玫瑰为池底其上布金沙。一一池侧有八梯陛。种种妙宝以为严饰。诸梯陛间有阎浮檀金芭蕉行树。一切池中种种莲华青黄赤白弥覆水上。诸池四边生好华树。风吹诸华堕池水中。其池成就八种功德。香若栴檀。色味具足轻且柔软。昙无竭菩萨与六万八千婇女。五欲具足共相娱乐。及城中男女俱入常喜等园贤等池中。五欲具足共相娱乐。善男子。昙无竭菩萨与诸婇女游戏娱乐。已日三时说般若波罗蜜。众香城中男女大小。于其城中多聚人处敷大法座。其座四足或以黄金或以白银。或以琉璃或以颇梨。敷以綩綖杂色茵褥。垂诸帏带以妙白[疊*毛]而覆其上。散以种种杂妙华香。座高五里张白珠帐。其地四边散五色华。烧众名香泽香涂地。供养恭敬般若波罗蜜故。昙无竭菩萨。于此座上说般若波罗蜜。彼诸人众。如是恭敬供养昙无竭。为闻般若波罗蜜故。于是大会百千万众诸天世人一处和集。中有听者。中有受者。中有持者。中有诵者。中有书者。中有正观者。中有如说行者。是时众生以是因缘故皆不堕恶道。不退转于阿耨多罗三藐三菩提。汝善男子。往诣昙无竭菩萨所。当闻般若波罗蜜。善男子。昙无竭菩萨。世世是汝善知识。能教汝阿耨多罗三藐三菩提示教利喜。昙无竭菩萨。本求般若波罗蜜时亦如汝今。汝去莫计昼夜莫生障碍心。汝不久当闻般若波罗蜜。尔时萨陀波仑菩萨摩诃萨欢喜心悦作是念。我当何时得见是善男子得闻般若波罗蜜。须菩提。譬如有人为毒箭所中更无余念。唯念何时当得良医。拔出毒箭除我此苦。如是须菩提。萨陀波仑菩萨摩诃萨更无余念。但作是愿。我何时当得见昙无竭菩萨。令我得闻般若波罗蜜。我闻是般若波罗蜜断诸有心。是时萨陀波仑菩萨于是处住。念昙无竭菩萨一切法中得无碍智见。即得无量三昧门现在前。所谓诸法性观三昧。诸法性不可得三昧。破诸法无明三昧。诸法不异三昧。诸法不坏自在三昧。诸法能照明三昧。诸法离暗三昧。诸法无异相续三昧。诸法不可得三昧。散华三昧。诸法无我三昧。如幻威势三昧。得如镜像三昧。得一切众生语言三昧。一切众生欢喜三昧。入分别音声三昧。得种种语言字句庄严三昧。无畏三昧。性常默然三昧。得无碍解脱三昧。离尘垢三昧。名字语句庄严三昧。见诸法三昧。诸法无碍顶三昧。如虚空三昧。如金刚三昧。不畏着色三昧。得胜三昧。转眼三昧。毕法性三昧。能与安隐三昧。师子吼三昧。胜一切众生三昧。华庄严三昧。断疑三昧。随一切坚固三昧。出诸法得神通力无畏三昧。能达诸法三昧。诸法财印三昧。诸法无分别见三昧。离诸见三昧。离一切闇三昧。离一切相三昧。解脱一切着三昧。除一切懈怠三昧。得深法明三昧。不可夺三昧。破魔三昧。不着三界三昧。起光明三昧。见诸佛三昧。如是萨陀波仑菩萨住是诸三昧中。即见十方无量阿僧祇诸佛。为诸菩萨摩诃萨说般若波罗蜜。是时十方诸佛安慰萨陀波仑菩萨言。善哉善哉。善男子。我等本行菩萨道时求般若波罗蜜得是诸三昧。亦如汝今所得。我等得是诸三昧善入般若波罗蜜。成就方便力住阿惟越致地。我等观是诸三昧性。不见有法出三昧入三昧者。亦不见行佛道者。亦不见得阿耨多罗三藐三菩提者。善男子是名般若波罗蜜。所谓不念有是诸法。善男子。我等于无所念法中住。得是金色身丈光明。三十二相八十随形好。不可思议智慧。无上戒无上三昧佛无上智慧。一切功德皆悉具足。一切功德具足故。佛尚不能取相说尽。何况声闻辟支佛及诸余人。以是故。善男子。于是佛法中倍应恭敬爱念生清净心。于善知识中应生如佛想。何以故。为善知识守护故。菩萨疾得阿耨多罗三藐三菩提

是时萨陀波仑菩萨白十方诸佛言。何等是我善知识。所应亲近供养者。十方诸佛告萨陀波仑菩萨言。汝善男子。昙无竭菩萨世世教化。成就汝阿耨多罗三藐三菩提。昙无竭菩萨守护汝。教汝般若波罗蜜方便力。是汝善知识。汝供养昙无竭菩萨。若一劫若二若三乃至过百劫顶戴恭敬。以一切乐具三千世界中所有妙色声香味触。尽以供养未能报须臾之恩。何以故。昙无竭菩萨摩诃萨因缘故。令汝得如是等诸三昧。得般若波罗蜜方便力。诸佛如是教化安慰萨陀波仑菩萨。令欢喜已忽然不现。是时萨陀波仑菩萨。从三昧起不复见佛。作是念。是诸佛从何所来去至何所。不见诸佛故复惆怅不乐谁断我疑。复作是念。昙无竭菩萨久远已来。常行般若波罗蜜。得方便力及得诸陀罗尼。于菩萨法中得自在。多供养过去诸佛。世世为我师常利益我。我当问昙无竭菩萨。诸佛从何所来去至何处

尔时萨陀波仑菩萨于昙无竭菩萨。生恭敬爱乐尊重心作是念。我当以何供养昙无竭菩萨。今我贫穷无华香璎珞烧香泽香衣服幡盖金银真珠琉璃颇梨珊瑚琥珀。无有如是等物可以供养般若波罗蜜及说法师昙无竭菩萨。我法不应空往昙无竭菩萨所。我若空往喜悦心不生。我当卖身得财为般若波罗蜜故。供养法师昙无竭菩萨。何以故。我世世丧身无数。无始生死中或死或卖。或为欲因缘故。世世在地狱中受无量苦恼。未曾为清净法故为供养说法师故丧身。是时萨陀波仑菩萨。中道入一大城至市肆上。高声唱言。谁欲须人。谁欲须人。谁欲买人。尔时恶魔作是念。是萨陀波仑爱法故欲自卖身为般若波罗蜜故供养昙无竭菩萨。当得正问般若波罗蜜及方便力。云何菩萨摩诃萨行般若波罗蜜。疾得阿耨多罗三藐三菩提。当得多闻具足如大海水。是时不可沮坏。得具足一切功德饶益诸菩萨摩诃萨。为阿耨多罗三藐三菩提故过我境界。亦教余人出我境界得阿耨多罗三藐三菩提。我今当坏其事。尔时恶魔隐蔽诸婆罗门居士。令不闻其自卖之声。除一长者女魔不能蔽。尔时萨陀波仑。卖身不售。忧愁啼哭在一面立。涕泣而言。我为大罪卖身不售。我自卖身为般若波罗蜜故。供养昙无竭菩萨

尔时释提桓因作是念。是萨陀波仑菩萨爱法自卖其身。为般若波罗蜜故欲供养昙无竭菩萨。我当试之知是善男子。实以深心爱法故舍是身不。是时释提桓因化作婆罗门身。在萨陀波仑菩萨边。行问言。汝善男子。何以忧愁啼哭颜色憔悴在一面立。答言。婆罗门。我爱敬法自卖身。为般若波罗蜜故欲供养昙无竭菩萨。今我卖身无有买者。自念薄福无财宝物自欲卖身供养般若波罗蜜及昙无竭菩萨。而无买者。尔时婆罗门。语萨陀波仑菩萨言。善男子。我不须人。我今欲祀天。当须人心人血人髓。汝能卖与我不。尔时萨陀波仑菩萨作是念。我得大利得第一利。我今便为具足般若波罗蜜方便力。得是买心髓血者。是时心大欢喜悦乐无忧。以柔和心语婆罗门言。汝所须者我尽与汝。婆罗门言。善男子。汝须何价。答言。随汝意与我。即时萨陀波仑。右手执利刀刺左臂出血。割右髀肉复欲破骨出髓。时有一长者女。在阁上遥见萨陀波仑菩萨自割身体不惜寿命。作是念。是善男子。以何因缘故困苦其身。我当往问。长者女即下阁。到萨陀波仑所问言。善男子。何因缘困苦其身。用是心血髓作何等。萨陀波仑答言。卖与婆罗门。为般若波罗蜜故供养昙无竭菩萨。长者女言。善男子。作是卖身欲自出心髓血。欲供养昙无竭菩萨得何等功德利。萨陀波仑答言。善女人。是人善学般若波罗蜜及方便力。是人当为我说菩萨所应作菩萨所行道。我学是法学是道。得阿耨多罗三藐三菩提时。为众生作依止。当得金色身三十二相八十随形好丈光无量明。大慈大悲大喜大舍四无所畏。佛十力四无碍智十八不共法六神通。不可思议清净戒禅定智慧。得阿耨多罗三藐三菩提。于诸法中得无碍一切智见。以无上法宝分布与一切众生。如是等诸功德利我当从彼得之。是时长者女。闻是上妙佛法。大欢喜心惊毛竖。语萨陀波仑菩萨言。善男子。甚希有。汝所说者微妙难值。为是一一功德法故。应舍如恒河沙等身。何以故。汝所说者甚大微妙。汝善男子。汝今所须尽当相与。金银真珠琉璃颇梨琥珀珊瑚等诸珍宝物。及华香璎珞涂香烧香幡盖衣服伎乐等物供养之具。供养般若波罗蜜及昙无竭菩萨。汝善男子。莫自困苦其身。我亦欲往昙无竭菩萨所。共汝殖诸善根。为得如是微妙法如汝所说故。尔时释提桓因即复本身。赞萨陀波仑菩萨言。善哉善哉。善男子。汝坚受是事。其心不动。诸过去佛行菩萨道时。亦如是求般若波罗蜜及方便力。得阿耨多罗三藐三菩提。善男子。我实不用人心血髓。但来相试汝愿何等我当相与。萨陀波仑言。与我阿耨多罗三藐三菩提。释提桓因言。此非我力所办。是诸佛境界。必相供养更索余愿。萨陀波仑言。汝若于此无力必见供养。令我是身平复如故。是时萨陀波仑。身即平复无有疮瘢如本不异。释提桓因与其愿已忽然不现。尔时长者女语萨陀波仑菩萨言。善男子。来到我舍。有所须者。从我父母索之尽当相与。我亦当辞我父母。与诸侍从共汝往供养昙无竭菩萨。为求法故。即时萨陀波仑菩萨与长者女。俱到其舍在门外住。长者女入白父母。与我众妙华香及诸璎珞涂香烧香幡盖衣服金银琉璃颇梨真珠琥珀珊瑚。及诸伎乐供养之具。亦听我身及五百侍女先所给使。共萨陀波仑菩萨到昙无竭菩萨所。为供养般若波罗蜜故。昙无竭菩萨当为我等说法。我当如说行当得诸佛法。女父母语女言。萨陀波仑菩萨是何等人。女言。是人今在门外。是善男子。以深心求阿耨多罗三藐三菩提。欲度一切众生无量生死苦。是善男子。为法故自卖其身供养般若波罗蜜。般若波罗蜜名菩萨所学道。为供养般若波罗蜜。及供养昙无竭菩萨故。在市肆上高声唱言。谁欲须人。谁欲须人。谁欲买人。卖身不售。在一面立。忧愁啼哭。是时释提桓因化作婆罗门。来欲试之。问言。善男子。何以忧愁啼哭在一面立。答言。婆罗门。我欲卖身为供养般若波罗蜜及昙无竭菩萨摩诃萨故。而我薄福卖身不售。婆罗门语是善男子。我不须人。我欲祀天。当用人心人血人髓。汝能卖不。是时是善男子。不复忧愁其心和悦语是婆罗门。如汝之所须我尽相与。婆罗门言。汝须何价。答言。随汝意与我。即时是善男子。右手执利刀刺左臂出血。割右髀肉复欲破骨出髓。我在阁上遥见是事。我尔时作是念。是人何故困苦其身。我当往问。我即下阁往问。善男子。汝何因缘故自困苦其身。是善男子。答我言。姊我为法故欲供养般若波罗蜜及昙无竭菩萨说法者。我贫穷无所有。无金银琉璃砗磲码瑙珊瑚琥珀颇梨真珠华香伎乐。姊我为供养法故自卖其身。今得买者须人心人血人髓。我用是价供养般若波罗蜜及昙无竭菩萨说法者。我问是善男子。汝今自出身心血髓。欲供养昙无竭菩萨得何功德。是善男子言。昙无竭菩萨当为我说般若波罗蜜及方便力。此是菩萨所应学。菩萨所应作。菩萨所应行道。我当学是道得阿耨多罗三藐三菩提。为一切众生作依止。我当得金色身三十二相八十随形好丈光无量明。大慈大悲大喜大舍四无所畏四无碍智。佛十力十八不共法六神通。不可思议清净戒禅定智慧。得阿耨多罗三藐三菩提。于诸法中得无碍一切智见。以无上法宝分布与一切众生。如是等微妙大法。我当从彼得之。我闻是微妙不可思议法诸佛功德。闻其大愿。我心欢喜作是念。是清净微妙最大甚希有。乃如是为一一法故应舍如恒河沙等身。今善男子。为法能受苦行难事。所谓不惜身命。我多有妙宝。云何而不生愿求如是法。供养般若波罗蜜及昙无竭菩萨。我如是思惟已语萨陀波仑菩萨。汝善男子。莫困苦其身。我当白我父母。多与汝金银琉璃砗磲玛瑙珊瑚琥珀颇梨真珠华香璎珞涂香末香衣服幡盖及诸伎乐。供养般若波罗蜜及昙无竭菩萨说法者。我亦求父母与诸侍女共汝俱去供养昙无竭菩萨说法者。共汝殖诸善根为得如是等微妙清净法。如汝所说。父母今听我并五百侍女先所给者。亦听我持众妙华香璎珞涂香末香衣服幡盖伎乐金银琉璃供养之具。与萨陀波仑菩萨共去。供养般若波罗蜜及昙无竭菩萨说法者。为得如是等清净微妙诸佛法故。尔时父母报女言。汝所赞者希有难及说。是善男子。为法精进大乐法相。及是诸佛法不可思议。一切世间最为第一。一切众生欢乐因缘。是善男子。为是法故大誓庄严。我等听汝往见昙无竭菩萨亲近供养。汝发大心为诸佛故如是精进。我等云何当不随喜。是女为供养昙无竭菩萨故。得蒙听许。报父母言。我等亦随是心欢喜我终不断人善法因缘。是时长者女。庄严七宝车五百乘。身及侍女。种种宝物装饰供养之具。持种种水陆生华及金银宝华众色宝衣好香捣香泽香璎珞及众味饮食。共萨陀波仑菩萨五百侍女各载一车。恭敬围绕渐渐东去。见众香城七宝庄严。七重围绕七宝之堑。七宝行树皆亦七重。其城纵广十二由旬。丰乐安静甚可喜乐。人民炽盛五百市里街巷相当。端严如画桥津如地宽博清净。遥见众香城既入城中。见昙无竭菩萨坐高台法座上。无量百千万亿众恭敬围绕说法。萨陀波仑菩萨见昙无竭菩萨时。心即欢喜。譬如比丘入第三禅摄心安隐。见已作是念。我等仪不应载车趣昙无竭菩萨。作是念已下车步进。长者女并五百侍女皆亦下车。萨陀波仑菩萨与长者女及五百侍女。众宝庄严围绕恭敬俱到昙无竭菩萨所。尔时昙无竭菩萨摩诃萨。有七宝台赤牛头栴檀以为庄严。真珠罗网以覆台上。四角皆悬摩尼珠宝以为灯明。及四宝香炉常烧名香。为供养般若波罗蜜故。其台中有七宝大床。四宝小床。重敷其上。以黄金牒书般若波罗蜜置小床上。种种幡盖庄严垂覆其上。萨陀波仑菩萨及诸女人。见是妙台众宝严饰。及见释提桓因与无量百千万诸天。以天曼陀罗华碎末栴檀磨众宝屑以散台上。鼓天伎乐于虚空中娱乐此台。尔时萨陀波仑菩萨问释提桓因。憍尸迦。何因缘故与无量百千万诸天。以天曼陀罗华碎末栴檀磨众宝屑以散台上。鼓天伎乐于虚空中娱乐此台。释提桓因答言。汝善男子不知耶。此是摩诃般若波罗蜜。是诸菩萨摩诃萨母。能生诸佛摄持菩萨。菩萨学是般若波罗蜜成就一切诸功德。得诸佛法一切种智。是时萨陀波仑即欢喜悦乐。问释提桓因言。憍尸迦。是般若波罗蜜诸菩萨摩诃萨母。能生诸佛摄持菩萨。菩萨学是般若波罗蜜成就一切功德。得诸佛法一切种智。今在何处。释提桓因言。善男子。是台中有七宝大床。四宝小床重敷其上。以黄金牒书般若波罗蜜置小床上。昙无竭菩萨以七宝印印之。我等不能得开以示汝。是时萨陀波仑与长者女及五百侍女。取供养具华香璎珞幡盖。分作二分。一分供养般若波罗蜜。一分供养法座上昙无竭菩萨。尔时萨陀波仑菩萨与五百女人。持华香璎珞幡盖伎乐及诸珍宝。供养般若波罗蜜已。然后到昙无竭菩萨所。到已见昙无竭菩萨在法座上坐。以诸华香璎珞捣香泽香金银宝华幡盖宝衣。散昙无竭菩萨上为法故供养。是时诸华香宝衣于昙无竭菩萨上。虚空中化成华台。碎末栴檀宝屑金银宝华化成宝帐。宝帐之上所散种种宝衣化为宝盖。宝盖四边垂诸宝幡。萨陀波仑及诸女人。见昙无竭菩萨所作变化。大欢喜作是念。未曾有也。昙无竭大师神德乃尔。行菩萨道时神通力尚能如是。何况得阿耨多罗三藐三菩提时。是时长者女及五百女人清净信心敬重昙无竭菩萨。皆发阿耨多罗三藐三菩提心。作是愿言。如昙无竭菩萨得菩萨诸深法。如昙无竭菩萨供养般若波罗蜜。如昙无竭菩萨于大众中演说显示般若波罗蜜义。如昙无竭菩萨得般若波罗蜜方便力成就神通于菩萨事中得自在。我等亦当如是。是时萨陀波仑菩萨及五百女人。香华宝物供养般若波罗蜜及昙无竭菩萨已。头面礼昙无竭菩萨合掌恭敬一面立。一面立已白昙无竭菩萨言。我本求般若波罗蜜时。于空闲林中闻空中声言。善男子。汝从是东行当得闻般若波罗蜜。我受是语东行。东行不久作是念。我何不问空中声。我当何处去去是远近。当从谁闻。我是时大忧愁啼哭。于是处住七日七夜。忧愁故乃至不念饮食。但念我何时当得闻般若波罗蜜。我如是忧愁一心念般若波罗蜜。见佛身在虚空中语我言。善男子汝大欲大精进心莫放舍以是大欲大精进心。从是东行去是五百由旬。有城名众香。是中有菩萨摩诃萨名昙无竭。从是人所当得闻般若波罗蜜。是昙无竭菩萨世世是汝善知识常守护汝。我从佛受教诲已。便东行更无余念。但念我何时当见昙无竭菩萨为我说般若波罗蜜。我尔时中道住。于一切法中得无碍智见。得观诸法性等诸三昧现在前。住是三昧已见十方无量阿僧祇诸佛说是般若波罗蜜。诸佛赞我言。善哉善哉。善男子。我本求般若波罗蜜时得诸三昧亦如汝今日。得是诸三昧已遍得诸佛法。诸佛为我广说法。安慰我已忽然不现。我从三昧起作是念。诸佛从何处来去至何所。我不见诸佛故大愁忧。复作是念。昙无竭菩萨供养先佛殖善根。久行般若波罗蜜善知方便力。于菩萨道中得自在。是我善知识守护我。我当问昙无竭菩萨是事。诸佛从何所来去至何所。我今问大师。是诸佛从何处来去至何处。大师为我说诸佛所从来所至处令我得知。知已亦常不离见诸佛

    摩诃般若波罗蜜经法尚品第八十九(丹本昙无竭品)

尔时昙无竭菩萨摩诃萨语萨陀波仑菩萨言。善男子。诸佛无所从来去亦无所至。何以故。诸法如不动相。诸法如即是佛。善男子。无生法无来无去。无生法即是佛。无灭法无来无去。无灭法即是佛。实际法无来无去。实际法即是佛。空无来无去。空即是佛。善男子。无染无来无去。无染即是佛。寂灭无来无去。寂灭即是佛。虚空性无来无去。虚空性即是佛。善男子。离是诸法更无佛。诸佛如诸法如。一如无分别。善男子。是如常一无二无三。出诸数法无所有故。譬如春末月日中热时。有人见焰动逐之求水望得。于汝意云何。是水从何池何山何泉来。今何所去。若入东海西海南海北海耶。萨陀波仑言。大师。焰中尚无水。云何当有来处去处。昙无竭菩萨语萨陀波仑菩萨言。善男子。愚夫无智为热渴所逼。见焰动无水生水想。善男子。若有人分别诸佛有来有去。当知是人皆是愚夫。何以故。善男子。诸佛不可以色身见。诸佛法身无来无去。诸佛来处去处亦如是。善男子。譬如幻师幻作种种若象若马若牛若羊若男若女。如是等种种诸物。于汝意云何。是幻事从何处来去至何所。萨陀波仑菩萨言。大师。幻事无实。云何当有来去处。善男子。是人分别佛有来有去亦如是。善男子。譬如梦中见若象若马若牛若羊若男若女。于汝意云何。梦中所见有来处有去处不。萨陀波仑言。大师。是梦中所见虚妄。云何当有来去。善男子。是人分别佛有来有去亦如是。善男子。佛说诸法如梦。若有众生不知诸法如梦。以名字色身是佛。是人分别诸佛有来有去。不知诸法实相故。皆是愚夫无智之数。是诸人数数往来五道。远离般若波罗蜜。远离诸佛法。善男子。佛说诸法如幻如梦。若有众生如实知。是人不分别诸法若来若去若生若灭。若不分别诸法若来若去若生若灭。则能知佛所说诸法实相。是人行般若波罗蜜近阿耨多罗三藐三菩提。名为真佛弟子。不虚妄食人信施。是人应受供养为世间福田。善男子。譬如大海水中诸宝。不从东方来。不从南方西方北方四维上下来。众生善根因缘故海生此宝。此宝亦不无因无缘而生。是宝皆从因缘和合生。是宝若灭亦不去至十方。诸缘合故。有诸缘离故灭。善男子。诸佛身亦如是。从本业因缘果报生。生时不从十方来。灭时亦不去至十方。但诸缘合故有。诸缘离故灭。善男子。譬如箜篌声。出时无来处灭时无去处。众缘和合故生。有槽有颈有皮有弦有柱有棍。有人以手鼓之。众缘和合而有是声。是声亦不从槽出。不从颈出。不从皮出。不从弦出。不从棍出。亦不从人手出。众缘和合尔乃有声。是因缘离时亦无去处。善男子。诸佛身亦如是。从无量功德因缘生。不从一因一缘一功德生。亦不无因缘有。众缘和合故有。诸佛身不独从一事成。来无所从去无所至。善男子。应当如是知诸佛来相去相。善男子。亦当知一切法无来去相。汝若知诸佛及诸法无来无去无生无灭相。必得阿耨多罗三藐三菩提。亦能行般若波罗蜜及方便力。尔时释提桓因。以天曼陀罗华与萨陀波仑菩萨摩诃萨作是言。善男子。以是华供养昙无竭菩萨摩诃萨。我应当守护供养汝。所以者何。汝因缘力故。今日饶益百千万亿众生。便为得阿耨多罗三藐三菩提。善男子。如是善人甚为难遇。为饶益一切众生故。无量阿僧祇劫受诸勤苦。萨陀波仑菩萨摩诃萨受释提桓因曼陀罗华。散昙无竭菩萨上白言。大师。我从今日以身属师供给供养。如是白已合掌师前立。是时长者女及五百侍女。白萨陀波仑菩萨言。我等从今日亦以身属师。我等以是善根因缘故。当得如是法亦如师所得。共师世世供养诸佛。世世常供养师。是时萨陀波仑菩萨。语长者女及五百女人。若汝等以诚心属我者我当受汝。诸女言。我等以诚心属师当随师教。是时萨陀波仑菩萨与长者女及五百女人。并诸庄饰宝物上妙供具及五百乘七宝车。奉上昙无竭菩萨白言。大师。我持是五百女人奉给大师。是五百乘车随师所用。尔时释提桓因赞萨陀波仑菩萨言。善哉善哉。善男子。菩萨摩诃萨舍一切所有应如是。如是布施疾得阿耨多罗三藐三菩提。作如是供养说法人。必得闻般若波罗蜜及方便力。过去诸佛本行菩萨道时亦如是。住布施中得闻般若波罗蜜及方便力。得阿耨多罗三藐三菩提。尔时昙无竭菩萨。欲令萨陀波仑菩萨善根具足故。受五百乘车长者女及五百侍女。受已还与萨陀波仑菩萨。是时昙无竭菩萨说法日没起入宫中。萨陀波仑菩萨摩诃萨作是念。我为法故来不应坐卧。当以二仪若行若立。以待法师从宫中出说法。尔时昙无竭菩萨。七岁一心入无量阿僧祇菩萨三昧。及行般若波罗蜜方便力。萨陀波仑菩萨七岁经行住立。不坐不卧无有睡眠。无欲恚恼心不着味。但念昙无竭菩萨摩诃萨。何时当从三昧起出而说法。萨陀波仑菩萨过七岁已作是念。我当为昙无竭菩萨摩诃萨敷说法座。昙无竭菩萨摩诃萨当座上说法。我当洒扫清净散种种华庄严是处。为昙无竭菩萨摩诃萨当说般若波罗蜜及方便力故。是时萨陀波仑菩萨与长者女及五百侍女。为昙无竭菩萨摩诃萨敷七宝床。五百女人各脱上衣以敷座上作是念。昙无竭菩萨摩诃萨当坐此座上。说般若波罗蜜及方便力。萨陀波仑菩萨敷座已。求水洒地而不能得。所以者何。恶魔隐蔽令水不现。魔作是念。萨陀波仑菩萨求水不得。于阿耨多罗三藐三菩提。乃至生一念劣心异心。则智慧不照善根不增。于一切智而有稽留。尔时萨陀波仑菩萨作是念。我当自刺其身以血洒地。令无尘土来坌大师。我何用此身此身必当破坏。我从无始生死以来数数丧身未曾为法。即以利刀自刺出血洒地。萨陀波仑菩萨及长者女并五百侍女皆无异心。恶魔亦不能得便。是时释提桓因作是念。未曾有也。萨陀波仑菩萨。爱法乃尔以刀自刺出血洒地。萨陀波仑及众女人心不动转。恶魔波旬不能坏其善根。其心坚固发大庄严不惜身命。以深心欲求阿耨多罗三藐三菩提。当度一切众生无量生死苦。释提桓因赞萨陀波仑菩萨言。善哉善哉。善男子。汝精进力大坚固难动不可思议。汝爱法求法最为无上。善男子。过去诸佛亦如是。以深心爱法惜法重法。集诸功德得阿耨多罗三藐三菩提。萨陀波仑菩萨作是念。我为昙无竭菩萨摩诃萨敷法座。扫洒清净已讫。当于何处得好名华庄严此地。若昙无竭菩萨摩诃萨法座上坐说法时。亦当散华供养。释提桓因知萨陀波仑菩萨心所念。即以三千石天曼陀罗华与萨陀波仑。萨陀波仑受华以半散地。留牛待昙无竭菩萨摩诃萨坐法座上说法时当供养。尔时昙无竭菩萨摩诃萨。过七岁已从诸三昧起。为说般若波罗蜜故。与无量百千万众恭敬围绕往法座上坐。萨陀波仑菩萨摩诃萨。见昙无竭菩萨摩诃萨时心得悦乐。譬如比丘入第三禅。尔时萨陀波仑菩萨摩诃萨及长者女并五百侍女。到昙无竭菩萨摩诃萨所。散天曼陀罗华头面礼毕退坐一面。昙无竭菩萨见其坐已。告萨陀波仑菩萨言。善男子。谛听谛受。今当为汝说般若波罗蜜相。善男子。诸法等故当知般若波罗蜜亦等。诸法离故当知般若波罗蜜亦离。诸法不动故当知般若波罗蜜亦不动。诸法无念故当知般若波罗蜜亦无念。诸法无畏故当知般若波罗蜜亦无畏。诸法一味故当知般若波罗蜜亦一味。诸法无边故当知般若波罗蜜亦无边。诸法无生故当知般若波罗蜜亦无生。诸法无灭故当知般若波罗蜜亦无灭。虚空无边故当知般若波罗蜜亦无边。大海水无边故当知般若波罗蜜亦无边。须弥山庄严故当知般若波罗蜜亦庄严。虚空无分别故当知般若波罗蜜亦无分别。色无边故当知般若波罗蜜亦无边。受想行识无边故当知般若波罗蜜亦无边。地种无边故当知般若波罗蜜亦无边。水种火种风种无边故当知般若波罗蜜亦无边。空种无边故当知般若波罗蜜亦无边。如金刚等故当知般若波罗蜜亦等。诸法无分别故当知般若波罗蜜亦无分别。诸法性不可得故当知般若波罗蜜性亦不可得。诸法无所有等故当知般若波罗蜜亦无所有等。诸法无作故当知般若波罗蜜亦无作。诸法不可思议故。当知般若波罗蜜亦不可思议。是时萨陀波仑菩萨摩诃萨。即于坐处得诸三昧。所谓诸法等三昧。诸法离三昧。不动三昧。无念三昧。诸法无畏三昧。诸法一味三昧。诸法无边三昧。诸法无生三昧。诸法无灭三昧。虚空无边三昧。大海水无边三昧。须弥山庄严三昧。虚空无分别三昧。色无边三昧。受想行识无边三昧。地种无边三昧。水种火种风种空种无边三昧。如金刚等三昧。诸法无分别三昧。诸法不可思议三昧。如是等得六百万诸三昧门。尔时佛告须菩提。如我今于三千大千世界中与诸比丘僧围绕。以是相以是像貌以是名字说般若波罗蜜。萨陀波仑得是六百万三昧门。见东方南西北方四维上下。如恒河沙等三千大千世界中诸佛与诸比丘恭敬围绕。以如是相如是像貌如是名字。说是摩诃般若波罗蜜亦如是。萨陀波仑菩萨从是以后。多闻智慧不可思议如大海水。常不离诸佛生于有佛国中。乃至梦中未曾不见佛时。一切众难皆悉已断。在所佛国随愿往生。须菩提。当知是般若波罗蜜因缘。能成就菩萨摩诃萨一切功德得一切种智。以是故。须菩提。诸菩萨摩诃萨若欲学六波罗蜜。欲深入诸佛智慧。欲得一切种智。应受持般若波罗蜜读诵正忆念。广为他人说亦书写经卷。供养尊重赞叹香华乃至伎乐。何以故。般若波罗蜜是过去未来现在十方诸佛母。十方诸佛所尊重故

    摩诃般若波罗蜜经嘱累品第九十

尔时佛告阿难。于汝意云何。佛是汝大师不。汝是佛弟子不。阿难言。世尊。佛是我大师。修伽陀是我大师。我是佛弟子。佛言。如是如是。我是汝大师。汝是我弟子。若如弟子所应作者。汝已作竟。阿难。汝用身口意慈业供养供给我。亦常如我意无有违失。阿难。我身现在汝爱敬供养供给心常清净。我灭度后是一切爱敬供养供给事。当爱敬供养般若波罗蜜。乃至第二第三以般若波罗蜜嘱累汝。阿难汝莫忘失莫作最后断种人。阿难。随尔所时般若波罗蜜在世。当知尔所时有佛在世说法。阿难。若有书般若波罗蜜。受持读诵正忆念为人广说。恭敬尊重赞叹华香幡盖宝衣灯烛种种供养。当知是人不离见佛不离闻法为常亲近佛。佛说般若波罗蜜已。弥勒等诸菩萨摩诃萨。慧命须菩提。慧命舍利弗。大目揵连。摩诃迦叶。富楼那弥多罗尼子。摩诃拘絺罗。大迦旃延。阿难等。并一切大众及一切世间诸天人。揵闼婆阿修罗等。闻佛所说皆大欢喜

摩诃般若波罗蜜经卷第二十七


摩诃般若钞经

    No. 226 [Nos. 220(4or5), 224, 225, 227,　　228, cf. 229]

摩诃般若钞经卷第一(亦名长安品)

        秦天竺沙门昙摩蜱共竺佛念译

    道行品第一

闻如是。一时佛在罗阅只耆阇崛山中。与千二百五十比丘俱。皆是罗汉于生死以尽。垢浊以索所语如言。已脱于心度于智慧。其圣已了皆悉上士。所作已办离于重担。是即自从所有已尽。其智已脱心即从计。除贤者阿难。佛告须菩提。今日乐不。为诸菩萨说般若波罗蜜。菩萨当从是学成。舍利弗心念。今须菩提为诸菩萨说般若波罗蜜。自用力说耶。持佛威神说乎。须菩提。知舍利弗心所念便语舍利弗敢佛弟子所说法所成法皆承佛威神。何以故。佛所说法法中所学皆有证以知便能有所成。展转能相成教。于诸法随其教。所以者何。怛萨阿竭所说无有异。若有仁善欲学是法于中终不。诤。须菩提白佛言。使我为诸菩萨说般若波罗蜜。菩萨当从中成菩萨。菩萨有字为在何法而字。菩萨亦不见法有法字。菩萨亦不见。菩萨亦不能得。亦不见般若波罗蜜。亦不能得亦不见。菩萨亦不能得。亦不见。般若波罗蜜亦不能得。何所有菩萨当为说般若波罗蜜。说是时菩萨闻之。心不懈不怯不恐不难不畏。是故菩萨摩诃萨。以应般若波罗蜜。菩萨摩诃萨。当作是学般若波罗蜜。当念作是住是为学。须菩提白佛。菩萨摩诃萨行般若波罗蜜当作是学。学其心不当自念我是菩萨。何以故。心无心心者净。舍利弗谓须菩提。云何有心心无心。须菩提语舍利弗。心亦不有亦不无。亦不能得亦不能知处。舍利弗谓须菩提。何等心亦不有心不无。心亦不能得。亦不能知处者。须菩提言。从对虽有心。心无心。如是心亦不知者。亦无造者。以是亦不有有心。亦不无无心。舍利弗言。善哉善哉。须菩提。为佛所举作所举者不妄空身。空身慧所说最第一。从是中菩萨摩诃萨。署得阿惟越致举名。终不复失般若波罗蜜。菩萨摩诃萨以应中住。欲学声闻道地。当闻般若波罗蜜。当学当持当守。欲学辟支佛道地。当闻般若波罗蜜。当学当持当守。欲学菩萨道地。当闻般若波罗蜜。当学当持当守。所以者何。般若波罗蜜法甚广大故。菩萨摩诃萨所学。须菩提白佛。我熟念菩萨心不可得。亦不知处。亦不可见而可得。亦不能及说何所是菩萨摩诃萨般若波罗蜜亦不能逮说菩萨字字处无有处。如是字处无所止无所住。作是说者。菩萨闻之。心不懈不惓不恐不难不畏。以应阿惟越致。其畏无所住。住以如是住。悉了知不复还。须菩提白佛。菩萨摩诃萨。行般若波罗蜜。色中不当住痛痒思想生死识。不当于中住想色住为行生死识想痛痒思想生死。识住为行生死识。不当行生死识设住其中。不随般若波罗蜜教。不为应萨芸若。为受色故不当受色。以不受色为不受痛痒思想生死识。不受色者为非色。不受痛痒思想生死识者为非识。复不受般若波罗蜜。是菩萨摩诃萨为行般若波罗蜜。复不受三昧字广大所入。不受声闻辟支佛。乃至萨芸若都不受。所以者何。不当作想。若作想亦如外外小道。而有信于萨芸若。虽异外道未得解脱。虽不受色亦受痛痒思想生死识。以不受亦未晓尚未成不见慧。亦不内色见慧。亦不外色见慧。亦不异色见慧。亦不内痛痒思想生死。识见慧。亦不于外识见慧。亦不于内外识见慧。亦不异识见慧。虽从信欲得脱。欲知萨芸若事。于法而作限。谓为得脱以为得法。于法亦为无所得亦未得脱。其不以泥洹自贡高。是为菩萨摩诃萨般若波罗蜜。所以者何。为不受色。为不受痛痒思想生死识。亦不中道般泥洹。悉得十种力四无所畏佛十八事不同。是故为菩萨摩诃萨般若波罗蜜。复次天中天。菩萨摩诃萨入般若波罗蜜行者当作是视。何所是般若波罗蜜。在何所法了不能知不能得处。是故为般若波罗蜜。当作是念。菩萨摩诃萨。闻是不懈不怯不恐不难不畏。知是菩萨以住不离般若波罗蜜。舍利弗问须菩提。何因菩萨摩诃萨。不离般若波罗蜜住。离色色之自然。痛痒思想生死识识之自然。般若波罗蜜。离般若波罗蜜之自然。须菩提语舍利弗。离色者色之自然。痛痒思想生死识离识之自然。离般若波罗蜜。般若波罗蜜之自然。般若波罗蜜自然为离相故。相之自然为离故。相自然相。相之自然离相。舍利弗谓须菩提。学是者为学萨芸若。须菩提言。以学是者为入萨芸若。何以故。于诸法为无所入。菩萨摩诃萨作是行者。便自致至萨芸若坐。是菩萨摩诃萨般若波罗蜜萨芸若种。复次舍利弗。菩萨摩诃萨精进作是语。我欲学。设使行色为行想。设想色行为行想。设生色行为行想。设坏色行为行想。设灭色行为行想。设空色行为行想。设我行立欲得为行想。痛痒思想生死识灭为行想。识生行为行想。坏识行为行想。识灭行为行想。空识行为行想。我行立欲得为行想。是菩萨摩诃萨为反行想行。是守行般若波罗蜜。为不行般若波罗蜜反作想行。是菩萨摩诃萨无有护行。舍利弗问须菩提。菩萨摩诃萨。当云何行般若波罗蜜。不行色行不想色行。不生色行不坏色行。不灭色行不空色行。不痛痒思想生死识行。不生识行不坏识行。不灭识行不空识行。为行般若波罗蜜。亦无见亦无行。亦无见行无行亦不见亦不不行亦不无行。如是为不见。何以故。一切法无所从来亦无所持。是菩萨摩诃萨。于一切字法不受。是三昧无有边无有极无所不入。诸罗汉辟支佛所不能知。菩萨摩诃萨随是三昧者。疾得阿耨多罗三耶三菩得成至佛。须菩提承佛威神说是言时。菩萨摩诃萨皆得受决。前过去怛萨阿竭自致阿耨多罗三耶三菩时得成至佛。随是三昧者亦不见三昧。亦不言我知三昧。亦不念我三昧已。亦不想我坐三昧。亦不言我三昧已。随是法者。都无有短。舍利弗问须菩提。何所菩萨摩诃萨随是三昧行者。前过去佛得决时自致成佛。可得见三昧处不。须菩提言。不可得见。善男子。于三昧亦不知亦不晓亦不了。何以故不知不了。则答言亦不得。亦无有三昧亦不得字。佛言。善哉善哉。须菩提。如我所说。空身慧菩萨摩诃萨作是者。为随般若波罗蜜学。是菩萨摩诃萨。为学般若波罗蜜。舍利弗白佛。菩萨摩诃萨如是学。天中天。为学般若波罗蜜。佛语舍利弗。是菩萨摩诃萨。为学般若波罗蜜。舍利弗白佛。如是者为学何法。佛语舍利弗菩萨摩诃萨为学无学法。何以故。法无所逮得。莫痴如小儿学。舍利弗问佛。谁能逮得法者。佛语舍利弗。无所得。是故得。佛言。无所得法。莫痴如小儿学。谓有字不能得。欲学习入法适为两碍耳。亦不知亦不见。法若有法以有便可得色。是故法不可知是为知亦。不知亦不可见。若小儿痴。谓有身即不解便不信。以不解中住故曰小儿。舍利弗白佛。菩萨摩诃萨。作是学为不学萨芸若。佛语舍利弗。菩萨摩诃萨。作是学为不学萨芸若。菩萨摩诃萨不作是学。为学萨芸若以成萨芸若。须菩提白佛。若有问者。天中天。幻为学佛得作佛。或时作是问当何以报之。佛语须菩提。我故问汝随所报之。于须菩提云何。幻与色为有异乎。幻与痛痒思想生死识有异乎。须菩提报佛言。无有异。幻与色天中天。无有异。色是幻幻是色。幻与痛痒思想生死识等无有异。佛言。云何须菩提。所问等不随法。从五阴字菩萨。须菩提言。如是天中天。菩萨摩诃萨。学欲作佛为学幻耳。何以故。作幻者持阴色如幻无所有色。六衰五阴如幻。痛痒思想生死识皆空无所有。但有字六衰五阴耳。须菩提。须菩提白佛言。若新学菩萨摩诃萨。闻是语得无恐怖。佛语须菩提设使新学菩萨摩诃萨。与恶师相得相随或恐或怖。设与善师相随不恐不怖。须菩提白佛。何所菩萨摩诃萨恶师。当何以知之。佛语须菩提。其人不尊重摩诃般若波罗蜜。教人弃舍去。远离菩萨心。反教作想令学杂经。随杂经心邪喜乐。教学余经。声闻若辟支佛事。卷卷令讽诵之。为说魔事魔主行坏败菩萨。为种种说生死勤苦。言菩萨道不可得。是故为菩萨摩诃萨恶师。须菩提白佛。何所是菩萨摩诃萨善师。当何从知之。佛语须菩提。其人尊重摩诃般若波罗蜜。稍稍教人令学成。教语魔事令觉魔令远离诸魔。是故菩萨摩诃萨。摩诃僧那僧涅。摩诃衍三拔致谛。是为菩萨摩诃萨善师。须菩提问佛。何因菩萨名为菩萨。天中天。佛语须菩提。学诸经法悉晓了于诸法无所著。尔故字为菩萨。须菩提复问佛。悉晓知诸经法尔故字菩萨。何以故。复呼摩诃萨。佛语须菩提摩诃萨者于天上天下最尊。尔故字为摩诃萨。舍利弗白佛。我亦乐闻。何以故为摩诃萨。佛语舍利弗。乐闻者当为若说之。摩诃萨者。悉自了见悉了知。一切人世间所有悉了知。人寿命悉了知。悉了知着断之事。便能随人所乐为说法。以是故名为摩诃萨。须菩提白佛。摩诃萨者。天中天。以得摩诃萨字。设菩萨心无有心与心等者。无有能逮心者。诸罗汉辟支佛所不能及。心无所著心。何以故。是萨芸若心故。用无有余故。以是心无所著。是故号为摩诃萨。舍利弗问须菩提。何因菩萨心无所著。须菩提。心无所思故无所著。分耨文陀尼弗白佛。何因摩诃萨摩诃萨者。何所菩萨。为摩诃僧那僧涅。摩诃衍者大乘三拔谛。三拔谛者等住。佛言。是菩萨即为摩诃萨。须菩提白佛。摩诃僧那僧涅者。何因菩萨摩诃萨。为摩诃僧那僧涅。佛言。菩萨摩诃萨。念我当度不可计阿僧祇人悉令般泥洹。如是赐般泥洹。而无有法般泥洹者。何以故。须菩提。譬若如幻师于广大处。化作众人满一城中。悉断所化人头。于须菩提意云何。有所中伤死者不。须菩提言。无有中伤死者。佛言。如是须菩提。度不可计阿僧祇人赐般泥洹。无有人般泥洹者。闻是不恐。当知是菩萨摩诃萨。即为摩诃僧那僧涅。须菩提白佛。如我从佛闻念其中事。如是不为摩诃僧那僧涅。何以故。无有作萨芸若者。无有供养无有作人者。何所人当作僧那僧涅。色。天中天。无著无缚无脱。痛痒思想生死识。天中天。无著无缚无脱。分漫陀尼弗问须菩提。色无著无缚无脱。痛痒思想生死识无著无缚无脱。乃有色不着不缚不脱。乃有痛痒思想生死识不着不缚不脱。何所色。须菩提。无著无缚无脱。何所痛痒思想生死识无著无缚无脱。须菩提语分漫陀尼弗。色如幻无著无缚无脱。痛痒思想生死识如幻。无著无缚无脱。无有边无著无缚无脱。恍忽无著无缚无脱。无所生无著无缚无脱。是故菩萨摩诃萨。摩诃僧那僧涅。须菩提白佛。何因菩萨摩诃萨为摩诃衍三拔谛。何所是摩诃衍。从何所住衍衍为住何所。当从何所立衍中。佛语须菩提。摩诃衍摩诃衍者。无有极不可得边幅。从何所自致立衍。摩诃衍者。从三界出立萨芸若中。亦不于衍有所立不立。何以故。立不立者。于法不知法。何所法当立者。须菩提白佛言。摩诃衍摩诃衍者。于天上天下人中极过上。其衍与空等。如虚空覆不可计阿僧祇人。尔故为摩诃衍。菩萨摩诃萨。亦不见来时亦不见去时。亦不见住处。于摩诃衍。天中天。不能得本。亦不能得当所来。亦不能得中间。于三界见字为摩诃衍。佛言。善哉善哉。须菩提。尔故菩萨摩诃萨为摩诃衍。分漫陀尼弗白佛。尊者须菩提。佛使说般若波罗蜜。乃说摩诃衍事为。须菩提白佛言。我说般若波罗蜜得无过。天中天。佛语须菩提。所说般若波罗蜜。不过如毫毛适得其中。复次天中天。亦不见菩萨本。亦不见当来。菩萨亦不见菩萨中间色无有边。菩萨亦无有边。色菩萨不可逮。亦不可知。亦不可得。如是天中天。菩萨摩诃萨。亦不可知。亦不可得。当以何般若波罗蜜。为菩萨摩诃萨说之。亦不得菩萨。亦不见菩萨。当以何法说般若波罗蜜。菩萨转复相字为菩萨。云何天中天。何所字我我天中天。我者亦灭。是者法之自然。何所是色。其要不灭者。何所色为是。痛痒思想生死识亦尔。识者无有边菩萨亦无有边。菩萨了不知处亦不可见。天中天。一切菩萨摩诃萨。了无有处亦无可得。何所是菩萨摩诃萨。当为说般若波罗蜜。于菩萨都不可得见亦不知处。当从何法中说般若波罗蜜。菩萨摩诃萨。为得字者如是字想。我我天中天。我亦灭。是法之自然。何所识要而不灭者。何所识于法之自然而不灭。不灭者非法作亦不无不灭。何无灭者。如般若波罗蜜。所说不作异灭。当从何法自致。菩萨为住行者。其闻是者不恐不畏。为行般若波罗蜜。般若波罗蜜者。天中天。熟思惟是时。为不入色。何以得色无所生为非色。设非色为无色亦无有生。从其中无所得字。是色为法作数。是时菩萨摩诃萨。为行般若波罗蜜。当视法思惟深入中。是时亦不入痛痒思想生死识。何以故。识无所生为非识。设非识为无识。亦无有生。从其中无所得字是识为法作数。舍利弗问须菩提。所说法无所出生。设菩萨无所出生者。菩萨用何等故。勤苦行菩萨之道。设用一切人故。何能忍是勤苦。须菩提语舍利弗。我亦不使菩萨忍是勤苦行。菩萨忍勤苦行是菩萨之道。不自念我忍勤苦行。何以故。菩萨心不作是念。便能为不可计阿僧祇人而作本令悉安隐。念之如母念之如父。念之如子念之如身。菩萨摩诃萨当持心作是念。一切于菩萨不见亦不知处。于内外法当作是念当作是行。作是行者为忍勤苦行。设使菩萨。舍利弗。不见出生。菩萨为无所生。舍利弗谓须菩提。设使菩萨无所生。萨芸若亦无所生。须菩提语舍利弗。萨芸若亦无所生。舍利弗复谓须菩提。萨芸若无所生。凡人亦无所生。须菩提言。凡人者亦无所生。舍利弗谓须菩提。菩萨无所生。菩萨法亦无所生。萨芸若无所生。萨芸若法亦无所生。凡人亦无所生。凡人法亦无所生。菩萨无所从生自致萨芸若。须菩提言。不从无所生法可入。亦不无无所从生法逮得。舍利弗复问。其生生者乃能逮得法不。须菩提言。无所从生法为逮生。无无所生法是为逮得。舍利弗复言。以生生者。为从无所生生。须菩提言。无所生无所生乐闻。舍利弗语须菩提。无所乐生是故为乐。须菩提言。无所生闻是为闻。舍利弗言。以闻所语。须菩提语舍利弗。无无所语。是为语。无所语无所乐。是故语是故乐。舍利弗言。善哉善哉。须菩提。所说于法中为尊。何以故。尊者须菩提。随所问即答悉报之。须菩提语舍利弗。佛弟子所说法。皆悉如事随其所问即能解。何以故。随法如事故亦不知所出生。舍利弗言。善哉善哉。须菩提。从何波罗蜜度菩萨摩诃萨。须菩提语舍利弗。从般若波罗蜜说是法时。若讽诵读。菩萨摩诃萨。当知信之不疑。有随是法不增。不随是法者不减。舍利弗谓须菩提。随是法不增。不随是法亦不减。随法教一切人。随法者不失一切人。皆使得菩萨摩诃萨。何以故。一切人悉学法其法俗如故。须菩提言。善哉善哉。舍利弗。所解法如。舍利弗言。无异。何以故。人之自然。当念知人之恍忽。当念知恍忽。人身难了知当念知之。舍利弗。菩萨摩诃萨法当作是守当作是行

    摩诃般若波罗蜜问品第二

尔时释提桓因。与四万天人俱来共会。四天王与天上二万天人俱来共会。梵迦夷天与一万天人俱来共会。首陀譮天与五千天人俱来共会。诸天宿命有德。光明巍巍得佛威神力。诸天光明悉不复见。释提桓因白须菩提。若干万千天人大会。欲听须菩提说般若波罗蜜。云何菩萨摩诃萨。于般若波罗蜜中住。须菩提语释提桓因。拘翼。是若干万千天人乐闻者。皆听我当持佛威神力广为诸天人说般若波罗蜜。何所天人未发菩萨心者。今皆当行。以得须陀洹者不可复得菩萨道。何以故。闭塞生死故。正使是辈人索菩萨道。我亦劝助之不断其功德。悉使取法中极尊欲使极上。佛言。善哉善哉。须菩提。劝乐诸学乃尔。须菩提白佛言。我当报恩不得不报。何以故过去时怛萨阿竭皆令弟子为诸菩萨说般若波罗蜜。怛萨阿竭。时亦在其中学。如是法中今自致作佛。天中天。因是故当报恩。今我复说般若波罗蜜。菩萨亦当复受菩萨法。我亦复劝乐菩萨摩诃萨疾得成佛。须菩提语拘翼。当所问者。且听所问。菩萨摩诃萨。云何住般若波罗蜜。菩萨摩诃萨以空住般若波罗蜜。菩萨摩诃萨。摩僧那僧涅。摩诃衍。三拔谛色不那中住。痛痒思想生死识不那中住。须陀洹不那中住。斯陀含不那中住。阿那含不那中住。阿罗汉不那中住。辟支佛不那中住。佛不那中住。有色不那中住。有痛痒思想生死识不那中住有须陀洹不那中住有斯陀含不那中住。有阿那含不那中住。有阿罗汉不那中住。有辟支佛不那中住。有佛不那中住。色常无常不那中住。痛痒思想生死识常无常不那中住。色若乐若苦不那中住。痛痒思想生死识若苦若乐不那中住。色若空不空。不那中住。痛痒思想生死识若空不空不那中住。色是我所非我所不那中住。痛痒思想生死识是我所非我所不那中住。须陀洹道不动成就不那中住。须陀洹道成已不那中住。何以故。七死七生便度去。是故须陀洹道不那中住。斯陀含道不动成就不那中住。斯陀含道成已不那中住。何以故。斯陀含一死一生便度去。是故斯陀含道不那中住。阿那含道不动成就不那中住。阿那含道成已便于天上般泥洹。是故阿那含道不那中住。阿罗汉道不动成就不那中住。何以故。罗汉道成已便尽是间无有余泥洹般泥洹。是故罗汉道不那中住。辟支佛道不动成就不那中住。辟支佛道成已过声闻道地。不逮佛道。便中道般泥洹。是故辟支佛道不那中住。自致成佛。为阿僧祇人作本教。不可计阿僧祇人皆当般泥洹。佛所作为皆究竟已当般泥洹。亦不那中住。舍利弗心念言。菩萨云何住。须菩提知舍利弗心所念。便即报之。云何舍利弗。佛为在何所住。舍利弗语须菩提。佛无所住。怛萨阿竭心无所住止。亦不在不动处止。亦无动处止。须菩提语舍利弗。菩萨摩诃萨当作是学。如怛萨阿竭不住亦不不住亦无无住。当作是学住。诸天人闻是其心各作是念。诸阅叉若大若小所语悉可了知尊者须菩提所说了不可知须菩提。知诸天人心之所念。即报言。是语难了难了。亦不可闻亦不可知。诸天人心各各复念。是语当解当解。今尊者须菩提。所知深入深入。须菩提。即复知诸天人心所念语诸天人。欲得须陀洹道证以得须陀洹道不忍不那中住便度去。欲得斯陀含道证以得斯陀含道不忍不那中住便度去。欲得阿那含道证以得阿那含道。不忍不那中住便度去。欲得阿罗汉道证已得罗汉道不忍不那中住便度去。欲得辟支佛道证已得辟支佛道不忍不那中住便度去。欲得佛道证已得佛道不忍不那中住便度去。诸天人皆念言。尊者须菩提所说乃尔。谁当听受是法者。须菩提知诸天人心所念语诸天人幻人者当听我法当受我法。何以故。从我闻法已亦不作证。诸天人心各各复念。云何幻人听法与人等无有异。须菩提。知诸天人心所念语诸天人。幻如人人如幻。须菩提言。我说须陀洹斯陀含阿那含阿罗汉辟支佛道亦如幻耳。正使佛道我说亦复如幻。诸天人谓须菩提。乃至佛亦复说如幻。须菩提语诸天人。乃至泥洹亦复如幻。诸天人复问须菩提。乃至泥洹亦复如幻云何。须菩提言。诸天人设复有法出于泥洹者亦复如幻。何以故。幻人泥洹赐如空所有。舍利弗。分漫陀尼弗。摩诃拘絺罗。摩诃迦栴延等。共问须菩提。般若波罗蜜实重深。何等人当受是法者。贤者阿难亦尔。须菩提报诸比丘言。阿惟越致菩萨当受是法。若成就阿罗汉者。复有是法无有持者。何以故。般若波罗蜜说相如是。从中无所出。何以故。法中无所有。无所闻无所得。如是法。比无所闻法无所得法。从是法中无所受。释提桓因心念。雨法宝尊者须菩提所说。我宁可化作华持散须菩提上。释提桓因。即化作华散尊者须菩提上。须菩提即言。是华不出于忉利天上。曾见是华为从幻化。释提桓因。所化散我上者为从心树出。不从树木出生。是华为从心树出生。释提桓因言。如所说华为从心树出。须菩提言。如是拘翼。释提桓因言。亦不从心树出。须菩提言。以是故为非华。释提桓因言。尊者须菩提。所入慧甚深甚深。所说不增不减。作是说法。如须菩提教菩萨摩诃萨当作是学。须菩提语释提桓因。拘翼所言如语无有异。是菩萨摩诃萨所学。菩萨摩诃萨所学。菩萨摩诃萨作是学者。为不学须陀洹斯陀含阿那含阿罗汉辟支佛道。是菩萨为学萨芸若。作是学者为学不可计阿僧祇法。不生色学不生痛痒思想生死识学。不学受色不学痛痒思想生死识。不学受想法乐。亦不学受有所失。作是者为学萨芸若。为如萨芸若。舍利弗语须菩提。作是学者亦不受萨芸若亦不失学。为学萨芸若。为如萨芸若。须菩提语舍利弗。作是学亦不受萨芸若。亦不失学。是为学萨芸若。为如萨芸若。释提桓因问舍利弗。菩萨摩诃萨。当云何求般若波罗蜜。舍利弗言。当问尊者须菩提。释提桓因问尊者须菩提。当持何威神恩而所学。须菩提言。所学者悉承用佛威神恩。属拘翼所问。菩萨摩诃萨。当云何求般若波罗蜜。亦不可从色求亦不可离色求。亦不可从痛痒思想生死识求。亦不可离识求。何以故。般若波罗蜜亦非色亦不离色。般若波罗蜜。非痛痒思想生死识。般若波罗蜜亦不离识。般若波罗蜜。释提桓因问须菩提。摩诃波罗蜜无有边。摩诃波罗蜜无有极。须菩提语拘翼。摩诃波罗蜜。无有边无有极。波罗蜜了不可见无有极。波罗蜜了不可极。人无极波罗蜜亦无极。如是拘翼。当云何求波罗蜜。于法中无有极。无有边际亦无中间。亦不能得有所限。波罗蜜者。亦复如是。复次拘翼。法者无际无限。无有极。无有中间无可得者。释提桓因言。云何尊者须菩提。人无极。波罗蜜亦无极。须菩提语释提桓因。都卢不可议计。正使倍复倍人亦无极。波罗蜜亦复无极。释提桓因言。何缘人无极波罗蜜亦无极。须菩提言。于拘翼意云何。何所法中说人人之本。释提桓因言。无有法作是说者。亦无法留置者。设有出者但字耳。无有作者但以字耳。须菩提言。于释提桓因云何。能有人可得见者不。释提桓因言。不可得见。须菩提报释提桓因。无有作者何所有人。正使怛萨阿竭阿惟三佛寿如恒边沙劫说有人生者灭者。释提桓因言。无有人。何以故。本净净故。以是拘翼。人无有极。当作是念般若波罗蜜

摩诃般若钞经卷第一摩诃般若钞经卷第二

        前秦天竺沙门昙摩蜱共竺佛念译

    功德品第三

尔时诸因坻天。诸梵天。诸波耶和提天。诸伊沙天。诸那提干天。同时三反作是称誉法。贤者须菩提。所说法甚深。怛萨阿竭皆从是生。其有闻者若讽诵读有行者我辈恭敬视如怛萨阿竭。我辈恭敬视菩萨摩诃萨持般若波罗蜜。佛语诸天人。如是如是。昔我于提和竭罗佛前。逮得般若波罗蜜。我便为提和竭罗佛所授决言。却后若当为人中之导。悉当逮佛智慧。却后无数阿僧祇劫。汝当作佛。号字释迦文天上天下于中最尊安定世间法中极明号曰为佛。诸天人白佛言。甚善。菩萨摩诃萨。天中天行般若波罗蜜自致行到萨芸若。佛于天会中告诸比丘比丘尼优婆塞优婆夷。今以四辈为证。欲天梵天阿陂譮天皆共证知。佛语释提桓因。拘翼。若有善男子善女人。其有学般若波罗蜜持诵者。是善男子善女人。魔若魔天若人若非人。终不能得其便。亦不得横死。复次拘翼。忉利天上诸天人。其有行佛道者。未得般若波罗蜜学诵者。是辈天人皆当往到善男子善女人所其学持诵般若波罗蜜者。若行空闲屏隈之处。终不恐怖无所畏惧。四天王白佛言。我辈自共拥护是善男子善女人学般若波罗蜜持者诵者。梵摩三钵天。及诸梵天人。俱白佛言。我辈自共拥护是善男子善女人学般若波罗蜜持诵者释提桓因白佛言。我自拥护是善男子善女人学般若波罗蜜持诵者。释提桓因复白佛言。难及天中天。若善男子善女人。有学般若波罗蜜者便得现在法。其受般若波罗蜜者。天中天。为悉受六波罗蜜。佛言。如是拘翼。其受般若波罗蜜者。为悉受六波罗蜜。复次拘翼。若善男子善女人。学持讽诵般若波罗蜜者。拘翼且听。我说其人所得功德。上语亦善中语亦善下语亦善。释提桓因言。受教。佛语拘翼。其欲于我法中有所娆害乱者。其人稍稍起恶意。欲来未至中道而亡。是善男子善女人。用学般若波罗蜜持诵故。其人赍恶往来至。稍稍娆害乱意自止。便屈还终不至是者。拘翼。善男子善女人所作。为悉自见得。用学持诵般若波罗蜜故。譬若有药。拘翼。名为摩只。有蛇饥者行索食所当啖食。道逢虫豸蛇欲啖之。虫行到摩只药所。蛇闻药香即走还去。何以故。药力所却蛇毒即歇。药力所厌。如是拘翼。若善男子善女人。学持诵般若波罗蜜者。其有欲害便自消亡。用般若波罗蜜威神力所却。佛言。设有谋作者所从来处。便于彼斗破坏不复成。四天王皆拥护是善男子善女人若入般若波罗蜜中思惟者。自在所为所语如甘露所语悉尊重。嗔恚不生不自贡高。四天王皆当拥护是善男子善女人学持诵般若波罗蜜者。所语无有异所言如甘露。所言不轻嗔恚不起自贡高不生。何以故。用学般若波罗蜜故。不爱贡高不爱自用不爱嗔恚。是善男子善女人心自生念。若有斗诤常当远离。面自羞惭。念是曹之恶而不可近。自念我索佛道。不可随嗔恚语。疾使我逮好心。是善男子善女人所作。为悉自见现在功德。其学持诵般若波罗蜜者亦尔。释提桓因白佛言。难当天中天。为般若波罗蜜者乃过诸恶上去。自在所作无有与等者。佛语释提桓因。复次拘翼。善男子善女人。学持诵般若波罗蜜者。或过剧难之中终不恐。正使入军不被兵。佛言。我所语无有异。若善男子善女人。当是时念诵般若波罗蜜。正使于中当死。若冤家在中欲共害之。如佛所语无有异。是善男子善女人。终不于中横死。正使在中若有射者若有兵向者终不中其身。何以故。是般若波罗蜜者。极大咒持尊之咒。学是咒者。善男子善女人。不自念恶亦不念他人恶。都不念恶为人中之雄。自致作佛当护一切人。学是咒者疾成得佛。复次拘翼。若书般若波罗蜜学持诵经者。若人若非人不能害之。除宿命之罪不可请避。若佛初得道处。若有人从在方面来入其中。若鬼神禽兽欲来娆者终不能伤害。何以故。用过去当来今现在佛悉从是处自致成佛。以是故。不恐不怖无所畏惧。般若波罗蜜者。亦复如是。在所止处。一切皆为作礼恭敬护视之。释提桓因白佛言。若有天中天。书般若波罗蜜。持经卷自归作礼承事者。名华好香捣香杂香泽香烧香。缯彩华盖幢幡以是供养。若有持怛萨阿竭阿罗诃三耶三佛舍利起塔。自归作礼承事。好华名香捣香杂香泽香烧香。缯彩华盖幢幡持用供养。佛问拘翼。如是其福何所为多者。随所乐报云何。拘翼。怛萨阿竭阿罗诃三耶三菩。自致萨芸若。成佛身出见。从何法中学。得阿耨多罗三耶三菩阿惟三佛。释提桓因报言。怛萨阿竭从般若波罗蜜学。得阿耨多罗三耶三菩。自致成阿惟三佛。佛语释提桓因。不用身舍利故。为从萨芸若得佛。怛萨阿竭者。为从般若波罗蜜出。如是拘翼。萨芸若身者。为从般若波罗蜜出。怛萨阿竭阿罗诃三耶三菩。为从萨芸若生。我得作佛身。我般泥洹已后。舍利亦得供养。若有善男子善女人。书般若波罗蜜。学持诵行自归作礼承事。以好华名香捣香杂香泽香烧香。缯彩华盖幢幡持用供养。即为供养萨芸若慧已。复次拘翼。其有书般若波罗蜜者。持经卷虽不读但供养作礼。是善男子善女人。从其中得功德无比。何以故。为供养萨芸若慧故。释提桓因白佛言。如是天中天。阎浮利人。不供养事般若波罗蜜者。是辈人不知般若波罗蜜为尊。当得福无比。佛语释提桓因。云何拘翼。阎浮利人中。有几所信佛信法信比丘僧者。释提桓因白佛言。阎浮利人。少所信佛信法信比丘僧者少少耳。及行须陀洹斯陀含阿那含阿罗汉辟支佛少少耳。能至行佛道者亦复少少耳。佛言。如是拘翼。至有索佛道行者亦复少少耳求佛者。不可计阿僧祇人欲作菩萨行。然后从其中出者若一若两。在阿惟越致地立。以是故。拘翼。若善男子善女人行求佛道者。学持诵般若波罗蜜经。当为作礼承事恭敬。所以者何。用晓般若波罗蜜故。过去怛萨阿竭阿罗诃三耶三佛。本从菩萨行般若波罗蜜所学。我时亦在中学。怛萨阿竭般泥洹后。菩萨摩诃萨。悉当受是般若波罗蜜。怛萨阿竭般泥洹后。拘翼。若善男子善女人。取舍利供养起七宝塔。尽寿自归作礼承事。供养天华捣香泽香烧香杂香天缯华盖幢幡。如是于拘翼意云何。其所作为福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡得福甚多。佛言。置是塔。拘翼。若满阎浮利七宝塔。善男子善女人。尽形寿自归作礼承事。供养天华好香捣香杂香泽香烧香天缯华盖幢幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名香好香捣香杂香泽香烧香缯彩华盖幢幡得福甚多。佛言。且置是阎浮利所作塔。满四天下七宝塔。拘翼。若善男子善女人。尽形寿自归作礼承事。供养天华好香捣香杂香泽香烧香天缯华盖幢幡其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香缯彩华盖幢幡得福甚多。佛言。置四天下塔。拘翼。譬如一天下。复次一天下。如是千天下。四面皆满七宝塔。若善男子善女人。尽形寿自归作礼承事。供养天华好香捣香杂香泽香烧香天缯华盖幢幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯华盖幢幡得福甚多佛言。复置千天下。拘翼。复次千小国土。如是中为二千国土。四面皆满七宝塔。若善男子善女人。尽形寿自归作礼承事。供养天华捣香杂香泽香烧香天缯盖幢幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经自归作礼承事。供养名华好香捣香杂香泽香烧香缯盖幢幡得福甚多。佛言。置二千中国土。拘翼。三千大千国土四面满中七宝塔。若有善男子善女人。尽形寿。自归作礼承事。供养天华捣香杂香泽香烧香天缯盖幢幡。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡得福甚多。佛言。置三千大千国土七宝塔。拘翼。若三千大千国土中。一切菩萨悉得为人。人人作七宝塔。是辈人尽形寿。持倡伎乐歌舞天杂香名华捣香泽香烧香缯彩华盖幢幡持用供养。云何拘翼。是功德福宁多不。释提桓因言。其所作福德功德。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡得福甚多。释提桓因白佛言。如是如是。天中天。其自归般若波罗蜜作礼承事者。为供养过去当来今现在佛萨芸若已。释提桓因复白佛。置三千大千国土人。人人所作七宝塔。如恒河沙佛刹满中人。人人悉起七宝。塔皆供养。一劫复至一劫。持天华名香捣香杂香泽香烧香天缯华盖幢幡。以天上天下诸伎乐持用供养。其福功德。不如善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡所有得福出彼上。佛语释提桓因。如是拘翼。不如善男子善女人。从法中得福极多。不可计不可议。不可称不可量不可极。何以故。拘翼。怛萨阿竭阿罗诃三耶三佛萨芸若者。为从般若波罗蜜出。如是拘翼。善男子善女人。书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡。如是拘翼。是皆前世功德所致。佛言。如恒边沙佛刹百倍。皆起七宝塔。不在计中千倍。不在计中百千倍。不在计中万亿倍。不在计中无数倍。不在般若波罗蜜供养计中。尔时四万天子与释共来会者。皆谓释提桓因。尊者当取般若波罗蜜。当诵般若波罗蜜。佛语释提桓因。当学持诵般若波罗蜜。何以故。若阿须伦生念。欲起兵与忉利天共战。是时拘翼。当念诵般若波罗蜜。阿须伦即休兵众即还。释提桓因白佛。般若波罗蜜极大咒。天中天。般若波罗蜜极尊咒无有辈咒。佛言。如是如是。拘翼。般若波罗蜜为极大咒。般若波罗蜜为极尊咒。般若波罗蜜无有辈咒。是咒。拘翼。过去怛萨阿竭阿罗诃三耶三佛。皆从是咒自致作佛。甫当来诸怛萨阿竭阿罗诃三耶三佛。皆学是咒自致得佛。今现在诸佛。皆从是咒自致作佛。是咒者。拘翼。出十善功德照明于世。四禅四谛四神足五旬照明于世。菩萨摩诃萨。因沤和拘舍罗中。生十善功德照明世间。复次拘翼。若善男子善女人。学持诵般若波罗蜜者。便得现在法听。释提桓因问佛。云何当得今现在法听。佛言。其人终不横死终不中毒死。终不于溺死终不兵死。若时时遭县官。若为县官所侵。当诵念般若波罗蜜。往到其所终不得危害。何以故。般若波罗蜜所拥护。若为县官所呼召。当诵念般若波罗蜜。彼间若王若太子傍臣所使与相见。即得好语各皆欢喜。何以故。用学般若波罗蜜。慈心愍伤哀念一切人蜎飞蠕动故。其欲得害者不能得其便。佛说是时有异道人。遥见佛欲往乱坐。释提桓因自念言。尽我寿常得在佛边。受诵般若波罗蜜。异道人欲但来必乱我。令不得受般若波罗蜜。释提桓因从佛所受。诵般若波罗蜜。彼异道人即遥远所绕天中天一匝。便从彼道径还去。舍利弗心念。云何异道人从彼间中道而去。佛知舍利弗心所念。即言。是异道人无有好意来。释提桓因念般若波罗蜜。以故中道还去。弊魔作是念。怛萨阿竭阿罗诃三耶三佛。与四辈弟子共坐。欲天梵天诸天子。悉复在中无有异人。菩萨摩诃萨今受决者。当为人中之将自致作佛。我当往乱之。弊魔化乘一辕之车驾四马。稍稍欲前到佛所。释提桓因念。弊魔乘四马之车。欲来到佛所。非国王[卄/汧]沙四马之车亦不类。国王波斯匿四马之车亦非类。释种堕舍利种四马之车不类。是弊魔所作。常念索佛便欲乱世间人。释提桓因常愿欲念诵读般若波罗蜜。即时心念般若波罗蜜且欲究竟。弊魔即复道还去。忉利天上人持所化华。飞在空中用散佛上。皆言。使般若波罗蜜得久在阎浮利。令人悉得闻见。便复持天上若干种华。已散佛上。皆言。其有行般若波罗蜜者。守般若波罗蜜者。亦不为魔及魔天所得便。释提桓因白佛言。其闻般若波罗蜜者。是辈人其福功德不少。何况学诵持者。讽诵学已复行教人。是人前世已为见佛从闻般若波罗蜜。何况学持诵已行如中事者。即为供养怛萨阿竭已。何以故。欲得萨芸若者。当从般若波罗蜜。譬如欲得极天宝者。天中天。当从大海。欲得萨芸若珍宝者。天中天。怛萨阿竭阿罗诃三耶三佛。当从般若波罗蜜索之。佛言。如是如是。拘翼。怛萨阿竭阿罗诃三耶三佛。为从萨芸若出。阿难白佛言。无有说檀波罗蜜者。亦不尸波罗蜜。亦不羼波罗蜜。亦不惟逮波罗蜜。亦不禅波罗蜜。都无说是字者。但共说般若波罗蜜。何以故。天中天。佛语阿难。般若波罗蜜。五波罗蜜中最尊。云何阿难。不作萨芸若布施。能为檀波罗蜜不。不作萨芸若净戒忍辱精进一心智慧。能为尸羼惟逮禅波罗蜜不。阿难言。如是如是。天中天。无波罗蜜者为布施。萨芸若者是檀波罗蜜。无波罗蜜为戒忍辱精进一心智慧。萨芸若者是般若波罗蜜。佛语阿难。用是故。般若波罗蜜五波罗蜜中为最尊。譬如掘地以种散其中同时俱出生如是阿难。般若波罗蜜者。为生五波罗蜜萨芸若者从般若波罗蜜成。以是故阿难。般若波罗蜜于五波罗蜜。为极大尊自在所教。释提桓因白佛言。怛萨阿竭阿罗诃三耶三佛说。善男子善女人。从般若波罗蜜教学持诵者。说其功德未能竟。佛语拘翼。我不说讽起者。功德未竟说。善男子善女人。书般若波罗蜜者。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡。我说是供养功德耳。释提桓因白佛。我自拥护。视是善男子善女人书般若波罗蜜。持经卷自归供养承事名华好香捣香杂香泽香烧香缯彩华盖幢幡者。佛语拘翼。善男子善女人。诵般若波罗蜜时。若干百千天。往到其所听闻其法。若有于法不解。欲问法师适作是念。用兹法故应时各解。是善男子善女人。便得今现在法听。复次拘翼。善男子善女人。于四辈弟子中说般若波罗蜜。其心都无所难。若形试者终不畏。何以故。为般若波罗蜜所拥护。其所形试者便即而去。佛言。我了不见为般若波罗蜜者。何况欲形试般若波罗蜜。即是不能得见。为般若波罗蜜之所厌服。善男子善女人。无有敢轻易者。心亦无所畏恐。是善男子善女人。为悉见今现在所作功德法。复次拘翼。若善男子善女人。敬爱父母沙门道人知识兄弟宗亲中外。或时其欲说恶事者。持中正法为解说之。是者拘翼。善男子善女人。便得今现在所作功德法

复次拘翼。善男子善女人。书般若波罗蜜持经卷书。四天王上诸天人索佛道者。当到彼所问讯听受般若波罗蜜。作礼绕竟便去。忉利天上诸天人索佛道者。当到彼所问讯听受般若波罗蜜。作礼绕竟便去。盐天上诸天人索佛道者。当到。彼所问讯听受般若波罗蜜。作礼绕竟便去。是善男子善女人心当知。无央数阿僧祇佛刹。诸天人龙阅叉揵陀罗。阿须伦。迦楼罗。甄陀。摩睺休。人非人。当来到是间问讯听受般若波罗蜜作礼绕竟各自便去。是即为施。兜术天上诸天人索佛道者。当到彼所问讯听受般若波罗蜜。作礼绕竟便去。尼摩罗提天上诸天人索佛道者。当到彼间问讯听受般若波罗蜜。作礼绕竟便去。波罗尼蜜和耶拔致天上诸天人索佛道者。当到彼所问讯听受般若波罗蜜。作礼绕竟便去。梵迦夷天。梵富楼天。梵波产天。摩诃梵天。[病-丙+盍]天。波利陀天。[病-丙+盍]波摩那天。阿陂亘羞天。波利陀首诃天。阿波摩首天。首诃迦天。惟番罗天。阿比天。阿陀首天。首陀施天。阿迦腻吒天等诸天人。皆当到彼所问讯听受般若波罗蜜。作礼绕竟便各自去。乃至阿迦腻吒天常悉来下。何况拘翼。三千大千国土诸欲天人。诸色天人。悉皆当来问讯听受般若波罗蜜。作礼绕竟各自还去。是善男子善女人。在所止处。常当完坚无有娆者。除其宿命不请。余不能动。是善男子善女人。便得今现在功德法。诸天来时当可知。释提桓因。云何天中天。是善男子善女人。当何从知诸天来时。听受承事供养作礼。佛言。善男子善女人。若见光明知诸天若龙阅叉揵陀罗。来听受般若波罗蜜。承事作礼。其心欢喜踊跃知已为来。复次拘翼。善男子善女人。曾所不闻香若闻香。当知鬼神来已。复次拘翼。善男子善女人。当净身体用净洁故鬼神皆大欢喜。数往到彼所。其人踊跃。如小天去大天来到。以是譬之。其威神甚尊。光明巍巍。是善男子善女人。常欢喜净洁住。其病终不着身。所止常得安隐。未曾有恶梦。梦中不见余但见佛但见塔。但闻般若波罗蜜。但见佛所坐树。但见法轮转。但见且欲成佛时。但见诸佛成得佛已转法轮。但见若干菩萨。但见说六波罗蜜种种为解慧。但见当作佛者。但见余佛刹。但闻佛尊法。但见某方某刹怛萨阿竭阿罗诃三耶三佛。若干百千弟子若干亿弟子。佛在其中而说法。是者拘翼。善男子善女人。于梦中所见已便安隐。觉即身为轻不复思食。身如食软美而饱。譬若比丘得禅。从禅觉已其心软好。不大思食自软美饱。如是拘翼。是善男子善女人。从觉已不大思食。自想身软美如饱。何以故。拘翼。其邪鬼神不敢近。是善男子善女人。为自见今现在功德法已。用学诵般若波罗蜜故。若有书写虽不诵读但持经卷。自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡。复次拘翼。或阎浮利中。满怛萨阿竭舍利。若般若波罗蜜经。是二者欲取何所。释提桓因言。我宁取般若波罗蜜。何以故。我不敢不敬舍利。天中天。其舍利者为从般若波罗蜜出而得供养。如我于诸天中而独持坐。或时不在座上。敢有天人来到者。皆承事为座作礼。所受教处便即而去。般若波罗蜜出者是如天中天。出怛萨阿竭阿罗诃三耶三佛舍利。为从萨芸若智慧出生。阎浮利中满怛萨阿竭舍利。正使天中天。三千大千国土满中舍利为一分。般若波罗蜜经为二分。我从二分之中取般若波罗蜜。何以故。舍利为从中出自到得供养。譬如负债之人。天中天。与王者相知得甚敬爱。无有问者亦无所畏。何以故。在王边得威力故。天中天。以从般若波罗蜜者便出舍利。而得供养般若波罗蜜。譬若如王其住附者辄为人所敬。怛萨阿竭舍利。为从萨芸若出生。便得供养。是天中天。萨芸若慧。怛萨阿竭阿罗诃三耶三佛。为从般若波罗蜜出。当作是知两分之中。我取般若波罗蜜。其受般若波罗蜜持者。譬如无价摩尼珠。天中天。其有是宝无有与等者。在所著处鬼神不得其便。不为鬼神所害。若男子女人。无大无小其得邪者持。是摩尼珠着身其鬼神即走去若。中热者持是摩尼宝着身上。其热即为除。若中风者。持是摩尼珠着身上。其风即为除。若中寒者。持是摩尼珠着身上。其寒不复增即得除去。若夜时持摩尼珠着冥中即为悉明。若热时持摩尼珠。在所著处即为大凉。若寒时持摩尼珠。在所著处即为大温。在所置处诸毒即为不行。若男子女人。无大无小若蛇蟒所啮。持是摩尼珠着之毒即自去。是摩尼珠天中天。之为极尊。若有人病目痛者若得目冥持是摩尼珠近眼痛即为除愈。如是天中天。摩尼珠之德甚大巍巍。若着水中水即如色。持若干种缯。郑重裹摩尼珠着其水中水即随色。若水浊者即时为清。摩尼之德而无与比。阿难问释提桓因。云何拘翼。天上亦有摩尼。阎浮利地上亦有摩尼。俱同摩尼能有差别。即报阿难。天上摩尼者不与人间俱同。阎浮利所有其光明自然不足言耳。如我所说即之有异。其德甚尊十倍百千倍。万亿倍巨亿万倍。如我所语摩尼者。若着箧中若着函中。其光明彻照于外。假使举珠出去。其处续明如故。般若波罗蜜者。是萨芸若之慧。至怛萨阿竭阿罗诃三耶三佛般泥洹去后。舍利续得供养。舍利者即为萨芸若之函器。复次天中天。若三千大千国土满中舍利。乃至恒边沙佛刹满中舍利。合为一分。般若波罗蜜经为二分。我宁从二分之中。取般若波罗蜜。何以故。怛萨阿竭为从萨芸若生。其舍利者从般若波罗蜜出自致得供养。若善男子善女人。天中天。欲见今现在阿僧祇刹土诸佛。当承法如般若波罗蜜行。当作是念。佛语释提桓因言。如是拘翼。过去时怛萨阿竭阿罗诃三耶三佛。皆从般若波罗蜜自致成佛。甫当来怛萨阿竭阿罗诃三耶三菩。悉从般若波罗蜜当自致成作佛。今现在无央数阿僧祇刹土诸佛。亦从般若波罗蜜自致成作佛。释提桓因白佛言。摩诃波罗蜜。天中天。一切人蜎蜚蠕动。若波罗蜜悉了知之。佛言。菩萨摩诃萨用是知故。昼夜行般若波罗蜜。释提桓因言。所以但行般若波罗蜜。不行余波罗蜜者何。佛言。菩萨摩诃萨悉行六波罗蜜。般若波罗蜜于菩萨摩诃萨为最尊。若所施与般若波罗蜜为出其上。诫者无所犯。忍辱者为自守。精进者不懈怠。一心者而不乱。悉见诸法。是菩萨摩诃萨。为行般若波罗蜜。譬若阎浮利地上。拘翼。种种树木若干种色。各各异叶各各异华。各各异实各各异种。其影者而无异。即皆悉相类。如是拘翼。五波罗蜜为从般若波罗蜜出萨芸若。种种展转相得无有异。释提桓因白佛言。极大尊之德无过般若波罗蜜。天中天。不可计德无过般若波罗蜜。天中天。无有已波罗蜜。天中天。若有书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡。中复有书般若波罗蜜者。持施与人。其福何所为多。佛言。故问拘翼。自恣报之。若有怛萨阿竭舍利自供养。复分布与他人令供养之。中有自供养舍利不分布与人。其福何所多者。释提桓因言。是善男子善女人。自供养舍利。天中天。复分与人。其福出彼上甚多。佛言如是如是。拘翼。善男子善女人。若书般若波罗蜜。持经卷自归作礼承事。供养名华好香捣香杂香泽香烧香缯彩华盖幢幡。复书经卷分与他人令供养之其福甚大。复次拘翼。若法师在所至凑辄说经法分教于人。其功德甚大甚大

复次拘翼。阎浮利人悉是善男子善女人。皆令持十善。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷与人使书之。若为人读其福倍多。复次拘翼。置阎浮利。及四天下诸小千国土。二千中国土。三千大千国土。乃至恒边沙佛刹人。悉是善男子善女人。皆令持十善。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。善男子善女人。书般若波罗蜜。持经卷与人使书。若为人读其福倍多。复次拘翼。阎浮利人。悉是善男子善女人。皆令行四禅四谛四神足五旬。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷与人使书之若为人读其福倍甚益多。复次拘翼。置阎浮利四天下。及三千大千国土。乃至恒边沙佛刹人。悉是善男子善女人。皆令行四禅四谛四神足及五旬悉令得成。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷与人使书之。若为人读其福转倍。复次拘翼。若有人读般若波罗蜜者。复教余人令学之。其福甚倍益多。复次拘翼。若有人自学般若波罗蜜。复为人解其慧。得福转甚倍多。释提桓因白佛言。云何学般若波罗蜜解中慧者。天中天。佛言。其不晓者为解说之。若有当来善男子善女人。欲得阿耨多罗三耶三菩。阿惟三佛者。应学般若波罗蜜。反得恶师教学枝掖般若波罗蜜。释提桓因问佛。何谓为枝掖般若波罗蜜者。佛言。甫当来世有比丘。欲学般若波罗蜜。为恶师所反教。释提桓因言。何所为反教者。佛言。教人学色之无常。令人于色求无常。作是行般若波罗蜜作无常。学痛痒思想生死识于识求无常。作是行般若波罗蜜。拘翼。是为枝掖般若波罗蜜。佛言。其人作坏色行。求色无常。坏痛痒思想生死识行。于识求无常。视其作是行者。若有黠慧。当持般若波罗蜜为解之。其福转倍益多。复次拘翼。故阎浮利人。若善男子善女人。皆令得须陀洹道。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷与人使书之教令学。若为人读其福倍益甚多。何以故。须陀洹道者。皆从般若波罗蜜出。复次拘翼。置阎浮利。正使三千大千国土乃至恒边沙佛刹人教令得斯陀含。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷。与人使书之。教令学。若为人读。其福德益甚多。何以故。萨芸若德成法听故。从般若波罗蜜中成得佛。便出须陀洹道。复次拘翼。悉得斯陀含阿那含阿罗汉道。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如是善男子善女人。书般若波罗蜜。持经卷与人使书之。若为人读其福甚多。以是故皆从是法各各悉得。是般若波罗蜜之所致。何以故。为萨芸若法。以学萨芸若法。便能教成须陀洹斯陀含阿那含阿罗汉辟支佛。置阎浮利人。拘翼。及三千大千国土。乃至恒边沙佛刹人。悉教善男子善女人。皆令得成须陀洹斯陀含阿那含阿罗汉辟支佛道。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。不如善男子善女人。书般若波罗蜜。持经卷与人使书之。教令学若为人读其福益倍多。何以故。皆从般若波罗蜜。因萨芸若法德。用是故得须陀洹斯陀含阿那含阿罗汉辟支佛道。用是故其福转倍益多。复次拘翼。阎浮利人。都使发菩萨心。不如善男子善女人。持般若波罗蜜经卷与人使书。教令学为说之。若授与阿惟越致菩萨经书。其人当从是学深入般若波罗蜜。学知般若波罗蜜者转增益多。守无极知因得成就。以是故其福转倍甚多甚多。置阎浮利三千大千国土。拘翼。及如恒边沙佛刹人。皆发心为阿耨多罗三耶三菩行。不如善男子善女人。持般若波罗蜜经卷。与人使书之。教令学为说之。及授与阿惟越致菩萨经书。使人当从是学深入般若波罗蜜。学知般若波罗蜜者转增益多。守无极知因得成就。以是故其福转倍甚多。复次拘翼。阎浮利人皆发阿耨多罗三耶三菩行。不如善男子善女人。持般若波罗蜜经卷与人使书之。为解说其慧令学之。及授与阿惟越致菩萨摩诃萨般若波罗蜜经为解中慧。其福转倍益多。置阎浮利三千大千国土。及至恒边沙佛刹人。皆发阿耨多罗三耶三菩心。不如善男子善女人。持般若波罗蜜经卷与人使书之。教令学入黠慧中。若授与阿惟越致菩萨摩诃萨般若波罗蜜经为解中慧。其福转倍益多。复次拘翼。阎浮利人。皆令如阿惟越致菩萨阿耨多罗三耶三菩。若有善男子善女人。随教人入般若波罗蜜中。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。从是辈中若有一菩萨。便作是语。我欲疾作佛。正使欲疾作佛。不如人入般若波罗蜜者。其福转倍益多。置阎浮利三千大千国土。及至恒边沙佛刹人。皆悉如阿惟越致菩萨。阿耨多罗三藐三菩。若有教善男子善女人。入般若波罗蜜中。云何拘翼。其福宁多不。释提桓因言。甚多甚多。天中天。佛言。若有一菩萨从其中作是言。我欲疾作佛。正使疾作佛。不如持般若波罗蜜授与人者。其福转倍益多。释提桓因白佛言。如是如是。天中天。极安隐者即菩萨摩诃萨今近佛。坐持衣食床卧具供养医药所当得。不如持般若波罗蜜教授人者。其福转倍益多。何以故。天中天其得般若波罗蜜者。今近佛坐。须菩提语释提桓因言。善哉善哉。拘翼。于尊弟子菩萨摩诃萨中乃作是观。诸声闻者。因是而得成。是辈人不索佛道者。菩萨摩诃萨。不当于中学六波罗蜜。不学是法者不得作佛。随法如学。疾成阿耨多罗三耶三菩。便得至佛

摩诃般若钞经卷第二摩诃般若钞经卷第三

        秦天竺沙门昙摩蜱共竺佛念译

    善权品第四

尔时弥勒菩萨。谓须菩提。若有菩萨摩诃萨劝助为福。出入布施持戒自守者上。其福转尊极上无过。菩萨摩诃萨劝助福德。须菩提语弥勒菩萨。复有菩萨摩诃萨。阿僧祇刹土诸佛所而作功德。一一刹土不可计佛。其般泥洹者。乃从发意已来自到阿耨多罗三耶三菩。成至阿惟三佛者乃至无余泥洹界而般泥洹者。然后至于法尽。于是中所作功德。其功德度无有极。乃诸声闻作布施持戒自守为福于有余功德自致无余。诸有般泥洹佛。于其中所作功德。至有净戒身。三昧身。智慧身。以脱身。脱慧所见身。佛法极大哀不可计佛。天中天所说法。于其法中复学诸所有功德。乃于诸般泥洹佛法所作功德。都计之合之劝助为尊。种种德中为极。是上极劝助者是为劝助。劝助以持作阿耨多罗三耶三菩。以是为阿耨多罗三耶三菩。置是菩萨之人。持心能作是求阿耨多罗三耶三菩。乃生作是心欲有所得弥勒菩萨语须菩提。其不作是求乃能有所得。其作是思想者以为无黠。能生是意用思想悔还用信悔还。但用无黠故还堕四颠倒。无常谓有常苦谓有乐。空谓有实无身谓有身。以故思想悔还。心悔还信悔还。菩萨不当作是心。有所求于所求无处所。云何求阿耨多罗三耶三菩。弥勒菩萨谓须菩提。不当于新学菩萨摩诃萨前说是语。何以故。或亡所信亡所乐。亡所喜亡所行。便从是堕。当为是菩萨摩诃萨可说闻者。在善师边者当为是菩萨摩诃萨可说闻者。不恐不怖不畏。是菩萨摩诃萨能劝助为福。作萨芸若。持心作是劝助。心亦尽灭无所有无所见。何等心当作阿耨多罗三耶三菩者。当以何心作心无两对。心之自然乃能所作。释提桓因语须菩提。新学菩萨摩诃萨。闻是或恐或怖。若菩萨摩诃萨。欲作功德者。当云何劝助其福。得作阿耨多罗三耶三菩。须菩提语弥勒菩萨。当作护诸佛所破坏众恶而断爱欲。等行如一。降伏魔事。弃捐重担。即自从所有勤苦。悉为以尽其知以脱心即从计。从阿僧祇刹土诸般泥曰者。于其中所作功德福。于诸声闻中复作功德。都计之合之。劝助为尊种种德中无过劝助。其劝助者能为劝助。劝助以持作阿耨多罗三耶三菩。何所是菩萨摩诃萨想不还所信不悔还。正使菩萨摩诃萨持心。作阿耨多罗三耶三菩。其心无所想者。是菩萨摩诃萨心。得阿耨多罗三耶三菩。正使心念自了知。是为想悔还心悔还所信悔还。正使心念复知是心。则是作是为想悔还信悔还。正使菩萨摩诃萨持心了知。当作是觉知尽无所有知尽者。当知何心有所作。当了知心。何所心法。于法有所作。如法者。为随法已于作真。为是作即非邪作。是菩萨摩诃萨所作。若有菩萨摩诃萨。于过去当来今现在佛所作功德。若诸声闻下至凡人所作功德若畜生闻法。及诸天。诸阅叉。干多罗。阿须伦。迦留罗。真陀罗摩睺勒。诸人若非人。闻法者发心所作功德。及初学菩萨道者。都计之合之积累为上。其劝助者能为劝助是以极尊。种种德中无过劝助。是以劝助所当劝助能为劝助。福用作阿耨多罗三耶三菩正使复如是为尽法。于法无所生无所灭。无所处法无所生法。得作阿耨多罗三耶三菩。是法不了法。有反用作阿耨多罗三耶三菩故。是为无想不悔还心亦不悔还所信不悔还。作是无所求众所不逮。是为阿耨多罗三耶三菩所作。若有菩萨摩诃萨不谛晓了知作福德者。所以者何。于身恍忽于劝助福亦复恍忽。菩萨了知恍忽无所有。是故菩萨摩诃萨般若波罗蜜。若于诸般泥洹佛所而作功德。持是功德欲作所求。其知自然能为阿耨多罗三耶三菩。诸佛天中天。所著不着想。过去以灭亦无有想而不当学沤和拘舍罗。未得般若波罗蜜者不得入。已得般若波罗蜜乃得入。勿为身作识用之有灭。以是故无有身。身有德之人。有想便碍反欲苦。住怛萨阿竭阿罗诃三耶三菩。不学作是德持劝助。何以故。用不正故。视般泥曰佛而反有想以故为碍。所作功德。为不及逮。反欲苦住。其不作想者。是怛萨阿竭阿罗诃三耶三佛之德。其作想者譬若杂毒。何以故。设美饭以毒着中。色大甚好而香无不喜者。不知饭中有毒。愚闇之人食之欢喜饱满。食欲消时久久不便身不知德行者。甚之为难。不晓将护不晓中事不能解知。作是行德者。为如杂毒之食语。善男子。过去当来今现在佛。持戒身。三昧身。智慧身。以脱身。脱慧所见身及于声闻中。所作功德。佛天中天所说。若复辟支佛所而作功德。都劝助之。劝助以持是福德。作阿耨多罗三耶三菩。持所作为想。用是故譬若杂毒。菩萨摩诃萨当作是学。何所过去当来今现在佛功德。当云何劝助作福。成得阿耨多罗三耶三菩。是菩萨随怛萨阿竭教者。是即为作智。佛功德所生自然及其想法。所有持是福作劝助。因其劝助自致得阿耨多罗三耶三菩。菩萨摩诃萨作是施者无过。终不离怛萨阿竭阿罗诃三耶三佛。佛所语皆至诚。复次菩萨摩诃萨当作是施。如净戒。如三昧。如智慧。如以脱。如脱慧所见身。无欲界无色界无无色界。亦无过去当来今现在。亦无所有。无所有施亦复无所有。其作是施为以如法。法亦无所有。作施者为成所施无有毒。其作异施者为作反施。是菩萨摩诃萨。所施以如法者。佛天中天。所知是即为施得作阿耨多罗三耶三菩。佛言。善哉善哉。须菩提。所作为如佛。是即为菩萨摩诃萨所施。三千大千国土人。悉念慈哀等护心无过。菩萨摩诃萨上头所施。是即为极尊。复次须菩提。三千大千国土人。悉作阿耨多罗三耶三菩。使如恒边沙佛刹人。皆供养是菩萨。震越衣被饭食床卧具病瘦医药。如恒边沙劫供养。随所喜乐作是布施。云何须菩提。其福宁多不。须菩提言。甚多甚多。天中天。佛言。劝助功德福过其上不可计。须菩提白佛言。代劝功德福者。如恒边沙佛土不能悉受。佛言。善哉善哉。须菩提。若有菩萨持般若波罗蜜者。所作施为过其本所施上。以无能过劝助所施上。百倍千倍万倍亿倍巨亿倍。尔时四天王天上二万天人。悉以头面着佛足。皆白佛言。极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。其功德甚大尊。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。忉利天上诸天人。持天华名香捣香杂香泽香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已皆白佛言。极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。极大施之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。盐天上诸天人。持天华名香捣香杂香泽香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已皆白佛言极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。极大德之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。兜率天上诸天人。以天华名香捣香杂香泽香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已皆作是言。极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。极大德之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。尼摩罗提天上诸天人。持天华名香捣香杂香泽香烧香天缯华盖幢幡伎乐。持用供养娱乐佛。供养已皆白佛言。极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。极大尊之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。波罗尼蜜和耶拔致天上诸天人。持天华名香捣香杂香泽香烧香天缯彩华盖幢幡伎乐。持用供养娱乐佛。供养已皆白佛言。极大施天中天。菩萨摩诃萨。沤和拘舍罗乃作是施。极大尊之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。梵天。梵迦夷天。梵福楼天。梵波利产天。[病-丙+盍]天。波利陀天。[病-丙+盍]波摩那天。阿陂譮天。首诃天。波利首诃天。阿波摩首天。首诃迦天。比伊潘罗天。阿比耶天。须陀施天。尼天。乃至阿迦腻吒天等诸天人。悉以头面着佛足皆言。甚善天中天。菩萨摩诃萨。学般若波罗蜜。极为大施之功德。何以故。是菩萨摩诃萨。学般若波罗蜜。于中劝助故。佛语首陀卫诸天人。置三千大千国土中。菩萨摩诃萨。及恒边沙佛刹人。悉作阿耨多罗三耶三菩。复有恒边沙佛刹人。都共供养是辈菩萨摩诃萨。震越衣服饭食去来卧具病瘦医药供养。如恒边沙劫。随所乐喜作是施与。若复过是者。不及菩萨摩诃萨劝助之施。为过去当来今现在佛净戒身三昧身智慧身以脱身脱慧所见身及诸声闻身。其中者所作功德都共计之合之。不及劝助。若劝助者。以是极尊无能过者。作是劝助以持作阿耨多罗三耶三菩。须菩提白佛言。属天中天所说。都共计之合之。极尊无过劝助。悉代劝助劝助已菩萨摩诃萨。从是中得何等法。佛语须菩提。道德之人。当知过去当来今现在。法无所取亦无所舍。亦无所知亦无所得。其法者为无所生法亦无所灭。法者亦无从生法亦无所从灭。于法中了无有生者。法亦无所从有而灭。是者法之所法。我代劝助之。是为劝助。作是施者疾得作阿耨多罗三耶三菩。是故须菩提菩萨摩诃萨劝助为尊。复次须菩提。菩萨摩诃萨。于过去当来今现在佛所代作布施者。劝助代持戒忍辱精进一心智慧。而劝助之。代以脱者。劝助之。代脱慧所见身。劝助之。作是代劝助。其脱者是为布施。其脱者是为忍辱。其脱者是为精进。其脱者是为一心。其脱者是为智慧。其脱者是为脱慧。其脱者是为脱慧所见身。其脱者是为以脱。其脱者代其劝助。其脱者是为法。是故当来未有如其脱者。令阿僧祇刹土诸佛。天中天。现在者其脱者。是即诸佛弟子。其脱者以过去诸佛弟子。其脱者今现在诸佛弟子。于是法中无缚无著无脱。如是法者。持作阿耨多罗三耶三菩。所施为从中。无有能过者。无有能坏者。是者。须菩提。菩萨摩诃萨。劝助之为尊。如恒边沙佛刹中。菩萨悉寿。如恒边沙劫。恒边沙佛刹人。都悉供养诸菩萨摩诃萨。震越衣服饮食床卧具病瘦医药。乃至恒边沙劫须菩提。皆持戒忍辱于精进而不懈。于禅悉得三昧。百倍千倍万倍若干巨亿万倍。不如劝助功德福。最尊出其上

    摩诃般若波罗蜜地狱品第五

舍利弗白佛言般若波罗蜜者多所成。天中天。因般若波罗蜜。无不得字者。天中天。般若波罗蜜为极照明。天中天。般若波罗蜜为去冥。天中天。般若波罗蜜者无所著。天中天。般若波罗蜜为极尊。天中天。无目者般若波罗蜜为作眼。天中天。其迷惑者。般若波罗蜜悉授道路。天中天。萨芸若者即般若波罗蜜是。天中天。般若波罗蜜者是菩萨摩诃萨母。天中天。无所生无所灭即般若波罗蜜是。天中天。具足三合十二法轮为转是般若波罗蜜。天中天。般若波罗蜜其困苦者悉安隐之。天中天。般若波罗蜜于生死作护。天中天。般若波罗蜜于一切法悉皆自然。菩萨摩诃萨当云何于般若波罗蜜中住。天中天。佛语舍利弗。世多罗者因般若波罗蜜住。其敬佛者当自归般若波罗蜜。释提桓因心念。尊者舍利弗。何因发是问。即时释提桓因。谓舍利弗。何因尊者乃作是问。舍利弗谓释提桓因。拘翼。般若波罗蜜者是菩萨护。因其劝助功德福持作萨芸若。过菩萨之所作。为若布施持戒忍辱精进禅定。譬若如人从生而盲。若百人若千人。若万人若千万人。无有前导欲有所至。若欲入城者不知当如行。如是。拘翼五波罗蜜者。亦如盲无所见。离般若波罗蜜者如是。欲入萨芸若中。不知当如行。般若波罗蜜即五波罗蜜之护。悉与眼目。般若波罗蜜者是护。令五波罗蜜各得名字。舍利弗白佛。当云何守入般若波罗蜜中。佛语舍利弗。色者不见所入。痛痒思想生死识亦不见所入。视五阴亦不见所入。是为守般若波罗蜜。如是者。天中天。以为守般若波罗蜜。作是守者为逮何法。佛语舍利弗。无所守是为逮法守。为般若波罗蜜。释提桓因白佛言。般若波罗蜜不逮萨芸若者。亦不能得逮亦不逮守。于生死亦无所逮。当云何逮。天中天。佛言。无所逮故能为逮。释提桓因言。少有及者。天中天。如般若波罗蜜。于诸法诸法无生无所灭。当何所住无有住须菩提白佛言。菩萨或时作是念便离般若波罗蜜。佛语须菩提。傥有所因。便念般若波罗蜜。知般若波罗蜜。空无所有无近无远。是故为菩萨摩诃萨般若波罗蜜。须菩提白佛言。般若波罗蜜者为信何法。佛语须菩提。信般若波罗蜜者为不信色。亦不信痛痒思想生死识。有不信须陀洹道。不信斯陀含阿那含阿罗汉辟支佛道。须菩提白佛言。摩诃萨波罗蜜者。天中天。即般若波罗蜜是。佛谓须菩提。云何知摩诃萨波罗蜜。因般若波罗蜜是。须菩提。于色无大无小。不以色为证。亦不为色作证。痛痒思想生死识。亦无大无小。于识不以为证。亦不为识作证。便于怛萨阿竭阿罗诃三耶三佛。致十种力即不复为弱。萨芸若无广无狭。何以故。无广无狭萨芸若知。于般若波罗蜜无所行。所以者何。般若波罗蜜。无所有。若人若于中有所求。谓有所有是则为大非。何以故。人无所生。般若波罗蜜与人俱皆自然。人恍忽故般若波罗蜜俱不可计。人亦不坏般若波罗蜜亦如是。人如般若波罗蜜者。便得成至阿惟三佛。人亦有力故。恒萨阿竭现而有力。舍利弗白佛言。般若波罗蜜甚深甚深天中天。若有菩萨摩诃萨。信般若波罗蜜者。不说其中短亦不狐疑。其人从何所来生是间。为行菩萨道。已来几闻解般若波罗蜜事随教入中者。佛语舍利弗。从他方佛刹来生是间。是菩萨摩诃萨。于他方供养佛已。从受决闻般若波罗蜜故。以是复闻般若波罗蜜自念言。我如见佛无异。须菩提白佛言。般若波罗蜜。可得见闻不。佛言。不可得见。须菩提白佛言。是菩萨随深般若波罗蜜者。行已来为几闻。佛语须菩提。是非一辈学。各各有以供养。若干百佛若干千佛。悉见已于其所。皆行清净戒已。若有于众中闻般若波罗蜜。弃舍去为不敬菩萨摩诃萨法。佛说深般若波罗蜜。其人弃舍去不欲闻之。何以故。是人前世时闻般若波罗蜜。用弃舍去故。亦不以身心。是皆无知之人所致。用是罪故。若闻深般若波罗蜜。复止人不令说之。止般若波罗蜜者。为止萨芸若。其止萨芸若者。为止过去当来今现在佛。用是断法罪故。死入大泥犁中。若干百千岁。若干亿万岁。当受若干泥犁毒痛甚不可言。其中寿尽转生他方摩诃泥犁中。其寿复尽展转到他方摩诃泥犁中生。舍利弗白佛言。其罪为堕五逆恶。佛谓舍利弗。其罪虽喻不可引譬。若讽诵读深般若波罗蜜时。其心疑于法者亦不肯学念是言。非恒萨阿竭所说。止他人言。莫得学。是为以自坏复坏他人。自饮毒已复饮他人毒。是辈人为以自亡失复失亡他人自不晓知深般若波罗蜜转复坏他人。是曹人者不当见之。舍利弗。不当与共坐起言语饮食。何以故。是曹之人诽谤法者。自在冥中复持他人着冥中。其人自毒杀身无异断法之人。所语有信者用其言者。其人所受罪俱等无有异。所以者何。用诽谤佛语故。诽谤般若波罗蜜者。为悉诽谤诸法已。舍利弗白佛言。愿闻诽谤法者。受形何等像类。许不知其身大如。佛谓舍利弗。是诽谤法人傥闻是事。其人沸血便从面孔出。或恐便死因是被大痛。其人闻之心便愁毒而消尽。譬若断华着日中即为萎枯。舍利弗言。愿为人故当说之。令知其身受形云何。当为后世人作大明。其有闻者畏惧。当自念我不可诽谤断法如彼人。佛语舍利弗。是为示人之大明。以所因罪。受其身甚大丑恶。极勤苦臭处诚不可说。其苦痛甚大而久剧。是善男子善女人。闻是语自足以不敢复诽谤。须菩提白佛言。善男子善女人。闻是人但坐口所言乃致是罪。佛语须菩提。是愚痴之人于我法中作沙门。反诽谤般若波罗蜜言非道。止般若波罗蜜为者。止佛菩萨。以止佛菩萨者。为断过去当来现在佛萨芸若。已断萨芸若者为断法。以断法者为断比丘僧。以断比丘僧者为受不可计阿僧祇之罪。须菩提白佛言。若有断般若波罗蜜者。天中天。为几事。佛语须菩提。以为魔所中。是善男子是善女人不信不乐。用是二事故。能断深般若波罗蜜。复次须菩提。断般若波罗蜜者复有四事。何谓四事。随恶师所言。不随顺学。不承至法。主行诽谤索人短自贡高。是为四事。须菩提白佛言。少有信般若波罗蜜者。天中天。不晓了是法故。佛语须菩提。如是如是。少有信般若波罗蜜者不晓法故。须菩提言。云何深般若波罗蜜少有信者。佛语须菩提。色无著无缚无解。何以故。色之自然为色。痛痒思想生死识无著无缚无脱。何以故。识之自然为识。过去色无著无缚无脱。何以故。过去色之自然故。当来色无著无缚无脱。何以故。当来色之自然色故。今现在色无著无缚无脱。何以故。色之自然色故。过去痛痒思想生死识无著无缚无脱。何以故。过去色之自然故。当来识无著无缚无脱。何以故。当来识之自然故。今现在识无著无缚无脱。何以故。识之自然故。用是故须菩提。般若波罗蜜甚深少有信者

    摩诃般若波罗蜜清净品第六

须菩提白佛言。般若波罗蜜少有晓者。将不狎习故。佛语须菩提。如是如是。般若波罗蜜少有晓者。用是不狎习之所致。何以故。须菩提。色清净道亦清净故。言色清净道亦清净。痛痒思想生死识亦清净故。言道亦清净。是故识亦清净。复次须菩提。色清净萨芸若亦清净。色亦清净。是故色清净萨芸若亦清净等无异。今不断前前不断后故无坏。以是故前为不断。舍利弗白佛言。清净者。天中天。为甚深。佛言。甚清净。舍利弗言。清净为极明。天中天。佛言。甚清净。舍利弗言。清净无有垢。天中天。佛言。甚清净。舍利弗言。清净无瑕秽。天中天。佛言。甚清净。舍利弗言。清净无所有。天中天。佛言甚清净。舍利弗言。于欲无所欲清净。天中天佛言。甚清净。舍利弗言。于色而无色清净。天中天佛言甚清净。舍利弗言。无所生为色甚清净。天中天。佛言。甚清净。舍利弗言。于有智而无智甚清净。天中天。佛言。甚清净。舍利弗言。于智者而无智者甚清净。天中天。佛言。甚清净。舍利弗言。于色而有智无有者甚清净。天中天。佛言。甚清净。舍利弗言。于痛痒思想生死识。而无有智无有智者甚清净。天中天。佛言。甚清净。舍利弗言。般若波罗蜜甚亦清净。天中天。萨芸若者不增不减。天中天。佛言。甚清净。舍利弗言。般若波罗蜜甚清净。于诸法无所取。天中天。佛言。甚清净须菩提白佛言。我者清净色亦清净。天中天。佛言。本清净。须菩提言。故曰我清净。痛痒思想生死识亦清净。天中天。佛言。本清净。须菩提言。我清净道亦清净。天中天。佛言。本清净。须菩提言。我者清净萨芸若亦清净。天中天。佛言。本清净。须菩提言。我者清净无端绪。天中天。佛言。本清净。须菩提言。我者清净无有边。色亦清净无边。天中天。佛言本清净。须菩提言。我者无有边痛痒思想生死识亦无有边。天中天。佛言。本清净。须菩提言。晓知清净者。即菩萨摩诃萨般若波罗蜜是。佛言。本清净。须菩提言。般若波罗蜜者。亦不在彼。亦不在是。亦不离是。亦不在中间。天中天。佛言。本清净。须菩提白佛言。菩萨摩诃萨。知是者为行般若波罗蜜。有想者便离般若波罗蜜远已。佛言。善哉善哉。须菩提。有字者便有想以想故着。须菩提白佛言。难及波罗蜜天中天。安隐决于着。舍利弗言。问须菩提。何所为着须菩提言。知色空者是曰为着。知痛痒思想生死识空是曰为着。于过去法知过去法是曰为着。于当来法知当来法是曰为着。于现在法知现在法是曰为着。知法者为得大功德。发意菩萨是即为着。释提桓因问须菩提。何谓为着。须菩提。心知。拘翼持是知心。施与作阿耨多罗三耶三菩心者本清净。能可有所作。善男子善女人其菩萨者。劝人教人为阿耨多罗三藐三菩为说正法。自于身无所失。于佛种有所造。是善男子善女人。以离诸着。为弃本际。佛言。善哉善哉。须菩提。令菩萨摩诃萨知本际为觉着事。复次须菩提。有着甚深微妙。我今说之。谛听谛听。上中下言悉善。须菩提白佛言。愿乐欲闻。佛言。若善男子善女人。于怛萨阿竭阿罗诃三耶三佛。念欲作想随所想。是故为着过去当来今现在佛。天中天。于无余法代劝助之。是为劝助阿耨多罗三耶三菩。于法者而无法故。曰无过去当来今现在。以是不可有所作。亦不可有想。亦不可作因缘。有不可见闻不可知。须菩提白佛言。其本甚深清净。天中天。佛言。本清净。须菩提言。今自归般若波罗蜜。佛言。法无作者故。得成阿惟三佛。须菩提言。诸法实无作阿惟三佛者。佛语须菩提。无有两法用之本净故。曰为一其净者。于一切亦无作者。佛语须菩提。是以离诸着为弃本际。须菩提白佛言。般若波罗蜜者难了。天中天。佛言。如是无有得阿惟三佛者。须菩提言。般若波罗蜜不可计。天中天。佛言。如是须菩提。非心之所知。须菩提言。为无有作者。天中天。佛言。无有作者故无所著。须菩提白佛言。菩萨当云何行般若波罗蜜。佛言。不想痛痒思想生死识行。为行般若波罗蜜。色不满色。为行般若波罗蜜。色不满为非色行。为行般若波罗蜜。痛痒思想生死识不满。为行般若波罗蜜。须菩提白佛言。难及天中天。于着无所著。是实为不着。佛言。不着色者为行般若波罗蜜。不着痛痒思想生死识行。为行般若波罗蜜。是为菩萨摩诃萨行般若波罗蜜。于色为不着。于痛痒思想生死识为不着。于须陀洹斯陀含阿那含阿罗汉辟支佛道亦不着。所以者何。以过诸着故。复出萨芸若中。是为般若波罗蜜。须菩提白佛言。所说法甚深难逮。天中天。若所说不增不说者亦不减。佛言。如是如是。须菩提。譬若恒萨阿竭。尽寿称誉空。空亦不增。若不称誉空亦不减。譬如称誉幻人者亦不增不称誉者亦不减。闻善亦不喜。闻恶不忧。如是须菩提。于法各各讽诵学之。法亦不增不减。须菩提白佛。菩萨摩诃萨。甚慊苦行般若波罗蜜。若有守般若波罗蜜者。不懈不恐。不怖不动不还。以何故。守般若波罗蜜者为守空故。一切皆当为菩萨摩诃萨作礼。用被僧那大铠故与空共战。为一切人故着僧那。为一切人故而举空。是菩萨摩诃萨为极大勇猛。天中天。用空法故。自致阿耨多罗三耶三菩。得成阿惟三佛。有异比丘心念之。当自归般若波罗蜜。为无所生法亦为无所灭法。释提桓因语须菩提。菩萨随般若波罗蜜教者为随何教。须菩提言。为随空教。释提桓因言。何所随空教者。须菩提言。其欲寂静者。是菩萨摩诃萨。为知般若波罗蜜。释提桓因白佛言。其受般若波罗蜜者。天中天。当护几何间。须菩提谓释提桓因。云何拘翼。能见法当所护者不。而言欲护之。释提桓因言不。须菩提言。随般若波罗蜜教作者是为以得护。若人若非人。终不得其便。须菩提言。若菩萨摩诃萨。护空者为随般若波罗蜜行已。云何拘翼。能可护响不。释提桓因言。不能。须菩提言。如是拘翼。菩萨摩诃萨行般若波罗蜜者。其法亦如响。以知是者亦复无想。以无想念为行般若波罗蜜。用佛威神。三千大千国土诸四天王诸释梵。及诸尊天。一切皆来到佛所前为佛作礼。绕竟三匝各住一面。诸天天王释梵悉承佛威神。念诸千佛皆字释迦文。其比丘者皆字须菩提。问般若波罗蜜者皆如释提桓因

摩诃般若钞经卷第三摩诃般若钞经卷第四

        秦天竺沙门昙摩蜱共竺佛念译

    本无品第七

须菩提白佛言。诸法随次者。天中天。是为法语故。曰无所损。诸法者为无有端。其法相者为无所碍。如空法者为无所生。诸所生不可得。是为法生故无所得。诸欲诸梵天子俱白佛言。其寂者。即佛弟子今尊者须菩提所说者悉空。须菩提语诸天子言。为随怛萨阿竭教。佛言。云何须菩提。知随怛萨阿竭教。须菩提复言。如怛萨阿竭本无。是为怛萨阿竭教。诸过去当来现在悉为本无。佛言随本无者为随怛萨阿竭教。诸法亦本无。如诸法本无。怛萨阿竭亦本无。一切本无悉为本无。是为须菩提以随怛萨阿竭教无有异随本无者。是为怛萨阿竭教不异无有异随怛萨阿竭者为随本无。本无者是为怛萨阿竭。立须菩提之所立。为随怛萨阿竭教。如怛萨阿竭本无无所碍。诸法亦本无无所碍。是者须菩提。为随怛萨阿竭教。以如怛萨阿竭本无者。于法亦本无。一本无等无异。我者亦无作者本无。亦无作者一切皆本无。亦复无本无。如本无本无我者。亦尔故。须菩提为随怛萨阿竭教。如怛萨阿竭本无不异无有异。是故诸法亦本无不异无有异。是为怛萨阿竭本无。亦不坏亦不腐不可得。是者。须菩提为随怛萨阿竭教。怛萨阿竭与诸法俱本无。无异亦无异。本无亦不有异。本无悉皆是本无。如须菩提所随者。以入不可计。人亦复无所入。是为随怛萨阿竭教。怛萨阿竭者是为本无。亦不过去当来今现在。及诸法悉皆本无故。亦无过去当来今现在。如是者。须菩提。为随怛萨阿竭教。以如来本无者。即曰怛萨阿竭教。怛萨阿竭者即是本无。当来亦本无。过去亦本无。现在亦本无。以随过去本无。怛萨阿竭教是为本无。以随当来本无。怛萨阿竭教是为本无。以随现在本无。怛萨阿竭教是为本无。以如过去当来今现在本无。怛萨阿竭教是为本无。以如过去当来今现在本无。怛萨阿竭教是为本无等无异。如诸法本无。是者须菩提。等无异。为随怛萨阿竭教等无异。是为真菩萨之本无。自致阿惟三佛。亦俱等本无。以如本无者。便得本无如来名。地即为六反震动。怛萨阿竭因是本无而得成。是故须菩提。为随怛萨阿竭教。复次须菩提。为不随色。为不随痛痒思想生死识。亦不随须陀洹道。亦不随斯陀含阿那含阿罗汉辟支佛。是者须菩提。为随怛萨阿竭教。舍利弗白佛言。本无者甚深。天中天。佛言。如是本无实甚深。说本无时三百比丘皆得阿罗汉。五百比丘尼皆得须陀洹道。五百诸天及人悉逮得无所从生法乐忍。六十菩萨皆得阿罗汉道。佛语舍利弗是辈菩萨。供养过去五百佛已。皆作施与。护于净戒。成于忍辱。所作精进。定足于禅。以不得般若波罗蜜沤和拘舍罗。虽是菩萨摩诃萨。有道意入空无相无愿。离于沤和拘舍罗者。便中道为本际作证得声闻。譬如有大鸟。舍利弗。其身若四千里若八千里。若万二千里若万六千里若三万里。从忉利天上。欲来下至阎浮利地。是鸟而无翅。反从忉利天上自投来下。云何舍利弗。是鸟欲中道还上忉利天上。宁能还不。舍利弗言。不能天中天。佛言。是鸟来下至阎浮利地。欲令其身不痛。宁能使不痛。舍利弗言。不能天中天。其鸟来下身不得不痛。若死若当闷极何故其身甚大而反无翅。佛言。如是舍利弗。正使菩萨摩诃萨。如恒边沙劫。作布施。护于净戒。成于忍辱。所作精进。定足于禅。发心甚大。欲总揽一切成阿惟三佛。不得般若波罗蜜沤和拘舍罗者。便中道堕落在声闻辟支佛道地。如是舍利弗。菩萨摩诃萨。于过去当来今现在佛所。为不持戒三昧。若智慧。若脱慧。若见慧。而反作想。是为不持怛萨阿竭戒三昧。智慧若脱慧。若见慧。为不知怛萨阿竭故而晓知。但闻空声想之。如所闻持欲作阿耨多罗三耶三菩会不能得。便中道在声闻辟支佛道地。何以故。如是为不得般若波罗蜜沤和拘舍罗故。舍利弗白佛言。我念佛之所说。其离般若波罗蜜沤和拘舍罗者。便不能自致阿耨多罗三耶三菩。若有菩萨摩诃萨。欲得阿耨多罗三耶三菩阿惟三佛者。当黠学般若波罗蜜沤和拘舍罗。诸欲天诸色天子俱白佛言。般若波罗蜜者甚深难晓难了。泊然者不得阿耨多罗三耶三菩。佛语诸天子言。如是般若波罗蜜者甚深难晓了。泊然不得阿耨多罗三耶三菩。须菩提白佛言。般若波罗蜜者难晓了。天中天。如我念是慧。其为泊然者。乃能得阿耨多罗三耶三菩。何以故。亦不于是有得阿惟三佛者故。曰法空。无作阿惟三佛。用法空故于法亦不能得。当作阿惟三佛者故。诸法悉空于法无所有是为法语。无作阿惟三佛故曰法空。无作阿惟三佛者。亦无得阿惟三佛者。其念一切诸法悉空。随是者。天中天。而泊然得阿耨多罗三耶三菩成阿惟三佛。舍利弗谓须菩提。如所说者。泊然得阿耨多罗三耶三菩是为甚难。何以故。空不念我当作阿耨多罗三耶三菩。成阿惟三佛。如是法者。易得阿惟三佛。何以故。如恒边沙等菩萨云何转还。须菩提言。当作是知。不为泊然者难得阿耨多罗三耶三菩。须菩提谓舍利弗。用色还不作阿耨多罗三耶三菩。答言不。用痛痒思想生死识还不作阿耨多罗三耶三菩。答言不。能有异色得法还不作阿耨多罗三耶三菩。答言不。能有异。痛痒思想生死识得法还不作阿耨多罗三耶三菩。答言不。色本无宁还不作阿耨多罗三耶三菩。答言不。痛痒思想生死识本无宁还不作阿耨多罗三耶三菩。答言不。云何舍利弗。能有异色本无。于法得还不作阿耨多罗三耶三菩。答言不。能有异痛痒思想生死识本无。于法得还不作阿耨多罗三耶三菩。答言不。云何舍利弗。本无为还不作阿耨多罗三耶三菩。答言不。能有异本无于法得还不作阿耨多罗三耶三菩。答言不。设于是法不得。何所法还者作阿耨多罗三耶三菩。舍利弗谓须菩提。如所说法无有菩萨还者。须菩提言。菩萨之人而有三德。是怛萨阿竭所说。一者佛衍菩萨而不计三。如须菩提所言。分耨文陀尼弗语舍利弗。须菩提所说一道者而当问之。舍利弗谓须菩提。欲问所说一道佛衍菩萨事。须菩提。欲问所说一道佛衍菩萨事。须菩提言。云何舍利弗。于本无中能见三道。是为声闻辟支佛。佛语舍利弗言。不见本无中得二事者。须菩提言。云何舍利弗。本无者为一不。是故曰得。若菩萨摩诃萨闻本无心不懈怠。是菩萨摩诃萨。会致至菩萨。佛言。善哉善哉。须菩提。如所说无异悉佛威神之所致。是为菩萨摩诃萨本无无有异若菩萨心不懈怠会至菩萨。舍利弗白佛言。何谓为菩萨。佛语舍利弗。成阿耨多罗三耶三菩则是。须菩提白佛。何谓菩萨摩诃萨欲成者云何住。佛言。视一切人。皆等其心不异。无有害意以慈心向人。若身无异。其心柔软其心加哀其心无嗔恚。无所碍心无所娆心。视之若父母无异。是心菩萨摩诃萨所住。当作是学

    摩诃般若波罗蜜阿惟越致品第八

须菩提白佛言。阿惟越致菩萨摩诃萨。当何以比观其相行。知是为阿惟越致菩萨摩诃萨。佛语须菩提。于凡人及声闻辟支佛。乃至怛萨阿竭道地。闻悉本无而不动摇亦无有异。于其法亦本无是为本无于不动摇。是即为度。如所闻不转亦不有疑。亦不言是亦不言非。如本无者为无所失。其所语不轻。不说他事但说中正。他人有所作亦不观视。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨者。不形沙门婆罗门面类。是为沙门是为婆罗门。所见知悉谛了终不祠祀跪拜余天。不持华香而奉上之。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨终不生恶处不作妇人。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨终不离十善。身自不杀教人不杀身自不盗。不淫泆。不两舌。不恶口。不妄言。不绮语。不妒嫉。不贪余。不疑乱。身自作正。教人守正。是为十善。又于梦中自护不失十善。是为阿惟越致菩萨摩诃萨。于梦中面自见十善。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨心所学法持欲安隐一切人。悉为说法是为法施。令一切皆得法所。是即为法施。于一切如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨若王者为人中之雄。持所知名慧。闻说深法终不有疑。不有疑不言不信。所言柔软所语如蜜复少睡卧。出入行步其心不乱徐行安步。举足蹈地择地而行。及所被服衣中无蚤。常而净洁无有尘垢亦无有忧。身中都无八十种虫。所以者何。是菩萨摩诃萨所有功德。过出世间功德上。稍稍欲成满其功德转倍故。其身清净心亦清净。须菩提白佛。云何天中天。菩萨摩诃萨心清净。当何以知。佛语须菩提。菩萨摩诃萨所作功德转倍益多稍稍极上。其心自在而无所碍。其功德悉逮心故清净。过声闻辟支佛道地。是为菩萨摩诃萨心清净。如是比观其相行具足。知是即阿惟越致菩萨。复次须菩提。阿惟越致菩萨摩诃萨不求财物。若供养者无有悭贪。说深法时无有厌极正作在知。其欲闻深法者。持般若波罗蜜为说之。其有作余道若世事者。持般若波罗蜜主为正之。其不解者。以般若波罗蜜便为解之。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。至者弊魔便来致所化作八大泥犁。一泥犁化有若干百千菩萨。便指示言。是辈人者皆从佛受决已。皆是阿惟越致。今悉堕泥犁中。皆佛之所授决。设若作阿惟越致受决已者。当疾悔之。我非阿惟越致。设若言尔者。便不入泥犁当生天上。佛语须菩提。设心不动者是阿惟越致菩萨摩诃萨。佛言。我所语者无有异。设当生恶处者佛语为有异。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。弊魔化作沙门若用被服。到菩萨摩诃萨所言。若前从我所闻从我所受。今悉弃舍皆不可用。若今当自悔其过。若疾悔之随我言者。我日日自来问讯。若设不用我言者。我终不复来相视。若莫复说是语非佛所说。是皆他余外道之造作。今我所语是佛所说。佛言。闻是说而动转者。当知其人不从过去佛受决。来在菩萨摩诃萨举中。多有菩萨摩诃萨。未在阿惟越致其界。设不动转者。念法无有生死。念无有生死信他人言。譬若比丘得罗汉者。不随他人所言。眼悉见法以为作证。是为无所有终不可动。是菩萨摩诃萨亦不可动。如声闻辟支佛道地所念法众不复还。是菩萨摩诃萨正向萨芸若不可复还。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。弊魔到菩萨摩诃萨所化作异人。若所求者甚为勤苦。非萨芸若行。若致负是勤苦为。若用是勤苦为作。不当自还厌耶。当复于何所更索是躯。汝何不早取罗汉用佛为求耶。佛言。设不动转者。弊魔复弃舍去。更为方略。化作若干菩萨。在其边立复生指语之。若见是菩萨不。皆供养如恒边沙佛已。皆与衣服饭食床卧医药悉具足。皆于恒边沙佛所悉行清净戒皆从受事闻其中慧当所施行。其所求者为悉学已所住如法。今皆不能得阿耨多罗三耶三菩。作是学已作是受已作是行已。不能得萨芸若。何况若欲得阿耨多罗三耶三菩。佛言。设是不动者弊魔便去。更化作比丘作是言语。是悉罗汉。过去世时皆行菩萨道。今悉取罗汉。今是尚如是比丘。若当从何所得阿耨多罗三耶三菩。佛言。是菩萨摩诃萨虽从异处闻是言续作其行心不动转。亦无有异心觉知魔为。佛言。若有学波罗蜜随其行者。不得萨芸若当从何所得。佛所语者为无有异。其作是学其作是行。如般若波罗蜜者心不动摇。设是不得萨芸若佛语为有异。佛所语者终不有欺。是菩萨摩诃萨当作是学。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。弊魔往到阿惟越致菩萨所作是晓言。萨芸若者如空。是法不可得边幅。是法不可得穷极有所可得。何以故。无阿惟越致。亦无得阿惟三佛者。今得观视其法都卢皆空。若之所作是为勤苦。不当觉知是魔所为。云何欲得阿耨多罗三耶三菩。是非佛所说。佛言。是善男子善女人。当如是知。当作是念为魔事。其心正直而不动摇。用比观其相行具足知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨欲作第一禅第二禅。第三至于第四禅。三摩越。随是四禅而不录禅目。是为三摩越为人欲故。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨。不求称誉其名字者。若称说者。不念所欲其心广大。但念一切悉令得安。行步坐起其心不乱。出入用意当而至诚。不求有力不他淫欲。若欲往来自患其欲。于欲常有恐怖。譬若男子过大空泽之中。若欲饮食畏于贼盗疾欲发去。自念何时当到聚落安隐之处疾得脱去。阿惟越致菩萨摩诃萨亦复如是。于爱欲有往来时。自念所作是为不可。是即为非皆悉不正。非我法之所作。亦不念余恶。何以故。欲使一切皆得安隐。佛言。其作是念皆是般若波罗蜜威神之力。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。和夷罗洹阅叉。常随从阿惟越致菩萨摩诃萨。其余鬼神不敢附之。终不失志其心不乱。其身亦不妄起。身体完具无所缺减。为人雄不诱他人妇女。若为作符若咒若药都不为是。亦不自为亦不教人为。是为菩萨之净。不说男子事。亦不说妇人事都无是[億-音+(夫*夫)]。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨不与聚会人从事。亦不与王者。亦不与贼亦不与兵。亦不与军亦不与聚邑。亦不与城郭亦不与世俗。亦不与女人亦不与男子亦不与余道。亦不与谷亦不与须亦不与祠。亦不与杂色。亦不与华亦不与香。亦不与调戏亦不从海亦不从利。亦不作若干种。亦不与所有从事。但与般若波罗蜜从事。不离萨芸若常念不忘。亦不与斗从事。自守如法常行中正不从非法。常称誉贤者以为上头。常于人欲作亲厚。不作怨恶但求怛萨阿竭法。则欲求生异方佛刹。作是求将不生彼间。用是故常得见佛。复得供养阿惟越致菩萨摩诃萨。或从欲从色从无色。去其彼间来生中国。若在善人家。若黠慧中生。若在生谈语之中。若在晓经书之家。不喜豫少事。有生于边地。悉生大国中终不犯法。用是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨亦不言我是阿惟越致。亦不念我是阿惟越致。亦不自疑我不在阿惟越致地。譬若男子得须陀洹道。于其道地终不有疑。魔事虽起即悉觉知。既起者不随其计。阿惟越致菩萨摩诃萨亦如是。自于道地终不有疑亦不懈怠。魔事虽起即悉觉知。既起者不随其计。譬若男子作恶逆者。其心终不有忘。至于命尽其心终不可转。阿惟越致菩萨摩诃萨者。终不可移其心忠正立。于阿惟越致菩萨心终不可动。天上天下终不可转。魔事虽起即悉觉知。既起者不随其计。自于道地终不有疑。亦无声闻辟支佛心。终不念言佛之难得。其地安隐端自坚住无有胜者。何以故。如是住者无有能过。弊魔大愁便化作佛。往到其所言。若当聚罗汉证。证如来受决。得阿耨多罗三耶三菩。何以故。若不得比亦不得相。其如心比者用是相行具足。能为菩萨摩诃萨。或尚不得阿耨多罗三耶三菩。若当何当因得。佛言。设是菩萨摩诃萨心不动转。知是菩萨摩诃萨。从过去怛萨阿竭阿罗诃三耶三佛所受决已。设复作是念者。知魔作佛像来。是男子即非佛是魔所为。其作是作以应阿惟越致地。如佛所说魔事无有异。其作是视其作是念。知魔所为欲使我转。佛言。设不动者。是菩萨摩诃萨从过去怛萨阿竭阿罗诃三耶三佛所以受决。住阿惟越致地已。何以故。用是比观其相具足。知是审阿惟越致。如是比观其相行具足。知是即阿惟越致菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨用法故不贪所有。亦不惜身寿命。是菩萨摩诃萨欲悉受法。为护过去当来今现在佛所有法。其欲护过去当来今现在佛法。以为人数。是即为决是为护法。用是故。无所惜亦不惜命身。未曾懈时无有厌极。如是比观其相行具足。知是阿惟越菩萨摩诃萨。复次须菩提。阿惟越致菩萨摩诃萨怛萨阿竭阿罗诃三耶三佛之所说法。未曾有疑亦不言非。须菩提白佛。怛萨阿竭之所说法。亦不疑不言非。为于声闻说法。亦不有疑。亦不言非。诸声闻之所说法。于其中亦不疑亦不言非。何以故。须菩提。是菩萨摩诃萨为逮无所从生法乐忍。用是比观其相行具足。知是阿惟越致菩萨摩诃萨

    摩诃般若波罗蜜恒架调优婆夷品第九

须菩提白佛言。大哉阿惟越致菩萨摩诃萨。从大功德自致阿惟越致。乃从恒边沙等为以应相。今天中天。说深法。是菩萨摩诃萨之所施行。佛言。善哉善哉。须菩提。汝之所内是为甚深。是即为空无相无愿无生死无所生无所有无所欲。是为灭。泥洹者是为限。须菩提白佛。泥洹者是限非是诸法。佛语须菩提。诸法甚深。何以故。色者甚深。须菩提痛痒思想生死识亦甚深。阴亦甚深如色甚深者。何谓须菩提痛痒思想生死识之甚深。有甚深者非色之甚深。是为色之甚深。痛痒思想生死识亦尔。是识为甚深。须菩提白佛言。大哉微妙色之稍从泥洹。佛语须菩提。痛痒思想生死识。为稍从泥洹甚深。甚深者。般若波罗蜜。菩萨摩诃萨思惟念是为住。如般若波罗蜜教。为学般若波罗蜜。是菩萨摩诃萨随是思想惟念如空教。应行一日甚深不可言。须菩提白佛言。是菩萨摩诃萨应行一日者。为却几劫之生死。佛语须菩提。譬若淫泆有所重爱端正女人与共期会。女人不得自在。云何须菩提。其男子宁念不。须菩提言。用女人故思念甚多无有忘时佛言。如是男子。所念一日其心不转。是菩萨摩诃萨念般若波罗蜜。应行一日却生死若干劫已。其如般若波罗蜜教。如中所说学。思念随行一日者。是菩萨为却恶除罪已。若菩萨摩诃萨离般若波罗蜜者。正使布施如恒边沙劫。不如菩萨摩诃萨随般若波罗蜜教应行一日者。其功德出彼上。复次须菩提。若菩萨摩诃萨寿如恒边沙等劫持所布施。与须陀洹斯陀含阿那含阿罗汉辟支佛。而离般若波罗蜜。若有菩萨摩诃萨。随般若波罗蜜教。其功德出彼菩萨寿如恒边沙劫布施持戒者上。若有菩萨摩诃萨。念般若波罗蜜起便说法。其功德复出彼菩萨上。复次须菩提。是菩萨摩诃萨为以法施其功德复转倍若菩萨摩诃萨作法施者。是为阿耨多罗三耶三菩。若有菩萨摩诃萨法施者而不守中。其功德不如菩萨摩诃萨作法施而复守中。若有持般若波罗蜜者不离守中。是菩萨摩诃萨其功德甚多。须菩提白佛。一切无生死。若有不动。天中天。此二事何功德为甚多。佛语须菩提。菩萨摩诃萨于福生死。于功德生死。所行般若波罗蜜。乐于空。乐于无所有。乐于尽。乐于无所得。念是时。为不离般若波罗蜜。若不离般若波罗蜜者。是菩萨摩诃萨得不可计阿僧祇功德。须菩提白佛。天中天之所说。何谓不可计阿僧祇功德。有何差特。佛语须菩提。阿僧祇者。其数不可尽极。不可计者。不可量计之了不可得边幅。尔故为不可计阿僧祇。须菩提言。佛说不可计者色亦不可计。痛痒思想生死识亦不可计。佛语须菩提。如所言色亦不可计。痛痒思想生死识亦不可计。须菩提白佛。何谓为不可计。佛语须菩提。如空故不可计。无相无愿故言不可计。如是者不可计即为是空。亦无异法。佛言。云何须菩提。我言诸法悉空不。须菩提言。如是天中天。所说法悉空不可尽。佛言。如是须菩提。诸法悉空不可计。无有法各各异者有所差特分别可得不可得者。即怛萨阿竭得不可尽不可计。如空无相无愿。无生死。无所生。无所有。无所起。无所灭。如泥洹随所喜在所说。是为怛萨阿竭教。须菩提白佛。大哉天中天之所说法。是法实不可逮。如我念佛之所语。诸法亦不可逮。佛语须菩提。如是诸法不可逮悉。法如空故不可逮。须菩提言。如佛说本不可逮。愿解不可逮。佛言。不须菩提言六波罗蜜为不可逮是为布施无增无减。尸波罗蜜。羼波罗蜜。惟逮波罗蜜禅波罗蜜。般若波罗蜜。为不增不减。是即为六波罗蜜不增不减。何谓于六波罗蜜不增不减。是为菩萨摩诃萨自致阿耨多罗三耶三菩。何缘近佛坐。是菩萨摩诃萨而不离般若波罗蜜。自致阿耨多罗三耶三菩。佛语须菩提。如本不可逮不增不减。是菩萨摩诃萨为行般若波罗蜜沤和拘舍罗者。不念是为檀波罗蜜之所增减。是为般若波罗蜜但为有字。是为檀波罗蜜持所有而布施。心念持是功德。施作阿耨多罗三耶三菩。其施如阿耨多罗三耶三菩者。是菩萨摩诃萨为行般若波罗蜜。其行。般若波罗蜜。是为沤和拘舍罗。不念尸波罗蜜之增减但为有字。是为尸波罗蜜。是为持戒心念。以是功德施作阿耨多罗三耶三菩。施如阿耨多罗三耶三菩。是菩萨摩诃萨为行般若波罗蜜。羼波罗蜜惟逮禅波罗蜜亦尔。是菩萨摩诃萨为行般若波罗蜜沤和拘舍罗者。不念般若波罗蜜之增减但为有字。为般若波罗蜜者。即是智慧发心。持是功德施作阿耨多罗三耶三菩。施如阿耨多罗三耶三菩者。是能为施。须菩提白佛言。何等为阿耨多罗三耶三菩施。佛语须菩提。本无者是为阿耨多罗三耶三菩。是为不增不减。常随是念终不离行。今近阿耨多罗三耶三菩坐。如是须菩提。其本无者。不可逮亦不增不减。思惟念是为无所失。是为波罗蜜不减。是菩萨摩诃萨思惟念是。为离阿耨多罗三耶三菩坐。须菩提白佛。菩萨摩诃萨持心初发心。当近阿耨多罗三藐三菩坐。若持后心。近阿耨多罗三耶三菩坐。初心后心是二者无有对。后心初心亦无有对。何等功德而出生者。佛语须菩提。譬如灯炷之然。其炷用初明得然。若用后明得然。须菩提言。亦非初明得然。亦不离初明得然。亦非后明得然。亦不离后明得然。佛言。云何须菩提。为如是不。须菩提言。如是如是。天中天。佛语须菩提。菩萨摩诃萨亦不初心得阿耨多罗三耶三菩。亦不离初心得阿耨多罗三耶三菩。亦不后心得阿耨多罗三耶三菩。亦不离后心得阿耨多罗三耶三菩。须菩提白佛言。因缘者甚深。天中天。菩萨摩诃萨不用初心得阿耨多罗三耶三菩。菩萨亦不离初心得阿耨多罗三耶三菩。亦不后心得阿耨多罗三耶三菩。亦不离后心得阿耨多罗三耶三菩。云何须菩提。前心为灭耶。后心复生耶。须菩提言。不天中天。云何须菩提。心初生者为灭不。须菩提言。其法为灭法。天中天。云何须菩提。其法当所灭者。宁可灭不。须菩提言。不天中天。云何须菩提。宁可住如本无。须菩提言。其欲住者当如本无。云何须菩提。设令住如本无将无有异。须菩提言。不天中天。云何须菩提。本无为甚深不。须菩提言。甚深天中天。云何须菩提。本无为有心不。答言。无有天中天。云何须菩提。能有异本无有心者不。答言。不天中天。云何须菩提。本无见意不。答言。不天中天。云何须菩提。其作是行为深行不。答言。其作是行。天中天。为无所行。何以故。作是不见行为不可见行。佛语须菩提。菩萨摩诃萨行般若波罗蜜者为行何等。须菩提言。为行审谛天中天。云何须菩提。其行谛者为行想不。答言。不天中天。云何须菩提。菩萨摩诃萨为识想念不。答言不天中天。云何须菩提。为不识想念为念。须菩提言。菩萨摩诃萨而不为是。云何须菩提。不作想而得应行具足一切佛法不为声闻须菩提言。菩萨摩诃萨沤和拘舍罗者。于无想为无所贪。舍利弗问须菩提。若菩萨摩诃萨于梦向三事。三昧念脱门。空空无相无相无愿无愿三昧是为有益。般若波罗蜜于昼日夜复有益。若夜梦中时亦复有益。何以故。佛之所说昼日若夜梦中俱等无有异。须菩提语舍利弗。若菩萨摩诃萨昼日念般若波罗蜜。夜于梦中亦复倍益念般若波罗蜜。舍利弗言。云何须菩提。若于梦中有所作宁有所有不。答言不。一切诸法说亦如梦中之所有。须菩提语舍利弗。梦中所作善觉即大喜是者为益。若所作恶而不喜者是即为减。舍利弗言。设于梦中有杀其心大喜。觉已言我杀是大快。是者云何。须菩提言不妄。皆有因缘。心不空尔会有所缘。若见若闻若念觉即知之是为因缘故。令人心为所著。便有所得。何谓所得从所因缘乃受其罪。不从无因缘受其罪。皆从因缘生故。舍利弗言。一切所作因缘。皆为恍忽皆为空耳。云何天中天。从何因缘而得所生。答言。为从想因缘得生。舍利弗言。菩萨摩诃萨于梦中布施。持是施与作阿耨多罗三耶三菩。为有施与无。须菩提报舍利弗言。大弥勒菩萨摩诃萨今近在是。旦暮当补佛处。所问者可问之即能发遣。舍利弗白弥勒菩萨。今我所问。须菩提言。大弥勒菩萨即能解之。弥勒菩萨语舍利弗。如我字为弥勒。当所解者。当以色解。若当以痛痒思想生死识解。色者即空当以无所有解之。若痛痒思想生死识空解。亦不见法当所解者何所得解。亦不见法所解。当得阿耨多罗三耶三菩。舍利弗白弥勒菩萨。所说者为已得证。弥勒菩萨语舍利弗。所说法不言得证。舍利弗便作是念。弥勒菩萨所入慧为甚深。所以者何。般若波罗蜜以来久远。佛言。云何舍利弗。若能见彼作罗汉者不。舍利弗言。不天中天。佛语舍利弗。菩萨摩诃萨行般若波罗蜜亦如是不念我从是法受决。不从是法得决。若于是法当得阿耨多罗三耶三菩。自致阿惟三佛。是菩萨摩诃萨其作是作为行般若波罗蜜。不恐不得阿惟三佛。随是教者。为行般若波罗蜜。是菩萨摩诃萨为以无所畏。何以故。若至大剧难处虎狼之中不畏不怖。心念言设有啖我者当为布施。是为具足行檀波罗蜜。近阿耨多罗三耶三菩。愿我作佛。令其刹中无禽兽之道。若菩萨摩诃萨至大剧贼之中亦不畏怖。何以故。设令于其中死。心念言。我身会当弃捐。设杀我者我不嗔恚。是为具足忍辱行羼波罗蜜。当近阿耨多罗三耶三菩。愿我作佛时。令其刹中人无有贼盗。若菩萨摩诃萨至大无水浆之处亦不畏怖。心念言。一切人念悉无德使无水浆。愿我作佛时。令其刹中常有八味之水。使一切人悉得用之。用世间人故常为精进。若菩萨摩诃萨至谷贵之处亦不畏怖。心念言。我当坚其精进。自致得阿耨多罗三耶三菩。成阿惟三佛时。令我刹中无有恶。皆使一切人在所愿。饮食悉令在前。如忉利天上所有。是善男子。用一切人故。精进自致阿耨多罗三耶三菩。成阿惟三佛。若菩萨摩诃萨在恶贼时亦不畏怖。何以故。不见法当所痛者。用是故无所畏。假使我身遭是病死。心不有异必当精进。愿我作阿耨多罗三耶三菩成至佛时。令其刹中一切人皆无恶秽者死亡者。是菩萨摩诃萨之所言。如佛语而无异。复次舍利弗。是菩萨摩诃萨不久当成阿耨多罗三耶三菩。自致阿惟三佛。自于其法亦不恐怖。何以故。从本际已来发心呼言。不久其本际者为若干。为久远为甚大。久心如一转顷是为本际。是菩萨摩诃萨今近阿耨多罗三耶三菩。成阿惟三佛故。日闻是而不恐怖。尔时优婆夷。从坐起前为佛作礼长跪白佛。我闻是语不恐不怖。必后欲为一切人说法令不恐怖。应时佛笑。口中五色光出笑竟讫。以优婆夷者。即以金华持散佛上。用佛威神。其华在佛上亦不堕地。阿难从坐起。整衣服前为佛作礼却长跪问佛。怛萨阿竭所笑不妄必有所说。佛语阿难。是怛架调优婆夷者。却后当来世其劫名为星宿。当于是劫中作佛。号字曰金华佛。佛语阿难。是优婆夷者。后当弃女人形体。更受男子身便生阿閦佛国

摩诃般若钞经卷第四摩诃般若钞经卷第五

        秦天竺沙门昙摩蜱共竺佛念译

    守空品第十

须菩提白佛言。云何为空所作不贪。云何守空即是三昧。佛语须菩提。菩萨摩诃萨行般若波罗蜜者。观色空观痛痒思想生死识空。作是观者为一心。如所观于法亦为无所见。于法中而不作证。须菩提白佛言。佛所说者不以空作证。云何菩萨摩诃萨于三昧不以空作证耶。佛语须菩提。是菩萨摩诃萨观一切色所有皆空亦不作证。作是观者为不取证。不作证观即无所贪。是者为观以无所贪是即为观。欲向是时而不证不贪。其时心不念三昧因缘。是者为念。尔时为不失菩萨本法。不中道得证。何以故。所作功德法甚深。不贪是时故不取证。以从般若波罗蜜得护。譬如人若勇若捍能却敌者。为人端正猛健。无所不能。悉知兵法六十四变。悉索五晓为众所敬。在所致处无不得利。从是所得转分布与人。其心人俱莫不欢喜。若有他事。与父母妻子俱过大剧难之中。其人便自安其父母妻子言。莫恐莫怖今当俱出是难之中。若于其中。怨家卒来。其人慧黠。应时出其父母妻子。送归乡里皆得完具亦无有恶。及于怨家亦无所中伤。何以故。用无所不晓。其人勇健为变化胜于怨家。怨家见者莫不恐怖而皆走去。其父母妻子得出难中。归其处所无不欢喜。如是须菩提。菩萨摩诃萨于一切人极大慈心。是时菩萨摩诃萨持慈心悉施于人。过诸垢浊魔之所部。复出声闻辟支佛道地上。菩萨于三昧中立而无所尽。用波罗蜜故于空为无所贪。作是行时。是菩萨摩诃萨为行空三昧向脱门。亦不以有相不以无相。故不取证。譬若飞鸟。须菩提。飞行空中无所触碍。是菩萨摩诃萨为行空至空。向无相至无相。向无愿至无愿。不以空无相无愿故堕。悉欲具足佛诸法。譬如工射之人。须菩提。射空其箭在空中。复以一箭中前箭后复射前。各各中之而不堕地。其人欲令前箭堕尔乃堕之。如是须菩提。菩萨摩诃萨行般若波罗蜜者。以为沤和拘舍罗之所护持自于本际不中道取证。成满其功德。悉逮得阿耨多罗三耶三菩。于功德以成满者得佛。能为本际作证。是菩萨摩诃萨为行般若波罗蜜。是法于法有生。须菩提白佛言。菩萨摩诃萨实慊苦作是学。而不中道取证。大哉天中天。从本行是安隐自致得成佛。佛语须菩提。菩萨摩诃萨欲护一切人故。是为本愿之所致故。能护于一切而得度脱。是为守空三昧向脱门心念分别。何等为分别。守空三昧为分别。无相三昧为分别。无愿三昧为分别。而不中道为本际取证。何以故。为沤和拘舍罗之所护。初发心时念欲护一切故。持是所念得入沤和拘舍罗故。不中道取证。复次须菩提。若菩萨摩诃萨深入处脱者。若空三昧向脱门。无相三昧向脱门。无愿三昧向脱门。用是故其心分别之。是人已来久远所因。其行令弃所因。是为阿耨多罗三耶三菩之所说法。是为守空三昧向脱门。守无相三昧向脱门。守无愿三昧向脱门。是为无愿三昧向脱门。本心所发蒙沤和拘舍罗。不中道为本际作证。是为于慈无所损。是为护等哀三昧。所以者何。用沤和拘舍罗故。是菩萨摩诃萨为益于法便得多智。成于力无所不觉。复次须菩提。菩萨摩诃萨之所念。是人已来从久远而有益于法。得所知成其力无所不觉。复次须菩提。是为菩萨摩诃萨之所念。知人从久远有想识呼为有我。作阿耨多罗三耶三菩时用一切人故为说其法令作无相三昧向脱门发心念。是为沤和拘舍罗。用是故不中道为本际作证。是为于慈无所损。是为护等哀三昧。是为菩萨摩诃萨。益于法得所知。成其力无所不觉。复次须菩提。是为菩萨摩诃萨之所念。念人从久远已来。想无常想其苦想其空想现在。菩萨自念言。我作阿耨多罗三耶三菩时。用一切人故为说其法。无常者为从乐。其空者为从有。无我皆从我。用是念故得沤和拘舍罗。是为行般若波罗蜜。知佛不三昧而坐三昧。但欲具足佛诸法。是为无愿向脱门而不作证。菩萨摩诃萨当作是知何所阿耨多罗三耶三菩发心之所发者。是人所发者。是人为从久远已来。其所行者而无所行。于其想行而不想行。于其想行求而不行想。于其行想聚而不行想聚。于其所行有而不行所有。于其行不正而不行不正念使一切人皆令无。是菩萨摩诃萨念是时。为以明于一切人。作是念时是为沤和拘舍罗。是为甚深微妙观视其法。是者为空即为无相无愿。是为无生死即为无所生即为无所有。是者须菩提。为菩萨摩诃萨慧法为无所生。其于三界而不知者来有所问。是菩萨摩诃萨欲成阿耨多罗三耶三菩故。以是故欲知其法。当云何发珍宝心。于菩萨摩诃萨。不以空而作证。亦不无相亦不无愿。亦不生死亦不有所生。亦不以无念作证。是为念般若波罗蜜。是者须菩提。菩萨摩诃萨为已受决。所念如空无相无愿。无生死无所从生。念如无所有其本无。不发善心者不能知是。其能解者。是菩萨摩诃萨为从过去佛所闻阿耨多罗三耶三菩事。其心以不转已。何以故。复有菩萨摩诃萨。念法而不能明。其有问者。亦不能解遣知。是未在菩萨道地。不应阿惟越致其界。佛语须菩提。若不闻波罗蜜之所言。其有闻者若不闻者能解其慧。是菩萨摩诃萨为阿惟越致。须菩提言其为菩萨者。甚多天中天。少有能解者。佛语须菩提。少有菩萨。在阿惟越致慧地。其受决者乃能解之。是菩萨摩诃萨其功德为甚大。非是诸天及人阿须伦世间之所知

    摩诃般若波罗蜜远离品第十一

复次须菩提。其谛者。菩萨摩诃萨于梦中不入声闻辟支佛道地。于三界不念有所求。亦不那中有所索。视诸法若梦不那中作证。是者须菩提。当知菩萨摩诃萨。是为阿惟越致相

复次须菩提。菩萨摩诃萨于梦中与若干百若干千若干亿千弟子。共会在其中坐。为诸比丘僧说法。如怛萨阿竭阿罗诃三耶三佛之所说法。是者须菩提。阿惟越致菩萨摩诃萨当知是为阿惟越致相。复次须菩提菩萨摩诃萨于梦中飞在空中坐。为比丘僧说法。还自见七尺光。自在所变化。于余处其所作为如佛之。所说法。其于梦见是者。当知菩萨摩诃萨是为阿惟越致相。复次须菩提。菩萨摩诃萨于梦中不恐不怖不难不畏。若见郡县其中兵起展转相攻伐。若火起若见虎狼师子及余兽。若见断人头者。如是余变甚大剧苦多有困穷。若饥渴者见其厄难心中不恐不畏不惊不动摇。夜于梦中所见。觉即起坐作是念。世界所有譬若如梦。我作佛时。悉为说法而遍教之。当知菩萨摩诃萨是为阿惟越致相。复次须菩提。云何知是菩萨摩诃萨当得阿耨多罗三耶三菩成阿惟三佛时其境内一切无有恶。正是菩萨摩诃萨。须菩提。于梦中若畜生相食人民疾疫。其心稍稍有念。愿我作佛时。使我境界中一切无有恶。用是故知其相为清净。当知菩萨摩诃萨是为阿惟越致相。复次须菩提。菩萨摩诃萨于梦中得觉。若见灾邪火起。便作是念。我于梦中所见其心等无异。持是比用是相具足。知是菩萨摩诃萨阿惟越致若菩萨摩诃萨作是念。如我审应相行者。当如所言无异。今是城郭所起火者。当为悉灭消去不复见。佛言。若火悉为消灭去者。知是菩萨摩诃萨受决以为过去怛萨阿竭阿罗诃三耶三佛之所受阿耨多罗三耶三菩。知是为阿惟越致。令火不灭消去者。知是菩萨未受决。设火焚烧一舍。置一舍。复越烧一里置一里。是须菩提当知某家居人前世时。为断法罪之所致。觉是辈人所作。皆是宿命。念以见在所更恶令悉除。其所断法殃因是皆得消尽。用是故。须菩提当知是菩萨摩诃萨即阿惟越致阿耨多罗三耶三菩。复次须菩提。用是比相其行具足。当视是菩萨摩诃萨如阿惟越致。用是故说其比相行当令知之。或时须菩提。若男子女人。为鬼神所下若为所持。是彼菩萨若作是念。设我受决以过去怛萨阿竭阿罗诃三耶三佛。授我阿耨多罗三耶三菩者。实慊苦有异。当得阿耨多罗三耶三菩阿惟三佛。若于阿耨多罗三耶三菩阿惟三佛所念皆清净者。为却罗汉辟支佛心。设以却罗汉辟支佛心者。会当作阿耨多罗三耶三菩。不得不成自致阿惟三佛。若当得佛为阿耨多罗三耶三菩者。阿僧祇刹土现在诸佛。无不见者无不证者。今怛萨阿竭阿罗诃三耶三佛。悉知我所念无有异。我审作阿耨多罗三耶三菩阿惟三佛者。审如我之所言。是鬼神即当去便告言是男子女人为何鬼神所持。鬼神闻其所言即去。说是语时设不去者。是菩萨为未受决过去怛萨阿竭阿罗诃三耶三菩。不授阿耨多罗三耶三菩。若说是言邪即去者。知是菩萨为以受决。过去怛萨阿竭阿罗诃三耶三菩。所授阿耨多罗三耶三菩。佛语须菩提。其人审至诚者。弊魔往到菩萨摩诃萨所。若菩萨言我审至诚者已受决。为阿耨多罗三耶三菩。是邪鬼神即当去。弊魔用是故作好心。化令邪鬼神悉去。所以者何。弊魔极尊有威神故。诸邪鬼神不敢当之。是皆魔威神之所辟。用是故悉为除去。若菩萨自念用我威神故。是彼菩萨摩诃萨以自谓。是便反自贡高。轻易于人形笑他人。而无所录。语人言我从过去怛萨阿竭阿罗诃三耶三佛所授决。以其余人者悉未受决。为阿耨多罗三耶三佛所授决。以其余人者悉未受决为阿耨多罗三耶三菩。用是故自可自高恚怒稍增。即离萨芸若大远失阿耨多罗三耶三佛慧知是辈菩萨无沤和拘舍罗而自贡高。便在二道地堕声闻辟支佛地。是辈菩萨。须菩提。持不成作成不知魔。为反舍善师而去。亦不与从事亦不录视。用是故为魔所困。是菩萨摩诃萨当觉知魔为以何占之觉知。魔来在菩萨前。魔作变化为异被服往来。作是言语。菩萨摩诃萨若从过去怛萨阿竭阿罗诃三耶三佛之所。授决阿耨多罗三耶三菩。若本字某若母字某。若父字某若兄字某若姊字某若弟字某。亲厚知识字某。若父兄字某。若七世祖父字某。若母外家字某。若父外家字某。若在某城生。若在某国生。若在某郡生。若在某县生。若在某乡生。若常软语。若令作是语者皆乃前世之所致。亦复作是软语。或时高才者便复随形言。若前世时亦复高明。或见自守。或见乞食。或时一处饭。或时就饭者。或时先食果菜却食饭。或时在丘墓间。或时寂寞处。或时树间止。或时受请者。或时不受请。或时多少取足。或时一处止。或时麻油不涂身。或时声好或时互谈。何以故。魔复言。是因缘者皆前世时德之所致令逮得。是若前世时某家子。若刹利姓若复字某。前世有是德今故亦尔。彼菩萨心便作是念想我且尔。是弊魔便复作是言。若以受决过去怛萨阿竭阿罗诃三耶三佛授。若阿耨多罗三耶三菩。用是因缘功德故。若是阿惟越致。佛语须菩提。我所说阿惟越致菩萨摩诃萨不尔。持是比相行占之。如我所说者不具足得反自用者。当知是菩萨辈终不成为魔所坏。何以故。用是比观其相行。知是即非。阿惟越致菩萨摩诃萨者终不有是意。是辈菩萨闻魔乃。语名字心大欢喜。自谓审然便自贡高行形笑人。轻易同学而反自用。是彼菩萨摩诃萨。须菩提用受是字。因失其本便堕魔网

复次须菩提。用受字故。是菩萨摩诃萨不觉魔为。反自呼得阿耨多罗三耶三菩。魔复作是言。若当作阿耨多罗三耶三菩。若作佛时当字某。是菩萨闻是字。心中作是念。我将得无然。我亦先时念复如是。佛言。是菩萨于知为甚少。无沤和拘舍罗。反作是念希望名字。自我作阿耨多罗三耶三菩。字当如是。佛言。如魔所教者为从魔天。今作比丘为魔所迷。自念是我本发心之所致。今得是字为如所言。过去怛萨阿竭阿罗呵三耶三佛受我决以为阿耨多罗三耶三菩。佛语须菩提。我所说阿惟越致菩萨摩诃萨。用是比相行而不为是其以字自念我是。便轻余菩萨摩诃萨。用是轻故离萨芸若阿耨多罗佛慧。远沤和拘舍罗。以为离般若波罗蜜。以为离善师以为得恶师。是菩萨会堕二道。若声闻辟支佛道地。若大久远勤苦以后。乃复求佛者。用般若波罗蜜恩故。当复得阿耨多罗三耶三菩。自致成阿惟三佛。佛言。尔时发意受是字时。不即觉改悔者。如是当堕声闻辟支佛道地。佛言。比丘有四重事禁。若复他事所犯故。不复成沙门。不复为佛子。是坏菩萨之罪。重于比丘四事禁。是菩萨言。我字某生于某国。心作是念其罪最重于四事禁复过五逆恶。所以罪重者何为受字。故不知魔事之所为微妙。复次须菩提。远离之德。菩萨摩诃萨。弊魔须于前作是言。远离之法。正当如是怛萨阿竭阿罗呵三耶三佛之所称誉。佛语须菩提。我不作是说。远离教菩萨摩诃萨。止于独处树间闲处。须菩提白佛。云何天中天。菩萨摩诃萨有异远离。佛语须菩提。正使菩萨摩诃萨念恍忽。是为声闻之所念。念恍忽者为是辟支佛之所念。行恍忽者是菩萨摩诃萨。虽在城郭续为行远离行恍忽。是菩萨摩诃萨于一切恶法而无所起。行恍忽者是菩萨摩诃萨。若独处树间闲处止。是菩萨摩诃萨续行远离。是者我乐使菩萨摩诃萨作是行是远离之行当昼夜念之。是为菩萨摩诃萨远离行。菩萨摩诃萨远离行。菩萨摩诃萨行远离者虽在城傍续行恍忽。若在独处树间闲处止者恍忽。若在独处树间闲处止者行恍忽。是菩萨摩诃萨自念我以知远离。尔时弊魔便往教之令行远离言。若当于独处树间闲处止当作是行。是菩萨随魔所教便亡远离。魔复言。道为悉等声闻辟支佛道。皆作是念。无有异其作是者。为具足般若波罗蜜以当作是行。佛言。是菩萨摩诃萨所念法非清净。谓以随行而反自用轻余菩萨。自念谁能过我。轻易城傍行菩萨清净者。其心所念不入声闻辟支佛法。所有恶心。不受禅悦三昧三摩越。悉逮得所愿悉具足度佛言。无沤和拘舍罗菩萨者。正使在四千里空泽之中。禽兽所不至处。贼所不至。罗刹不至处。虽在彼间。若一岁若百岁。若千岁若百千岁若百千万岁。若百千万亿岁。正使复过是者不知远离。会无所益不能具足。为菩萨摩诃萨远离。自念谓悉得已悉明已。弊魔便往飞在空中作是言。善哉善哉。善男子。是真远离。怛萨阿竭阿罗呵三耶三菩所说。正当随是远离行。如是者疾得阿耨多罗三耶三菩阿惟三佛。是菩萨摩诃萨。闻是便从远离起去往到城傍远离菩萨所。若比丘成就有道人所。而自贡高反往轻言。若所行法是即为非。佛言。其随恍忽之行。是菩萨摩诃萨为正。反呼言非。中有反行反呼为是。不当敬者而反敬之。当所敬者反嗔向之。言我所行远离。用是故有非人来语我言。善哉善哉。若所行审是远离。若在城傍行者。谁当来语若谁当告若者。佛言。是菩萨有德人而反轻之。如是须菩提。菩萨当知。是人如担死人种。无所复中。反呼菩萨有短。是为菩萨怨家。其为厌菩萨者。以是天上天下之为大贼。正使如沙门被服亦复是贼。于菩萨有德人中亦复是贼。是曹辈者。须菩提。不当与共从事。不当与共语言。亦不当恭敬视之。何以故。当知是辈多嗔怒起败人好心。何所须菩提。是菩萨摩诃萨不释萨芸若。不舍阿耨多罗三耶三菩。若菩萨摩诃萨不释萨芸若者。是故阿耨多罗三耶三菩阿惟三佛。为一切人故作依。是辈菩萨不当与坏人者从事不敬之。不当与会所当护法。当自坚持当念之。常畏怖生死勤苦之处不当入中。于三界而不与交。是彼坏菩萨辈在所止处。常当慈心哀愍。护之。自念使我无得生。是恶心令有所[億-音+(夫*夫)]。设有不善。疾使我弃之。当用学故。是者须菩提。菩萨摩诃萨之为上知

    摩诃般若波罗蜜善知识品第十二

复次须菩提。其诸菩萨摩诃萨。欲得阿耨多罗三耶三菩阿惟三佛者。当亲近善师。与共从事恭敬承事。须菩提白佛言。何所是天中天。菩萨摩诃萨善师当何以知。佛语须菩提。天中天者。是菩萨摩诃萨善师。有说般若波罗蜜者。从其所闻般若波罗蜜。是即为度教人入。中当作。是知为是菩萨摩诃萨善师。六波罗蜜者。是菩萨善师。六波罗蜜是舍怛罗。六波罗蜜者是道。六波罗蜜者是为去冥。六波罗蜜者是即为台。六波罗蜜者是即为明。以过去怛萨阿竭阿罗诃三耶三佛皆从六波罗蜜出。甫当来怛萨阿竭阿罗诃三耶三佛皆从六波罗蜜出。今现在阿僧祇诸刹土怛萨阿竭阿罗诃三耶三佛皆从六波罗蜜出。成萨芸若。皆从四事杂施于人。一者布施。二者欢乐。三者饶益。四者等与。是者须菩提。菩萨摩诃萨舍怛罗。是即为母。是即为父。是即为舍。是即为台。是即为护。是即为归是即为导。是皆六波罗蜜。是为益于一切人者。菩萨摩诃萨。学六波罗蜜者。用无有极故。欲断人之狐疑。以是故当学般若波罗蜜。须菩提白佛。何所是天中天。般若波罗蜜相。佛语须菩提。无所挂碍是般若波罗蜜相。须菩提言。如天中。天所说。是相实般若波罗蜜。如是相者为得诸法。佛言。如是须菩提。其如相为得般若波罗蜜。如是相者为得诸法。何以故。须菩提。诸法皆是恍忽诸法皆是空。以是故须菩提。恍忽。与空是为般若波罗蜜相。诸法之相亦恍忽。是空亦恍忽。须菩提。天中天。说诸法悉恍忽是空何然。人欲有生无有尽时。其恍忽者无欲。其恍忽者而无生。其空者无欲。其空者无所生。恍忽与空无阿耨多罗三耶三菩阿惟三佛。亦不从异法。恍忽空得阿耨多罗三耶三菩阿惟三佛。云何天中天。所说而可得知。佛语须菩提。人从久远念言。是我所有非我所有。用是故因致是。须菩提言。如是天中天。所说人实从久远念言。是我所有非我所有。佛言。云何须菩提。是我所有为空不。须菩提言。是为空。天中天。佛言。云何须菩提非我所有为空不。须菩提言是为空。天中天。佛语须菩提。人用是故自念言。是我所非我所。用是故在于生死无有已时。须菩提言。如是天中天。人用是故在于生死无有休时。佛言。是者须菩提。人从欲便着于人之中当作是知。不当有所求。后便不复着。其谛者。须菩提有所增益不当念是我所有非我所有是为行般若波罗蜜。是者须菩提。其所生者后不作是生。是菩萨摩诃萨为行般若波罗蜜。须菩提白佛。作是行者。天中天。为不行色不行痛痒思想生死识。是所行者。天中天。菩萨摩诃萨所念为随俗。是为菩萨摩诃萨行。天中天。诸声闻辟支佛所不及。一切人之所行。是彼极过去。以是所得处无能逮者。是为菩萨摩诃萨之极上。天中天。是所念者。为般若波罗蜜。菩萨摩诃萨昼夜作是行。如所行者。疾近阿耨多罗三耶三菩阿惟三佛坐。佛言。云何须菩提。若阎浮利人。及一切菩萨悉令作人。皆行阿耨多罗三耶三菩发心索佛。各各尽寿作布施。持是施与作阿耨多罗三耶三菩。于须菩提意云何。是菩萨摩诃萨作是布施。其福宁多不。须菩提言甚多甚多。天中天。佛言。不如菩萨摩诃萨专念般若波罗蜜一日之行。其福以过彼上。或是菩萨所专念般若波罗蜜。如其所行。是者都于众中为极上尊。何以故。其余人无有是慈。除诸佛无有与摩诃萨等者。是善男子。所入为甚深。晓了悉知见于世间。是即大悯。其眼彻视见不可计人。悉欲见之无有解时。念于一切人而不作想。亦无有异。是者须菩提。即菩萨摩诃萨之大明。虽未作阿耨多罗三耶三菩阿惟三佛者。是即所行其行极尊。出于世间之上。于阿耨多罗三耶三菩终不复还受人衣被饭食床卧医药悉具。心住于般若波罗蜜者。虽受施与其德已净。所作福德令近萨芸若坐。是故须菩提。菩萨摩诃萨有所食无有罪。欲益于一切人。悉欲示人道径。其有照明。欲甚度大无有极。诸在牢狱之中悉欲度脱。欲使一切人眼皆悉清净。是为般若波罗蜜之所念。行随是教念般若波罗蜜者。有是即为不动摇。何以故。其作动者所念有想。即非般若波罗蜜。是即非护。当作如般若波罗蜜行昼夜念之。譬如男子。须菩提。摩尼珠前所不得。却后得之欢喜踊跃。得摩尼珠以复亡之用亡。是故便大愁毒。坐起有忧而无有解已。如是须菩提。菩萨摩诃萨欲索珍宝者。常坚持心无得失萨芸若念。须菩提白佛。一切所念为离自然。云何菩萨摩诃萨念萨芸若不离于念。佛语须菩提。设是菩萨摩诃萨作是知。为不失般若波罗蜜。何以故。须菩提。般若波罗蜜者是空不增不减。须菩提言。般若波罗蜜者。天中天。实为是空。云何是菩萨摩诃萨增于般若波罗蜜。成就其行近阿耨多罗三耶三菩坐。佛语须菩提。菩萨摩诃萨亦不有增亦不有减。说是法时闻之不恐不怖。当知是善男子为行般若波罗蜜以。须菩提白佛。般若波罗蜜者是为空行。报言不须菩提。能有异空而行般若波罗蜜者。报言不须菩提。为是色行。报言不须菩提。为痛痒思想生死识行。报言不须菩提。能有异色所行。报言不须菩提。能有异痛痒思想生死识行。报言不须菩提。云何天中天。菩萨摩诃萨行般若波罗蜜。佛言。云何须菩提。为自见法。法之所行般若波罗蜜。须菩提言。不见天中天。佛言。云何须菩提。菩萨摩诃萨能自见行般若波罗蜜者。须菩提言。不见天中天。佛言。云何须菩提。能见法有所生处不。须菩提言。不见天中天。佛语须菩提。是为菩萨摩诃萨无所从生法乐忍。如是者即为受决阿耨多罗三耶三菩。是怛萨阿竭阿罗呵三耶三佛无所畏。是菩萨摩诃萨所作行是力者。为逮佛慧。是即大慧。而自在慧。萨芸若慧。怛萨阿竭慧。其不为是不能自能是处。须菩提白佛。诸法为从无所生受决为阿耨多罗三耶三菩。佛语须菩提不。须菩提白佛。云何天中天授菩萨摩诃萨决。得阿耨多罗三耶三菩。佛语须菩提。能自见法法授决为阿耨多罗三耶三菩。须菩提言。我不见法当作阿耨多罗三耶三菩。佛语须菩提。诸法不可得。作是念者。是法成阿惟三佛。其不作是不自致阿惟三佛

    摩诃般若波罗蜜释提桓因品第十三

释提桓因。从众会中白佛言。甚深甚深者般若波罗蜜。天中天。难了菩萨事之为恍忽。其有德人。闻般若波罗蜜者。便书持学其福不小。佛语拘翼。若阎浮利人。都皆持十善。其功德百倍千倍万倍万亿倍巨亿倍。若复过是不啻。不如善男子善女人。闻般若波罗蜜书持学者。坐中有一比丘。语释提桓因。是为以出拘翼上去。释提桓因报是比丘。持心一反念者出我上去。何况闻般若波罗蜜。以书持学者。闻以随是教立。都出诸天阿须伦世间人上。若菩萨摩诃萨行般若波罗蜜者。不独过诸天阿须伦世间人上。乃至须陀洹斯陀含阿那含阿罗汉辟支佛都悉过是。若菩萨摩诃萨行般若波罗蜜者。不独过辟支佛上。亦复至菩萨行檀波罗蜜无沤和拘舍罗离波罗蜜上去。是菩萨摩诃萨行般若波罗蜜者。不独过檀波罗蜜。亦复及行尸波罗蜜羼波罗蜜惟逮波罗蜜禅波罗蜜无沤和拘舍罗离般若波罗蜜上去。若菩萨摩诃萨复讽起行般若波罗蜜者都合会诸天阿须伦世间人终不能胜。行般若波罗蜜菩萨摩诃萨用为极尊。亲近般若波罗蜜故。是菩萨摩诃萨为随萨芸若言无所断。是菩萨摩诃萨不离怛萨阿竭字。是为菩萨摩诃萨获不离佛坐。是菩萨摩诃萨所有懈怠不复生。是菩萨摩诃萨所学为学尊。不学声闻辟支佛学。是学为菩萨摩诃萨学。四天王当往问讯。令乐得疾学是学。当坐佛坐。自致阿耨多罗成阿惟三佛。当度四部弟子。菩萨摩诃萨作是学者。四天王当往问讯。何况余天子。是菩萨摩诃萨行般若波罗蜜者常为怛萨阿竭阿罗呵三耶三佛之所念。般若波罗蜜者是菩萨行。若于世间有勤苦之疾。是身会无此恶。是为菩萨摩诃萨行般若波罗蜜之所致。便得现在法福。阿难作是念。释提桓因自以智说耶。持佛威神说释提桓因知阿难心所念即语阿难。我所说者持佛威神。佛言。如是如是。阿难。是释提桓因所说。悉佛威神之所致。或时阿难。菩萨摩诃萨于是深念般若波罗蜜行。便念学般若波罗蜜。尔时三千大千刹土中。弊魔一切皆为愁毒。欲使菩萨摩诃萨中道以本际作证。令得声闻若辟支佛道。若使得阿耨多罗三耶三菩疾成阿惟三佛

摩诃般若钞经卷第五


普遍智藏般若波罗蜜多心经

    No. 252 [Nos. 250, 251, 253-255, 257]

    普遍智藏般若波罗蜜多心经

        摩竭提国三藏沙门法月重译

如是我闻。一时佛在王舍大城灵鹫山中。与大比丘众满百千人。菩萨摩诃萨七万七千人俱。其名曰观世音菩萨。文殊师利菩萨。弥勒菩萨等。以为上首。皆得三昧总持。住不思议解脱

尔时观自在菩萨摩诃萨在彼敷坐。于其众中即从座起。诣世尊所。面向合掌曲躬恭敬。瞻仰尊颜而白佛言。世尊。我欲于此会中。说诸菩萨普遍智藏般若波罗蜜多心。唯愿世尊听我所说。为诸菩萨宣秘法要。尔时世尊以妙梵音。告观自在菩萨摩诃萨言。善哉善哉具大悲者。听汝所说。与诸众生作大光明。于是观自在菩萨摩诃萨蒙佛听许。佛所护念。入于慧光三昧正受。入此定已。以三昧力行深般若波罗蜜多时。照见五蕴自性皆空。彼了知五蕴自性皆空。从彼三昧安详而起。即告慧命舍利弗言。善男子。菩萨有般若波罗蜜多心。名普遍智藏。汝今谛听善思念之。吾当为汝分别解说。作是语已。慧命舍利弗白观自在菩萨摩诃萨言。唯大净者。愿为说之。今正是时。于斯告舍利弗。诸菩萨摩诃萨应如是学。色性是空空性是色。色不异空空不异色。色即是空空即是色。受想行识亦复如是。识性是空空性是识。识不异空空不异识。识即是空空即是识。舍利子。是诸法空相。不生不灭不垢不净不增不减。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界乃至无意识界。无无明亦无无明尽。乃至无老死亦无老死尽。无苦集灭道。无智亦无得。以无所得故。菩提萨埵依般若波罗蜜多故心无挂碍。无挂碍故无有恐怖。远离颠倒梦想。究竟涅槃。三世诸佛依般若波罗蜜多故。得阿耨多罗三藐三菩提。故知般若波罗蜜多是大神咒。是大明咒。是无上咒。是无等等咒。能除一切苦真实不虚。故说般若波罗蜜多咒。即说咒曰

揭谛揭谛　波罗揭谛　波罗僧揭谛　菩提莎婆诃

佛说是经已。诸比丘及菩萨众。一切世间天人阿修罗乾闼婆等。闻佛所说皆大欢喜。信受奉行普遍智藏般若波罗蜜多心经


胜天王般若波罗蜜经

    No. 231 [No. 220(6)]

胜天王般若波罗蜜经卷第一

        陈优禅尼国王子月婆首那译

    通达品第一

如是我闻。一时婆伽婆。在王舍大城耆阇崛山。与大比丘众四万二千人俱。皆是阿罗汉。诸漏永尽所作已办。舍诸重担逮得己利。尽诸有结心善解脱。善得自在犹如大龙。唯阿难在学地须陀洹果。其名曰净命阿若憍陈如。摩诃迦叶憍梵波提薄拘罗离波多毕陵伽婆蹉大智舍利弗摩诃目干连须菩提富楼那弥多罗尼子阿尼楼陀摩诃迦栴延优波离罗睺罗如是等四万二千人俱。菩萨摩诃萨七万二千人俱。悉已通达甚深法性。调顺易化善行平等。一切众生真善知识。得无碍陀罗尼。能转不退法轮已。曾供养无量诸佛。从他佛土为法来集一生补处。护持法藏不断三宝种法王真子。绍佛转法轮。通达如来甚深境界。虽现世间世法不染。其名曰宝相菩萨宝掌菩萨宝印菩萨宝冠菩萨宝髻菩萨宝积菩萨宝海菩萨宝焰菩萨宝幢菩萨金刚藏菩萨金藏菩萨宝藏菩萨德藏菩萨净藏菩萨。如来藏菩萨智藏菩萨日藏菩萨定藏菩萨莲华藏菩萨解脱月菩萨普贤菩萨观世音菩萨观月菩萨普音菩萨普眼菩萨莲华眼菩萨。广眼菩萨普行菩萨普戒菩萨智意菩萨莲花意菩萨胜意菩萨上意菩萨金刚意菩萨师子游戏菩萨师子吼菩萨大音王菩萨妙音菩萨无染菩萨月光菩萨日光菩萨智光菩萨智德菩萨贤德菩萨华德菩萨文殊师利菩萨。十六贤士跋陀婆罗菩萨为上首。贤劫菩萨弥勒菩萨为上首。四天王天四王为上首。三十三天帝释为上首。夜摩诸天须夜摩王为上首。兜率陀天[月*冊]兜率陀王为上首。化乐天善化王为上首。他化自在天自在王为上首。诸梵天大梵王为上首。首陀婆娑天摩醯首罗为上首。复有诸阿修罗王。娑利阿修罗王罗睺阿修罗王。如是等无量百千诸大阿修罗王复有诸龙王。阿耨大池龙王摩那斯龙王娑伽罗龙王婆修吉龙王德叉迦龙王各将眷属无量百千耆阇崛山纵广四十由旬地。及虚空靡有间隙。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一心合掌恭敬如来。尔时世尊百千大众前后围绕。供养恭敬尊重赞叹。如来面门放大光明。遍照十方无量世界。还至佛所右绕三匝从面门入。东方去此过十恒河沙佛世界。有佛国土名曰庄严。佛号普光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在世为诸菩萨摩诃萨说一乘正法。彼佛国土尚无声闻辟支佛名。况复修其法者。诸菩萨众皆不退转阿耨多罗三藐三菩提。其土众生不因饮食但资禅定。日月星光皆悉不现。唯佛光明照曜其国。无诸山陵。地平如掌。有一菩萨名曰离障。与百千菩萨至其佛所。偏袒右肩右膝着地。合掌向佛头面作礼。而白佛言。世尊。以何因缘有斯光明照此国土。时普光如来告离障菩萨摩诃萨言。善男子。西方去此过十恒河沙世界。有佛国土名曰娑婆。佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今欲为诸菩萨说摩诃般若波罗蜜。以是因缘放此光明。时离障菩萨白彼佛言。我今欲往娑婆世界礼敬供养释迦如来听受正法。彼佛告言。善。男子。今正是时。尔时离障菩萨蒙佛听许。即与无量菩萨眷属来娑婆世界。至耆阇崛山顶。礼佛足右绕三匝退坐一面。南方去此过十恒河沙世界。有佛国土名清净华。佛名日光十号具足。菩萨名日藏。西方去此过十恒河沙世界国名宝华。佛名功德光明十号具足。菩萨名功德藏。北方去此过十恒河沙世界国名清净。佛号自在王。菩萨名广闻。东南方去此过十恒河沙世界国名火焰。佛号甘露王。菩萨名不退转。西南方去此过十恒河沙世界。国名功德清净。佛号智炬。菩萨名大慧。西北方去此过十恒河沙世界国名悦意。佛号妙音王。菩萨名功德聚。东北方去此过十恒河沙世界。国名慧庄严佛名智上。菩萨名常喜。上方去此过十恒河沙世界国名不动。佛号金刚相。菩萨名宝幢。下方去此过十恒河沙世界。国名月光明。佛号金刚宝庄严王。菩萨名宝信。皆亦如是。尔时众中有一天王名钵婆罗。即从座起偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。我今欲问。若蒙佛许乃敢陈疑。尔时佛告胜天王言。大王。如来应供正遍知随所疑问当为解说。尔时胜天王欢喜踊跃得未曾有。即白佛言。世尊。云何菩萨摩诃萨修学一法通达一切法。佛告胜天王言。大王。善哉善哉。快问谛听谛听善思念之。如王所问当分别释。善哉世尊。唯然愿闻。佛告胜天王言。大王。菩萨摩诃萨修学一法通达一切法者。所谓般若波罗蜜。菩萨摩诃萨修学般若波罗蜜。则能通达檀那波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅那波罗蜜。般若波罗蜜。优波憍舍罗波罗蜜。尼坻波罗蜜。婆罗波罗蜜。阇那波罗蜜。大王。云何菩萨摩诃萨学般若波罗蜜行檀波罗蜜。菩萨摩诃萨以清净心无所希望。为他说法不求名利但令灭苦。不见我说不见听者。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜行法檀波罗蜜。菩萨摩诃萨学般若波罗蜜行无畏檀波罗蜜。观诸众生犹如父母兄弟亲戚令一切众咸亲附我。何以故。无始世来流转六道皆为亲戚。若有众生在怖畏难。菩萨摩诃萨尚以身命而救拔之。况应加恼。不见我施无畏。不见受者。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行资生檀波罗蜜。随诸众生资养之物种种布施令受十善。不见我施善及他受施。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行不望报檀波罗蜜。凡行施时不望果报。菩萨法尔自应布施。不见我行不见施报。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行大悲檀波罗蜜。见诸众生贫穷老疾无救济者。起大悲心而发誓愿。我得阿耨多罗三藐三菩提。为诸众生作归依处。以少善根回向菩提为众生故亦不分别。我能救济及受救者。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行恭敬檀波罗蜜。随他所须。菩萨摩诃萨身自取物。不令彼倦敬心授与。不见我能敬不见彼受敬。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行尊重檀波罗蜜。于诸众生悉起师僧及父母想。以尊重心合掌恭敬。若无财物惠以善言。不见我能尊重他可重者。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行供养檀波罗蜜。若见寺塔则应香华灯油扫洒供养。若见尊像毁坏正法缺损则应治葺。若见众僧四事供养。不见我能供养彼可供者。无二无别自性离故。菩萨摩诃萨学般若波罗蜜行无依止檀波罗蜜。不作是念。以此布施愿得生天或求天王。愿得生人若求人王。乃至阿耨多罗三藐三菩提。亦不希取无所得故。是名菩萨摩诃萨学般若波罗蜜通达檀那波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行尸罗波罗蜜。作是思惟。佛阿含教及毗尼中。说波罗提木叉。菩萨摩诃萨应学不见戒相。及我能持不着戒。不着见不着我。菩萨摩诃萨学般若波罗蜜。作是思惟。阿耨多罗三藐三菩提不止以持戒得。应当遍学菩萨戒行。戒性清凉寂静不生。自性离故。菩萨摩诃萨学般若波罗蜜。作是思惟。云何持戒能断烦恼。烦恼三种贪恚愚痴。又各三品谓上中下。须知对治。贪欲重者修不净观。具足观身三十六物。嗔恚多者修慈悲观。多愚痴者修因缘观。不见能观及所观法。无二无别自性离故。菩萨摩诃萨学般若波罗蜜。复作是念。云何菩萨摩诃萨离不正思惟。菩萨摩诃萨不生是心。我行寂静行离行空。诸余沙门婆罗门在喧挠中不乐空行。见不二别知自性离即灭邪念。菩萨摩诃萨学般若波罗蜜。虽知诸法离而深畏罪业。如佛所说应持净戒。修习功德乃至般若波罗蜜。少不善法不与共居。世尊所说。譬如毒药多少皆害。菩萨摩诃萨学般若波罗蜜。常生怖畏信行相应。菩萨摩诃萨于空旷处独行无侣。或有沙门婆罗门等。赍持金银琉璃真珠玛瑙虎珀珊瑚车磲白玉。以寄菩萨。不起贪着无有取心。作是思惟。世尊所说宁自割身取肉而食。于他之财不与弗取。菩萨摩诃萨学般若波罗蜜持戒坚固。若魔及魔眷属以妙色形逼试菩萨。心不动摇作是思惟。世尊所说一切诸法如梦幻化。无二无别自性离故。菩萨摩诃萨学般若波罗蜜。虽勤持戒不求生人若作人王。不求生天若作天王。身离三失。无口四过。意免三愆。如此持戒不见我能持不见戒相。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达尸罗波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行羼提波罗蜜。菩萨摩诃萨于其内心常能生忍。忧悲苦恼皆悉不随。亦学外忍。若他打骂终不生嗔。亦学法忍。如世尊说甚深实性无人无法。不生寂静即是涅槃。闻如此说心不惊怖。作是思惟。不学是法云何能得阿耨多罗三藐三菩提。深观三毒如是贪嗔于何处起。何因缘生何因缘灭。作是观察不见有生及可生法。不见能灭及所灭法。如是忍心相续不断。于六时中无有间隙不择境界。父母国王我则须忍。余可以威即便加恶。菩萨行忍不为报恩。名利仁义惭耻怖畏。菩萨摩诃萨法应行忍。若人加害挝打骂辱心不倾动。菩萨摩诃萨若作国王王等。有贫贱人骂詈耻辱。不示威刑云我是王法应治剪。即作是念。我于往昔诸世尊前发大誓愿。一切众生我皆济拔。令得阿耨多罗三藐三菩提。今若起嗔则违本誓。譬如良医发如是誓。世间盲[目*壹]我悉治愈。若自失明岂疗他疾。如是菩萨为除众生无明黑闇。自起嗔恚安能救彼。不见我能忍不见可忍。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达羼提波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行毗梨耶波罗蜜。未灭令灭未度令度。未脱令脱未安令安未学令学。菩萨如是行精进时。有诸恶魔为作留难。谓菩萨言。善男子。莫修此法。空受勤苦。何以故。我往昔时曾修此法。未灭令灭未度令度。未脱令脱未安令安未学令学。空受勤苦都无实利。我从昔来多见菩萨。修学此行并皆退转。汝可回心以取声闻辟支佛乘而自灭度。菩萨摩诃萨即便觉知告言。恶魔。汝复道去我心如金刚非汝能坏。汝若作障碍自得长夜苦魔即不现。若余菩萨修五波罗蜜。未得般若波罗蜜者。菩萨摩诃萨如是精进。设百千劫亦能超过。况复声闻辟支佛乘。菩萨摩诃萨行般若波罗蜜。成就佛法众恶悉离。虽行精进不疾不迟而发大愿。使我得身与世尊等。眉间白毫顶上肉髻。佛转法轮我亦如是。譬如真金众宝莹饰则为严净。菩萨精进亦复如是远离垢秽。所谓懒惰懈怠疲极。不自觉知不正思惟。离此垢秽即获清净智慧功德而共庄严。身不疲劳心无厌怠。障道恶法一切不善皆悉灭除。其有助道向涅槃法悉令增长。少恶不起何况其多。假使十方恒沙世界满中大火如阿鼻狱。此世界外有一众生可度脱者。菩萨摩诃萨能从中过况多众生。可作是念。无上菩提不易可得。菩萨修行如救头燃。百千万劫如此重担难可荷负。作是思惟。过现诸佛皆修此行。成阿耨多罗三藐三菩提。我亦如是正应修习。宁百千劫处地狱中使众生度。终不弃舍速取涅槃。如是精进心不自高于他不下。不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达毗梨耶波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行禅波罗蜜深种善根。于大乘中世世生生多习妙行近善知识不生贫贱。常在婆罗门刹利大姓。正信三宝增长善法。因宿善根作如是念。众生长夜流转六道。苦轮不息皆由贪爱。菩萨摩诃萨起厌离心。知从虚妄分别而有。修多罗中方便种种说欲过患。如槊如[矛*重]如刀如蛇如泡。臭秽不净无常。云何智人贪着此法。即剃须发出家修道。未见令见未得令得未证令证。闻说受持若世谛第一义谛。如实修行如法观察。所谓正见正分别正精进正语正业正命正念正定。远离喧杂不求名闻。供养恭敬身心精进常无休息。思惟此心多行何境。若善若恶无记境界。若行善境则勤精进增长善根。三十七品以治诸恶不善之法。恶不善者贪恚愚痴。贪欲三品谓上中下。其上品者若闻。欲名遍身战动。心踊欢悦不观欲过厌离不生。无惭无愧。何谓无惭。经游独行恒思欲境心心相续。唯见妙好不知过患。若其父母及余尊长呵彼所欲。于所尊前不觉起诤是名无惭。此人命终当生恶趣。中品欲者。若离境界不恒生心。下品欲者。但共言笑欲情即歇。嗔亦三品。上品嗔者愤恚若发心惛目乱。或造五逆若谤正法。及大重罪五逆之恶。于百分中不及其一中品嗔者。以嗔恚故而造诸恶即生悔心。下品嗔者。心无嫌恨。但口呵毁随生悔过。痴亦如是。虽作是观。知一切法如幻梦响乾闼婆城。虚妄不实颠倒故见。灭外境界内心寂静。不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达禅波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行般若波罗蜜。正智观色受想行识。不见色生不见色集。不见色灭。受想行识亦复如是。何以故。自性皆空无有真实但虚名字。而行般若波罗蜜。化诸众生终不为说无业果报。一切诸法如梦如幻。无我无人无众生无寿者无养育。而说有业果报。菩萨摩诃萨如是修行般若波罗蜜。恶魔不能得便。何以故。近善知识成助菩提离世间法。于诸如来甚深正法欢喜赞叹。若天若魔沙门婆罗门。除佛正智无及菩萨。不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达般若波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行优波憍舍罗波罗蜜。菩萨摩诃萨善巧回向阿耨多罗三藐三菩提。若见华果日夜六时供养诸佛及菩萨众。以此善根回向菩提华树果树亦复如是。若闻如来修多罗中说甚深义。信乐受持为众生说以此善根回向菩提。若见如来塔庙形像香华供养。令诸众生离破戒香获得如来清净戒香。扫洒涂地令诸众生威仪齐整华盖覆罩。令诸众生皆离恼热。入僧伽蓝愿诸众生。悉入涅槃。若出伽蓝愿诸众生出魔境界。开伽蓝门作如是愿。以出世智为诸众生启未开门。若见关闭。愿为众生关闭恶趣及以三有。坐时念言。愿诸众生坐菩提座。若右胁卧愿诸众生皆得涅槃。起时念言。愿诸众生起离诸惑。若洗脚足愿诸众生远离尘垢。礼佛旋塔愿诸众生成天人师。若有外道邪见难化。即自念言。我为彼师必不肯信。且作同学或为弟子。虽处彼众戒行多闻胜诸外道。因尔降伏尊重为师言必信受。毁其邪法为说涅槃。令入正教精修梵行。禅定三昧得诸神通。见多欲者化为女人第一端正。令彼爱着倏忽之顷示现无常。色变膖胀烂坏臭处。使其增恶起厌离心。即复本形为菩萨像而为说法。令发阿耨多罗三藐三菩提心成无上果。见大乘人离善知识。学二乘道不得其果唐失大乘。观彼根性即为说法入无上道。未发心者化令发心。已发心者教使坚固。见持戒人犯少轻罪。不解忏悔懈退忧愁不复修道。即为说法对治忏除令道胜进。菩萨摩诃萨少欲知足唯求法利。为众生说供养。如来。成就六波罗蜜说法供养。是为檀波罗蜜行不违言。是尸波罗蜜若天若魔不能坏乱。是羼提波罗蜜心心相续不觉疲倦。是毗梨耶波罗蜜专心一念不缘异境。是禅波罗蜜说法供养不见我我所。是般若波罗蜜不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达方便波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行尼坻波罗蜜。菩萨发愿不为有乐出离三界求二乘道。作大愿言。一切众生众生所摄皆入涅槃。然后我身乃成正觉。未发心者即令发心。已发心者令其修行。已修行者令得菩提。得菩提者请转法轮。乃至分身舍利起塔供养。复作愿言。若有世界诸佛成道悉无天魔。愿自智慧发无上心不由外缘。又愿我身常在世间。一切众生悉令成就。愿新发意诸菩萨等。若闻如来说甚深法心不惊怖。无边佛道。无边佛境。无边大悲。愿诸众生皆悉通达。又愿我身常生秽国不生净土。何以故。譬如病人乃须医药无疾不须。不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达愿波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行婆罗波罗蜜。菩萨摩诃萨能伏天魔摧诸外道。具足功德智慧力故。一切佛法无不修行无不证见。以神通力用一毛发。能举阎浮提乃至四天下三千大千世界。乃至无量百千世界。能于空中取种种宝施诸众生。十方无量无边世界诸佛说法无不闻持。不见我能行及所行法。无二无别自性离故。是名菩萨摩诃萨学般若波罗蜜通达力波罗蜜。大王。菩萨摩诃萨学般若波罗蜜行阇那波罗蜜。菩萨摩诃萨观五阴。生不见实生灭非实灭。作是思惟。此五阴空无我无人无众生无寿者无养育。凡夫众生虚妄着我。五阴非我阴中无我。我非五阴我中无阴。凡夫愚惑不如实知流转生死如旋火轮。一切诸法自性本空无生无灭。缘合谓生缘散为灭。自性非无是故不生。自性非有是故无灭。菩萨摩诃萨一切境界无有一法不通达者。修行如是智波罗蜜。二乘外道不能掩蔽。以智观察从初发心至入涅槃皆悉明了。能以一法知一切境。一切境界即是一法。何以故。如如一故。不见我能修及所修法。无二无别自性离故。是名菩萨摩诃萨行般若波罗蜜通达智波罗蜜

    胜天王般若波罗蜜经显相品第二

尔时胜天王。即从座起偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。是般若波罗蜜甚深。何者是般若波罗蜜相。佛告胜天王言。如地水火风相。般若波罗蜜相亦复如是。世尊云何地相。佛言。普遍广大难可度量是为地相。般若波罗蜜相亦复如是。何以故。如如普遍广大难思量故。大王。一切药草皆依地生。一切善法皆依般若波罗蜜生。又如土地增之不喜减之不嗔。离我我所无二相故。般若波罗蜜亦复如是。赞叹不增毁皆不减。离我我所无二相故。世间行来举足下足悉依于地。若求善道趣向涅槃。应当依是般若波罗蜜。又如大地出种种宝。般若波罗蜜亦复如是。生出世间种种功德。又如大地虫蚁蚊虻种种诸苦不能倾动。般若波罗蜜亦复如是。离我我所不可倾动。又如大地若闻师子龙象之声终无惊怖。般若波罗蜜亦复如是。天魔外道不能恐惧。何以故。不见有人不见有法自性空故。又如水大从高赴下。一切善法皆向般若波罗蜜。又如水大能润草木得生华果。般若波罗蜜亦复如是。润诸三昧生助道法。成一切智树得佛法果利益众生。又如水大渍草木根。能使倾拔随流而去。般若波罗蜜亦复如是。一切诸见烦恼习气。根本悉灭永不复生。又如水大性本清净无垢不浊。般若波罗蜜亦复如是。体无烦恼故名清净。离诸惑故名为无垢。一相非异故名不浊。如人夏热遇水清凉。热恼众生闻般若波罗蜜亦即清凉。如人患渴得水乃止。求出世法得般若波罗蜜思愿亦止。又如水泉甚深难入。般若波罗蜜亦复如是。诸佛境界甚深难入。又如坑坎之处水悉平等。般若波罗蜜亦复如是。一切声闻辟支佛及诸凡夫皆悉平等。又如水能洗地悉得清净。菩萨摩诃萨通达般若波罗蜜。离诸烦恼即得清净。何以故。自性清净离诸惑故。又如火大能烧一切树木药草。不作是念我能烧物。般若波罗蜜亦复如是。能灭一切烦恼习气。亦不作念我能除灭。又譬如火悉能成熟一切诸物。般若波罗蜜亦能成就一切佛法。又譬如火悉能干竭一切湿物。般若波罗蜜亦复如是。竭诸漏流永不复起。假使火聚在雪山顶。若一由旬至十由旬皆悉能照。而无是念我能照远。般若波罗蜜亦复如是。皆悉能照声闻缘觉及以菩萨。亦不作念我能照彼。又如禽兽夜见火光恐怖远避。薄福凡夫及以二乘。若闻般若波罗蜜恐惧舍离。般若波罗蜜闻名尚难况复修学。如夜远行迷失道路。若见火光即生欢喜。知有聚落疾往投趣。至则安隐永无怖畏。生死旷野有福德人。若闻般若波罗蜜。生大欢喜归趣受持。永离烦恼心得安乐。如世间火贵贱共同。般若波罗蜜亦复如是凡圣等有。又如婆罗门刹利咸供养火。诸佛菩萨咸皆供养般若波罗蜜。又如小火能烧三千大千世界。般若波罗蜜亦复如是。若闻一句则能焚烧无量烦恼。大王。般若波罗蜜离垢无著寂静无边。无边智慧等达法性。犹如虚空性无所住。离相境界过诸觉观。心心数法无有分别。无生无灭自性离故。大王。菩萨摩诃萨行般若波罗蜜。世间希有利益众生。犹如日月一切受用。又譬如月能除热恼。般若波罗蜜亦复如是。能除一切烦恼热毒。又譬如月世间乐见。般若波罗蜜亦复如是。一切圣人之所乐见。又如初月日日增长。菩萨摩诃萨亲近般若波罗蜜。从初发心乃至菩提渐次增长。如黑分月日日渐尽。菩萨摩诃萨修行般若波罗蜜。烦恼结使次第灭尽。如世间月婆罗门刹利咸所赞叹。若善男子善女人亲近般若波罗蜜。一切世间天人阿修罗皆所赞叹。如月游行遍四天下。般若波罗蜜亦复如是。若色若心无处不遍。如世间月常自庄严。般若波罗蜜亦复如是性自庄严。何以故。不生不灭性本清净。遍一切法自性离故。如世间日破一切暗。而不作念我能破暗。般若波罗蜜亦复如是。能破无始一切烦恼。亦不作念我破烦恼。又譬如日开敷莲华。而不作念我开莲花。般若波罗蜜亦复如是。能开菩萨亦无是念。又譬如日遍照十方。不作是念我能遍照。般若波罗蜜亦复如是。能照无边而无照相。又如见东方赤则知日出不久。若闻般若波罗蜜。当知去佛不远。如阎浮提人若见日出生大欢喜。若世间中有般若波罗蜜名字。一切圣人皆大欢喜。又如日出月及星宿光悉不现。菩萨摩诃萨行般若波罗蜜。二乘外道德亦不现。又如日出方见坑坎高下之处。菩萨摩诃萨行般若波罗蜜。世间乃知邪正之道。何以故。般若波罗蜜自相平等不生不灭性是离故。大王。菩萨摩诃萨行般若波罗蜜。多修空行无所住着修道离障。远恶知识亲近诸佛。心心相续念佛不断。通达平等随顺法界。神通游戏十方国土。于其本处都不动摇。见诸佛法犹如现前。虽处世间世法不染。犹如莲花生在淤泥菩萨摩诃萨虽处生死以般若波罗蜜方便力故而不染着。何以故。般若波罗蜜不生不灭自相平等。不见不着性是离故。又如莲华不停水滴。菩萨摩诃萨行般若波罗蜜。一不善法不得暂住。又如莲华所在悉香。菩萨摩诃萨行般若波罗蜜若在城邑聚落。人间天上悉具戒香。又如莲华体性清净。婆罗门刹利长者居士之所爱重。菩萨摩诃萨行般若波罗蜜。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等菩萨诸佛咸所爱敬。又如莲华始欲敷启能悦众心。菩萨摩诃萨行般若波罗蜜。面门常笑曾无嚬蹙能悦众生。又如世人梦见莲花亦是吉相。一切人天乃至梦中。闻见菩萨行般若波罗蜜。亦是吉祥况当真见。又如莲华初始生时。若人非人之所爱护。菩萨摩诃萨始学般若波罗蜜。诸佛菩萨释梵诸天之所卫护。菩萨摩诃萨行般若波罗蜜。兴如是心如理通达诸波罗蜜。满足佛法教化众生坐菩提树。成就阿耨多罗三藐三菩提转正法轮。世间沙门婆罗门。天魔释梵所不能转。化度十方无边世界一切众生。平等济拔于生死海。皆悉安置般若波罗蜜中。无归无依无救护者为作救护。欲见佛者即为示之作师子吼。神通游戏叹佛功德令众渴仰。其心清净而不转移。意无谄曲远离邪念。所谓不念声闻辟支佛法。尽诸垢秽无复烦恼。身无伪行离邪威仪。口无巧言如实而说。受恩常感轻恩重报。心不怀憾口恒软语。如是修习清净之心。不见能污不见可染。无二无别自性离故。大王。菩萨摩诃萨行般若波罗蜜。能信如来三种清净。作是思惟。修多罗说如来法身。寂静身。无等等身。无量身。不共身。金刚身。于此决定心无疑惑。是名能信如来身净。复次思惟。修多罗说如来口净如为凡夫受作佛记。亦为菩萨授记成佛。信如是言不相违背。何以故。如来永离一切过失无诸垢秽。无有烦恼寂静清净。若天若魔沙门婆罗门若梵。能得如来口业失者无有是处。是名能信如来口净。复次修多罗说如来意净。诸佛世尊心所思事。若声闻辟支佛菩萨一切天人无能知者。何以故。如来之心甚深难入。非诸觉观离思量境。无有边量同虚空界。如是信知心不疑惑。是名能信如来意净。复次菩萨摩诃萨行般若波罗蜜。作是思惟。如佛所说菩萨摩诃萨为诸众生不怖不疲。荷负重担其心坚固曾无退转。次第修习诸波罗蜜。成就佛法无有障碍。无边无等不共之法。所言决定其性勇猛。成就如来广大之事。菩萨摩诃萨于是事中。不疑不惑深心信受。菩萨摩诃萨行般若波罗蜜作是思惟。菩萨摩诃萨行般若波罗蜜。坐道场时能得无碍清净天眼天耳他心智宿命智漏尽智。于一念中通达三世平等智。如实观察一切世间。如是众生具身恶行口恶行意恶行。毁谤圣人邪见造邪业。身坏命终当堕恶道。如是众生具身善行口善行意善行。不谤圣人正见正业。身坏命终当生善道。如实观察众生界已作如是念。我昔发愿行菩萨道。自觉觉他此愿应满。菩萨摩诃萨行般若波罗蜜。于如是事不疑不惑如实信受。大王。菩萨成佛所名为觉处。自觉名正觉。成就众生名正遍觉。大王。如是菩萨摩诃萨行般若波罗蜜。信知如来出兴于世。大王。菩萨摩诃萨行般若波罗蜜。闻说一乘即便信受。何以故。诸佛所说真实不虚。种种余乘皆佛乘出。如阎浮提种种城邑聚落。别名并属此洲。如是诸乘种种名说皆属佛乘。复作是念。如来世尊善巧方便。种种说法皆实不虚。何以故。世尊说法随众根性。是故分别说有三乘其实一道。菩萨摩诃萨行般若波罗蜜复作是念。如来说法深远音声真实不虚。何以故。释梵天等以少功德。尚复能有深远音声。何况如来无量亿劫积习功德。菩萨摩诃萨行般若波罗蜜作如是念。如来说法不违众根。若上中下皆使成就。众生各谓独为我说。诸佛本来无说无示。菩萨摩诃萨于如此事不疑信解。大王。菩萨摩诃萨行般若波罗蜜。得心微细作是思惟。世间炽然大火之聚。所谓贪欲火。嗔恚烟。愚痴暗。云何当令一切众生皆得出离。若能通达诸法平等名为出离。如实知法犹如幻相。善观因缘而不分别。菩萨摩诃萨行般若波罗蜜作是思惟。诸法无本而有业报。诸佛菩萨凡所发言我知其意。既知意已即思量义。思量义已即见真实。见真实已济度众生。大王。菩萨摩诃萨行般若波罗蜜。善巧方便为众说法。所谓一切诸法皆悉无我。无众生。无养育。无人。无作者。无觉者。无生者。无见者。空无所有非自在性虚妄分别因和合生。大王。若说诸法皆悉无我乃至无见者。为称理说空无所有。乃至生缘亦复如是。大王。夫其说法随顺法相是名称理。不违法相与法相应得入平等。显现义理名巧说法。大王。菩萨摩诃萨行般若波罗蜜得无碍辩才。所谓无著辩才。无尽辩才。相续辩才。不断辩才。不怯弱辩才。不惊怖辩才。不共辩才。天人所重辩才。无边辩才。菩萨摩诃萨行般若波罗蜜得清净辩才。所谓不嘶喝辩才。不迷乱辩才。不怖畏辩才。不高慢辩才。义具足辩才。味具足辩才。不拙涩辩才。应时节辩才。大王。菩萨摩诃萨行般若波罗蜜。离大众威德畏故不嘶喝。坚住不怯智故不迷乱。菩萨处众如师子王故无怖畏。离诸烦恼故不高慢。不说无义通达法相故义具足。善解书论文字世智故味具足。无量劫来习巧便语故不拙涩。如是说法随顺四时。春如春说秋冬亦尔。应前说者不中后说。应后说者不前中说。应中说者不前后说。善知时故。大王。菩萨摩诃萨行般若波罗蜜。所得辩才令众欢喜。所谓爱语面门常笑不曾嚬蹙。发辞有义。能称如实所说决定不欺侮人。种种乐说以柔软言令众欢喜。颜色宽和使他亲附。随义而说闻者悟解。称法相说为利益故。平等为说心无偏党。作决定说无虚妄言。种种乐说随众根性令得欢喜。大王。菩萨摩诃萨行般若波罗蜜成大威德。何以故。非器不闻故。尔时胜天王即白佛言。世尊。菩萨摩诃萨行般若波罗蜜其心平等。云何不为非器者说。佛告胜天王言。大王。般若波罗蜜性自平等。不见器不见非器。不见能说及以所说。众生虚妄见说不说。何以故。般若波罗蜜不生不灭无相分别。犹如虚空一切遍满。众生亦尔不生不灭。声闻辟支佛菩萨及佛亦复如是。无名字法假立名字。云是众生云是般若。云有能说云有所说云有听者。第一义中同是一相。所谓无相。菩萨摩诃萨行是甚深般若波罗蜜。威德重故非器不闻。大王。般若波罗蜜不为非器众生说。不为外道说。不为不尊重者说。不为不正信者说。不为求法贸易者说。不为贪利养者说。不为嫉妒者说。不为盲聋哑者说。何以故。菩萨摩诃萨行般若波罗蜜时。心无悭吝不秘深法。非于众生无大慈悲不舍众生。众生宿世善根。得见如来及闻正法。诸佛如来本无说心为此为彼。但障重者虽复在近而不见闻。尔时胜天王白佛言。世尊。何等众生堪闻诸佛菩萨说法。佛告胜天王言。大王。具正信者诸佛菩萨即为说法。根性纯熟堪为法器。于过去佛曾种善根。心无谄曲威仪齐整。不求名利亲近善友。利根性人说文知义。为法精进不违佛旨。大王。诸佛菩萨为如是等众生说法大王。菩萨摩诃萨行般若波罗蜜。能作法师善巧说法。云何巧说说法。为利益佛法而说佛法竟不可见。虽说波罗蜜而波罗蜜竟不可得。虽说菩提而说菩提竟不可得。虽断烦恼而说烦恼竟不可得。虽为涅槃而说涅槃竟不可得。虽为须陀洹向须陀洹果乃至阿罗汉向阿罗汉果。而四果向竟不可得。虽为辟支佛果。而辟支佛果竟不可得。断除我见而说我见竟不可得。说有业报而说业报竟不可得。何以故。名字所得非是实法。法非名字非言境界。法非可议非心所量。名字非法法非名字。但以世谛虚妄假名有说。无名字法说为名字。名字是空空无所有。无所有者非第一义。非第一义即是虚妄凡夫之法。大王。是名菩萨摩诃萨善巧说法。菩萨摩诃萨行般若波罗蜜。以方便力得无碍辩才。随众生根性说是甚深般若波罗蜜

胜天王般若波罗蜜经卷第一胜天王般若波罗蜜经卷第二

        陈优禅尼国王子月婆首那译

    法界品第三

尔时胜天王即从座起。偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。云何菩萨摩诃萨学般若波罗蜜通达甚深法界。尔时佛赞胜天王言。善哉大王。谛听谛听。善思念之。胜天王白佛言。世尊。唯然愿闻。佛告胜天王言。大王。菩萨摩诃萨有般若故近善知识勤修精进。离诸障惑心得清净恭敬尊重。乐习空行远离诸见。修如实道能达法界。大王。菩萨摩诃萨有般若故近善知识。欢喜恭敬犹如佛想。以亲近故不得懈怠。灭一切恶诸不善法生长善根。既灭烦恼远离障法。即得身口意业清净。由清净故即生敬重。以敬重心修习空行。修空行故远离诸见。离诸见故修行正道。修正道故能见法界。胜天王白佛。世尊。何等为法界。佛告胜天王言。大王。即是如实。世尊。云何如实。大王。即不变异。世尊。云何不异。大王。所谓如如。世尊。云何如如。大王。此可智知非言能说。何以故。过诸文字离语境界口境界故。无诸戏论无此无彼。离相无相远离思量。过觉观境无想无相。过二境界过诸凡夫。离凡境界过诸魔事。能离障惑非识所知。住无处所寂静圣智。后无分别智慧境界。无我我所求不可得。无取无舍无染无秽清净离垢。最胜第一性常不变。若佛出世及不出世性相常住。大王。是为法界。菩萨摩诃萨行般若波罗蜜。修此法界百种苦行。令诸众生皆悉通达。大王。是名般若波罗蜜如如实际。无分别相不可思议界真空。一切智一切种智不二界。尔时胜天王白佛言。世尊。云何能证至此法界。佛告胜天王言。大王。以出世般若波罗蜜证后无分别智至。胜天王白佛言。世尊。证与至有何差别。佛告胜天王言。大王。以般若波罗蜜如实见名为证。以智通达名为至。胜天王白佛言。世尊。如佛所说闻思修慧通达般若波罗蜜。非是出世后无分别智。佛告胜天王言。不尔大王。何以故。般若波罗蜜甚深微妙闻慧粗浅不能得见第一义故思不能量。出世法故修不能行。大王。般若波罗蜜如是甚深。凡夫二乘所不能见。何以故。譬如生盲不见众色。七日婴儿不见日轮。尚不能见况复修行。大王。譬如夏热有人西行在于旷野。复有一人从西往东。问前人言。我今热渴何处有水清凉树荫。彼人答言。善男子。从此东行则有二路。一左一右当从右路。有清泉水及树荫凉。大王。于意云何。虽闻此名思惟往趣。能除热渴得水味不。不也世尊。此人至彼入池洗浴饮水息树。方离热渴得知水味。佛言。如是如是。大王。不可以三慧通达真实般若波罗蜜。大王。所言旷野即是生死人谓众生。热名烦恼渴是贪爱。东来人者即是菩萨。其右路者萨婆若道。菩萨摩诃萨行般若波罗蜜。善知生死及出世路。清冷水者所谓般若波罗蜜。树荫凉者即是大悲。菩萨摩诃萨行二法故。远离凡夫及二乘道。大王。如是甚深般若波罗蜜无形无相。种种巧说令诸众生得入其中。大王。菩萨摩诃萨行般若波罗蜜。如实知力空。无畏空。不共法空。戒聚空。定聚慧聚解脱聚解脱知见聚空。空空。第一义空。而空相不可得。不取空相不起空见。不执空相不依止空。如是不取着故于空不堕。大王。菩萨摩诃萨行般若波罗蜜远离诸相。不见内外相。离戏论相。离分别相。离求觅相。离贪着相。离境界相。离攀缘相。离能知所知相。胜天王白佛言。世尊。菩萨摩诃萨般若波罗蜜如是观无相。诸佛世尊。复云何观。佛告胜天王言。大王。诸佛境界不可思议。何以故。离境界故。一切众生思量佛境。心则狂乱不知此彼。何以故。同虚空性不可思量求不可得离觉观境。菩萨摩诃萨行般若波罗蜜。尚不见有凡夫境界可得思量。况佛境界亦不依止一切诸愿。虽行布施不着施报持戒忍辱精进定慧亦复如是一切功德乃至涅槃亦不依着。何以故。离我我所无二无别自性离故。说是般若波罗蜜法门时。三千大千世界六种震动。须弥山王。目真邻陀山。铁围山。大铁围山。宝山。黑山。大黑山。皆悉震动。无量百千亿诸菩萨摩诃萨脱上分衣为佛敷座高如须弥。无量百千释梵护世诸天王等。合掌恭敬散诸妙华曼陀罗华摩诃曼陀罗华。曼殊沙华摩诃曼殊沙华。白莲华赤莲华。红莲华青莲华。耆阇崛山纵广四十由旬。积华遍满至于佛膝。无量天子作诸天乐不鼓自鸣。空中叹言。再睹佛兴世再见转法轮。善哉阎浮提一切众生。勤修功德多种善根。得闻如是甚深般若波罗蜜。况复来世有能信者。如是众生悉行诸佛如来境界。复有无量百千诸大龙王。即以神力普兴大云。降注香雨洒耆阇崛山及三千大千世界。诸听法者唯觉香润不见沾濡。无量龙女悉于佛前合掌赞叹。无量乾闼婆以妙音乐而供养佛。其夜叉众散诸妙华。十方无量无边国土诸佛世尊。皆放眉间白毫。光明。照此娑婆世界耆阇崛山。其三千大千世界幽暗之处。日月不照悉蒙光明。照世界已还至佛所。右绕三匝从佛顶入。无量百千婆罗门刹利居士长者。以涂香末香幡华幢盖而供养佛。尔时众中七十二亿菩萨摩诃萨得无生法忍。无量百千万亿众生得远尘垢法眼净。无量百千万亿众生发阿耨多罗三藐三菩提心。尔时胜天王白佛言。世尊。般若波罗蜜离文字无语言。云何菩萨摩诃萨行般若波罗蜜为众生说法。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜。如是说法为修习佛法故。而说佛法毕竟不可得。为成熟诸波罗蜜。而波罗蜜毕竟不可得。为清净菩提而菩提毕竟不可得。为涅槃离欲灭而涅槃离欲灭毕竟不可得。为须陀洹斯陀含阿那含阿罗汉果。而须陀洹乃至阿罗汉毕竟不可得。为辟支佛而辟支佛毕竟不可得。为断除我取而我及取毕竟不可得。菩萨摩诃萨如是行甚深般若波罗蜜。心不分别一切诸相。我能分别及所分别悉不可得。随顺般若波罗蜜不违生死。虽在生死不逆般若波罗蜜随顺法相。胜天王白佛言。世尊菩萨摩诃萨云何随顺法相不违世谛。佛告胜天王言。大王。菩萨摩诃萨随顺甚深般若波罗蜜。不远离色受想行识。不远离欲界色界无色界。不远离法。而不着般若波罗蜜。不远离道。何以故。具巧方便故。胜天王白佛言。世尊。何者是菩萨摩诃萨善巧方便。佛告胜天王言。大王。所谓无量菩萨摩诃萨具慈悲喜舍不舍众生常能利益。大王。菩萨摩诃萨行般若波罗蜜具无边慈。无分别慈。法慈。不息慈。不恼慈。利益慈。平等慈。遍益慈。出世慈。成就如是等大慈。世尊。云何大悲。佛言。大王。菩萨摩诃萨行般若波罗蜜。众生苦恼无归依处。即为济拔发菩提心勤求正法。既自得已为众生说其悭贪者教行布施。无戒破戒教令持戒。恶性之人教行忍辱。懒惰懈怠教令精进。散乱之人教行禅定。愚痴之人教行般若。为度众生虽遭苦恼。终不舍离菩提之心。是名大悲。世尊。云何大喜。佛言。大王菩萨摩诃萨行般若波罗蜜作是思惟。三界炽然我已出离故生欢喜。久相系着生死之绳。我已割断故生欢喜。种种觉观及诸取相。于生死海我已得出故生欢喜。无始竖立我慢之幢。我今已摧故生欢喜。以金刚智坏烦恼山永不复立故生欢喜。我自安隐又令他安。愚痴黑暗贪爱系缚久寐世间。今始得觉故生欢喜。我今已离一切恶趣。又拔众生令出恶道。众生久于生死迷乱不知出道。我今济拔开示正路。悉令得至萨婆若城故生欢喜。是名大喜。大王。菩萨摩诃萨行般若波罗蜜。眼所见色不着不离而起舍心。耳声鼻香舌味身触意法亦尔。大王。菩萨摩诃萨行般若波罗蜜成就如是四无量心。尔时胜天王白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜为度众生示现诸相。佛告胜天王言大王。般若波罗蜜相不可得。菩萨摩诃萨相亦不可得。但方便力教化众生。示现处胎乃至涅槃。何以故。诸天计常谓无堕落。菩萨摩诃萨行般若波罗蜜。以方便力破此执故示现处胎。因令彼天起无常念。世间最胜最高无等不着五欲。欲不能污尚有堕落。况复余天。是故咸应勿复放逸。勤加精进一心修道。譬如见日尚有隐没。则知萤火不得久住。大王。复有放逸诸天贪着乐故不修正法。虽与菩萨同在天宫。不往礼拜不咨受法。而作是意。今且游戏朋诣菩萨。各相谓言菩萨与我常共在此修行何晚。菩萨摩诃萨行般若波罗蜜。勤修精进如救头然。破彼放逸示现堕落。如是示现有二因缘。一令诸天离放逸故。二令众生咸得见故。大王。世间复有下劣众生。不堪见佛成无上道及转法轮。菩萨摩诃萨为此众生。是故示现婴儿童子后宫游戏。菩萨若作余像说法。后宫女人则不信乐。是故示现婴儿童子。大王。有高行者常能离俗。菩萨摩诃萨。为化彼故示现出家。大王。复有天人作如是念。若以端坐受人天乐而得圣道。菩萨摩诃萨。为化此故示现苦行。亦为降伏诸外道故示现苦行。大王。复有天人长夜发愿。菩萨摩诃萨行诣道场。我等诸天常献供养。菩萨为化此众生故示诣道场。一切人众皆悉获得菩提因缘。大王。复有天人作如是念。恶魔外道障碍正法。愿得菩萨坐于道场。降伏恶魔及诸外道。正信之人悉令见法。菩萨摩诃萨既成道已。三千大千世界于虚空中。种种音声而赞叹曰。佛日出世萤火隐没。此等天人悉发是言。愿我来世皆得阿耨多罗三藐三菩提。如今菩萨摩诃萨。为是众生现坐道场。大王。又有天人作如是言。愿见大师成就一切智无师智自然智。不求出离根性纯熟是深法器。为是众生示现三转十二种法轮。大王。复有天人乐闻涅槃。菩萨为化彼众生故示现涅槃。大王。菩萨摩诃萨修行般若波罗蜜。能现如是种种之相。大王。菩萨摩诃萨行般若波罗蜜不生难处。何以故。无福德人不闻般若波罗蜜名字故。又复常离一切恶业。佛所说戒悉不毁犯心无嫉妒。已于过去无数佛所。多种善根具足功德。智慧方便成就大愿。心乐寂静勤行精进。大王。菩萨摩诃萨。无有恶业牵堕地狱。性行十善故。菩萨摩诃萨。无有破戒牵堕畜生。性持戒故。菩萨摩诃萨。无有嫉妒不牵堕饿鬼。不生邪见家常值善知识。何以故。已于过去无数佛所深种善根。是故生处皆悉正见。菩萨受生诸根不缺成佛法器。何以故。于过去世供养诸佛听闻正法礼敬大众。是故根具相貌端圆成佛法器。大王。菩萨不生边地。钝根愚痴不知善恶。语言义趣非佛法器。不识沙门婆罗门。何以故。菩萨受生必在中国。利根智慧言辞辩了。善知语义。是佛法器。善知沙门及婆罗门。何以故。菩萨摩诃萨。宿世智慧力故。大王。菩萨不生长寿天。不见诸佛不利众生故。菩萨所以生在欲界。示现出世利益众生。何以故。善方便故。大王。菩萨不生空世界中。此处无佛不闻正法不供养僧。何以故。菩萨生处必具三宝宿愿强故。菩萨若闻恶世界名即生厌离。修行寂静心不懈怠。以一切善灭诸恶法。大王。菩萨摩诃萨修行般若波罗蜜。以是因缘不生难处。大王。菩萨摩诃萨行般若波罗蜜乃至梦中尚不忘失菩提之心。况复觉时何以故。一切菩萨生于此心即是阿耨多罗三藐三菩提心。若无此心则无有佛。无佛无法无法无僧。由此心故得有三宝及以天人。菩萨摩诃萨常离谄曲质直柔和。其心清净不疑佛法。欲听受者不秘深义。离法嫉妒远三涂业。于初中后无有异相。行不违言护持大乘。见同学者则生恭敬。劝他修习赞叹大乘。于说法师常生佛想。近善知识远离恶友。大王。菩萨摩诃萨。修般若波罗蜜。如是成就菩提之心。因由此心得宿命智。何以故。已曾供养无量诸佛。护持正法修清净戒。远离恶业障碍永无。心常欢喜心勤修学。心不散乱心智不失。何以故。大王。若菩萨摩诃萨。已曾供养无量诸佛则尊重正法。由重法故广为人说。为护正法不惜身命。身口意业三种清净。业清净已得离障碍。离障碍故心常欢喜。心欢喜故则勤精进。心性正直念智具足。由念智故知过去生。一十百千乃至无数。大王。菩萨摩诃萨行般若波罗蜜。如是了知过去生处既了宿命。近善知识由善知识。于诸佛所不失三事。谓见闻念常听正法。供养僧宝无空过时。诸佛菩萨所恒恭敬礼拜尊重。行住坐卧不离多闻。大王。持净戒者耳根常闻般若波罗蜜名字。恒勤修习助道之法。曾不远离三解脱门。修四无量。常闻萨婆若名。大王。菩萨摩诃萨行般若波罗蜜。以是因缘近善知识。大王。菩萨摩诃萨行般若波罗蜜。乃至梦中不近恶友。何况觉时。何以故。菩萨摩诃萨。不与破戒人共住。邪见人。无威仪人。邪命人无义语人。懒惰人。乐住生死人。背菩提人。乐俗务人。不与共住。大王。菩萨摩诃萨行如是法离恶知识。大王。菩萨摩诃萨行般若波罗蜜。能得如来清净之身。所谓平等身。清净身。无尽身。善修得身。法身。不可觉知身。不思议身。寂静身。虚空等身。智身。胜天王白佛言。世尊。菩萨摩诃萨在何位中。能得如来十种之身。佛告胜天王言。菩萨初地得平等身。何以故。离诸邪曲通达法性见平等故。于第二地得清净身。何以故。清净戒故。住第三地得无尽身。何以故。离嗔恚故。第四地中得善修身。何以故。常勤精进修佛法故。住第五地则得法身。何以故。见诸谛理故。住第六地得离觉观身。何以故。观因缘理非觉观所知故。住第七地得不思议身。何以故。具足方便故。于第八地得寂静身。何以故。离一切戏论无烦恼故。住第九地得等虚空身。何以故。身相不可量遍一切处故。住第十地则得智身。何以故成就一切种智故。胜天王白佛言。如来之身与菩萨身无差别乎。佛告胜天王言。身无差别但功德异。胜天王言。其义云何。大王。佛菩萨身无有差别。何以故。一切诸法同一性相。功德差别。世尊。云何功德而有差别。佛言大王。今当为王譬喻显了。譬如宝珠若有装饰或不装饰其珠何异。佛与菩萨功德有差法身无别。何以故。如来功德一切圆满。尽于十方遍众生界。清净离垢障碍永无。菩萨之身功德未满有余障故。譬如初月十五日。月亏盈有异月性无差。此等诸身皆悉坚固。犹如金刚不可破坏。何以故。三毒不破世法不染。恶趣人间苦不能逼。悉已远离生老病死。能伏外道过魔境界。不向声闻辟支佛乘。以是因缘不可破坏。大王。菩萨摩诃萨行般若波罗蜜。善能将导一切世间天人阿修罗。譬如有人善为将导。若国王等长者居士意咸用之。菩萨亦尔。声闻缘觉菩萨诸佛。咸同用为将导。又如善将导者。世间国王婆罗门长者居士咸共尊重。菩萨亦尔。天龙夜叉有学无学之所供养。又如旷野险难怖畏行人疲倦。遇善将导能令安隐。菩萨亦尔。以方便力于彼生死烦恼贼难。将导众生安隐得出。又如贫人依富长者方出险难。梵志尼干及余外道。于生死中依行般若波罗蜜菩萨。尔乃出离又如大富长者无量赀财为一切人之所受用。行般若波罗蜜菩萨亦复如是。于生死中六道众生之所受用。又如大富长者欲过险难必要多伴。饮食资粮皆悉具足尔乃得过。菩萨亦尔。欲出世间以功德智慧。摄一切众生度生死难至萨婆若。又如人远行多赍宝物。为得利故。菩萨亦尔。从生死海至萨婆若。广修功德智慧。为得一切智故。又如世人求财无厌。菩萨乐法亦无厌心。又如将导。四事胜他。所谓财富最胜。位高语用。菩萨亦尔。富功德位最胜法自在无异言。又如人善导至于大城。菩萨亦尔。善能将导至萨婆若城。大王。菩萨摩诃萨行般若波罗蜜。善知行路不可行路邪正安善。有水无水相貌曲直。出离之道皆悉通达。大王。菩萨摩诃萨知不倒路。凡所示道不违众根。为大乘人示无上道。不说声闻辟支佛路。为小乘人示声闻道不说大乘。辟支佛根示缘觉路。不说萨婆若道。为着我见说无我道。着法众生为说空道。着二边者为说中道。为散乱者说奢摩他毗婆舍那不说散乱。戏论众生示如如道不说言语。着生死者示涅槃道不说世间。为迷涂者而说正道。大王。是名菩萨知邪正路

    胜天王般若波罗蜜经念处品第四

尔时胜天王。即从座起偏袒右肩右膝着地。合掌向佛头面作礼。而白佛言。世尊。菩萨摩诃萨行般若波罗蜜。能如是知路非路者心缘何住。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜心正不乱。何以故。善念身念受念心念法。菩萨摩诃萨。凡所游行城邑聚落闻利养名。如佛戒说烦恼系缚善自忆念。大王。云何菩萨摩诃萨行般若波罗蜜念身。与身相应恶不善法。以如实智悉远离之观身过失。始自足底乃至头顶。此身无我无常败坏。但以筋脉共相连持。腥臊臭秽色恶可恶所不喜见。如是观己身中贪欲悉不复生不起身我。以是因缘相应善法皆悉随顺。云何菩萨摩诃萨行般若波罗蜜念受。作是思惟。诸受皆苦。颠倒众生妄起乐相。凡夫愚痴以苦为乐。圣人但说一切皆苦。勤修精进为断灭故。亦教余人修学此法。作是观已恒自念受。不随受行修行断受亦令他学。云何菩萨摩诃萨行般若波罗蜜念心。作是思惟。此心无常而谓常住。于苦谓乐。无我谓我不净谓净。数动不住速疾转易。结使根本诸恶趣门。烦恼因缘坏灭善道。是不可信贪嗔痴主。一切法中心为上首。若善知心悉解众法。种种世间皆由心造。心不自见。若善若恶悉由心起。心性回转如旋火轮。易转如马能烧如火暴起如水。作如是观于念不动。不随心行。令心随己。若能伏心则伏众法。云何菩萨摩诃萨行般若波罗蜜念法。恶不善法能如实知。所谓贪欲嗔恚愚痴及余烦恼而修对治。贪欲对治。嗔恚对治。愚痴对治如是知已。即回起念不行彼法亦令他离。云何菩萨摩诃萨行般若波罗蜜于境起念。若见色声香味触作是思惟。云何于彼不真实法而生贪爱。此乃凡夫愚痴所著即是不善。如世尊说爱即生着着即迷惑。迷故不知善法恶法。以是因缘生于恶趣。菩萨摩诃萨。自不漏失不着境界令他亦尔。大王。菩萨摩诃萨行般若波罗蜜阿兰若念。作是思惟。阿兰若者。是无诤人之所住处寂静住处。于此处中。天龙夜叉他心智人。悉能知我心心数法。不应于此起邪思惟。即得舍离于法正忆勤修行之。大王。菩萨摩诃萨行般若波罗蜜作是思惟。城邑聚落非出家人所可行处则不应往。所谓酤酒淫女。王城博弈歌舞之处悉远离之。大王。菩萨摩诃萨行般若波罗蜜。闻利养名起正忆念作是思惟。为生施福故受此财。不由贪爱受。不出内生长子息。不言我财。一切贫穷普皆周给。如是行者人所赞叹。终不计我及以我所。复作是念。人皆称我惠施名闻。世间无常须臾磨灭。云何智人无常无实不恒无主。随彼而行起我我所大王。菩萨摩诃萨行般若波罗蜜。于佛世尊所说念戒作是思惟。过去诸佛皆学此戒。成无上道得至涅槃。当来诸佛现在亦尔。如是知已精进勤修。大王。菩萨摩诃萨行般若波罗蜜。为化众生及以自身。少欲知足着粪扫衣。心常清洁信力坚固。宁失身命于戒不犯。心离高慢游行城邑不耻弊衣。远离懈怠常修精进。所作未办终不中息。于粪扫衣不见过患。朽故弊坏终无轻鄙但取其德。夫离欲者乃服此衣。如来所赞息悭贪着。亦不自赞我能服此。于他不服终无毁言。如此行人诸天礼敬。佛所赞叹菩萨护持。婆罗门刹利皆悉礼敬。大王。菩萨摩诃萨行般若波罗蜜。如是修清净行。尔时胜天王白佛言。世尊。高行菩萨能行般若波罗蜜。何用着粪扫衣。佛告胜天王言。诸大菩萨将护世人。何以故。世间众生乐见不同。大王。于意云何。菩萨高行何如世尊。胜天王言。百千万亿恒河沙分算数譬喻不及其一。何以故。如来世尊。是大法王一切种智。无有一法而不照了。大王。于意云何。诸佛如来于四天下。天龙夜叉人非人中示现苦行。及以赞叹头陀功德此何所为。王言世尊。为欲教化可度众生。及初发意诸菩萨等。未断烦恼为说对治。佛言。如是如是。大王。高行菩萨着粪扫衣亦复如是。是故菩萨摩诃萨行般若波罗蜜。多有方便利益众生。大王。菩萨摩诃萨行般若波罗蜜。示现世间但畜三衣。何以故。心知足故更不多求即是少欲。不求索故无所积聚。既不积聚则无丧失。无丧失故则不生苦。苦不生故即离诸恼。离诸恼故则无所著。无所著故是为漏尽。大王。菩萨摩诃萨行般若波罗蜜。利益众生故。入城邑聚落持钵乞食。何以故。菩萨摩诃萨大悲熏心。如实观察贫苦众生。令得富乐受彼供养。若入邑聚威仪齐整心正不乱。善摄诸根前视六尺。双犁轭地如法乞食。次第而往不越贫家。以量受食终不长取。于所得中更开一分拟施供养。何以故。信施难销为生福故。大王。菩萨摩诃萨行般若波罗蜜。但一坐食而不移动。何以故。一坐道场魔来恼乱亦不移动。出世禅定般若阇那。空一切法如实圣道。实际如如一切种智。于此诸法悉不移动。何以故。萨婆若法是一坐得。是故行一坐食。大王。菩萨摩诃萨行般若波罗蜜。以方便力如是示现乞食。大王。菩萨摩诃萨行般若波罗蜜。学阿兰若行。所谓常修梵行。于诸根中不起过失。深乐多闻力堪修行离我怖畏。不计着身常行寂静。菩萨摩诃萨。正法中出家。持三轮净戒善知法相。如来所说为少壮老。三种人戒悉能了达。不随外缘自心思量。诃毁世法赞叹出世。调伏诸根不缘恶境。于阿兰若居无难处。聚落乞食不远不近。有清泉水盥洗便易林木华果。无恶禽兽岩穴寂静。空闲罕人而为居止。所曾闻法日夜三时勤加读诵。声不过高亦不太下。心不缘外一念诵持常在胸臆。若婆罗门刹利来至阿兰若处当唤令坐。彼或不肯殷勤加劝。观此众生随其根性即为说法。令得欢喜信受修行。如是具足善巧方便即离我心。以无我故于阿兰若不生怖畏。离怖畏故乐行寂静。菩萨摩诃萨。如是以方便力示阿兰若行。大王。菩萨摩诃萨行般若波罗蜜。善能观行作是思惟。世间之中一切饮食清净香洁。身火所触即成不净烂坏臭处。一切凡夫愚痴无智。爱着此身及以饮食。若依圣智如实观察。即生秽恶不可乐着。大王。菩萨摩诃萨行般若波罗蜜。作是思惟。多行嗔恚则起恶业。我今当离直心趣道。真实思惟非徒口说。大王。菩萨摩诃萨行般若波罗蜜作是思惟。若法有生即是因缘。法之因缘又从缘起。云何智人于此虚妄因缘生法而作罪失。菩萨身中有障善法即自断除。若不能断他障善法。心即生舍不起无明。云何名障善法。不恭敬佛法僧净戒不敬同学。老少幼小自高降彼。趣向五欲背舍涅槃。而起我见众生见命见人见。执空起断见执有起常见。远离贤圣亲近凡夫。舍持戒人依破禁者。亲附恶友远善知识。闻甚深法即生毁谤。威仪不整口无辩说。烦恼覆心具足谄曲。贪着利养生五种慢。一姓贵。二种族。三见胜。四国土。五徒众。见恶则助遇善而舍。赞叹女人童稚外道。不乐阿兰若行。不解节食不亲近师。虽复读诵不知时节。若见善法亦复不生少尊重心。见恶不怖如象无钩马无辔勒放逸不制。喜起嗔忿不生慈心。见苦不悲遇病不视于死不怖。在火聚中不求免出。应作不作不能量忖。难思而察非望而求。不出谓出非路谓路。未得谓得远大善法。毁呰大乘赞叹小道。毁大乘人赞彼小学。多乐斗乱恶口粗言。心无慈悲令他怖畏。出言粗鄙语无一实。乐着戏论而不舍离。大王。菩萨摩诃萨行般若波罗蜜。如是等事名障善法。大王。菩萨摩诃萨行般若波罗蜜。灭诸戏论修习空行。作是思惟。所观境界皆悉空无。能观之心亦复如是。无能所观二种之异。诸法一相所谓无相。如是思惟遣内外相。不见身不见心不见法。次第相续修奢摩他毗婆舍那。毗婆舍那如实见法。奢摩他者一心不乱。菩萨如是修观行已即得净戒。戒清净故行亦如是。是名菩萨摩诃萨行般若波罗蜜观行清净。大王。菩萨摩诃萨行般若波罗蜜。护持如来正法之藏听受正法。为守护故不为利养。为三宝种不断故不为恭敬。为拥护大乘行故不为名闻。为无归依众生令得济拔与安乐故。无慧眼者令得慧眼。修小乘人示声闻道。欲行大乘示现大道。如是听法为无上智。终不为得下劣之乘。大王。菩萨摩诃萨行般若波罗蜜善知毗尼。所谓毗尼及毗尼行。毗尼甚深毗尼微细。净与不净有失无失波罗提木叉。声闻毗尼菩萨毗尼。大王。菩萨摩诃萨行般若波罗蜜。如是等毗尼皆悉善知。大王。菩萨摩诃萨行般若波罗蜜。善知一切威仪戒行。善学声闻戒辟支佛戒菩萨戒。既修戒行。若见威仪不称众者。即应远离非处不行。若有沙门戒行威仪则应亲近。若婆罗门异学余行劝修毗尼。如是戒行修之真实。心无巧伪嫉妒即灭。自行布施亦劝他行赞叹布施。见他布施心生随喜。不作是念。唯当施我勿与他人。但应思惟。一切众生多有所乏饥寒困苦。愿其得财现世安乐。以闻法故后世安乐。我今应当精进修道。与诸众生同得出世。是名菩萨无嫉妒心。于诸众生皆得平等。若行布施普为众生。戒忍精进禅定般若。乃至一切种智。无二心修。何以故。所修之法与众生共念为境界令速成道。于生死火自既出离亦使他出。譬如长者而有六子。并皆幼稚爱念无偏。长者在外其宅火起。大王。于意云何。长者作念于此六子先后救不。不也世尊。何以故。其父于子心平等故。大王。菩萨摩诃萨行般若波罗蜜亦复如是。凡夫贪着处在六道。生死火宅不知出离。菩萨摩诃萨行般若波罗蜜。以平等心种种方便。诱化令出皆悉安置寂静界中。大王。菩萨摩诃萨行般若波罗蜜于法亦等。所谓以法供养如来。种种供具供养如来。如实修行供养如来。利益安乐一切众生。守护一切众生善法。随顺众生善能教化。行菩萨道行不违言。心无疲倦求阿耨多罗三藐三菩提。若能如是乃得名为供养诸佛。不以资生而为供养。何以故。大王。法是佛身。若供养法即供养佛。大王。诸佛世尊。皆从如实修行而来。悉为利益安乐众生。护其善法随顺众生。若不尔者违本誓愿。懈怠懒惰不能成就菩提之心。何以故。菩萨摩诃萨。阿耨多罗三藐三菩提与众生共。若无众生菩萨云何能得菩提。大王。菩萨摩诃萨行般若波罗蜜。以法供养如来名真供养如是供养拔除我慢。远离俗务剃落须发于其父母兄弟亲戚。不复相关犹如已死。形状衣服相貌异常。执持钵器游入城郭。至其亲里若旃陀罗家。下意乞食作是思念。我命属他由彼食活。以是因缘能除我慢。复作念言。我今应取师僧尊长。及同学意令彼欢喜。昔未闻法为得闻故。若见他人嗔恚斗诤。即应忍辱下意避之。大王。菩萨摩诃萨。如是行般若波罗蜜拔除我慢。大王。菩萨摩诃萨行般若波罗蜜生坚正信。何以故。多诸功德宿世所种。善根力强具足善因。正见成就不信外道。内心清净不依余师。心行调直远离谄曲。诸根聪利具足般若。离诸盖障其心清净。远恶知识亲近善友。寻求善言不生懈怠。所闻说法知佛功德。胜天王白佛言。世尊。唯愿大慈。哀愍为说如来功德大威神力。佛告胜天王言。大王。谛听谛听。善思念之。我当为王宣说如来神德少分。善哉世尊。唯然愿闻。佛言大王。如来具足无边大慈遍照众生。众生所摄乃至十方尽虚空界。亦皆遍照不可测量。如来大悲声闻缘觉菩萨所无。何以故。不共法故。十方世界无一众生大悲不照。复次如来说法无尽。普为十方一切众生。一劫百劫千劫若无量劫。种种因缘说法无尽。若众生界种种言辞。一切句义咨问如来。一弹指顷一一众生。各为分别无能坏者。复次如来即是无碍禅定境界。假使一切世界众生。皆住十地入诸三昧百千亿劫。观如来定不能测量。复次如来身无边量。何以故。随所乐见能于一念示现种种如来。又有清净天眼。一切世界无量众生。一一众生一一世界。如是一切世界中事。如来悉见如观掌中阿摩勒果。诸天人眼所不能见。如来复有清净天耳。一切众生随其种类音声不同。如来悉闻解了其义。如来复有净他心智。一切世界有诸众生。作业思想若所得报。如来世尊行立坐卧。于一念顷皆悉了知。何以故。如来常定无散乱故。大王。诸佛如来无有失念。心不散乱根无异缘。何以故。离烦恼习最为清净寂静无垢。有烦恼者其心散乱则异攀缘。如来世尊无漏离垢。得一切法自在平等。常在三昧三摩跋提故。大王。如来以一威仪三昧游行乃至涅槃。无有天人能得知者。况复如来于无量劫修习无量无边万亿三昧。何以故。如来不可量不可思不可观故。尔时胜天王白佛言。世尊。我闻如来三阿僧祇劫修行成佛。云何而说无量劫修。佛言。不也大王。何以故。菩萨摩诃萨。修阿耨多罗三藐三菩提。无量功力之所能办。非尔许劫时始得入法平等理称为成佛。胜天王白佛言。世尊。善哉善哉。一切众生常行诸善远离障业。喜乐佛果修菩萨行。世尊。若有众生得闻如来大神通力。心生欢喜信受赞叹。当知是人不久得成此神通器。况复有人受持读诵书写宣说。如是人等不可思量。佛言。如是大王。此等众生如来拥护已种善根。过去供养无数诸佛。乃能得闻如来世尊大神通力。是善男女心不疑惑。于七日中澡浴清净着新洁衣。香华供养一心正忆。尔时如来即为现身便得见佛。其供养具或有阙少但一心念。于命将尽见佛在前。胜天王白佛言。世尊。颇有众生闻说如来神通功德。不起信心而谤毁不。佛言。有是众生。若闻如来神通法门。即起嗔毒不善之心。于说法师恶知识想。此人舍寿生泥梨中。若闻如来大神通力能生信受。于说法师善知识想。即得人天乃至成佛。尔时世尊。出广长舌相自覆面门。次至头顶次覆遍身次覆师子座。次覆菩萨众次覆声闻众。然后乃覆释梵护世一切大众还收舌相。告大众言。如来世尊有是舌相岂当妄语。汝等大众皆应信受长夜安乐。说是法时众中八万四千菩萨得无生法忍。无量百千众生。得远尘离垢法眼净。无量无边众生。发阿耨多罗三藐三菩提心

胜天王般若波罗蜜经卷第二胜天王般若波罗蜜经卷第三

        陈优禅尼国王子月婆首那译

    法性品第五

尔时胜天王。即从坐起偏袒右肩右膝着地。合掌向佛头面作礼。而白佛言。希有世尊。如来应供正遍知。快说微妙大神通力。诸佛如来因何得此。唯愿世尊分别解说。佛告胜天王言。大王。诸佛如来所行甚深不可思议。得果亦尔。胜天王白佛言。世尊。诸佛如来行何等法。名为甚深不可思议。佛告胜天王言。大王。诸佛如来法性因果不可思议。功德及法利益众生亦复如是。胜天王白佛言。世尊。云何法性不可思议。佛言大王。在诸众生阴界入中无始相续。所不能染法性体净。一切心识不能缘起。诸余觉观不能分别。邪念思惟亦不能缘。法离邪念无明不起。是故不从十二缘生。名为无相。则非作法。无生无灭无边无尽自相常住。大王。菩萨摩诃萨行般若波罗蜜。能知法性清净。如是无染无著远离垢秽。从诸烦恼超得解脱。此性即是诸佛法本。功德智慧因之而生。体性明净不可思量。大王。我今喻说汝善谛听。王言世尊。唯然愿闻。佛告胜天王言。譬如无价如意宝珠。装饰莹治皎洁可爱。体圆极净无有垢浊。堕在淤泥已经多时有人捡得取而守护不令堕落。法性亦尔。虽在烦恼不为所染后复显现。大王。诸佛如来悉知众生自性清净。客尘烦恼之所覆蔽不入自性。是故菩萨摩诃萨行般若波罗蜜。应作是念。我当勇猛勤修精进。为诸众生说是甚深般若波罗蜜除其烦恼。一切众生皆有性净。是故于彼勿生下劣应当尊重。彼即我师如法恭敬。菩萨摩诃萨。作如是心即生般若阇那大悲。大王。菩萨摩诃萨。如是行般若波罗蜜。能入阿鞞跋致地。大王。菩萨摩诃萨行般若波罗蜜复作是念。此诸烦恼无力无能。自体虚妄与净相违。何以故。背萨婆若故。清净法性为诸法本。自性无本虚妄烦恼皆从邪念颠倒而生。大王。譬如四大依虚空立空更无依。烦恼亦尔。依此法性法性无依。大王。菩萨摩诃萨行般若波罗蜜。如实观知不起违逆。以随顺故烦恼不生。大王。菩萨摩诃萨。观察烦恼不生染着。若自染着云何说法令他出离。是故菩萨断灭着心。如实说教解众生缚。菩萨摩诃萨行般若波罗蜜复作是念。若生死中有一烦恼。利益众生我则摄受。菩萨摩诃萨行般若波罗蜜复作是念。如昔诸佛行般若波罗蜜应如是行。何以故。诸佛如来昔在因地亦如是学。成菩提故以此二缘。是故菩萨种种方便知此法性。大王。如是法性无量无边。为诸烦恼之所隐覆。随生死流沉没六道长夜轮转随众生故名众生性。菩萨摩诃萨行般若波罗蜜。起厌离心除五尘欲修无上道。是时此性名为出离。过一切苦故名寂静为究竟法。一切世间之所乐求。一切种智常住微妙。因此法性能得自在受法王位。大王。菩萨摩诃萨行般若波罗蜜。初中上位观察法性。一切平等本来寂静悉无挂碍。犹如众色不能满空。菩萨摩诃萨行般若波罗蜜。如实而知诸佛所说一切众行如量修行。法性功德不可具说。无有二相过一异境。平等一相觉观不行。菩萨摩诃萨如是行般若波罗蜜。能除二相人相法相一切凡夫为执所缚。不识不见不得法性。菩萨摩诃萨行般若波罗蜜。则能通达如此法性。若在众生无二无别。何以故。如如不异故。大王。菩萨摩诃萨行般若波罗蜜。依此法性修诸善根。来入三有利益众生。虽现无常而非真实。何以故。菩萨摩诃萨行般若波罗蜜。如实见法性故。具足方便大悲愿力不舍众生。二乘凡夫无有如此大悲本愿。是故不见圆净法性。大王。菩萨摩诃萨行般若波罗蜜如是观法性一切圣人无能修者无所修法。无能行者无所行法。无心无心法无业无果报无苦无乐。如是观者名得平等。不异远离随顺广大。无我我所无高无下。真实无尽常住明净。何以故。一切圣法由此成就。因是性故显现圣人。大王。诸佛如来无边功德不共之法。从此性生由是性出。大王。一切圣人戒定慧品从此性生。诸佛菩萨般若波罗蜜从此性出。是性寂静过诸名相。性是真实则离颠倒。性不变异故称为如圣智境界名第一义。非有非无非常非断。非生死非涅槃非染非净。离一离异无名无相。大王。菩萨摩诃萨行般若波罗蜜。复作是念。法性离相。一切法离相无二无别。何以故。一切法离相即法性离相。法性离相一切众生离相同法界离相。法界离相一切法离相。如是离相求不可得。法性如如众生如如同一无二。众生如如法性如如同一无二。法性如如一切法如如无二无别。一切法如如诸佛如如无二无别。法性如如过去未来现在如如不相违逆。过去如如未来如如亦不相违。过去未来现在如如即是阴界入如如。阴界入如如即是染净如如。染净如如即是生死涅槃如如。生死涅槃如如即是一切法如如。大王。所言如者名为不异。无变不生无诤真实。以无诤故说名如如。如实知见诸法不生。诸法虽生如如不动。如如虽生一切诸法如如不生。是名法身清净不变犹如虚空无等等。一切三界无有一法所能及者。遍众生身无与似者。清净离垢本来不染。自性明净自性不生自性不起。在心意识非心意识性。即是空无相无愿。遍虚空界诸众生处。一切平等无边无量不异不别。非色不离色。非受想行识不离受想行识。非地大水火风大。不离地大水火风大。无生离生。虽逆生死不顺涅槃眼不能见耳不能闻。鼻不能嗅舌不能尝。身不能觉意不能知。不在心意识不离心意识。大王。是名法性。菩萨摩诃萨行般若波罗蜜。通达此法修行清净。三千大千世界若阎浮提城邑聚落。菩萨悉能示现色身。所现身者。非色非相而现色相非六根境。而化众生常无休息。为说此身无常无我苦不净法。了知众生有寂静性。能为示现无量种身。善巧方便令彼受化知一切身。无有作者亦无受者犹如木石。而为众生说清净行。大王。菩萨摩诃萨如是行般若波罗蜜。通达法性即得自在。无有移动而起智业。游戏神通种种示现安住自在。而能示现种种威仪。自在能趣一切种智。皆悉通达一切诸法。大王。般若波罗蜜如是自在。是无尽相遍一切处。无色现色自在遍观诸众生心。见如实心性自在忆念。无边数劫相续不断。自在变化住解脱相。自在尽漏为众生故不证漏尽自在出世。是圣智境自在甚深。声闻缘觉所不能测。自在坚牢魔不能坏。能至道场成就佛法最为第一。自在随顺转大法轮。自在调化一切众生。自在受位得法自在。大王。菩萨摩诃萨行般若波罗蜜如实通达甚深法性得是自在。菩萨摩诃萨。修是自在即得诸禅解脱三昧三摩跋提。不系欲界色无色界。何以故。远离一切虚妄分别。烦恼系缚。颠倒执相。若其受生于生自在无有系缚。若欲现灭亦复自在。随其生处恒摄大乘成就佛法。而于十方推求佛法竟不可得。一切诸法同一佛法非常非断。何以故。推求此法不可得故。以如实理求不可得。是法不可说有说无说亦无名相。过此境界若离名相即是平等。若法平等即无执着。无可著者是法真实。若着真实即是虚妄。以不着故即非虚妄。无所滞着心即无碍。无碍即无障无障即无诤无诤即同虚空。是法不系欲界不系色界不系无色界。若一切处无所系属。是法无色无相无形。若法无色无相无形。是法应如是知。随彼境界而离能知亦离所知。何以故是中无有少法可觉少法能觉。是名菩萨摩诃萨行般若波罗蜜通达平等。大王。菩萨摩诃萨行般若波罗蜜。观大慈大悲大喜大舍。不见我不见众生。不见命不见人。虽行布施而调伏心离戒相心而净持戒。以无尽心修行忍辱。离心精进。以寂静心修习禅定。心无所缘修行般若心念四处。以平等心修习正勤。离戏论心修诸神足。分别众生观察诸根。离愆失心修诸根力。以分别心观察觉分。无功用心修习正道。心无所著而有净信。自然智慧忆念诸法。平等智心修诸三昧。不分别心观般若波罗蜜。以止息心修奢摩他。无所见心修毗婆舍那。无所念心而修念佛。通达法界平等之心而修念法。无所住心而修念僧本心清净。教化众生。不起分别法界之心摄一切法。如虚空心净佛国土。无所得心得无生法忍。无进退心得阿鞞跋致。远离相心不见有相。三界平等心庄严道场。心能觉知一切诸法。转于法轮不见听说示现涅槃而知生死本性平等。大王。菩萨摩诃萨行般若波罗蜜。如是观诸法不见能观不见所观。即时能得游戏自在。何以故。自心清净能见一切众生净故。大王。譬如虚空遍满一切。菩萨摩诃萨行般若波罗蜜心亦如是。说此法时。众中八万四千人天发阿耨多罗三藐三菩提心。三万二千菩萨得无生法忍。八万四千众生得远尘离垢法眼净。一万二千比丘皆得漏尽。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜。心得清净深大如海。功德智慧不可测量。菩萨摩诃萨能现出世。诸功德宝众生用之。乃至菩提无有尽竭。菩萨功德亦复不灭。犹如大海多出众宝。菩萨智慧甚深难入。声闻缘觉无能涉者。亦如大海小兽不入。菩萨智慧广大无边。何以故。无著无住无色无相。菩萨智慧从初至后次第转深。初菩提心后萨婆若菩萨法尔。不与烦恼及恶知识而共止住。世间智慧若入菩萨智慧之中一相一味。所谓无相萨婆若无分别味。菩萨摩诃萨观一切法。不见法增不见法减。何以故。通达平等深法性故。菩萨摩诃萨。大慈悲力不违本愿。一切圣人之所依处。为诸众生永劫说法无有穷尽。大王。菩萨摩诃萨行般若波罗蜜。通达如是甚深法性。大王。菩萨摩诃萨。善能通达世谛众法。虽说诸色而非实有。推求此色终不取着。受想行识亦复如是。虽说地大而非真实。推求地大终不取着。水火风空识亦复如是。虽说眼入而非真实。推求眼入终不取着。耳鼻舌身意亦复如是。虽复说我而非真实。推求觅我终不取着。众生命养育人。作者寿者。知者见者。亦复如是。虽说世间而非真实。推求世间终不取着。虽说世法而非真实。推求世法终不取着。虽说佛法而非真实。推求佛法终不取着。虽说菩提而非真实。推求菩提终不取着。大王。凡有言说名为世谛此非真实。若无世谛第一义谛则不可说。菩萨摩诃萨行般若波罗蜜。通达世谛不违第一义谛。即通达之。知法无生无灭无坏无此无彼。悉离语言文字戏论。大王。第一义者离言寂静。圣智境界无变坏法。若佛出世若不出世性相常住。是名菩萨通达第一义谛。尔时胜天王白佛言。世尊。若一切诸法不生不灭自性空离。云何有佛出世及转法轮。云何菩萨于无生法而见有生。佛告胜天王言。大王。法不灭故不生。何以故。性不变异故。但以世谛因缘见有生灭。皆是虚妄非真实有。菩萨摩诃萨行般若波罗蜜。善巧方便见因缘法。即知世谛悉空无有不见坚实。似有如影。如炎响幻。不安摇动从因缘生。菩萨摩诃萨以般若波罗蜜。观诸法空乃至从因缘生。作是思惟。此等诸法今见有生有住有灭。何因缘生何因缘灭。即作是知。无明因缘故生诸行。依行生识。识生名色。名色生六入。六入生触。触生受故。凡夫起爱。渴爱生取。以因取故则相续有。由有故生。生则有老。老故有死忧悲苦恼。是故修行为断无明。无明若断余十一分则亦复灭。譬如人身若断命根余根靡用。大王。邪见外道为求解脱。但欲断死不知断生。若法不生则无有灭。譬如有人块掷师子。师子逐人而块自息。菩萨亦尔。但断其生而死自灭。犬唯逐块不知逐人块终不息。外道亦尔不知断生终不离死。大王。菩萨摩诃萨如是行般若波罗蜜。善知因缘诸法生灭。大王。菩萨摩诃萨行般若波罗蜜。知缘生法空无实有不起我慢。若生婆罗门刹利居士长者之家。不起二慢尊贵豪富。若生贫贱自知宿业不甚清净得报下劣。心起厌离即求出家。作是思惟。如我此身杂业所得。更修净业令自清净使他亦尔。自既求度亦复度他。自求脱离亦解他缚。以是因缘即生精进不堕懈怠。障道恶法皆为断除。助道善法悉应增长勤修精进。作是思惟我负重担。应当自灭一切烦恼。度脱众生不得懈怠。菩萨摩诃萨行般若波罗蜜。亲近师僧多闻寡闻有知无知持戒破戒。但生佛想恭敬同学思惟我今依师学习。修善未满悉令满足。烦恼未尽断之令尽。拥护善法舍离不善。一切种智怜愍世间。大悲福田寂静天人师。是我大师善得吉利。一切天人皆事法王以为大师。菩萨摩诃萨行般若波罗蜜作是思惟。佛说净戒。设为身命亦不毁犯。如世尊说随顺佛教即供养佛。若婆罗门刹利居士长者。种种饮食信心施与。如法受用不令彼人空失果报。食者施者俱得利益。婆罗门刹利居士长者。以沙门名而召菩萨作福田想。菩萨应当如理如量修行正法。即令显现沙门功德福田功德。菩萨如是自行化他不曾休废。菩萨摩诃萨行般若波罗蜜。如是修行则能随顺一切世间。见嗔恚者生下劣心。见高慢人起无我想。见邪曲人起正直想。见妄语人起如实言。于恶口人常说爱语。见刚强者示现柔和。见惨毒人则行慈忍。见邪法人则生大慈。见苦众生则起大悲。见悭嫉人则行布施。大王。菩萨摩诃萨行般若波罗蜜。如是随顺世智生净佛国。何以故。持戒无缺离诸杂秽。修平等心。于众生所具大善根不著名利。清净之信无所望报。勤行精进不生懈怠。修诸禅定离散乱法。以微妙慧而习多闻。诸根不缺具足利智。常修大慈远离嗔恼。以是因缘生净佛国。尔时胜天王白佛言。世尊。如佛所说。修戒等法生佛国土。为修行一行亦生。佛告胜天王言。大王。若有菩萨摩诃萨于前所说种种法中。净修一行即修众法。如是一行得生净土。何以故。一一行中具众行故。大王。菩萨摩诃萨行般若波罗蜜如是行生净土不为胎污。何以故。菩萨摩诃萨。造作佛像修葺伽蓝。如来塔前香泥涂地烧香供养。或以香汤浴洗佛像。于伽蓝内扫洒泥涂。菩萨摩诃萨。供养瞻省父母之身师僧同学及诸沙门。以平等心皆悉供养。回此善根为一切众生。回向阿耨多罗三藐三菩提令得清净。菩萨摩诃萨如是行般若波罗蜜即得离俗。何以故。心无取着不染朋党背诸境界。远离爱缘境界不染。世尊说戒如实修行。少欲知足随宜四事。趣足过时心常怖畏乐寂静离。大王。如是菩萨摩诃萨行般若波罗蜜。不着俗法即得净命。无伪威仪口意欺诈。于施主前终不诈伪现身威仪。安祥徐步视前六尺。若背檀越即便纵诞。于施主前不为利养下声细语软美之言顺彼意语。若背檀越则便自纵。见他行施口言不用心实欲须如是名为内心热恼。口现少欲心贪利养。大王。菩萨摩诃萨行般若波罗蜜。悉无此伪离求利相。若见檀越不得发言。三衣弊坏钵器阙无或须汤药。于施主前不得发言。某甲檀越施我此物。彼人谓我持戒多闻大悲心净。虽尔赞叹我无此德。唯当修行报施主恩。菩萨摩诃萨。不应如是自赞毁他。随顺白衣而求利养。若施余人勿生嗔恼。不作谄曲而以取财。不诈亲善害他取物。不为他人戏弄取财。檀越拟施或赞叹人。若说法者或拟大众。或复未拟或施未决。菩萨不得入中取分。若受施财不应执着。此是我有此是我物。即当回施沙门师僧父母。及余贫乏平等受用。若财物尽不以生忧。少日不得心无苦恼。大王。菩萨摩诃萨。受施回与二俱清净。行清净故心不疲劳。何以故。菩萨摩诃萨行般若波罗蜜。为利众生久处生死而不厌患。若有魔事众苦逼切心无退转。若人欲行二乘之道。即为说法不惮疲劳。菩萨自修助菩提法无有厌倦。大王。菩萨摩诃萨行般若波罗蜜。如是精进则能随顺佛正教行。何以故。菩萨摩诃萨行般若波罗蜜。离诸放逸心常谨慎。善摄自身不作诸恶不善之法。口意亦尔。菩萨摩诃萨行般若波罗蜜。虽处现在恒惧未来一切诸恶不善之法断之不生。言必附理常说法教。非法不言悉弃秽业。纯修净行不毁佛教。远离烦恼不净之法。是名拥护如来正教。一切诸恶不善之法悉断离之。大王。菩萨摩诃萨行般若波罗蜜。如是随顺佛清净教。视诸众生面门先笑曾无嚬蹙。所以然者。心离秽浊诸根清净不染离垢。心不嗔恚内无恨结。菩萨摩诃萨。如是行般若波罗蜜即得多闻。观察生死能如实知。欲火炽然嗔火焚烧。愚痴之火常所迷乱。亦如实知有为无常。一切行苦诸法无我。世间众生耽着戏论。一切法中唯有涅槃乃为寂静。若闻他说即思惟义。传以授人。发大慈悲起坚固意。若不闻法则无思修。是故闻慧犹如字本。一切智慧因之而生。既得多闻则护正法。大王。未来末世正法灭时。其有众生乐勤修行。不值法炬无人为说甚深之法。尔时菩萨。即为演畅甚深妙法。所谓般若波罗蜜。令诸众生得戒定慧。又赞之言。善男子。如是末世正法灭时。汝等能发菩萨之心。求阿耨多罗三藐三菩提利益众生。此般若波罗蜜。三世诸佛之所行者。汝若勤修。则去阿耨多罗三藐三菩提不远。何以故。般若波罗蜜不离菩提。譬如有人种谷已秀。当知收获必在不久。菩萨亦尔。求阿耨多罗三藐三菩提。得闻般若波罗蜜。当知决定去佛不远。大王。若善男子善女人。舍离般若波罗蜜。更依余法求阿耨多罗三藐三菩提无有是处。犹如王子舍其父王。更就余人求为太子决不可得。菩萨亦尔。求萨婆若必因般若波罗蜜得。譬如犊子若欲须乳必依其母。若就余牛则不可得。大王。菩萨摩诃萨。亲近般若波罗蜜。常为法王子相庄严身。以好为华严饰身相诸根不缺。如来行处常所游行。所行之道随佛如来所觉而觉。救护世间苦恼众生。善能通达佛所说教。常修梵行守护如来萨婆若城。大王。菩萨摩诃萨行般若波罗蜜。为法王子。释梵护世之所尊重。何以故。行菩萨道阿鞞跋致。一切诸魔所不能动。安住佛法通达一切空平等理不信外缘。如是安住佛法智慧。不与声闻辟支佛共。超过世间住无生法忍。大王。菩萨摩诃萨行般若波罗蜜。能如实知一切众生心贪欲嗔痴上中下品。亦如实知善心坚固心。如实知已。各各为说诸对治法。如是则能善化众生。菩萨摩诃萨行般若波罗蜜。若有众生应见佛身受化度者。菩萨摩诃萨即现佛身而为说法。应以菩萨身化度者现菩萨身。应以辟支佛身而受化者即现辟支佛身。应以声闻身受教化者。即现声闻身。应以帝释梵王婆罗门刹利长者居士身受教化者。皆为示现而度脱之。大王。菩萨摩诃萨如是行般若波罗蜜教化众生。菩萨摩诃萨行般若波罗蜜。心性慈和正直软善。无诸谄曲嫉妒垢秽心常清净。言语不粗远离恶口。多行忍辱亲狎众生。大王。菩萨摩诃萨如是行般若波罗蜜则在处安乐。所以然者。具足正见及清净见。清净之行所行境界与心相应。若心相违恶不善法。如是境界及染秽处斯则不行。菩萨摩诃萨行般若波罗蜜。见同学人心生欢喜。若财若法与他共用。唯行一道。所谓佛道。唯佛为师不尊余人。大王。菩萨摩诃萨行般若波罗蜜如是在处安乐。具诸摄法而摄众生。以利益施安乐施无尽施摄取众生。利益语有义语如法语不异语摄取众生。以财利益平等。身利益平等。命利益平等。资具利益平等。摄取众生。大王。利益施者即是法施。安乐施者即资生施。无尽施者即示现道。利益语者令彼生善。有义语者令彼见理。如法语者随顺佛教。不异语者说如实法。财利益平等者。可食可啖可饮可嗽可舐及衣服等。身利益平等者。如以摄卫利益己身令他亦尔。命利益平等者。真珠琉璃珊瑚玛瑙多为外命。资具利益平等者。象马车乘一切净财。菩萨摩诃萨行般若波罗蜜。自行与他皆悉共同。大王。菩萨摩诃萨行般若波罗蜜。受生端正。常能修习寂静威仪。不伪威仪。清净威仪。人所乐见内外温善。观者无厌能悦人意。一切众生之所爱重。其有见者皆发善心。嗔恚者见心即得解。大王。菩萨摩诃萨行般若波罗蜜。如是端正则堪依止。守护众生令烦恼灭。能将众生出离生死无边旷野。能度众生世间险难。为无眷属而作亲友。为烦恼疾而作良医。无救护者为之救护。无归依者为作归依。无明众生为作法炬。菩萨摩诃萨行般若波罗蜜。为诸众生而作依止。治诸疾病如药树王。譬如善见大树。根茎枝叶华果色香味触。悉为众生疗治众病。大王。菩萨摩诃萨行般若波罗蜜亦复如是。从初发心为诸众生治种种疾诸烦恼病。菩萨摩诃萨功德智慧。有疾病者见闻皆差。菩萨摩诃萨行般若波罗蜜。常与功德相应。随力所堪供养三宝。若有疾病即施汤药若见饥渴即施食饮。若见寒冻即施衣服。师僧和上尽心承奉。同学法人合掌恭敬。造立伽蓝布施田园。时时随有舍与众僧下使隶役如法料理。闻有名德沙门婆罗门修道行者时时往诣。大王。菩萨摩诃萨行般若波罗蜜能生诸善。有巧方便教化众生。于此佛国身不移动。而游无量诸佛世界咨问正法。于此佛国身不移动。而游无量诸佛世界听受正法。于此佛土身不移动。示现无量诸佛国土供养如来。于此佛土身不移动。而游无量诸佛世界。成就无上菩提资粮。于此佛土身不移动而游无量诸佛世界。若有菩萨成佛道者供养恭敬于此佛土身不移动。无量世界示现成道。于此佛土身不移动。无量佛国现转法轮。于此佛土身不动移。无量佛国示现涅槃于此佛土身不移动。无量佛国应得度者。为示化身皆悉令见。亦无分别有所作意。尔时胜天王白佛言。世尊。云何菩萨摩诃萨。作种种化无分别心。佛告胜天王言。大王。譬如日月照四天下而无分别。我照天下为作光明。众生业报自感日月光照天下。菩萨摩诃萨行般若波罗蜜亦复如是。虽现化身而无分别。何以故。众生各有宿世善业。菩萨摩诃萨。昔从因地修行发愿为度众生。以此愿力随其所念。皆悉应现无分别心。大王。菩萨摩诃萨行般若波罗蜜。如是方便善巧教化。速向阿耨多罗三藐三菩提。何以故。菩萨摩诃萨。行檀具足持戒清净。无穿缺杂戒聚清净。过诸声闻辟支佛境。具足忍辱精进禅定般若方便愿力智。如来世尊不共功德。一切具足已过声闻辟支佛地。大王。菩萨初地乃至十地。行般若波罗蜜。修如是行得阿耨多罗三藐三菩提。说是法门时。众中二万天子得远尘离垢法眼净。三万菩萨摩诃萨得无生法忍。八万四千天人发阿耨多罗三藐三菩提心。无量百千亿乾闼婆紧那罗皆悉合掌。赞叹如来绕耆阇崛山。无量百千亿夜叉众。雨诸莲华绕耆阇崛山。十方无量恒河沙世界菩萨。来集赞叹如来世尊快说甚深般若波罗蜜为诸菩萨。世尊。因此般若波罗蜜。得有人天。须陀洹向须陀洹果。乃至阿罗汉向阿罗汉果。辟支佛道。菩萨十地。十波罗蜜。如来十力。四无所畏。十八不共法。一切种智。皆从般若波罗蜜中出。世尊。譬如世间一切众生悉依虚空而空无依。般若波罗蜜亦复如是。一切法本而自无依。愿令我等于未来世。为诸菩萨摩诃萨说般若波罗蜜如今佛说。又以种种香华散如来上。尔时耆阇崛山天神及余集者空中赞言。我等忆念过去之世。无量诸佛于此耆阇崛山中。说是般若波罗蜜法亦如今日。尔时胜天王白佛言。世尊。空中诸天云何得知。如来境界久远世。佛说是般若波罗蜜事。佛言。大王。此诸天等皆住不可思议解脱。是故能知过去远事。大王。我昔为菩萨时。亦经生彼天神之道。见无量佛成道说法乃至涅槃。我常赞叹合掌礼拜。何以故。彼天神道寿命长故。尔时众中有一天子。名曰光德。即从坐起偏袒右肩右膝着地。合掌向佛头面作礼。白佛言。世尊。诸佛菩萨应游净土。娑婆世界是不清净。云何世尊出现此土。尔时佛告光德天子。诸佛如来所居之处无有秽土。于是世尊。即以神力现此三千大千世界。地平如掌琉璃所成。无诸山陵堆阜荆蕀。处处宝聚香华软草。流泉浴池八功德水。七宝阶砌树木华果。咸说菩萨不退法轮。无有凡夫。唯见十方诸大菩萨。不闻余音。唯闻般若波罗蜜声。处处莲华大如车轮青红赤白。一一华中。皆有菩萨结加趺坐。即见如来于大众中。为诸菩萨说甚深法。无量百千释梵护世。前后围绕。供养恭敬尊重赞叹。希有世尊。希有世尊。所说无虚真实不二。如世尊说诸佛住处实无秽土。众生薄福而见不净。世尊。若有善男子善女人。得闻般若波罗蜜名字甚为希有。况复书写受持读诵为他演说。佛言。若善男子善女人。无量百千劫。以无碍心施他财物。若复有人以净信心。书写此经传受与人。功德多彼。何以故。财施有竭。法施无尽。何以故。施财但能得世间果。若人若天昔已曾得。得已堕落今还复得。若以法施昔来未得。今始能得所谓涅槃。若三千大千世界一切众生。有人教化悉令安住十善道中。若善男子善女人。以净信心受持读诵般若波罗蜜为他人说。功德胜彼。何以故。一切善法皆从般若波罗蜜生故。若三千大千世界一切众生。有人教化。皆得须陀洹斯陀含阿那含阿罗汉果辟支佛道。若复有人信心受持读诵书写般若波罗蜜功德胜彼。何以故。声闻辟支佛法。皆从般若波罗蜜中生。一切菩萨摩诃萨法。皆从般若波罗蜜中生。因此般若波罗蜜故有佛出世。般若波罗蜜所在之处。当知即是菩提道场转法轮处。应念此处即我大师。如来应供正遍知处在此中。何以故。一切诸佛皆从般若波罗蜜生故。若人供养如来形像。不如供养般若波罗蜜。何以故。三世诸佛。皆因般若波罗蜜生故

胜天王般若波罗蜜经卷第三胜天王般若波罗蜜经卷第四

        陈优禅尼国王子月婆首那译

    平等品第六

尔时胜天王。即从坐起偏袒右肩右膝着地。向佛合掌头面作礼而白佛言。世尊。如佛所说法性平等。何者是平等。等何法故名为平等。佛告胜天王言。大王。等观诸法不生不灭。自性寂静名为平等。一切烦恼虚妄分别。不生不灭自性寂静名为平等。名相妄想不生不灭。自性寂静名为平等。灭诸颠倒不起攀缘名为平等。能缘心灭无明有爱即皆寂静。痴爱灭故不起我我所名为平等。我我所灭名色寂静名为平等。名色灭故边见不生名为平等。灭断常故身见寂静名为平等。大王。能取所取一切烦恼障善法者依身见生。菩萨摩诃萨能灭身见。一切诸使皆悉寂静作愿亦息。譬如大树拔除根株枝条枯死。如人无首命根即绝。一切烦恼亦复如是。若断身见余使自灭。大王。若人能观诸法无我。则取可取皆悉寂静。胜天王白佛言。世尊。云何生我见障真实理。佛告胜天王言。大王。于五阴身妄执有我即生我见。真实之法自性平等。无能所执我见相违是故为障。大王。如是我见不在内不在外不在内外。若无所住名为寂静。即是平等。远离我见通达平等。名真实空观。空无相无愿自性寂静。不生不灭不取不着。远离我见名为平等。大王。所言我者无来无去。无有真实虚妄分别。法从妄有亦是虚妄。菩萨摩诃萨行般若波罗蜜。观如是法远离虚妄。是故名为寂静平等。大王。能取可取则名为燃离名寂静。惑障为燃离为寂静。菩萨摩诃萨善巧方便行般若波罗蜜。能如实知诸烦恼灭。为增善法断除烦恼。不见可生不见可灭名为平等。修波罗蜜远离魔障。不见可修不见可离名为平等。菩萨常缘助菩提法。不起声闻辟支佛心。于助菩提声闻缘觉不见异相名为平等。缘萨婆若心不休息常修空行。以大悲力不舍众生名为平等。大王。菩萨摩诃萨具足方便行般若波罗蜜。即得心缘自在。心缘无相而修菩提。不见无相及菩提异名为平等。心缘无愿不舍三界。不见无愿及三界异名为平等。观身不净心住清净。观行无常心住生死而不厌离观众生苦住涅槃乐。观法无我于诸众生起大悲心。常为众生说不净药不见贪病。常说大慈不见嗔忿。常说因缘不见愚痴等集病者。说无常乐不见等病及无常异。如是菩萨摩诃萨。以方便力行般若波罗蜜。于一切法心缘自在。缘离欲法为化声闻。缘离嗔法化辟支佛。缘离痴法为化菩萨。缘一切色愿得佛色无所得故。心缘众声愿得如来微妙音声。心缘众香愿得如来清净戒香。心缘诸味愿得如来味中第一大丈夫相。心缘诸触愿得如来柔软手掌。心缘诸法愿得如来寂静之心。心缘布施为得成就相好之身。心缘尸罗为得清净佛之国土。心缘忍辱愿得如来大梵音声净光明身。心缘精进为度众生。心缘禅定为得成就诸大神通。心缘般若为断一切诸见烦恼。心缘大慈平等无碍令诸众生皆得安乐。心缘大悲为护正法。心缘大喜为得说法悦乐众生。心缘大舍不见众生烦恼结使。大王。菩萨摩诃萨。以方便力行般若波罗蜜。不见二事名平等行。心缘四摄为教化众生。缘嫉妒过为舍资财。缘破戒失为住净戒。缘嗔恚失为得忍辱。缘懒惰失为成佛力。缘散乱失为得如来寂静禅定。缘粗智失为成如来无碍智慧。心缘声闻及辟支佛为欲成就无上大乘。心缘恶趣为欲济拔一切众生。心缘诸天知一切法悉有败坏。缘诸众生知无坚实。心缘念佛为得成就禅定助道。心缘念法为得通达诸秘密藏。心缘念僧为得不退。心缘念舍为无爱着。心缘念戒为得净戒。心缘念天为成佛道诸天赞叹。心缘自身为得佛身。心缘自口为得佛口。心缘自意为得如来平等之心。心缘有为为成佛智。心缘无为为得寂静。大王。菩萨摩诃萨行般若波罗蜜无有一心一行空过不向萨婆若者。菩萨摩诃萨行般若波罗蜜。遍缘诸法而能不着。名忧波憍舍罗。观见诸法无不趣向菩提之者。大王。譬如三千大千世界大地出生诸物人无不用。菩萨摩诃萨行般若波罗蜜。所缘境界无不利益趣向菩提。譬如众色无有不因四大成者。如是菩萨所缘境界。无有一法不向菩提。何以故。菩萨摩诃萨修习诸行。皆因外缘而得成立。如因悭嫉人成就菩萨檀波罗蜜。因不知恩人成就菩萨尸波罗蜜。如因恶性嗔恚众生成就菩萨忍波罗蜜。因懒惰者成就菩萨毗梨耶波罗蜜。因散乱人成就菩萨禅波罗蜜。因诸痴钝成就菩萨般若波罗蜜。若有众生损恼菩萨。菩萨因此不起嗔心。菩萨若见修行善法向菩提者。生己身想犹我子心。菩萨摩诃萨。若人赞叹不生欢喜毁不嗔恚。见苦众生则起大悲。若见受乐则生大喜。若因难化佷戾众生。菩萨则发奢摩他心。因信行者。菩萨即得知恩智慧。若见众生外恶缘强善因弱者。菩萨则起拥护之心。菩萨若见因力强者。种种方便令其受教。菩萨若见智慧开悟解义众生。则为此人说甚深法。若有智人菩萨则为次第说法。著文字者。为说句义。若已先学奢摩他者。菩萨为说毗婆舍那。若有先学毗婆舍那。则应为彼说诸三昧。若着持戒为说地狱。持戒不着则不说之。若著闻者为说思修。着三昧者说入般若。乐阿兰若即应为说心远离法。若有乐闻佛功德者为说圣智。为贪欲者说不净法。为嗔恚人说慈悲法。为愚痴者说缘生法。为等集者说种种法。或说不净。或说慈悲。或说因缘。调化众生为说净戒禅定智慧。应入佛乘而受化者。为次第说诸波罗蜜。应以抑挫而受化者。先折其辞然后说法。种种语言而受化者。即应为说因缘譬喻令其得解。应以深法而受化者。即应为说般若波罗蜜及方便力。无人无我无诸法相。着见众生为说空法。多觉观者为说无相。乐著有为则说无愿。着阴众生为说如幻。着界众生说无所有。着入众生为说如梦。着欲界者为说炽然。若着色界为说行苦。着无色界说行无常。难化众生为赞圣种。易化众生说诸禅定及无量心。若闻生天而受化者则为说乐。因声闻法而受化者为说诸谛。辟支佛法而受化者为说因缘。以菩萨法而受化者。为说净心及大悲法。修行菩萨则应为说功德智慧。阿鞞跋致诸菩萨等。则应为说清净佛国。一生补处则应为说庄严道场。应以佛说而受化者。则为相续次第而说。大王。菩萨摩诃萨行清净般若波罗蜜。以方便力得诸自在。说法利益无有空过。说是菩萨自在法门时。众中三万天人发阿耨多罗三藐三菩提心。五千菩萨得无生法忍。尔时世尊欣然微笑。诸佛法尔。若微笑时。面门即放诸大光明。青黄赤白紫颇梨色。遍照无量无边世界。上至阿迦尼吒还归佛所。右绕三匝从佛顶入。尔时大智舍利弗。即从坐起偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。诸佛如来无大因缘。则不现此希有瑞相。世尊今者放是光明。遍照十方无量世界。为何因缘。愿世尊说。尔时佛告舍利弗言。善男子。此胜天王。过去无量无边阿僧祇劫于诸佛所修行众波罗蜜。为诸菩萨护持如是般若波罗蜜。未来之世过无量百千阿僧祇劫。成就无上菩提资粮。然后得阿耨多罗三藐三菩提。佛号功德庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名严净。劫名清净。其土丰饶人民安乐。纯菩萨众。彼国悉以七宝庄严。所谓金银琉璃颇梨马瑙车磲真珠。七宝间错以成其地。平坦如掌。香华软草而严饰之。无诸山陵堆阜荆棘。幡华幢盖种种庄严。城名难伏。七宝罗网弥覆其上。角悬金铃。日夜六时诸天空中自作天乐。散众天香及天妙华。其土人民受乐欢喜。胜他化天。人天往来不相隔碍。无三恶道。彼土众生唯求佛智无二乘名。其佛世尊为诸高行菩萨摩诃萨说清净法。无量无边菩萨眷属。无有破戒邪命着见盲瞎聋哑痀背裸形诸根缺者。皆悉具足二十八相庄严其身。佛寿八小劫。人天之众无中夭者。善男子。彼佛世尊。有如是等无量功德。若欲说法先放光明照曜国土。其诸菩萨遇斯光者。即知世尊将欲说法。我等今者宜应往听。尔时诸天为彼世尊。敷师子座高百由旬。种种严饰无量供养。世尊坐上为众说法。彼诸菩萨聪明利根。一闻悟解无我我所。饮食资粮应念即得。说是胜天王授记法门时。众中五万天人发阿耨多罗三藐三菩提心。皆愿未来生彼国土。尔时胜天王闻佛世尊为其授记。心大欢喜得未曾有。踊在虚空高七多罗树。尔时三千大千世界六种震动。诸天伎乐不鼓自鸣。散众天华以供养佛及胜天王。时胜天王从空中下。头面礼佛退坐一面

    胜天王般若波罗蜜经现相品第七

尔时大智舍利弗白胜天王言菩萨摩诃萨行般若波罗蜜。通达法性即应坐道场转法轮。何因缘故先修苦行降伏恶魔。尔时胜天王答舍利弗言。善男子。菩萨摩诃萨行般若波罗蜜实无苦行。为伏外道故示现之。而彼天魔实不能坏。是欲界主故示降伏化诸众生。舍利弗。外道自谓苦行第一。是故菩萨示现苦行能超过彼。舍利弗。或有众生但见菩萨屈一膝立。或见菩萨举两手立。或见菩萨视日而立。或见菩萨五热炙身。或见菩萨倒身而立。或见菩萨卧棘刺床。或卧牛粪或坐方石。或复卧地或见卧板。或卧杵上或卧尘土。或着板衣或着莣衣。或着草衣或树皮衣。或复裸形或着茅衣。或面向日随日而转。或食稗子或见食麦。或食草根杂诸树叶。食果食华或食薯蓣。或见食芋或见食藕。或六日一食或见食豆。或食大豆或食炒谷。或见食麻或见食米。或见饮水而以度日。或见菩萨食一[泳-永+適]苏而以度日。或一[泳-永+適]蜜或一[泳-永+適]乳。或无所食或见眠熟。舍利弗。菩萨摩诃萨。示现如是种种苦行。六年之中一事不亏。菩萨实无如是苦行。众生见有。以诸众生应以苦行而得度脱。为是等故菩萨示之。有六十那由他人安住三乘。舍利弗。复有天人宿世善根深乐大乘。则见菩萨坐七宝台身心不动。面门喜笑入三昧定。如是六年方从定起。舍利弗。复有众生深乐大乘。欲听闻者则见菩萨端坐说法。舍利弗。此是菩萨摩诃萨。以方便力行般若波罗蜜。大悲化度一切众生。能降天魔伏诸外道。菩萨摩诃萨。既经六年从定而起。随顺世法诣尼连禅河。洗浴出已于河边立。有牧牛女构百乳牛。以饮一牛。构此牛乳。用以作糜奉献菩萨。复有六亿天龙夜叉乾闼婆。各持饮食而来奉献。作如是言。大士受我供养。正士受我供养。菩萨悉受。而彼牛女天龙夜叉各不相见。一一天等各见菩萨独受其食。舍利弗。是等众生因见受供而得悟道。是故菩萨为示现之。而此菩萨实不洗浴及受供养。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力示现行诣道场。时有地居天子名曰妙地。与诸天神扫此大地散众妙华。种种香水而用洒之。三千大千世界。须弥山下诸天之众四天王天雨诸天华。三十三天及夜摩天。空中赞叹作诸伎乐。兜率陀天珊兜率陀王。以七宝网弥覆世界。四角皆悬阎浮檀金铃。悉雨众宝供养菩萨。化乐诸天善化王。以阎浮檀金罗网弥覆世界。作诸伎乐雨种种华供养菩萨他化自在诸天子。与诸天龙夜叉乾闼婆阿修罗。伽楼罗紧那罗摩睺罗伽人非人等。各各施设种种供养。自在天子与娑婆世界主大梵天王。既见菩萨行诣道场。即告一切诸梵天言。善男子。汝等当知。如此菩萨摩诃萨。坚固大身而自庄严。不违本誓心无厌怠。一切菩萨行悉满足。通达教化无量众生。菩萨诸地皆得自在。于诸众生其心清净善知根性。通达如来甚深蜜藏过诸魔事。一切善根不随外缘。无量诸佛之所拥护。能为众生开解脱门。大将导师摧伏诸魔。大千世界独为勇猛。善施法药为大医王。解脱灌顶受法王位放智慧光。世间八法所不能染如大莲华。通达一切诸陀罗尼甚深如海。安住不动如须弥山。智慧清净无有垢秽。如摩尼珠于一切法而得自在清净梵行。善男子。菩萨摩诃萨修般若波罗蜜。以方便力行诣道场。欲降恶魔坐菩提树。为成就十力四无畏十八不共法。转大法轮作师子吼。以法布施令诸众生皆悉饱满。为欲清净众生法眼。无上正法降伏外道。欲示诸佛本愿成就。于一切法而得自在。善男子。汝等可往供养菩萨。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力示现行诣道场。足下即现千辐轮相。微妙光明。一切地狱畜生饿鬼遇斯光明。皆悉离苦而得安乐。及照龙宫时有加梨加龙王。遇此光明即告诸龙。此金色光来照龙宫。悉令汝等身心安乐。我于过去曾见此相有佛出兴。今此光明如昔不异。当知必有佛出世间。可辨种种烧香涂香末香。金银真珠车磲马瑙珊瑚白玉。旛华幢盖。作诸音乐往诣菩萨宫中。好物悉赍供养。时加梨加龙王与诸眷属。普兴大云降注香雨。往诣菩萨作诸伎乐施设供养。右绕菩萨而赞叹言。金色光明令人喜悦。决定最胜佛出无疑。种种杂宝庄严大地。凡是因地生诸草木悉变成宝。江河皆静无风浪声。推如此瑞佛出无疑。释梵日月光明不现。恶趣清净佛出无疑。譬如有人少失父母。年既长大忽然还得心甚欢喜。一切世间睹佛兴出亦复如是。我等已曾供养过去诸佛世尊。今值法王人中师子。则我受生为不空过。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力取草敷坐。于菩提树右绕七匝正念端坐。下劣众生见如此相。舍利弗。复有高行诸大菩萨。见八万四千天子敷八万四千大师子座众宝合成。七宝罗网弥覆其上。四角金铃处处皆有。幡华幢盖缯彩罗列。尔时菩萨遍此八万四千座上一一皆坐。而诸天子自不相见。各谓菩萨独坐我座成阿耨多罗三藐三菩提。以是因缘心生欢喜得未曾有。皆证阿鞞跋致舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力即放眉间白毫相光明照诸魔宫。三千大千世界一切魔宫皆失光明。时诸魔等各作是念。以何因缘我等诸宫光明不现。讵非菩萨坐于道场证阿耨多罗三藐三菩提乎。即共观察。方见菩萨端坐道场菩提树下。时诸恶魔于自宫殿聚集魔军。无量千亿种种诸色。种种众形。种种相貌。种种头面。持种种仗。种种幢幡。种种音声。若有闻者耳鼻口中并皆流血。菩萨尔时以大悲力。令魔军众不得出声。舍利弗。是名菩萨摩诃萨行般若波罗蜜方便之力。舍利弗。菩萨行般若波罗蜜。以方便力。无量亿劫行布施持戒忍辱精进禅定智慧。慈悲喜舍。念处正勤。神足根力觉道。奢摩他毗婆舍那。三明解脱。身金色右臂。从顶自摩乃至遍身。作如是言。众生苦恼。我欲济拔而起大悲。尔时魔王及诸眷属。闻菩萨言即皆倒仆。菩萨摩诃萨。以大悲力令诸魔众闻空中声言。汝等可归依持戒力仙。能施无畏救护一切众生。魔及眷属闻此声已。犹伏在地作如是言。唯愿正士大士救济我命。舍利弗。尔时菩萨摩诃萨行般若波罗蜜。以方便力放大光明。其有遇者皆离怖畏。魔及眷属见是神力。恐怖欢喜二事交怀。舍利弗。菩萨摩诃萨行般若波罗蜜。或有众生见是降魔。亦复有人不见此事。或有众生但见菩萨敷草而坐。或见菩萨处大师子宝台而坐。或见菩萨在地而坐。或见空中自然而有师子之座菩萨安坐。或有众生见阿说他树为菩提树。或见波利质多罗树。或见众宝合成为菩提树。或有众生见菩提树高七多罗树。或有众生见菩提树高八万四千由旬。师子之座高四万二千由旬。或有众生遥见菩萨游戏空中。或见菩萨坐菩提树。舍利弗。菩萨摩诃萨行般若波罗蜜以方便力示现如是种种神变化度众生。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力现坐道场。十方恒河沙世界。无量无边菩萨摩诃萨。皆悉来集住虚空中。出是声言。安慰菩萨安乐欢喜。善哉速疾勇猛精进。大吉祥勿生怖惧。心如金刚游戏神通利益众生。一念之顷一切智现。舍利弗。菩萨摩诃萨坐道场时。魔来为乱亦不生嗔。一刹那心与般若波罗蜜相应。所知见觉无不通达。舍利弗。时十方恒河沙世界诸佛如来。异口同声赞言。善哉大士。通达自然智。无碍智。平等智。无师智。大悲庄严。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力能作如是种种示现。或有众生。见此菩萨今始成道。或见菩萨久远成道。或见一世界四天王献钵。或见十方恒河沙世界四天王献钵。舍利弗。菩萨尔时度众生故即受众钵。重叠掌中合而为一。其诸天王各不相见。皆谓世尊独用我钵。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力示现此事。说是法门时。众中三万菩萨摩诃萨得无生法忍。三万六千菩萨皆不退转阿耨多罗三藐三菩提。八万人天得远尘离垢法眼净。无量无边众生发阿耨多罗三藐三菩提心。舍利弗。复有六万天子先来献供。过去愿力若菩萨成道。必愿先受我等供养。尔时菩萨摩诃萨以般若波罗蜜方便力故。示现欲转法轮。娑婆世界主尸弃梵王。与六十八万梵天。来世尊所头面作礼。右绕七匝而发是言。唯愿大悲。转无上法轮。唯愿大悲。转无上法轮。尔时即现大师子座高四万二千由旬。种种庄严坚固安隐。十方无量释提桓因。悉为如来敷师子座亦复如是。尔时菩萨以神通力一一诸天各见菩萨坐其座上而转法轮。菩萨摩诃萨既坐此座。十方无量无边世界。皆悉震动放大光明。即入无边境界三昧。十方恒河沙世界一切众生。三恶道苦即得安乐悉离三毒。各各相于犹如母子无复恶心。时此三千大千世界。靡有间隙如一毛孔。天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽人非人等。悉满其中。若有众生应以苦法而受化者闻佛说苦。应以无我空寂静离无常皆亦如是。应以如幻法而受化者闻说如幻。应以如梦水中月如影如响皆亦如是。应以空无相无愿而受化者。即闻佛说空无相无愿法。或闻如来说一切法从因缘生。或闻说诸阴。或闻说诸界。或闻说诸入。或闻说苦声。或闻说集声。或闻说道声。或闻说念处。或闻说正勤。或闻说神足。或闻说根。或闻说力。或闻说觉。或闻说道。或闻说奢摩他。或闻说毗婆舍那。或闻说辟支佛法。或闻说大乘法。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力示现种种转法轮。令无量众生随其根性欢喜利益。尔时舍利弗白胜天王言。菩萨摩诃萨行般若波罗蜜。以方便力。甚深境界难知难思量难入。尔时胜天王答舍利弗言。菩萨摩诃萨行般若波罗蜜功德胜事。我今所说百分不及一。百千万亿分乃至算数譬喻亦不及一。唯有如来乃能尽说。我今所说其少分者。皆承如来威神之力。何以故。诸佛境界一生补处菩萨摩诃萨尚不能尽。况余菩萨。舍利弗。诸佛境界寂静无说。后无分别智之所能了。舍利弗。菩萨摩诃萨。欲入诸佛境界。应学般若波罗蜜。首楞严三昧。如幻三昧。金刚喻三昧。金刚三昧。不动意三昧。遍通达三昧。不缘境界三昧。师子自在三昧。三昧王三昧。功德庄严三昧。寂静意三昧。超出三昧。无著三昧。意庄严王三昧。无等等三昧。等觉三昧。正觉三昧。悦意三昧。欢喜三昧。清净三昧。火焰三昧。光明三昧。难胜三昧。常现前三昧。不相近三昧。无生三昧。通达三昧。最胜三昧。过魔界三昧。一切智意三昧。幢相三昧。大悲三昧。欢喜三昧。爱念三昧。不见法三昧。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力。通达如是等无量无边百千亿恒河沙数诸三昧已乃能得入诸佛境界。其心安隐恐怖悉无。如师子王不畏禽狩何以故。菩萨摩诃萨。修如是等诸三昧已。有所经游悉无怖畏。不见其前有一怨敌。何以故。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力心无所缘亦无所住。譬如有人生无色界。八万四千劫中唯是一识。无有住处亦无所缘。菩萨摩诃萨行般若波罗蜜亦复如是。心无住处亦无所缘。何以故。心不行无行处。心无想无想处。心不缘无缘处。心不着无著处。心不乱无乱处。心无高下心不随顺。又不违逆不喜不忧。无分别离分别。离奢摩他毗婆舍那心不随智。心不自住亦不住他。不依眼住不依耳鼻舌身意住。不依色住不依声香味触法住。心不在内亦不在外。心不缘法心不缘智。不住过去未来现在。舍利弗。菩萨摩诃萨行般若波罗蜜不取一法。于一切法知见无碍。心行净故见一切法。皆悉无垢不取见相。见不分别离诸戏论。舍利弗。菩萨摩诃萨般若波罗蜜。不与肉眼相应。不与天眼相应。慧眼法眼佛眼悉不相应。不与天耳相应。不与他心智相应。不与宿命智相应。不与神通智相应。不与漏尽智相应。舍利弗。是般若波罗蜜不与一切法相应非不相应。菩萨摩诃萨行般若波罗蜜。以方便力。于一切法得平等智。能观一切众生心行。一切染净皆如实知于十力四无畏十八不共法佛一切智咸不失念。菩萨摩诃萨行般若波罗蜜。以无功用心通达一切法无心意识。常在寂静三昧之中。不舍三昧教化众生。施作佛事无有休息。于诸佛法得无碍智心无染着。舍利弗。譬如化佛更化作佛。彼所化者无心意识。无身身业无口口业无心心业。而能施作一切佛事利益众生。何以故。佛神力故。舍利弗。菩萨摩诃萨从般若波罗蜜所化亦复如是。无身身业无口口业无意意业。以无功用心常作佛事利益众生。何以故。菩萨摩诃萨行般若波罗蜜通达一切法。犹如幻相心无分别。而诸众生恒闻说法。舍利弗。菩萨摩诃萨如是智慧。不住有为不住无为。不住诸阴不住界入不住内外。不住善法及不善法。不住世间及出世间。不染不净。不住有漏不住无漏。不住过去未来现在。不住数缘灭不住非数缘灭。舍利弗。是菩萨摩诃萨。如是行般若波罗蜜心无所住。而能通达一切诸法。以无碍智无功用力为众生说。常在寂静而教化事无有休息。舍利弗。菩萨摩诃萨宿愿强故。无功用心为人说法。舍利弗。菩萨摩诃萨。以般若波罗蜜方便力故无诸怖畏。何以故。执金刚神常守护故。若行若立若坐若卧恒不远之。舍利弗。菩萨摩诃萨。闻说深般若波罗蜜。心不惊不怖不疑不悔。当知是人已得授记。何以故。信受般若波罗蜜。近佛境界故。以此一心则能通达一切佛法。达佛法故利益众生。不见众生与佛法异。何以故。理无二故

胜天王般若波罗蜜经卷第四胜天王般若波罗蜜经卷第五

        陈优禅尼国王子月婆首那译

    无所得品第八

尔时众中有一菩萨摩诃萨。名须真胝。白胜天王言。如来为大王授记乎。胜天王答善思惟菩萨言。善男子。我授记如梦相。又问。大王。如此授记当得何法。答曰。善男子。佛授我记竟无所得。又问。无所得者为是何法。答曰。不得众生寿者人养育阴界入悉无所得。若善不善。若染若净。若有漏若无漏若世间若出世间。若有为若无为。若生死若涅槃。悉无所得。又问。若无所得用受记为。答曰。善男子。无所得故则得受记。又问若如大王。所说义者则有二智一无所得。二得受记。答曰。若有二者则无授记。何以故。佛智无二诸佛世尊。以不二智受菩萨记。又问。若智不二云何而有授记得记。答曰。得记授记其际不二。又问。不二际者。云何有记。答曰。通达不二际即是受记。又问。大王。住何际中而得授记。答曰。住我际得授记。住众生际寿命际人际得授记。又问。我际当于何求。答曰。当于如来解脱际求。又问。如来解脱际复于何求。答曰。当于无明有爱际求。又问。无明有爱当于何求。答曰。当于毕竟不生际求。又问。毕竟不生际当于何求。答曰。当于无知际求。又问。无知者为无所知。云何于此际求。答曰。若有所知求不可得。以无知故于此际求。又问。此际无言云何可求。答曰。以言语断是故可求。又问。云何言语断。答曰。诸法依义不依语。又问。云何依义。答曰。不见义相。又问。云何不见。答曰。不生分别义。是可依我为能依。无此二事故名通达。又问。若不见义此何所求。答曰。不见不取故名为求。又问。若法可求即是有求。答曰。不尔。夫求法者是无所求何以故。若是可求则为非法。又问。何者是法。答曰。法无文字亦离言语。又问。离文言中何者是法。答曰。文言性离心行处灭。是名为法。一切诸法皆不可说。其不可说亦不可说。善男子。若有所说即是虚妄。中无实法。又问。诸佛菩萨常有言说皆虚妄乎。答曰。诸佛菩萨从始至终不说一字。云何虚妄。又问。若有所说云何过咎。答曰。谓言语过。又问。言语何咎。答曰。谓思量过。又问。何法无咎。答曰。无说所说不见二相。是则无咎。又问。过何为本。答曰。能执为本。又问。执何为本。答曰着心为本。又问。着何为本。答曰。虚妄分别。又问。虚妄分别以何为本。答曰。攀缘为本。又问。何所攀缘。答曰。缘色声香味触法。又问。云何不缘。答曰。若离爱取则无所缘。以是义故如来常说诸法平等。说此法门时。众中五千比丘得远尘离垢法眼净。一万二千菩萨得无生法忍。无量无边众生发阿耨多罗三藐三菩提心。尔时胜天王即从座起。偏袒右肩右膝着地。合掌向佛头面作礼。而白佛言。世尊。善男子善女人。闻是般若波罗蜜。云何未发阿耨多罗三藐三菩提心者即能发心。皆悉成就得不退转。行常胜进而无堕落。佛告胜天王言。大王。谛听善思念之。当为王说。善男子善女人闻般若波罗蜜。行得胜进无有退堕。胜天王言善哉世尊。唯然愿闻。佛告胜天王言。大王。若善男子善女人。闻般若波罗蜜。以清净意发阿耨多罗三藐三菩提心。具足正信亲近贤圣乐闻正法。远离嫉妒无有悭吝。常修寂静好行布施。心无隔碍恒离秽浊。正信业果心不疑惑知黑白报。设为身命不应作者终不为之。大王。善男子善女人。如是行般若波罗蜜。则远离杀生不与取邪淫妄语两舌恶口绮语贪嗔邪见。心常系念此十善法。大王。善男子善女人行般若波罗蜜。以方便力。若见沙门婆罗门。正行精进戒品清洁。多闻解义常起正念。心性调伏寂静不散。口恒爱语远离诸恶不善之法。修习众善。不自矜高于他不下。不作恶口及无义语。不舍念处其心调直。能断有流善拔毒箭舍离重担。超出有难已度后有。大王。善男子善女人。行般若波罗蜜若见如是菩萨摩诃萨则应亲近依止。是人为善知识。菩萨摩诃萨。以方便力而为说法。善男子。施得大富持戒生天听法大智。又复告言。此是布施此是施报。此是嫉妒是嫉妒报。此是忍辱是忍辱报。此是精进是精进报。此是禅定是禅定报。此是般若是般若报。此是愚痴是愚痴报。是身善业身善业报。是身恶业身恶业报。是口善业口善业报。是口恶业口恶业报。是意善业意善业报。是意恶业意恶业报。诸善男子善女人。此法应作此不应作。若如是修致长夜乐。不如是作得长夜苦。大王。善男子善女人。以方便力亲近善知识。得闻如是次第说法。菩萨摩诃萨。若知彼人是法器者。则应为说甚深般若波罗蜜。所谓空无相无愿无作。无生无灭。无我无众生。无命无人。而说甚深因缘法。因此法彼法生。此法灭彼法灭。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。大王。菩萨摩诃萨行般若波罗蜜。以方便力作如是说。于真实中无有一法可生可灭。何以故。世间诸法皆因缘生。无我作者因缘和合。无一实法受生灭者。虚妄分别于三界中但有假名。随业烦恼而受果报。若以般若波罗蜜。如实观察一切诸法。无生无灭无作受者。若法无作是亦无行。则于诸法心无所著。谓不着色受想行识。不着眼色识。不着意法识。大王。菩萨摩诃萨作如是说。一切诸法自性空离不取不着。善男子善女人。因如是说则无退失。大王。菩萨摩诃萨行般若波罗蜜。乐见诸佛乐闻正法。不堕卑贱。在所生处不离见佛。听受正法供养众僧。面见诸佛勇猛精进。志求正法不著有为。妻子仆隶生生所资。悉不贪着不染诸欲。常依正教忆念诸佛。离俗出家如闻修行。转为他说心无求望。见听法众常生大慈。一切众生而起大悲。多闻广学不惜身命。少欲知足常乐远离。但采义理不滞言辞。说法修行不为自身。唯化众生得无上乐。所谓佛智。大王。菩萨摩诃萨行般若波罗蜜如是修行。远离放逸摄护诸根。若眼见色不着色相。如实观察此色过患。耳声鼻香舌味身触意法亦尔。若纵诸根名为放逸。若能摄护名不放逸。菩萨摩诃萨行般若波罗蜜。调伏自心将护他意名不放逸。远离贪欲心顺善法。觉观嗔痴不善根本。身恶口恶及以邪念。一切不善皆悉远离名不放逸。菩萨摩诃萨行般若波罗蜜。心常正念名不放逸。大王。菩萨摩诃萨行般若波罗蜜。一切诸法信为其首。正信之人不生恶趣。心不行恶圣人所赞。大王。菩萨摩诃萨行般若波罗蜜如法修行。在在生处常得值佛。远离二乘安住正道得大自在成就大事如来正智。菩萨摩诃萨行般若波罗蜜。欲求安乐当勤随顺萨婆若路。大王。今此大众得闻深般若波罗蜜。已于过去无量百千万劫。供养诸佛修习善根。是故应当勤加精进勿令退失。大王。若天若人能制诸根不着五欲。远离世间常修出世。三业清净习助道法名不放逸。大王。菩萨摩诃萨行般若波罗蜜。正信具足心不放逸。勤修精进令得胜法名不放逸。大王。菩萨摩诃萨欲具正信心不放逸。精进正念当学般若波罗蜜。因是念智。能速成就阿耨多罗三藐三菩提法。大王。菩萨摩诃萨行般若波罗蜜。具足正信心不放逸。勤修精进即得正念。用是念智知有知无。云何有无。若修正行得正解脱。是名为有。若修邪行得正解脱。是名为无。眼耳鼻舌身意。世谛为有真实中无。菩萨摩诃萨。勤修精进能得菩提。是名为有。懒惰菩萨得菩提者。是名为无。若说五阴皆从虚妄颠倒而生。是名为有。若谓世法不从因缘自然生者。是名为无。色是无常苦败坏法。是名为有。若言常乐。非败坏法。是名为无。受想行识亦复如是。无明缘行。是名为有。若离无明而行生者。是名为无。行缘识乃至生缘老死忧悲苦恼皆亦如是。施得大富。是名为有。施得贫穷。是名为无。清净持戒得生善道。是名为有。若生恶趣。是名为无。乃至般若波罗蜜能得成圣。是名为有。修行般若波罗蜜作凡夫者。是名为无。若修多闻能得大智。是名为有。得愚痴者。是名为无。若修正念能得出离。是名为有。不得为无。若行邪念不得出离。是名为有。得者为无。无我我所能得解脱。是名为有。有我我所而得解脱。是名为无。若言虚空遍一切处。是名为有。五阴中我。是名为无。如实修智能得解脱。是名为有。若着邪智而得解脱。是名为无。若离我见众生见寿者见人见能得空智。是名为有。着我众生寿者人见能得空智。是名为无。大王。菩萨摩诃萨行般若波罗蜜。如是知世有无能修平等。了知诸法因缘而生世谛故有不起常见。知因缘法本性自空不生断见。于诸佛教如实通达。大王。诸佛如来略为菩萨说是四法。世间沙门婆罗门及长寿天心皆着常。为破此执说行无常。有诸天人多贪着乐。为破此计说一切苦。外道邪见着身中我。为破此执而说无我。又复为破增上慢人。是故而说涅槃寂静。说无常者令其志求究竟之法。为说苦者令离愿求。说无我者为显空门。说寂静者令达无相。大王。菩萨摩诃萨行般若波罗蜜如是修学。于诸善法终无退堕。速成阿耨多罗三藐三菩提。尔时胜天王白佛言。世尊。菩萨摩诃萨行般若波罗蜜。修何等行拥护正法。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜行不违言。敬重尊长随顺正法。心行调直诸根寂静。远离众恶不善之法修习善根名护正法。大王。菩萨摩诃萨行般若波罗蜜。修身业慈悲。口业慈悲。意业慈悲。不求名利持戒清白远离诸见。名护正法。大王。菩萨摩诃萨行般若波罗蜜。不随爱行。不随嗔行。不随痴行。不随畏行。名护正法。大王。菩萨摩诃萨行般若波罗蜜。修习惭愧。名护正法。大王。菩萨摩诃萨行般若波罗蜜。说法修行悉如所闻。名护正法。大王。三世诸佛为护正法。是故拥护天王人王令法久住。说是陀罗尼

多侄他阿吼罗(理我反下悉同)吼罗婆(蒲我反下悉同)底(都覆反下悉同)厚罗拏(弩假反下悉同)莎臼茶(杜假反)柘柘柘柘柘祢(宁履反下悉同)富拏簉多(睹舸反下悉同)叉多叉延多叉也莎摩(暮舸反下悉同)奢摩祢柯罗瓯楼瓯楼婆底杞(枯履反)罗婆底金(季侵反)阿毗(彭履反)奢底祢莎罗祢[禾*土]阇[禾*土][禾*土]摩底阿婆柂祢婆柂跋多跋多羺莎履裒多羺悉蜜履底提婆多羺悉蜜履底

若龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。一切众生皆得安隐。大王。此大神咒。三世诸佛。为护正法。拥护天王人王。宜应诵持。怨贼恶难魔障正法皆悉消灭。诸佛如来为令正法久住世故。护天人王使其护法。说是般若波罗蜜神咒法门时。一切天宫大地诸山大海皆悉震动。众中八万众生发阿耨多罗三藐三菩提心。尔时胜天王。以七宝网弥覆佛上。而白佛言。世尊。菩萨摩诃萨行般若波罗蜜。修何等法于阿耨多罗三藐三菩提心不移动。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜。修无碍大慈无厌大悲成办大事。勤加精进学空三昧修平等智。以方便力则能通达清净大智。明了如实三世平等无有障碍。履三世佛所行之道。大王。菩萨摩诃萨行般若波罗蜜。修如是法于阿耨多罗三藐三菩提心不移动。胜天王白佛言。世尊。菩萨摩诃萨云何行般若波罗蜜。闻佛不思议事。不怖不畏不惊不悔。佛告胜天王言。大王。菩萨宜应具足般若具足阇那。近善知识乐闻深法。了知诸法皆悉如幻悟世非常。心不住着犹如虚空。知一切法生必有灭。大王。菩萨摩诃萨行般若波罗蜜。修如是法闻佛不思议事。不怖不畏不惊不悔。胜天王白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜。于一切处而得自在。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜。修五神通。具足无碍诸解脱门。四禅四无量心方便。般若波罗蜜于一切处而得自在。胜天王白佛言。世尊。菩萨摩诃萨行般若波罗蜜得何等门。佛告胜天王言大王。菩萨摩诃萨行般若波罗蜜。得阇那门。能入众生诸根利钝。得般若门分别句义。得陀罗尼门总知一切语言音声。得无碍门说法不尽。大王。是名菩萨摩诃萨行般若波罗蜜得是诸门。胜天王白佛言。世尊。菩萨摩诃萨行般若波罗蜜得何等力。佛告胜天王言。大王。得寂静力。成就大悲故。得精进力。成就阿鞞跋致故。得多闻力。成就大智故。得信乐力。成就解脱故。得修行力。成就出离故。得忍辱力。爱护众生故。得菩提心力。断除我见故。得大悲力。教化众生故。得无生忍力。成就十力故。大王。菩萨摩诃萨行般若波罗蜜。成就如是等力。说是法门时。众中五百菩萨得无生法忍。八千天子得阿鞞跋致。一万二千天子得远尘离垢法眼净。四万人天发阿耨多罗三藐三菩提心

    胜天王般若波罗蜜经证劝品第九

尔时佛告胜天王言。过去之世阿僧祇阿僧祇劫。不可数不可思量。此时有佛。名功德宝王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名宝庄严。劫名善观。时世丰乐无诸疾恼。人天往来不相隔碍。地平如掌无有山陵堆阜荆蕀生诸细草柔软青绀如孔雀毛。长可四寸。下足则靡举步随升。种种名花。须摩那花薝卜伽花。及余软草皆悉周遍。不寒不热四时调和。纯青琉璃以成其地。世界众生心性柔和。善伏三毒不随之行。时功德宝王佛。有声闻众一万三千那由他人。菩萨摩诃萨众六十二亿人。时人寿命三十六亿那由他岁无复中夭。有一国土名无垢庄严。其城南北广一百二十八由旬。东西八十由旬。十千园苑以为严饰。十千小国周遍围绕。转轮圣王名曰治世。七宝具足王四天下。已曾供养无量诸佛深种善根。不退阿耨多罗三藐三菩提心。有四园苑。妙花庄严功德悦意。孔雀游戏四时适乐。城壁厚十六由旬。门堞楼观悉用七宝。有四大池皆广半由旬。七宝为岸阎浮檀金以成阶道底布金沙。池中之水具八功德生宝莲华。凫雁鹅鹤鸳鸯猩猩游戏其中。岸列诸树白檀赤檀尸梨沙等。上有鹦鹉舍利。迦鸟翔集游戏。王之内宫七十千人相貌端正承事宝女。咸悉发心向阿耨多罗三藐三菩提。王有千子。大力勇健能摧怨敌。具二十八大丈夫相庄严其身。悉已发心向阿耨多罗三藐三菩提。尔时功德宝王如来。与无量天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。前后围绕入无垢庄严大城。治世圣王。即与七宝千子宫人奉迎世尊。施设种种微妙供养。尔时世尊及诸大众。受供养已还归本处。王与七宝千子内人。出城奉送亦即还宫。时治世王忽自叹曰。人身无常富贵如梦。诸根不缺正信甚难值佛闻法如优昙华。时彼千子知其父王恋仰世尊乐闻正法。即为营造牛头栴檀七宝庄严妙台。其香一两直阎浮提。此台东西广十由旬。南北十三由旬。四角大柱众宝庄严。一千宝轮。诸子将送奉献圣王。时王受已而赞叹曰。善哉诸子。我欲诣佛听受正法。尔时千子于此台中造师子座。安处圣王及诸宫人。其台四边悬缯幡盖。覆七宝网角垂金铃。种种诸华。薝卜伽华。须摩那华。优钵罗华。拘勿头华。分陀利华。迦摩罗华。而散台上。烧无价香。泥香涂之。末香以散。尔时千子共捧此台人各一轮。飞腾虚空犹如鹅王。往诣佛所安详不摇。至地徐下即到佛前。头顶礼足。右绕世尊及诸大众。凡七匝已退立一面。尔时圣王及诸宫人。从宝台下。王脱宝冠各脱革屣。至世尊前顶礼佛足。右绕世尊及诸大众。凡七匝已退坐一面。尔时宝庄严王佛。即告之言。圣王。今来听正法乎。尔时治世圣王。即从座起齐整衣服头顶礼足而白佛言。世尊。所说正法何者是乎。尔时世尊赞治世王言。善哉善哉。能为利益无量天人作是深问。如来应供正遍知。当为大王分别解说。治世圣王即白佛言。世尊。唯然愿闻。尔时佛告治世圣王言。大王。菩萨摩诃萨行般若波罗蜜。通达一切法名为正法。所谓四念处四正勤四如意足。五根五力七觉分八圣道分。空无相无愿。通达平等名为正法。治世圣王白佛言。世尊。菩萨摩诃萨。云何行般若波罗蜜。于大乘中恒得胜进而不退堕。佛告治世圣王言。大王。菩萨摩诃萨行般若波罗蜜。因正信故而得胜进。何者正信。知一切法不生不灭自性寂静。常能亲近正行之人。不应作法终不造作。心离散乱听受正法。不见说者不见我听。勤修精进令得神通。身心轻举教化众生。不见我有神通能化众生受化。何以故。大王。菩萨摩诃萨行般若波罗蜜。不见我不见众生二处平等。则得胜进而不退堕。大王。菩萨摩诃萨行般若波罗蜜。摄护诸根不令取着。一切资生起无常想。知法寂静命如假借。大王。菩萨摩诃萨如是行般若波罗蜜。于大乘中心不放逸。大王。菩萨摩诃萨行般若波罗蜜。于其梦中尚不忘失菩提之心。教化众生令修佛道。一切善根回向阿耨多罗三藐三菩提。见佛神力欢喜赞叹。大王。菩萨摩诃萨。如是行般若波罗蜜。则能速成阿耨多罗三藐三菩提。是故大王。当勤精进莫生放逸。菩萨摩诃萨。欲求法者勿着五欲。大王。一切凡夫于欲无厌。得圣智者则能舍弃。人身无常寿命短促。是故大王。应离世间求出世道。大王。今者供养如来所得善根。应作如是四种回向。自在无尽。法无尽。智无尽。辩才无尽。此四回向与般若波罗蜜同皆悉无尽。大王。菩萨摩诃萨行般若波罗蜜。应净身口意戒。何以故。为闻思修故。以方便力教化众生。以般若力降伏诸魔。愿力成就行不违言。尔时治世转轮圣王。闻佛所说甚深般若波罗蜜。心生欢喜得未曾有。即取宝冠自解璎珞供养如来。舍四天下皆以奉佛作如是愿。常修梵行学此甚深般若波罗蜜。以决定心趣向阿耨多罗三藐三菩提。王宫女人闻佛说法。皆生欢喜发菩提心。脱上分衣及宝缨络供养如来。治世圣王。即舍宝台以奉上佛而求出家。尔时功德庄严王佛。赞治世转轮圣王言。善哉善哉。大王。今日所行不违昔愿。大王。善修布施持戒忍辱精进禅定智慧。过去诸佛已修此法得成佛道。未来诸佛亦修此法当得成佛。尔时治世圣王白佛言。世尊。菩萨摩诃萨修行布施。为与般若波罗蜜异不。佛告治世圣王言。大王。夫布施者。若无般若波罗蜜。但名为檀非波罗蜜。以般若波罗蜜故。乃得名为檀波罗蜜。持戒忍辱精进禅定智慧亦复如是。何以故。般若波罗蜜性平等故。功德庄严故。佛说是法时。治世圣王得无生法忍。佛告胜天王言。菩萨摩诃萨行般若波罗蜜应如彼王。尔时治世转轮圣王即然灯佛是。其王千子贤劫千佛是。尔时胜天王白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜。修学速成阿耨多罗三藐三菩提道。佛告胜天王言。大王。菩萨摩诃萨行般若波罗蜜修习大慈。于诸众生不起恼心。具足勤行诸波罗蜜。及以四摄四无量心助菩提法。修学神通了达优波憍舍罗。一切善法无不修满。如是行者则能速成阿耨多罗三藐三菩提。大王。菩提道者。所谓信心。清净心。离谄曲心。行平等心。施无畏心。令诸众生咸悉亲附。勤行布施果报不尽。坚持净戒而无障碍。修行忍辱离诸嗔恼。勤加精进修行则易。以有禅定不起散乱。具足般若能善通达。有大悲故终无退转。有大喜故能悦彼心。修行大舍不起分别。无三毒故离诸棘刺。不着色声香味触故灭诸戏论。无烦恼故远离怨敌。舍二乘念其心广大。具一切智能出众宝。大王。菩萨摩诃萨行般若波罗蜜。如是学者速成阿耨多罗三藐三菩提。尔时胜天王白佛言。世尊。菩萨摩诃萨行般若波罗蜜。现何色貌教化众生。佛告胜天王言。菩萨摩诃萨行般若波罗蜜。示现色形无有定相。何以故。随诸众生心之所乐。即见菩萨色貌。如是或现金色。或现银色。或颇梨色或琉璃色。或马瑙色。或车磲色。或真珠色。青色黄色赤色白色。或日月色。火色。焰色。帝释色。梵王色。霜色。雌黄色。朱色。薝卜伽色。须摩那色。婆利师迦色。波头摩色。拘勿头色。分陀利色。功德天色。鹅色。孔雀色。珊瑚色。如意珠色。虚空色。天见是天人见是人。大王。十方恒河沙世界中。一切众生色形相貌。菩萨摩诃萨悉现如是。何以故。菩萨摩诃萨行般若波罗蜜。不舍一众生故遍能摄取。何以故。一切众生心各不同。是故菩萨种种示现。何以故。菩萨摩诃萨。过去世中有大愿力。随诸众生心所乐见而受化者。即为示现所欲见身。大王。如净明镜本无影像。随诸外色若好若丑。种种悉现。亦不分别我体明净能现众色。菩萨摩诃萨行般若波罗蜜亦复如是。无功用心随众生乐。种种示现悉令悦彼。而不分别我能现身。大王。菩萨摩诃萨行般若波罗蜜。于一座中随诸听众。或见菩萨说法。或见佛说法。或见辟支佛说法。或见声闻说法。或见帝释。或见梵王。或见摩醯首罗。或见围纽天。或见四天王。或见转轮圣王。或见沙门。或见婆罗门。或见刹利。或见毗舍首陀。或见居士。或见长者。或见坐宝台中。或见坐莲华上。或见行在地上。或见飞腾虚空。或见说法。或入三昧。大王。菩萨摩诃萨行般若波罗蜜为度众生。无一形相及一威仪不示现者。大王。般若波罗蜜。无形无相。犹如虚空遍一切处。譬如虚空无诸戏论。般若波罗蜜亦复如是过诸语言。又如虚空世所受用。般若波罗蜜亦复如是。一切凡圣之所受用。又如虚空无有分别。般若波罗蜜亦复如是无分别心。譬如虚空容受众色。般若波罗蜜亦能容受一切佛法。譬如虚空能现众色。般若波罗蜜亦复能现一切佛法。譬如空中一切草木众药华果依之增长。般若波罗蜜亦复如是。一切善根依之增长。譬如虚空非常无常非言语法。般若波罗蜜亦复如是。非常无常悉离言语。大王。世间沙门婆罗门。若释若梵。无能思量般若波罗蜜者。大王。般若波罗蜜无有一法可为譬喻。若善男子善女人。信受般若波罗蜜者。所获功德不可思量。若此功德有色形者空界不容。何以故。般若波罗蜜出生世间及出世间一切善法。若人若天若天人王。若须陀洹向须陀洹果。乃至阿罗汉向阿罗汉果。辟支佛道。菩萨十地。十波罗蜜。诸佛阿耨多罗三藐三菩提。一切种智。十力四无畏。十八不共法。皆从般若波罗蜜生。说是法门时。众中五万菩萨摩诃萨得不退转。一万五千天子得无生法忍。一万二千天人得远尘离垢得法眼净。恒河沙数众生发阿耨多罗三藐三菩提心。诸天空中作众伎乐不鼓自鸣。散众天华供养如来般若波罗蜜。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。散种种华及诸宝物。供养世尊般若波罗蜜。异口同音一时赞曰。善哉善哉。世尊。快说般若波罗蜜

胜天王般若波罗蜜经卷第五胜天王般若波罗蜜经卷第六

        陈优禅尼国王子月婆首那译

    述德品第十

尔时文殊师利菩萨摩诃萨。即从座起偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。菩萨摩诃萨。于几劫数行般若波罗蜜。供养几佛而能如是对扬如来。说甚深般若波罗蜜如胜天王。尔时佛告文殊师利菩萨摩诃萨。善男子。如此之事不可思量。若非无数百千亿劫修习众行种善根者。则不闻是般若波罗蜜名。善男子。十方恒河沙世界中。诸恒河沙数尚可知。是菩萨摩诃萨。几劫行般若波罗蜜。供养几佛数不可知。文殊师利。过去无量无边阿僧祇不可思议劫。尔时有佛。名曰多闻如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名日光。劫名增上。时多闻佛。为诸菩萨摩诃萨说清净法门。诸善男子。勤修精进莫顾身命。时彼会中有一菩萨摩诃萨。名曰进力。即从座起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。世尊。所说勤修精进莫顾身命如我解佛所说义者。菩萨摩诃萨。应当懈怠尔乃速成阿耨多罗三藐三菩提。何以故。菩萨摩诃萨若勤精进。是则不能久住生死。菩萨摩诃萨行般若波罗蜜。断伏烦恼久住生死。终无自度速证涅槃不化众生。世尊。菩萨摩诃萨。处生死中用之为乐。不以涅槃而为乐也。何以故。世尊。菩萨摩诃萨。利众生事以之为乐。随彼所乐即用方便。说种种法令得安乐。若证漏尽不能利益一切众生。世尊。是故菩萨观察生死起大悲心。不舍众生成就本愿。世尊。菩萨摩诃萨。具方便力久住生死。得见无量无边诸佛。及闻无量无边正法。教化无量无边众生。是故菩萨摩诃萨。不厌生死不乐涅槃。世尊。菩萨摩诃萨若观生死而起惊怖则堕非道。不能利益一切众生。通达如来甚深境界。云何非道。所谓贪乐声闻辟支佛地。于诸众生无大悲心。何以故声闻辟支佛道。即非菩萨摩诃萨道。何以故。声闻缘觉怖畏生死求速出离。功德智慧则不具足。以是义故。非菩萨道。尔时多闻世尊赞进力菩萨摩诃萨言。善哉善哉。善男子。如汝所说。菩萨摩诃萨。应修自行勿习非道。进力菩萨白佛言。世尊。何者是菩萨摩诃萨自所行道。尔时多闻世尊告进力菩萨摩诃萨言。善男子。菩萨摩诃萨。成就一切功德智慧。以大悲力不舍众生。远离声闻辟支佛地。得无生智不舍三有。心无求望而增善根。方便修行诸波罗蜜。以智慧力无分别心。生诸善根成就尽智。无量功德。无一法生方便现生。无一众生方便教化。知一切法皆自性离。观诸佛国犹如虚空。而以方便严净佛土。知一切佛法身无像。方便示现相好庄严。随诸众生心所须欲。即能应与。菩萨身心常寂静离。而为众生种种说法。亦以方便远离喧挠。修诸禅定知自性空。悉能通达甚深智慧。而以方便为他说法。不证声闻辟支佛果。求佛解脱不舍菩萨一切道行。善男子。是名菩萨摩诃萨道。文殊师利。进力菩萨从多闻世尊。闻说菩萨所行境界得未曾有。即白佛言。希有世尊。如我解佛所说义者。菩萨摩诃萨具足方便。一切诸法无非其道。世尊。譬如虚空悉能容受一切众色。如是菩萨具足方便所行之道摄一切法。又如虚空树木药草果树香树因之增长。如是诸物不染虚空亦不能净。不能令嗔亦不令喜。如是菩萨摩诃萨。有方便般若波罗蜜。缘一切法皆悉是道。若凡夫法。若学人法。辟支佛法。若菩萨法。若如来法。何以故。菩萨摩诃萨悉通达故。又譬如火若遇树木竹草必无退还。是等草木皆利益火发其光明。诸法亦尔。悉是菩萨摩诃萨道。譬如金刚自体坚密。刀不能斫。火不能烧。水不能烂。毒不能害。菩萨摩诃萨方便智慧。声闻缘觉及诸外道。一切烦恼所不能坏。世尊。如清水珠若在浊水即为之清。菩萨摩诃萨。般若波罗蜜珠。能使一切众生烦恼悉得清净。世尊。譬如妙药珠宝毒不共居能消众毒。菩萨摩诃萨行般若波罗蜜方便。不与一切烦恼共俱悉能断灭。世尊。以是因缘。一切诸法皆是菩萨摩诃萨道。文殊师利。进力菩萨说是法门时。众中八千菩萨发阿耨多罗三藐三菩提心。二百菩萨得无生法忍。文殊师利。过去多闻佛所进力菩萨。今胜天王是。尔时文殊师利菩萨白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜。得坚固力拥护正法。佛告文殊师利菩萨言。善男子。菩萨摩诃萨。宁弃身命不舍正法。于他卑恭不起憍慢。无势力人之所耻辱其心能忍。饥渴众生即便惠施最胜饮食。在厄难者施其无畏。于诸疾病如法疗治。贫穷众生令丰财宝。诸佛塔庙白灰泥涂。恶事则掩光扬善事。苦恼众生则施安乐。文殊师利。菩萨摩诃萨行般若波罗蜜。修如是行得坚固力拥护正法。文殊师利菩萨白佛言。世尊。菩萨摩诃萨行般若波罗蜜。云何能调伏心。佛告文殊师利菩萨言。菩萨摩诃萨行般若波罗蜜。不滥他事先思后行。心性调直离谄曲行。不自矜高意常柔软。文殊师利。菩萨摩诃萨。如是行者能调伏心。文殊师利菩萨白佛言。世尊。菩萨摩诃萨行般若波罗蜜。修是等行当生何道。佛告文殊师利菩萨言。菩萨摩诃萨如是行般若波罗蜜者。或生天中。或生人中。若生天中则为帝释值佛出世。或大梵王娑婆国主值佛出世。若生人中作转轮圣王长者居士值佛出世。文殊师利。菩萨摩诃萨。调伏心行得如是生。文殊师利菩萨白佛言。世尊。正信流出何法。佛告文殊师利菩萨。正信流出得善知识。世尊。布施流出何法。佛言。流出大富。世尊。多闻流出何法。佛言。流出般若波罗蜜。世尊。持戒流出何法。佛言。流出一切善道。世尊。忍辱流出何法。佛言。流出容受众生。世尊。精进流出何法。佛言。能成就一切佛法。世尊。思惟流出何法。佛言。流出寂静。世尊。般若流出何法。佛言。般若流出离一切烦恼。世尊。听法流出何法。佛言。流出远离疑网。世尊。如法问流出何法。佛言。出决定智。世尊。住寂静流出何法。佛言。流出禅定及诸神通。世尊。正修流出何法。佛言。流出厌离道。世尊。无常声流出何法。佛言。流出无所摄护。世尊。苦声流出何法。佛言。流出无生。世尊。无我声流出何法。佛言。流出灭我我所。世尊。空声流出何法。佛言。流出寂静。世尊。正念流出何法。佛言。流出圣正见。世尊。圣心离流出何法。佛言。流出三昧神通。世尊。圣道流出何法。佛言。流出圣果。世尊。信乐流出何法。佛言。流出成就诸解脱。世尊。佛生流出何法。佛言。流出一切助菩提法。尔时胜天王白佛言。世尊。云何佛生。佛告胜天王言。如发菩提心。世尊。云何发菩提心。佛言。大王。如生大悲。世尊。云何生大悲。佛言。不舍一切众生。世尊。云何不舍一切众生。佛言。如不舍三宝。世尊。谁不舍三宝。佛言。无烦恼者。尔时胜天王白佛言。希有世尊。希有修伽陀。诸佛世尊如是秘密甚深微妙。常说一切法空无生无灭寂静。不破所修善恶果报远离断常。世尊。于世界中颇有众生闻如是法。不起正信敬重之心生毁谤不。世尊。是等众生过去之世。因由善业得受人身。亲近恶知识故。不信如是甚深之法。则为孤负过去善业。诸佛世尊恩德深重。假使自割身肉出血供养如来。亦不能报以佛恩故。我等今日增长善根。得大法乐住大自在。世尊。菩萨摩诃萨行般若波罗蜜。应知佛恩。近善知识。当学佛行令得佛果。说是法时。众中二万五千菩萨得无生法忍。四万五千人天发阿耨多罗三藐三菩提心。一万二千天子得远尘离垢法眼净

    现化品第十一

尔时善思惟菩萨摩诃萨白胜天王言。如来所造化佛更能化不。尔时胜天王答善思惟菩萨言。今对世尊以为明证。佛所化佛更能化作恒河沙数无量化佛种种色相。神通说法利益众生。善男子。诸佛宿世愿力清净故能如是。善思惟菩萨白胜天王言。大王。善说甚深之法。诸佛宿世愿力清净。唯愿大王。请佛神力。令此般若波罗蜜久住世间无有隐没。胜天王答善思惟菩萨言。善男子。般若波罗蜜一切诸佛之所护持。何以故。文字所说般若波罗蜜。如是文字不生不灭无有隐没。字所显义亦不生不尽无有隐没。善男子。诸佛如来甚深般若波罗蜜亦不隐没。何以故。法不生故。若法无生此则无灭。即是如来秘密之教。若佛出世若佛不出性相常住。是名法界。亦曰如如。名不异际随顺因缘而不违逆。是为正法。其性常住无有隐没善思惟菩萨白胜天王言。大王。能护正法是何等人。胜天王答善思惟菩萨言。善男子。若不违逆一切法者。名护正法。何以故。无有诤论不违道理。名护正法。又问。云何不违道理。答曰。若顺文字不违道理无所诤论。名护正法。何以故。世间凡夫皆着诸见。顺道理者则常说空。是故世间而起诤论。如是凡夫爱重有法。顺道理者于此则轻。世间说有常乐我净。顺道理者说无常苦不净无我。是故世间而生诤论。善男子。一切凡夫顺世间流。顺道理者逆世间流。是故世间则生诤论。一切凡夫着阴界入。顺道理者说一切法悉无所著。是故世间而起诤论。善男子。随顺世者不行道理。顺道理者与世相违。善思惟菩萨白胜天王言。大王。今者取何等法。胜天王答善思惟菩萨言。我不取人不取法。又问。云何不取。答曰。我离众生离法离。是离悉不可得。过去未来现在离。离不可得。诸佛离诸佛不离。佛国土离国土不离。法离法不离。善男子。如是之行名顺道理无取不取。尔时善思惟菩萨赞胜天王言。善哉大士。善哉正士。能说如是甚深般若波罗蜜。无取无著无名无字。灭诸戏论。离能分别及所思惟。尔时众中有一天子。名曰贤德。即从坐起偏袒右肩右膝着地。合掌向佛头面作礼而白佛言。世尊。如胜天王所说无分别者为是何法。佛告贤德天子言。无分别法即是寂静。何以故。取可取无。离我我所。不起不息。是名无分别法。善男子。菩萨摩诃萨。如是观者能护正法。不见能护及以所护。说此法时。众中十千比丘心得解脱。一千天子得远尘离垢法眼净。尔时善思惟菩萨白胜天王言。何等辩才能如是说甚深之法。胜天王答善思惟菩萨言。善男子。一切烦恼习性无者。所得辩才能如是说。过言语道不可名宣第一义智。如是辩才能作此说。尔时善思惟菩萨问贤德天子言。善男子。云何无生法中以辩才说。尔时贤德天子答善思惟菩萨言。菩萨摩诃萨。不住无生无灭法中。则无辩才说甚深法。何以故。远离戏论不见所缘不见能缘。心无所住是故能说。不住人法不住此彼。唯住清净第一义谛。是故能说。尔时善思惟菩萨即白佛言。世尊。贤德天子甚为希有。乃能通达甚深之法辩才无尽。佛告善思惟菩萨言。善男子。此贤德天子。从妙喜世界不动佛所。而来至此娑婆世界。听受甚深般若波罗蜜。佛复告善思惟菩萨言。贤德天子。已于过去无量百千亿劫。修习陀罗尼门。穷劫说法亦无终尽。善思惟菩萨白佛言。世尊。何等陀罗尼。佛言。善男子。名众法不入陀罗尼。善男子。此陀罗尼过诸文字。言不能入心不能量。内外众法皆不可得。善男子。无有少法能入此者。故名众法不入陀罗尼。何以故。此法平等无有高下亦无出入。无一文字从外来入。亦无一字从此法出。又无一字住此法中。亦无文字共相见者。亦不分别法与非法。是诸文字说亦不减不说无增。从本以来无起造者无坏灭者。善男子。如文字心亦如是。如心一切法亦如是。何以故。法离言语亦离思量。本无生灭故无出入。是名众法不入陀罗尼。若能通达此法门者辩才无尽。何以故。通达不断无尽法故。善男子。能入虚空者则能入此陀罗尼门。善男子。菩萨摩诃萨。能通达此陀罗尼门。心得清净身口亦尔。所行附理般若坚固。一切众魔无有能乱。一切外道不敢视瞻。一切烦恼莫之能坏。身力成就心离怯弱。所说无尽能宣甚深一切圣谛。智慧多闻犹如大海。安住三昧喻须弥山。处众无畏如师子王。世法不染犹彼莲华。利益众生譬之大地洗诸垢秽喻如大水。成熟世间以方大火。清凉平等能悦众心。类之如月。能破诸暗譬其以日。摧烦恼怨名为勇健。心性调伏犹如大龙。能震法雷大云为喻。普雨众法譬之大雨。为诸众生除烦恼病犹彼良医。以法治世譬如国王。能护众生及护正法等四天王。于人天中财富最胜犹如帝释。心得自在譬大梵王自在王领娑婆世界。身得无碍如伽娄罗鸟。教示众生如世间父。能出法宝类毗沙门王能出众宝。功德智慧之所庄严。众生见者无不利益。诸佛世尊之所称赞。一切天众咸拥护之。善男子。菩萨摩诃萨。得是众法不入陀罗尼门。种种自在利益众生。方便说法而不穷尽。心无疲倦不求名利。法施平等无有嫉妒。持戒清净于身口意永无愆失。忍辱清净离诸嗔恼。精进清净所作办立。禅定清净善调伏心。般若清净悉无疑滞。具四无量犹如梵王。行诸三昧三摩跋提。世间最胜修无上道。具诸功德一切智慧受灌顶位。说是陀罗尼法门时。众中六万四千菩萨得不退转。三万菩萨得无生法忍。二万人天得远尘离垢法眼净。无量无边人天发阿耨多罗三藐三菩提心

    胜天王般若波罗蜜经陀罗尼品第十二

尔时文殊师利菩萨摩诃萨。即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。希有世尊。如来所说。菩萨摩诃萨得是众法不入陀罗尼。所成功德无量无边。尔时佛告文殊师利菩萨言。善男子。如是功德。假使如来百千年说亦复不尽。尔时众中有一菩萨摩诃萨名寂静意。白文殊师利菩萨言。菩萨摩诃萨。得是陀罗尼。为佛世尊之所赞叹。如此之人善得大利。自行化彼皆悉不空。尔时文殊师利菩萨答寂静意菩萨摩诃萨言。善男子。第一义中无法可赞无色无相。无色相者有何可赞。无可赞故于何欢喜。寂静意菩萨白文殊师利菩萨言。如我闻佛修多罗中说。一切法无我我所。无能令喜无能令嗔。此法平等菩萨应学。譬如大地。住在水上。若凿井池即得用水。其不凿者无由致之。如是圣智境界遍一切法。若有勤修般若方便即便得之。其不修者云何能得。是故菩萨欲求菩提。不得懈怠勤修精进。如是之法则在现前。善男子。如生盲人不能见色。如是烦恼盲诸众生不能见法。如人有眼无外光明不能见色。行人如是。虽有智慧无善知识不能见法。如有天眼不假外明自能见色。菩萨摩诃萨入法流者自然胜进。如在胎者日日增长而不自见。菩萨摩诃萨勤行精进亦不自见众行增长。而能成就一切佛法。譬如雪山有药树王不枯不析。菩萨摩诃萨勤修精进。一切众行不退不失。譬如转轮圣王。出现于世则具七宝。菩萨摩诃萨发菩提心具七法宝。所谓布施持戒忍辱精进禅定智慧及方便力。又如转轮圣王游四天下。于诸众生其心平等。菩萨摩诃萨以四摄法利益众生亦复如是。又如转轮圣王所在之处则无诤讼。菩萨摩诃萨如实说法亦无诤论。譬如三千大千世界初成。即有须弥山王及以大海。菩萨亦尔。若发阿耨多罗三藐三菩提心。即有般若及以大悲。譬如日出其高山者先照光明。菩萨摩诃萨得般若炬。高行菩萨善根熟者先照其光。譬如大地荷负一切。华果树木草药皆悉平等。菩萨摩诃萨得是陀罗尼门。于诸众生其心平等。尔时世尊赞寂静意菩萨摩诃萨言。善男子。如汝所说。善男子。菩萨摩诃萨得是陀罗尼门。凡有所说一文一字无非佛语。善男子。此所说法离色声香味触。何以故。非世法故。无尽无边能入一切身心轻利。假使百千佛前说者亦不怯弱。何以故。此菩萨摩诃萨。得佛住持力故心无所著。不着我。不着众生。不着法。即得清净法界。清净如来。清净实际。得法无尽。字无尽。说无尽。即生欢喜。得般若故。得阇那故。无疑网故。说是陀罗尼法门时。众中八千菩萨得此众法不入陀罗尼。一万二千菩萨得不退转。五千菩萨得无生法忍。一万六千天子得远尘离垢法眼净。无量无边众生发阿耨多罗三藐三菩提心。尔时世尊告寂静意菩萨言。此陀罗尼能伏众魔。破诸外道及憎嫉法人。灭烦恼火然般若灯。拥护法师令至涅槃。调伏自心善化外众。美身威仪见者欢喜。为正行人平等说法。如实观察众生根性不前不后。说是法时。三千大千世界诸须弥山及以大海皆悉震动。诸天雨华。曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。优钵罗华。拘物头华。分陀利华。迦摩罗华。诸天空中作众音乐不鼓自鸣。尔时世尊告寂静意菩萨言。善男子。过去之世无量无边不可数不可数劫。有佛出世名曰宝月如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名无毁。劫名欢喜。声闻弟子三十二亿。菩萨摩诃萨无复数量。是佛成道无有苦行及降天魔。时彼众中有一菩萨名宝功德。辩才巧妙种种说法。尔时大众请佛住世勿入涅槃。时宝功德菩萨告大众言。如来世尊无生无灭。何用劝请勿入涅槃。若虚空入涅槃如来乃入涅槃。若实际真如法界不思议界入涅槃。如来乃入涅槃。何以故。如来之法无成无坏无染无净。非世出世有为无为非断非常。假令一口而有十舌。是一一舌复生百舌。是一一舌复生千舌。亦不能说如来成坏。宝功德菩萨说此法时。八万六千菩萨得不退转。七千菩萨得无边功德陀罗尼。悦意陀罗尼。无碍陀罗尼。欢喜陀罗尼。大悲陀罗尼。月爱陀罗尼。月光陀罗尼。日爱陀罗尼。日光陀罗尼。须弥山陀罗尼。大海陀罗尼。德王陀罗尼。三万六千人天得远尘离垢法眼净。佛告寂静意菩萨言。尔时宝功德菩萨岂异人乎。即汝身是。以此因缘汝能说是陀罗尼门。尔时文殊师利菩萨而说偈言

  总持如妙药　　能疗众惑病
  犹彼天甘露　　得者永不死

尔时功德华王菩萨而说偈言

  总持无文字　　文字显总持
  般若大悲力　　离言文字说

尔时珊兜率陀天王即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。世尊。诸佛如来不可思议。诸佛说法亦不可思议。诸大菩萨所行所说亦不可思议。我等诸天宿世之中善根深厚。得值如来闻说是法。即以种种天诸宝华天华天香。散佛如来以为供养。尔时世尊告珊兜率陀天王言。大王。凡欲供养佛如来者当修三法。所谓发阿耨多罗三藐三菩提心。护持正法。如闻修行。大王。若有修行此三法者。是人名为供养如来。大王。假使如来寿命一劫住世。说此供养福报不能穷尽。是故大王。若欲供养佛如来者。具此三法乃名供养。大王。若有护持如来一四句偈。是人则为拥护过去现在未来诸佛阿耨多罗三藐三菩提。何以故。诸佛如来皆从法生。法供养者名真供养。一切资财所不能及。法供养者诸供养中最为第一。尔时世尊告珊兜率陀天王言。我念过去无量无边阿僧祇阿僧祇劫数行菩萨道时闻虚空中诸天说偈

  天人远离大宝藏　　王贼水火所去失
  百千万劫法难闻　　得闻不持不施等
  道心为本化众生　　如实修行心寂静
  自利利他平等心　　如是修行供养佛

大王。我于往昔初闻此偈即为他说。有八千人发阿耨多罗三藐三菩提心。是故大王。以法供养最为第一。何以故。一切诸佛从法生故

胜天王般若波罗蜜经卷第六胜天王般若波罗蜜经卷第七

        陈优禅尼国王子月婆首那译

    劝诫品第十三

尔时文殊师利菩萨即从座起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。世尊。如来所说甚深般若波罗蜜。于未来世末代之中。颇有众生能信受不。若善男子善女人。闻是修多罗生信不谤。如此等人成何功德。佛告文殊师利菩萨言。未来末世有善男子善女人。无量佛所修持净戒禅定般若。是佛真子。能信此修多罗。所致功德不可称计。最善胜法从般若生。净心信受。我今为汝。略以譬说。文殊师利。阎浮提洲纵广七千由旬。北广南狭。其中人面亦似地形。洲内遍满须陀洹斯陀含阿那含阿罗汉辟支佛等。密如竹麻甘蔗荻林。中无少空及以间缺。若有善男子善女人。四事供养毕圣人寿。或复七宝遍满此洲积至梵天。一一圣人各施尔许毕。是善男子善女人寿。日夜三十牟尤多相续不断。文殊师利。于意云何。此人以是因缘功德多不。文殊师利菩萨白佛言。甚多婆伽婆。甚多修伽陀。佛告文殊师利菩萨。若善男子善女人不谤此修多罗功德。胜彼百分不及一。千分百千万分不及一。乃至算数譬喻所不能及。文殊师利。瞿耶尼洲纵广八千由旬。形如半月人面亦尔。洲内遍满须陀洹斯陀含阿那含阿罗汉辟支佛。密如竹麻甘蔗荻林。中无少空及以间缺。若有善男子善女人。四事供养毕圣人寿。至涅槃后舍利起塔。或复七宝遍满此洲积至梵天。一一圣人各施尔许毕。是善男子善女人寿。日夜三十牟尤多相续不断。文殊师利。于意云何。此人以是因缘得福多不。文殊师利菩萨白佛言。甚多婆伽婆。甚多修伽陀。佛告文殊师利菩萨。若善男子善女人。信此修多罗功德。胜彼百分不及一。千分百千万分不及一。乃至算数譬喻所不能及。文殊师利。弗于逮洲纵广九千由旬。形如满月人面亦尔。洲内遍满须陀洹斯陀含阿那含阿罗汉辟支佛。密如竹麻甘蔗荻林。中无少空及以间缺。若有善男子善女人。四事供养毕圣人寿。或复七宝遍满此洲积至梵天。一一圣人各施尔许毕。是善男子善女人寿。日夜三十牟尤多相续不断。文殊师利。于意云何。此人以是因缘得福多不。文殊师利菩萨白佛言。甚多婆伽婆。甚多修伽陀。文殊师利。郁单越洲辟方十千由旬。人面亦方。洲内遍满须陀洹斯陀含阿那含阿罗汉辟支佛。密如竹麻甘蔗荻林。中无少空及以间缺。若善男子善女人。四事供养毕圣人寿。或复七宝遍满此洲积至梵天。一一圣人各施尔许毕。是善男子善女人寿。日夜三十牟尤多相续不断。文殊师利。于意云何。此人以是因缘得福多不。文殊师利菩萨白佛言。甚多婆伽婆。甚多修伽陀。佛告文殊师利菩萨。若善男子善女人。受持读诵此修多罗功德。胜彼百分不及一。千分百千万分不及一。乃至算数譬喻所不能及。文殊师利。娑婆世界悉为微尘。尔许圣人。若有善男子。善女人。四事供养毕圣人寿。尔许尘数三千大千世界满中七宝积至阿迦尼吒天。一一圣人各施尔许毕。是善男子善女人寿。文殊师利。于意云何。功德多不。文殊师利菩萨白佛言。世尊。前之福德已不可思议。况此功德。佛告文殊师利菩萨。若善男子善女人。流通此修多罗为他宣说。功德胜彼。百分不及一。千分百千万分不及一。乃至算数譬喻所不能及。文殊师利。如此功德。若不回向阿耨多罗三藐三菩提者。尔许微尘数劫作他化自在天王。尔许劫数作化乐天王。尔许劫数作兜率陀天王。尔许数劫作夜摩天王尔许数劫作天帝释。况复转轮圣王。回向萨婆若故。能得成就般若波罗蜜阿耨多罗三藐三菩提。文殊师利。阎浮提中遍满须陀洹斯陀含阿那含阿罗汉辟支佛。密如竹麻甘蔗荻林。若有恶人。皆悉杀害尔许贤圣。文殊师利。于意云何。是人以此因缘得罪多不。文殊师利菩萨白佛言。世尊。杀一圣人尚于一劫堕阿鼻地狱。何况尔许。其罪甚多不可称计。佛告文殊师利菩萨言。有人谤此修多罗者。其罪重彼百分不及一。千分百千万分不及其一。乃至算数譬喻亦不能及。文殊师利。瞿耶尼中遍满须陀洹斯陀含阿那含阿罗汉辟支佛。密如竹麻甘蔗荻林。若有恶人皆悉杀害。文殊师利。于意云何。此人以是因缘得罪多不。文殊师利菩萨白佛言。世尊。此罪不可闻不可闻。是人无有出阿鼻地狱期。佛告文殊师利菩萨言。有人不信此修多罗。其罪重彼百分不及一。千分百千万分不及一乃至算数譬喻所不能及。文殊师利。若四天下悉为微尘。尔许尘数诸佛如来。若有恶人皆悉杀害夺二种财。灭法财。破世财。文殊师利。于意云何。是人得罪多不。文殊师利菩萨白佛言。世尊。此罪不可闻不可计不可思量。佛告文殊师利菩萨。若复有人障碍此修多罗毁谤不信。其罪重彼百分不及一。千分百千万分不及一。乃至算数譬喻所不能及。假使三千大千世界一切众生。悉成阿耨多罗三藐三菩提已。如此恶人犹故不出阿鼻地狱。文殊师利。如是恶人。无一世界阿鼻地狱不经入者。况余地狱畜生饿鬼。何以故。毁坏三世诸佛母故。假使如前微尘数劫得离三涂。若生人中得阿萨阇病。又经尔许微尘数劫。得无舌报若无手报各经尔劫。文殊师利。我若住世一劫若减一劫。以佛神力说是恶人所得罪报不能究尽。文殊师利。若求现在未来世乐。勿得于此修多罗中。毁谤不信作大障碍

    胜天王般若波罗蜜经二行品第十四

尔时佛告文殊师利菩萨言。菩萨摩诃萨行般若波罗蜜。宜应成就前后般若波罗蜜。何以故。菩萨摩诃萨有二种行。成就般若教化众生。文殊师利菩萨白佛言。世尊。云何菩萨摩诃萨教化众生。佛告文殊师利菩萨言。从初般若乃至后际。离功用心说法无尽中不间隙。为脱三有恶趣之报。安诸众生令住善道得三圣果。文殊师利。是名菩萨摩诃萨行般若波罗蜜教化众生。文殊师利。菩萨摩诃萨行般若波罗蜜。成就无边无为。是名菩萨摩诃萨自行。何以故。成就一切德故。文殊师利菩萨白佛言。世尊。何等法与菩萨摩诃萨般若波罗蜜相应。佛告文殊师利菩萨言。一切种智。真实之法远离思量。微妙无相道理甚深。不可得见难以通达。常住寂静清凉遍满。无有分别无著无碍。随顺道理不可取执。大寂极静。一切法中最为无上无与等者。文殊师利。菩萨摩诃萨行般若波罗蜜。修此等法与萨婆若相应。文殊师利菩萨白佛言。世尊。菩萨摩诃萨于何境界行般若波罗蜜。佛告文殊师利菩萨言。菩萨摩诃萨行般若波罗蜜。甚深境界。广大境界。功德境界。文殊师利。甚深境界者。体是无为。不可相离不着二边。脱离诸障自性清净。不可思量不可数知。不与声闻辟支佛共。文殊师利。广大境者。菩萨摩诃萨行般若波罗蜜。诸佛如来一切功德。般若波罗蜜摩诃迦楼那二法为体。离分别相无功用心利益众生。皆称彼意无时暂舍。文殊师利。菩萨摩诃萨行般若波罗蜜。与一切功德相应。三十二相八十种好。佛威神力悉能示现种种相貌。随诸众生根欲性行。或升兜率或从彼下。或现处胎。或现初生。或现童子。或园游戏。或现出家。或现苦行。或诣菩提树。或现成佛。或现转法轮。或现涅槃。如是种种为诸众生。尽竭生死。文殊师利。是名菩萨摩诃萨行般若波罗蜜境界。文殊师利菩萨白佛言。希有世尊。如此甚深般若波罗蜜。诸佛境界不可思议。佛告文殊师利菩萨言。如是如是。如汝所说。般若波罗蜜是不共法不可思议。何以故。一切凡夫声闻缘觉。不能通达。非其境界故。除佛如来更无得者。何以故。如如之理义甚深故。自在不动无漏界摄。教化众生利益圆满。是以名为诸佛境界。过诸语言第一义摄。无有觉观分别思量绝诸譬类。一切法中最为上品。不住生死不住涅槃。文殊师利。菩萨摩诃萨行般若波罗蜜。凡有五事不可思议。一者自性。二者方处。三者住。四者一异。五者利益。文殊师利。云何自性不可思议。色即是如求不可得。离色有如求不可得。受想行识亦复如是。地大即如求不可得。离地求如亦不可得。水火风大一切皆尔。眼入即如求不可得。离眼求如亦不可得。耳鼻舌身意一切皆尔。有法是如求不可得。无法是如亦不可得。若在欲界不可思议。若离欲界亦不可思议。色无色界一切皆尔。若在东方不可思议。若离东方不可思议。南西北方四维上下一切皆尔。安乐住不可思议。寂静住不可思议。有心住不可思议。无心住不可思议。三世如来同在一处。自性清净无漏法界。若一若异不可思议。智慧神力同一法界。般若方便二相平等。能为众生无量利益。不可宣说过言语境。而能随顺众生根性。作种种说种种示现。三十二相八十种好。随众生意如是现之。文殊师利菩萨白佛言。世尊。何等名为三十二相八十种好。佛告文殊师利菩萨言。如来相好无穷无边说不可尽。随顺世法。是以略说三十二相八十种好。一足下平满。二行步平正三足下轮相悉具毂辋千辐庄严。四手指纤长软直节骨不现。五身大方正。六手足指网缦合犹如鹅王。七手掌如红莲华。八踝骨不现。九咽尼鹿王膊。十身软直。十一阴马藏。十二身分满足如尼拘卢陀树。十三身毛右旋。十四一孔一毛皮肤细滑不受尘垢。十五身金色。十六圆光一丈。十七七处满。十八师子臆。十九两臂平正腋下满。二十两臂圆直如象王鼻。立垂过膝。二十一口四十齿齐密相连白如珂雪。二十二上下四牙状如初月。二十三师子额。二十四头团圆。二十五咽喉具足千脉。二十六胸骨如那罗延。二十七顶骨自然踊起。二十八舌相广长如莲华叶。二十九音声如梵王天鼓。三十眼目青色如优钵罗华。三十一眼睫绀焰犹如牛王。三十二眉间白毫。文殊师利。是名三十二相。菩萨摩诃萨行般若波罗蜜。悉能成就如是功德。文殊师利。云何名为八十种好。一无能见顶。二顶骨坚实。三额广平正。四眉高而长形如初月。绀琉璃色。五目广长。六鼻高圆直而孔不现。七耳厚广长埵轮成就八身坚实如那罗延。九身分不可坏。十身节坚密。十一合身回顾犹如象王。十二身有光明。十三身调直。十四常少不老。十五身恒润泽。十六身自将卫不待他人。十七身分满足。十八识满足。十九容仪具足。二十威德远震。二十一一切向不背他。二十二住处安隐不危动。二十三面门如量不大不长。二十四面广而平。二十五面圆净如满月。二十六无瘁容。二十七进止如象王。二十八容仪如师子王。二十九行步如鹅王。三十头如摩陀那果。三十一身色光悦。三十二足趺厚三十三爪如赤铜叶。三十四行时印文现地。三十五指文庄严。三十六指文明了不暗。三十七手文明直。三十八手文长。三十九手文不断。四十手足如意。四十一手足红白色如莲华。四十二孔门相具。四十三行步不减。四十四行步不过。四十五行步安平。四十六脐深厚状如盘蛇团圆右转。四十七毛色青红如孔雀项。四十八毛色润净。四十九身毛右靡。五十口出无上香身毛皆尔。五十一唇色赤润如频婆果。五十二唇润相称。五十三舌形薄。五十四一切乐观。五十五随众生意和悦与语。五十六于一切处无非善言。五十七若见人先与语。五十八音声不高不下随众生乐。五十九说法随众生语言。六十说法不着。六十一等观众生。六十二先观后作。六十三发一音答众声。六十四说法次第皆有因缘。六十五无有众生能见相尽。六十六观者无厌。六十七具足一切音声。六十八显现善色。六十九刚强之人见则调伏。恐怖者见即得安隐。七十音声明净。七十一身不倾动。七十二身分大。七十三身长。七十四身不染。七十五光遍身各一丈。七十六光照身而行。七十七身清净。七十八光色润泽犹如青珠。七十九手足满。八十手足德字

    胜天王般若波罗蜜经赞叹品第十五

尔时文殊师利菩萨即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。世尊。如来功德希有无等不可思议。三世诸佛同一无别。若见如来或闻功德。此等众生亦不可思议。我等今日重见世尊转大法轮。欢喜踊跃得未曾有。尔时文殊师利菩萨。即升虚空高七多罗树。合掌赞曰

  一切众生　　唯佛大尊　　尚无等者
  况当有胜　　人法二空　　理无等等
  唯佛如来　　等无等等　　烦恼习气
  永尽无余　　所知之法　　皆悉明了
  若智若说　　无及佛者　　大千世界
  唯佛独尊　　十力无畏　　决定不虚
  若释若梵　　所不能得　　世尊大恩
  于诸众生　　此事难思　　无能及者
  无量善巧　　种种方便　　以为众生
  令得利益

尔时众中有一天子。名苏楼波。(陈言妙色)即从座起。偏袒右肩右膝着地。合掌向佛头面作礼。说偈赞云

  世间或说等佛者　　如是之言名口过
  若说法王最极尊　　此非虚妄为实语
  人天之俦正问难　　无有能折我大师
  善逝降魔及外道　　将导世间至解脱
  清净四辩无穷说　　甘露妙药施众生
  遍观诸法智无碍　　一切念中不减失
  大悲平等视众生　　清净之心世不染
  善能了知根欲性　　随所乐闻而应说
  烦恼差别非一种　　为示无量对治门
  巧说因缘无如佛　　专以利益众生故
  值佛闻法不得道　　是等众生度极难
  如来大名应渴仰　　得见世尊无限益
  佛智能令心清净　　既闻正教出生死
  闻佛名号大吉祥　　忆念世尊恒喜乐
  发心诣佛生慧解　　如教勤修成种智
  戒品清净故无垢　　禅定第一心澄明
  智惠最胜故难动　　法海清净如甘露
  一切众生喜放逸　　诸佛如来离世间
  等慈众生如一子　　恩德深厚无能报
  先说破诸结贼法　　久摧天魔幻化军
  世尊已说三有过　　广示涅槃无量德

尔时众中有一天子。名苏那摩(陈言善名)即从座起。偏袒右肩右膝着地。合掌向佛头面作礼。说偈赞云

  如来世尊行大悲　　设可度智与他者
  尚令调达最前得　　况复其余众生类
  我今不惬为空过　　修治正行报佛恩
  有人已证无漏灭　　是于佛恩未为报
  若能修行佛正教　　乃得名为真佛子
  佛久勤苦为众生　　无上大恩罕能报
  大慈开显真实法　　令人修行兼化他
  若佛如来不出世　　一切众生受大苦
  无复善道唯恶趣　　但闻三涂苦恼声
  六道受苦无免脱　　烦恼系缚众生故
  世尊能解他毒结　　翻为大悲之所萦
  佛是世间大福田　　依教正修离恶道
  若违佛教不修行　　是人永无生善趣
  有人于佛起恶心　　或复不乐闻深法
  是等众生甚可悲　　决定永当处黑暗
  如佛世尊自知智　　其等如来乃能了
  佛智非我所量测　　头面敬礼十方尊
  无畏智力不共法　　唯佛世尊独圆备
  相好庄严微妙音　　观者无厌超众色
  三种开敷不暂息　　清净佛华我今礼
  唯佛善知无上道　　出离一切诸险难
  佛为无上最第一　　头面敬礼两足尊
  佛以功德正法水　　洗诸垢秽悉无余
  世尊本来内外净　　我今顶礼真净身

尔时娑婆世界主大梵天即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼以偈赞云

  功德智慧佛具足　　利益众生不暂休
  常雨甘露令众饱　　我今顶礼能利他
  世间最胜可敬者　　此人犹故恭敬佛
  诸恶斯尽众善备　　我今顶礼无等尊
  靡有一行不修学　　为欲救拔众生故
  今度生死得安乐　　我今顶礼救世师
  敬礼微妙金色身　　敬礼所说甘露法
  敬礼清净无垢智　　敬礼一切功德林

尔时世尊告大梵天言。善哉善哉。如大梵天所赞。世尊。此事真实。何以故。诸佛如来于无量劫。修习种种功德智慧。是故得果无不备足。何以故。具足檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。身清净。口清净。意清净。以是清净故能通达如如实际。诸佛世尊住此实际所言不虚。尔时大梵天即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言。唯愿世尊。以住持力令此般若波罗蜜久在世间。佛告大梵天言。十方三世诸佛住持力。咸皆拥护是般若波罗蜜。世间若天若魔沙门婆罗门。无有能坏作障碍者。何以故。我念过去世。有佛名宝月如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名不毁劫名赞叹。是佛众中有二比丘。而为法师善能说法。一名智盛。二名实与。是二比丘随佛转法轮。正经一劫。三千大千世界百亿诸魔。悉皆受化发菩提心。尔时扇多意菩萨摩诃萨即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼而白佛言世尊。宝月如来为犹在世已入涅槃。佛告扇多意菩萨言。善男子。东方去此过十百千亿诸佛世界。有一世界名曰不毁。佛寿十千劫。彼佛国土说般若波罗蜜。无有天魔及诸外道能为障碍。皆悉发心向阿耨多罗三藐三菩提。智盛比丘即文殊师利菩萨是。实与比丘即胜天王是。此等二人善巧方便种种拥护。令般若波罗蜜久久住世。十方佛土说般若波罗蜜。此之二人即来听受。犹我今日放大光明。寻光来集

    胜天王般若波罗蜜经付嘱品第十六

尔时世尊告阿难言。汝可受持此般若波罗蜜修多罗。尔时阿难即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼白佛言世尊。云何受持。佛告阿难言。受持此修多罗有十种法。何等为十。一者书写。二者供养。三者流传。四者谛听。五者自读。六者忆持。七者广说。八者口诵。九者思惟。十者修行。阿难。此十种法能受持此修多罗阿难譬如大地一切树林花药皆依而生。一切善法皆依般若波罗蜜生。阿难。譬如转轮圣王若在世间七宝常现。般若波罗蜜亦复如是。此修多罗若在世间。则三宝种常不断绝。尔时大众一时咸同观如来面。异口共音俱发声言。诸善男子。如来灭后谁能荷负。世尊。如是之大重担。无量无边阿僧祇劫。所可修习阿耨多罗三藐三菩提。尔时众中有一万二千菩萨摩诃萨。为护持法故。即从坐起偏袒右肩。右膝着地合掌向佛。头面作礼说偈赞云

  我等舍身命　　不求未来报
  护持甚深法　　世尊之所说

尔时众中五百天子贤王为上首。即从坐起。偏袒右肩右膝着地合掌向佛头面作礼。说偈赞云

  为度诸众生　　成就大悲愿
  护持甚深法　　世尊之所说

尔时释提桓因尸弃大梵毗沙门天王。即从坐起。偏袒右肩右膝着地。合掌向佛头面作礼。说偈赞云

  般若微妙药　　能治一切病
  我等顶戴持　　世尊之所说

尔时执金刚神即从坐起。偏袒右肩右膝着地。合掌向佛头面作礼。说偈赞云

  法本无名字　　佛以名字说
  世尊大悲教　　我等顶戴持

尔时世尊告尸弃梵天言。梵天。佛有三事最为无上。何等为三。一者能发阿耨多罗三藐三菩提心。二者护持正法。三者如闻修行。梵天。如此三法最为无上。若复有人能修行者。此人名为供养如来。佛若在世一劫若减一劫。说彼功德不能究尽。梵天。若护持如来一四句偈。是人功德尚不可量况复般若波罗蜜三世佛母。何以故。梵天。诸佛如来皆从般若波罗蜜生。以法供养。即是供养诸佛如来。不以赀财而为供养。法供养者诸供养中最为第一。梵天。有人护持如来正法。当知此人二世安乐。是故梵天。应须护持甚深修多罗。梵天。梵天以拥护法故。得见贤劫千佛悉为请主。梵天于此秽土护持正法须臾之间。胜在净土过一劫若一劫。是故宜应勤加精进拥护正法。尔时世尊复告释提桓因言。憍尸迦。所在之处有此般若波罗蜜修多罗。当知即是如来得菩提处。转法轮处。示涅槃处。何以故。憍尸迦。一切菩萨一切善法一切诸佛。皆从此修多罗生。憍尸迦。若有法师流通此修多罗处。此地即是如来所行。于彼法师当生善知识心尊重之心。犹如佛心。见是法师恭敬欢喜尊重赞叹。憍尸迦。若我住世一劫若减一劫。说是流通此修多罗法师功德不能究尽。憍尸迦。若此法师所行之处。善男子善女人。宜应刺血洒地令尘不起。如是供养未足为多。何以故。如来法轮难受持故。尔时释提桓因白佛言。世尊。未来世中说是修多罗处。我及眷属拥护彼地及说法者。若见彼有修多罗处。即生前四种处心。尔时世尊赞天帝释言。善哉善哉。憍尸迦。以此修多罗付嘱。憍尸迦。未来末世拥护流通。尔时释提桓因白佛言。世尊。我等诸天得生善道。皆悉由此修多罗故。求阿耨多罗三藐三菩提。亦复由此修多罗故。我当不顾身命拥护正法。佛言。憍尸迦。如闻修行。善哉善哉。佛说是修多罗已。胜天王及十方诸大菩萨众。一切声闻众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻佛所说信受奉行

胜天王般若波罗蜜经卷第七

    经序

仁王般若经初众相谓曰大觉世尊前已为我二十九年说摩诃般若金刚般若天王问般若光赞般若则此经目题久传上国有梁太清二年六月于阗沙门求那跋阤(陈言德贤)赍一部梵文凡十六品始湏京师时中天竺优禅尼国王子月首那生知后朗世传释学无精义味兼善方言避难本邦登仕梁室被敕摠知外国使命忽见德贤有此经典敬恋宜怀如对真佛因从祈请毕命弘宣德贤嘉雅操灵心授与首那即又[石*(式-工+口)]敕求使顾表奉迎杂华经辞阙甫尔便值侯量称丘寇乱顶戴逃亡未暇翻译民之所欲天必从焉属我大陈膺期[石*(式-工+口)]运重光累业再清四海车书混同华夷[車*(吳-大+月)]睦首那贫笈怀经自达而至江洲刺史仪同黄法[(〦/賏)*毛]驱传本洲锡圭分陜护持正法渴仰大乘以天嘉六年岁次乙酉七月辛已朔二十三日癸卯劝请首那于洲听事略开题序说无遮大会四众云集五千余人匡山释僧果法师及远迩名德并学冠百家博通五部各有硕难纷纶靡不涣然水释到其月二十九日还兴业伽蓝揵捶既响僧徒咸萃首那躬执梵文译为陈语杨洲阿育王寺释智昕暂游鼓汇伏应至教听笔疏一言敢失再三修环撰为七卷讫其年九月十八日文句乃尽江洲僧正释慧恭法师戒香芬郁定水澄明揩则具瞻陈梁是寄别驾豫章万骃洲之股胡材之杞梓信慧并修文武兼用教委二人经始功德辄附卷余略述时事庶将来君子或精焉


圣八千颂般若波罗蜜多一百八名真实圆义陀罗尼经

    No. 230

    圣八千颂般若波罗蜜多一百八名真实圆义陀罗尼经

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

  归命最胜诸佛母　　般若波罗蜜多法
  过去未来及现在　　一切诸佛从是生
  善生诸佛为佛母　　无性自性我清净
  佛为须菩提广说　　如其所说今略集

般若波罗蜜多有一百八名。一者最胜般若波罗蜜多二一切智。三一切相智四实际。五真如六无坏真如。七无异真如八实性。九如实生十不颠倒。十一空无相无愿十二无性。十三自性十四无性自性。十五法性十六法界。十七法定十八法住。十九法无我二十法相。二十一非众生二十二非寿命。二十三非长养二十四非士夫。二十五非补特伽罗二十六非语言。二十七非语言道二十八离心意识。二十九无等三十无等等。三十一无憍三十二无我三十三无戏论三十四离戏论。三十五过诸戏论三十六一切佛母。三十七出生一切菩萨三十八出生一切声闻缘觉。三十九长养摄持一切世间四十无尽福行具足。四十一运用智慧四十二起作神通。四十三作净天眼四十四作净天耳。四十五作他心智四十六作宿命智。四十七作漏尽智四十八圣清净。四十九吉祥五十安住四念处。五十一具四正断五十二运四神足。五十三诸根清净五十四诸力具足。五十五严七觉支五十六示八圣道。五十七施七圣财五十八圆满九次第定。五十九具十自在六十安住十地。六十一圆满十力六十二十遍处庄严。六十三运用十智六十四善作调伏十种胜怨。六十五出生诸禅定六十六超过三界。六十七妙住一切正遍知觉六十八具一切智智。六十九内空七十外空。七十一内外空七十二空空。七十三大空七十四胜义空。七十五有为空七十六无为空。七十七毕竟空七十八无际空。七十九散空八十无变异空。八十一共相空八十二自相空。八十三不可得空八十四无性空八十五自性空八十六无性自性空。八十七无起作八十八不生。八十九不灭九十不断。九十一不常九十二非一义。九十三非多义九十四非来。九十五非去九十六善观缘起。九十七非寻伺九十八无摄藏。九十九无所有一百本来无所作。一百一无二一百二非无二。一百三寂静慧无所趣一百四无系无染与虚空等。一百五离十相语一百六诸法自性犹如幻梦。一百七如陶家轮一百八一切法同一味。如是般若波罗蜜多一百八名。若常持诵者销灭一切罪。一切诸佛所共称赞。一切菩萨及诸贤圣。于长时中常所卫护。即说般若波罗蜜多真实圆义陀罗尼曰

怛[寧*也](切身)他(引一句)唵(引)钵啰(二合)倪(引)钵嚩(二合)倪(引二)摩贺(引)钵啰(二合)倪也(二合引)婆(引)西(引三)钵嚩(二合)倪也(二合引)路(引)葛葛哩(四)阿倪也(二合引)那尾[馬*犬]摩泥(五)悉提(引六)苏悉提(引七)悉奠睹弥(引)婆誐嚩底(八)萨哩嚩(二合)三钵怛野(九)萨哩网(二合)誐孙奈哩(十)薄讫底(二合)嚩蹉梨(引十一)钵啰(二合)萨(引)哩多诃萨底(二合引十二)摩(引)说(引)萨那葛哩(十三)底瑟姹(二合)底瑟姹(二合十四)绀波绀波(十五)左罗左罗(十六)誐嚩誐嚩(十七)誐哩惹(二合)誐哩惹(二合)(十八)阿(引)誐蹉阿(引)誐蹉(十九)婆誐嚩底摩(引)尾蓝摩莎(引)贺(引二十)提(引二十一)纥凌(二合引二十二)室凌(二合引二十三)率噜(二合)(引)底(二十四)三蜜哩(三合)底(二十五)尾惹曳(引)莎(引)贺(引二十六)

此陀罗尼秘密章句若常忆念受持读诵者。所获功德不可称计圣八千颂般若波罗蜜多一百八名真实圆义陀罗尼经


实相般若波罗蜜经

    No. 240 [Nos. 220(10), 241-244]

    实相般若波罗蜜经

        唐天竺三藏菩提流志译

如是我闻。一时婆伽婆。以善成就一切如来金刚正智之所建立。种种殊特超于三界灌顶宝冠。摩诃瑜伽自在无碍。获深妙智证平等法。所作功业皆已究竟。随众生心悉令满足。三世平等常无动坏。三业坚固犹如金刚普光明身。住欲界他化自在天王宫殿之中。其王宫殿种种严好。皆以大宝摩尼所成。缯盖幢幡众彩交映。珠璎宝铎风动成音。一切如来常所游践。咸共叹美吉祥第一。有菩萨摩诃萨八千万人。前后围绕供养恭敬。佛为说法初中后善。其义深远其语巧妙。纯一无杂清净圆满

其名曰金刚手菩萨。观自在菩萨。虚空藏菩萨。文殊师利菩萨。转法轮菩萨。降伏一切魔菩萨。如是等菩萨摩诃萨而为上首

尔时世尊在大众中。为诸菩萨说一切法自性清净实相般若波罗蜜法门。所谓爱清净位是菩萨位。见清净位是菩萨位。深着清净位是菩萨位。悦乐清净位是菩萨位。藏清净位是菩萨位。庄严清净位。是菩萨位。光明清净位是菩萨位。身清净位是菩萨位。语清净位是菩萨位。意清净位是菩萨位。色清净位是菩萨位。声清净位是菩萨位。香清净位是菩萨位。味清净位是菩萨位。触清净位是菩萨位。何以故一切法自性清净故。一切法自性清净。即般若波罗蜜清净

尔时世尊说此法门已。告金刚手菩萨言。金刚手。若有人得闻此一切法自性清净实相般若波罗蜜法门。一经于耳。是人所有烦恼障业障法障。极重诸罪皆自消灭。乃至菩提不生恶道。若复有人能日日中。受持读诵思惟修习。即于现身。得一切法平等性金刚三昧。余十六生。当于一切法门。而得自在游戏快乐。乃至当获诸佛如来金刚之身。尔时如来即说咒曰

唅(长呼)

尔时世尊复以一切如来普光明相。为诸菩萨说一切诸佛寂静性成正觉实相般若波罗蜜法门。所谓金刚平等成正觉。大菩提坚固性如金刚故。义平等成正觉。大菩提一义性故。法平等成正觉。大菩提自性清净故。一切平等成正觉。大菩提离一切分别故。尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人。得闻此四种寂静性成正觉实相般若波罗蜜法门。受持读诵思惟修习。应知是人即得超于一切恶道。疾证阿耨多罗三藐三菩提。尔时如来复说咒曰

唵(长呼)

尔时世尊复以一切如来能调伏难调众生释迦牟尼相。为诸菩萨。说一切法平等实相般若波罗蜜法门。所谓贪无戏论性。嗔无戏论性。痴无戏论性。何以故一切法无戏论性故。一切法无戏论性。即般若波罗蜜无戏论性

尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人。得闻此一切法平等实相般若波罗蜜法门。受持读诵思惟修习。假令其人杀害三界一切众生。终不因斯堕于恶道。何以故已受调伏心律仪故。当知是人疾得阿耨多罗三藐三菩提。尔时如来复说咒曰

憾(长呼)

尔时世尊复以一切如来自性清净相。为诸菩萨。说一切法平等性观自在智印实相般若波罗蜜法门。所谓一切世间贪性清净嗔性清净。一切世间贪性清净嗔性清净故。一切世间垢性清净罪性清净。一切世间垢性清净罪性清净故。一切世间法性清净众生性清净故。一切世间法性清净众生性清净故。一切世间智性清净。一切世间智性清净。即般若波罗蜜清净

尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人得闻此一切法平等观自在智印实相般若波罗蜜法门。受持读诵正念修习。是人虽在五欲尘中。不为贪欲诸过所染。譬如莲华虽在淤泥非泥所著。乃至疾得阿耨多罗三藐三菩提。尔时如来复说咒曰

咭利(短呼)

尔时世尊复以一切如来为三界主相。为诸菩萨。说一切诸佛灌顶出现智藏实相般若波罗蜜法门。所谓灌顶施。令一切得三界王位故。财宝施。令一切得所愿满足故。净法施。令一切得诸法实性故。饮食施。令一切身心获安乐故。尔时如来复说咒曰

怛缆(长呼)

尔时世尊复以一切如来常住智印秘藏相。为诸菩萨。说一切诸佛金刚智印甚深处实相般若波罗蜜法门。所谓一切诸佛所摄持金刚身印。得一切如来真实体性故。一切诸佛所摄持金刚语印。得一切法门自在故。一切诸佛所摄持金刚心印。得一切三昧具足故。一切诸佛所摄持金刚智印。得最上身语心如金刚故

尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人。得闻此一切诸佛金刚智印甚深处实相般若波罗蜜法门。受持读诵正念思惟。当知是人则得成就最上金刚印。于一切智及众事业。皆得圆满。身口意性犹如金刚。乃至当成阿耨多罗三藐三菩提。尔时如来复说咒曰

阿(短呼)

尔时世尊复以一切如来永离戏论相。为诸菩萨。说文字转轮品实相般若波罗蜜法门。所谓一切诸法空。无自性故。一切诸法无相。离众相故。一切诸法无愿。离诸愿故。一切诸法自性清净。般若波罗蜜清净故。尔时如来复说咒曰

阿(乌舸反短呼)

尔时世尊复以一切如来入广大转轮相。为诸菩萨。说入广大转轮实相般若波罗蜜法门。所谓入金刚平等性。得入一切如来转轮故。入义平等性。得入一切菩萨转轮故。入法平等性得入妙法转轮故。入一切平等。性得入一切转轮故。尔时如来复说咒曰

嚂(长呼)

尔时世尊复以一切如来大善巧方便相。为诸菩萨。说最第一广供养诸佛实相般若波罗蜜法门。所谓发菩提心。即为大善巧方便广供养一切诸佛。救护众生。即为大善巧方便广供养一切诸佛。住持正法。即为大善巧方便广供养一切诸佛。尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人。得闻此最第一广供养诸佛实相般若波罗蜜法门。若自书若教人书。若自受持若教人受持。若自读诵若教人读诵。若自思惟若教人思惟。若自供养若教人供养。随其所作。即为大善巧方便广供养一切诸佛。尔时如来复说咒曰

唵(长呼)

尔时世尊复以一切如来能调伏相。为诸菩萨。说能调能摄一切众生秘密智藏实相般若波罗蜜法门。所谓一切众生平等性。是嗔平等性。一切众生调伏性。是嗔调伏性。一切众生真法性。是嗔真法性。一切众生金刚性。是嗔金刚性。何以故一切众生调伏性。即是菩提故。尔时如来复说咒曰

荷(长呼)

尔时世尊复以一切如来住平等相。为诸菩萨。说一切法最胜平等性实相般若波罗蜜法门。所谓一切法平等性故。般若波罗蜜平等性。一切法第一义性故。般若波罗蜜第一义性。一切法法性故般若波罗蜜法性一切法业用性故。般若波罗蜜业用性。尔时如来复说咒曰

颉唎(长呼)

尔时世尊复以一切如来为众生依怙相。为诸菩萨。说一切众生依怙实相般若波罗蜜法门。所谓一切众生是如来藏。普贤菩萨体性遍故。一切众生是金刚藏。金刚藏水所灌洒故。一切众生是正法藏。是正言词所说性故。一切众生是妙业藏。善巧妙业所运为故。尔时如来复说咒曰

底唎(长呼)

尔时世尊复以一切如来无量无边际究竟尽相。为诸菩萨。说一切法无量无边际究竟尽平等实相般若波罗蜜法门。所谓般若波罗蜜无量故。一切诸佛亦无量。般若波罗蜜无边故。一切诸佛亦无边。般若波罗蜜一性故。一切诸法亦一性。般若波罗蜜究竟尽故。一切诸法亦究竟尽。尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人。得闻此无量无边际究竟尽实相般若波罗蜜法门。受持读诵正念思惟。此人所有一切障累。皆得消灭究竟无余。疾至菩提。获于如来金刚之身而得自在。尔时如来复说咒曰

骠(长呼)

尔时世尊。复以一切如来离戏论秘密法性普光明相。为诸菩萨。说大安乐金刚不空无碍决定入法性无初中后最第一实相般若波罗蜜法门。所谓诸菩萨能广大承事供养故。得最上大安乐。得最上大安乐故。得诸佛无上大菩提。得诸佛无上大菩提故。能降伏一切魔军。降伏一切魔军故。得于三界皆自在。于三界皆自在故。能遍饶益一切众生。悉与究竟最上安乐。何以故颂曰

  有最胜智者　　常在生死中
  广度诸群生　　而不入涅槃
  般若波罗蜜　　究竟方便智
  能成清净业　　普净于诸有
  又以于贪等　　调伏诸世间
  乃至有顶天　　清净无违暴
  在于生死世　　世法不能染
  如莲华妙色　　尘垢所不污
  大欲清净人　　大施安乐人
  于三界自在　　作坚固利益

尔时世尊说此法门已。复告金刚手菩萨言。金刚手若有人得闻此大安乐金刚法性实相般若波罗蜜法门。于日日中每清旦时。若听闻若诵念相续不绝。当知是人所有罪障皆自消灭。心常调畅第一安乐。于现身中。即得成就金刚不空无碍决定入法。复当成就一切如来金刚秘密坚固之身。尔时如来复说咒曰

莎诃(长呼)

尔时世尊为诸菩萨。说如上诸法门已。复告金刚手菩萨言。金刚手我此经典难可得闻。若有得闻乃至极少至于一字。应知是人过去已曾供养诸佛。于诸佛所种诸善根。何况有人具足听闻读诵之者。当知是人决定。已曾供养恭敬尊重赞叹八十亿那由他恒河沙等诸佛。若是经典所在之处。此地则为有诸佛塔。若复有人爱重此经。常随守护不离身者。是人应受一切世间恭敬供养。是人当得宿命智通。能知过去无量劫事。不为一切天魔波旬之所扰乱。四天大王及余诸天常随卫护。一切诸佛及诸菩萨恒共摄受。十方净土随愿往生。金刚手我今略说实相般若波罗蜜法门功德如是。若广说者穷劫不尽。佛说此经已。金刚手等诸菩萨。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切众会皆大欢喜信受奉行实相般若波罗蜜经


殊师利所说般若波罗蜜经

    No. 233 [Nos. 220(7), 232]

    文殊师利所说般若波罗蜜经

        梁扶南国三藏僧伽婆罗译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众一万人俱。及诸菩萨摩诃萨十万人俱。皆悉住于不退转地。久已供养无量诸佛。于诸佛所深种善根。成就众生净佛国土。得陀罗尼。获乐说辩才。成就智慧具足功德。以自在神通游诸佛世界。放无量光明说无尽妙法。教诸菩萨入一相门。得无所畏。善降众魔教化度脱外道邪见。若有众生乐声闻者说声闻乘。乐缘觉者说缘觉乘。乐世间者说世间乘。以布施持戒忍辱精进禅定智慧。摄诸众生。未度者度。未脱者脱。未安者安。未泥洹者令得泥洹。究竟菩萨所行。善入诸佛法藏。如是种种功德皆悉具足。其名曰文殊师利法王子菩萨。弥勒菩萨。普光明菩萨。不舍勇猛精进菩萨。药王菩萨。宝掌菩萨。宝印菩萨。月光菩萨。日净菩萨。大力菩萨。无量力菩萨。得勤精进菩萨。力幢相菩萨。法相菩萨。自在王菩萨。如是等菩萨摩诃萨十万人俱。并余天龙鬼神等一切大众。皆悉来集

尔时世尊于中夜时放大光明。青黄赤白杂颇梨色。普照十方无量世界。一切众生触此光者。皆从卧起见此光明。皆得法喜。咸生疑惑。此光何来普遍世界。令诸众生得安隐乐。作是念已。于一一光复出大光明。照耀殊特胜于前光。如是展转乃至十重。一切菩萨及诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。咸皆踊跃得未曾有。各各思念必是如来放此光明。我等应当疾至佛所礼拜亲近恭敬如来。是时文殊师利。及诸菩萨摩诃萨众遇此光者。欢喜踊跃充遍身心。各从住处到祇洹门。尔时舍利弗。大目揵连。富楼那弥多罗尼子。摩诃迦叶。摩诃迦旃延。摩诃俱絺罗。皆从住处到祇洹门。帝释四天王上至阿迦尼吒天。亦睹光明叹未曾有。与其眷属赍妙天花天香天乐天宝衣。一切皆悉到祇洹门。其余比丘比丘尼优婆塞优婆夷天龙八部。遇光欢喜皆来到门。尔时世尊一切种智。知诸大众悉已在门外。从住处起出至门外。自铺法座结加趺坐。告舍利弗。汝今晨朝来门外乎。舍利弗白佛言。世尊。文殊师利等菩萨摩诃萨。皆悉先至。尔时世尊告文殊师利。汝于晨朝先至门乎。文殊师利白佛言。如是世尊。我于中夜见大光明十重照耀。得未曾有心怀欢喜踊跃无量。故来礼拜亲近如来。并欲愿闻甘露妙法。尔时世尊告文殊师利。汝今真实见如来乎。文殊师利白佛言。世尊。如来法身本不可见。我为众生故来见佛。佛法身者不可思议。无相无形不来不去。非有非无非见非不见。如如实际不去不来。非无非非无非处非非处。非一非二。非净非垢不生不灭。我见如来亦复如是。佛告文殊师利。汝今如是见如来乎。文殊师利白佛言。世尊。我实无见亦无见相。尔时舍利弗白文殊师利。我今不解汝之所说。云何如是见于如来。文殊师利答舍利弗。大德舍利弗。我不如是见于如来。舍利弗白文殊师利。如汝所说转不可解。文殊师利答舍利弗。不可解者即般若波罗蜜。般若波罗蜜。非是可解非不可解。舍利弗白文殊师利。汝于众生起慈悲心不。汝为众生行六波罗蜜不复为众生入涅槃不。文殊师利答舍利弗。如汝所说。我为众生起慈悲心。行六波罗蜜。入于涅槃而众生实不可得。无相无形不增不减。舍利弗汝常作是念。一一世界有恒河沙等诸佛。住世恒河沙劫。说一一法。教化度脱恒河沙众生。一一众生皆得灭度。汝有如是念不。舍利弗言。文殊师利。我常作是念。文殊师利答舍利弗。如虚空无数众生亦无数。虚空不可度众生亦不可度。何以故。一切众生与虚空等。云何诸佛教化众生。舍利弗言。若一切众生与虚空等。汝何故为众生说法令得菩提。文殊师利答舍利弗。菩提者实不可得。我当说何法使众生得乎。何以故。舍利弗。菩提与众生不一不二。无异无为无名无相实无所有。尔时世尊出大人相肉髻光明。殊特希有不可称说。入文殊师利菩萨摩诃萨法王子顶。还从顶出普照大众。照大众已乃遍十方一切世界。是时大众触此光明。身心快乐得未曾有。皆从座起瞻仰世尊及文殊师利。咸作是念。今日如来放此奇特微妙光明。入文殊师利法王子顶。还从顶出普照大众。照大众已乃遍十方。非无因缘必说妙法。我等但当勤修精进乐如说行。如是念已。各白佛言。世尊。如来今日放此光明。非无因缘必说妙法。我等渴仰乐如说行。如是白已默然而住。尔时文殊师利白佛言。世尊。如来放光加我神力。此光希有非色非相。不去不来不动不静。非见非闻非觉非知。一切众生无所观见。无喜无畏无所分别。我当承佛圣旨说此光明令诸众生入无想慧

尔时佛告文殊师利。善哉。善哉汝善快说。吾助汝喜。文殊师利白佛言。世尊。此光明者是般若波罗蜜。般若波罗蜜者是如来。如来者是一切众生。世尊。我如是修般若波罗蜜。尔时佛告文殊师利言。善男子。汝今如是说深般若波罗蜜。我今问汝。若有人问汝有几众生界。汝云何答。文殊师利白佛言。世尊若人作如是问。我当答言。众生界数如如来界。文殊师利。若复问汝众生界广狭云何。汝云何答。文殊师利白佛言。世尊。若人作如是问。我当答言。如佛界广狭。文殊师利。若复问汝众生界系在何处。当云何答。世尊。我当答言。如如来系众生亦尔。文殊师利。若复问汝众生界住在何处。当云何答。世尊。我当答言。住涅槃界佛告文殊师利。汝如是修般若波罗蜜般若波罗蜜有住处不。文殊师利白佛言。世尊。般若波罗蜜无有住处。佛告文殊师利。若般若波罗蜜无住处者汝云何修。云何学。文殊师利白佛言。世尊。若般若波罗蜜有住处者。则无修学。佛告文殊师利。汝修般若时。有善根增减不。文殊师利白佛言。世尊。无有善根可增可减。若有增减则非修般若波罗蜜。世尊。不为法增不为法减。是修般若波罗蜜。不断凡夫法不取如来法。是修般若波罗蜜。何以故。世尊般若波罗蜜。不为得法故修。不为不得法故修。不为修法故修。不为不修法故修。世尊。无得无舍。是修般若波罗蜜。何以故。不为生死过患。不为涅槃功德故世尊。若如是修般若波罗蜜。不取不受不舍不放。不增不减不起不灭故。世尊。若善男子善女人。作是思惟。此法上此法中此法下。非修般若波罗蜜。何以故。无上中下法故。世尊。我如是修般若波罗蜜。佛告文殊师利。一切佛法非增上耶。文殊师利白佛言。世尊。佛法菩萨法声闻法缘觉法乃至凡夫法皆不可得。何以故。毕竟空故。毕竟空中。无佛法凡夫法。凡夫法中无毕竟空。何以故。空不空不可得故。佛告文殊师利。佛法无上不。文殊师利白佛言世尊。无有一法如微尘许名为无上。何以故。檀波罗蜜檀波罗蜜空。乃至般若波罗蜜般若波罗蜜空。十力十力空。四无所畏十八不共法乃至萨婆若萨婆若空。空中无无上。无上中无空。空不空毕竟不可得故。世尊。不可思议法是般若波罗蜜。佛告文殊师利。汝不思惟佛法耶。文殊师利白佛言。世尊。我若思惟佛法我则见佛法无上。何以故。无上无故。世尊。五阴十二入十八界毕竟不可得。一切佛法亦不可得。不可得中无可得不可得故。世尊。般若波罗蜜中凡夫乃至佛。无法无非法。我当思惟何法。佛言。善男子。若无思惟。汝不应说此凡夫法此缘觉法。乃至不应说此是佛法。何以故。不可得故。世尊。我实不说凡夫法乃至佛法。何以故。不修般若波罗蜜故。佛言。善男子。汝亦不应作如是意。此欲界此色界此无色界。何以故。不可得故。世尊。欲界欲界性空。乃至无色界无色界性空。空中无说我亦无说。世尊。修般若波罗蜜。不见上不见不上。何以故。世尊。修般若波罗蜜。不取佛法不舍凡夫法。何以故。毕竟空中无取舍故

佛告文殊师利。善哉善哉。汝能如是说深般若波罗蜜。此是菩萨摩诃萨印。文殊师利。若善男子善女人。非于千万佛所深种善根得闻此法。乃于无量无边佛所深种善根乃得闻此甚深般若波罗蜜不生怖畏。文殊师利复白佛言。世尊。我承佛威神当更说甚深般若波罗蜜。佛告文殊师利。善哉善哉。恣听汝说。文殊师利白佛言。世尊。若不得法生是修般若波罗蜜。何以故。诸法无有生故。若不得法住是修般若波罗蜜。何以故。诸法如实故。若不得灭是修般若波罗蜜。何以故。诸法寂灭故。世尊。若不得色是修般若波罗蜜乃至不得识是修般若波罗蜜。何以故。一切诸法如幻如焰故。世尊。若不得眼是修般若波罗蜜。乃至不得意是修般若波罗蜜。若不得色乃至法。不得眼界色界眼识界。乃至不得法界意识界。是修般若波罗蜜。若不得欲界是修般若波罗蜜。乃至无色界亦如是。世尊。若不得檀波罗蜜。是修般若波罗蜜。乃至不得般若波罗蜜。是修般若波罗蜜。若不得佛十力四无所畏乃至十八不共法。是修般若波罗蜜。何以故。内空故。乃至无法有法空故。世尊。若得生住灭。非修般若波罗蜜。若得五阴十二入十八界。非修般若波罗蜜。若得欲界色界无色界。非修般若波罗蜜。若得檀乃至般若。若得佛十力乃至十八不共法。非修般若波罗蜜。何以故。以有得故。世尊。若善男子善女人。闻此甚深般若波罗蜜。不惊不疑不怖不退。当知是人久于先佛深种善根。文殊师利复白佛言。世尊。若不见垢法净法不见生死果不见涅槃果。不见佛不见菩萨不见缘觉不见声闻不见凡夫。是修般若波罗蜜。何以故。一切诸法无垢无净。乃至无凡夫故。世尊。若见垢净乃至见凡夫。非修般若波罗蜜。世尊。若见垢法差别净法差别。乃至见佛差别。凡夫法差别。非修般若波罗蜜。何以故。般若波罗蜜无差别故。佛告文殊师利。善哉善哉。是真修行般若波罗蜜。文殊师利。汝云何供养佛。文殊师利白佛言。世尊。若幻人心数灭我则供养佛。佛告文殊师利。汝不住佛法耶。文殊白佛。佛无法可住。我云何住。佛告文殊师利。若无法可得谁有佛法。文殊白佛言。世尊。无有有佛法者。佛告文殊师利。汝已到无所著乎。文殊师利白佛。无著则无到。云何世尊问已到无著。佛告文殊。汝住菩提不。文殊白佛言。世尊。佛尚不住菩提。何况我当住菩提乎。佛告文殊师利。汝何所依作如是说。文殊师利白佛。我无所依作如是说。佛告文殊。汝若无依为何所说。文殊白佛。如是世尊。我无所说。何以故。一切诸法无名字故。尔时长老舍利弗白佛言。世尊。若菩萨摩诃萨闻此深法。不惊疑怖畏。必定得近阿耨多罗三藐三菩提不。尔时弥勒菩萨白佛言。世尊。若诸菩萨摩诃萨闻此深法。不惊疑怖畏。得近阿耨多罗三藐三菩提不。尔时有天女名无缘。白佛言。世尊。若善男子善女人闻此深法。不惊疑怖畏。当得声闻法缘觉法菩萨法佛法不。尔时佛告舍利弗。如是如是。舍利弗。若诸菩萨摩诃萨闻此深法。不惊疑怖畏。必定当得阿耨多罗三藐三菩提。是善男子善女人。当为大施主第一施主胜施主。当具足戒忍辱精进禅定智慧。当具诸功德成就相好。自不怖畏令人不怖畏。究竟般若波罗蜜。以不可得无相无为成就第一不可思议法故。佛告文殊师利。汝何所见何所乐。求阿耨多罗三藐三菩提。文殊师利白佛言。世尊。我无见无乐故求菩提。佛告文殊师利。若无见无乐亦应无求。文殊白佛。如是世尊。我实无求。何以故。若有求者是凡夫相。佛告文殊师利。汝今真实不求菩提耶。文殊白佛。我真实不求菩提。何以故。若求菩提是凡夫相。佛告文殊师利。汝为定求为定不求。文殊白佛。若言定求定不求。定求不求定。非求非不求。是凡夫相。何以故。菩提无住处故。佛告文殊师利。善哉善哉。汝能如是说般若波罗蜜。汝先已于无量佛所。深种善根久修梵行。诸菩萨摩诃萨应如汝所说行。文殊白佛。我不种善根不修梵行。何以故。我若种善根则一切众生亦种善根。我若修梵行则一切众生亦修梵行。何以故。一切众生则梵行相。佛告文殊师利。汝何见何证说如是语。文殊白佛。我无见无证亦无所说。世尊。我不见凡夫不见学不见无学。不见非学非无学。不见故不证。尔时舍利弗白文殊师利。汝见佛不。文殊答舍利弗。我尚不见声闻人。何况我当见佛。何以故。不见诸法故谓为菩萨。舍利弗白文殊师利。汝今决定不见诸法耶。文殊师利答舍利弗。大德大比丘。汝止不须复说。舍利弗白文殊师利。谓为佛者是谁语言。文殊师利答舍利弗。佛非佛不可得。无有言者无有说者。舍利弗。菩提者不可以言说。何况有佛可言可说。复次大德舍利弗。汝说佛者是谁语言。此语言不合不散。不生不灭不去不来。无有一法可与相应。无字无句。大德舍利弗欲见佛者当如是学。尔时舍利弗白佛言。世尊此文殊师利所说。新发意菩萨所不能解。文殊师利答舍利弗。如是如是。大德舍利弗。菩提非可解。新发意者云何当解。舍利弗白文殊师利。诸佛如来不觉法界耶。文殊师利答舍利弗。诸佛尚不可得。云何有佛觉法界。舍利弗。法界尚不可得。云何法界为诸佛所觉。舍利弗。法界者即是菩提。菩提者即是法界。何以故。诸法无界故。大德舍利弗。法界佛境界无有差别。无差别者即是无作。无作者即是无为。无为者即是无说。无说者即无所有。舍利弗白文殊师利。一切法界及佛境界。悉无所有耶文殊师利答舍利弗。无有无不有。何以故。有及不有一相无相无一无二故。舍利弗白文殊师利。如是学者当得菩提耶。文殊师利答舍利弗。如是学无所学。不生善道不堕恶趣。不得菩提不入涅槃。何以故。舍利弗。般若波罗蜜毕竟空故。毕竟空中无一无二无三无四。无有去来不可思议。大德舍利弗。若言我得菩提是增上慢说。何以故。无得谓得故。如是增上慢人不堪受人信施。有信人不应供养。舍利弗白文殊师利。汝何所依作如是说。文殊师利答舍利弗。我无所依作如是说。何以故。般若波罗蜜与诸法等故。诸法无所依以平等故。舍利弗白文殊师利。汝不以智慧除断烦恼耶。文殊师利答舍利弗。汝是漏尽阿罗汉不。舍利弗言。不也。文殊师利言。我亦不以智慧除断烦恼。舍利弗言汝何所依作如是说。不怖不畏。文殊师利言。我尚不可得。当有何我而生怖畏。舍利弗言。善哉文殊师利。快说如是甚深般若波罗蜜。尔时佛告文殊师利言。善男子。有菩萨摩诃萨住菩提心求无上菩提不。文殊师利白佛言世尊。无菩萨住菩提心求无上菩提。何以故。菩提心不可得。无上菩提亦不可得。五无间罪是菩提性。无有菩萨起无间心求无间罪果。云何有菩萨住菩提心求无上菩提。菩提者是一切诸法。何以故。色非色不可得故。乃至识非识亦不可得。眼不可得乃至意不可得色不可得乃至法不可得眼界乃至法界亦不可得。生不可得乃至老死亦不可得。檀波罗蜜不可得。乃至般若波罗蜜亦不可得。佛十力不可得。乃至十八不共法亦不可得。菩提心无上菩提皆不可得。不可得中无可得不可得。是故世尊。无菩萨住菩提心求无上菩提者。佛告文殊师利。汝意谓如来是汝师不。文殊师利白佛言。我无有意谓佛是我师。何以故。世尊。我尚不可得。何况当有意谓佛是我师。佛告文殊师利。汝于我有疑不。文殊白佛言。世尊。我尚无决定。何况当有疑。何以故。先定后疑故。佛告文殊汝不定言如来生耶。文殊白佛。如来若生法界亦应生。何以故。法界如来一相无二相。二相不可得故。文殊师利。汝信诸佛如来入涅槃不。文殊言。一切诸佛即涅槃相。涅槃相者无入无不入。佛告文殊师利。汝言诸佛有流转不文殊白佛言。世尊不流转尚不可得。何况流转当可得。佛告文殊师利。如来无心。唯如来前可说此言或漏尽阿罗汉及不退菩萨前可说此言。若余人闻。此语则不生信起惊疑。何以故。此甚深般若波罗蜜。难信难解故文殊白佛言。世尊。复何等人能信此甚深法。佛告文殊师利。一切凡夫能信此法。何以故。如来无心一切凡夫亦无心故文殊师利白佛言。世尊。何故作如是说法。新发意菩萨及阿罗汉咸皆有疑。愿闻解说。佛告文殊。如实相法性法住法位实际中有佛有凡夫差别不。文殊白佛言。不也世尊。佛告文殊。若无差别何故生疑文殊白佛言。世尊无差别中有佛有凡夫不。佛言有。何以故。佛与凡夫无二无差别。一相无相故。佛告文殊。汝信如来于一切众生中最胜不。文殊白佛言。世尊。我信如来于一切众生中最胜。世尊。若我信如来于一切众生中最胜。则如来成不最胜。佛告文殊。汝信如来成就一切不可思议法不。文殊师利白佛言。世尊。我信如来成就一切不可思议法。世尊。我若信如来成就一切不可思议法。如来则成可思议。佛告文殊师利。汝信一切声闻是如来所教化不。世尊。我信一切声闻是如来所教化。世尊。我若信一切声闻是如来所教化。则法界成可教化。佛告文殊师利。汝信如来是无上福田不。世尊。我信如来是无上福田。世尊。我若信如来是无上福田。如来则非福田。佛告文殊师利。汝何所依作如是答我。文殊白佛言。世尊。我无所依作如是答。世尊。无所依中无胜无不胜。无可思议无不可思议。无教化无不教化。无福田无非福田。是时以佛神力地六种震动。一万六千比丘众。以无可取心得解脱七百比丘尼众。三千优婆塞四万优婆夷众。远尘离垢得法眼净。六万亿那由他诸天。远尘离垢得法眼净。是时长老阿难即从座起。偏袒右肩右膝着地。合掌恭敬白佛言。世尊。何因何缘此地大动。尔时佛告阿难。此说般若波罗蜜。往古诸佛皆于此处说此法。以是因缘故此地震动。尔时长老舍利弗白佛言。世尊。此文殊师利所说不可思议。尔时世尊告文殊师利。如舍利弗所说。此文殊师利所说不可思议

尔时文殊师利白佛言。世尊。若不可思议则不可说。若可说则可思议。不可思议者无所有。彼一切声亦不可思议。不可思议者无声。佛言。汝入不思议三昧耶。文殊师利言。不也世尊。我即不思议。不见有心能思议者。云何而言入不思议三昧。我初发心欲入是定。而今思惟。实无心相而入三昧。如人学射久习则巧。后虽无心以久习故箭发皆中。我亦如是。初学不思议三昧系心一缘。若久习成就更无心想恒与定合。舍利弗语文殊师利言。更有胜妙寂灭定不。文殊师利言。若有不思议定者。汝可问言更有寂灭定不。如我意解。不可思议定尚不可得。云何问我寂灭定乎。舍利弗言。不思议定不可得耶。文殊师利言。思议定者是可得相。不可思议定者不可得相。一切众生实成就不可思议定。何以故。一切心相即非心故。是名不思议定。是故一切众生相及不思议三昧相。等无分别。佛赞文殊师利言。善哉善哉。汝于诸佛。久殖善根净修梵行。乃能演说甚深三昧。汝今安住如是般若波罗蜜中。文殊师利言。若我住般若波罗蜜中。能作是说。即是有想便住我想。若住有想我想中者。般若波罗蜜便有处所。般若波罗蜜若住于无。亦是我想亦名处所。离此二处住无所住。如诸佛住安处寂灭非思议境界。如是不思议。名般若波罗蜜住处。般若波罗蜜处。一切法无相。一切法无作。般若波罗蜜即不思议。不思议即法界。法界即无相。无相即不思议。不思议即般若波罗蜜。般若波罗蜜法界无二无别无二无别即法界。法界即无相。无相即般若波罗蜜界。般若波罗蜜界即不思议界。不思议界即无生无灭界。无生无灭界即不思议界。文殊师利言。如来界及我界即不二相。如是修般若波罗蜜者。即不求菩提。何以故。菩提相离即般若波罗蜜故。世尊。若知我相而不可着。无知无著是佛所知。不可思议无知无著即佛所知。何以故。知体本性无所有相。云何能转法界。若知本性无体无著者。即名无物。若无有物是无处所无依无住无依无住即无生无灭。无生无灭即是有为功德。若如是知则无心想。无心想者云何当知。有为无为功德。无知即不思议。不思议者是佛所知。亦无取无不取不见三世去来等相。不取生灭及诸起作。亦不断不常。如是知者是名正智不思议智。如虚空无此无彼。不可比类。无好恶。无等等。无相无貌佛告文殊师利。若如是知名不退智。文殊师利言。无作智名不退智。犹如金鋋先加捶打方知好恶。若不治打无能知者。不退智相亦复如是。要行境界。不念不着无起无作。具足不动不生不灭。尔乃显现尔时佛告文殊师利言。诸如来自说己智。谁当能信。文殊言。如是智者非涅槃法非生死法。是寂灭行。不断贪欲嗔恚愚痴。亦非不断。何以故。无尽无灭。不离生死亦非不离。不离修道非不修道。作是解者名为正信佛告文殊师利言。善哉善哉。如汝所说。深解斯义。尔时长老摩诃迦叶白佛言。世尊。未来世谁能信此深法。谁乐听此法。佛告迦叶。即今日四众比丘比丘尼优婆塞优婆夷。于未来世能信此法。闻说此深般若波罗蜜。当知此法当求此法。迦叶譬如长者或长者子。已失一大宝珠价直亿万两金。大生忧恼。今更还得生大欢喜忧恼悉灭。如是迦叶。比丘比丘尼优婆塞优婆夷。于未来世闻此最深般若波罗蜜经。与般若相应。闻已生喜心得安乐。无复忧恼亦复如是。当作是言。我等今日得见如来供养如来。所以者何。以得闻此甚深微妙六波罗蜜故。迦叶。譬如三十三天见波利质多罗树初生疱时。作如是念。此疱不久必当开敷。如是迦叶。比丘比丘尼优婆塞优婆夷。闻此般若波罗蜜经心生欢喜。亦复如是。我于来世必得此法。迦叶。此深般若波罗蜜如来灭后。当住不灭处处流行。迦叶。以佛力故。未来世中若善男子善女人。当得此深般若波罗蜜。迦叶。如摩尼珠师见摩尼宝心生欢喜。不假思量即知真伪。何以故。以串见故。如是迦叶。若人闻此般若波罗蜜相应法。闻已欢喜生信乐心。当知此人先世已闻此般若波罗蜜从久远劫来已曾供养诸佛。迦叶白佛言。世尊。此善男子善女人今闻此法。于未来世转复信解。佛告摩诃迦叶。如是如是。如汝所说。尔时文殊师利白佛言。世尊。此法无行无相。说此法者亦无行无相。云何世尊。说有行相。佛告文殊师利。我本行。菩萨道时。修诸善根。欲住阿惟越致地。当学般若波罗蜜。欲成阿耨多罗三藐三菩提。当学般若波罗蜜。若善男子善女人欲解一切法相。欲知一切众生心界皆悉同等。当学般若波罗蜜。文殊师利欲学一切佛法具足无碍。当学般若波罗蜜。欲学一切佛成阿耨多罗三藐三菩提时相好威仪无量法式。当学般若波罗蜜。欲知一切佛不成阿耨多罗三藐三菩提一切法式及诸威仪当学般若波罗蜜。何以故。是空法中不见诸佛菩提等故。若善男子善女人。欲知如是等相无疑惑者。当学般若波罗蜜。何以故。般若波罗蜜。不见诸法若生若灭若垢若净。是故善男子善女人。应作如是学般若波罗蜜。欲知一切法无过去未来现在等相。当学般若波罗蜜。何以故。法界性相无去来现在故。欲知一切法同入法界心无挂碍。当学般若波罗蜜。欲得三转十二行法转亦自证知而不取着。当学般若波罗蜜。欲得慈心遍覆一切众生而无限齐亦不作念有众生相。当学般若波罗蜜。欲得于一切众生不起诤论亦复不取无诤论相。当学般若波罗蜜。欲知是处非处十力无畏住佛智慧得无碍辩。当学般若波罗蜜。尔时文殊师利白佛言。世尊。我观正法。无为无相无得无利。无生无灭无去无来。无知者无见者无作者。不见般若波罗蜜。亦不见般若波罗蜜境界。非证非不证不作戏论无有分别。一切法无尽离尽。无凡夫法无声闻法无辟支佛法佛法。非得非不得。不舍生死不证涅槃。非思议非不思议。非作非不作。法相如是。不知云何当学般若波罗蜜尔时佛告文殊师利。若能如是知诸法相。是名学般若波罗蜜。菩萨摩诃萨若欲学菩提自在三昧。得是三昧已。照明一切甚深佛法及知一切诸佛名字。亦悉了达诸佛世界无有障碍。当如文殊所说般若波罗蜜中学。文殊白佛言。世尊。何故名般若波罗蜜。佛言般若波罗蜜无边无际无名无相非思量。无归依无洲渚无犯无福无晦无明。如法界无有分齐亦无限数是名般若波罗蜜。亦名菩萨摩诃萨行处。非行非不行处。悉入一乘名非行处。何以故。无念无作故。即是一切诸佛之母。一切诸佛所从生故。何以故。以无生故。是故文殊师利。若善男子善女人。欲行菩萨行具足诸波罗蜜。当修此般若波罗蜜。若欲得坐道场成无上菩提。当修此般若波罗蜜。若欲以大慈大悲遍覆一切众生。当修此般若波罗蜜。若欲起一切定方便。当修此般若波罗蜜。若欲得一切三摩跋提。当修此般若波罗蜜。何以故。诸三摩提无所为故。一切诸法无出离无出离处。若人欲随逐此语。当修般若波罗蜜。一切诸法如实不可得。若欲乐如是知。当修般若波罗蜜。一切众生为菩提故修菩提道。而实无众生亦无菩提。若人欲信乐此法。当修般若波罗蜜。何以故。一切诸法如实与菩提等如。非众生行不舍自性彼众生行是非行。彼非行是菩提。彼菩提是法界。若欲不着此法。当修般若波罗蜜。文殊师利。若比丘比丘尼优婆塞优婆夷。若受持般若波罗蜜一四句偈为他人说。我说此人得不堕法。何况如实修行。当知彼善男子善女人住佛境界。文殊师利。若善男子善女人。闻此甚深般若波罗蜜。不生怖畏。当知此人受佛法印。此法印者是佛所造是佛所贵。何以故。以此法印印无著法故。若善男子善女人。为此印所印。当知是人随菩萨乘决定不退。不堕声闻辟支佛地。尔时释提桓因及诸天子。从三十三天。雨细末栴檀及细末金屑。又散郁波罗华钵头摩华拘物陀华分陀利华及曼陀罗华。以供养般若波罗蜜。供养已作如是言。我已供养无上无著最第一法。愿我来世更闻此深般若波罗蜜。若人已为此深般若波罗蜜印之所印。愿其未来复得听受。究竟成就萨婆若智。尔时释提桓因白佛言。世尊。若善男子善女人。闻此般若波罗蜜一经于耳。我为增长佛法故。守护彼人。面百由旬不令非人得其便也。是善男子善女人。究竟当得阿耨多罗三藐三菩提。我当日日往到其所而设供养尔时佛告释提桓因。如是如是。憍尸迦。当知彼善男子善女人具足佛法。必定得至阿耨多罗三藐三菩提。尔时文殊师利白佛言。唯愿世尊。以威神力持此般若波罗蜜久住于世。为欲饶益诸众生故。文殊师利说此语时。以佛神力大地六种震动。尔时世尊即便微笑放大光明。遍照三千大千世界。以威神力持此般若波罗蜜令久住世。尔时文殊师利复白佛言。世尊。放此光明是持般若波罗蜜相。佛告文殊师利。如是当如是。文殊师利。我放此光明是持般若波罗蜜相。文殊师利。汝今当知知我已持此般若波罗蜜久住于世。若有人不轻毁此法不说其过。当知是人已为此深般若波罗蜜印之所印。是故文殊师利。我于久远安住此印。若人已为此印所印。当知是人不为魔王之所得便。佛告帝释。汝当受持读诵此经广宣流布。使未来世诸善男子善女人得此法印。复告阿难。汝亦受持读诵广为人说。时天帝释及长老阿难白佛言。世尊。当何名此经。我等云何奉持。佛言。此经名文殊师利所说。亦名般若波罗蜜。如是受持。善男子善女人于恒沙劫。以无价宝珠布施恒河沙等众生。众生受已悉发道心。是时施主随其所宜示教利喜。令得须陀洹果至阿罗汉果。是人所得功德宁为多不。阿难白佛言。甚多世尊。佛言。善男子。若人起一念心。信此般若波罗蜜经不诽谤者。比前功德。出过百倍千倍百千万亿倍。乃至算数譬喻所不能知何况具足受持读诵为人解说。是人所得功德无量无边。诸佛如来说不能尽。何以故。能生一切诸佛萨婆若故。若虚空有尽。则此经功德尽。若法性有尽。则此经功德尽。是故文殊师利。善男子善女人应勤行精进守护此经。此经能灭生死一切怖畏。能摧天魔所立胜幢。能将菩萨到涅槃果。示教训导离于二乘。尔时帝释长老阿难俱白佛言。世尊。如是如是诚如佛言。我等当顶戴受持广宣流布。唯愿如来不以为虑。如是三白言。愿不为虑。我等当顶戴受持。佛说此经竟。文殊师利等诸菩萨摩诃萨。舍利弗等比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众。闻佛所说皆大欢喜。信受奉持

    文殊师利所说般若波罗蜜经佛告文殊师利。汝入不可思议定不。文殊师利白佛言。不也。世尊。若我入不可思议定者。我则成可思议。世尊。心无心。我当云何入不可思议定。复次。世尊。我初发菩萨意。言我当入不可思议定。我今无此意当入不可思议定。世尊。如初学射。先作此意。我当射堋。射堋成已。后作是念。我当射皮。射皮成已。复作是念。我当射木。射木成已。复作是念。我当射铁。射铁成已。无复前念。随其箭中。皆能彻过。我亦如是。昔初发意。求入不可思议定。我于今日。无复此意当入不可思议定。何以故。此定不可思议故。尔时舍利弗白佛言。世尊。文殊师利未应得住。何以故。离此不可思议定更有寂静定。是其所应得故。文殊师利白舍利弗言。汝云何知离此不可思议定更有寂静定。大德舍利弗。若此不可思议定可得者。可离此定有寂静定。若此不可思议定不可得者。彼寂静定亦不可得。何以故。以此不可思议定不可得故。彼亦不可得。复次。大德舍利弗。无有众生不得此定者。一切众生皆得此定。何以故。一切诸心无心故。彼无心性即是此定。是故一切众生皆得此定。尔时世尊叹文殊师利。善哉善哉。如汝所说是最胜义。汝于久远无量佛所。深种善根。能作是说。文殊师利。汝作是念。我住般若波罗蜜能说此言不。文殊师利白佛言。不也。世尊。我无此念。世尊。若我有此念。住般若波罗蜜能说此言者。我则住可得法。世尊。我若住我相。则有是念。是故世尊。我不作此念。住般若波罗蜜能说此言。尔时佛告文殊师利。谁当信汝所说。文殊师利白佛言。世尊。若人不执生死及涅槃相。是人信我所说。又若人坚执有我若人具三毒。此人不能信。何以故。见及烦恼无可灭故。尔时世尊叹文殊师利。善哉善哉。汝能善说善男子善女人。行相者。所谓信此法。受持此法。以无所得心故。行亦无所得。相亦无所得。文殊师利。若善男子善女人。乐此无所得。当听此般若波罗蜜。若善男子善女人。欲得不退转地。当听此般若波罗蜜。若善男子善女人。欲信一切诸法与法界等。当听此般若波罗蜜。若善男子善女人。欲知一切诸法。当听此般若波罗蜜。若人得信此义。当听此般若波罗蜜。若人不乐念一切诸法。当听般若波罗蜜。何以故。此般若波罗蜜不见一切诸法故。文殊师利。若善男子善女人。欲知一切诸法不净不秽。当听此般若波罗蜜。若善男子善女人。欲得无疑。当听此般若波罗蜜。若善男子善女人。欲慈悲偏覆一切众生。不住众生相。不与世间诤。当听此般若波罗蜜。尔时文殊师利白佛言。世尊。般若波罗蜜无我无我所无起无灭无因无果无可执持。云何听受而得功德。佛告文殊师利。般若波罗蜜无作无灭。非凡夫法非圣人法。非生死法非离生死法。非涅槃法非离涅槃法。无得无失。非可思议非不可思议。若善男子善女人如是听受。则与般若波罗蜜相应。是为功德亦无功德。复次文殊师利。若菩萨摩诃萨。欲得菩萨定。欲知一切诸佛名。欲见一切诸佛世界。欲闻一切诸佛所说法。欲行诸佛法。当学此般若波罗蜜。尔时文殊师利白佛言。世尊。何故名般若波罗蜜。佛告文殊师利。般若波罗蜜者。无量无边。无方无处。无去无来。无作无为。即是一切诸佛法界。故名般若波罗蜜。文殊师利。此般若波罗蜜是菩萨摩诃萨行处。菩萨于此处行。故名行处。何以故。以无处故


唐梵翻对字音般若波罗蜜多心经(并序 [燉煌出 S. 700])

    No. 256

    唐梵翻对字音般若波罗蜜多心经(并序 [燉煌出 S. 700])

        西京大兴善寺石璧上录出慈恩和尚奉　诏述序

梵本般若多心经者。大唐三藏之所译也。三藏志游天竺。路次益州。宿空惠寺道场内。遇一僧有疾。询问行止。因话所之。乃难叹法师曰。为法忘体。甚为希有。然则五天[這-言+((美-王-大)/口)][這-言+((美-王-大)/(尸@巾))]十万余逞。道涉流沙。波深弱水。胡风起处。动塞草以愁人。山鬼啼时对荒兵之落叶。朝行雪巘。暮宿冰崖。树挂猿猱。境多魑魅。层峦叠于葱岭。萦似带雪之白云。群木蔟于鹫峰耸参天之碧峤。逞途多难。去也如何。我有三世诸佛心要法门。师若受持。可保来往。遂乃口受与法师讫。至晓失其僧焉。三藏结束囊装。渐离唐境。或途经厄难。或时有[門@(圭*艮)]斋。馐忆而念之四十九遍。失路即化人指引。思食则辄现珍[卄/(跳-兆+束)]。但有诚祈。皆获戬祐。至中天竺磨竭陀国那烂陀寺。旋绕经藏。次忽见前僧。而相谓曰。逮涉艰崄。喜达此方。赖我昔在支那国所传三世诸佛心要法门。由斯经历。保尔行途。取经早[這-言+(血/(豕-一))]满尔心愿。我是观音菩萨。言讫冲空。既显奇祥。为斯经之至验。信为般若。□为圣枢。如说而行。必超觉际。究如来旨。巨历三祇。讽如来经。能销三障。若人虔诚受持者。体理斯而勤焉

        特进鸿胪卿开府议同三司封肃国公赠司空官食邑三千户敕谥大办正广不空奉　诏译

    莲花部等普赞叹三宝

曩谟(引)没驮(引声上)野(一)遇啰(上)吠(二)曩谟(引)达(引上)磨野(三)驮以(引)铭磨(四)曩谟(引)僧伽野(上引五)磨贺谛(二合引)谛[肄-聿+余](二合引)毗药(二合七)毗舍(引)佐(八)迦磨啰目佉(引九)迦磨啰路(引)左曩(十)迦磨啰攞(引)沙曩(十一)迦磨啰贺(引)娑哆(十二)迦磨啰婆母儞(上十三)迦磨攞(十四)迦磨啰(引十五)三婆(上)嚩娑(十六)迦啰磨啰(十七)[(敲-高)-又+乙]洒(二合)攞(引)曩(十八)娜谟(引)宰堵谛

    梵本般若波罗蜜多心经

        观自在菩萨与三藏法师玄奘亲教授梵本不润色

钵啰(二合般)誐攘(二合若)播(波)啰(罗)弭(蜜)哆(多)[糸*(占-口+乙)]哩(二合)那野(心)素怛囕(经)阿哩也(二合圣)嚩噜(观)枳帝(自)湿嚩路(在)冒地(菩)娑怛侮(萨二)俨鼻囕(深)钵啰(二合般)誐攘(若)播(波)啰(罗)弭(蜜)哆(多三)左哩焰(二合行)左啰(行)么[口*女]尾也(二合时四)嚩噜(引)迦(照)底娑么(二合见)畔左(五)塞建(引)驮(引五蕴)娑怛(引)室左(二合彼)娑嚩(自)婆嚩(引性)戍儞焰(二合空)跛失也(二合)底娑么(二合现)伊贺(此七)舍(舍)哩(利)补怛啰(子二合八)噜畔(色)戍儞焰(二合空)戍儞也(二合空)嚏(性)嚩(是)噜畔(色九)噜播(色)曩(不)比[口*栗](二合)他(异)戍儞也(二合)哆(多空十)戍儞也(二合空)哆野(亦十一)曩(引不)比[口*栗](二合)他(异)[薩/女]噜(二合)畔(色十二)夜(是)怒噜(二合)畔(色)娑戍(彼)儞也(二合)哆夜(空十三)戍(是)儞也(二合)哆(空)娑(彼)噜畔(色十四)曀嚩(如)弭嚩(是十四)吠那曩(受)散誐攘(想)散娑迦(引)啰(行)尾誐攘(二合)喃(识十五)伊贺(此)舍(舍)哩(利)补怛啰(子二合十六)萨啰嚩(诸)达么(诸法)戍儞也(二合)哆(空)落乞叉(二合)拏(相十七)阿怒(不)哆播(二合)曩(生)阿宁(不)噜驮(阿不十八)阿(不)尾么攞(净十九)阿(不)怒曩(增)阿(不)播哩补攞拏(减二合二十)哆(是)娑每(故)舍(舍)哩(利)补怛啰(子二合廿一)戍儞也(二空合)哆焰(中)曩(无上)噜畔(色二十二)曩(无)吠(引)那曩(受二十三)曩(无)散誐攘(想二合二十四)曩(无)散娑迦啰(行二合二十五)曩(无)尾誐攘(二合)喃(识廿六)曩(无)斫乞刍(眼)戍噜怛啰(二合耳)迦啰(二合)拏鼻[口*爾]贺(舌)嚩迦野(身)么曩[(台/十)*力](意廿七)曩(无)噜畔(色)摄那(声)彦驮(香)啰娑(味)娑播啰(二合)瑟吒尾也(触二舍)达么(法廿八)曩(无)斫刍(眼二合)驮都(界廿九)哩也(乃二合)嚩(至)曩(无)么怒(意)尾誐攘誐(二合)喃(识)驮都(界卅)曩(无)尾儞也(明卅一)曩(无)尾儞也(明尽无二)曩(无)尾儞也(明)乞叉喻(尽卅三)曩(无)尾儞也(明)乞叉喻(尽卅四)

野(乃)嚩(至)[口*惹]啰(老)么啰喃(无卅五)曩(无)[口*惹]啰(老)么啰拏(无)乞叉喻(尽卅六)曩(无)耨佉(苦)娑敏那野(集)宁噜驮(灭)么(哩)誐穰(二合道卅七)曩(无)誐攘喃(智卅八)曩(无)钵啰(二合)比底(得卅九)曩(无)鼻娑么(证四十)哆(以)娑每无那(所)钵啰(二合)比府(得二合)怛嚩(故四十一)冒(菩)地(提)娑(萨)怛嚩喃(埵四十二)钵啰(般二合)誐攘(若)播(波)啰弭(多四十三)么室哩底也(二合依)尾贺(于)啰底也(二合住四十四)只跢(心)嚩(无)啰(挂)拏(碍四十五)尾儞也(明)乞叉喻(尽三十三)曩(无)尾儞也(明)乞叉喻(尽卅四)野(乃)嚩(啰至曩无)[口*惹]啰(老)么啰喃(死卅五)曩(无)[口*惹]啰(老)么啰拏(死)乞叉喻(尽卅六)曩(无)耨佉(苦)娑每那野(集)宁噜驮(灭)么哩誐攘(二合道卅七)曩(无)誐攘喃(智卅八)曩(无)钵啰(二合)比底(得卅九)曩(无)鼻娑么(证四十)哆(以)娑每(无)那(所)钵啰(二合)比底(得二合)怛嚩(故四十一)冒(菩)地(提)娑(萨)怛嚩喃(埵四十二)钵啰(般二合)誐攘(若)播(波)啰(罗)弭(蜜)哆(多四十三)么室哩底也(二合依)尾贺(于)啰底也(二合住四十四)只哆(心)嚩(无)啰(挂)拏(碍四十五)只跢(心)啰(挂)拏(碍四十六)

曩(无)悉底怛嚩(二合有)那(恐)[怡-台+(日/工)]哩(二合)素都(二合怖四十七)尾播(颠)哩也(二合)娑(倒)底(远)伽兰哆(离四十八)宁(究)瑟吒(竟)宁哩也嚩(二合涅)喃(盘四十九)底哩也(三二合)驮嚩(二合世五十)尾也(二合)嚩(所)悉体跢(经)娑嚩(诸)没驮(佛五十一)钵啰(般)誐攘(二合若)播(波)啰(罗)弭(蜜)哆(多五十二)么室哩(故)底世(二合得)耨(无)跢兰(上)[糝-(彰-章)+(恭-共)]藐世(二合等)[糝-(彰-章)+(恭-共)](正)没地(竟五十三)么鼻[糝-(彰-章)+(恭-共)]没驮哆(引是)娑每(故二合)誐攘(二合)哆(应)尾演(知五十四)钵啰(般)誐攘(二合若)播(波)啰(罗)弭(蜜)哆(多五十五)么贺(引大)满怛噜(咒五十六)么贺(引大)尾儞也(明二合)满怛啰(咒五十七)阿(无)耨哆啰(上)满怛啰(咒阿无五十八)娑么(等)娑底(等)满

怛啰(咒五十九)萨(一)嚩(切)耨佉(苦)钵啰(二合)舍(止)曩(息卒)娑(真)底也(实)么弭(不)赞哩也(二合)怛嚩(虚二合六十一)钵啰(二合般)誐攘(若)播(波)啰(罗)弭(蜜)哆(多六十二)目讫姤(说)满怛啰(咒二合)怛儞(也)他(二合曰)誐谛谛谛(六十四)播啰誐谛(六十五)播啰僧誐谛(六十六)冒地(引)娑嚩贺(六十七)梵语般若波罗蜜多心经一卷(僧□□之)


文殊师利所说摩诃般若波罗蜜经

    No. 232 [Nos. 220(7), 233]

文殊师利所说摩诃般若波罗蜜经卷上

        梁扶南国三藏曼陀罗仙译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘僧满足千人。菩萨摩诃萨十千人俱。以大庄严而自庄严。皆悉已住不退转地。其名曰弥勒菩萨。文殊师利菩萨。无碍辩菩萨。不舍担菩萨。与如是等大菩萨俱。文殊师利童真菩萨摩诃萨。明相现时从其住处来诣佛所。在外而立

尔时尊者舍利弗。富楼那弥多罗尼子。大目犍连。摩诃迦叶。摩诃迦旃延。摩诃拘絺罗。如是等诸大声闻。各从住处俱诣佛所。在外而立。佛知众会皆悉集已。尔时如来从住处出。敷座而坐。告舍利弗。汝今何故。于晨朝时在门外立。舍利弗白佛言。世尊。文殊师利童真菩萨。先已至此住门外立。我实于后晚来到耳。尔时世尊问文殊师利。汝实先来到此住处。欲见如来耶。文殊师利即白佛言。如是世尊。我实来此欲见如来。何以故。我乐正观利益众生。我观如来如如相。不异相不动相不作相。无生相无灭相。不有相不无相。不在方不离方。非三世非不三世。非二相非不二相。非垢相非净相。以如是等。正观如来利益众生。佛告文殊师利。若能如是见于如来。心无所取亦无不取。非积聚非不积聚。尔时舍利弗语文殊师利言。若能如是如汝所说。见如来者甚为希有。为一切众生故见于如来。而心不取众生之相。化一切众生向于涅槃。而亦不取向涅槃相。为一切众生发大庄严。而心不见庄严之相。尔时文殊师利童真菩萨摩诃萨语舍利弗言。如是如是。如汝所说。虽为一切众生发大庄严心。恒不见有众生相。为一切众生发大庄严。而众生趣亦不增不减。假使一佛住世。若一劫若过一劫。如此一佛世界。复有无量无边恒河沙诸佛。如是一一佛若一劫若过一劫。昼夜说法心无暂息。各各度于无量恒河沙众生。皆入涅槃。而众生界亦不增不减。乃至十方诸佛世界。亦复如是。一一诸佛说法教化。各度无量恒河沙众生。皆入涅槃。于众生界亦不增不减。何以故。众生定相不可得故。是故众生界不增不减。舍利弗复语文殊师利言。若众生界不增不减。何故菩萨为诸众生。求阿耨多罗三藐三菩提。常行说法。文殊师利言。若诸众生悉空相者。亦无菩萨求阿耨多罗三藐三菩提。亦无众生而为说法。何以故。我说法中。无有一法当可得故。尔时佛告文殊师利。若无众生云何说有众生及众生界。文殊师利言。众生界相如诸佛界。又问众生界者是有量耶。答曰。众生界量如佛界量。佛又问众生界量有处所不。答曰众生界量不可思议。又问众生界相为有住不。答曰。众生无住犹如空住。佛告文殊师利。如是修般若波罗蜜时。当云何住般若波罗蜜。文殊师利言。以不住法为住般若波罗蜜。佛复问文殊师利。云何不住法。名住般若波罗蜜。文殊师利言。以无住相。即住般若波罗蜜。佛复告文殊师利。如是住般若波罗蜜时。是诸善根。云何增长云何损减。文殊师利言。若能如是住般若波罗蜜。于诸善根无增无减。于一切法亦无增无减。是般若波罗蜜性相亦无增无减。世尊。如是修般若波罗蜜。则不舍凡夫法。亦不取贤圣法。何以故。般若波罗蜜不见有法可取可舍。如是修般若波罗蜜。亦不见涅槃可乐生死可厌。何以故。不见生死况复厌离。不见涅槃何况乐着。如是修般若波罗蜜。不见垢恼可舍。亦不见功德可取。于一切法心无增减。何以故。不见法界有增减故。世尊。若能如是是名修般若波罗蜜。世尊。不见诸法有生有灭。是修般若波罗蜜。世尊。不见诸法有增有减。是修般若波罗蜜。世尊。心无悕取不见法相有可求者。是修般若波罗蜜。世尊。不见好丑不生高下不作取舍。何以故。法无好丑离诸相故。法无高下等法性故。法无取舍住实际故。是修般若波罗蜜。佛告文殊师利。是诸佛法得不胜乎。文殊师利言。我不见诸法有胜如相。如来自觉一切法空。是可证知。佛告文殊师利。如是如是。如来正觉自证空法。文殊师利白佛言。世尊。是空法中。当有胜如而可得耶。佛言。善哉善哉。文殊师利。如汝所说是真法乎。佛复谓文殊师利言。阿耨多罗是名佛法不。文殊师利言。如佛所说。阿耨多罗是名佛法。何以故。无法可得名阿耨多罗。文殊师利言。如是修般若波罗蜜。不名法器。非化凡夫法。亦非佛法非增长法。是修般若波罗蜜。复次世尊。修般若波罗蜜时。不见有法可分别思惟。佛告文殊师利。汝于佛法不思惟耶。文殊师利言。不也世尊。如我思惟。不见佛法。亦不可分别是凡夫法是声闻法是辟支佛法。如是名为无上佛法。复次修般若波罗蜜时。不见凡夫相。不见佛法相。不见诸法有决定相。是为修般若波罗蜜。复次修般若波罗蜜时。不见欲界不见色界不见无色界不见寂灭界。何以故。不见有法是尽灭相。是修般若波罗蜜。复次修般若波罗蜜时。不见作恩者不见报恩者。思惟二相心无分别。是修般若波罗蜜。复次修般若波罗蜜时。不见是佛法可取。不见是凡夫法可舍。是修般若波罗蜜。复次修般若波罗蜜时。不见凡夫法可灭。亦不见佛法而心证知。是修般若波罗蜜。佛告文殊师利。善哉善哉。汝能如是善说甚深般若波罗蜜相。是诸菩萨摩诃萨所学法印。乃至声闻缘觉学无学人亦当不离是印而修道果

佛告文殊师利。若人得闻是法不惊不畏者。不从千佛所种诸善根。乃至百千万亿佛所久植德本。乃能于是甚深般若波罗蜜。不惊不怖。文殊师利白佛言。世尊。我今更说般若波罗蜜义。佛言。便说。世尊。修般若波罗蜜时。不见法是应住是不应住。亦不见境界可取舍相。何以故。如诸如来不见一切法境界相故。乃至不见诸佛境界。况取声闻缘觉凡夫境界。不取思议相亦不取不思议相。不见诸法有若干相。自证空法不可思议。如是菩萨摩诃萨。皆已供养无量百千万亿诸佛。种诸善根。乃能于是甚深般若波罗蜜。不惊不怖。复次修般若波罗蜜时。不见缚不见解。而于凡夫乃至三乘不见差别相。是修般若波罗蜜。佛告文殊师利。汝已供养几所诸佛。文殊师利言。我及诸佛如幻化相。不见供养及与受者。佛告文殊师利。汝今可不住佛乘耶。文殊师利言。如我思惟不见一法。云何当得住于佛乘。佛言。文殊师利。汝不得佛乘乎。文殊师利言。如佛乘者。但有名字非可得亦不可见。我云何得。佛言。文殊师利。汝得无碍智乎。文殊师利言。我即无碍。云何以无碍而得无阂。佛言。汝坐道场乎。文殊师利言。一切如来不坐道场。我今云何独坐道场。何以故。现见诸法住实际故。佛言。云何名实际。文殊师利言。身见等是实际。佛言。云何身见是实际。文殊师利言。身见如相。非实非不实。不来不去亦身非身。是名实际

舍利弗白佛言。世尊。若于斯义谛了决定。是名菩萨摩诃萨何以故。得闻如是甚深般若波罗蜜相。心不惊不怖不没不悔

弥勒菩萨白佛言。世尊。得闻如是般若波罗蜜具足法相。是即近于佛坐。何以故。如来现觉此法相故。文殊师利白佛言。世尊。得闻甚深般若波罗蜜。能不惊不怖不没不悔。当知此人即是见佛

尔时复有无相优婆夷白佛言。世尊。凡夫法声闻法辟支佛法佛法。是诸法皆无相。是故于所从闻般若波罗蜜。皆不惊不怖不没不悔。何以故。一切诸法本无相故

佛告舍利弗。善男子善女人。若闻如是甚深般若波罗蜜。心得决定不惊不怖不没不悔。当知是人。即住不退转地。若人闻是甚深般若波罗蜜。不惊不怖信乐听受欢喜不厌。是即具足檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。亦能为他显示分别如说修行

佛告文殊师利。汝观何义。为得阿耨多罗三藐三菩提。住阿耨多罗三藐三菩提。文殊师利言。我无得阿耨多罗三藐三菩提。我不住佛乘。云何当得阿耨多罗三藐三菩提。如我所说即菩提相。佛赞文殊师利言。善哉善哉。汝能于是甚深法中巧说斯义。汝于先佛久种善根。以无相法净修梵行。文殊师利言。若见有相则言无相。我今不见有相。亦不见无相。云何而言以无相法净修梵行。佛告文殊师利。汝见声闻戒耶。答曰见。佛言汝云何见。文殊师利言。我不作凡夫见不作圣人见。不作学见不作无学见。不作大见不作小见。不作调伏见不作不调伏见。非见非不见

舍利弗语文殊师利言。汝今如是观声闻乘。若观佛乘当复云何。文殊师利言。不见菩提法。不见修行菩提及证菩提者。舍利弗语文殊师利言。云何名佛。云何观佛。文殊师利言。云何为我。舍利弗言。我者但有名字。名字相空。文殊师利言。如是如是。如我但有名字。佛亦但有名字。名字相空即是菩提。不以名字而求菩提。菩提之相无言无说。何以故。言说菩提二俱空故

复次舍利弗。汝问云何名佛。云何观佛者。不生不灭不来不去。非名非相。是名为佛。如自观身实相。观佛亦然。唯有智者乃能知耳。是名观佛

尔时舍利弗白佛言。世尊。如文殊师利所说般若波罗蜜。非初学菩萨所能了知。文殊师利言。非但初学菩萨所不能知。及诸二乘所作已办者亦未能了知。如是说法。无能知者。何以故。菩提之相。实无有法而可知故。无见无闻无得无念。无生无灭无说无听。如是菩提。性相空寂。无证无知无形无相。云何当有得菩提者

舍利弗语文殊师利言。佛于法界。不证阿耨多罗三藐三菩提耶。文殊师利言。不也舍利弗。何以故。世尊即是法界。若以法界证法界者即是诤论。舍利弗。法界之相即是菩提。何以故。是法界中无众生相。一切法空故。一切法空即是菩提。无二无分别故。舍利弗。无分别中则无知者。若无知者即无言说。无言说相。即非有非无非知非不知。一切诸法亦复如是。何以故。一切诸法不见处所。决定性故。加逆罪相不可思议。何以故。诸法实相不可坏故。如是逆罪亦无本性。不生天上不堕地狱亦不入涅槃。何以故。一切业缘皆住实际。不来不去非因非果。何以故。法界无边无前无后故。是故舍利弗。若见犯重比丘不堕地狱清净行者不入涅槃。如是比丘非应供非不应供。非尽漏非不尽漏。何以故。于诸法中住平等故

舍利弗言。云何名不退法忍。文殊师利言。不见少法有生灭相。名不退法忍。舍利弗言。云何复名不调比丘。文殊师利言。漏尽阿罗汉。是名不调。何以故。诸结已尽更无所调故名不调。若过心行名为凡夫。何以故。凡夫众生不顺法界。是故名过。舍利弗言。善哉善哉。汝今为我善解漏尽阿罗汉义。文殊师利言。如是如是。我即漏尽真阿罗汉。何以故。断求声闻欲及辟支佛欲。以是因缘故名漏尽得阿罗汉。佛告文殊师利。诸菩萨等坐道场时。觉悟阿耨多罗三藐三菩提不。文殊师利言。菩萨坐于道场。无有觉悟阿耨多罗三藐三菩提。何以故。如菩提相。无有少法而可得者。名阿耨多罗三藐三菩提。无相菩提谁能坐者亦无起者。以是因缘不见菩萨坐于道场。亦不觉证阿耨多罗三藐三菩提。文殊师利白佛言。世尊。菩提即五逆五逆即菩提。何以故。菩提五逆无二相故。无学无学者。无见无见者。无知无知者。无分别无分别者。如是之相名为菩提。见五逆相亦复如是。若言见有菩提而取证者。当知此辈即是增上慢人

尔时世尊告文殊师利。汝言我是如来。谓我为如来乎。文殊师利言。不也世尊。我谓不是如来为如来耶。无有如相可名为如。亦无如来智能知于如。何以故。如来及智无二相故。空为如来但有名字。我当云何谓是如来。佛告文殊师利。汝疑如来耶。文殊师利言。不也世尊。我观如来无决定性。无生无灭故无所疑

佛告文殊师利。汝今不谓如来出现于世耶。文殊师利言。若有如来出现世者。一切法界亦应出现

佛告文殊师利。汝谓恒沙诸佛入涅槃耶。文殊师利言。诸佛一相不可思议。佛语文殊师利。如是如是。佛是一相不思议相。文殊师利白佛言。世尊。佛今住世耶。佛语文殊师利。如是如是。文殊师利言。若佛住世。恒沙诸佛亦应住世。何以故。一切诸佛皆同一相不思议相。不思议相无生无灭。若未来诸佛出兴于世。一切诸佛亦皆出世。何以故。不思议中无过去未来现在相。但众生取着。谓有出世谓佛灭度。佛语文殊师利。此是如来。阿罗汉。阿鞞跋致菩萨所解。何以故。是三种人。闻甚深法。能不诽谤。亦不赞叹。文殊师利白佛言。世尊。如是不思议法。谁当诽谤谁当赞叹

佛告文殊师利。如来不思议。凡夫亦不思议。文殊师利白佛言。世尊。凡夫亦不思议耶。佛言。亦不思议。何以故。一切心相皆不思议。文殊师利言。若如是说。如来不思议。凡夫亦不思议。今无数诸佛求于涅槃徒自疲劳。何以故。不思议法即是涅槃。等无异故。文殊师利言。如是凡夫不思议诸佛不思议。若善男子善女人。久习善根近善知识乃能了知

佛告文殊师利。汝欲使如来于众生中为最胜耶。文殊师利言。我欲使如来于诸众生为最第一。但众生相亦不可得。佛言。汝欲使如来得不思议法耶。文殊师利言。欲使如来得不思议法。而于诸法无成就者。佛告文殊师利汝欲使如来说法教化耶。文殊师利白佛言我欲使如来说法教化。而是说及听者皆不可得。何以故。住法界故。法界众生无差别相

佛告文殊师利。汝欲使如来为无上福田耶。文殊师利言。如来是无尽福田是无尽相。无尽相即无上福田。非福田非不福田。是名福田。无有明闇生灭等相。是名福田。若能如是解福田相。深植善种亦无增减

佛告文殊师利。云何植种不增不减。文殊师利言。福田之相。不可思议。若人于中如法修善亦不可思议。如是植种名无增无减。亦是无上最胜福田。尔时大地以佛神力。六种震动现无常相。一万六千人皆得无生法忍。七百比丘三千优婆塞四万优婆夷六十亿那由他六欲诸天。远尘离垢于诸法中得法眼净

文殊师利所说摩诃般若波罗蜜经卷上文殊师利所说摩诃般若波罗蜜经卷下

        梁扶南国三藏曼陀罗仙译

尔时阿难从座而起。偏袒右肩右膝着地。白佛言。世尊。何因缘故。如是大地六种震动。佛告阿难。我说福田无差别相。故现斯瑞。往昔诸佛亦于此处。作如是说福田之相。利益众生。一切世界六种震动。舍利弗白佛言。世尊。文殊师利是不可思议。何以故。所说法相不可思议。佛告文殊师利。如是如是。如舍利弗言。汝之所说实不可思议文殊师利白佛言。世尊。不可思议不可说。思议亦不可说。如是思议不思议性俱不可说。一切声相非思议亦非不可思议。佛言。汝入不思议三昧耶。文殊师利言。不也世尊。我即不思议。不见有心能思议者。云何而言入不思议三昧。我初发心欲入是定。而今思惟。实无心相而入三昧。如人学射久习则巧后虽无心以久习故箭发皆中。我亦如是。初学不思议三昧系心一缘。若久习成就。更无心想恒与定俱。舍利弗语文殊师利言。更有胜妙寂灭定不。文殊师利言。若有不思议定者。汝可问言。更有寂灭定不。如我意解。不可思议定尚不可得。云何问有寂灭定乎。舍利弗言。不可思议定不可得耶

文殊师利言。思议定者是可得相。不可思议定者不可得相。一切众生实成就不思议定。何以故。一切心相即非心故。是名不思议定。是故一切众生相及不思议三昧相。等无分别。佛赞文殊师利言。善哉善哉。汝于诸佛久殖善根净修梵行。乃能演说甚深三昧。汝今安住如是般若波罗蜜中。文殊师利言。若我住般若波罗蜜中。能作是说。即是有想便住我想。若住有想我想中者。般若波罗蜜便有处所。般若波罗蜜若住于无。亦是我想亦名处所。离此二处住无所住。如诸佛住安处寂灭非思议境界。如是不思议。名般若波罗蜜住处。般若波罗蜜处。一切法无相。一切法无作。般若波罗蜜即不思议。不思议即法界。法界即无相。无相即不思议。不思议即般若波罗蜜。般若波罗蜜法界。无二无别。无二无别即法界。法界即无相。无相即般若波罗蜜界。般若波罗蜜界即不思议界不思议界即无生无灭界。无生无灭界即不思议界。文殊师利言。如来界及我界即不二相。如是修般若波罗蜜者则不求菩提。何以故。菩提相离。即是般若波罗蜜故。世尊。若知我相而不可着。无知无著是佛所知。不可思议无知无著即佛所知。何以故。知体本性无所有相。云何能转法界。若知本性无体无著者。即名无物。若无有物是无处所无依无住。无依无住即无生无灭。无生无灭即是有为无为功德。若如是知则无心想。无心想者云何当知。有为无为功德无知即不思议。不思议者是佛所知。亦无取无不取。不见三世去来等相。不取生灭及诸起作。亦不断不常。如是知者是名正智。不思议智如虚空。无此无彼不可比类。无好恶无等等无相无貌。佛告文殊师利。若如是知名不退智。文殊师利言。无作智名不退智。犹如金铤先加锤打方知好恶。若不治打无能知者。不退智相亦复如是。要行境界。不念不着无起无作。具足不动不生不灭。尔乃显现

尔时佛告文殊师利言。如诸如来自说己智。谁当能信。文殊师利言。如是智者。非涅槃法非生死法。是寂灭行是无动行。不断贪欲嗔恚愚痴。亦非不断。何以故。无尽无灭不离生死亦非不离。不修道非不修道。作是解者名为正信佛告文殊师利言。善哉善哉。如汝所说深解斯义。尔时摩诃迦叶白佛言。世尊。于当来世。若说如是甚深正法。谁能信解如闻受行。佛告迦叶。今此会中比丘比丘尼优婆塞优婆夷得闻此经者。如是人等于未来世若闻是法。必能信解于甚深般若波罗蜜。乃能读诵信解受持。亦为他人分别演说。譬如长者失摩尼宝忧愁苦恼。后若还得。心甚欢喜。如是迦叶。比丘比丘尼优婆塞优婆夷等。亦复如是。有信乐心。若不闻法则生苦恼。若得闻时信解受持。常乐读诵甚大欢喜。当知此人即是见佛。亦即亲近供养诸佛。佛告迦叶。譬如忉利天上波利质多罗树疱初出时。是中诸天见是树已皆大欢喜。此树不久必当开敷。若比丘比丘尼优婆塞优婆夷。得闻般若波罗蜜。能生信解。亦复如是。此人不久亦当开敷一切佛法。于当来世。有比丘比丘尼优婆塞优婆夷。闻般若波罗蜜。信受读诵心不悔没。当知是人已从此会听受是经。亦能为人聚落城邑广说流布。当知是人佛所护念。如是甚深般若波罗蜜中。有能信乐无疑惑者。是善男子善女人。于过去诸佛。久已修学殖众善根。譬如有人以手穿珠。忽遇无上真摩尼宝。心大欢喜。当知是人必已曾见。如是迦叶。若善男子善女人修学余法。忽然得闻甚深般若波罗蜜能生欢喜。亦复如是。当知此人已曾闻故。若有众生得闻甚深般若波罗蜜。心能信受生大欢喜。如是人等亦曾亲近无数诸佛。从闻般若波罗蜜已修学故。譬如有人。先所经见城邑聚落后若闻人赞叹彼城所有园苑种种池泉华果林树男女人民皆可爱乐。是人闻已即大欢喜。更劝令说是城园苑众好严饰杂华池泉多诸甘果。种种珍妙一切爱乐。是人得闻重甚欢喜。如是之人皆曾见故。若善男子善女人。有闻般若波罗蜜。信心听受能生欢喜。乐闻不厌而更劝说。当知此辈已从文殊师利。曾闻如是般若波罗蜜故。迦叶白佛言。世尊。若将来世善男子善女人。得闻是甚深般若波罗蜜。信乐听受。以是相故。当知此人亦于过去佛所曾闻修学。文殊师利白佛言。世尊。佛说诸法无作无相第一寂灭。若善男子善女人。有能如是谛了斯义。如闻如说。为诸如来之所赞叹。不违法相是即佛说。亦是炽然般若波罗蜜相。亦名炽燃具足佛法。通达实相不可思议。佛告文殊师利。我本行菩萨道时修诸善根。欲住阿鞞跋致地。当学般若波罗蜜。欲成阿耨多罗三藐三菩提。当学般若波罗蜜。若善男子善女人。欲解一切法相欲知一切众生心界皆悉同等。当学般若波罗蜜。文殊师利。欲学一切佛法具足无碍。当学般若波罗蜜。欲学一切佛成阿耨多罗三藐三菩提时相好威仪无量法式。当学般若波罗蜜。欲知一切佛不成阿耨多罗三藐三菩提一切法式及诸威仪。当学般若波罗蜜。何以故是空法中不见诸佛菩提等故。若善男子善女人。欲知如是等相无疑惑者。当学般若波罗蜜。何以故。般若波罗蜜。不见诸法若生若灭若垢若净。是故善男子善女人。应作如是学般若波罗蜜。欲知一切法无过去未来现在等相。当学般若波罗蜜。何以故。法界性相无三世故。欲知一切法同入法界心无挂碍。当学般若波罗蜜。欲得三转十二行法轮亦自证知而不取着。当学般若波罗蜜。欲得慈心遍覆一切众生而无限齐亦不作念有众生相。当学般若波罗蜜。欲得于一切众生不起诤论亦复不取无诤论相。当学般若波罗蜜。欲知是处非处十力无畏住佛智慧得无碍辩。当学般若波罗蜜。尔时文殊师利白佛言。世尊。我观正法。无为无相无得无利。无生无灭无来无去。无知者无见者无作者。不见般若波罗蜜。亦不见般若波罗蜜境界。非证非不证。不作戏论无有分别。一切法无尽离尽。无凡夫法无声闻法。无辟支佛法佛法。非得非不得。不舍生死不证涅槃。非思议非不思议。非作非不作。法相如是。不知云何当学般若波罗蜜

尔时佛告文殊师利。若能如是知诸法相。是名当学般若波罗蜜。菩萨摩诃萨若欲学菩提自在三昧。得是三昧已。照明一切甚深佛法及知一切诸佛名字。亦悉了达诸佛世界无有障碍。当如文殊师利所说般若波罗蜜中学。文殊师利白佛言。世尊。何以故。名般若波罗蜜。佛言。般若波罗蜜无边无际无名无相。非思量无归依无洲渚。无犯无福无晦无明。犹如法界无有分齐亦无限数。是名般若波罗蜜。亦名菩萨摩诃萨行处。非处非不行处。悉入一乘名非行处。何以故。无念无作故。文殊师利白佛言。世尊。当云何行能速得阿耨多罗三藐三菩提。佛言。文殊师利。如般若波罗蜜所说行。能速得阿耨多罗三藐三菩提。复有一行三昧。若善男子善女人修是三昧者。亦速得阿耨多罗三藐三菩提。文殊师利言。世尊。云何名一行三昧。佛言。法界一相。系缘法界是名一行三昧。若善男子善女人。欲入一行三昧。当先闻般若波罗蜜如说修学然后能入一行三昧。如法界缘不退不坏。不思议无碍无相。善男子善女人欲入一行三昧。应处空闲舍诸乱意不取相貌系心一佛专称名字。随佛方所端身正向。能于一佛念念相续。即是念中能见过去未来现在诸佛。何以故。念一佛功德无量无边。亦与无量诸佛功德。无二不思议。佛法等无分别。皆乘一如成最正觉。悉具无量功德无量辩才。如是入一行三昧者。尽知恒沙诸佛法界无差别相。阿难所闻佛法。得念总持辩才智慧。于声闻中虽为最胜。犹住量数则有限碍。若得一行三昧。诸经法门一一分别。皆悉了知决定无碍。昼夜常说智慧辩才终不断绝。若比阿难多闻辩才百千等分不及其一。菩萨摩诃萨应作是念。我当云何逮得一行三昧不可思议功德无量名称。佛言。菩萨摩诃萨。当念一行三昧常勤精进而不懈怠。如是次第渐渐修学。则能得入一行三昧。不可思议功德作证。除谤正法不信恶业重罪障者。所不能入。复次文殊师利。譬如有人得摩尼珠示其珠师。珠师答言。此是无价真摩尼宝。即求师言。为我治磨勿失光色。珠师治已随其磨时。珠色光明映彻表里。文殊师利。若有善男子善女人修学一行三昧。不可思议功德无量名称。随修学时知诸法相。明达无碍功德增长。亦复如是。文殊师利。譬如日轮光明遍满无有减相。若得一行三昧。悉能具足一切功德无有缺少。亦复如是。照明佛法如日轮光。文殊师利。我所说法皆是一味离味。解脱味寂灭味。若善男子善女人得是一行三昧者。其所演说亦是一味离味。解脱味寂灭味。随顺正法无错谬相。文殊师利。若菩萨摩诃萨得是一行三昧。皆悉满足助道之法。速得阿耨多罗三藐三菩提。复次文殊师利。菩萨摩诃萨。不见法界有分别相及以一相。速得阿耨多罗三藐三菩提相不可思议。是菩提中亦无得佛。如是知者速得阿耨多罗三藐三菩提。若信一切法悉是佛法。不生惊怖亦不疑惑。如是忍者。速得阿耨多罗三藐三菩提。文殊师利白佛言。世尊。以如是因。速得阿耨多罗三藐三菩提耶。佛言。得阿耨多罗三藐三菩提。不以因得不以非因得。何以故。不思议界。不以因得不以非因得。若善男子善女人闻如是说不生懈怠。当知是人已于先佛种诸善根。是故比丘比丘尼。闻说是甚深般若波罗蜜。不生惊怖。即是从佛出家。若优婆塞优婆夷。得闻如是甚深般若波罗蜜。心不惊怖。即是成就真归依处

文殊师利。若善男子善女人不习甚深般若波罗蜜。即是不修佛乘。譬如大地一切药木皆依地生长。文殊师利。菩萨摩诃萨亦复如是。一切善根皆依般若波罗蜜而得增长。于阿耨多罗三藐三菩提。不相违背。尔时文殊师利白佛言。世尊。此阎浮提城邑聚落。当于何处演说如是甚深般若波罗蜜。佛告文殊师利。今此会中若有人闻般若波罗蜜。皆发誓言。于未来世常得与般若波罗蜜相应。从是信解。未来世中能听是经。当知此人不从余小善根中来。所能堪受闻已欢喜。文殊师利。若复有人从汝听是般若波罗蜜。应作是言。此般若波罗蜜中。无声闻辟支佛法佛法。亦无凡夫生灭等法。文殊师利白佛言。世尊。若比丘比丘尼优婆塞优婆夷。来问我言。云何如来说般若波罗蜜。我当答言。一切诸法无诤论相。云何如来当说般若波罗蜜。何以故。不见有法可与法诤论。亦无众生心识能知。复次世尊。我当更说究竟实际。何以故。一切法相同入实际。阿罗汉无别胜法。何以故。阿罗汉法凡夫法。不一不异故。复次世尊。如是说法。无有众生已得涅槃今得当得。何以故。无有决定众生相故。文殊师利言。若人欲闻般若波罗蜜。我当作如是说。其有听者。不念不着无闻无得。当如幻人无所分别。如是说者是真说法。是故听者莫作二相。不舍诸见而修佛法。不取佛法不舍凡夫法。何以故。佛及凡夫二法相空。无取舍故。若人问我。当作是说。如是安慰如是建立。善男子善女人应如是问作如是住。心不退不没。当如法相随顺。般若波罗蜜说。

尔时世尊叹文殊师利。善哉善哉。如汝所说。若善男子善女人欲见诸佛。应学如是般若波罗蜜。欲亲近诸佛如法供养。应学如是般若波罗蜜。若欲言如来是我世尊。应学如是般若波罗蜜。若言如来非我世尊。亦应学如是般若波罗蜜。若欲成阿耨多罗三藐三菩提。应学如是般若波罗蜜。若欲不成阿耨多罗三藐三菩提。亦应学如是般若波罗蜜。若欲成就一切三昧。应学如是般若波罗蜜。若欲不成就一切三昧。亦应学如是般若波罗蜜。何以故。无作三昧无异相故。一切法无生无出故。若欲知一切法假名。应学如是般若波罗蜜。若欲知一切众生修菩提道不求菩提相心不退没。应学如是般若波罗蜜。何以故。一切法皆菩提相故。若欲知一切众生行非行相。非行即菩提。菩提即法界。法界即实际。心不退没。应学如是般若波罗蜜。若欲知一切如来神通变化无相无碍亦无方所。应学如是般若波罗蜜。佛告文殊师利。若比丘比丘尼优婆塞优婆夷。欲得不堕恶趣。当学般若波罗蜜一四句偈受持读诵为他解说随顺实相。如是善男子善女人。当知决定得阿耨多罗三藐三菩提则住佛国。若闻如是般若波罗蜜。不惊不畏心生信解。当知此辈佛所印可。是佛所行大乘法印。若善男子善女人学此法印超过恶趣。不入声闻辟支佛道。以超过故。

尔时帝释三十三天。以天妙华优钵罗华拘物头华分陀利华天曼陀罗华等天栴檀香及余末香种种金宝作天伎乐。为供养般若波罗蜜并诸如来及文殊师利。以散其上。作是供养已。愿我常闻般若波罗蜜法印。释提桓因复作是愿。愿阎浮提善男子善女人。常使得闻是经决定佛法。皆令信解受持读诵为人演说。一切诸天为作拥护。尔时佛告释提桓因言。憍尸迦。如是如是。善男子。善女人当得决定诸佛菩提。文殊师利白佛言。世尊。如是受持善男子善女人。得大利益功德无量。尔时以佛神力。一切大地六种震动。佛时微笑放大光明。遍照三千大千世界。文殊师利白佛言世尊。即是如来印般若波罗蜜相。佛言。文殊师利。如是如是。说般若波罗蜜已皆现此瑞。为印般若波罗蜜故。使人受持令无赞毁。何以故。无相法印不可赞毁。我今以是法印。令诸天魔不能得便。佛说是已。尔时诸大菩萨及四部众。闻说般若波罗蜜。欢喜奉行

文殊师利所说摩诃般若波罗蜜经卷下


小品经

    No. 227 [Nos. 220(4or5), 224-226, 228, cf. 229]

    小品经序

        释僧睿

般若波罗蜜经者。穷理尽性之格言。菩萨成佛之弘轨也。轨不弘则不足以寮群异指其归。性不尽则物何以登道场成正觉。正觉之所以成。群异之所以一。何莫由斯道也。是以异教殷勤。三抚以之频发。功德叠校。九增以之屡至。如问相摽玄而玄其玄。幻品忘寄而忘其忘。道行坦其津。难问穷其源。随喜忘趣以要终。照明不化以即玄。章虽三十。贯之者道。言虽十万。倍之者行。行凝然后无生。道足然后补处及此而变一切智也。法华镜本以凝照。般若冥末以解悬解悬理趣。菩萨道也。凝照镜本告其终也。终而不泯则归途扶疏。有三实之迹。权应不夷。则乱绪纷纶。有惑趣之异。是以法华般若。相待以期终。方便实化。冥一以俟尽。论其穷理尽性夷明万行。则实不如照。取其大明真化解本无三。则照不如实。是故叹深则般若之功重。美实则法华之用微。此经之尊。三抚三嘱。未足惑也。有秦太子者。寓迹储宫。拟韵区外。玩味斯经。梦想增至。准悟大品。深知译者之失。会闻究摩罗法师。神授其文。真本犹存。以弘始十年二月六日。请令出之。至四月三十日。校正都讫。考之旧译。真若荒田之稼芸。过其半未讵多也。斯经正文。凡有四种。是佛异时适化广略之说也。其多者云。有十万偈。少者六百偈。此之大品。乃是天竺之中品也。随宜之言。复何必计其多少。议其烦简耶。梵文雅质案本译之。于丽巧不足。朴正有余矣。幸冀文悟之贤。略其华而几其实也

摩诃般若波罗蜜经卷第一(丹本摩诃上有小品二字)

        后秦龟兹国三藏鸠摩罗什译

    初品第一

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘僧千二百五十人俱皆是阿罗汉。诸漏已尽如调象王。所作已办舍于重担。逮得己利尽诸有结。正智解脱心得自在。唯除阿难。尔时佛告须菩提。汝乐说者。为诸菩萨说所应成就般若波罗蜜。舍利弗。即作是念。须菩提。自以力说。为承佛神力。须菩提知舍利弗心所念。语舍利弗言。佛诸弟子敢有所说皆是佛力。所以者何。佛所说法于中学者。能证诸法相。证已有所言说。皆与法相不相违背。以法相力故。尔时须菩提白佛言。世尊。佛使我为诸菩萨说所应成就般若波罗蜜。世尊。所言菩萨。菩萨者何等法义。是菩萨我不见有法名为菩萨。世尊。我不见菩萨不得菩萨。亦不见不得般若波罗蜜。当教何等菩萨般若波罗蜜。若菩萨闻作是说。不惊不怖不没不退。如所说行。是名教菩萨般若波罗蜜。复次世尊。菩萨行般若波罗蜜时。应如是学不念是菩萨心。所以者何。是心非心。心相本净故。尔时舍利弗语须菩提。有此非心心不。须菩提语舍利弗。非心心可得若有若无不。舍利弗言不也。须菩提语舍利弗。若非心心不可得有无者。应作是言。有心无心耶。舍利弗言。何法为非心。须菩提言。不坏不分别。菩萨闻作是说。不惊不怖不没不退。当知是菩萨不离般若波罗蜜行。若善男子善女人欲学声闻地。当闻是般若波罗蜜受持读诵如说修行。欲学辟支佛地。当闻是般若波罗蜜受持读诵如说修行。欲学菩萨地。亦当闻是般若波罗蜜受持读诵如说修行。所以者何。般若波罗蜜中广说菩萨所应学法。须菩提白佛言。世尊。我不得不见菩萨。当教何等菩萨般若波罗蜜。世尊。我不见菩萨法来去。而与菩萨作字言。是菩萨我则疑悔。世尊。又菩萨字无决定无住处。所以者何。是字无所有故。无所有亦无定无处。若菩萨闻是事。不惊不怖不没不退。当知是菩萨毕竟住不退转地。住无所住。复次世尊。菩萨行般若波罗蜜时。不应色中住。不应受想行识中住。何以故。若住色中为作色行。若住受想行识中。为作识行。若行作法。则不能受般若波罗蜜。不能习般若波罗蜜。不具足般若波罗蜜。则不能成就萨婆若。何以故。色无受想。受想行识无受想。若色无受则非色。受想行识无受则非识。般若波罗蜜亦无受。菩萨应如是学行般若波罗蜜。是名菩萨诸法无受三昧广大无量无定。一切声闻辟支佛所不能坏。何以故是三昧不可以相得。若是三昧可以相得。先尼梵志。于萨婆若智不应生信。先尼梵志以有量智入是法中。入已不受色。不受受想行识。是梵志不以得门见。是智不以内色见。是智不以外色见。是智不以内外色见。是智亦不离内外色见。是智不以内受想行识见。是智不以外受想行识见。是智不以内外受想行识见。是智亦不离内外受想行识见。是智先尼梵志信解萨婆若智。以得诸法实相故得解脱。得解脱已。于诸法中无取无舍。乃至涅槃亦无取无舍。世尊。是名菩萨般若波罗蜜。不受色不受受想行识。虽不受色不受受想行识。未具足佛十力四无所畏十八不共法。终不中道而般涅槃。复次世尊。菩萨行般若波罗蜜。应如是思惟。何等是般若波罗蜜。是谁般若波罗蜜。若法不可得。是般若波罗蜜耶。若菩萨作是思惟。观时不惊不畏不怖不没不退。当知是菩萨不离般若波罗蜜行尔时舍利弗语须菩提。若色离色性。受想行

识离识性。般若波罗蜜离般若波罗蜜性者。何故说菩萨不离般若波罗蜜行。须菩提言。如是舍利弗。色离色性。受想行识离识性。般若波罗蜜离般若波罗蜜性。是法皆离自性。性相亦离。舍利弗言。若菩萨于是中学。能成就萨婆若耶。须菩提言如是。舍利弗。菩萨如是学者。能成就萨婆若。所以者何。一切法无生无成就故。若菩萨如是行者。则近萨婆若

尔时须菩提语舍利弗言。菩萨若行色行为行相。若生色行为行相。若灭色行为行相。若坏色行为行相。若空色行为行相。我行是行亦是行相。若行受想行识行为行相。若生识行为行相。若灭识行为行相。若坏识行为行相。若空识行为行相。我行是行亦是行相。若作是念。能如是行者。是行般若波罗蜜。亦是行相。当知是菩萨未善知方便。舍利弗语须菩提。今菩萨云何行。名为行般若波罗蜜。须菩提言。若菩萨不行色。不行色生不行色灭。不行色坏不行色空。不行受想行识。不行识生不行识灭。不行识坏不行识空。是名行般若波罗蜜。不念行般若波罗蜜。不念不行。不念行不行。亦不念非行非不行。是名行般若波罗蜜。所以者何。一切法无受故。是名菩萨诸法无受三昧广大无量无定。一切声闻辟支佛所不能坏。菩萨行是三昧。疾得阿耨多罗三藐三菩提。须菩提承佛威神。而作是言。若菩萨行是三昧。不念不分别。是三昧我当入是三昧。我今入我已入。无如是分别。当知是菩萨已从诸佛。得受阿耨多罗三藐三菩提记。舍利弗语须菩提。菩萨所行三昧。得从诸佛受阿耨多罗三藐三菩提记。是三昧可得示不。须菩提言。不也舍利弗。何以故。善男子。不分别是三昧。所以者何。三昧性无所有故。佛赞须菩提言。善哉善哉。我说汝于无诤三昧人中最为第一。如我所说。菩萨应如是学般若波罗蜜。若如是学者。是名学般若波罗蜜。舍利弗白佛言。世尊。菩萨如是学为学何法。佛告舍利弗。菩萨如是学于法无所学。何以故。舍利弗。是诸法不尔如凡夫所著。舍利弗白佛言。世尊。今云何有。佛言。如无所有如是有。如是诸法无所有故名无明。凡夫分别无明贪着无明。堕于二边不知不见。于无法中忆想分别贪著名色。因贪着故。于无所有法不知不见。不出不信不住。是故堕在凡夫贪着数中。舍利弗白佛言。世尊。菩萨如是学亦不学萨婆若。佛告舍利弗。菩萨如是学亦不学萨婆若。如是学亦名学萨婆若。成就萨婆若。须菩提白佛言。世尊。若有问幻人学萨婆若当成就萨婆若不。世尊。我当云何答。须菩提。我还问汝随意答。于意云何。幻异色色异幻。幻异受想行识耶。须菩提言幻不异色色不异幻。幻即是色色即是幻。幻不异受想行识。识不异幻。幻即是识识即是幻。须菩提。于意云何。五受阴名为菩萨不。如是世尊。佛告须菩提。菩萨学阿耨多罗三藐三菩提。当如幻人学。何以故。当知五阴即是幻人。所以者何。说色如幻。说受想行识如幻。识是六情五阴。世尊。新发意菩萨闻是说者将无惊怖退没耶。佛告须菩提。若新发意菩萨随恶知识。则惊怖退没。若随善知识闻是说者。则无惊怖没退。须菩提言。世尊。何等是菩萨恶知识。佛言。教令远离般若波罗蜜。使不乐菩提。又教令学取相分别严饰文颂。又教学杂声闻辟支佛经法。又与作魔事因缘。是名菩萨恶知识。世尊。何等为菩萨善知识。若教令学般若波罗蜜。为说魔事说魔过恶。令知魔事魔过恶已。教令远离。须菩提。是名发大乘心大庄严菩萨摩诃萨善知识。须菩提白佛言。世尊。所言菩萨。菩萨有何义。佛告须菩提。为学一切法无障碍。亦如实知一切法。是名菩萨义。须菩提白佛言。世尊。若知一切法名为菩萨义。复以何义。名为摩诃萨。佛言。当为大众作上首。名为摩诃萨义。舍利弗白佛言。世尊。我亦乐说所以为摩诃萨义。佛言。乐说便说。舍利弗白佛言。世尊。菩萨为断我见众生见寿者见人见有见无见断见常见等而为说法。是名摩诃萨义。于是中心无所著。亦名摩诃萨义。舍利弗问须菩提。何故于是中心无所著。须菩提言。无心故于是中心无所著。富楼那弥多罗尼子白佛言。世尊。菩萨发大庄严乘大乘故。是名摩诃萨义。须菩提白佛言。世尊。所言菩萨发大庄严。云何名为发大庄严。佛言。菩萨作是念。我应度无量阿僧祇众生。度众生已无有众生灭度者。何以故。诸法相尔。譬如工幻师于四衢道化作大众悉断化人头。于意云何。宁有伤有死者不。须菩提言。不也世尊。佛言。菩萨亦如是。度无量阿僧祇众生已。无有众生灭度者。若菩萨闻是事不惊不怖。当知是菩萨发大庄严。须菩提言。如我解佛所说义。当知是菩萨发大庄严而自庄严。何以故。萨婆若是不作不起法。为众生故发大庄严。是众生亦是不作不起法。何以故。色无缚无解。受想行识无缚无解故。富楼那语须菩提。色无缚无解。受想行识无缚无解耶。须菩提言。色无缚无解。受想行识无缚无解。富楼那言。何等色无缚无解。何等受想行识无缚无解。须菩提言。幻人色是无缚无解。幻人受想行识是无缚无解。无所有故无缚无解。离故无缚无解。无生故无缚无解。是名菩萨摩诃萨发大庄严而自庄严。须菩提白佛言。世尊。云何为大乘。云何为菩萨发趣大乘。是乘住何处。是乘从何处出。佛告须菩提。大乘者无有量无分数故。是乘从何处出。住何处者。是乘从三界出住萨婆若。无乘是乘出者。何以故。出法出者俱无所有。何法当出。须菩提白佛言。世尊。所言摩诃衍。摩诃衍者。胜出一切世间天人阿修罗。世尊。摩诃衍与虚空等。如虚空受无量阿僧祇众生摩诃衍亦如是。受无量阿僧祇众生。是摩诃衍。如虚空无来处无去处无住处。摩诃衍亦如是。不得前际不得中际不得后际。是乘三世等。是故名为摩诃衍。佛赞须菩提言。善哉善哉。诸菩萨摩诃萨摩诃衍。应如汝所说。尔时富楼那弥多罗尼子白佛言。世尊。佛使须菩提说般若波罗蜜乃说摩诃衍。须菩提白佛言。世尊。我所说将无离般若波罗蜜耶。不也须菩提。汝所说随顺般若波罗蜜。世尊。我不得过去世菩萨。亦不得未来现在世菩萨。色无边故。菩萨亦无边。受想行识无边故。菩萨亦无边。世尊。如是一切处一切时一切种。菩萨不可得。当教何等菩萨般若波罗蜜。我不得不见菩萨。当教何法入般若波罗蜜。世尊。所言菩萨。菩萨者但有名字。譬如所说我我法毕竟不生。世尊。一切法性亦如是。此中何等是色不着不生。何等是受想行识不着不生。色是菩萨不可得。受想行识是菩萨不可得。不可得亦不可得。世尊。一切处一切时一切种。菩萨不可得。当教何法入般若波罗蜜。世尊。菩萨但有名字。如我毕竟不生。诸法性亦如是。此中何等是色不着不生。何等是受想行识不着不生。诸法性如是。是性亦不生。不生亦不生。世尊。我今当教不生法入般若波罗蜜耶。何以故。离不生法不可得。菩萨行阿耨多罗三藐三菩提。若菩萨闻作是说不惊不怖。当知是菩萨行般若波罗蜜。世尊。菩萨随行般若波罗蜜时。作是观。诸法即不受色。何以故。色无生即非色。色无灭即非色。无生无灭无二无别。若说是色即是无二法。菩萨行般若波罗蜜。时不受受想行识。何以故。识无生即非识。识无灭即非识。无生无灭无二无别。若说识即是无二法。舍利弗问须菩提。如我解须菩提所说义。菩萨即是无生。若菩萨无生。何以故。有难行为众生故受苦恼。须菩提言。我不欲使菩萨有难行。何以故。生难行想苦行想。不能利益无量阿僧祇众生。于众生生易想乐想父母想子想我所想。则能利益无量阿僧祇众生。如我法一切处一切时一切种不可得。菩萨于内外法中。应生如是想。若菩萨以如是心行亦名难行。如舍利弗所言。菩萨无生。如是舍利弗。菩萨实无生。舍利弗言。但菩萨无生萨婆若亦无生。须菩提言。萨婆若亦无生。舍利弗言。萨婆若无生凡夫亦无生须菩提言。凡夫亦无生。舍利弗语须菩提。若菩萨无生菩萨法亦无生。萨婆若无生。萨婆若法亦无生。凡夫无生凡夫法亦无生。今以无生得无生。菩萨应得萨婆若。须菩提言。我不欲令无生法有所得。何以故。无生法不可得故。舍利弗言。生生无生生。汝所言乐说为生为无生。须菩提言。诸法无生。所言无生乐说亦无生。如是乐说。舍利弗言。善哉善哉。须菩提。汝于说法人中为最第一。何以故。须菩提。随所问皆能答故。须菩提言。法应尔。诸佛弟子于无依止法所问能答。何以故。一切法无定故。舍利弗言。善哉善哉。是何波罗蜜力。须菩提言。是般若波罗蜜力。舍利弗。若菩萨闻如是说如是论时。不疑不悔不难。当知是菩萨行是行不离是念。舍利弗言。若菩萨不离是行不离是念一切众生亦不离是行不离是念。一切众生亦当是菩萨。何以故。一切众生不离是念故。须菩提言。善哉善哉舍利弗。汝欲离我而成我义。所以者何。众生无性故当知念亦无性。众生离故念亦离。众生不可得故念亦不可得。舍利弗。我欲令菩萨以是念行般若波罗蜜

    摩诃般若波罗蜜释提桓因品第二

尔时释提桓因。与四万天子俱在会中。四天王与二万天子俱在会中。娑婆世界主梵天王。与万梵天俱在会中。乃至净居天众无数千种俱在会中。是诸天众业报光明。以佛身神力光明故皆不复现。尔时释提桓因语须菩提言。是诸无数天众皆共集会。欲听须菩提说般若波罗蜜义。菩萨云何住般若波罗蜜。须菩提语释提桓因及诸天众。憍尸迦。我今当承佛神力说般若波罗蜜。若诸天子未发阿耨多罗三藐三菩提心者。今应当发。若人已入正位。则不堪任发阿耨多罗三藐三菩提心。何以故。已于生死作障隔故。是人若发阿耨多罗三藐三菩提心。我亦随喜。终不断其功德。所以者何。上人应求上法。尔时佛赞须菩提言。善哉善哉。汝能如是劝乐诸菩萨。须菩提言。世尊。我当报佛恩。如过去诸佛及诸弟子。教如来住空法中。亦教学诸波罗蜜。如来学是法。得阿耨多罗三藐三菩提。世尊。我今亦当如是护念诸菩萨。以我护念因缘故。诸菩萨当疾得阿耨多罗三藐三菩提。须菩提语释提桓因言。憍尸迦。汝一心听菩萨住般若波罗蜜。憍尸迦。菩萨发大庄严乘。于大乘以空法住般若波罗蜜。不应住色。不应住受想行识。不应住色若常若无常。不应住受想行识若常若无常。不应住色若苦若乐。不应住受想行识若苦若乐。不应住色若净若不净。不应住受想行识若净若不净。不应住色若我若无我。不应住受想行识若我若无我。不应住色若空若不空。不应住受想行识若空若不空。不应住须陀洹果。不应住斯陀含果。不应住阿那含果。不应住阿罗汉果。不应住辟支佛道。不应住佛法。不应住须陀洹无为果。不应住须陀洹福田。不应住须陀洹乃至七往来生死。不应住斯陀含无为果。不应住斯陀含福田。不应住斯陀含一来此间当得尽苦。不应住阿那含无为果不应住阿那含福田不应住阿那含彼间灭度。不应住阿罗汉无为果。不应住阿罗汉福田。不应住阿罗汉今世入无余涅槃。不应住辟支佛道无为果。不应住辟支佛福田。不应住辟支佛过声闻地不及佛地而般涅槃。不应住佛法。利益无量众生。灭度无量众生。尔时舍利弗。作是念。菩萨当云何住。须菩提知舍利弗心所念。语舍利弗。于意云何如来为住何处。舍利弗言。如来无所住无住心名为如来。如来不住有为性。亦不住无为性。舍利弗。菩萨摩诃萨亦应如是住。如如来住于一切法。非住非不住。尔时众中有诸天子作是念。诸夜叉众语言章句尚可知义。须菩提所说所论难可得解。须菩提知诸天子心所念。语诸天子言。是中无说无示无听。诸天子作是念。须菩提欲令此义易解而转深妙。须菩提知诸天子心所念。语诸天子言。若行者欲证须陀洹果。欲住须陀洹果不离是忍。欲证斯陀含果阿那含果阿罗汉果。欲证辟支佛道。欲证佛法。亦不离是忍。尔时诸天子作是念。何等人能随顺听须菩提所说。须菩提知诸天子心所念。语诸天子言。幻人能随顺听我所说。而无听无证。诸天子作是念。但听者如幻。众生亦如幻。须陀洹果乃至辟支佛道亦如幻。须菩提。知诸天子心所念。语诸天子言。我说众生如幻如梦。须陀洹果亦如幻如梦。斯陀含果阿那含果阿罗汉果辟支佛道亦如幻如梦。诸天子言。须菩提。亦说佛法如幻如梦。须菩提言。我说佛法亦如幻如梦。我说涅槃亦如幻如梦。诸天子言。大德须菩提。亦说涅槃如幻如梦耶。须菩提言。诸天子设复有法过于涅槃。我亦说如幻如梦。诸天子。幻梦涅槃无二无别。尔时舍利弗。富楼那弥多罗尼子。摩诃拘絺罗。摩诃迦栴延。问须菩提。如是说般若波罗蜜义。谁能受者。时阿难言。如是说般若波罗蜜义。阿毗跋致菩萨具足正见者满愿阿罗汉。是等能受。须菩提言。如是说般若波罗蜜义无能受者。所以者何。此般若波罗蜜法中。无法可说无法可示。以是义故无能受者。尔时释提桓因作是念。长老须菩提为雨法雨。我宁可化作华散须菩提上。释提桓因即化作华散须菩提上。须菩提作是念。释提桓因今所散华。我于忉利天上所未曾见。是华从心树出不从树生。释提桓因知须菩提心所念。语须菩提言。是华非生华。亦非心树生。须菩提语释提桓因言。憍尸迦。汝言是华非生华。亦非心树生。若非生法不名为华。释提桓因作是念。长老须菩提智慧甚深。不坏假名而说实义。念已语须菩提言。如是如是须菩提。如须菩提所说。菩萨应如是学。菩萨如是学者。不学须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。若不学是地。是名学佛法学萨婆若。若学佛法学萨婆若。则学无量无边佛法。若学无量无边佛法者。不为增减色学。不为增减受想行识学。不为受色学。不为受受想行识学。是人于法无所取无所灭故学。舍利弗语须菩提。行者不为取萨婆若。不为灭萨婆若故学。须菩提言。如是如是舍利弗菩萨乃至萨婆若。不取不灭故学。如是观时。能学萨婆若能成就萨婆若。尔时释提桓因语舍利弗。菩萨摩诃萨般若波罗蜜。当于何求。舍利弗言。般若波罗蜜当于须菩提所转中求。释提桓因语须菩提。是谁神力。须菩提言。是佛神力。憍尸迦。如所问般若波罗蜜当于何求。般若波罗蜜不应色中求。不应受想行识中求。亦不离色求。亦不离受想行识求。何以故。色非般若波罗蜜。离色亦非般若波罗蜜。受想行识非般若波罗蜜。离受想行识亦非般若波罗蜜。释提桓因言。摩诃波罗蜜是般若波罗蜜。无量波罗蜜是般若波罗蜜。无边波罗蜜是般若波罗蜜。须菩提言。如是如是憍尸迦。摩诃波罗蜜是般若波罗蜜。无量波罗蜜是般若波罗蜜。无边波罗蜜是般若波罗蜜。憍尸迦。色无量故般若波罗蜜无量。受想行识无量故般若波罗蜜无量。缘无边故般若波罗蜜无边。众生无边故般若波罗蜜无边。憍尸迦。云何缘无边故般若波罗蜜无边。诸法无前无中无后。是故缘无边般若波罗蜜无边。复次憍尸迦。诸法无边。前际不可得。中际后际不可得。是故缘无边般若波罗蜜无边。释提桓因言长老须菩提。云何众生无边般若波罗蜜无边。憍尸迦。众生无量算数不可得是故众生无边般若波罗蜜无边。释提桓因言。大德须菩提众生有何义。须菩提言。众生义即是法义。于意云何。所言众生。众生有何义。释提桓因言。众生非法义。亦非非法义。但有假名。是名字无本无因。强为立名名为众生。须菩提言。于意云何。此中实有众生可说可示不。不也。须菩提言。憍尸迦。若众生不可说不可示。云何言众生无边般若波罗蜜无边。憍尸迦。若如来住寿如恒河沙劫。说言众生。众生实有众生生灭不。释提桓因言不也。何以故。众生从本已来常清净故。憍尸迦。是故当知众生无边般若波罗蜜无边

小品般若经卷第一小品般若波罗蜜经卷第二

        后秦龟兹国三藏鸠摩罗什译

    塔品第三(丹本云宝答品)

尔时释提桓因梵天王自在天王。及众生主诸天女等。皆大欢喜。同时三唱快哉快哉。佛出世故。须菩提乃能演说是法。尔时诸天大众俱白佛言。世尊。若菩萨能不离般若波罗蜜行。当视是人如佛。佛告诸天子。如是如是。昔我于众华城燃灯佛所不离般若波罗蜜行时燃灯佛记我。于来世过阿僧祇劫。当得作佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。诸天子白佛言。希有世尊。诸菩萨摩诃萨般若波罗蜜。能摄取萨婆若。佛因释提桓因。告欲色界诸天子及四众比丘比丘尼优婆塞优婆夷等。憍尸迦。若有善男子善女人。能受持读诵般若波罗蜜。如所说行。魔若魔天人若非人。不得其便终不横死。善男子善女人。受持读诵般若波罗蜜故。忉利诸天发阿耨多罗三藐三菩提心。未受持读诵般若波罗蜜者来至其所。复次憍尸迦。善男子善女人。受持读诵般若波罗蜜时。若在空舍若在道路若或失道无有恐怖。尔时四天王白佛言。世尊。若善男子善女人。受持读诵般若波罗蜜。如所说行。我等皆当护念。释提桓因白佛言。世尊。若善男子善女人。受持读诵般若波罗蜜。如所说行。我当护念。梵天王及诸梵天俱白佛言。世尊。若善男子善女人。受持读诵般若波罗蜜。如所说行。我等亦当护念。释提桓因白佛言。希有世尊。善男子善女人。受持读诵般若波罗蜜。得如是现世功德。世尊。若受持般若波罗蜜者。则为受持诸波罗蜜。佛言如是如是。憍尸迦。受持般若波罗蜜者。则为受持诸波罗蜜。复次憍尸迦。善男子善女人。受持读诵般若波罗蜜。所得功德。汝今善听当为汝说。释提桓因受教而听。佛告憍尸迦。若有欲毁乱违逆我此法者虽有是心渐渐自灭终不从愿。何以故。憍尸迦。若善男子善女人。受持读诵般若波罗蜜。种种毁乱违逆事起法应皆灭。是故此人终不从愿。憍尸迦。善男子善女人。受持读诵般若波罗蜜。得如是现世功德。譬如有药名为摩醯。有蛇饥行求食。见有小虫而欲食之。虫赴药所。蛇闻药气即回还去。所以者何。药力能消蛇毒故。憍尸迦。善男子善女人亦如是。若受持读诵般若波罗蜜。种种毁乱违逆事起。以般若波罗蜜力故即自消灭。复次憍尸迦。若受持读诵般若波罗蜜。护世四天王皆当护念。复次憍尸迦。是人终不说无益之语。有所言说人所信受。少于嗔恚终不怀恨。不为我慢所覆。不为嗔恚所使。善男子善女人若嗔恚时。能作是念。若我嗔者则坏诸根颜色变异。我欲求阿耨多罗三藐三菩提。云何当随嗔心。如是思惟。即得正念。憍尸迦。善男子善女人。受持读诵般若波罗蜜。亦得是现世功德。释提桓因白佛言。希有世尊。般若波罗蜜为回向故不为高心。佛告憍尸迦。善男子善女人。受持读诵般若波罗蜜。若人军阵诵般若波罗蜜。若住若出。若失寿命若被恼害。无有是处。若刀箭向者终不能伤。何以故。般若波罗蜜是大咒术无上咒术。善男子善女人学此咒术。不自念恶不念他恶。不两念恶学是咒术。得阿耨多罗三藐三菩提。得萨婆若智。能观一切众生心。复次憍尸迦。若般若波罗蜜经卷住处若读诵处。人若非人不得其便唯除业行必应受者。憍尸迦。譬如道场四边若人若畜生无能恼者。何以故。过去未来现在诸佛此中得道。已得今得当得。是处一切众生。无恐无畏无能恼害。憍尸迦。以般若波罗蜜故。是处则吉人所恭敬供养礼拜。释提桓因白佛言。世尊。若善男子善女人书般若波罗蜜。受持经卷供养恭敬尊重赞叹。以好花香璎珞涂香烧香末香杂香缯盖幢幡而以供养。若复有人以如来舍利。供养恭敬尊重赞叹。以好花香璎珞涂香烧香末香杂香缯盖幢幡而以供养其福何所为多。憍尸迦。我还问汝。随汝意答。于意云何。如来行何道。得萨婆若所依止身。得阿耨多罗三藐三菩提。释提桓因白佛言。世尊。如来学般若波罗蜜故。得是身得阿耨多罗三藐三菩提。憍尸迦。佛不以身故名为如来。以得萨婆若故名为如来。憍尸迦。诸佛萨婆若从般若波罗蜜生。是身萨婆若智所依止故。如来因是身得萨婆若智。成阿耨多罗三藐三菩提。是身萨婆若所依止故。我灭度后舍利得供养。憍尸迦。若善男子善女人书般若波罗蜜。受持读诵供养恭敬尊重赞叹。以好花香璎珞涂香烧香末香杂香缯盖幢幡而以供养。是善男子善女人即是供养萨婆若智。是故若人书写般若波罗蜜。供养恭敬尊重赞叹。当知是人得大福德。何以故供养萨婆若智故。释提桓因白佛言。世尊。阎浮提人不供养恭敬尊重赞叹般若波罗蜜。为不知得如是大利益耶。佛言。憍尸迦。于意云何。阎浮提有几所人于佛得不坏信。几所人于法于僧得不坏信。释提桓因言。少所人于佛得不坏信。于法于僧得不坏信。世尊。阎浮提少所人。得须陀洹斯陀含阿那含阿罗汉。得辟支佛者转复减少。能行菩萨道者亦复转少。如是如是憍尸迦。阎浮提少所人。于佛得不坏信。乃至能发阿耨多罗三藐三菩提心。行菩萨道者亦复转少。憍尸迦。无量无边阿僧祇众生。发阿耨多罗三藐三菩提心。于中若一若二住阿毗跋致地。是故当知善男子善女人。发阿耨多罗三藐三菩提心。乃至能受持读诵供养恭敬尊重赞叹般若波罗蜜。何以故。是人作是念。过去诸佛行菩萨道时。从是中学。我等亦应于是中学。般若波罗蜜是我大师。憍尸迦。若我现在若我灭后。菩萨常应依止般若波罗蜜。若善男子善女人于我灭后。以供养如来故起七宝塔。尽其形寿。以好花香涂香末香衣服幢幡。供养是塔。于意云何。是善男子善女人。以是因缘故。得福多不。释提桓因言。甚多世尊。佛言憍尸迦。若善男子善女人。供养般若波罗蜜经卷。恭敬尊重赞叹。以好华香涂香末香衣服幢幡。而以供养。其福甚多。憍尸迦。置是一塔。若满阎浮提七宝塔。善男子善女人尽其形寿。以好华香乃至伎乐。供养是塔于意云何。是人以是因缘故。得福多不。释提桓因言。甚多世尊。佛告憍尸迦。若善男子善女人。供养般若波罗蜜经卷。恭敬尊重赞叹。以好华香涂香末香衣服幢幡。其福甚多。憍尸迦。置是满阎浮提七宝塔。若满四天下七宝塔。若人尽形寿。以花香供养乃至伎乐。若复有人供养般若波罗蜜。其福甚多。憍尸迦。置是满四天下七宝塔。若满周梨迦小千世界七宝塔。若人尽形。以好华香供养乃至幢幡。若复有人供养般若波罗蜜。其福甚多。憍尸迦。置是周梨迦小千世界七宝塔。若满二千中世界七宝塔。若人尽形。以花香供养乃至幢幡。若复有人供养般若波罗蜜。其福甚多。憍尸迦。置是二千中世界。若满三千大千世界七宝塔。若善男子善女人。尽其形寿。以花香供养乃至幢幡。憍尸迦。于意云何。是人以是因缘故。得福多不。释提桓因言。甚多世尊。佛告憍尸迦。若复有人供养般若波罗蜜经卷。恭敬尊重赞叹花香乃至幢幡。其福甚多。憍尸迦。置是满三千大千世界七宝塔。假令三千大千世界所有众生。一时皆得人身。是一一人起七宝塔。尽其形寿。以一切好华名香幢幡伎乐歌舞。供养是塔。憍尸迦。于意云何。是人以是因缘故。得福多不。甚多世尊。佛告憍尸迦。若善男子善女人。供养般若波罗蜜经卷。恭敬尊重赞叹。花香乃至幢幡其福甚多。释提桓因言。如是如是世尊。若人供养般若波罗蜜。即是供养恭敬过去未来现在诸佛萨婆若。世尊。置是三千大千世界一一众生所起七宝塔。若满十方恒河沙等世界众生。皆得人身一一人起七宝塔。若于一劫若减一劫。以好华香乃至伎乐。供养是塔。若复有人供养般若波罗蜜经卷。恭敬尊重赞叹。华香乃至伎乐。其福甚多。佛言。如是如是憍尸迦。是善男子善女人。以是供养般若波罗蜜经卷因缘故。其福甚多。无量无边不可得数不可思议。何以故。憍尸迦。一切诸佛萨婆若智。皆从般若波罗蜜生。憍尸迦。以是因缘故。若善男子善女人。供养般若波罗蜜经卷。恭敬尊重赞叹。华香乃至伎乐供养。于前功德。百分不及一分。千分万分百千万亿分不及一。乃至算数譬喻所不能及

    摩诃般若波罗蜜明咒品第四

尔时释提桓因。与四万天子在会中者。语释提桓因言。憍尸迦。应受持读诵般若波罗蜜。佛告释提桓因。憍尸迦。汝受持读诵般若波罗蜜。若阿修罗生念。欲与忉利诸天共斗。尔时汝当诵念般若波罗蜜。以是因缘故。阿修罗恶心即灭。释提桓因白佛言。世尊。般若波罗蜜是大明咒。般若波罗蜜是无上咒。般若波罗蜜是无等等咒。佛言。如是如是憍尸迦。般若波罗蜜是大明咒。般若波罗蜜是无上咒。般若波罗蜜是无等等咒。何以故。憍尸迦。过去诸佛因是明咒。得阿耨多罗三藐三菩提。未来诸佛亦因是咒。当得阿耨多罗三藐三菩提。今十方现在诸佛亦因是咒。得阿耨多罗三藐三菩提。憍尸迦。因是明咒十善道出现于世。四禅四无量心四无色定五神通出现于世。因菩萨故。十善道出现于世。四禅四无量心四无色定五神通出现于世。若诸佛不出于世。但因菩萨故。十善道四禅四无量心四无色定五神通出现于世。譬如月不出时星宿光明照于世间。如是憍尸迦。世无佛时。所有善行正行皆从菩萨出生。菩萨方便力皆从般若波罗蜜生。复次憍尸迦。若善男子善女人供养般若波罗蜜经卷。恭敬尊重赞叹得是现世福德。释提桓因。白佛言。世尊。得何等现世福德。憍尸迦。是善男子善女人毒不能伤火不能烧。终不横死。又善男子善女人若官事起。诵念般若波罗蜜。官事即灭。诸求短者皆不得便。何以故。般若波罗蜜所护故。复次憍尸迦。善男子善女人诵念般若波罗蜜。若至国王若王子大臣所。皆欢喜问讯与共语言。何以故。憍尸迦。般若波罗蜜为慈悲一切众生故出。是故憍尸迦。诸求短者皆不得便。尔时外道出家百人。欲求佛短来向佛所。释提桓因作是念。是诸外道出家百人。欲求佛短来向佛所。我从佛所受般若波罗蜜。今当诵念。是诸外道来至佛所。或能断说般若波罗蜜。如是思惟已。即诵念从佛所受般若波罗蜜。时诸外道遥绕佛复道而去。舍利弗作是念。何因缘故是诸外道绕佛而去。佛知舍利弗心所念。告舍利弗。是释提桓因诵念般若波罗蜜。如是外道乃无一人有善心者。皆持恶意来求佛短。是故外道各各复道而去。尔时恶魔作是念。今是四众及欲色界诸天子在佛前坐。其中必有菩萨受阿耨多罗三藐三菩提记者。我当坏乱。即化作四种兵向佛所。尔时释提桓因作是念。魔严四兵来至佛所。四种兵相。摩伽陀国频婆娑罗王之所无有。憍萨罗国波斯匿王亦所无有。诸释子所无有。诸黎车所无有。今是兵相必是恶魔所作。是魔长夜欲求佛短恼乱众生。我当诵念般若波罗蜜。释提桓因即默诵般若波罗蜜。随其所诵恶魔稍稍复道而去。尔时忉利诸天。化作天华在于空中。散佛上作是念愿。般若波罗蜜久住阎浮提。阎浮提人当得诵习。是时诸天复以天花散佛上作是言。世尊。若有众生行般若波罗蜜。修习般若波罗蜜魔若魔天不得其便。尔时释提桓因白佛言。世尊。若人得闻般若波罗蜜者。已曾亲近诸佛。不从小功德来。何况受持读诵。如所说学如所说行。何以故。世尊诸菩萨萨婆若当于般若波罗蜜中求。世尊。譬如大宝当于大海中求。世尊。诸佛萨婆若大宝。应于般若波罗蜜中求。佛言。如是如是。憍尸迦。诸佛萨婆若皆于般若波罗蜜中生。尔时阿难白佛言。世尊。世尊不赞说檀波罗蜜名。不赞说尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜名何以故。但赞说般若波罗蜜名。佛告阿难。般若波罗蜜导五波罗蜜。阿难于意云何。若布施不回向萨婆若。成檀波罗蜜不。阿难言。不也世尊。若持戒忍辱精进禅定智慧。不回向萨婆若。成般若波罗蜜不。阿难言。不也世尊。阿难。是故般若波罗蜜为五波罗蜜导。阿难。譬如大地种散其中。因缘和合即得生长。不依此地终不得生。阿难。如是五波罗蜜住般若波罗蜜中而得增长。为般若波罗蜜所护故。得向萨婆若。是故阿难。般若波罗蜜为五波罗蜜作导。尔时释提桓因白佛言。世尊。是善男子善女人受持读诵般若波罗蜜。如所说行所得功德。如来说之犹亦未尽。佛告憍尸迦。我不但说是人受持读诵般若波罗蜜如所说行功德。憍尸迦。若有善男子善女人供养般若波罗蜜经卷。恭敬尊重赞叹。以好华香乃至幢幡。我亦说其所得功德。释提桓因白佛言。世尊。我亦当护念是善男子善女人。供养般若波罗蜜经卷恭敬尊重赞叹。以好华香乃至幢幡者。佛言。憍尸迦。是善男子善女人。受持读诵般若波罗蜜。若干百千诸天大众。为听法故来至其所。是法师为诸天说法时。非人益其气力。若法师疲极不乐说法。诸天恭敬法故令其乐说。憍尸迦。是亦善男子善女人得是现世功德。复次憍尸迦。是善男子善女人于四众中说般若波罗蜜时。其心不畏有来难问及诘责者。何以故。是人为般若波罗蜜护念故。不见有人得般若波罗蜜短者。般若波罗蜜亦无短可得。是人如是为般若波罗蜜护念故。无畏有来难问诘责者。憍尸迦。是亦善男子善女人现世功德。复次憍尸迦。是善男子善女人读诵般若波罗蜜故。为父母所爱。为宗亲知识沙门婆罗门所敬。衰恼斗讼如法能度。憍尸迦。是亦善男子善女人现世功德。复次憍尸迦。般若波罗蜜经卷所住处。四天王天上诸天发阿耨多罗三藐三菩提心者。皆来至般若波罗蜜所。受持读诵供养作礼而去。忉利天夜摩天兜率陀天化乐天他化自在天上诸天。发阿耨多罗三藐三菩提心者。皆来至般若波罗蜜所。受持读诵供养作礼而去。梵天梵世天梵辅天梵众天大梵天光天少光天无量光天光音天净天少净天无量净天遍净天无阴行天福生天广果天无广天无热天妙见天善见天无小天上诸天。发阿耨多罗三藐三菩提心者。皆来至般若波罗蜜所。受持读诵供养作礼而去。憍尸迦。汝勿谓但有无小天为供养般若波罗蜜故来。三千大千世界中欲色界诸天。发阿耨多罗三藐三菩提心者。皆来至般若波罗蜜所。受持读诵供养作礼而去。善男子善女人应作是念。十方无量阿僧祇国土中。所有诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。是等来至般若波罗蜜所。受持读诵供养作礼。时我当以般若波罗蜜法施。善男子善女人般若波罗蜜经卷所住处。若殿堂若房舍无能毁坏。除先行业必应受者。憍尸迦。亦是善男子善女人现世功德。释提桓因白佛言。世尊。是善男子善女人云何知诸天来受持读诵供养礼敬般若波罗蜜时。佛言。憍尸迦。若善男子善女人见大光明。必知天龙夜叉乾闼婆等来至其所。复次憍尸迦。善男子善女人若闻殊异之香。必知诸天来至其所。复次憍尸迦。善男子善女人所住之处应令净洁。以净洁故非人皆大欢喜来到其所。是中先住小鬼。不堪大力诸天威德故皆悉避去。随大力诸天数数来故。其心转乐大法。是故所住处四边不应令有臭秽不净。复次憍尸迦。善男子善女人身不疲极。卧起安隐不见恶梦。若其梦时但见诸佛诸佛塔庙。阿罗汉众诸菩萨众。修习六波罗蜜。学萨婆若净佛世界。又闻佛名某甲佛于某方某国与若干百千万亿众恭敬围绕而为说法。憍尸迦。善男子善女人梦中所见如是。觉已安乐气力充足身体轻便。是善男子善女人不贪饮食。譬如坐禅比丘从三昧起。以学禅故不贪饮食。何以故。憍尸迦。非人益其气力故。善男子善女人欲得如是等现世功德。当受持读诵般若波罗蜜如所说行。憍尸迦。善男子善女人若不能受持读诵般若波罗蜜如所说行。当书写经卷供养恭敬尊重赞叹以好华香涂香末香烧香杂香衣服幢幡伎乐

    摩诃般若波罗蜜舍利品第五

尔时佛告释提桓因言。憍尸迦。满阎浮提舍利以为一分。般若波罗蜜经卷以为一分。二分之中为取何分。释提桓因白佛言。世尊。我取般若波罗蜜。何以故。世尊。我于舍利非不恭敬。以舍利从般若波罗蜜生故。般若波罗蜜所熏故得供养。世尊。我于忉利天上善法堂中。我有坐处。忉利诸天子来供养我故。若我不在座上诸天子为我坐处。作礼恭敬绕已而去。作是念。释提桓因于此处坐为忉利诸天说法。诸佛舍利亦如是。从般若波罗蜜生。萨婆若所依止故得供养。是故世尊。我于二分之中。取般若波罗蜜。世尊。置满阎浮提舍利。若满三千大千世界舍利以为一分。般若波罗蜜经卷以为一分。二分之中我取般若波罗蜜。何以故。诸佛舍利。因般若波罗蜜生故得供养。世尊。譬如负债人常畏债主。以得亲近奉事王故。债主反更恭敬怖畏。何以故。依恃国王其力大故。世尊。舍利亦如是。依止般若波罗蜜故得供养。世尊。般若波罗蜜如王。舍利如亲近王人。如来舍利依止一切智慧故得供养。世尊。诸佛一切智慧。亦从般若波罗蜜生是故我于二分之中取般若波罗蜜。世尊。譬如无价宝珠有如是功德。其所住处非人不能得其便。若男若女若大若小。为非人所持宝珠至其处非人则去。若有热病珠能除灭。若有风病以珠着身上风患即除。若有冷病以珠着身上冷患亦除是珠住处夜时能为明。热时能为凉。寒时能为温。珠所住处蛇毒不入。若男若女若大若小。为毒虫所螫。以珠示之毒即除灭若诸目患以珠着目上目患即除。世尊。又是宝珠若着水中与水同色若以白缯裹着水中水色即白若以青黄紫赤种种色缯。裹着水中。水即各随其色。水浊即为清。是珠成就如是功德。尔时阿难问释提桓因。此是阎浮提宝为是天上宝。释提桓因言。此是天上宝。阎浮提人亦有是宝。但功德少而重。天上宝珠功德多而轻。人宝比天宝。算数譬喻所不能及。世尊。若是珠在箧中虽举珠去。以珠功德故其箧则贵。世尊以般若波罗蜜萨婆若智功德故。如来灭后舍利得供养。以如来舍利。是萨婆若智所住处故。我于二分之中取般若波罗蜜。世尊。置是满三千大千世界舍利。若满如恒河沙等世界中舍利以为一分。般若波罗蜜经卷以为一分。二分之中我取般若波罗蜜。何以故。诸佛如来萨婆若智。皆从般若波罗蜜生。萨婆若所熏故舍利得供养。复次世尊。若善男子善女人欲如实见十方无量阿僧祇诸佛者。当行般若波罗蜜。当修般若波罗蜜。佛言。如是如是。憍尸迦。过去诸佛皆因般若波罗蜜。得阿耨多罗三藐三菩提。未来诸佛亦因般若波罗蜜。得阿耨多罗三藐三菩提。现在十方无量阿僧祇世界诸佛亦因般若波罗蜜得阿耨多罗三藐三菩提。释提桓因白佛言。世尊。摩诃波罗蜜是般若波罗蜜。佛因是般若波罗蜜。皆知一切众生心心所行。佛言。憍尸迦。菩萨摩诃萨长夜行般若波罗蜜故。释提桓因白佛言。世尊菩萨但行般若波罗蜜。不行余波罗蜜耶。佛言。憍尸迦。菩萨皆行六波罗蜜。若布施时般若波罗蜜为上首。若持戒若忍辱若精进若禅定若观诸法时般若波罗蜜为上首。譬如阎浮提种种树种种形种种色种种叶种种华种种果其阴皆一无有差别。五波罗蜜亦如是。入般若波罗蜜中无有差别。世尊。是般若波罗蜜有大功德。有无量无边功德。有无等等功德。世尊。若有人写般若波罗蜜经卷。供养恭敬尊重赞叹。以好华香乃至幢幡。若复有人写般若波罗蜜经卷与他人。是二功德何所为多。佛言。憍尸迦。我还问汝。随意答我。于意云何。若有人得佛舍利但自供养。若复有人得佛舍利。自供养亦与他人令供养。是二功德何所为多释提桓因言。世尊。若人得佛舍利自供养。亦与他人令供养。其福甚多。佛言。如是如是。憍尸迦。若善男子善女人。写般若波罗蜜经卷。供养恭敬尊重赞叹。以好花香乃至幢幡。不如善男子善女人写般若波罗蜜经卷。自供养亦与他人令供养其福甚多。佛言。憍尸迦。若善男子善女人在在处处。为人解说般若波罗蜜。其福甚多

小品般若经卷第二小品般若波罗蜜经卷第三

        后秦龟兹国三藏鸠摩罗什译

    佐助品第六

佛告释提桓因言。憍尸迦。若有善男子善女人。教阎浮提人令行十善道。于意云何。是人以是因缘得福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷与他人令得书写读诵其福甚多。憍尸迦。置是阎浮提众生。若复有人教四天下众生令行十善道。置是四天下。若周梨迦小千世界。若二千中世界。若三千大千世界众生。若教十方如恒河沙等世界众生。令行十善道。于意云何。是人以是因缘故得福多不。释提桓因言。甚多世尊。佛言憍尸迦。不如善男子善女人以般若波罗蜜经卷与他人令得书写读诵其福甚多。复次憍尸迦。若有善男子善女人。教阎浮提众生。令行四禅四无量心四无色定五神通。是人以是因缘得福多不。释提桓因言。甚多世尊。佛言憍尸迦。不如善男子善女人以般若波罗蜜经卷与他人令得书写读诵其福甚多。憍尸迦。置是阎浮提及三千大千世界众生。乃至教十方如恒河沙等世界众生。令行四禅四无量心四无色定五神通。于意云何。是人以是因缘得福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷与他人令得书写读诵其福甚多。复次憍尸迦。若有善男子善女人。以般若波罗蜜经卷。与他人令得书写读诵。不如善男子善女人自为他人读诵其福甚多。复次憍尸迦。若善男子善女人自为他人读诵般若波罗蜜。不如善男子善女人自为他人解说其义其福甚多。是时释提桓因白佛言。世尊。应为何等人解说般若波罗蜜义。佛言。憍尸迦。若有善男子善女人。不知般若波罗蜜义故。应为解说其义。何以故。憍尸迦。未来世当有相似般若波罗蜜。善男子善女人于是中。欲得阿耨多罗三藐三菩提闻是相似般若波罗蜜则有违错。释提桓因言。世尊。何等是相似般若波罗蜜。憍尸迦。当来世有比丘欲说般若波罗蜜。而说相似般若波罗蜜世尊。云何诸比丘说相似般若波罗蜜。佛言。诸比丘说言。色是无常。若如是求是为行般若波罗蜜。受想行识是无常。若如是求是为行般若波罗蜜。憍尸迦。是名说相似般若波罗蜜。憍尸迦。不坏色故观色无常。不坏受想行识故观识无常。不作如是观者。是名行相似般若波罗蜜。憍尸迦。以是因缘故。菩萨说般若波罗蜜义其福甚多。复次憍尸迦。若有善男子善女人。教阎浮提众生。令得须陀洹果。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与他人令得书写读诵作是言。汝当得是应般若波罗蜜功德其福甚多。何以故。须陀洹果从般若波罗蜜出故。憍尸迦。置是阎浮提及三千大千世界。乃至教十方如恒河沙等世界众生。令得须陀洹果。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与他人令得书写读诵作是言。汝当得是应般若波罗蜜功德其福甚多。何以故。须陀洹果从般若波罗蜜出故复次憍尸迦。若有善男子善女人。教阎浮提众生。令得斯陀含果阿那含果阿罗汉果辟支佛道。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与他人令得书写读诵作是言。汝当得是应般若波罗蜜功德其福甚多。何以故。汝随学是法当得萨婆若法。随得萨婆若法。当随得斯陀含果阿那含果阿罗汉果辟支佛道。憍尸迦。置是阎浮提及三千大千世界众生。乃至教十方如恒河沙等世界众生。令得斯陀含果阿那含果阿罗汉果辟支佛道。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与他人令得书写读诵作是言。汝当得是应般若波罗蜜功德其福甚多。何以故。汝随学是法当得萨婆若法。随得萨婆若法。当随得斯陀含果阿那含果阿罗汉果辟支佛道。复次憍尸迦。若满阎浮提众生。皆发阿耨多罗三藐三菩提心。若有善男子善女人。以般若波罗蜜经卷与之令得书写读诵。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与一阿毗跋致菩萨。作是念。是菩萨于是中学。当能修习般若波罗蜜。以是因缘般若波罗蜜增广流布。福多于彼。憍尸迦。置是阎浮提及三千大千世界众生。乃至十方如恒河沙等世界众生。皆发阿耨多罗三藐三菩提心。若有善男子善女人。以般若波罗蜜经卷与之令得书写读诵。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。不如善男子善女人以般若波罗蜜经卷。与一阿毗跋致菩萨作是念。是菩萨于是中学。当能修习般若波罗蜜。以是因缘般若波罗蜜增广流布。福多于彼。复次憍尸迦。阎浮提所有众生。皆发阿耨多罗三藐三菩提心。若有善男子善女人。以般若波罗蜜经卷。与之为解其义。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。不如善男子善女人以般若波罗蜜经卷。与一阿毗跋致菩萨为解其义。福多于彼。憍尸迦。置是阎浮提及三千大千世界众生。乃至教十方如恒河沙等世界众生。皆发阿耨多罗三藐三菩提心。若有善男子善女人以般若波罗蜜经卷。与之为解其义。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。不如善男子善女人以般若波罗蜜经卷。与一阿毗跋致菩萨为解其义。福多于彼。复次憍尸迦。阎浮提所有众生皆是阿毗跋致菩萨。若有善男子善女人以般若波罗蜜义教之。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。于是中有一菩萨。疾得阿耨多罗三藐三菩提。若有人以般若波罗蜜义教之。福多于彼。憍尸迦。置是阎浮提及三千大千世界众生。乃至十方如恒河沙等世界众生。皆是阿毗跋致菩萨。若有善男子善女人以般若波罗蜜义教之。于意云何。是人以是因缘其福多不。释提桓因言。甚多世尊。佛言。憍尸迦。于是中有一菩萨。疾得阿耨多罗三藐三菩提。若有人以般若波罗蜜义教之。福多于彼。尔时释提桓因白佛言。如是如是。世尊。随菩萨近阿耨多罗三藐三菩提。转应以般若波罗蜜义教之。亦转应以衣服饮食卧具医药而供养之。其福甚多。何以故。世尊。法应尔随近阿耨多罗三藐三菩提。得福转多。尔时须菩提赞释提桓因言。善哉善哉。憍尸迦。汝是圣弟子。法应佐助诸菩萨。以阿耨多罗三藐三菩提安慰护念。若佛初发阿耨多罗三藐三菩提心时。过去诸佛及诸弟子。若不以六波罗蜜安慰佐助者。不能得阿耨多罗三藐三菩提。憍尸迦。佛初发意时。过去诸佛及诸弟子。以六波罗蜜应安慰佐助故。得阿耨多罗三藐三菩提

    摩诃般若波罗蜜回向品第七

尔时弥勒菩萨语须菩提。菩萨摩诃萨随喜福德。于余众生布施持戒修禅福德。最大最胜最上最妙。尔时须菩提问弥勒菩萨。若菩萨于十方无量阿僧祇世界。过去无量灭度诸佛。是诸佛从初发心。乃至得阿耨多罗三藐三菩提。入无余涅槃乃至法欲灭时。于是中间所有应六波罗蜜善根福德。及诸声闻弟子布施持戒修禅福德。所有学无学无漏福德及诸佛戒品定品慧品解脱品解脱知见品。大慈大悲利安众生。无量佛法及其所说。从是法中众生受学。是诸众生所有福德。及诸佛灭后众生所种福德。合集称量是诸福德。以最大最胜最上最妙心随喜。随喜已回向阿耨多罗三藐三菩提作是观。我此福德当得阿耨多罗三藐三菩提。若菩萨作是念。我以是心回向阿耨多罗三藐三菩提。如心所缘是诸缘诸事为可得不。弥勒言。是诸缘诸事不可得。如心取相。须菩提言。若是诸缘诸事不尔者。是人将无想颠倒见颠倒心颠倒。无常谓常。苦谓乐。不净谓净。无我谓我。生想颠倒见颠倒心颠倒。若诸缘诸事如实者。菩提亦如是。心亦如是。若诸缘诸事菩提及心无异者。何等是随喜心回向阿耨多罗三藐三菩提。弥勒言。须菩提。如是回向法不应于新发意菩萨前说。所以者何。是人所有信乐恭敬净心皆当灭失。须菩提。如是回向法应于阿毗跋致菩萨前说。若与善知识相随者说。是人闻是不惊不怖不没不退。菩萨随喜福德应如是回向萨婆若。所用心回向。是心即尽即灭。何等心是回向阿耨多罗三藐三菩提。若用心心回向。是二心不俱。又心性不可得回向。尔时释提桓因语须菩提。新发意菩萨闻是事将无惊怖耶。菩萨今云何以随喜福德如实回向。尔时须菩提因弥勒菩萨作是言。菩萨于过去诸佛。道已断行已灭戏论尽。灭蕀刺除重担。得己利尽有结。正智解脱心得自在。无量阿僧祇世界中灭度诸佛。所有善根福德势力。及诸弟子于诸佛所。所种善根合集称量。是诸福德以最大最胜最上最妙心随喜。随喜已回向阿耨多罗三藐三菩提。是菩萨今当云何不堕想颠倒见颠倒心颠倒。若是菩萨用是心回向阿耨多罗三藐三菩提。于是心中不生心相。则是回向阿耨多罗三藐三菩提。若是菩萨于是心中而生心相。则堕想颠倒见颠倒心颠倒。若菩萨随喜时。是心尽灭相。如实知尽灭相。尽灭相法则不可回向。回向心亦如是相。所回向法亦如是相。若能如是回向。是名正回向。菩萨摩诃萨应以随喜福德如是回向。若菩萨于过去诸佛所有福德。并诸弟子及凡夫人乃至畜生闻法种善根。及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻法发应萨婆若心。合集称量是诸福德。以最大最胜最上最妙心随喜。随喜已回向阿耨多罗三藐三菩提。若菩萨如是念。是诸法皆尽灭。所回向处亦尽灭。是名随喜福德正回向阿耨多罗三藐三菩提。又菩萨如是知无有法能回向法。是名正回向阿耨多罗三藐三菩提。若菩萨如是回向。则不堕想颠倒见颠倒心颠倒。何以故。是菩萨不贪着回向故。是名无上回向。若有菩萨于福德作起法。取相分别则不能以此福德回向。何以故。是作起法皆是离相。随喜福德亦是离相。若菩萨知所念作起法皆离相。当知是为行般若波罗蜜。又诸过去灭度佛善根福德亦如是。回向所用回向法性相亦如是。若能如是知。是名正回向阿耨多罗三藐三菩提。何以故。诸佛不许取相回向故。若法过去尽灭。是法无相。不可以相得。若如是亦分别。是名取相。若如是亦不分别。是名正回向。云何不取相分别而能回向。菩萨以是事故。应学般若波罗蜜方便。若不闻不得般若波罗蜜方便。则不能入是事。若不闻不得般若波罗蜜方便。能以诸福德正回向者。无有是处。何以故。是人于过去诸佛身及诸福德皆已灭度。而取相分别得是福德。欲以回向。如是回向诸佛不许亦不随喜。何以故。是皆于法有所得故。所谓于过去灭度诸佛取相分别。有所得而回向即是大贪着。以是有所得心回向者。诸佛不说有大利益。何以故。是回向名为杂毒衰恼。譬如美食其中有毒。虽有好色香美。以有毒故不可食之。愚痴无智之人若食此食。初虽香美可意。食欲消时有大苦报。如是有人不正受读诵不解其义。而教诸弟子回向语言。善男子来。如过去未来现在诸佛。戒品定品慧品解脱品解脱知见品。并诸声闻弟子及凡夫人所种善根。及诸佛与众生授辟支佛记。是辟支佛所种善根。及与菩萨受阿耨多罗三藐三菩提记。是诸菩萨所种善根合集称量。是诸福德随喜。随喜已回向阿耨多罗三藐三菩提。是人如是回向。是回向取相分别故。名为杂毒。如杂毒食。有所得者无有回向。何以故。是有所得皆是杂毒故。以是故。菩萨应如是思惟过去未来现在诸佛善根福德。应云何回向名为正回向至阿耨多罗三藐三菩提。若菩萨欲不谤诸佛应如是回向。如诸佛所知福德。何相何性何体何实。我亦如是随喜。我以是随喜。回向阿耨多罗三藐三菩提。菩萨如是回向则无有咎。不谤诸佛如是回向则不杂毒。亦名随诸佛教。复次菩萨应以随喜福德如是回向。如戒品定品慧品解脱品解脱知见品。不系欲界不系色界不系无色界。非过去非未来非现在。以无系故。是福德回向亦无系。所回向法亦无系。回向处亦无系。若能如是回向则不杂毒。若不如是回向。名为邪回向。菩萨回向法如三世诸佛所知回向。我亦如是回向阿耨多罗三藐三菩提。是名正回向。尔时佛赞须菩提言。善哉善哉。须菩提。汝能为诸菩萨摩诃萨作佛事。须菩提。若有三千大千世界众生。皆行慈悲喜舍心四禅四无色定五神通。不如是菩萨回向福德。最大最胜最上最妙。复次须菩提。若有三千大千世界众生。皆发阿耨多罗三藐三菩提心。是一一菩萨于恒河沙等劫。以有所得心供养如恒河沙等世界众生。衣服饮食卧具医药一切乐具。如是一一菩萨皆于恒河沙等劫。以有所得心供养是诸众生衣服饮食卧具医药一切乐具。于意云何。是诸菩萨以是因缘得福多不。须菩提言。甚多世尊。不可譬喻。若是福德有形。恒河沙等世界所不能受。佛赞须菩提言。善哉善哉。须菩提。若菩萨为般若波罗蜜所护故。能以是福德回向。于前有所得心布施福德。百分不及一。千万亿分不及一。乃至算数譬喻所不能及。尔时四天王天上二万天子。合掌礼佛作是言。世尊。是菩萨回向名为大回向。以方便故。胜于有所得菩萨布施福德。何以故。是菩萨回向为般若波罗蜜所护故。尔时忉利天上十万天子。以天花香涂香末香天衣幢幡天诸伎乐而供养佛。皆作是言。世尊。是菩萨回向名为大回向。以方便故。胜于有所得菩萨布施福德。何以故。是菩萨回向为般若波罗蜜所护故。夜摩天上十万天子。兜率陀天上十万天子。化乐天上十万天子。他化自在天上十万天子。皆以天华天香乃至伎乐而供养佛。皆作是言。世尊。是菩萨回向。名为大回向。以方便故。胜于有所得菩萨布施福德。何以故。是菩萨回向为般若波罗蜜所护故。梵世诸天子大声唱言。是菩萨回向名为大回向。以方便故。胜于有所得菩萨布施福德。何以故。是菩萨回向为般若波罗蜜所护故。梵辅天梵众天大梵天光天少光天无量光天光音天净天少净天无量净天遍净天无云行天福生天广果天无广天无热天妙见天善见天无小天上诸天子。合掌礼佛皆作是言。世尊。是善男子善女人求佛道者甚为希有。为般若波罗蜜所护故。能胜有所得菩萨布施福德。何以故。是菩萨回向为般若波罗蜜所护故。尔时佛告净居诸天子。置是三千大千世界众生。若十方恒河沙等世界众生。皆发阿耨多罗三藐三菩提心。是一一菩萨于恒河沙等劫。以有所得心供养十方如恒河沙等世界众生衣服饮食卧具医药一切乐具。如是一一菩萨皆于恒河沙等劫。以有所得心供养是诸众生衣服饮食卧具医药一切乐具。若有菩萨于过去未来现在诸佛。所有戒品定品慧品解脱品解脱知见品。并诸声闻弟子。及凡夫人所种善根。合集称量是诸福德。以最大最胜最上最妙心随喜。随喜已回向阿耨多罗三藐三菩提其福甚多。尔时须菩提白佛言。世尊。如佛所说。是诸福德合集称量。以最大最胜最上最妙心随喜。随喜已回向阿耨多罗三藐三菩提。世尊。云何名为最大最胜最上最妙随喜。佛告须菩提。若菩萨于过去未来现在诸法。不取不舍不念不得。于此中无有法若已生灭若今生灭若当生灭。如诸法实相。随喜回向阿耨多罗三藐三菩提亦如是。须菩提。是名菩萨最大最胜最上最妙随喜回向。复次须菩提。菩萨若欲于过去未来现在诸佛布施持戒忍辱精进禅定智慧解脱解脱知见随喜。应如是随喜。如解脱持戒亦如是。如解脱。定惠解脱解脱知见亦如是。如解脱信解亦如是。如解脱随喜亦如是。如解脱未来未生法亦如是。如解脱过去无量阿僧祇世界诸佛及弟子亦如是。如解脱今现在十方无量阿僧祇世界诸佛及弟子亦如是。如解脱未来无量阿僧祇世界诸佛及弟子亦如是。是诸法相不系不缚不解不脱。以是回向阿耨多罗三藐三菩提不生不灭故。须菩提。是名菩萨最大最胜最上最妙随喜回向。以是回向胜于十方如恒河沙等世界诸菩萨。以有所得心皆于恒河沙劫供养十方如恒河沙等世界众生衣服饮食卧具医药一切乐具。以有所得心布施持戒忍辱精进禅定。于此随喜回向福德。百分不及一。百千万亿分不及一。乃至算数譬喻所不能及

    摩诃般若波罗蜜泥犁品第八

尔时舍利弗白佛言世尊是般若波罗蜜。佛言。是般若波罗蜜。世尊。般若波罗蜜能作照明。世尊。般若波罗蜜所应敬礼。世尊。般若波罗蜜能与光明。世尊。般若波罗蜜除诸闇冥。世尊。般若波罗蜜无所染污。世尊。般若波罗蜜多所利益世尊。般若波罗蜜多所安隐。世尊。般若波罗蜜能与盲者眼。世尊。般若波罗蜜能令邪行者入正道。世尊。般若波罗蜜即是萨婆若。世尊。般若波罗蜜是诸菩萨母。世尊。般若波罗蜜非生法者非灭法者。世尊。般若波罗蜜具足三转十二相法轮。世尊。般若波罗蜜能为孤穷者作救护。世尊。般若波罗蜜能灭生死。世尊。般若波罗蜜能示一切法性。世尊。应云何敬视般若波罗蜜。佛言。如敬视佛。敬礼般若波罗蜜如敬礼佛。尔时释提桓因心念。舍利弗。何因缘作是问。念已问舍利弗。何因缘作是问。舍利弗言。菩萨摩诃萨以般若波罗蜜随喜福德。回向萨婆若故。于上诸菩萨所有布施持戒忍辱精进禅定等其福最胜。是故我作是问。憍尸迦。譬如盲人虽有百千万众无有导者不能进趣城邑聚落。憍尸迦。五波罗蜜离般若波罗蜜。亦如盲人无导。不能修道至萨婆若。若五波罗蜜为般若波罗蜜所护则为有目。般若波罗蜜力故。五波罗蜜得般若波罗蜜名。舍利弗白佛言。世尊。云何生般若波罗蜜。佛言。若菩萨不生色。则生般若波罗蜜。不生受想行识。则生般若波罗蜜。如是生般若波罗蜜为成何法。舍利弗。如是生般若波罗蜜于法无所成。若无所成则名般若波罗蜜。释提桓因白佛言。世尊。般若波罗蜜亦不成萨婆若耶。憍尸迦。般若波罗蜜成萨婆若。但不如名相作起法成。世尊。当云何成。佛言。如不成如是成。释提桓因白佛言。希有世尊。般若波罗蜜不为生不为灭故有。须菩提白佛言。世尊。菩萨如是亦分别则失般若波罗蜜则远离般若波罗蜜。佛告须菩提。有是因缘。若菩萨谓般若波罗蜜空无所有。则失般若波罗蜜则远般若波罗蜜。须菩提。是名菩萨般若波罗蜜。世尊。说般若波罗蜜为示何法。须菩提。说般若波罗蜜。不示色不示受想行识。不示须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。不示佛法。须菩提言。世尊。摩诃波罗蜜是般若波罗蜜。佛言。须菩提。于意云何。以是因缘。摩诃波罗蜜是般若波罗蜜。须菩提言。般若波罗蜜于色不作大不作小。不作合不作散。于受想行识。不作大不作小。不作合不作散。世尊。般若波罗蜜于佛十力。不作强不作弱。四无所畏乃至萨婆若。不作合不作散。世尊。菩萨如是亦分别则不行般若波罗蜜。何以故。般若波罗蜜无如是相。我当度若干众生。即是菩萨计有所得。所以者何。众生不生故般若波罗蜜不生。众生无性故般若波罗蜜无性。众生离相故般若波罗蜜离相。众生不灭故般若波罗蜜不灭。众生不可思议故般若波罗蜜不可思议。众生不可知故般若波罗蜜不可知。众生力集故如来力亦集。舍利弗白佛言。世尊。菩萨若能信是深般若波罗蜜。不疑不悔不难随顺解义。是人从何处终来生此间。佛言舍利弗。是菩萨于他方佛土命终来生此间舍利弗。菩萨从他方佛土来者。曾已亲近供养诸佛问其中义。今闻般若波罗蜜即生欢喜如从佛闻。若见般若波罗蜜如见佛。须菩提白佛言。世尊。般若波罗蜜可闻可见耶。佛言不也。世尊。是菩萨发心已来。几时能修习般若波罗蜜。须菩提。是事应分别。有菩萨得值若干百千万亿佛。于诸佛所修行梵行。有于大众闻深般若波罗蜜。无恭敬心即时舍去。须菩提。当知是人本于过去诸佛。闻说般若波罗蜜舍去故。于今闻深般若波罗蜜亦舍去。身心不和起无智业。积集无智业因缘故。诽谤拒逆般若波罗蜜。须菩提。诽谤拒逆深般若波罗蜜者。即诽谤拒逆萨婆若。诽谤拒逆萨婆若者。即诽谤拒逆三世诸佛。须菩提。是愚痴人。起如是破法重罪业故。若干百千万劫受大地狱罪。从一大地狱至一大地狱。从一大地狱至一大地狱受罪时。若火劫起堕他方大地狱。于彼亦从一大地狱至一大地狱。从一大地狱至一大地狱受罪时。若彼火劫起复堕他方大地狱。堕他方大地狱已。复从一大地狱至一大地狱。从一大地狱至一大地狱受罪时。若彼火劫起。还来堕此大地狱中。是人于此复从一大地狱至一大地狱受诸剧苦。如是展转。乃至火劫复起。受是无量苦恼业报。何以故。起恶口业故。尔时舍利弗白佛言。世尊。如是业似五逆罪。舍利弗。汝勿谓此破法罪似五逆罪。何以故。是人闻说深般若波罗蜜。诽谤拒逆作是念。不应学是法。是法非佛所说。以是因缘。其罪转增故。亦令他人离般若波罗蜜。佛言。是人自坏身亦坏他人身。自饮毒亦饮他人毒。自亡失亦亡失他人。自不知不解般若波罗蜜。亦教他人不知不解舍利弗。我尚不听是人出家。何况于我法中而受供养。何以故。当知是人为污法者。当知是人为是糟粕。其性浊黑。若有众生信受其言者。亦当受是剧苦重罪。何以故。舍利弗。若破般若波罗蜜。若污般若波罗蜜。当知是人破法污法者。舍利弗白佛言。世尊。不说是人受身大小。佛告舍利弗。置是人身量大小不须说也。是人若闻说其身量。热血当从口出。若死若近死。若闻说其身量。自知此罪忧愁深入身体干消。是故不须说其受身大小。舍利弗白佛言。世尊。唯愿佛说是人身量。令后世人得为明戒。知以是罪业故受是大身佛告舍利弗。是事足为后世众生作大明戒。积集如是罪业因缘故。受如是无量无边久剧苦恼。舍利弗。是事足为善人作大明戒。须菩提白佛言。世尊。善男子善女人。应善守护身业口业意业。世尊。但以口业因缘故。得如是重罪耶。佛告须菩提。以口业因缘故。得如是重罪。须菩提。我法中多有如是等痴人。诽谤拒逆深般若波罗蜜。须菩提。诽谤拒逆深般若波罗蜜者。即诽谤拒逆阿耨多罗三藐三菩提。诽谤拒逆阿耨多罗三藐三菩提者。即诽谤拒逆过去未来现在诸佛萨婆若。诽谤拒逆萨婆若者。即诽谤拒逆法宝。诽谤拒逆法宝者。即诽谤拒逆僧宝。诽谤拒逆三宝故。即起无量无边重罪之业。须菩提白佛言。世尊。若人诽谤拒逆深般若波罗蜜有几因缘。须菩提。是痴人一为魔所使。二于深妙法不信不解。复次须菩提。是痴人得恶知识。不乐不喜修习善法。又深贪着常求他过。自高其身卑下他人。须菩提。以是因缘故。诽谤拒逆深般若波罗蜜。须菩提白佛言。世尊。不精进者信解般若波罗蜜甚难。佛言。如是如是。须菩提。不精进者信解般若波罗蜜甚难。世尊云何不精进者信解般若波罗蜜甚难。须菩提。色无缚无解。何以故。色真性是色。受想行识无缚无解。何以故。识真性是识。复次须菩提。色前际无缚无解。何以故。色前际真性是色。色后际无缚无解。何以故。色后际真性是色。现在色无缚无解。何以故。现在色真性是色。须菩提。受想行识前际无缚无解。何以故。识前际真性是识。识后际无缚无解。何以故。识后际真性是识。现在识无缚无解。何以故。现在识真性是识。世尊。般若波罗蜜甚深。不精进者信解甚难。佛言。如是如是。须菩提。深般若波罗蜜不精进者信解甚难。须菩提。色净即是果净。色净故果亦净。受想行识净即是果净。受想行识净故果亦净。复次须菩提。色净即是萨婆若净。萨婆若净故色净。须菩提。色净萨婆若净。无二无别无异无坏。受想行识净即是萨婆若净。萨婆若净故受想行识净。须菩提。萨婆若净受想行识净。无二无别无异无坏

小品般若经卷第三小品般若波罗蜜经卷第四

        后秦龟兹国三藏鸠摩罗什译

    叹净品第九

尔时舍利弗白佛言。世尊。是净甚深。佛言净故。世尊是净明。佛言净故。世尊。是净不生欲界不生色界不生无色界。佛言净故。世尊。是净无垢无净。佛言净故。世尊。是净无得无果。佛言净故。世尊。是净不作不起。佛言净故。世尊。是净无知。佛言净故。世尊。是净不知色。不知受想行识。佛言净故。世尊。般若波罗蜜于萨婆若不增不减。佛言净故。世尊。般若波罗蜜净故。于法无所取。佛言净故。尔时须菩提白佛言。世尊。我净故色净。佛言毕竟净故。世尊。我净故受想行识净。佛言毕竟净故。世尊。我净故果净。佛言毕竟净故。世尊。我净故萨婆若净。佛言毕竟净故。世尊。我净故无得无果。佛言毕竟净故。世尊我无边故色无边。佛言毕竟净故。世尊。我无边故受想行识无边。佛言毕竟净故。世尊。如是如是名菩萨般若波罗蜜耶。须菩提毕竟净故。世尊。般若波罗蜜非此岸非彼岸非中流。佛言毕竟净故世尊。菩萨若如是。亦分别即失般若波罗蜜。即远般若波罗蜜。佛言。善哉善哉。须菩提。从名相故生着。希有世尊。善说般若波罗蜜中着。尔时舍利弗语须菩提。何因缘故名为着。舍利弗。若善男子善女人。分别色空。即名为着。分别受想行识空。即名为着分别过去法未来法现在法。即名为着。初发心菩萨得若干福德。即名为着。释提桓因问须菩提言。何因缘是事名为着。憍尸迦。是人分别是心以是心回向阿耨多罗三藐三菩提。憍尸迦。心性不可回向。是故菩萨若欲教他化人阿耨多罗三藐三菩提。应如诸法实相示教利喜。如是则不自伤。是佛所许是佛所教。善男子善女人亦离诸着。尔时佛赞须菩提言。善哉善哉。汝能示诸菩萨着法。须菩提。我当更说微细着法。汝今善听。须菩提言。唯然受教。佛言。若善男子。善女人。取相念诸佛随所取相。皆名为着。过去未来现在诸佛。所有无漏法皆随喜。随喜已回向阿耨多罗三藐三菩提。即亦是着。何以故。须菩提。诸法性非过去非未来非现在。不可取相不可缘。不可见不可闻。不可觉不可知。不可回向。世尊是诸法性甚深。佛言。毕竟离故。世尊。我敬礼般若波罗蜜。佛言。佛得是无作法故。世尊。佛得一切法。如是须菩提。如来得一切法。须菩提。法性唯一无二无三。是性亦非性非作。须菩提。菩萨能如是知则离诸着。世尊。般若波罗蜜甚为难知。须菩提。无有知者故。世尊。般若波罗蜜不可思议。须菩提。般若波罗蜜不可以心知故。世尊。般若波罗蜜无所作。须菩提。作者不可得故。世尊。菩萨当云何行般若波罗蜜。须菩提。若菩萨不行色即行般若波罗蜜。不行受想行识即行般若波罗蜜。若不行色不满足。即行般若波罗蜜。不行受想行识不满足。即行般若波罗蜜。何以故。色不满足则非色。受想行识不满足则非识。若能如是行不满足相。即行般若波罗蜜。须菩提言。希有世尊。于诸着中说无所著。须菩提。若菩萨不行色不着相。即行般若波罗蜜。不行受想行识不着相。即行般若波罗蜜。菩萨如是行。于色不生着。于受想行识不生着。于须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道不生着。乃至萨婆若亦不生着。何以故。过诸着故名无碍萨婆若。须菩提。菩萨欲过诸着。应如是思惟般若波罗蜜。须菩提白佛言。希有世尊。是法甚深。若说不减不说亦不减。若说不增不说亦不增。佛言。如是如是。须菩提。如佛尽寿称赞虚空。虚空不减。不称赞亦不减。称赞不增不称赞亦不增。须菩提。譬如称赞幻所化人亦不喜不称赞亦不嗔。须菩提。诸法性亦如是。若说亦不增不说亦不减。世尊。菩萨所为甚难。修行般若波罗蜜时。心无增减亦不退不转。世尊。修习般若波罗蜜。如修习虚空。世尊。菩萨为度一切众生故。发大庄严应当敬礼。世尊。菩萨为众生故发大庄严。如人与虚空共斗。世尊。菩萨为众生故发大庄严。如人与虚空诤讼。世尊。是菩萨名为发大庄严。世尊。菩萨为众生故发大庄严。如人欲举虚空。世尊。是菩萨名为度精进彼岸。名为勇健。名为同虚空诸法故。发阿耨多罗三藐三菩提。尔时会中有一比丘作是念。我敬礼般若波罗蜜。般若波罗蜜中。无有法生无有法灭。尔时释提桓因语须菩提。若菩萨修习深般若波罗蜜。为修习何法。憍尸迦。若菩萨修习深般若波罗蜜。即是修习虚空。释提桓因白佛言。世尊。若人能受持读诵般若波罗蜜我当守护须菩提语释提桓因汝见是法可守护耶。释提桓因言。不见也。憍尸迦。若菩萨如般若波罗蜜所说行。即是守护。若菩萨或时远离般若波罗蜜。人若非人则得其便。憍尸迦。若人欲守护行般若波罗蜜者。则为欲守护虚空。憍尸迦。于意云何。汝能守护响不。释提桓因言。不能也。憍尸迦。菩萨亦如是。行般若波罗蜜。知一切法空。如响如是。亦不分别。当知是为行般若波罗蜜。尔时佛以神力。令三千大千世界所有四天王天及诸释提桓因。娑婆世界主诸梵天王。皆来至佛所。头面礼佛足。却住一面。四天王诸释提桓因诸梵天王等。以佛神力。得见千佛如是相。如是名说般若波罗蜜品者。皆名须菩提难问者。亦如释提桓因弥勒菩萨。当成阿耨多罗三藐三菩提。亦于此土说般若波罗蜜。尔时须菩提白佛言。世尊。弥勒菩萨成阿耨多罗三藐三菩提时。于是处云何说般若波罗蜜。须菩提。弥勒菩萨成阿耨多罗三藐三菩提时。说般若波罗蜜。不说色空。不说受想行识空。不说色缚不说色解。不说受想行识缚。不说受想行识解。须菩提言。世尊。般若波罗蜜清净。佛言。色净故般若波罗蜜清净。受想行识净故般若波罗蜜清净。佛言。虚空净故般若波罗蜜清净。色无染故般若波罗蜜清净。受想行识无染故般若波罗蜜清净。须菩提。虚空无染故般若波罗蜜清净。世尊。若有善男子善女人。能受持读诵般若波罗蜜者。终不横死。若干百千诸天皆共随从。若月八日十四日十五日二十三日二十九日三十日。在在处处说般若波罗蜜。其福甚多。佛言。如是如是。须菩提。是人说般若波罗蜜。得福甚多。须菩提。般若波罗蜜多有留难。何以故。般若波罗蜜是大珍宝。于法无所著无所取。所以者何。谓诸法无所有不可得故。须菩提。般若波罗蜜无所得故。无能染污。何以故。般若波罗蜜以无法故。名为无染般若波罗蜜。般若波罗蜜无污故。诸法亦无污。若如是亦不分别。名为行般若波罗蜜。须菩提。般若波罗蜜。无有法若见若不见。无有法若取若舍是时若干百千诸天子踊跃欢喜。于虚空中同声唱言。我于阎浮提。再见法轮转。须菩提语诸天子。非初转非二转。何以故。般若波罗蜜法中无转无还。佛告须菩提。摩诃波罗蜜是菩萨般若波罗蜜。所谓于一切法无转无著。得阿耨多罗三藐三菩提。亦无所得。转法轮时亦无所转。无法可还无法可示无法可见。是法不可得故。何以故。须菩提。空不转不还。无相无作无起无生。无所有不转不还。如是说名为说般若波罗蜜。无听者无受者无证者。亦无以法作福田者。须菩提白佛言。世尊。无边波罗蜜是般若波罗蜜。虚空无边故。世尊。正波罗蜜是般若波罗蜜。诸法平等故。世尊。离波罗蜜是般若波罗蜜。诸法性离故。世尊。不可破波罗蜜是般若波罗蜜。诸法不可得故。世尊。无处波罗蜜是般若波罗蜜。诸法无形无名故。世尊。无去波罗蜜是般若波罗蜜。诸法无来故。世尊。无夺波罗蜜是般若波罗蜜。诸法不可取故。世尊。尽波罗蜜是般若波罗蜜。诸法无尽故。世尊。无生波罗蜜是般若波罗蜜。诸法无生故。世尊。无作波罗蜜是般若波罗蜜。作者不可得故。世尊。不出波罗蜜是般若波罗蜜。出者不可得故。世尊。不至波罗蜜是般若波罗蜜。无退没故。世尊。无垢波罗蜜是般若波罗蜜。诸烦恼清净故。世尊。无污波罗蜜是般若波罗蜜。处不污故。世尊。不灭波罗蜜是般若波罗蜜。诸法离前际故。世尊。幻波罗蜜是般若波罗蜜。诸法不生故。世尊。梦波罗蜜是般若波罗蜜。意识平等故。世尊。不戏波罗蜜是般若波罗蜜。诸戏平等故。世尊。不念波罗蜜是般若波罗蜜。诸念不生故。世尊。不动波罗蜜是般若波罗蜜。法性常住故。世尊离欲波罗蜜是般若波罗蜜。诸法不虚诳故。世尊。不起波罗蜜是般若波罗蜜。诸法无分别故。世尊。寂灭波罗蜜是般若波罗蜜。诸法相不可得故。世尊。无烦恼波罗蜜。是般若波罗蜜。诸法无过咎故。世尊。无众生波罗蜜。是般若波罗蜜。众生际不可得故。世尊。不断波罗蜜是般若波罗蜜。诸法不起故。世尊。无二边波罗蜜是般若波罗蜜。诸法无著故。世尊。不异波罗蜜是般若波罗蜜。诸法不和合故。世尊。不着波罗蜜是般若波罗蜜。不分别声闻辟支佛地故。世尊。不分别波罗蜜是般若波罗蜜。诸分别平等故。世尊。无量波罗蜜是般若波罗蜜。量法不生故。世尊。虚空波罗蜜是般若波罗蜜。诸法无障碍故。世尊。不生波罗蜜是般若波罗蜜。诸法不起故。世尊。无常波罗蜜是般若波罗蜜。诸法不失故。世尊。苦波罗蜜是般若波罗蜜。诸法无苦恼故。世尊。无我波罗蜜是般若波罗蜜。诸法无所贪着故。世尊。空波罗蜜是般若波罗蜜。诸法无所得故。世尊。无相波罗蜜是般若波罗蜜诸法相不可得故。世尊。无作波罗蜜是般若波罗蜜。诸法无所成故。世尊。力波罗蜜是般若波罗蜜。诸法不可破故。世尊。无量佛法波罗蜜是般若波罗蜜。过算数法故。世尊。无所畏波罗蜜是般若波罗蜜。心不没故。世尊。如波罗蜜是般若波罗蜜。诸法不异故。世尊。自然波罗蜜是般若波罗蜜。诸法无性故

    摩诃般若波罗蜜不可思议品第十

尔时释提桓因作是念。若人得闻般若波罗蜜者。当知是人已曾供养诸佛。何况受持读诵。如所说学如所说行。若人闻说深般若波罗蜜。受持读诵如所说行。当知是人已曾多供养佛广问其义。于过去诸佛。闻深般若波罗蜜。不惊不怖。尔时舍利弗白佛言。世尊。若菩萨摩诃萨。能信解深般若波罗蜜。当知是菩萨如阿毗跋致。何以故。世尊。若人于过去世。不久行深般若波罗蜜。则不能信解。世尊。若有诽谤拒逆般若波罗蜜。当知是人久已诽谤拒逆般若波罗蜜。何以故。是人于深般若波罗蜜。无有信心无清净心。亦不问诸佛及诸佛弟子所疑。尔时释提桓因语舍利弗。是般若波罗蜜甚深。若不久行菩萨道不能信解。有何可怪。若人敬礼般若波罗蜜。即是敬礼萨婆若智。舍利弗言。如是如是。憍尸迦。若人敬礼般若波罗蜜。即是敬礼萨婆若智。从般若波罗蜜生诸佛萨婆若智。从萨婆若智还生般若波罗蜜。菩萨应如是住般若波罗蜜。应如是习般若波罗蜜。释提桓因白佛言。世尊。云何菩萨行般若波罗蜜。名为住般若波罗蜜。名为习般若波罗蜜。佛告释提桓因言。善哉善哉憍尸迦。汝能问佛是义。汝所问者皆是佛力。憍尸迦。若菩萨行般若波罗蜜不住色。若不住色即是习色。不住受想行识。若不住识即是习识。复次憍尸迦。若菩萨不习色。若不习色即不住色。不习受想行识。若不习识即不住识。如是憍尸迦。是名菩萨习般若波罗蜜。住般若波罗蜜。舍利弗白佛言。世尊。般若波罗蜜甚深无量无底。佛告舍利弗。若菩萨摩诃萨不住色甚深。是为习色甚深。不住受想行识甚深。是为习识甚深。复次舍利弗。若菩萨摩诃萨不习色甚深。是为不住色甚深。不习受想行识甚深。是为不住识甚深。世尊。深般若波罗蜜。应于阿毗跋致菩萨前说。是人闻是不疑不悔。尔时释提桓因语舍利弗若于未受记菩萨前说当有何咎。憍尸迦。若未受记菩萨。得闻深般若波罗蜜。当知是菩萨久发大乘心近于受记。不久必得受记。若过一佛二佛。当得受阿耨多罗三藐三菩提记。佛言。如是如是舍利弗。若未受记菩萨。得闻深般若波罗蜜。当知是菩萨久发大乘心。舍利弗白佛言。世尊。我今当说譬喻。佛言。乐说便说。世尊。譬如求菩萨道者梦坐道场。知是菩萨当近阿耨多罗三藐三菩提。若求菩萨道者得闻深般若波罗蜜。当知是菩萨久发大乘心。善根成就近于受记。不久必得受记。佛言。善哉善哉。舍利弗。汝承佛神力复更说之。世尊。譬如有人欲过险道。若百由旬。若二百若三百若四百若五百由旬。欲出难时先见诸相。若见放牛羊者。若见疆界。若见园林。见如是相故。当知此中必有城邑聚落。见是相已作是念。如我所见之相。城邑聚落去此不远。其心安隐不复畏有怨家贼害。世尊。菩萨亦如是。若得闻深般若波罗蜜。当知是菩萨近于受记。不久必得受记。尔时不畏堕声闻辟支佛地。何以故。是菩萨得是本相。所谓得见深般若波罗蜜。得闻深般若波罗蜜。世尊。譬如有人欲见大海。稍稍前行若见树若树相。若见山若山相。当知是中去海尚远。若不见树无树相。不见山无山相。当知大海去是不远。大海深故无有山树。是人虽不见海知必近之。世尊。菩萨亦如是。得闻深般若波罗蜜。虽未于现在诸佛前受记。自知必近阿耨多罗三藐三菩提。何以故。我得见闻供养深般若波罗蜜故。世尊。譬如春时树叶零落。当知此树华叶果实将生不久。何以故。本相现故。阎浮提人见树本相。皆悉欢喜作是念。是树不久当生华叶果实。世尊。菩萨亦如是。若得见闻深般若波罗蜜当知是菩萨善根成就宿世善根因缘故。今得深般若波罗蜜。会中曾有见佛诸天皆大欢喜作是念。先诸菩萨亦有如是受记本相。是菩萨不久当得受阿耨多罗三藐三菩提记。世尊。譬如女人怀妊。转转不便身体疲极。不乐事务眠卧不安。食饮转少苦恼在身。不欲语言厌本所习。不复忆乐。本相现故。当知是女将产不久。菩萨善根成就亦复如是。若得见闻思惟深般若波罗蜜。当知是菩萨不久得受阿耨多罗三藐三菩提记。佛言。善哉善哉舍利弗。汝所乐说者皆佛神力。尔时须菩提白佛言。希有世尊。如来善说诸菩萨事。须菩提。是诸菩萨摩诃萨长夜多所利益。多所安隐多所安乐。怜愍世间。得阿耨多罗三藐三菩提。为诸天人演说法要。须菩提白佛言。世尊。菩萨摩诃萨云何得具足修习行般若波罗蜜。须菩提。若菩萨摩诃萨行般若波罗蜜。不见色增是为行般若波罗蜜。不见受想行识增。是为行般若波罗蜜。不见色减是为行般若波罗蜜。不见受想行识减。是为行般若波罗蜜。乃至不见法不见非法。是为行般若波罗蜜。世尊。如佛所说不可思议。须菩提。色不可思议。受想行识不可思议。若菩萨不分别色不可思议。不分别受想行识不可思议。是为行般若波罗蜜。世尊。般若波罗蜜如是谁能信解。须菩提。若久行菩萨道者。世尊。云何菩萨得名久行。须菩提。若菩萨行般若波罗蜜。不分别佛十力四无所畏。乃至不分别萨婆若。是名久行。何以故。佛十力不可思议。四无所畏十八不共法不可思议。乃至萨婆若不可思议。色不可思议。受想行识不可思议。一切法亦不可思议。菩萨如是行者。是名无处所行而行般若波罗蜜。是故名为久行。世尊般若波罗蜜甚深。般若波罗蜜是珍宝聚如虚空清净。希有世尊。般若波罗蜜多起留难。若欲书写者。乃至一岁当疾书成。佛言。如是如是。须菩提。若善男子善女人。欲书写读诵如所说行般若波罗蜜乃至一岁当疾疾为之。须菩提。珍宝法多有怨贼。世尊。般若波罗蜜。恶魔常欲伺求断绝。须菩提。恶魔虽欲伺求断绝亦不能得。舍利弗白佛言。世尊。谁神力故。恶魔不能留难般若波罗蜜。舍利弗。佛神力故恶魔不能留难。舍利弗。亦是十方无量世界现在诸佛神力故。恶魔不能留难。诸佛皆共护念是菩萨故。恶魔不能得便。何以故。舍利弗。菩萨为诸佛所护者。法应无有留难。何以故舍利弗。若人书写读诵说般若波罗蜜。十方无量阿僧祇现在诸佛法应护念。若有诵般若波罗蜜。当知是菩萨佛护念故能诵通利。世尊。善男子善女人能受持读诵般若波罗蜜。当知是人佛眼所见。舍利弗。若善男子善女人。能受持读诵般若波罗蜜乃至书写。当知是人佛眼所见。舍利弗。若求佛道善男子善女人。受持读诵般若波罗蜜。则近阿耨多罗三藐三菩提。乃至自书若使人书。书已受持读诵。以是因缘其福甚多。舍利弗。如来灭后般若波罗蜜。当流布南方。从南方流布西方。从西方流布北方。舍利弗。我法盛时无有灭相。北方若有乃至书写受持供养般若波罗蜜者。是人亦为佛眼所见所知所念。舍利弗白佛言。世尊。后五百岁时。般若波罗蜜当广流布北方耶。舍利弗。后五百岁当广流布北方。其中善男子善女人。闻般若波罗蜜。受持读诵修习。当知久发阿耨多罗三藐三菩提心。世尊。北方当有几所菩萨能受持读诵修习般若波罗蜜。舍利弗。北方虽多有菩萨能读听受般若波罗蜜。少能诵利修习行者。是人得闻亦不惊不怖。是人曾已见佛咨请问难。当知是人为能具足行菩萨道。为阿耨多罗三藐三菩提故。能利益无量众生。何以故。舍利弗。我为是善男子善女人。说应萨婆若法。是人转身。亦复乐说阿耨多罗三藐三菩提。一心和同。乃至魔王不能坏其阿耨多罗三藐三菩提心。是人闻般若波罗蜜。心大欢喜心得清净。令多众生种阿耨多罗三藐三菩提善根。是善男子善女人。于我前作是言。我等行菩萨道。常当以法示教利喜无量百千万众生。令住阿耨多罗三藐三菩提。舍利弗。我观其心则生随喜。是人行菩萨道。当以法示教利喜无量百千万众生。令住阿耨多罗三藐三菩提。如是善男子善女人。心乐大乘愿生他方现在佛前说法之处。于彼续复广闻说般若波罗蜜。于彼佛土。亦复以法示教利喜无量百千万众生。令住阿耨多罗三藐三菩提。舍利弗白佛言。希有世尊。如来于过去未来现在诸法。无法不知无法不识。如来于未来世。诸菩萨以多欲多精进。勤求般若波罗蜜。是善男子善女人。有求而得有不求而得。如来悉知。舍利弗。多有善男子善女人。精进不懈故。般若波罗蜜不求而得。世尊。是善男子善女人。余经应六波罗蜜者。亦不求而得耶。舍利弗。若有余应诸波罗蜜深经。是善男子善女人。亦不求而得。何以故。舍利弗。法应尔。若有菩萨为诸众生。示教利喜阿耨多罗三藐三菩提。亦自于中学。是人转身。应诸波罗蜜深经亦不求而得

小品般若经卷第四小品般若波罗蜜经卷第五

        后秦龟兹国三藏鸠摩罗什译

    魔事品第十一

尔时须菩提白佛言。世尊。已说善男子善女人功德。云何起留难。须菩提。若说法者不即乐说。菩萨当知是为魔事。复次须菩提。说法者乐说不止。菩萨当知是为魔事。须菩提。说法者说不究竟。菩萨当知是为魔事。须菩提。书读诵说般若波罗蜜时傲慢自大。菩萨当知是为魔事。须菩提。书读诵说般若波罗蜜时。互相嗤笑。菩萨当知是为魔事。须菩提书读诵说般若波罗蜜时。互相轻蔑。菩萨当知是为魔事。须菩提。书读诵说般若波罗蜜时。其心散乱。菩萨当知是为魔事须菩提。书读诵说般若波罗蜜时。心不专一。菩萨当知是为魔事。须菩提。行者作是念。我于般若波罗蜜不得气味。从座而去。菩萨当知是为魔事。须菩提。行者作是念。我于般若波罗蜜中无有受记。心不清净从座而去。菩萨当知是为魔事。须菩提。行者作是念。般若波罗蜜中不说我名心不清净。菩萨当知是为魔事。须菩提。行者作是念。般若波罗蜜中不说我生处。若城邑聚落。以是因缘不乐闻说般若波罗蜜。便弃舍去。随所起念辄却若干劫数。乃复还得修菩萨道。菩萨当知是为魔事。复次须菩提。诸经不能至萨婆若者。菩萨舍般若波罗蜜而读诵之。是菩萨则为舍本而取枝叶。何以故。是菩萨因般若波罗蜜。能成就世间出世间法。学般若波罗蜜。能学世间出世间法。若舍般若波罗蜜。菩萨当知是为魔事。须菩提。譬如有狗舍主所与食分反从作务者索。如是须菩提当来世或有菩萨。舍深般若波罗蜜反取余声闻辟支佛经。菩萨当知是为魔事。须菩提。譬如人得象不观反寻其迹。于意云何。是人为智不。不也世尊。须菩提。菩萨亦如是。得深般若波罗蜜而弃舍之。反于声闻辟支佛经求萨婆若。于意云何。是人为智不。不也世尊。菩萨当知是为魔事。须菩提。譬如人欲见大海。见已反求牛迹水作是言。大海水能多是耶。于意云何。是人为智不。不也世尊。须菩提。当来世菩萨亦如是。得深般若波罗蜜。而弃舍之。反读诵声闻辟支佛经。于意云何。是人为智不。不也世尊。菩萨当知是为魔事须菩提。譬如工匠欲造如帝释胜殿。而反揆度日月宫殿。于意云何。是人为智不。不也世尊。须菩提。当来世菩萨亦如是。得深般若波罗蜜。而弃舍之。反于声闻辟支佛经中求萨婆若。于意云何。是人为智不。不也世尊。菩萨当知是为魔事。须菩提。譬如人欲见转轮王。见已不知作是念。转轮王形貌威德云何。见诸小王取其形貌。作是言。转轮王形貌威德如是相耶。于意云何。是人为智不。不也世尊。须菩提。当来世菩萨亦如是。得深般若波罗蜜。而弃舍之。反于声闻辟支佛经中求萨婆若于意云何。是人为智不。不也世尊菩萨当知是为魔事。须菩提。譬如饥人舍百味食反食六十日饭。于意云何。是人为智不。不也世尊。须菩提。菩萨亦如是。得深般若波罗蜜。而弃舍之。反于声闻辟支佛经中求萨婆若。于意云何。是人为智不。不也世尊。菩萨当知是为魔事。须菩提。譬如人得无价宝珠而比水精。于意云何。是人为智不。不也世尊。须菩提。当来世菩萨亦如是。得深般若波罗蜜。而比声闻辟支佛经。于中求萨婆若。于意云何是人为智不。不也世尊。菩萨当知是为魔事。复次须菩提。书读诵说般若波罗蜜时。若多说余事妨废般若波罗蜜。菩萨当知是为魔事。须菩提白佛言。世尊。般若波罗蜜可得书读诵说耶。不也须菩提。若善男子善女人书写文字。而作是念。我书般若波罗蜜。即是魔事。须菩提。尔时应教是善男子善女人。汝等勿谓。但以书写文字。便作是念言。我书般若波罗蜜。诸善男子。以是文字。示般若波罗蜜义。是故汝等勿著文字。若著文字。菩萨当知是为魔事。若不贪着即舍魔事。复次须菩提。书读诵说般若波罗蜜时。忆念诸方国土城邑聚落国王怨贼战斗之事忆念父母兄弟姊妹。恶魔令生如是等念。妨废般若波罗蜜。菩萨皆应觉之。须菩提。如是当知亦是魔事。复次须菩提。书读诵说般若波罗蜜时。供养事起。衣服饮食卧具医药资生之物。妨废般若波罗蜜。菩萨皆应觉之。须菩提。如是当知亦为魔事。复次须菩提。恶魔作因缘。令菩萨得诸深经有方便菩萨于此深经不生贪着无方便菩萨舍般若波罗蜜。取是深经。须菩提。我于般若波罗蜜中。广说方便应于中求。而反于余深经声闻辟支佛法中。求索方便于意云何。是人为智不。不也世尊。须菩提如是当知亦为魔事。复次须菩提。听法者欲闻般若波罗蜜。说法者疲懈不乐为说。须菩提。如是不和合亦为魔事。复次须菩提。说法者身不疲极。乐说般若波罗蜜。听法者欲至余国。不得书读诵说般若波罗蜜。如是不和合亦为魔事。复次须菩提。听法者有念力智力。乐欲听受读诵般若波罗蜜说法者欲至余国。不得书读诵说般若波罗蜜。如是不和合亦为魔事。复次须菩提。说法者贵于财物衣服饮食。听法者惜不与之。不得书读诵说般若波罗蜜。如是不和合亦为魔事。复次须菩提。听法者有信乐心。欲供养说法者。而说法者诵习不利。听法者不乐听受。不得书读诵说般若波罗蜜如是不和合亦为魔事。复次须菩提。说法者心乐为说。听法者不乐听受。不得书读诵说般若波罗蜜。如是不和合亦为魔事。复次须菩提。说法者身重疲极。睡眠所覆不乐言说。听法者乐欲听受读诵。如是不和合亦为魔事。复次须菩提。若书读诵说般若波罗蜜时。有人来说三恶道苦。地狱中有如是苦。畜生饿鬼中有如是苦。不如于是身尽苦取涅槃。何用更生受是诸苦。如是须菩提。菩萨当知亦为魔事。复次须菩提。若书读诵说般若波罗蜜时。若有人来赞叹天上快乐。欲界中有极妙五欲快乐。色界中有禅定快乐。无色界中有寂灭定乐。是三界乐。皆无常苦空坏败之相。汝于是身。可取须陀洹果斯陀含果阿那含果阿罗汉果。不须更受后身。菩萨当知亦为魔事。复次须菩提。说法者爱乐徒众。作是言。若能随我当与般若波罗蜜。若不随我则不与汝。以此因缘。多人随从时。说法者欲经崄难危命之处。语诸人言。善男子。汝等知不。何用随我经此险难。善自筹量无得后悔。而作是言。何故至此饥饿怨贼之中。说法者以此细微因缘舍离诸人。听法者作是念。是舍离相。非与般若波罗蜜相。不得书读诵说般若波罗蜜。如是不和合。菩萨当知亦为魔事。复次须菩提。说法者欲经恶兽虎狼师子怨贼毒害无水之处。说法者语诸人言。汝等知不。我所至处。经过恶兽怨贼毒害无水之处。汝等岂能受如是苦。说法者以此细微因缘而舍离之。诸人不复随从。作是念。是舍离相。非与般若波罗蜜相。即便退还。须菩提。如是诸难。菩萨当知亦为魔事。复次须菩提。说法者重于檀越。以此因缘常数往返以是事故语听法者。诸善男子。我有檀越应往问讯。诸人念言。是为不与我般若波罗蜜相。即时舍离。不得学习书读诵说。如是不和合。菩萨当知亦为魔事。复次须菩提。恶魔勤作方便欲令无人读诵修习般若波罗蜜。须菩提白佛言。世尊。恶魔云何勤作方便。令人不得读诵修习般若波罗蜜。须菩提。恶魔诡诳诸人。作是言。此非真般若波罗蜜。我所有经是真般若波罗蜜。须菩提。恶魔如是诡诳众人。未受记者。当于般若波罗蜜中生疑。疑因缘故。不得读诵修习般若波罗蜜。如是须菩提。菩萨当知亦为魔事。复次须菩提。复有魔事。若菩萨行般若波罗蜜。即证实际取声闻果。如是须菩提。菩萨当知亦为魔事

    摩诃般若波罗蜜小如品第十二

佛告须菩提。般若波罗蜜。多有如是诸留难事。须菩提白佛言。如是如是。世尊。般若波罗蜜多有留难。譬如珍宝多有怨贼。般若波罗蜜亦如是。若人不受持读诵修习般若波罗蜜。当知是人新发道意。少智少信不乐大法。为魔所摄。如是如是。须菩提。若人不受持读诵修习般若波罗蜜。当知是人新发道意。少智少信不乐大法。为魔所摄。须菩提。般若波罗蜜。虽多有如是魔事及诸留难。若善男子善女人有能受持书读诵说。当知是等皆是佛力。何以故。恶魔虽复勤作方便欲灭般若波罗蜜。诸佛亦复勤作方便而守护之。须菩提譬如母人多有诸子。若十若百乃至十万。其母有疾诸子各各勤求救疗。皆作是愿。我等要当令母久寿身体安隐无诸苦患风雨寒热蚊虻毒螫。当以诸药因缘令母安隐。何以故。生育我等赐与寿命。示悟世间其恩甚重。须菩提。今十方现在诸佛。常念般若波罗蜜。皆作是言。般若波罗蜜。能生诸佛。能示萨婆若。何以故。诸佛萨婆若。皆从般若波罗蜜生故。须菩提。诸佛得阿耨多罗三藐三菩提。若已今得若当得。皆因般若波罗蜜。须菩提。般若波罗蜜如是示十方诸佛萨婆若。亦示世间。须菩提白佛言。世尊。如佛所说般若波罗蜜。示诸佛世间。世尊。云何为世间。佛言五阴是世间。世尊。云何般若波罗蜜示五阴。佛言。般若波罗蜜示五阴不坏相。何以故。须菩提。空是不坏相。无相无作是不坏相。般若波罗蜜如是示世间。复次须菩提。佛随无量无边众生性故。如实知其心。如是须菩提。般若波罗蜜示诸佛世间。复次须菩提。众生乱心摄心。是乱心摄心。佛如实知。须菩提。云何如来。知诸众生乱心摄心。以法相故知。须菩提。法相故知心非乱。如是知乱心。云何如来知摄心。须菩提。如来知心尽相。如实知尽相。如是知摄心。复次须菩提。众生染心如来如实知染心。恚心痴心如实知恚心痴心。云何如来。如实知染心。如实知恚心。如实知痴心。须菩提。染心如实相即非染心。恚心痴心如实相。即非恚心痴心。如是须菩提。诸佛从般若波罗蜜生萨婆若智。云何如来。离染心如实知离染心。离恚心。如实知离恚心。离痴心如实知离痴心。须菩提。离染心中无离染心相。离恚心中。无离恚心相。离痴心中无离痴心相。如是须菩提。般若波罗蜜示诸佛世间。复次须菩提。如来因般若波罗蜜。众生广心如实知广心。云何如来众生广心如实知广心。须菩提。是众生心不增不广。不离离相故。如是须菩提。如来因般若波罗蜜。众生广心如实知广心。复次须菩提。如来因般若波罗蜜。众生大心如实知大心。云何如来众生大心如实知大心。须菩提。如来知是心无来无去无住。如是须菩提。如来因般若波罗蜜。众生大心如实知大心。复次须菩提。如来因般若波罗蜜。众生无量心如实知无量心。云何如来。众生无量心如实知无量心。须菩提。如来知是心不住。住于寂灭无所依止。如虚空无量知心相亦尔。如是须菩提。如来因般若波罗蜜。众生无量心如实知无量心。复次须菩提。如来因般若波罗蜜。众生不可见心如实知不可见心。云何如来。众生不可见心如实知不可见心。如来以无相义故。如实知不可见心。如是须菩提。如来因般若波罗蜜。众生不可见心如实知不可见心。复次须菩提。如来因般若波罗蜜。众生不现心如实知不现心。云何如来。众生不现心如实知不现心。是心五眼所不见。如是须菩提。如来因般若波罗蜜。众生不现心。如实知不现心。复次须菩提。如来因般若波罗蜜。知众生诸出没。云何知出没。众生所起出没皆依色生。依受想行识生。何等是诸出没。所谓我及世间常。是见依色。依受想行识。我及世间无常。常无常非常非无常。是见依色。依受想行识。世间有边。世间无边。有边无边。非有边非无边。是见依色。依受想行识。死后如去。死后不如去。死后如去不如去。死后非如去非不如去。是见依色。依受想行识。身即是神。是见依色。依受想行识。身异神异。是见依色。依受想行识。如是须菩提。如来因般若波罗蜜。知众生诸出没。复次须菩提。如来因般若波罗蜜。知色相。云何知色相。知如如。须菩提。如来知受想。行识相。云何知识相。知如如。须菩提。五阴如即是如来所说出没。如五阴如即是世间如。五阴如即是一切法如。一切法如即是须陀洹果如。斯陀含果阿那含果阿罗汉果辟支佛道如。辟支佛道如即是如来如。是诸如皆是一如。无二无别无尽无量。如是须菩提。如来因般若波罗蜜。得是如相。如是须菩提。般若波罗蜜。示诸佛世间。能生诸佛。诸佛知世间如。如实得是如故。名为如来。须菩提白佛言。世尊。是如甚深。诸佛阿耨多罗三藐三菩提从是如生。世尊。如来得是深法能为众生说是如相。如是如相谁能信者。唯有阿毗跋致菩萨及具足正见者满愿阿罗汉。乃能信之。须菩提。是如无尽。佛如实说无尽

    摩诃般若波罗蜜相无相品第十三

尔时释提桓因。及欲界万天子。梵世二万天子。俱诣佛所。头面礼佛足却住一面。各白佛言。世尊。是法甚深。于此法中云何作相。佛告诸天子。诸法以空为相。以无相无作无起无生无灭无依为相。诸天子言。如来说是诸相如空无所依。如是诸相。一切世间天人阿修罗所不能坏。何以故。一切世间天人阿修罗。即是其相故。世尊。是诸相非可作。是诸相不在色数。不在受想行识数。是诸相非人非非人所作。佛告欲色界诸天子。若人问言。虚空谁之所作。是人为正问不。不也世尊。虚空无有作者。何以故。虚空无为故。诸天子。此诸相亦如是。有佛无佛常住不异。诸相常住故。如来得是诸相已名为如来。诸天子言。如来所说诸相甚深。诸佛智慧无碍故。能示是如。亦能说般若波罗蜜行相。世尊。般若波罗蜜是诸佛行处。亦如是示诸佛世间。复次须菩提。诸佛依止于法。供养恭敬尊重赞叹于法。法者则是般若波罗蜜。诸佛供养恭敬尊重赞叹般若波罗蜜。何以故。般若波罗蜜出生诸佛故。须菩提。如来知恩知报恩者。若人正问何等是知恩知报恩者。当答。佛是知恩知报恩者。须菩提。云何佛是知恩知报恩者。如来所行道所行法。得阿耨多罗三藐三菩提。即护念是道是法。以是事故。当知佛是知恩知报恩者。复次须菩提如来知一切法无作。亦是如来知作恩者。须菩提。如来因般若波罗蜜知一切法无作相。得如是智慧。以是因缘故。般若波罗蜜亦如是示诸佛世间。世尊。若一切法无知者无见者。云何般若波罗蜜示诸佛世间。须菩提。如是如是。一切法无知者无见者。须菩提。云何一切法无知者。一切法空故。云何一切法无见者。一切法无所依故。是故一切法无知者无见者。须菩提。如来因般若波罗蜜得如是法。是故般若波罗蜜亦如是示诸佛世间。不见色故示世间。不见受想行识故示世间。般若波罗蜜如是示诸佛世间。世尊。云何名不见色故示世间。云何名不见受想行识故示世间。须菩提。若不缘色生色。是名不见色。若不缘受想行识生识。是名不见识。若如是不见世间。是名真见世间。复次须菩提。世间空。般若波罗蜜如实示世间空。世间离相。般若波罗蜜如实示世间离相。世间净相般若波罗蜜如实示世间净。世间寂灭。般若波罗蜜如实示世间寂灭。须菩提。般若波罗蜜亦如是示诸佛世间。须菩提白佛言。世尊。般若波罗蜜为大事故出。般若波罗蜜为不可思议事不可称事不可量事无等等事故出。佛言。如是如是。须菩提。般若波罗蜜为大事故出。为不可思议事不可称事不可量事无等等事故出。须菩提。云何般若波罗蜜为大事故出。为不可思议事不可称事。不可量事无等等事故出。须菩提。如来法佛法自然法。一切智人法。广大不可思议不可筹量。是故须菩提。般若波罗蜜为大事不可思议事故出。云何般若波罗蜜为不可称事不可量事故出。须菩提。如来法佛法自然法一切智人法不可称不可量。是故须菩提。般若波罗蜜为不可称不可量事故出。云何般若波罗蜜为无等等事故出。须菩提。一切无与如来等者。何况有胜。是故须菩提。般若波罗蜜为无等等事故出。世尊。但如来法佛法自然法一切智人法不可思议不可称不可量。色亦不可思议不可称不可量。受想行识亦不可思议不可称不可量。须菩提。色亦不可思议不可称不可量。受想行识亦不可思议不可称不可量。一切法亦不可思议不可称不可量。何以故。须菩提。诸法实相中。无心无心数法。须菩提。色不可称。受想行识亦不可称。一切法亦不可称。此中无有分别故。须菩提。色不可量。受想行识亦不可量。一切法亦不可量。须菩提。何以故。色不可量。受想行识不可量。一切法不可量。须菩提。色量无所有不可得。受想行识量无所有不可得。一切法量无所有不可得。须菩提。何以故。色量无所有不可得。受想行识量无所有不可得。一切法量无所有不可得。须菩提。色无所有故。受想行识无所有故。一切法无所有故。量不可得。须菩提。于意云何。虚空有心心数法不。不也世尊。须菩提。以是因缘一切法不可思议。灭诸筹量故名不可思议。灭诸称故名不可称。须菩提。称者即是识业。须菩提。无量者过诸量故。须菩提。如虚空不可思议不可称不可量。诸如来法佛法自然法一切智人法。亦如是不可思议不可称不可量。说是不可思议无等等法时。五百比丘二十比丘尼。不受一切法故。漏尽心得解脱。六万优婆塞三万优婆夷。于诸法中得法眼净。二十菩萨得无生法忍。于此贤劫皆当成佛。尔时须菩提白佛言。世尊。是深般若波罗蜜为大事故出。乃至为无等等事故出。佛言。如是如是。须菩提。是深般若波罗蜜为大事故出。乃至为无等等事故出。诸佛萨婆若。皆在般若波罗蜜中。一切声闻辟支佛地。皆在般若波罗蜜中。须菩提。譬如灌顶刹帝利王。若诸城事诸聚落事。皆付大臣王无所忧。如是须菩提。诸如来亦如是。所有声闻事辟支佛事佛事。皆在般若波罗蜜中。般若波罗蜜能成办其事。是故须菩提。当知般若波罗蜜为大事故出。乃至为无等等事故出。须菩提。般若波罗蜜。不受不着色故出。不受不着受想行识故出。不受不着须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道故出。乃至萨婆若。亦不受不着故出。须菩提白佛言。世尊。云何般若波罗蜜不受萨婆若。不着萨婆若。须菩提。于意云何。汝见阿罗汉法可受可着不。不也世尊。我不见是法可生著者。佛言。善哉善哉。须菩提。我亦不见如来法。以不见故不受不着。是故须菩提。萨婆若不可受不可着。尔时欲色界诸天子白佛言。世尊。是深般若波罗蜜难解难得。若能信解深般若波罗蜜者。当知是人已于先世供养诸佛。世尊。若三千大千世界众生皆作信行。于信行地中修行。若一劫若减一劫。若人一日行深般若波罗蜜。筹量思惟观忍通利。是福为胜。佛告诸天子。若善男子善女人。闻是深般若波罗蜜疾得涅槃。是人于信行地中修行。若一劫若减一劫。所不能及。尔时欲色界诸天子。头面礼佛足绕佛而出去此不远忽然不现。欲界诸天子还至欲天。色界诸天子还至色天。尔时须菩提白佛言。世尊。若菩萨能信解深般若波罗蜜。是人于何命终来生此间。佛告须菩提。若菩萨闻是深般若波罗蜜。即时信解不疑不悔不难。乐见乐闻常行。是念不离说般若波罗蜜者。须菩提。譬如新产犊子不离其母。菩萨亦如是。闻深般若波罗蜜。不离说法者。乃至得读诵书写般若波罗蜜。须菩提当知。是菩萨人中命终还生人中。世尊颇有菩萨成就。如是功德因缘。于他方世界供养诸佛。于彼命终来生此间不。须菩提。有菩萨成就如是功德。于他方世界供养诸佛。于彼命终来生此间。复次须菩提。有菩萨成就如是功德。于兜率天上。闻弥勒菩萨说般若波罗蜜。问其中事。于彼命终来生此间。复次须菩提。若人先世闻是深般若波罗蜜。不问其义。是人若生人中。心续疑悔难决。须菩提当知是人于前世不问所致。何以故。于是般若波罗蜜中。心疑悔难决故。复次须菩提。若人先世若一日若二日三日四日五日。闻是深般若波罗蜜。问其中事。而不随所说行。是人转身续得闻深般若波罗蜜。问其中事信心无碍。若离法师不复问难。还为因缘所牵。失深般若波罗蜜。何以故。须菩提。法应尔。若人虽能问难是深般若波罗蜜。不能随所说行。或时乐闻深般若波罗蜜。或时不乐。其心轻躁如少[疊*毛]毳。当知是菩萨新发大乘。是菩萨信心清净。若不为般若波罗蜜所护。于二地中当堕一处。若声闻地若辟支佛地

    摩诃般若波罗蜜船喻品第十四

尔时佛告须菩提譬如大海中船卒破其中人若不取木若板若浮囊若死尸。当知是人不到彼岸没水而死。须菩提。其中人若取木板浮囊死尸。当知是人不没水死。安隐无恼得至彼岸。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信有忍有乐。有净心有深心。有欲有解有舍有精进。不取般若波罗蜜。当知是人中道退没。堕声闻辟支佛地。须菩提。若菩萨于阿耨多罗三藐三菩提。有信有忍有乐。有净心有深心。有欲有解有舍有精进。取般若波罗蜜。为般若波罗蜜所守护故。中道不退。过声闻辟支佛地。当住阿耨多罗三藐三菩提。须菩提。譬如有人持坏瓶诣河井池泉取水。当知是瓶烂坏不久还归于地。何以故。瓶未熟故。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信有忍有乐。有净心有深心。有欲有解有舍有精进。不为般若波罗蜜方便所护故。当知是人未得萨婆若中道。退转。须菩提。云何为菩萨中道退转。所谓若堕声闻地。若堕辟支佛地。须菩提。譬如有人持熟瓶诣河井池泉取水。当知是瓶坚固不坏持水而归。何以故。是瓶熟故。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信有忍有乐。有净心有深心。有欲有解有舍有精进。为般若波罗蜜方便所护故。当知是菩萨不中道退转。安隐得到萨婆若。须菩提。譬如大海中船未被庄治。推着水边载诸财物。当知是船中道漏没散失财物。以是贾客无方便故。多失财物自致忧恼。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信乃至进。不为般若波罗蜜方便所护故。未到萨婆若。中道而退失于大宝。而自忧恼失大珍宝。中道没者。堕声闻辟支佛地。失大珍宝者。失萨婆若宝。须菩提。譬如大海边船庄治坚牢推着水中载诸财物。当知是船不中道没。随所至处必能得到。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信乃至进。为般若波罗蜜方便所护故。当知是菩萨。不中道退转于阿耨多罗三藐三菩提。何以故。须菩提。法应尔。若菩萨于阿耨多罗三藐三菩提。有信乃至进。为般若波罗蜜方便所护故。不堕声闻辟支佛地。但以是诸功德。向阿耨多罗三藐三菩提。须菩提。譬如老人年百二十而有杂病风寒冷热。须菩提。于意云何。是人能从床起不。不也世尊。须菩提。是人或时能起。世尊。假令能起不能远行若十里二十里。何以故。是人已为老病所侵。虽复能起不能远行。须菩提。菩萨亦如是。虽发阿耨多罗三藐三菩提心乃至有精进。于阿耨多罗三藐三菩提有信乃至有进。不为般若波罗蜜方便所护故。未得萨婆若。中道退转。堕声闻辟支佛地。须菩提。是百二十岁老人。若有风寒冷热之病欲从床起。有二健人各扶一腋。安慰之言。随意所至。我等好相扶持。勿惧中道有所坠落。须菩提。菩萨亦如是。于阿耨多罗三藐三菩提。有信乃至进。为般若波罗蜜方便所护故。当知是菩萨不中道退转。能至阿耨多罗三藐三菩提

小品般若经卷第五小品般若波罗蜜经卷第六

        后秦龟兹国三藏鸠摩罗什译

    大如品第十五

尔时须菩提白佛言。世尊。新发意菩萨。云何应学般若波罗蜜。佛告须菩提。新发意菩萨若欲学般若波罗蜜。先当亲近善知识能说般若波罗蜜者。是人如是教。善男子来。汝所有布施。皆应回向阿耨多罗三藐三菩提。汝善男子。亦莫贪着阿耨多罗三藐三菩提。若色是。若受想行识是。何以故。是萨婆若非可著者。善男子。汝所有持戒忍辱精进禅定智慧。皆应回向阿耨多罗三藐三菩提。勿生贪着。若色是。若受想行识是。何以故。善男子。是萨婆若非可著者。汝善男子。亦勿贪着声闻辟支佛道。须菩提。如是新发意菩萨。应渐教令入深般若波罗蜜。世尊。诸菩萨发阿耨多罗三藐三菩提心。欲得阿耨多罗三藐三菩提。所为甚难。如是如是。须菩提。如诸菩萨发阿耨多罗三藐三菩提心。欲得阿耨多罗三藐三菩提。所为甚难。是人为安隐世间故发心。为安乐世间故发心。我当得阿耨多罗三藐三菩提。为世间作救。为世间作归。为世间作舍。为世间作究竟道。为世间作洲。为世间作导师。为世间作趣。须菩提。云何菩萨得阿耨多罗三藐三菩提时。为世间作救。菩萨为断生死中诸苦恼故。说法救众生于苦恼。须菩提。是名菩萨得阿耨多罗三藐三菩提时为世间作救。云何菩萨得阿耨多罗三藐三菩提时。为世间作归众生生法老病死法。忧悲苦恼法。是菩萨能度众生于此生法老病死法忧悲苦恼法。须菩提。是名菩萨得阿耨多罗三藐三菩提时为世间作归。云何菩萨得阿耨多罗三藐三菩提时。为世间作舍。须菩提。菩萨得阿耨多罗三藐三菩提时。为不着故说法。世尊。云何名不着。须菩提。若色不缚不解不生不灭。是名色不着。若受想行识不缚不解不生不灭。是名识不着。如是须菩提。一切法不缚不解故不着。菩萨得阿耨多罗三藐三菩提时。能为众生说如是法。是名菩萨为世间作舍。云何菩萨得阿耨多罗三藐三菩提时。为世间作究竟道。须菩提。色究竟不名色。受想行识究竟不名识。如究竟相。一切法亦如是。世尊。若究竟相一切法亦尔者。菩萨皆应得阿耨多罗三藐三菩提。何以故。是中无有分别故。如是如是。须菩提。是中无有分别。诸菩萨如是观如是知。其心不没。作是念。我得阿耨多罗三藐三菩提时。应为众生说如是法。须菩提。是名菩萨得阿耨多罗三藐三菩提时为世间作究竟道云何菩萨得阿耨多罗三藐三菩提时。为世间作洲。譬如水中陆地断流之处名之为洲。如是须菩提。色前际后际断。受想行识前际后际断。以前际后际断故。一切法都断。若一切法都断。是名寂灭微妙如实不颠倒涅槃。须菩提。是名菩萨得阿耨多罗三藐三菩提时为世间作洲。云何菩萨得阿耨多罗三藐三菩提时。为世间作导师。须菩提。菩萨得阿耨多罗三藐三菩提时。不为色生灭故说法。但为实相故说法。不为受想行识生灭故说法。但为实相故说法。不为须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道萨婆若生灭故说法。但为实相故说法。须菩提是。名菩萨得阿耨多罗三藐三菩提时为世间作导师。云何菩萨得阿耨多罗三藐三菩提时。为世间作趣。须菩提。菩萨得阿耨多罗三藐三菩提时。为众生说色趣空。说受想行识趣空。一切法皆趣空不来不去。何以故。色空不来不去。受想行识空不来不去。乃至一切法空不来不去故。一切法趣空不过是趣。一切法趣。无相趣无作趣。无起趣无生趣。无所有趣梦趣。无量趣无边趣。无我寂灭趣。涅槃趣。不还趣不趣。一切法不过是趣。世尊。如是法者。谁能信解。须菩提。若菩萨于先佛所久修道行。成就善根乃能信解。世尊。能信解者何相。须菩提。离灭欲恚痴性。是信解相。如是人能知深般若波罗蜜。世尊。是菩萨能解深般若波罗蜜。亦如是趣得是趣相。能为无量众生作趣。如是如是。须菩提是菩萨如是趣。能为无量众生作趣。须菩提。是名菩萨得阿耨多罗三藐三菩提时能为无量众生作趣。世尊。是菩萨所为甚难。能作如是大庄严。为灭度无量无边众生。而众生不可得。如是如是。须菩提。菩萨所为甚难。为灭度无量无边众生故发大庄严。而众生不可得。须菩提。是为菩萨大庄严。不为色。不为受想行识。不为声闻辟支佛地。不为萨婆若故。发大庄严。不为庄严一切法故。是菩萨发大庄严。世尊。菩萨能如是行深般若波罗蜜。则不堕二地。若声闻地辟支佛地。须菩提。汝见何义说如是事。若菩萨如是行深般若波罗蜜。则不堕二地。若声闻辟支佛地。世尊。是般若波罗蜜甚深。此中无修法无所修无修者。何以故。世尊。是深般若波罗蜜中无决定法。修虚空是修般若波罗蜜。世尊。不修一切法是修般若波罗蜜。修无边是修般若波罗蜜。修无著是修般若波罗蜜。须菩提。应以深般若波罗蜜试阿惟越致菩萨。若不贪着般若波罗蜜。不随他言论有所悕望。若闻说深般若波罗蜜时。不惊不怖不没不退。其心喜乐。当知是阿惟越致菩萨。先世已曾闻深般若波罗蜜。何以故。闻说深般若波罗蜜。不惊不怖不没不退。当知是阿惟越致菩萨。世尊。若菩萨闻说深般若波罗蜜。不惊不怖不没不退。应云何观。须菩提。是菩萨应随萨婆若心观般若波罗蜜。世尊。云何名为随萨婆若心观。须菩提。随虚空观。名为随萨婆若心观般若波罗蜜。须菩提。随萨婆若心观。即非观。何以故。无量是萨婆若。无量即无色无受想行识。无智无慧无道。无得无果无生无灭。无作无作者。无方无趣无住无量。即堕无量数。须菩提。如虚空无量。萨婆若亦无量。无法可得亦无得者。不可以色得。不可以受想行识得。不可以檀波罗蜜得。不可以尸波罗蜜得羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜得。何以故。色即是萨婆若。受想行识即是萨婆若。檀波罗蜜即是萨婆若。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。即是萨婆若。尔时欲色界诸天子白佛言。世尊。般若波罗蜜甚深难解难知。佛言。如是。如是。诸天子。般若波罗蜜甚深难解难知。以是义故。我欲默然而不说法。作是念。我所得法。是法中无有得者。无法可得。无所用法可得。诸法相如是甚深。如虚空甚深故是法甚深。我甚深故一切法甚深。不来不去甚深故一切法甚深欲色界诸天子白佛言。希有世尊。是所说法。一切世间难可得信。世间行贪着。是法为无贪着故说。尔时须菩提白佛言。世尊。是法随顺一切法。何以故。世尊。是法无障碍处无障碍相如虚空。世尊。是法无生。一切法不可得故。世尊。是法无处。一切处不可得故。尔时欲色界诸天子白佛言。世尊。是长老须菩提。为随佛生。有所说法皆为空故。须菩提。语欲色界诸天子言。汝等所说长老须菩提为随佛生。随何法生故名随佛生。诸天子。随如行故。须菩提随如来生。如如来如不来不去须菩提随如从本已来。亦不来不去。是故须菩提随如来生。又如来如即是一切法如。一切法如即是如来如。如来如者即非如。是故须菩提随如来生。如如来如。一切处一切处常不坏不分别。是故须菩提随如来生如如来如非住非不住。须菩提如亦如是。是故须菩提随如来生。如如来如无障碍处。一切法如亦无障碍处。是故须菩提随如来生。又如来如一切法如。皆是一如无二无别。是如无作无非如者。若是如无非如者。是故是如无二无别。是故须菩提随如来生。又如来如一切处不坏不分别。一切法如亦不坏不分别。如是如来如不可分别故无坏无别。是故须菩提随如来生。如如来如不离诸法。如是如不异诸法。是如无非如时常是如。如是如是。须菩提如不异是如故。如实随如行亦无所行。是故须菩提随如来生。如如来如非过去非未来非现在。一切法如亦如是。非过去非未来非现在。是故须菩提随如行生故名为随如来生。又如来即是如来如。如来如即是过去如。过去如即是如来如。如来如即是未来如。未来如即是如来如。如来如即是现在如。现在如即是如来如。过去未来现在如如来如无二无别。一切法如须菩提如亦无二无别。是故须菩提随如来生。菩萨如即是得阿耨多罗三藐三菩提时如。菩萨以是如得阿耨多罗三藐三菩提。名为如来。佛说是如时。地六种震动。以是如故。须菩提随如来生。又须菩提不随色生。不随受想行识生。不随须陀洹果生。不随斯陀含果生。不随阿那含果生。不随阿罗汉果生。不随辟支佛道生。是故须菩提随如来生。尔时舍利弗白佛言。世尊。是如甚深。佛言。如是如是。舍利弗。是如甚深。今说是如。三千比丘不受诸法故。漏尽心得解脱。舍利弗。五百比丘尼于诸法中。远尘离垢得法眼净。五千天人得无生法忍。六千菩萨不受诸法漏尽心得解脱。舍利弗。是六千菩萨已曾供养亲近五百诸佛。于诸佛所。布施持戒忍辱精进禅定。不为般若波罗蜜方便所护故。今不受诸法漏尽心得解脱。舍利弗。菩萨虽行空无相无作道。不为般若波罗蜜方便所护故。证于实际作声闻乘。舍利弗。譬如有鸟。身长百由旬若二三四五百由旬。翅未成就欲从忉利天上来至阎浮提。便自投来下。舍利弗。于意云何。是鸟中道作是念。我欲还忉利天上。宁得还不。不也世尊。舍利弗。是鸟复作是愿。至阎浮提身不伤损。得如愿不。不也世尊。是鸟至阎浮提身必伤损。若死若近死苦。何以故。世尊。法应尔。其身既大翅未成就故。舍利弗。菩萨亦如是。虽于恒河沙劫布施持戒忍辱精进禅定。发大心大愿受无量事。欲得阿耨多罗三藐三菩提。而不为般若波罗蜜方便所护故。则堕声闻辟支佛地。舍利弗。菩萨虽念于过去未来现在诸佛所行戒品定品慧品解脱品解脱知见品。而心取相。是菩萨取相念故。不知诸佛戒品定品慧品解脱品解脱知见品。不知不见故。闻诸法空名字。取是音声相。回向阿耨多罗三藐三菩提。当知是菩萨堕于声闻辟支佛地。何以故。舍利弗。菩萨离般若波罗蜜故法应当尔。世尊。如我解佛所说义。若菩萨离般若波罗蜜。则于阿耨多罗三藐三菩提。狐疑未了。是故菩萨摩诃萨欲得阿耨多罗三藐三菩提。当善行般若波罗蜜方便。尔时欲色界诸天子白佛言。世尊。般若波罗蜜甚深。阿耨多罗三藐三菩提难得。佛言。如是如是。诸天子。般若波罗蜜甚深。阿耨多罗三藐三菩提难得。须菩提白佛言。世尊。如佛所说。般若波罗蜜甚深。阿耨多罗三藐三菩提难得。如我解佛所说义。阿耨多罗三藐三菩提易得。何以故。无法可得。诸法空中无有得阿耨多罗三藐三菩提者。无法可得。无所用法可得。一切法皆空故。诸所说法为有所断。是法亦空。世尊。阿耨多罗三藐三菩提法。得者所用法。得知者所用法。如是法皆空。世尊。以是因缘故。阿耨多罗三藐三菩提。则为易得。诸可得者皆同虚空。舍利弗语须菩提。若阿耨多罗三藐三菩提易得者。恒河沙等诸菩萨不应退转。以是因缘故。当知阿耨多罗三藐三菩提难得。舍利弗。于意云何。色于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。受想行识于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。离色有法可得于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。离受想行识有法可得于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。色如于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。受想行识如于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。离色如有法可得于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。离受想行识如有法可得于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。离诸法如有法可得于阿耨多罗三藐三菩提退转不。不也须菩提。舍利弗。如是实求不可得。为何等法于阿耨多罗三藐三菩提退转者。舍利弗。无法于阿耨多罗三藐三菩提退转。舍利弗言。如须菩提所说义。则为无有菩萨退转。若尔者。佛说三乘人则无差别。尔时富楼那弥多罗尼子语舍利弗。应问须菩提。汝欲令有一菩萨乘不。舍利弗即问须菩提。汝欲令有一菩萨乘耶。须菩提言。如中可有三乘人不。若声闻辟支佛佛乘。须菩提。如中无有三相差别。舍利弗。如有一相不。不也须菩提。舍利弗。如中乃至见有一乘人不。不也须菩提。舍利弗。如是实求是法不可得。汝云何作是念。是声闻乘是辟支佛乘是佛乘者。如是三乘如中无差别。若菩萨闻是事。不惊不怖不没不退。当知是菩萨则能成就菩提。尔时佛赞须菩提言。善哉善哉。须菩提。汝所乐说皆是佛力。所谓如中求三乘人无有差别。若菩萨闻是事。不惊不怖不没不退。当知是菩萨能成就菩提。尔时舍利弗白佛言。世尊。是菩萨成就何等菩提。舍利弗。是菩萨成就无上菩提。舍利弗白佛言。世尊。若菩萨欲成就阿耨多罗三藐三菩提。应云何行。佛言。于一切众生。应行等心慈心不异心谦下心安隐心不嗔心不恼心不戏弄心父母心兄弟心与共语言。舍利弗。若菩萨欲成就阿耨多罗三藐三菩提。应如是学。应如是行

    摩诃般若波罗蜜阿惟越致相品第十六

尔时须菩提白佛言。世尊。何等是阿惟越致菩萨相貌。我当云何知是阿惟越致菩萨。佛告须菩提。所有凡夫地声闻地辟支佛地。如来地。是诸地于如中不坏不二不别。菩萨以是如入诸法实相。亦不分别。是如此是如相。随是如入诸法实相。出是如已更闻余法。不疑不悔不言是非。见一切法皆入于如。是菩萨凡有所说。终不说无益事。言必有益。不观他人长短。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨。不观外道沙门婆罗门言说。实知实见。又阿惟越致菩萨不礼事余天。不用华香供养。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨终不堕三恶道。不受女人身。须菩提以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨自不杀生。亦不教他杀生。自不偷劫。不邪淫不妄语不两舌不恶口不无益语。不贪嫉不嗔恼不邪见。亦不教他令行邪见。是十善道身常自行。亦教他行。是菩萨乃至梦中不行十不善道。乃至梦中亦常行十善道。须菩提。阿惟越致菩萨。以是相貌当知是阿惟越致菩萨。复次须菩提。所可诵读经典。作如是念。我欲令众生得安乐故。当为说法。以是法施如法满愿。以是法施与一切众生共之。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨。闻深法时心无疑悔。节言软语。少于眠卧。若来若去心常不乱。行不卒疾常一其心。安详徐步视地而行。须菩提。如是相貌当知是阿惟越致菩萨。复次须菩提阿惟越致菩萨衣服卧具无有垢秽。常乐清净威仪具足。身常安隐少于疾病。须菩提。凡夫身中八万户虫。是阿惟越致菩萨身中无有如是诸虫。何以故。须菩提。是菩萨善根超出世间。随善根增长故。得心清净身清净。须菩提白佛言。世尊。何等为菩萨心清净。须菩提。随菩萨善根增长。谄曲欺诳渐渐自灭。以灭故心清净。以心清净故能过声闻辟支佛地。是名菩萨心清净。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨不贪利养少于悭嫉。闻深法时其心不没。智慧深故一心听法。所可闻法。皆应般若波罗蜜。是菩萨因般若波罗蜜。世间诸事皆同实相。不见资生之事不应般若波罗蜜者。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。若恶魔至菩萨所。化作八大地狱。一一地狱化作若干百千万菩萨。作是言。是诸菩萨。佛皆与授阿惟越致记。而今堕此大地狱中。汝若受阿惟越致记者。即受地狱记。汝今若能悔是心者。不堕地狱当生天上。是菩萨若闻是语心不动恚。而作是念。阿惟越致菩萨。若堕恶道无有是处。须菩提。以是相貌当知是阿惟越致菩萨

复次须菩提。若恶魔化作沙门。至菩萨所作是言汝先所闻读诵。宜应悔舍汝。若舍离不复听受我。当常至汝所。汝所闻者非佛所说。皆是文饰庄校之辞。我所说经真是佛语。若闻是事心有动恚。当知是菩萨未从诸佛受记。非是必定菩萨。未住阿惟越致菩萨性中。须菩提。闻是事心不动恚。但依诸法相无生无作无起。不随他语。如漏尽阿罗汉现前证诸法相。不生不起法故。不为恶魔所制。须菩提。菩萨亦如是。求声闻辟支佛者所不能破。不复退转必至萨婆若。住阿惟越致性中不随他语

须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。若恶魔至菩萨所作是言。汝所行者是生死行。非萨婆若行。汝今可于此身尽苦取涅槃。若能如是则不复受生死诸苦。是身生尚不可得。何况欲受后身。是菩萨若闻是事心不动恚。恶魔复作是言。汝今欲见诸菩萨供养恒河沙等诸佛衣服饮食卧具医药。皆于恒河沙等诸佛所。修行梵行亲近咨请。为菩萨乘故多所问难。菩萨云何应住。云何应行。是诸菩萨于诸佛所。随所闻事皆能修行。如是教如是学如是行。犹尚不能得阿耨多罗三藐三菩提。不住萨婆若。何况汝当得阿耨多罗三藐三菩提。是菩萨若闻是事心不动恚。恶魔即时复化作诸比丘作是言。是诸比丘皆漏尽阿罗汉。先皆发心欲求佛道。而今皆住阿罗汉地。何况于汝当得阿耨多罗三藐三菩提。菩萨若作是念。我从他闻为无所失。若心不转不生异念。如是魔事。若菩萨如是行诸波罗蜜如是学诸波罗蜜不得萨婆若。无有是处。须菩提。若菩萨如诸佛说随所闻学。随所闻行不离是道。不离萨婆若念。不得萨婆若。无有是处。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨若恶魔来作是言。萨婆若同于虚空。是法无所有。无人用是法得道者。何以故。若得道者。得道法所用得法皆如虚空。知者知法所用法无所有皆同虚空。汝唐受苦恼。若言得阿耨多罗三藐三菩提。即是魔事非佛所说。菩萨于此应如是念。若诃我令离萨婆若尔者是为魔事。于是事中。应生坚固心不动心不转心。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提阿惟越致菩萨若欲入初禅第二第三第四禅。心转调习。是菩萨虽入诸禅。还取欲界法不随禅生。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨。心不贪好名闻称赞。于诸众生心无恚碍。常生安隐利益之心。进止来去心不散乱。常一其心不失威仪。须菩提。是菩萨若在居家不染着诸欲。所受诸欲心生厌离常怀怖畏。譬如险道多诸贼难。虽有所食厌离怖畏心不自安。但念何时过此险道。阿惟越致菩萨。虽在家居所受诸欲。皆见过恶心不贪惜。不以邪命非法自活。宁失身命不侵于人。何以故。菩萨在家应安乐众生。虽复在家而能成就如是功德。何以故。得般若波罗蜜力故。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨执金刚神常随侍卫。不令非人近之。是菩萨心无狂乱。诸根具足无所缺减。修贤善行非不贤善。不以咒术药草引接女人。身不自为亦不教他。是菩萨常修净命。不占吉凶亦不相人生男生女。如是等事皆不为之。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨复有相貌。今当说之。须菩提。阿惟越致菩萨。不乐说世间杂事官事战斗事寇贼事城邑聚落事象马车乘衣服饮食卧具事。不乐说华香女人淫女事。不乐说神龟事。不乐说大海事。不乐说恼他事。不乐说种种事。但乐说般若波罗蜜。常不离应萨婆若心。不乐斗讼。心常乐于法不乐非法。乐善知识不乐冤家。乐和诤讼不乐谗谤。乐佛法中而得出家。常乐欲生他方清净佛国。随意自在。其所生处常得供养诸佛。须菩提。阿惟越致菩萨多于欲界色界命终。来生中国。善于伎艺。明解经书咒术占相。悉能了知。少生边地。若生边地必在大国。有如是功德相貌。当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨不作是念。我是阿惟越致非阿惟越致。不生是疑。须菩提。自证阿惟越致地者终不复疑。譬如须陀洹所证法中心无所疑。种种魔事皆能觉之。觉已不随。菩萨亦如是。于阿惟越致地中。心无所疑。种种魔事皆能觉之。觉已不随。须菩提。譬如人有逆罪心常悔惧至死不舍不能远离。如是罪心常随是心乃至命终。须菩提。阿惟越致菩萨亦复如是。阿惟越致菩萨。心常安住阿惟越致地中。不可动转。一切世间天人阿修罗所坏种种魔事能觉之。觉已不随。所证法中其心决定无所疑惑。乃至转身不生声闻辟支佛心。转身亦复不疑。我不得阿耨多罗三藐三菩提。自证所得法中不随他人。自住证地无能破坏。何以故。成就不可坏智慧故。安住阿惟越致性。须菩提。若恶魔化作佛身。至阿惟越致菩萨所作是言。善男子。汝于此身可证阿罗汉。何用阿耨多罗三藐三菩提为。何以故。菩萨成就得阿耨多罗三藐三菩提相貌。汝无是相。须菩提。菩萨闻是语心不动异。即作是念。若是恶魔若魔所使。非佛所说。若佛所说不应有异。若菩萨能如是念。是魔变身作佛。欲令我远离般若波罗蜜。魔若还隐没。当知是菩萨已于先佛得受阿耨多罗三藐三菩提记。安住阿惟越致地中。何以故。是人有阿惟越致相貌。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨为护法不惜身命。为正法故行精进。作是念。我不但护过去现在诸佛正法。亦复当护未来世中诸佛正法。我亦当在未来数中而得受记。我则自守护法。是菩萨见是利故守护正法。乃至不惜身命。其心不没不悔。须菩提。以是相貌当知是阿惟越致菩萨。复次须菩提。阿惟越致菩萨。若从如来闻说法时。心无所疑。须菩提白佛言。世尊。是菩萨但闻如来说法时。心无所疑。闻声闻人说法时。亦无所疑耶。须菩提。是菩萨从声闻人闻法时。亦无所疑。何以故。是菩萨于诸法中得无生忍故。须菩提。菩萨成就如是功德相貌。当知是阿惟越致菩萨

小品般若经卷第六小品般若波罗蜜经卷第七

        后秦龟兹国三藏鸠摩罗什译

    深功德品第十七

尔时须菩提白佛言。希有世尊。是阿毗跋致菩萨。成就大功德。世尊。能说阿毗跋致菩萨恒河沙等相貌。说是相貌。则是说深般若波罗蜜相。佛言。善哉善哉。须菩提。汝能示诸菩萨甚深之相。须菩提。甚深相者即是空义。即是无相无作无起。无生无灭无所有。无染寂灭远离涅槃义。世尊。但是空义。乃至涅槃义。非一切法义耶。须菩提。一切法亦是甚深义。何以故。须菩提。色甚深。受想行识甚深。云何色甚深。如如甚深。云何受想行识甚深。如如甚深。须菩提。无色是色甚深。无受想行识是识甚深。须菩提言。希有世尊。以微妙方便。障色示涅槃。障受想行识示涅槃。佛告须菩提。菩萨若能于是深般若波罗蜜。思惟观察。如般若波罗蜜教我应如是学。如般若波罗蜜说我应如是行。是菩萨如是思惟修习。乃至一日所作功德无有限量。须菩提。譬如多欲之人欲觉亦多。与他端正女人共期。此女监碍失期不至。须菩提。于意云何。是多欲人欲觉。为与何法相应。世尊。是多欲人。但起欲觉相应念忆想此女。当至不久。我当与之坐卧戏笑。须菩提。于意云何。是人一日一夜起几欲念。世尊。是人一日一夜起念甚多。须菩提。若菩萨如深般若波罗蜜教。思惟学习则离退转过恶。舍若干劫数生死之难。是菩萨一日之中。应深般若波罗蜜所作功德。胜于菩萨远离深般若波罗蜜于恒河沙劫布施功德。复次须菩提。若菩萨离般若波罗蜜。于恒河沙劫供养须陀洹斯陀含阿那含阿罗汉辟支佛诸佛。于意云何。其福多不。须菩提言。甚多世尊。无量无边不可称数。佛言。不如菩萨于深般若波罗蜜如说修行。乃至一日其福甚多。何以故。菩萨行般若波罗蜜。能过声闻辟支佛地入菩萨位。得阿耨多罗三藐三菩提。复次须菩提。若菩萨于恒河沙劫。离般若波罗蜜。布施持戒忍辱精进禅定智慧。于意云何。其福多不。须菩提言。甚多世尊。佛言。不如菩萨于深般若波罗蜜如说修行。乃至一日布施持戒忍辱精进禅定智慧其福甚多。复次须菩提。若菩萨于恒河沙劫。离般若波罗蜜法施众生。于意云何。其福多不。须菩提言。甚多世尊。佛言。不如菩萨于深般若波罗蜜如说修行。乃至一日法施众生其福甚多。何以故。若菩萨不离般若波罗蜜。即是不离萨婆若。复次须菩提。若菩萨于恒河沙劫离般若波罗蜜。修行三十七品。于意云何。其福多不。须菩提言。甚多世尊。佛言。不如菩萨如般若波罗蜜教住。乃至一日修行三十七品其福甚多。何以故。若菩萨不离般若波罗蜜退失萨婆若。无有是处。复次须菩提。若菩萨于恒河沙劫。离般若波罗蜜。以是财施法施禅定功德。回向阿耨多罗三藐三菩提。于意云何。其福多不。须菩提言。甚多世尊。佛言。不如菩萨于深般若波罗蜜如说修行。乃至一日财施法施禅定功德。回向阿耨多罗三藐三菩提其福甚多。何以故。是第一回向。所谓不离深般若波罗蜜。须菩提白佛言。世尊。如佛所说。一切作起法皆是忆想分别。云何说菩萨得福甚多。须菩提。菩萨行般若波罗蜜时。亦能观察是作起功德空无所有。虚诳不实无坚牢相。若菩萨随所能观。则不离深般若波罗蜜。随不离深般若波罗蜜。即得无量阿僧祇福德。世尊。无量阿僧祇有何差别。须菩提。阿僧祇者。不可数尽。无量者过诸量数。世尊。颇有因缘色亦无量受想行识亦无量。佛言有须菩提。色亦无量。受想行识亦无量。世尊。无量者是何义。须菩提。无量者即是空义。即是无相无作义。世尊。无量但是空义。非余义耶。须菩提。于意云何。我不说一切法空耶。世尊说耳。须菩提。若空即是无尽。若空即是无量。是故此法义中无有差别。须菩提。如来所说无尽无量。空无相无作无起。无生无灭。无所有无染涅槃。但以名字方便故说。须菩提言。希有世尊。诸法实相不可得说。而今说之。世尊。如我解佛所说义。一切法皆不可说。如是如是。须菩提。一切法皆不可说。须菩提。一切法空相不可得说。世尊。是不可说义无增无减。若尔者檀波罗蜜亦应无增无减。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜亦应无增无减。若是诸波罗蜜无增无减。菩萨云何以是无增无减波罗蜜。得阿耨多罗三藐三菩提。近阿耨多罗三藐三菩提。世尊。若菩萨增减诸波罗蜜。则不能近阿耨多罗三藐三菩提。如是如是。须菩提。不可说义无增无减。善知方便菩萨行般若波罗蜜修般若波罗蜜时。不作是念。檀波罗蜜若增若减。作是念。是檀波罗蜜但有名字。是菩萨布施时是念是心及诸善根。皆如阿耨多罗三藐三菩提相回向。须菩提。善知方便菩萨行般若波罗蜜修般若波罗蜜时。不作是念。尸罗波罗蜜若增若减。羼提波罗蜜毗梨耶波罗蜜禅波罗蜜若增若减。须菩提。善知方便菩萨行般若波罗蜜修般若波罗蜜时。不作是念。般若波罗蜜若增若减。作是念。般若波罗蜜但有名字。修智慧时是念是心是善根。如阿耨多罗三藐三菩提相回向。须菩提白佛言。世尊。何等是阿耨多罗三藐三菩提。须菩提。阿耨多罗三藐三菩提者。即是如如无增减。若菩萨常行应如念。即近阿耨多罗三藐三菩提。如是须菩提。不可说义虽无增减。而不退诸念不退诸波罗蜜。菩萨以是行则近阿耨多罗三藐三菩提。而亦不退菩萨之行。作是念者。得近阿耨多罗三藐三菩提。世尊。菩萨前心近阿耨多罗三藐三菩提。后心近阿耨多罗三藐三菩提。世尊。前心后心各各不俱。后心前心亦各不俱。世尊。若前心后心不俱者。菩萨诸善根云何得增长。须菩提。于意云何。如然灯时。为初焰烧炷为后焰烧。世尊。非初焰烧亦不离初焰。非后焰烧亦不离后焰。须菩提。于意云何。是炷燃不。世尊。是炷实燃。须菩提。菩萨亦如是。非初心得阿耨多罗三藐三菩提亦不离初心。非后心得阿耨多罗三藐三菩提亦不离后心得。世尊。是因缘法甚深。菩萨非初心得阿耨多罗三藐三菩提。亦不离初心得。非后心得阿耨多罗三藐三菩提。亦不离后心而得阿耨多罗三藐三菩提。须菩提。于意云何。若心已灭是心更生不。不也世尊。须菩提。于意云何。若心生是灭相不。世尊。是灭相。须菩提。于意云何。是灭相法当灭不。不也世尊。须菩提。于意云何。亦如是住如如住不。世尊。亦如是住如如住。须菩提。若如是住如如住者。即是常耶。不也世尊。须菩提。于意云何。是如甚深不。世尊。是如甚深。须菩提。于意云何。是如即是心不。不也世尊。须菩提。离如是心不。不也世尊。须菩提。汝见如不。不也世尊。须菩提。于意云何。若人如是行者是甚深行不。世尊。若人如是行者。是为无处所行。何以故。是人不行一切诸行。须菩提。若菩萨行般若波罗蜜。于何处行。世尊。于第一义中行。须菩提。于意云何。若菩萨于第一义中行是人相行不。不也世尊。须菩提。于意云何。是菩萨坏诸相不。不也世尊。须菩提。于意云何。菩萨云何为坏诸相。世尊。是菩萨不如是学。我行菩萨道于是身断诸相。若断是诸相未具足佛道。当作声闻。世尊。是菩萨大方便力。知是诸相过而不取无相。尔时舍利弗语须菩提。若菩萨梦中修三解脱门空无相无作。增益般若波罗蜜不。若昼日增益梦中亦应增益。何以故。佛说昼夜梦中等无异故。舍利弗。若菩萨修般若波罗蜜。即有般若波罗蜜。是故梦中亦应增益般若波罗蜜。舍利弗。若人梦中起业。是业有果报不。佛说一切法如梦。不应有果报。若觉分别应有果报。舍利弗。若人梦中杀生觉已分别。我杀是快。是业云何。须菩提无缘则无业。无缘思不生。如是舍利弗。无缘则无业。无缘思不生。有缘则有业。有缘则思生。若心行于见闻觉知法中。有心受垢有心受净。是故舍利弗。有因缘起业非无因缘。有因缘思生非无因缘。舍利弗问须菩提言。若菩萨梦中布施。回向阿耨多罗三藐三菩提。是布施名为回向不。舍利弗。弥勒菩萨今现在座。佛授阿耨多罗三藐三菩提记。可以问之。弥勒当答。舍利弗即问弥勒菩萨。须菩提言。是事弥勒当答。弥勒菩萨语舍利弗。所言弥勒当答者。舍利弗。今以弥勒名字答。若以色答耶。受想行识答耶。若以色空答耶。受想行识空答耶。是色空不能答。受想行识空不能答。舍利弗。我都不见是法能有所答。亦不见答者及所答人所用答法所可答法。我亦不见是法得受阿耨多罗三藐三菩提记。舍利弗语弥勒菩萨。如所说法证此法不。弥勒言。我不随所说法证得。舍利弗作是念。弥勒菩萨智惠甚深。长夜行般若波罗蜜故。尔时佛知舍利弗心所念。语舍利弗言。于意云何。汝见是法。以是法得阿罗汉不。不也世尊。舍利弗。菩萨亦如是。行般若波罗蜜。有方便故不作是念。是法受阿耨多罗三藐三菩提记。已受记今受记当受记。若菩萨如是行。即是行般若波罗蜜。不畏不得阿耨多罗三藐三菩提。我勤行精进。必当得阿耨多罗三藐三菩提。舍利弗。菩萨应常不惊不怖。若在恶兽之中不应惊怖。何以故。菩萨应作是念。我今若为恶兽所啖我当施与。愿以具足檀波罗蜜。当近阿耨多罗三藐三菩提。我当如是勤行精进得阿耨多罗三藐三菩提时。世界之中无一切畜生道。若菩萨在怨贼中不应惊怖。何以故。菩萨法不应惜身命。作是念。若有夺我命者。是中不应生嗔恚。愿以具足羼提波罗蜜。当近阿耨多罗三藐三菩提。我应如是勤行精进得阿耨多罗三藐三菩提时。世界之中无有怨贼及诸寇恶。若菩萨在无水处不应惊怖。作是念。我应为一切众生说法除渴。若我渴乏命终。应作是念。是众生无福德故。在此无水之处。我应如是勤行精进得阿耨多罗三藐三菩提时。世界之中无水之处。亦令众生勤行精进修诸福德。世界之中自然而有八功德水。复次舍利弗。若菩萨在饥馑之中不应惊怖。作是念。我应如是勤行精进得阿耨多罗三藐三菩提时。世界之中无有如是饥馑之患。具足快乐随意所须应念即至。如忉利天上所念皆得。若菩萨如是不惊不怖。当知是菩萨能得阿耨多罗三藐三菩提。复次舍利弗。若菩萨在疾疫处不应惊怖。何以故。是中无法可病故。我应如是勤行精进得阿耨多罗三藐三菩提时。世界之中一切众生无有三病。我当勤行精进。随诸佛所行。复次舍利弗。菩萨若念阿耨多罗三藐三菩提久乃可得。不应惊怖。何以故。世界前际已来如一念顷。不应生久远想。不应念前际是久远。前际虽为久远。而与一念相应。如是舍利弗。若菩萨久乃得阿耨多罗三藐三菩提。不应惊怖退没

    摩诃般若波罗蜜恒伽提婆品第十八

尔时会中有一女人字恒伽提婆。从座而起偏袒右肩。右膝着地合掌向佛。白佛言。世尊。我于是事不惊不怖。我于来世亦为众生演说斯要。即持金华散佛。当佛顶上虚空中住。时佛微笑。阿难从座起偏袒右肩。右膝着地合掌向佛。白佛言。世尊。何因何缘而发微笑。诸佛常法不以无因缘而笑。佛告阿难。是恒伽提婆女人。当于来世星宿劫中而得成佛。号曰金花。今转女身得为男子生阿閦佛土。于彼佛所常修梵行。命终之后从一佛土至一佛土。常修梵行乃至得阿耨多罗三藐三菩提不离诸佛。譬如转轮圣王从一观至一观从生至终足不蹈地。阿难。此女亦如是。从一佛土至一佛土。常修梵行乃至得阿耨多罗三藐三菩提常不离佛。阿难作是念。尔时菩萨众会如诸佛会。佛即知阿难心所念。告阿难言。如是如是。当知尔时菩萨众会如诸佛会。阿难。是金花佛声闻入涅槃者无量无边不可计数。其世界中无诸恶兽怨贼之难。亦无饥馑疾病之患。阿难。是金花佛得阿耨多罗三藐三菩提时。无如是等怖畏之难。阿难白佛言。世尊。是女人于何处初种阿耨多罗三藐三菩提善根。阿难。是女人于燃灯佛所初种善根。以是善根回向阿耨多罗三藐三菩提。亦持金华散燃灯佛。求阿耨多罗三藐三菩提。阿难。尔时我以五茎华散燃灯佛。求阿耨多罗三藐三菩提。燃灯佛知我善根淳淑。即授我阿耨多罗三藐三菩提记。时此女人闻我受记。即发愿言。我亦如是。于未来世当得受记。如今是人得受阿耨多罗三藐三菩提记。阿难。是人于燃灯佛所初种善根。发阿耨多罗三藐三菩提心。阿难白佛言。世尊。是人则为久习阿耨多罗三藐三菩提行。佛言。如是阿难。是人久习阿耨多罗三藐三菩提行。尔时须菩提白佛言。世尊。若菩萨欲行般若波罗蜜。云何应习空。云何应入空三昧。佛告须菩提。菩萨行般若波罗蜜。应观色空。应观受想行识空。应以不散心观。法无所见亦无所证。须菩提言。世尊。如佛所说菩萨不应证空。云何菩萨入空三昧而不证空。须菩提。若菩萨具足观空本已生心。但观空而不证空。我当学空今是学时非是证时。不深摄心系于缘中。尔时菩萨。不退助道法亦不尽漏。何以故。是菩萨有大智慧深善根故。能作是念。今是学时非是证时。我为得般若波罗蜜故。须菩提。譬如人勇健多力难可倾动。容仪端正人所爱敬。善解兵法器仗精锐。六十四能皆悉具足。于余伎术无不炼解。为人爱念。凡有所作皆得成办。以是利故多所饶益。众咸宗敬倍复欢喜。是人有小因缘。扶侍父母携将妻子。经过险道艰难之处。安隐劝喻父母妻子令无恐怖。作是言。此路虽险多有怨贼。必得安隐无他踬顿。其人智力。成就前无敌故。能令父母妻子免此众难。得到城邑聚落村舍。无所伤失心大欢喜。于诸怨贼不生恶心。何以故。是人一切伎术无不炼解。于险道中。化作人众多于怨贼。又所执持器仗精锐。彼诸怨贼皆自退散。是故此人敢能自必安隐无患。如是如是须菩提。菩萨缘一切众生。系心慈三昧。过诸结使及助结使法。过诸魔及助魔者。过声闻辟支佛地。住空三昧而不尽漏。须菩提。尔时菩萨行空解脱门而不证无相。亦不堕有相。譬如鸟飞虚空而不堕落行于虚空而不住空。须菩提。菩萨亦如是。若行空学空。行无相学无相。行无作学无作。未具足诸佛法。而不堕空无相无作。譬如工射之人善于射法仰射虚空箭箭相拄。随意久近能令不堕。如是须菩提。菩萨行般若波罗蜜。方便所护故。不证第一实际。为欲成就阿耨多罗三藐三菩提善根故。成就阿耨多罗三藐三菩提时。乃证第一实际。是故须菩提。菩萨行般若波罗蜜。应如是思惟诸法实相而不取证。须菩提白佛言。世尊。菩萨所为甚难。最为希有。能如是学亦不取证。佛告须菩提。是菩萨不舍一切众生故。发如是大愿。须菩提。若菩萨生如是心。我不应舍一切众生。应当度之即入空三昧解脱门无相无作三昧解脱门。是时菩萨不中道证实际。何以故。是菩萨为方便所护故。复次须菩提。菩萨若欲入如是深定。所谓空三昧解脱门。无相无作三昧解脱门。是菩萨先应作是念。众生长夜着众生相。著有所得。我得阿耨多罗三藐三菩提。当断是诸见而为说法。即入空三昧解脱门。是菩萨以是心及先方便力故。不中道证实际。亦不失慈悲喜舍三昧。何以故。是菩萨成就方便力故。倍复增长善法诸根通利亦得增益菩萨诸力诸觉。复次须菩提。菩萨作是念。众生长夜行于我相。我得阿耨多罗三藐三菩提。当断是相而为说法。即入无相三昧解脱门。是菩萨以是心及先方便力故。不中道证实际。亦不失慈悲喜舍三昧。何以故。是菩萨成就方便力故。倍复增长诸善法善根通利。亦得增益菩萨诸力诸觉。复次须菩提。菩萨作是念。众生长夜行常想乐想净想我想。以是想有所作。我得阿耨多罗三藐三菩提。断是常想乐想净想我想。而为说法。是法无常非是常。是苦非乐。不净非净。无我非我。以是心及先方便力。虽未得佛三昧未具足佛法未证阿耨多罗三藐三菩提。而能入无作三昧解脱门。不中道证实际。复次须菩提。菩萨作如是念。众生长夜行有所得。今亦行有所得。先行有相今亦行有相。先行颠倒今亦行颠倒。先行和合相今亦行和合相。先行虚妄相今亦行虚妄相。先行邪见今亦行邪见。我当勤行精进得阿耨多罗三藐三菩提。为断众生如是诸相。而为说法除此诸过。须菩提。菩萨如是念一切众生。是以心及先方便力故观深法相。若空若无相无作无起。无生无所有。须菩提。菩萨成就如是智慧。若住三界若堕作起法者。无有是处。复次须菩提。菩萨欲得阿耨多罗三藐三菩提。应问余菩萨。于是诸法应云何学。云何生心。入空不证空。入无相无作无起无生无所有。不证无所有而能修习般若波罗蜜。菩萨若如是答。但应念空念无相无作无起无生无所有。不教先心不说先心。当知是菩萨于过去佛。未得受阿耨多罗三藐三菩提记。未住阿毗跋致地。何以故。是菩萨不能说阿毗跋致菩萨不共相。不能正示正答。当知是菩萨未到阿毗跋致地。世尊云何知是阿毗跋致。须菩提。若菩萨若闻若不闻。能如是正答。当知是为阿毗跋致。世尊。以是因缘故。众生多行菩提。少能如是正答者。须菩提。少有菩萨能得阿毗跋致记者。若得受记则能如是正答。当知是菩萨善根明净。当知是菩萨一切世间天人阿修罗所不能及

    摩诃般若波罗蜜阿毗跋致觉魔品第十九

佛告须菩提。若菩萨摩诃萨乃至梦中。不贪着三界及声闻辟支佛地。观一切法如梦而不取证。须菩提当知。是阿毗跋致菩萨相。复次须菩提。若菩萨梦中见佛处在大众高座上坐。无数百千万比丘及无数百千万亿大众。恭敬围绕而为说法。须菩提当知。是阿毗跋致菩萨相。复次须菩提。菩萨梦中。自见其身在于虚空为大众说法。见身大光。觉已作是念。我知三界如梦。必当应得阿耨多罗三藐三菩提。而为众生说如是法。须菩提当知。是阿毗跋致菩萨相。复次须菩提。云何当知。菩萨得阿耨多罗三藐三菩提时。其世界中一切皆无三恶道名。须菩提。若菩萨梦中见畜生作是愿。我当勤行精进得阿耨多罗三藐三菩提时。其世界中一切皆无三恶道名。须菩提。当知是阿毗跋致菩萨相。复次须菩提。菩萨若见城郭火起。即作是念。如我梦中所见相貌。菩萨成就如是相貌。当知是阿毗跋致菩萨。若我有是相貌作阿毗跋致者以此实语力故。此城郭火今当灭尽。若火灭尽。当知是菩萨已于先佛。得受阿耨多罗三藐三菩提记。若火不灭。当知是菩萨未得受记。若是火烧一家置一家烧。一里置一里。须菩提当知。是众生有破法重罪。是破法余殃今世现受。须菩提。以是因缘。当知是阿毗跋致菩萨相。复次须菩提。今当更说阿毗跋致菩萨相貌。须菩提。若男若女为鬼所著。菩萨于此应作是念。若我已于先佛。得受阿耨多罗三藐三菩提记。深心欲得阿耨多罗三藐三菩提。若我所行清净离声闻辟支佛心。必当应得阿耨多罗三藐三菩提。非不应得。于今现在十方无量阿僧祇佛。是诸佛无所不知无所不见。无所不得无所不证。若诸佛知我深心者。必当得阿耨多罗三藐三菩提。以此实语力故。今是男女为非人所持者。非人当疾去。若是菩萨说是语时。非人不去者。当知是菩萨先佛未与授阿耨多罗三藐三菩提记。须菩提。若菩萨说是语时。非人去者。当知是菩萨已于先佛。得受阿耨多罗三藐三菩提记。复次须菩提。有菩萨未得受记。而作誓愿。若我已于先佛得受记者。非人今当舍是人去。恶魔即便来至其所。令非人去。何以故。恶魔威力胜非人故。非人即去。菩萨于此便自念言。是我力故非人远去。而不能知恶魔之力。以是事故。轻蔑恶贱诸余菩萨。我于先佛已得受记。是诸人等于先佛所。未受阿耨多罗三藐三菩提记。以是因缘增长憍慢。以憍慢因缘故。远离萨婆若佛无上智慧。是菩萨以少因缘生于憍慢。当知是为无有方便。必堕二地。若声闻地若辟支佛地。如是须菩提。以是誓愿因缘起于魔事。菩萨于此。若不亲近善知识者。为魔所缚转更牢固。须菩提。当知是为菩萨魔事。复次须菩提。恶魔欲以名字因缘坏乱菩萨。作种种形至菩萨所而作是言。汝善男子。诸佛已与汝受阿耨多罗三藐三菩提记。汝今字是父母字。是兄弟姊妹知识字。是乃至七世父母皆说其名字。汝生某国某城某聚落某家。若是人性行柔和。便说其先世性行柔和。若其性急。亦复说其先世性急。若是人受阿练若法。若乞食。若着纳衣。若食后不饮浆。若一坐食。若节量食。若住死尸间。若坐空地。若坐树下。若常坐不卧。若随敷坐。若少欲知足远离。若不受涂脚油。若乐少语少论。恶魔亦说。其先世受阿练若法。乃至乐少语少论。汝今世有头陀功德。先世亦有头陀功德。是菩萨闻说如上名字及说头陀功德。以是因缘故憍慢心生。即时恶魔复作是言。汝于过去已受阿耨多罗三藐三菩提记。何以故。阿毗跋致功德相貌汝今有之。须菩提。我所说阿毗跋致菩萨真实相貌。是人无有。须菩提当知是菩萨为魔所著。何以故。阿毗跋致菩萨相貌。是人无有。但闻恶魔所说名字。则便轻贱诸余菩萨。须菩提。当知是菩萨因名字故起于魔事。复次须菩提。复有菩萨因名字故起于魔事。所谓魔至其所作是言。汝于先佛。得受阿耨多罗三藐三菩提记。汝作佛时。名号如是。是菩萨本所愿名号同魔所说。无智无方便故。便作是念。我得阿耨多罗三藐三菩提时。所愿名号。是比丘所说同我本愿。便随恶魔所著。比丘信受其语。但以名字因缘故。则便轻贱诸余菩萨。须菩提。我所说真实阿毗跋致菩萨相貌。是人无有。以轻慢因缘故。远离萨婆若佛无上智慧。是菩萨若离方便及善知识。遇恶知识当堕二地。若声闻地若辟支佛地。须菩提。若是菩萨即于此身。悔先诸心远离声闻辟支佛地。当久在生死乃复还因般若波罗蜜。得阿耨多罗三藐三菩提。何以故。是诸心罪重故。譬如比丘犯四重禁若一若二。则非沙门非释种子。是菩萨以名字。轻余菩萨故。其所获罪重于四禁。须菩提。置是四禁。如是之罪重于五逆。所谓以名字故。生憍慢心。须菩提。以是名字因缘。起此微细魔事菩萨应当觉之觉已远离

复次须菩提。恶魔见菩萨有远离行。便至其所。作是言。善男子远离行者。如来常所称赞。须菩提。我不说菩萨远离在于阿练若处空闲处山间树下旷绝之处。世尊。若阿练若处空闲处山间树下旷绝之处。不名远离者。更有何等远离。须菩提。若菩萨远离声闻辟支佛心。如是远离。若近聚落亦名远离。若在阿练若处空闲处山间树下旷绝之处。亦名远离。须菩提。如是远离我所听许。若菩萨昼夜修行如是远离。若近聚落亦名远离。若在阿练若处空闲处山间树下旷绝之处。亦名远离。须菩提。若恶魔所称赞远离。阿练若处空闲处山间树下旷绝之处。是菩萨虽有如是远离。而不远离声闻辟支佛心。不修般若波罗蜜。不为具足一切智慧。是则名为杂糅行者。是菩萨行是远离则不清净。轻余菩萨近聚落住心清净者。远离声闻辟支佛心者。不杂恶不善法。得诸禅定背舍三昧诸神通力。通达般若波罗蜜者。是无方便菩萨虽在百由旬空旷之处。但有鸟兽寇贼恶鬼所行处住。若百千万亿岁若过是数。而不能知真远离相。远于真远离。不知深心发阿耨多罗三藐三菩提心。如是菩萨。亦名愦闹行者。若贪着依止如是远离。是则不能令我心喜。何以故。我所听许远离行中。不见是人。是人无有如是远离。须菩提。复有恶魔到菩萨所住虚空中作是言。善哉善哉。汝所行者是真远离佛所称赞。以是远离。汝当疾得阿耨多罗三藐三菩提。是菩萨从远离所来至聚落。见余比丘求佛道者心性和柔。便生轻慢。汝是愦闹行者。须菩提。是菩萨以愦闹为真远离。以真远离为愦闹。如是说其过恶。不生恭敬心。应恭敬而反轻慢。应轻慢而反恭敬。作是念。我见非人念我而来助我而来。佛所听许真远离行。我则行之。汝近聚落。谁当念汝谁当助汝。作是念已。轻余菩萨清净行者。须菩提当知。是人是菩萨旃陀罗。当知是人污余菩萨臭秽不净。当知是人是似像菩萨。当知是人一切世间天人之大贼沙门形贼。须菩提。求佛道者不应亲近如是之人。何以故。如是人等名为增上慢者。须菩提。若菩萨爱惜萨婆若。爱惜阿耨多罗三藐三菩提。深心欲得阿耨多罗三藐三菩提。欲得利益一切众生。不应亲近如是等人。求佛道者常求己利。常应厌离怖畏三界。于此人中。当生慈悲喜舍之心。我当如是勤行精进。得阿耨多罗三藐三菩提时无如是恶。若其起者当疾除灭。须菩提。如是行者是为菩萨智慧之力

小品般若经卷第七小品般若波罗蜜经卷第八

        后秦龟兹国三藏鸠摩罗什译

    深心求菩提品第二十

佛告须菩提。若菩萨欲得阿耨多罗三藐三菩提。应当亲近善知识。须菩提白佛言。世尊。何等是菩萨善知识。佛告须菩提。诸佛世尊是菩萨善知识。何以故。能教菩萨。令入般若波罗蜜故。须菩提。是名菩萨善知识。复次须菩提。六波罗蜜是菩萨善知识。六波罗蜜是菩萨大师。六波罗蜜是菩萨道。六波罗蜜是菩萨光明。六波罗蜜是菩萨炬。须菩提。过去诸佛皆从六波罗蜜生。未来诸佛皆从六波罗蜜生。现在十方无量阿僧祇世界诸佛。皆从六波罗蜜生。又三世诸佛萨婆若。皆从六波罗蜜生。何以故。诸佛行六波罗蜜。以四摄法摄取众生。所谓布施爱语利益同事。得阿耨多罗三藐三菩提。须菩提。是故当知。六波罗蜜是大师。是父是母是舍是归。是洲是救是究竟道。六波罗蜜利益一切众生。是故菩萨欲自深智明了。不随他语不信他法。若欲断一切众生疑。应当学是般若波罗蜜。世尊。又何等相是般若波罗蜜。须菩提。无碍相是般若波罗蜜。世尊。颇有因缘。如般若波罗蜜无碍相。一切法亦无碍相耶。有须菩提。如般若波罗蜜无碍相。一切法亦无碍相。何以故。须菩提。一切法离相。一切法空相。是故须菩提。当知般若波罗蜜亦离相空相。一切法亦离相空相。世尊。若一切法离相空相。云何众生有垢有净。何以故。离相法无垢无净。空相法无垢无净。离相法空相法。不能得阿耨多罗三藐三菩提。离离相离空相。更无有法能得阿耨多罗三藐三菩提。世尊。我今云何当知是义。须菩提。我还问汝。随意答我。须菩提。于意云何。众生长夜着我我所不。如是如是。世尊。众生长夜着我我所。须菩提于意云何。我我所空不。世尊。我我所空。须菩提。于意云何。众生以我我所往来生死不。如是如是。世尊。众生以我我所故往来生死。须菩提。如是众生名为有垢。随众生所受所著故。是中实无有垢亦无受垢者。须菩提。若不受一切法。则无我无我所。是名为净。是中实无有净。亦无有受净者。菩萨如是行。名为行般若波罗蜜。世尊。若菩萨如是行则不行色。不行受想行识若菩萨如是行者。一切世间天人阿修罗不能降伏。世尊。菩萨如是行者。胜一切声闻辟支佛所行。住无胜处。世尊。无胜菩萨昼夜行是应般若波罗蜜念。近于阿耨多罗三藐三菩提。疾得阿耨多罗三藐三菩提。佛告须菩提。于意云何。假令阎浮提所有众生一时皆得人身。发阿耨多罗三藐三菩提心。发心已尽形布施。以是布施。回向阿耨多罗三藐三菩提。须菩提。于意云何。是人以是因缘得福多不。须菩提言。甚多世尊。佛言。若菩萨乃至一日行应般若波罗蜜念。其福胜彼。随喜菩萨行。应般若波罗蜜念。能为一切众生而作福田。何以故。唯除诸佛。其余众生无如是深慈心。如菩萨摩诃萨。诸菩萨因般若波罗蜜。能生如是慧。以是慧见一切众生受诸苦恼。如被刑戮。菩萨即得大悲之心。得大悲已。以天眼观诸众生。见无量众生有无间罪堕于诸难。即生怜愍之心。不住是相亦不住余相。须菩提。是名诸菩萨大智光明行是道者则为一切众生福田。而不退转阿耨多罗三藐三菩提。所受供养衣服饮食卧具医药所须之物。一心修习般若波罗蜜故。能净报施恩。亦近萨婆若。是故菩萨若欲不空食国中施。若欲利益一切众生。若欲示一切众生正道若欲解一切众生牢狱系缚。若欲与一切众生慧眼。常应修行应般若波罗蜜念。若行应般若波罗蜜念。是菩萨有所言说。亦与般若波罗蜜相应。何以故。是菩萨有所言说。皆随顺般若波罗蜜念。有所念亦随顺言说。菩萨常应如是昼夜念。般若波罗蜜。须菩提。譬如人得未曾有宝。得已大喜而复还失。以是因缘忧愁苦恼。其心常念。我今如何失此大宝。须菩提。菩萨亦如是。大宝者。是般若波罗蜜。菩萨得是已。常应以应萨婆若心念般若波罗蜜。须菩提白佛言。世尊。若一切念。从本已来性常离者。云何说言不应离是应般若波罗蜜念。须菩提。若菩萨能如是知。即不离般若波罗蜜。何以故。般若波罗蜜空。是中无有退失。世尊。若般若波罗蜜空。菩萨云何以般若波罗蜜而得增长。云何亦得近于阿耨多罗三藐三菩提。须菩提。菩萨行般若波罗蜜。亦无增无减。须菩提。若菩萨闻是说。不惊不怖不没不退。当知是菩萨行般若波罗蜜。世尊。般若波罗蜜空相。是行般若波罗蜜不。不也须菩提。世尊。离般若波罗蜜。更有法行般若波罗蜜不。不也须菩提。世尊。空可行空不。不也须菩提。世尊。离空可行空不。不也须菩提。世尊。行色是行般若波罗蜜不。不也须菩提。世尊。行受想行识是行般若波罗蜜不。不也须菩提。世尊。离色有法可行般若波罗蜜不。不也须菩提。世尊。离受想行识有法可行般若波罗蜜不。不也须菩提。世尊。菩萨云何行名为行般若波罗蜜。须菩提。于意云何。汝见有法行般若波罗蜜不。不也世尊。须菩提。汝见般若波罗蜜法是菩萨行处不不也世尊。须菩提。于意云何。汝所不见法颇有生不。不也世尊。须菩提。是名诸佛无生法忍。菩萨能成就如是忍者。当得受阿耨多罗三藐三菩提记。须菩提是名诸佛无所畏道。菩萨行是道修习亲近。若当不得佛无上智大智自然智一切智如来智。无有是处。世尊。一切法无生。以是得受阿耨多罗三藐三菩提记不。不也须菩提。世尊。今云何名为得受阿耨多罗三藐三菩提记。须菩提。于意云何。汝见有法受阿耨多罗三藐三菩提记不。不也世尊。我不见有法受阿耨多罗三藐三菩提记。亦不见所用法。亦不见所得法。须菩提。如是一切法不可得。不应作是言。是法可得。是所用法可得

尔时释提桓因在大会中。白佛言。世尊。般若波罗蜜甚深难见难解。毕竟离故。若人闻是般若波罗蜜。书写受持读诵。当知是人福德不少。憍尸迦。于意云何。假令阎浮提所有众生。成就十善道。其所得福。不如是人。闻是般若波罗蜜书写受持读诵。百分不及一。百千万亿分不及一。乃至算数譬喻所不能及。时有一比丘。语释提桓因言。憍尸迦。如是善男子善女人。胜于仁者。释提桓因言。此人一发心顷尚胜于我。何况得闻般若波罗蜜。书写受持读诵如所说行。是人于一切世间天人阿修罗中。最为殊胜。菩萨行般若波罗蜜。不但胜于一切世间天人阿修罗。亦胜须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨行般若波罗蜜。不但胜须陀洹乃至辟支佛。亦胜菩萨离般若波罗蜜无方便行檀波罗蜜。不但胜离般若波罗蜜无方便行檀波罗蜜。亦胜离般若波罗蜜无方便行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。如是菩萨最为殊胜。若菩萨随般若波罗蜜所说行者。皆胜一切世间天人阿修罗。一切世间天人阿修罗。皆应恭敬供养。若菩萨行随般若波罗蜜所教行者。是菩萨不断一切种智。是菩萨近阿耨多罗三藐三菩提。是菩萨必坐道场。是菩萨拯济没溺生死众生。菩萨如是学。名为学般若波罗蜜。如是学名为不学声闻辟支佛。若菩萨如是学时四天王持四钵至其所。作是言。善男子。汝疾学得阿耨多罗三藐三菩提坐道场时。我等当奉此四钵。世尊。我亦自往问讯。何况余诸天子。菩萨学般若波罗蜜者。诸佛常共护念。世间众生种种苦恼。是菩萨能随行般若波罗蜜故。无是诸苦。世尊。是菩萨现世功德。尔时阿难作是念。是释提桓因。自以智慧力如是说耶。为是佛神力。释提桓因知阿难心所念。语阿难言。皆是佛神力。佛告阿难。如是如是阿难。如释提桓因所说。皆是佛神力。阿难。菩萨学般若波罗蜜修习般若波罗蜜时。三千大千世界诸魔皆生疑惑。是菩萨为当中道证实际堕声闻辟支佛地。为当直至阿耨多罗三藐三菩提

    摩诃般若波罗蜜恭敬菩萨品第二十一

佛告阿难。若菩萨不离般若波罗蜜行。尔时恶魔忧恼如箭入心。放大雨雹雷电霹雳。欲令菩萨惊怖毛竖其心退没于阿耨多罗三藐三菩提。乃至一念错乱。阿难。恶魔不必普欲恼乱一切菩萨。世尊。何等菩萨为恶魔所乱。阿难。有菩萨先世闻说深般若波罗蜜。不能信受。如是之人恶魔恼乱而得其便。复次阿难。若菩萨闻深般若波罗蜜时心生疑惑。有是深般若波罗蜜耶无耶。阿难。如是菩萨亦为恶魔之所得便。复次阿难。有菩萨离善知识。为恶知识所得。是人不闻深般若波罗蜜中义。以不闻故不知不见。云何应行般若波罗蜜。云何应修般若波罗蜜。阿难。是人亦为恶魔得便。复次阿难。若菩萨受持邪法。是人亦为恶魔得便。恶魔作是念。是人助我亦令余人助我。亦能满我所愿。阿难。是人亦为恶魔得便。复次阿难。菩萨云何为恶魔得便。若菩萨闻深般若波罗蜜。语余菩萨言。是般若波罗蜜甚深。我等犹尚不能得底。汝等何用闻为。是人亦为恶魔得便。阿难。若菩萨轻余菩萨言。我是远离行者。汝等无此功德。尔时恶魔。甚大欢喜踊跃。阿难。若有众菩萨为恶魔称其名字。得是名字故。轻余清净善心菩萨。是等无有阿毗跋致菩萨功德相貌。而假托阿毗跋致功德增长烦恼。自高其身而下他人。作是言。我有所功德汝无是事。尔时恶魔即大欢喜。作是念。我之宫殿。则为不空。增益地狱饿鬼畜生。恶魔加其神力故。是人所语人皆信受。信受已。随所见学随所说行。随所见学随所说行已。亦复增益烦恼。如是人等以颠倒心故。所起身口意业果报皆苦。以是因缘故。增益地狱饿鬼畜生。阿难。恶魔见是利益亦大欢喜。阿难。若求佛道者。与声闻人共诤。恶魔复作是念。是人虽远离萨婆若。而不大远。阿难。若菩萨共菩萨诤。恶魔即大欢喜作是念。是人两离萨婆若远。阿难。若不得受记菩萨嗔恨受记者。而共诤竞恶口骂詈。若爱惜萨婆若。随其起念一念却一劫。尔乃还得发大庄严。阿难白佛言。世尊。如是罪者可得悔不。要当毕其随念劫数。尔乃还得发大庄严。佛言。有出我说菩萨声闻皆有出罪法。不说无出。阿难。若菩萨共菩萨诤。恶口骂詈不相悔谢结恨在心。我不说此人有出罪法。是人若爱惜萨婆若毕其随念劫数。亦复还得发大庄严。阿难。若菩萨共菩萨诤。恶口骂詈即相悔谢后不复作。作是念。我应谦下一切众生。我若嗔诤加报于人则为大失。我应当为一切众生而作桥梁。我尚不应轻汝他人。何况加报。应如聋哑。不应自坏深心。我得阿耨多罗三藐三菩提时当度是等。云何加忿自起嗔碍。阿难。求菩萨道者。于声闻人乃至不应生于嗔碍。阿难白佛言。世尊。菩萨与菩萨共住其法云何。佛言。相视当如佛想。是我大师。同载一乘共一道行。如彼所学我亦应学。彼若杂行非我所学。若彼清净学应萨婆若念我亦应学。菩萨若如是学。是名同学。尔时须菩提白佛言。世尊。若菩萨为尽学则学萨婆若。为无生学为离学为灭学。则学萨婆若。佛告须菩提。如汝所说。菩萨为尽学则学萨婆若。为无生学为离学为灭学。则学萨婆若者。须菩提。于意云何。如来以如得名如来。是如非尽非离非灭耶。如是世尊。须菩提。如是学者名为学萨婆若。学萨婆若为学般若波罗蜜。学佛地十力四无所畏十八不共法。须菩提。菩萨如是学者。则到诸学彼岸。如是学者。魔若魔民不能降伏。如是学者疾得阿毗跋致。如是学者疾坐道场。如是学者学自行处。如是学者学救护法。如是学者学大慈大悲。如是学者学三转十二相法轮。如是学者学度众生。如是学者学不断佛种。如是学者学开甘露门。须菩提。凡夫下劣不能如是学。欲调御一切众生者能如是学。须菩提。菩萨如是学者。不堕地狱畜生饿鬼。不生边地。如是学者不生旃陀罗家。不生竹草作家。不生除粪人家。不生诸余贫贱之家。须菩提。菩萨如是学者。不盲不瞎不睐眼。不痤短不聋哑。不顽钝不形残。身根具足。须菩提。菩萨如是学者。不夺他命。不盗他物。不邪淫。不妄语。不两舌。不恶口。不无益语。不贪嫉。不嗔恼。不邪见。不邪命活。不畜邪见眷属。不畜破戒眷属。须菩提。菩萨如是学者。不生长寿天。何以故。菩萨成就方便故。何等为方便。所谓从般若波罗蜜起。虽能入禅而不随禅生。须菩提。菩萨如是学者。得佛清净力清净无畏。世尊。若一切法本净相者。菩萨复得何等清净法。佛言。如是如是。须菩提。一切法本清净相。菩萨于是本净相法中。行般若波罗蜜。不惊不怖不没不退。是名清净般若波罗蜜。须菩提。凡夫不知不见一切法本清净相。是故菩萨发勤精进。于是中学。得清净诸力诸无畏。须菩提。菩萨如是学者。悉能通达一切众生心心所行。须菩提。譬如少所地出阎浮檀金。众生聚中。亦少能如是学般若波罗蜜。譬如众生少有能起转轮王业。多有能起诸小王业。如是须菩提。少有众生能行般若波罗蜜道。多有发声闻辟支佛乘。须菩提。少有众生能学阿耨多罗三藐三菩提心者。于学阿耨多罗三藐三菩提中。少能如说行者。于如说行中。少能随学般若波罗蜜者。于随学中。少能得阿毗跋致者。是故须菩提。菩萨欲在少中之少。当学般若波罗蜜。修习般若波罗蜜

    摩诃般若波罗蜜无悭烦恼品第二十二

佛告须菩提。若菩萨如是学般若波罗蜜。则不生烦恼心。不生悭心。不生破戒心。不生嗔恼心。不生懈怠心。不生散乱心。不生愚痴心。须菩提。菩萨如是学。皆摄诸波罗蜜。须菩提。譬如六十二见皆摄在身见中。须菩提。菩萨学般若波罗蜜时。皆摄诸波罗蜜。譬如人死。命根灭故诸根皆灭。如是须菩提。菩萨学般若波罗蜜。皆摄诸波罗蜜。是故须菩提。菩萨若欲摄诸波罗蜜。当学般若波罗蜜。须菩提。菩萨学般若波罗蜜。即于一切众生中最为上首。须菩提。于意云何。三千大千世界众生。宁为多不。世尊。阎浮提众生尚多。何况三千大千世界。须菩提。是众生皆为菩萨。若有一人尽形寿供养衣服饮食卧具医药。须菩提。于意云何。是人以是因缘得福多不。甚多甚多世尊。须菩提。若有菩萨如弹指顷。修习般若波罗蜜。福胜于彼。如是须菩提。般若波罗蜜大利益诸菩萨。能助阿耨多罗三藐三菩提。是故须菩提。若菩萨欲得阿耨多罗三藐三菩提。欲于一切众生中为无上者。欲为一切众生作救护。欲得具足佛法。欲得佛所行处。欲得佛所游戏。欲得佛师子吼。欲得三千大千世界大会讲法。当学般若波罗蜜。须菩提。我不见菩萨学般若波罗蜜不得如是具足之利。世尊。是菩萨亦得具足声闻利耶。须菩提。菩萨亦学具足声闻利。但不愿住声闻法中。欲具足诸功德。必皆能知。但不于中住。作是念。我亦当说是声闻功德教化众生。若菩萨如是学者。能为一切世间天人阿修罗作福田于声闻辟支佛福田为最殊胜。菩萨如是学者得近萨婆若。不舍般若波罗蜜。不离般若波罗蜜。菩萨如是行般若波罗蜜。名为不退于萨婆若。远声闻辟支佛地。近阿耨多罗三藐三菩提。是菩萨若作是念。此是般若波罗蜜。是某般若波罗蜜当得萨婆若。如是亦分别。即不行般若波罗蜜。若菩萨不分别般若波罗蜜。不见般若波罗蜜不言此是般若波罗蜜。是某般若波罗蜜当得萨婆若。如是亦不见不闻不觉不知。即行般若波罗蜜。尔时释提桓因作是念。是菩萨行般若波罗蜜。尚胜一切众生。何况得阿耨多罗三藐三菩提。若人乐闻般若。是人为得大利。寿命中最。何况能发阿耨多罗三藐三菩提心。是人则为世间之所贪慕。是人当得调御众生。尔时释提桓因。化作曼陀罗华。满掬散佛上。作是言。世尊。若有人发阿耨多罗三藐三菩提心者。愿令具足佛法。具足萨婆若。具足自然法。具足无漏法。世尊。我乃至不生一念欲使发阿耨多罗三藐三菩提心者有退转。世尊。我见生死之中有诸苦恼。不生一念欲使菩萨有退转者。我亦为阿耨多罗三藐三菩提。当勤行精进。何以故。是人等能发如是心。则大利益一切世间。我自得度当度未度者。我自得脱当脱未脱者。我自得安当安未安者。我自灭度当度未灭度者。世尊。若人于初发心菩萨随喜。若于行六波罗蜜。若于阿毗跋致。若于一生补处随喜。是人为得几所福德。憍尸迦。须弥山王尚可称量。是人随喜福德不可称量。憍尸迦。三千大千世界尚可称量。是人随喜福德不可称量。释提桓因白佛言。世尊。若人不能于是诸心随喜者。则为魔之所著。当知是为魔之眷属。不能于是诸心随喜者。当知是人于魔天命终来生此间。何以故。是诸心皆能破诸魔事。是人随喜福德。应回向阿耨多罗三藐三菩提。若人发阿耨多罗三藐三菩提心者。则为不舍佛不舍法不舍僧。以是故。应于是诸心而生随喜。如是如是憍尸迦。若人于是诸心随喜。当知是人疾得值佛。是人以是随喜福德善根故在所生处。常得供养恭敬尊重赞叹。不闻诸恶音声。亦不堕于诸恶道中。常生天上。何以故。是人随喜。为欲利益无量无边众生故。是随喜心渐渐增长。能至阿耨多罗三藐三菩提。是人得阿耨多罗三藐三菩提时。当灭度无量众生。憍尸迦。以是因缘当知是人。于是诸心随喜者。即是利益无量无边众生善根故随喜。须菩提白佛言。世尊。是心如幻。云何能得阿耨多罗三藐三菩提。须菩提。于意云何。汝见是人心如幻不。不也世尊。我不见是心如幻。于意云何。若不见是幻。不见如幻心。离幻离如幻心。更见有法可得阿耨多罗三藐三菩提不。不也世尊。离幻离如幻心。更不见法得阿耨多罗三藐三菩提。世尊。若我不见异法。当说何法若有若无。世尊。若法毕竟离。即不在有无。若法毕竟离。是法不得阿耨多罗三藐三菩提。世尊。无所有法亦不能得阿耨多罗三藐三菩提。是故般若波罗蜜毕竟离。若法毕竟离。则不可修习如是法者。不能生余法。般若波罗蜜毕竟离故。世尊。般若波罗蜜毕竟离。云何能得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提亦毕竟离。云何以离得离。佛言。善哉善哉。须菩提。般若波罗蜜毕竟离。阿耨多罗三藐三菩提亦毕竟离。以是因缘故。能得阿耨多罗三藐三菩提。须菩提。若般若波罗蜜非毕竟离者。则非般若波罗蜜。如是须菩提。亦不离般若波罗蜜。得阿耨多罗三藐三菩提。亦不以离得离

小品般若经卷第八小品般若波罗蜜经卷第九

        后秦龟兹国三藏鸠摩罗什译

    称扬菩萨品第二十三

尔时须菩提白佛言。世尊。菩萨行般若波罗蜜。即是行甚深义。如是如是。须菩提。菩萨行般若波罗蜜。即是行甚深义须菩提。菩萨所为甚难。行甚深义而不证是义。所谓若声闻地若辟支佛地。世尊。如我解佛所说义。菩萨所行不难。何以故。取证者不可得。所用取证法亦不可得。所证法亦不可得。若菩萨闻如是说。不惊不怖不没不退。当知是菩萨行般若波罗蜜。亦不见我行般若波罗蜜。如是亦不分别。当知是菩萨近阿耨多罗三藐三菩提。远离声闻辟支佛地。世尊。譬如虚空。不作是念是远是近。何以故。虚空无分别故。世尊。般若波罗蜜亦如是。不作是念。声闻辟支佛地去我远。阿耨多罗三藐三菩提去我近。何以故。般若波罗蜜无分别故。世尊。譬如幻所化人。不作是念。幻师去我近观者去我远。何以故。世尊。幻所化人无分别故。世尊。般若波罗蜜亦如是不作是念。声闻辟支佛地去我远。阿耨多罗三藐三菩提去我近。何以故。般若波罗蜜无分别故。世尊。譬如影。不作是念。所因去我近余事去我远。何以故。影无分别故。世尊。般若波罗蜜亦如是。不作是念。声闻辟支佛地去我远。阿耨多罗三藐三菩提去我近。何以故。般若波罗蜜无分别故。世尊。如如来无憎无爱。般若波罗蜜亦如是无憎无爱。世尊。如如来无诸分别。般若波罗蜜亦如是无诸分别。世尊。如如来所化人。不作是念。声闻辟支佛地去我远。阿耨多罗三藐三菩提去我近。何以故。如来所化人无分别故。世尊。般若波罗蜜亦如是。不作是念。声闻辟支佛地去我远。阿耨多罗三藐三菩提去我近。何以故。般若波罗蜜无分别故。世尊。如如来所化人。随事能作而无分别。世尊。般若波罗蜜亦如是。随所修习皆能成办而无所分别。世尊。譬如工匠于机关木人若男若女随所为事皆能成办而无分别。世尊。般若波罗蜜亦如是。随所修习皆能成办而无分别。须菩提白佛言。世尊。菩萨行般若波罗蜜。即是行坚固义。佛告须菩提菩萨行般若波罗蜜。即是行坚固义。尔时欲界诸天子作是念。若人发阿耨多罗三藐三菩提心。能行如是深般若波罗蜜。而不证实际堕声闻地若辟支佛地。当知是菩萨所为甚难。一切世间所应敬礼。须菩提语诸天子。菩萨行深般若波罗蜜。而不取证不足为难。若菩萨为无量无边众生故发大庄严。而众生毕竟不可得。所可度者不可得。而能发心我当度之。尔乃为难。诸天子是人欲度众生为欲度虚空。何以故。虚空离故众生亦离。是故当知是菩萨所为甚难。无众生而为众生发大庄严。如人与虚空共斗。佛说众生不可得。众生离故。可度者亦离。众生离故色亦离。众生离故受想行识亦离。众生离故一切法亦离。若菩萨闻如是说不惊不怖不没不退。当知是为行般若波罗蜜。佛问须菩提。菩萨何因缘故。不惊不怖不没不退。世尊。空故不没。无所有故不没。何以故。没者不可得。没法亦不可得。没处亦不可得。若菩萨闻如是说不惊不怖不没不退。当知是为行般若波罗蜜。须菩提。菩萨如是行般若波罗蜜。释提桓因与梵天王众生主。自在天王及诸天子皆共敬礼。须菩提。不但释提桓因梵天王众生主自在天王及诸天子敬礼是行般若波罗蜜菩萨。梵世诸天梵辅天梵众天大梵天光天少光天无量光天光音天净天少净天无量净天遍净天无阴天福生天广果天无广天无热天妙见天善见天无小天上诸天。皆敬礼是行般若波罗蜜菩萨。须菩提。今现在无量阿僧祇世界诸佛。皆念是行般若波罗蜜菩萨。须菩提若菩萨行般若波罗蜜时。为诸佛所念。当知是菩萨即是阿毗跋致。须菩提。假令如恒河沙等世界众生皆作恶魔。一一化作尔所恶魔。是诸恶魔皆不能坏是行般若波罗蜜菩萨。须菩提。菩萨成就二法。恶魔不能坏。何等二。一者观一切法空。二者不舍一切众生。菩萨成就是二法。恶魔不能坏。须菩提。复有二法。恶魔不能坏。何等二。一者随说能行。二者诸佛所念。菩萨成就是二法。诸天皆来供养恭敬请问安慰。善男子。汝行是行。当疾得佛道。汝行是行。无救众生当为作救。无舍众生当为作舍。无依众生当为作依。无洲众生当为作洲。无究竟道众生当为作究竟道。无归众生当为作归。无明众生为作光明。无趣众生当为作趣。何以故。是菩萨行般若波罗蜜行。成就是四功德。现在十方无量无边阿僧祇世界诸佛。与比丘僧围绕说法时。悉皆称扬赞叹说其名字。须菩提。譬如我今称扬赞叹实相菩萨说其名字。及余菩萨于阿閦佛所。修行梵行不离是般若波罗蜜行者。如是须菩提。今现在十方诸佛。亦皆称扬赞叹。说我国中诸菩萨名修行梵行不离般若波罗蜜行者。须菩提。白佛言。世尊。一切诸佛说法时。普皆称扬赞叹诸菩萨不。不也须菩提。诸佛说法时有称赞者有不称赞者。须菩提。诸佛说法时称扬赞叹诸阿毗跋致菩萨。世尊。未得阿毗跋致者。诸佛说法时亦皆称扬赞叹不。须菩提。未得阿毗跋致者。诸佛亦有称扬赞叹者。何者是能随学阿閦佛为菩萨时所行道者。如是菩萨虽未得阿毗跋致。亦为诸佛称扬赞叹。须菩提。有能随学实相菩萨所行道者。如是菩萨虽未得阿毗跋致。亦为诸佛。称扬赞叹。复次须菩提。有菩萨行般若波罗蜜。信解一切法无生。而未得无生法忍。信解一切法空。而于阿毗跋致地中未得自在。能行一切法寂灭相。而未入阿毗跋致地。须菩提。菩萨如是行者。诸佛说法时亦皆称扬赞叹。未得阿毗跋致。而为诸佛说法时称扬赞叹者。则离声闻辟支佛地。近于佛地。必得阿耨多罗三藐三菩提记。须菩提。若菩萨行般若波罗蜜。诸佛说法时称扬赞叹者。当知是菩萨必至阿毗跋致

    摩诃般若波罗蜜嘱累品第二十四

佛告须菩提。若菩萨闻是甚深般若波罗蜜。信解不疑不悔不难。是菩萨当于阿閦佛及诸菩萨所。闻深般若波罗蜜亦复信解。须菩提。菩萨若能信解如佛所说般若波罗蜜。是人必至阿毗跋致。须菩提。若人但闻般若波罗蜜。尚得饶益。何况信解如所说行。当住萨婆若。须菩提白佛言。世尊。若离如更无法可得。谁当住萨婆若。谁当得阿耨多罗三藐三菩提。谁当说法。佛告须菩提。汝所问。离如更无法可得。谁当住萨婆若。谁当得阿耨多罗三藐三菩提。谁当说法者。如是如是。须菩提。离如更无法住如中。如尚不可得。何况住如者。如不能得阿耨多罗三藐三菩提。离如亦不能得阿耨多罗三藐三菩提。如无说法者。离如亦无说法者。尔时释提桓因白佛言。世尊。无住如者。无得阿耨多罗三藐三菩提者。无说法者。而菩萨闻是深法。不疑不悔不难。而欲得阿耨多罗三藐三菩提。是为甚难。须菩提语释提桓因。憍尸迦。如所说菩萨闻是深法。不疑不悔不难。欲得阿耨多罗三藐三菩提。是为甚难者。憍尸迦。一切法空。此中谁当疑悔难者。释提桓因语须菩提。如所说者。皆因于空而无所碍。譬如仰射虚空箭去无碍。须菩提。所说无碍亦如是。尔时释提桓因白佛言。世尊。我如是说如是答。为随如来说随法答不。憍尸迦。汝如是说如是答。为随如来说。为随法答。皆为正答。憍尸迦。须菩提所说皆因于空。须菩提尚不能得般若波罗蜜。何况行般若波罗蜜者。尚不得阿耨多罗三藐三菩提。何况得阿耨多罗三藐三菩提者。尚不得萨婆若。何况得萨婆若者。尚不得如何况得如者。尚不得无生何况得无生者。尚不得诸力。何况得诸力者。尚不得无所畏。何况得无所畏者。尚不得法。何况说法者。憍尸迦。须菩提常乐远离。乐无所得行。憍尸迦。是须菩提所行于菩萨所行。百分不及一。百千万亿分不及一。乃至算数譬喻所不能及。憍尸迦。唯除如来所行。菩萨行般若波罗蜜。于余行中最大最胜最上最妙。菩萨所行亦于声闻辟支佛所行。最大最胜最上最妙。是故憍尸迦。若人欲于一切众生中最上者。当行菩萨所行般若波罗蜜。尔时会中忉利诸天子。以天曼陀罗华散佛上。六百比丘从座而起。偏袒右肩右膝着地。合掌向佛。佛神力故花悉满掬。即以此华散佛上。散已作是言。世尊。我等皆当行是上行。佛即微笑。诸佛常法若微笑时。青黄赤白无量色光。从口而出。是诸光明。遍照无量无边世界。上至梵天。还绕身三匝从顶上入。阿难即从座而起。偏袒右肩右膝着地。合掌向佛白佛言。世尊。何因缘故微笑。诸佛不以无因缘而笑。佛告阿难。是六百比丘当于星宿劫得成佛同号散花。阿难。是诸如来比丘僧数悉皆同等。寿命亦等俱二万劫。彼诸比丘从是已后。在所生处常得出家。其世界常雨五色好华。是故阿难。若人欲行上行。当行般若波罗蜜。若菩萨欲行如来行。当行般若波罗蜜。阿难。若菩萨行般若波罗蜜。当知是人从人间命终。若于兜率天上命终来生人间。何以故。人中兜术天上。行般若波罗蜜易故。阿难。若菩萨行般若波罗蜜。信乐受持读诵书写。书写已以般若波罗蜜。示教利喜诸余菩萨。当知是人为如来所见。当知是人于诸佛所种诸善根。不于弟子所种善根。阿难。若菩萨学般若波罗蜜。不惊不畏信乐受持读诵如所说行。当知是人至现在佛所。若有信般若波罗蜜。不谤不逆。当知是人已供养诸佛。阿难。若人于佛所种善根。求阿罗汉辟支佛。是善根不虚。亦不离般若波罗蜜。是故阿难。我今以般若波罗蜜嘱累于汝。阿难。我所说法。唯除般若波罗蜜。有所受持。若忘失其过尚少。汝若受持般若波罗蜜。乃至忘失一句其过甚重。是故阿难。我以般若波罗蜜嘱累于汝。汝所闻受持。皆应读诵悉令通利善念在心。当令章句分明。何以故。般若波罗蜜是过去未来现在诸佛法藏故。阿难。若人于今现在。欲以慈心恭敬供养我者。是人当以是心供养般若波罗蜜受持读诵如所说行。即是供养于我。阿难。是人不但供养于我。亦为恭敬供养过去未来现在诸佛。阿难。汝若爱重不舍于我。亦应如是爱重不舍般若波罗蜜。乃至一句慎莫忘失。阿难。我为嘱累般若波罗蜜因缘故。若于一劫百劫千万亿那由他劫乃至如恒河沙等劫说不可尽。阿难。今但略说。如我今为大师。过去现在十方诸佛。于一切世间天人阿修罗中。亦为大师。般若波罗蜜亦于一切世间天人阿修罗中。而作大师。有如是等无量因缘故。我于一切世间天人。阿修罗中。以般若波罗蜜嘱累于汝。佛告阿难。若人爱重佛爱重法爱重僧。爱重过去未来现在诸佛阿耨多罗三藐三菩提。当以是爱重爱重般若波罗蜜。此则是我所用教化。阿难。若有人受持读诵般若波罗蜜。当知是人则为受持过去未来现在诸佛阿耨多罗三藐三菩提。阿难。般若波罗蜜欲断绝时。若欲护助者。是人则是护助过去未来现在诸佛阿耨多罗三藐三菩提。何以故。阿难。诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜生。阿难。若过去诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜生。未来诸佛阿耨多罗三藐三菩提。亦从般若波罗蜜生。现在无量阿僧祇世界诸佛阿耨多罗三藐三菩提。亦从般若波罗蜜生。是故阿难。若菩萨欲得阿耨多罗三藐三菩提。当善学六波罗蜜。何以故。阿难。诸波罗蜜是诸菩萨母能生诸佛。若菩萨学是六波罗蜜。当得阿耨多罗三藐三菩提。是故阿难。我以六波罗蜜重嘱累汝。何以故。是六波罗蜜是诸佛无尽法藏。阿难。汝若因小乘法为小乘人说。三千大千世界众生。皆以是法证阿罗汉汝为弟子功德盖少不足言。若以六波罗蜜为菩萨说。汝为弟子功德具足。我则喜悦。阿难。若人以是小乘法。教三千大千世界众生得阿罗汉证。是诸布施持戒修善福德。宁为多不。阿难言。甚多世尊。佛告阿难。是福虽多不如声闻人为菩萨说般若波罗蜜乃至一日。其福甚多。阿难。置此一日。若从旦至食时。置从旦至食时。乃至一漏刻顷。置是一漏刻顷。乃至须臾。为菩萨说法。是人于一切声闻辟支佛善根福德不可相比。若菩萨如是行如是念。于阿耨多罗三藐三菩提。退转者无有是处

    摩诃般若波罗蜜见阿閦佛品第二十五

佛说般若波罗蜜。是时会中四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。佛神力故。见阿閦佛在大会中恭敬围绕而为说法。如大海水不可移动。时诸比丘皆阿罗汉。诸漏已尽无复烦恼心得自在。及诸菩萨摩诃萨其数无量。佛摄神力。大会四众等皆不复见阿閦如来及声闻菩萨国界严饰。佛告阿难。一切法亦如是。不与眼作对。如今阿閦佛及阿罗汉诸菩萨众皆不复现。何以故。法不见法。法不知法。阿难。一切法非知者非见者无作者无贪着不分别故。阿难。一切法不可思议。犹如幻人。一切法无受者不坚牢故。菩萨如是行者。名为行般若波罗蜜。于法亦无所著。菩萨如是学者。名为学般若波罗蜜。阿难。若菩萨欲到一切法彼岸。当学般若波罗蜜。何以故阿难学般若波罗蜜。于诸学中最为第一。安乐利益诸世间故。阿难。如是学者。无依止者。为作依止。如是学者。诸佛所许诸佛所赞。诸佛如是学已。能以足指震动三千大千世界。阿难。诸佛学是般若波罗蜜。于过去未来现在一切法中。得无碍知见。阿难。是故般若波罗蜜最上最妙。阿难。若欲称量般若波罗蜜。即是称量虚空。何以故。是般若波罗蜜无量故。阿难。我不说有般若波罗蜜有限有量。阿难。名字章句语言有量。般若波罗蜜无量。世尊。何因缘故。般若波罗蜜无量。阿难。般若波罗蜜无尽故无量般若波罗蜜离故无量阿难。过去诸佛皆从般若波罗蜜出。而般若波罗蜜不尽。未来诸佛皆从般若波罗蜜出。而般若波罗蜜不尽。现在无量世界诸佛。皆从般若波罗蜜出。而般若波罗蜜不尽。是故般若波罗蜜。已不尽今不尽当不尽。阿难。若人欲尽般若波罗蜜。为欲尽虚空。尔时须菩提作是念。是事甚深我当问佛。即白佛言。世尊。般若波罗蜜无尽耶。须菩提。般若波罗蜜无尽。虚空无尽故。般若波罗蜜无尽。世尊。应云何出生般若波罗蜜。须菩提。色无尽故是生般若波罗蜜。受想行识无尽故是生般若波罗蜜。须菩提。菩萨坐道场时。如是观十二因缘。离于二边。是为菩萨不共之法。若菩萨如是观因缘法。不堕声闻辟支佛地。疾近萨婆若必得阿耨多罗三藐三菩提。须菩提。若诸菩萨有退转者。不得如是念。不知菩萨行般若波罗蜜。云何以无尽法观十二因缘。须菩提。若诸菩萨有退转者。不得如是方便之力。须菩提。若诸菩萨不退转者。皆得如是方便之力。所谓菩萨行般若波罗蜜。以如是无尽法观十二因缘。若菩萨如是观时。不见诸法无因缘生。亦不见诸法常。不见诸法作者受者。须菩提。是名菩萨行般若波罗蜜时观十二因缘法。须菩提。若菩萨行般若波罗蜜时。不见色。不见受想行识。不见此佛世界。不见彼佛世界。亦不见有法见此佛世界彼佛世界。须菩提。若有菩萨能如是行般若波罗蜜。是时恶魔忧愁如箭入心。譬如新丧父母甚大忧毒。菩萨亦如是行般若波罗蜜。恶魔甚大忧毒。世尊。但一恶魔愁毒。三千世界恶魔皆悉愁毒耶。须菩提。是诸恶魔皆悉忧毒。各于坐处不能自安。须菩提。菩萨如是行般若波罗蜜。一切世间天人阿修罗无能得便。不见有法可退者。是故须菩提。菩萨欲得阿耨多罗三藐三菩提。当如是行般若波罗蜜。菩萨如是行般若波罗蜜时。则具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜。禅波罗蜜。菩萨行般若波罗蜜时。则具足诸波罗蜜。亦能具足方便力。是菩萨行般若波罗蜜。诸有所作生便能知。是故须菩提。菩萨欲得方便力者。当学般若波罗蜜。当修般若波罗蜜须菩提。若菩萨行般若波罗蜜。生般若波罗蜜时。应念现在无量无边世界诸佛。诸佛萨婆若智。皆从般若波罗蜜生。菩萨如是念时。应如是思惟。如十方诸佛所得诸法相。我亦当得。须菩提。菩萨行般若波罗蜜应生如是念。须菩提。若菩萨能生如是念。乃至弹指顷。胜于如恒河沙劫布施福德。何况一日半日。当知是菩萨必至阿毗跋致。当知是菩萨为诸佛所念。须菩提。菩萨为诸佛所念者。不生余处。必当立于阿耨多罗三藐三菩提。是菩萨终不堕三恶道。常生好处不离诸佛。须菩提。菩萨行般若波罗蜜。生般若波罗蜜。乃至弹指顷得如是功德。何况一日若过一日。如香象菩萨。今在阿閦佛所行菩萨道。常不离般若波罗蜜行。说是法时诸比丘众一切大会天人阿修罗。皆大欢喜

    摩诃般若波罗蜜随知品第二十六

佛告须菩提。一切法无分别。当知般若波罗蜜亦如是。一切法无坏。当知般若波罗蜜亦如是。一切法但假名字。当知般若波罗蜜亦如是。一切法以言说故有。当知般若波罗蜜亦如是。又此言说。无所有无处所。当知般若波罗蜜亦如是。一切法虚假为用。当知般若波罗蜜亦如是一切法无量当知般若波罗蜜亦如是色无量。当知般若波罗蜜亦如是。受想行识无量。当知般若波罗蜜亦如是。一切法无相。当知般若波罗蜜亦如是。一切法通达相。当知般若波罗蜜亦如是。一切法本来清净。当知般若波罗蜜亦如是。一切法无言说。当知般若波罗蜜亦如是。一切法同于灭。当知般若波罗蜜亦如是。一切法如涅槃。当知般若波罗蜜亦如是。一切法不来不去无所生。当知般若波罗蜜亦如是。一切法无彼我。当知般若波罗蜜亦如是。贤圣毕竟清净。当知般若波罗蜜亦如是。舍一切担。当知般若波罗蜜亦如是。何以故。色无形无处。自性无故。受想行识无形无处。自性无故。一切法无热。当知般若波罗蜜亦如是。一切法无染无离。当知般若波罗蜜亦如是。何以故。色无所有故无染无离。受想行识无所有故无染无离。一切法性清净。当知般若波罗蜜亦如是。一切法无系着。当知般若波罗蜜亦如是。一切法是菩提觉以佛慧。当知般若波罗蜜亦如是。一切法空无相无作。当知般若波罗蜜亦如是。一切法是药慈心为首。当知般若波罗蜜亦如是。一切法梵相慈相无过无恚。当知般若波罗蜜亦如是。大海无边。当知般若波罗蜜亦如是。虚空无边。当知般若波罗蜜亦如是。日照无边。当知般若波罗蜜亦如是。色离。当知般若波罗蜜亦如是。受想行识离。当知般若波罗蜜亦如是。一切音声无边。当知般若波罗蜜亦如是。诸性无边。当知般若波罗蜜亦如是。集无量善法。当知般若波罗蜜亦如是。一切法三昧无边。当知般若波罗蜜亦如是。佛法无边。当知般若波罗蜜亦如是。法无边。当知般若波罗蜜亦如是。空无边。当知般若波罗蜜亦如是。心心数法无边。当知般若波罗蜜亦如是。诸心所行无边。当知般若波罗蜜亦如是。善法无量。当知般若波罗蜜亦如是。不善法无量。当知般若波罗蜜亦如是。如师子吼。当知般若波罗蜜亦如是。何以故。色如大海受想行识如大海。色如虚空受想行识如虚空。色如须弥山庄严。受想行识如须弥山庄严。色如日光。受想行识如日光。色如声无边。受想行识如声无边。色如众生性无边。受想行识如众生性无边。色如地受想行识如地。色如水受想行识如水。色如火受想行识如火。色如风受想行识如风。色如空种。受想行识如空种。色离集善相。受想行识离集善相。色离和合法。受想行识离和合法。色三昧故无边。受想行识三昧故无边。色色离色性色如是佛法。受想行识识离识性识如是佛法。色相无边。受想行识相无边。色空无边。受想行识空无边。色心所行故无边。受想行识心所行故无边。色中善不善不可得。受想行识中善不善不可得。色不可坏。受想行识不可坏。色是师子吼。受想行识是师子吼。当知般若波罗蜜亦如是

小品般若经卷第九小品般若波罗蜜经卷第十

        后秦龟兹国三藏鸠摩罗什译

    萨陀波仑品第二十七

佛告须菩提。若菩萨欲求般若波罗蜜。当如萨陀波仑菩萨今在雷音威王佛所行菩萨道须菩提白佛言。世尊。萨陀波仑菩萨云何求般若波罗蜜。佛告须菩提。萨陀波仑菩萨本求般若波罗蜜时。不依世事。不惜身命。不贪利养。于空林中闻空中声言。善男子。汝从是东行当得闻般若波罗蜜。行时莫念疲倦。莫念睡眠。莫念饮食。莫念昼夜。莫念寒热。如是诸事。莫念莫观亦莫思惟。离谄曲心。莫自高身卑下他人。当离一切众生之相。当离一切利养名誉。当离五盖当离悭嫉。亦莫分别内法外法。行时莫得左右顾视。莫念前莫念后。莫念上莫念下。莫念四维。莫动色受想行识。何以故。若动色受想行识。则不行佛法。行于生死。如是之人。不能得般若波罗蜜。萨陀波仑报空中声言。当如教行。何以故。我为一切众生作光明故。集诸佛法。空中声言。善哉善哉。善男子。汝应信解空无相无作法。应离诸相离于有见离众生见人见我见。求般若波罗蜜。善男子。应离恶知识亲近善知识。善知识者。能说空无相无作无生无灭法。善男子。汝能如是。不久得闻般若波罗蜜。若从经卷闻。若从法师闻。善男子。汝所从闻般若波罗蜜。当于是人生大师想。当知报恩。应作是念。我所从闻般若波罗蜜。则是我善知识。我得闻般若波罗蜜。当不退于阿耨多罗三藐三菩提。不离诸佛。不生无佛世界。得离诸难。思惟如是功德利故。于法师所生大师想。善男子。莫以世俗财利心故随逐法师。当以爱重恭敬法故随逐法师。又善男子。应觉魔事。恶魔或时为说法者作诸因缘。令受好妙色声香味触。说法者以方便力故受是五欲。汝于此中莫生不净之心。应作念言。我不知方便之力。法师或为利益众生令种善根故。受用是法。诸菩萨者无所障碍。善男子。汝于尔时应观诸法实相。何等是诸法实相。佛说一切法无垢。何以故。一切。法性空。一切法无我无众生。一切法如幻如梦如响如影如炎。善男子。汝若如是观诸法实相随逐法师。不久当善知般若波罗蜜。又善男子。复应觉知魔事。若法师于求般若波罗蜜者。心有嫌恨而不顾录。汝于此中不应忧恼。但以爱重恭敬法心。随逐法师勿生厌离。须菩提。萨陀波仑菩萨受虚空中如是教已即便东行。东行不久复作是念。我向者云何不问空中声东行远近。当从谁闻般若波罗蜜。即住不行忧愁啼哭。作是念言。我住于此。若一日二日乃至七日。不念疲极不念睡眠不念饮食不念昼夜不念寒热。要当得知我从谁闻般若波罗蜜。须菩提。譬如有人。唯有一子爱之甚重。一旦命终甚大忧恼。唯怀忧恼无有余念。须菩提。萨陀波仑亦如是。无有余念。但念我当何时得闻般若波罗蜜。须菩提。萨陀波仑菩萨如是忧愁啼哭。时佛像在前立。赞言。善哉善哉。善男子。过去诸佛本行菩萨道时。求般若波罗蜜。亦如汝今。是故善男子。汝以是勤行精进爱乐法故从是东行。去此五百由旬有城名众香。七宝合成。其城七重纵广十二由旬。皆以七宝多罗之树。周遍围绕。丰乐安静人民炽盛。街巷相当端严如画。桥津如地宽博清净。七重城上皆以阎浮檀金而为楼阁。一一楼阁七宝行树种种宝果。其诸楼阁次第皆以宝绳连绵。宝铃罗网以覆城上。风吹铃声其音和雅。如作五乐甚可爱乐。以是音声娱乐众生。其城四边流池清净冷暖调适。中有诸船七宝严饰。是诸众生宿业所致。娱乐游戏诸池水中种种莲华。青黄赤白众杂好华。香色具足遍满其上。三千大千世界所有好华悉皆具有。其城四边有五百园观。七宝庄严甚可爱乐。一一园中有五百池水。池水各各纵广十里。皆以七宝杂色庄严。诸池水中皆有青黄赤白莲花。大如车轮弥覆水上。青色青光。黄色黄光。赤色赤光。白色白光。诸池水中皆有凫雁鸳鸯异类众鸟。是诸园观池沼适无所属。皆是众生宿业果报。长夜信乐深法行般若波罗蜜。福德所致。善男子。众香城中有大高台。昙无竭菩萨宫舍在上。其宫纵广各五十里。皆以七宝校成杂色庄严其墙七重皆亦七宝。七宝行树周匝围绕。其宫舍中有四围观常所娱乐。一名常喜。二名无忧。三名华饰。四名香饰。一一园中有八池水。一名为贤。二名贤上。三名欢喜。四名喜上五名安隐。六名多安隐。七名必定。八名阿毗跋致。诸池水边面各一宝。黄金白银琉璃颇梨玫瑰为底。金沙布上。一一池侧有八梯阶。种种宝物以为梯橙诸阶陛间有阎浮檀金芭蕉之树。诸池水中。皆有青黄赤白莲花。遍覆其上。凫雁鸳鸯孔雀众鸟。鸣声相和甚可爱乐。诸池水边皆生花树香树。风吹香华堕池水中。其池成就八功德水。香若栴檀色味具足。昙无竭菩萨与六万八千婇女。五欲具足共相娱乐。及城中男女俱入常喜等园贤等池中。共相娱乐。善男子。昙无竭菩萨与诸婇女游戏娱乐已。日日三时说般若波罗蜜。众香城中男女大小。为昙无竭菩萨于其城内多聚人处。敷大法座。其座四足。或以黄金或以白银。或以琉璃或以颇梨。敷以綩綖杂色茵蓐。以迦尸白[疊*毛]而覆其上。座高五里施诸帏帐。其地四边散五色华烧众名香。供养法故。昙无竭菩萨于此座上说般若波罗蜜。善男子。彼诸人众如是供养恭敬昙无竭菩萨。为闻般若波罗蜜故。于是大会百千万众诸天世人。一处集会。中有听者中有受者中有持者。中有诵者中有书者。中有正观者中有如说行者。是诸众生已度恶道。皆不退转于阿耨多罗三藐三菩提。善男子。汝从是去。当于昙无竭菩萨所闻般若波罗蜜。昙无竭菩萨世世是汝善知识。示教利喜汝阿耨多罗三藐三菩提。善男子。昙无竭菩萨本行菩萨道时。求般若波罗蜜。亦如汝今。今汝东行莫计昼夜。不久当得闻般若波罗蜜。萨陀波仑菩萨心大欢喜。譬如有人为毒箭所中。更无余念唯念何时当得良医拔出毒箭除我此苦。如是萨陀波仑菩萨无有余念。但念何时得见昙无竭菩萨为我说般若波罗蜜。我闻般若波罗蜜断诸有见。尔时萨陀波仑即于住处一切法中。生无决定想。入诸三昧门。所谓诸法性观三昧。诸法不可得三昧。破诸法无明三昧。诸法不异三昧。诸法不坏三昧。诸法照明三昧。诸法离闇三昧。诸法不相续三昧。诸法性不可得三昧。散华三昧。不受诸身三昧。离幻三昧。如镜像三昧。一切众生语言三昧。一切众生欢喜三昧。随一切善三昧。种种语言字句庄严三昧。无畏三昧。性常默然三昧。无碍解脱三昧。离尘垢三昧。名字语言庄严三昧。一切见三昧。一切无碍际三昧。如虚空三昧。如金刚三昧无负三昧。得胜三昧。转眼三昧。毕法性三昧。得安隐三昧。师子吼三昧。胜一切众生三昧。离垢三昧。无垢净三昧。华庄严三昧。随坚实三昧。出诸法得力无畏三昧。通达诸法三昧。坏一切法印三昧。无差别见三昧。离一切见三昧。离一切闇三昧。离一切相三昧。离一切着三昧。离一切懈怠三昧。深法照明三昧。善高三昧。不可夺三昧。破魔三昧。生光明三昧。见诸佛三昧。萨陀波仑菩萨住是诸三昧中。即见十方诸佛为诸菩萨说般若波罗蜜。诸佛各各安慰赞言。善哉善哉。善男子。我等本行菩萨道时求般若波罗蜜。亦如汝今。得是诸三昧。亦如汝今。得是诸三昧已了达般若波罗蜜。住阿毗跋致地。我等得是诸三昧故。得阿耨多罗三藐三菩提。善男子。是为般若波罗蜜。所谓于诸法无所念。我等住于无念法中。得如是金色之身三十二相大光明不可思议智慧诸佛无上三昧无上智慧。尽诸功德边。如是功德诸佛说之犹不能尽。况声闻辟支佛。是故善男子。汝于是法倍应恭敬爱重生清净心。得阿耨多罗三藐三菩提。不足为难。汝于善知识。应深恭敬爱重信乐。善男子。若菩萨为善知识所护念者。疾得阿耨多罗三藐三菩提。萨陀波仑菩萨白诸佛言。何等是我善知识。诸佛答言。善男子。昙无竭菩萨世世教诲成就汝于阿耨多罗三藐三菩提。令汝得学般若波罗蜜方便之力。昙无竭菩萨是汝善知识。汝应报恩。善男子。汝若于一劫若二劫三劫。乃至百劫若过百劫顶戴恭敬以一切乐具而供养之。若以三千大千世界妙好色声香味触。尽以供养。亦未能报须臾之恩。何以故。以昙无竭菩萨因缘力故。令汝得如是诸深三昧。及闻般若波罗蜜方便。诸佛如是。教授安慰萨陀波仑菩萨已。忽然不现。萨陀波仑菩萨从三昧起不见诸佛。作是念。是诸佛向从何来今至何所。不见佛故即大忧愁。作是念。昙无竭菩萨已得陀罗尼诸神通力。已曾供养过去诸佛。世世为我善知识。常利益我。我至昙无竭菩萨所。当问诸佛从何所来去至何所。尔时萨陀波仑菩萨于昙无竭菩萨。益加爱重恭敬信乐。作如是念。我今贫穷。无有华香璎珞烧香涂香衣服幡盖金银真珠颇梨珊瑚。无有如是诸物可以供养昙无竭菩萨。我今不应空往昙无竭菩萨所。我若空往心则不安。当自卖身以求财物。为般若波罗蜜故。供养昙无竭菩萨。何以故。我世世已来丧身无数。于无始生死中。为欲因缘故。在于地狱受无量苦。未曾为是清净之法。是时萨陀波仑菩萨中道入一大城至市肆上。高声唱言。谁欲须人谁欲须人。尔时恶魔作是念。萨陀波仑菩萨为爱法故欲自卖身以供养昙无竭菩萨。为闻般若波罗蜜方便。云何菩萨行般若波罗蜜。疾得阿耨多罗三藐三菩提。亦得多闻如大海水。不为诸魔所坏。能尽一切诸功德边。于此利益无量众生。是诸众生出我境界。得阿耨多罗三藐三菩提。我今当往坏其道意。即时恶魔隐蔽诸人。乃至不令一人得闻唱声。唯一长者女魔不能蔽。萨陀波仑菩萨卖身不售。在一处立流泪而言。我为大罪故。欲自卖身供养昙无竭菩萨为闻般若波罗蜜。而无买者。尔时释提桓因作是念。我今当试是善男子实以深心为爱法故舍是身不。即化作婆罗门。在萨陀波仑菩萨边行。问言善男子。汝今何故忧愁啼哭萨陀波仑言。我以贫穷无有财宝。欲自卖身供养昙无竭菩萨为闻般若波罗蜜。而无买者。婆罗门言。善男子。我不须人。今欲大祠当须人心人血人髓。能与我不。萨陀波仑自念。我得大利。定当得闻般若波罗蜜方便。以婆罗门欲买心血髓故。即大欢喜语婆罗门。汝所须者尽当相与。婆罗门言。汝须何价。答言。随汝所与。萨陀波仑菩萨即执利刀刺右臂出血。复割右髀欲破骨出髓。时一长者女在阁上遥见萨陀波仑菩萨刺臂出血割其右髀复欲破骨出髓。作是念。此善男子何因缘故困苦其身。我当往问。时长者女即便下阁到萨陀波仑菩萨所。问言善男子。何因缘故困苦其身。用是血髓为。萨陀波仑言。卖与婆罗门。供养般若波罗蜜及昙无竭菩萨。长者女言。善男子。汝卖血髓供养是人得何等利。萨陀波仑言。是人当为我说般若波罗蜜方便力。我随中学当得阿耨多罗三藐三菩提。金色之身三十二相。常光无量光。大慈大悲大喜大舍。十力四无所畏四无碍智十八不共法。六神通不可思议清净戒品定品智慧品解脱品解脱知见品。得佛无上智慧无上法宝。分布施与一切众生。时长者女语萨陀波仑。汝所说者。甚为希有微妙第一。为一一法。乃可应舍恒河沙身。善男子。汝今所须金银真珠琉璃颇梨琥珀珊瑚诸好珍宝。及华香璎珞幡盖衣服。尽当相与供养昙无竭菩萨。莫自困苦。我今亦欲随汝至昙无竭菩萨所种诸善根。为得如是清净法故。尔时释提桓因即复其身。在萨陀波仑菩萨前立。作是言。善哉善哉。善男子汝心坚固爱法如是。过去诸佛行菩萨道时。亦如汝今。求闻般若波罗蜜方便。得阿耨多罗三藐三菩提。善男子。我实不须人心血髓。故来相试。汝愿何等当以相与。萨陀波仑言。与我阿耨多罗三藐三菩提。释提桓因言。我无此也。诸佛世尊乃能办之。更求余愿当以相与。萨陀波仑言。汝于此中若无力者。还使我身平复如故。萨陀波仑身即平复无有疮[病-丙+槃]。于是释提桓因忽然不现。时长者女语萨陀波仑菩萨言。可至我舍。当白父母求索财宝。为闻法故。供养昙无竭菩萨。萨陀波仑菩萨与长者女俱到其舍。长者女入白父母言。与我华香璎珞种种衣服及诸宝物。愿听我身并先所给五百侍女与萨陀波仑菩萨共往供养昙无竭菩萨。昙无竭菩萨当为我说法。以是法故。我等当得诸佛之法。父母语女。萨陀波仑菩萨。今在何处。女言。今在门外。是人发心求阿耨多罗三藐三菩提。欲度一切众生生死苦恼。为爱法故欲自卖身而无买者。忧愁啼哭立在一处。作是言。我欲卖身而无买者。时一婆罗门。作是言。汝今何故。欲自卖身。答言。我爱法故。欲供养昙无竭菩萨。我当从彼得诸佛法。婆罗门言。我不须人。今欲大祠。当须人心人血人髓。即时是人心大欢喜。手执利刀刺臂出血复割右髀。欲破骨出髓。我在阁上遥见此事。心自念言。是人何故困苦其身。当往问之。我即往问。答我言。我以贫穷无有财宝。欲卖心血髓与婆罗门。我时问言。善男子。持是财物欲作何等。答我言。为爱法故供养昙无竭菩萨。我复问言。善男子。汝于是中得何等利。答我言。我于是中当得无量不可思议功德之利。我闻是无量不可思议诸佛功德。心大欢喜作是念。是善男子。甚为希有。乃能自受如是苦恼。为爱法故尚能舍身。我当云何不供养法。我今多有财物。于是事中当发大愿。我时语言。善男子。汝莫如是困苦其身。我当多与财物供养昙无竭菩萨。我亦随汝至昙无竭菩萨所欲自供养。我亦欲得无上佛法。如上所说。父母今当听我随是善男子及给财物供养昙无竭菩萨。父母报言。汝所赞者希有难及。是人一心念法。一切世界胜最第一。必能安乐一切众生。是人能求难事。我今听汝随去。我等亦欲见昙无竭菩萨。是女为供养昙无竭菩萨故。白父母言。我不敢断人功德。是女即时庄严五百乘车。敕五百侍女亦皆庄严。持种种色华种种色衣种种杂香末香涂香金银宝华种种杂色妙好璎珞诸美饮食。与萨陀波仑菩萨各载一车。五百侍女恭敬围绕渐渐东行。遥见众香城。其城七重七宝庄严甚可爱乐。有七重堑七重行树。其城纵广十二由旬。丰乐安静人民炽盛。五百街巷端严如画。桥津如地宽博清净。见昙无竭菩萨。于城中央法座上坐。无量百千万众围绕说法。心即欢喜。譬如比丘得第三禅。见已作是念。我等不应载车趣昙无竭菩萨。即皆下车步进。萨陀波仑与五百侍女恭敬围绕。各持种种庄严诸物。俱诣昙无竭菩萨所。昙无竭菩萨所有七宝台牛头栴檀而以校饰。真珠罗网宝铃间错。四角各悬明珠以为光明。有四白银香炉。烧黑沉水。供养般若波罗蜜。其宝台中有七宝大床。床上有四宝函。以真金鍱书般若波罗蜜。置是函中。其台四边垂诸宝幡。尔时萨陀波仑菩萨与五百侍女。遥见妙台种种珍宝以为挍饰。又见释提桓因与无量百千诸天以天曼陀罗华天金银华天栴檀华以散台上。天于空中作诸伎乐。即问释提桓因憍尸迦。汝以何故与诸天众。以天曼陀罗华天金银华天栴檀华散此台上。于虚空中作诸伎乐。释提桓因言。善男子。汝不知耶。有法名摩诃般若波罗蜜。是诸菩萨母。菩萨于是中学。当得尽诸功德一切佛法疾得萨婆若。萨陀波仑言。憍尸迦。摩诃般若波罗蜜是诸菩萨母。为在何处。我今欲见。善男子。在此七宝箧中黄金鍱上。昙无竭菩萨七处印之。我不得示汝。尔时萨陀波仑菩萨与五百女人。各持种种华香璎珞幡盖衣服金银珍宝。以半供养般若波罗蜜。以半供养昙无竭菩萨。萨陀波仑菩萨以种种花香璎珞幡盖衣服金银宝花。作诸伎乐。供养般若波罗蜜已。向昙无竭菩萨所。复以种种华香璎珞碎末栴檀金银宝华。供养法故散昙无竭菩萨上。即住虚空合成宝盖。其盖四边垂诸宝幡。萨陀波仑菩萨及五百女人。见此神力心大欢喜。作是念。未曾有也。昙无竭大师神力乃尔。未成佛道。神通之力尚能如是。况得阿耨多罗三藐三菩提。时五百女人敬重昙无竭菩萨。故皆发阿耨多罗三藐三菩提心。我等以是善根因缘。于未来世当得作佛。行菩萨道时亦得如是功德。如今昙无竭菩萨。供养恭敬尊重般若波罗蜜。为人演说。成就方便力。亦如昙无竭菩萨。萨陀波仑及五百女人头面礼昙无竭菩萨足。合掌恭敬却住一面。萨陀波仑白昙无竭菩萨言。我本求般若波罗蜜时。于空林中闻空中声言。善男子。从是东行。当得闻般若波罗蜜。我即东行。东行不久便作是念。我云何不问空中声。去当远近从谁得闻般若波罗蜜。忧愁懊恼即住七日。不念饮食及世俗事。但念般若波罗蜜。我云何不问空中声。去当近远从谁得闻。即时佛像现在我前。作是言。善男子。从是东行五百由旬。有城名众香城。中有菩萨名昙无竭。为诸大众说般若波罗蜜。汝于是中。当得闻般若波罗蜜。我于是处一切法中。生无依止想。亦得无量诸三昧门。我住是诸三昧。即见十方诸佛为诸大众说般若波罗蜜。诸佛赞我言。善哉善哉。善男子。我等本行菩萨道时亦得是诸三昧。住是诸三昧中。能成就诸佛法。诸佛安慰示教我已。皆不复现。我从诸三昧觉已作是念。诸佛从何所来去至何所。不知诸佛来去因缘故。即作是念。昙无竭菩萨已曾供养过去诸佛。深种善根善学方便。必能为我说诸佛从何所来去至何所。惟愿大师。今当为我说诸佛从何所来去至何所。令我常得不离见佛

    摩诃般若波罗蜜昙无竭品第二十八

尔时昙无竭菩萨语萨陀波仑菩萨言。善男子。诸佛无所从来去无所至。何以故。诸法如不动故诸法如即是如来。善男子。无生无来无去无生即是如来。实际无来无去。实际即是如来。空无来无去。空即是如来。断无来无去。断即是如来。离无来无去。离即是如来。灭无来无去。灭即是如来。虚空性无来无去。虚空性即是如来。善男子。离是诸法无有如来。是诸法如诸如来如。皆是一如无二无别。善男子。是如唯一无二无三。离诸数无所有。善男子。譬如春末后月日中热时见野马动。愚夫逐之谓当得水。善男子。于意云何。是水从何所来。为从东海来。南西北海来。萨陀波仑白大师言。焰中尚无有水。况有来处去处。但是愚人无有智故。于无水中而生水想。实无有水。善男子。若有人以如来身色音声而生贪着。如是人等分别诸佛有去来相。当知是等愚痴无智。如无水中而生水想。何以故。诸佛如来不应以色身见。诸佛如来皆是法身故。善男子。诸法实相无来无去。诸佛如来亦复如是。善男子。譬如幻师幻作象兵马兵车兵步兵无来无去。当知诸佛无来无去亦复如是。善男子。如人梦中见有如来。若一若二若十若二十。若五十若百若过百数觉已乃至不见有一如来。善男子。于意云何。是诸如来从何所来去。至何所。萨陀波仑白大师言。梦无定法皆是虚妄。善男子。如来说一切法虚妄如梦。若人不知诸法虚妄如梦。以色身名字语言章句而生贪着。如是人等分别诸佛而有来去。不知诸法相故。若人于佛分别来去。当知是人凡夫无智。数受生死往来六道。离般若波罗蜜离于佛法。善男子。若能如实知佛所说一切诸法虚妄如梦。是人于法则不分别若来若去若生若灭。若不分别。是人则以诸法实相而观如来。若以法相知如来者。是人则不分别如来若来若去。若能如是知诸法相。是人则行般若波罗蜜。近阿耨多罗三藐三菩提。是名真佛弟子。不虚受人信施。是为世界福田。善男子。譬如海中种种珍宝。不从东方来。南西北方四维上下来。众生福业因缘海生此宝。非无因而有。诸宝灭时亦不至十方。以众缘合则有。众缘灭则无。善男子。诸如来身亦复如是。无有定法不从十方来。亦不无因而有。以本行报生。众缘合则有。众缘灭则无。善男子。譬如箜篌音声。无所从来去无所至。属众因缘。有弦有槽有棍。有人以手鼓之。众缘合则有声。是声不从弦出槽出棍出手出。众缘合则有声。而无所从来。众缘散则灭而无所至。善男子。诸如来身亦复如是。属众因缘。无量福德之所成就不从一因缘一福德而生。亦不无因无缘而有。以众缘合则有。而无所从来。众缘散则灭。而去无所至。善男子。应当如是观诸如来来去之相。亦应如是观诸法相。善男子。汝若如是观诸如来及一切法。无来无去。无生无灭。必至阿耨多罗三藐三菩提。亦得了达般若波罗蜜方便。说是如来无来无去法时。三千大千世界地大震动。诸天宫殿亦皆震动。诸魔宫殿皆不复现。三千大千世界草木华树。悉皆倾向昙无竭菩萨。诸树皆出非时妙华。释提桓因及四天王。于虚空中雨天名华天末栴檀。散昙无竭菩萨上。语萨陀波仑菩萨言。因仁者故。我等今日闻第一义。一切世界所难值遇。贪身见者所不能及。尔时萨陀波仑菩萨白昙无竭菩萨。何因缘故地大震动。昙无竭言。以汝向问是诸如来无来无去。我答汝时。有八千人得无生法忍。八十那由他众生发阿耨多罗三藐三菩提心。八万四千众生远尘离垢。于诸法中得法眼净。萨陀波仑菩萨心即欢喜作是念。我今则为大得善利。闻般若波罗蜜中无来无去。利益如是无量众生。我之善根已为具足。于阿耨多罗三藐三菩提。心无疑悔。必当作佛。萨陀波仑闻法生欢喜因缘。即升虚空高七多罗树。作是念。我今当以何物供养昙无竭菩萨。释提桓因知萨陀波仑心所念。即以天曼陀罗华与萨陀波仑。作是言。汝以是花供养昙无竭菩萨。善男子。我等应助成汝。以汝因缘故利益无量众生。善男子。如是之人甚难得值。能为一切众生故。于无量阿僧祇劫往来生死。尔时萨陀波仑菩萨受释提桓因曼陀罗华。散昙无竭菩萨上。从虚空下头面作礼。白大师言。我从今日以身供给奉上大师。作是语已。合掌一面立。尔时长者女及五百侍女。白萨陀波仑菩萨言。我等今者以身奉上。持是善根因缘。当得如是善法。世世常共供养诸佛常相亲近。萨陀波仑菩萨报诸女言。汝若以身与我诚心随我行者。我当受汝。诸女白言。我等诚心以身奉上当随所行。尔时萨陀波仑菩萨与五百女人并诸宝物庄严之具及五百乘车。奉上昙无竭菩萨。白言大师。以是五百女人奉给大师。五百乘车随意所用。尔时释提桓因赞萨陀波仑菩萨言。善哉善哉。菩萨摩诃萨应如是学一切舍法。菩萨有是一切舍者。则能疾得阿耨多罗三藐三菩提。诸菩萨为闻般若波罗蜜及方便故。应如汝今供养于师。过去诸佛本行菩萨道时。亦皆如汝住是舍中。为般若波罗蜜供养于师。为闻般若波罗蜜及方便故。得阿耨多罗三藐三菩提。尔时昙无竭菩萨欲令萨陀波仑菩萨善根具足故。受五百女人及五百乘车。受已还与萨陀波仑。从坐而起还入宫中。是时日没。萨陀波仑菩萨作是念。我为法来不应坐卧。当以二事。若行若立以待法师出宫说法。尔时昙无竭菩萨七岁常入菩萨无量三昧无量般若波罗蜜及方便观萨陀波仑菩萨。满七岁中若行若立离于睡眠。不念于欲不念美味。但念昙无竭菩萨何时当从禅起。我当为敷法座。昙无竭菩萨当坐说法。我当扫洒令地清净布种种华。昙无竭菩萨当说般若波罗蜜及方便时。长者女及五百女人亦皆七岁随萨陀波仑菩萨所行之事。尔时萨陀波仑菩萨闻空中声言。善男子。昙无竭菩萨却后七日从三昧起。当于城中法座上说法。萨陀波仑菩萨闻空中声心大欢喜。与五百女人欲为昙无竭菩萨敷大法座。是时诸女各脱上衣。以为法座作是念。昙无竭菩萨当坐此座说般若波罗蜜及方便。萨陀波仑菩萨欲洒法座处地。求水不得。恶魔隐蔽令水不现。作是念。萨陀波仑求水不得。或当忧悔心动变异。善根不增智慧不照。萨陀波仑求水不得。即作是念。我当刺身出血以用洒地。何以故。此中尘土坌于大师。我今何用此身。此身不久必当坏败。我宁为法以灭于身终不空死。又我常以五欲因缘。丧无数身往来生死未曾得为如是法也。萨陀波仑即以利刀周遍刺身以血洒地。五百女人亦效萨陀波仑菩萨。各各刺身以血洒地。萨陀波仑菩萨及五百女人。乃至一念无有异心。魔不能坏障其善根。尔时释提桓因作是念。未曾有也。萨陀波仑菩萨爱法坚固。发大庄严不惜身命。深心趣于阿耨多罗三藐三菩提。当得阿耨多罗三藐三菩提。度脱无量众生生死苦恼。即时释提桓因变洒地血为天赤栴檀水。法座四边面百由旬。天栴檀气流布遍满。释提桓因赞言。善哉善哉。善男子。汝精进力不可思议。爱法求法最为无上。善男子。过去诸佛亦皆如是。深心精进爱法求法。以此修集阿耨多罗三藐三菩提。尔时萨陀波仑作是念。我为昙无竭菩萨。已敷法座扫洒清净。当于何所得好名华庄严此地。昙无竭菩萨在座说法当以供养。释提桓因知萨陀波仑心所念。即以三千石天曼陀罗华。与萨陀波仑菩萨作是言。善男子。取是曼陀罗华庄严此地。供养昙无竭菩萨。萨陀波仑菩萨受此华已。以半散地以半供养昙无竭菩萨。尔时昙无竭菩萨过七日已从三昧起。与无量百千万众恭敬围绕趣法座所。坐法座上说般若波罗蜜。萨陀波仑见昙无竭菩萨心大喜乐。譬如比丘入第三禅。尔时萨陀波仑及五百女人散华供养。头面礼足却坐一面。昙无竭菩萨因萨陀波仑。为大众说言。诸法等故般若波罗蜜亦等。诸法离故般若波罗蜜亦离。诸法不动故般若波罗蜜亦不动。诸法无念故般若波罗蜜亦无念。诸法无畏故般若波罗蜜亦无畏。诸法一味故般若波罗蜜亦一味。诸法无边故般若波罗蜜亦无边。诸法无生故般若波罗蜜亦无生。诸法无灭故般若波罗蜜亦无灭。如虚空无边般若波罗蜜亦无边。如大海无边般若波罗蜜亦无边。如须弥山庄严般若波罗蜜亦庄严。如虚空无分别般若波罗蜜亦无分别。色无边故般若波罗蜜亦无边。受想行识无边故般若波罗蜜无边。地种无边故般若波罗蜜无边。水种火种风种空种无边故般若波罗蜜无边。如金刚等故般若波罗蜜亦等。诸法无坏故般若波罗蜜无坏。诸法性不可得故般若波罗蜜性不可得。诸法无等故般若波罗蜜无等。诸法无所作故般若波罗蜜无所作。诸法不可思议故般若波罗蜜不可思议。是时萨陀波仑菩萨即于坐所。得诸法等三昧。诸法离三昧。诸法不动三昧。诸法无念三昧。诸法无畏三昧。诸法一味三昧。诸法无边三昧。诸法无生三昧。诸法无灭三昧。虚空无边三昧。大海无边三昧。须弥山庄严三昧。如虚空无分别三昧。色无边三昧。受想行识无边三昧。地种无边三昧。水种火种风种空种无边三昧。如金刚等三昧。诸法不坏三昧。诸法性不可得三昧。诸法无等三昧。诸法无所作三昧。诸法不可思议三昧。得如是等六百万三昧

    摩诃般若波罗蜜嘱累品第二十九

尔时佛告须菩提。萨陀波仑菩萨得六百万三昧门已。即见十方如恒河沙等世界诸佛。与大比丘众恭敬围绕。皆以是文字章句相貌说般若波罗蜜。如我今于此三千大千世界。与诸大众恭敬围绕。以是文字章句相貌说般若波罗蜜。萨陀波仑从是已后。多闻智慧不可思议。如大海水。世世所生不离诸佛。现在诸佛常生其所。一切众难皆悉得断。须菩提。当知是般若波罗蜜因缘。能具足菩萨道。是故诸菩萨若欲得一切智慧。应当信受般若波罗蜜读诵正忆念。如说修行广为人说。亦当了了书写经卷供养恭敬尊重赞叹华香璎珞末香涂香幡盖伎乐等。则是我教

尔时佛告阿难。于意云何。佛是汝大师不。世尊。佛是我大师。如来是我大师。佛告阿难。我是汝大师。汝是我弟子。汝以身口意业。于今现在供养恭敬尊重于我。我灭度后汝当以是供养恭敬尊重般若波罗蜜第二第三亦如是说。我以般若波罗蜜嘱累于汝。慎莫忘失。莫作最后断种人也。阿难。随尔所时般若波罗蜜在世。当知尔所时有佛在世说法。阿难。若有书写般若波罗蜜受持读诵正忆念。如所说行广为人说。供养恭敬尊重赞叹华香乃至伎乐。当知是人不离见佛不离闻法常亲近佛。佛说般若波罗蜜已。弥勒等诸菩萨摩诃萨。舍利弗须菩提目揵连摩诃迦叶等诸声闻众。一切。世间天人阿修罗等。闻佛所说。欢喜信受

小品般若经卷第十


不退转法轮经卷第一

    No. 267 [Nos. 266, 268]

不退转法轮经卷第一

        僧祐录云安公凉土异经在北凉录第二译

    序品第一

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘僧千二百五十人俱。及诸菩萨摩诃萨众无量无边阿僧祇数。尔时世尊于中夜后入广大光明照三昧。是时文殊师利法王子。于中夜后入大光明照三昧。弥勒菩萨。于中夜后亦入遍炬三昧。是时世尊从三昧起。与舍利弗于中夜后共出其房。到文殊师利法王子所住之处。时尊者舍利弗。见文殊师利法王子房及世尊房左右。皆悉满中池水。其池水中亦有无量种种莲华遍布水上。而诸莲华各放光明。普照祇洹及舍卫国。乃至三千大千世界皆悉照明。大闻法音遍于十方一切世界。其中菩萨互共咨请发问论议。时尊者舍利弗既入室已。见文殊师利寂然禅定在前而立。尊者舍利弗。即便弹指謦咳出声。尔时世尊及舍利弗等。见文殊师利法王子神通变化。各见其身在大海中。是时舍利弗。在文殊师利室中不能得出。欲踊虚空亦不能去。而不自知从何处来。况复能以神通而去。是时尊者舍利弗。结加趺坐。忽然而见文殊师利在其目前正身端坐。文殊师利神通力故。不离本处令舍利弗见。文殊师利。过恒河沙有世界。名阿鞞跋致论议音声。彼中有佛。号善住光华开敷。现在于世。有无量亿千菩萨围绕。见彼佛身于诸毛孔皆出莲华。其一一华光明遍照三千大千世界。华有千叶。皆以绀琉璃为茎。马瑙为须。众宝为台。其华台上。见诸菩萨结加趺坐。彼诸菩萨。皆住阿鞞跋致当得阿耨多罗三藐三菩提。于诸陀罗尼门成就大忍。以三十二相而自庄严。身色如真金微妙第一。尔时善住光华开敷佛。脐中出大莲华。其色众多华叶无量。亦以绀琉璃为茎。金刚为叶。因陀琉璃为须。龙坚旃檀王为台。世间尘水所不能染。舍利弗。见此华台空无所有。文殊师利入中而坐。与莲华台俱上至有顶。文殊师利绕佛三匝。一心合掌顶礼佛足。于莲华台中结加趺坐正念向佛。是时善住光华开敷如来问文殊师利言。汝从何方而来到此。文殊师利白佛言。世尊。我从娑婆世界故到此土。彼佛国中有二菩萨。一名善音。二名善声。是二菩萨摩诃萨。皆已住阿鞞跋致地。决定当得阿耨多罗三藐三菩提。俱从莲华台中而出。更整衣服右膝着地。一心合掌各白佛言。世尊。娑婆世界去此几何。尔时善住光华开敷佛答二菩萨言。娑婆世界。去此佛刹恒河沙世界之外。文殊师利从彼而来。是时善音善声菩萨俱白佛言。世尊。于彼世界。佛号何等。今欲知之。尔时善住光华开敷佛。即便答言。娑婆世界。有佛如来多陀阿伽度阿罗呵三藐三佛陀。号释迦牟尼。今现在世。是二菩萨复更问言。释迦牟尼佛为说何法。彼佛答言。说三乘法。而彼菩萨复白佛言。云何名为三乘。佛言。所谓声闻乘辟支佛乘佛乘。释迦牟尼佛常作如是说三乘法。时彼菩萨复白佛言。世尊。诸佛说法何故不同。佛言。一切诸佛有所说法悉皆同等。彼诸菩萨复白佛言。云何同等。佛言。不退法轮。一切诸佛皆悉等说。时彼菩萨复白佛言。世尊。何以故。释迦牟尼佛说三乘法。佛言。娑婆世界众生心多下劣。若说一乘则不能解。是故释迦牟尼佛。以善方便为诸众生出五浊世。分别说三引导众生令入一乘。时二菩萨白佛言。世尊。释迦牟尼佛说法为最甚难。佛言。释迦牟尼佛说法实为甚难。善音善声菩萨白佛言。世尊。我等今者快得善利。不生如是下劣恶国。尔时佛答二菩萨言。莫作是语。当疾舍离。善音善声菩萨复白佛言。世尊。以何因缘令舍是语。彼恶世中说此法难。以是故。我等今者不生喜乐。佛言。于此世界二十亿那由他劫修诸善根。不如娑婆世界于一食顷。与诸般若波罗蜜相应。令一众生归依三宝受持五戒。远离声闻辟支佛心。使发无上菩提道意甚难。于彼二十亿那由他者。况复有能劝人出家赞叹功德。广为说法令出三界。作如是教逮得己利。修集善法入诸禅定。何以故。此诸众生。多为烦恼之所浊乱。是二菩萨复白佛言。世尊。云何于彼世界。诸众生等。多为烦恼而浊乱耶。佛言。若我尽寿更为汝等。说娑婆世界众生浊乱。贪欲嗔恚愚痴。无量诸恶不善诸法。犹不可尽。惟佛能知业报善恶。尔时善音善声彼菩萨等。俱共叹言。是真释迦牟尼佛。是真释师子。是真释仙。作如是等三种赞叹。善哉说法。善知心念。亦为广说诸不善法贪欲嗔恚愚痴邪见无量诸恶。巧说善趣及向声闻辟支佛道。皆归于佛。成就佛智第一清净。发菩提心。随顺解脱。入佛智慧。为诸众生。成熟善根。心无所染。彼诸菩萨。皆悉共取七宝莲华若干种色。有百千万亿叶。如金刚宝藏。天绀琉璃为须。龙坚栴檀为台。众宝为茎。不着尘水。眼识所知。其华微妙。于虚空中而自回转。不可执持。犹如影幻从业报生。亦从解脱诸三昧生。于虚空中取已。遥散娑婆世界释迦牟尼佛上。持诸华鬘华盖悉是众宝。亦有宝云宝盖及杂彩缯盖末香涂香无量种色。供养释迦牟尼佛已。五体投地向佛作礼。皆作是言。南无释迦牟尼佛。此娑婆世界菩萨摩诃萨。庄严大乘。精进无懈。修诸功德。悉能护持过去未来现在诸佛一切正法。为欲拔济苦恼众生。作大照明住于一乘。我等欲往见释迦牟尼佛。及娑婆世界诸大菩萨摩诃萨众。以大庄严而自庄严。为绍佛种使不断绝。善住光华开敷如来。闻诸菩萨作是语已。观察其心。复重为说诸佛功德。示教利喜。告诸菩萨言。汝当随学释迦牟尼佛本所行道。于一切众生发大慈心生利益心。于诸深法莫生惊怖及诸诽谤。而起无相具足善根不求果报。如是菩萨摩诃萨。皆悉当往释迦牟尼佛国。以本愿力俱生于彼。护持正法随顺诸佛本所修学。汝可往见。彼二菩萨作如是言。我当乘佛神力。及过去未来诸佛之力而诣于彼。善住光华开敷如来告善音善声菩萨等。汝今当共文殊师利诣娑婆世界。亦语文殊师利。与二菩萨俱共到彼。时二菩萨语文殊师利言。我等欲见释迦牟尼佛及诸菩萨一切大众。当依汝神力得见彼佛。文殊师利语二菩萨言。善男子。汝等应当先礼彼佛。亦应亲近供养恭敬无数诸佛。悉为利益十方世界一切众生。为欲增长佛菩提故。亦为成就佛智慧故。彼二菩萨即如其教作如是言。我等亦当随逐供养诸佛如来。亲近礼拜尊重赞叹。当学文殊师利。为欲利益一切众生。尔时文殊师利。便礼善住光华开敷如来。绕佛三匝恭敬尊重。与诸菩萨并舍利弗俱诣于彼到已听法。受佛教敕谛观如来。散华供养末香涂香缯盖幢旛清净第一。悉为过去诸佛神力之所护持。念慧坚固。悉遍供养佛法僧宝。为一切众生得解脱故。如大力士屈伸臂顷。于彼东方恒河沙佛前忽然而见。于诸佛所。即便劝请广说清净不退转法轮。是诸佛国无有女人。亦无二乘声闻辟支佛名。亦如善住光华开敷佛国等无有异。诸世界中纯大菩萨以为庄严。是诸菩萨毛孔脐中皆出莲华。莲华台中皆有菩萨。一一莲华台上皆有文殊师利。悉作如是神通变化。供养诸佛。南西北方四维上下。乃至十方世界。悉有文殊师利。说不退转法轮。皆有二菩萨。从华台中而出问佛。彼娑婆世界云何名为说三乘法。皆悉欲随文殊师利。见释迦牟尼佛。尔时文殊师利法王子。于十方世界。安慰诸菩萨等。我当共汝俱往至彼娑婆世界。到阎浮提。天将欲明。是时阿难。天既未晓。门籥孔中而见光明。即起出外。便见大光遍照祇洹。净水澄洁湛然盈满。渊明镜彻无诸尘垢。林树精舍悉皆不现。阿难见已。即作是言。今何因缘忽有是相。寻念此瑞必说大法。尔时阿难入其水中。足不沉没水不着身。心意欢喜。即往佛所绕佛住处。有十千莲华闻大音乐。见诸莲华皆出光明。其光遍照祇洹精舍。及舍卫国阎浮提内。三千大千世界。悉皆大明如昼光照。阿难踊跃发大欢喜。右膝着地恭敬合掌一心向佛。尔时明相便已显现。日欲出时见十千莲华。中有一莲华。于祇洹林最胜特出。尊者阿难发心念言。今日世尊必应说法。我当敷座以待如来。见有如是说法相故。即便为佛敷师子座。于一瞬顷刹那中间佛坐已定。尔时大地六种震动。乃至十方恒沙世界。亦复如是六返震动。三千大千世界遍布天华。拘物头华。分陀利华。优钵罗华。诸果华树自然而出。时诸比丘皆悉欲出。见其大水而心惊怖。都不敢出。见祇洹林僧房。池水悉已盈满清净无垢。一切树木及诸僧房。堂舍园苑亦皆不现。惟见光明无不遍照。诸比丘等俱作是言。今此瑞相必说大法。尔时世尊从禅定起安详而坐。十方世界一切诸佛。放大光明若干宝网。百千万亿无数种色。眼识所识不可执捉。文殊师利共十方恒河沙等诸佛世界大菩萨等。为欲利益无量众生。于一一诸佛多陀阿伽度阿罗呵三藐三佛陀。皆悉礼拜供养恭敬尊重赞叹。与如是等诸菩萨摩诃萨俱。神通变化不可思议。欲令众生使信佛法教化利益。随其所应皆得闻见。方便为说悉令解悟。尔时文殊师利知释迦牟尼佛坐已。一切大地六返震动。有诸菩萨从地踊出。一阿僧祇百阿僧祇。乃至百千万亿那由他数阿僧祇等悉来集会。俱共绕佛至百千匝。复持无数莲华若干种色。其叶无量不可思议而散佛上。能令众生一心专念发趣胜慧。所散之华遍覆三千大千世界。龙坚旃檀种种诸香。持戒忍辱精进禅定智慧方便神通波罗蜜。皆是无想助道之香。并诸旃檀众杂妙香。悉为十方诸佛神通之所护持。以用供养释迦牟尼佛。尔时文殊师利为欲供养诸如来故。与众菩萨庄严妙塔。持诸摩尼八楞宝珠。及众宝树缯盖幢幡。以杂宝网罗覆其上。亦以摩尼造作僧房。门屏户牖种种严饰。池泉流渠及诸大河。优钵罗华。拘物头华。分陀利华。众宝莲华而覆水上。八功德水亦常盈满。异类众鸟皆悉游集。诸天宝树随念皆现。救度众生使得解脱。为修佛智发菩提心。皆是文殊师利不可思议神通变化。乘佛神力及誓愿力。亦是释迦牟尼佛本行愿力。文殊师利作是变化。为欲成就调伏众生。心不思议见不思议。发大庄严入圣境界。尔时文殊师利并诸菩萨摩诃萨众。庄严一切如意华树至于佛前。是诸菩萨若欲坐时。文殊师利先现其相。于刹那顷。无相莲华从毛孔出。茎若干种无量百千杂色。其叶无数不可思议。金刚宝藏以为光网。天绀琉璃以为其须。龙坚栴檀以为其台。有诸菩萨而在其中结加趺坐。尔时释迦牟尼佛放脐中光。普照六道幽闇之处。亿千种光皆如阿提目多伽色。种种无数光明细软。如莲华藏清净香洁。周遍十方通达无碍。莲华台中出妙楼阁。佛所护持与法界等。如寂灭乐解脱之色。空无相无愿无作无为无生无灭。与三世等。悉入空界过于眼境。文殊师利。在楼阁上正身端坐。心不动摇念佛境界。自证空法得金刚三昧。善学释迦牟尼佛法。决定成就无缘三昧。深入佛慧。文殊师利并诸菩萨摩诃萨。于十方世界作佛事已。心乐正法常勤修集。亦于过去诸佛法中。久种善根。皆是文殊师利之所摄持。志行菩提心无退没。犹如师子处无畏座。佛告阿难。汝语祇洹诸比丘众。及舍卫国诸比丘尼。如来世尊。今欲说法。令舍卫国优婆塞优婆夷等。信乐三宝善根纯熟。悉皆来集一时听法。尔时尊者阿难。从其僧房及经行处。皆即告言。佛欲说法。时有比丘已来集者。复有比丘住在房中。各言已见说法光相。而我等辈不能得往。阿难复问。何故不来。诸比丘言。今见祇洹大水盈满无诸树木。惟见光明未敢便去。尔时阿难即往佛所。白言。世尊。诸比丘不能得来。何以故。见祇洹中大水悉满清净无垢。亦复不见精舍树木。以是义故皆不得来。佛告阿难。彼诸比丘。于无水中而生水想。无色中生于色想。无受想行识中生受想行识想。无声闻辟支佛作声闻辟支佛想。阿难。汝今更往唤诸比丘。从其僧房及经行处悉来听法。尔时阿难即承佛教到舍卫国。敕诸比丘并比丘尼优婆塞优婆夷等。世尊今者为欲说法。令使我唤。宜速往听。诸比丘比丘尼优婆塞优婆夷。皆悉来集至于佛前。佛告目连。汝今当从三千大千世界诸菩萨摩诃萨等发大庄严。比丘比丘尼优婆塞优婆夷。皆趣大乘。天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽人非人等。亦皆集会而来听法。所未闻者皆悉得闻。天人阿修罗皆来听法。已于过去无量诸佛宿殖善根发趣大乘。求大乘者成最胜乘。亦名清净第一之乘。菩萨摩诃萨发大庄严而自庄严。修此乘者。普告令知悉来集会。目连白佛言。唯然世尊。如壮力士屈伸臂顷。遍至三千大千世界。于诸菩萨大庄严所。诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。以佛神力及誓愿力皆悉闻知。即还佛所。白言。世尊。我悉告已。尔时四众一切云集。纵广千由旬。高五千由旬。满中天人心乐闻法。文殊师利白佛言。世尊。四众已集。是时诸天遍满虚空。皆悉合掌而白佛言。今此大众皆悉惊惧。如来威德不敢辄坐。惟愿世尊。赐听令坐。尔时如来。即现瑞相。于刹那顷。有阎浮提金莲华百千万亿叶。从地踊出。光色照耀犹如火藏。以天琉璃为须。赤真珠为台。七宝为茎。一切大众。皆各自知坐如来前。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆面向佛瞻仰世尊。尔时文殊师利菩萨最为上首。诸菩萨摩诃萨。皆以三十二相而自严身。色如真金。勇猛精进威德炽盛。尔时诸菩萨摩诃萨文殊师利等。皆从华台起合掌向佛。劝请世尊一心念佛。尔时文殊师利白佛言。世尊。四众皆集寂然已定。一切诸天遍满虚空。惟愿世尊。广说清净不退法轮。是时比丘比丘尼优婆塞优婆夷。无量百千诸天。有信行法行者并诸八辈。有须陀洹想。斯陀含想。阿那含想。阿罗汉想。声闻想。辟支佛想。佛想。各作是想。愿佛演说安慰其心。何因缘故。说信行法行乃至八辈须陀洹斯陀含阿那含阿罗汉。何以故。作如是说。世尊默然。尔时尊者舍利弗白佛言。世尊。我于夜后分天欲明时。从坐而起出其住处。即向文殊师利房。到已前入其舍。见如来室。有十千莲华周匝踊出。天鼓自鸣闻歌咏声。见祇洹林及舍卫国三千大千世界光明普照。今何因缘而现此瑞。舍利弗作是语已。佛即告言。为说法故先现斯瑞。是时文殊师利请问如来。为说何法先现此瑞。尔时阿难复白佛言。世尊。我于夜后天欲明时。于户牖中光从而入。见已即从坐起便出其房。见祇洹林满中净水无垢无浊。不见树木精舍僧房惟见大光。何因何缘先现此瑞。尔时世尊告阿难言。如来为说清净法轮。亦是文殊师利神力劝请瑞相。尔时世尊为文殊师利。即说偈言

  此乘清净　　成得佛智　　文殊妙辩
  发问斯义　　一乘无垢　　得佛上智
  文殊为显　　故作斯问　　乘无分别
  离诸戏论　　文殊为显　　故作斯问
  本无有来　　亦复无去　　犹如涅槃
  文殊所问　　实无得果　　亦无所说
  但以方便　　引导众生　　远离音声
  声即一相　　文殊为显　　故作斯问
  寻声求声　　无声可取　　声名字空
  文殊所问　　是声如风　　无所依止
  声即解脱　　文殊所问　　阿难谛听
  文殊所问　　方便菩提　　皆无所有
  佛及菩提　　有声无实　　亦无方所
  诸法皆然　　菩提无色　　因缘无生
  无有去来　　是诸佛说　　无为无相
  如空无见　　菩提无说　　文殊所问
  去来今佛　　一切皆然　　智无方所
  无闻无见　　性相如是　　显现法界
  但以假名　　开示真实　　修清净施
  持戒无缺　　忍辱坚固　　志求菩提
  精进无懈　　修禅摄意　　智慧清净
  以求菩提　　佛善方便　　度诸神通
  无依众生　　为说菩提　　分别三乘
  四果差别　　以如实智　　随应救世
  现五浊刹　　为诸下劣　　于一乘道
  惊疑不信　　故说四果　　开示罗汉
  从声闻门　　入佛教门　　说数无数
  因缘差别　　现见四谛　　证诸法相
  声闻罗汉　　缘觉辟支　　同得无生
  是为菩萨　　行空无相　　无愿三昧
  入解脱门　　安住涅槃　　去来今际
  心无所著　　能开十方　　无生无为
  如是深法　　阿难文殊　　方便发问
  无相慧力　　乘一乘道　　知法无相
  是故问佛　　今说诸果　　三世平等
  知空无相　　诸声寂灭　　无佛菩提
  无数恒沙　　诸佛世界　　来求菩提
  文殊召集　　闻彼诸佛　　菩萨所行
  欲说三乘　　集娑婆界　　文殊发问
  为决疑惑　　乘果分别　　请说菩提
  以佛神力　　及誓愿力　　故说三乘
  度苦众生　　令勤修习　　文殊声辩
  愿救世说　　菩萨所行　　亿千诸天
  供养救世　　生果想者　　安慰彼疑
  如是比丘　　及比丘尼　　清信男女
  作最胜相　　文殊所问　　为慰疑惑
  是诸菩萨　　为法故来

    不退转法轮经信行品第二

尔时世尊说是偈已。阿难白佛言。如来今为文殊师利转不退法轮作如是问。佛言。如是如是。阿难复白佛言。世尊。如来今转不退法轮耶。佛言。如是如是。阿难。如来实转不退转法轮。阿难复白佛言。如来云何方便。说于信行法行如是八辈。须陀洹斯陀含阿那含。阿罗汉。声闻。辟支佛。是诸人等。如来皆为显示菩萨法耶。何故复言。为下劣众生出五浊世。不解大乘。如来自在成就方便。见诸众生大心者少多怀下劣。是故世尊。知其根性开示佛法方便济度。以无量善法教化众生。令灭诸苦得尽生死。离诸衰恼令住正证无为涅槃。乃至使得一切种智。尔时世尊告阿难言。菩萨摩诃萨。为无量无边众生。令生信解佛之知见。及无数诸佛所知之法。无色乃至受想行识。无染无著是名信行。复次阿难。菩萨摩诃萨能信如来一切法空作如是解。亦复名为菩萨信行。菩萨摩诃萨信佛智慧心生欣乐。云何智慧。都不见法。以不见故名为信行。复次阿难。菩萨摩诃萨不染五欲不舍信心。是名菩萨信行。菩萨摩诃萨复作是念。以不思议法施诸众生犹如如相。能信如是不思议法施者。是名菩萨信行。菩萨摩诃萨以欢喜故。能舍己身而不厌足。于一切处不生嫉恚。所作之施皆悉回向。作是回向已而亦不取菩提之想。以不坏故。是名菩萨信行。复次阿难。菩萨摩诃萨以清净信正念向佛。心无垢秽亦信无垢。诸法平等。无有众生寿命我人。无阴界入。亦自不着寿命处所。是名信行解脱。教化众生令信佛法。以调伏心回向菩提。亦不见心相。能知六界阴入平等悉同法界。以无分别故。则知法界无有异相。是名信施。一切无常。一切行苦。一切行空。一切行无我。于是法中得智慧力。信施信圣戒不戏论戒。得禅定力信寂灭界。是名信施菩萨。虽教化众生常信寂灭。然不取于众生之相。观诸众生同于寂灭。善知一切众生无相。悉同法界非见非不见。何以故。法界即是一切众生心界。是名菩萨摩诃萨信行。复次阿难。菩萨摩诃萨。观一切众生无有真实。无住无灭性相本空。是故不见一切众生无依止处。观一切众生同涅槃界。何以故。一切众生悉入空界。菩萨能令如是无量众生皆生信解。是名菩萨摩诃萨信行。尔时世尊。欲重宣此义。而说偈言

  多信众生　　见无数佛　　不着色相
  是名信行　　信一切法　　开示空相
  成就解脱　　是名信行　　常信正法
  欣乐求佛　　何时当得　　不思议智
  观察五欲　　无可信者　　逮得信力
  是名信行　　如是之信　　最为善哉
  当修法施　　供养大仙　　不思议施
  故得信辩　　无下劣想　　是名信行
  悉舍一切　　所爱之身　　而无舍想
  是名信行　　能施一切　　不怀嫉妒
  舍菩提想　　是名信行　　信心清净
  无诸浊秽　　亦无寿命　　是名信行
  虽修行施　　不求果报　　得深信力
  是名信行　　弃舍六入　　不念果报
  善解六界　　是名信行　　己自调伏
  亦调伏他　　令信佛法　　是名信行
  得是信已　　回向菩提　　而无心相
  是名信行　　知于六界　　悉同法界
  虽说法界　　不得界相　　诸行无常
  苦空非我　　亦不取着　　是名信行
  能信圣戒　　无诸戏论　　成就禅定
  是名信行　　信诸众生　　同寂灭相
  知无相已　　是名信行　　不着众生
  同入法界　　是众生界　　即不思议
  以信生信　　是名为信　　菩萨无畏
  是名信行　　众生决定　　无所有想
  体性如空　　无处无证　　众生涅槃
  是二俱空　　于彼生信　　是名信行
  菩萨无畏　　信诸众生　　不取名字
  从信而生　　能如是信　　常念不失
  阿难忆持　　显示分别　　如是诸法
  无量无数　　佛所证觉　　菩萨显现

复次阿难。如来多陀阿伽度。如是深义具足信力则为广说。是名菩萨摩诃萨信行。尔时世尊。见诸众生信力坚固。复重颂曰

  一切闻者　　心皆欢喜　　是诸佛子
  所说功德　　菩萨显现　　不可思议
  诸佛菩提　　不信者信　　不染假名
  亦无心数　　不着十方　　名最胜信
  菩萨显说　　常修信法　　不取于空
  显示寂灭　　救世所说　　如是解脱
  色相亦然　　如说修行　　菩萨显说
  智者能信　　佛不思议　　无量忆念
  菩萨所信　　虚空无边　　佛智无量
  号名丈夫　　志求无著　　不为贪欲
  造作不善　　而舍乐法　　是名菩萨
  能行法施　　菩萨之信　　善誓所印
  法施不思议　　信施而饮食
  摩尼金象马　　车乘奴婢等
  妻子诸男女　　舍所有国土
  手足支节等　　头目及髓脑
  眼耳与鼻口　　菩萨之胜信
  舍身无染着　　亦不念行施
  我本修法施　　以求于佛智
  舍身无染着　　一切施欢喜
  恒与善知识　　弃舍危脆身
  于诸众生中　　信心常清净
  闻法信诸佛　　是名为菩萨
  知眼耳鼻舌　　身根皆无常
  不坚如聚沫　　深信而舍身
  为无依众生　　建立于四摄
  慈心于一切　　信佛无量智
  见造恶众生　　为发无上心
  深信于菩提　　不取诸心相
  众生不求道　　愚惑于六界
  谓一切真实　　无界说界相
  见流转众生　　愚痴着诸边
  菩萨信我无　　诸行皆无常
  见诸破戒者　　信戒不思议
  净戒立禅定　　菩萨住摄心
  若见懈怠者　　求佛精进力
  调伏诸三昧　　总持正法智
  愚痴着寿命　　观阴无寿者
  众生性寂灭　　诸法相亦然
  信阴无来去　　善恶业不断
  因净不净业　　不离于生死
  众生同法界　　法界即生死
  是名不思议　　菩萨无畏信
  胜信不思议　　精勤修法智
  不为于少智　　名为净信说
  同信诸众生　　常住无所有
  于空无有着　　一切法不住
  众生空亦空　　同于涅槃界
  说法常无相　　令众生信解
  一切法性空　　平等观众生
  三有中胜智　　得如是信持
  亦名最上信　　好乐无畏法
  佛法中智人　　自信劝他信
  如是展转教　　增长诸功德
  净心无染着　　利益之福田
  欣乐调伏施　　净戒及忍辱
  精进禅定等　　智慧为开导
  方便现净智　　令众得胜乐
  命终离恶趣　　菩萨智最胜
  神通化众生　　世界六种动
  光明悉普照　　菩萨之妙智
  无相师子吼　　东西南北等
  四维及上下　　皆出于法音
  誓于佛不疑　　教他亦令然
  以是因缘故　　显现无量相
  住于此智者　　惟佛能证智

不退转法轮经卷第一癸卯岁高丽国大藏都监奉敕雕造不退转法轮经卷第二

        僧祐录云安公凉土异经在北凉录第二译

    信行品之余

阿难。是名如来多陀阿伽度阿罗呵三藐三佛陀为诸菩萨如是方便演说信行

阿难言。云何如来复为诸菩萨说于法行。佛语阿难。汝今当知。菩萨摩诃萨不住佛法而能显示不离法界究竟不思议界。受持诸法心无下劣。虽说诸法。而于法相无所取着。无念无住。总持诸法如实相性。不取于法不舍非法。非乐于法非不乐法。虽能如是而离诸法相。以善调伏心常安乐。善说诸法而无扰乱。于诸法相不离于身亦不住身。是身前际等法界。如虚空无来无去。同真际如如相。是佛所说菩萨证知清净无垢。观一切法空无见无取。何以故。无故离故不着故不见诸法。无所执持无有诤论。显现法界无言无说。体性本空心行处灭。是心不可得。亦不可思议。但示寂灭无缘境界。护持诸法。无所依止。何以故。一切法无体无相故。是菩萨法一相无相。不可称誉无果说法。若为他说法相名字一切章句。皆已自证。成就此法名为种性菩萨摩诃萨。得是种性已。于诸法中。无来无去。无取无舍。持一切法。无动无坏。以不坏故。是名法行。成就法故。便见一切诸法无相。得法利故。亦名法行。尔时世尊。而说偈言

  法无退转　　诸佛亦尔　　若能持者
  是名法行　　显示佛法　　无形无相
  甚深无染　　是名法行　　不离诸界
  即不思议　　到于法界　　是名法行
  护持诸智　　如佛显示　　心无瑕秽
  是名法行　　转不退轮　　名为无相
  而不取着　　是名法行　　无取无住
  受持法智　　如是持者　　是名法行
  心常好乐　　求法无厌　　远离懈怠
  是名法行　　闻法受持　　无漏无依
  善住安乐　　是名法行　　若说法者
  不念不着　　无相受持　　是名法行
  善身善住　　住无处所　　是身非身
  名知身相　　无前后际　　等于法性
  无去无来　　名知身相　　亦如诸佛
  显示菩萨　　得是法已　　是名法行
  空界性相　　一切无著　　能如是持
  是名法行　　又于诸法　　空无所见
  若无所见　　则无障碍　　显示无相
  无有诤论　　无言无说　　亦无所有
  离诸心相　　而无所得　　若心无得
  名不思议　　无来无去　　非不显现
  无缘无说　　名不思议　　若持是法
  不可依止　　名无所有　　是名持法
  如是法者　　菩萨所说　　无合无散
  显示无作　　名为行处　　是种性处
  得如是利　　名为行处　　从是种性
  无可讥呵　　得如是界　　是名持法
  见法无减　　虽行无去　　来而不来
  不见有法　　若来若去　　诸法亦尔
  如是持法　　亦无动摇　　不增不减
  是无作法　　若无增减　　是名持法
  法相如如　　无缘无说　　得此法者
  是名持法　　是故阿难　　显示菩萨
  得深法利　　是名持法　　是故阿难
  显示持法　　为不信者　　而说是法
  如是分别　　为菩萨说　　皆以方便
  开示佛法

如是阿难。如来正觉。为诸菩萨摩诃萨说斯方便显示持法

佛告阿难。云何如来。为诸菩萨摩诃萨说八正道法。云何菩萨摩诃萨。离于八邪向八解脱。出过凡夫。修八正道。而无到处。远离诸边。住于中道。越凡夫地。安住菩提。亦不住菩提相。离诸邪见。修于正见。不取身相。亦复不住菩提之相。佛身无为。离于诸数。修佛相者。则得众生一相无相。出离众生生死阴界。安住无为毕竟空舍。见一切法无生无住。何以故。诸法性相皆无住故。远离世间及出世间。住寂灭处。不染世间。不着出世间。若法非法。有为无为。皆悉远离。舍于断常。住平等相。知过去未来现在心数无有异相。亦不得菩提心相。何以故。一切诸心皆平等故。身相亦尔。是故不为毒火刀箭之所伤害。何以故。已离一切烦恼毒故。常生净国离诸恶趣。虽住诸趣而证菩提。常住安隐亦无依止。以如是义。一切刀兵不能加害。何以故。见寂灭菩提空无住处。以无住故一切毒箭皆不能害。是名无缚。乘于疾乘亦不住乘。是名无缚。何以故。无所得故。是故刀箭不害其身。知诸法空求不可得。一切毒害所不能侵。何以故。行普之慈遍覆一切故。行菩提慈不得诸众生故。行空之慈诸法寂灭故。行无热慈远离诸烦恼故。行如是慈能令刀兵皆不害身。欲色无色界亦悉平等。知一切界一切法性同于菩提等无异相。若能如是心无思虑。亦无调戏寂灭清净。菩萨摩诃萨。知一切法如呼声响。离一切相。尽同法界。无归无趣。善解一切音声语言。无示无说离音声相。不自高己离于我想。过于一切言说音声而无过相。是故悉知一切法寂灭。亦不得一切法相。出过诸法心无所归。于诸言音亦不染着。尔时世尊。而说偈言

  离于八邪　　而修八正　　九次八解
  是名八辈　　出过凡夫　　不住菩提
  法中之雄　　是名八辈　　出过凡夫
  不住菩提　　离菩提相　　是名八辈
  舍诸邪见　　修行正见　　既到道已
  是名八辈　　过诸身相　　不住菩提
  离证佛身　　是名八辈　　离众生想
  常修佛想　　度禅定想　　是名八辈
  离众生窟　　入涅槃城　　诸法无住
  是名八辈　　出于世间　　开示圣道
  会寂灭界　　是名八辈　　离诸世间
  说佛法相　　心无所证　　是名八辈
  无有有际　　亦无无际　　远离有无
  是名八辈　　寂灭无为　　舍于断常
  深入平等　　是名八辈　　不取过去
  及未来心　　现在亦尔　　是名八辈
  说有初心　　而发菩提　　心相自空
  何名菩提　　无到无出　　亦无菩提
  毒火刀箭　　所不能害　　断于诸趣
  永离依止　　无来无去　　而无所害
  无向菩提　　显说音声　　自证如实
  不由他教　　不得是趣　　及诸非趣
  声念念灭　　大乘速显　　常说安隐
  第一空法　　若能速证　　是名无缚
  疾乘是法　　菩萨所记　　心无弃舍
  是名无缚　　刀兵恶趣　　所不侵逼
  身得无畏　　毒不能害　　菩萨行慈
  普遍一切　　离于诤讼　　是名无缚
  不取身相　　善分别身　　到菩提道
  弃舍恶趣　　除其愚痴　　神通自在
  得明菩提　　是名八辈　　知欲色界
  及与无色　　三界同相　　是名八辈
  诸界平等　　离恼菩提　　妄想无智
  所不能染　　出一切相　　无所讥嫌
  若有所说　　皆趣法界　　说无所趣
  同于法界　　心住法忍　　是名八辈
  若欲修行　　住寂灭法　　不自称己
  而为他说　　出过声相　　度无声相
  不着音声　　是名八辈　　因声解脱
  知法无相　　亦无住处　　无趣无出
  阿难当知　　如是八辈　　于诸说中
  最为第一

尔时世尊告阿难言。汝今当知。如来等正觉为诸菩萨摩诃萨方便说示如是八辈

阿难言。云何如来世尊。为诸菩萨摩诃萨说须陀洹。佛言。须陀洹者。所为得入圣道流。名不思议佛法。若菩萨摩诃萨。能如是修不见道及所修道。度一切相。流注佛法非色非生。于一切法无著。一切法无处。一切法无缘。一切法无住。一切法无所有。一切法不成就。菩萨摩诃萨。若到是道得坚精进坚势力坚智坚慧不生懈怠。安住寂灭乘如实道。救护众生最胜无上。不取是道亦复不住。修如是道求一切法。而无所得不没不动。无住想无道想无世间想无佛想。悉皆平等无诸盖障。智行境界无所挂碍。于一切法及诸邪见住平等相。开佛知见示深法门。分别身见出过我想。是名须陀洹。不取佛道究竟无碍。乐求佛道不著有戒。亦不取佛戒。非戒取戒。非取相戒。三结已离不住三界。如佛所学修行圣道。离一切想不取于缘。无诸障碍入于佛道。心得寂灭。不着寿命我人等见。诸根清净。远离烦恼。为修菩提而行于施。悉舍一切。救苦众生。使度四流令立涅槃。尽诸有相显示无相。若见四众不生怖畏。志求寂灭净菩提道。已离怖畏无有死畏。何以故。现证寂灭离诸尘垢。善住佛道知去来趣亦无去来。而善分别众生之想。心无戏论究竟佛道。是名菩萨摩诃萨须陀洹相

    不退转法轮经声闻辟支佛品第三

尔时世尊。即说偈言

  说于四道　　佛难思议　　若有住者
  不退菩提　　犹如虚空　　无所依止
  无住无缘　　离于取着　　是名为道
  得坚固意　　乘如是乘　　无上救世
  不住彼此　　不处中流　　不着佛道
  名须陀洹　　一切世间　　及佛余法
  究竟彼岸　　名须陀洹　　灭诸盖障
  显示佛道　　尽一切相　　名须陀洹
  不高己身　　而起佛法　　开示知见
  入于佛慧　　先起我想　　颠倒众恶
  如是知已　　不着佛道　　本疑于佛
  为得不得　　究竟无著　　不取道想
  不起戒取　　善住佛戒　　常修正勤
  不取戒想　　断于三结　　不着三界
  行于佛道　　知众生想　　虽修菩提
  而不取想　　心行寂灭　　清净佛道
  欢喜布施　　远离颦蹙　　住于正命
  心无戏论　　悉舍一切　　济苦众生
  得无上施　　名须陀洹　　断数数生
  无相无著　　远离恐怖　　出世间畏
  法及非法　　一切皆舍　　不着诸阴
  名世间明　　安处四众　　而无所畏
  显示寂灭　　净修佛法　　无众生想
  亦非实想　　是名无染　　分别怖畏
  离一切畏　　亦无死畏　　处于寂灭
  离垢安隐　　已过恶趣　　是故不畏
  善说诸道　　无漏无相　　菩萨之法
  示须陀洹　　为诸下劣　　故作是说
  以巧方便　　显示佛法　　为放逸者
  故显此法　　救世世尊　　多方便说
  随其本行　　而示佛道　　阿难当知
  是须陀洹　　为小智者　　说如是事
  不解方便　　愚痴狭劣　　不识甚深
  而生诤论　　以百千法　　示须陀洹
  须陀洹者　　显菩提法

如是阿难。如来等正觉。为诸菩萨摩诃萨以善方便说须陀洹

阿难言。云何名如来等正觉为菩萨摩诃萨说斯陀含。阿难当知。菩萨摩诃萨。随顺于智。佛智不可思议。修无量因。亦不取因相及菩提智。能断一切惑而求佛智慧。赞叹金刚三昧出过一切诸禅定上。灭一切结烦恼暗障。悉见于佛。得一切佛法平等正观。以无量因求无所得。如佛证法不动众生。亦不动于众生之界而取法界。无量众生。于旷劫中多所乏少。不能成就菩提之道。引诸众生到不退转。志求于佛。根力觉道禅定解脱名无色定。我今当以如是等法。开示众生令得解悟而求佛道。欲坐道场求如实智。通达佛眼不思议眼。为欲利益一切众生求于佛眼。如是智慧为最为上。悉知诸法甚深之相。而自于智无所分别。安立众生住于诸法中。使知一切法不住。为得是法而来集会。名斯陀含。来已见众生界及不思议界通达无碍。不取境界亦无得无到。云何当有成就众生。不见成就众生故。于一切法及众生界。非见非不见。而知众生。流注法界。明了法界。同于菩提。解于法界。及众生界。无量佛道。无得无分别。同于道智。近无等智。离垢清净。得无所得。证无所证。是名真智。菩萨摩诃萨求如是智名斯陀含。尔时世尊。而说偈言

  随顺此智者　　是名不思议
  为求佛慧故　　故名斯陀含
  无量因缘说　　成就菩提道
  修行是法故　　我常往来求
  不动三昧相　　灭除烦恼结
  是故专修习　　成就而不退
  亦知法非法　　通达无碍相
  住诸法实际　　修于斯陀含
  随顺佛所说　　如闻而修行
  为得此法故　　我常往来求
  法界未曾有　　不动于众生
  是名斯陀含　　寂灭去来相
  众生无智慧　　愚痴甚苦恼
  为欲安立故　　而求佛智慧
  根力觉道等　　禅定及解脱
  勤修三昧相　　而求佛智慧
  究竟菩提道　　诸佛之所行
  是名斯陀含　　发行而常求
  若得如是法　　佛眼难思议
  是名斯陀含　　恒求于佛眼
  如佛所应求　　为救护依止
  我今所求者　　一切智最上
  是智之所知　　诸法相真实
  于智无染着　　是智为最上
  是智之所知　　诸法相真实
  心常无所染　　恒求如是法
  利安诸众生　　一切智中上
  是名斯陀含　　往来之所求
  谛观于法界　　众生不思议
  是名斯陀含　　为求众生界
  知众生界已　　不着于众生
  是名斯陀含　　而求无所得
  若不得众生　　一切法无相
  能作如是知　　开导诸众生
  虽观一切法　　不见观察相
  执心无乱意　　而求诸佛法
  如是清净智　　远离一切垢
  不得是智相　　是名为求道
  开示诸众生　　菩萨所不讥
  是名究竟智　　为得彼故来
  阿难汝当知　　为说斯陀含
  少智诸众生　　妄相着是非
  阿难汝当知　　为说斯陀含
  使精勤众生　　令作如是解
  常善修多闻　　决定甚深法
  逮得真实义　　速成于菩提

阿难。是名如来等正觉为诸菩萨摩诃萨方便说斯陀含。阿难言。云何名如来等正觉为诸菩萨摩诃萨说阿那含。佛告阿难。菩萨摩诃萨出过一切世间之相。究竟佛行心无行处。虽知去来。而常不取去来之相。知一切法无依住亦不来还。何以故。不见诸法有去无去。出过凡夫除凡夫想。不着佛想逮无住法。何以故。究竟一切寂灭法界。亦不得佛与凡夫差别之相。远离恶道除其贪欲。不着众味离于四食。开示知见。不取一切六十二见。不见有相。不着无相。悉离有无。于诸盖障作涅槃相。无转无不转除恶道垢。摧伏众魔远离愚痴。拔无明箭竭无明种。害无明怨照除贪嗔。断诸结使开示诸有。拔爱欲箭除诸憍慢。晓了阴相究竟明处。常乐佛乘不思议乘。到于一切诸法实相。菩萨摩诃萨若能如是出于淤泥。离于系着得本愿藏。亦得过去未来诸佛之藏。悉于一切伏藏中上。亦为过去诸佛之所建立。而心平等不高不下。得如是乘。于诸众生。为最为胜第一无上。菩萨摩诃萨究竟佛乘。于一切法悉得无相。菩萨摩诃萨于诸法中断于疑网证不还果。复次阿难。菩萨摩诃萨以四弘誓摄取一切众生。安立一切众生。悉入佛乘住菩提道。云何安住菩提。所谓众生相。如实觉悟住众生界。何以故。善知空界不思议界离众生想。何以故。是贤圣界即众生界。不思议界即是空相。亦无众生离诸结使。犹如虚空无形相。实无所有。无染无著。知一切众生。悉皆平等不出不没。究竟菩提离众生相。犹如空界无所觉了。何以故。无法可得。如是无得。即是一切法相及众生相。心所觉了即非觉了。何以故。无法可得。如是无得即是无证。是故名为得阿那含。一切众生。一切诸法。佛法僧等。出如是相。名阿那含。尔时世尊。即说偈言

  不复还来　　灭凡夫法　　舍世间行
  名阿那含　　知无去来　　无住无依
  无有处所　　是故不来　　舍于凡夫
  为佛救护　　更不复来　　名阿那含
  法无有去　　亦无来相　　无来无去
  名阿那含　　断诸贪欲　　不着四食
  不退道场　　名阿那含　　除灭一切
  六十二见　　而无所去　　名阿那含
  离一切有　　心无常相　　解了如实
  是故不来　　涅槃寂灭　　离诸烦恼
  灭去来相　　是故不来　　断诸恶趣
  离一切垢　　证于涅槃　　是故不来
  摧伏怨敌　　诸魔军将　　超出假名
  是故不来　　拔无明箭　　害一切爱
  弃舍喜欲　　是故不来　　灭诸结使
  开示阴相　　得决定智　　名阿那含
  拔忧恼刺　　破憍慢山　　善解五阴
  名阿那含　　究竟照明　　庄严佛乘
  出欲淤泥　　名阿那含　　悉知伏藏
  诸伏藏上　　佛所安置　　是故不来
  安住最胜　　佛乘无上　　断除诸结
  名阿那含　　以四弘誓　　建立菩提
  住菩提已　　是故不来　　知诸空界
  难可思议　　除灭诸想　　是故不来
  于诸众生　　及法界相　　而无所得
  是故不来　　心无所取　　不随于相
  安住菩提　　名阿那含　　众生界空
  不可思议　　知如是法　　是故不来
  如是阿难　　显示那含　　诸无碍相
  安立佛法

阿难当知。如来等正觉。为诸菩萨摩诃萨。随宜方便说阿那含。佛告阿难。我今复说菩萨摩诃萨阿罗汉。灭一切行。修佛所行。舍诸有为。而能成熟一切众生。亦断一切众生苦恼。是名阿罗汉。不得众生相。亦不得苦恼相。是名阿罗汉。灭诸取着。住于无相。知诸法空。离一切相。悉无所有。除诸众生一切妄想颠倒痴惑。了达空法不可思议。是阿罗汉得不思议菩提。成就如是法故名阿罗汉。如过去诸佛所应说法。未来现在一切诸佛亦如是说。无有戏论具足清白。演说真实菩提之法名阿罗汉。安立众生住菩提道。无所取著名阿罗汉。应行诸波罗蜜慈。得佛大慈满足众生。无相之慈亦能安立一切众生。如是修慈无所分别。不取众生及以慈相名阿罗汉。为一切众生说法。而于诸法都无所取。若能如是名阿罗汉。分别显示根力觉道。于诸众生无染无著名阿罗汉。善知一切众生心行。发起菩提。能如是者名阿罗汉。演说一切有为诸行。而不取著名阿罗汉。亦为诸余一切众生。说无著行无取行。作如是说名阿罗汉。游诸佛国心无去相悉到佛所。以无相智如佛而见名阿罗汉。若能如是成就佛国具足诸功德。亦名不思议平等无垢清净福田。空行福田。阿鞞跋致福田。第一清净无女人相福田。离诸结使贪欲福田。如佛证知能尽一切盖障福田。摧伏诸魔尘劳福田。悉制外道邪见福田。一切福田。庄严福田。离于一切怖畏福田。无诤福田。寂灭福田。神通福田。最胜福田。无窟宅福田。无尽福田。具足菩萨所行福田。得佛自在最上福田。佛所护持福田。变化福田。以是法印印诸众生令得安隐巧说福田。一切璎珞庄严佛界决定涅槃寂灭福田。亦于一切福田中。成就如是福田。能知一切法不生不灭。名阿罗汉。除诸染着。见来嗔者而心不恼。名阿罗汉。于一切法不取其相。名阿罗汉。灭除习智修最上智。而能速证名阿罗汉。以是威仪建立菩提。菩提势力名阿罗汉。如是菩提亦名不思议。不思议者亦名不动。如是不动。能令无数亿种众生。安立菩提。无所取着。皆住平等。同于坏相。无所有相。知一切法。皆入菩提。住无所住阿罗汉。如是知已。能为众生说如斯法而不染着。虽有言说亦无说相。度诸众生。亦复不取诸众生想。断常二边于身不动。不断烦恼而离憍慢。于一切法无生寂灭无行。不坏色相不坏受想行识诸凡夫法相。而心不动。以求解脱安住佛法。亦非安住须陀洹果相解脱。斯陀含阿那含阿罗汉果相解脱。妄见一切起诸颠倒取佛智慧解脱。妄见取菩提心解脱。妄见修菩提施解脱。妄见修菩提戒解脱。妄见恼害忍辱解脱。妄见懈怠精进解脱。妄见乱想禅定解脱。妄见愚痴智慧解脱。妄见声闻凡夫解脱。妄见父母妻子男女眷属。如是等一切解脱。妄见贪嗜诸欲无量苦恼。而生亲爱起于染着。是结使法是恼害处。于此法中生二种相。为除妄想度脱众生。名阿罗汉。为除利养贪求妄想及在家出家想。于诸鄙贱及最胜法皆悉平等。而亦不见此凡夫法彼是佛法。为断如是妄想颠倒说解脱法。若欲严净佛国教化成就如是众生。是名涅槃。如是众生不名涅槃。如是众生生于诸有。如是众生不生诸有。如是众生行于菩提。如是众生不行菩提。如是众生毁破禁戒。如是众生受持禁戒。如是众生名有智慧。如是众生名无智慧。若有众生。起于二心而生妄想。为除如是众生妄想。非福田非不福田。如是众生勤行精进。如是众生不勤精进。是愚痴法。是智人法。是女人法。是男子法。是圣法。是非圣法。起于二想。为除如是二心妄想故。菩萨住于不退菩提亦非不退菩提。有受菩提记亦非受菩提记。有近菩提座非近菩提座。有如是二心起虚妄想。如是菩提逮得菩提。菩萨不得菩提真实解脱。以要言之。着一切法皆是妄想。是故阿难。阿罗汉为断一切众生妄想。使得解脱故能如是说无相法。是名菩萨摩诃萨阿罗汉。尔时世尊。而说偈言

  除一切行　　离生死行　　出于世间
  名阿罗汉　　灭烦恼结　　度脱一切
  诸苦众生　　名阿罗汉　　不得众生
  及诸结使　　于法无利　　名阿罗汉
  灭除妄想　　住无妄想　　知诸法空
  名阿罗汉　　知空最胜　　而得无相
  尽一切相　　名阿罗汉　　灭诸众生
  一切恶相　　弃一切相　　名阿罗汉
  除诸边际　　得无想法　　而自证知
  名阿罗汉　　为得菩提　　难可思议
  发胜精进　　名阿罗汉　　若说于法
  无毁无浊　　安立菩提　　名阿罗汉
  为净福田　　令众得乐　　不得众生
  名阿罗汉　　若说诸法　　一切无取
  无法非法　　名阿罗汉　　觉道根力
  为众显示　　得第一果　　名阿罗汉
  善知众生　　净于菩提　　为说是相
  名阿罗汉　　世间所说　　一切诸行
  于行无著　　名阿罗汉　　勇猛世尊
  难思福田　　随佛住处　　为人演说
  若欲见佛　　无见不见　　如佛所见
  名阿罗汉　　是应福田　　圣贤福田
  无上精进　　名阿罗汉　　远离染欲
  于嗔不嗔　　亦说菩提　　名阿罗汉
  知一切法　　寂灭无相　　是故菩提
  名阿罗汉　　不动一相　　诸众生界
  令无数亿　　安住菩提　　众生菩提
  悉住无相　　知彼平等　　名阿罗汉
  得无等等　　同一切法　　而知无相
  平等菩提　　能如是解　　说名罗汉
  知如实法　　清净无浊　　为众说法
  而无所说　　度无量众　　亦无动摇
  不得众生　　断常诸边　　而众皆见
  度脱苦恼　　究竟诸法　　无生无灭
  而已方便　　度脱众生　　不坏于色
  受想行识　　亦复如是　　即名解脱
  于诸凡夫　　而无动相　　建立佛法
  安住解脱　　能令众生　　不念果报
  佛解脱相　　为人说法　　妄取菩提
  修行布施　　持戒忍辱　　为除妄想
  懈怠懒惰　　取相精进　　除解脱相
  罗汉所说　　生禅定想　　愚无智慧
  为令解脱　　说阿罗汉　　此无相法
  能除虚妄　　如是说法　　名阿罗汉
  众生虚妄　　取声闻想　　无解脱相
  罗汉说法　　父母妻子　　愚痴取着
  则非菩提　　染着生死　　兄弟姊妹
  妄生亲爱　　寂灭解脱　　名阿罗汉
  造诸行业　　贪着亲爱　　见即生恋
  本是我亲　　更相染着　　互共亲爱
  不识离别　　令魔自在　　不离世间
  为最极恶　　如是过患　　罗汉所说
  于诸结使　　皆悉觉悟　　二俱虚妄
  罗汉所说　　为利多人　　行无戏论
  如是解脱　　罗汉所说　　在家出家
  多生妄想　　凡愚取着　　罗汉解脱
  见家系缚　　广显正法　　凡愚妄想
  罗汉解脱　　弃舍凡夫　　无利佛法
  舍利无利　　名阿罗汉　　见有高下
  若干等种　　众生取想　　罗汉解脱
  成就取相　　多所修习　　如是着相
  善能解脱　　得佛福田　　究竟真实
  妄取是田　　罗汉解脱　　无灭非灭
  亦物非物　　虽修菩提　　不得菩提
  持戒毁戒　　有智无智　　众生愚痴
  起于二想　　人多取着　　有若干种
  解脱此想　　罗汉所说　　作福田想
  非福田想　　无智凡愚　　作种种想
  于诸女人　　及与男子　　圣非圣法
  作二种心　　如是众生　　凡愚无智
  取着二想　　罗汉解脱　　退不退法
  有记无记　　近坐菩提　　不取菩提
  得菩提已　　毕竟寂灭　　永离生死
  取涅槃想　　断众生缚　　灭一切相
  是故罗汉　　为名解脱　　菩萨法尔
  现为罗汉　　不起法忍　　即罗汉智
  如是罗汉　　菩萨不讥　　心常住于
  最上菩提

尔时世尊告阿难言。汝今当知。是名如来等正觉为诸菩萨摩诃萨方便说阿罗汉。阿难言。云何如来等正觉复为诸菩萨摩诃萨说名声闻。佛言。阿难。菩萨能使无量阿僧祇众生。以佛法声令一切闻。故名声闻。亦令得闻不可思议声。闻不可思议声已。而于菩提无有戏论。以清净声令彼得闻。亦名声闻。又使得闻唯涅槃乐更无余乐。闻如是声亦名声闻。又使得闻根力觉道禅定解脱。诸三昧等念处正勤证于无余。如是之法令无数众皆悉得闻亦名声闻。是身苦空无我。而诸阴相皆不可得。凡夫愚痴。分别此身妄起取着。闻如是声亦名声闻。又得眼界虚伪不实。乃至佛眼皆同眼界不可思议。能令众生如实而见。于一切法无成就相名成就眼。如是法相使众生闻名为声闻。如呼声响令众生闻名为声闻。不应于声而妄取着。无有声相亦无所得。闻如是声名为声闻。不应于香而取香相亦无所得。譬如有人梦中闻香实无有香。于无香中妄起香想。但是颠倒自生分别。而取香相凡愚信受。闻如是声名为声闻。舌入相空犹如肉段不能知味。亦如聚沫不可为喻。过于喻故非味非具。分别味相实无所得。如是味界及不思议界平等无二。离心无念亦无思惟实无心想。闻如是声名为声闻。已所知法皆令他闻名为声闻。若闻于身分别身相。身相体性本空非生非不生。是名菩提。令无量众得闻是声名为声闻。心性无体实无所有。皆如幻化非生非灭。能令众生皆悉得闻名为声闻。佛告阿难。声闻法施不可思议。得证是道名不思议。以是不思议法施能生菩提。何以故。种子相似生故。无果为果。非财施所得。从闻信解名为声闻。财施微小法施为上。如是法施不嫉于他。亦无施相不着是施。譬如幻化无分别。不生愿求不取施想无愿求故。阿难当知。如是施者成就菩提。从闻信解名为声闻。尽一切相离诸结使。出过声闻一切僧上。发大音声演说佛法。何以故。得具足声出过一切诸音声故。出是声已令闻佛法。知诸声相非一非异成就正信。说法无二亦非不二。闻如是法名为声闻。尔时世尊。而说偈言

  无量众生闻　　佛法不思议
  菩萨广大辩　　是名为声闻
  闻已信菩提　　无浊无戏论
  令一切悉闻　　是名为声闻
  闻于涅槃乐　　是乐最第一
  普令闻寂灭　　是名为声闻
  诸力及觉道　　念处与根等
  速得于究竟　　是名为声闻
  闻此身苦空　　无有坚实相
  贪恚痴所侵　　是故分别身
  亦闻于眼入　　非实而见实
  众生多愚痴　　凡夫盲无智
  若得于佛眼　　正见不思议
  逮得如是眼　　无复诸愚痴
  诸法无成就　　一切众生闻
  以如是因缘　　亦名为声闻
  一切诸法相　　犹如呼声响
  此中无闻者　　亦无有说者
  令无数众闻　　是名为声闻
  此中无所闻　　无有染著者
  譬如人梦中　　虽闻多种香
  无一成就者　　如是知香体
  远离一切垢　　亦无闻香者
  菩萨之解脱　　多颠倒众生
  闻舌犹肉段　　不能得知味
  肉段若知味　　亦应知平等
  分别如是相　　贪味为最恶
  此界难思议　　是名知于味
  决定知味已　　菩萨无所著
  令众闻决定　　是名为声闻
  观身分别相　　本性空无生
  若知于真实　　无生无能生
  菩提如是相　　亦无生能生
  普令众生闻　　是名为声闻
  意亦如是知　　体性无所有
  空无体性故　　能令一切闻
  如物法无生　　无灭亦无二
  无相无所见　　是名为声闻
  咸使闻其施　　法施不思议
  修行趣道场　　成就于菩提
  譬如种种子　　各得相似果
  修施不思议　　证道亦复然
  悉施诸财物　　法施为最胜
  舍心无贪嫉　　是名菩提道
  心常不取着　　虽施无依怙
  若能如是施　　速证于菩提
  能离一切相　　悉舍诸结使
  无有诸染着　　是名为声闻
  其声甚微妙　　于诸声最上
  此声令远闻　　佛法不思议
  能令一切知　　诸声无所依
  非一亦非异　　是名为声闻
  欲令一切闻　　诸佛之所说
  随所闻法音　　皆发于菩提
  闻诸福田中　　佛福田最胜
  随佛所住处　　亲近救世尊
  使闻三千界　　安住于虚空
  众生亦复尔　　皆同涅槃相
  所说四大界　　分别为众生
  犹如虚空相　　等于不思议
  诸界如是相　　亦无有能知
  是中无生死　　无恼无涅槃
  诸法无真实　　众生亦皆然
  是名寂灭界　　云何见生者
  为无量众生　　昼夜常闻知
  不着己名利　　但为众生说
  当知是声闻　　欲令一切闻
  实非声闻法　　但现为声闻
  世雄假名说　　说法中最上
  是故知众生　　一切皆如相
  是名为声闻　　无漏除结缚
  解脱一切结　　而为众生说
  显示离诸缚　　清净无调戏
  见已为人说　　佛法皆亦然
  不久当得见　　如佛所说法
  菩萨所修行　　于法无染着
  是名为声闻　　无缚而清净
  亦使一切闻　　如闻而修行
  阿难汝当知　　我以方便说
  如是知声闻　　菩萨无所依

阿难当知。是名如来等正觉为诸菩萨摩诃萨方便说名声闻。阿难言。云何如来等正觉。复为诸菩萨摩诃萨说辟支佛法。佛言。阿难。菩萨现见一切法。云何现见。所谓知诸法无诤皆是假名。不坏法性而能见法证法。是名辟支佛。佛不思议。于一切法及诸众生。同涅槃相等无差别。无形无相清净寂灭。实际众生际涅槃际。犹如影幻无分齐无所有。于此诸际亦无际相。非言非说无所依止亦无所说。何以故。如我空无生无灭知众生际。则知法际生死际即是佛际。知如是际。是名辟支佛。现知于色。色者则名色阴。色阴尽已。但有言说。无我我所。何以故。如说色阴。但有言说。是空无生无灭。言无言相。云何以言说。说是色阴。亦现见受想行识。乃至说是识阴。知假名识阴等。但有言说。言说皆空无生无灭非实非虚。言说尚无。何况阴相。如是五阴。从假名起。是名辟支佛。何以故。因于名字言说为色。色但假名。无因非因。说名为因。是阴因缘不可说相。一切诸法无依无缘。如是觉知名辟支佛。尔时世尊。而说偈言

  现见一切法　　皆悉知无诤
  不生亦不坏　　无有浊乱相
  现见一切法　　本性皆空寂
  体相如是者　　则无有决定
  现见究竟处　　一切法亦然
  是名为正智　　缘觉不思议
  众生及涅槃　　前际不可得
  是际无有生　　佛亦难思议
  如众生涅槃　　无生无出处
  若法无生相　　是名为涅槃
  众生与涅槃　　皆如水中影
  有像无众生　　是名为涅槃
  众生与涅槃　　一切假名说
  无生亦无灭　　但有假名字
  如是言说相　　知无有众生
  是义应当知　　众生即涅槃
  一切言说空　　无心亦无法
  以言说非言　　决定无知者
  非言际无依　　言说亦无住
  如是言说相　　众生不思议
  众生及涅槃　　实际非实际
  出离得安隐　　永趣寂灭宅
  一切众生际　　犹如于影响
  无因亦无缘　　实际不思议
  一切诸法本　　但以假名说
  是际无所有　　不得名字相
  实际无言说　　亦无能知者
  以空无实际　　众生不思议
  实际无言说　　言说无所成
  真实相如如　　众生亦无际
  言说相自空　　非以言故知
  如汝之所说　　众生莫能思
  如是实际相　　非思议能知
  是名正觉说　　辟支难思议
  现见于色阴　　但有假名字
  如是阴相性　　常离于言说
  无有真实相　　乃名为出世
  如是知诸阴　　本性无住处
  是色无所有　　假名以为阴
  但有空名字　　不生亦不灭
  言说及诸法　　无有决定处
  若无有言说　　是名说色阴
  现见于痛阴　　想行亦如是
  乃至识阴等　　但有假言说
  见阴不可说　　离于一切相
  本性无所有　　不生亦不住
  如所说真实　　远离一切法
  如是知诸相　　体性无住处
  假名之所说　　说阴等亦空
  知言说空已　　无生亦无灭
  言说及诸法　　无有决定处
  若无有言说　　是名为识阴
  是阴离言说　　不可得限量
  无生无灭相　　亦无所依处
  解脱诸烦恼　　非业非果报
  非觉亦非阴　　非言非涅槃
  是想无决定　　亦无有智慧
  内外不可得　　无懈怠精勤
  无调戏疑惑　　亦无有成就
  不惊不怖畏　　无有一切色
  亦不见于空　　无相亦复然
  无有一异相　　非缚亦非解
  一切诸言音　　是声无所入
  是名为律陀　　非言所能及
  究竟于现见　　而说无尽法
  得是三昧已　　不着于言说
  此智若现见　　等说阿律陀
  律陀同诸法　　默然而演说
  于此现见倒　　不从他因缘
  是名为正觉　　缘觉不思议

不退转法轮经卷第二癸卯岁高丽国大藏都监奉敕雕造不退转法轮经卷第三

        僧祐录云安公凉土异经在北凉录第二译

    重释二乘相品第四

阿难如是。菩萨摩诃萨。现知明无明。知行无行。知识知识相。知名色知名色相。知六入知六入相。知触知触相。知受知受相。知爱知爱相。知取知取相。知有知有相。知生知生相。知老死知老死相。修集现见名辟支佛。尔时世尊。而说偈言

  现见无明　　而无所知　　亦无成就
  如水中影　　明亦不动　　不着于法
  若不着法　　是名明相　　无明如空
  一切法相　　到于现见　　是名缘觉
  若说诸行　　非内非外　　亦非从佛
  而起于行　　是行假名　　决定非有
  无生无灭　　犹如虚空　　到此现见
  菩萨无畏　　是名正觉　　缘觉难思
  知一切法　　皆如幻化　　明如幻已
  是名现见　　不如实知　　是识行处
  是想分别　　知识法空　　识智非智
  一切不着　　若知于法　　识如幻想
  名色因缘　　皆有为相　　无决定体
  亦无成就　　离于六入　　说六入相
  言说音声　　体性皆空　　触无因缘
  从六入生　　分别是触　　如幻皆空
  是触无体　　从妄想生　　触无真实
  亦无住处　　现见于触　　知无触相
  成就厌离　　名辟支佛　　若证于受
  不坚如泡　　性相皆空　　究竟无实
  断于爱结　　得无爱法　　得尽诸欲
  是名缘觉　　分别于取　　空无所有
  如热时炎　　无有成就　　无有作想
  生想亦尔　　知生体性　　空寂无有
  得离于老　　亦不畏死　　无所成就
  不受后有　　现见此法　　无所依止
  以缘觉声　　实修菩萨

阿难汝今当知。是如来等正觉为诸菩萨摩诃萨方便说辟支佛。尔时阿难。即从坐起。整其衣服。合掌向佛。而说偈言

  涅槃非涅槃　　救度于世间
  犹如空中结　　以空而自解
  若能如是说　　亦名有所说
  世尊善方便　　而说无著法

尔时阿难说是偈已白佛言。世尊。一切世间愚痴所蔽而自欺诳。不解如来作假名说。信行法行八辈等法。须陀洹斯陀含阿那含阿罗汉声闻缘觉。尔时佛告阿难。汝于过去佛不忘假名植诸善根。以善解假名故。不为愚闇之所劫夺。何以故。假名诸法。如幻如水中影如热时焰如呼声响。如是假名。阿难汝今当知。不为诸恶之所侵害。具足庄严而自庄严。能知诸法假名因缘。无所忘失成就精进。而亦不取精进之相。无有忘失。得最胜智亦不取智相。尔时世尊。即说偈言

  愚痴诸众生　　懈怠少智者
  则不知假名　　应当勤精进
  能解于假名　　如实知诸阴
  救度于世间　　令得真实智
  知假名空已　　便即菩提觉
  亦不得菩提　　是名说菩提
  假名即空相　　空不能知空
  空但有音声　　离一切诤论
  显示如是义　　于空无所取
  亦无可证处　　云何有得者
  是名为空空

如是阿难当知。空法甚深无量。不生放逸亦无所失。是名说辟支佛具足行地。尔时众中有五百亿比丘皆得信行。从座而起在世尊前。俱说偈言

  离疑得正智　　救世无上主
  世尊说假名　　信行住菩提

尔时众中。复有五百亿法行比丘。闻说偈已。从座而起。整其衣服。俱说偈言

  我等除疑惑　　菩提之照明
  如来说假法　　法行住菩提

尔时众中。复有十亿八辈比丘。闻说偈已。从座而起。住于佛前。俱说偈言

  我先离疑悔　　久修于八辈
  如来说假名　　八辈住菩提

尔时众中。复有十亿须陀洹。闻说偈已。从座而起。住于佛前。俱说偈言

  我今蒙照明　　救世之圣主
  知佛所说法　　开示于假名

尔时众中。复有二百五万斯陀含比丘。闻说偈已。从座而起。住于佛前。俱说偈言

  我先有取着　　而得斯陀含
  今离诸妄想　　寂静无戏论

尔时众中。复有十亿阿那含。闻说偈已。从座而起。住于佛前。俱说偈言

  救世无上尊　　令我离戏论
  拔离果想已　　照明菩提道

尔时众中。复有三十五亿比丘。皆住四禅得阿罗汉。闻说偈已。从座而起。住于佛前。俱说偈言

  我今得离垢　　自证于无余
  诸乘入一乘　　如幻无决定

尔时众中。复有二万比丘。闻说偈已。从座而起。住于佛前。俱说偈言

  我本着妄说　　世尊说假名
  自谓为声闻　　住于假名法

尔时众中。复有五千比丘。住辟支佛乘。闻是偈已。从座而起。住于佛前。俱说偈言

  我今得现见　　为缘觉菩提
  如来说假名　　缘觉不思议

尔时众中。复有百万比丘尼。取须陀洹斯陀含阿那含阿罗汉果想。闻说偈已。从座而起。住于佛前。俱说偈言

  愿于女身相　　皆入平等法
  世尊无异说　　照明为最上

尔时众中。复有八百亿万优婆塞优婆夷。皆作须陀洹斯陀含阿那含阿罗汉果想。闻说偈已。从座而起。住于佛前。而说偈言

  我今心无垢　　净如毗琉璃
  今始名出家　　得住于佛法

尔时虚空中。有六十亿那由他诸天。以天曼陀罗华而散佛上。于如来前。俱说偈言

  我先取乘想　　贪着于诸果
  我今悉舍离　　始觉菩提道

    不退转法轮经除想品第五

尔时众中。复有无量百千阿罗汉。舍利弗。大目揵连。须菩提。阿那律。阿[少/兔]楼驮。劫宾那。憍梵波提。而为上首。从座而起整其衣服。住世尊前曲躬恭敬。白佛言。世尊。我今发真实愿。离于妄想摧伏众魔。具足五逆具足五欲。具足邪见离于正见。断于无量众生命者。我今当令悉成菩提入无余涅槃。尔时世尊默然而住。无量百千在会大众皆生疑惑。何故尔耶。而今我等尽皆盲冥无所觉知。诸阿罗汉尚作是说。何况凡夫。各坐一处而不动摇。一切坐者不能得起。若有立者亦不能坐。皆言何故作如是说。尔时阿难。即为大众百千万亿众生故。以佛神力令自知心亦知他心。问文殊师利言。如是大众百千亿等。闻诸罗汉作是说已皆生疑惑。唯愿文殊。为我分别说其因缘。尔时如来默然而住。文殊师利告阿难言。是不退转地菩萨。见诸大德因缘故作如是说。阿难言。文殊师利。不退转地是菩提耶。文殊师利答言。如是如是。不退转地是诸大德菩提。阿难问言。诸尊者何故作如是说。尔时文殊师利语阿难言。无明为母。从行生爱究竟灭尽悉除怨害。倒想为父。离于颠倒除灭欲爱。作阿罗汉坚固不坏。尽凡夫想及以僧想。坏是想故能修一切无坏法想。乃至不取如来之想。习学无生究竟永离。尊者阿难。诸大德作如是说。我今云何具足五逆。何以故。无来去想。是故名为具足五逆。又阿难言。何者为五欲。是诸比丘。知于五欲。如梦如幻如水上泡如呼声响。如是智慧具足。云何具足智慧不增不减。云何五欲亦不增不减。何以故。如是五欲究竟无体无相。如实知已。即五欲相得证智慧。是故名为具足五欲。以是义故。诸大德作如是说。我今具足五欲。阿难。何者是具足邪见离于正见。于一切法而皆取着。是名邪见。邪见者是虚妄想。一切诸法非依非无依。犹如虚空无归无依。何以故。一切法无实可得。应如是知。一切法皆悉平等。除其等想。是名正见。何以故。如是等想。即是恶想。以是义故。诸大德比丘。不见等想。亦不见恶想。何以故。尽一切想。名佛菩提。逮菩提已。而亦不见少法可得。阿难。以是因缘。大德比丘作如是说。离于正见具足邪见。阿难。何以故。是诸比丘言。我今实断百千众生命。诸大德出是语时。百千万亿诸天。闻如是说。皆即得解诸法。如梦如幻如水中影如呼声响。得如是解已。便断众生丈夫寿命及人等想。亦即得解脱无有种。于菩提善根一切诸法。皆无起无作无所修习。闻说假名深信无疑。及优婆塞优婆夷等。皆悉除断众生丈夫寿命及人等想。除是想已。便得不复数数受生。何以故。断除众生丈夫寿命人及饿鬼想。有是想故数受生死。离是想已。即得究竟自证无生。以是因缘。诸大德。如是方便善说假名。言断无量众生之命。是故说言具足得佛菩提。我今于无余涅槃而般涅槃。得佛相好。以是教化无量百千万亿众生。灭诸结使如佛所证。何以故。令诸众生皆发阿耨多罗三藐三菩提心。得无生忍已令得菩提。亦不舍烦恼。不近佛法。从意生烦恼尽灭无余。以是因缘。诸大德皆言。我今得到菩提。阿难。是故今者名为无生。何以故。如是善男子善女人。发阿耨多罗三藐三菩提心。照明诸法。发菩提心已。亦无所得。离菩提相及一切法相。于无余涅槃入般涅槃。阿难。如是族姓男女乘菩萨乘。不以见日而生昼想。凡夫愚人若见日时便作日想。则非智者。何以故。阿难。若日有体非虚妄者。则可积聚。以虚妄故。亦无过去未来。夜亦如是。若日作日想。夜作夜想。则是凡愚妄想所见。阿难。是菩萨乘。修行阿耨多罗三藐三菩提。有善知识。不应昼生昼想夜生夜想。何以故。离一切想。能住菩提如来之道。尔时文殊师利。而说偈言

  无明以为母　　从行之所生
  若断其根本　　是名为除害
  喜爱诸倒想　　是说名为父
  若能如实知　　究竟无所有
  知彼悉虚妄　　则断诸根本
  无缘亦无住　　是说名除害
  若说诸罗汉　　凡夫不思议
  如实不坏相　　是灭名究竟
  我本着僧想　　如实知是已
  诸法皆无坏　　亦令一切闻
  先取于如来　　是名为虚妄
  知彼无异想　　平等同一空
  拔断其根本　　是名无生智
  若能如是说　　显现禅定力
  若说具诸欲　　如是五名字
  能离如是想　　犹如于幻梦
  不增亦不减　　是名具五欲
  在于救世前　　彼作如是说
  知欲本性空　　犹如梦化相
  毕竟无有生　　具足如实智
  知诸邪见过　　虚妄生分别
  以此究竟智　　一切皆具足
  虚妄无取着　　离于和合相
  如是善知已　　无相无所有
  同智一切过　　邪见正见等
  逮得真实法　　邪正相俱灭
  众生生死想　　愚痴妄分别
  若不得众生　　则无有生死
  众生多方便　　舍离于命想
  远离是想已　　知命想最恶
  若离众生想　　分别寿命等
  断多众生命　　是彼之所说
  舍离于死想　　愚痴所分别
  究竟得无生　　是名为实法
  灭除诸结使　　得证于无相
  菩提无有色　　无灭亦无果
  魔怨不能障　　自觉于菩提
  诸法无诤论　　无生性寂灭

尔时文殊师利说是偈已。如是无量百千众生除诸疑悔。离疑悔已心生欢喜得法照明。各脱上服供养文殊师利。作如是言。能令我等皆得此法悉作是说。亦令众生心证诸法。皆得如彼文殊师利所解实相。尔时阿难白佛言。世尊。云何如是百千万亿众生皆生疑悔。何故如来不自为说令断疑悔。于是佛告阿难言。如是百千万亿众生。皆从文殊师利发菩提心。于文殊师利而得调伏。阿难复言。皆得阿耨多罗三藐三菩提耶。佛言如是。阿难。一切众生皆不退转于阿耨多罗三藐三菩提。何以故。皆由文殊师利善知识故。阿难言。如是等诸比丘。信行法行须陀洹斯陀含阿那含阿罗汉声闻辟支佛想尽。不退转于阿耨多罗三藐三菩提耶。佛言。有难信者。少智下劣者。懈怠懒惰少精进者。贪嗜饮食近于五欲。乐处愦闹心不远离。忘失正念无智慧者。心无正定常惊乱者。增上慢者。取着增上慢者。贪着己身乐于寿命不观无常。多诸贪嫉愚痴无智。毁破禁戒心生恼害。于佛法中起于疑惑。见无智者。近恶知识远离善知识。亦不恭敬善知识。不学般若波罗蜜。不修陀罗尼诸经之王。常起妄见。着妄见已得于恶师贪乐衣钵。于和上阿阇梨无恭敬心。亦不乐亲近。于初中后夜心生懈怠。两舌难信好喜妄语。恶口贪嫉亲近邪见。习邪见已常修邪观不好学戒。心无惭愧无所顾畏。亲近愚痴乐行外道。不信空无相无愿无生无灭。于一切法不生信心。阿难。如是人等难可解悟

尔时世尊默然而住。是时阿难承佛神力。问文殊师利言。如来何故默然而住。文殊师利答言。于末法中。后未来世多有众生。在于彼世成就如是心。不信法不能解了。是故如来默然而住。阿难言。复有众生能信如是法不。文殊师利答言。亦有众生少能信者。阿难。少有众生能识于宝。多有众生不识是宝。阿难。少有众生能生信解。如是说法城邑聚落。多有众生弃舍不信。何以故。是彼众生宿世因缘。本作谤法罪业障故。阿难言。唯愿文殊。当令是诸众生信解所说。文殊师利言。汝当问佛。佛自为汝分别解说。尔时阿难白佛言。惟愿世尊。时为我说。族姓男女少信解者。彼得闻已生大欢喜。尔时世尊遍观四方面门出舌。普覆三千大千世界。从其舌根出大光明。遍照东方恒河沙等诸佛世界。如是南西北方四维上下。各于十方恒河沙世界。尔时四众。以佛神力亦见东方恒河沙世界诸佛同说此法。亦皆遥闻不增不减。如是次第十方世界亦复如是。于是世界诸佛说法如此。大众皆悉见闻。得见闻已。亦皆一心劝请。世尊。惟愿哀愍。重为我等分别演说。使见无量无边不可称数诸佛所说。不增不减不可思议诸佛正法。唯愿世尊。时为说之。还摄舌相。佛告阿难。颇有作妄语人能得如是舌相不耶。阿难言。不也世尊。若有实语柔软语诸有智者。善能调顺利益语。慈悲喜舍如是等。乃至一切智人。得是舌相。惟愿世尊。为族姓男女有少信者分别解说。亦为怜愍不解者说。当使此辈心生悔恨。尔时佛告阿难。四众已集正身端坐。天龙夜叉乾闼婆阿修罗紧那罗迦楼罗摩睺罗伽人非人等。诸来在坐能听法者。皆不退转于阿耨多罗三藐三菩提心。各于此地而说正法。不增不减如今所说。尔时四众。及天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。心生欢喜。皆脱上服以奉于佛。或散华香。或散华鬘。或以金鬘。或以银鬘。或以琉璃鬘。或以玻璃鬘。或以马瑙鬘。或以毗卢旃鬘。或以曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。或以所作之华而散佛上。或以天优钵罗华。拘物头华。芬陀利华。以散佛上。于虚空中。天乐自鸣。龙雨真珠。诸妇女等。以身璎珞。各脱上服以供养佛。整其衣服右膝着地。合掌向佛皆共同音。白佛言。世尊。如来无二。尔时佛告阿难。如是如是。如彼所说。如来无二永尽愚痴。如来世尊无有吝惜。无一切过。已离过故。离于诸欲。一切尘垢清净无染。憍慢贪嫉悉断无余。智慧具足觉悟正法。到于彼岸。犹如大梵得大自在。威仪具足究竟诸行。得四具足。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。而不取著有为无为。不染生死。从佛世尊得正解脱。得具足见无阙失见具足亲近。阿难言。云何如来。得具足见无阙失见。具足闻佛具足见佛具足亲近。佛告阿难。汝不知耶。阿难言。我实不知。佛言。汝今谛听。当为汝说。阿难言。唯然世尊。愿为解说。阿难。汝今闻我释迦牟尼佛。已闻当闻。如是等。皆得不退于阿耨多罗三藐三菩提。何以故。一切法身若有所说。其见闻者皆悉利益。阿难。若以一华供养如来。及般涅槃后。为佛舍利起塔供养。亦得不退于阿耨多罗三藐三菩提。阿难。乃至畜生。得闻佛名。亦得阿耨多罗三藐三菩提耶。佛言。阿难。复有人闻释迦牟尼佛音声。称其名号。皆是阿耨多罗三藐三菩提种子。若善男子善女人。闻释迦牟尼佛名号。如其所说皆实不虚。阿难。譬如尼拘陀树。若一若二若三若四。乃至五十百千无量等众。止息其下皆蒙覆荫。阿难。于汝意云何。尼拘陀子为大小耶。阿难言。尼拘树子最为甚小。佛告阿难。如是尼拘陀树。以水雨粪土人功因缘。积其日月渐渐长大。阿难言。如是世尊。佛告阿难。以尼拘树子本甚微小。以水土日月因缘故。渐渐长大。如是阿难。得闻释迦牟尼佛名。善根种子终不败坏。不退于阿耨多罗三藐三菩提。亦复如是。何以故。无相种子于一切不住。是故不坏。以不坏故。如是种子不可毁坏。亦不取相。是故于一切法不坏。阿难白佛言。世尊。为是如来本愿之力。为是诸佛法应尔耶。佛即答言。以本愿力故。若有众生闻我名者。皆得不退于阿耨多罗三藐三菩提。一切诸佛法亦如是。何以故。一切佛法皆平等故。阿难言。一切佛法平等有何利益。佛言。能令众生虽不闻法以发愿力故亦使得同闻法利益。尔时阿难白佛言。世尊。如来成就未曾有法故。能大利益诸菩萨摩诃萨等。佛言。如是如是。阿难。我今虽为众生作大利益。若闻法者。无不得住利益福田。我于过去供养诸佛。不惜身命。一切皆舍。离诸贪嫉。勤修精进。诸根清净。于一切法。不取不着。无所依止。是故阿难。我成菩提能大利益一切众生

    不退转法轮经降魔品第六

尔时阿难白佛言。世尊。说是不退转法轮。能令恶魔使不扰乱。何以故。佛言。是文殊师利神通之力。能使波旬不令得闻。文殊师利发真实誓。能令恶魔闻空中声。释迦牟尼佛转不退法轮。尔时波旬。身毛皆竖心生惊怖。作如是言。见此世界皆非世界。忧愁涕泣身变朽老。如百岁人发白面皱。是时魔王。形体肤发亦皆俱老。尔时魔王。将四种兵魔及魔天。皆诣佛所。亦如如来初成道时。严治器仗而来向佛。各见己身皆悉朽老。如百岁人形体挛曲。持杖而行到于佛前。时四种兵及虚空诸天。皆闻释迦牟尼佛转不退法轮。而此四兵皆不能进。即住一面心生惊疑。悉不能得随魔王意。尔时魔王。独至佛所无有伴党。而白佛言。世尊。我今衰老愿赐手力。本所有国皆非我有。如来大悲怜愍一切。宁不与我一人以为手力。于是佛告波旬。我观众生界分甚多。譬如恒沙无有量数。日日成佛得般涅槃。若一劫若过一劫。不能令彼众生界减。尔时魔王白佛言。世尊。众生界分虽多无量。我无一人可为手力。或当倾危谁见扶侍。惟愿如来慈哀慰喻。令得还宫并诸眷属。于是佛告波旬。颠倒众生诸不信者皆属于汝。是汝手力。是卿等侣。尔时波旬甚大喜悦作如是言。我今当令一切众生不起信心皆生疑惑。堕疑惑者悉是我力。尔时波旬白佛言。唯愿世尊。重见慰喻令我欢喜。如佛言曰。若得闻佛称其名号。皆得不退于阿耨多罗三藐三菩提。唯愿如来。默然莫作是说。若有闻者是诸众生。当勤精进修于菩提。唯愿世尊。如是慰喻。尔时佛告波旬。勿生愁恼。欢喜而去。我今当令无一众生发菩提心。亦无众生而能动于众生界者。乃至无一众生于色动。及受想行识动。乃至无一众生于身见疑戒取等动。亦无众生于过去未来现在想动。无有众生于杀盗淫妄语两舌恶口绮语贪欲嗔恚邪见等动。乃至不见众生于诸邪有而能动者。我亦不见众生修行布施持戒忍辱精进禅定智慧。不见众生。于众生想。寿命想。父母想。兄弟想。妻子男女想。昼夜想。一月想。半月想。岁数想。劫想。施想。戒想。忍辱想。精进想。禅定想。智慧想。力无畏想。五根想。七觉意想。八正道想。佛想。法想。僧想。菩提想。无碍想。一切法不动想。无有众生于此诸想而能动者。波旬勿生忧恼。欢喜而去。尔时波旬闻是语已。离诸忧恼。便大欢喜。即于此处还复壮年。并以天华而散佛上。绕佛三匝。于世尊前。而说偈言

  我今心欢喜　　救世三佛陀
  佛所说无异　　真实不虚妄

尔时波旬说是偈已。欢喜而去。还于本宫五欲自娱。更不复起扰乱之心。魔去不久。尔时大地六种震动。阿难白佛言。世尊。今此大地。以何因缘六种震动。非魔力耶。佛言。是我神力为遣魔故。令此大地六种震动。尔时有六十四百千众生。得无生法忍。是故大地六种震动。阿难白佛言。世尊。颇有众生起疑惑不。佛言。复有十亿众生。心生疑惑。我等今者。无谬闻乎。各皆迷乱。不识四方。从何而来。以痴冥故。悉不相见。尔时阿难白佛言。唯愿世尊。当疾哀愍为彼众生作大照明令离疑惑。如来所说假名法相。若不可知悉堕地狱。阿难白佛言。世尊。如来何故令此魔王心得少恼欢喜而去。都无一人住于菩提。亦无众生能动众生界。于色受想行识亦无能动。乃至身见一切取相六十二见。过去未来现在种种相动者。亦无众生于杀盗淫妄语恶口两舌绮语贪嗔恚邪见等动者。何故如来作如是慰喻魔王波旬言。无众生修行布施持戒忍辱精进禅智。乃至无众生寿命父母兄弟妻子男女昼夜等想。亦无一月半月岁数时节诸劫之想。如来何故作如是说。慰喻波旬少恼而去。亦无众生于菩提心想动。于根力无畏想动。根觉意道想动。无佛想法想僧想菩提想无碍想动。菩萨想动。如来何故慰喻波旬少恼而去。复言。当使无一众生同于法想。世尊何故作如是说。唯愿如来。为此等众作大照明。当使未来一切众生得蒙照明。得照明已。当令此法次第相续使不断坏。若有众生。深心信解受持是法者。当为是人演其因缘。如来何故作如是说。尔时世尊即为无数百千众生除诸疑惑。重说偈言

  菩提无住处　　亦无能住者
  以是因缘故　　说无住菩提
  菩提及众生　　非一亦非异
  以是因缘故　　说无住菩提
  众生本不动　　其界亦复然
  是法无成就　　究竟无所得
  众生体相空　　其界难思议
  无有能动者　　惟一切智知
  如所说诸阴　　众生无动相
  阴即是众生　　无二无住相
  阴以空为体　　性相即不动
  若无相可取　　云何有动者
  是故知诸阴　　亦无有动相
  言说永寂灭　　无相亦无体
  身即是阴相　　阴即名行处
  非行处而行　　说阴名为空
  所说空界者　　不生亦不起
  如是同于阴　　是名不可动
  身见相无体　　亦无法可得
  不得故无动　　我今如是说
  不取众生相　　究竟无所住
  亦无有心相　　形处不可得
  若说于诸见　　现示六十二
  如是众生等　　亦如水中像
  诸见同水像　　六十二亦然
  无我无所有　　其性不可动
  过去及未来　　现在亦复尔
  无相无所有　　皆如炎水像
  是名为无我　　不得众生想
  众生不可动　　亦无能动者
  譬如杀生者　　处生死旷野
  亦住于寂灭　　是名为不动
  欲令众生动　　众生不可得
  实无有众生　　是名说不动
  菩提无有断　　亦无有能度
  是故当勤修　　不得于动者
  法施不思议　　度过去众生
  应当勤修习　　是名不可动
  度脱于邪欲　　亦不得邪想
  应当勤修习　　是名不可动
  妄语诸众生　　为令得解脱
  当发大精进　　如彼不动相
  恶口及两舌　　绮语亦复然
  如是平等相　　如焰无所有
  诸法皆如是　　亦无依止处
  犹如呼声响　　善知寂灭相
  过去诸无明　　着我故生忧
  若证于无我　　是名为不动
  能知烦恼害　　体性本无相
  无相即菩提　　是名为不动
  深证诸邪见　　得修于正智
  离邪见丛林　　是名为不动
  若心得无欲　　现受宝女抱
  乃至诸童女　　智者所远离
  以邪相持戒　　而不舍正法
  智者无心意　　惟求于圣道
  是名修法忍　　显示于外道
  无心而行忍　　亦不近涅槃
  外道自显异　　五热为精进
  非智所修学　　苦行非菩提
  外道所说定　　取相为行处
  非佛所赞叹　　亦不令他学
  菩萨无所畏　　能摄诸众生
  以是因缘说　　取相所不动
  非取着所摄　　能生菩提心
  菩提不取相　　是故不能动
  父母兄弟等　　姊妹及妻子
  譬如于幻化　　是故不能动
  一切取相法　　皆悉无所有
  若住无所有　　是故不能动
  若有昼夜想　　一月及半月
  如是一切想　　如炎水中像
  布施及持戒　　修忍辱精进
  皆起于取着　　是相则为动
  菩萨大势力　　禅定修智慧
  若有无畏想　　一切想非想
  觉意及正道　　本有菩提想
  愚痴之所起　　智者则远离
  佛及众法想　　乃至有僧想
  如是种种想　　皆说为动想
  菩提名无想　　种智即菩提
  远离如是想　　菩提难思议
  是故作是说　　来者如水像
  若动彼想已　　则不远菩提
  菩提与众生　　一切法如如
  故我如是说　　不知恶魔心

佛次第说遣魔偈已。十亿众生断除疑惑得法照明。于一切法得无生忍。得是忍已。十亿众生。住于佛前。而说偈言

  佛道难思议　　最胜之第一
  故号为世尊　　除疑蒙安慰
  一切皆照明　　安住于佛道
  神光遍十方　　见无数亿佛
  见佛得闻法　　色相庄严身
  除秽得净智　　救世能度者
  于亿福田中　　佛福田最胜
  随佛所住处　　无上救世尊

尔时十亿众生。闻说偈已。皆以盛服。供养于佛。及供养法。作如是言。当令一切众生。悉闻是法。皆共来集。尔时阿难白佛言。世尊。转是遣魔法轮。诸族姓男女得闻是已。皆悉解脱信受无疑得几所福。佛言。阿难。若族姓男女。日初出时。亲近供养恭敬尊重赞叹百佛。于中时亲近供养百佛。乃至晡时供养百佛。于初夜时供养百佛。于中夜时供养百佛。于后夜时供养百佛。以众妙乐具最上衣服。于二万岁供养于佛。日常六时尊重赞叹。行住坐卧修行供养。初不暂息。阿难。于汝意云何。得福多不。阿难言。得福甚多。不可以譬喻知其限数。佛言。阿难。若族姓男女。得闻如是遣魔章句。其义次第闻已。复能信解不生疑惑。是人功德倍多于彼

不退转法轮经卷第三癸卯岁高丽国大藏都监奉敕雕造不退转法轮经卷第四

        僧祐录云安公凉土异经在北凉录第二译

    受记品第七

佛告。善男子。复有三菩萨摩诃萨。从东方来住大乘道。持曼陀罗华百千万叶。如日初出。阿难见已。一切众会亦皆同见。生未曾有想。尔时阿难白佛言。世尊。是三族姓子从何处来。佛言。从东方过恒河沙须弥莲华世界。有佛名云上功德如来。今现在彼。此中有三善男子。初闻法时于彼国来。尔时三菩萨住世尊前。以曼陀莲华散于佛上。散已作如是言。我于此法深生信解。无有疑惑。何以故。如来世尊。已于此法得无疑滞。是故我今亦无疑滞。尔时是三菩萨其第一者白佛言。世尊。若有人说如来我即如来。于此法中都无疑惑。第二菩萨复白佛言。世尊。若有人称说世尊我即世尊。亦于此法悉无疑惑。第三菩萨白佛言。世尊。若有人称说阿罗诃三藐三佛陀。我即阿罗诃三藐三佛陀。亦于此法悉无疑惑。尔时大众无量百千亿众生。悉皆战动心不喜乐。我从昔来。初不闻说于一世界而有二佛。云何今者。是三大士各称为佛。于世尊前互相指言。唯佛如来天人中尊。于一切法皆得自在。明达三世悉无挂碍。是三菩萨何故今日俱作是说。尔时阿难白佛言。世尊。是三菩萨名字何等。能于佛前作师子吼。佛时答言。其第一者。名乐欲如来声正住。第二者。名乐欲世尊声正住。第三者。名乐欲佛声正住。阿难。以是因缘故。此三大士作如是说。阿难白佛言。世尊。如是百千万亿众生。心皆惊骇。以此事故。是诸菩萨更作是说。复有闻者。心不惊疑增长净善。譬如年少好自严饰。形体净洁。加复洗浴。香油涂身。以赤栴檀香汁洒体。复倍香洁。其身光泽。若闻此法信受不疑。亦复如是。阿难白佛言。世尊。云何菩萨作如是说。佛言。此三菩萨。善解假名。故作是说。阿难言。如是如是。此菩萨等。善说假名。惟愿世尊。重为我说。亦令大众蒙法照明。尔时世尊。便为如是百千万亿众生。解其疑悔决定善根。即于尔时。而说偈言

  若能见过去　　未来亦复然
  如实知诸法　　是名为如来
  现在亦如是　　去来悉同等
  非一亦非异　　究竟寂灭相
  譬如过去佛　　行施不思议
  彼施亦如是　　是故说假名
  譬如过去佛　　住无碍菩提
  彼住亦复尔　　是名为如来
  一切法不住　　菩提亦寂灭
  不得菩提相　　是名为如来
  若说过去戒　　未来亦如是
  现在皆同等　　是名为如来
  过去世行忍　　菩萨截手足
  彼忍亦如是　　是名住于忍
  若发大精进　　本求于菩提
  得是精进已　　是名为如来
  一切法平等　　获彼如实证
  亦不取我相　　是名为如来
  不取于诸法　　一切悉平等
  知彼平等已　　无相无所有
  如是等三昧　　不取诸法相
  安住于禅定　　是名为如来
  一切法性相　　及所说诸法
  知其性相已　　如实无所有
  当知诸法空　　智慧非福田
  知彼非智已　　得到智彼岸
  若到于彼岸　　智慧不思议
  而不得此智　　到寂灭彼岸
  如相非到智　　无有此彼岸
  不得如是智　　是名为如来
  菩提非如得　　凡愚所不思
  一切法无碍　　是名为如来
  若得于无碍　　而到大智处
  一切法无利　　证无碍菩提
  如本所修道　　救世者济度
  得彼无依道　　能知于体相
  如是修习已　　获于最胜道
  调伏此道已　　知一切皆空
  知其初中后　　皆与诸法同
  此法平等已　　是名为如来
  道若如菩提　　是名住菩提
  犹如虚空相　　是名为如来
  如是说法已　　如悉平等相
  若于此无疑　　是名住菩提
  阿难知假名　　言说为如来
  言说亦如是　　智者所行处
  菩萨无所畏　　明智不退转
  一切所行处　　作如是显说
  阿难是次第　　如来之所说
  为诸菩萨等　　令得于无碍

尔时阿难。作如是言。而说偈言

  以何因缘故　　能知诸法相
  是菩萨无碍　　亦名为世尊

世尊答曰

  于百千万亿　　无量无数劫
  尔乃成菩提　　佛道难思议
  成就菩提已　　为众生住世
  处处实无生　　是名为世尊
  久超轮回趣　　不受于生死
  救度众生故　　是名为世尊
  不处轮回趣　　亦不入生死
  云何拔众苦　　号世无上尊
  不念于诸法　　亦不怀危脆
  不得众生相　　能度诸苦恼
  无生死轮转　　亦不住生死
  令众如是住　　是名为世尊
  得诸法无畏　　于佛亦复然
  无量无有际　　说法若干种
  诸法究竟空　　佛法之体性
  如是成就已　　而不见诸法
  若能专修行　　空空之体性
  心得于无畏　　是名知空法
  如实知诸法　　一切皆妄想
  显现无所畏　　如是实法相
  已过怖畏处　　亦离于净居
  无恐亦无畏　　超度诸恶道
  勉济亿众生　　生死之大畏
  不得于生死　　而能度众生
  安置于众生　　寂灭涅槃岸
  亦无众生相　　是名为世尊
  诸法犹虚空　　显示现众生
  于彼亦无畏　　是名为世尊
  一切法平等　　显现若干种
  菩提无分别　　不得菩提相
  众生如是学　　得成于菩提
  如说如修行　　则无恐怖想
  分别菩提想　　犹如众生想
  超过一切想　　是名为世尊
  灭除一切想　　菩萨则无垢
  不得名字相　　是名为世尊
  能知一切法　　同于尽灭离
  过去不可得　　是名为世尊
  不重名字故　　是以不求名
  离著名字者　　而为广说法
  菩提离名字　　如彼之所住
  众生重名字　　远离于菩提
  名如呼声响　　分别则多种
  声亦无分别　　而恃空名称
  不着一切声　　名亦无所依
  菩提无戏论　　是名为世尊
  如是等诸法　　世尊之所说
  非菩萨所得　　是名为世尊
  若解于修道　　无有能知者
  安住于菩提　　除碍名无漏
  阿难是假名　　但以言语说
  是以我今称　　自号为世尊

阿难复说偈言

  以何因缘故　　菩萨作是说
  复以何因缘　　自号称为佛

佛答言

  阿难是佛子　　一切法无碍
  觉悟无碍法　　自号称为佛
  佛知烦恼过　　不使得自在
  已离于结使　　自号称为佛
  但以空为佛　　亦无有身相
  此中无真实　　云何身可得
  不坚生坚想　　凡愚计为身
  如实觉悟已　　自号称为佛
  觉愚痴无智　　体性无所有
  明智之所得　　自号称为佛
  本有过去想　　觉已得无想
  知想及无想　　不令想自在
  觉了于色阴　　本自无生住
  凡愚妄分别　　非色非成就
  觉知无根本　　本来无有性
  是故无所受　　一切法无依
  想如热时焰　　因缘无所有
  是故灭除想　　一切法亦然
  不得是身行　　身相不坚固
  若知身行空　　是故不着身
  是身及行相　　皆悉如芭蕉
  如是觉真实　　自号称为佛
  求识真实相　　不在于身内
  亦复不在外　　云何有生处
  是识若无生　　一切法亦然
  悉无其处所　　有为不可得
  如是知识已　　毕竟无所有
  体性犹如幻　　亦无有生者
  若不能见识　　众生亦复然
  实无有众生　　云何能知识
  是识无有实　　诸法毕竟空
  法及于众生　　一切无成就
  一切法无相　　彼已决定觉
  寂灭无戏论　　自号称为佛
  证知于佛法　　正觉之所住
  一切法皆无　　自号称为佛
  如来犹菩提　　正觉之所住
  佛及菩提相　　究竟不可得
  若生于心处　　亦如住菩提
  心同菩提已　　佛犹如幻化
  阿难是假名　　但以言语说
  以如名为佛　　我是救世者
  如是相似生　　同佛音声说
  若得此法音　　安住于菩提
  不着于菩提　　当作如是知
  不应起疑意　　一切法无求
  于诸法无疑　　众生中最上
  如是相似法　　当知真实相

作如是说。如来世尊佛等三号。于是百千亿数众生白佛言。世尊。我等实蒙光明得除疑悔。菩萨摩诃萨。能作如是种种假名。说为如来世尊及佛。我今如是知已如是解已。于一切法逮得忍力。如来世尊。作大利益。犹如父母。以佛神力及智慧手。挽出我等。令不迷乱而无所扰。犹如一切不动。世尊。譬如虚空无能动者。如是世尊。于一切法心不动。亦复如是。何以故。一切诸法皆同虚空。如佛觉了无有动相。尔时百千亿大众绕佛三匝。去佛不远却坐一面。说是如来世尊佛名品时。常照净根菩萨。从坐而起。更整衣服。偏袒右肩右膝着地。持种种华散于佛上。各以偈颂。赞叹世尊

  众生贪着果　　悉令得解脱
  成就离果想　　故我礼智者
  能说于诸果　　令知平等想
  正觉证平等　　归命礼最上
  众生多贪着　　行处种种果
  佛以解脱故　　我今礼智者
  显现于诸法　　安住平等处
  得觉平等已　　敬礼牟尼尊
  众生多系缚　　种种诸果报
  佛悉令解脱　　归命礼最上
  成就寂灭道　　不住种种果
  善知假名相　　顶礼世智者

尔时照明净根菩萨摩诃萨。说是偈已。绕佛三匝。去佛不远。瞻仰尊颜目不暂舍。是时莲华胜藏菩萨摩诃萨。从坐而起。整其衣服。偏袒右肩。右膝着地。以种种华而散佛上。复以偈颂。赞叹于佛

  众生多取想　　能令悉除灭
  离畏得欢喜　　敬礼牟尼尊
  寂灭离诸有　　无畏而说法
  是名世雄猛　　敬礼牟尼尊
  知有本空寂　　其体不可得
  诸有中最妙　　敬礼牟尼尊
  永离于三有　　灭除诸结使
  离畏得无畏　　敬礼牟尼尊
  无畏亦无惧　　施中得最上
  出过一切施　　敬礼牟尼尊
  离畏得无畏　　拔除忧毒箭
  解脱于诸法　　敬礼牟尼尊

尔时莲华功德藏菩萨。说如是偈赞世尊已。而白佛言。若有众生。于后末世得闻是经。心不惊畏。我当礼敬。尔时离垢意菩萨。于世尊前。复说偈言

  常应散众华　　智者所修行
  得闻是经已　　当令得解脱

尔时离垢意菩萨摩诃萨。于世尊前。复说偈曰

  佛法甚深广　　显说如是经
  当有少众生　　信受不疑惑
  贪着于我见　　于身取身想
  不信于此经　　是名无智者

尔时莲华眼菩萨摩诃萨。于世尊前。复说偈言

  实为诸众生　　开示眼目导
  如是之经法　　唯善者不疑

尔时不思议解脱菩萨摩诃萨。于世尊前。复说偈言

  世号人中尊　　众生不思议
  说如是等经　　闻则无疑悔

尔时常忆念菩萨摩诃萨。于世尊前。复说偈言

  若不忆念者　　数数生死中
  不着于诸法　　修行则无疑

尔时宝衣解脱菩萨摩诃萨。于世尊前。复说偈言

  多衣满一亿　　净洁而细致
  初摩而缠覆　　修行则无疑

尔时施食菩萨摩诃萨。于世尊前。复说偈言

  所设众饮食　　具足诸肴膳
  日日应常施　　修行无有疑

尔时悲行菩萨摩诃萨。于世尊前。复说偈言

  应悲诸众生　　数数而号哭
  此经甚深妙　　厌恶不修学
  若从地狱来　　则乐处地狱
  虽似修功德　　须臾寻生疑
  亲近恶知识　　不信甚深法
  愚痴网自蔽　　如是生疑惑
  诸有破戒者　　恶心见其过
  闻经不信受　　诽谤于此行
  懈怠少精进　　不住于菩提
  无智心下劣　　不解如是行
  众生多乐着　　我见心自在
  常处于三界　　无能修行者

  愚痴起恶心　　无智染诸欲
  乐处于愦闹　　作是诽谤行
  愚痴少智人　　饕餮嗜饮食
  不修清净法　　故作诽谤行
  众生多贪着　　偏执取妄想
  不识于假名　　唯救世能度

尔时能远离解脱菩萨摩诃萨。于世尊前。而说偈言

  远离诸众生　　如弃于粪秽
  虚伪犹泥钱　　解脱着果想
  譬如坏死尸　　其恶甚可厌
  若谤如是行　　应疾速远离
  如贼劫村落　　处于旷崄路
  闻者悉远避　　愿莫值是恶
  若见坏烂者　　厌恶如贼害
  有诽谤此经　　如是恶莫见

尔时阿难白佛言。世尊。如是菩萨摩诃萨。甚为希有。其意明了。为是自定力耶。为是佛神力乎。佛言。皆是乘佛神力能作是说。亦是此经功德威力。逮得无碍。何以故。如是族姓子。以于六十亿佛所。从于佛口常闻此法不增不减。亦如从我得闻不异。是故亿念过去一切诸禅定力及佛神力。阿难言。如是如是。信如所说。此诸菩萨。现可证知

    不退转法轮经现见品第八

尔时阿难白佛言。世尊。若闻是法。次第信解不生疑惑。如是族姓男女。得成就几所福。佛告阿难。若族姓男女。住阿耨多罗三藐三菩提。复以阎浮提满中七宝供养者。是人功德。不如得闻此经次第句义信解不疑其福甚多。置阎浮提满中七宝供养诸佛。假设恒河沙世界满中珍宝供养诸佛。复有善男子善女人。得闻是经次第句义。信解不疑心亦不悔。是人功德复倍于彼。尔时世尊。而说偈言

  假使三千界　　满中诸珍宝
  供养于如来　　救度于世间
  若佛说此经　　有能谛听者
  智慧得解脱　　其福倍过彼
  譬如恒河沙　　于此诸世界
  七宝悉充满　　尽施一切智
  于佛之所说　　信受是经典
  是为解脱智　　其福亦倍彼

尔时阿难白佛言。世尊。若有族姓男女。信解是经受持读诵复为人说。得几所福。佛告阿难。如是族姓男女。住无上道。于百劫中修行布施。供养如来。远离此经。百劫持戒百劫忍辱精进禅定智慧。复于百劫得五神通。修世间智具足戒身。若有远离此经典者。是则不名尊重供养于诸如来。若有善男子善女人。信解是经。受持读诵复为他说。其所得福倍多于上。尔时世尊。而说偈言

  假使满百劫　　一切诸肴膳
  供养救世者　　不名尊重供
  若欲供养者　　当受持是经
  舍除福报想　　修行法供养
  如是供养者　　是名真供养
  以法为供养　　如来法身故
  假使满百劫　　以衣服供养
  救世之世尊　　多诸衣服施
  不名为供养　　有能持经者
  是名真供养　　最上之第一
  假使满百劫　　常散诸天华
  奉上诸世尊　　不名为供养
  若作第一供　　救世能度者
  应受持此经　　能除果报相
  若造七宝塔　　为救世建立
  一切如须弥　　不名供养佛
  此为最大供　　众供养中上
  能持此经者　　不见我身相
  假使满百劫　　修持于禁戒
  而不持此经　　不名为最胜
  听经而持戒　　于戒为最上
  亦于持经中　　而无持经想
  不名为犯戒　　亦不为破戒
  能学此经者　　如我之所说
  若能学此经　　亦善学菩提
  虽同学菩提　　而实无所学
  能如是持戒　　此经所显示
  于戒得具足　　是名持戒者
  假设满百劫　　有人修忍辱
  挝骂不还报　　一切皆能忍
  乃至截手足　　而不起异想
  亦不生怨嫌　　一切无所念
  能行是忍者　　具足满百劫
  虽修如意忍　　而心不为胜
  是忍最第一　　亦名为善修
  若复闻此经　　信解而受持
  是名最胜忍　　第一无有上
  若于此经中　　闻已能信解
  欲求于无碍　　无上佛智者
  当受持此经　　则能速具得
  假使满百劫　　精进常不坐
  经行已过时　　除去于睡眠
  智者修是经　　应为人演说
  则得无所畏　　是名胜精进
  假设满百劫　　而得五神通
  若不闻此经　　不名胜神通
  若能持此经　　是名胜神通
  神通中最上　　知义而不着
  假设满百劫　　常作明智人
  成就世间智　　决了于世间
  若不学此经　　不名为智者
  若能持此经　　乃名为勇健
  若能如是知　　是名为智者
  受持此经典　　闻则能信解
  显示于此经　　智者所行处
  若能持此经　　应加勤精进

尔时阿难。复说偈言

  行满百由旬　　或至千由旬
  当诣于智者　　有是经法处
  常应到彼所　　为听是经故
  听已而信解　　其心恒随顺
  假满世界火　　百千亿由旬
  若有此经处　　智者宜疾听
  若求圣禅定　　诸禅中最上
  当说如是经　　为灭诸结使
  若有欲舍去　　乐着于世间
  为显示此经　　如佛之所说
  若欲见诸佛　　阿閦为最上
  于诸受持中　　此经为第一
  欲得一切乐　　修诸菩萨行
  应当说此经　　速到安乐处
  欲见三佛陀　　安养难思议
  应为演此经　　如佛之所说

尔时佛告阿难。善哉善哉。说是经时。族姓男女。若得闻者。心不散乱。读诵此经。远离一切诸亲近处。亦悉灭除一切想识。若欲见佛即便得见。临寿终时。则能面见百千诸佛。何以故。如是族姓子等。为一切诸佛之所护念。说是经已。复能受持读诵信解。亦为他人分别演说

    不退转法轮经安养国品第九

尔时比丘比丘尼。优婆塞优婆夷。四众之中。时有童女。名曰师子。与五百童女俱。白佛言。世尊。若有女人读诵此经。复能为他分别解说。得几所福。佛告师子童女。若有女人住阿耨多罗三藐三菩提。受持读诵如是经典为人能说。当知此等是最后女身。更不复受。何以故。已能受持读诵此经为他说故。而心无乱。一切结使皆得除灭。若有女人应起结使。亦令不起。师子白佛言。世尊。云何是女人相。能生烦恼。佛言。师子。若有女人。见他端正女人及诸璎珞摩尼等宝而自庄严。受于快乐见是事已。便生染着不解观察。譬如画瓶但饰其外。凡愚臭秽亦复如是。不净所熏屎尿充满不知观察。如是等相便生乐着。而起染心。以是因缘常受女身。复告师子言。一切女人多生嫉妒欺诳妄语。心口俱异。或对面语。为乞丐故。往至比丘所而不为法。生嗔恚心及睡调心。但为愦闹。亲近俗事。而于此经作不利益。不肯听受不说不诵。昼夜常起诸烦恼心。远离解脱。有如是等心故。受女身不得远离。是故师子。一切女人皆悉应作如是观察。我当云何断诸结使不令复有。如是女人无利益事。当听是经。受持读诵。亦为他说。何以故。得闻是经分别次第。必能离于一切结使。时师子言。若有女人。读诵此经为他解说。求舍女身当可得不。佛言。师子。若有女人受持读诵此经典者。是最后女身更不复受。除其方便神通变化现受女者。师子。譬如有人然大火聚。而自投之。既投火已。复作是言。莫烧我身。亦使我身莫作异色。师子。于汝意云何。是人虽作此语。得如所言不。师子答言。不也。世尊。何以故。是大火聚性能烧物灭除身色。佛言。师子。此经亦复如是。能烧一切结使行薪。若欲舍女身相。即得离欲。成就佛法。欲见无量无数阿僧祇诸佛得无碍辩。欲发慈心一切众生者。亦当受持读诵书写此经。是时师子及五百童女白佛言。世尊。我从定光佛所。得闻是经受持读诵。我今复为无量众生重说显示。尔时阿难白佛言。世尊。今此师子及五百童女。何故不转女身。佛告阿难。汝今谓是师子及五百童女是实女耶。阿难言。如是世尊。佛答阿难。莫作是语。何以故。如此师子及五百童女。皆示现为女身非真实也。何以故。但为未来众生示现变化。怜愍一切诸女人故。现为女像。厌离女身。何以故。若作男形。则不能入一切处故。阿难。此师子等亦非男非女。何以故。一切诸法皆非男非女。出过一切法。无相可得。是真照明。阿难。是师子等随顺世法故受女身。为化诸女随已修学。尔时有五百比丘尼。从坐而起。头面礼足白佛言。世尊。我等从今以往。当受持读诵书写此经。为他解说。何以故。我等受此女身无所利益。宜速厌离。自从今日若未解者当令得解。若未闻者当令得闻。初中后夜除其睡眠系念思惟。佛言。诸比丘尼。善哉善哉。汝等发大庄严以自庄严。兴大精进。勇猛第一皆悉厌离乐舍女身。为欲利益一切佛法。受持此经。书写读诵。为他演说。汝等皆是最后受于女身。诸比丘尼闻是语已。踊跃欢喜。皆脱上服以供养佛。作是施已。而说偈言

  我等蒙安慰　　为得男子身
  如来无二言　　人中最上说

尔时四部众中。有五百长者夫人。从坐而起整其衣服右膝着地长跪叉手。白佛言。世尊。我等亦从今日受持读诵书写解说。但是女身为他所制不得自在。怀妊十月。云何当得免斯苦耶。何以故。若处深宫为王拘摄。或为父母儿婿禁制。从今已往。当勤精进专行修习。乃至终身受持正法。于是世尊。赞叹五百长者夫人。善哉善哉。如汝所说。汝等从今永舍女身。不复继属承事他人。亦无怀妊十月等苦。离于淫欲及诸胞胎。世世常生净佛国土。尔时阿难白佛言。世尊。如是诸姊。得离女身生何净土。佛言。此诸姊等。当生宝藏莲华光世界。阿难白佛言。世尊。如彼世界。佛号何等。佛言。于彼世界有佛。号一切宝如意王光明如来至真等正觉。今现为彼。为诸众生。种种说法。如是族姓女等。悉生彼国。于彼佛所。得闻此经。尔时长者夫人。闻佛说已。欢喜踊跃。即解璎珞价直百千。以奉散佛。如是供养。供养已即说偈言

  我等蒙安慰　　舍离于女身
  如来无二言　　所说皆真实
  女身为最恶　　当愿速舍离
  凡愚之所迷　　不知真实相
  胎生女最恶　　愿更不复受
  得离女胎已　　菩提为无上

尔时诸长者夫人。瞻仰如来目不暂舍。释提桓因以天曼陀罗华散于佛上。我等亦当受持此经。佛言。憍尸迦。汝若与阿修罗战时。常使得胜。不令退散。尔时文殊师利法王子。与百千亿众生。皆悉发于善根因缘。文殊师利白佛言。世尊。如来未发菩提心时。我已转此不退法轮。佛言。文殊师利。十方无量亿诸菩萨等。皆发大胜光明犹如日轮。如是大地亦皆六返震动。诸天雨华盈没于膝。尔时阿难白佛言。世尊。以何因缘。大地六返振动。诸天雨华。佛言。是无量百千亿天。闻文殊师利所说。心生欢喜。故雨此华。而作是言。我等皆当受持书写读诵此经。亦愿当得如文殊师利说如是法得闻经已。心生欢喜。大地一切普皆振动。诸天雨华。尔时阿难白佛言。世尊。是经能成诸大功德。是经甚深最为希有。若有众生。得闻是经一经耳者。当知是人不从小功德来。佛言如是。阿难当知。是族姓男女皆已供养过去诸佛。是故今于此会得闻是经心生信解。乃能受持读诵解说。有此经处即是一切天人中塔。利益无量其福不虚。若是经卷所住之处。及能受持乃至书写者。皆应供养如世尊想。闻是经者命终皆得不堕恶道。降伏众魔建立法幢。常然法炬照诸幽冥。能吹法螺到菩提树。击大法鼓开阐法门。雨大法雨。有求法者皆悉满足。显示法界。尽开过去诸佛伏藏。知一切法。除色受想行识想。远离眼耳鼻舌身意想。离一切法想乃至佛想。若闻是经。信解受持读诵之者。是真佛子。皆从法生。阿难。若有善男子等。若欲食法味。坐于道场菩提树下。如我不异。皆当受持诵读此经。为他人说。乃至手持经卷。恭敬供养。阿难白佛言。世尊。于末劫中。当有人能受持读诵。手持此经恭敬供养不。佛言。若今闻经明信解了。于将来世。亦能受持读诵为他解说。手持此经礼拜供养。若有沙门婆罗门天人及阿修罗。今闻此经。于未来世更不闻者。无有是处。何以故。以今闻法因缘力故。若于后世亦得闻法。必能信解。譬如长者多诸男女。其家大富财宝无量。金银琉璃珊瑚虎珀车磲马瑙真珠珂贝。奴婢僮仆象马车乘。有如是等一切财宝。置之于后游行他方。还至本处得此宝不。阿难言得。何以故。此诸财宝本属已故。佛言。阿难。如是法宝。今得闻者。即是己法。后还复闻。我今亦以佛眼。见现在世受持读诵此经典者。后则还得如今无异。若未来世有诸众生。受持此经者皆以佛眼观察。如今所见等无有异。若有诽谤此经典者。我以佛眼明见此人。亦如今日。阿难白佛言。世尊。若人不信不解诽谤是经。当趣何所。佛言。止止阿难。莫作是问。阿难白佛言。世尊。唯愿说之。当使未来众生有不信者闻斯果报。则便恐怖令生信解。佛言。若是诽谤不信果报所受苦痛。与五逆业其罪同等。若以利刀杀害众生。满三千大千世界。于意云何。是人罪报当趣何所。阿难言。是人业报当趣恶道。佛言。阿难。汝今应当作如是知。若恒河沙诸佛入涅槃后。为供养舍利造作塔庙。有人恶心焚烧毁坏。于意云何。是人当得几所罪报。阿难言。如是人等受报甚苦。则不可说亦不可闻。若诽谤此经说其过恶。所得罪报亦复如是不可得闻。何以故。是人毁坏过去未来现在诸佛一切法眼故。佛言。若见有人受持读诵此经典者。而起诽谤轻笑毁訾。教他不信。令使是人。不得读诵如法受持。当知是人其罪甚重复多于彼。阿难言。若满三千大千世界众生。具足十善住菩提道。若有坏如是等人眼者。得几所罪。佛言。是人当于无量阿僧祇劫。所受诸身则常生盲。于地狱中受苦无间。常挑其目。佛言。若有一人于此经中而生诽谤心不信者。我说是人罪亦如彼。阿难言。若有菩萨住于菩提。信解此经受持不疑。当趣何所。佛言。是名随顺供养诸佛等无有异。阿难言。若复有人不信是经而自诽谤。亦教他人令生诽谤。如此人者。当受何身受何等苦。佛言。止止阿难。莫作是问。阿难言。惟愿世尊。时为解说。令此四众。若有疑惑生不信者。闻佛说已。当自悔过得生信心。佛言。若复有人。不信是经向他诽谤。当得十千由旬身。受如是大形获无量苦。阿难言。是人不慎舌故。复有何相。佛言。此人罪报。其舌纵广一千由旬。以五百亿大热铁犁。而耕其舌。复以五百亿大热铁丸。雨其舌上。何以故。不慎恶业诽谤过故。受如是苦。尔时四众闻是语已身毛皆竖。悲泣盈目自投于地。皆共同声唱如是言。世尊。若族姓男女。如是诽谤当获斯罪。是故我今代其忏悔使灭众罪。不受如是大恶果报。今于佛前及余十方无量佛前。我等愚冥不自知过。唯有佛眼实见实证。皆悉忏悔。自今以后不敢重作。犹如婴儿无所识知。不能晓了分别善根。我今至诚深自咎责。惟愿世尊。当垂怜愍受我忏悔。佛言。善哉善哉。是时四众各言。我今诚心自归。所有诸罪悉皆忏悔不敢覆藏。佛言。汝等如是至心忏悔。一切善法无不增长。尔时阿难白佛言。世尊。今此众中有生疑者。恶业罪障亦如是耶。佛时答言。于此众中若生疑者。可即忏悔。所有余罪受报轻微。阿难言。云何受罪轻微。佛言。是人临命终时。诸毛孔中皆悉受苦。喻如泥犁等无有异。何以故。能信如来所说言教。及信无量阿僧祇佛。亦自悔过。阿难。是族姓男女则不舍过去未来现在一切佛眼。若彼欲见无量阿僧祇佛。及见无量金刚叶莲华光明遍照殊胜妙相。尔时释提桓因现长者身。以种种华散诸四众。唱如是言。当以此华供养于佛。乃至供养如是经典。尔时四众即取诸华以散佛上变成华盖。而白佛言。世尊。以何因缘现是瑞相。今于佛前有是莲华。及无量恒河沙一切佛前。亦复皆有如是等华。佛言。为说是经功德威力故现此瑞。如是相者当知皆是神力所持。尔时阿难白佛言。世尊。佛威神力乃至如是护持法耶。佛言。阿难。实我神力护持是法。乃至恒河沙诸佛亦皆护持。尔时阿难白佛言。世尊。此经当何名。斯经云何受持。佛言。是经名为无著果无有种种诸杂恶报。如是受持。信行法行八辈须陀洹斯陀含阿那含阿罗汉辟支佛解是假名无有真实。如是受持。名为舍魔。如是受持。亦名六波罗蜜。如是受持。何以故。阿难。若有如是信解受持读诵书写此经为他人说。当知是善男子善女人。即是具足六波罗蜜。阿难言。云何受持读诵书写此经为他人说。即得具足六波罗蜜。佛言。若善男子善女人等。有能信解此经典者。即具足檀波罗蜜。于此法中心不犯戒。是名具足尸波罗蜜。若读是经心忍不退。是名具足羼提波罗蜜。能于此经心不退没。是名具足毗离耶波罗蜜。信乐此经心不散乱。是名具足禅波罗蜜。谛了此经无分别相。是名具足般若波罗蜜。是故此经。与六波罗蜜相应。亦名一切诸佛所说不退法轮广博严净。阿难言。是经名字不可得闻。何况得见。初中后善具足受持。佛言。如是如是。实如汝说。阿难言。得闻此经。是人生死余几所耶。佛言。若人得闻不退法轮广博严净方等经名。此人生死余则千劫。阿难言。若闻此经名字。信解能受发菩提心。是人功德当住何地。佛言。若有得闻是经名者则受阿耨多罗三藐三菩提记。得不退转地。尔时四众前。皆有莲华座若干种色。复有百千万亿种叶。时诸四众踊跃欢喜。各取此华以奉散佛。而作是言。我等皆当为人广说如是经典。分别显示使不断绝。尔时世尊熙怡微笑。作天伎乐。香风时来其气芬馥。多有诸天于虚空中。亦作无量种种天乐。雨诸天香细末栴檀沉水胶香。阎浮檀金末及诸银末。摩尼宝网罗覆其上。及五种色曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。迦迦罗华。摩诃迦迦罗华。一切优钵罗华。拘物头华。芬陀利华。及香璎珞涂香末香。一切诸天所有供养。遍满虚空。地上人民。亦整衣服散华供养。复有诸余众生。皆以臂脚宝环手钏。解颈诸璎无量宝冠。以上奉佛。复有诸余众生。以其金银散于佛上。复有诸余众生心皆欢喜。出大音声唱言。善哉善哉。及诸象马出和雅音。虚空诸鸟随类音声以用供养。地狱众生皆得暂乐。畜生众生更相爱念。如父母想。阎罗王界一切众生。亦暂受乐。饿鬼众生。皆悉得除饥渴苦恼。尔时天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。各受快乐。更相慈愍犹如父子。尔时阿难白佛言。世尊。如来今者。以何因缘而微笑耶。尔时佛告阿难。一切四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。若于今世后世闻此经者。皆得不退转于阿耨多罗三藐三菩提。能为他人广说是经无所损灭。亦如我今分别解说等无有异。阿难。闻此经已心生信解。即是佛种。何况受持读诵修行。当知是人去一切种智则为不远。当得一切智自然智。是故此经名不退转法轮之印。能为诸菩萨等作大利益。亦为一切众生。发于无上道心因缘。能发心已。便于此经具足成就阿难。如来以一切智示诸众生。若复有人。虽离佛智。但闻此经。即得自然智及佛智利。亦即受记。是故此经名为不退转法轮广博严净。亦名成就具足善根庄严方便为作利益行大乘者。阿难当知。尔时如来广说是经。无量菩萨皆得成就无生法忍。无量无边阿僧祇等亿数众生。皆悉得住不退转于阿耨多罗三藐三菩提。佛说经已。文殊师利舍利弗阿难等。及诸四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆大欢喜顶受奉行。作礼而去

不退转法轮经卷第四癸卯岁高丽国大藏都监奉敕雕造


大乘方广总持经一卷

    No. 275 [No. 274]

大乘方广总持经一卷

        隋天竺三藏毗尼多流支译

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众六万二千人俱。菩萨摩诃萨八十亿众。摩伽陀国优婆塞六十亿百千人

尔时世尊夏安居已。临涅槃时入如法三昧。入三昧已。是时三千大千世界。普遍庄严悬缯幡盖。置宝香瓶众香涂饰处处遍散千叶莲花。尔时此三千大千世界亿百千众。诸梵天王及亿百千眷属来诣佛所。到佛所已头面礼足。合掌向佛却住一面。复有亿百千净居天子。自在天王大自在天王。龙王夜叉王。阿修罗王迦楼罗王紧那罗王摩睺罗伽王。各与亿百千眷属来诣佛所。到佛所已头面礼足。合掌向佛却住一面。尔时十方如恒河沙大威德菩萨摩诃萨来诣佛所。到佛所已头面礼足。合掌向佛却住一面。尔时此三千大千世界。乃至有顶皆悉来集大众充满间无空处。尔时复有余大威力天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等皆来集会

尔时世尊正念现前从三昧起。遍观大众欠呿频申。如师子王如是至三。尔时世尊从其面门出广长舌。遍覆三千大千世界。是时如来现神通已复观大众。尔时一切大众即从坐起。合掌作礼默然而住。尔时佛告弥勒菩萨摩诃萨言。阿逸多。如来不久当入涅槃。汝于诸法有所疑者。我今现在。欲有所问今正是时。佛灭度后勿生忧悔。尔时弥勒菩萨摩诃萨白佛言。唯然世尊。善自知时。诸佛如来于一切法皆悉究竟。惟愿宣说令此法眼久住于世。尔时会中有大自在天子及八十亿净居天众。眷属围绕顶礼佛足。合掌恭敬而白佛言。世尊。此大乘方广总持法门。过去无量诸佛如来应供正遍知已曾宣说。惟愿世尊。今复敷演利益安乐无量人天。能令佛法久住世间。尔时世尊默然而许。是时大自在天子知佛许已欢喜踊跃。合掌作礼却住一面。尔时佛告弥勒菩萨摩诃萨言。阿逸多。此大乘方广总持法门非我独说。过去未来及今现在十方世界无量诸佛亦常宣说。若有众生于佛所说言非佛说及谤法僧。而此谤者当堕恶道受地狱苦。尔时佛告弥勒菩萨摩诃萨言。若有善男子善女人发菩提心。于此大乘方广总持经典。受持读诵复为人说。当知是人不堕恶道

尔时世尊复告弥勒菩萨摩诃萨言。阿逸多。我从成佛夜乃至将入无余涅槃。于其中间佛身口意。所作所说所念所思惟。颇有忘失起恶业不。弥勒菩萨言。不也世尊。佛言弥勒。如汝所说。我从成道乃至涅槃。于其中间所言所说皆悉真实无有虚妄。若有愚人不解如来方便所说。而作是言。是法如是是法不如是。诽谤正法及佛菩萨。我说是辈趣向地狱。佛言。阿逸多。于我灭后五浊世中。若有比丘比丘尼优婆塞优婆夷。实非菩萨自谓菩萨。是外道人。曾于过去供养诸佛发愿力故。于佛法律而得出家。随所至处多求亲友。名闻利养。恣行秽污弃舍信心。成就恶行不自禁制。不自调伏贪诸利养。于一切法门及出生坚固三昧。皆悉远离实无所知。为亲属故妄称知解住于谄曲。口说异言身行异行。阿逸多。我菩提道于一切众生。皆悉平等安住大悲。以善方便正念不忘。如来安住无等等力。无障无碍而为说法。若有众生作如是言。佛为声闻所说经典。诸菩萨等不应习学不应听受。此非正法此非正道。辟支佛法亦不应学。复作是言。诸菩萨等所修行法。声闻之人亦不应学不应听受。辟支佛法亦复如是。复作是言。诸菩萨等所有言说。声闻辟支佛不应听受。彼此言行更相违背不与修多罗相应。于如实说真解脱法不能信受。依彼法者不得生天。何况解脱。阿逸多。我今说法随其信心而调伏之如恒河沙。阿逸多。我今欲往十方世界随顺说法利益众生。不为实非菩萨而作菩萨相者。亦不为毒恶欺诳少闻之人于我法中作二说者。其二说人或作是言。是菩萨应学是不应学谤佛法僧。是人身坏命终堕于地狱。多百千劫不可得出。设令得出生贫穷家。至于后时虽得授记。五浊恶世成等正觉。如我今日于是生死五浊世中成于佛道。以是因缘汝应谛听。应当信知。随顺恶友所行如是。阿逸多。我念过去无央数劫。彼时有佛名曰无垢焰称起王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。是时彼佛寿命八万那由他岁为众说法。尔时无垢焰称起王如来法中。有一比丘名曰净命。总持诸经十四亿部大乘经典六百万部为大法师。言辞清美辩才无碍。利益无量无边众生示教利喜。尔时无垢焰称起王如来。临涅槃时告彼比丘净命言。未来世中汝当护持我正法眼。尔时净命受佛教已。于佛灭后千万岁中。守护流通诸佛秘藏。于此方广总持法门受持读诵深解义趣。于彼世界八万城中所有众生。随其愿乐广为宣说。尔时有一大城名曰跋陀。往彼城中为八十亿家。随其所乐而为说法。是时城中八十亿人获净信心。一亿人众住菩提道。七十九亿人住声闻乘而得调伏。尔时净命法师复与十千比丘众。相随俱往修菩提行。尔时跋陀城中复有比丘名曰达摩。于大乘经方广正典。受持千部获得四禅。唯以方广空法化彼城中一切众生。不能以善方便随欲而说。作如是言。一切诸法悉皆空寂我所说者真是佛说。彼净命比丘所说杂秽不净。此比丘实非净命而称净命。何以故。而此比丘所受诸华。不持供养而自受用。涂香末香亦复如是。净命比丘愚痴无智。不能知我久修梵行。彼既年少出家未久。我慢无信多诸放逸。是诸人等无所知晓。谓是净命持戒比丘。尔时达摩以其恶心谤持法者。身坏命终堕于地狱。经七十劫具受众苦。满七十劫已堕畜生中。过六十劫后值遇香宝光佛。于彼法中发菩提心。于九万世犹生畜生中。过九万世已得生人中。于六万世贫穷下贱恒无舌根。其净命比丘于诸法中得净信心为人说法。彼于后时得值六十三那由他佛。恒为法师具足五通。劝请彼佛转妙法轮。阿逸多。汝今当知。过去净命比丘者岂异人乎莫作异观。今阿弥陀佛是。阿逸多。汝今当知。过去达摩比丘者岂异人乎莫作异观。今我身是。由我过去愚痴无智毁谤他故受苦如是。我以此业因缘故。处五浊世成等正觉。是故阿逸多。若有菩萨于诸法中作二说者。以是因缘后五浊世成于佛道。其佛国中有诸魔等。于说法时恒作障难。尔时大众闻佛说已。皆悉悲泣涕泪交流俱发是言。愿于佛法莫作二说如达摩比丘

尔时会中有百菩萨。即从座起右膝着地悲号堕泪。尔时世尊知而故问彼菩萨言。善男子。汝等何为悲号如是。尔时诸菩萨等异口同音俱白佛言。世尊。我等自观亦应有此诸恶业障。尔时世尊作如是言。如是如是。汝亦曾于过去然灯佛所。在彼法中出家修道。是然灯佛灭度之后。时有比丘名曰智积。汝等尔时谤是比丘。因是已来不得见佛。不能发菩提心。不得陀罗尼及诸三昧。后共汝等同时安住菩提之道。汝等善男子。此贤劫最后佛所当获无生法忍。复于后时过三阿僧祇劫行菩萨道。当得阿耨多罗三藐三菩提。是故善男子。若菩萨见余菩萨。不应生于彼此之心。当如塔想如见佛想。是故菩萨见余菩萨。莫作异念谓非佛想。若起异念为自侵欺。当受持此莫作异想共相和合。我今观初发心菩萨不如佛想者。我便欺诳十方现在一切无量阿僧祇诸佛。是故善男子。菩萨未来于五浊世中。得陀罗尼三昧者。一切皆是佛之威力。是故善男子。若有诽谤其法师者。即为谤佛等无有异。善男子。佛灭度后若有法师。善随乐欲为人说法。能令菩萨学大乘者。及诸大众有发一毛欢喜之心乃至暂下一渧泪者。当知皆是佛之神力。若有愚人实非菩萨假称菩萨。谤真菩萨及所行法。复作是言。彼何所知彼何所解。弥勒。我忆过去于阎浮提学菩萨时。爱重法故为一句一偈。弃舍所爱头目妻子及舍王位。何以故。以求法故。如彼愚人专为名闻耽着利养。自恃少能不往如来传法人所听受正法。弥勒。若彼此和合则能住持流通我法。若彼此违诤则正法不行。阿逸多。汝可观此谤法之人。成就如是极大罪业。堕三恶道难可出离

复次弥勒。我初成佛以妙智慧广为众生宣说正法。若有愚人于佛所说而不信受如彼达摩比丘。虽复读诵千部大乘为人解说获得四禅。以谤他故七十劫中受大苦恼。况彼愚痴下劣之人。实无所知而作是言。我是法师明解大乘能广流布。谤正法师言无所解。亦谤佛法而自贡高。若彼愚人于佛大乘。乃至诽谤一四句偈。当知是业定堕地狱。何以故。毁谤佛法及法师故。以是因缘常处恶道永不见佛。以曾诽谤佛法僧故。亦于初发菩提心者。能作障碍令退正道。当知是人以大罪业而自庄严。于无量劫身堕地狱受大苦报。以恶眼视发菩提心人故得无眼报。以恶口谤发菩提心人故得无舌报。阿逸多。我更不见有一恶法能过毁破发菩提心罪之重也。以此罪故堕于恶道。况复毁谤余菩萨等。若有菩萨为诸众生。能如实说不起断常。言诸众生定有定无。亦不专执诸法有无。阿逸多。学菩萨者应如是住。如是住者是诸菩萨清净善业。凡所修集皆不取着。若有众生起执著者。当知是人生五浊世。复有菩萨善随根欲。能为众生种种说法。阿逸多。菩萨如是具足修行六波罗蜜。乃能成就无上菩提。彼愚痴人信己自执作如是说。菩萨惟学般若波罗蜜。勿学余波罗蜜。以般若波罗蜜最殊胜故。作是说者是义不然。何以故。阿逸多。往昔迦尸迦王学菩萨时。舍所爱身头目髓恼。尔时此王岂无智慧。弥勒白佛言。世尊。诚如圣说实有智慧。佛告阿逸多。我从昔来经无量时。具足修行六波罗蜜。若不具修六波罗蜜。终不得成无上菩提。如是世尊。佛告阿逸多。如汝所说。我曾往昔于六十劫。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅那波罗蜜般若波罗蜜各六十劫。彼愚痴人妄作是说。唯修一般若波罗蜜得成菩提。无有是处。彼怀空见故作如是不净说法。作此说者身口意业与法相违。虽解空法为人宣说。而于空法不如说行。以无行故去空义远。心怀嫉妒深着利养踰于亲戚。阿逸多。我于往昔作转轮王。舍诸珍宝头目手足。犹不得成无上菩提。况彼愚人为饮食故。缘历他家有所宣说。唯赞空法言己所说。是菩提道是菩萨行。唯此法是余法皆非。复作是言。而我所解无量法师悉皆证知。彼为名闻自赞己能憎妒明解。阿逸多。我见彼心规求利养以自活命。虽有善行经于百劫。尚不能得少法忍心。何况能成无上菩提。阿逸多。我不为心口相违诳惑之人而说菩提。不为嫉妒之人而说菩提。不为傲慢不敬之人而说菩提。不为无信之人而说菩提。不为不调伏人而说菩提。不为邪淫之人而说菩提。不为自是非他之人而说菩提。阿逸多。彼愚痴人以我慢故自谓胜佛。谤佛所说大乘经典。言是声闻小乘所说

尔时佛告尊者须菩提。不应为二见人说般若波罗蜜。须菩提白佛言。唯然世尊。如佛所说。佛言。如是须菩提。以无著心施是名菩提。须菩提言。如是世尊。佛言。须菩提。不自赞毁他施是名菩提。须菩提言。如是世尊。佛言。须菩提。汝观愚人起我我见。无惭无愧为爱亲戚。贪求活命好受他施。当知是人专造恶业

复次阿逸多。菩萨于一切法于一切菩萨法莫生恐怖。于一切辟支佛法亦莫恐怖。于一切声闻法亦莫恐怖。于一切凡夫法亦莫恐怖。于一切烦恼法亦莫恐怖。于一切尽法亦莫恐怖。于难精进亦莫恐怖。于是于非亦莫恐怖。于作不作亦莫恐怖。于畏不畏亦莫恐怖。于有于无亦莫恐怖。于心非心亦莫恐怖。于觉不觉亦莫恐怖。于业非业亦莫恐怖。于善不善亦莫恐怖。于安不安亦莫恐怖。于解脱不解脱亦莫恐怖。于修不修亦莫恐怖。于法非法亦莫恐怖。于静于乱亦莫恐怖。于假于实亦莫恐怖。于信不信亦莫恐怖。于善念不善念亦莫恐怖。于住不住亦莫恐怖。如是菩萨于一切法莫生恐怖。阿逸多。我于往昔修如是等无畏法故得成正觉。悉能了知一切众生心之境界。而于所知不起知相。以我所证随机演说。能令闻法诸菩萨等获得光明陀罗尼印。得法印故永不退转。若于此法不如实知言无善巧。终不得成无上菩提。阿逸多。我为四天下众生说此法时。是诸众生以佛神力。各自见释迦如来为我说法。如是次第乃至阿迦尼吒天。彼诸众生亦谓如来唯为我说。如一四天下乃至三千大千世界亦复如是。此诸众生咸作是念。释迦如来独生我国。唯为于我转大法轮。阿逸多。我以如是大方便力。能于无量无边世界。常于晨朝遍观众生所应化者而为说法。于中及暮恒以法眼等观众生。于彼世界而为众生说一切法。如是无量诸佛境界。所有众生学菩萨者应如是修。若彼愚人于佛所说谤诽正法。妄执自解用为真实。若谤法者则不信佛。以此恶业堕于地狱。具受众苦永不闻法。复次阿逸多。汝当受持如来密教以善方便广为人说

尔时文殊师利童子。福光平等菩萨无疑惑菩萨定发心菩萨。妙心开意菩萨。光明菩萨。欢喜王菩萨。无畏菩萨。心念遍到无边佛刹菩萨。观世音菩萨。香象菩萨。灭一切恶业菩萨。住定菩萨。百千功德庄严菩萨。妙音远闻菩萨。一切智不忘菩萨。大名远震宝幢庄严菩萨。求一切法菩萨。住佛境界菩萨。月光庄严菩萨。一切世间大众庄严菩萨。如是等菩萨摩诃萨白佛言。世尊。如是如是诚如圣说。我等于此东方过六十恒河沙佛刹。于诸佛所恭敬礼拜。一一佛刹唯见释迦如来出现于世。我等于其七日之中遍游十方。亦见释迦如来出现于世。不睹余佛。遍游历已还归本土听受正法

尔时佛告文殊师利童子。汝今谛观。如来智慧不可思议。如来境界亦不可思议。如是无等等是如来法。彼愚痴人作如是说。唯一般若波罗蜜。是如来行是菩萨行是甘露行。佛告文殊师利。作此说者与法相违。何以故菩萨行法具足甚难。无著行是菩萨行。无我我行是菩萨行。空行是菩萨行。无相行是菩萨行。文殊师利。如是等行是菩萨行。学菩萨者如是受持。若彼愚人心怀邪见。当知是人不了我法。文殊师利。汝等诸菩萨守护身口。于不善法勿令放逸。坚固其心使不退转。为诸众生具足说法。亦当自身住于法中。我从久远阿僧祇劫。具足成就无上菩提。以善方便广为人说。令诸众生远离恶趣。文殊师利。若有愚人谤微妙法。即是谤佛亦名谤僧。又作是说。此法是彼法非。如是说者亦名谤法。此法为菩萨说此法为声闻说。作是说者亦名谤法。此是菩萨学此非菩萨学。作是说者亦名谤法。复作是言。过去佛已灭。未来佛未至。现在佛无住。唯我获得陀罗尼法。作此说者亦名谤法。以谤法故言得陀罗尼者是不净法。于真法师毁谤所修。复谤法师虽有解慧不如说行。复谤法师行违于道。复谤法师身不持戒。复谤法师心无智慧。复谤法师意无明解。复谤法师言无辩了。复于如来所说文字心无信受。复作是言。此修多罗是此修多罗非。此偈经是此偈经非。此法可信此法不可信。见正说者妄作异论。于听正法者为作留碍。此是行此非行。此成就此非成就。此是时此非时。诸如此说皆名谤法。复次文殊师利。若声闻说法若菩萨说法。当知皆是如来威神护念力故。令诸菩萨等作如是说。文殊师利。如彼愚人于佛现在犹生诽谤。况我灭后受持我法诸法师等而不被谤。何以故。魔眷属故。当知是人堕于恶道。如彼愚人贪求利养以活亲属。于如来法心无信念。而复破坏如来教法。彼人亲戚以朋党心。往婆罗门家及长者所。作如是说赞彼愚人。于法于义能知能解。明达根欲善为人说。受他信施曾无惭愧。以谤法故身及眷属俱堕地狱。文殊师利。我终不为无信之人说菩萨行。亦不为贪着在家之人说清净法。不为二见之人说解脱法。不为一见之人说出苦法。不为乐世之人说真净法。文殊师利。我于恒河沙等法门。以无著心为人演说。又于恒河沙等法门。以有着心为众生说。若有乐空众生为说空法。若有乐智众生为说智法。若有乐无相众生为说无相法。若有乐有相众生说有相法。若有乐慈众生为说慈法。若有乐因缘众生说因缘法。若有乐无因缘众生说无因缘法。此是有威仪法此是无威仪法。此是空法此是有法。此是有为法此是无为法。此是摄受法此是覆盖法。此是凡夫法此是圣人法。此是色法此是不善法。此是愚人法此是定法。佛告文殊师利。如是等一切法是般若波罗蜜道。彼愚痴人在所言说。不依如来真净教法谤佛正法

尔时文殊师利童子白佛言。世尊。如佛所说。如是愚人以近恶友现身起谤。如是世尊。以何因缘能免斯咎。佛告文殊师利。我于往昔七年之中。昼夜六时忏悔身口及与意业所作重罪。从是已后乃得清净。经十劫已获得法忍。文殊师利。当知此经是菩萨乘。未觉悟者能令觉悟。闻说此经若不信受。以此谤因堕于恶道。是诸菩萨明受我法。然后乃可为人宣说。如是受持能远恶趣。佛告文殊师利。有四平等法。菩萨当学。云何为四。一者菩萨于一切众生平等。二者于一切法平等。三者于菩提平等。四者于说法平等。如是等四法。菩萨当知是四种法。菩萨知已为众生说。若有信者远离恶趣。若不信者当堕恶道。若善男子善女人住此四法。当知是人不堕恶趣。复有四法。云何为四。一者于诸众生心无退转。二者于诸法师而不轻毁。三者于诸智人心不生谤。四者于诸如来一切所说恒生尊重。如是四法若有善男子善女人能善修学。终不堕于诸恶趣中

复次文殊师利。菩萨以恒河沙等诸佛刹土满中七宝。于恒河沙劫日日奉施恒河沙等诸佛世尊。若有善男子善女人。能于如是大乘方广微妙经典乃至一句一偈。读诵三遍所获功德。胜前布施所得功德。若有诵持此经典者。所获功德倍多于彼。设复有人修行布施持戒忍辱精进禅定智慧。六波罗蜜所得功德亦不能及。文殊师利。如此经典名义广大无与等者。汝诸菩萨摩诃萨应善修学受持读诵广为众生分别解说。尔时一切大众乃至十方诸来菩萨摩诃萨等俱白佛言。世尊。如是如是。如佛所说我等受持。说此法时三十恒河沙诸菩萨等得无生法忍。七十恒河沙诸菩萨等于阿耨多罗三藐三菩提得不退转。复有六十三亿百千那由他三千大千世界一切大众。闻佛所说心生欢喜。于八十劫度生死流。复于阿耨多罗三藐三菩提不退转。经六十三劫已具足成就无上菩提。彼诸菩萨及一切大众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻佛所说皆大欢喜作礼奉行大乘方广总持经


大法鼓经卷上

    No. 270 [No. 271]

大法鼓经卷上

        宋天竺三藏求那跋陀罗译

如是我闻。一时佛住舍卫国祇树给孤独园。与大比丘众五百人俱。复有百千大菩萨众。复有众多天龙夜叉健闼婆众。复有百千诸优婆塞优婆夷众。复有娑婆世界主梵天王及天帝释四天王众。复有十方世界无量比丘比丘尼优婆塞优婆夷诸菩萨俱。尔时如来。于彼四众说如是法。有有则有苦乐。无有则无苦乐。是故离苦乐。则是涅槃第一之乐。彼五百声闻比丘。一切皆是阿罗汉。诸漏已尽无复烦恼。心得自在。譬如大龙。心得好解脱慧得好解脱所作已辨。已舍重担。逮得己利。尽诸有结。正智心解脱。得一切心自在第一波罗蜜。有无量学人。皆得须陀洹斯陀含阿那含果。有成就有漏法无量比丘众。有成就无量阿僧祇功德菩萨摩诃萨。徒十方来。算数譬喻所不能及。亦非一切声闻缘觉之所能知。除文殊师利菩萨。及大力菩萨。观世音菩萨。弥勒菩萨摩诃萨。如是上首菩萨摩诃萨无量阿僧祇众。譬如大地所生草木。从诸方来诸菩萨众。亦复如是。不可称数。复有差摩比丘尼。与比丘尼众俱。毗舍佉鹿子母。及末利夫人。各与无量大眷属俱。须达长者。与诸优婆塞俱。尔时世尊。于大众中说有非有法门

尔时波斯匿王。从卧而起作是思惟。我今应往至世尊所。念已即行。击鼓吹贝。往诣佛所。尔时世尊。知而故问。阿难。以何等故有鼓贝声。阿难白佛言。波斯匿王来诣佛所。是其击鼓吹贝之声。佛告阿难。汝今亦应击大法鼓。我今当说大法鼓经。阿难白佛言。世尊。是大法鼓经名。我未曾闻。以何等故。名大法鼓经。佛告阿难。汝何由知。是诸来会大菩萨等。悉不能知此大法鼓经六字名号。何况于汝而得闻知。阿难白佛言。世尊。未曾有也。此法名号真实难知。如是阿难。实尔不异。阿难。此大法鼓经。世间希有。如优昙钵华。阿难白佛言。非一切诸佛有此法耶。佛告阿难。三世诸佛悉有此法。阿难白佛言。若然者。彼诸菩萨人中之雄。何故悉来。普集于此。彼诸如来。何故自于其国不演说耶。佛告阿难。如有一阿练比丘隐居山窟。至时入村方欲乞食。道见人兽诸杂死尸。见已生厌。断食而还。呜呼苦哉。吾亦当然。彼于异时。心得快乐。作是思惟。我当更往观察死尸。令增厌离。复向聚落求见死尸。修不净想。见已观察。得阿罗汉果。如是他方诸佛。不说无常苦空不净。所以者何。诸佛国土法应如是。彼诸如来。为诸菩萨作如是说。奇哉难行释迦牟尼世尊。于五浊国土出兴于世。为苦恼众生。种种方便。说大法鼓经。是故诸善男子。当如是学。彼诸菩萨。咸欲见我恭敬礼拜。故来会此。既来会已。或得初住。乃至十住。是故大法鼓经。甚难值遇。是故十方大菩萨众。为闻法故普皆来集。阿难白佛言。善哉善哉。一切善来。彼悉得此难得经法。佛告阿难。如是深经。非一切共。是故不应说言一切善来。阿难白佛言。何故彼非一切善来。佛告阿难。此经典者。是诸如来。秘密法藏。甚深微妙。难解难信。是故阿难。不应说言一切善来。阿难白佛言。非如波斯匿王。临阵斗时。击大战鼓。其闻声者一切箭落耶。佛告阿难。波斯匿王击鼓战时。非彼一切闻鼓声喜。有怯弱者闻而恐怖。若死近死。如是阿难。此大法鼓经名。是二乘之人不信法门。是故阿难。譬如彼王。至斗战时。击王大鼓。此大法鼓。诸佛秘密。佛出世时。尔乃演说

尔时世尊告大迦叶。此诸比丘清净纯一。真实强力离诸糟糠。堪任闻此大法鼓经不。迦叶白佛言。若有比丘犯戒违律。是大目连之所呵责。有如是比。我不同行。况复世尊。今此会众。如栴檀林。清净纯一。佛告迦叶。今此会众。虽复一切清净纯一。然于隐覆之说有不善解。迦叶白佛言。云何名为隐覆之说。佛告迦叶。隐覆说者。谓言如来毕竟涅槃。而实如来常住不灭。般涅槃者非毁坏法。此修多罗离覆清净。明显音声。百千因缘。分别开示。是故迦叶。当更观察此诸大众。时大迦叶。即复观察彼诸来者。云何而来。时刹那顷。下信众生。及声闻缘觉。初业菩萨。自惟不堪。生退舍心。譬如王家力士。众中有名千力士者。从座而起击鼓唱言。谁能堪任与我斗力。其不堪者默然而住。心自念言。我不堪任与彼斗力。或能伤损以致失命。于彼众中无敢敌者。乃名勇健。难伏力士。建大胜幡。如是下劣众生。及声闻缘觉。初业菩萨。作是念言。我不堪任听受。如来已般涅槃。而复说言。常住不灭。于大众中。闻所未闻。从坐而去。所以者何。彼人长夜。于般涅槃。修习空见。闻离隐覆清净经故。从坐而去。彼十方来声闻缘觉初业菩萨。百千万亿阿僧祇分。余一分住。谓彼菩萨摩诃萨信解法身常住不变者。尔乃安住受持一切如来藏经。亦能解说安慰世间解知一切隐覆之说。善观一切了义不了义经。悉能降伏毁禁众生。尊敬承顺清净有德。于摩诃衍得大净信。不于二乘起奇特想。除如是等方广大经。不说余经。唯说如来常住及有如来藏。而不舍空。亦非身见空。空彼一切有为自性

佛告迦叶。汝更问大众。咸欲得闻此大法鼓方广一乘。所谓大乘难信经不。如是至三。迦叶白佛言。善哉世尊。即从坐起。偏袒右肩。右膝着地。顶礼佛足。右绕三匝已。告诸大众。咸欲闻此大法鼓经不。如来今当普为汝等演说一乘。所谓大乘。过一切声闻缘觉境界。如是三说。彼悉答言。愿乐欲闻。唯大迦叶。我等悉为闻法故来。善哉哀愍。当为我说大法鼓经。迦叶复言。汝等云何信。彼即答言。譬如士夫年甫二十有百岁子。若佛如是说者。我等亦当如是随信。况说正法。而不信受。所以者何。如来如说而行。如来净眼圆照无阂。以佛眼观知我等心。迦叶叹言。善哉善哉。诸贤汝等。堪任听大法鼓经。若持若说。佛告迦叶。譬如士夫年甫二十有百岁子。大法鼓经亦复如是。所以者何。如来涅槃而复常住。一切无我而复说我。彼即白言。唯佛能知。如世尊所说。我等如是受持

迦叶白佛。唯愿世尊。说大法鼓经。击大法鼓吹大法蠡。佛言。善哉善哉。迦叶。汝今听说大法鼓经。迦叶白佛言。唯然受教。何以故。是我境界故。是故如来大见敬待。云何为敬。曾告。我言。汝来共坐。以是因缘我应知恩。佛言。善哉迦叶。以是义故。我敬待汝。迦叶。譬如波斯匿王。善养四兵。若斗战时。击大战鼓。吹大战蠡。对敌坚住。缘斯恩养。战无遗力。能胜怨敌。国境安宁。如是比丘。我般涅槃后。摩诃迦叶。当护持此大法鼓经。以是义故。我分半坐。是故彼当行我所行。于我灭后。堪任广宣大法鼓经。迦叶白佛言。我是世尊口生长子。佛告比丘。譬如波斯匿王。教诸王子。学诸明处。彼于后世。堪绍王种。如是比丘。于我灭后。迦叶比丘。护持此经亦复如是

复次迦叶。如波斯匿王。多与诸王。共为怨敌。更相攻伐。于彼彼时。其诸战士。象马车步。四种兵众。闻大鼓声。心不恐怖坚持甲仗。时王恩恤。多所赐赍。及当战时。加赐珍宝。及以城邑。若能克敌。冠以素缯。封以为王。如是迦叶。我诸声闻比丘比丘尼优婆塞优婆夷。如戒随学波罗提木叉成就善住律仪。如来则与人天安乐。其有大功降四魔者。以四真谛解脱素缯。而冠其首。若有增上信解。求佛藏大我常住法身者。如来尔时以萨婆若。水而灌其顶。以大乘素缯。而冠其首。大迦叶。我今亦复如是。以大乘素缯用冠汝首。汝于未来无量佛所。当护持此经。迦叶当知。汝于我灭后。堪任护持如是经典。迦叶白佛言。当如尊教。复白佛言。我从今日及灭度后。常当护持广说此经

佛告迦叶。善哉善哉。今当为汝说大法鼓经。时虚空中。诸天龙众。同声叹言。善哉善哉迦叶。今日诸天。大雨天华。诸龙王众。雨甘露水。及细末香。安慰悦乐一切众生。应为世尊之所建立为法长子。时天龙众。同声说偈

  王于舍卫城　　伐鼓吹战蠡
  法王祇洹林　　击于大法鼓

佛告迦叶。汝今当以问难之桴击大法鼓。如来法王。当为汝说天中之天。当决汝疑

尔时世尊告大迦叶。有比丘名信大方广。若有四众。闻其名者。贪恚痴箭悉皆拔出。所以者何。迦叶。譬如波斯匿王。有耆婆子。名曰上药。若波斯匿王。与敌国战时。告上药言。汝今速持能为众生拔箭药来。尔时上药。即持消毒药。王以涂战鼓。若涂若熏若打。若彼众生。被毒箭者。闻其鼓声。若一由旬。若二由旬。箭悉拔出。如是迦叶。若有闻信方广比丘名者。贪恚痴箭悉皆拔出。所以者何。彼因此经增广正法以彼现法成就故。得此大果。大迦叶。汝当观彼无心凡鼓。以无心药。若涂若熏若打。有如是力饶益众生。况复闻彼菩萨摩诃萨信方广比丘名。而不能除众生三毒。迦叶白佛言。若闻菩萨名者。能除众生三种毒箭。况称世尊名号功德。言南无释迦牟尼。若称叹释迦牟尼名号功德。能拔众生三种毒箭。况复闻此大法鼓经。安慰演说若偈若句。况复广说。而不能拔三种毒箭

佛告迦叶。如我先说。净戒比丘。随心所欲。以本愿故。一切诸佛。皆有是法。所谓不作不起不灭。大法鼓经。是故迦叶。汝于来世。亦当如我。所以者何。若有四众。闻汝名者。三种毒箭悉得拔出。是故迦叶。汝今当问。大法鼓经。于我灭后。久于世间。护持宣布。迦叶白佛言。善哉世尊。今当为我说大法鼓经。佛告迦叶。汝于大法鼓经。应少咨问。尔时迦叶。即白佛言。善哉世尊。当请所疑。如世尊所说。若有有则有苦乐。无有则无苦乐。此有何义。佛告迦叶。若无有者。谓般涅槃第一之乐。是故离苦乐。得般涅槃第一之乐。若苦若乐。彼则是有。若无有者。则无苦乐。是故欲得般涅槃者。当求断有。尔时世尊。欲重宣此义。而说偈言

  一切有无常　　亦无不变异
  彼有有苦乐　　无有无苦乐
  不为无苦乐　　为则有苦乐
  莫乐诸有为　　亦勿更习近
  若人得安乐　　还复坠于苦
  若不到涅槃　　不住安乐处

尔时迦叶。以偈答言

  众生不为有　　涅槃第一乐
  彼则名字乐　　无有受乐者

尔时世尊。复说偈言

  常解脱非名　　妙色湛然住
  非声闻缘觉　　菩萨之境界

迦叶白佛言。世尊。云何言色而复常住。佛告迦叶。今当说譬。譬如士夫。从南方摩头逻来。有人问彼。汝从何来。士夫答言。从摩头逻来。即复问言。摩头逻为在何方。时彼士夫。即指南方。迦叶。非为彼人于此得信耶。所以者何。以是士夫自见彼来故。如是迦叶。以我见故。汝当信我。尔时世尊。即说偈言

  譬如有士夫　　以手指虚空
  我今亦如是　　名字说解脱
  譬如彼士夫　　远自南方来
  今我亦如是　　从彼涅槃出

然彼迦叶。若见义者。则不须因缘。若不见义。则须因缘。如是迦叶。诸佛世尊。常以无量因缘显示解脱。迦叶白佛言。云何为因。佛告迦叶。因者是事。迦叶白佛言。云何为缘。佛告迦叶。缘者是依。迦叶白佛言。愿更显示。其譬云何。佛告迦叶。如由父母而生其子。母则是因。父则是缘。是故父母因缘生子。如是说因缘住法。是名为成。迦叶白佛言。成者有何义。佛告迦叶。成者世间成。迦叶白佛言。云何世间。佛告迦叶。众生和合施设。迦叶白佛言。云何众生。佛告迦叶。法集施设。迦叶白佛言。云何为法

佛告迦叶。非法亦法。法亦非法。法者复有二种。何等为二。有为及无为。色及非色。更无第三法。迦叶白佛言。法何像类。佛告迦叶。法者非色。迦叶白佛言。非法何类。佛告迦叶。非法者亦非色。迦叶白佛言。若法非法非色无相。云何是法。云何非法。佛告迦叶。法者是涅槃。非法者是有。迦叶白佛言。若法非法非色无相者。彼慧者。云何知。何所知。何故知彼相耶。佛告迦叶。众生生生死中。习种种福德清净善根。是其正行。若彼行如是法。一切净相生。若行此法者。是法众生。众生生生死中。行种种非福恶不善业。若彼行如是非法。一切恶不净相生。若行此非法者。是非法众生

迦叶白佛言。世尊。云何众生。佛告迦叶。众生者四界摄施设。谓内地界水界火界风界。及入处五根。乃至十三缘起支。(无尽意经中云从不正思惟生无明故十三支)受想思心意识。是名众生法。迦叶当知。是名一切法。迦叶白佛言。是中何等法是众生佛告迦叶。是中非一法名为众生。所以者何。迦叶。譬如波斯匿王鼓。何等为鼓。迦叶白佛言。所言鼓者。皮木及捊。此三法和合。是名为鼓。佛告迦叶。如是和合施设。名为众生。迦叶白佛言。声鼓者非鼓耶。佛告迦叶。离声鼓者。鼓亦有声。以风动故。迦叶白佛言。鼓者为是法。为是非法耶。佛告迦叶。鼓者非法非非法。迦叶白佛言。名为何等。佛告迦叶。非法非非法者。名为无记。迦叶白佛言。有无记法者。世间应有三法。佛告迦叶。无记相者。如非男非女。非男非女。名为不男。彼亦如是。迦叶白佛言。如世尊说。父母和合而生其子。若父母无众生种子者。不为父母因缘。佛告迦叶。彼无众生种子者。名为涅槃。大常不男亦复如是。所以者何。譬如波斯匿王。与敌国战时。彼诸战士。食丈夫禄。不勇猛者。不名丈夫。如是无众生种子者。不名父母。常不男者亦复如是

迦叶白佛言。世尊。善法不善法无记法。何者善法。何者不善法。何者无记法。佛告迦叶。乐受是善法。苦受是不善法。不苦不乐受是无记法。此三法众生常触。乐受者。谓天人五欲功德。苦受者。谓地狱畜生饿鬼阿修罗。不苦不乐受者。谓白癣等。迦叶白佛言。此则不然。佛告迦叶。从乐生苦。从苦生苦。彼为无记。迦叶白佛言。其譬如何。佛告迦叶。因食生病。食则是乐。病则是苦。彼白癣等。名为无记。迦叶白佛言。若苦乐名无记者。父母子亦无记。佛告迦叶。此则不然。迦叶白佛言。其譬如何。佛告迦叶。如非想非非想等天乃至无想。则恒住子法。善亦如是。迦叶白佛言。世尊。如佛所说。受想是众生。是故非想非非想处。应非众生。佛告迦叶。彼有行分。我说此众生法者。除无想天。迦叶白佛言。众生为是色为非色耶。佛告迦叶。众生亦非色亦非非色。然成就彼法名为众生。迦叶白佛言。若如是。非众生成就法。更有异众生者。不应有无色天。若然者。无二法世间色及无色

佛告迦叶。法亦非色。非法亦非色。迦叶白佛言。云何为法与解脱俱。为非法与解脱俱。无色天亦有解脱。佛告迦叶。不然。唯有为法无为法。是故无色天。是有为数。解脱是无为。无色天有色性耳

迦叶白佛言。世尊。一切有为是色。非色是无为。无色天有色者。是佛境界。非我等境界。佛告迦叶。善哉善哉。是我境界。非汝等境界。如是诸佛世尊。到解脱者。彼悉有色解脱亦有色

佛告迦叶。云何无色天。天处所作汝知不。迦叶。云何有色天。名无色数不。迦叶白佛言。非我等境界。佛告迦叶。如是诸佛世尊。到解脱者皆有色。汝当观察

迦叶白佛言。世尊。若如是得解脱者。复应受苦乐。佛告迦叶。如有病众生。服药离病已。还复病耶。迦叶白佛言。若有业者。则必有病。佛告迦叶。无业者彼有病耶。迦叶白佛言。不也。世尊。佛告迦叶。如是离苦乐是解脱。当知苦乐是病。如丈夫是得涅槃者。迦叶白佛言。若离苦乐是解脱者。无业病尽耶。佛告迦叶。世间乐者彼则是苦。于彼出离如是业尽得解脱。迦叶白佛言。不复终尽耶。佛告迦叶。譬虚空如海。虚空如海耶。虚空无譬解脱无譬。亦复如是。如无色天有色而不可知。亦不可知似此似彼。如是住如是游戏。非是声闻缘觉境界。解脱亦如是

迦叶白佛言。世尊。一切众生谁之所作。佛告迦叶众生自作。迦叶白佛言。此义云何。佛告迦叶。作福者佛。作恶者众生。迦叶白佛言。最初众生谁之所作。佛告迦叶。非想非非想等无色天。谁之所作。云何活云何住。迦叶白佛言。于彼诸业所不能知。然唯业作。如是众生。生死黑及涅槃白。谁之所作。佛告迦叶。业之所作。业起无量法。善起无量法。迦叶白佛言。何者业起。何者善起。佛告迦叶。业起者有。善起者解脱。迦叶白佛言。无生处云何善起。佛告迦叶。如如不异。迦叶白佛言。若善起者。云何到无生处。佛告迦叶。行善业。迦叶白佛言。谁之所教。佛告迦叶。无始佛教。迦叶白佛言。一切无始佛谁化谁教。佛告迦叶。无始者。非一切声闻缘觉思量所知。若有士夫出于世间。智慧多闻如舍利弗。长夜思惟终不能知。佛之无始谁最为先。乃至涅槃中间亦不能知。复次迦叶。如大目连。以神通力。求最初佛世界。无始终不能得。如是一切声闻缘觉十地菩萨。如弥勒等悉不能知。如佛元起难可得知。众生元起亦复如是。迦叶白佛言。是故世尊。无有作者无有受者。佛告迦叶。因是作者受者。迦叶白佛言。世间为有尽耶。为无尽乎。佛告迦叶。世间未曾尽。无所尽无尽时。佛告迦叶。如以一毛渧大海水。能令尽不。迦叶白佛言。唯然能尽。佛告迦叶。乃往过去无量阿僧祇大劫时。有佛名鸡罗婆。出兴于世。广说法教。尔时城中有离车童子。名一切世间乐见。作转轮圣王正法治化。王与百千大眷属俱。往诣佛所。顶礼佛足。右绕三匝。供养毕已。而白佛言。我当久如得菩萨道。佛告大王。转轮圣王。即是菩萨。更无有异。所以者何。无有余人作帝释梵王及转轮圣王。若菩萨者。即是释梵转轮圣王。先作众多帝释梵王。然后乃作转轮圣王正法治化。汝已曾作恒沙阿僧祇帝释梵王。今作转轮圣王。时王白言。帝释梵王。何所像类。佛告大王。释梵天王。亦如汝今首着天冠。而彼端严。则不及汝。如佛色像端严殊特。非声闻缘觉菩萨所及。如佛端严。汝亦如是。迦叶。尔时圣王复问佛言。我于久如当得成佛。佛言大王。凡得佛者。时大久远。所以者何。假令大王。舍其福德。还为凡人。而以一毛渧大海水。乃至将竭。余如牛迹。当有如来出兴于世。名曰灯光如来应供等正觉。时有国王。名地自在。灯光如来为王授记当得作佛。汝于尔时。当为彼王第一长子。亦俱授记。时彼如来。当如是说。大王。汝此长子。从昔暨今。大海将尽。生为汝子。于其中间。不为小王。或为释梵转轮圣王。正法治化。汝此长子。勇猛精进如是。地自在。菩提难得。以是因缘故说此譬。地自在。汝此长子。有六万婇女。端正姝好璎珞庄严。状如天女。弃之如唾。知欲无常危脆不坚。我当出家。作是语已。信家非家。舍家学道。是故彼佛记此童子。当来有佛。名释迦牟尼。世界名忍。汝童子。名一切世间乐见离车童子。佛涅槃后正法欲灭。余八十年。作比丘持佛名宣扬此经。不顾身命。百年寿终。生安乐国。得大神力。住第八地。一身住兜率天。一身住安乐国。复化一身。问阿逸多佛。此修多罗。时地自在王。闻子授记。欢喜踊跃。今日如来。记说我子。得八住地。时彼童子。闻授记声。勤加精进。迦叶白佛言。是故世尊。毛渧大海。犹尚可尽。佛告迦叶。此义云何。迦叶白佛言。世尊。譬如商人。计数金钱。置一器中。其子啼时。授与一钱。彼器中钱。日日损减。如是菩萨摩诃萨。于大海水渧渧损减。悉能知之。亦知余在。况复世尊。于众生大聚尽而不知。但诸众生无有减尽。一切声闻缘觉所不能知。唯佛世尊乃能知耳。佛告迦叶。善哉善哉。如汝所说。众生大聚。无有尽时。迦叶白佛言。众生般涅槃者。为有尽耶。为无尽耶佛告迦叶。众生无有尽也。迦叶白佛言。云何众生不尽。佛告迦叶。若众生尽者。应有损减。此修多罗。则为无义。是故迦叶。诸佛世尊。般涅槃者。悉皆常住。以是义故。诸佛世尊。般涅槃者。然不磨灭。迦叶白佛言。云何诸佛般涅槃。不毕竟灭。佛告迦叶。如是如是。舍坏则为虚空。如是如是诸佛涅槃。即是解脱

大法鼓经卷上大法鼓经卷下

        宋天竺三藏求那跋陀罗译

尔时世尊。告大迦叶。譬如有王能行布施。彼王国中多出伏藏。所以者何。以彼国王种种周给贫苦众生。是故伏藏自然发出。如是迦叶。大方便菩萨。广为众生说甚深法宝故。得此甚深离非法经。谓空无相无作相应经。复得如是如来常住。及有如来藏经。迦叶。如郁单越。自然之食。众共取之。无有损减。所以者何。以彼尽寿。无我所想及悭贪想。如是迦叶。此阎浮提。比丘比丘尼优婆塞优婆夷。得此深经。书持读诵究竟通利广为人说。终不疲厌不疑不谤。以佛神力。常得自然如意供养。乃至菩提无乏无尽。除定报业。如持戒比丘。不缓持戒。终身天神随侍供养。若彼能于如是深经。乃至不起一念谤想。当得如来藏如来常住。常见诸佛亲近供养。如转轮圣王。凡所游行七宝常随。如是安慰说者所住之处。如是比经常与彼俱。如转轮圣王所住之处。七宝随住不住余处。其非真宝住于余处。如是安慰说者。现在所住如是比经。悉从他方来至其所。诸不了义空相应经于余处住。如是安慰说者所住至方此经常随。如转轮圣王所游之处。诸余众生随顺王者。作如是念。彼王所住。我亦应去。如是安慰说者所住之处。如是比经亦复常随。如转轮圣王出于世时。七宝随出。如是安慰说者出于世间。如是比经亦随出现。如转轮圣王所有七宝。若失一宝。彼王寻求。必至宝所。如是安慰说者。为闻此经处处寻求。要至经所

复次如转轮圣王不出世时。诸余小王力转轮王。和合诸王各现于世。如是诸方。无人演说此深经处。余杂说者。说诸杂经。所谓正不正杂经。彼诸众生。亦如是随学。彼随学时。闻此如来藏如来常住究竟深经。心生疑惑。于安慰说者。生恚害心。轻贱嗤笑。不生爱念。骂辱不忍。作如是说。此将文笔。魔之所说。谓为毁法。悉弃舍去各还本处。更相破坏犯戒邪见。终不能得如是比经。所以者何。安慰说者所住之处。此经随住故。尔时世间多有众生。见闻摩诃衍经。而生诽谤。莫生恐畏。所以者何。五浊世时。正法损减。多有众生谤摩诃衍。如七家村中必出茶夷尼鬼。如是比经所行之处。七人众中必有谤者。迦叶。譬如同戒之人。相见欢喜。彼亦如是。各各毁戒。于说法众中。闻是经时。更相瞻视。作戏笑言。何者众生界。何者为常瞻彼颜色。作是思惟。彼是我伴。更相慈愍。如是作已。守性而住。守性而去。如婆罗门长者种性。生子习恶。父母训诫。曾不改悔。舍家而去。随逐恶友。斗诸鸟兽。以为戏乐。如是展转。乃至他国。要结同类。共为非法。是为同行。不乐此经者亦复如是。见他诵说而反戏笑。所以者何。尔时众生。并多懈怠。持戒宽缓。为法留难。彼诸同行相随诽谤。迦叶白佛言。呜呼真是恶时

佛告迦叶。至于尔时安慰说者。当如之何。迦叶。譬如城邑边近路之田。为诸人众象马侵食。彼时田主。使一人监视。监视之人不勤守护。复更增足二三四五。若十二十乃至百人。守者逾多。取者弥众。最后一人作是思惟。如此守视非一切护。当善方便令无侵害。即取田苗手自惠施。彼生感愧田苗得全。迦叶。若能如是。善方便者。于我灭后能护此经

迦叶白佛言。世尊。我终不能摄彼恶人。宁以两肩荷负须弥至百千劫。不能堪忍听彼恶人犯戒灭法谤法污法。如是诸恶非法音声。世尊。我宁属他为其仆使。不能堪忍听彼恶人犯戒背法远法坏法。如是诸恶非法音声。世尊。我宁顶戴大地山海经百千劫。不能堪忍听彼恶人犯戒灭法自高毁他。如是诸恶非法音声。世尊。我宁恒受聋盲喑哑。不能堪忍听彼恶人毁犯净戒。为利出家受他信施。如是诸恶非法音声。世尊。我宁舍身疾般涅槃。不能堪忍听彼恶人犯毁净戒蠡声之行。而身行谄曲口言虚妄。如是诸恶非法音声。佛告迦叶。汝般涅槃。是声闻般涅槃。非为究竟。迦叶白佛。言若声闻缘觉般涅槃非究竟者。世尊何故。说有三乘声闻乘辟支佛乘佛乘。世尊云何已般涅槃复般涅槃耶。佛告迦叶。声闻以声闻般涅槃。而般涅槃非为究竟。辟支佛以辟支佛般涅槃。而般涅槃亦非究竟。乃至得一切种功德。一切种智大乘般涅槃。然后究竟无异究竟

迦叶白佛言。世尊。此义云何。佛告迦叶。譬如从乳出酪。酪出生酥。生酥出熟酥。熟酥出醍醐。凡夫邪见如初生乳。乳血共杂。受三归者犹如纯乳。随信行等。及初发心菩萨。住解行地。犹如成酪。七种学人及七地住菩萨。犹如生酥。意生身阿罗汉辟支佛得自在力。及九住十住菩萨犹如熟酥。如来应供等正觉。犹如醍醐

迦叶白佛言。世尊。如来云何说有三乘。佛告迦叶。譬如导师。勇猛雄杰。将诸亲属及余人众。从其所住欲至他方。经由旷野崄难恶道。作是思惟。此众疲乏。将恐退还。为令诸人得止息故。于其前路化作大城。遥以指示语诸大众。前有大城当速至彼。诸众悉见渐近彼城。各相谓言。是我息处。即共入城休息快乐。乐于中住不欲前进。尔时导师作是思惟。此诸大众得此小乐。便以为足。羸劣休懈无前进意。尔时导师即灭化城。彼诸大众见城灭已。白导师言。此为何等。为幻为梦。为真实耶。导师闻已。即告大众。向者大城。为止息故我化作耳。更有余城。今所应往。宜速至彼快乐安隐。大众答言。唯然受教。何缘乐此鄙陋小处。当共前进安乐大城。导师告言。善哉当行。即共前进。复告大众。所往大城先相已现。汝当观察。彼前大城极甚丰乐。以渐前行见彼大城。尔时导师告诸大众。诸仁当知。此是大城。时诸大众。遥见大城。安隐丰乐。心得欢喜。各共相视生希有心。此城为实为复虚妄。导师答言。此城真实。一切奇特安隐丰乐。即告彼众入此大城。此则第一究竟大城。过此处已更无余城。彼诸大众俱入城已。生希有心。心得欢喜。叹彼导师。善哉善哉。真实大智。大悲方便哀愍我等。迦叶当知。彼初化城。谓声闻缘觉乘清净智慧。空无相无作解脱之智。真实大城。是如来解脱。是故如来。开示三乘。现二涅槃。又说一乘。佛告迦叶。若有说言无此经者。非我弟子。我非彼师

迦叶白佛言。世尊。诸摩诃衍经。多说空义。佛告迦叶。一切空经是有余说。唯有此经是无上说。非有余说。复次迦叶。如波斯匿王。常十一月设大施会。先食饿鬼孤独贫乞。次施沙门及婆罗门。甘膳众味随其所欲。诸佛世尊亦复如是。随顺众生种种欲乐。而为演说种种经法。若有众生。懈怠犯戒不勤修习。舍如来藏常住妙典。好乐修学种种空经。或随句字说。或增异句字。所以者何。彼如是言。一切佛经皆说无我。而彼不知空无我义。彼无慧人趣向灭尽。然空无我说亦是佛语。所以者何。无量尘垢诸烦恼藏。常空涅槃。如是涅槃是一切句。彼常住安乐。是佛所得大般涅槃句。迦叶白佛言。世尊。云何离于断常。佛告迦叶。乃至众生轮回生死我不自在。是故我为说无我义。然诸佛所得大般涅槃常住安乐。以是义故。坏彼断常。迦叶白佛言。世尊。再转无我转我久矣

佛告迦叶。为破世间我故说无我义。若不如是说者。云何令彼受大师法。佛说无我。彼诸众生。生奇特想。闻所未闻。来诣佛所。然后以百千因缘令入佛法。入佛法已。信心增长。勤修精进善学空法。然后为说常住安乐有色解脱。复次或有世俗说有是解脱。为坏彼故。说言解脱悉无所有。若不如是说。云何令彼受大师法。是故百千因缘。为说解脱灭尽无我。然后我复见彼众生。见毕竟灭以为解脱。彼无慧人趣向灭尽。然后我复百千因缘。说解脱是有

迦叶白佛言。世尊。得解脱自在者。当知众生必应有常。譬如见烟必知有火。若有我者必有解脱。若说有我。则为已说解脱有色。非世俗身见。亦非说断常

迦叶复白佛言。世尊。云何如来。不般涅槃示般涅槃。不生示生。佛告迦叶。为坏众生计常想故。如来不般涅槃示般涅槃。不生示生。所以者何。众生谓佛尚有终没不得自在。何况我等有我我所。譬如有王。为邻国所执。系缚枷锁。作是思惟。我今复是王是主耶。我今非王非主。何缘乃致如是诸难。由放逸故。如是众生。乃至生死轮回。我不自在。不自在故。说无我义。譬如有人。为贼所逐。举刀欲害。作是思惟。我今无力。当得免此死难。以不如是生老病死种种众苦成就众生思想。愿作帝释梵王。如来为坏彼思想故。示现有死。如来是天中之天。若般涅槃悉磨灭者。世间应灭。若不灭者。则常住安乐。常住安乐。则必有我。如烟有火。若复无我。而有我者。世间应满实有我非。无我亦不坏。若实无我。我则不成。迦叶白佛言。世尊。有者何耶。佛告迦叶。有者。二十五有众生行。非有者。无思之物。若非有是众生者。应从他来。设有思之物坏者。众生当减。若非有是众生者。则应充满。以众生不生不坏故。不减不满。迦叶白佛言。世尊。若有我者。云何生彼烦恼诸垢。佛告迦叶。善哉善哉。应以是问。问于如来。譬如金师见彼金性。作是思惟。如此金性何由生垢。今当推寻生垢之本。彼人云何为得本不。迦叶白言。不也世尊。佛告迦叶。若尽寿思惟寻初因相。乃至无始得本际不。既不得本亦不得金。若巧方便精勤不懈。除彼金垢尔乃得金。佛告迦叶。如是我者。生客烦恼。欲见我者。作是思惟。今当推寻我及垢本。彼人云何为得本不。迦叶白佛言。不也世尊。佛告迦叶。若勤方便除烦恼垢。尔乃得我。谓闻如是比经。深心信乐不缓不急。善巧方便专精三业。以是因缘尔乃得我

迦叶复白佛言。世尊。若有我者何故不见。佛告迦叶。今当说譬。譬如初学。学五字句。界成句偈。欲先知义。然后乃学。当得知不。要当先学。然后乃知。彼善学已。然后师教。界成句义。引譬示之。彼能听受。缘师得解界成句义故。则能信乐。如是我今。为烦恼藏所覆。众生说言善男子。如来藏如是如是。彼便欲见。当得见不。迦叶白言。不也世尊。佛告迦叶。如彼不知界成句义。当缘师信如是。迦叶当知。如来是诚实语者。以诚实语说有众生。汝后当知。如彼学成。今当为汝更说譬喻。如四种众生界隐覆譬喻。所谓。肤翳覆眼。重云隐月。如人穿井。瓶中灯焰。当知此四有佛藏因缘。一切众生悉有佛性。无量相好庄严照明。以彼性故。一切众生得般涅槃。如彼眼翳是可治病。未遇良医。其目常冥。既遇良医。疾得见色。如是无量烦恼藏。翳障如来性。乃至未遇诸佛声闻缘觉。计我非我我所为我。若遇诸佛声闻缘觉。乃知真我。如治病愈。其目开明。翳者谓诸烦恼。眼者谓如来性。如云覆月。月不明净。诸烦恼藏覆如来性。性不明净。若离一切烦恼云覆。如来之性净如满月。如人穿井。若得干土知水尚远。得湿土埿知水渐近。若得水者。则为究竟。如是值遇诸佛声闻缘觉。修习善行掘烦恼土。得如来性水。如瓶中灯焰。其明不现。于众生无用。若坏去瓶。其光普昭。如是诸烦恼瓶。覆如来藏灯。相好庄严则不明净。于众生无用。若离一切诸烦恼藏。彼如来性烦恼永尽。相好照明施作佛事。如破瓶灯众生受用。如此四种譬喻因缘。如我有众生界。当知一切众生。皆亦如是。彼众生界无边明净

迦叶白佛言。世尊。若一切众生。有如来藏一性一乘者。如来何故。说有三乘声闻乘缘觉乘佛乘。佛告迦叶。今当说譬。如巨富长者。唯有一子。随乳母行。于大众中亡失所在。长者临终作是思惟。我唯一子久已亡失。更无余子。父母亲属。若我一旦终没之后。一切财物王悉取去。于思惟顷。本所失子。游行乞求。到其本家。而不自知是其父舍。所以者何。幼少失故。父见识之。而不言子。所以者何。虑怖走故多与财物。而语之言。我无子息。为我作子。勿复余行。彼子答言。不堪住此。所以者何。住此常苦如被系缚。长者谓言。汝欲何作。子复答言。宁除众秽放牧田作。长者念言。此子薄福。我当知时。且随彼意。即令除粪。其子久后。见大长者五欲自娱。心生欣乐。作是思惟。愿大长者。时见哀纳多赐财宝。以我为子。作是念已。不勤作务。长者见已。作是思惟。如是不久。必为我子。是时长者。寻告之曰。汝今云何起异心想。不勤作务。彼即答言。愿欲作子生如是心。长者言善。我是汝父。汝是我子。我实汝父。而汝不知。所有库藏悉以付汝。于大众中唱如是言。此是我子。我失来久。今遇还家。而不自知。我命为子。而复不肯。今日自求为我作子。迦叶。如彼长者。方便诱引志意下劣子。先令除粪。然后付财。于大众中唱如是言。此本我子。亡失来久。今幸自来。为我作子。迦叶。如是不乐一乘者。为说三乘。所以者何。此是如来善巧方便。是诸声闻悉是我子。如除粪者今始自知。迦叶白佛言。呜呼异哉。是声闻乘。何鄙之甚。实是佛子。而不识父

佛告迦叶。应如是学。若汝不堪诃责毁骂。则应舍离。彼后熟时。汝当知之。复次迦叶。声闻大乘常相违反。世俗无漏愚痴黠慧。复次迦叶。若谤此经者。应当摄取。所以者何。彼以谤故。舍身当堕无边黑闇。哀愍彼故。当设方便以大乘法而成熟之。若不可治者。当堕地狱。若有信者彼自当信。其余众生。应以摄事摄令解脱。复次迦叶。若有士夫。初得热病。不应与药及余众治。所以者何。时未至故。要待时至然后乃治。二处不知是则败医。是故病熟然后应治。若未熟者要待时至。如是众生谤此经者。过患熟时深自悔责。呜呼苦哉。我之所作。今始觉知。至于尔时。应以摄事而救摄之

复次迦叶。如有士夫。度大旷野。闻合群鸟鸣。时彼士夫思是鸟声。谓有劫贼。异道而去。入空泽中。至虎狼处。为虎所食。如是迦叶。彼当来世比丘比丘尼优婆塞优婆夷。于有我无我声。畏有我声。入于大空断见。修习无我。于如是如来藏。诸佛常住甚深经典。不生信乐。复次迦叶。汝所问我。为阿难说。有有有苦乐。无有无苦乐。汝今谛听。迦叶。如来者。非有非众生亦不坏。迦叶白佛言。云何世尊。佛告迦叶。如雪山下有出净光摩尼宝性。有人善知摩尼宝相。见相则知。即取持去。如炼金法。消除滓秽离垢清净。随所著处。本垢不污。所以者何。譬如士夫持灯而行。随所至处。闇冥悉除。灯光特明。彼摩尼宝亦复如是。如炼真金尘垢不污。星月光照则雨净水。日光所照寻即出火。如是迦叶。如来应供等正觉。出兴于世。永离一切生老病死。烦恼习垢一切悉灭。常大照明。如彼明珠。一切不污。如净莲华。尘水不着。复次迦叶。如来如是如是时。如是如是像类。出于世间。随其所应。示现凡身。不为彼彼凡品生处垢秽所染。亦复不受世间苦乐。乐者人天五欲功德。彼即是苦唯有解脱究竟常乐。迦叶白佛言。善哉善哉。世尊。我自惟省。今始出家受具足戒。得比丘分成阿罗汉。当于如来知恩报恩。以如来昔日。分我半坐。今日复于四大众中。以大乘法水而灌我顶

尔时众中。有持比丘色像仪式者。或持优婆塞色像仪式者。或持非优婆塞色像仪式者。倾侧低仰一切皆是魔之所为。尔时阿难。白佛言世尊。今此大众。离诸糟糠。坚固真实。如栴檀林。如是众中。彼云何住。佛告阿难。问大迦叶。阿难言。唯善哉当问。即问迦叶。于此众中。彼云何住。迦叶答言。彼愚痴人是魔眷属。与魔俱来。是故阿难。我先说言。不能堪任。于如来灭后。善巧方便。护持正法。如善守田。是故先言。宁负大地。广说如上。尔时世尊。即告我言。于我灭后。汝当堪忍护持正法至于法尽。我时白佛。我当堪能四十年中护持正法。时佛责言。何以懈怠。不能护法至于法尽也

佛告迦叶。汝且求魔。若能得者堪任护法。迦叶即以天眼观察而不能见。如舍卫国有一野人亡失其子。于大众中求子不得。疲乏而归。迦叶。天眼于大众中求魔不得。亦复如是。即白佛言。我不堪任求觅恶魔。如是八十诸大声闻。皆曰不堪。复令贤护等五百菩萨。除一菩萨名一切世间乐见。推觅恶魔。亦复不得

尔时世尊复告迦叶。汝不堪任法欲灭时余八十年护持正法。南方菩萨当能护持。汝当于贤护菩萨五百众中最后求之。迦叶答言。善哉当求。求得一切世间乐见离车童子。世尊。一切世间乐见离车童子。则是其人

佛告迦叶。汝往劝请令觅恶魔。尔时迦叶。即与八十诸大声闻及贤护等五百菩萨。俱共劝请一切世间乐见离车童子。汝童子。世尊所举。堪觅恶魔。尔时童子于大众中白迦叶言。我今堪任推觅恶魔。然有八十诸大声闻。贤护等五百菩萨摩诃萨。及文殊师利。观世音。得大势。灭诸恶趣。弥勒菩萨等。何故不觅令我觅耶。宜令彼先。然后及我。迦叶谓言。降伏恶魔为无福耶。答言。迦叶。汝知有福。宜自为之。我今不能。尔时迦叶以此白佛。佛告迦叶。此童子语为何所说。迦叶白佛。童子说言。先诸大德。然后及我。我是俗人。性复下劣。是诸大德。八十声闻。及贤护等五百上首。彼悉在先。然后次我。时诸声闻及贤护等。一切推觅悉不能得。如彼野人求子不获。皆曰不堪。于一面立

尔时世尊复告迦叶。汝今闻此大法鼓经。于我灭后四十年中。当善护持如今正法。当击大法鼓。吹大法蠡。设大法会。建大法幢。然后一切世间乐见离车童子。于正法欲灭余八十年。当以五系缚彼恶魔及其眷属。如缚小兔。广当宣唱大法鼓经。当击大法鼓。吹大法蠡。设大法会。建大法幢。迦叶白佛言。当于何时。佛告迦叶。正法欲灭余八十年

迦叶白佛言。世尊。欲见恶魔。佛告童子。速以恶魔示诸大众。尔时童子。瞻仰世尊。即指示言。观此恶魔。从异方来。如诸菩萨。作比丘像。于众中坐。大众悉见见被五系。魔言童子。我于此经不复作碍。如是三说

尔时世尊告一切世间乐见离车童子等菩萨众言。摩诃迦叶。已能于我灭度之后四十年中护持正法。汝等谁能于我灭后最后护法。如是三说。无能堪者。佛告大众。汝等勿得起轻劣想。我此众中多有弟子。于我灭后能护正法说此经者。贤护等五百菩萨最后一人。一切世间乐见离车童子。于我灭后。当击大法鼓。吹大法蠡。设大法会。建大法幢。尔时童子即放弊魔。时诸大众语童子言。汝已授记。尔时世尊复告大迦叶言。今汝迦叶。如守田夫无善方便。不能堪任护持此经。今此童子闻此经已。能善诵读现前护持为人演说。常能示现为凡夫身。住于七地。正法欲灭余八十年。在于南方文荼罗国大波利村善方便河边迦耶梨姓中生。当作比丘持我名。如善方便守护田苗。于我慢缓懈怠众中离俗出家。以四摄法而摄彼众。得此深经诵读通利。令僧清净。舍先所受本不净物。为说大法鼓经。第二为说大乘空经。第三为说众生界如来常住大法鼓经。击大法鼓。吹大法蠡。设大法会。建大法幢。当于我前被弘誓铠。尽百年寿常雨法雨。演说此经。满百年已。现大神力示般涅槃。说如是记。释迦牟尼佛。今来至此。悉当瞻仰恭敬礼拜。如是如来常住安乐。诸仁当观真实常乐如我所说。尔时空中。十方诸佛皆悉现身说如是言。如是如是如汝所说。一切皆当信其善说

迦叶白佛言。世尊。菩萨成就几德。能见如来常住不坏法身。临命终时现大神力。佛告迦叶菩萨摩诃萨。成就八功德者。能现前见如来常住不坏法身。何等为八。一者说此深经心不懈怠。二者说彼三乘三种之说亦不懈倦。三者所应化者终不弃舍。四者若僧坏者和合一味。五者终不亲近比丘尼女人黄门。六者远离亲近国王及大力者。七者常乐禅定。八者思惟观察不净无我。是为成就八种功德。复有四事。何等为四。一者善能持法。二者常自欣庆善哉我今所作快乐大善。三者能自归依作是思惟我得善利。四者于如来常住决定无疑。日夜常念如来功德。以是因缘。现前得见常住法身现大神力。然后命终。迦叶。如是善男子善女人。随所住处城邑聚落。我为是等示现法身。而说是言。善男子善女人。如来常住。汝从今日。常应受持读诵此经为人解说。作如是语。当知如来常住安乐。正心悕望勿为谄曲。当知世尊如是常住。净悕望者我当现身。汝大迦叶。当信当审。若不如是修行法者。何由见我。云何能得神通示现。如我为声闻乘说。比丘能舍一法者。我为保任得阿那含果。谓彼所行功德成就亦复如是。如我先说持戒比丘终身天神常随供事。是故汝等。勿贪利养。当修厌离住身念处。复次迦叶。持我名比丘常令僧净。迦叶白佛言。世尊。此为云何。佛告迦叶。行摄取时。满足犯戒贪乌之众。如彼巧便守护四法。贤护等五百菩萨。先不堪任。是等今者。犹故不堪。于我灭后最后护法。持我名比丘行摄法时。摄诸宽纵懈怠比丘。习近供养。与其经卷。消息将护。如养牛法。知可伏时。然后调伏。若摄取调伏。而不改者。则便弃舍。不令毒箭涂伤善净。彼复当作如是思惟。莫令净行比丘因彼犯戒。彼说非法行恶行者。不应致敬共同法集布萨自恣羯磨僧事。悉不应同。如王摧敌。彼亦如是。如是方便调伏彼已。于百年中常雨法雨。击大法鼓。吹大法蠡。设大法会。建大法幢。示大神力。命终涅槃。过千佛已。六十二劫。经百千缘觉及八如来般涅槃后。乃成佛道。名智积光明如来应供等正觉。彼时持我名比丘者。即是一切世间乐见离车童子。当于此土成等正觉。迦叶当知。无上菩提。如是难得。迦叶。为是凡人所能得不。迦叶白佛言。不也世尊。佛告迦叶。一佛国土一佛施作佛事。第二第三亦复如是。如一芥子中有众多世界。周旋往返而不自知。谁持来去。谁安我此。随所应知随顺为作。如是或有知我者或不知者。此一世界。耆阇崛山中。有释迦牟尼佛。即于此中。有阿逸多佛。于此世界。或现劫烧。或现说法。如是奇特甚为希有。复有何等最上奇特。谓一切世间乐见童子。不于凡俗家生。其所生家。悉是菩萨。迦叶当知。彼供养给侍者。悉皆欢喜。宗亲爱念。皆作是言。我种姓中。有如是人生。此诸人等。一切皆是我之所遣。迦叶当知。彼菩萨摩诃萨。若余四众为作眷属。悉闻说此大法鼓经。一切皆当得无上菩提。迦叶。我于过去久远世时。在毗舍离城。作转轮王。名难提斯那。尔时毗舍离城。如四天王下阎浮提。如忍世界。其余天下亦复如是。如是三千大千世界。我时寿命不可思议。我作如是转轮圣王。行阿僧祇殊胜布施及诸功德。持戒清净修诸善行。合集如是无量福德。若善男子善女人。闻说一乘大法鼓经。戏笑而往。乃至一念。所得功德胜前福业。不可称记算数譬喻。所不能计。如有咒王名曰焰昭。一说此咒。四月善护。迦叶当知。世间凡咒势力如是。何况一读大法鼓经。而力不能尽寿为护。是故有能供养此经者。是诸众生。为无上菩提作决定因。乃至究竟菩提不离是经。时诸大众。同声唱言。善哉善哉。甚奇世尊。今此童子。当为持佛名比丘。若般涅槃者。祇洹林神无所依怙。所以者何。彼从南方来至佛所。而般涅槃。佛告大众。彼亦不来。我自往彼。示现其身。先遣此经。然后乃往。所以者何。若此经不往至彼手中。则彼生退心。若彼有众生应调伏者。我与大众往住其前。彼见我已。当即还往迎彼已便般涅槃。随其所欲度众生处。而般涅槃

尔时天帝释子。名阿毗曼儒。当乘神通而来至此。彼虽幼少。真心清净信乐大乘。唯独一人无有俦匹。于天人中。持此大乘甚深经典。是故彼为说解脱因。得授佛记。时诸大众。同声说偈

  奇哉一切　　世间乐见　　为比丘像
  击大法鼓　　护持佛法　　令得久住
  般涅槃后　　世间虚空　　彼灭度后
  无与等者　　如是比丘　　世间难得
  能为世间　　说究竟道

尔时迦叶阿难贤护菩萨等。无量大众。闻佛所说。欢喜奉行

大法鼓经卷下


大萨遮尼干子所说经卷第一

    No. 272

大萨遮尼干子所说经卷第一

        元魏天竺三藏菩提留支译

    序品第一

归命大智海毗卢遮那佛(外国本一切经首皆有此句)

如是我闻。一时婆伽婆在郁阇延城。王名严炽。住王园中。其园所有殊胜庄严不可称计。所谓娑罗树。多罗树。多摩罗树。迦尼迦罗树。尼拘律树。波罗叉树。郁昙钵华树。婆师迦华树。陀[少/兔]尼迦华树。阿提目多伽华树。瞻卜华树。阿输迦华树。波吒罗华树。如是无量百千众妙树林庄严。复有种种异相之水。所谓泉水海水。直流水。曲流水。多罗迦水。池水。从上注下水。从下涌上水。如是无量百千妙相众水庄严。复有种种众妙杂华。所谓优波罗华。钵头摩华。拘牟头华。分陀利华。他罗华。摩诃他罗华。卢遮华。摩诃卢遮华。如是无量百千妙华以为庄严。复有种种妙音声鸟。所谓鹅鸟。昆仑遮鸟。拘只罗鸟。钩那罗鸟。具多鸟。崛多鸟。鹦鹉鸟。鸲鹆鸟。耆婆耆婆鸟。迦陵频伽鸟。有如是等无量百千众妙声鸟。以为庄严。复有种种妙色众蜂。飞在虚空迭相连接。犹如罗网遍覆于上。以为庄严。复有种种众杂色草。柔软香洁。无量百千异种文色。庄严其地。如是众妙庄严园中。与大比丘众七十二百千万等诸大众俱。其名曰慧命舍利弗。大目揵连摩诃迦叶。阿[少/兔]楼陀。须菩提。摩诃迦栴延。摩诃劫宾那。离波多。难陀。那提迦叶。伽耶伽叶。富楼那弥多罗尼子。憍范波提。般他迦。周罗般他迦。陀[馬*剽]摩罗子。佉陀林纯陀。摩诃拘絺罗。罗睺罗。慧命阿难等。七十二百千万亿诸大众中而为上首。一切皆修如实法界境界诸行。一切皆入法界实性。一切皆得无障无碍虚空境界殊胜妙行。一切皆得无所著行。一切皆离烦恼诸垢一切结使。一切皆入如来法性光明照处。一切皆证同一法性平等大慧。一切皆得现诸如来一切智门。一切皆得常不休息大菩提道。一切皆得转不退转大菩提道。一切皆得证不退转大菩提心。一切皆到第一彼岸般若智见。一切皆得究竟彼岸方便智慧

复有摩诃波阇波提比丘尼。耶输陀罗比丘尼等。八千比丘尼。于百千万亿比丘尼中而为上首。一切皆悉具足善集诸妙白法。一切善入一切智道。一切皆近一切智智。一切皆入无所有性。一切能观诸法无相。一切善信法际无际。一切皆得无障解脱。一切皆得随诸有缘。可化众生示佛色身。诸菩萨摩诃萨。七十二百千万亿诸大众俱。其名曰大速行菩萨。大速行住持菩萨。大奋迅菩萨。大奋迅王菩萨。大精进奋迅菩萨。大勇奋迅菩萨。现大勇势奋迅菩萨。大力奋迅菩萨。大众自在菩萨。大香像菩萨。大月菩萨。善月菩萨。月功德菩萨。宝月菩萨。月光普照菩萨。法无垢月菩萨。月普照菩萨。月名称菩萨。放月光明菩萨。满月菩萨。范声菩萨。范自在吼声菩萨。地吼声菩萨。法界吼声菩萨。惊怖一切魔宫吼声菩萨。出法鼓声菩萨。普识声菩萨。无分别离分别声菩萨。师子吼地勇声菩萨。闭塞一切声菩萨。普藏菩萨。功德藏菩萨。普照藏菩萨。宝藏菩萨。月藏菩萨。日藏菩萨。日光藏菩萨。波头摩藏菩萨。福德藏菩萨。智胜藏菩萨。大慧菩萨。胜慧菩萨。名称慧菩萨。快慧菩萨。上慧菩萨。增长慧菩萨。无边慧菩萨。广慧菩萨。佛慧菩萨。无尽慧菩萨。弥留山灯明菩萨。燃大灯明菩萨。法灯明菩萨。遍十方灯明菩萨。普照菩萨。普灭一切闇灯明菩萨。普照诸趣灯明菩萨。常放火光灯明菩萨。月光灯明菩萨。日光灯明菩萨。离恶道菩萨。降魔菩萨。大降魔菩萨。希生菩萨。难降菩萨。难量菩萨。难知智菩萨。竭恶道菩萨。大势至菩萨。观世自在菩萨。弥勒菩萨。文殊师利法王子菩萨等。七十二百千万众而为上首。如是诸菩萨摩诃萨等。一切皆得一生补处。一切皆得诸陀罗尼。一切皆得诸三昧海。一切皆得无边乐说无碍辩才。一切皆得无畏说法。一切皆到第一彼岸。功德丛林如意自在。一切皆得大神通道。奋迅自在到诸佛国。一切皆得无碍自在身心解脱。一切皆得无障无碍毕竟知见。一切皆得普现佛身游诸十方无佛国土。一切皆得如实正智。转大法轮无过无谬。一切皆得随顺十方。堪闻众生而为说法。一切皆得陀罗尼门说无非法。一切皆得无取无舍如实法界。一切皆得能说诸法空义无碍。一切皆能师子吼吼。一切皆能降伏外道。一切皆能摧魔怨敌。一切皆得菩萨神通诸胜妙行。一切皆得离诸怨憎。一切皆得地水火风平等大心。一切皆得入诸如来深密之处。一切皆得为诸众生住持佛事。一切皆得诸佛如来所共赞叹称誉随喜说其胜行。一切皆能具足住持无边际劫。一切皆能住持如来所说法轮。一切皆得放大法宝胜妙光明。一切皆得说不可尽胜行功德。一切皆得于诸世间具足自在。一切皆得具足成就过去诸愿。一切皆得诸佛如来信行境界。一切皆得过去所修善行具足。一切皆得具足清净佛无垢智。一切皆得常不休息勇猛精进供养一切诸佛如来。一切皆得勇猛发起毕定取于不退转地。一切皆得大悲现前。一切皆得自性清净深心解脱。一切皆得离诸疑悔戒取烦恼。一切皆得过去诸佛神力所加

复有无量诸优婆塞诸优婆夷。复有三千大千世界。具大威德具大威德。上下殊胜诸天天王。诸龙龙王。诸夜叉夜叉王。诸乾闼婆乾闼婆王。诸阿修罗阿修罗王。诸迦楼罗迦楼罗王。诸紧那罗紧那罗王。诸摩睺罗伽摩睺罗伽王。人及人王。彼时一切诸大众等。各有百千万亿眷属俱集会坐

尔时世尊。为诸无量百千万亿诸大众等。恭敬围绕。处在百千万福庄严功德胜藏师子座上。结加趺坐。如来妙色身光威德。其相殊特照曜显现。盖诸一切天龙八部。譬如须弥山王涌出大海。威光殊胜照曜显现盖诸小山。如来世尊大须弥王。处在百千万福庄严师子妙座。威光殊特照曜显现盖诸大众。亦复如是。譬如初月。光轮渐长至月满足。其光殊胜照曜显现。映夺一切星宿诸光。如来世尊。处在百千万福庄严师子妙座。威光殊特照曜显现。映诸一切天人大众。亦复如是。譬如虚空清净无垢。离诸一切云翳尘染。其中日轮放大光明。其光殊胜照曜显现。映夺一切诸虫萤火所有光明皆悉不现。如来日轮。处在百千万福庄严师子妙座。威光殊特照曜显现。映蔽一切释提桓因。诸梵天王四天王等光明不现。亦复如是。譬如闇夜在大山顶然大火轮。光明殊胜照曜显现一切皆见。如来山火。处在百千万福庄严师子妙座。光明殊特照曜显现有缘皆见。亦复如是。譬如师子诸兽之王在于深山。威力殊胜照曜显现。降伏一切诸虫兽等。如来师子诸法之王。处在百千万福庄严师子妙座。威光殊特照曜显现。降伏一切外道异见诸众生等。亦复如是。譬如离垢八楞摩尼如意宝珠置在高幢。放大光明随众生愿雨令满足。其光殊胜照曜显现遍照十方。如来摩尼。处在百千万福庄严师子妙座。大智慧明威光殊特照曜显现遍照十方满众生愿。亦复如是。譬如自在转轮圣王。威德殊胜照曜显现。悉能降伏遍四天下一切无有能敌对者。如来世尊转法轮王。处在百千万福庄严师子妙座。威光殊特照曜显现。降伏一切诸魔怨敌。亦复如是。譬如释提桓因以帝释宝摩尼璎珞系在颈上。处善法堂诸天众中。威德殊胜照曜显现。降伏一切诸天大众。如来帝释。处在百千万福庄严师子妙座。威光殊特照曜显现盖诸天人。亦复如是

    大萨遮尼干子所说经问疑品第二

尔时圣者文殊师利法王子菩萨。见诸无量大众云集。见佛世尊现大胜妙希有之相。作是思惟。今者世尊。为何事故。先现此相。我有疑事。今应当问。何以故。如来世尊。处在百千万福庄严师子妙座。威光殊特照曜显现。如是无量大众集会。难可值遇。作是念已。即从坐起。偏袒右肩右膝着地合掌向佛。即以偈颂赞叹如来。而说偈言

  世尊十力雄　　天人诸世间
  三界无与等　　何有能过者
  譬如须弥王　　出大海小山
  深固不倾动　　诸天蒙安隐
  如来须弥王　　过圣生死海
  诸功德住持　　安住不可动
  功德须弥身　　显出诸世间
  一切依如来　　安隐住涅槃
  譬如空无障　　满月独明照
  一切星宿光　　隐没不能现
  如来十力净　　智慧月明朗
  神通弟子众　　亦如星宿光
  譬如日光轮　　照曜诸世间
  除灭一切闇　　诸小光不现
  如来智日轮　　照除世间闇
  诸梵王等光　　隐没不能现
  譬如夜然火　　置在高山顶
  以体明净故　　十方闇皆见
  如来大明火　　智慧山高显
  照烦恼闇界　　法性令开现
  譬如师子王　　雄猛盖诸兽
  不现威怒相　　一切兽降伏
  如来师子王　　无畏力具足
  慈心诸外道　　自然皆降伏
  譬如摩尼珠　　放光照世间
  随诸众生愿　　一切雨满足
  如来摩尼珠　　智慧幢照远
  能雨大法雨　　满足众生愿
  譬如转轮王　　具足七宝福
  游诸四天下　　怨对生亲友
  如来转轮王　　具足十力宝
  摄诸四魔众　　皆归如来道
  譬如帝释王　　三十三天主
  布正善法堂　　诸天欢喜受
  如来天帝释　　三界大法王
  慈心观诸趣　　坐涅槃法堂
  兴大慈悲云　　雨甘露法雨
  天人欢喜受　　修行无上道

尔时圣者文殊师利法王子菩萨。说诸偈颂赞叹佛已。合掌白佛言。世尊。如来乃能为诸大众。说菩萨行方便境界奋迅法门。以闻此经诸有信乐无上大乘善根众生。皆发阿耨多罗三藐三菩提心。及信小乘狭劣众生。亦发无上菩提之心。已发无上大心众生。而能增长菩提之念。诸狭劣行小见众生。能发大行。退道众生。而能进取大菩提道。以取菩提胜道众生能入如来智慧庄严深密法中。尔时世尊告文殊师利法王子菩萨言。文殊师利。诸佛如来应正遍知。所有难信难知难觉难识难量难入深密之法。一切天人不知如来依何意说。文殊师利。如此甚深微妙之法。若有众生行恶行者。不知此法不识此法。诸破戒者。不知此法不识此法。乐小行者。不信此法。破坏心者。不信此法。为恶知识所摄持者。不入此法。诸善知识所不摄者。不入此法。不为诸佛住持众生。不闻此法。除诸如来加力持者。能闻此法。能信此法。无有是处。尔时世尊重宣此义。而说偈言

  美妙声法子　　能问我此事
  汝今至心听　　我当为汝说
  众生无明覆　　唯有信小心
  闻此大乘法　　不信故不说
  若于无量世　　过去诸佛所
  修行诸善行　　善根具成熟
  如是诸众生　　常被如来加
  闻说生欢喜　　乃能谛信受
  若为恶知识　　毒蛇之所螫
  离于善知识　　不闻甘露法
  于诸胜法中　　起于放逸心
  堕大邪见坑　　闻说不生信
  众生心狭劣　　不堪受大法
  闻退生不信　　起于诽谤心
  长夜堕恶道　　永不闻佛法
  为彼起悲心　　故我不速说

尔时圣者文殊师利法王子菩萨白佛言。世尊。此会大众皆善清净。善行诸行。善能供养诸佛如来。善能将护诸善知识。善能修集清净信眼。善入大智信诸境界。善具清净深心直心。此会大众。一切善能观诸境界。能知此法能识此法。善哉世尊。唯愿为我及时会大众乐闻之心。善说此法。而说偈言

  此会诸众生　　已于无量劫
  一切诸佛所　　种善根满足
  如是众生等　　能入佛境界
  为满法器故　　愿佛今速说
  一切皆瞻仰　　天人师面门
  恭敬合掌观　　渴仰目不舍
  愿世尊愍此　　渴仰众生心
  雨大妙法雨　　令生善法牙
  我今请如来　　无上大法王
  愿开甘露门　　转最胜法轮
  是诸众生等　　若闻佛所说
  能行无上道　　究竟涅槃法

    大萨遮尼干子所说经一乘品第三之一

尔时圣者。文殊师利法王子菩萨。如是问已。佛告文殊师利。善哉善哉。法王子。善哉文殊师利。汝今善能。问于如来应正遍知菩萨所行甚深法门。何以故。文殊师利。汝见诸法实义。现前无有疑惑。究竟到于智波罗蜜第一彼岸。为欲利益无量众生。令入菩萨无上道故。问如是法。文殊师利。汝能复为未来众生然大明灯灭诸闇故。问如是法。善哉善哉。文殊师利。汝今谛听。我当为汝说菩萨行方便境界奋迅法门。文殊师利白佛言。善哉世尊。愿乐欲闻。时诸一切菩萨大众。一心同声俱白佛言。善哉世尊。愿乐欲闻

尔时世尊。欲说此法告诸大众。诸善男子。若有善男子善女人等。毕竟成就十二法者。乃能发于阿耨多罗三藐三菩提心。何等十二。一者自性信大乘法。为离小乘狭劣心故。发菩提心。二者自性成就大悲。为欲具足诸白法故。发菩提心。三者直心本行坚固。为厌生死向彼岸故。发菩提心。四者善集一切功德。为欲修满诸愿行故。发菩提心。五者能善供养诸佛。为欲善起诸白法故。发菩提心。六者身口意业清净。为离一切诸恶行故。发菩提心。七者远离诸恶知识。为欲亲近善知识故。发菩提心。八者闻法如说修行。为不虚妄诳众生故。发菩提心。九者为欲利益一切畜诸资生不贪不悭故。发菩提心。十者以得诸佛加护。为离一切诸魔加故。发菩提心。十一者。于诸众生常起大悲。能舍内外一切诸物。为离悭嫉故。发菩提心。十二者。具法行力为能成就诸功德故。发菩提心。善男子。是名十二妙法。若善男子善女人。成就此十二法者。乃能发于阿耨多罗三藐三菩提心。善男子。复有十二种胜法。菩萨成就。名发阿耨多罗三藐三菩提心。何等十二。一者安隐心。为与一切众生乐故。发菩提心。二者愍念心。他恶来加能忍将护不生异相故。发菩提心。三者大悲心。为荷众生大重担故。发菩提心。四者大慈心。为拔一切恶道苦故。发菩提心。五者清净心。能于余乘不生愿乐故。发菩提心。六者无染心。为离一切烦恼浊故。发菩提心。七者光明心。为求无上自性清净光明照故。发菩提心。八者幻心。能知诸法究竟无物故。发菩提心。九者无物心。能知一切无所有故。发菩提心。十者坚固心。于诸法中不可动故。发菩提心。十一者不退心。能证诸法究竟尽故。发菩提心。十二者度诸众生不生厌心。如说修行故。发菩提心。尔时世尊。重说偈言

  诸善男子等　　若有诸众生
  欲修诸白法　　成就无垢法
  能于怨亲中　　悲润心平等
  如是诸菩萨　　名发菩提心
  若有众生等　　已于无量劫
  将护恶知识　　供养善知识
  护持菩提门　　起诸大愿行
  如是诸菩萨　　名发菩提心
  若有诸众生　　忆念过去世
  无量亿劫事　　坚固如山王
  精进心无惓　　常行不休息
  如是诸菩萨　　名发菩提心
  若有众生等　　舍离诸恶法
  具足悲愍心　　安隐心成就
  念示诸众生　　一切善业道
  如是诸菩萨　　名发菩提心
  若有众生等　　见诸胜智者
  念于大菩提　　无上胜功德
  欲于余乘中　　心净无点秽
  如是诸菩萨　　名发菩提心
  菩萨得净心　　离虚妄分别
  观世间涅槃　　平等无差别
  虽行化众生　　如见镜中像
  如是发心者　　是实菩提心
  已离烦恼过　　一切诸尘劳
  清净知虚空　　不为垢所染
  诸相永寂灭　　出离言语道
  是名满足修　　清净菩提心
  如是诸菩萨　　不久坐道场
  得大陀罗尼　　无上胜辩才
  具足三十二　　八十相好身
  能住一切佛　　本性功德中

复次文殊师利。菩萨摩诃萨。能住如是胜功德中。有十二种布施妙行。能大利益疾到菩提。菩萨应行檀波罗蜜。何等十二。一者布施。能速增长无上菩提功德利故。菩萨应行檀波罗蜜。二者布施。生处富足手中常出无尽宝故。菩萨应行檀波罗蜜。三者布施。随愿得生释梵天王诸大家故。菩萨应行檀波罗蜜。四者布施。能离一切悭贪心过。弃舍诸有不生愿乐故。菩萨应行檀波罗蜜。五者布施。能舍世间贪染缚故。菩萨应行檀波罗蜜。六者布施。出饿鬼门离诸恶趣故。菩萨应行檀波罗蜜。七者布施。离诸世间多人共物。能得菩提不共物故。菩萨应行檀波罗蜜。八者布施。能称众生欢喜心故。菩萨应行檀波罗蜜。九者布施。能舍内外行佛行故。菩萨应行檀波罗蜜。十者布施。于诸一切所爱事中。能离缚着垢害心故。菩萨应行檀波罗蜜十一者布施。行能满足无上檀波罗蜜故。菩萨应行檀波罗蜜。十二者布施。行能随如来教所愿成就故。菩萨应行檀波罗蜜。善男子。是名菩萨摩诃萨十二种修行檀波罗蜜得大利益。回向阿耨多罗三藐三菩提。尔时世尊。即以偈颂赞叹檀波罗蜜。重说偈言

  欲求无上道　　修行诸功德
  破于悭贪心　　布施最第一
  佛子行舍心　　见来乞求者
  能生欢喜心　　一切无吝惜
  国城及妻子　　乃至天王位
  身肉及手足　　头目诸髓脑
  清净无垢眼　　施已心欢喜
  如是行舍心　　名檀波罗蜜
  一切诸如来　　满足诸功德
  具胜涅槃道　　皆由布施故
  是故诸佛子　　欲求无上道
  常当修舍心　　行檀波罗蜜
  施能得菩提　　不住于世间
  是故诸菩萨　　常当行舍心
  施能断贫穷　　富足七净财
  悭嫉妒心尽　　清净佛菩提
  布施能满足　　成就十自在
  是故诸如来　　赞叹行施福
  菩萨见是利　　为成波罗蜜
  是故修舍心　　常施一切物

善男子。菩萨复有十二种持戒得大利益。菩萨应行尸波罗蜜。何等十二。一者持戒。能摄一切诸善根故。菩萨应行尸波罗蜜。二者持戒。入菩萨道故。菩萨应行尸波罗蜜。三者持戒。解脱一切烦恼缚故。菩萨应行尸波罗蜜。四者持戒。能过一切诸恶道故。菩萨应行尸波罗蜜。五者持戒。能拔恶道苦众生故。菩萨应行尸波罗蜜。六者持戒。身口意业不为诸佛如来诃故。菩萨应行尸波罗蜜。七者持戒。诸佛如来常赞叹故。菩萨应行尸波罗蜜。八者持戒。能入诸有不放逸故。菩萨应行尸波罗蜜。九者持戒。即施众生无怖畏故。菩萨应行尸波罗蜜。十者持戒。成就身口意业善故。菩萨应行尸波罗蜜。十一者持戒。能得于诸法中随顺自在故。菩萨应行尸波罗蜜。十二者持戒。成就第一彼岸功德波罗蜜业故。菩萨应行尸波罗蜜。善男子。是名菩萨摩诃萨十二种修行尸波罗蜜。得大利益。回向阿耨多罗三藐三菩提。尔时世尊。即以偈颂赞叹尸波罗蜜。重说偈言

  欲离诸生死　　安隐到涅槃
  一切如来说　　持戒最第一
  戒如清凉池　　能生诸善花
  亦如猛炽火　　能烧诸恶草
  戒善持行者　　如鸟飞虚空
  不惧堕生死　　诸趣恶道中
  恶道大毒龙　　无明诸罗刹
  见持净戒者　　恭敬舍害心
  一切诸如来　　安隐住涅槃
  断诸恶趣道　　皆由持戒故
  是故诸佛子　　欲求无上道
  坚固诸善本　　持戒波罗蜜
  菩萨应思惟　　善住戒品中
  解脱烦恼缚　　闭诸恶趣门
  若欲持净戒　　应当如牦牛
  为护一毛故　　守死不惜命
  如是护诸业　　是名持戒人
  如来常赞叹　　所求皆成就
  能持净戒者　　有如是功德
  是故诸菩萨　　常当持净戒
  身口意业净　　诸恶皆不行
  是能到菩提　　一切智现前
  持戒不放逸　　诸善皆坚固
  法中得自在　　能净诸佛戒
  菩萨持净戒　　视物无怨亲
  等心诸群生　　见者无怖心
  我住于彼处　　常修不放逸
  是故今得离　　一切诸恶趣
  到第一彼岸　　如实功德地
  是故诸菩萨　　常当持净戒
  菩萨若欲求　　菩提佛功德
  持戒如牦牛　　常念不放逸
  如是诸菩萨　　是名为智者
  能速到彼岸　　住佛果菩提

善男子。菩萨如是修行诸法已。复有十三种观修行羼提波罗蜜得大利益。菩萨应行忍波罗蜜。何等十三。一者忍行。堪忍诸恼能证一切诸法空故。菩萨应行忍波罗蜜。二者忍行。不见有我为他害故。菩萨应行忍波罗蜜。三者忍行。不见众生有怨亲故。菩萨应行忍波罗蜜。四者忍行。不见自他身可损故。菩萨应行忍波罗蜜。五者忍行。闻毁赞叹心常不动故。菩萨应行忍波罗蜜。六者忍行。能断烦恼诸结使故。菩萨应行忍波罗蜜。七者忍行。能断嗔恨诸结使故。菩萨应行忍波罗蜜。八者忍行。能成三十二相八十种好故。菩萨应行忍波罗蜜。九者忍行。能离恶道生梵天故。菩萨应行忍波罗蜜。十者忍行。能过一切损害境界故。菩萨应行忍波罗蜜。十一者忍行。能得尽智无生智故。菩萨应行忍波罗蜜。十二者忍行。能降一切恶魔诸境界故。菩萨应行忍波罗蜜。十三者忍行。能见如来无量功德庄严身故。菩萨应行忍波罗蜜。善男子。是名菩萨十三种观修羼提波罗蜜得大利益。回向阿耨多罗三藐三菩提。尔时世尊。即以偈颂赞叹忍辱波罗蜜。重说偈言

  若欲为众生　　作诸归依处
  令生无畏心　　忍辱最第一
  能行忍辱者　　见者皆欢喜
  怨家舍毒心　　皆生亲友想
  一切诸如来　　成就平等心
  众生所归依　　皆由行忍故
  是故诸佛子　　欲求无上道
  为物作依止　　当坚固忍辱
  菩萨若欲住　　一切佛菩提
  当观诸法空　　众生不可得
  如是行忍行　　能具佛功德
  是故诸菩萨　　常应修忍辱
  菩萨若修忍　　当远离二边
  不见自他身　　能有损益者
  如来大慈悲　　赞叹如是观
  是故诸菩萨　　常应修忍辱
  若欲得尽智　　灭诸使烦恼
  不怯弱修忍　　常无分别心
  如是观诸法　　成忍波罗蜜
  是故诸菩萨　　常应修忍辱
  菩萨欲庄严　　如来相好身
  复生梵世界　　出离诸魔道
  乐行忍辱行　　一切皆成就
  是故诸菩萨　　应坚固忍辱
  忍辱力最上　　诸行无过者
  一切诸功德　　住在忍行中
  四魔力难敌　　忍力能除灭
  是故诸菩萨　　常应修忍辱

大萨遮尼干子所说经卷第一大萨遮尼干子所说经卷第二

        元魏天竺三藏菩提留支译

    一乘品第三之二

善男子。菩萨复有十二种发勇猛心。修行毗梨耶波罗蜜得大利益。菩萨应行精进波罗蜜。何等十二。一者精进。能速觉知诸佛法海故。菩萨应发大勇猛心修行精进波罗蜜。二者精进。能速往诣诸佛所故。菩萨应发大勇猛心修行精进波罗蜜。三者精进。能遍十方供养恭敬一切佛故。菩萨应发大勇猛心修行精进波罗蜜。四者精进。所作之业能称一切诸佛意故。菩萨应发大勇猛心修行精进波罗蜜。五者精进。能勤化度一切众生不生厌足故。菩萨应发大勇猛心修行精进波罗蜜。六者精进。能置众生诸佛法中趣解脱门故。菩萨应发大勇猛心修行精进波罗蜜。七者精进。速能令诸一切众生离诸愚痴故。菩萨应发大勇猛心修行精进波罗蜜。八者精进。速能悉与一切众生诸佛智慧故。菩萨应发大勇猛心修行精进波罗蜜。九者精进。速能清净诸佛国土故。菩萨应发大勇猛心修行精进波罗蜜。十者精进行。能建立尽未来际一切劫数。为诸众生行菩萨行不生疲惓心故。菩萨应发大勇猛心修行精进波罗蜜。十一者精进行。能于一念中遍诸佛国种诸善根故。菩萨应发大勇猛心修行精进波罗蜜。十二者精进行。能遍诣一切诸佛国土成无上道转大法轮故。菩萨应发大勇猛心修行精进波罗蜜。善男子。是名菩萨十二种发勇猛心。修行毗梨耶波罗蜜得大利益。回向阿耨多罗三藐三菩提。尔时世尊。即以偈颂赞叹精进波罗蜜。重说偈言

  若欲为众生　　修行菩萨行
  速成无上道　　精进最第一
  如来无量劫　　所行诸苦行
  一切皆能忍　　不生怯弱故
  是故诸佛子　　欲速成佛道
  常当勤修行　　精进波罗蜜
  菩萨行精进　　能速到胜处
  过诸百千国　　供养观诸佛
  菩萨求大乐　　为拔众生苦
  修行菩萨道　　坚固不转退
  能为诸众生　　无量百千劫
  受苦无懈怠　　皆由精进故
  愿我常精进　　清净佛国土
  次愿能觉知　　一切诸佛法
  能遍诸佛国　　转大妙法轮
  愿诸众生类　　一切皆觉知
  悉入大乘中　　离余乘魔界
  满足诸大愿　　速到无畏地
  菩萨精进故　　能于一念时
  觉大菩提法　　开示涅槃门
  化作无量身　　遍满十方国
  为利益众生　　示如是胜事

善男子。菩萨复有十二种观行禅波罗蜜得大利益。菩萨应修禅波罗蜜。何等十二。一者禅定。能灭一切诸烦恼染。菩萨应修禅波罗蜜。常无分别心故。二者禅定。心住寂静念不散乱。菩萨应修禅波罗蜜。不取诸境界故。三者禅定。心无所著能满诸行。菩萨应修禅波罗蜜。能过三界故。四者禅定。能出世间不着诸有。菩萨应修禅波罗蜜。过世间故。五者禅定。能观胜法心无疲惓。菩萨应修禅波罗蜜。不以为足故。六者禅定。柔软自在不随禅生。菩萨应修禅波罗蜜。自在转诸禅故。七者禅定。得无相心不见诸物。菩萨应修禅波罗蜜。以离诸相故。八者禅定。心净能照无量境界。菩萨应修禅波罗蜜。以过有量诸三昧等呵责过故。九者禅定。能灭观心不见能观。菩萨应修禅波罗蜜。以得寂静心故。十者禅定。证柔软心灭诸觉观。菩萨应修禅波罗蜜。以得调伏心故。十一者禅定。心能寂灭一观诸根不动。菩萨应修禅波罗蜜。以得降伏不善根故。十二者禅定。心能于诸法中有大方便。菩萨应修禅波罗蜜。以能不舍大菩提心故。何以故。以诸菩萨住禅波罗蜜故。不起憍慢心。住禅波罗蜜故。不起邪见心。住禅波罗蜜故。不起憎爱心。是故诸菩萨能降一切学诸禅定声闻辟支佛外道梵行入禅三昧者。善男子。是名菩萨十二种修行禅波罗蜜得大利益。回向阿耨多罗三藐三菩提。尔时世尊。即以偈颂赞叹禅波罗蜜。而说偈言

  欲修无漏智　　出离欲淤泥
  灭除诸业障　　禅定最第一
  禅定难思议　　是诸佛境界
  二乘诸凡夫　　三昧不能知
  大地诸山海　　劫火能烧除
  若心住禅定　　安隐无损害
  如来智慧日　　无漏摩尼珠
  不从余处生　　禅定海中出
  是故诸佛子　　求佛大智宝
  当除散乱心　　念禅波罗蜜
  诸菩萨禅定　　寂灭诸烦恼
  是故智者说　　胜修余禅者
  深心常寂灭　　不乐诸境界
  能摄诸乱心　　住胜涅槃处
  菩萨修禅定　　三界无所住
  是故不依止　　彼非依止处
  菩萨禅能过　　世间出世间
  是故三昧胜　　胜世间二乘
  菩萨禅柔软　　随意无挂碍
  是故能回转　　生于欲界中
  菩萨所修禅　　胜余一切观
  诸禅非究竟　　故佛说胜者
  菩萨禅无量　　从于胜境生
  离诸众生相　　及离诸垢法
  是故诸菩萨　　所修禅定胜
  降修余禅者　　及诸少分禅
  菩萨一向观　　清净诸境界
  如是所修禅　　从慧方便生
  正智为根本　　不起邪见心
  是故菩萨禅　　无有可讥嫌
  菩萨入禅定　　不住有无中
  以观实境故　　能离有无相
  如是胜智禅　　不同余境界
  罗汉辟支佛　　智慧悉迷闷

善男子。菩萨复有十二种观。修行般若波罗蜜得大利益。菩萨应修慧波罗蜜。何等十二。一者般若。远离诸垢能发光明。菩萨应修慧波罗蜜。以能离诸黑闇法故。二者般若。悉能觉了诸闇障碍。菩萨应修慧波罗蜜。以能照除烦恼稠林故。三者般若。能放一切智慧光明。菩萨应修慧波罗蜜。以离一切诸无智故。四者般若。如犁耕地除诸草秽。菩萨应修慧波罗蜜。以能拔诸无明根本故。五者般若。如利铁钩随意琢斫。菩萨应修慧波罗蜜。以能钩断诸爱网故。六者般若如金刚杵不为一切诸物所坏。菩萨应修慧波罗蜜。以能破碎烦恼山故。七者般若如大日轮离诸云翳。菩萨应修慧波罗蜜。以能干竭一切烦恼诸淤泥故。八者般若如大火聚烧诸秽草。菩萨应修慧波罗蜜。以能焚烧业烦恼树故。九者般若如摩尼珠能照一切。菩萨应修慧波罗蜜。以无闇心不迷诸法故。十者般若能住寂灭究竟实际。菩萨应修慧波罗蜜。以无所有故。十一者般若能灭有相心无分别。菩萨应修慧波罗蜜。以无相故。十二者般若能成无愿心无求乐。菩萨应修慧波罗蜜。以过三界故。善男子。是名菩萨十二种修行般若波罗蜜得大利益。尔时世尊。即以偈颂赞叹般若波罗蜜。而说偈言

  究竟断有种　　安隐入涅槃
  诸波罗蜜中　　智慧最第一
  譬如世间灯　　能破一切闇
  亦如高幢火　　世间最胜观
  一切诸如来　　出离诸有流
  降伏四魔众　　智慧为猛将
  诸佛子若欲　　自利利众生
  常当勤修行　　般若波罗蜜
  譬如犁耕地　　能除诸荒秽
  智灭疑爱草　　如犁耕净地
  帝释金刚杵　　灭恶阿修罗
  智碎烦恼山　　能坏亦如是
  一切诸如来　　说于智慧力
  犹如夏中日　　亦如世间灯
  能竭烦恼海　　照除无明闇
  以体出世间　　无漏火明故
  智慧能割截　　无明痴闇树
  犹如快利刀　　剪除诸细草
  智如摩尼珠　　平等照世间
  如空无分别　　不住有涅槃
  智慧心自在　　决定于一切
  能断诸疑悔　　及断所有问
  说世间恶报　　及显涅槃果
  普示诸众生　　如闇示明灯
  诸佛明月眼　　现见诸法相
  诸菩萨同彼　　无垢智修行
  如人夜执灯　　去处皆明了
  生死黑闇中　　慧明能度彼

善男子。菩萨复有十二种境界。修方便行得大利益。是故菩萨应修方便波罗蜜。何等十二。一者方便不离涅槃清净境界。而现世间垢浊境界故。菩萨应修方便波罗蜜。二者方便不离一处寂静境界。而现世间愦闹境界故。菩萨应修方便波罗蜜。三者方便不离禅定甚深境界。而现世间王宫境界故。菩萨应修方便波罗蜜。四者方便不离清净无功用境界。而现世间功用境界故。菩萨应修方便波罗蜜。五者方便不离无生真实境界。而现世间生此退彼退此生彼诸境界故。菩萨应修方便波罗蜜。六者方便能过一切四魔境界。而现世间降魔境界故。菩萨应修方便波罗蜜。七者方便不离一切圣人境界。而现世间凡夫境界故。菩萨应修方便波罗蜜。八者方便不离能出世间境界。而住世间诸有境界故。菩萨应修方便波罗蜜。九者方便不离一切智慧境界。而现世间无智境界故。菩萨应修方便波罗蜜。十者方便不离菩萨实际境界。而现声闻缘觉境界故。菩萨应修方便波罗蜜。十一者方便力能善知一切诸法无相。而能示现三十二相八十种好。教化众生故。菩萨应修方便波罗蜜。十二者方便力能入诸一切平等境界。而能示现诸魔境界故。菩萨应住方便波罗蜜。善男子。是名菩萨十二种住方便波罗蜜得大利益。尔时世尊。即以偈颂赞叹方便波罗蜜。而说偈言

  一切诸菩萨　　行诸波罗蜜
  若无方便者　　不能到彼岸
  自利亦利他　　住世间涅槃
  如是无净染　　皆由方便故
  一切诸如来　　所行诸境界
  二乘不思议　　斯由方便力
  是故诸佛子　　欲行如来事
  常当勤修行　　方便波罗蜜
  菩萨常清净　　方便利众生
  实无诸欲垢　　示现行染行
  涅槃池中浴　　方便现诸有
  是名诸菩萨　　不住于二边
  身口意常住　　第一义寂静
  为利益众生　　方便同世间
  如蜂入华林　　不专采一华
  菩萨方便行　　一切诸境界
  或现种种相　　殊妙庄严身
  遍诸宫女中　　行于放逸行
  或现在地狱　　救诸苦众生
  虽现如是相　　常不舍禅定
  不舍诸三昧　　而现散乱中
  示现行损害　　是名方便力
  菩萨已能离　　一切有为行
  于诸有无中　　亦无分别心
  虽现行诸染　　不生妄欲火
  方便中示现　　分别有为相
  菩萨于诸有　　不生亦无退
  示现生退事　　方便智力故
  弃舍魔业处　　住佛境界中
  智慧不怯弱　　示现诸魔事
  菩萨大悲力　　奋迅方便智
  住圣无上处　　而现凡夫事
  以入诸法相　　知诸法体空
  常处于涅槃　　而不舍世间
  诸法自体空　　寂静及无相
  为利益众生　　相好庄严身
  无痴现无智　　无嗔现无慈
  而能益众生　　是名为方便
  菩萨摩诃萨　　住彼如是处
  是名示圣人　　种种诸方便

复次诸善男子。如来应正遍知。更有方便。汝等应知。何以故。诸善男子。诸佛如来。有十二种胜妙功德。犹如醍醐。于诸味中。最为胜上清净。第一能净一切诸佛国土。如来于中成阿耨多罗三藐三菩提。何等十二。一者示现劫浊。二者示现时浊。三者示现众生浊。四者示现烦恼浊。五者示现命浊。六者示现三乘差别浊。七者示现不净佛国土浊。八者示现难化众生浊。九者示现说种种烦恼浊。十者示现外道乱浊。十一者示现魔浊。十二者示现魔业浊。善男子。一切诸佛所有国土。皆是出世功德庄严具足清净。无有诸浊。如此过者。皆是诸佛方便力现为利众生。汝等应知。尔时圣者文殊师利法王子菩萨白佛言。世尊。如来应正遍知。说此十二最上功德清净佛国。如来当于何等国土。成阿耨多罗三藐三菩提。佛告文殊师利。一者彼佛国土众生。毕竟能成胜清净劫。离诸劫浊具足功德。如是净土。如来于中成阿耨多罗三藐三菩提。二者彼佛国土众生。毕竟能成最胜妙时。诸佛法行不失时节。如是净土。如来于中成阿耨多罗三藐三菩提。三者彼佛国土众生。毕竟能成最胜法器受佛正法。如是净土。如来于中成阿耨多罗三藐三菩提。四者彼佛国土众生。毕竟能成净妙智海清净一切诸烦恼垢。如是净土。如来于中成阿耨多罗三藐三菩提。五者彼佛国土众生。毕竟能成柔软之心。其中常有调伏众生。如是净土。如来于中成阿耨多罗三藐三菩提。六者彼佛国土众生。毕竟能成最胜妙乘。能以一乘究竟。取于无上涅槃。如是净土。如来于中成阿耨多罗三藐三菩提。七者彼佛国土众生。毕竟能成胜器世间无有余相。如是净土。如来于中成阿耨多罗三藐三菩提。八者彼佛国土众生。毕竟能成如来正教。无诸一切外道邪法。如是净土。如来于中成阿耨多罗三藐三菩提。九者彼佛国土众生。毕竟能成直心正心无有谄曲。如是净土。如来于中成阿耨多罗三藐三菩提。十者彼佛国土众生。毕竟能成无垢功德。成就一切清净白法。如是净土。如来于中成阿耨多罗三藐三菩提。十一者。彼佛国土所有众生。毕竟能成诸圣人法。其中常有胜福田众。如是净土。如来于中成阿耨多罗三藐三菩提。十二者。彼佛国土所有众生。毕竟能成胜妙道场。过去诸佛于中成道。如是净土。如来于中成阿耨多罗三藐三菩提。文殊师利。是名十二种最胜功德能净佛土。如是净土。如来于中成阿耨多罗三藐三菩提。文殊师利。我佛国土。无有声闻辟支佛等差别之说。何以故。诸佛如来。离于种种取相过故。文殊师利。如来若为一种众生说于大乘。一种众生说缘觉乘。一种众生说声闻乘。如是说者。是如来成不清净心。是如来成不平等心。是如来成斗诤过心。是如来成无有平等慈悲之心。是如来成诸相过心。是如来成于诸法中生悭吝心。文殊师利。我为众生说于何等何等之法。彼一切法。随顺菩提随顺大乘。取一切智。毕竟究竟能到一处。谓能到于一切智处。文殊师利。是故我土无乘差别

尔时圣者文殊师利法王子菩萨白佛言。世尊。若无三乘差别性者。何故如来。为诸众生说三乘法。而言此是声闻学乘。而言此是缘觉学乘。而言此是菩萨学乘。佛告文殊师利。诸佛如来说三乘者。示地差别。非乘差别。诸佛如来说三乘者。说法相差别。非乘差别。诸佛如来说三乘者。说人差别。非乘差别。诸佛如来说三乘者。示少功德知多功德。而佛法中无乘差别。何以故。以法界性无差别故。文殊师利。诸佛如来说三乘者。令诸众生悉入如来诸佛法门。令诸众生渐入如来大乘法门。如学诸伎次第修习。文殊师利。譬如射师于射智中。究竟到射第一彼岸。能以种种无量方便教诸弟子。如己知见一切究竟。文殊师利。如来射师亦复如是。于诸法中。皆悉究竟到于彼岸。即以如来一切智智分别而说。示诸众生三乘差别。如世射师教诸弟子。文殊师利。譬如少火所有灾炎。渐渐增长能遍世界。乃至成于劫烧大火。文殊师利。如来智火亦复如是。即彼一智光明之性。次第增长成就如来一切知见大智光明。能烧一切诸染烦恼。文殊师利。譬如诸大须弥山王。无分别心。众生到者皆同一色。所谓金色。文殊师利。如来世尊无上大智须弥山王亦复如是。于诸众生无有分别。若有众生入佛法者。彼诸众生皆成一色。所谓一切种智妙色。文殊师利。譬如因陀罗净妙清色摩尼宝珠。置在一切器世间中。彼摩尼宝所有境界。彼境界中一切诸色种种诸相。摩尼珠力皆同一色。所谓青色。文殊师利。如来世尊无上青色摩尼宝珠亦复如是。智慧光明照众生者皆同一色。所谓一切种智之色。文殊师利。譬如大海无量百千河涧水入。入已一切皆同一味。所谓盐味。以常住故。文殊师利。大海水者。名为如来一切智慧。种种河涧水皆入者。名为声闻缘觉菩萨。入已一切同盐味者。名为一乘。常住者名无分别一切种智。文殊师利。依此义故。汝应当知无乘差别。文殊师利。是故佛说地差别者。示诸众生三乘作业渐次令入。说法相差别者。示现众生如来种智渐次令入。说少功德知多功德者。示诸众生三人差别。示现如来奋迅方便无碍辩才。文殊师利。诸佛如来说三乘者。依世谛说。文殊师利。诸佛如来说一乘者。依第一义说。第一义者。唯是一乘。更无第二故。文殊师利。我佛国土所有外道。僧佉毗世师遮梨迦尼干子等。皆是诸佛如来方便。皆是如来神力住持世间能见。何以故。以诸如来善除一切诸恶对故。文殊师利。诸佛如来名为善逝。有怨对者无有是处。文殊师利。譬如世间转轮圣王。成就少分善根功德。断绝善根非究竟法。具足一切贪嗔痴等。诸结烦恼不离三有。不离一切诸使烦恼。不离一切垢染烦恼。彼转轮王。毕竟无有一切怨对。毕竟无有一切敌对。何以故。文殊师利。以转轮王无怨刺故。文殊师利。何况如来成就一切功德智慧。得不断绝大慈悲心。行于无漏虚空法界。满足七觉诸善功德。毕竟成就不忘失法。能转无上大妙法轮。毕竟成就无上菩提。而有棘刺诸魔怨刺外道敌对。无有是处。文殊师利。我佛国土所有僧佉毗世师遮梨迦尼干子等。皆是如来住持力故。方便示现。文殊师利。此诸外道善男子等。虽行种种诸异学相。皆同佛法。一桥梁度。更无余济故。文殊师利。一切禽兽。无有能于师子王前立出声者。文殊师利。如来师子大丈夫王。具足十力四无所畏。一切外道尼干子等。无一敢于如来境中与佛世尊诤法是非。作师子吼者无有是处。除诸如来方便力者。文殊师利。譬如日轮出能放大光明罗网。一切诸虫萤火光明皆悉休息。一切摩尼诸火光明亦不能现。文殊师利。如来出世。放大智慧日轮光明。一切外道尼干子虫萤火智慧诸光明等。皆悉闭塞不能显现。文殊师利。譬如铁王名阿塞件陀。彼所在处。一切凡铁皆不敢住。何以故。以独相故。不共凡铁同在一处。文殊师利。如来铁王亦复如是。随何国土出世之处。一切凡铁诸外道等。皆不得生。何以故。以佛如来独相出世故。文殊师利。譬如何等何等处所有如意宝摩尼王出。彼处不生伪琉璃珠。文殊师利。如来如意大智宝王。随何国土出现于世。彼处一切诸外道等。皆不得生。文殊师利。譬如何等宝性中出阎浮檀金。彼处不出诸铜铁等。文殊师利。如来宝性亦复如是。随何国土出现于世。彼处不生诸外道等。文殊师利。依此义故。汝应当知。随何国土如来出世。彼处不生诸外道等。何以故。文殊师利。我佛国土有诸外道尼干子等。皆是如来住持力故。为欲示现不可思议方便境界。何以故。此诸一切诸外道等。皆是住于不可思议解脱门故。皆是大智究竟般若波罗蜜门故。一切皆得大方便力奋迅自在故。一切皆得不舍佛法僧等念故。一切皆到第一彼岸。以大神力教化众生故。一切皆得如来加力教化众生故。说此一乘门时。八千天子依声闻行。闻一乘已。发阿耨多罗三藐三菩提心。五百比丘得住一乘平等大智灯明三昧。千二百万菩萨得无生忍。此三千大千世界六种震动。诸天在于虚空界中。悉皆雨天优钵罗华。钵头摩华。拘牟头华。分陀利华。雨天栴檀诸末香等。一切盈满。如来足下。无量百千诸天子等。住虚空中。作诸百千种种伎乐。俱出妙声供养如来。雨天衣雨击诸天鼓。而作是言。我于世间。未曾闻此希有上妙最胜法门。复白佛言。世尊。愿此法门。究竟住于阎浮提中。作大饶益一切众生。八千比丘尼。各各脱身所著上衣。奉献如来。尔时世尊而说偈言

  文殊汝当知　　诸佛胜方便
  我出有法时　　方便示时浊
  一切时有法　　毕竟常清净
  随众生受法　　故现众生浊
  诸佛胜智人　　出于妙劫中
  国土常清净　　是故说无浊
  我于无量劫　　具足修苦行
  清净诸业障　　得胜智功德
  能于无量劫　　寿命常无尽
  除佛方便力　　是故无命浊
  众生起常想　　故我示无常
  以无数劫命　　示行短寿相
  如来胜功德　　无量劫所修
  薄福怯众生　　闻生惊怖心
  为此众生故　　分别差别说
  究竟皆成佛　　更无有余乘
  我为化众生　　分别说余道
  渐化令入一　　故无三差别
  譬如善射师　　快能知刀箭
  为教诸弟子　　一艺种种说
  如来亦如是　　为成就众生
  而于一法中　　种种差别说
  我于诸众生　　无有差别心
  以器不同故　　所说有分别
  若无平等心　　人说我悭嫉
  自取最上乘　　与众生下法
  上因陀罗宝　　随处青光色
  普照物皆同　　而宝无分别
  佛无上智宝　　光明照世间
  同一菩提色　　离诸分别心
  譬如微少火　　增长成大明
  诸罗汉少智　　增长成佛慧
  一切诸众生　　往诣须弥处
  依须弥光力　　一切同一色
  如是诸众生　　住佛须弥法
  如来法力故　　同一佛色身
  譬如蜜蜂嘴　　集诸种种物
  置在一器中　　和合成一味
  佛说三亦尔　　为熟众生根
  说诸种种法　　成佛菩提味
  譬如转轮王　　出无怨敌对
  我法王出时　　亦无外道刺
  譬如日轮出　　余光皆闭塞
  佛日轮出已　　外道自除灭
  随生铁王处　　不生余凡铁
  随佛所生处　　不生诸外道
  随生妙金处　　不生余铜铁
  随佛成道处　　自然无外道
  譬如摩尼宝　　不共秽杂住
  是故出生处　　无伪琉璃珠
  如来摩尼珠　　出处亦如是
  不杂诸外道　　同时一国土
  外道大神通　　皆自在菩萨
  汝当知方便　　示现如是相
  一切诸菩萨　　闻诸外道等
  具足方便力　　皆发欢喜心
  各各生尊重　　奉献恭敬意
  散华供养佛　　种种妙香薰
  于彼说法时　　大地六种动
  虚空出声言　　希有未曾闻
  无量诸天子　　空中合掌赞
  同声言善哉　　善哉修伽陀

    大萨遮尼干子所说经诣严炽王品第四

尔时南方国大萨遮尼干子。与八十八千万尼干子俱。游行诸国教化众生。次第到于郁阇延城。复有无量百千诸众。或歌或舞吹唇唱啸。作百千万种种伎乐。前后侍从。大萨遮尼干子。诣郁阇延城。尔时国主严炽大王。闻大萨遮尼干子众。从南大国与无量众诣郁阇延。闻如是已。即生尊重大萨遮尼干子心。生尊重心已。为欲迎大萨遮尼干子。以大王力王神通力王奋迅力。与诸大臣及诸王子。受学师长。合家眷属国大长者。诸小城邑聚落土主。象马车步四部大众。前后导从恭敬围绕。椎钟鸣鼓。作百千种无量伎乐。打百千种诸妙声鼓。吹百千种诸妙声蠡。建百千万种种杂色缯盖幢幡。散百千万种种妙华。优波罗华。钵头摩华。拘牟头华。分陀利华。阿输迦华。薄拘罗华。鞞罗迦华。阿提目多伽华。遍布道路。金瓶银瓶盛百千种诸杂妙花。以百千种诸宝香炉烧无价香。置前而行诣萨遮尼干子处。时大萨遮尼干子。遥见严炽王与大众来。萨遮尼干子见已下道。在一树下敷座而坐。时严炽王。遥见萨遮在树下坐。即下象舆。步诣萨遮尼干子所。坐摩尼宝百千巧妙无价庄严如意宝床。时大萨遮尼干子问讯于王。作如是言。善来大王。王今善种无上最胜希有功德。福多不少。何以故。以王能降天尊贵重自在之心。屈意卑下来诣沙门问讯起居。大王。于汝所治国内。无诸盗贼亡命群党乱人民不。无有诸官残暴侵食诸人民不。无诸异业奸伪憍诈欺诳世间诸人民不。无诸反叛娆乱国土诸人民不。无诸偷劫相窃盗不。所在边国诸官禁司无欺大王不行王命不。大王。汝所治化国内。所有沙门修净行人安乐住不。衣服饮食房舍卧具疾病汤药资生所须一切之物不乏不少不。汝国人民皆得善心。尊重供养诸沙门众净行人不。大王。汝今所治国内。无诸屠猎罗网河岳焚烧山泽放鹰走狗钩刺鱼鳖弹射禽兽作诸坑陷毒箭机拨行杀害不。大王。汝今一国之主。制命自在。教令善恶。无敢违者。汝登王位所设教令无不善不。国内人民所行善恶汝悉知不。能行善者汝劝进不。行不善者汝劝舍不。大王。汝身不起恶念加害一切二足四足多足无足诸众生不。何以故。大王。当知一切众生有识之类。宝重身命无不畏死。至于业对百年寿终。莫问老少无一引分言应去者。何以故。爱命重故。何况加害而不生恼。命终之后更相怨嫉。与怨相报无有穷已。是故大王。汝当远离杀生之罪。舍离刀杖无起害心。大王。汝今应当远离偷盗之罪。舍自资生当生知足。于他资生无起欲心。大王。汝今应当远离邪淫之罪。自妻知足他妻无求。无起邪心。大王。汝今应当远离妄语之罪。常作实语出言成法。无发虚言。大王。汝今应当远离两舌之罪。无破坏语。于已破者当念和合。无起坏心。大王。汝今应当远离恶口之罪。常作爱语柔软妙语无起粗语。大王。汝今应当远离绮语之罪。常决定语忆念语。无不正语。大王。汝今应当远离贪欲之罪。于他受用无希望心。于他所护无生夺心。生欢喜心。大王。汝今应当远离嗔恚之罪。常生慈心清净心业。无起恨心。大王。汝今应当远离邪见之罪。见自业果随顺圣人。而生正见无起异见。何以故。杀生之罪。能令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者短命。二者多病。偷盗之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者贫穷。二者共财不得自在。邪淫之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者妇不受语。二者自妻为他侵夺。妄语之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者常为他人所谤。二者常为他人所诳。两舌之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者得破坏眷属。二者得弊恶眷属。恶口之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者不闻善名。二者常起斗诤。绮语之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者得不敬重语。二者言无定实不为他乐。贪欲之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者不知足。二者常生贪心。嗔恚之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者无安隐心。二者常念损害无有慈心。邪见之罪亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者常生邪见家。二者心常謟曲。大王当知。如是无量无边苦聚。皆由十不善业集因缘故。是故大王。汝莫放逸轻作恶业。当观诸法有为无常。一切世间无可保者。人命无常住少时间。勿生常想。大王当观。劫初已来天尊王位土地人民。皆就无常。无一在者。当知此身甚为危脆。如焰如响如影如电。如水中月如镜中像。如水聚沫如水上泡。如芭蕉实如琢石火。如梦所见。如山谷中瀑水卒起。遍满沟涧须臾过尽。还就枯竭。大王当知。身命非实无常亦尔。俄尔零落就未来世。不可免脱。是故大王。莫恃现在。当畏未来。大王当知。善恶果报共相追逐。如声发响如影随形。无能免者。亦如连锁不可断绝。莫轻作业自招重苦。尔时大萨遮尼干子。重说偈言

  大王汝今当　　莫作放逸行
  若不舍诸恶　　死必入地狱
  以作恶行者　　定入泥犁故
  摄心不放逸　　生天帝释处
  一切诸众生　　无不爱寿命
  王若求长生　　不应行杀害
  大王知世人　　辛苦集财宝
  常忧不活命　　不应起侵夺
  以不侵夺故　　生处常富足
  若故侵损他　　常生贫穷家
  节己莫淫他　　自妻生足心
  是故妻爱己　　不为他人侵
  莫说虚妄言　　常念依实语
  实语生帝释　　妄语生饿鬼
  常念离两舌　　和合破坏人
  眷属常雍穆　　退此生梵天
  出言莫粗矿　　说令他乐闻
  善语生天上　　常闻美妙音
  念离诸绮语　　善思美妙言
  报生天帝释　　诸天钦受教
  若欲自利益　　莫令侵恼他
  生贪来世报　　钱财资五家
  若不修慈悲　　能行嗔害心
  虽行诸善行　　死入于泥犁
  大王汝今当　　应舍嗔恚痴
  常慈念众生　　莫行诸怒害
  王当舍邪见　　坚固正见心
  常持清净法　　天中受乐身
  比丘修梵行　　汝当常供养
  是故舍恶道　　受乐于天上

尔时大萨遮尼干子问讯王已为严炽王说不放逸十善业道相应法已。默然而住

大萨遮尼干子所说经卷第二大萨遮尼干子所说经卷第三

        元魏天竺三藏菩提留支译

    王论品第五之一

尔时国主严炽王。闻大萨遮尼干子所说正法。欢喜信受。即时问讯大萨遮尼干子言。大师仁慈。而能远涉游化众生。道路多难。不审大师。四大调和气力安不。众生易化不。诸弟子众如说行不。幸蒙大师不耻我国。今得奉见闻说正法。我心欢喜。如见慈母。如饥得食。如渴得水。如裸得衣。如贫得宝。如热得凉。如寒得火。如盲得视。如聋得听。如囚得赦。如贱得贵。如迷得返。如学逢师。我心欢喜。亦复如是。复作是言。大师当知。我从向来。心自思念。正法难闻。良师难遇。人身难得。诸根难具。正见难生。信心难发。合会难俱。自在难逢。太平难值。如是诸难我皆免离。今遇大师。如入大海欲采珍宝得大宝渚。我有所疑悉欲请问。惟愿大师。赐决所疑

时大萨遮尼干子告严炽王言。随王所疑今悉可问。我当为王分别解说。除决所疑令王开解。尔时严炽王。见大萨遮尼干子听许问已。心生欢喜而发问言。大师。何等生法何等住持。于何法上而有此名。萨遮尼干子言。大王当知。所言生者。谓诸众生。言住持者。谓器世间。言众生者。谓五取阴聚。名为众生。以何等法名五取阴。谓色取阴聚。受取阴聚。想取阴聚。行取阴聚。识取阴聚。大王当知。依此五法。说名众生。说器世间。说众生者。谓摄四生。卵生胎生湿生化生。说器世间者。谓摄虚空地水火风。王言。大师。谁能护此一切众生。谁能护持此器世间。答言。大王。皆是众生自业果报。及王国主力能护持。王复问言。大师。云何自业果报能护众生。答言。大王。有诸众生。自业增上果报力故。而生胜处。而彼众生。于一切物无吝护心。不生彼我自他之心。一切所须资生之物。不加功力随念具足。尽其命住安隐快乐。离粗病苦寒热饥渴种种痛恼。亦无恶心迭相加害。亦无欺诳虚妄之心。聚落城邑七宝庄严。常行胜乐妙触境界。满足千岁寿尽舍身。而生天上善道受乐。如此所谓北郁单越业护众生。大王当知。复有众生。依于自业果报力故。生胜妙处。身有光明飞腾虚空。处禅悦乐以为美食。不入胎生。寿命无量住世长远。如此所谓劫初众生。大王当知。复有众生。依自业报过去功德胜因力故。生世间中。而知敬心尊重父母及家尊长。并诸沙门净行人等。以为福田。常行善行作所应作。畏于恶行。常受善持五戒八戒。而作布施集诸福德。此谓劫初第二时中善根众生。大王当知。尔时众生。善根满足不起诸恶。是故世间未立王法。如是名为自业果报能护众生

王言。大师。如是业护我已知竟。云何名为国主王力能护众生。答言。大王。诸王众生是众生主。而彼主力能护众生。王言。大师。彼诸王等何故名王。答言。大王。王者民之父母。以能依法摄护众生令安乐故。名之为王。大王当知。王之养民当如赤子。推干去湿不待其言何以故。大王当知。王者得立以民为国。民心不安国将危矣。是故王者。常当忧民如念赤子不离于心。当知国内人民苦乐。以时安行。知水知旱知风知雨。知熟不熟知丰知俭。知有知无。知忧知喜。知老知少。知病不病。知诸狱讼。知有罪知无罪。知轻知重。于诸王子大臣诸官。知有功者。知无功者。如是知者名不离心。大王当知。王于国内如是知已。以力将护。所应与者及时给与。所应取者念当筹量。役使知时不夺民利。禁肃贪暴民得安乐。是名摄护。名之为王

大王当知。王有四种。一者转轮王。二者少分王。三者次少分王。四者边地王。转轮王者。有一种转轮王。谓灌顶刹利统四边畔。独尊最胜护法法王。彼转轮王七宝具足。何等七宝。一者夫人宝。二者摩尼宝。三者轮宝。四者象宝。五者马宝。六者大臣宝。七者主藏宝。彼转轮王。如是七宝具足成就。遍行大地无有敌对。无有怨刺。无有诸恼。无诸刀仗。依于正法。平等无偏。安慰降伏。王言。大师。云何名为转轮圣王统四边畔。答言。大王。以王四天下得自在故。王言。大师。云何名为独尊最胜。答言。大王。所出教令无违逆故。王言。大师。云何护法。答言。大王。修十善法。不令邪法杀生等坏。名为护法。王言。大师。云何法王。答言。大王。转轮圣王。以十善道化四天下。悉令受持离十恶业。行十善道具足成就。名为法王。王言。大师。彼转轮王。依何因得第一夫人宝。云何成就。答言。大王。转轮圣王。依离嗔心不善业故。得夫人宝。与己相对受最胜乐。名为成就。云何名为受最胜乐。大王当知。彼转轮王。夫人身中。常出无价栴檀妙香。口中常出优钵罗华无价之香。身体柔软如迦陵伽鸟。迦陵迦鸟在大海渚。彼诸众生。若有触彼迦陵伽鸟者。即得远离身诸疲劳。亦离饥渴并诸忧恼。受最第一无极快乐。转轮圣王。见彼夫人。所受快乐亦复如是。大王当知。彼夫人身。寒时能暖热时能凉。世间无人手能触彼夫人身者。何以故。以离贪心不善业道依善根因故。一切众生观察敬重。如母如女如姊妹故。而彼夫人。于转轮王生三种心。何等为三。一者心常尊奉于王不生异心。二者心常恭敬于王。三者心常念转轮王。何以故。以王能离贪心垢故。复次大王。转轮圣王夫人宝者。离于女人五种恶法。何等为五。一者离于女人无志轻躁之心。二者离贪余男子心。三者离于悭嫉妒心。四者离于非处起贪颠倒之心。五者转轮圣王命尽彼亦俱尽。复次大王。彼夫人宝。有五种功德。何等为五。一者知念不违王心。二者能生千子具足。三者自然姓尊豪贵。四者能令住处具足一切资生。五者若王与诸女人受欲乐时。不起嫉妒嗔恨恶心。复次大王。彼转轮王夫人。成就三种功德。何等为三。一者离恶口。二者离邪见。三者若王余行不在五欲境界不能动心。大王当知。转轮圣王夫人。舍身生于天上。何以故。以离贪嫉故。如是名为转轮圣王夫人功德。令王受于最胜上乐

王言。大师。转轮圣王。依何因得彼摩尼宝。答言。大王。转轮圣王。依离嗔心不善业故。得彼第二摩尼珠宝。得受最胜光明资生无上乐故。云何最胜。大王当知。转轮圣王摩尼珠宝有八种功德。何等为八。第一功德者。彼摩尼宝。于夜黑闇放大光明。如秋满月。光明能照一百由旬。至于夏日众生患热。以摩尼宝放光触身。得清凉故。第二功德者。转轮圣王。若行旷野无水之处。众生饥渴时。摩尼宝即放八味具功德水。充足饥渴。第三功德者。转轮圣王。有所须者。一切皆从摩尼宝出。第四功德者。彼摩尼宝有八楞相。一一楞中出种种光。谓青黄赤白颇梨红紫。第五功德者。彼摩尼宝在所。能令一百由旬所有众生。皆离病苦常得定心。所作善业无空过者。第六功德者。彼摩尼宝所住境界。无诸恶龙能放毒气。雹风恶雨伤害众生。第七功德者。一切山川溪谷沟涧泉水干竭悉令还复。树林草木华果枯悴。能令滋茂。钵头摩等池水华林一切具足。第八功德者。彼摩尼宝所在之处。人民无有疾疫诸毒非时死者。至于畜生虎狼师子蛇鼠猫狸鹰鹞之类。相食啖者不起害心。复次大王。转轮圣王。千子满足身体洪壮。勇猛雄杰降伏世间。随顺王命。能护大法。随顺法行。心能慈愍一切众生。是名转轮圣王摩尼宝用。令王得受最上胜乐

王言。大师。转轮圣王。依何因得第三轮宝。答言。大王。转轮圣王。依离嗔心不善业故。得彼轮宝。所住之处自然降伏得大胜乐。王言。大师。云何名为得大胜乐。大王当知。转轮圣王。所有轮宝具足。能有五种功德。何等为五一功德者。彼轮宝体纯阎浮檀金。具足千辐广五由旬。显现世间如第二日轮。二功德者。彼轮宝去飞腾虚空无能障碍。一日能行八千由旬。三功德者。随顺转轮王心中念欲。诣四天王行四天下。南阎浮提。西拘耶尼。北郁单越。东弗波提。时彼轮宝。随王念处。即飞虚空。在前而去。依彼轮力。四兵象马及车步等。一切悉皆飞腾而去。四功德者。所有不伏转轮王者。王若心念。而彼轮宝。随所念处即飞而去。悉令降伏。五功德者。彼轮宝势无有敌对。一切小王见者降伏。以转轮王依法修行离嗔心故。是名转轮圣王轮宝之用。令王受于最胜大乐

王言。大师。转轮圣王。依何因得第四象宝。答言。大王。转轮圣王。依离嗔心不善业故。得于象宝。受于第一最胜乘乐。王言。大师。云何名为最胜乘乐。大王当知。彼大象宝。犹如良马调伏柔软随自在用降伏他国。七支善住。所谓四足首及阴尾。是七种支善住大力。力能堪敌凡象千数。白如凝雪。譬如帝释伊罗钵罗象。一切凡象。无能现前来嗅香者。大王。彼象能于三处有自在用。所谓虚空水中陆地。大王。彼象能速疾行一日三匝行阎浮提。大王当知。彼转轮王乘象王者。彼时象王与王心同。随王念处即从而去。行步平正犹如鹅王。不疾不迟不曲不戾。凡人中行不令惊怖。乃至女人有摩触者。心不嗔娆。至斗战时。极能现大凶害之相。不可侵近。行住坐卧眠食拘系。一丝能掣牵挽去住。随顺无违。是名转轮圣王象宝之用。令王受于最胜乘乐

王言。大师。转轮圣王。依何因得第五马宝。答言。大王。转轮圣王。依离嗔心不善业故。得彼马宝。受最迅疾第一乘乐。王言。大师。云何迅疾。大王当知。彼马宝者。色白如彼拘牟头华。天旋轮文遍满身相。不大不小不高不下。身体正足心性柔软善能调伏。如帝释王婆罗何马。随意去住。一日三遍行阎浮提。无疲劳想。大王当知。如是名为转轮圣王马宝之用。令王受于第一迅疾上胜乘乐

王言。大师。转轮圣王。依何因得第六大臣宝。答言。大王。转轮圣王。依离嗔心。得大臣宝。令王闲游。得受第一无事胜乐。王言。大师。云何无事第一胜乐。大王当知。彼大臣者。代王理政一如王心。忧国忘身不营私务。念护百姓如养双目。随王所念。如念即办。不碍不着。修行正道离于非法。随时随处不行恼害。正依王命行十善法。不违善行。不违如法。不违如法义。皆能具足。大王当知。如是名为转轮圣王。大臣宝用。令王得受第一胜乐

王言。大师。转轮圣王。依何因得第七主藏宝。答言。大王。转轮圣王。依离嗔心不善业故。得主藏宝。满王愿心安隐受乐。王言。大师。云何满足安隐受乐。大王当知。彼主藏宝有大功德。一切诸山深涧幽谷。旷野川泽丘陵堆埠。坑坎高下不平之处。能以金刚宝。因陀罗宝。摩罗迦多宝。马瑙宝等。一切珍宝以用填满。而宝不尽。何况金银琉璃颇梨不在数者。彼主藏宝。心常欢喜。无谄曲相。无异心相。不生他恼。一切见者心皆欢喜。大王当知。如是名为转轮圣王主藏宝用。令王满足一切愿乐。大王当知。转轮圣王。具足如是七宝用故。王四天下及诸龙王二种天王。谓四天下三十三天。共天帝释分座而坐。以依离一嗔恨恶心不善业道。得如是等七宝具足。受用胜乐。何况具足行十善道

大王当知。转轮圣王。复有七种。名为软宝。所有功德少前七宝。何等为七。一者剑宝。二者皮宝。三者床宝。四者园宝。五者屋舍宝。六者衣宝。七者足所用宝。王言。大师。云何转轮圣王第一剑宝。有何等用。大王当知。彼剑宝者。转轮圣王所王国内。若有心念违王命者。时彼剑宝。即从虚空飞往诣彼。彼诸小王见即降伏。拜问剑宝。而彼剑宝。不起杀心害一众生。是名转轮圣王剑宝功德。一切国土。不加刀仗自然随顺。大师。云何转轮圣王第二皮宝。大王当知。彼转轮王所有皮宝者。海龙王皮出大海中。大海商主所持奉献。转轮圣王。彼皮宝身。广五由旬长十由旬。体净鲜洁光曜白日。火烧不焦水渍不烂。猛风摧岳吹不能动。体含温凉能却寒热。随王去处皮宝亦去。而彼皮宝。随转轮王所有士众。满十由旬遍覆其上。能作屋舍。充足一切人众所居。而彼人众。各得别屋。不相防碍。是名皮宝功德之用。大师。云何转轮圣王第三床宝。大王当知。彼转轮王所有床宝。立能平正安隐不动。不高不下不广不狭。不长不短不坤不垤。不坚不软不涩不滑。柔软得所。若王入禅坐彼床宝。即入解脱禅定三昧。若王欲起贪嗔痴心。坐彼床宝即时俱灭。女人见王坐宝床者。即皆得离贪嗔痴心。是名床宝功德之用。大师。云何转轮圣王第四园宝。大王当知。彼转轮王。若欲入于禅定之时。入彼园中即得定心。若王欲受五欲乐时。入彼园中。依王所行善业功德。诸天界中所有可乐。华果诸鸟泉水流水池水河水妓乐歌舞戏乐之具。于彼天中自然隐没现于王前。时转轮王。亦如诸天受诸欲乐。是名园宝功德之用。大师。云何转轮圣王第五舍宝。大王当知。彼转轮王。若入彼屋。欲见日月彼诸星宿。即彼屋内一切悉见。彼天宫殿所有种种殊异珍玩。悉见无碍。彼诸天中所作妓乐。屋中悉闻。即离忧恼一切疲劳。于睡眠中极受快乐。于其睡中。梦见种种希妙瑞相。寒时暖风柔软香美。热时凉风清冷适悦。受快触乐。夜二分眠。第三分起。远离睡眠。起受法乐。第四分中说法教化。是名舍宝功德之用。大师。云何转轮圣王第六衣宝。大王当知。彼转轮王所有衣宝。无如世间绢布丝缕。纵横文章第一柔软。一切尘垢不能点污。着彼宝衣。即离寒热。饥渴病瘦忧恼疲极。大王当知。而彼衣宝。火不能烧。刀不能割。水不能烂。是名衣宝功德之用。大师。云何转轮圣王足所用宝。大王当知。转轮圣王足所用宝者。所谓靴等。若王著者。涉水不没如行陆地。入火不烧如清凉池。王欲游行步受戏乐。虽复远行百千由旬。不觉疲极。是名足宝功德之用。大王。是名转轮圣王七种软宝。是十善中少分习气功德果报。非正具足。十善业道

王言。大师。云何名为遍行大地无有敌对。云何名为无有诸刺。云何名为无有诸恼。云何名为无有刀仗。云何名为依于正法。云何平等。云何名为安慰降伏。答言。大王。遍行大地无敌对者。以遍大地得自在故。无诸刺者。以无恶对怨敌刺故。无诸恼者。不以强力威逼人故。无刀仗者。离于刀仗不行损害故。依正法者。以离非法贪嗔痴使行于正法化愚闇故。平等者。等慈众生。如念一子不偏护故。安慰降伏者。余王众生各各住处。不移不夺安隐住故。何以故。大王当知。转轮圣王王四天下。彼时彼处所有城邑。有诸小王。彼诸小王迎转轮王。而作是言。大王当知。此诸大地。如是安隐。如是满足。如是大丰。如是大乐。如是无病。衣服饮食自然而得。无诸苦恼。多诸众生人民象马一切满足。皆是大天圣王所有。随王受用。我等随顺大王教命无敢违逆。时转轮王告诸王言。汝诸王等。各安汝国。我来为汝不为国土。汝等当依正法行化莫依邪法。依平等心莫依偏心。汝等国内。若邪法起速除灭者。是顺我命。名受汝国。若不除灭。我当与汝极大重罪。大王当知。如是名为转轮圣王护诸众生。诸小王者。谓少分王。次少分王。边地王。彼二种王。随顺转轮圣王教令。大王当知。如是名为大地国主王化众生。王言。大师。诸余小王。依何等法。治国养民得为如法。答言。大王。诸小王等。依王论法。以道治国。护诸众生。除转轮王。何以故。转轮圣王出在世时。彼时众生。离诸不善恶贪法心。离颠倒贪心。离邪见心。彼彼诸国。无有非法屠猎师等。何以故。依法王法。明识罪福。心不迷闷。不疑于法。动则合理。不生过非故。大王当知。如是名为转轮圣王依自业力功德护持于彼世。时诸小王。论一切不行

大萨遮尼干子所说经卷第三大萨遮尼干子所说经卷第四

        元魏天竺三藏菩提留支译

    王论品第五之二

王言。大师。于何时中。诸小王等。行王论法。答言。大王。于末世时。转轮圣王隐没不现。正法不行邪法竞兴。众生心恶起三种过。一者乐于非法贪心。二者起于颠倒贪心。三者邪法罗网缠心。彼诸小王。自无智慧退失明解。是故圣人说诸小王治国论法。为行正法护世众生。王言。大师。云何名为乐于非法贪心。答言。大王。于十不善恶业道中生于乐心。是名乐于非法贪心。云何名为颠倒贪心。自己手力得诸资生。依时节得。依正法得。依如法得。不生足心。更求他财。如是名为颠倒贪心。王言。大师。云何名为邪法罗网之所缠心。答言。大王。于诸外道非义论中起义论想。于无益论生利益想。于非法中生是法想。于末世时。非是智者所作论中。以为正论。生于信心。熏修邪见。以为福德。是名邪法罗网缠心。王言。大师。以何等法。名为王论。令诸小王依彼论法治国理民。是名如法能护众生。答言。大王。离诸颠倒贪欲之心。离诸颠倒嗔恚之心。离诸颠倒愚痴之心。依对治依实体。依差别依利益。依对治依实体者。对所治法。所谓名为不贪善根不嗔善根不痴善根。云何能起所治法能治法。所治法者。谓放逸心及无慈心。能治法者。谓行法行王。不放逸心大慈悲心。知身无常资生无常。善自观身见诸过失。能如实知。如是远离受用资生。行法行王。虽得自在不行非法。如是名为不放逸心。大王当知。依王论法。不应得物。得不应取。所应得者。非时不敢取。若依时节应得之物。于贫穷人不逼恼取。至于俭难贼难返逆难相害难。如此难时。当起慈心不避危害护诸众生。于贫穷者施与衣食。于恶行者教以善法。是名慈心。大王当知。依此二法。是则名为行法行王。正护众生不放逸心大慈悲心

王言。大师。行法行王。有慈悲心。云何而能治彼恶行诸众生等。答言。大王。彼法行王。若欲治彼恶行众生。先起慈心。智慧观察。思惟五法。然后当治。何等为五。一者依实非不实。二者依时非不时。三者依义非无义。四者依柔软语非粗犷语。五者依慈心非嗔心。王言。大师。云何依实非不实。答言。大王。如法诘问。取其自言。依实过治。不依不实。是名依实非不实。王言。大师。云何依时非不时。答言。大王。王有力时。彼违王命。应治其罪。若王无力。应止不治。是名依时非不时。王言。大师。云何依义非无义。答言。大王。当问前人。何心起罪。若从恶心。应如法治。若非恶心。不应治罪。是名依义非无义。王言。大师。云何柔软非粗犷语。答言。大王。知此众生所犯王法。但应呵责不合余治。应如其过正说不隐。善说苦言如是呵责。非不呵责。是名软语非粗犷语。王言。大师。云何慈心非嗔心。答言。大王。智者知此非但呵责。断此罪过除却断命。不得割截手脚眼耳鼻舌。依于大慈大悲之心。听系闭牢狱。枷锁打缚。种种呵责。夺取资生驱摈他方。为令改悔。非常恶心舍此众生。是名慈心非嗔心。王言。大师。行法行王。云何如是苦他众生。系闭打缚驱摈他方。而复说言。有慈悲心。二法相违。云何名为行法行王。尔时大萨遮尼干子告言。大王。如此之义。我今为汝说于譬喻。大王当知。譬如父母于恶行子。为念子故。欲令改悔。方便苦治。除不断命不坏诸根。余打骂等随心苦治。不名舍心。不名恶心。不名恼心。以念子重。为令改悔更不作故。而彼父母不名非法。名为念子。不失慈心。大王当知。行法行王。治诸一切恶行众生。亦复如是。慈心重故。为令改悔。除却断命不坏诸根。生大慈心起大悲心。系闭打缚恶口呵骂。夺其资生驱摈他方。为令改悔舍恶从善。亦令其余念恶众生不作非法。非常恶心舍此众生。亦不故心为恼众生而行苦切。如是名为行法行王。以慈悲心行恶口等治罪众生。不名非法不失慈心。是故二行名虽有返。而不相违

王言。大师。何等是恶行众生。答言。大王。恶行众生略说有五。如是应知。何等为五。一者于王无利益众生。二者迭共作无利益众生。三者起逆众生。四者邪行众生。五者邪命众生。大王当知。于王无利益众生。有十一种。何等为十一。一者返逆众生。二者教他返众生。三者与王毒药众生。四者夺王资生众生。五者破王所应作事众生。六者侵夺王妻宫女众生。七者违王命众生。八者出王密语众生。九者觇伺国土众生。十者骂王众生。十一者毁呰王众生。如是等。大王当知。是名于王无利益众生

大王当知。迭共作无利益众生者。有十种。何等为十。一者迭共相杀众生。二者迭相劫夺众生。三者迭相侵妻众生。四者虚妄证他众生。五者虚妄诳他众生。六者坏他亲友众生。七者恶口骂他众生。八者恶业斗秤欺诳损他众生。九者迭相毁呰众生。十者迭相焚烧众生。大王当知。如是等名迭共作无利益众生

大王当知。返逆众生者。谓诸边地城邑小王聚落主等。不臣根本大王教命。如是名为返逆众生

大王当知。邪行众生者。谓无戒众生。何等无戒。所谓具足诸恶律仪。屠儿猎师畜养猪羊鸡犬鹅鸭猫狸鹰鹞钓射鱼鳖造诸罗网火坑毒箭劫夺虫兽断害他命自恣作恶。如是名为邪行众生

大王当知。邪命众生者。所谓出家剃除须发断诸资生修无著行。着诸种种异相衣服。不护禁戒起种种见行诸异行。种种方便求诸利养非法活命。各各不能自法中住。如是名为邪命众生

王言。大师。行法行王。云何治彼五种众生。答言。大王。行法行王。治彼罪人不断其命。不行割截眼耳鼻舌手足身根。有三种治法。何等三法。一者呵责以为治罪。二者夺其所有资生以为治罪。三者牢狱系闭枷锁打缚呵骂驱摈以为治罪。随彼五种作恶众生。上中下罪三种法治。是名行法行王治彼五种作恶众生

王言。大师。行法行王。云何治彼于王作无利益众生。答言。大王。如是罪人。除不断命不坏诸根。得系闭牢狱枷锁打缚夺其资生驱摈他处以为治罪。大王当知。如是名为行法行王治彼于王作无利益众生之罪

王言。大师。行法行王。云何治彼迭共作无利益众生。答言。大王。除不断命不坏诸根。得系闭牢狱枷锁打缚。不得全夺所有资生。六分之中夺其一分驱摈他处。大王当知。如是名为行法行王治彼迭共作无利益众生之罪。王言。大师。行法行王。云何治彼起逆众生。答言。大王。行法行王。先以善言如法开示。若闻王命即舍逆心。请罪王所者。王放大恩恕其重罪。依其国土王领之处。不减不夺亦不驱出。何以故。为令知王有三种事故。何等三事。一者有信。二者有恩。三者大力。未降伏者为令降伏。已降伏者令不更作。欲返逆者令不敢起。大王当知。彼有罪人得免其罪。还伏王位人民安隐。彼如法王。得福无量善名流布。若彼罪人。闻大王命不肯伏罪。当加重治。不得断命不坏诸根。尽夺资生国土人民。驱摈他处。何以故。为余众生不起逆故。大王当知。如是名为行法行王治彼起逆众生之罪

王言。大师。行法行王。云何治彼邪行众生。答言。大王。如是恶人。不得断命。不坏诸根。不得驱摈。不得夺其资生之物。惟呵责治罪。而作是言。若汝更作如是如是事者。与汝重罪。是名行法行王治彼邪行众生之罪

王言。大师。行法行王。云何治彼邪命众生。答言。大王。应当随顺如法僧众。大王当知。若彼比丘。破戒邪见。不依正法如实修行。邪命自活者。僧当和合唤令现前取其自言。彼若自引所作是罪。随犯轻重当如法治。若彼比丘。拒违僧命。不从师友善知识语。恼乱众僧不得修道者。若彼国主。是法王者。僧当往语令王教敕顺从僧命。尔时行法行王。先应唤彼破戒比丘。善言劝喻令顺僧命。若其不从。当集二众现前对实。若得其罪。助如法众。治彼比丘。不得断命。不得割坏一切诸根。不得囚闭。不得枷锁。不得挝打。不得脱袈裟。不得夺其资生之物。得呵责得驱摈。大王当知。若有二众朋党诤讼。依破戒依邪见。依颠倒邪行。依种种邪命。起种种异诤种种异说种种异语。行法行王。若自知法若自知义。应当如法断彼诤事。若彼国王闇钝无知。不自知法不自知义。不知正法。不知邪法。不知如法众。不知非法众。不知如法语。不知非法语。尔时彼王。应问国内大德沙门知法知义有大智慧常行正法利益众生善知断诤能如法语者。问其正法知犯非犯。如是知已。然后如法为灭彼诤。大王当知。如是名为行法行王治彼邪命众生之罪

王言。大师。若彼国王闇钝无智。国内多诸沙门婆罗门。所行各异。互相是非。各各自言。我是沙门修正道者。能利众生。我是福田应受供者。如是各各互相是非。云何得知。是真沙门。非真沙门。是正道是邪道。是如法语非法语。大王当知。有大沙门释迦子。出家为道。得神通证。有大名称如来应正遍知。彼诸弟子比丘比丘尼。于彼瞿昙法中住者。是真沙门。能行正道利益众生。是福田者。能知正法。是如法语者。大王当知。除彼沙门瞿昙法外。余诸一切婆罗门等。是名邪道。非实沙门。非法语者。不应取语。何以故。大王当知。彼无正法。云何能得如法之语

王言。大师。若彼国王闇钝无智。不知王论。不行正法。自在作恶。是国王罪。谁应当治。答言。大王。彼王自身自罪自治。王言。大师。云何自身而自治罪。答言。大王。彼王当依二法自治。何等二法。一者依自力。二者依外力。依自力者。彼王应当如是思惟。我今所行。为是放逸为非放逸。为有慈心为无慈心。为是应作为不应作。为是善业为是恶业。若知所作是不应作是恶业者。即止不作。生惭愧心。悔过自责。畏恶名称。畏堕恶道。当依二法护惜自身。何等二法。一者放逸。二者无慈悲心。如是名为依自智力自罪自治。若王无智不能如是自思惟者。应于国内处处推求有大智慧善知王论常行正法能如实语诸沙门等。王应自往彼沙门所。若不自往。当遣大臣王子贵人人所重者。诣彼沙门宣王渴仰尊重之心。将至王所。若彼来者。王应迎送礼拜问讯尽恭敬心尽尊重心问沙门言。何等善行何等恶行。行何等法能有利益。行何等法无有利益。我心闇钝无有智慧。愿为我说。时彼沙门。应当为王广说过去行法行王所行之法诸王论法。以柔软语语彼王言。如是如是法应当奉行。有大利益。谓十善法。不杀生等。如是如是法不应行。无有利益。谓十恶法。如杀生等。如是如是等是行法行王所行之法。王今不知。应舍十恶等恶行法。应行十善等善行法。闻已受持如法改悔。若能如是名依外力自罪自治。王言。大师。行法行王。云何护器世间。答言。大王。行法行王。不焚烧不破坏不浇灌。是名护器世间行。何以故。一切皆是作不善业。是故行法行王。不应焚烧破坏浇灌城邑聚落山林川泽园观宫殿庄严楼阁一切行路及诸桥梁自然窟宅一切谷豆麻麦花果草木丛林不应焚烧不应破坏不应浇灌不应斫伐。何以故。以彼诸物皆共有命畜生等有。无不用者。而彼众生无有罪过。不应损其所受用物令生苦恼。又彼一切外树林等。诸善净天一切鬼神。皆悉共有于中受用。屋舍宫殿庄严楼观诸天共住。又彼园池屋舍宫殿庄严楼观一切水陆有命诸虫悉皆共用。所谓雀鼠鸡狗鸠鸽鹦鹉象马牛羊猫狸蛇蝎鹅鸭鱼鳖。乃至一切微细诸虫所共受用。行法行王。与诸众生共依止此器世间活。不应破坏。如是名为行法行王护器世间安乐众生。王言。大师。行法行王。无量诸天侍从护王。天力自在能护于人。云何而言人能护天。答言。大王。行法行王。能与彼天正命净食。所谓为说如来正教甘露法门禅定解脱十善道等。令其得离诸恶道苦。以是为护。除诸不善杀生鬼等。何以故。摄在恶命自活众生分故。是故行法行王。即身能集无量功德。资益现在未来。复能集诸善果。大王当知。行法行王。不应焚烧破坏除灭如来塔庙及诸沙门净行人等房舍窟宅资生之物园观楼阁树林华果。亦不应取亦不应贷。除欲为利佛法僧者。王言。大师。行法行王。所有臣佐宰官禁司。不忧国计但求利己。或从私忿以害公政。或受货财以抂治道。增长百姓迭相欺乱。以强陵弱以贵轻贱。以富欺贫以曲抂直。富者获申贫者受屈。谄佞宰政忠贤隐退。或时在朝惧危自默。或行求财货用安己。百姓贫苦不堪充济。厌苦思乱不闻王命。斯由臣吏不行忠节。欺上乱下冒受王禄。如是之人。摄在何等众生数中。答言。大王。如是恶人。摄在劫夺众生数中上品治罪。何以故。大王当知。以其受王名官重禄。舍公念私不存公政。祸乱之生莫不由之。此是国之最大恶贼。王是法王。不得断命。是故摄在劫夺数中上品治罪

王言。大师。行法行王。国内若有不孝众生。不念父母生养之恩。舍背父母与妻子居。所有衣食病瘦医药。念给妻子不与父母。父母衰老出入无力。曾不生忧亲近扶侍。于其妻子昼夜不离。得一美味不敢自啖持与妻子。或偷父母所有财宝。私共妻子欢乐食啖。父母善言不肯随顺。妻子恶语。信用无舍。或为妻子呵骂父母。或共亲族母女姊妹尊卑上下行于淫欲无惭愧心。如是众生。摄在何等众生数中。答言。大王。如是恶人。摄在劫夺众生数中上品治罪。何以故。大王当知。父母恩重。至心孝养犹不能报。何况弃舍违逆教命。是名世间最大劫贼

王言。大师。行法行王。国内有人放逸无慈。于其妻子奴婢眷属。能行不忍非法驱使非时驱使。不应作者强逼令作。至于打骂。无过能行。衣食不充。眠卧无所。唤不及应走则嫌迟。出言常骂如似怨家。如是之人。摄在何等众生分中。答言。大王。摄在邪行众生分中中品治罪。何以故。大王当知。居家资生奴婢共报有其半分。自分衣食恣意着啖。奴婢之分护惜不与。设令给与不依时节。应多与少常令不足。是名世间最大邪行

王言。大师。行法行王。国内有人。于佛法僧作不利益。焚烧破坏塔寺形像及诸经书。恶言毁呰。言造作者。无有福利。其供养者。虚损现在。无益未来。或嫌塔寺及诸形像妨碍处所。破坏除灭送置余处。或破沙门净行人等房舍窟宅。或取佛物法物僧物园林田宅象马车牛驴骡骆驼奴婢僮仆衣服饮食金银琉璃车磲马瑙一切珍宝。或捉沙门策役驱使。责其发调罢令还俗。或时轻心弄诸沙门。欲为戏笑不备时供。虚诳请唤不与饮食。设与饮食不及时节。与非法食。或时轻贱毁呰骂詈恶言诽谤。或以杖木土块瓦石及自手卷打诸沙门。或捉刀槊弓箭鉾戟斫射伤害。或推水中或推火中。或推山涧坑陷之中。或放象马虎狼师子恶狗毒兽伤害其身。如是恶人摄在何等众生分中。答言。大王。如是恶人。摄在恶逆众生分中上品治罪。何以故。以作根本极重罪故。王言。大师。何者根本罪。答言。大王。有五种罪。名为根本。何等为五。一者破坏塔寺焚烧经像。或取佛物法物僧物。若教人作见作助喜。是名第一根本重罪。若谤声闻辟支佛法及大乘法。毁呰留难隐蔽覆藏。是名第二根本重罪。若有沙门信心出家。剃除须发身着染衣。或有持戒或不持戒。系闭牢狱枷锁打缚。策役驱使责诸发调。或脱袈裟逼令还俗。或断其命。是名第三根本重罪。于五逆中若作一业。是名第四根本重罪。谤无一切善恶业报。长夜常行十不善业。不畏后世。自作教人坚住不舍。是名第五根本重罪。大王当知。若犯如是根本重罪而不自悔。决定烧灭一切善根。趣大地狱受无间苦。大王当知。以王国内行此不善极重业故。梵行罗汉诸仙圣人出国而去。诸天悲泣。一切善鬼大力诸神。不护其国。大臣相杀辅相争竞。四方逆贼一时俱起。天王不下龙王隐伏。水旱不调风雨失时。诸龙皆去。泉流河池悉皆枯涸。草木焦然五谷不熟。人民饥饿劫贼纵横。迭相食啖白骨满野。疫毒疫病死亡无数。时诸人民。不知自思所作是过。而怨诸天诉诸鬼神。是故行法行王。为救此苦行治罪法

王言。大师。行法行王。若无染心无恶心者。何故不得慈心断命割截诸根。答言。大王。行法行王。以无染心无恶心故。不能得起如是心念。断众生命割截诸根。何以故。彼法行王。见彼众生至于死时。依自业过生嗔恨心。死已命断生恶道中。恶心随逐长夜不断。是故行法行王。不行断命不坏诸根。何以故。此事难故。若断其命割截诸根。一作已后不可收故。系闭枷锁打缚呵骂等。非永弃舍。是故佛听。行法行王。为护众生。若断其命割截诸根。不名满足护众生者。大王当知。断众生命割截诸根。最是世间大怖畏事故。佛不听行法行王作如是事。王言。大师。行法行王。国内人民。所应输王课调物者。为是王物为是他物。答言。大王。非王自物亦非他物。何以故。他自手力能作能得。是故非王自己有物。非他物者。以王能护彼众生故。是故非是一向他物。彼众生等立如是法。是故输王。王应得分。非是他物。王言。大师。行法行王。若有人民应输王物而不输王。彼民为是偷盗王物。为非偷盗。答言。大王。非偷王物。彼民贪惜欺王不输。得无量罪。何以故。以应输物不输王故。王言。大师。于王国内合输物者而不肯输。然王即行鞭杖打责。若取彼物。为是劫夺。为非劫夺。答言。大王。非是劫夺。何以故。大王当知。以王有力能护其难。彼由王护得安自业。应输王物。故非劫夺。王言。大师。若贫穷人。应输王物以无物故。强加鞭打而责其物。为是劫夺为非劫夺。答言。大王。有人边是劫夺。有人边非劫夺。有人边非劫夺者。彼人若是窳堕懈怠。不勤家业。非法邪淫樗蒱棋博如是等戏。输他财物致贫穷者。如是人边。行法行王。鞭打征责。乃至他边贷物输王。王非劫夺。何以故。王作是念。为令彼人更不敢作非法之事损失财物故。如是王民二俱有益。王得益者。库藏满足。民得益者。资生成就。又得无罪故。王言。大师。何等人边。王是劫夺。大王当知。王虽合得。若知彼人所有家业。为贼劫夺。诈亲人夺。非法王夺。失火焚烧。暴风疾雨飞沙雹石坏其家业。或时住处不得安隐。人民走散失没家生。或有虫螟雀鼠鹦鹉啖伤五谷。或时复值天旱不熟水涝不收。如是等缘。家业不立资生坏尽。于此人边应当默然不应征责。若取此物名为劫夺。何以故。以不慈愍此贫穷人。不名具足护众生故。大王当知。我为此事说一譬喻。智者于中以喻得解。譬如有人欲以饮食供养沙门净行人等。备具种种一切美味。其家忽然失火焚烧风吹水漂贼所劫夺饮食都尽。或为不净恶物所污不任食啖。诸沙门等食时既至。到施主家见其损失。反助忧苦乞食来与。何心敢责施主饮食。然彼施主不与饮食亦无有罪。大王当知。行法行王亦复如是。王虽合得。彼人不与。不犯王法。不合打责。如是行法行王。在世治化民常愿乐

大萨遮尼干子所说经卷第四大萨遮尼干子所说经卷第五

        元魏天竺三藏菩提留支译

    王论品第五之三

王言。大师。如是不放逸行法行王。成就几法。得名行法行王。答言。大王。成就十法。而得名为行法行王。何等为十。一者自性成就。二者眷属有礼。三者智慧成就。四者常勤精进。五者尊重法。六者猛利。七者恩厚。八者善解世间所行法。九者能忍诸苦。十者不取颠倒法。大王当知。自性成就王者。有于二种功德成就。一者王子大臣长者居士。城邑聚落所有人民。皆爱重王。二者无诸一切疾病。大王当知。眷属有礼王者。亦有二种功德成就。一者于王所作事中。即各竞办不须王忧。二者谨慎不犯王法。大王当知。智慧成就王者。亦有二种功德成就。一者善知方便依法善护众生。二者于欲所作之事自智能知不依他作。大王当知。常勤精进王者。亦有二种功德成就。一者一切库藏满足。二者无诸一切怨贼。欢喜安住。大王当知。尊重法王者。亦有二种功德成就。一者常行一切善法无有休息。二者能化恶行众生。大王当知。猛利王者。亦有二种功德成就。一者于心所欲求事速能满足。二者发心所欲作事。不久思惟即成如法。大王当知。恩厚王者。亦有二种功德成就。一者所有眷属乐王。二者大臣一切人民皆信重王。大王当知。善解世间所行法王者。亦有二种功德成就。一者能知恶行众生善行众生。二者王应民边得物不令有失。大王当知。能忍诸苦王者。亦有二种功德成就。一者于王所欲行事能满成就。二者不畏诸苦恼事。大王当知。不取颠倒法王者。亦有二种功德成就。一者自能进趣胜道。二者常不离善知识。大王当知。成就如是十种功德者。名为成就行法行王。王言。大师。成就如是十种功德。而得名为行法行王者。若其国内有逆贼主。具四种兵。与法行王斗诤国土。及外国王来相侵夺。欲与大斗。集四部兵一切现前。行法行王云何与彼而共斗战。答言。大王。行法行王当应思惟。于三时中出三方便入阵斗战。何等三时。谓初入时中入时后入时。大王当知。初欲入时作方便者。行法行王。若见逆王。尔时复作三种思惟。一者思惟。此返逆王所有兵马。为与我等。为当胜我。若与我等共斗战者。俱损无益。若其胜我。彼活我死。如是念已。应觅逆王所有亲友及善知识。当令和解灭此斗诤。二者行法行王。见彼逆王与己平等及胜己力者。心自思惟。不应与战。当与其物求灭斗诤。三者若见逆王。多有士众眷属朋党象马车步四兵力胜。行法行王士众虽少。能以方便现大勇健难敌之相。令彼逆王生惊畏心以灭斗诤。如是名为于初时中思惟三种方便之用。大王当知。若以亲友与物惊怖。如此三事。不能灭彼斗诤事者。行法行王。尔时复起三种思惟入阵斗战。何等三种。一者思惟。此返逆王。无慈悲心自杀众生。余人杀者亦不遮护。我今不令如此相杀。此是初心护诸众生。二者思惟。当以方便降伏逆王。士马兵众不与斗战。三者思惟。当以方便活系缚取不作杀害。生此三种慈悲心已。然后庄严四种兵众。分布士马唱说号令。简选兵众分作三品。于上品中有上中下。以上品中下勇猛者列在于前。次列第二中品健者。次列上品最健兵马分在两厢。令护步众不生畏心。行法行王处在军中。与最上品象马车步猛健众俱。如是入斗。何以故。有五种事。能令大军竞进不退。何等为五。一者惭愧王。二者畏王。三者取王意。四者令众背后无畏。五者令念报国王恩。如力如分。不生退转。能勇战斗。大王当知。行法行王。设是方便入阵斗战。尔时虽复杀害众生。而彼王得轻微少罪。非决定受忏悔能灭。何以故。彼法行王。为欲入战。先生三种慈悲心故。虽作此恶得罪轻微。非决定受。大王当知。彼法行王。为令众生。为护沙门护沙门法。为护妻子族姓知识。能舍自身及资生物。作如是业。因此事故。彼法行王得无量福。大王当知。若为护国养活人民。兴兵斗战。彼时国王。应当先发如上三心。敕令主将一依王教。如是斗者有福无罪。王言。大师。行法行王。生几种心。常能如是护诸众生。答言。大王。行法行王。于诸众生生八种心。何等八种。一者念诸一切众生如念子想。二者念于恶行众生如病子想。三者常念受苦众生生大慈心。四者念受胜乐众生生欢喜心。五者念于怨家众生生护过想。六者能于亲友众生生覆护想。七者能于资生之中生如药想。八者能于自身生无我想。大王当知。念诸众生如念子想者。起二种心。一者能如父母念子遮护诸恶。二者常于一切众生不舍慈心。大王当知。念恶行众生如病子想者。起二种心。一者能忍如世病人骂诸良师。良师不生嗔恨之心。二者为断一切过失行如是心。大王当知。念受苦众生生大慈心者。起二种心。一者能于诸急难中救免其苦。二者能与胜安隐乐。大王当知。于受乐众生生欢喜心者。起二种心。一者能于他财物中他资生中不生贪心。二者于他富贵胜乐不生嫉心。大王当知。于怨家众生生护过想者。起二种心。一者常念断彼过因远离怨家。二者能于怨家众生生亲友心。何况其余非怨家者。大王当知。于亲友众生生覆护想者。起二种心。一者念令亲友坚固。二者念令一切众生不生怨憎。大王当知。于资生中生药想者。起二种心。一者有欲不行邪淫。二者能于色香味中随世受用不生贪着。大王当知。于自身中无我想者。起二种心。一者往诣沙门大智人边问法。二者闻法如说修行。大王当知。行法行王。常念思惟如是八法故。不求资生。而世间人自然奉献珍奇异物国内无者。库藏盈溢。而诸世间非法恶王。鞭打百姓逼恼索者。了无其一。大王当知。行法行王。行此八法者。于所作业。岁时日月星宿节朔。常与吉会。一切非人诸恶邪鬼。欲觅其便无能得者。于其国内风雨以时。五谷丰熟。人民饱足无饥渴想。一切诸虫雀鼠龙雹。能与世间作无利者。悉皆息灭。若有怨贼在其国内。一切即依自业罪过受诸苦恼。依自业尽依自业灭。大王当知。行法行王。若能如是护诸众生护器世间者。不负一切世间众生。诸善行人智慧人圣人。一切众生无能呵责者。何以故。无罪过故。大王当知。如是善行王。若命终时。当生天上受彼诸天妙境界乐。而说偈言

  重法不放逸　　常念利众生
  眷属有礼法　　善能知他行
  自身常清净　　离诸无益业
  彼王胜世间　　名行法行王
  貌重言常和　　于善勤精进
  善能知世间　　一切诸伎艺
  以常不懈怠　　方便护世间
  众生得安乐　　无有苦恼者
  常乐利益他　　将护一切心
  出口说爱语　　安隐决定言
  知过有功德　　知胜知不如
  如是王能共　　众生受安乐
  于他平等心　　能舍物解义
  诸臣及眷属　　一切爱乐王
  具足善众集　　常有大势力
  如是正法王　　能久住王位
  慈心离杀生　　布施断偷盗
  正欲防邪淫　　实言止妄语
  和合除两舌　　软语遮恶口
  正说治绮语　　净命对饮酒
  净心舍三毒　　受妙天王位
  大王应当知　　常善护诸戒

    大萨遮尼干子所说经请食品第六

尔时严炽王闻大萨遮尼干子所说法已。心大欢喜。即语萨遮尼干子言。大师仁慈不遗我国。今此旷野不可停止。愿降神德。将诸大众与我俱诣宫内寝息。何以故。我今心念。欲为大师及诸大众设于时供。萨遮尼干子言。善哉善哉。善哉大王。欲与我食。今正是时。何以故。大王当知。我从远来。道路疲极。常多饥渴。日时已至。我受王请。时严炽王。闻大萨遮尼干子受其请已。心大欢喜。即以萨遮尼干子及诸大众置在于前。王与四兵导从前后俱入王宫。入已。王请萨遮尼干子。坐王七宝庄严间错无价宝床。余诸一切尼干子众。随所应坐。悉皆令坐。萨遮尼干子受坐已。严炽王。即生至心恭敬心尊重心希有心。自手供给萨遮尼干子及诸大众。百味饮食极令饱足。恣意令取丰满盈溢。萨遮尼干子食已。严炽王。即以价直百千万亿上下衣服。奉施萨遮尼干子。余弟子众所应得者。悉皆施与上下衣服。尔时萨遮尼干子食食讫已。摄诸钵器澡漱清净。即语严炽王言。大王当知。王今至心。奉施沙门饮食衣服。福不可量。今且略说十五功德。何等十五。一者闭塞悭贪之心。二者能开布施心手。三者能灭无布施福邪见之心。四者能生果报不亡正见之心。五者随顺善知识人。六者远离下无智人。七者能开诸善道门。八者能闭诸恶趣门。九者能种善根种子。十者能拔不善根栽。十一者能渐薄一切诸烦恼结。十二者能增长一切诸善根分。十三者能饱足一切诸持戒人。十四者能应为自身所作已作。十五者能为利益他应作已作。何以故。大王当知。能施布施得大富。施好色食。后得妙色。观者无厌。施好香食。后得名称世间普闻。施美味食。后得资生过诸世间种种胜妙。施乐触食。后得手脚细滑柔软。施能至心。后得一切世人亲爱恭敬供养。自手布施。得多僮仆围绕给侍。依时节施。随心所须应时即得。以爱物施。后得胜妙资生境界。不损害施。后得资生坚固不坏不疲劳。施安坐受报眷属常爱。与饮食者。后得大力自在无碍。与衣裳者。得好妙色世间敬爱。施灯明者。得明净眼无诸病坏。施伎乐者。得耳不聋常闻妙声。施诸乘者。常得安乐辇舆随身。施汤药者。得无疾病形色肥鲜。施屋舍者。离诸恐怖得安隐乐。布施法者。后得不死甘露法药。离杀生者。后得长寿命不中夭。离劫盗者。后得大富资生无尽。离邪淫者。后得好妻他不能夺。离妄语者。后得实报不被他谤。离两舌者。后得和合眷属无诤。离恶口者。后得常闻胜妙音声。离绮语者。有所言说他人受用。离贪心者。得不增上厚重贪心。离嗔心者。得不增上厚重嗔心。离邪见者。得不增上厚重痴心。离憍慢者。生豪贵家得人尊敬。离嗔心者。得身端正见者爱乐。离嫉心者。得大威力所愿皆成。离悭心者。生处富足资生无乏。离非处淫者。得胜诸根具丈夫相。大王当知。施饮食者。即是与命与色与力与乐与辩。大王当知。施主爱众生。智者赞叹。名闻十方。入诸大众心不怯弱。若命终已。生上天中受妙境界。于最后身得无上道。尔时萨遮尼干子。而说偈言

  至心持戒人　　能生欢喜心
  时食施沙门　　来世得七福
  得胜色命力　　乐辩才乐说
  生天善道中　　终得至涅槃
  所为事布施　　毕竟得彼事
  为求乐布施　　后毕得安乐
  施福最胜乐　　所求者毕成
  当生天人中　　及色无色界
  智慧圣施主　　若修精进行
  毕竟尽诸苦　　得上胜智慧
  以作无量福　　天魔魔眷属
  行恶不善者　　不能作障难
  以故常布施　　求三种胜事
  善道及富贵　　能证无上道

    大萨遮尼干子所说经问罪过品第七

尔时严炽王。即生是心。萨遮尼干子所说法者。皆是随顺如来正法。作是思惟。我今当问萨遮尼干子。于如来所有尊重心不。尔时严炽王。作是念已。即移座处。更敷下座。恭敬而坐。问萨遮尼干子言。大师当知。我有小疑。今欲请问。为见听不。尔时萨遮尼干子答言。大王。随汝所问。我当为汝分别解说令得开解。时严炽王闻大萨遮尼干子听其问已。即作是言。大师。世间颇有众生于众生界中聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此能雨婆罗门。聪明大智利根黠慧善知星宿。善知祭祀种种诸天。善知咒术。善知事火。善知天文日月八星。善知天雨石雹灾害。善知地动吉凶变异。善知日月运蚀殃灾。善知年岁国土丰俭。善知世间安隐破坏。彼婆罗门而有罪过。王言。大师。彼能雨婆罗门罪过云何。答言。大王。此能雨婆罗门。常多淫欲喜侵他妻。大王当知。黠慧之人不应侵他妻。何以故。大王当知。侵他妻者。现在未来多受苦恼。一切天人之所呵责。而说偈言

  自妻不生足　　好淫他妇女
  是人无惭愧　　常被世呵责
  现在未来世　　受苦及打缚
  舍身生地狱　　受苦常无乐

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此颇罗堕婆罗门。聪明大智利根黠慧。知法知礼而有罪过。王言。大师。彼颇罗堕婆罗门罪过云何。答言。大王。此颇罗堕婆罗门。常多睡眠。大王当知。黠慧之人不应睡眠。何以故。大王当知。多睡眠人。退失诸行。失于世间出世间法。妨碍智慧离诸烦恼。而说偈言

  若人多睡眠　　懈怠妨有得
  未得者不得　　已得者退失
  若欲得胜道　　除睡疑放逸
  精进策诸念　　离恶功德集

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如此众生今者谁是。答言。大王。此黑王子。聪明大智利根黠慧。有大威力而有罪过。王言。大师。彼黑王子罪过云何。答言。大王。此黑王子多诸嫉妒。大王当知。黠慧之人不应嫉妒何以故。大王当知。若有人得生富贵家。资财丰足。不肯布施怀嫉妒心。如是之人。于资生中不取坚固。彼人空手命终即去生饿鬼中。生彼处已。受诸种种饥饿苦恼。而说偈言

  惜财不布施　　藏积恐人知
  舍身空手去　　饥鬼中受苦
  饥渴寒热等　　忧悲常煎煮
  智者不聚积　　为破悭贪故

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如此众生今者谁是。答言。大王。此胜仙王子。聪明大智利根黠慧。有大威力而不怯弱。好行布施有大威德。而有罪过。王言。大师。彼胜仙王子罪过云何。答言。大王。此胜仙王子多作杀生。大王当知。有黠慧者不应杀生。何以故。大王当知。杀生之罪得短命报。命终生于地狱畜生饿鬼之中。而说偈言

  杀生无善报　　短命多诸疾
  来世生恶道　　具受种种苦
  欲离诸苦恼　　未来求胜乐
  应当护他身　　如爱自己命

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此无畏王子。聪明大智利根黠慧。而有罪过。王言。大师。彼无畏王子罪过云何。答言。大王。此无畏王子慈心太过。大王当知。黠慧之人不应慈心太过。何以故。大王当知。若王王子慈心太过者。彼王王子国内多有群贼乱民。不可遮护。多有仇难。而说偈言

  若王及王子　　慈悲心太过
  长贼多欺诳　　民怖王命危
  王应思此过　　筹量行慈悲
  念世间受苦　　舍离太过心

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此天力王子。聪明大智利根黠慧。而有罪过。王言。大师。彼天力王子罪过云何。答言。大王。此天力王子饮酒太过。大王当知。黠慧之人不应饮酒太过。何以故。大王当知。饮酒太过。忘失诸事障修大道。失于世间出世间利。而说偈言

  饮酒多放逸　　现世常愚痴
  忘失一切事　　常被智者呵
  来世常闇钝　　多失诸功德
  是故黠慧人　　离诸饮酒失

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此婆薮天王子。聪明大智利根黠慧。有大威力心不怯弱。常好布施有大威德。而有罪过。王言。大师。彼婆薮天王子罪过云何。答言。大王。此婆薮天王子。了达诸事而行事太迟。大王当知。有黠慧人不应行事太迟。何以故。大王当知。行事太迟者。不及时节。多失诸利。令斗诤事坚固难灭。是故大王。黠慧之人有所作事。不失时节不应太迟。而说偈言

  行事太迟人　　多失所作业
  未得者不得　　已得者便失
  应舍迟行事　　慕速及时节
  过时不得利　　是故多所失

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此大仙王子。聪明大智利根黠慧。有大威力而有罪过。王言。大师。彼大仙王子罪过云何。答言。大王。此大仙王子。贪心太过。为颠倒覆心。常夺他财。大王当知。黠慧之人不应过贪。何以故。大王当知。过贪之人。不为一切众生亲附。舍此身命即生地狱。而说偈言

  贪人多积聚　　得不生厌足
  无明颠倒心　　常念侵损他
  现在多怨憎　　舍身堕恶道
  是故有智者　　应当念知足

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此大天王子。聪明大智利根黠慧。有大威力而有罪过。王言。大师。彼大天王子罪过云何。答言。大王。此大天王子。轻躁戏笑放逸太过。大王当知。黠慧之人不应轻躁放逸太过。何以故。大王当知。放逸太过者。能障奢摩他毗婆舍那法。此戏笑之罪是恶道因。而说偈言

  戏笑垢染心　　心不住三昧
  为智者所呵　　行善不解脱
  欲得速利益　　应离诸放逸
  现世无安隐　　失名称功德

王言。大师。世间颇更有诸众生。聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此憍萨罗国波斯匿王。聪明大智利根黠慧。而有罪过。王言。大师。彼波斯匿王罪过云何。答言。大王。此波斯匿王啖食太过。大王当知。黠慧之人不应啖食太过。何以故。大王当知。啖食太过者。体难回动懒惰懈怠。所食难消。远离现在未来二世善法利益。而说偈言

  啖食太过人　　身重多懈怠
  现在未来世　　于身失大利
  睡眠自受苦　　亦恼于他人
  迷闷难寤寤　　应时筹量食

王言。大师。世间颇更有诸众生聪明大智利根黠慧有罪过不。答言。大王。有此众生亦有罪过。王言。大师。如是众生今者谁是。答言。大王。此众生者即王身是。大王亦甚聪明大智利根黠慧。有大威力心不怯弱。好喜布施威德具足。亦有罪过。王言。大师。我之所有罪过云何。答言。大王。大王之罪太极暴恶。大王太严。大王太忽。大王太[革*卬]。大王太卒。大王当知。黠慧之人不应太恶。何以故。大王当知。若王王子性太恶者。彼为一切多人不用。多人不爱。多人不喜。乃至父母亦不喜见。何况余人大臣王子长者居士等。是故大王。黠慧之人不应太恶。大王当知。有黠慧人所欲作事。应当安详不应太卒。而说偈言

  若王行恶行　　嗔心不见事
  动则怖众生　　乃至父母畏
  何况余非亲　　而当有念爱
  大王应当知　　智者舍嗔恚

尔时严炽王。在坐对面。闻大萨遮尼干子毁呰自身。心生不忍嗔心恚心懊恼心无欢喜心。生毒害心即作是言。萨遮尼干子。汝今云何于大众中说我过恶毁呰于我。我从昔来。无人敢正看我面者。汝今毁我罪应合死。作是语已。以嗔恚心告诸臣言。汝当捉此说不爱语愚痴沙门断其命根。尔时萨遮尼干子惊怖毛竖。语严炽王言。大王。汝今莫速卒作如是恶事不饶益我。我有善言。愿王暂时施我无畏听我所说。王言。沙门。与汝无畏。所欲说者汝当速说。萨遮尼干子言。大王当知。我亦有罪。王言。沙门。何者汝罪。萨遮尼干子言。大王当知。我罪过者。由太实语不虚语称事语。以我如是大恶人前。可畏人前。急性人前。无慈悲人前。卒作事人前。如是恶行人前说如实语。大王当知。黠慧之人。不应一切时一切处常说实语。何以故。有不饶益故。大王当知。黠慧之人应当善观。可与语人。不可与语人。应当善知。可语时非语时。应当善知。可语处非语处。然后说语。何以故。大王当知。实语人者。世人不爱。世人不喜。智者不赞叹。世间痴人嗔。而说偈言

  智者不知时　　卒随意说实
  彼人智者呵　　何况无智者
  智者一切处　　亦不皆实语
  是实憍尸迦　　实语入恶道

尔时严炽王。闻萨遮尼干子说自身过。即便开解。心生欢喜。白萨遮尼干子言。大师。师无罪过。由我太卒。今闻师教。如闇得灯。如盲得眼。常当受持。我今忏悔。愿师于我莫舍实语。而说偈言

  我实愚痴闇　　不识知识语
  是故生恶心　　出如是恶口
  我今圣人前　　忏悔如是罪
  愿愍诸众生　　令我罪除灭

大萨遮尼干子所说经卷第五大萨遮尼干子所说经卷第六

        元魏天竺三藏菩提留支译

    如来无过功德品第八之一

尔时严炽王闻萨遮尼干子所说。得欢喜已。更问所疑。作如是言。大师。今此众生界中众生聚中。颇更有人聪明大智利根黠慧知法非法无过失不。答言。大王。有此众生无诸过失。王言。大师。今者谁是。答言。大王。此沙门瞿昙释家子。生释王家出家为道。大王当知。如我有四围陀经中说。彼释种沙门瞿昙无有过失。所谓生在大家不可讥嫌。何以故。以是转轮王家生故。种姓豪贵不可讥嫌。何以故。以甘蔗姓种家生故。福德庄严不可讥嫌。何以故。以三十二相八十种好庄严身故。具足实事不可讥嫌。何以故。以具持戒十力四无所畏十八不共法毕竟成就故。是故知彼沙门瞿昙无有过失。大王当知。彼释种子沙门瞿昙若不舍家出家为道者。当作转轮圣王王四天下。当行法行而为法王。具足七宝。轮宝象宝马宝如意宝夫人宝大臣宝主藏宝。千子具足。勇猛雄杰有丈夫相。身诸威德无可嫌毁。力能降伏他诸军众。具足成就转轮王相。于四天下而得自在。无与等者。于此大地无诸怨刺无诸恼害。无有刀杖依法降伏。行于平等自在而住。而彼王子沙门瞿昙不乐如是世间之乐。舍家出家。勇猛精进行大苦行。日食一麻或食一米。心不懈怠六年苦行。成等正觉。坐于道场菩提树下。降诸魔力。一心念于相应智慧。所有应知。所有应得。所有应见。所有应觉。所有应证。彼诸一切所应得法。不从师学。自智即能如实觉知。是故知彼沙门瞿昙一切世间天人魔梵沙门婆罗门等无与等者。何况有胜彼沙门瞿昙无等等无胜等。是故彼无一切过失。何以故。以彼沙门瞿昙家姓无等。形色无等。智慧无等。是故无过失重说偈言

  家色生姓胜　　诸相百福胜
  八十种妙好　　庄严佛自身
  六年修苦行　　坐于菩提树
  降伏诸魔众　　逮得一切智
  是诸天人师　　常念利世间
  慈悲心平等　　救苦无怨亲
  波罗奈城说　　四谛相应法
  无我命众生　　是故无过失

尔时严炽王语大萨遮尼干子言。大师应说。何者是如来三十二大丈夫相。以是三十二相庄严身故。得大丈夫师子王名。尔时大萨遮尼干子告严炽王言。大王。今当一心谛听。当为汝说。王言。大师。愿乐欲闻。萨遮尼干子言。大王当知。沙门瞿昙三十二相者。一者沙门瞿昙足下平满蹈地善住。二者沙门瞿昙足下具足千辐轮相。三者沙门瞿昙手脚柔软如天劫贝。四者沙门瞿昙诸指纤长。五者沙门瞿昙指皆网缦。六者沙门瞿昙足跟圆满。七者沙门瞿昙足趺上隆。八者沙门瞿昙鹿王[跳-兆+專]相。九者沙门瞿昙身相端严。十者沙门瞿昙马王阴藏。十一者沙门瞿昙一孔一毛不相杂乱。十二者沙门瞿昙发如青妙净琉璃色。十三者沙门瞿昙身毛上靡。十四者沙门瞿昙皮如金色。十五者沙门瞿昙皮肤细软。十六者沙门瞿昙七处平满。十七者沙门瞿昙两肩圆厚。十八者沙门瞿昙两肩高峻圆如金山。十九者沙门瞿昙身体广长。二十者沙门瞿昙。身圆正直如尼拘树王。二十一者沙门瞿昙颊如师子。二十二者沙门瞿昙四十齿满。二十三者沙门瞿昙齿间明密。二十四者沙门瞿昙齿方齐平。二十五者沙门瞿昙齿白如雪。二十六者沙门瞿昙舌得上味。二十七者沙门瞿昙舌能覆面。二十八者沙门瞿昙声如梵声。二十九者沙门瞿昙。眼如牛王上下俱瞬。三十者沙门瞿昙目相鲜明如青莲华叶。三十一者沙门瞿昙。额上毫相功德满足。三十二者沙门瞿昙头相高显无见顶者。大王当知。此沙门瞿昙三十二相。沙门瞿昙以此三十二相庄严身故。说名大丈夫师子王。而说偈言

  顶高相微妙　　最胜庄严身
  发如青琉璃　　色净轮右旋
  眼瞬如牛王　　青莲华叶形
  是故瞿昙身　　皆叹不可嫌
  瞿昙微妙声　　过诸梵世音
  如彼迦陵伽　　众鸟悉非伦
  舌能覆面门　　净如莲花叶
  妙相过群生　　是故世无及
  舌根得上味　　诸味无差别
  速成妙相人　　故佛无过失
  瞿昙齿功德　　一切无与等
  明净如珂雪　　齐平无差跌
  颊相称上广　　方如师子王
  唇色众叹美　　喻如频婆果
  两肩相高显　　前后俱团圆
  神光曜众目　　峻美如金山
  瞿昙身诸相　　三十二庄严
  上下体圆满　　如尼拘树王
  瞿昙身广长　　善住不可嫌
  智者常渴仰　　乐观无厌心
  瞿昙功德体　　七处俱满足
  皮色常晖鲜　　如阎浮檀金
  身毛细柔软　　尘垢无能染
  生则轮右旋　　相着俱上靡
  发净色青美　　厚满不偏布
  是故瞿昙相　　过诸世间姿
  瞿昙身正直　　坐立无委曲
  马王阴藏相　　亦如大龙王
  胫如鹿王[跳-兆+專]　　粗细上下均
  是故智者观　　无有疲厌心
  手足指网缦　　内外常鲜明
  甲如赤铜叶　　指如铜擆形
  足趺上丰高　　体满如珂圆
  脚跟相端严　　圆满无高下
  诸指皆纤长　　屈申相柔软
  足下平善住　　蹈地常安隐
  此是瞿昙福　　功德诸相山
  依此功德聚　　显成瞿昙身
  如是功德身　　过天人世间
  如彼净满月　　显于众星中
  瞿昙丈夫相　　功德庄严身
  大悲自在现　　能利诸世间
  法身净无垢　　无量诸功德
  如是诸妙相　　唯瞿昙境界

王言大师。何者如来八十种好。百福功德以是相好庄严身故。名为如来百福庄严功德相身。答言。大王。我今为成此事说喻。大王当知。若三千大千世界所摄四生众生。谓卵生胎生湿生化生。此等众生假使一时得于人身。得人身已。彼一一众生皆修十善。成就转轮圣王福德。彼诸众生所修成就转轮圣王福德之聚。彼一一福德更增百倍。始得成就沙门瞿昙一毛孔中下相功德。如是一毛孔中功德。余一一毛孔所有功德亦复如是。大王当知。如是一切毛孔功德。更增百倍。始得成就沙门瞿昙身中所有一好功德。如是一好功德。余一一好功德亦复如是。大王当知。如是一切诸好功德。更增百倍。始得成就沙门瞿昙身中所有大丈夫相一相功德。如是一相功德。余一一相功德亦复如是。大王当知。如是三十二相功德。更增百倍。始得成就沙门瞿昙眉间白毫一相功德。如是眉间白毫功德。更增百倍。始得成就沙门瞿昙丈夫相中一顶相功德。大王当知。如是顶相功德。更增百千万亿倍。始得成就沙门瞿昙丈夫相中一法蠡声功德。沙门瞿昙以此法蠡声功德故。所有众生界。众生所摄。彼一一众生言音不同。一时各各作百千种种种异问。彼一一众生所问之事。余不重问。能以一念相应智慧。以一音答尔所众生。能令一时各得其解。大王当知。沙门瞿昙以此功德庄严身故。名为成就大丈夫相。是故瞿昙成就百福功德身相。是故瞿昙。成就梵王法蠡妙声。而说偈言

  瞿昙功德身　　百福相住持
  导济诸群生　　故号天人师
  见闻及受物　　其福不可量
  瞿昙出世间　　饶益诸众生
  众生界差别　　随类各异问
  瞿昙一念智　　一音答令解
  瞿昙现世间　　能以梵音声
  转最上法轮　　令天人苦尽

尔时严炽王。问萨遮尼干子。而说偈言

  大师向说名　　如来诸小相
  愿为诸众生　　及我分别说

尔时萨遮尼干子答严炽王言。大王。汝能为诸众生。显发如来功德小相多有利益。汝今谛听。我当一一分别显说。沙门瞿昙八十种好。依彼诸好。广宣瞿昙诸功德相。如秋满月现众星中。何等八十。一者沙门瞿昙头相端严上下相称。二者沙门瞿昙头相满美如摩陀罗树果。三者沙门瞿昙发长弱美如委黑丝。四者沙门瞿昙发缕条理不相杂乱。五者沙门瞿昙发毛婉转蠡文右旋。六者沙门瞿昙发色光泽如青琉璃。七者沙门瞿昙眉长皎洁如月初生。八者沙门瞿昙眼相长广如青莲华叶。九者沙门瞿昙耳埵轮成如似垂露。十者沙门瞿昙鼻修高直孔相不现。十一者沙门瞿昙口气香洁嗅者无厌。十二者沙门瞿昙舌色光赤如赤铜鍱。十三者沙门瞿昙舌相细滑薄利柔软。十四者沙门瞿昙唇色红赤如频婆果。十五者沙门瞿昙牙白纤利光曜面门。十六者沙门瞿昙面色华艳光如明镜。十七者沙门瞿昙面貌上下广狭相称。十八者沙门瞿昙面貌丰美如似满月。十九者沙门瞿昙面貌端正殊特可美。二十者沙门瞿昙身体常净尘垢不染。二十一者沙门瞿昙身体净软如练春华。二十二者沙门瞿昙洪身正直如帝释幢。二十三者沙门瞿昙身诸文相福德超绝。二十四者沙门瞿昙身体柔润如涂膏泽。二十五者沙门瞿昙身相粗细如尼拘树王佣圆得所。二十六者沙门瞿昙身诸相好无能嫌者。二十七者沙门瞿昙身力无敌如那罗延。二十八者沙门瞿昙威仪容止进退有法。二十九者沙门瞿昙身诸相好一切众生乐观无厌。三十者沙门瞿昙身诸形相恶众生见生欢喜心。三十一者沙门瞿昙行步容仪众生见者观无厌足。三十二者沙门瞿昙回身顾视如大象王。三十三者沙门瞿昙身动威相如师子王。三十四者沙门瞿昙身相凝重无轻举相。三十五者沙门瞿昙身相广大不可度量。三十六者沙门瞿昙身相广长无短小相。三十七者沙门瞿昙光轮遍身周匝一丈。三十八者沙门瞿昙身诸光相照曜十方。三十九者沙门瞿昙身相尊重见者归伏。四十者沙门瞿昙皮肤细密常有光泽。四十一者沙门瞿昙皮肤平满无老皱相。四十二者沙门瞿昙身色光明曜众生目不能正观。四十三者沙门瞿昙身色光明昼夜无异。四十四者沙门瞿昙身诸毛孔常出妙香。四十五者沙门瞿昙形貌威德过诸世间。四十六者沙门瞿昙身诸筋脉深隐不现。四十七者沙门瞿昙骨节相连如似钩锁。四十八者沙门瞿昙身毛细软一一右旋。四十九者沙门瞿昙毛色光曜如阎浮檀金。五十者沙门瞿昙手足赤白如蔙花色。五十一者沙门瞿昙手足鲜净常有润泽。五十二者沙门瞿昙十指纤长佣圆可美。五十三者沙门瞿昙踝相不现平无高下。五十四者沙门瞿昙[跳-兆+專]骨坚长上下满好。五十五者沙门瞿昙手足圆满无有高下。五十六者沙门瞿昙手指柔软内外受握。五十七者沙门瞿昙手所有文细现深隐。五十八者沙门瞿昙手所有文正直分明。五十九者沙门瞿昙手所有文文不中断。六十者沙门瞿昙指甲薄润如赤铜色。六十一者沙门瞿昙立不倾斜平正得所。六十二者沙门瞿昙住立安隐无能动者。六十三者沙门瞿昙身动威势如师子王。六十四者沙门瞿昙回身顾视如大象王。六十五者沙门瞿昙行步平正无有倾曲。六十六者沙门瞿昙行步安详如似象王。六十七者沙门瞿昙动足去步如白鹅王。六十八者沙门瞿昙行不履地轮相炳着。六十九者沙门瞿昙九孔门满相皆具足。七十者沙门瞿昙腹小不现。七十一者沙门瞿昙脐孔深圆。七十二者沙门瞿昙声响调和粗细俱美。七十三者沙门瞿昙妙声远彻随闻无障。七十四者沙门瞿昙所有言音随众生意闻皆和悦。七十五者沙门瞿昙语随方音不增不减。七十六者沙门瞿昙说法应机无有差谬。七十七者沙门瞿昙语能随俗方音为说。七十八者沙门瞿昙一音说法令诸异类一时俱解。七十九者沙门瞿昙随有因缘次第说法。八十者沙门瞿昙胸有万字示功德相。大王当知。是名沙门瞿昙八十种好庄严成就功德相身。一切声闻辟支佛诸天魔梵沙门婆罗门及诸外道。莫能有者。是故我言无有过失。而说偈言

  地主听我说　　如来八十好
  以是诸相好　　庄严瞿昙身
  瞿昙甲圆好　　形如半竹筒
  美艳赤铜色　　光泽如油涂
  指间肉平满　　次第均无差
  手文齐正直　　深细相分明
  脉深无异相　　唇色如频婆
  脚善住无差　　是故常安隐
  踝骨隐不现　　高下难分别
  手中相明显　　示现诸功德
  舌相妙柔软　　如天新华绵
  薄如赤铜叶　　光色常晖鲜
  诸节皆深隐　　妙相甚难见
  两手过双膝　　天人皆赞叹
  妙声甚深远　　犹如大龙王
  如天中雨雷　　声微妙最胜
  瞿昙满月身　　实相净相应
  妙形善端美　　上下俱佣圆
  永尽恶身相　　满足诸功德
  膺满如师子　　一一好差别
  手足善光泽　　皮如金色鲜
  如是诸功德　　一一不可嫌
  身相次第好　　离诸粗涩触
  脐轮相圆正　　孔深无洼曲
  一切诸身分　　功德所集成
  诸行皆清净　　光明离闇浊
  如是功德身　　善备不可嫌
  以是诸世间　　乐观无厌足
  起如大龙王　　奋迅动重渊
  步如牛王相　　威如师子转
  身相甚柔软　　骨节不相违
  趋进如鹅王　　不疾亦不迟
  腹相小不现　　胁柔软肋平
  毛右旋熠耀　　光色如流电
  行步及去来　　诸相甚端妍
  离随嗔恚爱　　成就诸好因
  瞿昙无诸恶　　万相表吉祥
  离于黄黑等　　不好诸黡相
  眉如月初生　　色如金精黑
  净眼无妒眼　　广眼曜如星
  面门方圆好　　妙声吐和音
  诸相过群生　　离诸烦恼缠
  眉相甚妍美　　鼻高如悬筒
  双目相广长　　如青莲花叶
  眉齐不相离　　相满圆如规
  齿高次第利　　二牙光面门
  身毛无参差　　咽颈离高下
  是故瞿昙相　　天人无等者
  头圆如伞盖　　缺骨顶夷平
  皮额俱不皱　　如珂体圆实
  瞿昙毛细滑　　不乱亦不散
  宛转轮右旋　　常出诸妙音
  瞿昙毛鲜洁　　尘垢不能染
  如彼净琉璃　　不为淤泥点
  瞿昙毛满足　　一一次第住
  如多楞只草　　齐细不相绕
  瞿昙毛细软　　如蜂王腹毛
  离病衰老相　　发甲不变白
  瞿昙胸相满　　亦如师子坐
  如鱼如高幢　　亦如金刚钩
  如似立金瓮　　如画还复旋
  如钵头摩花　　如珂功德天
  如结加趺坐　　一一诸节中
  力如那罗延　　是故过世间
  瞿昙胸万字　　具足千辐轮
  手脚相不异　　千辐轮无差
  人主此正是　　瞿昙诸小相
  二乘及外道　　天人皆无等

大王当知。沙门瞿昙成就如是诸相好身。一切众生无如此者。是故我言沙门瞿昙无有过失

大王当知。沙门瞿昙究竟成就大慈心力。能大饶益一切众生。无有害心。彼大慈心无碍故。无障故。常行故。自然照故。遍至一切世间境界。入诸众生烦恼使故。大王当知。譬如净水摩尼宝珠。自体净故。而能清净一切浊水。大王当知。沙门瞿昙大慈心水亦复如是。自身清净。复能清净一切众生烦恼淤泥诸见浊水。大王当知。沙门瞿昙毕竟成就如是大慈。是故我言无有过失。而说偈言

  瞿昙大慈悲　　遍观十方界
  一切众生心　　无时能舍离
  故名佛世尊　　成就大慈心
  是故一切智　　无有诸过失
  如彼能净水　　如意摩尼珠
  以体明净故　　能清诸浊水
  瞿昙亦如是　　自性离诸垢
  能以慈心水　　净众生浊心

大王当知。沙门瞿昙于诸众生。毕竟成就三十二种大悲观心。何等三十二。一者沙门瞿昙见诸众生坠堕痴闇大黑处故。起大悲心。二者沙门瞿昙见诸众生坠堕无明所缠窟故。起大悲心。三者沙门瞿昙见诸众生坠堕世间大险处故。起大悲心。四者沙门瞿昙见诸众生离寂静处堕世间故。起大悲心。五者沙门瞿昙见诸众生堕大瀑水随漂流故。起大悲心。六者沙门瞿昙见诸众生堕在颠倒险难大苦处故。起大悲心。七者沙门瞿昙见诸众生堕在恶道离圣道故。起大悲心。八者沙门瞿昙见诸众生为大烦恼能缚所缚。常为种种烦恼罗网所缠裹故。起大悲心。九者沙门瞿昙见诸众生于诸境界常不可足不可满故。起大悲心。十者沙门瞿昙见诸众生属诸爱主不自在故。起大悲心。十一者沙门瞿昙见诸众生常为老死大苦劫害不生厌故。起大悲心。十二者沙门瞿昙见诸众生不离诸疹。为诸一切种种病苦所逼恼故。起大悲心。十三者沙门瞿昙见诸众生三火常然昼夜常烧常不灭故。起大悲心。十四者沙门瞿昙见诸众生下业所缠增长世间诸苦恼故。起大悲心。十五者沙门瞿昙见诸众生常怀惊怖无安隐心故。起大悲心。十六者沙门瞿昙见诸众生少利所缠忘大过故。起大悲心。十七者沙门瞿昙见诸众生为诸种种放逸所醉。无始睡蛇常睡在心。在旷野道常为五阴怨家逐故。起大悲心。十八者沙门瞿昙见诸众生常为诸盖劫善财故。起大悲心。十九者沙门瞿昙见诸众生无明覆眼常曀不见善知识故。起大悲心。二十者沙门瞿昙见诸众生常为种种事乱其心犹如乱丝无理者故。起大悲心。二十一者沙门瞿昙见诸众生常在愦闹离寂静故。起大悲心。二十二者沙门瞿昙见诸众生常在难处离无难故。起大悲心。二十三者沙门瞿昙见诸众生云何云何邪见缠故。起大悲心。二十四者沙门瞿昙见诸众生随逐贪饵依止种种邪见使故。起大悲心。二十五者沙门瞿昙见诸众生长夜执在想倒心倒。无常法中生于常想。于苦法中生于乐想。不净法中生于净想。无我法中生我想故。起大悲心。二十六者沙门瞿昙见诸众生无始世来。常负生死诸恶重担。受大苦恼不疲厌故。起大悲心。二十七者沙门瞿昙见诸众生依止世间。羸薄少力非坚固中谓坚固故。起大悲心。二十八者沙门瞿昙见诸众生为染所染。常在无量诸垢中故。起大悲心。二十九者沙门瞿昙见诸众生为有贪缚不厌舍故。起大悲心。三十者沙门瞿昙见诸众生为诸供养恭敬降伏常求资生诸供养故。起大悲心。三十一者沙门瞿昙见诸众生常为种种境界缠心生忧恼故。起大悲心。三十二者沙门瞿昙见诸众生坠堕憍慢我慢地故。起大悲心。大王当知。是名沙门瞿昙于诸众生毕竟成就三十二种大悲观心。是故我言无有过失。而说偈言

  瞿昙见众生　　闭在世间狱
  轮回遍诸趣　　常受一切苦
  痴闇覆其心　　不知生厌离
  是故无上尊　　常起大悲心
  瞿昙见众生　　乐着诸世间
  四流河所漂　　随顺不得返
  常没生死海　　不知求出离
  是故十力者　　常起大悲心
  瞿昙见众生　　坠堕大险中
  入于非正道　　无有能救者
  是故瞿昙观　　起于大悲心
  置于佛菩提　　最胜无畏处
  瞿昙见众生　　缚在牢狱中
  与爱作僮仆　　策使诸境界
  宛转老死海　　不觉亦不知
  是故十力者　　常起大悲心
  瞿昙见众生　　炽然三种火
  常在诸恶趣　　种种苦所害
  怖畏诸恶道　　无有依止处
  是故十力者　　常起大悲心
  瞿昙见众生　　乐着于诸有
  放逸心自在　　贪着诸境界
  常被种种害　　而不生怖畏
  是故十力者　　常起大悲心
  瞿昙见众生　　无明黑所覆
  种种曀所障　　不离一切盖
  诸见乱如丝　　无有能解者
  是故十力者　　常起大悲心
  瞿昙见众生　　堕在八邪见
  为爱久住处　　以是常缚心
  如是诸难中　　乐不生厌离
  是故十力者　　常起大悲心
  瞿昙见众生　　起于颠倒心
  于苦不净中　　而生乐净想
  无常无我中　　而反我常实
  是故十力者　　常起大悲心
  瞿昙见众生　　依止羸薄力
  常为重担押　　无心生厌离
  起于坚固想　　染着不能舍
  是故十力者　　常起大悲心
  瞿昙见众生　　在有贪海中
  利养覆心故　　常求爱境界
  贪心如野火　　炽然不知足
  是故十力者　　常起大悲心
  瞿昙见众生　　具造诸苦业
  常为诸忧悲　　苦恼之所逼
  为拔彼众生　　种种诸恼害
  是故十力者　　常起大悲心
  瞿昙恒观彼　　一切众生界
  常起大悲心　　是故无过失

大王当知。沙门瞿昙毕竟成就三念处。王言。大师。何者如来三念处。答言。大王。一者无喜心。二者无嗔心。三者无嗔无喜心。王言。大师。云何无喜心答。言。大王。无喜心者。沙门瞿昙在众说法。若有众生。身正恭敬。摄耳不散。随顺受教。如说修行。沙门瞿昙。不以为喜。不生踊悦。不生踊跃。何以故。沙门瞿昙舍心平等。安住一心故。王言。大师。云何无嗔心。答言。大王。沙门瞿昙在众说法。若有众生。身不恭敬。耳不专听。违背圣教。不如说行。沙门瞿昙不生嗔心。亦复不起不忍之心。亦复不生非可信心。亦不生彼违我教心。何以故。沙门瞿昙舍心平等。安住一心故。王言。大师。云何不喜不嗔心。答言。大王。沙门瞿昙在众说法。于其众中。身正恭敬摄耳不散随顺受教如说修行。有不恭敬失耳境界违背圣教不如说行。沙门瞿昙于此二人。不生喜心踊悦心踊跃心。不生嗔心。亦复不起不忍之心。亦复不生不可信心。亦不念彼违我教心。何以故。沙门瞿昙舍心平等。安住一心故。大王当知。沙门瞿昙依三念处不染心住。是故我言无有过失。而说偈言

  瞿昙说法中　　一心正受者
  常住正念故　　不起欢喜心
  瞿昙说法中　　不正心谛受
  常住正念故　　亦不起嗔心
  瞿昙说法中　　受不受二分
  常住平等故　　不嗔亦不喜

大王当知。沙门瞿昙毕竟成就三不护业。王言。大师。何者如来三不护业。答言。大王。一者身业不护。二者口业不护。三者意业不护。王言。大师。云何身业不护。答言大王。沙门瞿昙身行清净。沙门瞿昙。无有诸行不清净者。是故沙门瞿昙不作心念。我身业不清净。恐畏他知作心防护。何以故。沙门瞿昙无有身行不清净故。是名第一身业不护。王言。大师。云何口业不护。答言。大王。沙门瞿昙口业清净。沙门瞿昙无有口业不清净者。是故沙门瞿昙不作心念。我口业不清净。恐畏他知作心防护。何以故。沙门瞿昙无有口业不清净故。是名第二口业不护。王言。大师。云何意业不护。答言。大王。沙门瞿昙意业清净。沙门瞿昙无有意业不清净者。是故沙门瞿昙不作心念。我意业不清净。恐畏他知作心防护。何以故。沙门瞿昙无有意业不清净故。是名第三意业不护。大王当知。沙门瞿昙毕竟成就三不护业。是故我言无有过失。而说偈言

  瞿昙三种业　　离妄及无记
  是故常清净　　出诸护境界
  为诸弟子众　　平等心说法
  有过者能除　　无过者便摄

大王当知。沙门瞿昙毕竟成就一切种智清净。王言。大师。何者如来一切种智清净。答言。大王。沙门瞿昙一切种智清净。有四种。一者身一切种智清净。二者观一切种智清净。三者心一切种智清净。四者智一切种智清净。王言。大师。云何如来身一切种智清净。答言。大王。沙门瞿昙身一切种智清净者。离诸烦恼一切习气皆灭无余。随意所欲取舍生退。于一切处身得自在。是名身一切种智清净。王言。大师。云何如来观一切种智清净。答言。大王。沙门瞿昙观一切种智清净者。于应化身。离一切烦恼。及烦恼习气。皆灭无余。回转现没。一切观中而得自在。是名观一切种智清净。王言。大师。云何如来心一切种智清净。答言。大王。沙门瞿昙心一切种智清净者。一切烦恼烦恼习气及心所染。皆悉远离心得自在。聚集一切善根满足。是名心一切种智清净。王言。大师。云何如来智一切种智清净。答言。大王。沙门瞿昙智一切种智清净者。一切无明分及诸烦恼。烦恼习气。皆灭无余。一切法中得无障碍自在。是名智一切种智清净。大王当知。沙门瞿昙。毕竟成就如是一切种智清净。是故我言无有过失。而说偈言

  瞿昙一切智　　依止四净法
  是故见无垢　　智慧身自在
  瞿昙清净慧　　具足四种智
  烦恼习气灭　　是故无过失

大萨遮尼干子所说经卷第六大萨遮尼干子所说经卷第七

        元魏天竺三藏菩提流支译

    如来无过功德品第八之二

王言。大师。何者如来自在。答言。大王。沙门瞿昙有十自在。一者命自在。二者心自在。三者物自在。四者业自在。五者生自在。六者如意自在。七者信自在。八者愿自在。九者智自在。十者法自在。大王当知。得上甘露名命自在。能知一切惟是一心。名心自在。于虚空中揽成珍宝。名物自在。远离一切烦恼及习无明诸使。名业自在。于深禅定解脱三昧三摩拔提随意回转。名生自在。于一切行自然而行。名如意自在。于诸入中得自在观。名信自在。即生心时现前成就一切诸事。名愿自在。身口意业以智为本。名智自在。现住平等真如法界无垢实际。名法自在。大王当知。远离杀生无嗔害心。是命自在因。平等心舍一切事物求大菩提。是物自在因。三业所作清净无染。是业自在因。以菩提心摄诸善根。是生自在因。舍诸一切供养恭敬礼拜赞叹象马车乘施与众生。是如意自在因。常说三宝教化众生。是信自在因。称诸一切众生所求应时给与。是愿自在因。常行法施不为利养名闻恭敬。是智自在因。常为众生说诸如来及诸众生真如平等法身为体非饮食身。是法自在因。大王当知。得命自在故。对治一切生死怖畏。得心自在故。对治一切烦恼怖畏。得物自在故。对治一切贫穷怖畏。得业自在故。对治一切恶道怖畏。得生自在故。对治一切生缚怖畏。得如意自在故。对治一切追求怖畏。得信自在故。对治一切谤法怖畏。得愿自在故。对治一切心念缚怖畏。得智自在故。对治一切疑刺怖畏。得法自在故。对治一切大众怖畏。大王当知。沙门瞿昙。毕竟成就如是自在。是故我言。无有过失。而说偈言

  瞿昙修正行　　为利诸群生
  是故诸法中　　一切得自在
  念护诸众生　　不行杀盗心
  是故于财命　　生处常自在
  常行禅法施　　永断诸恶因
  心业无障碍　　生处常自在
  常念菩提本　　不恼众生心
  赞叹三宝福　　广利诸众生
  三业依智行　　心常住法界
  生处意信愿　　智法常自在

大王当知。沙门瞿昙。毕竟成就三十七品菩提分法。所谓四念处四正勤四如意足五根五力七觉分八正道。沙门瞿昙。成就如是清净道法。是故我言。无有过失。王言。大师。何者如来四念处。答言大王。沙门瞿昙四念处者。一者身念处。二者受念处。三者心念处。四者法念处。大王当知。沙门瞿昙身念处者。谓观内身外身内外身。于此身中作二种观。一者不净观。二者净观。不净观者。观身不净秽恶充满诳诸凡夫故。净观者。作是思惟。我今因此不净身故。得净佛身。得净法身净功德身。一切众生所乐见身。作是观已。能净二行。一者无常。二者常。云何无常。观身无常毕定当死。如是观已。不为身故造诸恶业邪命自活。当为此身修三坚法。一修身坚。二修命坚。三修财坚。如是观已。远离一切身口意曲。行正直心。云何为常。观无常已。得于常身。因无常故。得功德身。因无常故。不断佛种法种僧种。何以故。修身念处。观察一切众生之身。毕竟成就诸佛法身。以有法身故。作是观故。得平等心无分别心。不起诸漏。所谓欲漏有漏无明漏。不见有我及我所。住如实际成一切智。是名身念处。大王当知。沙门瞿昙受念处者。谓观内受外受内外受。于是受中。作二种观。谓常无常。起慈悲心观诸众生。若受乐时生于贪心。若受苦时生于嗔心。若受不苦不乐受时生于痴心。作是思惟。有受皆苦。毕竟乐者。断一切受。即是常乐。随所受生。常生一切慈心悲心。若自若他受乐受时。远离染心生于慈心。若受苦时。观三恶道。远离嗔心。生于悲心。若受不苦不乐受时。离无明心。生于舍心。观一切受无常苦无我。见受乐者。即知是苦。见受苦者。如痈如疮。见受不苦不乐受者。是不寂静。观于乐受。即知无常。观于苦受。即知是空。观不苦不乐受。即知无我。如是观者。名受念处

大王当知。沙门瞿昙心念处者。谓观内心外心内外心。于是心中。作二种观。谓常无常。常观者。观于自身菩提之性。不忘不失。正念不乱。如是观心。又观所发菩提之心。是心性者。生已即灭。念念不住。不在内入。不在外入。不在内外入。不在阴中。不在界中。作是思惟。如是心缘。为异不异。若心异缘。则一时中有于二心。若心即缘。不应复能观于自心。亦如指端不能自触。心亦如是。作是观已。见心无住无常变异。即知是心。非从缘生。非不缘生。非常非断。非内非外。非有非无。菩提之心。亦复如是。是心非色。不可睹见。如幻如化无所挂碍。自观心已。观诸一切众生心性。如自心性。如自心相。一切众生心性心相亦复如是。知自心空。一切众生心空亦尔。观自心平等。观诸众生心性平等亦复如是。是名心念处。大王当知。沙门瞿昙法念处者。谓观内法外法内外法。于是法中作二种观。谓常无常。常以佛眼见一切法。至坐道场未曾中失。观诸法时。不见一法。乃至一切微细诸相。离空无相无愿无作无生无灭无物。不见一切法乃至微细相。不入十二缘者。见法非法。无非是法。云何为法。谓无我无众生无寿命无人。是名为法。云何非法。谓我见众生见命见人见断见常见有见无见。是名非法。沙门瞿昙。观一切法是法非法。何以故。观空无相无愿。是名一切法是法。我慢憍慢。我及我所。摄取诸见。是名一切法非法。作如是观诸法性已。不见有法非菩提因非出道因。悉是出法。若不如是求诸法者。是名灭法。出者从缘。灭者从缘。如是观时。观于三行。所谓恶行善行不动行。于三行中。常行福行。行十善法。为净三业。净身业者。为求诸佛三十二相八十种好。他不能害故。净口业者。有所说法众生乐闻故。净心业者。于诸众生其心平等。常入禅定故。如是方便观法念处。离诸一切障菩提垢。不着常见。不着断见。行中道见。如是中道。世间智慧所不能见。不可宣说。不可显示。无有相貌。无色无处无取无舍。清净寂静。不可眼见。乃至不可触。亦无至处。不在世间。不出世间。不可宣说。非多非少。非常非断。非相非非相。非觉非非觉。非虚非实。非此非彼。非有非无。非有为非无为。非行非非行。非生非死。非涅槃非作法。是名中道。不以肉眼天眼慧眼观法念处。何以故。如是三眼。无相貌故。是故观法以法眼观。而心不着不失诸法。是名法念处。大王当知。修四念处。得四种离法。观身不净出离净倒。观受是苦出离乐倒。观心无常出离常倒。观法无我出离我倒。又观身念处离于揣食。观受念处离于触食。观心念处离于识食。观法念处离于思食。大王当知。沙门瞿昙。毕竟成就如是念处。是故我言。无有过失。王言。大师。云何如来四正勤法。答言。大王。沙门瞿昙四正勤者。谓四种精进。遮二种恶法。集二种善法。沙门瞿昙。善性成就心住善法。未生恶法及已生恶。不以精进令灭。未生善法已生善法。不以精进令生。何以故。沙门瞿昙。于无量世常修善性。一切恶法自然不生。一切善法自然满足。恶法者。谓非戒聚伴。非定聚伴。非慧聚伴。于四念处观时。诸懈怠心五盖烦恼覆障心眼。离于信等五种善根。是诸恶法。未生不生已生即灭。勤精进故。善法者。谓信等善根。未生令生。已生增广。勤精进故。是名四正勤法。大王当知。沙门瞿昙。毕竟成就如是四正勤法。是故我言。无有过失

王言。大师。何者如来四如意分。答言。大王。沙门瞿昙四如意分者。一者欲如意。二者精进如意。三者心如意。四者思惟如意。如是四法。慈悲喜舍而为根本。是四无量心常亲近。常亲近故。心得调柔。心调柔故。得入初禅第二禅第三禅第四禅。入诸禅故。身得轻软。成就如是身轻心柔。入如意分。善入如意分已。即生神通。若欲若精进若心若思惟。欲者专向彼法。精进者成就彼法。心者观察彼法。思惟者彼法方便成就。如是如意分。已能得神通。欲者庄严。精进者成就。心者正住。思惟者善能分别。沙门瞿昙得四如意。随其所解如其所作。心得自在。随意所往善作诸业。毕竟成就一切本行。如风行空无所挂碍。得四自在。一者命自在。二者身自在。三者法自在。四者神力自在。命自在者。为调众生。随所生处。若天若人。于短命中能现长寿。于长寿中能现短寿。是名命自在。身自在者。以自在故。随心作身。随心作色。示现威仪。为众生故。若欲与诸一切众生同其身相。悉皆能作。是名身自在。法自在者。能知一切出世之法。示诸众生世间之事。善知甚深十二因缘。得无碍辩。能随种种众生言说。令住正信。是名法自在。神力自在者。能令四大海水合作一海。不来不去无有动相。能令三千大千世界。诸须弥山合为一山。不来不去无有增损如本不异。于四天王三十三天无所妨碍。欲令三千大千世界。悉作金银七宝庄严。栴檀花香随现能作。是名神力自在。大王当知。沙门瞿昙。毕竟成就如是四如意分。是故我言。无有过失。大王当知。沙门瞿昙。成就如是四如意分已。能入一切禅定解脱神通无碍四无量心

王言。大师。何者如来禅定。答言。大王。沙门瞿昙。有九次第定。入三摩拔提。一者初禅。二者二禅。三者三禅。四者四禅。五者空处。六者识处。七者不用处。八者非有想非无想处。九者入灭尽处。大王当知。沙门瞿昙。离诸欲恶不善法有觉有观。离生喜乐入初禅行。离诸欲恶者。谓初禅所对诸爱染法。远离彼法。名离诸欲。离诸恶不善法者。谓因贪嗔痴起杀生等十不善业。是名不善法。远离彼法。是名初禅。有觉者。谓共觉故。何者是觉。依何境界随顺初禅。是觉多种。谓知觉思惟观集定等。是名为觉。何者是观。即彼随顺初禅觉行。思惟观受欲定知觉。是名为观。依于厌行共彼有觉有观而成初禅依。于厌行共彼有喜有乐而成初禅行。是名有喜有乐入初禅行。行者。所谓受持念护喜乐知等。是名为行。大王当知。沙门瞿昙。住初禅中。得无生法忍。增上欲心。是故入初禅求无生法忍。为求转胜无生忍故。于初禅中生不坚固想。起上欲心舍彼初禅求第二禅。为欲入彼第二禅故。离彼初禅有觉有观心。灭于彼心离于彼心。净于彼心寂静彼心。内净。心一处。无觉无观定生喜乐。入第二禅行。内净者。谓对治彼障第二禅法。寂静彼法清净无浊。是名内净。心一处者。谓灭彼初禅一切觉观。寂静一味犹如大海。一切诸水入皆一味。所谓盐味。入第二禅。灭彼初禅一切觉观。寂静一味无觉无观。如是名得无觉无观三昧。依彼三昧生喜。谓于佛法僧中生于喜心。依彼喜心。诸善功德自然满足。为欲令彼无生法忍。转转增胜。转转光明。转转胜妙。转转柔软。得上欲心。于彼第二禅中不住不乐。更求胜上第三禅行。生如是心。知彼喜心障第三禅及无生法忍。是故离喜行舍忆念。安慧身受乐。是乐圣人亦说亦舍。依彼二禅无生法忍胜上欲心。离彼喜乐。入三禅行得三昧乐。厌于彼喜。生如是心。此无喜乐。是无常乐。是尽灭法。非常非恒。非真实乐。非究竟乐。如是知已转更复起胜无生忍增上欲心。依彼胜忍增上欲心。不乐苦乐远离苦乐。先灭忧喜。不苦不乐舍念清净。入第四禅行。得第四禅三摩拔提。柔软心自在心寂静心光明心正直心。舍彼一切所有乐事与诸众生。与彼众生安隐乐时。即时得彼胜无生忍光明现前。得彼胜忍光明现前故。令行速疾。于第四禅胜妙乐中。不生乐心。远离彼乐舍念清净。惟见无边虚空现前。过一切色相。灭一切有对相。不念种种相。知无边虚空。即入无边虚空行。如是观色。略有二种。一者四大。二者依四大。四大者。谓地水火风。依四大者。谓色香味触如是广有八种色相。离彼色相。无彼色相。灭彼一切诸色相。名过一切色相。随何等法有其色相。彼法必有所对碍相。灭彼一切所有对相。不念不行种种异相。而能过彼种种异相。而不念彼种种异相故。惟见虚空相。是故知无边虚空。即入无边虚空行。是故说言。过一切色相。入彼无边虚空三昧已。生如是心。虚空无边。虚空无际。虚空无岸。随何等法。以无边等故。彼法无有前际中际后际。如是观一切法无前中后际。入如是三昧。即于一切众生起大慈心。即舍一切法。得平等智而现在前。尔时于彼无生忍中。始得胜进光明现前。过一切无边虚空相。现前知无边识相。入无边识处行。生如是心。是无边虚空相。惟是识想分别。得如是心知一切法。惟是识相。是识无量。入如是三昧。得无生法忍。非究竟成就。无生法忍。过一切无边识相处。现前知无所有处。入无所有少处行。无所有者。无彼所有贪嗔痴等分别之心。种种分别虚妄分别。一切世间有为之法。皆从虚妄分别心生。无彼所有故。言无所有。少者。如向所说。法中少相细相微相等。名少相。无彼少相故。言无少。过彼一切粗细想故。言无所有无所少。住是三昧。得于转胜无生法忍光明现前。为得彼胜无生法忍。而不乐彼无所有无少三昧。生胜欲心。转求增上三昧胜行。生如是心。是无所有无少行相。亦是细相虚妄分别故。次观非想非非想。何等是非想非非想。非想者是空。非非想者从因缘生。尔时非想非非想三昧现前。过一切无所有处少相。入非想非非想处三昧。行住于彼处。生如是心。彼非想非非想处。无所可乐远离彼法。即证诸法不生不灭三昧现前。知一切法不生不灭。见一切法自性寂灭不行不住。尔时名得胜上清净无生法忍。是名九种次第入三摩拔提。大王当知。沙门瞿昙毕竟成就如是定法。是故我言。无有过失。王言。大师。何者如来解脱之相。答言。大王。沙门瞿昙解脱有八种。一者有色见色。二者内有色相见外色。三者信净。四者过一切色相。灭一切有对相。不念一切别异相。知无边虚空。即入无边虚空行。五者过一切虚空无边相。知无边识。即入无边识行。六者过一切无边识相。知无所有少。即入无所有处行。七者过一切无所有处。知非有想非无想安隐。即入非有想非无想处行。八者过一切非有想非无想行。灭一切受想。入灭尽定行。是名八解脱。有色见色者。有色者。皆是因缘生法。见空无寿者。能如是见。得脱于缚。名为解脱。内有色相见外色者。见空无寿者。皆是因缘生法。能如是见。得脱于缚。名为解脱。信净者。若分别净不净相。名为邪见。以信净故。得脱于缚。名为解脱。过一切色相。灭一切有对相。不念别异相。知无边虚空。即入无边虚空行者。无量虚空。虚空能如是知。得脱于缚。名为解脱。过一切虚空无边相。知无边识。即入无边识行者。无量识无边识。此无边识。即是空。能如是知。得脱于缚。名为解脱。过无边识。知无所有少。即入无所有行者。所有者。名贪嗔痴烦恼。入无所有行者。灭彼烦恼。能如是知。得脱于缚。名为解脱。过无所有。知非有想非无想安隐。即入非有想非无想行者。非有想者。性空寂静。非无想者。以依因缘而有。能如是见。得脱于缚。名为解脱。过一切非有想非无想。灭一切受想。入灭尽定行者。如是见想如阳焰受如泡。想即是受。受即是想。无知者无寿者。能如是见。得脱于缚。名为解脱。大王当知。沙门瞿昙。毕竟成就如是解脱。是故我言。无有过失。王言。大师。何者如来神通智行。答言。大王。沙门瞿昙神通行有六种。一者天眼通。二者天耳通。三者他心通。四者宿命通。五者如意通。六者漏尽通。大王当知。沙门瞿昙所有天眼。过诸一切天龙八部声闻缘觉所有天眼。一切悉能明见十方功德智慧所成。悉见十方所有形色光明诸像若粗若细若近若远。一切悉见明了分别。其中所有一切众生。遍诸趣中生死相续。若业业果分别诸根悉知无余。于十方界诸佛如来所有庄严净妙国土亦见。其中菩萨声闻五道众生所修行业悉见无余。何以故。是眼清净。见无碍故。是眼不污。不着色故。是眼解脱。远离诸见烦恼缚故。是眼清净。性明了故。是眼无依。离所缘故。是眼不发。断烦恼故。是眼无垢。断诸恶故。是眼无翳。断疑网故。是眼不起。断障碍故。是眼无贪嗔恚愚痴。能断一切诸结使故。是眼得明。照了法故。是眼念知。不行识故。是眼无上。究竟圣道故。是眼无碍。平等照众生故。是眼无染。性清净故。何以故。沙门瞿昙。住大悲心。善分别义。无有诤讼。随见闻说。舍诸不善。趣于道场。心无障碍。见悭贪者。能以财施。见犯戒者。劝摄诸根。见嗔恚者。劝忍不诤。见懈怠者。劝勤精进。见散乱者。示禅定乐。见愚痴者。教修智慧。故得天眼清净无障。是名天眼神通智行

大王当知。沙门瞿昙所有天耳。尽十方界。其中所有一切诸声。天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人声。悉能分别。及知诸佛说法之声。菩萨声闻缘觉之声。一切耳根所能对声。乃至地狱畜生饿鬼蚊虻蝇蚤所有诸声。悉皆能闻。若诸众生心有所缘。善恶无记所出音声。一切解了。悉闻过去未来诸声。皆尽本际。何以故。沙门瞿昙。安住大悲。能闻诸声无有障碍。断诸烦恼习气灭故。是名天耳神通智行

大王当知。沙门瞿昙所有他心神通智行。所有众生。众生所摄。如其心念。所谓善心。不善心。无记心。顺烦恼心。背烦恼心。声闻心。辟支佛心。菩萨心。佛心。天心。龙心。夜叉心。乾闼婆心。阿修罗心。迦楼罗心。紧那罗心。摩睺罗伽心。人非人心。地狱心。畜生心。饿鬼心。阎罗处众生心。过去心。未来心。悉分别知。何以故。沙门瞿昙安住大悲。能知他心无碍无障。无诸烦恼故。断诸习气故。照一切法故。能如是解。是名他心神通智行

大王当知。沙门瞿昙所有宿命神通智行念知过去一生二生。乃至十生百生千生。无量百生。无量千生。无量百千生。及天地成坏。无量世界成。无量世界坏。无量成坏世界。无量成坏劫。知诸众生于是中生。如是种姓如是名字。如是色像如是寿命。如是受苦如是受乐。如是住处。如是衣服饮食。于是中死还是中生。于彼中死还彼中生。死此生彼。死彼生此。尽过去际悉知无余。又知过去尽过去际所有诸佛。如是眷属父母妻子兄弟姊妹。从初发心出家求道。修集愿行供养诸佛。教化调伏一切众生。坐菩提树成等正觉。如是名号。如是住处。如是胜坐。如是声闻。如是侍者。如是天。如是人。如是大众。如是外道。如是说法。如是度众生。如是寿命。如是灭度。如是正法住。如是像法住。悉能念知。何以故。安住大悲。善解作业故。是智无恼。安住禅定故。是智无畏。善摄智慧故。是智自然。不从他求现得善知故。是智正忆。毕竟不失故。是智功德。究竟大乘故。是智善根。从波罗蜜生到彼岸故。是名知宿命神通智行

大萨遮尼干子所说经卷第七大萨遮尼干子所说经卷第八

        元魏天竺三藏菩提留支译

    如来无过功德品第八之三

大王当知。沙门瞿昙如意神通智行者。为欲调伏邪见刚强难化众生令从正法。是故沙门瞿昙。能示种种神通教化。若色相若势力若变化。色相者。谓示佛色像。菩萨色像。缘觉色像。声闻色像。释提桓因梵天王四天王色像。转轮圣王色像。及余种种乃至畜生色像。随诸众生应见受化。悉能示现而为说法。若有众生恃身强力。而起憍慢嗔恚贡高。为欲调伏如是众生。示现大力如那罗延。以须弥山置一指端。掷着他方无量世界。或时断取三千大千世界下至水际。以一手举高至有顶住经一劫。现如是力。令彼憍慢自大众生贡高心息而为说法。变化者。以变化力。能变大海如牛迹水。大海不减牛迹不大。变牛迹水能成大海。若劫将尽火灾起时。应见水者即变为水。应见风者即变为风。水灾起时。应见火者即变为火。应见风者即变为风。风灾起时。应见水者即变为水。应见火者即变为火。作如是等种种变化。示诸众生令生欢喜。而为说法。何以故。是神通力。信欲精进禅定智慧诸法所摄。调伏柔和心得自在善修集故。是名如意神通

大王当知。沙门瞿昙漏尽通智行者。诸漏已尽远离一切烦恼习气。所谓欲漏有漏见漏无明漏。不同一切声闻辟支佛等所得漏尽。何以故。一切声闻辟支佛等得漏尽已。一切生处而有障碍。不具自在教化众生。是故有碍。沙门瞿昙无有障碍。是名漏尽智通。大王当知。沙门瞿昙。毕竟成就如是神通智行。是故我言。无有过失。王言。大师。云何如来四无碍智。答言。大王。四无碍智者。一者法无碍。二者义无碍。三者辞无碍。四者乐说无碍。大王当知。沙门瞿昙法无碍者。谓观众生。初发心行。多欲心行。少欲心行及善法恶法。世间法出世间法。可作法不可作法。有漏法无漏法。有为法无为法。黑法白法。生死法涅槃法。菩提平等。法性平等。如实而知。随所应闻。而为演说。是名法无碍智

大王当知。沙门瞿昙义无碍者。于诸法中知第一义智。是无我智。无众生智。无人智。无寿命智。知于过去无有挂碍智。知于未来无有边智。知于现在一切种智。知诸谛智。是苦不和合智。知集不作智。知灭自性智。知道能到智。知诸众生心行随入智。皆如实知。随所应闻。而能为说。是名义无碍智

大王当知。沙门瞿昙辞无碍智者。悉能了知一切音声语言。所谓知诸天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等所有音声语言文字。悉能了知。随所应闻种类差别。一一能同方音差别。说法说义。是名辞无碍智

大王当知。沙门瞿昙乐说无碍智者。随所应闻随所来问。一切语言及诸文字。口所分别正直而答。心无厌怠。所谓一切禅定三摩跋提辩说三乘。随诸众生一切心行。如应而答。言辞美妙说无挂碍。犹如流水不可穷尽。是名乐说无碍智。大王当知。沙门瞿昙。成就如是四无碍智。是故我言。无有过失

王言。大师。何者如来四无量心。答言。大王。四无量者。所谓慈心无量。悲心无量。喜心无量。舍心无量。大王当知。沙门瞿昙。有十种无量大慈之心。一者平等大慈。不选择一切众生故。二者饶益大慈。能开天人善道涅槃闭诸恶趣故。三者救护大慈。毕竟能度一切众生生死险难故。四者哀愍大慈。不舍一切众生长养诸根故。五者解脱大慈。灭诸众生烦恼热故。六者出生菩提大慈。示诸众生无上涅槃大菩提故。七者于诸众生无碍大慈。放大光明。普照一切众生界故。八者虚空等大慈。救护一切诸众生故。九者法缘大慈。觉悟一切诸众生等知真实法故。十者无缘大慈。证离生死实法性故。大王当知。是名慈心无量。大王当知。沙门瞿昙。有十种无量大悲之心。一者不共大悲。性大悲故。二者不厌大悲。代一切众生受大苦故。三者入一切恶道大悲。处在生死度众生故。四者于诸天人受生大悲。示现诸法悉无常故。五者不舍一切邪定。众生大悲。于无量劫起大誓心庄严成就故。六者不着己乐大悲。为与一切众生乐故。七者不求报大悲自心清净故。八者除灭一切众生倒心大悲说实法故。九者说真法性大悲。知诸法界自性清净故。十者说空空无所有大悲。不为诸客尘烦恼染故。大王当知。是名悲心无量

大王当知。沙门瞿昙。有十种无量大喜之心。一者大喜庆诸众生发菩提心故。二者大喜。念诸众生舍诸有故。三者大喜。于犯戒者不生恶心教化成就故。四者大喜。于诸一切诤讼众生悉令和合得无上智故。五者大喜。为诸众生常护正法故。六者大喜。远离世间出世间故。七者大喜。令诸众生不着一切资生之具常乐正法故。八者大喜。不共一切难摧伏故。九者大喜。不坏法界令诸众生常乐禅定解脱三昧相续不断故。十者大喜。令诸众生专求寂静。除灭乱心得无上慧。远离邪见满足诸愿故。是名喜心无量

大王当知。沙门瞿昙。有十种无量大舍之心。一者大舍。一切众生恭敬供养。心不加喜。一切众生轻慢毁辱不生恼故。二者大舍。常行世间。不为世间八法所染故。三者大舍。知器知时。于器非器心行平等故。四者大舍。不与众生声闻辟支佛学无学法故。五者大舍。远离一切烦恼习气故。六者大舍。不叹修行二乘菩提厌生死故。七者大舍。远离世间涅槃语。非离欲语。戏笑语。恼他语。声闻缘觉乃至一切障菩提语故。八者大舍。若有众生待时受化。如来于中。暂时放舍故。九者大舍。若有众生应受佛化。随彼应见种种色像。即能现故。十者大舍。远离二法。无上无下。无取无舍。无虚无实。观察平等。安住真实。得净忍故。是名舍心无量。大王当知。沙门瞿昙。毕竟成就如是四无量心。是故我言。无有过失

王言大师。何者如来五根之相。答言大王。五根相者。所谓信根精进根念根定根慧根。大王当知。沙门瞿昙信根者。信于四法。何等四法。一者于生死中。行施正见。信于业报。乃至夺命。终不作恶故。二者信菩萨行。不随诸见。专求菩提。不求余乘故。三者信解诸法。同空无相无愿。同第一义。同于了义甚深因缘。无我无人无众生。无有分别故。四者信一切佛十力四无畏十八不共法。如是信已。除诸疑网。集一切佛法。是名信根

大王当知。沙门瞿昙精进根者。若法信根所摄。是法即为精进根修。是名精进根。若法精进根所摄。是法终不忘失。是名念根。若法念根所摄。是法不忘不失。一心不乱。是名定根。若法定根所摄。是慧所观。是慧体性。内自照了。不从他知。自住正行。是名慧根。大王当知。沙门瞿昙。毕竟成就如是五根。是故我言。无有过失

王言大师。何者如来五力之相。答言大王。五力相者。所谓信力精进力念力定力慧力。大王当知。沙门瞿昙信力者。是信一向不可沮坏。乃至天魔变为佛身。示现出入禅定解脱。不能倾动。是名信力。于诸善法得坚固门。如所得力修诸禅定。诸天及人所不能坏。如本所愿皆悉成就是名精进力。所住诸法。不为烦恼之所破坏。何以故。是正念力能摧伏故。如是念力无能坏者。是名念力。远离愦闹常乐独行。虽有所说言语音声。不碍初禅善住觉观不碍二禅。心生欢喜不碍三禅。虽乐教化一切众生。不舍佛法。而亦不碍第四禅心。行四禅时。诸妨定法无所障碍。不舍诸定。亦不随定。而能自在处处受生。是名定力。知世间法出世间法。无有一法能坏是智。在在生处一切伎艺。不从师受悉自然知。一切世间外道苦行。为化众生悉能受行是出世间法。能过世间者。慧力所成。是名慧力。大王当知。沙门瞿昙。毕竟成就如是五力。是故我言无有过失

王言大师。何者如来七觉分相。答言大王。七觉分者。所谓念觉分择法觉分精进觉分喜觉分猗觉分定觉分舍觉分。大王当知。沙门瞿昙念觉分者。能观诸法能分别法。亦能观察诸法自相。云何自相。观一切法自性皆空。念如是等一切觉了。名念觉分。若能分别晓了八万四千法聚。如所了法。了义是了义。不了义是不了义。世谛是世谛。第一义谛是第一义谛。假名是假名。正了无疑。分别选择如是等法。是名择法觉分。若念法择法喜法倚法定法舍法。以智摄取精进勇猛。欲不退转勤修进趣。不舍本意行于正道。是名精进觉分。于所修行无量清净胜乐法中。心生悦豫无有懈怠。是喜踊跃。能除身心所有烦恼。是名喜觉分。若除身心诸烦恼垢。离于诸盖。入定境界。令心正住。是名倚觉分。如所入定悉能觉了。非不入定是觉了法。又了诸见烦恼结缚。其心平等。一切诸法无别异相。能如是觉。是名定觉分。若法忧喜其心不没。亦复不为世法所牵。无高无下正住不动无有诸漏。无喜无著无诸障碍。随顺真谛正直正道。是名舍觉分。大王当知。沙门瞿昙。毕竟成就如是七觉分。是故我言无有过失

王言大师。何者如来八正道分。答言大王。八圣道分者。所谓正见正思惟正语正业正命正精进正念正定。大王当知。沙门瞿昙正见者。若见出世。不起我人众生寿命养育士夫断见常见有见无见。亦复不起善以不善无记等见。乃至不起生死涅槃二相之见。是名正见。若能起彼贪欲嗔痴诸烦恼等。是名不正。不起是事。惟思戒定智慧解脱解脱知见。能如是思住戒聚中。名正思惟。凡所有说。不令自身及以他身而有损恼。成就如是善好语言。起于正道。是名正语。若业是黑有黑报。白有白报。若业黑白有黑白报。终不敢作。若业非黑非白。有非黑非白报。若业能尽业。是业必作。是名正业。修行圣种头陀威仪。不动不转无诸奸谄。不为世间利养所牵。见他得利心不生热。于己利养常知止足。如是正行圣人所赞。是名正命。若精进向邪。非圣所赞。所谓贪欲嗔恚愚痴烦恼。是正精进终不为之。若法能入正谛圣道寂灭涅槃。是正精进。若念不失。不动于法。正直不曲。见生死过。进求涅槃。系心不忘。不失正道。是名正念。若定不乱。于一切法住是定时。成正决定。是名正定。大王当知。住是三昧者。为一切众生得解脱故。成正决定。是名正定。是八圣道。悉是过去未来现在诸佛所行。是名圣道。大王当知。沙门瞿昙。具足成就如是三十七助菩提法。依此法故沙门瞿昙。名为如来应正遍知。是故我言无有过失。而说偈言

  瞿昙四念处　　及以四正勤
  禅定诸三昧　　于中得自在
  惟瞿昙究竟　　更无第二人
  是故说瞿昙　　无有诸过失
  瞿昙如意道　　最胜无有比
  修诸四无碍　　具足到彼岸
  大圣能善解　　解脱器差别
  是故如实知　　能净诸众生
  梵行得自在　　慈悲及喜舍
  得正见寂静　　是故无过失
  八圣正道水　　清净无垢浊
  洗诸罪众生　　服七觉宝衣
  将置彼不动　　无畏涅槃处
  是故说瞿昙　　无有诸过失
  瞿昙如牛王　　独胜过诸群
  众圣皆尊仰　　世间无等伦
  离诸一切恶　　具足诸功德
  常念利世间　　是故无过失

大王当知。沙门瞿昙。毕竟成就十种智力。王言大师。何者是如来十种智力。答言大王。十力者。所谓知是处非处智力。知业集智力。知性智力。知信智力。知根智力。知至处道智力。知定智力。知宿命智力。知天眼智力。知漏尽智力。大王当知。沙门瞿昙知是处非处智力者。决定了知因果中智。知从是因能生是果不生是果。知行不善定得苦报不生乐报。修行善因定得乐果不生苦果。是处者有是报。非处者无是报。是名知是处非处智力

大王当知。沙门瞿昙知业集智力者。如实能知过去未来现在诸业所得果报。知处知事知因知果。或谓过去事灭皆无。沙门瞿昙说于过去。虽无现相。是业能得未来世报。若有作业。是声闻因。是辟支佛因。是菩萨因。是如来因。沙门瞿昙悉能了知。是名知业集智力。大王当知。沙门瞿昙知欲力者。如实能知一切众生种种欲乐。知是众生乐于五欲知是众生乐于修道。知是众生住邪定聚。知是众生住正定聚。知是众生住不定聚。知是众生乐声闻道。知是众生乐辟支佛道。知是众生乐无上道。如是知已。随宜说法。广度一切诸众生等。是名知欲智力

大王当知。沙门瞿昙知性力者。如实能知一切众生无量种性。有漏种性。无漏种性。世间性。出世间性。常性。无常性。法界性。无差别性。又知众生所乐习成难改之性。从性起欲。知其所乐。及知所起善性不善性。起声闻性辟支佛性无上菩提性。皆如实知。随宜说法。是名知性智力

大王当知。沙门瞿昙知根力者。如实能知一切众生诸根差别。知有漏根无漏根利根钝根。知增知减。能知贪欲嗔恚愚痴。有无量种各有轻重。悉如实知。知有根能增长生死。知有根能损减生死。知善根不善根。知非善非不善根。知眼根耳根鼻根舌根身根意根。男根女根命根。苦根乐根忧根喜根舍根。信根精进根念根定根慧根。未知欲知根。知根知已根。知眼根因乃至意根因。知耳根因作眼根缘。知鼻根因作舌根缘。知舌根因作身根缘。知戒庄严能修于施。知施庄严能修于戒。能知谁可说施说戒。乃至智慧亦复如是。能知谁可说四念处乃至八正道分。知谁可为说声闻乘辟支佛乘无上佛乘。知缘觉根学声闻乘。知正觉根学声闻乘辟支佛乘。知下根人能修上根上根之人修于下根。知众生根未可调者。则生舍心。可调伏者。为说正法。知根熟不熟相。不熟熟相。不熟不熟相。熟有熟相。知生死根。知解脱根。知庄严根。知具足根。如是知已。而为说法。是名知根智力

大王当知。沙门瞿昙知至处道力者。如实能知行是道者堕于地狱乃至生天。行是道者得至涅槃。是业皆从根欲性生。知有漏业故生于五道。无漏业故得至涅槃。如是能知正定聚邪定聚及不定聚。知于因力及果报力。知过去世福德因缘。知现在世庄严因缘。难调易调。略说广解。广说略解。知是众生能得解脱。知是众生不得解脱。知不定者。遇善知识住正定聚。不得善友则无解脱。如是知已。随所应闻而为说法。是名能知至处道力

大王当知。沙门瞿昙知禅定力者。如实能知禅定解脱三昧三摩拔提。知垢知净知住知增。知诸众生以是因缘贪乐生死。以是因缘贪乐涅槃。云何名因云何名缘。知诸众生思惟不善是生死因缘。因不善思惟故生长无明。是故不善为因无明为缘。因无明故则生于行。是故无明为因诸行为缘。如是乃至因生则有老死等苦。是故生则为因老死为缘。烦恼为因诸业为缘。诸见为因爱结为缘。烦恼为因五盖为缘。是名为因是名为缘。而诸众生。以是因缘贪乐生死。何因缘故贪乐涅槃。有二因二法。令诸众生乐于涅槃。一者喜乐听法。二者乐正思惟。复有二法。一者舍摩他。二者毗婆舍那。又知说法因缘得声闻三昧缘觉三昧菩萨三昧。如是知已。而为说法。是名知定智力

大王当知。沙门瞿昙知宿命智力者。如实能知自身过去一切生处。有色无色种性名字。饮食色貌形相苦乐寿命长短。念他有灭生于他有。如知自身知他亦尔。知是众生所有业因。是诸众生造是业因得他有身。知诸众生心及因缘。如是灭已次第生心。悉知三世无有始终。劝诸众生。观诸过去所作善恶果报苦乐。如是知已。随所应闻而为说法。是名知宿命智力

大王当知。沙门瞿昙知天眼智力者。如实知见一切众生生灭堕落。若受善色。若受恶色。若生善有。若生恶有。知诸业因皆悉明了。知是众生身口意恶。诽谤圣人增长邪见。以恶业故。舍此身已。即堕地狱。知是众生身口意善。不谤圣人增长正见。以是业缘舍此身已。即生善有。能见十方诸佛世界无有边际。犹如虚空无有限量。悉见众生生时灭时。见诸世界成时坏时。亦知众生发菩提心生时灭时。见一切佛始成正觉转正法轮入涅槃时。见诸声闻证解脱已取涅槃时。见诸缘觉以神通力报诸众生信施恩时。如是等事。一切五通声闻缘觉及诸菩萨。所不能见。沙门瞿昙天眼。成就如是功德。以天眼故。观诸众生。谁应为佛之所化度。谁复应为声闻缘觉之所化度。如是见已。随应度者。示现其身而为说法。是名知天眼智力

大王当知。沙门瞿昙知漏尽力者。诸漏已尽毕竟解脱。是故唱言。我生已尽。梵行已立。所作已办。更无后有。佛漏尽智清净微妙。言清净者。无习气故。声闻之智有边有量。何以故。有习气故。辟支佛智亦有边量。何以故。无大悲故。佛漏尽智无量无边。何以故。知一切行故。具足成就一切智故。永断一切诸习气故。摄取大慈大悲庄严四无所畏于一切法无取相习。一切世间所不能胜。行住坐卧无诸过失。犹如虚空清净无碍不杂烟云。佛漏尽智亦复如是。不杂一切烦恼习故。能为一切众生说法。令彼闻者断诸烦恼。是名知漏尽智力。大王当知。沙门瞿昙。毕竟成就如是十种智力。以是庄严故。名如来应正遍知。是故我言。无有过失。而说偈言

  是处及非处　　诸佛如实知
  大尊实语者　　是故无过失
  于诸过去世　　圣照无障碍
  未来及现在　　智慧不迷没
  业及业果报　　所有果因智
  皆能如实知　　是故名为佛
  世人无量性　　种种如实知
  于性中善解　　是名无等人
  世间种种信　　及无量信者
  如实智慧知　　是故不异语
  如实知下根　　及知中根者
  如实知根熟　　于根得自在
  生一切处道　　世尊如实知
  力通根禅定　　觉分解脱者
  知染及清净　　差别如实解
  如来无有障　　以离诸障故
  过去无量生　　种种知力见
  自身及他身　　智者如实知
  佛净眼无垢　　过天人世间
  依彼清净眼　　见众生生退
  知诸漏尽智　　及知于解脱
  所有无漏界　　圣人如实知
  是力无等等　　佛世尊自在
  于一心中现　　而心无分别
  不取亦不舍　　自然而现前
  如轮依本业　　自然而回转
  一念如实知　　众生诸心念
  于心及众生　　不起二种相
  于一切法中　　具足诸功德
  是故说瞿昙　　自在无过失

大萨遮尼干子所说经卷第八大萨遮尼干子所说经卷第九

        元魏天竺三藏菩提流支译

    如来无过功德品第八之四

大王当知。沙门瞿昙。毕竟成就四无所畏。王言大师。何者如来四无所畏。答言大王。所谓一切智无畏。漏尽无畏。障道无畏。尽苦道无畏。大王当知。一切智无畏者。沙门瞿昙。悉以觉知一切诸法。若诸世间天人魔梵沙门婆罗门。作如是言。沙门瞿昙。不能觉知一切诸法。如实说者无有是处。何以故。沙门瞿昙。悉能觉知一切诸法。是故名为平等正觉。所谓凡夫法。圣人法。声闻法。缘觉法。佛法菩萨法。学法无学法。世间法出世间法。善法不善法。有漏法无漏法。有为法无为法。觉如是法故名正觉。言平等者。见空平等。法真实故。无相平等。坏诸相故。无愿平等。不着三界故。不生平等。无生性故。无行平等。无行性故。无出平等。无出性故。无至处平等。无至处性故。真实平等。无三世故。解脱平等。无无明性故。涅槃平等。无生死性故。是故沙门瞿昙。悉能觉知一切诸法。至无畏处。以大悲心在大众中。作师子吼转梵法轮。一切世间天人魔梵沙门婆罗门。未曾有能如法转者。是名一切智无畏。大王当知。漏尽无畏者。沙门瞿昙诸漏已尽。是故唱言。我漏已尽。若诸世间天人魔梵沙门婆罗门。作如是言。沙门瞿昙诸漏未尽。如实说者无有是处。何以故。沙门瞿昙诸漏已尽。于欲漏有漏无明漏见漏。心得解脱诸习气灭。是故沙门瞿昙。诸漏已尽至无畏处。在大众中作师子吼转梵法轮。一切世间天人魔梵沙门婆罗门。未曾有能如是转者。是名漏尽无畏。大王当知。障道无畏者。沙门瞿昙知诸欲法能障圣道。是故说言。欲能障道。若诸世间天人魔梵沙门婆罗门。作如是言。是诸欲法不能障道。如实说者无有是处。何以故。沙门瞿昙。如实觉知障道法故。障道法者。谓十不善业能障圣道。沙门瞿昙。能如实知至无畏处。在大众中作师子吼转梵法轮。一切世间天人魔梵沙门婆罗门。未曾有能如法转者。是名说障道无畏。大王当知。尽苦道无畏者。沙门瞿昙说言。修习圣道能尽苦际得无上解脱。若诸世间天人魔梵沙门婆罗门。作如是言。修习圣道不能毕竟尽诸苦际。如实说者无有是处。何以故。沙门瞿昙。已证无上解脱尽诸苦故。云何名为真实圣道。所谓一乘。复有二种。谓舍摩陀毗婆舍那。复有三种。谓空三昧无相无愿三昧。复有七法。谓四念处乃至八圣道。是名毕竟真实圣道。毕竟道者。无增无减。无取无舍。无执无放。非正非邪。非一非二。是名真实毕竟正道。沙门瞿昙。如实能知至无畏处。在大众中作师子吼转梵法轮。一切世间天人魔梵沙门婆罗门。未曾有能如法转者。是名尽苦道无畏。大王当知。沙门瞿昙。毕竟成就如是四无畏智能师子吼。是故我言无有过失。而说偈言

  瞿昙如师子　　处众无畏说
  世间无与等　　何况有胜者
  瞿昙证诸法　　如实不虚妄
  以是实见故　　出师子王说
  若有能说言　　瞿昙说不正
  瞿昙不能见　　无有如是处
  以不见相者　　在于天人中
  自在师子吼　　出妙无畏声
  瞿昙漏已尽　　已得无漏身
  过天人世间　　是故言无等
  瞿昙为众生　　说诸障道法
  一切皆如实　　故不虚妄说
  瞿昙说进取　　自证如是说
  修行彼法者　　无有诸障碍
  瞿昙如是知　　至胜无畏处
  得无畏妙乐　　瞿昙安隐住
  转梵正法轮　　余未曾转彼
  世人不能转　　除两足尊者

大王当知。沙门瞿昙。毕竟成就不共之法。王言大师。何者如来不共之法。答言大王。沙门瞿昙不共法者。所谓无有一切过。名不共法。何以故。沙门瞿昙身业无失故。无一切过。名不共法。何以故。沙门瞿昙口业无失故。无一切妄。名不共法。何以故。沙门瞿昙。意业无失故。无种种相。名不共法。何以故。沙门瞿昙。若得供养不生高心。若得毁辱不生下心故。无不定心。名不共法。何以故。沙门瞿昙。若行若住若坐若卧若语若默。常在定故。无不住心舍心。名不共法。何以故。沙门瞿昙。修身故。修戒故。修心故。修慧故。断痴故。是名圣舍欲无休息。名不共法。何以故。沙门瞿昙。大慈大悲说法度人。安住寂静无增减故。精进无休息。名不共法。何以故。沙门瞿昙。为一切众生。于无量劫。受大苦恼。不生疲厌故。念无休息。名不共法。何以故。沙门瞿昙初得道时。遍观一切去来现在众生之心。后为说法不须更观。不失先念故。智慧无休息。名不共法。何以故。沙门瞿昙。于三世中忆念不忘故。解脱无休息。名不共法。何以故。沙门瞿昙。不从师学自然觉悟。不同二乘从他闻故。因缘生故。解脱知见无休息。名不共法。何以故。沙门瞿昙得无碍智。知一切义一切字一切句。于一句法无量劫说义无穷尽故。一切身业智。为本智展转。名不共法。何以故。沙门瞿昙。所有身业随智行故。一切口业智。为本智展转。名不共法。何以故。沙门瞿昙。所有口业随智行故。一切意业智。为本智展转。名不共法。何以故。沙门瞿昙。所有意业随智行故。知过去世无障无碍。名不共法。何以故。沙门瞿昙具宿命明故。知未来世无障无碍。名不共法。何以故。沙门瞿昙得天眼明故。知现在世无障无碍。名不共法。何以故。沙门瞿昙得漏尽明故。无见顶者。名不共法。何以故。沙门瞿昙无边身故。无能胜者。名不共法。何以故。沙门瞿昙。过诸天人声闻辟支佛故。众生各各见在己前。名不共法。何以故。沙门瞿昙身不可思议故。所有言说闻者生善。名不共法。何以故。沙门瞿昙。成就一切诸功德故。说法之音随受者闻。名不共法。何以故。沙门瞿昙。善知余者闻无益故。出言清净。名不共法。何以故。沙门瞿昙。口常不说非义语故。出口所说粗言软语闻者欢喜。名不共法。何以故。沙门瞿昙其心平等离怨亲故。所说言音闻者无厌。名不共法。何以故。沙门瞿昙。说微妙故。处众无畏。名不共法。何以故。沙门瞿昙。清净一切诸智障故。于众言说不生怯弱。名不共法。何以故。沙门瞿昙。毕竟成就四无畏故。随意言说。名不共法。何以故。沙门瞿昙。善知一切众生心故。弟子寂静。名不共法。何以故。沙门瞿昙。所有徒众随顺受教故。见者离恼除诸不善。名不共法。何以故。沙门瞿昙。常愿其身如药树王故。观者无厌。名不共法。何以故。沙门瞿昙。能令见者觉一切法故。动身回顾如大象王。名不共法。何以故。沙门瞿昙。视如龙王威仪清净故。在于四众能师子吼。名不共法。何以故。沙门瞿昙。具足十力善决众疑故。常受上供。名不共法。何以故。沙门瞿昙无上福田故。功德无尽。名不共法。何以故。沙门瞿昙。所修诸行不求果报故。一切天人魔王梵众无能坏者。名不共法。何以故。一一节中有那罗延力故。所记之事无有虚谬。名不共法。何以故。善知一切诸根使故。知一切行。名不共法。何以故。沙门瞿昙。觉一切法故。所有智慧无有疑浊。名不共法。何以故。沙门瞿昙。善知三世智清净故。烦恼习尽。名不共法。何以故。沙门瞿昙。善能清净烦恼因故。于诸世间天人魔梵沙门婆罗门众中。而为师首。名不共法。何以故。沙门瞿昙。通达一切诸法相故。所得法身。名不共法。何以故。沙门瞿昙。寿命无尽故。见闻亲近得大利益。名不共法。何以故。沙门瞿昙。成就善法三业不空故。出身血者犯于逆罪。名不共法。何以故。沙门瞿昙。成就无上胜善根故。大王当知。沙门瞿昙。毕竟成就如是不共法。是故我言无有过失。而说偈言

  瞿昙无过失　　亦无一切习
  诸念皆清净　　是智者无过
  一切无异相　　而心不忘失
  舍心非无作　　诸欲皆不减
  精进无懈怠　　有念不曾忘
  慧解脱不退　　正见无失减
  智慧不可动　　身口业亦尔
  以智为根本　　如是常展转
  常智无过失　　过去世亦尔
  未来及现在　　诸处无障碍
  瞿昙是智者　　如是诸功德
  更有余胜法　　地主不可数

王言大师。如来成就如是功德庄严之身。为是常也为无常也。如是功德。为有尽也为无尽也。答言大王。沙门瞿昙。住是功德。尽生死际。最后边身。是常住身。非无常也。大王当知。勿观瞿昙同无常也。王言大师。如是常身当云何观。答言大王。如自观己法性之身。观于瞿昙法身亦尔。是身为色。不可如色见故。是身为心。不可如心知故。是身为炬。性不闇故。是身勇健。降众恶故。是身为力。无降伏故。是身无违。性平等故。是身为空。离见闻故。是身无相。离觉观故。是身无愿。出三界故。是身一相。无异相故。是身如虚空。无相似故。是身非生。从缘生故。是身非灭。本不生故。是身非住。非三世故。是身非方。不离方故。是身非众生。不离一切众生故。大王当知。如是观者。名观常身。名见法身。大王当知。如是观者。名为正观。若他观者。名为邪观。王言大师。云何非生而从缘生。大王当知。法身非生。从缘生故。王言大师。云何从缘生。大王当知。从缘生者。从无量功德智慧生。从戒生。从定生。从慧生。从解脱生。从解脱知见生。从慈悲喜舍生。从布施生。从持戒生。从忍辱生。从精进生。从禅定生。从智慧生。从解脱三昧生。从诸方便波罗蜜生。从六通生。从三明生。从四无碍生。从十力四无所畏十八不共法生。从断一切不善法集一切善法生。从实慧生。从不放逸生。大王当知。从如是无量清净功德法生。瞿昙身功德无尽故。法身无尽。王言大师。生法有尽。云何有生而无有尽。答言大王。本不生故。而无有尽。王言。大师。何者本不生故。答言大王。法身非生。以本有故。以缘生故。名之为生。王言大师。如是缘者。无量无边。若欲行者。以何为本。从何为始。答言大王。一切功德助道之行。举要言之。以戒为本。持戒为始。若不持戒。乃至不得疥野干身。何况当得功德之身。大王当知。以戒净故。不断佛种。成等正觉。不断法种。分别法性。不断僧种。修无为道。以持净戒相续不断故。功德无尽。王言大师。一切戒善。皆无有尽。亦有尽也。答言大王。非一切尽。亦非不尽。何以故。相续断故有尽。不断故无尽。王言大师。何者相续断。何者相续不断。答言大王。净戒相续。不中断故。功德无尽。何以故。凡夫戒者。在所受生断故有尽。人中十善所得果报断故有尽。欲界诸天福报功德断故有尽。色界诸天禅无量心断故有尽。无色诸天取入诸定断故有尽。一切声闻学无学戒入涅槃际断故有尽。辟支佛戒无大悲心断故有尽。诸菩萨戒到于菩提。成大悲故功德无尽何以故。于是戒中。出生一切凡夫二乘所有诸戒。如种无尽故。果亦无尽。是故菩提种不可尽。王言大师。如此法身。当依何法作如是观。答言大王。当依一切众生烦恼身观。当依贪欲嗔恚愚痴众生中观。当依四颠倒见众生中观。当依阴界诸入中观。当依地狱畜生饿鬼乃至阿修罗等诸身中观。何以故。此身即是如来藏故。大王当知。一切烦恼诸垢藏中。有如来性湛然满足。如石中金。如木中火。如地下水。如乳中酪。如麻中油。如子中牙。如藏中宝。如摸中象。如孕中胎。如云中日。是故我言。烦恼身中有如来藏。尔时萨遮尼干子。重说偈言

  瞿昙法性身　　妙色常湛然
  清净常寂灭　　其相如虚空
  如是法性身　　众生等无差
  此境界甚深　　二乘不能知

尔时严炽王。闻大萨遮尼干子说于如来不可思议功德法身。生欢喜心。生踊悦心。生踊跃心。生无量欢喜心。生无量信敬心。生无量爱念心。生无量庆悦心。于大萨遮尼干子所。复生不可思议者心。生不可量者心。生可尊者心。生可尊重者心。生可恭敬者心。生善知菩提道者心。生一切智者心。生到彼岸者心。生寤寐者心。生与念者心。生住不可思议解脱菩萨心。生如是等不可思议种种心已。以价直百千万阿僧祇璎珞。及不可量上价妙衣。持用奉施萨遮尼干子。复作是言。善哉善哉萨遮大师。能说如是胜大方便巧妙法门。复作是言。萨遮大师。师所说法。善巧随顺一切智智。此法能到一切智地。师所说法。能度一切诸世间流。师所说法。能洗一切诸烦恼垢。师所说法。能破一切诸嫉妒门。师所说法。能拔一切诸恶道苦。师所说法。能善方便坏散一切大憍慢山。师所说法。悉能干竭一切世间爱欲大海。师所说法。能照一切无智稠林。师所说法。能不失时不失受时。尔时萨遮尼干子告严炽王言。如是如是大王。诸菩萨摩诃萨。无有威仪不化众生。无有一法不能随顺大乘法门。无有一法不能到于一切智地。无有一法不能断于一切烦恼。无有一法不示世间一切过失。无有一法不示涅槃无上功德。无有一法不示菩萨无上胜行。大王当知。诸菩萨摩诃萨所行一切行。皆为自利。亦为他利。彼二俱利。萨遮尼干子。说此法门时。严炽王。得大坚固不退转菩提之心。王十六子所得。名为欢喜踊跃境界信心。八千天子。得名观佛庄严三昧。时严炽王所有眷属。及大萨遮尼干子诸眷属等。十三千人。发阿耨多罗三藐三菩提心。彼诸众生。各各脱身所著上衣。持用奉施萨遮尼干子。而作是言。我今善得无上大利。以我得见萨遮善男子故。得闻说此一切智慧胜妙法门

    大萨遮尼干子所说经诣如来品第九

尔时严炽王及诸眷属作是言。萨遮善男子。师今应往诣如来所。见佛世尊。礼拜如来。供养如来。何以故。今佛世尊在我园中。为诸大众说微妙法。萨遮尼干子言。善哉大王。欲见如来。今正是时。可共国内城邑小王。诸聚落主。大臣王子。长者居士。及王夫人后宫婇女。并王大力臣。如是等众。一时同心俱往佛所。尔时严炽王。敕令国内一切城邑乃至聚落主等。各将所领及家眷属。悉共庄严。俱诣佛所。若其不往如来所者。当断其命。尔时国内所有一切善男子善女人及童男童女等。闻王教令。欲与萨遮大师俱往佛所亲觐供养。心生欢喜。各各庄严彩饰绮妙。备诸一切种种香华。涂香末香华鬘幡盖。执诸种种一切伎乐。出郁阇延城。在于大路。待严炽王。尔时严炽王。驾七宝绳交络辇舆。以诸无量金瓶银瓶。插种种华侠在两厢。王兴大力。现大王势。作大王神通。作大王奋迅。象马车步。作大王戏乐。竖诸种种幢幡华盖。打八千种诸妙声鼓。种种歌舞。与大萨遮尼干子。大臣王子。与王大力夫人宫人。及诸小王长者居士。乃至守门守宫人等。九万八千万人前后围绕。俱往园中诣如来所。到佛所已。顶礼佛足绕佛三匝。萨遮尼干子。与诸眷属。顶礼佛足。绕佛无量百千匝已。却坐一面。一心合掌。观佛不舍。默然而住

    大萨遮尼干子所说经说法品第十之一

尔时慧命舍利弗。见大萨遮尼干子。在佛前坐一心合掌。观佛不舍默然而住。作是思惟。此萨遮尼干子。为何事故来诣佛所。作是念已。语大萨遮尼干子言。汝为何事来诣佛所。为见佛也。为闻法乎。尔时萨遮尼干子语慧命舍利弗言。大德舍利弗。我今来诣佛世尊所。不为见佛。不为闻法。大德舍利弗。我今不为一切法故来诣佛所。何以故。大德舍利弗。非见色故。名见如来。非见受想行识故。名见如来。非见地性故。名见如来。非见水性火性风性故。名见如来。非见我故。名见如来。非见众生故。名见如来。非见寿命故。名见如来。非见人故。名见如来。非见作者故。名见如来。非见我所故。名见如来。非见所见事故。名见如来。非见相故。名见如来。非见无相故。名见如来。何以故。大德舍利弗。不见一切相。名见如来。不执着见。名见如来。不见物故。名见如来。如实见故。名见如来。见实际非际故。名见如来。厌眼厌色故。名见如来。不见耳不闻声故。名见如来。不见鼻不嗅香故。名见如来。不见舌不知味故。名见如来。不见身不见触故。名见如来。不见意法不分别意法故。名见如来。舍利弗言。萨遮大德。若如是相见不见如来者。云何名见佛世尊也。萨遮尼干子答言。大德舍利弗。非见家故。名见如来。非见姓故。名见如来。非相故名见如来。非非相故名见如来。非法故名见如来。非非法故名见如来。非实故名见如来。非非实故名见如来。非观故名见如来。非非观故名见如来。非念故名见如来。非非念故名见如来。非分别故名见如来。非非分别故名见如来。非有为故名见如来。非无为故名见如来。非有物故名见如来。非无物故名见如来。非和合故名见如来。非别离故名见如来。非色故名见如来。非受想行识故名见如来。非取故名见如来。非不取故名见如来。非生故名见如来。非不生故名见如来。尔时慧命舍利弗语大萨遮尼干子言。萨遮大德。若如是见名见如来者萨遮大德。云何而见佛世尊也。萨遮尼干子答言。大德舍利弗。我非见色见如来。亦不离色见如来。我不灭坏色名见如来。如是非见受想行识。名见如来。不离受想行识名见如来。我不灭坏受想行识。名见如来。我不见如来世间所摄。亦不见如来出世间摄。我不见如来为阴所摄。不见如来为界所摄。不见如来为入所摄。我见如来离诸一切音声言语。我今如是见于如来。如是不见非不见。不知不分别。不起不示。不生不增长。不取不舍。不戏论。不作相。不作非不作。不作物非不作物。不受不护。非作心见。非自然见。非观见。非不观见。非可语见。非不可语见。离一切言语名字章句音声。名见如来。何以故。以不可如是相见故。大德舍利弗。诸菩萨摩诃萨。如是见佛。我亦如是见于如来。舍利弗言。萨遮大德。若能如是见如来者。如来说法。大德云何而得闻也。答言。大德舍利弗。我若起法相非法相。应闻如来所说之法。何以故。大德舍利弗。诸菩萨摩诃萨。于诸一切名字章句言语之音。闻说法声。而不作心法相非法相。何以故。以离一切诸法相故。舍利弗言。萨遮大德。汝来佛所。非为法来也。答言。大德舍利弗。我不为法。非不为法。来诣佛所。何以故。大德舍利弗。夫为法者。不为一切法名为为法。大德舍利弗。若有人言为法来者。彼人不着此法名为佛。不见此法名为法。不着生名为僧。夫为法者。不为知苦。不为离集。不为修道。不为证灭。不为过欲界。不为过色界。不为过无色界。不为得涅槃。大德舍利弗。汝依此法应知。我今不为法故来诣佛所。尔时慧命舍利弗告大萨遮尼干子言。萨遮大德。今依何法作如是说。答言。大德舍利弗。我今都不依于一法作如是说。何以故。法界中无依。法界中依不可得。法界中无依亦不可得。何以故。以不见二故。舍利弗言。萨遮大德。汝今不依六道去来也。答言。大德舍利弗。我若见彼六道相者。应有去来。我若有生。亦应受生。有退应退。有去应去。大德舍利弗。一切法不动不转不去不退不生。舍利弗言。萨遮尼干子。若如是者。如来何故说言。比丘汝生老死亦退亦生。答言。大德舍利弗。如来依着六道众生。作如是说。为欲拔彼依止六道。是故如来作如是说。大德舍利弗。于佛法中不去不来不退不生。舍利弗言。善哉善哉。萨遮大德。如萨遮大德所说。是大乘行者。知义知字者。萨遮尼干子言。大德舍利弗。汝知何者为义何者为字。舍利弗言。善男子。我不欲说。我欲闻说。大德当说。何者为义何者为字。尔时萨遮尼干子告舍利弗言。大德舍利弗。所言义者。名不可说。说不可说。名之为字。所言义者。名不可语。说彼语者。名之为字。所言义者。名不可名。说彼名者。名之为字。所言义者。不可动。不可知。不可戏论。不可分别。不可生。不可聚。非物非实。无我非起。非可取。非可依。远离一切依言语名字。所言字者。思惟数称量观察令他解。名之为字。所言义者。为义无碍。所言字者。名法无碍辞无碍乐说无碍。大德舍利弗。是名略说义略说字。尔时世尊告萨遮尼干子言。善哉善哉。萨遮。快者善哉。若有善男子。欲说法者。应如是说。如汝所说。说此法门。尔时众中。三千天子。闻大萨遮尼干子乐说辩才。得无生法忍。二十千众生。发阿耨多罗三藐三菩提心

大萨遮尼干子所说经卷第九大萨遮尼干子所说经卷第十

        元魏天竺三藏菩提留支译

    说法品第十之二

尔时慧命大目揵连白佛言。世尊。此萨遮尼干子。现此外道相。教化几所众生。发阿耨多罗三藐三菩提心。佛告目连。目连。汝今问我此事。天人闻说。皆悉迷没。除诸菩萨摩诃萨众。目连。我今说其少分。令众生入。萨遮善男子。以种种形种种色种种威仪。教化众生。发阿耨多罗三藐三菩提心。目连。如须弥山微尘数等众生。住外道法中。萨遮善男子。行外道法。教化令发阿耨多罗三藐三菩提心。四天下微尘数等众生。住遮罗伽外道法中。萨遮善男子。行遮罗伽法。教化令发阿耨多罗三藐三菩提心。八万四千恒河沙等众生。住波利婆阇外道法中。萨遮善男子。行波利婆阇外道法。教化令发阿耨多罗三藐三菩提心。十恒河沙等众生。乐声闻行。萨遮善男子。现声闻行。教化令住声闻菩提。后发阿耨多罗三藐三菩提心。过是声闻数等身。现行辟支佛形。教化令发阿耨多罗三藐三菩提心。无数众生。萨遮善男子。行菩萨道。教化令发阿耨多罗三藐三菩提心。应见帝释身而受化者。即现帝释身教化众生。应见梵王身而受化者。即现梵王身教化众生。应见转轮王身而受化者。即现转轮王身教化众生。应见四天王身而受化者。即现四天王身教化众生。应见紧那罗身而受化者。即现紧那罗身教化众生。应见阿修罗身而受化者。即现阿修罗身教化众生。应见迦楼罗身而受化者。即现迦楼罗身教化众生。应见摩睺罗伽身而受化者。即现摩睺罗伽身教化众生。应见人身而受化者。即现人身教化众生。应见女身而受化者。即现女身教化众生。应见童男童女身而受化者。即现童男童女身教化众生。应见地天身而受化者。即现地天身教化众生。应见同生天身而受化者。即现同生天身教化众生。应见圣人身而受化者。即现圣人身教化众生。应见摩那婆身而受化者。即现摩那婆身教化众生。应见比丘比丘尼身而受化者。即现比丘比丘尼身教化众生。应见优婆塞优婆夷身而受化者。即现优婆塞优婆夷身教化众生。目连。萨遮善男子。现如是等一切种种无量身相。教化如是无量众生。发阿耨多罗三藐三菩提心。目连白佛言。世尊。萨遮善男子。供养几所诸佛。佛告目连。目连。地界水界火界风界虚空分界等。悉可量数。而萨遮善男子。以种种身所供养佛。不可量数

    大萨遮尼干子所说经授记品第十一

尔时大德摩诃迦叶告萨遮善男子言。善男子。汝已供养无量诸佛。具足成就无量无边诸功德聚。何故不成阿耨多罗三藐三菩提。萨遮答言。大德迦叶。我若有见此是菩提此是证者。我应得阿耨多罗三藐三菩提。迦叶言。萨遮善男子。无量无边菩萨。发阿耨多罗三藐三菩提心。可不已成阿耨多罗三藐三菩提。当成阿耨多罗三藐三菩提。现成阿耨多罗三藐三菩提也。萨遮答言。大德迦叶。汝今所言。无量无边诸众生等。成阿耨多罗三藐三菩提者。此是憍慢众生之数。何以故。大德迦叶。于第一义中。菩提不可得。菩萨不可得。何以故。大德迦叶。言菩提者。名为无为。菩提者离一切数。菩提者非色法。菩提者不可见。菩提者非青非黄非赤非白。非红非黑非颇梨色。无色无形无相无表。过一切相。无依离一切依。无物离一切物。无相离一切相。不可言。不可说。不可见。不可和合知。不可别异知。非闇非明。无形无相无可观。非言语离言语。不可触不可知不可闻。非音声非口道。无拥无碍无缚无脱。非嗔非痴。不可以一切事示现不可说。大德迦叶。菩提体如是相。彼不可以身证。不可以心知。何以故。大德迦叶。是身无知如草木。是身无觉如石壁。是身无识如镜像。是故不可以身得菩提。大德迦叶。心亦不可见不可示。是故不以心得菩提。大德迦叶。众生不可见。无众生故。是故不得阿耨多罗三藐三菩提。大德迦叶。一切诸法若如是者。云何迦叶。而作是言。汝已供养无量诸佛。满足无量无边功德。何故不成阿耨多罗三藐三菩提。尔时会中。诸菩萨摩诃萨。比丘比丘尼优婆塞优婆夷。释提桓因四天王梵天王等一切大众。作如是念。如来世尊。应除我等疑惑心故。随我心信。应与萨遮善男子授阿耨多罗三藐三菩提记。于几所时。当成阿耨多罗三藐三菩提。于何等劫。何等世界。何等国。何等姓。何等家。何等眷属。云何出家。何等树下成阿耨多罗三藐三菩提。成阿耨多罗三藐三菩提已。佛名何等。几时住世。几众集会。尔时世尊。知彼众会诸菩萨摩诃萨比丘比丘尼优婆塞优婆夷释提桓因四天王梵天王等心之所念诸觉观已。告文殊师利法王子言。文殊师利。此萨遮善男子。过此贤劫。复过无量无数劫已。当成阿耨多罗三藐三菩提。佛名实慧幢王。世界名善观名称。彼世界中无诸怨敌。文殊师利。彼善观名称世界。庄严希有殊特极妙可乐。其地七宝间错庄严。城郭周匝七宝墙障百千万重。其中复有七百千万。重大香水海。周匝围绕。七百千万大毗琉璃摩尼宝珠。以为门阙。十百千万阎浮檀金。以为罗网遍覆世界。十百千万摩尼宝。间错其阙。悬十百千万师子爱摩尼宝。遍诸宫殿以为严饰。十百千万师子幢摩尼宝。庄严街道。十百千万火幢摩尼宝。日夜常然普照世界。十百千万七宝和铃。常出妙声遍诸世界。竖十百千万摩尼宝高幢。普遍世界。悬十百千万金幡。置在高幢。文殊师利。彼善观名称世界。地平如掌宝树普覆。诸草柔软右旋婉转。如善巧画。如孔雀项毛。其触柔软。如迦陵伽鸟。遍覆世界。十百千万妙庄严园。普遍世界。一一园中。十百千万诸大宝池。普遍庄严。一一池皆八道侧方。八楞摩尼宝以为间错。阎浮檀金沙遍布其底。一一池中。皆各满足八味香水。七宝钵头摩花以覆水上。昆仑遮鸟耆婆耆婆鸟。常出妙声遍诸世界。文殊师利。彼善观世界。有八千万城邑聚落。遍满国土以为庄严。一大城中。有十百千万小城以为庄严。一切城邑皆亦如是。一一城邑一一聚落。满百千万男子女人童男童女。文殊师利。彼善观名称世界中。有一四天下。名曰见者欢喜世界。诸四天下。此最胜妙。人民炽盛安隐快乐。实慧幢王如来应正遍知。彼世界中出现于世。文殊师利。彼实慧幢王如来。生在婆罗门家。母名速行。如我现世母名摩耶。父名梵才。如我现世父名白净王。儿名名称。如我现世。子罗睺罗。妻名大慧。如我现世释种瞿夷。乳母名大称。如我现世摩诃波阇波提瞿昙弥。奉侍人名常随顺。如我现世阐陀迦。马名大速。如我现世马王揵陟。实慧幢王如来。乘彼大速踰城出家。如我现世所乘揵陟马王出家。彼佛道场名曰法尚。实慧幢王如来。于彼道场成阿耨多罗三藐三菩提。如我现在寂灭道场。彼道场树。有八十万百千万亿树。以为眷属。文殊师利。实慧幢王如来。于彼劫中出世之时。无诸魔怨及魔眷属。文殊师利。彼实慧幢王如来。成阿耨多罗三藐三菩提时。彼世界中所有众生。一切执持种种华香涂香末香散香。作诸种种伎乐歌舞。一时往诣法尚道场。乃至阿迦尼吒天一切天众。作诸种种天妙伎乐。集彼道场。一切夜叉众作诸伎乐。集彼道场。彼世界中所有一切乾闼婆众。一切阿修罗众。一切迦楼罗众。一切紧那罗众。一切摩睺罗伽众。各作百千万种伎乐。与其眷属集会道场。东方南方西方北方四维上下。无量无边世界菩萨俱来集会。文殊师利。实慧幢王如来初成正觉。为彼时会所集大众。说此菩萨行方便境界奋迅大法门。有无量百千万亿那由他修多罗。以为眷属。文殊师利。彼实慧幢王如来说此法门时。恒河沙等众生。得不退转阿耨多罗三藐三菩提。文殊师利。彼实慧幢王如来出世。不说三乘教化之法。何以故。彼佛国土。无诸声闻辟支佛人。彼世界中所有众生。皆信一乘。皆信菩萨上妙胜行。文殊师利。彼实慧幢王如来。初集会时。有诸无量恒河沙等不退菩萨。而来集会。第二会时。有八十亿百千万那由他一生补处菩萨。而来集会。第三会时。有六十频婆罗菩萨。而来集会。文殊师利。次于后时。无量无边众生。得不退转阿耨多罗三藐三菩提心。文殊师利。彼实慧幢王如来。得阿耨多罗三藐三菩提已。六十小劫住世说法。后入涅槃。佛涅槃后。正法住世。八十万亿百千亿那由他劫。正法流行教化众生。人众多少所得利益。如佛在世所度不异。文殊师利。彼实慧幢王如来临涅槃时。与大幢王菩萨授记。然后入般涅槃。作如是言。大幢王菩萨。次我后成阿耨多罗三藐三菩提。名大庄严如来应正遍知。尔时大众。欲知众中何者是彼大幢王菩萨。次彼实慧幢王如来后。成阿耨多罗三藐三菩提。何者名大庄严如来应正遍知。尔时世尊。知彼时众觉观心念。知心念已。告文殊师利法王子言。文殊师利。此萨遮善男子坐前坐者。名实喜摩那婆。于一切弟子众中最为第一。此摩那婆。于彼时中。成大庄严如来应正遍知。彼佛世界庄严胜妙。如实慧幢王如来世界不异。尔时会中。闻说彼佛国土胜妙功德庄严。彼六十百千万亿那由他菩萨。愿生彼国。作如是言。此实慧幢王如来成佛之时。愿我往生彼佛国土。尔时世尊。即与授记。皆当往生彼佛国土。八十千万尼干子众。一时同声白言。世尊。我亦愿往生彼佛国。世尊亦即皆与授记。汝善男子。一切皆当生彼佛国。八千万亿那由他天子。虚空界中作如是言。世尊。我等亦愿实慧幢王如来得菩提时。俱往生彼善观名称世界。得见彼佛不可思议功德庄严清净国土。时佛即告彼诸天子。诸善男子。汝等皆当生彼善观名称世界。供养彼佛。诸天子。汝等亦当在彼善观名称世界。皆成阿耨多罗三藐三菩提。种种名字。寿命住世。劫数多少。如彼实慧幢王如来住世不异。彼时三千大千世界六种振动。大地涌出百千万亿钵头摩花。阎浮檀金为叶。大青因陀罗摩尼宝以为其台。玛瑙日光宝为须。大毗琉璃摩尼宝以为其茎。彼诸一切钵头摩花。一一花上。见有无量百千万亿诸菩萨众结跏趺坐。三十二相八十种好庄严其身。一切皆共归命如来。彼诸菩萨各以种种宝云罗网。奉施如来作如是言。世尊。我等种种世界。来诣佛所。为闻佛说不可思议示现菩萨功德法门。为见如来礼拜如来供养如来。为见萨遮大善男子。为欲见此大会所有诸菩萨众

如来说此妙法门时。于不可思议佛国土中。无量无边诸来菩萨。皆得不退阿耨多罗三藐三菩提。尔时世尊。欲重宣此义。而说偈言

  一心摄诸根　　听我说妙法
  如来无妄语　　诸佛不虚说
  萨遮及大众　　未来无量世
  过不可数劫　　无刺净劫中
  尔乃得成佛　　号宝慧幢王
  时世无垢害　　故名无刺劫
  时彼佛世界　　号善观名称
  具足诸功德　　天人皆叹仰
  国界诸庄严　　一切皆殊妙
  门阙诸楼阁　　百千诸宝成
  阎浮金罗网　　遍覆相映发
  光明常普照　　昼夜无差别
  悬诸百千宝　　建立师子幢
  宝铃出妙声　　说于如实法
  无垢宝垣墙　　过诸天宫殿
  泉流诸池水　　具足八美味
  钵头摩诸花　　拘迦那陀等
  鲜明满诸池　　不杂诸尘垢
  彼世界住处　　四天下中最
  具足妙庄严　　是故名乐见
  彼处如来生　　婆罗门出家
  母名曰速行　　父字名梵才
  子名曰妙称　　如我罗睺罗
  彼夫人大慧　　如我今瞿夷
  乳母大名称　　如我波阇提
  给侍名随顺　　亦名阐尼迦
  如我阐尼迦　　恭敬随我心
  第一最胜马　　字名曰大速
  彼能出如来　　如我乘揵陟
  彼佛菩提树　　字名曰法尚
  胜树为眷属　　八十百千万
  彼树下法王　　字名实惠佛
  坐彼道树下　　成于大菩提
  无诸魔眷属　　亦无诸魔业
  彼佛国土中　　无有诸怨刺
  无量诸天人　　俱集彼净土
  各执妙花鬘　　百千诸伎乐
  各以恭敬心　　俱诣如来所
  如来知彼心　　为说诸妙法
  无量修多罗　　以为诸眷属
  彼佛初集时　　闻此法门者
  过恒沙尘众　　不退之菩提
  彼无声闻乘　　及无辟支佛
  诸勇猛菩萨　　充满彼净土
  第二时会中　　有诸菩萨众
  八十那由他　　一生住补处
  第三会所集　　诸大胜菩萨
  六十频婆罗　　住于如实处
  彼如来住世　　寿命六十劫
  时佛灭度后　　法灯住世间
  舍利广流布　　八十亿万千
  那由他劫住　　利益诸众生
  彼佛记大幢　　然后入涅槃
  佛名大庄严　　名称显世间
  彼世界庄严　　不异实慧佛
  于彼国土中　　成无垢菩提
  汝等当信我　　智慧如虚空
  无尽性常住　　遍处无障碍
  悉能见未来　　未有当有事
  何况过去劫　　曾有而不记
  我住第一义　　如实智慧中
  出言无虚妄　　亦不令他说
  我今说真实　　美妙甘露法
  是故汝大众　　闻应谛信受
  大众闻佛说　　皆生欢喜心
  彼佛成道时　　咸愿生彼国
  世尊悉记彼　　无量诸众生
  彼佛出于世　　汝等皆往生
  汝等彼世界　　教化诸众生
  即彼成菩提　　世界亦不异
  说此法门时　　大地六种动
  莲花中菩萨　　合掌向佛言
  善哉佛世尊　　不可得思议
  为诸无量众　　善说此法门
  我等诸大众　　无量世界来
  皆为欲闻此　　最上妙法轮

    大萨遮尼干子所说经信功德品第十二

尔时会中一切大众皆大欢喜踊跃。各各脱身所著上衣。奉施如来。而作是言。如来世尊。今于世间第二转法轮。如来昔于波罗捺城。初转法轮。今复于此郁阇延城。第二转法轮。复作是言。世尊。我等愿常不离闻此妙宝法门。愿常不离萨遮善男子。时虚空中。诸天伎乐妙鼓出声。天雨忧钵罗花。钵头摩花。拘牟头花。分陀利花。婆师迦花等。满佛足下。天于空中。满天宝衣如云而下。而作是言。若有善男子善女人。有能受持读诵书写为人解说此妙法门。彼人决定。已得无量无边功德。尔时文殊师利法王子菩萨白佛言。世尊。善男子善女人。有能受持读诵书写广为人说此妙法门。成就几许功德。佛告文殊师利法王子言。文殊师利。若有善男子善女人。数此三千大千世界众生。若有色若无色。若有想若无想。于众生界中所有众生。佛智慧知彼诸一切所有众生。一时俱生得于人身。得人身已。彼共俱修波罗蜜行。一时俱成阿耨多罗三藐三菩提。彼诸佛等一劫住世。有善男子善女人。满足一劫。供养尔所诸佛如来。礼拜恭敬尊重赞叹。具足一切诸胜供养。乃至一切花香伎乐。文殊师利。于意云何。彼善男子善女人得福多不。文殊师利言。甚多婆伽婆。甚多修伽陀。彼善男子善女人。所得功德无量无边。不可量不可数。不可知不可说。佛告文殊师利。若有善男子善女人。受持读诵书写流布为人广说此菩萨行方便功德法门。所得功德。过彼善男子善女人供养诸佛功德。无量无边不可称数不可挍量。文殊师利白佛言。世尊。希有婆伽婆。希有修伽陀。如来为欲安乐一切诸众生故。说此法门。复作是言。世尊。此妙法门。于阎浮提几时住世。佛告文殊师利。我涅槃时。有八大国王。为欲流布我舍利故。彼时八国分为八分。置八函中。人取一函。各还本国。立大塔庙尊重供养

尔时阿阇世王。于我舍利所得一分。于金叠上书此修多罗。并与舍利。一切俱置七宝函中。于王舍大城外。掘地作坑。于中立塔。庄严殊妙。以舍利函置彼塔中。悬百千万阿僧祇宝盖幢幡。散诸无价一切香花。七宝香瓮盛满香油。然大灯炷。满一百年住持不灭。文殊师利。我入涅槃一百年后。有阿输迦王。于毛梨家生出现于世。作转轮王王阎浮提。而得自在得具足力。善能降伏刚强众生。彼王尔时。必观察我。能忆念我。护持我法。于我身上得尊重心。文殊师利。彼阿输迦王。有一比丘。名净自在。王子中生。出家求道。阿输迦王。以为门师。有大神通力。有大威德力。护诸佛法护大方广。阿输迦王。深心尊重净自在比丘故。不令余处。常在王家身自供养。文殊师利。阿输迦王。为欲流布我身舍利。饶益一切诸众生故。欲出地下舍利宝函。与诸无量大臣王子长者居士眷属围绕。设大庄严显大王力。执持香花涂香末香散香。作百千种诸妙伎乐。诣王舍大城。设诸一切胜妙供养。无量无边不可称数。掘出地中舍利宝函。出已七日。以一切香一切花。一切花鬘。一切散香。一切涂香。一切伎乐。供养恭敬。满七日已。于阎浮提种种国土。非前后时。于一日一时一须臾间。遍阎浮提。一时建立八万四千佛舍利塔。尔时净自在比丘。于彼舍利函中。取此法门在于北厢。大国土中广宣流布。文殊师利。彼净自在比丘。虽加流布。而此法门受持者少。多人不知。多人不觉。多人不摄。多人不受。希有人能受持读诵此法门者。何以故。此是胜法。众生薄福不应闻故。文殊师利。此妙法门。人多秘掌。置经函中诸库藏中。何以故。以无法器不应得种无上善根故。何以故。文殊师利。此妙法门。难信难行难量故。文殊师利。凡所有人。宿无善根。曾闻大乘生疑毁谤。是故闻此无上法门。不能生信不能得入。文殊师利。后末世中法欲灭时。闻此法门。能生信者。能推求者。能解入者。文殊师利。汝知此人已曾供养过去无量无边诸佛。善行诸行乃能信入此大乘门。文殊师利。若有善男子善女人。于后末世。闻此经名。闻能生信。受持读诵书写解说。书已尊重供养经卷。彼诸众生。应自念知。已于过去。曾见无量恒沙诸佛。供养恭敬恒沙诸佛。文殊师利。彼诸众生。亦见我身在此园中说此法门。亦见此诸大会之众。尔时世尊告阿难言。阿难。汝当受持读诵此妙法门。为诸众生而广宣说。当观众生有大乘根堪信受者。乃可为说。不得率尔不观而说。何以故。薄福众生。闻生不信。得罪无量故。阿难。此法门者。名为如来真实功德。名为如来秘密之藏。名为如来纯净妙藏。名为如来法印之藏。名为如来心所护藏。名为如来现实信藏。是故阿难。汝当秘掌。莫卒宣说。除诸佛子菩萨摩诃萨等。何以故。彼善男子。于诸佛所深种善根。能护法藏。能利自己。亦能利他。应为彼说。阿难言。世尊。我已受此净妙法门。世尊。今此法门。名为何等。云何奉持。佛告阿难。此妙法门。名为菩萨行方便境界奋迅法门。名为如来深秘密藏。名为如来具足功德。名为如来甚深境界。名为一乘。名为文殊师利所说经。名为萨遮尼干子授记经。名为萨遮尼干子所说经。汝今应当如是奉持。如来说此法门时。三十亿那由他众生。发阿耨多罗三藐三菩提心。六十千菩萨。得无生忍。无量无边众生。毕竟不退阿耨多罗三藐三菩提心。佛说此经已。慧命阿难。文殊师利法王子菩萨。及诸一切菩萨摩诃萨。比丘比丘尼。优婆塞优婆夷。释提桓因。四天王。梵天王。天人阿修罗等。闻佛所说。皆大欢喜。信受奉行

大萨遮尼干子经卷第十


佛说阿惟越致遮经

    No. 266 [Nos. 267, 268]

佛说阿惟越致遮经卷上

        西晋月氏三藏竺法护译

    不退转法轮品第一

闻如是一时。佛游舍卫祇树给孤独园。与大比丘众千二百五十人俱。彼时世尊。于后夜起三昧正受。号离垢光。文殊师利童子菩萨。亦以普明三昧。弥勒菩萨导众大士普显三昧。于是贤者舍利弗。后夜寤起自出其室。发心往诣文殊师利。欲入其室。未入之顷。见佛神室则前进矣。睹十万莲华不可称计围绕佛屋。又复遥闻大音乐声若干种响。其大莲华自然衍光。遍照祇树。悉周舍卫靡不见焉。三千大千佛之境界光耀巍巍。时舍利弗。即立不行。抑而不候文殊师利。不自觉耳处于其室。住文殊师利前。睹加趺坐淡然而定。时舍利弗。即为弹指永不寤矣。声发洪音亦不兴也。又一心观文殊师利。现大变化感动如此。自察其身在于大海。愕然欲出文殊师利三昧之室了不能退。将以神足起踊于空。亦复碍矣。尽现神力不得游腾。又见己身。与文殊师利及其室宇。自然东行。时舍利弗。立文殊师利前。结加趺坐视之无厌。尔时东方度是佛土。恒沙等刹。其世界名不退转音。佛号最选光明莲华开剖。贤者舍利弗从文殊师利见彼圣尊。一切毛孔悉出莲华。又其莲华各周四十万里皆照三千大千佛土。彼诸莲华。有十万数妙宝为茎。及以金刚紫磨黄金师子之座。一切菩萨皆坐其上。于无上正真之道不退转。以得总持五通自乐成就法忍。三十二相庄严其身。最选光明莲华开剖如来至真等正觉。齐生莲华清净无瑕。其色百千不可称数。青琉璃茎姝妙交络。上好栴檀珍宝为座。殊异珠铃垂布四面。彼座独空。文殊师利即处于上。与其莲华师子之座。踊变上至三十三天。寻还诣佛稽首作礼。绕佛三匝还坐莲华。彼世尊前叉手自归。于是最选光明莲华开剖如来等正觉问文殊师利仁者。何来枉至此土。文殊师利答曰。唯然世尊。从忍界来。尔时彼佛侍者。号柔音软响菩萨大士。志于无上正真之道逮不退转。则莲华上更整衣服。长跪叉手问彼佛曰。其斯忍土离是几何其佛告曰。西方去此恒沙等刹。有忍世界。是文殊师利从彼土来。柔音软响菩萨又问佛言。其忍世界佛号云何。今现在乎。世尊告言。字曰能仁如来至真等正觉。现在讲法。又问佛言。其佛大圣云何现法。佛言。开三道教。侍者又问。何谓为三。声闻缘觉及弘佛道。释迦文佛说法如此是三道教。侍者又问诸佛世尊说经开化不普等乎。佛言悉等柔音软响。又问佛言。何谓为等。世尊告曰讲不退转。此谓平等。又问何故。能仁如来至真等正觉宣三道教。其佛告言。彼土人民刚强难化。心劣意弱。难以一乘救化度矣以是之故。诸佛世尊善权方便而为说法。能仁如来兴五浊世。以斯善权随时之义而济度之。又复问曰。唯然世尊。彼忍世界讲法所化勤劳之难。乃如是乎。佛言实然。有勤危患。侍者复问。我等世尊。快哉善利。不生彼土。佛言且止。无得说此。宜当舍之。自改悔过。又问何故改往修来而忍世界讲法甚难。以故吾等不愿彼土。世尊答曰。诸贤莫念。重说此辞。当自改过。所以者何。于是佛土。修二十亿那术百千劫殖众德本。不如忍界从明至食。为人讲说度无极法。开化愚冥归命三宝。令受五戒。释于声闻缘觉之道。是菩萨大士甚难于彼。何况诲之使为沙门。捐俗近道以法将护。劝助导示善法之义。或复昌显立之大道。此为菩萨大士难及之教。所以者何。其忍世界多有患难。又问何患。世尊答曰。柔音软响。使贤者身寿。于那术亿百千劫闻受无数诸佛国土本命极长。不可穷究。共计忍界怀淫怒痴无量恶法而不可尽。今吾口说彼人罪福因缘所著。又以佛慧了了分别。其忍世界瑕秽之垢。未央可竟。尔时柔音软响菩萨大士。三反扬声而叹颂曰。妙哉能仁如来。最慈师子人中之王。道德巍巍无所挂碍。念世尊明肃然恭敬。因本功德其意之愿。而为众生乃忍劳谦讲说道义。除淫怒痴无量蹇法。教发声闻缘觉之心。开化以渐使逮佛圣。显道深慧用一切故游众德本。志无荣冀。诸菩萨等取七宝华。其色光耀。无数百千清净无埃。又无量叶生金刚茎。其华之藕上犹交露。微妙栴檀众宝合成。璎珞分布而为庄严。心达眼明宿之本德。所发兴化现雅圣行。犹如幻化。欣悦盛意踊在虚空。手执此华。遥向释迦文如来至真等正觉。顾彼忍界一心散华。如雨宝盖缯彩幢幡。秉志供养能仁如来。已散众香。而烧栴檀杂香捣香。自于彼土五心投地。西向稽首应时赞曰。南无能仁佛等正觉。及彼忍界菩萨大士。无极德铠志于精进。意无慢恣德备巍巍。其心究竟极尊圣妙。奉于正法以法为力慈愍众生。而奋大光等习一乘。异口同音俱共叹曰。愿欲奉觐能仁如来至真等正觉及诸菩萨。佛之教训令不断绝。于是最选光明莲华开剖如来。闻诸菩萨歌颂之声。察其心源为诸菩萨大士衍以佛法。分别要义令心悦豫。告菩萨言。诸族姓子。汝等宁睹能仁无著正觉及忍世界诸菩萨学人民之处。修彼佛教顺化众生。欲度危厄。志怀慈愍。于深妙法未尝恐惧不以为难。未尝谤讪殖众德本。心无所著不望想报。奉于六度无极之行。菩萨大士生忍世界。即崇能仁如来宿之本愿。遵奉正法以道为力。觉诸佛行。菩萨答曰。唯然世尊。承佛圣旨普悉见矣。又去来现在诸佛之慈恩也。永无疑网。最选光明莲华开剖如来等正觉。告柔音软响菩萨。汝等当与文殊师利俱至忍界。奉修训诲使心[火*霍]然。柔音软响菩萨白文殊师利。吾等欲诣能仁如来观忍世界。承仁圣慧令愿得果。文殊答曰。快哉行矣。众族姓子。诸佛世尊难见难遇。所以者何。亿世时有。当共佥然供养奉事。所以出世于十方界。矜愍众生化入大道令逮觉慧。当为一切蚑行喘息人物之类。供顺修礼诸佛世尊咨问经典。令十方人获致上庆。菩萨答曰。令吾等身与尊者俱。奉见诸佛归命启受。习学圣智慈化群黎

于是文殊师利。稽首礼彼最选光明莲华开剖如来至真等正觉。绕其三匝。与诸菩萨恭肃敬意。及舍利弗。闻佛说法受其教令视佛无厌。观身五事若如幻。各以华香栴檀杂香捣香缯彩幢幡以供养佛。蒙佛本德心坚意固。遵奉三宝。欲度众生奉侍佛焉。说此适竟。如伸臂顷忽然不现。则至东方恒沙等刹佛世尊前。皆听诸佛等衍是经。讲不退转方等无垢清净之明。彼诸佛土悉无女人。亦无声闻缘觉佛教。一切佛土德义悉等鲜洁之命。犹如最选光明莲华开剖如来佛土等无差特。菩萨道场充满佛国。彼诸世尊莲花皆同出其脐中文殊师利普如座上感动变化。威仪如一供养诸佛东方南方西方北方东南西南西北东北上方下方。时于十方各如恒沙诸佛之土。文殊师利悉现其前无不周遍彼诸如来尽悉讲是不退转轮方等无瑕。一切侍者恭敬肃肃。志存大道。在莲华上长跪叉手。自问其佛。能仁如来何故兴此三道之教。悉欲往诣能仁如来咨启法化。从文殊师利求恩见济。十方亦告诸菩萨曰。汝等侍卫文殊师利。俱至能仁如来佛土。于是忍界阎浮提处。夜尚未明。贤者阿难。时见光明从轩窗入。即从卧起欲出精舍。睹其祇洹光耀如昼。仰观虚空亦不见月。察其祇树但睹其水。青青如璧柔软且清。了不复见树木房室。心自念言。今日旦当讲大深法。以故先现此之瑞应。于时阿难。举足入水水不着足。无所湿溺欣然大悦。往诣神室欲见世尊。见千万莲华绕佛神室。又闻洪音作若干伎。莲华出光照于祇洹及舍卫城。三千大千世界靡不明达。志怀欣豫。偏袒右肩长跪叉手稽首作礼自归于佛。明星出时夜以向晓。诸大莲华绕佛室者。大莲华入于祇洹正住于中。阿难心念。今吾宜往为佛施座。此则说法本之瑞应。适布座竟。寻时三千大千世界六反震动十方佛土各十恒沙亦复如是。大意咸达莫不惊欣青莲华红莲华黄莲华白莲华。普遍佛国。自然生树。枝叶华实亦以茂盛。诸比丘众各欲出屋不能自致。见祇树园为水所溺水软且清。住精舍户惟见大光。各心念言。今日当说大微妙法以故先现此之变应。彼时世尊能仁大圣。从三昧兴出其神室。就师子座佛身适坐。应时十方一切世界诸佛世尊。身奋大光色色各异不可称计。于彼黎民莫不睹焉。于是文殊师利周于十方。与众菩萨游诸佛土普供养遍。是大菩萨导众大士。神足示现不可思议救利萌类。持顺佛法教化度脱。随众所乐而以开导。为十方人各说法竟。文殊师利见能仁如来坐师子床。诸菩萨俱于祇树园从地踊出。与无央数亿亿百千那术兆垓一切菩萨。绕佛世尊无量之匝。各化莲华不可称计。有十万叶其色各异以供养佛。是诸莲华布佛境界无空缺处。又此菩萨散栴檀香杂香捣香妙香。其香悉熏三千大千之国土。皆兴美香。布施遵戒忍辱精进一心智慧。善权方便神通之香。分流法香。六度无极菩萨微妙道慧之香。具足经义修行之香。是辈众香尽衍大光。其明周遍十方佛前。勇猛意强承佛威化。供养能仁如来至真等正觉。过大精进勤修正道。其心坚固莫能踰者。归命如来。时文殊师利与诸菩萨一切众生。庄严如意摩尼。现众宝树八品行行。有名宝树边竖幡。交露珠帐紫磨黄金。而以校成明月珠地。化造屋室讲堂楼阁。天窗轩牖刻镂笼疏。泉源陂池江河之流。苑囿泉水中生莲华。青红黄白叶皆明珠无不周遍。地出甘露有八味水。欲悦众生示现大道发菩萨意之所当行。故为一切垂哀变化。文殊师利承佛圣旨。顺己道力。能仁如来本之所愿。故以此变开化众生。柔音软响菩萨等俱多所劝助。不可思议无心不心。善心思唱导被大德铠。顺其精进身行高德。昔心所志庄严虚空。一切毕竟皆住佛前。于是世尊游以道教。放法光明照文殊师利。及诸菩萨大士之等使有床座。应时自然十万莲华从佛身出光色无数不可称限。百千显耀而独照明。以宝为茎。珍宝之珠遍垂周匝。摩尼交露栴檀杂香师子之座。是诸菩萨大士之众。皆坐其上处于虚空。时能仁佛。脐中有光。号曰金刚。又名救济众生之类。而放此明。亿百千莲华光曜各异。无能计量莲华光明。清净微妙紫磨金色。交露之帐甚香鲜洁。显照十方无所挂碍。此莲华中自然化出亿千莲华。一切诸佛皆受法界平等一类。训诲众生起度脱门。及言教声空无思想。不愿之法无有邪行。不起不灭三世等空。其目清净自然轨迹。化出亿千名宝莲华。文殊师利安详雅步。其心寂然则坐其上。不着佛身佛体无想。心念世尊觉了一切。所志三昧号踰金刚。而学能仁如来至真等正觉之法。则行越空无不慕三昧

于是世尊见文殊师利。及十方佛国菩萨大士坐讫悉定。修诸佛法供养过去无数大圣。文殊师利所见摄持心不怯弱。顺佛道行处师子座。时佛则告贤者阿难。汝去遍令舍卫祇树园中内外。比丘比丘尼清信士清信女。信乐三宝佛众僧。殖诸德本行欲向城。悉使来集今当说法。阿难。受教遍行宣命。比丘对曰。吾等今夜见大瑞应。即时察知当讲大法衍深要事。欲得往会不能自致。时阿难问。何所妨碍。答曰。皆见祇树为水所溺。水青如璧柔软且清。不见树木。屋室悉没。惟见大光。以此之故不能自致。于是阿难。具以启佛。佛告阿难。此比丘等闭隔不解。都无有水横造水想。如此比丘无水谓有。不但齐是心意不开。无色痛痒思想生死之识。反谓有矣。不持信谓持。不奉法想奉。未致八等心想获矣。道迹往来不还无著之道亦复然矣。不成声闻心念办矣。不了缘觉心想致矣。汝复更往重告来会。阿难。受敕一一令语如世尊教。还白佛言。今四部众皆来集会

于是世尊。告贤者目连。汝至三千大千世界。悉呼深学菩萨大士。被无极铠志求大乘。比丘比丘尼。清信士清信女。天龙鬼佛犍沓和阿须伦迦留罗真陀罗摩睺勒人与非人。使知今日有大法会未闻之要。四部弟子人与非人。或在天上或处世间。皆以奉敬过去诸佛。志于大乘学住一道。心慕大慧妙尊最上巍巍无极。菩萨大士被巨德铠。求利法义精进不废。悉使来会听深妙法。目连受教承佛圣旨。自以道力如申臂顷。遍三千大千世界宣告。如是有未尝法当共普听。寻以神足还住佛前。白世尊曰。宣告已周。尔时四辈围绕充满四十万里。诸天龙神住于虚空。五十万里无空缺处

尔时文殊师利白世尊曰。今四辈人悉来聚会。诸天龙神填于虚空。悉共一心叉手礼佛。皆观如来威神之变。光耀暐晔靡不通达。众会坐定恭敬恭肃愿佛说法。于时世尊即寻欣笑。七宝莲华从地踊出。莲华之叶有无央数百千交露之帐。如大高车超天帝座。垂明月珠赤珠璎珞众珍为幢。向于八方欲济八难。一切众会四辈弟子比丘比丘尼清信士清信女。诸天龙神犍沓和等人与非人。悉坐其上普察尊颜。文殊师利所从菩萨大士之等。相好具足威神巍巍志同一类。在莲华上一心叉手。恭敬元元察佛圣德。及文殊师利志求大道。于是文殊师利前白佛言。今四辈众诸天龙神咸皆渴仰。愿佛赞说不退转轮离垢之法。此比丘比丘尼清信士清信女。诸天龙神无央数千。怀笃信想奉法之想。志八等想道迹往来。不还无著声闻缘觉各兴此想。是故世尊蠲除此念。何故如来光于持信至于奉法显缘觉行。于是世尊默然不应。舍利弗白佛言。唯然大圣。吾于后夜寤起出屋。诣文殊师利。睹世尊室则欲进前。见十万莲华绕如来室。出大光明照于祇树舍卫国城。及三千大千刹土。闻洪法音伎乐之声。惟佛解说此何感应。佛言。今当讲此不退转轮。文殊师利俱共分别是之本瑞。阿难白佛。今于后夜见大光明从轩窗入寤。从坐起出见祇洹。为水所溺水软且清。不见树木及与精舍。但见大光此何感应。佛言。今文殊师利。当说深法不退转轮是之本瑞。于是世尊。为贤者阿难说颂曰

  此诸佛不我　　一乘而无上
  其软音勇猛　　因缘兴问斯
  是乘则清净　　佛道无有上
  普柔音勇猛　　今所兴问斯
  此乘无想念　　清净离调戏
  普软音勇猛　　今所兴问斯
  普软音所问　　救济一切乘
  非处无所成　　不起亦不灭
  一切所咨嗟　　此不成道果
  世尊为本无　　此教则成实
  普软音勇猛　　今所兴问此
  于此离响者　　一切声平等
  普软音所问　　因动而有声
  其声不可获　　法无响无字
  普软音所问　　法声等如风
  离形无所立　　欲令度响着
  阿难且听是　　普音之所问
  道正法时身　　涂想亦复空
  诸佛等正觉　　空寂无有相
  说设若不说　　一切法无住
  平等觉无色　　道迹之所趣
  获来不还反　　此佛所说法
  离形远众相　　如虚空无数
  佛道如不着　　此为普音闻
  过去当来佛　　于今亦复然
  为现道慧意　　未尝见有涂
  不可睹法界　　但以音声耳
  分别经本无　　此法乃为道
  布施度无极　　净戒亦复然
  忍辱度无极　　此说现佛道
  精进度无极　　一心亦俱然
  智慧度无极　　现道之慧明
  佛善权方便　　神通度彼岸
  假声讲佛道　　于俗无所著
  为现三乘教　　宣扬说果声
  导师之所讲　　随顺察本性
  吾兴五浊世　　知劣懈废人
  故为佛乘者　　使人成大圣
  吾现四果音　　已成无著道
  因音谓声闻　　诸法无缘会
  所谓众合会　　教皆有所立
  现在获因缘　　故说目前法
  罗汉谓声闻　　因观成缘觉
  永不起法忍　　菩萨之所睹
  其空无有想　　平等禅不愿
  三脱之门音　　以故说泥洹
  不着于往古　　来现在亦然
  十方之所兴　　不起无所有
  普音今所问　　法深妙无量
  逮力之至诚　　不废致果想
  以专于一乘　　不想一切法
  故启问于佛　　德果之缘念
  此三世平等　　空寂而无想
  已度一切音　　不猗着佛道
  犹如有二十　　江水之流沙
  菩萨数如此　　普音之所化
  从诸佛听采　　菩萨所修行
  三涂适平等　　赞扬入大乘
  普音志勇猛　　为决除众网
  兴着生德果　　故问吾道惠
  此佛所建立　　修愿亦如是
  游演三乘等　　以济勤苦患
  普音志勇猛　　因为此等造
  启道师讲法　　示菩萨道行
  诸天亿百千　　处空供养佛
  志好于德果　　欲决此犹豫
  其四辈比丘　　比丘尼居士
  想着于德果　　故分别令解
  普柔是以问　　拔除诸疑网
  此诸菩萨会　　犹欲采此法

    阿惟越致遮经持信品第二

于是世尊说此偈已。贤者阿难前问佛言。唯然大圣。文殊师利今问如来不退转轮乎。告曰如是。乃当讲说不退转轮耶。佛言。阿难。诸佛世尊因不退转为应说法。阿难又问。最胜何缘转持笃信至于缘觉。如来惟显菩萨法乎。答曰。如此阿难当知。惟畅菩萨经典为上。所以者何。吾身故兴五浊世。用懈废者志怀羸劣。诸佛当以善权方便。随时之宜讲说经道。少有志乐微妙之训多慕卑劣。是以如来善权方便而为现法。开演大乘乃应本要。是以观心顺所发意而救度之。志若得入调柔安隐。无所造立苦乐得除。诱无从生不起不灭无为之安。渐向大慧一切之智。于是世尊默而不语也

尔时阿难问文殊师利。如来何故默而不言。答曰。俗人少有信此法说。此诸罗汉无数百千心中愕然不解。如来何故说此殊异经教。吾今目睹此四辈人心鬲狐疑。曷因如来演处。持信至于奉法缘觉有碍欲令进达此。无数亿诸天龙神咸共犹豫。何因如来显叙。菩萨道迹往来不还无著缘觉之道。无量菩萨亿百千垓不了。世尊。以菩萨道叹咏执信至于奉法四果缘觉。一切江河川流泉源窒不通行。飞鸟在空不能进退。日月不前翳无光耀黯黮昼昏。所以者何。此法微妙难解如此。是故如来默然不言。彼时十万莲华绕佛室者。一切同声咸共劝助。唯然世尊。讲不退轮清净方等经典之要。吾等常从九十二亿百千垓佛闻此经慧。于斯佛土弘修是法。时舍利弗复前求哀。惟愿大圣演不退轮。吾今后夜与文殊师利俱游。等至十方无数佛土。闻诸佛世尊说是妙法。于时虚空中八十五亿百千垓天自归请求。欲令如来说不退轮。吾等此土从九十二亿百千垓佛咨受此法。贤者阿难复白佛言。惟愿加哀说不退轮。何因世尊咨嗟笃信奉法之义至于缘觉。此四辈人静然无声。欲听世尊分别说之。今无央数百千之众闭结不解。何故世尊。光显菩萨持信奉法至于缘觉。当决大疑。惟愿如来。兴隆大哀蠲除所滞。普共证明信此圣道。佛告阿难。如是如来至真等正觉。不释明证而说经道。阿难白佛。何谓明证。众祐答曰。明证经籍及诸听者然后说法。如来法力最明等觉。因其明证而为分别。阿难谛听。善思念之。今为汝了如来所因。光美菩萨持信奉法至于缘觉。于是阿难与诸大众受教而听。佛言。阿难。何因如来赞扬菩萨笃持信乎。于是菩萨开化无量不可计人。使立笃信得睹诸佛。已见大圣不着佛身。色痛痒思想生死识。亦无所慕五阴如空。是谓菩萨执持笃信。又阿难。菩萨信诸法空如来所说等无有异。又阿难。菩萨信成佛慧心自念言。何因致其平夷之智了不见慧之所归趣。如是等观谓持笃信。又菩萨不信五欲获致道力是谓笃信。又菩萨何缘调心分流法施。独逮如来至真等正觉。其心澹然笃于法施。心怀此念是谓持信。又菩萨一切所有皆能惠施。不惜身命劝助于道。不择布恩无所矜吝。一切是福劝助于道。等造空观不见菩萨。如是察正则谓为信。又菩萨笃于佛道而心不荒。好寂寞法攘舍六情。不慕诸种志于圣轨。其不笃道开化立之。令顺佛经劝使兴乐。发大道意不得彼心。而无所著等于法界。何谓知等惟言声矣。等诸四大诸种叵获。有信所作万物无常苦空非身。则致此力信圣戒义。而无放逸清净之禁。定意正受寂灭无为。信一切界悉归空尽。身等无异是则信根。如此等观不舍众生。睹一切人法界同等。则不复见法界所在。所以者何。一切群黎究归法界。假使笃信诸法如此。是谓持信。又菩萨皆信众生。诸有欲贪亦不有受。犹空自然。不见众生之所立居。省视一切蚑行喘息人物之类。悉是泥洹。所以者何。众生空故审实本无。故见众生悉为泥洹。令无数人奉信如此。以是菩萨则谓持信。于是佛颂曰

  开化无数人　　令见无量佛
  于彼无所著　　是则谓持信
  信解一切法　　分别皆为空
  笃乐如此教　　是则谓持信
  志慕于道慧　　心常思于彼
  吾已当因缘　　逮心所志明
  于五乐之欲　　未尝信乐之
  以得此信力　　是则谓持信
  信于奉禁戒　　吾何因逮成
  兴行于法施　　犹如佛大圣
  彼勇猛之士　　心信行布施
  志无所想报　　是则谓持信
  敢有乞求者　　一切等心施
  既兴无施想　　是则谓持信
  好乐于惠与　　一切无贪垢
  皆已向圣道　　是则谓持信
  蠲除于六情　　睹了无所求
  以获得法力　　是则谓持信
  恭肃向于佛　　究竟心鲜洁
  常笃于道法　　是则谓持信
  远舍于六病　　其心无所求
  五阴以永除　　是则谓持信
  若人不如道　　劝化令欣乐
  不疑于佛法　　是则谓持信
  若见欢喜者　　劝导其道意
  自察心不得　　是则谓持信
  慧平等六衰　　法界不差特
  于土无所获　　土界言声耳
  心常思终始　　若空无吾我
  于慧有大力　　是则谓持信
  好修圣禁戒　　清净无放逸
  戒定具足成　　是则谓持信
  好乐寂然界　　众生亦复然
  彼为有至相　　是则谓持信
  不舍一切人　　法界亦如是
  计彼众生种　　经界无思议
  如法界无异　　是信乃为了
  以故叹笃信　　菩萨无所畏
  众生皆自然　　计了无住处
  普了明法空　　彼处不可得
  一切人无为　　其群黎亦空
  此为寂泥洹　　故为一切显
  菩萨若勇猛　　解众生如此
  以故得名号　　称扬于持信
  行笃法如是　　叹之为持信
  阿难当持是　　分别说亦然
  阿难吾因此　　遵行道无余
  是法成等觉　　菩萨演光明

如是阿难。如来至真等正觉。以此之故叹立菩萨。则为持信。计视此义。善权方便而开导之

    阿惟越致遮经奉法品第三

佛告阿难。如来至真等正觉。何因赞扬菩萨奉持法乎。菩萨于此存于佛道而不退转。执持觉轨了了分别不越法界。不可思议逮得经籍。所可总持常处不动。志顺法句质一切疑。诸法自然无所猗着。所可总持不有依立。顺于总持不专经本。志常乐圣钦敬道者。于一切法而无所受。以不受行乃为演说法。志性仁调进止安隐讲寂然经。于此持法不猗不舍。一切自然则圣道相。以获此义未尝越失其身所行。体常坚住世非有处。何谓菩萨常睹察之。未尝见此身安谛住。自顺正法等于境界不去不来。作是解知。诸佛菩萨所可说法。逮得此籍清净无垢。见一切法无合无散。睹诸经典忽然不现。所以不见诸法无为。以故不见。以不见法则无所持。知界虚空则演经籍。诸想自然不有调戏。无形清凉离心无心心不可得。设不可得则为道心。而无去来讲寂然行。不有言说无所慕求。于法如此无依因者。所以不猗不兴法貌。常顺经典是菩萨法。而无所著不生泥洹。彼说此义犹如显致。不慕种姓以获如此舍诸种姓。逮菩萨行无所得法。于诸往返不去不来。一切诸慧无去来今。执信如是不动不摇不退不舍。奉持诸法不急不缓。是谓持法得菩萨道。既得圣行则无所得。以成如是菩萨大士。名曰奉法。佛于是颂曰

  一切诸佛法　　未尝有退转
  奉持经如此　　是则为持法
  讲诸佛佛法　　无想不自然
  甚深不可得　　是则为持法
  未尝毁诸界　　法界无思议
  以得致彼义　　则谓为持法
  奉法殷勤悫　　诸佛之所行
  其心无所著　　则谓为持法
  所执无进退　　一切法自然
  众经无所著　　则谓为持法
  不立于寂灭　　奉持履大迹
  以随顺彼典　　则谓为持法
  道常为法身　　慕求微妙说
  弃捐于懈怠　　是则为持法
  听经则采受　　学思而玩习
  性仁游居安　　是则为持法
  常讲澹然义　　执经而不着
  得致无想行　　是则为持法
  坚心立于道　　明智行无住
  于身常无身　　彼解深如是
  以致于空身　　法界则平等
  无往亦无来　　分别身诸想
  诸佛及菩萨　　所可讲说法
  普逮此经典　　是则为持法
  一切法无为　　彼界甚清净
  以奉此经者　　是则为持法
  广察一切经　　适见便不见
  若不见诸法　　彼则无所持
  是诸界皆空　　则为讲法界
  自然离众想　　无形不调戏
  其心舍诸有　　志亦不可得
  设不能逮心　　此念为最上
  所志无有意　　讲法寂然义
  无言无所著　　是心乃为尊
  以能奉此法　　所兴不有着
  不猗于诸界　　是则为持法
  菩萨所奉法　　如是应经籍
  不依无所举　　示现无有造
  如是行善训　　顺彼诸种姓
  以得是义者　　故赞扬种姓
  以殖于此姓　　谓为菩萨义
  能顺此总持　　是则为持法
  了不见诸法　　一切无所趣
  其若咸驰至　　亦不是彼法
  当为亦无趣　　其解一切法
  分别了总持　　不制不动摇
  非舍无所追　　彼则兴造法
  不举无所下　　总持乐于法
  于诸法无法　　讲说不有着
  不得于诸经　　是则为持法
  阿难吾以故　　开演菩萨行
  逮致微妙道　　是则赞诸法
  阿难吾以故　　歌颂奉法者
  用人想道玄　　开导此等类
  降此无数法　　菩萨之所赞
  善权永安隐　　故叹于此经

佛告阿难。是故如来至真等正觉。赞扬菩萨总持之法。此所现义亦善权方便

    阿惟越致遮经八等品第四

佛告阿难。如来至真等正觉。何故赞扬菩萨八等之义。于此菩萨远于八邪获致脱门。而无所著不猗八正。度凡夫法立于道义。获致中正超于凡俗。愿立道慧不见得涂。出于邪迳常住正观。获平等迹离于贪身。愿住道义逮致佛身。除超人想常思佛教。等心一切远众生着。常处无猗诸法悉断。所以者何。法不可获身所崇力。离世俗籍慕度世典。获定法界不逮道法亦不离俗。释有无义。遵修平夷。舍断着想。去来现在。心念无殊。不得道意。所以者何。等志一切遵修普慧毒火刀杖不能危身。悉舍诸界致于佛土。不离诸道立无去来。道所往来辄弘大安。故曰菩萨涂不有住。所以者何。佛道则空是故无处。以无所住刀不向身。无能害者斯谓获安。适逮此行无学不学亦非所求。不得圣贤志未尝慕。以是之故。刀不能害身无能动摇。一切道遵空分别空慧。刀不能害。用弘大慈愍。于众生得寂定界。逮澹然界。弘施非哀弃捐嗔恚。其行慈者。则发明慧。以慈化世成就大哀。不得人处厥慈具足刀不能伤。等于欲界色界无色界等于法界。平均之界道无若干。不兴识念无有嗔恚。离于调戏寂然无音。法界如此度诸所有。菩萨造行诸可专心。一切音声所至到处法莫有所奉不住终始。群黎所趣但音声耳。所为了了讲法化者。有无说想与其言也。以舍我想度诸音声。越于等邪。逮得是教。解一切法言音声耳。亦不获法。莫有度者。是谓八等。未尝慕着一切音声。佛于是颂曰

  以住于八等　　逮致八解门
  于八无所著　　是谓为八等
  越八凡夫行　　得住于正议
  不睹中间慧　　是谓为八等
  超度俗夫行　　得住于佛道
  于是无所获　　是谓为八等
  远离众邪见　　遵修于正见
  获致平等道　　是谓为八等
  以除于贪己　　而立正圣道
  逮致得佛身　　是谓为八等
  弃捐众生想　　常志修佛行
  平均吾我人　　是谓为八等
  得越众生想　　住于无所处
  诸法尽逝过　　是谓为八等
  捐离于俗法　　奉修圣正教
  而致寂然义　　是谓为八等
  所去为俗法　　佛道亦如是
  于此法无得　　是谓为八等
  言有一本耳　　无有二元际
  蠲除如此念　　是谓为八等
  不处于中间　　无志断着行
  道慧如平一　　是谓为八等
  不得过去心　　当来亦如是
  平夷于现在　　是谓为八等
  始无心所由　　其发道意者
  此心不可获　　何缘如致道
  以入无所著　　如圣无可获
  以故刀与毒　　莫能危之者
  脱离于五道　　众相之所由
  具足于往返　　是故谓无欺
  道舍不周旋　　所言音声耳
  弃除诸响着　　是故不自欺
  不得其所由　　从来亦如斯
  去来惟音身　　但劝于学者
  安化故有言　　其安亦复空
  以应如此学　　故能不自欺
  菩萨所玩习　　了学如此慧
  一切无所断　　是谓不自欺
  彼不自贪己　　设有利刀刃
  不能加害身　　莫有动摇者
  普慈于一切　　乐道之大哀
  捐除恚害心　　利刀莫能加
  设有欲害者　　自计身空无
  而致获佛道　　刀则何缘伤
  逮得澹然句　　弃除诸恶道
  一切殃尽灭　　刀刃不能害
  成就于明慧　　圣达无所乏
  显耀逮佛道　　以故刀不害
  欲界及色界　　无色为三界
  等同斯三界　　是故不自欺
  等种成正觉　　不见名别异
  无阴岂所净　　清净远调戏
  入斯平等迹　　故曰为菩萨
  若着音声者　　无离于五道
  虽言至法界　　讲其无所去
  以逮不住忍　　谓之为八等
  分别诸响应　　讲说寂然法
  无念非有名　　故谓为八等
  除释一切音　　而得无声界
  不着一切响　　是谓为八等
  因声解诸法　　一切法自然
  诸法无有名　　不见有度者
  阿难我是故　　赞扬正八等
  义响而趣斯　　是亦无所获

佛告阿难。如来至真等正觉。叹美菩萨演八等声。斯议所趣权慧方便也

    阿惟越致遮经道迹品第五

佛复告阿难。如来何故。咨嗟菩萨为道迹乎。轨能通流至于佛心。菩萨住此诸所兴造。永无所立不进不懈。度一切法逮于佛流。不着仁慧非猗于法。无所著行而弗有处。具足妙行得获圣迹。精进菩萨其力坚强。心慈忍辱未尝懈怠。捐除慢惰慕求妙道。世遵最上不着圣行亦无所住。存在斯道而求诸法。其所索者永无可获未尝动摇。虽住于道计圣生死。佛慧平等弃离众乐而等阴盖。灭除一切贪身邪见。勤修观佛察彼精进以睹圣轨。悉除诸想超度吾我。是谓道迹。不着佛路得无为觉。不疑圣慧佛之戒禁。不猗于世不睹其戒。以无所见则不有求戒。莫而慕除释三结。正住三界乃获大安。护众生想不猗不涂。舍一切着乃得佛道。致寂然迹不计身命。一切所有施而无惜。诸根常悦捐除恚色遵修圣行。虽以惠与无所放施救群生隘。既有所度不住无为越一切想。兴无念法弃捐人想而逮斯慧。不惧众会论于寂灭用净佛道。超度诸难不畏生死。所以者何。逮澹然法而无瑕秽圣化妙安。知无往来锄众类想。但正道明志清净行。时佛而颂曰

  讲论彼道迹　　佛圣无思议
  计众有住者　　则为道所持
  圣慧最上安　　不猗众想网
  空寂不有住　　于彼无所得
  以获斯道者　　菩萨志坚强
  惟趣是圣教　　世尊无有上
  志道不有贪　　心常采大慧
  以是为道迹　　不猗无所著
  所谓生死想　　佛念亦如是
  具足正平等　　是谓解道迹
  无有众阴盖　　演析于道法
  是故除一切　　了斯为道迹
  众生皆猗身　　兴心观佛道
  其意志所察　　常睹于圣路
  身本时兴结　　凶危想有我
  以故无尘埃　　不着于佛道
  初志怀狐疑　　将无不得佛
  以释斯犹豫　　正立于佛道
  假使识于戒　　及佛所演禁
  蠲除诸戒想　　无应不应禁
  超度于三结　　等住于三界
  则获致佛道　　分别众生想
  习空明轨迹　　而愿求大慧
  逮志圣寂然　　不着于佛道
  常舍心布施　　弃捐嗔恚色
  以故无有命　　存道无放逸
  一切不矜悁　　救济众恼患
  是故谓道迹　　住处于上路
  未尝兴诸想　　当习无所著
  斯已而不惧　　不游无禁戒
  若习诸经籍　　善权舍诸求
  觉了众音响　　处世无所畏
  设至于众会　　则不有诸难
  便唱澹然法　　净治于圣道
  造时兴人想　　以解自然行
  用无强着故　　则舍众畏难
  若舍众患害　　便不畏终始
  逮得净然道　　离垢安最上
  等了恶道休　　斯以无所惧
  平等上圣轨　　道恩则不离
  斯即菩萨法　　为现道迹事
  用懈废劣人　　导利彼故说
  以微妙善权　　讲论佛圣道
  若入菩萨者　　是已为唱导
  导师所演法　　常合善方便
  本行亦若兹　　志慕于佛道
  我是故阿难　　分别说道迹
  朦冥如意塞　　多想求如此
  为说不能解　　愚騃心冥冥
  谤讪慧精进　　听诸志深要
  阿难吾是故　　叹美于道迹
  设了菩萨无　　是辈能解耳
  无数百千籍　　训化于道迹
  履轨之音声　　为现佛道明

佛告阿难。如来至真等正觉。光耀菩萨谓为道迹。当知是义善权方便也

    阿惟越致遮经往来品第六

佛复告阿难。如来何故畅说菩萨为往来乎。于是菩萨入于佛道不可思慧。志求圣觉无量因缘。于诸愦闹无所兴造。设致大道慧断诸缘慕索佛明。求不乱禅越一切定释诸尘埃。乃逮致法等佛典籍。了一切经惟求此义。如来所护道德之明。人未尝动无所转移。则为法界忧念众生心闭意塞。遭众苦患不了经典。慕求佛道立之此慧。而志大明根力觉意脱门正受分别是义。吾身如何开化众人令慕佛道。常以此明劝化道场。而求佛眼心无阴盖。若入正观导利世间。所志慧因诸圣之上。其不了慧一切诸法之所归趣明不可获。以是之圣不求众生便当立之。于此诸慧了法无处。以故当来睹群萌界。求无上处慕于不念。非得彼界不来不往。成就众生往亦不往。开化人民了黎民处。分别此义随其开化睹是诸法。一切众生皆存法界察以不见。等御法界则省一切经典平夷。观于大道以佛圣慧不得人无了人道等求如是像。无持之慧离垢尘埃故慧无非处。其以无慧求大明轨不可望圣。是慧慧中之大明慧。不有诸求求亦无所慕。是谓圣明之智。菩萨所行能得是者。以故求来此谓往来。于是颂曰

  此智有往返　　佛慧难思议
  是故谓往来　　志求于佛道
  开化多因缘　　乃成于佛路
  是事顺慧均　　慕求不复还
  不猗一切禅　　劝化诸尘埃
  欲救济斯等　　具足于往来
  佛经平等法　　分别人无相
  晓了如本无　　已故谓往返
  所可获法者　　达了一切慧
  吾亦当获是　　欲求所住处
  未尝动众生　　及计诸法界
  故谓于往来　　不近所归处
  忧念无数人　　少智既遭患
  欲立于斯慧　　则求佛大道
  根力及觉意　　讲咏三脱禅
  分别斯义已　　故求佛圣道
  志慕于道场　　过去佛所猗
  故谓为往来　　则立存大圣
  慕乐慈愍眼　　佛眼无思议
  是故为往来　　慕于佛大道
  诸佛之圣求　　世尊微妙义
  自志斯深慧　　一切智最上
  明智之所了　　一切法之归
  其慧不可得　　及以求道者
  济之无数人　　立之于上慧
  以故为往来　　来者有所求
  怀来睹佛界　　人界不思议
  故以为往来　　于彼救众生
  省察众生界　　求之不可得
  故以为往来　　慕心于法界
  群黎无所趣　　及一切人界
  若晓了彼处　　顺所游分别
  睹一切诸法　　见以则不现
  常一心定意　　求佛大圣道
  如是微妙慧　　无垢而清净
  而明所分别　　其智不可获
  菩萨所欣乐　　开化于众生
  则获彼明智　　何缘来至此
  吾是故阿难　　论讲于往来
  为少智之人　　睹示所兴念
  吾是故阿难　　论说于往来
  人怀精进者　　尔乃晓了此
  有德者分别　　解深妙之义
  能获于斯德　　速得成大道

佛告阿难。如来至真等正觉。颁宣菩萨为往来。当知是义亦是善权方便也

佛说阿惟越致遮经卷上佛说阿惟越致遮经卷中

        西晋月氏三藏竺法护译

    不还品第七

佛复告阿难。何故如来说美菩萨为不还乎。于是菩萨一切所存。处处造行超越诸有。而逮佛明蠲除诸行。降伏此已则不复还。所以者何。见一切法不有往还。超度凡夫捐舍俗慧。入佛明智获无所住诸法平夷。所以者何。用致寂界非动凡夫。不立圣道塞诸恶路勉济情欲。于食无食逮上明迹。拔去诸见则无所著。无有诸邪六十二见。已越生死观于泥洹。踰之无为释弃众想。不随经籍净垢恶道。捐弃贡高不怀自大。出于无黠忧恼之先。破坏爱欲灭除众冥。拔去贪乐舍置尘埃。憍慢自恣止息斯碍远离世智。故思佛乘等获圣慧。菩萨捐志舍爱欲界。则习本净过去圣灭之志。厥慧无上诸佛所解欲以显思。一切众生极尊无极。为一切乘此则佛慧。菩萨获斯诸想无想等。除一切狐疑之界。菩萨逮是则不复还。又问阿难。其有人不住于道悉当立之以道。是者觉了众生明尔则道。能觉如是则制人想。所以者何。知于空事人界难议平等道慧。所以者何。分别若此群黎之种则空。净界人种亦空远于众想。一切诸人与空无特许。不有身不获不住彼则亦空。虚空无空免一切想。无念致道蠲除众生。虚空之想无弃不弃。所以者何。一切诸法皆为平净。一切众生而无所捐。等于所释故无所得。已不有获是以不来。此者乃计为之不还。有为无为于一切法觉了所会。越度诸患故谓不还。于是佛颂曰

  彼则无所生　　造行如所处
  蠲除诸所住　　是谓不复还
  晓知于往还　　不着一切法
  所住不可得　　是故不还此
  其凡夫之行　　及佛世雄教
  不然无所量　　故谓不复还
  诸法无复来　　亦不得诸住
  以获无去来　　是谓不复还
  其人未尝住　　不至于三涂
  逮致佛道明　　则谓为不还
  决除一切欲　　于食而不着
  得至于道场　　则谓为不还
  众见之所行　　分别六十二
  不堕于彼际　　则谓为不还
  此法无终始　　已舍离诸畏
  斯慧如本无　　是故不至此
  所应无为寂　　不着诸尘劳
  逝除彼众想　　是故不诣此
  已断诸恶道　　洗去众垢着
  学寂然无为　　则谓不复还
  降伏于弊魔　　及官属兵刃
  永无有众念　　是故不诣此
  挽拔痴忧戚　　蠲除爱欲根
  断截盛贪淫　　是故不诣此
  降制诸尘垢　　拔去于众想
  究竟至尊慧　　故谓不复还
  捐去众愁戚　　破坏于贡高
  忆断于五阴　　故谓不复还
  志乘得光明　　佛乘无有上
  不贪爱欲患　　故谓不复还
  已知佛藏处　　诸藏中第一
  过去佛所辩　　是故不诣此
  彼处于尊乘　　佛圣无有上
  截去诸狐疑　　是故不诣此
  受千无数人　　劝立于佛道
  以得立圣轨　　是故不诣此
  晓了空无界　　等心于人界
  远离诸着想　　是故不诣此
  晓了一切界　　法界亦如是
  众生不可得　　是故不诣此
  分别黎民界　　虚空无思念
  一切法如是　　是故不诣此
  其人而无心　　退除于众想
  诸念不成道　　则谓为不还
  吾是故阿难　　叹说于不还
  诸事永不来　　得住于佛道

佛告阿难。是故如来至真等正觉。叹美菩萨为不还。亦当知此为善权方便也

    阿惟越致遮经无著品第八

佛复告阿难。何谓如来叹美菩萨为无著也。是菩萨没一切行离于处土。不倚诸佛度脱众生。不有所造尘劳之垢及与苦乐以灭色。欲救济一切故谓为无著。弗得众生。不获欲埃非贪如故谓无著。释去侵欺处无所住。一切法空。以了寂静不习众想。诸想以定则除众思。不计有人坏灭所志。而智空法得无所著。佛道无思具足不怙故谓无著。演说典籍破坏众瑕。叹于往古等正觉教当来现在。而不放逸清净离秽。唯论寂然故谓无著。菩萨大士开化诸人。立于佛道求圣路者。于一切法而无所慕。具足慈心行佛之仁永不有处。彼慈如此故谓无著。化立众生亦不得人。究竟大哀晓了不处故谓无著。为众生故加恩见道法无法想。断除如此故谓无著。赞扬觉力计有愿数获于不住知拔除众根。志化众生。了清净法使成道义。永不有倚故谓不着。睹不依处制不贪身。于诸万物非有所依。求及与众会不毁万物。讲有为法。如是无本故谓无著。游诸佛土去无所至。不起本末睹佛圣尊。觉道无寂故谓无著。非有依处立如斯土。于无量刹平等诸国。不调戏界清净不足。住福德之域空无诸刹。不退转地无有女人。释去尘势睡眠之志。得佛圣国除阴盖土。降魔官属去诸怨敌。入寂然土感动变化。立于愿刹土众求国。菩萨具足之威耀住无所住。睹获佛意净印印多所安国。舍离一切璎珞宝饰众垢之瑕。究无为地一切最尊。成如是像微妙佛处。诸法皆空具足道行故谓无著。蠲除众乐诸根不可。于一切法不嗔不怒。寂平等乘则为佛慧。身口心同习无上寂。慕求圣道不着轨迹不想思人。悲念众生无心不心。劝化无数亿百千人。使立大道开示萌类。使念佛法等诸人物。导利无数众庶黎民。令发圣意而无等伦。一切诸法均空特异。本空慧同立之不想。能等如是知无所倚已了。若此应其众生而为说法。不慕诸利无倚经籍。具足离根讲法如是。永不有言多所化济。不见度人救于众生。着断诸事免诸贪身超越贡高。睹一切法不起不灭。开化群黎万物之想。令不坏色痛痒思想生死之识。凡夫不动则应解脱。而立佛法着道迹者。化之不倚则成除勖。导利所依令无佛想。则为勉济劝发菩萨。弘不念心救道因缘。诸愦乱意离痴狂诈。具足三昧成就定意。不怀众想。拔于邪智令睹正慧。化发声闻慕反迹者。制倚父母妻子舍宅兄弟姊妹令除恩爱。度着国土财色万物。贪求之想尘劳颠倒开化诸着万物之想。慕离于家而为寂志。懈废羸劣等脱诸相。成入佛土欲垢之法。兴发道意心不有二。未尝生念。是无为法。此生死法。因缘无缘。道意俗心。犯戒护禁。开化此辈。兴二相者。使其无念。度诸根本故曰无著。众祐。贤圣。懈怠精进。男子女人。顽愚聪达。明圣闇结。导利此等。令无二心。救进众生故曰无著。是诸菩萨成不退意。或有受别。又复不着。斯诸菩萨近道远道。分别此义。不生二想。得逮圣路。至不起余而般泥洹。便离发意而不有倚。缘此诸法以开化人。如是自然解一切法。演无根本故曰无著。时佛叹曰

  释除一切行　　所尊亦如是
  弃捐诸言教　　故曰为无著
  锄捐诸尘埃　　度脱动苦患
  救济于众生　　名之曰无著
  察人不可得　　欲垢亦如之
  诸法无可获　　故曰为无著
  蠲去众颠倒　　立心处不惑
  分别知法空　　可曰为无著
  了解知空义　　无有诸想着
  除去一切颠　　号曰为无著
  捐除一切想　　及人众恶念
  心无邪乱意　　故曰为无著
  解空无所依　　佛道不可量
  勖勉大精进　　故曰为无著
  讲经所因缘　　淡靖无调戏
  劝人立道德　　与名曰无著
  真人修行慈　　欲令众生安
  劝人不可得　　故曰名无著
  本无讲经籍　　加恩众生类
  未尝有人想　　故曰为无著
  正真根力觉　　为人分别说
  己身逮此慧　　故曰为无著
  知人之寂定　　清净法致道
  开演大圣教　　故曰为无著
  不信诸万物　　现目之所睹
  一切虚无有　　是谓为无著
  无倚诸佛土　　在国行仁义
  平等觉所处　　为众生讲法
  真人觉正教　　则睹于无见
  如谛观圣觉　　是谓为无著
  成就自然国　　今我得知之
  究竟无本始　　是谓为无著
  除去诸所知　　心不怀嗔害
  应真如无恨　　习成寂然道
  定意而不灭　　靖泊无所起
  念道亦如是　　故谓为无著
  人物不增动　　众生界如是
  亿萌亦普然　　化立道之义
  群生及与道　　所处永无念
  计慧悉平一　　是谓为无著
  平等无像类　　一切法亦然
  心正若如道　　故曰无思念
  所谓为应真　　诸法非所著
  能为人分别　　寂尔而无倚
  为人讲法义　　虽言而无教
  普度无量人　　见众不有动
  众生无可获　　诸民除断着
  拔人离邪见　　度众勤苦恼
  一切法不起　　所处亦无灭
  睹众生诸想　　脱群民困厄
  无增坏诸色　　痛痒亦如是
  想识于生死　　济之令无他
  不动贤圣法　　凡夫亦如斯
  立之以佛义　　度使志无著
  众人怀果想　　及缘觉之念
  超越于觉意　　为人说此法
  以兴发道心　　常依所布施
  戒忍亦如是　　故讲无所倚
  知解之颠倒　　兴习于精进
  以除斯诸想　　故说无著法
  道意之所念　　邪智若慧明
  于此无所倚　　故说无著法
  是法不生念　　了别无若干
  而说如此法　　故说无所著
  自计己有身　　声闻多所念
  以为除此想　　故说无所著
  诸法非有思　　解知不若干
  演说斯无根　　故曰为无著
  父母兄弟子　　空寂之所有
  则为生死行　　不能成佛道
  慕妻及姊妹　　所倚皆归妄
  设其不有依　　故名曰无著
  造兴生死事　　则有亲族念
  见因有情欲　　吾宿之友党
  自念身有我　　心驰众诸事
  分别堕颠倒　　必则处魔教
  弃捐于生死　　终始之灾患
  赞扬泥洹德　　故说于无著
  所讲劳垢法　　兴衰及诤讼
  斯皆言声耳　　是曰为无著
  众所多竞利　　放逸贪万物
  欲救此等类　　故说无著法
  恋慕室家者　　心念行学道
  顽钝意如斯　　显举于无著
  唯见卑贱法　　不睹真妙义
  弗省于众念　　故度至无著
  除弃凡夫义　　专精慕佛法
  拔去众民求　　故曰为无著
  若睹善恶行　　如是众数法
  无量人亦然　　故救放无著
  以具诸相好　　精进不可计
  而倚于此相　　仁贤得济度
  庄严诸佛土　　成就尊上法
  依怙觉正利　　度之至无著
  无为法之义　　若得或不获
  斯乃圣道行　　则能立正愿
  无戒不睹犯　　放逸及智慧
  闇昧软弱人　　便着斯三事
  众生兴此相　　诸念不可计
  蠲除若干意　　故说无著法
  存慕圣众祐　　亦念于无德
  分别凡人法　　故说无所著
  以得如是行　　男子及女人
  贤圣与凡夫　　斯则兴二心
  人起此二事　　愚行之所为
  用倚是二际　　故度至无著
  回动不退转　　兴造而不作
  欲以近圣道　　故兴心此念
  获致于大道　　不起无所灭
  心常怀想着　　用求于无为
  于彼受众生　　仁人念萌类
  以故曰无著　　救济诸求想
  是则菩萨法　　为现阿罗汉
  因以发法忍　　自谓为无著
  讲说罗汉事　　斯应为菩萨
  名住无所著　　获致无上道

佛告阿难。如来至真等正觉。赞叹说菩萨无著。亦当知之善权方便也

    阿惟越致遮经声闻品第九

佛告阿难。何故如来光耀菩萨为声闻乎。菩萨大士开化无数不可计人。令闻佛法分别经籍故谓声闻。使听圣道净不放逸故谓声闻。使听无为安隐甘露。根力觉意意止意断。具足此事速至道慧故谓声闻。令得空慧身无坚固。闇昧之人闭塞不解。所以者何。乃贪己身诸入之事眼存为色。了观如是则成佛眼。其目普见不可思议。眼无所倚。究竟此目致一切法。故谓声闻。计此诸法如呼之响。莫得着音。非有说者亦无听者。无香想香亦不有嗅。譬如有人卧出梦中。嗅种种香计此无香。此则或事思想所为。一切诸香人所嗅者。譬若如梦而无坚固。解斯音者则谓声闻。舌之味味亦复为空。若肉段如为舌。或智者了之不为味惑。譬如聚沫。以离诸论无可为喻。明者观之知无所有不可得。持想着味者则致恶罪。莫思六界以分别味。心则开解意不放逸。若知此者心想无为。各各分别谓所听义。而闻此空故谓声闻。晓了其诸入之事。听之为空身自寂然。未尝有生不知所起。无生不生则为圣道。故谓声闻。若所听者皆无所有。解身自然不起不灭。故谓声闻。听于布施惠以法行。不可思议佛犹此路致于佛道。心有所施不自见心。以无意志逮得圣慧。所以者何。如其所种必获其实亦不有果。说果之声听衣食施。计物之施所与薄耳。一切所舍法施为尊。无得贪惜莫怀施想。虽有所惠不得悕望。譬如幻人无有心意不与想念。欲成行者无得想施。所以者何。施不悕望则顺道行。故谓声闻。离诸所音一切尘埃都无所听。离诸有为。不可以音听受佛法。分别诸响而无所倚。所以者何。二事造声。虽有二事则无所有。因缘合致则有二事。用有人故而致法音。故谓声闻。于是佛颂曰

  使无央数人　　闻佛无念法
  以故谓声闻　　则勇猛菩萨
  闻寂定之道　　恬静不放逸
  无量人听法　　故谓为声闻
  听澹泊安隐　　诸乐非有像
  以故为声闻　　至寂然无为
  听于觉根力　　具足意止断
  自究竟斯事　　故谓为声闻
  听身所有空　　不可得坚固
  愚騃之所慕　　故当时了体
  其目无所睹　　不听亦如兹
  众生为见侵　　闇塞不了了
  若得成佛眼　　等自不可议
  致之在本无　　开化诸闇昧
  无量人闻经　　诸法非有兴
  此以得名号　　称存于声闻
  其无所听受　　了之如呼响
  不见有说者　　亦复无所闻
  所以名声闻　　令众人听受
  计本不有闻　　莫为音所惑
  譬如人寐梦　　嗅于无数香
  恍惚不可得　　游逸嗅于空
  了香亦如此　　未尝有嗅香
  无量人失志　　菩萨令开明
  计舌无所猗　　肉段不知味
  设使肉解甘　　舌亦当识之
  无倚此诸想　　念美为凶危
  六界不可念　　分别诸味种
  菩萨大勇猛　　目睹分别此
  因听而致之　　故曰为声闻
  自分别己体　　是则空自然
  能了此虚无　　则无起不生
  若无所兴隆　　则解此圣道
  令群黎听法　　是则谓声闻
  计心言本净　　无形不可得
  是者莫有人　　听此为声闻
  犹如幻化生　　灭尽则亦空
  若有睹众想　　了之为声闻
  又听所施与　　法施不可念
  是轨为圣路　　尔乃成佛道
  随其本所种　　获果亦如之
  不可思议施　　成大道无念
  衣食施薄福　　法施为最广
  未尝有悁惜　　此则圣慧涂
  弘无想之心　　布施不有着
  如是惠施者　　疾致成佛道
  释去一切心　　计耳无所闻
  超度诸合会　　故谓为声闻
  因呼有响应　　假使不着音
  则于众圣尊　　佛法无有上
  诸可不闻响　　一切而无倚
  不二无若干　　畅音有声闻
  无数佛演法　　令彼闻其音
  计所闻如响　　乐人成佛道
  善游诸佛土　　所闻不以乱
  平等觉所处　　世尊无有上
  听千三千世　　所住如虚空
  计人等猗寂　　若泥洹无形
  世人所著想　　计倚有四大
  是则为虚空　　泥洹为想念
  解诸种如是　　莫得计坚固
  本无生死者　　不灭尽尘劳
  万物不究竟　　计人弗可得
  此诸法寂然　　未有睹众界
  令黎民听此　　夙夜亦如之
  彼不兴众念　　我化诸人闻
  使人得听法　　如此为弟子
  所闻无所闻　　故叹曰声闻
  雄人念往古　　听受最上法
  睹不分别经　　一切法一切
  讲音无所偏　　救度一切会
  为众人说法　　是则为声闻
  则讲无为界　　清净不放逸
  谛观无说法　　佛法亦如之
  睹法不去远　　佛之所讲扬
  彼法亦不近　　是故无所猗
  所以谓弟子　　听采随此教
  劝化于群黎　　斯乃为闻法
  阿难我是故　　讲说声闻化
  假号曰弟子　　则菩萨大士

佛告阿难。是故如来至真等正觉。叹说菩萨为声闻。当知是义亦善权方便也

    阿惟越致遮经缘觉品第十

佛告阿难。何故如来颁宣。菩萨为缘觉乎。于是菩萨目睹诸法。何谓目睹一切法空。无有像类而不可坏。现在觉观法不可灭。故谓缘觉。诸佛经籍不可思议。晓了诸萌悉如泥洹。无有内外则不可获。一切诸法不起不灭。人之本际则泥洹也。所号本净但着言耳。则无所有法不可逮。因名演称语无所达。所以者何。其言则空。口之所说不解已无。法本之际佛道之无。分别观斯故曰缘觉。自察色阴但是声耳。此色阴者。计于色生唯有名矣。以离言声则无有阴。其色阴者无身。无我。所以者何。因口作号所言亦空。不起不灭所言自然。不着吾我不得久存况口言乎。目睹色阴则为痛痒。痛痒阴灭则不有名。因口之说号为痛痒。痛痒阴身无我。所以者何。所谓痛阴其言则空不起不灭。言不着身则无所住况于言乎。晓痛痒阴。即观想阴若寂想阴则无思想想阴号耳无身无我。所以者何。口之所说思想阴者。其言则空不起不灭。分别言已不着自然。心无所立何况口言。观想阴已则生死阴已灭。行阴则无生死。所谓行阴无身无我。所以者何。所号行阴言其则空。不起不灭但着言耳。不得久存况口所说。观行阴已则有识阴。假使识阴惔然寂灭。则此识阴但阴声耳。所以者何。其号识阴是则空耳。不起不灭其言自然。无所住止况言说乎。是五阴者皆无所有。分别本无故曰缘觉。所以者何。斯口之言缘对而致无缘不缘诸因讲说有言无言。五阴之事。于此一切永无所著。不造众因故曰缘觉。于是佛颂曰

  目睹一切法　　分别知之空
  不着于诸色　　究竟莫有相
  现在观此法　　解空知自然
  分别了澹泊　　不可得根源
  现在获于斯　　晓五阴如此
  则为平等觉　　缘觉无思念
  众生志无为　　其心不可获
  本际无有起　　净无无思议
  一切人不起　　观见无所灭
  诸法无动兴　　是谓为无为
  众生皆泥洹　　省察是所趣
  无人犹若影　　故曰为无为
  不用是名称　　群黎为泥洹
  不起无所灭　　如口所叹咏
  敢可说悉空　　人不解非言
  是故为众生　　示现说泥洹
  口所发假言　　无处亦无念
  因口而有训　　求本不可得
  阴不在本际　　口言无所显
  诸声所称说　　人际亦无念
  一切愿泥洹　　本无及始际
  澹然无放逸　　则救有所将
  本净游乎响　　众生亦复然
  无形则空寂　　本净无心念
  法本为若此　　假名而赞扬
  其源不可得　　所以有言说
  不以谀谄事　　而可分别解
  其际则空无　　便了众生本
  其言不依讲　　口言无所显
  诸群黎如此　　则不着人本
  所发阴则空　　其声无所别
  其说亦如此　　而际亦复然
  其无谛如是　　觉已无所念
  是则平等道　　缘觉无思议
  觉了于本色　　此但阴声耳
  寂灭斯色阴　　则无有言声
  自然释之去　　是则曰无形
  吾我既自然　　睹之无有处
  因言谓之阴　　色本不有身
  其声皆归空　　不起亦不灭
  因口而告言　　求本不可得
  其说因痴兴　　号之谓色阴
  现在观识阴　　诸声无所有
  此阴以寂灭　　则无有响阴
  于此远离身　　所谓吾我者
  计已自然空　　未尝有坚住
  口之所缘阴　　识阴则虚空
  口言本则寂　　不起无所灭
  若有所颂说　　察之悉本无
  无黠之所言　　故演为色阴
  诸音无有说　　其限不可得
  不起无所灭　　无处而不决
  无尘劳侵欺　　亦不造诸法
  不执无所舍　　莫调不泥洹
  彼亦无寂灭　　不有所睹见
  不乐施欲埃　　不怠不精进
  不乱不一心　　彼亦无守戒
  非物可成就　　何故当持禁
  五道非有念　　无思亦如斯
  不恐无所畏　　不脱而不缚
  虽讲无所演　　是为色所入
  一切法音然　　无获莫着言
  现在逮是觉　　无尽之法说
  以成是三昧　　则无诸响声
  目自分别此　　响之等如称
  诸法亦如是　　无言不有着
  晓了因缘者　　知音无所有
  故号平等道　　是谓为缘觉

佛告阿难。菩萨大士现在分别。有明无明。是行非行。有识不识。色与不色。六入无入。诸习不习。痛痒非痛痒。恩爱莫爱。不受舍受。有与不有。生若不生。老病死患。一切自然察之本无。如是观者。故曰缘觉。于是佛颂曰

  现在了无慧　　未尝倚为明
  不成立有形　　若如水中影
  聪达晓诸义　　不着一切法
  假使不倚经　　是则慧者相
  明与身无异　　一切诸法相
  觉了此缘趣　　故曰为缘觉
  所号身之行　　其躯无所造
  永不有内外　　则超生死体
  终始犹芭蕉　　非根无有貌
  不起莫有灭　　等譬如虚空
  现在晓了此　　则勇猛菩萨
  斯号平等圣　　缘觉如无念
  分别一切法　　寂行如幻化
  其识自然尔　　现在晓了之
  忽然解斯心　　知识行如之
  诸所道示想　　明识诸法空
  分别识其然　　一切无所著
  了如是法者　　知识亦如幻
  所可号名色　　身及诸音声
  众貌空不成　　是谓自然相
  心驰骋六情　　如幻化无言
  现语非音声　　计自然悉空
  久远来习之　　因发诸入处
  彼则分别习　　名自然如空
  习以成悉无　　游念起众更
  若晓习本寂　　则知法无住
  目睹习自然　　睹众更悉寂
  不兴凶罪殃　　故曰为缘觉
  晓了诸痛痒　　皆空如本净
  譬如泡起顷　　志敬空无形
  断除众恩爱　　则从无著法
  情欲已永尽　　故曰为缘觉
  若受而不受　　则空无有有
  非形何成就　　譬之如野马
  吾无所兴想　　身生亦如是
  计本自然生　　无根非有形
  以离起灭法　　则不畏当终
  未当复成身　　一切得自在
  现在获此慧　　永无有著者
  又缘觉之音　　则造菩萨行

佛告阿难。如来至真等正觉。以是之故。赞扬菩萨为缘觉也。亦当知是善权方便。如来用是之故光耀菩萨大士。持信奉法八等道迹往来不还无著声闻缘觉也。

    阿惟越致遮经释果想品第十一

贤者阿难。而说偈言

  世尊所演说　　假号名泥洹
  喻之若虚空　　度于无所有
  虽有所讲说　　则非以辞言
  诸佛行善权　　合集说法耳

于是阿难说此偈已。前白佛言。惟天中天。其世人民。不解如来至真等正觉随时之化。则自侵欺。不了如来。何因分别菩萨大士持信奉法至于缘觉也。世尊告曰。若有明者于过去佛积功累德。心开意达不见侵欺。所以者何。晓了诸法。譬若幻梦影响野马水月。所以者何。菩萨大士。分别此慧则不自侵。殷勤修学如来之法。精进不懈则不自枉。佛于是颂曰

  世尊之所赞　　赞扬于圣道
  是故之因缘　　菩萨行勇猛
  少智懈怠者　　不能解此义
  故当修精进　　如来以此说
  道意所游生　　世尊有开化
  故分别此慧　　清净之明哲
  彼解道意者　　智圣不可获
  若致得知轨　　心觉五事空
  空者不知空　　寂定非不言
  悉除一切音　　故赞唱空法
  捉空无所得　　未尝能获者
  假使不可持　　则知为空义
  设有解是五　　分别了空慧
  成得无放逸　　则不自侵欺

尔时五亿比丘志怀持信。即从坐起住世尊前。叉手自归。异口同音。而歌颂曰

  今世尊大圣　　蠲除诸狐疑
  平等觉所宣　　志立于大道

复有五亿比丘。闻是之说皆悉奉行。悉住佛前。等心颂曰

  唯世之光耀　　吾今离犹豫
  圣尊之所叹　　分别佛大道
  志愿奉法迹　　正慧无挂碍
  道德自然成　　开化诸十方

复有千亿比丘怀八等想。闻此叹颂即从坐起叉手而立。俱歌颂曰

  志所怀八等　　今则释疑网
  心已分别了　　所因见八等

复有十亿比丘怀道迹念。自从坐起。叉手而立。同说偈曰

  导师及吾类　　以获致法明
  乃知平等觉　　所因演道迹

复有二百五十万比丘。志怀往来心。则从坐起叉手自归。同叹颂曰

  我等本依倚　　志怀往来心
  今日永无难　　存亡无放逸

复有五十亿比丘。怀不还想。而说颂曰

  导师尊无上　　今日无调戏
  永舍诸果想　　致圣导光耀

复有三十五亿比丘。怀无著想兴立四禅。即从坐起。叉手说是偈曰

  今吾不犹豫　　逮致无余法
  解诸乘平等　　譬之若如幻

复有五十八亿比丘。意怀声闻即从坐起叉手而立。则赞颂曰

  吾等犯斯言　　意欲度众生
  所演谓声闻　　今日乃达知

复有五亿比丘。即从坐起。兴缘觉想叉手而立。同心颂曰

  今日乃目睹　　缘觉之所因
  世尊分别说　　缘觉无思想

复有百万比丘尼。谓成道迹往来不还无著果想。即从坐起叉手而立。说是颂曰

  吾了平等法　　则舍女人身
  各各成佛圣　　当为世最上

复有八百八十万清信士清信女。悉怀道迹想往来不还念。即从坐起叉手立佛前。心同意等俱共颁宣。而颂曰

  吾等念心净　　譬如琉璃器
  于是当舍家　　兴佛之法教

复有六十亿垓彼诸天人。住于虚空而雨天华。散于佛上俱供养世尊。即下叉手立于佛前。而歌颂曰

  吾本怀诸乘　　果想亦如是
  今日以永除　　觉成无上道

    阿惟越致遮经降魔品第十二

于时无数百千比丘。舍利弗目犍连须菩提阿难律。离越劫宾奴等。从坐起叉手而立。白世尊言。吾等今日圣道具足。不违大意。降弃魔怨。备究五逆得悉五乐。成就邪见舍离正见。吾等今日已害无数万千人命。悉成佛道至无余界而已灭度。时世尊默然。于是众中无量百千诸来在会。闻此所言而皆狐疑。此谓何乎。义所趣耶。心怀瞑然。如阿罗汉。乃兴此言。岂况凡夫。住者直立。坐者默坐。不能起立。贤者阿难承圣尊旨。悉知无数百千诸众心之所念。问文殊师利曰。闻耆年言会者皆疑。不审所论为何归趣。又佛世尊默然不言。文殊师利乃曰。唯仁阿难。此经名曰不退转轮菩萨之地。是耆年等所可讲说。诸得不退菩萨大士目睹信耳。阿难又问。耆年何故说此言耶。世尊默然。此耆年等于无上正真不退转也。答曰唯然。当成正觉不复回还也。文殊师利谓贤者阿难。无黠之行则曰其母。是诸人者。究尽除害。无善思想贪着情色。斯则为父。除不善想远诸情念。至无著意释凡夫法。洗荡不净想别圣俗。碎破众念不坏大法。兴如来意以除诸想。于一切法无所从生。是故耆年讲说此语。吾等今日具足五逆。所以然者逆无往反。耆年所言成五乐者。察其五乐皆如梦幻影响野马。了知此慧行无缺减则为五乐。所以者何。无有根本。设无其源则为尽除。乃应平等。讲具圣慧即逮法忍。此者名曰五乐备足。耆年所说。吾等今日得离正见住邪见者。睹一切法皆处邪见。欺哉诸法诈妄至诚。尽无所有。譬之虚空。非有像貌。虚实去来悉无归趣。不可将护。所以者何。其本自然。计此诸法则皆平一。如诸法等邪见亦然。此比丘辈非等无邪。所以者何。以离诸想致佛圣道。获众觉法饱满经义。而无所得。是故阿难。是诸比丘悉共说言。吾等今日具足邪见释于正见。此耆年等所谓今日吾等害无数百千人命。说斯语时。不可计无数千万人神。闻之诸法譬若如幻梦影响野马。蠲除人想。无有吾我。远寿命人。超众德本。发大道意。无所殖种。兴修道义。及余比丘比丘尼清信士清信女。舍我人寿无身之想。不复频更终始之患。所以者何。无我人想不尽想永尽无余。逮致究竟不起法忍。故说此言。吾等今日害无数百千人命。斯诸耆年属者所云今日吾等逮得佛道。致无余界而灭度者。开化无量亿百千人命。弃众尘埃令获圣道。所以者何。皆发无上正真道意。说此语时。悉逮无所从生法忍。以故咨嗟自赞颂言。今日我类拔去情欲成佛道法。无尘劳形除有余秽。故谓我辈今获大道于无余界而灭度矣。是贤者等。以在大乘不愿在天。惟仁阿难。族姓子族姓女。发无上正真道意。以起俗事其心清净。不为俗法之所系缚。乃应发心越一切义。道舍诸想究竟经典。则无余界而灭度矣。是为阿难习菩萨乘。行菩萨者不习日行。愚騃之人随日念耳。非明智者。所以者何。设无此诚信要御诸天宫殿。则无光明。便无出入。过去无晦。则无昼夜便不思想。愚冥之人兴昼夜念。菩萨大士寂修大道习善知识。无有穹志昼夜想也。所以者何。永除众念乃致佛道。于是文殊师利。则说颂曰

  所谓不怀施　　爱己计有身
  彼若不断除　　则谓不可摇
  分别于嗔恚　　自然不生想
  圣道以无处　　彼则不可动
  所可敷母者　　终始所由生
  拔去此根无　　则谓为害命
  不顺念为父　　所乐情欲法
  是等解本无　　究竟莫有根
  化之归无身　　不知明所趣
  不动无所住　　向者故说此
  所修罗汉法　　凡夫法亦然
  诸可尽爱欲　　向者故说此
  大兴有为想　　察吾我自然
  诸法无所怀　　则无音声说
  如来之所知　　古昔之所念
  即拔此根株　　则谓无从生
  以舍是想乐　　等同而无二
  假使晓了斯　　则谓平等教
  所言五欲乐　　俗人赞此五
  蠲除非常想　　念之如幻化
  具足不乏少　　则怀爱欲无
  以故此等类　　世尊前叹之
  分别诸罪福　　譬之若如梦
  究竟无从生　　其慧晓了斯
  识邪嗔恚法　　空寂无能固
  邪见为欺哉　　彼分别妙智
  一切法不实　　莫有近法者
  虚事不可倚　　如虚空无处
  普解睹一切　　故难为正见
  此法则平夷　　了慧见正等
  厥愚冥之人　　起人想则没
  索人不可得　　则无有死者
  无量人起生　　则舍寿命想
  便以无众念　　计命者罪重
  蠲除众生想　　非有计寿念
  以故说此言　　吾害无数人
  舍诸尘劳埃　　法无应不应
  解道无形貌　　则无所坏除
  降伏诸魔力　　逮清净道法
  诸法莫有诤　　不起不有灭

时文殊师利说此偈已。应时五千怀狐疑者。心开意解获大光明。而得具成有起无所从生法忍。各取身衣供养奉上文殊师利。同时说言。愿令吾等致是法慧。所说若斯。开化群黎。分别深慧。无所挂碍。亦如仁者。

于是世尊赞文殊师利曰。善哉善哉。斯最妙胜。决诸疑网近佛圣籍。贤者阿难前白佛言。文殊师利。何所开化。而今世尊赞之如是。世尊则曰。文殊师利诱化无数百千人类令入大道。悉解了此深经之义。阿难白曰。唯然世尊。讲不退转轮入圣轨乎。佛言如是。阿难。讲不退轮兴化大道。所以者何。文殊师利则是善友。导利群黎。阿难又问。唯天中天。今此比丘立佛前者。悉怀持信奉法之念八等道迹往来不还无著声闻缘觉之想。此辈之类发大道意耶。世尊告曰。是辈懈废羸劣心曚无恺悌志难可开化。慢懈不进意在衣食。非习深法慕于法利。兴有为事愦闹之缘。感于八等迷惑卒暴。而不安详诸根不定。放逸其心贡高自大。志计有身及寿命人。不舍众瑕犯戒贪嫉想求佛法。悉从恶友乐于邪智。不肯奉受智度无极。顺从外缘贪利财色衣食之乐。古今以来夙兴夜寐。而不专精进违失道。义两舌恶口妄言绮语。其志怀害转共诤讼。重于罪福不信空无相不愿之法。蠲于众行不起不灭。坏一切法永无有想。此之谓也。于是佛默然无所加言。贤者阿难承佛威神。问文殊师利曰。何故世尊默而不言。文殊师利报曰。最于后末五浊世时。人法如是不信深经。佛故默然。阿难又问。颇有信者悉不信乎。答曰。信者少耳。譬如阿难明智者鲜愚冥人多。所以者何。不乐修行以故不了。如是阿难。其闻是法鲜有好喜多不欣乐。设有信者为众弃捐不见恭敬。所入郡国县邑墟聚诸人忽笑。所以者何。宿罪由致阴盖所覆本功德薄。阿难又问。向者讲说少有信者。义何所趣。文殊师利答曰。是辈之类则为舍佛不信大道。阿难白佛。唯愿演之。乐者虽鲜。闻佛所说悉当欣踊。尔时世尊周观四方。便出其舌覆三千大千世界。因从舌根出大光明。照恒沙等刹。时四部众承佛圣旨。目睹东方恒沙等国诸佛世尊。咸说此法不退转轮。是闻会者悉遥闻之。等无差别。四辈之会睹斯变化。一切等心异口同音。皆白佛言。唯愿大圣。遵崇所叹不退转轮。如佛所言诚不异。吾等目视。无量不可思议诸佛世尊讲斯深经等无差特。唯佛说之于是。世尊还呐其舌。告阿难言。厥妄言者。宁获斯舌。阿难启曰。不也天中天。奉至诚者开化正义。积累功德遵无数劫。阐于大慧乃致此耳。是故圣尊。惟当说之。设族姓子。有信乐者。学虽寡鲜。闻是说已。睹其明证。即当欣然兴之不废。佛告阿难。一切四辈未遭斯典。志于仿佛。比丘比丘尼。清信士清信女。天龙鬼神阿须伦犍沓和真陀罗摩睺勒。闻是经籍得不退转。当至无上正真道最正觉。而于此土讲于法义。等无有异。如我今也。尔时四辈及天龙鬼神。欣然大悦疑网永裂。皆手擎华香共散佛上。诸有女人下身宝璎以散佛上。心同意等普白佛言。今日大圣如来至真等正觉乃无二言。佛复告阿难。实如所云诚不有异。如来所演实无二言。除诸瑕疵愚冥之贪。假使慧觐佛天中天则获如愿。阿难问佛。何谓慧觐佛。世尊问之。汝不解之乎。答曰。不敏。安能及之。众祐告曰。假使有人闻能仁佛。皆不退转成佛圣路。所以者何。佛道普慧。有益无损除贪恚痴。岂况一华奉如来乎。吾灭度后。若持舍利供养自归。悉得如意。阿难又问。精进不疑专心听经。皆不退转当成佛耶。佛言。其有人闻能仁佛。皆当逮得无上正觉。所以者何。设不尔者。佛语为异。则有二言。佛问阿难。如拘类树荫五百车。若五百众处在其下。悉荷覆盖。其种大小。答曰。甚小。佛言。阿难。如拘类树其种小小。溉灌时节稍稍长大。而布枝叶广覆四远。况笃佛道闻圣尊名。亦当如是斯种德本。渐修其行非坏不腐。至于无上正真之道。所以者何。此一切法殖种之源永非猗住。群萌本无故不有败。一切法种无所倚演。阿难问佛。唯佛说之是圣本愿。诸佛世尊道法然耶。佛言。本发意愿。其闻我名悉不转退成最正觉。诸佛之法皆亦应然。所以者何。诸佛法等。阿难又问。设使等者何用愿乎。佛告阿难。菩萨大士闻说斯经。假使发愿或不兴愿。会当证明逮闻是法。阿难白佛言。未尝有世尊。斯法微妙。诸佛世尊。乃以大慧开化群黎。佛言。如是如是。阿难。诸觉洪明多所开化立于圣旨。吾于佛土。慈愍蚑行喘息之类。不惜身命。一切所有施而不吝。精进不懈。于一切法。而无所著。行菩萨法。积功累德。欲救众生。修深经籍。乃得佛道。阿难问佛。难及世尊。今说此经。弊魔不来废乱学者。不令兴德发于无上正真道耶。佛言。魔不闻之。所以者何。文殊师利神足之变也。于是文殊师利即释威神。时魔波旬遥于虚空闻讲不退法轮之声。听能仁佛所说法言。心怀恐惧衣毛则竖。口说此言以得胜我。共于力势以空余界。无复国土。愁忧涕泪老极憔悴。譬如百岁男子朽耄。时魔波旬体变如此。四部兵。合集三千大千世界。各各异魔及魔官属等类诸天。往诣佛所。兵仗严整。众魔之威。逼加菩萨。初成佛时。现于身老。执扙战痏面皱皮缓。置四部兵。住于虚空。普共遥闻不退转能仁佛音。心悉得定。时魔自知非我所有。孤独一身而无侍从。直前诣佛。白世尊曰。今吾一身都无侍从。羸瘦老极无将扶者。又无力势不能自胜。以空我界非有国土。如来大慈。咸哀众生。亦可怜我。世尊。尽度永空吾界。而无扶我给授水浆。佛告魔言。人种甚多不可思议。假使诸佛日日兴盛如恒沙等。发起无量不可称计亿百那术众生之类。人种不尽。魔白佛言。唯然世尊。人种虽多今吾孤独。不有徒使无扶接余。假令行道忽极躄地。不能自起。愿见安抚得欢喜悦。唯愿世尊。哀速抚育使眷属兴。佛告魔言。且自安志。不闻斯法离于信者。悉是汝伴。魔即欢喜善心生矣。意与口言吾当化人。虽闻是法。令不信乐。志怀狐疑。已有犹豫。必从我教。时魔波旬复白佛言。惟愿加哀。弘以大慈。重见慰抚。令吾踊跃无有忧戚。佛向者讲闻能仁名悉不退转。必当逮成无上正真之道。愿圣默然勿宣是旨。是群萌党。闻便加精进。立于大道。佛报魔言。汝且安心。勿得怀懅。当令众生不立道意。存于人种。人人各安。使不动摇。不震于色痛想行识。佛当开导不离邪见非立正观。及六十二诸所疑惑。一切无动。不念过去当来今现在。非离害群生杀盗淫嫉妄言两舌恶口绮语及嫉恚疑。亦不劝人入于正道。亦不化人。于布施持戒忍辱精进一心智慧。亦不教人。导奉四恩。惠施人爱利人。等利一切。救济合度。无所猗动。不想人种。无念父母兄弟妻子及与男女。释除亲友夙夜日月。一月半月。诸动之想。波旬且安。吾当劝人令除六度无极思想及大道意力无畏根力觉意八正之行佛法圣众及一切智道义之想。化诸群黎。于一切法使不动转。时魔欢喜。不自胜。即于其处。颜色窈窕面目光泽。华散佛上绕佛三匝。则偈说曰

  平等觉世尊　　吾心本欣踊
  正觉言无特　　所造必如意

于是魔波旬说此偈已即还天宫。与诸眷属五乐自娱。不复忧戚发大意者。世尊。说此降魔品时。三千大千刹土六种震动。阿难白佛今魔威德地大动乎。佛言。讲是降魔品时。六万四千人得不起法忍。阿难又问。宁有狐疑不了者。世尊曰。向者见此悉怀疑结。心各念言。余以闻之。此语何谓。何所归乎。不复相见。阿难白佛。惟愿世尊。速为众会现大光明决其疑网。所以如来为魔说之。波旬且安。吾化群黎使不住道。于是众生界。而不动摇。不发道意。无倚智慧。不舍邪见不处正观。于六十二疑。而不转移。亦无去来现在之想。非离杀盗贪淫妄言绮语两舌恶口及嫉恚疑。令不施与戒忍精进一心智慧不顺父母兄弟妻子。无有昼夜一月半月。离是众想亦非动摇。令不奉六度无极。及无所畏。根力觉意佛法圣众。并一切智。使不转移。波旬且安。吾当开化一切众生。使不动义不立于行。唯然世尊所因讲斯速分别之。使此会者无余疑结心开意解。及于后世边地诸国。遭值圣明禀受经典。持讽诵读勿复犹豫。尔时世尊则说颂曰

  圣道无所住　　慧轨非有处
  说此大义时　　人解及应造
  涂及一切人　　无二不有处
  佛以是故说　　今觉非有处
  莫能动众生　　人种亦如之
  一切不有形　　至竟无所获
  群黎类皆空　　人界不可思
  彼则普无念　　晓了一切慧
  众人不可动　　假名曰身命
  四大而合成　　此灭度空寂
  分别五阴空　　自然不有动
  灭度不可获　　设总而不移
  阴止无所震　　晓了不吾我
  离形寂然空　　究竟非有着
  身与五阴同　　衰行亦如之
  无行以为行　　诸阴犹虚空
  所谓寂定界　　不起亦不生
  斯诸阴盖入　　未能倾转者
  计己身吾我　　其法莫摇者
  尚不获曷震　　故佛说此言
  众生不侵欺　　计本不可得
  逮之而无心　　自然不可获
  所可云诸见　　凡有六十二
  无自然如斯　　犹如水中月
  其六十二见　　譬之若如影
  离有形无我　　自然不动震
  过去当来想　　现在亦如之
  诸想无处所　　譬之如野马
  是法空无念　　计人不可得
  诸众生无处　　则不可动摇
  其人喜杀生　　由入大旷野
  立志于灭度　　故不可动摇
  虽转于众生　　彼则无所有
  计日不可得　　则曰而不动
  说道有过去　　未尝有生者
  佛以了故说　　人而不可动
  假使杀生者　　法施无思议
  以乃成道慧　　彼则不可动
  所谓邪淫者　　爱欲无可得
  以故分别说　　彼则不可动
  其妄言之法　　起者不有脱
  精进而独尊　　彼则不可动
  两舌及恶口　　谗言亦如是
  观一切诸诲　　如幻如无形
  皆无有处所　　不可有所倚
  诸阴譬如响　　其念莫有者
  所谓不怀施　　爱己计有身
  圣道以无处　　彼则不可动
  分别于嗔恚　　自然不生想
  彼若不可断　　则谓不可摇
  晓了众邪见　　奉修于正法
  超度诸有言　　彼则不可动
  离劝助智慧　　一切宝清净
  愍哀着色财　　蠲舍众恶罪
  所见及奉戒　　舍远于圣道
  智慧不兴此　　莫求于正真
  异学怀邪心　　斯外诸忍辱
  等求平等道　　不倚于无为
  精进于三事　　异道之明说
  是不归圣慧　　此谓明智行
  多修于三昧　　倚一切诸想
  非佛之所叹　　亦不劝助彼
  爱欲之瑕痏　　非明哲之称
  得不兴众想　　佛慧不可量
  菩萨行勇猛　　摄取众生类
  则为说此义　　虽受无所动
  寂除众生想　　则发菩萨意
  道意无所起　　彼则不可动
  思父母兄弟　　姐妹及男女
  一切犹如幻　　彼则不可动
  一切是诸念　　计之无所有
  群黎法悉空　　彼则不可动
  其夙夜之想　　一月十五日
  一切除想念　　譬如野马水
  布施奉禁戒　　忍辱精进想
  一切于此念　　是诸想不动
  定意之智慧　　菩萨之道力
  修于无所畏　　释除诸妄念
  觉意及思道　　免去圣轨慕
  明智未尝动　　不为诸想惑
  佛法之所求　　如此众圣想
  无有若干念　　言行之所动
  佛慧无挂碍　　道想之所依
  则为远佛道　　佛圣非思议

佛分明说化魔品时。十亿之众坏除疑网。成就大明。逮不起法忍。得法忍已。一切同心。说此偈言

  弘道之尊圣　　佛轨忽无思
  为吾等大师　　道勖断狐疑
  具一切光明　　使住佛明道
  其耀照十方　　目睹亿千佛
  普见众庶元　　于色无所著
  蒙世尊之恩　　吾等法眼净

尔时百亿人众各脱身衣以覆佛上。供养大圣。则叹斯言。令一切人逮闻此法。光明具足所愿必获。阿难白佛。其有闻是开化魔经受持讽诵。为得何福。佛言。其福大浩。阿难复问。何谓为浩。佛言。若善男子善女人。则旦供养百佛。日中晡时。人定夜半。天晓肃肃。各各供养百佛世尊。一日一夜中合六百佛。一切所安随其所宜。如此比像具足千岁。其福多少。阿难言。福大多大多。天中天。不可为喻。佛言。假使是分别魔经受信不疑。德过于彼

佛说阿惟越致遮经卷中佛说阿惟越致遮经卷下

        西晋月氏三藏竺法护译

    如来品第十三

尔时三菩萨各从远来。见此变化佛所演法。得未曾有。阿难白佛。此三菩萨。从何所来。世尊告曰。东方去是恒沙等刹有世界。曰身超须弥山。住在本土。闻说斯经。故来到是。时三菩萨来住佛前。皆以香华供养世尊俱白佛言。余等佥然信乐斯法不怀狐疑。所以者何。心中[火*霍]然。譬如目睹。如来至真等正觉恩之所覆。时一菩萨前白佛言。如我所言。至诚不虚。吾于是经都无狐疑。第二菩萨复白佛言。余于此法亦复不疑。第三菩萨复白佛言。我之所言至诚不虚。所谓佛者吾则是佛。晓了斯经无有疑网

尔时众中无数百千诸来会者。悉共叉手不乐本座。佛兴于世。此徒何故乃宣斯言。其余众人各各默声。各心念言。今佛现在自当分别。阿难复白佛。此等菩萨皆号云何。佛告阿难。一菩萨者。名得如来住。第二菩萨。名志得世尊音。第三菩萨。名志逮得佛声。如是阿难。如彼所言。等无有异。其义趣此。阿难白佛言。今此无数百千之众扰动不安。悉各叉手一心向佛。不知斯义为何趣也。是辈功德转当增加。譬如男子。端正殊妙颜貌洁白。净水自洗。以栴檀香熏浴其体。着好衣毕。其人体色益自光耀。是辈功德信乐大道。叉手向佛福转难及。佛尔时说颂曰

  如来知过去　　当来亦如是
  见诸法本无　　故曰为如来
  悉达现在事　　未来悉睹喻
  不造立三行　　究竟如无想
  如往古诸佛　　所觉不可计
  无从来一等　　故曰为如来
  如往古诸佛　　所猗求圣道
  觉者亦当然　　故曰为如来
  诸法本所立　　道声寂然定
  音归不可得　　故曰为如来
  专应过去戒　　当来亦复然
  现在获本无　　故曰为如来
  如勇猛忍辱　　为菩萨之人
  彼学亦如是　　此人则无上
  本为菩萨时　　获勤力如是
  志所行精进　　故曰为如来
  如诸法平等　　所说无特异
  不着念在有　　故曰为如来
  平等不有念　　常自然等正
  无有平等想　　非思莫发念
  本无成三昧　　具足此音声
  遵修于定意　　故曰为如来
  诸法悉本净　　本无不有处
  一切无所称　　因缘不有形
  晓了智慧相　　明空法亦尔
  至诚无所疑　　智慧度无极
  如圣之所度　　逮本无思议
  彼明不可得　　则无量灭度
  犹获智慧爽　　过度亦复然
  以是慧无处　　故曰为如来
  佛道不可获　　如意之所念
  不得一切法　　故曰为如来
  获致于无为　　假使多所逮
  诸法非有数　　叹道不可限
  世尊之威耀　　无有修轨迹
  彼道则雅谛　　悉从智慧兴
  道尊如无漏　　各分别如是
  彼道则正真　　涂志应自然
  有晓了圣化　　法所御平等
  将令至本无　　故曰为如来
  圣与平等同　　所住顺明轨
  道与身本无　　故名为如来
  今吾讲说法　　声平等如是
  假使住于斯　　尔乃求大道
  我是故阿难　　口出是语耳
  此事如所言　　则为识之行
  晓了不退转　　则勇猛菩萨
  故以修精进　　赞扬其义耳
  阿难是因缘　　菩萨志所演
  所以谓如来　　勇猛菩萨智
  顺此诸因缘　　其法为何类
  何因谓世尊　　菩萨修无畏
  讲道亿百劫　　所因成大圣
  佛道无思念　　成就慧明迹
  皆自为身求　　永睹无所畏
  故曰为世尊　　未尝惧生死
  终始无所立　　以是度群生
  故曰为世尊　　何谓畏生死
  云何住终始　　何因度众生
  世尊最上觉　　无道利法者
  法亦不有坏　　非坚无有散
  度人勤苦患　　是不畏生死
  此非住终始　　度群黎如此
  故曰为世尊　　未曾惧诸法
  永不畏诸义　　及一切佛经
  令闻无数法　　非底不有边
  众生法悉空　　诸佛道自然
  不睹诸法本　　即依顺此经
  专精于诸法　　智空法自然
  不恐无所畏　　晓了道慧空
  知诸法侵欺　　分别无所猗
  精进次第演　　则解诸法本
  勖勉一切难　　弃捐众恶道
  未尝有恐惧　　免众生恶涂
  过度亿人民　　越终始大惧
  常不动生死　　尔乃度群生
  过之度彼岸　　至上尊无为
  得致号之人　　故曰为世尊
  为人分别说　　说法犹虚空
  亦不有畏难　　故曰为世尊
  因依一切法　　多所而开导
  道平等无异　　圣则不可获
  众生等于彼　　则逮成佛道
  分别说如此　　则无所畏难
  开化闭鬲人　　度无数群生
  超越诸所畏　　故曰为世尊
  释去诸人想　　专修于道念
  拔除群萌志　　故曰为世尊
  得离众思想　　菩萨无所慕
  以故得号字　　则亦谓世尊
  寂灭致等法　　晓了一切义
  当来所立志　　则亦谓世尊
  不求上妙道　　彼亦不求名
  若脱无为称　　为人讲经义
  道舍众憍慢　　则不有立愿
  人求尊名称　　则不慕佛道
  计音如响等　　因兴众想念
  贪着虚伪声　　我名誉乃尔
  不存一切响　　口言无所著
  菩萨不放逸　　故曰为世尊
  大圣所说音　　如是譬像法
  假有菩萨号　　故曰为世尊
  以故当了之　　莫不迷惑者
  至诚求佛道　　无数无有漏
  是缘乃余事　　叹说世尊音
  阿难知随因　　而号为菩萨
  我是故阿难　　口出此语耳
  所缘诸明智　　佛号为世尊
  觉了众尘埃　　未尝为之惑
  平等觉除欲　　是故号曰佛
  何以为世尊　　显示斯名号
  曷从言白佛　　而讲说道法
  佛法无所有　　晓了空寂灭
  一切无有着　　故号字为佛
  觉了体悉空　　见体无所属
  彼不有坚固　　身不可久得
  愚騃离慧明　　不要谓常要
  觉此悉本无　　故号曰为佛
  分别无明慧　　自然不有形
  逮得大圣智　　故名曰为佛
  过去所兴想　　分别学无想
  晓众想无处　　不为念所惑
  觉知往古色　　无生不有处
  愚者为想惑　　计色无所成
  分别色本无　　不可得根源
  不着一切法　　则无有痛痒
  晓想譬如幻　　无物不有形
  已分别斯慧　　一切法如是
  总持无所行　　一切身无古
  空义非有御　　故身不可得
  人身不坚要　　若如芭蕉树
  悉分别此义　　故号曰为佛
  其识自然空　　计身无有内
  外亦不可获　　识之何等类
  睹识无所有　　一切法亦然
  不得处形貌　　究竟不可获
  识之所知然　　计本悉等寂
  若了晓想者　　则莫有所见
  明不作是观　　一切人亦然
  群生萌类同　　以故无能知
  自然不有启　　诸法无所行
  一切莫有受　　人法亦俱然
  一切法忍过　　觉了未尝生
  无若干放逸　　故号曰为佛
  晓了佛众经　　所经如正谛
  一切法无处　　故名号曰佛
  如空谛法尔　　所觉经本无
  犹佛道无异　　莫能得根本
  从始发意来　　所因志大道
  则了不有志　　诸法无所获
  何缘发其志　　而慕求圣道
  其心与道同　　觉了无形类
  吾以故阿难　　演出此经耳
  所因讲圣轨　　吾为佛道师
  以斯法像类　　其音号曰佛
  假使作彼教　　乃为求佛道
  则得近正道　　其知是法者
  不复怀二心　　一切法如是
  不疑佛经籍　　则致世最上
  若解此讲者　　普说法若斯

佛分别说此如来世尊佛义之时。则无央数百千人众。前白佛言。吾等除疑无复结网。所以菩萨因由得名。号之如来世尊为佛。晓了此法。自逮见心。一切法空。人为之惑。父母妻子恋恨恩情。如来手授深妙之义。其心坚住不复轻发。了不动法。如空不摇。无能震者。如是世尊。一切诸法无所转移。所以者何。诸法如空。尔时无数百千之众。稽首佛足绕圣三匝。则还复坐

    阿惟越致遮经开化品第十四

尔时有菩萨。名诸根常悦。说是颂曰

  众人兴果想　　救济于异念
  平等于实道　　稽首世明智
  常讲说德实　　演果为平等
  得平夷正觉　　稽首世明智
  无数人贪果　　猗行众生实
  佛悉度此等　　稽首世明智
  说法无差特　　所住而正均
  觉诸法平等　　稽首世明智
  人多慕德果　　勖勉令不着
  解脱众颠倒　　稽首世明智
  所兴德具足　　使众坚住道
  成就一切德　　稽首世明智

于是诸根常悦菩萨。说偈赞佛已。绕佛三匝。去佛不远瞻圣尊颜。不以为厌心开意悦。于是莲华首藏菩萨。即从座起。莲华散佛已。赞曰

  众人皆怀想　　度脱诸所著
  永离于恐惧　　稽首上能仁
  寂除一切处　　说法无境界
  英雄超诸受　　稽首上能仁
  尊解诸法空　　自然无坚固
  平等法越难　　稽首上能仁
  断除诸根株　　众生着尘劳
  勉济使无畏　　稽首上能仁
  无恐而不惧　　为大师子吼
  超度诸境界　　稽首上能仁
  无有众忧患　　戚恼已永尽
  心除远凶害　　稽首上能仁

莲华首藏菩萨大士。赞佛已讫。即白佛言。若人行此当为作礼。最后世时闻是深经。智慧明达未曾恐惧

复有菩萨。名离欲迹。前白佛言。假使有人。闻此深经欢喜信者。则谓明智。当以华香夙夜供养

复有菩萨。号曰广心。前白佛言。说此经法尊兴佛道。不疑此者德不可量。致供养利其心坚固。信是经者。所愿者得。其不信者。为魔所固。则随魔行。复有菩萨。号曰莲华目。前白佛。而赞颂曰

  若信是经者　　为世作眼明
  无有狐疑心　　指示人道路

复有菩萨。名心信悦。佛前颂曰

  闻斯经法者　　欢喜信为上
  是等之人辈　　则为世神明

复有菩萨。号喜神灵。而说颂曰

  其闻是经者　　信之而不疑
  为世之威神　　人中之上尊

复有菩萨。名曰常戚。前白佛言。而说颂曰

  若有疑是经　　当为兴悲哀
  志在虚妄法　　则数数生死

复有菩萨。名曰宝衣。而说偈曰

  无数亿衣服　　清净善微妙
  疾化度尊长　　令未曾狐疑

复有菩萨。名曰禅食。佛前说颂曰

  其信此深经　　当为施美食
  一切味具足　　专精大圣行

复有菩萨。名曰见人住圣。佛前说颂曰

  其疑是经者　　当为兴悲哀
  啼哭堕泣泪　　不信深经法
  或从地狱来　　或还入恶道
  用须臾之间　　狐疑此像法
  为恶友所摄　　不解深妙义
  为疑网所缚　　以故归非处
  则不顺正戒　　观嗔恚怀恼
  于是所住时　　喻之如凶兽
  既不修道术　　懈怠不精进
  信邪无智慧　　不信此典籍
  慕终始群生　　着吾我恩爱
  猗在三界患　　不信斯微妙
  怀害为愚冥　　着在欲所乐
  贪猗自见身　　诽谤是道教
  志慕好衣服　　追逐美饮食
  少存清白法　　故诽谤斯经
  人在乐欲界　　贪慕无德实
  其人则自远　　不近于世尊

复有菩萨。名曰弃恶法。佛前说颂曰

  当弃是辈人　　譬如远溷厕
  愚者疑此经　　猗界而求脱
  当共远离之　　犹若死臭尸
  其疑深经者　　远之当如此
  有人诽谤者　　如贼危聚落
  则住在冥处　　见恶意舍走
  观此即当驰　　是贼凶恶物
  若诽谤此经　　不见意无乱

尔时阿难前白佛言。未尝有天中天。是诸菩萨分别经慧。乃如是乎。因三昧力说是语也。承佛圣旨晓了之乎。佛言。承佛威神缘此经义。得三昧力逮至无为。所以者何。今是住者。族姓子等。于六十亿诸佛闻此经籍。信乐赞诵。亦如于今志三昧力。承佛威神讲此经。所以者何。如彼所言。等无有异。则为明证。阿难问佛。其闻是经。即欢喜信而不狐疑。族姓子族姓女得何福祐。佛告阿难。族姓子族姓女。志求无上正真之道。假使七宝满此天下。施与如来。若复有人。闻此深经即欢喜信。非以疑狐。福过于彼。佛言。置是满天下宝。如恒沙等诸佛世界满中珍宝供养如来。其闻此经欢喜信者福过于彼。佛尔时颂曰

  假使是天下　　七宝满其中
  以供施如来　　世尊成谛慧
  智人闻是经　　信乐不回动
  此福最为上　　其德不可限
  使如恒沙等　　诸佛界如是
  供养圣世尊　　不及闻是经

阿难白佛言。族姓子族姓女。闻是经法而欢喜。信持讽诵。其福如何。佛言。若族姓子族姓女。求无上正觉。百劫供养如来。布施持戒忍辱精进一心智慧。又得五通。各各百劫晓了世间。无所复疑。不受此经。其人则为不供养佛。佛尔时颂曰

  若具足百劫　　奉供养世尊
  饮食普备悉　　则不供养佛
  其受是经者　　则奉于大圣
  舍离猗道想　　法供养诸佛
  如此顺尊教　　乃为奉事佛
  法供养等觉　　如来则法身
  假使满百劫　　选择好衣服
  奉世尊正觉　　此非供养佛
  其受是经者　　乃为尊恭肃
  此应奉事佛　　胜以衣被服
  若于百劫中　　明珠好华香
  进世尊等觉　　不应供养佛
  设有受此经　　皆除猗果想
  是则为供养　　世尊最上慧
  若起七宝塔　　为世雄兴立
  皆高如须弥　　不为供养佛
  假使受此经　　不自睹吾我
  是供养最尊　　一切无有上
  若具足百劫　　有人奉禁戒
  不持此经籍　　彼戒无名闻
  其受是经者　　此戒大名称
  若奉清净戒　　此戒无有上
  无量不可议　　明智顺是经
  因缘而奉事　　其禁常备足
  彼禁悉究竟　　不谓之毁戒
  其学是经典　　即当如上教
  其不学是经　　则非求佛道
  奉圣虽具足　　则亦无所学
  修戒如是像　　分别此经义
  其持是卷者　　禁戒则具足
  假使百劫中　　一心奉忍辱
  设有嗔骂者　　皆忍一切人
  若受是经者　　闻持而讽诵
  忍此最为上　　微妙不可量
  或断手足者　　心未尝怀恨
  不厌不以剧　　其心初不起
  如是之忍辱　　行之于百劫
  遵行如是者　　此忍无有持
  若受是经者　　闻持而讽诵
  此忍最为上　　微妙不可量
  苦持是经卷　　其忍最为上
  巍巍无等伦　　则不有虚伪
  不断至诚教　　佛慧莫有上
  非轻毁此经　　一切逮如愿
  假使百劫中　　精进不懈怠
  夙夜兴不寐　　一切得如愿
  若修学此经　　讲说成明智
  是精进为上　　勤修无踰者
  若满百劫中　　为五通神仙
  不逮闻是经　　则为无神足
  假使受此法　　分别而无著
  神通为以达　　一切莫有上
  设于百劫中　　修奉于智慧
  超度世间明　　娱乐所猗行
  如不学此卷　　则不成智慧
  斯圣达勇猛　　能持此深经
  此者则道智　　晓了圣明慧
  若闻深经要　　欢喜受奉持
  有分别深慧　　晓诸法所趣
  当从说是经　　此像之智慧
  修习正经典　　一智无有二
  故修精进行　　顺持要经籍

尔时贤者阿难。于佛前说颂曰

  假使四千里　　若远四千里
  则往听是经　　顺度佛德果
  便往到其家　　不以道为难
  智者当速行　　所在推是经
  其欲速禅思　　越度诸一切
  诵说此经道　　受持解其义
  设求一切安　　志慕菩萨行
  讲说是经典　　则至安乐国
  得睹平等觉　　阿弥陀无念
  而修随经义　　一切佛所演

佛言。善哉善哉。阿难。审如所言。等无有异。族姓子族姓女。赞此经者。讽诵之时。其心不乱。离一切想。自在其舍。见佛世尊。赞经不乱。临寿终时。目睹无数诸佛世尊。所以者何。族姓子族姓女。一切诸佛皆救护之。受持是经。而读讽诵之所致之也

    阿惟越致遮经师子女品第十五

尔时私休童女。与五百童女俱问佛言。唯然世尊。女人若学是经卷者。获何功德。设讽诵读。福何所趣。佛言。女人若求无上正真之道。欲学此经。观余女人。所以者何。若学此经专精不乱。不效他女贪于尘劳。犹是之缘致女人身。私休又问。何谓女人之尘劳也。为欲所惑奚受女身。答曰。若有女人。见他妇女端正姝好宝璎珞身。不以愿乐。自观察已。譬如秽厕。心不乐欲。造污路观。不以为清。若贪乐是。则受女身。又计女人多怀嫉妒。心口各异。而不相副。不应前后。虽见比丘。但求名闻。不用经法。多怀嗔恚。喜会人客。未尝利求如此像经。若读诵者心在着求。其志愦乱游于尘埃。以是之故。受女人形。不能除罪。此以女人。设除爱欲。不兴邪想。受此经本。持讽诵读。所以者何。是深尊经。除女尘色。又问。假使女人。不愿其身。受此经法。持讽诵读。以何因缘。转女像耶。佛言。欲转女身。受此经籍。持讽诵读不愿女人。常畏秽之。譬如有人见大炽火自投其中。而口说言。莫令火烧。无使伤肌。于童女意云何。彼人言尔。宁得愿乎。答曰不得。天中之天。所以者何。计于火种主有所烧。烂坏肌肉不得无伤。佛言如是。此经亦然。烧尽尘埃爱欲无余。设使贪着情欲之态累世自危。是故女人欲转是身。速当究竟成于圣道。见无央数诸佛世尊。备无量辩。当受此经持讽诵读。私休童女及五百人俱白佛言。吾等省念。世尊。往古从定光佛如来至真等正觉。受此经本。持讽诵读。为无量亿百千之众演说其义。阿难白佛。此私休身虽为女人则非女也。所以者何。今吾最后而目察睹。私休童女示现变化乃如是乎。愍伤女人欲以度脱。摄诸男子不见处所。以是感动化众女人。佛言阿难。其私休者。非男非女无有此法。所以者何。观诸法本。不得男子亦无女人。一切诸法皆无可获。等不差特。所以者何。如是计之。非男非女。私休童女分别此经。无所挂碍逮得法明。是故阿难。若有女人欲求男子。当顺私休修行之法。受是经卷持讽诵读

尔时五百比丘尼前白佛言。吾等之类。从今日始受是经本持讽诵读。不乐女人秽厌此身。从今以往不复座寐。讽诵此经通利乃定。时佛赞曰。善哉。是之所说讽诵斯言。被大德铠通达精进不慕女像。是故仁者。益加勤修受此经本持讽诵读。时比丘尼。闻佛所说欣然大悦。即脱身衣以覆佛上。而叹颂曰

  我今日得乐　　望为男子身
  正觉言无异　　必获世上尊

于是五百长者妻。闻比丘尼被是德铠。即从座起前白佛言。唯天中天。吾从今始受此经卷持讽诵读。愿令我等获得自在。不系缀人莫察他颜。离于魔使难固之患。所以者何。正使女人生于王家。则有所属不得自在。尽其形寿给事夫婿。是故我等今日始遵精进。假使有人。说此经中一句之义。不敢诽谤。至穷命尽不近夫婿。令我等读解此经。于时世尊。赞长者妻言。善哉善哉。是女人等。今于佛前大师子吼。此言甚佳被无极铠。如人所志不察他颜。不负重担十月怀躯。亦不加遭而入胞胎。所生佛国清净佛土。无女人处莫有瘕疵。阿难问佛。此诸姊等所生世界。其号云何而无瘕疵。佛言。世界号宝莲华藏。当生彼土。又问佛言。圣号为何如来至真等正觉。佛言。佛号一切诸宝妙珍之光如来至真等正觉。现在说法。是长者妻学此经籍。见彼如来。时长者妻。欢喜踊跃善心生矣。即解颈着百千之宝七宝珠璎。以散佛上。同声说偈言

  今日获大望　　当弃女人身
  等觉言无特　　口演至诚语
  当除此愚形　　女人殃罪体
  痴騃志贪着　　不解知本无
  非更于胞胎　　除去所受身
  逮得无上义　　未尝有所处

时长者妻说是偈已。瞻仰尊颜。目未尝瞬

    阿惟越致遮经叹法师品第十六

于是天帝释则取天华已散佛上。而白佛言。唯然世尊。吾以奉受此微妙经。答曰。是故拘翼蒙此经恩。天阿须伦不兴战斗

于是文殊师利。欲以开化无数百千人民之众。使立德本。前白佛言。如来至真等正觉。本发道意而讽诵此大法之本。佛言。是故仁者。于不可计百亿那术菩萨最尊光明智圣。普遍十方诸佛之土。犹日宫殿无所不照。说是语时。此之国土六反震动。遍雨天华。阿难白佛。地何故动而雨天华。佛告阿难。无数亿天闻文殊师利之所赞咏。心怀踊跃。散此天华而兴立愿。吾等亦当受此经卷。逮得道慧。如文殊师利。适说此言。众罪悉毕得近此经。以故欣然稽首佛足。复礼文殊师利。是故地动。阿难问佛。是经之德广大无极。其闻此经。其得不小不可妄遇。佛言。如是阿难。族姓子族姓女前后供养无央数佛。尔乃逮闻是经法耳。若闻信乐受持讽诵。则为天上天下圣神。佛语阿难。假使是经所流布处。则不虚妄有佛比伦。若有受持讽诵学者。则坏罗网降伏弊魔。则逮法瑛而演法明。勖勉众冥得至道场。若有从我闻是经籍。欢喜受持而讽诵学。则为佛子从法身生。欲服圣食坐于佛树如吾坐时。讲说经法如佛所演。当受是经持讽诵读。阿难问佛。惟愿世尊。说当来者。后岂有人受此经法持讽诵读。佛言。阿难。于今现在佛前信者。彼人后世乃信之耳。受持讽诵。佛观天上天下人间诸魔梵天沙门梵志诸天人民及阿须伦。不闻是经。后世闻之。而信乐者未之有也。于今闻者后乃信耳。譬如长者及长者子。财富无数。独处藏宝。行到他国。于阿难意计之云何。其人藏宝不还得耶。答言。得之。所以者何。知其藏处求辄得之。佛言。如是。今闻是经后世归之犹取藏宝。如佛于此道眼睹之。其今现世闻是经法欢喜信者受持讽诵。后世必获亦如是。阿难。汝坐佛前。听是深经

    阿惟越致遮经讥谤品第十七

尔时阿难白佛言。其闻是经而不信乐。呰毁诽谤罪何所趣。佛告阿难。汝且默然用是问为。阿难白佛。愿佛说之。若不信者。闻诽谤罪或能自改。佛言。得五逆罪。又复加害三千大千世界人命。其罪云何。阿难言。甚多甚多。天中天。凶殃无量。佛言。诽谤法者。罪至于此。若复有人破坏损毁恒边沙等佛之塔寺。佛泥洹后火烧寺舍。罪宁多不。答曰。甚多甚多。天中天。是辈之人不当见闻。佛言。阿难。当为其人现说此罪。若复有人毁乱灭尽过去当来现在佛法。其罪如何。阿难言。其罪甚深不可称计。佛言。谤是经者其殃如斯。若止余人使不学者。罪当奈何。佛言。假使三千大千世界众生。修行十善。又发无上正真道意。若有一人尽挑其眼。彼罪何如。阿难言。其罪甚多甚多。天中天。无央数劫中常当生盲。又泥犁火烧之难竟。佛语阿难。我故语汝殷勤嘱累。假使有人。诽谤禁止一人。不得为此法。罪踰于彼。阿难又问。若复有人发求大道。狐疑是经亦不诽谤。罪何所趣。佛言。其人发意前后狐疑若干之数。常当违远诸佛世尊随其疑数。又从疑数更若干劫乖阔道教。阿难白佛。若不信喜。禁止众人令不学之。其人受殃身大小加受罪多少。佛言。且止阿难。用是问为。阿难白佛。愿世尊演说。此四辈中或有尔者。及当来世边地之土诸大国人闻是经法。多有疑者。当令信解不复诽谤。佛言。其人身当长一万垓。周遍勤苦毒痛不可计之。阿难问佛言。其舌大小。佛言。其舌广长各四万里。驾犁耕舌五百亿载。各五百亿岁。当吞销铜其火焰赫。及雨身上烧炙缹煮。所以者何。此不护舌之所致也。于是四辈诸来众会。衣毛皆竖泪出而惧颠倒躄地。同时举声求哀悔过。当为是善男子善女人请救其罪。乃当毒痛若干之恼。其身长大苦不可言。复有余人其泪流面前。白佛言。不能自察今世后世心起狐疑。今现佛前及违十方诸佛世尊经籍之教。阴盖所覆不自见过。今悉自归佛前。首罪不敢覆藏。惟佛原之。譬如愚騃无知之人。乖其理政自睹罪咎。惟佛大哀愿见原赦。佛告四辈。善哉善哉。族姓子。族姓女。疑于是法观己过罪。悔彼殃衅犹日除冥

尔时阿难前白佛言。今此众会志怀狐疑。亦当复获如此罪耶。佛言。阿难。虽怀狐疑今复悔过。是辈之罪犹当轻微。阿难又问。愿佛说之。佛言。临寿终时遭地狱痛一一毛孔。当更无数不可计患。犹是余息。所以者何。在于佛前舍疑悔过。加及十方无数诸佛哀施恩德。是故阿难。善男子善女人当自察之。得身如此遭无量痛。闻是经卷欢喜不当狐疑。其不欲舍佛法圣众。去来今佛圣法之教。当信是经持讽诵读

    阿惟越致遮经嘱累品第十八

贤者阿难白世尊曰。诸佛大圣。悉等同一说不退轮乎。佛言。如是。等无有异。阿难问佛。假使诸佛同等讲不退轮。何因大圣向者说言。假使有人不欲违远佛法圣众。佛所兴显去来今佛。不当远离此经之卷。阿难又问。佛说法何所光兴。佛言。不退轮众。为显佛法。合集聚会。不退转种。如来所演也。阿难又曰。诸不退转菩萨大士应圣众乎。佛言。阿难。清净正意发大道心。观察此意。是辈皆应不退转众。阿难白佛。至未尝有。诸佛世尊善权方便。随时之义显扬大道。尔时天帝释即以天华散于佛上而叹颂曰。令一切人承善权方便演说经籍。佛言。拘翼。其闻是经欢喜信者。此辈之人犹当以此善权方便。说法开化多所发起。亦复如我等无有异。尔时有无数诸天之众。皆以天华供养世尊俱说斯言。令一切人逮得此法。阿难白佛。惟愿世尊。建立大慈。令是经卷后世人蒙之。佛告阿难。善男子善女人。来在此会。后世必值得是经卷。假使差跌在大海中。应得是经毕当闻之。所以者何。过去诸佛之所神变。摄是经法。阿难白佛。虽为过去诸佛威神。亦复现在今者如来至真等正觉之所建立也。说是语时。三千大千世界六返震动。应时佛前无央数亿百千之华。众宝莲华自然涌出。普光众会各照十方恒沙等国。尔时会者。遍见十方恒沙等刹。佛世尊前有宝莲华。亿百千叶。无不达者也。时天帝释自变其形作长者身。擎若干等华分布四辈。而说此言。愿持此华已散如来至真等正觉。又加供养此深经义。四辈如言。各各取华散诸佛上。众会皆见所散之华。在诸佛上化成华盖。应时四辈各白佛言。此何本瑞。光明巍巍乃如是乎。地大震动。又众宝华化现在佛前。所散诸华。一切佛上变成宝盖。佛言。阿难。皆是经卷之变应也。故当知。建立此经。流布一切。受者则思。尔时阿难复白佛言。今者世尊。圣旨之德建此经也。佛言。如是。建立护以及现在佛。亦复若此。等无差特。阿难问佛。今此经卷。所名云何。如何奉持。佛言。阿难。是经。名曰不猗果实除德迹想。又名持信奉法道迹往来不还无著声闻缘觉也。又名开化弊魔。又名遵奉六度无极。当持。所以者何。闻此经若信乐者即当具足六度无极。阿难又问。云何信乐而奉持者具足六度无极。佛语阿难。若族姓子族姓女。信喜是经不疑布施则度无极。不毁失戒则禁无极。在所忍辱则忍无极。亦不应懈怠离于怯弱则进无极。所为兴立如不轻举则禅无极。一切无念等于诸法则智无极。是故阿难。说是经卷号之名曰六度无极。又名不退转轮方等之法。阿难白佛。唯然世尊。闻是经名则为大饶益。何况受持讽诵者乎。佛言。如是难值。阿难又问。闻是经名能超几劫。佛言。阿难。闻是经不退转轮。欢喜信者。则当越除无数千百劫终始之患假使又闻。弃除贡高。信发道意。是辈云何。佛言。阿难。佛皆授决。得为无上正真之道意也。尔时四辈众会人人其前。化有莲华光色无量。一一华者。有无央数百千诸华。各怀悦豫。则取莲华供养世尊。同音叹曰。愿令吾等值是法世。亦效如今分别说之。时佛即笑。便有伎乐而自然鸣。香闻十方。无数千天空中雨华。栴檀粟金及天心华。诸天之衣散世尊上。贤者阿难。长跪叉手前白佛言。佛不妄笑会当有意。佛语阿难。今诸四辈。天龙鬼神。人及非人。闻是经者。后世所生。辄值此经演说其义。如我今日等无有异。佛说是时。贤者阿难。文殊师利菩萨。诸天世人。莫不欢喜

佛说阿惟越致遮经卷下


佛说法华三昧经一卷

    No. 269

佛说法华三昧经一卷

        宋凉州沙门智严译

佛在罗阅只耆阇崛山中。与诸尊弟子比丘千二百五十。菩萨七万三千人。诸释梵不可复计。十方飞来无央数。皆神通妙达。复有他方恒边沙诸天人及诸菩萨。如是等百亿千恒沙。皆来会在佛前坐。时舍利弗须菩提等诸尊菩萨。皆有疑心念言。何因缘诸上人。皆来在是间会。有何异要之瑞应。尔时诸弟子。起疑心念。为佛作礼长跪欲问佛。佛时已放无数光从口出。若千亿亿稍稍引大遍虚空明。远照恒边沙刹土。地复震动。于是尽明。即不复见佛身相。大众愕然。共议佛三昧为何所之趣。各自思之。即便还坐三昧。求佛至处座前有菩萨名慧相。便报言。善哉善哉。当尔贤者。思惟了不知所至处。须臾罗阅王后宫太子皇女及婇女夫人。三万二千人。皆从共来诣山中到不见佛。复有不想菩萨。问王将从何多。王名辩通。答言。见佛光明故来耳。王女名利行。便问菩萨。佛今所在为到何方。答曰。向已求佛。了不知。处女答曰。卿是佛第一神通者。应当知处。菩萨答曰。且坐。须臾顷。地即震动。从地中出。坐自然大宝莲华上。众坐上人愕然。王女利行。起为佛作礼讫。住佛前说偈问佛

  向见大光明　　疑佛有异要
  故来将大众　　欲问心狐疑
  反更不见佛　　意甚有怪惊
  愿得具为说　　当令大众解
  各发一三昧　　推求佛身相
  了言不知处　　各共坐作议
  更起何三昧　　毕欲求佛意
  女来问众等　　佛今为所在
  纯行有至心　　必欲有所问
  愿见世尊授　　令意解狐疑
  具为现众等　　分别解说之
  向所三昧处　　所名在何所

佛语女利行。所问甚深。当为汝分别说。向所三昧。名法华。譬如大国中有一树。有一华覆三千大千刹土。其香熏恒边沙佛国。若有人。得闻名字若知解。自然疾得是三昧。若诸病痛者。得闻是三昧。应时自解。人根众病消尽。女利行问佛。何谓华之威德。乃有是慧。佛语女利行。华者一树之色。人见莫不爱乐。欲得之者。法华三昧是。生死中之色。大光受有形。人不知不闻。不信是三昧。不奉行之。未应菩萨不见慧。失人之本。反随沫流。终已不见明。女利行复问佛。今欲得是三昧。行何法。有几事。行得人中。愿佛弘慈恩润。广开行议。令一切闻解。皆入三昧中。佛言。善哉善哉。多所度脱。永度无极。有二事。何谓为二。一者知法身如幻如化。二者知淫怒痴无根无形。佛尔时说偈言

  法身有一切　　化幻现沉浮
  淫怒痴无形　　如水现泡沫
  观察人身物　　如灭无形住
  离散合自成　　分别计皆空

佛语女利行。复有四事。别如行三昧者。何谓为四。一者行戒无色想。二者行檀无受者。三者不厌无乱者。四者行智无愚者。是为四。佛尔时说偈言

  不犯戒无毁　　行檀不入智
  不厌无痴乱　　不愚无智慧
  不说无行者　　有行不言向
  三昧可得入　　无处无中边

佛语女利行。复有三十六事。是为三昧所见事。何谓三十六事。不见生不见死。不减不增。不出不入。不在外不在内。无住无止。无水色无火色。无风色无地色。无痛无痒无思无想。无生无死无识。无贪无淫。无嗔无恚。无愚无痴。无悭无施。无恶无善。无心无意无识行。不起上若干事。不灭上若干事。如一无形像。是为三十六事法华所见事。佛尔时说偈言

  不想念无念　　不行色想要
  无行法华净　　空寂无吾我
  不处有入中　　没灭无形像
  不观善以恶　　俱皆空自然

佛告女利行。法华三昧所见。譬亦如是。佛说是三十六事品时。无数天人及世间大众人。及王所侍从。大小合有四十亿万。皆发无上正真道意。女利行及后宫人。三万二千婇女夫人。逮得无所从生法乐。于中立女。见众人皆发道意。心甚欢喜。起为佛作礼。绕佛三匝。住佛前说偈言

  世尊实神妙　　演知三世事
  断世淫怒垢　　开化沫流人
  皆到无为城　　快乐乃安宁
  如是天人中　　地为大动倾
  今日合大众　　亿亿百万千
  当来及过去　　现在得自然
  愿得大普恩　　法华威神力
  三界一切人　　皆得是三昧
  令我值在世　　常行法华事
  使世无老死　　快乐无忧患
  三苦自然除　　皆如为三昧
  空想于愿识　　自然现相好
  教授沫流人　　得意慈普行
  光光威仪好　　等为身如来
  合聚于沫生　　三昧豫生行
  便使于空中　　得慧如上首

女利行说偈已作是念。今欲教授人。不见法则。何事开解人。佛即知女心中念。便语女。欲持何法。教何人法。复何所在人。复何所止。立女白佛言。如是所说。无法无教无人。佛语女。无法有八事行。无教有六事除。无人有七事散。女问佛。何谓八事行六事除七事散。佛言。一者直见不邪。二者直闻不听。三者直治不曲。四者直说不烦。五者直行不迷。六者直念不思。七者直意不动。八者直受不寻。是为八事行无法。何谓无教六事除。一者不念有见无见无。二者不念有声无声无。三者不念有味无味无。四者不念有香无香无。五者不念有触无触无。六者不念有意无意无。是为六事除。何谓无人七事散。无水色。无风色。无火色。无地色。无心色。无识色。无行色。是为七事散。无人可教。当作此解。佛尔时说偈言

  若有解法华　　三昧要句品
  当念勤精进　　晓解得正言
  七八六已足　　计本无形迹
  不受自可欲　　去想安寂然
  说法无言教　　不见有寿命
  人本空无寂　　不解沫言有
  不除不断欲　　出入无住处
  无痛无思想　　不生不死灭
  有念为劳苦　　不复着因缘
  示现有色欲　　已反爱灰尘
  观见有病痛　　常意与本并
  慧见不空念　　寂寂安空空
  法华三昧现　　不出不入住
  无见不见空　　是为疾得如
  便能行施法　　以慧为布施
  说慧等如是　　诸佛皆称叹

女闻说是时。倍复踊跃欢喜。起为佛作礼。踊在空中去地七尺。还坐金刚莲华上。时坐中有比丘心念言。是为真是女为幻人。自起为佛作礼长跪叉手。说偈问佛言

  本自生愚痴　　不识道慧义
  不知女利行　　为是真男女
  审是一定人　　用法何复问
  真是女子身　　所问何以深
  生来侍佛法　　未见如是人
  所见非凡及　　智慧何以尔
  本从何方来　　而生于王家
  宿命行何法　　逮及几佛来
  精进健乃尔　　所问如来报
  戒具真有行　　能问如有说
  能忍有柔意　　但能口说行
  休心意何如　　实欲往试之
  可应几法住　　往对不起意
  若实有智慧　　我欲从解要
  省视所说法　　咏广入道俗
  有何异心意　　独得是智慧

佛便语比丘言。自若干因缘。即说偈报言

  女利行本心　　立德识本处
  在世来千岁　　常习于三昧
  心解众色要　　寂然与禅同
  真是女子身　　不为化来现
  本从无色世　　今来在世界
  续复如本行　　已行便立正
  无身现说心　　普念众慈行
  念法空为本　　不起因缘相
  比丘自不解　　何怪是女身
  不见无有本　　反自受缚着
  禅思欲去色　　更反为色乱
  远苦避三毒　　已入三毒苦
  汝自不解身　　自谓得常安
  万物如幻化　　入出无形住
  四色本虚空　　自然受形着
  爱习自拘限　　坏本起末欲

尔时比丘八万四千人。闻说偈意解。即发无上正真道意。不可计天人。散华名香皆来供养佛。时舍利弗心念。女子乃有是辩。何不去女作男。佛即知舍利弗心所念。便语舍利弗。汝自问女。舍利弗即问。唯女利行。所说非常事。如与如来共对语。何不去女作男。女利行答言。唯舍利弗。道德之要以慧善见。不视于四色。是地水火风。五情合六入为衰。心意识如幻如化。出入无形。痴意不尽。故与三流对。更出浮沉。何足珍。虽漏尽结解。有不净想。无色如为恶。苦住反为乐。舍利弗问。学佛之法。应有谤毁言不。女问。贤者舍利弗。云何为谤毁。答言。一好一恶。是为谤毁。女报言。未晓未了。大人所说。不以小为小大为大。好恶无二。等无异。谤身。身是色。谤意。意无形。四色法空。无形无造。何所受谤毁者。舍利弗答曰。卿所说是菩萨大人所行。卿未应菩萨。何缘乃说此事。女报言。大人为以何立。报言。普等为言。何谓为普。教授十方人。远苦得道。是为普。唯贤者所说。不说普。说生死勤苦耳。女语舍利弗。谓为普者。不见有人无人有教无教有法无法所念。是曰为普。不为见生死苦欲教之令得道。是为普。舍利弗。无有辩才析答此言。女尔时说偈叹曰

  人用三尘乱　　辄为六衰着
  五恶十贼对　　三厄堕困穷
  十二连相续　　四色拘没三
  不解名颠倒　　坐受空聚藏
  无故没三淫　　自网投深渊
  坚藏畏二三　　自灭更受生
  宛为空所缚　　恒怀不净想
  自呼是常安　　为得真自然
  是辈满阎浮　　亿亿百万千
  所行遍十方　　不益一切人
  当有随受行　　皆共堕海流
  可作大法行　　入海勉欲根
  决海令灭尽　　平故无还流
  返原尽欲室　　令人归故乡
  故乡名无为　　号字清净堂
  快乐多紫金　　入出杨光明
  恒边沙劫佛　　莫不称叹说
  以法空无戏　　无相不愿识
  渊流以海水　　皆复不足说
  广意开化人　　自然常自安
  惟念诸贤者　　乃自反不解
  无故自受缚　　幻化受报应

尔时四万二千罗汉。皆正意。第七住。八万五千释梵。皆逮无所行从生。六万四千贤女。起为佛作礼。住佛前说偈言

  今日女利行　　为我众等说
  闻说佛深法　　令我心开解
  实欲知道德　　皆从何所来
  聚合众一切　　有何神妙德
  而致与大众　　莫不惊愕心
  伏意往乐从　　随教之所行
  愿欲求天尊　　愍发起濯众
  至心受大慧　　如来神化现
  应时诸女身　　倒愿去色欲
  便欲作沙门　　佛之知我情
  毕觉诸审谛　　使身如菩萨
  宣佛神道教　　当复转化人
  诸贤大众女　　俱起在佛前
  头面稽首礼　　愿得如佛像

佛语诸女。所说实至心。今欲求所愿。先当报父母。次当复由王得听可去耳。于是诸女。说偈报白言

  欲愿作沙门　　先当报父母
  次当复由王　　得听可作道
  为道不苦晚　　但当勤开心
  晓解心意本　　一切与同等
  便有决大意　　心解乃至道
  道从解心起　　不住于缚着
  化达观众见　　如复心出生
  从本知本空　　知皆非常苦
  心乱便随流　　所见必有对
  不生善恶想　　尔乃作沙门

诸贤女。起往至父母所。长跪白父母及大王。今日受王恩德。来诣佛所。为尊女利行问佛深妙法。欲求无为道。现身及一切佛。为女说本末生死苦痛。但为色欲着。不知道德本。缘是无常至。当就三苦勤。愿欲作沙门。愿父母听我作沙门。当得道还度父母。父母语诸女。求自然道。各自见便利。随意所习行。汝曹尚去。我亦随汝去。汝自白语王。得听便自去用问我为。诸女稽首大王前。泪出而言。人在三界中。苦欲坐色想。不得自在。无常卒至无有代者。实欲作沙门。并与诸女俱。无为得道者。当还度父母。王愿从本意。王语女利行等。早欲使汝去。随行作沙门。以汝三事未足。是以不遣汝耳。一者未尽学识诸礼教。二者常乐未有见苦。三者口食恣味未有足者。以是故。不欲遣汝耳。若有至意者。便去勿疑。吾亦欲作沙门。王即起至佛所。作礼白佛言。闻说智慧意甚愿乐。国付太子。身归三尊给侍左右。并受法教。欲作沙门求道如佛。佛即放光若干种色。其明照十方。地为六反震动。诸天作乐覆满于虚空。散华名宝覆三千大千刹土天下丘墟皆平。其有大山。化为黄金。枯木更生。中有不端正者。皆得愿。树木枯者。皆生条叶。自然风吹。皆歌叹佛功德。生华者即自堕落。各气到佛所。罗住空中。各说偈赞佛功德

  今蒙圣神力　　得救死复生
  光色还本然　　复实滋道成
  生死淫乱色　　譬于枯木时
  值佛说音声　　还来合本并
  六色沉着瞑　　四色合五欲
  分别法空然　　解道成法行
  为得真定智　　快乐得安宁
  一切皆欢喜　　稽首礼佛足

尔时诸六通及罗汉。见华有是说。女利行即化为男子。复为菩萨一女子。作是二化变。众坐莫不欢喜。时一佛刹中无有女人。诸六通道者十万五千人。三万须陀洹。皆得阿惟越致。八万六千人及阿那含皆得柔顺法忍。不可计罗汉。更发无上正真道意。其有辟支佛行。即如弥勒辈。王即以国付太子。太子名辩积。拜跪白大王。王为欲施子孙之殃。与色身之福。施子孙。当以法财之利。持诛灭之怨大罪。与子孙。大国之治世世漏没。人根不知大慧。灭善之路。与子孙。当奈何。父王有教。不得不从。辄便礼拜。辞王而去。还国宫殿。坐领国。普告。若不到佛所求无为道作善孝者。罪与三逆等。太子于殿上。精进勇慧。广开大道意。心甚过本无量。即灭一城之恶。地即为六反震动。时人民皆言。愿太子便得作佛。我曹大众。皆当承弟。亦当作佛。佛时笑。五色光出。照于十方佛刹。人民皆发愿。令我得道如佛。天下饮食自然在前。如忉利天上。其国菩萨。皆如阿弥陀国中。太子辩积。得功德在宫七日。出诣佛所。从大众群臣大小人民无央数至佛所。为作礼住佛前。说亿亿万千偈。赞曰

  佛作三昧决　　功德甚巍巍
  光相威神照　　感动三千刹
  施人无上慧　　德普入众心
  感发开童蒙　　莫不受福成
  演咏法华事　　改世濯群异
  降伏犷强者　　和更受柔顺
  等寻道场光　　世人受业长
  去老逮空寂　　不死而复生
  除病远秽辱　　色想没灭劳
  阴盖即以除　　清净无欲尘
  思想受欲定　　流布还无为
  空定常寂然　　不住不然行
  不行无法识　　示现光相成
  本法无增减　　常安寂空空
  如来现神化　　一切得真道
  愚痴寂然定　　心与无生同
  我今听说法　　演出法华慧
  心解得发愿　　一切得如佛
  今欲城国土　　愿便说法华
  以何法行得　　当有几事解
  疾得是法华　　依义说其慧
  皆令分别知　　一切心得解
  晓了诸法事　　当从中外得
  得之为远近　　便可立得佛
  复更于劫数　　久从几佛受
  解慧而有要　　须臾变化成
  愿以具演说　　皆令大众知
  太子及众人　　作礼还复坐

佛语女利行。欲知法华之开解所示现也。当来过去现在诸佛。皆从是散身譬喻品得道知谛。尔时有亿百千天及诸梵。不可计人民。四十八万菩萨。逮得无所从生。其有声闻皆更发意。时不想菩萨白佛言。今日大众听闻法华三昧。解说事要都未受诀。佛告菩萨。今日说法华三昧者。皆以授诀有劫数。各各自有国土处所。是故不复说耳。若汝不解。自往皆问之。时太子及女利行。即白菩萨心中所欲问。即各说偈答报言

  惟贤上智慧　　何以不解要
  其有求想报　　皆为不受慧
  当说有处所　　则非法华事
  要当须口说　　欲听真高声
  不解其本末　　语亦俱不知
  指示道径法　　犹若如盲人
  师子之大音　　尚复呼小声
  受诀已得佛　　不知礼正道
  受诀有国土　　譬亦如幻化
  有对便出应　　不复预思想
  见附住教授　　弥及去来今
  神通无不知　　不须有言说
  受诀在空无　　寂然安无为
  常定不动转　　私细人不知
  开演于未然　　寂静无所为
  是为所乐国　　清净为证正
  不念有思想　　是为快法安
  相好示光明　　是为勤苦现
  弟子有人民　　是为入欲浊
  不苦不勤念　　都尽不起灭

如是说十八万亿偈报。菩萨即欢喜。说偈赞曰

  我自生愚痴　　不解上人语
  不知其音法　　反呼未受决
  如今所说偈　　甚深难具陈
  愿发本时意　　与神共参论

时太子白佛言。今诸贤皆尚不解要。以善权方便开解。佛即笑。五色光从心口出。十方皆明。阿难白佛。佛不妄笑。笑必有意。愿闻其说。佛语阿难。汝见大众不。阿难答言见。今是如来。问皆具答。各各在十方教化。度恒沙等天人民。皆使作佛。尔时自然雨香华七宝。覆三千大千刹土。而周匝遍无有空处。佛语太子。此法华所解。人身之事如是。尔时不可计洹沙百千人民。皆发无上正真道意。逮无所从生心。无数千声闻。皆逮阿惟越致地。阿难长跪白佛言。此名何经。云何奉行。佛语阿难。名法华三昧。女利行所问解人身散情经要集。若有男女。书写讽诵读。胜行檀八十劫。若供养对跪拜者。胜菩萨行慈三千亿万劫。若当晓解展转相教。胜供养恒边沙佛。若有一闻是经者。不复更生死勤苦。不信谤者。此人以随末流。未复还本。佛语阿难。嘱累汝法华三昧事。千劫尚不能尽。粗说要谛。受书持奉行。勿得减一字。正书句逗相得。太子所从大众开解。各得道慧。皆如上首。起为佛作礼而去法华三昧经


佛说观普贤菩萨行法经

    No. 277

    佛说观普贤菩萨行法经

        宋元嘉年昙无蜜多于杨州译

如是我闻。一时佛在毗舍离国大林精舍重阁讲堂。告诸比丘。却后三月我当般涅槃。尊者阿难。即从座起。整衣服叉手合掌。绕佛三匝为佛作礼。胡跪合掌谛观。如来目不暂舍。长老摩诃迦叶。弥勒菩萨摩诃萨。亦从座起。合掌作礼瞻仰尊颜。时三大士异口同音。而白佛言。世尊。如来灭后。云何众生起菩萨心。修行大乘方等经典。正念思惟一实境界。云何不失无上菩提之心。云何复当不断烦恼不离五欲。得净诸根灭除诸罪。父母所生清净常眼。不断五欲而能得见诸障外事。佛告阿难。谛听谛听善思念之。如来昔在耆阇崛山及余住处。已广分别一实之道。今于此处。为未来世诸众生等。欲行大乘无上法者。欲学普贤行。普贤行者。我今当说其忆念法。若见普贤及不见者。除却罪数。今为汝等当广分别。阿难。普贤菩萨。乃生东方净妙国土。其国土相。法华经中已广分别。我今于此略而解说。阿难。若比丘比丘尼优婆塞优婆夷。天龙八部一切众生。诵大乘经者。修大乘者。发大乘意者。乐见普贤菩萨色身者。乐见多宝佛塔者。乐见释迦牟尼佛及分身诸佛者。乐得六根清净者。当学是观。此观功德除诸障碍。见上妙色。不入三昧。但诵持故。专心修习。心心相次。不离大乘。一日至三七日。得见普贤。有重障者。七七日尽然后得见。复有重者一生得见。复有重者二生得见。复有重者三生得见。如是种种业报不同。是故异说。普贤菩萨身量无边。音声无边色像无边。欲来此国。入自在神通。促身令小。阎浮提人三障重故。以智慧力化乘白象。其象六牙七支跓地。其七支下生七莲华。象色鲜白。白中上者。颇梨雪山不得为比。身长四百五十由旬。高四百由旬。于六牙端有六浴池。一一浴池中生十四莲华。与池正等。其华开敷如天树王。一一华上有一玉女。颜色红辉有过天女。手中自然化五箜篌。一一箜篌。有五百乐器以为眷属。有五百飞鸟。凫雁鸳鸯皆众宝色。生花叶间。象鼻有华。其茎譬如赤真珠色。其华金色含而未敷。见是事已。复更忏悔。至心谛观思惟大乘。心不休废。见华即敷金色金光。其莲华台是甄叔迦宝。妙梵摩尼以为华鬘。金刚宝珠以为华须。见有化佛坐莲华台。众多菩萨坐莲华须。化佛眉间。亦出金光入象鼻中。从象鼻出入象眼中。从象眼出入象耳中。从象耳出照象顶上。化作金台。其象头上有三化人。一捉金轮。一持摩尼珠。一执金刚杵举杵拟象。象即能行脚。不履地蹑虚而游。离地七尺。地有印文。于印文中。千辐毂辋皆悉具足。一一辋间生一大莲华。此莲华上生一化象。亦有七支。随大象行。举足下足。生七千象以为眷属。随从大象。象鼻红莲华色。上有化佛放眉间光。其光金色。如前入象鼻中。于象鼻中出入象眼中。从象眼出还入象耳。从象耳出至象颈上。渐渐上至象背。化成金鞍。七宝校具。于鞍四面有七宝柱。众宝校饰以成宝台。台中有一七宝莲华。其莲华须百宝共成。其莲华台是大摩尼。有一菩萨结加趺坐。名曰普贤。身白玉色五十种光。光五十种色以为项光。身诸毛孔流出金光。其金光端无量化佛。诸化菩萨以为眷属。安庠徐步。雨大宝华至行者前。其象开口。于象牙上。诸池玉女鼓乐弦歌。其声微妙。赞叹大乘一实之道。行者见已。欢喜敬礼。复更诵读甚深经典。遍礼十方无量诸佛。礼多宝塔及释迦牟尼。并礼普贤诸大菩萨。发是誓言。若我宿福应见普贤。愿尊遍吉。示我色身。作是愿已。昼夜六时礼十方佛。行忏悔法。诵大乘经。读大乘经。思大乘义。念大乘事。恭敬供养持大乘者。视一切人犹如佛想。于诸众生如父母想。作是念已。普贤菩萨。即于眉间放大人相白毫光明。此光现时。普贤菩萨身相端严。如紫金山。端正微妙。三十二相皆悉备有。身诸毛孔放大光明。照其大象令作金色。一切化象亦作金色。诸化菩萨亦作金色。其金色光。照于东方无量世界。皆同金色。南西北方四维上下亦复如是

尔时十方面一一方。有一菩萨。乘六牙白象王。亦如普贤等无有异。如是十方无量无边满中化象。普贤菩萨神通力故。令持经者皆悉得见。是时行者。见诸菩萨。身心欢喜。为其作礼。白言。大慈大悲者。愍念我故。为我说法。说是语时。诸菩萨等异口同音。各说清净大乘经法。作诸偈颂赞叹行者。是名始观普贤菩萨最初境界

尔时行者。见是事已。心念大乘。昼夜不舍。于睡眠中。梦见普贤为其说法。如觉无异。安慰其心。而作是言。汝所诵持。忘失是句。忘失是偈。尔时行者。闻普贤菩萨所说深解义趣。忆持不忘。日日如是。其心渐利。普贤菩萨。教其忆念十方诸佛。随普贤教正心正意。渐以心眼见东方佛。身黄金色。端严微妙。见一佛已。复见一佛。如是渐渐。遍见东方一切诸佛。心相利故。遍见十方一切诸佛。见诸佛已。心生欢喜。而作是言。因大乘故。得见大士。因大士力故。得见诸佛。虽见诸佛犹未了了。闭目则见。开目则失。作是语已。五体投地。遍礼十方佛。礼诸佛已。胡跪合掌而作是言。诸佛世尊。十力无畏十八不共大慈大悲三念处。常在世间色中上色。我有何罪而不得见。说是语已。复更忏悔。忏悔清净已。普贤菩萨复更现前。行住坐卧不离其侧。乃至梦中常为说法。此人觉已。得法喜乐。如是昼夜经三七日。然后方得旋陀罗尼。得陀罗尼故。诸佛菩萨所说妙法。忆持不失。亦常梦见过去七佛。唯释迦牟尼佛为其说法。是诸世尊。各各称赞大乘经典

尔时行者。复更忏悔。遍礼十方佛。礼十方佛已。普贤菩萨住其人前。教说宿世一切业缘。发露黑恶一切罪事。向诸世尊。口自发露。既发露已。寻时即得诸佛现前三昧。得是三昧已。见东方阿閦佛及妙喜国。了了分明。如是十方。各见诸佛上妙国土。了了分明。既见十方佛已。梦象头上有一金刚人。以金刚杵遍拟六根。拟六根已。普贤菩萨。为于行者。说六根清净忏悔之法。如是忏悔。一日至七日。以诸佛现前三昧力故。普贤菩萨说法庄严故。耳渐渐闻障外声。眼渐渐见障外事。鼻渐渐闻障外香。广说如妙法华经。得是六根清净已。身心欢喜无诸恶相。心纯是法。与法相应。复更得百千万亿旋陀罗尼。复更广见百千万亿无量诸佛。是诸世尊。各伸右手摩行者头。而作是言。善哉善哉。行大乘者。发大庄严心者。念大乘者。我等昔日发菩提心时。皆亦如汝殷勤不失。我等先世行大乘故。今成清净正遍知身。汝今亦当勤修不懈。此大乘典诸佛宝藏。十方三世诸佛眼目。出生三世诸如来种。持此经者。即持佛身即行佛事。当知是人。即是诸佛所使。诸佛世尊衣之所覆。诸佛如来真实法子。汝行大乘。不断法种。汝今谛观东方诸佛。说是语时。行者即见东方一切无量世界。地平如掌。无诸堆阜丘陵荆棘。琉璃为地黄金间侧。十方世界亦复如是。见是地已。即见宝树。宝树高妙五千由旬。其树常出黄金白银七宝庄严。树下自然有宝师子座。其师子座。高二十由旬。座上亦出百宝光明。如是诸树及余宝座。一一宝座。皆有自然五百白象。象上皆有普贤菩萨

尔时行者礼诸普贤。而作是言。我有何罪。但见宝地宝座及与宝树。不见诸佛。作是语已。一一座上。有一世尊端严微妙。而坐宝座。见诸佛已心大欢喜。复更诵习大乘经典。大乘力故。空中有声而赞叹言。善哉善哉善男子。汝行大乘功德因缘能见诸佛。今虽得见诸佛世尊。而不能见释迦牟尼佛分身诸佛及多宝佛塔。闻空中声已。复勤诵习大乘经典。以诵大乘方等经故。即于梦中。见释迦牟尼佛。与诸大众。在耆阇崛山。说法华经。演一实义。教已忏悔。渴仰欲见。合掌胡跪向耆阇崛山。而作是言。如来世雄常在世间。愍念我故为我现身。作是语已。见耆阇崛山七宝庄严。无数比丘声闻大众。宝树行列宝地平正。复铺妙宝师子之座。释迦牟尼佛放眉间光。其光遍照十方世界。复过十方无量世界。此光至处。十方分身释迦牟尼佛。一时云集。广说如妙法华经。一一分身佛。身紫金色。身量无边。坐师子座。百亿无量诸大菩萨。以为眷属。一一菩萨。行同普贤。如此十方无量诸佛菩萨眷属。亦复如是。大众集已。见释迦牟尼佛举身毛孔放金色光。一一光中有百亿化佛。诸分身佛。放眉间白毫大人相光。其光流入释迦牟尼佛顶。见此相时。分身诸佛一切毛孔。出金色光。一一光中。复有恒河沙微尘数化佛。尔时普贤菩萨。复放眉间大人相光。入行者心。既入心已。行者自忆过去无数百千佛。所受持读诵大乘经典。自见故身。了了分明。如宿命通等无有异。豁然大悟。得旋陀罗尼。百千万亿诸陀罗尼门。从三昧起。面见一切分身诸佛。众宝树下坐师子床。复见琉璃地。如莲华聚。从下方空中踊出。一一华间。有微尘数菩萨。结加趺坐。亦见普贤分身菩萨。在彼众中赞叹大乘。时诸菩萨异口同音。教于行者清净六根。或有说言。汝当念佛。或有说言。汝当念法。或有说言。汝当念僧。或有说言。汝当念戒。或有说言。汝当念施。或有说言。汝当念天。如此六法。是菩提心。生菩萨法。汝今应当于诸佛前发露先罪。至诚忏悔。于无量世。眼根因缘贪着诸色。以着色故。贪爱诸尘。以爱尘故。受女人身。世世生处惑着诸色。色坏汝眼。为恩爱奴。色使使汝经历三界。为此弊使盲无所见。今诵大乘方等经典。此经中说。十方诸佛色身不灭。汝今得见审实尔不。眼根不善伤害汝多。随顺我语归向诸佛。释迦牟尼说汝眼根所有罪咎。诸佛菩萨慧明法水。愿以洗除令我清净。作是语已。遍礼十方佛。向释迦牟尼佛大乘经典。复说是言。我今所忏。眼根重罪障蔽秽浊。盲无所见。愿佛大慈哀愍覆护。普贤菩萨乘大法船。普度一切。十方无量诸菩萨伴。唯愿慈哀听我悔过。眼根不善恶业障法。如是三说。五体投地。正念大乘。心不忘舍。是名忏悔眼根罪法。称诸佛名。烧香散华。发大乘意。悬缯幡盖。说眼过患忏悔罪者。此人现世见释迦牟尼佛。及见分身无量诸佛。阿僧祇劫不堕恶道。大乘力故。大乘愿故。恒与一切陀罗尼菩萨共为眷属。作是念者是为正念。若他念者名为邪念。是名眼根初境界相。净眼根已。复更诵读大乘经典。昼夜六时胡跪忏悔。而作是言。我今云何。但见释迦牟尼佛分身诸佛。不见多宝佛塔全身舍利。多宝佛塔恒在不灭。我浊恶眼。是故不见。作是语已。复更忏悔。过七日已。多宝佛塔从地涌出。释迦牟尼佛。即以右手开其塔户。见多宝佛入普现色身三昧。一一毛孔。流出恒河沙微尘数光明。一一光明。有百千万亿化佛。此相现时。行者欢喜。赞偈绕塔满七匝已。多宝如来出大音声。赞言法子。汝今真实能行大乘。随顺普贤眼根忏悔。以是因缘。我至汝所为汝证明。说是语已赞言。善哉善哉释迦牟尼佛。能说大法。雨大法雨。成就浊恶诸众生等。是时行者。见多宝佛塔已。复至普贤菩萨所。合掌敬礼白言。大师教我悔过。普贤复言。汝于多劫。耳根因缘随逐外声。闻妙音时心生惑着。闻恶声时起八百种烦恼贼害。如此恶耳报得恶事。恒闻恶声生诸攀缘。颠倒听故。当堕恶道边地邪见不闻法处。汝于今日。诵持大乘功德海藏。以是缘故见十方佛。多宝佛塔现为汝证。汝应自当说己过恶忏悔诸罪。是时行者闻是语已。复更合掌五体投地。而作是言。正遍知世尊。现为我证方等经典。为慈悲主。唯愿观我听我所说。我从多劫乃至今身。耳根因缘闻声惑着。如胶着草。闻诸恶时起烦恼毒。处处惑着无暂停时。坐此窍声劳我神识。坠堕三涂。今始觉知。向诸世尊发露忏悔。既忏悔已。见多宝佛放大光明。其光金色。遍照东方及十方界。无量诸佛身真金色。东方空中作是唱言。此佛世尊。号曰善德。亦有无数分身诸佛。坐宝树下师子座上。结加趺坐。是诸世尊。一切皆入普现色身三昧。皆作是赞言。善哉善哉善男子。汝今读诵大乘经典。汝所诵者。是佛境界。说是语已。普贤菩萨。复更为说忏悔之法。汝于前世。无量劫中。以贪香故。分别诸识处处贪着。堕落生死。汝今应当观大乘因。大乘因者诸法实相。是闻是语已。五体投地复更忏悔。既忏悔已当作是语。南无释迦牟尼佛。南无多宝佛塔。南无十方释迦牟尼佛分身诸佛。作是语已。遍礼十方佛。南无东方善德佛。及分身诸佛。如眼所见。一一心礼。香华供养。供养毕已。胡跪合掌。以种种偈赞叹诸佛。既赞叹已。说十恶业忏悔诸罪。既忏悔已而作是言。我于先世无量劫时。贪香味触造作众恶。以是因缘无量世来。恒受地狱饿鬼畜生边地邪见诸不善身。如此恶业今日发露。归向诸佛正法之王。说罪忏悔。既忏悔已。身心不懈。复更诵读大乘经典。大乘力故。空中有声。告言法子。汝今应当向十方佛赞说大乘。于诸佛前自说己过。诸佛如来是汝慈父。汝当自说舌根所作不善恶业。此舌根者。动恶业相。妄言绮语恶口两舌。诽谤妄语。赞叹邪见。说无益语。如是众多诸杂恶业。构斗坏乱法说非法。如是众罪。今悉忏悔。诸世雄前。作是语已五体投地。遍礼十方佛。合掌长跪当作是语。此舌过患无量无边。诸恶业刺从舌根出。断正法轮从此舌起。如此恶舌断功德种。于非义中多端强说。赞叹邪见如火益薪。犹如猛火伤害众生。如饮毒者无疮疣死。如此罪报恶邪不善。当堕恶道百劫千劫。以妄语故堕大地狱。我今归向南方诸佛发露黑恶。作是念时。空中有声。南方有佛名栴檀德。彼佛亦有无量分身。一切诸佛。皆说大乘除灭罪恶。如此众罪。今向十方无量诸佛大悲世尊。发露黑恶诚心忏悔。说是语已。五体投地。复礼诸佛。是时诸佛。复放光明照行者身。令其身心自然欢喜。发大慈悲普念一切

尔时诸佛广为行者。说大慈悲及喜舍法。亦教爱语修六和敬。尔时行者。闻此教敕心大欢喜。复更诵习终不懈息。空中复有微妙音声出如是言。汝今应当身心忏悔。身者杀盗淫。心者念诸不善。造十恶业及五无间。犹如猿猴。亦如黐胶。处处贪着遍至一切六情根中。此六根业。枝条华叶。悉满三界二十五有一切生处。亦能增长无明老死十二苦事。八邪八难无不经中。汝今应当忏悔如是恶不善业。尔时行者闻此语已。问空中声。我今何处行忏悔法。时空中声即说是语。释迦牟尼名毗卢遮那遍一切处。其佛住处名常寂光。常波罗蜜所摄成处。我波罗蜜所安立处。净波罗蜜灭有相处。乐波罗蜜不住身心相处。不见有无诸法相处。如寂解脱。乃至般若波罗蜜。是色常住法故。如是应当观十方佛。时十方佛各伸右手。摩行者头作如是言。善哉善哉善男子。汝诵读大乘经故。十方诸佛。说忏悔法菩萨所行。不断结使不住使海。观心无心。从颠倒想起。如此想心。从妄想起。如空中风无依止处。如是法相不生不灭。何者是罪。何者是福。我心自空。罪福无主。一切法如是。无住无坏。如是忏悔。观心无心。法不住法中。诸法解脱灭谛寂静。如是想者名大忏悔。名庄严忏悔。名无罪相忏悔。名破坏心识。行此忏悔者。身心清净不住法中。犹如流水。念念之中。得见普贤菩萨及十方佛。时诸世尊。以大悲光明。为于行者说无相法。行者闻说第一义空。行者闻已。心不惊怖。应时即入菩萨正位。佛告阿难。如是行者。名为忏悔。此忏悔者。十方诸佛。诸大菩萨。所忏悔法。佛告阿难。佛灭度后。佛诸弟子。若有忏悔恶不善业。但当诵读大乘经典。此方等经是诸佛眼。诸佛因是得具五眼。佛三种身从方等生。是大法印印涅槃海。如此海中。能生三种佛清净身。此三种身。人天福田应供中最。其有诵读大方等典。当知此人具佛功德。诸恶永灭从佛慧生。尔时世尊。而说偈言

  若有眼根恶　　业障眼不净
  但当诵大乘　　思念第一义
  是名忏悔眼　　尽诸不善业
  耳根闻乱声　　坏乱和合义
  由是起狂乱　　犹如痴猿猴
  但当诵大乘　　观法空无相
  永尽一切恶　　天耳闻十方
  鼻根着诸香　　随染起诸触
  如此狂惑鼻　　随染生诸尘
  若诵大乘经　　观法如实际
  永离诸恶业　　后世不复生
  舌根起五种　　恶口不善业
  若欲自调顺　　应勤修慈心
  思法真寂义　　无诸分别相
  心根如猿猴　　无有暂停时
  若欲折伏者　　当勤诵大乘
  念佛大觉身　　力无畏所成
  身为机关主　　如尘随风转
  六贼游戏中　　自在无挂碍
  若欲灭此恶　　永离诸尘劳
  常处涅槃城　　安乐心恬怕
  当诵大乘经　　念诸菩萨母
  无量胜方便　　从思实相得
  如此等六法　　名为六情根
  一切业障海　　皆从妄想生
  若欲忏悔者　　端坐念实相
  众罪如霜露　　慧日能消除
  是故应至心　　忏悔六情根

说是偈已。佛告阿难。汝今持是忏悔六根观普贤菩萨法。普为十方诸天世人。广分别说。佛灭度后。佛诸弟子。若有受持读诵解说方等经典。应于静处。若在冢间。若林树下。阿练若处诵读方等。思大乘义。念力强故。得见我身及多宝佛塔。十方分身无量诸佛。普贤菩萨。文殊师利菩萨。药王菩萨。药上菩萨恭敬法故。持诸妙华住立空中。赞叹恭敬行持法者。但诵大乘方等经故。诸佛菩萨。昼夜供养是持法者。佛告阿难。我与贤劫诸菩萨及十方诸佛。因思大乘真实义故。除却百万亿亿劫阿僧祇数生死之罪。因此胜妙忏悔法故。今于十方各得为佛。若欲疾成阿耨多罗三藐三菩提者。若欲现身见十方佛及普贤菩萨。当净澡浴着净洁衣。烧众名香。在空闲处。应当诵读大乘经典思大乘义。佛告阿难。若有众生。欲观普贤菩萨者。当作是观。作是观者是名正观。若他观者是名邪观。佛灭度后佛诸弟子。随顺佛语行忏悔者。当知是人行普贤行。行普贤行者。不见恶相及恶业报。其有众生。昼夜六时礼十方佛。诵大乘经。思第一义甚深空法。一弹指顷。除去百万亿亿阿僧祇劫生死之罪。行此行者。真是佛子。从诸佛生。十方诸佛及诸菩萨。为其和上。是名具足菩萨戒者。不须羯磨自然成就。应受一切人天供养

尔时行者。若欲具足菩萨戒者。应当合掌在空闲处。遍礼十方佛忏悔诸罪。自说己过。然后静处白十方佛。而作是言。诸佛世尊常住在世。我业障故。虽信方等见佛不了。今归依佛。唯愿释迦牟尼正遍知世尊。为我和上文殊师利具大慧者。愿以智慧。授我清净诸菩萨法。弥勒菩萨胜大慈日。怜愍我故。亦应听我受菩萨法。十方诸佛。现为我证。诸大菩萨。各称其名。是胜大士。覆护众生。助护我等。今日受持方等经典。乃至失命。设堕地狱受无量苦。终不毁谤诸佛正法。以是因缘功德力故。今释迦牟尼佛。为我和上。文殊师利。为我阿阇黎。当来弥勒。愿授我法。十方诸佛。愿证知我。大德诸菩萨。愿为我伴。我今依大乘经甚深妙义。归依佛归依法归依僧。如是三说。归依三宝已。次当自誓受六重法。受六重法已。次当勤修无碍梵行。发广济心。受八重法。立此誓已。于空闲处。烧众名香散华。供养一切诸佛及诸菩萨大乘方等。而作是言。我于今日发菩提心。以此功德普度一切。作是语已。复更顶礼一切诸佛及诸菩萨。思方等义。一日乃至三七日。若出家在家。不须和上。不用诸师。不白羯磨。受持读诵大乘经典力故。普贤菩萨劝发行故。是十方诸佛正法眼目。因由是法。自然成就五分法身。戒定慧解脱解脱知见。诸佛如来从此法生。于大乘经得受记别。是故智者。若声闻毁破三归。及五戒八戒。比丘戒比丘尼戒。沙弥戒沙弥尼戒。式叉摩尼戒。及诸威仪。愚痴不善恶邪心故。多犯诸戒及威仪法。若欲除灭令无过患。还为比丘具沙门法。当勤修读方等经典。思第一义甚深空法。令此空慧与心相应。当知此人。于念念顷。一切罪垢永尽无余。是名具足沙门法式具诸威仪。应受人天一切供养。若优婆塞。犯诸威仪作不善事。不善事者。所谓说佛法过恶。论说四众所犯恶事。偷盗淫劮无有惭愧。若欲忏悔灭诸罪者。当勤读诵方等经典思第一义。若王者大臣婆罗门居士长者宰官。是诸人等。贪求无厌。作五逆罪。谤方等经。具十恶业。是大恶报。应堕恶道。过于暴雨。必定当堕阿鼻地狱。若欲除灭此业障者。应生惭愧改悔诸罪。云何名刹利居士忏悔法。忏悔法者。但当正心。不谤三宝。不障出家。不为梵行人作恶留难。应当系念修六念法。亦当供给供养持大乘者。不必礼拜。应当忆念甚深经法第一义空。思是法者。是名刹利居士修第一忏悔。第二忏悔者。孝养父母恭敬师长。是名修第二忏悔法。第三忏悔者。正法治国不邪枉人民。是名修第三忏悔。第四忏悔者。于六斋日敕诸境内力所及处。令行不杀。修如此法。是名修第四忏悔。第五忏悔者。但当深信因果。信一实道。知佛不灭。是名修第五忏悔。佛告阿难。于未来世。若有修习如此忏悔法。当知此人着惭愧服。诸佛护助。不久当成阿耨多罗三藐三菩提。说是语时。十千天子。得法眼净。弥勒菩萨等诸大菩萨。及以阿难。闻佛所说。欢喜奉行佛说观普贤菩萨行法经


佛说广博严净不退转轮经卷第一

    No. 268 [Nos. 266, 267]

佛说广博严净不退转轮经卷第一

        宋凉州沙门智严译

如是我闻。一时佛在舍卫国只陀林中给孤独园精舍。与大比丘众千二百五十人俱。尔时世尊于夜后分入无垢光三昧。文殊师利法王子于夜后分入遍照三昧。弥勒菩萨摩诃萨于夜后分入遍炬三昧。尔时尊者舍利弗。于夜后分明相出时。佛神力故从自房出诣文殊师利房。尔时尊者舍利弗。欲入文殊师利房时。遥见佛精舍边有十千莲花回旋围绕。闻大音乐歌颂之声。彼诸莲花出大光明。遍照祇洹及舍卫国。乃至三千大千世界

尔时尊者舍利弗。便不复见文殊师利房。而自见身在文殊师利前立。见文殊师利结加趺坐而入三昧。即便弹指不能令寤。高声謦咳亦不能寤。尔时尊者舍利弗。见文殊师利如此神力。自见其身处大海水。欲从其所。以神足力。乘虚还诣本所住房。而不能去

尔时尊者舍利弗。即于文殊师利前结加趺坐。一心瞻仰目不暂眴。时文殊师利与舍利弗东行。过一恒河沙世界到一佛土。其世界名说不退转音声。佛号华光开敷遍身如来。即见彼佛身诸毛孔皆出莲花。其花遍满一万由旬。皆出光明遍照三千大千世界。其华开敷有百千叶。金刚为根光网为茎。阿牟茶马瑙为须。阎浮那提宝为台。其花台上有菩萨坐。已于阿耨多罗三藐三菩提不退转。得陀罗尼具五神通逮得诸忍。以三十二相而自严身。身真金色

尔时华光开敷遍身如来。脐中出一莲花。光色严净有百千叶。金刚为根青琉璃为茎。因陀罗网宝为须。优勒迦娑罗栴檀宝王为台。其花明净尘垢不污空无坐者。尔时文殊师利。往莲花台上结加趺坐。即与花俱上升虚空乃至有顶。还至佛所右绕三匝头顶礼敬。还坐花上一心合掌瞻仰世尊。尔时花光开敷遍身如来。知而故问文殊师利。从何所来。文殊师利白花光开敷遍身如来言。我从娑婆世界来。尔时彼佛有二侍菩萨摩诃萨。一名美音。二名妙音。已于阿耨多罗三藐三菩提不退转。从莲华台下整衣服右膝着地。一心合掌白佛言。娑婆世界去此近远。尔时花光开敷遍身如来告二菩萨摩诃萨言。善男子。娑婆世界今在西方。过恒河沙佛土。文殊师利从彼土来。时二菩萨复白佛言。娑婆世界现在说法佛名何等。佛言。彼佛名释迦牟尼。今现在说法。复白佛言。彼佛世尊为说何法。佛言。释迦牟尼佛说三乘法。复白佛言。云何名三乘。佛言。三乘者所谓声闻乘辟支佛乘佛乘。时二菩萨白佛言。诸佛说法皆不等耶。佛言。诸佛说法皆悉平等。时二菩萨白佛言。云何平等。佛言一切诸佛皆说广博严净不退转轮法。是故平等。时二菩萨白佛言。何故释迦文佛说三乘法。佛言。娑婆世界众生。心乐小法不堪大乘。诸佛如来以方便力说三乘法。释迦文佛出五浊世彼诸众生不能堪受大乘之法。以方便故分别说三。时二菩萨白佛言。释迦文佛于娑婆世界说法甚难。佛言。如是如是。彼佛说法实为甚难。时二菩萨白佛言。我等今者获大善利不生彼国。佛言。善男子。莫作是言。应速悔过。时二菩萨白佛言。世尊。我闻彼国说法甚难。乃无一念乐生彼国。何故悔过。佛言。速舍此语。应当悔过。所以者何。若于此土二十亿百千那由他劫种诸善根。不如彼佛世界。以一食顷。说诸波罗蜜。教一众生。受三自归。奉持五戒。远离声闻心。如是菩萨所行甚难。何况以出家正法发菩提心而作饶益。如是菩萨倍为甚难功德无量。所以者何。娑婆世界多秽恶故。时二菩萨白佛言。娑婆世界有何秽恶。佛告美音妙音。娑婆世界秽恶之事。以我神口尽汝寿量说不可尽。所以者何。彼土众生烦恼厚重。多行贪欲嗔恚愚痴。无量无边诸不善法。我以佛智乃能具知

时二菩萨。即三赞叹。善哉善哉。释迦牟尼。善哉善哉。释迦师子。善哉善哉。释迦仙王。作是叹已。一心合掌忏悔先来诸不善心。若离贪欲嗔恚愚痴。无量无边诸不善法。若曾发心求声闻辟支佛。今悉忏悔。亦欲明净求佛智心顺解脱心。为得佛智故。为一切众生故。以无著善根相应心。持七宝花。其花皆出百千光色。有百千叶。金刚为根。因陀罗宝网为须。优勒迦娑罗栴檀宝王为台。以一切诸宝王为茎。其花明净尘垢不污。可以眼识识。不可以手触。犹如幻化果报。从三昧正观生。于虚空中遥散释迦文佛上。所散之花。于虚空中变成花鬘华云华盖宝鬘宝云宝盖缯鬘缯云缯盖。供养释迦牟尼佛。复以百千种色花鬘末香涂香细末栴檀。遥散释迦牟尼佛上而以供养。即于彼处五体投地。顶礼释迦牟尼佛足。作如是言。南无释迦牟尼佛。及娑婆世界诸菩萨摩诃萨。发大庄严成就大精进力诸先旧者。能持正法有大威力。能利益一切众生而作照明。正求一乘。能守护三世佛法城堑。不断佛种住娑婆世界者。作如是言。我今应往彼土见释迦牟尼佛。并诸菩萨摩诃萨及余众生

尔时花光开敷遍身如来。闻二菩萨作如是言。又筹量观察深心所行。复以佛法诫敕安慰告言。善男子。汝今欲往娑婆世界。见释迦牟尼佛。并诸菩萨及余众生者。当生尊重心怜愍心饶益心。所以者何。彼诸菩萨。于甚深法不生怖畏。亦不诽谤。能奉三世诸佛教戒。以无著心种诸善根。不为果报勤行诸波罗蜜。此诸菩萨摩诃萨等。以本愿故生彼佛土。为守护诸佛法城堑故。亦欲遍学一切佛法故。汝等今欲往彼见耶。时二菩萨白佛言。世尊。若承佛神力及三世诸佛威势护助愿欲往见。尔时华光开敷遍身如来告美音妙音菩萨摩诃萨。今欲往者当与文殊师利法王子俱往。善男子当共汝往。尔时美音妙音菩萨摩诃萨。语文殊师利法王子言。我今因仁者力。欲往娑婆世界。见释迦如来。并诸菩萨及余众生。文殊师利言。善男子。我今欲往十方世界。多供养恭敬尊重赞叹礼拜诸佛。为令一切众生入佛菩提得佛智故。时二菩萨语文殊师利言。我今亦共仁者。至十方世界。多供养恭敬尊重赞叹礼拜诸佛。如仁者。为一切众生入佛菩提得佛智故。我亦随学。尔时文殊师利。顶礼花光开敷遍身如来。右绕三匝尊重恭敬。与彼菩萨并尊者舍利弗。受佛教已一心瞻仰渐渐却退。以如幻花而用散佛。以众花鬘聚涂香末香聚诸幢幡盖聚。皆是先佛威神之力。能生欢喜踊跃欣乐。以供养佛以供养法。为令众生得解脱故。供养佛已。犹如壮士屈伸臂顷。于彼佛前忽然不现。在东方恒河沙佛前自然而现。皆悉如上说广博严净不退转轮法。彼佛世界无有女人。亦无声闻辟支佛乘世界庄严皆如莲华开敷遍身如来佛土。菩萨庄严充满其国亦复如是。彼国诸佛脐中皆出一大莲花。文殊师利而坐其上。恭敬供养现诸神变皆亦如上。南西北方四维上下亦复如是。一一方面恒河沙诸佛如来。文殊师利而现其前。彼诸世尊。皆说广博严净不退转轮法。亦遣侍者菩萨摩诃萨。此诸菩萨下莲花台。一心念佛合掌恭敬咨问彼佛。云何名三乘。亦欲因文殊师利威神力往娑婆世界见释迦牟尼佛听受法教。文殊师利皆悉安慰。十方世界诸菩萨摩诃萨。我当共汝至娑婆世界。见释迦牟尼佛。如是时间于此娑婆世界阎浮提中夜犹未晓

尔时尊者阿难。从房门孔有光来入。即从床起出自房时。见有光明照只陀林日犹未出。见只陀林大水盈满。其水澄清无诸扰浊。房舍园林悉皆不现便作是念。今日必说未曾有法故现斯瑞。尔时尊者阿难。举足入水不没不湿。心生欢喜诣佛精舍。见一万莲花回旋围绕世尊精舍。闻大音乐歌颂之声。彼诸莲花出大光明。照只陀林及舍卫国。乃至三千大千世界。佛威神故乃令阿难。心生欢喜。右膝着地一心合掌顶礼世尊。如是时间天已明了。尔时佛精舍边回旋莲华中有一莲华。忽然而来至只陀林处中而住。尊者阿难。见是事已便作此念。我今应往为佛世尊敷置法座。所以者何。今有此瑞必说大法。尔时阿难为佛世尊敷置法座。当尔之时。大地六变震动。乃至十方恒沙世界皆亦震动。动遍动等遍动。起遍起等遍起。震遍震等遍震。摇遍摇等遍摇踊遍踊等遍踊。吼遍吼等遍吼。是时天雨优钵罗华波头摩花拘物头华分陀利花。如是等花遍满三千大千世界。华果诸树自然而现。时比丘僧欲出只陀园门而不能出。见只陀林大水盈满。其水澄清无诸扰浊。房舍园林悉皆不现。唯见大光遍照祇洹。集在房门而作是言。今现此瑞必说大法

尔时世尊从三昧安祥而起。出自精舍升所敷座。当尔之时。释迦牟尼佛及十方佛放大光网。其光皆有百千种色照明正法。令诸众生生欢喜故。尔时文殊师利。游诸佛土皆与二菩萨俱。所经佛土皆悉礼拜供养诸佛尊重赞叹。为众生故。为得佛智故。为摄众生受教化故。现不可思议神变之事。随其所乐而为说法。时文殊师利法王子。知释迦牟尼佛已升法座。与诸菩萨摩诃萨。从地踊出住于佛前。与无量阿僧祇百千万亿那由他菩萨摩诃萨。绕释迦牟尼佛满百千匝。持百千万种种色花。其花有不可思议百千万叶。皆生欢喜踊跃欣乐以散佛上。所散诸花遍满三千大千世界。复以优迦娑罗细末栴檀而散佛上。复以种种花香。其香亦有百千种色。常出戒香忍香精进香禅香慧香智方便香神通香六波罗蜜香无所著香具诸道品方便之香。其栴檀香。能生欢喜踊跃欣乐。其香光明。皆是十方诸佛神力之所守护。为供养释迦牟尼佛。故发大精进勇猛精进超胜精进坚固精进无等等精进。供养释迦牟尼佛。尔时文殊师利与诸菩萨摩诃萨。便庄严此土。化作八楞摩尼宝树八觚分明。亦有种种宝树庄严。宝盖幢幡以摩尼宝网。及诸铃网而严饰之。变此大地成摩尼宝。于其地上造诸堂阁。窗牖都栏妙宝墙壁。大小诸河泉源花池。优钵罗花波头摩花芬陀利花摩尼宝花。充满其中以甘露水。其水八味流注池中。有种种鸟游集其上。作是变现为令众生心欢喜故。为得佛智故。发大堪忍故。发菩萨心故。现如是等无量神变。是诸佛力。亦是文殊师利法王子力。亦是释迦牟尼佛本愿之力。尔时文殊师利及诸菩萨摩诃萨。作是神变已住于佛前

尔时世尊放从法生光。遍照文殊师利及诸菩萨摩诃萨身。为令坐故。佛便微笑身出莲华。其花有百千种色出。无量百千不可思议光。金刚为根。因陀罗宝为须。优勒迦娑罗栴檀宝王为台。在虚空中。诸菩萨摩诃萨。于其华上结加趺坐。释迦牟尼佛。于自脐中放一光明。其光名曰照诸众生最胜金刚王。即此光中有亿那由他莲花。其花亦出若干种色。其色寂静无量无边过于日光。清净香洁遍照十方。其莲花中自然变成微妙花帐。而是花帐诸佛所护。从法性生安隐寂静。顺解脱门空无相无作。不生不灭相应。踰过三世平等眼所见。文殊师利安坐花帐身相显现。一心合掌正念观佛。所谓佛能通达一切诸法。能生金刚三昧。于一切法无所得三昧。尔时世尊。知文殊师利。及十方诸佛所使菩萨摩诃萨。乐求法者专向一乘。已于先佛种诸善根。为文殊师利之所守护无怯弱心。勤修精进求佛菩提。如是等众安隐坐已

尔时世尊告阿难。汝往遍告只陀林中诸比丘比丘尼优婆塞优婆夷。使集听法。时尊者阿难诣诸比丘房而告之言。诸大德。世尊今敕汝等来集听法。诸比丘言。大德阿难。我等先见此瑞不能得往。阿难言。以何事故而不能往。诸比丘言。我等见只陀林中大水盈满。其水澄清无诸扰浊。大光遍照。房舍园林悉不复现。以是事故不能得往。时尊者阿难。还至佛所白佛言。彼诸比丘不能得来。所以者何。彼作是言。我等见是只陀林中大水盈满。其水澄清无诸扰浊。大光遍照。房舍园林悉不复现。以是事故不能得来。佛告阿难。彼诸比丘。于非水中而作水想。不但于非水中而作水想。亦于非色中而作色想。非受想行识中作受想行识想。非坚信作坚信想。非坚法作坚法想。非八人作八人想。非须陀洹果作须陀洹果想。非斯陀含果作斯陀含果想。非阿那含果作阿那含果想。非阿罗汉果作阿罗汉果想。非声闻乘作声闻乘想。非辟支佛乘作辟支佛乘想。阿难。汝往重告诸比丘比丘尼优婆塞优婆夷来集听法。此法皆是汝等昔所未闻。时尊者阿难。复往诸比丘所而告之言。诸大德。世尊告敕汝等来集听法。如是音声遍舍卫国。诸比丘比丘尼优婆塞优婆夷普闻此声。时尊者阿难。知四部众闻此语已。还至佛所而白佛言。我以遍告四众来集听法

尔时世尊告大目揵连。汝速往诣三千大千世界。遍告诸菩萨摩诃萨发大庄严者。及诸比丘比丘尼优婆塞优婆夷。天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人敬信佛法僧久种善根者。集只陀林听受正法。此法汝等昔所未闻。天人阿修罗及余世间所不能转。唯于先佛所久种善根。乐求大乘最胜乘第一乘无上乘无等等乘菩萨摩诃萨。发大庄严勤行此法者能受能转。时尊者大目揵连受佛教已。即于佛前忽然不现。犹如壮士屈伸臂顷。遍至三千大千世界。菩萨摩诃萨。比丘比丘尼优婆塞优婆夷。天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。敬佛法僧久种善根者。而告之言。世尊告敕。汝等来集听法。尔时大目揵连。承佛威力及己神足。还至佛所白佛言。诸听法众皆悉已集。尔时四众普来集会。纵广一千由旬在上诸天及余众生。住虚空中者。纵广五千由旬

尔时文殊师利法王子白佛言。世尊。今此四众诸来集者。一心合掌顶礼如来。供养恭敬。世尊威德未敢就坐。唯愿世尊。垂哀听坐。尔时世尊。熙怡微笑。是时有无量阎浮那提金色莲花。从地踊出。各百千叶。尸利迦宝为根。因陀罗尼宝为须。赤真珠为台。七宝为茎。大如车轮。诸来会者。在于佛前皆坐其上与文殊师利诸来菩萨摩诃萨。三十二相而自庄严身真金色。入于三昧身出光明。尔时文殊师利。及诸菩萨摩诃萨。诸来四众。莲花台上曲躬恭敬。一心合掌瞻仰世尊。时文殊师利白佛言。世尊。今此四众虚空诸天皆已坐定。唯愿如来等正觉。说广博严净不退转轮法。今此会众比丘比丘尼优婆塞优婆夷百千诸天。皆生须陀洹果想斯陀含果想阿那含果想阿罗汉果想声闻乘想辟支佛乘想。唯愿世尊。为除此众如是诸想。以何因缘。世尊。说须陀洹果斯陀含果阿那含果阿罗汉果声闻乘辟支佛乘。世尊默然。时尊者舍利弗白佛言。世尊。我夜后分明相出时。从自房出诣文殊师利房。欲入房时遥见佛精舍边。有十千莲花回旋围绕。闻大音乐歌颂之声。彼诸莲花出大光明。照只陀林及舍卫国。乃至三千大千世界。如是之相是何先瑞。佛告舍利弗。此是文殊师利所请法瑞。尔时阿难白佛言。世尊。我夜后分房门孔中有光来入。即从床起出自房时。见有光明照只陀林犹如日出。见只陀林大水盈满。其水澄清无诸扰浊。房舍园林悉皆不现。如是之相是何先瑞。尔时世尊告阿难言。此是文殊师利所请广博严净不退转轮法瑞。尔时世尊即为阿难。而说偈言

  佛乘无有上　　清净无浊秽
  文殊无畏者　　今问如此事
  是乘无分别　　无漏无戏论
  文殊无畏者　　今问如此事
  此乘无所有　　毕竟无所生
  是处不可着　　文殊今已问
  是中终不说　　出生于诸果
  诸佛导世者　　说此微密语
  菩提无音声　　亦无来去相
  文殊无畏者　　今问如此事
  虽说诸音声　　其性不可得
  文殊所问法　　无音声文字
  音声犹如风　　无性无住处
  文殊所问法　　远离诸音声
  阿难今善听　　文殊所问法
  诸佛微密语　　宣说菩提空
  诸佛菩提法　　皆悉空寂相
  无有诸方所　　亦无有住处
  菩提如虚空　　无生亦无灭
  亦无来去相　　唯佛能显示
  犹如虚空中　　无有诸相貌
  文殊今问此　　妙净菩提法
  去来今诸佛　　等说此菩提
  非是可见法　　亦无能见者
  如此法性相　　以音声显现
  法界与菩提　　二俱不相见
  净檀波罗蜜　　尸罗亦复然
  能净忍辱者　　显现佛菩提
  能净于精进　　禅定亦复然
  净慧净智者　　能显见菩提
  能净于方便　　到神通彼岸
  无依无猗者　　以声说菩提
  我说三乘法　　诸果差别名
  随其所乐闻　　分别而为说
  五浊世众生　　其心多怯弱
  畏佛智慧故　　不趣佛菩提
  成就第四果　　名曰阿罗汉
  从声得悟者　　是名为声闻
  我说缚解相　　因缘各差别
  晓了此诸缘　　能现见诸法
  便名阿罗汉　　亦号辟支佛
  通达无生法　　是名为菩萨
  空三昧无作　　无相无所有
  从此解脱门　　能入于涅槃
  于前中后际　　终不生染着
  已离于方所　　是故名无为
  阿难汝当知　　文殊问甚深
  能解微密语　　不分别诸果
  文殊住一乘　　不分别诸法
  以是故问佛　　诸果相所以
  三世皆平等　　空寂无性相
  远离语音声　　不分别菩提
  文殊所教化　　诸来大菩萨
  二十恒河沙　　其数不减少
  今来诣我所　　欲闻菩萨行
  亦欲听三乘　　种种差别相
  文殊无畏者　　为除彼疑心
  是故今问我　　果相及乘相
  此是佛威神　　亦是本愿力
  为拔苦众生　　分别说三乘
  文殊无畏者　　殷勤劝请我
  唯愿大法王　　说菩萨所行
  百千亿诸天　　供养佛世尊
  皆着诸果相　　愿除此疑心
  今此四部众　　比丘等来集
  着诸果音声　　不解微密语
  为除彼疑故　　文殊今问我
  以是众因缘　　诸菩萨来集

广博严净经卷第一佛说广博严净不退转轮经卷第二

        宋凉州沙门智严译

尔时阿难白佛言。文殊师利法王子。问佛世尊广博严净不退转轮法耶。佛言。阿难。如是如是。文殊师利法王子。问我广博严净不退转轮法。所以者何。诸佛世尊。皆转广博严净不退转轮法。阿难白佛言。以何因缘。世尊。说坚信坚法八人须陀洹斯陀含阿那含阿罗汉声闻辟支佛耶。世尊。彼之所行是菩萨法耶。佛告阿难。如是如是。彼所行者是菩萨法。所以者何。五浊众生心乐小法不求大乘。是故诸佛以方便力随众生性而为说法。以诸众生多乐小法不堪大乘如来以方便力观其深心。令发道意入佛智慧。阿难。如来以如是方便度诸众生到安隐处。无为无作离心数法。皆悉平等永灭苦乐。无有方所亦无住处。安隐寂静无余涅槃

尔时世尊说是语已而便默然。时尊者阿难问文殊师利言。以何因缘故如来默然。文殊师利言。尊者阿难。以诸众生闻说是法少能信者是故默然。世尊说微密之语。唯我能了。今四部众咸生此疑。以何缘故。世尊说坚信法乃至声闻辟支佛耶。今此百千万亿那由他诸天。亦有百千万亿那由他诸菩萨摩诃萨。皆生疑心。世尊何故说坚信坚法乃至声闻辟支佛乘。以佛默然而不说此难信法故。诸河泉源小大诸水湛然不流。空中诸鸟亭住不飞。日月不行。一切灯炬无复光照。一切众生无有威光。所以者何。世尊默然而不解说难信法故

尔时世尊所住精舍。一万莲华回旋围绕者。皆发此言。唯愿世尊。说广博严净不退转轮法。所以者何我等曾于此处闻九十二亿百千那由他诸佛皆说此法。是时尊者舍利弗白佛言。世尊。愿说广博严净不退转轮法。所以者何。我夜后分与文殊师利法王子。至东方恒河沙佛土。是诸如来皆说此法。南西北方四维上下。无量无边不可计数诸佛世尊皆宣此法。时虚空中有八十万五千那由他诸天。白佛言。世尊。愿说广博严净不退转轮法。所以者何。我等曾于此处。闻九十二亿百千那由他诸佛皆说此法。尔时尊者阿难白佛言。世尊。以何因缘。说坚信坚法乃至声闻辟支佛。今此四众咸皆默然。乃至无有謦咳之声。今此会中百千万亿众生皆生疑惑。世尊何故。说坚信坚法乃至声闻辟支佛乘。唯愿世尊。拔此大众心中疑箭。此诸大众是佛时证。佛告阿难如是如是。诸佛世尊所说之法皆有时证。阿难白佛言。谁是证耶。佛告阿难。法是我证。诸佛如来以法为证而有所说

佛告阿难。谛听谛听善思念之。吾当为汝分别解说。菩萨摩诃萨。名曰坚信。乃至名曰辟支佛乘。时尊者阿难。诸大声闻。皆悉一心听佛所说。佛告阿难。菩萨摩诃萨。令无量无边阿僧祇众生信佛知见。信佛知见已。不着色不着受想行识。以不着色不着受想行识故。是菩萨摩诃萨名为坚法。复次阿难。菩萨摩诃萨。信诸佛所说法皆悉空寂。信此法者。是菩萨摩诃萨。名为坚信。复次阿难。菩萨摩诃萨。信于佛智。便作是念。我等亦当成就此智。亦不见此智。是故阿难。菩萨摩诃萨名为坚信。复次阿难。菩萨摩诃萨。于五欲乐不生欣乐成就信力。是故菩萨摩诃萨名为坚信。复次阿难。菩萨摩诃萨作是念。如佛世尊。以不可思议法施诸众生。我亦应学以不可思议法施诸众生。如是菩萨摩诃萨名为坚信。复次阿难。菩萨摩诃萨心生欢喜舍一切物。乃至自身尚以布施。何况余物。信行此施而不倚着。于一切处不生悭吝。以此因缘回向菩提。亦不起菩提见。是菩萨摩诃萨名为坚信。复次阿难。菩萨摩诃萨信心清净无有怯弱。于佛法僧心得淳净。守护六情无所愿求。无信众生。于佛法僧令生信乐。已生信乐心不放逸。发菩提心不着心相。信知六界与法界等。云何信知。所谓此界以诸音声文字故说实不可得。信知诸行是无常苦空无我之法。亦信无漏圣戒非戏论法具诸三昧。信一切众生即是灭界。众生之相即是灭相。以无依心见诸众生即是法界。而于此法不见法界。所以者何。法界即是众生无心之界。菩萨摩诃萨如是信者名为坚信。一切众生无有住处。所以者何。自性空故。亦复不见众生形相。见诸众生同涅槃相。所以者何。众生界空。是故即见是涅槃相。若有能信如是法者。令多众生得如是信。是故阿难。菩萨摩诃萨名为坚信。尔时世尊欲重宣此义。而说偈言

  能令诸众生　　信向佛知见
  心不生染着　　是名为坚信
  信诸佛说法　　其性相皆空
  能信解此法　　是名为坚信
  信诸佛知见　　是不可思议
  发心而勤求　　我应得是智
  不生信乐心　　贪求五欲乐
  是信力成就　　是名为坚信
  信诸牟尼尊　　以法施众生
  我亦应随学　　是名为坚信
  信能行布施　　乃至舍自身
  亦不生施想　　是名为坚信
  信能施一切　　不生悭吝心
  尽回向菩提　　是名为坚信
  信向于诸佛　　其心无秽浊
  亦信无心法　　是名为坚信
  能守护六情　　亦不复愿求
  已信解此法　　是名为坚信
  诸不信众生　　以信而建立
  令随顺佛法　　是名为坚信
  以此信向心　　尽回向菩提
  而不得心相　　是名为坚信
  知六界平等　　即与法界同
  以音声分别　　不得诸界性
  信诸行无常　　苦空无有我
  成就是信力　　是名为坚信
  信无漏圣戒　　非是论戏法
  具戒三昧者　　是名为坚信
  信诸众生界　　即是灭界性
  能信如是相　　是名信中信
  众生无依性　　即是诸法界
  如此诸法界　　其性难思议
  若能如是信　　随顺彼法相
  此无畏菩萨　　是名为坚信
  信诸众生身　　毕竟无所住
  其性本空无　　是故无处所
  众生是涅槃　　其性即空故
  以是义显示　　寂静涅槃相
  若能如是信　　名无畏菩萨
  如是诸众生　　皆名为坚信
  阿难善受持　　亦如是宣说
  若有如是信　　是名为坚信
  如是等诸法　　余无量无边
  佛为诸菩萨　　说是差别相

如是阿难。如来应正等觉。以方便力为声闻人说菩萨摩诃萨名为坚信。复次阿难。今当为乐此法众生。复以偈颂说菩萨摩诃萨名坚信义。尔时世尊。即说偈言

  皆共和合一心听　　我说佛子诸功德
  布施持戒及精进　　忍辱禅定智慧身
  信向乐求如是法　　不信者信佛净智
  有如是信名菩萨　　导化世间无厌惓
  信解诸法无分别　　其性空寂佛所说
  若能善解如是法　　是名菩萨坚信者
  信佛知见无有量　　发心欲求如是智
  无上大人所有智　　我当何时得此智
  不信欲乐是净法　　不为欲因行恶业
  以信力故乐求法　　有此胜信名菩萨
  信诸如来以法施　　我亦应当如是学
  佛所说法随顺行　　有此胜信名菩萨
  信能舍此上肴膳　　象马金宝及奴婢
  男女眷属所爱妻　　大小村城及国土
  亦以手足支节施　　破骨出髓无所畏
  耳鼻眼目及以头　　有此胜信名菩萨
  信知此身内无主　　是故能以惠施他
  亦复能以妙法施　　以是因缘求佛智
  信能舍此无我身　　见来求者心欢喜
  如是众生我善友　　为菩提舍危脆身
  信如是法菩提因　　以清净心化世间
  闻法不疑佛知见　　有此胜信名菩萨
  知眼无常及耳鼻　　舌身及意亦复然
  知是虚伪不牢固　　为菩提因悉能舍
  见苦众生无信手　　化令住信能信施
  自住慈心愍世间　　皆令信佛最上智
  见着六尘行恶者　　化令回心趣佛智
  不得此心菩提因　　能信菩提无心相
  见诸众生界无智　　不知六界是平等
  此法皆同法界相　　以音声说不可得
  见诸众生在生死　　无常计常痴冥中
  教信诸行是无常　　令信解空无有我
  见诸众生行恶戒　　教令信佛无上戒
  自净戒定诸功德　　有此胜信名菩萨
  见诸众生多懒堕　　教令信佛大精进
  知精进力自调伏　　能持此信名菩萨
  见愚众生计寿命　　教信阴身无有寿
  了知灭界同法界　　若知此法是胜信
  分析此身无去住　　虽复异世业不亡
  所造善恶诸业因　　终不远离此法性
  见众生性无依法　　此界亦同诸众生
  法界平等不思议　　无畏菩萨如是信
  佛说此信无有二　　勤修善行知诸法
  亦为他说如是信　　而不染着于三有
  信如是等众生性　　无有决定常住处
  空不可取无相法　　能信是法名菩萨
  是诸众生如空定　　亦不寂静涅槃界
  不可说有诸性相　　知是法者名持信
  见诸众生信边法　　以寂静法而导之
  故于三界得高称　　亦名持信胜菩萨
  若有如是妙胜信　　发无畏心乐求法
  我法若有黠慧人　　广向时众而宣说
  已说坚信诸功德　　及余种种差别相
  不着三界清净心　　怜愍众生良福田
  长夜布施自调伏　　住清净戒修忍辱
  精进修定及智慧　　行菩萨行心调伏
  以诸相应方便智　　导众生到安隐处
  能令不堕诸恶趣　　有如是智名菩萨
  以真净心动世界　　震起波踊有六种
  光照华上坐菩萨　　皆说寂静空无法
  东方国土及南方　　西方北方亦复然
  上方下方及四维　　皆同说此寂静法
  宁舍身命不疑佛　　亦教他人信佛智
  若诸众生有是信　　佛及行者能证知

复次阿难。云何如来说菩萨摩诃萨名为坚法。阿难当知。菩萨摩诃萨。于佛正法终不退转。受持佛法为他宣说终不毁犯。于不可思议真如法界。应当逮得如是等法。坚心受持而无怯弱。能观诸法真实之相不生染着故。而于此法无所受持。于法非法亦不生着。应如是持乐求诸法。求已能受。受已能持。持已能说。欢喜调柔易可共住。常乐宣说寂静之法。不动法界能逮诸法真实之相。于诸法中善得调伏。亦不毁损常住妙身。如此之身常住故妙。应知此身无始无终无聚无散。应如是知。如佛世尊。为诸菩萨分别解说。于此法中亦应逮得。见一切法清净无垢。善解诸法无可着处。诸法性虚不可得见。以不见故无所受持。宣说法界无相无性。无有言说亦无所有无有思想。远离思想心不可得。其性寂静离诸音声。无有言说非境界法。常乐受持宣说是法。而于是法心无所依。以如是等无所有法。种种差别为菩萨摩诃萨说。而于此法不作合散无种种相。如其所说皆已逮得。已得此法名为性地。性地菩萨摩诃萨。乃至于少法中不生来去想。已能受持不来去法。而于此法不生增减亦无聚散。若能受持不增不减不聚不散。如是等法是名坚法。菩萨摩诃萨于诸法性得无所得。以于此法性无所得故。是菩萨摩诃萨名为坚法。尔时世尊。欲重宣此义。而说偈言

  于诸佛正法　　而无所退转
  能持如是法　　是名为坚法
  未曾有毁犯　　不思议法界
  能逮如是法　　是名为坚法
  久发心受持　　诸佛所说法
  心无有怯弱　　是名为坚法
  于一切法性　　正趣而勤求
  不生染着心　　是名为坚法
  不着亦不住　　亦能教示他
  能持如是法　　是名为坚法
  调柔易共住　　宣说寂静法
  不动彼法性　　是名为持法
  了知诸法体　　而无有性相
  于此法决定　　是名为持法
  亦未曾毁损　　常住真妙身
  当知此身者　　即以法为体
  此身无终始　　诸法之所成
  于此无增减　　是名为持法
  佛为诸菩萨　　宣说诸法相
  能得如是法　　是名为持法
  此界性自空　　于法无染着
  能持如是法　　是名为持法
  观察一切法　　性空不可见
  以不见法故　　亦复无所持
  以无所持故　　能显示法界
  无性相音声　　其体无所有
  远离诸思想　　心亦不可得
  以不得心故　　名不可思议
  已远离心想　　宣示寂静法
  无音声境界　　名不可思议
  能持如是法　　亦复无所信
  不依无所信　　不依无所有
  佛为诸菩萨　　宣说如是法
  不合亦不散　　亦无种种相
  若说于此行　　得住于性地
  已住于性地　　即名性地人
  住性地菩萨　　毕竟无所依
  能持如是法　　是名为持法
  以是故阿难　　菩萨摩诃萨
  于法无所得　　即名为持法
  若有诸众生　　佛道生远想
  以方便力故　　令到究竟处
  如是法及余　　为诸菩萨说
  以微妙方便　　显示佛知见
  持法大明人　　唯佛能证知
  及修行此法　　无畏诸菩萨
  不可思议智　　说持法差别
  法非法清净　　安住是法中

如是阿难。如来正等觉。以方便力故为声闻人。说菩萨摩诃萨名为坚法。复次阿难。云何如来说菩萨摩诃萨名为八人。阿难当知。菩萨摩诃萨。已过八邪修八解脱不着八正。过凡夫法而无所作。逮平等道过凡夫法。勤求菩提不得菩提。离诸邪见而修正见。逮平等道离自身相。虽未得佛身。而求菩提离众生想。而修佛想逮平等想。离众生摷窟法求无摷窟法。于诸法中而无所住。所以者何。不见有法而可住者。过世间法开通圣法已逮灭界。亦不得世间及出世间法。远离有无是法非法。善能观察断常二边。观去来现在心相。乃至菩提心相亦不可得。所以者何。已逮众生心相平等法故。是以毒不能害火不能烧刀不伤身。所以者何。已能远离诸境界故。虽未得佛行。已于诸趣无有决定。所以者何。菩提离诸趣故。菩提趣者安静无为。菩提性空无有处所。是以刀不伤身名不可害。其乘速疾名不可害。所以者何。速达此乘无有挂碍。以是事故刀不伤身。亦有遍缘众生慈菩提行慈。一切众生界不可得。无所行慈一切法空慈。趣寂静界慈。离嗔恚慈。行智明慈。能照菩提。众生界不可得慈。遍缘众生故刀不能伤。知欲色无色界皆悉平等。亦知法界平等如菩提无种种相。不可知不可着无戏论无垢秽。安隐寂静离诸音声。菩萨摩诃萨能了知是界。于诸趣中所有言说音声皆能了知。所以者何。以于无来去法界中得无住法忍故。善知一切众生言音。而为解说寂灭之法。不作是念。我于是时为此众生说法。已远离我想诸音声故。知诸法寂静故。于诸法中不取其相。不可得故。不着言说故。是菩萨摩诃萨名为八人。尔时世尊。欲重宣此义。而说偈言

  已过于八难　　正住八解脱
  不着八正见　　是名为八人
  已过凡夫法　　而不住正道
  处中离二边　　是名为八人
  已过凡夫法　　而离求菩提
  不得菩提相　　是名为八人
  远离诸邪见　　能修行正见
  逮得平等道　　是名为八人
  远离自身相　　而不住菩提
  虽未得佛身　　是名为八人
  除去众生想　　能修行佛想
  已逮平等相　　是名为八人
  离众生摷窟　　求无摷窟法
  不住于诸法　　是名为八人
  已过世间法　　而开通圣法
  成就于灭界　　是名为八人
  诸佛所说法　　及余世间法
  不得此法相　　是名为八人
  见有是一边　　见无第二边
  能舍如是见　　是名为八人
  观察中道法　　及与断常边
  知是平等想　　是名为八人
  不得过去心　　及与未来心
  现在心不住　　是名为八人
  所说最初心　　能生菩提者
  此心不可得　　云何得菩提
  若能逮得此　　不得菩提心
  故毒火不能　　伤害坏其身
  其趣虽不定　　遍修如是行
  逮无去来法　　故名不可害
  菩提无趣相　　以音声故说
  善解音声相　　故名不可害
  去相不可得　　来相亦复尔
  音声说去来　　故名速疾乘
  是故名安隐　　亦名为空无
  亦名速疾乘　　亦名不可害
  如是速疾乘　　菩萨应通达
  无能挂碍者　　是故名不害
  设以利刃刀　　不能伤其身
  不见于身相　　故刀不能害
  遍缘众生慈　　及以菩提慈
  行菩提慈故　　不为刀所害
  无行无众生　　不得众生界
  寂静无生慈　　遍缘众生慈
  远离嗔恚慈　　及行智明慈
  能照菩提慈　　遍缘诸众生
  解刀是空法　　善修于身相
  未得菩提道　　不为刀所害
  已逮寂静界　　远离诸恶趣
  恶业不能障　　不为刀所害
  远离于无明　　已证知明法
  逮得菩提照　　是名为八人
  能知欲色界　　无色界是空
  皆悉是平等　　是名为八人
  界与菩提等　　无有种种相
  无智无分别　　清净无戏论
  已逮此平等　　菩萨无所依
  所说诸音声　　能遍至诸趣
  来去诸音声　　皆归于法界
  于无住法中　　得此最上忍
  善解众生音　　为说寂灭法
  不生如是心　　我为彼说法
  已过音声法　　不取种种相
  知诸法寂灭　　是名为八人
  已过诸音声　　通达音声界
  不着音声者　　故名为八人
  阿难以是事　　是名为八人
  虽作如是说　　其实不可得

如是阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名为八人

复次阿难。云何如来说菩萨摩诃萨名须陀洹。阿难当知。不可思议佛道名须陀洹。菩萨摩诃萨住无所住近于佛道。不受诸法无所依倚亦无所缘。不住诸法毕竟无生。菩萨摩诃萨为得是道故。坚固精进坚固思惟无有懈怠。终不违逆心无所依。诸佛所乘无上最胜出要之道。不着此道亦不住中。以如是道推求诸法。虽复推求而无所得。而于彼道不动不住。于道想生死想佛想能生平等。于结障法平等诸法。平等诸佛平等。远离身见能生佛见开悟诸见。修对治想已过我想。阿难。以是事故。菩萨摩诃萨名须陀洹。不着佛道逮无染道。不疑佛菩提。不选择戒。乃至不见佛戒。以不见故。不选择戒不分别戒。永断三结不住三界。已逮佛道离众生想。无所依止离依止法。专求佛道得安隐寂静道不惜身命。以欢喜心能舍一切物。颜貌和悦无有嚬蹙。为菩提故而行布施。无有少物而不能舍。为济苦众生故。令到涅槃故。为修有相法故。得无相法故。离众生想入众无畏。说寂静法净菩提道。无所怖畏。乃至无有死畏。所以者何。以逮得寂静法。远离尘垢安住佛道。善修恶趣诸平等想无戏论道。阿难。以是事故。菩萨摩诃萨名须陀洹。尔时世尊。欲重宣此义。而说偈言

  不思议佛道　　名为须陀洹
  若有住此道　　必流入菩提
  此道如虚空　　不依一切法
  无缘无所住　　所有不可得
  菩萨坚精进　　能逮如是法
  诸佛导世者　　无上出要道
  不染着此道　　亦复不住中
  以此道推求　　不见一切法
  此道无动摇　　亦复无住中
  不懈怠如佛　　不逆无所畏
  所说生死相　　佛想亦复然
  能于此平等　　知是须陀洹
  诸结及与障　　能覆佛道者
  皆悉能远离　　是名须陀洹
  能断于身见　　而生于佛见
  开悟诸邪见　　善修对治想
  善修自身想　　知我想过患
  是名须陀洹　　不着于佛道
  设生此犹豫　　我不得菩提
  即得无染着　　而求于佛道
  亦不选择戒　　不愿佛尸罗
  已断于戒想　　不分别尸罗
  永断于三结　　不住于三界
  已逮得佛道　　善修众生想
  以无所缘道　　而求于菩提
  已逮寂静道　　佛无垢菩提
  好乐行布施　　和颜无嚬蹙
  不惜于身命　　为无戏论道
  为苦恼众生　　一切皆能舍
  令过须陀洹　　妙胜果之上
  远离诸有想　　善通达无相
  以是故无有　　恶名诸怖畏
  所说法非法　　二俱能远离
  于中不染着　　无有恶名畏
  若入大众时　　其心无所畏
  宣说寂灭法　　已净菩提道
  若起众生想　　能生其真实
  以是故无垢　　远离一切畏
  已离一切怖　　乃至无所畏
  已得寂静道　　安隐无有上
  知恶趣平等　　而不生怖畏
  此道现在前　　无有吾我想
  菩萨如是法　　名为须陀洹
  为乐小法者　　而作如是说
  以微妙方便　　宣说于佛法
  于道放逸者　　令入如是法
  诸佛之导师　　舍方便而说
  为诸久行人　　求最胜道者
  以是故阿难　　我说须陀洹
  黠慧诸众生　　能解了是事
  以是故阿难　　我说须陀洹
  不黠慧众生　　谬分别是事
  凡小无智心　　不解微密语
  愚心起诤讼　　不解微妙义
  满足多百法　　乃名须陀洹
  以须陀洹名　　显示诸佛法

如是阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名须陀洹

广博严净经卷第二佛说广博严净不退转轮经卷第三

        宋凉州沙门智严译

复次阿难。云何如来说菩萨摩诃萨名斯陀含。阿难当知。菩萨摩诃萨。随学佛智解了菩提不从缘生。为无缘智故而求佛智。以众因缘求无处所禅。而求佛智得烧烦恼法。烧诸烦恼得佛平等法。求未得法如诸佛阿罗诃三藐三佛陀。虽度众生而不动众生。求不动众生界。有诸众生慧心微薄。愁忧苦恼不解法界。欲令此众住于智故而求佛智。于根力觉道解脱三昧。先自觉悟觉悟众生。而求佛智所可用智能至道场。为得此智。而求佛智佛眼。是不可思议无障碍眼。恒以此眼利益世间。为求是智眼故。求智中胜智所可用智。知一切法如如亦不可得。此智所可用智。令一切众生住是智中。所谓不住一切法智。以是事故而来此间。来已见众生界。是不可思议界。求是界已不得此界。众生从何而生。不知众生生处。从众生界有差别名。观察法界众生界时。不见是差别相。见众生界尽入法界。见法界是平等道佛法道是众生不可得道众生平等智道。为求是无比智故。此智清净离尘垢。不得此智不可以此智求。知此智是无所知智。菩萨摩诃萨。以此智故而有差别。未得此智。为求此智而来此间。阿难。以是事故。菩萨摩诃萨名斯陀含。尔时世尊。欲重宣此义。而说偈言

  随学诸佛智　　其智无有上
  以求佛智故　　是名斯陀含
  所说众因缘　　能生于菩提
  为如是缘故　　是故来此间
  所说无处禅　　能烧诸烦恼
  以是故来此　　为生此禅故
  先所未得法　　一切智所行
  我亦欲求故　　而来于此间
  不动诸众生　　法界亦如是
  为不移动故　　是故来此间
  苦恼无黠慧　　愁忧诸众生
  欲令如是众　　住佛无量智
  诸根力觉道　　解脱及与禅
  自觉觉他故　　而求于佛智
  能趣向道场　　先佛所行法
  为求此法故　　是故来此间
  为求如是智　　不思议佛眼
  求如是眼故　　而来于此间
  诸佛导世师　　所行巧方便
  为求如是智　　诸智中最胜
  诸所可用智　　能知诸法如
  此智不可得　　云何求诸法
  愿令多众生　　安住无上智
  亦欲令他知　　故来于此间
  来已见众生　　其界不思议
  是以斯陀含　　来此求众生
  以求众生界　　众生不可得
  是故虽来求　　亦复不可知
  不知诸众生　　及以众生界
  若能知此界　　知众生差别
  观察一切法　　观已无所见
  安住于定心　　而求诸佛法
  若有此净智　　无垢性清净
  亦不得此智　　而知于所知
  以如是众生　　能逮得此智
  名无依菩萨　　是故来此间
  阿难以是事　　名为斯陀含
  无黠慧众生　　谬分别是事
  阿难以是事　　名为斯陀含
  勤精进众生　　乃能知是事
  慧者解微密　　于深法决定
  能解如是义　　速能生菩提

如是阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名斯陀含

复次阿难。云何如来说菩萨摩诃萨名阿那含。阿难当知。菩萨摩诃萨。已过分行得佛所行。远离一切诸所行法。知无来去法。于诸法中无所依无所住。是故不来此间。所以者何。亦不见法来去相故。已过凡夫离凡夫想。亦离佛想过无所住法。无有因缘能使来者。所以者何。已逮寂静界故。诸佛导世者。说凡夫禅不往生。彼离诸难处永断爱欲。不贪抟食永离食想。逮得菩提示诸邪见无所贪着。知六十二见性同涅槃离诸盖想。离诸法中所有过患清净无垢。制伏憍慢拔无明箭。已害爱结无复喜爱。烧诸烦恼离一切想。拔忧恼箭离慢大慢。善知诸音逮得照明。乘不可思议佛乘。得菩萨摩诃萨性。离欲污泥得先佛所藏。最胜智藏无增无减。得一切众生乘中最上佛乘。离有无想断一切疑。菩萨摩诃萨成就如是等法。不来此间名阿那含。复次阿难。菩萨摩诃萨有缘众生令住菩提。云何而住。所谓众生即是菩提。菩提即是众生。能觉众生想。所以者何。已了知性空故。知众生界是不可思议界故。是故能觉此想。能知众生界即是虚空界。虚空界空故远离众生界。虚空界离虚空性无所止住。虚空界虚空性空。以如是法令诸众生回向菩提。所以者何。知众生是虚空界。众生界皆入虚空界。所以者何。众生性诸法性各各相入。所以者何。以不可得故。以不可得故不来此间。是故数名阿那含。一切诸法中无有数相。诸佛已过数相。阿难。以是事故。菩萨摩诃萨名阿那含。尔时世尊。欲重宣此义。而说偈言

  已离不复来　　更不修分行
  已离分行故　　是名阿那含
  善知来去相　　不依一切法
  不得少处所　　而可来此间
  诸佛导世师　　所说凡夫禅
  更不往彼间　　是名阿那含
  诸法无来相　　去相不可得
  逮无来去相　　是名阿那含
  其人更不复　　趣向三恶道
  已逮诸佛法　　是名阿那含
  永断一切欲　　不贪于抟食
  已逮菩提道　　是名阿那含
  所说诸见处　　凡有六十二
  更不住见处　　故名阿那含
  诸法无性相　　已离于性相
  如实了知故　　更不来此间
  说涅槃寂静　　能烧诸烦恼
  能远离诸相　　故不来此间
  已断诸难处　　能远离尘垢
  到安隐涅槃　　是名阿那含
  已降伏恶魔　　及其诸眷属
  不为彼所动　　是名阿那含
  已拔无明箭　　亦害诸爱结
  已觉知喜爱　　是名阿那含
  能烧诸烦恼　　亦离诸有想
  决定胜妙果　　是名阿那含
  已拔忧恼箭　　除去诸憍慢
  善知五阴相　　是名阿那含
  已逮诸照明　　不思议佛乘
  远离欲污泥　　是名阿那含
  已得大智藏　　先佛之所藏
  诸藏中最胜　　是名阿那含
  已安住无上　　诸佛之大乘
  永断诸疑心　　是名阿那含
  有缘诸众生　　皆令住菩提
  为彼住菩提　　而不来此间
  能知诸空界　　众生界难思
  已离如是想　　是名阿那含
  能知众生界　　及以法界空
  不得诸众生　　是名阿那含
  其心更不求　　取着诸有相
  已到无相处　　是名阿那含
  阿难以是事　　是名阿那含
  以无所住法　　而住佛法中

是故阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名阿那含

复次阿难。云何如来说菩萨摩诃萨名阿罗汉。阿难当知。菩萨摩诃萨。离诸分行应行佛行。拔济一切众生行破诸烦恼。应为烦恼所苦众生解烦恼缚。而不得众生亦不得烦恼缚。应作是事名阿罗汉。舍有所得住无所得知一切空。此空亦空通达无相。以离诸相离一切想。知众生想是过患法。能舍无智达无心法。晓了空法应逮菩提。应生不可思议佛菩提。以是事故名阿罗汉。应宣说法如三世佛已说今说当说。其所说法皆悉寂静。无有戏论清净无秽。通达是事故名阿罗汉。应令众生住于菩提。知一切法及与菩提是无所有而不可取。应修佛慈不着众生慈。以如是慈遍缘众生。而不得众生。已逮众生不可得慈故。名阿罗汉。应说诸法利益众生。而不起法非法想。于诸法中。应常在先。是名阿罗汉。应为众生说根力觉道。而于此法不染不着故名阿罗汉。应令众生知清净菩提。令彼众生起如是菩提故名阿罗汉。应于世间众生利养而不贪着。应为众生说不贪着利养法。说此法故名阿罗汉。应往诸佛世界。应见诸佛如佛见佛。见如是佛世界已。应当发心求如是世界。所谓不可思议世界。不可量世界。无等等世界。无边世界。无戏论世界。不可说世界。空世界。无相世界。无作世界。不退转世界。离女人世界。离淫欲世界。无烦恼世界。佛无碍辩世界。菩萨世界。无障碍世界。无染世界。降魔世界。无怨敌世界。无毕竟涅槃世界。此诸世界。于一切世界中上。应求如是世界。故名阿罗汉。未生诸法。应生起故名阿罗汉。于欲不染于可嗔法不生嗔。故名阿罗汉。于无上灭集智。速通达故名阿罗汉。以阿罗汉故名为菩提。以菩提故名阿罗汉。菩提不动。以众生界不动故。应令百千万亿众生住菩提道。住菩提道故名阿罗汉。一切众生及与菩提。从无分别生。应以是平等法教诸众生。此平等法。于一切法中无与等者。此平等菩提从无分别生。应知如是法。知是法已。为众生说无有增减。成就无增减法故名阿罗汉。应说如是离音声法故名阿罗汉。应解如是多众生着。所谓众生不可得着。众生断常着。众生身见着。不能过着。见诸法不生不灭无为无作着。不坏色着。不坏受想识行着。离凡夫法着。建立诸佛法着。须陀洹果想着。斯陀含果想着。阿那含果想着。阿罗汉果想着。辟支佛果想着。如来等正觉想着。菩提心想着。为菩提故行施着。为菩提故护戒着。取嗔恚想行忍着。取懈怠想行精进着。取乱心想生禅定着。取恶慧想修智慧着。于父母妻子男女眷属兄弟姊妹所爱诸亲着。欲见爱念诸亲着。乐谈说着。烦恼法出要法作二见着。贪利养着。见在家出家着。见卑胜法着。离凡夫法着。缘佛法着。见下上法着。具足诸相方便着。生佛世界想着。应除众生如是着故名阿罗汉。亦不分别是众生是涅槃法。是众生非涅槃法。是众生能生法。是众生不能生法。是众生行菩提。是众生不能行菩提。是众生持戒。是众生毁戒。是众生多福。是众生少福。不起如是二见名阿罗汉。亦不分别是众生是福田。是众生非福田。是众生精进。是众生不精进。是众生凡小。是众生智明。此是女人。此是男子。此是非男非女。此是法。此是非法。不起如是二见名阿罗汉。亦不分别是众生于菩提退转。是众生于菩提不退转。是众生于菩提得自在。是众生于菩提不得自在。是众生近菩提。是众生远菩提。发如此心。我当得菩提入无余涅槃。略说能除众生一切着故名阿罗汉。阿难。阿罗汉如是除众生着已。亦为众生说众生实性。说如是法故。菩萨摩诃萨名阿罗汉。尔时世尊。欲重宣此义。而说偈言

  已能舍一切　　所有诸分行
  能舍分行故　　是名阿罗汉
  能断诸烦恼　　及苦众生结
  皆令得解脱　　是名阿罗汉
  远离有所得　　住无所得法
  知一切法空　　是名阿罗汉
  已能知解空　　亦通达无相
  远离一切相　　是名阿罗汉
  应行最胜行　　诸佛之所行
  度脱诸众生　　生死大险难
  已离一切相　　知众生想过
  能舍诸想故　　是名阿罗汉
  舍诸无知想　　通达无心法
  已知空法故　　是名阿罗汉
  应逮得诸佛　　不思议菩提
  应勤行精进　　是名阿罗汉
  应宣说诸法　　清净无戏论
  令众生住道　　是名阿罗汉
  应以遍缘慈　　令众生安乐
  而不得众生　　是名阿罗汉
  应宣说诸法　　于众最第一
  无法非法想　　是名阿罗汉
  应为诸众生　　说根力觉道
  不染着此法　　是名阿罗汉
  应令他众生　　觉了清净法
  亦能生菩提　　是名阿罗汉
  应不生贪着　　世所有利养
  不贪利养故　　是名阿罗汉
  应往诣诸佛　　严净妙世界
  诸佛所住处　　为众生说法
  应当发是心　　求此严净界
  应求是界故　　是名阿罗汉
  于欲无所染　　嗔处不生嗔
  知菩提平等　　是名阿罗汉
  已于灭集智　　通达寂灭相
  以菩提道故　　是名阿罗汉
  于诸众生界　　不移动众生
  令多亿众生　　皆住菩提道
  众生及菩提　　从无分别生
  能知此平等　　是名阿罗汉
  一切法等中　　此法等最上
  此等及菩提　　从无分别生
  知已为他说　　而无有增减
  亦从此法生　　故名阿罗汉
  应为此众生　　说无音声法
  解脱多众生　　而无有动者
  众生不可得　　及断常二边
  为除诸邪见　　令得脱众苦
  着诸法生灭　　无为无作相
  诸苦恼众生　　以相而分别
  不毁坏于色　　于受亦复然
  想行及与识　　令离此诸着
  于此凡夫法　　而见有移动
  住佛法不住　　皆令得解脱
  住于诸果想　　缘觉想亦然
  为众生说法　　令离佛想着
  着于菩提心　　着施亦复然
  着于戒忍者　　为说无著法
  取于懈怠想　　分别行精进
  定心与乱想　　恶慧及妙慧
  不分别此法　　知无种种相
  应当如是说　　是名阿罗汉
  坚着于我想　　声闻多分别
  为除分别故　　应为彼说法
  父母及妻子　　无慧故贪着
  此道非菩提　　是生死所行
  此是我兄弟　　姊妹爱念心
  除彼贪爱着　　是名阿罗汉
  故作巧谈说　　发他喜勇心
  生意欲得见　　先旧诸所亲
  若得相见时　　展转生爱着
  无智颠倒故　　属魔不自在
  远离诸利养　　知利养过患
  应为诸众生　　说诸利养过
  此是烦恼法　　此是出要法
  不着此二见　　是名阿罗汉
  贪着于利养　　而不能自解
  能除彼着故　　是名阿罗汉
  此是在家法　　此是出家法
  凡小起分别　　应为解彼着
  于一切法中　　而见有卑胜
  着是器非器　　应解如是着
  远离凡夫法　　而缘于佛法
  应为彼说法　　离得不得着
  大小非坚法　　如是甚众多
  当应为解着　　众生如是相
  能生诸相好　　其事亦众多
  唯有调柔者　　能除彼想着
  诸佛妙世界　　兴起修净心
  着彼世界想　　应当为除却
  涅槃非涅槃　　能生不能生
  此行菩提道　　此不求菩提
  恶戒及善戒　　有福及无福
  愚智诸众生　　而作种种相
  如是诸众生　　多有种种想
  为除此想故　　应为彼说法
  此是良福田　　此非良福田
  分别愚智法　　其事亦众多
  取着于女想　　亦复分别男
  是圣是非圣　　分别起二见
  众生无慧心　　起于此二见
  着此二见者　　应当为除断
  退转不退转　　有记及无记
  此近于菩提　　此不近菩提
  已逮于菩提　　毕竟般涅槃
  行如是诸相　　分别于涅槃
  唯有调柔者　　除众生是想
  是名阿罗汉　　亦名除想者
  此是菩萨法　　说名阿罗汉
  若见此本缘　　知是阿罗汉

如是阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名阿罗汉

复次阿难。云何如来说菩萨摩诃萨名为声闻。阿难当知。菩萨摩诃萨。以佛法声不可思议法声寂静菩提法声无戏论法声无垢清净法声。令无量无边不可计众生闻故名为声闻。复以涅槃是无比法安乐法声。念处正勤神足根力觉道法声。令多众生速能勤求名为声闻。说此身空非坚固法。坚固不可得。凡夫愚小贪着此身。为解说声。又说眼入所见虚妄。应生佛眼不可思议法眼。以此眼故令多众生无愚惑声。又说诸法无生相声名为声闻。又说音声其喻如响。不应于声而生染着。无有闻者亦无说者。于香不生嗅想。无有嗅香者。如人梦中嗅众多香。实无有香亦无嗅者。以颠倒故起嗅香想。此香犹如梦法。而不可信亦无牢固。说是法声名为声闻。复说舌入犹如肉段。不能知味。如此肉段。犹如聚沫实无所有。如是味想不可思议。味界无心。离诸心法不应生心。知心是不住相。说如是法声令众生闻。名为声闻。又于此法了了现见。如其所见能宣说声。又说是身空无性相。以无相故不生亦无所生。为多众生说是菩提法声名为声闻。复说意入空无所有亦无自性。其犹如幻不生不灭。说是法声名为声闻。又说不可思议法施此法能得菩提。菩提不可思议。法施亦不可思议。能生不可思议菩提法。所以者何。如其种子果实亦然。此中无果。以音声故说果。复说财施下劣法施最胜。除却悭心。无所分别不生施想。犹如幻师于所幻事无所分别。如是以无所分别心。而行布施能生菩提。说是法声名为声闻。此声离一切说息诸烦恼。过诸言说离诸染着。以是音声为诸众生宣说佛法。所以者何。此音声一切音中最上。以是音声宣说佛法。此声不可破坏亦无所依。从无二无别生。如其所生说无二无别佛法。是故阿难。菩萨摩诃萨。以如是法声令众生闻。名为声闻。尔时世尊。欲重宣此义。而说偈言

  以不可思议　　最上佛法声
  令多众生闻　　菩萨名声闻
  能为多众生　　说菩提寂灭
  清净无戏论　　是名为声闻
  宣说涅槃乐　　其乐无有比
  亦说寂灭相　　是名为声闻
  说念处正勤　　根力及觉道
  速生此法故　　是名为声闻
  宣说此身空　　牢固不可得
  为诸凡小者　　显说是身相
  又语于眼入　　所见皆虚妄
  无智诸众生　　于此生染惑
  应生于佛眼　　难思平等眼
  于无生法中　　亦不生惑着
  如声犹如响　　解耳亦复然
  此中无闻者　　亦复无说者
  以无闻说故　　不应生染着
  宣示诸众生　　是名为声闻
  如人于梦中　　嗅种种诸香
  但依颠倒起　　而实无所有
  应如是知鼻　　不能嗅彼香
  为颠倒众生　　菩萨宣说是
  说舌是空无　　肉段不知味
  若肉能知味　　手触时应知
  宣说如是想　　味想多过患
  当知此味界　　是不可思议
  菩萨无所依　　能现见了了
  宣说现见法　　是名为声闻
  宣说如是身　　空无有性相
  空无性相故　　不生无所生
  菩提亦如是　　不生无所生
  为多众生说　　故名为声闻
  说意入性相　　其实无所有
  说无所有法　　故名为声闻
  宣说布施法　　法施难思议
  此施能出生　　无上佛菩提
  财施是下劣　　法施为最胜
  能除悭贪心　　得至菩提果
  离诸宣说声　　息诸烦恼声
  离诸染着声　　无垢清净声
  最上微妙声　　其声性寂静
  以此寂静声　　说难思佛法
  此声不可坏　　亦复无所依
  说无二无别　　故名为声闻
  以如是音声　　宣诸佛所说
  随音声而说　　而求菩提道
  常为他宣说　　严净佛世界
  无上道世师　　诸佛所住处
  说此三千界　　如虚空而住
  如空诸众生　　皆同涅槃相
  所说四十四　　令众生差别
  皆悉如虚空　　不思无分别
  此界亦如是　　莫生坚固想
  此中无生死　　无烦恼可灭
  生中无法生　　亦无有众生
  此皆寂静故　　无有见生者
  恒为众生说　　昼夜不断绝
  而不生是念　　我为众生说
  声闻如是知　　亦为众生说
  无闻能闻故　　是名为声闻
  其心意勇猛　　宣说最上法
  若能知此法　　亦知诸法如
  声闻说如是　　无染无有漏
  亦为多众生　　说无染着法
  若知无染界　　清净无戏论
  于诸佛法中　　欲观不能见
  诸佛所说法　　远则不可见
  近亦复无有　　而能得见者
  声闻说是法　　令多众生信
  安住是法中　　故名为声闻
  阿难以是事　　我说是声闻
  当知是声闻　　是无依菩萨

是故阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名为声闻

复次阿难。云何如来说菩萨摩诃萨名辟支佛。阿难当知。菩萨摩诃萨。于一切法现见了了。以现见了了故能知圣法。而于诸法不增不减。觉一切法无有增减。现见了了名辟支佛。觉知一切不可思议法。觉知一切众生等同涅槃。而不可得不生不灭。不生不灭故即是实际。照涅槃际。众生际。一切诸法无所有际。称名字际。不可言说际。不依言说。不可以言说说。所以者何。言说法空不得自在。言说不能知众生际及以法际。现见了了觉知此际名辟支佛。现见色阴。以言说故名为色阴。而此色阴无有言说。离言说故。但以言说名为色阴。此中无我我所。所以者何。言说说者此二皆空。不得自在不生不灭。言说无知。云何能说此是色阴。受想行识。亦应如是了了现见。现见识阴。以言说故名为识阴。而此识阴无有言说。离言说故。但以言说名为识阴。此中无我我所。所以者何。言说说者此二皆空。不得自在不生不灭。言说无知。云何能说此是识阴。于此五阴言说诸缘了了现见名辟支佛。所以者何。此阴言说诸缘。此缘无缘非缘能知。阿难。是菩萨摩诃萨名辟支佛。尔时世尊。欲重宣此义。而说偈言

  现见一切法　　知圣法亦然
  无诤不可坏　　毕竟无有相
  现见一切法　　其性相自空
  若知自性相　　毕竟无所有
  已逮此现见　　与彼法无异
  是名为正觉　　难思辟支佛
  众生如涅槃　　其始不可得
  无始无终际　　是名为实际
  众生如涅槃　　毕竟无有生
  若法无有生　　说名为涅槃
  众生如涅槃　　亦有诸照用
  照用无有我　　故名为涅槃
  众生如涅槃　　立种种名字
  不生亦不灭　　以言说故说
  言说性是空　　言说无所知
  以无所知故　　众生是涅槃
  言说不自在　　无我无有心
  以言说无性　　毕竟无所有
  言说不依际　　亦复无所住
  言说所说者　　难思众生际
  众生际涅槃　　不思议实际
  安隐无戏论　　最胜归依处
  犹如电光际　　即是众生际
  无缘无处所　　不思议实际
  一切法边际　　无有众名字
  以名字名故　　其际不可得
  实际不可名　　亦无能知者
  众生际无我　　当知此际空
  言说不依际　　言说无所宣
  若能了知此　　无有众生际
  言不自在空　　言不知诸际
  言说所言者　　难思众生际
  如是等诸际　　自然能觉知
  是名为正觉　　难思辟支佛
  现见于色阴　　以名字故说
  此阴无言说　　常离言说故
  远离于所知　　所知名计寿
  能知此所知　　而无有住处
  所说名色阴　　色阴无有我
  言不自在空　　毕竟无生灭
  所言言说性　　毕竟无所有
  以无所有故　　能说色阴名
  受想亦如是　　行识亦复然
  以无有言说　　说是五阴名
  此阴不可说　　亦复不可断
  不生亦不灭　　无处非无常
  非烦恼出要　　非报亦非业
  非取亦非舍　　非戏论寂灭
  亦非奢摩他　　非毗婆奢那
  非多欲知足　　非懈怠精进
  非掉亦非悔　　亦无有增减
  不得所生法　　而可以为戒
  不修无分别　　宣说无分别
  无怖无有诤　　无缚亦无解
  以此入言说　　言说无所入
  言说及诸法　　无言说而说
  自能逮现见　　说法无穷已
  依如是三昧　　不着诸言说
  有此现见智　　知言说平等
  如言说诸法　　以无言说说
  已逮此现见　　更不复随他
  是名为正觉　　难思辟支佛

复次阿难。菩萨摩诃萨。现见无明及行非生想。知识自性。知名色自性。知六入自性。知触自性。知受自性。知爱自性。知取自性。知有自性。知生自性。知老死自性。于此法中了了现知名辟支佛。尔时世尊。欲重宣此义。而说偈言

  现见于无明　　毕竟不能生
  犹如水中影　　终始无所有
  明见一切法　　而无动摇相
  若见法如是　　是故名为明
  明性如虚空　　一切法皆尔
  若得此现见　　是名辟支佛
  如说此身行　　而不在于内
  亦不在于外　　此身行不生
  身行如芭蕉　　毕竟无坚固
  不生亦不灭　　其性如虚空
  无畏诸菩萨　　若得此现见
  是名为正觉　　难思辟支佛
  了知一切法　　其性常如幻
  亦能深信解　　识无所有性
  观察如此识　　所行而虚妄
  以有此知故　　能知识性空
  已知智非知　　一切处无染
  若知如是法　　识则同于幻
  如说诸名色　　无受不可说
  而知其性相　　毕竟无所有
  能说诸入性　　而无有取相
  能如是知入　　此是性空故
  触性无不在　　住于诸入中
  观察此触时　　如幻无所有
  触性本自空　　分别故能知
  而此诸触性　　住处无方所
  若能现见触　　智者能远离
  有慧远离触　　是名辟支佛
  能知受相空　　受亦无自性

  如泡不牢固　　毕竟无所有
  已断一切爱　　通达无爱法
  已到爱尽处　　是名辟支佛
  知取无所取　　亦知是虚无
  不生无所有　　如热时炎水
  本来诸有想　　及本有生想
  若知此性想　　毕竟无所有
  已离一切老　　更不复受死
  而于一切处　　不复更受身
  已逮此现见　　而无有所依
  以辟支佛名　　宣说诸菩萨

如是阿难。如来等正觉。以方便力为声闻人。说菩萨摩诃萨名为辟支佛。如是阿难。诸佛如来。说菩萨摩诃萨名为坚信坚法八人须陀洹斯陀含阿那含阿罗汉声闻辟支佛。尔时尊者阿难。便说偈言

  自在导世师　　不可说而说
  于空中作结　　即空而解之
  佛有大方便　　说无著法者
  于不可说法　　而能分别说

广博严净不退转轮经卷第三佛说广博严净不退转轮经卷第四

        宋凉州沙门智严译

尔时阿难白佛言。世尊。一切世间必生疑惑不能解了。如来等正觉。以何缘故说坚信坚法乃至辟支佛耶。尔时世尊告阿难言。阿难当知。若有众生于先佛所造众善行。能解如来密语不生疑惑。所以者何。能知如来密语。如幻如热时炎如梦所见如影如响。阿难。若如是知密语者不生疑惑。是故阿难。菩萨摩诃萨。于如来等正觉密语应如是知。若有勤行精进不得精进。勤修智慧不得智慧者。不生疑惑。尔时世尊。欲重宣此义。而说偈言

  诸佛导世者　　微密语难知
  为发大庄严　　无异菩萨说
  懈怠无智者　　不能解密语
  应当勤精进　　为解密语故
  如幻炎梦见　　如电亦如响
  以言说显现　　如是等诸法
  如是知诸佛　　所说微密语
  能以如是慧　　照净微密智
  不应如是知　　菩提可宣说
  应如是觉知　　无言说故空
  空不能知空　　空不分别空
  断一切分别　　显示如是空
  虚空无所归　　亦无有取舍
  以无取舍故　　是故知法空

佛告阿难。若如是知有为法皆悉如梦。而不放逸者不生疑惑。说是法时。五亿比丘生坚信想者。即从坐起整其衣服。偏袒右肩右膝着地。一心合掌皆共和合。住于佛前。而说偈言

  今日牟尼尊　　除我等疑心
  得解微密义　　以信求菩提

复有五亿比丘生坚法想者。从诸比丘闻此偈已。即从坐起。乃至合掌。住于佛前。而说偈言

  今蒙菩提照　　除我等疑冥
  得解微密义　　坚法求菩提

复有十亿比丘生八人想者。从诸比丘闻此偈已。即从坐起。乃至和合。住于佛前。而说偈言

  先住八地心　　今日皆除舍
  得解微密义　　八人求菩提

复有十一亿比丘生须陀洹想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  今于佛法中　　得断诸疑网
  解佛微密语　　宣说须陀洹

复有二万五千比丘生斯陀含想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  我等本深着　　志乐斯陀含
  今皆得离着　　寂灭无戏论

复有五百亿比丘生阿那含想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  今遭救世尊　　远离诸戏论
  得菩提光照　　永拔诸果想

复有三万五千亿得四禅比丘生阿罗汉想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  我已离烦恼　　通达无异法
  知诸乘平等　　皆悉如幻法

复有二万比丘生声闻想者。从诸比丘闻说偈已。即从坐起乃至和合。住于佛前。而说偈言

  离缚牟尼尊　　止我等虚说
  密说声闻义　　我今皆通达

复有五千比丘生辟支佛想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  我等今现见　　辟支佛所行
  解佛微密义　　难思辟支佛

复有一万比丘尼生须陀洹果想。斯陀含果想。阿那含果想。阿罗汉果想者。从诸比丘闻说偈已。即从坐起乃至和合。住于佛前。而说偈言

  今知平等法　　永断女身分
  佛无有异言　　必成人中尊

复有八万八千优婆塞。生须陀洹果想。斯陀含果想。阿那含果想者。从诸比丘闻此偈已。即从坐起乃至和合。住于佛前。而说偈言

  我等心无垢　　如净毗琉璃
  为修佛法故　　今日当出家

尔时虚空中。有六十亿那由他诸天。以天曼陀罗华而散佛上。散已住立。而说偈言

  本有诸乘想　　亦有诸果想
  今日悉除舍　　必当成菩提

尔时有百千阿罗汉。舍利弗。大目揵连。须菩提。阿泥卢头。离婆多。劫宾那等。即从坐起整衣服。偏袒右肩右膝着地。一心合掌皆共和合。住于佛前而白佛言。世尊。我等今日志愿满足。能降伏魔摧诸怨敌。具足成就五无间业。我等今日满足成就五欲功德。我等今日邪见具足远离正见。我等今日害多百千众生之命。我等今日已逮菩提。即于今日无余涅槃而般涅槃。尔时世尊默无所说

尔时会中有百千众生皆生疑惑。我等今者如在闇中。云何诸大罗汉作如是语。何况凡夫。以疑惑故不能从此至彼从彼至此。坐不能立立不能坐。尔时尊者阿难。知此百千众生心之所疑。亦以佛神力故。问文殊师利法王子言。今此大众百千众生。闻诸大德比丘作如是语皆生疑惑。世尊默然而无所说。愿文殊师利说其因缘。此诸大德比丘。以何因缘说此密语。尔时文殊师利法王子。语尊者阿难言。阿难当知。此是不退转菩萨地事。唯有不退转菩萨。乃能证知此诸大德比丘密语。尊者阿难问文殊师利言。此诸大德比丘。皆是不退转菩萨耶。文殊师利言。如是如是。此诸大德比丘皆是菩萨。已于菩提得不退转。阿难请文殊师利言。愿说诸大德比丘微密语义

文殊师利言。无明能生生死。是故名母。断无明故名为害母。父名不正思惟及以喜爱。彼以永断名为害父。以诸法不可坏。方便坏众多想。亦坏诸行名为坏僧。应坏凡夫法名阿罗汉。以不灭方便灭罗汉想名杀罗汉。以不灭方便灭如来想名出佛身血。如是等想已断已害毕竟无余。阿难。以是事故。诸大德比丘作如是语。我等今日具足成就五无间业。所以者何。于此法中不聚不散不减不满。是故名为五无间业满足成就。阿难当知。彼作是说。我等今日满足成就五欲功德者。彼诸比丘于此五欲。了知如梦如幻如热时炎如影如响。彼于此智满足成就。而于五欲无增无减。所以者何。能知此法毕竟而无所有。以无所有故能如实知。而于彼法得如是忍。故名满足成就五欲功德。阿难。以是事故。彼诸比丘作如是说。我等今日满足成就五欲功德。阿难当知。彼作是说。我等今日满足成就邪见远离正见者。彼诸比丘知诸法邪见诸法邪。阿难。邪名有为。诸法皆是虚妄。此虚妄法犹若虚空不增不减。亦不住方亦无所属。所以者何。离自性故。彼知是法皆悉平等。以平等故正见亦等。彼已远离如是等想。所以者何。若有等想有不等想。彼诸比丘无有等想及不等想。所以者何。诸佛之法离一切想。彼于佛法通达无生。不得无生法。是故阿难。彼诸大德比丘作如是语。我等今日具足成就邪见远离正见。阿难当知。彼作是说。我等今日害多百千众生命者。阿难。彼诸比丘令此时会百千众生诸天及人。知有为法皆悉如幻如影如响。知此法故。离众生想离寿想人想。离一切法想。以一切法不可种。方便种菩提善根。诸比丘比丘尼。优婆塞优婆夷。从诸比丘闻此密语。亦得离众生想寿想人想不数数死。所以者何。若着众生想寿想人想则数数死。彼已远离如是法故毕竟不生。是故阿难。彼诸比丘作如是说。我等今日害多百千众生命根。阿难当知。彼作是说。我等今日已逮菩提。于无余涅槃而般涅槃者。阿难。彼诸比丘。令此大众百千万亿那由他诸天及人。即于今日得离烦恼得逮菩提。所以者何。此诸大众皆发阿耨多罗三藐三菩提心。而于今日闻说金刚句法。皆得无生法忍得见菩提。以是事故而作是说。我等今日逮得菩提。我等今日于无余涅槃而般涅槃者。彼不断烦恼不修佛法无余烦恼。是故阿难。彼诸比丘作如是说。我等今日已逮菩提。于无余涅槃界而般涅槃。言今日者。阿难当知。即于此日不生亦无所生。故名今日。(天竺正音不生与今日音同也)是故阿难。求菩萨乘若善男子善女人发阿耨多罗三藐三菩提心者。于一切法应当渐损以不可得法发菩提心。于一切法是名为出离菩提想。于一切法是名为入无余涅槃而般涅槃。阿难。求菩萨乘族姓子。不应深着日想不应以日而生昼想。阿难。愚小之人以日为昼想。无黠慧故。所以者何。若令此昼是真实是坚牢是常住者。应有积聚不应过去。唯应有昼不应有夜。阿难当知。有昼夜想者此是凡小。是故阿难。求菩萨乘族姓子有深心者。为善知识所护。不应生昼夜想。所以者何。求离一切想是菩提道故。尔时文殊师利法王子。欲重宣此义。而说偈言

  无明名为母　　能生生死故
  已拔其根本　　是故名为害
  不正观思惟　　喜爱名为父
  彼皆如实知　　毕竟无所有
  以知无所有　　而害其根本
  不缘无所有　　是故名为害
  所说罗汉法　　及与凡夫法
  彼已以智坏　　是故名为害
  所有众多相　　已知其性相
  以不可坏法　　坏相名坏僧
  本来所分别　　如来诸法想
  彼已断远离　　知其不生灭
  此想次第起　　思量知是空
  如所说平等　　彼已能证知
  所说欲功德　　其名有五种
  远离此诸想　　知想皆如幻
  是诸比丘等　　于欲无增减
  于导世师前　　而作如是说
  知欲性皆空　　犹如梦所见
  毕竟无所生　　于此智得满
  以邪智知法　　虚伪不牢固
  邪名为虚妄　　于此智得满
  有为法虚妄　　而无有远近
  无知无近远　　如五指摩空
  彼说诸正见　　皆见是平等
  如诸法平等　　知见等亦然
  凡小多分别　　众生想故死
  若不得众生　　亦无有死想
  有缘诸众生　　除其计寿想
  知计寿过患　　除其如是想
  远离众生想　　及与计寿想
  彼作如是说　　害多众生命
  已远离死想　　达无分别法
  知不坏菩提　　不增无果报
  死生不可聚　　觉了清净法
  一切法无诤　　不生常寂灭
  不应分别昼　　亦不分别夜
  于不来去法　　而求于菩提
  凡小恒分别　　以日用为昼
  欲求菩提者　　莫作是分别
  彼以是密语　　宣说如是法
  以知此法故　　能作如是说

文殊师利法王子说此偈已。尔时会中百千众生已拔疑箭。无复疑惑逮大照明。于诸法中得无生法忍。各自脱身所著上服。以奉文殊师利法王子。皆作是言。愿使我等于未来世。说是妙法觉悟众生如今文殊师利法王子觉悟众生。尔时世尊告文殊师利言。善哉善哉。文殊师利。除众生疑照明佛法。法应如是。尔时阿难白佛言。世尊。今此百千众生所有疑箭。非是世尊所拔断耶。佛告阿难。今此百千众生。皆是文殊师利本所教化成就菩提。闻彼说法皆能信解。阿难白佛言。是诸众生皆于菩提不退转耶。佛告阿难。如是如是。是诸众生已于菩提而不退转。所以者何。为文殊师利善知识所护念故

尔时阿难白佛言。世尊。此诸比丘。生坚信想。生坚法想。生八人想。生须陀洹想。生斯陀含想。生阿那含想。生阿罗汉想。生声闻想。生辟支佛想者。皆于菩提不退转耶。佛告阿难。是处难信。乐小法者。懒惰懈怠不勤精进贪着饮食贪着欲染。亲近乐行欲染法者。好喜谈说无益之语。乱心失念不具威仪。心意躁扰不摄诸根轻躁嬉戏愚佷多语。如是众生信是法难。阿难。着增上慢不能护身贪着身命。远闲居处舍多闻法。破戒憍慢毁法窃法。不尊重法毁灭正法。贫穷法财喜乐非法。诽谤正法乐行非法。不知恩报恩。不敬佛法僧。阿难。如是众生信是法难。悭心坚着恶戒嗔心。不解佛法。成就恶慧贫穷智慧。恶友所护远离善友。不为般若波罗蜜所护。不为诸陀罗尼经王所护。起有得见。深重利养贪着衣钵。于衣钵物极生重心。不尊重和上阿阇梨。于初夜后夜不勤行方便。阿难。如是众生信是法难。杀生偷盗邪淫妄语两舌恶口说非时语。贪嗔邪见亲近邪见。修行广布邪方便法。无惭无悔朋党交游。独行无伴离沙门法。行非沙门法。不信空无相无作无为不生不灭一切诸法非破坏相。阿难当知。如是众生信是法难。尔时世尊说是语已。即便默然。尔时阿难承佛威神问文殊师利法王子言。文殊师利。世尊何故默无所说。文殊师利言。将来恶世众生。成就如是恶不善法。不能信解如是深法。以是事故世尊默然。尊者阿难问文殊师利言。来世众生少有信解。如是法不。文殊师利言。来世众生信此法者甚少。犹如众生不识珍宝者多识者甚少。所以者何。非其智力所及。阿难。众生亦尔。闻说此法信解者少。设有信解如是法者。不为国土城村人民所敬。国土人民咸共轻贱而远离之。所以者何。此人先世作法留难业因缘故今受此报。阿难请文殊师利言。惟愿为此少信解众生敷演此义。文殊师利言。此事问佛。佛当演说。尔时阿难。即便问佛

尔时世尊。四面顾视。即出舌相。遍覆三千大千世界。于其舌相复放光明。遍照十方恒河沙世界。皆令周遍。时四部众。佛神力故。皆见十方恒河沙诸佛世界诸佛世尊。皆说是法悉得闻知。闻是法已皆共和合劝请世尊。唯愿如来宣说此法莫令断绝。世尊。今十方诸世界中。无量无边不可限量诸佛世尊宣说是法。我等悉得见闻。其所说法无有增减。如今世尊等无有异。尔时世尊还摄舌相告阿难言。汝颇曾见不实语人有是广长舌相不耶。阿难白佛言。无也世尊。此是世尊诚实说于戒定忍辱。怜愍饶益慈悲喜舍。一切智果所得舌相。是故世尊。唯愿为此少信众生族姓男女敷演此义。因是事故。诸不信者以此证知。皆令得信

尔时世尊告阿难言。今此四众诸来会者。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻说此法者。皆于阿耨多罗三藐三菩提不退转。渐次修行。当得阿耨多罗三藐三菩提。即于此处宣说是法无有增减。如我今日等无有异。尔时四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆大欢喜踊跃无量。其中或有以衣散佛者。或以华者。或以诸鬘。所谓须曼那鬘。金鬘银鬘。毗琉璃鬘。颇梨鬘。车磲鬘。马瑙鬘。象瑙鬘。日光宝鬘。杂七宝鬘。以如是等鬘。而散佛上。诸天以曼陀罗华。摩诃曼陀罗华。波流沙华。摩诃波流沙华。曼殊沙华。摩诃曼殊沙华。迦迦勒羁华。摩诃迦迦勒羁华。卢遮摩祢华。摩诃卢遮摩祢华。输娑摩祢华。摩诃输娑摩祢华。如是等诸华而散佛上。复以天优钵罗华。波头摩华。拘物头华。分陀利华。而散佛上。于虚空中作天伎乐。种种歌颂赞叹佛德。诸龙王等皆雨真珠散于佛上。一切女人即脱身上妙好璎珞以散佛上。脱身上服以用奉佛。即整衣服右膝着地。一心合掌住于佛前。皆共和合而作是言。诸佛如来。言无有二智无障碍。记说我等必当作佛

尔时世尊告阿难言。如是阿难。是诸女人必于阿耨多罗三藐三菩提不退转。所以者何。诸佛世尊。永断愚痴贪欲嗔恚及诸憍慢尘垢黑闇一切染着。烧燃烦恼永尽无余。成就精进成就诸力。威德尊严神足自在光明照曜。眷属成就尊贵威势。色族姓处皆悉具足。相好具足光明具足到安隐处。如释如梵如欲界中尊。威仪具足戒行具足观察具足。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆共尊重恭敬赞叹不染世法。永舍一切诸有为法。成就解脱诸佛之法见闻不虚。阿难白佛言。世尊。云何诸佛世尊闻不虚耶

佛告阿难。汝不知耶。阿难白佛言。世尊。实所未知。唯愿说之。云何如来闻不虚耶

佛告阿难。一心善听。吾今解说。阿难当知。若有众生。已闻今闻当闻释迦牟尼佛名者。是诸众生。皆于阿耨多罗三藐三菩提不退转。所以者何。诸佛菩提无虚妄故。亦无贪欲及以嗔恚。阿难。何况今日现于我前能以一华散我上者。若有众生。我泥洹后形像舍利。能持一华以供养者。如是众生亦于阿耨多罗三藐三菩提不退转。阿难白佛。若有畜生闻释迦牟尼佛名者。皆于阿耨多罗三藐三菩提不退转耶。佛告阿难。若有畜生闻释迦牟尼佛名者。是诸众生皆种阿耨多罗三藐三菩提种子因缘。所以者何。诸佛如来其有闻者闻必不虚。是故诸佛如来言无有二。阿难。譬如尼拘陀树枝叶茂盛。能荫百人至五百人。阿难于意云何。其树种子为大小耶。阿难白佛言。世尊。其子甚小。佛告阿难。是尼拘陀树种子虽小。得地水火风虚空众缘故。而得生长渐次广大。如是阿难。彼诸众生种菩提种子渐次增长。当成阿耨多罗三藐三菩提。而不可腐败不可败坏。所以者何。以不住一切法作种子故。而不腐败亦无毁坏

尔时阿难白佛言。世尊。为是诸佛本愿之力。为是诸佛法应尔耶。佛告阿难。是我本愿。若有闻我名者。必不退转阿耨多罗三藐三菩提。亦是诸佛法应如是。所以者何。一切诸佛法皆等故。阿难白佛。若诸佛法等。以何缘故立誓愿耶。佛告阿难。诸佛世尊宣说法时。会中诸菩萨摩诃萨。闻佛说法即立誓愿。使我将来成佛说法。见闻不虚亦复如是。尔时阿难白佛言。甚奇世尊。成就如此希有之法。复以此法利益众生。佛告阿难。如是如是。如汝所说。我为利益诸众生故。遍诸佛土供养诸佛不惜身命。舍一切物无有悭吝。勤修精进积集难得。无所依倚菩提之道。于一切法而无所取。以摄众生

广博严净经卷第四佛说广博严净不退转轮经卷第五

        宋凉州沙门智严译

尔时阿难白佛言。世尊。甚为希有。魔王波旬。闻说此经不作留难。佛告阿难。以不闻故不作留难。所以者何。文殊师利法王子。以神力隐蔽令不得闻故无留难。尔时文殊师利法王子还摄神力。恶魔波旬。即于梦中闻说新异不退转法轮。亦闻称释迦牟尼佛名。即便惊悟。愁忧恐怖身毛皆竖。即从床上自投于地。作如是言。先所降伏今不伏我。先所领土今不属我。愁忧苦恼发声啼哭。以愁忧苦恼发声啼哭故。身形老瘦犹如百岁老人。尔时恶魔波旬。将四种兵及三千大千世界所有魔天。来诣佛所。犹如菩萨坐道树时。魔严兵众来诣佛所亦复如是。尔时恶魔波旬。身形老劣如百岁人。头低脊膢行步迟重。喘息短气举身战掉。扶杖而行来诣佛所。当魔波旬来诣佛时。于虚空中所将眷属四种兵众。闻说不退转法轮。亦闻释迦牟尼佛名。时四种兵及诸眷属。自然而住不能得前。生如是念。我等不复随从波旬。尔时波旬单独羸老。白佛言。乃至不留一人扶接我者。本降伏者今不伏我。先所领土今不属我。世尊怜愍一切众生。我今亦在众生数中而不垂愍。乃至不留一人授我水者。尔时世尊告波旬言。众生界多是无尽法。波旬当知。假令日日恒河沙等诸佛出世。一一诸佛于日日中度恒河沙众生令般涅槃。而众生界犹不可尽。时魔波旬复白佛言。众生界虽不可尽。如我今者单独羸老。在道行时若其颠躄。乃至无有扶接我者。唯愿世尊。安慰我意。令我欢喜速得还去。佛告波旬。且安意去。若有众生。不信不解不退法者。是诸众生皆属于汝。是汝眷属汝得自在。一切皆是扶接汝者。尔时波旬闻是语已。欢喜踊跃作如是言。我今当为众生作诸留难。令于此法不信不解生于疑惑。生疑惑故当属于我。我得自在。尔时波旬复白佛言。唯愿世尊。重安慰我令我欢喜而得还去。佛自说言。若有众生闻我名者。皆于阿耨多罗三藐三菩提而不退转。从今已往更莫复说。所以者何。若有众生闻此语已。勤行精进求佛菩提。尔时世尊告波旬言。汝安意去。我当令诸众生乃至无有住菩提者。亦复无有出众生界者。无有众生离色阴者。离受想行识阴者。波旬且安意去。我常令诸众生。无有离身见者。离戒取见取者。离有所得者。离六十二见者。离过去未来现在想者。离杀生者。离不与取邪淫者。离妄语绮语恶口两舌者。离贪恚邪见者。波旬且安意去。我不教众生而行布施持戒忍辱精进禅定智慧。亦不教众生行四摄法。不令众生离众生想。离悭着想。离父母想。离兄弟姊妹男女想。离昼夜想。离半月一月一年想。离布施持戒忍辱精进禅定智慧想。菩提心想。力无畏想。根力觉道想。佛法僧想。障菩提想。一切种智想。波旬汝且安意去。我当令众生于一切法无远离想。尔时波旬欢喜踊跃拔愁忧箭。即于是处还复本形。以诸天花而散佛上。绕佛三匝住于佛前。而说偈言

  今日两足尊　　说此微妙音
  佛无有二言　　今我大欢喜

时魔波旬说此偈已欢喜安意渐离佛去。还本天宫皆共和合。受五欲乐以自娱乐。更不复生留难之心。说此降伏遣魔法时。大地六种震动。阿难白佛言。世尊。以何因缘大地震动。佛告阿难。说此降伏遣魔法时。六万四千菩萨。于诸法中得无生法忍。阿难白佛言。世尊。今此会中颇有疑惑是法者不。佛告阿难。令此会中有十亿众生。皆生疑惑心意迷闷。作如是说。为是何语。将非我等错谬闻耶。以是事故不知时方。亦不自知从何所来欲至何所。以疑惑故各不相见。阿难白佛。唯愿世尊。以慈悲心为此众生速作照明。莫令此众怀疑惑故堕于恶趣。以何因缘而作是说。恶魔波旬且安意去。我不令众生住于菩提。乃至波旬且安意去。我不令众生于一切法无远离想。唯愿世尊。为此众生速作照明。亦令将来众生逮照明故。受持此法而不忘失。愿分别说。尔时世尊。便说偈言

  菩提无住相　　亦无能住者
  是故说众生　　无住菩提者
  菩提与众生　　无二无有异
  是故说众生　　无住菩提者
  亦无有众生　　能离众生界
  无所有不生　　毕竟不可得
  难思众生界　　其性本自空
  假令一切智　　不见其离想
  我所说诸阴　　无众生能离
  此阴与众生　　无异常寂灭
  已知阴是空　　而不离其性
  说其体是一　　不可取而离
  已能知诸阴　　不取不可离
  无我无自性　　毕竟无所依
  诸阴如虚空　　阴所行亦尔
  行无所行故　　说阴如虚空
  如说虚空界　　非生非能生
  阴性亦如是　　无有能离者
  身见自性相　　无法而可得
  以不可得故　　我说不可离
  疑无有自性　　毕竟不可得
  以不得疑故　　众生无能离
  无有诸众生　　能持选择戒
  见取诸众生　　亦复不可得
  计有得法者　　众生不可得
  有得法无心　　不离于自性
  如所说诸见　　凡有六十二
  如是等诸见　　皆如水中影
  已知此诸见　　皆如水中影
  无我无所有　　自性不可得
  过去未来想　　及与现在想
  此想无所有　　亦如水中影
  此想无有我　　众生不可得
  以不得众生　　是故不可离
  杀害诸众生　　必趣崄恶处
  安置涅槃中　　无有能动者
  众生若可得　　可有离动相
  众生无有实　　故说不可离
  菩提名不与　　未曾有与者
  虽勤作方便　　而无动离者
  不行施众生　　教行胜法施
  虽勤作方便　　而无动离者
  亦不得众生　　依倚淫欲者
  欲中无有邪　　可与非邪合
  妄语诸众生　　有缘者应化
  虽勤作方便　　而无动离者
  两舌与恶口　　及以非时言
  如是等言说　　如响令人惑
  此法无处所　　亦不可染着
  此诸声如响　　知其无所依
  本所有无明　　深计着于我
  以知我真实　　无能动离者
  亦能知嗔恚　　毕竟无有相
  菩提无相故　　无能动离者
  若能知邪见　　是名为正见
  以过着见法　　无能动离者
  不教诸众生　　而以女色施
  贤圣所禁制　　是施有过患
  邪见所持戒　　圣道所捐弃
  智者不应教　　以此求圣法
  外道所称赞　　种种诸忍相
  此忍非正道　　令人到涅槃
  外道所称赞　　五热精进法
  不能至菩提　　智者应舍离
  外道诸禅定　　尽行诸有想
  非诸佛所赞　　是以不教他
  不用世俗慧　　教化诸众生
  此慧不能得　　不思议佛慧
  于清净众生　　成就无畏者
  我说于是众　　不行四摄法
  深敬念佛者　　不教离是着
  佛有无染智　　亦无诸障碍
  深敬念法者　　不教离是着
  离欲最胜法　　云何而可离
  不着众生想　　而发菩提心
  菩提不可着　　云何而得离
  父母及兄弟　　姊妹男女想
  此想皆如幻　　云何而可离
  此想一切处　　无法无所有
  无法无有故　　云何而可离
  昼想及夜想　　半月一月想
  此想无真实　　如热时炎水
  施想与戒想　　忍辱精进想
  此想非真想　　云何以想离
  定想及慧想　　菩提心之想
  力无畏诸根　　是想皆虚诳
  诸觉及道想　　佛想与法想
  皆从无知起　　云何离此想
  分别诸僧想　　此想亦众多
  从分别起故　　我说不可离
  不着菩提想　　及一切智想
  此想远诸佛　　不思议菩提
  以是故我说　　波旬无智人
  不离此诸想　　而远求菩提
  诸法及菩提　　皆悉知如如
  宣说不离义　　去魔忧恼心

世尊决定说此降伏遣魔法时。会中十亿众生。拔犹豫箭无复疑惑。逮大照明。于诸法中得无生法忍。会中十亿众生皆共和合。住于佛前。而说偈言

  不思议佛道　　今我以证知
  佛是导世师　　除断我疑心
  以逮大照明　　安住佛法中
  诸方明净故　　得见一亿佛
  亦得见其法　　知色等不生
  遭遇救世师　　得净如是智
  亦得见一亿　　诸佛严净土
  无上导世师　　皆悉住其中

尔时十亿众生说此偈已。脱身所著上妙之服。为供养法欢喜奉佛。作如是言。愿令此法流布一切众生皆得耳闻。尔时阿难白佛言。世尊。若有众生。闻是降伏遣魔法者。能信能解不生疑惑。是善男子善女人得几所福。佛告阿难。若善男子善女人。闻此降伏遣魔法一经耳。能信能解不疑惑者。功德甚多不可限量。阿难白佛言。其所得福可以方喻知不。佛告阿难。若善男子善女人。于日初分供养百千诸佛。于日中分供养百千诸佛。于日后分供养百千诸佛。尊重赞叹以上妙房舍。一切所须皆悉充足。经百千劫。是善男子善女人。所得功德宁为多不。阿难白佛言。世尊。甚多甚多。不可限量难以喻知。佛告阿难。若善男子善女人。闻此降伏遣魔法一经耳。能信能解不疑惑者其福胜彼

尔时虚空中有三善男子求菩萨乘。自然而现渐渐而来。各各执持千大莲花。其花高广踰须弥山。有百千万亿叶。出百千万亿光色。尔时尊者阿难及诸时会。皆共遥见三善男子求菩萨乘者。渐渐而来。见已生希有心。尔时阿难白佛言。世尊。此善男子为从何来。佛告阿难。东方过恒河沙佛土有世界。名花高须弥山。此善男子。于彼世界。闻说此法及上因缘。以是故来。阿难白佛。彼世界佛名号何等。佛告阿难。彼佛名华高须弥山王如来等正觉。今现在说法。尔时三善男子求菩萨乘者。前诣释迦牟尼佛。头面礼足右绕三匝。右膝着地一心合掌。以所执华而散佛上。作如是言。世尊。我等今于此法。能信能解不生疑惑。所以者何。我等于此法中。无有疑惑犹如如来。尔时第一善男子求菩萨乘者白佛言。世尊若作是说。我是如来。此言便是正说。所以者何。我于此法不生疑惑故。尔时第二善男子求菩萨乘者白佛言。世尊。若作是说。我是世尊。此言便是正说。所以者何。我于此法不生疑惑故。尔时第三善男子求菩萨乘者白佛言。世尊。若作是说。我是佛。此言便是正说。所以者何。我于此法不生疑惑故

尔时会中百千众生。心皆扰动不安本坐作是念。无有二佛并出世间。今此善男子。以何等故发如是言。作是念已。展转相语且共默然。世尊在座自当解说此诸菩萨如是语义。尔时阿难白佛言。世尊。此诸菩萨名字何等。乃能作是大师子吼。佛告阿难。其一菩萨名乐求如来音声。第二菩萨名乐求世尊音声。第三菩萨名乐求佛音声。阿难当知。以是缘故。彼菩萨摩诃萨作如是说。阿难白佛言。世尊。今此会中有百千众生。心皆扰动作是念。无有二佛并出世间。以何缘故彼作是说。唯愿如来敷演其义。令此大众心不扰动。所种善根增益明净。世尊。如人澡浴严治发爪肤色鲜净。复以赤栴檀水更浴其身。肤色鲜净倍胜于前。世尊。是诸众生亦复如是。若闻说是语义。所种善根增益。明净倍胜于前。尔时世尊。即说偈言

  皆共一心听　　我说是语义
  何故名如来　　世尊及佛耶
  能知过去如　　亦知未来如
  见一切法如　　是故名如来
  如先昔诸佛　　行不思议施
  我亦行此施　　是故作是说
  如先昔诸佛　　求无依倚道
  我亦如是求　　是故名如来
  不住一切法　　求寂静菩提
  亦不得菩提　　是故名如来
  如昔诸菩萨　　勤苦行忍辱
  我亦行是忍　　能到忍彼岸
  如我昔精进　　勤求于菩提
  彼亦勤精进　　是故名如来
  彼已能通达　　诸法平等相
  亦不生心念　　是故名如来
  不念一切法　　其性常平等
  知此平等已　　而无差别心
  已能通达此　　如如平等定
  通达此定故　　是故名如来
  所说一切法　　各自有性相
  已知此性相　　毕竟常寂然
  知相名为慧　　知虚名为智
  若能知众生　　名到慧彼岸
  如先昔智者　　智慧到彼岸
  亦不得此慧　　到彼岸寂然
  彼亦得此慧　　而到于彼岸
  不得此慧故　　是故名如来
  不得菩提如　　其性相难议
  不得一切法　　是故名如来
  已能逮无著　　不着如如来
  不着一切法　　通无著道故
  如先导世师　　能知见正道
  此道真实相　　未曾有始终
  彼亦如是修　　最胜无上道
  此道无始终　　性空无所有
  知道无始终　　诸法皆平等
  亦知如平等　　是故名如来
  道如菩提如　　及与不住如
  知如如虚空　　是故名如来
  我所说诸法　　其如常平等
  若能见此如　　应当求菩提
  阿难以是事　　彼作如是说
  如说能修行　　彼亦如是行
  若能行是行　　能作如是说
  知是不退转　　无畏诸菩萨
  阿难应当知　　无畏诸菩萨
  能作如是说　　自言是如来

阿难白佛言。世尊。以何因缘。得何等法名世尊耶。尔时世尊。便说偈言

  皆共一心听　　此百千亿劫
  求如是菩提　　无量难思议
  为诸众生故　　求如是菩提
  未曾有怖畏　　是故名世尊
  不畏于生死　　正住生死中
  化度诸众生　　是故名世尊
  云何不怖畏　　云何住生死
  云何度众生　　云何名世尊
  生死无有法　　而可破坏者
  不牢不破坏　　以此度众生
  是名不怖畏　　是名住生死
  是名度众生　　是名为世尊
  知诸法虚空　　而无怯弱心
  宣说诸法相　　而无所怖畏
  已断诸怖畏　　远离诸难处
  不畏难处故　　度难处众生
  度多亿众生　　过生死崄难
  亦不得生死　　及所度众生
  安置诸众生　　寂静涅槃岸
  亦不得众生　　是名为世尊
  恒为诸众生　　说如虚空法
  未曾生怖畏　　是名为世尊
  法性无差别　　说有种种名
  平等如菩提　　菩提不可得
  教导诸众生　　令趣向菩提
  虽教如是法　　未曾有所说
  不可说而说　　度脱多众生
  无畏无所取　　是故名世尊
  远离一切想　　能修菩提相
  已过一切想　　是名为世尊
  已能灭诸想　　烦恼无有余
  以是故得称　　名之为世尊
  以慧观诸法　　知诸法平等
  常不求少法　　是故名世尊
  不重于名誉　　亦不求名誉
  恒为诸众生　　说离名誉法
  菩提离名誉　　彼亦如是求
  若有重名誉　　是名远菩提
  是声犹如响　　分别故多种
  横生诸分别　　我有如是名
  不着一切声　　亦不依倚名
  无戏论菩提　　是名为世尊
  知如是诸法　　名之为世尊
  亦不得菩提　　是故名世尊
  知如是诸法　　而无有所著
  求如是菩提　　解脱无有漏
  阿难以是事　　及诸余因缘
  菩萨摩诃萨　　自言是世尊

阿难白佛言。世尊。以何因缘。得何等法名为佛耶。尔时世尊。便说偈言

  觉知一切法　　此法无所有
  已觉无有法　　是故名为佛
  觉了诸烦恼　　不令得自在
  以智离烦恼　　是故名为佛
  能觉此身空　　此身无所属
  此身不牢固　　牢固不可得
  愚于不牢身　　而生坚牢想
  彼如实觉知　　是故名为佛
  觉无明无智　　自性无所有
  已得于明智　　是故名为佛
  所有过去想　　觉知是无想
  知想无相故　　更不随此相
  修未来诸想　　现在想亦然
  已修一切想　　是故名为佛
  觉知色前际　　未曾有生起
  凡小虽分别　　不能令色生
  觉受无根本　　根本不可得
  于一切法中　　亦无有受者
  知想犹如幻　　其性无所有
  于一切法中　　不为想所累
  知行不能作　　种种诸身相
  身空行亦空　　是故无所作
  知行及与身　　犹如芭蕉树
  如实能觉知　　是故名为佛
  观识之实性　　亦不在身内
  亦不在身外　　而可有是识
  于一切法中　　识性不可得
  而于此身中　　无形无处所
  能如是知识　　识性无所有
  无想犹如幻　　未曾见识生
  于一切法中　　无有见识者
  一切众生性　　未曾有作者
  众生无作者　　诸法毕竟然
  若法若众生　　无有来去相
  觉一切诸法　　毕竟无有相
  无分别戏论　　是故名为佛
  如诸佛不住　　佛正法大乘
  不住一切法　　是故名为佛
  如如诸法如　　诸佛不住如
  佛如菩提如　　是竟不可得
  为求菩提故　　应发如是心
  能觉此心相　　少法不可得
  为求菩提故　　应发如是心
  此心菩提等　　亦觉知如幻
  阿难以是事　　彼作如是说
  自言我是佛　　如佛导世师
  以佛之名声　　说如是等法
  若有住此法　　尽应求菩提
  若有知此法　　是则近菩提
  于一切法中　　不生诸疑惑
  于诸法无疑　　必为世间上
  已知此法故　　能解密语义

尔时世尊。说如来世尊佛名已。是时会中百千众生白佛言。世尊。我等无复疑网逮大照明。得解菩萨摩诃萨名为如来世尊佛义。以一切法不可得故。于诸法中逮得法忍。如来今者犹如父母矜接我等。不令我等心有扰动。亦得觉知不扰动法。犹如虚空不可扰动。所以者何。我等今者觉一切法。犹如虚空无扰动故。尔时会中百千众生。头面礼佛右绕三匝。去佛不远默然而坐

尔时会中有菩萨摩诃萨。名常笑诸根清净。即从坐起。以种种华而散佛上。即说偈言

  众生多果想　　能解彼果想
  离果得具足　　故礼世间智
  众生贪着果　　行种种果名
  唯佛能除解　　故礼世间智
  宣说果平等　　而以觉悟他
  说果是假名　　故礼世间智
  宣说平等法　　住平等法中
  觉一切法等　　故礼世间智
  众生得果想　　除此有得心
  唯佛能除断　　故礼世间智
  具知果寂灭　　不住种种果
  诸佛善密语　　故礼世间智

尔时常笑诸根清净菩萨摩诃萨。说是偈已。赞叹世尊。头面礼足右绕三匝。去佛不远一心观佛。目不暂眴欢喜而住。尔时会中有菩萨摩诃萨。名莲华德藏。即从坐起。以花散佛。说此偈言

  众生多有想　　能解此有心
  离怖无所取　　故礼牟尼尊
  于诸有寂静　　说无所有法
  远离一切有　　故礼牟尼尊
  知有是空无　　其性无有我
  以远离有畏　　故礼牟尼尊
  远离诸忧戚　　能拔忧戚者
  永断诸系缚　　故礼牟尼尊

尔时莲华德藏菩萨摩诃萨。说此偈已。赞叹世尊。复更说偈。而白佛言

  于后恶世中　　若有闻此经
  不生怖畏者　　皆应合掌礼

尔时无垢意菩萨摩诃萨。即于佛前。而说偈言

  若有闻此经　　不生疑惑者
  于一切时中　　应以众花散

尔时广思惟菩萨摩诃萨。即于佛前。而说偈言

  此经中广说　　无量诸佛法
  众生闻是法　　不疑惑者少
  贪着于己身　　生种种身想
  得闻如是经　　云是颠倒说
  当知属于魔　　为魔所抑持
  无智闻此经　　返更生疑惑

尔时青莲华目菩萨摩诃萨。即于佛前。而说偈言

  若有闻此经　　不生疑惑者
  犹如世间眼　　亦名施眼者

尔时乐供养塔菩萨摩诃萨。即于佛前。而说偈言

  若有闻此经　　深生信乐者
  此人处世间　　犹如最上塔

尔时渴仰意菩萨摩诃萨。即于佛前。而说偈言

  虽在生死中　　应数生渴仰
  不着一切法　　能不疑此经

尔时乐以衣施菩萨摩诃萨。即于佛前。而说偈言

  应以多亿衣　　细软而平正
  以供覆其身　　不疑此法者

尔时乐以食施菩萨摩诃萨。即于佛前。而说偈言

  所说诸肴膳　　味中最上者
  应以供其人　　不疑此法者

尔时悲念乐见众生菩萨摩诃萨。即于佛前。而说偈言

  悲念诸众生　　应数数涕泣
  而于此经中　　无有信乐意
  若人少时间　　疑惑于此经
  当知地狱来　　还趣向地狱
  亲近恶知识　　不解是深法
  无明网所覆　　不向此妙趣
  破戒自缠裹　　恶意好求短
  贪着于利养　　能诽谤是经
  不勤求菩提　　懈怠不精进
  恶慧乐小法　　不信解是经
  贪利养众生　　计我随爱欲
  深着于三世　　不能信是经
  愚佷恶心性　　染爱盲无智
  好乐多谈说　　而不信是经
  好选择衣服　　贪味嗜饮食
  少于白法者　　能诽谤是经
  着果诸众生　　好说着果法
  解佛微密语　　如是者甚难
  过去先昔佛　　无上导世师
  尽能供养者　　能信解是经

尔时远离恶法菩萨摩诃萨。即于佛前。而说偈言

  愚心贪着果　　能诽谤是经
  应远离是人　　犹如臭粪秽
  亦如烂死尸　　行者皆远避
  谤此经众生　　皆应常远离
  犹如劫村贼　　住大旷野中
  闻者皆驰走　　恐为我作难
  应如是驰走　　远离是恶贼
  嗔恚怀恶意　　诽谤是经者

广博严净经卷第五佛说广博严净不退转轮经卷第六

        宋凉州沙门智严译

尔时阿难白佛言。世尊。甚为希有。是诸菩萨摩诃萨。决定善说菩提之法。世尊。为是自三昧力。为是佛威神力。为是此经三昧力能作是说耶。佛告阿难。是诸善男子。曾于六十亿那由他诸佛所。闻说是经无有增减。如我今者说微密语。等无有异。彼不以三昧力故能作是说。所以者何。彼于此经现见通达故。尔时阿难白佛言。世尊。若有闻此经能信能解不生疑惑者。世尊。是善男子善女人得几所福。佛告阿难。若善男子善女人。欲求阿耨多罗三藐三菩提。以满阎浮提七宝施诸如来。若有善男子善女人。得闻是经信解不疑。阿难当知。其所得福甚多甚多。阿难。置阎浮提。假使以恒河沙世界满中七宝施诸如来。若有得闻此经信解不疑。其福胜彼。尔时世尊。欲重宣此义。而说偈言

  若以阎浮提　　满中七宝施
  奉诸佛如来　　慈悲导世者
  亦如恒河沙　　数等诸世界
  满中诸珍宝　　以奉上诸佛
  若有闻此经　　能信能解者
  亦不生疑惑　　其福胜于彼

尔时阿难白佛言。世尊。若有善男子善女人。得闻是经能信能解。能信解已。复能受持读诵通利。是善男子善女人得几所福。佛告阿难。若善男子善女人。求阿耨多罗三藐三菩提。远离是经。于百劫中。行檀波罗蜜奉施诸佛。如是于百劫中。护戒忍辱精进禅定。起五神通修行智慧。以远离此经故。不如善男善女。得闻是经信解不疑。受持读诵悉令通利。其福胜彼。尔时世尊。欲重宣此义。而说偈言

  若满百劫中　　以种种肴膳
  以供导世师　　未名供养佛
  若能持此经　　是名供养佛
  诸佛敬法故　　是无上恭敬
  若满百劫中　　以种种衣散
  救世大精进　　未名供养佛
  若能持此经　　是最胜供养
  是名供养佛　　胜前以衣施
  若满百劫中　　以种种华散
  救世大精进　　未名供养佛
  欲以最胜供　　供养诸佛者
  应当持此经　　不染着诸果
  此供是大供　　诸供中最上
  若能持此经　　而不计于我
  若满百劫中　　坚固守净戒
  若不持此经　　彼皆无名称
  若能持此经　　此戒有名称
  于诸戒中上　　胜先行戒施
  虽有纯净戒　　无量难思议
  应当常勤求　　受持如是经
  如此经中说　　善修戒行者
  不名为恶戒　　亦不名破戒
  若持此经戒　　名持菩提戒
  持菩提定戒　　具足无作戒
  如是等诸戒　　皆于此经说
  若能持此经　　具足一切戒
  若人满百劫　　能行大忍辱
  众生恶口骂　　其心皆能忍
  若截其手足　　其身不扰动
  未曾起恶心　　嗔恨于他人
  行如是忍辱　　如忍辱仙人
  虽经百劫中　　其忍不为上
  若有闻此经　　信解能堪忍
  是忍名为上　　是忍名贤善
  是忍名最胜　　是忍无有上
  若能持此经　　而无所染着
  欲求无染着　　诸佛无上智
  不应生染着　　速受持此经
  若满百劫中　　常立不坐卧
  除却诸睡眠　　勤行大精进
  智者勤精进　　流布如是经
  是人到无畏　　胜彼大精进
  若满百劫中　　能起五神通
  不得闻此经　　其智不为上
  若能持是经　　通达无依义
  于诸神通中　　是神通最上
  若满百劫中　　修行诸智慧
  此慧是世间　　分别世间法
  若不学此经　　不名为明慧
  若能学是经　　是名坚固慧
  若有闻此经　　信乐无有上
  是人名为慧　　亦名通达者
  欲以如是慧　　能知诸法如
  应宣说此经　　当得如是慧
  慧者所行法　　皆此经中说
  应当勤精进　　受持于此经

尔时阿难。即于佛前。而说偈言

  应往一由旬　　乃至百由旬
  听受如是经　　能舍离诸果
  设有大火坑　　纵广一由旬
  智者从中往　　听受如是经
  欲得诸圣戒　　于诸戒中上
  应流布是经　　能净于戒身
  欲得诸圣禅　　于诸禅中上
  应流布是经　　烧一切烦恼
  欲得诸圣慧　　于诸慧中上
  应流布是经　　能净诸法界
  欲往诣诸方　　严净诸世界
  其界名喜乐　　应流布是经
  欲见阿閦佛　　诸牟尼中尊
  应当持是经　　广为众生说
  若欲净菩萨　　种种之所行
  应流布是经　　得往安乐界
  得见弥陀佛　　光明不可议
  应流布是经　　诸佛之所说

尔时世尊告阿难言。善哉善哉。如汝所言。所以者何。若善男子善女人。以不散心读诵此经为他解说。欲见诸佛即皆得见。若以散乱心读诵此经为他解说。其人命欲终时。眼见百千诸佛。所以者何。一切诸佛皆守护是善男子善女人故。尔时会中有一童女。名曰师子。与五百童女俱即从坐起。偏袒右肩右膝着地。一心合掌白佛言。若有女人。受持此经读诵通利有何功德。尔时世尊告师子言。若有女人。欲求阿耨多罗三藐三菩提。受持是经读诵通利。当知是身最是后边。所以者何。若有女人。以不散乱心受持是经读诵通利。所有烦恼受女人身者不现在前。师子白佛言。世尊。何等烦恼能受女身。佛告师子。凡诸女人见他女人形容端正。以金银珍宝种种珠玑。严饰其身受众快乐。见已生爱着心。不能如实观察此身。但是粪聚臭秽不净。假以彩色众香涂熏。惑愚者眼便生染着。起诸烦恼故受女身。复次师子。女人之性多诸悭嫉。言说时异。心思时异。现前语异。屏处语异。为气味故。有诸女人不为正法。嗔恚所弊睡眠所盖乐喜谈说。以是缘故不能受持此经。又于昼夜多染污心少出要心。成就如是诸恼心故。恒受女身不能令止。是故师子。若女人欲不起烦恼不受女身者。应当受持读诵此经为他解说。所以者何。此经能除女人诸烦恼故。师子复白佛言。世尊。若有女人。不为离女身受持此经读诵通利者。当受女身不。佛告师子。若有女人。虽不为离女身。受持此经读诵通利。当知此身最是后边。除其神足现女身者。师子。譬如有人投大火聚。而作是言。莫烧我身烧我肤色。于意云何。是人所语得称意不。师子白佛言。不也世尊。所以者何。火性坏人形色。佛告师子。此经亦尔。烧诸烦恼令无有余。是故师子。若有女人。欲不受女身。欲速得一切佛法。欲得见无量无边诸佛。欲得无碍辩才。欲以慈心遍缘一切众生者。应受持此经读诵通利为他解说。尔时师子及五百童女白佛言。世尊。我等于燃灯佛所受持是经。如是展转至于今日

尔时阿难白佛言。世尊。是师子童女。未尽女身分耶。佛告阿难。于意云何。汝谓师子是女人耶。阿难白佛言。如是世尊。佛告阿难。莫作是言。所以者何。是师子及五百童女。以神通力现为女身。怜愍饶益未来世中诸女人故。所以者何。一切男子不得随意入诸家中。是故阿难。师子童女。以神通力现受女身。而此女人。无女人法。无男子法。无非男非女法。所以者何。女人法男子法非男非女法不可得故。阿难。是师子于此法中不得一切法。成就法忍逮大照明。是故阿难。一切女人应当随学。如师子童女受持是经读诵通利为他解说。尔时会中有五千比丘尼。即从坐起偏袒右肩右膝着地。一心合掌白佛言。世尊。我从今日受持是经读诵通利为他解说。所以者何。我不愿乐更受女身。受持是经。若不究竟读诵通利。终不坐卧亦不睡眠。佛告诸比丘尼。善哉善哉。作如是言。发大庄严而自庄严。以大精进而自精进。所以者何。汝等不乐女身乐求佛法。是故汝等倍加精进。坚心受持读诵是经。悉令通利为他解说。当知汝等所受女身最是后边。尔时诸比丘尼。闻佛所说欢喜踊跃。各各脱身所著郁多罗僧。以散佛上。而说偈言

  佛无有二语　　必成男子身
  说我等作佛　　我志愿满足

尔时会中有五千居士妇。从诸比丘尼闻是偈已。即从坐起偏袒右肩右膝着地。一心合掌白佛言。世尊。我等今者受持此经。读诵通利为他解说。所以者何。我等今者欲得远离不自在身。视人颜色犹如婢妾。女人之身虽生王家长养。令大娉与他王不得自在。尽其形寿奉事其夫。怀妊十月受种种苦。以是事故。我等从今勤加精进。受持是经为他解说。受一食法奉持斋戒。胁不触地。乃至夺命。誓不与夫携手亲近。要当受持读诵是经。尔时世尊告诸居士妇言。善哉善哉。诸善女人。快说此言。汝等从今更不属他。常得自在。不视他颜色。无怀妊苦。不更处胎。生无淫欲无女人处诸佛世界。尔时阿难白佛言。世尊。此诸姊等所生之处。世界何名佛号何等。佛告阿难。世界名众宝华光。佛号放众宝摩尼王光如来等正觉。今现在说法。此诸女人当生彼国。诸居士妇。受持是经故得见彼佛。尔时诸居士妇。闻说是已。皆生欢喜。踊跃无量。即解颈十千真珠璎珞。持用散佛。即于佛前。而说偈言

  我等获善利　　得远离女身
  佛无有二语　　所说皆真实
  永弃如是身　　卑陋女人相
  但诳无智人　　不能如实知
  更不如婢妾　　属他不自在
  亦不复十月　　怀妊受众苦
  终不复更受　　处胎诸恶法
  已得离胎智　　此智无有上

尔时诸居士妇说此偈已。头面礼佛右绕三匝。去佛不远皆共就坐。一心观佛目不暂瞬

尔时释提桓因。以天拘薮摩花而散佛上。作如是言。世尊。我当受持是经读诵通利为他解说。佛告释提桓因。憍尸迦。汝若如是终不更与阿修罗战

尔时文殊师利法王子。欲令百千众生所有善根转明净故。白佛言。世尊。如来昔者从我闻说是经发菩提心。佛告文殊师利。以是事故。汝于百千万亿那由他菩萨众中。最为明照。于十方世界开悟众生。如日光明。即时大地震动。天雨众华。绕佛世尊积至于膝。尔时阿难白佛言。世尊。以何因缘大地震动。散诸天华积至于膝。佛告阿难。今百千万亿那由他诸天。从文殊师利闻说此言。欢喜踊跃散众天华。皆发是言。我等当受持读诵是经为他解说。如文殊师利法王子快说是言。我等亦当随学。如文殊师利照明世间。我等亦当如是照明。说此语时。皆得忆念是经如现在前。是故心生欢喜踊跃无量。复闻我从文殊师利得闻此经。阿难。是故大地震动天雨众华。尔时阿难白佛言。世尊。此经成就诸大功德。此经成就未曾有功德。非是成就少善根众生得闻此经。佛告阿难。如是如是。如汝所言。若善男子善女人。供养无量百千诸佛乃闻是经。闻已信解受持读诵为他解说。阿难。此善男子。在天人中当知如塔。若有受持读诵是经者。其人所住方面便有明正法人。复次阿难。若有受持是经读诵通利为他解说。乃至书写经卷而供养者。当知是人离诸恶趣。已能降伏恶魔波旬。建立法幢能行法施。燃大法炬破无明闇。吹大法蠡趣向道场。击大法鼓开甘露门降大法雨。充足一切乐求法者。开诸法藏诸佛所聚出大法财。知一切法远离诸想。所谓色受想行识想。眼耳鼻舌身意想。色声香味触法想。远离一切诸法想。乃至佛法僧想。阿难。若有从我闻此经者。受持读诵。当知是人便是我子。从佛口生从法身生。是故阿难。若有众生。欲食如来食。欲坐道场欲说正法。如我今者。应受持是经读诵通利为他解说。乃至书写经卷受持供养

尔时阿难白佛言。世尊。未来世中受持是经读诵通利为他解说。乃至书写经卷而供养者。皆是今日受持读诵是经者耶。佛告阿难。如是如是。所以者何。我未曾见诸余世间。天人魔梵沙门婆罗门人及非人。于未来世能说是经。令他闻者无有是处。阿难。能于今日积聚法财。于未来世随意受用。譬如居士若居士子。其家大富多饶财宝。金银琉璃真珠摩尼。珂贝璧玉仓库盈溢。奴婢僮仆象马牛羊如是众多。往至余方游戏观看。其人后时还至财所得受用不。阿难白佛言。世尊。自在受用。是其财故。如是阿难。若于我前得闻此经。于未来世亦复得闻。受持读诵如是经典。而设供养犹如令日。阿难。我以佛眼见有信解受持是经读诵通利为他解说。乃至书写经卷如今。阿难。而供养者。亦见诽谤不信受者。尔时阿难白佛言。世尊。若有众生不信解是经而诽谤者。其人罪报当生何处。佛告阿难。且止不须问也。阿难白佛言。世尊。惟愿说之。为不信此法众生生信乐故。佛告阿难。其人罪报生处。与五无间业等。阿难于意云何。假使有人于一日中。悉断三千大千世界众生命根。其人生处罪报云何。阿难白佛言。甚恶世尊。佛告阿难。其人罪报亦与彼等。阿难于意云何。假使有人。若坏若烧恒河沙诸佛般泥洹后所起塔庙。得罪多不。阿难。白佛言。甚多世尊。眼不应视。耳不应闻。佛告阿难。其人生处罪报云何。阿难白佛言。世尊。甚恶甚重。佛告阿难。其人罪报亦与彼等。阿难于意云何。假使有人。坏乱过去未来现在诸佛正法。其罪云何。阿难白佛言。甚重世尊。佛告阿难。其人罪报亦与彼等。阿难白佛言。世尊。若有毁呰诽谤令众生远离是经。其罪云何。佛告阿难。于意云何。三千大千世界众生。皆行十善求阿耨多罗三藐三菩提。假使有人毁坏其眼。其罪多不。阿难白佛言。甚多世尊。当于百千万亿那由他劫。在地狱中受诸苦恼

佛告阿难。我今语汝。若有众生毁谤此经。乃至一人令远离者。当知此罪亦与彼等。阿难白佛言。世尊。若有菩萨。欲求阿耨多罗三藐三菩提。于此经中虽有疑心而不诽谤。其罪云何。佛告阿难。若生疑心则逆诸佛而有罪过。经一亿劫远离菩提。阿难白佛言。世尊。若有众生诽谤是经。令多众生而远离者。所受罪身大小云何。佛告阿难。且止不须问此罪身大小。阿难白佛言。世尊。惟愿说之。令此四众来世众生惭愧怖畏。佛告阿难。其人罪身长一万由旬受无量苦。阿难白佛言。其人不能护口。所受舌报大小云何。佛告阿难。其罪人舌。纵广一千由旬。五百铁犁光焰炽燃以耕其舌。复有五百铁丸。光焰炽燃雨其舌上。以其前世不护口故。尔时四众皆生怖惧身毛皆竖。涕泣流泪举身投地。皆共同声作如是言。世尊。我等今者为彼族姓子族姓女发露忏悔。愿令远离如是罪身不受众苦。会中复有涕泣流泪作如是言。世尊。我等若于此生。若前百千万亿那由他生。曾起疑心作是众苦因缘者。我等今于如来等正觉前。及余百千万亿不可限量诸佛世尊前发露忏悔。诸佛如来愿以佛眼见知我等。我等今者所有罪业。皆悉发露不敢覆藏。我等愚小。无知无觉无有方便。惟愿诸佛。以怜愍故受我等悔。佛告诸善男子。善哉善哉。汝等。今于我前不覆藏罪发露忏悔。于我法中便为增益。阿难白佛言。世尊。今此会中生疑心者。皆受如是地狱苦耶。佛告阿难。今此会中生疑心者。以悔过故其罪甚少。阿难白佛言。彼人受罪为多少耶。佛告阿难。其人欲命终时。身上一一诸毛孔中受无量苦亦不经久。所以者何。以于我前及余无量无边诸佛世尊悔过罪故。阿难是故。诸族姓子族姓女。不欲受如是罪身如是罪舌如是众苦者。应当信解是经莫生疑惑。阿难。若有善男子善女人。不欲舍佛舍法舍比丘僧。不欲舍过去当来现在诸佛正法者。应受持是经读诵通利为他解说。书写经卷而供养之。阿难白佛言。世尊。如来今者说不退转轮经。以何缘故作如是说。若不舍僧不舍何僧。佛告阿难。僧者所谓不退转者说名为僧。为不退转法。来集会者亦名为僧。阿难白佛言。退转菩萨不在僧数中耶。佛告阿难。若有深发菩提心不见此心者。皆入不退转僧中。阿难白佛言。希有世尊。诸佛成就大方便力。以方便故说如是法。尔时释提桓因。以天曼陀罗华而散佛上。白佛言。世尊。愿令一切众生皆成就如是方便。佛告释提桓因。憍尸迦。若有信解是经者。皆当成就如是方便演说诸法。如我今者等无有异。尔时有百千诸天。以天曼陀罗花。而散佛上作是言。愿令一切众生逮得是经。尔时阿难白佛言。世尊。惟愿如来。怜愍未来众生守护是经。尔时佛告阿难。若善男子善女人。在大海中应闻是经。是善男子善女人皆悉得闻。所以者何。先佛如来已守护故。阿难白佛言。世尊。先佛如来虽守护是经。如来今者怜愍众生当守护是经。尔时大地六变震动。即于佛前有阎浮那提金色天华自然而现。其华有百千万亿叶。出大光明遍照十方恒河沙诸佛世界。是时四众皆见十方恒河沙世界诸佛世尊。是诸佛前。亦有阎浮那提金色天华。有百千万亿叶自然而现。出大光明遍照十方。尔时释提桓因。即自化身作居士形。持种种花与诸四众作如是言。诸仁今者可以此花散如来上。亦用供养是经法故。是时四众即取其花散如来上。佛神力故所散之花。于诸佛上变成花盖。是时四众白佛言。世尊。以何缘故大地震动。是大莲花于诸佛前自然而现。乃至东方恒河沙诸佛世界。南西北方四维上下恒河沙诸佛世界亦复如是。佛告四众。若先有此相。当知诸佛已守护是经。尔时阿难白佛言。世尊。如来今者已守护是经耶。佛告阿难。如是如是。我已守护阿难白佛言。唯佛世尊守护是经。余世界佛亦守护是经耶。佛告阿难。十方恒河沙诸佛世尊亦守护是经。阿难白佛言。世尊。当何名是经。云何受持。佛告阿难。此经名不着诸果。亦名远离诸果。亦名说坚信坚法八人须陀洹斯陀含阿那含阿罗汉声闻辟支佛密义。亦名降伏遣魔。亦名与六波罗蜜相应。所以者何。若善男子善女人。信解是经受持读诵。乃至书写经卷而供养者。便具足修行六波罗蜜。阿难白佛言。世尊。云何信解是经受持读诵。具足修行六波罗蜜耶。佛告阿难。若善男子善女人。信解是经名檀波罗蜜。不生疑惑名尸波罗蜜。堪任此法名羼提波罗蜜。心无怯弱名精进波罗蜜。心不扰动名禅波罗蜜。不分别一切法名般若波罗蜜。是故阿难。此经名六波罗蜜相应。亦名一切诸佛正说。亦名广大不退转轮。亦名广博严净不退转轮。阿难。如是等名汝当受持。阿难白佛言。世尊。闻此经名。尚应听受。何况具闻初中后说。佛告阿难。如是如是。如汝所言。阿难白佛言。世尊。若有得闻此经名者。能却几劫生死罪耶。佛告阿难。若有得闻广博严净不退转轮经名者。闻已信解。阿难当知。是诸众生。得却百千劫生死。阿难白佛言。世尊。若有众生。得闻是经。能信解已发菩提心者。逮得何法。佛告阿难。如是众生已逮受记。当得阿耨多罗三藐三菩提

尔时四众。各各自见其所坐前有大莲华自然而现。其华开敷有百千叶。亦有百千万亿光色。是时四众心生欢喜踊跃无量。即取是华以散佛上。作如是言。愿使我等于未来世宣说是经。犹如世尊等无有异。尔时世尊即便微笑。当尔之时。一切音乐不鼓自鸣。一切众香自然芬熏。百千万亿虚空诸天。于虚空中作大音乐。复有百千万亿诸天。于虚空中雨天细末栴檀种种天香。天阿迦楼香。细末多摩罗香。复雨天阎浮那提金粟银粟天摩尼宝。复雨曼陀罗华。摩诃曼陀罗华。波楼沙华。摩诃波楼沙华。曼殊沙华。摩诃曼殊沙华。迦迦罗华。摩诃迦迦罗华。楼遮摩那华。摩诃楼遮摩那华。输婆摩那华。摩诃输婆摩那华。天优钵罗华。拘物头华。芬陀利华。如是众华。而散佛上。种种天香。种种天鬘。乃至诸天所有珍宝皆悉雨之。虚空诸天现身在地。而作音乐以供养佛。世间诸人各各脱身所著上服而散佛上。复有诸人。脱手足璎珞咽胸璎珞所著天冠华鬘而散佛上。复有诸人。以金银天冠。众宝天冠。众华天冠。栴檀天冠散佛上者。复有诸人欢喜踊跃称庆无量。当尔之时。牛马欢悦出和柔声。虚空众鸟出和雅音。地狱畜生离苦获安。饿鬼充足离饥渴苦。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆悉欢喜踊跃无量。是时众生皆得慈心。慈心相向无有忿恨。尔时阿难白佛言。世尊。以何因缘世尊微笑。诸佛如来不以无缘而笑。尔时世尊告阿难言。今此四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。今于我前得闻此经。及未来世得闻经者。皆于阿耨多罗三藐三菩提而不退转。后成佛时宣说是经无有增减。如我今日等无有异。佛说是经时。有无量无边不可思议不可限量百千万亿那由他天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆于阿耨多罗三藐三菩提而不退转。佛说是经已。文殊师利法王子。无边无量诸菩萨摩诃萨。尊者阿难诸大声闻。及诸四众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。及诸世闻佛所说。皆大欢喜

广博严净经卷第六


佛说济诸方等学经一卷

    No. 274 [No. 275]

佛说济诸方等学经一卷

        西晋月氏三藏竺法护译

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。比丘六万。菩萨八十亿。摩竭国中众优婆塞六百万。临灭度时最后末年至罗阅只初首新岁。于时世尊即如其像三昧正受。庄严于斯三千大千世界。悬缯幡彩竖诸幢盖。散华烧香布诸莲华其叶百千。三千世界亿亿梵天王。各与无央数亿百千眷属。往诣佛所稽首足下。退住一面叉手自归。此大千界净居身天。威灵尊势大神妙天王。诸龙王鬼神王。阿须伦王。迦留罗王。真陀罗王。摩睺勒王。各与无数亿百千官属。往诣佛所稽首足下。却住一面叉手自归。其于十方各江沙等诸佛世界。神圣殊绝巍巍高节菩萨大士。来诣佛所稽首足下。迁住一面叉手自归。诸来会者应时周遍于此三千大千世界。极于上界三十二天。无有空缺间不容杖。针不得入靡不稠密。大神无极天龙鬼神。阿须伦迦留罗真陀罗摩睺勒。各各住立瞻佛尊颜。其身各异其心同一。释弃因缘等心归佛

尔时世尊安然庠序从三昧起。三返观察诸来众会。三返观已。三返自察师子频申。三频申已三返出舌。三出舌已。三返以舌覆三千大千世界靡不周遍。光明煌煌照于十方。于是大圣还缩其舌。重复顾眄诸来会者诸来会者佥然起住。稽首作礼自归命佛

尔时世尊告于弥勒菩萨大士。阿逸。仁识知之。正觉不久当取灭度。欲有所问今是其时。应宜咨请。诸有疑结志不解者前质如来无得后悔。面值大圣何不决之。弥勒菩萨前白佛言。世尊。知时明彻六通诸度无极。靡不宣畅决一切疑。善哉世尊。随时便宜颁宣经道。令斯法目永得久存

于是大神妙天王与八十亿净居天人。营从围绕行诣佛所。稽首足下叉手自归。前白佛言。唯然世尊。今斯经典其号名曰济诸方等学。过去诸佛如来至真等正觉之所讲说。今日大圣惟当垂哀重为散意。多所愍哀多所安隐。使如来法训诲久存。时佛默然可大神妙天王所启。天王见佛默然可已退住一面

尔时世尊告弥勒菩萨。阿逸当知。诸过去如来至真等正觉。无不讲说此济诸方等经典之要。当来现在十方世界如来至真皆亦说是。其不宣斯谤佛违经毁诸圣众。所以者何。若说此经有无益想谓不备悉。为诽谤佛违失经典毁呰圣众。毁三宝者必归地狱。是故弥勒。若族姓子及族姓女学菩萨乘。通畅诸经众他异法。尔乃分别演众经义。若欲周备不阙文字。随正典教不自损己。又仁弥勒。宜当专精思惟是门。然后末世摄护正法。弥勒应曰。惟然世尊。诚如圣教。当传神旨不敢违命

佛复告弥勒菩萨。如来至真某日于夜得逮无上正真之道为最正觉。至于无余泥洹界。灭度日夜如来至真。宁有缺漏意误忘乎。宣恶念非瑕疵行耶。弥勒报曰。无也世尊。复谓阿逸。如来某夜成最正觉至灭度日。所可讲说皆实至诚。顺时应宜而无虚妄。佛言。或有愚人。不别如来善权方便。不觉真实诚谛之言。反传狂语出意自说。此事合义此义不合。以是比类诽谤正道。若诽谤经则为谤佛。吾谓此党必归地狱。佛言弥勒。当来末世五浊之俗。余五十岁当有四辈比丘比丘尼优婆塞优婆夷志学菩萨。慕本所誓外异学意。奉事如来。见佛所说法律出家。修为沙门谦敬种姓。其人所志惟求利养毁坏种姓。贪嫉室家乱其居业。面无好色志慕小意。性不开解不能宽泰。不坏情欲多求汲汲。远于一切诸法门行三昧正定。常住谀谄心念各异言行不同。贪其种姓依有势者。见诸明智晓了法藏谓之无知。己无所知自叹有慧。己无聪明自叹聪智。因猗佛道建立其意。等心众生兴发大哀。又不忘舍善权方便。依蒙佛力而已违越所讲信乐于其学中。或复说言。若有经卷说声闻事。其行菩萨不当学此亦不当听。非吾等法非吾道义。声闻所行也。修菩萨者慎勿学彼。辟支佛法亦复如是慎莫听之。佛语阿逸。佛为信乐开化诸天随时说法。教诸龙神阿须伦迦留罗真陀罗摩睺勒犍沓和人与非人。随其本行志所应脱说法开化。普至十方各江沙等。导利众生各随本行。随宜当度利益众生。因斯志操颁宣经道。度脱一切皆使得道

佛告弥勒。当是世时菩萨学中志自怀结。诸菩萨中刚强难化弊恶凶暴。妄言两舌鲜闻智少。宣传佛道别为两分。欲为菩萨当学此法不当学是。而怀是心诽谤于佛。毁呰经典斗乱圣众寿终身散便堕地狱。在彼见煮当经无数劫痛。罪犹不毕从地狱出。当复还生贫匮之门。所当经历众难之患。极远难量乃得受决。虽得受决在五浊世乃成为佛。亦如我本遭难长远无央数劫在五浊世成最正觉。若闻其言而信听受。笃信思惟从其教者。亦当如是归于恶趣。所以然者。信恶亲友故遭此患

佛告阿逸。过去久远不可计劫。尔时有佛号离垢[火*僉]成就功称如来至真等正觉。出现于世八十垓岁。为诸众生颁宣经道。时有比丘名净命。为法都讲宣若干教。言辞柔软辩才至真。劝助发起无央数人。显扬等教多所欢悦。时离垢成就功称如来嘱累净命比丘。于后末世当护正法。嘱累已后乃取灭度。如来至真灭度之后。彼比丘于亿岁。执法品宣佛教。因得普入济诸方等经典之要。宣传道化发起一切。顺诸众生本心所乐应当解者而分别之。周旋往返八万城邑。观察众生本愿发意。令得饱满除去饥虚众情之难。于彼世时有大国城名曰仁贤。有八十亿众民居中。亦观根源而为说法。于时城中八十亿家忻然受教。化一亿家发菩萨意。七十九亿立声闻乘。于是净命比丘与万菩萨。同心俱往诣修道处。出去未久时有比丘名曰为法。行来周旋远他乡来在仁贤城。奉持方等千余经卷。现得四禅自以为远。净命比丘学方等经十四亿卷。及修余经六百万卷。时法比丘在仁贤城。惟但宣散一品法教。不知随时观其本行讲说经法也。不能觉了达诸法界。专以空法而开化之。言一切法空悉无所有。所可宣讲但论空法。言无罪福轻蔑诸行。复称己言。如今吾说悉佛所教。净命比丘所可演者。猗着杂碎志性不清为人秽浊。谁本为彼比丘作字号净命者实不清净。所以者何。受取众华取众华已而服食之。亦受名香诸杂涂香亦服食之。彼学愚冥痴无所知。吾身学来久修梵行。彼适新学而受其诫。从来未久勿得信之。又其比丘放逸自恣。众人横敬一心悦豫归净命比丘。其法比丘作是谤毁宣其恶行。众人不信不从其教。其法比丘用怀毒心诽谤智士。寿终之后堕地狱中竟八十劫。用诽谤佛毁呰正法。在地狱中七十劫已。加六十劫迷荒失志。尽斯数已。乃逮前行本发道意香宝光明如来佛所。其佛为讲更说法义劝发道意。堕畜生中九百万世。后生人间六百万世常遭贫厄。所生之处常哑无舌。然后于世见六十三垓诸佛正觉。在诸佛所常为法师。世世所生普成五通。皆为诸佛所见教敕。悉解诸法说清净义。佛告阿逸。欲知尔时净命比丘。岂异人乎莫作斯观。所以者何。是阿弥陀佛也。其法比丘则我身是。吾于彼世所更如是

佛告阿逸。众事诸法难了难了义微如是。吾以是故于五浊世得成正觉。佛言阿逸。若有菩萨说两品法。因是之故在五浊世当成佛道。又其佛土多有诸魔数数兴乱。成佛道时若宣经法亦娆乱之。当尔之时诸来众会。咸皆郁咿流泪于面。各自说言。莫令学人宣二品法讲说经义。勿令偏党专愚放恣自是恶彼如法比丘。为诸比丘及在家学。所分别说说是非法。时彼会中有百菩萨。寻从座起避席地坐嘘唏流泪。于时世尊知此菩萨心念本末故复发问。诸族姓子。何故坐地嘘唏流泪。即白佛言。我等世尊。各自识察犯此殃衅。佛言。如是族姓子等所察念也。锭光佛时有一菩萨名曰智积。佛灭度后建为法师。诸贤者等求其缺漏。从是以来未曾复与诸佛相见。不识道心不得总持不逮三昧。诸族姓子。前世之时亦与我俱同发道意。又族姓子。是披陀劫最后有佛名曰楼由。当于彼世乃能逮得无所从生法忍。然后三阿僧祇劫逮致无上正真之道为最正觉。是故族姓子。菩萨菩萨展转相见。莫生异心相求短也。若见菩萨当自念言。今吾睹佛寺见佛正觉佛立吾前。假使族姓子。若有菩萨。见余菩萨发起异心。视不如佛则自毁损。由是之故莫怀慎恨。其见初发菩萨心者。视不如佛辄为侵欺。诸佛世尊于今现在不可计数无限世界。又族姓子。今佛预睹将来末世余五十岁。有得总持若逮三昧。皆是如来威神所致。故族姓子。若诽谤法师求其短者为谤如来。如来灭度后。若有晓了随时之宜。从众生心本所信行为说法要。若于众会有菩萨学一发意顷衣毛为竖。一返闻经寻即讽诵。则当知之如来圣旨之所接也。于彼世时有愚憃士。无菩萨行自谓菩萨。在诸菩萨凶坚自用。分别经典侏[仁-二+張]匿功。独谓己达以为二行。常自说言。此人何知此何所解。佛告弥勒。我身现在所宣颂教。行佛道时布施头目支体肌肉妻子国邑。佛悉识念以一颂故布施天下。是等愚惑求获利养。不往敬佛宣道教者。不随佛教违失道节。佛言。阿逸。当以清和可奉此法不以诤讼。阿逸。且观此党众生习随瑕疵发起嗔恚。不熟思惟识达义故也。如吾所修成最正觉。宣传佛慧而为说法。便当说言莫传此教。于彼世时利供养故。其法比丘讲说方等千余经卷兴发四禅。因是乃致如此艰难。何况妄说违失义理不顺道教。若有比丘奉方等教。宣方等藏故发道心。反更兴心诽谤法师。则为诽谤诸佛经典。甚怀慢恣求其瑕缺。佛不谓此得至究竟尽生死源。是等之类必堕地狱。所以者何。若有求取法师短者。则为慊佛患厌经法。其轻法师则不敬佛。若不欲睹于法师者。其人则为不欲见佛。若毁法师为毁诸佛。若兴害心念初发意菩萨恶者。从其发心害意。诸无数劫若干劫失其道意。以其恶眼视菩萨数。更若干世世世生盲。从本字数口宣诽谤说法师恶。更若干劫喑哑无舌

佛告阿逸。佛普观察见诸菩萨。不因余法速堕恶趣。惟由恶心向余菩萨。想吾我人贪住求法故堕恶趣。佛言。阿逸。如来不谓宣传经典。随颠倒教。念在生死自恣放逸。住我人想行若干法。为是菩萨因是之故故堕地狱。是故阿逸。菩萨遵习六波罗蜜。能成佛慧无上正真。或有愚人口自宣言。菩萨惟当学般若波罗蜜。其余经者非波罗蜜。说其乏短。于阿逸意所趣云何。本时国王所以持头施与人者为无智乎。弥勒答曰。不也世尊。佛本所修六波罗蜜。所为至诚真实行乎。为不行是得佛道耶弥勒报曰。不也世尊。佛语阿逸。仁本宿世具六十劫行檀波罗蜜。尸羼惟逮所修禅定。般若波罗蜜亦复如是。各六十劫而愚憃等各自发言。当以一品行般若波罗蜜至于佛道。奉随颠倒无所慕乐。是等之类虽口有言行不清白。虚言反教常行猗着。悕望于空不肯作行。但口发言以为第一。虽行甚远贪妒怀嫉。敬重种姓亲属知识。吾本宁以头施于人。不用转轮圣王之位。斯等贪着衣食利养。入他家居当说此言。行道如是。如是行者其理如是无复异义。多有法师不了斯教。利供养故多生害意念法师恶。佛言。阿逸。佛不以是贪爱其命无道愚夫为学道也。正使百劫不得柔顺法忍也。况当获致至佛道乎。佛言。阿逸。行谀谄者吝惜贪嫉不行恭敬。无有明智怀妒种姓。造二品行为求道也。斯愚人等自谓智明想胜佛慧。所以然者。横自发言。如来说法言辞不尔有声闻事。佛亦不说声闻之法

尔时佛告贤者须菩提。般若波罗蜜其原为一无二行乎。须菩提白曰。唯然天中天。又问。须菩提。菩萨所行舍众望想无所著乎。唯然世尊。复问。须菩提。菩萨所修弃诸驰骋无放逸乎。唯然世尊

佛告须菩提。岂见学士己不自修不知羞惭。欲得希望功勋之报当致贫厄。欲求势姓慕得援助。何甚愚哉

佛复告阿逸。菩萨假使闻说一切诸法皆声闻法。不当恐怖。一切诸法皆缘觉法。一切诸法皆为佛法。不当恐怖。莫怀悕望有所猗着。一切诸法皆凡夫法。一切诸法皆尘劳法。设闻是言不当恐怖。一切诸法皆嗔恚法。一切诸法无嗔恨法。设闻是言不当恐怖。若有所受若无所受。作与不作。覆不覆。清不清。有心无心。有念无念。有罪无罪。有福无福。有报无报。有安无安。有脱无脱。精进懈怠。有行无行。修贤圣法无贤圣法。寂然不寂然。受与不受。至诚虚诈。顺念不顺念。住与不住。于此诸法永无所畏。佛本学时在佛树下。所达诸法成最正觉。畅解一切众生境界。悉无颠倒晓了诸法。皆为自然不着无处。故为世人分别说此。如来至真不名诸法亦无所诤。菩萨以故逮致圣光无极法曜。兴发总持称举法印。为诸法故无所上下。佛语阿逸。佛以法故为四方域颁宣经道。众生各念。如来为我如是比类演出经义。至二十四阿加腻吒天。次复开化第二方域。至二十四天。三千大千世界亦复如是。众生皆念。如来生此而转法轮讲说经法。如是比像无数方便。至无央数无际世界开化众生。吾于明旦所周旋处。兴作佛事不可限量。日中晡时亦复如是。如来至真常尔不废。目无蔽碍普见一切众生境界。一切佛土如是无限。诸佛部界其亦然矣。菩萨皆当学如此义。住在诸法妄想之处而开化之。其住诸佛有所悕望。则已住在诽谤诸佛。其已住在诽谤诸佛。彼则住在堕于崄路。其堕崄路则堕恶趣。其住恶趣则住诸法诤讼之处。是故阿逸。当护如来善权方便。佛自随时说此法耳。于是文殊师利告趣聚福菩萨。不虚见菩萨。一辩心菩萨。善了说心菩萨。诃辩菩萨。喜王菩萨。离怨毛竖无畏行菩萨心。愿无量佛土菩萨。光世音菩萨。众香手菩萨。除诸阴盖菩萨。不置远菩萨。合百千德菩萨。威神音菩萨。心不舍诸慧菩萨。宣名称英幢菩萨。念求诸义菩萨。行不离佛界菩萨。超月殿威灼灼菩萨。严诸大界菩萨。文殊师利告于此等二十菩萨。复白佛言。如是如是。世尊。诚如圣教。吾诣东方过是六十江沙诸佛刹土。礼诸世尊闻所说法。亦如今日。西南北佛土四维上下亦复如是。游观七日转复前行不见余佛。寻复还反来至此土稽首听经

尔时世尊告文殊师利。仁且观此如来圣慧无量。若兹诸佛境界不可思议巍巍如是。如来所入等无有侣靡不周悉。或有愚騃不识义理。趣自说言。般若波罗蜜如来所行。是诸如来无极修教。余经皆非佛语。文殊。菩萨行者无合会行。乃是开士正真之行。无等伦行则菩萨行。无所受行为菩萨行。无所著行亦无不着是菩萨行。如是文殊。菩萨所行为无轻慢。吾以随时分别宣说。诸法难见亦难晓了。是故文殊。诸贤一切当修寂然无放逸行。顺从正士坚固之行。常怀慈心不为嗔害。以住诸法修等行者则从佛教。佛无数劫遵习此道。以权方便而颁宣之。有无智人各怀异意堕大艰难。当兴讥谤谤讪经道。非如来所宣。毁呰法者不觉微失坐不护口。或自心念是事嘉快。或谓不快故诽谤法。以诽谤法则诽谤佛。已诽谤佛则毁圣众。口横说言。是事为应是事不应。如是言者为诽谤法。为诸菩萨讲说此事。为诸声闻演如是教。口说此言为诽谤法。诸菩萨等当学此法。当舍此法不当习学也。妄说如此为诽谤法。某有辩才某不辩才。某性便利某性讷钝。妄有讥诃。说经如是为诽谤法。若以宣言。值佛世时可得总持。不值佛世不得总持。为诽谤法。虽以修行逮得总持。所逮总持未必清净。若说如是为诽谤法。求法师短瞻其法则所行缺漏。为诽谤法。不信法师所行具足。假使法师不应威仪。为诽谤法。宣于法师放逸之业。驰骋由己不能专一。为诽谤法。礼节不备失经违节。非所奉戒扰扰凶凶。则诽谤法。有所宣义理其明不广妄有所讲。为诽谤法。言语不了辩才不畅欲传道教。为诽谤法。本学不勤所知甚鲜。明不广远欲宣道教。为诽谤法。心自念言。某不知限不了随时。当教开化达令至义。为诽谤法。兴发想念不护佛教。怀抱危害。为诽谤法。各获一卷文字经教。各是所学诤义失义。为诽谤法。各颂一偈诤其义理自说是非。为诽谤法。某有信乐某不笃道。某当得脱某不得脱。为诽谤法。若讲法时所言各异。反其义理非某所讲。故来乱坐谈语说事。为诽谤法。是人应行是不应行。某为随顺某不随顺。为诽谤法。某以随时某不知时。违失义理不从道节。为诽谤法。佛告文殊师利。诸声闻众有所怀裹分别说者。诸菩萨等聪明辩才有所颁宣。皆承如来威神圣旨。佛言。文殊。如来道教随时之宜所誓如是。斯等愚夫唯念毁呰求其长短。不从佛教反非如来。所念法师而讥谤之。是等悉为魔之所乱。猗求利养故发此意。当归恶趣。将护居家所依善厚。反不慎护住如来教。猗其尊势有势位者王者长者梵志。若使有人难问义者诵说义理。咸共叹言善说此事。所知嘉快如佛所说。所可颁宣极有义理佥然劝助。由是劝助堕诽谤法。同等群党出入进退。然后没已俱堕恶趣。佛复告文殊师利。若有菩萨猗着诸行。我不谓此为菩萨也。佛言。阿逸。其依种姓有豪居位。佛不谓此为清净也。其有宣传两品经义言行各异。佛不谓此当得解脱。必归地狱。假使有人专一品说。谓义趣是莫能过者。佛不谓此越度恶趣众患之难。其多辞说乐于众闹。佛不谓此应清白行。佛语文殊。佛所颁宣理诸颠倒。进退法门如江沙等。所宣法门乐着空者。其数多少亦如江沙。为诸妄想而计有人宣法门教。其限多少亦如江沙。众生亦如无想之业。诸有相原。无愿之业诸有愿本。为说法门亦如江沙。有人无人。有命无命。有寿无寿。有欲无欲。有贪无贪。有为无为。某人殷勤随从计常。某不殷勤但念断灭。是乐随俗是为度世。某贪欲门。某嗔恚门某乐痴门。如来皆使除此诸门故说法门矣。佛语文殊。若有修行平等之宜永无所著。一切皆应般若波罗蜜教。若有讲说慧各各异。心在见闻演不如慧。则谤如来也。于是文殊师利复问佛言。唯然世尊。此等之类为从恶友误启受教。乃能兴发如是讥谤。以何方便现世自责能除罪法。世尊即告文殊师利。假使此人于七岁中。昼夜各三悔过自责。然后乃除所造谤罪微微消化。当复曾更十五劫行乃逮法忍。佛言。文殊。菩萨习此经典之要。不能晓了而妄宣传。欲解其事甚难得度。文字之法散义不畅。是故菩萨先善谛学然后能宣。如是学者不自伤损。佛言。文殊。菩萨有四法晓了诸行。何谓为四。一曰等心愍于众生。二曰等解诸法而无偏党。三曰等于道义不猗邪正。四曰所说平等不怀妄想。是为四。若不解此四平等妄有所说则自伤损。若族姓子及族姓女。逮住四法不自伤损。何谓为四。一曰不怀害心加于众生。二曰不与法师而共诤讼。三曰己身少明不毁他人博达慧者。四曰心自念言。此一切义皆佛所说。故当敬奉谦下恭顺。是为四法不自伤损。佛言。文殊。若有菩萨于江河沙诸佛刹土满中七宝如江沙劫。一切供养十方诸佛。日日各尔。布施奉佛而不休息。若复受此济方等学经典之要。书着竹帛一返宣说。其福过彼供养诸佛。所以然者。布施持戒忍辱精进一心智慧。皆不能及斯人善业。济方等学经典之要。菩萨学是德无等伦独步无侣。说是经时三十江河沙等菩萨皆悉得无所从生法忍。七十江河沙等菩萨普悉得立不退转地。当成无上正真之道。六十亿垓百千众人生在于此三千大千国者。闻是经典咸共劝助悉发道意。佥然意解越八十劫生死之难。亦皆一时得不退转。佛说如是。诸比丘及菩萨一切众会。天龙鬼神犍沓和阿须伦世间人民。闻佛所说莫不欢喜作礼而去

济诸方等学经


佛说菩萨行方便境界神通变化经卷上

    No. 271 [No. 270]

佛说菩萨行方便境界神通变化经卷上

        宋天竺三藏法师求那跋陀罗译

如是我闻。一时佛在优禅延国。住旃茶钵树提王园。其中多有诸娑罗树。多罗树。迦尼迦罗树。尼拘罗树。博叉树。优昙钵罗树。复有婆师华。陀腻迦华。阿提目多华。瞻婆华。阿叔迦树。波吒罗树。以为庄严。又有泉井池沼江河清流庄严。又有青黄赤白莲华遍诸水上。鹅雁鸳鸯拘那罗鸟。钵吒军陀鹦鹉鸲鹆。命命诸鸟出种种音。多诸黑蜂出妙音声。多软深草遍布大林。与大比丘众十二亿俱。大德舍利弗。大目揵连。摩诃迦叶。阿尼揵陀。须菩提。大迦旃延。摩诃劫宾那。离波多。波宾那。难提翅那那提迦叶。伽耶迦叶。富楼那弥多罗尼子。憍梵波提。那陀翅那。周梨槃特。闼婆摩罗子。呿陀婆林。难陀。摩诃拘絺罗。罗睺罗。大德阿难等。而为上首。十二亿俱。一切入一法界处行。进入一切诸法。如性行虚空行。无依止处无依止行。离诸一切所起覆盖障碍结缠。入度如来。无有法界近一法界。向一切智道而不休废。欲一切智心无退转。智慧了别得到彼岸。勤进修行方便境界。摩诃波阇波提。耶输陀罗等。与八亿比丘尼俱。一切成就白净之法。皆悉善行。一切智道近一切智。善行进入无有法性。观一切法无有性相。自解诸法实际无际。得于无碍解脱智慧。随应众生。所应调伏。善能示现。复与七十二亿大菩萨众。其名曰大力菩萨。大力持菩萨。大变化菩萨。大变化王菩萨。大进趣菩萨。大进揵菩萨。大吼菩萨。大吼意菩萨。大众主菩萨。大香象菩萨。大月菩萨。善月菩萨。功德月菩萨。宝月菩萨。普照月菩萨。法无垢月菩萨。月照菩萨。妙名月菩萨。放光月菩萨。满月菩萨。梵音菩萨。梵主雷音菩萨。地音菩萨。法界音声菩萨。降一切魔场音菩萨。妙音声菩萨。普告音菩萨。无妄想分别音菩萨。地轮音菩萨。一切无障音菩萨。普藏菩萨。无垢普藏菩萨。德藏菩萨。照藏菩萨。宝藏菩萨。月藏菩萨。日藏菩萨。炽藏菩萨。莲华藏菩萨。莲华德藏菩萨。大意菩萨。益意菩萨。妙意菩萨。好意菩萨。胜意菩萨。增意菩萨。无边意菩萨。广意菩萨。觉意菩萨。无尽意菩萨。须弥灯菩萨。大灯菩萨。法炬灯菩萨。照一切方灯菩萨。普灯菩萨。灭一切闇灯菩萨。照一切道灯菩萨。一照明灯菩萨。月灯菩萨。日灯菩萨。离一切恶道菩萨。魔不降伏菩萨。大魔不降伏菩萨。威德菩萨。无降伏菩萨。无能测菩萨。威德觉干恶菩萨。得大势菩萨。观世音菩萨。弥勒菩萨。文殊师利童子菩萨摩诃萨等。七十二亿俱。皆是一生。得陀罗尼。得诸三昧。得无边乐说。得无碍无所畏。获得神通到于彼岸。能过无边佛之刹土。游于神通身心解脱。诸碍无碍智见成就。无佛世界现佛出世。善转法轮无有错谬。随于一切众生所解。而为说法说无作法。于法性中无有动发非不动发。其心入度到于彼岸。演说空法吼大师子吼。降伏破坏一切外道。伏魔怨敌。得诸菩萨所行神通。断离爱嗔其心平等。如地水火风。入于一切如来密处。为一切众生而作佛事。常为诸佛之所赞叹。受持一切未来世劫。受持一切如来法性。雨于法宝。叹其所有一切功德。不可穷尽。为世界主本愿成就。行于如来解脱之行。先已善修行于大乘。信眼清净无有垢污。常恒勤进供养给事诸佛如来。能善庄严不退庄严趣向大悲。其心解性无可比喻。超度疑佛犹豫惑心。为过诸佛之所护持。复有无量优婆塞优婆斯。于此三千大千世界威德无喻。诸天天主。诸龙龙主。夜叉夜叉主。乾闼婆乾闼婆主。阿修罗阿修罗主。迦楼罗迦楼罗主。摩睺罗摩睺罗主。紧那罗紧那罗主。人非人人非人主。一切各与百千眷属皆来会坐。尔时世尊。无量百千大众围绕。坐于德藏师子之座。蔽诸大众身光猛盛照明无垢。犹如须弥显于大海映蔽诸山照明挺特。世尊亦尔。坐师子座覆蔽一切诸天世人。殊特猛盛照明无垢。犹十五日月盛满已隐蔽众星照明清净。世尊亦尔。隐蔽一切诸天世人。照明清净。犹如虚空清明净洁无有云翳。日放明网。隐蔽山光萤火闇已极照明净。世尊亦尔。坐师子座。降伏隐蔽诸天世人极为照明。亦复隐蔽释梵护世等光。犹如闇夜于高山顶炽然大火照明清净。世尊亦尔。处师子座。降伏隐蔽诸天世人。光极照明清净无垢。如师子兽王降伏一切诸小禽兽。世尊亦尔。处师子座。降伏隐蔽一切天人。如毗琉璃如意宝珠八楞无垢放净光明。世尊亦尔。处师子座。端严殊妙明照十方。如转轮王降伏四域所有众生。世尊亦尔。处师子座。降伏隐蔽诸天世人如释提桓因着释迦毗楞伽宝璎珞已处善法堂降伏隐蔽诸天光明。世尊亦尔。处师子座。降伏隐蔽诸天世人。照明清净。尔时文殊师利童子。知大众心已。见如来身威德隆盛。作是思惟。是何光瑞。世尊今坐于师子座。极为光明清净殊特。大会甚多。我今当问如来是义。尔时文殊师利童子即从座起。正于衣服。偏袒右肩。右膝着地。合掌向佛。以偈赞曰

  十力照光明　　降伏天世人
  三有无与等　　众生无有过
  如须弥天居　　悉照明诸方
  降伏蔽诸山　　勇出照众山
  佛持德亦尔　　智山勇出世
  降伏蔽诸众　　常恒净照明
  如月处虚空　　日月功德照
  盛满极圆足　　降伏蔽诸宿
  十力亦如是　　弟子星围绕
  放净月光明　　能照人天世
  喻如日宫殿　　照明降一切
  人尊主如是　　降伏人天世
  犹如山顶火　　闇夜照诸方
  智光明如是　　调御放妙光
  如师子兽王　　显威德降兽
  外道众如是　　显照明降伏
  人主转轮王　　威德降伏世
  世调御如是　　降伏照诸世
  三十三天王　　降伏胜诸天
  无等亦如是　　降伏照诸众

尔时文殊师利童子。偈赞佛已。合掌白佛言。惟愿世尊。今为此众。说菩萨行方便境界神通变化经。若众生闻趣上行者。当发阿耨多罗三藐三菩提心。向下行者得上胜进。已发无上菩提心者。增益无上菩提境界。懈怠众生发大欲乐。退道众生安菩提道。趣菩提道诸众生等。具足庄严如来智度。文殊师利如是请已。佛告文殊师利。如来应供正遍知所说难解。当何缘说。何缘进入。难知难觉难可测量难教难度。诸天世人坏威仪者。及破戒者。不能解知。下众生等所不能解。诸坏心者所不能信。为恶知识之所摄者。所不能入。离善知识者。所不能知。不为诸佛所护持者。不能听受。况当解趣。无有是处。惟除诸佛所护持者。尔时世尊而说偈言

  文殊听我说　　汝所问事义
  下暗不能行　　不知此法性
  于先佛不行　　调御世不护
  若闻此法者　　无有恭敬心
  恶知识所摄　　离善知识人
  若闻如是法　　疾退堕大山
  小心无进行　　无有胜妙心
  下人无信解　　是等闻不喜
  佛悲彼不说　　勿娆彼众生
  不信此法故　　长夜无利益

尔时文殊师利童子白佛言。世尊。此所集众皆悉清净。先有善行。多供给事过去诸佛善知识。摄善净信根。恭敬出世解脱之法。善知净心。毕竟善解善教。如此等众皆悉集会。能知能解如此之法。善哉世尊。愿今演说。摄取利益诸众生故。重说偈言

  此多众生求法利　　善知解了此法性
  过去诸佛所修行　　是故说法调御师
  悉皆恭敬合掌住　　瞻视谛观世调御
  调御为此生悲心　　大觉愿说胜妙法
  我今咸请于法王　　愿当演说胜妙法
  为利摄取菩萨故　　人尊愿开善法藏

文殊师利如是请已。佛即赞言。善哉善哉。文殊师利。汝问如来应供正遍知如是之义。文殊师利。汝今悉知一切法行。于诸法中无有疑惑。汝已善觉智慧方便。文殊师利。汝多利益诸众生行。文殊师利。汝为未来诸菩萨等作大光明。文殊师利。汝今谛听。善思念之。吾今当说菩萨所行方便境界神通变化经。文殊师利诸菩萨言。如是世尊。当至心听。佛言。善男子。若有成就十二功德法。是善男子善女人等。能发阿耨多罗三藐三菩提心。何等十二。有妙解性离下解行。有性行悲生于白净。有心专行坚受无为。有善庄严久修善行。有善恭敬供养诸佛善集白净法。有身业口业意业无作离一切恶。有远恶知识近善知识。有如说如作无有谀谄。有善觉知法不贪于味节量而食。有如来护持离魔所持。有常一切诸众生中生于悲心。亦不放舍一切众生。心亦不贪。有因缘力功德庄严。善男子。是名成就十二功德法。善男子善女人。发于阿耨多罗三藐三菩提心。是利益心。能与一切众生乐故。哀愍心。不作诸恶故。大悲心。堪任荷负诸众生故。大慈心消灭一切诸恶道故。白净心。不求余乘故。无爱心。离于一切结使浊故。是净心。其性净故。如幻心。无有物故。无所有心。离所有故。坚固心。不动摇故。不退转心。达诸法故。度于一切众生之心。如说作故。尔时世尊。而说偈言

  若有佛子善修行　　清净之法满足心
  一切众生慈悲心　　柔软之心为菩提
  本先远离恶知识　　近示菩提善知识
  誓愿勤进菩提果　　生于觉知菩提心
  恒常不生疲厌心　　所修行行如本际
  犹如金刚不退心　　如是等生菩提心
  于诸众生慈悲心　　安诸众生住乐故
  远离一切诸恶故　　是等疾生菩提心
  慧者不求于余乘　　思惟菩提胜功德
  净心无垢亦无爱　　如是等欲菩提心
  离物悲物无有爱　　其性犹如电幻等
  离一切物无有相　　佛说菩提心等是
  离一切使一切恶　　无垢明了如虚空
  一切文字不可见　　此说菩提心清净
  是菩提根胜妙行　　亦陀罗尼诸辩者
  亦是诸根及众好　　此是得佛诸功德

佛告文殊师利。菩萨安住。见于如是十二功德勤进修行檀波罗蜜。何等十二。见菩提道安和调适。勤进修行檀波罗蜜。见大富族。勤进修行檀波罗蜜。见生可爱种姓中故。勤进修行檀波罗蜜。见离悭垢。勤进修行檀波罗蜜。见施心具足。勤进修行檀波罗蜜。见关闭于饿鬼门故。勤进修行檀波罗蜜。见财多共欲求坚固。勤进修行檀波罗蜜。见诸所须自在具足。勤进修行檀波罗蜜。见修习行一切舍已。勤进修行檀波罗蜜。见离贪惜舍一切物。勤进修行檀波罗蜜。见我当满檀波罗蜜故。勤进修行檀波罗蜜。见应慎行如来教敕故。勤进修行檀波罗蜜。所有布施悉皆回向阿耨多罗三藐三菩提。善男子。是名菩萨见于如是十二功德勤进修行檀波罗蜜。尔时世尊。以偈颂曰

  施求无等一切智　　手足净目头骨髓
  不惜内外一切舍　　后无贪惜增益德
  当成妙封生胜家　　后增菩提降贪垢
  得自在满于檀度　　一切诸佛所赞施
  慧见是诸功德利　　我当修行一切舍

复次诸善男子。若菩萨见如是十二功德事故。勤精进修行尸波罗蜜。何等十二。见我当护持摄成就戒。勤进修行尸波罗蜜。见我当向菩萨道故。勤进修行尸波罗蜜。见我当缓结使缚故。勤进修行尸波罗蜜。见我当离一切恶道。勤进修行尸波罗蜜。见我当净一切恶道。勤进修行尸波罗蜜。见我当成于身口意无作业故。勤进修行尸波罗蜜。见我当为慧者不诃。勤进修行尸波罗蜜。见我当习不放逸戒。勤进修行尸波罗蜜。见我当施一切众生无所畏故。勤进修行尸波罗蜜。见我当得身口意戒。勤进修行尸波罗蜜。见我当于一切法中得自在故。勤进修行尸波罗蜜。见我当学无上如来戒。勤进修行尸波罗蜜。见善男子。是名菩萨见于十二功德事故勤进修行尸波罗蜜。是戒回向于一切智。尔时世尊。以偈颂曰

  我当得缓结使缚　　我当关于恶道门
  我当思量胜妙事　　我当护戒牛爱尾
  我当如佛所教住　　我当慧者所称赞
  我当护持常不离　　我当有住戒功德
  我当身口得无作　　我当行意无作法
  我当善护身口意　　我当不复行恶道
  若不放逸善逝赞　　是诸一切善业本
  我当常住于是处　　舍离一切诸放逸
  我当行尸波罗蜜　　我当成就于佛法
  我当净于如来戒　　是一切戒胜无上
  不悕望求此功德　　若菩提萨求胜道
  护戒犹如牦牛尾　　当得一切功德利

复次诸善男子。菩萨念于是十三行。修行于忍。何等十三。一切行空修行于忍。不得我故修行于忍。不得众生修行于忍。不偏自他修行于忍。究竟无嗔修行于忍。覆蔽结使修行于忍。永断贪嗔修行于忍。成就相好修行于忍。欲生梵世修行于忍。离他逼切修行于忍。欲得尽智无生智故修行于忍。欲降诸魔修行于忍。欲知见如来无量身故修行于忍。以是忍辱。悉用回向于一切智。善男子。是名菩萨见十三行修行于忍。尔时世尊。以偈颂曰

  此法空无有　　求不得众生
  解知于此法　　安住忍功德
  俱远离二边　　自他无有嗔
  慧者修忍力　　大悲如是示
  究竟无有嗔　　进修忍无忧
  觉知于尽故　　修忍寂结使
  相好色严净　　是生于梵宫
  坚进近忍力　　乐思惟吉忍
  无大忍力等　　令魔力非力
  一切德来归　　是故修妙忍

复次诸善男子。菩萨有于十二庄严。庄严修进。何等十二庄严。觉了一切佛法。勤修行进庄严。往诣一切佛所。勤修行进庄严。供给一切如来。勤修行进庄严。教化一切众生。勤修行进庄严。安住一切众生于佛法中。勤修行进庄严。灭诸众生无明。勤修行进庄严。施诸众生佛智。勤修行进庄严。净于一切佛土。勤修行进庄严。尽于未来际劫。修菩萨行而不疲厌。勤修行进庄严。欲于一弹指顷遍至一切佛之世界。勤修行进庄严。一切佛之世界。成无上道转妙法轮。勤修行进。诸善男子。是名菩萨十二庄严勤修行进。尔时世尊。以偈颂曰

  无上勇进无懈怠　　是佛子向胜菩提
  往多佛刹犹复断　　是所行处无疲厌
  为化众生坚精进　　堪百千亿劫苦聚
  常恒勤进无懈怠　　施与众生灭度乐
  我愿修净诸佛刹　　尽悉觉知一切法
  我诸世界中胜轮　　转已多亿众生调
  一念心觉胜菩提　　遣化多刹调伏故
  佛子常度进彼岸　　现众庄严为众生

复次诸善男子。菩萨十二行修于禅定。何等十二。燋结使行。究竟不发故。正心住行。不随境界故。无依止行。离欲界色界无色界故。出过世行。降伏非圣凡夫定故。增益胜行。无我心故。次第定行。分别禅故。无所有行。离有想故。无边之行。呵责有边三昧禅故。以是定行。善寂静故。调心行。无不知故。寂静之行。护诸根故。方便境界行。菩萨修禅。不舍不发非慧非慢非见非爱非念修故。是故菩萨降伏一切诸修禅者。诸善男子。是名菩萨见十二行修于禅定。尔时世尊。以偈颂曰

  此禅定尊贵　　是彼菩萨行
  燋一切结使　　究竟不复发
  专修寂定禅　　不修逐境界
  若有不住心　　劝令住于定
  修无依止禅　　彼无所依止
  欲色无色界　　思惟无所著
  是禅超出世　　是菩萨所知
  是故降一切　　诸非圣定者
  行于次第禅　　欲得自在故
  是故舍禅定　　还生于欲界
  增益胜妙行　　智慧者修禅
  是无我心禅　　为于菩萨说
  无量无边行　　修行最上禅
  是故少分禅　　照明令降伏
  智慧方便俱　　修禅大名称
  都无所见得　　一向白净行
  无所依止故　　亦不住于物
  智慧者修禅　　舍离于物相
  行如是等行　　智慧者修禅
  于缘觉自在　　是故无所行

诸善男子。菩萨十二行智入般若波罗蜜。何等十二。明了行。不闇蔽故。大炬行。照明一切诸结使故。放智明网行。离无智故智慧钩行。拔无明根故。善利槊行。破爱网故。金刚行。破结山故。日宫行。干燋结泥故。火大行。烧生树故。摩尼宝行。不迷惑故。是空行。无有物故。无相行。无有相故。无愿行。过三界故。善男子。是名菩萨十二行智入般若波罗蜜。尔时世尊。以偈颂曰

  此慧胜世间　　作光灭诸闇
  日炬甚清净　　照诸结使众
  慧利灭无明　　觉知破坏爱
  破诸结使山　　天主金刚杵
  破坏阿修罗　　所有诸军众
  得照明离闇　　慧示现如灯
  犹日干燋泥　　胜慧犹如日
  度结海彼岸　　犹如船渡水
  拔断无知树　　如刀斩诸树
  得不迷摩尼　　空无物性相
  常离于觉观　　不依诸有道
  得破坏疑惑　　能论出言说
  示生死过患　　示现涅槃炬
  此慧调世眼　　现无迷相事
  因慧菩萨健　　离闇行菩提

诸善男子。是菩萨知见十二境界示现方便。何等十二。善男子。是菩萨到涅槃境界。方便示现生死境界。到寂静境界。方便示现在众闹中。到禅境界。方便示现后宫婇女。到无作境界。方便示现诸作境界。到无生境界。方便示现生死境界。离四魔境界。方便示现降伏诸魔。到圣人境界。方便示现近非圣境界。离世境界。方便示现世间境界。得智境界。方便示现凡夫境界。现了见于实际境界。方便示现不堕声闻缘觉境界。达解得到无相法界。方便示现相好严身。为化众生境界故入佛境界。方便示现诸魔境界。诸善男子。是名菩萨知见十二境界方便示现。尔时世尊。以偈颂曰

  是方便境界　　菩萨净众生
  是住于境界　　示一切境界
  得涅槃境界　　方便现有为
  又到是境界　　无二过患污
  得到寂静处　　方便现众闹
  于二俱无著　　无著行如蜂
  示现婇女中　　宫中贪娱乐
  彼得于寂静　　持德者方便
  不退于禅定　　方便现乱心
  见无诸匆务　　方便智示现
  亦无有恭敬　　无妄相戏论
  非妄妄想界　　方便智示现
  不生亦不死　　不生法豪贵
  示现于生死　　方便智勇健
  出过魔境界　　住威德佛界
  而现魔境界　　是佛子方便
  到圣功德顶　　方便凡夫行
  净智力众生　　方便智变化
  一切法无际　　知于本际空
  不求于灭度　　是方便所持
  一切法无相　　是达空无有
  以化众生故　　示现相好身
  是方便境界　　大威德佛子
  是佛子安住　　示现百变化

诸善男子。汝今当知。如来方便。出生十二功德成就。精练佛土。成于无上正真道已。示现劫浊见浊众生浊烦恼浊。命浊。现差别乘。示现佛土污秽不净。现众生钝。现说法异。现众生异。现异道诤讼。现魔魔业。都无过咎。当知一切是如来方便。佛说是已。尔时文殊师利童子白佛言。世尊。愿说十二功德成就精练佛土。诸佛世尊。于是功德精练佛土。成于无上正真之道。佛言。文殊师利是精练佛土。有精练劫成就具足。不舍精练诸功德故。诸佛世尊。即于是处。成于无上正真之道。是精练佛土。有精练时成就具足。不违失于行法时故。是精练佛土。有于精练众生成就。无不知法故。是精练佛土。有于精练福田成就。善妙净故。是精练佛土。有于精练易解众生成就具足。不顽钝故。是精练佛土。有精练乘成就具足。出一乘故。是精练佛土。有于精练妙地成就。无有物故。是精练佛土。有于精练妙地成就。一切不外行道法故。是精练佛土。有于精练功德成就。无谀谄故。是精练佛土。有精练心毕竟成就。是白净性众生住故。是精练佛土。有于精练圣人成就。福田不空故。是精练佛土。有于精练道场成就。往古先佛所住处故。文殊师利。是名十二功德成就精练佛土。是处一切诸佛如来。成于无上正真之道。文殊师利。汝今当知。我此都无声闻缘觉所安止处。何以故。如来舍离诸异相故。文殊师利。若其如来。或有欲于众生大乘。或有欲于众生小乘。则是如来有不净心。有不等心。有执着过。有小分大悲。有异想咎。我便有于吝惜法咎。文殊师利。我若为众生有所说法。皆趣菩提皆趣大乘。入一切智得到一切智。以是义故。无有异乘所止住处。文殊师利白佛言。世尊。若其无有异乘住处。何故如来序说三乘为众生说法。此是声闻乘。此是缘觉乘。此是大乘。佛言。文殊师利。乘止住处。如来为作安止地耳。非乘止处。非法相作安止住处。如来为人作安止处。若少庄严无量庄严彼安止处。是乘无差法界无别故。文殊师利。如来演说无障碍门。次第到于所住止处。文殊师利。犹工初学。从善巧师。到巧智岸。种种方便。随于弟子所欲学事。令其巧智。示现种种精勤之事。是巧智一也。文殊师利。如来世尊亦复如是。善法巧师。是一切智。作三种说。文殊师利。犹如少火渐渐增长能烧至劫。文殊师利。是一切智明亦复如是。渐次增长。乃至得到如来大智。智慧之明。烧于一切众生结使

文殊师利。须弥山王无所分别。若有众生。往到其所。一切同色。谓一金色。文殊师利。是无上如来大智须弥。亦复如是无所分别。若有观于如来法性。皆同一色。谓一切智。文殊师利。喻如绀青大摩尼宝在所住处。是摩尼宝境界之内。有异色光。谓种种色种种异形。是摩尼宝威德力故。皆为一色。所谓青色。文殊师利。如来无上绀摩尼宝亦复如是。若有众生触如来光。一切一色一切智色。文殊师利。喻如大海。虽种种门众水流入。入已一味。所谓碱味。以常住故。文殊师利。大海者。谓如来大智。种种水入。谓诸一切声闻缘觉菩萨法也。入已一味。所谓一乘无差别故。文殊师利。以是方便。当知如来。安虚妄地。名如来分别引导说作安止。入如来法安住处故。如来示现次第入于佛法中故。令小庄严大庄严者安住佛法。如来以是方便智辩。种种变化说于出世。是第一义者一乘无二。文殊师利。此佛刹土。若诸外道有出家行。如来是中现方便行如来护持自在引导。何以故。文殊师利。如来善能降伏一切诸怨敌故。如来一切常无怨敌

佛说菩萨行方便经卷上佛说菩萨行方便境界神通变化经卷中

        宋天竺三藏法师求那跋陀罗译

文殊师利。如转轮王小功德成有尽德聚。有贪有嗔有痴有取有结有使。是转轮王。一切无有作怨敌者。所以者何。文殊师利。是转轮王无有诤恼。文殊师利。岂况如来转大法轮。无量大智。功德庄严具足成就。得无断大悲。游行无漏法虚空中。七助菩提法宝成就。以不忘法。转大法轮。外有诤讼诸怨敌怖。无有是处。文殊师利当知。若见此佛刹土外道出家。汝善男子当知。一切安住一道。所谓佛道。文殊师利。喻诸禽兽无力能住师子王前。如是文殊师利。诸外道出家无能便入如来境界。亦不能与如来诤论。大人师子。持于十力。得四无畏。在其前吼。无有是处。惟除如来之所加持。文殊师利。喻日宫出放光明网。一切萤火皆悉隐蔽。一切珍宝火光星宿悉无照明。如是文殊师利。无上如来大日宫出时。放大智光明。诸外道出家皆悉隐蔽。无有照明。文殊师利。喻胜铁王随其地分所出之处。一切诸铁无有住者。以诸铁聚不共相故。如是文殊师利。若有佛土有佛出世。当知一切诸外道等无出家行。何以故。不共相佛出于世故。文殊师利。喻如意宝王随所出处。不生一切伪摩尼宝。如是文殊师利。如来大智宝所出处。当知是处不出外道。文殊师利。喻如宝性有出阎浮檀金之处。是处不出下贱铜等。如是文殊师利。若有世界有佛出世。是处不出一切外道。文殊师利。当知方便随佛出处。不应出诸外道出家。文殊师利。汝今当知。如来受持不可思议方便境界。以是缘故。此佛刹土现诸一切外道出家。所以者何。一切外道上首。皆是住于不可思议解脱。从般若波罗蜜出。游戏方便。亦不舍离念佛法僧。教化众生到于彼岸。如来受持化众生故。说是法时。八千天子依声闻乘者。闻说一乘。发于无上正真道心。五百比丘得一乘灯三昧。千二百菩萨。得无生法忍。普此三千大千世界六种震动。天于空中雨天青黄赤白莲华。雨天末栴檀。于佛之前。百千天子。住虚空中。发声唱呼。天衣空中而自回转。诸天作乐说如是言。本未曾闻是经出世。世尊。令此经典久行于阎浮提。八百比丘比丘尼。脱优多罗僧以奉上佛。尔时世尊。欲重宣此义。而说偈言

  方便境界不思议　　文殊师利当知我
  我精练时觉菩提　　我又示现如此时
  时节过咎我所无　　常恒有于妙法时
  众生闻我法过度　　众生过患我所无
  精练劫残功德物　　精练福田净无垢
  我精练时得菩提　　是故知我无有浊
  我已从久多亿劫　　成就无量佛智慧
  如我得道命亦尔　　于是中间无灭度
  我方便现示灭度　　有常想故示无常
  我今示现于余残　　我寿命等未来劫
  我惟一乘一灭度　　我差别乘不可得
  作如是三说三乘　　当知方便之境界
  有懈怠心及小心　　闻即生于惊怖畏
  为是等故示三乘　　惟有一乘无有二
  我随欲于法者说　　入于佛道法事故
  以是一乘演说三　　然于此乘无伤损
  如巧智度到彼岸　　以是智示现于三
  世尊亦尔知胜法　　以是一乘演说三
  等心调御诸众生　　我都无有于异想
  我意喜敬于下乘　　我则有于悭吝咎
  绀琉璃宝众宝上　　随其所在住止处
  一切皆同作一色　　而是绀色无差别
  调御智宝亦如是　　一切佛土普放光
  一切众生作一色　　菩提心色无差别
  犹如小火之所烧　　渐渐增长成大焰
  声闻智焰亦如是　　斯亦放佛功德光
  须弥山王归向者　　以威德故同一色
  归依十力亦如是　　柔忍者得菩提色
  喻如一切众蜂口　　采拾种种众净妙
  一切众物共和合　　皆悉作于一蜜相
  知世赞世亦如是　　示现作于三乘已
  一切白净和合已　　作菩提想无异想
  转轮人王无忧恼　　无有余方怨敌故
  我以法界普告敕　　云何当有外道界
  犹如日宫初出时　　隐蔽萤火诸星宿
  智慧宫出亦如是　　蔽诸外道无明照
  随有胜铁所住处　　一切余铁无能行
  若有国土如来行　　是处无有外道行
  随有金玉所出处　　是处不出生余铜
  若有刹土证菩提　　是处不杂外道众
  意珠伪珠不和杂　　过去未来亦不杂
  佛宝外道亦如是　　一刹土中常不杂
  禅定神通忍自在　　一切智门此外道
  慧方便行智慧者　　示现种种诸变化
  闻于方便境界已　　尔时佛子甚欢喜
  生于庆乐喜无量　　散华供养于调御
  此地六种大震动　　空中伎乐而鼓作
  亿天虚空中合掌　　赞言善哉调御说

说此偈时。萨遮尼干子。与八十亿诸尼干俱。从南方次第游行于诸国界。向优禅尼大城之所。百千大众围绕庄严唱叫唤呼。尔时旃茶钵树提王。遥见萨遮尼干子来。于是萨遮。生爱乐心。生清净心。与诸大臣内宫眷属。国土人民子息四兵。大王威德大王神力。百千满瓨以用庄严。鼓百千伎乐。擎幢幡宝盖以为庄严。即出往迎萨遮尼干。尔时萨遮尼干子。遥见旃茶钵树提王。柔软爱语。善来大王。汝国界中无有怨敌相逼切也。无有病患苦恼热也。是国臣属诸伎卒。恶不肖之人。守罗关税。是等不乱坏国土不。大王。汝国沙门诸婆罗门安乐行不。大王。汝常安法治理国不。大王。不应害于众生猎张鱼捕逼诸众生。何以故。大王当知。一切众生皆悉爱命。是故大王。应受不杀不应偷夺。于自国封应生知足。不应邪淫自足妻色。终不妄语真实而言。不应两舌有异言说。不应恶口常柔软语。不应绮语随所念语。于他财封勿生贪心。大王。应当离于嗔恚。以慈庄严于身口意。大王。不应生于邪见。行圣正见。大王。汝今不应放逸。善观无常。大王当知。寿命短促速至他世。大王。汝今应怖畏后世。应信业报。重说胜偈

  人主常应不放逸　　护持境土不放逸
  若放逸者堕恶道　　若不放逸生善道
  亦莫抂断众生命　　一切众生爱寿命
  慧者不应害众生　　爱护众生如己身
  常应远离于偷盗　　常不应说于妄语
  常应护持实言誓　　大王当来生善趣
  所说言语耳乐闻　　不应说强粗恶语
  常应爱语柔软语　　大王不应说两舌
  人主不应说绮语　　有所言说随顺说
  离于嗔恚过患恶　　如大象王生善道
  王不应行于邪淫　　于他妻女离欲心
  于自妻色常知足　　汝当来生于善道
  大王不应怀于见　　当安住于妙善见
  当修行于如是法　　大王受天娱乐乐
  持戒沙门婆罗门　　及孝顺供于父母
  得远离于恶道已　　当受天中欢喜乐

是萨遮尼干子。以此不放逸法。劝钵树提王已。尔时栴茶钵树提王。向萨遮尼干子。说于爱软安乐之语。自言。不作如是之事。汝婆罗门可至我家。何以故。我今请汝及诸眷属。欲设饭食。尼干子言。善哉善哉。当如是作。何以故。大王。我来道远饥乏所须。大王如是。如汝所请。尔时大王。在萨遮尼干子眷属后行。前入王宫。入已萨遮尼干坐御座。余诸尼干随次而坐。尔时彼王善心恭敬手自料理。萨遮尼干及其眷属。食充足已。尔时此王如是思惟。我今当少问是萨遮尼干子。于如来所有信敬不。王思是已。取小卑床。坐于萨遮尼干子前。作如是言。婆罗门。我欲少论。若听许者。我当问汝。汝为我说。萨遮尼干语大王言。随汝所欲自恣而问。我当善答悦可汝心。王闻听已。问言。婆罗门。世众生中颇有众生慧者明了无乱心智然有过耶。萨遮答言。实有大王。王又问言。婆罗门此是谁也。萨遮答言。跋沙婆罗门是。王又问言。跋沙婆罗门有何过耶。萨遮答言。跋沙婆罗门。善瞻星历。善知节会。善学唱说。善知月蚀。善知地动。善知丰俭。善知世俗会。善学瞻相。然实邪淫爱他妻妇。大王。慧人不应行于邪淫。何以故。大王。行邪淫者。现世来世得大苦法。乃至天人之所呵责。如说偈言

  贪欲他妇女　　不护恶境界
  不足自妻色　　世所有呵责

王言。婆罗门。世众生中复有众生慧者明了无乱心智然有过耶。萨遮答言。实有大王。王言谁是。萨遮答言。此颇罗堕婆罗门是慧者明了知时非时。彼有过患。王又问言。有何过耶。答言。大王。此婆罗门多所睡眠。大王。慧者不应多于睡眠。何以故。大王。睡眠退失世出世法若智若断。如说偈言

  若多乐睡眠　　懈怠所覆蔽
  睡眠放逸覆　　凡夫退诸利

王复问言。婆罗门。世众生中复有众生成就如是诸法然有过耶。萨遮答言。实有大王。王言。谁是。答言。大王。黑王子是。王又问言。是黑王子有何过耶。答言。大王。多于嫉妒。大王。慧者不应多于嫉妒。何以故。大王。若得成就于封邑。行于嫉妒。是人封邑不得坚牢。空手而死。死已便堕于饿鬼界。如说偈言

  嫉妒覆蔽心　　彼人成封邑
  彼有空手死　　堕在饿鬼界

王又问言。复有众生成就如是上功德法有过患耶。萨遮答言。实有大王。王言。谁是。答言。大王。此吉军王子是。王又问言。吉军王子有何过耶。答言。大王。是吉军王子甚嬉杀生。大王。慧者不应好嬉杀生。何以故。杀生短寿。当堕地狱饿鬼畜生。如说偈言

  人王杀生者　　少力及短命
  命终堕地狱　　是故不害生

王又问言。婆罗门复有众生慧者明了无乱心智有过患耶。萨遮答言。实有大王。王言。谁是。答言。大王。此即无畏王子是也。王又问言。无畏王子有何过耶。答言。大王。多悲愍他。大王。慧者不应多悲愍他。何以故。大王。多悲愍他。若自在者。是国多贼。难可降伏。多有过患。如说偈言

  多悲愍于他　　若人自在者
  不能降伏是　　不能执短己

王又问言。颇众生中复有众生慧者慧赞有过患耶。萨遮答言。实有大王。王言。谁是。答言。大王。此天力王子是。慧者慧赞然实有过。王言。婆罗门。天力王子有何过耶。答言。大王。天力王子饮酒放逸。大王慧者。不应多饮酒也。何以故。大王。酒多失念障碍上义。亦失于世及出世义。如说偈言

  常作放逸　　一切王事　　酒放逸蔽
  退出世义

王又问言。婆罗门。复有众生慧者慧赞有过患耶。萨遮答言。实有大王。王言。谁是。答言。大王。此天勋王子是。慧者慧赞然有过患。王言。婆罗门。天勋王子有何过患。答言。大王。天勋王子长思虑过。大王。慧者不应有长思虑。何以故。大王。长思虑者妨废失利令重事起不得寂静。是故大王。大聪慧者不应长思。如说偈言

  若有长思虑　　事失不吉利
  以是善庄严　　妨废发意事

王又问言。萨遮。复有众生慧者慧赞有过患耶。萨遮答言。实有大王。王言。谁是。答言。大王。此大军王子是。慧者慧赞然有过患。王又问言。大军王子有何过耶。答言。大王。有大悭恶覆蔽之过。劫夺他财。大王。慧者不应有大悭恶。如说偈言

  若人主有悭　　得封不知足
  是所聚集财　　至他世忧愁

王又问言。萨遮。复有慧者慧赞然有过患。萨遮答言。实有大王。王言。谁是。答言。大王。波斯匿王。慧者慧赞然有过患。王言。婆罗门。波斯匿王有何过患。答言。大王。波斯匿王有多食过。大王。夫有慧者不应多食。何以故。大王。若有多食。懒怠身重所食难消。如说偈言

  人主多食　　懒怠身重　　又损觉知
  颜状不鲜

王又问言。婆罗门。世众生中复有慧者慧赞然有过患。萨遮答言。实有大王。王言。谁是。答言。大王汝是。世间慧者慧赞。汝亦有过。王言。婆罗门。我有何过。答言。大王。汝多暴虐恶性卒急粗犷无慈。大王。夫有慧者不应粗暴。若慧者粗暴。人不多附。乃至父母亦不适意。况余众生。大王。若聪慧者不应粗暴。大王。有慧之人应深长思。如说偈言

  若有粗暴　　不长觉思　　必有呵责
  无人亲附

尔时栴茶钵树提王。面闻自过。嗔恚忿恼。不适其意。不能忍耐。语萨遮尼干子言。汝应于是大众之中呵责我耶。以嗔恚故。敕令斩杀。尔时萨遮惊怖。向王说如是言。大王。不应作是卒暴。施我无畏听我所白。王言。与汝无畏汝欲何说。大王。我亦有过。我王面前说王过恶。言多暴虐。恶性卒急。粗犷无慈。如实而说。大王。慧者不应于一切时说他实事。大王慧者应当知时非时。何以故。大王。如实说他。多不适意。人不亲附。无慧者呵。如说偈言

  如实说人王　　凡夫者所毁
  是以智慧者　　思量然后说

尔时此王叹言善说。复重问论。婆罗门。世众生中。颇有众生慧者明了。无乱心智。无过咎耶。萨遮答言。实有。大王。王言谁是。答言。大王。此沙门瞿昙是。释王种释种出家。如我等所瞻。彼无过咎。其种贵故无有过咎。生于转轮王种姓故。无有过咎。不生厮下种姓中故。无有过咎。释种生故无有过咎。色貌威德极端严故。无有过咎。相好庄严故。无有过咎。以是义故。无有过咎。是释瞿昙若不出家。当作于大转轮王。七宝成就。所谓轮宝象宝马宝摩尼宝女宝藏臣宝主兵宝。千子具足勇健端正。能坏他众。亦皆成就转轮王相。于四天下统领自在。正法之王。兵仗不用。正法治国。既出家已。苦行六年。日日食于一麻一米。坐菩提树降伏魔众。既降伏已。一念心慧。如所知。如所得。如所触。如所觉。如所证。一切觉知。无有众生与等等者。何况有胜。是沙门瞿昙无有等者。故无过咎。何以故。大王。是沙门瞿昙家种无等。端正威德无与等者。智慧威德无与等者。是故无过。如说偈言

  持于三十二相好　　出生释种人师子
  是净饭王之太子　　世尊一切智无咎

萨遮尼干子如是说已。钵树提王言。大婆罗门。汝今当说。何等是如来三十二大丈夫相。婆罗门言。我今当说。王言。何谓也。大王。是沙门瞿昙。善安跱立足下平满。轮辐圆足。手足柔软。指长佣[月*韱]。手足网鞔。是沙门瞿昙。足跟佣平。足骨钩锁。是沙门瞿昙。其[跳-兆+專]鹿[跳-兆+專]。是沙门瞿昙。其身端正。是沙门瞿昙。阴藏隐密。是沙门瞿昙。其毛一一右旋。是沙门瞿昙。毛悉上靡。是沙门瞿昙。其发绀青。是沙门瞿昙。皮肤金色极上细软。是沙门瞿昙。七处圆满。是沙门瞿昙。身体佣满。是沙门瞿昙。极好支节。是沙门瞿昙。身不逶迤。是沙门瞿昙。身极长广。是沙门瞿昙。周身团圆如尼拘陀树。是沙门瞿昙。身如师子王。是沙门瞿昙。具四十齿。是沙门瞿昙。其齿密致。是沙门瞿昙。牙齿齐平。是沙门瞿昙。牙齿鲜白。是沙门瞿昙。得上胜味。是沙门瞿昙。其舌广长。是沙门瞿昙。有梵音声。是沙门瞿昙。眴则俱眴。是沙门瞿昙。其目绀青。是沙门瞿昙。白毫相具。是沙门瞿昙。其顶有髻。大王。是沙门瞿昙。具三十二大丈夫相。以是义故无有过咎。如说偈言

  出生释种顶有髻　　其发绀青而右旋
  目如青莲牛王眴　　是故世尊无过咎
  迦陵频伽梵音声　　其舌长广净鲜薄
  人中世尊齿齐密　　含齿四十而白净
  一切世人及诸天　　瞻睹其美皆欢喜
  佛世尊舌遍覆面　　是故众生无与等
  一切众味悉和集　　世尊舌相之所出
  一切众味作一味　　是故世尊无过咎
  如师子身频婆唇　　其肩端严广满好
  世尊身如尼拘树　　周匝团圆善安住
  世尊庄严身端直　　人师子身极长广
  七处旋满无与等　　上妙金色善鲜净
  人师子毛而上靡　　其体皮肤极细软
  其髻各各合螺成　　是故众生无与等
  又师子跱不曲垂　　阴藏隐密如马王
  髀佣圆满鹿王[跳-兆+專]　　其谁瞻视不欢喜
  世尊手足有网曼　　其指纤长赤铜爪
  足跟佣平钩锁骨　　足下平满无高下
  世尊手足庄柔软　　纤长指普有轮相
  人尊足安而平跱　　履行地时不倾动
  无与等者如是相　　世灯如是善庄严
  处在大众甚尊妙　　犹如月王处众星
  是大丈夫色如是　　世尊为世作灯明
  何况其余无漏法　　以是法故自然觉

大王。是沙门瞿昙。其色尊妙。一切众生无与等者。以是义故无有过咎。大王。是沙门瞿昙大慈力成。于诸众生其心无碍。常行大慈无碍无著。自然普到一切世界入诸众生。大王。如摩尼宝能清浊水。宝性净故。能令一切浊水清净。大王。沙门瞿昙亦复如是。内清净故。能净一切众生结使浊污淤泥。是故无过。如说偈言

  慈心普遍世　　三世诸世界
  一切众生心　　一切智普慈
  无处不普至　　是慈无与等
  普覆虚空界　　一切智无过
  善净摩尼宝　　能净淤浊水
  世尊净诸有　　净众生结垢

大王。是沙门瞿昙。成三十二大悲之行。何等三十二。见世众生没愚痴闇。是沙门瞿昙。于是众生行于大悲。见世众生在大无明[穀-禾+卵]。是沙门瞿昙。于是众生行于大悲。见世众生堕在于大生死轮回。是沙门瞿昙。于是众生行于大悲。见世众生常勤行于不善寂法。是沙门瞿昙。于是众生行于大悲。见世众生随于大流顺流而去。是沙门瞿昙。于是众生而起大悲。见世众生堕于大山大苦逼切。是沙门瞿昙。于是众生而起大悲。见世众生离于圣道堕于邪道。是沙门瞿昙。于是众生而起大悲。见世众生闭大牢狱自然缠缚。是沙门瞿昙。于是众生而起大悲。见世众生贪于色声香味触故无厌无满。是沙门瞿昙。于是众生而起大悲。见世众生是爱奴仆常系属他。是沙门瞿昙。于是众生而起大悲。见世众生老死逼切羸劣困悴。是沙门瞿昙。于是众生而起大悲。见世众生常病逼切。是沙门瞿昙。于是众生而起大悲。见世众生为三火烧常触燋炽。是沙门瞿昙。于是众生而起大悲。见世众生下缠所缠增长生死。是沙门瞿昙。于是众生而起大悲。见世众生心常惊怖。是沙门瞿昙。于是众生而起大悲。见世众生贪嗜少味不见过患。是沙门瞿昙。于是众生而起大悲。见世众生久眠放逸。是沙门瞿昙。于是众生而起大悲。见世众生堕大饥饿常互相害。是沙门瞿昙。于是众生而起大悲。见世众生常在衰损互相劫夺。是沙门瞿昙。于是众生而起大悲。见世众生无明所盲常不明了。是沙门瞿昙。于是众生而起大悲。见世众生共相斗诤恼乱不息。是沙门瞿昙。于是众生而起大悲。见世众生如芒草滋萁。是沙门瞿昙。于是众生而起大悲。见世众生不净交会离于清净。是沙门瞿昙。于是众生而起大悲。见世众生行于诸难离于无难。是沙门瞿昙。于是众生而起大悲。见世众生多于疑惑着诸邪见。是沙门瞿昙。于是众生而起大悲。见世众生如兜罗华依种种见。是沙门瞿昙。于是众生而起大悲。见世众生想心见倒无常常想苦有乐想不净净想无我我想。是沙门瞿昙。于是众生而起大悲。见世众生担负重担常受苦乏。是沙门瞿昙。于是众生而起大悲。见世众生依止羸劣不坚牢想。是沙门瞿昙。于是众生而起大悲。见世众生常在垢污。是沙门瞿昙。于是众生而起大悲。见世众生系缚欲有而心贪着。是沙门瞿昙。于是众生而起大悲。见世众生利养覆蔽常求于利。是沙门瞿昙。于是众生而起大悲。见世众生堕在种种病苦忧悲啼哭愁恼众苦大聚。是沙门瞿昙。于是众生而起大悲。大王。此沙门瞿昙。成就如是三十二种大悲行故。是故无过。如说偈言

  无明愚痴大闇黑　　见无明[穀-禾+卵]蔽众生
  见众生趣生死狱　　是故人尊生大悲
  众生常勤造众行　　正觉见众生流漂
  恒常随顺此流漂　　十力常生大悲心
  坠堕于极高大山　　见众生行于邪道
  善安止于圣道中　　安寂静处无烦恼
  诸邪见者所系缚　　爱怒境界无满足
  为生老死之所没　　是故十力有大悲
  种种众苦所逼切　　见世三火烧炽然
  惊怖畏之被鹿皮　　以是缘故十力悲
  众生贪着嗜于味　　放逸贪着于境界
  见其堕于饥饿道　　调御能救于怨害
  见诸众生互相害　　为无明闇所覆蔽
  犹如芒草蔓滋萁　　以是缘故十力悲
  淫欲所生诸系缚　　见诸众生行难行
  行于邪见稠林中　　以是缘故十力悲
  于不净中有净想　　无常有常无我我
  见诸众生厌重担　　是故十力生于悲
  见担负于大重担　　凡夫常依止羸劣
  常为诸结所污染　　是故十力有大悲
  见为利养所覆蔽　　复次境界无厌足
  堕于欲有之大海　　是故十力有大悲
  多于种种忧愁病　　见诸众生苦恼已
  为是一切诸苦恼　　是故十力有大悲
  知于非有亦非无　　彼常有于大悲心
  一切众生普遍心　　是故一切智无过

大王。今复略说。是沙门瞿昙成就四念处。四正勤。四如意足。四禅。五根。五力。七助道法。八圣道分。成就具足。是故大王。是沙门瞿昙。无有过咎。如说偈言

  常勤精进修念处　　大觉善知于正断
  大仙禅定得自在　　胜出众生无过咎
  调御世成诸神通　　诸辩自在到彼岸
  如来善知解脱咒　　大觉善通达诸谛
  于梵行处得自在　　修于慈悲及喜舍
  善安止住于定慧　　是故常无众过咎
  大仙善知助菩提　　如来善知八圣道
  见众生苦于圣道　　究竟安止安乐渚
  一切世界无众生　　有与世调齐等者
  一切智成一切德　　恒常不毁呰于他

大王。是沙门瞿昙。成就十力。王言。大婆罗门。何等是名如来十力。大王。是佛如来。是处如实知。是处非处如实知。非处去来现在作业受业住处因报如实而知。无量诸界种种世界如实知之。若诸余人余众生等种种所解如实而知。若余众生余人等根胜非胜根如实而知。一切至道如实而知。若余众生余人诸根诸力。助道诸禅解脱定次第定。一切结使污染白净。随各各处如实了知。念于无量种种宿命。若于一生若无量生。如其所行如其所说如实而知。天眼清净过于人眼。见诸众生种种生死。乃至生于善道恶道如实而知。诸漏尽无漏心解脱及慧解脱如实而知。大王。是名如来十力成就。具足力故。名持十力。名无降伏。是故无过。如说偈言

  是处非处　　如实而知　　实说大人
  彼无有过　　过去无障　　彼有智慧
  未来现在　　知不失之　　善知业报
  知有因缘　　如实不错　　世调御知
  知于无量　　种种诸界　　善知诸界
  世人无等　　世种种解　　无量诸佛
  照世明知　　如实不异　　知于钝根
  亦知中根　　又知熟根　　到于彼岸
  一切至道　　如实而知　　根力助道
  神通解脱　　污染白净　　各各了知
  无有障碍　　知见无碍　　念于平等
  无量称实　　自身及他　　如实不异
  天眼清净　　过于人眼　　生死众生
  调御悉见　　知诸漏尽　　亦知解脱
  无漏有异　　亦悉知见　　是人尊力
  觉了自在　　是一念有　　心无分别
  动发非发　　自然而有　　始初转轮
  无分别行　　一心而知　　诸众生思
  及众生心　　无有二相　　是故无过
  佛得自在　　一切善法　　出诸德事

大王。是沙门瞿昙。成就四无畏。王又问言。大婆罗门。何等如来四无畏也。大王。是沙门瞿昙自言。我得于正遍知。若有沙门诸婆罗门魔梵及世言。汝于诸法不正遍知。我不见是相。不见相故得安隐行。得无畏行。自言。我得最胜处行。在大众中。正师子吼。能转梵轮。沙门婆罗门及余诸世。无有能转是正法者。佛自誓言。我诸漏尽。若有说言。汝漏未尽。佛不见是相。不见相故。如来得于安乐之行。得无畏行。得胜处行。在大众中。正师子吼。能转梵轮。沙门婆罗门及余诸世。无有能转是正法者。佛说障道法。若有说言。亲近是法无有障碍。佛不见是相。不见相故得安乐行。得无畏行。得胜处行。在大众中。正师子吼。转于梵轮。沙门婆罗门及余诸世。无有能转是正法者。我说圣出道。若有说言。亲近是者不能出世。佛不见是相。不见相故。得安乐行。得无畏行。得胜处行。在大众中。正师子吼。能转梵轮。沙门婆罗门及余诸世。无有能转是正法轮。大王。此是如来四无所畏。如来成就是四无畏。在大众中。正师子吼。是故无过。如说偈言

  众中师子吼　　人调无所畏
  更无与我等　　况众生有过
  若我所觉法　　是真实不虚
  是正遍知见　　鹿王师子吼
  若有违逆者　　不见有彼相
  以不见相故　　人调无所畏
  我一切漏尽　　我身是无漏
  无有似等者　　诸天及世人
  有是障碍法　　世调御所说
  是真实空虚　　无有可变异
  我说出道法　　自觉已演说
  修行此法者　　无有于障碍
  大健知是已　　如来得安乐
  得于无畏乐　　胜大丈夫行
  转于梵法轮　　余无有能转
  世间所不转　　惟除两足尊

佛说菩萨行方便经卷中佛说菩萨行方便境界神通变化经卷下

        宋天竺三藏法师求那跋陀罗译

复次大王。是沙门瞿昙。成就十八不共佛法。大王。何等十八不共佛法。大王。是佛如来。无有错乱。口无言说。无有失念。无有异想。无不定心。无不知己。舍欲无退减。进无退减。念无退减。慧无退减。解脱无退减。解脱知见亦无退减。一切身业以智为首随于智行。一切口业以智为首随于智行。一切意业以智为首随于智行。知于过去无碍知见。知于未来无碍知见。知于现在无碍知见。大王。是名如来十八不共佛法成就。是故无过。如说偈曰

  世尊无错乱　　口无有言说
  其念无有失　　是故彼无过
  无有于异想　　正智心不乱
  随时不生舍　　一切智无过
  欲无有退减　　善誓进无减
  其念无有失　　彼无能毁者
  慧无损退减　　解无有退减
  解知见无减　　彼智无有恼
  一切诸身业　　口业及意业
  以智力自在　　智亦无有失
  知于过去世　　彼智无有碍
  未来亦无碍　　现在世无碍
  有如是功德　　是沙门瞿昙
  复过是无量　　非我说能尽

尔时栴茶钵树提王。闻如来如是不可思议诸功德已。甚适其意。欢喜踊跃生于爱乐。于是萨遮尼干子所。得无量欢喜。得不可思议想。得世尊想。得善知识想。得示菩提想。得度到彼一切智想。得启请想。得于念想。又得菩萨不可思议解脱之想。得于如是诸想心已。以价直百千真珠璎珞。又复以上无价之衣。供养萨遮尼干子已。如是赞言。善哉善哉。萨遮尼干子。善说次第方便之法。又言。萨遮。汝所说法顺一切智。汝所说法到一切智。汝所说法出于生死。汝所说法灭结使垢。汝所说法破嫉妒门。汝所说法击大施鼓。汝所说法能破坏魔大憍慢山。汝所说法能干爱海。汝所说法照愚痴林。汝所说法。教化众生不过失时。王说是已。萨遮尼干子语大王言如是大王。菩萨威仪无不调伏诸众生者。无有说法逆大乘者。若不能增益一切智。若不能尽一切结使。若不能示生死过患。若其不能到于涅槃。若不能近菩萨之行。若不能到自利利他及俱利者。无有是处。大王。若有一切初发意时。便到自利利他俱利。萨遮尼干说是事时。栴茶钵树提王。得断疑信得不坏信。十六王子。得于欢喜信行之界。八千天子获得三昧。名庄严佛行。是王宫中所坐尼干有万三千。发于无上正真道心。各各脱衣供养萨遮尼干子已。作如是言。我等今者得于善利。见是萨遮大善男子。又闻演说是随顺法。复言。萨遮。可与俱往。欲见世尊。是佛如来今在我园。萨遮答言。一切悉来和合共往。尔时大王与其眷属大臣人民设大庄严。尔时大王遍城行令唱如是言。若不至于如来所者。当斩杀之。举城一切男子女人童男童女。闻王令已。各各持诸华鬘涂香末香种种伎乐。出于优禅大城外已。向园而住待于大王。尔时钵树提王。与萨遮尼干子诸大臣等。王子兵众。内宫婇女。国土人民。骑乘围绕。大王威德。王大神力。王大变化。王大游戏。擎幢幡盖。百千音乐歌舞唱伎。箫笛击节出种种妙音。象马槃戏百千吉瓨。在前行列。以金锁庄校象车马车。九十八亿人众围绕。趣向自园诣世尊所。到已顶礼佛足右绕三匝却住一面。萨遮尼干及其眷属。顶礼佛足右绕无量百千匝已。住立合掌观佛不眴。尔时大德舍利弗。见萨遮尼干子佛前观佛目不暂眴。见是事已作是思惟。萨遮尼干子何缘来此。如是思已。语萨遮尼干子言。萨遮。汝何缘故诣如来所。欲见如来为欲听法。萨遮尼干子言。大德舍利弗。我不见佛不为听法。大德舍利弗。我今不用一切法故诣如来所。何以故。大德舍利弗。见色不名见于如来。见受相行识。亦不名为见于如来。不见地大水火风大名见如来。不见于我名见如来。不见众生不见寿命不见养育名见如来。不见丈夫名见如来。不见我胜我所胜名见如来。不见于想名见如来。大德舍利弗。不见一切相者名见如来。不见执著名见如来。见无有物名见如来。见于性故名见如来。见本际故名见如来。见眼色离欲名见如来。见耳声无教名见如来。见鼻香不和合名见如来。见舌味无知名见如来。见身触无觉名见如来。见意法无分别名见如来。舍利弗言。萨遮。以如是相见如来者。云何见如来耶。萨遮答言。大德舍利弗。非以种故见于如来。不以性故见于如来。非相非无相。非法非无法。非实非不实。非境界非不境界。非思惟非不思惟。非分别非不分别。非有为非无为。非物非不物。非聚非散。非色非受非想非行非识。非取非不取。名见如来。舍利弗言。萨遮。以如是相见如来者。汝善丈夫。云何得见于如来耶。萨遮答言。大德舍利弗。我非到色见于如来。亦不离色见于如来。亦不坏色见于如来。如是受想行识。非到于识见于如来。不离于识见于如来。亦不坏识见于如来。非现世分见于如来。非过世分见于如来。非以阴分见于如来。非以界分见于如来。我以如是见于如来。我见一切言说非言说。名见如来。我非见非不见。非有非不有。非分别非不分别。非忆想非诤非恼非起非取非舍非戏论。非作想非不作想。非作物非不作物。非动发非不动发。非作见非无作见。非境界见非不境界见。非言语非不言语。见于如来。离于一切所有言语谈论音声。名见如来。亦无所见。大德舍利弗。菩萨如是见于如来。我亦如是见于如来。舍利弗言。汝以如是见于如来。汝复云何闻说法耶。萨遮答言。大德舍利弗。若我听于如来说法。若生法想非是法想。何以故。大德舍利弗。菩萨一切所有言说皆出于法。然不执着。亦不生想。何以故。离法想故。舍利弗言。汝今萨遮。不求听法诣如来耶。萨遮答言。大德舍利弗。我非求法。非不求法。诣如来耶。何以故。大德舍利弗。夫求法者。名不求于一切诸法。大德舍利弗。夫求法者。不着佛求。不着法求。不着僧求。不知苦求。非断集求。非修道求。非证灭求。非过欲界。非过色界无色界求。非生死求。非涅槃求。大德舍利弗。汝当知。我都不求于一切法故。诣如来所。舍利弗言。以何缘故作如是说。萨遮答言。大德舍利弗。一切诸法无因缘故。我如是说。又法界性。无有因缘。非无因缘。俱不可得故。舍利弗言。汝今流转于诸道耶。萨遮答言。大德舍利弗。若有道者我则流转。若有生者我则有生。若有去者我则有死。大德舍利弗。一切诸法无去无生死。舍利弗言。萨遮。如佛所说。汝等比丘生老病死。萨遮答言。大德舍利弗。一切众生依止有道及憍慢故。为坏依止。如来世尊作如是说。佛法如性。无有如是生老病死。舍利弗言。善哉善哉。萨遮。汝说大乘知分别义。萨遮答言。大德舍利弗。汝今能知。云何是义。云何分别。舍利弗言。善男子。我非说者我今欲听。善男子。汝当演说。云何是义。云何分别萨遮答言。大德舍利弗。义者谓无言说。若有言说名为分别。又复义者。谓不可说。若有言说名为分别。又复义者。名谓默然。若有言说名为分别。又复义者。谓无动摇无诸戏论。无有分别无有庄严。非有非物。无有我想。非勇。不可取不可见。无有居止。离于一切居止言说。又分别者。谓思量数观往至他心。又复义者。名谓义辩。分别者。谓法辩辞辩乐说之辩。大德舍利弗。是名略说义及分别。尔时世尊赞萨遮尼干子。善哉善哉。善男子如汝所说。说此法时三千天子。得无生法忍。二万众生闻此大辩。发于无上正真道心

尔时大德目连白佛言。世尊。是萨遮善男子。作是外道尼干子服。化几众生。佛告目连。若闻此事。一切天人皆当迷惑。唯除菩萨摩诃萨等。目连谛听。我今演说。萨遮尼干子。种种形服色像威仪。教化众生少分之事。目连。是萨遮善男子。作外道服。教化须弥尘数众生。令发无上正真道心。作遮勒形服。化四天下尘数众生。发于无上正真道心。作余异道出家之像。化八十四恒河沙等众生。发于无上正真道心。现声闻形。化十恒河沙等众生。示声闻乘已。然后复化。令发无上正真道心。作缘觉像。教化众生复过是数。菩萨形服。教化众生复过是数。复作释像。复作梵像。复作转轮大王之像。复作护世像。复作紧那罗像。复作阿修罗像。复作迦楼罗像。复作摩睺罗像。复作人像。复作非人像。复作男子像。复作女人像。复作童子像。复作童女像。复作地天像。复作即化生天像。复作仙人像。复作年少婆罗门像。复作比丘像。复作比丘尼像。复作优婆塞像。复作优婆斯像。目连。萨遮善男子。教化众生如是甚多。尔时目连白佛言。世尊。是萨遮尼干子。奉事供养几如来耶。佛告目连。假量虚空可得其边。无有能得萨遮善男子。以种种形供养奉事诸佛如来得其边者。目连。假令能得地界水界火界风界众生界边。无有能得是萨遮善男子奉事供养诸佛如来得其边者。尔时大德大迦叶。语萨遮善男子言。善男子。汝多奉事供养诸佛。汝之功德具足成就。何故不成无上正真道。萨遮答言。大德迦叶。若有菩提有觉菩提者。我当觉于无上正道。大德迦叶。语萨遮言。恒河沙等菩萨摩诃萨发菩提愿。觉于无上正真之道。已觉今觉当觉。萨遮答言。大德迦叶。为憍慢众生作如是数。第一义中。无有菩提。无觉菩提者。何以故。大德迦叶。菩提是无为。离一切数。菩提非色。不可见故。菩提非青非黄非赤非白非紫非颇梨色。无有形像。无貌无相。过一切相。无有居止。断一切居止。非有。离一切有。非相。离一切相。无有言说。口业不及故。非见非聚亦非有物。非闇非明无形无体。不可言说非不可说。非触非知非闻非声非句。非系非缚非解非染。非嗔非痴非一切事。非假名非不假名。大德迦叶。菩提性尔。又菩提者。非身所觉。又菩提者。非心所觉。何以故。大德迦叶。身痴无智。犹如草木墙壁土块。是故不能觉。于菩提心者非色。又不可见是亦不能觉于菩提。亦无众生可觉菩提。大德迦叶。一切法性皆悉如是。汝云何言。汝何不成无上正道。尔时菩萨。大声闻众。优婆塞优婆斯。及释梵护世。如是思惟。世尊。如实知众生心。如所解知。如来当断我等疑惑犹豫之心。当说萨遮善男子记。几时当成无上正道。世界何名。得菩提已。名号何等。住寿几何。大众有几。尔时世尊。知诸菩萨声闻优婆塞优婆斯释梵护世心之所念。即告文殊师利。是萨遮善男子。此贤劫过已。然后复过于算数劫。当得作佛。号实意相王如来应供正遍知。其佛世界名善观称。劫名灭刺。文殊师利。是善观称世界。端严甚可爱乐。七宝庄严周匝百千。七宝垣墙以为庄严。有百千堑。七种香水充满其中。复有百千高大台观。七种琉璃大宝所成。有百千万阎浮檀金网。以为庄严而遍覆之。有百千万摩尼之宝间错台。有百千万过师子摩尼宝。庄严牖响。有百千万师子幢摩尼宝庄严宝座。有百千万大幢摩尼宝。照明一切。百千万铃网。出于和适软妙音声。遍满其中。悬百千万珠宝金网。竖立百千万种相幢。文殊师利。是善观称世界。地平如掌。宝树遍覆。生柔软草。其草右旋。如难提跋旦孔雀项色。触如天衣。是草普遍善观称界。有百千万园以为庄严。其一一园。复以百千万园围绕庄严。有百千万池周遍庄严。是一一池。以八楞摩尼宝而间错之。阎浮檀金以为梯橙。底布金沙。满八味水。宝华遍布。有鹅雁鸳鸯相和而鸣。文殊师利。善观称世界。百千万国及城邑村落周遍庄严。其一一大城。复有百千万城。周匝庄严。诸村邑聚落。亦复如是。是一切国城邑村落男女充满。文殊师利。是善观称世界之中有四天下。名适意见。甚为殊特。极妙端严极盛丰乐。男女甚多。彼实意相王如来应供正遍知。当生其中。文殊师利。是实意相王如来出婆罗门种。母名勇猛。如今我母名曰摩耶。父名梵摩婆秀。如我父王名曰净饭。彼当有子名曰遍声。如今我子名罗睺罗。有妻胜后名曰大意。如今我妻瞿婆伽释种童女。当有乳母名曰大称。如我乳母名摩诃波阇波提瞿昙弥。彼佛世尊当有侍使名常顺行。如我侍使名曰阐陀。彼佛如来。有大马王名曰大力。实意相王当乘出家。如今我马王名建持迦。彼佛如来当有道场。名曰法勇。彼佛如来于是场上。当成无上正真之道。当有八十亿菩提树周匝庄严。文殊师利。彼佛尔时。无魔无魔天众。文殊师利。彼当来世。实意相王。成于无上正真道时。彼佛世界所有众生。悉以一切诸华香鬘种种伎乐。作众伎乐。当共往诣法勇道场。上至阿迦腻吒天众一切来集。龙众夜叉众乾闼婆众阿修罗众迦楼罗众紧那罗众摩睺罗伽众。皆当来集。东西南北诸大菩萨皆当来集。文殊师利。是实意相王。初觉菩提已。在大众中。说此菩萨行方便境界神通变化经。无量百千亿经而围绕之。文殊师利。彼实意相王如来说此经时。恒河沙等众生。于阿耨多罗三藐三菩提得不退转。文殊师利。是实意相王如来。不说于三乘法。彼佛世界。无声闻缘觉。惟皆一乘妙解众生。生彼世界。文殊师利。彼实意相王如来世尊。初会说法。当有恒河沙等菩萨得不退转。第二大会。有八十那由他菩萨当得一生。第三大会。当有六十频婆罗数菩萨。自是以后。当有过于算数菩萨。安住不退无上正真道。文殊师利。彼实意相王佛。得成道已。寿六十中劫。佛涅槃后。正法住世八十亿百千那由他岁。当广流布佛之舍利。所调众生其数如先。文殊师利。彼佛临欲入灭度时。授于大相菩萨记已。后乃灭度。此大相菩萨。次于我后。当得成于无上正真道。号大庄严如来应供正遍知。时此大众。心生惊疑。谁是尔时大相菩萨。次彼世尊当成无上正真之道。号大庄严如来应供正遍知。尔时世尊。知大众心。即告文殊师利童子。是萨遮善男子前坐外道小童子者。名实欢喜。得胜一切诸余童子。彼当成佛。号大庄严如来应供正遍知。彼佛世界所庄严事如彼实意相王如来等无有异。此众闻彼佛刹功德庄严威德。会中六十亿百千那由他诸菩萨等。发心愿生彼佛世界。白佛言。世尊。是实意相王。得成佛时。我等当生彼佛世界。世尊即记当生彼国。有八十亿诸尼干等。同声唱言。世尊。我等亦当生彼佛土。佛一切记当生彼国。于上空中。有九十亿百千那由他诸天子等。说如是言。世尊。彼实意相王佛得菩提时。我等当生彼善观称世界之中。当见如是功德庄严。佛即记言。汝等天子亦当生彼善观称界奉事彼佛。汝诸天子。亦当于彼善观称界成于无上正真之道。各有异名等同寿命。即时三千大千世界六种震动。其地自然勇出无量百千亿那由他大宝莲华。阎浮檀金为叶。天绀琉璃摩尼为台。车磲为须。琉璃为茎。诸莲华中有菩萨现。结加趺坐相好严身恭敬礼佛。以于种种璎珞云网。供佛世尊。皆言我等各各在于异佛世界。遥闻说此不可思议菩萨功德经。故来至此。见佛世尊礼敬右绕。亦为见萨遮善男子及诸大众。又言世尊。有不可思议诸佛刹土无数众生。闻此经已。皆得不退无上正道。尔时世尊。欲重宣此义。而说偈言

  听我说此义　　一心勿乱念
  如来语无虚　　调御无异说
  萨遮佛出世　　过算数亿劫
  号实意相王　　劫净无垢刺
  无有淫欲刺　　无有多过咎
  亦无愚痴刺　　彼劫无有刺
  世界善观称　　杂色妙庄严
  人天喜乐观　　调御世当有
  游宝高台观　　当有普严净
  阎浮金网覆　　妙软声适意
  竖师子宝幢　　悬珍宝金网
  珍宝高墙壁　　当有天宫殿
  当有江池井　　当一切庄严
  青白莲遍布　　八味水溢满
  当中四天下　　名曰适意见
  善逝所生城　　出婆罗门种
  母名曰勇猛　　父梵摩婆秀
  子曰遍名声　　如我子罗睺
  彼善逝胜后　　其名曰大意
  如我后瞿婆　　乳母名大称
  如今我乳母　　名曰瞿昙弥
  侍使名顺行　　当为调御使
  供给于善逝　　如我使阐陀
  二足尊马王　　当名曰大力
  负善逝出家　　如我健持迦
  彼如来道场　　当名曰法勇
  八十亿百千　　树周匝围绕
  人尊坐此已　　实意自无等
  无上无忧道　　道树下善觉
  无魔无魔众　　终无有魔业
  善逝土无刺　　有无等丈夫
  彼界有众生　　作人天功德
  华鬘诸伎乐　　出诣世尊所
  调御知众集　　知毕竟心净
  当说此经王　　有亿经围绕
  闻于此胜经　　二足尊说时
  多亿恒沙众　　有不退佛智
  终不闻下乘　　亦无缘觉乘
  慧健诸菩萨　　彼佛世界有
  二足尊初会　　当有恒河沙
  功德海不退　　菩萨大名称
  二会八十那由他　　悉皆得住于一生
  三会六十频婆罗　　诸善菩萨多利益
  满六十中劫　　善逝所寿命
  人调御灭已　　正法广流布
  八十亿千岁　　法住那由他
  舍利广流布　　亦多调众生
  世调灭度时　　记大相菩萨
  汝当调御世　　号名大庄严
  彼庄严亦尔　　利众生亦等
  当作调世觉　　无上无尘道
  我知见无上　　知当无量劫
  何况现在前　　一切智无碍
  信我语无量　　如来语无空
  谛住于我教　　取我所说语
  闻善逝说已　　大众生喜勇
  发愿彼世界　　我等当生彼
  世调御说记　　生彼无垢刹
  汝当觉胜道　　广利来众生
  说此经王时　　大地六种动
  华中出菩萨　　合掌礼调御
  善哉觉丈夫　　善说法不断
  佛说法我闻　　远来此为法

当于尔时。一切大众甚适其意。欢喜踊跃爱乐受持。唯留一衣。余衣悉以奉上供佛。说如是言。世尊出世再转法轮。于波罗奈初转法轮。今复更转最大法轮咸言。世尊。愿令我等常不离于如此法宝。亦常不离此善丈夫。时上空中作种种天乐。雨大青黄赤白莲华于佛足前。诸天天衣于虚空中而自回转。唱如是言。是善丈夫。于当来世成就不可思议功德。所谓若有受持此经读诵通利为他广说。说是语已。文殊师利白佛言。世尊。是善男子善女人等。书写此经。受持读诵令通利已。为他广说得几所功德。如是问已。佛言。文殊师利。若有一善男子善女人。三千大千世界之中。所有众生。有色无色有想无想。有众生界。唯佛能知诸有一切。未得人身悉得人身。成于无上正真道已。是一善男子善女人。恭敬供养尊重礼拜。是一切佛。施诸所安。寿命一劫。文殊师利。于汝意云何。是善男子善女人。以是因缘得福多不。文殊师利答言。甚多世尊。甚多善逝。无有能数无有计量。佛言。文殊师利。是善男子善女人。书写受持读诵通利为他广说。福多于彼善男子善女人供诸佛者。文殊师利言。世尊未曾有也。世尊利益一切世间。说此经典。世尊此经。当于阎浮提中流布几时。佛言。文殊师利。我涅槃后。我之舍利。当广流布。尔时八王。当以宝箱分我舍利。作八分已。各各自国造作大塔。阿阇世王。取我舍利第八之分。盛宝香奁。王舍城外穿凿于地。而藏隐之。安置种种众妙杂香。竖立种种幢幡宝盖。散众宝华然百岁灯。藏舍利箱。待阿叔迦王。于金叶上书此经王。并藏去之。文殊师利。我涅槃后百岁。当有阿叔迦王。是王当出于莫刹利种。王阎浮提。得自在住四渚转轮。彼王尔时修念我行。于佛法中得清净心

尔时有比丘名因陀舍摩。得大神通有大威德。摄持正法持方等经。是王种出家。出入阿叔迦大王宫中。文殊师利。阿叔迦王。为广流布我舍利故。大多将从诸贵人等。大王威德而自庄严。持诸华鬘末香涂香种种伎乐。到王舍城大设供养。垦掘其地取舍利箱。七日之中设种种供养。以一切华一切鬘一切末香一切涂香一切伎乐。作于如是大供养已。然后随于种种多人所居止处。一日一时安起八万四千大塔。尔时因陀舍摩法师。从于宝箱出此经已。安置北方多人住处。此经又无多人识知。无多人解。无多人受。少人受持读诵此经。文殊师利。此经多隐在箱箧中。何以故。无人受故。非真器故。文殊师利。当知此经。难解难信。难得其底。非是常人所能信受。非凡下人能读能入。文殊师利后五十岁时。若复有人。闻此经典信解恭敬。文殊师利。不应作疑。当知是人供养多佛。善行于此大乘经典。有真实器。若有书写受持此经读诵通利。是众生等应当自知。我等已见恒河沙等诸佛如来。奉事供养右绕礼拜。亦见于我在此园中。说是经时及见大众。尔时佛告阿难。汝受此经读诵通利。汝慎勿于厮下人前说此经典。不知根故。何以故。阿难。是如来功德。是如来蜜处。是如来说。纯无杂法。是如来印。是如来坚法。是如来胜财。阿难汝当坚持勿妄与人。唯除我长子持我法藏护我法藏与是等人。阿难白言。我持此经已。世尊。此经何名。云何受持。佛言阿难。此经名曰说菩萨行方便境界神通变化经。亦名如来密处。亦名如来说纯无杂法。亦名如来说出一乘。亦名文殊师利所问。亦名萨遮受记。亦名萨遮品。如是受持。如来演说此经法时。有三十那由他诸众生等。本未曾发无上道心今悉发心。六万菩萨得无生法忍。无量众生必定无上正真之道。佛说是经已。大德阿难欢喜适意。文殊师利童子。一切菩萨。比丘比丘尼优婆塞优婆斯。释梵护世天及世人。闻佛说已。欢喜信受

佛说菩萨行方便经卷下


金刚三昧经序品第一

    No. 273

    金刚三昧经序品第一

        北凉失译人名

如是我闻。一时佛在王舍大城耆阇崛山中。与大比丘众一万人俱。皆得阿罗汉道。其名曰舍利弗。大目犍连。须菩提。如是众等阿罗汉。复有菩萨摩诃萨二千人俱。其名曰解脱菩萨。心王菩萨。无住菩萨。如是等菩萨。复有长者八万人俱。其名曰梵行长者。大梵行长者。树提长者。如是等长者。复有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。六十万亿。尔时尊者大众围绕。为诸大众说大乘经。名一味真实无相无生决定实际本觉利行。若闻是经。乃至受持一四句偈。是人则为入佛智地。能以方便教化众生。为一切众生作大知识。佛说此经已。结加趺坐。即入金刚三昧。身心不动。尔时众中。有一比丘。名曰阿伽陀。从座而起。合掌胡跪。欲重宣此义。而说偈言

  大慈满足尊　　智慧通无碍
  广度众生故　　说于一谛义
  皆以一味道　　终不以小乘
  所说义味处　　皆悉离不实
  入佛诸智地　　决定真实际
  闻者皆出世　　无有不解脱
  无量诸菩萨　　皆悉度众生
  为众广深问　　知法寂灭相
  入于决定处　　如来智方便
  当为入实说　　随顺皆一乘
  无有诸杂味　　犹如一雨润
  众草皆悉荣　　随其性各异
  一味之法润　　普充于一切
  如彼一雨润　　皆长菩提芽
  入于金刚味　　证法真实定
  决定断疑悔　　一法之印成

    金刚三昧经无相法品第二

尔时尊者。从三昧起。而说是言。诸佛智地入实法相。决定性故。方便神通皆无相利。一觉了义难解难入。非诸二乘之所知见。唯佛菩萨乃能知之。可度众生皆说一味

尔时解脱菩萨。即从座起合掌胡跪。而白佛言。尊者。若佛灭后。正法去世。像法住世。于末劫中。五浊众生。多诸恶业轮回三界无有出时。愿佛慈悲为后世众生。宣说一味决定真实。令彼众生等同解脱。佛言。善男子。汝能问我出世之因。欲化众生。令彼众生获得出世之果。是一大事不可思议。以大慈故。以大悲故。我若不说即堕悭贪。汝等一心谛听谛听。为汝宣说。善男子。若化众生无生于化。不生无化其化大焉。令彼众生皆离心我。一切心我本来空寂。若得空心心不幻化。无幻无化即得无生。无生之心在于无化。解脱菩萨。而白佛言。尊者。众生之心性本空寂。空寂之心体无色相。云何修习得本空心。愿佛慈悲为我宣说。佛言。菩萨一切心相本来无本。本无本处空寂无生。若心无生即入空寂。空寂心地即得心空。善男子。无相之心无心无我。一切法相亦复如是。解脱菩萨。而白佛言。尊者。一切众生。若有我者。若有心者。以何法觉。令彼众生出离斯缚。佛言。善男子。若有我者。令观十二因缘。十二因缘本从因果。因果所起兴于心行。心尚不有何况有身。若有我者令灭有见。若无我者令灭无见。若心生者令灭灭性。若心灭者。令灭生性。灭是见性。即入实际。何以故。本生不灭本灭不生。不灭不生不生不灭。一切诸法亦复如是。解脱菩萨。而白佛言。尊者。若有众生。见法生时令灭何见。见法灭时令灭何见。佛言。菩萨若有众生。见法生时令灭无见。见法灭时令灭有见。若灭是见得法真。无入决定性决定无生。解脱菩萨。而白佛言。尊者。令彼众生住于无生是无生也。佛言。住于无生即是有生。何以故。无住无生乃是无生。菩萨若生无生以生灭生。生灭俱灭本生不生。心常空寂空性无住。心无有住乃是无生。解脱菩萨。而白佛言。尊者。心无有住有何修学。为有学也为无学也。佛言。菩萨无生之心。心无出入。本如来藏性寂不动。亦非有学亦非无学。无有学不学。是即无学。非无有学是为所学。解脱菩萨。而白佛言。尊者。云何如来藏性寂不动。佛言。如来藏者生灭虑知相隐理不显。是如来藏性寂不动解脱菩萨。而白佛言。尊者。云何生灭虑知相。佛言。菩萨理无可不。若有可不。即生诸念。千思万虑。是生灭相。菩萨观本性相理自满足。千思万虑不益道理。徒为动乱。失本心王。若无思虑。则无生灭。如实不起。诸识安寂。流注不生。得五法净。是谓大乘。菩萨入五法净。心即无妄。若无有妄。即入如来自觉圣智之地。入智地者。善知一切从本不生。知本不生。即无妄想。解脱菩萨。而白佛言。尊者。无妄想者。应无止息。佛言。菩萨妄本不生。无妄可息。知心无心。无心可止。无分无别。现识不生。无生可止。是则无止。亦非无止。何以故。止无止故。解脱菩萨。而白佛言。尊者。若止无止。止即是生。何谓无生。佛言。菩萨当止是生。止已无止。亦不住于无止。亦不住于无住。云何是生。解脱菩萨。而白佛言。尊者。无生之心。有何取舍。住何法相。佛言。无生之心。不取不舍。住于不心。住于不法。解脱菩萨。而白佛言。尊者。云何住于不心。住于不法。佛言。不生于心。是住不心。不生于法。是住不法。善男子。不生心法。即无依止。不住诸行。心常空寂。无有异相。譬彼虚空无有动住。无起无作无彼无此。得空心眼。得法空身。五阴六入悉皆空寂。善男子。修空法者。不依三界。不住戒相。清净无念。无摄无放。性等金刚。不坏三宝。空心不动。具六波罗蜜。解脱菩萨。而白佛言。尊者。六波罗蜜者。皆是有相。有相之法。能出世也。佛言。善男子。我所说六波罗蜜者。无相无为。何以故。若人离欲。心常清净。实语方便。本利利人。是檀波罗蜜。志念坚固。心常无住。清净无染。不着三界。是尸波罗蜜。修空断结。不依诸有。寂静三业。不住身心。是羼提波罗蜜。远离名数。断空有见。深入阴空。是毗梨耶波罗蜜。俱离空寂。不住诸空。心处无住。不住大空。是禅波罗蜜。心无心相。不取虚空。诸行不生不证寂灭。心无出入。性常平等。诸法实际。皆决定性。不依诸地。不住智慧。是般若波罗蜜。善男子。是六波罗蜜者。皆获本利。入决定性。超然出世。无碍解脱。善男子。如是解脱法相。皆无相行。亦无解不解。是名解脱。何以故。解脱之相。无相无行。无动无乱。寂静涅槃。亦不取涅槃相。解脱菩萨闻是语已。心大欣怿得未曾有。欲宣义意。而说偈言

  大觉满足尊　　为众敷演法
  皆说于一乘　　无有二乘道
  一味无相利　　犹如太虚空
  无有不容受　　随其性各异
  皆得于本处　　如彼离心我
  一法之所成　　诸有同异行
  悉获于本利　　灭绝二相见
  寂静之涅槃　　亦不住取证
  入于决定处　　无相无有行
  空心寂灭地　　寂灭心无生
  同彼金刚性　　不坏于三宝
  具六波罗蜜　　度诸一切生
  超然出三界　　皆不以小乘
  一味之法印　　一乘之所成

尔时大众闻说是义。心大欣怿。得离心我。入空无相。恢廓旷荡。皆得决定。断结尽漏

    金刚三昧经无生行品第三

尔时心王菩萨。闻佛说法出三界外不可思议。从座而起。叉手合掌。以偈问曰

  如来所说义　　出世无有相
  可有一切生　　皆得尽有漏
  断结空心我　　是则无有生
  云何无有生　　而得无生忍

尔时佛告心王菩萨言。善男子。无生法忍法本无生。诸行无生非无生行。得无生忍即为虚妄。心王菩萨言。尊者。得无生忍。即为虚妄。无得无忍应非虚妄。佛言。不也。何以故。无得无忍是则有得。有得有忍是则有生。有生于得。有所得法。并为虚妄。心王菩萨言。尊者。云何无忍无生心。而非虚妄。佛言。无忍无生心者。心无形段。犹如火性。虽处木中。其在无所决定性故。但名但字。性不可得。欲诠其理假说为名。名不可得。心相亦尔。不见处所。知心如是。则无生心。善男子。是心性相。又如阿摩勒果。本不自生。不从他生。不共生。不因生不无生。何以故。缘代谢故。缘起非生。缘谢非灭。隐显无相。根理寂灭。在无有处。不见所住。决定性故。是决定性亦不一不异不断不常。不入不出不生不灭。离诸四谤言语道断。无生心性亦复如是。云何说生不生有忍无忍。若有说心有得有住及以见者。即为不得阿耨多罗三藐三菩提。般若是为长夜了别心性者。知心性如是性亦如是。无生。无行心王菩萨言。尊者。心若本如无生于行诸行无生生行不生不生无行。即无生行也。佛言。善男子。汝以无生。而证无生行也。心王菩萨言。不也。何以故。如无生行。性相空寂。无见无闻无得无失无言无说无知无相无取无舍。云何取证。若取证者。即为诤论。无诤无论。乃无生行。佛言。汝得阿耨多罗三藐三菩提也。心王菩萨言。尊者。我无得阿耨多罗三藐三菩提。何以故。菩提性中无得无失无觉无知无分别相。无分别中即清净性。性无间杂。无有言说。非有非无。非知非不知。诸可法行亦复如是。何以故。一切法行。不见处所决定性故。本无有得不得。云何得阿耨多罗三藐三菩提。佛言。如是如是。如汝所言。一切心行。不过无相体寂无生。可有诸识亦复如是。何以故。眼眼触悉皆空寂。识亦空寂。无有动不动相。内无三受。三受寂灭。耳鼻舌身心意。意识及以末那阿梨耶识亦复如是。皆亦不生。寂灭之心及无生心。若生寂灭心。若生无生心。是有生行。非无生行。菩萨内生三受三行三戒。若已寂灭生心不生。心常寂灭无功无用。不证寂灭相。亦不住于无证。可处无住总持无相。则无三受三行三戒。悉皆寂灭清净无住。不入三昧。不住坐禅。无生无行。心王菩萨言。禅能摄动。定诸幻乱。云何不禅。佛言。菩萨禅即是动。不动不禅是无生禅。禅性无生。离生禅相。禅性无住。离住禅动。若知禅性无有动静。即得无生。无生般若。亦不依住。心亦不动。以是智故。故得无生般若波罗蜜。心王菩萨言。尊者。无生般若。于一切处。无住于一切处。无离心无住处。无处住心。无住无心。心无生住。如此住心。即无生住。尊者。心无生住不可思议。不思议中可不可说。佛言。如是如是。心王菩萨闻如是言。叹未曾有。而说偈言

  满足大智尊　　广说无生法
  闻所未曾闻　　未说而今说
  犹如净甘露　　时时乃一出
  难遇难思议　　闻者亦复难
  无上良福田　　最上胜妙药
  为度众生故　　而今说宣说

尔时众中闻说此已。皆得无生无生般若

    金刚三昧经本觉利品第四

尔时无住菩萨闻佛所说一味真实不可思议。从远近来。亲如来座专念谛听。入清白处。身心不动。尔时佛告无住菩萨言。汝从何来今至何所。无住菩萨言。尊者。我从无本来。今至无本所。佛言。汝本不从来。今本不至所。汝得本利不可思议。是大菩萨摩诃萨。即放大光遍照千界。而说偈言

  大哉菩萨　　智慧满足　　常以本利
  利益众生　　于四威仪　　常住本利
  导诸群庶　　不来不去

尔时无住菩萨而白佛言。尊者。以何利转。而转众生一切情识。入庵摩罗。佛言。诸佛如来常以一觉而转诸识。入庵摩罗。何以故。一切众生本觉。常以一觉觉诸众生。令彼众生皆得本觉。觉诸情识空寂无生。何以故。决定本性本无有动。无住菩萨言。可一八识。皆缘境起如何不动。佛言。一切境本空。一切识本空。空无缘性。如何缘起。无住菩萨言。一切境空。如何有见。佛言。见即为妄。何以故。一切万有。无生无相。本不自名。悉皆空寂。一切法相亦复如是。一切众生身亦如是。身尚不有。云何有见。无住菩萨言。一切境空。一切身空。一切识空觉亦应空。佛言。可一觉者。不毁不坏。决定性故。非空非不空。无空不空。无住菩萨言。诸境亦然。非空相非无空相。佛言。如是。彼可境者。性本决定。决定性根。无有处所。无住菩萨言。觉亦如是。无有处所。佛言。如是。觉无处故清净。清净无觉。物无处故清净。清净无色。无住菩萨言。心眼识亦复如是。不可思议。佛言。心眼识亦复如是。不可思议。何以故。色无处所。清净无名。不入于内。眼无处所。清净无见。不出于外。心无处所。清净无止。无有起处。识无处所。清净无动。无有缘别。性皆空寂。性无有觉。觉则为觉。善男子。觉知无觉。诸识则入。何以故。金刚智地解脱道断。断已入无住地。无有出入。心处无在决定性地。其地清净如净琉璃。性常平等如彼大地。觉妙观察如慧日光。利成得本如大法雨。入是智者。是入佛智地。入智地者。诸识不生。无住菩萨言。如来所说。一觉圣力。四弘智地。即一切众生本根觉利。何以故。一切众生即此身中本来满足。佛言。如是。何以故。一切众生。本来无漏。诸善利本。今有欲刺。为未降伏。无住菩萨言。若有众生未得本利。犹有采集。云何降伏难伏。佛言。若集若独行。分别及以染。回神住空窟。降伏难调伏。解脱魔所缚。超然露地坐。识阴般涅槃。无住菩萨言。心得涅槃独一无伴。常住涅槃。应当解脱。佛言。常住涅槃。是涅槃缚。何以故。涅槃本觉利。利本觉涅槃。涅槃觉分即本觉分。觉性不异涅槃无异。觉本无生涅槃无生。觉本无灭涅槃无灭。涅槃觉本无异故。无得涅槃。涅槃无得。云何有住。善男子。觉者不住涅槃。何以故。觉本无生。离众生垢。觉本无寂。离涅槃动。住如是地心无所住。无有出入。入庵摩罗识。无住菩萨言。庵摩罗识。是有入处。处有所得。是得法也。佛言。不也。何以故。譬如迷子。手执金钱。而不知有。游行十方。经五十年。贫穷困苦。专事求索。而以养身。而不充足。其父见子有如是事。而谓子言。汝执金钱何不取用。随意所须皆得充足。其子醒已。而得金钱。心大欢喜。而谓得钱。其父谓言。迷子汝勿欣怿。所得金钱是汝本物。汝非有得。云何可喜。善男子。庵摩罗者亦复如是。本无出相今即非入。昔迷故非无。今觉故非入。无住菩萨言。彼父知其子迷。云何经五十年。十方游历。贫穷困苦。方始告言。佛言。经五十年者。一念心动。十方游历。远行遍计。无住菩萨言。云何一念心动。佛言。一念心动五阴俱生。五阴生中具五十恶。无住菩萨言。远行遍计游历十方一念心生。具五十恶。云何令彼众生无生一念。佛言。令彼众生安坐心神。住金刚地静念无起。心常安泰即无一念。无住菩萨言。不可思议觉念不生。其心安泰即本觉利。利无有动常在不无。无有不无。不无不觉。觉知无觉。本利本觉。觉者清净无染无著。不变不易决定性故。不可思议。佛言。如是。无住菩萨闻是语已。得未曾有。而说偈言

  尊者大觉尊　　说生无念法
  无念无生心　　心常生不灭
  一觉本觉利　　利诸本觉者
  如彼得金钱　　所得即非得

尔时大众闻说是语。皆得本觉利般若波罗蜜

    金刚三昧经入实际品第五

于是如来作如是言。诸菩萨等本利深入可度众生。若后非时。应如说法时说利。不但顺不顺说。非同非异。相应如说。引诸情智。流入萨婆若海。无令可众挹彼虚风。悉令彼庶一味神乳。世间非世间。住非住处。五空出入无有取舍。何以故。诸法空相。性非有无。非无不无。不无不有。无决定性。不住有无。非彼有无。凡圣之智。而能测隐。诸菩萨等若知是利。即得菩提。尔时众中有一菩萨。名曰大力。即从座起。前白佛言。尊者。如佛所说。五空出入无有取舍。云何五空而不取舍。佛言。菩萨五空者。三有是空。六道影是空。法相是空。名相是空。心识义是空。菩萨如是等空。空不住空。空无空相。无相之法。有何取舍。入无取地。则入三空。大力菩萨言。云何三空。佛言。三空者。空相亦空。空空亦空。所空亦空。如是等空。不住三相。不无真实。文言道断。不可思议。大力菩萨言。不无真实。是相应有。佛言。无不住无。有不住有。不无不有。不有之法。不即住无。不无之相。不即住有。非以有无而诠得理菩萨。无名义相。不可思议。何以故。无名之名。不无于名。无义之义。不无于义。大力菩萨言。如是名义。真实如相。如来如相。如不住如。如无如相。相无如故。非不如来。众生心相。相亦如来。众生之心。应无别境。佛言。如是。众生之心。实无别境。何以故。心本净故。理无秽故。以染尘故。名为三界。三界之心。名为别境。是境虚妄。从心化生。心若无妄。即无别境。大力菩萨言。心若在净。诸境不生。此心净时。应无三界。佛言。如是。菩萨心不生境。境不生心。何以故。所见诸境唯所见心。心不幻化则无所见。菩萨内无众生。三性空寂。则无己众。亦无他众。乃至二入。亦不生心。得如是利。则无三界。大力菩萨言。云何二入不生于心。心本不生云何有入。佛言。二入者。一谓理入。二谓行入。理入者深信众生不异真性。不一不共。但以客尘之所翳障。不去不来。凝住觉观。谛观佛性。不有不无。无己无他。凡圣不二。金刚心地。坚住不移。寂静无为。无有分别。是名理入。行入者心不倾倚。影无流易。于所有处。静念无求。风鼓不动。犹如大地。捐离心我。救度众生。无生无相。不取不舍。菩萨心无出入。无出入心。入不入故。故名为入。菩萨如是入法。法相不空。不空之法。法不虚弃。何以故。不无之法。具足功德。非心非影。法尔清净。大力菩萨言。云何非心非影法尔清净。佛言。空如之法。非心识法。非心使所有。法非空相。法非色相。法非心有。为不相应法。非心无为。是相应法。非所现影。非所显示。非自性。非差别。非名非相非义。何以故。义无如故。无如之法。亦无无如。无有无如。非无如有。何以故。根理之法。非理非根。离诸诤论。不见其相。菩萨如是净法。非生之所生生。非灭之所灭灭。大力菩萨言。不可思议。如是法相。不合成不独成。不羁不绊。不聚不散。不生不灭。亦无来相及以去住。不可思议。佛言。如是。不可思议。不思议心。心亦如是。何以故。如不异心。心本如故。众生佛性。不一不异。众生之性。本无生灭。生灭之性。性本涅槃。性相本如。如无动故。一切法相。从缘无起。起相性如。如无所动。因缘性相。相本空无。缘缘空空。无有缘起。一切缘法。惑心妄见。现本不生。缘本无故。心如法理。自体空无。如彼空王。本无住处。凡夫之心。妄分别见。如如之相。本不有无。有无之相。见唯心识。菩萨如是心法。不无自体。自体不有。不有不无。菩萨无不无相。非言说地。何以故。真如之法。虚旷无相。非二乘所及。虚空境界。内外不测。六行之士。乃能知之。大力菩萨言。云何六行。愿为说之。佛言。一者十信行。二者十住行。三者十行行。四者十回向行。五者十地行。六者等觉行。如是行者。乃能知之。大力菩萨言。实际觉利无有出入。何等法心得入实际。佛言。实际之法。法无有际。无际之心。则入实际。大力菩萨言。无际心智。其智无崖。无崖之心。心得自在。自在之智。得入实际。如彼凡夫。软心众生。其心多喘以何法御。令得坚心。得入实际。佛言。菩萨彼心喘者。以内外使。随使流注。滴沥成海。大风鼓浪。大龙惊骇。惊骇之心。故令多喘。菩萨令彼众生存三守一入如来禅。以禅定故。心则无喘。大力菩萨言。何谓存三守一入如来禅。佛言。存三者。存三解脱。守一者守一心如。入如来禅者理观心净如。入如是心地。即入实际。大力菩萨言。三解脱法是何等事。理观三昧。从何法入。佛言。三解脱者虚空解脱。金刚解脱。般若解脱。理观者心如理净无可不心。大力菩萨言。云何存用。云何观之。佛言。心事不二。是名存用。内行外行。出入不二。不住一相。心无得失。一不一地。净心流入。是名观之。菩萨如是之人。不在二相。虽不出家。不住在家。虽无法服。而不具持波罗提木叉戒。不入布萨。能以自心无为自恣。而获圣果。不住二乘入菩萨道。后当满地成佛菩提。大力菩萨言。不可思议。如是之人。非出家非不出家。何以故。入涅槃宅。着如来衣。坐菩提座。如是之人。乃至沙门宜应敬养。佛言。如是。何以故。入涅槃宅。心越三界。着如来衣。入法空处。坐菩提座。登正觉地。如是之人心超二我。何况沙门而不敬养。大力菩萨言。如彼一地及与空海。二乘之人为不见也。佛言。如是。彼二乘人。味着三昧。得三昧身于彼空海一地。如得酒病惛醉不醒。乃至数劫犹不得觉。酒消始悟方修是行。后得佛身。如彼人者。从舍阐提。即入六行。于行地所。一念净心。决定明白。金刚智力。阿鞞跋致。度脱众生。慈悲无尽。大力菩萨言。如是之人应不持戒。于彼沙门应不敬仰。佛言。为说戒者。不善慢故。海波浪故。如彼心地。八识海澄。九识流净。风不能动。波浪不起。戒性等空。持者迷倒。如彼之人。七六不生诸集。灭定不离三佛。而发菩提。三无相中。顺心玄入。深敬三宝。不失威仪。于彼沙门不无恭敬。菩萨彼仁者。不住世间动不动法。入三空聚灭三有心。大力菩萨言。彼仁者。于果足满德佛。如来藏佛。形像佛。如是佛所。发菩提心。入三聚戒。不住其相。灭三界心。不居寂地。不舍可众。入不调地不可思议。尔时舍利弗从座而起。前说偈言

  具足波若海　　不住涅槃城
  如彼妙莲华　　高原非所出
  诸佛无量劫　　不舍诸烦恼
  度世然后得　　如泥华所出
  如彼六行地　　菩萨之所修
  如彼三空聚　　菩提之真道
  我今住不住　　如佛之所说
  来所还复来　　具足然后出
  复令诸众生　　如我一无二
  前来后来者　　悉令登正觉

尔时佛告舍利弗言。不可思议。汝当于后成菩提道。无量众生超生死苦海。尔时大众皆悟菩提。诸小众等入五空海

    金刚三昧经真性空品第六

尔时舍利弗而白佛言。尊者。修菩萨道。无有名相。三戒无仪。云何摄受为众生说。愿佛慈悲为我宣说。佛言。善男子。汝今谛听。为汝宣说。善男子。善不善法。从心化生。一切境界。意言分别。制之一处。众缘断灭。何以故。善男子。一本不起。三用无施。住于如理。六道门杜。四缘如顺。三戒具足。舍利弗言。云何四缘如顺三戒具足。佛言。四缘者。一谓作择灭力取缘摄律仪戒。二谓本利净根力所集起缘摄善法戒。三谓本慧大悲力缘摄众生戒。四谓一觉通智力缘顺于如住。是谓四缘。善男子。如是四大缘力。不住事相。不无功用。离于一处。则不可求。善男子。如是一事通摄六行。是佛菩提萨婆若海。舍利弗言。不住事相不无功用。是法真空常乐我净。超于二我。大般涅槃。其心不系。是大力观。是观觉中。应具三十七道品法。佛言。如是。具三十七道品法。何以故。四念处。四正勤。四如意足。五根。五力。七觉分。八正道等。多名一义。不一不异。以名数故。但名但字。法不可得。不得之法一义无文。无文相义。真实空性。空性之义如实如如。如如之理具一切法。善男子。住如理者。过三苦海。舍利弗言。一切万法。皆悉言文。言文之相。即非为义。如实之义。不可言议。今者如来云何说法。佛言。我说法者。以汝众生在生说故。说不可说。是故说之。我所说者。义语非文。众生说者。文语非义。非义语者。皆悉空无。空无之言。无言于义。不言义者。皆是妄语。如义语者。实空不空。空实不实。离于二相。中间不中。不中之法离于三相。不见处所。如如如说。如无无有。无有于无。如无有无。有无于有。如有无不在。说不在说故。不在于如。如不有如。不无如说。舍利弗言。一切众生。从一阐提。阐提之心。住何等位。得至如来如来实相。佛言。从阐提心。乃至如来如来实相。住五等位。一者信位。信此身中。真如种子为妄所翳。舍离妄心。净心清白。知诸境界意言分别。二者思位。思者。观诸境界。唯是意言。意言分别随意显现。所见境界非我本识。知此本识非法非义非所取非能取。三者修位。修者。常起能起。起修同时。先以智导。排诸障难。出离盖缠。四者行位。行者。离诸行地。心无取舍。极净根利。不动心如。决定实性。大般涅槃。唯性空大。五者舍位。舍者。不住性空。正智流易。大悲如相。相不住如。三藐三菩提。虚心不证。心无边际。不见处所。是至如来。善男子。五位一觉从本利入。若化众生从其本处。舍利弗言。云何从其本处。佛言。本来无本。处于无处。空际入实。发菩提心。而满成圣道。何以故。善男子。如手执彼空。不得非不得。舍利弗言。如尊所说。在事之先。取以本利。是念寂灭。寂灭是如。总持诸德。该罗万法。圆融不二。不可思议。当知是法。即是摩诃般若波罗蜜。是大神咒。是大明咒。是无上咒。是无等等咒。佛言。如是如是。真如空性。性空智火。烧灭诸结。平等平等。等觉三地。妙觉三身。于九识中皎然明净。无有诸影。善男子。是法非因非缘。智自用故。非动非静。用性空故。义非有无。空相空故。善男子。若化众生。令彼众生观入是义。入是义者是见如来。舍利弗言。如来义观不住诸流。应离四禅而超有顶。佛言。如是。何以故。一切法名数。四禅亦如是。若见如来者。如来心自在。常在灭尽处。不出亦不入。内外平等故。善男子。如彼诸禅观。皆为想空定。是如非复彼。何以故。以如观如。实不见观。如相诸相。相已寂灭。寂灭即如义。如彼想禅定。是动非是禅。何以故。禅性离诸动。非染非所染。非法非影。离诸分别。本利义故。善男子。如是观定。乃名为禅。舍利弗言。不可思议。如来常以如实而化众生如是实义。多文广义。利根众生乃可修之。钝根众生难以措意。云何方便令彼钝根得入是谛。佛言。令彼钝根受持一四句偈。即入实谛。一切佛法。摄在一四偈中。舍利弗言。云何一四句偈。愿为说之。于是尊者。而说偈言

  因缘所生义　　是义灭非生
  灭诸生灭义　　是义生非灭

尔时大众。闻说是偈。佥大欢喜。皆得灭生灭。生般若性空智海

    金刚三昧经如来藏品第七

尔时梵行长者从本际起。而白佛言。尊者。生义不灭灭义不生。如是如义即佛菩提。菩提之性则无分别。无分别智分别无穷。无穷之相唯分别灭。如是义相不可思议。不思议中乃无分别。尊者。一切法数无量无边。无边法相一实义性唯住一性。其事云何。佛言。长者。不可思议我说诸法。为迷者故。方便导故。一切法相一实义智。何以故。譬如一市开四大门。是四门中皆归一市。如彼众庶随意所入。种种法味亦复如是。梵行长者言。法若如是。我住一味。应摄一切诸味。佛言。如是如是。何以故。一味实义如一大海。一切众流无有不入。长者。一切法味犹彼众流。名数虽殊其水不异。若住大海则括众流。住于一味则摄诸味。梵行长者言。诸法一味。云何三乘道。其智有异。佛言。长者。譬如江河淮海。大小异故。深浅殊故。名文别故。水在江中名为江水。水在淮中名为淮水。水在河中名为河水。俱在海中唯名海水。法亦如是。俱在真如。唯名佛道。长者。住一佛道。即达三行。梵行长者言。云何三行。佛言。一随事取行。二随识取行。三随如取行。长者。如是三行总摄众门。一切法门无不此入。入是行者。不生空相。如是入者。可谓入如来藏。入如来藏者。入不入故。梵行长者言。不可思议。入如来藏。如苗成实。无有入处。本根利力。利成得本。得本实际。其智几何。佛言。其智无穷。略而言之。其智有四。何者为四。一者定智。所谓随如。二者不定智。所谓方便破病。三者涅槃智。所谓除电觉际。四者究竟智。所谓入实具足佛道。长者。如是四大事用。过去诸佛所说。是大桥梁。是大津济。若化众生。应用是智。长者。用是大用。复有三大事。一者于三三昧内外不相夺。二者于大义科随道择灭。三者于如慧定以悲俱利。如是三事。成就菩提。不行是事。则不能流入彼四智海。为诸大魔所得其便。长者。汝等大众。乃至成佛。常当修习勿令暂失。梵行长者言。云何三三昧。佛言。三三昧者。所谓空三昧无相三昧无作三昧。如是三昧。梵行长者言。云何于大义科。佛言。大谓四大。义谓阴界入等。科谓本识。是谓于大义科。梵行长者言。不可思议。如是智事。自利利人。过三界地。不住涅槃。入菩萨道。如是法相是生灭法。以分别故。若离分别。法应不灭。尔时如来欲宣此义。而说偈言

  法从分别生　　还从分别灭
  灭诸分别法　　是法非生灭

尔时梵行长者闻说是偈。心大欣怿。欲宣其义。而说偈言

  诸法本寂灭　　寂灭亦无生
  是诸生灭法　　是法非无生
  彼则不共此　　为有断常故
  此则离于二　　亦不在一住
  若说法有一　　是相如毛轮
  如焰水迷倒　　为诸虚妄故
  若见于法无　　是法同于空
  如盲无目倒　　说法如龟毛
  我今闻佛说　　知法非二见
  亦不依中住　　故从无住取
  如来所说法　　悉从于无住
  我从无住处　　是处礼如来
  敬礼如来相　　等空不动智
  不着无处所　　敬礼无住身
  我于一切处　　常见诸如来
  唯愿诸如来　　为我说常法

尔时如来而作是言。诸善男子。汝等谛听。为汝众等说于常法。善男子。常法非常法。非说亦非字。非谛非解脱。非无非境界。离诸妄断际。是法非无常。离诸常断见。了见识为常。是识常寂灭。寂灭亦寂灭。善男子。知法寂灭者。不寂灭心。心常寂灭。得寂灭者。心常真观知诸名色。唯是痴心。痴心分别。分别诸法。更无异事出于名色。知法如是不随文语。心心于义不分别我。知我假名即得寂灭。若得寂灭。即得阿耨多罗三藐三菩提。尔时长者梵行闻说是语。而说偈言

  名相分别事　　及法名为三
  真如正妙智　　及彼成于五
  我今知是法　　断常之所系
  入于生灭道　　是断非是常
  如来说空法　　远离于断常
  因缘无不生　　不生故不灭
  因缘执为有　　如采空中华
  犹取石女子　　毕竟不可得
  离诸因缘取　　亦不从他灭
  及于己义大　　依如故得实
  是故真如法　　常自在如如
  一切诸万法　　非如识所化
  离识法即空　　故从空处说
  灭诸生灭法　　而住于涅槃
  大悲之所夺　　涅槃灭不住
  转所取能取　　入于如来藏

尔时大众闻说是义。皆得正命。入于如来如来藏海

    金刚三昧经总持品第八

尔时地藏菩萨从众中起至于佛前。合掌胡跪而白佛言。尊者。我观大众心有疑事。犹未得决。今者如来欲为除疑。我今为众随疑所问。愿佛慈悲垂哀听许。佛言。菩萨摩诃萨。汝能如是救度众生。是大悲愍不可思议。汝当广问。为汝宣说。地藏菩萨言。一切诸法云何不缘生。尔时如来欲宣此义。而说偈言

  若法缘所生　　离缘可无法
  云何法性无　　而缘可生法

尔时地藏菩萨言。法若无生云何说法法从心生。于是尊者。而说偈言

  是心所生法　　是法能所取
  如醉眼空华　　是法然非彼

尔时地藏菩萨言。法若如是法则无待。无待之法法应自成。于是尊者。而说偈言

  法本无有无　　自他亦复尔
  不始亦不终　　成败则不住

尔时地藏菩萨言。一切诸法相即本涅槃。涅槃及空相亦如是。无是等法。是法应如。佛言。无如是法。是法是如。地藏菩萨言。不可思议。如是如相。非共不共。意取业取。即皆空寂。空寂心法。俱不可取。亦应寂灭。于是尊者。而说偈言

  一切空寂法　　是法寂不空
  彼心不空时　　是得心不有

尔时地藏菩萨言。是法非三谛。色空心亦灭。是法本灭时。是法应是灭。于是尊者。而说偈言

  法本无自性　　由彼之所生
  不于如是处　　而有彼如是

尔时地藏菩萨言。一切诸法无生无灭。云何不一。于是尊者。而说偈言

  法住处无在　　相数空故无
  名说二与法　　是则能所取

尔时地藏菩萨言。一切诸法相。不住于二岸。亦不住中流。心识亦如是。云何诸境界。从识之所生。若识能有生。是识亦从生。云何无生识。能生有所生。于是尊者。而说偈言

  所生能生二　　是二能所缘
  俱本各自无　　取有空华幻
  识生于未时　　境不是时生
  于境生未时　　是时识亦灭
  彼即本俱无　　亦不有无有
  无生识亦无　　云何境从有

尔时地藏菩萨言。法相如是内外俱空。境智二众本来寂灭。如来所说实相。真空如是之法即非集也。佛言。如是。如实之法。无色无住。非所集。非能集。非义非大。一本利法。深功德聚。地藏菩萨言。不可思议。不思议聚。七五不生。八六寂灭。九相空无。有空无有。无空无有。如尊者所说法义皆空。入空无行不失诸业。无我我所。能所身见。内外结使。悉皆寂静故愿亦息。如是理观。慧定真如。尊者常说。寔如空法。即良药也。佛言。如是。何以故。法性空故。空性无生心常无生。空性无灭。心常无灭。空性无住心亦无住。空性无为心亦无为。空无出入离诸得失。界阴入等皆悉亦无。心如不着。亦复如是。菩萨。我说空法破诸有故。地藏菩萨言。尊者。知有非实如阳焰水。知实非无如火性生。如是观者是人智也。佛言。如是。何以故。是人真观。观一寂灭。相与不相。等以空取空以修空故。不失见佛。以见佛故不顺三流。于大乘中。三解脱道一体无性。以其无性故空。空故无相。无相故无作。无作故无求。无求故无愿。无愿故以是知业故须净心。以心净故便得见佛。以见佛故当生净土。菩萨。于是深法。三化勤修。慧定圆成。即超三界。地藏菩萨言。如来所说。无生无灭。即是无常。灭是生灭。生灭灭已。寂灭为常。常故不断。是不断法。离诸三界。动不动法。于有为法。如避火坑。依何等法而自呵责。入彼一门。佛言。菩萨。于三大事呵责其心。于三大谛而入其行。地藏菩萨言。云何三事而责其心。云何三谛而入一行。佛言。三大事者。一谓因。二谓果。三谓识。如是三事。从本空无。非我真我。云何于是而生爱染。观是三事。为系所缚飘流苦海。以如是事。常自呵责。三大谛者。一谓菩提之道。是平等谛。非不平等谛。二谓大觉正智得谛。非邪智得谛。三谓慧定无异行入谛。非杂行入谛。以是三谛而修佛道。是人于是法。无不得正觉。得正觉智。流大极慈。己他俱利。成佛菩提地藏菩萨言。尊者。如是之法。则无因缘。若无缘法。因则不起。云何不动法入如来

尔时如来欲宣此义。而说偈言

  一切诸法相　　性空无不动
  是法于是时　　不于是时起
  法无有异时　　不于异时起
  法无动不动　　性空故寂灭
  性空寂灭时　　是法是时现
  离相故寂住　　寂住故不缘
  是诸缘起法　　是法缘不生
  因缘生灭无　　生灭性空寂
  缘性能所缘　　是缘本缘起
  故法起非缘　　缘无起亦尔
  因缘所生法　　是法是因缘
  因缘生灭相　　彼则无生灭
  彼如真实相　　本不于出没
  诸法于是时　　自生于出没
  是故极净本　　本不因众力
  即于后得处　　得彼于本得

尔时地藏菩萨闻佛所说心地快然。时诸众等无有疑者。知众心已。而说偈言

  我知众心疑　　所以殷固问
  如来大慈善　　分别无有余
  是诸二众等　　皆悉得明了
  我今于了处　　普化诸众生
  如来之大悲　　不舍于本愿
  故于一子地　　而住于烦恼

尔时如来而告众言。是菩萨者不可思议。恒以大慈拔众生苦。若有众生。持是经法。持是菩萨名者。即不堕于恶趣。一切障难皆悉除灭。若有众生。无余杂念。专念是经如法修习

尔时菩萨。常作化身而为说法。拥护是人终不暂舍。令是人等速得阿耨多罗三藐三菩提。汝等菩萨。若化众生。皆令修习如是大乘决定了义

尔时阿难从座而起前白佛言。如来所说大乘福聚。决定断结。无生觉利不可思议。如是之法。名为何经。受持是经得几所福。愿佛慈悲。为我宣说。佛言。善男子。是经名者不可思议。过去诸佛之所护念能入如来一切智海。若有众生持是经者。则于一切经中无所悕求。是经典法。总持众法。摄诸经要。是诸经法。法之系宗。是经名者。名摄大乘经。又名金刚三昧。又名无量义宗。若有人受持是经典者。即名受持百千诸佛如是功德。譬如虚空无有边际不可思议。我所嘱累唯是经典。阿难言。云何心行云何人者。受持是经。佛言。善男子。受持是经者。是人心无得失。常修梵行。若於戏论。常乐静心。入于聚落。心常在定。若处居家。不着三有。是人现世。有五种福。一者众所尊敬。二者身不横夭。三者辩答邪论。四者乐度众生。五者能入圣道。如是人者受持是经。阿难言。如彼人者。度诸众生。得受供养不。佛言。如是人者。能为众生作大福田。常行大智。权实俱演。是四依僧。于诸供养。乃至头目髓脑。亦皆得受。何况衣食而不得受。善男子。如是人者。是汝知识。是汝桥梁。何况凡夫而不供养。阿难言。于彼人所。受持是经。供养是人。得几所福。佛言。若复有人。持以满城金银而以布施。不如于是人所。受持是经一四句偈。供养是人不可思议。善男子。令诸众生持是经者。心常在定不失本心。若失本心当即忏悔。忏悔之法是为清凉。阿难言。忏悔先罪不入于过去也

佛言如是。犹如暗室。若遇明灯。暗即灭矣。善男子。无说悔先。所有诸罪。而以为说入于过去。阿难言。云何名为忏悔。佛言。依此经教入真实观。一入观时诸罪悉灭。离诸恶趣当生净土速成阿耨多罗三藐三菩提。佛说是经已。尔时阿难。及诸菩萨。四部大众。皆大欢喜。心得决定。顶礼佛足。欢喜奉行

金刚三昧经


萨昙分陀利经一卷

    No. 265 [Nos. 262(11, 12), 263(11), 264(11)]

萨昙分陀利经一卷

        失译人名今附西晋录

闻如是。佛在罗阅只耆阇崛山中。与大比丘众四万二千人俱。三慢陀颰陀文殊师利菩萨等。八万四千人。弥勒菩萨等。拔陀劫中千人。释王等。与忉利诸天不可复计。梵王。与诸梵不可复计。阿阇世王。与阎浮提人王众多不可复计。佛在四辈弟子比丘比丘尼优婆塞优婆夷中。说萨昙分陀利(汉言法华)佛说无央数偈。是时七宝浮图。涌从地出上至梵天。浮图中央。有七宝大讲堂。悬幢幡华盖。名香清洁。姝好讲堂中有金床。床上有坐佛。字抱休罗兰。(汉言大宝)叹释迦文佛言。善哉善哉。我般泥洹已来过恒边沙劫。恒边沙佛刹。止于空中。恒边沙佛以过去。我历尔所劫。初不还彼刹。我见释迦文佛。精进求佛道。用人民故。布施无厌足。不惜手不惜眼不惜头。不惜妻子象马车乘。不惜珍宝。无有贪爱心。我故来出。欲供养释迦文佛并度诸下劣。愿释迦文佛坐我金床。更说萨昙分陀利经。于是释迦文佛。上讲堂就于金床而坐便说萨昙分陀利经。复说无央数偈言

  闻乐宝佛　　知名字者　　不畏生死
  不复勤苦　　闻药王佛　　知字名者
  不得愈病　　自识宿命

于是释迦文佛。说无央数阿僧祇劫。复说无央数阿僧祇劫。我行菩萨道时。求索萨昙分陀利经。布施与人。在所求索。饭食衣被七宝妻子。初无爱恋心。我为有国王时。是世极长寿。我便立太子。为王弃国事。挝鼓摇铃自炫身言。谁欲持我作奴者。我求索萨昙分陀利经。我欲行供养。时有一婆罗门语我言。与我作奴来。我有萨昙分陀利经。我便随婆罗门去一心作奴。汲水扫地采花果。饮食婆罗门。千岁不懈息。佛于是说偈言

  挝鼓摇铃愿　　自炫言谁欲
  持我作奴者　　我欲行供养
  奴心善意行

佛言。是时王者。我身是也。时婆罗门者。调达是。谁恩令我得满六波罗蜜者。三十二相八十种好。皆是调达福恩。调达是我善师。善师恩令我得满六波罗蜜。三十二相八十种好。威神尊贵度脱十方。一切皆是调达恩。调达却后阿僧祇劫。当得作佛。号名提和罗耶(汉言天王佛)当得十种力三十二相八十种好。天王佛国。名提和越(汉言天地国)天王佛。当为人民说法。尽劫不懈止。第一说法。当度恒边沙人得罗汉道。恒边沙人辟支佛道。恒边沙人发阿耨多罗三藐三菩提心。尔时天王佛寿二十劫。乃般泥洹后。法住二十劫。天王佛般泥洹后。不散舍利。起作一七宝塔。广六十里。长八十里。一切阎浮人。悉往供养佛舍利。是时无央数人得罗汉道。无央数人发辟支佛心。无央数人发阿耨多罗三藐三菩提心。善男子善女人。闻是法华之经。信不诽谤。除灭过去当来罪。闭三恶道门。开三善道门。生天上常第一。生人中常第一。生十方佛前。自然七宝莲华中化生

于是下方佛所从菩萨。名般若拘。自白其佛。早还本土。释迦文佛谓般若拘。我有菩萨。字文殊师利。可与相见乃还本土。即时文殊师利。从沙曷龙王池中涌出。坐大莲华。华如车轮。其华千叶。从诸菩萨其数甚多。文殊师利下大莲华。为二佛作礼。还与般若拘菩萨相问讯。般若拘问文殊。所入池中度云何数多少。文殊答曰。其数甚多无能计者。若当口说非心所信。自当有证。其池即时涌华从下而出。尽是池中一切所散。本发菩萨心者。其华在空中。但说摩诃衍事。本发声闻者。其华在空中。但说断生死事。文殊师利见华如是。以偈答般若拘菩萨言。以仁者之意。自分别其数。般若拘菩萨复问文殊师利。说何等法所度乃尔。文殊答曰。于是池中。但说萨昙分陀利。般若拘复问。其法甚尊无能及者。为有便可得佛者不。文殊答曰。沙曷龙王有女年八岁。智慧甚大意愿不轻。便可得佛。般若拘菩萨谓文殊师利言。我见仁者之师。求佛勤苦积累功德。劫数甚多。不信此女便可得佛。池中有女即时涌出绕佛三匝叉手而白佛言。佛相好端正功德巍巍。为诸天所奉。为一切龙鬼神人民萨和萨所敬。所说法甚尊。今我立愿。便欲得佛。舍利弗即谓女。虽发是愿佛不可得。又汝女。行积功累。行未应菩萨。女自持一摩尼珠。其价当一大国。女疾过与佛。佛亦疾受。女谓舍利弗及般若拘菩萨。我与佛珠为迟疾。答曰。甚疾。女复言。佛受我珠为迟疾。答曰。甚疾。女言。我与佛珠为迟。佛受我珠复迟。我今取佛疾。于是即时女身变为菩萨众会皆惊。即变为佛身。相种好皆具足。国土弟子如佛所为。一切众会天龙鬼神无央数人。皆发无上正真道意。三千大千国土六反震动。三万须陀洹。得阿惟越致

萨昙分陀利经一卷


添品妙法莲华经序

    No. 264 [Nos. 262, 263]

    添品妙法莲华经序

        隋仁寿元年崛多笈多二法师添品

妙法莲华经者。破二明一之指归也。降神五浊。弘道三乘。权智不思。大悲难极。先设化城之迹后示系珠之本。车虽有异。雨实无差。记以正觉之名。许以真子之位。同入法性。归之于此。昔炖煌沙门竺法护。于晋武之世。译正法华。后秦姚兴。更请罗什。译妙法莲华。考验二译。定非一本。护似多罗之叶。什似龟兹之文。余捡经藏。备见二本。多罗则与正法符会。龟兹则共妙法允同。护叶尚有所遗。什文宁无其漏。而护所阙者。普门品偈也。什所阙者。药草喻品之半。富楼那及法师等二品之初。提婆达多品。普门品偈也。什又移嘱累。在药王之前。二本陀罗尼。并置普门之后。其间异同。言不能极。窃见提婆达多。及普门品偈。先贤续出。补阙流行。余景仰遗风。宪章成范。大隋仁寿元年辛酉之岁。因普曜寺沙门上行所请。遂共三藏崛多笈多二法师。于大兴善寺。重勘天竺多罗叶本。富楼那及法师等二品之初。勘本犹阙。药草喻品更益其半。提婆达多通入塔品。陀罗尼次神力之后。嘱累还结其终。字句差殊。颇亦改正。傥有披寻。幸勿疑惑。虽千万亿偈妙义难尽。而二十七品。本文且具。所愿四辩梵词。遍神州之域。一乘秘教。悟象运之机。聊记翻译。序之云尔

添品妙法莲华经卷第一

        隋天竺三藏阇那崛多共笈多译

    妙法莲华经序品第一

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。皆是阿罗汉。诸漏已尽无复烦恼。逮得己利尽诸有结。心得自在。其名曰阿若憍陈如。摩诃迦叶。优楼频螺迦叶。伽耶迦叶。那提迦叶。舍利弗。大目干连。摩诃迦旃延。阿[少/(兔-、)]楼驮。劫宾那。憍梵波提。离婆多。毕陵伽婆蹉。薄拘罗。摩诃拘絺罗。难陀。孙陀罗难陀富楼那弥多罗尼子。须菩提。阿难。罗睺罗。如是众所知识大阿罗汉等。复有学无学二千人。摩诃波阇波提比丘尼。与眷属六千人俱。罗睺罗母耶输陀罗比丘尼。亦与眷属俱。菩萨摩诃萨八万人。皆于阿耨多罗三藐三菩提不退转。皆得陀罗尼乐说辩才。转不退转法轮。供养无量百千诸佛。于诸佛所。殖众德本。常为诸佛之所称叹。以慈修身善入佛慧。通达大智到于彼岸。名称普闻无量世界。能度无数百千众生

其名曰文殊师利菩萨。观世音菩萨。得大势菩萨。常精进菩萨。不休息菩萨。宝掌菩萨。药王菩萨。勇施菩萨。宝月菩萨。月光菩萨。满月菩萨。大力菩萨。无量力菩萨。越三界菩萨。跋陀婆罗菩萨。弥勒菩萨。宝积菩萨。导师菩萨。如是等菩萨摩诃萨八万人俱

尔时释提桓因。与其眷属二万天子俱。复有名月天子。普香天子。宝光天子。四大天王。与其眷属万天子俱。自在天子大自在天子。与其眷属三万天子俱。娑婆世界主梵天王。尸弃大梵光明大梵等。与其眷属万二千天子俱。有八龙王。难陀龙王。跋难陀龙王。娑伽罗龙王。和修吉龙王。德叉迦龙王。阿那婆达多龙王。摩那斯龙王。沤钵罗龙王等。各与若干百千眷属俱。有四紧那罗王。法紧那罗王。妙法紧那罗王。大法紧那罗王。持法紧那罗王。各与若干百千眷属俱。有四乾闼婆王。乐乾闼婆王。乐音乾闼婆王。美乾闼婆王。美音乾闼婆王。各与若干百千眷属俱。有四阿修罗王。婆稚阿修罗王。佉罗骞驮阿修罗王。毗摩质多罗阿修罗王。罗睺阿修罗王。各与若干百千眷属俱。有四迦楼罗王。大威德迦楼罗王。大身迦楼罗王。大满迦楼罗王。如意迦楼罗王。各与若干百千眷属俱。韦提希子。阿阇世王。与若干百千眷属俱。各礼佛足退坐一面

尔时世尊。四众围绕供养恭敬尊重赞叹。为诸菩萨说大乘经。名无量义教菩萨法佛所护念。佛说此经已。结加趺坐入于无量义处三昧。身心不动。是时天雨曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上及诸大众。普佛世界六种振动。尔时会中。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。及诸小王转轮圣王。是诸大众得未曾有。欢喜合掌一心观佛。尔时佛放眉间白毫相光。照东方万八千世界靡不周遍。下至阿鼻地狱。上至阿迦腻吒天。于此世界。尽见彼土六趣众生。又见彼土现在诸佛。及闻诸佛所说经法。并见彼诸比丘比丘尼优婆塞优婆夷诸修行得道者。复见诸菩萨摩诃萨。种种因缘种种信解种种相貌行菩萨道。复见诸佛般涅槃者。复见诸佛般涅槃后。以佛舍利起七宝塔。尔时弥勒菩萨作是念。今者世尊现神变相。以何因缘而有此瑞。今佛世尊入于三昧。是不可思议现希有事。当以问谁。谁能答者。复作此念。是文殊师利法王之子。已曾亲近供养过去无量诸佛。必应见此希有之相。我今当问。尔时比丘比丘尼优婆塞优婆夷。及诸天龙鬼神等。咸作此念。是佛光明神通之相。今当问谁。尔时弥勒菩萨欲自决疑。又观四众比丘比丘尼优婆塞优婆夷及诸天龙鬼神等众会之心。而问文殊师利言。以何因缘。而有此瑞神通之相。放大光明照于东方万八千土。悉见彼佛国界庄严。于是弥勒菩萨。欲重宣此义。以偈问曰

  文殊师利　　导师何故　　眉间白毫
  大光普照　　雨曼陀罗　　曼殊沙华
  旃檀香风　　悦可众心　　以是因缘
  地皆严净　　而此世界　　六种震动
  时四部众　　咸皆欢喜　　身意快然
  得未曾有　　眉间光明　　照于东方
  万八千土　　皆如金色　　从阿鼻狱
  上至有顶　　诸世界中　　六道众生
  生死所趣　　善恶业缘　　受报好丑
  于此悉见　　又睹诸佛　　圣主师子
  演说经典　　微妙第一　　其声清净
  出柔软音　　教诸菩萨　　无数亿万
  梵音深妙　　令人乐闻　　各于世界
  讲说正法　　种种因缘　　以无量喻
  照明佛法　　开悟众生　　若人遭苦
  厌老病死　　为说涅槃　　尽诸苦际
  若人有福　　曾供养佛　　志求胜法
  为说缘觉　　若有佛子　　修种种行
  求无上慧　　为说净道　　文殊师利
  我住于此　　见闻若斯　　及千亿事
  如是众多　　今当略说　　我见彼土
  恒沙菩萨　　种种因缘　　而求佛道
  或有行施　　金银珊瑚　　真珠摩尼
  车磲马瑙　　金刚诸珍　　奴婢车乘
  宝饰辇舆　　欢喜布施　　回向佛道
  愿得是乘　　三界第一　　诸佛所叹
  或有菩萨　　驷马宝车　　栏楯华盖
  轩饰布施　　复见菩萨　　身肉手足
  及妻子施　　求无上道　　又见菩萨
  头目身体　　欣乐施与　　求佛智慧
  文殊师利　　我见诸王　　往诣佛所
  问无上道　　便舍乐土　　宫殿臣妾
  剃除须发　　而被法服　　或见菩萨
  而作比丘　　独处闲静　　乐诵经典
  又见菩萨　　勇猛精进　　入于深山
  思惟佛道　　又见离欲　　常处空闲
  深修禅定　　得五神通　　又见菩萨
  安禅合掌　　以千万偈　　赞诸法王
  复见菩萨　　智深志固　　能问诸佛
  闻悉受持　　又见佛子　　定慧具足
  以无量喻　　为众讲法　　欣乐说法
  化诸菩萨　　破魔兵众　　而击法鼓
  又见菩萨　　寂然宴默　　天龙恭敬
  不以为喜　　又见菩萨　　处林放光
  济地狱苦　　令入佛道　　又见佛子
  未尝睡眠　　经行林中　　勤求佛道
  又见具戒　　威仪无缺　　净如宝珠
  以求佛道　　又见佛子　　住忍辱力
  增上慢人　　恶骂捶打　　皆悉能忍
  以求佛道　　又见菩萨　　离诸戏笑
  及痴眷属　　亲近智者　　一心除乱
  摄念山林　　亿千万岁　　以求佛道
  或见菩萨　　肴膳饮食　　百种汤药
  施佛及僧　　名衣上服　　价直千万
  或无价衣　　施佛及僧　　千万亿种
  栴檀宝舍　　众妙卧具　　施佛及僧
  清净园林　　华果茂盛　　流泉浴池
  施佛及僧　　如是等施　　种种微妙
  欢喜无厌　　求无上道　　或有菩萨
  说寂灭法　　种种教诏　　无数众生
  又见菩萨　　观诸法性　　无有一相
  犹如虚空　　又见佛子　　心无所著
  以此妙慧　　求无上道　　文殊师利
  又有菩萨　　佛灭度后　　供养舍利
  又见佛子　　造诸塔庙　　无数恒沙
  严饰国界　　宝塔高妙　　五千由旬
  纵广正等　　二千由旬　　一一塔庙
  各千幢幡　　珠交露缦　　宝铃和鸣
  诸天龙神　　人及非人　　香华伎乐
  常以供养　　文殊师利　　诸佛子等
  为供舍利　　严饰塔庙　　国界自然
  殊特妙好　　如天树王　　其华开敷
  佛放一光　　我及众会　　见此国界
  种种殊妙　　诸佛神力　　智慧希有
  放一净光　　照无量国　　我等见此
  得未曾有　　佛子文殊　　愿决众疑
  四众欣仰　　瞻仁及我　　世尊何故
  放斯光明　　佛子时答　　决疑令喜
  何所饶益　　演斯光明　　佛坐道场
  所得妙法　　为欲说此　　为当授记
  示诸佛土　　众宝严净　　及见诸佛
  此非小缘　　文殊当知　　四众龙神
  瞻察仁者　　为说何等

是时文殊师利语弥勒菩萨摩诃萨及诸大士。善男子等。如我惟忖。今佛世尊。欲说大法雨大法雨吹大法螺击大法鼓演大法义。诸善男子。我于过去诸佛曾见此瑞。放斯光已即说大法。是故当知。今佛现光亦复如是。欲令众生咸得闻知一切世间难信之法。故现斯瑞。诸善男子。如过去无量无边不可思议阿僧祇劫。尔时有佛。号日月灯明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。演说正法。初善中善后善。其义深远其语巧妙。纯一无杂。具足清白梵行之相。为求声闻者。说应四谛法。度生老病死究竟涅槃。为求辟支佛者。说应十二因缘法。为诸菩萨。说应六波罗蜜。令得阿耨多罗三藐三菩提。成一切种智。次复有佛。亦名日月灯明。次复有佛。亦名日月灯明。如是二万佛。皆同一字。号日月灯明。又同一姓。姓颇罗堕。弥勒当知。初佛后佛皆同一字。名日月灯明。十号具足。所可说法初中后善。其最后佛未出家时。有八王子。一名有意。二名善意。三名无量意。四名宝意。五名增意。六名除疑意。七名响意。八名法意。是八王子。威德自在。各领四天下。是诸王子。闻父出家得阿耨多罗三藐三菩提。悉舍王位亦随出家。发大乘意常修梵行。皆为法师。已于千万佛所殖诸善本。是时日月灯明佛说大乘经。名无量义教菩萨法佛所护念。说是经已。即于大众中结加趺坐。入于无量义处三昧。身心不动。是时天雨曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上及诸大众。普佛世界六种震动。尔时会中比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。及诸小王转轮圣王等。是诸大众得未曾有。欢喜合掌一心观佛。尔时如来。放眉间白毫相光。照东方万八千佛土。靡不周遍。如今所见是诸佛土。弥勒当知。尔时会中。有二十亿菩萨。乐欲听法。是诸菩萨。见此光明普照佛土。得未曾有。欲知此光所为因缘。时有菩萨。名曰妙光。有八百弟子。是时日月灯明佛从三昧起因妙光菩萨说大乘经。名妙法莲华教菩萨法佛所护念。六十小劫不起于座。时会听者。亦坐一处六十小劫身心不动。听佛所说谓如食顷。是时众中。无有一人若身若心而生懈倦。日月灯明佛。于六十小劫说是经已。即于梵魔沙门婆罗门及天人阿修罗众中。而宣此言。如来于今日中夜。当入无余涅槃。时有菩萨。名曰德藏。日月灯明佛。即授其记告诸比丘。是德藏菩萨。次当作佛。号曰净身多陀阿伽度阿罗诃三藐三佛陀。佛授记已。便于中夜入无余涅槃。佛灭度后。妙光菩萨。持妙法莲华经。满八十小劫。为人演说。日月灯明佛八子。皆师妙光。妙光教化。令其坚固阿耨多罗三藐三菩提。是诸王子。供养无量百千万亿佛已。皆成佛道。其最后成佛者。名曰然灯。八百弟子。中有一人。号曰求名。贪着利养。虽复读诵众经。而不通利。多所忘失。故号求名。是人亦以种诸善根因缘故。得值无量百千万亿诸佛。供养恭敬尊重赞叹。弥勒当知。尔时妙光菩萨。岂异人乎。我身是也。求名菩萨。汝身是也。今见此瑞与本无异。是故惟忖。今日如来。当说大乘经。名妙法莲华教菩萨法佛所护念。尔时文殊师利。于大众中。欲重宣此义。而说偈言

  我念过去世　　无量无数劫
  有佛人中尊　　号日月灯明
  世尊演说法　　度无量众生
  无数亿菩萨　　令入佛智慧
  佛未出家时　　所生八王子
  见大圣出家　　亦随修梵行
  时佛说大乘　　经名无量义
  于诸大众中　　而为广分别
  佛说此经已　　即于法座上
  加趺坐三昧　　名无量义处
  天雨曼陀华　　天鼓自然鸣
  诸天龙鬼神　　供养人中尊
  一切诸佛土　　即时大震动
  佛放眉间光　　现诸希有事
  此光照东方　　万八千佛土
  示一切众生　　生死业报处
  又见诸佛土　　以众宝庄严
  琉璃颇梨色　　斯由佛光照
  及见诸天人　　龙神夜叉众
  乾闼紧那罗　　各供养其佛
  又见诸如来　　自然成佛道
  身色如金山　　端严甚微妙
  如净琉璃中　　内现真金像
  世尊在大众　　敷演深法义
  一一诸佛土　　声闻众无数
  因佛光所照　　悉见彼大众
  或有诸比丘　　在于山林中
  精进持净戒　　犹如护明珠
  又见诸菩萨　　行施忍辱等
  其数如恒沙　　斯由佛光照
  又见诸菩萨　　深入诸禅定
  身心寂不动　　以求无上道
  又见诸菩萨　　知法寂灭相
  各于其国土　　说法求佛道
  尔时四部众　　见日月灯佛
  现大神通力　　其心皆欢喜
  各各自相问　　是事何因缘
  天人所奉尊　　适从三昧起
  赞妙光菩萨　　汝为世间眼
  一切所归信　　能奉持法藏
  如我所说法　　惟汝能证知
  世尊既赞叹　　令妙光欢喜
  说是法华经　　满六十小劫
  不起于此座　　所说上妙法
  是妙光法师　　悉皆能受持
  佛说是法华　　令众欢喜已
  寻即于是日　　告于天人众
  诸法实相义　　已为汝等说
  我今于中夜　　当入于涅槃
  汝一心精进　　当离于放逸
  诸佛甚难值　　亿劫时一遇
  世尊诸子等　　闻佛入涅槃
  各各怀悲恼　　佛灭一何速
  圣主法之王　　安慰无量众
  我若灭度时　　汝等勿忧怖
  是德藏菩萨　　于无漏实相
  心已得通达　　其次当作佛
  号曰为净身　　亦度无量众
  佛此夜灭度　　如薪尽火灭
  分布诸舍利　　而起无量塔
  比丘比丘尼　　其数如恒沙
  倍复加精进　　以求无上道
  是妙光法师　　奉持佛法藏
  八十小劫中　　广宣法华经
  是诸八王子　　妙光所开化
  坚固无上道　　当见无数佛
  供养诸佛已　　随顺行大道
  相继得成佛　　转次而授记
  最后天中天　　号曰然灯佛
  诸仙之导师　　度脱无量众
  是妙光法师　　时有一弟子
  心常怀懈怠　　贪着于名利
  求名利无厌　　多游族姓家
  弃舍所习诵　　废忘不通利
  以是因缘故　　号之为求名
  亦行众善业　　得见无数佛
  供养于诸佛　　随顺行大道
  具六波罗蜜　　今见释师子
  其后当作佛　　号名曰弥勒
  广度诸众生　　其数无有量
  彼佛灭度后　　懈怠者汝是
  妙光法师者　　今则我身是
  我见灯明佛　　本光瑞如此
  以是知今佛　　欲说法华经
  今相如本瑞　　是诸佛方便
  今佛放光明　　助发实相义
  诸人今当知　　合掌一心待
  佛当雨法雨　　充足求道者
  诸求三乘人　　若有疑悔者
  佛当为除断　　令尽无有余

    妙法莲华经方便品第二

尔时世尊。从三昧安详而起。告舍利弗。诸佛智慧甚深无量。其智慧门难解难入。一切声闻辟支佛。所不能知。所以者何。佛曾亲近百千万亿无数诸佛。尽行诸佛无量道法。勇猛精进名称普闻。成就甚深未曾有法。随宜所说意趣难解。舍利弗。吾从成佛已来。种种因缘种种譬喻。广演言教无数方便。引导众生令离诸着。所以者何。如来方便知见波罗蜜。皆已具足。舍利弗。如来知见。广大深远。无量无碍力无所畏。禅定解脱三昧深入无际。成就一切未曾有法。舍利弗。如来能种种分别巧说诸法。言辞柔软悦可众心。舍利弗。取要言之。无量无边未曾有法。佛悉成就。止舍利弗。不须复说。所以者何。佛所成就第一希有难解之法惟佛与佛乃能究尽。诸法实相。所谓诸法。如是相如是性如是体如是力如是作如是因如是缘如是果如是报如是本末究竟等。尔时世尊。欲重宣此义。而说偈言

  世雄不可量　　诸天及世人
  一切众生类　　无能知佛者
  佛力无所畏　　解脱诸三昧
  及佛诸余法　　无能测量者
  本从无数佛　　具足行诸道
  甚深微妙法　　难见难可了
  于无量亿劫　　行此诸道已
  道场得成果　　我已悉知见
  如是大果报　　种种性相义
  我及十方佛　　乃能知是事
  是法不可示　　言辞相寂灭
  诸余众生类　　无有能得解
  除诸菩萨众　　信力坚固者
  诸佛弟子众　　曾供养诸佛
  一切漏已尽　　住是最后身
  如是诸人等　　其力所不堪
  假使满世间　　皆如舍利弗
  尽思共度量　　不能测佛智
  正使满十方　　皆如舍利弗
  及余诸弟子　　亦满十方刹
  尽思共度量　　亦复不能知
  辟支佛利智　　无漏最后身
  亦满十方界　　其数如竹林
  斯等共一心　　于亿无量劫
  欲思佛实智　　莫能知少分
  新发意菩萨　　供养无数佛
  了达诸义趣　　又能善说法
  如稻麻竹苇　　充满十方刹
  一心以妙智　　于恒河沙劫
  咸皆共思量　　不能知佛智
  不退诸菩萨　　其数如恒沙
  一心共思求　　亦复不能知
  又告舍利弗　　无漏不思议
  甚深微妙法　　我今已具得
  惟我知是相　　十方佛亦然
  舍利弗当知　　诸佛语无异
  于佛所说法　　当生大信力
  世尊法久后　　要当说真实
  告诸声闻众　　及求缘觉乘
  我令脱苦缚　　逮得涅槃者
  佛以方便力　　示以三乘教
  众生处处着　　引之令得出

尔时大众中。有诸声闻漏尽阿罗汉。阿若憍陈如等千二百人。及发声闻辟支佛心。比丘比丘尼优婆塞优婆夷。各作是念。今者世尊。何故殷勤称叹方便。而作是言。佛所得法甚深难解。有所言说意趣难知。一切声闻辟支佛。所不能及。佛说一解脱义。我等亦得此法到于涅槃。而今不知是义所趣。尔时舍利弗。知四众心疑。自亦未了。而白佛言。世尊。何因何缘。殷勤称叹诸佛第一方便。甚深微妙难解之法。我自昔来。未曾从佛闻如是说。今者四众咸皆有疑惟愿世尊。敷演斯事。世尊。何故殷勤称叹甚深微妙难解之法。尔时舍利弗。欲重宣此义。而说偈言

  慧日大圣尊　　久乃说是法
  自说得如是　　力无畏三昧
  禅定解脱等　　不可思议法
  道场所得法　　无能发问者
  我意难可测　　亦无能问者
  无问而自说　　称叹所行道
  智慧甚微妙　　诸佛之所得
  无漏诸罗汉　　及求涅槃者
  今皆堕疑网　　佛何故说是
  其求缘觉者　　比丘比丘尼
  诸天龙鬼神　　及乾闼婆等
  相视怀犹豫　　瞻仰两足尊
  是事为云何　　愿佛为解说
  于诸声闻众　　佛说我第一
  我今自于智　　疑惑不能了
  为是究竟法　　为是所行道
  佛口所生子　　合掌瞻仰待
  愿出微妙音　　时为如实说
  诸天龙神等　　其数如恒沙
  求佛诸菩萨　　大数有八万
  又诸万亿国　　转轮圣王至
  合掌以敬心　　欲闻具足道

尔时佛告舍利弗。止止不须复说。若说是事。一切世间诸天及人。皆当惊疑。舍利弗重白佛言。世尊。惟愿说之。惟愿说之。所以者何。是会无数百千万亿阿僧祇众生。曾见诸佛。诸根猛利智慧明了。闻佛所说则能敬信。尔时舍利弗。欲重宣此义。而说偈言

  法王无上尊　　惟说愿勿虑
  是会无量众　　有能敬信者

佛复止。舍利弗。若说是事。一切世间天人阿修罗。皆当惊疑。增上慢比丘将坠于大坑。尔时世尊。重说偈言

  止止不须说　　我法妙难思
  诸增上慢者　　闻必不敬信

尔时舍利弗重白佛言。世尊惟愿说之。惟愿说之。今此会中。如我等比百千万亿。世世已曾从佛受化。如此人等必能敬信。长夜安隐多所饶益。尔时舍利弗。欲重宣此义。而说偈言

  无上两足尊　　愿说第一法
  我为佛长子　　惟垂分别说
  是会无量众　　能敬信此法
  佛已曾世世　　教化如是等
  皆一心合掌　　欲听受佛语
  我等千二百　　及余求佛者
  愿为此众故　　惟垂分别说
  是等闻此法　　则生大欢喜

尔时世尊告舍利弗。汝已殷勤三请。岂得不说。汝今谛听。善思念之。吾当为汝分别解说。说此语时。会中有比丘比丘尼优婆塞优婆夷五千人等。即从座起礼佛而退。所以者何。此辈罪根深重。及增上慢。未得谓得。未证谓证。有如此失。是以不住。世尊默然而不制止。尔时佛告舍利弗。我今此众。无复枝叶。纯有贞实。舍利弗。如是增上慢人。退亦佳矣。汝今善听。当为汝说。舍利弗言。唯然世尊。愿乐欲闻。佛告舍利弗。如是妙法。诸佛如来时乃说之。如优昙钵华时一现耳。舍利弗。汝等当信。佛之所说言不虚妄。舍利弗。诸佛随宜说法意趣难解。所以者何。我以无数方便种种因缘譬喻言辞。演说诸法。是法非思量分别之所能解。惟有诸佛乃能知之。所以者何。诸佛世尊。惟以一大事因缘故出现于世。舍利弗。云何名诸佛世尊惟以一大事因缘故出现于世。诸佛世尊。欲令众生开佛知见使得清净故。出现于世。欲示众生佛知见故。出现于世。欲令众生悟佛知见故。出现于世。欲令众生入佛知见道故。出现于世。舍利弗。是为诸佛以一大事因缘故出现于世。佛告舍利弗。诸佛如来。但教化菩萨。诸有所作常为一事。惟以佛之知见示悟众生。舍利弗。如来但以一佛乘故。为众生说法。无有余乘若二若三。舍利弗。一切十方诸佛法亦如是。舍利弗。过去诸佛。以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生。从诸佛闻法究竟皆得一切种智。舍利弗。未来诸佛当出于世。亦以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从佛闻法。究竟皆得一切种智。舍利弗。现在十方无量百千万亿佛土中诸佛世尊。多所饶益安乐众生。是诸佛亦以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从佛闻法。究竟皆得一切种智。舍利弗。是诸佛但教化菩萨。欲以佛之知见示众生故。欲以佛之知见悟众生故。欲令众生入佛知见道故。舍利弗。我今亦复如是。知诸众生有种种欲深心所著。随其本性。以种种因缘譬喻言辞方便力故。而为说法。舍利弗。如此皆为得一佛乘一切种智故。舍利弗。十方世界中尚无二乘。何况有三。舍利弗。诸佛出于五浊恶世。所谓劫浊烦恼浊众生浊见浊命浊。如是舍利弗。劫浊乱时。众生垢重悭贪嫉妒。成就诸不善根故。诸佛以方便力。于一佛乘分别说三。舍利弗。若我弟子。自谓阿罗汉辟支佛者。不闻不知诸佛如来但教化菩萨事。此非佛弟子。非阿罗汉。非辟支佛。又舍利弗。是诸比丘比丘尼。自谓已得阿罗汉是最后身究竟涅槃。便不复志求阿耨多罗三藐三菩提。当知此辈。皆是增上慢人。所以者何。若有比丘实得阿罗汉。若不信此法。无有是处。除佛灭度后现前无佛。所以者何。佛灭度后。如是等经受持读诵解其义者。是人难得。若遇余佛。于此法中便得决了。舍利弗。汝等当一心信解受持佛语。诸佛如来言无虚妄。无有余乘惟一佛乘。尔时世尊。欲重宣此义。而说偈言

  比丘比丘尼　　有怀增上慢
  优婆塞我慢　　优婆夷不信
  如是四众等　　其数有五千
  不自见其过　　于戒有缺漏
  护惜其瑕疵　　是小智已出
  众中之糟糠　　佛威德故去
  斯人鲜福德　　不堪受是法
  此众无枝叶　　惟有诸贞实
  舍利弗善听　　诸佛所得法
  无量方便力　　而为众生说
  众生心所念　　种种所行道
  若干诸欲性　　先世善恶业
  佛悉知是已　　以诸缘譬喻
  言辞方便力　　令一切欢喜
  或说修多罗　　伽陀及本事
  本生未曾有　　亦说于因缘
  譬喻并祇夜　　优波提舍经
  钝根乐小法　　贪着于生死
  于诸无量佛　　不行深妙道
  众苦所恼乱　　为是说涅槃
  我设是方便　　令得入佛慧
  未曾说汝等　　当得成佛道
  所以未曾说　　说时未至故
  今正是其时　　决定说大乘
  我此九部法　　随顺众生说
  入大乘为本　　以故说是经
  有佛子心净　　柔软亦利根
  无量诸佛所　　而行深妙道
  为此诸佛子　　说是大乘经
  我记如是人　　来世成佛道
  以深心念佛　　修持净戒故
  此等闻得佛　　大喜充遍身
  佛知彼心行　　故为说大乘
  声闻若菩萨　　闻我所说法
  乃至于一偈　　皆成佛无疑
  十方佛土中　　惟有一乘法
  无二亦无三　　除佛方便说
  但以假名字　　引导于众生
  说佛智慧故　　诸佛出于世
  惟此一事实　　余二则非真
  终不以小乘　　济度于众生
  佛自住大乘　　如其所得法
  定慧力庄严　　以此度众生
  自证无上道　　大乘平等法
  若以小乘化　　乃至于一人
  我则堕悭贪　　此事为不可
  若人信归佛　　如来不欺诳
  亦无贪嫉意　　断诸法中恶
  故佛于十方　　而独无所畏
  我以相严身　　光明照世间
  无量众所尊　　为说实相印
  舍利弗当知　　我本立誓愿
  欲令一切众　　如我等无异
  如我昔所愿　　今者已满足
  化一切众生　　皆令入佛道
  若我遇众生　　尽教以佛道
  无智者错乱　　迷惑不受教
  我知此众生　　未曾修善本
  坚着于五欲　　痴爱故生恼
  以诸欲因缘　　坠堕三恶道
  轮回六趣中　　备受诸苦毒
  受胎之微形　　世世常增长
  薄德少福人　　众苦所逼迫
  入邪见稠林　　若有若无等
  依止此诸见　　具足六十二
  深着虚妄法　　坚受不可舍
  我慢自矜高　　谄曲心不实
  于千万亿劫　　不闻佛名字
  亦不闻正法　　如是人难度
  是故舍利弗　　我为设方便
  说诸尽苦道　　示之以涅槃
  我虽说涅槃　　是亦非真灭
  诸法从本来　　常自寂灭相
  佛子行道已　　来世得作佛
  我有方便力　　开示三乘法
  一切诸世尊　　皆说一乘道
  今此诸大众　　皆应除疑惑
  诸佛语无异　　惟一无二乘
  过去无数劫　　无量灭度佛
  百千万亿种　　其数不可量
  如是诸世尊　　种种缘譬喻
  无数方便力　　演说诸法相
  是诸世尊等　　皆说一乘法
  化无量众生　　令入于佛道
  又诸大圣主　　知一切世间
  天人群生类　　深心之所欲
  更以异方便　　助显第一义
  若有众生类　　值诸过去佛
  若闻法布施　　或持戒忍辱
  精进禅智等　　种种修福慧
  如是诸人等　　皆已成佛道
  诸佛灭度已　　若人善软心
  如是诸众生　　皆已成佛道
  诸佛灭度已　　供养舍利者
  起万亿种塔　　金银及颇梨
  车磲与马瑙　　玫瑰琉璃珠
  清净广严饰　　庄校于诸塔
  或有起石庙　　栴檀及沉水
  木櫁并余材　　塼瓦泥土等
  若于旷野中　　积土成佛庙
  乃至童子戏　　聚沙为佛塔
  如是诸人等　　皆已成佛道
  若人为佛故　　建立诸形像
  刻雕成众相　　皆已成佛道
  或以七宝成　　鋀石赤白铜
  白镴及铅锡　　铁木及与泥
  或以胶漆布　　严饰作佛像
  如是诸人等　　皆已成佛道
  彩画作佛像　　百福庄严相
  自作若使人　　皆已成佛道
  乃至童子戏　　若草木及笔
  或以指爪甲　　而画作佛像
  如是诸人等　　渐渐积功德
  具足大悲心　　皆已成佛道
  但化诸菩萨　　度脱无量众
  若人于塔庙　　宝像及画像
  以华香幡盖　　敬心而供养
  若使人作乐　　击鼓吹角贝
  箫笛琴箜篌　　琵琶铙铜钹
  如是众妙音　　尽持以供养
  或以欢喜心　　歌呗颂佛德
  乃至一小音　　皆已成佛道
  若人散乱心　　乃至以一华
  供养于画像　　渐见无数佛
  或有人礼拜　　或复但合掌
  乃至举一手　　或复小低头
  以此供养像　　渐见无量佛
  自成无上道　　广度无数众
  入无余涅槃　　如薪尽火灭
  若人散乱心　　入于塔庙中
  一称南无佛　　皆已成佛道
  于诸过去佛　　现在或灭度
  若有闻是法　　皆已成佛道
  未来诸世尊　　其数无有量
  是诸如来等　　亦方便说法
  一切诸如来　　以无量方便
  度脱诸众生　　入佛无漏智
  若有闻法者　　无一不成佛
  诸佛本誓愿　　我所行佛道
  普欲令众生　　亦同得此道
  未来世诸佛　　虽说百千亿
  无数诸法门　　其实为一乘
  诸佛两足尊　　知法常无性
  佛种从缘起　　是故说一乘
  是法住法位　　世间相常住
  于道场知已　　道师方便说
  天人所供养　　现在十方佛
  其数如恒沙　　出现于世间
  安隐众生故　　亦说如是法
  知第一寂灭　　以方便力故
  虽示种种道　　其实为佛乘
  知众生诸行　　深心之所念
  过去所集业　　欲性精进力
  及诸根利钝　　以种种因缘
  譬喻亦言辞　　随应方便说
  我今亦如是　　安隐众生故
  以种种法门　　宣示于佛道
  我以智慧力　　知众生性欲
  方便说诸法　　皆令得欢喜
  舍利弗当知　　我以佛眼观
  见六道众生　　贫穷无福慧
  入生死险道　　相续苦不断
  深着于五欲　　如牦牛爱尾
  以贪爱自蔽　　盲冥无所见
  不求大势佛　　及与断苦法
  深入诸邪见　　以苦欲舍苦
  为是众生故　　而起大悲心
  我始坐道场　　观树亦经行
  于三七日中　　思惟如是事
  我所得智慧　　微妙最第一
  众生诸根钝　　着乐痴所盲
  如斯之等类　　云何而可度
  尔时诸梵王　　及诸天帝释
  护世四天王　　及大自在天
  并余诸天众　　眷属百千万
  恭敬合掌礼　　请我转法轮
  我即自思惟　　若但赞佛乘
  众生没在苦　　不能信是法
  破法不信故　　坠于三恶道
  我宁不说法　　疾入于涅槃
  寻念过去佛　　所行方便力
  我今所得道　　亦应说三乘
  作是思惟时　　十方佛皆现
  梵音慰喻我　　善哉释迦文
  第一之导师　　得是无上法
  随诸一切佛　　而用方便力
  我等亦皆得　　最妙第一法
  为诸众生类　　分别说三乘
  少智乐小法　　不自信作佛
  是故以方便　　分别说诸果
  虽复说三乘　　但为教菩萨
  舍利弗当知　　我闻圣师子
  深净微妙音　　称南无诸佛
  复作如是念　　我出浊恶世
  如诸佛所说　　我亦随顺行
  思惟是事已　　即趣波罗奈
  诸法寂灭相　　不可以言宣
  以方便力故　　为五比丘说
  是名转法轮　　便有涅槃音
  及以阿罗汉　　法僧差别名
  从久远劫来　　赞示涅槃法
  生死苦永尽　　我常如是说
  舍利弗当知　　我见佛子等
  志求佛道者　　无量千万亿
  咸以恭敬心　　皆来至佛所
  曾从诸佛闻　　方便所说法
  我即作是念　　如来所以出
  为说佛慧故　　今正是其时
  舍利弗当知　　钝根小智人
  着相憍慢者　　不能信是法
  今我喜无畏　　于诸菩萨中
  正直舍方便　　但说无上道
  菩萨闻是法　　疑网皆已除
  千二百罗汉　　悉亦当作佛
  如三世诸佛　　说法之仪式
  我今亦如是　　说无分别法
  诸佛兴出世　　悬远值遇难
  正使出于世　　说是法复难
  无量无数劫　　闻是法亦难
  能听是法者　　斯人亦复难
  譬如优昙华　　一切皆爱乐
  天人所希有　　时时乃一出
  闻法欢喜赞　　乃至发一言
  则为已供养　　一切三世佛
  是人甚希有　　过于优昙华
  汝等勿有疑　　我为诸法王
  普告诸大众　　但以一乘道
  教化诸菩萨　　无声闻弟子
  汝等舍利弗　　声闻及菩萨
  当知是妙法　　诸佛之秘要
  以五浊恶世　　但乐着诸欲
  如是等众生　　终不求佛道
  当来世恶人　　闻佛说一乘
  迷惑不信受　　破法堕恶道
  有惭愧清净　　志求佛道者
  当为如是等　　广赞一乘道
  舍利弗当知　　诸佛法如是
  以万亿方便　　随宜而说法
  其不习学者　　不能晓了此
  汝等既已知　　诸佛世之师
  随宜方便事　　无复诸疑惑
  心生大欢喜　　自知当作佛

添品妙法莲华经卷第一添品妙法莲华经卷第二

        隋天竺三藏阇那崛多共笈多译

    譬喻品第三

尔时舍利弗。踊跃欢喜。即起合掌瞻仰尊颜。而白佛言。今从世尊闻此法音。心怀踊跃得未曾有。所以者何。我昔从佛闻如是法。见诸菩萨受记作佛。而我等不预斯事。甚自感伤。失于如来无量知见。世尊。我尝独处山林树下。若坐若行每作是念。我等同入法性。云何如来。以小乘法而见济度。是我等咎非世尊也。所以者何。若我等待说所因成就阿耨多罗三藐三菩提者。必以大乘而得度脱。然我等不解方便随宜所说。初闻佛法遇便信受。思惟取证。世尊。我从昔来终日竟夜每自克责。而今从佛闻所未闻未曾有法。断诸疑悔。身意泰然快得安隐。今日乃知真是佛子。从佛口生从法化生。得佛法分。尔时舍利弗。欲重宣此义而说偈言

  我闻是法音　　得所未曾有
  心怀大欢喜　　疑网皆已除
  昔来蒙佛教　　不失于大乘
  佛音甚希有　　能除众生恼
  我已得漏尽　　闻亦除忧恼
  我处于山谷　　或在林树下
  若坐若经行　　常思惟是事
  呜呼深自责　　云何而自欺
  我等亦佛子　　同入无漏法
  不能于未来　　演说无上道
  金色三十二　　十力诸解脱
  同共一法中　　而不得此事
  八十种妙好　　十八不共法
  如是等功德　　而我皆已失
  我独经行时　　见佛在大众
  名闻满十方　　广饶益众生
  自惟失此利　　我为自欺诳
  我常于日夜　　每思惟是事
  欲以问世尊　　为失为不失
  我常见世尊　　称赞诸菩萨
  以是于日夜　　筹量如此事
  今闻佛音声　　随宜而说法
  无漏难思议　　令众至道场
  我本着邪见　　为诸梵志师
  世尊知我心　　拔邪说涅槃
  我悉除邪见　　于空法得证
  尔时心自谓　　得至于灭度
  而今乃自觉　　非是实灭度
  若得作佛时　　具三十二相
  天人夜叉众　　龙神等恭敬
  是时乃可谓　　永尽灭无余
  佛于大众中　　说我当作佛
  闻如是法音　　疑悔悉已除
  初闻佛所说　　心中大惊疑
  将非魔作佛　　恼乱我心耶
  佛以种种缘　　譬喻巧言说
  其心安如海　　我闻疑网断
  佛说过去世　　无量灭度佛
  安住方便中　　亦皆说是法
  现在未来佛　　其数无有量
  亦以诸方便　　演说如是法
  如今者世尊　　从生及出家
  得道转法轮　　亦以方便说
  世尊说实道　　波旬无此事
  以是我定知　　非是魔作佛
  我堕疑网故　　谓是魔所为
  闻佛柔软音　　深远甚微妙
  演畅清净法　　我心大欢喜
  疑悔永已尽　　安住实智中
  我定当作佛　　为天人所敬
  转无上法轮　　教化诸菩萨

尔时佛告舍利弗。吾今于天人沙门婆罗门等大众中说。我昔曾于二万亿佛所为无上道故。常教化汝。汝亦长夜随我受学。我以方便引导汝故。生我法中。舍利弗。我昔教汝志愿佛道。汝今悉忘。而便自谓已得灭度。我今还欲令汝忆念本愿所行道故。为诸声闻说是大乘经。名妙法莲华教菩萨法佛所护念。舍利弗。汝于未来世过无量无边不可思议劫。供养若干千万亿佛。奉持正法。具足菩萨所行之道。当得作佛。号曰华光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名离垢。其土平正清净严饰。安隐丰乐天人炽盛。琉璃为地有八交道。黄金为绳以界其侧。其傍各有七宝行树。常有华果。华光如来。亦以三乘教化众生。舍利弗。彼佛出时虽非恶世。以本愿故说三乘法。其劫名大宝庄严。何故名曰大宝庄严。其国中以菩萨为大宝故。彼诸菩萨无量无边不可思议。算数譬喻所不能及。非佛智力无能知者。若欲行时宝华承足。此诸菩萨非初发意。皆久殖德本。于无量百千万亿佛所。净修梵行。恒为诸佛之所称叹。常修佛慧具大神通。善知一切诸法之门。质直无伪志念坚固。如是菩萨充满其国。舍利弗。华光佛寿十二小劫。除为王子未作佛时。其国人民寿八小劫。华光如来过十二小劫。授坚满菩萨阿耨多罗三藐三菩提记。告诸比丘。是坚满菩萨次当作佛。号曰华足安行多陀阿伽度阿罗诃三藐三佛陀。其佛国土亦复如是。舍利弗。是华光佛灭度之后。正法住世三十二小劫。像法住世亦三十二小劫。尔时世尊。欲重宣此义。而说偈言

  舍利弗来世　　成佛普智尊
  号名曰华光　　当度无量众
  供养无数佛　　具足菩萨行
  十力等功德　　证于无上道
  过无量劫已　　劫名大宝严
  世界名离垢　　清净无瑕秽
  以琉璃为地　　金绳界其道
  七宝杂色树　　常有花果实
  彼国诸菩萨　　志念常坚固
  神通波罗蜜　　皆已悉具足
  于无数佛所　　善学菩萨道
  如是等大士　　华光佛所化
  佛为王子时　　弃国舍世荣
  于最末后身　　出家成佛道
  华光佛住世　　寿十二小劫
  其国人民众　　寿命八小劫
  佛灭度之后　　正法住于世
  三十二小劫　　广度诸众生
  正法灭尽已　　像法三十二
  舍利广流布　　天人普供养
  华光佛所为　　其事皆如是
  其两足圣尊　　最胜无伦匹
  彼即是汝身　　宜应自欣庆

尔时四部众。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等大众。见舍利弗于佛前得受阿耨多罗三藐三菩提记。心大欢喜踊跃无量。各各脱身所著上衣。以供养佛。释提桓因梵天王等与无数天子。亦以天妙衣天曼陀罗华摩诃曼陀罗华等。供养于佛。所散天衣。住虚空中而自回转。诸天伎乐百千万种。于虚空中一时俱作。雨众天华。而作是言。佛昔于波罗奈初转法轮。今乃复转无上最大法轮。尔时诸天子。欲重宣此义。而说偈言

  昔于波罗奈　　转四谛法轮
  分别说诸法　　五众之生灭
  今复转最妙　　无上大法轮
  是法甚深奥　　少有能信者
  我等从昔来　　数闻世尊说
  未曾闻如是　　深妙之上法
  世尊说是法　　我等皆随喜
  大智舍利弗　　今得受尊记
  我等亦如是　　必当得作佛
  于一切世间　　最尊无有上
  佛道叵思议　　方便随宜说
  我所有福业　　今世若过世
  及见佛功德　　尽回向佛道

尔时舍利弗白佛言。世尊。我今无复疑悔。亲于佛前得受阿耨多罗三藐三菩提记。是诸千二百心自在者。昔住学地佛常教化言。我法能离生老病死究竟涅槃。是学无学人。亦各自以离我见及有无见等。谓得涅槃。而今于世尊前。闻所未闻皆堕疑惑。善哉世尊。愿为四众说其因缘令离疑悔。尔时佛告舍利弗。我先不言。诸佛世尊以种种因缘譬喻言辞方便说法。皆为阿耨多罗三藐三菩提耶是诸所说。皆为化菩萨故。然舍利弗。今当复以譬喻更明此义。诸有智者以譬喻得解。舍利弗。若国邑聚落有大长者。其年衰迈财富无量。多有田宅及诸僮仆。其家广大唯有一门。多诸人众一百二百。乃至五百人止住其中。堂阁朽故墙壁颓落柱根腐败梁栋倾危。周匝俱时欻然火起焚烧舍宅。长者诸子。若十二十或至三十。在此宅中。长者见是大火从四面起。即大惊怖而作是念。我虽能于此所烧之门安隐得出。而诸子等于火宅内乐着嬉戏。不觉不知不惊不怖。火来逼身苦痛切己。心不厌患无求出意。舍利弗。是长者作是思惟。我身手有力。当以衣裓若以机案从舍出之。复更思惟。是舍唯有一门。而复陜小。诸子幼稚未有所识。恋着戏处。或当堕落为火所烧。我当为说怖畏之事。此舍已烧宜时疾出。无令为火之所烧害。作是念已。如所思惟具告诸子。汝等速出。父虽怜愍善言诱喻。而诸子等乐着嬉戏。不肯信受。不惊不畏了无出心。亦复不知。何者是火何者为舍。云何为失。但东西走戏视父而已。尔时长者。即作是念。此舍已为大火所烧。我及诸子若不时出。必为所焚。我今当设方便令诸子等得免斯害。父知诸子先心各有所好。种种珍玩奇异之物。情必乐着。而告之言。汝等所可玩好希有难得。汝若不取后必忧悔。如此种种羊车鹿车牛车。今在门外可以游戏。汝等于此火宅宜速出来。随汝所欲皆当与汝。尔时诸子闻父所说珍玩之物。适其愿故心各勇锐。互相推排竞共驰走争出火宅。是时长者见诸子等安隐得出。皆于四衢道中露地而坐。无复障碍。其心泰然欢喜踊跃。时诸子等各白父言。父先所许玩好之具。羊车鹿车牛车愿时赐与。舍利弗。尔时长者。各赐诸子等一大车。其车高广众宝庄校。周匝栏楯四面悬铃。又于其上张设幰盖。亦以珍奇杂宝而严饰之。宝绳交络垂诸华缨。重敷綩綖安置丹枕。驾以白牛肤色充洁形体姝好。有大筋力行步平正。其疾如风。又多仆从而侍卫之。所以者何。是大长者财富无量。种种诸藏悉皆充溢。而作是念。我财物无极。不应以下劣小车与诸子等。今此幼童皆是吾子。爱无偏党。我有如是七宝大车。其数无量。应当等心各各与之。不宜差别。所以者何。以我此物周给一国。犹尚不匮。何况诸子。是时诸子。各乘大车得未曾有。非本所望。舍利弗。于汝意云何。是长者等与诸子珍宝大车。宁有虚妄不。舍利弗言。不也世尊。是长者但令诸子得免火难。全其躯命非为虚妄。何以故。若全身命。便为已得玩好之具。况复方便于彼火宅而拔济之。世尊。若是长者。乃至不与最小一车。犹不虚妄。何以故。是长者先作是意。我以方便令子得出。以是因缘无虚妄也。何况长者。自知财富无量。欲饶益诸子等与大车。佛告舍利弗。善哉善哉。如汝所言。舍利弗。如来亦复如是。则为一切世间之父。于诸怖畏衰恼忧患无明闇蔽。永尽无余。而悉成就无量知见力无所畏。有大神力及智慧力。具足方便智慧波罗蜜。大慈大悲常无懈惓。恒求善事利益一切。而生三界朽故火宅。为度众生生老病死忧悲苦恼愚痴闇蔽三毒之火。教化令得阿耨多罗三藐三菩提。见诸众生为生老病死忧悲苦恼之所烧煮。亦以五欲财利故。受种种苦。又以贪着追求故。现受众苦。后受地狱畜生饿鬼之苦。若生天上及在人间。贫穷困苦爱别离苦怨憎会苦。如是等种种诸苦。众生没在其中欢喜游戏。不觉不知不惊不怖。亦不生厌不求解脱。于此三界火宅东西驰走。虽遭大苦不以为患。舍利弗。佛见此已便作是念。我为众生之父。应拔其苦难。与无量无边佛智慧乐。令其游戏。舍利弗。如来复作是念。若我但以神力及智慧力。舍于方便。为诸众生赞如来知见力无所畏者。众生不能以是得度。所以者何。是诸众生。未免生老病死忧悲苦恼。而为三界火宅所烧。何由能解佛之智慧。舍利弗。如彼长者虽复身手有力而不用之。但以殷勤方便。免济诸子火宅之难。然后各与珍宝大车。如来亦复如是。虽有力无所畏而不用之。但以智慧方便。于三界火宅拔济众生。为说三乘声闻辟支佛佛乘。而作是言。汝等莫得乐住三界火宅。勿贪粗弊色声香味触也。若贪着生爱则为所烧。汝等速出三界。当得三乘声闻辟支佛佛乘。我今为汝保任此事。终不虚也。汝等但当勤修精进。如来以是方便诱进众生。复作是言。汝等当知此三乘法皆是圣所称叹。自在无系无所依求。乘是三乘。以无漏根力觉道禅定解脱三昧等。而自娱乐。便得无量安隐快乐。舍利弗。若有众生。内有智性。从佛世尊闻法信受。殷勤精进。欲速出三界自求涅槃。是名声闻乘。如彼诸子为求羊车出于火宅。若有众生从佛世尊闻法信受。殷勤精进求自然慧。乐独善寂。深知诸法因缘。是名辟支佛乘。如彼诸子为求鹿车出于火宅。若有众生。从佛世尊闻法信受。勤修精进求一切智佛智自然智无师智。如来知见。力无所畏。愍念安乐无量众生。利益天人度脱一切。是名大乘菩萨。求此乘故。名为摩诃萨。如彼诸子为求牛车出于火宅。舍利弗。如彼长者见诸子等安隐得出火宅到无畏处。自惟财富无量。等以大车而赐诸子。如来亦复如是。为一切众生之父。若见无量亿千众生以佛教门出三界苦怖畏险道得涅槃乐。如来尔时便作是念。我有无量无边智慧力无畏等诸佛法藏。是诸众生皆是我子。等与大乘不令有人独得灭度。皆以如来灭度而灭度之。是诸众生脱三界者。悉与诸佛禅定解脱等娱乐之具。皆是一相一种圣所称叹。能生净妙第一之乐。舍利弗。如彼长者初以三车诱引诸子。然后但与大车宝物庄严安隐第一。然彼长者无虚妄之咎。如来亦复如是。无有虚妄。初说三乘引导众生。然后但以大乘而度脱之。何以故。如来有无量智慧力无所畏诸法之藏。能与一切众生大乘之法。但不尽能受。舍利弗。以是因缘。当知诸佛方便力故。于一佛乘分别说三。佛欲重宣此义。而说偈言

  譬如长者　　有一大宅　　其宅久故
  而复顿弊　　堂舍高危　　柱根摧朽
  梁栋倾斜　　基陛颓毁　　墙壁圯坼
  泥涂搋落　　覆苦乱坠　　椽梠差脱
  周障屈曲　　杂秽充遍　　有五百人
  止住其中　　鸱枭雕鹫　　鸟鹊鸠鸽
  蚖蛇蝮蝎　　蜈蚣蚰蜒　　守宫百足
  狖狸鼷鼠　　诸恶虫辈　　交横驰走
  屎尿臭处　　不净流溢　　蜣螂诸虫
  而集其上　　狐狼野干　　咀齰践蹋
  [齒*齊]啮死尸　　骨肉狼籍　　由是群狗
  竞来搏撮　　饥羸慞惶　　处处求食
  斗争[齒*查]掣　　啀喍嗥吠　　其舍恐怖
  变状如是　　处处皆有　　魑魅魍魉
  夜叉恶鬼　　食啖人肉　　毒虫之属
  诸恶禽兽　　孚乳产生　　各自藏护
  夜叉竞来　　争取食之　　食之既饱
  恶心转炽　　斗争之声　　甚可怖畏
  鸠槃茶鬼　　蹲踞土埵　　或时离地
  一尺二尺　　往返游行　　纵逸嬉戏
  捉狗两足　　扑令失声　　以脚加颈
  怖狗自乐　　复有诸鬼　　其身长大
  裸形黑瘦　　常住其中　　发大恶声
  叫呼求食　　复有诸鬼　　其咽如针
  复有诸鬼　　首如牛头　　或食人肉
  或复啖狗　　头发蓬乱　　残害凶险
  饥渴所逼　　叫唤驰走　　夜叉饿鬼
  诸恶鸟兽　　饥急四向　　窥看窗牖
  如是诸难　　恐畏无量　　是朽故宅
  属于一人　　其人近出　　未久之间
  于后舍宅　　欻然火起　　四面一时
  其焰俱炽　　栋梁椽柱　　爆声震裂
  摧折堕落　　墙壁崩倒　　诸鬼神等
  扬声大叫　　雕鹫诸鸟　　鸠槃茶等
  周慞惶怖　　不能自出　　恶兽毒虫
  藏窜孔穴　　毗舍阇鬼　　亦住其中
  薄福德故　　为火所逼　　共相残害
  饮血啖肉　　野干之属　　并已前死
  诸大恶兽　　竞来食啖　　臭烟熢[火*孛]
  四面充塞　　蜈蚣蚰蜒　　毒蛇之类
  为火所烧　　争走出穴　　鸠槃茶鬼
  随取而食　　又诸饿鬼　　头上火燃
  饥渴热恼　　周慞闷走　　其宅如是
  甚可怖畏　　毒害火灾　　众难非一
  是时宅主　　在门外立　　闻有人言
  汝诸子等　　先因游戏　　来入此宅
  稚小无知　　欢娱乐着　　长者闻已
  惊入火宅　　方宜救济　　令无烧害
  告喻诸子　　说众患难　　恶鬼毒虫
  灾火蔓莚　　众苦次第　　相续不绝
  毒蛇蚖蝮　　及诸夜叉　　鸠槃茶鬼
  野干狐狗　　雕鹫鸱枭　　百足之属
  饥渴恼急　　甚可怖畏　　此苦难处
  况复大火　　诸子无知　　虽闻父诲
  犹故乐着　　嬉戏不已　　是时长者
  而作是念　　诸子如此　　益我愁恼
  今此舍宅　　无一可乐　　而诸子等
  耽湎嬉戏　　不受我教　　将为火害
  即便思惟　　设诸方便　　告诸子等
  我有种种　　珍玩之具　　妙宝好车
  羊车鹿车　　大牛之车　　今在门外
  汝等出来　　吾为汝等　　造作此车
  随意所乐　　可以游戏　　诸子闻说
  如此诸车　　即时奔竞　　驰走而出
  到于空地　　离诸苦难　　长者见子
  得出火宅　　住于四衢　　坐师子座
  而自庆言　　我今快乐　　此诸子等
  生育甚难　　愚小无知　　而入险宅
  多诸毒虫　　魑魅可畏　　大火猛焰
  四面俱起　　而此诸子　　贪乐嬉戏
  我已救之　　令得脱难　　是故诸人
  我今快乐　　尔时诸子　　知父安坐
  皆诣父所　　而白父言　　愿赐我等
  三种宝车　　如前所许　　诸子出来
  当以三车　　随汝所欲　　今正是时
  惟垂给与　　长者大富　　库藏众多
  金银琉璃　　砗磲码瑙　　以众宝物
  造诸大车　　庄校严饰　　周匝栏楯
  四面悬铃　　金绳交络　　真珠罗网
  张施其上　　金华诸缨　　处处垂下
  众彩杂饰　　周匝围绕　　柔软缯纩
  以为茵蓐　　上妙细[疊*毛]　　价直千亿
  鲜白净洁　　以覆其上　　有大白牛
  肥壮多力　　形体姝好　　以驾宝车
  多诸傧从　　而侍卫之　　以是妙车
  等赐诸子　　诸子是时　　欢喜踊跃
  乘是宝车　　游于四方　　嬉戏快乐
  自在无碍　　告舍利弗　　我亦如是
  众圣中尊　　世间之父　　一切众生
  皆是吾子　　深着世乐　　无有慧心
  三界无安　　犹如火宅　　众苦充满
  甚可怖畏　　常有生老　　病死忧患
  如是等火　　炽然不息　　如来已离
  三界火宅　　寂然闲居　　安处林野
  今此三界　　皆是我有　　其中众生
  悉是吾子　　而今此处　　多诸患难
  唯我一人　　能为救护　　虽复教诏
  而不信受　　于诸欲染　　贪着深故
  是以方便　　为说三乘　　令诸众生
  知三界苦　　开示演说　　出世间道
  是诸子等　　若心决定　　具足三明
  及六神通　　有得缘觉　　不退菩萨
  汝舍利弗　　我为众生　　以此譬喻
  说一佛乘　　汝等若能　　信受是语
  一切皆当　　成得佛道　　是乘微妙
  清净第一　　于诸世间　　为无有上
  佛所悦可　　一切众生　　所应称赞
  供养礼拜　　无量亿千　　诸力解脱
  禅定智慧　　及佛余法　　得如是乘
  令诸子等　　日夜劫数　　常得游戏
  与诸菩萨　　及声闻众　　乘此宝乘
  直至道场　　以是因缘　　十方谛求
  更无余乘　　除佛方便　　告舍利弗
  汝诸人等　　皆是吾子　　我则是父
  汝等累劫　　众苦所烧　　我皆济拔
  令出三界　　我虽先说　　汝等灭度
  但尽生死　　而实不灭　　今所应作
  唯佛智慧　　若有菩萨　　于是众中
  能一心听　　诸佛实法　　诸佛世尊
  虽以方便　　所化众生　　皆是菩萨
  若人小智　　深着爱欲　　为此等故
  说于苦谛　　众生心喜　　得未曾有
  佛说苦谛　　真实无异　　若有众生
  不知苦本　　深着苦因　　不能暂舍
  为是等故　　方便说道　　诸苦所因
  贪欲为本　　若灭贪欲　　无所依止
  灭尽诸苦　　名第三谛　　为灭谛故
  修行于道　　离诸苦缚　　名得解脱
  是人于何　　而得解脱　　但离虚妄
  名为解脱　　其实未得　　一切解脱
  佛说是人　　未实灭度　　斯人未得
  无上道故　　我意不欲　　令至灭度
  我为法王　　于法自在　　安隐众生
  故现于世　　汝舍利弗　　我此法印
  为欲利益　　世间故说　　在所游方
  勿妄宣传　　若有闻者　　随喜顶受
  当知是人　　阿惟越致　　若有信受
  此经法者　　是人已曾　　见过去佛
  恭敬供养　　亦闻是法　　若人有能
  信汝所说　　则为见我　　亦见于汝
  及比丘僧　　并诸菩萨　　斯法华经
  为深智说　　浅识闻之　　迷惑不解
  一切声闻　　及辟支佛　　于此经中
  力所不及　　汝舍利弗　　尚于此经
  以信得入　　况余声闻　　其余声闻
  信佛语故　　随顺此经　　非己智分
  又舍利弗　　憍慢懈怠　　计我见者
  莫说此经　　凡夫浅识　　深着五欲
  闻不能解　　亦勿为说　　若人不信
  毁谤此经　　则断一切　　世间佛种
  或复嚬蹙　　而怀疑惑　　汝当听说
  此人罪报　　若佛在世　　若灭度后
  其有诽谤　　如斯经典　　见有读诵
  书持经者　　轻贱憎嫉　　而怀结恨
  此人罪报　　汝今复听　　其人命终
  入阿鼻狱　　具足一劫　　劫尽更生
  如是展转　　至无数劫　　从地狱出
  当堕畜生　　若狗野干　　其形[乞*頁]瘦
  黧黮疥癞　　人所触娆　　又复为人
  之所恶贱　　常困饥渴　　骨肉枯竭
  生受楚毒　　死被瓦石　　断佛种故
  受斯罪报　　若作骆驼　　或生驴中
  身常负重　　加诸杖捶　　但念水草
  余无所知　　谤斯经故　　获罪如是
  有作野干　　来入聚落　　身体疥癞
  又无一目　　为诸童子　　之所打掷
  受诸苦痛　　或时致死　　于此死已
  更受蟒身　　其形长大　　五百由旬
  聋騃无足　　宛转腹行　　为诸小虫
  之所唼食　　昼夜受苦　　无有休息
  谤斯经故　　获罪如是　　若得为人
  诸根闇钝　　矬陋挛躄　　盲聋背伛
  有所言说　　人不信受　　口气常臭
  鬼魅所著　　贫穷下贱　　为人所使
  多病痟瘦　　无所依怙　　虽亲附人
  人不在意　　若有所得　　寻复忘失
  若修医道　　顺方治病　　更增他疾
  或复致死　　若自有病　　无人救疗
  设服良药　　而复增剧　　若他反逆
  抄劫窃盗　　如是等罪　　横罗其殃
  如斯罪人　　永不见佛　　众圣之王
  说法教化　　如斯罪人　　常生难处
  狂聋心乱　　永不闻法　　于无数劫
  如恒河沙　　生辄聋哑　　诸根不具
  常处地狱　　如游园观　　在余恶道
  如己舍宅　　驼驴猪狗　　是其行处
  谤斯经故　　获罪如是　　若得为人
  聋盲喑哑　　贫穷诸衰　　以自庄严
  水肿干痟　　疥癞痈疽　　如是等病
  以为衣服　　身常臭处　　垢秽不净
  深着我见　　增益嗔恚　　淫欲炽盛
  不择禽兽　　谤斯经故　　获罪如是
  告舍利弗　　谤斯经者　　若说其罪
  穷劫不尽　　以是因缘　　我故语汝
  无智人中　　莫说此经　　若有利根
  智慧明了　　多闻强识　　求佛道者
  如是之人　　乃可为说　　若人曾见
  亿百千佛　　殖诸善本　　深心坚固
  如是之人　　乃可为说　　若人精进
  常修慈心　　不惜身命　　乃可为说
  若人恭敬　　无有异心　　离诸凡愚
  独处山泽　　如是之人　　乃可为说
  又舍利弗　　若见有人　　舍恶知识
  亲近善友　　如是之人　　乃可为说
  若见佛子　　持戒清洁　　如净明珠
  求大乘经　　如是之人　　乃可为说
  若人无嗔　　质直柔软　　常愍一切
  恭敬诸佛　　如是之人　　乃可为说
  复有佛子　　于大众中　　以清净心
  种种因缘　　譬喻言辞　　说法无碍
  如是之人　　乃可为说　　若有比丘
  为一切智　　四方求法　　合掌顶受
  但乐受持　　大乘经典　　乃至不受
  余经一偈　　如是之人　　乃可为说
  如人至心　　求佛舍利　　如是求经
  得已顶受　　其人不复　　志求余经
  亦未曾念　　外道典籍　　如是之人
  乃可为说

  告舍利弗　　我说是相　　求佛道者
  穷劫不尽　　如是等人　　则能信解
  汝当为说　　妙法华经

    添品妙法莲华经信解品第四

尔时慧命须菩提。摩诃迦旃延。摩诃迦叶。摩诃目犍连。从佛所闻未曾有法。世尊授舍利弗阿耨多罗三藐三菩提记。发希有心欢喜踊跃。即从座起整衣服。偏袒右肩右膝着地。一心合掌曲躬恭敬。瞻仰尊颜而白佛言。我等居僧之首。年并朽迈自谓已得涅槃。无所堪任。不复进求阿耨多罗三藐三菩提。世尊往昔说法既久。我时在座身体疲懈。但念空无相无作。于菩萨法游戏神通净佛国土成就众生。心不喜乐。所以者何。世尊。令我等出于三界得涅槃证。又今我等年已朽迈。于佛教化菩萨阿耨多罗三藐三菩提。不生一念好乐之心。我等今于佛前闻授声闻阿耨多罗三藐三菩提记。心甚欢喜得未曾有。不谓于今忽然得闻希有之法。深自庆幸获大善利。无量珍宝不求自得。世尊。我等今者乐说譬喻以明斯义。譬若有人年既幼稚。舍父逃逝久住他国。或十二十至五十岁。年既长大加复穷困。驰骋四方以求衣食。渐渐游行遇向本国。其父先来求子不得。中止一城。其家大富财宝无量。金银琉璃珊瑚琥珀颇梨珠等。其诸仓库悉皆盈溢。多有僮仆臣佐吏民。象马车乘牛羊无数。出入息利乃遍他国。商估贾客亦甚众多。时贫穷子游诸聚落。经历国邑。遂到其父所止之城。父每念子。与子离别五十余年。而未曾向人说如此事。但自思惟心怀悔恨。自念老朽多有财物。金银珍宝仓库盈溢。无有子息。一旦终没。财物散失无所委付。是以殷勤每忆其子。复作是念。我若得子委付财物。坦然快乐无复忧虑。世尊。尔时穷子。佣赁展转遇到父舍。住立门侧遥见其父。踞师子床宝机承足。诸婆罗门刹利居士。皆恭敬围绕。以真珠缨络价直千万。庄严其身。吏民僮仆。手执白拂侍立左右。覆以宝帐垂诸华幡。香水洒地散众名华。罗列宝物出内取与。有如是等种种严饰威德特尊。穷子见父有大力势。即怀恐怖悔来至此。窃作是念。此或是王。或是王等。非我佣力得物之处。不如往至贫里。肆力有地衣食易得。若久住此。或见逼迫强使我作。作是念已。疾走而去。时富长者。于师子座。见子便识心大欢喜。即作是念。我财物库藏今有所付。我常思念此子。无由见之。而忽自来。甚适我愿。我虽年朽犹故贪惜。即遣傍人急追将还。尔时使者疾走往捉。穷子惊愕称怨大唤。我不相犯何为见捉。使者执之逾急。强牵将还。于时穷子自念无罪而被囚执。此必定死。转更惶怖闷绝躄地。父遥见之而语使言。不须此人勿强将来。以冷水洒面令得醒悟。莫复与语。所以者何。父知其子志意下劣。自知豪贵为子所难。审知是子而以方便。不语他人云是我子。使者语之。我今放汝随意所趣。穷子欢喜得未曾有。从地而起往至贫里。以求衣食。尔时长者。将欲诱引其子。而设方便。密遣二人形色憔悴无威德者。汝可诣彼徐语穷子。此有作处倍与汝直。穷子若许将来使作。若言欲何所作。便可语之。雇汝除粪。我等二人亦共汝作。时二使人即求穷子。既已得之具陈上事。尔时穷子先取其价。寻与除粪。其父见子愍而怪之。又以他日。于窗牖中遥见子身。羸瘦憔悴粪土尘坌污秽不净。即脱缨络细软上服严饰之具。更着粗弊垢腻之衣。尘土坌身。右手执持除粪之器。状有所畏语诸作人。汝等勤作勿得懈息。以方便故得近其子。又复告言。咄男子。汝常此作勿复余去。当加汝价。诸有所须。盆器米面盐酢之属。莫自疑难。亦有老弊使人。须者相给好自安意。我如汝父勿复忧虑。所以者何。我年老大而汝少壮。汝常作时无有欺怠嗔恨怨言。都不见汝有此诸恶如余作人。自今已后如所生子。即时长者。更与作字名之为儿。尔时穷子。虽欣此遇。犹故自谓客作贱人。由是之故。于二十年中常令除粪。过是已后心相体信。入出无难。然其所止犹在本处。世尊。尔时长者有疾。自知将死不久。语穷子言。我今多有金银珍宝仓库盈溢。其中多少所应取与。汝悉知之。我心如是当体此意。所以者何。今我与汝便为不异。宜加用心无令漏失。尔时穷子。即受教敕领知众物。金银珍宝及诸库藏。而无希取一餐之意。然其所止故在本处。下劣之心亦未能舍。复经少时。父知子意渐以通泰。成就大志自鄙先心。临欲终时而命其子。并会亲族国王大臣刹利居士。皆悉已集。即自宣言。诸君当知。此是我子我之所生。于某城中舍吾逃走。伶俜辛苦五十余年。其本字某我名某甲。昔在本城怀忧推觅。忽于此间遇会得之。此实我子我实其父。今我所有一切财物。皆是子有。先所出内是子所知。世尊。是时穷子。闻父此言。即大欢喜得未曾有。而作是念。我本无心有所希求。今此宝藏自然而至。世尊大富长者则是如来。我等皆似佛子。如来常说我等为子。世尊。我等以三苦故。于生死中受诸热恼。迷惑无知乐着小法。今日世尊。令我等思惟蠲除诸法戏论之粪。我等于中勤加精进得至涅槃一日之价。既得此已。心大欢喜自以为足。而便自谓。于佛法中勤精进故所得弘多。然世尊先知我等心着弊欲乐于小法。便见纵舍不为分别。汝等当有如来知见宝藏之分。世尊。以方便力说如来智慧。我等从佛得涅槃一日之价。以为大得。于此大乘无有志求。我等又因如来智慧。为诸菩萨开示演说而自于此无有志愿。所以者何。佛知我等心乐小法。以方便力随我等说。而我等不知真是佛子。今我等方知。世尊于佛智慧无所吝惜。所以者何。我等昔来真是佛子。而但乐小法。若我等有乐大之心。佛则为我说大乘法。于此经中唯说一乘。而昔于菩萨前毁呰声闻乐小法者。然佛实以大乘教化。是故我等说本无心有所希求。今法王大宝自然而至。如佛子所应得者皆已得之。尔时摩诃迦叶。欲重宣此义。而说偈言

  我等今日　　闻佛音教　　欢喜踊跃
  得未曾有　　佛说声闻　　当得作佛
  无上宝聚　　不求自得　　譬如童子
  幼稚无识　　舍父逃逝　　远到他土
  周流诸国　　五十余年　　其父忧念
  四方推求　　求之既疲　　顿止一城
  造立舍宅　　五欲自娱　　其家巨富
  多诸金银　　车渠马瑙　　真珠琉璃
  象马牛羊　　辇舆车乘　　田业僮仆
  人民众多　　出入息利　　乃遍他国
  商估贾人　　无处不有　　千万亿众
  围绕恭敬　　常为王者　　之所爱念
  群臣豪族　　皆共宗重　　以诸缘故
  往来者众　　豪富如是　　有大力势
  而年朽迈　　益忧念子　　夙夜惟念
  死时将至　　痴子舍我　　五十余年
  库藏诸物　　当如之何
  尔时穷子　　求索衣食　　从邑至邑
  从国至国　　或有所得　　或无所得
  饥饿羸瘦　　体生疮癣　　渐次经历
  到父住城　　佣赁展转　　遂至父舍
  尔时长者　　于其门内　　施大宝帐
  处师子座　　眷属围绕　　诸人侍卫
  或有计算　　金银宝物　　出内财产
  注记券疏　　穷子见父　　豪贵尊严
  谓是国王　　若是王等　　惊怖自怪
  何故至此　　复自念言　　我若久住
  或见逼迫　　强驱使作　　思惟是已
  驰走而去　　借问贫里　　欲往佣作
  长者是时　　在师子座　　遥见其子
  默而识之　　即敕使者　　追捉将来
  穷子惊唤　　迷闷躄地　　是人执我
  必当见杀　　何用衣食　　使我至此
  长者知子　　愚痴狭劣　　不信我言
  不信是父　　即以方便　　更遣余人
  眇目矬陋　　无威德者　　汝可语之
  云当相雇　　除诸粪秽　　倍与汝价
  穷子闻之　　欢喜随来　　为除粪秽
  净诸房舍　　长者于牖　　常见其子
  念子愚劣　　乐为鄙事　　于是长者
  着弊垢衣　　执除粪器　　往到子所
  方便附近　　语令勤作　　既益汝价
  并涂足油　　饮食充足　　荐席厚暖
  如是苦言　　汝当勤作　　又以软语
  若如我子　　长者有智　　渐令入出
  经二十年　　执作家事　　示其金银
  真珠颇梨　　诸物出入　　皆使令知
  犹处门外　　止宿草庵　　自念贫事
  我无此物　　父知子心　　渐已旷大
  欲与财物　　即聚亲族　　国王大臣
  刹利居士　　于此大众　　说是我子
  舍我他行　　经五十年　　自见子来
  已二十年　　昔于某城　　而失是子
  周行求索　　遂来至此　　凡我所有
  舍宅人民　　悉以付之　　恣其所用
  子念昔贫　　志意下劣　　今于父所
  大获珍宝　　并及舍宅　　一切财物
  甚大欢喜　　得未曾有　　佛亦如是
  知我乐小　　未曾说言　　汝等作佛
  而说我等　　得诸无漏　　成就小乘
  声闻弟子　　佛敕我等　　说最上道
  修习此者　　当得成佛　　我承佛教
  为大菩萨　　以诸因缘　　种种譬喻
  若干言辞　　说无上道
  诸佛子等　　从我闻法　　日夜思惟
  精勤修习　　是时诸佛　　即授其记
  汝于来世　　当得作佛　　一切诸佛
  秘藏之法　　但为菩萨　　演其实事
  而不为我　　说斯真要　　如彼穷子
  得近其父　　虽知诸物　　心不悕取
  我等虽说　　佛法宝藏　　自无志愿
  亦复如是　　我等内灭　　自谓为足
  唯了此事　　更无余事　　我等若闻
  净佛国土　　教化众生　　都无欣乐
  所以者何　　一切诸法　　皆悉空寂
  无生无灭　　无大无小　　无漏无为
  如是思惟　　不生喜乐　　我等长夜
  于佛智慧　　无贪无著　　无复志愿
  而自于法　　谓是究竟　　我等长夜
  修习空法　　得脱三界　　苦恼之患
  住最后身　　有余涅槃　　佛所教化
  得道不虚　　则为已得　　报佛之恩
  我等虽为　　诸佛子等　　说菩萨法
  以求佛道　　而于是法　　永无愿乐
  导师见舍　　观我心故　　初不劝进
  说有实利　　如富长者　　知子志劣
  以方便力　　柔伏其心　　然后乃付
  一切财宝　　佛亦如是　　现希有事
  知乐小者　　以方便力　　调伏其心
  乃教大智　　我等今日　　得未曾有
  非先所望　　而今自得　　如彼穷子
  得无量宝　　世尊我今　　得道得果
  于无漏法　　得清净眼　　我等长夜
  持佛净戒　　始于今日　　得其果报
  法王法中　　久修梵行　　今得无漏
  无上大果　　我等今者　　真是声闻
  以佛道声　　令一切闻　　我等今者
  真阿罗汉　　于诸世间　　天人魔梵
  普于其中　　应受供养　　世尊大恩
  以希有事　　怜愍教化　　利益我等
  无量亿劫　　谁能报者　　手足供给
  头顶礼敬　　一切供养　　皆不能报
  若以顶戴　　两肩荷负　　于恒沙劫
  尽心恭敬　　又以美膳　　无量宝衣
  及诸卧具　　种种汤药　　牛头栴檀
  及诸珍宝　　以起塔庙　　宝衣布地
  如斯等事　　以用供养　　于恒沙劫
  亦不能报　　诸佛希有　　无量无边
  不可思议　　大神通力　　无漏无为
  诸法之王　　能为下劣　　忍于斯事
  取相凡夫　　随宜而说　　诸佛于法
  得最自在　　知诸众生　　种种欲乐
  及其志力　　随所堪任　　以无量喻
  而为说法　　随诸众生　　宿世善根
  又知成熟　　未成熟者　　种种筹量
  分别知已　　于一乘道　　随宜说三

添品妙法莲华经卷第二添品妙法莲华经卷第三

        隋天竺三藏阇那崛多共笈多译

    药草喻品第五

尔时世尊。告摩诃迦叶及诸大弟子。善哉善哉。迦叶。善说如来真实功德。诚如所言。如来复有无量无边阿僧祇功德。汝等若于无量亿劫说不能尽。迦叶当知。如来是诸法之王。若有所说皆不虚也。于一切法。以智方便而演说之。其所说法。皆悉到于一切智地。如来观知一切诸法之所归趣。亦知一切众生深心所行。通达无碍。又于诸法究尽明了。示诸众生一切智慧。迦叶。譬如三千大千世界。山川溪谷土地所生。卉木丛林及诸药草。种类若干名色各异。密云弥布遍覆三千大千世界。一时等澍其泽普洽。卉木丛林及诸药草。小根小茎小枝小叶。中根中茎中枝中叶。大根大茎大枝大叶。诸树大小随上中下。各有所受。一云所雨称其种性。而得生长华果敷实。虽一地所生一雨所润。而诸草木各有差别。迦叶当知。如来亦复如是。出现于世如大云起。以大音声普遍世界天人阿修罗。如彼大云遍覆三千大千国土。于大众中而唱是言。我是如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。未度者令度。未解者令解。未安者令安。未涅槃者令得涅槃。今世后世如实知之。我是一切知者。一切见者。知道者。开道者。说道者。汝等天人阿修罗众。皆应到此。为听法故。尔时无数千万亿种众生。来至佛所而听法。如来于时观是众生诸根利钝精进懈怠。随其所堪而为说法。种种无量皆令欢喜。快得善利。是诸众生闻是法已。现世安隐后生善处。以道受乐亦得闻法。既闻法已离诸障碍。于诸法中任力所能渐得入道。如彼大云雨。于一切卉木丛林及诸药草。如其种性具足蒙润各得生长如来说法一相一味。所谓解脱相离相灭相。究竟至于一切种智。其有众生闻如来法。若持读诵如说修行。所得功德不自觉知。所以者何。唯有如来。知此众生种相体性。念何事。思何事。修何事。云何念。云何思。云何修。以何法念。以何法思。以何法修。以何法得何法。众生住于种种之地。唯有如来如实见之。明了无碍。如彼卉木丛林诸药草等。而不自知上中下性。如来知是一相一味之法。所谓解脱相离相灭相。究竟涅槃常寂灭相。终归于空。佛知是已。观众生心欲而将护之。是故不即为说一切种智。汝等迦叶甚为希有。能知如来随宜说法。能信能受。所以者何。诸佛世尊随宜说法难解难知。尔时世尊。欲重宣此义而说偈言

  破有法王　　出现世间　　随众生欲
  种种说法　　如来尊重　　智慧深远
  久默斯要　　不务速说　　有智若闻
  则能信解　　无智疑悔　　则为永失
  是故迦叶　　随力为说　　以种种缘
  令得正见　　迦叶当知　　譬如大云
  起于世间　　遍覆一切　　惠云含润
  电光晃曜　　雷声远震　　令众悦豫
  日光掩蔽　　地上清凉　　叆叇垂布
  如可承揽　　其雨普等　　四方俱下
  流澍无量　　率土充洽　　山川崄谷
  幽邃所生　　卉木药草　　大小诸树
  百谷苗稼　　甘蔗蒲桃　　雨之所润
  无不丰足　　干地普洽　　药木并茂
  其云所出　　一味之水　　草木丛林
  随分受润　　一切诸树　　上中下等
  称其大小　　各得生长　　根茎枝叶
  华果光色　　一雨所及　　皆得鲜泽
  如其体相　　性分大小　　所润是一
  而各滋茂　　佛亦如是　　出现于世
  譬如大云　　普覆一切　　既出于世
  为诸众生　　分别演说　　诸法之实
  大圣世尊　　于诸天人　　一切众中
  而宣是言　　我为如来　　两足之尊
  出于世间　　犹如大云　　充润一切
  枯槁众生　　皆令离苦　　得安隐乐
  世间之乐　　及涅槃乐　　诸天人众
  一心善听　　皆应到此　　觐无上尊
  我为世尊　　无能及者　　安隐众生
  故现于世　　为大众说　　甘露净法
  其法一味　　解脱涅槃　　以一妙音
  演畅斯义　　常为大乘　　而作因缘
  我观一切　　普皆平等　　无有彼此
  爱憎之心　　我无贪着　　亦无限碍
  恒为一切　　平等说法　　如为一人
  众多亦然　　常演说法　　曾无他事
  去来坐立　　终不疲厌　　充足世间
  如雨所润　　贵贱上下　　持戒毁戒
  威仪具足　　及不具足　　正见邪见
  利根钝根　　等雨法雨　　而无懈惓
  一切众生　　闻我法者　　随力所受
  住于诸地　　或处人天　　转轮圣王
  释梵诸天　　是小药草　　知无漏法
  能得涅槃　　起六神通　　及得三明
  独处山林　　常行禅定　　得缘觉证
  是中药草　　求世尊处　　我当作佛
  行精进定　　是上药草　　又诸佛子
  专心佛道　　常行慈悲　　自知作佛
  决定无疑　　是名小树　　安住神通
  转不退轮　　度无量亿　　百千众生
  如是菩萨　　名为大树　　佛平等说
  如一味雨　　随众生性　　所受不同
  如彼草木　　所禀各异　　佛以此喻
  方便开示　　种种言辞　　演说一法
  于佛智慧　　如海一渧　　我雨法雨
  充满世间　　一味之法　　随力修行
  如彼丛林　　药草诸树　　随其大小
  渐增茂好　　诸佛之法　　常以一味
  令诸世间　　普得具足　　渐次修行
  皆得道果　　声闻缘觉　　处于山林
  住最后身　　闻法得果　　是名药草
  各得增长　　若诸菩萨　　智慧坚固
  了达三界　　求最上乘　　是名小树
  而得增长　　复有住禅　　得神通力
  闻诸法空　　心大欢喜　　放无数光
  度诸众生　　是名大树　　而得增长
  如是迦叶　　佛所说法　　譬如大云
  以一味雨　　润于人华　　各得成实
  迦叶当知　　以诸因缘　　种种譬喻
  开示佛道　　是我方便　　诸佛亦然
  今为汝等　　说最实事　　诸声闻众
  皆非灭度　　汝等所行　　是菩萨道
  渐渐修学　　悉当成佛

复次迦叶。如来于诸众生调伏平等。迦叶。譬如日月光明照于世间。若作善若作不善。若高处住。若下处住。若香若臭。诸处平等光照无偏。如是迦叶。如来应正遍知一切种智心之光明于诸五趣众生受生之中。如其信解大乘缘觉乘声闻乘中。为说正法平等而转。如来智慧亦无增减。如其福智聚集而生。迦叶。无有三乘。唯彼众生别异行故。施设三乘。慧命摩诃迦叶白佛言。世尊。若无三乘。何故现世施设声闻缘觉菩萨。佛告慧命摩诃迦叶。譬如作瓦器者。等和土泥而用作器。彼中或有盛沙糖器。或盛酥器。或盛乳酪器。或盛恶粪秽器。泥亦无有种种别异。而物着中随所受量。器则种种别异施设。如是迦叶此唯一乘所谓大乘。无有二乘及以三乘。慧命摩诃迦叶白佛言。世尊。彼诸众生种种信解。若出三界。彼等为一涅槃。为当二三。佛告慧命摩诃迦叶。若觉诸法体等涅槃。彼亦唯一无有二三。迦叶。以彼义故。我当为汝作喻。以此喻故有智丈夫则当解我所说之义。迦叶。譬如生盲丈夫。作如是言。无有好恶等色。亦无好恶等色可见。无有日月星宿等。亦无星宿等可见。有异丈夫。于彼生盲者前。说如是言。有好恶等色。亦有好恶等色可见。有日月星宿等。亦有星宿等可见。生盲丈夫虽闻其说而不信受。时有良医能知诸病。见彼生盲丈夫。如是念言。其彼丈夫先有恶业今有病生。若其病生则有四种。所谓风黄与癃及以等分。时彼良医。为欲灭其病故。又复方便如是思惟。所有药物世所行者。彼等不能疗治此病。唯雪山王。有四种药。何等为四。所谓初名顺入诸色味处。二名解脱诸病。三名破坏诸毒。四名随所住处施与安乐。是为四种。时彼良医。于生盲所发生悲愍。兴起如是方便思惟。以彼方便诣雪山王。到已上顶。或下入或傍行。周遍观察。既观察已。得四种药。于中或以齿等咀嚼。作已与之。或以石磨。或复和别药物煮熟与之。或复和生药物作已与之。或针刺身与作孔穴。或有与火炙烧。或以别异药物相和。乃至饮食和而与之。时彼生盲。以方便相应故即时得眼。彼得眼已。内外远近日月光明星宿诸色皆悉得见。说如是言。呜呼我甚愚痴。我闻先说本不信受。我今此时皆悉得见。我盲已脱。亦已得眼。无胜我者。彼时复有五通仙人。天眼天耳了知他心。忆念宿住善证智通。语丈夫言。丈夫汝唯得眼。余无一知。汝今何故已生憍慢。汝亦未有智慧善巧。彼复作如是言。丈夫汝入室坐。外有别色不见不知。汝亦不知众生善心恶心。五踰阇那边住。所有言说鼓贝等声。汝亦不闻不知。拘卢舍边不举两足不能往到。及生长已。母胎作业汝亦不念。云何汝有巧智。云何作如是言。我悉得见。又汝丈夫。闇作明知明作闇知。时彼丈夫语仙人言。以何方便。又作何等清净业已。当得是智。及于汝等。净信力故。我亦当得如此功德。时彼仙人语丈夫言。若欲如是。汝应当住空闲山窟。坐思念法及断烦恼。当得神通具足功德。时彼丈夫受其义已。即行出家住空闲处。专守一心断世渴爱。得五神通。既得五神通已。思惟我先作于别业。以彼因故。无一功德可以证知。我念此时。随所思念即能得去。我于昔时少智少慧。有盲而住。迦叶。作此譬喻欲令知义。于此义中复应当见。迦叶。其生盲者。即是六趣流转中住所有众生。若于正法未有知觉。烦恼盲闇则当增长。及彼无明闇冥。以无明闇冥故。行业聚集以行业为缘故。名色乃至唯有大苦之聚积集。当生如是无明闇冥。众生流转中住。唯有如来超出三界。发生悲愍。亦如慈父爱念一子。发悲愍已下入三界。见彼众生。于流转轮中行。不如实知出离流转。佛以佛眼而观见之。见已了知此等众生。先世作善。少嗔厚欲。少欲厚嗔。或有少智。或有巧慧。或有成熟清净。或有邪见。彼等众生。佛为方便巧说三乘。如彼仙人五通净眼者。即是菩萨。菩提心生得无生忍。证觉无上正真之觉。如彼大医。即是如来。当如是见。如彼生盲。即是痴闇众生。当如是见。如彼风黄癃等即是欲嗔及痴六十二见。当如是见。如四种药。即是空无相无愿涅槃门。当如是见。随所服药。其病随灭。即是空无相无愿解脱门。正修念已无明当灭。无明灭故行灭。乃至唯有大苦聚灭。如是思惟。不住善中亦不恶中。如盲得眼。即是声闻缘觉乘。当如是见。割断流转烦恼系缚。解脱烦恼。解脱六趣及以三界。以彼义故。声闻乘者如是念言。无有别法更须证觉。我今已得到于涅槃。尔时如来为彼说法。若于诸法未能悉到。何处彼有究竟涅槃。彼等佛以菩提教化。发菩提心。不住流转不到涅槃。彼悟三界十方空寂。皆如化梦及以焰响。观见诸法不生不灭。不縳不解不闇不明。如是见甚深法。彼见亦无所见。而亦恒见满诸三界别异众生心之信解。尔时世尊。欲重宣此义。而说偈言

  譬如日月光　　平等照三千
  于善及于恶　　而光无增减
  如来智慧光　　平等如日月
  教化诸众生　　无增亦无减
  如瓦师作器　　平等和土泥
  于中器或盛　　沙糖乳稣水
  或有盛不净　　或有盛于酪
  彼唯取一泥　　瓦师用为器
  若物堕其内　　因彼知器名
  如众生无余　　如来随别欲
  虽说乘差别　　决定唯佛乘
  无智故轮转　　而不知寂灭
  若人能知空　　远离于法我
  彼知佛世尊　　所得正真觉
  安置处中智　　说名缘觉者
  空智教化已　　显名为声闻
  若能觉诸法　　说名正遍知
  如有生盲者　　不见日月星
  彼便如是言　　无有诸色类
  大医于生盲　　为其入慈愍
  往诣雪山已　　上下及傍行
  求得于良药　　顺入色味处
  如是等四种　　和合而疗治
  或有用齿啮　　或有以石磨
  或以针入身　　疗治生盲者
  彼既得眼已　　即见日月光
  复作如是念　　昔时无智说
  是流转众生　　生盲大无智
  缘生轮所运　　无智受苦道
  无智痴世中　　如是一切智
  如来大良医　　出生悲愍体
  彼以善方便　　演说寂正法
  无上佛觉智　　演说最胜乘
  广说处中际　　中智导师者
  怖畏于流转　　为赞异菩提
  出离三界已　　声闻自知住
  如是念我得　　涅槃无垢安
  当得诸法觉　　涅槃甘露处
  大仙于彼故　　为其入悲愍
  告言汝愚痴　　莫念我是智
  若有于仓舍　　汝住彼中时
  外有则不知　　汝是小智者
  若住彼中时　　知外作未作
  彼亦未是知　　况汝小智者
  五踰阇那量　　若有音声出
  汝不能闻彼　　何况别远住
  他人于汝所　　若爱若恶心
  汝不能知彼　　如何生普慢
  欲向俱卢舍　　不步不能往
  汝胎所有事　　汝亦忘彼时
  若得五神通　　乃名一切智
  汝痴无一智　　而说是智者
  汝欲一切智　　出生于神通
  若住空闲处　　神通则可出
  思惟清净法　　则当得神通
  受义诣空闲　　思惟入静室
  得五神通已　　不久具功德
  如是诸声闻　　念得涅槃想
  诸佛说彼时　　小息非涅槃
  是诸佛方便　　为说如此道
  若离一切智　　无有发涅槃
  三世智无边　　六度行清净
  空寂及无相　　作愿亦除舍
  及以菩提心　　别法向涅槃
  及四种梵行　　四摄亦赞说
  为教化众生　　胜仙而说此
  若复知诸法　　自性如幻梦
  不实似芭蕉　　亦与音响等
  及知彼自性　　三界无余残
  不缚亦不解　　不知于灭度
  诸法平等空　　无有异体者
  此亦无所见　　不观于一法
  彼见大智者　　法身无余残
  无有于三乘　　一乘此中有
  诸法皆平等　　平等常等等
  知如是智已　　涅槃甘露安

    添品妙法莲华经授记品第六

尔时世尊。说是偈已。告诸大众唱如是言。我此弟子摩诃迦叶。于未来世。当得奉觐三百万亿诸佛世尊。供养恭敬尊重赞叹。广宣诸佛无量大法。于最后身得成为佛。名曰光明。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名光德。劫名大庄严。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫。国界严饰无诸秽恶。瓦砾荆棘便利不净。其土平正。无有高下坑坎堆埠。琉璃为地宝树行列。黄金为绳以界道侧。散诸宝华周遍清净。其国菩萨无量千亿。诸声闻众亦复无数。无有魔事。虽有魔及魔民。皆护佛法尔时世尊。欲重宣此义。而说偈言

  告诸比丘　　我以佛眼　　见是迦叶
  于未来世　　过无数劫　　当得作佛
  而于来世　　供养奉觐　　三百万亿
  诸佛世尊　　为佛智慧　　净修梵行
  供养最上　　两足尊已　　修集一切
  无上之慧　　于最后身　　得成为佛
  其土清净　　琉璃为地　　多诸宝树
  行列道侧　　金绳界道　　见者欢喜
  常出好香　　散众名华　　种种奇妙
  以为庄严　　其地平正　　无有丘坑
  诸菩萨众　　不可称计　　其心调柔
  逮大神通　　奉持诸佛　　大乘经典
  诸声闻众　　无漏后身　　法王之子
  亦不可计　　乃以天眼　　不能数知
  其佛当寿　　十二小劫　　正法住世
  二十小劫　　像法亦住　　二十小劫
  光明世尊　　其事如是

尔时大目犍连。须菩提。摩诃迦栴延等。皆悉悚栗。一心合掌瞻仰世尊。目不暂舍。即共同声。而说偈言

  大雄猛世尊　　诸释之法王
  哀愍我等故　　而赐佛音声
  若知我深心　　见为授记者
  如以甘露洒　　除热得清凉
  如从饥国来　　忽遇大王膳
  心犹怀疑惧　　未敢即便食
  若复得王教　　然后乃敢食
  我等亦如是　　每惟小乘过
  不知当云何　　得佛无上慧
  虽闻佛音声　　言我等作佛
  心尚怀忧惧　　如未敢便食
  若蒙佛授记　　尔乃快安乐
  大雄猛世尊　　常欲安世间
  愿赐我等记　　如饥须教食

尔时世尊。知诸大弟子心之所念。告诸比丘。是须菩提。于当来世。奉觐三百万亿那由他佛。供养恭敬尊重赞叹。常修梵行具菩萨道。于最后身得成为佛。号曰名相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名有宝。国名宝生。其土平正颇梨为地。宝树庄严无诸丘坑。沙砾荆棘便利之秽。宝华覆地周遍清净。其土人民。皆处宝台珍妙楼阁。声闻弟子无量无边。算数譬喻所不能知。诸菩萨众。无数千万亿那由他。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫。其佛常处虚空。为众说法。度脱无量菩萨及声闻众。尔时世尊。欲重宣此义。而说偈言

  诸比丘众　　今告汝等　　皆当一心
  听我所说　　我大弟子　　须菩提者
  当得作佛　　号曰名相　　当供无数
  万亿诸佛　　随佛所作　　渐具大道
  最后身得　　三十二相　　端正殊妙
  犹如宝山　　其佛国土　　严净第一
  众生见者　　无不爱乐　　佛于其中
  度无量众　　其佛法中　　多诸菩萨
  皆悉利根　　转不退轮　　彼国常以
  菩萨庄严　　诸声闻众　　不可称数
  皆得三明　　具六神通　　住八解脱
  有大威德　　其佛说法　　现于无量
  神通变化　　不可思议　　诸天人民
  数如恒沙　　皆共合掌　　听受佛语
  其佛当寿　　十二小劫　　正法住世
  二十小劫　　像法亦住　　二十小劫

尔时世尊。复告诸比丘众。我今语汝。是大迦旃延。于当来世。以诸供具。供养奉事八千亿佛。恭敬尊重。诸佛灭后。各起塔庙高千由旬。纵广正等五百由旬。以金银琉璃车磲马瑙真珠玫瑰七宝合成。众华璎珞。涂香末香烧香。缯盖幢幡供养塔庙。过是已后。当复供养二万亿佛。亦复如是。供养是诸佛已。具菩萨道当得作佛。号曰阎浮那提金光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其土平正。颇梨为地。宝树庄严。黄金为绳以界道侧。妙华覆地周遍清净。见者欢喜。无四恶道。地狱饿鬼畜生阿修罗道。多有天人。诸声闻众。及诸菩萨。无量万亿。庄严其国。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫尔时世尊。欲重宣此义。而说偈言

  诸比丘众　　皆一心听　　如我所说
  真实无异　　是迦旃延　　当以种种
  妙好供具　　供养诸佛　　诸佛灭后
  起七宝塔　　亦以华香　　供养舍利
  其最后身　　得佛智慧　　成等正觉
  国土清净　　度脱无量　　万亿众生
  皆为十方　　之所供养　　佛之光明
  无能胜者　　其佛号曰　　阎浮金光
  菩萨声闻　　断一切有　　无量无数
  庄严其国

尔时世尊复告大众。我今语汝。是大目犍连。当以种种供具供养八千诸佛。恭敬尊重。诸佛灭后。各起塔庙高千由旬。纵广正等五百由旬。以金银琉璃车磲马瑙真珠玫瑰七宝合成。众华缨络。涂香末香烧香。缯盖幢幡。以用供养。过是已后。当复供养二百万亿诸佛。亦复如是。当得成佛。号曰多摩罗跋栴檀香如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名喜满。国名意乐。其土平正。颇梨为地宝树庄严。散真珠华周遍清净。见者欢喜。多诸天人。菩萨声闻其数无量。佛寿二十四小劫。正法住世四十小劫。像法亦住四十小劫。尔时世尊。欲重宣此义而说偈言

  我此弟子　　大目犍连　　舍是身已
  得见八千　　二百万亿　　诸佛世尊
  为佛道故　　供养恭敬　　于诸佛所
  常修梵行　　于无量劫　　奉持佛法
  诸佛灭度　　起七宝塔　　长表金刹
  花香伎乐　　而以供养　　诸佛塔庙
  渐渐具足　　菩萨道已　　于意乐国
  而得作佛　　号多摩罗　　栴檀之香
  其佛寿命　　二十四劫　　常为天人
  演说佛道　　声闻无量　　如恒河沙
  三明六通　　有大威德　　菩萨无数
  志固精进　　于佛智慧　　皆不退转
  佛灭度后　　正法当住　　四十小劫
  像法亦尔　　我诸弟子　　威德具足
  其数五百　　皆当授记　　于未来世
  咸得成佛　　我及汝等　　宿世因缘
  吾今当说　　汝等善听

    添品妙法莲华经化城喻品第七

佛告诸比丘乃往过去无量无边。不可思议阿僧祇劫。尔时有佛。名大通智胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其国名好成。劫名大相。诸比丘。彼佛灭度已来甚大久远。譬如三千大千世界所有地种。假使有人磨以为墨。过于东方千国土。乃下一点。大如微尘。又过千国土。复下一点。如是展转尽地种墨。于汝等意云何。是诸国土。若算师若算师弟子。能得边际知其数不。不也世尊。诸比丘。是人所经国土。若点不点。尽末为尘。一尘一劫。彼佛灭度已来。复过是数。无量无边百千万亿阿僧祇劫。我以如来知见力故。观彼久远犹若今日。尔时世尊。欲重宣此义。而说偈言

  我念过去世　　无量无边劫
  有佛两足尊　　名大通智胜
  如人以力磨　　三千大千土
  尽此诸地种　　皆悉以为墨
  过于千国土　　乃下一尘点
  如是展转点　　尽此诸尘墨
  如是诸国土　　点与不点等
  复尽末为尘　　一尘为一劫
  此诸微尘数　　其劫复过是
  彼佛灭度来　　如是无量劫
  如来无碍智　　知彼佛灭度
  及声闻菩萨　　如见今灭度
  诸比丘当知　　佛智净微妙
  无漏无所碍　　通达无量劫

佛告诸比丘。大通智胜佛。寿五百四十万亿那由他劫。其佛本坐道场破魔军已。垂得阿耨多罗三藐三菩提。而诸佛法不现在前。如是一小劫乃至十小劫。结跏趺坐身心不动。而诸佛法犹不在前。尔时忉利诸天。先为彼佛。于菩提树下敷师子座。高一由旬。佛于此坐当得阿耨多罗三藐三菩提。适坐此座。时诸梵天王。雨众天华。面百由旬。香风时来吹去萎华更雨新者。如是不绝满十小劫供养于佛。乃至灭度常雨此华。四王诸天为供养佛常击天鼓。其余诸天作天伎乐。满十小劫至于灭度。亦复如是。诸比丘。大通智胜佛。过十小劫。诸佛之法乃现在前。成阿耨多罗三藐三菩提。其佛未出家时有十六子。其第一者名曰智积。诸子各有种种珍异玩好之具。闻父得成阿耨多罗三藐三菩提。皆舍所珍往诣佛所。诸母涕泣而随送之。其祖转轮圣王。与一百大臣及余百千万亿人民。皆共围绕随至道场。咸欲亲近大通智胜如来。供养恭敬尊重赞叹。到已头面礼足。绕佛毕已。一心合掌瞻仰尊颜。以偈颂曰

  大威德世尊　　为度众生故
  于无量亿岁　　尔乃得成佛
  诸愿已具足　　善哉吉无上
  世尊甚希有　　一坐十小劫
  身体及手足　　静然安不动
  其心常惔怕　　未曾有散乱
  究竟永寂灭　　安住无漏法
  今者见世尊　　安隐成佛道
  我等得善利　　称庆大欢喜
  众生常苦恼　　盲冥无导师
  不识苦尽道　　不知求解脱
  长夜增恶趣　　减损诸天众
  从冥入于冥　　永不闻佛名
  今佛得最上　　安隐无漏道
  我等及天人　　为得最大利
  是故咸稽首　　归命无上尊

尔时十六王子。偈赞佛已。劝请世尊转于法轮。咸作是言。世尊说法多所安隐。怜愍饶益诸天人民。重说偈言

  世雄无等伦　　百福自庄严
  得无上智慧　　愿为世间说
  度脱于我等　　及诸众生类
  为分别显示　　令得是智慧
  若我等得佛　　众生亦复然
  世尊知众生　　深心之所念
  亦知所行道　　又知智慧力
  欲乐及修福　　宿命所行业
  世尊悉知已　　当转无上轮

佛告诸比丘。大通智胜佛。得阿耨多罗三藐三菩提时。十方各五百万亿诸佛世界六种震动。其国中间幽冥之处。日月威光所不能照。而皆大明。其中众生各得相见。咸作是言。此中云何忽生众生。又其国界诸天宫殿。乃至梵宫六种震动。大光普照遍满世界。胜诸天光。尔时东方五百万亿诸国土中。梵天宫殿光明照曜。倍于常明。诸梵天王各作是念。今者宫殿光明昔所未有。以何因缘而现此相。是时诸梵天王。即各相诣共议此事。时彼众中。有一大梵天王。名救一切。为诸梵众。而说偈言

  我等诸宫殿　　光明昔未有
  此是何因缘　　宜可共求之
  为大德天生　　为佛出世间
  而此大光明　　遍照于十方

尔时五百万亿国土诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣西方推寻是相。见大通智胜如来。处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。即时诸梵天王头面礼佛绕百千匝。即以天华而散佛上。其所散华如须弥山。并以供养佛菩提树。其菩提树高十由旬。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳受。尔时诸梵天王。即于佛前一心同声。以偈颂曰

  世尊甚希有　　难可得值遇
  具无量功德　　能救护一切
  天人之大师　　哀愍于世间
  十方诸众生　　普皆蒙饶益
  我等所从来　　五百万亿国
  舍深禅定乐　　为供养佛故
  我等先世福　　宫殿甚严饰
  今以奉世尊　　唯愿哀纳受

尔时诸梵天王。偈赞佛已各作是言。唯愿世尊。转于法轮度脱众生。开涅槃道。时诸梵天王。一心同声。而说偈言

  世雄两足尊　　唯愿演说法
  以大慈悲力　　度苦恼众生

尔时大通智胜如来默然许之。又诸比丘。东南方五百万亿国土诸大梵王。各自见宫殿光明照曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。时彼众中。有一大梵天王。名曰大悲。为诸梵众。而说偈言

  是事何因缘　　而现如此相
  我等诸宫殿　　光明昔未有
  为大德天生　　为佛出世间
  未曾见此相　　当共一心求
  过千万亿土　　寻光共推之
  多是佛出世　　度脱苦众生

尔时五百万亿诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣西北方推寻是相。见大通智胜如来。处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之华如须弥山。并以供养佛菩提树。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳处。尔时诸梵天王。即于佛前。一心同声。以偈颂曰

  圣主天中王　　迦陵频伽声
  哀愍众生者　　我等今敬礼
  世尊甚希有　　久远乃一现
  一百八十劫　　空过无有佛
  三恶道充满　　诸天众减少
  今佛出于世　　为众生作眼
  世间所归趣　　救护于一切
  为众生之父　　哀愍饶益者
  我等宿福庆　　今得值世尊

尔时诸梵天王。偈赞佛已。各作是言。唯愿世尊。哀愍一切。转于法轮度脱众生。时诸梵天王。一心同声。而说偈言

  大圣转法轮　　显示诸法相
  度苦恼众生　　令得大欢喜
  众生闻是法　　得道若生天
  诸恶道减少　　忍善者增益

尔时大通智胜如来默然许之。又诸比丘。南方五百万亿国土诸大梵天。各自见宫殿光明照曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。以何因缘。我等宫殿有此光明。时彼众中有一大梵大王名曰妙法。为诸梵众。而说偈言

  我等诸宫殿　　光明甚威曜
  此非无因缘　　是相宜求之
  过于百千劫　　未曾见是相
  为大德天生　　为佛出世间

尔时五百万亿诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣北方推寻是相。见大通智胜如来。处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之华如须弥山。并以供养佛菩提树。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳处。尔时诸梵天王。即于佛前。一心同声。以偈颂曰

  世尊甚难见　　破诸烦恼者
  过百三十劫　　今乃得一见
  诸饥渴众生　　以法雨充满
  昔所未曾睹　　无量智慧者
  如优昙钵罗　　今日乃值遇
  我等诸宫殿　　蒙光故严饰
  世尊大慈愍　　唯愿垂纳受

尔时诸梵天王。偈赞佛已。各作是言。唯愿世尊。转于法轮。令一切世间诸天魔梵沙门婆罗门。皆获安隐而得度脱。时诸梵天王。一心同声而说偈言

  惟愿天人尊　　转无上法轮
  击于大法鼓　　而吹大法螺
  普雨大法雨　　度无量众生
  我等咸归请　　当演深远音

尔时大通智胜如来默然许之。西南方乃至下方亦复如是

尔时上方五百万亿国土诸梵天王。皆悉自睹所止宫殿。光明威曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。以何因缘。我等宫殿有斯光明。时彼众中。有一大梵天王。名曰尸弃。为诸梵众。而说偈言

  今以何因缘　　我等诸宫殿
  威德光明曜　　严饰未曾有
  如是之妙相　　昔所不闻见
  为大德天生　　为佛出世间

尔时五百万亿诸梵天王与宫殿俱。各以衣裓盛诸天华。共诣下方推寻此相。见大通智胜如来。处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之华如须弥山。并以供养佛菩提树。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳处。尔时诸梵天王。即于佛前。一心同声。以偈颂曰

  善哉见诸佛　　救世之圣尊
  能于三界狱　　勉出诸众生
  普智天人尊　　哀愍群萌类
  能开甘露门　　广度于一切
  于昔无量劫　　空过无有佛
  世尊未出时　　十方常闇冥
  三恶道增长　　阿修罗亦盛
  诸天众转减　　死多堕恶道
  不从佛闻法　　常行不善事
  色力及智慧　　斯等皆减少
  罪业因缘故　　失乐及乐想
  住于邪见法　　不识善仪则
  不蒙佛所化　　常堕于恶道
  佛为世间眼　　久远时乃出
  哀愍诸众生　　故现于世间
  超出成正觉　　我等甚欣庆
  及余一切众　　喜叹未曾有
  我等诸宫殿　　蒙光故严饰
  今以奉世尊　　唯垂哀纳受
  愿以此功德　　普及于一切
  我等与众生　　皆共成佛道

尔时五百万亿诸梵天王。偈赞佛已各白佛言。唯愿世尊。转于法轮。多所安隐。多所度脱。时诸梵天王。一心同声。而说偈言

  世尊转法轮　　击甘露法鼓
  度苦恼众生　　开示涅槃道
  唯愿受我请　　以大微妙音
  哀愍而敷演　　无量劫集法

尔时大通智胜如来。受十方诸梵天王。及十六王子请。即时三转十二行法轮。若沙门婆罗门。若天魔梵及余世间。所不能转。谓是苦。是苦集。是苦灭。是苦灭道。及广说十二因缘法。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。佛于天人大众之中说是法时。六百万亿那由他人。以不受一切法故。而于诸漏心得解脱。皆得深妙禅定。三明六通具八解脱。第二第三第四说法时。千万亿恒河沙那由他等众生。亦以不受一切法故。而于诸漏心得解脱从是已后诸声闻众。无量无边不可称数。尔时十六王子。皆以童子出家而为沙弥。诸根通利智慧明了。已曾供养百千万亿诸佛。净修梵行。求阿耨多罗三藐三菩提。俱白佛言。世尊。是诸无量千万亿大德声闻皆已成就。世尊。亦当为我等说阿耨多罗三藐三菩提法。我等闻已皆共修学。世尊。我等悉愿如来知见。深心所念。佛自证知。尔时转轮圣王。所将众中八万亿人。见十六王子出家。亦求出家。王即听许。尔时彼佛受沙弥请。过二万劫已。乃于四众之中。说是大乘经。名妙法莲华教菩萨法佛所护念。说是经已。十六沙弥。为阿耨多罗三藐三菩提故。皆共受持讽诵通利。说是经时。十六菩萨沙弥皆悉信受。声闻众中亦有信解。其余众生千万亿种皆生疑惑。佛说是经。于八千劫未曾休废。说此经已即入静室。住于禅定八万四千劫。是时十六菩萨沙弥。知佛入室寂然禅定。各升法座。亦于八万四千劫。为四部众。广说分别妙法华经。一一皆度六百万亿那由他恒河沙等众生。示教利喜。令发阿耨多罗三藐三菩提心。大通智胜佛。过八万四千劫已。从三昧起。往诣法座。安详而坐。普告大众。是十六菩萨沙弥。甚为希有。诸根通利智慧明了。已曾供养无量千万亿数诸佛。于诸佛所常修梵行。受持佛智开示众生。令入其中。汝等皆当数数亲近而供养之。所以者何。若声闻辟支佛及诸菩萨。能信是十六菩萨所说经法受持不毁者。是人皆当得阿耨多罗三藐三菩提如来之慧。佛告诸比丘。是十六菩萨。常乐说是妙法华经。一一菩萨所化。六百万亿那由他恒河沙等众生。世世所生与菩萨俱。从其闻法悉皆信解。以此因缘。得值四万亿诸佛世尊。于今不尽。诸比丘。我今语汝。彼佛弟子十六沙弥。今皆得阿耨多罗三藐三菩提。于十方国土现在说法。有无量百千万亿菩萨声闻。以为眷属。其二沙弥东方作佛。一名阿閦。在欢喜国。二名须弥顶。东南方二佛。一名师子音。二名师子相。南方二佛。一名虚空住。二名常灭。西南方二佛。一名帝相。二名梵相。西方二佛。一名阿弥陀。二名度一切世间苦恼。西北方二佛。一名多摩罗跋旃檀香神通。二名须弥相。北方二佛。一名云自在。二名云自在王。东北方佛。名坏一切世间怖畏。第十六我释迦牟尼佛。于娑婆国土。成阿耨多罗三藐三菩提。诸比丘。我等为沙弥时。各各教化无量百千万亿恒河沙等众生。从我闻法。为阿耨多罗三藐三菩提。此诸众生。于今有住声闻地者。我常教化阿耨多罗三藐三菩提。是诸人等。应以是法渐入佛道。所以者何。如来智慧难信难解。尔时所化无量恒河沙等众生者。汝等诸比丘及我灭度后。未来世中声闻弟子是也。我灭度后。复有弟子不闻是经。不知不觉菩萨所行。自于所得功德。生灭度想。当入涅槃。我于余国作佛。更有异名。是人虽生灭度之想入于涅槃。而于彼土求佛智慧。得闻是经。唯以佛乘而得灭度。更无余乘。除诸如来方便说法。诸比丘。若如来自知涅槃时到。众又清净信解坚固。了达空法深入禅定。便集诸菩萨及声闻众。为说是经。世间无有二乘而得灭度。唯一佛乘得灭度耳。比丘当知。如来方便。深入众生之性。知其志乐小法深着五欲。为是等故说于涅槃。是人若闻则便信受。譬如五百由旬险难恶道。旷绝无人怖畏之处。若有多众欲过此道至珍宝处。有一导师聪慧明达。善知险道通塞之相。将导众人欲过此难。所将人众中路懈退。白导师言。我等疲极而复怖畏。不能复进。前路犹远。今欲退还。导师多诸方便。而作是念。此等可愍。云何舍大珍宝而欲退还。作是念已。以方便力。于险道中。过三百由旬。化作一城。告众人言。汝等勿怖。莫得退还。今此大城可于中止。随意所作。若入是城快得安隐。若能前至宝所亦可得去。是时疲极之众。心大欢喜叹未曾有。我等今者免斯恶道。快得安隐。于是众人前入化城。生已度想生安隐想。尔时导师。知此人众既得止息无复疲倦。即灭化城语众人言。汝等去来宝处在近。向者大城。我所化作为止息耳。诸比丘。如来亦复如是。今为汝等作大导师。知诸生死烦恼恶道。险难长远应去应度。若众生但闻一佛乘者。则不欲见佛。不欲亲近。便作是念。佛道长远。久受勤苦乃可得成。佛知是心怯弱下劣。以方便力。而于中道。为止息故。说二涅槃。若众生住于二地。如来尔时即便为说。汝等所作未办。汝所住地近于佛慧。当观察筹量。所得涅槃。非真实也。但是如来方便之力。于一佛乘分别说三。如彼导师为止息故。化作大城。既知息已。而告之言。宝处在近。此城非实。我化作耳。尔时世尊。欲重宣此义。而说偈言

  大通智胜佛　　十劫坐道场
  佛法不现前　　不得成佛道
  诸天神龙王　　阿修罗众等
  常雨于天花　　以供养彼佛
  诸天击天鼓　　并作众伎乐
  香风吹萎花　　更雨新好者
  过十小劫已　　乃得成佛道
  诸天及世人　　心皆怀踊跃
  彼佛十六子　　皆与其眷属
  千万亿围绕　　俱行至佛所
  头面礼佛足　　而请转法轮
  圣师子法雨　　充我及一切
  世尊甚难值　　久远时一现
  为觉悟群生　　振动于一切
  东方诸世界　　五百万亿国
  梵宫殿光曜　　昔所未曾有
  诸梵见此相　　寻来至佛所
  散花以供养　　并奉上宫殿
  请佛转法轮　　以偈而赞叹
  佛知时未至　　受请默然坐
  三方及四维　　上下亦复尔
  散华奉宫殿　　请佛转法轮
  世尊甚难值　　愿以大慈悲
  广开甘露门　　转无上法轮
  无量慧世尊　　受彼众人请
  为宣种种法　　四谛十二缘
  无明至老死　　皆从生缘有
  如是众过患　　汝等应当知
  宣畅是法时　　六百万亿垓
  得尽诸苦际　　皆成阿罗汉
  第二说法时　　千万恒沙众
  于诸法不受　　亦得阿罗汉
  从是后得道　　其数无有量
  万亿劫算数　　不能得其边
  时十六王子　　出家作沙弥
  皆共请彼佛　　演说大乘法
  我等及营从　　皆当成佛道
  愿得如世尊　　慧眼第一净
  佛知童子心　　宿世之所行
  以无量因缘　　种种诸譬喻
  说六波罗蜜　　及诸神通事
  分别真实法　　菩萨所行道
  说是法华经　　如恒河沙偈
  彼佛说经已　　静室入禅定
  一心一处坐　　八万四千劫
  是诸沙弥等　　知佛禅未出
  为无量亿众　　说佛无上慧
  各各坐法座　　说是大乘经
  于佛宴寂后　　宣扬助法化
  一一沙弥等　　所度诸众生
  有六百万亿　　恒河沙等众
  彼佛灭度后　　是诸闻法者
  在在诸佛土　　常与师俱生
  是十六沙弥　　具足行佛道
  今现在十方　　各得成正觉
  尔时闻法者　　各在诸佛所
  其有住声闻　　渐教以佛道
  我在十六数　　曾亦为汝说
  是故以方便　　引汝趣佛慧
  以是本因缘　　今说法华经
  令汝入佛道　　慎勿怀惊惧
  譬如险恶道　　迥绝多毒兽
  又复无水草　　人所怖畏处
  无数千万众　　欲过此险道
  其路甚旷远　　经五百由旬
  时有一导师　　强识有智慧
  明了心决定　　在险济众难
  众人皆疲倦　　而白导师言
  我等今顿乏　　于此欲退还
  导师作是念　　此辈甚可愍
  如何欲退还　　而失大珍宝
  寻时思方便　　当设神通力
  化作大城郭　　庄严诸舍宅
  周匝有园林　　流渠及浴池
  重门高楼阁　　男女皆充满
  即作是化已　　慰众言勿惧
  汝等入此城　　各可随所乐
  诸人既入城　　心皆大欢喜
  皆生安隐想　　自谓已得度
  导师知已息　　集众而告言
  汝等当前进　　此是化城耳
  我见汝疲极　　中道欲退还
  故以方便力　　权化作此城
  汝今勤精进　　当共至宝所
  我亦复如是　　为一切导师
  见诸求道者　　中路而懈废
  不能度生死　　烦恼诸险道
  故以方便力　　为息说涅槃
  言汝等苦灭　　所作皆已办
  既知到涅槃　　皆得阿罗汉
  尔乃集大众　　为说真实法
  诸佛方便力　　分别说三乘
  唯有一佛乘　　息处故说二
  今为汝说实　　汝所得非灭
  为佛一切智　　当发大精进
  汝证一切智　　十力等佛法
  具三十二相　　乃是真实灭
  诸佛之导师　　为息说涅槃
  既知是息已　　引入于佛慧

添品妙法莲华经卷第三添品妙法莲华经卷第四

        隋天竺三藏阇那崛多共笈多译

    五百弟子授记品第八

尔时富楼那弥多罗尼子。从佛闻是智慧方便随宜说法。又闻授诸大弟子阿耨多罗三藐三菩提记。复闻宿世因缘之事。复闻诸佛有大自在神通之力。得未曾有心净踊跃。即从座起到于佛前头面礼足却住一面。瞻仰尊颜目不暂舍。而作是念。世尊甚奇特。所为希有。随顺世间若干种性。以方便知见而为说法。拔出众生处处贪着。我等于佛功德言不能宣。唯佛世尊。能知我等深心本愿。尔时佛告诸比丘。汝等见是富楼那弥多罗尼子不。我常称其于说法人中最为第一。亦常叹其种种功德。精勤护持助宣我法。能于四众示教利喜。具足解释佛之正法。而大饶益同梵行者。自舍如来无能尽其言论之辩。汝等勿谓富楼那但能护持助宣我法。亦于过去九十亿诸佛所。护持助宣佛之正法。于彼说法人中亦最第一。又于诸佛所说空法明了通达。得四无碍智。常能审谛清净说法。无有疑惑。具足菩萨神通之力。随其寿命常修梵行。彼佛世人咸皆谓之实是声闻。而富楼那。以斯方便饶益无量百千众生。又化无量阿僧祇人。令立阿耨多罗三藐三菩提。为净佛土故。常作佛事教化众生。诸比丘。富楼那亦于七佛说法人中而得第一。今于我所说法人中亦为第一。于贤劫中当来诸佛说法人中亦复第一。而皆护持助宣佛法。亦于未来护持助宣无量无边诸佛之法。教化饶益无量众生。令立阿耨多罗三藐三菩提。为净佛土故。常勤精进教化众生。渐渐具足菩萨之道。过无量阿僧祇劫。当于此土得阿耨多罗三藐三菩提。号曰法明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛以恒河沙等三千大千世界。为一佛土。七宝为地。地平如掌。无有山陵溪涧沟壑。七宝台观充满其中。诸天宫殿近处虚空。人天交接两得相见。无诸恶道亦无女人。一切众生皆以化生。无有淫欲得大神通。身出光明飞行自在。志念坚固精进智慧。普皆金色三十二相。而自庄严。其国众生常以二食。一者法喜食。二者禅悦食。有无量阿僧祇千万亿那由他诸菩萨众。得大神通四无碍智。善能教化众生之类。其声闻众。算数校计所不能知。皆得具足六通三明及八解脱。其佛国土。有如是等无量功德庄严成就。劫名宝明。国名善净。其佛寿命无量阿僧祇劫。法住甚久。佛灭度后。起七宝塔遍满其国。尔时世尊。欲重宣此义。而说偈言

  诸比丘谛听　　佛子所行道
  善学方便故　　不可得思议
  知众乐小法　　而畏于大智
  是故诸菩萨　　作声闻缘觉
  以无数方便　　化诸众生类
  自说是声闻　　去佛道甚远
  度脱无量众　　皆悉得成就
  虽小欲懈怠　　渐当令作佛
  内秘菩萨行　　外现是声闻
  少欲厌生死　　实自净佛土
  示众有三毒　　又现邪见相
  我弟子如是　　方便度众生
  若我具足说　　种种现化事
  众生闻是者　　心则怀疑惑
  今此富楼那　　于昔千亿佛
  勤修所行道　　宣护诸佛法
  为求无上慧　　而于诸佛所
  现居弟子上　　多闻有智慧
  所说无所畏　　能令众欢喜
  未曾有疲倦　　而以助佛事
  已度大神通　　具四无碍慧
  知众根利钝　　常说清净法
  演畅如是义　　教诸千亿众
  令住大乘法　　而自净佛土
  未来亦供养　　无量无数佛
  护助宣正法　　亦自净佛土
  常以诸方便　　说法无所畏
  度不可计众　　成就一切智
  供养诸如来　　护持法宝藏
  其后得成佛　　号名曰法明
  其国名善净　　七宝所合成
  劫名为宝明　　菩萨众甚多
  其数无有量　　皆度大神通
  威德力具足　　充满其国土
  声闻亦无数　　三明八解脱
  得四无碍智　　以是等为僧
  其国诸众生　　淫欲皆已断
  纯一变化生　　具相庄严身
  法喜禅悦食　　更无余食想
  无有诸女人　　亦无诸恶道
  富楼那比丘　　功德悉成满
  当得斯净土　　贤圣众甚多
  如是无量事　　我今但略说

尔时千二百阿罗汉心自在者作是念。我等欢喜得未曾有。若世尊各见授记如余大弟子者。不亦快乎。佛知此等心之所念。告摩诃迦叶。是千二百阿罗汉。我今当现前次第与授阿耨多罗三藐三菩提记。于此众中。我大弟子憍陈如比丘。当供养六万二千亿佛。然后得成为佛。号曰普明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其五百阿罗汉沤楼频螺迦叶。伽耶迦叶。那提迦叶。迦留陀夷。优陀夷。阿[少/兔]楼驮。离波多。劫宾那。薄拘罗。周陀莎伽陀等。皆当得阿耨多罗三藐三菩提。尽同一号。名曰普明。尔时世尊。欲重宣此义。而说偈言

  憍陈如比丘　　当见无量佛
  过阿僧祇劫　　乃成等正觉
  常放大光明　　具足诸神通
  名闻遍十方　　一切之所敬
  常说无上道　　故号为普明
  其国土清净　　菩萨皆勇猛
  咸升妙楼阁　　游诸十方国
  以无上供具　　奉献于诸佛
  作是供养已　　心怀大欢喜
  须臾还本国　　有如是神力
  佛寿六万劫　　正法住倍寿
  像法复倍是　　法灭天人忧
  其五百比丘　　次第当作佛
  同号曰普明　　转次而授记
  我灭度之后　　某甲当作佛
  其所化世间　　亦如我今日
  国土之严净　　及诸神通力
  菩萨声闻众　　正法及像法
  寿命劫多少　　皆如上所说
  迦叶汝已知　　五百自在者
  余诸声闻众　　亦当复如是
  其不在此会　　汝当为宣说

尔时五百阿罗汉。于佛前得授记已。欢喜踊跃。即从座起到于佛前。头面礼足悔过自责。世尊。我等常作是念。自谓已得究竟灭度。今乃知之。如无智者。所以者何。我等应得如来智慧。而便自以小智为足。世尊。譬如有人至亲友家醉酒而卧。是时亲友官事当行。以无价宝珠系其衣里与之而去。其人醉卧都不觉知。起已游行到于他国。为衣食故。勤力求索甚大艰难。若少有所得便以为足。于后亲友会遇见之。而作是言。咄哉丈夫。何为衣食乃至如是。我昔欲令汝得安乐五欲自恣。于某年日月。以无价宝珠系汝衣里。今故现在。而汝不知。勤苦忧恼以求自活。甚为痴也。汝今可以此宝贸易所须。常可如意无所乏短。佛亦如是。为菩萨时教化我等。令发一切智心。而寻废忘不知不觉。既得阿罗汉道。自谓灭度。资生艰难得少为足。一切智愿犹在不失。今者世尊觉悟我等。作如是言。诸比丘。汝等所得非究竟灭。我久令汝等种佛善根。以方便故示涅槃相。而汝谓为实得灭度。世尊。我今乃知实是菩萨。得授阿耨多罗三藐三菩提记。以是因缘。甚大欢喜得未曾有。尔时阿若憍陈如等。欲重宣此义而说偈言

  我等闻无上　　安隐授记声
  欢喜未曾有　　礼无量智佛
  今于世尊前　　自悔诸过咎
  于无量佛宝　　得少涅槃分
  如无智愚人　　便自以为足
  譬如贫穷人　　往至亲友家
  其家甚大富　　具设诸肴膳
  以无价宝珠　　系着内衣里
  默与而舍去　　时卧不觉知
  是人既已起　　游行诣他国
  求衣食自济　　资生甚艰难
  得少便为足　　更不愿好者
  不觉内衣里　　有无价宝珠
  与珠之亲友　　后见此贫人
  苦切责之已　　示以所系珠
  贫人见此珠　　其心大欢喜
  富有诸财物　　五欲而自恣
  我等亦如是　　世尊于长夜
  常愍见教化　　令种无上愿
  我等无智故　　不觉亦不知
  得少涅槃分　　自足不求余
  今佛觉悟我　　言非实灭度
  得佛无上慧　　尔乃为真灭
  我今从佛闻　　授记庄严事
  及转次受决　　身心遍欢喜

    添品妙法莲华经授学无学人记品第九

尔时阿难罗睺罗。而作是念。我等每自思惟。设得授记。不亦快乎。即从座起到于佛前。头面礼足。俱白佛言。世尊。我等于此亦应有分。唯有如来我等所归。又我等为一切世间天人阿修罗所见知识。阿难常为侍者护持法藏。罗睺罗是佛之子。若佛见授阿耨多罗三藐三菩提记者。我愿既满众望亦足。尔时学无学声闻弟子二千人。皆从座起。偏袒右肩到于佛前。一心合掌瞻仰世尊。如阿难罗睺罗所愿。住立一面。尔时佛告阿难。汝于来世当得作佛。号山海慧自在通王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。当供养六十二亿诸佛护持法藏。然后得阿耨多罗三藐三菩提。教化二十千万亿恒河沙诸菩萨等。令成阿耨多罗三藐三菩提。国名常立胜幡。其土清净琉璃为地。劫名妙音遍满。其佛寿命。无量千万亿阿僧祇劫。若人于千万亿无量阿僧祇劫中。算数校计不能得知。正法住世倍于寿命。像法住世复倍正法。阿难。是山海慧自在通王佛。为十方无量千万亿恒河沙等。诸佛如来所共赞叹称其功德。尔时世尊。欲重宣此义。而说偈言

  我今僧中说　　阿难持法者
  当供养诸佛　　然后成正觉
  号曰山海慧　　自在通王佛
  其国土清净　　名常立胜幡
  教化诸菩萨　　其数如恒沙
  佛有大威德　　名闻满十方
  寿命无有量　　以愍众生故
  正法倍寿命　　像法复倍是
  如恒河沙等　　无数诸众生
  于此佛法中　　种佛道因缘

尔时会中。新发意菩萨八千人。咸作是念。我等尚不闻诸大菩萨得如是记。有何因缘。而诸声闻得如是决。尔时世尊知诸菩萨心之所念。而告之曰。诸善男子。我与阿难等。于空王佛所。同时发阿耨多罗三藐三菩提心。阿难常乐多闻。我常勤精进。是故我已得成阿耨多罗三藐三菩提。而阿难护持我法。亦护将来诸佛法藏。教化成就诸菩萨众。其本愿如是。故获斯记。阿难面于佛前。自闻授记及国土庄严。所愿具足。心大欢喜。得未曾有。即时忆念过去无量千万亿诸佛法藏。通达无碍如今所闻。亦识本愿尔时阿难而说偈言

  世尊甚希有　　令我念过去
  无量诸佛法　　如今日所闻
  我今无复疑　　安住于佛道
  方便为侍者　　护持诸佛法

尔时佛告罗睺罗。汝于来世当得作佛。号蹈七宝华如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。当供养十世界微尘等数诸佛如来。常为诸佛而作长子犹如今也。是蹈七宝华佛。国土庄严。寿命劫数。所化弟子。正法像法。亦如山海慧自在通王如来无异。亦为此佛而作长子。过是已后。当得阿耨多罗三藐三菩提。尔时世尊。欲重宣此义。而说偈言

  我为太子时　　罗睺为长子
  我今成佛道　　受法为法子
  于未来世中　　见无量亿佛
  皆为其长子　　一心求佛道
  罗睺罗密行　　惟我能知之
  现为我长子　　以示诸众生
  无量亿千万　　功德不可数
  安住于佛法　　以求无上道

尔时世尊。见学无学二千人。其意柔软。寂然清净一心观佛。佛告阿难。汝见是学无学二千人不。唯然已见。阿难。是诸人等。当供养五十世界微尘数诸佛如来。恭敬尊重护持法藏。末后同时。于十方国各得成佛。皆同一号。名曰宝相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。寿命一劫。国土庄严。声闻菩萨。正法像法。皆悉同等。尔时世尊欲重宣此义。而说偈言

  是二千声闻　　今于我前住
  悉皆与授记　　未来当成佛
  所供养诸佛　　如上说尘数
  护持其法藏　　后当成正觉
  各于十方国　　悉同一名号
  俱时坐道场　　以证无上慧
  皆名为宝相　　国土及弟子
  正法与像法　　悉等无有异
  咸以诸神通　　度十方众生
  名闻普周遍　　渐入于涅槃

尔时学无学二千人。闻佛授记欢喜踊跃。而说偈言

  世尊慧灯明　　我闻授记音
  心欢喜充满　　如甘露见灌

    添品妙法莲华经法师品第十

尔时世尊。因药王菩萨。告八万大士。药王。汝见是大众中。无量诸天龙王夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。及比丘比丘尼优婆塞优婆夷。求声闻者。求辟支佛者。求佛道者。如是等类。咸于佛前。闻妙法华经一偈一句乃至一念随喜者。我皆与授记。当得阿耨多罗三藐三菩提。佛告药王。又如来灭度之后。若有人闻妙法华经乃至一偈一句一念随喜者。我亦与授阿耨多罗三藐三菩提记。若复有人。受持读诵解说书写妙法华经乃至一偈。于此经卷敬视如佛。种种供养华香璎珞。末香涂香烧香。缯盖幢幡衣服伎乐。乃至合掌恭敬。药王当知。是诸人等。已曾供养十万亿佛。于诸佛所成就大愿。愍众生故生此人间。药王。若有人问。何等众生。于未来世当得作佛。应示是诸人等于未来世必得作佛。何以故。若善男子善女人。于法华经乃至一句。受持读诵解说书写。种种供养经卷。华香璎珞末香涂香烧香。缯盖幢幡衣服伎乐。合掌恭敬。是人一切世间所应瞻奉。应以如来供养而供养之。当知此人是大菩萨。成就阿耨多罗三藐三菩提。哀愍众生愿生此间。广演分别妙法花经。何况尽能受持种种供养者。药王当知。是人自舍清净业报。于我灭度后。愍众生故。生于恶世广演此经。若是善男子善女人。我灭度后。能窃为一人说法华经。乃至一句。当知是人。则如来使。如来所遣。行如来事。何况于大众中广为人说。药王。若有恶人。以不善心。于一劫中。现于佛前常毁骂佛。其罪尚轻。若人以一恶言。毁呰在家出家读诵法华经者。其罪甚重。药王。其有读诵法华经者。当知是人。以佛庄严而自庄严。则为如来肩所荷担。其所至方。应随向礼一心合掌。恭敬供养尊重赞叹。华香璎珞。末香涂香烧香。缯盖幢幡衣服肴馔。作诸伎乐。人中上供而供养之。应持天宝而以散之。天上宝聚应以奉献。所以者何。是人欢喜说法。须臾闻之。即得究竟阿耨多罗三藐三菩提故。尔时世尊。欲重宣此义。而说偈言

  若欲住佛道　　成就自然智
  常当勤供养　　受持法花者
  其有欲疾得　　一切种智慧
  当受持是经　　并供养持者
  若有能受持　　妙法华经者
  当知佛所使　　愍念诸众生
  诸有能受持　　妙法华经者
  舍于清净土　　愍众故生此
  当知如是人　　自在所欲生
  能于此恶世　　广说无上法
  应以天华香　　及天宝衣服
  天上妙宝聚　　供养说法者
  吾灭后恶世　　能持是经者
  当合掌礼敬　　如供养世尊
  上馔众甘美　　及种种衣服
  供养是佛子　　冀得须臾闻
  若能于后世　　受持是经者
  我遣在人中　　行于如来事
  若于一劫中　　常怀不善心
  作色而骂佛　　获无量重罪
  其有读诵持　　是法华经者
  须臾加恶言　　其罪复过彼
  有人求佛道　　而于一劫中
  合掌在我前　　以无数偈赞
  由是赞佛故　　得无量功德
  叹美持经者　　其福复过彼
  于八十亿劫　　以最妙色声
  及与香味触　　供养持经者
  如是供养已　　若得须臾闻
  则应自欣庆　　我今获大利
  药王今告汝　　我所说诸经
  而于此经中　　法华最第一

尔时佛复告药王菩萨摩诃萨。我所说经典。无量千万亿。已说今说当说。而于其中。此法华经。最为难信难解。药王。此经是诸佛秘要之藏。不可分布妄授与人。诸佛世尊之所守护。从昔已来未曾显说。如此经者。如来现在。犹多怨嫉。况灭度后。药王当知。如来灭后。其能书持读诵供养为他人说者。如来则为。以衣覆之。又为他方现在诸佛之所护念。是人有大信力及志愿力诸善根力。当知是人与如来共宿。则为如来手摩其头。药王。在在处处。若说若读若诵若书。若经卷所住处皆应起七宝塔。极令高广严饰。不须复安舍利。所以者何。此中已有如来全身。此塔应以一切华香璎珞缯盖幢幡伎乐歌颂。供养恭敬尊重赞叹。若有人得见此塔礼拜供养。当知是等。皆近阿耨多罗三藐三菩提。药王。多有人在家出家行菩萨道。若不能得见闻读诵书持供养是法华经者。当知是人未善行菩萨道。若有得闻是经典者。乃能善行菩萨之道。其有众生求佛道者。若见若闻是法华经。闻已信解受持者。当知是人。得近阿耨多罗三藐三菩提。药王。譬如有人渴乏须水。于彼高原穿凿求之。犹见干土知水尚远。施功不已转见湿土。遂渐至泥。其心决定知水必近。菩萨亦复如是。若未闻未解未能修习是法华经。当知是人。去阿耨多罗三藐三菩提尚远。若得闻解思惟修习。必知得近阿耨多罗三藐三菩提。所以者何。一切菩萨阿耨多罗三藐三菩提。皆属此经。此经开方便门示真实相。是法华经藏。深固幽远无人能到。今佛教化成就菩萨而为开示。药王。若有菩萨。闻是法华经惊疑怖畏。当知是为新发意菩萨。若声闻人。闻是经惊疑怖畏。当知是为增上慢者。药王。若有善男子善女人。如来灭后欲为四众说是法华经者。云何应说。是善男子善女人。入如来室着如来衣坐如来座。尔乃应为四众广说斯经。如来室者。一切众生中大慈悲心是。如来衣者。柔和忍辱心是。如来座者。一切法空是。安住是中。然后以不懈怠心。为诸菩萨及四众。广说是法华经。药王。我于余国遣化人。为其集听法众。亦遣化比丘比丘尼优婆塞优婆夷。听其说法。是诸化人。闻法信受随顺不逆。若说法者在空闲处。我时广遣天龙鬼神乾闼婆阿修罗等。听其说法。我虽在异国。时时令说法者得见我身。若于此经忘失句逗。我还为说令得具足。尔时世尊。欲重宣此义。而说偈言

  欲舍诸懈怠　　应当听是经
  此经难得闻　　信受者亦难
  如人渴须水　　穿凿于高原
  犹见干燥土　　知去水尚远
  渐见湿土泥　　决定知近水
  药王汝当知　　如是诸人等
  不闻法华经　　去佛智甚远
  若闻是深经　　决了声闻法
  是诸经之王　　闻已谛思惟
  当知此人等　　近于佛智慧
  若人说此经　　应入如来室
  着于如来衣　　而坐如来座
  处众无所畏　　广为分别说
  大慈悲为室　　柔和忍辱衣
  诸法空为座　　处此为说法
  若说此经时　　有人恶口骂
  加刀杖瓦石　　念佛故应忍
  我千万亿土　　现净坚固身
  于无量亿劫　　为众生说法
  若我灭度后　　能说此经者
  我遣化四众　　比丘比丘尼
  及清信士女　　供养于法师
  引导诸众生　　集之令听法
  若人欲加恶　　刀杖及瓦石
  则遣变化人　　为之作卫护
  若说法之人　　独在空闲处
  寂寞无人声　　读诵此经典
  我尔时为现　　清净光明身
  若忘失章句　　为说令通利
  若人具是德　　或为四众说
  空处读诵经　　皆得见我身
  若人在空闲　　我遣天龙王
  夜叉鬼神等　　为作听法众
  是人乐说法　　分别无挂碍
  诸佛护念故　　能令大众喜
  若亲近法师　　速得菩萨道
  随顺是师学　　得见恒沙佛

    添品妙法莲华经见宝塔品第十一

尔时佛前有七宝塔。高五百由旬。纵广二百五十由旬。从地踊出住在空中。种种宝物而庄挍之。五千栏楯龛室千万。无数幢幡以为严饰。垂宝璎珞宝铃万亿。而悬其上。四面皆出多摩罗跋栴檀之香。充遍世界。其诸幡盖。以金银琉璃砗磲马瑙真珠玫瑰七宝合成。高至四天王宫。三十三天。雨天曼陀罗华。供养宝塔。余诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等千万亿众。以一切华香璎珞幡盖伎乐。供养宝塔。恭敬尊重赞叹。尔时宝塔中出大音声叹言。善哉善哉。释迦牟尼世尊。能以平等大慧教菩萨法佛所护念妙法华经。为大众说。如是如是。释迦牟尼世尊。如所说者皆是真实。尔时四众见大宝塔住在空中。又闻塔中所出音声。皆得法喜怪未曾有。从座而起。恭敬合掌却住一面。尔时有菩萨摩诃萨。名大乐说。知一切世间天人阿修罗等心之所疑。而白佛言。世尊。以何因缘。有此宝塔从地踊出。又于其中发是音声。尔时佛告大乐说菩萨。此宝塔中有如来全身。乃往过去东方无量千万亿阿僧祇世界。国名宝净。彼中有佛。号曰多宝。其佛本行菩萨道时。作大誓愿。若我成佛灭度之后。于十方国土有说法华经处。我之塔庙。为听是经故。踊现其前。为作证明。赞言善哉。彼佛成道已临灭度时。于天人大众中告诸比丘。我灭度后。欲供养我全身者。应起一大塔。其佛以神通愿力。十方世界在在处处。若有说法华经者。彼之宝塔。皆踊出其前。全身在于塔中赞言。善哉善哉。大乐说。今多宝如来塔。闻说法华经故。从地踊出。赞言。善哉善哉。是时大乐说菩萨。以如来神力故。白佛言。世尊。我等愿欲见此佛身。佛告大乐说菩萨摩诃萨。是多宝佛。有深重愿。若我宝塔。为听法华经故。出于诸佛前时。其有欲以我身示四众者。彼佛分身诸佛。在于十方世界说法。尽还集一处。然后我身乃出现耳。大乐说。我分身诸佛。在于十方世界说法者。今应当集。大乐说白佛言。世尊。我等亦愿欲见世尊分身诸佛礼拜供养。尔时佛放白毫一光。即见东方五百万亿那由他恒河沙等国土诸佛。彼诸国土。皆以颇梨为地。宝树宝衣以为庄严。无数千万亿菩萨充满其中。遍张宝幔宝网罗上。彼国诸佛。以大妙音而说诸法。及见无量千万亿菩萨。遍满诸国为众说法。南西北方四维上下。白毫相光所照之处。亦复如是。尔时十方诸佛。各告众菩萨言。善男子。我今应往娑婆世界释迦牟尼佛所。并供养多宝如来宝塔。时娑婆世界。即变清净。琉璃为地宝树庄严。黄金为绳以界八道。无诸聚落村营城邑。大海江河山川林薮。烧大宝香。曼陀罗华遍布其地。以宝网幔罗覆其上。悬诸宝铃。唯留此会众。移诸天人置于他土。是时诸佛。各将一大菩萨以为侍者。至娑婆世界。各到宝树下。一一宝树高五百由旬。枝叶华果次第庄严。诸宝树下。皆有师子之座。高五由旬。亦以大宝而挍饰之。尔时诸佛。各于此座结加趺坐。如是展转。遍满三千大千世界。而于释迦牟尼佛一方所分之身。犹故未尽。时释迦牟尼佛。欲容受所分身诸佛故。八方各更变二百万亿那由他国。皆令清净。无有地狱饿鬼畜生及阿修罗。又移诸天人置于他土。所化之国。亦以琉璃为地。宝树庄严。树高五百由旬。枝叶华果次第严饰。树下皆有宝师子座。高五由旬。种种诸宝以为庄严。亦无大海江河。及目真邻陀山。摩诃目真邻陀山。铁围山。大铁围山。须弥山等诸山王。通为一佛国土。宝地平正。宝交露幔遍覆其上。悬诸幡盖烧大宝香。诸天宝华遍布其地。释迦牟尼佛。为诸佛当来坐故。复于八方。各更变二百万亿那由他国。皆令清净。无有地狱饿鬼畜生及阿修罗。又移诸天人置于他土所化之国。亦以琉璃为地。宝树庄严。树高五百由旬。枝叶花果次第庄严。树下皆有宝师子座。高五由旬。亦以大宝而挍饰之。亦无大海江河。及目真邻陀山。摩诃目真邻陀山。铁围山。大铁围山。须弥山等诸山王。通为一佛国土。宝地平正。宝交露幔遍覆其上。悬诸幡盖烧大宝香。诸天宝华遍布其地。尔时东方释迦牟尼所分之身。百千万亿那由他恒河沙等国土中诸佛。各各说法。来集于此。如是次第十方诸佛。皆悉来集。坐于八方。尔时一一方四百万亿那由他国土。诸佛如来遍满其中。是时诸佛各在宝树下坐师子座。皆遣侍者。问讯释迦牟尼佛。各赍宝华满掬。而告之言。善男子。汝往诣耆阇崛山释迦牟尼佛所。如我辞曰。少病少恼气力安乐。及菩萨声闻众。悉安隐不。以此宝华散佛供养。而作是言。彼某甲佛。与欲开此宝塔。诸佛遣使亦复如是。尔时释迦牟尼佛。见所分身佛悉已来集。各各坐于师子之座。皆闻诸佛与欲同开宝塔。即从座起住虚空中。一切四众起立合掌一心观佛。于是释迦牟尼佛以右指开七宝塔户。出大音声。如却关钥开大城门。即时一切众会。皆见多宝如来于宝塔中坐师子座。全身不散如入禅定。又闻其言。善哉善哉。释迦牟尼佛。快说是法华经。我为听是经故而来至此。尔时四众等。见过去无量千万亿劫灭度佛。说如是言。叹未曾有。以天宝华聚。散多宝佛及释迦牟尼佛上。尔时多宝佛。于宝塔中。分半座与释迦牟尼佛。而作是言。释迦牟尼佛。可就此座。即时释迦牟尼佛。入其塔中。坐其半座结加趺坐。尔时大众。见二如来在七宝塔中师子座上结加趺坐。各作是念。佛座高远。惟愿如来。以神通力。令我等辈俱处虚空。即时释迦牟尼佛。以神通力接诸大众。皆在虚空。以大音声普告四众。谁能于此娑婆国土。广说妙法华经。今正是时。如来不久当入涅槃。佛欲以此妙法华经付嘱有在。尔时世尊。欲重宣此义。而说偈言

  圣主世尊　　虽久灭度　　在宝塔中
  尚为法来　　诸人云何　　不勤为法
  此佛灭度　　无央数劫　　处处听法
  以难遇故　　彼佛本愿　　我灭度后
  在在所往　　常为听法　　又我分身
  无量诸佛　　如恒沙等　　来欲听法
  及见灭度　　多宝如来　　各舍妙土
  及弟子众　　天人龙神　　诸供养事
  令法久住　　故来至此　　为坐诸佛
  以神通力　　移无量众　　令国清净
  诸佛各各　　诣宝树下　　如清凉池
  莲花庄严　　其宝树下　　诸师子座
  佛坐其上　　光明严饰　　如夜闇中
  然大炬火　　身出妙香　　遍十方国
  众生蒙熏　　喜不自胜　　譬如大风
  吹小树枝　　以是方便　　令法久住
  告诸大众　　我灭度后　　谁能护持
  读说此经　　今于佛前　　自说誓言
  其多宝佛　　虽久灭度　　以大誓愿
  而师子吼　　多宝如来　　及与我身
  所集化佛　　当知此意　　诸佛子等
  谁能护法　　当发大愿　　令得久住
  其有能护　　此经法者　　则为供养
  我及多宝　　此多宝佛　　处于宝塔
  常游十方　　为是经故　　亦复供养
  诸来化佛　　庄严光饰　　诸世界者
  若说此经　　则为见我　　多宝如来
  及诸化佛　　诸善男子　　各谛思惟
  此为难事　　宜发大愿　　诸余经典
  数如恒沙　　虽说此等　　未足为难
  若接须弥　　掷置他方　　无数佛土
  亦未为难　　若以足指　　动大千界
  远掷他国　　亦未为难　　若立有顶
  为众演说　　无量余经　　亦未为难
  若佛灭后　　于恶世中　　能说此经
  是则为难　　假使有人　　手把虚空
  而以游行　　亦未为难　　于我灭后
  若自书持　　若使人书　　是则为难
  若以大地　　置足甲上　　升于梵天
  亦未为难　　佛灭度后　　于恶世中
  暂读此经　　是则为难　　假使劫烧
  担负干草　　入中不烧　　亦未为难
  我灭度后　　若持此经　　为一人说
  是则为难　　若持八万　　四千法藏
  十二部经　　为人演说　　令诸听者
  得六神通　　虽能如是　　亦未为难
  于我灭后　　听受此经　　问其义趣
  是则为难　　若人说法　　令千万亿
  无量无数　　恒沙众生　　得阿罗汉
  具六神通　　虽有是益　　亦未为难
  于我灭后　　若能奉持　　如斯经典
  是则为难　　我为佛道　　于无量土
  从始至今　　广说诸经　　而于其中
  此经第一　　若有能持　　则持佛身
  诸善男子　　于我灭后　　谁能受持
  读诵此经　　今于佛前　　自说誓言
  此经难持　　若暂持者　　我则欢喜
  诸佛亦然　　如是之人　　诸佛所叹
  是则勇猛　　是则精进　　是名持戒
  行头陀者　　则为疾得　　无上佛道
  能于来世　　读持此经　　是真佛子
  住纯善地　　佛灭度后　　能解其义
  是诸天人　　世间之眼　　于恐畏世
  能须臾说　　一切天人　　皆应供养

尔时佛告诸菩萨及天人四众。吾于过去无量劫中。求法华经无有懈倦。于多劫中常作国王。发愿求于无上菩提。心不退转。为欲满足六波罗蜜。勤行布施心无吝惜。象马七珍国城妻子奴婢仆从。头目髓脑身肉手足。不惜躯命。时世人民寿命无量。为于法故。捐舍国位委政太子。击鼓宣令四方求法。谁能为我说大乘者。吾当终身供给走使。时有仙人。来白王言。我有大乘。名妙法莲华。若不违我当为演说。王闻其言欢喜踊跃。即随仙人供给所须。采果汲水拾薪设食。乃至以身而为床座。身心无倦。于时奉事经于千岁。为于法故。精勤给使令无所乏。尔时世尊。欲重宣此义。而说偈言

  我念过去劫　　为求大法故
  虽作世国王　　不贪五欲乐
  捶钟告四方　　谁有大法者
  若为我解说　　身当为奴仆
  尔时有仙人　　来白大王言
  我有微妙法　　世间所希有
  若能修行者　　吾当为汝说
  时王闻仙言　　心生大欢喜
  即便随仙人　　供给于所欲
  采薪及果蓏　　随时恭敬与
  情存妙法故　　身心无懈倦
  普为诸众生　　勤求于大法
  亦不为己身　　及以五欲乐
  故为大国王　　勤求获此法
  遂致得成佛　　今故为汝说

佛告诸比丘。尔时王者。则我身是。时仙人者。今提婆达多是。由提婆达多善知识故。令我具足六波罗蜜慈悲喜舍。三十二相八十种好紫磨金色。十力四无所畏四摄法。十八不共神通道力。成等正觉广度众生。皆因提婆达多善知识故。告诸四众。提婆达多。却后过无量劫。当得成佛。号曰天王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名天道。时天王佛。住世二十中劫。广为众生说于妙法。恒河沙众生得阿罗汉果。无量众生发缘觉心。恒河沙众生发无上菩提心。得无生忍至不退转。时天王佛般涅槃后。正法住世二十中劫。全身舍利起七宝塔。高六十由旬。纵广四十由旬。诸天人民。悉以杂华涂香末香烧香衣服璎珞幢幡宝盖伎乐歌颂。礼拜供养七宝妙塔。无量众生得阿罗汉。无量众生悟辟支佛。不可思议众生发菩提心至不退转。佛告诸比丘。未来世中。若有善男子善女人。闻此妙法莲华经品。闻已净心信敬不生疑惑者。不堕地狱饿鬼畜生。生十方佛前。所生之处常闻此经。若生天人中受胜妙乐。若在佛前莲华化生。于时下方多宝世尊所从菩萨。名曰智积。白多宝佛。当还本土。释迦牟尼佛告智积曰。善男子。且待须臾。此有菩萨。名文殊师利。可与相见论说妙义。可还本土。尔时文殊师利。坐千叶莲华。大如车轮。俱来菩萨亦坐宝华。从于大海娑竭罗龙宫。自然踊出。住虚空中。诣灵鹫山。从莲华下至于佛所。头面敬礼二世尊足。修敬已毕。往智积所。共相慰问。却坐一面。智积菩萨问文殊师利。仁者往诣龙宫所化众生其数几何。文殊师利言。其数无量不可称计。非口所宣。非心所测。且待须臾。自当有证。所言未竟。无数菩萨。坐宝莲华从海踊出。诣灵鹫山住在虚空。此诸菩萨。皆是文殊师利之所化度。具菩萨道行。皆共论说六波罗蜜。本声闻人。在虚空中说声闻行。今皆修行大乘空义。文殊师利谓智积曰。于海所化其事如此。尔时智积菩萨以偈赞曰

  大智德勇健　　化度无量众
  今此诸大会　　及我皆已见
  演畅实相义　　开阐一乘法
  广度诸群生　　令速成菩提

文殊师利言。我于海中。唯常宣说妙法华经。智积问文殊师利言。此经甚深微妙。诸经中宝。世所希有。颇有众生。勤加精进修行此经。速得佛不。文殊师利言。有娑竭罗龙王女。年始八岁。智慧利根。善知众生诸根行业。得陀罗尼。诸佛所说甚深秘藏悉能受持。深入禅定了达诸法。于刹那顷发菩提心。得不退转。辩才无碍。慈念众生。犹如赤子。功德具足心念口演。微妙广大。慈悲仁让。志意和雅。能至菩提。智积菩萨言。我见释迦如来。于无量劫难行苦行。积功累德求菩提道。未曾止息。观三千大千世界。乃至无有如芥子许非是菩萨舍身命处。为众生故。然后乃得成菩提道。不信此女于须臾顷便成正觉言论未讫。时龙王女忽现于前。头面礼敬却住一面。以偈赞曰

  深达罪福相　　遍照于十方
  微妙净法身　　具相三十二
  以八十种好　　用庄严法身
  天人所戴仰　　龙神咸恭敬
  一切众生类　　无不宗奉者
  有闻成菩提　　唯佛当证知
  我阐大乘教　　度脱苦众生

尔时舍利弗语龙王女言。汝谓不久得无上道。是事难信。所以者何。女身垢秽非是法器。云何能得无上菩提。佛道玄旷经无量劫。勤苦积行具修诸度。然后乃成。又女人身犹有五障。一者不得作梵天王。二者不得作帝释。三者魔王。四者转轮圣王。五者佛身。云何女身速得成佛

尔时龙王女有一宝珠。价直三千大千世界。持以上佛。佛即受之。龙女谓智积菩萨尊者舍利弗言。我献此宝珠世尊纳受。是事疾不答言甚疾。女言。以汝神通力观我成佛。复速于此。当时众会。皆见龙女。忽然之间。变成男子具菩萨行。即往南方无垢世界。坐宝莲花成等正觉。三十二相八十种好。普为十方一切众生演说妙法。尔时娑婆世界菩萨声闻天龙八部人与非人。皆遥见彼龙女成佛普为时会人天说法。心大欢喜悉遥敬礼。无量众生闻法解悟。得不退转。无量众生得授道记。无垢世界六种振动。娑婆世界三千众生住不退地。三千众生发菩提心。而得授记。智积菩萨及舍利弗。一切大会。默然信受

    添品妙法莲华经劝持品第十二

尔时药王菩萨摩诃萨。及大乐说菩萨摩诃萨。与二万菩萨眷属俱皆于佛前作是誓言。唯愿世尊。不以为虑。我等于佛灭后。当奉持读诵说此经典。后恶世众生善根转少。多增上慢。贪利供养增不善根。远离解脱。虽难可教化。我等当起大忍力。读诵此经。持说书写种种供养。不惜身命。尔时众中。五百阿罗汉得授记者。白佛言。世尊。我等亦自誓愿。于异国土广说此经。复有学无学八千人得授记者。从座而起合掌向佛。作是誓言。世尊。我等亦当于他国土广说此经。所以者何。是娑婆国中。人多弊恶怀增上慢。功德浅薄嗔浊谄曲。心不实故。尔时佛姨母摩诃波阇波提比丘尼。与学无学比丘尼六千人俱。从座而起一心合掌。瞻仰尊颜目不暂舍。于时世尊告憍昙弥。何故忧色而视如来。汝心将无谓我不说汝名授阿耨多罗三藐三菩提记耶。憍昙弥。我先总说一切声闻皆已授记今汝欲知记者。将来之世。当于六万八千亿诸佛法中。为大法师。及六千学无学比丘尼。俱为法师。如是渐渐具菩萨道。当得作佛。号一切众生喜见如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。憍昙弥。是一切众生喜见佛。及六千菩萨转次授记。得阿耨多罗三藐三菩提

尔时罗睺罗母耶输陀罗比丘尼作是念。世尊。于授记中独不说我名。佛告耶输陀罗。汝于来世百千万亿诸佛法中。修菩萨行为大法师。渐具佛道。于善国中当得作佛。号具足千万光相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。佛寿无量阿僧祇劫。尔时摩诃波阇波提比丘尼。及耶输陀罗比丘尼。并其眷属。皆大欢喜得未曾有。即于佛前。而说偈言

  世尊导师　　安隐天人　　我等闻记
  心安具足

诸比丘尼说是偈已。白佛言。世尊。我等亦于他方国土广说斯经

尔时世尊。视八十万亿那由他诸菩萨摩诃萨。是诸菩萨。皆是阿鞞跋致。转不退法轮。得诸陀罗尼。即从座起至于佛前一心合掌而作是念。若世尊告敕我等持说此经者。当如佛教广宣斯法。复作是念。佛今默然不见告敕。我当云何。时诸菩萨敬顺佛意。并欲自满本愿。便于佛前作师子吼。而发誓言。世尊。我等于如来灭后。周旋往返十方世界。能令众生书写此经。受持读诵解说其义。如法修行正忆念皆是佛之威力。唯愿世尊。在于他方遥见守护。即时诸菩萨。俱同发声。而说偈言

  唯愿不为虑　　于佛灭度后
  恐怖恶世中　　我等当广说
  有诸无智人　　恶口骂詈等
  及加刀杖者　　我等皆当忍
  恶世中比丘　　邪智心谄曲
  未得谓为得　　我慢心充满
  或有阿练若　　纳衣在空闲
  自谓行真道　　轻贱人间者
  贪着利养故　　与白衣说法
  为世所恭敬　　如六通罗汉
  是人怀恶心　　常念世俗事
  假名阿练若　　好出我等过
  而作如是言　　此诸比丘等
  为贪利养故　　说外道论义
  自作此经典　　诳惑世间人
  为求名闻故　　分别于是经
  常在大众中　　欲毁我等故
  向国王大臣　　婆罗门居士
  及余比丘众　　诽谤说我恶
  谓是邪见人　　说外道论义
  我等敬佛故　　悉忍是诸恶
  为斯所轻言　　汝等皆是佛
  如此轻慢言　　皆当忍受之
  浊劫恶世中　　多有诸恐怖
  恶鬼入其身　　骂詈毁辱我
  我等敬信佛　　当着忍辱铠
  为说是经故　　忍此诸难事
  我不爱身命　　但惜无上道
  我等于来世　　护持佛所嘱
  世尊自当知　　浊世恶比丘
  不知佛方便　　随宜所说法
  恶口而嚬蹙　　数数见摈出
  远离于塔寺　　如是等众恶
  念佛告敕故　　皆当忍是事
  诸聚落城邑　　其有求法者
  我皆到其所　　说佛所嘱法
  我是世尊使　　处众无所畏
  我当善说法　　愿佛安隐住
  我于世尊前　　诸来十方佛
  发如是誓言　　佛悉知我心

添品妙法莲华经卷第四添品妙法莲华经卷第五

        隋天竺三藏阇那崛多共笈多译

    安乐行品第十三

尔时文殊师利法王子菩萨摩诃萨白佛言。世尊。是诸菩萨。甚为难有。敬顺佛故。发大誓愿。于后恶世护持读诵说是法华经。世尊。菩萨摩诃萨。于后恶世云何能说是经。佛告文殊师利。若菩萨摩诃萨。于后恶世欲说是经。当安住四法。一者安住菩萨行处亲近处。能为众生演说是经。文殊师利。云何名菩萨摩诃萨行处。若菩萨摩诃萨。住忍辱地。柔和善顺。而不卒暴。心亦不惊。又复于法无所行。而观诸法如实相。亦不行不分别。是名菩萨摩诃萨行处。云何名菩萨摩诃萨亲近处。菩萨摩诃萨。不亲近国王王子大臣官长。不亲近诸外道梵志尼干子等。及造世俗文笔赞咏外书。及路伽耶陀逆路伽耶陀者。亦不亲近诸有凶戏相叉相扑。及那罗等种种变现之戏。又不亲近旃陀罗及畜猪羊鸡狗畋猎渔捕诸恶律仪。如是人等或时来者。则为说法无所悕望。又不亲近求声闻比丘比丘尼优婆塞优婆夷。亦不问讯。若于房中。若经行处。若在讲堂中。不共住止。或时来者随宜说法。无所悕求。文殊师利。又菩萨摩诃萨。不应于女人身取能生欲想相而为说法。亦不乐见。若入他家。不与小女处女寡女等共语。亦复不近五种不男之人以为亲厚。不独入他家。若有因缘须独入时。但一心念佛。若为女人说法。不露齿笑。不现胸臆。乃至为法犹不亲厚。况复余事。不乐畜年少弟子沙弥小儿亦不乐与同师。常好坐禅。在于闲处修摄其心。文殊师利。是名初亲近处。复次菩萨摩诃萨。观一切法空如实相。不颠倒不动不退不转。如虚空无所有性。一切语言道断。不生不出不起。无名无相实无所有。无量无边无碍无障。但以因缘有。从颠倒生故说常乐。观如是法相。是名菩萨摩诃萨第二亲近处。尔时世尊。欲重宣此义。而说偈言

  若有菩萨　　于后恶世　　无怖畏心
  欲说是经　　应入行处　　及亲近处
  常离国王　　及国王子　　大臣官长
  凶险戏者　　及旃陀罗　　外道梵志
  亦不亲近　　增上慢人　　贪着小乘
  三藏学者　　破戒比丘　　名字罗汉
  及比丘尼　　好戏笑者　　深着五欲
  求现灭度　　诸优婆夷　　皆勿亲近
  若是人等　　以好心来　　到菩萨所
  为闻佛道　　菩萨则以　　无所畏心
  不怀悕望　　而为说法　　寡女处女
  及诸不男　　皆勿亲近　　以为亲厚
  亦莫亲近　　屠儿魁脍　　田猎渔捕
  为利杀害　　贩肉自活　　炫卖女色
  如是之人　　皆勿亲近　　凶险相扑
  种种嬉戏　　诸淫女等　　尽勿亲近
  莫独屏处　　为女说法　　若说法时
  无得戏笑　　入里乞食　　将一比丘
  若无比丘　　一心念佛　　是则名为
  行处近处　　以此二处　　能安乐说
  又复不行　　上中下法　　有为无为
  实不实法　　亦不分别　　是男是女
  不得诸法　　不知不见　　是则名为
  菩萨行处　　一切诸法　　空无所有
  无有常住　　亦无起灭　　是名智者
  所亲近处　　颠倒分别　　诸法有无
  是实非实　　是生非生　　在于闲处
  修摄其心　　安住不动　　如须弥山
  观一切法　　皆无所有　　犹如虚空
  无有坚固　　不生不出　　不动不退
  常住一相　　是名近处　　若有比丘
  于我灭后　　入是行处　　及亲近处
  说斯经时　　无有怯弱　　菩萨有时
  入于静室　　以正忆念　　随义观法
  从禅定起　　为诸国王　　王子臣民
  婆罗门等　　开化演畅　　说斯经典
  其心安隐　　无有怯弱　　文殊师利
  是名菩萨　　安住初法　　能于后世
  说法华经

又文殊师利。如来灭后于末法中。欲说是经。应住安乐行。若口宣说。若读经时。不乐说人及经典过。亦不轻慢诸余法师。不说他人好恶长短。于声闻人亦不称名说其过恶。亦不称名赞叹其美。又亦不生怨嫌之心。善修如是安乐心故。诸有听者不逆其意。有所难问。不以小乘法答。但以大乘而为解说。令得一切种智。尔时世尊。欲重宣此义。而说偈言

  菩萨常乐　　安隐说法　　于清净地
  而施床座　　以油涂身　　澡浴尘秽
  着新净衣　　内外俱净　　安处法座
  随问为说　　若有比丘　　及比丘尼
  诸优婆塞　　及优婆夷　　国王王子
  群臣士民　　以微妙义　　和颜为说
  若有难问　　随义而答　　因缘譬喻
  敷演分别　　以是方便　　皆使发心
  渐渐增益　　入于佛道　　除懒惰意
  及懈怠想　　离诸忧恼　　慈心说法
  昼夜常说　　无上道教　　以诸因缘
  无量譬喻　　开示众生　　咸令欢喜
  衣服卧具　　饮食医药　　而于其中
  无所希望　　但一心念　　说法因缘
  愿成佛道　　令众亦尔　　是则大利
  安乐供养　　我灭度后　　若有比丘
  能演说斯　　妙法华经　　心无嫉恚
  诸恼障碍　　亦无忧愁　　及骂詈者
  又无怖畏　　加刀杖等　　亦无摈出
  安住忍故　　智者如是　　善修其心
  能住安乐　　如我上说　　其人功德
  千亿万劫　　算数譬喻　　说不能尽

又文殊师利。菩萨摩诃萨。于后末世法欲灭时。受持读诵斯经典者。无怀嫉妒谄诳之心。亦勿轻骂学佛道者求其长短。若比丘比丘尼优婆塞优婆夷。求声闻者。求辟支佛者。求菩萨道者。无得恼之令其疑悔。语其人言。汝等去道甚远。终不能得一切种智。所以者何。汝是放逸之人。于道懈怠故。又亦不应戏论诸法有所诤竞。当于一切众生起大悲想。于诸如来起慈父想。于诸菩萨起大师想。于十方诸大菩萨常应深心恭敬礼拜。于一切众生平等说法。以顺法故。不多不少。乃至深爱法者。亦不为多说。文殊师利。是菩萨摩诃萨。于后末世法欲灭时。有成就是第三安乐行者。说是法时。无能恼乱得好同学。共读诵是经。亦得大众而来听受。听已能持。持已能诵诵已能说。说已能书若使人书供养经卷恭敬尊重赞叹。尔时世尊。欲重宣此义。而说偈言

  若欲说是经　　当舍嫉恚慢
  谄诳邪伪心　　常修质直行
  不轻蔑于人　　亦不戏论法
  不令他疑悔　　云汝不得佛
  是佛子说法　　常柔和能忍
  慈悲于一切　　不生懈怠心
  十方大菩萨　　愍众故行道
  应生恭敬心　　是则我大师
  于诸佛世尊　　生无上父想
  破于憍慢心　　说法无障碍
  第三法如是　　智者应守护
  一心安乐行　　无量众所敬

又文殊师利。菩萨摩诃萨。于后末世法欲灭时。有持是法华经者。于在家出家人中生大慈心。于非菩萨人中生大悲心。应作是念。如是之人则为大失。如来方便随宜说法。不闻不知不觉不问不信不解。其人虽不问不信不解是经。我得阿耨多罗三藐三菩提时。随在何地。以神通力智慧力。引之令得住是法中。文殊师利。是菩萨摩诃萨。于如来灭后有成就此第四法者。说是法时无有过失。常为比丘比丘尼优婆塞优婆夷。国王王子大臣人民婆罗门居士等。供养恭敬尊重赞叹。虚空诸天为听法故。亦常随侍。若在聚落城邑空闲林中。有人来欲难问者。诸天昼夜常为法故。而卫护之。能令听者皆得欢喜。所以者何。此经是一切过去未来现在诸佛神力所护故。文殊师利。是法华经。于无量国中。乃至名字不可得闻。何况得见受持读诵。文殊师利。譬如强力转轮圣王。欲以威势降伏诸国。而诸小王不顺其命。时转轮王。起种种兵而往讨伐。王见兵众战有功者。即大欢喜。随功赏赐。或与田宅聚落城邑。或与衣服严身之具。或与种种珍宝。金银琉璃车磲马瑙珊瑚琥珀。象马车乘奴婢人民。唯髻中明珠。不以与之。所以者何。独王顶上有此一珠。若以与之。王诸眷属必大惊怪。文殊师利。如来亦复如是。以禅定智慧力得法国土。王于三界。而诸魔王不肯顺伏。如来贤圣诸将与之共战。其有功者。心亦欢喜。于四众中为说诸经。令其心悦。赐以禅定解脱无漏根力诸法之财。又复赐与涅槃之城。言得灭度。引导其心。令皆欢喜而不为说是法华经。文殊师利。如转轮王见诸兵众有大功者。心甚欢喜以此难信之珠。久在髻中。不妄与人。而今与之。如来亦复如是。于三界中为大法王。以法教化一切众生。见贤圣军与五阴魔烦恼魔死魔共战。有大功勋。灭三毒出三界破魔网。尔时如来亦大欢喜。此法华经。能令众生至一切智。一切世间多怨难信。先所未说而今说之。文殊师利。此法华经。是诸如来第一之说。于诸说中最为甚深。末后赐与。如彼强力之王。久护明珠。今乃与之。文殊师利。此法华经。诸佛如来秘密之藏。于诸经中最在其上。长夜守护不妄宣说。始于今日乃与汝等而敷演之。尔时世尊。欲重宣此义。而说偈言

  常行忍辱　　哀愍一切　　乃能演说
  佛所赞经　　后末世时　　持此经者
  于家出家　　及非菩萨　　应生慈悲
  斯等不闻　　不信是经　　则为大失
  我得佛道　　以诸方便　　为说此法
  令住其中　　譬如强力　　转轮之王
  兵战有功　　赏赐诸物　　象马车乘
  严身之具　　及诸田宅　　聚落城邑
  或与衣服　　种种珍宝　　奴婢财物
  欢喜赐与　　如有勇健　　能为难事
  王解髻中　　明珠与之　　如来亦尔
  为诸法王　　忍辱大力　　智慧宝藏
  以大慈悲　　如法化世　　见一切人
  受诸苦恼　　欲求解脱　　与诸魔战
  为是众生　　说种种法　　以大方便
  说此诸经　　既知众生　　得其力已
  末后乃为　　说是法华　　如王解髻
  明珠与之　　此经为尊　　众经中上
  我常守护　　不妄开示　　今正是时
  为汝等说　　我灭度后　　求佛道者
  欲得安隐　　演说斯经　　应当亲近
  如是四法　　读是经者　　常无忧恼
  又无病痛　　颜色鲜白　　不生贫穷
  卑贱丑陋　　众生乐见　　如慕贤圣
  天诸童子　　以为给使　　刀杖不加
  毒不能害　　若人恶骂　　口则闭塞
  游行无畏　　如师子王　　智慧光明
  如日之照　　若于梦中　　但见妙事
  见诸如来　　坐师子座　　诸比丘众
  围绕说法　　又见龙神　　阿修罗等
  数如恒沙　　恭敬合掌　　自见其身
  而为说法　　又见诸佛　　身相金色
  放无量光　　照于一切　　以梵音声
  演说诸法　　佛为四众　　说无上法
  见身处中　　合掌赞佛　　闻法欢喜
  而为供养　　得陀罗尼　　证不退智
  佛知其心　　深入佛道　　即为授记
  成最正觉　　汝善男子　　当于来世
  得无量智　　佛之大道　　国土严净
  广大无比　　亦有四众　　合掌听法
  又见自身　　在山林中　　修习善法
  证诸实相　　深入禅定　　见十方佛
  诸佛身金色　　百福相庄严
  闻法为人说　　常有是好梦
  又梦作国王　　舍宫殿眷属
  及上妙五欲　　行诣于道场
  在菩提树下　　而处师子座
  求道过七日　　得诸佛之智
  成无上道已　　起而转法轮
  为四众说法　　经千万亿劫
  说无漏妙法　　度无量众生
  后当入涅槃　　如烟尽灯灭
  若后恶世中　　说是第一法
  是人得大利　　如上诸功德

    添品妙法莲华经从地踊出品第十四

尔时他方国土。诸来菩萨摩诃萨。过八恒河沙数。于大众中起合掌作礼。而白佛言。世尊。若听我等。于佛灭后。在此娑婆世界。勤加精进。护持读诵书写供养是经典者。当于此土而广说之。尔时佛告诸菩萨摩诃萨众。止善男子。不须汝等护持此经。所以者何。我娑婆世界。自有六万恒河沙等菩萨摩诃萨。一一菩萨。各有六万恒河沙眷属。是诸人等。能于我灭后护持读诵广说此经。佛说是时。娑婆世界三千大千国土。地皆震裂。而于其中。有无量千万亿菩萨摩诃萨。同时踊出。是诸菩萨身皆金色。三十二相无量光明。先尽在此娑婆世界之下此界虚空中住是。诸菩萨闻释迦牟尼佛所说音声。从下发来。一一菩萨。皆是大众唱导之首。各将六万恒河沙眷属。况将五万四万三万二万一万恒河沙等眷属者。况复乃至一恒河沙。半恒河沙。四分之一。乃至千万亿那由他分之一。况复千万亿那由他眷属。况复亿万眷属。况复千万百万乃至一万。况复一千一百乃至一十。况复将五四三二一弟子者。况复单己乐远离行。如是等比无量无边。算数譬喻所不能知。是诸菩萨从地出已。各诣虚空七宝妙塔多宝如来释迦牟尼佛所。到已向二世尊。头面礼足。及至诸宝树下师子座上佛所。亦皆作礼右绕三匝合掌恭敬。以诸菩萨种种赞法。而以赞叹。住在一面。欣乐瞻仰于二世尊。是诸菩萨摩诃萨。从初踊出。以诸菩萨种种赞法。而赞于佛。如是时间。经五十小劫。是时释迦牟尼佛默然而坐。及诸四众亦皆默然。五十小劫。佛神力故。令诸大众谓如半日。尔时四众。亦以佛神力故。见诸菩萨遍满无量百千万亿国土虚空。是菩萨众中。有四导师。一名上行。二名无边行。三名净行。四名安立行。是四菩萨。于其众中。最为上首唱导之师。在大众前各共合掌。观释迦牟尼佛。而问讯言。世尊。少病少恼安乐行不。所应度者受教易不。不令世尊生疲劳耶。尔时四大菩萨。而说偈言

  世尊安乐　　少病少恼　　教化众生
  得无疲倦　　又诸众生　　受化易不
  不令世尊　　生疲劳耶

尔时世尊。于菩萨大众中。而作是言。如是如是。诸善男子。如来安乐少病少恼。诸众生等易可化度。无有疲劳。所以者何。是诸众生。世世已来常受我化。亦于过去诸佛。供养尊重种诸善根。此诸众生。始见我身。闻我所说。即皆信受。入如来慧。除先修习。学小乘者。如是之人。我今亦令得闻是经入于佛慧。尔时诸大菩萨。而说偈言

  善哉善哉　　大雄世尊　　诸众生等
  易可化度　　能问诸佛　　甚深智慧
  闻已信行　　我等随喜

于时世尊赞叹上首诸大菩萨。善哉善哉善男子。汝等能于如来发随喜心。尔时弥勒菩萨。及八千恒河沙诸菩萨众。皆作是念我等从昔已来。不见不闻。如是大菩萨摩诃萨众。从地踊出住世尊前。合掌供养问讯如来。时弥勒菩萨摩诃萨。知八千恒河沙诸菩萨等心之所念。并欲自决所疑。合掌向佛。以偈问言

  无量千万亿　　大众诸菩萨
  昔所未曾见　　愿两足尊说
  是从何所来　　以何因缘集
  巨身大神通　　智慧叵思议
  其志甚坚固　　有大忍辱力
  众生所乐见　　为从何所来
  一一诸菩萨　　所将诸眷属
  其数无有量　　如恒河沙等
  或有大菩萨　　将六万恒沙
  如是诸大众　　一心求佛道
  是诸大师等　　六万恒河沙
  俱来供养佛　　及护持是经
  将五万恒沙　　其数过于是
  四万及三万　　二万至一万
  一千一百等　　乃至一恒沙
  半及三四分　　亿万分之一
  千万那由他　　万亿诸弟子
  乃至于半亿　　其数复过上
  百万至一万　　一千及一百
  五十与一十　　乃至三二一
  单己无眷属　　乐于独处者
  俱来至佛所　　其数转过上
  如是诸大众　　若人行筹数
  过于恒沙劫　　犹不能尽知
  是诸大威德　　精进菩萨众
  谁为其说法　　教化而成就
  从谁初发心　　称扬何佛法
  受持行谁经　　修习何佛道
  如是诸菩萨　　神通大智力
  四方地震裂　　皆从中踊出
  世尊我昔来　　未曾见是事
  愿说其所从　　国土之名号
  我常游诸国　　未曾见是众
  我于此众中　　乃不识一人
  忽然从地出　　愿说其因缘
  今此之大会　　无量百千亿
  是诸菩萨等　　皆欲知此事
  是诸菩萨众　　本末之因缘
  无量德世尊　　唯愿决众疑

尔时释迦牟尼佛分身诸佛。从无量千万亿他方国土来者。在于八方诸宝树下师子座上结加趺坐。其佛侍者。各各见是菩萨大众于三千大千世界四方从地踊出住于虚空。各白其佛言。世尊。此诸无量无边阿僧祇菩萨大众。从何所来。尔时诸佛各告侍者。诸善男子。且待须臾。有菩萨摩诃萨。名曰弥勒。释迦牟尼佛之所授记。次后作佛。已问斯事。佛今答之。汝等自当因是得闻。尔时释迦牟尼佛告弥勒菩萨。善哉善哉。阿逸多。乃能问佛如是大事。汝等当共一心。被精进铠。发坚固意。如来今欲显发宣示诸佛智慧。诸佛自在神通之力。诸佛师子奋迅之力。诸佛威猛大势之力。尔时世尊。欲重宣此义。而说偈言

  当精进一心　　我欲说此事
  勿得有疑悔　　佛智叵思议
  汝今出信力　　住于忍善中
  昔所未闻法　　今皆当得闻
  我今安慰汝　　勿得怀疑惧
  佛无不实语　　智慧不可量
  所得第一法　　甚深叵分别
  如是今当说　　汝等一心听

尔时世尊。说此偈已。告弥勒菩萨。我今于此大众。宣告汝等。阿逸多。是诸大菩萨摩诃萨。无量无数阿僧祇。从地踊出汝等昔所未见者。我于是娑婆世界。得阿耨多罗三藐三菩提已。教化示导是诸菩萨。调伏其心令发道意。此诸菩萨皆于是娑婆世界之下此界虚空中住。于诸经典读诵通利思惟分别正忆念。阿逸多。是诸善男子等。不乐在众多有所说。常乐静处勤行精进。未曾休息。亦不依止人天而住。常乐深智无有障碍。亦常乐于诸佛之法。一心精进求无上慧。尔时世尊。欲重宣此义而说偈言

  阿逸汝当知　　是诸大菩萨
  从无数劫来　　修习佛智慧
  悉是我所化　　令发大道心
  此等是我子　　依止是世界
  常行头陀事　　志乐于静处
  舍大众愦闹　　不乐多所说
  如是诸子等　　学习我道法
  昼夜常精进　　为求佛道故
  在娑婆世界　　下方空中住
  志念力坚固　　常勤求智慧
  说种种妙法　　其心无所畏
  我于伽耶城　　菩提树下坐
  得成最正觉　　转无上法轮
  尔乃教化之　　令初发道心
  今皆住不退　　悉当得成佛
  我今说实语　　汝等一心信
  我从久远来　　教化是等众

尔时弥勒菩萨摩诃萨。及无数诸菩萨等。心生疑惑怪未曾有。而作是念。云何世尊。于少时间。教化如是无量无边阿僧祇诸大菩萨。令住阿耨多罗三藐三菩提。即白佛言。世尊。如来为太子时。出于释宫。去伽耶城不远。坐于道场。得成阿耨多罗三藐三菩提。从是已来。始过四十余年。世尊。云何于此少时。大作佛事。以佛势力。以佛功德。教化如是无量大菩萨众。当成阿耨多罗三藐三菩提。世尊。此大菩萨众。假使有人。于千万亿劫。数不能尽。不得其边。斯等久远已来于无量无边诸佛所殖诸善根。成就菩萨道。常修梵行。世尊。如此之事。世所难信。譬如有人。色美发黑年二十五。指百岁人言是我子。其百岁人。亦指年少言是我父。生育我等。是事难信。佛亦如是。得道已来其实未久。如此大众诸菩萨等。已于无量千万亿劫。为佛道故。勤行精进。善入出住无量百千万亿三昧。得大神通。久修梵行。善能次第集诸善法。巧于问答。人中之宝。一切世间甚为希有。今日世尊。方云得佛道时初令发心。教化示导令向阿耨多罗三藐三菩提。世尊。得佛未久。乃能作此大功德事。我等虽复信佛随宜所说。佛所出言。未曾虚妄。佛所知者皆悉通达。然诸新发意菩萨。于佛灭后。若闻是语。或不信受。而起破法罪业因缘。唯然世尊。愿为解说除我等疑。及未来世诸善男子。闻此事已亦不生疑。尔时弥勒菩萨。欲重宣此义。而说偈言

  佛昔从释种　　出家近伽耶
  坐于菩提树　　尔来尚未久
  此诸佛子等　　其数不可量
  久已行佛道　　住神通智力
  善学菩萨道　　不染世间法
  如莲华在水　　从地而踊出
  皆起恭敬心　　住于世尊前
  是事难思议　　云何而可信
  佛得道甚近　　所成就甚多
  愿为除众疑　　如实分别说
  譬如少壮人　　年始二十五
  示人百岁子　　发白而面皱
  是等我所生　　子亦说是父
  父少而子老　　举世所不信
  世尊亦如是　　得道来甚近
  是诸菩萨等　　志固无怯弱
  从无量劫来　　而行菩萨道
  巧于难问答　　其心无所畏
  忍辱心决定　　端正有威德
  十方佛所赞　　善能分别说
  不乐在人众　　常好在禅定
  为求佛道故　　于下空中住
  我等从佛闻　　于此事无疑
  愿佛为未来　　演说令开解
  若有于此经　　生疑不信者
  即当堕恶道　　愿今为解说
  是无量菩萨　　云何于少时
  教化令发心　　而住不退地

    添品妙法莲华经如来寿量品第十五

尔时佛告诸菩萨及一切大众。诸善男子。汝等当信解如来诚谛之语。复告大众。汝等当信解如来诚谛之语。又复告诸大众。汝等当信解如来诚谛之语。是时菩萨大众。弥勒为首。合掌白佛言。世尊。惟愿说之。我等当信受佛语。如是三白已。复言。惟愿说之。我等当信受佛语。尔时世尊知诸菩萨三请不止。而告之言。汝等谛听。如来秘密神通之力。一切世间天人及阿修罗。皆谓今释迦牟尼佛。出释氏宫。去伽耶城不远。坐于道场。得阿耨多罗三藐三菩提。然善男子。我实成佛已来。无量无边百千万亿那由他劫。譬如五百千万亿那由他阿僧祇三千大千世界。假使有人末为微尘。过于东方五百千万亿那由他阿僧祇国。乃下一尘。如从东行尽是微尘。诸善男子。于汝意云何。是诸世界。可得思惟校计知其数不。弥勒菩萨等俱白佛言。世尊。是诸世界无量无边。非算数所知。亦非心力所及。一切声闻辟支佛。以无漏智。不能思惟知其限数。我等住阿惟越致地。于是事中亦所不达。世尊。如是诸世界无量无边。尔时佛告大菩萨众。诸善男子。今当分明宣语汝等。是诸世界。若着微尘及不著者。尽以为尘。一尘一劫。我成佛已来复过于此。百千万亿那由他阿僧祇劫。自从是来。我常在此娑婆世界说法教化。亦于余处百千万亿那由他阿僧祇国。导利众生。诸善男子。于是中间。我说然灯佛等。又复言其入于涅槃。如是皆以方便分别。诸善男子。若有众生来至我所。我以佛眼观其信等诸根利钝。随所应度。处处自说名字不同年纪大小。亦复现言当入涅槃。又以种种方便说微妙法。能令众生发欢喜心。诸善男子。如来见诸众生乐于小法德薄垢重者。为是人说。我少出家得阿耨多罗三藐三菩提。然我实成佛已来久远若斯。但以方便教化众生。令入佛道。作如是说。诸善男子。如来所演经典。皆为度脱众生。或说己身或说他身。或示己身或示他身。或示己事或示他事。诸所言说皆实不虚。所以者何。如来如实知见三界之相。无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。不如三界见于三界。如斯之事。如来明见无有错谬。以诸众生有种种性种种欲种种行种种忆想分别故。欲令生诸善根。以若干因缘譬喻言辞。种种说法。所作佛事未曾暂废。如是我成佛已来甚大久远。寿命无量阿僧祇劫。常住不灭。诸善男子。我本行菩萨道所成寿命。今犹未尽。复倍上数。然今非实灭度。而便唱言。当取灭度。如来以是方便教化众生。所以者何。若佛久住于世。薄德之人不种善根。贫穷下贱贪着五欲。入于忆想妄见网中。若见如来常在不灭。便起憍恣而怀厌怠。不能生难遭之想恭敬之心。是故如来以方便说。比丘当知诸佛出世难可值遇。所以者何。诸薄德人。过无量百千万亿劫。或有见佛或不见者。以此事故。我作是言。诸比丘如来难可得见。斯众生等闻如是语。必当生于难遭之想。心怀恋慕渴仰于佛。便种善根。是故如来。虽不实灭而言灭度。又善男子。诸佛如来法皆如是。为度众生皆实不虚。譬如良医智慧聪达明练方药善治众病。其人多诸子息。若十二十乃至百数。以有事缘远至余国。诸子于后饮他毒药。药发闷乱宛转于地。是时其父还来归家。诸子饮毒。或失本心或不失者。遥见其父皆大欢喜。拜跪问讯善安隐归。我等愚痴误服毒药。愿见救疗更赐寿命。父见子等苦恼如是。依诸经方求好药草。色香美味皆悉具足。捣簁和合与子令服。而作是言。此大良药。色香美味皆悉具足。汝等可服速除苦恼无复众患。其诸子中不失心者。见此良药色香俱好。即便服之病尽除愈。余失心者。见其父来。虽亦欢喜问讯求索治病。然与其药而不肯服。所以者何。毒气深入失本心故。于此好色香药而谓不美。父作是念。此子可愍。为毒所中心皆颠倒。虽见我喜求索救疗。如是好药而不肯服。我今当设方便令服此药。即作是言。汝等当知。我今衰老死时已至。是好良药今留在此。汝可取服勿忧不差。作是教已复至他国。遣使还告。汝父已死。是时诸子闻父背丧。心大忧恼而作是念。若父在者。慈愍我等能见救护。今者舍我远丧他国。自惟孤露无复恃怙。常怀悲感心遂醒悟。乃知此药色味香美。即取服之毒病皆愈。其父闻子悉已得差。寻便来归咸使见之。诸善男子。于意云何。颇有人能说此良医虚妄罪不。不也世尊。佛言。我亦如是。成佛已来无量无边百千万亿那由他阿僧祇劫。为众生故。以方便力言当灭度。亦无有能如法说我虚妄过者。尔时世尊。欲重宣此义。而说偈言

  自我得佛来　　所经诸劫数
  无量百千万　　亿载阿僧祇
  常说法教化　　无数亿众生
  令入于佛道　　尔来无量劫
  为度众生故　　方便现涅槃
  而实不灭度　　常住此说法
  我常住于此　　以诸神通力
  令颠倒众生　　虽近而不见
  众见我灭度　　广供养舍利
  咸皆怀恋慕　　而生渴仰心
  众生既信伏　　质直意柔软
  一心欲见佛　　不自惜身命
  时我及众僧　　俱出灵鹫山
  我时语众生　　常在此不灭
  以方便力故　　现有灭不灭
  余国有众生　　恭敬信乐者
  我复于彼中　　为说无上法
  汝等不闻此　　但谓我灭度
  我见诸众生　　没在于苦恼
  故不为现身　　令其生渴仰
  因其心恋慕　　乃出为说法
  神通力如是　　于阿僧祇劫
  常在灵鹫山　　及余诸住处
  众生见劫尽　　大火所烧时
  我此土安隐　　天人常充满
  园林诸堂阁　　种种宝庄严
  宝树多花果　　众生所游乐
  诸天击天鼓　　常作众伎乐
  雨曼陀罗华　　散佛及大众
  我净土不毁　　而众见烧尽
  忧怖诸苦恼　　如是悉充满
  是诸罪众生　　以恶业因缘
  过阿僧祇劫　　不闻三宝名
  诸有修功德　　柔和质直者
  则皆见我身　　在此而说法
  或时为此众　　说佛寿无量
  久乃见佛者　　为说佛难值
  我智力如是　　慧光照无量
  寿命无数劫　　久修业所得
  汝等有智者　　勿于此生疑
  当断令永尽　　佛语实不虚
  如医善方便　　为治狂子故
  实在而言死　　无能说虚妄
  我亦为世父　　救诸苦患者
  为凡夫颠倒　　实在而言灭
  以常见我故　　而生憍恣心
  放逸着五欲　　堕于恶道中
  我常知众生　　行道不行道
  随应所可度　　为说种种法
  每自作是意　　以何令众生
  得入无上道　　速成就佛身

    添品妙法莲华经分别功德品第十六

尔时大会。闻佛说寿命劫数长远如是。无量无边阿僧祇众生得大饶益。于时世尊。告弥勒菩萨摩诃萨。阿逸多。我说是如来寿命长远时。六百八十万亿那由他恒河沙众生得无生法忍。复有千倍菩萨摩诃萨。得闻持陀罗尼门。复有一世界微尘数菩萨摩诃萨。得乐说无碍辩才。复有一世界微尘数菩萨摩诃萨。得百千万亿无量旋陀罗尼。复有三千大千世界微尘数菩萨摩诃萨。能转不退法轮。复有二千中国土微尘数菩萨摩诃萨。能转清净法轮。复有小千国土微尘数菩萨摩诃萨。八生当得阿耨多罗三藐三菩提。复有四四天下微尘数菩萨摩诃萨。四生当得阿耨多罗三藐三菩提。复有三四天下微尘数菩萨摩诃萨。三生当得阿耨多罗三藐三菩提。复有二四天下微尘数菩萨摩诃萨。二生当得阿耨多罗三藐三菩提。复有一四天下微尘数菩萨摩诃萨。一生当得阿耨多罗三藐三菩提。复有八世界微尘数众生。皆发阿耨多罗三藐三菩提心。佛说是诸菩萨摩诃萨得大法利时。于虚空中。雨曼陀罗华摩诃曼陀罗华。以散无量百千万亿众宝树下师子座上诸佛。并散七宝塔中师子座上释迦牟尼佛。及久灭度多宝如来。亦散一切诸大菩萨及四部众。又雨细末栴檀沉水香等。于虚空中。天鼓自鸣妙声深远。又雨千种天衣。垂诸璎珞真珠璎珞摩尼珠璎珞如意珠璎珞。遍于九方。众宝香炉烧无价香。自然周至供养大会。一一佛上。有诸菩萨执持幡盖。次第而上至于梵天。是诸菩萨。以妙音声歌无量颂。赞叹诸佛。尔时弥勒菩萨从座而起。偏袒右肩合掌向佛。而说偈言

  佛说希有法　　昔所未曾闻
  世尊有大力　　寿命不可量
  无数诸佛子　　闻世尊分别
  说得法利者　　欢喜充遍身
  或住不退地　　或得陀罗尼
  或无碍乐说　　万亿旋总持
  或有大千界　　微尘数菩萨
  各各皆能转　　不退之法轮
  复有中千界　　微尘数菩萨
  各各皆能转　　清净之法轮
  复有小千界　　微尘数菩萨
  余各八生在　　当得成佛道
  复有四三二　　如此四天下
  微尘诸菩萨　　随数生成佛
  或一四天下　　微尘数菩萨
  余有一生在　　当成一切智
  如是等众生　　闻佛寿长远
  得无量无漏　　清净之果报
  复有八世界　　微尘数众生
  闻佛说寿命　　皆发无上心
  世尊说无量　　不可思议法
  多有所饶益　　如虚空无边
  雨天曼陀罗　　摩诃曼陀罗
  释梵如恒沙　　无数佛土来
  雨栴檀沉水　　缤纷而乱坠
  如鸟飞空下　　供散于诸佛
  天鼓虚空中　　自然出妙声
  天衣千万种　　旋转而来下
  众宝妙香炉　　烧无价之香
  自然悉周遍　　供养诸世尊
  其大菩萨众　　执七宝幡盖
  高妙万亿种　　次第至梵天
  一一诸佛前　　宝幢悬胜幡
  亦以千万偈　　歌咏诸如来
  如是种种事　　昔所未曾有
  闻佛寿无量　　一切皆欢喜
  佛名闻十方　　广饶益众生
  一切具善根　　以助无上心

尔时佛告弥勒菩萨摩诃萨。阿逸多。其有众生。闻佛寿命长远如是。乃至能生一念信解。所得功德无有限量。若有善男子善女人。为阿耨多罗三藐三菩提故。于八十万亿那由他劫。行五波罗蜜。檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。除般若波罗蜜。以是功德比前功德。百分千分百千万亿分。不及其一。乃至算数譬喻所不能知。若善男子有如是功德。于阿耨多罗三藐三菩提退者。无有是处。尔时世尊。欲重宣此义。而说偈言

  若人求佛慧　　于八十万亿
  那由他劫数　　行五波罗蜜
  于是诸劫中　　布施供养佛
  及缘觉弟子　　并诸菩萨众
  珍异之饮食　　上服与卧具
  栴檀立精舍　　以园林庄严
  如是等布施　　种种皆微妙
  尽此诸劫数　　以回向佛道
  若复持禁戒　　清净无缺漏
  求于无上道　　诸佛之所叹
  若复行忍辱　　住于调柔地
  设众恶来加　　其心不倾动
  诸有得法者　　怀于增上慢
  为此所轻恼　　如是亦能忍
  若复勤精进　　志念常坚固
  于无量亿劫　　一心不懈怠
  又于无数劫　　住于空闲处
  若坐若经行　　除睡常摄心
  以是因缘故　　能生诸禅定
  八十亿万劫　　安住心不乱
  持此一心福　　愿求无上道
  我得一切智　　尽诸禅定际
  是人于百千　　万亿劫数中
  行此诸功德　　如上之所说
  有善男女等　　闻我说寿命
  乃至一念信　　其福过于彼
  若人悉无有　　一切诸疑悔
  深心须臾信　　其福为如此
  其有诸菩萨　　无量劫行道
  闻我说寿命　　是则能信受
  如是诸人等　　顶受此经典
  愿我于未来　　长寿度众生
  如今日世尊　　诸释中之王
  道场师子吼　　说法无所畏
  我等未来世　　一切所尊敬
  坐于道场时　　说寿亦如是
  若有深心者　　清净而质直
  多闻能总持　　随义解佛语
  如是之人等　　于此无有疑

又阿逸多。若有闻佛寿命长远解其言趣。是人所得功德无有限量。能起如来无上之慧。何况广闻是经若教人闻。若自持若教人持。若自书若教人书。若以华香璎珞幢幡缯盖香油稣灯供养经卷。是人功德无量无边。能生一切种智。阿逸多。若善男子善女人。闻我说寿命长远。深心信解。则为见佛常在耆阇崛山共大菩萨诸声闻众围绕说法。又见此娑婆世界。其地琉璃坦然平正。阎浮檀金以界八道。宝树行列。诸台楼观皆悉宝成。其菩萨众咸处其中。若有能如是观者。当知是为深信解相。又复如来灭后。若闻是经。而不毁呰起随喜心。当知已为深信解相。何况读诵受持之者。斯人则为顶戴如来。阿逸多。是善男子善女人。不须为我复起塔寺及作僧坊以四事供养众僧。所以者何。是善男子善女人。受持读诵是经典者。为已起塔造立僧坊供养众僧。则为以佛舍利起七宝塔。高广渐小至于梵天。悬诸幡盖及众宝铃。华香璎珞末香涂香烧香。众鼓伎乐箫笛箜篌。种种舞戏。以妙音声歌呗赞诵。则为已于无量千万亿劫作是供养已。阿逸多。若我灭后。闻是经典有能受持。若自书若教人书。则为起立僧坊。以赤栴檀作诸殿堂。三十有二。高八多罗树。高广严好。百千比丘于其中止。园林浴池经行禅窟。衣服饮食床褥汤药。一切乐具充满其中。如是僧坊堂阁若干百千万亿其数无量。以此现前供养于我及比丘僧。是故我说。如来灭后。若有受持读诵为他人说。若自书若教人书。供养经卷。不须复起塔寺及造僧坊供养众僧。况复有人能持是经。兼行布施持戒忍辱精进一心智慧。其德最胜无量无边。譬如虚空东西南北四维上下无量无边。是人功德亦复如是无量无边。疾至一切种智。若人读诵受持是经为他人说。若自书若教人书。复能起塔及造僧坊。供养赞叹声闻众僧。亦以百千万亿赞叹之法。赞叹菩萨功德。又为他人种种因缘。随义解说此法华经。复能清净持戒。与柔和者而共同止。忍辱无嗔志念坚固。常贵坐禅得诸深定。精进勇猛摄诸善法。利根智慧善答问难。阿逸多。若我灭后。诸善男子善女人。受持读诵是经典者。复有如是诸善功德。当知是人已趣道场。近阿耨多罗三藐三菩提。坐道树下。阿逸多。是善男子若坐若立若经行处。是中便应起塔。一切天人皆应供养。如佛之塔。尔时世尊。欲重宣此义。而说偈言

  若我灭度后　　能奉持此经
  斯人福无量　　如上之所说
  是则为具足　　一切诸供养
  以舍利起塔　　七宝而庄严
  表刹甚高广　　渐小至梵天
  宝铃千万亿　　风动出妙声
  又于无量劫　　而供养此塔
  华香诸璎珞　　天衣众伎乐
  然香油稣灯　　周匝常照明
  恶世法末时　　能持是经者
  则为已如上　　具足诸供养
  若能持此经　　则如佛现在
  以牛头栴檀　　起僧坊供养
  堂有三十二　　高八多罗树
  上馔妙衣服　　床卧皆具足
  百千众住处　　园林诸流池
  经行及禅窟　　种种皆严好
  若有信解心　　受持读诵书
  若复教人书　　及供养经卷
  散华香末香　　以须曼瞻卜
  阿提目多伽　　薰油常然之
  如是供养者　　得无量功德
  如虚空无边　　其福亦如是
  况复持此经　　兼布施持戒
  忍辱乐禅定　　不嗔不恶口
  恭敬于塔庙　　谦下诸比丘
  远离自高心　　常思惟智慧
  有问难不嗔　　随顺为解说
  若能行是行　　功德不可量
  若见此法师　　成就如是德
  应以天华散　　天衣覆其身
  头面接足礼　　生心如佛想
  又应作是念　　不久诣道树
  得无漏无为　　广利诸人天
  其所住止处　　经行若坐卧
  乃至说一偈　　是中应起塔
  庄严令妙好　　种种以供养
  佛子住此地　　则是佛受用
  常在于其中　　经行及坐卧

添品妙法莲华经卷第五添品妙法莲华经卷第六

        隋天竺三藏阇那崛多共笈多译

    随喜功德品第十七

尔时弥勒菩萨摩诃萨白佛言。世尊。若有善男子善女人。闻是法华经随喜者。得几所福。而说偈言

  世尊灭度后　　其有闻是经
  若能随喜者　　为得几所福

尔时佛告弥勒菩萨摩诃萨。阿逸多。如来灭后。若比丘比丘尼优婆塞优婆夷。及余智者若长若幼。闻是经随喜已。从法会出至于余处。若在僧坊若空闲地。若城邑巷陌聚落田里。如其所闻。为父母宗亲善友知识。随力演说。是诸人等闻已随喜。复行转教。余人闻已亦随喜转教。如是展转至第五十。阿逸多。其第五十善男子善女人随喜功德。我今说之。汝当善听。若四百万亿阿僧祇世界。六趣四生众生。卵生胎生湿生化生。若有形无形。有想无想。非有想非无想。无足二足四足多足。如是等在众生数者。有人求福。随其所欲娱乐之具皆给与之。一一众生。与满阎浮提金银琉璃车磲马瑙珊瑚虎珀诸妙珍宝。及象马车乘七宝所成宫殿楼阁等。是大施主如是布施。满八十年已。而作是念。我已施众生娱乐之具。随意所欲。然此众生皆已衰老。年过八十发白面皱。将死不久。我当以佛法而训导之。即集此众生。宣布法化示教利喜。一时皆得须陀洹道斯陀含道阿那含道阿罗汉道。尽诸有漏。于深禅定皆得自在。具八解脱。于汝意云何。是大施主所得功德。宁为多不。弥勒白佛言。世尊。是人功德甚多无量无边。若是施主。但施众生一切乐具。功德无量。何况令得阿罗汉果。佛告弥勒。我今分明语汝。是人以一切乐具。施于四百万亿阿僧祇世界六趣众生。又令得阿罗汉果。所得功德。不如是第五十人闻法华经一偈随喜功德。百分千分百千万亿分。不及其一。乃至算数譬喻所不能知。阿逸多。如是第五十人。展转闻法华经随喜功德。尚无量无边阿僧祇。何况最初于会中闻而随喜者。其福复胜无量无边阿僧祇不可得比。又阿逸多。若人为是经故。往诣僧坊。若坐若立须臾听受。缘是功德转身所生。得好上妙象马车乘珍宝辇舆及乘天宫。若复有人于讲法处坐。更有人来劝令坐听。若分座令坐。是人功德。转身得帝释坐处。若梵王坐处。若转轮圣王所坐之处。阿逸多。若复有人语余人言。有经名法华。可共往听。即受其教乃至须臾间闻。是人功德。转身得与陀罗尼菩萨共生一处。利根智慧。百千万世终不喑哑。口气不臭舌常无病。口亦无病齿不垢黑。不黄不疏亦不缺落。不差不曲唇不下垂。亦不褰缩不粗涩不疮胗。亦不缺坏亦不喎斜。不厚不大亦不黧黑。无诸可恶。鼻不[月*扁][月*弟]亦不曲戾。面色不黑亦不狭长。亦不窊曲。无有一切不可喜相。唇舌牙齿悉皆严好。鼻修高直面貌圆满。眉高而长额广平正。人相具足。世世所生见佛闻法。信受教诲。阿逸多。汝且观是劝于一人令往听法。功德如此。何况一心听说读诵。而于大众为人分别如说修行。尔时世尊。欲重宣此义。而说偈言

  若人于法会　　得闻是经典
  乃至于一偈　　随喜为他说
  如是展转教　　至于第五十
  最后人获福　　今当分别之
  如有大施主　　供给无量众
  具满八十岁　　随意之所欲
  见彼衰老相　　发白而面皱
  齿疏形枯竭　　念其死不久
  我今应当教　　令得于道果
  即为方便说　　涅槃真实法
  世皆不牢固　　如水沫泡焰
  汝等咸应当　　疾生厌离心
  诸人闻是法　　皆得阿罗汉
  具足六神通　　三明八解脱
  最后第五十　　闻一偈随喜
  是人福胜彼　　不可为譬喻
  如是展转闻　　其福尚无量
  何况于法会　　初闻随喜者
  若有劝一人　　将引听法华
  言此经深妙　　千万劫难遇
  即受教往听　　乃至须臾闻
  斯人之福报　　今当分别说
  世世无口患　　齿不疏黄黑
  唇不厚褰缺　　无有可恶相
  舌不干黑短　　鼻高修且直
  额广而平正　　面目悉端严
  为人所喜见　　口气无臭秽
  优钵华之香　　常从其口出
  若故诣僧坊　　欲听法华经
  须臾闻欢喜　　今当说其福
  后生天人中　　得妙象马车
  珍宝之辇舆　　及乘天宫殿
  若于讲法处　　劝人坐听经
  是福因缘得　　释梵转轮座
  何况一心听　　解说其义趣
  如说而修行　　其福不可限

    添品妙法莲华经法师功德品第十八

尔时佛告常精进菩萨摩诃萨。若善男子善女人。受持是法华经。若读若诵若解说若书写。是人当得八百眼功德。千二百耳功德。八百鼻功德。千二百舌功德。八百身功德。千二百意功德。以是功德庄严六根皆令清净。是善男子善女人。父母所生清净肉眼。见于三千大千世界。内外所有山林河海。下至阿鼻地狱上至有顶。亦见其中一切众生。及业因缘果报生处。悉见悉知。尔时世尊。欲重宣此义。而说偈言

  若于大众中　　以无所畏心
  说是法华经　　汝听其功德
  是人得八百　　功德殊胜眼
  以是庄严故　　其目甚清净
  父母所生眼　　悉见三千界
  内外弥楼山　　须弥及铁围
  并诸余山林　　大海江河水
  下至阿鼻狱　　上至有顶处
  其中诸众生　　一切皆悉见
  虽未得天眼　　肉眼力如是

复次常精进。若善男子善女人。受持此经。若读若诵若解说若书写。得千二百耳功德。以是清净耳。闻三千大千世界。下至阿鼻地狱上至有顶。其中内外种种所有语言音声。象声马声牛声车声。啼哭声愁叹声。螺声鼓声钟声铃声。笑声语声。男声女声童子声童女声。法声非法声。苦声乐声。凡夫声圣人声。喜声不喜声天声龙声夜叉声。乾闼婆声阿修罗声。迦楼罗声紧那罗声摩睺罗伽声。火声水声风声地狱声畜生声饿鬼声。比丘声比丘尼声。声闻声辟支佛声。菩萨声佛声。以要言之。三千大千世界中。一切内外所有诸声。虽未得天耳。以父母所生清净常耳。皆悉闻知。如是分别种种音声。而不坏耳根。尔时世尊。欲重宣此义。而说偈言

  父母所生耳　　清净无浊秽
  以此常耳闻　　三千世界声
  象马车牛声　　钟铃螺鼓声
  琴瑟箜篌声　　箫笛之音声
  清净好歌声　　听之而不着
  无数种人声　　闻悉能解了
  又闻诸天声　　微妙之歌音
  及闻男女声　　童子童女声
  山川险谷中　　迦陵频伽声
  命命等诸鸟　　悉闻其音声
  地狱众苦痛　　种种楚毒声
  饿鬼饥渴逼　　求索饮食声
  诸阿修罗等　　居在大海边
  自共言语时　　出于大音声
  如是说法者　　安住于此间
  遥闻是众声　　而不坏耳根
  十方世界中　　禽兽鸣相呼
  其说法之人　　于此悉闻之
  其诸梵天上　　光音及遍净
  乃至有顶天　　言语之音声
  法师住于此　　悉皆得闻之
  一切比丘众　　及诸比丘尼
  若读诵经典　　若为他人说
  法师住于此　　悉皆得闻之
  复有诸菩萨　　读诵于经法
  若为他人说　　撰集解其义
  如是诸音声　　悉皆得闻之
  诸佛大圣尊　　教化众生者
  于诸大会中　　演说微妙法
  持此法华者　　悉皆得闻之
  三千大千界　　内外诸音声
  下至阿鼻狱　　上至有顶天
  皆闻其音声　　而不坏耳根
  其耳聪利故　　悉能分别知
  持是法华者　　虽未得天耳
  但用所生耳　　功德已如是

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。成就八百鼻功德。以是清净鼻根。闻于三千大千世界。上下内外种种诸香。须曼那华香。阇提华香。末利华香。瞻卜华香。波罗罗华香。赤莲华香。青莲华香。白莲华香。华树香果树香。栴檀香沉水香。多摩罗跋香。多伽罗香。及千万种和香。若末若丸若涂香。持是经者于此间住。悉能分别。又复别知众生之香。象香马香牛羊等香。男香女香童子香童女香。及草木丛林香。若近若远所有诸香。悉皆得闻分别不错。持是经者。虽住于此。亦闻天上诸天之香。波利质多罗拘鞞陀罗树香。及曼陀罗华香。摩诃曼陀罗华香。曼殊沙华香。摩诃曼殊沙华香。栴檀沉水种种末香。诸杂华香。如是等天香。和合所出之香。无不闻知。又闻诸天身香。释提桓因在胜殿上。五欲娱乐嬉戏时香。若在妙法堂上。为忉利诸天说法时香。若于诸园游戏时香。及余天等男女身香。皆悉遥闻。如是展转。乃至梵天。上至有顶。诸天身香。亦皆闻之。并闻诸天所烧之香。及声闻香辟支佛香。菩萨香诸佛身香。亦皆遥闻知其所在。虽闻此香。然于鼻根不坏不错。若欲分别为他人说。忆念不谬。尔时世尊。欲重宣此义。而说偈言

  是人鼻清净　　于此世界中
  若香若臭物　　种种悉闻知
  须曼那阇提　　多摩罗栴檀
  沉水及桂香　　种种华果香
  及知众生香　　男子女人香
  说法者远住　　闻香知所在
  大势转轮王　　小转轮及子
  群臣诸宫人　　闻香知所在
  身所著珍宝　　及地中宝藏
  转轮王宝女　　闻香知所在
  诸人严身具　　衣服及璎珞
  种种所涂香　　闻则知其身
  诸天若行坐　　游戏及神变
  持是法华者　　闻香悉能知
  诸树华果实　　及稣油香气
  持经者住此　　悉知其所在
  诸山深险处　　栴檀树华敷
  众生在中者　　闻香悉能知
  铁围山大海　　地中诸众生
  持经者闻香　　悉知其所在
  阿修罗男女　　及其诸眷属
  斗诤游戏时　　闻香皆能知
  旷野险隘处　　师子象虎狼
  野牛水牛等　　闻香知所在
  若有怀妊者　　未辨其男女
  无根及非人　　闻香悉能知
  以闻香力故　　知其初怀妊
  成就不成就　　安乐产福子
  以闻香力故　　知男女所念
  染欲痴恚心　　亦知修善者
  地中众伏藏　　金银诸珍宝
  铜器之所盛　　闻香悉能知
  种种诸璎珞　　无能识其价
  闻香知贵贱　　出处及所在
  天上诸华等　　曼陀曼殊沙
  波利质多树　　闻香悉能知
  天上诸宫殿　　上中下差别
  众宝华庄严　　闻香悉能知
  天园林胜殿　　诸观妙法堂
  在中而娱乐　　闻香悉能知
  诸天若听法　　或受五欲时
  来往行坐卧　　闻香悉能知
  天女所著衣　　好华香庄严
  周旋游戏时　　闻香悉能知
  如是展转上　　乃至于梵天
  入禅出禅者　　闻香悉能知
  光音遍净天　　乃至于有顶
  初生及退没　　闻香悉能知
  诸比丘众等　　于法常精进
  若坐若经行　　及读诵经法
  或在林树下　　专精而坐禅
  持经者闻香　　悉知其所在
  菩萨志坚固　　坐禅若读经
  或为人说法　　闻香悉能知
  在在方世尊　　一切所恭敬
  愍众而说法　　闻香悉能知
  众生在佛前　　闻经皆欢喜
  如法而修行　　闻香悉能知
  虽未得菩萨　　无漏法生鼻
  而是持经者　　先得此鼻相

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。得千二百舌功德。若好若丑若美不美。及诸苦涩物。在其舌根。皆变成上味。如天甘露。无不美者。若以舌根。于大众中有所演说。出深妙声能入其心。皆令欢喜快乐。又诸天子天女释梵诸天。闻是深妙音声。有所演说言论次第。皆悉来听。及诸龙龙女。夜叉夜叉女。乾闼婆乾闼婆女。阿修罗阿修罗女。迦楼罗迦楼罗女。紧那罗紧那罗女。摩睺罗伽摩睺罗伽女。为听法故。皆来亲近恭敬供养。及比丘比丘尼优婆塞优婆夷。国王王子群臣眷属。小转轮王大转轮王。七宝千子内外眷属。乘其宫殿俱来听法。以是菩萨善说法故。婆罗门居士国内人民。尽其形寿随侍供养。又诸声闻辟支佛菩萨诸佛。常乐见之。是人所在方面。诸佛皆向其处说法。悉能受持一切佛法。又能出于深妙法音。尔时世尊。欲重宣此义。而说偈言

  是人舌根净　　终不受恶味
  其有所食啖　　悉皆成甘露
  以深净妙声　　于大众说法
  以诸因缘喻　　引导众生心
  闻者皆欢喜　　设诸上供养
  诸天龙夜叉　　及阿修罗等
  皆以恭敬心　　而共来听法
  是说法之人　　若欲以妙音
  遍满三千界　　随意即能至
  大小转轮王　　及千子眷属
  合掌恭敬心　　常来听受法
  诸天龙夜叉　　罗刹毗舍阇
  亦以欢喜心　　常乐来供养
  梵天王魔王　　自在大自在
  如是诸天众　　常来至其所
  诸佛及弟子　　闻其说法音
  常念而守护　　或时为现身

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。得八百身功德。得清净身。如净琉璃。众生喜见其身净故。三千大千世界众生。生时死时上下好丑。生善处恶处。悉于中现。及铁围山大铁围山。弥楼山摩诃弥楼山等诸山。及其中众生悉于中现。下至阿鼻地狱上至有顶。所有及众生。悉于中现。若声闻辟支佛菩萨诸佛说法。皆于身中现其色像。尔时世尊。欲重宣此义。而说偈言

  若持法华者　　其身甚清净
  如彼净琉璃　　众生皆喜见
  又如净明镜　　悉见诸色像
  菩萨于净身　　皆见世所有
  唯独自明了　　余人所不见
  三千世界中　　一切诸群萌
  天人阿修罗　　地狱鬼畜生
  如是诸色像　　皆于身中现
  诸天等宫殿　　乃至于有顶
  铁围及弥楼　　摩诃弥楼山
  诸大海水等　　皆于身中现
  诸佛及声闻　　佛子菩萨等
  若独若在众　　说法悉皆现
  虽未得无漏　　法性之妙身
  以清净常体　　一切于中现

复次常精进。若善男子善女人。如来灭后受持是经。若读若诵若解说若书写。得千二百意功德。以是清净意根。乃至闻一偈一句。通达无量无边之义。解是义已。能演说一句一偈。至于一月四月。乃至一岁。诸所说法随其义趣。皆与实相不相违背。若说俗间经书治世语言资生业等。皆顺正法。三千大千世界六趣众生。心之所行心所动作心所戏论。皆悉知之。虽未得无漏智慧。而其意根清净如此。是人有所思惟筹量言说。皆是佛法无不真实。亦是先佛经中所说。尔时世尊。欲重宣此义。而说偈言

  是人意清净　　明利无秽浊
  以此妙意根　　知上中下法
  乃至闻一偈　　通达无量义
  次第如法说　　月四月至岁
  是世界内外　　一切诸众生
  若天龙及人　　夜叉鬼神等
  其在六趣中　　所念若干种
  持法华之报　　一时皆悉知
  十方无数佛　　百福庄严相
  为众生说法　　悉闻能受持
  思惟无量义　　说法亦无量
  终始不忘错　　以持法华故
  悉知诸法相　　随义识次第
  达名字语言　　如所知演说
  此人有所说　　皆是先佛法
  以演此法故　　于众无所畏
  持法华经者　　意根净若斯
  虽未得无漏　　先有如是相
  是人持此经　　安住希有地
  为一切众生　　欢喜而爱敬
  能以千万种　　善巧之语言
  分别而说法　　持法华经故

    添品妙法莲华经常不轻菩萨品第十九

尔时佛告得大势菩萨摩诃萨。汝今当知。若比丘比丘尼优婆塞优婆夷。持法华经者。若有恶口骂詈诽谤。获大罪报如前所说。其所得功德。如向所说。眼耳鼻舌身意清净。得大势。乃往古昔过无量无边不可思议阿僧祇劫。有佛。名威音王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名离衰。国名大成。其威音王佛。于彼世中。为天人阿修罗说法。为求声闻者。说应四谛法。度生老病死究竟涅槃。为求辟支佛者。说应十二因缘法。为诸菩萨。因阿耨多罗三藐三菩提。说应六波罗蜜法。究竟佛慧。得大势。是威音王佛寿四十万亿那由他恒河沙劫。正法住世劫数。如一阎浮提微尘。像法住世劫数。如四天下微尘。其佛饶益众生已。然后灭度。正法像法灭尽之后。于此国土复有佛出。亦号威音王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。如是次第有二万亿佛。皆同一号。最初威音王如来。既已灭度。正法灭后。于像法中增上慢比丘有大势力。尔时有一菩萨比丘。名常不轻。得大势。以何因缘名常不轻。是比丘凡有所见。若比丘比丘尼优婆塞优婆夷。皆悉礼拜赞叹。而作是言。我深敬汝等不敢轻慢。所以者何。汝等皆行菩萨道当得作佛。而是比丘。不专读诵经典。但行礼拜。乃至远见四众。亦复故往礼拜赞叹。而作是言。我不敢轻于汝等。汝等皆当作佛。四众之中。有生嗔恚心不净者。恶口骂詈言是无智比丘从何所来自言我不轻汝。而与我等授记。当得作佛。我等不用如是虚妄授记。如此经历多年。常被骂詈不生嗔恚。常作是言。汝当作佛。说是语时。众人或以杖木瓦石。而打掷之。避走远住。犹高声唱言。我不敢轻汝。汝等皆当作佛。以其常作是语故。增上慢比丘比丘尼优婆塞优婆夷。号之为常不轻。是比丘临欲终时。于虚空中具闻威音王佛先所说法华经。二十千万亿偈。悉能受持。即得如上眼根清净耳鼻舌身意根清净。得是六根清净已。更增寿命二百万亿那由他岁。广为人说是法华经。于时增上慢四众。比丘比丘尼优婆塞优婆夷。轻贱是人为作不轻名者。见其得大神通力乐说辩力大善寂力。闻其所说。皆信伏随从。是菩萨复化千万亿众。令住阿耨多罗三藐三菩提。命终之后。得值二千亿佛。皆号日月灯明。于其法中说是法华经。以是因缘。复值二千亿佛。皆同号云自在灯王。于此诸佛法中。受持读诵。为诸四众说此经典故。得是常眼清净耳鼻舌身意诸根清净。于四众中说法心无所畏。得大势。是常不轻菩萨摩诃萨。供养如是若干诸佛。恭敬尊重赞叹种诸善根。于后复值千万亿佛。亦于诸佛法中说是经典。功德成就当得作佛。得大势。于意云何。尔时常不轻菩萨。岂异人乎。则我身是若。我于宿世不受持读诵此经为他人说者。不能疾得阿耨多罗三藐三菩提。我于先佛所。受持读诵此经为他人说故。疾得阿耨多罗三藐三菩提。得大势。彼时四众比丘比丘尼优婆塞优婆夷。以嗔恚意轻贱我故。二百亿劫。常不值佛不闻法不见僧。千劫于阿鼻地狱受大苦恼。毕是罪已。复遇常不轻菩萨教化阿耨多罗三藐三菩提。得大势。于汝意云何。尔时四众常轻是菩萨者。岂异人乎。今此会中。跋陀婆罗等五百菩萨。师子月等五百比丘尼。思佛等五百优婆塞。皆于阿耨多罗三藐三菩提不退转者是。得大势。当知是法华经。大饶益诸菩萨摩诃萨。能令至于阿耨多罗三藐三菩提。是故诸菩萨摩诃萨。于如来灭后。常应受持读诵解说书写是经。尔时世尊。欲重宣此义。而说偈言

  过去有佛　　号威音王　　神智无量
  将导一切　　天人龙神　　所共供养
  是佛灭后　　法欲尽时　　有一菩萨
  名常不轻　　时诸四众　　计着于法
  不轻菩萨　　往到其所　　而语之言
  我不轻汝　　汝等行道　　皆当作佛
  诸人闻已　　轻毁骂詈　　不轻菩萨
  能忍受之　　其罪毕已　　临命终时
  得闻此经　　六根清净　　神通力故
  增益寿命　　复为诸人　　广说是经
  诸着法众　　皆蒙菩萨　　教化成就
  令住佛道　　不轻命终　　值无数佛
  说是经故　　得无量福　　渐具功德
  疾成佛道　　彼时不轻　　则我身是
  时四部众　　着法之者　　闻不轻言
  汝当作佛　　以是因缘　　值无数佛
  此会菩萨　　五百之众　　并及四部
  清信士女　　今于我前　　听法者是
  我于前世　　劝是诸人　　听受斯经
  第一之法　　开示教人　　令住涅槃
  世世受持　　如是经典　　亿亿万劫
  至不可议　　时乃得闻　　是法华经
  亿亿万劫　　至不可议　　诸佛世尊
  时说是经　　是故行者　　于佛灭后
  闻如是经　　勿生疑惑　　应当一心
  广说此经　　世世值佛　　疾成佛道

    添品妙法莲华经如来神力品第二十

尔时千世界微尘等菩萨摩诃萨。从地踊出者。皆于佛前一心合掌瞻仰尊颜。而白佛言。世尊。我等于佛灭后。世尊分身所在国土灭度之处。当广说此经。所以者何。我等亦自欲得是真净大法。受持读诵解说书写而供养之。尔时世尊。于文殊师利等无量百千万亿旧住娑婆世界菩萨摩诃萨。及诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切众前。现大神力。出广长舌上至梵世。一切毛孔放于无量无数色光。皆悉遍照十方世界。众宝树下师子座上诸佛。亦复如是。出广长舌放无量光。释迦牟尼佛及宝树下诸佛。现神力时满百千岁。然后还摄舌相。一时謦欬俱共弹指。是二音声。遍至十方诸佛世界。地皆六种震动。其中众生。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。以佛神力故。皆见此娑婆世界无量无边百千万亿众宝树下师子座上诸佛。及见释迦牟尼佛共多宝如来在宝塔中坐师子座。又见无量无边百千万亿菩萨摩诃萨。及诸四众恭敬围绕释迦牟尼佛。既见是已。皆大欢喜得未曾有。即时诸天。于虚空中高声唱言。过此无量无边百千万亿阿僧祇世界。有国名娑婆。是中有佛。名释迦牟尼。今为诸菩萨摩诃萨。说大乘经。名妙法莲华教菩萨法佛所护念。汝等当深心随喜。亦当礼拜供养释迦牟尼佛。彼诸众生。闻虚空中声已。合掌向娑婆世界。作如是言。南无释迦牟尼佛。南无释迦牟尼佛。以种种华香璎珞幡盖及诸严身之具珍宝妙物。皆共遥散娑婆世界。所散诸物从十方来。譬如云集。变成宝帐。遍覆此间诸佛之上。于时十方世界通达无碍。如一佛土。尔时佛告上行等菩萨大众。诸佛神力如是。无量无边不可思议。若我以是神力。于无量无边百千万亿阿僧祇劫。为嘱累故。说此经功德。犹不能尽。以要言之。如来一切所有之法。如来一切自在神力。如来一切秘要之藏。如来一切甚深之事。皆于此经宣示显说。是故汝等。于如来灭后。应一心受持读诵解说书写如说修行所在国土。若有受持读诵解说书写如说修行。若经卷所住之处。若于园中若于林中。若于树下若于僧坊。若白衣舍若在殿堂。若山谷旷野。是中皆应起塔供养。所以者何。当知是处即是道场。诸佛于此得阿耨多罗三藐三菩提。诸佛于此转于法轮。诸佛于此而般涅槃。尔时世尊。欲重宣此义。而说偈言

  诸佛救世者　　住于大神通
  为悦众生故　　现无量神力
  舌相至梵天　　身放无数光
  为求佛道者　　现此希有事
  诸佛謦欬声　　及弹指之声
  周闻十方国　　地皆六种动
  以佛灭度后　　能持是经故
  诸佛皆欢喜　　现无量神力
  嘱累是经故　　赞美受持者
  于无量劫中　　犹故不能尽
  是人之功德　　无边无有穷
  如十方虚空　　不可得边际
  能持是经者　　则为已见我
  亦见多宝佛　　及诸分身者
  又见我今日　　教化诸菩萨
  能持是经者　　令我及分身
  灭度多宝佛　　一切皆欢喜
  十方现在佛　　并过去未来
  亦见亦供养　　亦令得欢喜
  诸佛坐道场　　所得秘要法
  能持是经者　　不久亦当得
  能持是经者　　于诸法之义
  名字及言辞　　乐说无穷尽
  如风于空中　　一切无障碍
  于如来灭后　　如佛所说经
  因缘及次第　　随义如实说
  如日月光明　　能除诸幽冥
  斯人行世间　　能灭众生闇
  教无量菩萨　　毕竟住一乘
  是故有智者　　闻此功德利
  于我灭度后　　应受持斯经
  是人于佛道　　决定无有疑

    妙法莲华经陀罗尼品第二十一

尔时药王菩萨即从座起。偏袒右肩合掌向佛。而白佛言。世尊。若善男子善女人。有能受持法华经者。若读诵通利。若有书写经卷。得几所福。佛告药王。若有善男子善女人。供养八百万亿那由他恒河沙等诸佛。于汝意云何。其所得福宁为多不。甚多世尊。佛言。若善男子善女人。能于是经。乃至受持一四句偈。读诵解义如说修行。功德甚多

尔时药王菩萨白佛言。世尊。我今当与说法者陀罗尼咒以守护之。即说咒曰

怛(都割)侄(地夜)他(一)安埿(如帝二)曼(莫安)埿(三)未泥(奴羝四)磨(莫贺)磨泥(五)质羝(六)折(之热)唎[羊*(句-口+瓦)](七)摄迷(八)摄寐多鼻(九)奢(舒迦)安[羊*(句-口+瓦)](十)目讫[羊*(句-口+瓦)](十一)目讫跢(都个)檐(都灆)迷糁(稣灆)迷(十二)[禾*憂](乌合)鼻钐迷(十三)糁磨糁迷(十四)社(时夜)颐(余[羊*(句-口+瓦)]十五)憩(欹债)颐(十六)恶憩颐(十七)恶攲奶(奴皆十八)奢安[羊*(句-口+瓦)]摄寐(十九)阤逻腻(奴寄二十)阿(长声)卢迦婆迻(二十一)钵啰诋(都夜)鞞刹(驱察)腻(二十二)鼻鼻[口*路](二十三)[禾*憂]便(扶延)哆[這-言+囉]儞(奴弃)鼻瑟[〦/(刀*ㄚ*(留-刀-田))/齒](都皆二十四)頞(乌割)颠跢波唎秫(鼠出)啼(二十五)郁(于竹)究犁(二十六)目究犁(二十七)頞[這-言+囉]第(屠皆二十八)钵[這-言+囉]第(二十九)恕(鼠注)迦欹(三十)頞糁磨糁迷(三十一)勃地鼻卢吉[羊*(句-口+瓦)](三十二)达磨钵离器[羊*(句-口+瓦)](三十三)僧伽涅瞿杀奶(三十四)跋耶(余哥)跋夜(余个)输达泥(三十五)曼窒(都结)[口*梨](三十六)曼怛[這-言+囉]憩夜[羊*(句-口+瓦)](三十七)护路跢憍(俱昭)舍利颐(三十八)恶叉夜(三十九)恶叉跋奈(奴个)多夜(四十)跋庐优曼祢(奴夜)奈多夜

世尊。是陀罗尼神咒。六十二亿恒河沙等诸佛所说。若有侵毁此法师者。则为侵毁是诸佛已。时释迦牟尼佛赞药王菩萨言。善哉善哉。药王。汝愍念拥护此法师故。说是陀罗尼。于诸众生多所饶益

尔时勇施菩萨白佛言。世尊。我亦为拥护读诵受持法华经者。说陀罗尼。若此法师得是陀罗尼。若夜叉若罗刹。若富单那若吉蔗。若鸠槃荼若饿鬼等。伺求其短无能得便。即于佛前。而说咒曰

怛侄他(一)涉皤(菩播)犁(二)莫诃涉皤犁(三)郁鸡(四)目鸡(五)頞第(六)頞荼(屠迦)皤底(都弃七)涅唎致(都寄)颐(八)涅唎致耶跋底(九)壹郅(都笔)尔(十)比(扶必)郅尔(十一)质郅尔(十二)涅唎哲(都八)尔(十三)涅唎吒(都家反)跋尔(十四)

世尊。是陀罗尼神咒。恒河沙等诸佛所说。亦皆随喜。若有侵毁此法师者。则为侵毁是诸佛已

尔时毗沙门天王护世者白佛言。世尊。我亦为愍念众生。拥护此法师故。说是陀罗尼。即说咒曰

怛侄他(一)頞[齒*來](都皆二)捺(奴割)[齒*來](三)讷(奴骨)捺[齒*來](四)案那厨(拏句五)那稚(徒寄六)捃(俱运)奈(奴个)稚

世尊。以是神咒拥护法师。我亦自当拥护持是经者。令百由旬内无诸衰患。尔时持国天王在此会中。与千万亿那由他乾闼婆众恭敬围绕前诣佛所合掌白佛言。世尊。我亦以陀罗尼神咒。拥护持法华经者。即说咒曰

怛侄他(一)恶揭(其羯)奶(奴皆)揭奶(二)瞿唎(三)犍(伽安)陀唎(四)旃荼(徒家)利(五)摩登只(渠弃六)比羯肆(七)僧句犁(八)部[口*留]萨利(九)

世尊。是陀罗尼神咒。四十二亿诸佛所说。若有侵毁此法师者。则为侵毁是诸佛已

尔时有罗刹女等。一名蓝婆。二名毗蓝婆。三名曲齿。四名华齿。五名黑齿。六名多发。七名无厌足。八名持璎珞。九名睾帝。十名夺一切众生精气。是十罗刹女。与鬼子母并其子及眷属。俱诣佛所。同声白佛言。世尊。我亦欲拥护读诵受持法华经者除其衰患。若有伺求法师短者。令不得便。即于佛前。而说咒曰

怛侄他壹底(都弃)迷(此一句五遍道)尔(奴弃)迷(亦五遍)护[口*路]醯(呼羯亦五遍道)萨跢(都个)醯(亦五遍道)

宁上我头上。莫恼于法师。若夜叉若罗刹若饿鬼若富单那。若吉蔗若毗陀罗。若干驮若乌摩勒伽。若阿跋摩罗。若夜叉吉蔗。若人吉蔗。若热病。若一日若二日若三日若四日乃至七日。若常热病。若男形若女形。若童男形若童女形。乃至梦中亦复莫恼。即于佛前。而说偈言

  若不顺我咒　　恼乱说法者
  头破作七分　　如摩利阇迦
  如杀父母罪　　亦如压油殃
  斗秤欺诳人　　调达破僧罪
  犯此法师者　　当获如是殃

诸罗刹女。说此偈已白佛言。世尊。我等亦当身自拥护受持读诵修行是经者。令得安隐离诸衰患消众毒药。佛告诸罗刹女。善哉善哉。汝等但能拥护受持法华名者。福不可量。何况拥护具足受持。供养经卷。华香璎珞。末香涂香烧香幡盖伎乐。然种种灯。稣灯油灯诸香油灯。稣摩那华油灯。瞻卜华油灯。婆师迦华油灯。优波罗华油灯。如是等百千种供养者。睾谛汝等及眷属。应当拥护如是法师。说此陀罗尼咒品时。六万八千人得无生法忍

    妙法莲华经药王菩萨本事品第二十二

尔时宿王花菩萨白佛言。世尊。药王菩萨。云何游于娑婆世界。世尊。是药王菩萨。有若干百千万亿那由他难行苦行。善哉世尊。愿少解说。诸天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。又他国土诸来菩萨及此声闻众。闻皆欢喜。尔时佛告宿王花菩萨。乃往过去无量恒河沙劫有佛。号日月净明德如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛有八十亿大菩萨摩诃萨七十二恒河沙大声闻众。佛寿四万二千劫。菩萨寿命亦等。彼国无有女人地狱饿鬼畜生阿修罗等及以诸难。地平如掌琉璃所成。宝树庄严宝帐覆上。垂宝花幡。宝瓶香炉周遍国界。七宝为台。一树一台。其树去台尽一箭道。此诸宝树。皆有菩萨声闻而坐其下。诸宝台上。各有百亿诸天。作天伎乐歌叹于佛。以为供养

尔时彼佛。为一切众生喜见菩萨及众菩萨诸声闻众。说法华经。是一切众生喜见菩萨乐习苦行。于日月净明德佛法中。精进经行一心求佛。满万二千岁。已得现一切色身三昧。得此三昧已心大欢喜。即作念言。我得现一切色身三昧。皆是得闻法华经力。我今当供养日月净明德佛及法华经。即时入是三昧。于虚空中。雨曼陀罗华摩诃曼陀罗华细粖坚黑栴檀。满虚空中如云而下。又雨海此岸栴檀之香。此香六铢。价直娑婆世界。以供养佛。作是供养已。从三昧起。而自念言。我虽以神力供养于佛。不如以身供养。即服诸香栴檀薰陆兜楼婆毕力迦沉水胶香。又饮瞻卜诸华香油。满千二百岁已。香油涂身。于日月净明德佛前。以天宝衣而自缠身。灌诸香油。以神通力愿而自然身。光明遍照八十亿恒河沙世界。其中诸佛同时赞言。善哉善哉。善男子。是真精进。是名真法供养如来。若以华香璎珞烧香粖香涂香天缯幡盖及海此岸栴檀之香。如是等种种诸物供养。所不能及。假使国城妻子布施。亦所不及。善男子。是名第一之施。于诸施中最尊最上。以法供养诸如来故。作是语已而各嘿然。其身火然千二百岁。过是已后其身乃尽。一切众生喜见菩萨。作如是法供养已。命终之后。复生日月净明德佛国中。于净德王家。结加趺坐忽然化生。即为其父。而说偈言

  大王今当知　　我经行彼处
  即时得一切　　现诸身三昧
  勤行大精进　　舍所爱之身

说是偈已而白父言。日月净明德佛。今故现在。我先供养佛已。得解一切众生语言陀罗尼。复闻是法华经。八百千万亿那由他甄迦罗频婆罗阿閦婆等偈。大王。我今当还供养此佛。白已即坐七宝之台。上升虚空高七多罗树。往到佛所头面礼足。合十指爪以偈赞佛

  容颜甚奇妙　　光明照十方
  我适曾供养　　今复还亲觐

尔时一切众生喜见菩萨。说是偈已。而白佛言。世尊。世尊犹故在世。尔时日月净明德佛告一切众生喜见菩萨。善男子。我涅槃时到。灭尽时至。汝可安施床座。我于今夜当般涅槃。又敕一切众生喜见菩萨。善男子。我以佛法嘱累于汝及诸菩萨大弟子。并阿耨多罗三藐三菩提法。亦以三千大千七宝世界。诸宝树宝台及给侍诸天。悉付于汝。我灭度后所有舍利。亦付嘱汝。当令流布广设供养。应起若干千塔。如是日月净明德佛。敕一切众生喜见菩萨已。于夜后分入于涅槃。尔时一切众生喜见菩萨。见佛灭度。悲感懊恼恋慕于佛。即以海此岸栴檀为积。供养佛身而以烧之。火灭已后收取舍利。作八万四千宝瓶。以起八万四千塔。高三世界表刹庄严。垂诸幡盖悬众宝铃。尔时一切众生喜见菩萨。复自念言。我虽作是供养。心犹未足。我今当更供养舍利。便语诸菩萨大弟子及天龙夜叉等一切大众。汝等当一心念。我今供养日月净明德佛舍利。作是语已。即于八万四千塔前。然百福庄严臂。七万二千岁而以供养。令无数求声闻众无量阿僧祇人发阿耨多罗三藐三菩提心。皆使得住现一切色身三昧。尔时诸菩萨天人阿修罗等见其无臂。忧恼悲哀而作是言。此一切众生喜见菩萨。是我等师。教化我者。而今烧臂身不具足。于时一切众生喜见菩萨。于大众中立此誓言。我舍两臂。必当得佛金色之身。若实不虚。令我两臂还复如故。作是誓已自然还复。由斯菩萨福德智慧淳厚所致。当尔之时。三千大千世界六种震动。天雨宝华。一切人天得未曾有。佛告宿王华菩萨。于汝意云何。一切众生喜见菩萨。岂异人乎。今药王菩萨是也。其所舍身布施如是。无量百千万亿那由他数

宿王华。若有发心欲得阿耨多罗三藐三菩提者。能燃手指乃至足一指供养佛塔。胜以国城妻子及三千大千国土山林河池诸珍宝物而供养者。若复有人。以七宝满三千大千世界。供养于佛及大菩萨辟支佛阿罗汉。是人所得功德。不如受持此法华经乃至一四句偈。其福最多。宿王华。譬如一切川流江河诸水之中海为第一。此法华经亦复如是。于诸如来所说经中最为深大。又如土山黑山小铁围山大铁围山及十宝山。众山之中须弥山为第一。此法华经亦复如是。于诸经中最为其上。又如众星之中月天子最为第一。此法华经亦复如是。于千万亿种诸经法中。最为照明。又如日天子能除诸闇。此经亦复如是。能破一切不善之闇。又如诸小王中转轮圣王最为第一。此经亦复如是。于众经中最为其尊。又如帝释于三十三天中王。此经亦复如是。诸经中王。又如大梵天王一切众生之父。此经亦复如是。一切贤圣学无学及发菩萨心者之父。又如一切凡夫人中须陀洹斯陀含阿那含阿罗汉辟支佛为第一。此经亦复如是。一切如来所说。若菩萨所说。若声闻所说。诸经法中最为第一。有能受持是经典者。亦复如是。于一切众生中亦为第一。一切声闻辟支佛中。菩萨为第一。此经亦复如是。于一切诸经法中。最为第一。如佛为诸法王。此经亦复如是。诸经中王。宿王华。此经能救一切众生者。此经能令一切众生离诸苦恼。此经能大饶益一切众生。充满其愿。如清凉池。能满一切诸渴乏者。如寒者得火。如裸者得衣。如商人得主。如子得母。如渡得船。如病得医。如闇得灯。如贫得宝。如民得王。如贾客得海。如炬除闇。此法华经亦复如是。能令众生离一切苦一切病痛。能解一切生死之缚。若人得闻此法华经。若自书若使人书。所得功德。以佛智慧筹量多少。不得其边。若书是经卷。华香璎珞烧香粖香涂香幡盖衣服。种种之灯。稣灯油灯诸香油灯。瞻卜油灯。须曼那油灯。波罗罗油灯。婆利师迦油灯。那婆摩利油灯供养。所得功德亦复无量。宿王华。若有人闻是药王菩萨本事品者。亦得无量无边功德。若有女人。闻是药王菩萨本事品。能受持者。尽是女身后不复受。若如来灭后后五百岁中。若有女人。闻是经典如说修行。于此命终。即往安乐世界阿弥陀佛大菩萨众围绕住处。生莲花中宝座之上。不复为贪欲所恼。亦复不为嗔恚愚痴所恼。亦复不为憍慢嫉妒诸垢所恼。得菩萨神通无生法忍。得是忍已眼根清净。以是清净眼根。见七百万二千亿那由他恒河沙等诸佛如来。是时诸佛遥共赞言。善哉善哉。善男子。汝能于释迦牟尼佛法中。受持读诵思惟是经为他人说。所得福德无量无边。火不能焚水不能漂。汝之功德。千佛共说不能令尽。汝今已能破诸魔贼。坏生死军。诸余怨敌皆悉摧灭。善男子。百千诸佛以神通力。共守护汝。于一切世间天人之中。无如汝者。唯除如来。其诸声闻辟支佛乃至菩萨。智慧禅定无有与汝等者。宿王华。此菩萨成就如是功德智慧之力。若有人闻是药王菩萨本事品。能随喜赞善者。是人现世口中。常出青莲华香。身毛孔中。常出牛头栴檀之香。所得功德如上所说。是故宿王华。以此药王菩萨本事品。嘱累于汝。我灭度后后五百岁中。广宣流布于阎浮提。无令断绝。恶魔魔民诸天龙夜叉鸠槃茶等。得其便也。宿王华。汝当以神通之力守护是经。所以者何。此经则为阎浮提人病之良药。若人有病。得闻是经。病即消灭不老不死。宿王华。汝若见有受持是经者。应以青莲华盛满粖香供散其上。散已作是念言。此人不久。必当取草坐于道场破诸魔军。当吹法螺击大法鼓度脱一切众生老病死海。是故求佛道者。见有受持是经典人。应当如是生恭敬心。说是药王菩萨本事品时。八万四千菩萨。得解一切众生语言陀罗尼。多宝如来于宝塔中。赞宿王华菩萨言。善哉善哉。宿王华。汝成就不可思议功德。乃能问释迦牟尼佛如此之事。利益无量一切众生

添品妙法莲华经卷第六

安尔(一)曼尔(二)摩祢(三)摩摩祢(四)旨隶(五)遮梨第(六)赊咩(羊鸣音)赊履(罔雉切)多玮(七)膻(输千切)帝(八)目帝(九)目多履(十)娑履(十一)阿玮娑履(十二)桑履(十三)娑履(十四)叉裔(十五)阿叉裔(十六)阿耆腻(十七)膻帝(十八)赊履(十九)陀罗尼(二十)阿卢伽婆娑(苏奈切)簸遮毗叉腻(二十一)祢毗剃(二十二)阿便哆(都饿切)逻祢履剃(二十三)阿亶哆波隶输地(途置切二十四)沤究隶(二十五)牟究隶(二十六)阿罗隶(二十七)波罗隶(二十八)首迦差(初几切二十九)阿三磨三履(三十)佛陀毗吉利袠帝(三十一)达磨波利差(初离切)帝(三十二)僧伽涅瞿沙祢(三十三)婆舍婆舍输地(三十四)曼哆逻(三十五)曼哆逻叉夜多(三十六)邮楼哆(三十七)邮楼哆憍舍略(来加切三十八)恶叉逻(三十九)恶叉冶多冶(四十)阿婆卢(四十一)阿摩若(荏蔗切)那多夜(四十二)

痤(誓螺切)隶(一)摩诃痤隶(二)郁枳(三)目枳(四)阿隶(五)阿罗婆第(六)涅隶第(七)涅隶多婆第(八)伊致(猪履切)抳(九)韦致抳(十)旨致抳(十一)涅隶墀抳(十二)涅梨墀婆底(十三)

阿梨(一)那梨(二)[少/兔]那梨(三)阿那卢(四)那履(五)拘那履(六)

阿伽祢(一)伽祢(二)瞿利(三)乾陀利(四)旃陀利(五)摩蹬耆(六)常求利(七)浮楼莎抳(八)頞底(九)

伊提履(一)伊提泯(二)伊提履(三)阿提履(四)伊提履(五)泥履(六)泥履(七)泥履(八)泥履(九)泥履(十)楼醯(十一)楼醯(十二)楼醯(十三)楼醯(十四)多醯(十五)多醯(十六)多醯(十七)兜醯(十八)[少/兔]醯(十九)添品妙法莲华经卷第七

        隋天竺三藏阇那崛多共笈多译

    妙音菩萨品第二十三

尔时释迦牟尼佛。放大人相肉髻光明。及放眉间白毫相光。遍照东方百八万亿那由他恒河沙等诸佛世界。过是数已有世界。名净光庄严。其国有佛。号净华宿王智如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为无量无边菩萨大众。恭敬围绕而为说法。释迦牟尼佛白毫光明。遍照其国。尔时一切净光庄严国中。有一菩萨。名曰妙音。久已殖众德本。供养亲近无量百千万亿诸佛。而悉成就甚深智慧。得妙幢相三昧。法华三昧。净德三昧。宿王戏三昧。无缘三昧。智印三昧。解一切众生语言三昧。集一切功德三昧。清净三昧。神通游戏三昧。慧炬三昧。庄严王三昧。净光明三昧。净藏三昧。不共三昧。日旋三昧。得如是等百千万亿恒河沙等诸大三昧。释迦牟尼佛光照其身。即白净华宿王智佛言。世尊。我当往诣娑婆世界。礼拜亲近供养释迦牟尼佛。及见文殊师利法王子菩萨。药王菩萨。勇施菩萨。宿王华菩萨。上行意菩萨。庄严王菩萨。药上菩萨。尔时净华宿王智佛告妙音菩萨。汝往莫轻彼国生下劣想。善男子。彼娑婆世界高下不平。土石诸山秽恶充满。佛身卑小。诸菩萨众其形亦小。而汝身四万二千由旬。我身六百八十万由旬。汝身第一端正。百千万福光明殊妙。是故汝往莫轻彼国。若佛菩萨及国土生下劣想。妙音菩萨白其佛言。世尊。我今诣娑婆世界。皆是如来之力。如来神通游戏。如来功德智慧庄严。于是妙音菩萨。不起于座。身不动摇而入三昧。以三昧力。于耆阇崛山去法座不远。化作八万四千众宝莲华。阎浮檀金为茎。白银为叶。金刚为须。甄叔迦宝以为其台。尔时文殊师利法王子。见是莲华而白佛言。世尊。是何因缘先现此瑞。有若干千万莲华。阎浮檀金为茎。白银为叶。金刚为须。甄叔迦宝以为其台。尔时释迦牟尼佛告文殊师利。是妙音菩萨摩诃萨。欲从净华宿王智佛国。与八万四千菩萨围绕。而来至此娑婆世界。供养亲近礼拜于我。亦欲供养听法华经。文殊师利白佛言。世尊。是菩萨种何善本修何功德。而能有是大神通力。行何三昧。愿为我等说是三昧名字。我等亦欲勤修行之。行此三昧。乃能见是菩萨色相大小威仪进止。惟愿世尊。以神通力。彼菩萨来。令我得见。尔时释迦牟尼佛告文殊师利。此久灭度多宝如来。当为汝等而现其相。时多宝佛告彼菩萨。善男子来。文殊师利法王子欲见汝身。于时妙音菩萨于彼国没。与八万四千菩萨俱共发来。所经诸国六种震动。皆悉雨于七宝莲华。百千天乐不鼓自鸣是菩萨。目如广大青莲华叶。正使和合百千万月。其面貌端正复过于此。身真金色。无量百千功德庄严。威德炽盛光明照曜。诸相具足。如那罗延坚固之身。入七宝台上升虚空。去地七多罗树。诸菩萨众恭敬围绕。而来诣此娑婆世界耆阇崛山。到已下七宝台。以价直百千璎珞。持至释迦牟尼佛所。头面礼足奉上璎珞。而白佛言。世尊。净华宿王智佛问讯世尊。少病少恼起居轻利安乐行不。四大调和不。世事可忍不。众生易度不。无多贪欲嗔恚愚痴嫉妒悭慢不。无不孝父母不敬沙门不。无邪见不。无不善心不。摄五情不。世尊。众生能降伏诸魔怨不。久灭度多宝如来在七宝塔中来听法不。又问讯多宝如来。安隐少恼堪忍久住不。世尊。我今欲见多宝佛身。惟愿世尊。示我令见。尔时释迦牟尼佛语多宝佛。是妙音菩萨欲得相见。时多宝佛告妙音言。善哉善哉。汝能为供养释迦牟尼佛及听法华经并见文殊师利等故来至此。尔时华德菩萨白佛言。世尊。是妙音菩萨种何善根修何功德。有是神力。佛告华德菩萨。过去有佛。名云雷音王多陀阿伽度阿罗呵三藐三佛陀。国名现一切世间。劫名喜见。妙音菩萨于万二千岁以十万种伎乐供养云雷音王佛。并奉上八万四千七宝钵。以是因缘果报。今生净华宿王智佛所有是神力。华德。于汝意云何。尔时云雷音王佛所妙音菩萨伎乐供养奉上宝器者。岂异人乎。今此妙音菩萨摩诃萨是。华德。是妙音菩萨。已曾供养亲近无量诸佛。久殖德本。又值恒河沙等百千万亿那由他佛。华德。汝但见妙音菩萨其身在此。而是菩萨现种种身。处处为诸众生说是经典。或现梵王身。或现帝释身。或现自在天身。或现大自在天身。或现天大将军身。或现毗沙门天王身。或现转轮王身。或现诸小王身。或现长者身。或现居士身。或现宰官身。或现婆罗门身。或现比丘比丘尼优婆塞优婆夷身。或现长者居士妇女身。或现宰官妇女身。或现婆罗门妇女身。或现童男童女身。或现天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等身。而说是经。诸有地狱饿鬼畜生及众难处皆能救济。乃至于王后宫变为女身。而说是经。华德。是妙音菩萨。能救护娑婆世界诸众生者。是妙音菩萨。如是种种变化现身。在此娑婆国土。为诸众生说是经典。于神通变化智慧。无所损减。是菩萨。以若干智慧明照娑婆世界。令一切众生各得所知。于十方恒河沙世界中。亦复如是。若应以声闻形得度者。现声闻形而为说法应以辟支佛形得度者。现辟支佛形而为说法。应以菩萨形得度者。现菩萨形而为说法。应以佛形得度者。即现佛形而为说法。如是种种随所应度者。而为现形。乃至应以灭度而得度者。示现灭度。华德。妙音菩萨摩诃萨。成就大神通智慧之力。其事如是。尔时华德菩萨白佛言。世尊。是妙音菩萨深种善根。世尊。是菩萨住何三昧。而能如是在所变现度脱众生。佛告华德菩萨。善男子。其三昧。名现一切色身。妙音菩萨住是三昧中。能如是饶益无量众生。说是妙音菩萨品时。与妙音菩萨俱来者八万四千人。皆得现一切色身三昧。此娑婆世界无量菩萨。亦得是三昧及陀罗尼。尔时妙音菩萨摩诃萨。供养释迦牟尼佛及多宝佛塔已。还归本土。所经诸国六种震动雨宝莲华。作百千万亿种种伎乐。既到本国。与八万四千菩萨围绕。至净华宿王智佛所白佛言。世尊。我到娑婆世界饶益众生。见释迦牟尼佛及见多宝佛塔。礼拜供养。又见文殊师利法王子。及见药王菩萨得勤精进力菩萨勇施菩萨等。亦令是八万四千菩萨得现一切色身三昧。说是妙音菩萨来往品时。四万二千天子得无生法忍。华德菩萨得法华三昧

    添品妙法莲华经观世音菩萨普门品第二十四

尔时无尽意菩萨。即从座起偏袒右肩合掌向佛。而作是言。世尊。观世音菩萨。以何因缘名观世音。佛告无尽意菩萨。善男子。若有无量百千万亿众生。受诸苦恼。闻是观世音菩萨。一心称名观世音菩萨。即时观其音声皆得解脱

若有持是观世音菩萨名者。设入大火火不能烧。由是菩萨威神力故。若为大水所漂。称其名号即得浅处。若有百千万亿众生。为求金银琉璃车磲马瑙珊瑚琥珀真珠等宝。入于大海。假使黑风吹其船舫。飘堕罗刹鬼国。其中若有乃至一人称观世音菩萨名者。是诸人等皆得解脱罗刹之难以是因缘名观世音

若复有人临当被害。称观世音菩萨名者。彼所执刀杖。寻段段坏而得解脱。若三千大千国土满中夜叉罗刹。欲来恼人。闻其称观世音菩萨名者。是诸恶鬼尚不能以恶眼视之。况复加害

设复有人。若有罪若无罪。杻械枷锁捡系其身。称观世音菩萨名者。皆悉断坏即得解脱。若三千大千国土满中怨贼。有一商主将诸商人。赍持重宝经过险路。其中一人作是唱言。诸善男子勿得恐怖。汝等应当一心称观世音菩萨名号。是菩萨能以无畏施于众生。汝等若称名者。于此怨贼当得解脱。众商人闻俱发声言。南无观世音菩萨。称其名故即得解脱。无尽意。观世音菩萨摩诃萨。威神之力巍巍如是。若有众生。多于淫欲。常念恭敬观世音菩萨。便得离欲。若多嗔恚。常念恭敬观世音菩萨。便得离嗔。若多愚痴常念恭敬观世音菩萨。便得离痴。无尽意。观世音菩萨。有如是等大威神力。多所饶益。是故众生常应心念。若有女人。设欲求男。礼拜恭敬观世音菩萨。便生福德智慧之男。设欲求女。便生端正有相之女。宿殖德本众人爱敬。无尽意。观世音菩萨有如是力。若有众生。恭敬礼拜观世音菩萨。福不唐捐。是故众生。皆应受持观世音菩萨名号。无尽意。若有人受持六十二亿恒河沙菩萨名字。复尽形供养饮食衣服卧具医药。于汝意云何。是善男子善女人。功德多不。无尽意言。甚多世尊。佛言。若复有人。受持观世音菩萨名号。乃至一时礼拜供养。是二人福正等无异。于百千万亿劫不可穷尽。无尽意。受持观世音菩萨名号。得如是无量无边福德之利。无尽意菩萨白佛言。世尊。观世音菩萨。云何游此娑婆世界。云何而为众生说法。方便之力其事云何。佛告无尽意菩萨。善男子。若有国土众生应以佛身得度者。观世音菩萨。即现佛身而为说法。应以辟支佛身得度者。即现辟支佛身而为说法。应以声闻身得度者。即现声闻身而为说法。应以梵王身得度者。即现梵王身而为说法。应以帝释身得度者。即现帝释身而为说法。应以自在天身得度者。即现自在天身而为说法。应以大自在天身得度者。即现大自在天身而为说法。应以天大将军身得度者。即现天大将军身而为说法。应以毗沙门身得度者。即现毗沙门身而为说法。应以小王身得度者。即现小王身而为说法。应以长者身得度者。即现长者身而为说法。应以居士身得度者。即现居士身而为说法。应以宰官身得度者。即现宰官身而为说法。应以婆罗门身得度者。即现婆罗门身而为说法。应以比丘比丘尼优婆塞优婆夷身得度者。即现比丘比丘尼优婆塞优婆夷身而为说法。应以长者居士宰官婆罗门妇女身得度者。即现妇女身而为说法。应以童男童女身得度者。即现童男童女身而为说法。应以天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等身得度者。即皆现之而为说法。应以执金刚神得度者。即现执金刚神而为说法。无尽意。观世音菩萨。成就如是功德。以种种形游诸国土。度脱众生。是故汝等。应当一心供养观世音菩萨。是观世音菩萨摩诃萨。于怖畏急难之中。能施无畏。是故此娑婆世界。皆号之为施无畏者。无尽意菩萨白佛言。世尊。我今当供养观世音菩萨。即解颈众宝珠璎珞价直百千两金。而以与之。作是言。仁者。受此法施珍宝璎珞。时观世音菩萨不肯受之。无尽意复白观世音菩萨言。仁者。愍我等故受此璎珞。尔时佛告观世音菩萨。当愍此无尽意菩萨及四众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等故。受是璎珞。即时观世音菩萨。愍诸四众及于天龙人非人等故。受其璎珞。分作二分。一分奉释迦牟尼佛。一分奉多宝佛塔。无尽意。观世音菩萨。有如是自在神力。游于娑婆世界

尔时庄严幢菩萨问无尽意菩萨言。佛子。以何因缘名观世音。无尽意菩萨即便遍观观世音菩萨过去愿海。告庄严幢菩萨言。佛子谛听。观世音菩萨所行之行。尔时无尽意菩萨即说偈言

  世尊妙相具　　我今重问彼
  佛子何因缘　　名为观世音
  具足妙相尊　　偈答无尽意
  汝听观音行　　善应诸方所
  弘誓深如海　　历劫不思议
  侍多千亿佛　　发大清净愿
  我为汝略说　　闻名及见身
  心念不空过　　能灭诸有苦
  假使兴害意　　推落大火坑
  念彼观音力　　火坑变成池
  或漂流巨海　　鱼龙诸鬼难
  念彼观音力　　波浪不能没
  或在须弥峰　　为人所推堕
  念彼观音力　　如日虚空住
  或被恶人逐　　堕落金刚山
  念彼观音力　　不能损一毛
  或值怨贼绕　　各执刀加害
  念彼观音力　　咸即起慈心
  或遭王难苦　　临刑欲寿终
  念彼观音力　　刀寻段段坏
  或囚禁枷锁　　手足被杻械
  念彼观音力　　释然得解脱
  咒咀诸毒药　　所欲害身者
  念彼观音力　　彼即转回去
  或遇恶罗刹　　毒龙诸鬼等
  念彼观音力　　时悉不敢害
  若恶兽围绕　　利牙爪可怖
  念彼观音力　　疾走无边方
  蚖蛇及蝮蝎　　毒气烟火燃
  念彼观音力　　寻声自回去
  云雷鼓掣电　　降雹澍大雨
  念彼观音力　　应时得消散
  众生被困厄　　无量苦逼身
  观音妙智力　　能救世间苦
  具足神通力　　广修智方便
  十方诸国土　　无刹不现身
  种种诸恶趣　　地狱鬼畜生
  生老病死苦　　以渐悉令灭
  真观清净观　　广大智慧观
  悲观及慈观　　常愿常瞻仰
  无垢清净光　　慧日破诸闇
  能伏灾风火　　普明照世间
  悲体戒雷震　　慈意妙大云
  澍甘露法雨　　灭除烦恼焰
  诤讼经官处　　怖畏军阵中
  念彼观音力　　众怨悉退散
  妙音观世音　　梵音海潮音
  胜彼世间音　　是故须常念
  念念勿生疑　　观世音净圣
  于苦恼死厄　　能为作依怙
  具一切功德　　慈眼视众生
  福聚海无量　　是故应顶礼

尔时持地菩萨即从座起。前白佛言。世尊。若有众生。闻是观世音菩萨品自在之业普门示现神通力者。当知是人功德不少。佛说是普门品时。众中八万四千众生。皆发无等等阿耨多罗三藐三菩提心

    添品妙法莲华经妙庄严王本事品第二十五

尔时佛告诸大众。乃往古世。过无量无边不可思议阿僧祇劫有佛。名云雷音宿王华智多陀阿伽度阿罗诃三藐三佛陀。国名光明庄严。劫名喜见。彼佛法中有王。名妙庄严。其王夫人。名曰净德。有二子。一名净藏。二名净眼。是二子。有大神力福德智慧。久修菩萨所行之道。所谓檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。方便波罗蜜。慈悲喜舍。乃至三十七助道法。皆悉明了通达。又得菩萨净三昧。日星宿三昧。净光三昧。净色三昧净照明三昧。长庄严三昧。大威德藏三昧。于此三昧亦悉通达。尔时彼佛欲引导妙庄严王。及愍念众生故。说是法华经。时净藏净眼二子。到其母所合十指爪掌白言。愿母往诣云雷音宿王华智佛所。我等亦当侍从亲觐供养礼拜。所以者何。此佛于一切天人众中。说法华经。宜应听受。母告子言。汝父信受外道。深着婆罗门法。汝等应往白父与共俱去。净藏净眼合十指爪掌白母。我等是法王子。而生此邪见家。母告子言。汝等当忧念汝父为现神变。若得见者心必清净。或听我等往至佛所。于是二子。念其父故。踊在虚空高七多罗树。现种种神变。于虚空中行住坐卧。身上出水身下出火。身下出水身上出火。或现大身满虚空中。而复现小。小复现大。于空中灭。忽然在地。入地如水履水如地。现如是等种种神变。令其父王心净信解。时父见子神力如是。心大欢喜得未曾有。合掌向子言。汝等师为是谁。谁之弟子。二子白言。大王。彼云雷音宿王华智佛。今在七宝菩提树下法座上坐。于一切世间天人众中。广说法华经。是我等师。我是弟子。父语子言。我今亦欲见汝等师。可共俱往。于是二子从空中下。到其母所合掌白母。父王今已信解。堪任发阿耨多罗三藐三菩提心。我等为父已作佛事。愿母见听于彼佛所出家修道。尔时二子。欲重宣其意。以偈白母

  愿母放我等　　出家作沙门
  诸佛甚难值　　我等随佛学
  如优昙波罗　　值佛复难是
  脱诸难亦难　　愿听我出家

母即告言。听汝出家。所以者何。佛难值故。于是二子白父母言。善哉父母。愿时往诣云雷音宿王华智佛所亲觐供养。所以者何。佛难得值。如优昙波罗华。又如一眼之龟值浮木孔。而我等宿福深厚生值佛法。是故父母。当听我等令得出家。所以者何。诸佛难值时亦难遇。彼时妙庄严王。后宫八万四千人。悉皆堪任受持是法华经。净眼菩萨。于法华三昧久已通达。净藏菩萨。已于无量百千万亿劫通达离诸恶趣三昧。欲令一切众生离诸恶趣故。其王夫人。得诸佛集三昧。能知诸佛秘密之藏。二子如是以方便力善化其父。令心信解好乐佛法。于是妙庄严王。与群臣眷属俱。净德夫人与后宫婇女眷属俱。其王二子与四万二千人俱。一时共诣佛所。到已头面礼足。绕佛三匝却住一面。尔时彼佛。为王说法示教利喜。王大欢悦。尔时妙庄严王及其夫人。解颈真珠璎珞价直百千。以散佛上。于虚空中化成四柱宝台。台中有大宝床。敷百千万天衣。其上有佛结跏趺坐。放大光明

尔时妙庄严王作是念。佛身希有端严殊特。成就第一微妙之色。时云雷音宿王华智佛告四众言。汝等见是妙庄严王于我前合掌立不。此王于我法中作比丘。精勤修习助佛道法。当得作佛。号娑罗树王。国名大光。劫名大高王。其娑罗树王佛。有无量菩萨众及无量声闻。其国平正。功德如是。其王即时以国付弟。与夫人二子并诸眷属。于佛法中出家修道。王出家已。于八万四千岁常勤精进。修行妙法华经。过是已后。得一切净功德庄严三昧。即升虚空高七多罗树。而白佛言。世尊。此我二子已作佛事。以神通变化转我邪心令得安住于佛法中得见世尊。此二子者是我善知识。为欲发起宿世善根饶益我故。来生我家。尔时云雷音宿王华智佛告妙庄严王言。如是如是。如汝所言。若善男子善女人。种善根故。世世得善知识。其善知识。能作佛事示教利喜。令入阿耨多罗三藐三菩提。大王当知。善知识者是大因缘。所谓化导令得见佛。发阿耨多罗三藐三菩提心。大王。汝见此二子不。此二子已曾供养六十五百千万亿那由他恒河沙诸佛亲见恭敬。于诸佛所受持法华经。愍念邪见众生。令住正见。妙庄严王。即从虚空中下。而白佛言。世尊。如来甚希有以功德智慧故。顶上肉髻光明显照。其眼长广而绀青色。眉间毫相白如珂月。齿白齐密常有光明。唇色赤好如频婆果。尔时妙庄严王。赞叹佛如是等无量百千万亿功德已。于如来前一心合掌复白佛言。世尊。未曾有也。如来之法具足成就。不可思议微妙功德。教戒所行安隐快善。我从今日。不复自随心行。不生邪见憍慢嗔恚诸恶之心。说是语已礼佛而出。佛告大众。于意云何。妙庄严王。岂异人乎。今华德菩萨是。其净德夫人。今佛前光照庄严相菩萨是。哀愍妙庄严王及诸眷属故于彼中生。其二子者。今药王菩萨药上菩萨是。是药王药上菩萨。成就如此诸大功德。已于无量百千万亿诸佛所殖众德本。成就不可思议诸善功德。若有人识是二菩萨名字者。一切世间诸天人民。亦应礼拜。佛说是妙庄严王本事品时。八万四千人远尘离垢。于诸法中得法眼净

    添品妙法莲华经普贤菩萨劝发品第二十六

尔时普贤菩萨。以自在神通威德名闻。与大菩萨无量无边不可称数。从东方来。所经诸国普皆震动。雨宝莲华。作无量百千万亿种种伎乐。又与无数诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等大众围绕。各现威德神通之力。到娑婆世界耆阇崛山中。头面礼释迦牟尼佛。右绕七匝白佛言。世尊。我于宝威德上王佛国。遥闻此娑婆世界说法华经。与无量无边百千万亿诸菩萨众共来听受。唯愿世尊。当为说之。若善男子善女人。于如来灭后。云何能得是法华经。佛告普贤菩萨。若善男子善女人。成就四法。于如来灭后当得是法华经。一者为诸佛护念。二者殖诸德本。三者入正定聚。四者发救一切众生之心。善男子善女人。如是成就四法。于如来灭后必得是经。尔时普贤菩萨白佛言。世尊。于后五百岁浊恶世中。其有受持是经典者。我当守护除其衰患令得安隐。使无伺求得其便者。若魔若魔子。若魔女若魔民。若为魔所著者。若夜叉若罗刹。若鸠槃荼若毗舍阇。若吉遮若富单那。若韦陀罗等诸恼人者。皆不得便。是人若行若立读诵此经。我尔时乘六牙白象王。与大菩萨众俱诣其所而自现身。供养守护安慰其心。亦为供养法华经故。是人若坐思惟此经。尔时我复乘白象王。现其人前。其人若于此法华经。有所忘失一句一偈。我当教之与共读诵。还令通利。尔时受持读诵法华经者。得见我身。甚大欢喜转复精进。以见我故。即得三昧及陀罗尼。名为旋陀罗尼百千万亿旋陀罗尼法音方便陀罗尼。得如是等陀罗尼。世尊。若后世后五百岁浊恶世中。比丘比丘尼优婆塞优婆夷。求索者。受持者。读诵者。书写者。欲修习是法华经者。于三七日中应一心精进。满三七日已。我当乘六牙白象。与无量菩萨而自围绕。以一切众生所喜见身现其人前。而为说法示教利喜。亦复与其陀罗尼咒。得是陀罗尼故。无有非人能破坏者。亦不为女人之所惑乱。我身亦自常护是人。惟愿世尊。听我说此陀罗尼。即于佛前。而说咒曰

多(上)侄他阿坛荼(徒皆反)坛荼(直下反)钵底坛荼跋啰(上)多(上)尔坛荼(上)矩舍(始迦上反)犁坛荼稣(上)陀唎(上)稣(上)陀啰(上)陀啰(上)跋底勃驮钵膻泥陀啰(上)尼(奴移反)阿跋啰(上)怛尔阿啰怛尔僧伽(上)跛[口*梨](上)绮羯僧伽(上)尔伽多(上)泥达啰(上)磨(上)跛[口*梨](上)绮羯啰(上)婆(上)娑(上)多(上)婆(上)户噜多(上)憍(俱照反)舍(始迦上)罗耶阿(上)努伽(上)羝[言*斯]伽(上)鼻(上)抧[口*梨]驰(上)羝

世尊。若有菩萨。得闻是陀罗尼者。当知普贤神通之力。若法华经行阎浮提有受持者。应作是念。皆是普贤威神之力。若有受持读诵正忆念解其义趣如说修行。当知是人行普贤行。于无量无边诸佛所深种善根。为诸如来手摩其头。若但书写。是人命终。当生忉利天上。是时八万四千天女。作众伎乐而来迎之。其人即着七宝冠。于婇女中娱乐快乐。何况受持读诵正忆念解其义趣如说修行。若有人受持读诵解其义趣。是人命终为千佛授手令不恐怖。不堕恶趣。即往兜率天上弥勒菩萨所。弥勒菩萨有三十二相大菩萨众所共围绕。有百千万亿天女眷属。而于中生。有如是等功德利益。是故智者应当一心自书若使人书。受持读诵正忆念如说修行。世尊。我今以神通力守护是经。于如来灭后阎浮提内。广令流布使不断绝。尔时释迦牟尼佛赞言。善哉善哉。普贤。汝能护助是经。令多所众生安乐利益。汝已成就不可思议功德。深大慈悲。从久远来。发阿耨多罗三藐三菩提意。而能作是神通之愿。守护是经。我当以神通力守护能受持普贤菩萨名者。普贤。若有受持读诵正忆念修习书写是法华经者。当知是人则见释迦牟尼佛。如从佛口闻此经典。当知是人供养释迦牟尼佛。当知是人佛赞善哉。当知是人为释迦牟尼佛手摩其头。当知是人为释迦牟尼佛衣之所覆。如是之人不复贪着世乐。不好外道经书手笔。亦复不喜亲近其人。及诸恶者若屠儿若畜猪羊鸡狗若猎师若炫卖女色。是人心意质直。有正忆念有福德力。是人不为三毒所恼。亦不为嫉妒我慢邪慢增上慢所恼。是人少欲知足。能修普贤之行。普贤。若如来灭后后五百岁。若有人见受持读诵法华经者。应作是念。此人不久当诣道场破诸魔众。得阿耨多罗三藐三菩提。转法轮击法鼓吹法螺雨法雨。当坐天人大众中师子法座上。普贤。若于后世。受持读诵是经典者。是人不复贪着衣服卧具饮食资生之物。所愿不虚。亦于现世得其福报。若有人轻毁之言。汝狂人耳。空作是行终无所获。如是罪报。当世世无眼。若有供养赞叹之者。当于今世得现果报。若复见受持是经者。出其过恶。若实若不实。此人现世得白癞病。若有轻笑之者。当世世牙齿疏缺。丑唇平鼻手脚缭戾。眼目角睐身体臭秽。恶疮脓血水腹短气。诸恶重病。是故普贤。若见受持是经者。当起远迎当如敬佛。说是普贤劝发品时。恒河沙等无量无边菩萨。得百千亿旋陀罗尼。三千大千世界微尘等诸菩萨。具普贤道

    添品妙法莲华经嘱累品第二十七

尔时释迦牟尼佛。从座而起现大神力。以右手摩无量菩萨摩诃萨顶。而作是言。我于无量百千万亿阿僧祇劫。修集是难得阿耨多罗三藐三菩提法。今以付嘱汝等。汝等应当一心流布此法广令增益。如是三摩诸菩萨摩诃萨顶。而作是言。我于无量百千万亿阿僧祇劫。修集是难得阿耨多罗三藐三菩提法。今以付嘱汝等。汝当受持读诵广宣此法。令一切众生普得闻知。所以者何。如来有大慈悲。无诸悭吝。亦无所畏。能与众生佛之智慧如来智慧自然智慧。如来是一切众生之大施主。汝等亦应随学如来之法。勿生悭吝。于未来世。若有善男子善女人信如来智慧者。当为演说此法华经使得闻知。为令其人得佛慧故。若有众生不信受者。当于如来余深法中示教利喜。汝等若能如是。则为已报诸佛之恩。时诸菩萨摩诃萨闻佛作是说已。皆大欢喜遍满其身。益加恭敬曲躬低头。合掌向佛俱发声言。如世尊敕。当具奉行。唯然世尊。愿不有虑。诸菩萨摩诃萨众。如是三反俱发声言。如世尊敕当具奉行。唯然世尊。愿不有虑。尔时释迦牟尼佛。令十方来诸分身佛各还本土。而作是言。诸佛各随所安。多宝佛塔还可如故说是语时。十方无量分身诸佛坐宝树下师子座上者。及多宝佛并上行等无边阿僧祇菩萨大众。舍利弗等声闻四众。及一切世间天人阿修罗等。闻佛所说皆大欢喜

添品妙法莲华经卷第七

阿檀地(途置切一)檀陀婆地(二)檀陀婆帝(三)檀陀鸠舍隶(四)檀陀修陀隶(五)修陀隶(六)修陀罗婆底(七)佛驮波膻祢(八)萨婆陀罗尼阿婆多尼(九)萨婆婆沙阿婆多尼(十)修阿婆多尼(十一)僧伽婆履又尼(十二)僧伽涅伽陀尼(十三)阿僧祇(十四)僧伽婆伽地(十五)帝隶阿惰僧伽兜略(卢遮切)阿罗帝波罗帝(十六)萨婆僧伽三摩地伽兰地(十七)萨婆达磨修波利刹帝(十八)萨婆萨埵楼驮憍舍略阿[少/兔]伽地(十九)辛阿毗吉利地帝(二十)


无量义经序

    No. 276

    无量义经序

        萧齐荆州隐士刘虬作

无量义经者。取其无相一法。广生众教。含义不赀。故曰无量。夫三界群生随业而转。一极正觉任机而通。流转起灭者。必在苦而希乐。此叩圣之感也。顺通示现者。亦施悲而用慈。即救世之应也。根异教殊其阶成七。先为波利等说五戒。所谓人天善根一也。次为拘邻等转四谛。所谓授声闻乘二也。次为中根演十二因缘。所谓授缘觉乘三也。次为上根举六波罗蜜。所谓授以大乘四也。众教宣融群疑须导。次说无量义经。既称得道差品。复云未显真实。使发求实之冥机。用开一极之由绪五也。故法华接唱显一除三。顺彼求实之心。去此施权之名六也。虽权开而实现。犹掩常住之正义。在双树而临崖。乃畅我净之玄音七也。过此以往法门虽多。撮其大归数尽于此。亦由众声不出五音之表。百氏并在六家之内。其无量义经。虽法华首戴其目。而中夏未睹其说。每临讲肆。未尝不废谈而叹想见斯文。忽有武当山比丘慧表。生自羌胄。伪帝姚略从子。国破之日。为晋军何澹之所得。数岁聪黠。澹之字曰螟蛉。养为假子。俄放出家。便勤苦求道南北游寻。不择夷险。以齐建元三年。复访奇搜秘远至岭南。于广州朝廷寺。遇中天竺沙门昙摩伽陀耶舍。手能隶书。口解齐言。欲传此经未知所授。表便殷勤致请。心形俱至。淹历旬朔仅得一本。仍还峤北赍入武当。以今永明三年九月十八日。顶戴出山见校弘通。奉觌真文欣敬兼诚。咏歌不足手舞莫宣。辄虔访宿解抽刷庸思。谨立序注云。自极教应世与俗而差。神道救物称感成异。玄圃已东。号曰太一。罽宾以西。字为正学。东国明殃庆于百年。西域辩休咎于三世。希无之与修空。其揆一也。有欲于无者。既无得无之分。施心于空者。岂有入空之照。而讲求释教者。或谓会理可渐。或谓入空必顿。请试言之。以筌幽寄。立渐者。以万事之成。莫不有渐。坚冰基于履霜。九仞成于累土。学人之入空也。虽未圆符。譬如斩木去寸无寸去尺无尺。三空稍登宁非渐耶。立顿者。以希善之功。莫过观法性。法性从缘非有非无。忘虑于非有非无。理照斯一者。乃曰解空。存心于非有非无。境智犹二者。未免于有。有中伏结。非无日损之验。空上论心。未有入理之效。而言纳罗汉于一听。判无生于终朝。是接诱之言非称实之说。妙得非渐理固必然。既二谈分路两意争途。一去一取莫之或正。寻得旨之匠。起自支安。支公之论无生。以七住为道慧阴足。十住则群方与能。在迹斯异语照则一。安公之辩异观。三乘者。始篑之日称。定慧者。终成之实录。此谓始求可随根而三。入解则其慧不二。譬喻亦云。大难既夷乃无有三。险路既息其化即亡。此则名一为三。非有三悟明矣。生公云。道品可以泥洹。非罗汉之名。六度可以至佛。非树王之谓。斩木之喻。木存故尺寸可渐。无生之证。生尽故其照必顿。案三乘名教。皆以生尽照息。去有入空。以此为道。不得取像于形器也。今无量义亦以无相为本。若所证实异。岂曰无相。若入照必同。宁曰有渐。非渐而云渐。密筌之虚教耳。如来亦云。空拳诳小儿。以此度众生。微文接粗渐说或允。忘象得意顿义为长。聊举大较。谈者择焉

    无量义经德行品第一

        萧齐天竺三藏昙摩伽陀耶舍译

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众万二千人俱。菩萨摩诃萨八万人。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽诸比丘比丘尼优婆塞优婆夷俱。大转轮王小转轮王。金轮银轮诸转轮王。国王王子国臣国民。国士国女国大长者。各与眷属百千万数而自围绕。来诣佛所头面礼足绕百千匝。烧香散华种种供养。供养佛已退一面坐。其菩萨名曰文殊师利法王子。大威德藏法王子。无忧藏法王子。大辩藏法王子。弥勒菩萨。导首菩萨。药王菩萨。药上菩萨花幢菩萨。花光幢菩萨。陀罗尼自在王菩萨。观世音菩萨。大势至菩萨。常精进菩萨。宝印手菩萨。宝积菩萨。宝杖菩萨。越三界菩萨。毗摩跋罗菩萨。香象菩萨。大香象菩萨。师子吼王菩萨。师子游戏世菩萨。师子奋迅菩萨。师子精进菩萨。勇锐力菩萨。师子威猛伏菩萨。庄严菩萨。大庄严菩萨。如是等菩萨摩诃萨八万人俱。是诸菩萨。莫不皆是法身大士。戒定慧解脱解脱知见之所成就。其心禅寂常在三昧。恬安惔怕无为无欲。颠倒乱想不复得入。静寂清澄志玄虚漠。守之不动亿百千劫。无量法门悉现在前。得大智慧通达诸法。晓了分别性相真实。有无长短明现显白又能善知诸根性欲。以陀罗尼无碍辩才。请佛转法轮。随顺能转。微渧先堕以淹欲尘。开涅槃门扇解脱风。除世热恼致法清凉。次降甚深十二因缘。用洒无明老病死等。猛盛炽然苦聚日光。尔乃洪注无上大乘。润渍众生诸有善根。布善种子遍功德田。普令一切发菩提萌。智慧日月方便时节。扶疏增长大乘事业。令众疾成阿耨多罗三藐三菩提。常住快乐微妙真实。无量大悲救苦众生。是诸众生真善知识。是诸众生大良福田。是诸众生不请之师。是诸众生安隐乐处。救处护处大依止处。处处为众作大导师能为生盲而作眼目。聋劓哑者作耳鼻舌。诸根毁缺能令具足。颠狂荒乱作大正念。船师大船师运载群生渡生死河。置涅槃岸。医王大医王。分别病相晓了药性。随病授药令众乐服。调御大调御。无诸放逸行。犹如象马师。能调无不调。师子勇猛威伏众兽。难可沮坏。游戏菩萨诸波罗蜜。于如来地坚固不动。安住愿力广净佛国。不久得成阿耨多罗三藐三菩提。是诸菩萨摩诃萨。皆有如是不思议功德

其比丘。名曰大智舍利弗。神通目揵连。慧命须菩提。摩诃迦旃延。弥多罗尼子。富楼那。阿若憍陈如等。天眼阿那律。持律忧波离。侍者阿难。佛子罗云。忧波难陀。离婆多。劫宾那。薄拘罗。阿周陀。莎伽陀。头陀大迦叶。忧楼频螺迦叶。伽耶迦叶。那提迦叶。如是等比丘万二千人。皆阿罗汉尽诸结漏无复缚着。真正解脱。尔时大庄严菩萨摩诃萨遍观众坐各定意已。与众中八万菩萨摩诃萨俱。从坐而起来诣佛所。头面礼足绕百千匝。烧散天华天香天衣天璎珞天无价宝。从于空中旋转来下。四面云集而献于佛。天厨天钵器。天百味充满盈溢。见色闻香自然饱足。天幢天幡天幰盖天妙乐具。处处安置作天伎乐。娱乐于佛。即前胡跪合掌。一心俱共同声。说偈赞言

  大哉大悟大圣主　　无垢无染无所著
  天人象马调御师　　道风德香熏一切
  智恬情怕虑凝静　　意灭识亡心亦寂
  永断梦妄思想念　　无复诸大阴界入
  其身非有亦非无　　非因非缘非自他
  非方非圆非短长　　非出非没非生灭
  非造非起非为作　　非坐非卧非行住
  非动非转非闲静　　非进非退非安危
  非是非非非得失　　非彼非此非去来
  非青非黄非赤白　　非红非紫种种色
  戒定慧解知见生　　三明六通道品发
  慈悲十力无畏起　　众生善业因缘出
  示为丈六紫金晖　　方整照曜甚明彻
  毫相月旋项日光　　旋发绀青顶肉髻
  净眼明照上下眴　　眉睫绀舒方口颊
  唇舌赤好若丹果　　白齿四十犹珂雪
  额广鼻修面门开　　胸表卍字师子臆
  手足柔软具千辐　　腋掌合缦内外握
  臂修肘长指直纤　　皮肤细软毛右旋
  踝膝不现阴马藏　　细筋锁骨鹿膊肠
  表里映彻净无垢　　净水莫染不受尘
  如是等相三十二　　八十种好似可见
  而实无相非相色　　一切有相眼对绝
  无相之相有相身　　众生身相相亦然
  能令众生欢喜礼　　虔心表敬诚殷勤
  因是自高我慢除　　成就如是妙色躯
  我等八万之等众　　俱共稽首咸归命
  善灭思想心意识　　象马调御无著圣
  稽首归依法色身　　戒定慧解知见聚
  稽首归依妙幢相　　稽首归依难思议
  梵音雷震向八种　　微妙清净甚深远
  四谛六度十二缘　　随顺众生心业转
  有闻莫不心意开　　无量生死众结断
  有闻或得须陀洹　　斯陀阿那阿罗汉
  无漏无为缘觉处　　无生无灭菩萨地
  或得无量陀罗尼　　无碍乐说大辩才
  演说甚深微妙偈　　游戏澡浴法清池
  或跃飞腾现神足　　出没水火身自由
  如是法轮相如是　　清净无边难思议
  我等咸复共稽首　　归依法轮转以时
  稽首归依梵音声　　稽首归依缘谛度
  世尊往昔无量劫　　勤苦修习众德行
  为我人天龙神王　　普及一切诸众生
  能舍一切诸难舍　　财宝妻子及国城
  于法内外无所吝　　头目髓脑悉施人
  奉持诸佛清净戒　　乃至失命不毁伤
  若人刀杖来加害　　恶口骂辱终不嗔
  历劫挫身不倦惰　　昼夜摄心常在禅
  遍学一切众道法　　智慧深入众生根
  是故今得自在力　　于法自在为法王
  我等咸共俱稽首　　归依能勤诸难勤

    无量义经说法品第二

尔时大庄严菩萨摩诃萨与八万菩萨摩诃萨。说是偈赞佛已俱白佛言。世尊。我等八万菩萨之众。今者欲于如来法中有所咨问。不审世尊。垂愍听不。佛告大庄严菩萨及八万菩萨言。善哉善哉善男子。善知是时。恣汝所问。如来不久当般涅槃。涅槃之后普令一切无复余疑。欲何所问便可说也。于是大庄严菩萨与八万菩萨。即共同声白佛言。世尊。菩萨摩诃萨欲得疾成阿耨多罗三藐三菩提。应当修行何等法门。何等法门。能令菩萨摩诃萨疾成阿耨多罗三藐三菩提。佛告大庄严菩萨及八万菩萨言。善男子。有一法门。能令菩萨疾得阿耨多罗三藐三菩提。若有菩萨学是法门者。则能疾得阿耨多罗三藐三菩提。世尊。是法门者。号字何等其义云何。菩萨云何修行。佛言。善男子。是一法门。名为无量义。菩萨欲得修学无量义者。应当观察一切诸法。自本来今性相空寂。无大无小无生无灭。非住非动不进不退。犹如虚空无有二法。而诸众生虚妄横计。是此是彼是得是失。起不善念造众恶业。轮回六趣备诸苦毒。无量亿劫不能自出。菩萨摩诃萨如是谛观。生怜愍心发大慈悲将欲救拔。又复深入一切诸法。法相如是生如是法。法相如是住如是法。法相如是异如是法。法相如是灭如是法。法相如是能生恶法。法相如是能生善法。住异灭者亦复如是。菩萨如是观察四相始末。悉遍知已。次复谛观一切诸法。念念不住新新生灭。复观即时生住异灭。如是观已。而入众生诸根性欲。性欲无量故。说法无量。说法无量义亦无量。无量义者。从一法生。其一法者。即无相也。如是无相。无相不相。不相无相。名为实相。菩萨摩诃萨安住如是真实相已。所发慈悲明谛不虚。于众生所真能拔苦。苦既拔已。复为说法。令诸众生受于快乐。善男子。菩萨若能如是修一法门无量义者。必得疾成阿耨多罗三藐三菩提。善男子。如是甚深无上大乘无量义经。文理真正尊无过上。三世诸佛所共守护。无有众魔群道得入。不为一切邪见生死之所坏败。是故善男子。菩萨摩诃萨若欲疾成无上菩提。应当修学如是甚深无上大乘无量义经。尔时大庄严菩萨复白佛言。世尊。世尊说法不可思议。众生根性亦不可思议。法门解脱亦不可思议。我等于佛所说诸法。无复疑惑。而诸众生生迷惑心故重咨问。世尊。自从如来得道已来四十余年。常为众生演说诸法四相之义。苦义空义无常无我。无大无小无生无灭。一切无相。法性法相本来空寂不来不去不出不没。若有闻者。或得暖法顶法世第一法须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。发菩提心登第一地第二第三至第十地。往日所说诸法之义。与今所说有何等异。而言甚深无上大乘无量义经。菩萨修行必得疾成无上菩提。是事云何。唯愿世尊。慈愍一切。广为众生而分别之。普令现在及未来世有闻法者无余疑网。于是佛告大庄严菩萨。善哉善哉大善男子。能问如来如是甚深无上大乘微妙之义。当知汝能多所利益。安乐人天拔苦众生。真大慈悲信实不虚。以是因缘必得疾成无上菩提。亦令一切今世来世诸有众生得成无上菩提。善男子。自我道场菩提树下端坐六年。得成阿耨多罗三藐三菩提。以佛眼观一切诸法不可宣说。所以者何。以诸众生性欲不同。性欲不同种种说法。种种说法以方便力。四十余年未曾显实。是故众生得道差别。不得疾成无上菩提。善男子。法譬如水能洗垢秽若井若池若江若河溪渠大海。皆悉能洗诸有垢秽。其法水者亦复如是。能洗众生诸烦恼垢。善男子。水性是一。江河井池溪渠大海。各各别异。其法性者亦复如是。洗除尘劳等无差别。三法四果二道不一。善男子。水虽俱洗。而井非池。池非江河。溪渠非海。而如来世雄于法自在。所说诸法亦复如是。初中后说。皆能洗除众生烦恼。而初非中。而中非后。初中后说。文辞虽一而义各异。善男子。我起树王诣波罗奈鹿野园中。为阿若拘邻等五人转四谛法轮时。亦说诸法本来空寂代谢不住念念生灭。中间于此及以处处为诸比丘并众菩萨。辩演宣说十二因缘六波罗蜜。亦说诸法本来空寂代谢不住念念生灭。今复于此演说大乘无量义经。亦说诸法本来空寂代谢不住念念生灭。善男子。是故初说中说今说。文辞是一而义差异。义异故。众生解异。解异故。得法得果得道亦异。善男子。初说四谛。为求声闻人。而八亿诸天来下听法。发菩提心。中于处处演说甚深十二因缘。为求辟支佛人。而无量众生发菩提心。或住声闻。次说方等十二部经摩诃般若华严海云。演说菩萨历劫修行。而百千比丘万亿人天无量得须陀洹得斯陀含得阿那含得阿罗汉。住辟支佛因缘法中。善男子。以是义故。故知说同而义别异。义异故。众生解异。解异故。得法得果得道亦异。是故善男子。自我得道初起说法至于今日。演说大乘无量义经。未曾不说苦空无常无我。非真非假非大非小本来不然。今亦不灭一切无相。法相法性不来不去。而众生四相所迁。善男子。以是义故。诸佛无有二言。能以一音普应众声。能以一身。示百千万亿那由他无量无数恒河沙身。一一身中。又示若干百千万亿那由他阿僧祇恒河沙种种类形。一一形中。又示若干百千万亿那由他阿僧祇恒河沙形。善男子。是则诸佛不可思议甚深境界。非二乘所知。亦非十住菩萨所及。唯佛与佛乃能究了。善男子。是故我说微妙甚深无上大乘无量义经。文理真正尊无过上。三世诸佛所共守护。无有众魔外道得入。不为一切邪见生死之所坏败。菩萨摩诃萨若欲疾成无上菩提。应当修学如是甚深无上大乘无量义经。佛说是已。于是三千大千世界六种震动。自然空中雨种种花。天忧钵罗华钵昙摩华拘物头华分陀利华。又雨无数种种天香天衣天璎珞天无价宝。于上空中旋转来下。供养于佛及诸菩萨声闻大众。天厨天钵器。天百味充满盈溢。天幢天幡天幰盖天妙乐具处处安置。作天伎乐歌叹于佛。又复六种震动。东方恒河沙等诸佛世界。亦雨天华天香天衣天璎珞天无价宝。天厨天钵器天百味。天幢天幡天幰盖天妙乐具作天伎乐。歌叹彼佛及彼菩萨声闻大众。南西北方四维上下亦复如是。于是众中三万二千菩萨摩诃萨得无量义三昧。三万四千菩萨摩诃萨得无数无量陀罗尼门。能转一切三世诸佛不退转法轮。其诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。大转轮王小转轮王银轮铁轮诸转轮王。国王王子国臣国民。国士国女国大长者。及诸眷属百千众俱。闻佛如来说是经时。或得暖法顶法世间第一法须陀洹果。斯陀含果阿那含果阿罗汉果辟支佛果。又得菩萨无生法忍。又得一陀罗尼又得二陀罗尼。又得三陀罗尼。又得四陀罗尼五六七八九十陀罗尼。又得百千万亿陀罗尼。又得无量无数恒河沙阿僧祇陀罗尼。皆能随顺转不退转法轮。无量众生发阿耨多罗三藐三菩提心

    无量义经十功德品第三

尔时大庄严菩萨摩诃萨复白佛言。世尊。世尊说是微妙甚深无上大乘无量义经。真实甚深甚深甚深。所以者何。于此众中。诸菩萨摩诃萨及诸四众。天龙鬼神国王臣民诸有众生。闻是甚深无上大乘无量义经。无不获得陀罗尼门。三法四果菩提之心。当知此经。文理真正尊无过上。三世诸佛之所守护。无有众魔群道得入。不为一切邪见生死之所坏败。所以者何。一闻能持一切法故。若有众生得闻是经。则为大利。所以者何。若能修行。必得疾成阿耨多罗三藐三菩提。其有众生不得闻者。当知是等为失大利。过无量无边不可思议阿僧祇劫。终不得成阿耨多罗三藐三菩提。所以者何。不知菩提大道直故行于险径多留难故。世尊。是经典者不可思议。唯愿世尊。广为大众慈哀敷演是经甚深不思议事。世尊。是经典者。从何所来。去何所至。住何所住。乃有如是无量功德不思议力。令众疾成阿耨多罗三藐三菩提。尔时世尊告大庄严菩萨摩诃萨言。善哉善哉善男子。如是如是如汝所言。善男子。我说是经甚深甚深真实甚深。所以者何。令众疾成阿耨多罗三藐三菩提故。一闻能持一切法故。于诸众生大利益故。行大直道无留难故。善男子。汝问是经。从何所来去至何所住何所住者。当善谛听。善男子。是经本从诸佛宫宅中来。去至一切众生发菩提心。住诸菩萨所行之处。善男子。是经。如是来如是去如是住。是故此经。能有如是无量功德不思议力。令众疾成阿耨多罗三藐三菩提。善男子。汝宁欲闻是经复有十不思议功德力不。大庄严言。愿乐欲闻。佛言。善男子。第一是经。能令菩萨未发心者发菩提心。无慈仁者起于慈心。好杀戮者起大悲心。生嫉妒者起随喜心。有爱著者起能舍心。诸悭贪者起布施心。多憍慢者起持戒心。嗔恚盛者起忍辱心。生懈怠者起精进心。诸散乱者起禅定心。于愚痴者起智慧心。未能度彼者起度彼心。行十恶者起十善心。乐有为者志无为心。有退心者作不退心。为有漏者起无漏心。多烦恼者起除灭心。善男子。是名是经第一功德不思议力。善男子。第二是经不可思议功德力者若有众生得是经者。若一转若一偈。乃至一句。则能通达百千亿义。无量数劫不能演说所受持法。所以者何。以其是法义无量故。善男子。是经譬如从一种子生百千万。百千万中。一一复生百千万数。如是展转乃至无量。是经典者亦复如是。从于一法生百千义。百千义中。一一复生百千万数。如是展转。乃至无量无边之义。是故此经。名无量义。善男子。是名是经第二功德不思议力

善男子。第三是经不可思议功德力者。若有众生得闻是经。若一转若一偈乃至一句。通达百千万亿义已。虽有烦恼如无烦恼。出生入死无怖畏想。于诸众生生怜愍心。于一切法得勇健想。如壮力士能担能持诸有重者。是持经人亦复如是。能荷无上菩提重宝。担负众生出生死道。未能自度已能度彼。犹如船师身婴重病。四体不御安止此岸。有好坚牢船舟。常办诸度彼者之具。给与而去。是持经者亦复如是。虽婴五道诸有之身百八重病常恒相缠。安止无明老死此岸。而有坚牢此大乘经无量义办。能度众生。能如说行者得度生死。善男子。是名是经第三功德不思议力

善男子。第四是经不可思议功德力者。若有众生得闻是经。若一转若一偈乃至一句。得勇健想。虽未自度而能度他。与诸菩萨以为眷属。诸佛如来。常向是人而演说法。是人闻已。悉能受持随顺不逆。转复为人随宜广说。善男子。是人譬如国王夫人新生王子。若一日若二日若至七日。若一月若二月若至七月。若一岁若二岁若至七岁。虽复不能领理国事。己为臣民之所宗敬。诸大王子以为伴侣。王及夫人。爱心偏重常与共语。所以者何。以稚小故。善男子。是持经者亦复如是。诸佛国王是经夫人。和合共生是菩萨子。若是菩萨得闻是经。若一句若一偈。若一转若二转。若十若百若千若万。若亿万亿若恒河沙。无量无数转。虽复不能体真理极。虽复不能震动三千大千国土雷震梵音转大法轮。己为一切四众八部之所宗仰。诸大菩萨以为眷属。深入诸佛秘密之法。所可演说无违无失。常为诸佛之所护念。慈爱偏覆。以新学故。善男子。是名是经第四功德不思议力

善男子。第五是经不可思议功德力者。若善男子善女人。若佛在世若灭度后。其有受持读诵书写如是甚深无上大乘无量义经。是人虽复具缚烦恼未能远离诸凡夫事。而能示现大菩提道。延于一日以为百劫。百劫亦能促为一日。令彼众生欢喜信伏。善男子。是善男子善女人。譬如龙子始生七日。即能兴云亦能降雨。善男子。是名是经第五功德不思议力

善男子。第六是经不可思议功德力者。若善男子善女人。若佛在世若灭度后。受持读诵是经典者。虽具烦恼而为众生说法。令得远离烦恼生死断一切苦。众生闻已修行得法得果得道。与佛如来等无差别。譬如王子。虽复稚小。若王游巡及以疾病。委是王子领理国事。王子是时依大王命如法教令。群寮百官宣流正化。国土人民各随其安。如大王治等无有异。持经善男子善女人亦复如是。若佛在世若灭度后。是善男子。虽未得住初不动地。依佛如是用说教法而敷演之。众生闻已一心修行。断除烦恼得法得果乃至得道。善男子。是名是经第六功德不思议力

善男子。第七是经不可思议功德力者。若善男子善女人。于佛在世若灭度后得闻是经。欢喜信乐生希有心。受持读诵书写解说。如法修行发菩提心。起诸善根兴大悲意。欲度一切苦恼众生。虽未修行六波罗蜜。六波罗蜜自然在前。即于是身得无生忍。生死烦恼一时断坏。即升第七地与大菩萨位。譬如健人为王除怨。怨既灭已王大欢喜。赏赐半国之封皆悉与之。持经男子女人亦复如是。于诸行人最为勇健。六度法宝不求自至。生死怨敌自然散坏证无生忍。半佛国宝封赏安乐。善男子。是名是经第七功德不思议力

善男子。第八是经不可思议功德力者。若善男子善女人。于佛在世若灭度后。有人能得是经典者。敬信如视佛身令等无异。爱乐是经受持读诵书写顶戴如法奉行。坚固戒忍兼行檀度。深发慈悲。以此无上大乘无量义经。广为人说。若人先来都不信有罪福者。以是经示之。设种种方便强化令信。以经威力故。发其人心欻然得回。信心既发。勇猛精进故。能得是经威德势力得道得果。是故善男子善女人。即于是身得无生法忍得至上地。与诸菩萨以为眷属。速能成就众生净佛国土。不久得成无上菩提。善男子。是名是经第八功德不思议力

善男子。第九是经不可思议功德力者。若善男子善女人。若佛在世及灭度后。有得是经欢喜踊跃得未曾有。受持读诵书写供养。广为众人分别解说是经义者。即得宿业余罪重障一时灭尽。便得清净逮得大辩。次第庄严诸波罗蜜。获诸三昧首楞严三昧。入大总持门。得勤精进力。速越上地。善能分身散体遍十方国。拔济一切二十五有极苦众生悉令解脱。是故是经有如此力。善男子。是名是经第九功德不思议力

善男子。第十是经不可思议功德力者。若善男子善女人。若佛在世及灭度后。若得是经发大欢喜生希有心。即自受持读诵书写供养如说修行。复能广劝在家出家人。受持读诵书写供养解说如法修行。既令余人修行是经力故得道得果。皆由是善男子善女人慈心勤化力故。是善男子善女人。即于是身便逮无量诸陀罗尼门。于凡夫地自然初时能发无数阿僧祇弘誓大愿。深能发救一切众生成就大悲广能救苦。厚集善根饶益一切。而演法泽洪润枯涸。以众法药练诸众生安乐一切。渐见超登住法云地。恩泽普润慈被无外。摄苦众生令入道迹。是故此人不久得成阿耨多罗三藐三菩提。善男子。是名是经第十功德不思议力

善男子。如是无上大乘无量义经。极有大威神之力。尊无过上。能令诸凡夫皆成圣果。永离生死而得自在。是故此经名无量义也。能令一切众生于凡夫地生起诸菩萨无量道芽。令功德树蔚茂扶疏增长。是故此经号十不可思议功德力也

于是大庄严菩萨摩诃萨及八万菩萨摩诃萨同声白佛言。世尊。佛所说甚深微妙无上大乘无量义经。文理真正尊无过上。三世诸佛所共守护。无有众魔群道得入。不为一切邪见生死之所坏败。是故此经乃有如是十种功德不思议力。大饶益无量一切众生。令一切诸菩萨摩诃萨各得无量义三昧。或得百千陀罗尼门。或令得菩萨诸地诸忍。或得缘觉罗汉四道果证。世尊慈愍。快为我等说如是法。令我大获法利。甚为奇特。未曾有也。世尊慈恩实难可报。尔时三千大千世界六种震动。于上空中复雨种种华。天忧钵罗华。钵昙摩华。拘物头华。分陀利华。又雨无数种种天香天衣天璎珞天无价宝。于上空中旋转来下。供养于佛及诸菩萨声闻大众。天厨天钵器。天百味充满盈溢。见色闻香自然饱足。天幢天幡天幰盖。天妙乐具处处安置。作天伎乐歌叹于佛。又复六种震动东方恒河沙等诸佛世界。亦雨天华天香天衣天璎珞天无价宝。天厨天钵器天百味。见色闻香自然饱足。天幢天幡天幰盖天妙乐具。作天伎乐歌叹彼佛及诸菩萨声闻大众。南西北方四维上下亦复如是。尔时佛告大庄严菩萨摩诃萨及八万菩萨摩诃萨言。汝等当于此经应深起敬心如法修行。广化一切勤心流布。常当殷勤昼夜守护。普令众生各获法利。汝等真是大慈大悲。以立神通愿力守护是经勿使疑滞。于当来世必令广行阎浮提。令一切众生使得见闻读诵书写供养。以是之故。亦令汝等速得阿耨多罗三藐三菩提。是时大庄严菩萨摩诃萨。与八万菩萨摩诃萨。即从坐起来诣佛所。头面礼足绕百千匝。即前胡跪俱共同声白佛言。世尊。我等快蒙世尊慈愍。为我等说是甚深微妙无上大乘无量义经。敬受佛敕。于如来灭后。当广令流布是经典者。普令一切受持读诵书写供养。唯愿世尊。勿垂忧虑。我等当以愿力。普令一切众生使得见闻读诵书写供养。得是经法威神之力。尔时佛赞言。善哉善哉。诸善男子。汝等今者真是佛子。大慈大悲深能拔苦救厄者矣。一切众生之良福田。广为一切作大良导。一切众生大依止处。一切众生之大施主。常以法利广施一切。尔时大会皆大欢喜。为佛作礼。受持而去无量义经


御制大乘妙法莲华经序

    No. 262 [Nos. 263, 264]

    御制大乘妙法莲华经序

昔如来于耆阇崛山中。与大阿罗汉阿若憍陈如摩诃迦叶无量等众。演说大乘真经。名无量义。是时天雨宝华布濩充满。慧光现瑞洞烛幽显。普佛世界六种震动。一切人天得未曾有。咸皆欢喜赞叹。以为是经乃诸佛如来秘密之藏。神妙叵测。广大难名。所以拔滞溺之沈流。拯昏迷之失性。功德弘远莫可涯涘。溯求其源。肇彼竺干流于震旦。爰自西晋沙门竺法护者初加翻译。名曰正法华。暨东晋龟兹三藏法师鸠摩罗什重翻。名曰妙法莲华。至隋天竺沙门阇那笈多所翻者。亦名妙法。虽三经文理重沓互陈。而惟三藏法师独得其旨。第历世既远。不无讹谬。匪资刊正。渐致多疑。用是特加仇校。仍命镂梓。以广其传。呜呼如来愍诸众生。有种种性种种欲种种行种种忆想分别。历劫缠绕无有出期。乃为此大事因缘现世。敷畅妙旨。作殊胜方便。俾皆得度脱超登正觉。此诚济海之津梁。而烛幽之慧炬也。善男子善女人一切众生。能秉心至诚。持诵佩服顶礼供养。即离一切苦恼。除一切业障。解一切生死之厄。不啻如饥之得食。如渴之得饮。如寒之得火。如热之得凉。如贫之得宝。如病之得医。如子之得母。如渡之得舟。其为快适欣慰。有不可言。噫道非经无以寓。法非经无以传。缘经以求法。缘法以悟道。方识是经之旨。清净微妙第一希有。遵之者则身臻康泰。诸种善根圆满具足。如莲华出水不染淤泥。即得五蕴皆空六根清净。遄跻上善。以成于正觉者不难矣。苟或沉迷胶固。甘心堕落绝灭善根。则身罹苦趣。轮回于生死之域者。其有纪极哉。虽然善恶两途。由人所趋。为善获吉。为恶获凶。幽明果报。不爽锱铢。观于是经者。尚戒之哉。尚勉之哉

永乐十八年四月十七日

    妙法莲华经弘传序

        唐终南山释道宣述

妙法莲华经者。统诸佛降灵之本致也。蕴结大夏出彼千龄。东传震旦三百余载。西晋惠帝永康年中。长安青门炖煌菩萨竺法护者。初翻此经。名正法华。东晋安帝隆安年中。后秦弘始。龟兹沙门鸠摩罗什。次翻此经。名妙法莲华。隋氏仁寿。大兴善寺北天竺沙门阇那笈多。后所翻者。同名妙法。三经重沓文旨互陈。时所宗尚。皆弘秦本。自余支品别偈不无其流。具如序历。故所非述

夫以灵岳降灵。非大圣无由开化。适化所及。非昔缘无以导心。所以仙苑告成。机分小大之别。金河顾命。道殊半满之科。岂非教被乘时。无足核其高会。是知五千退席。为进增慢之俦。五百授记。俱崇密化之迹。所以放光现瑞。开发请之教源。出定扬德。畅佛慧之宏略。朽宅通入大之文轨。化城引昔缘之不坠。系珠明理性之常在。凿井显示悟之多方。词义宛然。喻陈惟远。自非大哀旷济。拔滞溺之沈流。一极悲心。拯昏迷之失性。自汉至唐六百余载。总历群籍四千余轴。受持盛者。无出此经。将非机教相扣。并智胜之遗尘。闻而深敬。俱威王之余绩。辄于经首。序而综之。庶得早净六根。仰慈尊之嘉会。速成四德。趣乐土之玄猷。弘赞莫穷。永贻诸后。云尔

妙法莲华经卷第一

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    序品第一

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。皆是阿罗汉。诸漏已尽无复烦恼。逮得己利尽诸有结。心得自在。其名曰阿若憍陈如。摩诃迦叶。优楼频螺迦叶。迦耶迦叶。那提迦叶。舍利弗。大目揵连。摩诃迦旃延。阿[少/(兔-、)]楼驮。劫宾那。憍梵波提。离婆多。毕陵伽婆蹉。薄拘罗。摩诃拘絺罗。难陀。孙陀罗难陀。富楼那弥多罗尼子。须菩提。阿难。罗睺罗。如是众所知识大阿罗汉等。复有学无学二千人。摩诃波阇波提比丘尼。与眷属六千人俱。罗睺罗母耶输陀罗比丘尼。亦与眷属俱。菩萨摩诃萨八万人。皆于阿耨多罗三藐三菩提不退转。皆得陀罗尼乐说辩才。转不退转法轮。供养无量百千诸佛。于诸佛所殖众德本。常为诸佛之所称叹。以慈修身善入佛慧。通达大智到于彼岸。名称普闻无量世界。能度无数百千众生。其名曰文殊师利菩萨。观世音菩萨。得大势菩萨。常精进菩萨。不休息菩萨。宝掌菩萨。药王菩萨。勇施菩萨。宝月菩萨。月光菩萨。满月菩萨。大力菩萨。无量力菩萨。越三界菩萨。跋陀婆罗菩萨。弥勒菩萨。宝积菩萨。导师菩萨。如是等菩萨摩诃萨八万人俱

尔时释提桓因。与其眷属二万天子俱。复有名月天子。普香天子。宝光天子。四大天王。与其眷属万天子俱。自在天子。大自在天子。与其眷属三万天子俱。娑婆世界主梵天王。尸弃大梵光明大梵等。与其眷属万二千天子俱。有八龙王。难陀龙王。跋难陀龙王。娑伽罗龙王。和修吉龙王。德叉迦龙王。阿那婆达多龙王。摩那斯龙王。优钵罗龙王等。各与若干百千眷属俱。有四紧那罗王。法紧那罗王。妙法紧那罗王。大法紧那罗王。持法紧那罗王。各与若干百千眷属俱。有四乾闼婆王。乐乾闼婆王。乐音乾闼婆王。美乾闼婆王。美音乾闼婆王。各与若干百千眷属俱。有四阿修罗王。婆稚阿修罗王。佉罗骞驮阿修罗王。毗摩质多罗阿修罗王。罗睺阿修罗王各与若干百千眷属俱。有四迦楼罗王。大威德迦楼罗王。大身迦楼罗王。大满迦楼罗王。如意迦楼罗王。各与若干百千眷属俱。韦提希子阿阇世王。与若干百千眷属俱。各礼佛足退坐一面

尔时世尊。四众围绕。供养恭敬尊重赞叹。为诸菩萨说大乘经。名无量义教菩萨法佛所护念。佛说此经已。结加趺坐。入于无量义处三昧。身心不动。是时天雨曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上及诸大众。普佛世界六种震动。尔时会中比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。及诸小王转轮圣王。是诸大众得未曾有。欢喜合掌一心观佛。尔时佛放眉间白毫相光。照东方万八千世界。靡不周遍。下至阿鼻地狱。上至阿迦尼吒天。于此世界。尽见彼土六趣众生。又见彼土现在诸佛。及闻诸佛所说经法。并见彼诸比丘比丘尼优婆塞优婆夷诸修行得道者。复见诸菩萨摩诃萨种种因缘种种信解种种相貌行菩萨道。复见诸佛般涅槃者。复见诸佛般涅槃后以佛舍利起七宝塔。尔时弥勒菩萨作是念。今者世尊现神变相。以何因缘而有此瑞。今佛世尊入于三昧。是不可思议现希有事。当以问谁。谁能答者。复作此念。是文殊师利法王之子。已曾亲近供养过去无量诸佛。必应见此希有之相。我今当问。尔时比丘比丘尼优婆塞优婆夷。及诸天龙鬼神等咸作此念。是佛光明神通之相。今当问谁。尔时弥勒菩萨欲自决疑。又观四众比丘比丘尼优婆塞优婆夷。及诸天龙鬼神等众会之心。而问文殊师利言。以何因缘而有此瑞神通之相。放大光明照于东方万八千土。悉见彼佛国界庄严。于是弥勒菩萨。欲重宣此义。以偈问曰

  文殊师利　　导师何故　　眉间白毫
  大光普照　　雨曼陀罗　　曼殊沙华
  栴檀香风　　悦可众心　　以是因缘
  地皆严净　　而此世界　　六种震动
  时四部众　　咸皆欢喜　　身意快然
  得未曾有　　眉间光明　　照于东方
  万八千土　　皆如金色　　从阿鼻狱
  上至有顶　　诸世界中　　六道众生
  生死所趣　　善恶业缘　　受报好丑
  于此悉见　　又睹诸佛　　圣主师子
  演说经典　　微妙第一　　其声清净
  出柔软音　　教诸菩萨　　无数亿万
  梵音深妙　　令人乐闻　　各于世界
  讲说正法　　种种因缘　　以无量喻
  照明佛法　　开悟众生　　若人遭苦
  厌老病死　　为说涅槃　　尽诸苦际
  若人有福　　曾供养佛　　志求胜法
  为说缘觉　　若有佛子　　修种种行
  求无上慧　　为说净道　　文殊师利
  我住于此　　见闻若斯　　及千亿事
  如是众多　　今当略说　　我见彼土
  恒沙菩萨　　种种因缘　　而求佛道
  或有行施　　金银珊瑚　　真珠摩尼
  车磲马脑　　金刚诸珍　　奴婢车乘
  宝饰辇舆　　欢喜布施　　回向佛道
  愿得是乘　　三界第一　　诸佛所叹
  或有菩萨　　驷马宝车　　栏楯华盖
  轩饰布施　　复见菩萨　　身肉手足
  及妻子施　　求无上道　　又见菩萨
  头目身体　　欣乐施与　　求佛智慧
  文殊师利　　我见诸王　　往诣佛所
  问无上道　　便舍乐土　　宫殿臣妾
  剃除须发　　而被法服　　或见菩萨
  而作比丘　　独处闲静　　乐诵经典
  又见菩萨　　勇猛精进　　入于深山
  思惟佛道　　又见离欲　　常处空闲
  深修禅定　　得五神通　　又见菩萨
  安禅合掌　　以千万偈　　赞诸法王
  复见菩萨　　智深志固　　能问诸佛
  闻悉受持　　又见佛子　　定慧具足
  以无量喻　　为众讲法　　欣乐说法
  化诸菩萨　　破魔兵众　　而击法鼓
  又见菩萨　　寂然宴默　　天龙恭敬
  不以为喜　　又见菩萨　　处林放光
  济地狱苦　　令入佛道　　又见佛子
  未尝睡眠　　经行林中　　勤求佛道
  又见具戒　　威仪无缺　　净如宝珠
  以求佛道　　又见佛子　　住忍辱力
  增上慢人　　恶骂捶打　　皆悉能忍
  以求佛道　　又见菩萨　　离诸戏笑
  及痴眷属　　亲近智者　　一心除乱
  摄念山林　　亿千万岁　　以求佛道
  或见菩萨　　肴膳饮食　　百种汤药
  施佛及僧　　名衣上服　　价直千万
  或无价衣　　施佛及僧　　千万亿种
  栴檀宝舍　　众妙卧具　　施佛及僧
  清净园林　　华果茂盛　　流泉浴池
  施佛及僧　　如是等施　　种果微妙
  欢喜无厌　　求无上道　　或有菩萨
  说寂灭法　　种种教诏　　无数众生
  或见菩萨　　观诸法性　　无有二相
  犹如虚空　　又见佛子　　心无所著
  以此妙慧　　求无上道　　文殊师利
  又有菩萨　　佛灭度后　　供养舍利
  又见佛子　　造诸塔庙　　无数恒沙
  严饰国界　　宝塔高妙　　五千由旬
  纵广正等　　二千由旬　　一一塔庙
  各千幢幡　　珠交露幔　　宝铃和鸣
  诸天龙神　　人及非人　　香华伎乐
  常以供养　　文殊师利　　诸佛子等
  为供舍利　　严饰塔庙　　国界自然
  殊特妙好　　如天树王　　其华开敷
  佛放一光　　我及众会　　见此国界
  种种殊妙　　诸佛神力　　智慧希有
  放一净光　　照无量国　　我等见此
  得未曾有　　佛子文殊　　愿决众疑
  四众欣仰　　瞻仁及我　　世尊何故
  放斯光明　　佛子时答　　决疑令喜
  何所饶益　　演斯光明　　佛坐道场
  所得妙法　　为欲说此　　为当授记
  示诸佛土　　众宝严净　　及见诸佛
  此非小缘　　文殊当知　　四众龙神
  瞻察仁者　　为说何等

尔时文殊师利语弥勒菩萨摩诃萨及诸大士。善男子等。如我惟忖。今佛世尊。欲说大法。雨大法雨。吹大法螺。击大法鼓。演大法义。诸善男子。我于过去诸佛曾见此瑞。放斯光已即说大法。是故当知。今佛现光亦复如是。欲令众生咸得闻知一切世间难信之法。故现斯瑞。诸善男子。如过去无量无边不可思议阿僧祇劫。尔时有佛。号日月灯明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。演说正法。初善中善后善。其义深远。其语巧妙。纯一无杂。具足清白梵行之相。为求声闻者。说应四谛法。度生老病死究竟涅槃。为求辟支佛者。说应十二因缘法。为诸菩萨说应六波罗蜜。令得阿耨多罗三藐三菩提成一切种智。次复有佛。亦名日月灯明。次复有佛。亦名日月灯明。如是二万佛。皆同一字。号日月灯明。又同一姓。姓颇罗堕。弥勒当知。初佛后佛皆同一字。名日月灯明。十号具足。所可说法初中后善。其最后佛未出家时。有八王子。一名有意。二名善意。三名无量意。四名宝意。五名增意。六名除疑意。七名向意。八名法意。是八王子。威德自在。各领四天下。是诸王子。闻父出家得阿耨多罗三藐三菩提。悉舍王位亦随出家。发大乘意常修梵行。皆为法师。已于千万佛所殖诸善本。是时日月灯明佛。说大乘经。名无量义教菩萨法佛所护念。说是经已。即于大众中结加趺坐。入于无量义处三昧。身心不动。是时天雨曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上及诸大众。普佛世界六种震动。尔时会中比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。及诸小王转轮圣王等。是诸大众得未曾有。欢喜合掌一心观佛

尔时如来放眉间白毫相光。照东方万八千佛土。靡不周遍。如今所见是诸佛土。弥勒当知。尔时会中有二十亿菩萨。乐欲听法。是诸菩萨见此光明普照佛土。得未曾有。欲知此光所为因缘。时有菩萨。名曰妙光。有八百弟子。是时日月灯明佛从三昧起。因妙光菩萨说大乘经。名妙法莲华教菩萨法佛所护念。六十小劫不起于座。时会听者亦坐一处。六十小劫身心不动。听佛所说谓如食顷。是时众中。无有一人若身若心而生懈惓。日月灯明佛。于六十小劫说是经已。即于梵魔沙门婆罗门及天人阿修罗众中。而宣此言。如来于今日中夜当入无余涅槃。时有菩萨。名曰德藏。日月灯明佛。即授其记。告诸比丘。是德藏菩萨。次当作佛。号曰净身多陀阿伽度阿罗诃三藐三佛陀。佛授记已。便于中夜入无余涅槃。佛灭度后。妙光菩萨。持妙法莲华经。满八十小劫为人演说。日月灯明佛八子。皆师妙光。妙光教化。令其坚固阿耨多罗三藐三菩提。是诸王子。供养无量百千万亿佛已。皆成佛道。其最后成佛者。名曰燃灯。八百弟子中有一人。号曰求名。贪着利养。虽复读诵众经而不通利。多所忘失。故号求名。是人亦以种诸善根因缘故。得值无量百千万亿诸佛。供养恭敬尊重赞叹。弥勒当知。尔时妙光菩萨。岂异人乎。我身是也。求名菩萨汝身是也。今见此瑞与本无异。是故惟忖。今日如来当说大乘经。名妙法莲华教菩萨法佛所护念。尔时文殊师利。于大众中。欲重宣此义。而说偈言

  我念过去世　　无量无数劫
  有佛人中尊　　号日月灯明
  世尊演说法　　度无量众生
  无数亿菩萨　　令入佛智慧
  佛未出家时　　所生八王子
  见大圣出家　　亦随修梵行
  时佛说大乘　　经名无量义
  于诸大众中　　而为广分别
  佛说此经已　　即于法座上
  加趺坐三昧　　名无量义处
  天雨曼陀华　　天鼓自然鸣
  诸天龙鬼神　　供养人中尊
  一切诸佛土　　即时大震动
  佛放眉间光　　现诸希有事
  此光照东方　　万八千佛土
  示一切众生　　生死业报处
  有见诸佛土　　以众宝庄严
  琉璃颇梨色　　斯由佛光照
  及见诸天人　　龙神夜叉众
  乾闼紧那罗　　各供养其佛
  又见诸如来　　自然成佛道
  身色如金山　　端严甚微妙
  如净琉璃中　　内现真金像
  世尊在大众　　敷演深法义
  一一诸佛土　　声闻众无数
  因佛光所照　　悉见彼大众
  或有诸比丘　　在于山林中
  精进持净戒　　犹如护明珠
  又见诸菩萨　　行施忍辱等
  其数如恒沙　　斯由佛光照
  又见诸菩萨　　深入诸禅定
  身心寂不动　　以求无上道
  又见诸菩萨　　知法寂灭相
  各于其国土　　说法求佛道
  尔时四部众　　见日月灯佛
  现大神通力　　其心皆欢喜
  各各自相问　　是事何因缘
  天人所奉尊　　适从三昧起
  赞妙光菩萨　　汝为世间眼
  一切所归信　　能奉持法藏
  如我所说法　　唯汝能证知
  世尊既赞叹　　令妙光欢喜
  说是法华经　　满六十小劫
  不起于此座　　所说上妙法
  是妙光法师　　悉皆能受持
  佛说是法华　　令众欢喜已
  寻即于是日　　告于天人众
  诸法实相义　　已为汝等说
  我今于中夜　　当入于涅槃
  汝一心精进　　当离于放逸
  诸佛甚难值　　亿劫时一遇
  世尊诸子等　　闻佛入涅槃
  各各怀悲恼　　佛灭一何速
  圣主法之王　　安慰无量众
  我若灭度时　　汝等勿忧怖
  是德藏菩萨　　于无漏实相
  心已得通达　　其次当作佛
  号曰为净身　　亦度无量众
  佛此夜灭度　　如薪尽火灭
  分布诸舍利　　而起无量塔
  比丘比丘尼　　其数如恒沙
  倍复加精进　　以求无上道
  是妙光法师　　奉持佛法藏
  八十小劫中　　广宣法华经
  是诸八王子　　妙光所开化
  坚固无上道　　当见无数佛
  供养诸佛已　　随顺行大道
  相继得成佛　　转次而授记
  最后天中天　　号曰燃灯佛
  诸仙之导师　　度脱无量众
  是妙光法师　　时有一弟子
  心常怀懈怠　　贪着于名利
  求名利无厌　　多游族姓家
  弃舍所习诵　　废忘不通利
  以是因缘故　　号之为求名
  亦行众善业　　得见无数佛
  供养于诸佛　　随顺行大道
  具六波罗蜜　　今见释师子
  其后当作佛　　号名曰弥勒
  广度诸众生　　其数无有量
  彼佛灭度后　　懈怠者汝是
  妙光法师者　　今则我身是
  我见灯明佛　　本光瑞如此
  以是知今佛　　欲说法华经
  今相如本瑞　　是诸佛方便
  今佛放光明　　助发实相义
  诸人今当知　　合掌一心待
  佛当雨法雨　　充足求道者
  诸求三乘人　　若有疑悔者
  佛当为除断　　令尽无有余

    妙法莲华经方便品第二

尔时世尊从三昧安详而起。告舍利弗。诸佛智慧甚深无量。其智慧门难解难入。一切声闻辟支佛所不能知。所以者何。佛曾亲近百千万亿无数诸佛。尽行诸佛无量道法。勇猛精进名称普闻。成就甚深未曾有法。随宜所说意趣难解。舍利弗。吾从成佛已来。种种因缘。种种譬喻。广演言教。无数方便引导众生。令离诸着。所以者何。如来方便知见波罗蜜。皆已具足。舍利弗。如来知见广大深远。无量无碍力无所畏。禅定解脱三昧。深入无际。成就一切未曾有法。舍利弗。如来能种种分别巧说诸法。言辞柔软悦可众心。舍利弗。取要言之。无量无边未曾有法。佛悉成就。止舍利弗。不须复说。所以者何。佛所成就第一希有难解之法。唯佛与佛乃能究尽诸法实相。所谓诸法如是相。如是性。如是体。如是力。如是作。如是因。如是缘。如是果。如是报。如是本末究竟等。尔时世尊。欲重宣此义。而说偈言

  世雄不可量　　诸天及世人
  一切众生类　　无能知佛者
  佛力无所畏　　解脱诸三昧
  及佛诸余法　　无能测量者
  本从无数佛　　具足行诸道
  甚深微妙法　　难见难可了
  于无量亿劫　　行此诸道已
  道场得成果　　我已悉知见
  如是大果报　　种种性相义
  我及十方佛　　乃能知是事
  是法不可示　　言辞相寂灭
  诸余众生类　　无有能得解
  除诸菩萨众　　信力坚固者
  诸佛弟子众　　曾供养诸佛
  一切漏已尽　　住是最后身
  如是诸人等　　其力所不堪
  假使满世间　　皆如舍利弗
  尽思共度量　　不能测佛智
  正使满十方　　皆如舍利弗
  及余诸弟子　　亦满十方刹
  尽思共度量　　亦复不能知
  辟支佛利智　　无漏最后身
  亦满十方界　　其数如竹林
  斯等共一心　　于亿无量劫
  欲思佛实智　　莫能知少分
  新发意菩萨　　供养无数佛
  了达诸义趣　　又能善说法
  如稻麻竹苇　　充满十方刹
  一心以妙智　　于恒河沙劫
  咸皆共思量　　不能知佛智
  不退诸菩萨　　其数如恒沙
  一心共思求　　亦复不能知
  又告舍利弗　　无漏不思议
  甚深微妙法　　我今已具得
  唯我知是相　　十方佛亦然
  舍利弗当知　　诸佛语无异
  于佛所说法　　当生大信力
  世尊法久后　　要当说真实
  告诸声闻众　　及求缘觉乘
  我令脱苦缚　　逮得涅槃者
  佛以方便力　　示以三乘教
  众生处处着　　引之令得出

尔时大众中。有诸声闻漏尽阿罗汉阿若憍陈如等千二百人。及发声闻辟支佛心比丘比丘尼优婆塞优婆夷。各作是念。今者世尊。何故殷勤称叹方便而作是言。佛所得法甚深难解。有所言说意趣难知。一切声闻辟支佛所不能及。佛说一解脱义。我等亦得此法到于涅槃。而今不知是义所趣

尔时舍利弗知四众心疑。自亦未了。而白佛言。世尊。何因何缘。殷勤称叹诸佛第一方便。甚深微妙难解之法。我自昔来未曾从佛闻如是说。今者四众咸皆有疑。唯愿世尊。敷演斯事。世尊何故殷勤称叹甚深微妙难解之法。尔时舍利弗欲重宣此义。而说偈言

  慧日大圣尊　　久乃说是法
  自说得如是　　力无畏三昧
  禅定解脱等　　不可思议法
  道场所得法　　无能发问者
  我意难可测　　亦无能问者
  无问而自说　　称叹所行道
  智慧甚微妙　　诸佛之所得
  无漏诸罗汉　　及求涅槃者
  今皆堕疑网　　佛何故说是
  其求缘觉者　　比丘比丘尼
  诸天龙鬼神　　及乾闼婆等
  相视怀犹豫　　瞻仰两足尊
  是事为云何　　愿佛为解说
  于诸声闻众　　佛说我第一
  我今自于智　　疑惑不能了
  为是究竟法　　为是所行道
  佛口所生子　　合掌瞻仰待
  愿出微妙音　　时为如实说
  诸天龙神等　　其数如恒沙
  求佛诸菩萨　　大数有八万
  又诸万亿国　　转轮圣王至
  合掌以敬心　　欲闻具足道

尔时佛告舍利弗。止止不须复说。若说是事。一切世间诸天及人皆当惊疑。舍利弗重白佛言。世尊。唯愿说之。唯愿说之。所以者何。是会无数百千万亿阿僧祇众生。曾见诸佛。诸根猛利智慧明了。闻佛所说则能敬信。尔时舍利弗欲重宣此义。而说偈言

  法王无上尊　　唯说愿勿虑
  是会无量众　　有能敬信者

佛复止舍利弗。若说是事。一切世间天人阿修罗。皆当惊疑。增上慢比丘将坠于大坑。尔时世尊。重说偈言

  止止不须说　　我法妙难思
  诸增上慢者　　闻必不敬信

尔时舍利弗重白佛言。世尊。唯愿说之。唯愿说之。今此会中。如我等比百千万亿。世世已曾从佛受化。如此人等必能敬信。长夜安隐多所饶益。尔时舍利弗欲重宣此义。而说偈言

  无上两足尊　　愿说第一法
  我为佛长子　　唯垂分别说
  是会无量众　　能敬信此法
  佛已曾世世　　教化如是等
  皆一心合掌　　欲听受佛语
  我等千二百　　及余求佛者
  愿为此众故　　唯垂分别说
  是等闻此法　　则生大欢喜

尔时世尊告舍利弗。汝已殷勤三请。岂得不说。汝今谛听。善思念之。吾当为汝分别解说。说此语时。会中有比丘比丘尼优婆塞优婆夷五千人等。即从座起礼佛而退。所以者何。此辈罪根深重及增上慢。未得谓得。未证谓证。有如此失。是以不住。世尊默然而不制止

尔时佛告舍利弗。我今此众无复枝叶。纯有贞实。舍利弗。如是增上慢人。退亦佳矣。汝今善听。当为汝说。舍利弗言。唯然世尊。愿乐欲闻。佛告舍利弗。如是妙法。诸佛如来时乃说之。如优昙钵华时一现耳。舍利弗。汝等当信佛之所说言不虚妄。舍利弗。诸佛随宜说法意趣难解。所以者何。我以无数方便种种因缘譬喻言辞演说诸法。是法非思量分别之所能解。唯有诸佛乃能知之。所以者何。诸佛世尊。唯以一大事因缘故出现于世。舍利弗。云何名诸佛世尊唯以一大事因缘故出现于世。诸佛世尊。欲令众生开佛知见使得清净故出现于世。欲示众生佛之知见故出现于世。欲令众生悟佛知见故出现于世。欲令众生入佛知见道故出现于世。舍利弗。是为诸佛以一大事因缘故出现于世

佛告舍利弗。诸佛如来。但教化菩萨。诸有所作常为一事。唯以佛之知见示悟众生。舍利弗。如来但以一佛乘故为众生说法。无有余乘若二若三。舍利弗。一切十方诸佛法亦如是。舍利弗。过去诸佛以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从诸佛闻法。究竟皆得一切种智。舍利弗。未来诸佛当出于世。亦以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从佛闻法。究竟皆得一切种智。舍利弗。现在十方无量百千万亿佛土中诸佛世尊。多所饶益安乐众生。是诸佛亦以无量无数方便种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从佛闻法。究竟皆得一切种智。舍利弗。是诸佛但教化菩萨。欲以佛之知见示众生故。欲以佛之知见悟众生故。欲令众生入佛之知见故。舍利弗。我今亦复如是。知诸众生有种种欲深心所著。随其本性。以种种因缘譬喻言辞方便力而为说法。舍利弗。如此皆为得一佛乘一切种智故。舍利弗。十方世界中尚无二乘。何况有三。舍利弗。诸佛出于五浊恶世。所谓劫浊烦恼浊众生浊见浊命浊。如是舍利弗。劫浊乱时众生垢重。悭贪嫉妒成就诸不善根故。诸佛以方便力。于一佛乘分别说三。舍利弗。若我弟子。自谓阿罗汉辟支佛者。不闻不知诸佛如来但教化菩萨事。此非佛弟子。非阿罗汉。非辟支佛。又舍利弗。是诸比丘比丘尼。自谓已得阿罗汉是最后身究竟涅槃。便不复志求阿耨多罗三藐三菩提。当知此辈皆是增上慢人。所以者何。若有比丘实得阿罗汉。若不信此法。无有是处。除佛灭度后现前无佛。所以者何。佛灭度后。如是等经。受持读诵解义者。是人难得。若遇余佛。于此法中便得决了。舍利弗。汝等当一心信解受持佛语。诸佛如来言无虚妄。无有余乘唯一佛乘。尔时世尊。欲重宣此义。而说偈言

  比丘比丘尼　　有怀增上慢
  优婆塞我慢　　优婆夷不信
  如是四众等　　其数有五千
  不自见其过　　于戒有缺漏
  护惜其瑕疵　　是小智已出
  众中之糟糠　　佛威德故去
  斯人鲜福德　　不堪受是法
  此众无枝叶　　唯有诸贞实
  舍利弗善听　　诸佛所得法
  无量方便力　　而为众生说
  众生心所念　　种种所行道
  若干诸欲性　　先世善恶业
  佛悉知是已　　以诸缘譬喻
  言辞方便力　　令一切欢喜
  或说修多罗　　伽陀及本事
  本生未曾有　　亦说于因缘
  譬喻并祇夜　　优波提舍经
  钝根乐小法　　贪着于生死
  于诸无量佛　　不行深妙道
  众苦所恼乱　　为是说涅槃
  我设是方便　　令得入佛慧
  未曾说汝等　　当得成佛道
  所以未曾说　　说时未至故
  今正是其时　　决定说大乘
  我此九部法　　随顺众生说
  入大乘为本　　以故说是经
  有佛子心净　　柔软亦利根
  无量诸佛所　　而行深妙道
  为此诸佛子　　说是大乘经
  我记如是人　　来世成佛道
  以深心念佛　　修持净戒故
  此等闻得佛　　大喜充遍身
  佛知彼心行　　故为说大乘
  声闻若菩萨　　闻我所说法
  乃至于一偈　　皆成佛无疑
  十方佛土中　　唯有一乘法
  无二亦无三　　除佛方便说
  但以假名字　　引导于众生
  说佛智慧故　　诸佛出于世
  唯此一事实　　余二则非真
  终不以小乘　　济度于众生
  佛自住大乘　　如其所得法
  定慧力庄严　　以此度众生
  自证无上道　　大乘平等法
  若以小乘化　　乃至于一人
  我则堕悭贪　　此事为不可
  若人信归佛　　如来不欺诳
  亦无贪嫉意　　断诸法中恶
  故佛于十方　　而独无所畏
  我以相严身　　光明照世间
  无量众所尊　　为说实相印
  舍利弗当知　　我本立誓愿
  欲令一切众　　如我等无异
  如我昔所愿　　今者已满足
  化一切众生　　皆令入佛道
  若我遇众生　　尽教以佛道
  无智者错乱　　迷惑不受教
  我知此众生　　未曾修善本
  坚着于五欲　　痴爱故生恼
  以诸欲因缘　　坠堕三恶道
  轮回六趣中　　备受诸苦毒
  受胎之微形　　世世常增长
  薄德少福人　　众苦所逼迫
  入邪见稠林　　若有若无等
  依止此诸见　　具足六十二
  深着虚妄法　　坚受不可舍
  我慢自矜高　　谄曲心不实
  于千万亿劫　　不闻佛名字
  亦不闻正法　　如是人难度
  是故舍利弗　　我为设方便
  说诸尽苦道　　示之以涅槃
  我虽说涅槃　　是亦非真灭
  诸法从本来　　常自寂灭相
  佛子行道已　　来世得作佛
  我有方便力　　开示三乘法
  一切诸世尊　　皆说一乘道
  今此诸大众　　皆应除疑惑
  诸佛语无异　　唯一无二乘
  过去无数劫　　无量灭度佛
  百千万亿种　　其数不可量
  如是诸世尊　　种种缘譬喻
  无数方便力　　演说诸法相
  是诸世尊等　　皆说一乘法
  化无量众生　　令入于佛道
  又诸大圣主　　知一切世间
  天人群生类　　深心之所欲
  更以异方便　　助显第一义
  若有众生类　　值诸过去佛
  若闻法布施　　或持戒忍辱
  精进禅智等　　种种修福慧
  如是诸人等　　皆已成佛道
  诸佛灭度已　　若人善软心
  如是诸众生　　皆已成佛道
  诸佛灭度已　　供养舍利者
  起万亿种塔　　金银及颇梨
  车磲与马脑　　玫瑰琉璃珠
  清净广严饰　　庄校于诸塔
  或有起石庙　　栴檀及沉水
  木櫁并余材　　塼瓦泥土等
  若于旷野中　　积土成佛庙
  乃至童子戏　　聚沙为佛塔
  如是诸人等　　皆已成佛道
  若人为佛故　　建立诸形像
  刻雕成众相　　皆已成佛道
  或以七宝成　　鋀石赤白铜
  白镴及铅锡　　铁木及与泥
  或以胶漆布　　严饰作佛像
  如是诸人等　　皆已成佛道
  彩画作佛像　　百福庄严相
  自作若使人　　皆已成佛道
  乃至童子戏　　若草木及笔
  或以指爪甲　　而画作佛像
  如是诸人等　　渐渐积功德
  具足大悲心　　皆已成佛道
  但化诸菩萨　　度脱无量众
  若人于塔庙　　宝像及画像
  以华香幡盖　　敬心而供养
  若使人作乐　　击鼓吹角贝
  箫笛琴箜篌　　琵琶铙铜钹
  如是众妙音　　尽持以供养
  或以欢喜心　　歌呗颂佛德
  乃至一小音　　皆已成佛道
  若人散乱心　　乃至以一华
  供养于画像　　渐见无数佛
  或有人礼拜　　或复但合掌
  乃至举一手　　或复小低头
  以此供养像　　渐见无量佛
  自成无上道　　广度无数众
  入无余涅槃　　如薪尽火灭
  若人散乱心　　入于塔庙中
  一称南无佛　　皆已成佛道
  于诸过去佛　　在世或灭度
  若有闻是法　　皆已成佛道
  未来诸世尊　　其数无有量
  是诸如来等　　亦方便说法
  一切诸如来　　以无量方便
  度脱诸众生　　入佛无漏智
  若有闻法者　　无一不成佛
  诸佛本誓愿　　我所行佛道
  普欲令众生　　亦同得此道
  未来世诸佛　　虽说百千亿
  无数诸法门　　其实为一乘
  诸佛两足尊　　知法常无性
  佛种从缘起　　是故说一乘
  是法住法位　　世间相常住
  于道场知已　　导师方便说
  天人所供养　　现在十方佛
  其数如恒沙　　出现于世间
  安隐众生故　　亦说如是法
  知第一寂灭　　以方便力故
  虽示种种道　　其实为佛乘
  知众生诸行　　深心之所念
  过去所习业　　欲性精进力
  及诸根利钝　　以种种因缘
  譬喻亦言辞　　随应方便说
  今我亦如是　　安隐众生故
  以种种法门　　宣示于佛道
  我以智慧力　　知众生性欲
  方便说诸法　　皆令得欢喜
  舍利弗当知　　我以佛眼观
  见六道众生　　贫穷无福慧
  入生死崄道　　相续苦不断
  深着于五欲　　如牦牛爱尾
  以贪爱自蔽　　盲瞑无所见
  不求大势佛　　及与断苦法
  深入诸邪见　　以苦欲舍苦
  为是众生故　　而起大悲心
  我始坐道场　　观树亦经行
  于三七日中　　思惟如是事
  我所得智慧　　微妙最第一
  众生诸根钝　　着乐痴所盲
  如斯之等类　　云何而可度
  尔时诸梵王　　及诸天帝释
  护世四天王　　及大自在天
  并余诸天众　　眷属百千万
  恭敬合掌礼　　请我转法轮
  我即自思惟　　若但赞佛乘
  众生没在苦　　不能信是法
  破法不信故　　坠于三恶道
  我宁不说法　　疾入于涅槃
  寻念过去佛　　所行方便力
  我今所得道　　亦应说三乘
  作是思惟时　　十方佛皆现
  梵音慰喻我　　善哉释迦文
  第一之导师　　得是无上法
  随诸一切佛　　而用方便力
  我等亦皆得　　最妙第一法
  为诸众生类　　分别说三乘
  少智乐小法　　不自信作佛
  是故以方便　　分别说诸果
  虽复说三乘　　但为教菩萨
  舍利弗当知　　我闻圣师子
  深净微妙音　　喜称南无佛
  复作如是念　　我出浊恶世
  如诸佛所说　　我亦随顺行
  思惟是事已　　即趣波罗柰
  诸法寂灭相　　不可以言宣
  以方便力故　　为五比丘说
  是名转法轮　　便有涅槃音
  及以阿罗汉　　法僧差别名
  从久远劫来　　赞示涅槃法
  生死苦永尽　　我常如是说
  舍利弗当知　　我见佛子等
  志求佛道者　　无量千万亿
  咸以恭敬心　　皆来至佛所
  曾从诸佛闻　　方便所说法
  我即作是念　　如来所以出
  为说佛慧故　　今正是其时
  舍利弗当知　　钝根小智人
  着相憍慢者　　不能信是法
  今我喜无畏　　于诸菩萨中
  正直舍方便　　但说无上道
  菩萨闻是法　　疑网皆已除
  千二百罗汉　　悉亦当作佛
  如三世诸佛　　说法之仪式
  我今亦如是　　说无分别法
  诸佛兴出世　　悬远值遇难
  正使出于世　　说是法复难
  无量无数劫　　闻是法亦难
  能听是法者　　斯人亦复难
  譬如优昙花　　一切皆爱乐
  天人所希有　　时时乃一出
  闻法欢喜赞　　乃至发一言
  则为已供养　　一切三世佛
  是人甚希有　　过于优昙花
  汝等勿有疑　　我为诸法王
  普告诸大众　　但以一乘道
  教化诸菩萨　　无声闻弟子
  汝等舍利弗　　声闻及菩萨
  当知是妙法　　诸佛之秘要
  以五浊恶世　　但乐着诸欲
  如是等众生　　终不求佛道
  当来世恶人　　闻佛说一乘
  迷惑不信受　　破法堕恶道
  有惭愧清净　　志求佛道者
  当为如是等　　广赞一乘道
  舍利弗当知　　诸佛法如是
  以万亿方便　　随宜而说法
  其不习学者　　不能晓了此
  汝等既已知　　诸佛世之师
  随宜方便事　　无复诸疑惑
  心生大欢喜　　自知当作佛

妙法莲华经卷第一妙法莲华经卷第二

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    譬喻品第三

尔时舍利弗踊跃欢喜。即起合掌瞻仰尊颜。而白佛言。今从世尊闻此法音。心怀勇跃得未曾有。所以者何。我昔从佛闻如是法。见诸菩萨授记作佛。而我等不豫斯事。甚自感伤。失于如来无量知见。世尊。我常独处山林树下。若坐若行。每作是念。我等同入法性。云何如来以小乘法而见济度。是我等咎非世尊也。所以者何。若我等待说所因成就阿耨多罗三藐三菩提者。必以大乘而得度脱。然我等不解方便随宜所说。初闻佛法遇便信受思惟取证。世尊。我从昔来终日竟夜每自克责。而今从佛闻所未闻未曾有法。断诸疑悔。身意泰然快得安隐。今日乃知真是佛子。从佛口生从法化生。得佛法分。尔时舍利弗。欲重宣此义。而说偈言

  我闻是法音　　得所未曾有
  心怀大欢喜　　疑网皆已除
  昔来蒙佛教　　不失于大乘
  佛音甚希有　　能除众生恼
  我已得漏尽　　闻亦除忧恼
  我处于山谷　　或在树林下
  若坐若经行　　常思惟是事
  呜呼深自责　　云何而自欺
  我等亦佛子　　同入无漏法
  不能于未来　　演说无上道
  金色三十二　　十力诸解脱
  同共一法中　　而不得此事
  八十种妙好　　十八不共法
  如是等功德　　而我皆已失
  我独经行时　　见佛在大众
  名闻满十方　　广饶益众生
  自惟失此利　　我为自欺诳
  我常于日夜　　每思惟是事
  欲以问世尊　　为失为不失
  我常见世尊　　称赞诸菩萨
  以是于日夜　　筹量如此事
  今闻佛音声　　随宜而说法
  无漏难思议　　令众至道场
  我本着邪见　　为诸梵志师
  世尊知我心　　拔邪说涅槃
  我悉除邪见　　于空法得证
  尔时心自谓　　得至于灭度
  而今乃自觉　　非是实灭度
  若得作佛时　　具三十二相
  天人夜叉众　　龙神等恭敬
  是时乃可谓　　永尽灭无余
  佛于大众中　　说我当作佛
  闻如是法音　　疑悔悉已除
  初闻佛所说　　心中大惊疑
  将非魔作佛　　恼乱我心耶
  佛以种种缘　　譬喻巧言说
  其心安如海　　我闻疑网断
  佛说过去世　　无量灭度佛
  安住方便中　　亦皆说是法
  现在未来佛　　其数无有量
  亦以诸方便　　演说如是法
  如今者世尊　　从生及出家
  得道转法轮　　亦以方便说
  世尊说实道　　波旬无此事
  以是我定知　　非是魔作佛
  我堕疑网故　　谓是魔所为
  闻佛柔软音　　深远甚微妙
  演畅清净法　　我心大欢喜
  疑悔永已尽　　安住实智中
  我定当作佛　　为天人所敬
  转无上法轮　　教化诸菩萨

尔时佛告舍利弗。吾今于天人沙门婆罗门等大众中说。我昔曾于二万亿佛所。为无上道故常教化汝。汝亦长夜随我受学。我以方便引导汝故生我法中。舍利弗。我昔教汝志愿佛道。汝今悉忘。而便自谓已得灭度。我今还欲令汝忆念本愿所行道故。为诸声闻说是大乘经。名妙法莲华教菩萨法佛所护念。舍利弗。汝于未来世过无量无边不可思议劫。供养若干千万亿佛。奉持正法。具足菩萨所行之道。当得作佛。号曰华光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名离垢。其土平正清净严饰。安隐丰乐天人炽盛。琉璃为地有八交道。黄金为绳以界其侧。其傍各有七宝行树。常有华果。华光如来亦以三乘教化众生。舍利弗。彼佛出时虽非恶世。以本愿故说三乘法。其劫名大宝庄严。何故名曰大宝庄严。其国中以菩萨为大宝故。彼诸菩萨无量无边不可思议。算数譬喻所不能及。非佛智力无能知者。若欲行时宝华承足。此诸菩萨非初发意。皆久殖德本。于无量百千万亿佛所净修梵行。恒为诸佛之所称叹。常修佛慧具大神通。善知一切诸法之门。质直无伪志念坚固。如是菩萨充满其国。舍利弗。华光佛寿十二小劫。除为王子未作佛时。其国人民寿八小劫。华光如来过十二小劫。授坚满菩萨阿耨多罗三藐三菩提记。告诸比丘。是坚满菩萨次当作佛。号曰华足安行多陀阿伽度阿罗诃三藐三佛陀。其佛国土亦复如是。舍利弗。是华光佛灭度之后。正法住世三十二小劫。像法住世亦三十二小劫。尔时世尊。欲重宣此义。而说偈言

  舍利弗来世　　成佛普智尊
  号名曰华光　　当度无量众
  供养无数佛　　具足菩萨行
  十力等功德　　证于无上道
  过无量劫已　　劫名大宝严
  世界名离垢　　清净无瑕秽
  以琉璃为地　　金绳界其道
  七宝杂色树　　常有华果实
  彼国诸菩萨　　志念常坚固
  神通波罗蜜　　皆已悉具足
  于无数佛所　　善学菩萨道
  如是等大士　　华光佛所化
  佛为王子时　　弃国舍世荣
  于最末后身　　出家成佛道
  华光佛住世　　寿十二小劫
  其国人民众　　寿命八小劫
  佛灭度之后　　正法住于世
  三十二小劫　　广度诸众生
  正法灭尽已　　像法三十二
  舍利广流布　　天人普供养
  华光佛所为　　其事皆如是
  其两足圣尊　　最胜无伦匹
  彼即是汝身　　宜应自欣庆

尔时四部众。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等大众。见舍利弗于佛前受阿耨多罗三藐三菩提记。心大欢喜踊跃无量。各各脱身所著上衣。以供养佛。释提桓因梵天王等。与无数天子。亦以天妙衣天曼陀罗华摩诃曼陀罗华等。供养于佛。所散天衣住虚空中。而自回转。诸天伎乐百千万种。于虚空中一时俱作。雨众天华。而作是言。佛昔于波罗奈初转法轮。今乃复转无上最大法轮。尔时诸天子。欲重宣此义。而说偈言

  昔于波罗奈　　转四谛法轮
  分别说诸法　　五众之生灭
  今复转最妙　　无上大法轮
  是法甚深奥　　少有能信者
  我等从昔来　　数闻世尊说
  未曾闻如是　　深妙之上法
  世尊说是法　　我等皆随喜
  大智舍利弗　　今得受尊记
  我等亦如是　　必当得作佛
  于一切世间　　最尊无有上
  佛道叵思议　　方便随宜说
  我所有福业　　今世若过世
  及见佛功德　　尽回向佛道

尔时舍利弗白佛言。世尊。我今无复疑悔。亲于佛前得受阿耨多罗三藐三菩提记。是诸千二百心自在者。昔住学地。佛常教化言。我法能离生老病死究竟涅槃。是学无学人。亦各自以离我见及有无见等。谓得涅槃。而今于世尊前闻所未闻皆堕疑惑。善哉世尊。愿为四众说其因缘令离疑悔。尔时佛告舍利弗。我先不言诸佛世尊。以种种因缘譬喻言辞方便说法。皆为阿耨多罗三藐三菩提耶。是诸所说皆为化菩萨故。然舍利弗。今当复以譬喻更明此义。诸有智者。以譬喻得解。舍利弗。若国邑聚落有大长者。其年衰迈财富无量。多有田宅及诸僮仆。其家广大。唯有一门。多诸人众。一百二百乃至五百人。止住其中。堂阁朽故墙壁隤落。柱根腐败梁栋倾危。周匝俱时欻然火起焚烧舍宅。长者诸子。若十二十或至三十。在此宅中。长者见是大火从四面起。即大惊怖。而作是念。我虽能于此所烧之门安隐得出。而诸子等。于火宅内乐着嬉戏。不觉不知不惊不怖。火来逼身苦痛切己。心不厌患无求出意。舍利弗。是长者作是思惟。我身手有力。当以衣裓。若以机案。从舍出之。复更思惟。是舍唯有一门。而复狭小。诸子幼稚未有所识。恋着戏处。或当堕落为火所烧。我当为说怖畏之事。此舍已烧宜时疾出。无令为火之所烧害。作是念已。如所思惟。具告诸子。汝等速出。父虽怜愍善言诱喻。而诸子等。乐着嬉戏不肯信受。不惊不畏了无出心。亦复不知何者是火何者为舍。云何为失。但东西走戏视父而已。尔时长者即作是念。此舍已为大火所烧。我及诸子。若不时出。必为所焚。我今当设方便。令诸子等得免斯害。父知诸子先心各有所好。种种珍玩奇异之物情必乐着。而告之言。汝等所可玩好希有难得。汝若不取后必忧悔。如此种种羊车鹿车牛车今在门外。可以游戏。汝等于此火宅宜速出来。随汝所欲皆当与汝。尔时诸子闻父所说。珍玩之物适其愿故。心各勇锐互相推排。竞共驰走争出火宅。是时长者。见诸子等安隐得出。皆于四衢道中露地而坐。无复障碍。其心泰然欢喜踊跃。时诸子等。各白父言。父先所许玩好之具。羊车鹿车牛车愿时赐与

舍利弗。尔时长者。各赐诸子等一大车。其车高广众宝庄校。周匝栏楯四面悬铃。又于其上张设幰盖。亦以珍奇杂宝而严饰之。宝绳绞络垂诸华缨。重敷綩綖安置丹枕。驾以白牛。肤色充洁形体姝好。有大筋力。行步平正。其疾如风。又多仆从而侍卫之。所以者何。是大长者。财富无量。种种诸藏悉皆充溢。而作是念。我财物无极。不应以下劣小车与诸子等。今此幼童皆是吾子。爱无偏党。我有如是七宝大车。其数无量。应当等心各各与之。不宜差别。所以者何。以我此物周给一国。犹尚不匮。何况诸子。是时诸子。各乘大车得未曾有。非本所望。舍利弗。于汝意云何。是长者等与诸子珍宝大车。宁有虚妄不。舍利弗言。不也世尊。是长者。但令诸子得免火难。全其躯命非为虚妄。何以故。若全身命。便为已得玩好之具。况复方便于彼火宅而拔济之。世尊。若是长者。乃至不与最小一车。犹不虚妄。何以故。是长者先作是意。我以方便令子得出。以是因缘无虚妄也。何况长者。自知财富无量。欲饶益诸子等与大车。佛告舍利弗。善哉善哉。如汝所言。舍利弗。如来亦复如是。则为一切世间之父。于诸怖畏衰恼忧患无明闇蔽。永尽无余。而悉成就无量知见力无所畏。有大神力及智慧力。具足方便智慧波罗蜜。大慈大悲常无懈惓。恒求善事利益一切。而生三界朽故火宅。为度众生生老病死忧悲苦恼愚痴闇蔽三毒之火。教化令得阿耨多罗三藐三菩提。见诸众生为生老病死忧悲苦恼之所烧煮。亦以五欲财利故受种种苦。又以贪着追求故现受众苦。后受地狱畜生饿鬼之苦。若生天上及在人间。贫穷困苦爱别离苦怨憎会苦。如是等种种诸苦。众生没在其中。欢喜游戏。不觉不知不惊不怖。亦不生厌不求解脱。于此三界火宅东西驰走。虽遭大苦不以为患。舍利弗。佛见此已便作是念。我为众生之父。应拔其苦难。与无量无边佛智慧乐。令其游戏

舍利弗。如来复作是念。若我但以神力及智慧力。舍于方便。为诸众生。赞如来知见力无所畏者。众生不能以是得度。所以者何。是诸众生。未免生老病死忧悲苦恼。而为三界火宅所烧。何由能解佛之智慧。舍利弗。如彼长者。虽复身手有力而不用之。但以殷勤方便。勉济诸子火宅之难。然后各与珍宝大车。如来亦复如是。虽有力无所畏。而不用之。但以智慧方便。于三界火宅拔济众生。为说三乘声闻辟支佛佛乘。而作是言。汝等莫得乐住三界火宅。勿贪粗弊色声香味触也。若贪着生爱则为所烧。汝速出三界。当得三乘声闻辟支佛佛乘。我今为汝保任此事。终不虚也。汝等但当勤修精进。如来以是方便诱进众生。复作是言。汝等当知。此三乘法皆是圣所称叹。自在无系无所依求。乘是三乘。以无漏根力觉道禅定解脱三昧等。而自娱乐。便得无量安隐快乐。舍利弗。若有众生。内有智性。从佛世尊闻法信受。殷勤精进欲速出三界。自求涅槃。是名声闻乘。如彼诸子为求羊车出于火宅。若有众生。从佛世尊闻法信受。殷勤精进求自然慧。乐独善寂深知诸法因缘。是名辟支佛乘。如彼诸子为求鹿车出于火宅。若有众生。从佛世尊闻法信受。勤修精进。求一切智佛智自然智无师智如来知见力无所畏。愍念安乐无量众生。利益天人度脱一切。是名大乘。菩萨求此乘故名为摩诃萨。如彼诸子为求牛车出于火宅。舍利弗。如彼长者见诸子等安隐得出火宅到无畏处。自惟财富无量等以大车而赐诸子。如来亦复如是。为一切众生之父。若见无量亿千众生以佛教门出三界苦怖畏险道得涅槃乐

如来尔时便作是念。我有无量无边智慧力无畏等诸佛法藏。是诸众生皆是我子。等与大乘。不令有人独得灭度。皆以如来灭度而灭度之。是诸众生脱三界者。悉与诸佛禅定解脱等娱乐之具。皆是一相一种圣所称叹。能生净妙第一之乐。舍利弗。如彼长者初以三车诱引诸子。然后但与大车宝物庄严安隐第一。然彼长者。无虚妄之咎。如来亦复如是。无有虚妄。初说三乘引导众生。然后但以大乘而度脱之。何以故。如来有无量智慧力无所畏诸法之藏。能与一切众生大乘之法。但不尽能受。舍利弗。以是因缘。当知诸佛方便力故。于一佛乘分别说三。佛欲重宣此义。而说偈言

  譬如长者　　有一大宅　　其宅久故
  而复顿弊　　堂舍高危　　柱根摧朽
  梁栋倾斜　　基陛隤毁　　墙壁圮坼
  泥涂褫落　　覆苫乱坠　　椽梠差脱
  周障屈曲　　杂秽充遍　　有五百人
  止住其中　　鸱枭雕鹫　　乌鹊鸠鸽
  蚖蛇蝮蝎　　蜈蚣蚰蜒　　守宫百足
  狖狸鼷鼠　　诸恶虫辈　　交横驰走
  屎尿臭处　　不净流溢　　蜣螂诸虫
  而集其上　　狐狼野干　　咀嚼践蹋
  [齒*齊]啮死尸　　骨肉狼藉　　由是群狗
  竞来搏撮　　饥羸慞惶　　处处求食
  斗诤[齒*查]掣　　啀喍[口*睪]吠　　其舍恐怖
  变状如是　　处处皆有　　魑魅魍魉
  夜叉恶鬼　　食啖人肉　　毒虫之属
  诸恶禽兽　　孚乳产生　　各自藏护
  夜叉竞来　　争取食之　　食之既饱
  恶心转炽　　斗诤之声　　甚可怖畏
  鸠槃荼鬼　　蹲踞土埵　　或时离地
  一尺二尺　　往返游行　　纵逸嬉戏
  捉狗两足　　扑令失声　　以脚加颈
  怖狗自乐　　复有诸鬼　　其身长大
  裸形黑瘦　　常住其中　　发大恶声
  叫呼求食　　复有诸鬼　　其咽如针
  复有诸鬼　　首如牛头　　或食人肉
  或复啖狗　　头发蓬乱　　残害凶险
  饥渴所逼　　叫唤驰走　　夜叉饿鬼
  诸恶鸟兽　　饥急四向　　窥看窗牖
  如是诸难　　恐畏无量　　是朽故宅
  属于一人　　其人近出　　未久之间
  于后舍宅　　忽然火起　　四面一时
  其炎俱炽　　栋梁椽柱　　爆声震裂
  摧折堕落　　墙壁崩倒　　诸鬼神等
  扬声大叫　　雕鹫诸鸟　　鸠槃荼等
  周章惶怖　　不能自出　　恶兽毒虫
  藏窜孔穴　　毗舍阇鬼　　亦住其中
  薄福德故　　为火所逼　　共相残害
  饮血啖肉　　野干之属　　并已前死
  诸大恶兽　　竞来食啖　　臭烟熢[火*孛]
  四面充塞　　蜈蚣蚰蜒　　毒蛇之类
  为火所烧　　争走出穴　　鸠槃荼鬼
  随取而食　　又诸饿鬼　　头上火燃
  饥渴热恼　　周章闷走　　其宅如是
  甚可怖畏　　毒害火灾　　众难非一
  是时宅主　　在门外立　　闻有人言
  汝诸子等　　先因游戏　　来入此宅
  稚小无知　　欢娱乐着　　长者闻已
  惊入火宅　　方宜救济　　令无烧害
  告喻诸子　　说众患难　　恶鬼毒虫
  灾火蔓延　　众苦次第　　相续不绝
  毒蛇蚖蝮　　及诸夜叉　　鸠槃茶鬼
  野干狐狗　　雕鹫鸱枭　　百足之属
  饥渴恼急　　甚可怖畏　　此苦难处
  况复大火　　诸子无知　　虽闻父诲
  犹故乐着　　嬉戏不已　　是时长者
  而作是念　　诸子如此　　益我愁恼
  今此舍宅　　无一可乐　　而诸子等
  耽湎嬉戏　　不受我教　　将为火害
  即便思惟　　设诸方便　　告诸子等
  我有种种　　珍玩之具　　妙宝好车
  羊车鹿车　　大牛之车　　今在门外
  汝等出来　　吾为汝等　　造作此车
  随意所乐　　可以游戏　　诸子闻说
  如此诸车　　即时奔竞　　驰走而出
  到于空地　　离诸苦难　　长者见子
  得出火宅　　住于四衢　　坐师子座
  而自庆言　　我今快乐　　此诸子等
  生育甚难　　愚小无知　　而入险宅
  多诸毒虫　　魑魅可畏　　大火猛炎
  四面俱起　　而此诸子　　贪乐嬉戏
  我已救之　　令得脱难　　是故诸人
  我今快乐　　尔时诸子　　知父安坐
  皆诣父所　　而白父言　　愿赐我等
  三种宝车　　如前所许　　诸子出来
  当以三车　　随汝所欲　　今正是时
  唯垂给与　　长者大富　　库藏众多
  金银琉璃　　车磲马脑　　以众宝物
  造诸大车　　庄校严饰　　周匝栏楯
  四面悬铃　　金绳交络　　真珠罗网
  张施其上　　金华诸璎　　处处垂下
  众彩杂饰　　周匝围绕　　柔软缯纩
  以为茵蓐　　上妙细[疊*毛]　　价直千亿
  鲜白净洁　　以覆其上　　有大白牛
  肥壮多力　　形体姝好　　以驾宝车
  多诸傧从　　而侍卫之　　以是妙车
  等赐诸子　　诸子是时　　欢喜踊跃
  乘是宝车　　游于四方　　嬉戏快乐
  自在无碍　　告舍利弗　　我亦如是
  众圣中尊　　世间之父　　一切众生
  皆是吾子　　深着世乐　　无有慧心
  三界无安　　犹如火宅　　众苦充满
  甚可怖畏　　常有生老　　病死忧患
  如是等火　　炽然不息　　如来已离
  三界火宅　　寂然闲居　　安处林野
  今此三界　　皆是我有　　其中众生
  悉是吾子　　而今此处　　多诸患难
  唯我一人　　能为救护　　虽复教诏
  而不信受　　于诸欲染　　贪着深故
  以是方便　　为说三乘　　令诸众生
  知三界苦　　开示演说　　出世间道
  是诸子等　　若心决定　　具足三明
  及六神通　　有得缘觉　　不退菩萨
  汝舍利弗　　我为众生　　以此譬喻
  说一佛乘　　汝等若能　　信受是语
  一切皆当　　成得佛道　　是乘微妙
  清净第一　　于诸世间　　为无有上
  佛所悦可　　一切众生　　所应称赞
  供养礼拜　　无量亿千　　诸力解脱
  禅定智慧　　及佛余法　　得如是乘
  令诸子等　　日夜劫数　　常得游戏
  与诸菩萨　　及声闻众　　乘此宝乘
  直至道场　　以是因缘　　十方谛求
  更无余乘　　除佛方便　　告舍利弗
  汝诸人等　　皆是吾子　　我则是父
  汝等累劫　　众苦所烧　　我皆济拔
  令出三界　　我虽先说　　汝等灭度
  但尽生死　　而实不灭　　今所应作
  唯佛智慧　　若有菩萨　　于是众中
  能一心听　　诸佛实法　　诸佛世尊
  虽以方便　　所化众生　　皆是菩萨
  若人小智　　深着爱欲　　为此等故
  说于苦谛　　众生心喜　　得未曾有
  佛说苦谛　　真实无异　　若有众生
  不知苦本　　深着苦因　　不能暂舍
  为是等故　　方便说道　　诸苦所因
  贪欲为本　　若灭贪欲　　无所依止
  灭尽诸苦　　名第三谛　　为灭谛故
  修行于道　　离诸苦缚　　名得解脱
  是人于何　　而得解脱　　但离虚妄
  名为解脱　　其实未得　　一切解脱
  佛说是人　　未实灭度　　斯人未得
  无上道故　　我意不欲　　令至灭度
  我为法王　　于法自在　　安隐众生
  故现于世　　汝舍利弗　　我此法印
  为欲利益　　世间故说　　在所游方
  勿妄宣传　　若有闻者　　随喜顶受
  当知是人　　阿鞞跋致　　若有信受
  此经法者　　是人已曾　　见过去佛
  恭敬供养　　亦闻是法　　若人有能
  信汝所说　　则为见我　　亦见于汝
  及比丘僧　　并诸菩萨　　斯法华经
  为深智说　　浅识闻之　　迷惑不解
  一切声闻　　及辟支佛　　于此经中
  力所不及　　汝舍利弗　　尚于此经
  以信得入　　况余声闻　　其余声闻
  信佛语故　　随顺此经　　非己智分
  又舍利弗　　憍慢懈怠　　计我见者
  莫说此经　　凡夫浅识　　深着五欲
  闻不能解　　亦勿为说　　若人不信
  毁谤此经　　则断一切　　世间佛种
  或复颦蹙　　而怀疑惑　　汝当听说
  此人罪报　　若佛在世　　若灭度后
  其有诽谤　　如斯经典　　见有读诵
  书持经者　　轻贱憎嫉　　而怀结恨
  此人罪报　　汝今复听　　其人命终
  入阿鼻狱　　具足一劫　　劫尽更生
  如是展转　　至无数劫　　从地狱出
  当堕畜生　　若狗野干　　其影[乞*頁]瘦
  黧黮疥癞　　人所触娆　　又复为人
  之所恶贱　　常困饥渴　　骨肉枯竭
  生受楚毒　　死被瓦石　　断佛种故
  受斯罪报　　若作馲驼　　或生中驴
  身常负重　　加诸杖捶　　但念水草
  余无所知　　谤斯经故　　获罪如是
  有作野干　　来入聚落　　身体疥癞
  又无一目　　为诸童子　　之所打掷
  受诸苦痛　　或时致死　　于此死已
  更受蟒身　　其形长大　　五百由旬
  聋騃无足　　宛转腹行　　为诸小虫
  之所唼食　　昼夜受苦　　无有休息
  谤斯经故　　获罪如是　　若得为人
  诸根闇钝　　矬陋挛躄　　盲聋背伛
  有所言说　　人不信受　　口气常臭
  鬼魅所著　　贫穷下贱　　为人所使
  多病痟瘦　　无所依怙　　虽亲附人
  人不在意　　若有所得　　寻复忘失
  若修医道　　顺方治病　　更增他疾
  或复致死　　若自有病　　无人救疗
  设服良药　　而复增剧　　若他反逆
  抄劫窃盗　　如是等罪　　横罗其殃
  如斯罪人　　永不见佛　　众圣之王
  说法教化　　如斯罪人　　常生难处
  狂聋心乱　　永不闻法　　于无数劫
  如恒河沙　　生辄聋哑　　诸根不具
  常处地狱　　如游园观　　在余恶道
  如己舍宅　　驼驴猪狗　　是其行处
  谤斯经故　　获罪如是　　若得为人
  聋盲喑哑　　贫穷诸衰　　以自庄严
  水肿干痟　　疥癞痈疽　　如是等病
  以为衣服　　身常臭处　　垢秽不净
  深着我见　　增益嗔恚　　淫欲炽盛
  不择禽兽　　谤斯经故　　获罪如是
  告舍利弗　　谤斯经者　　若说其罪
  穷劫不尽　　以是因缘　　我故语汝
  无智人中　　莫说此经　　若有利根
  智慧明了　　多闻强识　　求佛道者
  如是之人　　乃可为说　　若人曾见
  亿百千佛　　殖诸善本　　深心坚固
  如是之人　　乃可为说　　若人精进
  常修慈心　　不惜身命　　乃可为说
  若人恭敬　　无有异心　　离诸凡愚
  独处山泽　　如是之人　　乃可为说
  又舍利弗　　若见有人　　舍恶知识
  亲近善友　　如是之人　　乃可为说
  若见佛子　　持戒清洁　　如净明珠
  求大乘经　　如是之人　　乃可为说
  若人无嗔　　质直柔软　　常愍一切
  恭敬诸佛　　如是之人　　乃可为说
  复有佛子　　于大众中　　以清净心
  种种因缘　　譬喻言辞　　说法无碍
  如是之人　　乃可为说　　若有比丘
  为一切智　　四方求法　　合掌顶受
  但乐受持　　大乘经典　　乃至不受
  余经一偈　　如是之人　　乃可为说
  如人至心　　求佛舍利　　如是求经
  得已顶受　　其人不复　　志求余经
  亦未曾念　　外道典籍　　如是之人
  乃可为说　　告舍利弗　　我说是相
  求佛道者　　穷劫不尽　　如是等人
  则能信解　　汝当为说　　妙法华经

    妙法莲华经信解品第四

尔时慧命须菩提。摩诃迦旃延。摩诃迦叶。摩诃目犍连。从佛所闻未曾有法。世尊授舍利弗阿耨多罗三藐三菩提记。发希有心欢喜踊跃。即从座起整衣服。偏袒右肩右膝着地。一心合掌曲躬恭敬。瞻仰尊颜而白佛言。我等居僧之首。年并朽迈。自谓已得涅槃无所堪任。不复进求阿耨多罗三藐三菩提。世尊。往昔说法既久。我时在座身体疲懈。但念空无相无作。于菩萨法游戏神通净佛国土成就众生心不喜乐。所以者何。世尊。令我等出于三界得涅槃证。又今我等年已朽迈于佛教化菩萨阿耨多罗三藐三菩提。不生一念好乐之心。我等今于佛前闻授声闻阿耨多罗三藐三菩提记。心甚欢喜得未曾有。不谓于今忽然得闻希有之法。深自庆幸获大善利。无量珍宝不求自得

世尊。我等今者。乐说譬喻以明斯义。譬若有人年既幼稚。舍父逃逝久住他国。或十二十至五十岁。年既长大加复穷困。驰骋四方以求衣食。渐渐游行遇向本国。其父先来。求子不得。中止一城。其家大富财宝无量。金银琉璃珊瑚虎珀颇梨珠等。其诸仓库悉皆盈溢。多有僮仆臣佐吏民。象马车乘牛羊无数。出入息利乃遍他国。商估贾客亦甚众多。时贫穷子。游诸聚落经历国邑。遂到其父所止之城。父母念子。与子离别五十余年。而未曾向人说如此事。但自思惟心怀悔恨。自念老朽多有财物。金银珍宝仓库盈溢。无有子息。一旦终没财物散失。无所委付。是以殷勤每忆其子。复作是念。我若得子委付财物。坦然快乐无复忧虑。世尊。尔时穷子。佣赁展转遇到父舍住立门侧。遥见其父踞师子床宝机承足。诸婆罗门刹利居士皆恭敬围绕。以真珠璎珞价直千万庄严其身。吏民僮仆手执白拂侍立左右。覆以宝帐。垂诸华幡。香水洒地。散众名华。罗列宝物出内取与。有如是等种种严饰。威德特尊。穷子见父有大力势。即怀恐怖。悔来至此。窃作是念。此或是王。或是王等。非我佣力得物之处。不如往至贫里肆力有地。衣食易得。若久住此。或见逼迫强使我作。作是念已。疾走而去。时富长者。于师子座见子便识。心大欢喜。即作是念。我财物库藏。今有所付。我常思念此子。无由见之。而忽自来。甚适我愿。我虽年朽犹故贪惜。即遣傍人急追将还。尔时使者疾走往捉。穷子惊愕称怨大唤。我不相犯何为见捉。使者执之愈急强牵将还。于时穷子自念。无罪而被囚执此必定死。转更惶怖闷绝躄地。父遥见之。而语使言。不须此人。勿强将来。以冷水洒面令得醒悟。莫复与语。所以者何。父知其子志意下劣。自知豪贵为子所难。审知是子。而以方便不语他人云是我子。使者语之。我今放汝随意所趣。穷子欢喜得未曾有。从地而起往至贫里以求衣食。尔时长者。将欲诱引其子。而设方便。密遣二人形色憔悴无威德者。汝可诣彼徐语穷子。此有作处倍与汝直。穷子若许将来使作。若言欲何所作。便可语之。雇汝除粪。我等二人亦共汝作。时二使人即求穷子。既已得之具陈上事。尔时穷子先取其价寻与除粪。其父见子愍而怪之。又以他日于窗牖中遥见子身。羸瘦憔悴粪土尘坌污秽不净。即脱璎珞细软上服严饰之具。更着粗弊垢腻之衣。尘土坌身右手执持除粪之器。状有所畏语诸作人。汝等勤作勿得懈息。以方便故得近其子。后复告言。咄男子。汝常此作勿复余去。当加汝价。诸有所须盆器米面盐醋之属。莫自疑难。亦有老弊使人。须者相给。好自安意。我如汝父勿复忧虑。所以者何。我年老大而汝少壮。汝常作时无有欺怠嗔恨怨言。都不见汝有此诸恶如余作人。自今已后如所生子。即时长者更与作字名之为儿。尔时穷子。虽欣此遇。犹故自谓客作贱人。由是之故于二十年中常令除粪。过是已后。心相体信入出无难。然其所止犹在本处。世尊。尔时长者有疾。自知将死不久。语穷子言。我今多有金银珍宝仓库盈溢。其中多少所应取与。汝悉知之。我心如是当体此意。所以者何。今我与汝便为不异。宜加用心无令漏失。尔时穷子。即受教敕领知众物。金银珍宝及诸库藏。而无悕取一餐之意。然其所止故在本处。下劣之心亦未能舍。复经少时。父知子意渐已通泰成就大志自鄙先心。临欲终时而命其子。并会亲族。国王大臣刹利居士皆悉已集。即自宣言。诸君当知。此是我子。我之所生。于某城中舍吾逃走。伶俜辛苦五十余年。其本字某。我名某甲。昔在本城怀忧推觅。忽于此间遇会得之。此实我子。我实其父。今我所有一切财物。皆是子有。先所出内是子所知。世尊。是时穷子闻父此言。即大欢喜得未曾有。而作是念。我本无心有所希求。今此宝藏自然而至

世尊。大富长者则是如来。我等皆似佛子。如来常说我等为子。世尊。我等以三苦故。于生死中受诸热恼。迷惑无知乐着小法。今日世尊。令我等思惟蠲除诸法戏论之粪。我等于中勤加精进得至涅槃一日之价。既得此已心大欢喜自以为足。而便自谓。于佛法中勤精进故。所得弘多。然世尊。先知我等心着弊欲乐于小法。便见纵舍不为分别。汝等当有如来知见宝藏之分。世尊以方便力说如来智慧。我等从佛得涅槃一日之价。以为大得。于此大乘无有志求。我等又因如来智慧。为诸菩萨开示演说。而自于此无有志愿。所以者何。佛知我等心乐小法。以方便力随我等说。而我等不知真是佛子。今我等方知。世尊于佛智慧无所吝惜。所以者何。我等昔来真是佛子。而但乐小法。若我等有乐大之心。佛则为我说大乘法。于此经中唯说一乘。而昔于菩萨前毁呰声闻乐小法者。然佛实以大乘教化。是故我等说本无心有所悕求。今法王大宝自然而至。如佛子所应得者皆已得之。尔时摩诃迦叶。欲重宣此义。而说偈言

  我等今日　　闻佛音教　　欢喜踊跃
  得未曾有　　佛说声闻　　当得作佛
  无上宝聚　　不求自得　　譬如童子
  幼稚无识　　舍父逃逝　　远到他土
  周流诸国　　五十余年　　其父忧念
  四方推求　　求之既疲　　顿止一城
  造立舍宅　　五欲自娱　　其家巨富
  多诸金银　　车磲马脑　　真珠琉璃
  象马牛羊　　辇舆车乘　　田业僮仆
  人民众多　　出入息利　　乃遍他国
  商估贾人　　无处不有　　千万亿众
  围绕恭敬　　常为王者　　之所爱念
  群臣豪族　　皆共宗重　　以诸缘故
  往来者众　　豪富如是　　有大力势
  而年朽迈　　益忧念子　　夙夜惟念
  死时将至　　痴子舍我　　五十余年
  库藏诸物　　当如之何　　尔时穷子
  求索衣食　　从邑至邑　　从国至国
  或有所得　　或无所得　　饥饿羸瘦
  体生疮癣　　渐次经历　　到父住城
  佣赁展转　　遂至父舍　　尔时长者
  于其门内　　施大宝帐　　处师子座
  眷属围绕　　诸人侍卫　　或有计算
  金银宝物　　出内财产　　注记券疏
  穷子见父　　豪贵尊严　　谓是国王
  若是王等　　惊怖自怪　　何故至此
  覆自念言　　我若久住　　或见逼迫
  强驱使作　　思惟是已　　驰走而去
  借问贫里　　欲往佣作　　长者是时
  在师子座　　遥见其子　　默而识之
  即敕使者　　追捉将来　　穷子惊唤
  迷闷躄地　　是人执我　　必当见杀
  何用衣食　　使我至此　　长者知子
  愚痴狭劣　　不信我言　　不信是父
  即以方便　　更遣余人　　眇目矬陋
  无威德者　　汝可语之　　云当相雇
  除诸粪秽　　倍与汝价　　穷子闻之
  欢喜随来　　为除粪秽　　净诸房舍
  长者于牖　　常见其子　　念子愚劣
  乐为鄙事　　于是长者　　着弊垢衣
  执除粪器　　往到子所　　方便附近
  语令勤作

  既益汝价　　并涂足油　　饮食充足
  荐席厚暖　　如是苦言　　汝当勤作
  又以软语　　若如我子　　长者有智
  渐令入出　　经二十年　　执作家事
  示其金银　　真珠颇梨　　诸物出入
  皆使令知　　犹处门外　　止宿草庵
  自念贫事　　我无此物　　父知子心
  渐已广大　　欲与财物　　即聚亲族
  国王大臣　　刹利居士　　于此大众
  说是我子　　舍我他行　　经五十岁
  自见子来　　已二十年　　昔于某城
  而失是子　　周行求索　　遂来至此
  凡我所有　　舍宅人民　　悉以付之
  恣其所用　　子念昔贫　　志意下劣
  今于父所　　大获珍宝　　并及舍宅
  一切财物　　甚大欢喜　　得未曾有
  佛亦如是　　知我乐小　　未曾说言
  汝等作佛　　而说我等　　得诸无漏
  成就小乘　　声闻弟子　　佛敕我等
  说最上道　　修习此者　　当得成佛
  我承佛教　　为大菩萨　　以诸因缘
  种种譬喻　　若干言辞　　说无上道
  诸佛子等　　从我闻法　　日夜思惟
  精勤修习　　是时诸佛　　即授其记
  汝于来世　　当得作佛　　一切诸佛
  秘藏之法　　但为菩萨　　演其实事
  而不为我　　说斯真要　　如彼穷子
  得近其父　　虽知诸物　　心不希取
  我等虽说　　佛法宝藏　　自无志愿
  亦复如是　　我等内灭　　自谓为足
  唯了此事　　更无余事　　我等若闻
  净佛国土　　教化众生　　都无欣乐
  所以者何　　一切诸法　　皆悉空寂
  无生无灭　　无大无小　　无漏无为
  如是思惟　　不生喜乐　　我等长夜
  于佛智慧　　无贪无著　　无复志愿
  而自于法　　谓是究竟　　我等长夜
  修习空法　　得脱三界　　苦恼之患
  住最后身　　有余涅槃　　佛所教化
  得道不虚　　则为已得　　报佛之恩
  我等虽为　　诸佛子等　　说菩萨法
  以求佛道　　而于是法　　永无愿乐
  导师见舍　　观我心故　　初不劝进
  说有实利　　如富长者　　知子志劣
  以方便力　　柔伏其心　　然后乃付
  一切财物

  佛亦如是　　现希有事　　知乐小者
  以方便力　　调伏其心　　乃教大智
  我等今日　　得未曾有　　非先所望
  而今自得　　如彼穷子　　得无量宝
  世尊我今　　得道得果　　于无漏法
  得清净眼　　我等长夜　　持佛净戒
  始于今日　　得其果报　　法王法中
  久修梵行　　今得无漏　　无上大果
  我等今者　　真是声闻　　以佛道声
  令一切闻　　我等今者　　真阿罗汉
  于诸世间　　天人魔梵　　普于其中
  应受供养　　世尊大恩　　以希有事
  怜愍教化　　利益我等　　无量亿劫
  谁能报者　　手足供给　　头顶礼敬
  一切供养　　皆不能报　　若以顶戴
  两肩荷负　　于恒沙劫　　尽心恭敬
  又以美膳　　无量宝衣　　及诸卧具
  种种汤药　　牛头栴檀　　及诸珍宝
  以起塔庙　　宝衣布地　　如斯等事
  以用供养　　于恒沙劫　　亦不能报
  诸佛希有　　无量无边　　不可思议
  大神通力　　无漏无为　　诸法之王
  能为下劣　　忍于斯事　　取相凡夫
  随宜为说　　诸佛于法　　得最自在
  知诸众生　　种种欲乐　　及其志力
  随所堪任　　以无量喻　　而为说法
  随诸众生　　宿世善根　　又知成熟
  未成熟者　　种种筹量　　分别知已
  于一乘道　　随宜说三

妙法莲华经卷第二妙法莲华经卷第三

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    药草喻品第五

尔时世尊告摩诃迦叶及诸大弟子。善哉善哉。迦叶。善说如来真实功德。诚如所言。如来复有无量无边阿僧祇功德。汝等若于无量亿劫说不能尽。迦叶当知。如来是诸法之王若有所说皆不虚也。于一切法以智方便而演说之。其所说法。皆悉到于一切智地。如来观知一切诸法之所归趣。亦知一切众生深心所行。通达无碍。又于诸法究尽明了。示诸众生一切智慧。迦叶。譬如三千大千世界。山川溪谷土地所生卉木丛林。及诸药草种类若干名色各异。密云弥布遍覆三千大千世界。一时等澍其泽普洽卉木丛林及诸药草。小根小茎小枝小叶。中根中茎中枝中叶。大根大茎大枝大叶。诸树大小。随上中下各有所受。一云所雨。称其种性而得生长。华果敷实。虽一地所生一雨所润。而诸草木各有差别。迦叶当知。如来亦复如是。出现于世如大云起。以大音声普遍世界天人阿修罗。如彼大云遍覆三千大千国土。于大众中而唱是言。我是如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。未度者令度。未解者令解。未安者令安。未涅槃者令得涅槃。今世后世如实知之。我是一切知者。一切见者。知道者。开道者。说道者。汝等天人阿修罗众。皆应到此。为听法故。尔时无数千万亿种众生。来至佛所而听法。如来于时观是众生诸根利钝精进懈怠。随其所堪而为说法。种种无量。皆令欢喜快得善利。是诸众生闻是法已。现世安隐后生善处。以道受乐亦得闻法。既闻法已离诸障碍。于诸法中。任力所能渐得入道。如彼大云雨于一切卉木丛林及诸药草。如其种性。具足蒙润各得生长。如来说法一相一味。所谓解脱相离相灭相。究竟至于一切种智。其有众生闻如来法。若持读诵如说修行。所得功德不自觉知。所以者何。唯有如来。知此众生种相体性。念何事。思何事。修何事。云何念。云何思。云何修。以何法念。以何法思。以何法修。以何法得何法。众生住于种种之地。唯有如来。如实见之明了无碍。如彼卉木丛林诸药草等。而不自知上中下性。如来知是一相一味之法。所谓解脱相离相灭相。究竟涅槃常寂灭相。终归于空。佛知是已。观众生心欲而将护之。是故不即为说一切种智。汝等迦叶。甚为希有。能知如来随宜说法。能信能受。所以者何。诸佛世尊随宜说法难解难知。尔时世尊。欲重宣此义。而说偈言

  破有法王　　出现世间　　随众生欲
  种种说法　　如来尊重　　智慧深远
  久默斯要　　不务速说　　有智若闻
  则能信解　　无智疑悔　　则为永失
  是故迦叶　　随力为说　　以种种缘
  令得正见　　迦叶当知　　譬如大云
  起于世间　　遍覆一切　　慧云含润
  电光晃曜　　雷声远震　　令众悦豫
  日光掩蔽　　地上清凉　　叆叇垂布
  如可承揽　　其雨普等　　四方俱下
  流澍无量　　率土充洽　　山川险谷
  幽邃所生　　卉木药草　　大小诸树
  百谷苗稼　　甘蔗蒲萄　　雨之所润
  无不丰足　　干地普洽　　药木并茂
  其云所出　　一味之水　　草木丛林
  随分受润　　一切诸树　　上中下等
  称其大小　　各得生长　　根茎枝叶
  华果光色　　一雨所及　　皆得鲜泽
  如其体相　　性分大小　　所润是一
  而各滋茂　　佛亦如是　　出现于世
  譬如大云　　普覆一切　　既出于世
  为诸众生　　分别演说　　诸法之实
  大圣世尊　　于诸天人　　一切众中
  而宣是言　　我为如来　　两足之尊
  出于世间　　犹如大云　　充润一切
  枯槁众生　　皆令离苦　　得安隐乐
  世间之乐　　及涅槃乐　　诸天人众
  一心善听　　皆应到此　　觐无上尊
  我为世尊　　无能及者　　安隐众生
  故现于世　　为大众说　　甘露净法
  其法一味　　解脱涅槃　　以一妙音
  演畅斯义　　常为大乘　　而作因缘
  我观一切　　普皆平等　　无有彼此
  爱憎之心　　我无贪着　　亦无限碍
  恒为一切　　平等说法　　如为一人
  众多亦然　　常演说法　　曾无他事
  去来坐立　　终不疲厌　　充足世间
  如雨普润　　贵贱上下　　持戒毁戒
  威仪具足　　及不具足　　正见邪见
  利根钝根　　等雨法雨　　而无懈倦
  一切众生　　闻我法者　　随力所受
  住于诸地　　或处人天　　转轮圣王
  释梵诸王　　是小药草　　知无漏法
  能得涅槃　　起六神通　　及得三明
  独处山林　　常行禅定　　得缘觉证
  是中药草　　求世尊处　　我当作佛
  行精进定　　是上药草　　又诸佛子
  专心佛道　　常行慈悲　　自知作佛
  决定无疑　　是名小树　　安住神通
  转不退轮　　度无量亿　　百千众生
  如是菩萨　　名为大树　　佛平等说
  如一味雨　　随众生性　　所受不同
  如彼草木　　所禀各异　　佛以此喻
  方便开示　　种种言辞　　演说一法
  于佛智慧　　如海一渧　　我雨法雨
  充满世间　　一味之法　　随力修行
  如彼丛林　　药草诸树　　随其大小
  渐增茂好　　诸佛之法　　常以一味
  令诸世间　　普得具足　　渐次修行
  皆得道果　　声闻缘觉　　处于山林
  住最后身　　闻法得果　　是名药草
  各得增长　　若诸菩萨　　智慧坚固
  了达三界　　求最上乘　　是名小树
  而得增长　　复有住禅　　得神通力
  闻诸法空　　心大欢喜　　放无数光
  度诸众生　　是名大树　　而得增长
  如是迦叶　　佛所说法　　譬如大云
  以一味雨　　润于人华　　各得成实
  迦叶当知　　以诸因缘　　种种譬喻
  开示佛道　　是我方便　　诸佛亦然
  今为汝等　　说最实事　　诸声闻众
  皆非灭度　　汝等所行　　是菩萨道
  渐渐修学　　悉当成佛

    妙法莲华经授记品第六

尔时世尊说是偈已。告诸大众唱如是言。我此弟子摩诃迦叶。于未来世当得奉觐三百万亿诸佛世尊。供养恭敬尊重赞叹。广宣诸佛无量大法。于最后身得成为佛。名曰光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名光德。劫名大庄严。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫。国界严饰无诸秽恶瓦砾荆棘便利不净。其土平正。无有高下坑坎堆阜。琉璃为地宝树行列。黄金为绳以界道侧。散诸宝华周遍清净。其国菩萨无量千亿。诸声闻众亦复无数。无有魔事。虽有魔及魔民。皆护佛法。尔时世尊欲重宣此义。而说偈言

  告诸比丘　　我以佛眼　　见是迦叶
  于未来世　　过无数劫　　当得作佛
  而于来世　　供养奉觐　　三百万亿
  诸佛世尊　　为佛智慧　　净修梵行
  供养最上　　二足尊已　　修习一切
  无上之慧　　于最后身　　得成为佛
  其土清净　　琉璃为地　　多诸宝树
  行列道侧　　金绳界道　　见者欢喜
  常出好香　　散众名华　　种种奇妙
  以为庄严　　其地平正　　无有丘坑
  诸菩萨众　　不可称计　　其心调柔
  逮大神通　　奉持诸佛　　大乘经典
  诸声闻众　　无漏后身　　法王之子
  亦不可计　　乃以天眼　　不能数知
  其佛当寿　　十二小劫　　正法住世
  二十小劫　　像法亦住　　二十小劫
  光明世尊　　其事如是

尔时大目犍连。须菩提。摩诃迦栴延等。皆悉悚栗。一心合掌瞻仰尊颜。目不暂舍。即共同声。而说偈言

  大雄猛世尊　　诸释之法王
  哀愍我等故　　而赐佛音声
  若知我深心　　见为授记者
  如以甘露洒　　除热得清凉
  如从饥国来　　忽遇大王膳
  心犹怀疑惧　　未敢即便食
  若复得王教　　然后乃敢食
  我等亦如是　　每惟小乘过
  不知当云何　　得佛无上慧
  虽闻佛音声　　言我等作佛
  心尚怀忧惧　　如未敢便食
  若蒙佛授记　　尔乃快安乐
  大雄猛世尊　　常欲安世间
  愿赐我等记　　如饥须教食

尔时世尊。知诸大弟子心之所念。告诸比丘。是须菩提。于当来世。奉觐三百万亿那由他佛。供养恭敬尊重赞叹。常修梵行具菩萨道。于最后身得成为佛。号曰名相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名有宝。国名宝生。其土平正。颇梨为地宝树庄严。无诸丘坑沙砾荆棘便利之秽。宝华覆地周遍清净。其土人民皆处宝台珍妙楼阁。声闻弟子无量无边。算数譬喻所不能知。诸菩萨众无数千万亿那由他。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫。其佛常处虚空为众说法。度脱无量菩萨及声闻众。尔时世尊欲重宣此义。而说偈言

  诸比丘众　　今告汝等　　皆当一心
  听我所说　　我大弟子　　须菩提者
  当得作佛　　号曰名相　　当供无数
  万亿诸佛　　随佛所行　　渐具大道
  最后身得　　三十二相　　端正姝妙
  犹如宝山　　其佛国土　　严净第一
  众生见者　　无不爱乐　　佛于其中
  度无量众　　其佛法中　　多诸菩萨
  皆悉利根　　转不退轮　　彼国常以
  菩萨庄严　　诸声闻众　　不可称数
  皆得三明　　具六神通　　住八解脱
  有大威德　　其佛说法　　现于无量
  神通变化　　不可思议　　诸天人民
  数如恒沙　　皆共合掌　　听受佛语
  其佛当寿　　十二小劫　　正法住世
  二十小劫　　像法亦住　　二十小劫

尔时世尊复告诸比丘众。我今语汝。是大迦旃延。于当来世。以诸供具供养奉事八千亿佛恭敬尊重。诸佛灭后。各起塔庙高千由旬。纵广正等五百由旬。皆以金银琉璃车磲马瑙真珠玫瑰七宝合成众华璎珞涂香末香烧香缯盖幢幡。供养塔庙。过是已后。当复供养二万亿佛。亦复如是。供养是诸佛已。具菩萨道当得作佛。号曰阎浮那提金光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其土平正。颇梨为地宝树庄严。黄金为绳以界道侧。妙华覆地周遍清净。见者欢喜。无四恶道地狱饿鬼畜生阿修罗道。多有天人诸声闻众。及诸菩萨无量万亿。庄严其国。佛寿十二小劫。正法住世二十小劫。像法亦住二十小劫。尔时世尊欲重宣此义。而说偈言

  诸比丘众　　皆一心听　　如我所说
  真实无异　　是迦栴延　　当以种种
  妙好供具　　供养诸佛　　诸佛灭后
  起七宝塔　　亦以华香　　供养舍利
  其最后身　　得佛智慧　　成等正觉
  国土清净　　度脱无量　　万亿众生
  皆为十方　　之所供养　　佛之光明
  无能胜者　　其佛号曰　　阎浮金光
  菩萨声闻　　断一切有　　无量无数
  庄严其国

尔时世尊复告大众。我今语汝。是大目犍连。当以种种供具供养八千诸佛。恭敬尊重。诸佛灭后。各起塔庙高千由旬。纵广正等五百由旬。皆以金银琉璃车磲马瑙真珠玫瑰七宝合成众华璎珞涂香末香烧香缯盖幢幡。以用供养。过是已后。当复供养二百万亿诸佛。亦复如是。当得成佛。号曰多摩罗跋栴檀香如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名喜满。国名意乐。其土平正。颇梨为地宝树庄严。散真珠华周遍清净。见者欢喜。多诸天人菩萨声闻其数无量。佛寿二十四小劫。正法住世四十小劫。像法亦住四十小劫。尔时世尊。欲重宣此义。而说偈言

  我此弟子　　大目犍连　　舍是身已
  得见八千　　二百万亿　　诸佛世尊
  为佛道故　　供养恭敬　　于诸佛所
  常修梵行　　于无量劫　　奉持佛法
  诸佛灭后　　起七宝塔　　长表金刹
  华香伎乐　　而以供养　　诸佛塔庙
  渐渐具足　　菩萨道已　　于意乐国
  而得作佛　　号多摩罗　　栴檀之香
  其佛寿命　　二十四劫　　常为天人
  演说佛道　　声闻无量　　如恒河沙
  三明六通　　有大威德　　菩萨无数
  志固精进　　于佛智慧　　皆不退转
  佛灭度后　　正法当住　　四十小劫
  像法亦尔　　我诸弟子　　威德具足
  其数五百　　皆当授记　　于未来世
  咸得成佛　　我及汝等　　宿世因缘
  吾今当说　　汝等善听

    妙法莲华经化城喻品第七

佛告诸比丘。乃往过去无量无边不可思议阿僧祇劫。尔时有佛。名大通智胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其国名好成。劫名大相。诸比丘。彼佛灭度已来甚大久远。譬如三千大千世界所有地种。假使有人磨以为墨。过于东方千国土乃下一点。大如微尘。又过千国土复下一点。如是展转尽地种墨。于汝等意云何。是诸国土。若算师若算师弟子。能得边际知其数不。不也世尊。诸比丘。是人所经国土。若点不点。尽末为尘一尘一劫。彼佛灭度已来复过是数。无量无边百千万亿阿僧祇劫。我以如来知见力故。观彼久远犹若今日。尔时世尊欲重宣此义。而说偈言

  我念过去世　　无量无边劫
  有佛两足尊　　名大通智胜
  如人以力磨　　三千大千土
  尽此诸地种　　皆悉以为墨
  过于千国土　　乃下一尘点
  如是展转点　　尽此诸尘墨
  如是诸国土　　点与不点等
  复尽末为尘　　一尘为一劫
  此诸微尘数　　其劫复过是
  彼佛灭度来　　如是无量劫
  如来无碍智　　知彼佛灭度
  及声闻菩萨　　如见今灭度
  诸比丘当知　　佛智净微妙
  无漏无所碍　　通达无量劫

佛告诸比丘。大通智胜佛。寿五百四十万亿那由他劫。其佛本坐道场破魔军已。垂得阿耨多罗三藐三菩提。而诸佛法不现在前。如是一小劫乃至十小劫。结加趺坐身心不动。而诸佛法犹不在前。尔时忉利诸天。先为彼佛于菩提树下。敷师子座。高一由旬。佛于此座。当得阿耨多罗三藐三菩提。适坐此座。时诸梵天王。雨众天华面百由旬。香风时来吹去萎华更雨新者。如是不绝满十小劫供养于佛。乃至灭度常雨此华。四王诸天。为供养佛常击天鼓。其余诸天作天伎乐满十小劫。至于灭度亦复如是。诸比丘。大通智胜佛。过十小劫。诸佛之法乃现在前。成阿耨多罗三藐三菩提。其佛未出家时。有十六子。其第一者。名曰智积。诸子各有种种珍异玩好之具。闻父得成阿耨多罗三藐三菩提。皆舍所珍往诣佛所。诸母涕泣而随送之。其祖转轮圣王。与一百大臣及余百千万亿人民。皆共围绕随至道场。咸欲亲近大通智胜如来。供养恭敬尊重赞叹。到已头面礼足绕佛毕已。一心合掌瞻仰世尊。以偈颂曰

  大威德世尊　　为度众生故
  于无量亿劫　　尔乃得成佛
  诸愿已具足　　善哉吉无上
  世尊甚希有　　一坐十小劫
  身体及手足　　静然安不动
  其心常惔怕　　未曾有散乱
  究竟永寂灭　　安住无漏法
  今者见世尊　　安隐成佛道
  我等得善利　　称庆大欢喜
  众生常苦恼　　盲瞑无导师
  不识苦尽道　　不知求解脱
  长夜增恶趣　　减损诸天众
  从冥入于冥　　永不闻佛名
  今佛得最上　　安隐无漏道
  我等及天人　　为得最大利
  是故咸稽首　　归命无上尊

尔时十六王子偈赞佛已。劝请世尊转于法轮。咸作是言。世尊说法多所安隐怜愍饶益诸天人民。重说偈言

  世雄无等伦　　百福自庄严
  得无上智慧　　愿为世间说
  度脱于我等　　及诸众生类
  为分别显示　　令得是智慧
  若我等得佛　　众生亦复然
  世尊知众生　　深心之所念
  亦知所行道　　又知智慧力
  欲乐及修福　　宿命所行业
  世尊悉知已　　当转无上轮

佛告诸比丘。大通智胜佛。得阿耨多罗三藐三菩提时。十方各五百万亿诸佛世界六种震动。其国中间幽冥之处。日月威光所不能照。而皆大明。其中众生各得相见。咸作是言。此中云何忽生众生。又其国界诸天宫殿。乃至梵宫六种震动。大光普照遍满世界。胜诸天光。尔时东方五百万亿诸国土中。梵天宫殿光明照曜倍于常明。诸梵天王各作是念。今者宫殿光明。昔所未有。以何因缘而现此相。是时诸梵天王。即各相诣共议此事。时彼众中。有一大梵天王。名救一切。为诸梵众。而说偈言

  我等诸宫殿　　光明昔未有
  此是何因缘　　宜各共求之
  为大德天生　　为佛出世间
  而此大光明　　遍照于十方

尔时五百万亿国土诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣西方推寻是相。见大通智胜如来处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。即时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。其所散华如须弥山。并以供养佛菩提树。其菩提树高十由旬。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳受。时诸梵天王。即于佛前一心同声。以偈颂曰

  世尊甚希有　　难可得值遇
  具无量功德　　能救护一切
  天人之大师　　哀愍于世间
  十方诸众生　　普皆蒙饶益
  我等所从来　　五百万亿国
  舍深禅定乐　　为供养佛故
  我等先世福　　宫殿甚严饰
  今以奉世尊　　唯愿哀纳受

尔时诸梵天王。偈赞佛已。各作是言。唯愿世尊。转于法轮。度脱众生开涅槃道。时诸梵天王。一心同声。而说偈言

  世雄两足尊　　唯愿演说法
  以大慈悲力　　度苦恼众生

尔时大通智胜如来。默然许之。又诸比丘。东南方五百万亿国土诸大梵王。各自见宫殿。光明照曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。时彼众中。有一大梵天王。名曰大悲。为诸梵众。而说偈言

  是事何因缘　　而现如此相
  我等诸宫殿　　光明昔未有
  为大德天生　　为佛出世间
  未曾见此相　　当共一心求
  过千万亿土　　寻光共推之
  多是佛出世　　度脱苦众生

尔时五百万亿诸梵天王。与宫殿俱。各以衣裓盛诸天华共诣西北方推寻是相。见大通智胜如来处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之华如须弥山。并以供养佛菩提树。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳受。尔时诸梵天王。即于佛前一心同声。以偈颂曰

  圣主天中王　　迦陵频伽声
  哀愍众生者　　我等今敬礼
  世尊甚希有　　久远乃一现
  一百八十劫　　空过无有佛
  三恶道充满　　诸天众减少
  今佛出于世　　为众生作眼
  世间所归趣　　救护于一切
  为众生之父　　哀愍饶益者
  我等宿福庆　　今得值世尊

尔时诸梵天王偈赞佛已。各作是言。唯愿世尊。哀愍一切。转于法轮度脱众生。时诸梵天王。一心同声。而说偈言

  大圣转法轮　　显示诸法相
  度苦恼众生　　令得大欢喜
  众生闻此法　　得道若生天
  诸恶道减少　　忍善者增益

尔时大通智胜如来。默然许之。又诸比丘。南方五百万亿国土诸大梵王。各自见宫殿。光明照曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。以何因缘我等宫殿有此光曜。时彼众中。有一大梵天王。名曰妙法。为诸梵众。而说偈言

  我等诸宫殿　　光明甚威曜
  此非无因缘　　是相宜求之
  过于百千劫　　未曾见是相
  为大德天生　　为佛出世间

尔时五百万亿诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣北方推寻是相。见大通智胜如来处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之华如须弥山。并以供养佛菩提树。华供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳受。尔时诸梵天王。即于佛前一心同声。以偈颂曰

  世尊甚难见　　破诸烦恼者
  过百三十劫　　今乃得一见
  诸饥渴众生　　以法雨充满
  昔所未曾见　　无量智慧者
  如优昙钵花　　今日乃值遇
  我等诸宫殿　　蒙光故严饰
  世尊大慈悲　　唯愿垂纳受

尔时诸梵天王偈赞佛已。各作是言。唯愿世尊。转于法轮。令一切世间诸天魔梵沙门婆罗门。皆获安隐而得度脱。时诸梵天王。一心同声。以偈颂曰

  唯愿天人尊　　转无上法轮
  击于大法鼓　　而吹大法螺
  普雨大法雨　　度无量众生
  我等咸归请　　当演深远音

尔时大通智胜如来。默然许之。西南方乃至下方亦复如是。尔时上方五百万亿国土诸大梵王。皆悉自睹所止宫殿。光明威曜昔所未有。欢喜踊跃生希有心。即各相诣共议此事。以何因缘我等宫殿有斯光明。时彼众中有一大梵天王。名曰尸弃。为诸梵众。而说偈言

  今以何因缘　　我等诸宫殿
  威德光明曜　　严饰未曾有
  如是之妙相　　昔所未闻见
  为大德天生　　为佛出世间

尔时五百万亿诸梵天王。与宫殿俱。各以衣裓盛诸天华。共诣下方推寻是相。见大通智胜如来处于道场菩提树下坐师子座。诸天龙王乾闼婆紧那罗摩睺罗伽人非人等恭敬围绕。及见十六王子请佛转法轮。时诸梵天王。头面礼佛绕百千匝。即以天华而散佛上。所散之花如须弥山。并以供养佛菩提树。花供养已。各以宫殿奉上彼佛。而作是言。唯见哀愍饶益我等。所献宫殿愿垂纳受。时诸梵天王。即于佛前一心同声。以偈颂曰

  善哉见诸佛　　救世之圣尊
  能于三界狱　　勉出诸众生
  普智天人尊　　哀愍群萌类
  能开甘露门　　广度于一切
  于昔无量劫　　空过无有佛
  世尊未出时　　十方常暗冥
  三恶道增长　　阿修罗亦盛
  诸天众转减　　死多堕恶道
  不从佛闻法　　常行不善事
  色力及智慧　　斯等皆减少
  罪业因缘故　　失乐及乐想
  住于邪见法　　不识善仪则
  不蒙佛所化　　常堕于恶道
  佛为世间眼　　久远时乃出
  哀愍诸众生　　故现于世间
  超出成正觉　　我等甚欣庆
  及余一切众　　喜叹未曾有
  我等诸宫殿　　蒙光故严饰
  今以奉世尊　　唯垂哀纳受
  愿以此功德　　普及于一切
  我等与众生　　皆共成佛道

尔时五百万亿诸梵天王偈赞佛已。各白佛言。唯愿世尊。转于法轮。多所安隐。多所度脱。时诸梵天王。而说偈言

  世尊转法轮　　击甘露法鼓
  度苦恼众生　　开示涅槃道
  唯愿受我请　　以大微妙音
  哀愍而敷演　　无量劫习法

尔时大通智胜如来。受十方诸梵天王及十六王子请。即时三转十二行法轮。若沙门婆罗门。若天魔梵及余世间。所不能转。谓是苦。是苦集。是苦灭。是苦灭道。及广说十二因缘法。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。佛于天人大众之中说是法时。六百万亿那由他人。以不受一切法故。而于诸漏心得解脱。皆得深妙禅定三明六通具八解脱。第二第三第四说法时。千万亿恒河沙那由他等众生。亦以不受一切法故。而于诸漏心得解脱。从是已后。诸声闻众。无量无边不可称数。尔时十六王子。皆以童子出家而为沙弥。诸根通利智慧明了。已曾供养百千万亿诸佛。净修梵行。求阿耨多罗三藐三菩提。俱白佛言。世尊。是诸无量千万亿大德声闻。皆已成就。世尊。亦当为我等说阿耨多罗三藐三菩提法。我等闻已皆共修学。世尊。我等志愿如来知见。深心所念佛自证知。尔时转轮圣王所将众中八万亿人。见十六王子出家。亦求出家王即听许。尔时彼佛受沙弥请。过二万劫已。乃于四众之中。说是大乘经。名妙法莲华教菩萨法佛所护念。说是经已。十六沙弥。为阿耨多罗三藐三菩提故。皆共受持讽诵通利说是经时。十六菩萨沙弥皆悉信受。声闻众中亦有信解。其余众生千万亿种皆生疑惑。佛说是经。于八千劫未曾休废。说此经已即入静室。住于禅定八万四千劫。是时十六菩萨沙弥。知佛入室寂然禅定。各升法座。亦于八万四千劫。为四部众广说分别妙法华经。一一皆度六百万亿那由他恒河沙等众生示教利喜。令发阿耨多罗三藐三菩提心。大通智胜佛。过八万四千劫已。从三昧起。往诣法座安详而坐。普告大众。是十六菩萨沙弥。甚为希有。诸根通利智慧明了。已曾供养无量千万亿数诸佛于诸佛所常修梵行。受持佛智开示众生令入其中。汝等皆当数数亲近而供养之。所以者何。若声闻辟支佛及诸菩萨。能信是十六菩萨所说经法。受持不毁者。是人皆当得阿耨多罗三藐三菩提如来之慧。佛告诸比丘。是十六菩萨常乐说是妙法莲华经。一一菩萨所化六百万亿那由他恒河沙等众生。世世所生与菩萨俱。从其闻法悉皆信解。以此因缘。得值四百万亿诸佛世尊于今不尽。诸比丘。我今语汝。彼佛弟子十六沙弥。今皆得阿耨多罗三藐三菩提。于十方国土。现在说法有无量百千万亿菩萨声闻。以为眷属。其二沙弥东方作佛。一名阿閦在欢喜国。二名须弥顶。东南方二佛。一名师子音。二名师子相。南方二佛。一名虚空住。二名常灭。西南方二佛。一名帝相。二名梵相。西方二佛。一名阿弥陀。二名度一切世间苦恼。西北方二佛。一名多摩罗跋栴檀香神通。二名须弥相。北方二佛。一名云自在。二名云自在王。东北方佛名坏一切世间怖畏。第十六我释迦牟尼佛。于娑婆国土。成阿耨多罗三藐三菩提。诸比丘。我等为沙弥时。各各教化无量百千万亿恒河沙等众生。从我闻法为阿耨多罗三藐三菩提。此诸众生。于今有住声闻地者。我常教化阿耨多罗三藐三菩提。是诸人等。应以是法渐入佛道。所以者何。如来智慧难信难解。尔时所化无量恒河沙等众生者。汝等诸比丘及我灭度后未来世中声闻弟子是也。我灭度后。复有弟子不闻是经。不知不觉菩萨所行。自于所得功德生灭度想。当入涅槃。我于余国作佛。更有异名。是人虽生灭度之想入于涅槃。而于彼土求佛智慧。得闻是经。唯以佛乘而得灭度。更无余乘。除诸如来方便说法。诸比丘。若如来自知涅槃时到。众又清净信解坚固。了达空法深入禅定。便集诸菩萨及声闻众为说是经。世间无有二乘而得灭度。唯一佛乘得灭度耳。比丘当知。如来方便深入众生之性。如其志乐小法深着五欲。为是等故说于涅槃。是人若闻则便信受。譬如五百由旬险难恶道旷绝无人怖畏之处。若有多众。欲过此道至珍宝处。有一导师。聪慧明达善知险道通塞之相。将导众人欲过此难。所将人众。中路懈退白导师言。我等疲极而复怖畏。不能复进。前路犹远。今欲退还。导师多诸方便。而作是念。此等可愍。云何舍大珍宝而欲退还。作是念已。以方便力。于险道中过三百由旬。化作一城。告众人言。汝等勿怖莫得退还。今此大城。可于中止随意所作。若入是城快得安隐。若能前至宝所亦可得去。是时疲极之众。心大欢喜叹未曾有。我等今者免斯恶道快得安隐。于是众人。前入化城。生已度想生安隐想。尔时导师。知此人众既得止息无复疲惓。即灭化城。语众人言。汝等去来宝处在近。向者大城我所化作为止息耳。诸比丘。如来亦复如是。今为汝等作大导师。知诸生死烦恼恶道险难长远应去应度。若众生但闻一佛乘者。则不欲见佛不欲亲近。便作是念。佛道长远久受勤苦。乃可得成佛。知是心怯弱下劣。以方便力而于中道为止息故说二涅槃。若众生住于二地。如来尔时即便为说。汝等所作未办。汝所住地近于佛慧。当观察筹量。所得涅槃。非真实也。但是如来方便之力。于一佛乘分别说三。如彼导师为止息故化作大城。既知息已而告之言宝处在近。此城非实。我化作耳。尔时世尊欲重宣此义。而说偈言

  大通智胜佛　　十劫坐道场
  佛法不现前　　不得成佛道
  诸天神龙王　　阿修罗众等
  常雨于天华　　以供养彼佛
  诸天击天鼓　　并作众伎乐
  香风吹萎华　　更雨新好者
  过十小劫已　　乃得成佛道
  诸天及世人　　心皆怀踊跃
  彼佛十六子　　皆与其眷属
  千万亿围绕　　俱行至佛所
  头面礼佛足　　而请转法轮
  圣师子法雨　　充我及一切
  世尊甚难值　　久远时一现
  为觉悟群生　　震动于一切
  东方诸世界　　五百万亿国
  梵宫殿光曜　　昔所未曾有
  诸梵见此相　　寻来至佛所
  散花以供养　　并奉上宫殿
  请佛转法轮　　以偈而赞叹
  佛知时未至　　受请默然坐
  三方及四维　　上下亦复尔
  散花奉宫殿　　请佛转法轮
  世尊甚难值　　愿以大慈悲
  广开甘露门　　转无上法轮
  无量慧世尊　　受彼众人请
  为宣种种法　　四谛十二缘
  无明至老死　　皆从生缘有
  如是众过患　　汝等应当知
  宣畅是法时　　六百万亿垓
  得尽诸苦际　　皆成阿罗汉
  第二说法时　　千万恒沙众
  于诸法不受　　亦得阿罗汉
  从是后得道　　其数无有量
  万亿劫算数　　不能得其边
  时十六王子　　出家作沙弥
  皆共请彼佛　　演说大乘法
  我等及营从　　皆当成佛道
  愿得如世尊　　慧眼第一净
  佛知童子心　　宿世之所行
  以无量因缘　　种种诸譬喻
  说六波罗蜜　　及诸神通事
  分别真实法　　菩萨所行道
  说是法华经　　如恒河沙偈
  彼佛说经已　　静室入禅定
  一心一处坐　　八万四千劫
  是诸沙弥等　　知佛禅未出
  为无量亿众　　说佛无上慧
  各各坐法座　　说是大乘经
  于佛宴寂后　　宣扬助法化
  一一沙弥等　　所度诸众生
  有六百万亿　　恒河沙等众
  彼佛灭度后　　是诸闻法者
  在在诸佛土　　常与师俱生
  是十六沙弥　　具足行佛道
  今现在十方　　各得成正觉
  尔时闻法者　　各在诸佛所
  其有住声闻　　渐教以佛道
  我在十六数　　曾亦为汝说
  是故以方便　　引汝趣佛慧
  以是本因缘　　今说法华经
  令汝入佛道　　慎勿怀惊惧
  譬如险恶道　　迥绝多毒兽
  又复无水草　　人所怖畏处
  无数千万众　　欲过此险道
  其路甚旷远　　经三百由旬
  时有一导师　　强识有智慧
  明了心决定　　在险济众难
  众人皆疲惓　　而白导师言
  我等今顿乏　　于此欲退还
  导师作是念　　此辈甚可愍
  如何欲退还　　而失大珍宝
  寻时思方便　　当设神通力
  化作大城郭　　庄严诸舍宅
  周匝有园林　　渠流及浴池
  重门高楼阁　　男女皆充满
  即作是化已　　慰众言勿惧
  汝等入此城　　各可随所乐
  诸人既入城　　心皆大欢喜
  皆生安隐想　　自谓已得度
  导师知息已　　集众而告言
  汝等当前进　　此是化城耳
  我见汝疲极　　中路欲退还
  故以方便力　　权化作此城
  汝等勤精进　　当共至宝所
  我亦复如是　　为一切导师
  见诸求道者　　中路而懈废
  不能度生死　　烦恼诸险道
  故以方便力　　为息说涅槃
  言汝等苦灭　　所作皆已办
  既知到涅槃　　皆得阿罗汉
  尔乃集大众　　为说真实法
  诸佛方便力　　分别说三乘
  唯有一佛乘　　息处故说二
  今为汝说实　　汝所得非灭
  为佛一切智　　当发大精进
  汝证一切智　　十力等佛法
  具三十二相　　乃是真实灭
  诸佛之导师　　为息说涅槃
  既知是息已　　引入于佛慧

妙法莲华经卷第三妙法莲华经卷第四

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    五百弟子受记品第八

尔时富楼那弥多罗尼子。从佛闻是智慧方便随宜说法。又闻授诸大弟子阿耨多罗三藐三菩提记。复闻宿世因缘之事。复闻诸佛有大自在神通之力。得未曾有心净踊跃。即从座起到于佛前。头面礼足却住一面。瞻仰尊颜目不暂舍。而作是念。世尊甚奇特。所为希有。随顺世间若干种性。以方便知见而为说法。拔出众生处处贪着。我等于佛功德言不能宣。唯佛世尊。能知我等深心本愿。尔时佛告诸比丘。汝等见是富楼那弥多罗尼子不。我常称其于说法人中最为第一。亦常叹其种种功德。精勤护持助宣我法。能于四众示教利喜。具足解释佛之正法。而大饶益同梵行者。自舍如来无能尽其言论之辩。汝等勿谓富楼那但能护持助宣我法。亦于过去九十亿诸佛所。护持助宣佛之正法。于彼说法人中亦最第一。又于诸佛所说空法。明了通达。得四无碍智。常能审谛清净说法。无有疑惑。具足菩萨神通之力。随其寿命常修梵行。彼佛世人。咸皆谓之实是声闻。而富楼那以斯方便。饶益无量百千众生。又化无量阿僧祇人。令立阿耨多罗三藐三菩提。为净佛土故。常作佛事教化众生。诸比丘。富楼那亦于七佛说法人中而得第一。今于我所说法人中亦为第一。于贤劫中当来诸佛说法人中亦复第一。而皆护持助宣佛法。亦于未来护持助宣无量无边诸佛之法。教化饶益无量众生。令立阿耨多罗三藐三菩提。为净佛土故。常勤精进教化众生。渐渐具足菩萨之道。过无量阿僧祇劫。当于此土得阿耨多罗三藐三菩提。号曰法明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛以恒河沙等三千大千世界为一佛土。七宝为地。地平如掌。无有山陵溪涧沟壑。七宝台观充满其中。诸天宫殿近处虚空。人天交接两得相见。无诸恶道亦无女人。一切众生皆以化生。无有淫欲得大神通。身出光明飞行自在。志念坚固精进智慧。普皆金色三十二相。而自庄严。其国众生常以二食。一者法喜食。二者禅悦食。有无量阿僧祇千万亿那由他诸菩萨众。得大神通四无碍智。善能教化众生之类。其声闻众。算数校计所不能知。皆得具足六通三明及八解脱。其佛国土。有如是等无量功德庄严成就。劫名宝明。国名善净。其佛寿命。无量阿僧祇劫。法住甚久。佛灭度后。起七宝塔遍满其国。尔时世尊欲重宣此义。而说偈言

  诸比丘谛听　　佛子所行道
  善学方便故　　不可得思议
  知众乐小法　　而畏于大智
  是故诸菩萨　　作声闻缘觉
  以无数方便　　化诸众生类
  自说是声闻　　去佛道甚远
  度脱无量众　　皆悉得成就
  虽小欲懈怠　　渐当令作佛
  内秘菩萨行　　外现是声闻
  少欲厌生死　　实自净佛土
  示众有三毒　　又现邪见相
  我弟子如是　　方便度众生
  若我具足说　　种种现化事
  众生闻是者　　心则怀疑惑
  今此富楼那　　于昔千亿佛
  勤修所行道　　宣护诸佛法
  为求无上慧　　而于诸佛所
  现居弟子上　　多闻有智慧
  所说无所畏　　能令众欢喜
  未曾有疲惓　　而以助佛事
  已度大神通　　具四无碍智
  知诸根利钝　　常说清净法
  演畅如是义　　教诸千亿众
  令住大乘法　　而自净佛土
  未来亦供养　　无量无数佛
  护助宣正法　　亦自净佛土
  常以诸方便　　说法无所畏
  度不可计众　　成就一切智
  供养诸如来　　护持法宝藏
  其后得成佛　　号名曰法明
  其国名善净　　七宝所合成
  劫名为宝明　　菩萨众甚多
  其数无量亿　　皆度大神通
  威德力具足　　充满其国土
  声闻亦无数　　三明八解脱
  得四无碍智　　以是等为僧
  其国诸众生　　淫欲皆已断
  纯一变化生　　具相庄严身
  法喜禅悦食　　更无余食想
  无有诸女人　　亦无诸恶道
  富楼那比丘　　功德悉成满
  当得斯净土　　贤圣众甚多
  如是无量事　　我今但略说

尔时千二百阿罗汉心自在者作是念。我等欢喜得未曾有。若世尊各见授记如余大弟子者。不亦快乎。佛知此等心之所念。告摩诃迦叶。是千二百阿罗汉。我今当现前次第与授阿耨多罗三藐三菩提记。于此众中。我大弟子憍陈如比丘。当供养六万二千亿佛。然后得成为佛。号曰普明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其五百阿罗汉。优楼频螺迦叶。伽耶迦叶。那提迦叶。迦留陀夷优陀夷。阿[少/兔]楼驮。离婆多。劫宾那。薄拘罗周陀莎伽陀等。皆当得阿耨多罗三藐三菩提。尽同一号。名曰普明。尔时世尊。欲重宣此义。而说偈言

  憍陈如比丘　　当见无量佛
  过阿僧祇劫　　乃成等正觉
  常放大光明　　具足诸神通
  名闻遍十方　　一切之所敬
  常说无上道　　故号为普明
  其国土清净　　菩萨皆勇猛
  咸升妙楼阁　　游诸十方国
  以无上供具　　奉献于诸佛
  作是供养已　　心怀大欢喜
  须臾还本国　　有如是神力
  佛寿六万劫　　正法住倍寿
  像法复倍是　　法灭天人忧
  其五百比丘　　次第当作佛
  同号曰普明　　转次而授记
  我灭度之后　　某甲当作佛
  其所化世间　　亦如我今日
  国土之严净　　及诸神通力
  菩萨声闻众　　正法及像法
  寿命劫多少　　皆如上所说
  迦叶汝已知　　五百自在者
  余诸声闻众　　亦当复如是
  其不在此会　　汝当为宣说

尔时五百阿罗汉。于佛前得受记已欢喜踊跃。即从座起到于佛前。头面礼足悔过自责。世尊。我等常作是念。自谓已得究竟灭度。今乃知之如无智者。所以者何。我等应得如来智慧。而便自以小智为足。世尊。譬如有人至亲友家醉酒而卧。是时亲友官事当行。以无价宝珠系其衣里与之而去。其人醉卧都不觉知。起已游行到于他国。为衣食故。勤力求索甚大艰难。若少有所得便以为足。于后亲友会遇见之。而作是言。咄哉丈夫。何为衣食乃至如是。我昔欲令汝得安乐五欲自恣。于某年日月。以无价宝珠系汝衣里。今故现在。而汝不知。勤苦忧恼以求自活。甚为痴也。汝今可以此宝贸易所须。常可如意无所乏短。佛亦如是。为菩萨时教化我等。令发一切智心。而寻废忘不知不觉。既得阿罗汉道。自谓灭度。资生艰难得少为足。一切智愿犹在不失。今者世尊觉悟我等。作如是言。诸比丘。汝等所得非究竟灭。我久令汝等种佛善根。以方便故示涅槃相。而汝谓为实得灭度。世尊。我今乃知实是菩萨。得受阿耨多罗三藐三菩提记。以是因缘甚大欢喜得未曾有。尔时阿若憍陈如等。欲重宣此义。而说偈言

  我等闻无上　　安隐授记声
  欢喜未曾有　　礼无量智佛
  今于世尊前　　自悔诸过咎
  于无量佛宝　　得少涅槃分
  如无智愚人　　便自以为足
  譬如贫穷人　　往至亲友家
  其家甚大富　　具设诸肴膳
  以无价宝珠　　系着内衣里
  默与而舍去　　时卧不觉知
  是人既已起　　游行诣他国
  求衣食自济　　资生甚艰难
  得少便为足　　更不愿好者
  不觉内衣里　　有无价宝珠
  与珠之亲友　　后见此贫人
  苦切责之已　　示以所系珠
  贫人见此珠　　其心大欢喜
  富有诸财物　　五欲而自恣
  我等亦如是　　世尊于长夜
  常愍见教化　　令种无上愿
  我等无智故　　不觉亦不知
  得少涅槃分　　自足不求余
  今佛觉悟我　　言非实灭度
  得佛无上慧　　尔乃为真灭
  我今从佛闻　　授记庄严事
  及转次受决　　身心遍欢喜

    妙法莲华经授学无学人记品第九

尔时阿难。罗睺罗。而作是念。我等每自思惟。设得受记不亦快乎。即从座起到于佛前头面礼足。俱白佛言。世尊。我等于此亦应有分。唯有如来我等所归。又我等为一切世间天人阿修罗所见知识。阿难常为侍者护持法藏。罗睺罗是佛之子。若佛见授阿耨多罗三藐三菩提记者。我愿既满众望亦足。尔时学无学声闻弟子二千人。皆从座起偏袒右肩到于佛前。一心合掌瞻仰世尊。如阿难罗睺罗所愿。住立一面。尔时佛告阿难。汝于来世当得作佛。号山海慧自在通王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。当供养六十二亿诸佛护持法藏。然后得阿耨多罗三藐三菩提。教化二十千万亿恒河沙诸菩萨等。令成阿耨多罗三藐三菩提。国名常立胜幡。其土清净琉璃为地。劫名妙音遍满。其佛寿命。无量千万亿阿僧祇劫。若人于千万亿无量阿僧祇劫中。算数校计不能得知。正法住世倍于寿命。像法住世复倍正法。阿难。是山海慧自在通王佛。为十方无量千万亿恒河沙等诸佛如来。所共赞叹称其功德。尔时世尊。欲重宣此义。而说偈言

  我今僧中说　　阿难持法者
  当供养诸佛　　然后成正觉
  号曰山海慧　　自在通王佛
  其国土清净　　名常立胜幡
  教化诸菩萨　　其数如恒沙
  佛有大威德　　名闻满十方
  寿命无有量　　以愍众生故
  正法倍寿命　　像法复倍是
  如恒河沙等　　无数诸众生
  于此佛法中　　种佛道因缘

尔时会中新发意菩萨八千人。咸作是念。我等尚不闻诸大菩萨得如是记。有何因缘。而诸声闻得如是决。尔时世尊。知诸菩萨心之所念。而告之曰。诸善男子。我与阿难等。于空王佛所。同时发阿耨多罗三藐三菩提心。阿难常乐多闻。我常勤精进。是故我已得成阿耨多罗三藐三菩提。而阿难护持我法。亦护将来诸佛法藏。教化成就诸菩萨众。其本愿如是。故获斯记。阿难面于佛前。自闻授记及国土庄严。所愿具足。心大欢喜得未曾有。即时忆念过去无量千万亿诸佛法藏。通达无碍如今所闻。亦识本愿。尔时阿难。而说偈言

  世尊甚希有　　令我念过去
  无量诸佛法　　如今日所闻
  我今无复疑　　安住于佛道
  方便为侍者　　护持诸佛法

尔时佛告罗睺罗。汝于来世当得作佛。号蹈七宝华如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。当供养十世界微尘等数诸佛如来。常为诸佛而作长子。犹如今也。是蹈七宝华佛。国土庄严。寿命劫数。所化弟子。正法像法。亦如山海慧自在通王如来无异。亦为此佛而作长子。过是已后当得阿耨多罗三藐三菩提。尔时世尊。欲重宣此义。而说偈言

  我为太子时　　罗睺为长子
  我今成佛道　　受法为法子
  于未来世中　　见无量亿佛
  皆为其长子　　一心求佛道
  罗睺罗密行　　唯我能知之
  现为我长子　　以示诸众生
  无量亿千万　　功德不可数
  安住于佛法　　以求无上道

尔时世尊。见学无学二千人其意柔软寂然清净一心观佛。佛告阿难。汝见是学无学二千人不。唯然已见。阿难。是诸人等。当供养五十世界微尘数诸佛如来。恭敬尊重护持法藏。末后同时。于十方国各得成佛。皆同一号。名曰宝相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。寿命一劫。国土庄严。声闻菩萨。正法像法。皆悉同等。尔时世尊。欲重宣此义。而说偈言

  是二千声闻　　今于我前住
  悉皆与授记　　未来当成佛
  所供养诸佛　　如上说尘数
  护持其法藏　　后当成正觉
  各于十方国　　悉同一名号
  俱时坐道场　　以证无上慧
  皆名为宝相　　国土及弟子
  正法与像法　　悉等无有异
  咸以诸神通　　度十方众生
  名闻普周遍　　渐入于涅槃

尔时学无学二千人。闻佛授记欢喜踊跃。而说偈言

  世尊慧灯明　　我闻授记音
  心欢喜充满　　如甘露见灌

    妙法莲华经法师品第十

尔时世尊。因药王菩萨。告八万大士。药王。汝见是大众中无量诸天龙王夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。及比丘比丘尼。优婆塞优婆夷。求声闻者。求辟支佛者。求佛道者。如是等类咸于佛前。闻妙法华经一偈一句。乃至一念随喜者。我皆与授记。当得阿耨多罗三藐三菩提。佛告药王。又如来灭度之后。若有人闻妙法华经乃至一偈一句一念随喜者。我亦与授阿耨多罗三藐三菩提记。若复有人。受持读诵解说书写妙法华经乃至一偈。于此经卷敬视如佛。种种供养华香璎珞末香涂香烧香缯盖幢幡衣服伎乐。乃至合掌恭敬。药王当知。是诸人等。已曾供养十万亿佛。于诸佛所成就大愿。愍众生故生此人间。药王。若有人问何等众生于未来世当得作佛。应示是诸人等于未来世必得作佛。何以故。若善男子善女人。于法华经乃至一句。受持读诵解说书写。种种供养经卷。华香璎珞末香涂香烧香缯盖幢幡衣服伎乐。合掌恭敬。是人一切世间所应瞻奉。应以如来供养而供养之。当知此人是大菩萨。成就阿耨多罗三藐三菩提。哀愍众生愿生此间。广演分别妙法华经。何况尽能受持种种供养者。药王当知。是人自舍清净业报。于我灭度后。愍众生故。生于恶世广演此经。若是善男子善女人。我灭度后。能窃为一人说法华经乃至一句。当知是人。则如来使如来所遣行如来事。何况于大众中广为人说。药王。若有恶人以不善心。于一劫中现于佛前。常毁骂佛其罪尚轻。若人以一恶言。毁呰在家出家读诵法华经者。其罪甚重。药王。其有读诵法华经者。当知是人。以佛庄严而自庄严。则为如来肩所荷担。其所至方应随向礼。一心合掌恭敬供养尊重赞叹。华香璎珞末香涂香烧香缯盖幢幡衣服肴馔。作诸伎乐。人中上供而供养之。应持天宝而以散之。天上宝聚应以奉献。所以者何。是人欢喜说法。须臾闻之。即得究竟阿耨多罗三藐三菩提故。尔时世尊。欲重宣此义。而说偈言

  若欲住佛道　　成就自然智
  常当勤供养　　受持法华者
  其有欲疾得　　一切种智慧
  当受持是经　　并供养持者
  若有能受持　　妙法华经者
  当知佛所使　　愍念诸众生
  诸有能受持　　妙法华经者
  舍于清净土　　愍众故生此
  当知如是人　　自在所欲生
  能于此恶世　　广说无上法
  应以天华香　　及天宝衣服
  天上妙宝聚　　供养说法者
  吾灭后恶世　　能持是经者
  当合掌礼敬　　如供养世尊
  上馔众甘美　　及种种衣服
  供养是佛子　　冀得须臾闻
  若能于后世　　受持是经者
  我遣在人中　　行于如来事
  若于一劫中　　常怀不善心
  作色而骂佛　　获无量重罪
  其有读诵持　　是法华经者
  须臾加恶言　　其罪复过彼
  有人求佛道　　而于一劫中
  合掌在我前　　以无数偈赞
  由是赞佛故　　得无量功德
  叹美持经者　　其福复过彼
  于八十亿劫　　以最妙色声
  及与香味触　　供养持经者
  如是供养已　　若得须臾闻
  则应自欣庆　　我今获大利
  药王今告汝　　我所说诸经
  而于此经中　　法华最第一

尔时佛复告药王菩萨摩诃萨。我所说经典无量千万亿。已说今说当说。而于其中。此法华经最为难信难解。药王。此经是诸佛秘要之藏。不可分布妄授与人。诸佛世尊之所守护。从昔已来未曾显说。而此经者。如来现在犹多怨嫉。况灭度后。药王当知。如来灭后。其能书持读诵供养为他人说者。如来则为以衣覆之。又为他方现在诸佛之所护念。是人有大信力及志愿力诸善根力。当知是人与如来共宿。则为如来手摩其头。药王。在在处处。若说若读若诵若书。若经卷所住处。皆应起七宝塔极令高广严饰。不须复安舍利。所以者何。此中已有如来全身。此塔应以一切华香璎珞缯盖幢幡伎乐歌颂。供养恭敬尊重赞叹。若有人得见此塔礼拜供养。当知是等皆近阿耨多罗三藐三菩提。药王。多有人在家出家行菩萨道。若不能得见闻读诵书持供养是法华经者。当知是人未善行菩萨道。若有得闻是经典者。乃能善行菩萨之道。其有众生求佛道者。若见若闻是法华经。闻已信解受持者。当知是人得近阿耨多罗三藐三菩提。药王。譬如有人渴乏须水。于彼高原穿凿求之。犹见干土知水尚远。施功不已转见湿土遂渐至泥。其心决定知水必近。菩萨亦复如是。若未闻未解未能修习是法华经者。当知是人去阿耨多罗三藐三菩提尚远。若得闻解思惟修习。必知得近阿耨多罗三藐三菩提。所以者何。一切菩萨阿耨多罗三藐三菩提皆属此经。此经开方便门示真实相。是法华经藏深固幽远。无人能到。今佛教化成就菩萨。而为开示。药王。若有菩萨。闻是法华经惊疑怖畏。当知是为新发意菩萨。若声闻人。闻是经惊疑怖畏。当知是为增上慢者。药王。若有善男子善女人。如来灭后。欲为四众说是法华经者。云何应说。是善男子善女人。入如来室。着如来衣。坐如来座。尔乃应为四众广说斯经。如来室者。一切众生中大慈悲心是。如来衣者。柔和忍辱心是。如来座者。一切法空是。安住是中。然后以不懈怠心。为诸菩萨及四众广说是法华经。药王。我于余国遣化人为其集听法众。亦遣化比丘比丘尼优婆塞优婆夷听其说法。是诸化人。闻法信受随顺不逆。若说法者在空闲处。我时广遣天龙鬼神乾闼婆阿修罗等听其说法。我虽在异国。时时令说法者得见我身。若于此经忘失句逗。我还为说令得具足。尔时世尊。欲重宣此义。而说偈言

  欲舍诸懈怠　　应当听此经
  是经难得闻　　信受者亦难
  如人渴须水　　穿凿于高原
  犹见干燥土　　知去水尚远
  渐见湿土泥　　决定知近水
  药王汝当知　　如是诸人等
  不闻法华经　　去佛智甚远
  若闻是深经　　决了声闻法
  是诸经之王　　闻已谛思惟
  当知此人等　　近于佛智慧
  若人说此经　　应入如来室
  着于如来衣　　而坐如来座
  处众无所畏　　广为分别说
  大慈悲为室　　柔和忍辱衣
  诸法空为座　　处此为说法
  若说此经时　　有人恶口骂
  加刀杖瓦石　　念佛故应忍
  我千万亿土　　现净坚固身
  于无量亿劫　　为众生说法
  若我灭度后　　能说此经者
  我遣化四众　　比丘比丘尼
  及清信士女　　供养于法师
  引导诸众生　　集之令听法
  若人欲加恶　　刀杖及瓦石
  则遣变化人　　为之作卫护
  若说法之人　　独在空闲处
  寂寞无人声　　读诵此经典
  我尔时为现　　清净光明身
  若忘失章句　　为说令通利
  若人具是德　　或为四众说
  空处读诵经　　皆得见我身
  若人在空闲　　我遣天龙王
  夜叉鬼神等　　为作听法众
  是人乐说法　　分别无挂碍
  诸佛护念故　　能令大众喜
  若亲近法师　　速得菩萨道
  随顺是师学　　得见恒沙佛

    妙法莲华经见宝塔品第十一

尔时佛前有七宝塔。高五百由旬。纵广二百五十由旬。从地踊出住在空中。种种宝物而庄校之。五千栏楯龛室千万。无数幢幡以为严饰。垂宝璎珞。宝铃万亿而悬其上。四面皆出多摩罗跋栴檀之香。充遍世界。其诸幡盖。以金银琉璃车磲马脑真珠玫瑰七宝合成。高至四天王宫。三十三天。雨天曼陀罗华供养宝塔。余诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等千万亿众。以一切华香璎珞幡盖伎乐。供养宝塔恭敬尊重赞叹。尔时宝塔中出大音声叹言。善哉善哉。释迦牟尼世尊。能以平等大慧教菩萨法佛所护念妙法华经为大众说。如是如是。释迦牟尼世尊。如所说者。皆是真实。尔时四众见大宝塔住在空中。又闻塔中所出音声。皆得法喜怪未曾有。从座而起恭敬合掌却住一面。尔时有菩萨摩诃萨。名大乐说。知一切世间天人阿修罗等心之所疑。而白佛言。世尊。以何因缘有此宝塔从地踊出。又于其中发是音声。尔时佛告大乐说菩萨。此宝塔中有如来全身。乃往过去东方无量千万亿阿僧祇世界。国名宝净。彼中有佛。号曰多宝。其佛行菩萨道时。作大誓愿。若我成佛。灭度之后。于十方国土。有说法华经处。我之塔庙。为听是经故。踊现其前为作证明。赞言善哉。彼佛成道已。临灭度时。于天人大众中告诸比丘。我灭度后。欲供养我全身者。应起一大塔。其佛以神通愿力。十方世界在在处处。若有说法华经者。彼之宝塔皆踊出其前。全身在于塔中。赞言善哉善哉。大乐说。今多宝如来塔。闻说法华经故。从地踊出。赞言善哉善哉。是时大乐说菩萨。以如来神力故。白佛言。世尊我等愿欲见此佛身。佛告大乐说菩萨摩诃萨。是多宝佛有深重愿。若我宝塔。为听法华经故出于诸佛前时。其有欲以我身示四众者。彼佛分身诸佛。在于十方世界说法。尽还集一处。然后我身乃出现耳。大乐说。我分身诸佛。在于十方世界说法者今应当集。大乐说白佛言。世尊。我等亦愿欲见世尊分身诸佛礼拜供养。尔时佛放白毫一光。即见东方五百万亿那由他恒河沙等国土诸佛。彼诸国土。皆以颇梨为地。宝树宝衣以为庄严。无数千万亿菩萨。充满其中。遍张宝幔宝网罗上。彼国诸佛以大妙音而说诸法。及见无量千万亿菩萨。遍满诸国为众说法。南西北方四维上下。白毫相光所照之处。亦复如是。尔时十方诸佛各告众菩萨言。善男子。我今应往娑婆世界释迦牟尼佛所。并供养多宝如来宝塔。时娑婆世界即变清净。琉璃为地宝树庄严。黄金为绳以界八道。无诸聚落村营城邑。大海江河山川林薮烧大宝香。曼陀罗华遍布其地。以宝网幔罗覆其上。悬诸宝铃。唯留此会众。移诸天人置于他土。是时诸佛各将一大菩萨以为侍者。至娑婆世界。各到宝树下。一一宝树。高五百由旬。枝叶华果次第庄严。诸宝树下皆有师子之座。高五由旬。亦以大宝而校饰之。尔时诸佛各于此座结加趺坐。如是展转遍满三千大千世界。而于释迦牟尼佛一方所分之身。犹故未尽。时释迦牟尼佛。欲容受所分身诸佛故。八方各更变二百万亿那由他国。皆令清净。无有地狱饿鬼畜生及阿修罗。又移诸天人置于他土所化之国。亦以琉璃为地。宝树庄严。树高五百由旬。枝叶华果次第严饰。树下皆有宝师子座。高五由旬。种种诸宝以为庄校。亦无大海江河及目真邻陀山摩诃目真邻陀山铁围山大铁围山须弥山等诸山王。通为一佛国土。宝地平正。宝交露幔遍覆其上。悬诸幡盖。烧大宝香。诸天宝华遍布其地。释迦牟尼佛。为诸佛当来坐故。复于八方。各更变二百万亿那由他国。皆令清净。无有地狱饿鬼畜生及阿修罗。又移诸天人置于他土。所化之国。亦以琉璃为地。宝树庄严。树高五百由旬。枝叶华果次第庄严。树下皆有宝师子座。高五由旬。亦以大宝而校饰之。亦无大海江河及目真邻陀山摩诃目真邻陀山铁围山大铁围山须弥山等诸山王。通为一佛国土。宝地平正。宝交露幔遍覆其上。悬诸幡盖。烧大宝香。诸天宝华遍布其地。尔时东方释迦牟尼佛所分之身。百千万亿那由他恒河沙等国土中诸佛。各各说法来集于此。如是次第十方诸佛。皆悉来集坐于八方。尔时一一方四百万亿那由他国土。诸佛如来遍满其中。是时诸佛各在宝树下坐师子座。皆遣侍者。问讯释迦牟尼佛。各赍宝华满掬而告之言。善男子。汝往诣耆阇崛山释迦牟尼佛所。如我辞曰。少病少恼气力安乐。及菩萨声闻众悉安隐不。以此宝华散佛供养。而作是言。彼某甲佛。与欲开此宝塔。诸佛遣使亦复如是。尔时释迦牟尼佛。见所分身佛悉已来集。各各坐于师子之座。皆闻诸佛与欲同开宝塔。即从座起住虚空中。一切四众起立合掌一心观佛。于是释迦牟尼佛。以右指开七宝塔户。出大音声。如却关钥开大城门。即时一切众会。皆见多宝如来。于宝塔中坐师子座。全身不散如入禅定。又闻其言。善哉善哉。释迦牟尼佛。快说是法华经。我为听是经故。而来至此。尔时四众等。见过去无量千万亿劫灭度佛。说如是言。叹未曾有。以天宝华聚。散多宝佛及释迦牟尼佛上。尔时多宝佛。于宝塔中分半座。与释迦牟尼佛。而作是言。释迦牟尼佛。可就此座。即时释迦牟尼佛。入其塔中坐其半座。结加趺坐。尔时大众。见二如来在七宝塔中师子座上结加趺坐。各作是念。佛座高远。唯愿如来以神通力。令我等辈俱处虚空。即时释迦牟尼佛。以神通力接诸大众皆在虚空。以大音声普告四众。谁能于此娑婆国土广说妙法华经。今正是时。如来不久当入涅槃。佛欲以此妙法华经付嘱有在。尔时世尊。欲重宣此义。而说偈言

  圣主世尊　　虽久灭度　　在宝塔中
  尚为法来　　诸人云何　　不勤为法
  此佛灭度　　无央数劫　　处处听法
  以难遇故　　彼佛本愿　　我灭度后
  在在所往　　常为听法　　又我分身
  无量诸佛　　如恒沙等　　来欲听法
  及见灭度　　多宝如来　　各舍妙土
  及弟子众　　天人龙神　　诸供养事
  令法久住　　故来至此　　为坐诸佛
  以神通力　　移无量众　　令国清净
  诸佛各各　　诣宝树下　　如清净池
  莲华庄严　　其宝树下　　诸师子座
  佛坐其上　　光明严饰　　如夜闇中
  燃大炬火　　身出妙香　　遍十方国
  众生蒙薰　　喜不自胜　　譬如大风
  吹小树枝　　以是方便　　令法久住
  告诸大众　　我灭度后　　谁能护持
  读说斯经　　今于佛前　　自说誓言
  其多宝佛　　虽久灭度　　以大誓愿
  而师子吼　　多宝如来　　及与我身
  所集化佛　　当知此意　　诸佛子等
  谁能护法　　当发大愿　　令得久住
  其有能护　　此经法者　　则为供养
  我及多宝　　此多宝佛　　处于宝塔
  常游十方　　为是经故　　亦复供养
  诸来化佛　　庄严光饰　　诸世界者
  若说此经　　则为见我　　多宝如来
  及诸化佛　　诸善男子　　各谛思惟
  此为难事　　宜发大愿　　诸余经典
  数如恒沙　　虽说此等　　未足为难
  若接须弥　　掷置他方　　无数佛土
  亦未为难　　若以足指　　动大千界
  远掷他国　　亦未为难　　若立有顶
  为众演说　　无量余经　　亦未为难
  若佛灭后　　于恶世中　　能说此经
  是则为难　　假使有人　　手把虚空
  而以游行　　亦未为难　　于我灭后
  若自书持　　若使人书　　是则为难
  若以大地　　置足甲上　　升于梵天
  亦未为难　　佛灭度后　　于恶世中
  暂读此经　　是则为难　　假使劫烧
  担负干草　　入中不烧　　亦未为难
  我灭度后　　若持此经　　为一人说
  是则为难　　若持八万　　四千法藏
  十二部经　　为人演说　　令诸听者
  得六神通　　虽能如是　　亦未为难
  于我灭后　　听受此经　　问其义趣
  是则为难　　若人说法　　令千万亿
  无量无数　　恒沙众生　　得阿罗汉
  具六神通　　虽有是益　　亦未为难
  于我灭后　　若能奉持　　如斯经典
  是则为难　　我为佛道　　于无量土
  从始至今　　广说诸经　　而于其中
  此经第一　　若有能持　　则持佛身
  诸善男子　　于我灭后　　谁能受持
  读诵此经　　今于佛前　　自说誓言
  此经难持　　若暂持者　　我则欢喜
  诸佛亦然　　如是之人　　诸佛所叹
  是则勇猛　　是则精进　　是名持戒
  行头陀者　　则为疾得　　无上佛道
  能于来世　　读持此经　　是真佛子
  住淳善地　　佛灭度后　　能解其义
  是诸天人　　世间之眼　　于恐畏世
  能须臾说　　一切天人　　皆应供养

    妙法莲华经提婆达多品第十二

尔时佛告诸菩萨及天人四众吾于过去无量劫中。求法华经无有懈惓。于多劫中常作国王。发愿求于无上菩提。心不退转。为欲满足六波罗蜜。勤行布施。心无吝惜象马七珍国城妻子奴婢仆从。头目髓脑身肉手足不惜躯命。时世人民寿命无量。为于法故。捐舍国位委政太子。击鼓宣令四方求法。谁能为我说大乘者。吾当终身供给走使。时有仙人来白王言。我有大乘。名妙法华经。若不违我当为宣说。王闻仙言欢喜踊跃。即随仙人供给所须。采果汲水拾薪设食。乃至以身而为床座。身心无惓。于时奉事经于千岁。为于法故。精勤给侍令无所乏。尔时世尊。欲重宣此义。而说偈言

  我念过去劫　　为求大法故
  虽作世国王　　不贪五欲乐
  捶钟告四方　　谁有大法者
  若为我解说　　身当为奴仆
  时有阿私仙　　来白于大王
  我有微妙法　　世间所希有
  若能修行者　　吾当为汝说
  时王闻仙言　　心生大喜悦
  即便随仙人　　供给于所须
  采薪及果蓏　　随时恭敬与
  情存妙法故　　身心无懈惓
  普为诸众生　　勤求于大法
  亦不为己身　　及以五欲乐
  故为大国王　　勤求获此法
  遂致得成佛　　今故为汝说

佛告诸比丘。尔时王者。则我身是。时仙人者。今提婆达多是。由提婆达多善知识故。令我具足六波罗蜜慈悲喜舍三十二相八十种好紫磨金色。十力四无所畏四摄法。十八不共神通道力。成等正觉广度众生。皆因提婆达多善知识故。告诸四众。提婆达多。却后过无量劫。当得成佛。号曰天王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名天道。时天王佛。住世二十中劫。广为众生说于妙法。恒河沙众生得阿罗汉果。无量众生发缘觉心。恒河沙众生发无上道心。得无生忍至不退转。时天王佛般涅槃后。正法住世二十中劫。全身舍利起七宝塔。高六十由旬。纵广四十由旬。诸天人民悉以杂华末香烧香涂香衣服璎珞幢幡宝盖伎乐歌颂。礼拜供养七宝妙塔。无量众生得阿罗汉果。无量众生悟辟支佛。不可思议众生发菩提心至不退转。佛告诸比丘。未来世中。若有善男子善女人。闻妙法华经提婆达多品。净心信敬不生疑惑者。不堕地狱饿鬼畜生。生十方佛前。所生之处常闻此经。若生人天中受胜妙乐。若在佛前莲华化生。于时下方多宝世尊所从菩萨。名曰智积。白多宝佛。当还本土。释迦牟尼佛告智积曰。善男子。且待须臾。此有菩萨。名文殊师利。可与相见论说妙法可还本土。尔时文殊师利。坐千叶莲华大如车轮。俱来菩萨亦坐宝莲华。从于大海娑竭罗龙宫自然踊出。住虚空中诣灵鹫山。从莲华下至于佛所。头面敬礼二世尊足。修敬已毕。往智积所共相慰问。却坐一面。智积菩萨问文殊师利。仁往龙宫所化众生。其数几何。文殊师利言。其数无量不可称计。非口所宣非心所测。且待须臾。自当有证。所言未竟。无数菩萨坐宝莲华从海踊出。诣灵鹫山住在虚空。此诸菩萨皆是文殊师利之所化度。具菩萨行皆共论说六波罗蜜。本声闻人在虚空中说声闻行。今皆修行大乘空义。文殊师利谓智积曰。于海教化其事如是。尔时智积菩萨。以偈赞曰

  大智德勇健　　化度无量众
  今此诸大会　　及我皆已见
  演畅实相义　　开阐一乘法
  广导诸众生　　令速成菩提

文殊师利言。我于海中唯常宣说妙法华经。智积问文殊师利言。此经甚深微妙。诸经中宝世所希有。颇有众生勤加精进修行此经速得佛不。文殊师利言。有娑竭罗龙王女。年始八岁。智慧利根善知众生诸根行业。得陀罗尼。诸佛所说甚深秘藏悉能受持。深入禅定了达诸法。于刹那顷发菩提心。得不退转辩才无碍。慈念众生犹如赤子。功德具足心念口演。微妙广大慈悲仁让。志意和雅能至菩提。智积菩萨言。我见释迦如来。于无量劫难行苦行。积功累德求菩提道。未曾止息。观三千大千世界。乃至无有如芥子许非是菩萨舍身命处。为众生故。然后乃得成菩提道。不信此女于须臾顷便成正觉。言论未讫。时龙王女忽现于前。头面礼敬却住一面。以偈赞曰

  深达罪福相　　遍照于十方
  微妙净法身　　具相三十二
  以八十种好　　用庄严法身
  天人所戴仰　　龙神咸恭敬
  一切众生类　　无不宗奉者
  又闻成菩提　　唯佛当证知
  我阐大乘教　　度脱苦众生

时舍利弗语龙女言。汝谓不久得无上道。是事难信。所以者何。女身垢秽非是法器。云何能得无上菩提。佛道悬旷经无量劫。勤苦积行具修诸度。然后乃成。又女人身犹有五障。一者不得作梵天王。二者帝释。三者魔王。四者转轮圣王。五者佛身。云何女身速得成佛。尔时龙女有一宝珠。价直三千大千世界。持以上佛。佛即受之。龙女谓智积菩萨尊者舍利弗言。我献宝珠世尊纳受。是事疾不。答言甚疾。女言。以汝神力观我成佛。复速于此。当时众会皆见龙女。忽然之间变成男子。具菩萨行。即往南方无垢世界。坐宝莲华成等正觉。三十二相八十种好。普为十方一切众生演说妙法。尔时娑婆世界菩萨声闻天龙八部人与非人。皆遥见彼龙女成佛。普为时会人天说法。心大欢喜悉遥敬礼。无量众生闻法解悟得不退转。无量众生得受道记。无垢世界六反震动。娑婆世界三千众生住不退地。三千众生发菩提心而得受记。智积菩萨及舍利弗。一切众会默然信受

    妙法莲华经劝持品第十三

尔时药王菩萨摩诃萨。及大乐说菩萨摩诃萨。与二万菩萨眷属俱。皆于佛前作是誓言。唯愿世尊不以为虑。我等于佛灭后。当奉持读诵说此经典。后恶世众生。善根转少多增上慢。贪利供养增不善根。远离解脱虽难可教化。我等当起大忍力读诵此经。持说书写种种供养不惜身命。尔时众中五百阿罗汉得受记者白佛言。世尊。我等亦自誓愿。于异国土广说此经。复有学无学八千人得受记者。从座而起合掌向佛。作是誓言。世尊。我等亦当于他国土广说此经。所以者何。是娑婆国中人多弊恶。怀增上慢功德浅薄。嗔浊谄曲心不实故。尔时佛姨母摩诃波阇波提比丘尼。与学无学比丘尼六千人俱。从座而起一心合掌。瞻仰尊颜目不暂舍。于时世尊告憍昙弥。何故忧色而视如来。汝心将无谓我不说汝名授阿耨多罗三藐三菩提记耶。憍昙弥。我先总说一切声闻皆已授记。今汝欲知记者。将来之世当于六万八千亿诸佛法中为大法师。及六千学无学比丘尼俱为法师。汝如是渐渐具菩萨道。当得作佛。号一切众生喜见如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。憍昙弥。是一切众生喜见佛。及六千菩萨。转次授记得阿耨多罗三藐三菩提。尔时罗睺罗母耶输陀罗比丘尼作是念。世尊于授记中独不说我名。佛告耶输陀罗。汝于来世百千万亿诸佛法中。修菩萨行为大法师渐具佛道。于善国中当得作佛。号具足千万光相如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。佛寿无量阿僧祇劫。尔时摩诃波阇波提比丘尼。及耶输陀罗比丘尼。并其眷属。皆大欢喜得未曾有。即于佛前。而说偈言

  世尊导师　　安隐天人　　我等闻记
  心安具足

诸比丘尼说是偈已白佛言。世尊。我等亦能于他方国土广宣此经。尔时世尊。视八十万亿那由他诸菩萨摩诃萨。是诸菩萨。皆是阿惟越致。转不退法轮。得诸陀罗尼。即从座起至于佛前。一心合掌而作是念。若世尊告敕我等持说此经者。当如佛教广宣斯法。复作是念。佛今默然不见告敕。我当云何。时诸菩萨敬顺佛意。并欲自满本愿。便于佛前作师子吼。而发誓言。世尊。我等于如来灭后。周旋往返十方世界。能令众生书写此经受持读诵解说其义如法修行正忆念。皆是佛之威力。唯愿世尊。在于他方遥见守护。即时诸菩萨俱同发声。而说偈言

  唯愿不为虑　　于佛灭度后
  恐怖恶世中　　我等当广说
  有诸无智人　　恶口骂詈等
  及加刀杖者　　我等皆当忍
  恶世中比丘　　邪智心谄曲
  未得谓为得　　我慢心充满
  或有阿练若　　纳衣在空闲
  自谓行真道　　轻贱人间者
  贪着利养故　　与白衣说法
  为世所恭敬　　如六通罗汉
  是人怀恶心　　常念世俗事
  假名阿练若　　好出我等过
  而作如是言　　此诸比丘等
  为贪利养故　　说外道论议
  自作此经典　　诳惑世间人
  为求名闻故　　分别于是经
  常在大众中　　欲毁我等故
  向国王大臣　　婆罗门居士
  及余比丘众　　诽谤说我恶
  谓是邪见人　　说外道论议
  我等敬佛故　　悉忍是诸恶
  为斯所轻言　　汝等皆是佛
  如此轻慢言　　皆当忍受之
  浊劫恶世中　　多有诸恐怖
  恶鬼入其身　　骂詈毁辱我
  我等敬信佛　　当着忍辱铠
  为说是经故　　忍此诸难事
  我不爱身命　　但惜无上道
  我等于来世　　护持佛所嘱
  世尊自当知　　浊世恶比丘
  不知佛方便　　随宜所说法
  恶口而颦蹙　　数数见摈出
  远离于塔寺　　如是等众恶
  念佛告敕故　　皆当忍是事
  诸聚落城邑　　其有求法者
  我皆到其所　　说佛所嘱法
  我是世尊使　　处众无所畏
  我当善说法　　愿佛安隐住
  我于世尊前　　诸来十方佛
  发如是誓言　　佛自知我心

妙法莲华经卷第四妙法莲华经卷第五

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    安乐行品第十四

尔时文殊师利法王子菩萨摩诃萨白佛言。世尊。是诸菩萨甚为难有敬顺佛故发大誓愿。于后恶世护持读说是法华经。世尊。菩萨摩诃萨。于后恶世云何能说是经。佛告文殊师利。若菩萨摩诃萨。于后恶世。欲说是经。当安住四法。一者安住菩萨行处及亲近处。能为众生演说是经。文殊师利。云何名菩萨摩诃萨行处。若菩萨摩诃萨。住忍辱地柔和善顺而不卒暴心亦不惊。又复于法无所行。而观诸法如实相。亦不行不分别。是名菩萨摩诃萨行处。云何名菩萨摩诃萨亲近处。菩萨摩诃萨。不亲近国王王子大臣官长。不亲近诸外道梵志尼揵子等。及造世俗文笔赞咏外书。及路伽耶陀逆路伽耶陀者。亦不亲近诸有凶戏相叉相扑。及那罗等种种变现之戏。又不亲近旃陀罗及畜猪羊鸡狗畋猎渔捕诸恶律仪。如是人等或时来者。则为说法无所悕望。又不亲近求声闻比丘比丘尼优婆塞优婆夷。亦不问讯。若于房中。若经行处。若在讲堂中。不共住止。或时来者。随宜说法无所悕求。文殊师利。又菩萨摩诃萨。不应于女人身取能生欲想相而为说法。亦不乐见。若入他家。不与小女处女寡女等共语。亦复不近五种不男之人以为亲厚。不独入他家。若有因缘须独入时但一心念佛。若为女人说法不露齿笑。不现胸臆。乃至为法犹不亲厚。况复余事。不乐畜年少弟子沙弥小儿。亦不乐与同师。常好坐禅。在于闲处修摄其心。文殊师利。是名初亲近处

复次菩萨摩诃萨观一切法空。如实相。不颠倒不动不退不转。如虚空无所有性。一切语言道断。不生不出不起。无名无相实无所有。无量无边无碍无障。但以因缘有。从颠倒生故。说常乐观如是法相。是名菩萨摩诃萨第二亲近处。尔时世尊。欲重宣此义。而说偈言

  若有菩萨　　于后恶世　　无怖畏心
  欲说是经　　应入行处　　及亲近处
  常离国王　　及国王子　　大臣官长
  凶险戏者　　及旃陀罗　　外道梵志
  亦不亲近　　增上慢人　　贪着小乘
  三藏学者　　破戒比丘　　名字罗汉
  及比丘尼　　好戏笑者　　深着五欲
  求现灭度　　诸优婆夷　　皆勿亲近
  若是人等　　以好心来　　到菩萨所
  为闻佛道　　菩萨则以　　无所畏心
  不怀悕望　　而为说法　　寡女处女
  及诸不男　　皆勿亲近　　以为亲厚
  亦莫亲近　　屠儿魁脍　　畋猎渔捕
  为利杀害　　贩肉自活　　炫卖女色
  如是之人　　皆勿亲近　　凶险相扑
  种种嬉戏　　诸淫女等　　尽勿亲近
  莫独屏处　　为女说法　　若说法时
  无得戏笑　　入里乞食　　将一比丘
  若无比丘　　一心念佛　　是则名为
  行处近处　　以此二处　　能安乐说
  又复不行　　上中下法　　有为无为
  实不实法　　亦不分别　　是男是女
  不得诸法　　不知不见　　是则名为
  菩萨行处　　一切诸法　　空无所有
  无有常住　　亦无起灭　　是名智者
  所亲近处　　颠倒分别　　诸法有无
  是实非实　　是生非生　　在于闲处
  修摄其心　　安住不动　　如须弥山
  观一切法　　皆无所有　　犹如虚空
  无有坚固　　不生不出　　不动不退
  常住一相　　是名近处　　若有比丘
  于我灭后　　入是行处　　及亲近处
  说斯经时　　无有怯弱　　菩萨有时
  入于静室　　以正忆念　　随义观法
  从禅定起　　为诸国王　　王子臣民
  婆罗门等　　开化演畅　　说斯经典
  其心安隐　　无有怯弱　　文殊师利
  是名菩萨　　安住初法　　能于后世
  说法华经

又文殊师利。如来灭后。于末法中欲说是经。应住安乐行。若口宣说若读经时。不乐说人及经典过。亦不轻慢诸余法师。不说他人好恶长短。于声闻人亦不称名说其过恶。亦不称名赞叹其美。又亦不生怨嫌之心。善修如是安乐心故。诸有听者不逆其意。有所难问。不以小乘法答。但以大乘而为解说。令得一切种智。尔时世尊。欲重宣此义。而说偈言

  菩萨常乐　　安隐说法　　于清净地
  而施床座　　以油涂身　　澡浴尘秽
  着新净衣　　内外俱净　　安处法座
  随问为说　　若有比丘　　及比丘尼
  诸优婆塞　　及优婆夷　　国王王子
  群臣士民　　以微妙义　　和颜为说
  若有难问　　随义而答　　因缘譬喻
  敷演分别　　以是方便　　皆使发心
  渐渐增益　　入于佛道　　除懒惰意
  及懈怠想　　离诸忧恼　　慈心说法
  昼夜常说　　无上道教　　以诸因缘
  无量譬喻　　开示众生　　咸令欢喜
  衣服卧具　　饮食医药　　而于其中
  无所悕望　　但一心念　　说法因缘
  愿成佛道　　令众亦尔　　是则大利
  安乐供养　　我灭度后　　若有比丘
  能演说斯　　妙法华经　　心无嫉恚
  诸恼障碍　　亦无忧愁　　及骂詈者
  又无怖畏　　加刀杖等　　亦无摈出
  安住忍故　　智者如是　　善修其心
  能住安乐　　如我上说　　其人功德
  千万亿劫　　算数譬喻　　说不能尽

又文殊师利。菩萨摩诃萨。于后末世法欲灭时。受持读诵斯经典者。无怀嫉妒謟诳之心。亦勿轻骂学佛道者求其长短。若比丘比丘尼优婆塞优婆夷。求声闻者。求辟支佛者。求菩萨道者。无得恼之令其疑悔。语其人言汝等去道甚远。终不能得一切种智。所以者何。汝是放逸之人。于道懈怠故。又亦不应戏论诸法有所诤竞。当于一切众生起大悲想。于诸如来起慈父想。于诸菩萨起大师想。于十方诸大菩萨。常应深心恭敬礼拜。于一切众生平等说法。以顺法故不多不少。乃至深爱法者。亦不为多说

文殊师利。是菩萨摩诃萨。于后末世法欲灭时。有成就是第三安乐行者。说是法时无能恼乱。得好同学共读诵是经。亦得大众而来听受。听已能持。持已能诵。诵已能说。说已能书。若使人书。供养经卷恭敬尊重赞叹。尔时世尊。欲重宣此义。而说偈言

  若欲说是经　　当舍嫉恚慢
  謟诳邪伪心　　常修质直行
  不轻蔑于人　　亦不戏论法
  不令他疑悔　　云汝不得佛
  是佛子说法　　常柔和能忍
  慈悲于一切　　不生懈怠心
  十方大菩萨　　愍众故行道
  应生恭敬心　　是则我大师
  于诸佛世尊　　生无上父想
  破于憍慢心　　说法无障碍
  第三法如是　　智者应守护
  一心安乐行　　无量众所敬

又文殊师利。菩萨摩诃萨。于后末世法欲灭时。有持是法华经者于在家出家人中生大慈心。于非菩萨人中生大悲心。应作是念。如是之人则为大失。如来方便随宜说法。不闻不知不觉不问不信不解。其人虽不问不信不解是经。我得阿耨多罗三藐三菩提时。随在何地。以神通力智慧力。引之令得住是法中。文殊师利。是菩萨摩诃萨。于如来灭后。有成就此第四法者。说是法时无有过失。常为比丘比丘尼优婆塞优婆夷。国王王子大臣人民婆罗门居士等。供养恭敬尊重赞叹。虚空诸天为听法故亦常随侍。若在聚落城邑空闲林中。有人来欲难问者。诸天昼夜。常为法故而卫护之。能令听者皆得欢喜。所以者何。此经是一切过去未来现在诸佛神力所护故。文殊师利。是法华经。于无量国中。乃至名字不可得闻。何况得见受持读诵

文殊师利。譬如强力转轮圣王。欲以威势降伏诸国。而诸小王不顺其命。时转轮王。起种种兵而往讨罚。王见兵众战有功者。即大欢喜随功赏赐。或与田宅聚落城邑。或与衣服严身之具。或与种种珍宝金银琉璃车磲马脑珊瑚虎珀象马车乘奴婢人民。唯髻中明珠不以与之。所以者何。独王顶上有此一珠。若以与之。王诸眷属必大惊怪。文殊师利。如来亦复如是。以禅定智慧力得法国土王于三界。而诸魔王不肯顺伏。如来贤圣诸将与之共战。其有功者心亦欢喜。于四众中为说诸经令其心悦。赐以禅定解脱无漏根力诸法之财。又复赐与涅槃之城言得灭度。引导其心令皆欢喜。而不为说是法华经。文殊师利。如转轮王见诸兵众有大功者心甚欢喜。以此难信之珠久在髻中。不妄与人。而今与之。如来亦复如是。于三界中为大法王。以法教化一切众生。见贤圣军与五阴魔烦恼魔死魔共战有大功勋。灭三毒出三界破魔网。尔时如来亦大欢喜。此法华经。能令众生至一切智。一切世间多怨难信。先所未说而今说之。文殊师利。此法华经。是诸如来第一之说。于诸说中最为甚深。末后赐与。如彼强力之王。久护明珠今乃与之。文殊师利。此法华经。诸佛如来秘密之藏。于诸经中最在其上。长夜守护不妄宣说。始于今日。乃与汝等而敷演之。尔时世尊。欲重宣此义。而说偈言

  常行忍辱　　哀愍一切　　乃能演说
  佛所赞经　　后末世时　　持此经者
  于家出家　　及非菩萨　　应生慈悲
  斯等不闻　　不信是经　　则为大失
  我得佛道　　以诸方便　　为说此法
  令住其中　　譬如强力　　转轮之王
  兵战有功　　赏赐诸物　　象马车乘
  严身之具　　及诸田宅　　聚落城邑
  或与衣服　　种种珍宝　　奴婢财物
  欢喜赐与　　如有勇健　　能为难事
  三解髻中　　明珠赐之　　如来亦尔
  为诸法王　　忍辱大力　　智慧宝藏
  以大慈悲　　如法化世　　见一切人
  受诸苦恼　　欲求解脱　　与诸魔战
  为是众生　　说种种法　　以大方便
  说此诸经　　既知众生　　得其力已
  末后乃为　　说是法华　　如三解髻
  明珠与之　　此经为尊　　众经中上
  我常守护　　不妄开示　　今正是时
  为汝等说　　我灭度后　　求佛道者
  欲得安隐　　演说斯经　　应当亲近
  如是四法　　读是经者　　常无忧恼
  又无病痛　　颜色鲜白　　不生贫穷
  卑贱丑陋　　众生乐见　　如慕贤圣
  天诸童子　　以为给使　　刀杖不加
  毒不能害　　若人恶骂　　口则闭塞
  游行无畏　　如师子王　　智慧光明
  如日之照　　若于梦中　　但见妙事
  见诸如来　　坐师子座　　诸比丘众
  围绕说法　　又见龙神　　阿修罗等
  数如恒沙　　恭敬合掌　　自见其身
  而为说法　　又见诸佛　　身相金色
  放无量光　　照于一切　　以梵音声
  演说诸法　　佛为四众　　说无上法
  见身处中　　合掌赞佛　　闻法欢喜
  而为供养　　得陀罗尼　　证不退智
  佛知其心　　深入佛道　　即为授记
  成最正觉　　汝善男子　　当于来世
  得无量智　　佛之大道　　国土严净
  广大无比　　亦有四众　　合掌听法
  又见自身　　在山林中　　修习善法
  证诸实相　　深入禅定　　见十方佛
  诸佛身金色　　百福相庄严
  闻法为人说　　常有是好梦
  又梦作国王　　舍宫殿眷属
  及上妙五欲　　行诣于道场
  在菩提树下　　而处师子座
  求道过七日　　得诸佛之智
  成无上道已　　起而转法轮
  为四众说法　　经千万亿劫
  说无漏妙法　　度无量众生
  后当入涅槃　　如烟尽灯灭
  若后恶世中　　说是第一法
  是人得大利　　如上诸功德

    妙法莲华经从地踊出品第十五

尔时他方国土诸来菩萨摩诃萨。过八恒河沙数。于大众中起立合掌作礼。而白佛言。世尊。若听我等于佛灭后在此娑婆世界勤加精进护持读诵书写供养是经典者。当于此土而广说之。尔时佛告诸菩萨摩诃萨众。止善男子。不须汝等护持此经。所以者何。我娑婆世界。自有六万恒河沙等菩萨摩诃萨。一一菩萨各有六万恒河沙眷属。是诸人等能于我灭后。护持读诵广说此经。佛说是时。娑婆世界三千大千国土地皆震裂。而于其中有无量千万亿菩萨摩诃萨同时踊出。是诸菩萨身皆金色。三十二相无量光明。先尽在此娑婆世界之下。此界虚空中住。是诸菩萨闻释迦牟尼佛所说音声从下发来。一一菩萨。皆是大众唱导之首。各将六万恒河沙眷属。况将五万四万三万二万一万恒河沙等眷属者。况复乃至一恒河沙半恒河沙四分之一。乃至千万亿那由他分之一。况复千万亿那由他眷属。况复亿万眷属。况复千万百万乃至一万。况复一千一百乃至一十。况复将五四三二一弟子者。况复单己乐远离行。如是等比。无量无边算数譬喻所不能知。是诸菩萨从地出已。各诣虚空七宝妙塔多宝如来释迦牟尼佛所。到已向二世尊头面礼足。及至诸宝树下师子座上佛所。亦皆作礼右绕三匝合掌恭敬。以诸菩萨种种赞法。而以赞叹住在一面。欣乐瞻仰于二世尊。是诸菩萨摩诃萨从初踊出。以诸菩萨种种赞法而赞于佛。如是时间经五十小劫。是时释迦牟尼佛默然而坐。及诸四众亦皆默然。五十小劫。佛神力故。令诸大众谓如半日。尔时四众亦以佛神力故。见诸菩萨遍满无量百千万亿国土虚空。是菩萨众中有四导师。一名上行。二名无边行。三名净行。四名安立行。是四菩萨于其众中。最为上首唱导之师。在大众前各共合掌。观释迦牟尼佛。而问讯言。世尊。少病少恼安乐行不。所应度者受教易不。不令世尊生疲劳耶。尔时四大菩萨。而说偈言

  世尊安乐　　少病少恼　　教化众生
  得无疲惓　　又诸众生　　受化易不
  不令世尊　　生疲劳耶

尔时世尊于菩萨大众中。而作是言。如是如是。诸善男子。如来安乐少病少恼。诸众生等易可化度。无有疲劳。所以者何。是诸众生。世世已来常受我化。亦于过去诸佛。供养尊重种诸善根。此诸众生。始见我身闻我所说。即皆信受入如来慧。除先修习学小乘者。如是之人。我今亦令得闻是经入于佛慧。尔时诸大菩萨。而说偈言

  善哉善哉　　大雄世尊　　诸众生等
  易可化度　　能问诸佛　　甚深智慧
  闻已信行　　我等随喜

于时世尊。赞叹上首诸大菩萨。善哉善哉善男子。汝等能于如来发随喜心。尔时弥勒菩萨。及八千恒河沙诸菩萨众。皆作是念。我等从昔已来。不见不闻如是大菩萨摩诃萨众。从地踊出住世尊前。合掌供养问讯如来。时弥勒菩萨摩诃萨。知八千恒河沙诸菩萨等心之所念。并欲自决所疑。合掌向佛。以偈问曰

  无量千万亿　　大众诸菩萨
  昔所未曾见　　愿两足尊说
  是从何所来　　以何因缘集
  巨身大神通　　智慧叵思议
  其志念坚固　　有大忍辱力
  众生所乐见　　为从何所来
  一一诸菩萨　　所将诸眷属
  其数无有量　　如恒河沙等
  或有大菩萨　　将六万恒沙
  如是诸大众　　一心求佛道
  是诸大师等　　六万恒河沙
  俱来供养佛　　及护持是经
  将五万恒沙　　其数过于是
  四万及三万　　二万至一万
  一千一百等　　乃至一恒沙
  半及三四分　　亿万分之一
  千万那由他　　万亿诸弟子
  乃至于半亿　　其数复过上
  百万至一万　　一千及一百
  五十与一十　　乃至三二一
  单己无眷属　　乐于独处者
  俱来至佛所　　其数转过上
  如是诸大众　　若人行筹数
  过于恒沙劫　　犹不能尽知
  是诸大威德　　精进菩萨众
  谁为其说法　　教化而成就
  从谁初发心　　称扬何佛法
  受持行谁经　　修习何佛道
  如是诸菩萨　　神通大智力
  四方地震裂　　皆从中踊出
  世尊我昔来　　未曾见是事
  愿说其所从　　国土之名号
  我常游诸国　　未曾见是众
  我于此众中　　乃不识一人
  忽然从地出　　愿说其因缘
  今此之大会　　无量百千亿
  是诸菩萨等　　皆欲知此事
  是诸菩萨众　　本末之因缘
  无量德世尊　　唯愿决众疑

尔时释迦牟尼分身诸佛。从无量千万亿他方国土来者。在于八方诸宝树下师子座上结加趺坐。其佛侍者。各各见是菩萨大众。于三千大千世界四方从地踊出住于虚空。各白其佛言。世尊。此诸无量无边阿僧祇菩萨大众。从何所来。尔时诸佛各告侍者。诸善男子。且待须臾。有菩萨摩诃萨。名曰弥勒。释迦牟尼佛之所授记。次后作佛。以问斯事。佛今答之。汝等自当因是得闻

尔时释迦牟尼佛。告弥勒菩萨。善哉善哉阿逸多。乃能问佛如是大事。汝等当共一心。被精进铠发坚固意。如来今欲显发宣示诸佛智慧。诸佛自在神通之力。诸佛师子奋迅之力。诸佛威猛大势之力。尔时世尊。欲重宣此义。而说偈言

  当精进一心　　我欲说此事
  勿得有疑悔　　佛智叵思议
  汝今出信力　　住于忍善中
  昔所未闻法　　今皆当得闻
  我今安慰汝　　勿得怀疑惧
  佛无不实语　　智慧不可量
  所得第一法　　甚深叵分别
  如是今当说　　汝等一心听

尔时世尊说此偈已。告弥勒菩萨。我今于此大众。宣告汝等。阿逸多。是诸大菩萨摩诃萨。无量无数阿僧祇从地踊出。汝等昔所未见者。我于是娑婆世界。得阿耨多罗三藐三菩提已。教化示导是诸菩萨。调伏其心令发道意。此诸菩萨皆于是娑婆世界之下此界虚空中住。于诸经典读诵通利思惟分别正忆念。阿逸多。是诸善男子等。不乐在众多有所说。常乐静处勤行精进未曾休息。亦不依止人天而住。常乐深智无有障碍。亦常乐于诸佛之法。一心精进求无上慧。尔时世尊欲重宣此义。而说偈言

  阿逸汝当知　　是诸大菩萨
  从无数劫来　　修习佛智慧
  悉是我所化　　令发大道心
  此等是我子　　依止是世界
  常行头陀事　　志乐于静处
  舍大众愦闹　　不乐多所说
  如是诸子等　　学习我道法
  昼夜常精进　　为求佛道故
  在娑婆世界　　下方空中住
  志念力坚固　　常勤求智慧
  说种种妙法　　其心无所畏
  我于伽耶城　　菩提树下坐
  得成最正觉　　转无上法轮
  尔乃教化之　　令初发道心
  今皆住不退　　悉当得成佛
  我今说实语　　汝等一心信
  我从久远来　　教化是等众

尔时弥勒菩萨摩诃萨。及无数诸菩萨等。心生疑惑怪未曾有。而作是念。云何世尊于少时间。教化如是无量无边阿僧祇诸大菩萨。令住阿耨多罗三藐三菩提。即白佛言。世尊。如来为太子时出于释宫。去伽耶城不远坐于道场。得成阿耨多罗三藐三菩提。从是已来始过四十余年。世尊。云何于此少时大作佛事。以佛势力以佛功德。教化如是无量大菩萨众当成阿耨多罗三藐三菩提。世尊。此大菩萨众。假使有人。于千万亿劫。数不能尽不得其边。斯等久远已来。于无量无边诸佛所殖诸善根。成就菩萨道常修梵行。世尊。如此之事世所难信。譬如有人。色美发黑年二十五。指百岁人言是我子。其百岁人。亦指年少言是我父生育我等。是事难信。佛亦如是。得道已来其实未久。而此大众诸菩萨等。已于无量千万亿劫。为佛道故勤行精进。善入出住无量百千万亿三昧。得大神通久修梵行。善能次第习诸善法。巧于问答人中之宝。一切世间甚为希有。今日世尊方云得佛道时初令发心教化示导。令向阿耨多罗三藐三菩提。世尊得佛未久。乃能作此大功德事。我等虽复信佛随宜所说。佛所出言未曾虚妄。佛所知者皆悉通达。然诸新发意菩萨。于佛灭后。若闻是语或不信受。而起破法罪业因缘。唯然世尊。愿为解说除我等疑。及未来世诸善男子。闻此事已亦不生疑。尔时弥勒菩萨欲重宣此义。而说偈言

  佛昔从释种　　出家近伽耶
  坐于菩提树　　尔来尚未久
  此诸佛子等　　其数不可量
  久已行佛道　　住于神通力
  善学菩萨道　　不染世间法
  如莲华在水　　从地而踊出
  皆起恭敬心　　住于世尊前
  是事难思议　　云何而可信
  佛得道甚近　　所成就甚多
  愿为除众疑　　如实分别说
  譬如少壮人　　年始二十五
  示人百岁子　　发白而面皱
  是等我所生　　子亦说是父
  父少而子老　　举世所不信
  世尊亦如是　　得道来甚近
  是诸菩萨等　　志固无怯弱
  从无量劫来　　而行菩萨道
  巧于难问答　　其心无所畏
  忍辱心决定　　端正有威德
  十方佛所赞　　善能分别说
  不乐在人众　　常好在禅定
  为求佛道故　　于下空中住
  我等从佛闻　　于此事无疑
  愿佛为未来　　演说令开解
  若有于此经　　生疑不信者
  即当堕恶道　　愿今为解说
  是无量菩萨　　云何于少时
  教化令发心　　而住不退地

    妙法莲华经如来寿量品第十六

尔时佛告诸菩萨及一切大众诸善男子。汝等当信解如来诚谛之语。复告大众。汝等当信解如来诚谛之语。又复告诸大众。汝等当信解如来诚谛之语。是时菩萨大众。弥勒为首合掌白佛言。世尊。唯愿说之。我等当信受佛语。如是三白已。复言唯愿说之。我等当信受佛语。尔时世尊。知诸菩萨三请不止。而告之言。汝等谛听。如来秘密神通之力。一切世间天人及阿修罗。皆谓今释迦牟尼佛出释氏宫。去伽耶城不远坐于道场。得阿耨多罗三藐三菩提。然善男子。我实成佛已来。无量无边百千万亿那由他劫。譬如五百千万亿那由他阿僧祇三千大千世界。假使有人末为微尘。过于东方五百千万亿那由他阿僧祇国。乃下一尘。如是东行尽是微尘。诸善男子。于意云何。是诸世界。可得思惟校计知其数不。弥勒菩萨等俱白佛言。世尊。是诸世界无量无边非算数所知。亦非心力所及。一切声闻辟支佛。以无漏智。不能思惟知其限数。我等住阿惟越致地。于是事中亦所不达。世尊。如是诸世界无量无边。尔时佛告大菩萨众。诸善男子。今当分明宣语汝等。是诸世界。若着微尘及不著者。尽以为尘一尘一劫。我成佛已来。复过于此百千万亿那由他阿僧祇劫。自从是来。我常在此娑婆世界说法教化。亦于余处百千万亿那由他阿僧祇国导利众生。诸善男子。于是中间。我说燃灯佛等。又复言其入于涅槃。如是皆以方便分别。诸善男子。若有众生来至我所。我以佛眼。观其信等诸根利钝。随所应度。处处自说名字不同年纪大小。亦复现言当入涅槃。又以种种方便说微妙法。能令众生发欢喜心。诸善男子。如来。见诸众生乐于小法德薄垢重者。为是人说。我少出家得阿耨多罗三藐三菩提。然我实成佛已来久远若斯。但以方便教化众生。令入佛道作如是说。诸善男子。如来所演经典。皆为度脱众生。或说己身或说他身。或示己身或示他身。或示己事或示他事。诸所言说皆实不虚。所以者何。如来。如实知见三界之相。无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。不如三界见于三界。如斯之事。如来明见无有错谬。以诸众生有种种性种种欲种种行种种忆想分别故。欲令生诸善根。以若干因缘譬喻言辞种种说法。所作佛事未曾暂废。如是我成佛已来甚大久远。寿命无量阿僧祇劫常住不灭

诸善男子。我本行菩萨道所成寿命。今犹未尽复倍上数。然今非实灭度。而便唱言当取灭度。如来以是方便教化众生。所以者何。若佛久住于世。薄德之人不种善根。贫穷下贱贪着五欲。入于忆想妄见网中。若见如来常在不灭。便起憍恣而怀厌怠。不能生难遭之想恭敬之心。是故如来以方便说。比丘当知。诸佛出世难可值遇。所以者何。诸薄德人。过无量百千万亿劫。或有见佛或不见者。以此事故我作是言。诸比丘。如来难可得见。斯众生等闻如是语。必当生于难遭之想。心怀恋慕渴仰于佛。便种善根。是故如来。虽不实灭而言灭度

又善男子。诸佛如来法皆如是。为度众生皆实不虚。譬如良医智慧聪达。明练方药善治众病。其人多诸子息。若十二十乃至百数。以有事缘远至余国。诸子于后饮他毒药。药发闷乱宛转于地。是时其父还来归家。诸子饮毒。或失本心或不失者。遥见其父皆大欢喜。拜跪问讯善安隐归。我等愚痴误服毒药。愿见救疗更赐寿命。父见子等苦恼如是。依诸经方。求好药草色香美味皆悉具足。捣筛和合与子令服。而作是言。此大良药。色香美味皆悉具足。汝等可服。速除苦恼无复众患。其诸子中不失心者。见此良药色香俱好。即便服之病尽除愈。余失心者。见其父来。虽亦欢喜问讯求索治病。然与其药而不肯服。所以者何。毒气深入失本心故。于此好色香药而谓不美。父作是念。此子可愍。为毒所中心皆颠倒。虽见我喜求索救疗。如是好药而不肯服。我今当设方便令服此药。即作是言。汝等当知。我今衰老死时已至。是好良药今留在此。汝可取服勿忧不差。作是教已复至他国。遣使还告。汝父已死。是时诸子闻父背丧。心大忧恼而作是念。若父在者。慈愍我等能见救护。今者舍我远丧他国。自惟孤露无复恃怙。常怀悲感心遂醒悟。乃知此药色味香美。即取服之毒病皆愈。其父闻子悉已得差。寻便来归咸使见之

诸善男子。于意云何。颇有人能说此良医虚妄罪不。不也世尊。佛言。我亦如是。成佛已来。无量无边百千万亿那由他阿僧祇劫。为众生故。以方便力言当灭度。亦无有能如法说我虚妄过者。尔时世尊欲重宣此义。而说偈言

  自我得佛来　　所经诸劫数
  无量百千万　　亿载阿僧祇
  常说法教化　　无数亿众生
  令入于佛道　　尔来无量劫
  为度众生故　　方便现涅槃
  而实不灭度　　常住此说法
  我常住于此　　以诸神通力
  令颠倒众生　　虽近而不见
  众见我灭度　　广供养舍利
  咸皆怀恋慕　　而生渴仰心
  众生既信伏　　质直意柔软
  一心欲见佛　　不自惜身命
  时我及众僧　　俱出灵鹫山
  我时语众生　　常在此不灭
  以方便力故　　现有灭不灭
  余国有众生　　恭敬信乐者
  我复于彼中　　为说无上法
  汝等不闻此　　但谓我灭度
  我见诸众生　　没在于苦恼
  故不为现身　　令其生渴仰
  因其心恋慕　　乃出为说法
  神通力如是　　于阿僧祇劫
  常在灵鹫山　　及余诸住处
  众生见劫尽　　大火所烧时
  我此土安隐　　天人常充满
  园林诸堂阁　　种种宝庄严
  宝树多花果　　众生所游乐
  诸天击天鼓　　常作众伎乐
  雨曼陀罗花　　散佛及大众
  我净土不毁　　而众见烧尽
  忧怖诸苦恼　　如是悉充满
  是诸罪众生　　以恶业因缘
  过阿僧祇劫　　不闻三宝名
  诸有修功德　　柔和质直者
  则皆见我身　　在此而说法
  或时为此众　　说佛寿无量
  久乃见佛者　　为说佛难值
  我智力如是　　慧光照无量
  寿命无数劫　　久修业所得
  汝等有智者　　勿于此生疑
  当断令永尽　　佛语实不虚
  如医善方便　　为治狂子故
  实在而言死　　无能说虚妄
  我亦为世父　　救诸苦患者
  为凡夫颠倒　　实在而言灭
  以常见我故　　而生憍恣心
  放逸着五欲　　堕于恶道中
  我常知众生　　行道不行道
  随所应可度　　为说种种法
  每自作是意　　以何令众生
  得入无上慧　　速成就佛身

    妙法莲华经分别功德品第十七

尔时大会闻佛说寿命劫数长远如是无量无边阿僧祇众生得大饶益。于时世尊。告弥勒菩萨摩诃萨。阿逸多。我说是如来寿命长远时。六百八十万亿那由他恒河沙众生。得无生法忍。复有千倍菩萨摩诃萨。得闻持陀罗尼门。复有一世界微尘数菩萨摩诃萨。得乐说无碍辩才。复有一世界微尘数菩萨摩诃萨。得百千万亿无量旋陀罗尼。复有三千大千世界微尘数菩萨摩诃萨。能转不退法轮。复有二千中国土微尘数菩萨摩诃萨。能转清净法轮。复有小千国土微尘数菩萨摩诃萨。八生当得阿耨多罗三藐三菩提。复有四四天下微尘数菩萨摩诃萨。四生当得阿耨多罗三藐三菩提。复有三四天下微尘数菩萨摩诃萨。三生当得阿耨多罗三藐三菩提。复有二四天下微尘数菩萨摩诃萨。二生当得阿耨多罗三藐三菩提。复有一四天下微尘数菩萨摩诃萨。一生当得阿耨多罗三藐三菩提。复有八世界微尘数众生。皆发阿耨多罗三藐三菩提心。佛说是诸菩萨摩诃萨得大法利时。于虚空中。雨曼陀罗华摩诃曼陀罗华。以散无量百千万亿众宝树下师子座上诸佛。并散七宝塔中师子座上释迦牟尼佛及久灭度多宝如来。亦散一切诸大菩萨及四部众。又雨细末栴檀沉水香等。于虚空中。天鼓自鸣妙声深远。又雨千种天衣。垂诸璎珞真珠璎珞摩尼珠璎珞如意珠璎珞。遍于九方众宝香炉烧无价香。自然周至供养大会。一一佛上。有诸菩萨执持幡盖。次第而上至于梵天。是诸菩萨以妙音声歌无量颂赞叹诸佛。尔时弥勒菩萨从座而起。偏袒右肩合掌向佛。而说偈言

  佛说希有法　　昔所未曾闻
  世尊有大力　　寿命不可量
  无数诸佛子　　闻世尊分别
  说得法利者　　欢喜充遍身
  或住不退地　　或得陀罗尼
  或无碍乐说　　万亿旋总持
  或有大千界　　微尘数菩萨
  各各皆能转　　不退之法轮
  复有中千界　　微尘数菩萨
  各各皆能转　　清净之法轮
  复有小千界　　微尘数菩萨
  余各八生在　　当得成佛道
  复有四三二　　如此四天下
  微尘诸菩萨　　随数生成佛
  或一四天下　　微尘数菩萨
  余有一生在　　当成一切智
  如是等众生　　闻佛寿长远
  得无量无漏　　清净之果报
  复有八世界　　微尘数众生
  闻佛说寿命　　皆发无上心
  世尊说无量　　不可思议法
  多有所饶益　　如虚空无边
  雨天曼陀罗　　摩诃曼陀罗
  释梵如恒沙　　无数佛土来
  雨栴檀沉水　　缤纷而乱坠
  如鸟飞空下　　供散于诸佛
  天鼓虚空中　　自然出妙声
  天衣千万种　　旋转而来下
  众宝妙香炉　　烧无价之香
  自然悉周遍　　供养诸世尊
  其大菩萨众　　执七宝幡盖
  高妙万亿种　　次第至梵天
  一一诸佛前　　宝幢悬胜幡
  亦以千万偈　　歌咏诸如来
  如是种种事　　昔所未曾有
  闻佛寿无量　　一切皆欢喜
  佛名闻十方　　广饶益众生
  一切具善根　　以助无上心

尔时佛告弥勒菩萨摩诃萨。阿逸多。其有众生。闻佛寿命长远如是。乃至能生一念信解。所得功德无有限量。若有善男子善女人。为阿耨多罗三藐三菩提故。于八十万亿那由他劫。行五波罗蜜。檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。除般若波罗蜜。以是功德比前功德。百分千分百千万亿分不及其一。乃至算数譬喻所不能知。若善男子善女人。有如是功德。于阿耨多罗三藐三菩提退者。无有是处。尔时世尊欲重宣此义。而说偈言

  若人求佛慧　　于八十万亿
  那由他劫数　　行五波罗蜜
  于是诸劫中　　布施供养佛
  及缘觉弟子　　并诸菩萨众
  珍异之饮食　　上服与卧具
  栴檀立精舍　　以园林庄严
  如是等布施　　种种皆微妙
  尽此诸劫数　　以回向佛道
  若复持禁戒　　清净无缺漏
  求于无上道　　诸佛之所叹
  若复行忍辱　　住于调柔地
  设众恶来加　　其心不倾动
  诸有得法者　　怀于增上慢
  为此所轻恼　　如是亦能忍
  若复勤精进　　志念常坚固
  于无量亿劫　　一心不懈息
  又于无数劫　　住于空闲处
  若坐若经行　　除睡常摄心
  以是因缘故　　能生诸禅定
  八十亿万劫　　安住心不乱
  持此一心福　　愿求无上道
  我得一切智　　尽诸禅定际
  是人于百千　　万亿劫数中
  行此诸功德　　如上之所说
  有善男女等　　闻我说寿命
  乃至一念信　　其福过于彼
  若人悉无有　　一切诸疑悔
  深心须臾信　　其福为如此
  其有诸菩萨　　无量劫行道
  闻我说寿命　　是则能信受
  如是诸人等　　顶受此经典
  愿我于未来　　长寿度众生
  如今日世尊　　诸释中之王
  道场师子吼　　说法无所畏
  我等未来世　　一切所尊敬
  坐于道场时　　说寿亦如是
  若有深心者　　清净而质直
  多闻能总持　　随义解佛语
  如是诸人等　　于此无有疑

又阿逸多。若有闻佛寿命长远解其言趣。是人所得功德无有限量。能起如来无上之慧。何况广闻是经。若教人闻。若自持若教人持。若自书若教人书。若以华香璎珞幢幡缯盖香油酥灯供养经卷。是人功德无量无边。能生一切种智。阿逸多。若善男子善女人。闻我说寿命长远深心信解。则为见佛常在耆阇崛山。共大菩萨诸声闻众围绕说法。又见此娑婆世界。其地琉璃坦然平正。阎浮檀金以界八道宝树行列。诸台楼观皆悉宝成。其菩萨众咸处其中。若有能如是观者。当知是为深信解相。又复如来灭后若闻是经。而不毁呰起随喜心。当知已为深信解相。何况读诵受持之者。斯人则为顶戴如来。阿逸多。是善男子善女人。不须为我复起塔寺及作僧坊以四事供养众僧。所以者何。是善男子善女人。受持读诵是经典者。为已起塔造立僧坊供养众僧。则为以佛舍利起七宝塔高广渐小至于梵天。悬诸幡盖及众宝铃。华香璎珞末香涂香烧香。众鼓伎乐箫笛箜篌种种舞戏。以妙音声歌呗赞颂。则为于无量千万亿劫作是供养已

阿逸多。若我灭后闻是经典。有能受持若自书若教人书。则为起立僧坊。以赤栴檀作诸殿堂三十有二。高八多罗树高广严好。百千比丘于其中止。园林浴池经行禅窟。衣服饮食床褥汤药。一切乐具充满其中。如是僧坊堂阁若干。百千万亿其数无量。以此现前供养于我及比丘僧。是故我说如来灭后。若有受持读诵为他人说。若自书若教人书供养经卷。不须复起塔寺及造僧坊供养众僧。况复有人能持是经。兼行布施持戒忍辱精进一心智慧。其德最胜无量无边。譬如虚空东西南北四维上下无量无边。是人功德亦复如是无量无边。疾至一切种智。若人读诵受持是经为他人说。若自书若教人书。复能起塔及造僧坊。供养赞叹声闻众僧。亦以百千万亿赞叹之法。赞叹菩萨功德。又为他人种种因缘随义解说此法华经。复能清净持戒与柔和者而共同止。忍辱无嗔志念坚固。常贵坐禅得诸深定。精进勇猛摄诸善法。利根智慧善答问难

阿逸多。若我灭后。诸善男子善女人。受持读诵是经典者。复有如是诸善功德。当知是人已趣道场。近阿耨多罗三藐三菩提坐道树下。阿逸多。是善男子善女人。若坐若立若行处此中便应起塔。一切天人皆应供养如佛之塔。尔时世尊欲重宣此义。而说偈言

  若我灭度后　　能奉持此经
  斯人福无量　　如上之所说
  是则为具足　　一切诸供养
  以舍利起塔　　七宝而庄严
  表刹甚高广　　渐小至梵天
  宝铃千万亿　　风动出妙音
  又于无量劫　　而供养此塔
  华香诸璎珞　　天衣众伎乐
  燃香油酥灯　　周匝常照明
  恶世法末时　　能持是经者
  则为已如上　　具足诸供养
  若能持此经　　则如佛现在
  以牛头栴檀　　起僧坊供养
  堂有三十二　　高八多罗树
  上馔妙衣服　　床卧皆具足
  百千众住处　　园林诸浴池
  经行及禅窟　　种种皆严好
  若有信解心　　受持读诵书
  若复教人书　　及供养经卷
  散华香末香　　以须曼瞻卜
  阿提目多伽　　薰油常燃之
  如是供养者　　得无量功德
  如虚空无边　　其福亦如是
  况复持此经　　兼布施持戒
  忍辱乐禅定　　不嗔不恶口
  恭敬于塔庙　　谦下诸比丘
  远离自高心　　常思惟智慧
  有问难不嗔　　随顺为解说
  若能行是行　　功德不可量
  若见此法师　　成就如是德
  应以天华散　　天衣覆其身
  头面接足礼　　生心如佛想
  又应作是念　　不久诣道树
  得无漏无为　　广利诸人天
  其所住止处　　经行若坐卧
  乃至说一偈　　是中应起塔
  庄严令妙好　　种种以供养
  佛子住此地　　则是佛受用
  常在于其中　　经行及坐卧

妙法莲华经卷第五妙法莲华经卷第六

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    随喜功德品第十八

尔时弥勒菩萨摩诃萨白佛言。世尊。若有善男子善女人。闻是法华经随喜者。得几所福。而说偈言

  世尊灭度后　　其有闻是经
  若能随喜者　　为得几所福

尔时佛告弥勒菩萨摩诃萨。阿逸多。如来灭后。若比丘比丘尼优婆塞优婆夷。及余智者若长若幼。闻是经随喜已。从法会出至于余处。若在僧坊若空闲地。若城邑巷陌聚落田里。如其所闻。为父母宗亲善友知识随力演说。是诸人等闻已随喜复行转教。余人闻已亦随喜转教。如是展转至第五十。阿逸多。其第五十善男子善女人随喜功德。我今说之。汝当善听。若四百万亿阿僧祇世界六趣四生众生卵生胎生湿生化生。若有形无形。有想无想。非有想非无想。无足二足四足多足。如是等在众生数者。有人求福。随其所欲娱乐之具皆给与之。一一众生与满阎浮提金银琉璃车磲马脑珊瑚虎珀诸妙珍宝及象马车乘七宝所成宫殿楼阁等是大施主。如是布施满八十年已。而作是念。我已施众生娱乐之具。随意所欲。然此众生皆已衰老年过八十。发白面皱将死不久。我当以佛法而训导之。即集此众生。宣布法化示教利喜。一时皆得须陀洹道斯陀含道阿那含道阿罗汉道。尽诸有漏于深禅定皆得自在具八解脱。于汝意云何。是大施主所得功德宁为多不。弥勒白佛言。世尊。是人功德甚多无量无边。若是施主。但施众生一切乐具功德无量。何况令得阿罗汉果。佛告弥勒。我今分明语汝。是人以一切乐具。施于四百万亿阿僧祇世界六趣众生。又令得阿罗汉果。所得功德。不如是第五十人。闻法华经一偈随喜功德。百分千分百千万亿分不及其一。乃至算数譬喻所不能知。阿逸多。如是第五十人展转闻法华经随喜功德。尚无量无边阿僧祇。何况最初于会中闻而随喜者。其福复胜无量无边阿僧祇。不可得比。又阿逸多。若人为是经故。往诣僧坊若坐若立。须臾听受。缘是功德转身所生。得好上妙象马车乘珍宝辇舆及乘天宫。若复有人。于讲法处坐。更有人来。劝令坐听。若分座令坐。是人功德转身。得帝释坐处。若梵王坐处。若转轮圣王所坐之处。阿逸多。若复有人语余人言。有经名法华可共往听。即受其教。乃至须臾间闻。是人功德转身。得与陀罗尼菩萨共生一处。利根智慧。百千万世终不喑哑。口气不臭。舌常无病。口亦无病。齿不垢黑。不黄不疏。亦不缺落。不差不曲。唇不下垂。亦不褰缩。不粗涩。不疮胗。亦不缺坏。亦不喎斜。不厚不大。亦不黧黑。无诸可恶。鼻不匾[匚@虒]。亦不曲戾。面色不黑。亦不狭长。亦不窊曲。无有一切不可喜相。唇舌牙齿悉皆严好。鼻修高直面貌圆满。眉高而长额广平正。人相具足世世所生。见佛闻法信受教诲。阿逸多。汝且观是劝于一人令往听法功德如此。何况一心听说读诵。而于大众为人分别如说修行。尔时世尊欲重宣此义。而说偈言

  若人于法会　　得闻是经典
  乃至于一偈　　随喜为他说
  如是展转教　　至于第五十
  最后人获福　　今当分别之
  如有大施主　　供给无量众
  具满八十岁　　随意之所欲
  见彼衰老相　　发白而面皱
  齿疏形枯竭　　念其死不久
  我今应当教　　令得于道果
  即为方便说　　涅槃真实法
  世皆不牢固　　如水沫泡焰
  汝等咸应当　　疾生厌离心
  诸人闻是法　　皆得阿罗汉
  具足六神通　　三明八解脱
  最后第五十　　闻一偈随喜
  是人福胜彼　　不可为譬喻
  如是展转闻　　其福尚无量
  何况于法会　　初闻随喜者
  若有劝一人　　将引听法华
  言此经深妙　　千万劫难遇
  即受教往听　　乃至须臾闻
  斯人之福报　　今当分别说
  世世无口患　　齿不疏黄黑
  唇不厚褰缺　　无有可恶相
  舌不干黑短　　鼻高修且直
  额广而平正　　面目悉端严
  为人所喜见　　口气无臭秽
  优钵华之香　　常从其口出
  若故诣僧坊　　欲听法华经
  须臾闻欢喜　　今当说其福
  后生天人中　　得妙象马车
  珍宝之辇舆　　及乘天宫殿
  若于讲法处　　劝人坐听经
  是福因缘得　　释梵转轮座
  何况一心听　　解说其义趣
  如说而修行　　其福不可量

    妙法莲华经法师功德品第十九

尔时佛告常精进菩萨摩诃萨。若善男子善女人。受持是法华经。若读若诵若解说若书写。是人当得八百眼功德。千二百耳功德八百鼻功德。千二百舌功德。八百身功德。千二百意功德。以是功德庄严六根皆令清净。是善男子善女人。父母所生清净肉眼。见于三千大千世界。内外所有山林河海。下至阿鼻地狱上至有顶。亦见其中一切众生。及业因缘果报生处。悉见悉知。尔时世尊欲重宣此义。而说偈言

  若于大众中　　以无所畏心
  说是法华经　　汝听其功德
  是人得八百　　功德殊胜眼
  以是庄严故　　其目甚清净
  父母所生眼　　悉见三千界
  内外弥楼山　　须弥及铁围
  并诸余山林　　大海江河水
  下至阿鼻狱　　上至有顶处
  其中诸众生　　一切皆悉见
  虽未得天眼　　肉眼力如是

复次常精进。若善男子善女人。受持此经。若读若诵若解说若书写。得千二百耳功德。以是清净耳。闻三千大千世界。下至阿鼻地狱上至有顶。其中内外种种语言音声。象声马声牛声车声。啼哭声愁叹声。螺声鼓声钟声铃声。笑声语声。男声女声童子声童女声。法声非法声。苦声乐声。凡夫声圣人声。喜声不喜声。天声龙声夜叉声乾闼婆声阿修罗声迦楼罗声紧那罗声摩睺罗伽声。火声。水声风声。地狱声畜生声饿鬼声。比丘声比丘尼声。声闻声辟支佛声。菩萨声佛声。以要言之。三千大千世界中。一切内外所有诸声。虽未得天耳。以父母所生清净常耳。皆悉闻知如是分别种种音声。而不坏耳根。尔时世尊欲重宣此义。而说偈言

  父母所生耳　　清净无浊秽
  以此常耳闻　　三千世界声
  象马车牛声　　钟铃螺鼓声
  琴瑟箜篌声　　箫笛之音声
  清净好歌声　　听之而不着
  无数种人声　　闻悉能解了
  又闻诸天声　　微妙之歌音
  及闻男女声　　童子童女声
  山川崄谷中　　迦陵频伽声
  命命等诸鸟　　悉闻其音声
  地狱众苦痛　　种种楚毒声
  饿鬼饥渴逼　　求索饮食声
  诸阿修罗等　　居在大海边
  自共语言时　　出于大音声
  如是说法者　　安住于此间
  遥闻是众声　　而不坏耳根
  十方世界中　　禽兽鸣相呼
  其说法之人　　于此悉闻之
  其诸梵天上　　光音及遍净
  乃至有顶天　　言语之音声
  法师住于此　　悉皆得闻之
  一切比丘众　　及诸比丘尼
  若读诵经典　　若为他人说
  法师住于此　　悉皆得闻之
  复有诸菩萨　　读诵于经法
  若为他人说　　撰集解其义
  如是诸音声　　悉皆得闻之
  诸佛大圣尊　　教化众生者
  于诸大会中　　演说微妙法
  持此法华者　　悉皆得闻之
  三千大千界　　内外诸音声
  下至阿鼻狱　　上至有顶天
  皆闻其音声　　而不坏耳根
  其耳聪利故　　悉能分别知
  持是法花者　　虽未得天耳
  但用所生耳　　功德已如是

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。成就八百鼻功德。以是清净鼻根。闻于三千大千世界上下内外种种诸香。须曼那华香。阇提华香。末利华香。瞻卜华香。波罗罗华香。赤莲华香。青莲华香。白莲华香。华树香果树香。栴檀香沉水香。多摩罗跋香。多伽罗香。及千万种和香。若末若丸若涂香。持是经者。于此间住悉能分别。又复别知众生之香。象香马香牛羊等香。男香女香。童子香童女香。及草木丛林香。若近若远所有诸香。悉皆得闻分别不错。持是经者。虽住于此。亦闻天上诸天之香。波利质多罗拘鞞陀罗树香。及曼陀罗华香。摩诃曼陀罗华香。曼殊沙华香。摩诃曼殊沙华香。栴檀沉水。种种末香。诸杂华香。如是等天香。和合所出之香。无不闻知。又闻诸天身香。释提桓因在胜殿上五欲娱乐嬉戏时香。若在妙法堂上为忉利诸天说法时香。若于诸园游戏时香。及余天等男女身香。皆悉遥闻。如是展转乃至梵世。上至有顶诸天身香。亦皆闻之。并闻诸天所烧之香。及声闻香。辟支佛香。菩萨香。诸佛身香。亦皆遥闻知其所在。虽闻此香。然于鼻根不坏不错。若欲分别为他人说。忆念不谬。尔时世尊欲重宣此义。而说偈言

  是人鼻清净　　于此世界中
  若香若臭物　　种种悉闻知
  须曼那阇提　　多摩罗栴檀
  沉水及桂香　　种种华果香
  及知众生香　　男子女人香
  说法者远住　　闻香知所在
  大势转轮王　　小转轮及子
  群臣诸宫人　　闻香知所在
  身所著珍宝　　及地中宝藏
  转轮王宝女　　闻香知所在
  诸人严身具　　衣服及璎珞
  种种所涂香　　闻香知其身
  诸天若行坐　　游戏及神变
  持是法华者　　闻香悉能知
  诸树华果实　　及酥油香气
  持经者住此　　悉知其所在
  诸山深崄处　　栴檀树花敷
  众生在中者　　闻香皆能知
  铁围山大海　　地中诸众生
  持经者闻香　　悉知其所在
  阿修罗男女　　及其诸眷属
  斗诤游戏时　　闻香皆能知
  旷野险隘处　　师子象虎狼
  野牛水牛等　　闻香知所在
  若有怀妊者　　未辩其男女
  无根及非人　　闻香悉能知
  以闻香力故　　知其初怀妊
  成就不成就　　安乐产福子
  以闻香力故　　知男女所念
  染欲痴恚心　　亦知修善者
  地中众伏藏　　金银诸珍宝
  铜器之所盛　　闻香悉能知
  种种诸璎珞　　无能识其价
  闻香知贵贱　　出处及所在
  天上诸华等　　曼陀曼殊沙
  波利质多树　　闻香悉能知
  天上诸宫殿　　上中下差别
  众宝花庄严　　闻香悉能知
  天园林胜殿　　诸观妙法堂
  在中而娱乐　　闻香悉能知
  诸天若听法　　或受五欲时
  来往行坐卧　　闻香悉能知
  天女所著衣　　好华香庄严
  周旋游戏时　　闻香悉能知
  如是展转上　　乃至于梵世
  入禅出禅者　　闻香悉能知
  光音遍净天　　乃至于有顶
  初生及退没　　闻香悉能知
  诸比丘众等　　于法常精进
  若坐若经行　　及读诵经法
  或在林树下　　专精而坐禅
  持经者闻香　　悉知其所在
  菩萨志坚固　　坐禅若读诵
  或为人说法　　闻香悉能知
  在在方世尊　　一切所恭敬
  愍众而说法　　闻香悉能知
  众生在佛前　　闻经皆欢喜
  如法而修行　　闻香悉能知
  虽未得菩萨　　无漏法生鼻
  而是持经者　　先得此鼻相

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。得千二百舌功德。若好若丑。若美不美。及诸苦涩物。在其舌根。皆变成上味。如天甘露无不美者。若以舌根。于大众中有所演说。出深妙声能入其心。皆令欢喜快乐。又诸天子天女释梵诸天。闻是深妙音声。有所演说言论次第。皆悉来听。及诸龙龙女。夜叉夜叉女。乾闼婆乾闼婆女。阿修罗阿修罗女。迦楼罗迦楼罗女。紧那罗紧那罗女。摩睺罗伽摩睺罗伽女。为听法故。皆来亲近恭敬供养。及比丘比丘尼优婆塞优婆夷。国王王子群臣眷属。小转轮王大转轮王。七宝千子内外眷属。乘其宫殿俱来听法。以是菩萨善说法故。婆罗门居士国内人民。尽其形寿随侍供养。又诸声闻辟支佛菩萨诸佛。常乐见之。是人所在方面。诸佛皆向其处说法。悉能受持一切佛法。又能出于深妙法音。尔时世尊欲重宣此义。而说偈言

  是人舌根净　　终不受恶味
  其有所食啖　　悉皆成甘露
  以深净妙声　　于大众说法
  以诸因缘喻　　引导众生心
  闻者皆欢喜　　设诸上供养
  诸天龙夜叉　　及阿修罗等
  皆以恭敬心　　而共来听法
  是说法之人　　若欲以妙音
  遍满三千界　　随意即能至
  大小转轮王　　及千子眷属
  合掌恭敬心　　常来听受法
  诸天龙夜叉　　罗刹毗舍阇
  亦以欢喜心　　常乐来供养
  梵天王魔王　　自在大自在
  如是诸天众　　常来至其所
  诸佛及弟子　　闻其说法音
  常念而守护　　或时为现身

复次常精进。若善男子善女人。受持是经。若读若诵若解说若书写。得八百身功德。得清净身如净琉璃。众生喜见。其身净故。三千大千世界众生。生时死时上下好丑。生善处恶处。悉于中现。及铁围山。大铁围山。弥楼山。摩诃弥楼山等诸山。及其中众生悉于中现。下至阿鼻地狱上至有顶。所有及众生悉于中现。若声闻辟支佛菩萨诸佛说法。皆于身中现其色像。尔时世尊欲重宣此义。而说偈言

  若持法花者　　其身甚清净
  如彼净琉璃　　众生皆喜见
  又如净明镜　　悉见诸色像
  菩萨于净身　　皆见世所有
  唯独自明了　　余人所不见
  三千世界中　　一切诸群萌
  天人阿修罗　　地狱鬼畜生
  如是诸色像　　皆于身中现
  诸天等宫殿　　乃至于有顶
  铁围及弥楼　　摩诃弥楼山
  诸大海水等　　皆于身中现
  诸佛及声闻　　佛子菩萨等
  若独若在众　　说法悉皆现
  虽未得无漏　　法性之妙身
  以清净常体　　一切于中现

复次常精进。若善男子善女人。如来灭后受持是经。若读若诵若解说若书写。得千二百意功德。以是清净意根。乃至闻一偈一句。通达无量无边之义。解是义已。能演说一句一偈。至于一月四月乃至一岁。诸所说法随其义趣。皆与实相不相违背。若说俗间经书。治世语言资生业等。皆顺正法。三千大千世界六趣众生。心之所行。心所动作。心所戏论。皆悉知之。虽未得无漏智慧。而其意根清净如此。是人有所思惟筹量言说。皆是佛法无不真实。亦是先佛经中所说。尔时世尊欲重宣此义。而说偈言

  是人意清净　　明利无秽浊
  以此妙意根　　知上中下法
  乃至闻一偈　　通达无量义
  次第如法说　　月四月至岁
  是世界内外　　一切诸众生
  若天龙及人　　夜叉鬼神等
  其在六趣中　　所念若干种
  持法花之报　　一时皆悉知
  十方无数佛　　百福庄严相
  为众生说法　　悉闻能受持
  思惟无量义　　说法亦无量
  终始不忘错　　以持法华故
  悉知诸法相　　随义识次第
  达名字语言　　如所知演说
  此人有所说　　皆是先佛法
  以演此法故　　于众无所畏
  持法花经者　　意根净若斯
  虽未得无漏　　先有如是相
  是人持此经　　安住希有地
  为一切众生　　欢喜而爱敬
  能以千万种　　善巧之语言
  分别而说法　　持法花经故

    妙法莲华经常不轻菩萨品第二十

尔时佛告得大势菩萨摩诃萨。汝今当知。若比丘比丘尼优婆塞优婆夷。持法花经者。若有恶口骂詈诽谤。获大罪报。如前所说。其所得功德。如向所说。眼耳鼻舌身意清净。得大势。乃往古昔过无量无边不可思议阿僧祇劫。有佛名威音王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名离衰。国名大成。其威音王佛。于彼世中。为天人阿修罗说法。为求声闻者。说应四谛法。度生老病死究竟涅槃。为求辟支佛者。说应十二因缘法。为诸菩萨因阿耨多罗三藐三菩提。说应六波罗蜜法究竟佛慧。得大势。是威音王佛。寿四十万亿那由他恒河沙劫。正法住世劫数。如一阎浮提微尘。像法住世劫数。如四天下微尘。其佛饶益众生已。然后灭度。正法像法灭尽之后。于此国土复有佛出。亦号威音王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。如是次第有二万亿佛皆同一号。最初威音王如来。既已灭度。正法灭后于像法中。增上慢比丘有大势力。尔时有一菩萨比丘。名常不轻。得大势。以何因缘。名常不轻。是比丘凡有所见。若比丘比丘尼优婆塞优婆夷。皆悉礼拜赞叹。而作是言。我深敬汝等不敢轻慢。所以者何。汝等皆行菩萨道当得作佛。而是比丘。不专读诵经典。但行礼拜。乃至远见四众。亦复故往礼拜赞叹而作是言。我不敢轻于汝等。汝等皆当作佛。四众之中。有生嗔恚心不净者。恶口骂詈言。是无智比丘。从何所来自言我不轻汝而与我等授记当得作佛。我等不用如是虚妄授记。如此经历多年常被骂詈。不生嗔恚常作是言。汝当作佛。说是语时。众人或以杖木瓦石而打掷之。避走远住。犹高声唱言。我不敢轻于汝等。汝等皆当作佛。以其常作是语故。增上慢比丘比丘尼优婆塞优婆夷。号之为常不轻。是比丘临欲终时。于虚空中。具闻威音王佛先所说法华经。二十千万亿偈悉能受持。即得如上眼根清净耳鼻舌身意根清净。得是六根清净已。更增寿命二百万亿那由他岁。广为人说是法华经。于时增上慢四众。比丘比丘尼优婆塞优婆夷。轻贱是人。为作不轻名者。见其得大神通力乐说辩力大善寂力。闻其所说皆信伏随从。是菩萨复化千万亿众令住阿耨多罗三藐三菩提。命终之后得值二千亿佛。皆号日月灯明。于其法中说是法华经。以是因缘复值二千亿佛。同号云自在灯王。于此诸佛法中受持读诵。为诸四众说此经典故。得是常眼清净耳鼻舌身意诸根清净。于四众中说法心无所畏。得大势。是常不轻菩萨摩诃萨供养如是若干诸佛。恭敬尊重赞叹种诸善根。于后复值千万亿佛。亦于诸佛法中说是经典。功德成就当得作佛。得大势。于意云何。尔时常不轻菩萨岂异人乎。则我身是。若我于宿世。不受持读诵此经。为他人说者不能疾得阿耨多罗三藐三菩提。我于先佛所。受持读诵此经为人说故。疾得阿耨多罗三藐三菩提。得大势。彼时四众比丘比丘尼优婆塞优婆夷。以嗔恚意轻贱我故。二百亿劫常不值佛不闻法不见僧。千劫于阿鼻地狱受大苦恼。毕是罪已。复遇常不轻菩萨教化阿耨多罗三藐三菩提。得大势。于汝意云何。尔时四众常轻是菩萨者。岂异人乎。今此会中跋陀婆罗等五百菩萨。师子月等五百比丘尼。思佛等五百优婆塞。皆于阿耨多罗三藐三菩提不退转者是。得大势。当知是法华经。大饶益诸菩萨摩诃萨。能令至于阿耨多罗三藐三菩提。是故诸菩萨摩诃萨于如来灭后常应受持读诵解说书写是经。尔时世尊。欲重宣此义。而说偈言

  过去有佛　　号威音王　　神智无量
  将导一切　　天人龙神　　所共供养
  是佛灭后　　法欲尽时　　有一菩萨
  名常不轻　　时诸四众　　计着于法
  不轻菩萨　　往到其所　　而语之言
  我不轻汝　　汝等行道　　皆当作佛
  诸人闻已　　轻毁骂詈　　不轻菩萨
  能忍受之　　其罪毕已　　临命终时
  得闻此经　　六根清净　　神通力故
  增益寿命　　复为诸人　　广说是经
  诸着法众　　皆蒙菩萨　　教化成就
  令住佛道　　不轻命终　　值无数佛
  说是经故　　得无量福　　渐具功德
  疾成佛道　　彼时不轻　　则我身是
  时四部众　　着法之者　　闻不轻言
  汝当作佛　　以是因缘　　值无数佛
  此会菩萨　　五百之众　　并及四部
  清信士女　　今于我前　　听法者是
  我于前世　　劝是诸人　　听受斯经
  第一之法　　开示教人　　令住涅槃
  世世受持　　如是经典　　亿亿万劫
  至不可议　　时乃得闻　　是法华经
  亿亿万劫　　至不可议　　诸佛世尊
  时说是经　　是故行者　　于佛灭后
  闻如是经　　勿生疑惑　　应当一心
  广说此经　　世世值佛　　疾成佛道

    妙法莲华经如来神力品第二十一

尔时千世界微尘等菩萨摩诃萨。从地踊出者。皆于佛前一心合掌瞻仰尊颜而白佛言。世尊。我等于佛灭后。世尊分身所在国土灭度之处。当广说此经。所以者何。我等亦自欲得是真净大法。受持读诵解说书写而供养之。尔时世尊于文殊师利等无量百千万亿旧住娑婆世界菩萨摩诃萨。及诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切众前。现大神力出广长舌上至梵世。一切毛孔放于无量无数色光。皆悉遍照十方世界。众宝树下师子座上诸佛亦复如是。出广长舌放无量光。释迦牟尼佛及宝树下诸佛。现神力时满百千岁。然后还摄舌相。一时謦欬俱共弹指。是二音声。遍至十方诸佛世界。地皆六种震动。其中众生。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。以佛神力故。皆见此娑婆世界无量无边百千万亿众宝树下师子座上诸佛。及见释迦牟尼佛共多宝如来在宝塔中坐师子座。又见无量无边百千万亿菩萨摩诃萨。及诸四众恭敬围绕释迦牟尼佛。既见是已。皆大欢喜得未曾有。即时诸天于虚空中高声唱言。过此无量无边百千万亿阿僧祇世界。有国名娑婆。是中有佛。名释迦牟尼。今为诸菩萨摩诃萨。说大乘经。名妙法莲华教菩萨法佛所护念。汝等当深心随喜。亦当礼拜供养释迦牟尼佛。彼诸众生闻虚空中声已。合掌向娑婆世界。作如是言。南无释迦牟尼佛。南无释迦牟尼佛。以种种华香璎珞幡盖及诸严身之具珍宝妙物。皆共遥散娑婆世界。所散诸物从十方来。譬如云集变成宝帐。遍覆此间诸佛之上。于时十方世界通达无碍。如一佛土。尔时佛告上行等菩萨大众。诸佛神力如是无量无边不可思议。若我以是神力。于无量无边百千万亿阿僧祇劫。为嘱累故说此经功德。犹不能尽以要言之。如来一切所有之法。如来一切自在神力。如来一切秘要之藏。如来一切甚深之事。皆于此经宣示显说。是故汝等于如来灭后。应一心受持读诵解说书写如说修行。所在国土。若有受持读诵解说书写如说修行。若经卷所住之处。若于园中。若于林中。若于树下。若于僧坊。若白衣舍。若在殿堂。若山谷旷野。是中皆应起塔供养。所以者何。当知是处即是道场。诸佛于此得阿耨多罗三藐三菩提。诸佛于此转于法轮。诸佛于此而般涅槃。尔时世尊。欲重宣此义。而说偈言

  诸佛救世者　　住于大神通
  为悦众生故　　现无量神力
  舌相至梵天　　身放无数光
  为求佛道者　　现此希有事
  诸佛謦欬声　　及弹指之声
  周闻十方国　　地皆六种动
  以佛灭度后　　能持是经故
  诸佛皆欢喜　　现无量神力
  嘱累是经故　　赞美受持者
  于无量劫中　　犹故不能尽
  是人之功德　　无边无有穷
  如十方虚空　　不可得边际
  能持是经者　　则为已见我
  亦见多宝佛　　及诸分身者
  又见我今日　　教化诸菩萨
  能持是经者　　令我及分身
  灭度多宝佛　　一切皆欢喜
  十方现在佛　　并过去未来
  亦见亦供养　　亦令得欢喜
  诸佛坐道场　　所得秘要法
  能持是经者　　不久亦当得
  能持是经者　　于诸法之义
  名字及言辞　　乐说无穷尽
  如风于空中　　一切无障碍
  于如来灭后　　知佛所说经
  因缘及次第　　随义如实说
  如日月光明　　能除诸幽冥
  斯人行世间　　能灭众生闇
  教无量菩萨　　毕竟住一乘
  是故有智者　　闻此功德利
  于我灭度后　　应受持斯经
  是人于佛道　　决定无有疑

    妙法莲华经嘱累品第二十二

尔时释迦牟尼佛。从法座起现大神力。以右手摩无量菩萨摩诃萨顶。而作是言。我于无量百千万亿阿僧祇劫。修习是难得阿耨多罗三藐三菩提法。今以付嘱汝等。汝等应当一心流布此法广令增益。如是三摩诸菩萨摩诃萨顶。而作是言。我于无量百千万亿阿僧祇劫。修习是难得阿耨多罗三藐三菩提法。今以付嘱汝等。汝等当受持读诵广宣此法。令一切众生普得闻知。所以者何。如来有大慈悲。无诸悭吝亦无所畏。能与众生佛之智慧如来智慧自然智慧。如来是一切众生之大施主。汝等亦应随学如来之法。勿生悭吝。于未来世。若有善男子善女人。信如来智慧者。当为演说此法华经使得闻知。为令其人得佛慧故。若有众生不信受者。当于如来余深法中示教利喜。汝等若能如是。则为已报诸佛之恩。时诸菩萨摩诃萨。闻佛作是说已。皆大欢喜遍满其身。益加恭敬曲躬低头。合掌向佛俱发声言。如世尊敕当具奉行。唯然世尊。愿不有虑。诸菩萨摩诃萨众。如是三反俱发声言。如世尊敕当具奉行。唯然世尊。愿不有虑。尔时释迦牟尼佛。令十方来诸分身佛各还本土。而作是言。诸佛各随所安。多宝佛塔还可如故。说是语时。十方无量分身诸佛。坐宝树下师子座上者。及多宝佛。并上行等无边阿僧祇菩萨大众。舍利弗等声闻四众。及一切世间天人阿修罗等。闻佛所说。皆大欢喜

    妙法莲华经药王菩萨本事品第二十三

尔时宿王华菩萨白佛言。世尊。药王菩萨。云何游于娑婆世界。世尊。是药王菩萨。有若干百千万亿那由他难行苦行。善哉世尊。愿少解说。诸天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。又他国土诸来菩萨。及此声闻众。闻皆欢喜。尔时佛告宿王华菩萨。乃往过去无量恒河沙劫有佛。号日月净明德如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛有八十亿大菩萨摩诃萨。七十二恒河沙大声闻众。佛寿四万二千劫菩萨寿命亦等。彼国无有女人地狱饿鬼畜生阿修罗等及以诸难。地平如掌琉璃所成。宝树庄严。宝帐覆上。垂宝华幡。宝瓶香炉周遍国界。七宝为台。一树一台。其树去台尽一箭道。此诸宝树。皆有菩萨声闻而坐其下。诸宝台上。各有百亿诸天作天伎乐。歌叹于佛以为供养。尔时彼佛。为一切众生喜见菩萨及众菩萨诸声闻众。说法华经。是一切众生喜见菩萨乐习苦行。于日月净明德佛法中。精进经行一心求佛。满万二千岁已。得现一切色身三昧。得此三昧已心大欢喜。即作念言。我得现一切色身三昧。皆是得闻法华经力。我今当供养日月净明德佛及法华经。即时入是三昧。于虚空中雨曼陀罗华摩诃曼陀罗华。细末坚黑栴檀。满虚空中如云而下。又雨海此岸栴檀之香此香六铢。价直娑婆世界。以供养佛。作是供养已。从三昧起。而自念言。我虽以神力供养于佛。不如以身供养。即服诸香。栴檀。薰陆。兜楼婆。毕力迦。沉水。胶香。又饮瞻卜诸华香油。满千二百岁已。香油涂身。于日月净明德佛前。以天宝衣而自缠身。灌诸香油。以神通力愿。而自然身。光明遍照八十亿恒河沙世界。其中诸佛同时赞言。善哉善哉。善男子。是真精进。是名真法供养如来。若以华香璎珞烧香末香涂香天缯幡盖及海此岸栴檀之香。如是等种种诸物供养。所不能及。假使国城妻子布施亦所不及。善男子。是名第一之施。于诸施中最尊最上。以法供养诸如来故。作是语已而各默然。其身火燃千二百岁。过是已后其身乃尽。一切众生喜见菩萨。作如是法供养已。命终之后。复生日月净明德佛国中。于净德王家。结加趺坐忽然化生。即为其父。而说偈言

  大王今当知　　我经行彼处
  即时得一切　　现诸身三昧
  勤行大精进　　舍所爱之身
  供养于世尊　　为求无上慧

说是偈已。而白父言。日月净明德佛。今故现在。我先供养佛已。得解一切众生语言陀罗尼。复闻是法华经。八百千万亿那由他。甄迦罗。频婆罗。阿閦婆等偈。大王。我今当还供养此佛。白已即坐七宝之台。上升虚空高七多罗树。往到佛所头面礼足合十指爪。以偈赞佛

  容颜甚奇妙　　光明照十方
  我适曾供养　　今复还亲觐

尔时一切众生喜见菩萨。说是偈已。而白佛言。世尊。世尊犹故在世。尔时日月净明德佛告一切众生喜见菩萨。善男子。我涅槃时到。灭尽时至。汝可安施床座。我于今夜当般涅槃。又敕一切众生喜见菩萨。善男子。我以佛法嘱累于汝。及诸菩萨大弟子。并阿耨多罗三藐三菩提法。亦以三千大千七宝世界。诸宝树宝台。及给侍诸天。悉付于汝。我灭度后所有舍利。亦付嘱汝。当令流布广设供养。应起若干千塔。如是日月净明德佛。敕一切众生喜见菩萨已。于夜后分入于涅槃。尔时一切众生喜见菩萨。见佛灭度悲感懊恼恋慕于佛。即以海此岸栴檀为[卄/積]。供养佛身。而以烧之。火灭已后。收取舍利。作八万四千宝瓶。以起八万四千塔。高三世界。表刹庄严。垂诸幡盖悬众宝铃。尔时一切众生喜见菩萨。复自念言。我虽作是供养心犹未足。我今当更供养舍利。便语诸菩萨大弟子。及天龙夜叉等一切大众。汝等当一心念。我今供养日月净明德佛舍利。作是语已。即于八万四千塔前。然百福庄严臂。七万二千岁而以供养。令无数求声闻众无量阿僧祇人发阿耨多罗三藐三菩提心。皆使得住现一切色身三昧。尔时诸菩萨天人阿修罗等。见其无臂忧恼悲哀。而作是言。此一切众生喜见菩萨。是我等师。教化我者。而今烧臂身不具足。于时一切众生喜见菩萨。于大众中立此誓言。我舍两臂。必当得佛金色之身。若实不虚。令我两臂还复如故。作是誓已自然还复。由斯菩萨福德智慧淳厚所致。当尔之时。三千大千世界六种震动。天雨宝华。一切人天得未曾有。佛告宿王华菩萨。于汝意云何。一切众生喜见菩萨。岂异人乎。今药王菩萨是也。其所舍身布施如是。无量百千万亿那由他数。宿王华。若有发心欲得阿耨多罗三藐三菩提者。能燃手指乃至足一指供养佛塔。胜以国城妻子及三千大千国土山林河池诸珍宝物而供养者。若复有人。以七宝满三千大千世界。供养于佛及大菩萨辟支佛阿罗汉。是人所得功德。不如受持此法华经。乃至一四句偈其福最多。宿王华。譬如一切川流江河诸水之中。海为第一。此法华经亦复如是。于诸如来所说经中。最为深大。又如土山黑山小铁围山大铁围山及十宝山。众山之中须弥山为第一。此法华经亦复如是。于诸经中最为其上。又如众星之中。月天子最为第一。此法华经亦复如是。于千万亿种诸经法中。最为照明。又如日天子能除诸闇。此经亦复如是。能破一切不善之闇。又如诸小王中。转轮圣王最为第一。此经亦复如是。于众经中最为其尊。又如帝释。于三十三天中王。此经亦复如是。诸经中王。又如大梵天王。一切众生之父。此经亦复如是。一切贤圣学无学。及发菩萨心者之父。又如一切凡夫人中。须陀洹斯陀含阿那含阿罗汉辟支佛为第一。此经亦复如是。一切如来所说。若菩萨所说。若声闻所说。诸经法中最为第一。有能受持是经典者。亦复如是。于一切众生中亦为第一。一切声闻辟支佛中菩萨为第一。此经亦复如是。于一切诸经法中最为第一。如佛为诸法王。此经亦复如是。诸经中王。宿王华。此经能救一切众生者。此经能令一切众生离诸苦恼。此经能大饶益一切众生。充满其愿。如清凉池。能满一切诸渴乏者。如寒者得火。如裸者得衣。如商人得主。如子得母。如渡得船。如病得医。如暗得灯。如贫得宝。如民得王。如贾客得海。如炬除暗。此法华经亦复如是。能令众生离一切苦一切病痛。能解一切生死之缚。若人得闻此法华经。若自书。若使人书。所得功德。以佛智慧筹量多少不得其边。若书是经卷。华香璎珞。烧香末香涂香。幡盖衣服。种种之灯酥灯油灯诸香油灯。瞻卜油灯。须曼那油灯。波罗罗油灯。婆利师迦油灯。那婆摩利油灯供养。所得功德亦复无量。宿王华。若有人闻是药王菩萨本事品者。亦得无量无边功德。若有女人闻是药王菩萨本事品。能受持者。尽是女身后不复受。若如来灭后后五百岁中。若有女人。闻是经典如说修行。于此命终。即往安乐世界阿弥陀佛大菩萨众围绕住处。生莲华中宝座之上。不复为贪欲所恼。亦复不为嗔恚愚痴所恼。亦复不为憍慢嫉妒诸垢所恼。得菩萨神通无生法忍。得是忍已。眼根清净。以是清净眼根。见七百万二千亿那由他恒河沙等诸佛如来。是时诸佛遥共赞言。善哉善哉。善男子。汝能于释迦牟尼佛法中。受持读诵思惟是经为他人说。所得福德无量无边。火不能烧。水不能漂。汝之功德千佛共说不能令尽。汝今已能破诸魔贼坏生死军。诸余怨敌皆悉摧灭。善男子。百千诸佛以神通力共守护汝。于一切世间天人之中无如汝者。唯除如来。其诸声闻辟支佛乃至菩萨智慧禅定。无有与汝等者。宿王华。此菩萨成就如是功德智慧之力。若有人闻是药王菩萨本事品。能随喜赞善者。是人现世口中常出青莲华香。身毛孔中。常出牛头栴檀之香。所得功德如上所说。是故宿王华。以此药王菩萨本事品。嘱累于汝。我灭度后后五百岁中。广宣流布于阎浮提无令断绝。恶魔魔民诸天龙夜叉鸠槃茶等得其便也。宿王华。汝当以神通之力守护是经。所以者何。此经则为阎浮提人病之良药。若人有病。得闻是经病即消灭。不老不死。宿王华。汝若见有受持是经者。应以青莲花盛满末香供散其上。散已作是念言。此人不久。必当取草坐于道场破诸魔军。当吹法螺击大法鼓。度脱一切众生老病死海。是故求佛道者。见有受持是经典人。应当如是生恭敬心。说是药王菩萨本事品时。八万四千菩萨。得解一切众生语言陀罗尼。多宝如来于宝塔中。赞宿王华菩萨言。善哉善哉。宿王华。汝成就不可思议功德。乃能问释迦牟尼佛如此之事。利益无量一切众生

妙法莲华经卷第六妙法莲华经卷第七

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

    妙音菩萨品第二十四

尔时释迦牟尼佛。放大人相肉髻光明。及放眉间白毫相光。遍照东方百八万亿那由他恒河沙等诸佛世界。过是数已有世界。名净光庄严。其国有佛。号净华宿王智如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为无量无边菩萨大众恭敬围绕而为说法。释迦牟尼佛白毫光明遍照其国。尔时一切净光庄严国中。有一菩萨名曰妙音。久已殖众德本。供养亲近无量百千万亿诸佛。而悉成就甚深智慧。得妙幢相三昧。法华三昧。净德三昧。宿王戏三昧。无缘三昧。智印三昧。解一切众生语言三昧。集一切功德三昧。清净三昧。神通游戏三昧。慧炬三昧。庄严王三昧。净光明三昧。净藏三昧。不共三昧。日旋三昧。得如是等百千万亿恒河沙等诸大三昧。释迦牟尼佛光照其身。即白净华宿王智佛言。世尊。我当往诣娑婆世界。礼拜亲近供养释迦牟尼佛。及见文殊师利法王子菩萨。药王菩萨。勇施菩萨。宿王华菩萨。上行意菩萨。庄严王菩萨。药上菩萨。尔时净华宿王智佛告妙音菩萨。汝莫轻彼国生下劣想。善男子。彼娑婆世界。高下不平土石诸山秽恶充满佛身卑小。诸菩萨众其形亦小。而汝身四万二千由旬。我身六百八十万由旬。汝身第一端正。百千万福光明殊妙。是故汝往莫轻彼国若佛菩萨及国土生下劣想。妙音菩萨白其佛言。世尊。我今诣娑婆世界。皆是如来之力。如来神通游戏。如来功德智慧庄严。于是妙音菩萨。不起于座身不动摇。而入三昧。以三昧力。于耆阇崛山去法座不远。化作八万四千众宝莲华。阎浮檀金为茎。白银为叶。金刚为须。甄叔迦宝以为其台。尔时文殊师利法王子。见是莲华而白佛言。世尊。是何因缘先现此瑞。有若干千万莲华。阎浮檀金为茎。白银为叶。金刚为须。甄叔迦宝以为其台。尔时释迦牟尼佛告文殊师利。是妙音菩萨摩诃萨。欲从净华宿王智佛国。与八万四千菩萨围绕。而来至此娑婆世界。供养亲近礼拜于我。亦欲供养听法华经。文殊师利白佛言。世尊。是菩萨种何善本修何功德。而能有是大神通力。行何三昧。愿为我等说是三昧名字。我等亦欲勤修行之。行此三昧。乃能见是菩萨色相大小威仪进止。唯愿世尊。以神通力。彼菩萨来令我得见。尔时释迦牟尼佛告文殊师利。此久灭度多宝如来。当为汝等而现其相。时多宝佛告彼菩萨。善男子来。文殊师利法王子。欲见汝身。于时妙音菩萨。于彼国没。与八万四千菩萨俱共发来。所经诸国六种震动。皆悉雨于七宝莲华。百千天乐不鼓自鸣。是菩萨。目如广大青莲华叶。正使和合百千万月。其面貌端正复过于此。身真金色。无量百千功德庄严。威德炽盛光明照曜。诸相具足。如那罗延坚固之身。入七宝台上升虚空。去地七多罗树。诸菩萨众恭敬围绕。而来诣此娑婆世界耆阇崛山。到已下七宝台。以价直百千璎珞。持至释迦牟尼佛所。头面礼足奉上璎珞。而白佛言。世尊。净华宿王智佛。问讯世尊。少病少恼起居轻利安乐行不。四大调和不。世事可忍不。众生易度不。无多贪欲嗔恚愚痴嫉妒悭慢不。无不孝父母不敬沙门邪见不善心不摄五情不。世尊。众生能降伏诸魔怨不。久灭度多宝如来。在七宝塔中来听法不。又问讯多宝如来。安隐少恼堪忍久住不。世尊。我今欲见多宝佛身。唯愿世尊。示我令见。尔时释迦牟尼佛语多宝佛。是妙音菩萨欲得相见。时多宝佛告妙音言。善哉善哉。汝能为供养释迦牟尼佛。及听法华经。并见文殊师利等。故来至此

尔时华德菩萨白佛言。世尊。是妙音菩萨。种何善根修何功德。有是神力。佛告华德菩萨。过去有佛。名云雷音王多陀阿伽度阿罗诃三藐三佛陀。国名现一切世间。劫名喜见。妙音菩萨。于万二千岁。以十万种伎乐。供养云雷音王佛。并奉上八万四千七宝钵。以是因缘果报。今生净华宿王智佛国有是神力。华德。于汝意云何。尔时云雷音王佛所妙音菩萨伎乐供养奉上宝器者。岂异人乎。今此妙音菩萨摩诃萨是。华德。是妙音菩萨。已曾供养亲近无量诸佛久殖德本。又值恒河沙等百千万亿那由他佛。华德。汝但见妙音菩萨其身在此。而是菩萨现种种身。处处为诸众生说是经典。或现梵王身。或现帝释身。或现自在天身。或现大自在天身。或现天大将军身。或现毗沙门天王身。或现转轮圣王身。或现诸小王身。或现长者身。或现居士身。或现宰官身。或现婆罗门身。或现比丘比丘尼优婆塞优婆夷身。或现长者居士妇女身。或现宰官妇女身。或现婆罗门妇女身。或现童男童女身。或现天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等身。而说是经。诸有地狱饿鬼畜生。及众难处皆能救济。乃至于王后宫。变为女身而说是经。华德。是妙音菩萨。能救护娑婆世界诸众生者。是妙音菩萨。如是种种变化现身。在此娑婆国土。为诸众生说是经典。于神通变化智慧无所损减。是菩萨。以若干智慧。明照娑婆世界。令一切众生各得所知。于十方恒河沙世界中亦复如是。若应以声闻形得度者。现声闻形而为说法。应以辟支佛形得度者。现辟支佛形而为说法。应以菩萨形得度者。现菩萨形而为说法。应以佛形得度者。即现佛形而为说法。如是种种随所应度。而为现形。乃至应以灭度而得度者。示现灭度。华德。妙音菩萨摩诃萨。成就大神通智慧之力。其事如是

尔时华德菩萨白佛言。世尊。是妙音菩萨深种善根。世尊。是菩萨住何三昧。而能如是在所变现度脱众生。佛告华德菩萨。善男子。其三昧名现一切色身。妙音菩萨住是三昧中。能如是饶益无量众生。说是妙音菩萨品时。与妙音菩萨俱来者八万四千人。皆得现一切色身三昧。此娑婆世界无量菩萨。亦得是三昧及陀罗尼。尔时妙音菩萨摩诃萨。供养释迦牟尼佛及多宝佛塔已。还归本土。所经诸国六种震动。雨宝莲华。作百千万亿种种伎乐。既到本国。与八万四千菩萨围绕。至净华宿王智佛所。白佛言。世尊。我到娑婆世界饶益众生。见释迦牟尼佛。及见多宝佛塔礼拜供养。又见文殊师利法王子菩萨。及见药王菩萨。得勤精进力菩萨。勇施菩萨等。亦令是八万四千菩萨得现一切色身三昧。说是妙音菩萨来往品时。四万二千天子得无生法忍。华德菩萨得法华三昧

    御制观世音普门品经序

观世音菩萨。以烁迦罗心。应变无穷。自在神通。遍游法界。入微尘国土。说法济度。具足妙相。弘誓如海。凡有因缘。发清净心。才举声称。即随声而应。所有欲愿。即获如意。妙法莲华经普门品者。为度脱苦恼之真诠也。人能常以是经作观。一念方萌。即见大悲胜相。能灭一切诸苦。其功德不可思议。朕惟。天道福善祸淫。故佛示果报。使人为善。而不敢为恶。夫天堂地狱。皆由人为。不违于方寸之内。故为善者得升天堂。为恶者即堕地狱。夫忠臣孝子吉人贞士其心即佛。故神明芘佑。业障俱泯。是以生不犯于宪条。没不堕于无间。夫凶顽之徒。一于为恶。弃五伦如敝帚。蹈刑法如饮甘。宁餧罗刹。不钦佛道。然人性本善。所为恶者。特气质之偏。苟能改心易虑。修省避畏。转移之间。恶可为善矣。为善则即善人。昔之所积之咎。如太空点尘。红罏片雪。消涤净尽。虽有果报。将安施乎。朕恒念此。惟恐世之人。有过而不知改。乃甘心焉以自弃。遂表章是经。使善良君子。永坚禁戒之心。广纳无量之福。为善功德。岂有涯涘哉

永乐九年五月初一日妙法莲华经观世音菩萨普门品经

        姚秦三藏法师鸠摩罗什译长行

        隋北天竺沙门阇那崛多译重颂

    妙法莲华经观世音菩萨普门品第二十五

尔时无尽意菩萨即从座起。偏袒右肩合掌向佛而作是言。世尊。观世音菩萨。以何因缘名观世音。佛告无尽意菩萨。善男子若有无量百千万亿众生受诸苦恼。闻是观世音菩萨。一心称名。观世音菩萨即时观其音声皆得解脱。若有持是观世音菩萨名者。设入大火火不能烧。由是菩萨威神力故。若为大水所漂。称其名号即得浅处。若有百千万亿众生。为求金银琉璃车磲马瑙珊瑚虎珀真珠等宝。入于大海。假使黑风吹其船舫。飘堕罗刹鬼国。其中若有乃至一人。称观世音菩萨名者。是诸人等。皆得解脱罗刹之难。以是因缘名观世音。若复有人。临当被害。称观世音菩萨名者。彼所执刀杖。寻段段坏。而得解脱。若三千大千国土满中夜叉罗刹。欲来恼人。闻其称观世音菩萨名者。是诸恶鬼。尚不能以恶眼视之。况复加害。设复有人。若有罪若无罪。杻械枷锁检系其身。称观世音菩萨名者。皆悉断坏即得解脱。若三千大千国土满中怨贼。有一商主将诸商人。赍持重宝经过崄路。其中一人作是唱言。诸善男子勿得恐怖。汝等。应当一心称观世音菩萨名号。是菩萨能以无畏施于众生。汝等。若称名者。于此怨贼当得解脱。众商人闻俱发声言南无观世音菩萨。称其名故即得解脱。无尽意。观世音菩萨摩诃萨。威神之力巍巍如是。若有众生多于淫欲。常念恭敬观世音菩萨。便得离欲。若多嗔恚。常念恭敬观世音菩萨。便得离嗔。若多愚痴。常念恭敬观世音菩萨。便得离痴。无尽意。观世音菩萨。有如是等大威神力多所饶益。是故众生常应心念。若有女人设欲求男。礼拜供养观世音菩萨。便生福德智慧之男。设欲求女。便生端正有相之女。宿殖德本众人爱敬。无尽意。观世音菩萨。有如是力。若有众生。恭敬礼拜观世音菩萨。福不唐捐。是故众生。皆应受持观世音菩萨名号。无尽意。若有人受持六十二亿恒河沙菩萨名字。复尽形供养饮食衣服卧具医药。于汝意云何。是善男子善女人功德多不。无尽意言。甚多世尊。佛言。若复有人受持观世音菩萨名号。乃至一时礼拜供养。是二人福正等无异。于百千万亿劫不可穷尽。无尽意。受持观世音菩萨名号。得如是无量无边福德之利

无尽意菩萨白佛言。世尊。观世音菩萨。云何游此娑婆世界。云何而为众生说法。方便之力。其事云何。佛告无尽意菩萨。善男子。若有国土众生应以佛身得度者。观世音菩萨。即现佛身而为说法。应以辟支佛身得度者。即现辟支佛身而为说法。应以声闻身得度者。即现声闻身而为说法。应以梵王身得度者。即现梵王身而为说法。应以帝释身得度者。即现帝释身而为说法。应以自在天身得度者。即现自在天身而为说法。应以大自在天身得度者。即现大自在天身而为说法。应以天大将军身得度者。即现天大将军身而为说法。应以毗沙门身得度者。即现毗沙门身而为说法。应以小王身得度者。即现小王身而为说法。应以长者身得度者。即现长者身而为说法。应以居士身得度者。即现居士身而为说法。应以宰官身得度者。即现宰官身而为说法。应以婆罗门身得度者。即现婆罗门身而为说法。应以比丘比丘尼优婆塞优婆夷身得度者。即现比丘比丘尼优婆塞优婆夷身而为说法。应以长者居士宰官婆罗门妇女身得度者。即现妇女身而为说法。应以童男童女身得度者。即现童男童女身而为说法。应以天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等身得度者。即皆现之而为说法。应以执金刚身得度者。即现执金刚身而为说法。无尽意。是观世音菩萨。成就如是功德。以种种形游诸国土度脱众生。是故汝等。应当一心供养观世音菩萨。是观世音菩萨摩诃萨。于怖畏急难之中能施无畏。是故此娑婆世界。皆号之为施无畏者。无尽意菩萨白佛言。世尊。我今当供养观世音菩萨。即解颈众宝珠璎珞。价直百千两金。而以与之。作是言。仁者。受此法施珍宝璎珞。时观世音菩萨不肯受之。无尽意复白观世音菩萨言。仁者。愍我等故受此璎珞

尔时佛告观世音菩萨。当愍此无尽意菩萨及四众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等故。受是璎珞。即时观世音菩萨愍诸四众及于天龙人非人等。受其璎珞。分作二分。一分奉释迦牟尼佛。一分奉多宝佛塔。无尽意。观世音菩萨。有如是自在神力。游于娑婆世界。尔时无尽意菩萨。以偈问曰

  世尊妙相具　　我今重问彼
  佛子何因缘　　名为观世音
  具足妙相尊　　偈答无尽意
  汝听观音行　　善应诸方所
  弘誓深如海　　历劫不思议
  侍多千亿佛　　发大清净愿
  我为汝略说　　闻名及见身
  心念不空过　　能灭诸有苦
  假使兴害意　　推落大火坑
  念彼观音力　　火坑变成池
  或漂流巨海　　龙鱼诸鬼难
  念彼观音力　　波浪不能没
  或在须弥峰　　为人所推堕
  念彼观音力　　如日虚空住
  或被恶人逐　　堕落金刚山
  念彼观音力　　不能损一毛
  或值怨贼绕　　各执刀加害
  念彼观音力　　咸即起慈心
  或遭王难苦　　临刑欲寿终
  念彼观音力　　刀寻段段坏
  或囚禁枷锁　　手足被杻械
  念彼观音力　　释然得解脱
  咒诅诸毒药　　所欲害身者
  念彼观音力　　还着于本人
  或遇恶罗刹　　毒龙诸鬼等
  念彼观音力　　时悉不敢害
  若恶兽围绕　　利牙爪可怖
  念彼观音力　　疾走无边方
  蚖蛇及蝮蝎　　气毒烟火燃
  念彼观音力　　寻声自回去
  云雷鼓掣电　　降雹澍大雨
  念彼观音力　　应时得消散
  众生被困厄　　无量苦逼身
  观音妙智力　　能救世间苦
  具足神通力　　广修智方便
  十方诸国土　　无刹不现身
  种种诸恶趣　　地狱鬼畜生
  生老病死苦　　以渐悉令灭
  真观清净观　　广大智慧观
  悲观及慈观　　常愿常瞻仰
  无垢清净光　　慧日破诸闇
  能伏灾风火　　普明照世间
  悲体戒雷震　　慈意妙大云
  澍甘露法雨　　灭除烦恼焰
  诤讼经官处　　怖畏军阵中
  念彼观音力　　众怨悉退散
  妙音观世音　　梵音海潮音
  胜彼世间音　　是故须常念
  念念勿生疑　　观世音净圣
  于苦恼死厄　　能为作依怙
  具一切功德　　慈眼视众生
  福聚海无量　　是故应顶礼

尔时持地菩萨即从座起。前白佛言。世尊。若有众生。闻是观世音菩萨品自在之业普门示现神通力者。当知是人功德不少。佛说是普门品时。众中八万四千众生。皆发无等等阿耨多罗三藐三菩提心

    妙法莲华经陀罗尼品第二十六

尔时药王菩萨即从座起。偏袒右肩合掌向佛。而白佛言。世尊。若善男子善女人。有能受持法华经者。若读诵通利。若书写经卷。得几所福。佛告药王。若有善男子善女人。供养八百万亿那由他恒河沙等诸佛。于汝意云何。其所得福宁为多不。甚多世尊。佛言。若善男子善女人。能于是经。乃至受持一四句偈。读诵解义如说修行。功德甚多。尔时药王菩萨白佛言。世尊。我今当与说法者。陀罗尼咒以守护之。即说咒曰

安尔(一)曼尔(二)摩祢(三)摩摩祢(四)旨隶(五)遮梨第(六)赊咩(羊鸣音七)赊履(网雉反)多玮(八)膻(输千反)帝(九)目帝(十)目多履(十一)娑履(十二)阿玮娑履(十三)桑履(十四)娑履(十五)叉裔(十六)阿叉裔(十七)阿耆腻(十八)膻帝(十九)赊履(二十)陀罗尼(二十一)阿卢伽婆娑(苏奈反)簸蔗毗叉腻(二十二)祢毗剃(二十三)阿便哆(都饿反)逻祢履剃(二十四)阿亶哆波隶输地(途卖反二十五)沤究隶(二十六)牟究隶(二十七)阿罗隶(二十八)波罗隶(二十九)首迦差(初几反三十)阿三磨三履(三十一)佛[馬*犬]毗吉利袠帝(三十二)达磨波利差(猜离反)帝(三十三)僧伽涅瞿沙祢(三十四)婆舍婆舍输地(三十五)曼哆逻(三十六)曼哆逻叉夜多(三十七)邮楼哆(三十八)邮楼哆憍舍略(来加反三十九)恶叉逻(四十)恶叉冶多冶(四十一)阿婆卢(四十二)阿摩若(荏蔗反)那多夜(四十三)

世尊。是陀罗尼神咒。六十二亿恒河沙等诸佛所说。若有侵毁此法师者。则为侵毁是诸佛已。时释迦牟尼佛赞药王菩萨言。善哉善哉。药王。汝愍念拥护此法师故。说是陀罗尼。于诸众生多所饶益

尔时勇施菩萨白佛言。世尊。我亦为拥护读诵受持法华经者。说陀罗尼。若此法师得是陀罗尼。若夜叉。若罗刹。若富单那。若吉遮。若鸠槃茶。若饿鬼等。伺求其短无能得便。即于佛前。而说咒曰

痤(誓螺反)隶(一)摩诃痤隶(二)郁枳(三)目枳(四)阿隶(五)阿罗婆第(六)涅隶第(七)涅隶多婆第(八)伊致(猪履反)柅(女氏反九)韦致柅(十)旨致柅(十一)涅隶墀柅(十二)涅犁墀婆底(十三)

世尊。是陀罗尼神咒。恒河沙等诸佛所说。亦皆随喜。若有侵毁此法师者。则为侵毁是诸佛已

尔时毗沙门天王护世者白佛言。世尊。我亦为愍念众生拥护此法师故。说是陀罗尼。即说咒曰

阿梨(一)那梨(二)[少/(兔-、)]那梨(三)阿那卢(四)那履(五)拘那履(六)

世尊。以是神咒拥护法师。我亦自当拥护持是经者。令百由旬内无诸衰患。尔时持国天王在此会中。与千万亿那由他乾闼婆众恭敬围绕。前诣佛所合掌白佛言。世尊。我亦以陀罗尼神咒。拥护持法华经者。即说咒曰

阿伽祢(一)伽祢(二)瞿利(三)乾陀利(四)旃陀利(五)摩蹬耆(六)常求利(七)浮楼莎柅(八)頞底(九)

世尊。是陀罗尼神咒。四十二亿诸佛所说。若有侵毁此法师者。则为侵毁是诸佛已

尔时有罗刹女等。一名蓝婆。二名毗蓝婆。三名曲齿。四名华齿。五名黑齿。六名多发。七名无厌足。八名持璎珞。九名睾帝。十名夺一切众生精气。是十罗刹女。与鬼子母并其子及眷属俱诣佛所同声白佛言。世尊。我等亦欲拥护读诵受持法华经者。除其衰患。若有伺求法师短者。令不得便。即于佛前。而说咒曰

伊提履(一)伊提泯(二)伊提履(三)阿提履(四)伊提履(五)泥履(六)泥履(七)泥履(八)泥履(九)泥履(十)楼醯(十一)楼醯(十二)楼醯(十三)楼醯(十四)多醯(十五)多醯(十六)多醯(十七)兜醯(十八)[少/(兔-、)]醯(十九)

宁上我头上。莫恼于法师。若夜叉。若罗刹。若饿鬼。若富单那。若吉遮。若毗陀罗。若犍驮。若乌摩勒伽。若阿跋摩罗。若夜叉吉遮。若人吉遮。若热病。若一日若二日若三日若四日乃至七日。若常热病。若男形若女形。若童男形若童女形。乃至梦中亦复莫恼。即于佛前。而说偈言

  若不顺我咒　　恼乱说法者
  头破作七分　　如阿梨树枝
  如杀父母罪　　亦如压油殃
  斗秤欺诳人　　调达破僧罪
  犯此法师者　　当获如是殃

诸罗刹女。说此偈已白佛言。世尊。我等亦当身自拥护受持读诵修行是经者。令得安隐离诸衰患消众毒药。佛告诸罗刹女。善哉善哉。汝等但能拥护受持法华名者。福不可量。何况拥护具足受持供养经卷。华香璎珞。末香涂香烧香。幡盖伎乐。燃种种灯。酥灯油灯。诸香油灯。苏摩那华油灯。瞻卜华油灯。婆师迦华油灯。优钵罗华油灯。如是等百千种供养者。睾帝。汝等及眷属。应当拥护如是法师。说是陀罗尼品时。六万八千人。得无生法忍

    妙法莲华经妙庄严王本事品第二十七

尔时佛告诸大众。乃往古世。过无量无边不可思议阿僧祇劫有佛。名云雷音宿王华智多陀阿伽度阿罗诃三藐三佛陀。国名光明庄严。劫名喜见。彼佛法中有王。名妙庄严。其王夫人。名曰净德。有二子。一名净藏。二名净眼。是二子。有大神力福德智慧。久修菩萨所行之道。所谓檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。方便波罗蜜。慈悲喜舍。乃至三十七品助道法。皆悉明了通达。又得菩萨净三昧。日星宿三昧。净光三昧。净色三昧。净照明三昧。长庄严三昧。大威德藏三昧。于此三昧亦悉通达。尔时彼佛欲引导妙庄严王。及愍念众生故。说是法华经。时净藏净眼二子。到其母所合十指爪掌白言。愿母往诣云雷音宿王华智佛所。我等亦当侍从亲近供养礼拜。所以者何。此佛于一切天人众中。说法华经。宜应听受。母告子言。汝父信受外道深着婆罗门法。汝等应往白父与共俱去。净藏净眼合十指爪掌白母。我等是法王子。而生此邪见家。母告子言。汝等当忧念汝父为现神变。若得见者。心必清净。或听我等往至佛所。于是二子念其父故。踊在虚空高七多罗树。现种种神变。于虚空中行住坐卧。身上出水身下出火。身下出水身上出火。或现大身满虚空中。而复现小小复现大。于空中灭忽然在地。入地如水履水如地。现如是等种种神变。令其父王心净信解。时父见子神力如是。心大欢喜得未曾有。合掌向子言。汝等师为是谁。谁之弟子。二子白言。大王。彼云雷音宿王华智佛。今在七宝菩提树下法座上坐。于一切世间天人众中。广说法华经。是我等师。我是弟子。父语子言。我今亦欲见汝等师。可共俱往。于是二子从空中下。到其母所合掌白母。父王今已信解。堪任发阿耨多罗三藐三菩提心。我等为父已作佛事。愿母见听于彼佛所出家修道。尔时二子欲重宣其意。以偈白母

  愿母放我等　　出家作沙门
  诸佛甚难值　　我等随佛学
  如优昙钵罗　　值佛复难是
  脱诸难亦难　　愿听我出家

母即告言。听汝出家。所以者何。佛难值故。于是二子白父母言。善哉父母。愿时往诣云雷音宿王华智佛所亲近供养。所以者何。佛难得值。如优昙钵罗华。又如一眼之龟值浮木孔。而我等宿福深厚生值佛法。是故父母当听我等令得出家。所以者何。诸佛难值时亦难遇。彼时妙庄严王。后宫八万四千人。皆悉堪任受持是法华经。净眼菩萨。于法华三昧久已通达。净藏菩萨。已于无量百千万亿劫。通达离诸恶趣三昧。欲令一切众生离诸恶趣故。其王夫人。得诸佛集三昧。能知诸佛秘密之藏。二子如是以方便力善化其父。令心信解好乐佛法。于是妙庄严王与群臣眷属俱。净德夫人与后宫婇女眷属俱。其王二子与四万二千人俱。一时共诣佛所。到已头面礼足。绕佛三匝却住一面

尔时彼佛为王说法示教利喜。王大欢悦。尔时妙庄严王及其夫人。解颈真珠璎珞价直百千。以散佛上。于虚空中。化成四柱宝台。台中有大宝床。敷百千万天衣。其上有佛。结加趺坐放大光明。尔时妙庄严王作是念。佛身希有端严殊特。成就第一微妙之色。时云雷音宿王华智佛告四众言。汝等见是妙庄严王于我前合掌立不。此王于我法中作比丘。精勤修习助佛道法。当得作佛。号娑罗树王。国名大光。劫名大高王。其娑罗树王佛。有无量菩萨众。及无量声闻。其国平正功德如是。其王即时以国付弟。与夫人二子并诸眷属。于佛法中出家修道。王出家已。于八万四千岁。常勤精进修行妙法华经。过是已后。得一切净功德庄严三昧。即升虚空高七多罗树。而白佛言。世尊。此我二子已作佛事。以神通变化转我邪心。令得安住于佛法中。得见世尊。此二子者是我善知识。为欲发起宿世善根饶益我故来生我家

尔时云雷音宿王华智佛告妙庄严王言。如是如是。如汝所言。若善男子善女人。种善根故。世世得善知识。其善知识。能作佛事示教利喜。令入阿耨多罗三藐三菩提。大王当知。善知识者是大因缘。所谓化导令得见佛。发阿耨多罗三藐三菩提心。大王。汝见此二子不。此二子已曾供养六十五百千万亿那由他恒河沙诸佛亲近恭敬。于诸佛所受持法华经。愍念邪见众生。令住正见。妙庄严王。即从虚空中下。而白佛言。世尊。如来甚希有。以功德智慧故。顶上肉髻光明显照。其眼长广而绀青色。眉间毫相白如珂月。齿白齐密常有光明。唇色赤好如频婆果。尔时妙庄严王赞叹佛如是等无量百千万亿功德已。于如来前一心合掌复白佛言。世尊。未曾有也。如来之法具足成就。不可思议微妙功德。教诫所行安隐快善。我从今日不复自随心行。不生邪见憍慢嗔恚诸恶之心。说是语已礼佛而出。佛告大众。于意云何。妙庄严王岂异人乎。今华德菩萨是。其净德夫人。今佛前光照庄严相菩萨是。哀愍妙庄严王及诸眷属故。于彼中生。其二子者。今药王菩萨药上菩萨是。是药王药上菩萨。成就如此诸大功德。已于无量百千万亿诸佛所殖众德本。成就不可思议诸善功德。若有人识是二菩萨名字者。一切世间诸天人民。亦应礼拜。佛说是妙庄严王本事品时。八万四千人远尘离垢。于诸法中得法眼净

    妙法莲华经普贤菩萨劝发品第二十八

尔时普贤菩萨。以自在神通力。威德名闻。与大菩萨无量无边不可称数从东方来。所经诸国普皆震动。雨宝莲华。作无量百千万亿种种伎乐。又与无数诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等大众围绕。各现威德神通之力。到娑婆世界耆阇崛山中。头面礼释迦牟尼佛。右绕七匝白佛言。世尊。我于宝威德上王佛国。遥闻此娑婆世界说法华经。与无量无边百千万亿诸菩萨众。共来听受唯愿世尊。当为说之。若善男子善女人。于如来灭后。云何能得是法华经。佛告普贤菩萨。若善男子善女人。成就四法。于如来灭后。当得是法华经。一者为诸佛护念。二者殖众德本。三者入正定聚。四者发救一切众生之心。善男子善女人。如是成就四法。于如来灭后必得是经。尔时普贤菩萨白佛言。世尊于后五百岁浊恶世中。其有受持是经典者。我当守护除其衰患令得安隐。使无伺求得其便者。若魔若魔子。若魔女若魔民。若为魔所著者。若夜叉若罗刹。若鸠槃茶。若毗舍阇。若吉遮若富单那。若韦陀罗等。诸恼人者。皆不得便。是人若行若立读诵此经。我尔时乘六牙白象王。与大菩萨众俱诣其所。而自现身。供养守护安慰其心。亦为供养法华经故。是人若坐思惟此经。尔时我复乘白象王现其人前。其人若于法华经。有所忘失一句一偈。我当教之与共读诵还令通利。尔时受持读诵法华经者。得见我身甚大欢喜。转复精进。以见我故。即得三昧及陀罗尼。名为旋陀罗尼。百千万亿旋陀罗尼。法音方便陀罗尼。得如是等陀罗尼。世尊。若后世后五百岁浊恶世中。比丘比丘尼优婆塞优婆夷。求索者。受持者。读诵者。书写者。欲修习是法华经。于三七日中应一心精进。满三七日已。我当乘六牙白象。与无量菩萨而自围绕。以一切众生所喜见身。现其人前。而为说法示教利喜。亦复与其陀罗尼咒。得是陀罗尼故。无有非人能破坏者。亦不为女人之所惑乱。我身亦自常护是人。唯愿世尊。听我说此陀罗尼咒。即于佛前。而说咒曰

阿檀地(途卖反一)檀陀婆地(二)檀陀婆帝(三)檀陀鸠舍隶(四)檀陀修陀隶(五)修陀隶(六)修陀罗婆底(七)佛驮波膻祢(八)萨婆陀罗尼阿婆多尼(九)萨婆婆沙阿婆多尼(十)修阿婆多尼(十一)僧伽婆履叉尼(十二)僧伽涅伽陀尼(十三)阿僧祇(十四)僧伽波伽地(十五)帝隶阿惰僧伽兜略(卢遮反)阿罗帝婆罗帝(十六)萨婆僧伽三摩地伽兰地(十七)萨婆达磨修波利刹帝(十八)萨婆萨埵楼驮憍舍略阿[少/兔]伽地(十九)辛阿毗吉利地帝(二十)

世尊。若有菩萨。得闻是陀罗尼者。当知普贤神通之力。若法华经行阎浮提有受持者。应作此念。皆是普贤威神之力。若有受持读诵正忆念解其义趣如说修行。当知是人行普贤行。于无量无边诸佛所深种善根。为诸如来手摩其头。若但书写。是人命终当生忉利天上。是时八万四千天女。作众伎乐而来迎之。其人即着七宝冠。于婇女中娱乐快乐。何况受持读诵正忆念解其义趣如说修行。若有人受持读诵解其义趣。是人命终为千佛授手。令不恐怖不堕恶趣。即往兜率天上弥勒菩萨所。弥勒菩萨有三十二相。大菩萨众所共围绕。有百千万亿天女眷属。而于中生。有如是等功德利益。是故智者应当一心自书若使人书。受持读诵正忆念如说修行。世尊。我今以神通力故守护是经。于如来灭后。阎浮提内广令流布使不断绝。尔时释迦牟尼佛赞言。善哉善哉。普贤。汝能护助是经。令多所众生安乐利益。汝已成就不可思议功德深大慈悲。从久远来发阿耨多罗三藐三菩提意。而能作是神通之愿守护是经。我当以神通力守护能受持普贤菩萨名者。普贤。若有受持读诵正忆念修习书写是法华经者。当知是人则见释迦牟尼佛。如从佛口闻此经典。当知是人供养释迦牟尼佛。当知是人佛赞善哉。当知是人为释迦牟尼佛手摩其头。当知是人为释迦牟尼佛衣之所覆。如是之人不复贪着世乐。不好外道经书手笔。亦复不喜亲近其人。及诸恶者。若屠儿。若畜猪羊鸡狗。若猎师。若炫卖女色。是人心意质直。有正忆念有福德力。是人不为三毒所恼。亦复不为嫉妒我慢邪慢增上慢所恼。是人少欲知足能修普贤之行。普贤。若如来灭后后五百岁。若有人见受持读诵法华经者。应作是念。此人不久当诣道场破诸魔众。得阿耨多罗三藐三菩提。转法轮击法鼓吹法螺雨法雨。当坐天人大众中师子法座上。普贤。若于后世。受持读诵是经典者。是人不复贪着衣服卧具饮食资生之物。所愿不虚。亦于现世得其福报。若有人轻毁之言。汝狂人耳。空作是行终无所获。如是罪报当世世无眼。若有供养赞叹之者。当于今世得现果报。若复见受持是经者。出其过恶。若实若不实。此人现世得白癞病。若有轻笑之者。当世世牙齿疏缺。丑唇平鼻。手脚缭戾。眼目角睐。身体臭秽。恶疮脓血。水腹短气。诸恶重病。是故普贤。若见受持是经典者。当起远迎当如敬佛。说是普贤劝发品时。恒河沙等无量无边菩萨。得百千万亿旋陀罗尼。三千大千世界微尘等诸菩萨具普贤道。佛说是经时。普贤等诸菩萨舍利弗等诸声闻。及诸天龙人非人等。一切大会皆大欢喜。受持佛语作礼而去

妙法莲华经卷第七

    妙法莲华经后序

        后秦沙门僧睿述

法华经者。诸佛之秘藏。众经之实体也。以华为名者。照其本也。称芬陀利者。美其盛也。所兴既玄。其旨甚婉。自非达识传之。罕有得其门者。夫百卉药木之英。物实之本也。八万四千法藏者。道果之原也。故以喻焉。诸华之中。莲华最胜。华尚未敷。名屈摩罗。敷而将落。名迦摩罗。处中盛时。名芬陀利。未敷喻二道。将落譬泥洹。荣曜独足以喻斯典。至如般若诸经。深无不极。故道者以之而归。大无不该。故乘者以之而济。然其大略。皆以适化为大。应务之门。不得不以善权为用。权之为化。悟物虽弘。于实体不足。皆属法华。固其宜矣。寻其幽旨。恢廓宏邃。所该甚远。岂徒说实归本毕定殊涂而已耶。乃实大明觉理。囊括古今。云佛寿无量永劫。未足以明其久也。分身无数万形。不足以异其体也。然则寿量定其非数。分身明其无实。普贤显其无成。多宝照其不灭。夫迈玄古以斯今。则万世同一日。即万化以悟玄。则千途无异辙。夫如是者。则生生未足以期存。永寂亦未可言其灭矣。寻幽宗以绝往。则丧功于本无。控心辔于三昧。则忘期于二地。经流兹土。虽复垂及百年。译者昧其虚津。灵关莫之或启。谈者乖其准格。幽踪罕得而履。徒复搜研皓首并未有窥其门者。秦司隶校尉左将军安城侯姚嵩。拟韵玄门。宅心世表。注诚斯典。信诣弥至。每思寻其文。深识译者之失。既遇鸠摩罗法师。为之传写。指其大归真。若披重霄而高蹈。登昆仑而俯盻矣。于时听受领悟之僧。八百余人。皆是诸方英秀一时之杰也。是岁弘始八年。岁次鹑火

鲁国太夫人张氏伏遇

亡夫太傅大丞相李公远忌之辰谨施净财壹贯文人福州开元寺大藏经司雕凤字函妙法莲华经七卷法华三昧等经三卷共计一十卷伏兹胜因荐严超生净土时绍兴二十一年正月十五日谨题


正法华经卷第一

    No. 263 [Nos. 262, 264]

正法华经卷第一

        西晋月氏国三藏竺法护译

    光瑞品第一

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。比丘千二百。一切无著。诸漏已尽无复欲尘。已得自在逮得己利。生死已索众结即断。一切由已获度无极。已脱于慧心解得度。名曰贤者知本际。贤者大迦叶。上时迦叶。象迦叶。江迦叶。舍利弗。大目揵连。迦旃延。阿那律。劫宾[少/兔]。牛齝。离越。譬利斯。薄拘卢。拘絺。难陀。善意。满愿子。须菩提。阿难。罗云。菩萨八万皆不退转。坚住无上正真之道。逮总持法得大辩才。常赞叹不退转法轮。供养无数百千诸佛。于无量佛殖众德本。诸佛世尊所见咨嗟。身常行慈入如来慧。善权普至大知度无极。从无数劫多所博闻。名达十方。救护无量百千众生。游于三界犹如日明。解一切法如幻如化野马影响。悉无所有住无所住。虽见终始亦无去来。既见色像本无形貌。现诸所生永无起灭。导利群黎不着三处。分别空慧无想无愿。起三脱门至三达智。无去来今现在之想。开化黎庶使了本无

其名曰溥首菩萨。光世音菩萨。大势至菩萨。常精进菩萨。不置远菩萨。宝掌菩萨。印手菩萨。药王菩萨。妙勇菩萨。宝月菩萨。月光菩萨。月满菩萨。大度菩萨。超无量菩萨。越世菩萨。解缚菩萨。宝事菩萨。恩施菩萨。雄施菩萨。水天菩萨。帝天菩萨。大导师菩萨。妙意菩萨。慈氏菩萨。如是大士八万上首。尔时天帝释与二万天子俱。日天子与无数眷属俱。月天子以宝光明普有所昭。宝光天子光耀天子俱。四大天王与万天子俱。[火*僉]明大梵自在天子与三万天子俱。梵忍迹天子与三万二千天子俱。饰干大梵与无数天子。又梵名[火*僉]光。与无数大众俱。来诣佛所稽首毕退坐一面。有八龙王。与无央数千诸龙眷属俱。四真陀罗王。慎法真陀罗王。大法真陀罗王。仁和真陀罗王。持法真陀罗王。香音神。各与营从来诣佛所。稽首毕退住一面。净身四天子。柔软天子。和音天子。美软天子。悦响天子。俱来诣佛所。前稽首毕退坐一面。四阿须伦王。最胜阿须伦。欲锦阿须伦。燕居阿须伦。吸气阿须伦。与无央数百千阿须伦人民俱。来诣佛所。前稽首毕退坐一面。四金翅鸟王。大身王。大具足王。得神足王。不可动王。俱来诣佛所。稽首毕退住一面。摩竭国王阿阇世与十子并诸营从。来诣佛所。稽首毕退坐一面。诸天龙神世人。莫不归命奉敬侍坐。尔时世尊与四部众眷属围绕而为说经。讲演菩萨方等大颂一切诸佛严净之业。说斯经已升于自然师子之床加趺而坐。三昧正受定意。名曰立无最颂。寻应所宜不见身貌不得心意。所坐立处则有瑞应。天雨意华大意华柔软音华大柔软音华。散世尊上及于大会四部之众。普佛国土六反震动。时大众会比丘比丘尼清信士清信女。天龙神鬼揵沓和阿须伦迦留罗真陀罗摩休勒人与非人。国王君主大力转轮圣王。各与营从咸悉一心瞻戴世尊。意皆愕然怪未曾有。于时佛放面口结光明。普昭东方万八千佛土。其大光明照诸佛国。靡不周遍。至于无择大地狱中。上彻三十三天。彼此世界六趣周旋。所有蒸民一切皆现。其界诸佛现在所由。此土众会悉遥见之。彼土睹斯亦复如是。十方诸佛所说经法。普遍闻焉。诸比丘比丘尼清信士清信女。修行独处者逮得德果一切表露。又诸菩萨意寂解脱。其出家者求报应行。皆亦悉现。诸佛世界灭度众圣。所建宝庙自然为现。于是弥勒菩萨心自念言。今者世尊如来至真等正觉。三昧正受现大感变。多所降伏睹未曾有。天上世间诸佛庙寺。恢阔彰显。将何所兴而有此瑞。从昔暨今未曾见也。欲问其归。孰堪发遣解斯谊乎。寻改思曰。今者大士溥首童真。所作已办靡所不达。供养过去无数诸佛。曾当瞻觐如来至真等正觉。如此瑞应欲请问之。时四部众比丘比丘尼清信士清信女。诸天龙神揵沓和阿须伦迦留罗真陀罗摩休勒。志怀犹豫得未曾有。见斯大圣无极威曜神足变化。各各发意欲问世尊决散疑网。慈氏大士见众会心。便问溥首曰。仁者惟说。今何因缘有此瑞应。大圣神足放大光明照于东方万八千土。诸佛世界自然为现。所说经法皆遥闻之。于是慈氏以颂而问溥首曰

  文殊师利　　今何以故　　导利众庶
  放演光明　　甚大威曜　　出于面门
  神变遍照　　十方[火*霍]然　　天雨众华
  纷纷如降　　意华大意　　柔软音华
  种种若干　　其色殊妙　　栴檀馨香
  悦可众心　　严净巍巍　　皆悉周遍
  今日四辈　　欣然踊跃　　于此佛土
  十方世界　　六反震动　　莫不倾摇
  于彼光明　　则照东方　　万八千土
  其晖普彻　　诸佛境土　　紫磨金色
  煌煌灼灼　　[火*僉]无不接　　国邑群萌
  莫不蒙赖　　达尽上界　　入无择狱
  众庶受生　　用无明故　　灭没堕落
  归此诸趣　　斯等黎民　　睹见因缘
  若干之趣　　今现严净　　贤明不肖
  中间品类　　吾于此住　　皆遥见之
  又睹诸佛　　而师子吼　　演说经典
  开阐法门　　消除众生　　无数之秽
  歌颂圣教　　出柔软音　　其响深妙
  令人欣踊　　各各自舍　　境界所有
  讲说譬喻　　亿载报应　　分别敷演
  于此佛法　　一切众生　　所造苦患
  以无巧便　　治老病死　　犹斯等类
  说寂灭度　　比丘当知　　贫剧恼困
  众人则处　　安雅快乐　　积累功德
  乃见圣尊　　又得逮至　　缘一觉乘
  一切令入　　于此道业　　见佛殊异
  诸所经籍　　或有志求　　无上之慧
  一切世间　　见若干形　　斯等众类
  歌咏佛德　　仁者溥首　　彼所言说
  我立住此　　今悉见闻　　及余无数
  诸亿千众　　在此游居　　吾悉睹眄
  又见佛土　　不可计数　　诸菩萨等
  如江河沙　　亿百千数　　而不减少
  建志精进　　兴发道意　　或有放舍
  诸所财业　　而行布施　　金银珍宝
  明月真珠　　车渠马脑　　奴婢车乘
  床卧机榻　　诸所珍异　　环佩璎珞
  于是具足　　皆用惠赐　　悉以劝助
  上尊佛道　　今我等类　　闻斯音声
  安住所叹　　正觉大乘　　游于三界
  而无所猗　　其人速逮　　得获斯愿
  或以诸乘　　则而施与　　诸华伎乐
  栏楯庄严　　箫成鼓吹　　音节所娱
  四事如应　　惠与奉授　　以此布施
  心不吝惜　　妻妾子孙　　所重辇舆
  或虑非常　　手足与人　　志不矜爱
  皆用惠施　　欲以慕求　　此尊佛道
  复有舍身　　给诸所有　　头眼支体
  无所遗爱　　所以布施　　用成佛道
  志愿逮获　　如来圣慧　　溥首童真
  吾瞻国王　　与眷属俱　　而出游立
  中宫后妃　　婇女贵人　　族姓娱乐
  俱礼佛身　　众庶朋党　　悉诣导师
  而于法王　　启问经典　　则除俗服
  下其须发　　而被袈裟　　以为法式
  我睹若干　　诸菩萨众　　比丘知友
  顿止山岩　　独处闲居　　解畅空无
  或有受经　　而读诵赞　　吾复瞻见
  开士之党　　英雄俦疋　　出入山谷
  专精思惟　　历察众相　　分别讲说
  演诸佛乘　　捐弃爱欲　　永使无余
  常自纂修　　悕仰正行　　安住诸子
  不离闲居　　则便逮得　　成五神通
  高妙之士　　志平等句　　向诸导师
  恭敬叉手　　心怀踊跃　　歌咏佛德
  以数千偈　　叹人中王　　睹无所畏
  志踊调和　　晓了分别　　出家之业
  咨禀经典　　于两足尊　　所闻频数
  寻即执玩　　安住众子　　先自修已
  我又遥见　　诸佛孙息　　为无数亿
  人民讲法　　而现报应　　兆载难计
  志怀欣喜　　自归正法　　劝助开化
  无数菩萨　　降伏众魔　　秉势官属
  而雷击扣　　于此法鼓　　善逝典诰
  我又览历　　诸天人神　　所共宗奉
  安住诸子　　不以奇雅　　益用寂然
  履行定隐　　无所猗着　　犹如师子
  开化度众　　令发道意　　众生在居
  手执所供　　心怀悦豫　　佥然俱诣
  又诸佛子　　立于精进　　弃捐欲尘
  常得自在　　建志经行　　游诸树间
  心愿勤修　　根求佛道　　而护身口
  常行清净　　禁戒安隐　　不畏生死
  于彼秉心　　具足诸行　　以斯禁戒
  寤诸不觉　　最胜之子　　据忍辱力
  为诸贡高　　卑下谦顺　　轻毁骂詈
  若挝捶者　　其求佛道　　默然不校
  吾或复观　　菩萨之众　　一切弃离
  调戏伎乐　　与诸力势　　亲友等俱
  其心坚固　　平如虚空　　蠲除诸秽
  愦乱之意　　建立一心　　消灭隐盖
  禅思思惟　　亿百千岁　　布施立意
  求尊佛道　　或自割损　　多所惠润
  刈除贪嫉　　闲不怀懅　　饮食供具
  所当得者　　及无数人　　诸病医药
  又复施与　　衣被服饰　　檀已济裸
  无所藏积　　与营从俱　　面见最胜
  在上化立　　亿百千供　　所造珍宝
  及栴檀香　　多有床座　　明珠诸藏
  现在目前　　奉上安住　　其宝之价
  直亿百千　　所睹园观　　树叶华实
  具足鲜净　　悦可人意　　夙夜修行
  兼加进献　　上人正士　　诸声闻等
  所可慧益　　品列如斯　　杂种若干
  欢喜济乏　　深自欣庆　　而建道行
  以此所施　　愿求尊觉　　或有得人
  寂然法谊　　察诸报应　　众亿兆载
  发起民庶　　使其悔过　　令舍亿宝
  志愿佛道　　晓了观察　　不秘吝法
  灭除三事　　寂等如空　　安住之子
  悉无所著　　斯等智慧　　求尊佛道
  溥柔软音　　吾复睹见　　诸灭度佛
  安住开化　　诸所现在　　大菩萨众
  咸共奉敬　　最胜舍利　　吾觐佛庙
  亿千之数　　凡难限计　　如江河沙
  在于亿土　　常见尊戴　　诸所化现
  最胜由已　　七宝自然　　清净而现
  具足里数　　二十五万　　诸盖幢幡
  各有数千　　广长周匝　　各二千里
  其盖妙好　　殊异严净　　所在众香
  珍宝自然　　诸果芬馥　　伎乐和雅
  鬼神罗刹　　肃恭人尊　　安住诸子
  所兴感动　　以用供养　　舍利若斯
  今此佛庙　　昱铄璨丽　　普布香华
  如昼度树　　于斯人众　　无数亿千
  悉遥睹见　　炜晔斑斓　　衣毛为竖
  眷属驰造　　欲见最胜　　显发光明
  人中之上　　演大光耀　　妙哉明哲
  离垢无漏　　乃能阐现　　如斯弘晖
  示诸佛土　　无央数千　　见此瑞应
  得未曾有　　如是畴类　　诸大变化
  唯愿溥首　　具说斯谊　　吾今钦羡
  及诸佛子　　于四部众　　心怀悦豫
  渴仰仁者　　兼见瞻察　　今日安住
  何所因由　　奋大光明　　而从口出
  解散狐疑　　劝发欣跃　　何故佛现
  无极大光　　如斯所变　　当有所感
  安住之子　　愿用时说　　大圣所成
  此微妙法　　在于道场　　正士敷演
  世雄导师　　所由方面　　愿为分别
  此诸菩萨　　欲见佛土　　无央数千
  群生伦品　　众宝严净　　诸佛自现
  无量明目　　凡新学者　　得无犹豫
  诸最胜子　　普共启问　　悦诸人民
  天神罗刹　　四部之众　　一切戴仰
  今者溥首　　惟具分别

于是溥首告慈氏。诸大士众会者族姓子女。吾心惟忖。今者如来。当敷大法演无极典。散大法雨击大法鼓。吹大法螺讲无量法。又自追忆。乃从过去诸佛世尊见斯像瑞。彼如来等所放光明亦复若兹。犹斯识察知讲大法。诸如来至真等正觉。欲令众生听无极典故现斯应。所以者何。世尊欲令群生洗除俗秽闻服佛法。现弘大变光明神化。又念往故无央数劫不可思议无能度量时。有如来。号日月灯明至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。演说经典。初语亦善中语亦善竟语亦善。分别其谊微妙具足。究竟清净修梵行。为声闻乘讲陈圣谛。则令众庶度生老死忧恼众患入近无为。为诸菩萨大士之众。显扬部分分别六度无极无上正真。又族姓子。其日月灯明如来灭度之后。次复有佛。亦号日月灯明。灭度之后。次复有佛。亦号日月灯明。灭度之后。复次有佛。亦号日月灯明。如是等伦八十如来。皆同一号日月灯明。胄绍一姓。若斯之比二万如来。佛语莫能胜。彼二万如来最前兴者。号日月灯明。最后起者。故复名曰日月灯明如来至真等正觉。其佛说经。初语中语竟语皆善。分别其谊微妙具足净修梵行。为诸声闻讲说四谛十二因缘。生老病死愁戚诸患。皆令灭度究竟无为。为诸菩萨讲六度无极。使逮无上正真道至诸通慧。其日月灯明如来未出家时有八子。一名有志。二曰善意。三曰加劝。四曰宝志。五曰持意。六曰除慢。七曰响意。八曰法意。是八太子则如来子神足弘普。时一一子各各典主四域天下。其土丰殖治以正法无所侵枉。而见世尊弃国修道逮最正觉适闻得佛。寻皆离俗不顾重位。诣世尊所悉为沙门。皆志无上正真之道。尽为法师常修梵行。于无央数百千诸佛殖众德本。又曰。阿逸。时日月灯明。劝发菩萨护诸佛法。而为众会讲演大颂方等正经。时彼世尊于座寂然。以无量颂三昧正受即不复现。无身无意都不可得心无所立。世尊适三昧已。天雨意华大意华柔软音华大软音华。而散佛上及于大会四部之众。应时其地六反震动。国中人民各取天华复散佛上。四部弟子诸天世人愕然疑怪。其佛三昧未久威神德本面出一光其光。普照东方万八千佛土。靡不周遍。诸佛国土所可造作悉自然现。亦如今日诸佛土现。彼时世尊与二十亿诸菩萨俱。于众会中讲说经法。诸菩萨大士睹大光明普照世间。而其佛世有菩萨。名曰超光。侍者十八人。有一菩萨而独劳懈。名曰名闻。佛三昧正受。从三昧起为超光菩萨讲正法华方等之业。诸菩萨行皆说佛法。一处安坐具足六十劫说斯经典。众会亦然。身不倾动心无因缘。又彼世尊六十中劫。因为诸会说法。听者一无疲厌心不劳扰。日月灯明六十劫中。为诸菩萨讲演法华方等正经。便自说言。当般泥洹。告天世人诸梵魔众沙门梵志阿须伦鬼神诸比丘等。察于其时。如来夜半至无余界当般泥洹。授其菩萨首藏之决。告诸比丘。吾灭度后首藏开士。当逮无上正真道成最正觉。号离垢体如来至真等正觉。佛授决已。寻于夜半而取灭度。彼世尊子等类八人。皆归超光菩萨大士而顺教敕。咸志无上正真之道。见无央数亿载诸佛。供养奉侍悉逮正觉。最后兴者号曰法事。十八人中有一菩萨。于利无节殷勤求供。尊己贪秽多于三病。分别句谊中而忽忘。便得于闲不复懅务。时族姓子得名闻定。以斯德本从不可计亿百千佛。求愿得见悉奉众圣。溥首谓莫能胜。欲知尔时比丘法师号超光者。则吾是也。其名闻菩萨大士而懈怠者。则莫能胜是。是故当知。见此世尊所见瑞应放其光明。吾观察之。今日大圣当为我等讲正法华方等典籍。于是溥首菩萨。欲重现谊说此颂曰

  吾自忆念　　往古过去　　不可思议
  无央数劫　　最胜造谊　　智慧无上
  其号名曰　　日月灯明　　彼讲说法
  圣达无极　　开化众生　　不可计忆
  劝助发起　　无数菩萨　　不可思议
  亿百千人　　于时如来　　尊者诸子
  皆为幼童　　见佛导师　　则从所尊
  悉作沙门　　弃捐爱欲　　一切所有
  导利世者　　为讲说法　　所演经典
  名无量颂　　而号最上　　厥谊如此
  开化黎庶　　亿千之数　　大圣适说
  斯经典已　　能仁至尊　　处于法床
  加趺而坐　　寻有瑞应　　三昧正受
  名无量颂　　于时即雨　　大意音华
  又现电[火*僉]　　大雷音声　　诸天鬼神
  住于虚空　　一心奉敬　　人中之尊
  寻则感动　　诸佛国土　　从其眉间
  显出妙[火*僉]　　放斯光明　　无量难限
  不可计人　　怪未曾有　　其明遍照
  东方佛土　　周万八千　　亿数世界
  常以应时　　多所分别　　示于众生
  终始根原　　或有佛土　　立诸宝盖
  光如琉璃　　及若水精　　以导师光
  威神之曜　　现若干种　　瑰异雅丽
  诸天人民　　并鬼神龙　　揵沓和等
  惊喜希有　　其有专精　　奉事安住
  彼诸世界　　皆自然现　　又见诸佛
  各各自由　　端正姝妙　　紫磨金色
  如琉璃中　　而有众宝　　在于会中
  为雨法教　　其诸声闻　　不可称计
  嗟叹无量　　安住弟子　　一切导师
  一一世界　　又光明曜　　皆悉巍巍
  常行精进　　戒无所犯　　忍辱之力
  犹明月珠　　世尊诸子　　现无央数
  游于间居　　山林旷野　　一切禅定
  不起因缘　　若有加害　　不兴嗔恨
  诸菩萨众　　如恒沙数　　安住光明
  感动若斯　　心念无常　　不为放逸
  忍辱乐禅　　不舍一心　　有安住子
  普悉来现　　自伏其志　　慕尊佛道
  立审谛住　　其心寂然　　各以缘便
  多所开化　　无数佛界　　广说经法
  世尊所为　　感应如此　　又睹大圣
  犹如船师　　所出光明　　蔽日月晖
  一切众生　　所立欢喜　　各各问言
  此何感变　　天人所奉　　从三昧起
  未久之顷　　导师便坐　　其菩萨者
  名曰超光　　而作法师　　佛为解说
  世间之眼　　蠲除众趣　　唯安悦我
  示诸种大　　为我分别　　于斯经法
  吾愍众生　　以是教化　　建立劝助
  诸菩萨众　　闻佛教诏　　欣然嗟叹
  于时世尊　　说大经法　　所演具足
  六十中劫　　于一床上　　结加趺坐
  导师化世　　说殊特教　　彼诸佛等
  皆已灭度　　其法师者　　超光仁人
  最胜所演　　讲说经典　　无央数人
  皆悉欢喜　　惟愿大圣　　分别解之
  在诸天上　　及与世间　　讲说经典
  自然之谊　　显示众庶　　此正法华
  告诸比丘　　吾已时到　　当于夜半
  而取灭度　　修无放逸　　坚固其心
  吾已解说　　诸经法教　　大圣神通
  难得值遇　　于无央数　　亿那术劫
  常当供养　　无量佛子　　忧恼诸患
  甚亦苦剧　　时闻世尊　　所现章句
  观于无为　　采习言教　　值睹人尊
  所见安慰　　会无数人　　不可思忆
  比丘莫惧　　吾当泥曰　　我去然后
  已不复现　　第二菩萨　　号曰首藏
  无有诸漏　　无所不入　　当究竟逮
  尊上佛道　　所号名曰　　离垢之体
  即寻于此　　夜半之时　　便取灭度
  尽执光耀　　其佛舍利　　而广分布
  即起塔庙　　无量亿载　　诸比丘等
  及比丘尼　　志悉慕求　　上尊佛道
  不可称限　　如江河沙　　常修精进
  尊安住教　　尔时比丘　　为法师者
  超光大人　　执持经典　　一坐之顷
  演说尊法　　则具足满　　八十中劫
  彼时侍从　　有十八人　　教化度之
  皆蒙安隐　　此等值见　　无数亿佛
  至心供养　　诸大圣尊　　常尊奉教
  柔顺之法　　于诸世界　　皆各成佛
  尊得自在　　受持无量　　各各授决
  使逮正觉　　于时诸佛　　皆悉究竟
  定光世尊　　最后得佛　　大仙日月
  开化圣众　　导师所化　　巨亿百千
  安住所兴　　诸大威化　　法师超光
  则吾身是　　尔时侍从　　志懈怠者
  求索利养　　亲属交友　　志所愿求
  但慕名闻　　周旋行来　　诣诸族姓
  舍置所学　　不讽诵读　　彼时不肯
  分别而说　　以故其人　　唐载此名
  于佛法教　　欲使称誉　　其人由此
  所造德本　　在住世尊　　而有瑕疵
  值见诸佛　　亿千之数　　积累功德
  广普大圣　　专修正行　　得最顺忍
  又睹世尊　　于斯能行　　然于将来
  最后世时　　当得无上　　尊佛正道
  成至世尊　　号曰慈氏　　教化众生
  无数亿千　　逮得勇猛　　所在自由
  安住灭度　　仁顺其教　　于彼世时
  比像如是　　我身尔时　　则为法师
  是以之故　　行哀如此　　过世睹见
  如是之类　　安住之仁　　变动若兹
  本第一察　　如斯瑞应　　彼时世尊
  无量明目　　诸释中王　　现第一谊
  今者欲说　　正法华典　　吾过世时
  所闻道业　　今日变化　　而得具足
  诸导师尊　　行权方便　　大释师子
  建立兴发　　讲说经法　　自然之教
  诸怀道意　　悉叉手归　　导利世者
  今者分别　　当雨法雨　　柔软法教
  普润饱满　　履道意者　　其有诸天
  入于无为　　志怀狐疑　　而有犹豫
  若有菩萨　　求斯道意　　今当蠲除
  吾我之想

    正法华经善权品第二

于是世尊从三昧觉。告贤者舍利弗。佛道甚深。如来至真等正觉。所入之慧难晓难了不可及知。虽声闻缘觉。从本亿载所事归命。无央数劫造立德本。奉遵佛法殷勤劳苦精进修行。尚不能了道品之化。又舍利弗。如来观察人所缘起。善权方便随谊顺导。猗靡现慧各为分别。而散法谊用度群生。以大智慧力无所畏。一心脱门三昧正受。不可限量。所说经典不可及逮。而如来尊较略说耳。大圣所说得未曾有巍巍难量。如来皆了诸法所由。从何所来诸法自然。分别法貌众相根本知法自然。于时世尊欲重解谊。更说颂曰

  世雄不可量　　诸天世间人
  一切众生类　　焉能知导师
  离垢解脱门　　寂然无所畏
  如诸佛法貌　　莫有逮及者
  本从亿诸佛　　依因而造行
  入于深妙谊　　所现不可及
  于无央数劫　　而学佛道业
  果应至道场　　犹如行慈愍
  使我获斯慧　　如十方诸佛
  诸相普具足　　众好亦如是
  其身不可见　　亦无有言说
  察诸群黎类　　世间无与等
  若说经法时　　有能分别解
  其惟有菩萨　　常履怀信乐
  假使诸佛　　弟子之众　　所作已办
  如安住教　　尽除疾病　　执御其心
  不能达彼　　若干种慧　　设令于斯
  佛之境界　　皆以七宝　　充满其中
  以献安住　　神明至尊　　欲解此慧
  终无能了　　正使十方　　诸佛刹土
  诸明哲者　　悉满其中　　及吾现在
  诸声闻众　　一切具足　　亦复如是
  一时普会　　共思惟之　　计安住慧
  无能及知　　佛之智慧　　无量若斯
  欲知其限　　莫能逮者　　诸缘一觉
  无有众漏　　诸根通达　　总摄其心
  假使十方　　悉满中人　　譬如甘蔗
  若竹芦苇　　悉俱合会　　而共思惟
  欲察知佛　　所说解法　　于亿那术
  劫载计念　　未曾能知　　及法利谊
  新学发意　　诸菩萨等　　假使供养
  无数亿佛　　讲说经法　　分别其谊
  复令是等　　周满十方　　其数譬如
  稻麻丛林　　在诸世界　　滋茂不损
  悉俱合会　　而共思惟　　世尊所明
  睹诸法本　　不可思议　　无数亿劫
  如江河沙　　不可限量　　心无变异
  超越智慧　　欲得知者　　非其境界
  无数菩萨　　皆不退转　　无崖底劫
  如恒边沙　　一心专精　　悉共思惟
  此之等类　　亦不堪任　　诸佛圣明
  不可及逮　　一切漏尽　　非心所念
  独佛世尊　　能解了知　　分别十方
  诸佛世界　　告舍利弗　　安住所说
  唯佛具足　　解达知彼　　最胜导利
  悉畅了识　　说无上谊　　以来久远
  佛今日告　　诸声闻众　　缘觉之乘
  如所立处　　舍置已逝　　入泥曰者
  所可开化　　各各得度　　佛有尊法
  善权方便　　犹以讲说　　法化世间
  常如独步　　多所度脱　　以斯示现
  真谛经法

尔时大众会中。一切声闻阿罗汉等。诸漏已尽知本际党。千二百众及弟子。学比丘比丘尼清信士清信女诸声闻乘。各各兴心念。世尊何故。殷勤咨嗟善权方便。宣畅如来深妙经业。致最正觉慧不可及。声闻缘觉莫能知者。如今世尊乃演斯教。于是佛法无逮泥洹。虽说此经。吾等不解谊之所趣。贤者舍利弗。见四部众心怀犹豫。欲为发问决其疑网。冀并被蒙。前白佛言。唯然世尊。今日如来何故独宣善权方便。以深妙法逮最正觉。道德巍巍不可称限。时舍利弗以偈颂曰

  乐慧圣大尊　　久宣如是教
  力脱门禅定　　所奉无央数
  赞扬佛道场　　无敢发问者
  独咨嗟真法　　无能启微妙
  显现大圣法　　自叹誉其行
  智慧不可限　　欲分别深法
  今鄙等怀疑　　说道诸漏尽
  其求无为者　　皆闻佛所赞
  其求缘觉者　　比丘比丘尼
  诸天龙鬼神　　揵沓摩休勒
  及余诸等类　　心各怀犹豫
  请问两足尊　　大德愿解说
  一切诸声闻　　安住所教化
  大圣见叹誉　　我独度无极
  鄙意在沉吟　　不能自决了
  究竟至泥洹　　今复闻此说
  唯愿演分别　　雷震音现说
  如今所发教　　犹若师子吼
  最胜诸子等　　归命皆叉手
  欲闻正是时　　愿为分别说
  诸天龙众　　鬼神真陀　　无数百千
  如江河沙　　而悉佥曰　　供养世尊
  咸欲发问　　于尊佛道　　国主帝王
  转轮圣王　　悉共同心　　亿百千垓
  一切恭敬　　叉手而立　　德何因盛
  众行具足

尔时世尊。告舍利弗。且止且止用问此谊。所以者何。诸天世人闻斯说者。悉当恐怖。时舍利弗。复重启曰。唯愿大圣。如是谊者加哀说之。所以者何。于此众会有无央数亿百千载蚑行喘息蜎蜚蠕动群生之类。曾见过佛知殖众德。闻佛所说。悉当信乐受持奉行。时舍利弗以偈颂曰

  愿人中王　　哀恣意说　　此出家者
  众庶亿千　　恭肃安住　　钦信慧谊
  斯之等类　　必皆欣乐

于时世尊。叹舍利弗。如是至三。告曰勿重。诸天世人悉怀慢恣。比丘比丘尼坠大艰难。世尊以偈告舍利弗

  且止且止　　用此为问　　斯慧微妙
  众所不了　　假使吾说　　易得之谊
  愚痴闇塞　　至怀慢恣

贤者舍利弗复白佛言。唯愿大圣以时哀说。无央数众。昔过世时曾受佛教。以故今者思闻圣音。闻者则信多所安隐。冀不疑慢。时舍利弗以偈颂曰

  我佛长子　　今故启劝　　愿两足尊
  哀为解说　　今有众生　　无数亿千
  悉当信乐　　圣尊所诏　　会致本德
  决诸疑网　　往古长夜　　曾被训诲
  是等叉手　　恭肃侧立　　必当钦乐
  于斯法谊　　我之等类　　千二百人
  及余众党　　求尊佛道　　假令见闻
  安住言教　　寻当欢喜　　兴发大意

于时世尊见舍利弗三反劝助。而告之曰。尔今殷勤所启至三。安得不说。谛听谛听善思念之。吾当解说。世尊适发此言。比丘比丘尼清信士清信女五千人等。至怀甚慢。即从坐起稽首佛足舍众而退。所以者何。慢无巧便。未得想得未成谓成。收屏盖藏衣服卧具摩何而去。世尊默然亦不制止。又舍利弗。众会辟易有窃去者。离广大谊声味所拘。又舍利弗。斯甚慢者退亦佳矣。如来云何说此法乎。譬灵瑞华时时可见。佛叹斯法久久希有。尔等当信如来诚谛所说深经。谊甚微妙言辄无虚。若干音声现诸章句。各各殊别人所不念。本所未思如来悉知。所以者何。正觉所兴世嗟叹一事为大示现皆出一原。以用众生望想果应劝助此类出现于世。黎元望想希求佛慧出现于世。蒸庶望想如来宝决出现于世。以如来慧觉群生想出现于世。示寤民庶八正由路使除望想出现于世。以故当知。正觉所兴悉为一谊。以无极慧而造大业。犹一空慧。以无盖哀兴出于世。如佛所行。所化利谊亦复如是。而为说法。教诸菩萨现真谛慧。以佛圣明而分别之。转使增进唯大觉乘。无有二乘况三乘乎。十方世界诸佛世尊。去来现在亦复如是。以权方便若干种教。各各异音开化一切。而为说法皆兴大乘。佛正觉乘诸通慧乘。又舍利弗。斯众生等悉更供养诸过去佛。亦曾闻法。随其本行获示现谊。吾见群生本行不同。佛观其心所乐若干。善权方便造立报应。而讲法谊。皆为平等正觉大乘。至诸通慧道德一定。无有二也。十方世界等无差特。安得三乘。又舍利弗。设如来说众生瑕秽一劫不竟。今吾兴出于五浊世。一曰尘劳。二曰凶暴。三曰邪见。四曰寿命短。五曰劫秽浊。为此之党本德浅薄悭贪多垢故。以善权现三乘教。劝化声闻及缘觉者。若说佛乘终不听受不入不解。无谓如来法有声闻及缘觉道深远诸难。若比丘比丘尼。已得罗汉自已达足。而不肯受无上正真道教。定为诽谤于佛乘矣。虽有是意佛平等训。然后至于般泥洹时。诸甚慢者乃知之耳。所以者何。又诸比丘为罗汉者。无所志求诸漏已尽。闻斯经典而不信乐。若灭度时。如来面现诸声闻前大圣灭度不以斯行。令受持说方等颂经。寻于异佛至真等正觉决其狐疑。然后于彼乃当笃信。如来言诚正有一乘。无有二也。世尊颂曰

  比丘比丘尼　　心怀甚慢恣
  诸清信士女　　五千人不信
  不自见瑕秽　　奉诫有缺漏
  多获倾危事　　而起愚騃意
  反行求杂糅　　悉无巧方便
  诸佛最胜禅　　缘此得闻法
  供养清净慧　　众会俨然住
  一切受恩教　　逮志立见要
  舍利弗听此　　佛为人中上
  谛觉了诸法　　为说若干教
  善权方便　　亿百千垓　　随人心行
  而为说法　　罪福之事　　若干不同
  从其宿世　　各得报应　　此诸众生
  心各各异　　所造众多　　缠绵结缚
  因缘诸见　　亿百千垓　　一切品类
  瑕秽如是　　如来大圣　　说此经典
  所言至诚　　终无虚欺　　从始引喻
  若干无数　　如有所说　　寻为分别
  其有不乐　　正觉明者　　于无数佛
  不造立行　　愚痴生死　　甚多苦患
  故为斯等　　现说泥洹　　大圣所兴
  行权方便　　因劝化之　　使入佛慧
  如佛道教　　兴显于世　　吾始未曾
  为若等现　　何故愚冥　　睹于导师
  见自患厌　　乃为分别　　今乃得闻
  演于平等　　以故得说　　佛所决了
  于我法教　　诸新学者　　佛以圣慧
  行权方便　　所可分别　　为众生故
  欲开化之　　故示此谊　　欲知佛道
  常调清净　　仁乐圣典　　实为要妙
  在诸佛所　　所作已办　　故为斯类
  说方等经　　志性和顺　　行能具足
  是等勇猛　　亲近圣教　　则为彼说
  德最弘衍　　于当来世　　慈愍哀伤
  一切闻之　　欣然咨嗟　　我等成佛
  亦当如是　　缘是行故　　世世端正
  而当玩习　　是方等经　　其有逮闻
  无极圣教　　斯等乃为　　佛之弟子
  假使得听　　佛一偈者　　皆成正觉
  终无有疑　　佛道有一　　未曾有二
  何况一世　　而当有三　　除人中上
  行权方便　　以用乘故　　开化说法
  欲得讲说　　佛之深慧　　善权方便
  导师光明　　唯有一乘　　岂宁有二
  下劣乘者　　当求殊特　　诸佛所觉
  常皆如应　　至尊所在　　莫敢能当
  其力一心　　若顺脱门　　皆立众生
  于此道教　　诸佛最胜　　无有瑕疵
  尊无等伦　　现平等觉　　如是示以
  众生善法　　世尊因而　　劝立是乘
  所在安和　　诱进稽首　　诸境界名
  于此当行　　断除一切　　诸凶暴法
  是故号佛　　则大勇猛　　今已造立
  若干种相　　眷属围绕　　演出法光
  无数众生　　亿百千垓　　为讲说法
  自然之印　　告舍利弗　　我见如是
  今当奈此　　群生类何　　三十二相
  颜容殊妙　　犹得自在　　无所拘碍
  而吾所观　　若所思念　　如往古时
  有可志愿　　皆具足成　　深微妙事
  分别讲说　　等至佛位　　语舍利弗
  佛言至诚　　以何等事　　寤觉众生
  假使为说　　不能解了　　不肯启受
  善言至诚　　即时心念　　如是之谊
  前往古世　　行不可议　　今日乃逮
  得本所愿　　已断爱欲　　除大阴雨
  众庶坐欲　　坠于恶趣　　安住秽厌
  众诸秽垢　　黑冥之法　　数数增长
  薄德之夫　　患苦所恼　　为诸邪见
  之所羁系　　有此无异　　不有不无
  具足依倚　　六十二见　　当住于斯
  根着所有　　势力薄少　　而怀恐惧
  未曾得闻　　佛之音声　　恒当堕落
  不离三处　　亿百千生　　不能解法
  佛了善权　　卓然难及　　为说勤苦
  断其根原　　众生之类　　诸见所恼
  佛故导示　　便至泥洹　　吾所以故
  常解灭度　　令一切法　　皆至寂然
  又复过去　　诸佛之子　　当来之世
  得成最胜　　今我如是　　行权方便
  各令休息　　说三乘教　　其乘有一
  亦不非一　　大圣世尊　　故复说一
  诸有蒸民　　兴发沉吟　　意虑愦乱
  狐疑犹豫　　如来所说　　终无有异
  慧乘有一　　未曾有二　　其有往古
  世雄导师　　亿百千佛　　诸灭度者
  或有过去　　无央数劫　　计其限量
  不可称度　　谓此一切　　人中之上
  讲说经法　　无数清净　　所可作为
  报应譬喻　　行权方便　　亿百千垓
  普为众生　　示现一乘　　是故说道
  度未度者　　常为人说　　平等道慧
  开化众庶　　亿百千垓　　又复见异
  若干大圣　　为讲分别　　是大尊法
  本性清净　　乃信解之　　若在天上
  世间亦然　　其有闻经　　若听省者
  彼诸众生　　所获安隐　　常行布施
  其戒具足　　忍辱无乏　　斯行平等
  精进一心　　修善勇猛　　于此经典
  遵奉智慧　　或有建立　　若干种德
  斯等皆当　　成得佛道　　其有灭度
  诸所如来　　彼时所有　　一切众生
  忍辱调意　　得至大安　　斯等皆当
  成得佛道　　假使供养　　诸佛舍利
  大圣最胜　　及灭度者　　兴立佛庙
  众亿百千　　黄金白银　　水精琉璃
  若以马瑙　　造作塔寺　　车渠异宝
  及明月珠　　若以墼泥　　立作形像
  斯等皆当　　成得佛道　　假使以石
  用作佛庙　　或以栴檀　　若木蜜香
  设令塔寺　　立天尊像　　材木刻镂
  彩画众饰　　或有奉戒　　口言至诚
  若复竖立　　最胜庙寺　　在于居室
  讽诵经典　　处于旷野　　深谷中立
  为数亿人　　而师子吼　　现有十方
  诸佛庙寺　　中有舍利　　童子对舞
  斯等皆当　　成得佛道　　若为如来
  作宝模像　　三十二相　　执持殊最
  假使复有　　诵经说谊　　斯等皆当
  成得佛道　　设为安住　　兴立彩像
  后致七宝　　觉意道路　　其光遍照
  通彻众行　　斯等皆当　　成得佛道
  若复以铜　　刻镂碧玉　　为大圣尊
  立殊特形　　设以经字　　载妙素帛
  斯等皆当　　成得佛道　　若缮坏寺
  修立形像　　功德志性　　有百福相
  出家学法　　书佛经卷　　斯等皆当
  成得佛道　　设使各各　　作奇异行
  除弃一切　　所乐调戏　　正士童子
  聪达解谊　　而不嘲话　　言不虚诞
  悉亦自致　　为大慈哀　　一切皆当
  逮得佛道　　即使得度　　亿千群萌
  无数菩萨　　神通三昧　　设为是等
  安住舍利　　兴立塔寺　　彩画形像
  涂治垩饰　　书经着壁　　供上华香
  勋散塔像　　假令伎乐　　歌诵佛德
  箫成鼓舞　　节奏哀和　　赞美嬉笑
  又加肃敬　　以若干事　　遵修供奉
  弹琴箜篌　　铙镜应弦　　筝笛吹笙
  激发妙音　　皆以一心　　不为众吏
  缘是悉致　　寂然悦豫　　若以挹洒
  净扫塔寺　　用柔软水　　蜜浆饮施
  杂香垩涂　　理作乐器　　归命安住
  供养最胜　　以若干物　　供上舍利
  如来灭度　　少多肃敬　　假使一反
  鼓伎拊弄　　一切皆当　　得成佛道
  设令得见　　安住画像　　执持一华
  进上灵模　　以恭敬意　　笃信无疑
  当稍稍见　　无数亿佛　　其有人众
  叉手佛庙　　具足一反　　绕旋自归
  礼拜大圣　　嗟叹稽首　　所行如是
  身无垢染　　当渐渐觐　　无数亿佛
  于诸导师　　多造利谊　　假使有持
  舍利供养　　口宣音言　　南摸佛尊
  其乱心者　　若说此言　　斯等皆当
  逮尊佛道　　灭度因缘　　尽除毒火
  此等皆当　　逮成佛道　　于众会中
  建立信者　　尔时安住　　当济此伦
  假使有人　　闻此法名　　斯等皆当
  逮成佛道　　若复当来　　无数亿佛
  不可思议　　无能限量　　是等上胜
  世雄导师　　当为讲说　　善权慧事
  是等大人　　行权方便　　当得成佛
  导世圣雄　　所以开化　　亿数众生
  禅定智慧　　以消诸漏　　得闻此法
  未有一人　　群萌品类　　岂弘了觉
  诸大圣法　　皆本所愿　　行佛道时
  最后究竟　　无量法门　　亿千垓数
  当来最胜　　之所讲说　　诸如来尊
  常宣布法　　是则得见　　诸佛正教
  诸佛本净　　常行自然　　此诸谊者
  佛所开化　　如两足尊　　乃分别道
  故畅斯教　　一乘之谊　　诸法定意
  志怀律防　　常处于世　　演斯赞颂
  每同赞说　　善权方便　　诸最胜尊
  志意弘大　　其有供养　　天人所归
  今现在佛　　如江河沙　　欲利安隐
  一切群黎　　斯等正觉　　亦说佛尊
  所可演说　　善权方便　　以若干教
  开化令入　　皆共咨嗟　　是一乘道
  寂然之地　　无有二上　　欲知众生
  本际之行　　从其过去　　志性所猗
  料简精进　　而观本原　　诸未脱者
  为分别说　　众导师力　　若干因缘
  攀喻引譬　　而为示现　　探睹群生
  种种所乐　　若干部音　　而开化之
  今我如是　　为人中王　　兴发黎庶
  安隐利谊　　种种音声　　亿百千垓
  故为示现　　斯佛大道　　吾所说法
  若干种变　　知诸萌类　　心所好乐
  若干色像　　寻令悦豫　　缘其智慧
  训以道力　　吾为法王　　而遍观见
  诸愚冥者　　离智慧德　　崩坠生死
  坑圹险谷　　不得解脱　　来世艰难
  爱欲所系　　驰如流沙　　诸尘劳垢
  今日自在　　大圣威神　　觉无所来
  诸法未曾　　致众患苦　　群萌之类
  默在六堑　　坚住邪见　　不可动转
  在于苦恼　　处危崄径　　吾发大哀
  愍此愚痴　　安隐求至　　处于道场
  具足七日　　坐于草蓐　　即思惟谊
  当何所兴　　寻时即断　　彼世慢恣
  观察尊树　　目未曾眴　　吾又经行
  于斯树下　　因奇特慧　　得未曾有
  众生轮转　　于大无明　　于时梵天
  则知佛意　　帝释四天　　诸护世者
  大神妙天　　及善天子　　无数亿千
  皆共觉知　　一切叉手　　俨然恭肃
  我时自念　　当奈之何　　假令吾叹
  佛之道德　　群黎品类　　莫肯受化
  诸闇冥者　　便当谤毁　　适毁此已
  趣非法地　　吾初未曾　　说奇妙法
  常乐余事　　当何兴立　　等观往古
  诸佛所为　　彼时圣众　　行权方便
  吾今宁可　　以此佛道　　分为三乘
  而开化之　　初成佛时　　作此思惟
  又有十方　　诸佛世尊　　其大圣众
  悉各自现　　音赞善哉　　我等欣豫
  快哉能仁　　世雄导师　　斯为正法
  执御当然　　乃能思惟　　善权方便
  诸大圣典　　亦学救世　　吾等为佛
  履上迹时　　分为三乘　　而开化之
  下劣不肖　　志怀羸弱　　观诸佛兴
  卒不肯信　　吾等犹此　　兴立摄济
  以权方便　　而为示现　　嗟叹称美
  获果之证　　又复劝助　　无数菩萨
  尔时佛身　　听诸尊叹　　寻则解了
  诸大圣音　　弘妙之士　　心欣悦豫
  今大神通　　分别名色　　于时余等
  当遵其行　　如诸导师　　之所言说
  我时比丘　　亦持斯法　　出生于人
  黎庶之间　　告舍利弗　　吾听省彼
  寻时往诣　　波罗奈国　　便即合集
  诸比丘众　　身子欲知　　佛善权法
  大圣应时　　便转法轮　　兴发宣畅
  灭度寂然　　叹罗汉音
  赞誉法声　　于是歌颂　　圣众之德
  其闻最胜　　说彼经典　　一切皆来
  归于世尊　　佥共叉手　　恭肃而住
  善权方便　　为若干种　　尔时世尊
  复更思惟　　吾说尊法　　今正是时
  我所以故　　于世最胜　　应当讲说
  斯尊佛道　　志怀愚痴　　起于妄想
  设吾说法　　少有信者　　憍慢自大
  不肯启受　　如斯法者　　菩萨乃听
  佛时悦豫　　秉修勇猛　　应时解断
  一切诸结　　今日当说　　最胜自由
  或以劝助　　使入佛道　　诸佛之子
  得观睹此　　因从获信　　顺行法律
  时千二百　　诸漏尽者　　皆当于世
  成为佛道　　亦如往古　　诸佛大圣
  亦如当来　　最胜之法　　吾复如是
  蠲弃众想　　然后尔乃　　讲天尊法
  久久时时　　世间有佛　　大仙慧士
  兴发圣道　　无极明目　　既现于世
  选择希有　　时讲斯法　　于亿百千
  无量劫数　　乃得值遇　　如此像法
  假使菩萨　　获斯比经　　若复逮闻
  是尊佛道　　若灵瑞华　　时时可见
  欲见慕值　　莫能睹者　　最胜容貌
  和悦难遭　　天上世间　　无上圣贤
  今此大尊　　乃谓琦珍　　假使有人
  而说斯经　　一反举声　　欢喜劝助
  则为供养　　一切佛已　　共去乱心
  不怀狐疑　　吾为法王　　悉普告敕
  吾之法中　　一切声闻　　则便劝助
  以尊佛道　　卿舍利弗　　及诸声闻
  今现在者　　且皆默然　　其诸菩萨
  意勇智慧　　密持斯法　　勿得忘宣
  何故说世　　而有五事　　或有众生
  怀毒求短　　贪欲愚聩　　而好诽谤
  如是伦品　　不尚至道　　若当来人
  而说此法　　听察如来　　一乘之教
  设复睹见　　诸最胜名　　诽谤斯经
  便堕地狱　　假使有人　　惭愧清净
  发心志愿　　来尊佛道　　闻大觉乘
  无量之德　　诸佛圣明　　则现目前
  众猛尊导　　讲法如是　　善权方便
  亿百千垓　　分别无数　　无复想念
  其不学者　　不能晓了　　由是之故
  了正真言　　正觉出世　　顺修明哲
  断诸狐疑　　蠲除犹豫　　能仁欣勇
  咸至佛道

正法华经卷第一正法华经卷第二

        西晋月氏国三藏竺法护译

    应时品第三

于是贤者舍利弗。闻佛说此欣然踊跃。即起叉手白众祐曰。今闻大圣讲斯法要。心加欢喜得未曾有。所以者何。常从佛闻法说化导诸菩萨乘。见余开士听承佛音德至真觉。甚自悼感独不豫及。心用灼惕。所示现议所不绍逮。我已永失如来之慧。假使往返山林岩薮。旷野树下闲居独处。若在宴室谨敕自守。一身经行益用愁毒。深自惟言法号等入。世尊为我现若干教。而志小乘自我等咎。非如来也。所讲演法大圣等心。为开士叹思奉尊者。为受第一如来训典。堪至无上正真之道。我等所顺而被衣服。所建立愿不以频数。唯然世尊。鄙当尔时用自克责。昼夜寝念。虽从法生不得自在。偏蒙圣恩得离恶趣。今乃逮闻时。舍利弗以颂赞曰

  得闻佛乘　　一句之业　　超出本望
  怪未曾有　　所当受获　　非心口言
  睹大尊雄　　益怀喜欢　　假使有人
  能造行者　　闻安住音　　以为奇雅
  诸尘劳垢　　鄙已蠲尽　　音声之信
  亦悉永除　　我本昼日　　设经行时
  若在树下　　端坐一心　　设在林薮
  山岩之中　　心自思惟　　如此行谊
  呜呼自责　　弊恶之意　　因平等法
  而得无漏　　不由三界　　顺尊法居
  追悔过事　　以诫将来　　紫磨金容
  相三十二　　我已违远　　失不自严
  众相八十　　具足殊特　　种种积累
  不以璎珞　　根力脱门　　八部之音
  于平等法　　而自危削　　诸佛之法
  有十八事　　如是之谊　　我已永失
  音声所闻　　达于十方　　吾以得见
  愍世俗者　　一身独己　　昼日经行
  又自克责　　而内思惟　　我每夙夜
  深自料计　　反侧婉转　　忖度己身
  当问世尊　　如是之谊　　鄙何所失
  当复所失　　现在眼前　　于圣明日
  夙夜过去　　逝不休息　　见余菩萨
  而不可计　　世雄尊师　　之所开化
  彼等悉闻　　此佛音教　　为诸群萌
  讲演法力　　其法无想　　诸漏已尽
  普悉晓畅　　致微妙慧　　睹若干种
  诸所祠祀　　历外异学　　诸邪伪术
  由是之故　　解佛言教　　观见脱门
  即说灭度　　一切得解　　诸所见行
  寻时开了　　空无之法　　由是自谓
  已得灭度　　今乃自知　　非至泥洹
  得觐诸佛　　天中之天　　时人中上
  众会围绕　　三十二相　　光色巍巍
  因斯觉了　　至度无余　　我适闻说
  除于众热　　不以音声　　而得无为
  如我所知　　正觉师子　　诸天世人
  之所奉事　　则以力势　　恒住如斯
  第一初闻　　大圣之教　　波旬时化
  变为佛形　　无得为魔　　之所娆害
  如因缘行　　而引说喻　　无央数亿
  显现垓限　　善立彼岸　　至道意海
  得闻彼法　　除诸狐疑　　有百千佛
  及垓之数　　悉得睹见　　众灭度脱
  如斯诸佛　　所说经典　　善权方便
  随顺御之　　假使有见　　现究竟行
  当来诸佛　　众亿百千　　善权方便
  导御是党　　为讲说经　　诱进泥洹
  随其体像　　化以慧行　　悉而分别
  次第所有　　诸佛之法　　所当教诲
  寻即承圣　　受转经轮　　世雄导师
  现真雅训　　吾亦如是　　依蒙其像
  彼诸魔众　　而不敢当　　心未常怀
  邪疑之碍　　普兴柔软　　深妙之道
  以佛音声　　而得欢欣　　今日所有
  诸志犹预　　以弃沉吟　　住于圣慧
  我成如来　　无众结网　　诸天世人
  以为眷属　　今日得睹　　佛之道眼
  当劝助化　　于众菩萨

佛告贤者舍利弗。今吾班告天上世间沙门梵志诸天人民阿须伦。佛知舍利弗。曾以供奉三十二千亿佛。而为诸佛之所教化。当成无上正真道。吾身长夜亦开导汝以菩萨谊。尔缘此故兴在吾法。如来威神之所建立。亦本愿行念菩萨教。未得灭度自谓灭度。舍利弗。汝因本行欲得识念无央数佛。则当受斯正法华经一切佛护。普为声闻分别说之。佛语舍利弗。汝于来世无量无数不可计劫。供养亿百千佛受正法教。奉敬修行此方等经。具足众行当得佛道。号莲华光如来至真等正觉明行成为善逝世间解无上士道法御天人师。其世界名离垢。平等快乐威曜巍巍。诸行清净所立安隐。米谷丰贱人民繁炽。男女众多具足周备。琉璃黄金以为长绳。连绵路傍一切路边。有七宝树八重交道。行树枝叶华实常茂。莲华光正觉亦当承续说三乘法。而佛说法具足一劫。所可演经示奇特愿。劫名大宝严。所以名曰大宝严者。谓彼佛国诸菩萨众。诸菩萨众有无央数。不可思议无能限量。唯有如来乃能知数。菩萨大士在其佛土。为觉意宝行如莲华。无有新学久殖德本。净修梵行而无年限。亲近如来常应佛慧。具大神通志存法要。勇猛志强诸菩萨众。具足如是无有缺减。是故其劫名大宝严。莲华光佛当寿十二中劫。不可计童子时也。其国人民当寿八劫。莲华光如来过十二劫。有菩萨名坚满。当授其决。告诸比丘言。此坚满大士。吾灭度后当得无上正真道。号度莲华界如来正觉。莲华光佛灭度之后。正法像法住二十中劫。其佛世界如前佛土等无差特。度莲华界如来亦寿二十二中劫。尔乃灭度。佛灭度后。其佛正法及像法住二十二中劫。尔时世尊以偈颂曰

  卿舍利弗　　于当来世　　得成为佛
  显如来尊　　号莲华光　　普平等目
  教授开化　　众庶亿千　　奉事无数
  诸佛亿载　　于彼修力　　多所兴立
  所在劝化　　得为十力　　便当成就
  上尊佛道　　不可思议　　无央数劫
  劫当号名　　大宝严庄　　世界名曰
  为离诸垢　　其莲华光　　国土清净
  以绀琉璃　　遍敷为地　　紫磨金绳
  连绵为饰　　若干种树　　皆七宝成
  其树华实　　悉以黄金　　彼诸菩萨
  意皆坚强　　所造言行　　圣哲聪明
  善学佛道　　亿百千垓　　是等来现
  最胜法教　　佛最后时　　无有荫盖
  为童子时　　无所慕乐　　弃离爱欲
  即出家去　　便得成就　　上尊佛道
  斯最胜尊　　则得自在　　其命当寿
  十二中劫　　法教当立　　尽于八劫
  彼命限量　　劫数如是　　若大圣佛
  灭度之后　　当具足满　　廿二中劫
  尔时法住　　若干之数　　愍哀天上
  及世间人　　其佛正法　　灭尽之后
  像法当住　　廿二中劫　　彼大圣明
  舍利流布　　男神女鬼　　供养最胜
  其世尊德　　亦当如是　　告舍利弗
  且当自庆　　仁者国土　　严饰如是
  两足之尊　　自然无伦

尔时四部众。比丘比丘尼清信士清信女。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩休勒。闻佛世尊授舍利弗决。当成无上正真之道。心怀欣豫欢喜踊跃。不能自胜。各自脱身衣以覆佛上。时天帝释梵忍迹天。及余无数亿千天子。各各取衣供养世尊。以天华香意华大意华散于佛上。诸天衣物悉在虚空罗列而住。天上伎乐自然而鸣。天上大声自然雷震普雨天华。咸共举声而皆叹曰。今所闻法自昔未有。前波罗奈鹿苑之中。始转法轮盖不足言。今佛世尊则复讲说无上法轮。时诸天子赞颂曰

  于世无双比　　今者转法轮
  为男女讲说　　阴衰所从起
  彼第一畅说　　十二展转事
  今导师演说　　少能信乐者
  从世雄大圣　　面闻无数法
  往始至于兹　　未聆如斯典
  大导师所说　　我今代劝助
  勇猛舍利弗　　而乃得授决
  为叹本发意　　所供养佛数
  我当蒙及逮　　得佛世最上
  已所造净行　　频数若干种
  奉过去诸佛　　愿获佛道谊

于是舍利弗白世尊曰。我今无结狐疑已除。现在佛前得授予决。为无上正真道。又曰。大圣。斯千二百得自在者。昔来岂不住学地乎。当来如是此佛教耶。斯诸比丘。顿止行门遵尚法律。度老病死咨嗟泥洹。是诸比丘无央数千。供养世尊。学诸所学。畏吾我惧三世。毁诸见众邪。行立灭度。已怀此想得至道场。初未曾闻如是像法。心每犹豫善哉世尊。愿说要谊。使此比丘疑网悉除。今四部众意咸怅怅。当令坦然无余结恨。佛告舍利弗。向者吾不说斯法耶。以若干种善权方便。随其因缘而示现之。如来至真等正觉所分别演。皆为无上正真道故。我所咨嗟皆当知之。为菩萨也。又舍利弗。今吾引喻重解斯谊。有明慧者当了此譬喻。如郡国县邑有大长者。其年朽迈坐起苦难。富乐无极财宝无量。有大屋宅。周匝宽博垣墙高广。其舍久故。数百千人而在其内。唯有一门及监守者。堂屋倾危梁柱腐败。轩窗既多多积薪草。时失大火。从一面起普烧屋宅。长者有子。若十若二十。欲出诸子。诸子放逸嬉戏饮食。卒见火起各各驰走。周慞诘屈不知所出。父而念曰。今遭火变屋皆然炽。以何方便免救吾子。时父知子各所好喜。即为陈设象马车乘游观之具。开示门合使出于外。鼓作倡伎绝妙之乐。戏笑相娱令济火厄。当赐众乘。象车马车羊车伎车。吾以严办停在门外。速疾走出出避火灾。自恣所欲从意所乐。诸子闻父所敕所赐象马车乘音乐之属。各共精进广设方计。土坌水浇奔走得出。长者见子安隐而出。四面露坐心各踊跃。不复恐惧。各各白言。愿父赐我诸所见许若干种伎相娱乐具象马车乘。又舍利弗。彼大长者。等赐诸子七宝大车。珠交露幔车甚高广。诸珍严庄所未曾有。清净香华璎珞校饰。敷以缯褥氍毹綩綖。衣被鲜白铄如电光。冠帻履屣世所希有。若干童子各各手持。一种一色皆悉同等。用赐诸子。所以者何。今此幼童皆是吾子。宠敬等爱意无偏党。以故赐与平等大乘。又舍利弗。吾亦如是为众生父。停储库藏满无空缺。如斯色像。教化诱进得示大乘。诸子则寻获斯大乘。以为奇珍得未曾有。而乘游行。于意云何。长者赐子珍宝大乘。将无虚妄乎。舍利弗白佛。不也安住。不也世尊。其人至诚。所以者何。彼大长者救济诸子。而不欲令遇斯火害。随其所乐许而赐之。适出之后各与大乘。以故长者不为虚妄。究竟诸子志操所趣。故以方便令免患祸。况复贮畜无量宝藏。以一色类平等大乘赐子不虚。佛言。善哉舍利弗。诚如所云。如来至真等正觉超越十方光照众冥。解脱忧恐拔断根牙。枝叶华实如来慧现。法王神力为世之父。善权方便摄持恩议。行乎大悲道心无尽。愍哀三界大火炽然。黎庶不解故现世间。救济众生生老病死。诸不可意结缚之恼。裂坏所著脱淫怒痴。诱导三乘渐渐劝示无上正真之道。适兴于世睹诸群萌。妄想财业爱惜无厌。因从情欲致无数苦。于今现在贪求汲汲。后离救护便堕地狱饿鬼畜生。烧炙脯煮饥渴负重。痛不可言。正使生天及在人间。与不可会恩爱别离。忧恼难量一时离苦。歌舞戏笑不知恐畏。无所忌难不自觉了。不肯思惟计其本末。不求救护复见烧然。三界众生勤苦之患。吾当施立无极大安。无数百千不可思议诸佛正慧。其有盈逸迷惑欲乐。如来诱立道慧神足。善权方便化现佛慧。闻使佛力无所畏。众生难寤不肯寻受。因缘所缚。未脱生老病死忧患。未始得度三界烧炙。不了所归。何谓解佛慧者。譬如长者。立强勇猛多力诸士。救彼诸子使离火患。方便诱之适出在外。然后乃赐微妙奇特众宝车乘。如是舍利弗。如来正觉以力无畏建立众德。善权方便修勇猛慧。睹见三界然炽之宅。欲以救济众生诸难。故现声闻缘觉菩萨之道。以是三乘开化驱驰使弃爱欲。教诸萌类灭三界火淫怒痴缚。色声香味细滑之法。三处五欲五欲烧人。不猗三界便得三乘。勤精三乘则超三界。进三乘者诸佛所训也。黎庶则至无央数集。世尊现戏行为娱乐。修此根力觉意禅定脱门三昧正受。然于后世致大法乐。安隐欣豫无所挂碍。又舍利弗。其有众生未兴起者。如来出世有信乐者。乐佛法教精进奉行。最后竟时欲取灭度。谓声闻乘。遵求罗汉孚出三界。譬如长者免济子难许以羊车。若复有人无有师法。自从意出求至寂然。欲独灭度觉诸因缘。于如来法而行精进。谓缘觉乘。出之火宅许以马车。假使有人。求诸通慧诸佛道慧。自在圣慧自从心出。无师主慧多所哀念。多所安隐诸天人民。欲利天上世间人民。灭度黎庶于如来法。奉修精进欲求大圣。普见之慧力无所畏。谓如来道。菩萨大士所履乘也。譬如长者劝诱其子免火患难。许以象车驱出火宅。父见子安济难无惧。自察家中财宝无量。等赐诸子高大殊妙七宝大乘。如来正觉亦复如是。睹无数众亿百千垓。使度三难勤苦怖惧。从其所愿开生死门。遂令脱出难崄恐患使灭度安。又舍利弗。如来尔时从终始宅。以无数慧力无所畏。观众罹厄矜哀喻子。普劝进使归于佛乘。不令各各从意而灭度也。如来悉诱。以佛灭度而灭度之。假使众生得度三界。以如来慧脱门定意贤圣度门。安慰欢娱施乐法谊。惠以一貌佛之大道。如彼长者本许诸子以三品乘。适见免难各赐一类平等大乘。诚谛不虚。各得踊跃无有愠恨。如来如是。本现三乘然后皆化使入大乘不为虚妄。所以者何。当知如来等觉有无央数仓库帑藏。以得自在。为诸黎庶现大法化诸通愍慧。当作是知当解此谊。如来等正觉善权力便。以慧行音唯说一乘。谓佛乘也。世尊颂曰

  譬如长者　　而有大宅　　极甚朽故
  腐败倾危　　有大殿舍　　而欲损坏
  梁柱榱栋　　皆复摧折　　多有轩闼
  及诸窗牖　　又有仓库　　以泥涂木
  高峻垣墙　　壁障崩隤　　薄所覆苫
  弥久雕落　　时有诸人　　五百之众
  皆共止顿　　于彼舍宅　　有无央数
  草木积聚　　所当用者　　满畜无量
  一切门户　　时皆闭塞　　有诸楼阁
  及诸莲华　　亿千众香　　而有芬气
  若干种鸟　　眷属围绕　　种种虺蛇
  蝠螫遁窜　　在在处处　　有诸恶虫
  有若干种　　狖狸鼷鼠　　其字各异
  呜呼啾[口*室]　　其地处处　　而有匿藏
  溷厕屎溺　　污秽流溢　　虫明刺蕀
  充满其中　　师子狐狼　　各各[口*睪]吠
  悉共咀嚼　　死人尸体　　何人闻见
  而不怖惧　　无数狗犬　　蹲伏窠窟
  各各围绕　　皆共齹掣　　假使此等
  饥饿之时　　普皆诤食　　疲瘦羸劣
  斗相齮啮　　音声畅逸　　其舍恐畏
  变状如是　　有诸鬼神　　志怀毒害
  蝇蚤壁虱　　亦甚众多　　百足种种
  及诸魍魉　　四面周匝　　产生孚乳
  各取分食　　羯羠羝羊　　不得奔走
  归其处所　　虽诸鬼神　　来拥护之
  不能济脱　　令不被害　　彼诸鬼神
  亦食众生　　虽得饱满　　心续怀恶
  群品不同　　种姓别异　　若有死者
  皆埋冡埌　　彼志出外　　而游所处
  鸠桓香音　　志存暴弊　　舒展两臂
  往来经行　　无有咒术　　可以辟除
  于时诸犬　　取其两足　　扑令仰卧
  而就击之　　捉其两脚　　绞加颈项
  坐自放恣　　心意荡逸　　诸黑象众
  厥状高大　　体力强盛　　拔扈自在
  旬日饥饿　　行求饮食　　遥见刍蒿
  奔走趣之　　有针嘴虫　　及铁喙鸟
  在丘圹间　　见人死尸　　恶鬼凶崄
  放发叫呼　　诸魃凑满　　贪欲慢翰
  窗牖显明　　视瞻四顾　　于斯窥看
  不可得常　　诸邪妖魅　　及众饿鬼
  雕鹫鸱枭　　悉行求食　　其宅恐难
  如是品类　　有大园观　　墙壁隤落
  室宅门户　　圯裂破柝　　唯一男子
  而守护之　　其人在里　　止顿居跱
  尔时失火　　寻烧屋宇　　周回四面
  而皆燔烧　　无数千人　　惊怖啼哭
  于今火盛　　焚我子息　　又彼尊者
  举声称怨　　堂柱摧灭　　垣屏碎散
  神诸饿鬼　　扬声喜唤　　雕鹫数百
  飞欲避火　　无数鸠垣　　框榱怀懅
  百千妖魅　　慞遑驰走　　亲自目见
  火所燔烧　　无量群萌　　乌殟灰芦
  诸薄枯者　　为火所灾　　各各懊恼
  而见焚烧　　炙燎焦烂　　沸血流离
  于时此宅　　强猛之众　　一一鬼魅
  悉共啖食　　臭烟熢勃　　称赞香美
  一切奔骛　　周旋诘屈　　蜈蚣蚰蜒
  蚳蛆并出　　厌魅勇逸　　多所龃齰
  头上火然　　游行嬉怡　　悉饥食啖
  火所烧者　　其屋宅中　　怖遑若兹
  百千人众　　烧丧狼藉　　于时宅主
  大势长者　　见之如斯　　急急孚务
  闻此灾祸　　愍念诸子　　建立伎乐
  宝乘诱出　　有诸愚痴　　不能解知
  于彼戏笑　　放逸自恣　　长者听察
  寻入馆内　　騃夫不觉　　无解脱想
  今我诸子　　闇蔽闭塞　　一切盲瞆
  无有耳目　　以戏乐故　　而自系缚
  种姓孙息　　甚难得值　　凡品众庶
  若干等伦　　遭大灾火　　各各痛恼
  鬼神蛇虺　　心中怀毒　　无数妖魅
  欢喜踊跃　　诸狼狐狗　　亦不可计
  饥渴欲求　　饮食之具　　我子众多
  皆没于此　　设无火灾　　亦不可乐
  狐疑众结　　酷苦若是　　何况周匝
  普见炽然　　执愚意者　　于斯自恣
  诸子贪戏　　而相娱乐　　永不思惟
  父所言教　　心不自念　　速图方计
  尔时长者　　意自忖度　　吾生此子
  勤苦养育　　得无为火　　而见烧爇
  于何救子　　而脱孙息　　即自思议
  立造权计　　今我诸子　　耽媔音伎
  祸害乘至　　非戏乐时　　痛哉愚愦
  不睹酷苦　　诸童瑕猥　　不识此难
  今吾心怖　　子乐逸荡　　要从精进
  免济大墙　　即寻设计　　于舍之外
  施张伎乐　　游戏之具　　子所好慕
  吾皆办之　　调隐音节　　一时俱作
  诸子闻赐　　贪爱乐音　　各各速疾
  尽力劢励　　驱逐一切　　迸出灾屋
  得脱苦恼　　集子一处　　安隐欢然
  无复恐惧　　于是长者　　见诸子出
  心中宽泰　　意得自由　　广设众具
  师子之座　　吾身今日　　则获无为
  彼诸苦患　　已永尽除　　斯诸童子
  修精进力　　迷在灾宅　　而自放恣
  前者曾更　　无限眠寐　　火[火*僉]然炽
  人遭此难　　阴盖所覆　　心不开解
  今日一切　　皆得解脱　　已致自然
  志之所愿　　父见诸子　　志在安隐
  于时诸子　　往诣长者　　唯愿天父
  各各赐我　　如前所许　　若干种乘
  本居遇火　　迷冥不寤　　大人敕教
  一切奉承　　当赐诸子　　三品之乘
  今正是时　　愿垂给与　　于时长者
  敕侍开藏　　紫磨天金　　明月珠宝
  上妙珍异　　世所希有　　极好奇特
  弘雅之车　　最尊难及　　庄校严饰
  周匝栏楯　　珠玑璎珞　　幢幡缯彩
  而为光观　　金银交露　　覆盖其上
  炜晔殖立　　珍宝诸华　　四面周匝
  而皆下垂　　车上重叠　　敷诸坐具
  天缯白褺　　而不可计　　又复加施
  柔软茵褥　　无量綩綖　　参席于车
  计所校饰　　车价亿千　　奇异珍宝
  无量兆载　　其象多力　　鲜白如华
  象身高大　　仪体扰驯　　调驾宝车
  以为大乘　　于时长者　　严车以办
  各以赐与　　诸正士畴　　皆是我子
  一切等给　　是时诸子　　欢喜踊跃
  各各处处　　欣庆相娱　　告舍利弗
  大仙如是　　为诸群生　　救护父母
  一切众庶　　皆是我子　　为三界欲
  所见缠缚　　计惟三处　　如彼火宅
  勤苦患恼　　具足百千　　此则所谓
  普然无余　　生老病死　　忧哭之痛
  佛为三界　　救度无余　　游在闲居
  若坐林树　　则常应时　　将护三处
  彼见烧炙　　皆斯吾子　　寤诸黎庶
  令得自归　　由此意故　　示现于彼
  一切黎元　　愚不受教　　坐着爱欲
  而自絷绁　　善权方便　　为大良药
  分别三乘　　以示众生　　适闻三界
  无量瑕秽　　则以随时　　驱劝令出
  其诸菩萨　　来依倚佛　　六通三达
  成大圣慧　　或有得成　　为缘觉乘
  逮不退转　　致佛尊道　　现在诸子
  因佛自由　　以是譬喻　　无有嗔恨
  缘是得近　　于佛道乘　　受斯一切
  得为最胜　　于是恢阐　　平等之信
  降伏弃离　　一切世色　　诸正觉慧
  殊异道德　　稽首归命　　于圣中尊
  根力脱门　　一心如是　　三昧之定
  亿数千垓　　诸佛之子　　常所宗重
  斯则名曰　　尊妙大乘　　昼则誓愿
  志存降魔　　夜每专精　　钦慕不倦
  于一年数　　若历劫数　　度脱众生
  无数千垓　　所喻宝乘　　则谓于斯
  以是游至　　于佛道场　　无数佛子
  以为娱乐　　其有听者　　安住弟子
  告舍利弗　　卿当知是　　计有一乘
  则无有二　　住至十方　　一切求索
  知人中上　　普行善权　　稍稍诱进
  从微至大　　先现声闻　　缘觉之证
  适德三界　　欲舍之去　　然后便示
  菩萨大道　　佛恩普润　　譬如良田
  随其所种　　各得其类　　种者所殖
  非地增减　　佛亦如是　　一切普等
  常示大道　　取者增减　　佛则于彼
  诸人者父　　我常观者　　众庶苦恼
  无数亿劫　　而见烧煮　　三界之中
  恐畏之难　　佛为唱导　　使得灭度
  诸贤无为　　今日乃知　　弃捐生死
  脱勤苦患　　其有菩萨　　住于是者
  至诚之决　　取譬若斯　　一切普闻
  佛之明日　　诸大导师　　行权方便
  所当劝助　　如诸菩萨　　瑕秽爱欲
  亦可恶厌　　心闇塞者　　而见污染
  是故导师　　为说勤苦　　现四圣谛
  当分别此　　假使众人　　不解众恼
  根着冥尘　　不肯舍离　　故为是等
  而示其路　　因从所习　　而致诸苦
  爱欲已断　　常无所著　　已得灭度
  于斯三品　　了无有异　　则得解脱
  若修八路　　便得超度　　告舍利弗
  何所为度　　受无所有　　则为解脱
  彼亦不为　　一切解脱　　无所灭度
  便见导师　　佛何以故　　而说解脱
  无所逮者　　乃成佛道　　当得如我
  为圣法王　　以安隐谊　　现出于世
  告舍利弗　　是吾法印　　是佛最后
  微妙善说　　愍伤诸天　　及于世间
  在所游处　　常能独行　　假使有人
  讲说是典　　若有劝助　　代欢喜者
  闻其妙法　　当奉持之　　为悉供养
  过去诸佛　　奉持此法　　至不退转
  假使有人　　信乐斯经　　往古已见
  过去导师　　亦悉奉顺　　诸圣至尊
  如得逮闻　　如是典摸　　皆得曾见
  吾之仪容　　又亦观察　　我比丘众
  常观勤视　　今现菩萨　　信斯典者
  德亦如是　　一切皆瞻　　是诸菩萨
  其信此经　　则亦如是　　顽騃闇夫
  不肯笃信　　若说此经　　诸得神通
  诸声闻党　　非其所逮　　缘觉之乘
  亦不能了　　今我所有　　诸声闻等
  舍利弗身　　坚固信之　　仁辈如是
  信大法典　　现在尽悉　　不着因缘
  假使不应　　斯经卷者　　则为谤讪
  佛天中天　　闇冥辈类　　常怀爱欲
  未曾解了　　无所生法　　又其毁谤
  善权方便　　世间所有　　佛常明日
  其闻佛说　　讲此罪福　　志不欢乐
  颜色为变　　我今现在　　及灭度后
  若有诽谤　　如是典比　　不使比丘
  书写斯经　　佛说罪缘　　皆谊普听
  没失人身　　堕无择狱　　处于其中
  具足一劫　　又无央数　　过是之限
  若罪竟已　　常在痴冥　　假令得出
  于地狱中　　便当堕于　　禽兽畜生
  为狗蛊狐　　其形燋悴　　当入人宅
  或复见害　　设有憎恶　　佛经典者
  其色变异　　黯黕如墨　　罪之所为
  颜常若漆　　身体羸瘦　　而无润泽
  为诸品类　　所见贱秽　　瓦石打掷
  啼哭泪出　　其人常被　　挝捶榜笞
  饥渴虚乏　　躯形瘦燥　　当坠畜生
  骆驼驴骡　　常负重担　　而得捶杖
  心中燠燶　　厄求刍草　　谤佛斯经
  获罪若此　　虽得为人　　身疽癞疮
  状貌痤陋　　肌色伤烂　　假使行人
  县邑聚落　　童子轻易　　戏弄叉踏
  其愚騃子　　若后寿终　　即当堕生
  边夷狄处　　当为含血　　蠕动之类
  或为聋哑　　不得自在　　假使诽谤
  此经获罪　　常多疾病　　体生疽虫
  无数之命　　唼食其躯　　心常忧瘀
  疾不离己　　告舍利弗　　不信此经
  彼男子者　　无黠无明　　所在悭贪
  性常嚵[口*斥]　　生盲无目　　人所弃捐
  人坐不信　　于佛大道　　口中常臭
  恶气外薰　　鬼神厌魅　　详触娆之
  普世俗人　　无用言者　　假使不乐
  斯道地者　　所在穷乏　　常当贫匮
  身未常得　　着好被服　　财业虽丰
  不敢饮食　　有所造作　　当所为者
  假使欲求　　安隐之具　　设有所得
  寻复亡失　　兴发恶行　　果报如此
  假使呼医　　合诸方药　　善知方便
  而疗治之　　有不除差　　及转增剧
  恒被疾病　　不得所便　　设复发意
  兴立余事　　则遭扰扰　　斗诤之业
  又见毁辱　　而被楚挞　　彼犯律者
  常遇此恶　　若有诽谤　　斯经之罪
  未曾得见　　世雄导师　　人中帝王
  佛之法教　　卒暴隧鬼　　阿须伦神
  恒当罗殃　　耳聋闭塞　　愚痴騃瞆
  不得闻经　　设有诽谤　　斯经典者
  然于后世　　永无所见　　假使毁呰
  斯经罪果　　殃无数亿　　百千之计
  若干垓劫　　如江河沙　　常当喑哑
  口不能言　　佛所立道　　常师子吼
  毁者地狱　　以为游观　　勤苦恶趣
  用作居宅　　已所犯罪　　致殃如斯
  人多疾患　　自速喑哑　　若在世间
  当获此咎　　坐在众会　　两舌欺言
  命欲尽时　　举贾生息　　其身恒遭
  若干苦痛　　无央数亿　　百千众患
  颜貌常黑　　人所不喜　　殃暴疽疠
  常有臭气　　自见吾我　　颜色黧黮
  嗔恚怀毒　　怒害滋甚　　情欲炽盛
  无有节限　　有所好忤　　若如畜生
  告舍利弗　　今日世尊　　具足一切
  说其人罪　　若有诽谤　　斯佛经者
  欲计殃限　　不可究竟　　见是谊已
  当观察之　　今我故为　　舍利弗说
  不为愚騃　　不解道者　　分别论讲
  如斯像法　　其有聪明　　广博多闻
  秉志坚强　　常修忆辨　　若有劝发
  遵尚佛道　　尔乃听受　　未曾有法
  则以睹见　　亿百千佛　　殖无央数
  如意功德　　其人志性　　猛如月光
  尔乃听受　　如是典籍　　若有精进
  志常怀慈　　常于夙夜　　昭耀悲哀
  朽弃躯体　　不惜寿命　　尔乃听受
  于斯经卷　　常行恭敬　　无他想习
  其心专一　　不立愚愿　　恒处旷野
  若隐岩居　　彼等人仁　　尔乃听受
  结亲善友　　常相恃怙　　弃捐远离
  诸恶知识　　当得逮见　　如是佛子
  乃能值遇　　若斯言教　　不犯禁戒
  如宝明珠　　志习奉受　　方等诸经
  当见如兹　　佛圣子孙　　常专精此
  一品经卷　　设有骂詈　　毁辱经者
  恒以愍哀　　向于众生　　常志恭敬
  承安住教　　今故为之　　说是经法
  其在众会　　诵斯经者　　心常如应
  得无合会　　引无央数　　亿载譬喻
  故为是伦　　而见斯典　　又佛今日
  讲解道品　　所至到处　　踊跃而步
  假使比丘　　欲求善说　　若见此经
  当欣顶受　　其有奉持　　方等经者
  心常专精　　不乐余业　　执持一颂
  志不改易　　乃得听受　　如是弘模
  假使有人　　慕求斯经　　当崇敬之
  如如来身　　若人思侥　　欲学此法
  设令得者　　当稽首受　　其人不当
  念索余经　　亦未曾想　　世之群籍
  而行佛道　　志在根力　　悉舍离之
  讲专斯经　　告舍利弗　　佛满一劫
  举喻亿千　　分别解脱　　设有愿发
  上尊佛道　　当以斯经　　宣畅布散

正法华经卷第二正法华经卷第三

        西晋月氏国三藏竺法护译

    信乐品第四

于是贤者须菩提。迦旃延。大迦叶。大目揵连等。听演大法得未曾有。本所未闻。而见世尊授舍利弗决。当得无上正真之道。惊喜踊跃咸从坐起。进诣佛前偏袒右肩。礼毕叉手瞻顺尊颜。内自思省心体熙怡。支节和怿悲喜并集。白世尊曰。唯大圣通。我等朽迈年在老耄。于众耆长佥老羸劣。归命众祐冀得灭度。志存无上正真之道。进力鲜少无所堪任。如来所讲我等靖听。次第坐定诸来大众。不敢危疲无所患厌。前者如来为鄙说法。已得于空无相无愿。至于佛典国土所有。于一切法无所造作。其诸菩萨所可娱乐。如来劝发多所率化。鄙于三界而见催逐。常自惟忖谓获灭度。今至疲惫。尔乃诲我以奇特谊。乐于等一则发大意。于无上正真道。而今大圣授声闻决当成正觉心用愕然怪未曾有。余得大利各当奉事。乃获逮闻如是品经。从过去佛常闻斯法。故初值遇。则我禄厚喻获妙宝。无央数妙意所至愿。现在于色而无所畏。珍琦鼓乐自然为鸣。而燃大灯昭耀弥广。栴檀丛林芬蕴而香。唯然世尊。我岂堪任而说之乎。告曰可也。时诸声闻共白佛言。昔有一士离父流宕。侨亭他土二三十年。驰骋四至求救衣食。恒守贫穷困无产业。父诣异城。获无央数金银珍宝水精琉璃车磲马瑙珊瑚虎魄。帑藏盈满。侍使僮仆象马车乘不可称计。眷属无数七宝丰溢。出内钱财耕种贾作。子厄求食周行国邑城营村落。造富长者适值秋节。入处城内循行帑藏。与子别久忽然思见。不知所在自念一夫。财富无量横济远近。窃惟我老朽耄垂至。假使终没室藏骚散。愿得见子恣所服食。则获无为不复忧戚。其子侥会至长者家遥见门前。梵志君子大众聚会眷属围绕。金银杂厕为师子座。交露珠璎为大宝帐。父坐其中分部言教。诸解脱华遍布其地。亿百千金以为饮食。子觐长者色像威严。怖不自宁。谓是帝王若大君主。进退犹豫不敢自前。孚便驰走。父遥见子心用欢喜。遣傍侍者追呼令还。遑懅躄地。谓追者曰。我不相犯。何为见捉。侍者执之俱诣长者。长者告曰。勿恐勿惧。吾为子勤广修产业帑藏充实。与子别久数思相见。年高力弊父子情重将入家内。在于众辈不与共语。所以者何。父知穷子志存下劣不识福父。久久意悟色和知名又见琦珍。长者言曰。是吾子也以权告子。今且恣汝随意所奉。穷子怪之得未曾有。则从坐起行诣贫里求衣索食。父知子缘方便与语。汝便自去与小众俱。子来至此而再致印曰。至此宅有所调饰。父付象马即令粗习。假有问者答亦如之。当调车马严治宝物恣意赐与。父求穷子所可赈给。具足如斯。时子于厩调习车马缮治珍宝。转复教化家内小大。父于窗牖遥见其子所为超绝。脱故所著沐浴其身。右手洗之。以宝璎珞香华被服。光曜其体皆令清净。而告之曰。尔从本来何所兴立。何所系属。舍吾他行。勤苦饥寒。吾以耄矣以情相告。便时纳娶。嬉游饮食以康祚胤。吾所造业不可訾计。众宝具足子知之乎。求汝积年而恋恶友。今乃来归宜除瑕垢。吾有妙宝夜光明珠琦珍瑰异。皆为汝施。僮仆侍使男女大小。恣意所欲。一以相付。吾爱念汝。犹如国王幸其太子。诸尊声闻共白佛言。彼时穷子。播荡流离二三十年。至长者家乃得申叙。追惟前后游观所更心悉念之。时大长者寝疾于床知寿欲终。自命其子而告之曰。吾今困劣宜承洪轨。居业宝藏若悉受之。周济穷乏从意所施。辄备奉教喜不自胜。所行至诚不失本誓。父知子志身行谨敕。先贫后富益加欣庆。宗敬亲属礼拜耆长。父于国王君主大臣众会前曰。各且明听。斯是吾子则吾所生。名字为某。舍我流迸二三十年。今乃相得。斯则吾子吾则是父。所有财宝皆属我子。子闻宣令大众之音。心益欣然而自念言。余何宿福得领室藏。诸声闻等又白佛言。大富长者则譬如来。诸学士者则谓佛子。勉济吾等三界勤苦。如富长者还执其子度脱生死。于是世尊。有无央数圣众之宝。以五神通除五阴盖。常修精进在彼道教。志于灭度谓为妙印。殷勤慕求初不休懈。欲得无为意中默然。熟自思惟所获无量。于如来所承顺法行。遵修禅定而常信乐。谓观我等懈废下劣。而不分别不能志愿。此如来法珍宝之藏。于今世尊以权方便。观于本际慧宝帑藏。蠲除饥[飢-几+內]授大妙印。唯然大圣于今耆年。斯大迦叶从如来所朝旦印印。当至无为。又世尊为我等示现菩萨大士慧谊。余党奉行为众说法。当显如来圣明大德。咸使畅入随时之谊。所以者何。世雄大通善权方便。知我志操不解深法。为现声闻。畏三界法及生老死。色声香味细滑之事。趣欲自济不救一切。离大慈悲智慧善权。禅定三昧乃知人心。不睹一切众生根原。譬如穷士求衣索食。而父须待欲使安乐。子不觉察。佛以方便随时示现。我等不悟。今乃自知成佛真子。无上孙息为佛所矜。施以大慧。所以者何。虽为佛子下贱怯弱。假使如来。睹心信乐喜菩萨乘。然后乃说方等大法。又世尊兴为二事。为诸菩萨现甘露法。为诸下劣志愿小者。转复劝进入微妙谊。譬如彼子与父别久。行道遥见。不识何人呼而怖惧。后稍稍示威仪法则乃知是父。佛亦如是。吾等不解菩萨大士。虽从法生为如来子。但求灭度。不志道场坐于树下降魔官属度脱一切。我辈自谓已得解脱。以是之故。今日睹闻未为成就。不为出家不成沙门。今如来尊现诸通慧。我等以获大圣珍宝。佛则为父我则为子。父子同体焉得差别。犹如长者临寿终时于大众前。宣令帝王梵志长者君子。今诸所有库藏珍宝用赐其子。子闻欢喜得未曾有。佛亦如是。先现小乘一时悦我。然今最后。普令四辈比丘比丘尼清信士清信女。天上世间一切人民。显示本宜。佛权方便说三乘耳。尚无有二岂当有三。是诸声闻皆当成佛。我等悦豫不能自胜。时大迦叶则说颂曰

  我等今日　　逮闻斯音　　怪之愕然
  得未曾有　　由是之故　　心用悲喜
  又省导师　　柔软音声　　尊妙珍宝
  为大积聚　　一处合集　　以赐我等
  未曾思念　　亦不有求　　还闻弘教
  心怀踊跃　　譬如长者　　而有一子
  兴起如愚　　亦不闇冥　　自舍其父
  行诣他国　　志于殊域　　仁贤百千
  于时长者　　愁忧念之　　然后而闻
  即自迸走　　游于十方　　意常悒戚
  父子隔别　　二三十年　　与人恋讼
  欲得其子　　便诣异土　　入于大城
  则于彼止　　立于屋宅　　具足严办
  五乐之欲　　无数紫金　　及诸珍宝
  奇异财业　　明珠碧玉　　象马车乘
  甚为众多　　牛畜猪彘　　鸡鹜羠羊
  出内产息　　贾作耕种　　奴仆僮使
  不可计数　　严办众事　　亿千百类
  又得王意　　威若国主　　一城民庶
  委敬自归　　诸郡种人　　远皆戴仰
  若干种业　　因从求索　　兴造既多
  不可计限　　势富如是　　啼哭泪出
  吾既朽老　　志力衰变　　心诲思想
  欲得见子　　夙夜追念　　情不去怀
  闻子之问　　意增烦惋　　舍我别来
  二三十年　　吾之所有　　财业广大
  假当寿终　　无所委付　　计彼长者
  其子愚浊　　贫穷困厄　　常求衣食
  游诸郡县　　恒多思想　　周旋汲汲
  慕系啬口　　征营驰迈　　栽自供活
  或时有获　　或无所得　　缠滞他乡
  亦怀悒傶　　志性褊促　　荆棘劙身
  展转周旋　　行不休息　　渐渐自致
  到父所居　　槃桓入出　　复求衣食
  稍稍得进　　至于家君　　遥见势富
  极大长者　　在于门前　　坐师子床
  无数侍卫　　眷属围绕　　出入财产
  及所施与　　若干人众　　营从立侍
  或有计校　　金银珍宝　　或合簿书
  部别分莂纪别入出　　料量多少
  于时穷子　　见之如此　　倚住路侧
  观所云为　　自惟我身　　何为至此
  斯将帝王　　若王太子　　得无为之
  所牵逼迫　　不如舍去　　修己所务
  思虑是已　　寻欲迸逝　　世无敬贫
  喜穷士者　　是时长者　　处师子座
  遥见其子　　心密踊跃　　寻遣侍者
  追而止之　　呼彼穷子　　使还相见
  侍者受教　　追及宣告　　录召令还
  即怖僻地　　心窃自惟　　得无被害
  曷为见执　　何所求索　　大富长者
  见之起强　　怜伤斯子　　为下劣极
  亦不睹信　　彼是我父　　又复怀疑
  不审财宝　　其人慰喻　　具解语之
  有紫磨金　　积聚于此　　当以供仁
  为饮食具　　典摄众计　　役业侍使
  吾有众宝　　蕴积腐败　　委在粪壤
  不见饰用　　子便多取　　以为质本
  蓄财殷广　　无散用者　　其人闻告
  如是教敕　　则寻往诣　　奉宣施行
  受长者教　　不敢违命　　即入家中
  止顿正领　　尔时长者　　遥从天窗
  详观察之　　知何所为　　虽是吾子
  下劣底极　　唯晓计算　　调御车耳
  即从楼观　　来下到地　　便还去衣
  垢污之服　　则便往诣　　到其子所
  敕之促起　　修所当为　　则当与卿
  剧难得者　　以德施人　　案摩手脚
  碱醲滋美　　以食相给　　及床卧具
  骑乘所乏　　于时复为　　娉索妻妇
  敖黠长者　　以此渐教　　子汝当应
  分部之业　　吾爱子故　　心无所疑
  渐渐稍令　　入在家中　　贾作治生
  所入难计　　所空缺处　　皆使盈溢
  步步所行　　鞭杖加人　　珍琦异宝
  明珠流离　　都皆收检　　内于帑藏
  一切所有　　能悉计校　　普悉思惟
  财产利谊　　为愚騃子　　别作小库
  与父不同　　在于外处　　于时穷士
  心自念言　　人无有此　　如我库者
  时父即知　　志性所念　　其人自谓
  得无极势　　即便召之　　而亲视之
  欲得许付　　所有财贿　　而告之曰
  今我一切　　无数财宝　　生活资货
  聚会大众　　在国王前　　长者梵志
  君子等类　　使人告令　　远近大小
  今是我子　　舍我迸走　　在于他国
  梁昌求食　　穷厄困极　　今乃来归
  与之别离　　二三十年　　今至此国
  乃得相见　　在于某城　　而亡失之
  于此求索　　自然来至　　我之财物
  无所乏少　　今悉现在　　于斯完具
  一切皆以　　持用相与　　卿当执御
  父之基业　　其人寻欢　　得未曾有
  我本贫穷　　所在不诣　　父时知余
  为下劣极　　得诸帑藏　　今日乃安
  大雄导师　　教化我等　　睹见下劣
  乐喜小乘　　度脱我辈　　使得安隐
  便复授决　　当成佛道　　于今安住
  多所遣行　　无数菩萨　　慧力无量
  分别示现　　无上大道　　攀缘称赞
  亿垓譬喻　　余等得闻　　最胜诸子
  则便奉行　　尊上大道　　所当起立
  视众眼目　　当于世间　　得成佛道
  而为圣尊　　造业如斯　　将养拥护
  于此佛法　　讲说分别　　最胜慧谊
  则为感动　　一切众生　　我等志愿
  贫心思念　　假使得闻　　于斯佛诲
  不肯发起　　如来之慧　　睹见最胜
  宣畅道谊　　意中自想　　尽得灭度
  不愿志求　　如此比慧　　又闻大圣
  诸佛国土　　未曾有意　　发欢喜者
  寂然在法　　一切无漏　　弃捐所兴
  灭度之事　　由此思想　　不成佛道
  常当修行　　昼夜除慢　　诸佛道谊
  最无有上　　未曾劝助　　志存于彼
  今乃究竟　　具足最胜　　得无为限
  当舍阴盖　　长夜精进　　修理空谊
  解脱三界　　勤苦之恼　　佛兴教戒
  则以具严　　如是计之　　无所乏少
  最胜所演　　经身之慧　　假使有人
  愿等佛道　　为是等故　　加赐法事
  由缘致斯　　余徒钦乐　　有大导师
  周旋世间　　普悉观察　　如此辈相
  诸恐惧者　　令得利谊　　求索劝助
  令我信乐　　善权方便　　犹若如父
  譬如长者　　遭时大富　　其子而复
  穷劣下极　　则以财宝　　而施与之
  大圣导师　　所兴希有　　分别宣畅
  善权方便　　诸子之党　　志乐下劣
  修行调定　　而以法施　　我等今日
  致得百千　　未曾有法　　如贫得财
  于佛教化　　获道得宝　　第一清净
  无复诸漏　　长夜所习　　戒禁定意
  执谊将护　　世雄唱导　　今日有获
  佛之大道　　眷属围绕　　修行无阙
  其有长夜　　清净梵行　　依倚法王
  深远之慧　　而为具足　　此尊德果
  日成微妙　　无有诸漏　　我等今日
  乃为声闻　　还得听省　　上尊佛道
  当复见扬　　圣觉音声　　以故获听
  超度恐惧　　今日乃为　　致无所著
  以无著谊　　为诸天说　　世人魔王
  及与梵天　　为亲一切　　众生之类
  何所名色　　造立寂然　　蠲除众生
  无亿数劫　　于是所造　　甚难得值
  计于世间　　希有及者　　今日无著
  烧罪度岸　　修行为业　　踊跃欢喜
  吾等归圣　　以顶受之　　所愿具足
  如江河沙　　饮食衣服　　若干巨亿
  诸床卧具　　离垢无秽　　用栴檀香
  以为屋室　　柔软坐具　　以敷其上
  若疾病者　　无所药疗　　今日供养
  安住广度　　所施劫数　　如江河沙
  所造立者　　无能夺还　　高远之法
  无量无限　　其大神足　　建立法力
  佛为大王　　无漏最胜　　堪任坚强
  常修牢固　　安慰劝进　　恒以时节
  未曾修设　　望想福行　　于一切世
  诸法中尊　　皆为大神　　最胜如来
  然大灯明　　示无央众　　知诸黎庶
  筋力所在　　若干种种　　所喜乐愿
  因缘百千　　而顺开化　　如来皆睹
  众人性行　　他人心念　　一切群萌
  以若干法　　而致堕落　　以法示现
  此尊佛道

    正法华经药草品第五

尔时世尊告大迦叶及诸耆年声闻。善哉所叹如实。审如所言。如来之德如向所喻。复倍无数不可思谊。无能计量劫之垓底。一一计数大圣所应。如来之慧无能限者。不有法想道地处所。莫能尽原。世尊普入一切诸谊。察于世间见众庶心。所度无极一切分别。皆使决了权慧之事。劝立一切度于彼岸。皆现普智入诸通慧。譬如三千大千世界。其中所有诸药草木。竹芦丛林诸树小大。根本茎节枝叶华实。其色若干种类各异。悉生于地。若在高山岩石之间。丘陵堆阜溪谷坑坎。时大澍雨润泽普洽。随其种类各各茂盛。叵我低仰莫不得所。雨水一品周遍佛土。各各生长地等无二。如来正觉讲说深法。犹如大雨。大圣出现兴在世者。则为一切诸天人民阿须伦鬼神龙。显示威曜咸寻来至。皆现在前。为畅大音分别慧谊。大师子吼班宣景模。吾为如来使。天上天下诸天世人。未度者度。未脱者脱。未安者安。未灭度者令得灭度。于是世及后世所知而审。为诸通慧皆能普见。度诸度。脱诸脱。安诸安。未灭度者皆令灭度。悉来诣我。于时诸天人民阿须伦揵沓和迦留罗真陀罗摩睺勒一切云集。吾于讲法现其道谊。佛为道父分别道慧。佛语迦叶。于时黎庶无数亿垓。皆来听经。如来通见一切根本。大精进力如应说法。分别散告无量言教。不失本心咸令欢喜。安隐无患或得度世。终生善处恣其所好。各自然生。或习爱欲便为说经。或听受法离诸贪惑。转稍以渐遵诸通慧。因从本力如其能量。坚固成就平等法身。犹如大雨。普佛世界滋育养生。等无差特。如来演法一品如是。至解脱味离欲寂灭。入诸通慧。若听受持讽诵奉者。不自识省无所观念。所以者何。群生根本形所像类。如所想念。已念当念所可施行。以行当行所当行者。诸所因缘。所当获致所当说者。唯如来目悉知见之。在所现处住于其地。如雨等润药草丛林白黑青赤上中下树。世尊如之见一味已。入解脱味志于灭度。度诸未度究竟灭度。令至一土一同法味。到无恐惧使得解脱。化于众生使得信乐。苞育将护悉令普至于诸通慧。赞咏分别逮贤圣法。亦如向者迦叶所说。世尊欲重解谊所趣。以偈颂曰

  吾兴于世间　　仁和为法王
  为众生说法　　随其所信乐
  意勇建大业　　久立分别说
  群萌多受持　　蒸庶无所言
  法王慧难解　　闇冥设闻者
  众入怀狐疑　　则弃所住处
  随其境界说　　如本力所任
  又示余利谊　　则为现正法
  譬如纯黑云　　涌出升虚空
  普雨佛世界　　遍覆于土地
  又放大电[火*僉]　　周匝有水气
  而复震雷声　　人民皆欢喜
  阴蔽于日月　　除热令阴凉
  欲放雨水故　　时布现在上
  彼时普等雨　　水下无偏党
  滂流于佛土　　泽洽众塸域
  应时而降雨　　激灌一切地
  旱涸枯溪涧　　一切得浸渍
  惠泽无不到　　众源皆涌溢
  深谷诸广野　　林麓慉幽薮
  萌叶用青仓　　药草无数生
  樛木诸丛林　　滋长大小树
  众药咸茂殖　　茎干华实繁
  随其本境界　　皆令得蒙恩
  诸天树木　　结根坑坎　　陜隘迮处
  而生其中　　如诸邪道　　一切愚痴
  长益系缚　　如象着绊　　草刺棘树
  芦苇[禾*曷][禾*曷]　　茎节枝叶　　及诸华实
  华实茂盛　　多所饶益　　蒙之恩雨
  药草滋长　　从其种类　　因本境界
  各各得服　　饥渴饱满　　如其所种
  各得其类　　然其天雨　　皆为一味
  告迦叶曰　　佛亦如是　　出兴于世
  譬如天雨　　这现天下　　为众说法
  以是诚行　　示于众生　　大仙以斯
  使人闻经　　皆于诸天　　人民前现
  佛为如来　　圣中之尊　　善权方便
  犹如天雨　　吾当饱满　　一切群萌
  愚騃之党　　身形枯燥　　除诸苦患
  得立大安　　烧尽爱欲　　获至灭度
  诸天人民　　皆听我言　　普悉当来
  诣佛大圣　　吾为如来　　世尊无伦
  有所导御　　故出于世　　为一切人
  分别说经　　化无数千　　众生之类
  又复示现　　若干种谊　　于彼若此
  常行平等　　得至解脱　　灭度无为
  或在门前　　而说经典　　则为造立
  道德之藏　　诸等不等　　皆令平等
  无有所憎　　爱欲永除　　未曾讲说
  无益之语　　未常增惟　　诸放逸缘
  以一切法　　为众生说　　假使众庶
  多不可计　　为讲大典　　不诡因缘
  行步所由　　若复住立　　在于座上
  而续三昧　　譬如大龙　　雨多所润
  普浸润斯　　一切世间　　寻兴慧云
  而降法雨　　畅发微妙　　应病与药
  常为众生　　说贤圣谊　　皆令奉戒
  如天阴凉　　众人失言　　及违诸行
  欲使近法　　转渐调柔　　使住疑者
  舍诸邪见　　劝化导利　　令净所睹
  舍置下劣　　远众懈废　　随其所趣
  而令入法　　应时为说　　如其心本
  令皆弃捐　　顺师子行　　世尊等演
  经法之雨　　悉使得至　　大尊佛道
  任其力耐　　而令听受　　若干道慧
  而化立之　　从诸天人　　志性所乐
  天帝释梵　　转轮圣王　　犹如于此
  诸小世间　　诸药品类　　各各异种
  碎小段段　　诸所良药　　迦叶且听
  吾悉当说　　以能识慧　　无漏之法
  便得无为　　所在游行　　神通三达
  亦复如是　　斯雨定意　　三昧诸药
  或有游诣　　在于山岩　　其人便得
  缘一觉乘　　于彼修禅　　清净之行
  是则名曰　　为中品药　　假使志愿
  上士美德　　我当于世　　逮成导师
  常精进行　　志依一心　　是则名曰
  为上尊药　　设使欲为　　安住之子
  恃怙慈心　　而行寂然　　疾得成道
  为人中尊　　所谓树者　　则喻于斯
  是等能转　　不退转轮　　建立神足
  根力之行　　缘是长养　　医药除病
  英雄度脱　　无数亿人　　随时示现
  于斯佛道　　是则名曰　　为大林树
  吾之所顺　　善权方便　　一切大圣
  亦复如是　　最胜讲法　　则为平等
  犹如庆云　　普一放雨　　神通无碍
  如此比像　　若如众药　　在于地上
  以见如是　　微妙之谊　　如来所建
  善权方便　　假使分别　　一善法事
  亦如天雨　　至若干形　　以佛法雨
  多所安隐　　普润天下　　有所成就
  观察其人　　堪任所趣　　佛之法诲
  景则一等　　譬如放雨　　堕草山岩
  及至中间　　无有不遍　　灌诸树木
  若大丛林　　密云四集　　天下丰羡
  设使世间　　行慈愍法　　常以经典
  饱满天下　　以现世间　　令普安隐
  天雨药草　　华实茂盛　　其药树木
  稍渐长大　　是为罗汉　　诸漏尽者
  诸缘觉品　　处于林薮　　我所说法
  无有尘垢　　无数菩萨　　志开总智
  周旋三界　　一切普行　　于众会中
  演此大道　　犹如树木　　日日滋长
  修进神足　　专达四禅　　若闻空慧
  心则解达　　放出光明　　无数亿千
  是为大树　　而复滋茂　　若诸声闻
  不至灭度　　斯为世尊　　第一最说
  若此分别　　乃为讲法　　犹如兴云
  而澍甘雨　　渐渐长育　　众药草木
  人民之华　　不可称量　　一时之间
  说因缘法　　而为众人　　现于佛道
  善权方便　　佛谓言教　　一切导师
  亦复如是　　斯诸说法　　为最究畅
  诸声闻等　　皆当承是　　缘斯之行
  当得佛行　　此诸罗汉　　如是无异
  世尊演谊　　尽极于斯　　化诸小乘
  皆得佛道

佛复告大迦叶。如来所教等化无偏。譬如日明广照天下。光无所择照与不照。高下深浅好恶香臭。等无差特。佛亦如是。以智慧光普照一切。五道生死菩萨缘觉声闻。慧无增减。随心所解各得其所。本无三乘缘行致之。迦叶白佛。设无三乘。何故得有菩萨缘觉声闻。佛言。譬如陶家埏埴作器。或盛甘露蜜。或盛酪苏麻油。或盛醲饮食。泥本一等。作器别异所受不同。本际亦尔一等无异。各随所行成上中下。迦叶又问。纵使别异。究竟合不。告曰。当合明者解之。譬若有人从生而盲不见日月五色十方。则谓天下无日月五色八方上下。有对说者其人不信。若有良医观人本病。何故无目。本罪所种。离明眼冥体瘿重病。何谓重病。风寒热癖是则四病。便心念言。斯人之疾。凡药疗之终不能愈。雪山有药能疗四病。一曰显二曰良三曰明四曰安。是药四名。于时良医愍伤病人。为设方便即入雪山。采四品药哺咀捣合。以疗其盲目便见明。又加针灸消息补写。斯人目睛内外通彻。睹日月光五色十方。尔乃取信寻自克责。我之盲冥。无所见闻自以为达。今眼得视。乃自知本愚蔽之甚也今睹远近高下无喻我者。时有五通闲居仙人。洞视彻听身能飞行。心能知人所念。自知所从来生死本末。而具语曰卿。莫矜高自以为达。仁在屋里自闭不出。不知外事。人念卿善恶。尚不能见十里五里。语言之音或二十里击鼓之音声犹不能闻。近一二里自不躇步。亦不能至自观未生胚胎所忆。亦不能识。有何通达。称无不见乎。今吾察卿身。冥中为明。明中为冥。其人问曰。作何方术得斯圣通。愿垂慧诲。仙人答曰。当入深山闲居独处。除诸情欲尔乃有获。即遵所训舍家岩燕。一心专精无所慕乐。则得神通尔乃自觉。察本所见不足言名。今得五通无所挂碍。甫自知本所见蔽闇。佛言。如是当解此喻。人在生死五道阴盖。不了本无则名曰痴。从痴致行从行致识。从识致名色。从名色致六入。从六入致更。从更致痛。从痛致爱。从爱致受。从受致有。从有致生。从生致老病死忧恼苦患。罪应集会故谓盲冥。是以世尊愍伤其人。升降三界轮转无际。不能自拔。观于众生心之根原。病有轻重垢有厚薄。解有难易。睹见远近。便见三乘。发菩萨心至不退转。无所从生径得至佛。犹如有目得为神仙。其良医者谓如来也。不发大意谓生盲也。贪淫嗔恚愚痴六十二见。谓四病也。空无想无愿向泥洹门。谓四药也。药行病愈则无有痴。名色六入所更痛爱受有生老病死忧恼苦患。皆悉除矣。志不作善亦不在恶。如生盲者还得两目。谓声闻缘觉生死已断。度于三界省练五道。自以通畅莫能喻者。临欲灭度佛在前住。诲以要法发菩萨意。不在生死不住灭度。解三界空十方一切如化如幻。如梦野马深山之响。悉无所有无所希望。无取无舍无冥无明。尔乃深睹。无所不达见无所见。见知一切黎庶萌兆。于是颂曰

  譬如日光曜　　遍照于天下
  其明无增减　　亦不择好丑
  如来犹若兹　　慧等殊日月
  普化于十方　　亦不有增减
  若如彼陶家　　埏埴作瓦器
  或盛甘露蜜　　或受苏油食
  计泥本一等　　为器各别异
  所受又不同　　因盛而立名
  人本亦如是　　无三界五道
  随行而随生　　展转不自觉
  解空号菩萨　　中住则缘觉
  倚空不解慧　　则名为声闻
  譬如人生盲　　不见日月光
  五色及十方　　谓天下无此
  良医探本端　　见四病阴盖
  慈哀怜愍之　　入山为求药
  所采药奇妙　　名显良明安
  哺咀而捣合　　以疗生盲者
  消息加针灸　　病愈目睹明
  见日月五色　　乃知本淳愚
  人不了无本　　坐堕生死径
  十二缘所缚　　不解终始病
  世尊现于世　　观察三界原
  因疾而随本　　各各开化之
  了空则菩萨　　意劣为缘觉
  畏厌生死苦　　故坠于声闻
  自谓道德高　　无能有喻者
  所睹极究练　　无所忧弊碍
  犹如五通者　　号名曰仙人
  愍而告之曰　　卿故有蔽碍
  不能弘深奥　　于愚则为明
  在内不见外　　虽明故为愚
  数十里有声　　耳则不得闻
  若人欲危害　　不知彼所念
  欲至外数里　　不躇步不到
  若生长大时　　不识胎中事
  五事表里彻　　尔乃为悉达
  何以忍贡高　　自谓无等伦
  欲得五通者　　当处于闲居
  精思专念道　　尔能晓了此
  即寻奉所诲　　舍家入深山
  一心无秽虑　　便得成神仙
  若得至声闻　　及获缘觉乘
  自谓慧具足　　与佛等泥洹
  临欲灭度时　　佛即住其前
  为现菩萨法　　三达无挂碍
  智慧度无极　　进善权方便
  度空无想愿　　菩萨由是生
  四等心四恩　　用开化黎庶
  解一切如化　　幻梦野马影
  深山响芭蕉　　三界无所有
  不执亦不舍　　无愚亦无明
  不生死泥洹　　悉等如虚空
  无见无不见　　乃睹一切本
  当尔时所见　　不造三界观
  一切普平等　　所济无有量

    正法华经授声闻决品第六

于是世尊说斯颂时。一切普告诸比丘众。吾尽宣告。此声闻比丘大迦叶者。曾已供养三千亿佛。方当供养如此前数。奉敬承顺诸佛世尊。禀受正法奉持宣行。竟斯数已当得作佛。世界曰还明。劫名弘大。佛号时大光明如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。寿十二中劫佛灭度后。正法住二十劫。其像法者亦二十劫。其佛国土甚为清净。无有砾石荆蕀秽浊之瑕山陵溪涧。普大快乐。绀琉璃地众宝为树。黄金为绳连绵诸树。有八交道。诸宝树木常有华实。悉皆茂盛。其土菩萨无央数亿百千垓。诸声闻等亦不可量亿百千垓。其土无有魔事及诸官属。诸魔营从皆护佛法。常行精进无所违失。尔时世尊。欲重解谊。即说颂曰

  我睹比丘　　以佛明目　　迦叶住此
  当成为佛　　于将来世　　无央数劫
  供养诸佛　　圣中之尊　　具足悉满
  三千亿佛　　斯大迦叶　　诸漏得尽
  便当越度　　三品之行　　当得佛道
  亲近法施　　供养诸佛　　天人之尊
  合集得至　　无上大道　　最于来世
  尊无上伦　　为大圣道　　无极神仙
  其佛国土　　最胜第一　　清净离垢
  若干显明　　随意所欲　　常可至心
  紫磨金色　　珍宝庄严　　复以珍宝
  成为树木　　有诸道径　　严八交路
  天人放香　　自然流馨　　彼时国土
  所有如是　　若干种华　　而为挍饰
  一切诸华　　紫磨金色　　出光音声
  以为法则　　普常微妙　　莫不见者
  诸菩萨众　　亿千之数　　志性调定
  逮大神通　　诸圣哲等　　奉方等经
  不可计数　　亿百千垓　　无有诸漏
  奉持志强　　所有声闻　　彼佛法胜
  假使天眼　　欲计劫限　　弟子之数
  不可称算　　其佛当寿　　十二中劫
  正法当住　　二十中劫　　像法亦立
  二十中劫　　大光明佛　　德当如是

于是贤者大目揵连。贤者须菩提。贤者摩诃迦旃延。等类同心侧立顶戴。瞻顺光颜目未曾眴。稽首足下战战兢兢。应时各各说斯之颂。而咨嗟曰

  大雄无所著　　释王无极人
  乃愍伤我等　　赞扬宣佛音
  今以知余等　　愍授我畴莂
  以甘露见灌　　沐浴众祐决
  譬如饥馑时　　丈夫得美膳
  虚乏叫唤求　　有人手授食
  吾等咸欢喜　　本为下劣乘
  违时舍众人　　虚乏不得决
  设至平等觉　　大圣不拜授
  于今处世伦　　则不复饮食
  世尊见劝励　　闻尊上音声
  唯垂见授决　　尔能获大安
  大哀愿散疑　　愍伤多所矜
  抚恤贫匮意　　甘露诱示子

于是世尊。见诸耆旧心志所念。即复重告诸比丘众。比丘当知。此大声闻耆年须菩提。当复奉侍供养八千三十亿百千垓佛。在诸佛所常修梵行。积累功德具足究竟。竟后世时当得作佛。号称叹如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。世界名宝成。劫曰宝音。普佛之土周匝悉遍。有诸宝树自然庄严。无沙砾石山陵溪涧。其树音声哀和柔雅。众庶产业不可称数。人所居跱馆宇若干。重阁交露有无央数声闻之众。欲计算者无能限量。悉识宿命。彼土菩萨亦不可计亿那术百千。其佛当寿十二中劫。灭度之后。正法当住二十中劫。像法亦立二十中劫。则坐虚空。为一切人讲说经法。开化无数百千菩萨。尔时世尊而说颂曰

  今吾普告　　诸比丘众　　悉且明听
  佛所班宣　　尊须菩提　　是吾弟子
  当来之世　　得成为佛　　大圣所见
  至诚无虚　　具足三十　　那术垓千
  当于世间　　遵修道行　　常志求斯
  佛之要道　　于彼来世　　究竟行已
  颜色殊妙　　相三十二　　威曜巍巍
  紫磨金容　　处世清净　　多所愍哀
  国土快乐　　所在显现　　无数人见
  踊跃可意　　悉当游行　　诣诸世尊
  度脱群生　　亿百千垓　　诸菩萨众
  不可计量　　而常广说　　不退转轮
  在最胜教　　诸根通利　　皆当恭顺
  彼佛国土　　诸声闻事　　不可计量
  欲有限算　　无能尽极　　六通三达
  获大神足　　脱门无碍　　而处安隐
  计神足力　　不可思议　　我假使说
  诸佛尊道　　诸天人民　　如江河沙
  常当叉手　　自归圣尊　　其佛当寿
  十二中劫　　正法当住　　二十中劫
  像法亦立　　二十中劫　　世雄导师
  劫数如是

尔时世尊重复宣告诸比丘众。比丘欲知坚固取要分别平等。是我声闻大迦旃延。后当供养奉侍八千亿佛。佛灭度后各起塔庙。高四万里。广长各二万里。皆七宝成。金银琉璃水精车磲马瑙珊瑚碧玉。香华杂香捣香缯彩幢幡供庙。如是过斯数已。当复供养二十亿佛。然后来世当得作佛。号曰还已紫磨金色如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。国土严净平等无邪。名闻显现琉璃为地。若干种树众宝校饰。紫磨黄金为绳连绵。诸树华实茂盛华遍。佛土无有地狱饿鬼畜生。但有诸天人民众多具足充满。又诸声闻无数百千那术之众。诸菩萨等无数百千。庄严国土。其佛当寿十小劫。灭度之后。正法当住二十中劫。像法亦住二十中劫。于时世尊。即说颂曰

  诸比丘众　　皆听吾教　　其佛音声
  当美柔软　　尊迦旃延　　为佛弟子
  当供养佛　　若干导师　　奉敬承顺
  恭恪无量　　无数世人　　不能称计
  若灭度后　　当起庙寺　　当以华香
  而供养之　　然于后世　　便得作佛
  国土清净　　无有瑕秽　　讲说发起
  亿千众生　　具足开导　　一切人民
  世界庄严　　光照十方　　当得作佛
  多所超喻　　号紫金色　　其德巍巍
  究竟群黎　　亿百千垓　　无数菩萨
  及诸声闻　　满其佛国　　无量难计
  常行精进　　于佛法教　　除断诸难
  灭终始患

于是世尊。复告四部众会曰。今佛大圣宣告尔等。是我声闻尊大目揵连。当悉供养奉侍于八千佛。承顺世尊一切无量。诸佛灭度当起塔庙。七宝校成。金银琉璃水精车磲马瑙珊瑚真珠。高四万里广长二万里。若干殊好众宝之物。供养塔庙。及与香华杂香捣香。缯彩华盖幢幡伎乐之娱。过是数已。当复奉敬二百万亿佛。供养承顺。最后世时当得作佛。号还已金华栴檀香如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。国土名意乐。劫曰乐满。其佛世界。快乐安隐清净鲜洁。绀色琉璃以为其地。诸树华实七宝合成。普以真珠众华庄校。平等端严众宝具足。诸大仙圣有亿百千。寂然而坐所谓无量。皆诸菩萨广说经法。其佛当寿二十中劫。灭度之后正法当住四十中劫。并计像法。尔时世尊则说颂曰

  大目揵连　　是吾弟子　　弃捐仁行
  犹得自在　　二百万亿　　诸劫之数
  悉当供养　　此诸佛教　　普于诸佛
  常修梵行　　而当志愿　　斯诸佛道
  悉当奉侍　　诸佛世尊　　具以承事
  导师之众　　皆当广普　　执持圣教
  若干亿劫　　百千之数　　殷勤承顺
  不违大命　　诸安住等　　灭度之后
  以众七宝　　兴立塔庙　　为诸最胜
  建修上业　　用栴檀香　　以为柱梁
  众香伎乐　　而供养之　　然于后世
  事究竟已　　言谈斐粲　　人所宗仰
  多所愍哀　　所为如此　　当得作佛
  号金栴檀　　其佛当寿　　二十中劫
  安住所更　　行德如是　　当为菩萨
  讲说经法　　于是劫数　　分别雅谊
  最胜声闻　　有无数千　　亿百千数
  如江河沙　　六通三达　　得大神足
  于安住世　　获致妙通　　无数菩萨
  悉不退转　　精进勇猛　　有志智慧
  修行如应　　顺斯佛教　　不可计量
  若干千数　　佛灭度后　　弟子多学
  正法当住　　流布十方　　正法像法
  四十中劫　　正法没尽　　像法乃出
  是佛声闻　　得大神足　　佛皆劝立
  在大尊道　　依倚大圣　　不违真法
  于当来世　　成佛自在

正法华经卷第三正法华经卷第四

        西晋月氏国三藏竺法护译

    往古品第七

佛告诸比丘。乃去往古久远世时。不可计会无央数劫。有佛号大通众慧如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。世界。曰大殖稼。劫名所在形色。其佛说经不可称限。譬如于是三千大千世界所有土地。有一士夫皆悉破碎此一佛国悉令如尘。则取一尘。过东方如千佛界中尘之数国。乃着一尘。如是比类复取一尘。越东如前佛界尘数。乃着一尘。悉使尘尽三千大千世界中尘。令无有余遍于东方。如是比类无量佛国。于意云何。宁可称限得诸佛界边际不乎。比丘答曰。不也世尊。不也安住。佛言比丘。如是等伦佛土诸数悠邈。犹如有人一一取尘着诸佛土。若干之限诸佛国尘不可称量。亿百千垓兆载诸劫。欲知其佛灭度以来劫数长久。不可思议无量难测。大通众慧道力示现。灭度以后法住劫数。亦复如是。世尊颂曰

  我念过去　　无数亿劫　　时有如来
  两足之尊　　名大通慧　　无极慈仁
  于时世尊　　黎庶之上　　比如皆取
  此佛世界　　悉破碎之　　尽令如尘
  假使有人　　一一取尘　　过千佛界
  乃着一尘　　如是次第　　圣尊国土
  其人着尘　　皆令悉遍　　若干之数
  悉令周普　　世界众限　　有不可数
  一切所有　　大圣国土　　诸所有尘
  不可限量　　皆悉破碎　　令无有余
  大圣至尊　　逝来如斯　　其佛安住
  灭度已竟　　劫数如是　　无量亿千
  若欲料限　　无能思议　　灭度已来
  若干劫数　　彼时导师　　过久乃尔
  诸弟子众　　及菩萨行　　如来之慧
  巍巍如斯　　今佛悉念　　圣灭度来
  比丘欲知　　佛之智慧　　圣明普达
  等无有异　　佛皆觉了　　过无数劫
  不计微妙　　无漏之谊

佛告诸比丘。其大通众慧如来正觉。寿四十四亿百千劫。以无上正真道。初升道场坐于树下。一劫默然至于二劫。不得正觉乃至十劫。而不兴起身不动摇。体不倾倚亦不自念。都无思想而向诸法。遂坐佛树降魔官属。当成正觉。忉利诸天子。化作大师子座。面四十里。佛坐其上。世尊坐定。诸梵天子普雨天华周四千里。自然风起吹放众华。散于佛上。佛在树下满十中劫。天华纷纷尽劫不绝。又四天王及诸天子。作众伎乐音如雷震。常以华香伎乐供养大圣。未曾休懈。佛告比丘。时世尊大通众慧乃至十劫。逮成无上正真之道。为最正觉至于灭度。供养不懈。其佛在家未舍国去。为太子时有十六子。端正殊好智慧难及。色像第一儒雅仁和。时十六国王子者。各各自有若干种乐。所居游观快不可言。种种显现。琴瑟伎乐亦不可量。见佛世尊成最正觉。时有自然大法音声。寻则弃国。舍转轮王位万民伎乐诸欲之娱。眷属围绕。及诸圣贤大响帝王百千之数。并不可计亿百千垓。群萌之类营从集会。往诣世尊所处道场。欲得稽首奉受佛教。群从佥然雍雍肃肃。稽首佛足绕佛三匝却住一面。以偈颂曰

  大通众慧　　极尊无上　　积累平等
  无量亿数　　以上妙谊　　愍伤一切
  所愿具足　　于是贤圣　　修勤苦行
  竟十中劫　　专精一心　　处在一座
  其身清净　　而不动摇　　烧诸苦患
  如拔树根　　分别于心　　而志湛泊
  未曾进退　　亦不倾倚　　无有增减
  默然而应　　究竟寂定　　无有诸漏
  现在吉祥　　常获大安　　无想着故
  得尊佛道　　我等见之　　增智无畏
  如是比类　　长益德义　　不计身命
  皆断苦患　　积累忍辱　　不贪安乐
  分别道慧　　不处恼痛　　号在间居
  兴发精进　　其不笃信　　诸佛音声
  长夜增益　　恶道之罪　　则失人身
  堕落恶趣　　为一切世　　所见谤毁
  今以逮见　　世之圣父　　其道最上
  无有众漏　　于此世间　　而见救护
  及诸过去　　大圣导师

佛告比丘。斯诸帝王及诸太子。太子兄弟年既幼少。嗟叹称誉大通众慧如来至尊等正觉。以此雅颂宣扬已竟。启劝世尊。愿说经法安住分别。多所安隐多所愍伤。饶益众生安诸天人。复以此偈。而赞颂曰

  惟愿大圣　　赞说经典　　开化众生
  发起黎庶　　三界群萌　　悉共渴仰
  使建道意　　皆令蒙度
  诸佛普大圣　　百福法庄严
  无极仙逮获　　慧则最尊妙
  为诸天讲法　　及世间人民
  度脱我等类　　普及诸群萌
  应时彰现露　　如来之慧谊
  犹如今于此　　显导上尊道
  令诸群品类　　予等获此法
  悉解于一切　　诸行慧本末
  皆为分别说　　前世所行德
  普见知黎庶　　心本所好乐
  则为转法轮　　最胜无等伦
  勉脱众生厄　　悉令至大道

佛告诸比丘。于时世尊大通众慧如来变化十方世界。各各五百亿百千佛土六反震动。光明普照无所不周。皆于一切诸佛境界。虚空大神若干种明。日月光耀远照无极。尊无等伦诸天宫殿馆宇之明。梵天往返自然威曜。其佛变现瑞应光明。皆覆蔽之悉令不现。天上世间晃昱晖曜。众生品类若生彼界。皆相见知各自说言。此问今日卒有人生。时于天上震动所现。靡不周遍

尔时东方佛土边无限。亿百千梵天宫殿。自然为明威曜巍巍。诸梵自念。无数梵宫宫殿馆宇[火*霍]明。无所不接。有何瑞应而现斯变。于时五百世界诸亿百千大梵天众。各从宫殿云集而会。时于众中有大梵天号护群生。为诸梵天。而叹颂曰

  今日我等　　宫殿室宅　　诸贤当知
  此大光明　　诸天最胜　　志所乐喜
  以何因缘　　现此瑞应　　善哉当往
  趣求斯谊　　时诸天子　　今日自兴
  承何圣旨　　现神如是　　今所睹见
  本未曾有　　亲近诸天　　为人中王
  将无大圣　　兴出于世　　最妙光明
  照于十方　　所变感动　　乃如是乎

佛告诸比丘。时五百世界亿百千垓梵天。悉共相和从东方来。遥见西方大通众慧如来正觉。处于道场在菩提树下坐师子床。诸天龙神阿须伦迦留罗真陀罗摩休勒人与非人。及十六子眷属围绕。适睹是已。悉共启劝欲令说经。即诣如来稽首于地。绕佛无数匝。执其莲华如大须弥。及散佛树。树高四十里。普已本土梵天宫殿。奉进世尊。惟愿哀愍纳受宫殿华土之供。以偈颂赞曰

  见佛无量　　得未曾有　　多所愍伤
  兴出于世　　世尊所演　　如师子吼
  则已将护　　十方黎庶　　我等经历
  所从来处　　去此五百　　亿百千界
  计诸世界　　若干之类　　皆弃宫殿
  咸诣圣尊　　一切皆是　　宿命净德
  若干丽妙　　诸宝宫殿　　惟加临眄
  而居其中　　愿发大哀　　愍伤受之

佛告诸比丘。时大梵天众面赞叹佛五百人俱白世尊曰。愿转法轮演大圣典。勉济群黎使获灭度。时五百梵天亿百千众。合一音声。而叹颂曰

  世尊愿说经　　两足上分别
  当现慈心力　　度众勤苦患

佛告诸比丘。于时世尊。见诸梵天所上宫殿。默然受之。尔时东南方去是五百亿百千世界诸梵天众。各各自从宫殿皆见光明。晃晃铄铄无不周接。怪未曾有悉俱集会。于众会中有大梵天。号最慈哀。为诸梵天而叹颂曰

  诸大天当知　　此则本瑞应
  宫殿悉感动　　最有大名闻
  有德诸天子　　人人云集此
  则是其威神　　令宫殿巍巍
  今佛兴于世　　两足之中尊
  所以令馆宇　　现光明如是
  吾等当往质　　斯事不可妄
  从昔至于今　　睹瑞无若兹
  四方有光明　　至于亿国土
  今有定至诚　　佛当成于世

佛告诸比丘。时五百亿百千梵天。各从宫殿骆驿四出。以诸天华如须弥山。诣西北角。遥见如来大通圣慧处于道场于佛树下坐师子座。诸天龙神阿须伦迦留罗真陀罗摩休勒眷属围绕。而为说经法。适见佛已寻时即往。稽首于地绕无数匝。手执大华而散佛上。时大梵天及诸眷属。以颂赞曰

  礼无等伦　　则为大仙　　天中之天
  声如哀鸾　　唱导普护　　诸天人民
  愿稽首礼　　愍伤世俗　　得未曾有
  在在难值　　久思光颜　　今日乃见
  本于百劫　　积德解空　　八十亿佛
  寿如尘劫　　又人中尊　　分别空慧
  而常讲说　　善权方便　　诸天群臣
  人民得觐　　具足亿垓　　八十之数
  其眼彻见　　在所救济　　多所拥护
  于佛道法　　故出于世　　愍伤众庶
  我等福会　　甚难值遇

佛告诸比丘。无数亿千梵天之众。劝发世尊愿转法轮。演出典谊散告群生。救脱三界令获安隐

尔时诸梵天悉俱等心。同声赞曰

  最上大人　　愿转法轮　　惟讲经典
  为十方人　　度脱群萌　　苦恼之患
  令一切人　　喜踊亘然　　其有闻者
  得成佛道　　诸天人民　　咸蒙安隐
  阿须伦身　　当复减损　　施于忍辱
  安隐之事

佛告诸比丘。大通众慧如来默然可之。南方西方亿百千垓诸佛世界。诸大梵天宫殿馆宇悉为普明。弈弈煌煌靡不周达。时诸梵天。自见宫殿威变煜爚。怪未曾有悉俱集会。各自念言。我等宫殿何乃如之。于其众中有大梵天。名曰善法。独叹颂曰

  大圣而兴　　所举不妄　　一切宫殿
  威光重照　　有此瑞应　　现于世间
  善哉行求　　如斯奥谊　　过去无数
  亿千诸劫　　未曾睹见　　如是感动
  将以如来　　出现于世　　令诸天子
  自然来会

佛告诸比丘。时五百百千亿诸梵天人。从其所处。遥见大华如须弥山。各手执持众供养具行诣北方。瞻觐如来大通众慧佛处于道场坐树下师子座上。与无央数诸天龙神阿须伦迦留罗真陀罗摩休勒眷属围绕。讲说经法。即诣佛所稽首于地绕无数匝。手执大华如须弥山。供养散佛。寻以宫殿奉上世尊。惟愿愍伤受而处之。时诸梵天等心同声。而叹颂曰

  诸佛现世　　甚难得值　　久不瞻睹
  今日乃觐　　侥幸来至　　蠲除爱欲
  具足充满　　于三千刹　　诸大导师
  饱满饥虚

  古来至今　　未曾见闻　　如灵瑞华
  鲜可遭值　　道慧难遇　　时时乃有
  我等宫殿　　雅丽无量　　承佛威神
  而得获此　　唯垂大哀　　纳受所进
  愿处其中　　显现道因

时诸梵天劝请世尊。惟转法轮分别经典。令诸天神沙门梵志。多所愍伤普安一切。天上世间悉当蒙恩。于是梵天与群侍俱。等心同声。而叹颂曰

  幸愿世尊　　广演经典　　加哀当转
  大圣法轮　　讲若干法　　声若雷震
  惟愿愍伤　　吹大法螺　　以大经典
  雨于世界　　分别善教　　微妙之诲
  我等劝助　　愿讲道慧　　开度众生
  亿百千垓

西南方西北方东北方。各各如是。无数梵天不可计限。上方下方各各如是。自在宫殿。睹见光明靡不周接。怪之未有。各从斯去。五百亿百千世界诸梵天众。各舍宫殿来诣佛所。有大梵天名曰妙识。即叹偈曰

  善哉愿诸佛　　世吼获圣明
  为三界众生　　开示正觉乘
  普为世间眼　　达见于十方
  开通甘露门　　度脱无数人
  乃昔往古世　　人中尊变现
  空无思想念　　使现于十方
  长益乐地狱　　好喜畜生处
  后生堕饿鬼　　亿数难思议
  亡失于天身　　寿终堕恶趣
  若得听佛法　　进获平等道
  志行趣佛慧　　将护众黎庶
  皆得归安隐　　不失快乐想
  常不行佛道　　不处于正法
  违无量圣教　　即堕于恶趣
  睹见世光明　　以善故来至
  发一切众生　　而行于慈哀
  逮见于世尊　　解空慧无漏
  诸天及世间　　于斯悉劝助
  宫殿妙无量　　犹如威神德
  普施明月珠　　大导师愿受
  人尊愿受供　　愍伤幸宫殿
  令此群品类　　逮得无上道

佛告诸比丘。于时五百百千亿大梵天众。赞叹佛已。启劝令佛转大法轮。开度十方安隐世人。复叹颂曰

  思愿讲说　　无上法轮　　惟雷法鼓
  尊妙法音　　度脱众生　　勤苦之患
  加哀示现　　无为大道　　我等劝助
  唯圣说法　　救护余类　　及世间人
  音声柔软　　敷扬美响　　亿百千劫
  积累德行

佛告诸比丘。大通众慧如来。尔时见十方无央数百千亿众生劝请说法。及十六子国王太子。转大法轮三转十二事。开化发起沙门梵志诸天龙神众魔梵天及世人民。为说苦本是为苦谛。至习尽道由是尽苦。苦尽至道十二缘起具足分别。从痴致行。从行致识。从识致名色。从名色致六入。从六入致习。从习致痛。从痛致爱。从爱致受。从受致有。从有致生。从生致老病死忧苦大患。又告比丘。大通众慧如来三说经法。须臾之顷分别此谊。令十六亿百千垓众漏尽意解。逮得六通三达之智。无央数人皆得度脱。如是至三。第四说经。江河沙等亿百千垓群生听经。一一皆获漏尽意解。诸声闻众不可称计

尔时十六国王太子以家之信出家为道。皆为沙弥。聪明智慧多有方便。以曾供养亿百千佛。造立众行。求无上正真道。俱白佛言。今大会声闻众。无央数亿百千人。有大神足已具成就。惟为我等。讲演无上正真道谊。愿弘慧见指示其处。当从如来学大圣教。以共劝进观察其本。于时世尊。悉见幼童国王太子心之所念。则为国王及诸眷属讲说经法。八十亿百千垓人皆作沙门。于时彼佛观诸沙门心之本原。为二万劫说正法华方等经典菩萨所行一切佛护。皆已周遍。四部众会普等无异。十六幼童沙弥兄弟。闻佛所说悉共受持。讽诵讲赞。其佛授决。当得无上正真之道。说是经已声闻欢喜。十六沙弥无数亿百千垓诸菩萨众皆得本志。彼佛说是。于八万劫未曾休懈。说斯经已。即入静室精思闲定。四十万劫三昧正受

尔时十六王子为沙弥者。行菩萨道本是佛子。睹见世尊独处闲居。各各豫严法座。欲用敷演广彼法谊。于时都会八万四千劫分别说经。一一菩萨化度六十万江河沙亿百千垓。处于无上正真道。皆立大乘。其大通众慧如来八十四万劫。乃从三昧兴就法座。普告一切诸比丘众。十六王子所建功德难及无量。至未曾有智慧巍巍。则以供养无数亿百千诸佛。众行具足普受圣慧。入于道明合集佛智。诸比丘众皆当稽首。恭敬自归十六仁贤。数数莫懈。其志声闻缘觉乘。已得声闻缘觉之路。若行菩萨及成就者。其新发意皆当付此。诸族姓子。听所说经不拒逆者。皆当逮得无上正真之道成佛圣慧。诸族姓子顺世尊教。以是正法数数分别为一切说。其十六子具菩萨乘。一一开化六十江河沙等人。所生之处常共俱会。亦复普说听正法谊。各各值见四十亿百千诸佛世尊。或当复更见诸佛者。今我班宣四辈

佛言欲知尔时十六国王子乎。答曰不及也。佛言。今皆成无上正真之道。今悉现在处于十方说法救护。无数亿百千垓兆载声闻众。不可称计菩萨东方现在甚乐世界。有二佛号无怒山岗如来至真等正觉。东南方现在二佛。号师子响师子幢如来。南方现在二佛。号一住常灭度如来。西南方现在二佛。号帝幢梵幢如来。西方现在二佛。号无量寿超度因缘如来。西北方现在二佛。号栴檀神通山藏念如来。北方现在二佛。号乐雨雨音王如来。东北方现在二佛。号除世惧。今吾能仁。于忍世界。得成如来至真等正觉。合十六尊

又告比丘。吾等十六为沙弥时。在彼佛世讲说经法。众生听受。一一菩萨开化无量诸江河沙亿百千垓。发无上正真道者。今得成就为菩萨道。住声闻地者。渐当诱进无上大道。稍稍当成最正觉。所以者何。如来之慧难限难计。不可逮及为若此也。又告比丘。何所是乎。吾为菩萨时。开化无量亿百千垓江河沙等。听闻咨受诸通慧者。当来末世。或有发意。学弟子乘。成为声闻。后不肯听受菩萨之教。不解佛慧不行菩萨。一切志在无为之想。谓当灭度。甫当往至他佛世界。顺殊异行生异佛国。当求道慧志听启受。尔乃解知如来之法。有一灭度无有二乘也。皆是如来善权方便说三乘耳。如来正觉灭度之时。若有供养以清净行。信乐妙言趣于经典。一心定意为大禅思。当知尔时观于如来。皆普合会诸菩萨众。会诸声闻听受此法。尔乃睹见世间佛道。无二灭度也。如来正觉善权说耳。其乐下劣小乘行者。则自亡失远乎人种。不解人本为欲所缚。如来灭度时。若有闻说欢喜信者。佛恩所护

假喻旷野五百里路。迥绝无人亦无国君。有一导师聪慧明达。方策密谋隐知远近。将众贾人欲度悬迥。皆俱疲怠不能自前。各思恋曰。予等安处圣兴之土。本国平雅有君长师父。今来远涉极不任进。宁可共还免离苦难。导师愍之。发来求宝中路而悔。设权方便于大旷野。度四千里若八千里。以神足力化作大城。告众商人无怀废退。大国已至可住休息。随意所欲饭食自恣。欲得大宝于此索之。又告比丘。商人见城人民兴盛。快乐无极怪未曾有。离苦获安喜用自慰。无复忧恐饥乏之患。自谓无为如得灭度。停止有日隐知欲厌。即没化城令无处所。告众贾曰。速当转进到大宝地。吾见汝等行疲心惧。故现此城

又告比丘。如来如是。为人等伦唱道经谊。睹见生死长久艰难虚乏之患。现于三乘。禅定一心使得灭度。又佛从本说有一乘。闻佛讲法不受道慧。若患厌者谓当积行甚为勤苦。如来悉见其心所念志疲懈想。为现声闻缘觉易得。犹如无导化作大城。人民饶裕商者晏息。视如厌玩没之不现。为众商人说幻化城。其导师者谓如来也。大旷野者谓五道生死。众商贾人谓诸学者。将行求宝谓说道慧菩萨行法。中路厌玩不肯进者。谓佛难得累劫积功不可卒成。诱以声闻缘觉易办。化作城者谓罗汉泥洹。没城不现谓临灭度。佛在前立劝发无上正真道意。其罗汉事限碍非真不至大道。若至他方与佛相见。得不退转无所从生。乃为大宝究竟之事。佛语诸比丘。如来说法尔等闻之。谓悉备足。不知所作尚未成办。又如来慧普见世间一切人心。示现泥洹。如来至真等正觉。善权方便说有三乘。尔时世尊欲重解谊。说斯颂曰

  昔有大通　　众慧导师　　适坐道场
  于佛树下　　其佛定处　　具十中劫
  尚未得成　　究竟道谊　　诸天龙神
  阿须伦等　　普发精进　　供养最胜
  雨诸天华　　纷纷如降　　用散等觉
  人中之导　　于虚空中　　畅发雷震
  而以进贡　　上尊大圣　　最胜在彼
  行甚勤苦　　所行久长　　成无上道
  专精思惟　　于十中劫　　乃成正觉
  大通众慧　　诸天人民　　亿百千垓
  一切众生　　欢喜踊跃　　彼佛本有
  诸子十六　　皆顺禀受　　人中道化
  众庶之类　　亿百千垓　　眷属围绕
  造两足尊　　前稽首礼　　师长圣尊
  殷勤启谏　　愿说经典　　勇猛师子
  讲未闻者　　饱满我等　　及世人民
  十六荒域　　及此世界　　久远空墟
  大圣乃兴　　梵天宫殿　　亘然大明
  现众瑞应　　悉分别说　　东方世界
  亿百千垓　　五百国土　　自然震动
  彼有大梵　　自处其宫　　威神功德
  巍巍最上　　于时睹见　　此本瑞应
  寻即造诣　　愍伤俗者　　则以天华
  供散大仁　　皆用宫殿　　奉上世尊
  鼓乐弦歌　　赞佛功德　　劝谏正导
  令转法轮　　时人中尊　　默然受之
  寻为如应　　解说经法　　南方西方
  北方世界　　上方下方　　四隅境域
  亿千垓众　　梵天悉来　　各献所珍
  以为供养　　又复下方　　诸界梵天
  普亦如是　　等无有异　　皆以宫殿
  奉上大圣　　嗟叹如来　　悉共劝助
  愿转法轮　　光阐心目　　无数亿劫
  难得值遇　　惟垂示现　　往古根力
  加哀开[門@為]　　甘露法门　　普等法眼
  分别慧谊　　宣扬群典　　若干品类
  时佛为说　　遍示四谛　　一切具解
  十二因缘　　为显无黠　　令得眼目
  讲说生死　　忧苦空患　　一切世间
  悉从生有　　当知因是　　致于终没
  如来适说　　是法欲竟　　若干种类
  无央数人　　八十亿垓　　众生之俦
  于时听者　　住声闻乘　　何况余方
  立第一地　　彼时最胜　　所说经法
  如江河沙　　黎庶清净　　都卢志于
  声闻之行　　导师圣众　　计数若兹
  一切共算　　不能称限　　众等品类
  一一如是　　皆悉若斯　　立大上慧
  于时至尊　　十六圣子　　等俱学者
  齐共同心　　一切出家　　咸为沙弥
  而悉分别　　佛方等经　　吾等当成
  世之明父　　汝党如是　　皆得上慧
  斯诸众生　　悉令如此
  又如世尊　　为法之眼　　最胜至诚
  见人心本　　幼少为童　　常行平等
  而为众生　　说上尊道　　亿百千垓
  无底譬喻　　示现因缘　　寻获报应
  分别所兴　　诸通敏慧　　如诸菩萨
  所当造行　　于时大圣　　为现真谛
  显扬宣布　　斯正法华　　普雨讲说
  大方等经　　若干千颂　　不可思念
  无能限量　　如江河沙　　于时适说
  斯之经典　　则入静室　　三昧等观
  八十四万　　劫中澹然　　世雄尊师
  定意如斯　　时诸沙弥　　觐瞻大圣
  在于静室　　而不出游　　开化人民
  无数亿千　　觉了禅定　　清净无漏
  第一始设　　于大法座　　宣扬说此
  仁贤经典　　于安住教　　流布佛化
  如是比像　　所造弘广　　于江河沙
  不可称限　　亿百千数　　皆听启受
  安住之子　　一一开导　　算诸黎庶
  无能限量　　于时最胜　　灭度之后
  悉得觐于　　四十亿佛　　彼诸学士
  适闻斯名　　便即供养　　两足之尊
  有四事行　　离垢为贵　　悉得佛道
  现在十方　　斯十六童　　皆是佛子
  普在八方　　敷弘道諠　　于彼所说
  及听受者　　是诸声闻　　悉佛弟子
  步步各各　　若干色像　　今当亲近
  发大道意　　吾身尔时　　寤不觉者
  皆令一切　　咸得听受　　尔诸贤者
  号声闻子　　善权方便　　示诸人道
  吾前世时　　报应如斯　　应所说法
  是其因缘　　假使不忍　　修尊佛道
  比丘当知　　魔所娆因　　随其本性
  凶弊纵恣　　志不奉行　　不乐空慧
  无数百世　　渴不值水　　又当愚騃
  常处恐惧　　无数丈夫　　百千之众
  发迹而行　　欲度旷野　　又睹旷野
  殊迥艰难　　其里计数　　五百踰旬
  有一大人　　贤圣明哲　　导师开化
  心无所畏　　为彼贾人　　导示径路
  旷野悬邈　　多有艰恐　　无数亿人
  创碍羸惫　　各对导师　　而自诉讼
  吾等疲弊　　不能进前　　徒类今日
  欲退还归　　导师聪明　　为方便父
  谆谆宣喻　　诱诲委曲　　矜怜闇塞
  欲弃宝退　　坏败本计　　中路规还
  吾今宁可　　设神足力　　化造立作
  广大城郭　　严庄若干　　亿千人民
  而立房室　　令微妙好　　又当复化
  大江流河　　苑园浴池　　华实滋茂
  台馆殿宇　　墙垣绮[女*(替-曰+貝)]　　男女若干
  巨亿百千　　诱恤勉励　　使不恐惧
  各自侥庆　　欢喜悦豫　　今日得至
  于此大城　　入市所娱　　所欲之具
  心怀忻然　　如得灭度　　尔等及吾
  诸难以除　　以亲亲故　　欢悦所安
  今日一切　　恣所施为　　从己所乐
  周遍观采　　与卿同心　　故郑重说
  悉来聚集　　听闻所说　　吾以神足
  化作大城　　吾时观察　　枯燥荆棘
  每惧仁等　　创楚悔还　　即设善权
  化现众诸　　且宜精志　　顺路进前
  佛告比丘　　吾亦如是　　见无央数
  亿千众生　　患厌勤苦　　周旋迷惑
  以方便教　　而开导之　　故佛念斯
  如是利谊　　厌于佛道　　不得灭度
  一切道父　　而觉了之　　贤等事办
  今得罗汉　　故劝助立　　住斯德报
  偶察诸贤　　得至罗汉　　汝等一切
  皆弃众苦　　一切众会　　乃演斯法
  诸佛大圣　　善权方便　　讲说佛教
  大仙救护　　其乘有一　　未曾有二
  休息尔等　　故分别说　　由是教化
  此诸比丘　　当兴精进　　第一英妙
  诸仁当志　　一切敏慧　　菩萨典法
  无有灭度　　我常发求　　成诸通慧
  得达十方　　最胜之法　　颜貌殊妙
  相三十二　　当得佛道　　乃应灭度
  诸大导师　　说法如是　　且令休息
  自谓灭度　　适得休息　　言获无为
  缘是之故　　畅诸通慧

正法华经卷第四正法华经卷第五

        西晋月氏国三藏竺法护译

    授五百弟子决品第八

于是贤者邠耨文陀尼子。闻佛世尊敷阐善权示现方便。授声闻决当成佛道。追省往古所兴立行。又瞻如来诸佛境界。得未曾有欢喜踊跃。无衣食想支体解怿。不能自胜。于大正法或悲或喜。即从坐起稽首佛足。寻发心言。甚难及也世尊。未曾有也安住。如来至真等正觉所设方谋甚深甚深。非口所宣。此诸世界有若干品。以无数权随现慧谊。顺化群生分别了法。为此众人说其本原。方便度脱。世尊圣慧。悉知我等行迹志性之所归趣。乃复举喻说古世事及始发意。时满愿子稽首佛足却住一面。归命世尊。瞻戴光颜目未曾眴

佛言。善哉诚如所云。如来通见一切本际。推其深浅因行授与。如示声闻卑下小乘。淫怒垢除令得休息。乃导菩萨无极之慧。犹如昔者有一导师。行慈多哀怜愍贫厄。衣食不充求乞无获穷无资贿。乃为击鼓普令国境。谁欲入海采珍宝者。人民皆会。复循令言。谁不爱身不嫪父母不顾妻子者。当共入海采求珍宝。人民闻令退还者多。又诸贫乞欲规采宝。无衣覆体无资自济。前却犹豫不能自决。导师知之悉召告曰。设欲入海相给衣粮不使空乏。诸贫欢喜。即奉教命一时上船。望风举帆游入大海。不逢大鱼不触山崖。弊鬼罗刹亦不敢娆。得至龙宫。便从龙王求如意宝。俗人贫厄不自谐活。愿见惠施以救远近。龙王即与随所侥愿。若欲得者悉令来取。导师还令。行取者少不取者多。所以者何。心怀恐怯。到龙王所惧没不还。于时导师告诸贾人。各恣所欲。贾人悉采金银琉璃水精虎珀车磲马瑙。各取满船。导师严敕。还阎浮利。众人从命归到本土。家室亲里。饮食伎乐车马乘从。悉来迎逆。共相娱乐七日七夜。乃归家居。各各相问。得何等宝。少智贫乞但得七宝导师。慧侣获如意珠。师升高楼手执宝珠。周向四方四隅上下。斯珠之德令雨七宝。寻如所言则雨七宝。普遍其国无所不满。其余慧侣分布诸国。四出周行亦雨七宝。少智贫士乃更呼嗟。我俱入海恨不值此。导师告曰。吾敕令卿。卿不往取今何所望。众人弃宝更相合会。共还采宝。诣海龙王求如意珠。即悉得之。还阎浮利亦雨七宝

佛言。发无上正真道意欲度一切。譬如导师行入大海。愍诸贫匮令入海者。谓为一切讲说经道。望风举帆入大海者。谓学权智。海三难者。谓空无想无愿。海谓生死。得如意珠谓获如来无极法身。众又随从取如意珠。谓闻菩萨道而发大意得无从生。贫劣下人采取七宝各自满船。谓得七觉意。还归乡里家室迎者。谓十方人来受道教。升楼执珠向八方上下。谓得佛道度脱十方。谓诸慧士等分至诸国雨七宝者。谓各诣他方成最正觉。众贫悔还相命入海。谓诸声闻闻有一乘无二道也。尔乃更发无上正真道意。后当成佛各有名号。于是颂曰

  比丘当听　　解喻说之　　如有导师
  愍伤国人　　多贫匮乏　　常苦汲汲
  击鼓巡令　　谁欲入海　　众人集会
  更告之曰　　不惜身命　　不嫪父母
  不顾妻子　　当共入海　　海中有难
  无得变悔　　时诸贫乞　　亦欲有意
  恐不自致　　沉吟不决　　导师宽恕
  给其衣食　　时入大海　　各求七宝
  于是导师　　诣龙王宫　　并告所领
  求如意珠　　等侣受教　　获如意珠
  还归乡里　　大小悉迎　　于时导师
  升高楼上　　向于八方　　遍雨珍宝
  朋党分行　　在于异国　　亦雨七宝
  莫不蒙恩　　采七宝者　　乃自悔恨
  俱行入海　　怨不值是　　导师告曰
  前相敕令　　自不肯取　　是若等过
  何所怨责　　即还入海　　求如意珠
  寻则得之　　发意菩萨　　得正真道
  畏厌生死　　便随声闻　　奉行空事
  无想无愿　　得度三界　　至泥洹门
  见佛世尊　　降魔官属　　至于无上
  正真之道　　开化一切　　出万亿音
  十方群生　　莫不受教　　天龙鬼神
  皆来稽首　　发菩萨意　　至无从生
  或为声闻　　断三垢毒　　睹见十方
  无所挂碍　　诸罗汉等　　乃自咎悔
  俱行学道　　何为得斯　　坐起行步
  懊恼自责　　如来然后　　现于三乘
  善权方便　　随顺诱导　　道无有二
  况乃三乎　　诸声闻等　　尔乃踊跃
  其心[火*霍]如　　云除日出　　佛皆授决
  当至大道　　国土处所　　各有名号

佛告诸比丘。宁见声闻满愿子乎。于比丘众为法都讲。光扬咨嗟诸佛之德。敷陈正典精进劝助。开佛说法讽受奉宣。散示未闻而无懈废阐弘谊趣解畅槃结。应答四部不以厌惓。显诸梵行悉令欢喜。舍除如来菩萨大士辩才质疑。未曾有如满愿子者。于比丘众所取云何。其满愿子。岂独为吾作声闻乘而受法典也。勿造斯观。曾已历侍九十亿佛。从诸世尊启受正要。所在众会常为法讲。宣散经谊分别空慧。志无所著。若说经时无有犹豫。靡不通达未常弊碍。普恒尽心诸佛世尊菩萨神通。毕其形寿令修梵行。于声闻众信意想之。以斯善权利益救济。于无央数亿百千垓群生之类。开化无量阿僧祇人。令发无上正真道意。其所游至皆为黎庶。显畅大道令得佛住。一切所修。常为己身净诸佛土。所行如应开化众生。于诸正觉普现供侍。今于吾世为尊法讲。每受正典论议难及。贤劫之中兴显千佛。又当供养将来世尊。亦皆为尊法之都讲。常为无量无极品类。光益训谊。劝化一切无限蒸民。令发无上正真道意。具足满进菩萨道行。却无数劫当成为佛。号法照曜如来至真等正觉明行成为善逝世间解无上士道法御天人师。当于此土而为大圣。尔时江河沙等三千大千世界为一佛土。七宝为地。地平如掌。无有山陵丘墟溪谷荆棘砾石。重阁精舍周匝普满。而用七宝。犹如诸天宫殿丽妙遥相瞻见。天上视世间。世间得见天上。天人世人往来交接。其土无有九十六种六十二见憍慢罗网。一切化生不由女人。净修梵行各有威德。以大神足飞行虚空。常志精进所作备具智慧普达。紫磨金容三十二表。大人之相。是时人民常有二食。一曰法食。二曰乐禅悦豫。是为二食。有无央数亿百千垓诸菩萨众。悉得神通周旋分别坟籍谊理。其声闻等皆逮圣行。行八脱门威曜方便。名德奇雅得度无极。劫名宝明。世界曰善净。佛寿无量劫。灭度之后法住甚久。起七宝塔遍是世界。十方诸佛皆共歌叹斯土功德。佛说如是欲重解义。即而颂曰

  诸比丘听　　于此谊旨　　如吾所语
  诸天世人　　行权方便　　究竟善学
  若当遵崇　　修佛道行　　此诸众生
  脆劣懈废　　故当演说　　微妙寂静
  示现声闻　　缘觉之乘　　而常住立
  菩萨大道　　善权方便　　若干亿千
  以用开化　　无数菩萨　　斯声闻众
  故复说言　　上尊佛道　　甚为难获
  亿数群生　　被蒙淳化　　已得修学
  如是之行　　下劣懈废　　恣尚慢堕
  而当渐渍　　皆成佛道　　身口及心
  常遵所行　　如是声闻　　力势薄少
  畏厌一切　　终始之患　　而复严治
  净己佛土　　或复示现　　己在爱欲
  怒害嗔恚　　及闇痴冥　　睹诸众生
  迷惑邪见　　坏裂蠲除　　疑网弊结
  吾声闻众　　行亦如是　　应时随宜
  化此萌类　　以权方便　　发起一切
  悉为众人　　顺而广说　　告诸比丘
  我声闻备　　所行具足　　于亿千佛
  以欲救护　　斯佛正法　　觉了禅思
  而求于度　　所在自处　　为尊弟子
  博闻多智　　讲法勇猛　　当悦众生
  心不厌倦　　而兴佛事　　建立于道
  获大神通　　安住普达　　具足导利
  则是灯明　　察知众生　　常见根原
  为说经典　　使至清净　　诱导群萌
  亿百千垓　　分别宣示　　尊上正法
  处此大乘　　无上正真　　自见国土
  英妙清净　　将来之世　　亿百千佛
  应时供侍　　奉敬如是　　恒当将护
  于尊正法　　又复严净　　己之佛土
  讲说经典　　亿百千垓　　善权方便
  常遵勇猛　　当复开化　　无数众生
  悉在道慧　　无有诸漏　　彼每事敬
  诸大圣雄　　常当执持　　此佛尊法
  当得佛道　　自在导师　　名法光曜
  照闻十方　　其佛国土　　最尊快乐
  七宝之地　　普悉清净　　时劫当名
  为宝之明　　世界号曰　　善净严饰
  无数亿千　　诸菩萨众　　如是等类
  得大神通　　时佛世界　　众所嗟叹
  神通恢大　　善妙清净　　又诸声闻
  亿千之数　　皆为大圣　　贤猛之众
  神足极上　　行八脱门　　分别解散
  靡不开达　　其佛国土　　一切众生
  皆行清净　　常修梵行　　具足辩慧
  众德无乏　　庶人贤兴　　盛殷甚多
  诸贤人等　　人民繁炽　　但乐经典
  余无所慕　　其土亦无　　女人之众
  无有恶趣　　勤苦之患　　紫磨金色
  自然在身　　三十二相　　而自庄严
  而佛国土　　无衣食想　　在所欲得
  当说于斯

尔时千二百由己行者。各心念言。怪未曾有莫不喜踊。世尊加哀余皆得决。必愍余等使蒙其例。于是世尊。知诸声闻心之所念。告贤者大迦叶。今应真众千二百人。现在目下除阿难罗云。又是声闻知本际等。当供养六十二亿佛。过斯数已。五百弟子皆当作佛。号普光如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。优为迦叶。像迦叶。江迦叶。海迦叶。黑曜。优陀。阿难律。离越。劫宾[少/兔]。薄拘卢。淳[少/兔]善等。五百罗汉。皆当逮成无上正真道。为最正觉悉同一号。于是世尊而叹颂曰

  佛尊弟子　　姓曰本际　　当成如来
  世之导师　　将来之世　　无央数劫
  当化众庶　　无数亿千　　得为最胜
  号曰普光　　彼佛国土　　名曰清净
  当来之世　　无央数劫　　常见诸佛
  不可计量　　光音神足　　大力明父
  音声畅闻　　十方世界　　亿千众生
  周匝围绕　　唯但讲说　　尊上佛道
  诸菩萨等　　常修正行　　所乘端严
  尊妙宫殿　　所游行处　　无所想念
  得听受法　　于两足尊　　常往周旋
  他方佛国　　诸佛大圣　　如是比像
  已复供养　　广普至尊　　心中欣然
  多所悦可　　其诸国土　　皆一等类
  众大圣雄　　无有异名　　人中之上
  悉号普光　　如是俦类　　精进力行
  安住之寿　　极长难限　　劫数具足
  六万二千　　灭度之后　　正法当住
  圣所遗典　　存劫三倍　　又以像法
  当复住立　　过于正法　　转复三倍
  假使正法　　灭尽之后　　男女众多
  遭大苦患　　是诸最胜　　大圣伦等
  名号普光　　大士之上　　具足当为
  五百导师　　各各悉等　　皆成佛道
  其名普闻　　十方佛土　　神足大力
  及其境界　　正法功德　　正类如是
  悉当遵修　　宣此雅典　　一切所得
  皆当若兹　　现于天上　　及在世间
  如我往古　　施于清净　　广普光明
  人中之上　　所建立行　　悉耐从已
  各已受决　　多所愍哀　　无央数事
  成一平等　　如佛今者　　于世正真
  尊故兴发　　为迦叶说　　卿当念持
  五百佛名　　诸声闻众　　及余一切
  是故弟子　　犹得自在

尔时五百无著。目见耳闻如来授决。欢喜踊跃往诣佛所。自投于地稽首作礼。悔过自责。鄙之徒等每忆前者。自谓已得泥洹灭度。无有巧便。不能识练了别正归。弃背明哲志疲厌想。今乃得逮如来之慧。当成正觉。唯然世尊。譬如士夫入慈室藏。以明月珠置于结中。醉酒卧寐不自唯省。寤忘明珠不知所在。起之他国无有资用。饥乏求食计穷无获。思设方计周旋往反。乃得供膳心怀悦豫。于时乃念前寝室藏。明珠系结将无堕彼。驰还求索。寻即往见慈室长者。慈室长者而谓之曰。卿何以故而自劳烦。行求饭食思想不息。子欲知乎。尔时吾身严整衣服。游行采毅敬利所谊。行至于此见明月珠。系于子结今珠在体。岂不省耶。以何因缘来至吾计。设何方便而尽力行。子今求财宝所以难致者。以不自察可否之事。且便疾去以明珠宝。持诣大龙而贸易之。由得诸宝所有之藏恣意所施。昔者世尊本始造行。为菩萨时发诸通惠。我等不解亦不觉了。于今悉住罗汉之地。而谓灭度。处崄难业常如虚乏。今日如此乃能志愿于诸通慧。当以斯法开化余人。以如来慧分别道意。比丘尔等。勿以此谊谓泥洹也。卿诸贤者。又当亲殖众德之本。昔者如来以权方便开导若等。今亦如是重说经法。若之徒类自取灭度。今者世尊。授以无上正真道决。于是五百声闻知本际等。而叹颂曰

  我等闻斯　　乃知前失　　已得受决
  是上佛道　　稽首世尊　　无量明日
  唯愍讲斯　　所演光耀　　犹如愚冥
  不能分别　　所以一一　　而获灭度
  今日欢然　　安住所化　　志愿广普
  诸通慧事　　如有一子　　行来求索
  即时游入　　于慈室堂　　于彼睹见
  多财富者　　于时富士　　广设饮食
  其人一寐　　而不饮食　　明月珠宝
  而系在结　　因此卧寐　　从寐而起
  坐慈藏室　　而欢喜悦　　彼愚騃子
  而越利谊　　寻时起去　　远行入城
  求服饮食　　甚不能获　　行索供膳
  财自系活　　从人得食　　谓获无为
  明珠约结　　而自念言　　今此珍宝
  为在不乎　　续在佩身　　求不知处
  故复睹见　　慈室长者　　所可施与
  丈夫之事　　即为示说　　善哉快言
  畅现妙宝　　教化令度　　其人适见
  第一安隐　　蒙宝之恩　　获致于斯
  有无极财　　藏满丰盈　　又以五欲
  而自娱乐　　如是世尊　　说譬若兹
  吾等前世　　俱发志愿　　非是如来
  之所兴为　　于往古时　　长夜精进
  世尊我等　　下劣心弊　　不能觉了
  如来教化　　心无志愿　　不肯进前
  而以泥洹　　欢喜自庆　　如佛圣教
  所觉开度　　如是计之　　无得灭度
  人中之上　　愍发慧谊　　乃为灭度
  第一无为　　此结明珠　　离垢上珍
  今日我等　　所闻无限　　因从化导
  普显怡怿　　各各逮得　　别授殊决

    正法华经授阿难罗云决品第九

于是贤者阿难自念言。我宁可蒙受决例乎。心念此已发愿乙密。即从坐起稽首佛足。贤者罗云。复前自投世尊足下。俱共白言。唯为我等演甘露味。大圣是父靡不明彻。无归得归无救得救无护得护。于诸天阿须伦。兴立庄严若干种变。阿难罗云。则是佛子亦是侍者。持圣法藏。惟愿世尊。孚令我等所愿具足。授无上正真。又余声闻合二千人。与尘劳俱皆从坐起。偏袒右肩一心叉手。瞻戴尊颜我等逮见。佛告阿难。汝于来世。当得作佛。号海持觉娱乐神通如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。先当供养六十二亿佛恭顺奉侍。执持正法将护经典。然后究竟成最正觉。于是开化二十百千江河沙等天人。使发无上正真道意。其佛国土清净无瑕。地绀琉璃。竖诸幢幡。自然庄严世界平正。无沙砾石山陵溪谷。地皆柔软如天綩綖。劫名柔和。无有雷震。时佛寿命不可计数亿百千垓。无可为喻难得崖底。诸弟子众受道教者。不可计会亿百千垓无能限量。阿难成佛为大圣时。所以名曰海持觉娱乐神通。其土人民多神变周旋如来灭度后法住过倍。像法存立复倍正法。十方无量江河沙等亿百千佛。悉当叹颂彼佛功德。于时世尊。而赞叹颂曰

  今佛颁宣　　诸比丘众　　仁者阿难
  总持吾法　　于当来世　　成为最胜
  供养诸佛　　六十二亿　　名曰海持
  觉乘神通　　于此博闻　　彼成大道
  其土清净　　显现微妙　　自然跱立
  无数幢幡　　诸菩萨众　　如江河沙
  皆是如来　　之所建发　　悉如最胜
  无极神足　　其德名闻　　流遍十方
  欲计寿命　　无量难限　　教化世间
  多所愍伤　　假使其佛　　灭度之后
  正法当住　　过倍其数　　像法存立
  转复过倍　　最胜宣发　　教化若兹
  又此众生　　如江河沙　　兴报应心
  立以佛道

尔时新发意八万菩萨。各自念言。怪未曾闻古来未有。吾等焉用菩萨谊。为诸声闻类顽嚚之俦。乃复授决当获大道。何因若兹。世尊即知其心所念。便告之曰。诸族姓子及比丘听。佛法平等。族姓子。这发无上正真道意。前于超空如来至真等正觉所。而现在博听众经。常修精进。来至吾所欲建殷勤。由是缘故。速得无上正真道成最正觉。仁贤阿难。为佛世尊奉持法藏。修菩萨行。出家之缘意履雅愿。以诸族姓子用相托付。尔时阿难自亲从佛。闻已无量空无之谊。当得成佛授国土决。闻本行愿欢喜悦豫。寻即忆念无央数亿百千之垓诸正觉典。又观本行所履之迹前后劫数。即叹颂曰

  我本闻有　　无量诸佛　　悉念为余
  说经典时　　诸有灭度　　最胜大圣
  余皆忆识　　如所闻说　　得立佛道
  心不怀疑　　如是比者　　善权方便
  而为安住　　立侍者地　　以大道故
  奉持正法

于是世尊告贤者罗云。罗云思之。汝当来世当得作佛。号度七宝莲华如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。则当供事如十世界尘数如来。当为诸佛现作尊子。亦复如今为吾息也。其度七宝莲华如来。国土寿命教化众生所有庄严。亦如海持觉娱乐神通世界清净。罗云当为其佛尊子。过是已后当得无上正真道成最正觉。时佛颂曰

  罗云是我　　尊上长子　　幼少精童
  柔和殊妙　　斯佛之子　　当得大道
  常以法施　　多所悦喜　　无数亿佛
  所见哀念　　欲得算计　　无能限量
  普为最胜　　诸佛之子　　当成大道
  众比丘像　　又此罗云　　所行温雅
  兴立殊愿　　奉吾正戒　　咨嗟宣扬
  世雄导师　　言我今是　　如来之子
  诸德无量　　亿垓之数　　设有思念
  莫能限量　　其罗云者　　佛之长子
  今所通履　　住佛道故

尔时阿难罗云。俱白佛言。今我等见二千声闻。学弟子戒心怀忻然。瞻戴尊颜。道法正典不可思议。愿及是时。佛告阿难罗云。宁见二千声闻学弟子法戒者乎。阿难白佛言。唯然见之佛告阿难。斯党同行等学大乘。当供养五百世界尘数如来执持正典。然于后世一时同集。布于十方各各异土。逮成无上正真道为最正觉。号宝英如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。其寿一劫。觉慧平等。诸声闻同多少无差。诸菩萨众亦复如是。灭度之后正法住立。数亦无异。时佛颂曰

  此诸声闻　　二千朋党　　今悉住立
  于世尊前　　斯等圣智　　佛皆授决
  将来之世　　便当成佛　　而显示现
  无量譬喻　　睹见诸佛　　悉当供养
  便当逮获　　无上尊道　　住于道行
  犹得自在　　其名行异　　游处十方
  悉当忍辱　　须臾不变　　当复独处
  坐丛树下　　当得佛道　　成就慧谊
  皆当成觉　　号同一等　　名曰宝英
  流闻世界　　其佛国土　　平等殊特
  诸声闻众　　等亦如是　　神足光明
  皆遍世间　　周流一切　　十方国土
  分别经法　　有所依猗　　正法存立
  等无有异

于是诸学闻佛授决。欢喜踊跃不能自胜。以颂赞佛

  闻佛授我决　　世光见饱满
  如甘露见灌　　已获无极安

正法华经卷第五正法花经卷第六

        西晋月氏国三藏竺法护译

    正法花经药王如来品第十

佛告诸比丘。道法一等无有二乘。谓无上正真道。往古来今无有两正。犹如众流四渎归海合为一味。如日所照靡不周遍未曾增减。若族姓子欲至正觉。解无三涂去来今者。当学受持正法花经。分别空慧无六度想。不以花香伎乐供养。为供养也。当了三脱。至三达智无极之慧。乃为供养。所以者何。乃昔久远劫难称限。尔时有佛。号药王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。世界名大净。劫曰净除。药王如来寿二十中劫。诸声闻众三十六亿。菩萨大士有十二亿。时转轮王名曰宝盖。典主四域。王有千子。端政勇猛。有七宝圣臣。降伏怨敌。其王供养药王如来。具足五中劫。与眷属俱一切施安奉敬药王。过五劫已告其千子。吾已供侍如来。若等亦当顺遵前绪。于时千子闻父王教。复以五劫供养药王如来。进以上妙不违所安。彼一太子名曰善盖。闲居独处静然思念。我等今者供养如来。宁有殊特超彼者乎。承佛威神虚空有天。而语之曰。今族姓子岂欲知耶。有法供养最尊无极。又问曰。何谓法之供养。天曰。尔当往问药王如来。普当为若分别说之。善盖即起诣药王如来所。稽首于地白药王如来曰。法之供养奉顺典者。为何谓乎。世尊告曰。法之供养者。顺若如来所说经典深妙优奥。开化一切世间人民。难受难见出家舍利。志求菩萨诸箧之藏。旷邈处中。以总持印而印之。精进力行不退转轮。现于六度无极之慧。殷勤揽摄佛之道品。不起法忍开入正典。于诸群生。设大慈哀。降伏魔兵离诸法见。觉了演畅十二因缘。无我无人非寿非命。志空无愿无想之法。不由众行。处于道场而转法轮。劝诸天龙揵沓和等。莫不乐仰。开阐法藏护诸贤圣。宣扬显布诸菩萨行。究竟众苦无我非身。群生违禁立以所便。众魔异道堕颠倒见贪猗有为。常怀怖懅而为咨嗟。诸佛之德。使灭生死慰除所患。而见安隐无为之事。去来今佛所叹如是。而割判了微妙色像。总持崖底诸法法忍。开道宣布阐发诸器。权便所义将养正法。是为法之供养。设于诸经志在法忍。敷陈典籍而顺反复。演训其要无诸邪见。无所从生不起法忍。无我无人入诸因缘。无嗔不诤无所讼诉。无我无寿循执句义。而无识着慧无放逸。将御心识住无所住。识理指趣因导非义。洮汰通流诸所猗法。不造见人恃怙真谛。如法所归无著无入。断诸猗着灭诸无黠。生老病死悉为除屏。观十二缘而不可尽。睹诸住见不随颠倒。是为族姓子法之供养。王子善盖。从药王佛闻法供养。应时逮得柔顺法忍。即脱身衣以覆佛上。白世尊曰。唯加圣恩建立我志。如来灭后。愿护正法兴法供养。降魔怨敌将迎后法。时佛知心。然其末世当护法城。佛告比丘王子善盖。因佛现在。以家之信出家为道。常精进学兴诸德本。不久成就立五神通。总持辩才无能断截。佛灭度后。神通总持力无所畏。即皆具足。于十中劫。药王如来所说经法。为转法轮。善盖比丘护正法故。于一世中化千亿人。悉发无上正真道意而不退转。十四载人立声闻缘觉地。不可计人得生天上。比丘欲知时王宝盖。岂将异乎。今现在佛宝[火*僉]如来至真等正觉是。其王千子。此贤劫中千佛兴者是。拘楼秦如来为始。最后成者名曰欣乐。太子善盖。今我身是。是故当知。一切所供无过法养。去来今佛皆从是出。若族姓子族姓女。欲得供养十方诸佛。即当受持正法花经。持讽诵读宣示一切。分别一乘无有三乘道。时佛颂曰

  假使有一　　欲解大法　　开化一切
  皆至正觉　　当孚受持　　斯法华经
  宣示远近　　诸未闻者　　譬如泉流
  皆归于海　　合为一味　　无有若干
  声闻缘觉　　及菩萨道　　一切皆归
  无上正真　　譬如日月　　照于天下
  百谷药木　　及诸荆蕀　　斯典如是
  以无极慧　　照耀三界　　皆入一义
  曩昔如来　　名曰药王　　时有圣王
  名曰宝盖　　五劫供养　　彼药王佛
  一切施安　　无所乏少　　告诸千子
  使供养佛　　千子受教　　踊跃等心
  供养如来　　亦俱五劫　　饮食床卧
  旛盖妓乐　　善盖太子　　闲居自惟
  宁有供养　　踰于此乎　　空中天言
  法供养胜　　即自问言　　何谓法养
  天便告曰　　当行问佛　　太子即问
  佛为具说　　难解之句　　深妙法藏
  空无想愿　　乃入正慧　　大慈大悲
  降伏众魔　　六十二见　　自然为除
  无常苦空　　非身之事　　无我无人
  无寿无命　　顺至将持　　不起法忍
  转不退轮　　法法相照　　十二因缘
  展转相生　　已解本无　　无有终始
  于是善盖　　得柔顺忍　　佛灭度后
  守护法城　　精进不懈　　得五神通
  总持辩才　　开化一切　　时千亿人
  皆立大道　　十四载人　　声闻缘觉
  无央数人　　得生天上　　以故叹称
  法供为最　　假使有人　　欲供养者
  当受持此　　正法华经　　分别如来
  善权方便　　无有二乘　　皆归一道

尔时世尊告八万菩萨。因药王开士缘诸菩萨等。宁察斯四部众。无央数亿天龙鬼神阿须伦迦留罗真陀罗揵沓和摩休勒人与非人。比丘比丘尼清信士清信女声闻缘觉菩萨。现在目睹欲闻如来说斯经典。一切众会闻一颂一偈。一发意顷欢喜劝助。佛皆授斯四部之决。当得无上正真道意。佛告药王。假使如来灭度之后。闻斯经典一颂四句。发意之顷代劝助者。佛皆授决。当得无上正真之道。前已奉侍亿百千佛。从亿百千佛发意立愿。是等俦类。愍伤众人故来生耳。从是经典受持一颂。讽诵书写载于竹帛。铭着心怀念而不忘。若听颂音恭敬察之。方如如来圣尊上句。若以华香缯彩幢幡。发意供养是经卷者。叉手向之稽首作礼。则当谓之世间自归。又告药王。若族姓子族姓女。假使能持一颂。劝助欢喜闻经卷名。若得闻名则当觉是。将来世尊展转相谓。族姓子族姓女。来世便为如来至真等正觉。所以者何。其受是经持读诵写。观听供养幡华缯彩杂香芬薰。则当谓斯族姓子女成无上正真道。得灭度已若觐如来。则普愍伤诸天世人。从其所愿而得自恣。常生人间欲演斯经。其人本已造微妙行。因所作行则当生于严净佛土。常自观缘欲讲法故。当知斯党愍伤群生。佛灭度故故来生此。则有反复如来所使。其族姓子则谓彼人行如来事。世尊所遣。其有讲说如来所宣。斯法训者若复不畅。其身续蒙。假使有人志姓凶崄常怀毒害。发意之顷。为其人说不可之事。其殃难测。若一劫中诽谤如来毁斯人者。罪等无异。是皆悉为如世尊种。若族姓子讲斯典时。有小童子受是经卷。白衣沙门。若以言语恶事向之。所不可意加于其人。使闻恶言。至诚虚妄宣扬怨声。则在殃罪。犹如害意向于如来。族姓子女。受斯经典持讽诵读。而不游行不为人说。当获衅咎。若受持经。当以衣被甘膳饭食香华灯火琦珍殊妙供养奉散。斯族姓子斯族姓女。则为大宝当为作礼。所以者何。乃能一反闻斯经典。若有听者以所供养。志愿无上正真道故。时佛颂曰

  若欲住佛道　　志慕己功德
  当供养彼人　　持斯经典者
  若乐诸通慧　　恣意有所说
  则当受斯典　　并供养侍者
  说此经法者　　愍伤于众生
  世吼之所遣　　来化群生类
  假使持是典　　所生常精进
  强勇而自来　　矜哀于众庶
  自在所欲生　　最后于末世
  从彼得睹遇　　斯经为尊上
  所当供奉养　　诸天人香华
  衣服诸覆盖　　常供给法师
  恭敬彼人　　常当如佛　　寻叉手礼
  自然圣道　　若最后时　　逢值斯经
  佛灭度已　　受持经卷　　常当供养
  如奉最胜　　饭食之属　　诸昧具膳
  房室床卧　　衣被亿数　　一反闻之
  崇进如是　　如来则授　　其人之决
  佛遣彼士　　来在人间　　若有最胜
  值遇斯典　　设使闻者　　书写执持
  于今佛在　　见于目前　　诽谤如来
  具足一劫　　心中怀恨　　面色改常
  其人即获　　无数殃衅　　设有受持
  是经卷者　　而分别说　　为他人解
  若有诽谤　　此等伦者　　其罪过彼
  不可计数　　假使有人　　面现赞佛
  而叉十指　　具足一劫　　清净志求
  斯尊佛道　　亿百千垓　　咨嗟赞颂
  称咏法师　　发心悦豫　　其人获福
  不可限量　　用宣誉是　　明智者德
  彼士获福　　复超于斯　　而有人来
  供养学者　　若于十八　　亿千诸劫
  其人供进　　珍馔众味　　诸天香华
  细柔精妙　　计劫之数　　十八千亿
  和声悦颜　　崎岖以献　　若有一反
  闻是经者　　得诸利庆　　无极难比

佛告药王菩萨。吾每散告。前后所宣经品无量。甫当说者经号甚多。比拟世间一切诸法。今此典颂。名祚显绰最尊第一。普天率土所不信乐。如来正觉无所毁败。于内燕居。密从法师受斯典者。则为如来威力所护。无能破坏。乃前世时曾得闻之。如来现在有闻斯典。多有诽谤。何况如来灭度之后。难得值遇。所欲志愿而见覆盖。观族姓子女为如此也。他方世界现在如来。悉睹见之。在所存立己身还闻。诸信力也。善本力。志愿力。在如来室等顿一处。斯之伦党德如是也。求如来水志存佛掌。是乃前世愿行所致。佛灭度后。若有信此正法典者。受持书写供养奉顺为他人说。德乃若斯。佛告药王菩萨。若有能说斯经训者书写见者。则于其人起佛神寺。以大宝立高广长大。不当复着佛舍利也。所以者何。则为全着如来舍利。其有说此经法之处。讽诵歌咏书写。书写已竟。竹帛经卷当供养事。如佛塔寺归命作礼。一切香华杂香芬薰。琴瑟箜篌幢盖缯幡。若有众生欲得佛寺稽首作礼者。当亲近斯经无上道教。又告药王。多有菩萨出家为道。及凡白衣行菩萨法。不能得致如是像经。及见读诵书写供养。其有菩萨。行菩萨行晓了权宜。假使得闻是佛景摸。菩萨所行共行法者听者。信乐来入其中。解达分明即受供养。于一座上应近无上正真之道。若有见者。如是士夫入于斯谊。德不可计。佛告药王。譬如男子渴极求水。舍于平地穿凿高原。日日兴功但见燥土。积有时节。其泉玄邃而不得水。复于异时。掘土甚多乃见泥水。浊不可饮当奈之何。其人不懈稍进得水。于时男子睹本瑞应。释除狐疑无复犹豫。吾兴功夫积有日月。今者乃能值得水耳。如是药王。设有菩萨闻是经典。而不受持讽诵学者。去于无上正真之道。为甚远矣。是景摸者。诸菩萨业。假使闻此正法华经。讽诵精修怀抱在心而奉行之。尔乃疾成最正觉矣。佛语药王。一切菩萨。其有不肯受讽行者。不能得至无上正真道。最正觉也。所以者何。吾前已说班宣此言。假使有人不乐斯经。则为违远于诸如来。此经典者。道法之首众慧之元。成就菩萨。若有菩萨闻此经典恐怖畏懅而不爱乐。则当知之。新学乘者。若不恐怖。则是久修菩萨之行。若声闻遇是经法。或恐或怖心怀畏懅。为憍慢恣。佛语药王。如来灭度之后。若有菩萨及大士等。欲以是经为四部说。着如来衣坐于世尊师子之座。然后尔乃为四部众宣传此经。何谓着衣于如来被服。谓人忍辱柔和安雅。是则名为如来被服。其族姓子。当修此衣。何谓世尊师子之座。解一切法皆悉空寂。处无想愿。是为世尊师子之座。又族姓子。当作是住所坐若兹。以此经法为比丘比丘尼清信士女天龙鬼神广分别说。其心踊跃不怀怯弱。志于大道开道四辈。其族姓子。若复处于他方世界。化作化人及与眷属比丘比丘尼清信士清信女颁宣此法。设使有闻而不乐者。吾起令乐必使爱喜。若在闲居圹野之中。有天龙神揵沓和阿须伦迦留罗真陀罗摩休勒。吾遣化人为说经法。虽复迥在异方刹土。普当自现令众人见。若受此典。不识句义失其次绪。使讽学者。蒙其威神令达义次。尔时世尊。即说偈曰

  皆相弃怯乱　　而当听此经
  是法难得遇　　信者亦难值
  如人欲求水　　穿掘于高原
  数数积功夫　　但睹燥干土
  彼观自思惟　　其水为甚远
  所掘深乃尔　　续见干燥土
  然后转渐睹　　湿土稍稍现
  尔乃心决疑　　今已得近水
  其不闻是经　　不数修行者
  其人离道远　　去佛慧若此
  斯经深巍巍　　决诸声闻事
  还闻此经王　　听之思惟义
  则得近大道　　智者成圣慧
  犹如见湿土　　尔乃知得水
  当入于佛室　　被服如来衣
  则处吾圣座　　明者乃说此
  慈心入吾室　　忍柔和被服
  解空师子座　　而说无所畏
  设刀凡石打　　为人见骂詈
  故为说此法　　吾悉忍斯音
  游在亿千土　　吾身当坚固
  无思议垓劫　　为众生分别
  佛灭度之后　　为众去怨结
  多遣诸化人　　而说此经典
  比丘比丘尼　　清信士女等
  当供养此辈　　及诸来会者
  石打杖挝骂　　怀结而恶口
  若有设此凶　　化人悉呵教
  假使独自行　　而讽诵玩习
  不被无恶声　　质直游闲居
  其人在彼行　　画夜一己身
  吾遣与共俱　　为伴说此典
  其人辩才　　无所挂碍　　多能明了
  随顺之法　　可悦人民　　亿百千垓
  犹如佛圣　　之所建立　　假使有人
  不依此法　　则为名曰　　诸菩萨逆
  学者游行　　及有所坐　　得见诸佛
  如江河沙

    正法华经七宝塔品第十一

尔时佛前。七宝之塔从地踊出。二万里适现绕佛。超在虚空自然而立。其塔殊好色若千变。五种之华而雨其上。纷纷如雪。庄严校饰塔寺讲堂。以无数宝因共合成。百千栏楯窗牖轩户。不可称计。悬众幡盖垂宝璎珞。诸明月珠罗列虚空。犹如众星。香炉宝瓶满中名香。栴檀芬馨一切普勋。三千大千佛之国土。金银琉璃水精珊瑚虎魄车磲马瑙。以为宝盖。其盖高显至第一天。忉利诸天及四天王。皆散意华供养七宝塔。其塔寺中自然发声。叹言。善哉善哉世尊安住。审如所言。道德玄妙超绝无侣。慧平等一犹如虚空。实无有异。时四部众见七宝塔。在于空虚高大微妙。巍巍无量光耀炜晔。靡所不照。颁宣善哉。欢喜踊跃叉手而立。瞻戴无厌。时有菩萨。名曰大辩。见诸天人心怀犹豫。乍悲乍喜欲得知此。何所瑞应。故前问佛。唯然世尊。今者何故。七宝塔寺现大圣前。高广无极莫不见者。而宝塔寺自然出声。赞曰善哉。何所感动而有此瑞。世尊则告大辩菩萨。此宝塔寺有如来身。完具一定而无缺减。东方去此不可计会。诸佛世界有佛。号名多宝如来。国曰宝净。本行道时而自发愿。吾会当以此正法华经当自修成。使诸菩萨皆得听闻。然后乃坐于佛树下。还成无上正真之道。其佛所念。果如所言。为诸十方讲说经法。开化一切皆令得道。于时其佛临欲灭度。普告诸天世间人民及诸比丘。吾灭度后。奉如来身全取其体。一等完具兴大塔寺。若见塔者悉得其所。功德难限。于时其佛。建立如是无极圣化。十方世界其有讲说此法华经。吾七宝塔。踊现诸佛所说经处。其舍利身在七宝塔。赞言善哉。佛告大辩。是七宝塔在于东方而处于下。去是无量江河沙佛土。在于虚空未曾出现。今见能仁如来正觉。本行学道为菩萨时。用众生故不吝身命。精进不懈行权方便。布施持戒忍辱精进一心智慧。求头与头求眼与眼。求鼻与鼻求耳与耳。手足支体妻子侍从。七宝车乘象马衣裘。国邑墟聚恣人所求。无所爱惜自致得佛。今故来现致敬能仁。欲令能仁佛坐我所有师子金床。讲正法华开化一切。使蒙其恩。能仁如来寻如所劝。则升讲堂师子之座。分别数演正法华经。而说颂曰

  设闻多宝佛　　知其名号者
  未曾畏终始　　不复遭苦患
  若闻药王师　　假记名号者
  众病自然愈　　寻则识宿命
  一切所供养　　奉法为最上
  分别空无慧　　自致得佛道
  宣畅法华经　　以示诸不及
  解本无三乘　　顺一无上真

佛告大辩。今者多宝如来至真。在斯塔寺遥闻说此正法华典。是以踊出。赞言善哉。大辩菩萨复白佛言。唯然世尊。今我等类诸来会者。欲得睹见多宝佛形。愿垂恩慈加以威神。使诸来者各得其所开发大道。佛告大辩菩萨。多宝如来本亦自誓。我之塔寺所至方面。听此经典设诸如来及四部众。欲睹吾身。随其十方之所欲愿。皆当得见。咸共供养于此化像。大辩。欲知我身。亦当感是十方诸佛。一切世界所化如来。讲说法者皆令诣此。尔时大辩菩萨复白佛言。唯然世尊。垂加大恩。普现一切十方国土诸佛圣德。佛默然可。即时演放眉间众毛微妙光明。普照十方各各五百江河沙等亿百千数诸佛国土。一切世尊各各普现。止其国土坐于树下奇妙庄严师子之座。与无央数百千菩萨。在宝交露布好座具。珍琦殊异悬缯幡盖。垂于四面诸佛座上。为诸众生讲说经法。音声柔和靡不解达。百千菩萨启受所闻。东西南北四偶上下。无数百千亿垓难量江河沙等诸佛世界。皆亦如是靡不见者。时十方佛各各自告诸菩萨等。诸族姓子。汝辈当往诣忍世界见能仁佛如来至真。并当瞻戴多宝世尊形像塔寺。彼时于此忍界所有功勋善德。殊雅威神自然而现。七宝诸树周匝而生。其地悉变为绀琉璃。以紫磨金而为长绳。连绵庄饰八交路道。其地平正。除诸郡国县邑村落大海江河川流泉源。皆不复现。但见自然诸天香炉烧众名香普雨天华。于此佛土。应时移徙诸天人民在他佛国。时诸众会现在七宝诸交露帐。诸交露帐庄严殊妙。不可称量遍此佛土。时彼十方一切诸佛。各有侍者。亦复皆来诣此忍界。各各至于众宝树下。此诸宝树高二万二千里。枝叶华实各各茂盛。斯宝树下有师子床。高二万里。皆以奇宝众珍为座。如来座上。如是比像。于此三千大千世界。但见诸佛靡不周遍。非是释迦文如来至真等正觉之所变现也。各从十方诸佛刹土而来到此。显示大道无极之德。尔时世尊释迦文尼。变诸如来所化形像。在于八方各二万亿所有国土。皆无地狱饿鬼畜生。移徙诸天及阿须伦。在于他方诸佛世界。令二万亿诸佛国土地绀琉璃。皆以七宝变成树木。其诸宝树高二万二千里。枝叶华实各各茂盛。诸师子座高二万里。此诸佛土而皆平正。无有河海众流泉源。亦无诸山目邻大目邻须弥山王铁围大铁围。一一佛土其地平等七宝合成各各庄严。诸宝交露快乐难量。遍布诸华烧众名香。诸宝树下各有如来坐师子床。如是比类复更别有二万世界能仁如来。各为诸方而特庄严。显现清净。皆为诸佛作其处所。此诸佛土。亦无地狱饿鬼畜生。诸龙鬼神及阿须伦。亦复移徙诸天人民在他佛土。此诸佛土地绀琉璃。以紫磨金而为宝绳。连绵诸树八重交道。又彼诸树高大妙好亦复如前师子之床庄严交饰。其地平正无有山河江海之事。香华众宝珍琦交露。垂明月珠亦复如前。行来进止道径由路等无差特。尔时释迦文佛所化如来。在于东方恒沙等刹班宣道教。皆复来至。十方世界各三千亿诸佛正觉。皆来诣此。如来悉坐于师子宝床。各取宝华授诸侍者。诸族姓子。汝等往诣耆阇崛山能仁佛所。致吾名字敬问无量。圣体康强力势如常所游安耶。以此众华。供散彼佛及诸菩萨众弟子上。宣我所言。多所开化。于是释迦文如来至真。见诸所化各各坐于师子之座。及诸侍者皆来集会。赍华供养。即从坐起住于虚空。四部之众悉亦各起叉手而立。佛以手指开七宝寺讲堂之户。亘然通彻晃若日出。譬如开于大国城门。而以管籥去其关轴内外无碍。释迦文佛以手两指。开七宝寺讲堂之户。现其威德不可称限亦复若兹。如来这开七宝寺户。多宝如来至真等正觉身即现矣。坐师子床肌色如故亦不枯燥。威光端正相好如画。口重宣言。善哉善哉。释迦文佛。说此经典。何其快乎。吾以欲闻此经法故。故自出现。时四部众见多宝如来至真等正觉。闻其灭度去世以来不可称计亿百千劫。听言善哉。甚大惊怪。初未曾有。即以天华。供养散于释迦文佛多宝如来。时多宝佛则以半座与释迦文。七宝寺中有声出曰。释迦文佛愿坐此床。释迦文佛辄如其言。时二如来共同一处。在于虚空。七宝交露坐师子床。时四部众各心念言。诸佛至真道德高远而不可逮。巍巍难量不可称限。惟愿如来。垂意见念加威神恩。令我等辈俱处虚空。佛知所念现神足力。使四部众自然超上处于虚空。时释迦文佛告四部众诸比丘等。于此忍界谁能堪任说是经典。今是其时亦是大节。如来现在若灭度后。当受此法持讽读诵。今如来身幸欲灭度。比丘当舍如来所供养供事之谊。奉顺恭敬于此经典。于时说颂曰

  无极大圣　　来至于斯　　导师因现
  琦妙塔寺　　比丘欲知　　听法故举
  何人省是　　不兴精进　　灭度以来
  无央数劫　　今日乃能　　欲听经典
  以故发来　　因缘宣教　　得度无极
  法之善利　　于往故世　　自兴此誓
  导师所愿　　正由此道　　灭度以来
  久远乃尔　　于今复见　　十方世界
  自在去此　　悠悠极迥　　亿百千数
  如江河沙　　因经典故　　而发诣此
  灭度圣将　　而自现矣　　各各由在
  于诸国土　　一切志乐　　声闻之行
  皆欲将护　　于正法故　　何缘当令
  经典久存　　因由依附　　诸佛之道
  在无央数　　诸佛世界　　取合众生
  来至于斯　　修治严净　　神足之力
  各各自说　　如是广谊　　何因得说
  于兹法眼　　诸佛住此　　不可称计
  在于树下　　而处道场　　其身真谛
  巍巍亿垓　　诸导师众　　坐师子床
  清净常正　　明显如日　　若如火光
  除于阴冥　　柔软美香　　薰于十方
  供养达至　　愍伤世者　　其有度脱
  一切众生　　恩德流布　　常通于此
  吾灭度之后　　其持此经典
  速逮得受决　　目见世导师
  佛灭度之后　　其多宝仁贤
  闻见师子座　　塔寺所在处
  我身次在是　　亿千来至此
  最胜子所由　　堪说斯经典
  若闻此法　　能受究竟　　则为奉事
  归命我身　　并及多宝　　如来之尊
  奉顺现在　　十方诸佛　　复及今来
  诸导师众　　庄校圣体　　殊妙难量
  悉为供养　　具足无限　　用尊修受
  此经典故　　以曾见吾　　闻所讲说
  亦复更睹　　寺中世尊　　并余无数
  诸导师众　　从百千亿　　国土至此
  慧命族姓子　　愍伤于众生
  此处难可值　　诸导师所乐
  诸无数经卷　　犹如江河沙
  佛虽说彼经　　不足为奇特
  其度须弥山　　则以手举持
  跳着亿千国　　不足以为难
  设有分别说　　奇句述百千
  闻亿千佛国　　不足以为难
  若住极上界　　为天人讲法
  宣畅无量经　　不足以为奇
  佛灭度之后　　末世能堪受
  班宣此经典　　尔乃为殊特
  若以一手卷　　捉尽于虚空
  至于无所至　　不足以为难
  我灭度之后　　若归如是像
  来世书此经　　尔乃为奇特
  设取十方地　　举着于爪上
  擎行恣所游　　升置于梵天
  此者不为远　　精进无奇异
  不如于来世　　须臾读此经
  假使劫烧时　　人践火中行
  乃担草不烧　　不足以为奇
  我灭度之后　　若持此经典
  为一人说者　　尔乃为殊特
  假使有受持　　八万诸法藏
  颁宣如所说　　以示亿千人
  比丘于彼世　　开化诸声闻
  住于神通者　　不足为奇异
  若持此经典　　信喜而爱乐
  数数咨称者　　尔乃为殊异
  若无数亿千　　兴立无著塔
  六通极大圣　　犹如恒边沙
  佛灭度之后　　设持此经典
  其人得功报　　过是难限量
  百千诸世界　　说法不可计
  今我亦宣畅　　佛慧所分别
  计是经典者　　一切经中尊
  其奉持此典　　则侍诸佛身
  族姓子讲说　　现在如来前
  后世持是经　　贤圣乃堪任
  须臾持此经　　则为奉敬佛
  一切诸导师　　是经难值遇
  一切十方佛　　为现所咨嗟
  勇猛有威神　　神通为以达
  名德远流布　　诸佛所爱乐
  用持此经故　　逮得寂定地
  导师灭度后　　则为天世人
  显示作眼目　　宣布此经故
  于当来之世　　须臾说此典
  其一切众生　　稽首礼明者

  (诸本此中加梵志品各分为二十八品云)

时能仁佛告诸众会。吾往无数难称限劫。求法华经未曾懈惓。时作国王。遵修大法六度无极。布施金银水精琉璃琥珀珊瑚珠玉车磲马瑙。头目肌肉手足支体。妻子男女象马车乘不惜躯命。时人寿长不可计会。吾用法故捐弃国位委正太子。行求大典。击鼓振铎宣令华裔。有能为吾演大典者。吾当为仆供给走使。时有梵志而报之曰。我有大典正法华经。若能为仆吾当慧报。佛告比丘。吾闻其言欢喜从命奉侍梵志。给所当得水浆饮食。扫洒应对趋走采果。储畜资粮未曾懈废。奉侍千岁使无侥渴。佛时颂曰

  击鼓振铎　　宣令远近　　欲求大典
  正法华经　　若见赐者　　吾当为仆
  趋走役使　　给所当得　　甘心乐闻
  不敢疲倦　　所当供养　　不惜身力
  趣欲闻受　　正法华经　　愿及十方
  不适为已　　其王精进　　未曾休懈
  衣食供命　　不求甘奇　　愍念众生
  诸未度者　　寻时即获　　正法华经

佛告诸比丘。时国王。则吾身也。梵志者。调达是。今吾具足六度无极大慈大悲。成四等心三十二相八十种好紫磨金色。十种力四无所畏四事不护。十八不共威神尊重度脱十方。皆由调达恩德之力。调达却后无央数劫。当得作佛。号曰天王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。世界名天衢。时天王佛广说经法。如江河沙众生得无著证。无数不可计人志在缘觉。如江河沙无量烝民。皆发无上正真道意至不退转。其佛当寿二十中劫。灭度之后。正法当住二十中劫。不散身骨合全舍利起七宝塔。高六十里。周八十里。普天下人悉往供养。香华伎乐歌颂功德。绕塔作礼。不可计人得无著证。无央数人志缘觉乘。不可思议无量天人。发无上正真道意。志不退转若族姓子族姓女。逮得闻是正法华经。心中[火*霍]然而无狐疑。杜塞三趣。不堕地狱饿鬼畜生。便当得生十方佛前咨受正法。若在天上世间豪贵。若在佛前自然化生七宝莲华。于时下方多宝世尊所从菩萨。号曰智积。自启其佛。当还本土。时能仁佛告智积曰。吾有菩萨。名溥首童真。且待斯须可与相见。宣叙阔别咨讲经典乃还本土。于是溥首坐七宝莲华。有千叶大如车轮。与诸菩萨俱坐莲华。从龙王宫踊出大海。溥首童真。皆退下华礼二佛已。与智积菩萨对相问讯。智积菩萨问溥首曰。所诣海渊化度几何。答曰。其数无量不可称限。非口所宣非心所计。如今不久自当有应。所说未竟。寻有莲华从海踊出在虚空中。无数菩萨皆坐其上。此皆溥首在海之所化。悉发大意。其志无上正真道者。普在空中讲大乘事。本发声闻意者。在于虚空说弟子行。解知大乘。溥首前谓智积曰。在海所化其现若兹。智积菩萨以颂问曰

  至仁慧无量　　化海众宝数
  唯为露圣旨　　分别说其意

溥首答曰。在于海中惟但敷演正法华经。智积又问。其法甚深尊妙难及。能有寻时得佛者乎。溥首答曰。龙王有女厥年八岁。聪明智慧与众超异。发大道意志愿弘广。性行和雅而不仓卒。便可成佛。智积又问。我睹能仁。是仁大师。本求佛道为菩萨时。积功累德精进不懈。历劫难计乃得佛道。不信此女便成正觉。言语未竟女忽然现。稽首作礼绕佛三匝。却住赞曰

  功祚殊妙达　　现相三十二
  诸天所敬侍　　神龙皆戴仰
  一切众生类　　莫不宗奉者
  今我欲成佛　　说法救群生

时舍利弗即谓女言。汝虽发意有无极慧。佛不可得。又如女身。累劫精进功积显著。尚不得佛。所以者何。以女人身未阶五位。一曰天帝。二曰梵天。三曰天魔。四曰转轮圣王。五曰大士。其女即以一如意珠价当是世时孚供上佛。佛辄受之。女谓舍利弗及智积曰。吾以此珠供上世尊。佛授疾不。答曰。俱疾。女曰。今我取无上正真道成最正觉。速疾于斯。于斯变成男子菩萨。寻即成佛。相三十二众好具足。国土名号众会皆见。怪未曾有。无央数人天龙鬼神。皆发无上正真道意。三千世界六反震动。三万道迹得不退转。皆当逮成无上正真道。舍利弗智积菩萨。默然无言

    正法华经劝说品第十二

尔时有菩萨。名曰药王。复有菩萨。名曰大辩。与二万菩萨俱。于世尊前面自启白。惟愿大圣。自安宣教。勿以为虑。如来至真灭度之后。我等当共分布此经讲说示人。假使有人儱戾自用。性不修调。薄德无福心怀自大。着供养利不备善本。离于解脱难可成就。我等世尊。兴忍辱力在于彼世。受此经典书持诵说。供养奉事怀佩在身。除于吾我班宣斯经。报安住恩。尔时会中五百比丘学不学者。前白佛言。唯然世尊。吾等堪任宣布此经。又复大圣。他方世界如来声闻诸学不学。佛悉授决。当成无上正真之道。一切叉手而礼世尊。八千比丘复白佛言。大圣自安。勿以为虑。灭度之后。当广解说传此经道。亦当宣布他方世界。所以者何。此忍世界。人多憍慢本德薄少。心常怀乱如火毒然。迷惑三界不能自安。尔时大敬逵比丘尼。与六千比丘尼俱。瞻戴尊颜不以为厌。启白佛言。道德至尊巍巍无量。超绝虚空无能及者。佛即告曰。汝辈瞿昙弥。勿怀悒悒而为愁戚悲颜观佛。恨言如来而不班宣。独不见蒙授无上至真正觉之决。一切众会等共和同。尔乃演布授众人决。当至无上正真之道。皆一等味味无有异。从是已往。汝当遭值三万八千亿诸佛之众供养奉事。当为菩萨常为法师。此学不学六千比丘尼。为诸众生。菩萨法师。次第具足菩萨行已。当成为佛。号曰一切众生咸敬如来至真等正觉。成佛以后开化人民。各各展转共相授决。当成为佛。度脱无数不可计人。于是罗云母比丘尼及持名闻。各心念言。今佛世尊而不愍念。独见遗弃。于是大圣告名闻比丘尼。今我班宣告语远近。当于十万亿佛修道。常为法师奉菩萨行。所遵具足当得作佛。号具足百千光幢幡如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。其世界名仁贤。尔时其佛。光明威神无数百千。寿不可限。时大敬逵及罗云母比丘尼等。得未曾有惊喜悦豫。即说是偈。而嗟叹佛

  世尊所开示　　为众之导师
  开化于世界　　并及于天人
  天人所奉事　　今者见慰抚
  以为人导师　　充满悦我意

比丘尼说此颂已白世尊曰。唯然大圣。我等信乐是佛法训。堪任诵读。又及余人他方世界。于时世尊。顾眄八十亿垓百千逮诸总持开士讲不退转法轮。时诸菩萨见佛照临。寻叉手启白。唯愿大圣。以斯经典付授我等。讲说宣布得此经卷。专惟佛德。诸族姓子欣仰世尊。俯察己身前世所行平等之愿。则于佛前而师子吼。如来灭度后。若此经法在于十方。我等书写受持讽诵。思惟其谊分别布路。显化余人亦令如斯。承佛圣旨。我之朋党处殊异土。大圣加恩。将接我等使得成立尔时诸菩萨大士同心等意。佛前而说颂曰

  唯然世尊　　默然安圣　　佛灭度后
  光阐影训　　然后末世　　恐有患难
  当普班宣　　分别说之
  若挝捶骂詈　　以石打掷者
  大圣往来世　　鄙当忍此愚
  语言难可了　　谀谄痴憍慢
  然后处山岩　　无获谓有得
  无便于智慧　　当何以报答
  独行顺心志　　怀恶为无忍
  在居贪恶声　　当为说经法
  所讲言决除　　犹若此六通
  凶暴秉毒心　　处寂行斯想
  入燕而独住　　不慕骂詈对
  是我等无忍　　猗着于利养
  则是外道人　　所说为已施
  于经自精进　　犹以供养利
  于众会中说　　宣吾等名誉
  若至国王宫　　大臣及寮属
  并梵志长者　　若余比丘所
  谤毁说我恶　　所行如邪道
  吾当悉忍此　　当奉侍大圣
  尔时离忧戚　　若使能忍辱
  以斯佛所说　　悉当呵教之
  劫乱比丘诤　　凶暴大恐惧
  悉骂詈我等　　诸比丘如鬼
  在世行恭敬　　皆令忍苦患
  以顺柔软性　　故当说此经
  吾等不贪身　　亦不惜寿命
  当堪奉持此　　志愿于佛道
  世尊具知之　　如凶恶比丘
  然后来末世　　当分别开解
  颜色常不悦　　数数犯不当
  游行不以时　　衣服多不政
  假使今世雄　　灭度后末世
  在众会勇猛　　分别说是经
  若行求入城　　傥有所慕索
  所在当施与　　佛知不令堕
  用爱乐世原　　兴修仁善心
  少欲行节限　　逮善寂灭度
  一切世光曜　　十方悉来会
  我当言至诚　　悉见心不虚

正法华经卷第六正法华经卷第七

        西晋月氏国三藏竺法护译

    安行品第十三

于是溥首大士白佛。唯大圣。此诸菩萨恭敬世尊。所当劝悦难及难及。何时应当为一切众说斯经典。佛语溥首曰。菩萨先处二法乃应讲经。一曰威仪。二曰礼节。何谓菩萨解知威仪。假使持心忍辱调柔。将护其意畏不自立。其志如地不见有人。不见有人而行法者。观自然相诸法本无。此诸法者众行之式。亦无想念。是谓威仪。何谓礼节。设令菩萨不与王者太子大臣吏民从事。不与外道异学交启。不尚世典赞叙音韶合偶习俗。不贪不学不与屠杀鱼猎弋射鸡鹜罗网贼害从事。不与歌乐游戏众会同处。不与声闻比丘比丘尼清信士清信女从事。亦不亲近行礼问讯。不共止顿。不与同志经行烧香散华然灯。除其往至讲经会时。唯与讲会而共从事。纵有所说亦无所著。是为礼节

又语溥首。菩萨大士不嫪家居宗室亲属。不殷勤思见内人女弱独说经法。亦不频数诣群从幼童男女。及余异人而说软语。所不当讲不为定意自赖说经。不与住立亦不同愿。亦不与一比丘尼独入房室。除念如来精进为行。纵为女人有说经缘。不于是中污染法味。不令受取而广谊理。不与沙弥比丘尼童子童女共在一处。常好燕坐绸缪好习辟屏闲居。是为礼节。又语溥首。菩萨大士。观一切法皆为空无。如所住立已堕颠倒。所立正谛常住如法。专秉身心不动不摇。不退不转蠲舍灭尽。不生不有无有自然。无为无数无所可有。逮无所有除诸言辞。不住无为无想不想。得伏诸想。假使菩萨。乙蜜观察斯一切法。款款修此所当行者。常住威仪礼节二事。世尊重解现此谊。而叹颂曰

  若菩萨好乐　　说此经典者
  于后当来世　　勇猛无怯劣
  顺威仪礼节　　善明清白行
  国王及太子　　大臣寮属吏
  外道若异学　　屠猎恶害品
  抑制交启习　　不与通往返
  比丘放罗汉　　除立于法律
  不与自大俱　　复远犯禁者
  比丘比丘尼　　调譺嘲话谈
  舍离清信女　　不与无益言
  现在欲获法　　常当止息非
  好住灭度地　　是谓为威仪
  假使不肯往　　咨问于道法
  为斯持法说　　不怯无所著
  众生有癞病　　若亲属宗室
  母人诸细色　　悉当舍离去
  不与是等俱　　而积殖德本
  当弃贩卖业　　诸慢不恭敬
  弃捐诸住立　　不为己身害
  若干种虫蚤　　不习食啖肉
  蠲舍诸非法　　喜嗔恚恨者
  所行乃如是　　亦不与谈语
  不与强颜俱　　及余自用性
  作行如是者　　皆当屏除之
  明者设有缘　　为女人说经
  而不独游行　　不住于调戏
  设入出聚落　　数数行求食
  将一比丘伴　　常志念于佛
  佛故先示现　　此威仪礼节
  其奉持斯典　　则当勤行之
  上中下劣人　　若不行法者
  无无常供养　　一切皆至诚
  丈夫无想念　　坚固行勇猛
  不知一切法　　亦不见灭尽
  一切诸菩萨　　是谓为威仪
  如常行礼节　　且当听察之
  斯当讲说　　无为之法　　一切不兴
  亦无所生　　建志常立　　观采空谊
  此为明者　　所行礼节　　有所念者
  悉颠倒想　　以无为有　　用虚作实
  虽有所起　　诸法无生　　因想蹉踖
  而生诸有　　心常专一　　善修三昧
  建立于行　　若须弥顶　　所住如此
  普观诸法　　是一切法　　犹如虚空
  譬若虚无　　等无坚固　　不念取胜
  无所弃捐　　诸法所处　　无有常名
  是为明者　　所行礼节　　我灭度后
  若有比丘　　敢能守护　　如是法则
  无所怯软　　心不起想　　为无数人
  说此经典　　其明哲者　　所念以时
  若入屋室　　所行若兹　　观察诸法
  一切普净　　宴然说谊　　而不动摇
  国主帝王　　及与太子　　欲听闻法
  皆供养之　　并余长者　　及诸梵志
  立诸眷属　　皆无所欲

又语溥首。如来灭度之后欲说此经。住于安隐已立安隐。不怀谀谄无眩惑心。乃说经法藏厌身怀。或载竹帛为他人说。亦不多辞亦无所生。亦不轻慢诸余比丘。为法师者亦不歌叹亦不毁呰。异心比丘为声闻者。未曾举名说其瑕秽。亦不诽谤。亦不仇怨意相待之。未曾毁呰居家行者。无所志愿。不建彼行亦无所想。行来安住而立谊要。往来周旋。若诣法会。自护己身行无有失。而说经法。若有请问。心无所猗。离声闻乘。有所发遣觉了佛慧。佛时颂曰

  智者常安　　住于佛道　　先隐定坐
  尔乃说经　　若当敷座　　务令柔软
  若干种具　　所置绮灿　　体常儭着
  净洁被服　　于七七日　　而习经行
  犹如黑云　　在于虚空　　合集积累
  弘雅功德　　所处之座　　具足箧藏
  床足坚固　　平坦显赫　　无数坐具
  [疊*毛]蓐綩綖　　俨然正首　　尊其视瞻
  安详升据　　高广法座　　而普等心
  为一切人　　国主帝王　　太子大臣
  及诸比丘　　比丘尼众　　清信高士
  及清信女　　应所乐闻　　为讲无量
  明智无限　　次第剖判　　为演种种
  微妙之谊　　追逐侍后　　请求问諠
  斯睿哲者　　复为解说　　而入神足
  柔顺之忍　　其有听闻　　悉得佛道
  斯智慧士　　皆为一切　　进却弃除
  懈怠疲厌　　常以慈心　　为众说法
  未曾起于　　劳废之想　　昼夜歌诵
  咏尊法训　　分别演说　　亿千垓喻
  普能劝悦　　诸会者心　　无敢生念
  欲危害者　　若得供养　　饮食之具
  床卧所安　　衣服被枕　　病瘦医药
  而无侥冀　　不从众人　　有所请求
  除其瞻劳　　住庙精舍　　欲令众庶
  悉解佛道　　若一切人　　来听经法
  我乃嘉豫　　如获大安　　佛灭度后
  若有比丘　　宣扬经法　　无所悕望
  无所妨废　　不遭苦患　　常察精进
  离于疾病　　无能为彼　　造怨怖事
  不被杖痛　　无诽谤想　　身无疲厌
  不有所患　　其人住忍　　得力如是
  其明智者　　所处安隐　　有所存立
  如佛言诏　　若已咨嗟　　亿百功德
  一切称誉　　不能究竟

又语溥首。如来灭度后若有菩萨。于是经卷怀疑不了。若说教化闻不坚固。性不调和。见余菩萨求大乘者。为造虚妄而诽谤之。见声闻缘觉比丘比丘尼清信士清信女若值菩萨。心为踌躇不即往见。其族姓子则远无上正真之道。而不得近佛天中天所在行处。假使究竟不蒙福力不成最正觉。菩萨行三乘犹如师子在于林树。若有犹豫自然远离。不乐所乐亦不不乐。若于众生修行慈力。至于如来兴大父想。见诸菩萨念如世尊。及诸处家未离尘秽。宽弘等敬礼节恭肃。净诸法谊无疑无结。严一切法谨慎安谛。钦顺平等不着经法。极有所乐亦无所至。所在昼夜敬护斯典。溥首。是为三法之行。菩萨观时然后乃说。造安隐行。不被烦恼亦不娆害。说是经法者。与同学者等心道友。若讲若闻信乐斯典。诵持书写载之竹帛。供养奉事德不可量。说以安住。则乃颂曰

  若有嫉妒　　怀难亿数　　其法师慈
  当远憎恶　　有明智者　　不造贪着
  若欲读斯　　正典摸者　　未曾诽谤
  说人之恶　　亦不堕非　　诸疑邪见
  心常[火*霍]然　　无有沉吟　　以愍伤故
  得了此定　　安住之子　　亦能忍辱
  其人常屏　　贡高自大　　数数讲诵
  佛之典诰　　未曾以此　　持作懈倦
  其有菩萨　　在十方者　　愍伤众生
  于世兴行　　顺造恭敬　　学圣慧者
  皆当念之　　是我世尊　　思念诸佛
  两足之上　　想诸菩萨　　如想父母
  设有求道　　无有情欲　　弃捐吾我
  自大之想　　假使听省　　如是像法
  其明士等　　当自慎护　　所行安隐
  常得调定　　将御佛道　　救亿众生

又语溥首。如来灭度后。若菩萨大士。奉行斯典常以时节。其是比丘当行慈愍。向诸白衣出家寂志一切群生。行菩萨道者。常念过去世行大乘者善权方便演真谛谊。若听闻者。不知不了不悦不信不省不综。反自叹说我当逮得无上正真道成最正觉。威神足力而欲得飞。溥首当知。吾见斯等。佛灭度后。菩萨有四事说法而不诤怒。何等为四。为诸比丘比丘尼清信士清信女所见奉敬。帝王太子大臣群寮郡国人民所见供养。长者梵志皆共承顺。虚空神明无数天子听所说经。天龙鬼神侍卫其后皆营护之。是为四。若入县邑还归室宇。昼夜悉来咨问经法。若为解说分别所归莫不欢喜。所以者何。溥首欲知。皆佛所建立加此经恩。去来今佛尽从斯生。亦护是典。若于忍界闻正法华品。服名听声者甚难值遇。溥首。譬有大力转轮圣王。威德弘茂顺化所领。诸余敌国未率伏者。不敢窥[門@俞]。若转轮王兴举军兵。当有所讨。不宾之臣欲距大邦。雄猛将士奋武克捷。莫不稽颡。王用欢悦断功定赏。封城食邑赐之土田。七宝珍奇象马车乘男女奴婢。元首效绩勋殊特者。王解髻中明珠赐之。所以者何。臣当国强华裔乃康。如来正觉亦复如是。为大法王无极道谛。自伏其心。以法教化。以德消害。以慧战斗。降诸法王无数之众。无量经典百千要谊。咸施群生无所秘蔽。诏平等城其见身魔。能与魔战以贤圣法。攻淫怒痴降魔官属。尽三界患至于灭度。所作克捷则大勇猛。于后无坏亦无有实。因由诸虚致斯世间。如处色像一切因缘。普诸世界古今以来。无有信此正法华经未曾畅说。所以说者。由诸通慧大慈所致。如大圣帝髻中明珠。以为世尊第一法要。缘是趣行。如来使闻深妙之典。往古来今诸行班宣。斯经为最消除一切缘起之患。犹如圣帝珍重爱护髻中明珠。久乃解出以赐元功。如来如是。夙夜宝护最妙无瑕。从是来久立诸法顶。今日加哀乃演散耳。世尊欲重显现要谊。而叹颂曰

  今如来现　　慈心之力　　常愍众生
  群萌之界　　安住咨嗟　　最尊经卷
  故分别说　　如斯典诰　　最后世时
  志菩萨法　　若使出学　　及居家者
  若闻此经　　慈心战栗　　一切普现
  不得诽谤　　吾本初始　　得佛道时
  如今如来　　现在之时　　设能逮闻
  于是尊经　　则便建立　　亿权方便
  犹如势强　　转轮圣帝　　战斗降伏
  外异国王　　得赐象马　　车乘箧藏
  又加封邑　　城郭郡土　　或有得赐
  手足宝钏　　微妙之色　　紫磨金珍
  真珠夜光　　车磲碧玉　　种种殊别
  奇财妙异　　若干诸物　　各用赐之
  使一切众　　踊跃惊喜　　睹所立功
  怪未曾有　　最后解髻　　明月宝施
  佛亦如是　　今为法王　　忍辱之力
  无极慧音　　常行慈愍　　兴发哀护
  以法等化　　一切世间　　睹诸众庶
  忧恼之患　　讲说经法　　亿千之数
  晓知众生　　所应方便　　今日众生
  以为尽原　　于时法王　　无极大圣
  分别经卷　　亿百千垓　　以知黎庶
  志力猛慧　　便说此经　　如髻明珠
  最后世时　　正典所处　　一切诸法
  皆无及者　　钦仰是经　　未曾轻讲
  识练幽微　　慧明者闻　　吾以演现
  如是像法　　佛灭度后　　当恃怙之
  其有志求　　斯尊道者　　普当受决
  如佛所言　　彼人未曾　　有疵瑕欲
  无有疾病　　众患之难　　则于末后
  将来之世　　便即逮成　　无上真慧
  殊胜差特　　普当具足　　诸四部众
  亦复顺遇　　若有闻者　　除身诸漏
  怪其无为　　悉叉手归　　己身景曜
  所照光光　　其奉行是　　所获若此
  得成正觉　　而转法轮　　则睹弘摸
  及见最胜　　梦中闻见　　百福德相
  紫磨金色　　佛所说经　　设得闻已
  为众会说　　及诸亲族　　皆悉具足
  又复所护　　一切除弃　　若使卧寤
  所见如是　　悉舍远离　　而行出家
  皆得往至　　于佛道场　　便即处于
  师子之座　　是为求道　　所获利谊
  所谓七宝　　悉归于斯　　修此则奉
  最胜如来　　已得佛道　　存立惠施
  即转法轮　　无有诸漏　　为诸四辈
  而说经法　　不可思议　　亿千劫数
  分别讲说　　无漏之法　　教化无数
  亿垓众生　　梦中所见　　如斯色像
  灭度因缘　　悉无生死　　溥首当知
  常志道者　　多所教化　　不可限量
  最后末世　　求斯尊法　　分别广说
  安住所演

    正法华经菩萨从地踊出品第十四

于是他方世界八江河沙等菩萨大士。各异形服来诣佛所。稽首于地长跪叉手。白世尊曰。鄙之徒类来造忍界。欲闻斯典受持讽写。精进供养奉行如法。惟愿大圣垂心于我。如来灭度后。以正法华经加哀见付。世尊告曰。止族姓子。仁等无乃建发是计。今此忍界自有八江河沙等大士。一一大士各有眷属。如六十亿江河沙等菩萨大士。后末世时。皆当受持分布班宣。时此佛界周普无数亿百千垓诸菩萨众自然云集。颜貌殊妙紫磨金色三十二相严庄其身。在于地下摄护土界。人民道行倚斯忍界。闻佛显扬法华音声从地踊出。一一菩萨。与六十亿江河沙等诸菩萨俱。营从相随一心一行。无有差别。或半江河沙百千菩萨来者。或四十分江河沙。或五十分江河沙。或百分江河沙。或五百分江河沙。或千分江河沙。或百千分。或亿百千分江河沙等菩萨。各各朋党相随来。或复无央数亿百千菩萨眷属而来至者。或有二百人同行修菩萨道。或有百千各有眷属。或有千眷属。或五百眷属。或四百眷属。或三百眷属。或二百眷属。或百眷属。或五十眷属。或四十眷属。或三十眷属。或二十眷属。或十眷属。或五眷属。或四眷属。或三眷属。或二眷属。或一眷属。或独而至。不可称限。其数难喻从地踊出。或从上下。或四方来。至忍世界悉住空中。见于灭度多宝世尊能仁大圣。各处七宝树下坐师子床。寻稽首礼二如来至真等正觉。右绕三匝却住一面。或有菩萨。以若干品奇妙之谊。咨嗟二尊赞咏诸佛。从始已来假使具足。五十中劫不能究畅。能仁世尊为勤苦行。与佛别来亦复如是。四部众会。等无差特。亦复默然。尔时世尊。即如色像现其神足。令四部众悉得普见。又使念知此忍世界。诸菩萨众于虚空中。各各摄护百千佛土。诸菩萨众。皆满具足百千佛土。又此大众。有四菩萨以为元首。其名曰种种行菩萨。无量行菩萨。清净行菩萨。建立行菩萨。是为四。于无限无量尘数云集。大会菩萨之上最也。于是四菩萨大士。各与大众不可思议。部部住立。于世尊前叉手白曰。大圣体尊起居康强。蠲除众疾所行安耶。群生各各善顺律行。处于清凉无众患乎。此类将无兴坠崄谷。时四菩萨大士。以偈赞曰

  世雄阐光曜　　所行康强耶
  救脱现在者　　众行无患难
  众生善因室　　决受谛清净
  得无起疲厌　　宁受世吼命

尔时世尊告众大会诸菩萨曰。诸族姓子。佛所行安无疾无患。众庶各各悉受律行。善学道教不敢兴厌。欲至严净。所以者何。斯之品类。乃于往古诸平等觉。各各作行。是诸声闻。信乐吾教入于佛慧。又各各异三乘学者。住声闻乘。我悉立志入佛大慧。时诸菩萨而叹颂曰

  善哉快世尊　　我等悉劝助
  乃令众生一　　善化微妙律
  欲得闻大圣　　教命询深要
  听之欢喜信　　乃入法供养

于是世尊。赞大会菩萨曰。善哉善哉。诸族姓子。诚如所云。如来所诏。各随权宜不违本旨。时弥勒大士。及余八亿恒沙菩萨俱举声。而叹颂曰

  从古以来　　未曾见闻　　乃有尔所
  菩萨之众　　从地踊出　　住世尊前
  供奉归命　　是等俦类　　从何来乎

弥勒即知八亿恒沙菩萨心之所念。寻时叉手以颂问曰

  无央数百千　　于算巨亿载
  不可称限量　　未曾见菩萨
  来诣两足尊　　曷因是何等
  大通所从来　　其像巨亿长
  一切志强勇　　猛雄为大圣
  端正可钦敬　　今为所从来
  世尊一一见　　慧雅诸菩萨
  眷属无央数　　犹如江河沙
  其数超江河　　具足度佛法
  诸菩萨眷属　　皆建正觉道
  如是群英伦　　集会礼大圣
  具足满六十　　百千江河沙
  其数过于彼　　眷属无思想
  五百江河沙　　或四或三百
  或二百江河　　诸营从如是
  其限复殊此　　或五或复十
  一一诸眷属　　世尊大圣子
  斯众缘何来　　至于导师所
  或四三或二　　或一江河沙
  恒沙数各来　　伴侣悉善学
  甚多不可限　　除住空中者
  于亿百千劫　　不可卒合聚
  半江或三分　　或十或二十
  具足众立行　　明哲众菩萨
  俱住于空中　　其限不可量
  现别无彼此　　亿劫行清净
  又无量异部　　眷属不可议
  亿亿复超亿　　或有半亿者
  或十或二十　　五四三或二
  诸雄从眷属　　无能筹量者
  身各自修行　　寂寞乐等遵
  恬怕如虚空　　别来者无限
  犹如江河劫　　莫能有计者
  在精舍寂室　　各从其方来
  一切天神圣　　皆用尊故至
  诸菩萨雄猛　　何从忽见此
  谁为彼说经　　谁立于佛道
  为显何佛教　　建立何佛行
  细微各可敬　　普从四方来
  因明目神足　　大慧忽然现
  于羸旷世界　　能仁令充备
  仁贤诸菩萨　　伦党自然至
  从生出已来　　未见如斯变
  愿说其国土　　大圣哀尽名
  十方所从来　　各怀十八法
  吾未曾得见　　如斯等菩萨
  我为最胜子　　未曾见闻此
  今斯若干众　　能仁愿说行
  菩萨无数千　　百垓难可限
  诸亿千无量　　本为何所处
  诸菩萨勇猛　　志性不可量
  如是之等类　　大雄愿说之

尔时他方世界无央数亿百千垓诸如来至真等正觉。普从十方诣能仁如来劝说法者。各各坐于七宝树下师子之床。是诸如来侍者。各各见诸菩萨无量大会部部变化。从地踊出。各各住立自问其佛。此诸菩萨大士之等。从何所来。不可计量无有边际。时彼诸佛。各各告其侍者曰。诸族姓子。且待须臾有菩萨名弥勒。为能仁如来所授决。当逮无上正真道成最正觉。自问能仁。如尔所怪。佛为一一分别谊归。悉静一心而俱听之。尔时佛告弥勒大士。善哉阿逸。仁者所问极大微妙优奥难量。且听且听。今吾说之。一切菩萨及诸会者。普当坚固。强猛力势于无上意。当知如来。慧见无底。诸大圣立境界无量。禅定智慧所乐自恣。莫能宣畅而剖判说。方便兴化不可限量。时佛颂曰

  诸族姓子　　皆听佛道　　今吾所说
  慧柔和悦　　若明达者　　以为美香
  如来之慧　　不可思议　　皆当强意
  普存坚固　　各建立志　　一心平等
  大圣难值　　愍哀世间　　今当听受
  未曾有法　　佛当建立　　仁者诸党
  一切无得　　生狐疑心　　导师所诏
  令无有异　　其慧平等　　安隐无特
  安住所疗　　法甚深奥　　非心所思
  不可限量　　今当讲说　　无极因缘
  普共听之　　义何所趣

世尊叹已告弥勒曰。班宣一切。阿逸。欲知此诸菩萨大士众会无量不可思议各各从地而踊出者。昔所不见皆集忍界。吾始逮无上正真道成最正觉时。劝悦斯等立不退转。使成大道教授化立。族姓开士大士之众。处于下方而于其中。有所救护赞经讽诵。思惟禅定专察其归。欣然悦豫乐无为行。诸族姓子。志于恬惔不存远近。天上人间常应专修。转于法轮无为无会。好深神通法乐为乐。志愿精进求于佛慧。于时世尊而叹颂曰

  今此无数　　诸菩萨众　　不可思议
  无能限量　　造行亿数　　不可限劫
  殖积神足　　博问智慧　　吾悉劝诱
  于大圣道　　今佛一切　　皆授其决
  斯诸菩萨　　悉佛众子　　皆为住止
  于吾国土　　悉舍弃离　　诸所习地
  一切皆处　　闲居得度　　斯诸佛子
  所行无为　　精修学习　　奉遵上道
  斯聪哲者　　在于下方　　今日故来
  摄护国土　　昼夜精进　　无有逸慢
  积累德行　　分别佛道　　常行勤修
  立于慧力　　一切意坚　　而无限量
  志常勇猛　　思惟法典　　普悉是吾
  达清净子　　吾初逮成　　为佛道时
  在于城中　　若树无著　　则便讲演
  无上法轮　　劝立其志　　于尊佛道
  今佛所说　　至诚无漏　　闻佛叹咏
  皆当信之　　开化发起　　此诸群英
  从久曩来　　立尊正道

尔时弥勒大士。闻佛说彼菩萨之众。亿百千垓数难计会。心用愕如。怪未曾有。白世尊曰。云何大圣。处迦维罗卫释氏王宫为太子时。委国重位众女之娱。出适道场坐于树下。得无上正真道成最正觉。从来近近甫四十年。而所教化所度无量。乃复爰发诸佛境界。多所劝益所建权慧而不可议。今是菩萨大会之众。悉皆如来之所开导。部党部党众多无量。久修梵行殖众德本。供养无数百千诸佛。假使欲计成就已来劫数无限。弥勒又启。欲引微喻譬如士夫年二十五。首发美黑姿体鲜泽。被服璨丽端严殊妙。常怀恐惧见百岁子。其父谓言族姓子来。尔则我子。其百岁子谓二十五岁人是我之父。父则察知口自说言。是我之子。如是世尊。世俗之人所不信者。而令得信。佛亦如是。成佛未久。今有若干亿百千数。久修梵行长夜遵倚在于道慧。劝进现在无量之众。晓了坐定起立方便。成大神通聪明智慧。住于佛地习佛慧谊。于世希有建大圣力。世尊往古。亦复教化于斯品类。诱导建立于菩萨地。当成无上正真之道致诸正觉。悉行方便所作已办。今我以受信誓诚谛。探畅既往断析此谊。其唯如来。新学菩萨心怀犹豫。所不及知。如来灭后闻是经典。终不信也。以有犹豫不遵此法。亦不劝乐。当获罪衅。善哉世尊。现说此谊。其有狐疑于斯典者。当来末世诸学大乘。设使闻者令不沉吟。于是弥勒大士。于世尊前叹斯颂曰

  譬如有人　　现生老子　　能仁至圣
  弃国捐王　　生于城中　　而得佛道
  导师近尔　　布属鲜少　　今此诸乐
  不退转子　　无数亿劫　　行救大众
  神足之力　　住不可动　　学智慧强
  靡所不入　　今来至斯　　在所开通
  如水莲华　　悉无所著　　威神尊重
  志超于世　　住立恭肃　　一切叉手
  诸菩萨众　　如是色像　　为如之何
  谁当信此　　惟愿大圣　　加哀示现
  剖判分别　　如审谛谊　　譬如有人
  而为士夫　　年既幼少　　发美且黑
  其人年岁　　二十有五　　而能产生
  百岁之男　　养育澡洗　　随时衣食
  是我等父　　而为最胜　　一切世间
  无有信者　　幼稚年少　　而生斯子
  如是世尊　　我等无失　　无数菩萨
  如来集会　　心强智慧　　又无所畏
  无数亿劫　　所学审谛　　志怀明哲
  其目通达　　威神巍巍　　显现端正
  而勇意猛　　晓了法律　　为雄导师
  所见咨嗟　　而窜山岩　　静行无为
  如虚空界　　悉无所著　　禅定精进
  为安住子　　而心志求　　于此佛道
  而何所人　　当信此言　　若于导师
  灭度之后　　吾等于此　　而无狐疑
  佛前目睹　　则闻菩萨　　于是之处
  初学罔然　　将无菩萨　　归于恶道
  云何劝发　　化斯等伦　　惟愿世尊
  覶缕解决

    正法华经如来现寿品第十五

尔时世尊。普告菩萨大众。三举声诏。诸族姓子。悉当信佛诚谛至教。勿得犹豫。时会菩萨弥勒大士。具余之众咸皆叉手白世尊曰。惟愿大圣。分别说之。我等悉信如来所诏。诸菩萨白佛而亦至三。于是世尊。见诸菩萨三称劝助欲令佛说。佛告诸菩萨曰。谛听谛听。善思念之。佥曰受教。佛言。族姓子。如来建立如是色像无极之力。诸天龙神阿须伦世间人。各自知之各自念言。能仁世尊从释氏土。弃国捐王行至江边。就于道场坐于树下。逮得无上正真道成最正觉。又吾在昔从无数亿百千那术垓劫以来。已成至真等正觉矣。譬有无数五百千亿佛世界。所有土地满其中尘。若有士夫举取一尘。过于东方不可计会亿百千垓诸佛国土。乃着一尘。如是次取越尔所国土。复着一尘。如斯比类。取无数五百千亿佛界所有土地一切之尘。一一取布着诸佛国。悉令尘尽。于诸族姓子意中云何。有能计数此诸佛国。思惟筹算。宁知者乎。弥勒大会诸菩萨众悉白佛言。无能计者。天中天。所以者何。诸佛世界甚多无量不可思议。非心所及。假使一切声闻缘觉处贤圣慧。不能思惟知其数者。唯有世尊大圣之慧。乃能知耳。余无能及。正使我等不退转地诸菩萨。尚不能知。此诸佛世界不可限量。难得边际。于时世尊告大众曰。今吾宣布诏诸族姓子。如彼士夫取无数五百千亿佛界中尘。举一尘过于东方不可计会亿百千垓诸佛国土。乃着一尘。如是次。取越尔所国土复着一尘。如斯比类。取无央数五百千亿佛界所有土地一切之尘。一一取布着诸佛国。悉令尘尽。吾逮无上正真道成最正觉已来其劫之限。过于尔所尘数之劫。诸族姓子等。见吾于此忍界讲法。复在他方亿百千垓诸佛世界而示现。皆悉称吾为如来至真等正觉锭光如来。以诸伴党若干之数而现灭度。诸族姓子。吾以善权方便。演说经典。现无央数种种瑞应。又如来悉知一切群萌。往来进止诸原根本。悉观其心而随示现。各为名号亦不灭度而说泥洹。顺诸众生瑕秽善恶。则为解演若干种法。诸族姓子。见无数品心性各异。所行不同德本浅薄。多所坏破而不信乐。故为说言。告诸比丘。这度终始方今出家。成平等觉从来未久。甫乃逮得无上正真道成最正觉。又如来成佛已来甚久。故佛说言。得佛未久。所以者何。欲化众生故。诸可说经皆已度脱。所可讲诏自现其身。为一切故建示所行。皆为天人喜造罪福。以故如来诸所讲演。皆实至诚非是虚妄。如来皆见一切三界。随其化现亦无所行。亦复不生亦不周旋。亦不灭度不实不有。亦不本无不知不尔。亦无虚实亦不三界如来所行不见三处。如来普观一切诸法。在于某处不失诸法。一切所说至诚不虚。众生苦恼不可称限。行若干种志性各异。思想诸念各各差别。欲令众生殖众德本。故为分别说若干法。又如来所当作者皆悉作之。现这得佛。成平等觉已来大久。寿命无量常住不灭度。又如来不必初始所说。前过去世时行菩萨法。以为成就寿命限也。又如来得佛已来。复倍前喻。亿百千垓。然后乃于泥洹而般泥曰所以者何。为众生故而教化之。故而示现行来久远。为无德类离于福祚。为贫窭行着于爱欲。缠诸见网而自覆盖。驱驰不定。如来故为现。发忨忨疾获之想。不起懈怠难得之虑。如来善权告诸比丘。勤苦作行乃得佛道诚谛不虚。以诸众生从无央数亿百千垓。乃见如来。以其匆匆所作不当故。恇汲恇汲无宁息。故言法难值如来难遇闻见。是已怪之难及兴难遭想。悲喜孜孜知佛希有。便多发意。乐在闲居而行精进。这不见佛而怀渴仰。见如来已。欢喜稽首造众德本。其不灭度者教令灭度。开化黎庶。缘是如来出现。说经而宣斯言。诚谛不虚

譬如士夫而为医术。聪明智慧工巧难及。晓练方药知病轻重药所应疗。多有儿子若十至百。其医远行诸子皆在。不解谊理不别医药不识毒草。被病困笃皆服毒药。毒药发作闷愊反覆。父从远来。子在城中脑发邪想。父见诸子被病。起想这见父来。悉皆喜悦白言。父来。安隐甚善。我等自为食任信他言而服毒药。惟愿大人救济我命。时父见子遭苦恼患婉转在地。寻敕从人持大药来。药色甚好味美且香。和合众药与诸儿子而告之曰。速服上药甘香芬馥。假使诸子时服此药。其毒消灭病得瘳除。身体安隐气力康强。诸子不随颠倒[怡-台+龍]悷想者。见药嗅香。尝知其味。寻便服之。病即得愈毒药消灭。子性悷者。不肯服之。毒药除者。皆白父母。与我等药。病悉瘳愈。而蒙安隐。其邪想者。不肯服也。得见药色不喜香味。父医念言。今我此子愚冥不解。志性颠倒不肯服药。病不除愈或恐死亡。宁可以权饮诸子药。则设方便欲令速服。便告诸子。今我年老羸秽无力。如是当死。汝辈孚起。若吾命尽。可以此药多所疗治。服药节度汝等当学。假使厌病欲得安隐。宜服斯药。教诸子已舍诣他国。犹如终没。诸子闻父潜逝发哀。啼哭悲哀不能自胜。我等之父智慧聪明。骜不服药今者薨殪。兄弟狐露思慕殷勤。乃自克责存不顺教。甫便遵崇父之余业。谛观众药形色香味。自当攻疗不可轻戏。寻便服药深自消息。病即除愈。时父见子服药病愈。便复还现。佛语诸族姓子。如是医者善权方便。令子病愈。宁可诽谤。彼医所处为不审乎。诸菩萨白佛言。不也世尊。不也安住。佛言吾从无数不可计限亿百千劫。发无上正真道意。勤苦无量每行权便。示现教化发起群生。其父医者。谓如来也。诸儿子者。谓五道生死人也。父他行而不在者。谓如来未出于世。诸子入城服毒药婉转者。谓在三界三毒所缚婉转五道不能自济。父闻来还。谓佛如来行大悲哀。见三界人。或流五趣不能自出。故现世间。广说经法开化黎庶服药病愈。谓发无上正真道意。立不退转无所从生。或得声闻缘觉乘。不至究竟。视药形色香味不肯服者。谓六十二见诸堕邪者。见父年老留药教子舍之去者。谓诸黎庶疑受道教。故现灭度。留诸经法以教后世。四辈弟子讽诵学问。思佛功德发大道意。或得罗汉或得缘觉。佛见如是复还出世。一切众生皆是吾子。诸族姓子。如来行权非徒虚妄。于是世尊。欲重解谊显扬其事。而叹颂曰

  不可思议　　亿百千劫　　欲得限量
  莫能知数　　得佛已来　　至尊大道
  常讲说经　　未曾休懈　　劝助发起
  无数菩萨　　皆建立之　　于佛道慧
  无数亿劫　　开道众生　　亿千垓数
  不可思议　　而为示现　　立于灭度
  以教化谊　　导利众生　　用权方便
  而现灭度　　故为众人　　演斯法典
  吾已自立　　一切黎庶　　分别群萌
  于彼之谊　　其心颠倒　　而不觉了
  欲立是等　　佛宣畅说　　设见于佛
  灭度之后　　以若干物　　而用供养
  又睹吾没　　愁悒忧戚　　若复见佛
  欢喜踊跃　　假使质直　　说至诚言
  众生之类　　朽弃身体　　然后如来
  合集众音　　能自示现　　显大佛道
  而于后世　　分别此语　　吾在于斯
  不为灭度　　比丘欲知　　佛权方便
  数数堪忍　　现寿于世　　及与异人
  眷属围绕　　因而宣扬　　于尊佛道
  诸贤得闻　　佛出世间　　又复导师
  余国灭度　　观察众生　　愁忧懊恼
  仓卒不见　　其身相好　　望想饥虚
  欲得见佛　　然后乃为　　分别经典
  不可思议　　亿百千劫　　吾常建立
  如此像谊　　佛来至于　　灵鹫之山
  自然床座　　无量垓数　　设使众生
  见是世界　　水火灾变　　劫烧天地
  当斯之时　　吾此佛土　　具足微妙
  柔软安雅　　歌舞戏笑　　无量安隐
  讲堂精舍　　楼阁室宅　　校饰庄严
  皆以七宝　　药草树木　　华实茂好
  自然雨华　　心华众色　　以散于佛
  及弟子上　　诸人皆坐　　馆室雷震
  或复好乐　　发道意者　　吾之国土
  建立常然　　余人有见　　劫如烧尽
  睹其世界　　火甚可异　　本以权便
  示现斯变　　如来咨嗟　　无央数亿
  佛之法尊　　其为若兹　　众生品类
  不肯听闻　　然而喜造　　殃衅之罪
  假使人民　　柔软中和　　其时佛兴
  出于人间　　已见世尊　　经法所诏
  则为显扬　　清净谊理　　佛来为人
  分别诫诲　　说斯所造　　往返之事
  假使如来　　久久而现　　然后乃为
  讲是经典　　吾智慧力　　圣达光明
  如是所见　　不为薄少　　前世所行
  无量劫数　　慈心之品　　平坦无求
  智慧明者　　无得狐疑　　弃捐犹豫
  勿怀结滞　　所当列露　　未曾班宣
  佛今散告　　无复余谊　　如医所建
  善权方便　　开阐分别　　示子方术
  现衰老死　　其身续存　　神变音声
  不终不始　　受诸等友　　而自由用
  世吼疗治　　众生之病　　开导痴騃
  令离愚冥　　而现泥洹　　亦不灭度
  何故殷勤　　欲得现已　　人常闇弊
  使意信乐　　以放逸故　　坠堕三处
  其心踊跃　　欲令觉了　　如来所诏
  常以知时　　为其众生　　而行智慧
  以何方便　　而受道法　　何因令获
  从佛经教

世尊说是如来寿限时。则无央数不可思议众生。皆获利谊解脱至道

正法华经卷第七正法华经卷第八

        西晋月氏国三藏竺法护译

    御福事品第十六

尔时世尊告弥勒大士。阿逸。欲知今佛说此如来寿限经典之时。六十八亿那术百千江河沙等诸菩萨。逮不起法忍。二千江河沙菩萨大士。皆得总持。如一佛世界尘数菩萨大士。逮得无碍辩才总持。复有如千佛世界尘数亿百千垓菩萨。得不退转总持。复有如千佛世界尘数菩萨大士。闻是经典。转不退转法轮。复有如中千佛世界尘数菩萨。逮得无垢大圣分别而转法轮。复有如佛小千世界尘数菩萨。闻斯经典。逮得八生住。当成无上正真道。复有如四天下尘数菩萨大士。闻斯法已。得一生补处。当成正觉。复有如八佛世界尘数黎庶。闻是经典。悉发无上正真之道。佛这说斯诸菩萨大士。寻则建立。应时虚空雨诸天华。意华及大意华。纷纷如雪。以散无数百千世界亿百千垓诸佛世尊。故来垂恩坐师子床七宝树下。及能仁大圣上。其无央数不可称限。诸灭度佛并多宝佛身。地即大动。及雨一切诸菩萨上。又雨四种栴檀杂香蜜香一切诸香。从虚空堕。虚空之中发大雷音。深柔软音自然妙响。千万璎珞若干琦珍。明月珠宝如意之珠。诸珠璎珞。皆于空中垂下如幡。无数香炉在于空中自然香出。复有无数百千宝盖自然来至。一一宝盖各各普覆一一佛上。上至梵天。诸菩萨众在于空中。执盖而侍亿百千垓诸如来左右。于是弥勒而赞颂曰

  安住令闻　　未曾有法　　本来未尝
  见此明光　　广大极远　　不可限量
  如向所睹　　无能思议　　今日我已
  所闻经典　　面观安住　　现分别说
  建立众生　　亿百千数　　大圣导师
  于世殊特　　不退转轮　　住于佛道
  或有得立　　执揽微密　　或有得处
  无限之谊　　亿百千数　　总持之要
  欲有限量　　及思惟者　　有所建立
  并越度生　　或有二住　　及八住者
  当得佛道　　所度无量　　或有学者
  超越千四　　或有至三　　或于二住
  缘从导师　　闻是经典　　当得佛道
  显第一谊　　或有建立　　一生补处
  成诸通慧　　游于诸有　　听省于斯
  大圣所说　　有成果证　　无有诸漏
  犹如八佛　　国土诸尘　　其欲数者
  限量如此　　若有黎庶　　亿数听经
  闻是皆发　　殊胜道意　　无极大仙
  造德若斯　　分别演说　　立真谛地
  无量诸身　　不得称限　　譬如虚空
  无有边际　　诸天所雨　　无数亿华
  不可计量　　天子亿千　　帝释梵天
  如江河沙　　其来至此　　无数亿千
  杂香妙香　　供养安住　　蜜香上香
  而已散佛　　专己作行　　犹如飞鸟
  普来供散　　安住如来　　上虚空中
  自然雷震　　柔软音声　　畅深妙法
  亿百千天　　俱共歌颂　　明月珠宝
  自然下降　　自然诸香　　而为芬薰
  七宝宝瓶　　亿百千垓　　罗列虚空
  如雁飞行　　供养大圣　　威神之尊
  诸盖亿垓　　不可限量　　广大周匝
  七宝严饰　　聪明智慧　　诸菩萨执
  身形高长　　上至梵天　　微妙姝好
  威光巍巍　　幢幡绮丽　　供养上佛
  咨嗟众圣　　亿千赞诵　　心怀踊跃
  敬安住名　　所在向方　　尊未曾有
  见若干种　　诸异导师　　而普示现
  寿命之限　　今此众生　　悉欢喜悦
  其谊广普　　至于十方　　导师音声
  靡不达至　　饱满众生　　亿百千数
  晓了道意　　具足庄严

尔时世尊告弥勒曰。其闻如来所现寿命所说经法。发意顷生快心笃信者。所得功德不可称量。譬如族姓子族姓女。欲得无上正真道。奉行布施持戒忍辱精进一心五度无极。八亿百千劫。不如族姓子族姓女。闻斯如来寿命之限。发意之顷欢喜信乐。而不狐疑若干种行归一道者。欲知功德。胜于八亿百千劫行五度无极。百倍千倍万倍亿亿倍巨亿万倍。福不可譬。无以为喻。佛言。阿逸。族姓子族姓女闻斯经法。一发意顷欢喜信者。则为坚住无上正真道成最正觉。佛时颂曰

  若一切遵修　　行五度无极
  志慕求斯慧　　意存佛上道
  设于亿千劫　　具足八前劫
  而布施诸佛　　数数及声闻
  供养诸缘觉　　菩萨亿千垓
  奉进诸饮食　　衣服床卧具
  榻席及屋室　　皆以栴檀香
  园观平等足　　为施经行处
  如是布施已　　若干种无数
  于亿百劫中　　用求尊佛道
  又复护禁戒　　信喜稽首佛
  明立无所犯　　犹得佛慧故
  复次顺忍辱　　住于调定地
  志尊无所限　　忍无数骂詈
  设睹卒暴者　　住慢而自大
  志能忍彼等　　以求佛道故
  常殷勤精进　　宽弘心坚固
  意念余思想　　游至亿佛土
  若处于闲居　　欲弃于睡眠
  其人亿劫行　　常习于经行
  欲比无等伦　　亿千劫禅定
  加复八千亿　　而行专一心
  志愿上佛道　　欲得诸通慧
  具足定无极　　一切禅寂然
  诸所造福德　　合会而聚集
  亿百千劫中　　如前所咨嗟
  若男子女人　　其闻佛寿限
  一时欢喜信　　此德为最上
  当弃捐犹豫　　诸着思想事
  信乐大法谊　　其福为若斯
  若菩萨求道　　尊奉亿劫载
  是闻不为闻　　听佛寿无量
  当已顶稽首　　如是像类人
  然后将来世　　度脱亿数人
  如能仁世尊　　释师子大人
  坐于佛树下　　而演师子吼
  吾今所以来　　众生所供敬
  处于佛道场　　说寿亦当然
  志性悉具足　　其人博闻持
  所说谛化人　　则无有狐疑

佛复告阿逸。其有闻说如来寿经者。入中受持分别晓了。其得福德不可称限。即过于彼若干亿劫奉五度无极。上至于佛慧。所当示现。所当奉行。复次其闻是经。即持书写已。载于竹帛供养奉事。散华烧香捣香杂香。缯彩幢幡麻油灯香。油灯醍醐灯。其福过彼甚多无数。当致如来慧见之事。犹如阿逸。彼族姓子。设得闻斯如来寿限经。其心质直欢喜信者。以是情性当观此相。即当知之。以见如来在灵鹫山说是经时。与诸菩萨眷属围绕声闻之众。于斯佛土三千大千世界之中。平等忍辱地为绀琉璃紫磨金色。八种交道七宝行树。若干种亿。屋宅居室。诸菩萨众于其中止。阿逸。欲知彼其人心常而质直安悦信者。以是色像知其相行。曾见佛会又如来尊。悉见彼人心所信乐。如来灭度后族姓子女。闻此经卷亦不诽谤。欢乐受持。则为如来所见拥护。其族姓子。超于兴起为佛塔庙。起于建立精舍讲堂。超于瞻视比丘疾病。而给医药供养之具。所以者何。是等族姓子。以为具足兴立塔庙。起七宝寺上至梵天。悉为供养一切舍利。其佛塔寺周回无限。普尽地际悬众宝铃。无上之藏诸舍利庙。供养华香杂香捣香。宝盖幢幡伎乐歌颂。若干种香。天上世间所有珍琦。天华天香及天伎乐。空中雷震畅发洪音。钟磬大鼓箜篌乐器。箫成琴瑟铙镜若干。柔软哀声歌舞节奏。调合克谐。无数亿百千劫供养奉侍。诸度无极皆悉充备。佛灭度后其有得闻此经典者。持读书写若分别说。福胜无量。修慈愍哀广普受持。讲堂精舍床榻锦绣敷具。令比丘众顿止其中。园观华实明月珠宝。经行诸坐饮食供养。病给医药一切施安。悉令具足。其床榻脚若干种宝。微妙显好上至梵天。幡盖校饰。劝助福故。稍稍转具而灭除罪。靡不粲丽。五体精进而在闲居。积累功德。无数巨亿百千劫中。称扬其名。一切庄严威神巍巍。皆悉弥普。于是世尊。而叹颂曰

  若起七宝寺　　上至于梵天
  华香及伎乐　　幡盖悉供养
  诸床卧之具　　饮食细供馔
  病瘦给医药　　宝床若干品
  入微妙庄严　　上至于梵天
  普校饰佛土　　劝助兼备足
  五事劝闲居　　咸兴变亿数
  一切人所乐　　微妙施最胜
  供事悉具足　　鲜洁华幢幡
  以此为衣服　　数数如雷震
  众伎柔软悲　　以供养舍利
  香油为然灯　　分布围周匝
  其有持此经　　于乱讲说法
  以为具足辩　　斯若干供养
  无数亿屋室　　皆以栴檀作
  讲堂三十二　　极高无有极
  悉敷诸座具　　随所欲饮食
  如是亿百千　　供珍妙肴馔
  园观及经行　　华布遍其地
  覆盖具无量　　采画若干像
  用供养众僧　　其持是经法
  目前办斯已　　如来灭度后
  若读诵写经　　欢喜如信乐
  其得福无量　　超余福之上
  其有人书写　　净洁令安谛
  当供养经卷　　华香普芬薰
  常当然灯火　　香油为锭镣
  所生辄欢喜　　数上思夷华
  其人奉经卷　　供养当如是
  得福甚众多　　其限不可量
  譬如虚空界　　其限不可得
  十方之无量　　其福比如是
  何况能复加　　常施于安隐
  奉戒行禅思　　而在燕坐行
  无嗔不恶口　　恭敬立思惟
  比丘尼常当　　谦恪不自大
  智慧如明月　　问智者不恐
  次第顺分别　　意怀愍得佛
  假使如是像　　持殊胜经者
  其人功德品　　不可得限量
  设使人见此　　如是像法师
  当持此经卷　　奉敬加供养
  假使有人　　以天华香　　用天宝盖
  而以覆阴　　当以首顶　　礼其人足
  常想念之　　如来最胜　　尔时见者
  作是思惟　　而当求索　　树王之下
  当觉成佛　　所在供养　　为饶利益
  诸天世间　　假使住立　　若处安坐
  所在经行　　其德如是　　卧在床榻
  若着衣服　　而常讲演　　斯如来经
  于时士夫　　于此经卷　　兴若干种
  显谛微妙　　世尊导师　　所说至诚
  以无数珍　　而供养者　　如吾所叹
  所有土地　　则为佛身　　于彼经行
  佛圣于中　　如坐座上　　觉了所在
  游居之处

    正法华经劝助品第十七

尔时弥勒大士白佛言。其有闻是所说经典。得何福祐。以偈颂曰

  大雄若灭度　　其有闻是经
  省之即劝助　　为得何福祐

于是世尊告弥勒曰。如来灭度后其有闻是所说经者。若比丘比丘尼清信士清信女。男子女人大小眷属。闻已劝助。于众会中宣转为人说。若在屋宅若在露处。若在闲居郡国县邑。所当作为如所闻经。如所受得住彼力势。为人解说。若为父母宗室叹咏。闻大士言亦读代喜。所可闻知展转相传。不见法师威容色貌。若转学者代之劝助。以是因缘所兴方便。使五道人有五盖者通得相见。各以所闻转相劝化。听我所说劝助之福。所闻法师经法功德。族姓子女。无所千载四域天下。六趣群生未尽罗网。有色无色。有想无想。不有想不无想。有足无足。两足四足多足。诸天人民。或有一人欲求功德。随此众生所欲乐喜。已所爱重极上微妙供养之具满阎浮利。为一一人广大布施。随其所欲。屋宅金银水精琉璃珊瑚虎魄车磲马瑙。象马车牛众宝合成。无央数岁恣所求索应意备足。供养饮食无所乏少。中自念言。年朽力弊心用疲殆。岂可化入如来法律。以佛所诏用诲众生。寻如所念。以律检非导之典教。黎庶一时俱履道迹。往来不还无著得证。诸漏以尽禅定具足。威神巍巍得八解门。一心不乱。于阿逸意云何。彼时士夫所建福施。有能思惟限量者乎。弥勒答曰。甚多不可赀计。乃能安慰无量众生。供足所乏加复立志。于无著证。佛告阿逸。今故语仁。宣布四远如彼士夫。兴大布施。供给无数四域群生。立无著证。佛言。其闻是经一句一偈。劝助代喜。福过彼人所布施上。一句一颂劝助功德。不可称限。百倍千倍万倍亿倍。巨亿万倍亿百千劫。不可计量无以为喻。何况目见于此经典。耳听代喜德难计会。假使有人欲闻斯经。若入精舍所至到处。若入县邑若住若坐。一时得闻此经法者。若再反闻所在专精。现在生处所获福祐。常得自然无数珍宝。宫殿精舍床榻坐具。象马车乘安雅无量。说经进止若住若坐。息心天王就拥护之。不遭罪患。释梵四天翼佐营卫。转轮圣王近师子座。设族姓子唱言。有经名正法华。真可奉敬宜共听受。更相请命。若辞泥雨设懈不行。若得斯须暂听闻者。则解罪福善恶报应。便得德本当获总持。与诸菩萨世世相随。在在所生聪明智慧。亿百千世体常香洁。不堕恶趣不与贼害。兵刃共会无有邪心。面色光润生贤善家。见者欢喜无憎恶者。不盲不聋鼻不偏戾。亦不塞齆不喑不哑。不秃不跛不瘘不癖。不愚痴不短不长。不柔不刚不白不黑。面不痿黄。身体完具姿颜端正。色如桃花人所爱敬。心性仁贤口言辩慧。疾逮禅定如来法教。欲觐诸佛如愿即见世尊正觉。当学此经。佛语阿逸。且观其德。若有一人。一反闻名劝助代喜。乃获此福。何况有人。专精听受供养思惟。而复具足为人说者。尔时世尊。而叹颂曰

  最后若有　　值是经卷　　假使逮得
  一颂之说　　听采其谊　　心喜劝助
  其人功德　　不可限量　　设令有人
  独能施与　　常给众生　　亿千垓数
  如佛向者　　所现譬喻　　令无数劫
  皆得饱满　　于时丈夫　　睹面色变
  头白齿落　　年老朽耄　　斯群生类
  将无终没　　我欲教化　　使入道法
  其人最后　　以法教喻　　为分别演
  无为之地　　一切五道　　犹如芭蕉
  速令逮及　　于灭度事　　一切众庶
  皆听受经　　而从士夫　　亲近咨请
  制伏其心　　皆使无漏　　一时之顷
  得无著证　　若闻一偈　　代是劝助
  所得功德　　出彼无量　　各各所施
  一一分别　　一颂之德　　难计难限
  仓卒得闻　　讲一颂者　　莫能限量
  动无崖底　　其人得福　　无数如是
  何况现在　　面自启受　　假使有人
  来至众会　　一反闻经　　欢喜踊跃
  从亿百千　　诸垓劫数　　是法难值
  亦难晓了　　若今有人　　还及彼土
  须臾得闻　　于斯经卷　　且当听是
  所获果报　　在在所由　　无有大病
  世世所生　　舌无有患　　牙齿坚固
  未曾堕落　　初不凶害　　除诸危殆
  及邪反戾　　父母贤良　　所立巧便
  寿命常长　　未曾生盲　　目亦不冥
  鼻耳姝好　　无有缺减　　唇口雅妙
  面常鲜洁　　常为众人　　所见爱敬
  口气芬馥　　无有臭秽　　形体常香
  如青莲华　　其薰流布　　无所不周
  若居堂室　　行至精舍　　所到之处
  有听斯经　　须臾之间　　还知闻者
  熙怡喜踊　　在边启受　　其人仪体
  获致安隐　　殊妙车马　　则用躬迎
  若复乘于　　贤善象车　　所在游得
  若干种宝　　常复获逮　　上妙璎珞
  数百千人　　悉共发意　　住造其所
  所说法果　　则为讲斯　　清净教诲
  清净法故　　所建鲜明　　得为天帝
  梵天床座　　速疾逮致　　转轮圣王
  长处众会　　敷演经谊

    正法华经叹法师品第十八

尔时世尊。告常应时菩萨大士。若族姓子族姓女。受是经典持读书写。当得十眼功德之本八百名称。千二百耳根。千二百鼻根。千二百舌根。千二百身行。千二百意净。是为无数百千品德。则能严净六根功祚。彼人若令眼根清净而以肉眼睹诸所有。满三千大千世界诸味石蜜丛树。下至无可大地狱中。上至三十三天。一切普见悉能摄取。故曰肉眼。若有众庶生其中者。皆悉见之。咸晓了知罪福所趣。于时世尊而叹颂曰

  其执此经卷　　勇猛处众会
  所说不怯弱　　旦听斯名德
  八百诸名称　　清净目明朗
  若已离诸垢　　其目所觉普
  彼则以肉眼　　而从父母生
  睹诸佛世界　　普见超神仙
  诸山须弥山　　又睹于铁围
  并诸陵丘阜　　而复察大海
  默正住一处　　普瞻靡不达
  下至无可狱　　肉眼为若此
  尚未获天眼　　亦不晓了知
  肉眼之境界　　根且觉轻便

佛复告常应时菩萨。若族姓子族姓女。说是经典。若为异类声闻乘说者。则便逮得千二百耳名称。闻三千大千世界周匝。下至无可大地狱。上至三十三天。超外神仙。所谓闻者。象声马声牛声。伎乐声车声。啼哭声愁叹声。鼓声钟声。歌声舞声戏笑声。男声女声。幼僮声僮女声。风声奇妙声。正法声非法声。乐声苦声。力声志性。声柔声粗声天声龙声。鬼神揵沓和阿须伦迦留罗真陀罗摩休勒声。火声水声地中声。比丘声声闻声。菩萨声如来声。三千大千世界所有音声。内外通彻一切清净。以肉耳根。悉闻众生所说声。尚未得天耳而悉普闻。晓了萌类诸声。亦不思惟观察。黎庶本末所由。又耳悉闻。亦不求索一切音声。又而顺闻巍巍如是。常应时菩萨大士未得天耳。而耳所听乃如斯也。佛说此已欲重解谊。从后颂曰

  鲜洁总摄　　若干品类　　清净之耳
  千有二百　　于是世界　　以是听省
  闻其音声　　无有遗余　　有六情者
  则而听闻　　车牛诸乘　　象马音声
  拍手击鼓　　悲好音声　　铙钹梢拂
  亦复如是　　伎乐柔和　　其音殊好
  虽在于彼　　无所染着　　闻无数人
  诸可讲说　　彼人等伦　　所喜分别
  皆闻诸天　　天耳所听　　常而降伏
  甘美柔和　　男子女人　　诸啼哭声
  童男童女　　所可作为　　哀鸾之音
  及赤嘴鸦　　鵁鶄鸳鸯　　及与鹦鹉
  其有栖持　　于山林者　　悉得听闻
  斯类音声　　地狱之中　　勤苦毒痛
  悲哀嚾呼　　所酷苦响　　思想饭食
  所至求索　　兴作发起　　所出音声
  诸阿须伦　　居在于海　　诸响畅逸
  而各各异　　于时法师　　停住于此
  有语言者　　寻则普闻　　畜生饿鬼
  劳饥渴声　　各各讲说　　或鸣或吼
  彼时法师　　默如立斯　　则得听闻
  若干音声　　其梵天上　　所居诸天
  光音天上　　善究竟天　　及余奇特
  各各异声　　法师普得　　悉闻此响
  在安住世　　而出舍家　　诸比丘众
  讽诵所行　　分别现说　　他人志性
  法师悉闻　　是等说经　　诸菩萨众
  处斯境界　　所可讽诵　　为他人说
  可集结谊　　以为经典　　悉得普闻
  若干种音　　其佛世尊　　为人御法
  而为众生　　说无数经　　独在树下
  悉得听闻　　因其菩萨　　能持此经
  一切三千　　是佛国土　　无数众生
  音声畅逸　　若在室中　　或复处外
  所言粗细　　悉普聆掺　　悉闻一切
  群萌音响　　于诸音声　　亦无所著
  处处悉知　　他人表里　　其耳清净
  聪彻如是　　斯人常未　　得天耳光
  适睹因缘　　寻能即听　　于时法师
  功德如是　　学斯经卷　　名称若兹

佛复告常应时菩萨。若族姓子族姓女。有持是经卷分别说者。若复讽读书着竹帛。得八百功德诸根坚固鼻根清净。以是鼻根三千大千世界所有诸香。皆得普闻。柔软香须曼香生香。傅饰须香思夷华香。青莲红莲黄莲白莲。若干树木果实薰陆香。苏合香华香。栴檀香木榓香。青木榓香种种众香。百千殊品处处生者。诸质朴香人所嗅香。男子女人童男童女香。皆自闻。御己身之香。象马六畜飞[狂-王+禽]走狩香。诸树木香。诸树木间含血品类香。诸妖魅香。至诚香天上香。比陀美香。昼度树香。意香大意香。柔软香。诸天香天宫香。帝释身香。知所生处。于讲堂上鼓乐弦歌。所当修设诸大法则。为忉利天诸天说法。从地踊出自然生者。歌戏利谊天玉女香。童男童女香。以是因缘。假生梵天诸天子等。诸大天人大梵身香。其香各各从身流出诸天杂香无数百千。其名各异。声闻缘觉菩萨大士。如来游居所开化香。其法师者于此间住。所去殊远不到其前。亦不近边不往就嗅。悉闻彼香不爱不求。亦不思念亦不乍香。而嗅知气以一心住。在于众会。悉分别说如是诸香。心亦不着无所慕求。于是世尊。而叹颂曰

  其人鼻根　　清净如是　　若干种香
  所闻甚多　　于是世界　　一切所有
  诸所可生　　香香甚好　　又有诸形
  华殖之香　　栴檀诸香　　种种异品
  其诸香实　　各各异类　　微妙好薰
  众木榓香　　男子女人　　童子女类
  其心顿处　　各各异品　　人间所生
  诸香参差　　在在兹殖　　青苍杂遝
  又知大国　　转轮圣王　　所据柔仁
  自由力强　　于彼所有　　难缕字名
  众众异香　　皆分别之　　财物珍宝
  若干甚多　　藏去着之　　于何所地
  有玉女宝　　及余珍异　　时彼菩萨
  悉晓了香　　是等体着　　所有璎珞
  珠环庄严　　衣被端正　　或时在座
  若复床卧　　以香涂身　　菩萨悉知
  歌戏娱乐　　一切神足　　明哲智者
  鼻力悉闻　　若有奉持　　此经善训
  以快妙香　　及麻油香　　若干种类
  及华实香　　所在安住　　又嗅悉知
  其于某处　　有此众香　　悉能分别
  若干种香　　而于山岩　　中间所有
  无央数种　　栴檀华香　　又复人民
  诸所有香　　居止于彼　　一切了知
  若转轮王　　所可爱喜　　或有潜处
  在于海中　　若于地内　　所生虫蛾
  明者皆练　　此辈众香　　知阿须伦
  妃后子女　　并及臣民　　皆分别识
  阿须伦王　　歌舞戏笑　　其鼻悉嗅
  如是果报　　若于旷野　　四缴道中
  多有师子　　虎狼龙象　　水牛眷属
  诸所种类　　特牛牸牛　　悉能知之
  若有女人　　随其喜乐　　假使童子
  及童女众　　若有怀躯　　身体疲极
  以香分别　　腹中男女　　复自识知
  身所从来　　又亦晓了　　谊法科律
  采睹其人　　安隐苦乐　　童男力势
  福应所获　　男子所愿　　众多悉知
  而睹嗅别　　诸所愿香　　已自可意
  如是无尽　　又复嗅别　　身寂然香
  其自处在　　地中诸藏　　财物珍宝
  金银杂色　　柔软珊[王*氐]　　形如紫金
  所止顿处　　悉嗅知之　　诸贯璎珞
  明月珠宝　　世间载有　　人所不及
  用鼻悉嗅　　知其好丑　　行来进止
  别其善恶　　诸天在上　　虚空之中
  意华诸华　　柔软音华　　众会之中
  所有诸华　　以鼻势力　　住此悉闻
  其诸天人　　所有宫殿　　上妙下极
  及中间宫　　种种之品　　如斯色像
  于是住立　　鼻力嗅之　　又复分别
  游观之园　　诸天之法　　众明寂然
  亦复晓了　　尊妙宫殿　　诸天子等
  所游戏处　　于是建立　　悉嗅天香
  以香分别　　诸天子党　　住于何法
  兴何等行　　所在游居　　悉闻其香
  诸天玉女　　所畜华果　　诸宝璎珞
  周旋娱乐　　于时菩萨　　悉识其香
  三十二天　　至第一天　　诸天大梵
  所游宫殿　　彼以鼻嗅　　悉能知之
  住已不住　　皆能晓了　　诸所远近
  无不开达　　终没若生　　前世宿命
  以鼻嗅之　　知斯本末　　其有菩萨
  持是经卷　　若有比丘　　顺安住教
  常修精进　　静住经行　　若已至诚
  讽诵解说　　其彼菩萨　　皆悉知之
  亦别声闻　　最胜之子　　常在树下
  一身独处　　其明哲者　　承嗅悉睹
  有某比丘　　处于某处　　悉能分别
  所在之处　　其有菩萨　　意坚禅定
  常自娱乐　　讽诵讲说　　复为他人
  讲演解法　　于时菩萨　　以香觉了
  安住大人　　游所在方　　愍哀行慈
  分别说法　　在其座中　　弟子围绕
  以香识了　　法王所在　　假使众生
  得闻经法　　以得禀受　　心怀踊跃
  时菩萨住　　于此悉见　　安住众会
  一切所在　　菩萨力势　　如是色像
  尚未逮得　　天人之鼻　　自然得是
  本之瑞应　　诸天之鼻　　无有诸漏

佛复告族姓子。其有持是经典读诵书写。当获奇异舌根千二百功德。舌根具足分别诸味。若得甘美。变为天上自然饮食。设服酢涩碱苦。化成天馔。嗞味无量。若入众会讲授法要。蒸庶欣载钦仰典则。若入诤怒德音柔软。谈谊辩慧清白知节。慈愍通彻。众人欢和感味余响。其从闻经言论美妙。天人往造。释梵四王清净天身诸天玉女。思侥往见。天子龙神妃后。阿须伦阿须伦妃后。迦留罗迦留罗妃后。真陀罗真陀罗妃。摩休勒摩休勒妃。揵沓和揵沓和妃。阅叉鬼神妇女。比耶反足鬼神妇女。悉欲往观。稽首作礼听受经戒问讯谊归。比丘比丘尼清信士清信女。国王太子大臣群僚。大力豪势转轮圣帝。尊重巍巍七宝具足。太子眷属玉女采女。又异梵志君子居士。州城郡国县邑营从。悉欲往观。思尽形寿稽首归命。供养奉侍听受经法。言诲和淑犹如世尊如来所叹面见思察。逮佛明慧深妙之要。晓了如此自然而闻。又知世尊所向方面坐说法时。于是世尊。而叹颂曰

  其人舌根　　则悉柔软　　分别诸味
  简练好丑　　自然甘美　　如天饮食
  若干种味　　次第而生　　音声殊妙
  语言和雅　　听受奇异　　意欢喜悦
  在众会者　　莫不钦敬　　又当演出
  深奥音响　　其有听闻　　所说经法
  睹察报应　　清净亿千　　即生欢喜
  晓了尊上　　供养经卷　　不可计量
  诸天龙神　　蛟阿须伦　　常怀钦敬
  欲得见之　　谦肃恭逊　　咨问经典
  其人名德　　获致如是　　于是世界
  发意之顷　　皆以音闻　　能遍告之
  其响柔软　　微妙殊特　　深邃儒雅
  而有限节　　诸天豪尊　　转轮圣帝
  欲得供养　　普往至所　　皇后玉女
  悉俱叉手　　而常元元　　听禀经典
  诸所鬼神　　善共宗重　　天揵沓和
  及诸营从　　反足女鬼　　及诸男女
  普悉恭敬　　皆造奉侍　　自在尊豪
  梵天之王　　大神妙天　　及诸天子
  天帝梵尊　　天子枝党　　无数玉女
  悉诣其所　　世间有佛　　圣明导师
  声闻弟子　　悉听妙响　　见所在处
  佥然护之　　察所讲法　　悉用欣然

佛复告族姓子菩萨大士。若闻是经持读诵写者。逮得身行八百功德。肌色泽光猛勇响饩。犹如琉璃净妙无垢。所当作为人民钦效。容止可宗进退致益。彼已无易。三千大千世界众生稽首为礼。普佛国土群萌好丑。鲜色恶色生趣善恶。铁围大铁围。小山大山。人所居处。下至无可大地狱中。上至三十三天。自以威德普悉见之。于此世界。声闻缘觉菩萨如来。所可游居讲说经法。以己威光都皆观之。所以者何。身行清净之所致也。于时世尊。而叹颂曰

  彼人己身　　所行清净　　譬如琉璃
  而无瑕疵　　为一切人　　所见爱敬
  其有持此　　微妙经卷　　犹如明镜
  见其面像　　见世形类　　亦复如是
  目睹本末　　及见他人　　其身清净
  如须弥山　　于斯世界　　所有众生
  诸天人民　　蛟阿须伦　　地狱饿鬼
  及诸畜生　　悉见身体　　及面颜容
  诸天所有　　宫殿馆室　　土山石山
  及诸铁围　　雪山须弥　　及诸大山
  悉得睹见　　其所在处　　以大威圣
  瞻见诸佛　　一切声闻　　及佛弟子
  若有菩萨　　独在屏处　　所说经法
  悉能知之　　其身清净　　亦复如是
  悉睹见于　　一切世间　　以俗之身
  觉了如兹　　斯人尚未　　获成圣道

佛复告族姓子。菩萨大士。如来灭度后。若持斯经讽读解说。得千二百意根清净德。其人则以清净意根。靡不贯畅。闻一颂者。所究弥广多所达了。以弘觉了。便能一月讲说经法。四月一年综练所历。忆念不忘。凡俗所为贩卖贾作语言音声。以法皆睹次第分别。不失其绪。三千大千世界诸六趣生。皆知其心所念善恶如应不应。中为沙门圣非圣者。普见不应。意志清净不复思惟。自然分别说法谊趣。言皆至诚。有至讲者皆亦承说。如来所诏一切剖析。往古最胜经卷。于时世尊。而叹颂曰

  其人意根　　清净皦洁　　光彻鲜明
  见心所念　　由是之故　　晓若干品
  瑕秽卑贱　　好恶中间　　若闻一颂
  能奉持者　　解无央数　　明哲谊理
  一月四月　　若至一年　　所说善恶
  不违至诚　　于斯世界　　中间所苞
  若有群萌　　种种品类　　诸天人民
  及阿须伦　　枝神异类　　及诸畜生
  六道之中　　所有黎元　　是等思想
  若干种念　　持是经者　　各各异意
  一时之间　　悉睹知之　　诸佛大圣
  百福德相　　一切悉为　　世间说法
  登时所讲　　普等听闻　　所说清净
  即能受诵　　前世更历　　所学经卷
  长夜所讲　　当综解之　　有常所演
  经典之要　　得众会中　　无所畏惮
  其有持经　　部分光扬　　卒未遭值
  众想之患　　枝党群从　　悉为贤良
  意根明达　　亦复如是　　菩萨所住
  未曾有地　　普为众生　　分别说经
  其能受持　　安住正法　　巧便意宜
  则知所应

正法华经卷第八正法华经卷第九

        西晋月氏国三藏竺法护译

    常被轻慢品第十九

于是佛告德大势菩萨。是故当知。其有比丘比丘尼。清信士清信女持斯经典。假使四部骂詈诽谤。出粗犷辞诃制止之。罪不可限。设复有人。闻是经卷受持讽诵。为他人说广解其谊。获上妙福。如斯畴类。佛所咨嗟。眼耳鼻口身意清净。而无蔽碍。又告德大势。乃去往古久远世时。不可称限广远无量不可议劫有佛。号寂趣音王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。劫名离大财。世界曰大柱。佛语德大势。寂趣音王如来。普为诸天自境界人。讲经化导。与声闻乘演四圣谛。度老病死使近泥洹。解十二缘所由从起。为诸菩萨讲六度无极。使至无上正真之道。现如来慧所行常连。佛寿四江河沙亿百千垓劫。佛灭度后正法住立。如一阎浮提。亿百千垓尘数劫。其像法立。如四天下亿百千垓尘数劫。又语德大势。其佛灭度后像法没尽。次复有佛。续号寂趣音王。展转相承二十亿千如来至真等正觉明行成为善逝世间解无上士道法御天人师。时此诸佛次第灭度。正法没已像法次尽。彼世比丘。憍慢自大越背法诏。有一比丘。名曰常被轻慢。为菩萨学。何故名之常被轻慢。其开士见比丘比丘尼清信士清信女。每谓之曰。诸贤无得憍慢自高。所以者何。诸贤志趣。当尚菩萨如来至真等正觉。以是方便。慎所缘谊。为诸比丘讲菩萨行。不受所诲不肯讽诵。遥见四部仍谓之曰。我身终不轻慢诸贤人。普当学菩萨高行。得至如来至真等正觉。佛语德大势。尔时四部得闻此言。咸兴恚怒毁呰骂詈。此一比丘。不问吾等不见人心。反自贡高云见人心。授我等决。当成无上至真等正觉。人所不欲非常之事。而为人说。又语德大势。若一比丘行值大雨。蒙佛威神如被覆盖。身不渍溺。虽见骂詈心不恚恨。面色不变。若闻其言憎不喜者。以瓦石掷。续遥举声而教之曰。勿行轻慢。修忍辱心发菩萨意。所以者何。尔时比丘比丘尼清信士清信女。贡高自大数数闻见。大士教曰。吾心常谦不轻诸贤。虽见骂辱心不增减。彼等四辈。因共名之常被轻慢。斯一大士临欲寿终。得闻寂趣音王如来讲正法华经二十颂本深妙之谊亿百千事。大士临终。踊在虚空唱扬大音。叹斯经典而告之曰。仁当受经。亦当逮得如前净眼。耳鼻口身意亦清净。已获斯净。更即增益二十亿垓寿。逮得定意。复为众人讲是经典。前时四部闻其所说而毁呰之。名此大士为常被轻慢建自大者。见此大士微妙神力辩才慧力善权道力。皆来归伏敬宗为友听闻经法。是等辈类。余不可计。无数亿人。便立无上正真道意。时彼大士寿没之后。便值二十百千亿如来正真。此诸世尊。皆为讲说正法华经。稍稍进前。以是德本。复更值见二十亿百千如来。皆同一号。号雷鸣音王。皆从得闻如斯经典。复更值遇二十亿百千如来。皆复同号。名雷音王。亦复从闻正法华经。受持讽诵为四辈说。在所生处。常自然获眼净耳净鼻净口净身净意净。视听洞彻。鼻通口辩。身能轻举。意睹众生心。普为四辈演斯经典分别其谊

佛语德大势。常被轻慢大士。供养奉事若干亿百千数如来已。复更值无数亿百千如来。亦复从受正法华经。以是德本。自致无上正真之道成最正觉。德大势。菩萨欲知大士常被轻慢于寂趣音王如来之世为四部人说经法者不乎。则我身是也。假使尔时设不受是正法华经。不持讽诵为人说者。不能疾逮无上正真道成最正觉。备从过去诸佛世尊。闻此经典。受持讽诵广为人说致最正觉。尔时比丘比丘尼清信士清信女。其一大士为说经言。我行恭敬不轻诸贤仁等当逮如来正觉道德之慧。又诸四部轻彼大士骂詈形笑不自改者。二十亿千劫所生之处。常不值佛不闻法声。又万劫中堕无可大地狱。拷掠烧炙痛不可言。罪已毕竟从地狱出。以彼大士教化之故。令发无上正真道意。皆得神通。慧无挂碍。今悉现在。佛语得。大势。欲知尔时四部毁呰形笑恚骂大士者不。今此会中颰陀和等五百菩萨。师子月等五百比丘比丘尼。今在佛前。五百清信士五百清信女等。皆不退转。当成无上正真之道。佛告德大势。此正法华经其谊广大。威神无量一切无庆诸菩萨大士所当钦尚。如来灭后其受斯经。持讽诵读得福如是。逮成无上正真道。于是世尊。而叹颂曰

  今我识念　　往古过事　　佛名寂趣
  音声之王　　威神无量　　天人所敬
  为诸众生　　人民讲法　　其佛最胜
  灭度之后　　然其正法　　最末世时
  有一比丘　　为菩萨行　　因时号名
  常被轻慢　　即时往至　　于比丘众
  及比丘尼　　所睹颠倒　　但劝化之
  志行佛道　　自宣我心　　不怀憍恣
  骂詈轻毁　　每见形笑　　彼时常为
  使闻此言　　假使得闻　　此经法时
  若复住立　　设有所作　　时明慧者
  临欲寿终　　用分别说　　此正法华
  寻时报应　　增益寿命　　变现其身
  而得自在　　处在虚空　　讲说经典
  教化一切　　悉发道慧　　于时大士
  寿终没后　　逮见诸佛　　亿百千垓
  稍稍渐渐　　开化入法　　为分别说
  于斯经卷　　诸最胜子　　得成为佛
  则我身是　　能仁如来　　其诸比丘
  口喜诽谤　　众比丘尼　　及清信士
  彼时所有　　诸清信女　　被蒙开化
  闻经解慧　　常当睹见　　无数亿佛
  则颰陀和　　五百人是　　诸比丘众
  及比丘尼　　清信士女　　今见佛前
  吾尔时悉　　令闻尊法　　皆开化之
  使得晓了　　于今佛身　　灭度之后
  数数当受　　奉斯经卷　　无数亿亿
  而当思惟　　未曾得闻　　如是之法
  假使有佛　　亿百千数　　希闻讲说
  如斯等经　　是故以闻　　如是像典
  自在圣尊　　称赞经典　　我灭度后
  若有说此　　频数当忍　　受正法华

    正法华经如来神足行品第二十

尔时于彼三千世界尘数亿百千垓诸菩萨等从地踊出者。一切皆悉住世尊前佥然叉手白大圣曰。如来灭后。布露经典遍诸佛国。及世尊土灭度之处。于彼所在讲说斯经。多所利益。若有受持此妙典要。讲读书写为人说者。德不可量。于时溥首。处于忍界诸菩萨无数亿百千垓。受比丘比丘尼清信士清信女。诸天龙神健沓和阿须伦迦留罗真陀罗摩休勒及人非人。如来皆为神足变化。如来至真等正觉。为现瑞应。悉得柔顺法忍。皆令书写正法华经。化异世界亿百千数诸菩萨等。各各坐于诸宝树下师子座上

尔时能仁世尊。及此一切如来正觉。现其神足具足充满。百千岁中有所兴立。应时百千岁中功德自然。而大光明灭除阴云。弹指之顷自然有声靡不通达。十方佛国一切世界六反震动。诸天龙神阿须伦迦留罗真陀罗摩休勒。承佛威神各随所住。无央数千诸佛世界。普悉睹见斯忍佛土。又诸如来十方无数亿百千垓。各各自坐诸宝树下师子座上。能仁如来多宝世尊。于彼七宝庙寺讲堂。自然严净师子之座。威曜显赫无数无限。不可计会亿百千垓菩萨大士及四部众。见斯变化。心中愕然惊喜无量。得未曾有。则闻空中音声。而歌颂曰。仁者。欲知过是无限不可思议亿百千垓诸佛世界。有佛世界。名曰忍土。于彼有佛。号能仁如来。为诸菩萨大士。讲正法华经方等典诏。一切诸佛普护斯经。用救菩萨大士。以故诸贤。心当质直清净。稽首归命劝赞奉侍。供养彼能仁正觉。于时众生闻空中自然之音。有佛世尊。号曰能仁。这闻名称。应时叉手。以若干种华香衣服幢幡杂香。举手各散忍世界。璎珞珠玑诸贯真珠如意宝珠。而供养之。其华香幡盖璎珞珠玑明月宝珠。自然来入于忍世界。寻时合会为宝华盖。在于虚空悉覆诸佛及菩萨上。时彼世尊告诸异行。及佛前住诸菩萨众。如来正觉功德威神。不可思议。诸族姓子。于无数亿那术百千垓劫。说此经谊不可究竟。虽无央数若干种经。所不能及不可限尽。欲度彼岸难得边际。诸族姓子。举要言之。假令有人欲了斯经要。悉佛威神普诸佛法。诸世尊界诸佛精进。诸佛闲居诸佛妙力。示现是经。故族姓子。佛灭度后。当以殷勤求此经典。受持书写精进奉行。供养承事为他人说。设使有人。赍此经行讲赞书写。思惟奉宣着于竹帛。若在精舍斋堂室宅。大林树下若在水边。当起塔庙。所以者何。则为如来所处之地。观是道场佛所坐树。则当察之。一切如来正觉所游。群圣世雄转法轮处。十方诸佛在中灭度。等无差特。于斯世尊。而叹颂曰

  世愍哀法　　不可思议　　而常建立
  神通之慧　　亦复示现　　普等明目
  众生一切　　悉得欢喜　　其舌神根
  畅音梵天　　演奋光明　　亿百千垓
  诸群萌类　　睹见神足　　怪未曾有
  皆入大道　　又圣导师　　兴一大光
  弹指之顷　　宣洪音声　　即时普告
  一切佛土　　周遍十方　　诸佛世界
  如此变化　　及余感动　　大圣所现
  瑞应如是　　如来尔时　　皆令欢喜
  佛灭度后　　奉是经卷　　安住宣畅
  功德之法　　无央数劫　　不可思议
  持是经卷　　福祚之限　　导师咨嗟
  若干无量　　欲尽其限　　不可边崖
  犹如虚空　　不可穷极　　名称至德
  无能思惟　　持是经者　　净德常然
  则为见佛　　大圣导师　　及吾于世
  灭度大通　　则此一切　　诸菩萨众
  并复睹此　　四部之会　　其有值遇
  斯经典者　　则为遭见　　今日之会
  佛灭度后　　亦复在此　　及彼十方
  诸佛世界　　其有能持　　此经卷者
  则为睹觐　　诸过去佛　　及于十方
  今现在佛　　目自面见　　供养奉持
  悉当悦意　　向人中上　　在于道场
  所可思惟　　当速受持　　于此经典
  自然辩才　　无所挂碍　　设本种命
  不能长者　　当分别晓　　于斯经谊
  便当受持　　于此世尊　　晓了诸经
  次第所归　　大圣世尊　　灭度之后
  假使有人　　至诚说者　　分别此经
  议理所趣　　则讲审谛　　诸经卷谊
  其人光明　　分别所觉　　譬如日月
  普照远近　　游于天下　　在所至到
  劝化发起　　无数菩萨　　是故智慧
  诸菩萨众　　闻如是像　　经无等伦
  我灭度后　　奉此经典　　其人不疑
  于佛大道

    正法华经药王菩萨品第二十一

于是宿王华菩萨前白佛言。药王菩萨。以何等故。游忍世界。堪任无数勤苦之难。善哉天尊。愿为十方诸佛世界菩萨声闻云集于斯。若有闻佛班宣药王。初发道心宿行功勋。为今众会及后来世。普闻受持追学究竟。天人龙鬼诸尊神王。佥皆悦豫发大道意。自致正觉度脱一切。于时世尊。见宿王华发心至诚。为一切诸佛赞曰善哉。乃为将来诸菩萨施。劝进后学令入道智。谛听谛听善思念之。唯然世尊。愿乐欲闻。佛言。乃往过去江河沙劫。尔时有佛。号离垢日月光首如来至真等正觉。出现于世。其土寿命四万二千岁。教化众生济度危厄。于时十方菩萨大会有八十亿。诸声闻众七十二江河沙等。又其佛土而无女人三恶之趣。无阿须伦八难之患。其地平正绀琉璃色。众宝校成庄严清净。生众宝树周回围绕。珍琦珓珞周匝覆盖。竖诸幢幡。宝瓶香炉烧众名香。一切树下设宝床榻。坐具严饰不可称载。诸坐具上有五千亿诸天之座。鼓诸音乐歌佛功德。以为供养。于时其佛。为诸菩萨及声闻众。分别讲说正法华经。时有菩萨。名众生喜见。闻佛敷演散解义要。即奉佛法遵习苦行。夙夜精进。万二千岁。经行不坐竟万二千岁。即便逮得普现三昧。逮此定已辄复思惟。吾以逮是普现三昧。便能致此正法华经因逮定意。踊跃欢喜心自念言。我当供养离垢日月光首如来至真奉正法华经。即如其像三昧正受。处在虚空。雨心天华杂香栴檀。用供养佛。应时所雨众华杂香。普熏十方诸佛世界。其闻香者悉得法忍。众生之类和心相向。众生喜见菩萨。从定意起重自思惟。虽用杂物供养于佛。不能畅尽至真之德。以身供养尔乃无上。寻如所念。断绝五谷专食众香。众香华汁而以饮之。日使身中内外皆香。如是服香竟十二年。复和众香以涂其体。香油润衣。而立誓愿以身为灯。为一切故。即然其身供养诸佛。以精诚故。其光遍照八十江河沙诸佛世界。应时诸佛同声赞曰。善哉善哉。族姓子。精进乃尔世之希有。斯真供养如来经典。乃为众生忍苦不劳。超踰天人一切所行。国财妻子施所不及。供养之中为尊为上。为最为长为无畴匹。以身施者乃成法施。诸佛世尊叹是德已。则便默然。于时菩萨自然其身。千二百岁火故不灭。用一心故无有苦患。于是之后火焰乃息。勤修精进供养法故。于是终没还生其世。更复值见离垢日月光首如来至真之士。生离垢施国王宫内。自然化生结加趺坐。而为父母说此颂曰

  尊王识念我本行　　坚强勤修大精进
  所重爱身以用施　　建立住此逮三昧

说此偈已启其父母。离垢日月光首如来至真。今故现在。吾往昔时至心供养。因是逮致了一切音总持法要。是正法华无上经典学中要者。经卷本有八十垓百千亿那术垓偈。当一心思。何所造作立佛像摸。而常心中无嗔恚。怒此正法华菩萨所行。吾本宿世。习若干千亿百千垓偈。从彼如来。而闻受之。离垢施王赞其子曰。善哉善哉。当共俱往躬身当觐供养圣尊。说此言已。与父王俱踊在空中。去地七刃经行虚空。足不蹈地。其身正坐七宝珓珞珍琦帐中。往诣佛所叉手礼佛。以颂赞曰

  人中之尊　　颜姿离垢　　其光巍巍
  照于十方　　吾本供养　　圣尊无极
  今复自亲　　故来奉面

尔时众生喜见菩萨大士。说此偈已。前白离垢日月光首如来至真。世尊垂恩愍哀十方。故复现在训诲一切。度脱众生无不蒙赖。时离垢日月光首如来。告众生喜见菩萨。今时已至吾欲灭度。以此法教而相嘱累。佛因其时至所教周悉乱世欲到吾舍去矣。为佛施座今取灭度。又告之曰。以斯经典重相嘱累。普令流布等润十方。咸使一切皆蒙福庆。众生喜见则曰。受教。其佛夜半便取灭度。于时菩萨众生喜见见佛灭度。以栴檀香琦异妙香蛇维佛身。取其舍利香汁洗之。感慕哀泣泪下如雨。修造宝瓶八万四千。立七宝塔高至梵天。庄严幢盖悬众宝铃。心自念言。吾已供养世尊舍利当复更事超过于前。告诸菩萨及大声闻。诸天龙神一切人民。诸族姓子咸共思念。世尊舍利普共供养。于是佛告宿王华菩萨。当尔世时。众生喜见菩萨劝率众人。供奉舍利八万四千塔。于塔寺前。建立形像百福德相。然无数灯烧香散华。光显道法。供养奉事七万二千岁。供养讫竟。在其众会。化无数千诸声闻众。开诸菩萨皆令逮得普现三昧。见众菩萨建立定已。自现其身诸根缺漏。诸菩萨众及诸弟子天龙鬼神。举声号啕泪下如雨。是族姓子众生喜见菩萨大士。是我等师开化我党。今现缺减诸根不具。是故悲酸不能自胜。于时众生喜见。谓诸菩萨及大弟子诸天龙神。吾建要誓至诚之愿。如我所言随顺不虚。我此手臂成紫金身。令我手臂平复如故。地当大动于虚空中雨众华香。所言适竟。地即大动天雨众华。寻时手臂平复如故。众生喜见欲度一切。因示现此慧力所行。福德功勋势力所致。佛告宿王华菩萨。欲知尔时众生喜见菩萨大士。今药王菩萨是。又族姓子。菩萨勤苦不可称计。捐身弃命无有限量。常建大乘志无上道。兴发大功无极之德。于如来前然一足指。功德难喻。况然其身以为供养。胜施国土妻子血肉。设以珍宝满佛世界。布施供养诸佛圣众。福德虽多不及于彼。所以者何。福报有尽无益众生。若族姓子族姓女。受正法华一四句颂。分别奉行为人解说。比其福施万不如一。犹如巨海万川皆归。此经如是。一切诸法最为元首。犹若须弥众山中高。如月盛满星中最明。大慧光明照曜三界。为诸法首无上道王。犹如日出普照天下消众幽冥。此经如是。蠲除一切愚痴闇蔽。皆入道明。犹天帝释忉利天上诸天中王。此经如是。一切诸法众经典主。揽持十方度脱一切。犹梵天王处第七宫。制御诸天莫不奉命。此经如是。普济众生学与不学。教导三乘行君父业。犹如四道及至缘觉。皆超一切诸凡夫学。正法华经亦复如斯。皆超一切上中下乘。处众生之原化诸不逮。犹如菩萨所行高远。过诸声闻缘觉之业覆护三世。此经如是。调御诸法。悉令成就无上正真。犹如世尊三界法王。被道服饰三十二相诱众愚蔽。此经如是。从菩萨学乃至如来。开导声闻诸缘觉等。皆使成就无上正真。犹族姓子。斯经典者为三界护。度脱众生危厄之难。饱满饥虚众情之患。寒者温暖。热者清凉。有裸露者皆得衣被。开导众生悉令入道。犹如导师将护众贾。菩萨如是。养育众生若如慈母。譬如船师渡人往返。菩萨如是。周旋三界度脱一切灭众闇冥。犹如炬火灭众闇冥。化生老死。犹转轮王制御四域。此经如是。以圣道明照耀三界。犹如大明消天下冥。此经如是。致不退转无从生忍至成佛道

佛告宿王华菩萨。斯经典者。度脱一切众苦之患。拔断诸垢三毒疹疾。救济生死诸系牢狱。若闻此经。寻即解了能书写者。其功德福无能称计。何况闻持怀抱诵说。华香供养杂香泽香然灯幢幡。若有闻持药王菩萨往古学品。受持思念之。其福过彼众物供养。不可称载。若有女人。闻此经法寻即受持。便于此世毕女形寿。后得男子。若有女人。于五浊世最后末俗。闻是经法能奉行者。于是寿终生安养国。见无量寿佛。与诸菩萨眷属围绕。生宝莲华坐师子座。无淫怒痴除去众结。亦无贪嫉未曾怀恨。适生其国得五神通。逮不退转不起法忍。已逮法忍。辄得睹见七十二亿兆载江河沙诸如来众。适见诸佛。眼根清净。眼根已净。所见一切十方诸佛。遥赞叹之。善哉善哉。族姓子。汝乃值是能仁佛世。间佛所说正法华经。受持讽诵为他人说。此功德福。火不能烧水不能漂。盗贼怨家县官不侵。千佛嗟叹不能究竟。所获功德不可限量。巍巍如是。缘斯功德。降伏众魔。弃诸怨敌。渡生死难周旋诸患。又族姓子。以是经法伏众恶逆。为诸千佛所见建立。拥护汝身。天上世间而无俦匹。自舍如来。未有声闻及诸菩萨。功德福祐智慧定意。无有等侣

佛告宿王华菩萨。若有学人。受是经者。所逮圣明势力威德。超越若斯。是故仁者。若有讲说此药王品。有赞善者。后生为人。口中自然优钵华香。身栴檀香。若闻此经赞叹善者。其人现在功德远闻。佛已豫叹其人功勋。佛告宿王华。吾以是经嘱累汝等众生喜见往古法品。最后末俗五浊之世。流布天下阎浮利内。无能中坏。其魔波旬不能得便。及魔宫属邪神鬼魅。无能害者。天龙罗刹鸠洹厌鬼。无敢当者。又宿王华。是药王品威德所立。所流布处若有疾病。闻是经法病则消除。无有众患。因是功德。后致正真无老病死。若有比丘。最后末世。手执青莲华。满盛杂香。供散法师。心自念言。假使有人。求菩萨乘至此道场。吾授斯华以为草座。敷佛树下降伏众魔。具足法鼓吹大法螺。缘此济度生死之海。若大乘学。见诸比丘持是经卷。当观其人功德如是。佛说是药王菩萨往古品时。八万四千菩萨。即皆逮得晓一切音方便总持。于时众宝如来赞言。善哉善哉。宿王华菩萨。卿能咨启不可思议经典行业。如来讲说何以快哉

    正法华经妙吼菩萨品第二十二

于是世尊能仁如来。即从眉顶大人之相演百千光。照于东方千八百万亿江河沙诸佛国土。靡不周遍。过是诸佛土有世界。名庄严照明。其土有佛。号离垢紫金宿华王如来至真等正觉。与无央数诸菩萨众眷属围绕。宣布导化。能仁如来所演光明。遍照彼土。又其佛土有一菩萨。名曰妙音。从过去佛殖众德本。供养无数百千兆垓诸佛正觉。每见诸佛咨受经典。逮成圣慧。以得尊重三昧。定法华三昧。施离垢三昧。乐宿王三昧。无著光三昧。慧印三昧。普晓诸音三昧。等集众德三昧。喜信净三昧。神足戏乐三昧。慧光三昧。严净王三昧。离垢光三昧。离垢藏三昧。无缘三昧。日转三昧。取要言之。普悉逮得亿百千垓江河沙数诸三昧定。其佛光明普遍周至照妙音菩萨。妙音菩萨蒙佛圣光。因诣佛所白世尊曰。我欲往诣至忍世界。见能仁佛稽首作礼。咨受经典及欲致敬文殊师利。药王菩萨。妙勇菩萨。宿王华菩萨。尊意行菩萨。净王菩萨。超药菩萨。咨讲经义受诸不及。令一切闻悉发道意。其佛告曰。往族姓子。虽到彼土。莫发异想而念其土懈废下贱。所以者何。又族姓子。彼忍世界。其大陆地黑山杂糅。众垢石沙秽恶充满。溪涧山谷不与凡同。其土佛身卑小丈六。诸菩萨身长七八尺。又卿本体高四万二千踰旬。而我现身八万四千踰旬。端正殊好色像第一。威曜殊妙相好颜容难可比喻。积百千德睹莫不欢。又卿往至见彼土人。慎莫心念起不可想。如来菩萨佛土不如。所以者何。佛土本空。众生罪福。现有不同。妙音菩萨复白佛言。承佛威神如来圣力。道德巍巍以自娱乐。往诣忍界。如来道慧清净之业。辄当如法无所违失。不敢起想

于是时妙音菩萨心自念言。不起于坐。即如其像三昧正受。到忍世界至灵鹫山。当在如来法座中间。化作八万四千亿众宝莲华。紫金茎白银叶。严饰净好光明巍巍。照诸会者。辄如所念即时办足。文殊师利问能仁佛。唯然世尊。今化现此八万四千众宝莲华。紫金茎白银叶。清净严好。此谁瑞应而现此变。佛告文殊。有菩萨名曰妙音。从紫金离垢宿华王佛土而来。与八万四千菩萨俱。进至此忍界。欲见吾身稽首咨问。欲得听闻正法华经。故先见瑞。文殊师利复问佛言。其人宿本积何功德造殊妙行。而今致此奇特洪勋。住何三昧本造立行。愿欲闻之。所行三昧神足变化。吾等闻之当受奉行。见诸菩萨颜貌色像。为何等类。举动进止何所饶益。甚哉世尊。唯现瑞应。使诸菩萨来至于此。众会欲见之。佛语文殊。卿当启白众宝如来。令现瑞应。使诸菩萨咸来至此各现身相。一切众会皆欲见之。文殊师利即受其教。辄启灭度众宝如来。寻现瑞应

于时妙音菩萨而于本土忽然不现。与八万四千菩萨俱。动诸佛土雨宝莲华。同时发作百千亿伎乐。诸来菩萨各自现形。其眼明好犹如绀色。颜貌充满如月盛明。体紫金光。无央数亿百千功德庄严其身。威神巍巍智慧光光。奇相众好文饰光颜。身力无极。其身处在七宝交络。于虚空中去地四丈九尺。与诸菩萨眷属围绕到忍世界至灵鹫山。下宝交路。手执宝瑛其价百千。诣能仁佛稽首足下。以持贡上能仁如来。复白佛言。紫金离垢宿王华如来致问无量。起居轻利游步康强。又问。世尊说法如常乎。众生一切受者增进耶。蠲除狐疑顺法律不也。将无多怀淫怒痴行憎嫉饕餮不。能恭敬孝顺父母听受道法如法奉行不。随邪见爱惜财宝诸根不定。为降诸魔众官属乎。又诸众生。听受灭度众宝如来所说法耶。今诸菩萨故来诣此。本土如来之所发遣。欲得奉见七宝塔寺灭度众宝如来。问讯启受圣体康宁说法如何。众生普受行如法不。众宝如来现住久如。我等故来。欲得睹见众宝如来形像所类。愿佛现之。时能仁佛语众宝如来。今妙音菩萨及诸眷属。欲见世尊圣体形像。众宝如来寻时赞曰。善哉善哉。族姓子。卿能故来见能仁佛。稽首咨受正法华经。及复欲睹文殊师利启诸不逮。时莲华首菩萨问佛。妙音菩萨往宿命时。积何德本。乃致斯变无极神圣。时能仁佛告莲华首菩萨曰。乃往过去久远世时有佛。号云雷音王如来至真等正觉。讲说经道六度无极菩萨法藏。天上天下靡不蒙安。时妙音菩萨。闻其所说欣然意解。鼓百千音乐娱乐其佛。八万四千众宝妙器。贡上至尊。如是精进供养如来万二千岁。又族姓子。妙音菩萨往宿命时。从云雷音王如来之世。修无上法种此功德。未曾懈废。传如来旨化诸愚冥。不识至真悉令信。乐。欲知尔时妙音菩萨。今妙音菩萨是也。用彼世时布施宝器众伎乐音。又复供养无数诸佛。亿千佛所殖众德本修治众行。前世值遇亿百千垓江河沙等诸佛世尊

今莲华首。为现妙音菩萨所行。不可限量变无数形。为诸众生宣布讲化正法华经。或现梵天形色貌而诱立之。或现天帝形或尊豪形。或将军形化导众兵。或息意天王转轮圣王诸散小王。尊者长者诸令长形。沙门梵志形像色貌。说正法华经。或现比丘比丘尼清信士清信女形。宫人婇女长者夫人诸贫贱女形。男女大小而诱立之。说正法华经。或阿须伦形。迦留罗真陀罗摩休勒人非人形像色貌。而诱立之。说正法华经。或入地狱饿鬼畜生及诸八难。所在拥护而救济之。上中下士前后进退。随其形体男女之像。而开化之。说正法华经。或入中宫化皇后形。度众贵人。莲华首当知。妙音菩萨。将护忍界一切众生。又族姓子。妙音菩萨。以若干变无数方便。诱忍佛土演正法华经。神足威德未曾损耗而复增益也。圣慧道智亦复如是。又族姓子。妙音菩萨。光明功勋智慧巍巍。周旋十方随时开化。轮转无际皆使入律。上中下愿各令得所。逮游忍界。复至他方江河沙佛土。现菩萨身而为说法。又现声闻缘觉色像而开化。示本行所学。闻之亘然各成所志。不违本誓。若有众生。奉如来律。以佛色像。随其道律示现形貌。显授大道无上正真。欲导慕泥洹现已灭度。因而示仪开化道慧。妙音菩萨。势力圣智不可恻度。超绝巍巍功德若斯。无以为喻。于是莲华首菩萨前白佛言。妙音菩萨。积功累德堂堂乃尔。唯然世尊。住何三昧开化众生不可限量。能仁如来告莲华首菩萨曰。族姓子听。有三昧名现入众像。妙音菩萨。住斯定意利益开化。无限众生使入道议。佛说是妙音菩萨章句品时。其诸菩萨与妙音开士俱发来者。寻时皆逮现入众像三昧正定。其行殊胜。于是忍界超越菩萨。所修定意诸有限数。若有逮致现入众像三昧。便得总持。揽持三世无不蒙济。时妙音菩萨。供养能仁如来至真。具足奉事众宝如来塔寺舍利。欲还本土。前稽首能仁如来。自归而退。与众会别。动震诸国雨众莲华。同时和鼓百千亿垓雅颂伎乐。与八万四千诸菩萨众俱归本土。前稽首礼妙紫金离垢宿华王如来。以诣忍界导利众生。又睹众宝如来宝寺舍利。及文殊师利药王菩萨所逮精进无极道力。见妙勇菩萨。令是八万四千菩萨。皆得正行现入众像三昧。往到彼间俱共进行。四万二千天子。闻正法华经。皆悉逮得无所从生法忍。莲华首菩萨逮正法华定

正法华经卷第九正法华经卷第十

        西晋月氏国三藏竺法护译

    光世音普门品第二十三

于是无尽意菩萨。即从座起偏露右臂长跪叉手。前白佛言。唯然世尊。所以名之光世音乎。义何所趣耶。佛告无尽意曰。此族姓子。若有众生。遭亿百千垓困厄患难苦毒无量。适闻光世音菩萨名者。辄得解脱无有众恼。故名光世音。若有持名执在心怀。设遇大火然其山野。烧百草木丛林屋宅。身堕火中。得闻光世音名。火即寻灭。若入大水江河驶流心中恐怖。称光世音菩萨。一心自归。则威神护令不见溺。使出安隐。若入大海。百千亿垓众生豪贱。处海深渊无底之源。采致金银杂珠明月。如意宝珠水精琉璃。车磲马瑙珊瑚虎魄。载满船宝。假使风吹其船流堕黑山回波。若经鬼界值魔竭鱼。众中一人窃独心念。光世音菩萨功德威神。而称名号。皆得解脱一切众患。及其伴侣众得济渡。不遇诸魔邪鬼之厄。故名光世音。佛言。族姓子。若见怨贼欲来危害。即称光世音菩萨名号。而自归命。贼所持刀杖。寻段段坏手不得举。自然慈心。设族姓子。此三千大千世界满中诸鬼神。众邪逆魅欲来娆人。一心称呼光世音名。自然为伏不能妄犯。恶心不生不得邪观。若人犯罪若无有罪。若为恶人县官所录。缚束其身杻械在体。若枷锁之。闭在牢狱。拷治苦毒。一心自归。称光世音名号。疾得解脱。开狱门出无能拘制。故名光世音。佛言。如是族姓子。光世音境界。威神功德难可限量。光光若斯。故号光世音。佛告无尽意。假使族姓子。此三千大千世界满中众逆盗贼怨害。执持兵杖刀刃矛戟。欲杀万民。一部贾客。独自经过在于其路。赍持重宝。导师恐怖心自念言。此间多贼。将无危我劫夺财宝。当设权计脱此众难。不见危害。谓众贾人不宜恐畏。等共一心俱同发声。称光世音菩萨威神。辄来拥护令无恐惧。普心自归便脱众难。不遇贼害。众贾人闻悉共受教。咸俱同声称光世音。身命自归愿脱此畏难。适称其名。贼便退却不敢触犯。众贾解脱永无恐怖。光世音菩萨。威德境界巍巍如是。故曰光世音。佛复告无尽意菩萨。若有学人。淫怒痴盛。稽首归命光世音菩萨。淫怒痴休。观于无常苦空非身。一心得定。若有女人。无有子姓。求男求女。归光世音。辄得男女。一心精进自归命者。世世端正颜貌无比。见莫不欢。所生子姓而有威相。众人所爱愿乐欲见。殖众德本不为罪业。其光世音威神功德。智慧境界巍巍如是。其闻名者。所至到处终不虚妄。不遇邪害。致得无上道德果实。常遇诸佛真人菩萨高德正士。不与逆人。无反复会。若闻名执持怀抱。功德无量不可称载。若有供养六十二亿江河沙诸菩萨等。是诸菩萨。皆使现在等行慈心。若族姓子女。尽其形寿。供养衣被饮食床卧具病瘦医药一切所安。福宁多不。无尽意曰。多矣。世尊。不可限量。所以者何。是诸菩萨。无央数亿不可譬喻。佛言。虽供养此无限菩萨。不如一归光世音稽首作礼执持名号福过于彼。况复供养。虽复供养六十二亿恒河沙数诸菩萨等执持名号。计此二福。亿百千劫不可尽极。终不相比。是故名曰光世音。于是无尽意菩萨。前白佛言。光世音。以何因缘游忍世界。云何说法。何谓志愿。所行至法善权方便境界云何。佛言。族姓子。光世音菩萨所游世界。或现佛身而班宣法。或现菩萨形像色貌。说经开化。或现缘觉或现声闻。或现梵天帝像而说经道。或揵沓和像。欲度鬼神现鬼神像。欲度豪尊现豪尊像。或复示现大神妙天像。或转轮圣王化四域像。或殊特像。或复反足罗刹形像。或将军像。或现沙门梵志之像。或金刚神隐士独处仙人僮儒像。光世音菩萨。游诸佛土。而普示现若干种形。在所变化开度一切。是故族姓子。一切众生咸当供养光世音。其族姓子。所可周旋有恐惧者。令无所畏。已致无畏使普安隐。各自欣庆。故游忍界。于是无尽意菩萨。即解己身百千宝璎。以用贡上于光世音。惟愿正士。受此法供己身所有殊异宝璎。而不肯受。时无尽意复谓光世音。唯见愍念以时纳受。愿勿拒逆。时光世音心自计念。不用是宝。无尽意言。唯复垂愍诸天龙神揵沓和阿须伦迦留罗真陀罗摩睺勒人及非人。受其宝璎辄作两分。一分奉上能仁如来。一分供养众宝如来至真等正觉贡上宝寺。其族姓子。普为一切。以是之故。神足变化游忍世界。无所不济。于是持地菩萨。即从座起前白佛言。假使有人。闻光世音所行德本。终不虚妄。世世安隐至无极慧。其光世音。神足变化普至道门。所显威神而无穷极。佛说是普门道品。彼时会中八万四千人。至无等伦。寻发无上正真道意

    正法华经总持品第二十四

于是药王菩萨。即从座起长跪叉手。前白佛言。若族姓子及族姓女。闻是正法华经典。受持怀抱书写经卷。获福如何。佛言。族姓子女。受持是经。诵在怀抱书写经卷。福不可量无以为喻。若族姓子。供养八十亿百千垓江河沙诸如来众。若复受持怀抱书写。是正法华经讲说供养。何所福多。于意云何。宁当一心奉持经典。若以衣食供养诸佛。药王菩萨白佛言。若族姓子及族姓女。受正法华经典之要。执持书写一四句颂。讲说讽诵若复奉行。具足成就其福最多。胜于供养若干江沙诸佛世尊。佛言。甚哉。法之供养。最为第一。药王菩萨复白佛言。我当拥护如是等辈。诸族姓子及族姓女。受此经者斯法师等。以义宿卫长使无患。诵总持句。又寻咒曰

奇异所思意念无意永久所行奉修寂然澹泊志默解脱济渡平等无邪安和普平灭尽无尽莫胜玄默澹然总持观察光耀有所依倚恃怙于内究竟清净无有坑坎亦无高下无有回旋所周旋处其目清净等无所等觉已越度而察于法合众无音所说解明而怀止足尽除节限宣畅音响晓了众声而了文字无有穷尽永无力势无所思念

药王菩萨白曰。唯然世尊。是总持句。六十二江河沙诸佛所说。假使有犯此咒言者。若复违毁此等法师。为失诸佛世尊道教。佛叹药王菩萨大士。善哉善哉。若族姓子说总持句为众生故。愍念拥护多所安隐

于时妙勇菩萨前白佛言。唯然世尊。我身亦为众生之故。欲令永安。若有奉持此经典者。授总持句。将护如此诸法师等。令无伺求得其便者。鬼神诸魅溷厕众鬼突鬼厌鬼饿鬼反足虽欲来娆。无能得便。妙勇菩萨专心思惟。说此总持曰

晃耀大明炎光演晖顺来富章悦喜欣然住此立制永作无合无集

是总持句。江河沙等诸佛所说。咸共劝助。若违如来如是比像诸法师教。还自危亡。时毗沙门天王前白佛言。我亦当演此总持句。加以慈心为众生故。拥护法师

富有调戏无戏无量无富何富

以是故。拥护诸法师等。百由旬内无敢犯触。宿卫将顺。诸族姓子。如是比像至学法师乃能受持。以是拥护常获吉利。时顺怨天王。在彼会坐。与诸香音亿百千垓鬼眷属围绕。往诣佛所前白佛言。唯然世尊。我亦当宣此总持句

无数有数曜黑持香凶咒大体于器顺述暴言至有

唯然世尊。此总持句。四千二百亿诸佛所说。以此总持。拥护供养诸学经者。令无伺求得其便者。时有一魅。名有结缚。复名离结。复名施积。复名施华。复名施黑。复名被发。复名无著。复名持华。复名何所。复名取一切精。往诣佛所。鬼子母与诸子俱。异口同音前白佛言。我等世尊。常当拥护如是比像诸法师等。加施吉祥。令无伺求得法师短。于时诸魅同共举声。宣此总持将顺法师

于是于斯于尔于氏极甚无我无吾无身无所俱同已兴已生已成而住而立亦住嗟叹亦非消头大疾无得加害

是等之类是我眷属。令无所犯拥护法师。消除鬼神诸魅饿鬼溷神突鬼蛊道符咒痴狂颠鬼。化是像来。若鬼神形及非人像。二日三日若至四日。若常热病。若复夜卧。值恶梦者。若现男女大小诸像。我等拥护。令无伺求得其便者。于时诸魅。共于佛前说此颂曰

  犯头破七分　　犹如华菜剖
  当致杀母罪　　亦得害父殃
  其有犯法师　　皆当获此衅
  世世不得安　　不与诸佛会
  破坏佛寺罪　　斗乱圣众殃
  如合众麻油　　麻油聚一处
  放火皆燋然　　消尽无有余
  其有犯法师　　当获此罪殃
  犹如称载峻　　罪垢之所聚
  其有犯法师　　当获此重衅

诸鬼神军头等。说此颂已前白佛言。我等咸护如是比像诸法师等。使常安隐除去怨敌。周匝宿卫令无伤害。若有行毒。毒为不行。时佛嗟叹诸魅所咒。善哉善哉。汝等乃欲护诸法师。若闻此经。宣持名号德不可量。何况具足随时持说书在经卷。若以供养华香幢幡盖杂香捣香。然灯悬缯。思夷合欢。青莲红莲。黄莲白莲。稍着油苏以用然灯。供养此经勤修不懈。百千亿倍福不可限。汝等当护如是比像精进学者。佛说是总持品时。六万八千人。逮得无所从生法忍

    正法华经净复净王品第二十五

佛告族姓子。乃往过去无央数劫。不可思议长远难量。尔时有佛。号总水雷音宿华慧王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。世界曰照明严饰。劫曰爱见。又族姓子。于其佛世。有王名净复净。尔时其王有一正后。名曰离垢施。其后有二子。一名离垢藏。二名离垢目。又其二子皆得神足。轻举能飞智慧具足。功德备悉圣达巍巍。行菩萨业夙夜精进。未曾懈废。勤心专精六度无极。善权四等所济无限。悉遵通达三十有七道品之法。普畅道义。所周旋业。进逮离垢三昧定矣。度宿日光三昧。离垢显曜三昧。净庄严三昧。大威藏三昧。皆得通达。此三昧定而度无极。时佛集会与诸四辈释梵四天王诸天人民。班宣分别正法华经。时佛愍念一切众生。哀伤国土皆欲化之使入大道。又族姓子。其二太子往诣母所。叉手白言。惟愿屈意。见念加慈专精身心。欲往到佛奉见如来身。亦自欲稽首自归。所以者何。今日如来。为天上天下一切众生。广宣要典正法华经故。当奉觐听正法华。离垢施后告二太子。汝等父王。志存外邪信乐梵志。常怀嗔恨。以是之故。不可得往。时二太子同心叉手。复白其母。我等薄相。所生邪见无义之家。又我等身。本是法王子。当以经道化于浊俗反伪向真。尔乃佛子也。于是离垢施后告二太子。善哉行矣。汝真孝子。为其父母修大慈愍。各显神足睹之欣然心中开解。便听子等俱诣佛所稽首受业。时二太子辄受母教。其身踊住在虚空中。去地七仞。愍念其亲各现威变。在于虚空。二人俱时坐卧经行。身上出火身下出水。身上出水身下出火。演大光明照曜远近。现身长大复还为小。从虚空下入于地中。若人入水从地踊出。处在虚空犹如履地。其二太子现若干变而显神足。以用开化于其父母。于时父王。睹其二子神足变化威德若斯。欣然踊跃善心生焉。躬身叉手向二子曰。汝等师主所受谁乎。时二太子自启父王。大王欲知我等师主。总水雷音宿华慧王如来至真。是我等师主。今现在游于宝树下处于法座。为四部众诸天人民。广演宣布正法华经。其佛世尊。是我师主也。王告二子。吾欲往诣卿等师主。奉觐亲受大圣正真无上言教。于时二子。从虚空下行至母所。自白其母。而叉手言。阿母威德。则化父王。以造立心无上正真因成道教圣尊之业。惟垂愍念。听我诣佛出家为道得作沙门。时二太子为母说偈曰

  唯母听我等　　出家为沙门
  如来甚难遇　　曼时当精学
  所云难得值　　犹如灵瑞华
  难遇复越彼　　闲静不可得

于时王后离垢施。以颂告曰

  吾以听汝等　　善哉子辄去
  至圣甚难遭　　我亦出家俱

尔时二太子。叹是法颂报父母已。重复白父王及所生母。惟愿二亲。同时一心。俱往诣总水雷音宿华慧王佛所。屈意一时发见彼世尊稽首归命。所以者何。二亲当知佛兴难值。犹灵瑞华。亦如如意最上明珠。佛亦复然。不可再遇。是故我等来生此土。心念出家功德第一。由是之故。不宜有难。便可相许。报言。善哉。得出家学。弃捐爱欲舍其俗业。所以者何。若睹如来福庆无量。人命难得佛世难值。离于八难。得闲静难。犹死更生。父王皇后报太子言。诺。宜知是时。佛言。族姓子。尔时净复净王宫内。八万四千宫人婇女。宿命德本应得启受是正法华经典。本是道器。离垢目太子。宿命本修行积功累德。从来无限。离垢藏太子。无央数亿百千垓劫。往昔宿命曾以奉行。弃于众生一切恶趣三昧正定。何谓弃于众生一切恶趣三昧正定。其王正后二太子母离垢施者。晓十方佛一切道同诸佛要集。诸佛奥藏无极圣慧。以权方便现于女身耳。佛告族姓子。时净复净王。见二太子所见神足。化入如来至真之法。以得超越。展转相成多所度脱。一切盲冥咸入道明。便自发意。与其眷属四万二千。离垢施后与诸群党。随二太子中宫婇女群臣百官。一时和同往诣佛所。稽首足下退各就坐。从本常位。时佛见净复净王。与大眷属自投归命。因其本行观宿所缘。而为说法。应病与药各得开解。欣然踊跃善心生焉。更立国王。与其正后离垢施及二太子宫人婇女一切官属。弃国捐王行作沙门。已作沙门。八万四千岁奉修道业。思惟观察是正法华经典之要。讽诵奉行。如佛所教无所违失

于是净复净王。遵奉勤修正法华经。与其眷属。竟八万四千岁。逮众德本严净三昧正定。适逮斯定。其身即时踊在虚空。去地四丈九尺。住于虚空。遥白总水雷音宿华慧王如来至真。唯然世尊。其二子者则是圣师。化导吾家蒙其恩德。获现神足显扬变化。而缘是见所化神变。心得开解退俗入道。奉佛法训度众秽厄。顺从法律坚住无极。得奉如来启受经法。乃为至圣无盖善师。是二子者。示现子像生我家耳。皆是宿世明识本德。承佛仁慈。非是凡庶之可思论。佛告王曰。如是如是。大王。如大王所言。是二太子。宿殖德故。乃能示现。因欲开王及诸眷属一切众生。佛言。大王。若族姓子及族姓女。学是经典。所生之处周旋终始。易得善师显世尊教。得立无上正真之道。开化导示度脱一切。是为微妙无极之业。展转相教展转相成。得至圣谛无极之处。值佛道法王因遇善师。得见如来启受经法。由劝助恩。王今宁见此二太子。是诸族姓子。前世已曾供养奉事六十五亿百千兆垓江河沙等如来至真。而复授持是正法华经。愍伤众生没在邪冥九十六种不能自济。故开化之令住正见。修行精进求佛大道

于是佛语族姓子曰。其净复净王。于彼世时叹众功德。从虚空下即叉十指。前白其佛。唯佛宣布。如来至真本宿命时。行何功德。圣慧巍巍。眉间之相。演大晖曜照无限国。而目明好彻睹十方。其眉间相。白如珂雪。柔软细好。巍巍光泽平政无斜。无所不照。世尊面像充满如日。安住道目犹如月初。一切观之而无厌极。于时国王。说此颂曰

  其殊异功勋　　巨亿百千垓
  虚空尚可喻　　其慧不可限

佛以颂答曰

  前世行中正　　加施人平等
  故使眉间相　　所照无有限
  和视施灯慧　　目明踰日月
  其眼如月初　　彻睹十方国

时王嗟叹已叉手白佛。至未曾有。如来至真之教。弘慈无极。不可思议功德具足。敷演道义施设法禁。令无罪衅。长涂之难皆得无患。唯然世尊。如吾今日心不放逸。由得自在不随邪径。弃捐自大不从虚伪。亦无嗔恨。不兴恶心无益之业。我国多事。欲出家学不还中宫。重欲自归所有供养。佛言。大佳。时王即起稽首佛足。其王正后离垢施者。解身百千所著宝璎。以散佛上。佛之威神。化成七宝交露之帐。以为交露琦异妙帐。自然有床。布以无数琦异坐具。如来坐上。于时国王心自念言。至未曾有。天尊至德交露帐中。所见如来。甚大端正。威神巍巍光色第一。颜貌充满净好无比。愿令一切皆蒙此福。于时世尊告四部众。汝等宁见净复净王。一心叉手而住佛前。皆曰已见。佛言。比丘。是王于今是我学世现比丘像。于将来世当得作佛。名曰种帝王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。其佛土曰广普。劫曰超王。于时其佛。诸菩萨众不可称限。诸声闻众亦无央数。其佛世界。平等如掌。无有倾斜无沙砾石。得作佛时威神巍巍。广大无极光光如是。能仁如来告族姓子。欲知尔时净复净王发道意者。岂是异人。莫造此观。所以者何。则是今现莲华首菩萨是。欲知尔时离垢皇后者。今光照严饰菩萨是。常念诸菩萨愍伤众生故。生彼国开化度之。欲知尔时二太子者。则今药王菩萨超药菩萨身是。又族姓子。药王菩萨超药菩萨。功德巍巍无限若斯。在无央数亿百千垓诸如来所。殖众德本。是二正士道德备悉不可思议。若有闻此二正士名执持怀抱。一切众人皆当礼敬。如是学士。天上世间皆归仰之。佛说是往古宿世本所行时。八万四千人远尘离垢诸法眼净

    正法华经乐普贤品第二十六

于时普贤菩萨。过东方江河沙诸佛国土。诸菩萨来者。动诸佛国。雨众莲华。鼓亿百千垓伎乐。歌叹如来功德。承其开士其大神足无极变化。大菩萨身威神巍巍。圣旨玄妙普照十方。与诸天龙神揵陀罗阿须伦迦留罗真陀罗摩休勒人及非人俱。各各将诸眷属。各显神足不可思议至灵鹫山往诣佛所。稽首足下绕佛七匝。前白佛言。我从宝超威王如来佛土来。承今世尊演正法华经。故至忍界欲得听受。与诸菩萨无数百千。亦乐听闻所宣道议。善哉世尊。唯加垂哀。以时颁宣正法华经。宁有女人。何所修行。得奉执经卷。佛时即告普贤菩萨。族姓子。女人有四事法。得是经卷。何谓为四。一曰常为诸佛所见建护。二曰积功累德不以懈废。三曰能分别化究畅众要诸所聚处。四曰普护众生发未发者。是为四。逮是经卷

时普贤菩萨前白佛言。最后末俗五浊之世。若有比丘受是经典。长拥护之令得吉祥。除众抂横毒亦不行。令无伺求得其便者。有受是经。咸共宿卫。令魔波旬不能娆乱。及诸官属诸鬼神龙。沟边溷鬼蛊道符咒。令不得行躬身自往。常以一心拥护法师。常使安隐。若有比丘学此经典。坐起经行精进修业。象马车乘往到其所护此经典。与诸菩萨眷属围绕。俱当往诣法师比丘。受是经者。思惟行者。令不忘失正法华经一句之义。乘驾往诣此学士所。目自奉见。为是经举。见我欢喜普更勤学。当护法师逮得三昧。若复获致回转总持。又当逮成若干百千亿周旋总持。晓了一切诸音总持。惟愿世尊。若于最后余残末俗五浊之世。余五十岁中。比丘比丘尼清信士清信女。受是经典宣示同学。持书慕求为他人说。最后末俗余五十岁。若能受是正法华经。心存解义精进不废。致二十一日诸行稍备。已致诸行。二十一日勤心存于法。自现可敬巍巍之德。乘六通驰。与诸眷属大小相随。往诣法师劝助法师。二十一日专修此法。使心开解怀致总持。若使法师不化众生。若不劝助不能开化。非人得便。犹是法师不得拥护。不致安隐。是故学者常行精进。承佛威神宿卫法师。若有法师。持佛正法便勤精进。愿听总持。其辞咒曰

无我除我因我方便宾仁和除甚柔软柔弱句见诸佛因诸总持行众诸说盖回转尽集会除众趣无央数计诸句三世数等越有为举诸法晓众生音师子娱乐

唯然世尊。是则名曰是总持句。若有菩萨。耳根听闻此总持句。入耳中者。即当知之。普贤菩萨之所建立。是正法华经若布天下。阎浮利内值是经者。心当思念。普贤菩萨威神所致。令我等辈致是经卷。普贤菩萨所行神化。令此众人致此妙典。斯等众生。无数佛所积众德本。如来至真手摩其头。若有书写执持在手。则奉佛身。敬爱道法敬书是经。书是经已欲解中义。于此寿终生忉利天。适生天上。八万四千天人王女。往就供养鼓琴歌颂。已作天子坐王女中。而相娱乐。若族姓子。但书是经功德如是。何况诵说思惟中义。是故世尊。一心勤修正法华经。书持经卷常当思惟一切不忘。当礼此人。用书写此经至德所致。而为千佛所见授臂。临寿终时面见千佛。游在吉安不堕恶趣。寿终之后生兜术天。适生天上。八万四千诸玉女众。往诣其所鼓诸伎乐。而歌颂德。在诸玉女以法相乐。是族姓子。书此经者功德如斯。何况诵说思惟其义。是故勤修书写宣传。正法华经。思惟奉行皆令具足。专精一心志未曾乱。千佛授臂。临寿终时。面见千佛不堕恶趣。于是寿终生兜术天。在弥勒佛所成菩萨身。三十二相庄严其体。亿千玉女眷属围绕。是故智者。常当勤修书是经典敷演思惟。唯然世尊。若有书此经卷思惟诵说。功祚无量不可称限。巍巍如是。是故智者书持是经。当得还致若干功德。吾以是故。建立是经。用五弘意勤念道法。流布天下阎浮利内

于是能仁如来至真告普贤曰。善哉善哉。汝乃发心多所哀念。精进勤护将来菩萨。劝道于斯无思谊法。其心怀抱无极大哀。发心之顷摄无量行。各执经卷建立拥护。若有受持普贤菩萨宣其名者。则当知之见能仁佛。前已曾闻如是像法。供养奉事见能仁佛。班宣经道讲赞善哉。如来摩头。则当谓之是普贤也。佛之威神之所建立。佛以衣服而覆护之。受如来教。不乐俗业不喜调戏。合偶嘲呓不好歌舞。不游在外。不入屠杀养猪鸡鹜。不与女人无益从事。若闻是经。书写听受持讽诵说。乐如是像。自然之法思惟奉行。缘内精专自兴福力。一切众生若有睹见。靡不爱敬。若有比丘受持此经。不为淫怒愚痴所缚。不为贪嫉自大所系。不怀憍慢刚强自用强梁邪见。己利止足。若有法师普修至贤。最后末俗世余五十岁五浊之俗。若有比丘受持是经。当作是知思惟解念。是等族姓子。必至道场降伏魔宫。而转法轮击于法鼓。吹大法螺演时法雨。于师子座而处法座。最后末俗世受持是经。功德如是。又是比丘不猗利养不贪衣钵。是等法师志性质直。而无谀谄不堕痴冥。其人现在自然如是。若有比丘受持是经。世世不忘所生聪明黠慧。未曾聋盲。现在获安无有众患。若毁此经诃学持者而复诽谤。其人现在身致癞病。见书是经非之不可而共调戏。所生之处其身缺漏。为火所烧常遇诤讼。鼻面生疱手足了戾。口目不政其身臭秽。体生疮痍。医药不治困苦难言。若说是经有闻见者。宣之不可增恶不喜。所说不诚言不真实。用是犯恶众罪之故。得殃无量在所不安。佛言。是故普贤。若见比丘受持是经遥起远迎恭敬承事。如奉如来。今佛现在靡不归命。归彼法师如是无异。乃应佛教。佛说是乐普贤品时。如江河沙亿百千垓诸菩萨众。皆逮总持

    正法华经嘱累品第二十七

于是世尊能仁。从法座起。合诸菩萨如其色像示现神足。都举大会着其右掌。而赞叹曰。诸族姓子佛从无数不可计会亿百千劫积累造行。乃成无上正真之道。得度无极。故取诸贤安措右掌。举手下之以为念识。当受斯经持讽诵读当为众会分别说之。令诸群生普得见闻。又族姓子。心无所著。勿得秘惜此正法华经。志无所畏。则施佛慧如来之慧自在之慧。则为无上无极法施。当学佛行。无得矜惜悭嫉爱重。宜广示现斯如来慧。当使通闻至于不至。往所不往。当勤听受此要经典。其不信者。当令信乐。当劝群生入于尊法。诸族姓子。能如是者。则知如来之所建立。时诸菩萨。为能仁世尊所见咨嗟。悉踊跃加敬倾身侧体。低头叉手稽首自归。向能仁佛同声启白。唯如世尊所敕。不敢违教。请奉行之。具足顺从如佛所宣。愿勿为虑。诸菩萨三启如是。所至到处。周旋十方颁宣圣旨

尔时能仁正觉一切发遣。十方世界诸来世尊。各随便宜从其所安。时十方佛皆亦报曰。如来亦当从宜所安。诸如来正觉多宝世尊。七宝讲堂佛之塔庙。即复故处。又诸如来皆从所安。佛说是经时。十方无量异佛世界诸来大圣。坐佛树下处师子座。多宝如来及大士等。诸余学行现佛前者。不可计会无数无量。并从地中踊出菩萨。诸大声闻四部之众。诸天龙神阿须伦揵沓和。世间人民。闻佛所说莫不欢喜

正法华经卷第十


大方广佛花严经修慈分一卷

    No. 306

    大方广佛花严经修慈分一卷

        唐于阗三藏提云般若等奉　制译

如是我闻。一时佛在王舍城鹫峰山中。与无量大菩萨众俱。弥勒菩萨摩诃萨。而为上首

尔时东方。有十亿梵天。皆住慈心。来诣佛所。顶礼佛足。以众妙供供养于佛。供养毕已。各自坐于众福所生莲华之座。恭敬尊重。瞻仰如来。南西北方。四维上下。诸来梵天。皆亦如是

尔时诸梵天众。在于佛所。各以慈目。递相瞻顾。复共同时。舒颜谛视。弥勒菩萨。时弥勒菩萨摩诃萨。即从座起。偏袒右肩。长跪合掌。白佛言。大德世尊。一切智者。于诸法性。能正觉了。遍知众生善恶之业。凡愚由此。生死往来。善能开悟三乘之道。及以三乘。同归一乘。一切众生。根性差别。及于烦恼缠盖之中。有如来种。普皆明见。无有谬失。又知诸法皆悉是空。如梦如幻。如阳焰等。无有坚实。而大悲无尽。以善方便。令诸凡夫。见佛色身微妙之相。佛身者。般若波罗蜜之所成就。自然真实。常住不变。犹如虚空。若有众生。勤修福慧。不随心识。驰鹜于境。非如渴鹿于旷野中。追求阳焰以之为水。如是之人。则得见佛。恒闻说法。亦能依教。如理修行。世尊。我今欲于如来应正等觉。少有所问。唯愿慈哀。为我宣说。世尊。菩萨云何。于阿耨多罗三藐三菩提。少用功力。安乐无倦。而能速证广大佛法。菩萨云何。在生死中。不受无量众苦逼迫。于诸佛法速得圆满

尔时世尊。告弥勒菩萨摩诃萨言。善哉弥勒。汝于我所。常有所问。今所问义。最顺我心。汝今哀愍诸天及人一切世间。无量众生。多所利益。多所安乐。故能问我如是之义。吾当为汝。分别演说。令诸菩萨。不经勤苦。而能速疾证佛菩提。佛子。若有众生。为求菩提。而修诸行。愿常安乐者。应修慈心以自调伏。如是修习。于念念中。常具修行六波罗蜜。速能逮及诸忍之地。速得圆满无上正觉。具足十力四无所畏。十八不共法。三十二相。八十种好。最上功德。庄严其身。尽于未来。常住安乐。亦能除灭。一切众生无始已来诸业重障。佛子。若诸菩萨。修习慈心。应在空闲寂静之处。以清净信。摄诸心法。观察其身上下支节。皆微尘聚。地水火风。和合所成。复应思惟。即彼一一微尘之内。皆有虚空。是诸虚空。莫不悉以容受为相。又应想念。彼诸微尘。清净明彻外如琉璃。内如紫金。庄严妙好。柔软芬馥。复应观察一切世界所有众生一一众生所有支节。一一支节。所有微尘。皆亦如是。若诸菩萨。于自他身一切众生。作于如是决定解已。复应想念自身微尘。一一尘中。皆有佛国。其中宫殿。琉璃所成。白银为门。黄金为柱。广博崇丽。光影洞彻。宝堂间列。宝墙围绕。宝阁宝楼。处处分布。其中各有诸天宝床。重茵绮褥。敷置其上。复有无量上好园苑。围绕庄严。其园苑中。皆有浴池。悉以七宝而为提岸。黄金栏楯四面周匝。清泉长流引注其中。香末为泥。金沙间错。八功德水。弥满澄净。波头摩花。优钵罗花。拘物头花。分陀利花。菡萏开敷。周布其上。其池四边。多诸宝树。真珠为花。光色滋荣。其果成熟。香味具足。于诸树下。置天宝座。一一座前。宝器行列。甘露美食。莫不充满。复应想念。如是一切诸佛国土。青绀琉璃。以为其地。众妙七宝。绮错庄严。是诸土中。所有微尘。清净细妙。如天上宝。其光晃曜。如盛明日。其色美好如阎浮檀金。香气氛氲如乌罗伽栴檀。质性柔软如迦旃延衣。触着于身能生悦乐。作是观已。即应想念。从此东方。一切世界。所有众生。皆来入我诸佛国土宫殿之中。南西北方。四维上下。彼诸世界。所有众生。皆亦如是。又应想念。如是六道一切众生。皆同威仪。色相相似。其身柔软常有香气。丈夫之相。具足庄严。离诸苦恼。受天快乐。是诸众生。若须衣服庄严之具。即时往诣劫波树下。随其所须。应念而得。种种众具以为严好。譬如他化自在之天。复有香风从八方来。其风触身。令心适悦。有诸乐器。无人抚击。随风回动。出妙音声。是诸众生或在宫殿。或游园苑。或有食于诸天美食。或执宝器。而饮甘露。或有坐于莲花之台。身佩璎珞。两边垂下。财宝充满。众具备足。随其所好。种种欢娱。面目熙怡。身心悦怿。体常无病。盛年好色。不老不死。功德势力。皆同一类。无有为人之所使者。悉能摧灭淫怒愚痴。当证菩提。究竟安乐。佛子。是修慈者。若在如是众生之中。见一众生于已有违。心缘于此。不生爱念。则应以智慧。深自观察。我往世中。定于此人。作重业障。以是因故。还于今日。障我菩提。我若于此人。不生欢喜。则于余一切众生之处。皆亦不应。而作饶益。何以故。以无始时来在生死中。无一众生非于过去。曾害我者。若于此众生。不生怜愍。于余一切。当亦复然。我今普于一切众生。皆行饶益。是故于此。决当慈念。复应思惟。嗔恚因缘。能令众生。堕于地狱。若怀怨结。后必生在毒蛇之中。若我来世。受斯报者。当令彼人。深快其意。故应舍离所有嗔恚怨结之心。我若多嗔。及怨结者。十方现在诸佛世尊。皆应见我当作是念。云何此人欲求菩提。而生嗔恚。及以怨结。此愚痴人。以嗔恨故。于自诸苦不能解脱。何由能救一切众生。多嗔众生。在在生中。所受之身。恶毒充满。故应修习慈愍之心。永远离于嗔恚怨结。平等平等。利益安乐一切众生。若如是思惟。离嗔结已。次应想念。十方诸佛。与诸菩萨声闻大众俱来。入我诸佛国土宫殿之中。是诸如来身量大小。过人一倍。具诸相好。端正香洁。以天衣服。庄严其身。各各坐于千叶莲花师子之座。一一无量众所围绕。覆以宝盖。悬众宝幡。种种璎珞。周匝垂布。有天乐器。不鼓自鸣。其音和雅。闻者喜悦。香风徐动。吹诸宝树。幢幡盖网。璎珞等物。出妙音声歌赞如来种种功德。黄金为器。七宝庄严。其器光明。犹如日月。所有香气。如坚黑栴檀。甘露满中。而以供养。诸佛菩萨及声闻众。其诸菩萨阿罗汉等。皆于如来最上法中。游戏快乐。复应想念。一切众生。皆于诸佛座前而坐。佛为演说修慈之行。如我今时之所修习。言音美妙。悦可其心。令诸众生。获最上乐。譬如有人。得甘露浆。而以洗沐。息除劳苦。形神休畅。此亦如是。以法沾心。灭诸烦恼。身心寂静。永得安乐。复应想念。如是一切宝幢幡盖。衣服等物。所有微尘。光明朗曜。出过于日。柔软细滑。如触天身。所出之香。如牛头栴檀。其色清净。如毗琉璃宝。一切物像。皆于中现。又应想念。彼诸如来一一如来身之微尘。柔软光色。转加殊胜。比前微尘。踰百千倍。复应观察。我所思念。一切众生。性空无我。如梦如幻。如阳焰如眩翳。一切诸佛亦复如是。自性皆空本无有我。凡夫无智。于彼妄执。有我自性。是故不能解脱生死。复应观察。一切诸法。体相微细。皆悉空寂。凡夫之人。以自分别。生诸境界。自分别中。还自系缚。乃至未了心之自性。齐尔许时。如在梦中。妄着诸境。复应观察。一切三界皆悉是空。空不碍空。我今慈心。犹为狭小。又应思念。如一切众生及以诸佛。性空无我。当知我身亦复如是。一切国土亦唯想念。作是解已。复应观察。彼诸所有一切微尘。一一尘中。皆有三世诸佛国土。是诸国土。最极清净。超过于前所有佛国。三世诸佛三世众生。及以三世庄严之事。皆悉具足。三世劫数入于一念一一念中。三世诸佛。坐一切处。普现一切众生之前。或入禅定。或说妙法。或餐美食。或饮甘露。一一佛前。三世菩萨。及阿罗汉。围绕而坐。三世快乐。充满其身。亦自见身。在诸佛所。受于如是三世安乐。复应想念。一一念中。我三世身。各持无量上好供具。而以供养一切诸佛。菩萨声闻。及以施与众生之类。于一一念。从其身出种种香云。云中复有无量宝盖。庄严绮饰。弥覆一切诸佛如来菩萨声闻。及以六趣众生之上。其云复雨天之甘露及坚黑牛头栴檀香末。曼陀罗花。摩诃曼陀罗花。波头摩花。拘物头花。芬陀利花。妙香花。妙意花。皆从空中。缤纷而坠。电光烈曜。如日舒景。雷音震动。闻者悦豫。一切诸佛菩萨声闻。及诸众生。若行若住。若坐若卧。四威仪中。其身恒受最上安乐。佛子。譬如比丘。入遍处定。于一切物。皆作地解水火风解。以如是解。摄持其心。修慈之人。亦复如是以慈胜解。庄严摄持。复应思惟。我今所与众生安乐。但唯是想。如幻如化。譬如幻师作所幻事。我亦如是。与诸众生种种安乐。又如幻物无有自性。一切众生。亦复如是。本来无有我我所性。又如渴鹿。于阳焰中。妄生水想。勤苦奔逐。我心行慈。当知亦尔。又如阳焰。水不可得。一切诸法。亦复如是。无有我性。又如梦中见种种物。梦心分别。谓为实事。及至觉时。了无所在。应知诸法皆亦复然。如翳目者。于净空中。见种种物。谓之为有。其人后得阿伽陀药。治眼翳尽。所见之物。悉皆随灭。如是众生。以有身见及边见故。而有我想。若得智慧药。灭除此见。所有我想。亦随止息。是故我应如是修慈。如从梦觉。离我我所。佛子当知。此修慈者。乃至未能离于分别。未能不起我我所见。常得六种梵天之福。若舍分别。离我我所。此则名为广大之慈。先世已来。所有罪障。皆得除灭。不久当证无上菩提。佛子。一切菩萨。皆应如是修习慈心。汝以修慈。名为慈者。佛子。若善男子善女人。有得闻此修慈经者。则能销灭无始时来诸恶业障。离众病厄。为一切人之所爱敬。于其中间。或至临终。必得奉见十方诸佛。及与授阿耨多罗三藐三菩提记。或得三昧。或得法忍。或得入于陀罗尼门。其心安隐。无有死畏。永离一切诸恶道苦。必生清净极乐佛国。佛子。譬如有人。于三界中。盛满七宝。日以三时。奉施如来。尽于一劫。其人功德。应知亦尔。何况有能修习之者。假使无量诸佛如来于一劫中。说其功德。犹不能尽。佛说此经已。弥勒菩萨摩诃萨。及十方国土。诸来梵众。皆大欢喜。信受奉行大方广佛花严经修慈分


大方广佛华严经不思议佛境界分一卷

    No. 300 [No. 301]

    大方广佛华严经不思议佛境界分一卷

        唐于阗三藏提云般若译

如是我闻。一时薄伽梵。在摩揭陀国。于菩提树下。得阿耨多罗三藐三菩提。成等正觉。其菩提树。根深坚固。善植于地。如栴檀柱。树身佣长。傍无枝叶。坚实圆满。名阿湿波他。所有诸鸟。不能飞过。皮肤细软。文象如绫。无量枝条。妙饰间错。其叶表里。素绿庄严。叶脉显现。如绀青色。枝叶垂下。周匝圆满。其花开敷。甚可爱乐。光明照曜。香气芬馥。其根茎等。显种种色。具足众德。如妙高山。其下严饰。如欢喜园。光明香气。一瑜缮那量。夜分远烛。如大火聚。其地四面。普皆平坦。于中。有草柔软滋茂。光色鲜洁。如孔雀毛。有妙香气。令心悦豫。无量小树周匝围绕。其菩提树王庄严胜妙。除波利遮德迦。及毗陀罗树。无以为喻。佛在树下。大众围绕。端严而住。如星中月处净虚空。时有十佛刹极微等诸佛。各各从本国土。来至于此。为欲庄严鞞卢遮那。为众会故。示菩萨形。其名曰观自在菩萨摩诃萨。曼殊室利菩萨。地藏菩萨。虚空藏菩萨。金刚藏菩萨。无垢称菩萨。善成(二本威)德菩萨。能弃诸盖菩萨。宝手菩萨。大慧菩萨。普贤菩萨摩诃萨等。而为上首。如是等众。皆来集会。复有无量千俱胝诸菩萨众。示声闻形。亦皆来集。所谓。舍利弗多罗。苏补底没特伽良演那。罗怙罗。憍陈那。摩诃迦叶波。邬波离阿。阿泥律陀。缬丽缚多。阿难陀。提婆达多。跋难陀。而为上首。一切皆是久习所行六波罗蜜。能近菩提。为欲利益诸众生故。于此杂染佛土。示声闻形。复有无量千苾刍尼。摩诃钵剌阇钵底乔答弥。为上首。为欲调伏下劣有情故。虽现女身。具丈夫业。复有释梵护世。天龙药叉健达婆阿素罗揭路荼紧捺洛莫呼洛伽人非人等一切非凡。皆是菩萨。悉来集会。何以故。以彼诸佛。有秘密法威德神通三摩地神变。云何菩萨。能得了知。乃至诸佛威德神通。有无边力。一切法空。诸力得转。有情云何。能得了知。如人梦中见种种事。若觉悟已即无所见。如梦中想。如是如是。梦愚痴故。法体想起。诸佛觉悟。无有所见。以诸甚深无障碍品。利益有情。微细解脱。得成就故。而彼菩提树下。薄伽梵。端身而住。入三摩地。名不思议佛之境界。此三摩地。极胜广大。由此三摩地故。诸佛世尊。恒常入定。说时食时。行时乃至般涅槃时。如是严饰。佛薄伽梵。如妙高山王。如波利遮德迦树下安如意珠。而彼清净三十二丈夫相中。一切佛刹诸薄伽梵。如净圆镜。普皆示现。一一随好中。菩萨本所行。行皆悉显现。从初光照王因缘。乃至究竟定光如来一一苦行事。所谓。能舍头目。手足身分。妻妾男女。奴婢僮仆。作使大位宫殿等。尔时德藏菩萨摩诃萨。诸所修行未成正觉。请问普贤菩萨言。佛子。如来所住三摩地。为是何等三摩地耶。佛子。云何自然十方佛刹中。度脱有情。佛事示现。佛子。此三摩地。以何为名。尊者。此三摩地。云何证得。是时普贤菩萨。告言。善男子。谛听。我今为汝。宣说斯事。于是诸菩萨。起尊重心。瞻仰尊颜。正念安住。同声说言。善哉善哉。德藏。如汝所问。甚为微妙。然彼尊者能知一切。尔时大地六种震动。所谓。动遍动等遍动。摇遍摇等遍摇。吼遍吼等遍吼。击遍击等遍击。旋遍旋等遍旋。开合上下遍开合上下。当遍开合上下东涌西没。乃至中边。亦复如是。当此之时。一切众生。所有苦恼暂得休息。雨妙天华。尔时普贤菩萨。告德藏菩萨言。佛子。此三摩地。是诸佛菩提。佛子。此三摩地。名不思议佛之境界。诸佛世尊。常住于此。从然灯佛。得授记已。即于是时。入三摩地。从是以来。无功用住。于一毛端处。有无量佛刹。乃至一切佛刹所有极微等。诸佛刹土。普皆示现。或现生于睹史多天。从彼没已。下生入胎。住胎出胎。能行七步。而自唱言。我应永离生老病死。所作已办。或现处宫。或现出家。修行苦行。成等正觉。降伏众魔。转于法轮或现住世。寿无量劫。度脱众生所有苦恼。乃至示现入般涅槃。于一念中。普能示现诸佛刹土。如上事业。于一念中。摄一切劫。无增无减。皆无功用。乃至一切有情界。未得解脱。一一刹那中。于一切处。作诸佛事。是诸佛刹中。毛端际处。示现无量诸佛刹土。如是彼佛。无边威仪。然此威仪。周遍虚空。无有毛端处。而无诸佛刹。亦无毛端处。而不于中念念示现阿耨多罗三藐三菩提。一切诸佛。生现正觉。乃至般涅槃。于极微中。亦皆普现一切佛刹极微等。诸佛刹土复过是数无量无边。彼彼薄伽梵。示现睹史多天宫。佛行行。示现度脱无量众生。佛土不小极微不大。何以故。以一切法不坚牢如幻如阳炎。乃至究竟。尽虚空界。如是无量佛事业起。刹那刹那。于有情所。常作利益。无暂休息。譬如即此大菩萨集会十佛刹土极微等数量于摩揭陀国十二緰缮那地分中安住展转。不相碍。如是如是。于极微中。容受无量阿僧企耶诸佛刹土。有余佛刹。各各相向。或有相背或有在傍。或有相纳如是展转不相障碍。如人梦中于一处所。见种种事。虽见非真实故。不能为碍。如是如是。此诸佛刹。皆唯心量之所变现。或有世界。见劫火烧。或烧已尽。或见风起。或有清净。或有杂染。或现无佛诸刹土中。众生之类。随其自业。各见不同。如是如是。无量变异。譬如饿鬼饥渴所逼。于殑伽河边。或有见水。或有见灰。或见脓血。或见便利。不净充满。如是如是。有情于自佛刹土中。或见杂染。或见清净。或见有佛。或见涅槃。或见大众会中说法。或有听闻第一义法。或闻广说檀波罗蜜。或见游行。或有见住。或有见坐。或见食时。或见二丈夫量。或见七丈夫量。或见一瑜缮那量。或见百瑜缮那量。或见千瑜缮那量。或见光明照曜如日初出。或见如满月圆朗空中。随其业行种种见异。或见久远入般涅槃。或有不闻诸佛名字。譬如饿鬼于河水边有见猛火。或见异事。或见如是。如此大菩萨集会。各各于自佛刹土中。佛薄伽梵。作菩萨形。或见有一佛刹土中。劫波火烧。或烧已尽。或见于此佛刹土中。众生界满。佛现饶益。有薄伽梵。取诸佛刹入一佛土中。令相似示现。如患翳者。翳因缘故。不了众色。如是如是。识因缘故。不了众相。于是普贤菩萨。告德藏言。佛子。我今为汝。略说此三摩地法。一刹那中于一切处。乃至尽虚空及众生界一毛端分量中无量无边佛刹。于一极微中法界极微等诸佛刹土。一一佛刹土。甚多威仪路。如一刹那中为利众生故。有十佛刹土极微等数量。如是念念中。有一切处。乃至一切众生。未得阿耨多罗三藐三菩提。此饶益事。常不断绝。如是威仪。第二第三。第四第五。乃至十方所有诸佛。无量无边。威德势力。亦复如是。尔时德藏菩萨。闻说是已。于此三摩地藏。明了通达入不思议诸佛境界。觉悟一切诸佛世尊神通威力。即于是处。以诸威力。善巧调伏无量众生。有百殑伽沙诸菩萨众。于三摩地法。种种觉悟。或有证忍位。或有证诸地。其中观自在等菩萨摩诃萨。譬如瓶水已满置于雨中。终更不容一渧之水。如是如是。住第十地诸菩萨众。所行妙行皆已圆满。多时于此三摩地中。示现佛事。于一刹那能纳无量劫。于一极微能纳无量土。即于一念遍诸佛刹。任运度脱无量众生。时薄伽梵。住三摩地。放眉间白毫相光。名能发起。其光照曜。有功用行诸菩萨众。于十地中。亦未觉悟。由光触故。能见一切诸佛国土所有住极微毛端分量处。无量佛刹。即于是时。周遍虚空。无量无边。佛刹示现。譬如琉璃瓶满中盛芥子。如是如是。于一极微一分量中见诸佛土佛薄伽梵。于一如来身。一切如来色相显现。一一如来。有无量名号。于一刹那中。一一佛刹土。利益一一有情故。自然示现此阿耨多罗三藐三菩提。如如意珠置高幢上。随诸众生。自然而雨种种珍宝。如是如是。一切如来。阿罗呵三藐三勃陀。无量众生。自然解脱。何以故。以一切趣不坚牢如幻如阳炎。如是此诸佛刹土中。有情展转。不相障碍。如现神通者。山河石壁等。终无限碍。如是诸菩萨。见彼佛威德。自身各各于一切佛刹佛世尊前。于一刹那中一一如来所。一劫波供养。或二劫或三劫。或百劫或千劫。或一刹那。或一牟呼栗多。种种供养。于如来所。闻说波罗蜜多。或闻陀罗尼。或闻说诸地。见诸如来神通变化。以一切劫入一刹那。起难遭之想。云何如来。有此威德。于一念中现无量劫。而为我等生善根故。广演如此诸功德聚无量劫所作不思议佛境界三摩地。觉悟如是威力如是威德。尔时德藏菩萨。问普贤菩萨言。尊者。作何功德。证此三摩地耶。云何修习般若。云何布施。云何持戒。是时普贤菩萨。告言。佛子。于十方处一切清净圆满佛刹诸众生类。其中示现无量佛事。诸菩萨等。积集种种福德善根。应供养佛。供养法。供养僧。孝养父母。常不断绝。一切贫穷困苦。孤独乞丐。菩萨皆应悲哀摄受。乃至自身血肉。随应施与。勿生悭吝。何以故。以供养佛者。其福甚多。如是有情。受胜妙乐。速当证得阿耨多罗三藐三菩提。供养法者生诸善根。智慧增长。当得觉寤法自在故。于一切法。能正了知。供养僧者。种诸善根。而彼无量。资粮增盛。由此菩萨。乃至成佛。所有孝养。父母或尊者邬波柁耶。或余生死中。曾得恩处。当思报恩。倍令增长。何以故。以有情类。知恩报恩者。设于生死造罪业时。彼诸善根。终无散失。故诸如来。常赞报恩。呵责一切不知恩者。云何菩萨。坚固成就一切善根。谓有贫穷孤独等类。于彼增长广大悲愍。以摄事法。而摄受之。有福德者。有知恩者。有悲愍者。菩萨菩提。现前获得此三种田。如来已说诸菩萨等。所作事业。应当觉寤于一一田。种诸善根。广大殊胜。成就圆满

复次德藏。诸菩萨众。应当广大殖诸种子。令其善芽渐渐增长。此三摩地。为菩提主。应先种殖种子于佛前或形像所。华鬘烧香。涂香末香。歌舞音乐。如是等种种供具。而为供养。即应如是思惟。如先所说。于一切处诸佛世尊毛端分量及极微中。无有不见诸佛威德诸菩萨等大众集会。我于彼所。以清净心。平等忆念。而作供养。谓一如来法性。即是一切如来法性。若我供养一如来。即一切如来。皆已供养。于无量劫一一如来所供养亦尔。乃至多劫入一刹那。佛神力故。深生信解。而彼菩萨。殖种子。得成广大不思议佛之境界三摩地。善男子善女人。日日应作如此供养。于一切佛薄伽梵前。乃至一合掌。亦种子增长三摩地芽滋茂广大。应以尸罗智慧妙愿。而灌洒之。又诸菩萨。应如是布施。不得简择持戒破戒。若爱若憎。若贫若富。然彼富者。虽无所须。能施之者。自获利益。应当发起殊胜舍愿。我定当作佛。度脱一切众生。于一一刹那一切处毛端分量中一切佛刹。我别别当成就。乃至一切佛刹极微等一切极微中。尔所刹土。乃至一切佛刹极微。于彼彼中。转正法轮。如今世尊鞞卢遮那如来。于一刹那中能纳一切劫。任运即于一一佛土我当示现无量威仪。如佛刹极微等。一切威仪中。如是有情。解脱诸苦。如殑伽沙乃至尽虚空界及众生界。又诸菩萨应清净持戒。于破戒有情。起悲救护。不应于彼而生厌舍时普贤菩萨。告德藏言。佛子。如汝所问。云何修习般若。汝应谛听。当为汝说。若有乐求无上菩提。欲令证得此三摩地。应当远离虚妄诸业恶语染意。发起净心。大悲摄受。应往精舍中。见甚希奇。微妙佛像安住不动以金薄庄身。或纯金作。诸相具足。支节充满。于圆光中。有无量佛。妙饰间列。结加趺坐。入三摩地。即于像前。恭敬礼拜。应如是思惟。我闻十方现在所有诸佛世尊无边无量。谓一切义成如来。无量寿如来。宝幢如来。阿閦鞞如来。鞞卢遮那如来。宝月如来。宝日如来等。于彼广大。信乐尊重。复应起想。是此如来。深生尊重。乃至自然。现前得见。于一切处。当审观察。如是思惟。往空闲处。心正忆念。随近摄持。极一臂量。专注忆念。无令忘失。若有忘失。应更往观。如是观时。起尊重心。作现佛想。不应于彼作形像想。如是自然面见诸佛。应于彼所。以涂香末香。烧香。花鬘。右绕如是等种种供具。而为供养。由一切心。如是摄持。佛薄伽梵。自然现前。能见一切。能闻一切。一切心等。能了达故。数数决定。而取于相。复往空闲。心念不失。若有福德者。于三七日中。精勤修习。速疾现前。能见诸佛。有于先世所作罪业。如是之人。不能得见。若有希求。应起精进。勇猛修行。决定观察。何以故。由于一境。令心调伏。勉励专精。菩提资粮。无不成办。若多惛沈。懈怠放逸。自然如是。不能解脱。何况解脱一切众生所有苦恼。此如大地真为重担。若如是者。于菩提直道。亦不能作精勤修习。譬如有人于大海中。饮一掬水。即为已饮赡部洲中所有河水。如是如是。若修习菩提海。一切三摩地诸忍诸地诸陀罗尼皆已修习。是故常应精勤勇猛。远离放逸。如是思惟。自然现前。能见诸佛。若已得见。即应如是思惟。此所见者。为是如来。为形像耶。若觉寤此如来现前。即于佛所。长跪合掌。应当忆念。如先所说。诸佛威德。由大威德及大悲故。今于我所。现前来也。若能发问。即应请言。唯愿世尊。为我演说不思议佛之境界大三摩地法。而于其中。勿生疑惑。设有所说。作决定心。若得听闻。即于是处。圆满成就。或先业障不能申请。即应如是。种种观察。一切诸法。如露如翳。如幻如阳焰如镜像。如是诸佛。犹如虚空。平等自性。非幻非梦。然一切法如幻如梦。应当了知。由智慧悲。佛世尊现。今应为我放大悲光。令我苦恼悉皆销灭。复应如是思惟观察微妙空性。尔时世尊。从眉。间白毫相。放大光明。光名青焰照触其顶。所有苦恼皆悉销灭。即于是处得法。名鞞卢遮那忍。种种三摩地。皆能觉寤。于第七日夜。佛薄伽梵。梦中现前。为授阿耨多罗三藐三菩提记。若如是知。此是形像。即应思惟一切如来及一切众生。如见形像。无实可得。如是如是。一切如来。如幻如化。如梦如阳焰。自然如是。面见如来。如梦所见。皆非实有。如是如是。一切如来。非生即生。非灭即灭。异于诸行。法性甚深。非说能说。非去而去。非来而来。非识所识。非我想。非命者想。非有情想。非养育者想。非补特伽想。非食者想。非蕴非不蕴。有似蕴相。十八界十二处毕竟总无。亦非异彼。以一切佛一切诸法。平等平等。皆同一理。如阳焰等。一切众生及诸如来一切佛土。皆不离想。如是想现。识缘于色。自性如是。终无有生。如来灭识。是故异色。观察应知。若一切法。不离于想。即识如来。毛端分量亦无差别。犹如虚空平等平等。若我分别。佛即现前。若无分别。都无所见。想能作佛。离想无有。如是三界。一切诸法。皆不离心。若能了知一切诸佛及一切法性惟心量。得随顺忍。或证欢喜地。舍身他世。速疾生于妙喜世界。或生极乐净佛土中。常见如来。亲承供养

于是德藏菩萨摩诃萨。白普贤菩萨摩诃萨言。佛子。若有众生。闻此法门。受持读诵。书写广说。得几所福。时普贤菩萨。告德藏言。善男子。谛听。此所生福量。譬如有人。摄取三界一切众生。令解脱生死。得阿罗汉果。复于彼所。起净意乐。无热恼心。经于百劫。以衣服饮食。卧具汤药。种种供具。而为供养。彼涅槃已。起七宝塔。恭敬供养。其福甚多。若有众生。闻此法门。生信尊重。亦不毁谤。复经百劫。净修梵行。百劫修忍。百劫精勤。百劫修静虑。所生福聚。无有限量若复有人。闻此法门。生信尊重。能正受持。速得成佛。福过于彼

尔时十方一切佛土中佛薄伽梵。皆现其身。赞普贤菩萨言。善哉善哉。佛子。如是如是。如汝所说。于是释迦牟尼如来。从其面门放无量色光。照曜三界。雨众妙花。如是音乐。不鼓自鸣。出微妙音。令心悦豫。是时大地。微细摇动。从光明中。演出无量妙伽陀曰

  若闻此法心清净　　获诸地定陀罗尼
  及忍自在妙神通　　速证无上菩提果
  当来能转于法轮　　还如过去大仙人
  一刹那中纳多劫　　于一极微现众刹
  无量众生满三界　　其中放逸受诸苦
  恶见系缚失正道　　念念度脱无空过

普贤菩萨。说此法门时。千俱胝天人。所有苦恼。皆得解脱。于阿耨多罗三藐三菩提。得不退转。普贤菩萨摩诃萨。于此法门。已善通达。现前证得。说此经已。时德藏菩萨摩诃萨。及诸菩萨。天人健达婆阿素罗等。一切世间。闻佛所说。皆大欢喜。信受奉行大方广佛华严经不思议佛境界分


大方广佛华严经卷第一(40)

    No. 293 [Fasc. 1-39 = Nos. 278(34), 279(39); Fasc. 40 = Nos. 278(31),279(36), 296, 297]

大方广佛华严经卷第一

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

如是我闻。一时佛在室罗筏城。逝多林。给孤独园。大庄严重阁。与菩萨摩诃萨五千人俱。普贤菩萨摩诃萨。文殊师利菩萨摩诃萨。而为上首。其名曰智慧胜智菩萨。普贤胜智菩萨。无著胜智菩萨。华胜智菩萨。日胜智菩萨。月胜智菩萨。无垢胜智菩萨。金刚胜智菩萨。无尘劳胜智菩萨。毗卢遮那胜智菩萨。星宿幢菩萨。须弥幢菩萨。宝胜幢菩萨。无碍幢菩萨。华幢菩萨。无垢幢菩萨。日幢菩萨。妙幢菩萨。离尘幢菩萨。毗卢遮那幢菩萨。地威德光菩萨。宝威德光菩萨。大威光菩萨。金刚智光菩萨。无垢光菩萨。法日光菩萨。福山光菩萨。智焰光菩萨。普贤吉祥光菩萨。普贤焰光菩萨。地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。净德藏菩萨。法海藏菩萨。毗卢遮那藏菩萨。脐藏菩萨。莲华吉祥藏菩萨。妙眼菩萨。清净眼菩萨。无垢眼菩萨。无著眼菩萨。普见眼菩萨。妙观眼菩萨。青莲华眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。普眼菩萨。天冠菩萨。遍照法界摩尼智冠菩萨。道场冠菩萨。光明遍照十方冠菩萨。诸佛所赞冠菩萨。超诸世间冠菩萨。光明普照冠菩萨。无能胜冠菩萨。持诸如来师子座冠菩萨。大光普照法界虚空冠菩萨。梵王髻菩萨。释主髻菩萨。一切诸佛变化差别光明髻菩萨。真实菩提场髻菩萨。一切愿海声摩尼王髻菩萨。出生大舍诸佛圆光摩尼王髻菩萨。现等虚空界一切宝盖摩尼王髻菩萨。现一切佛神通光幢网垂覆摩尼王髻菩萨。出一切佛大法轮声髻菩萨。大福圆满名字音声髻菩萨。大焰光菩萨。无垢焰光菩萨。离垢威德焰光菩萨。宝焰光菩萨。星宿焰光菩萨。法焰光菩萨。寂焰光菩萨。日焰光菩萨。神通焰光菩萨。天焰光菩萨。福聚菩萨。智聚菩萨。法聚菩萨。神通聚菩萨。光焰聚菩萨。华聚菩萨。菩提聚菩萨。梵聚菩萨。一切众生光聚菩萨。摩尼宝聚菩萨。梵声菩萨。大海声菩萨。大地吼声菩萨。世主声菩萨。山王自在声菩萨。遍满一切法界声菩萨。一切法海潮声菩萨。摧破一切魔力声菩萨。大悲云雷教声菩萨。速疾救护一切世间苦恼声菩萨。法出生菩萨。胜出生菩萨。智出生菩萨。福德须弥出生菩萨。最胜功德宝王出生菩萨。名称出生菩萨。普贤光出生菩萨。大悲出生菩萨。智聚出生菩萨。如来种姓出生菩萨。光吉祥菩萨。最胜吉祥菩萨。正勇出生吉祥菩萨。毗卢遮那吉祥菩萨。莲华吉祥菩萨。月吉祥菩萨。虚空吉祥菩萨。宝吉祥菩萨。积吉祥菩萨。智慧吉祥菩萨。山自在王菩萨。法自在王菩萨。世自在王菩萨。梵自在王菩萨。数自在王菩萨。龙自在王菩萨。寂静自在王菩萨。不动自在王菩萨。威力自在王菩萨。最胜自在王菩萨。最寂音菩萨。无等音菩萨。地震音菩萨。大海潮音菩萨。大云雷音菩萨。法光音菩萨。虚空音菩萨。一切众生广大善根音菩萨。演昔大愿音菩萨。降魔王众音菩萨。宝觉菩萨。须弥觉菩萨。虚空觉菩萨。无垢觉菩萨。无著觉菩萨。广大觉菩萨。开敷觉菩萨。普照三世觉菩萨。广严觉菩萨。普观觉菩萨。法界光明觉菩萨。如是等上首菩萨摩诃萨。一切皆从普贤菩萨。行愿所生。所行无碍。普遍一切诸佛刹故。现身无量。亲近一切诸如来故。离诸盖障。如净月轮。普现一切佛神变故。得现觉智。悉见诸佛所现自在神通境故。得无量明。照一切佛大法教海智慧光故。具无碍解。以清净辩。于无量劫。说佛功德。无穷尽故。住最胜智。犹若虚空。所行清净。无染着故。无所依止。随诸众生心之所乐。现色身故。离诸翳障。了知众生我人寿者。皆非有故。智慧普遍。犹如虚空。以大光网。照法界故

复与五百声闻众俱。其诸声闻。有大威德。悉觉真谛。皆证实际。深入法性。永出有海。依于如来虚空境界。离结使缚。不着依处。其心寂静。犹如虚空。于诸佛所。永断疑惑。于佛智海。深信趣入

复与无量诸世主俱。已曾供养无量诸佛。常勤利乐一切众生。与诸众生。为不请友。常勤守护无归向者。不舍世间。入殊胜智。从诸佛教境界而生。护持如来所有正法。起大誓愿。不断佛种。从行愿力。生如来家。专求如来一切智智

时诸菩萨。及大声闻。世间诸王。并其眷属。咸作是念。如来境界。如来智行。如来神通。如来力。如来无畏。如来三昧。如来所住。如来最胜。如来身。如来智。一切世间诸天及人。无能通达。无能趣入。无能信解。无能遍知。无能分别。无能思惟。无能观察。无能拣择。无能开示。无有能令众生悟入。唯除诸佛加被之力。佛神通力。佛威德力。佛本愿力。及自宿世善根之力。亲近善友力。深净信解力。广大志乐力。趣向菩提清净心力。求一切智广大行愿力。唯愿世尊。以方便力。随顺我等。及诸众生。种种心量。种种信解。种种智慧。种种言辞。种种名字。种种证得。种种地位。种种根清净。种种意方便。种种心境界。种种依止。如来功德。随能听受。诸所说法。显示如来往昔趣求一切智道。往昔所起菩萨大愿。往昔所净诸波罗蜜。往昔所证诸菩萨地。往昔圆满诸菩萨行。往昔所乘智庄严道。往昔所行诸清净道。往昔出离殊胜法海。往昔所起游戏神通大庄严海。往昔所集无量本事相应行海。及遍显示如来现前成正觉门神通智海。如来自在转法轮海。如来神通净佛刹海。如来调伏一切众生巧方便海。如来开示一切智城。如来显示诸众生道。如来善入一切众生生死之处。如来普为一切众生最上福田。如来普为一切众生说施功德。如来所记一切众生种种心行。如来普为一切众生演说教诫。如来能以三昧神通。现众影像。如是等法。唯垂大悲。普为开演

尔时世尊。知诸菩萨一切大众心之所念。大悲为身。大悲为门。大悲为首。以大悲法。而为方便。充满虚空。遍周法界。入于师子频申三昧。入三昧已。一切世间。普皆严净。于时此大庄严楼阁。忽然之间。高广严丽。遍周法界。金刚为地。众宝严饰。如意宝网。无能胜幢。列布其中。无数宝华。及众摩尼。普散其上。一切宝聚。处处盈满。毗琉璃宝。以为其柱。光明照世。摩尼宝王。以用庄严。阎浮檀金。及诸摩尼。周遍严饰。一切众宝。门闼窗牖。含辉交映。相望间列。阶墀轩槛。一切皆以妙宝庄严。奇形异像。如诸世主。一切众生种种相海。摩尼宝网以覆其上。于诸门侧悉建幢幡。一一严事。各各流光。遍周法界。于楼阁外。阶砌栏楯。其数无量。不可称说。靡不咸以摩尼所成。众杂妙宝。周遍校饰。尔时复以佛神力故。令逝多林忽然广博。与不可说佛刹。极微尘数诸佛世界。其量正等。一切妙宝。间错庄严。以不可说宝。庄严其地。无数摩尼宝。以为垣墙。宝多罗树庄严。行列其间。复有无量香河。香水盈满。湍激洄澓。一切宝华。随流右转。演出一切佛法音声。不思议宝。芬陀利华。菡萏芬敷。一切妙宝。波头摩华。鲜荣布濩。不思议数妙宝华树。高显荣茂。列植其岸。不思议数种种杂宝。台榭楼观。于其岸上。次第行列。摩尼宝网之所弥覆。阿僧祇摩尼宝。放大光明。阿僧祇众杂妙宝。庄严其地。蕴众香藏。腾出香云。香气氛氲。普熏法界。复建无量种种宝幢。所谓无量宝香幢。无量宝衣幢。无量宝幡幢。无量宝缯幢。无量宝华幢。无量宝璎珞幢。无量宝鬘幢。无量宝铃幢。无量威德宝网幢。无量摩尼宝王伞盖幢。无量光明普照摩尼王幢。无量出一切如来名号圆满音声摩尼王幢。无量师子游步摩尼王幢。无量说一切如来本事相应行海摩尼王幢。无量普现法界差别影像摩尼王幢。如是一切诸妙宝幢。周遍十方。处处严饰。尔时逝多林上虚空之中。有不思议天宝宫殿诸楼阁云。复有无数香树云。不可说须弥山云。不可说妓乐云。出美妙音。歌赞如来。不可说宝莲华云。遍覆庄严。不可说宝师子座云。敷以天衣。菩萨坐上。叹佛功德。不可说天王形像摩尼宝云。不可说白真珠云。不可说赤真珠宝楼阁云。遍覆庄严。不可说一切坚固金刚珠云。雨庄严具。如是一切宝庄严云。皆悉尽于虚空法界。周遍严饰。何以故。如来所种清净善根。不思议故。如来所成白净法聚。不思议故。如来威力。秘密加持。不思议故。如来神变。能以一身。普遍一切诸佛世界。不思议故。如来能以神力。普令十方一切诸佛。及佛国土。皆入其身。不思议故。如来能于一极微尘中。普现一切差别世界。不思议故。如来能于一一毛端。现过去际一切诸佛。出兴次第。不思议故。如来能于一一毛孔。放大光明。一一光明。悉能显照一切世界。不思议故。如来能于一一毛孔。出一切佛刹极微尘数变化云。充满一切诸佛刹土。不思议故。如来能于一一毛孔。普现十方一切世界成住坏劫。不思议故。如于此逝多林给孤独园。见佛国土清净庄严。如是十方尽法界虚空界。一切世界。亦如是见。所谓见如来身遍逝多林。菩萨众会。各各圆满。见普雨一切庄严具云庄严建立。见普雨一切宝威力光明云。照曜法界。见普雨一切摩尼宝云。周遍庄严。见普雨一切庄严盖云。覆一切刹。见普雨一切天身变化云。皆妙严饰。见普雨一切华树云。其华开敷犹如海藏。见普雨一切缯彩云。盘旋宛转。见普雨一切衣服云。缤纷而下。见普雨一切华鬘璎珞云。相续不绝。见普雨一切烧香云。其形旋转如众生身。见普雨一切妙宝华网云。周遍庄严相续不断。见普雨一切末香云香气周流弥布十方。见普雨一切众宝幢幡云。天女执持周旋空界。见普雨一切宝盖云。其盖周圆众宝所成。微妙莲华庄严其上。流出乐音声闻法界。见普雨一切宝师子座云。如诸众生所有形像。杂宝鬘网璎珞庄严

尔时毗卢遮那如来。住此师子频申三昧。即时东方过不可说佛刹极微尘数世界海外。有世界海。名金沙灯云幢。佛号毗卢遮那吉祥威德王。于彼如来大众海中。有菩萨摩诃萨。名毗卢遮那焰愿藏光明。与不可说佛刹。极微尘数诸菩萨俱。受彼佛教。从彼佛土道场众海。而来向此娑婆世界毗卢遮那佛所。悉以神力。出兴种种诸供养云。所谓天华云。天香云。天宝莲华云。天鬘云。天宝云。天璎珞环钏云。天宝盖云。天妙衣云。天宝幢幡云。天一切妙宝庄严具云。皆悉充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于东方。化作宝庄严楼阁。摩尼宝网弥覆其上。于楼阁中。化作光照十方摩尼宝王大莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以大如意摩尼宝网。罗覆其身。南方过不可说佛刹极微尘数世界海外。有世界海。名金刚海藏。佛号普光遍照吉祥藏王。于彼如来大众海中。有菩萨摩诃萨。名难摧伏速疾精进王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。赍持种种微妙宝鬘。诸供养具交络庄严。所谓持一切妙宝香华鬘。持一切妙宝轮网鬘。持一切宝华璎珞鬘。持一切金刚宝璎珞鬘。持一切摩尼宝网鬘。持一切诸宝缯彩鬘。持一切宝形像璎珞鬘。持一切出现吉祥光摩尼宝璎珞鬘。持一切毗卢遮那摩尼庄严宝网鬘。持一切师子游步摩尼宝璎珞网鬘。悉以神力。充满一切诸世界海。既至佛所。顶礼佛足。以为供养。修敬毕已。即于南方。化作毗卢遮那众宝庄严胜妙楼阁。摩尼宝网。弥覆其上。于楼阁中。化作普照十方摩尼宝莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以天拘苏摩妙宝华网。罗覆其身。西方过不可说佛刹极微尘数世界海外。有世界海。名须弥山幢毗卢遮那摩尼宝灯。佛号法界智灯王。于彼如来大众海中。有菩萨摩诃萨。名普遍出生吉祥威德王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。出兴种种须弥山云。所谓不可说佛刹极微尘数种种色幢须弥山云。不可说佛刹极微尘数种种色涂香烧香末香须弥山云。不可说佛刹极微尘数种种色金光庄严摩尼宝王众妙资具须弥山云。不可说佛刹极微尘数种种焰光圆满庄严星宿幢须弥山云。不可说佛刹极微尘数种种妙色金刚月藏摩尼宝王庄严境界须弥山云。不可说佛刹极微尘数种种光明普照法界阎浮檀金摩尼王幢须弥山云。不可说佛刹极微尘数种种法界差别光明普照一切摩尼王幢须弥山云。不可说佛刹极微尘数一切如来差别相好摩尼宝王须弥山云。不可说佛刹极微尘数一切如来本所修行诸菩萨行本事因缘相应行海微妙音声摩尼王幢须弥山云。不可说佛刹极微尘数一切如来遍坐道场摩尼宝王须弥山云。一一充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于西方。化作一切香王楼阁真珠宝网。弥覆其上。于楼阁中。化作种种因陀罗差别光幢摩尼宝王妙莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。冠以如意摩尼宝冠。以妙色差别摩尼珠网。罗覆其身。北方过不可说佛刹极微尘数世界海外。有世界海。名宝衣光焰幢。佛号吉祥大光明遍照一切虚空法界。于彼如来大众海中。有菩萨摩诃萨。名无碍吉祥胜藏王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。出兴一切妙宝衣云。周遍庄严。尽虚空界。所谓黄色光明摩尼宝王衣云。种种香熏摩尼宝王衣云。净妙日幢摩尼宝王衣云。金焰炽盛吉祥光照摩尼宝王衣云。杂宝流光摩尼宝王衣云。一切上妙星宿形像摩尼宝王衣云。白玉光焰因陀罗网摩尼宝王衣云。毗卢遮那殊胜赫奕吉祥光焰摩尼宝王衣云。光照诸境能令十方一切法界皆出光明互相涉入毗卢遮那摩尼宝王衣云。大海庄严摩尼宝王衣云。如是等云。一一充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于北方。化作大海出生摩尼宝王楼阁。及毗琉璃宝胜莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以星宿幢妙庄严藏摩尼宝王。为髻明珠。以师子游步妙威德王摩尼宝网。罗覆其身。东北方过不可说佛刹极微尘数世界海外。有世界海。名一切大地王。佛号放宝光网遍照法界无相眼。于彼如来大众海中。有菩萨摩诃萨。名妙变化遍法界愿月王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。化作种种妙宝严饰诸楼阁云。所谓现一切宝幢楼阁云。现一切香王楼阁云。现一切烧香楼阁云。现一切白栴檀香楼阁云。现一切拘苏摩花楼阁云。现一切摩尼宝王楼阁云。现一切金刚宝王楼阁云。现一切阎浮檀金楼阁云。现一切缯彩衣服楼阁云。现一切众妙莲华楼阁云。如是等云。一一弥覆。虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于东北方。化作一切法界门妙宝山峰摩尼宝王楼阁。及无比香王摩尼宝莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。冠以种种杂色摩尼宝王妙庄严。冠以拘苏摩华如意宝网。罗覆其身。东南方过不可说佛刹极微尘数世界海外。有世界海。名香云庄严幢。佛号龙自在王。于彼如来大众海中。有菩萨摩诃萨。名法慧光明威德王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。出兴种种上妙宝色圆满光明云。所谓金色幢圆满光明云。无量宝色圆满光明云。如来顶髻色圆满光明云。如来眉间毫相色圆满光明云。种种宝色圆满光明云。莲华藏色圆满光明云。宝树垂枝色圆满光明云。摩尼宝王色圆满光明云。阎浮檀金色圆满光明云。日月星宿色圆满光明云。如是等云。一一充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于东南方。化作离垢摩尼拘苏摩华毗卢遮那吉祥摩尼宝王楼阁。及金刚摩尼宝莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以众宝光焰摩尼王网。罗覆其身。西南方过不可说佛刹极微尘数世界海外。有世界海。名日藏光明摩尼宝王。佛号普智光照法月王。于彼如来大众海中。有菩萨摩诃萨。名摧碎一切魔力智幢王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。于一切毛孔。出等虚空界种种焰云。所谓拘苏摩华宝焰云。种种音乐宝焰云。一切色宝焰云。金刚宝焰云。种种香熏众宝衣焰云。如龙电光宝焰云。毗卢遮那摩尼宝焰云。腾辉摩尼宝焰云。吉祥炽盛光藏摩尼宝焰云。等三世如来普光教海摩尼宝焰云。如是等云。一一皆从毛孔中出。遍虚空界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于西南方。化作一念普现十方法界种种光明摩尼宝王楼阁。及香焰灯光摩尼宝王胜莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以离垢藏摩尼宝王妙光明网。罗覆其身。西北方过不可说佛刹极微尘数世界海外。有世界海。名毗卢遮那愿藏。佛号普光遍照须弥山王。于彼如来大众海中。有菩萨摩诃萨。名毗卢遮那愿智星宿幢。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。于念念中。各于其身。一切相好。一切肢分。一切毛孔。一一皆出三世一切诸影像云。所谓出一切如来影像云。出一切菩萨影像云。出一切如来众会影像云。出一切如来变化轮影像云。出一切如来本事海相应身影像云。出一切声闻辟支佛影像云。出一切如来菩提树种种光色影像云。出一切如来神通影像云。出一切世主身影像云。出一切清净佛刹影像云。念念出生如是等云。一一充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于西北方。化作普照十方毗卢遮那摩尼宝王庄严藏楼阁。及光明遍照一切世间摩尼宝王大莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。冠以普焰光明摩尼宝冠。以无能胜光明真珠网。罗覆其身

大方广佛华严经卷第一大方广佛华严经卷第二

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时下方过。不可说佛刹极微尘数世界海外。有世界海。名一切如来圆满普焰光。佛号无著智星宿幢王。于彼如来大众海中。有菩萨摩诃萨。名破诸盖障勇猛智自在王。与不可说世界海极微尘数诸菩萨俱。从彼佛会。向如来所。悉以神力。于其身上一一毛孔。出演说种种法海妙音声云。所谓出演说一切法义众生语言陀罗尼海音声云。出演说一切三世菩萨修行方便海音声云。出演说一切菩萨誓愿方便海音声云。出演说一切菩萨圆满清净波罗蜜海音声云。出演说一切菩萨遍一切刹圆满行海音声云。出演说一切菩萨成满种种神通轮海音声云。出演说一切如来往诣道场破魔军众销竭烦恼成等正觉神通轮海音声云。出演说一切如来转妙法轮种种名句修多罗海音声云。出演说一切如来随应教化调伏众生方便行海音声云。出演说一切如来随时随善根随其愿力普令获得一切智智善巧方便。海音声云。如是等云。一一充满虚空法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于下方。化作现一切如来。宫殿光明。种种色。藏宝楼阁。及一切妙形像宝莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以普现一切菩提场影像光幢摩尼王冠。以严其身。上方过不可说佛刹极微尘数世界海外。有世界海。名无尽佛种性。佛号普智圆满差别光明大声王。于彼如来大众海中。有菩萨摩诃萨。名普遍法界大愿际。与不可说世界海极微尘数诸菩萨俱。受彼佛教。发彼道场。而来向此娑婆世界毗卢遮那如来所。悉以神力。各于其身。一切相好。一切身分。一切肢节。一切毛孔。一切言音。一切名句。一切衣服。一切庄严具中。现毗卢遮那等。尽过去际一切诸佛。尽未来际一切诸佛。尽现在际一切诸佛。并其众会。十方刹土。清净杂染。广狭大小。靡不皆现。亦现彼佛过去所行。檀那波罗蜜。随顺积集。一切施行。受者财物。本事影像。相应行海。亦现彼佛过去所行。尸罗波罗蜜。随顺积集。本事影像。相应行海。亦现彼佛过去所行。羼提波罗蜜。断截肢体。心无动乱。随顺积集。本事影像。相应行海。亦现彼佛过去所行。毗梨耶波罗蜜。勇猛不退。随顺积集。本事影像。相应行海。亦现彼佛过去所求。一切如来。禅那波罗蜜。随顺积集。而得成就。本事影像。相应行海。亦现彼佛过去所求。般若波罗蜜。一切如来所转法轮。所成就法。发勇猛心。一切皆舍。本事影像。相应行海。亦现彼佛过去所成。方便波罗蜜。乐见一切佛。乐行一切菩萨道。乐化一切众生界。本事影像。相应行海。亦现彼佛过去所发。愿波罗蜜一切菩萨。广大誓愿。清净庄严。本事影像。相应行海。亦现彼佛过去所成。一切菩萨。力波罗蜜。了种种行。清净和合。本事影像。相应行海。亦现彼佛过去所修。一切菩萨。智波罗蜜。圆满清净。种种差别。证悟法门。本事影像。相应行海。如是所现一切如来本事影像。相应行海。悉皆遍满广大法界。既至佛所。顶礼佛足。以为供养。修敬毕已。即于上方。化作一切金刚宝王种种庄严藏楼阁。及帝青金刚宝王莲华藏师子之座。诸菩萨众。各于其上。结跏趺坐。以演说三世如来名号。大音声海摩尼宝王。为髻明珠。庄严宝冠。以一切妙宝光焰炽盛。摩尼王网。罗覆其身。如是十方一切菩萨。各以种种神通。兴种种供养云。来会道场普周法界。此诸菩萨。并其眷属。皆从普贤行愿所生。以净智眼。普见三世一切诸佛众所乐见种种相海。得无碍耳。普闻十方一切如来所转法轮修多罗海。已得至于一切菩萨最胜自在究竟彼岸。于念念中。现大神变。能遍亲近十方诸佛。一身充满一切世界。普现诸佛道场众会。光明遍照一切世界。于一尘中。普现十方尽虚空界。一切世界。于彼世界现种种身。随诸众生应受化者。调伏成熟未曾失时。一切毛孔出大音声。周闻十方。演畅如来妙法轮云广大境界。知诸众生悉皆如幻。知诸如来悉皆如影。知诸界趣业行受生悉皆如梦。知诸世间所现果报如镜中像。知诸世间诸有生起如热时焰。知诸国土依心想住皆如变化。通达如来十种智力。威德自在。如大牛王。得无所畏能师子吼。深入无尽辩才大海。了知众生诸秘密海。深入文字语言智海。了达法界犹如虚空。得诸菩萨神通智慧。威力勇健摧伏魔军。智力明彻了达三世。知一切法无有违诤。而常趣求一切智地。以无断智入诸世间。以法界智流出教海。得神通力。能令十方一切世界。展转相入。得善根力。于诸世界自在受生。得周遍眼。普见十方一切世界广狭大小。得无碍智。于微细境现广大刹。于广大境现微细刹。以自在力。于一佛所。得一切佛功德智慧。威神所加。普见十方。无有疑惑。于一念顷。能以神通。普遍十方一切刹海。具足如是无量功德。诸大菩萨。满逝多林。皆是如来威神之力

于时上首诸大声闻。大智舍利弗。神通目揵连。摩诃迦叶。离婆多。须菩提。阿[少/兔]楼驮。难陀。劫宾那。迦旃延。富楼那弥多罗尼子等。在逝多林。皆悉不见如来神力。如来严好。如来境界。如来游戏。如来神变。如来尊胜。如来妙行。如来威德。如来加持。如来刹海。亦复不见。不可思议。菩萨境界。菩萨集会。菩萨遍入。菩萨亲近。菩萨神通。菩萨游戏。菩萨眷属。菩萨方处。菩萨师子座。菩萨宫殿。菩萨威仪。菩萨三昧。菩萨周遍观察。菩萨师子频申。菩萨勇猛。菩萨供养。菩萨授记。菩萨成熟。菩萨身业清净。菩萨智身圆满。菩萨愿身显示。菩萨色身普遍。菩萨相好具足。菩萨常光圆满。菩萨放大光网。菩萨起变化云。菩萨普遍方网。菩萨诸行圆满。如是种种。皆悉不见。何以故。以善根不同故。彼于过去。本不修集见一切佛种种神通妙善根故。本不赞说十方刹海普遍庄严净功德故。本不称叹诸佛世尊种种神通变化事故。本不能于生死之中发阿耨多罗三藐三菩提心故。本不劝发一切众生令住广大菩提心故。本不能令如来种性不断绝故。本不精勤摄受一切诸众生故。本不勤修一切菩萨波罗蜜故。本于生死不劝众生求智眼故。本不修习顺一切智诸善根故。本不觉了如来出世胜善根故。本不获得普遍严净一切佛刹神通智故。本不获得菩萨所知广大境界清净眼故。本不欣求超出世间究竟不共大善根故。本不发起一切菩萨广大誓愿出离智故。本不从于一切如来威力加持之所生故。本不能知一切诸法皆如幻故。本不能知菩萨所知思想执持皆如梦故。本不能得菩萨勇猛广大志乐深欢喜故。如是种种。皆是普贤智眼境界。不与一切二乘所共。以是因缘。彼诸上首大德声闻。不能闻。不能信。不能知。不能见。不能忆念。不能观察。不能筹量。不能思惟。不能证入。不能分别。何以故。诸佛菩萨神通境界。非诸二乘狭劣境故。是故虽在逝多林中。不见如来广大神变。复次彼诸声闻。无如是菩萨所修最胜善根故。无如是见佛神通清净智眼故。无如是甚深三昧微细观察故。无如是广大神力所加持故。无如是不可思议解脱门故。无如是神通自在故。无如是广大势力故。无如是广大威德故。无如是最胜住处故。无如是智眼所行境故。是故于此。不能知。不能见。不能入。不能得。不能遍解。不能出生。不能观察。不能忍受。不能修行。不能安住。不能开示。亦复不能广为人说。不能赞叹。不能指示。不能授与。不能摄取。不能劝进。不能教诲令其修习令其安住令其证入诸佛境界。何以故。彼诸声闻。无有如是大智慧故。依声闻乘。而出离故。入声闻道。得智慧故。修声闻行。求满足故。住声闻果。为究竟故。悟解声闻实谛智故。住于差别真实际故。乐住寂静。为涅槃故。于诸世间。舍大悲故。远离救护诸众生故。恒住自事。趣寂灭故。是故虽在逝多林中。不见如是种种神变。何以故。本于如来一切智性。不能志求。不能积集。不能乐欲。不能出生。不能修习。不能清净。亦于如来三昧神通。不能入。不能行。不能知见。不能证得。何以故。如是境界。唯诸菩萨广大智眼。乃能见知。非诸声闻所行境故。以是因缘。诸大声闻。虽复住在逝多林中。不见如来种种神变。种种加持。种种佛刹。种种严净。及大菩萨。普遍众会。游戏神通。皆悉不见。譬如恒河。两岸。多有百千亿无量饿鬼。裸露饥渴。羸瘦憔悴。皮肉筋骨。内外焦然。风飘日曝。遍体干枯。乌鹫豺狼。诸恶禽兽。竞来搏撮。为渴所逼。欲求水饮。虽住河侧。而不见河。设有见者。见其枯涸。或见流火。或见煻煨。何以故。深厚业障之所覆故。诸大声闻。亦复如是。虽复住在逝多林中。不见如来广大神变。何以故。不乐种智。无明翳瞙。蔽其眼故。不曾种植一切智地。胜善根故。譬如有人于众会中假寐昏寝。忽然梦见须弥山顶帝释所住善见宫城。殊胜宝殿。园苑庄严。天子天女。百千万亿柔软宝地。普散天华。种种衣树。出妙衣服。种种华树。开敷妙华。诸珍宝树。出诸珍宝。诸庄严树。出诸严具。诸音乐树。奏天音乐。无量诸天。于中游戏。其人自见。着天衣服。住止周旋。受诸快乐。其众会中。一切人众。虽同一处。不见不知。不能观察。何以故。此人梦中。所见境界。非彼众会所能见故。一切菩萨。及诸世主。现前所见。广大庄严。神通变化。亦复如是。以得一切佛加持故。以久积集善根力故。发一切智广大愿故。修习如来胜功德故。善住菩萨庄严道故。圆满一切种智门故。成就普贤诸行愿故。趣入菩萨一切智地清净解故。游戏菩萨一切三昧神通海故。观察菩萨一切境界智无碍故。是故。悉见如来世尊不可思议自在游戏神通境界。能入能知。一切声闻。诸大弟子。虽有智慧具胜神通。皆不能见。皆不能知。何以故。以无菩萨清净眼故。譬如雪山多诸药草。犹如种植处处出生。有大良医成就明智。知诸药性差别功能。随病所须。于中采取。其诸捕猎放牧之人。游止其中。不见不知。况能采取。此亦如是。以诸菩萨普入如来智慧境界。出生菩萨种种游戏。能了如来三昧境界。诸大弟子。本不修习一切种智。不能利乐一切众生。虽复住在逝多林中。不见不知如来三昧广大神变。譬如大地。众宝所依。多诸伏藏。百千万亿。珍奇杂宝。处处盈满。一一庄严。无不备足。有一丈夫。聪慧明达。善知宝藏所在之处。及知众宝功能势力。其人复有大福德力。能随所欲。自在而取。奉养父母。赈给宗亲。老病穷乏。靡不均赡。诸有所求。咸令充足。其余无福无智慧人。虽于宝处行住坐卧。以无智故。不见不知。此亦如是。诸大菩萨。以有清净普遍智眼。于逝多林。能入如来不可思议甚深境界。能见诸佛广大神变。能了诸佛一切法门。能入无边佛三昧海。能勤供事一切如来。能以胜法开悟众生。能以四摄摄受群品。彼诸声闻虽住林中。不能得见如来神力。亦复不见菩萨众会。譬如有人。以缯蔽目。至大宝洲。行住坐卧。不能得见宝树宝衣宝香宝果众宝形色贵贱功能。复有一人。开目至彼。一切皆见。悉能了知。诸菩萨等。亦复如是。至于如来大法宝洲最胜功德庄严之处。悉皆明见。诸大弟子。虽在林中亲近世尊。不见如来自在神变三昧境界。亦不得见普遍庄严菩萨众会。何以故。以诸声闻与佛智慧。不相应故。无明覆障蔽其眼故。无诸菩萨无碍智故。不能次第入法界故。以是因缘。不见如来自在三昧差别神变。譬如有药。名无垢光。若复有人。用涂其眼。眼得清净。一切闇色。不能为障。其人有时。处于夜闇。无量百千人众之内。悉见彼众形相威仪行住坐卧。此人所有。威仪形相。进退往来。彼诸人众。皆不能睹。此亦如是。彼诸菩萨。成就如来清净智眼。悉能明见一切世间。无有障碍。其所显示三昧神通。广大境界。大菩萨众。所共围绕。诸大声闻。悉不能见。譬如比丘于众会中。入遍处定。所谓地遍处定。水遍处定。火遍处定。风遍处定。青遍处定。黄遍处定。赤遍处定。白遍处定。天遍处定。种种众生身遍处定。一切音声语言遍处定。一切所缘遍处定。入此定者。见其所缘地水等相光明周遍。乃至一切所缘定境。其余大众。悉不能见。唯除有住此三昧者。此亦如是。如来所现。不可思议三昧神通广大境界。一切菩萨能入能知。一切二乘不知不见。譬如有人得翳形药。用以涂眼身则隐蔽。于众会中。行住往来。无能见者。而能悉睹众会中事。应知如来亦复如是。成就智眼。超出世间。普见世间。无有障碍。所现三昧神通境界。非诸声闻之所能知。唯除趣向一切智境。诸大菩萨乃能得见。譬如世人初始生时。则有二天。同时而生。一曰同生。二曰同名。彼天与人。恒相随逐。天常见人。人不见天。如来亦尔。住不思议一切智智广大三昧神通境界。诸大菩萨。众会庄严。彼诸声闻。悉不能见。譬如比丘得心自在入灭尽定。想受皆灭。六根作业。皆悉不行。亦非涅槃。世变迁流。不知不觉。何以故。由此定力所加持故。彼大声闻。亦复如是。虽复住在逝多林中。具足六根。而于如来自在神变广大境界。不见不知。不解不入。亦复不见菩萨众会三昧神通。何以故。如来境界。微细甚深。秘密广大。难见难知。难量难测。超过一切世出世间。不可思议。无能坏者。非诸声闻及辟支佛所知境故。是故如来自在神力。所现境界。不可思议。眷属庄严。菩萨众会。及逝多林。普遍一切无量阿僧祇清净世界。如是等事。一切二乘悉不能见。何以故。以非菩萨广大器故

尔时东方毗卢遮那焰愿藏光明菩萨摩诃萨。承佛威力。观察十方。而说偈言

  汝等观佛智　　微妙难思议
  于此逝多林　　神变无能胜
  大觉威神力　　显现无数行
  迷惑诸世间　　不解佛深法
  甚深法王法　　无量难思议
  所现诸神通　　举世无能测
  诸佛所现相　　称扬不可尽
  虽以相严身　　所现皆无相
  佛种种神变　　显现逝多林
  所现皆甚深　　言辞莫能及
  不思议亿刹　　具德诸菩萨
  众会广庄严　　奉佛故云集
  大愿悉皆满　　威仪无所著
  难思心境界　　举世莫能知
  利智辟支佛　　及彼大声闻
  皆悉不能知　　菩萨行境界
  菩萨智甚深　　最胜难超越
  建立精进幢　　一切无能动
  已入无量定　　已得大名称
  显现大神通　　遍周于法界

尔时南方难摧伏速疾精进王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  汝观诸佛子　　妙智功德藏
  能集菩提行　　安乐诸世间
  三昧妙威神　　智慧无边际
  彼心及境界　　一切皆甚深
  今此逝多林　　正遍知住处
  菩萨众云集　　普现大庄严
  汝观无所著　　菩萨大众海
  各坐莲华座　　安处于道场
  无去亦无来　　无依无所著
  究竟离分别　　普现于十方
  勇猛大智幢　　坚固无能动
  能于无相海　　现相满尘方
  十方诸亿刹　　一切诸佛所
  普诣不分身　　悉离有无相
  汝观释师子　　种种力神通
  能令大威德　　菩萨皆云集
  法界无分别　　诸佛身亦然
  世间唯假名　　佛子咸通达
  诸佛住真实　　寂灭平等际
  常转差别轮　　无动无分别

尔时西方。普遍出生吉祥威德王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  汝观无上士　　广大智圆满
  不择时非时　　演法恒无尽
  能摧诸外道　　种种差别见
  普随众生心　　为现神通力
  正觉非有量　　亦复非无量
  若量若非量　　牟尼悉超越
  如日处虚空　　光明恒遍照
  佛智亦如是　　能除三世暗
  譬如净满月　　一切皆乐见
  佛德圆满时　　见者咸欣悦
  譬如空中日　　周行无暂已
  诸佛现神通　　相续恒无尽
  譬如十方空　　不碍于诸刹
  智灯照世王　　无碍心如是
  譬如世间地　　一切同所依
  诸佛于众生　　为依亦如是
  譬如迅疾风　　行空无所碍
  佛智亦如是　　不碍于世间
  譬如大水轮　　世界所依止
  三世佛亦然　　恒依智轮住

尔时北方无碍吉祥胜藏王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  譬如大宝山　　普益诸含识
  见佛亦如是　　能生出世智
  譬如大海水　　深广净无垢
  见佛亦如是　　能消诸渴爱
  譬如须弥山　　高出于大海
  智山亦如是　　安住深法海
  譬如深大海　　众宝之所生
  觉海亦如是　　能生诸智宝
  世雄甚深智　　无数亦无量
  所现诸神通　　无能测量者
  譬如巧幻师　　幻作种种相
  佛智亦如是　　现化量难思
  譬如摩尼珠　　所欲皆随意
  佛宝亦如是　　能满诸净愿
  譬如光净宝　　遍照于虚空
  佛宝亦复然　　普照于群有
  譬如八面宝　　照现于诸方
  无碍大智灯　　遍照于法界
  譬如水清珠　　能清诸浊水
  见佛亦如是　　诸根悉清净

尔时东北方妙变化遍法界愿月王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  譬如帝青宝　　照物皆同色
  众生见佛时　　同佛菩提色
  一一刹尘中　　诸佛现神变
  念念常不断　　所化皆清净
  甚深希有智　　不可得思议
  菩萨乃能知　　群生莫能入
  佛身极清净　　具足相庄严
  普入于法界　　成就诸菩萨
  不可思议刹　　皆现成正觉
  降魔坐道场　　菩萨众围绕
  释迦无上尊　　于法恒自在
  一切极微刹　　神通不可量
  菩萨种种行　　无碍妙光明
  佛力不思议　　一切皆能现
  佛子应善学　　甚深诸佛法
  证入诸法中　　无著智境界
  法王大威力　　常转妙法轮
  所现诸神通　　能净十方界
  甚深圆满智　　世间真实宝
  佛智大龙王　　随心悉能济

尔时东南方法慧光明威德王菩萨摩诃萨。承佛威力观察十方。而说偈言

  尽十方三世　　一切大声闻
  不能知如来　　所有微妙法
  复尽彼三世　　十方诸缘觉
  亦不知如来　　所有神通事
  况复处流转　　盲瞑诸凡夫
  结使之所缚　　而能测佛境
  如来无碍智　　过量及非量
  离于语言道　　一切无能说
  佛以相严身　　凝光如满月
  曩劫因修忍　　化现于十方
  谛观诸佛力　　三昧及神通
  亿劫共思量　　不能知少分
  谛观诸佛智　　自觉妙难思
  一一功德门　　无能测边际
  若有发大愿　　爱乐于佛法
  于斯难见境　　通达不为难
  若以清净心　　精勤集福智
  具足大功德　　闻教能随入
  若人依佛慧　　志愿亦弘深
  是向佛菩提　　当成一切智

尔时西南方摧碎一切魔力智幢王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  智身无所著　　远离于身相
  难思佛境界　　众圣莫能知
  不思议净业　　起此微妙身
  相好及光明　　三世无能碍
  遍照于世间　　法界恒清净
  开佛菩提门　　常生一切智
  体净无诸垢　　远离一切障
  犹如世间日　　普放智光明
  永绝三界流　　能除生死怖
  成就诸菩萨　　令满菩提愿
  显现无量色　　此色无依住
  所现虽无量　　一切难思议
  佛于一念中　　普现难思事
  菩提深境界　　无有能测知
  佛于一念中　　显现三世佛
  所现虽无尽　　念性曾无异
  智者应善思　　念念恒相续
  唯智无别业　　专向佛菩提
  是法难思议　　性离于言说
  亦非心境界　　诸佛从此生

尔时西北方毗卢遮那愿智星宿幢菩萨摩诃萨。承佛威力。观察十方。而说偈言

  净念离痴乱　　勇猛恒持法
  圆满智能观　　无尽菩提海
  若得决定解　　则能入佛境
  自在智从生　　永断诸疑惑
  念念心增进　　所行无懈倦
  于法常志求　　究竟诸佛法
  从彼诸善根　　能生广大信
  常乐常观察　　无相无依住
  亿劫常修集　　圆满诸善根
  皆为佛菩提　　证于无比乐
  行于生死中　　不着于生死
  于法无疑惑　　常乐佛境界
  于诸有为法　　世间虚妄乐
  永离贪着心　　专求佛功德
  凡夫迷佛智　　没溺生死流
  菩萨无著心　　普救咸令出
  菩萨无动行　　举世无能测
  普现随类身　　等与群生乐
  已净菩提智　　于世起慈悲
  如日出世间　　光照无边际

尔时下方破诸盖障勇猛智自在王菩萨摩诃萨。承佛威力。观察十方。而说偈言

  无量亿千劫　　佛名难得闻
  况复于现前　　见佛除疑惑
  如来无尽智　　照世圆满灯
  三世流福河　　能令众清净
  如来妙色身　　清净无过失
  亿劫常瞻仰　　其心无厌足
  佛子善观察　　如来妙色身
  智净恒无著　　能成自他利
  如来深智力　　无尽妙辩才
  开佛菩提门　　所说皆无碍
  牟尼遍照尊　　导彼难思众
  授胜菩提记　　令登解脱门
  广大福德聚　　出兴于世间
  开悟诸群生　　令集菩提行
  曾供养诸佛　　智度恒清净
  能破诸惑网　　永除恶道怖
  能观两足尊　　发大菩提愿
  获佛自在力　　能生大智光
  若见人中尊　　求佛心决定
  当知如是人　　必获如来智

尔时上方普遍法界大愿际菩萨摩诃萨。承佛威力。观察十方。而说偈言

  牟尼殊特尊　　众德皆圆满
  见者心清净　　回向大菩提
  如来兴出世　　寂静大慈悲
  普转妙法轮　　利益诸含识
  佛于无量劫　　勤苦为众生
  云何诸众生　　能报大师恩
  宁受三涂苦　　备经无量劫
  终不舍如来　　而求于出离
  宁代诸众生　　永受轮回苦
  终不舍如来　　而求于少乐
  宁恶道多劫　　受苦闻佛名
  不愿生善道　　暂时不闻佛
  宁地狱多劫　　受苦常见佛
  不愿离三涂　　生无佛法处
  何故于恶道　　而无厌离心
  由见于法王　　智慧常增长
  见佛自在力　　能除一切苦
  得入诸如来　　甚深智境界
  若得见佛时　　灭除诸恶趣
  增长福智芽　　必获菩提果
  众生若见佛　　能破种种疑
  世出世间乐　　所愿皆圆满

大方广佛华严经卷第二大方广佛华严经卷第三

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时普贤菩萨摩诃萨。普观一切菩萨众会。欲为开发如来最上师子频申大三昧故。以等虚空界方便。等三世方便。等法界方便。等一切世界。等一切业。等一切众生心。等一切众生欲。等一切众生根。等一切众生成熟时。等一切法光影方便。告诸菩萨言。佛子我今为汝。以十种法门清净名句。开示演说师子频申广大三昧神通境界。何等为十。所谓等虚空界。如来所现遍法界。一切佛刹。极微尘中。一切诸佛出兴次第。及一切刹成坏次第。法门名句。等虚空界。一切佛刹。尽未来际一切劫中。赞叹如来殊胜功德。法门名句。等虚空界。一切佛刹如来出世。显现无量菩提门海。法门名句。等虚空界一切佛刹。如来所坐。最胜道场。菩萨众会。圆满境界。法门名句。一切毛孔。于念念中。出等三世一切诸佛变化身云。充满法界。法门名句。以威神力。能令一身。普现十方一切刹海。光明遍照诸佛世界。法门名句。以威神力。能于一切诸境界中。普现三世一切诸佛。种种神变。如观掌中。明了显现。法门名句。能令三世一切佛刹极微尘中。普现三世一切佛刹。极微尘数佛。显现种种神通境界。经于劫海。相续不断。法门名句。能令一切毛孔出声。演说三世一切诸佛。大愿海音尽未来际。加持出生。一切菩萨。法门名句。能令所处师子之座。量同法界。最胜觉解。大菩萨众。庄严道场。遍一切处。尽未来际。转于法轮。无间成熟。相续不绝。法门名句。佛子此十法句。以为其首。有不可说佛刹极微尘数清净名句微妙法品。皆是如来智慧境界。非我及汝所能证知。尔时普贤菩萨。欲重宣此如来所入师子频申广大三昧少分境界。承佛神力。一心瞻仰。观察如来不可思议菩萨众海。观察如来不可思议三昧神通种种变现。观察如来不可思议入出一切诸世界海。观察如来不可思议入一切法幻智境界。观察如来不可思议普现三世一切诸佛悉皆平等。观察如来不可思议无量无边诸语言道开悟一切诸法门海。而说偈言

  一一毛孔中刹海　　等一切刹极微数
  佛悉于中坐道场　　菩萨众会共围绕
  一一毛孔所有刹　　佛悉于中坐道场
  安处最胜莲华座　　普现神通周法界
  一毛端处所有佛　　一切刹土极微数
  悉于菩萨众会中　　皆为宣扬普贤行
  如来安坐于一刹　　一切刹中无不现
  十方无尽菩萨云　　普共同来集其所
  功德光明菩萨海　　百千亿刹极微数
  俱从会起赞如来　　遍往十方充法界
  自在游于深法界　　悉住普贤无等行
  现一切刹放光明　　普入无边诸佛会
  普于十方一切刹　　安住最胜诸佛所
  听闻正法具修行　　一一土经无量劫
  菩萨常修种种行　　皆入普贤愿海中
  住佛境界德无边　　法海光明无不遍
  通达普贤广大行　　出生诸佛无尽法
  赞佛功德海无涯　　现众神通充法界
  身云普现如尘数　　念念恒周一切刹
  甘露法雨润群生　　普遍法界令开悟

尔时世尊。以最胜甚深广大意乐正念思惟。欲令众会诸菩萨等。安住如来师子频申大三昧故。从眉间白毫相中。放大光明。名普照现三世法界门。以不可说佛刹极微尘数光明。而为眷属。普照十方一切刹海。时逝多林菩萨众会。悉见十方尽法界虚空界一切世界所有极微。一一极微。各有一切佛刹极微尘数诸佛国土。种种名字。种种色相。种种庄严。种种清净。种种依住。种种形状。如是一切诸国土中。皆有最胜菩提道场。一一道场。皆有庄严宝师子座。一一座上。皆有菩萨。成等正觉。一切菩萨所共围绕。一切世主。恭敬供养。或见处在不可说佛刹大众会中。转正法轮。其声无碍。遍周法界。或见处在天王宫中。龙王宫中。夜叉王宫。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等诸王宫中。及余人间。村营城邑。王都聚落。乃至种种众生住处。现种种神力。说种种法门。所谓。生种种族姓。受种种色身。住种种威仪。示种种相好。佩种种圆光。放种种光网。处种种众会。入种种三昧。起种种神变。现种种威力。发种种音声。出种种言辞。以种种名句。演种种教法。如此会中。菩萨大众见于如来甚深三昧广大神变。如是尽法界虚空界。东西南北。四维上下。遍一切处。种种方转变中。种种方法门中。种种方想住中。种种方出生中。种种方分齐中。种种方解起中。种种方海中。皆依于众生心想而住。始从前际。至今现在。所有一切国土身。一切众生身。一切毛孔中。一切极微中。及彼一切虚空界中。一一毛端量处皆有一切刹土。极微尘数。种种刹海。种种业起。相续不断。次第而住。其中所有。道场众会。见佛神力。悉亦如是。以得见佛神通力故。悉能遍入十方三世一切世界众生心中。现其影像。随诸众生。种种乐欲。出妙言音。随其所应。演说诸法。普入众会中。普现众生前。色相有别。智慧无异。遍一切刹。尽未来际。自在示现常无休息。教化调伏一切众生。其有见此神通力者。皆是毗卢遮那如来。过去修集愿力。善根之所摄受。或昔曾以四摄善根之所摄受。或是往昔见闻忆念亲近供养之所成熟。或是往昔令其发起阿耨多罗三藐三菩提心。或昔曾于如来所。修菩萨行时。经游之处。勇猛精勤。善根所摄。或昔曾于一切佛所。与佛同种相似善根。或是如来于过去时。为求无上一切智故。种种方便教化成熟。是故皆得入于如来不可思议甚深三昧尽法界虚空界广大神变。或有得见入佛法身。或有得见入佛色身。或有得见入佛智身。或有得见入于如来过去所行清净行海。或有得见入于如来究竟圆满功德彼岸。或有得见入于菩萨庄严行轮。或有得见入于菩萨所证诸地。或有得见入于如来成正觉智。或有得见入佛所住诸三昧门平等神变。或有得见入于如来十种智力四无所畏。或有得见入于如来四无碍解辩才大海。入如是等十不可说佛刹极微尘数如来种种大神变海。彼诸菩萨。以种种信。种种解。种种道。种种门。种种入。种种教。种种随顺。种种方所。种种根器。种种国土。种种世界。种种智慧。种种法聚。种种神变。种种方便。种种三昧。以如是等。入于如来神变大海。云何菩萨种种三昧。所谓入一切菩萨普遍庄严法界三昧。菩萨光照三世无碍境三昧。菩萨法界无断智光明三昧。菩萨住一切佛境界三昧。菩萨光照无边虚空际三昧。菩萨入出游戏如来自在力三昧。菩萨勇猛无畏奋迅庄严三昧。菩萨入一切法界方便漩澓藏三昧。菩萨遍法界如月普现以无碍音演一切法三昧。菩萨种种法云平等庄严三昧。菩萨离垢缯系顶法王幢三昧。菩萨观一切佛智慧海三昧。菩萨无分别光幢照一切世间差别身三昧。菩萨入如来无分别境界身三昧。菩萨大悲藏随一切世间转三昧。菩萨安住一切法无依迹威力三昧。菩萨照一切法最极寂静圆满智三昧。菩萨知诸法空巧能化现遍一切世间三昧。菩萨威力平等普出生一切佛刹三昧。菩萨于一切佛刹现成正觉庄严相三昧。菩萨观一切世间色空三昧。菩萨不着一切世间最胜圆满空三昧。菩萨出生一切如来威力母三昧。菩萨修行入一切佛究竟功德海三昧。菩萨观察一切境界出生神变尽未来际威力三昧。菩萨入一切如来次第本事海三昧。菩萨能以威力尽未来际护持一切如来种性三昧。菩萨以决定解力令现在十方一切佛刹皆清净三昧。菩萨一刹那中普照一切佛差别住处三昧。菩萨深入观察无碍际三昧。菩萨能以威力令一切世界为一佛刹三昧。菩萨出生一切佛变化身三昧。菩萨以金刚智知一切诸根海三昧。菩萨知一切如来同一胎藏身三昧。菩萨知一切法界随所安立悉住心念际三昧。菩萨于一切法界广大刹中现成正觉及般涅槃大威力三昧。菩萨令住最上威力处三昧。菩萨照一切佛刹众生身无分别威力三昧。菩萨入一切佛智慧旋转藏三昧。菩萨知一切法性相差别三昧。菩萨一刹那中以无分别智普见三世法三昧。菩萨念念中普现法界藏身三昧。菩萨以勇猛智如师子王随顺悟解一切如来种姓三昧。菩萨观一切法界圆满智慧眼三昧。菩萨正勇猛趣向十力三昧。菩萨以普遍眼观察一切圆满功德三昧。菩萨遍照出生一切众生色相圆满三昧。菩萨旋转不动藏三昧。菩萨演说一法普入一切法三昧。菩萨于一法以一切言辞差别训释辩才三昧。菩萨演说一切佛无二法句威力幢三昧。菩萨知三世无碍际三昧。菩萨随顺悟解一切劫无差别三昧。菩萨入微细十力方便三昧。菩萨以金刚智起一切菩萨行三昧。菩萨能于十方随心速疾普现身云三昧。菩萨现遍法界成正觉身种种神变三昧。菩萨受一切触安乐幢三昧。菩萨出一切庄严具庄严虚空界三昧。菩萨念念中出等一切世间数变化形像云三昧。菩萨如来无垢月光照虚空三昧。菩萨一切如来加持三昧。菩萨一光照一切法根本差别庄严三昧。菩萨广演一切法义灯三昧。菩萨照十力境圆满三昧。菩萨三世诸佛星宿幢三昧。菩萨一切佛一密藏三昧。菩萨观一切相皆究竟三昧。菩萨无尽福德藏三昧。菩萨见尽无边佛境界三昧。菩萨见一切法如金刚师子吼威力三昧。菩萨现一切如来变化正见平等三昧。菩萨一切佛日念念周行三昧。菩萨一念普照三世法三昧。菩萨普音演说净光等照一切法自性清净三昧。菩萨见一切佛差别力三昧。菩萨见一切佛觉一切差别法界如莲华开敷三昧。菩萨观察诸法如虚空无住处三昧。菩萨一方普出十方海旋转藏三昧。菩萨入一切法界门三昧。菩萨一切法海差别藏身三昧。菩萨以寂静身放差别光照一切众生身三昧。菩萨一刹那心以大愿力出生一切神通三昧。菩萨常于一切处正觉威力普遍三昧。菩萨随顺悟解以一庄严入一切法界三昧。菩萨正念一切佛身普照三昧。菩萨悟解最胜神通智遍一切世界三昧。菩萨一念令无量教字本母普遍法界三昧。菩萨以一教法庄严一切法界法光明三昧。菩萨一切佛威力光明圆满轮三昧。菩萨以行愿网摄一切众生界三昧。菩萨见一切世界不断绝三昧。菩萨莲华吉祥种种神变普游步三昧。菩萨知一切众生身旋转智三昧。菩萨威力普现一切众生前三昧。菩萨悟解一切众生音声言辞秘密海三昧。菩萨观一切众生差别智三昧。菩萨无分别大悲藏三昧。菩萨入一切如来际三昧。菩萨观察一切如来解脱处师子频申三昧。彼诸菩萨。以如是等不可说佛刹极微尘数菩萨三昧。而为方便。入毗卢遮那如来过去所修广大功德念念充满一切法界诸佛三昧大神变海。其诸菩萨。住逝多林。不离如来道场众会。各各自见。普于十方一切佛刹极微尘数广大世界。坐于种种宝莲华藏师子之座。皆已具足广大智慧。普现种种神通境界。已住寂静诸菩萨地。自在出生明利智慧。已得随顺普遍智行。从佛智慧种性而生。已证现前一切智智。得无痴翳清净智眼。善巧调御一切众生。住一切佛平等法性。于一切法。顺悟随解。已能观察一切诸法自性清净。知诸世间究竟寂灭无有所依。普诣十方一切国土。而无所著。常勤观察一切世间。而无所住。普往十方一切刹土。而无所去。已入一切妙法宫殿而无所来。遍于诸法。了达性空。知无积聚。而恒教化成熟众生。示诸众生安乐行处。开示智慧解脱境界。恒以智身。住离贪际。超越一切生死苦海。普示众生诸蕴实际。智光圆满照彻一切。定力坚固无能倾动。于诸众生常起大悲。了一切法悉皆如幻。知诸世间悉皆如梦。观一切佛现差别身悉皆如影。知所说法音声语言悉皆如响。现见诸法生成住持悉皆如化。善能积集最胜行愿。普遍智慧。圆满清净。善巧随顺。究竟寂静。善入总持种智境界。具足无畏诸三昧力。勇猛精进遍修诸行。住法界际获明智眼。到一切法无所住处。修习无边智慧行海。到智波罗蜜究竟彼岸。得般若波罗蜜之所摄持。以神通波罗蜜。度诸众生。依禅波罗蜜。得心自在。证一切佛真实境界。以善巧智开示法藏。以明了智训释文词。以辩才力说无尽法。雄猛无畏能师子吼。常乐观察无差别法。以净慧眼普观一切。无生智月等照世间。观诸众生见真实谛。福智坚固如金刚山。一切譬谕说不能及。增长一切智慧根芽。勇猛精进摧诸魔众。无量智慧威光圆满。身相殊特超诸世间。得一切法无碍智慧。解了诸法尽无尽际。智慧清净住普遍际。能遍随顺入真实际。无相观智常现在前。善巧圆满诸菩萨行。以无二智观诸世间。知诸众生往来所趣。遍诸佛刹得圆满智。于一切法离诸暗障。普放法光照十方界。为诸世间最胜福田。广大愿轮如月普现。福德超胜如须弥山。一切世间无能过者。摧伏一切外道邪论。于一切刹普现其身。以微妙音。演说诸法。普见诸佛心无厌足。已得诸佛自在威力。随所应化。现种种身。乘大智舟。泛生死海。周旋普济。所往无碍。智慧圆满。身光映彻。如日轮出普照世间。随众生心。现众色像。知诸众生根性欲乐。入于无诤清净境界。知一切法自性无生。以自在智。能令一切小大境界互相涉入。决了佛地甚深理趣。知诸世间文字句义。以无尽句说无尽法。于一句中。演出一切修多罗海。具足获得广大智慧陀罗尼身。随所受持。尽未来劫。初无忘失。一念能忆不可说劫宿住之事。一念能了三世一切诸众生心。与诸众生一切诸佛总持法藏。常转清净不退法轮。令诸众生生大智慧入佛境界。具一切智。常善安住甚深三昧。巧能分别一切法句。而于诸法悉无所著。最胜智慧自在游戏。于诸境界。皆得解脱。观察一切净庄严身。其身普入十方法界。随所应化悉能遍往。知诸刹海所有极微。悉于其中现成正觉。于无色性现一切色。能以一方入一切方。其诸菩萨。具足如是无量智慧功德之藏。十方所有一切诸佛。悉共称扬。说其功德。不能令尽。靡不咸在逝多林中。悉见于佛光明所照。深入如来功德大海

尔时彼诸菩萨。得不思议正法光明照故。其心欢喜。安隐快乐。各于其身及师子座。众宝楼阁。诸庄严具。遍逝多林。凡所受用。一切物中。化出种种大庄严云。充满十方一切法界。所谓于念念中。普放一切微妙广大光明网云。充满法界。遍能开觉一切众生。咸令欢喜。于念念中。出现一切摩尼铃云。充满法界。出微妙音。称扬赞叹三世诸佛一切功德。于念念中。出现一切天音乐云。充满法界。出微妙音。演说众生诸业果报。于念念中。出现一切诸大菩萨种种行愿身色相云。充满法界。悉以妙音。说诸菩萨所有一切广大行愿。于念念中。出现一切如来自在种种神通妙变化云。充满法界。以随类音。遍众生界。演说诸佛广大言音。于念念中。出现一切种种庄严诸相随好菩萨身云。充满法界。遍一切刹。说诸如来普于十方一切国土出兴次第相续不断。于念念中。出现一切三世如来菩提场云。充满法界。显现诸佛成等正觉。普遍观察显示成佛庄严功德。于念念中。出现一切诸大龙王相似身云。充满法界。一一身云遍诸佛刹。普雨一切诸上妙香。于念念中。出现一切诸世间主相似身云。充满法界。一一世主。普遍观察演说普贤菩萨之行。于念念中。出现一切妙宝光明净佛刹云。充满法界。显示十方一切诸佛所转法轮。是诸菩萨。以得如是不可思议光明所照。入于广大不可思议神通境界。法应如是出兴此等不可说佛刹极微尘数种种神变大庄严云。尔时文殊师利菩萨摩诃萨。承佛威力。欲重开示逝多林中诸神变事。观察十方。而说偈言

  汝应观此逝多林　　广博庄严量无际
  一切身云皆示现　　以佛威神充法界
  清净色相庄严身　　十方无量诸佛子
  咸来影现道场中　　众会普观无不见
  从诸佛子毛孔中　　演佛法音若雷震
  焰云种种庄严相　　普遍十方一切刹
  又于宝树华叶中　　出现梵释庄严相
  动止威仪恒寂静　　从禅定起而游步
  佛身一一毛孔中　　常现难思众菩萨
  相好端严甚微妙　　悉与普贤菩萨等
  逝多林上诸严具　　充遍虚空发妙音
  赞说三世诸菩萨　　种种庄严功德海
  逝多林中诸宝树　　亦出无量妙音声
  演说一切诸群生　　种种业报差别海
  林中所有诸境界　　悉现三世诸如来
  十方刹海极微中　　皆起神通无不遍
  一切刹海极微中　　所有十方诸国土
  于佛一一诸毛孔　　普遍庄严皆显现
  宝焰香云皆现佛　　等众生数遍世间
  一一咸起大神通　　方便随宜而化度
  如虚空量宝宫城　　尽妙庄严如日现
  宝藏及与菩提树　　靡不普遍于十方
  十方三世诸如来　　所有道场菩萨众
  劫海修行功德相　　一切于此林中现
  普贤大行诸菩萨　　已于刹海具庄严
  其数无量等群生　　于此林中无不见

尔时彼诸菩萨。蒙佛三昧光明照故。一一皆得不可说佛刹极微尘数大悲门。以得如是大悲门故。摄受利益安乐众生。即于其身一一毛孔。各出不可说佛刹极微尘数众色光明。一一光明。各各化现不可说佛刹极微尘数菩萨身云。复出一切世主相似身云。充满十方一切法界普现一切诸众生前。随诸众生身相言音。种种方便教化调伏。令其成熟。或现不可说佛刹极微尘数诸天宫殿退堕无常门。或现不可说佛刹极微尘数一切众生随业受生门。或现不可说佛刹极微尘数梦中境界令心觉悟门。或现不可说佛刹极微尘数一切菩萨圆满诸行门。或现不可说佛刹极微尘数一切菩萨圆满大愿门。或现不可说佛刹极微尘数震动世界门。或现不可说佛刹极微尘数一切如来悉舍内外檀波罗蜜门。或现不可说佛刹极微尘数一切如来修诸功德正行圆满尸波罗蜜门。或现不可说佛刹极微尘数一切菩萨断截肢体心无动乱羼提波罗蜜门。或现不可说佛刹极微尘数一切菩萨勤修种种智慧神通毗梨耶波罗蜜门。或现不可说佛刹极微尘数修诸静虑等持等至神通解脱禅波罗蜜门。或现不可说佛刹极微尘数智光照世般若波罗蜜门。或现不可说佛刹极微尘数勤求佛法为一一名句一一文义。皆舍国城妻子财物无数身命门。或现不可说佛刹极微尘数于诸如来亲近供养。咨求请问一切法要心无疲厌门。或现不可说佛刹极微尘数随诸众生根欲成熟。往诣其所开发示导令其悟入智海光明门。或现不可说佛刹极微尘数一切菩萨大福智聚。摧伏众魔制诸外道胜幢威力门。或现不可说佛刹极微尘数知一切工巧技术明智门。或现不可说佛刹极微尘数知一切众生心行微细差别明智门。或现不可说佛刹极微尘数知一切诸法种类差别殊胜明智门。或现不可说佛刹极微尘数知一切众生种种心乐差别明智门。或现不可说佛刹极微尘数知一切众生根行差别烦恼习气令其除灭明智门。或现不可说佛刹极微尘数知一切众生品类差别业报明智门。以如是等不可说佛刹极微尘数诸方便门。往诣一切众生住处。摄受调伏。而成熟之。所谓。或往梵王宫。或往帝释宫。或时往诣天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等阎摩罗界诸王宫中。或往畜生饿鬼地狱之所住处。以平等大悲。平等大愿。平等智慧。平等三昧。教化摄取。而调伏之。彼诸众生。或有见已而调伏者。或有闻已而调伏者。或有忆念而调伏者。或闻音声而调伏者。或闻名号而调伏者。或见圆光而调伏者。或见光网而调伏者。随诸众生心之所乐。皆诣其所。令其获益。而此林中一切菩萨。为欲成熟诸众生故。虽以神力或时现处种种严饰诸宫殿中。或时示现住自楼阁宝师子座。道场众会。所共围绕。充满十方一切刹海。普遍示现。皆令得见。然亦不离此逝多林如来之所。又此菩萨为欲成熟诸众生故。示现无量变化身云。或现其身眷属庄严。或现其身独一无侣。所谓或现沙门身。或现婆罗门身。或现异道出家身。或现苦行身。或现充盛身。或现医王身。或现商主身。或现淫女身。或现妓乐身。或现毗沙门身。或现世主身。或现奉事诸天身。或现工巧技术身。现如是等诸变化身。往诣一切诸众生所。随其所应。起如幻智。于诸世间。犹如帝网。行菩萨行。以种种形相。种种威仪。种种音声。种种言论。种种住处。演说诸法。所谓或说一切世间工巧事业。或说一切福德智慧照世明灯。或说一切所证真实威力加持。或说一切业力所持庄严世趣。或说一切建立十方清净乘位。或说一切圆满智灯照法境界。如是菩萨。虽普周遍十方法界。教化调伏。成熟众生。而亦不离此逝多林如来之所

大方广佛华严经卷第三大方广佛华严经卷第四

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时文殊师利童子。从善住楼阁出。与无量同行大菩萨众。及常侍卫诸金刚神。普为世间。现大威力身众神。久发坚誓供养诸佛足行神。念昔大愿乐闻正法相续不断主地神。深净大悲庄严法界普润众生主水神。智慧威力光明遍照主火神。摩尼宝冠以严其首主风神。光照十方差别仪式主方神。专勤除灭无明黑闇主夜神。一心开现如来智日主昼神。普遍庄严虚空法界主空神。能勤方便拔济众生出生死海主海神。常勤积集出过心量趣一切智胜幢善根主山神。发大誓愿运度众生称赞诸佛勇猛无倦主河神。常勤守护一切众生菩提心城主城神。常勤守护一切众生诸大龙王。常勤守护一切智城诸夜叉王。常令众生增长欢喜乾闼婆王。常勤除灭一切饿鬼所有饥渴鸠槃茶王。恒愿拔济一切众生度生死海迦楼罗王。愿诸众生普得成就超诸世间如来力身阿修罗王。曲躬恭敬乐见诸佛种种功德摩睺罗伽王。深厌生死常乐瞻仰诸佛相好诸大天王。尊重于佛恭敬供养称扬赞叹诸大梵王。文殊师利。与如是等种种色像威德庄严大菩萨众。及诸世主。前后围绕。从自住处来诣佛所。右绕如来。经无量匝。以诸供具种种供养。供养毕已。顶礼辞退。右绕而出。往于南方

尔时尊者舍利弗。承佛神力。见文殊师利菩萨。与如是等诸大菩萨。及诸世主种种神通威德自在众会庄严。从逝多林。安详而出。作是思惟。我今当与文殊师利。俱往南方。时舍利弗。即与眷属六十比丘。前后围绕。出自住处往诣佛所。到已顶礼。一心观佛。具白世尊。世尊听许。右绕三匝。作礼辞退。往文殊师利童子所此诸比丘。皆舍利弗之所化度。出家未久。自所同住。所谓海觉比丘。妙德比丘。福光比丘。大悲比丘。电德比丘。净行比丘。天德比丘。实慧比丘。梵胜比丘。寂慧比丘。与如是等六十人俱。曾于过去。供养诸佛。深种善根。于甚深法。悉能悟解。深信趣入最极清净。志行宽博。等佛境界。于佛教法。能正修行。悉能了知诸法本性。能大饶益成熟众生。常乐勤求诸佛功德。皆是文殊师利童子之所教化

尔时尊者舍利弗。将诸比丘。随路而行。观诸比丘。告海觉言。汝可观察文殊师利清净相好庄严之身。诸天及人莫能思议。汝可观察文殊师利圆光映彻普照十方能令众生心生欢喜。汝可观察文殊师利放光明网。微妙庄严。除灭众生无量苦恼。汝可观察文殊师利众会威德。皆是菩萨往昔善根之所摄受。汝可观察文殊师利所行之路。左右八步清净平坦。众宝庄严。汝可观察文殊师利所住之处。周回十方常有道场。显现庄严随逐而转。汝可观察文殊师利所行之路。具足无量福德庄严。左右两边。皆有伏藏。种种珍宝自然而出。汝可观察文殊师利。由昔供养诸佛善根。随其所在有杂宝树。于其树间宝藏开敷。出庄严具。汝可观察文殊师利。随其所在一切世主兴供养云。雨诸供具。周布陈列。以为供养。汝可观察文殊师利。十方诸佛将说法时。悉放眉间白毫光明。来照其身。从顶上入。尔时尊者舍利弗。为诸比丘。称扬赞叹开示演说。文殊师利如是无量种种功德具足庄严。时诸比丘闻是赞已。心意清净。信解坚固。踊跃欢喜。不能自持。形体柔软。诸根和悦。垢障咸尽。忧苦悉除。常见诸佛。恒闻正法。回向趣求一切智智。成就菩萨无碍善根。逮得菩萨无量诸力。出生无尽圆满大悲。发起无边广大誓愿。深入诸度。究竟彼岸。十方佛海。皆悉现前。于佛境界。深生信乐。即白尊者舍利弗言。唯愿和尚。将道我等。亲近于彼胜妙丈夫。时舍利弗。即与俱行诣文殊师利童子所。见已顶礼白言。仁者此诸比丘。愿得奉觐。尔时文殊师利童子。与无量自在神通菩萨围绕。并其大众。种种眷属。如象王回。观诸比丘。时诸比丘。头面礼足。恭敬合掌。白如是言。唯愿。大圣文殊师利。和尚舍利弗。世尊释迦牟尼。悉当证知。我等今以得见大士胜妙丈夫。奉觐瞻礼。恭敬信乐。所有善根。及以我等过去所集福智善根。以此善根。愿令我等。于仁所有如是色身。如是相好。如是音声。如是自在。一切功德。悉当具得

尔时文殊师利菩萨。告诸比丘言。若善男子善女人。成就十种趣大乘法。无疲厌心。则能速疾深入如来究竟之地。况菩萨地。何等为十。所谓见诸如来。以广大心。亲近供养。心无疲厌。积集成就。一切善根。究竟不退。心无疲厌。勤求一切诸佛正法。心无疲厌。勤行一切菩萨殊胜诸波罗蜜。心无疲厌。普遍修习一切菩萨甚深三昧。心无疲厌。次第趣入三世流转一切诸法。心无疲厌。庄严十方一切刹海。悉令清净。心无疲厌。教化调伏一切众生。皆令成熟。心无疲厌。于一切刹。行菩萨行。经一切劫。心无疲厌。为欲成熟一众生故。修一切刹极微尘数波罗蜜门。成就圆满如来一力。如是次第。为一切众生。成就如来一切智力。心无疲厌。比丘当知。若善男子善女人。成就深信。发此十种无疲厌心。则能长养一切善根。舍离一切生死流转。悉能超出一切世间。不堕声闻辟支佛地。成就如来一切种性。满足菩萨清净大愿。积集一切如来功德。修行一切菩萨诸行。获得如来力无所畏。摧伏众魔及诸外道。灭除一切烦恼习气。入菩萨地。近如来地。时诸比丘闻此法已。即时同证广大三昧。名见一切佛境界无碍眼。得此三昧威神力故。悉见十方一切世界诸佛如来。及其所有道场众会。亦悉见彼一切世界所有众生种种趣类各各差别。亦悉见彼一切世界同异染净各各差别。亦悉见彼一切世界所有极微尘相差别。亦悉见彼诸世界中一切众生所住宫殿。种种庄严。种种成就。及所受用。种种资具。各各差别。及闻彼佛。诸音声海。演说诸法。种种名句。文词训释。性相秘密。悉能解了。亦能观察彼世界中一切众生心行根欲各各差别。亦能忆念彼世界中一切众生过去未来各十生事。亦能忆念彼世界中过去未来各十劫事。亦能忆念彼诸如来十本生事。十成正觉。十转法轮。十种神通。十种记心。十种教诫。十种说法。十种辩才。又由得此三昧力故。即时获得十千真实菩提之心。成就十千甚深三昧。具足十千诸波罗蜜。圆满十千智慧光明。发起十千自在神力。以得如是菩萨三昧种种威神无碍势力所庄严故。令其身心。柔软微妙。增长信乐。住菩提心。坚固不动。尔时文殊师利菩萨。具足安住真实吉祥微妙功德普贤胜行。劝诸比丘。令其安住胜普贤行。住胜行已。入于甚深广大愿海。入愿海已。普遍成就甚深大愿。以得成就大愿海故。得心清净。心清净故得身清净。身清净故得身轻利。身轻利故则得广大不退神通。以得如是大神通故。不离文殊师利足下。普于十方一切世界诸如来所。悉现其身。具足成就一切佛法

尔时文殊师利菩萨。劝诸比丘。发阿耨多罗三藐三菩提心已。渐次南行。经历人间城邑聚落。至福生城。于其城东。住庄严幢娑罗林中。往昔诸佛曾所止住。教化成熟一切众生大塔庙处。亦是世尊毗卢遮那。于往昔时。行菩萨行。能舍无量难舍之处。是故此林。名称普闻无量佛刹。此处常为天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。恭敬供养。时文殊师利。与诸眷属。到此林已。即于其处。坐师子座。说修多罗。名普照法界圆满光明。百万亿那由他修多罗。以为眷属。说此经时。有无量百千亿那由他诸大龙王并其眷属。闻此法已。自厌龙趣。于佛功德。深生爱乐。咸舍龙身。生人天中。一万诸龙。于阿耨多罗三藐三菩提。得不退转。获有无量无数众生。于三乘中。各得成熟

时福城人。闻文殊师利住庄严幢娑罗林中大塔庙处。皆从城出。来诣其所。有优婆塞。名曰大慧。与其眷属五百人俱所谓须达多优婆塞。宝德优婆塞。圆光优婆塞。名称天优婆塞。月吉祥优婆塞。月喜优婆塞。月智优婆塞。大智优婆塞。贤护优婆塞。贤吉祥优婆塞。如是等众。前后围绕。来诣文殊师利童子所。到已礼足。右绕三匝。却坐一面

复有优婆夷。名曰大慧。与其眷属五百人俱。所谓妙圆光优婆夷。梵德优婆夷。吉祥优婆夷。妙臂优婆夷。贤光优婆夷。贤吉祥优婆夷。月光优婆夷。星宿光优婆夷。贤德优婆夷。妙眼优婆夷。如是等众。前后围绕。来诣文殊师利童子所。到已礼足。右绕三匝。却坐一面

复有童子。名曰善财。与其眷属五百人俱。所谓善禁童子。善戒童子。善威仪童子。善行童子。善思惟童子。善智童子。善慧童子。善眼童子。善臂童子。善光童子。如是等众。前后围绕。来诣文殊师利童子所。到已礼足。右绕三匝。却坐一面

复有童女。名曰妙贤。与其眷属五百人俱。所谓大慧童女。善贤童女。端严面童女。坚善慧童女。吉祥贤童女。吉祥智童女。供养德童女。吉祥圆光童女。妙觉童女。如是等众。前后围绕。来诣文殊师利童子所。到已礼足。右绕三匝。却坐一面

尔时文殊师利童子。知福城人悉已来集。普遍观察。随其心乐。即以神力。现自在身。威光赫奕。蔽诸大众。以大慈力。令其众会。皆得安隐清凉快乐。以大悲力。起说法心。普遍成就。以大智力。令其开悟。灭除一切烦恼心垢。以无碍辩。将说甚深广大佛法。复于是时。观察善财。以何因缘。而立此名。知此童子初入胎时。于其宅内。自然而出七宝楼阁。其楼阁下。有七伏藏。于其藏上。生七宝芽。所谓金银琉璃。玻璃赤珠。砗磲码瑙。善财童子。处胎十月。然后诞生。形体端正。肢分具足。其七伏藏。纵广高下。量各七肘。忽自开现。光明照耀。内外家族。视之无厌。复于宅中。自然而有五百宝器。珍奇杂宝。各各盈满。所谓金刚器中。盛满诸香。于香器中。盛种种衣。美玉器中。盛满饮食。摩尼器中。盛满杂宝。黄金器中。盛满银粟。白银器中。盛满金粟。金银器中。盛满琉璃。琉璃器中。盛满金银及摩尼宝。玻璃器中。盛满砗磲。砗磲器中。盛满玻璃。码瑙器中。盛满赤珠。赤珠器中。盛满码瑙。星幢摩尼器中。盛满水精摩尼。水精摩尼器中。盛满星幢摩尼。如是等五百宝器。自然出现。复于宅中。遍雨种种珍宝财物。及诸资具。一切库藏。悉皆充满。以此事故。父母亲属。及善相师。共呼此儿。名曰善财。又知此童子。已曾供养过去诸佛。深种善根。信解广大。常乐亲近诸善知识。身语意业。皆无过失。勇猛精进。净菩萨道。求一切智。成佛法器。心行清净。犹如虚空

尔时文殊师利菩萨。如是观察善财童子殊胜相已。熙怡微笑。安慰开谕。广为演说一切佛法。所谓说一切佛积集法。说一切佛相续法。说一切佛次第深入法。说一切佛众会清净法。说一切佛法轮化导法。说一切佛色身相好清净法。说一切佛法身普遍成就法。说一切佛无碍辩才法。说一切佛圆满庄严法。说一切佛平等无二法

尔时文殊师利童子。为善财童子。及诸大众。说此法已。复以种种善巧方便。殷勤劝谕。令其开觉增长势力。生大欢喜。发阿耨多罗三藐三菩提心。又令善财。忆念过去所种善根。复为福城一切人众随其根欲。显现神通。如所应度。广为说法。然后而去

尔时善财童子。从文殊师利童子所。闻说诸佛如是种种胜妙功德大威力已。勤求爱乐阿耨多罗三藐三菩提。随逐文殊师利。瞻恋不舍。一心归向。合掌谛观。而说偈言

  有大智慧威神力　　行菩提行利众生
  无量境界誓当求　　唯愿仁尊哀听许
  爱水深浚为池堑　　憍慢高举为垣墙
  诸趣出入为门户　　三有难超作城郭
  痴闇无明常所覆　　贪恚炽盛火恒烧
  魔王自在处其中　　愚童凡夫依止住
  谄诳忿恨惑乱戏　　贪欲所缠如罥索
  疑惑所蔽若生盲　　恒行险趣诸邪道
  常为悭嫉之所缚　　入于三涂八难中
  五趣轮回不觉知　　恒受生老病死苦
  灭惑大悲清净日　　智光普照圆满轮
  能竭生死烦恼海　　愿降慈光少观察
  圆满大慈清净月　　福德光明无垢轮
  一切众生咸施安　　愿赐清凉少观察
  一切法界功德王　　白业成就为轮宝
  所向导前无所碍　　愿顺我心垂教敕
  广博福智大商主　　勇猛不退求菩提
  普利一切诸众生　　唯愿垂悲拔济我
  身被最胜忍辱甲　　手提明利智慧剑
  常能自在破魔军　　愿雄猛者守护我
  安住妙法须弥顶　　绕以三昧诸天女
  摧灭业惑阿修罗　　真实帝释愿观我
  三有昏闇凡愚宅　　烦恼轮回地趣因
  仁尊永灭尽无余　　照世真灯示我道
  众生恶趣行已除　　修治善道咸清净
  度诸有海桥梁者　　示我真乘解脱门
  常乐我净颠倒想　　厚重邪执常迷覆
  明利智眼悉能除　　开我真乘解脱路
  善了真谛无迷惑　　于诸法中无所畏
  调伏众生自在人　　愿示于我菩提道
  安住如来正见地　　增长诸佛功德树
  雨一切佛妙法华　　愿速示我菩提道
  去来现在一切佛　　如日光明出世间
  为众能开甘露门　　彼所得道愿宣说
  能善解除诸业缚　　巧转诸乘妙法轮
  智慧决了自在人　　示我普焰摩诃衍
  大悲为毂行愿轮　　信辖深固坚忍轴
  净功德宝真实辕　　令我载此菩提乘
  一切总持圆满箱　　慈愍普覆庄严盖
  妙辩才音铃震响　　令我载此最上乘
  清净戒品为茵蓐　　诸妙三昧为采女
  法鼓洪音警有情　　令我载此摩诃衍
  具足四摄无尽藏　　庄严璎珞功德宝
  自他惭愧为羁鞅　　令我载此无上乘
  常放大舍圆满光　　恒涂净戒真实香
  永灭烦恼疮疣者　　令我载此最胜乘
  三业调伏不退轮　　六根寂静三昧箱
  最胜智慧方便轭　　令我载此妙法乘
  大愿回向善御者　　总持诸法坚固力
  智慧周旋常遍转　　令我载此速疾乘
  交络普贤诸行网　　悲心广运能徐转
  所行无畏得安详　　令我载此无上乘
  任持坚固等金刚　　妙智巧成如幻事
  一切障碍皆能断　　令我速载普贤乘
  大慈无垢等群生　　普与世间贤圣乐
  净智如空照法界　　愿速令我载此乘
  能净一切业惑尘　　亦断世间流转苦
  摧伏诸魔及外道　　令我载此妙法乘
  智慧境界等虚空　　行力庄严遍法界
  普满一切群生欲　　愿速令我载此乘
  志乐清净量难穷　　无明爱见皆除灭
  利益一切心无尽　　愿速令我载此乘
  愿力如风速疾行　　定心安住恒无动
  普运一切诸含识　　愿速令我载此乘
  坚誓如地永无倾　　大悲如水恒饶益
  勇健荷担无疲倦　　愿速令我载此乘
  普照众生智慧日　　四摄光明圆满轮
  总持胜妙清净光　　愿示于我咸令见
  能于劫海勤修学　　一切种智圆满因
  摧灭坚执有为城　　与我如是金刚智
  仁于诸佛大智海　　获是智海广无涯
  一切佛德靡不充　　善哉大圣当宣说
  已入法王妙法城　　已冠智王大智冠
  已系诸佛离垢缯　　最胜智眼愿观察

尔时文殊师利菩萨。如象王回。观察善财。作如是言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。复欲亲近诸善知识行菩萨行。问诸菩萨所行之道。善男子。亲近供养诸善知识。是集一切智。最初因缘。由乐亲近善知识故。令一切智疾得成满。是故于此。勿生疲厌。善财白言。圣者唯愿慈悲。广为我说。我应云何学菩萨行。应云何修菩萨行。应云何起菩萨行。应云何行菩萨行。应云何满菩萨行。应云何净菩萨行。应云何转菩萨行。应云何深入菩萨行。应云何出生菩萨行。应云何观察菩萨行。应云何增广菩萨行。应云何成就菩萨行。应云何令普贤行速得圆满。尔时文殊师利菩萨。为善财童子。而说偈言

  善哉清净功德海　　佛子能来至我所
  发起广博大悲心　　勇猛志求无上觉
  为欲度脱诸有情　　一切世间流转苦
  已发大愿深如海　　勤修一切菩萨行
  若有菩萨心坚固　　久处生死无疲厌
  彼当具足普贤行　　得佛功德无能坏
  福德威光福德星　　福德生处福德海
  汝能普为诸众生　　誓修普贤清净行
  汝见无边诸佛土　　去来现在一切佛
  亦闻所转妙法轮　　念力忆持无忘失
  汝于十方一切刹　　普见无量诸如来
  愿海清净悉皆成　　具足菩萨尘沙行
  汝入方便大法海　　安住如来功德地
  导师胜行汝当修　　当成一切无师智
  汝于一切广大刹　　所有刹土微尘劫
  于中修习普贤行　　成就最胜菩提道
  汝于无边劫海中　　普遍十方一切刹
  为欲成满诸大愿　　修行普贤诸妙行
  此中无量诸众生　　闻汝愿已皆欢喜
  悉发广大菩提意　　专心愿学普贤乘

尔是文殊师利菩萨。说此偈已。告善财童子言。善哉善哉。善男子。若有众生。能发阿耨多罗三藐三菩提心。是事为难。能发心已。复欲勤求行菩萨行。倍更为难。善男子。汝今发心。求菩萨道。为欲成就一切智智。应当勤求真善知识。善男子。求善知识。勿生疲懈。见善知识。勿生厌足。于善知识。所有教诲。当念随顺。不应违逆。于善知识。善巧方便。但应恭敬。勿见过失。善男子。于此南方。有一国土。名为胜乐。其国有山。名曰妙峰。彼有比丘。名吉祥云。汝可往问。菩萨云何学菩萨行。菩萨云何修菩萨行。乃至菩萨云何。于普贤行。疾得圆满。善男子。彼善知识。当为汝说具足圆满普贤行愿。时善财童子。闻是语已。心生欢喜。踊跃无量。于彼比丘。深生渴仰。于文殊师利。殷勤恋慕。顶礼双足。绕无数匝。悲泣流泪辞退而去

尔时善财童子。渐次南行。往胜乐国。登妙峰山。于其山上。东西南北。四维上下。周遍求觅。经于七日。竟不能见。由为勤求善知识故。捐舍身命。无饥渴想。正念观察。心安无退。过七日已。见彼比丘。在别山上徐步经行。即前往诣。顶礼双足。右绕三匝。合掌而住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨行。云何起菩萨行。云何行菩萨行。乃至云何于普贤行。疾得圆满。我闻圣者。善能诱诲。唯愿慈哀。为我宣说。云何菩萨。速得成就阿耨多罗三藐三菩提。时吉祥云比丘。告善财言。善哉善哉善男子。汝已能发阿耨多罗三藐三菩提心。是事为难。复能请问行菩萨行。难中之难。所谓勤求菩萨道。勤求菩萨境界。勤求菩萨广博净行。勤求菩萨出现神变。勤求菩萨示现广大诸解脱门。勤求菩萨示现世间种种作业。勤求菩萨随顺众生种种心行。勤求菩萨示现入出生死涅槃。勤求菩萨于为无为心无所著。勤求菩萨除断众生种种烦恼微细过失。善男子。我得自在决定解力。信眼清净。智行照耀。普眼明彻。具清净行。慧眼遍观一切境界。善巧方便离一切障。以清净身。普诣十方一切国土。恭敬供养一切诸佛。以信解力。常念十方一切诸佛。以总持力。受持十方一切佛法。以智慧眼。常见十方一切诸佛。所谓见于东方。一佛二佛。十佛百佛。千佛百千佛。亿佛百亿佛。千亿佛百千亿佛。那由他亿佛。百那由他亿佛。千那由他亿佛。百千那由他亿佛。乃至见无数无量。无边无等。不可数。不可称。不可思。不可量。不可说。不可说不可说佛。乃至见阎浮提极微尘数佛。四天下极微尘数佛。小千世界极微尘数佛。中千世界极微尘数佛。大千世界极微尘数佛。十佛刹极微尘数佛。百佛刹极微尘数佛。千佛刹极微尘数佛。百千佛刹极微尘数佛。亿佛刹极微尘数佛。百亿佛刹极微尘数佛。千亿佛刹极微尘数佛。百千亿佛刹极微尘数佛。那由他亿佛刹极微尘数佛。乃至见不可说不可说佛刹极微尘数佛。如见东方一切诸佛。南西北方。四维上下。所见诸佛。亦复如是。随其所见。一一方中。所有诸佛。种种色相。种种形貌。种种神通。种种受用。种种游戏。种种众会庄严道场。种种光明无边照耀。种种宫殿庄严国界。种种寿量示有修短。随诸众生种种心乐。示现种种成正觉门。于大众中。广现神变。作师子吼度脱众生。善男子。我唯得此忆念一切诸佛平等境界无碍智慧普见法门。如诸菩萨摩诃萨。无量智慧具足圆满清净行门。岂能了知所有边际。所谓智光普照差别境界念佛门。常见诸佛种种国土宫殿庄严悉现前故。令安住种种增上意乐念佛门。随诸众生心之所乐。皆令见佛得清净故。令安住究竟佛力念佛门。令入如来十种力中随顺行故。令安住种种如来究竟正法念佛门。见一切佛。演说正法。咸听闻故。遍照十方无差别藏念佛门。普见一切诸世界中等无差别诸佛海故。入不可见极微细处念佛门。彻见一切微细境中如来神变自在事故。住种种劫念佛门。于一切劫。常见诸佛。施作佛事。咸亲近故。住一切时念佛门。于一切时。常得见佛。与佛同住。不相离故。住一切刹念佛门。一切刹土。咸见佛身。超过世间。无等比故。住一切世念佛门。随于自心所有乐欲。普见三世诸如来故。住一切境念佛门。普见一切诸境界中。诸佛相续。咸出兴故。住一切性寂灭念佛门。于念念中。见一切刹一切诸佛示涅槃故。住一切时处念佛门。于一日中。见一切佛。从其住处。而往化故。住一切境广大念佛门。见一切佛结跏趺坐一一佛身满法界故。住一切法微细念佛门。于一毛孔。见不可说诸佛出兴。咸至其所。而承事故。住刹那际庄严念佛门。于一念中。见一切刹皆有诸佛成等正觉现神变故。住一切法念佛门。见一切佛出兴于世以智慧光转法轮故。住自在心念佛门。随其自心所有欲乐。一切如来。现其影像。咸得见故。住一切业念佛门。能随法界一切众生所修行业。为现其身令觉悟故。住一切神变念佛门。见一切佛住于广大香水海中。坐莲华台。普现神变。满十方故。住等虚空界念佛门。观察如来所现身云庄严法界虚空界故。如是等无量无数念佛门。而我云何能知能说彼功德行。善男子。南方有国。名曰海门。彼有比丘。名为海云。汝往彼问。菩萨云何学菩萨行。修菩萨道。海云比丘。能善分别开发广大善根因缘。当令汝入广大助道位。当令汝成广大善根力。当为汝说发菩提心因。当令汝生广大乘光明。当令汝得广大波罗蜜。当令汝入广大诸行海。当令汝转广大誓愿轮。当令汝净广大庄严门。当令汝起广大慈悲力。时善财童子。礼吉祥云比丘足。绕无数匝。殷勤瞻仰。恋慕而去

大方广佛华严经卷第四大方广佛华严经卷第五

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。闻善知识教。一心正念。随顺思惟所有智慧光明门。随顺通达所有甚深解脱门。随顺忆持所有自在三昧门。随顺敬奉所有清净教诲门。随顺观察所见诸佛威德门。随顺欣乐所见诸佛住处门。随顺解了所见诸佛轨则门。随顺思念所见诸佛出现门。随顺趣入所见诸佛法界门。随顺安住所见诸佛境界门。渐次南行。向海门国。诣海云比丘所。顶礼双足。绕无数匝。于前合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。欲入甚深最上智海。而未知菩萨云何能具菩萨行。长养菩提种。云何能舍凡夫家。生于如来家。云何能度生死海。入佛智慧海。云何能离凡愚地。入佛最胜地。云何能断生死流。入佛净行流。云何能坏生死轮。成就大愿轮。云何能灭魔境界。显示佛境界。云何能竭爱欲海。增长大悲海。云何能闭三涂八难门。开人天涅槃门。云何能出三有系缚城。入种智解脱城。云何能弃舍一切珍玩资具。饶益摄受一切众生。唯愿慈哀。为我宣说。时海云比丘。告善财言。善男子。汝已发阿耨多罗三藐三菩提心耶。善财言唯。我已先发阿耨多罗三藐三菩提心。海云告言。善哉善哉。善男子。发菩提心者。不可得闻。何况自能深心发趣。善男子。若诸众生。未曾修种深固善根。则不能发阿耨多罗三藐三菩提心。是故菩萨。要得平等无碍境界普门善根光明照故。要得真实巧方便藏正道三昧光明照故。要得积集功德海藏广大福聚庄严身故。要得增长种种白法。念念出生无休息故。要能供事真善知识。咨问法要。无疲厌故。要舍悭吝。无所藏积。于身命财。无爱着故。要离憍慢。心无高下。安住不动。如大地故。要恒慈愍。随顺众生。平等饶益。无违逆故。要处生死。于恶趣中。度苦众生。心不舍故。要恒观察如来境界。欣求修习。至究竟故。要恒利益安乐一切诸众生故。如是乃能发菩提心。发菩提心者。所谓拔济苦恼诸众生故。发大悲心。平等福祐诸众生故。发大慈心。除灭众生诸苦蕴故。发安乐心。为息众生不善心故。发饶益心。救护怖畏诸众生故。发哀愍心。舍离执着障碍法故。发无著心。普遍法界诸佛刹故。发广大心。等虚空界无不往故。发无边心。见一切佛妙色身故。发无垢心。观三世法智无尽故。发清净心。为欲普入一切智智甚深海故。发大智心。发如是等种种心故。是名菩萨发菩提心

善男子。我初止住此海门国。十有二年。常以十事。观察大海。而为境界。所谓思惟大海宽广难量。思惟大海深难得底。思惟大海同一碱味。思惟大海出生众宝。思惟大海吞纳众流。思惟大海水色差别不可思议。思惟大海种种众生之所依住。思惟大海容受无量大身众生。思惟大海能受大云所雨之雨。思惟大海究竟恒满无有增减。善男子。我复思念世间之中。颇有深广过此海不。乃至容受常无增减。过此海不。善男子。我作如是思惟之时。从大海中。有大莲华。众宝庄严欻然出现。以无能胜帝青颇胝迦金刚摩尼王宝为茎。毗琉璃摩尼王宝为台。无垢清净阎浮檀金为叶。随时芬馥。白栴檀香沉水妙宝。而为其藏。黄色映彻码瑙宝王。以为其须。百万摩尼宝庄严网。罗布其上。凡所庄校。周圆无际。光荣四照。弥覆大海。百万欲天王。普雨种种天宝天华。天鬘天香。天烧香。天涂香。天末香。天妙衣服。天幢幡盖。如云而下。百万龙王。起大香云。雨众香水。百万夜叉王。献以种种珍奇宝藏。百万罗刹王。各以慈心。合掌观察。百万乾闼婆王。以妙乐音。歌咏赞叹。百万阿修罗王。执持其茎。曲躬而立。百万迦楼罗王。衔诸璎珞。妙宝缯带。四面垂下。百万紧那罗王。起饶益心。欢喜爱乐。百万摩睺罗伽王。起清净心。恭敬礼拜。百万人王。起殷重心。合掌瞻仰。百万转轮圣王。各以七宝庄严供养。百万梵天王。头顶礼敬。百万净居天。恭敬合掌。百万主海神。俱时出现。恭敬作礼。百万主火神。各持种种妙宝庄严。百万味光摩尼宝。光明普照。百万净福摩尼宝。布散庄严。百万遍照摩尼宝。为清净藏。百万离垢藏摩尼宝。其光赫奕。百万吉祥藏摩尼宝。放妙光明。百万妙藏摩尼宝。光照无边。百万阎浮幢摩尼宝。周布行列。百万不可坏金刚摩尼宝。清净庄严。百万日藏摩尼宝。广大清净。圆光普照。百万可爱乐摩尼宝。显现众色。具足庄严。百万心王摩尼宝。放杂色光。雨无尽宝。此大莲华。所有庄严。皆从如来过去积集出世广大善根所生。令诸菩萨。各于此华。信愿成满普于十方一切世界。无不显现。从如幻观香王业生。以无生法。所庄严故。从如梦观离相法生。以无作法之所印故。从无染着离诤法生。随境观察。无所著故。恒出妙音。演说如来广大境界。其声充满一切诸佛清净刹土。假使无数百千亿劫。以妙辩才。称赞此华功德无尽善男子。我时于此莲华之上。见有如来结跏趺坐。相好具足。形量高广。上至有顶如来所处。宝莲华座。不可思议。道场众会。不可思议。圆满智慧。不可思议。圆光照耀。不可思议。威仪随现。不可思议。光明炽盛。不可思议。诸相随好。不可思议。变现自在。不可思议。神通调伏。不可思议。清净妙色。不可思议。无见顶相。不可思议。舌相长广。不可思议。辩才善巧。不可思议。圆音普演。不可思议。无量智力。不可思议。清净无畏。不可思议。无碍解智。不可思议。忆念彼佛。往修本行。不可思议。菩提自在。不可思议。法雷震吼。不可思议。普门示现。不可思议。种种庄严。不可思议。随其左右。见各差别。不可思议。普遍饶益。咸令成熟。不可思议

善男子。时彼如来。于莲华上。则伸右手。而摩我顶。为我演说普眼法门。显发一切菩萨诸行。开演一切如来境界。阐扬一切诸佛妙法。光照一切诸佛刹土。圆满一切诸佛相好。摧伏一切外道邪论。散灭一切诸魔军众。能令一切众生欢喜。调伏一切众生烦恼。能照一切众生心行。善了一切众生根性。能以威力。普转法轮。随众生心。悉令开悟。我从彼佛。得闻于此普眼法门。受持读诵。忆念思惟。假使有人。以大海量墨。须弥聚笔。书此无尽广大海藏普眼法门。一品中一门。一门中一法。一法中一义。一义中一句。乃至少分。尚不可得。何况尽能具足书写。善男子。我于彼佛。千二百岁。受持如是普眼法门。相续不断。于日日中。常以十种陀罗尼门。领受记持十无数品。所谓以闻持陀罗尼光明。领受无数品。以寂静门陀罗尼光明。趣入无数品。以无边旋陀罗尼光明。普入无数品。以随地观察普遍照耀陀罗尼光明。分别无数品。以具足威力陀罗尼光明。普摄无数品。以莲华庄严陀罗尼光明。引发无数品。以微妙言音陀罗尼光明。开演无数品。以虚空藏陀罗尼光明。显示无数品。以光聚山陀罗尼光明。增广无数品。以海藏普持陀罗尼光明。辨析无数品。善男子。是时十方一切世界。各有无量诸众生等。为听法故。而来我所。所谓天王。龙王。夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王。梵王。如是诸王。并其眷属。来诣我所。咨问我法。我悉为其次第开演。分别解说。咸令欢喜。心生爱乐。深信趣入。悟解成就。安住于此诸佛菩萨光明妙行普眼法门。善男子。我唯知此普眼法门。如诸菩萨摩诃萨。深入一切菩萨行海。随其愿力。皆清净故。深入一切广大愿海。尽一切劫。住世间故。深入一切诸众生海。随其心行。普饶益故。深入一切众生心海。出生无碍十力智故。深入一切众生根海。随时调伏令成熟故。深入一切同异刹海。为满本愿悉严净故。深入一切无尽佛海。常愿承事。兴供养故。深入一切正觉法海。能以智慧。咸悟入故。深入一切佛功德海。于真实道。具足修故。深入一切诸言辞海。遍一切刹。转法轮故。而我云何。能知能说彼功德行。善男子。从此南行。六十由旬。楞伽道边。有一聚落。名为海岸。彼有比丘。名曰妙住。汝诣彼问。菩萨云何。令菩萨行速得清净。时善财童子。礼海云足。右绕瞻仰。辞退而去

尔时善财童子。随顺思惟善知识教。专心忆念普眼法门。专念如来神变威力。忆持微妙法句身云。趣入无边法门教海。观察善友威仪法式。游泳甚深法海漩澓。普遍趣入虚空法界。净治法眼所有翳障。捃拾善友所集法宝。如是作意。渐次南行。至楞伽道海岸聚落。观察十方。周遍求觅妙住比丘。见彼比丘在虚空中。经行来往。不思议数诸净居天与宫殿俱。于虚空中。恭敬合掌。发弘誓愿。而为供养。不思议数诸梵天王。曲躬合掌。出妙音声。以人间法。称扬赞叹。而为供养。无数千万欲界诸天。及诸天王。恭敬围绕。满虚空中。布天华云。雨天华雨。作天妓乐。出妙音声。无数缯绮。宝幢幡盖。种种严饰。悉遍虚空。而为供养。复有无数诸大龙王。于虚空中。兴不思议沉水香云。普遍虚空。震雷激电。而为供养。无量不思议数诸夜叉王。各以眷属。周匝围绕。恭敬守护而为供养。无量不思议数诸罗刹王。与诸眷属。其形长大。甚可怖畏。咸起慈心亲近瞻仰。而为供养。无量阿修罗王。兴不思议摩尼宝云。放大光明。遍满虚空。雨种种宝。庄严照耀。而为供养。无数迦楼罗王。作童子形。诸妙采女。之所围绕。起大慈愍。无杀害心。恭敬合掌。而为供养。无数紧那罗王。拊击众乐。演出种种微妙音声。复以种种称法言辞。歌咏赞叹。而为供养。无数摩睺罗伽王。持不思议上妙微细天诸衣服。亲近随逐。周回布列。而为供养。无量主海神。作诸妓乐。啸和雅音。而为供养。善财童子。见此比丘。于虚空中。经行自在复有如是。供养之事。充满虚空。欢喜踊跃。不能自持。五体投地。一心敬礼。良久乃起。合掌白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何勤求佛法。云何积集佛法。云何满足佛法。云何熏习佛法。云何修行佛法。云何净治佛法。云何随顺佛所行法。云何通达佛算数法。云何增长佛普遍法。云何清净佛究竟法。云何总摄佛功德法。云何能入佛随顺法。我闻圣者。善能诱诲。唯愿慈悲。为我宣说菩萨云何恒见诸佛。闻法勤修。而不舍离。菩萨云何恒同一切菩萨善根。而不舍离。菩萨云何恒以智慧。证诸佛法。而不舍离。菩萨云何恒以大愿。饶益众生。而不舍离。菩萨云何恒修一切菩萨事业。而不舍离。菩萨云何恒住劫海。修行无厌。而不舍离。菩萨云何恒住刹海。普遍庄严。而不舍离。菩萨云何恒依佛力。悉能知见诸佛神变。而不舍离。菩萨云何恒于六趣。自在受生。住无住道。而不舍离。菩萨云何恒受诸佛正法云雨。悉能忆持。而不舍离。菩萨云何恒发智光普照三世佛所行处。而不舍离。唯愿慈哀。为我开演

尔时妙住比丘。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。今复志求一切智法。及自觉法。善男子。汝能发心。深信爱乐。殷勤不舍。请问于我。汝当谛听。今为汝说。善男子。我得菩萨普遍速疾勇猛不空供养诸佛成熟众生解脱门。常于此门。若行若止。修习思惟。或入或出。随顺观察。即时获得智慧光明。名普照诸法。究竟无碍。由得如是智光明故。知诸众生种种心行。无所挂碍。知诸众生种种殁生。无所挂碍。知诸众生宿住之事。无所挂碍。知诸众生未来劫事。无所挂碍。知诸众生现在世事。无所挂碍。知诸众生种种言音随俗差别。无所挂碍。知诸众生种种疑网咸为决了。无所挂碍。知诸众生种种根性受法差别。无所挂碍。知诸众生应受化时悉往调伏。无所挂碍。知诸时分。刹那腊缚。牟呼栗多。昼夜年劫。延促相入。无所挂碍。知三世海诸法流转相续次第。无所挂碍。知诸佛刹无量差别。能以其身。遍往十方。无所挂碍。何以故。以得无住无作无行神通力故。善男子。我以得此神通力故。于虚空中。或行或住。或坐或卧。乃至现作种种威仪。隐显自在。或以一身分为多身。或以多身合为一身。或以其身来往入出。穿度石壁。而无障碍。或于空中。结跏趺坐。自在往来。犹如飞鸟。入地如水。履水如地。遍身上下。普出烟焰。光明炽盛。如大火聚。或时震动一切大地。或时以手扪摸日月。或现威德。超自在天。或现大身过于梵世。或以神力。转变自在。或现烧香云。盘旋如盖。弥覆十方。或现宝焰云。光明炽盛。普照一切。或现变化云。其身随类等众生界。或现光网云。具足众色。映彻无碍。或现其身。于一念顷。过于东方一世界。十世界。百世界。千世界。百千世界。亿世界。百亿世界。千亿世界。百千亿世界。百千亿那由他世界。乃至无数世界。无量世界。无边世界。无等世界。不可思世界。不可量世界。不可称世界。不可说世界。不可说不可说世界。乃至。或过阎浮提极微尘数世界。乃至过不可说不可说佛刹极微尘数世界。如是一切世界海中。所有一切世界出生中。一切世界方处中。一切世界旋转中。一切世界普遍中。一切世界变化中。一切世界名字中。一切世界法门中。一切世界时劫中。一切世界微细中。一切世界菩提场中。一切世界庄严具中。一切世界大众会中。如是一切种种世界。其中所有一切刹土。皆有如来现成正觉。彼诸如来。一一复现一切佛刹极微尘数大众集会差别之身。我悉于彼一切佛所。普现其身。于一一身。普雨一切诸佛刹海极微尘数诸供养云。所谓一切华云。一切香云。一切鬘云。一切盖云。一切幢云。一切幡云。一切帐云。一切网云。一切末香云。一切涂香云。一切衣服云。以一切身。各持如是诸供具云。而为供养。一一如来所转法轮种种宣说。所谓。广说。略说。赞说。毁说。明了说。隐密说。有余说。无余说。不定说。决定说。我皆悟解。忆念受持。一一国土。诸佛刹海。所有庄严。我皆忆持。曾无忘失。如于东方。南西北方。四维上下。亦复如是。善男子。如是一切诸世界中。所有众生。若闻我名。若见我身。或睹经行止住之处。或以一心。礼拜供养。或时散乱怀疑不信。如是一切。皆决定于阿耨多罗三藐三菩提。得不退转。彼诸世界一切众生。我皆明见。随其大小。胜劣苦乐。示同其形。随所应度。教化调伏而成熟之。随有众生亲近我者。悉令安住如是法门。善男子。我唯知此普遍速疾勇猛不空供养诸佛成熟众生无碍解脱门。如诸菩萨摩诃萨。具足受持大慈悲戒。波罗蜜戒。住大乘戒。不离菩萨道戒。不着一切法戒。不舍菩提心戒。不堕二乘地戒。常以佛法为所缘戒。心常忆念一切智戒。所发志乐等虚空戒。一切世间无所依戒。不缺漏戒。不浊乱戒。无遗失戒。不杂染戒。不追悔戒。无厌怠戒。清净戒。离尘戒。无垢戒。如是菩萨。戒行功德无量无边。而我云何能知能说。善男子。从此南方。有一国土。名达逻比叱。其国有城。名金刚层。中有大士。名曰弥伽。汝往彼问。菩萨云何。学菩萨行云何修菩萨道。时善财童子。礼妙住足。右绕瞻仰。辞退而去。尔时善财童子。一心随顺善知识教。正念观彼法光明门。以清净心深信趣入。念法威力顺佛所行。专心忆持。绍三宝种。叹离欲性。念善知识。普遍观察。照明三世。忆本大愿。随顺修行。以无碍心。入众生界。常勤作意。救护世间。于诸有为。心无倚着。观一切法根本自性。念念流入一切智海。普遍严净一切佛刹。于诸如来道场众会。心无依住。如是观察。渐次南行。至达逻比吒国。入金刚层城。周遍求觅。弥伽大士。乃见其人于市肆中处高台上坐师子座。十千人众所共围绕。广说轮字庄严法门。善财往诣。顶礼其足。绕无数匝。恭敬合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。云何流转诸趣。常不忘失菩提之心。云何心得坚固。勤求佛法。无有厌倦。云何获得清净谦下之心。无能坏者。云何得大悲心力。恒处生死。不惮劬劳。云何得陀罗尼力。自在摄持普门清净。云何发生广大智光。离诸翳障。云何得妙辩才。善巧决择甚深法藏。云何得正念力。忆持诸佛一切法轮。云何得净趣力。演一切法。普净诸趣。云何得成菩萨普遍智力。于一切法。种种分别。悉能决定。了真实义。唯愿慈哀。为我宣说。尔时弥伽。告善财言。善男子。汝已先发阿耨多罗三藐三菩提心耶。善财白言。唯然。大士。我已先发阿耨多罗三藐三菩提心。弥伽遽即下师子座。由为尊重菩提心故。于善财前。五体投地。一心礼敬。从地而起。散金银华无价宝珠。及以上妙碎末旃檀。复以杂彩无量宝衣。以覆其上。复散无数殊胜光洁悦意香华众妙供具。而为供养。然后合掌。以柔软音。而称赞言。善哉善哉。善男子。汝乃能发阿耨多罗三藐三菩提心。善男子。若有能发阿耨多罗三藐三菩提心者。则为勤求一切智智不断佛种。则为永离一切世间凡夫种性。则为严净一切诸佛所有刹土。则为调伏一切众生令其成熟。则为觉了一切法性出生死海。则为照解一切业种无所依着。则为勤修一切菩萨所有妙行。则为已发一切大愿无有断绝。则为随顺一切种智离欲行处。则为获得一切菩萨坚固种性。则为已得一切诸佛威力加持。则能明见一切三世所有差别。则为十方一切如来共所护念。则与法界一切菩萨志乐平等。则得一切贤圣咸共称赞。则得一切梵王一心礼觐。则得一切天王恭敬供养。则得一切夜叉王常勤守护。则得一切罗刹王随逐侍卫。则得一切诸大龙王迎接奉事。则得一切紧那罗王歌咏赞叹。则得一切诸世间主同心庆悦。则令一切诸众生界悉得安隐。所谓令断一切恶趣流转故。令舍一切诸苦难处故。令息一切贫穷根本故。令生一切人天快乐故。令得亲近供养一切善知识故。令得听闻受持诸佛广大法故。能令修集一切菩萨菩提分法故。能令增长一切功德善法根芽故。能令熏发一切菩萨无漏智种故。能令智光普照一切差别智道故。能令究竟住于菩萨真实智地故。善男子。如是菩萨。难得出世。亦难值遇。诸有所作。难识难知。能为众生。作甚难事。若得见者。倍更为难。何以故。菩萨出世。与诸众生。为大利益。如父母。长养安慰令成就故。如璎珞。庄严一切诸天人故。如船师。于生死海度众生故。如屋宅。覆护一切诸世间故。如商主。能导群生至宝所故。如赫日。智慧光明能普照故。如君主。觉法城中得自在故。如炽火。能烧众生我爱薪故。如大云。普霔无边甘露雨故。如时雨。增长信等善根芽故。如船舫。运度众生达彼岸故。如桥梁。能度众生越生死故。如津济。显示一切出要道故。如风轮。能持众生不令堕落三恶趣故。如大地。悉能增长一切众生诸善根故。如大海。具足一切无尽福智功德藏故。如满月。普放智光破烦恼暗施清凉故。如猛将。悉能摧伏一切魔军令退散故。如须弥。胜智善根超出深广生死海故。尔时弥伽。广为善财。称赞显示发菩提心大功德力。令诸众会皆生欢喜。同声唱言。善哉善哉。善男子。今我众会因见胜人。得闻菩萨功德行愿。踊跃欢喜。不能自持。是时弥伽。还升本座。从其面门。放种种光。普照三千大千世界。时此世界诸大梵王。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。如是诸王并其眷属。蒙光照耀靡不来集。是时大士。观察众心。咸生恭敬。离诸谄慢。其心寂静。志意柔顺。随其乐欲。广为分别开示解释轮字句品庄严法门。彼诸众生。闻此法已。信顺悟入。皆于阿耨多罗三藐三菩提。得不退转。所应作已。告善财言。善男子。我已成就妙音陀罗尼光明法门。于一念中。能分别知三千大千世界所有欲色诸天语言。差别秘密。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。所有语言。差别秘密。亦知彼彼一切众生所有心想种种乐欲。差别秘密。所谓了知色界梵王及诸梵众。所有心乐。差别秘密。亦知欲界诸大天王。天子天女。所有心乐。差别秘密。亦知龙等人及非人男女眷属所有心乐。差别秘密。亦能知此三千大千世界。一切声闻。及辟支佛。所有向果。各各修习。一切菩萨行愿地位。各各修习微细意趣。差别秘密。及诸言辞。分别解说。辨释文义。无不明了。亦能了知三世诸佛为诸众生演说一切甚深法海。种种言辞。意趣秘密。如于一念。知此世界所有众生。及诸贤圣。言辞心想。行愿地位。各各差别。微细秘密。亦知东方一十百千万亿那由他。无数无量无边无等。不可数。不可称。不可思。不可量。不可说。不可说不可说诸世界中。所有众生及诸贤圣。言辞心想。行愿地位。微细秘密。南西北方。四维上下。各尽不可说不可说。诸世界中所有众生。及诸贤圣。言辞心想。行愿地位。各各差别。微细秘密。如是一切悉能了知。无不通达。善男子。我唯知此妙音陀罗尼光明法门。如诸菩萨摩诃萨。普能随入一切众生种种想行眷属海。普能随入一切众生种种建立施设海。普能随入一切众生种种称谓名字海。普能随入一切众生种种方俗语言海。普能随入一切诸佛甚深秘密法句海。普能随入一切诸佛究竟最上法句海。普能随入一切诸佛于一所缘中说一切三世所缘法句海。普能随入一切诸佛于一切语言中演说一切增上法句海。普能随入一切诸佛于一切语言中演说一切上上法句海。普能随入一切诸佛于一切语言中演说广大差别法句海。普能随入一切诸佛于一切语言中演说一切差别善巧调伏法句海。普能随入一切诸佛于一切世界中演说种种咒术言辞差别秘密海。普能随入一切世界种种众生音声语言际。普能随入一切诸佛清净法轮圆满庄严际。普能随入一切世间种种字轮。普遍出生显示诸法际。如是菩萨行智功德。而我云何能知能说。善男子。从此南方。有一聚落。名为住林。彼有长者。名住解脱。汝往彼问。菩萨云何修集菩萨道。菩萨云何出生菩萨德。菩萨云何成就菩萨行。菩萨云何思惟菩萨法。时善财童子。蒙善知识深心诲诱。于一切智法。深生尊重。于一切善根。增益信乐。于一切佛法。倍起精勤。于一切善知识教。普加随顺。礼弥伽足。悲泣流泪。绕无量匝。恋慕瞻仰。辞退南行

大方广佛华严经卷第五大方广佛华严经卷第六

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。随顺思惟。一心专念彼诸菩萨微妙辩才庄严法门。一心专念彼诸菩萨言辞教海。一心专念彼诸菩萨微细方便。一心专念彼诸菩萨清净解脱。一心专念彼诸菩萨善根光明。一心专念彼诸菩萨清净善巧。一心专念彼诸菩萨摄众生智。一心专念彼诸菩萨广大智力。一心专念彼诸菩萨勇猛不退。一心专念彼诸菩萨殊胜志乐。一心专念彼诸菩萨无量功德。一心专念彼诸菩萨无碍法门。如是思惟。弘誓坚固。勇猛精进。而为甲胄。以正信力。恒自庄严。勤求正法。心无疲厌。志愿坚固。犹若金刚及那罗延。无能坏者。恒于一切善知识教。奉顺修行。常无间断。于诸境界。心无染着。普门妙行。皆悉现前。普眼智光。照诸法海。圆满诸地陀罗尼门。现见十方。了法边际。以无碍智。普遍庄严。证解清净无依法性。显示无对无二法门。超过一切最胜彼岸。入净智门。永离诸想。能审观察诸法实际。普知三世差别法门。普往十方差别世界。普见十方差别佛身。普入十方差别时劫。普观十方差别业性。普转诸佛差别法轮。普智三昧明照其心。心恒普入平等境界。如来慧光。照触其身。一切智流。相续不断。若身若心。势力自在。常不舍离一切佛法。以深信力。常得诸佛威神所加。以净慧力。为诸如来光明所照。以誓愿力。愿身周遍一切刹网。一切法界。普入其身。渐次游行。经十二年。至住林城。周遍询求解脱长者。既得见已。五体投地。顶礼双足。起立合掌。白言圣者。我今得与善知识会。是我获得广大善利。何以故。善知识者。难可出现。难得闻名。难得逢值。难得亲近。难得承接。难得同住。难得奉事。难令喜悦。难蒙开晓。难得随逐。我今会遇真善知识。是我获得最胜善利。如是展转难中之难。圣者。我已先发阿耨多罗三藐三菩提心。为欲值遇一切佛兴故。为欲普闻一切佛名故。为欲普见一切佛身故。为欲普诣一切佛刹故。为欲普入一切佛会故。为欲普观一切佛境故。为欲普知一切佛意故。为欲普受一切佛记故。为欲普承一切佛力故。为欲普事一切诸佛故。为欲证悟一切佛法故。为欲随顺一切佛心故。为欲圆满一切佛愿故。为欲获得一切三昧故。为欲照明一切佛智故。为欲庄严一切佛会故。为欲遍修诸佛本行故。为欲现见诸佛神通故。为欲具证诸佛智力故。为欲清净诸佛无畏故。为欲听闻一切佛法故。为欲受持诸佛法轮故。为欲辨析一切佛法故。为欲住持诸佛教海故。为欲守护诸佛法城故。为欲观察佛所觉法故。为欲解悟佛所证法故。为欲深入佛所知法故。为欲见一切佛法于自身中出生故。为欲与一切菩萨同体故。为欲与一切菩萨同类故。为欲等一切菩萨善根故。为欲观一切菩萨所学故。为欲同一切菩萨净行故。为欲成一切菩萨所修故。为欲满一切菩萨波罗蜜故。为欲发一切菩萨清净愿故。为欲入一切菩萨大愿海故。为欲具一切菩萨大悲力故。为欲至一切菩萨究竟处故。为欲获得诸佛菩萨差别威神藏故。为欲获得一切菩萨智慧光明无尽藏故。为欲获得一切菩萨广大功德三昧藏故。为欲获得一切菩萨无量威力藏故。为欲获得一切菩萨无量神通藏故。为欲获得一切菩萨大神变藏无穷尽故。为欲获得一切菩萨大自在藏常现前故。为欲获得一切菩萨净妙色藏而庄严故。为欲获得一切菩萨大慈悲藏教化众生。皆令究竟达彼岸故。圣者。我今以如是心。如是意乐。如是希欲。如是勤求。如是思惟。如是渴仰。如是尊重。如是方便。如是勇猛。如是究竟。如是谦下。来至圣者善知识所。我闻圣者。善能诱诲诸菩萨众。能以方便开佛境界。示其道路。指其津济。与其桥梁。授其船筏。普令一切截愚痴网。除颠倒障。拔疑惑箭。涤烦恼垢。照心稠林。破心迷执。令心洁白。正心谄曲。除心热恼。使心清凉。回生死流。趣涅槃道。令心远离诸见牢狱。令心解脱贪欲系缚于染爱处。令心动转随顺。趣入一切智性。令其疾到广大法城。令其坚固无上大悲。令其安住究竟大慈。令其发起诸菩萨行。令其修集诸三昧门。令其悟入圣所证位。令其观察诸法本性。令其增长普贤愿力。于诸众生其心平等。唯愿慈哀。为我宣说。菩萨云何学菩萨行。修菩萨道。随所修习。疾得清净。疾得明了。具足圆满。时解脱长者。以过去积集善根力故。如来现在威神力故。文殊师利童子忆念力故。十方一切诸善知识本行愿力所加持故。即入菩萨胜三昧门。其三昧名普摄无边一切佛刹旋陀罗尼。入三昧已。其身清净。光明映彻。于其身中。显现十方各十佛刹极微尘数佛。及佛刹净妙庄严。众会道场光明等事。亦现彼佛往昔同行诸菩萨众。往昔所现神通变化。往昔所发广大誓愿。往昔所修助道之法。往昔所净诸出离道。往昔所有清净庄严。往昔所修诸菩萨行。亦见彼佛成等正觉。转妙法轮。教化众生。如是一切悉于身中。分明显现。无有障碍。亦于身内一切刹中。普现其身。无不充遍。身与佛刹互相涉入。不相障碍种种色像。而无往来一一差别。次第而住不相杂乱。所谓种种佛刹各别庄严。种种众会眷属圆满。种种威仪恭敬供养。种种道场各各严饰其中诸佛。示现种种游戏神通。建立种种差别乘道。显示种种广大愿门。普遍庄严种种神力。或一世界。示现上生处兜率宫。而作佛事。或一世界。殁兜率天。下入王宫。而作佛事。或现处胎种种神变。或现诞生种种瑞相。或现婴孩种种游戏。或示童子现处内宫。或现出家。示行苦行。或诣觉树。坐于道场。或现神通破魔军众。或现自在成无上道。或现诸王劝请说法。或现受请转妙法轮。或现天龙乾闼婆等。恭敬围绕。常随守护。或现其身遍入诸趣。或往一切众生住处。或时示现度众生已。入般涅槃为令世间咸增恋慕。或现舍利。全身碎身。分布人天令兴福祐。或遍人天。起大塔庙。庄严国界。饶益众生。彼诸如来。于种种世界。种种趣生。种种部类。种种众会。种种根器。种种乐欲。种种业行。种种信解。种种根力。种种修习。种种行愿。种种觉悟。种种心想种种烦恼随眠习气。如是一切众生海中。以佛威力。广现神通。遍一切处。施作佛事。所谓或处极微尘量道场。或处无边广大道场。或处一由旬量道场。或处十由旬量道场。乃至或处与不可说不可说佛刹极微尘数诸世界海。其量正等众会道场。以种种神通。种种音声。种种言辞。种种辩才。种种训释。于诸如来圣谛海中。以种种无畏大师子吼。为种种众生。演说种种修多罗海。开示种种陀罗尼门。普转种种如来法轮。普授种种诸菩萨记。彼诸如来所说法门所出言音。善财童子。悉能听受。忆持不忘。思惟观察。亦见诸佛及诸菩萨不可思议诸三昧门自在神变。尔时解脱长者。现是相已。即从三昧安详而起。告善财童子言。善男子。我已于此甚深无碍庄严解脱门。自在入出。善男子。我住于此解脱门时。即见东方阎浮檀金光明世界。龙自在王如来应正等觉。道场众会之所围绕。毗卢遮那藏菩萨。而为上首又见南方速疾具足诸力世界。遍覆普香王如来应正等觉。道场众会之所围绕。思惟心王菩萨。而为上首。又见西方具足一切香圆满光世界。须弥灯王如来应正等觉。道场众会之所围绕。无碍心菩萨。而为上首。又见北方袈裟幢世界。金刚坚固如来应正等觉。道场众会之所围绕。金刚游步勇猛行菩萨。而为上首。又见东北方一切殊胜妙宝世界。无所得境界眼毗卢遮那如来应正等觉。道场众会之所围绕。无所得妙变化菩萨。而为上首。又见东南方自在香焰光音世界。香灯王如来应正等觉。道场众会之所围绕。金刚焰慧自在妙因王菩萨。而为上首。又见西南方智日焰普光明世界。毗卢遮那普智声如来应正等觉。道场众会之所围绕。普焰垂髻变现香华光菩萨。而为上首。又见西北方普清净妙香庄严藏世界。无量功德海幢圆满光如来应正等觉。道场众会之所围绕。无碍威力身智幢王菩萨。而为上首。又见下方师子腾焰解脱光明世界。无碍法界幢具足智慧焰光如来应正等觉。道场众会之所围绕。法界智焰光明遍照世界幢菩萨。而为上首。又见上方光明遍照次第出现无尽佛世界。名称无边无碍智慧圆满光幢王如来应正等觉。道场众会之所围绕。无碍精进力法界智幢王菩萨。而为上首。善男子。我见如是十佛世尊。而为上首。如是乃至见于十方各十佛刹极微尘数诸佛如来应正等觉。道场众会之所围绕。一一皆有上首菩萨。并诸眷属。分明显现。然彼一切世界如来。不来至此。我身亦不往诣于彼。善男子。我若欲见安乐世界无量寿如来。随意即见。我若欲见白栴檀香世界月智如来。妙香世界宝光明如来。莲华世界宝莲华光明如来。妙金光世界寂静光如来。妙喜世界不动如来。善住世界师子相如来。镜光明世界月觉如来。吉祥师子宝庄严世界毗卢遮那如来。如是十方一切世界所有如来。我若欲见。随意即见。然彼如来。不来至此。我不往彼。善男子。我若欲见尽过去际一切劫中。所有诸佛。及彼佛刹种种庄严。道场众会。神通变化。调伏众生。尽未来际。一切劫海。所有如来。及诸菩萨。庄严国土。众会道场。调伏众生神通变化。如是一切随念皆见。彼诸如来。及彼诸劫。一切佛刹。所有庄严。种种差别。不来至今。我心亦不入彼过未。然其所见。皆如现在。善男子。我能了知十方三世一切如来。及诸菩萨。国土庄严。神通等事。无所从来。亦无所去。无有行处。亦无住处。亦知己身无去无来。无行住处。所以者何。知一切佛及与我心皆如梦故。如梦所见从分别生。见一切佛从自心起。又知自心如器中水。悟解诸法如水中影。又知自心犹如幻术。知一切法如幻所作。又知自心诸佛菩萨悉皆如响。譬如空谷随声发响。悟解自心。随念见佛。我如是知。如是忆念。所见诸佛。皆由自心。善男子。当知菩萨修诸佛法。净诸佛刹。积集妙行。调伏众生。发大誓愿。入一切智自在游戏不可思议解脱法门。得佛菩提。现大神通。遍往十方一切法界。以微细智。普入诸劫。如是一切佛菩萨法。皆由自心。善男子。诸业虚妄。积集名心。末那思量。意识分别。眼等五识。了境不同。愚痴凡夫。不能觉知。怖老病死。求入涅槃。生死涅槃。二俱不识。于一切境。妄起分别。又由未来诸根。五尘境界断灭。凡愚之人。以为涅槃。诸佛菩萨自证悟时。转阿赖耶。得本觉智。善男子。一切凡愚。迷佛方便。执有三乘。不了三界由心所起。不知三世一切佛法自心现量。见外五尘。执为实有。犹如牛羊不能觉知。生死轮中无由出离。善男子。佛说诸法无生无灭。亦无三世。何以故。如自心现五尘境界本无有故。有无诸法本不生故。如兔角等。圣者自悟境界如是。善男子。愚痴凡夫。妄起分别。无中执有。有中执无。取阿赖耶种种行相。堕于生灭二种见中。不了自心。而起分别。善男子。当知自心即是一切佛菩萨法。由知自心即佛法故。则能净一切刹。入一切劫。是故。善男子。应以善法扶助自心。应以法雨润泽自心。应以妙法治净自心。应以精进坚固自心。应以忍辱卑下自心。应以禅定清净自心。应以智慧明利自心。应以佛德发起自心。应以平等广博自心。应以十力四无所畏明照自心。善男子。我唯于此如来甚深无碍庄严解脱法门。自在入出。如诸菩萨摩诃萨。住无碍智。行无碍行。于诸境界。无不通达。现前常得见一切佛广大三昧。住一切佛无涅槃际成正觉门。普遍了知诸三昧海所有境界。能随观察三世诸法悉皆平等。分身遍往一切刹海。入于诸佛无分别处。一切境界皆悉现前。常能观察一切诸法。以圆满智尽能说行一切菩萨功德行愿。于其身中。悉能显现一切世界成坏之相。而于自身。及彼世界。不生二想。如是妙行。而我云何能知能说。善男子。从此南行阎浮提畔。有一住处。名遍无垢。彼有比丘。名曰海幢。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼长者足。右绕观察。思惟瞻仰。称扬赞叹无量功德。念善知识能为救护。于善知识。常生欢喜。依善知识。发起行愿。由善知识。令我开悟。敬善知识。心无违逆。事善知识。无有谄诳。于善知识。心常随顺。于善知识。起慈母想。令我远离一切颠倒。于善知识。起慈父想。令我成就菩萨善法。如是思惟。深生爱乐。悲泣流泪。辞退而去

尔时善财童子。一心正念彼长者教。随顺观察。如说修行。忆持彼不思议菩萨解脱门。思惟彼不思议智慧光明门。深入彼不思议法界次第门。悟解彼不思议遍入普法门。明见彼不思议如来神变。观察彼不思议普入佛刹。深信彼不思议佛力庄严。照现彼不思议菩萨三昧。了达彼不思议差别世界。修集彼不思议菩萨净业。发起彼不思议广大誓愿。如是观察。渐次南行。向阎浮提畔无垢聚落。周遍寻觅海幢比丘。乃见处在经行林侧。结跏趺坐。端身正念。离出入息。无别思觉住不思议广大三昧。以三昧力。现大神通。于其身上。从顶至足。一切肢分。一切毛孔。悉现无量不思议数同自身相一切身云。遍一切处。现一切身。为普供养一切如来故。为普严净一切佛刹故。为普成熟一切菩萨故。为普调伏一切众生故。为普济拔诸苦蕴故。为普除断三恶趣故。为普开示人天路故。为普销灭烦恼毒故。为令众生普入甚深智慧海故。为令众生究竟安住一切智故从两足下。出无数佛刹极微尘数长者居士婆罗门众相似身云。首戴华冠。身垂璎珞明珠系顶。被服庄严。无量童男以为眷属。普往十方一切世界。悉以一切上妙供具。普施众生。所谓普雨一切上味如法饮食。一切上妙杂色宝华。一切衣服。一切璎珞。一切鬘带。一切熏香。一切涂香。一切宝器。一切宫室。一切欲乐资生之具。于一切处。救摄一切贫穷众生。充济所须令其满足。安慰一切苦恼众生。获身心乐令其欢喜。成熟一切善根众生。心意调柔。令其清净究竟无上菩提之道。如是示现充满十方

从其两膝。出现无数百千万亿诸刹帝利。及婆罗门。并其眷属相似身云。皆悉聪慧。具诸艺业。世出世间。无不通达。种种色相。种种形貌。种种衣服上妙庄严。普遍十方一切世界。恒以四摄。摄诸众生。谓与财宝。令其富乐。可意语言。令闻欢喜。或以同事。劝导诱进。如是一切。贫者令足。病者令愈。危者令安。怖者令止。有忧苦者。令其快乐。复以方便。咸使发心。授以正法。令其开悟。速疾令其离诸不善。集众善法。从生死泥。拔济令出。住真实义无畏法中。如是示现。充满十方从其脐轮。出等众生数异道诸仙相似身云。种种形相各别庄严。或服草衣。或衣树皮。皆执澡瓶。威仪寂静。将诸仙众。足步虚空。往返周旋十方世界。咸出无量歌赞之声。称扬诸佛所有功德。或叹菩萨所修梵行。所说妙法。所证清净。其音和雅。美妙清彻。普闻十方无有障碍。调伏成熟一切众生。普摄诸根。不令放逸。令其观察真实境界。或说诸法皆无自性。使其发起一切智心。令其安住究竟实道。或说世间资生言论。或现方域导俗轨仪。种种善巧。随宜化度。开一切智出要法门。令诸众生普得饶益。随其次第。各修其业。如是示现。充满十方

从其两胁。出不思议无数龙王龙子龙女。并其眷属相似身云。现不思议诸龙神变。遍满虚空。所谓雨不思议宝香庄严云。不思议宝华庄严云。不思议宝鬘庄严云。不思议宝盖庄严云。不思议宝幢庄严云。不思议宝幡庄严云。不思议种种妙宝璎珞庄严云。不思议大摩尼宝王庄严云。不思议种种宝座庄严云。不思议天宝严具庄严云。不思议天宝宫殿庄严云。不思议诸天采女歌咏赞叹庄严云。不思议天宝珠网庄严云。不思议摩尼须叶台蕊宝莲华庄严云。不思议一切摩尼宝冠庄严云。不思议无边光焰天宝庄严云。不思议华鬘幢盖天身庄严云。不思议恭敬合掌诸天采女云。不思议含辉吐焰金色莲华云。不思议演说一切诸佛功德大音声云。如是一切。普遍虚空。以为庄严。周遍十方一切世界诸佛道场。而为供养。普令众生皆生欢喜。除烦恼热。得清凉乐。如是示现。充满十方

从其胸臆吉祥相中。出无数佛刹极微尘数阿修罗王。并其眷属相似身云。皆悉示现不可思议巧幻术力。种种神变。充满虚空。所谓能令无量百千万亿世界。皆悉震动。一切山王互相冲击。一切海水皆大涌沸。诸天宫殿无不动摇。诸魔光明无不隐蔽。诸魔军众无不摧伏。普令众生舍离憍慢。心无放逸。除悭嫉垢。息诸怨害。咸起慈心。破烦恼山。竭爱欲海。长无斗诤。永共和善。复以幻力游戏神通。开悟群生。令离贪着。于诸恶法。常乐远离。怖畏生死。欣求解脱。令出世间一切诸趣。令住无上菩提之心。令修菩萨清净妙行。令趣菩萨波罗蜜道。令入一切诸菩萨地。令照菩萨微妙法门。令观菩萨方便善巧。如是示现。遍周法界

从其背出无量阿僧祇佛刹极微尘数声闻独觉相似身云。为诸众生应以二乘而受化者。广说法要。令其调伏。所谓为执我者。说无有我。为执常者说行无常。为贪行者。说不净观。为嗔行者。说慈心观。为痴行者。说缘起观。为等分者。说与智慧。相应境界。各别对治。令遍观察。为于境界生乐著者。说离诸着无所有性。为遍耽滞五欲境界说离诸欲无染着性。为着寂静定所系者。说大愿门。令深爱乐。誓普饶益一切众生转于法轮。尽未来际。令诸众生所愿皆满。如是遍周一切法界从其两肩。出阿僧祇佛刹极微尘数夜叉罗刹王。种种形貌种种色相长短广狭。种种仪容威势雄猛甚可怖畏无量眷属。而自围绕。现种种神力。吼种种大声。随其所应。作种种方便。遍满十方一切世界。守护一切善行众生。及诸贤圣菩萨众会说法道场。诸有受持菩萨净行。欣求如来一切正智。若向正住。及正住者。或时现作执金刚神。守护诸佛。承事供养。及佛住处。或遍守护一切世间。令其不入一切恶道。有恐怖者。令得安隐。有疾病者。令得除差。在厄难者。令除苦恼。有过恶者。令自厌悔。有灾横者令其息灭。积集福智大心众生。令其能转诸佛法轮舍生死轮。住正法轮。摧灭一切异道邪论。如是利益。遍满十方一切法界

从其腹。出无量百千阿僧祇佛刹极微尘数紧那罗王。各与无数百千万亿紧那罗女。眷属围绕。无量佛刹极微尘数乾闼婆王。各与无数百千万亿乾闼婆女。眷属围绕。各奏无数阿僧祇百千天乐。歌咏赞叹一切诸法。缘生实性。歌咏赞叹一切诸佛难思功德。歌咏赞叹发菩提心普遍威力。歌咏赞叹一切菩萨修圆满行。歌咏赞叹一切诸佛成正觉门。歌咏赞叹一切诸佛转法轮门。歌咏赞叹一切诸佛现神变门。歌咏赞叹一切诸佛般涅槃门。歌咏赞叹守护一切诸佛教门。歌咏赞叹令诸众生皆欢喜门。开示演说严净一切诸佛刹门。开示演说一切诸佛微妙法门。开示演说照一切法无障碍门。开示演说发起一切诸善根门。如是利益。充满十方

从其面门。出无量百千阿僧祇佛刹极微尘数转轮圣王。七宝具足。四兵围绕。放大舍光。雨无尽宝。最胜摩尼。庄严世界。普施众生。咸令充足。令断十恶。修行十善。所谓一切屠猎渔捕暴恶众生。令起慈悲。不断生命。贫乏苦恼下劣众生。令其永舍不与取行。常行惠施。能舍无量百千万亿端正采女。心无吝惜。令诸众生。永断邪淫。修持梵行。虚诳众生。令其究竟常真实语。不作虚诳无益谈说。令摄他语。不行离间。常乐和合。无有乖诤。令柔软语。无有粗恶。杂秽语者。令常演说甚深决定明了之义。顺佛法语。利益修行。永断绮饰无义言辞。令诸众生。深入法句。多贪欲者。令其少欲修习知足。最胜端严无生正行。多怒害者令除嗔恚。于诸众生。恒起慈心。心无瑕垢。为说大悲。欢喜摄受。令入佛法。堕见网者。为说实义。令观诸法。深入因缘。善明谛理。决择正邪。令心清净。拔邪见刺。破疑惑山。令诸众生悟心实性。具足通达趣入甚深。一切障碍。悉皆除灭。如是所作。充满法界

从其两目。出无量百千阿僧祇佛刹极微尘数广大日轮。放大光明。普照一切诸大地狱。所有苦恼。悉令除灭。又照一切世界中间。令除黑闇睹见光明。又照一切十方世界饿鬼傍生。令其舍离愚痴翳障。得大智慧。拔除众苦。复于一切垢浊世界。放清净光。白银世界放黄金光黄金世界放白银光。琉璃世界放玻璃光。玻璃世界放琉璃光。砗磲世界放码瑙光。码瑙世界放砗磲光。赤珠世界放日藏摩尼王光。日藏摩尼王世界放赤珠光。帝青世界放月藏焰网摩尼宝王光。月藏焰网摩尼宝王世界放帝青光。纯宝所成世界放杂宝光。杂宝所成世界放纯宝光。如是光明。普照佛刹道场众会。而作佛事。照诸众生心之稠林。办诸众生无量事业。严饰一切世间境界。令诸众生心得清凉。生大欢喜。安隐快乐。如是所作。充满法界

大方广佛华严经卷第六大方广佛华严经卷第七

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时海幢比丘。从其眉间白毫相中。出无量百千阿僧祇佛刹极微尘数帝释天王。威德光明。超过天众。舍离世间一切欲乐。于诸境界。而得自在。摩尼宝珠。以系其顶。身光映蔽诸天宫殿。震动一切须弥山王。觉悟一切放逸天众。叹福德力。说智慧力。生其乐力。持其志力。增其所有清净念力。坚其所发菩提心力。赞乐见佛。令除世欲。赞乐闻法。令厌世间。赞乐观智令绝世染。止修罗战。断烦恼诤。灭怖死心。发降魔愿。兴立正法须弥山王。成辨众生一切事业。念念调伏无量众生。如是所作。周遍法界

从其额上。出无量百千阿僧祇佛刹极微尘数诸梵天王。色相端严。世间无比。威仪寂静。言音美妙。请佛转法。叹佛功德。令诸菩萨心生欢喜。能办众生无量事业。如是普遍十方法界

从其头上。出无量百千阿僧祇佛刹极微尘数诸菩萨众。皆以相好。庄严其身。其诸菩萨。各于其身肢节毛孔。一切普放大光明云。显现诸佛往昔所行菩萨行海。宣说菩萨种种妙行。所谓普遍十方一切世界。称扬赞叹一切诸佛往昔所行檀波罗蜜。施者受者。及所施物。并所随顺相应行海。示导一切悭吝众生。永离悭着。成就舍心。常行惠施。摄取众生。令住无上檀波罗蜜。显示诸佛相好功德。令得众宝庄严世界。及示依正所出生因令诸众生爱乐修习。普遍十方一切世界。称扬赞叹一切诸佛往昔所行尸波罗蜜。并所随顺相应行海。令诸众生于五欲境。深生厌离。于诸佛境。专意趣求。除颠倒想。恒正思惟。断邪分别。永离诸恶。念菩萨戒。摄诸众生。住大慈悲。称赞解脱。护持如来究竟戒品。普令众生住于佛戒。说一切有悉皆如梦。了达诸法自性皆空。说诸欲乐无有滋味。令诸众生远离欲缚。出烦恼垢。普遍十方一切世界。称扬赞叹一切诸佛往昔所行忍波罗蜜。并所随顺相应行海。令诸众生得法自在。得心自在。具忍辱力。称扬赞叹金色身业。离嗔恚垢。起慈悲行。止杀害心。绝畜生道。普遍十方一切世界。称扬赞叹一切诸佛往昔所修勤波罗蜜。并所随顺相应行海。令诸菩萨精进勇猛。为一切智。勤求正法。供养承事一切如来。恭敬赞叹。心无疲厌。令诸世间不起放逸。摄取众生令离苦蕴。入佛究竟圆满智海。普遍十方一切世界。称扬赞叹一切诸佛往昔所修禅波罗蜜。并所随顺相应行海。令其散灭尘劳障翳。永舍憍慢。不起贪嗔。荫清凉云。除烦恼热。竭生死海。摧业结山。调伏众生。安住妙法。究竟令其心得自在。普遍十方一切世界。称扬赞叹一切诸佛往昔所修般若波罗蜜。并所随顺相应行海。普耀正见智慧电光。令诸众生照达本性。普震清净妙法雷音。令诸众生增长功德。摧灭一切我慢高山。拔出一切诸见毒箭。决除一切疑惑翳膜。令诸众生得自在智。普遍十方一切世界。称扬赞叹一切诸佛往昔所修方便波罗蜜。并所随顺相应行海。随顺世间种种所作。令诸众生究竟成熟。虽普调伏一切众生。而于众生无所染着。虽普照明诸佛众会。而于众会。心无所著。虽离生死。而于诸趣。自在受生。虽现世间。而于涅槃。入出自在。虽能了达生死涅槃无二无别。而常善巧饶益众生。安住菩萨圆满自在。超出世间到于彼岸。普遍十方一切世界。称扬赞叹一切诸佛往昔所成愿波罗蜜。并所随顺相应行海。令诸菩萨尽未来际。乘四愿轮。游正觉路。遍周刹海。利乐众生。摧无明山。裂爱欲网。解众结缚。永灭无余。示现神通种种变化。令诸众生寿命自在。普遍十方一切世界。称扬赞叹一切诸佛往昔所成力波罗蜜。并所随顺相应行海。演说菩萨大总持力。方便法音妙辩才力。成熟众生广大愿力。摧伏魔怨智自在力。制诸外道心无畏力。身力坚固。犹若金刚能碎一切大铁围山。能灭十方一切劫火。能竭海水。能吞猛风。掌擎尽空所有世界。而于身力。无有损减。令诸众生净治三昧。普于一切。自在受生。普遍十方一切世界。称扬赞叹一切诸佛往昔所修智波罗蜜。并所随顺相应行海。分别演说种种智地。所谓普生诸佛十力无畏一切功德具足智地。普满诸佛一切相好自在庄严具足智地。普发菩萨一切大愿具足智地。普遍摄受一切众生具足智地。普为众生显示无我具足智地。普遍观察一切众生种种心念具足智地。普遍分别一切众生根解差别具足智地。普遍随顺一切众生信乐差别具足智地。普遍了知一切众生甚深业海无量差别具足智地。普遍趣入一切众生无量愿海心乐差别具足智地

从其顶上肉髻之中。出无量阿僧祇佛刹极微尘数如来之身。其身最胜。世无能比。诸相随好。清净庄严。威光赫奕。如真金山。无量光明。普照十方。演妙圆音。普周法界。示现无量大神通力。为诸世间。普雨法雨。随其所应。皆令获益。所谓为坐菩提场诸菩萨。雨大法雨。名平等现前智。为灌顶位诸菩萨。雨大法雨。名普门法界。为法王子位诸菩萨。雨大法雨。名入诸菩萨普庄严门。为童真位诸菩萨。雨大法雨。名住坚固山大法智云。为不退位诸菩萨。雨大法雨。名普遍庄严平等海藏。为成就正心位诸菩萨。雨大法雨。名以金刚智普照境界。为方便具足位诸菩萨。雨大法雨。名普摄众生自性庄严门。为生贵位诸菩萨。雨大法雨。名如来圆满随顺世间。为修行相应位诸菩萨。雨大法雨。名演法本际悲愍世间。为治地位诸菩萨。雨大法雨。名积集法藏。为初发心诸菩萨。雨大法雨。名普摄众生平等庄严。为广大信解诸菩萨。雨大法雨。名如来愿藏无尽解脱。为无色界诸天。雨大法雨。名普门智无尽藏。为梵世诸天。雨大法雨。名无量教声普门智藏。为他化自在天。雨大法雨。名能生法力资具无尽藏。为诸魔众。雨大法雨。名种种心幢勤求一切智。为化乐诸天。雨大法雨。名净念智宝住种种善轭。为兜率诸天。雨大法雨。名菩萨生意种种愿宝幢。为夜摩诸天。雨大法雨。名随顺如来净念欢喜藏。为忉利诸天。雨大法雨。名疾见如来出生庄严爱乐藏。为诸龙王众。雨大法雨。名出生菩萨厌离龙趣。种种神变欢喜幢。为夜叉王众。雨大法雨。名见佛欢喜普遍法界如来神变藏。为乾闼婆王众。雨大法雨。名一切如来集法音声云。为阿修罗王众。雨大法雨。名金刚智轮大法境界。为迦楼罗王众。雨大法雨。名无边光明出生一切如来方便。为紧那罗王众。雨大法雨。名一切如来饶益世间殊胜智云。为摩睺罗伽王众。雨大法雨。名爱乐速疾增长法。为诸人王众。雨大法雨。名得一切众生胜智慧法。为地狱众生。雨大法雨。名寂静音声正念庄严。为畜生众生。雨大法雨。名随顺如来具智慧藏无恶业道声。为阎罗王界众生。雨大法雨。名不舍众生出生如来波罗蜜声。为诸厄难处众生。雨大法雨。名寂静音声普遍安慰。悉令众生。永离忧苦。咸得入于贤圣众会。如是所作。充满十方一切法界。海幢比丘。各于其身一切毛孔。一一皆出无量阿僧祇佛刹极微尘数大光明网。一一光明。具阿僧祇色相。一一色相有阿僧祇庄严。一一庄严。现阿僧祇境界。一一境界。辨阿僧祇事业。如是普遍十方法界。尔时善财。复于如是大光网中。悉见海幢往昔所修一切菩萨三世所行檀波罗蜜。悉舍一切内外所有圆满施行。往昔所修一切菩萨三世所持尸波罗蜜。从初发心尽未来劫。誓舍身命。不起一念毁犯之心。往昔所修一切菩萨三世相应忍波罗蜜。或遇损害。头目手足。断截肢节。恶言毁辱。悉能安受。无有动乱。恒思舍离怨害之心。观自他身无有我相。生大慈悲。成一切智。以是因缘。获得菩萨具足相好自在色身。示一切身于一切处。经一切劫受一切苦。勤求正法。利益众生。不起一念厌退之心。种种神变。普遍十方等众生界。现一切身。如影随形。充满法界。往昔所修一切菩萨三世所行勤波罗蜜。所学三世诸佛菩萨勇猛精进离相妙行。所现种种神通变化震动十方一切世界诸大海水。令诸众生精勤匪懈。厌生死海。出离魔界。一切外道无不怖惧。一切魔军无不摧碎。光照十方一切法界。令诸菩萨修种种行。种种神变。普利众生。往昔所修一切菩萨三世所求禅波罗蜜。或见受身生诸族姓。或为国王。遇善知识。发菩提心。厌弃国城。出家学道。立大誓愿。种种威仪。坚持禁戒。身心寂静修诸禅定。往昔所修一切菩萨三世所成般若波罗蜜。为欲开发一切智故。勤求佛法。生正见心。为欲拔济诸众生故。事善知识。亲近承事。不违言教。尊重恭敬。深生信心。礼拜供养。情无懈倦。勤求如来一句正法。遍舍一切内外所有。于身命财。心无吝惜。乃至勤求一切法句。亦复如是。如是念念。尽未来际。诸所修行。皆为成就一切众生。究竟圆满智慧业故。往昔所修一切菩萨三世相应方便波罗蜜。能于一切诸趣类海。普现一切众生色相相似身云。以种种威仪。善巧摄受。普令众生获大饶益。往昔所求一切菩萨所发三世愿波罗蜜。所谓供事一切诸佛愿。成熟一切众生愿。严净一切佛刹愿。如是所发一切誓愿。圆满修行。所成功德。具足一切如来相好。修诸对治一切善法灭除一切生死过患。尽未来劫。利益众生。誓愿无尽。往昔所修一切菩萨三世相应力波罗蜜。所谓出生大愿力。普供诸佛力。普净佛刹力。普修妙行力。普化众生力。往昔所修一切菩萨三世所行智波罗蜜。恒以一切微细境界圆满智力。启悟法界一切众生无明睡眠。咸令开觉。究竟出生一切智道。海幢比丘。各于其身。从足至顶。乃至一切毛孔之中。所现境界。善财童子。于念念中。无不明见

尔时善财。一心观察海幢比丘。深生渴仰。忆念彼不思议三昧解脱。随顺彼不思议三昧自在。思惟彼不思议利益众生巧方便海。深入彼不思议无作妙用普庄严门。爱乐彼不思议甚深信解清净境界。观察彼不思议庄严法界清净智。安住彼不思议受佛究竟加持智。出生彼不思议菩萨自在力。坚固彼不思议菩萨大愿力。增广彼不思议菩萨诸行力。如是住立。思惟观察。一日一夜。乃至经于七日七夜。半月一月。乃至六月。复经六日。过此已后。海幢比丘。从三昧起。善财尔时。以身布地。恭敬作礼。起立合掌。叹未曾有。赞言圣者。如此三昧。希有奇特。此三昧门最为甚深。此三昧门最为广大。此三昧门境界无量。此三昧门神变难思。此三昧门光明无等。此三昧门庄严无数。此三昧门威力难制。此三昧门境界平等不动不乱。此三昧门普照十方一切世界。此三昧门方便无量有胜堪能。所以者何。如此三昧。利益无尽。以能除灭一切众生无量苦蕴故。所谓能令一切众生断贫穷业故。出地狱苦故。免畜生趣故。绝饿鬼因故。闭诸难门故。开人天道故。亲近一切安乐法故。出生人天殊胜乐故。令其爱乐定境界故。能令增长有为乐故。能为显示勤求出离三界法故。能为引发勤求无上菩提心故。能使增长大福智聚出生因故。能令速疾增长广博大悲心故。能令出生广大愿力故。能令照明菩萨智道故。能使庄严波罗蜜道故。能令深入最胜大乘故。能令明了普贤妙行故。能令趣入诸菩萨地智光明故。能令积集成就菩萨诸愿行故。能令安住一切智智境界中故。能令清净一切菩萨变化力故。能令勤求一切加持自在力故。圣者。此三昧门。名为何等。海幢告言。善男子。此三昧。名普眼舍得。亦名般若波罗蜜境界清净光明。亦名平等清净普庄严门。善男子。我以修习此平等清净普庄严门。而为上首。具足圆满百万阿僧祇最胜最尊无比三昧。善财白言。圣者此三昧境界究竟。唯如是耶。海幢言。善男子。此三昧门境界。甚深广大无量。若有修习身心寂静。入三昧时。了知十方一切世界无所障碍。往诣十方一切世界。无所障碍。入出十方一切世界无所障碍。庄严十方一切世界无所障碍。修治十方一切世界无所障碍。严净十方一切世界无所障碍。见一切佛普遍十方无所障碍。观一切佛广大威德无所障碍。知一切佛游戏神通无所障碍。证一切佛甚深智力无所障碍。入一切佛大功德海无所障碍。兴一切佛无上法云无所障碍。受一切佛无量法雨无所障碍。于诸佛法修习妙行无所障碍。知一切佛转妙法轮平等智性无所障碍。入一切佛道场众海现神通力无所障碍。随顺十方一切诸佛所起妙行无所障碍。观察十方一切诸佛演说。妙法无所障碍。普入十方一切佛刹咸起神通无所障碍。大悲摄受十方众生令其出苦无所障碍。常起大慈充满十方与众生乐无所障碍。普见十方一切诸佛心无厌足无所障碍。普入十方一切众生种种解海。无所障碍。普知十方一切众生种种根海无所障碍。普知十方一切众生种种业海。无所障碍。善男子。我唯知此般若波罗蜜清净光明三昧法门。如诸菩萨摩诃萨所入甚深究竟智海。所净最胜诸法境界。所达一切诸佛法门。所往十方无量佛刹所有大智总持光明。所住圆满自在三昧。所现清净种种神通。所具无尽辩才大海。所得无畏美妙音声。善巧宣说诸地功德所能拥护一切众生。而我何能知其妙行。叹其功德。显其境界。赞其愿力。现其光明。入其度门。达其所证。集其胜业。了其次第。知其普遍。住其三昧。见其心境。说其正道。辨其威势。得其所有平等智慧。善男子。从此南行。至海潮处。彼有大城。名圆满光。其城有王。名妙圆光。于彼城东。有一园林。名普庄严。王有夫人名伊舍那。为优婆夷。止住此林。修菩萨行。汝往彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。于海幢比丘所。得最胜法。获坚固身。证三昧境。究竟明彻。住清净解。悟深法界。其心随顺诸佛教海。于诸法门。忆持不忘。安住广大普庄严门。智慧光照。充满十方。心生欢喜。踊跃无量。五体投地。礼海幢足。绕无量匝。重复顶礼。恭敬瞻仰。思惟观察。想其容止。持其名号。念其功德观其行愿。忆其言音。思其三昧。想其所行广大境界。受其所得总持智慧。清净光明。咨嗟恋慕。辞退南行

尔时善财童子。蒙善知识力。令功德身信解圆满。依善知识教。正念思惟。念善知识语。递相开发。于善知识行。深生惭愧。爱乐恭敬。观善知识心。善巧摄受。倍益欢喜。作是念言。因善知识。令我普见一切诸佛。因善知识。令我普闻一切佛法。善知识者。是我师范。示导于我一切智法。普令见故。善知识者。是我眼目。令我普见诸佛境界如虚空故。善知识者。是我渠流。引我令入诸佛如来莲华池故。如是思念。渐次南行。向海潮处。至彼城东。见普庄严园。众宝垣墙。周匝围绕。一切宝树。行列庄严。所谓诸宝叶树。枝叶扶疏。光彩鲜明。敷荣微妙。诸宝华树。雨众妙宝拘苏摩华。发焰舒光。布散于地。诸宝香树。吐妙香云。香气氛氲。普熏十方诸佛世界。诸宝鬘树。雨大宝鬘。庄严宝林。处处垂下。摩尼王树。普雨种种大摩尼宝。遍布充满。随处庄严一切天宝。劫波衣树。普雨种种妙宝缯彩杂色衣服。随其所应。敷布严饰。宝音乐树。出妙乐器。微风吹动。发和雅音。其音美妙。过诸天乐。诸宝资具。庄严藏树。各雨众宝。珍奇玩好。诸庄严具。处处分布。以为严饰。其地清净。无有高下。宽广平坦。种种庄严。园中具有百万殿堂。大摩尼宝之所合成。百万楼阁。阎浮檀金。以为校饰。百万宫殿。毗卢遮那摩尼宝王。间错庄严。云构龙盘延袤远近。甍栋相承。势如飞动。百万浴池。七宝合成。一切妙宝。以为其岸。细妙金沙澄布其底。七宝阶道。摩尼栏楯周匝围绕。四面庄严。宝草芬芳夤缘际畔。栴檀香水。盈满其中。调适温凉。随众生意。宝树林间。宝渠分布。水清宝珠。周遍间错。昼夜常流。八功德水。水中多有凫雁鸳鸯。白鹤孔雀。迦陵频伽。拘枳罗等。杂色诸鸟飞集往来。游戏出没整毛理翮。游泳翱翔。出妙好声。清切和雅。犹如天乐。令人乐闻。宝多罗树。周匝行列。覆以宝网。垂诸金铃。微风徐摇。恒出美音。建立无数摩尼宝幢。杂宝缯幡。四面垂饰。光明普照百千由旬。其中复有百万陂池。香水湛然。清莹澄澈。随时坚细。栴檀香泥。澄垽其下。一切上妙。众宝莲华。菡蓞芬敷。大摩尼华。光色照耀。园中复有广大宫殿。名庄严幢。海藏妙宝。以为其地。种种形像。悉现其中。毗琉璃宝。以为其柱。阎浮檀金宝庄严网。弥覆其上。重楼挟阁。巍巍高大。犹妙金山。见者欣乐。种种胜宝。以为庄严。光藏摩尼。恒吐妙光。以为照耀。毗卢遮那藏摩尼宝王。殊丽校饰。辉映分明。一切众宝。无价香王。咸出妙香。普熏一切。所谓具足一切最胜妙宝香王。香气普腾。氤氲成雾。普现如意妙宝香王。香气随应。周闻法界。随根觉悟。妙宝香王。凡所嗅闻。诸根聪利。能于正法。精勤匪懈。其宫殿中。复有无量宝莲华座。周回布列。所谓光照十方妙藏摩尼宝莲华座。毗卢遮那如意摩尼宝莲华座。无垢藏摩尼宝莲华座。杂宝庄严摩尼宝莲华座。普门庄严摩尼宝莲华座。圆光庄严摩尼宝莲华座。安住海藏清净庄严摩尼宝莲华座。普焰光照摩尼宝莲华座。金刚藏师子摩尼宝莲华座。照耀世间摩尼宝莲华座。如是无量摩尼宝莲华座。一一皆以不可思议妙宝缯带。四面垂饰。不可思议众色摩尼。以为庄校。于宫殿中光影相照。平等庄严空中。复有百万宝帐。所谓宝衣帐。宝鬘帐。宝华帐。宝香帐。阎浮檀金帐。宝枝垂覆帐。杂宝摩尼帐。妙宝璎珞帐。光焰金刚帐。诸天妓乐帐。象王神变帐。马王神变帐。帝释所坐摩尼宝帐。如是种种宝庄严帐。严饰虚空。复有百万诸大宝网。弥覆其上。所谓宝铃网。宝盖网。宝身网。海藏真珠网。绀琉璃摩尼宝网。师子摩尼宝网。月爱光明摩尼宝网。一切人天种种形像宝香网。一切杂色宝冠网。一切妙宝璎珞网。如是等网。各于其上。垂覆庄严。复有百万大宝光明。而为照耀。所谓焰光摩尼宝光明。日藏摩尼宝光明。月藏摩尼宝光明。香焰摩尼宝光明。吉祥焰藏摩尼宝光明。莲华焰藏摩尼宝光明。焰幢摩尼宝光明。大焰摩尼宝光明。遍照十方摩尼宝光明。普现香云庄严具摩尼宝光明。如是等类大宝光明。而为照耀。常雨百万庄严具云。随意受用。百万随时芬馥白栴檀香云。普熏道场。百万天诸妙乐云。音声美妙。百万天曼陀罗华云。而以布散。百万诸天鬘带云。处处垂下以为严饰。百万天宝缯彩云。处处垂布以为衣服。百万出过诸天宝璎珞云。庄严林树。及诸楼阁。百万欲界天子。欣乐瞻仰。恭敬作礼。百万诸天采女往修同行。常来其所。投身而下。亲近敬奉。百万诸大菩萨。恒诣道场。常乐闻法。时伊舍那。具大人相。坐真金座。戴海藏真珠网冠。挂出过诸天真金宝钏。垂绀青发。顶髻庄严。吉祥焰藏摩尼宝王。以为鬘带。毗琉璃摩尼宝。以为耳珰。师子口摩尼宝缘饰耳轮。大如意摩尼宝王。以为璎珞。庄严其颈。大威德帝青摩尼宝网。以覆其首。种种光焰炽盛摩尼宝网。罗覆其身。百千亿那由他众生曲躬恭敬。亲近供养。东方有无量众生。来诣其所。所谓大梵天。梵辅天。梵众天。如是色界一切诸天。欲界他化自在天。化乐天。兜率天。夜摩天。忉利天。诸龙夜叉乾闼婆阿修罗迦楼罗。紧那罗摩睺罗伽及鸠槃茶。阎罗王界大力鬼神。乃至一切人及非人。诸王众等。南西北方。四维上下。亦复如是。其有见此优婆夷者。身病心病。种种所缠。一切邪见。障碍执着。所有惑苦。悉得除灭。速离一切诸烦恼垢。速拔一切诸见毒刺。疾破一切诸障碍山。深入无碍清净境界。种植一切圆满善根。长养一切善法根芽。入于一切清净智门。普获一切陀罗尼门。普证一切大三昧海。通达一切诸佛教海。一切诸佛广大愿门。无不开发。一切菩萨所修妙行。皆悉现前。一切如来功德大海。皆悉清净。其心广大。具足一切自在神通。其身无碍。于一切处。靡所不至。普诣十方。无所依着。随顺成就一切法门。尔时善财童子。入普庄严园。周遍观察。见伊舍那优婆夷。往诣其所。顶礼其足。绕无数匝。正立合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲诸菩萨众愿为我说。时伊舍那。告善财言。善男子。我得菩萨一解脱门。无间修习。若有众生。暂见我身。暂闻我名。或听我法。忆念于我。与我同住。亲近随顺。供给我者。悉不唐捐。善男子。若有众生。不种善根。不为善友之所摄受。不为诸佛之所护念。虽近于我。经于多时。与我同住。终不能见。善男子。其有众生。得见我者。皆于阿耨多罗三藐三菩提。获不退转。善男子。东方所有一切如来应正等觉。常来至此处。于众宝妙师子座。为我说法。南西北方。四维上下。一切如来。悉来至此处。于宝座为我说法。善男子。我常不离见佛闻法。与诸菩萨而共同住。不离菩萨三昧解脱。善男子。我此会众。有八万四千亿那由他。常在于此普庄严园。与我同住。皆于往昔与我修习一切菩萨同类行门。不相离故。一切咸于阿耨多罗三藐三菩提。得不退转。其余众生。或久或近。住此园者。一切修我同类行门。亦皆普入不退转位。善财白言。圣者。发阿耨多罗三藐三菩提心。为久近耶。答言。善男子。我忆。曾于然灯佛所。亲近承事。修行梵行。恭敬供养。闻法受持。次前。于离垢佛所。出家学道。受持正法。次前。于星宿幢佛所。闻法修行。欢喜供养。次前。于妙胜吉祥佛所。次前。于莲华德藏佛所。次前。于毗卢遮那佛所。次前。于普眼佛所。次前。于梵寿佛所。次前。于金刚脐佛所。次前。于水天佛所。善男子。我忆过去。于无量劫无量生中。如是次第三十六恒河沙佛所。皆悉亲近。一心承事。恭敬供养。出家学道。所受正法。所发誓愿。所入三昧。所证解脱。如是一切种种行门。我皆忆持。心无废忘。过此已往。佛智所知。非我能测。善男子。应知菩萨初发心。无有量。充满一切法界故。菩萨大悲门。无有量。普入一切众生界故。菩萨大愿门。无有量。究竟十方一切法界故。菩萨大慈门。无有量。普覆一切众生界故。菩萨所修行。无有量。于一切刹一切劫中。恒修习故。菩萨三昧力。无有量。令菩萨道不退转故。菩萨总持力。无有量。能持世间随所应闻教法海故。菩萨智明力。无有量。普能悟入三世佛教。巧随顺故。菩萨神通力。无有量。普现十方一切所有诸刹网故菩萨辩才力。无有量。圆音一演。令诸众生随类解故。菩萨清净身。无有量。现身普遍诸佛刹故

大方广佛华严经卷第七大方广佛华严经卷第八

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。白言圣者。久如当得阿耨多罗三藐三菩提。答言。善男子。菩萨不为教化调伏一众生故发菩提心。不为教化调伏百众生故发菩提心。不为教化调伏千众生故发菩提心。不为教化调伏百千众生故发菩提心。乃至不为教化调伏不可说不可说转众生故发菩提心。不为教化成熟一世界众生故发菩提心。乃至不为教化成熟不可说不可说转世界众生故发菩提心。不为教化成熟一阎浮提极微尘数世界众生故发菩提心。不为成熟一四天下极微尘数世界众生故发菩提心。不为成熟小千世界极微尘数世界众生故发菩提心。不为成熟中千世界极微尘数世界众生故发菩提心。不为成熟三千大千世界极微尘数世界众生故发菩提心。乃至不为教化成熟不可说不可说转三千大千世界极微尘数世界众生故发菩提心。复次菩萨。不为亲近供养一如来故发菩提心。乃至不为亲近供养不可说不可说转佛刹极微尘数诸如来故发菩提心。不为亲近供养一世界中尽未来劫次第兴世诸如来故发菩提心。乃至不为亲近供养不可说不可说转世界中尽未来劫次第兴世诸如来故发菩提心。不为亲近供养一佛刹极微尘数世界中尽未来劫次第兴世诸如来故。发菩提心。乃至不为亲近供养不可说不可说转佛刹极微尘数世界中尽未来劫次第兴世诸如来故发菩提心。复次菩萨。不为严净一世界故发菩提心。乃至不为严净不可说不可说转世界故发菩提心。不为严净一佛刹极微尘数世界故发菩提心。乃至不为严净不可说不可说转佛刹极微尘数世界故发菩提心。复次菩萨。不为受持一如来教故发菩提心。乃至不为受持不可说不可说转佛刹极微尘数如来教故发菩提心。复次菩萨。不为修习一如来愿故发菩提心。乃至不为修习不可说不可说转佛刹极微尘数如来愿故发菩提心。复次菩萨。不为往一佛刹故发菩提心。乃至不为往不可说不可说转佛刹极微尘数诸佛刹故发菩提心。复次菩萨。不为庄严一如来众会故发菩提心。乃至不为庄严不可说不可说转佛刹极微尘数如来众会故发菩提心。复次菩萨。不为受持一佛所转妙法轮故发菩提心。乃至不为受持不可说不可说转佛刹极微尘数如来所转妙法轮故发菩提心。复次菩萨。不为住持一如来遗法故发菩提心。乃至不为住持不可说不可说转佛刹极微尘数如来遗法故发菩提心。不为住持一世界中尽未来劫次第出现如来遗法故发菩提心。乃至不为住持不可说不可说转佛刹极微尘数世界中尽未来劫次第出现如来遗法故发菩提心。不为住持一阎浮提极微尘数世界中尽未来劫次第出现如来遗法故发菩提心。不为住持一四天下极微尘数世界中尽未来劫次第出现如来遗法故发菩提心。乃至不为住持不可说不可说转佛刹极微尘数世界中尽未来劫次第出现如来遗法故发菩提心。如是略说。不为满一佛誓愿故。不为往一佛国土故。不为入一佛众会故。不为持一佛法眼故。不为转一佛法轮故。不为知一世界中诸劫次第故。不为知一众生种种心海故。不为知一众生种种根海故。不为知一众生种种业海故。不为知一众生种种行海故。不为知一众生种种烦恼海故。不为知一众生种种烦恼习气海故。乃至不为知不可说不可说转佛刹极微尘数众生种种烦恼习气海故发菩提心。何以故。菩萨为欲教化调伏一切众生悉无余故。发菩提心。为欲亲近供养一切诸佛悉无余故。发菩提心。为欲严净一切诸佛所有刹土悉无余故。发菩提心。为欲守护一切佛教悉无余故。发菩提心。为欲随顺一切如来所行之道悉无余故。发菩提心。为欲成满一切如来广大誓愿悉无余故。发菩提心。欲往一切诸佛国土悉无余故。发菩提心。欲入一切诸佛众会悉无余故。发菩提心。欲知一切诸世界中诸劫次第悉无余故。发菩提心。欲知一切众生心海悉无余故。发菩提心。欲知一切众生根海悉无余故。发菩提心。欲知一切众生业海悉无余故。发菩提心。欲知一切众生行海悉无余故。发菩提心。欲灭一切众生诸烦恼海悉无余故。发菩提心。欲拔一切众生烦恼习气海悉无余故。发菩提心

善男子。取要言之。菩萨以如是等百万阿僧祇方便行故。发菩提心。善男子。菩萨行普入一切法皆证得故。普入一切刹悉严净故。是故善男子。严净一切世界尽。我愿乃尽。悉知十方一切世界劫次第尽。我愿乃尽。悉得十方一切诸佛功德海尽。我愿乃尽。次第修集一切菩萨精进海尽。我愿乃尽。庄严十方一切诸佛众会海尽。我愿乃尽。悉见十方一切众生心乐海尽。我愿乃尽。悉知十方一切众生根器海尽。我愿乃尽。普观十方一切众生诸行海尽。我愿乃尽。普竭十方一切众生惑业海尽。我愿乃尽。悉灭十方一切众生众苦海尽。我愿乃尽。悉拔十方一切众生习气海尽。我愿乃尽。善男子。如是。乃至百千万亿阿僧祇菩萨行门皆悉圆满。悉无余故。我愿乃满。是故菩萨。为欲成满一切智故。为欲随顺菩萨行故。为欲严净一切刹故。于一切法。勇猛勤求。无有懈息。善男子。应知菩萨发菩提心。所修行愿。所有志乐。广大如法界。究竟如虚空。虚空究竟。无穷尽故。我愿究竟。亦无有尽。法界广大无边际故。我愿广大亦无边际。诸众生界究竟无尽故。我愿究竟亦无有尽。善财童子。白言圣者。此解脱门。名为何等。伊舍那言。善男子。此解脱名离忧安隐幢。善男子。我唯知此一解脱门。如诸菩萨摩诃萨。乐欲深广。犹如大海。容受佛法。心无厌足。志意坚固。如须弥山。所修正行。不可倾动。所作不空。如善见药。能除众生烦恼重病。无碍慧身如明净日。灭诸众生无明闇障。无尽大悲犹如大地。普作一切众生所依。福智功德。犹如好风。与诸众生。作大义利。普照世间。犹如灯烛。能生一切智慧光明。普现其身。犹如大云。能与众生。雨寂灭法。福德光明。犹如满月。能令见者咸得安乐。威德尊胜。犹如帝释。悉能守护一切众生。而我云何。能知能说。彼诸菩萨难思戒定无边法海功德行愿。善男子。于此南方海潮之处。有一国土。名那罗素。中有仙人。名大威猛声。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼伊舍那优婆夷足。绕无数匝。殷勤瞻仰。悲泣流泪。作是思惟。善知识者。难可出现。如优昙华。善知识者。最极难值。善知识者。难得亲近。善知识者。难得承事。善知识者。难令欢喜。复作是念。得菩提难。得菩萨诸根难。净菩萨诸根难。值同行善知识难。积集菩萨广大善根难。寂静菩萨广大境界难。如理观察菩萨行愿难。随顺思惟菩萨教法难。依教修行菩萨妙行难。忆念出生菩萨善心难。速疾发起菩萨方便难。善巧增长一切智法光明难。作是念已。辞退而去

尔时善财童子。随顺思惟菩萨正教。随顺思惟菩萨净行。起速疾增长一切菩萨福力心。起速疾普见一切诸佛光明心。起速疾获得一切法藏心。起速疾增长一切大愿心。起速疾现见十方诸法心。起速疾明照诸法本性心。起速疾散灭一切障碍心。起速疾观察法界无闇心。起速疾能坏内垢金刚心。起速疾摧伏魔王军众心。起速疾清净意宝庄严心。如是思惟。渐渐游行。至那罗素国。周遍寻求大威猛仙。见一大林。其林蓊郁。阿僧祇树。以为庄严。所谓种种叶树。枝条扶疏。密叶葱翠。种种华树柯叶布濩。繁华鲜美。种种果树。相续成熟。种种宝树。雨摩尼果。大栴檀树。处处行列。诸沉水树。常出好香。阎浮檀树。恒雨甘果。悦意香树。妙香庄严。波吒罗树。其华鲜荣。香气芬馥。四面围绕。尼拘陀树。其身耸擢。枝叶繁布。盘旋如盖。优钵罗华。波头摩华。拘物头华。芬陀利华。处处开敷。以严池沼。时善财童子。入此大林。见栴檀树。其身洪直。枝条垂布。华叶繁密。偃盖成荫。时彼仙人。在此树下。萦发为髻。藉以香草。十千仙众。前后围绕。其诸仙人。或衣鹿皮。或衣树皮。或编细草。种种衣服。髻环垂鬓。瞻仰而住。善财见已。往诣其所。五体投地。深心顶礼。作如是言。我今得遇真善知识。复作是念。善知识者。则是趣向一切智门。令我得入真实道故。善知识者。则是趣向一切智乘。令我得至如来地故。善知识者。则是趣向一切智船。令我得至智宝洲故。善知识者。则是趣向一切智炬。令我得生十力光故。善知识者。则是趣向一切智道。令我速入涅槃城故。善知识者。则是趣向一切智灯。令我得辨邪正路故。善知识者。则是趣向一切智桥。令我得度生死流故。善知识者。则是趣向一切智盖。令我获得慈悲荫故。善知识者。则是趣向一切智津。令我速达功德岸故。善知识者。则是趣向一切智眼。令我得见法性门故。善知识者。则是趣向一切智潮。令我应限不失时故。作是语已。从地而起。绕无量匝。合掌前立。白言。圣者我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者善能诱诲。愿为我说。时彼仙人。顾眄仙众。而告之言。诸仁当知。此童子已发阿耨多罗三藐三菩提心。此童子欲施一切众生无畏。此童子欲与一切众生利益。此童子欲惠一切众生安乐。此童子欲观一切诸佛智海。此童子欲荫一切如来法云。此童子欲游一切诸佛教海。此童子欲然一切大智明灯。此童子欲起一切大慈悲云。此童子欲饮一切甘露法水。此童子欲雨一切广大法雨。此童子欲以智月普照世间。此童子欲灭众生烦恼毒热。此童子欲施世间善法清凉。此童子欲长含识一切善根。时诸仙众。闻是语已。各以种种上妙香华。散善财上。布身作礼。绕无量匝。称扬赞叹。作如是言。今此童子。必能救护一切众生。必能除灭诸地狱苦。必能永断诸畜生趣。必能永离阎罗王界。必能关闭诸难处门。必能干竭诸爱欲海。必能解脱贪欲缠缚。必能永灭众生苦蕴。必能永破无明黑闇。必以福德大轮围山。周护世间令其安乐。必以智慧大宝须弥。显示世间功德智聚。必以清净无碍智日。开示一切善根法藏。必令众生开净智眼。明识世间。归于正道。时大威猛声。告群仙言。善男子。若有能发阿耨多罗三藐三菩提心。必能勇猛行菩萨行。必能饶益一切众生。必与众生广大利乐。必能成就一切智道。此善男子。已发阿耨多罗三藐三菩提心。当净一切佛功德地。说是语已。告善财言。善男子。我得菩萨无胜幢解脱门。善财白言。圣者。此解脱门境界云何。时彼大仙。即伸右手。摩善财顶。执善财手。即时善财。自见其身。普往十方百千佛刹极微尘数诸世界中。普诣十方百千佛刹极微尘数诸如来所。见彼佛刹及其众会种种庄严。亦见彼佛种种相好光明炽盛。亦闻彼佛随诸众生心之所乐而演说法。一文一句皆悉通达。各别领受诸佛法轮。各别记持开发义理。前后次第。无有杂乱。亦知彼佛所度众生种种乐欲。随其根性。雨诸法雨。各得成熟。亦知彼佛于往昔时。以种种解。净诸愿海。亦知彼佛以清净愿成就诸力。亦见彼佛随众生心。所现种种差别色身。亦见彼佛大光明网。种种色相。圆满清净。亦知彼佛无障碍智道场众会。清净庄严。又自见身。普于一切诸如来所。亲近供养。受持正法。或于佛所一日一夜。或于佛所七日七夜。或经半月。或经一月。一年十年百年千年。或百千年。或经亿年。百亿千亿百千亿年。或阿庾多亿年。或那由他亿年。或经半劫。或经一劫百劫千劫。或百千亿阿庾多那由他亿劫。乃至不可说不可说佛刹极微尘数劫。如是一切。咸悉了知。无不通达。尔时善财童子。为菩萨无胜幢解脱智光明照故。得毗卢遮那藏三昧光明。为无尽智解脱三昧光明照故。得普摄诸方现诸方身陀罗尼光明。为金刚轮陀罗尼光明照故。得清净境界智慧聚三昧光明。为普门际境界庄严藏般若波罗蜜光明照故。得佛圆满虚空藏三昧光明。为一切佛戒定慧法轮三昧光明照故。得三世无尽圆满智三昧光明。时彼仙人。放善财手。善财童子。即自见身。还在本处。仙人告言。善男子。汝忆念耶。善财言。唯此是圣者善知识力。令我忆念分明显现。仙人告言。善男子。我唯知此菩萨无胜幢解脱门。如诸菩萨摩诃萨。成就一切殊胜三昧。于一切时。而得自在。于一念顷。出生诸佛无量智慧微妙境界。以佛智慧。而为庄严。普照世间。无有障碍。一念普入三世境界。分形遍往十方刹海。智身普入一切法界。随众生心。普现其前。放净光明。令其爱乐。观其根行。而为利益。而我云何能知能说彼功德行。彼殊胜愿。彼庄严刹。彼智境界。彼三昧所行。彼神通变化。彼解脱游戏。彼身相差别。彼音声清净。彼智慧光明。彼三世境界。彼色身遍往。彼智身普照。彼随乐普现。彼随时饶益。彼随俗轨仪。彼圆音所说。彼清净妙行。彼光网所照。善男子。于此南方。有一聚落。名伊沙那。彼有住处。名阿野怛那。有婆罗门。名曰胜热。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。欢喜踊跃。生爱敬心。顶礼其足。绕无数匝。殷勤瞻仰。辞退南行

尔时善财童子。为菩萨无胜幢解脱门光明照其心故。得住诸佛不思议境界种种神通力。证菩萨不思议解脱种种神通智。得菩萨不思议三昧智光明。得一切时恒熏习三昧智光明。得遍了知一切境界皆依想所住三昧智光明。得入一切世间具足殊胜智光明。以得如是智光明故。于一切处。皆随现身。随一一身。以究竟智。皆悉演说究竟平等无二无别无分别法。以明净智。普照境界。凡所听闻甚深解脱清净法藏。皆能忍受信解。清净决定。明了诸法自性。无有疑惑。心恒不舍。修习一切菩萨妙行。勇猛精进。趣一切智。无有退转。获得十力差别智光。爱乐深法。常无厌足。以正修行。住一切智。其心正向入佛境界。出生菩萨广大庄严。圆满无边清净大愿。以无障碍智。知无边世界网。以无懈怠心。度无边众生海。普遍了达无边菩萨诸行境界。普见无边一切世界种种差别。普入无边广狭粗妙一切世界。普知无边一切世界种种想网。普知无边一切世界诸安立谛。普了无边一切世界言辞称赞。普知无边一切众生种种信解。普知无边一切众生成熟时节。普知无边一切众生种种心想。普见无边一切众生种种色相。随其所应。方便成熟。念善知识。渐次游行。至伊沙那聚落。见胜热婆罗门。修诸苦行。于赫日中。四面火聚。犹如大山。中有刀山。高[(阿-可)*(山/(峻-山))]无极。为欲勤求一切智智。登彼刀山。投身入火。时善财童子。既至其所。顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。婆罗门言。善男子。汝今若能登此刀山。投身火聚。诸菩萨行。悉得清净。时善财童子。作如是念。得人身难。离诸难难。得无难难。离恶法难。得净法难。遇佛出世难。具足诸根难。得闻正法难。得遇善人难。逢真善知识难。受如理正教难。得正命自活难。得随法修行难。此将非魔。魔所使耶。将非是魔。险恶徒党诈现菩萨善知识相。与诸菩萨而作怨敌。而欲为我作善根难。作寿命难。作梵行难。障我修行一切智道。牵我令入邪恶趣中。障我所证解脱法门。障我所求无上佛法。作是念时。十千梵天。住虚空中。作如是言。善男子。莫作是念。莫作是念。今此圣者。得金刚焰三昧光明。发大精进勇猛不退。誓入生死。度诸众生。欲竭一切诸贪欲海。欲截一切诸邪见网。欲烧一切诸烦恼薪。欲普运度诸险难碛。欲尽除断老病死怖。欲尽吹坏无明障山。欲普引导出惑稠林。欲放一切妙法光明。普照三世愚痴黑闇。善男子。我诸梵天。执着邪见。皆悉自谓是自在者。是能作者。我为一切世间最胜。此婆罗门。五热炙身时。其火光明照我宫殿。我即开悟。于自所居及诸禅定。心无乐着。皆共来诣婆罗门所。时婆罗门。以神通力。即为我等。现大苦行。令我灭除一切邪见。为我说法。令我断除一切憍慢。普为一切世间众生。住于大慈。行于大悲。起广大心。发菩提意。住坚固愿。欣求解脱。常见诸佛。恒闻妙法。于一切处。心无所著。能转一切圆满法轮。其声无碍。普遍一切。复有十千诸魔天众。住虚空中。以天摩尼宝。散婆罗门上。告善财言。善男子。此婆罗门。五热炙身时。其火光明。映夺我等所有宫殿。及身璎珞诸庄严具。一切光明皆如聚墨。令我于中不生乐着。我与眷属。来诣其所。时婆罗门。为我说法。令我及余无量天子诸天女等。于阿耨多罗三藐三菩提。得不退转。复有十千他化天王。于虚空中。各散天华。作如是言。善男子。此婆罗门。五热炙身时。其火光明映夺于我所有宫殿。璎珞严具。一切光明皆如聚墨。令我于中不生爱着。即与眷属来诣其所。时婆罗门。为我说法。令我身心而得自在。于烦恼中而得自在。于受生中而得自在。于寿命中而得自在。于业障中而得自在。于诸三昧而得自在。于庄严具而得自在。于菩提心而得自在。乃至能于一切佛法而得自在。复有十千化乐天王。住虚空中。作天音乐。以美妙声。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。其火光明。照我宫殿。诸庄严具。所有光明。隐蔽不现。能令我身及诸采女。于五欲中不生爱着。不受欲乐。身心柔软。即与眷属来诣其所。时婆罗门。为我说法。能令我等心得清净。心得明洁。心得堪能。心得纯善。心极柔软。心生欢喜。乃至令得具足十力清净智身。出生无量清净色身。演出无量清净言辞。出生无量如来音声。悟入无量如来之心。具足获得一切智智。复有十千兜率天王。天子天女无量眷属。于虚空中。起诸香云。雨众妙香。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。光照我宫。令我诸天及其眷属。于自宫殿。不生爱着。不贪欲乐。来诣其所。时婆罗门。为我说法。能令我等。断除一切五欲爱着。小欲知足。心生欢喜。心得充满。生诸善根。发菩提心。乃至圆满一切佛法。复有十千夜摩天王。并其眷属天子天女。前后围绕。于虚空中。以天曼陀罗华。摩诃曼陀罗华。拘苏摩华。散婆罗门上。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。光照我宫。能令我等集会之时。于天音乐。不生贪着。亦不爱乐己身眷属。来诣其所。闻其说法。于诸欲乐。悉生舍离。回向趣求一切佛法。复有十千三十三天帝释诸王。并其眷属天子天女。前后围绕。于虚空中。雨天衣服。众宝璎珞。天庄严具。拘苏摩华。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。光照我宫。令我天众。于其宫殿殊胜集会。游戏园林。天诸音乐娱乐之处。不生爱乐。即与眷属来诣其所。时婆罗门。为我等说一切诸法皆悉无常。迁流变动。败坏磨灭。令我断除憍慢放逸。令我爱乐无上菩提。善男子。我当见此婆罗门时。须弥山顶六种震动。我等诸天。见是相已。极生恐怖厌离之心。即时发起阿耨多罗三藐三菩提意。咸愿趣求一切智智

复有十千诸大龙王。所谓伊罗钵那龙王。难陀龙王。优婆难陀龙王等。于虚空中。布大香云。普雨无量随时栴檀微细香雨。无数龙女。奏天音乐。雨天妙华及天香水。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。其火光明照我宫殿。令诸龙众。离热沙怖。金翅鸟怖。除灭嗔恚。身得清凉。心无垢浊。泰然安隐。复为我等。如应说法。闻法信解。厌恶龙趣。发至诚心。悔除一切诸恶业障。乃至发阿耨多罗三藐三菩提心。究竟安住一切智智。复有十千诸夜叉王。于虚空中。各以种种上妙供具。恭敬供养此婆罗门及以善财。作如是言。善男子。此婆罗门。五热炙身时。能令我等及诸眷属。悉于众生。发慈愍心。一切罗刹鸠槃茶等。亦生慈心。以慈心故。于诸众生。无所恼害。能施安乐。各与眷属俱来见我。我及彼等。即共来诣婆罗门所。时婆罗门。为我说法。能令我等一切皆得身心安乐。增长威力。又令无量夜叉罗刹鸠槃茶等。发于无上菩提之心

大方广佛华严经卷第八大方广佛华严经卷第九

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

复有十千乾闼婆王。于虚空中。作如是言。善男子。此婆罗门。五热炙身时。其火光明照我宫殿及诸眷属。悉令我等受不思议无量快乐。是故我等。来诣其所。此婆罗门。为我说法。能令我等于阿耨多罗三藐三菩提。得不退转。复有十千阿修罗王。从大海出。住虚空中。舒右膝轮。合掌礼敬。作如是言。善男子。此婆罗门。五热炙身时。我阿修罗所有宫殿大地诸山。悉皆震动。大海波涛。涌浪腾沸。令我眷属失其威力。舍憍慢心。离诸放逸。息除战斗伤害之心。是故来诣婆罗门所。从其闻法。永离谄诳。入深法忍。住于三昧。成就十力。坚固不动。复有十千迦楼罗王。大力勇持迦楼罗王而为上首。于虚空中。化作广大童子之形。容貌端严。色相具足。于虚空中。唱如是言。善男子。此婆罗门。五热炙身时。其火光明照我宫殿。一切震动。而令我等皆悉恐怖。不乐住处。生厌离心。来诣其所。时婆罗门。即为我等如应说法。能令我等修习大慈。增长大悲。令其精进不舍善轭。令于五欲拔出众生。令其发起大菩提心。令入甚深清净法界。令其获得明利智慧。方便善巧调伏众生。复有十千紧那罗王。于虚空中。唱如是言。善男子。此婆罗门。五热炙身时。从火焰中。有大风起。吹我宫殿。园林池沼。宝多罗树。诸宝铃网。诸宝缯彩。璎珞鬘带。诸音乐树。诸妙宝树。及诸乐器。一切资具。咸皆震动。自然演出佛声法声。及不退转菩萨僧声。发起大愿菩萨道声。住于无上正等觉声。云某方某界某国某处。有某菩萨。发菩提心。出生大愿。某方某界某国某处。有某菩萨。修行苦行。于身命财。难舍能舍。某方某界某国某处。有某菩萨。为速圆满一切智智。积集菩萨功德妙行。乃至究竟无作法门。某方某界某国某处。有某菩萨。往诣道场。坐菩提树。降魔军众。成等正觉。乃至某方某界某国某处。有某如来。转大法轮。某方某界某国某处。有某如来。作佛事已。而般涅槃。善男子。假使有人以阎浮提地及草木一切所有。末为微尘。此微尘数可知边际。我宫殿中宝多罗树。乃至乐器庄严具等所出音声。演说菩萨名如来名法名僧名。所发大愿。所修诸行。及佛菩萨。所游所住。所说所化。无有能得知其边际。善男子。我等以闻佛声法声菩萨僧声。菩萨所住行愿声故。生大欢喜。来诣其所。时婆罗门。即为我等。如应说法。令我及余无量众生。于阿耨多罗三藐三菩提。得不退转。复有无量欲界天子。现高大身。住虚空中。以诸种种上妙供具。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。其火光明。下照阿鼻及诸地狱。诸所受苦悉令休息。我等遇此光明照故。心生净信。以信心故。罪垢除灭。从彼命终。生于天中。以惭愧故。为知恩故。舍离欲乐而来其所。恭敬恋仰。无有厌足。时婆罗门。为我说法。能令我等及与无量百千众生发阿耨多罗三藐三菩提心

尔时善财童子。得闻如是种种说法。心大欢喜。踊跃无量。于婆罗门所。发起真实善知识想。头顶礼足。恭敬合掌。唱如是言。我于大圣善知识所。生不信心。而怀疑惑。唯愿圣者。容我悔过。时婆罗门。即为善财而说偈曰

  若有诸菩萨　　顺善知识教
  一切无疑惧　　安住心不动
  彼当决定得　　诸佛自然智
  降魔坐道场　　广度无边众

尔时善财童子。闻此偈已。即登刀山。自投火聚。未至中间。即得菩萨善住坚牢清净三昧。才触火焰。复得菩萨寂静乐神通门三昧。善财白言。甚奇圣者。如是刀锋及大火焰。我身触时。安隐快乐。时婆罗门。告善财言。善男子。我唯得此菩萨普圆满无尽轮解脱。如诸菩萨摩诃萨。大功德焰悉能烧尽一切众生诸见烦恼。安住菩萨无退转心。无穷尽心。无懈怠心。无怯弱心。如那罗延金刚藏心。疾修诸行无慢惰心。大愿风轮普持一切。勇猛坚誓无有退转。而我云何能知能说彼功德行。善男子。南方有城。名师子频申。彼城有王。名无畏星宿幢。王有童女。名为慈行。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。于善知识所。起不思议最极尊重心。生广大清净信解心。常念大乘恒不舍离。心专求佛智常无异念。心观法境界无有疑惑。一心系念随善知识。无障碍智常现在前。决定住于真实智际。善能分别诸法实际。普入三世诸刹那际。随顺解了如虚空际。现见诸法恒无二际。住于法界无分别际。入一切义无障碍际。住一切劫无失坏际。随顺调伏诸业性际。如来最胜不共法际。解了如来无际之际。以最胜智。悉能破坏一切执着颠倒想网。不取一切同异刹土差别之相。亦复不取一切诸佛众会道场和合之相。不取佛刹清净之相。了知众生皆无有我及众生相。亦知一切音声语言如空谷响。亦知一切差别众色皆如影像。如是思惟。正念观察。渐次南行。向师子频申城。周遍询求慈行童女。闻众人言。彼是王女。处在王宫。五百童女。以为侍从。住毗卢遮那摩尼藏殿。于龙胜栴檀足金线网天衣座上。而说妙法。善财闻已。诣王宫门。一心渴仰求见彼女。于时乃见无量人众来入宫中。善财问言。诸人今者欲何所诣。人咸报言。我等欲诣慈行童女听受妙法。善财即念。此王宫门。既无限碍。我亦应入。遂入王宫。见其宝殿。玻璃为地。琉璃为柱。金刚为壁。阎浮檀金以为垣墙。众宝栏楯百千杂宝。光明普照而为窗牖。阿僧祇胜摩尼宝而庄校之。宝藏摩尼镜圆满庄严。世中最上光藏摩尼宝。昼夜光明。以为照耀。无数宝网。周匝弥覆。窗闼交映。众宝相辉。百千金铃。悬置其上。微风吹动出微妙音。有如是等不可思议众宝严饰慈行童女身真金色。目发绀青。形貌端严相好具足。以梵音声而演说法。善财见已。顶礼其足。绕无数匝。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。童女告言。善男子。汝应观我所住宫殿内外种种庄严之事。善财顶礼如教观察。见一一壁中。一一镜中。一一柱中。一一相中。一一形像中。一一宝网中。一一栏楯中。一一金铃中。一一宝树中。一一宝璎珞中。一一庄严具中。一一宝形像中。一一摩尼宝中。一一光明照世毗卢遮那宝中。悉见十方一切法界。一切如来从初发心修菩萨道。各各行愿。各各境界。各各出兴成等正觉。各各示现广大神变转妙法轮。乃至各各现入涅槃。如是影相种种境界。如镜中像亦如净水。普见虚空日月星宿。如此皆是慈行童女。过去所修大善根力。所有众像于中显现。尔时善财。忆所观察一切诸佛庄严刹土功德行愿神变之相。合掌恭敬一心瞻仰慈行童女。时彼童女。告善财言。善男子。此般若波罗蜜普庄严门。我于三十六恒河沙数诸如来所。求得此法。彼诸如来。各以种种异方便门。令我得入。一佛所演。余不重说。善财白言。圣者。此般若波罗蜜普庄严门境界云何。童女答言。善男子。我入此般若波罗蜜普庄严门。随顺趣向。思惟观察。忆持分别。所有境界。所有威仪。所有相状。所有证入。即时获得普遍出生陀罗尼门。百万阿僧祇陀罗尼门。皆悉现前。如水漩澓。速疾显现。所谓佛陀罗尼门。法陀罗尼门。佛刹陀罗尼门。众生陀罗尼门。普遍陀罗尼门。过去陀罗尼门。未来陀罗尼门。现在陀罗尼门。常住际陀罗尼门。福德陀罗尼门。福德聚陀罗尼门。智慧陀罗尼门。智慧聚陀罗尼门。诸愿陀罗尼门。分别诸愿陀罗尼门。行陀罗尼门。行清净陀罗尼门。行修集陀罗尼门。行圆满陀罗尼门。业陀罗尼门。业不失坏陀罗尼门。业清净陀罗尼门。业流注陀罗尼门。业现前所作陀罗尼门。舍离恶业陀罗尼门。修习正业陀罗尼门。业自在陀罗尼门。善行陀罗尼门。常持善行陀罗尼门。三昧陀罗尼门。随顺三昧陀罗尼门。观察三昧陀罗尼门。三昧境界陀罗尼门。从三昧起陀罗尼门。神通陀罗尼门。心海陀罗尼门。种种心陀罗尼门。直心陀罗尼门。清净心陀罗尼门。照心稠林陀罗尼门。心地清净陀罗尼门。知众生心所生处陀罗尼门。知众生微细心陀罗尼门。知众生烦恼行陀罗尼门。知烦恼习气陀罗尼门。知烦恼方便陀罗尼门。知烦恼所作陀罗尼门。知众生信陀罗尼门。知众生解陀罗尼门。知众生行陀罗尼门。知众生信解诸行差别陀罗尼门。知众生性陀罗尼门。知众生欲陀罗尼门。知众生想陀罗尼门。知世界所起陀罗尼门。普见十方陀罗尼门。普见一切法陀罗尼门。说法陀罗尼门。大慈陀罗尼门。大悲陀罗尼门。寂静陀罗尼门。语言道陀罗尼门。解脱陀罗尼门。普遍出生陀罗尼门。无著际陀罗尼门。方便非方便陀罗尼门。随顺陀罗尼门。差别陀罗尼门。普入陀罗尼门。无碍际陀罗尼门。普遍一切陀罗尼门。佛法陀罗尼门。菩萨法陀罗尼门。声闻法陀罗尼门。独觉法陀罗尼门。世间法陀罗尼门。世界成陀罗尼门。世界坏陀罗尼门。世界住陀罗尼门。世界庄严陀罗尼门。世界形状陀罗尼门。狭世界陀罗尼门。广世界陀罗尼门。垢世界陀罗尼门。净世界陀罗尼门。于净世界现垢世界陀罗尼门。于垢世界现净世界陀罗尼门。纯垢世界陀罗尼门。纯净世界陀罗尼门。垢净世界陀罗尼门。净垢世界陀罗尼门。平坦世界陀罗尼门。高下世界陀罗尼门。覆世界陀罗尼门。仰世界陀罗尼门。侧世界陀罗尼门。世界网陀罗尼门。世界转陀罗尼门。世界各别依想住陀罗尼门。世界行陀罗尼门。细入粗陀罗尼门。粗入细陀罗尼门。大入小陀罗尼门。小入大陀罗尼门。见诸佛陀罗尼门。分别佛身陀罗尼门。见佛光明庄严网陀罗尼门。闻佛圆满妙音声陀罗尼门。佛转法轮陀罗尼门。佛法轮成就陀罗尼门。佛法轮差别陀罗尼门。佛法轮无差别陀罗尼门。佛法轮训释陀罗尼门。佛法轮旋转陀罗尼门。佛身普遍陀罗尼门。佛会圆满陀罗尼门。能作佛事陀罗尼门。了知佛会差别相陀罗尼门。遍入佛众会海陀罗尼门。诸佛光照陀罗尼门。诸佛三昧陀罗尼门。诸佛三昧自在用陀罗尼门。诸佛住处陀罗尼门。诸佛加持陀罗尼门。诸佛变化陀罗尼门。诸佛游戏陀罗尼门。佛知众生心行差别陀罗尼门。诸佛神通种种变现陀罗尼门。住兜率宫所作业陀罗尼门。乃至示现入于涅槃陀罗尼门。利益众生陀罗尼门。入甚深法陀罗尼门。入微妙法陀罗尼门。菩提心相陀罗尼门。菩提心所从生陀罗尼门。菩提心助道相陀罗尼门。诸愿陀罗尼门。诸行陀罗尼门。神通相陀罗尼门。出离相陀罗尼门。总持清净相陀罗尼门。智轮清净相陀罗尼门。智慧清净相陀罗尼门。无量解脱相陀罗尼门。念力清净陀罗尼门。自心清净陀罗尼门。善男子。我唯知此般若波罗蜜普庄严门。如诸菩萨摩诃萨。其心广大。等虚空界。入于法界。智慧宽博。福德成满。坚固不动。住出世法。远离世间。勤求修习。向一切智。智眼清净。无诸垢翳。身语心行。悉皆清净。以差别智。普入诸法无障碍慧。犹如虚空。通达一切世间境界。获无碍地大光明藏。善巧分别一切法义。一切世间。无能映夺。常行于世。不染世法。能益于世。非世所坏。为诸众生。究竟依止。善了一切众生语言。明解众生种种仪式。知诸众生业习根器。随其心行。如应说法。于一切处。普随现身。于一切时。恒得自在。而我云何。能知能说彼功德行。善男子。于此南方。有一国土。名为三目。彼有比丘。名曰妙见。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。恋慕瞻仰。辞退南行

尔时善财童子。随顺思惟菩萨所住行甚深。思惟菩萨所证法界际甚深。思惟菩萨众生微细智甚深。思惟菩萨世间想行智甚深。思惟众生无作性甚深。思惟众生心流注甚深。思惟诸法缘起际甚深。思惟众生真实际甚深。思惟众生如光影甚深。思惟众生名号差别际甚深。思惟众生语言际甚深。思惟众生庄严法甚深。思惟众生秘密际甚深。思惟众生光明际甚深。渐次前行。至三目国。于彼城邑。市肆廛里。山川林薮仙人住处。周遍寻访妙见比丘。忽然睹见在一林中经行往复。头骨如盖顶有肉髻。殊胜端严。其眼修广如青莲叶。鼻修高直如挺真金。唇色丹洁如频婆果。齿白齐密具足四十。颊如师子颐颔充满。眉高而长。额广平正。毫相映彻如白琉璃。耳相垂埵如悬珠状。面如满月见者无厌。颈项圆直约文三道。胸标德相妙藏庄严。臆如师子肩膊佣圆。腰胁深细如金刚杵。臂肘佣直立垂过膝。网缦指相如白鹅王。手足掌中金刚轮相。柔软细滑如兜罗绵。伊尼鹿腨七处平满。手指纤长。足跟平圆。皮肤金色常光一寻。身毛上靡一一右旋。其身圆满如尼拘陀树。相好严洁犹如雪山王。诸根澄静。目视不瞬。于诸境界。心无动乱。智慧深广犹如大海。若沈若举。是智非智。动转戏论。一切咸息。得佛所行平等境界。入于缘起差别法门。成熟众生。心恒不倦。能生深广圆满大悲。教化示导心无暂舍。为欲受持一切如来正法眼故。为欲普令一切众生生智眼故。为于如来所行之道恒履践故。不迟不速审谛经行。寂静端严犹如满月。威仪雍肃如净居天。无数天龙乾闼婆等。释梵护世。人及非人。前后围绕。主方之神。随方回转引导其前。足行诸神。持宝莲华随捧其足。无尽光主火神。执持宝炬舒光照耀。阎浮幢主林神。恒雨众妙拘苏摩华。不动藏主地神。随现宝藏。普光明主空神。庄严虚空。妙吉祥主海神。雨摩尼宝。须弥藏主山神。合掌作礼。无碍力主风神。散众香华。春和淑气主夜神。曲躬恭敬。常觉圆满主昼神。持遍照十方摩尼宝幢。住虚空中。放大光明。善财童子。前诣其所。头面礼足。合掌白言。圣者。我已先发阿耨多罗三藐三菩提心。复欲勤求诸菩萨道。我闻圣者。善能诱诲。愿为我说。菩萨云何学菩萨行。修菩萨道。妙见答言。善男子。我年既少。出家又近。我此生中。于三十八恒河沙数诸如来所。亲近供养。净修梵行。或有佛所。一日一夜净修梵行。或有佛所。七日七夜净修梵行。或有佛所。半月一月一年百年千年百千年那由他年。乃至不可说不可说年。或有佛所。经一小劫。或一中劫。或一大劫。乃至不可说不可说阿僧祇劫。亲近供养净修梵行。听闻妙法。依教奉行。清净庄严诸大誓愿。证入诸佛甚深境界。修集菩萨一切妙行。圆满一切波罗蜜门。亦见彼佛所成正觉。所现神通。所转法轮。所现涅槃。所有遗教。乃至法尽各各差别。悉能受持。无有杂乱。亦知彼佛以本所发大誓愿力。普遍严净诸佛国土。以本所入诸三昧力。圆满菩萨甚深妙行。以本所修普贤行力。清净诸佛波罗蜜海。又善男子。我常不离此经行处。一念中一切十方皆悉现前。得净妙智。观察了知无障碍故。一念中一切世界皆悉现前得速疾力。一念过不可说不可说世界无障碍故。一念中不可说不可说佛刹皆悉现前。得普严净成就菩萨愿力故。一念中不可说不可说众生差别行皆悉现前。得满足普贤教门海故。一念中不可说不可说佛清净身皆悉现前。得普亲近成就普贤行愿力故。一念中不可说不可说佛刹极微尘数如来皆悉现前。得柔软心供养承事一切如来愿力故。一念中不可说不可说如来降注法雨入众生心皆悉现前。得了知阿僧祇法门随顺陀罗尼愿力故。一念中不可说不可说菩萨行海皆悉现前。得净一切诸菩萨行。犹如帝网。殊胜愿力故。一念中不可说不可说诸三昧海皆悉现前。得于一三昧中自在入出一切三昧愿力故。一念中不可说不可说诸根海皆悉现前。得了知诸根际于一根中见一切根愿力故。一念中不可说不可说时皆悉现前。得于一切时转正法轮众生界尽法轮无尽愿力故。一念中不可说不可说三世海皆悉现前。得了知一切世界中三世分位智光明愿力故。善男子。我唯知此菩萨随顺无尽灯解脱门。如诸菩萨摩诃萨。心行坚固犹如金刚。生如来家种族。真正成就不坏常住命根。常然智灯无有尽灭。其身坚固不可沮坏。普能示现如幻色身。形貌端严。世无伦匹。随众生心无量差别。如缘起法转变无尽。毒刃火灾所不能害。降魔兵众。摧伏异道。身色妙好。如阎浮金。超过世间最胜无比。放大光网。普照十方。若有见者。必破一切障碍大山。必拔一切不善根本。必种广大殊胜善根。如是之人。难可得见。难得出现如优昙华。而我云何。能知能说彼功德行。善男子。于此南方有一国土。名圆满多闻其中有城名曰妙门。彼有童子。名根自在主。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。为欲成满诸菩萨行。欲修菩萨无尽功德。欲被菩萨大誓愿甲。欲放菩萨大力光明。欲成菩萨深信解力。欲起菩萨无量胜行。于菩萨法。心无厌足。乐入一切菩萨功德。愿常摄御一切众生。欲超生死稠林旷野。于善知识。常乐见闻。承事供养。心无厌倦。于无量法。心生尊重。顶礼妙见。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。受妙见比丘教已。忆持不忘。思惟修习。决定明了。于彼法门。随顺悟入。天龙夜叉。乾闼婆等。眷属围绕。渐次前行。向圆满多闻国。入妙门城。周遍推求根自在主童子。时虚空中。天龙神等。告善财言。善男子。今此童子。在河渚上。与诸童子。聚沙为戏。尔时善财。闻是语已。即诣其所。见彼童子。十千童子。前后围绕。聚沙为戏。见已亲近顶礼其足绕无数匝。合掌前立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。唯愿慈哀。为我解说。自在主言。善男子。我昔曾于文殊师利童子所。修学算数印相等法。即得悟入一切工巧神通智门。善男子。我因此故。知诸世间所有声论内明因明医方明等文字。算数契印取与种种智论。亦知一切药毒。蛊毒和合销解。亦能疗治风痫痟瘦鬼魅所著。如是所有一切诸病。亦能建立城邑聚落形胜所居市肆廛里园林池沼义堂福舍台榭楼观宫殿屋宅窗牖门闼种种庄严。亦善驾御驷马车乘斗战之法安危进止取舍胜负。亦善调炼种种仙药幻术变化。亦善营理田农商贾种种诸业。亦善礼仪尊卑次序。亦知众生身相吉凶业行善恶。亦知众生具足一切善不善根。亦知众生善趣恶趣种类差别。亦善了知一切贤圣清净业道。此人应得声闻乘道。此人应得辟支佛道。此人应得菩萨乘道。此人应入如来智地。如是乃至真俗二谛皆悉能知。亦知一切诸寂静众轨仪法式时非时食应所不应以自摄养而延寿命。亦知世俗治生方法经理资产出处贵贱。亦知自他过去受身中有分位入胎住胎经生差别。亦知未来一切众生。死此生彼。死彼生此。从彼处殁。还生于彼。从此处殁。还生于此。亦知过现一切诸佛差别法门。种种安布教授教诫。调伏众生能令坚固。随顺修持。越生死流。到涅槃岸。身心清净。如炼真金。光明普照。广大成就。善男子。我复善知十八工巧。种种技术。并六十二眷属明论。及内明等一切方法。治内烦恼。何等名为内身烦恼。有四因缘。一谓眼根摄受色境。二由无始取着习气。三由彼识自性本性。四于色境作意希望。由此四种因缘力故。藏识转变。识波浪生。譬如瀑流相续不断。善男子。如眼识起一切根识。微尘毛孔。俱时出生。亦复如是譬如明镜顿现众像。诸识亦尔。或时顿现。善男子。譬如猛风吹大海水。波浪不停。由境界风。飘静心海。起识波浪。相续不断。因缘相作。不相舍离。不一不异。如水与波。由业生相。深起系缚。不能了知色等自性五识身。转彼阿赖耶。终不自言。我生七识。七识不言从赖耶生。但由自心执取境相。分别而生。如是甚深阿赖耶识行相。微细究竟边际。唯诸如来住地菩萨之所通达。愚法声闻。及辟支佛。凡夫外道。悉不能知

大方广佛华严经卷第九

悉见法界一切如来从初发心修菩萨行成满大愿具足功德成等正觉转妙法轮乃至示现入于涅槃如是影像靡不皆现如净水中普见虚空日月星宿所有众像如此皆是慈行童女过去世中善根之力尔时善财童子忆念所见诸佛之相合掌瞻仰慈行童女大方广佛华严经卷第十

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

善男子。我又善知一切声论。音声语言。内外因起。名字训释。普遍无穷。假使帝释。于梵王所。听受声明。尽其天寿。足满千岁。亦不能知声论边际。我一念顷。以此算法。悉能了知。尽其源底。善男子。彼复教我菩萨算法。所谓百千为一洛叉。一百洛叉为一俱胝。俱胝俱胝为一阿庾多。阿庾多阿庾多为一那由他。那由他那由他为一频婆罗。频婆罗频婆罗为一矜羯罗。矜羯罗矜羯罗为一阿伽罗。阿伽罗阿伽罗为一微湿伐罗。微湿伐罗微湿伐罗为一钵啰伐罗。钵啰伐罗钵啰伐罗为一钵啰么。钵啰么钵啰么为一婆嚩罗。婆嚩罗婆嚩罗为一阿婆罗。阿婆罗阿婆罗为一多婆罗。多婆罗多婆罗为一獶钵弥耶。獶钵弥耶獶钵弥耶为一阿枲摩。阿枲摩阿枲摩为一普摩。普摩普摩为一祢摩。祢摩祢摩为一阿婆钤。阿婆钤阿婆钤为一微婆伽。微婆伽微婆伽为一微婆奢。微婆奢微婆奢为一没哩嚩迦。没哩嚩迦没哩嚩迦为一那贺罗。那贺罗那贺罗为一毗逻伽。毗逻伽毗逻伽为一弥嚩伽。弥嚩伽弥嚩伽为一毗伽婆。毗伽婆毗伽婆为一僧羯逻摩。僧羯逻摩僧羯逻摩为一毗萨罗。毗萨罗毗萨罗为一毗赡婆。毗赡婆毗赡婆为一慈汦伽。慈汦伽慈汦伽为一毗盛伽。毗盛伽毗盛伽为一毗噜陀。毗噜陀毗噜陀为一微皤诃。微皤诃微皤诃为一微薄帝。微薄帝微薄帝为一毗佉担。毗佉担毗佉担为一都逻那。都逻那都逻那为一阿睹[里*也]。阿睹[里*也]阿睹[里*也]为一嚩逻那。嚩逻那嚩逻那为一微皤兰。微皤兰微皤兰为一三末耶。三末耶三末耶为一微睹罗。微睹罗微睹罗为一奚婆罗。奚婆罗奚婆罗为一陀嚩罗。陀嚩罗陀嚩罗为一微度栗娜。微度栗娜微度栗娜为一奢弥陀。奢弥陀奢弥陀为一儞[口*尸]嚩啰。儞[口*尸]嚩啰儞[口*尸]嚩啰为一微者啰。微者啰微者啰为一微舍啰。微舍啰微舍啰为一微儞萨多。微儞萨多微儞萨多为一阿瓢孽哆。阿瓢孽多阿瓢孽哆为一微悉步多。微悉步多微悉步多为一泥嚩啰。泥嚩啰泥嚩啰为一波哩杀陀。波哩杀陀。波哩杀陀为一微目差。微目差微目差为一钵哩哆。钵哩哆钵哩哆为一喝哩多。喝哩多喝哩多为一阿噜迦。阿噜迦阿噜迦为一印[寧*吉]哩耶。印[寧*吉]哩耶印[寧*吉]哩耶为一系噜迦。系噜迦系噜迦为一奴嚩那。奴嚩那奴嚩那为一何噜那。何噜那何噜那为一婆噜陀。婆噜陀婆噜陀为一谜噜陀。谜噜陀谜噜陀为一乞羼耶。乞羼耶乞羼耶为一阿差目多。阿差目多阿差目多为一翳噜婆耶。翳噜婆耶翳噜婆耶为一微么噜耶。微么噜耶微么噜耶为一曼弩婆耶。曼弩婆耶。曼弩婆耶为一微洒[馬*犬]耶。微洒[馬*犬]耶微洒[馬*犬]耶为一三么陀。三么陀三么陀为一钵啰么怛啰。钵啰么怛啰钵啰么怛啰为一阿啰么怛啰。阿啰么怛啰阿啰么怛啰为一勃么怛啰。勃么怛啰勃么怛啰为一阿畔么怛啰。阿畔么怛啰阿畔么怛啰为一伽么怛啰。伽么怛啰伽么怛啰为一那么怛啰。那么怛啰那么怛啰为一奚么怛啰奚么怛啰奚么怛啰为一鞞么怛啰。鞞么怛啰鞞么怛啰为一钵啰么怛啰。钵啰么怛啰钵啰么怛啰为一尸么怛啰。尸么怛啰尸么怛啰为一翳啰。翳啰翳啰为一薜罗。薜罗薜罗为一帝罗。帝罗帝罗为一偈罗。偈罗偈罗为一窣步啰。窣步啰窣步啰为一制罗耶。制罗耶制罗耶为一泥罗。泥罗泥罗为一计罗。计罗计罗为一细罗。细罗细罗为一媲罗。媲罗媲罗为一谜罗。谜罗谜罗为一娑逻茶。娑逻茶娑逻茶为一谜噜陀。谜噜陀谜噜陀为一冥噜陀。冥噜陀冥噜陀为一契噜陀。契噜陀契噜陀为一摩睹罗。摩睹罗摩睹罗为一珠噜哆。珠噜哆珠噜哆为一娑母罗。娑母罗娑母罗为一阿野娑。阿野娑阿野娑为一迦么罗。迦么罗迦么罗为一摩伽婆。摩伽婆摩伽婆为一阿婆啰。阿婆啰阿婆啰为一系噜婆。系噜婆系噜婆为一吠嚧婆。吠嚧婆吠嚧婆为一迦涩嚩罗。迦涩嚩罗迦涩嚩罗为一何婆罗。何婆罗何婆罗为一毗婆啰。毗婆啰毗婆啰为一那婆罗。那婆罗那婆罗为一宁畔多。宁畔多宁畔多为一摩婆罗。摩婆罗摩婆罗为一娑啰那。娑啰那娑啰那为一勃逻摩。勃逻摩勃逻摩为一勃逻么那。勃逻么那勃逻么那为一微伽摩。微伽摩微伽摩为一邬波跋多。邬波跋多邬波跋多为一儞哩泥舍。儞哩泥舍儞哩泥舍为一阿差耶。阿差耶阿差耶为一三姥驮三姥驮三姥驮为一阿畔多。阿畔多阿畔多为一阿嚩摩娜。阿嚩摩娜阿嚩摩娜为一优钵罗优钵罗优钵罗为一波头摩。波头摩波头摩为一僧祇。僧祇僧祇为一阿婆俭弭耶。阿婆俭弭耶阿婆俭弭耶为一孽[亭*也]孽[亭*也]孽[亭*也]为一阿僧祇。阿僧祇阿僧祇为一阿僧祇转。阿僧祇转阿僧祇转为一无量。无量无量为一无量转。无量转无量转为一无边。无边无边为一无边转。无边转无边转为一无等。无等无等为一无等转。无等转无等转为一不可数。不可数不可数为一不可数转。不可数转不可数转为一不可称。不可称不可称为一不可称转。不可称转不可称转为一不可思。不可思不可思为一不可思转。不可思转不可思转为一不可量。不可量不可量为一不可量转。不可量转不可量转为一不可说。不可说不可说为一不可说转。不可说转不可说转为一不可说不可说。此又不可说不可说为一不可说不可说转。善男子。我复以此菩萨所知算数之法。分别算知无数由旬广大沙聚颗粒多少。亦能算知十方尽虚空所有世界种种安立差别次第。亦能算知十方所有一切世界广狭大小种种分量及以名字差别不同。所谓一切劫名。一切佛名。一切法名。一切谛名。一切业名。一切菩萨名。一切众生名。皆悉了知通达无碍。善男子。我唯知此一切工巧大神通智光明法门。如诸菩萨摩诃萨。能知一切诸众生数。及知一切诸众生名。能知一切法品类数。及知一切法品类名。能知三世诸时劫数。及知三世诸时劫名。能知一切诸如来数。及知一切诸如来名。能知一切诸菩萨数。及知一切诸菩萨名。亦能算知一切世界染净成坏相续次第。一切时分日月年劫相续次第。一切诸佛出兴名号相续次第。一切诸佛所转法轮相续次第。一切菩萨发心行道相续次第。一切菩萨成熟众生相续次第。一切众生所造因业相续次第。一切众生所受果报相续次第。如是乃至一切名相展转出生无尽缘起相续次第。如是菩萨所得算数自在法门。自利利他广大饶益。能令众生随顺悟入次第成熟究竟解脱。而我何能说其功德。示其所行。显其境界。彰其胜力。辨其乐欲。宣其助道。发其大愿。阐其妙行。演其诸度。赞其清净。开其殊胜智慧光明。如是菩萨所有功德。乃至少分。尚不能知。岂能尽知一切诸佛胜妙威神大功德海。圆满一切诸佛福智宝聚波罗蜜果。证悟诸佛如灯照现无碍法界。演说诸佛广大清净自在法轮。游戏诸佛最胜甚深三昧境界。觉了诸佛神通明智解脱法门。善男子。南方有城。名海别住。有优婆夷。名辨具足。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。闻是语已。欢喜踊跃。生尊敬心。获得希有信乐宝心。成就广大利众生心。悉能明见一切诸佛出兴次第。降生成道。说法涅槃。最胜清净究竟圆满。悟入甚深微妙智慧。普于诸趣。皆随现身。了知三世差别境界。获得无尽大功德藏。放大智慧自在光明。开三有城所有关键。趣向佛智究竟菩提。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。随顺思惟善知识教。正念观察。殷勤渴仰。心无厌足。犹如巨海。受大云雨。吞纳众流。作是念言。善知识教。犹如春日。生长一切善法根苗。善知识教。如秋满月。凡所照触身意清凉。善知识教。如夏雪山。能除一切诸兽热渴。善知识教。如芳池日。能开一切善心莲华。善知识教。如日珠轮。照引众生。至法宝处。善知识教。如阎浮树。开敷一切福智华果。善知识教。如大龙王。自在兴布妙法云雨。善知识教。如妙高山。积集种种无漏功德。三十三天庄严止住。善知识教。如天帝释。功德诸天所共围绕。能破爱见阿修罗军。如是思惟。渐次前行。至海住城。周遍求觅此优婆夷。时彼众人。咸告之言。善男子。彼优婆夷。在此城内住自宅中。善财闻已。即诣其门。合掌而立。见其舍宅。广博殊丽。种种庄严。众宝垣墙。周匝围绕。四面皆有宝庄严门。善财入已。见优婆夷。处于宝座。妙年盛色。容貌端严。不御华璎。素服垂发。威光殊特。人所乐见。除佛菩萨。余无能及。有胜威力。有广大心。令诸众生见闻亲近。咸生尊重爱敬之心。于其宅中。敷十亿座。超诸人天一切所有。皆是菩萨业力所成。宅内无有衣服饮食。及余严具。但于其前。置一小器。复有十千童女围绕。一切妙宝庄饰其身。言音和雅。常侍左右。瞻仰承顺。情无厌怠。身出妙香。普熏城内。及遍虚空。一切人天。闻其香者。于菩提心。皆不退转。其余众生。遇斯香者。身心柔软。无怒害心。无怨结心。无悭嫉心。无谄诳心。无险曲心。无贪爱心。无嗔恚心。无幻伪心。无下劣心。无高慢心。无邪僻心。无障碍心。无执着心。住平等心。起大慈心。发利益心。住律仪心。离贪求心。闻其声者。欢喜踊跃。见其身者。悉离贪染尔时善财。即前顶礼优婆夷足。右绕恭敬。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。彼即告言。善男子。我得菩萨无尽福德庄严藏解脱门。能于如是一小器中。随诸众生种种欲乐。如应为出种种甘美上好饮食。色香味触悉皆充足。善男子。我此器中所出饮食。假使百众生。千众生。百千众生。亿众生。百亿众生。千亿众生。百千亿众生。那由他众生。乃至不可说不可说众生。假使阎浮提。极微尘数众生。一四天下极微尘数众生。小千世界中千世界大千世界极微尘数众生。乃至不可说不可说佛刹极微尘数众生。假使十方一切世界极微尘数众生。随其欲乐。悉令充满。饥渴消除。身心安乐。智慧增长。然其饮食。无有穷尽。亦不减少。如出饮食。乃至能出种种床座。种种敷具。种种缯彩。种种衣服。种种车乘。种种幢幡。种种轩盖。种种华鬘。种种璎珞。种种珍宝。种种散香。种种丸香。种种涂香。种种烧香。种种末香。乃至种种如法资具。随其来者。普心给施。不择怨亲贵贱贫富。如所意愿。悉令丰足。皆于我所。生尊重心。生恭敬心。生无厌心。生调伏心。善男子。假使东方一世界中所有众生。修习声闻独觉乘者。食我食已。皆证声闻独觉乘果。住最后身。如一世界。如是次第。百世界。千世界。百千世界。亿世界。百亿世界。千亿世界。百千亿世界。百千亿那由他世界。阎浮提极微尘数世界。一四天下极微尘数世界。小千世界极微尘数世界。中千世界极微尘数世界。大千世界极微尘数世界。乃至不可说不可说佛刹极微尘数世界。其中所有一切众生。修习声闻独觉乘者。食我食已。皆证声闻辟支佛果。住最后身。南西北方。四维上下。亦复如是。又善男子。如东方一世界。乃至不可说不可说佛刹极微尘数世界。其中所有最后身菩萨。食我食已。皆诣最胜菩提道场。降伏魔军。成等正觉。南西北方。四维上下。所有一世界。乃至不可说不可说佛刹极微尘数世界。其中所有最后身菩萨。食我食已。皆得往诣最胜道场。降伏魔军。成等正觉。善男子。汝见我此十千童女眷属以不。答言已见。优婆夷言。善男子。今我所有菩萨眷属百万阿僧祇。此十千童女而为上首。皆悉与我行同类行。同一大愿。同一善根。同出离道。同清净解。同清净信。同清净念。同清净趣。同清净智。同无量觉。同净诸根。同普遍心。同广大心。同所行境。同所证理。同决定解。同明了法。同净妙色。同无量力。同最精进。同正法音。同随类音。同清净音。同第一音。同赞功德。同清净业。同清净报。同广大慈。同普遍悲。同普救护。同遍成熟。同净身业。随缘现起。如所应见。皆令欢喜。同净语业。于法自在。随俗训释。宣布法化。同能普诣诸佛道场。同能普往一切佛所。供养承事。同现觉智。悉解诸佛差别法门。同得安住一切菩萨清净行地。善男子。是十千童女。能取此食。于一念顷。遍至十方。供养一切住最后身诸大菩萨。及供一切声闻独觉。乃至遍诣十方世界诸饿鬼趣。皆令充足。除其饥渴。善男子。此十千童女。又取我食。能于天中。充足天食。亦于龙中。充足龙食。乃至能于人非人中。随其所须。施诸饮食。悉令充足。我此器中。曾无减少。何况有尽。善男子。且待须臾。汝当自见。说是语时。善财即见无量众生从四门入。皆优婆夷本愿所请。既来集已。敷座令坐。随其所须。给施饮食。乃至种种上妙资具。悉皆充足。令诸众生心生欢喜。安隐适悦。互相庆慰。而此器中所出之物。无减无尽。时优婆夷。作此施已。告善财言。善男子。我唯知此菩萨无尽福德庄严藏解脱门。如诸菩萨摩诃萨无尽福德大庄严藏。甚深无底犹如大海。广大无际犹若虚空。满众生心如如意珠。所求皆得如大宝聚。拥护一切如轮围山。长诸善根如大云雨。守护法藏犹如关钥。普集法宝如妙高山。破无明闇犹如灯烛。普荫群生犹如高盖。而我云何能知能说彼功德行。善男子。南方有城。名为大有。彼有长者。名具足智。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。得菩萨无尽庄严福德藏解脱门已。随顺思惟彼福德大海。观察彼福德虚空。向彼福德聚。登彼福德山。摄彼福德藏。饮彼福德泉。游彼福德池。净彼福德场。见彼福德藏。入彼福德教。开彼福德眼。行彼福德道。植彼福德种。渐次而行。至大有城。周遍询求明智居士。于善知识。心生渴仰。念善知识。心无间断。慕善知识。志乐坚固。方便求见诸善知识。常无厌足。愿得承事诸善知识。精勤匪懈。以善知识。熏修其心。知由依止善知识故。能满众善。知由依止善知识故。能生众福。知由依止善知识故。能长众行。知由依止善知识故。不由他教。自能承事一切善友。知由依止善知识故。清净一切菩萨诸根。如是思惟。长其善根。深其志乐。益其德本。广其大悲。近一切智。具普贤道。照明一切诸佛正法。增长菩萨所有行愿。明照如来十力智光。尔时善财。见彼居士。在于城内市四衢道。七宝台上。处于众宝庄严之座。其座妙好无数清净如意宝王。以为其身。种种金刚帝青摩尼。以为其足。宝绳珠网以为交络。无垢藏摩尼宝而校饰之。复以五百妙宝形像而为庄严。敷天宝衣。建天幢幡。张大宝网。施大宝帐。阎浮檀金以为其盖。净琉璃宝以为其竿。令人执持。以覆其上。鹅王羽翮以为其扇。白牦牛尾以为其拂。悉以离垢妙宝庄严。天诸童子。执侍左右。熏众妙香。雨众天华。昼夜常奏五百乐音。其音美妙。过于天乐。众生闻者。无不欢悦。十千眷属前后围绕。色相端严。人所喜见。天庄严具。以为严饰。出过天人。最胜无比。悉已成就菩萨志欲。皆与居士同昔善根。侍立瞻对。承其教命。时彼城内一切众生。及虚空中所有天众。于居士所。生随顺心。生爱乐心。生欢喜心。以心随顺欢喜。爱乐善知识故。即起一切天拘苏摩妙宝华云。普雨一切天拘苏摩妙宝华雨。是诸人天。亦与居士。往昔同种清净善根。尔时善财。见是事已。前礼其足绕无数匝。合掌而立。白言圣者。我为利乐诸众生故。发阿耨多罗三藐三菩提心。为令一切众生灭除苦难故。为令一切众生究竟安乐故。为令一切众生出生死海故。为令一切众生入法宝洲故。为令一切众生枯竭爱河故。为令一切众生起大慈悲故。为令一切众生舍离贪着故。为令一切众生渴仰佛智故。为令一切众生越度生死大旷野故。为令一切众生爱乐诸佛胜功德故。为令一切众生出三界城故。为令一切众生入一切智城故。以如是等种种利益。发菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。而能摄护一切众生。为诸众生作依止处。我闻圣者。善能诱诲。愿为我说。居士告言。善哉善哉。善男子。汝乃能为如是利故。发阿耨多罗三藐三菩提心。善男子。发阿耨多罗三藐三菩提心。是人难得。若能发心。是人则能求菩萨行。心无动转。值遇善知识。心无厌足。亲近善知识。心无劳倦。承事善知识。心无忧戚。供养善知识。终不退转。爱念善知识。终不放舍。渴仰善知识。无暂懈息。求觅善知识。无时憩止。行善知识教。未曾怠惰。禀善知识命。心无误失。善知识者。有大威力。难得亲近承事供养。若能给侍瞻礼赞叹。心无忧悔。则得具足一切功德。不为烦恼毒乱其心。善男子。汝见我此十千眷属众会人不。答言已见。居士言。善男子。我已令其发阿耨多罗三藐三菩提心。生如来家。增长白法。安住无量诸波罗蜜。学佛十力。离世间种。住如来种。坏生死轮。转净法轮。灭三恶趣。住正法趣。如是等诸菩萨行。悉能成就。普能救护一切众生。善男子。我得随意出生福德藏解脱门。一切众生。凡有所须。悉满其愿。所谓须食与食。须饮与饮。如是种种衣服。璎珞。华鬘。缯彩。烧香。涂香末香。金银真珠。珍奇众宝。种种幢幡。种种轩盖。房舍屋宅。倚卧之具。种种灯烛。病缘汤药。种种船舫。象马车乘。奴婢牛羊。及诸侍使。如是一切资生之物。亦复能与。天冠宝饰。髻中明珠。乃至所爱妻妾男女。眼耳鼻舌。皮肉骨髓。身体手足。不拣贫富贵贱好丑。随其来意。皆悉与之。乃至为说真实妙法。使令修证究竟圆满。善男子。且待须臾。汝当自见。说是语时。无量众生。从种种方所。种种世界。种种国土。种种城邑。种种聚落。种种居处。形类差别。爱乐不同。其数无量。皆以菩萨往昔愿力。俱来集会。尔时居士。知众云集。普遍观察。系念须臾。仰视虚空。如其所须。悉从空下。相续流入居士掌中。随诸众会。一切愿求皆手授与。普令满足。既满愿已。生大欢喜。身色光悦。心意调柔。堪任受化。然后为说种种妙法。所谓为得充足诸美食者。与说种种集福德门。演说一切离贫穷行。演说富饶甘露财行。演说法智大尊重行。演说相好庄严身行。成就威德降魔怨行。成就法喜禅悦食行。增长成就难屈伏行。善能了达无上食行。令得常命色力安辩具足法门。为得充足诸好饮者。与其说法。令于生死。舍离渴爱。欣乐佛乘。入深法味。为得充足诸上味者。与其说法。皆令具足充满法味。证得如来味中上味。为得充足种种舟船及车乘者。与其宣说出离法门。皆令越度生死大海。载于最胜无上大乘。为得充足诸衣服者。与其说法。令得清净惭愧之衣。乃至如来清净妙相。金色皮肤。如是一切资生之物。随意与之。靡不周赡。然后悉为如应说法。随其所宜。各令悟入无上清净。智慧法门。既闻法已。还归本处。尔时居士。为善财童子。显示菩萨不可思议解脱境界已。告言。善男子。我唯知此随意出生福德藏解脱门。如诸菩萨摩诃萨。成就宝手。遍覆十方一切世界。为供养佛。普施众生以自在力。兴种种色宝云。雨种种色宝雨。所谓种种色璎珞。种种色宝冠。种种色妙鬘。种种色世服。种种色法衣。种种色严具。种种色宝华。种种色妙香。种种色涂香。种种色末香种种色楼阁。种种色宝盖。种种色幢幡。种种色音乐。其声美妙。歌赞佛法。乃至种种资生之具。普遍一切众生住处。充满一切佛刹道场。悉以供养一切诸佛。亦为成熟一切众生。而我云何能知能说彼诸功德自在神力。善男子。于此南方。有一大城。名师子宫。彼有长者。名尊法宝髻。汝往彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。欢喜踊跃。深自庆幸。知因一切善知识故。圆满功德。于善知识。尊重谦卑。如弟子礼。作如是念。由此居士开悟于我。令我得闻希有之法。由是思惟。不断爱念善知识见。不坏尊重善知识心。常乐受行善知识教。决定信顺善知识语。敬善知识。展转增胜。事善知识。心无退转。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第十大方广佛华严经卷第十一

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。于居士所。闻此甚深解脱门已。思惟修习。决定无间游彼福德海。净彼福德田。趣彼福德津仰彼福德山。开彼福德藏。转彼福德轮。观彼福德法。植彼福德因。生彼福德力。增彼福德势。长彼福德心。悟彼福德门。渐次行诣师子宫城。周遍推求宝髻长者。见在市中。遽即顶礼。绕无数匝。合掌前立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。善哉圣者。愿为我说诸菩萨道。我乘此道。趣一切智。尔时长者。执善财手。将诣其家。示其所居。告善财言。善男子。汝且观我所居舍宅。尔时善财。即遍观察。见其舍宅。广博严丽。于其四面。各开二门。阎浮檀金之所合成。白银为墙。周匝围绕。玻璃为殿。杂宝庄严。绀琉璃宝以为楼阁。砗磲妙宝而为其柱。阶墀轩槛户牖窗闼。靡不咸以众宝所成。百千种宝庄严校饰。码瑙宝池。香水盈满。四面栏楯。络以真珠。杂宝树林周遍行列。赤珠摩尼为师子座。阿僧祇宝间错庄严。毗卢遮那摩尼宝王以为其帐。于其座前左右建立。光焰炽盛摩尼宝幢。杂色光明如意珠王。而为其网。以覆其上。于其宅内。有大楼阁。高十层级。层开八门。善财入已。次第观察。见最下层。施以种种上味饮食。见第二层。施诸宝衣及众财物。见第三层。普施一切宝庄严具。见第四层施诸采女。言辞善巧随意眷属。并所受用上妙珍宝见第五层。五地菩萨云集其中。为安众生。演说妙法。诸所施为。无非利乐。成就如来最胜论者。陀罗尼门。诸三昧海。及诸世间种种明智。光明印行。见第六层。有诸菩萨。皆已成就甚深智慧。了达法性。得大总持。三明六通。皆悉具足。入普藏门。出障碍境。住不二法。现佛威仪。于不可说妙庄严海道场众中。而共集会。各以异名。分别显示般若波罗蜜门。所谓寂静藏般若波罗蜜门。善巧分别诸众生智般若波罗蜜门。不可动转般若波罗蜜门。离欲光明般若波罗蜜门。不可降伏藏般若波罗蜜门。照众生轮般若波罗蜜门。随顺教网般若波罗蜜门。功德海藏般若波罗蜜门。普眼舍得般若波罗蜜门。入无尽藏随顺修行般若波罗蜜门。入一切世间无尽方便海般若波罗蜜门。入随诸世间一切教海般若波罗蜜门。无碍辩才般若波罗蜜门。随顺众生普照无碍般若波罗蜜门。离垢光明般若波罗蜜门。常观宿缘而布法云般若波罗蜜门。说如是等百万阿僧祇般若波罗蜜门。遍不可说道场众会。显示庄严甚深智慧。见第七层。得如响忍诸菩萨等。充满其中。以方便智。分别演说诸出离门。悉能闻持一切如来所说正法。见第八层。得不退转神通智力无量菩萨。共集其中。以微细智。观诸世间。知诸佛刹道场众会。如幻如焰。如影如像。无有实性。见诸如来无分别境。现一切佛普遍色身。能以一音遍十方界。其身普诣一切道场。尽于法界。靡不周遍。普入佛境。普见佛身。普能受持一切佛法。普于一切佛众会中。而为上首。演说法要。见第九层。一生所系诸菩萨众。于中集会。见第十层。一切如来充满其中。从初发心。修菩萨行。超生死轮。成大愿海。具胜神通。得胜自在。以胜威力。净佛国土。殊胜庄严。普现十方道场众会。演说正法。乃至示灭。尽未来际。调伏利益。化度众生。如是一切。悉使明见

尔时善财。见如是等奇特事已。白言圣者。昔于何处。种何善根。获如是等殊胜果报。致此一切清净众会。长者告言。善男子。我念往昔过佛刹极微尘数劫。有世界。名种种色庄严轮。佛号无边光圆满法界普庄严王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。与百千亿声闻众俱。智毗卢遮那而为上首复与百千亿菩萨众俱。智日威德光而为上首。时彼国王。名法自在。佛受王请。入摩尼幢庄严园中。我于衢路。奏妙乐音。烧一丸香。而以供养。由彼如来与诸菩萨及声闻众。受我供故。令此香烟起大香云。普遍虚空而为荫盖。于阎浮提。七日七夜。普雨种种无边众色众生身相微妙香云。又令乐音出生种种美妙音声。普遍虚空。演出如来不可思议三世无碍广大智聚。令其闻者。除灭一切烦恼垢障。增长一切真实善根。速疾圆满一切智智。普能发起种种神通。我时以此供养善根。回向三处。一愿永离贫穷困苦。二愿常见诸佛菩萨。三愿恒闻诸佛正法。由是因缘故获斯报。善男子。我唯知此菩萨无障碍愿普遍庄严福德藏解脱门。如诸菩萨摩诃萨。得不思议功德宝藏。出不思议无量功德。入无分别如来身海。荫无分别无上法云。修无分别功德助道。起无分别普贤行网。证无分别三昧境界。等无分别菩萨善根。住无分别如来所住。见无分别三世平等。于一切劫。不生疲厌。住不可坏普眼境界自在之地。而我云何能知能说彼功德行。善男子。南方有国。名曰藤根。其国有城。名普遍门。中有长者。名为普眼。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。于宝髻长者所。闻此解脱已。深入诸佛无量知见。安住菩萨无量胜行。了达菩萨无量方便。希求菩萨无量法门。清净菩萨无量信解。明利菩萨无量诸根。成就菩萨无量欲乐。通达菩萨无量行门。增长菩萨无量愿力。建立菩萨无边胜幢。发起菩萨无边智慧。证得菩萨无边法光。普入菩萨无边大会。于菩萨法。决定无疑。趣求菩萨清净解脱。住菩萨心。深信爱乐。随顺作意。渐次前行。至藤根国。处处寻访彼城所在。虽历艰难不惮劳苦。身无疲倦。心无厌退。但唯正念善知识教。愿常亲近承事供养。遍策诸根。离众放逸。于善知识。心恒爱乐。然后乃到普遍门城。百千聚落周匝围绕。其城广大。种种庄严。雉堞崇峻。衢路宽平。市列百工。货多珍异。往来委输。人物可观。尔时善财。于彼城内。推求寻觅长者所居。人咸报言。住市肆中鬻香药处。闻已往诣。见其处在香台座上。即前礼足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。长者告言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我昔曾于文殊师利童子所。修学了知病起根本。殊妙医方。诸香要法。因此了知一切众生种种病缘悉能救疗。所谓风黄痰热。鬼魅蛊毒。乃至水火之所伤害。如是一切内外诸疾品类无边。我悉能于一念之中。以种种方药。如法疗治。咸令除差。施其安乐。如是法门。汝应修学。善财复言。圣者。我问菩萨所修妙行。云何说此世俗医方。长者告言。善男子。菩萨初学修菩提时。当知病为最大障碍。若诸众生。身有疾病。心则不安。岂能修习诸波罗蜜。是故菩萨。修菩提时。先应疗治身所有疾。菩萨复观一切世界所有众生。营辨事业。受于欲乐乃至出家。精勤修习。得圣道果皆因国王。王之理化要因无病。何以故。以诸人王。是诸众生安乐本故。菩萨起化。先疗国王。次治众生。令无患苦。然后说法。调伏其心。善男子。菩萨若欲治诸病者。先当审观诸病因起。品类增损无量无边。我今为汝说其少分。善男子。一切众生。因四大种和合为身。从四大身。能生四病。所谓身病。心病。客病。及俱有病。言身病者。风黄痰热而为其主。言心病者。颠狂心乱而为其主。言客病者。刀杖所伤。动作过劳。以为其主。俱有病者。饥渴寒热。苦乐忧喜而为其主。其余品类。展转相因。能令众生受身心苦。善男子。如是众病。贫贱人少。多劳役故。富贵人多。过优乐故。善男子。一切众生。皆以无量极微大种聚集成身。犹如大海众微水滴。如是人身。毛及毛孔。各三俱胝。三俱胝虫之所依住。以是谛观。皮肤穿漏。两眼睛内。手足掌中。脂膏集处。毛虫不生。其余身分。间无空缺。善男子。又观此身。唯五大性。何等为五。所谓坚湿暖动及虚空性。所言坚者所谓身骨三百六十。及诸坚鞕皆地大性。凡诸湿润。皆水大性。一切暖触。皆火大性所有动摇。皆风大性。凡诸窍隙皆空大性。然彼四大皆多极微。于空界中。互相依住。极微自性。微细难知。除佛菩萨。余无能见。善男子。如是五大和合成身。如世仓篅。终归败散。如是身器。由业所持。非自在天之所能作。亦非自性。及时方等。譬如陶师埏埴成器。内盛臭秽。彩画严饰。诳惑愚夫。又如四蛇置之一箧。如是四大和合为身。一大不调。百一病起。是故智者应观此身如养毒蛇。如持坏器。善男子。汝复应知内身外器。皆四大成。从始至终。五时流变。云何外器五时流变。谓尽虚空十方世界众生。所感妄业所持。劫初成时。人寿无量。自然化生。无我我所。次食段食贪等现行。次由我所共立田主。以为统御。次寿渐减。乃至十年。由恶业故。起小三灾。至第五时。世界将坏。火灾既起。梵世皆空。水灾风灾。相续亦尔。善男子。是名外器五时流变。云何内身五时流变。谓婴孩位。心无分别。如劫初时人无我所。次童幼位。能辨是非。如第二时立自他别。次壮年位。纵贪嗔痴。如第三时共立田主。次衰老位。众病所侵如第四时寿等损减。次至死位。身坏命终。如第五时世界坏灭。是名内身五时流变。善财白言。圣者。如是五时。因何而起。普眼告言。善男子。时无自体。分别所成。随妄业轮。循环无际。如人睡觉则名初时。从初刹那及怛刹那。次名腊缚牟呼栗多。昼夜年劫。时多差别。或约一岁。分为六时。所谓春时。热时。雨时。秋时。寒时。雪时。是故智者。知病增损。善达方域。所有诸时。谓春雪时。痰癊病动。于热雨际。风病发生。于秋寒时。黄热增长。总集病者。随时增长。善男子。我今为汝已说诸病随时增长。如是身病。从宿食生。若诸众生。能于饮食。知量知足。量其老少。气力强弱。时节寒热。风雨燥湿。身之劳逸。应自审察。无失其宜。能令众病无因得起。善男子。我此住处。常有十方一切众生诸病苦者。来至我所。而求救疗。我以智力。观其因起。随病所宜。授与方药。平等疗治。普令除差。复以种种香汤沐浴上服名衣。璎珞庄严施诸饮食。及诸财宝。珍玩资具。皆悉与之。咸令充足。然后各为如应说法。令其永断心病烦恼。所谓为诸一切贪欲多者教不净观。嗔恚多者教慈悲观。愚痴多者教其分别种种法相。等分行者。为其显示不净慈悲。或略中广。殊胜法门。如是随应。断诸烦恼。为欲令其发菩提心。称扬一切诸佛功德。为欲令其起大悲心。显示生死无量苦恼。为欲令其增长功德。赞叹修集无量福智。为欲令其发大誓愿。称赞调伏一切众生。为欲令其修普贤行。说诸菩萨住一切刹。于一切劫修诸行网。为欲令其具佛相好庄严色身。称扬赞叹檀波罗蜜。为欲令其得佛清净无垢法身。称扬赞叹尸波罗蜜。为欲令其得佛功德不思议身。称扬赞叹忍波罗蜜。为欲令其获于如来无能胜身。称扬赞叹勤波罗蜜。为欲令其得佛清净无与等身。称扬赞叹禅波罗蜜。为欲令其得佛究竟平等法身。称扬赞叹般若波罗蜜。为欲令其得佛普现差别色身。称扬赞叹方便波罗蜜为欲令其为诸众生。住一切劫。心无厌倦。称扬赞叹愿波罗蜜。为欲令其普现其身。严净一切诸佛刹土。称扬赞叹力波罗蜜。为欲令其现清净身。随众生心悉使欢喜。称扬赞叹智波罗蜜。为欲令其获于究竟最胜净妙无染着身。称扬赞叹永离一切诸不善法。回向诸佛一切善法。如是种种广以财法。施诸众生。悉满所愿。各令授化欢喜而去。善男子。我又善知和合一切诸香要法。所谓无等香王香。频头萨哩多香王香。(此香状如水滴)无能胜香王香。种种觉悟香王香。阿缕拏袜低香王香(其香色赤如初日色树汁流以为香)随身所欲出生香王香。随时坚细栴檀香王香。龙胜坚固栴檀香王香。(梵音乌洛迦婆啰香)坚黑沉水香王香。不动诸根香王香。如是等香。悉知出处功能势力。及其贵贱调理之法。善男子。我持此香。以为供养。普见诸佛。所愿皆满。所谓救护一切众生愿。严净一切佛刹愿。供养一切如来愿。善男子。我欲供养然此香时。从一一香。出无量香。遍满十方一切法界一切如来道场海中。化为种种香宫殿。香垣墙。香楼阁。香栏楯。香却敌。香门户。香窗牖。香半月。香罗网。香形像。香圆光。香严具。香光明。香云雨。香幢。香帐。香幡。香盖。庄严十方一切法界。处处充满。以为供养。善男子。我唯知此令一切众生普见诸佛承事供养欢喜法门。如诸菩萨摩诃萨。如大药王。若见若闻。若忆。若念。若同住。若共行。若称名。若随喜。皆获利益。无空过者。若有众生。暂得值遇。必令销灭一切烦恼。入于佛法。离诸苦蕴。永息一切生死怖畏。到无所畏一切智处。摧坏一切老死大山。安住平等大涅槃城。而我云何。能知能说彼功德行。善男子。于此南方。有一大城。名多罗幢。彼城有王。名甘露火。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼普眼足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。于普遍眼善知识所。闻说菩萨能令众生普见诸佛欢喜法门。随顺忆念。心心相续。欢喜踊跃。作是思惟。善知识者。以善方便能摄受我。以深重心能守护我。令我于阿耨多罗三藐三菩提。得不退转。如是专念。生净信心。欣庆心。怡畅心。调顺心。勇进心。寂静心。广大心。庄严心。无著心。无碍心。得心。自在心。常作心。师心善巧分别心。普生众行心随闻解法心。遍往佛刹心。见佛庄严心。恒不离佛心。专求十力心。一向无退心。渐次前行。经历国邑村营聚落。然后乃至多罗幢城。处处寻求见王方便。于时遇有多闻多解诸婆罗门。在于四衢。谈论世法。善财往问。云何得见甘露火王。时彼多智大婆罗门。问善财言。仁从何来。何所求请。欲见我王白言。我从藤根国来。普眼长者。教我获得欢喜法门。令我来此。求见大王。请问菩萨行菩萨行。婆罗门言。彼藤根国安隐。丰乐。仁之色相。德慧庄严。舍彼来此。必获利益。以仁大智。必见我王。仁且安坐。听我所说。我王恒居宝严正殿。坐胜摩尼师子之座。颁行正法。成就众生。善财复言。何故大王。名甘露火。答言。我王具足七支。行中道化。治罚恶人。销其过犯。犹如烈火。安摄善人。与其快乐。譬如甘露。以是慈悲平等教化。增其寿命。心无厌足。故我国人。美王盛德。歌赞王猷。咸称我王。为甘露火。我王复以种种方便。调御众生。决其诤讼。抚其孤弱。恤其茕独。遂其胜行。皆令永断十不善业。正修十善。如转轮王所行之法。善财复言。云何名为具足七支行中道化。答言。审听当为宣说言。七支者。一有君德。天下仰戴如人之首。二有辅臣。左右忠良如人之臂。三有国境。宽富包容如人之腹。四有险固。囊结万方如人之脐。五有仓库。财食充盈。所往无难。如人之髀。六有兵威。士马精锐。制动由己。如人之胫。七有邻境。贡赋以时。往复王命。如人之足。复有二法。能持七支。一谓威勇。二谓智谋。二德相资。如人目足。七支依住。正教施行。所向皆从。靡不流布。如山出云。如地持物。泽润卉木。德被黔黎。由是四海。皆遵圣化。支德互阙。如车只轮。如鸟一翼。决定不能翔空致远。我王咸具。名称普闻仁复当知。我国大王。成就九法。能转王轮。何等为九。一德伏四邻。自修职贡。二贡赋不入。恩信感之。三感之不从。说其君臣。令相疑阻。四彼或革心。君臣异议。说使和同。令归圣化。五善说不听。王师讨伐。六观彼主率将德有无。七审其寡德议其城守。八知彼牢城料兵强弱。九自揣国中人和兵锐。我国大王。具此九法。慧眼常明。照瞩一切。是故八表咸归正化。自求臣属。永不退还。譬如众流潮宗于海。皆同一味。无有异心。仁者当知。我国大王。奉事多佛。是大菩萨。具大慈悲。应现人间。覆育群品。知诸众生。应渐调伏。先宣王法。渍润其身。究竟令其心得解脱。是故我王有二圣德。何等为二。一者内德。种族真正。仁慧深远。二者外德。如上略明后当广说。善财白言。云何内德。愿为说之。答言仁者。我国大王。种族尊胜。嫡嗣承袭。历代相传。入胎处胎。诸天护念。出胎已后。乃至受位。福庆交至。万国欢娱。圣德日跻。博闻强记。仁智孝友。恭慈惠和。听视聪明。具诸惭愧。有具足力。身无众患。含垢忍辱。心无卒暴。尊贤重德。愍哀庶类。于己财位。恒知止足。于他危难。常思救护。善摄五根。不纵情志。辩才无碍。能师子吼。发言诚谛。离诸爱恚。善解世间殊音异论。威仪整肃。人咸畏敬。慰谕辅臣。抚育黎庶。怜愍众生。等心无二。察人辞色。悉知其心。见象马形。亦知善恶。于有恩德。报复无疲。于怨恶人。善巧将护。行幸城邑。端坐车中。审谛自心。无内外顾。依时出入。以慰国人。有或不顺。返逆王命。酷害王民。动作非法。先以善言。如法开示。舍逆从顺。王必慈恕。依所领处。不减不夺。亦不驱摈。闻命不悛。当加讨罚。克敌制胜。务在安人。是故我王。善称遐布。仁者当知。居俗日夜。分为八时。于昼与夕。各四时。异一一时。中又分四分。通计日夜三十二分。以水漏中。定知时分。昼四时者。自鸡鸣后。乃至辰前。为第一时。辰初分后。至午分初。为第二时。午中分后。乃至申前。为第三时。申初分后。至日没前。为第四时。于第一时。日未出前。为初二分。日出已后。乃至朝毕。为后二分。如是四分。名日初时。我王精勤。不着眠睡。于夜四时。二时安静。第三时起。正定其心。受用法乐。第四时中。外思庶类。不想贪嗔。自昼初时。先嚼杨枝。乃至祠祭。凡有十位。何者为十。一嚼杨枝。二净沐浴。三御新衣。四涂妙香。五冠珠鬘。六油涂足。七擐革屣。八持伞盖。九严侍从。十修祠祭。善财问言。云何大王。每自晨朝。要嚼齿木。乃至祠祭。然后临朝。答言仁者。世界增长。要因于王。王欲理人。先自理身。以身安故。心意和平。神清体和。布化无爽。是故我王。先嚼杨枝。乃至祠祭。又此十事。一一能生十种功德。初嚼杨枝。具十德者。一销宿食。二除痰癊。三解众毒。四去齿垢。五发口香。六能明目。七泽润咽喉。八唇无皴裂。九增益声气。十食不爽味。晨朝食后。皆嚼杨枝。诸苦辛物。以为齿木。细心用之。具如是德

复次我王。香水沐浴。具十功德。一能除风。二去魑魅三精气充实。四增益寿命。五解诸劳乏。六身体柔软。七净除垢秽。八长养气力。九令人胆勇。十善去烦热

复次我王。御新净衣。具十功德。一增长吉祥。二行步适悦。三眷属爱敬。四处众无畏。五安乐身心。六能益寿命。七净无尘垢。八名称远闻。九贤圣护念十一切赞叹

复次我王。涂诸妙香。具十功德。一增益精气。二令身芳洁。三调适温凉。四长其寿命。五颜色光盛。六心神悦乐。七耳目精明。八令人强壮。九瞻睹爱敬。十具大威德

复次我王。冠妙珠鬘。具十功德。一胜福日增。二殊珍自至。三颜色充悦。四辩才清畅。五具足吉祥。六身心无恼。七吉庆恒集。八益其寿命。九具大胆勇。十奉觐欢喜

复次我王。足涂香油。具十功德。一能除风疾。二身心轻利。三耳目聪明。四增益精气。五念无忘失。六减省昏睡。七眠梦吉祥。八延其寿命。九除诸垢秽。十不生众疾

复次我王。擐妙革屣。有十功德。一足趺柔软。二身触轻安。三行步有力。四益其精气。五举止安详。六增长寿命。七威仪整肃。八左右欢喜。九形相端严。十诸天敬畏

复次我王。侍卫持盖。具十功德。一威严尊重。二颜色鲜明。三露行去热。四不犯风尘。五能遮雨湿。六不视无福。七众人敬畏。八身得安宁。九益寿增气。十清净光华

复次我王。庄严侍卫。具十功德。一威仪严整。二令人敬畏。三增王胆勇。四佐王威势。五降伏恶人。六天神自卫。七禁御暴兽。八舒畅王意。九邪魅不侵。十行王教令。如是庄严眷属围绕。故我大王。如御驾驷。检察前后。调息自他。宽猛合度。刚柔称适。如大舶主。统领诸船。随有穿漏。应时补塞。奉侍王人。内宫采女。耆德耄齿。监守王宫。妍貌壮年。令其侍卫。或前行导引。烧香散华。吹贝鼓乐。歌咏赞叹。种种庄严。或侍从王行。执扇持拂。涂香衣服。众妙资具。随时受用。靡不备足。如是导从。以候王心

大方广佛华严经卷第十一大方广佛华严经卷第十二

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

时婆罗门。复告善财言。我王圆满如上种种法式清净威仪。先入道场。礼敬贤圣。上祈福祐。泽润含生。或祠祭祖宗。思报恩德。教人孝敬。冥益万方。或出游巡狩。抚俗省方。御众班师。功成告谢。水旱灾祥。省躬庆祐。祀祭之时。一心专念。恭敬无怠。如对目前。想其仪形。思其教诲。感涕荐奉。罄志无私。国内辅臣。有功有德。贤良节行。在家出家硕德高年人所宗事。设命终已。图画形容。随其行业。建诸塔庙。我王如是日日之中。内尽诚心。外精供事。饮食财宝。上妙珍奇祠敬礼拜。曾无懈废。如上十种首嚼齿木乃至祠祭。于昼初时前二分毕日初出时。先召良医。候其安否。昼夜时分。服食量宜。次召历算。占候阴阳。风雨日辰。星月运数。行度差正。隐现灾祥。福庆禳除。靡不诚告。中外款候。可以密闻。于此时中。一以言听。所为既讫。正坐临朝。十千大臣。前后围绕。共理王事。出纳王言。听事毕来。尽昼初时。为后二分。次第二时。进御王膳。奏妙音乐。种种欢娱。以悦王意。于第三时。沐浴游宴。十亿采女。内奏乐音。容止殊丽。周匝环绕。软意承旨。恒起慈心。清净园林。处处严饰。若闻若见烦恼销除。尽第四时。于王正殿。敷置众宝庄严论座。于王国内。处处请求有大智慧沙门婆罗门得道果者。演说正法。听闻其义。合掌恭敬。礼拜问讯。尽恭敬心。尽尊重心。请令安坐。然后咨问。何等善法。何等恶法。何正何邪。何损何益。可行则行。可止则止。复应数集宿旧智臣高道隐逸。咨承不逮。以达聪明。询问国政。评其德失。由斯王德渐盛渐圆。国内众生。展转安乐。能令世化为解脱因。所以者何。一切菩萨诸所施为。无非佛事。譬如白月初出渐明至十五日。光明圆满。流照十方。亦如海潮月初渐起至十五日。大起潮波。洄澓万里。法王政化亦复如是。王德增长。若无国王智臣耆旧。如船无主漩洄覆没。又如众生渴乏时。雨求天帝释。释天护念。设不降雨。经于十年。是诸众生。亦不必死。若无国王。一日之中。万姓荒乱。相残害尽。以是当知。覆护众生。王胜帝释。复次我王。由闻胜法。常自省诫。以化群生。每至临朝。力势雄猛。王德增上。威伏强邻。外设朝仪种种严卫。奏妙音乐。肃敬侍王。王与内宫眷属围绕。就师子座。身心无畏。如日出云光显自在。犹天帝释。处众天中。置四大人于殿四角。身被金甲。如四天王。左右侍卫。执诸兵仗。显示我王巍巍威德。王志含容。心卑万姓。不听不视。恒思顺行。如海吞流。如山蕴宝。乐音静息。内外一心。尔时我王遍观辅相种种威仪珍严妙饰。知如幻化。自坚其心。以慈软音。而说偈言

  合会须臾散　　荣贵尽无常
  人命如电光　　强力皆归死
  死魔亏盛满　　无常坏宝山
  胜法恒坚牢　　应修不放逸

王说偈已。宣令群臣。各归常位。理王政事。利益众生。心无懈废。仁者当知。如是名为我王内德。善财白言。云何复名王德外化。答言仁者。一切众生。及器世间。安立护持。皆是众生自业果报。及诸国主德力任持。劫初成时。此器世间。人皆化生。肢体圆满。不藉衣食。形相充盈。照耀身光。无有昼夜。宿惑既胜。地味随生。乃至渐生自然香稻。后立田主。遐迩同归。覆育均平。为刹帝利。自是至今。王化不绝。有欲之人。无主则乱。国有君主。一切获安。故名王力能护众生。仁者当知。人有四姓。一婆罗门种。多修口业。二刹帝利种。多修手业。三吠舍种。多修田业。四戍达罗种。修驰逐业。其余杂类旃陀罗等。多皆修习恶律仪业。然此四姓。及余杂类业习不同。居处亦异。从少至老。所务虽殊。皆崇四事。云何为四。一修持艺业。二营办资财。三共受欲乐。四各求解脱。言艺业者。并从髫龀以至壮年。各于其伦。习学其事。若婆罗门业。修智慧。图书印记。纬候阴阳。身相吉凶。围陀典籍。刹帝利种。增修射御。政在养人。功存禁暴。弦歌悦众征罚不庭。吠舍田业。播种耕耘粮聚仓储人天国本。戍达罗种。通商有无。兴贩往来。务滋货殖。言营财者。业艺既成。咸务自事。各于其党。竞构资生。言受乐者。既丰财利。卜定厥居。婚乐宴游恣娱声色。言解脱者。要言二类。一婆罗门刹利王种。发既斑白。年逾五十。力迈色衰。厌世求道。情深出要。咸谓真修。所习既殊。师承自异。九十六种。各业本宗。或求生天。或计解脱。二者释种如来弟子。三乘学人。服甘露味。修习慈悲。利益群品。如是种种邪宗正宗。在家出家。精心道检。皆依王国。而得住持。并因我王演化流布故。诸学者。如世轮绳。艺业所修。如聚泥土。王行正化。如匠埏埴。巧益自他。如成众器。若无王力。功行不成。法灭无余。况能利济。又彼所修一切功德。六分之一。常属于王。王之福山。崇固难坏。其余外境。正化不行。国内之人。恣情积恶。令修善者。无以暂安。如是障修及造不善所有罪业。六分之一。还属彼王。王之罪山。牢峻难坏。是故我王福慧殊胜。时婆罗门。复告善财。仁岂不闻地神语耶。地神常言。我负大地。一切所有。及须弥山。不以为重。亦无厌心。于三种人。我恒厌倦。不欲胜持。何等为三。一心怀叛逆。谋害人王。二念弃恩亲。不孝父母。三拨无因果。毁谤三尊。破法轮僧障修善者。如是三人。我极患重。乃至一念不欲任持。复次我王。宣流正化。诸佛护念。何况龙神。以是正心。能制诸恶。如执钩策。邪法不生。能与世间作无利者。感化调伏。正见修行。亦如牛王。王若行时。一切诸牛悉皆随从。王亦如是。正化流行。一切有情悉皆随顺。又如铁钩能制狂象。王治正化。能伏恶人。究竟令其同归解脱

复次我王建国体人。恒在三事。一念除五怖。二慎择三臣。三精修御膳。所以者何。树君养人。事先除怖。臣德允备足以弼谐。御膳精羞。爱身及物。教人忠孝亲长尊严。善财白言。云何五怖。此国独无。答言。仁者。一王德简俭。财赋均平。无国王贪夺怖。二王族贞贤。不贪为宝。无近臣侵抑怖。三宰官循职。惠恕充怀。无酷吏伤残怖。四人皆义让。国无欺枉。无盗贼偷劫怖。五邻境雍和。承风向化。无外境寇难怖。余国五怖。人必不安。是故我王圣化无外。善财白言。云何三臣王所慎择。答言。仁者。如日天王。高居日殿。去地四万二千由旬。四天下人。不睹形色。但蒙光照。瞻仰日轮。咸知所在。我王圣德。如彼日轮。大明御宇无幽不烛。开物成务。辩别除昏。十千大臣。一亿猛将。皆王照使。为国之光。慎择三臣。统兹百辟。何等为三。一者辅臣。二者将帅。三者使臣。言辅臣者。弼谐王化。代王理政。上佐王德。下恤王人。进贤任能。清心奉职。如日照曜。类辩群分。二将帅者。主兵大臣。必在忠淳。深仁厚义。德行兼茂。勇略无亏。为护众生。除恶务本。如日照曜。涤闇除昏。初自七月至十月终。严鼓戒兵。顺天肃励。乘便逐宜。安营相地。如是主将。受命临戎。攻守以时。战无不利。仁复应知。我国五城。云何为五。一者山城。凭高据崄。断岸周围。二者水城。堑以江河。沿流四绕。三者沙城。旷碛悬远。外无水草。四者土城。坚壁高垒。内实兵储。五者人城。主圣臣贤。深谋远略。如是五城。量宜相敌。人城最胜。我国所尊。故我大王。住不思议神通妙化。三使臣者。所谓行人。受使四方。往复王命。如日照使流光原湿幽谷无私。所以者何。王德精微。王居深密。万方不睹。四海莫知。皆由使臣宣布王泽。殊方款塞。八表钦承。未安者安。已安不退。是故我王。与诸耆旧宰辅大臣。精选良能。慎择其事。要言王使十德乃堪。一资忠奉信。二爱敬君亲。三强记博闻。四识量宏达。五才辩纵横。六精闲内外。七谦卑仁让。八刚正无瑕。九仪范出群。十通王密意。具兹十德。受命宣威。凡所经游。清身洁独。不惛酒色。不寝众居。醉后眠中。虑泄枢密。奉使邻国必达王言。不以利迁。不以威变。行藏进退。靡不合时。风俗土宜。任物成化。于王权变。了达无疑。务显得能。以慰殊俗。由此三臣成王德化。变恶显善。威被万方。如日流光。照物除暗。远近皆明故。我国中禀王圣化。多诸善众。动静合宜。或所游止。不狎恶人。所谓拨无因果。弃背君亲。性少慈悲。好见他过。庸贱卑猥。不畏罪违。多欲多嗔。无惭无愧。心顽性怯。忌胜嫉能。如是等人。皆不亲近。亦不乘御。[怡-台+龍]悷不调。诸恶象马亦不驯养。无益禽兽亦不经游。深山大泽。空聚冢间。旷野山崄。恶兽非人之所住处。亦不正视酒肆屠坊淫秽之处。若或遭遇胜吉祥事。右旋礼敬。为护福故。曾不履践佛法众僧父母师长大人之影及所行迹。于可尊崇有德人所。恭敬礼拜。心无轻慢。见诸佛塔灵庙僧坊仙圣所居胜人住处。自劝劝他。遵崇修葺。令其成就。以是天龙咸生欢喜。风雨以时。五谷丰登。兆庶安乐。王之左右。所使忠良。佞媚凶残。不能亲近。如栴檀林。栴檀围绕。不杂伊兰。如无热池。香流德水。无诸碱味。王远恶人。亦复如是。非如甘果猛兽所藏。善财复言。何等之人。堪典御膳。答言仁者。典御膳人。应具十德。何者为十。一种姓清净。二三业调柔。三忠孝备足。四信让谦和。五知王食性。六妙闲食禁。七善调体味。八知王食时。九体食甘毒。亦善解除。十知所应食昼夜月时。具此十德。可典王厨。量所使人。及治食处。清净香洁。监守无违

婆罗门言。仁复应知。我常思念。天上人间。若闻若见。凡诸胜类。一切功德。观我圣王。靡不咸具。是义云何

仁者当知。师子兽王一德最胜。谓无二心。如杀大象尽其势力。杀余小兽尽力亦然。我王亦尔。不畏大事。不轻小事。尽悲智力。究竟无遗

仁者当知。诸水鸟王皆具二德。一审谛其心。如取鱼时。入水翘立。一心觇视。嶷然不动。二静观水族。所欲皆从。我王亦尔。高居俯视。听政万方。寂然不动。感通无碍。言不虚发。一切自成

婆罗门言。仁复应知。我王三德。圣化流行。如金轮世调善马王。有三功德。何等为三。一心性和柔。力能致远。二不畏寒暑。涉险能安。三调怨易事。常无不足。我王亦尔。一言必柔实。以法利人。教化众生。毕竟成就。二克勤庶政。心无险易。能舍珍财。调给一切。三大智勇健。调诸怨敌。赋税量宜。恒知止足。具此三德。扇以和风。他国畏威。自境怀惠

婆罗门言。仁复应知。我王四德。圣化流行。如摩伽国妙音鸡王有四功德。何等为四。一立信司晨。二守义均食。三对敌贾勇。四不随牝鸡。我王亦尔。一赏罚应时。二万方均济。三义伏强御。四内言不听。具兹四德。化洽无圻

婆罗门言。仁复应知。我王五德。圣化流行。如欲天上善时鹅王有五功德。何等为五。一染合有时。二呼鸣无畏。三量宜求食。四心无放逸。五不受诸鸟谄佞言辞。我王亦尔。一清心寡欲。不纵内宫。二发言审谛。外无违命。三取与不差。务充衣食。四调心道检。离过精勤。五成就正心。不亲谄佞。具兹五德。惠及八荒

婆罗门言。仁复应知。我王六德。圣化流行。如摩伽国胜德犬王有六功德。何等为六。一随得而食。二少得知足。三趣安便睡。四草动易觉。五贫富一心。六勇防盗贼。我王亦尔。一万方贡献。任土无违。二俭时少奉。恒怀惭愧。三所作吉祥。易得安眠。四正见在怀。动念便觉。五重德尊亲。愍哀贫贱。六思存庶品。念护无时。威勇自在。无诸寇难。具兹六德。亿兆同心。以是思惟。触类成德。仰叹我王名称高远。善摄众生。精勤匪懈。如是增数二十一种殊胜功德。我王能行。一切怨敌自然散灭。所有外寇不能入国。仁复应知。若有阙此二十一德。但有三德。亦善治化。一能散珍财。赒给一切。二宁舍身命。无虚诳言。三具大勇猛。能制怨敌。设无此三。但有一德。亦能政化。谓有大福德。如是仁王。最为第一。譬如八万四千法门终归胜义。王亦如是。种种奇谋。终归福德。王若有福。王之国土。休泰和平。无为无事。众生富乐。化及万方。近益身心。远同解脱。由王慈福仁惠所成。广说我王妙行无尽

时婆罗门。为善财童子。如是称赞甘露火王内外功德。令欣敬已。欲重宣此义。以偈赞曰

  众生于世界　　三毒风所吹
  将坠恶趣中　　非王不能制
  含生着五欲　　贪暴由是生
  王依正法持　　令趣真常道
  倾夺于财色　　由无王法持
  譬如河池鱼　　大小相吞食
  王法持自他　　现未常安乐
  正化广流布　　咸为解脱因
  人以王为命　　王以法为身
  世道既和平　　佛法由兹始
  政暴人思乱　　刑疏于不行
  恩威不爽时　　万国常休泰
  多生事多佛　　福德胜为王
  悲深惠益深　　亿兆同康乐
  我王生盛族　　威光同日轮
  忘己济群生　　率土无贫乏
  知身本不净　　无常之所侵
  调心大丈夫　　守正非余事
  蒸人如旱草　　惠化洽油云
  慈心降德音　　泽润诸含识
  王者顺人心　　爱恤人稣息
  威行肃贪暴　　赏罚称其宜
  或有妙形声　　含毒人非爱
  或具大聪睿　　染欲蔽其心
  我主胜端严　　惩忿诫诸欲
  心如净明镜　　鉴物未尝私
  明镜唯照形　　不鉴于心想
  我王心镜净　　洞见于心源
  左右无佞邪　　耳目唯良善
  谄媚及残暴　　本所不能亲
  或有肆奸意　　欲害于王人
  王心鉴未形　　悉使归忠正
  芳林伏猛兽　　碱海毒清流
  蠹政害良人　　凶邪败君德
  香河流德水　　甘果茂甘林
  八表同欢康　　臣贤由主圣
  王持防患戒　　济众洁其源
  富寿利群生　　拔出贪嗔海
  慈悲既深广　　正法亦遐宣
  老幼与孤茕　　护育令安乐
  尊贤贵有德　　重齿敬其亲
  戚属与妃嫔　　内外咸雍穆
  温言调万姓　　和色奉师尊
  祠敬无惰容　　福流千万代
  古先无道主　　骄侈慢宗亲
  徇己不忧人　　恶称恒流布
  我王知幻境　　利物以忘身
  有道庇众生　　具吉祥名称
  贪嗔与悭嫉　　皆为诸苦因
  愚惑常不知　　感报犹影响
  王以人为本　　亿兆同一身
  役使如四肢　　劳逸无过分
  我王镜前躅　　垂范为元龟
  动作顺人心　　舍恶而从善
  爱人如爱己　　率己以随人
  九族既从风　　百辟遵王政
  八方归圣化　　端拱以无为
  推功因理心　　心静曾无事
  忠臣辅我主　　顺动如股肱
  万国达聪明　　四海称君德
  谛承诸佛教　　以法悟众生
  令其了自心　　日照莲华发
  国人护我主　　犹王护国人
  如林卫兽王　　兽护于林薮
  余国多五怖　　王贪及宠臣
  酷吏陷非辜　　盗贼公偷劫
  自境有四患　　外寇必来侵
  我王内外清　　国人无五怖
  世间有四业　　一智二珍财
  三受五欲乐　　四求于解脱
  诸王多未具　　殁世人莫称
  如风持韛囊　　风息命随绝
  我王备四法　　智德莹其身
  富有妙珍财　　赒济于穷乏
  五欲无伦匹　　不染如莲华
  但为引众生　　后令入佛智
  住如幻解脱　　示现处贪嗔
  变化治恶人　　皆令向佛道
  不久汝当见　　种种方便门
  究竟利众生　　是故声远震
  妙慧以为风　　常命恒无尽
  汝应速瞻诣　　勿生懈慢心
  一见胜智人　　过住百千岁
  有或寿千岁　　恒食人所弃
  不知三世事　　亦寡法财宝
  饱腹资欲心　　人形畜无别
  少学或心高　　易满如牛迹
  如鼠手持物　　自谓己能多
  智海广难量　　不测反增谤
  牛饮水成乳　　蛇饮水成毒
  智学成菩提　　愚学为生死
  如是不了知　　斯由少学过
  是故我国人　　多闻无厌怠
  我王多辅臣　　国城亦险固
  丰财饶士马　　邻国皆亲好
  如是具七支　　勇智恒依住
  人间与天上　　种种胜功德
  利益诸众生　　如上所宣说
  智人闻一义　　触类广无涯
  要言为法王　　调身安万姓
  世荣恒不退　　出世妙难思
  如海纳川流　　包容益深广

时婆罗门。偈赞王已。告善财言。仁者当知。诸众生身。毛及毛孔。各三俱胝。今我大王。有三俱胝内行功德。外行功德亦三俱胝。以是德化。惠育含生。我向为仁才说大王一毛功德。其余王德深广难陈。我智微浅。何能思说。况我缘务无暇久言。我王今者正殿施化。汝应往诣一心瞻见。尔时善财。闻婆罗门说是语已殷勤礼足。辞诣王宫。遥见彼王处于正殿。坐那罗延金刚妙宝大莲华藏师子之座。阿僧祇众摩尼宝以为其台。阿僧祇日光明宝以为其足。阿僧祇妙宝形像以为庄严。金绳为网弥覆其上。阿僧祇摩尼宝聚光明照耀。阿僧祇天妙宝衣。敷置其上。种种天香而用普熏。种种宝华布散其地。无数宝幢四面行列。无数宝幡周遍垂布。孔雀尾色种种光明天摩尼宝以为其帐。而覆其上。尔时大王。壮年盛色。尊重可畏。相好具足。微妙庄严。如意摩尼以为宝冠。庄严其首。阎浮檀金以为半月。庄严其额。帝青摩尼无垢宝王以为耳珰。庄严其耳。无价摩尼如意宝王以为璎珞。庄严其颈。无垢光照天妙摩尼如意宝王以为印钏。庄严其臂。阎浮檀金以为伞盖。众宝间错以为轮辐。光味摩尼以为其脐。百千鬘网交络严饰清净藏宝以为其铃。恒出妙音。演无尽法。夜光摩尼。放大光明。周遍十方。以为照耀。具足圆满。毗琉璃宝以为其竿。人恒执持以覆其上。甘露火王王德增上。有大力势。威伏远方。邻国诸王。靡不钦奉。以离垢缯。而系其顶。十千大臣。前后围绕。十万猛卒。左右行列。形貌可畏。如阎罗使。攘臂嗔目。咬齿虬眉。执持器仗。见者惶怖。国内众人。有犯王法。或夺他命。或盗他财。或侵他妻。虚妄离间。粗恶无义。贪嗔邪见。作如是等种种恶业。身被五缚。将诣王所。随罪治之。或以火烧。或以汤煮。或投煻煨。或灌沸油。种种焚炙。令其糜烂。或驱上高山。推令堕落。或斩其首。或断其腰。或截耳鼻。或刖手足。或挑双目。或剥身皮。或解其体。肢节分离。聚骨成山。流血为池。复见血中人头手足骸骨遍满。复有无数猪狗野干乌鹫之类。竞趣池中。饮血啖肉发大恶声。人闻恐怖。池中死尸。种种形色。或有青瘀。或有脓流。臭秽纵横。膖胀烂坏。肠胃藏腑。悉皆出现。爪发筋脉散布池中。或有轻罪。苦楚鞭笞。断截肢解。种种刑害。呻吟号叫。出大怖声。或呼父母。或呼眷属声如雷震。酸切人心。有如是等无量苦毒。譬如众合大地狱中。善财见已。作如是念。我为利益一切众生。发阿耨多罗三藐三菩提心。修菩萨道。求菩萨行。问善知识。云何修习菩提善根。云何远离诸不善根。今见是王。舍善根法。作大恶业。逼害众生。乃至断命。曾不畏惧未来恶道苦业。现前临欲颠坠。云何于此。而欲求问。行菩萨行。学菩萨道。能生具足广博大悲。救护众生。以如是心。种种思念。作是念时。于虚空中。有天告曰。善男子。汝不忆念普眼长者善知识教。及向所见诸婆罗门赞叹此王种种功德微妙法耶。善财仰视。而白之曰。我深忆念。曾无忘失。诸天复言。善男子。汝若常念慎莫生疑。善男子。汝莫厌离善知识语。善知识者。恒以正法引导于汝。岂令汝堕险恶处乎。善男子。菩萨巧行方便智不可思议。摄受众生智不可思议。护念众生智不可思议。利乐众生智不可思议。治罚众生智不可思议。清净众生智不可思议。成熟众生智不可思议。深入众生智不可思议。度脱众生智不可思议。知众生时智不可思议。知众生根智不可思议。愍念调伏诸众生智不可思议。善男子。汝诣王所。深心请问学菩萨行修菩萨道。尔时善财。闻天语已。前诣王所。顶礼王足。绕无数匝。合掌白言。圣者我已先发阿耨多罗三藐三菩提心。而未知。菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。时甘露火王。理王事已。执善财手。将入内宫。命之同座。而告之言。善男子。汝当观我所住宫殿。及诸资具。善财如语。即遍观察见彼宫殿。广博无比。众摩尼宝之所合成。百千众宝以为楼阁。赤真珠宝以为其柱。种种色宝间错厕钿。不思议摩尼宝。腾光普照。种种摩尼宝随处庄严。以牟萨罗孽磨妙宝。以为茵蓐。庄严其地。无数百千种种色宝。以用庄严师子之座。毗卢遮那摩尼宝王而为其帐。以覆座上。如意宝王种种色网。周匝垂覆。师子王光味摩尼微妙宝幢周回建立。复有种种妙宝池沼。池水清净具八功德。码瑙宝王砌垒其岸。种种色宝以为栏楯。处处宝树行列庄严。一一宝墙周匝围绕。侍从采女具足十亿。妙色端严令人喜见。容止美丽仪范可观。凡所施为。无非巧妙。软意承旨。常起慈心。善财见已。生希有想。王时告言。善男子。于意云何。如汝所见。诸可爱果。如是色相。如是眷属。如是荣乐。如是富饶。如是自在。岂是恶业而能感耶。白言不也。善男子。我得菩萨如幻解脱。善男子。今我国土所有众生。多行恶业如旃陀罗我于如是不受善教诸恶众生。作余无量种种方便。不能令其舍离恶业回向善道。善男子。我为调伏彼诸众生令成熟故。大悲先导。化作恶人。于恶人前。示造诸恶。及变化作忍害之人。逼恼责罚。种种苦治。令其国内作恶众生。见是事已。心生惶惧。心生恐怖。于诸欲乐。心生厌离。心生怯弱。便能永断一切恶业。发菩提心。得不退转。善男子。以是当知。汝向所见造恶众生受诸苦者。及彼能治暴恶众生。皆是变化。善男子。我以如是种种方便。令诸众生断其所作十不善业。具足修习住十善道。究竟利乐。究竟安隐。究竟圆满。永断诸苦。住于如来一切智地。善男子。我身语意忆想。未曾于一众生而行恼害。善男子。如我意者。宁尽未来。受无间苦。终不发起一念嗔心。于一蚊一螘微细众生。起恼害想。何况造作如是恶业。善男子。我自忆念。乃至梦中。未曾一念心生放逸。况于觉悟而杀人耶。所以者何。人是福田。能生一切诸善果故。譬如此中十六大国乃至一切地居众生。依于大地。安立生长。而得住故。如是一切贤圣道果。皆依于人而能修证。善男子。我唯得此如幻解脱变化法门。如诸菩萨摩诃萨得无生忍。知诸有趣悉皆如幻。知菩萨行悉皆如化。知诸世间悉皆如影。知一切法悉皆如梦。入真实相无著法门。随顺法界。修诸妙行。犹如帝网。以无著智。行于境界。无有障碍。平等普入。三昧法门。已得自在旋陀罗尼。住佛境界。如影随形。而我云何能知能说彼诸菩萨行智功德。善男子。于此南方。有城名妙光。王名大光。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。时善财童子顶礼王足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第十二大方广佛华严经卷第十三

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。一心正念。随顺思惟。彼王所得幻智法门。观察彼王如幻解脱。思惟彼王如幻法性。发如幻愿。净如幻法。悟如幻业。随顺如幻成就之法。出生如幻不思议智。清净如幻三世性相。以如幻智起于种种如幻变化。如是思念。渐次前行。经历人间聚落城邑。或至旷野岩谷险难山川原隰。处处寻求无有疲懈。然后乃至妙光大城。于其门侧。问众人言。此名何城。何王统御。人咸报言。此妙光城。是大光王之所住处。时善财童子。欢喜踊跃。志乐清净。一心瞻慕。作如是念。我善知识。在此城中。我今必当亲得奉觐。闻诸菩萨所行之行。闻诸菩萨出要之门。闻诸菩萨所证之法。闻诸菩萨不思议功德。闻诸菩萨不思议自在。闻诸菩萨不思议平等。闻诸菩萨不思议勇猛。闻诸菩萨不思议境界。闻诸菩萨不思议法性。闻诸菩萨不思议三昧。闻诸菩萨不思议解脱游戏。闻诸菩萨不思议广大清净。作是念已。入妙光城。周遍观察见此大城。众宝严饰。以金银琉璃。玻璃赤珠。砗磲码瑙七宝所成。七重宝堑周匝围绕。八功德水盈满其中。底布金沙。光明照耀。优钵罗华。波头摩华。拘物头华。芬陀利华。遍布其上。其水清彻。随时温凉。白栴檀泥。澄垽其下。其水随泥。如栴檀色。宝多罗树。七重行列。枝叶繁茂。蓊郁庄严。七重金刚。以为垣墙。所谓师子光明金刚垣。无能超胜金刚垣。不可沮坏金刚垣。精进难伏金刚垣。坚固无著金刚垣。天衣网藏金刚垣。无垢妙色金刚垣。如是七重。一一围绕。悉以无数摩尼妙宝间错庄严。阎浮檀金种种众宝。而为埤堄。金银琉璃。赤珠码瑙。玻璃海藏。真珠等宝。以为严饰。其城纵广一十由旬。周回八方。面开八门。皆以七宝周遍严饰。帝青琉璃。以为其地。众色杂宝。随处庄严。种种珍奇。甚可爱乐。其城内有十亿街道。一一道边。安布妙宝。以为庄严。过天帝释所游之路。一一道间。皆有无数万亿众生。于中止住。无数百千广大宫殿。一一皆以众宝合成。复有无数不思议阎浮檀金楼阁。帝青琉璃摩尼宝网。罗覆其上。无数不思议白银楼阁。赤真珠摩尼宝网。罗覆其上。无数不思议毗琉璃楼阁。广博妙藏摩尼宝网。罗覆其上。无数不思议玻璃楼阁。日藏摩尼王网。罗覆其上。无数不思议光照世间摩尼宝楼阁。吉祥光藏摩尼王网。罗覆其上。无数不思议帝青摩尼宝王楼阁。妙光摩尼王网。罗覆其上。无数不思议众生海藏摩尼宝王楼阁。焰光明藏摩尼王网。罗覆其上。无数不思议金刚宝王楼阁无能胜幢摩尼王网。罗覆其上。无数不思议栴檀香王楼阁。天曼陀罗华摩诃曼陀罗华网。罗覆其上。无数不思议无等香王楼阁。种种华网。罗覆其上。有如是等无数不思议种种庄严妙宝楼阁。种种宝网罗覆其上。一一楼阁。众宝栏楯。周匝围绕。宝多罗树次第行列。皆以宝绳而为界道。一一宝绳。悬以金铃。一一金铃众宝鬘络。如孔雀尾。异色端严。风动成音。闻之可意。其城复有阿僧祇摩尼宝网。阿僧祇宝铃网。阿僧祇天香网。阿僧祇天华网。阿僧祇宝形像网。其城复有阿僧祇金刚帐。阿僧祇宝衣帐。阿僧祇宝盖帐。阿僧祇宝幡帐。阿僧祇宝山帐。阿僧祇宝华鬘帐。阿僧祇宝楼阁帐之所弥覆。处处罗列宝盖幢幡。城中宝池。德水盈满。底布金沙。光映内外。天诸妙华敷荣其上。天诸宝鸟浮戏其中。出和雅音。悦可人意。池岸阶砌。七宝庄严。帝释宝池无以为比。当此城中。有一楼阁。名妙法藏。阿僧祇种种色宝以为庄严。光明照耀最胜无比。众生乐见心无厌足。彼大光王常处其中

尔时善财童子。于彼大城。妙宝楼阁。宝池宝堑。宝树宝墙。宝盖宝幢。宝铃宝网。如是一切珍宝妙物。受用资具。乃至男女六尘境界。皆无爱着。唯于正法园苑之中。深心渴慕。但正思惟究竟之法。一心愿乐。见善知识。渐渐前行。普遍观察。见大光王。去于所住楼阁不远。四衢道中。坐如意摩尼宝莲华藏广大庄严师子宝座。绀琉璃宝以为其足。金缯为帐。众宝为网。阎浮金绳交络严饰。上妙天衣以为茵蓐。四布敷设。阿僧祇妙宝形像随处庄严。其王具有三十二种大人之相八十随好。而以严身。如真金山光色炽盛。如净空日威光赫奕。如盛满月见者清凉心无厌足。如梵天王处于梵众。威德殊胜。亦如大海聚功德宝无量无边。亦如大云遍法性空法雷震吼。如净空界显现种种法门星象。如雪山王相好树林以为严饰。如须弥山四色普现众生心海。如宝洲渚种种智宝充满其中。于王座前。复有无量金银琉璃真珠摩尼珊瑚琥珀珂贝璧玉诸珍宝聚种种宝衣华鬘璎珞。及诸饮食。皆悉充满。复见无数百千万亿驷马宝车。百千万亿天诸妓乐。百千万亿天诸妙香。百千万亿病缘汤药。无数乳牛蹄角金色。无数千亿端正女人。上妙栴檀以涂其体。天衣璎珞种种庄严。六十四能靡不该练。仪范礼则悉皆善知。随众生心而以给施。城邑聚落。四衢道侧。相次陈列。福舍义堂。满二十亿。安置一切珍宝妙物。及诸饮食。充满其中。一一道傍有二十亿诸大菩萨。以此诸物。惠施众生。令无所乏。为欲摄受诸众生故。为欲发起一切众生爱敬心故。为欲发起一切众生欢喜心故。为欲发起一切众生踊跃心故。为欲清净一切众生正信心故。为令众生心清凉故。为令众生除爱热故。为令众生息烦恼故。为令众生解真实故。为令众生入种智故。为令众生舍怨敌故。为令众生离诸恶故。为令众生拔邪见故。为令众生净诸业故

时善财童子。五体投地顶礼王足。绕无数匝。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何。学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说

时王告言。善男子。我得净修菩萨大慈幢行解脱门。清净满足。善男子。我于无量百千万亿乃至不可说不可说佛所。亲近听闻。问难此法。随顺思惟。审谛观察。清净悟入。修习庄严。善男子。我以此法为王。以此法教敕。以此法摄受。以此法随逐世间。以此法兴行政化。以此法调伏众生。以此法引导众生。以此法怜愍众生。以此法安慰众生。以此法运载众生。以此法令众生趣入。以此法令众生修行。以此法与众生方便。以此法令众生思惟诸法究竟实性。以此法令众生安住大慈。以慈为主。具足慈力。如是令住利益心。安乐心。哀愍心。摄受心。守护众生心。常不舍离心。拔众生苦无休息心。代诸众生恒受苦心。令诸众生住安乐心。为令众生舍离一切障盖缠缚得自在故。为令众生究竟安乐于诸众生得自在故。为令众生永断如草蔓莚滋长生死心故。为令众生永断如河。相续流注结使心故。为令众生永断烦恼习气心故。为令众生住于法性寂静心故。为令众生永息一切不善法故。为令众生截生死流入法流故。为令众生入深法界。心无退转。以智慧火烧烦恼薪。永断一切五道生处。具菩萨行。向一切智。心海清净无诸浊乱。信力坚固。诸天魔梵沙门婆罗门人与非人所不能动善男子。我住如是大慈幢行解脱门故。能以正法教化世间。善男子。我国土中。一切众生。皆于我所。无有恐怖。善男子。若有一切贫乏众生。裸露饥羸。来至我所。或求衣服或求饮食。乃至求索一切所须受用之物。我开库藏示令知见。而告之言。汝等昔来。为此财宝。造十不善种种恶业。由是业故。贫穷裸露衣食不充。我于今者。悉施汝等。恣意取之。既自充足。随力修行。莫造诸恶。莫害众生。莫起诸见。莫生执着。汝等贫乏。若有所须。当来我所。及四衢道二十亿处。义堂福舍。一切财宝种种具足。汝随意取。勿生疑难。善男子。此妙光城所住众生。皆是菩萨发大乘意。行大乘行。于诸众生起大悲心。普遍清净。随心所欲所见不同。或见此城其量狭小。或见此城其量广大。或见此城土沙为地。或见琉璃众摩尼宝以为其地。或见垣墙聚土成立。或无能胜金刚所成。或见其地高下不平。或见其地平坦如掌。或见屋宅土木所成。或见殿堂众宝严饰。及诸楼阁阶墀窗闼轩槛户牖。如是一切无非妙宝

善男子。若有众生。其心清净。曾种善根。供养诸佛。发心趣向一切智道。以一切智为归依处。及我昔时修菩萨行。以四摄事。曾所摄受。则见此城。具足众宝清净庄严。余皆见秽

善男子。此国土中一切众生。五浊世时。随本业习。乐造诸恶。我起怜愍。摄受彼心。而欲救护入于菩萨大慈为首随顺世间大三昧门。善男子。我当入此三昧门时。彼诸众生所有怖畏心。恼害心。怨敌心。诤论心。如是诸心悉自销灭。何以故。入于菩萨大慈为首顺世三昧。本性功能法如是故。善男子。且待须臾。自当得见。时大光王。即入此定。其城内外六种震动。宝地宝墙宝堂宝殿台观楼阁阶砌户牖。如是一切互相冲击。悉向于王。咸作曲躬敬礼之像。咸出妙音。称赞王德。其城内外所有人民。靡不同时欢喜踊跃。俱来王所。投地顶礼。近王所住。鸟兽之属。互相瞻视。起慈悲心。咸向王前。恭敬礼拜。一切山原。及诸草树。莫不回转咸向于王如礼敬像。陂池泉井及以河海悉皆腾溢流注王前。十千龙王。起大香云。震雷激电。洒细香雨。复有十千六欲天王。所谓四大天王。忉利天王。夜摩天王。兜率陀天王。妙变化天王。他化自在天王如是等王。而为上首。于虚空中。作众妓乐。阿僧祇天女歌咏赞叹。阿僧祇天宝华云。阿僧祇天宝香云。阿僧祇天宝鬘云。阿僧祇天末香云。阿僧祇天宝衣云。阿僧祇天宝盖云。阿僧祇天宝幢云。阿僧祇天宝幡云。遍虚空中而为严饰。供养于王。复有[醫-酉+言]罗钵那大象王。以自在力。于虚空中。布阿僧祇大宝莲华。垂阿僧祇天宝璎珞。阿僧祇宝缯带。阿僧祇宝严具。阿僧祇宝衣服。阿僧祇宝鬘。阿僧祇宝华。阿僧祇宝香。阿僧祇烧香。阿僧祇涂香。种种奇妙。以为严饰。阿僧祇天女出美妙音。歌咏赞叹。阎浮提内复有阿僧祇百千万亿诸罗刹王。诸夜叉王。鸠槃茶王。毗舍阇王。诸鬼王等。或居陆地。或处虚空。或住山间。或居大海。如是一切饮血啖肉。残害众生。皆起慈心。愿行利益。明识后世。不造诸恶。恭敬合掌。顶礼于王。恐怖不生身心寂静。皆得无量广大安乐。如阎浮提。余三天下乃至三千大千世界。并及十方百千万亿那由他世界。其中所有毒恶众生。悉亦如是。如是一切。皆以菩萨大慈为首随顺世间三昧法门力如是故

时大光王。从三昧起。告善财言。善男子。我唯得此菩萨大慈幢行顺世三昧解脱门。如诸菩萨摩诃萨。为高盖慈心普荫诸众生故。为圆满平等救护无分别故。为修行下中上行悉等行故。为大地能以慈心任持一切诸众生故。为盛满月福德光明于诸世间平等现故。为净日轮以智光明照了一切所知境故。为世明灯能破众生诸黑闇故。为水清珠能清众生谄诳浊故。为如意宝能满众生心所愿故。为猛疾风任持众生及三昧宫殿一切智智大法城故。而我云何能知其行。能说其德。能称量彼福德大山。能瞻仰彼功德众星。能观察彼大愿风轮。能校量彼法平等力。能发起彼大修行心。能显示彼大庄严海。能阐明彼普贤行门。能深入彼诸三昧窟。能赞叹彼大慈悲云。能降注彼甘露法雨。善男子。于此南方。有一王都。名曰安住。有优婆夷。名曰不动。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼王足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。出妙光城行于道路。正念思惟大光王教。忆念菩萨大慈幢行。思惟菩萨顺世三昧。普见彼不思议菩萨清净身。普念彼不思议妙宝师子座。增长彼不思议大愿福德自在力。坚固彼不思议成熟众生智。观察彼不思议不共受用大威德。忆念彼不思议神通差别相。思惟彼不思议清净大众会。分别彼不思议菩萨所作业。忆念明了随顺信解。生欢喜心。生澄净心。生猛利心。生欣悦心。生庆幸心。生踊跃心。生不乱心。生明照心。生坚固心。生广博心。生无尽心。如是思惟。悲泣流泪。念善知识。实为希有难见难闻。善知识者。是我宝山。出生一切诸功德宝。能遍清净诸菩萨行。圆满菩萨一切净念。清净菩萨陀罗尼轮。显发菩萨三昧光明。修治菩萨见佛境界。普雨一切诸佛法雨。显现如来不思议智。显示一切菩萨愿门。生长一切菩萨根芽。复作是念。善知识者。能救护我。令我不堕一切恶趣。善知识者。能引导我。令我得入平等佛慧。善知识者。能显照我。令我了知诸夷险道。善知识者。能开示我。令我解了大乘奥义。善知识者。能劝发我。令我速入普贤诸行。善知识者。能晓悟我。令我速到一切智城。善知识者。能诲谕我。令我趣入法界大海。善知识者。能劝诱我。令我普见三世法海。善知识者。能教授我。令我得与众圣集会。善知识者。能增长我。令我出生一切白法。念善知识。能以如是利益众生。善财童子。如是思惟。涕泪盈目。彼常守护觉悟菩萨。犹影随形。如来使天。于虚空中。而告之言。善男子。其有随顺善知识教。诸佛世尊悉皆欢喜。其有随顺善知识语。则得近于一切智地。其有能于善知识行心无疑惑。则常值遇一切善友。其有发心愿常不离善知识者。则得具足一切甚深最胜义利。善男子。汝可往诣安住王都。即当得见不动优婆夷大善知识。从彼请问诸菩萨行

尔时善财童子。从彼三昧智光明起。渐次游行。至安住城。周遍求问。不动优婆夷。今在何所。遇彼人众。咸示之言。善男子不动优婆夷。身是童女。侍觐父母。在自宅中。与其亲属及无量人。周匝围绕演说妙法。善财闻已。其心欢喜。生寂静心。生爱敬心。如见父母念。我于今所愿圆满。即诣不动优婆夷所。到彼宅门。住立观察。入其宅内。见彼堂宇。微妙清净众宝庄严。金色光明普皆照耀。如是光明触善财身。善财即时。获得五百妙三昧门。所谓入一切安乐自在幢三昧门。了一切寂静相三昧门。远离一切世间三昧门。普眼舍得三昧门。如来藏三昧门。得如是等五百三昧门。以得如是三昧门故。身心柔软。如七日胎。微妙轻安世无过者。又闻妙香。非诸天龙乾闼婆等人与非人之所能有。即前往诣。恭敬合掌。一心观察。见其形色端正殊妙。十方世界一切女人无能与比。况复过者。唯除如来及以一切灌顶菩萨。其身殊胜。口出妙香。宫殿庄严。受用资具。眷属围绕。威光炽盛。清净无染。悉无与等。况其过者。十方世界一切众生。无有于此优婆夷所起染着心。若有众生。暂得瞻见。所有烦恼悉自销灭。譬如百万大梵天王决定不生欲界烦恼。其有见此优婆夷者。不起烦恼亦复如是。十方众生。观此女人欢喜爱敬。心无厌足。唯除具足大智慧者。尔时善财童子。曲躬合掌。恭敬瞻视。正念观察。见此女人。其身自在不可思议。色相颜容世无与等。光明洞彻物无能障。普为法界一切众生。作大饶益无有穷尽。其身毛孔恒出妙香。眷属无边宫殿第一。功德深广不可思议。莫能究尽知其涯际。生欢喜心。以偈赞曰

  汝常护持清净戒　　普修菩萨无垢忍
  坚进不动如金刚　　妙果超世无能比

尔时善财童子。说此偈已。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时不动优婆夷。以菩萨柔软语。可爱语。慈悲语。慰谕善财。而告之言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我得菩萨难摧伏智慧。藏解脱门。我得菩萨坚固受持愿行门。我得菩萨一切法平等地总持门。我得菩萨一切法智光照辩才门。我得菩萨求一切法心无疲厌庄严三昧门。善财童子。白言圣者。菩萨难摧伏智慧藏解脱门。乃至求法心无疲厌庄严三昧门。境界云何。答言。善男子。此处甚深难知难信。善财白言。唯愿圣者。承佛神力。为我宣说。我因圣者善知识力。能信能受。能解能知。能甚深入。能随顺行。明了观察。忆念修习。离诸分别。究竟平等

大方广佛华严经卷第十三大方广佛华严经卷第十四

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时不动优婆夷。告善财童子言。善男子。我忆过去。无垢光劫。彼劫有佛。名为修臂。十号圆满。时有国王。名曰电授。唯有一女。即我身是。我于其夜分废音乐时。父母兄弟悉已眠寝。五百童女亦皆昏寐。我于楼上仰观星宿。于虚空中。见彼如来。如宝山王。无量无边天龙八部。及不思议诸菩萨众。所共围绕。佛身普放大光明网。遍满十方无所障碍。佛身毛孔皆出妙香。我闻是香。身体柔软。心生欢喜。便从楼下。合十指掌。顶礼于佛。谛观彼佛。不见顶相。观身左右。莫知边际。思惟彼佛诸相随好。无有厌足。善男子。我于尔时。窃自念言。此佛世尊。作何等业。获于如是胜妙之身。相好圆满。光明具足。眷属成就。宫殿庄严。福德智慧。总持三昧。神通辩才。咸不思议。善男子。时彼如来。知我心念。即告我言。汝应发难摧伏心断诸烦恼。汝应发无能胜心破诸邪执。汝应发无退怯心入深法门。汝应发不动转心拔生死苦。汝应发无迷惑心普于一切诸趣受生。汝应发无厌足心求见诸佛无有休息。汝应发无知足心悉受一切如来法雨。汝应发正思惟心普照一切佛法光明。汝应发大住持心普转一切如来法轮。汝应发广流通心随众生欲施其法宝。善男子。我于彼佛正等觉所。闻如是法。随顺趣求一切种智。心无退转。求佛十力。求佛辩才。求佛光明。求佛色身。求佛相好求佛众会求佛净刹。求佛威仪求佛寿命。发是心已。深心爱乐如渴思水其心坚固犹如金刚。一切烦恼。及以二乘。所不能坏。善男子。我忆初发是心已来。经阎浮提极微尘数劫。尚不曾起一念欲心。况行其事。尔所劫中。于自亲属有过失者。尚不生起一念嗔心。况他众生无过失者。尔所劫中。于其自身不生我见。况于众具而计我所。尔所劫中。死时生时。及于胎藏入住出时。乃至梦中。未曾迷惑。起众生想。及无记心。况于余时。尔所劫中。乃至梦寐。随见一佛。未曾忘失。何况菩萨十眼所见。尔所劫中。受持一切如来正法。未曾忘失一文一句。乃至世俗所有言辞尚不忘失。何况如来语言藏中所宣妙法。尔所劫中。受持一切如来法海。一文一句无不思惟。如理观察。乃至一切世俗之法。尚恒思惟观察觉了。何况如来真胜义法。尔所劫中。受持一切如来法海。未曾于一法中不得三昧。乃至世间一切工巧技艺之法。一一法中亦复如是。尔所劫中。住持一切如来法轮。随所住持未曾废舍。一文一句亦无错谬。乃至不曾生于世智。唯除为欲调伏众生。尔所劫中。见诸佛海。未曾于一佛所不得成就清净大愿。乃至于诸变化佛所悉亦如是。尔所劫中见诸菩萨修行妙行。无有一行我不成就。而得清净。尔所劫中。所见众生。无一众生我不劝发阿耨多罗三藐三菩提心。未曾劝一众生乃至一念发于声闻辟支佛意。尔所劫中。于一切佛所闻之法。乃至一文一句。不生疑心。不生二想。不生分别想。不生种种想。不生执着想。不生高下想。不生胜劣想。不生爱憎想。乃至无一念中生如是想。善男子。我从是来。所见诸佛。常得亲近。未曾舍离。常见菩萨未曾舍离。常见真实大善知识未曾舍离。常闻诸佛清净大愿未曾舍离。常闻菩萨所修妙行未曾舍离。常闻菩萨波罗蜜门未曾舍离。常闻菩萨地智光明门未曾舍离。常闻菩萨总持三昧无尽藏门未曾舍离。常闻菩萨普入无边世界网门未曾舍离。常闻菩萨普入无边众生界门未曾舍离。常闻菩萨。以智光明除灭一切众生烦恼未曾舍离。常闻菩萨生长一切众生善根未曾舍离。常闻菩萨能随众生遍周法界普现其身未曾舍离。常闻菩萨以妙言音开悟法界一切众生未曾舍离。善男子。我得菩萨难摧伏智慧藏解脱门。我得菩萨求一切法心无疲厌庄严三昧门。我得菩萨坚固受持愿行门。我得菩萨一切法平等地总持门。我得菩萨一切法智光照辩才门。现不思议自在神变。汝欲见不。善财言唯。我心愿见

尔时不动优婆夷。不起龙藏师子之座。入菩萨难摧伏智慧藏解脱门。求一切法心无疲厌庄严三昧门。不空圆满庄严三昧门。十力智轮现前三昧门。入如是等十亿三昧门。入此三昧门时。十方各有不可说不可说佛刹极微尘数世界。六种震动。一一世界。皆悉清净琉璃所成。一一世界中。有百亿四天下。一一四天下。皆有如来。或升兜率。或时降生。入胎初生。出家苦行。或居道树。或现降魔。示证菩提。受梵王请。趣波罗奈转四谛轮。或从忉利还阎浮提。三道宝阶从天而下。或时现处遍六大城。现大神通摧诸外道。或时现住毗耶离城狝猴池侧。初制律仪。或时现处王舍大城灵鹫山等。说诸般若波罗蜜门。乃至或现拘尸那城娑罗林间。示般涅槃。如是所作。一切佛事。普遍十方清净世界。一一如来放光明网。周遍法界。道场众会。清净围绕。转妙法轮开悟群品。时不动优婆夷。从三昧起。告善财言。善男子。汝见此不。汝闻此不。汝解此不。善财言唯。我皆已见。已闻已解。优婆夷言。善男子。我唯得此菩萨所修坚固受持大愿行门。求一切法心无疲厌庄严三昧智光明门。菩萨难摧伏智慧藏解脱门。一切法平等地总持门。一切法智光照辩才门。为一切众生善巧方便。以妙言音。普遍一切。说微妙法。皆令欢喜。如诸菩萨摩诃萨。如乌洒婆鸟。游行虚空无所障碍。能入一切众生大海。自在甚深。普遍观察。见有善根已成熟者。即便执取置菩提岸。又如商客。入一切智大宝洲中。采求如来十力智宝。又如渔师。有具足力。持正法网。入生死海。漉诸众生。如阿修罗王。能遍挠动三有大城。诸烦恼海。普令众生究竟寂静。又如日轮。出现虚空。照爱水泥令其干竭。犹如满月出现虚空。令可化者心华开敷。犹如大地。普皆平等。无量众生。于中止住。恒受履践。心无分别。增长一切善法根芽。犹如大风所向无碍。能拔一切诸见大树。坏散一切生死园苑。如转轮王游行世间。以四摄事摄诸众生。而我云何能知能说彼功德行。善男子。于此南方。有一大城。名都萨罗。其中有一出家外道。名曰遍行。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。时善财童子。顶礼不动优婆夷足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。于不动优婆夷所。得闻法已专心忆持。所有教诲。所有示导。所有演说。所有赞叹。所遇光照。皆悉随顺。生希有心。思惟观察。普遍修习一心正念。渐渐前行。经历国邑村营聚落。然后乃至都萨罗城。于日没时。入彼城中。廛店闾里四达交衢处处寻求遍行外道。于高显处。远望观察。其城东北。有一大山。名妙吉祥。善财童子。于中夜时。见此山顶。有大光明。峰峦峻峙。岩岫攒拱。草树华林。靡不辉映。照耀城居。如日初出。见此事已。生大欢喜。作是念言。我必于此。见善知识。便从城出正念观察。而登彼山。住立思惟。遥望瞻仰。见此外道于其山上平坦之处。徐步经行。色相圆满。威光照耀。吉祥福焰。过于炽火。十千梵众之所围绕。大梵天王所不能及善财即时。往诣其所。顶礼其足绕无数匝。合掌前立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知。菩萨云何。学菩萨行。云何修菩萨道我闻圣者。善能诱诲。愿为我说。遍行答言善哉善哉。善男子。汝乃能发阿耨多罗三藐三菩提心。复能请问诸菩萨行。善男子。我已安住至一切处随顺遍行菩萨行。已成就普观一切世间等无障碍三昧门。已成就无依无作神通力。已成就普门法界际般若波罗蜜。如是一切智慧光明。随行圆满。善男子。我能普于一切世间种种方所种种形色。种种相貌。种种殁生。种种行解。种种信乐。一切趣类。诸众生中。所谓天趣。龙趣。夜叉趣。乾闼婆。阿修罗。迦楼罗。紧那罗。摩睺罗伽。地狱。畜生。阎罗王界。人非人等。一切趣类。或住诸见。或信二乘。或有爱乐大乘之道。如是一切诸众生中。我以种种方便。种种智慧。种种教化。种种调伏。平等利益悉令圆满。所谓或为演说一切世间种种技艺利益众生。或为演说坚如金刚能破无明陀罗尼智。或为演说四摄方便摄诸众生令得亲近一切智道。或为演说诸波罗蜜。开示赞叹。令其回向一切智位。或为称叹发菩提心。令其不失无上道意。或为称赞诸菩萨行。令其满足能净佛刹度众生愿。或为演说造诸恶业受地狱等种种苦报。令于不善深生厌离。或为演说供养诸佛种诸善根。决定获得一切智果。令其发起欢喜之心。或为赞说一切如来应正等觉所有功德。令乐佛身求一切智。或为赞说诸佛威德。令其愿乐佛不坏身。或为赞说佛自在身。令求如来无能映蔽大威德体。善男子。我又于此都萨罗城。一切方所一切族类。若男若女诸人众中。以善方便。示同其形。随其所应。变化言音。种种差别。而为说法。诸众生等。悉不能知我是何人从何而至。唯令闻者。如理修行。悟真实义。善男子。如于此城利益众生。于阎浮提。城邑聚落。所有众生。止住之处。悉亦如是。而为利益。善男子。阎浮提内九十六众。各起异见而生执着。我悉于其中。方便调伏。令其舍离所有诸见。如阎浮提一切住处。余三天下。亦复如是。如四天下。小千中千大千世界。其中众生。一切住处。亦复如是。如此三千大千世界。如是十方无量世界。一切住处。一切品类。诸众生海。我悉于中。随诸众生心之所乐。以种种方便。种种法门。种种理趣。种种正行。种种事业。现种种色身。种种形相。种种言音。而为说法。令彼众生。皆得利益。善男子。我唯知此至一切处随顺遍行菩萨行。如诸菩萨摩诃萨。得与众生无差别身。得与一切众生数等三昧。以变化身普入诸趣。于一切处。皆现受生。清净光明。遍照法界。其有见者。无不蒙益。以无碍愿。住一切劫。得如帝网诸无等行。常勤利益一切众生。虽于无量烦恼垢中。恒与共居。而无染着。普于三世众生平等。以无我智。周遍照耀。以大悲藏。增长善根。而我云何能知能说彼功德行清净智慧。善男子。于此南方。有一国土。名为广博。彼有聚落。从国为名。其中有一鬻香长者。名曰具足优钵罗华。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼遍行足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。因善知识教。不顾身命。不着财宝。不耽五欲。不恋眷属。不重王位。自在安乐。唯愿化导一切众生。令其成熟。唯愿庄严诸佛刹土。普遍清净。唯愿供养一切如来。心无疲厌。唯愿证知诸法实性。分明显现。唯愿随顺甚深法界普遍无碍。唯愿修集一切菩萨大功德海。终无退转。唯愿恒于一切劫中。修菩萨行。唯愿普入一切如来众会道场。唯愿入于一三昧门。普现诸三昧门自在神力。唯愿于佛一法轮中。普持一切如来法轮。唯愿于佛一毛孔中见一切佛。心无厌足唯愿证得智慧光明。能持一切诸佛法藏。专求此等诸佛菩萨所有功德渐次游行。至广博国。及其聚落。普遍寻求鬻香长者。见已前诣。顶礼其足。绕无数匝。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。欲求一切佛平等智慧。欲满一切佛无量大愿。欲净一切佛最上色身。欲见一切佛清净法身。欲知一切佛广大智身。欲净治一切菩萨诸行。欲照明一切菩萨三昧。欲安住一切菩萨总持。欲坚牢一切菩萨功德。欲除灭一切所有障碍。欲游行一切十方世界。而未知。菩萨云何学菩萨行。云何修菩萨道。而能出生一切种智。长者告言。善哉善哉善男子。汝乃能发阿耨多罗三藐三菩提心。善男子。我善别知一切诸香。所谓一切香。一切烧香。一切涂香。一切末香。亦知调合如是香法。又知如是一切香王所出之处。又善了知天香龙香。夜叉香。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等所有诸香。又善了知治诸病香。断诸恶香。除忧恼香。生染爱香。增烦恼香。灭烦恼香。令于有为生乐着香。令于有为生厌离香。舍诸骄逸香。闻法欢喜香。发心念佛香。证解法门香。圣所受用香。一切菩萨差别香。一切菩萨地位香。如是等香。及调和法。形相生起出现。成就清净安隐方便境界。威力业用所从根本随处随人种类差别。如是一切。我皆了知。善男子。人间有香。名曰龙藏。因龙斗生。若烧一丸大如油麻。即能兴起大香焰云。犹如帝网弥覆王都。于七日中。雨细香雨。若着身者。身即金色。若着衣服。皆悉变成拘苏摩华色。若因风吹入宫殿中。一切台殿楼阁堂宇。皆悉变为拘苏摩华色。众生嗅者七日七夜。欢喜充满。身心快乐。惑热清凉。无有诸病。及诸烦恼不相侵害。离诸忧苦。不惊不怖。不迷不乱。慈心相向。志意清净。我知是已。如应说法。令其决定发阿耨多罗三藐三菩提心。善男子。摩罗耶山。出栴檀香。名曰牛头。若以涂身。设入火坑。火不能烧。善男子。海中有香。名无能胜。若以涂鼓及诸螺贝。其声发时。一切敌军悉皆退散。善男子。阿那婆达多池边。出沉水香。名莲华藏。若烧一丸如麻子大。香气普熏阎浮提界。众生闻者。离一切罪。戒品清净。善男子。雪山有香。名具足明相。若有众生嗅此香者。其心决定。离诸染着。我为说法。莫不皆得离垢圆满清净三昧。善男子。罗刹界中有香名海藏。其香但为转轮王用。若烧一丸。香气所熏。王及四军。皆腾虚空。游止自在。善男子。善法堂中有香。名香性庄严。若烧一丸。熏彼天众。普令发起念佛之心。善男子。须夜摩天有香。名净藏性。若烧一丸。熏彼天众。莫不云集彼天王所。恭敬听闻王所说法。善男子。兜率天中有香。名信度嚩啰。于一生所系菩萨座前。若烧一丸。兴大香云。遍覆法界。普雨一切诸供养具。供养一切如来道场菩萨众会。善男子。妙变化天有香。名夺意性。若烧一丸。于七日中。普雨一切不可思议诸庄严具。善男子。我唯知此调和香法。如诸菩萨摩诃萨。远离一切诸恶习气。为无垢香。永断烦恼众魔罥索。超诸有趣。得如幻智。于诸世间。皆无染着。具足圆满无所著戒。净无著智。行无著境。于一切处。悉无有着。其心平等。无著无依。而我何能知其妙行。说其功德。显其所有清净戒品。示其所作无过失业。阐其所有无过失智。辨其离染三业行门。善男子。于此南方。有一大城。名曰楼阁。彼有船师。名婆施罗。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼长者足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。一心正念。向楼阁城。随顺思惟观察道路。所谓观道高卑。观道夷险。观道净秽。观道安危。观道曲直。渐次而行。作如是念。我当亲近彼善知识。善知识者。是成就修行诸波罗蜜。增胜道因。善知识者。是成就修行。普入法界无碍道因。善知识者。是成就修行。摄取一切众生智道因。善知识者。是成就修行。令一切众生不堕险恶道因。善知识者。是成就修行。令一切众生离邪业道因。善知识者。是成就修行。令一切众生灭烦恼道因。善知识者。是成就修行。令一切众生除恶慧道因。善知识者。是成就修行。令一切众生离憍慢道因。善知识者。是成就修行。令一切众生拔恶刺道因。善知识者。是成就修行。令一切众生舍恶见道因。善知识者。是成就修行。令一切众生至一切智城道因。何以故。于善知识处。得一切善法故。依善知识力。得一切智道故。善知识者。难见难遇。于善知识。如是思惟。勤求作意。渐次前行。到彼城已。见彼船师。在城门外海岸上住。百千商人大众围绕。说大海法。方便开示佛功德海。即前往诣。顶礼其足。绕无数匝。一心合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知。菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说船师告言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。今复能问生大智因。断除一切生死苦因。往一切智大宝洲因。成就不坏趣大乘因。远离二乘怖生死因。住诸三昧生智慧因。遍行菩萨微细行因。乘大愿车游菩萨行清净道因。以菩萨行庄严无坏智清净道因。普观一切十方诸佛皆无障碍清净道因。速能趣入一切诸佛甚深智海清净道因。善男子。我在海岸楼阁大城。净修菩萨大悲幢行

善男子。我普观察阎浮提内。贫穷众生为饶益故。修种种行。随其所愿。悉令满足。先以世间珍宝饮食。充足其意。复施法财。令其欢喜。令修福行。令生智道。令增善根力。令发菩提心。令净菩提愿。令坚大悲力。令修能灭生死道。令起不舍生死行。令摄众生海。令修功德海。令照诸法海。令见诸佛海。令入种智海。善男子。我住于此。如是思惟。如是作意。如是勤求。如是利益。如是安乐一切众生。善男子。我知海中一切宝洲。一切宝处。一切宝性。一切宝根。一切宝种。一切宝类。我又能知净一切宝。钻一切宝。出一切宝。作一切宝。一切宝器一切宝用。一切宝境界。一切宝光明。我又能知一切龙宫。一切夜叉宫。一切罗刹宫。一切部多宫。如是一切差别住处。皆善回避。免其诸难。亦知大海漩澓浅深波涛远近。水色好恶。种种不同。亦善别知日月星辰。列宿回转。运行度数。变异灾祥。昼夜晷漏。时分延促。亦知其船铁木坚脆机关涩滑。水之大小。风之逆顺。左右旋转。安危之相。可行则行。可止则止。我以如是种种方便。常能利益一切众生善男子。我以好船运诸商众行安隐道。示其寂静。无恐怖相。复为说法。令其欢喜。随所乐欲。引至宝洲。与诸珍宝。咸使充足。然后将领还阎浮提。善男子。我将大船。如是往来。从昔至今。未曾损坏。若有众生。得见我身。闻我法者。令其永不怖生死海。必得入于一切智海。必能竭尽诸爱欲海。能以智光照三世海。能尽一切众生苦海。能净一切众生心海。速能严净一切刹海。普能往诣十方佛海。普知一切众生根海。普了一切众生行海。普顺一切众生性海。善男子。我唯得此大悲幢行。若有众生见闻忆念。与我同住。皆悉不空。如诸菩萨摩诃萨。善能游涉生死大海。能不染着诸烦恼海。能舍一切诸妄见海。能观一切诸法性海。能以四摄摄众生海。能善安住一切智海。能灭一切众生着海。能平等住一切时海。能以神通度众生海。能以其时调众生海。而我云何能知能说彼功德行。善男子。于此南方。有一城邑。名乐璎珞。中有长者。名为最胜。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼船师足。绕无数匝殷勤瞻仰。悲泣流泪。求善知识。心无厌足。于善知识。增恋慕心。增爱乐心。一心观察。辞退而去

大方广佛华严经卷第十四大方广佛华严经卷第十五

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。于诸众生。起大慈普遍心。起大悲润泽心。思惟相续。曾无间断。福德智慧具足庄严正见圆满。离诸尘垢。证法平等心无高下。随顺悟入一切智道。拔不善刺灭一切障。了达甚深觉法自性。坚固精进以为墙堑。不思议三昧而为园苑。以慧日光破无明闇。以方便风开智慧华。以广大愿充满法界。心常现入一切智城。如是勤求菩萨之道。渐次往诣乐璎珞城。到彼询求最胜长者。见在城东大庄严幢无忧林中。无量商人百千长者众所围绕。理断人间种种事务。因为宣扬出世之法。令离见慢及我我所。舍所积聚眷属珍财。灭除悭嫉一切疑执。心得清净。无诸秽浊。获净信力。常乐见佛。受持佛法。生菩萨力。起菩萨行。入菩萨三昧。得菩萨智慧。住菩萨正念。增菩萨乐欲。发起无上菩提之心。尔时善财。即至其所。以身投地。顶礼其足。良久乃起。以尊重心。白言圣者。我是善财。我是善财。我专寻求菩萨胜行。菩萨云何学菩萨行。菩萨云何修菩萨道。随修学时。常能化度一切众生。常能现见一切诸佛。常得听闻一切佛法。常能住持一切佛法。常能趣入一切法门。入一切刹。学菩萨行。常能久住一切大劫。修菩萨道。心无厌足。能知一切如来神力。能得一切如来护念。能入一切如来智慧。时彼长者。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我已成就至一切处净菩萨行法门。无体无依无作无住神通之力

善男子。云何名为至一切处净菩萨行法门。善男子。我于此三千大千世界欲界一切诸众生中。所谓一切三十三天。一切须夜摩天。一切兜率陀天。一切乐变化天。一切他化自在天。一切魔天。及余一切欲界所居部类眷属。一切天龙夜叉罗刹鸠槃茶乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。村营城邑。一切住处。诸众生中。随其所应。而为说法。令舍非法。令息诤论。令除斗战。令止忿竞。令破怨结。令解系缚。令出牢狱。令免怖畏。令断杀生。乃至邪见一切恶业不可作事。皆令禁止。令其顺行一切善法。诸可作事皆使正修。令其遍学一切技艺。于诸世间而作利益。为其分别种种诸论。随其所应。令生欢喜。令渐成熟随顺。一切诸外道众。为说胜慧。令断诸见。令入佛法。乃至色界一切梵天。我亦为其说如是法。如于此三千大千世界。乃至十方十不可说百千亿那由他佛刹极微尘数世界之中。我皆为其广说正法。所谓佛法。菩萨法。声闻法。独觉法。说地狱趣。说地狱众生受苦差别。说向地狱道。说畜生趣。说畜生众生受苦差别。说向畜生道。说阎罗王界。说阎罗王界受苦差别。说向阎罗王界道。说天世间。说天世间受乐差别。说向天世间道。说人世间。说人世间受苦受乐。说向人世间道。善男子。我说如是种种世间。若集若坏若染若净。为欲开显菩萨功德。为令舍离生死过患。为令知见诸佛功德。为令知见诸有趣生。为令知见无障碍法。为令开发智慧光明。为欲显示苦乐因起。为欲显示入无相门。为令众生舍诸想着。为令证得佛无依法。为令永灭烦恼业轮。为令能转佛净法轮。我为众生说如是法。善男子。我唯知此至一切处净菩萨行庄严法门无依无作无性无住神通之力。如诸菩萨摩诃萨。具足一切自在神通。悉能遍往一切佛刹。得普眼地。住净耳根。悉闻一切音声言说。普入诸法。智慧自在。勇健无比。离诸乖诤。以广长舌。出平等音。其身妙好。同诸菩萨。与诸如来究竟无二。智身广大。普入三世境界无际。同于虚空。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名无边际河。其国有城。名羯陵迦林。有比丘尼。名师子频申。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼最胜足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财。童子渐渐前行。至无边际河羯陵迦林。周遍寻访师子频申比丘尼。时无量人。咸告之言。善男子。此比丘尼。在胜光王之所舍施日光园中。说法利益无量众生。善财闻已。欢喜踊跃。即诣彼园。周遍观察。见其园中。有一大树。名过满月。形如楼阁。高广严好。放大光明。照一由旬。复见叶树。名曰普覆。其形如盖。绀青光明。周遍照耀。复见华树。名曰华藏。形色高洁犹如雪山。雨众妙华如流香水。周遍普熏无有穷尽。犹忉利天欢喜园中波利质多罗树。复有果树。名为常熟。形如金山。味如甘露。柔软香美常放光明。种种众果。悉皆具足其中。复有摩尼宝树。名毗卢遮那藏。其形无比。如妙高山。心王摩尼宝。最在其上。阿僧祇色相摩尼宝周遍庄严。栴檀摩尼以为树果。众杂珠网。罗覆其上。复有鬘树。名为天宝。恒出妙宝璎珞华鬘。如意宝王敷荣光耀。摩尼宝藏蕴伏其下。以为树根。复有衣树。名能清净。常出众色诸妙宝衣。垂布树枝。以为严饰。有音乐树。名为欢喜。其音美妙。过诸天乐。复有香树。名遍庄严。恒出妙香。普熏一切园中。复有种种陂池。一切皆以七宝庄严。其池入处。众宝庄严。众色摩尼。而为栏楯。栴檀香末。凝积其中。上妙金沙弥布其底。八功德水清净盈满。优钵罗华。波头摩华。拘物头华。芬陀利华。遍覆其上。瞻博迦华。阿提目多迦华。婆利师迦华。曼陀罗华。摩诃曼陀罗华。如是等华。列植其岸。众鸟和鸣。其声清雅。种种天宝。妙庄严树。行列园中。诸宝树下。各各敷置宝师子座。以不思议种种妙宝而为庄严。布以天衣。熏以妙香。垂诸宝缯。施诸宝帐。阎浮金网。弥覆其上。宝铎徐摇。出妙音声。或有树下敷莲华藏师子之座。或有树下敷香王摩尼藏师子之座。或有树下敷龙象庄严摩尼王藏师子之座。或有树下敷宝师子聚摩尼王藏师子之座。或有树下敷毗卢遮那摩尼王藏师子之座。或有树下敷十方毗卢遮那摩尼王藏师子之座。或有树下敷因陀罗摩尼金刚王藏师子之座。或有树下敷众生形相毗卢遮那摩尼王藏师子之座。或有树下敷如意摩尼王藏师子之座。或有树下敷白色光明摩尼王藏师子之座。其一一座各有百千宝师子座周匝围绕。一一皆具无量庄严。此大园中。众宝充满。如海宝洲。宝衣布地。敷设庄严。柔软妙好。如迦邻迦衣。能生乐触。蹈之没足。举即还复。异类众鸟。凫雁鸳鸯。白鹤孔雀。拘枳罗等。飞翔自在。顾影和鸣。宝栴檀林列植门侧。密叶葱翠。耸干枎疏。布影垂阴。庄严妙好。种种华树。常雨妙华。逾天帝释杂华之园。无比香王。普熏一切。香风四布。流及天人。一切楼阁众宝庄严。上妙香华。珍奇校饰。过天帝释善法之堂。诸音乐树奏天音乐。种种乐器。悬布树枝。所谓筝笛箜篌琵琶箫瑟。如是等乐。不鼓自鸣。闻皆可意。离诸染着。宝多罗树。覆宝铃网。微风吹动。出微妙音。如自在天善口天女。诸如意树。出众宝衣。如天劫波服。垂布严饰。有无量色。犹如大海。百千楼阁众宝庄严。如忉利天帝释宫殿。宝盖弥覆。如妙高峰。如梵王宫。光明普照。尔时善财童子。见此园林。无量功德。种种庄严。皆是菩萨不思议业之所成就。出世善根之所生起。供养一切诸佛功德。广修净业。无能坏者。一切世间无能与等。如是皆从师子频申比丘尼了法如幻不舍有为积集广大善业所成。不与声闻辟支佛共。异道邪论不能倾动。一切魔军无能与敌。凡夫浅智不能思惟。三千大千世界天龙八部。无量众生。随自善根。如应度者。皆入此园。而不迫窄。何以故。此比丘尼。不可思议威神力故

尔时善财。见比丘尼。遍坐一切诸宝树下大师子座。身相端严。威仪寂静。住法平等。动止安详。诸根调顺。如大象王。心无垢浊。如清净池。普济所求。如如意宝。不染世法。犹如莲华。心无所畏。如师子王。护持净戒。不可倾动。如须弥山。能令见者心得清凉。如妙香山。能除众生诸烦恼热。如雪山中妙栴檀香。众生见者。诸苦销灭。如妙见药王。能令见者。所愿不空。如婆楼那天。永离欲染。如大梵王。净众生心。如水清宝。能长众善。如良沃田。三业自在。犹如如来。在一一座。众会不同。所说法门。亦各差别。或见处座。净居天众所共围绕。摩醯首罗天王而为上首。此比丘尼。为说法门。名无尽法相解脱。或见处座。诸梵天众。所共围绕。妙光明梵王而为上首。此比丘尼。为说法门。名普门差别清净言音轮。或见处座。他化自在天天子天女。所共围绕。自在转天王。而为上首。此比丘尼。为说法门。名菩萨清净心自在庄严。或见处座。妙变化天天子天女所共围绕。乐变化天王。而为上首。此比丘尼。为说法门。名妙法清净庄严门。或见处座。兜率陀天天子天女。所共围绕。兜率天王。而为上首。此比丘尼为说法门。名自心藏旋转。或见处座。须夜摩天天子天女所共围绕。须夜摩天王。而为上首。此比丘尼为说法门。名普遍庄严。或见处座。三十三天天子天女。所共围绕。释提桓因。而为上首。此比丘尼。为说法门。名厌离门。或见处座。百光明龙王。难陀龙王。优波难陀龙王。摩那斯龙王。伊罗跋陀龙王。阿那婆达多龙王等。龙子龙女。所共围绕。娑伽罗龙王。而为上首。此比丘尼。为说法门。名佛境界光明庄严。或见处座。诸夜叉众。童男童女。所共围绕。毗沙门天王。而为上首。此比丘尼。为说法门。名救护众生藏。或见处座乾闼婆。众男女眷属。所共围绕。持国乾闼婆王。而为上首。此比丘尼。为说法门。名雨无尽大欢喜法雨。或见处座。阿修罗众男女眷属。所共围绕。罗睺阿修罗王。而为上首。此比丘尼。为说法门。名速疾庄严法界智门。或见处座。迦楼罗众男女眷属。所共围绕。大力勇持迦楼罗王。而为上首。此比丘尼。为说法门。名怖动诸有海。或见处座。紧那罗众男女眷属。所共围绕。大树紧那罗王。而为上首。此比丘尼。为说法门。名佛行光明门。或见处座。摩睺罗伽众男女眷属。所共围绕。庵罗林忿怒摩睺罗伽王。而为上首。此比丘尼。为说法门。名出生见佛欢喜心。或见处座。无数百千男子女人童男童女。所共围绕。此比丘尼。为说法门。名殊胜行。或见处座。诸罗刹众男女眷属。所共围绕。常吸精气大树罗刹王。而为上首。此比丘尼。为说法门。名发生慈悲心。或见处座。信乐声闻乘众生。所共围绕。此比丘尼。为说法门。名胜智威力大光明。或见处座。信乐独觉乘众生。所共围绕。此比丘尼。为说法门。名佛功德广大光明。或见处座。信乐大乘众生。所共围绕。此比丘尼。为说法门。名普门三昧智光明。或见处座。初地菩萨。所共围绕。此比丘尼。为说法门。名一切诸佛大愿聚三昧。或见处座。二地菩萨。所共围绕。此比丘尼。为说法门。名无垢轮三昧。或见处座。三地菩萨。所共围绕。此比丘尼。为说法门。名大寂静庄严三昧。或见处座。四地菩萨。所共围绕。此比丘尼。为说法门。名速疾出生一切智境界三昧。或见处座。五地菩萨。所共围绕。此比丘尼。为说法门。名妙华藏三昧。或见处座。六地菩萨。所共围绕。此比丘尼。为说法门。名毗卢遮那藏三昧。或见处座。七地菩萨所共围绕。此比丘尼为说法门。名普遍庄严地三昧。或见处座。八地菩萨。所共围绕。此比丘尼。为说法门。名普遍法界境界化现身三昧。或见处座。九地菩萨。所共围绕。此比丘尼。为说法门。名无所得力智庄严三昧。或见处座。十地菩萨。所共围绕。此比丘尼。为说法门。名无障碍轮三昧。或见处座。执金刚菩萨所共围绕。此比丘尼。为说法门。名金刚智那罗延庄严三昧

尔时善财童子。见如是等一切大众种种出生。种种住处。种种身相。种种眷属。已成熟者。已调伏者。堪为法器。皆入此园。各于树下。围绕而坐。师子频申比丘尼。如其所应种种心性。种种欲乐。种种信解。随彼所宜胜劣差别。而为演说相应法门。令于阿耨多罗三藐三菩提得不退转。何以故。此比丘尼。得普眼舍得般若波罗蜜门。演说一切佛法般若波罗蜜门。法界差别际般若波罗蜜门。散坏一切障碍轮般若波罗蜜门。生长一切众生善心般若波罗蜜门。最胜庄严般若波罗蜜门。无碍真实藏般若波罗蜜门。法界圆满般若波罗蜜门。清净心藏般若波罗蜜门。普遍出生种种语言神通藏般若波罗蜜门。此十般若波罗蜜门。而为上首。入如是等无数百万阿僧祇般若波罗蜜门。此日光园中。一切菩萨。及诸众生。所见境界。所闻妙法。各各差别。悟解不同。皆是师子频申比丘尼。初劝发心。说法教化。令于阿耨多罗三藐三菩提得不退转。时善财童子。见师子频申比丘尼。如是园林。如是床座。如是经行。如是众会。如是威仪。如是自在。如是普身。如是无畏。如是神力。如是辩才。如是庄严。复闻如是不可思议广大法门。身心柔软。五体投地。恭敬顶礼。合掌念言。我当右绕此比丘尼。经于无数百千万匝。作是念时。此比丘尼。即放光明。遍照其园。普及众会。善财童子。即自见身。遍一切处。一一座上。比丘尼所。皆悉右绕。百千万匝。围绕毕已。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。比丘尼言。善男子。我得菩萨解脱。名灭除一切微细分别门

善财白言。圣者何故。名为灭除一切微细分别。比丘尼言。善男子。此解脱门。于一念中。普照三世一切诸法。显示本性智慧光明。善财白言。圣者此智光明境界云何。比丘尼言。善男子。我入此智光明门时。得自在出生一切法三昧王。以得如是三昧王故。现意生身。普遍十方一切世界兜率天宫。一生所系诸菩萨所。于一一菩萨前。现不可说佛刹极微数身。于一一身。作不可说佛刹极微数最胜供养。所谓或现天王身。龙王身。夜叉王身。乃至人王身。各各执持种种华云。种种鬘云。烧香涂香。及以末香。衣服璎珞。幢幡缯盖。宝网宝帐。宝藏宝灯。乃至一切庄严具云。我皆执持。而以供养。如于住兜率宫一生所系菩萨所。亲近承事。种种供养。如是降神入胎。住胎出胎。在家出家。往诣道场。成等正觉。转正法轮。入于涅槃。如是中间。或住天宫。或住龙宫。乃至或住人非人宫。于彼一切诸如来所。我皆如是而为供养。若有众生。知我如是见闻亲近供养佛者。一切皆于阿耨多罗三藐三菩提。得不退转。若有众生。来诣我所。我皆诱诲。为其宣说般若波罗蜜门。善男子。我见一切众生。不分别众生相。智眼明见故。听一切语言。不分别语言相。心无所著故。见一切如来。不分别如来相智。了法身故。住持一切如来法轮。不分别法轮相。悟法自性故。一念遍知一切法。不分别诸法相。知法如幻故。善男子。我唯知此灭除一切微细分别成就一切智菩萨解脱门。如诸菩萨摩诃萨心无分别。普知诸法。一身端坐。充满法界。于自身中。示现摄持一切佛刹。悉能往诣一切佛所。于自身内。普现一切诸佛神力。一毛遍举不可说不可说诸佛世界。于其自身一毛孔中。现不可说不可说世界成坏。于一念中。与不可说不可说众生同住。于一念中。入不可说不可说一切诸劫。而我云何能知能说彼功德行。善男子。于此南方。有一聚落。名为险难。其中有城。名宝庄严。彼有女人。名伐苏蜜多。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。大慧光明照启其心。思惟观察一切智智。一心随顺诸法实性。坚固了知一切众生言音陀罗尼门。得受持一切如来法轮陀罗尼门。得与一切众生作所归依大悲力。得观察一切法义理光明门。得速疾圆满法界轮。得转彼清净大愿轮。得普照十方一切法智光明。得遍庄严一切世界自在力。得普摄取一切菩萨神通智。得普发起一切菩萨圆满愿。渐渐前行。至险难国宝庄严城。处处寻访伐苏蜜多女。城中有人。不知此女功德智慧。方便善巧。所住境界。微密甚深。作如是念。今此童子。诸根寂静。诸根调顺。智慧明了。已离放逸。心不迷乱。谛视一寻。无有疲懈。无所取着。目视不瞬。心无所动。甚深宽广。犹如大海。不应于此伐苏蜜多女。有贪爱心。有颠倒心。生于净想。生于欲想。不应为此女色所摄。此童子者。不行魔行。不入魔境。不没欲泥。不被魔缚。不应作处。已能不作。有何等意。而求此女。其中有人。先知此女有胜功德具深智慧。告善财言。善哉善哉。善男子。汝今乃能推求寻觅伐苏蜜多女。汝已获得广大善利。善男子。汝应决定求佛妙果。决定欲为一切众生作所依怙。决定欲拔一切众生贪爱毒箭。决定欲破一切众生于女色中所有净想。决定欲雨一切如来普遍法界大功德雨。善男子。伐苏蜜多女。于此城内市廛之北自宅中住。时善财童子。闻是语已。欢喜踊跃。心愿圆满。一心正念。往诣其门。见其住宅。广博严丽。宝墙宝树。及以宝堑。一一皆有十重围绕。其宝堑中。香水盈满。底布金沙。诸天宝华。优钵罗华。波头摩华。拘物头华。芬陀利华。遍覆水上。异香芬馥。悦畅众心。妙宝殊珍。庄严其岸。阶陛栏楯。众宝合成。宫殿楼阁。处处分布。门闼窗牖。相望间列。咸施网铎。悉建幢幡。无量珍奇。以为严饰。琉璃为地。众宝间错。烧诸沉水。涂以栴檀。悬众宝铃。风动成音。散诸天华。周遍其地。摩尼灯烛。光明普照。诸珍宝藏。其数百千。十大园林。以为庄严。宝树枝条。腾芳发耀。种种殊丽。不可称说。尔时善财。见此女人。颜貌端严。色相圆满。皮肤金色。目发绀青。不长不短。不粗不细。欲界人天。无能与比。音声美妙。超诸梵世。一切众生。差别言音。悉皆具足。无不解了。深达字义。善巧谈说。得如幻智。入方便门。众宝璎珞。庄严其身。一切宝网。周覆其上。首冠如意摩尼宝冠。无量眷属。恭敬围绕。皆共善根。同一行愿。福德大藏。具足无尽。时彼女人。从其身出广大光明。普照宅中。一切堂宇。及宝宫殿。遇斯光者。身得清凉。心除惑热

尔时善财。前诣其所。顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。彼即告言。善男子。我得菩萨解脱。名离贪欲际。我能随顺一切众生诸所乐欲。而为现身。若天见我。我为天女。形貌光明。殊胜无比。如是乃至人非人等。而见我者。我即为现人非人女。随其形相。各各殊胜。随其乐欲。皆令得见。善男子。若有众生。欲意所缠。来诣我所。而于我身。生极爱染。心如昏醉。我为说法。彼闻法已。则离贪欲。得菩萨无著境界三昧。若有众生。暂见于我。则离贪欲。得菩萨欢喜三昧。若有众生。暂与我语。则离贪欲。得菩萨无碍妙音声藏三昧。若有众生。暂执我手。则离贪欲。得菩萨随顺遍往一切佛刹三昧。若有众生。暂升我座。则离贪欲。得菩萨离一切世间光明三昧。若有众生。暂观于我。则离贪欲。得菩萨寂静庄严三昧。若有众生。见我频申。则离贪欲。得菩萨摧伏一切外道三昧。若有众生。见我目瞬。则离贪欲。得菩萨住佛境界光明三昧。若有众生。抱持于我。则离贪欲。得菩萨摄一切众生恒不舍离三昧。若有众生。[口*(一/巾)]我唇吻。则离贪欲。得菩萨增长一切众生福德藏三昧。如是一切所有众生。来诣我所。亲近于我。一切皆得住离贪际。入于菩萨一切智地最胜解脱

尔时善财童子。白伐苏蜜多女言。圣者云何。此解脱门。得名最胜。时女告言。善男子。一切菩萨。发阿耨多罗三藐三菩提心。由为女人。不得速成无上佛道。亦不疾得辟支佛乘。阿罗汉果。五通仙人由女色故退失神通为荷负者。天阿修罗。常兴战伐。十头罗刹。焚烧南海楞伽大城。或有诸王。丧失国土。乃至兄弟自相杀害。造恶趣因。现世贫穷。甘为奴仆。不顺师长。违背君亲。如是一切皆由女人。我观无数百千世界贪欲众生。生死旷野。轮转无穷。苦业之中。女为上首。是故菩萨。若离女色。即得亲近诸善知识。复令众生因此离欲。皆住最胜解脱法门

善财童子。白言圣者。种何善根。修何福业。而得增长如是种种殊胜功德。时女答言。善男子。我念过去。有佛出世。名为高行如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。时王都城。名曰妙门。善男子。时彼如来。为欲利乐诸众生故。来入王城。蹈彼门阃。其城一切六种震动。忽然广博。众宝庄严。无量光明。递相映彻。种种宝华。散布其地。诸天音乐。同时俱奏。一切诸天充满虚空。恭敬礼拜。尊重赞叹。善男子。我于彼时。为长者妻。名曰妙智。见佛神通。心生觉悟。则与其夫。疾诣佛所。发广大心。以一宝钱。奉施于佛。是时文殊师利童子。为佛侍者。为我说法。令发阿耨多罗三藐三菩提心。善男子。我唯知此菩萨离贪欲际解脱法门。如诸菩萨摩诃萨。成就无边巧方便智。福德广大。犹如虚空。而我云何能知能说彼功德行。善男子。南方有城。名净达彼岸。中有居士。名毗瑟底罗。彼常供养栴檀座佛塔。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第十五大方广佛华严经卷第十六

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。闻伐苏蜜多离贪欲际解脱门。一心随顺。忆念修行。观彼菩萨无著境界三昧。思彼菩萨欢喜三昧。寻彼菩萨无碍音声藏三昧。行彼菩萨遍往一切佛刹三昧。念彼菩萨离一切世间光明三昧。入彼菩萨寂静庄严三昧。修彼菩萨摧伏外道三昧。观彼菩萨佛境界光明三昧。思彼菩萨摄一切众生不舍三昧。住彼菩萨增长众生福德藏三昧。念一切智。渐次前行。至彼岸城。诣居士宅。顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者善能诱诲。愿为我说。居士告言。善男子。我得菩萨解脱。名不般涅槃际。善男子。我不生心言。如是如来。已般涅槃。如是如来。现般涅槃。如是如来。当般涅槃。我知十方一切世界诸佛如来。毕竟无有般涅槃者。唯除为欲调伏众生而示现耳。善男子。我开彼栴檀座如来塔门时。得三昧。名佛种无尽。善男子。我念念中。入此三昧。念念得知一切诸佛殊胜之事。善财白言。此三昧者。境界云何。居士答言。善男子。我入此三昧时。随其次第。见此世界一切诸佛相续出现。所谓迦叶佛。拘那含牟尼佛。拘留孙佛。毗舍浮佛。尸弃佛。毗婆尸佛。提舍佛。弗沙佛。名称佛。最胜莲华佛。如是等佛。而为上首。于一念顷。得见百佛。得见千佛。得见百千佛。得见亿佛。百亿佛。千亿佛。百千亿佛。阿庾多亿佛。那由他亿佛。乃至见不可说不可说世界极微尘数佛。如是一切次第皆见。亦见彼佛初始发心。种诸善根。获胜神通。成就大愿。修行妙行。具波罗蜜。入菩萨地。得清净忍。摧伏魔军。成等正觉。国土清净。众会庄严。放大光明。神通自在。作师子吼。转妙法轮。变化示现种种差别。无量方便。成熟众生。善巧宣扬。诸分别法。我悉能持。我悉能忆。悉能观察。分别显示。随顺解了。无有忘失。如是未来弥勒佛等。百佛千佛。百千亿佛。乃至不可说不可说世界。极微尘数佛。及初发心。相续不断。信解甚深。勤求不懈。精进势力。速疾增长。一切世间凡夫二乘。所不能动。亦见现在毗卢遮那佛等十方不可说不可说佛刹极微尘数一切世界诸佛如来。悉亦如是。彼一切佛。我皆现见。彼一切法。我悉得闻。忆念受持。心无忘失。以智慧力。随顺解了。以慈悲力。宣扬显示。善男子。我唯知此菩萨所得不般涅槃际解脱门。如诸菩萨摩诃萨。以一念智。普知三世。一念遍入一切三昧。如来智日。恒照其心。于一切法。无有分别。了一切佛。悉皆平等。如来及我一切众生等无有二。知一切法自性清净。光明普照。无所不遍。无有思虑。无有动转。而能普入一切世间。离诸分别。住佛法印。悉能开悟法界众生。而我云何能知能说彼功德行。善男子。于此南方有山名补怛洛迦。彼有菩萨。名观自在。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时居士。因此指示。即说偈言

  海上有山众宝成　　贤圣所居极清净
  泉流萦带为严饰　　华林果树满其中
  最胜勇猛利众生　　观自在尊于此住
  汝应往问佛功德　　彼当为汝广宣说

时善财童子。礼居士足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。蒙居士教。随顺思惟。一心正念。入彼菩萨深信解藏。得彼菩萨能随念力。忆彼诸佛出现次第。见彼诸佛成等正觉。持彼诸佛所有名号。观彼诸佛所证法门。知彼诸佛具足庄严。信彼诸佛所转法轮。思彼诸佛智光照曜。念彼诸佛平等三昧。解彼诸佛自性清净。修彼诸佛无分别法。契彼诸佛甚深法印。作彼诸佛不思议业。渐次前行。至于彼山。处处求觅此大菩萨。见其西面岩谷之中。泉流萦映。树林蓊郁。香草柔软。右旋布地。种种名华。周遍严饰。观自在菩萨。于清净金刚宝叶石上。结跏趺坐。无量菩萨皆坐宝石。恭敬围绕。而为宣说智慧光明大慈悲法。令其摄受一切众生。善财见已。欢喜踊跃。于善知识。爱乐尊重。合掌恭敬。目视不瞬。作如是念。善知识者即是如来。善知识者一切法云。善知识者诸功德藏。善知识者难可值遇。善知识者十力宝因。善知识者无尽智炬。善知识者福德根芽。善知识者一切智门。善知识者智海导师。善知识者集一切智助道之具。作是念已。即便往诣大菩萨所。尔时观自在菩萨。遥见善财告言。善哉善来。童子汝发大乘意。普摄众生。起正直心。专求佛法。大悲深重。救护一切。住不思议最胜之行。普能拯拔生死轮回。超过世间无有等比。普贤妙行。相续现前。大愿深心。圆满清净。勤求佛法。悉能领受。积集善根。恒无厌足。顺善知识。不违其教。从文殊师利功德智慧大海所生。其心成熟。得佛威力。已获广大三昧光明。专意希求甚深妙法。常见诸佛。生大欢喜。智慧清净犹如虚空。既自明了。复为他说。安住如来智慧光明。受持修行一切佛法。福智宝藏自然而至。一切智道速得现前。普观众生。心无懈倦。大悲坚固犹若金刚。尔时善财童子。诣菩萨所。礼菩萨足。绕无数匝。合掌而住。白言圣者。我已先发阿耨多罗三藐三菩提心而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。尔时观自在菩萨摩诃萨。放阎浮檀金妙色光明。起无量色宝焰网云。及龙自在妙庄严云。以照善财。即舒右手。摩善财顶。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我已成就菩萨大悲速疾行解脱门。善男子。我以此菩萨大悲行门。平等教化一切众生。摄受调伏。相续不断。善男子。我恒住此大悲行门。常在一切诸如来所。普现一切诸众生前。随所应化而为利益。或以布施摄取众生。或以爱语摄取众生。或以利行摄取众生。或以同事摄取众生。或现种种微妙色身摄取众生。或现种种不思议色净光明网摄取众生。或以音声善巧言辞。或以威仪胜妙方便。或为说法。或现神变。令其开悟而得成熟。或为化现种种色相。种种族姓。种种生处。同类之形。与其共居。而成熟之。善男子。我修习此大悲行门。愿常救护一切众生。令离诸怖。所谓愿一切众生离险道怖。离热恼怖。离迷惑怖。离系缚怖。离杀害怖。离王官怖。离贫穷怖。离不活怖。离恶名怖。离于死怖。离诸病怖。离懈怠怖。离黑暗怖。离迁移怖。离爱别怖。离怨会怖。离逼迫身怖。离逼迫心怖。离忧悲愁叹怖。离所求不得怖。离大众威德怖。离流转恶趣怖。复作是愿。愿诸众生。若念于我。若称我名。若见我身。皆得免离一切恐怖。灭除障难。正念现前。善男子。我以如是种种方便。令诸众生离诸怖畏。住于正念。复教令发阿耨多罗三藐三菩提心。至不退转。尔时观自在菩萨摩诃萨。欲重明此解脱门义。为善财童子。而说偈言

  善来调伏身心者　　稽首赞我而右旋
  我常居此宝山中　　住大慈悲恒自在
  我此所住金刚窟　　庄严妙色众摩尼
  常以勇猛自在心　　坐此宝石莲华座
  天龙及以修罗众　　紧那罗王罗刹等
  如是眷属恒围绕　　我为演说大悲门
  汝能发起无等心　　为见我故而来此
  爱乐至求功德海　　礼我双足功德身
  欲于我法学修行　　愿得普贤真妙行
  我是勇猛观自在　　起深清净大慈悲
  普放云网妙光明　　广博如空极清净
  我垂无垢佣圆臂　　百福妙相具庄严
  摩汝深信善财顶　　为汝演说菩提法
  佛子应知我所得　　一相一味解脱门
  名为诸佛大悲云　　秘密智慧庄严藏
  我为精勤常救护　　起诸弘誓摄众生
  怜愍一切如己身　　常以普门随顺转
  我于无数众苦厄　　常能救护诸群生
  心念礼敬若称名　　一切应时皆解脱
  或遭牢狱所禁系　　杻械囚执遇怨家
  若能至心称我名　　一切诸苦皆销灭
  或犯刑名将就戮　　利剑毒箭害其身
  称名应念得加持　　弓矢锋刃无伤害
  或有两竞诣王官　　诤讼一切诸财宝
  彼能至诚称念我　　获于胜理具名闻
  或于内外诸亲属　　及诸朋友共为怨
  若能至诚称我名　　一切怨家不能害
  或在深林险难处　　怨贼猛兽欲伤残
  若能至心称我名　　恶心自息无能害
  或有怨家怀忿毒　　推落险峻大高山
  若能至心称我名　　安处虚空无损坏
  或有怨家怀忿毒　　推落深流及火坑
  若能至心称我名　　一切水火无能害
  若有众生遭厄难　　种种苦具逼其身
  若能至心称我名　　一切解脱无忧怖
  或为他人所欺谤　　常思过失以相仇
  若能至心称我名　　如是怨嫌自休息
  或遭鬼魅诸毒害　　身心狂乱无所知
  若能至心称我名　　彼皆销灭无诸患
  或被毒龙诸鬼众　　一切恐怖夺其心
  若能至诚称我名　　乃至梦中皆不见
  若有诸根所残缺　　愿得端严相好身
  若能至诚称我名　　一切所愿皆圆满
  若有愿于父母所　　承顺颜色志无违
  欢荣富乐保安宁　　珍宝伏藏恒无尽
  内外宗族常和合　　一切怨隙不来侵
  若能至诚称我名　　一切所愿皆圆满
  若人愿此命终后　　不受三涂八难身
  恒处人天善趣中　　常行清净菩提道
  有愿舍身生净土　　普现一切诸佛前
  普于十方佛刹中　　常为清净胜萨埵
  普见十方一切佛　　及闻诸佛说法音
  若能至诚称我名　　一切所愿皆圆满
  或在危厄多忧怖　　日夜六时称我名
  我时现住彼人前　　为作最胜归依处
  彼当生我净佛刹　　与我同修菩萨行
  由我大悲观自在　　令其一切皆成就
  或清净心兴供养　　或献宝盖或烧香
  或以妙华散我身　　当生我刹为应供
  或生浊劫无慈愍　　贪嗔恶业之所缠
  种种众苦极坚牢　　百千系缚恒无断
  彼为一切所逼迫　　赞叹称扬念我名
  由我大悲观自在　　令诸惑业皆销灭
  或有众生临命终　　死相现前诸恶色
  见彼种种色相已　　令心惶怖无所依
  若能至诚称我名　　彼诸恶相皆销灭
  由我大悲观自在　　令生天人善道中
  此皆我昔所修行　　愿度无量群生众
  勇猛精勤无退转　　令其所作皆成就
  若有如应观我身　　令其应念咸皆见
  或有乐闻我说法　　令闻妙法量无边
  一切世界诸群生　　心行差别无央数
  我以种种方便力　　令其闻见皆调伏
  我得大悲解脱门　　诸佛证我已修学
  其余无量功德海　　非我智慧所能知
  善财汝于十方界　　普事一切善知识
  专意修行无懈心　　听受佛法无厌足
  若能闻法无厌足　　则能普见一切佛
  云何见佛志无厌　　由听妙法无厌足

尔时观自在菩萨。说此偈已。告善财言。善男子。我唯得此菩萨大悲速疾行解脱门。如诸菩萨摩诃萨。已净普贤一切愿。已住普贤一切行。常行一切诸善法。常入一切诸三昧。常住一切无边劫。常诣一切无边刹。常观一切诸如来。常闻一切三世法。常息一切众生恶。常长一切众生善。常绝众生生死流。常入如来正法流。而我云何能知能说彼功德行。尔时善财童子。闻观自在菩萨摩诃萨说此大悲清净偈已。欢喜踊跃。充遍其身。生爱敬心。增信乐心。发清净心。从坐而起。偏袒右肩。右膝着地。礼菩萨足。长跪合掌。于菩萨前。瞻仰一心。以偈赞曰

  天人大众阿修罗　　及与一切诸菩萨
  以妙言音共称赞　　大圣智慧深如海
  能于一切众生中　　平等大悲同一味
  一智同缘普救护　　种种苦难皆销灭
  菩萨最胜神通力　　反覆大地不为难
  又能干竭于大海　　令大山王咸震动
  圣者菩萨大名闻　　号曰大悲观自在
  云何我以微劣智　　于仁胜德能称赞
  我闻圣者诸功德　　无断无尽大悲门
  因是发起清净心　　生我智慧辩才力
  我今处于大众会　　以大勇猛而观察
  称扬赞叹妙庄严　　恭敬至诚无懈倦
  如大梵王居梵众　　映蔽一切诸梵天
  菩萨吉祥妙色身　　处于众会无伦匹
  菩萨顾视同牛王　　妙色融朗如金聚
  具足广大菩提愿　　普利一切诸天人
  种种华鬘以严饰　　顶上真金妙宝冠
  光明净妙过诸天　　威德尊严超世主
  圆光状彼流虹绕　　外相明如净月轮
  顶相丰起若须弥　　端严正坐如初日
  腰系金绦色微妙　　现殊胜相放光明
  伊尼鹿皮作下裙　　能令见者生欢喜
  妙身种种庄严相　　众宝所集如山王
  腰垂上妙清净衣　　如云普现无边色
  真珠三道为交络　　犹如世主妙严身
  恒放净光普照明　　亦如朗日游空界
  身色净妙若金山　　又如瞻博迦华聚
  以白璎珞为严饰　　如白龙王环绕身
  世主手执妙莲华　　色如上妙真金聚
  毗琉璃宝以为茎　　大慈威力令开发
  出过天人之所有　　普放光明犹日轮
  显现如在妙高山　　香气普熏于一切
  于诸恶鬼部多等　　黑蛇醉象及师子
  痴火毒害蔽慈心　　及余种种诸危难
  重苦系缚所伤迫　　一切恐怖无依怙
  世主一味大悲心　　平等救彼众生类
  妙宝叶石为胜座　　无等莲华之所持
  百千妙福之所成　　众妙莲华所围绕
  极妙身光清净色　　从真胜义而成就
  诸天种种上妙供　　咸共赞叹仁功德
  于尊能发清净意　　速离一切忧怖心
  眷属快乐共欢娱　　一切妙果皆圆满
  大海龙王住自宫　　及余居处诸龙众
  常惧妙翅大鸟王　　搏撮伤残受诸苦
  或有众生入大海　　遇风鼓浪如雪山
  若遭摩竭欲来吞　　恐怖惊惶无所救
  或遇醉象而奔逐　　种种厄难之所缠
  至心忆念大悲尊　　如是一切无忧怖
  大石山王有洞窟　　其窟幽深极可畏
  有犯王法锁其身　　种种系缚投于彼
  彼诸苦恼众生等　　至心忆念大悲尊
  枷锁解脱苦销除　　一切无忧安隐乐
  仁以大悲清净手　　摄取忆念诸众生
  令于一切厄难中　　获得无忧安隐乐
  我今赞叹人天主　　最胜威德大仙王
  三毒翳障尽销除　　福智无涯如大海
  调伏众生无懈倦　　利乐平等无怨亲
  愿于菩萨妙金山　　一切胜福皆成就
  普于十方诸世界　　息灭众生邪见心
  速获如来无上身　　普愿众生咸证得

尔时有一菩萨。名正性无异行。从于东方虚空中。来至此世界轮围山顶。以足按地。时此世界六种震动。变成无数杂宝庄严。复于其身。放大光明。映蔽一切。释梵护世天龙八部。日月星电。所有光明。皆如聚墨。其光普照地狱饿鬼畜生。阎罗王界。及余一切苦恼众生。罪垢销除身心清净。又于一切诸佛刹土。普兴一切诸供养云。普雨一切华香璎珞衣服幢盖。如是所有诸庄严具。供养于佛。复以神力。随诸众生心之所乐。普于一切诸宫殿中。而现其身。令其见者皆悉欢喜。然后来诣观自在菩萨摩诃萨所。时观自在菩萨。告善财言。善男子。汝见正性无异行菩萨。来此大会道场中不。善财答言。唯然已见。告言善男子。汝可往问。菩萨云何学菩萨行。修菩萨道。尔时善财童子。于观自在菩萨所得甚深智。入大悲门。以甚深心。随顺观察。心无疲厌。一心顶礼观自在菩萨足。绕无数匝。敬承其教。辞退而行

往诣正性无异行菩萨所。顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。菩萨告言。善男子。我得菩萨解脱。名普门不动速疾行。善财白言。圣者。于何佛所。得此解脱。所从来刹。去此几何。发来久如。菩萨告言。善男子。如此境界。甚深难解。一切世间天人阿修罗。沙门。婆罗门等。所不能了。唯诸菩萨最胜精进。具菩萨行。无退无怯。已能亲近诸善知识。善友所摄。诸佛所念。增长善根。志乐清净。得菩萨根。有智慧眼。能闻能持。能解能入。善财白言。唯愿圣者。为我宣说。我当承佛威神之力善知识力。能信能受能解能入。菩萨告言。善男子。我从东方具足吉祥藏世界普吉祥出生佛所。而来此土。善男子。于彼佛所。得此法门。从彼发来。已经不可说不可说佛刹极微尘数劫。一一念中。举不可说不可说佛刹极微尘数步。一一步过不可说不可说佛刹极微尘数世界。一一世界。我皆遍入。以最胜心至其佛所。以妙供具而为供养。及施一切诸众生海。此诸供具。皆是无上心所成。无作法所印。诸如来所忍。诸菩萨所叹。善男子。我又普见彼世界中。一切众生。悉知其心。悉知其根。随其解欲。现身说法。或放光明。或施财宝。种种方便。教化调伏。利乐成熟。无有休息。如从东方。南西北方。四维上下。亦复如是。善男子。我唯得此菩萨普门不动速疾行解脱。能疾周遍到一切处。如诸菩萨摩诃萨。随顺遍行。普于十方无所不至。智慧境界等无差别。善布其身。悉遍法界。至一切道。入一切刹。知一切法。观一切世。平等演说一切法门。深信爱乐一切妙行。同时照曜一切众生。于诸佛所不生分别。于一切处无有障碍。而我云何能知能说彼功德行。善男子。南方有城。名为门主。其中有神。名曰大天。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼菩萨足。绕无数匝。殷勤瞻仰辞退而去

大方广佛华严经卷第十六大方广佛华严经卷第十七

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。入菩萨广大行。正念思惟心无障碍求菩萨智慧境。见菩萨神通事。念菩萨胜功德。被菩萨坚进甲。生菩萨大欢喜。趣菩萨不思议。游菩萨大自在。修菩萨功德地。观菩萨三昧地。住菩萨总持地。具菩萨大愿地。得菩萨辩才地。成菩萨诸力地。渐次前行。至于彼城。寻访大天。今在何所。人咸告言。在此城内。现广大身。处高显座。为众说法。善财闻已。往至其所顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。尔时大天。即于是时。长舒四臂。取四海水。自洗其面。持诸金华。以散善财。而告之言。善男子。甚奇希有。乃能如是求善知识。善男子。一切菩萨。出现世间。最极希有。难可得闻。难可得见。如众生中芬陀利华。于险难处。为归为救。如安隐城。于黑闇处。作大光明。犹如朗日。又如导师。引诸众生。入佛法门。亦如猛将。善能守护一切智城。善男子。菩萨如是难可遇会。唯身语意具足清净。无诸过失。然后乃得见其形相。闻其辩才。于一切时。常现在前。善男子。我已成就菩萨解脱。名为云网。善财白言。圣者。云网解脱境界云何。尔时大天。于善财前。示现种种金聚。银聚琉璃聚。玻璃聚。砗磲聚。码瑙聚。摩尼宝聚。无垢藏宝聚。毗卢遮那宝聚。普现十方宝聚。宝冠聚。宝印聚。宝鬘聚。宝珰聚。宝钏聚。宝锁聚。宝铃聚。宝璎珞聚。宝珠网聚。种种众色摩尼宝聚。种种一切宝庄严聚。种种如意摩尼宝聚。一一积聚皆如大山。又复示现一切华。一切香。一切鬘。一切盖。一切幢。一切幡。一切涂香。一切末香。一切衣服。一切音乐。一切五欲娱乐之具。亦如山积。及现无数百千万亿诸童女众。而彼大天。告善财言。善男子。今恣汝意。可取此物。供养如来。修诸福德。并施一切。摄取众生。显示难舍而能舍故。令其修学檀波罗蜜。善男子。如我为汝示现此物。教汝行施。乃至普为一切众生。悉亦如是。皆令以此布施善根熏习力故。令其息灭不欲行施障胜行心。于佛法僧最胜福田善知识所。恭敬供养。种诸善根。增长善法。发阿耨多罗三藐三菩提心

复次善男子。若有众生贪着五欲自放逸者。为其示现不净境界。何以故。由彼众生愚痴迷惑。被诸女色昏醉其心。犹如婴孩无有自性。亦如素衣易受染色。为欲所溺。不能得出。如粪中虫乐着粪处。如秽弊猪不净严身。如犯罪人种种系缚。如世劫贼恒夺法财。如犯极刑将付魁脍。如瞽导盲俱堕坑险。如船泛海遭遇恶风。损害善根。丧诸法宝。如近恶龙毒气熏染永离戒香。夭伤慧命。以要言之。愚痴婴孩。为欲所盲。为欲所系。为欲所使。为欲所迷。恒顺欲心而为僮仆。常随欲转如犊逐母。为欲所缚不得自在。善男子。我为此等盲瞑众生。生怜愍心。方便济拔。先现端正可爱女身。称悦其心。令其耽着。复现命终。其身坏烂。为诸鸟兽之所啖食。种种不净。如尸陀林。复现恐怖罗刹女形。身状黑云。鬓发丹赤。大腹下垂。狗牙上出。以人髑髅而为严饰。手执利剑。发大恶声。现如是身。向染欲者。令起惊厌。心生惶怖。因斯发起求见我心。我应彼形。为其说法。令除厌怖。安住戒身。成就最胜戒波罗蜜。具足十种波罗蜜门。乃至圆满菩提胜果。尔时大天。即为善财。种种称赞戒波罗蜜。而说偈言

  如诸众生及草木　　一切生长咸依地
  世及出世诸善根　　皆依最胜尸罗地
  无戒欲求生善道　　如鸟无翼欲飞空
  如人无足欲游行　　亦如渡海无船筏
  如诸苦行食根果　　饮水自活住山林
  或衣树皮如兽居　　无戒不得为清净
  有剃四周留顶发　　或不沐发萦为髻
  或有裸形或异服　　此等无戒皆如戏
  或于冰河而洗浴　　或投盛火以焚身
  或升高山自坠形　　此等无戒徒为死
  或浴华池辩才水　　或恒饮浴殑伽河
  昼夜求福以为依　　此等无戒空无果
  或于日夕三时浴　　或复三时作护摩
  却粒自默如哑羊　　无戒苦身无所利
  欲住天宫尽天寿　　服天璎珞以严身
  饮食天中诸上味　　持戒一切皆圆满
  或大族姓旃陀类　　俱能持戒等生天
  贵贱种姓亏戒身　　皆堕地狱无差别
  卑门持戒生天上　　胜族毁犯堕幽冥
  摩登持戒亦生天　　仙人破戒入诸狱
  王族多闻具色力　　恶见无戒如兽蚖
  如甘果树猛兽围　　犹莲华池毒蛇止
  宁守贫贱恒持戒　　具圣财宝德严身
  破戒众人之所轻　　持戒天人咸信重
  栴檀郁金及沉麝　　如是一切不为香
  菩萨持戒最胜香　　遍出人天无有尽
  卑陋持戒后生天　　现蒙王者所瞻礼
  此世他生安隐乐　　如是戒果牟尼说
  欲生人天及涅槃　　如应具戒必当得
  是故精勤持净戒　　随心所愿皆圆满
  若有临终肢节痛　　一切亲属欲分离
  谛思我有清净戒　　身心欢乐无忧畏
  戒为惑病最胜药　　护诸苦厄如父母
  痴闇灯炬生死桥　　无涯业海为船筏
  帝释转轮威德主　　富贵尊严无等伦
  家有仆隶能持戒　　承事供养而亲敬
  若有临至命终时　　持戒破戒生安畏
  欲得当来极乐处　　应当专意勤护持
  戒珠不假刀兵护　　戒为伏藏无所侵
  戒为勇伴导前行　　戒为出世庄严具
  我赞持戒诸功德　　如佛世尊真实说
  为觉悟彼破戒者　　令心坚住持净戒

善男子。如我以此种种方便教化众生。令住净戒波罗蜜中。若有众生。嗔恚憍慢。多诤竞者。我以强力。折伏其心。为其示现极可怖形。如罗刹等饮血啖肉。令其见已。惊恐惶惧。心意和柔舍离怨结。若有众生惛沈懒惰。为其示现王贼水火。及诸重疾。种种危难。令其见已。心生惶惧。知有忧苦。厌离惛惰。而自勉策。日夜精勤。以如是等种种方便。令舍一切诸不善法。修习一切清净善法。令除一切波罗蜜障。令开一切波罗蜜门。令超一切障碍险道。令到一切无障碍处。善男子。我唯得此菩萨云网解脱。如诸菩萨摩诃萨。犹如帝释。已能摧灭一切烦恼阿修罗军。如大海水。普能消灭一切众生诸烦恼火。如劫尽火。普能干竭一切众生诸爱欲水。如大猛风。普能吹碎一切众生诸见取幢。犹如金刚。悉能摧破一切众生诸我见山。而我云何能知能说彼功德行。善男子。此阎浮提摩竭提国菩提场中。有主地神。名自性不动。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼大天足。绕无数匝。一心瞻恋。辞退而行

尔时善财童子。受天神教。渐次前行。往东北方。趣摩竭国菩提树王大道场处。将诣自性不动神所。十千地神同在其中。更相谓言。此来童子。即是一切如来宝藏。必当普为一切众生作所依怙。必当普坏一切众生无明[穀-禾+卵]藏。此人已生法王种中。当以法缯而冠其首。当开智慧大珍宝藏。当执菩萨金刚慧剑。勇猛自在。得法无畏。摧伏一切异道邪论。当以法船。于生死海。运济众生。令达彼岸智解圆满。犹如白月。必当息灭一切众生热恼乱心。尔时自性不动神等。一万地神。即以神力。震动大地。出雷吼声。放大光明。遍照三千大千世界。种种宝物。处处庄严。影洁光流。递相鉴彻。一切叶树。俱时生长。一切华树。咸共开敷。一切果树。靡不成熟。一切河流。互相灌注。一切池沼。悉皆盈满。兴大密云。雨细香雨。遍洒其地。香风时来。吹众名华。普散其上。无数音乐。一时俱奏。出可爱声。天庄严具。咸出美音。令人欢悦。天阿修罗。乃至非人。牛王。象王。师子王等。皆大欢喜踊跃哮吼。犹如大山相击出声。百千伏藏。自然涌现。时彼地神。告善财言。善来童子。汝于此处。曾种善根。我为汝现。汝欲见不。尔时善财。礼地神足。绕无数匝。合掌而立。白言圣者。唯然欲见。时彼地神。以足按地。百千亿阿僧祇摩尼宝藏。自然涌出。开发显现。地神告言。善男子。今此宝藏。随逐汝行。是汝往昔善根果报。是汝福力之所守护。汝应恣意自在而用。善男子。我得菩萨解脱。名难摧伏智慧藏。常以此法。具足圆满。成熟众生

善男子。我忆自从然灯佛来。常随菩萨。恭敬守护。如影随形。从始至今。念念无间。观察菩萨所有心行。普遍寻求。深入菩萨一切誓愿智慧境界。圆满菩萨一切所修诸清净行。思惟菩萨一切三昧随顺明达。安住菩萨一切法门。究竟了知一切心性。圆满一切大自在力。增长一切无能坏法。遍往一切诸佛刹土。普受一切诸如来记。忆持现觉一切智性。转于一切诸佛法轮。广说一切修多罗门。大法光明。普皆照耀。教化调伏一切众生。示现一切诸佛神变。随顺解知。受持忆念。常无忘失。善男子。乃往古世。过须弥山极微尘数劫。有劫名庄严。世界名月幢。佛号妙眼。于彼佛所。最初获得此解脱门。善男子。我从是来。于此法门。若入若出。修习增长。常见诸佛。未曾舍离。始从初得乃至贤劫。于其中间。值遇不可说不可说佛刹极微尘数如来应正等觉。悉皆承事。恭敬供养。亦见彼佛。诣菩提树。坐道场时。现大神通。种种佛事。亦见彼佛所有一切功德善根。善男子。我唯知此难摧伏智慧藏解脱门。如诸菩萨摩诃萨。常能随侍一切诸佛。能持一切佛所说法。入一切佛甚深智慧。念念充遍一切法界。等如来身。生诸佛心。具诸佛法。作诸佛事。心心出生一切诸佛清净法藏。离分别心。常无间断。而我云何。能知能说彼功德行。善男子。此阎浮提摩竭提国恒河北岸。有一大城。名迦毗罗。有主夜神。名曰春和。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。时善财童子。礼地神足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。蒙地神教。一心思惟。忆持菩萨难摧伏智慧藏解脱门。修其三昧。学其轨则。观其游戏。入其智海。悟其甚深。行其胜行。住其大愿。得其智慧。达其平等。如是思惟。渐次前行。北度恒河。向迦毗罗城。至城南门。敬心右绕。从东门入。伫立未久。遇日没时。心念随顺诸菩萨行。渴仰欲见春和夜神。于善知识。生如来想。复作是念。由善知识。得周遍眼。普能明见十方境界。由善知识。得广大解。普能了达一切所缘。由善知识得三昧眼。普能观察一切法门。由善知识得智慧眼。普能明照十方刹海。作是念时。见彼夜神。于虚空中。处众色宝摩尼楼阁香莲华藏宝师子座。身真金色。顶发绀青。眼如广大青莲华叶。形貌端严。见者欢喜。众宝璎珞。以为严饰。身服朱衣。首戴梵冠。一切星宿。炳然在体。于其身上一一毛孔。皆现化度无量无数世界众生。临欲颠坠堕恶道者。悉令免离而得解脱。是诸众生。或生人中。或生天上。或有趣向二乘菩提。或有修行一切智道。如是影像。炳然显现。又彼一一诸毛孔中。示现种种教化方便。成熟众生。或为现身种种形色。或为说法种种言音。或为示现声闻乘道。或为示现独觉乘道。或为示现诸菩萨行。菩萨勇猛。菩萨三昧。菩萨自在。菩萨住处。菩萨观察。菩萨思惟。菩萨神通。菩萨境界。菩萨师子频申。菩萨解脱游戏。如是种种成熟众生。善财童子。见闻此已。心大欢喜。踊跃欣庆。心愿圆满。爱敬尊重。以身投地。礼夜神足。绕无数匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。我心冀望。依善知识威神力故。获诸如来功德法藏。唯愿圣者。与我决定。作依止处。示我趣向一切智道。令我于中修行增进至十力地。时彼夜神。告善财言。善哉善哉。善男子。汝能深心敬善知识。法力圣力入汝身中。令汝勤求不惜身命。一心亲近。乐闻其语。随顺听闻。修行其教。以汝亲近闻教修行决定心故。当得阿耨多罗三藐三菩提善男子。我得菩萨教化调伏破一切众生痴闇法光明解脱门。善男子。我于恶慧众生。起大慈心。于不善业众生。起大悲心。于作善法众生。起于喜心。于善恶二行众生。起不二心。于杂染众生。起令生清净心。于邪行众生。起令生正行心。于劣解众生。起令兴大解心。于懒惰众生。起令生精进心。于乐生死众生。起令舍轮转心。于住二乘道众生。起令住一切智心。善男子。我以得此解脱门故。常与如是心共相应。善男子。我于夜暗人静。鬼神盗贼。诸恶众生。所游行时。密云重雾。恶风暴雨。日月星宿。并皆昏蔽不见色时。见诸众生若入于海。若行于陆。山林旷野。沙碛险难。一切危厄。诸恐怖处。或遭盗贼。或乏资粮。或迷惑方隅。或忘失道路。慞惶忧怖。不能自出。我时即以种种方便而救济之。为海难者。示作船师。鱼王。马王。龟王。象王。阿修罗王。及以海神。捕渔人像。为彼种种海难众生。而作救护。所谓止恶风雨。息大波浪。于洄澓中。及迷方中。引其道路。示其洲岸。令免怖畏。悉得安隐。复作是念。以此善根回施众生。愿令舍离一切诸苦。为在陆地一切众生。于夜闇中。遭诸恐怖。瓦砾荆棘。虎豹豺狼。师子恶兽。毒蛇险路。盗贼鬼神。肆暴之处。现作日月。及诸星宿。晨霞夕电。种种光明。或作屋宅。或为人众天龙八部菩萨如来种种形相。引导覆护。令其得免恐怖之厄。复作是念。以此善根。回施众生。悉令除灭诸烦恼闇。一切众生。有惜寿命。有爱名闻。有贪财宝。有重官位。有着男女。有恋妻妾。眷属稠林。种种缠缚。未称所求。多生忧怖。我皆救济。令其离苦。为行山险而留难者。为作善神现形亲近。为作好鸟发音慰悦。为作灵药舒光照耀。示其果树。示其泉井。示正直道。示平坦地。或现龛室。或现胜居。令其免离一切忧苦。为行旷野险道稠林。毒树藤萝。交蔽隐密。阇努啰兽潜伏伤残。震吼出声。惊骇闻者。堕此难中。种种忧怖。云雾所暗。心识昏迷。种种事中。而恐怖者。现大力身。救其危难。示其正道。令得出离。作是念言。愿一切众生。伐见稠林。截爱罗网。出生死野。灭烦恼暗。入一切智无畏大城。到平坦处。毕竟安乐

善男子。若有众生。战诤城邑。乃至小兽。忿竞无时。我以方便。使其和好。各起慈心。永息乖诤。作是念言。愿一切众生。离烦恼诤。得法和合。善男子。若有众生。乐着国土。角力求取。胜负不安。种种诤讼。而忧苦者。我以方便。令舍坚执。示现无常。令生厌离。作是念言。愿一切众生不着诸蕴。住一切佛萨婆若境。善男子。若有众生。乐着聚落。贪爱宅舍。常处黑暗。甘被系缚。受诸苦者。我为说法。令生厌离。令法满足。令依法住。作是念言。愿一切众生。悉不贪乐六处聚落。速得出离生死境界。究竟安住一切智城。善男子。若有众生。行闇夜中。迷惑十方。于平坦路。生险难想。于险难道。起平坦想。以高为下。以下为高。其心迷惑。生大苦恼。我以方便。舒光照及。若欲出者。示其门户。若欲行者。示其道路。欲济彼岸。示其桥梁。欲涉河海。与其船筏。若于热时。示其清冷。若于寒际。示作温和。暖殿凉宫。随时适意。若或游观。常导其前。示其险易安危之处。欲休息者。示其城邑近处宫室。令其憩止。远行渴乏。示其池沼河水流泉。令其饮沐。华林果树。使得清凉身心安乐。若有父母妻子眷属。恩爱分离。令其合会。无诸苦恼。作是念言。如我于此。照除闇夜。救众灾厄。令诸世事。悉得宣叙。愿我普于一切众生生死长夜。无明闇处。以智慧光。普皆照了。是诸众生无有智眼。想心见倒之所覆翳。无常常想。苦中乐想。无我我想。不净净想。坚固执着我人众生蕴界处法。迷惑因果。不了善恶。杀害众生。乃至邪见不孝父母。不敬沙门及婆罗门。不知恶人。不识善人。贪着恶事。安住邪法。毁谤如来。坏正法轮。于诸菩萨。呰辱伤害。轻大乘道。断菩提心。于有恩人。反加杀害。于无恩处常怀怨结。毁谤贤圣。亲近恶伴。盗塔寺物。作五逆罪。不久当堕三恶道中。愿我速以大智光明。破彼众生无明黑闇。令其疾发阿耨多罗三藐三菩提心。既发心已。示普贤乘。开十力道。亦示如来法王境界。亦示诸佛一切智城。诸佛所行。诸佛自在。诸佛成就。诸佛总持。一切诸佛同共一身。一切诸佛平等之处。皆令安住

善男子。一切众生。或病所缠。或老所侵。或苦贫穷。或遭祸难。或犯王法。临当受刑。无所依怙。生大怖畏。我皆救济。使得安隐。谓以方药除诸病苦。供事老朽。安乐终年。给足资具。令无贫乏。无主作主。无归作归。苦难逼迫。同事救摄。令离忧恼。令无怖惧。复作是念。愿我以法普摄众生。令其解脱一切烦恼。生老病死忧悲苦患。近善知识。常行法施。勤修善业。速得如来清净法身。住于究竟无变易处。善男子。一切众生。入见稠林。住于邪道。于诸境界。起邪分别。常行不善。身语意业。妄作种种诸邪苦行。于非正觉。生正觉想。于正觉所。非正觉想。为诸恶友之所摄持。以起恶见。将堕恶道。我以种种诸方便门。而为救护。令住正见。当生人天复作是念。如我救此将坠恶道诸众生等。愿我普救一切众生。悉令解脱一切诸苦。住波罗蜜出世圣道。于一切智得不退转。具普贤愿。近佛菩提。而不舍离诸菩萨行。常勤教化一切众生。尔时春和主夜神。欲重宣此解脱义。承佛威力。普观十方一切法界。为善财童子。而说偈曰

  我此寂静解脱海　　出生具足智光明
  远离一切愚痴暗　　观众生根而演说
  我于往昔无边劫　　具修广大清净慈
  如日普照于世间　　汝应勇猛勤修习
  我此难量大悲海　　出生三世诸如来
  能救法界苦众生　　汝应勇猛勤修习
  能生圣道无为乐　　亦生世间安隐乐
  令我踊跃心欢喜　　汝应入此甚深门
  已背有为如幻法　　亦弃声闻解脱乘
  常修佛力具庄严　　汝应入此难思教
  我眼清净广无边　　普见十方诸刹土
  其中所有一切佛　　悉坐菩提树王下
  见佛处于大众会　　相好庄严妙色身
  于诸毛孔放光明　　一一光明恒普照
  见诸群生堕业海　　死此生彼各差别
  相续轮回五趣中　　常受种种无边苦
  我耳清净量无边　　一念听周诸刹海
  众生所有语言法　　皆悉忆持无忘失
  及闻诸佛转法轮　　其音胜妙无能比
  言辞训释诸方便　　我悉忆持无忘失
  我鼻广博甚清净　　于诸法中无所著
  住一切处解脱门　　汝应入此无疑惑
  我舌光明赤铜相　　具足清净妙辩才
  巧宣妙法应群心　　汝应入此无疑惑
  我身离相恒清净　　常遍一切诸世间
  普随信乐众生心　　为现色身令得见
  我心离着无诸垢　　如响普应诸众生
  随念悉见诸如来　　而于其中不分别
  不思议刹众生海　　所有乐欲及诸根
  我于一念悉能知　　而于其中不分别
  我以广大妙神通　　普震难思诸佛刹
  威力光明无不现　　调伏一切难调众
  我福广大甚清净　　无量庄严无尽藏
  普能供养诸如来　　等与一切众生乐
  我智广博甚清净　　了达无边诸法海
  普断一切众生疑　　佛子宜应善修学
  我知三世诸佛海　　及了一切诸法海
  亦入彼诸大愿门　　此无等行应修习
  我于三世刹尘中　　悉见十方诸刹海
  亦见其中所有佛　　此是普门无等力
  普于十方一切刹　　悉见大智卢舍那
  一切尘中坐道场　　以寂静音宣妙法

尔时善财童子。白春和主夜神言。汝发阿耨多罗三藐三菩提心。经几时耶。得此解脱其已久如。乃有如是大威德力。能作如是利益众生夜神告言。佛子。我念往古过须弥山极微尘数劫。有劫名寂静光。世界名出生吉祥宝。五百亿佛于中出现。彼世界中。有四天下。名宝月灯光。有城名莲华光。有转轮王。名妙法岸。具足七宝。领四天下。以圣王道。安乐众生。王有夫人。名法智月。妓乐自娱。夜久眠寝。时彼城东。有一大林。名寂静出生妙德。林中有一大菩提树。名一切胜法摩尼王庄严身出生诸佛神力光明。尔时有佛。名一切法大吼声王。于此树下。成等正觉。放无量色广大光明。名摩尼王普照一切妙宝世界。莲华城内。有主夜神。名净月光。诣王夫人法智月所。动身璎珞。环佩出声。以觉夫人。而告之言。夫人当知。一切法大吼声王如来。于寂静出生妙德大林之中。而成等正觉。及广称赞诸佛功德自在神力。普贤菩萨所有行愿。令王夫人发阿耨多罗三藐三菩提心。供养恭敬。承事彼佛。及诸菩萨声闻僧众。善男子。时王夫人法智月者。岂异人乎。我身是也。我于彼佛。发菩提心。深重爱敬。种善根故。于须弥山极微尘数劫。不生地狱饿鬼畜生诸恶趣中。亦不生于下贱之家。诸根具足无有众苦。于天人中福德殊胜。不生恶世。恒不离佛及诸菩萨大善知识。常于其所。种植善根。经八十亿须弥山极微尘数劫。常受安乐。而未满足菩萨诸根。过此劫已。复过万劫。于贤劫前。有劫名无忧遍照。世界名离垢胜德。其世界中。净秽诸杂。有五百佛于中出现。其第一佛。名须弥幢大寂静吉祥眼如来应正等觉。我为名称长者女。字妙慧光明。端正殊妙。人相具足。彼净月夜神。以本愿力。于离垢胜德世界一四天下众色幢王城中。作主夜神。名妙净眼。我于一时。在父母边。夜久眠息。彼妙净眼。来诣我所。震动我宅。放大光明。出现其身。赞佛功德言。彼如来坐菩提树。始成正觉。劝谕于我。及以父母。并诸眷属。令速见佛。自为前导。引至佛所。广兴供养。我才见佛。即得调伏众生见佛三昧。及得普照三世智光明轮三昧。获此三昧故。能忆念须弥山极微尘数劫。亦见其中一切诸佛菩萨出现。于彼如来。及菩萨所。听闻妙法。以闻法故。即得此教化调伏破一切众生痴暗法光明解脱门。得此解脱故。即见其身遍十佛刹极微尘数世界。亦见彼世界所有如来。又见自身一一亲近。亦见彼世界一切众生。解其言音识其根性。知其往昔曾为善友之所摄受。随其所乐而为现身。令生欢喜。我时于彼所得解脱。念念增长。此心无间。又见自身遍往百佛刹极微尘数世界。此心无间。又见自身遍往千佛刹极微尘数世界。此心无间。又见自身遍往百千佛刹极微尘数世界。如是念念。乃至不可说不可说佛刹极微尘数世界。亦见彼世界中一切如来。亦见自身在彼佛所听闻妙法。受持忆念。观察决了。亦知彼佛诸本事海。诸大愿海。彼诸如来严净佛刹。我亦严净。亦见彼世界一切众生。心性根器。形量差别。种类不同。随其所应而为现身教化调伏。令此解脱念此菩萨教化调伏破一切众生痴暗法光明解脱门。如诸菩萨摩诃萨。成就普贤无边行愿。普入一切诸法界海。得诸菩萨金刚智幢自在三昧。游戏神通。心无障碍。出生大愿。住持佛种。于念念中。成满一切大功德海。严净一切广大世界。以自在智。教化成熟一切众生。以智慧日。灭除一切世间闇障。以勇猛智。觉悟一切众生昏睡。以智慧月。决了一切众生疑惑。以清净意。断除一切诸有执着。于一切法界一一尘中。示现一切自在神力。智眼明净等见三世。而我何能知其妙行。说其功德。入其境界。示其自在游戏神通。善男子。此阎浮提恒河南岸摩竭提国菩提场中。有主夜神。名普遍吉祥无垢光。我本从其发阿耨多罗三藐三菩提心。常以妙法开悟于我。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时善财童子。合掌恭敬。向春和夜神。以偈赞曰

  我今见汝清净身　　色相端严如妙德
  威光超世无能比　　殊特犹若宝山王
  见汝清净妙法身　　等于三世无分别
  普入一切诸世间　　若坏若成无所著
  我今普观一切趣　　见汝所现差别身
  犹如星月处虚空　　一毛孔中皆得见
  汝心广大常清净　　如空普遍于十方
  一切诸佛悉入中　　智慧平等无分别
  汝身一一诸毛孔　　放刹尘数光明云
  悉遍十方佛刹中　　普雨一切庄严具
  汝身一一诸毛孔　　等众生数而现身
  普于十方世界中　　方便化度令调伏
  汝身一一诸毛孔　　示现不可思议刹
  普随一切众生心　　庄严显现令清净
  若有众生见汝身　　闻名爱乐生欢喜
  获功德利清净命　　当必成就大菩提
  堕于恶趣无边劫　　恒受种种无量苦
  闻名暂发欢喜心　　诸烦恼业皆销灭
  于千佛刹微尘劫　　赞叹汝身一毛德
  微尘劫数犹可穷　　汝身功德终无尽

尔时善财童子。以此妙偈。赞夜神已。礼夜神足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第十七大方广佛华严经卷第十八

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。一心思惟彼夜神教。了知彼神初发菩提心。圆满清净。所生菩萨藏。所发菩萨愿。所净菩萨波罗蜜。所入菩萨诸住地。所修菩萨行。所行出离道。随顺一切智光海。发普救一切众生心。起大悲云。普覆一切。于诸佛刹。尽未来际。常能出生普贤行愿。渐次游行。诣彼夜神。顶礼其足。绕无数匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何修行菩萨地。云何出生菩萨地。云何成就菩萨地。夜神答言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。复能问于诸菩萨地修行出生及以成就。善男子。菩萨具足十法。则能圆满诸菩萨行。何等为十。一者得清净三昧。常见一切如来现前。二者以清净眼。常观一切如来相好。三者以甚深智。知诸如来福智大海。四者知等法界无量诸佛法光明海。五者知诸如来一一毛孔放等众生数大光明海利益一切。六者见诸如来一一毛孔出众宝色光明焰海。七者念念出现佛变化海。普遍法界调伏众生。八者得佛音声。同诸众生语言音海。能转三世诸佛法轮。九者知一切佛无边名号海。十者知一切佛调伏众生不可思议自在威力。善男子。菩萨具足此十种法。则能圆满诸菩萨行。善男子。我得菩萨解脱。名寂静禅定乐普游步勇猛法门。普见三世一切诸佛。亦见彼佛清净国土道场众会三昧神通相应行海。种种名号。说法寿命。言音身相。种种不同。充满法界。悉皆明见。甚深趣入。而无取着。亦无入处。何以故。知诸如来非去。世趣永灭故。非来。体性无生故。非生。法身平等故。非灭。无有生相故。非实。住如幻法故。非虚。利益众生故。非迁。超过生死故。非坏。性常不变故。一相言语悉离故。无相性相本空故。善男子。我如是知一切如来。时于菩萨寂静禅定乐普游步勇猛解脱门。分别了达。成就增长。思惟观察。坚固庄严。普遍照明种种境界。圆满广大甚深。随顺住平等际。不起一切妄想分别。大悲救护一切众生。一心不动。修习初禅。息诸意业。摄诸众生。智力勇猛。喜心悦怿。修第二禅。思惟一切众生自性。厌离生死。住涅槃乐。修第三禅。悉能息灭一切众生众苦热恼。修第四禅。增长圆满一切智愿。善巧出生诸三昧海。入诸菩萨解脱海门。游戏一切菩萨神通。成就一切清净变化。以清净智。普入法界。善男子。我修习此解脱门时。以种种方便。成熟众生。所谓于在家放逸贪欲众生。令生不净想。不爱乐想。可厌想。疲劳想。逼迫想。系缚想。罗刹想。无常想。苦想。空想。无我想。无主想。不自在想。老病死想。自于欲境。不生爱乐。亦劝众生不着欲乐。唯住法乐。出离于家。入于非家。若有众生。住于空闲。我为止息诸恶音声。于静夜时。为说深法。与顺行缘。开出家门。示正道路。为作光明。除其暗障。灭其怖畏。赞出家业。叹佛法僧及善知识具诸功德。亦劝亲近承事供养善知识行。善男子。我修如是解脱门时。令诸众生离非法贪。舍邪分别。未生恶法令其不生。若已作者皆令止息。妄想境界。所不能转。未生诸善法。未修波罗蜜。未求一切智。未起殊胜愿。未发大慈悲。未造人天业。皆令得生。若已生者令其增长。我与如是顺道因缘。乃至令成一切智智。善男子。我唯得此菩萨寂静禅定乐普游步勇猛解脱门。如诸菩萨摩诃萨。具足普贤所有行愿。了达一切无边法界。常能增长一切善根。照见一切如来智力。住于一切如来境界。恒处生死。心无障碍。疾能满足一切智愿。普能往诣一切刹海。悉能观见一切佛海。遍能听受一切法云。能破一切众生痴闇。能于生死大夜之中。出生一切智慧光明。而我云何能知能说彼功德行。善男子。去此不远。菩提树王道场右面。有主夜神。名喜目观察一切众生。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时普遍吉祥无垢光主夜神。欲重明此解脱门义。为善财童子。而说偈曰

  一切三世诸如来　　皆为信心而出现
  若具清净广大眼　　则能普见诸佛海
  汝观诸佛无垢身　　妙相庄严极清净
  悉坐众会道场中　　示现神通无不遍
  毗卢遮那善逝尊　　道树降魔成正觉
  普随一切众生心　　转大法轮充法界
  佛证甚深真法性　　妙体寂静无差别
  色身清净具庄严　　普示众生无有尽
  佛身广大不思议　　遍周法界常无尽
  平等普现于十方　　一切刹中无不见
  诸佛圆光常遍满　　普照一切微尘刹
  互相照现色无边　　一一周圆充法界
  如来毛孔出光云　　广大难思无有尽
  普照一切众生心　　令其烦恼皆除灭
  如来毛孔出化云　　一一神通无有量
  调伏一切诸众生　　所有众苦皆除灭
  如来广大圆满音　　声光所出言辞海
  雨大法雨遍群生　　令其普觉菩提性
  佛昔无边劫海中　　为摄受我修诸行
  令我今得见如来　　影现十方诸刹海
  如来出现诸世间　　量等一切众生数
  境界甚深难趣入　　彼非我智所能知
  具大威德诸菩萨　　入于善逝一毛中
  彼解脱境叵思议　　非我能知诸佛智
  于此近处有夜天　　名星宿光大喜目
  汝应往问所修行　　彼当授汝菩提道

时善财童子。礼夜天足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。敬顺善知识教。奉行善知识语。作如是念。善知识者。难见难遇。见善知识。令心作意无有散乱。见善知识。能破烦恼大障碍山。见善知识。能入大悲救众生海。见善知识。得智慧光普照法界。见善知识。悉能修行一切智道。见善知识。普能睹见十方佛海。见善知识。得见诸佛转正法轮。忆持不忘。作是念已。发意欲诣喜目观察一切众生夜神所。时喜目神。以威神力。加善财童子。令知亲近善知识。能生善根。增长成熟。所谓令知亲近善知识能修助道具。令知亲近善知识能起勇猛心。令知亲近善知识能作难坏业。令知亲近善知识能得坚固力。令知亲近善知识能入无边方。令知亲近善知识能久远修行。令知亲近善知识能辨无边业。令知亲近善知识能行无量道。令知亲近善知识能得速疾力普诣诸刹。令知亲近善知识能不离本处遍至十方。时善财童子。遽发是念。由亲近善知识。能勇猛勤修一切智道由亲近善知识。能速疾出生诸大愿海。由亲近善知识。能为利乐一切众生。尽未来劫受无边苦。由亲近善知识。能被勇猛精进甲。于一极微中说法声遍法界。由亲近善知识。能速往诣遍十方海。由亲近善知识。于一毛道尽未来劫修菩萨行。由亲近善知识。于念念中。行菩萨行。究竟安住一切智地。由亲近善知识。能入三世一切如来自在神力诸庄严道。由亲近善知识。常缘法界未曾动出。而能遍往无边国土。由亲近善知识。能常遍入净法界门。离去来想。遍往十方

尔时善财童子。发是念已。即诣喜目夜神所。见彼夜神。在于如来众会道场。坐莲华藏师子之座。入大速疾普喜幢无垢解脱门。于其身上一一毛孔。出无量种变化身云。随其所应。以妙言音而为说法。普摄无量一切众生皆令欢喜。而得利益。所谓出无量化身云充满十方一切世界。说诸菩萨行檀波罗蜜。于一切事。皆无恋着。于一切众生。普皆施与。法界一相。其心平等。供养承事。无有轻慢。内外悉施。难舍能舍

又从一一毛孔。出等众生数无量化身云。充满法界。普现一切诸众生前。说持净戒。无有缺犯。修诸苦行。皆悉圆满。于诸世间。无有所依。于诸境界。无所爱着。说在生死轮回往返。说诸人天盛衰苦乐。说诸境界皆是不净。说有为法皆是无常。说诸有漏悉苦无味。说一切法空无有我。令诸众生舍离想心妄见颠倒。住如来境。了不思议。常乐我净。究竟真实持如来戒。如是演说种种戒行。戒香普熏。令诸众生悉得成熟

又从一一毛孔。出等众生数种种身云。说能忍受一切众苦。所谓割截捶楚。诃骂轻辱。其心泰然。无有忿恚。安受谛思。不动不乱。于一切行不卑不高。于诸众生不起我慢。于诸法性审谛观察。说菩提心。无有穷尽。心无尽故。智亦无尽。普断一切众生烦恼。说诸众生卑贱丑陋。形相鄙恶。不具足身。令生厌离。方便除灭。如是等因。赞诸如来清净妙色无上之身。令生欣乐。如是方便。成熟众生又从一一毛孔。出等众生数种种身云。随诸众生心之所乐。说勇猛精进。修一切智助道之法。勇猛精进。摧伏魔怨。勇猛精进。发菩提心不动不退。勇猛精进。度诸众生出生死海。勇猛精进。除灭一切恶道诸难。勇猛精进。以智慧力坏无智山。勇猛精进。供养承事一切如来心无疲厌。勇猛精进。受持一切诸佛法轮常不忘失。勇猛精进。坏散一切诸重烦恼大障碍山。勇猛精进。教化成熟一切众生勇猛精进。严净一切诸佛刹土。如是方便成熟众生

又从一一毛孔。出等众生数无量身云。以种种方便。令诸众生除灭愁叹忧悲苦恼。心生欢喜。舍离恶意。厌一切欲。为说惭愧。令诸众生藏护诸根。为说无上清净梵行。为说诸欲是魔境界。令生恐怖。为现不乐世间欲乐。住法园苑。受诸法乐。随其次第。入深禅定诸三昧乐。令思惟观察。除灭一切所有烦恼。赞叹心性。显示无生。又为演说一切菩萨诸三昧海。神力变现。自在游戏。令诸众生欢喜适悦。离诸惑怖。其心清净。心性调柔。堪任受用诸根明利。爱重于法。修习增长。以是方便。成熟众生

又从一一毛孔。出等众生数种种身云。为说往诣一切佛刹。亲近承事。供养诸佛及以师长真善知识。受持一切诸佛法轮。精勤不懈。又为演说称赞一切诸如来海。观察一切诸法门海。显示一切诸法性相。开阐一切诸三昧门。照智慧境界。枯竭一切众生疑海示金刚智。坏邪见山。升慧日轮。破诸痴暗。皆令欢喜。成一切智

又从一一毛孔。出等众生数种种身云。现种种色相。种种形貌。不思议身。普诣一切诸众生前。随其所应。以种种言辞。辩才训释。而为说法。或说世间神通福力。或说三界皆是可怖。令其不作世间业行。离三界处。出见稠林。或为称赞一切智道。令其超越一切声闻辟支佛地。或为演说不住生死。不住涅槃。令其不著有为无为。于敬于慢。心无忧喜。或为演说住于天宫。乃至道场。成等正觉。令其欣乐发菩提意。显示如是方便善巧波罗蜜门。教化成熟一切众生。皆令究竟得一切智

又从一一毛孔。出一切世界极微尘数种种身云。普现一切诸众生前。于念念中。示普贤菩萨。一切行愿。于念念中。示清净大愿充满法界。于念念中。示严净一切世界海。于念念中。示供养一切如来海。于念念中。示入一切法门海。于念念中。示入一切刹海极微尘数诸世界海。于念念中。示于一切刹尽未来劫清净修行一切智道。于念念中。示入十方一切如来力。于念念中。示入三世一切方便海。于念念中。示往一切刹现种种神通变化自在。于念念中。示一切菩萨种种行愿。显示如是愿波罗蜜。令诸众生住一切智。如是所作。恒无休息

又从一一毛孔。出等一切众生种种心数变化身云。普诣一切诸众生前。说诸菩萨集一切智助道之法。无边际力。不破坏力。无穷尽力。修无上行不退转力。无间断力。于生死法。无染着力。能破一切诸魔军力。远离一切烦恼垢力。能破一切业障山力。住一切劫修大悲行无疲倦力。震动一切诸佛刹土令诸众生生欢喜力。普于世间转法轮力。以如是等力波罗蜜。方便成熟。令诸众生。至一切智

又从一一毛孔。出等一切众生种种心数种种色相变化身云。普诣十方无量世界。随众生心。演说一切菩萨智行。所谓说入一切众生界海智。说入一切众生心海智。说入一切众生根海智。说入一切众生行海智。说度一切众生成熟调伏未曾失时智。说出一切法界音声智。说念念遍一切法界海智。说念念知一切世界海灭坏智。说念念知一切世界海成住庄严形相差别智。说念念神通自在亲近供养一切如来听受法轮智。显示如是智波罗蜜。令诸众生。皆大欢喜。调畅适悦。其心寂静。生决定解。求一切智。无有退转。如说菩萨诸波罗蜜。种种调伏成熟众生。于种种时。随种种心。知种种根。令其明利有所堪任。能生爱乐深信解力。于一切智究竟圆满。如是宣说一切菩萨种种行法。而为利益。成熟众生。亦复如是

又于一一毛孔。现彼夜神从初发心所集功德。所谓承事诸善知识。亲近诸佛。修习善法。行施波罗蜜。难舍能舍。行戒波罗蜜。弃舍王位。富贵自在。宫殿眷属。以增胜心。出家学道。行忍波罗蜜。能忍世间一切难行。种种苦事。及以菩萨圆满清净。所修苦行。所持正法。皆悉坚牢。其心不动。亦能忍受。一切众生。于己身心。恶作恶说。忍一切业。皆不失坏。忍一切法。深信决定。生正解心。忍诸法性。能谛思惟。无有分别。行精进波罗蜜。起一切智行。成一切佛法。普遍成熟。而无退转。行禅波罗蜜。满足清净。其禅波罗蜜所有资具。所有勤求。所有修行。所有成就。所有清净。所有圆满。所起三昧神通。所入三昧海门。皆悉显示。行般若波罗蜜。心无取着。其般若波罗蜜所有资具。所有清净大智慧日。大智慧云。大智慧藏。大智慧海。大智慧行。大智慧门。皆悉显示。复示修行方便善巧波罗蜜门。其方便波罗蜜所有资具。所有修行。所有体性。所有理趣。所有清净。所有相应事。皆悉显示。行愿波罗蜜。其愿波罗蜜。所有体性。所有成就。所有修习。所有相应事。皆悉显示。行力波罗蜜。其力波罗蜜所有资具。所有因缘。所有理趣。所有演说。所有相应事。皆悉显示。行智波罗蜜。其智波罗蜜所有资具。所有体性。所有修行。所有成就。所有出生。所有清净。所有处所。所有增长。所有深入。所有光明。所有显示。所有理趣。所有相应事。所有能拣择。所有诸行相。所有相应法。所有所摄法。所知法。所知业。所知刹。所知劫。所知世。所知佛出现。所知佛。所知菩萨。所知菩萨心。菩萨位。菩萨资具。菩萨发趣。菩萨回向。菩萨所行。菩萨大愿。菩萨法轮。菩萨拣择。菩萨法海。菩萨法门海。菩萨法漩流。菩萨法伏藏。菩萨法理趣。如是等智波罗蜜相应境界。皆悉显示。从彼夜神一一毛孔。皆悉具足。显现如是十波罗蜜。教化成熟一切众生

尔时善财童子。见喜目观察一切众生主夜神。复于一一诸毛孔中。出兴无量众生形相相似身云。所谓出兴色究竟天。善现天。善见天。无热天。无烦天。相似身云。如是出兴广果福生无云天相似身云。出兴遍净无量净少净天相似身云。出兴极光净无量光少光天相似身云。出兴大梵梵辅梵众天相似身云。出兴他化自在天化乐天兜率陀天须夜摩天忉利天如是天王及天采女诸天子众相似身云。出兴提头赖吒乾闼婆王乾闼婆子乾闼婆女相似身云出兴毗楼勒叉鸠槃茶王鸠槃茶子鸠槃茶女相似身云。出兴毗楼博叉龙王龙子龙女相似身云。出兴毗沙门夜叉王夜叉子夜叉女相似身云。出兴大树紧那罗王紧那罗子紧那罗女相似身云。出兴妙智摩睺罗伽王摩睺罗伽子摩睺罗伽女相似身云。出兴大势速疾力迦楼罗王迦楼罗子迦楼罗女相似身云。出兴罗睺阿修罗王阿修罗子阿修罗女相似身云。出兴阎罗法王阎罗王子阎罗王女相似身云。出兴世间一切人王及王夫人王子王女相似身云。出如是等一切种类诸趣身云。出兴一切声闻独觉一切菩萨及诸佛众相似身云。出兴一切地神。水神。火神。风神。河神。海神。山神。林神。主稼神。主药神。主树神。主地神。主城神。主昼神。主夜神。主空神。主方神。身众神。足行神。主道场神。乃至执金刚神等相似身云。周遍十方。充满法界。于彼一切诸众生前。现种种声。所谓风轮声。水轮声。火焰声。海潮声。地震声。大山相击声。天城震动声。摩尼相击声。天王声。龙王声。夜叉王声。乾闼婆王声。阿修罗王声。迦楼罗王声。紧那罗王声。摩睺罗伽王声。人王声。梵王声。天女歌咏声。诸天音乐声。摩尼宝王声。声闻声。独觉声。菩萨声。以如是等种种音声。宣说喜目观察众生主夜神从初发心所集功德相续次第。所习善根相续次第。发菩提心相续次第。所修无量诸波罗蜜相续次第。死此生彼及其名号相续次第。亲近善友承事诸佛相续次第。听诸如来种种法轮相续次第。受持正法相续次第。修菩萨行相续次第。入诸三昧相续次第。以三昧力普见诸佛相续次第。普见诸刹相续次第。普知诸劫相续次第。深入法界相续次第。观察众生相续次第。入法教海相续次第。知诸众生死此生彼相续次第。得净天耳。闻一切声种种辩才随顺思惟相续次第。得净天眼。见一切色种种形相善巧观察相续次第。得他心智。知众生心。相续次第。得宿住智知前际事相续次第。得不思议无依无作神足智通自在游行遍十方刹相续次第。得菩萨差别解脱。入菩萨不可思议解脱教海。住菩萨三昧神通。得菩萨勇猛游步。住菩萨心想。为菩萨眷属。入菩萨道场。如是一切所有功德相续次第。皆悉演说。分别显示。成熟众生。如是说时。于念念中。十方各严净不可说不可说诸佛刹土度脱无量恶趣众生。令无量众生。生天人中。富贵自在。令无量众生。出生死海。令无量众生。安住声闻辟支佛地。令无量众生。得菩萨法门。令无量众生。住如来智地

大方广佛华严经卷第十八大方广佛华严经卷第十九

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。见闻如上所现一切众希有事。念念观察。思惟解了。随顺修行深入安住平等成就。承佛威力及解脱力。得菩萨不可思议大速疾力普喜幢无垢解脱门。何以故。与彼夜神。于往昔时。同修行故。如来威力所加持故。不思议善根所祐助故。得菩萨诸根故。生如来种中故。得善友力所摄受故。受诸如来所护念故。毗卢遮那如来曾所化故。彼分善根已成熟故。堪修普贤菩萨行故。尔时善财童子。得此解脱已。心生欢喜。十方如来威神力故。合掌向喜目观察夜神。以偈赞曰

  天于无量大劫中　　善学诸佛甚深法
  普随一切众生类　　显现色身无所著
  了知沉溺诸众生　　无主无亲婴妄想
  为现神通种种身　　宣示正法令调伏
  法身寂静恒无二　　无依无著无分别
  为化众生普现身　　演说正法令调伏
  仁于诸蕴及界处　　了法皆空无所著
  示现色相庄严身　　演说正法令调伏
  不着内外一切法　　已出无边生死海
  欲拔众生离有无　　现同类身无不遍
  仁心能于一切境　　永离诸欲及分别
  普为痴暗诸众生　　显自觉法令调伏
  仁心能住于三昧　　经于多劫恒不动
  于身毛孔出化云　　为供十方诸善逝
  汝入如来十力门　　念念方便无边际
  随应化现各不同　　普摄一切诸群品
  汝审谛观诸有海　　种种业力具庄严
  于无障碍道法中　　为说令心得清净
  汝身色相如普贤　　清净庄严妙无比
  随诸众生种种欲　　普能显示于世间

尔时善财童子以此妙偈。赞夜神已。白言圣天。汝发阿耨多罗三藐三菩提心。其已久如。得此解脱。为几时耶。尔时夜天。以偈答曰

  我念过去经多劫　　过于佛刹微尘数
  刹号摩尼安乐光　　劫名寂静大音声
  刹中所有四天下　　百千俱胝那由他
  其中有一四天下　　名摩尼山众色光
  其中所有广大城　　百千万亿那由他
  于中有一王都城　　名众香光摩尼幢
  具足妙宝所庄严　　人天见者皆欣悦
  彼时有一转轮王　　名广大身为世主
  三十二相皆圆满　　种种随好以严身
  真金妙色光明聚　　清净莲华之所生
  腾空自在放身光　　其光普及阎浮界
  其转轮王有千子　　威势勇猛相端严
  良臣辅佐一俱胝　　智慧多闻咸具足
  后妃嫔御有十亿　　皆如天女悦人心
  能随王意性调柔　　恒起慈心而给侍
  时王以法利群生　　正法宣流四天下
  铁围大地皆臣属　　富乐丰饶人庶欢
  我时与王为宝女　　言辞具足梵音声
  身光照及千由旬　　光如无垢真金色
  有时日光既已没　　所奏音乐咸寂然
  大王及我诸妃嫔　　一切无不皆安寝
  彼时有佛出世间　　号曰吉祥功德海
  显现无量神通力　　普遍十方诸世界
  复出无量光明海　　等一切刹微尘数
  示现种种自在身　　遍满十方无有尽
  大地诸山皆震动　　发声普告佛出兴
  天人龙众阿修罗　　闻佛出世皆欢喜
  复从一一毛孔中　　出佛化身神变海
  十方世界皆充满　　随众生心说妙法
  我时于彼夜梦中　　见佛种种诸神变
  亦闻演说甚深法　　爱乐喜叹未曾有
  时有十千主夜神　　在王宫上空中住
  同时赞佛诸功德　　以妙言音觉悟我
  胜智贤后汝应起　　佛已出兴于汝国
  百千劫海难值遇　　见者利乐皆清净
  我时寝寤心欣敬　　即睹清净妙光明
  观此光相从何来　　见佛坐于树王下
  三十二相庄严体　　妙色出过宝山王
  复于一切毛孔中　　普放广大光明海
  我时见已生欢喜　　即发广大希有心
  愿我亦当如世尊　　具足广大神通力
  我于是时寻觉悟　　大王妃嫔诸眷属
  咸令见佛大光明　　一切身心皆庆悦
  我时与彼转轮王　　四兵千亿同围绕
  及与无量诸众生　　俱行共诣如来所
  我时经于二万岁　　一心供养彼如来
  七宝大地四天下　　敬心奉施曾无倦
  时彼如来为我说　　修多罗海功德云
  以佛威力应群心　　发起庄严诸愿海
  彼时夜神觉悟我　　令我见佛心增益
  我时愿得如是身　　觉悟一切诸放逸
  我从于此初发心　　愿趣无上菩提道
  往来生死诸有海　　能灭众苦心无失
  此后常以深信心　　供佛十亿那由他
  恒受人天安隐乐　　饶益一切诸群生
  初佛号名吉祥海　　二名功德无尽灯
  第三佛号妙宝幢　　第四佛号虚空慧
  第五佛号拘苏摩　　第六智月无所著
  第七法月光明王　　第八智轮光普照
  第九如来两足尊　　号为宝焰山灯光
  第十调御天人师　　名曰三世大光音
  如是十亿那由他　　我皆供养心欢喜
  然犹未得智慧眼　　入此甚深解脱海
  从此次第复有刹　　名一切佛宝光明
  其劫名为天吉祥　　五百如来出兴世
  初佛月轮圆满光　　第二佛名为日灯
  第三佛号星宿幢　　第四佛名妙宝峰
  五华焰光六海灯　　七焰吉祥八天德
  第九法王号光幢　　第十普智光明王
  如是五百诸如来　　一一我皆曾供养
  尚于我爱阿赖耶　　不知无依计为有
  从此次第复有劫　　名众妙色梵光明
  世界具足宝庄严　　名胜吉祥华灯云
  彼中无量佛出兴　　一一我皆曾供养
  亦供如来大众会　　恭敬听法心欢喜
  初佛号曰宝须弥　　二名光明功德海
  三名法界妙音幢　　四号法海大声王
  五法幢佛六威严　　七法力光八空智
  第九法焰须弥光　　第十佛名云吉祥
  如是上首等诸佛　　一一我皆亲供养
  未能明了深法性　　而得入于诸佛海
  此后次第复有劫　　其劫名为月吉祥
  当于彼时有佛刹　　号曰日灯吉祥幢
  彼时有佛出于世　　其数八十那由他
  广陈一切庄严具　　皆以深心而敬奉
  最初甘露味王佛　　第二佛名大树王
  三名功德须弥峰　　四名平等妙宝眼
  五光遍照六光严　　七法海佛八胜力
  九名世主威力贤　　第十一切法光王
  如是上首等诸佛　　我悉供养咸亲近
  然犹未获深妙智　　能入甚深诸法海
  此后无间复有劫　　名为寂静智威力
  其刹名曰普光云　　金刚坚固摩尼宝
  无数庄严具众色　　于中千佛出兴世
  众生多净少烦恼　　离垢众会具庄严
  最初佛号金刚脐　　第二受持无著力
  第三法界影像佛　　四普光照十方王
  第五大悲威德佛　　第六名为苦行海
  第七忍辱圆满灯　　第八觉法圆满光
  第九佛号海庄严　　最后寂静光王佛
  如是上首等千佛　　我悉一一曾供养
  然于法性未深悟　　平等如空性清净
  及遍游行一切刹　　而于彼刹修诸行
  次第无间复有劫　　其劫名为妙出生
  刹号香灯云吉祥　　于中净秽恒相杂
  于中亿佛出兴世　　彼刹及劫妙庄严
  彼佛所说妙法轮　　我以念力皆能受
  初无垢称二法海　　第三佛号云吉祥
  四名法主五德云　　六名法山须弥冠
  第七智焰威德佛　　第八虚空大声佛
  第九复有两足尊　　名普出生殊胜灯
  最后第十无上士　　号眉间光智吉祥
  供彼一切人中尊　　未能净治无碍道
  次第无间复有劫　　名集坚固妙高王
  刹号宝峰胜顶幢　　上妙杂宝为严饰
  有五百佛于中现　　色身遍满胜庄严
  供彼一切自觉尊　　求此甚深真解脱
  第一功德圆满佛　　二寂静音三海山
  四威德佛五山王　　六须弥相大云声
  七法自在八功德　　九福须弥十寂光
  此等上首五百佛　　我皆次第兴供养
  彼佛所有真净道　　我皆普入尽无余
  然未能于佛法中　　成就甚深平等忍
  次第无间复有劫　　名为安乐庄严光
  刹号寂音璎珞智　　众生清净少烦恼
  于中所有诸佛现　　其数八十那由他
  我悉供彼人中尊　　修佛最胜清净道
  初佛华聚拘苏摩　　二海藏佛三德生
  第四佛号天王髻　　第五摩尼胜藏王
  第六佛名真金山　　第七佛号宝聚尊
  第八法幢九财胜　　最后名为智慧王
  如是上首天人主　　我皆供养无不尽
  此后次第复有劫　　其劫名为千吉祥
  刹号妙灯变化幢　　亿那由他佛出现
  最初佛名寂静幢　　第二佛号奢摩他
  第三寂静百灯云　　第四世尊吉祥王
  第五佛号最胜王　　第六佛名如云行
  第七如来日威德　　第八胜法须弥灯
  九名天焰妙吉祥　　十师子吼智慧灯
  如是上首诸善逝　　我悉供养无空过
  然犹未得清净忍　　入彼甚深诸法海
  此后次第复有劫　　名为无著遍庄严
  当于彼时有世界　　名无边光普吉祥
  其中诸佛出兴世　　三十六亿那由他
  初佛名普功德云　　第二无间虚空心
  三佛妙生具庄严　　四名法海大吼声
  第五法界大音声　　六妙变化功德山
  第七普方威德尊　　第八出生法海声
  第九海灯功德山　　第十随顺智日王
  彼所出现诸如来　　我皆供养心欢喜
  最后有佛出兴世　　名宝吉祥功德幢
  我为天后名月面　　供养于彼人中尊
  时佛为我说契经　　名无依着庄严门
  成就出生诸愿海　　我以念力皆受持
  获得广大清净眼　　寂静总持三昧力
  恒于相续念念中　　悉见十方诸佛海
  得彼诸佛大悲藏　　及普方便大慈门
  增长如空大智心　　成就无量如来力
  见诸众生颠倒心　　坚执常乐我净想
  黑暗愚痴云所迷　　惑乱妄起诸烦恼
  行止恒游邪见林　　来往入于贪欲海
  积集种种轮回业　　堕落种种诸苦趣
  一切众生诸趣中　　各随其业而受身
  生老病死所逼迫　　身心恒受无边苦
  为欲安乐彼众生　　发起最胜菩提志
  愿如十方一切刹　　所有出现十力尊
  为求成佛利众生　　起大愿云周法界
  从是具修功德聚　　趣入佛道总持门
  发起广大行愿云　　速疾普入无生道
  具足广大波罗蜜　　法界出生无不遍
  速疾普入于诸地　　亦入三世方便海
  一念普修一切佛　　所有地度无碍行
  我时得为佛长子　　得入普贤深行愿
  了十法界差别门　　通达甚深诸佛教

善男子。于汝意云何。彼时转轮圣王名十方主能建正法绍继佛种。使不断者。岂异人乎。文殊师利童子是也。尔时夜神。觉悟我者。普贤菩萨之所化耳。善男子。我于彼时。为王宝女。蒙彼夜神觉悟于我。令我见佛。发阿耨多罗三藐三菩提心。从是以来。经佛刹极微尘数劫。未曾生于恶道之中。常生人天。恒得自在。于一切处。不舍见佛。其心坚固。乃至于功德幢宝吉祥灯佛所。得此菩萨大速疾力普喜幢无垢解脱。以此解脱。能得如是功德严身。种种供养。亲近诸佛。及善知识。成熟调伏。利益众生。令修妙行。善男子。我唯知此大速疾力普喜幢无垢解脱门。如诸菩萨摩诃萨。于念念中普诣一切诸如来所。速疾趣入一切智海。于念念中。以发趣门。入于一。切诸大愿海。于念念中。以愿海门。尽未来劫。念念出生一切诸行。一一行中。变化出生一切佛刹极微尘数身。一一身遍入一切法界门。一一法界门。一切佛刹中。应众生心。说诸妙行。一切佛刹一一尘中。悉见无边诸如来海。一一如来所悉见。遍法界诸佛神通游戏自在。一一如来所悉见。往劫修诸菩萨种种妙行。一一如来所受持守护。所有法轮常不忘失。悉见三世一切如来种种神变方便教海。而我云何能知能说彼功德行。善男子。于此如来大众会中。有主夜神。名普救护一切众生威德吉祥。汝诣彼问。菩萨云何入菩萨行。圆满清净诸菩萨道。时善财童子。礼夜神足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。从喜目夜神所。闻普喜幢解脱。深信趣入。随顺观察。念善知识所有教诲。心无暂舍。作意思惟。诸根不散。一心愿得遇善知识。普于十方。勤求匪懈。愿常亲近诸善知识。生诸功德。于善知识。承事供养。常令欢喜。与善知识所有善根。同一体性。得善知识巧方便行。无能破坏。依善知识。速疾增长。入精进海。与善知识。随顺共住。常不远离。作是愿已。往诣普救众生威德神所。时彼夜神。即为善财。示现菩萨调伏众生解脱神力。以诸相好。庄严其身。即于眉间。放大光明。名普智焰无垢星宿幢。无量光明以为眷属。其光普照一切世间。照世间已。入善财顶。充满其身。善财即时。得极清净圆满三昧。得三昧已。悉见喜目普救二神两处中间。所有一切地尘水尘。及以火尘金刚摩尼众宝。微尘华香。璎珞诸庄严具。如是一切所有极微一一尘中。各见佛刹极微尘数世界成坏。及见一切地水火风诸大积聚。亦见一切世界连接。皆以地轮任持而住种种形像。种种眷属种种山海。种种河池。种种树林。种种宫殿。所谓天宫殿龙宫殿。夜叉宫殿。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。宫殿屋宅。种种庄严。地狱畜生阎罗王界。一切住处。诸趣轮转。生死往来。随业受报。各各差别。普遍出生不相杂乱。靡不知见。善财又见一切世界种种差别。所谓或有世界杂秽。或有世界清净。或有世界趣杂秽。或有世界趣清净。或有世界杂秽清净。或有世界清净杂秽。或有世界其形平正。或有世界随心想住。或有覆住。或有侧住。如是世界。一切趣类。一切生中。皆悉见此普救众生威德夜神。于一切时。遍一切处。随诸众生。如是寿量。如是信乐。形貌言辞。行解差别。以方便力。普现其前。随宜调伏。而成熟之。令地狱众生免诸苦毒。令畜生众生不相食啖。令阎罗界饿鬼众生无有饥渴。令诸龙等离一切怖。令欲界众生离欲界怖。令人趣众生离暗夜怖。毁訾怖。恶名怖。大众怖。不活怖。死怖。恶道怖。断善根怖。退菩提心怖。遇恶知识怖。离善知识怖。堕二乘地怖。种种生死怖。异类众生同住怖。恶时受生怖。恶种族中受生怖。造恶业怖。业烦恼障怖。执着诸相种种系缚怖。如是等怖。悉令舍离回向菩提。善财又见一切众生。卵生胎生。湿生化生。有色无色。有想无想。非有想。非无想。普现其前。常勤救护。为成就菩萨大愿力故。深入菩萨三昧力故。坚固菩萨神通力故。出生普贤行愿力故。增广菩萨大悲海故。得普覆众生无碍大慈故。得普与众生无量喜乐故。得普摄众生智慧方便故。得菩萨解脱自在神通故。严净一切诸佛刹故。觉悟了知一切法故。承事供养一切佛故。受持一切诸佛教故。积集一切胜善根故。修诸菩萨诸妙行故。入众生心无障碍故。知众生根能成熟故。净一切众生信解海故。破一切众生无知闇故。得一切智清净光明故。尔时善财童子。见普救众生威德夜神。入调伏一切众生解脱门。现不思议甚深境界神通力已。心大欢喜。踊跃无量。头面作礼。一心瞻仰。时彼夜神。即舍菩萨种种相好妙庄严身。还复本形。而不舍其神通变化自在威力。尔时善财童子。恭敬合掌。却住一面。观察夜神。以偈赞曰

  我见仁尊今所现　　如是广大神通力
  令我发生欢喜心　　即说妙偈而称赞
  我见圣者广大身　　殊胜妙宝庄严色
  譬如星月处空中　　难思相好皆微妙
  身放清净光明轮　　量等无边刹尘数
  种种色相皆殊妙　　普照十方无不遍
  于仁一一毛孔出　　等诸众生心数光
  光中佛坐宝莲华　　化现能灭众生苦
  光中复出妙香云　　普熏一切众生类
  复能普雨众妙华　　普供十方一切佛
  眉放广大光明聚　　宝光无垢等须弥
  普照十方世界中　　触者令灭愚痴暗
  口常普放无垢光　　光轮广大如千日
  普照十方诸世界　　毗卢遮那所行境
  眼放无垢光明云　　光明晃耀如星月
  普照一切十方刹　　灭除三有诸痴翳
  仁所化现种种身　　其身相状等众生
  充满十方法界中　　调伏无量众生海
  分身普往遍十方　　悉现一切众生前
  灭除王贼水火怖　　令心调伏生欢喜
  我承喜眼天神教　　念尊功德来奉事
  见尊毫相放光云　　圆明广大无诸垢
  此光普照于十方　　悉灭众生烦恼暗
  显现种种神通力　　然后而来入我身
  我时遇此圆满光　　身心安乐生欢喜
  得百总持三昧海　　普见十方善逝尊
  我于所有经行处　　悉见一切极微尘
  于彼一一极微中　　各见佛刹如尘数
  或有尘中无数刹　　一向杂染恒浊秽
  众生无救受诸苦　　发声悲叹常号泣
  或有诸刹染净杂　　众生少乐多忧苦
  现佛独觉声闻形　　大悲往彼而救度
  有刹先净后杂染　　男女端严皆可乐
  菩萨充满具庄严　　住持无量诸佛法
  十方一一极微中　　皆有无量净刹海
  毗卢遮那于往昔　　普修行海所庄严
  佛于十方一切刹　　悉坐最胜菩提场
  成等正觉现神通　　说法调伏群生类
  我见普救威德天　　其身普往无边刹
  毗卢遮那境界中　　供事十方一切佛

尔时善财童子。说此偈已。白普救众生威德神言。希有圣者。乃能住此甚深解脱。得此解脱。其已久如。本修何行。而能清净。夜神告言。善男子。此处难知。一切世间天人二乘所不能测。何以故。此是住普贤菩萨行者境界故。随顺大悲藏者境界故。救护一切众生者境界故。能净一切三恶八难者境界故。能以无上清净庄严一切佛刹者境界故。能于一切诸佛刹中绍继佛种不断者境界故。能持一切诸佛正法者境界故。能于一切劫修菩萨行成满大愿海者境界故。能于一切法界海以清净智光灭无明闇障者境界故。能以一念智慧光明普照一切三世方便海者境界故。我当承佛威力。为汝宣说。善男子。乃往古世过佛刹极微尘数劫。尔时有劫。名无垢圆满。世界名毗卢遮那威德吉祥。有须弥山极微尘数如来。于中出现。其佛世界。以一切香王摩尼宝金刚为体。以天龙宫殿众宝庄严。住无垢光明摩尼王海上。其形正圆清净无垢。一切璎珞严具帐云。而覆其上。一切庄严摩尼轮山千匝围绕。十万亿那由他四天下皆妙庄严。或有四天下。恶业众生。于中止住。或有四天下。杂业众生。于中止住。或有四天下。善根众生。于中止住。或有四天下。一向清净。诸大菩萨之所止住善男子。彼界东际轮围山侧。有四天下。名宝灯华幢。国界清净。安隐丰乐。不藉耕耘而生稻粱。皆由往业胜力成熟。宫殿楼阁。悉皆奇妙。诸如意树。处处行列。种种香树。恒出香云。诸末香树。雨末香云。种种鬘树。恒出鬘云。种种华树。雨不思议众妙华云。种种宝树。雨大摩尼珍奇妙宝。无量色光。周匝照曜。诸音乐树。出诸音乐。随风吹动演妙音声。日月光明摩尼宝王。普照一切昼夜受乐。无时间断。此四天下。有百万亿那由他诸王国土。一一国土。有千大河。周匝围绕。一一皆以妙华覆上。随流漂动。出天乐音。一切宝树。列植其岸。种种珍奇。以为严饰。舟船来往。称情嬉戏。种种资缘。受用安乐。一一河间。有百万亿城。一一城有百万亿那由他聚落。如是一切城邑聚落。各有无量百千亿那由他宫殿园林。周匝围绕。以为眷属。此四天下阎浮提中。有一国土。名宝华灯。安隐丰乐。人民炽盛。宫殿严好。自在圆满。其中众生。具行十善。有转轮王。于中出现。名毗卢遮那宝莲华藏。于莲华中。欻然化生。三十二相庄严其身七宝成就。王四天下。恒以正法教导群生。王有千子。端正勇健。威力自在。能伏怨敌。百万亿那由他宫人采女。以为眷属。皆悉与王。同种善根。同修诸行。同时诞生。同以宝饰。璎珞庄严。端正姝妙。犹如天女。身真金色。常放光明。诸毛孔中。恒出妙香。良臣猛将具足十亿。王有正妃。名具足圆满吉祥面。是王女宝端严殊特。观者无厌。最胜清净。皮肤金色。目发绀青。言同梵音。身有天香。常放光明。照千由旬。其妃有女。名普喜吉祥莲华眼。形体端严。德行具足。相好圆满。如转轮王。众生见者。心无厌足。彼时众生。寿命无量。或有不定而中夭者。种种形色。种种音声。种种名字。种种族姓长短大小。勇怯愚智。贫富苦乐。信乐胜劣。无量品类。皆悉不同。时或有人。谓余人言。我身端正。汝形丑陋。作是语已。互相毁辱。集不善业。以是业故。寿命色力。一切乐事。悉皆损减

大方广佛华严经卷第十九大方广佛华严经卷第二十

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时宝华灯城北。有菩提树。名普光遍照法云声幢。以念念显示一切如来庄严道场金刚坚固摩尼宝王。而为其根。一切摩尼以为其干。众杂妙宝以为其叶。枝条华果。次第分布。并相称可。四方上下。圆满庄严。放种种色宝焰光明。出妙音声。演说一切诸佛如来自在神通甚深境界。于彼树前。有一香池。名宝华光法雷声。香水盈满。妙宝为岸。百万亿那由他宝树围绕。一一树形如菩提。树。众宝璎珞周匝垂下。复有无量宫殿楼阁。众宝所成。周遍道场。以为严饰。彼香池内。出大莲华。名普现三世一切如来庄严境界云。须弥山极微尘数如来。于中出现。其第一佛。名普智宝焰吉祥威德王。于此华上。最初得阿耨多罗三藐三菩提。无量千岁。演说妙法。成熟众生。其彼如来。未成佛时。十千年中。菩提树王。放大光明。显现神通。成熟众生所谓十千年前。放净光明。名一切众生离垢灯。若有众生遇斯光者。心自开悟。知十千年后。佛当出现。九千年前。放净光明。名具足无垢吉祥藏。若有众生遇斯光者。得清净眼。见一切色。知九千年后。佛当出现。八千年前。放大光明。名一切众生业果音声。若有众生遇斯光者。悉能自知业海差别。种种果报。知八千年后佛当出现。七千年前放大光明。名生一切善根音声。若有众生遇斯光者。一切善根悉皆圆满。知七千年后佛当出现。六千年前。放大光明。名佛不思议境界音声。若有众生遇斯光者。其心广大。普得自在。知六千年后佛当出现。五千年前。放大光明。名严净一切佛刹音声。若有众生遇斯光者。悉见一切清净佛土。知五千年后佛当出现。四千年前。放大光明。名一切如来境界无杂乱灯。若有众生遇斯光者。悉能深入如来境界。遍一切处。往觐诸佛。知四千年后佛当出现。三千年前。放大光明。名一切众生普照三世现前灯。若有众生遇斯光者。悉能现见一切如来诸本事海。知三千年后佛当出现。二千年前。放大光明。名三世智电灯。若有众生遇斯光者。则见一切如来过去相应行海。知二千年后佛当出现。一千年前。放大光明。名如来无翳智慧灯。若有众生遇斯光者。具足普眼。能见诸佛神通变化。净一切刹。知一千年后佛当出现。一百年前。放大光明。名令一切众生皆得见佛集诸善根。若有众生遇斯光者。则得成就见佛三昧。知百年后佛当出现。次七日前。放大光明。名一切众生大喜爱乐音。若有众生遇斯光者。则得见佛能生爱敬。知七日后佛当出现善男子。如是种种无量无边清净光明。十千年中。乃至七日。调伏众生。令其成熟。满七日已。一切世界。悉皆震动。纯一清净。无诸秽杂。念念普现十方一切清净佛刹。亦现彼刹种种庄严。若有众生。根性淳熟。应见佛者。咸诣道场。尔时彼世界中。一切轮围。一切须弥。一切诸山。一切河海。一切大地。一切城邑。一切垣墙。一切宫殿。一切音乐。一切资具。一切璎珞。一切语言。皆出音声。赞说一切诸佛如来神通境界变化庄严。又出一切香云。一切烧香云。一切末香云。一切涂香云。一切香摩尼形像云。一切摩尼衣云。一切宝焰云。一切焰藏云。一切璎珞云。一切妙华云。一切音乐云。一切如来光明云。一切如来圆光云。一切如来愿声云。一切如来言音海云。一切如来种种相好色光明云。显示如来出现世间不思议相。善男子。此普现三世一切如来庄严境界大宝莲华王。有十佛刹极微尘数妙宝莲华。以为眷属。周匝围绕。其诸莲华一一台上皆有摩尼宝师子座。一一座上皆有菩萨结跏趺坐。善男子。彼普智宝焰吉祥威德王如来。于此成阿耨多罗三藐三菩提。时即于十方一切世界。成阿耨多罗三藐三菩提。随众生心。悉现其前。为转法轮。于一一世界。令无量众生离恶道苦。令无量众生生人天中。令无量众生住于声闻辟支佛地。令无量众生成就出离菩提之行。令无量众生成就无垢勇猛幢菩提之行。令无量众生成就清净法光明菩提之行。令无量众生成就威德清净根菩提之行。令无量众生成就随顺平等力菩提之行。令无量众生成就现前入法城菩提之行。令无量众生成就遍至一切处不可坏神通力菩提之行。令无量众生普于十方一切如来应正等觉。生希有心。安住平等菩提之行。令无量众生安住三昧门菩提之行。令无量众生成就缘一切清净境界菩提之行。令无量众生发菩提心。令无量众生住菩萨道修菩萨行。令无量众生安住清净波罗蜜道。令无量众生住菩萨初地。令无量众生安住菩萨二地三地乃至十地。令无量众生入于菩萨殊胜行愿。令无量众生安住普贤清净行愿。善男子。彼普智宝焰吉祥威德王如来。现如是等佛不思议自在神力转法轮时。于彼一一诸世界中随其所应。念念调伏。教化成熟无量众生

时普贤菩萨。知宝华灯王城中众生。自恃色貌。及诸境界。放逸昏醉。而生憍慢。为欲调伏彼众生故。化现妙身。端正殊特。往诣彼城。放大光明。普照一切。令彼圣王及诸妙宝。日月星宿。宝树宝衣。摩尼璎珞。众生身等。一切光明。威德端严。悉皆不现。譬如日出众景夺曜。亦如聚墨对阎浮金。时诸众生各心念言。此为是谁。为天为梵。今放此光映蔽一切。令我等身所有威德光色端严皆不显现种种思惟。无能解了。尔时普贤菩萨。在彼轮王宫殿之上虚空中住。而告之言。大王当知。今汝国中。有佛出兴。在普光遍照法云声幢菩提树下。时轮王女普喜吉祥莲华眼。见普贤菩萨所现色身光明自在。及闻身上种种璎珞诸庄严具所出妙音。生爱敬心。生欢喜心。生深信心。作如是念。愿我所有一切善根。得如是身。如是庄严。如是相好。如是威仪。如是神通。如是威德。今此大圣。能于众生生死长夜黑闇之中。放大光明。显示如来出兴于世。愿令于我亦得如是。为诸众生。作智光明。破彼所有无知黑闇。愿我所在受生之处。常得不离此善知识。善男子。时毗卢遮那宝莲华藏妙吉祥髻转轮圣王。与其宝女千子眷属。大臣辅佐。七宝四兵。及其城内无量人众。前后围绕。以王神力。俱升虚空。高一由旬。放大光明。照四天下。普使一切咸得瞻仰。欲令众生俱往见佛。以偈赞曰

  佛今已出于世间　　普救一切诸群品
  汝等宜应速发心　　往诣最胜导师所
  经于无量俱胝劫　　乃有如来兴出世
  开示甚深微妙法　　普为利乐诸众生
  佛观一切诸世间　　颠倒无明常翳惑
  生死逼迫轮回苦　　而起救护大悲心
  无数千万俱胝劫　　修习种种菩提行
  成就最胜大悲心　　普灭一切众生苦
  头目耳鼻身手足　　如是一切皆能舍
  为证甘露佛菩提　　经于无量无边劫
  过于无量俱胝劫　　出世导师难可遇
  见闻供养及亲承　　一切获益无空过
  我今与汝俱往诣　　观彼最胜调御师
  为转无上大法轮　　道树降魔成正觉
  汝应观佛妙色身　　放无边际光明网
  种种妙色咸清净　　除灭众生惑苦暗
  从于一一毛孔中　　普放无数光明云
  遍照一切诸群生　　咸令爱敬心欢喜
  汝等各各应思念　　发起广大精进心
  即时同诣彼如来　　亲近至诚而供养

尔时转轮圣王。说偈赞佛。开悟国内一切众生已。从轮王善根。出十千种大供养云。往诣道场。向如来所。所谓出一切宝盖云。一切华帐云。一切宝衣云。一切香海云。一切宝座云。一切宝幢云。一切宫殿云。一切妙华云。一切宝铃网云。一切庄严具云。于虚空中。周遍严饰。到已顶礼普智宝焰吉祥威德王如来足。右绕无数百千万匝。即于佛前坐普照十方光明摩尼宝莲华座。时轮王女普喜吉祥莲华眼。即解身上一切璎珞诸庄严具。持以奉散。时庄严具。于虚空中。变成大摩尼宝盖。有种种色摩尼宝网。周匝垂下。一切龙王共所执持。一切宫殿于中间列。十种宝盖眷属围绕。形如楼阁。内外清净。诸璎珞云。遍覆其上。及诸宝树香海摩尼种种妙饰以为严好。于此盖中。有菩提树。枝叶荣茂。普覆法界。念念示现无量庄严。毗卢遮那如来。坐此树下。有不可说不可说佛刹极微尘数菩萨。前后围绕。一切皆从普贤菩萨行愿出生。住诸菩萨不可思议无差别住。亦见一切诸世间主。合掌瞻仰。围绕如来。亦见一切如来自在神通之力。又见一切诸劫次第世界成坏。又亦见彼一切世界一切诸佛出兴次第。又亦见彼一切世界。一一皆有普贤菩萨。种种供养一切如来。种种调伏一切众生。又亦见彼一切菩萨及其自身。莫不皆在普贤身中。亦见自身在一切如来前。一切普贤前。一切菩萨前。一切众生前。又亦见彼一切世界。一一各有佛刹极微尘数世界。种种际畔。种种任持。种种形状。种种体性。种种安布。种种庄严种种清净。种种庄严云。而覆其上。种种劫名。种种佛兴。种种三世。种种方处。种种住法界。种种入法界。种种住虚空。种种菩萨庄严。种种菩萨住处。种种如来菩提场。种种如来神通力。种种如来师子座。种种如来大会海。种种如来众差别。种种如来巧方便。种种如来转法轮。种种如来妙音声。种种如来言说海。种种如来契经云。既见是已。其心清净。生大欢喜。时彼如来为此女人。说修多罗。名一切如来转法轮音。十佛刹极微尘数修多罗。而为眷属。时彼女人闻此经已。即得成就十千三昧门。身心柔软。无有粗强。如初受胎。如始诞生。如娑罗树初始生芽。彼三昧心。柔软可爱。亦复如是。所谓现见一切佛三昧。普照一切刹三昧。深入一切三世门三昧。演说一切佛法轮三昧。了知一切佛愿海三昧。开悟一切众生令出生死苦三昧。常愿破一切众生闇三昧。常愿灭一切众生苦三昧。常愿生一切众生乐三昧。教化一切众生不生疲厌三昧。一切菩萨住一切地自在庄严三昧。一切菩萨无障碍幢三昧。普诣一切清净佛刹三昧。得如是等十千三昧已。复得微细等引。谓不动心。欢喜心。安慰心。普光照心。顺善知识教心。缘甚深一切智心。随顺慈无量教行心。舍离一切执着心。不住一切世间境界心。深入如来境界心。普照一切佛色相海心。不散乱心。不飘动心。无障碍心。无高下心。无疲倦心。无退转心。得自在心。离懈怠心。正念诸法自性心。安住一切法门海心。修行一切法门海心。了知一切众生海心。救护一切众生海心。普照一切世界海心。普生一切佛愿海心。悉破一切障碍山心。积集广大福聚心。现见如来十力心。普照菩萨境界心。增长菩萨助道心。遍缘一切方海心。一心思惟观察普贤所有大愿。发一切如来十佛刹极微尘数平等愿海。所谓愿严净一切佛国。愿成熟一切众生。愿遍知一切法界。愿普入一切法界海。愿于一切佛刹尽未来劫。修菩萨行。愿尽未来际劫不舍一切众生。愿得亲近一切如来。愿得承事一切善友悉令欢喜。愿得供养一切如来悉令遍满。愿于念念中修菩萨行增一切智无有间断。发如是等十佛刹极微尘数愿海。成就普贤所有大愿。时彼如来。复为其女。开示演说。发心已来。所种善根。所修妙行。所得大果。令其开悟。甚深信解。成就如来圆满广大所有愿海。一心趣向一切智位

善男子。复于此前。过十大劫。有世界。名日轮光照摩尼王。佛号因陀罗幢吉祥相。时此莲华眼女。于彼如来遗法之中。普贤菩萨劝其修补莲华座上故坏佛像。既修补已。而复彩画。既彩画已复宝庄严。发阿耨多罗三藐三菩提心。善男子。我念过去。由普贤菩萨善知识故。种此善根。从是已来。不堕恶趣。常于一切天王人王种族中生。一切生处。身形殊妙。端正可喜。色相圆满令人乐见。常见于佛。常得亲近普贤菩萨。令我忆持所得法门。乃至于今示导开悟成熟于我。令生欢喜。善男子。于意云何。尔时毗卢遮那宝莲华藏妙吉祥髻转轮王者。岂异人乎。今弥勒菩萨是也。是时王妃具足圆满吉祥面者。具足功德寂静音海夜神是也。今所住处。去此不远。时普喜吉祥莲华眼童女者。即我身是。我于昔时。身为童女。普贤菩萨。劝我修补莲华座像。以为无上菩提因缘。令我发阿耨多罗三藐三菩提心。我于彼时。初始发心。次复引导。令我得见普智宝焰吉祥威德王如来。解身璎珞。散佛供养。见佛神变。闻佛说法。即得菩萨普现一切世间调伏众生解脱门。从是得见须弥山极微尘数佛。我皆尊重恭敬供养。听彼如来种种说法。闻法欢喜。依教修行。于念念中。常得见彼一切如来。及彼佛刹菩萨大会。善男子。过彼毗卢遮那威德吉祥世界无垢圆满劫已。次有世界。名摩尼轮种种妙色庄严。劫名大光。有五百佛。于中出现。我皆承事恭敬供养。令其欢喜。其最初佛。名大悲云幢。我为夜神。见佛出行。恭敬供养。次有佛出。名金刚那罗延幢。我为轮王。亲近承事。恭敬供养。时佛为我说修多罗。名一切佛出现。十佛刹极微尘数修多罗以为眷属。我皆受持。次有佛出。名金刚无碍德。我于彼时。为转轮王。恭敬供养。其佛为我。说修多罗。名普照一切众生根。须弥山极微尘数修多罗而为眷属。我皆受持。次有佛出。名火焰山吉祥庄严。我于彼时。为长者女。供养恭敬。其佛为我。说修多罗。名普照三世藏庄严。阎浮提极微尘数修多罗而为眷属。我皆受持。次有佛出。名一切法海高胜王。我为天王。恭敬供养。其佛为我。说修多罗。名分别一切法界智。五百修多罗而为眷属。我皆受持。次有佛出。名甚深法吉祥海光。我于彼时。为龙王女。雨如意摩尼宝云。而为供养。其佛为我。说修多罗。名速疾增长欢喜海。百万亿那由他修多罗而为眷属。我皆受持。次有佛出。名宝峰光焰灯。我为海神。雨宝莲华云。亲近承事。恭敬供养。其佛为我。说修多罗。名法界方便海光明。佛刹极微尘数修多罗而为眷属。我皆受持。次有佛出。名功德海光照圆满吉祥。我于彼时。为五通仙现大神力。六千诸仙。眷属围绕。雨妙香华高山峰云。而为供养。其佛为我。说修多罗。名无著法灯。六千修多罗而为眷属。我皆受持。次有佛出。名毗卢遮那吉祥藏。我于彼时。为主地神。名平等利益。与无量地神俱。雨一切宝树云一切宝藏云。一切宝璎珞云。一切宝庄严云。而为供养。其佛为我。说修多罗。名出生一切如来智藏。无量修多罗而为眷属。我皆听闻。忆持不忘

善男子。如是次第五百如来。其最后佛。名法界虚空宝山圆满吉祥灯。我于彼时。身为妓女。名可喜吉祥面。遇佛入城。歌舞供养。承佛威力。踊在空中。以千妙偈。赞叹于佛。佛为于我。放眉间光。名普照法界光明庄严。光照我身。一切遍满。我蒙光触。即得解脱。名法界方便不退藏门。善男子。此世界中。有如是等佛刹极微尘数劫。一切如来。于中出现。我皆承事。恭敬供养。令其欢喜。彼诸如来。为我演说种种正法。我皆忆念。如法受持。乃至不忘一文一句。于彼一一诸如来所。称扬赞叹一切佛法。为无量众生。广作利益。于彼一一诸如来所。得现三世法界藏住广大法界身。得入一切智光明。入一切普贤行。善男子。我依一切智光明故。于念念中。见无量佛。既见佛已。先所未得。先所未见。先所未闻。普贤菩萨所有妙行。悉得成就。何以故。以得一切智光明故。差别显示无量无边法界门故。尔时普救众生夜神。欲重明此解脱门义。承佛威力。为善财童子而说偈言

  善财汝应听我说　　甚深难入难见法
  普光遍照于三世　　一切差别智明门
  如我初发菩提心　　勤求佛智诸功德
  所证无边解脱门　　为汝宣扬应谛听
  忆昔过刹极微劫　　时有劫名无垢轮
  刹号胜幢遍照灯　　庄严广大无诸垢
  于中十力出世间　　量与须弥尘数等
  初佛宝焰吉祥光　　第二法王功德幢
  第三法幢福须弥　　第四无畏自在王
  第五佛名寂静王　　第六佛名寂静城
  第七如来名称山　　第八导师须弥德
  第九佛号吉祥光　　第十名为月面佛
  于此十佛世尊所　　令我开悟最初门
  此后次第有十佛　　相续出兴于世间
  最初佛号虚空住　　第二如来名普光
  三名出生住诸方　　第四如来正念海
  第五佛名高胜光　　第六世尊须弥云
  第七如来法焰光　　第八如来名称山
  第九出生莲华王　　第十大悲法界华
  此十佛海光明照　　令我悟入第二门
  此后相续时无间　　次第复有十佛出
  第一如来光幢王　　第二佛名智慧光
  第三佛名利益心　　第四如来帝吉祥
  第五如来名天智　　第六佛号尊慧王
  第七佛名智吉祥　　第八佛号光照王
  第九勇猛天行佛　　第十法界莲华尊
  此十能显广大法　　令我成就第三门
  此后无间复值遇　　次第相续十佛出
  最初宝焰山吉祥　　第二功德吉祥佛
  第三佛号法光明　　第四佛名莲华藏
  第五智月妙眼佛　　第六如来香宝光
  第七善逝须弥德　　八名乾闼婆光明
  第九摩尼藏王佛　　第十具足威德佛
  此后次第有十佛　　相续出兴于世间
  最初佛号广大智　　第二佛号宝光明
  第三如来功德云　　第四佛名最胜相
  第五苦行圆满光　　第六佛号那罗延
  第七世尊须弥德　　第八功德轮围王
  第九如来无胜幢　　第十佛名大树王
  此后次第有十佛　　相续出兴于世间
  初名帝德娑罗王　　二名普现世主身
  第三佛号高显光　　第四佛名金刚光
  第五世尊地威德　　第六甚深法德王
  第七法海大智音　　第八佛号须弥幢
  第九如来智光照　　第十妙宝吉祥王
  此后次第有十佛　　相续出兴于世间
  初梵光佛虚空音　　第三法界像吉祥
  第四圆满光明轮　　第五诸方智光幢
  六虚空灯七妙德　　第八遍照吉祥光
  第九福光寂静德　　第十大悲云吉祥
  此后次第有十佛　　相续出兴于世间
  初真谛力智光明　　二现一切众生前
  第三名为高显光　　第四佛号光明身
  第五善逝法出生　　第六名为速疾风
  第七世尊吉祥相　　第八如来勇猛幢
  第九佛名宝肢节　　第十普现三世光
  此后次第有十佛　　相续出兴于世间
  初佛愿海吉祥灯　　二佛吉祥金刚山
  第三坚固须弥德　　第四佛名念幢王
  第五如来法智尊　　第六佛名般若灯
  第七佛号德光幢　　第八佛名广大智
  第九智行法界门　　第十法海智吉祥
  此后次第有十佛　　相续出兴于世间
  最初福山功德王　　次佛名为智吉祥
  第三如来法驾轮　　第四宝王吉祥佛
  第五功德轮吉祥　　第六普智焰光佛
  第七佛号须弥灯　　第八世尊迅疾光
  第九如来大寂声　　第十佛名寂静幢
  十一众生吉祥灯　　十二大愿速吉祥
  十三无能胜力幢　　十四世尊智焰海
  皆于世间为上首　　普利一切诸众生
  此后次第有十佛　　相续出兴于世间
  第一佛名法自在　　第二无著智如来
  第三世尊海慧音　　第四众密音调御
  五名具足言辞佛　　第六妙音大吉祥
  第七佛智自在转　　第八普现众生前
  九等众生吉祥身　　十名德贤自性山
  如是须弥尘数劫　　所有上首诸如来
  普为众生作世灯　　我皆供养无空过
  复过佛刹极微数　　劫中所有诸如来
  我于一切咸供养　　入此甚深解脱海
  我于如是无边劫　　修行得此解脱门
  汝今闻已速修行　　不久亦当如我得

善男子。我唯知此菩萨普现一切世间调伏众生解脱门。如诸菩萨摩诃萨。集无边行海。发种种解心。现种种身。具种种根。满种种愿。入种种三昧。起种种神通。成就种种方便。能作种种利益。游入种种智藏。照种种法门海。得种种法光明。往种种佛刹海。受种种佛灌顶。事种种善知识。悟种种解脱门。证种种自在心。起种种无作行。现种种难思色。顺种种众生心。起种种变化身。入种种菩萨地。知种种法因缘。离种种妄分别。依种种菩萨愿。持种种佛遗教。安住出生普贤妙行。而我云何能知能说彼功德行。善男子。去此不远。菩提场中。有主夜神。名具足功德寂静音海。坐星宿光幢摩尼王庄严宝莲华藏师子之座。百万阿僧祇夜神。以为眷属。前后围绕。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

大方广佛华严经卷第二十大方广佛华严经卷第二十一

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。于普救众生威德吉祥夜神所。闻菩萨普现一切世间调伏众生解脱门。及得一切如来现前三昧。超出一切众生庄严三昧。得如是等十千三昧。皆悉修习。起深信解。光明普照。周遍随顺。趣入游履。广大出生。自在作用渐次前行。往诣具足功德寂静音海夜神所。顶礼其足。绕无数匝。合掌恭敬。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。我依善知识故。学菩萨行。修菩萨行。入菩萨行。住菩萨行。我愿出生一切智海不思议法。唯愿慈哀。为我宣说。菩萨云何学菩萨行。云何修菩萨道。时彼夜神。告善财言。善哉善哉。善男子。汝能依止诸善知识。求菩萨行。善男子。我得菩萨念念出生广大欢喜庄严解脱门。善财言。大圣。此解脱门为何事业。行何境界。修何方便。作何观察。夜神言。善男子。我发起清净平等乐欲心。我发起离一切世间尘垢清净坚固庄严心。我发起于一切事难作能作决定不退心。我发起庄严一切功德宝山犹如须弥处金轮上永不倾动心。我发起于一切处无所住着心。我发起普现一切众生前皆能救护心。我发起见一切佛海无有厌足心。我发起求一切菩萨清净愿力心。我发起住普遍大智光明海心。我发起令一切众生超过忧恼生死旷野心。我发起令一切众生舍离愁叹众苦心。我发起令一切众生舍离种种不可意色声香味触法心。我发起令一切众生舍离种种恩爱别离怨憎会苦心。我发起令一切众生舍离种种恶业因缘愚痴等苦心。我发起与一切恶趣险难众生作救护心。我发起令一切众生出生死苦显示正道心。我发起令一切众生舍离生老病死等苦心。我发起令一切众生成就如来无上法乐心。我发起令一切众生皆受清净大喜乐心。我发起令一切众生修行正行无厄难心。发是心已。复为说法。令其渐至一切智地。所谓若见众生乐着所住宫殿屋宅。我为说法。令其了达诸法本性。离诸执着。若见众生恋着父母兄弟亲属。我为说法。令其得入诸佛菩萨清净众会。若见众生恋着妻子情无舍离。我为说法。令其舍离生死爱染。起大悲心。于一切众生平等无二。若见众生恋着市肆廛里集会。我为说法。令其得与众圣集会。若见众生贪着资具。我为说法。令其具足诸波罗蜜。若见众生爱着音乐。我为说法令其爱乐清净法乐。若见众生着五欲境。我为说法。令其得入如来境界。若见众生多起嗔恚。我为说法。令住如来忍波罗蜜。若见众生其心懈怠。我为说法。令得清净勤波罗蜜。若见众生其心散乱。我为说法。令得如来禅波罗蜜。若见众生入见稠林无明闇障。我为说法。令得出离稠林黑闇。若见众生无有智慧。我为说法。令其成就般若波罗蜜。若见众生染着三界。我为说法。令于生死心无取舍而得安住方便波罗蜜。若见众生志意下劣。我为说法。令其圆满佛菩提愿。若见众生但求自利。我为说法。令其发起平等利益诸众生愿。若见众生志乐微弱。我为说法。令得菩萨力波罗蜜。若见众生愚痴黑闇。我为说法。令得如来究竟清净智波罗蜜。若见众生色相不具。我为说法。令得如来圆满色身。若见众生形容丑陋。我为说法。令得无上清净法身。若见众生色相粗恶。我为说法。令得微细金色皮肤。若见众生诸苦逼迫。我为说法。令得如来最极安乐。若见众生种种安乐。我为说法。令其安住一切智乐。若见众生种种病苦。我为说法。令其成就如影像身。若见众生积集色爱。我为说法。令其爱乐诸菩萨行。若见众生贫穷所困。我为说法。令得菩萨功德宝藏。若见众生乐止园林。我为说法。令其供养承事诸佛住法园苑。若见众生游行道路。我为说法。令其趣向一切智道。若见众生乐居村邑。我为说法。令出三界。若见众生乐住聚落。我为说法。令其超越二乘之道住如来地。若见众生乐住城郭。我为说法。令其得住法王城中。若见众生乐止四隅。我为说法。令得三世平等智慧。若见众生乐止诸方。我为说法。令得智慧见一切法。若见众生贪行多者。我为彼说不净观门。令其舍离生死渴爱。若见众生嗔行多者。我为彼说大慈观门。令勤修习心无恼害。若见众生痴行多者。我为说法。令得智眼观诸法海。若见众生等分行者我为说法。令其得入一切胜智诸大愿海。若见众生乐生死乐。我为说法。令其厌离。若见众生厌生死苦应为如来之所化者。我为说法。令悟无生示现受生。若见众生爱着五蕴。我为说法。令其得住无依境界。若见众生其心下劣。我为显示胜庄严道。若见众生心生憍慢。为说如来平等法忍。若见众生其心谄曲。为说菩萨清净直心。善男子。我以如是无量法施。摄诸众生。种种方便教化调伏。令离恶道受人天乐。脱三界缚住一切智。我时便得广大欢喜法光明海。速疾爱乐甚深圆满。其心怡畅。安隐适悦。复次善男子。我常观察一切菩萨道场众海。修种种愿行。现种种净身。有种种常光。放种种光明。以种种方便。入一切智门。入种种三昧。现种种神变。出种种音声海。具种种庄严身。入种种如来门。诣种种国土海。见种种诸佛海。得种种辩才海。照种种解脱境。得种种智光海。入种种三昧海。游戏种种解脱宫殿。以种种门趣一切智。以庄严云覆虚空界。观察种种道场众会。集种种世界。入种种佛刹。诣种种方海。受种种如来命。从种种如来所。与种种菩萨俱。雨种种庄严云。入如来种种方便。观如来种种法海。思如来种种神通门。顺如来种种智慧海。往如来种种殊胜会。坐如来种种庄严座。善男子。我观察此道场众会。知佛神力无量无边。生大欢喜。善男子。我观毗卢遮那如来。念念出现不思议色身。既见是已。生大欢喜。又观如来。于念念中放大光明。充满无边广大法界。既见是已。生大欢喜。又见如来一一毛孔。念念出现无量佛刹极微尘数光明海。一一光明以无量佛刹极微尘数光明。而为眷属。一一周遍一切法界。销灭一切诸众生苦。既见是已。生大欢喜。又善男子。我观如来顶及两肩。念念出现一切佛刹极微尘数宝焰山云。充满十方一切法界。既见是已。生大欢喜。又善男子。我观如来一一毛孔。于念念中。出一切佛刹极微尘数香光明云。充满十方一切佛刹。既见是已。生大欢喜。又善男子。我观如来一一相海。于念念中。出一切佛刹极微尘数诸相庄严如来身云。遍往十方一切世界。既见是已。生大欢喜。又善男子。我观如来一一随好。于念念中。出一切佛刹。极微尘数随好光明如来身云。既见是已。生大欢喜。又善男子。我观如来一一毛孔。于念念中。出不可说不可说佛刹极微尘数佛变化云。示现如来从初发心。修波罗蜜。具庄严道。入菩萨地。游戏菩萨种种神力。既见是已。生大欢喜。又善男子。我观如来一一毛孔。念念出现不可说不可说佛刹极微尘数天王身云。及以天王自在神变。充遍一切十方法界。应以天王身而得度者。即现其前而为说法。既见是已。生大欢喜。又善男子。我观如来一一毛孔。念念出现不可说不可说佛刹极微尘数龙王身云。夜叉王身云。乾闼婆王身云。阿修罗王身云。迦楼罗王身云。紧那罗王身云。摩睺罗伽王身云。人王身云。梵王身云。莫不念念毛孔中现如是神变。如是身相。如是言音。如是说法。我见是已。于念念中。生大欢喜。广大信乐。量与法界萨婆若等。昔所未得。而今始得。昔所未解。而今始解。昔所未证。而今始证。昔所未入。而今始入。昔所未满。而今始满。昔所未见。而今始见。昔所未闻。而今始闻。何以故。以能了知法界相故。知一切法唯一相故。能平等入三世道故。能说一切无边法故

善男子。我入此菩萨念念出生广大欢喜庄严解脱光明海。又善男子。此解脱无边。普入一切法界门故。此解脱无尽。等发一切智性心故。此解脱无量。菩萨智眼所知境故。此解脱无际。入无际畔一切众生心想中故。此解脱甚深。寂静智慧所观察故。此解脱广大。周遍一切如来境故。此解脱无坏。菩萨智眼之所知故。此解脱无底。尽于法界之源底故。此解脱者即是普门。于一事中。普遍出生诸神变故。此解脱者体性不空。一切法身等无二故。此解脱者终无有生。以能了知如幻法故此解脱者犹如影像。一切智愿光所生故。此解脱者犹如变化。诸菩萨行妙变化故。此解脱者犹如大地。为一切众生所依处故。此解脱者犹如大水。能以大悲润一切故。此解脱者犹如大火。干竭众生贪爱水故。此解脱者犹如大风。令诸众生速疾趣于一切智故。此解脱者犹如大海。众功德宝。庄严一切诸众生故。此解脱者如须弥山。出一切智法宝海故。此解脱者如天宫殿。一切妙法所庄严故。此解脱者犹如虚空。普容三世一切如来神通力故。此解脱者犹如大云。普为众生雨法雨故。此解脱者犹如净日。能破众生无知闇故。此解脱者犹如满月。满足广大福智海故。此解脱者犹如如来。于一切处正遍知故。此解脱者犹如自影。从自善业所化出故。此解脱者犹如谷响。随其所应为说法故。此解脱者犹如影像。随众生心而照现故。此解脱者如大树王。开敷一切神通华故。此解脱者犹如金刚。从本已来不可坏故。此解脱者如如意珠。出生无量自在力故。此解脱者如离垢藏摩尼宝王。示现一切三世如来诸神变故。此解脱者犹如喜幢妙摩尼宝。能平等出一切诸佛法轮声故。善男子。我今为汝。种种称赞此解脱门无比希有真实功德。难解难入。难信难知。汝应思惟。随顺悟入。尔时善财童子。白夜神言。圣者。云何修行得此解脱。具足圆满。夜神言。善男子。菩萨修行十大法藏。积集圆满。光明遍照。爱乐出生。威力自在。则能成就此解脱门。何等为十。一修布施广大法藏。随众生心。悉令满足。二修净戒广大法藏。普入一切佛功德海。三修安忍广大法藏。能遍思惟一切法性。四修精进广大法藏。趣一切智恒无退转。五修禅定广大法藏。能灭一切众生热恼。六修般若广大法藏。能遍了知一切法海。七修方便广大法藏。能遍成熟诸众生海。八修诸愿广大法藏。能遍游入诸佛刹海。为诸众生。尽未来劫。修菩萨行。九修诸力广大法藏。能念念中。现于一切法界教海。于一切刹。成等正觉。常无休息。十修净智广大法藏。能得如来清净妙智。遍知三世一切诸法无有障碍。善男子。若诸菩萨。安住如是十大法藏。则能获得如是解脱。清净增长。积集具足。出生坚固。广大成就。安住圆满

善财白言。圣者汝发阿耨多罗三藐三菩提心。其已久如。夜神言。善男子。此华藏庄严世界海东。过千世界海。有世界海。名一切净光众宝庄严。有世界种。名大愿光明音。中有世界。名无垢金光庄严。以一切香金刚摩尼王为体。形如楼阁。众妙宝云以为其际。住于一切宝璎珞海。妙宫殿云而覆其上。净秽相杂。彼世界中。乃往古世。有劫名普照光幢。有国名普宝吉祥藏。有菩提场。名一切宝藏众色光明。有佛名不退转法界妙音。于此场中。成等正觉。我于尔时。作菩提树神。名福德灯光明幢。守护道场。见彼如来成等正觉。示现种种自在神力。发阿耨多罗三藐三菩提心。即于此时。获得三昧。名普照如来功德海。彼道场中。次有如来。出兴于世。名法树威德山王。我时命终。还生于此。为道场主夜神名。吉祥福智光明。见彼如来转正法轮现大神通。即得三昧。名普照一切离贪境界。次有如来出兴于世。名一切法海音声王。我为夜神。因得见佛。种种承事。供养恭敬。心生欢喜。即获三昧。名增长一切善法地。次有如来出兴于世。名宝光明灯幢王。我为夜神。因得见佛。承事供养。令其欢喜。即获三昧。名普现神通光明云。次有如来出兴于世。名功德须弥光威德王。我为夜神。因得见佛。承事供养。令得欢喜。则获三昧。名普照诸佛海。次有如来出兴于世。名法云妙音声王。我为夜神。因得见佛。承事供养。令心欢喜。即获三昧。名一切法海灯。次有如来出兴于世。名智炬光照王。我为夜神。因得见佛。承事供养。令其欢喜。即获三昧。名灭一切众生苦光照灯。次有如来出兴于世。名妙法神通速疾幢。我为夜神。因得见佛。承事供养。心大欢喜。即获三昧。名三世如来所行光明藏。次有如来出兴于世。名法灯勇猛智慧师子王。我为夜神。因得见佛。承事供养。令生欢喜。即获三昧。名一切世间无碍智轮威德光。次有如来出兴于世。名智力具足威德王。我为夜神。因得见佛。承事供养。令心欢喜。即获三昧。名普照三世众生根行影像。如是。善男子。彼无垢金光庄严世界。普照光明幢劫中。有如是等十佛刹极微尘数如来出兴于世。我于彼时。或为天王。或为龙王。或为夜叉王。或为乾闼婆王。或为阿修罗王。或为迦楼罗王。或为紧那罗王。或为摩睺罗伽王。或为人王。或为梵王。或为天身。或为人身。或为男子身。或为女人身。或为童男身。或为童女身。悉以种种诸供养具。恭敬供养尊重承事彼诸如来。亦闻诸佛所说妙法。悉皆听受。忆持不忘。从此命终。还即于此世界中生。经于佛刹极微尘数劫。修行菩萨种种妙行。然后寿终。生此华藏庄严世界海中娑婆世界。值迦罗鸠孙驮如来。承事供养。令生欢喜。得三昧。名离一切尘垢影像光明。次值拘那含牟尼如来。承事供养。令生欢喜。得三昧。名普光遍照一切刹海。次值迦叶如来。承事供养。令生欢喜。得三昧。名演一切众生妙音声海。次值毗卢遮那如来。于此道场成等正觉。念念示现种种神通广大威力。我时得见。即获此念念出生广大欢喜庄严解脱门。得此解脱已。能入十不可说不可说佛刹极微尘数法界诸安立海。见彼一切法界安立海。一切佛刹所有极微尘。一一尘中。有十不可说不可说佛刹极微尘数诸佛国土。一一国土。皆有毗卢遮那如来。坐于道场。于念念中成等正觉。现诸神变。所现神变。一一皆遍一切法界海。亦见自身在彼一切诸如来所。又亦闻彼一切世界一切如来种种说法。我悉听受忆持不忘。复次善男子。我复见彼一切如来一一毛孔。出生种种变化海。现神通力。于十方一切法界海。一切佛刹海一切世界种。一切世界中。随诸众生种种生类。种种心性。种种想行。如其所应转正法轮。我得速疾陀罗尼力。悉能受持一切文义。正念思惟。以明了智。普入一切清净法藏。以自在智。普游一切甚深法海。以周遍智。普知三世诸广大义。以平等智。普达诸佛无差别法。我能如是悟解一切诸佛法门。一一法门中。悟解一切修多罗云。一一修多罗云中。悟解一切法海。一一法海中。悟解一切法品。一一法品中。悟解一切法云。一一法云中。悟解一切法流。一一法流中。出生一切法爱乐海。一一法爱乐海。出生一切地。一一地中。出生一切三昧海。一一三昧海。得一切见佛海。一一见佛海。得一切智光海。一一智光海。普照三世。遍入十方。知无量如来过去诸行海。知无量如来所有本事海。知无量如来难舍能舍布施波罗蜜海。知无量如来圆满净戒波罗蜜海。知无量如来清净安忍波罗蜜海。知无量如来广大精进波罗蜜海。知无量如来圆满清净禅波罗蜜海。知无量如来甚深趣入般若波罗蜜海。知无量如来种种方便波罗蜜海。知无量如来种种增长愿波罗蜜海。知无量如来种种成就力波罗蜜海。知无量如来种种圆满智波罗蜜海。知无量如来过去种种超菩萨地无障碍行智光普照海。知无量如来过去种种住菩萨地无障碍行无量劫海现神通力。知无量如来过去种种圆满菩萨地。知无量如来过去种种修习菩萨地。知无量如来过去种种净治菩萨地。知无量如来过去种种观察菩萨地。知无量如来过去为菩萨时常见诸佛如影随形。知无量如来过去为菩萨时尽见佛海劫海同住。知无量如来过去为菩萨时以无量身遍生刹海。知无量如来过去为菩萨时周遍法界修广大行。知无量如来过去为菩萨时示现种种诸方便门调伏成熟一切众生。知无量如来放大光明普照十方一切刹海。知无量如来现大神力普现一切众生之前。知无量如来广大智地光明自在。知无量如来成等正觉神变难思。知无量如来转正法轮悉能受持无有忘失。知无量如来示现相海。知无量如来示现身海。知无量如来广大境界。彼诸如来。从初发心。乃至法灭。如是等法。所有勤求。相应方便我于念念。悉得知见甚深证入。善男子。汝问我言。发心已来。为久如者。我念往昔过二佛刹极微尘数劫。如上所说。于无垢金光庄严世界。为福德灯圆满光明幢菩提树神。闻不退转法界妙音如来种种说法。发阿耨多罗三藐三菩提心。经二佛刹极微尘数劫。种种修行诸菩萨行。然后生此娑婆世界贤劫之中。从迦罗鸠孙驮佛。至释迦牟尼佛。及此劫中。未来所有一切如来。我皆亲近。承事供养。恭敬尊重。令生欢喜。如此世界贤劫之中。供养未来一切诸佛。一切世界一切劫中所有未来一切诸佛。悉亦如是。亲近承事。种种供养。善男子。彼无垢金光庄严世界今犹现在。诸佛出现相续不断。汝当一心修此菩萨大勇猛门。尔时具足功德寂静音海主夜神。欲重宣此解脱门义。为善财童子。而说偈曰

  善财汝今听我说　　如是净妙解脱门
  闻已爱乐生欢喜　　究竟勤修令悟入
  我昔修行多劫海　　生于广大深信心
  常观法性令现前　　速证如空一切智
  我于三世诸佛所　　咸生广大信乐心
  最胜清净诸眷属　　悉愿承事常亲近
  我见过去天人师　　为利众生皆供养
  闻此广大净法门　　其心爱敬生欢喜
  常于父母及师长　　尊重恭敬令欢悦
  如是曾无休懈心　　于此解脱能深入
  又于老病贫穷人　　无主诸根不具足
  经无数劫受轮回　　慈心愍济令安乐
  浊劫水火及王贼　　醉象恶兽诸恐怖
  我昔修行有海中　　种种救护令除免
  三有烦恼恒炽然　　诸恶业障常缠覆
  堕于生死险难中　　我昔救彼令除灭
  一切恐怖恶趣中　　种种苦难恒相续
  生老病死厄其身　　我当救彼咸令出
  愿尽未来一切劫　　普为苦恼诸群生
  灭除生死使无余　　得佛究竟诸安乐

善男子。我唯知此念念速疾出生广大欢喜庄严解脱门。如诸菩萨摩诃萨。深入一切法界海。远离一切内外苦。永除一切诸妄想。具足一切菩萨智。悉知一切诸劫数。普见一切刹成坏。而我云何能知能说彼功德行。善男子。此菩提场。如来清净圆满会中。有主夜神。名守护一切城增长威德。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时善财童子。一心观察具足功德寂静音海主夜神身。合掌恭敬。以偈赞曰

  我因随顺善友教　　今来得诣天神所
  身无边量等须弥　　处座庄严皆妙好
  非是执着于色相　　计有诸法为依止
  邪见浅识劣智人　　而能了知尊境界
  一切世间天及人　　于无边劫常观察
  不能测度圣天身　　色相无量难思故
  天能远离于诸蕴　　亦复不依于界处
  普为众生出世间　　示现种种神通力
  最胜智眼常清净　　无垢无动无所著
  能观一切极微中　　见佛种种神通力
  仁今身为正法藏　　心智无碍常清净
  既得如来智慧光　　复照一切诸群品
  心能普集无边业　　庄严一切诸世间
  了一切法皆是心　　现身等彼众生数
  解了世间犹若梦　　一切诸佛犹如影
  诸法如响悉皆空　　随心普现而无著
  天能普为诸众生　　念念现身恒自在
  于有于无心不住　　常闻说法遍诸方
  无量刹尘诸刹海　　及善逝海众生海
  如是悉在一尘中　　此尊解脱境界力

时善财童子。以此妙偈。赞彼神已。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第二十一大方广佛华严经卷第二十二

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。随顺修行。具足功德寂静音海主夜神所得解脱。观察彼神所说法门。一一文句。皆无忘失。于无量深心。无量法性。一切方便神通智慧。忆念思择。相续不断。微细分别。解了甚深。其心广大证入安住。渐行往诣守护一切城增长威德主夜神所。见彼夜神。坐光明普照一切宫殿摩尼宝王大莲华藏师子之座。百千夜神而为眷属前后围绕。现普应一切众生色相身。现普对一切众生之前身。现不染一切世间身。现等一切众生身数身。现超过一切世间身。现调伏众生随转身。现速往一切十方身。现圆满一切大愿身。现灭除一切障碍究竟如来体性身。现究竟教化成熟一切众生身。善财见已。欢喜踊跃。心愿圆满。欣庆无量。顶礼其足。绕无数匝。于前合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨修菩萨行时。云何利益安乐众生。云何以无上摄摄取众生。云何学菩萨道。云何住菩萨业。云何顺诸佛教。云何近法王位。唯愿慈哀为我宣说。时彼夜神。告善财言。善哉善哉。善男子。汝为救护一切众生故。汝为严净一切佛刹故。汝为供养一切如来故。汝欲住一切劫救众生故。汝欲守护一切佛种性故。汝欲普入十方修诸行故。汝欲普入一切法门海故。汝欲以平等心遍入一切所知境故。汝欲普遍闻持一切如来正法轮故。汝欲普随一切众生心之所乐雨法雨故。问诸菩萨所修行门。善男子。我得菩萨甚深自在可爱妙音解脱门。为大法师。白缯系顶。于一切法心无所著。善能开示一切如来深法藏故。具大誓愿大慈悲力。令一切众生住菩提心故。能作一切利众生事。积聚善根无休息故。为一切众生调御之师。令一切众生住一切智道故。为一切世间。作大法云。普雨一切契经法故。为一切世间清净法日。普照世间令生善根故。于一切世间其心平等。普令众生增善法故。于诸境界。其心清净。除灭一切不善业故为大导师。引导众生。令入一切善行中故。为诸众生。智慧庄严。令诸世间以智先导诸善行故。恒事一切诸善知识为令众生住佛教故。善男子。我以此等法施众生。令生白法求一切智。其心坚固。犹如金刚那罗延藏。善能观察佛力魔力。常得亲近诸善知识。摧破一切业惑障山。集一切智助道之法。心恒不舍一切智地。圆满白净无碍法门。善男子。我以如是净法光明。普遍觉悟一切众生。种种饶益。积集善根。增长成就助道法时。常作十种观察法界。何者为十。所谓我知法界无量。获得广大智光明故。我知法界无边。见一切佛诸神变故。我知法界无际。普入一切诸佛国土。恭敬供养诸如来故。我知法界无畔。普于一切世界海中。示现修行菩萨行故。我知法界无断。入于如来甚深平等种种圆满不断智故。我知法界一性。入于如来圆满言音。随众生心无不了故。我知法界性净。入于如来过去愿海。究竟调伏诸众生故。我知法界遍诸众生。普贤妙行悉周遍故。我知法界一庄严。普贤神通善庄严故。我知法界不可坏。一切善根。充满法界不可坏故。善男子。我作此十种观察法界。随顺解知出生一切广大善根辨助道法。明了诸佛殊胜威德。深入如来难思境界。又善男子。我以如是随顺作意。正念思惟。得如来十种广大威德陀罗尼轮。普为众生。演说妙法。何者为十。所谓普入一切法海陀罗尼轮。普持一切法藏陀罗尼轮。普受一切清净法云陀罗尼轮。普念一切如来智灯陀罗尼轮。普演一切如来名号音声陀罗尼轮。普入三世诸佛平等愿海陀罗尼轮。普入一切诸乘行海速疾圆满陀罗尼轮。普入一切众生业海净诸垢障陀罗尼轮。疾转一切业海清净陀罗尼轮。速疾出生一切智智勇猛成就陀罗尼轮。善男子。此十陀罗尼轮。以十千陀罗尼轮而为眷属。恒为众生演说妙法。善男子。我或为众生说闻慧法。或为众生说思慧法。或为众生说修慧法。或为众生说一有海法。或为众生说一切有海法。或为众生说一如来名号海法。或为众生说一切如来名号海法。或为众生说一世界海法。或为众生说一切世界海法。或为众生说一佛授记海法。或为众生说一切佛授记海法。或为众生说一如来众会道场海法。或为众生说一切如来众会道场海法。或为众生说一如来法轮海法。或为众生说一切如来法轮海法。或为众生说一如来修多罗海法。或为众生说一切如来修多罗海法。或为众生说一如来集会海法。或为众生说一切如来集会海法。或为众生说一萨婆若心海法。或为众生说一切萨婆若心海法。或为众生说一乘出离法。或为众生说一切乘出离法。善男子。我以此等不可说法门。为众生说。善男子。我入如是等无差别法界门海。说无上法。普遍最胜摄诸众生。尽未来劫。住普贤行时。此甚深自在可爱妙音解脱。于念念中。修习增长一切菩萨诸解脱门。念念充满一切法界。时善财童子。白夜神言。奇哉圣者。此解脱门。如是希有。如是甚深。圣者证得其已久如。夜神告言。善男子。乃往古昔。过世界转极微尘数劫。有劫名无垢焰光。世界名法界焰光吉祥云。以现一切众生业海变化摩尼王为体。形如莲华。净秽相杂。依须弥山极微尘数差别香摩尼王网而住。以一切如来过去大愿声妙宝莲华。次第庄严。须弥山极微尘数宝莲华轮围山。周匝围绕。须弥山极微尘数香摩尼宝间错庄严。有须弥山极微尘数四天下。一一四天下。有不可说不可说百千亿那由他城。善男子。彼世界中。有四天下。名种种色妙庄严幢。中有王都。名普宝拘苏摩光。去彼不远。有菩提场。名普现法王宫殿影像。须弥山极微尘数如来。于中出现。其最初佛。名一切法海大声光明王。彼佛出时。有转轮王。名无垢面日光明。于其佛所。闻一切法海旋修多罗。悉能受持。佛涅槃后。其王出家。护持正法。法欲灭时。有千部异。佛正法眼。分十千门。各随其宜。种种说法。近于末劫。五浊现时。诸恶比丘业惑障重。种种缠缚。多诸斗诤。乐着境界。受取无厌。不求一切增胜功德。乐说王论。贼论。女论。国论。海论。及诸世间种种议论。不舍外道断灭见论。心生爱染。情无舍离。时王比丘。以正法音而语之言。奇哉苦哉。佛于无数大劫海中。忍种种苦。集此法炬。云何汝等而共毁灭。作是语已。上升虚空。高七多罗树。身出无量众色焰云。放种种色大光明网。令无量众生除烦恼热。令无量众生发菩提心。以是因缘。彼如来教。复于六十千岁。而得兴盛。时彼众中。有比丘尼。名法轮变化光。是此王女。百千比丘尼而为眷属。闻父王语。及见神通光明威力。皆发阿耨多罗三藐三菩提心。永不退转诸比丘尼。各得三昧。名现见如来平等出生。及得陀罗尼。名一切如来转法轮金刚光明。及得般若波罗蜜。名普入一切法门海。时法轮变化光比丘尼。即得三昧。名出生一切佛教光明灯。又得此甚深自在可爱妙音解脱。得此三昧解脱门故。身心柔软。微细适悦。便得现见一切法海大声光明王如来一切所有神通威力。善男子。于汝意云何。彼无垢面日光明转轮圣王。随彼如来。转正法轮。及涅槃后。兴其末法。然大法炬。光照世间者。岂异人乎。今普贤菩萨是。其法轮变化光比丘尼。即我身是。百千眷属比丘尼。即此会中百千夜神是。我于彼时。守护佛法。令百千比丘尼于阿耨多罗三藐三菩提。得不退转。又令得现见一切如来平等出生三昧。又令得一切如来法轮金刚光明陀罗尼。又令得普入一切法门海般若波罗蜜。善男子。次彼如来。有佛出兴。名无垢法山顶智光明。我以种种承事供养。令心欢喜。次有佛兴。名法轮圆满光明髻。次有佛兴。名法日吉祥云。次有佛兴。名法海门妙声王。次有佛兴。名法日智轮灯。次有佛兴。名法拘苏摩幢云。次有佛兴。名法焰光山幢王。次有佛兴。名甚深吉祥圆满月。次有佛兴。名法智出生普光明藏。次有佛兴。名出生根本智藏。次有佛兴。名吉祥藏山王。次有佛兴。名普门智须弥贤。次有佛兴。名速疾精进幢。次有佛兴。名法宝拘苏摩吉祥云。次有佛兴。名甚深寂静山光明髻。次有佛兴。名法焰光明影像月。次有佛兴。名智焰光吉祥海。次有佛兴。名普贤圆满智。次有佛兴。名无上神通智光明王。次有佛兴。名福德焰光开敷拘苏摩灯。次有佛兴。名智师子幢王。次有佛兴。名普日光明王。次有佛兴。名须弥相宝庄严王。次有佛兴。名日光勇猛普照影像。次有佛兴。名法网觉胜月。次有佛兴。名法莲华开敷吉祥云。次有佛兴。名日轮普光明。次有佛兴。名普光吉祥大声。次有佛兴。名师子无畏金刚那罗延。次有佛兴。名普智勇猛幢。次有佛兴。名普法开敷莲华身。次有佛兴。名功德拘苏摩吉祥海。次有佛兴。名高山法门光明藏。次有佛兴。名高山智焰光明云。次有佛兴。名普法高山面门光明。次有佛兴。名道场吉祥月。次有佛兴。名炽然法炬吉祥月。次有佛兴。名普影像光明髻。次有佛兴。名法速疾灯幢。次有佛兴。名金刚海幢云。次有佛兴。名名称山吉祥云。次有佛兴。名栴檀吉祥月。次有佛兴。名普吉祥拘苏摩威德光。次有佛兴。名照一切众生光明王。次有佛兴。名功德莲华吉祥藏。次有佛兴。名香焰普光明王。次有佛兴。名波头摩华因。次有佛兴。名众相山毗卢遮那。次有佛兴。名普音声名称幢。次有佛兴。名须弥山普门光明。次有佛兴。名法城吉祥光明。次有佛兴。名大树山威德。次有佛兴。名普吉祥毗卢遮那幢。次有佛兴。名吼法海大音声光。次有佛兴。名出生威德一切法宫殿。次有佛兴。名普智最胜光。次有佛兴。名最胜吉祥相。次有佛兴。名法力勇猛幢。次有佛兴。名转法轮妙音声。次有佛兴。名功德焰冠智慧光。次有佛兴。名出生吉祥法轮月。次有佛兴。名法轮莲华毗卢遮那幢。次有佛兴。名宝莲华光明藏。次有佛兴。名宝吉祥云山灯。次有佛兴。名普清净拘苏摩。次有佛兴。名种种吉祥焰须弥藏。次有佛兴。名焰轮圆满山王。次有佛兴。名福德云种种色。次有佛兴。名法山云幢王。次有佛兴。名功德山王光明。次有佛兴。名法日云灯王。次有佛兴。名法云名称遍满王。次有佛兴。名法轮云。次有佛兴。名开悟菩提智威德幢。次有佛兴。名普照法轮吉祥月。次有佛兴。名摩尼金山威德贤。次有佛兴。名妙高吉祥威德贤。次有佛兴。名贤德广大光。次有佛兴。名普智慧妙声云。次有佛兴。名法力吉祥功德山。次有佛兴。名吉祥云香焰王。次有佛兴。名金色摩尼山妙音声。次有佛兴。名顶髻藏出一切法圆满光明云。次有佛兴。名法轮炽盛威德王。次有佛兴。名无上出生威德。次有佛兴。名普精进炬光明云。次有佛兴。名三昧印广大智慧海光明冠。次有佛兴。名妙宝吉祥威德王。次有佛兴。名法炬宝帐妙音声。次有佛兴。名普照虚空界无畏法光明。次有佛兴。名相好庄严幢。次有佛兴。名种种色光明焰山云。次有佛兴。名照无障碍法虚空光明。次有佛兴。名妙相华开敷身。次有佛兴。名最胜世主妙光明音。次有佛兴。名一切法三昧妙光明音。次有佛兴。名妙辩才法音功德藏。次有佛兴。名炽然光明法海妙音云。次有佛兴。名普照三世大光明相威德王。次有佛兴。名普照法轮吉祥山广大光明。次有佛兴。名法界师子光。次有佛兴。名毗卢遮那吉祥妙高。次有佛兴。名一切三昧海普遍光焰师子王。次有佛兴。名普智光明灯。次有佛兴。名普智慧光明法城灯。善男子。如是等须弥山极微尘数如来。其最后佛。名法界城智慧灯光王。于无垢焰光劫中。出兴于世。我皆尊重。亲近供养。听闻受持所说妙法。我亦于彼诸如来所。出家学道。护持法教。入此菩萨甚深自在可爱妙音解脱。种种方便。教化成熟无量众生。从是已来。于佛刹极微尘数劫。所有诸佛。出兴于世。我皆供养。修行其法。善男子。我从是来。于生死夜无明昏寐诸众生中。而独觉悟。令诸众生守护心城。舍三界城。住一切智无上法城。善男子。我唯知此甚深自在可爱妙音解脱。如诸菩萨摩诃萨。舍离世间诸杂秽语。不作二语检策语业。行正直道。安住胜义。成就圆满。永不系属一切语言。于念念中。开悟一切语言自性。深入一切诸言音海。了知众生诸秘密海。明见一切诸法门海。普摄一切平等法海。出生种种陀罗尼海。已得自在。随诸众生心之所宜。而为说法。善巧方便。究竟调伏成熟众生。能普摄受一切众生。巧修菩萨诸无上业。深入菩萨种种法门极微细智。能善观察种种妙事诸菩萨藏。能自在说诸菩萨法。何以故。已得成就一切法轮陀罗尼故。得名殊胜真实丈夫。而我云何能知能说彼功德行。善男子。此菩提场佛众会中。有主夜神名能开敷一切树华安乐汝诣彼问。菩萨云何学一切智。云何修一切智。云何引导一切众生。令其悟入一切智城。尔时守护一切城增长威德主夜神。欲重宣此解脱门义。为善财童子。而说偈曰

  菩萨解脱深难见　　虚空如如平等际
  普见无边法界中　　所有一切三世佛
  出生无量诸解脱　　证入难思真法性
  速疾增长无碍智　　通达三世慈悲道
  过于刹转极微劫　　时有劫名无垢光
  刹号法光吉祥云　　城名普宝拘苏摩
  其中诸佛兴于世　　量与须弥尘数等
  佛号法海大声王　　于此劫中先出现
  乃至其中最后佛　　名为法界智灯王
  如是一切诸如来　　我皆供养听闻法
  我见法海音王佛　　其身普作真金色
  众相庄严如宝山　　发心愿得无师道
  我暂见彼如来身　　即发菩提广大心
  誓愿勤求一切智　　心等如空法界性
  由斯普见三世佛　　及以一切菩萨海
  亦见刹海众生海　　普遍发起大悲心
  随诸众生心所宜　　一身普现无边刹
  舒光动地遍十方　　开悟一切诸含识
  见第二佛而亲近　　亦见十方刹海佛
  乃至最后佛出兴　　名为法界智灯王
  如是须弥极微数　　一切如来咸供养
  于诸刹转极微劫　　所有如来照世灯
  我皆亲近而瞻奉　　令此解脱得清净

尔时善财童子。得此菩萨甚深自在可爱妙音解脱。入无边三昧海。成广大总持海。又得菩萨大神通海。深入菩萨大辩才海。速疾增长大欢喜海。观察守护一切城增长威德主夜神。以偈赞曰

  已行广大深智海　　已度无边诸有海
  长寿无患智藏身　　威光普照如满月
  觉悟法性如虚空　　普入三际皆无碍
  念念普缘一切境　　心心寂静无分别
  观察众生性本无　　大悲常入众生海
  自在游于解脱门　　广度群迷无量众
  观察思惟一切法　　证入甚深诸法性
  一切圣道普修行　　普化众生令解脱
  天是最胜调御师　　开示如来无垢智
  普为法界诸含识　　敷演离尘清净行
  已住如来诸愿道　　已入无边广大智
  已修一切诸佛力　　已见诸佛神通事
  天神心净如虚空　　普离一切诸烦恼
  了知三世无量刹　　诸佛菩萨及众生
  天神一念悉了知　　昼夜日月年劫海
  亦知一切众生类　　种种名相各差别
  十方众生生死处　　有色无色想无想
  随顺世俗悉了知　　引导令入菩提路
  已生如来誓愿家　　已入诸佛功德海
  已证法性心平等　　随众生乐现色身

时善财童子。说此妙偈赞夜神已。礼夜神足。绕无数匝殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。得此菩萨甚深自在可爱妙音解脱正念思惟。增长广大。精勤显示。普遍修行。即时往诣开敷一切树华安乐主夜神所。见其身在众宝香树枝条楼阁之内。坐大宝树妙藏师子之座。十千夜神。前后围绕。善财童子。顶礼其足。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知。菩萨云何学菩萨行。云何修行。成就增长。得一切智。唯愿慈哀为我宣说。夜神告言。善男子。我于此娑婆世界。日光已没。莲华覆合。诸人众等。罢游观时。见其一切。若山若水。若城若野。若异国土。如是等处。种种众生咸悉发心。欲还所住。迷失道路。惶怖不安。我皆密护。令其无畏。为放光明。示以正道。达其处所。令免众苦。宿夜安乐。若有众生。病苦逼恼。于梦寐中。令其安乐善男子。若有众生。盛年好色。爱着纵逸。五欲自恣。憍慢醉心。我为示现老病死相。令生恐怖舍离诸恶。永断无明离生死怖。复为称叹种种善根。令其修习。为悭吝者赞叹布施。为破戒者称扬净戒。有嗔害者令行慈忍。若懈怠者令起精进。若散乱者令修禅定。住恶慧者令学般若。乐小乘者令住大乘。勤修一切善巧方便。乐着三界诸趣中者。令住菩萨愿波罗蜜。若有众生福智微劣。为诸结业之所逼迫。种种障碍不自在者。令住菩萨力波罗蜜。若有众生其心闇昧无有智慧着我我所种种昏蔽。令住菩萨智波罗蜜。善男子。我得菩萨出生广大欢喜光明解脱门。善财白言。圣者此解脱门。境界云何。夜神言。善男子。入此解脱。能知如来种种福聚普摄众生善巧方便智慧光明。云何普摄善男子。一切众生所受诸乐。皆是如来威德力故。顺如来教故。行如来语故。学如来行故。得如来所护力故。修如来所印道故。种如来同类善根故。赞如来相似善果故。守护如来所说戒法故。随喜如来广大誓愿故。如来平等智慧日光之所照故。如来性净圆满业力之所摄故。以如是故。一切世间种种安乐。出现成就。云何知然。善男子。我入此出生广大欢喜光明解脱门时。正念思惟毗卢遮那如来应正等觉往昔所修菩萨行海。随顺观察。悉皆明见。善男子。世尊往昔为菩萨时。见一切众生着我我所。住无明闇室。入诸见稠林。为贪爱所缚。忿怒所坏。愚痴所乱。悭嫉所缠。种种烦恼。逼扰身心。生死轮回。贫穷困苦。不得值遇诸佛菩萨。我见是已。起大悲心。为欲利益一切众生。所谓起愿得一切妙宝资具摄众生心。愿一切众生皆悉具足资生之物无所乏心。于一切众事离执着心。于一切境界无贪染心。于一切所有无悭吝心。于一切布施无疑惑心。于一切果报无希望心。于一切荣好无羡慕心。于一切因缘无迷惑心。起观察真实法性心。起救护一切众生心。起深入一切诸法自性漩澓心。起于一切众生住平等大慈心。起于一切众生行方便大悲心。起为大法盖普覆众生令无热恼心。起以大智金刚杵破一切众生烦恼大障山心。起令一切众生速疾增长广大喜乐心。起愿一切众生究竟成就极安乐心。起随一切众生所欲雨一切财宝心。起以平等方便成熟一切众生心。起令一切众生满足圣财心。起愿一切众生究竟皆得十力智果心。起如是心已。得菩萨力。现大神变。遍满虚空最胜法界。于一切十方诸众生前。起一切相一切财一切布施无缘大云。普雨一切众宝璎珞资生之物。随诸众生心之所欲。悉满其意。皆令欢喜。如是无量布施摄门。种种财物。恒行惠施。于一切时。常无休息。不悔不吝。无间无断。以是方便。普摄众生。教化成就具足圆满。皆令得出生死苦难。救护饶益。不望其报。作意平等。心无分别。净治一切众生心宝。令其生起于一切佛。一相深密同一善根。应众生心。作众资具。摄取众生。增一切智。速疾圆满福德大海。菩萨如是。于念念中。尽无余界调伏成熟一切众生。令其皆得最胜清净。念念严净一切佛刹。令无杂秽。念念普入一切法界。念念皆悉遍虚空界。念念普入一切三世。念念以方便智调伏众生。念念恒于一切世界。普转一切不退法轮。念念恒以一切智道。善巧利益一切众生。念念普于一切世界种种差别诸众生前。尽未来劫。现一切佛成等正觉。念念普于一切世界一切诸劫。修菩萨行。不生二想。所谓普入一切广大世界海一切世界种中。所有一切种种际畔。诸世界种种庄严。诸世界种种体性。诸世界种种形状。诸世界种种分布。诸世界或有世界。秽而兼净。或有世界。净而兼秽。或有世界。一向杂秽。或有世界。一向清净。或有广大。或有狭小。或高或下。或粗或妙。或正或侧。或覆或仰。或圆或方。或非圆方。如是一切种种名字形像庄严。诸世界中。念念修行诸菩萨行。入菩萨住。现菩萨力。亦现三世一切佛身。随众生心。普使知见。速疾增长一切智智福德海门。善男子。毗卢遮那如来。于过去世。如是修行菩萨行时。见诸众生不修福德。无有智慧。远离惭愧。着我我所。无明翳障。出生种种不正思惟。入诸邪网恶见稠林。不识因果。顺烦恼业。迷惑其心。不得自在。堕于生死险难深坑。具受种种无量诸苦。起大悲心。修集一切波罗蜜行。为诸众生。称扬赞叹坚固善根。令其安住远离生死贫穷困苦。勤修福智助道之法。为说种种诸因果门。为说业报不相违返。为说于法证入之处。为说一切众生欲解。及说一切受生国土。令其不断一切佛种。令其守护一切佛教。令其舍离一切诸恶。又为称叹趣一切智助道之法。令诸众生心生欢喜。令行法施普摄一切。令其发起一切智行。令其修学诸大菩萨波罗蜜道。令其增长成一切智诸善根海。令其满足一切圣财。令其得入佛自在门。令其摄取无量方便。令其观察如来威德。令其亲近随顺如来寂静安乐。令其安住成就菩萨种种智慧

大方广佛华严经卷第二十二大方广佛华严经卷第二十三

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。白言圣者。发阿耨多罗三藐三菩提心。修此妙行。其已久如。夜神言。善男子。如汝所问。此事难知难信难解难证难入。难可显示。难可生起。难可演说。一切世间。诸天及人声闻独觉。皆不能知。唯除如来威力所加善知识所摄。修集广大福德智慧。其心坚固。欲乐清净。无下劣心。无杂染心。无谄曲心。无散乱心。无鄙吝心。无极闇心。得普照曜开敷一切智光明心。发普利乐成熟一切诸众生心。一切烦恼及以众魔无能坏心。起必趣向一切种智无障碍心。不乐世间一切生死染污乐心。能乐观察一切如来清净妙乐。能勤除灭一切众生忧悲苦海。能修一切诸佛如来功德法海。能观一切诸法实性虚空境界。能具一切广大甚深清净信解。能超一切生死暴流。能入一切如来智海。能决定到无上法城。能勇猛入如来境界。能速疾趣诸佛智地。能即成就一切智力。能于十力已得究竟。如是之人。乃能于此能知能入。能信能解。能持能了。随顺修行。何以故。此是如来智慧境界。一切菩萨尚不能知。况余众生。然我今当承佛威力。欲令调顺可化众生意速清净。欲令修习善根众生心得自在。随汝所问。为汝宣说。尔时开敷一切树华安乐主夜神。欲重明此义。观察三世如来境界。而说偈言

  佛子汝今之所问　　诸佛无边深境界
  难思刹海微尘劫　　具足演说无能尽
  非诸弊恶贪恚痴　　憍慢无明惑所覆
  垢心缠缚众生等　　能知诸佛寂静法
  非诸谄诳浊乱心　　常随悭嫉情无舍
  烦恼业绳之所系　　而能了知佛境界
  非是执着蕴界处　　心恒不舍于身见
  心倒想倒见倒人　　能入如来寂灭地
  寂静甚深诸佛境　　本性真常离分别
  非着诸有生死人　　入此平等无依法
  生于诸佛种姓家　　一切如来恒守护
  能持法王教藏者　　此仙智眼之境界
  亲近真实善知识　　爱乐白法无厌足
  专求佛力受法云　　彼闻此法生欢喜
  心恒清净无分别　　不着一切如虚空
  智灯自在破无明　　此无垢者之境界
  以大慈悲覆世间　　遍入三世众生海
  随宜利乐无边际　　此深行者之境界
  心常欢喜无诸着　　一切所有皆能舍
  乐说平等施众生　　此无著者之境界
  心无垢浊离诸过　　究竟调伏无忧悔
  随顺佛教能具修　　此无垢者之境界
  心无动乱无分别　　能普觉知诸法性
  远离一切诸惑业　　此解脱者之境界
  心无疲厌常无退　　勇猛勤修一切智
  安住增上净戒中　　此大丈夫之境界
  其心深入诸三昧　　究竟清凉无热恼
  已修一切智海因　　此寂静者之解脱
  了知诸法差别相　　善入无边深法界
  普度群生靡有余　　此慧灯者之解脱
  了达众生真实性　　于诸有海无所著
  如影普现心水中　　此先导者之解脱
  从于三世诸佛海　　方便愿种而出生
  尽诸劫刹勤修行　　此普贤者之解脱
  普入一切法界门　　悉见十方诸刹海
  亦见其中劫成坏　　此无二者之境界
  十方刹海极微中　　悉见佛坐菩提树
  成等正觉化群生　　此无碍眼之境界
  汝从无量大劫海　　亲近承事善知识
  为利群生求正法　　闻已忆念无遗忘
  毗卢遮那广大境　　无边无量难思议
  我承佛力为汝说　　令汝深心转清净

善男子。乃往古世过世界海极微尘数劫。有世界海。名毗卢遮那海真金摩尼山。彼世界海中。有佛出现名普照法界智慧山寂静威德王。善男子。其佛往修菩萨行时。能普清净彼世界海。其世界海中。有佛刹极微尘数世界种。一一世界种。有佛刹极微尘数世界。一一世界。有世界极微尘数劫。一一劫中。无量如来出兴于世。一一如来。说世界海极微尘数修多罗。一一修多罗。授佛刹极微尘数诸菩萨记。现种种佛神通力。说种种调伏众生法。转种种诸乘轮度无量众生海。善男子。彼毗卢遮那海真金摩尼山世界海中。有世界种。名普门现前庄严幢。此世界种中。有世界。名一切宝色吉祥普照光明。以现一切化佛影像摩尼王为体。形如天城。以现一切如来菩提道场。摩尼宝王。而为庄严。住于一切宝拘苏摩华海上。净秽相杂。此世界中。有须弥山极微尘数四天下。有一四天下最处其中。名一切宝山幢。其四天下。一一纵广无量百千由旬。一一各有一万大城。其阎浮提中。有一王都。名妙宝娑罗庄严云灯。以十千大城而为眷属。周匝围绕。阎浮提人寿万岁时。中有轮王。名一切法圆满宝盖大师子吼声。其王具有五百辅臣。六万采女。七百王子。其诸王子。色相端严。勇健雄猛。有大威力。尔时彼王威德普被阎浮提内。无有怨敌。时彼世界。劫欲尽时。有五浊起。一切人众。寿命短促。资财乏少。形色鄙陋。行住坐卧。多苦少乐。不修十善。专作恶业。更相忿诤。互相倾夺。欺诳诈伪。绮饰言辞。离间于他。发粗恶语。妒他荣好。非法贪求。深入邪网稠林旷野。以是因缘。风雨不时。苗稼不登。药木华卉。园林草树。一切枯槁。衣食匮乏。多诸疫病。驰走四方。靡所依怙。咸来共绕王都大城。无量无边。百千万亿。四面周匝。高声大呼。或举两手。或复合掌。或以头叩地。或举手推胸。或屈膝长号。或踊身大叫。头发蓬乱。衣裳弊恶。皮肤皴裂。面目无光。彼诸众生。以种种形貌出种种音声。作种种言辞。为种种谈说。而白王言。大王大王。我等今者。贫穷孤露。饥渴寒冻疾病衰羸众苦所逼。种种困厄迫切身心命将不久。无依无救无所控告。如在牢狱。死相现前。我等今者。来归大王。我观大王仁慈智慧。于大王所。生得安乐想。得怜愍想。得爱敬想。得身命想。得摄受想。得宝藏想。遇津梁想。逢道路想。值船筏想。见宝洲想。获财利想升天宫想。离怨家想。灭众苦想

尔时大王。闻此语已。获得百万阿僧祇大悲门。一心思惟。作意观察。发于十种大悲之语。云何为十。所谓哀哉众生堕落无底生死深坑。我当云何而速免济。令其得出。安住如来一切智地。哀哉众生为诸烦恼。逼迫身心。我当云何而作救护。安住种种善业道中。哀哉众生恒为种种生老病死之所恐怖。我当云何为作归依。令离缚着。永得一切身心安隐。哀哉众生常为世间。种种恐怖。逼害其身。我当云何。而为救护。令其得免一切厄难。安住如来一切智道。哀哉众生无有智眼。常为身见疑惑所覆。我当云何为作方便。令其得决疑见翳瞙。哀哉众生。常为痴暗之所迷惑。远离善法。我当云何。为作慧炬。照彼无明。令其显见。一切智城究竟解脱。哀哉众生常为种种悭嫉谄诳。浊乱其心。我当云何。而为开晓。令其证得清净法身。哀哉众生长时漂溺一切世界生死大海。我当云何。为作船筏。而普运度。令其得入一切智海。哀哉众生诸根刚强。远离调御无上大师。一切世间无能调者。我当云何。而为调御。令其成熟一切善根。具足如来大威神力。哀哉众生犹如盲瞽。不见正道。随逐邪径。我当云何。开其慧眼。而为引导。令其得入一切智门。时彼大王。兴此十种大悲之心。作是语已。即于王都大众之中。击鼓宣令。咸使闻知。我今普施一切众生。随有所须。悉令充足。即时颁下阎浮提内大小诸城。及诸聚落。悉开库藏。出种种物。置四衢道。所谓金银琉璃。摩尼等宝。衣服饮食。华香鬘盖。涂香末香。种种璎珞。宫殿屋宅。床榻敷具。一切资财。无不备足。建大光明摩尼宝幢。其光触身。悉使安隐。灭除黑闇。开发照明。随心所欲。皆悉圆满。又复随化种种身形。一切承事。供养恭敬一切众生。亦施一切病缘汤药。活命资具。种种宝器。盛众杂宝。所谓金刚器中。盛种种香宝。香器中盛种种衣。摩尼妙宝。庄校严饰。辇舆车乘。众宝璎珞。宝帐宝网。周围垂覆。建立种种高胜妙幢。如是一切资生之物。悉开库藏。而以给施。亦施一切村营城邑。山泽林薮。妻子眷属。及以王位。头目耳鼻。唇舌牙齿。手足皮肉。心肾肝肺。大肠小肠。脂膏筋脉。一切肢分。内外所有。悉皆能舍

尔时妙宝娑罗庄严云灯王城东门。名摩尼山威德。于其门外。有施会处。其地广博。清净平坦。无诸坑坎。荆棘沙砾。一切皆以妙宝所成。散众宝华。烧诸妙香。无数摩尼王宝。庄校严饰。然诸宝灯。周遍照曜。宝焰吉祥。威德香云。充满虚空。无量宝树。次第行列。微妙分布。间错庄严。种种天人宫殿楼阁。种种庄严。种种幢幡。种种缯盖。常出光明。宝拘苏摩网。一切香王宝网。弥覆其上。宝铎徐摇。出妙音声。无量百千亿那由他诸音乐器。恒出妙音。如是一切。皆以妙宝而为庄严。悉是菩萨净业果报之所成就。于彼会中。置师子座。十种妙宝。以为其地。十宝栏楯。放大光明。十种宝树。枝叶扶疏。周匝围绕。靡不严好。微妙坚固。金刚宝轮。以承其下。以一切宝。为龙神像。而共捧持种种宝物。以为严饰。于交露间。标题德相。以种种色。间错庄严。一切宝幢。一切宝幡。周遍行列。众宝铃网。摩尼宝网。众宝华网。大摩尼王网。以覆其上。无量宝香。常出香云。种种宝衣。处处分布。百千种乐。出过诸天。恒奏美音。悦可人意。复于其上。张施宝盖。常放无量宝焰光明。如阎浮金炽然清净。垂诸华璎。无数摩尼宝王为带。周回间列。种种杂色摩尼宝铃。恒出妙音。劝诸众生。修行十善。时一切法圆满宝盖。大师子吼妙音声王。处师子座。具足妙色。形容端正。人相圆满。最胜清净。世无能比。毗卢遮那摩尼宝王。以为其冠。那罗延身。不可沮坏。一一肢分。悉皆圆满。性普贤善。王种中生于财及法。皆得自在。辩才无碍。智慧明达。以正治国。无违命者。一切众生。咸赞彼王无量无边殊胜功德。光明炽盛。过天帝释。见者无厌。常于空中。现大轮盖。摩尼宝藏。其数百千。以为轮辐。无数宝焰。吉祥威德。光明庄严阎浮檀金。放清净光。以覆其上。种种宝色。金网庄严。真珠璎珞。周匝垂下。又以宝绳。悬众宝铃。众宝庄校。恒吐妙音。过诸天乐。觉悟世间。宣扬善行。复有妙扇宝缕织成。扇以香风。发扬威德

尔时于此阎浮提内。无量无数百千万亿那由他众生。种种国土。种种族类。种种眷属。种种形貌。种种衣服。种种言辞。种种心行。种种欲乐。各各希求。种种财宝。种种资生。种种受用。俱来此会。观察彼王。以种种言语。种种训释。种种辩才。种种名句。咸叹此王。是大智人。是福须弥。是胜功德圆满白月。是得自在。无碍丈夫。住菩萨愿行广大施。时王见彼诸来集会。于己乞求。生爱敬心。生悲愍心。生欢喜心。生尊重心。生广大心。生善友心。生相续心。生精进心。生不退心。生舍施心。生周遍心生平等心。生清净心。生成就心。生速疾心。生见种种善知识心。善男子。尔时彼王。见诸乞者。心大欢喜。经须臾顷。假使转轮圣王。尽无边劫所受快乐。所不能及。如是忉利天王。夜摩天王。兜率陀天王尽百千亿那由他劫所受快乐。亦不能及。善化天王。于无数劫所受快乐。自在天王。于无量劫所受快乐。大梵天王于无边劫所受梵乐。光音天王。于难思劫所受天乐。遍净天王。于无尽劫所受天乐。净居天王不可说劫住寂静乐。悉不能及。譬如有人。仁慈孝友。遭逢世难。父母兄弟。姊妹妻息。内外宗亲。并皆散失。忽于旷野道路之间。而相值遇。瞻奉抚对。情无厌足。时彼大王。见来乞者。心生爱敬。欢喜踊跃。庆幸之心。亦复如是。善男子。其王尔时。因善知识。于佛菩提。解欲增长。诸根成就。信心清净。欢喜圆满。不可思议。何以故。此大菩萨。勤修诸行。求一切智。愿得利益一切众生。心无懈倦。愿得充足一切众生衣服饮食。愿获菩提。无量妙乐。舍离一切诸不善心。常愿积集一切善根。常愿救护一切众生。常乐观察萨婆若道。常乐修行一切智法。满足一切众生所愿。入一切佛功德大海。破一切魔业惑障山。随顺受持一切佛教。行一切智无障碍道。已能深入一切智流。一切法流。常现在前。大愿无尽。为大丈夫。住大人法。积集一切普门善藏。愿舍一切执着之心。不染一切世间境界。知诸法性犹如虚空。于彼一切诸来乞者。生一子想。生父母想。生福田想。生善友想。生难得想。生恩益想。生覆护想。生坚固想。生导师想。生如来想。不拣方处。不择族类。不选形貌。随有来至。如其所欲。随其方处。随其国邑。如彼所求。如彼爱乐。以大慈心。平等无碍。以大舍光。照明一切。应众生心令无所乏。求饮食者。施与饮食。求衣服者。施与衣服。求香华者。施与香华。求鬘盖者。施与鬘盖。如是有求。幢幡璎珞。宫殿园苑。象马车乘。床座被褥。金银摩尼。真珠琉璃。璧玉珂贝。诸珍宝物。一切库藏。及诸眷属。采女妃嫔。城邑聚落。园林屋宅。皆悉如是。普施众生

时此会中。有长者女。名宝光明。与六十童女。眷属围绕。端正殊妙。人所喜见。皮肤金色。目发绀青。胜妙圆满。色相具足。身出妙香。口演梵音。上妙宝衣。以为严饰。常怀惭愧正念不乱。有大智慧。动止安详。具足威仪。恭敬师长。最胜清净。心无放逸。常念顺行甚深妙行。所闻之法忆持不忘。宿世善根。流润其心。相似妙果靡不成就。清净广大。犹如虚空。等安众生。常见诸佛。尽无余界。求一切智。去王不远。合掌顶礼。以恭敬心。作如是念。我得善利。我得善利。我今得见大善知识。最难见者。于今得见。时女于王。生大师想。生于最胜善知识想。具慈悲想。能摄受想。其心正直。最胜清净。生于广大欢喜之心。即解自身所佩璎珞。持奉彼王。作是愿言。今此大王。能为一切无量无边无主无依无明众生。成就救护。利益照明。作所依处。愿我未来亦复如是。如彼大王所知之法所载之乘。所修之道。所具色相。所摄众会。无边无尽。难胜难坏。愿我未来。悉得成就。随彼大王所生之处。愿我常得随彼受生

大方广佛华严经卷第二十三大方广佛华严经卷第二十四

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时大王。知此童女。发如是心。作如是愿。观其意乐。而告之言。童女当知。随汝所欲。我皆与汝。我今所有一切皆舍。令诸众生。普得满足。一切平等。心无分别。随汝所愿。恣意取之。时宝光明女。信心清净。生大欢喜。速疾增长一切善根。即以妙偈。而赞王言

  昔此娑罗大城邑　　威德圣王未出时
  凡诸事物悉无堪　　可畏犹如饿鬼处
  一切众生相杀害　　窃盗淫佚性难调
  虚诳不实粗恶言　　杂秽乖离无义语
  常乐贪夺他财物　　恒怀嗔恚毒害心
  依邪恶见不善行　　从此命终堕恶道
  此诸非法众生类　　愚痴黑闇之所迷
  坏灭正法邪见兴　　由是天龙不降泽
  多历年岁无时雨　　百谷芽茎皆不生
  树木药草悉焦枯　　大小泉流亦干竭
  大王昔日未出时　　河池及井皆枯涸
  一切园苑尽荒芜　　白骨纵横犹旷野
  今得大王居宝位　　惠及一切诸群生
  油云膏雨被八方　　大地率土皆充满
  大王出兴为世主　　止诸盗贼息奸欺
  所有牢狱悉皆空　　一切茕独无忧怖
  昔时世界众生类　　好相杀害起怨仇
  饮啖血肉恣无厌　　今悉慈心互相视
  昔时国内诸众生　　贫穷裸露无衣服
  饥渴衰羸如饿鬼　　以草蔽身受寒苦
  大王今既兴于世　　稻粱甘果自然生
  劫波树藏出妙衣　　一切男女皆严饰
  昔日多求纵非法　　为竞微利相陵夺
  今时严具悉丰盈　　自在欢乐如天处
  昔纵迷心造诸恶　　放逸非分生贪染
  于他妻妾起邪淫　　乃至种种相侵夺
  今时所见他女人　　色貌端妍妙严饰
  心恒清净无染着　　知足犹如兜率天
  昔时世界诸众生　　妄言粗恶多离间
  恒起邪思灭正法　　谄曲杂秽随人意
  今时一切群生类　　悉皆舍离粗恶言
  音声柔软悦人心　　一切听闻无不喜
  大王今演妙法音　　众生闻者咸欣悦
  迦陵频伽梵声相　　诸天音乐无能及
  大王顶上殊胜盖　　一切妙宝所庄严
  琉璃藏宝吉祥竿　　覆以众妙摩尼网
  金铃自然出妙声　　其音超世无伦匹
  宣扬一切诸佛法　　除灭一切众生惑
  又此铃音广宣说　　现在十方诸刹土
  所有劫海一切佛　　具大名称诸眷属
  又复铃音次第演　　过去一切十方刹
  其中诸佛及刹名　　所转法轮无不尽
  铃中又出法轮音　　其声普遍阎浮界
  广说梵释及众生　　所依诸业皆差别
  人天闻此音声已　　各各自知诸业藏
  离恶向善勤修行　　安住诸佛菩提道
  王父号曰净光明　　王母名为莲华光
  当于五浊兴盛时　　出现为王治天下
  是时有一广大园　　园有五百莲华池
  一一百千树围绕　　摩尼华灯所弥覆
  于其一一池岸上　　建立千柱庄严殿
  以众杂宝为栏楯　　半月焰光恒普照
  彼王末世恶法生　　积年亢旱无时雨
  一切池水悉干竭　　所有草树皆枯槁
  大王将生七日前　　先现祯祥希有相
  众生瞻仰相谓言　　救护世者今当现
  尔时世界于中夜　　大地一切咸震动
  其中有一宝华池　　出大光明犹日现
  五百莲池所围绕　　八功德水咸充满
  流演普及阎浮地　　随其所至皆沾洽
  一切华林及药草　　百谷芽茎苗稼等
  所有枝叶及果实　　如是一切皆繁盛
  种种沟坑及堆阜　　乃至一切高下处
  如是所有阎浮地　　今时莫不皆平坦
  一切荆棘及沙砾　　阎浮所有诸杂秽
  如是皆于一念中　　变成众宝庄严地
  众生是时既见已　　欢喜相庆而称赞
  咸言我今得善利　　如渴乏人思美水
  时彼地主光明王　　即命辅臣并眷属
  前后导从千俱胝　　法驾游观诸园苑
  是时五百诸池内　　有一莲池名庆喜
  于池岸上有法堂　　王及夫人于此住
  时光明王语夫人　　我念曾于七夜前
  中宵山地皆震动　　此池中有光明现
  即时庆喜香池内　　忽生千叶宝莲华
  光明上彻须弥顶　　云网照耀如千日
  金刚妙宝以为茎　　阎浮檀金以为台
  净摩尼宝为华叶　　妙香光藏作须蕊
  大王生彼莲华上　　端然不动跏趺坐
  光明相好以庄严　　百千天众咸恭敬
  先王尔时大欢喜　　遽入华池自抚掬
  两手持以授夫人　　此是汝子应欣庆
  百千伏藏皆涌出　　一切宝树生妙衣
  诸天竞奏微妙音　　充满一切虚空界
  阎浮所有诸众生　　悉皆归向生欢喜
  合掌咸称如是言　　善哉救世今当出
  王时身放大光明　　普照一切诸群品
  一念能令四天下　　身病黑暗皆除灭
  夜叉罗刹毗舍阇　　一切毒虫诸恶兽
  所欲恼害众生者　　靡不隐蔽自藏匿
  衰毁讥苦诸无利　　种种灾难病所持
  如是众苦悉消除　　世间安乐咸欢喜
  凡是一切众生类　　互相瞻视如父母
  离诸怨害起慈心　　专意勤修一切智
  大王关闭诸恶趣　　开导一切天人路
  利益一切苦众生　　显示宣扬一切智
  我等今得见大王　　普获一切诸善利
  无主无归无导师　　一切如应悉安乐

尔时宝光明童女。以此妙偈。赞叹一切法圆满宝盖大师子吼妙音声王已。绕无量匝。合掌顶礼。曲躬恭敬。却住一面。时彼大王。普遍观察告童女言。善哉童女。汝能信知他人功德。甚为希有。何以故。一切众生。覆藏己过。扬人之短。称己有德。蔽他善根。不能信知他人功德。童女当知。一切众生。为诸愚痴黑闇覆盖烦恼缠缚。不识惭愧。不知报恩。无有智慧。其心浊乱。性不明了。本无志力。又退修行。如是之人。不信不解。不能了知菩萨如来所有功德。不能分别佛法僧宝最胜福田。不知一切诸佛菩萨清净法门。神通智慧随顺思惟。童女。汝今决定求趣无上正等菩提。能知菩萨如是广大甚深功德。能信能解。汝今生此阎浮提中。发勇猛心。修菩萨行。普摄众生。功不唐捐。如汝所愿。悉当成就。如是功德。如是福力。如是饶益。无不具足。王赞女已。以无价宝火光摩尼种种妙色所庄严衣。手自授与宝光童女。并其眷属。一一告言。汝诸童女。各各受取。着此妙衣。时诸童女。双膝着地。两手承捧。置于顶上。然后而着。既着衣已。右绕于王。头面作礼。时彼一切诸宝衣中。普出一切星宿光明。众人见之。咸作是言。此诸女等。皆悉端正。如净夜天星宿庄严。尔时夜神。告善财言。善男子。于意云何。尔时一切法圆满宝盖大师子吼妙音声王者。岂异人乎。毗卢遮那如来应正等觉是也。光明王者。净饭王是。莲华光夫人者。摩耶夫人是。宝光明童女者。即我身是。其王尔时。以四摄法。所摄众生。即此佛会大道场中。一切菩萨云集者是。皆于阿耨多罗三藐三菩提。得不退转。或住菩萨初极喜地。或离垢地。或发光地。或焰慧地。或难胜地。或现前地。或远行地。或不动地。或善慧地。或法云地。各各具足种种大愿。集种种助道。修种种妙行。备种种庄严。获种种清净。得种种神通。游种种自在。住种种解脱从种种方所来此会中。处于种种妙法宫殿。尔时能开敷一切树华安乐主夜神。为善财童子。欲明此解脱门义。而说偈言

  佛子我有广大眼　　普能观察于十方
  种种广大刹海中　　众生五趣轮回者
  亦见彼刹一切佛　　皆坐寂灭菩提树
  神通充遍于十方　　说法调伏诸群品
  佛子我有净妙耳　　普闻一切无尽声
  亦闻诸佛转法轮　　皆能信受生欢喜
  佛子我有他心智　　出过众生心境界
  无二无碍量无边　　一念悉了诸心海
  佛子我有宿命智　　能知过去诸劫海
  自身他身所受生　　一念分明皆悉了
  佛子我于一念知　　一切刹海极微劫
  佛及菩萨诸神通　　五道轮转众生类
  我亦知彼诸世尊　　初发广大菩提愿
  一切行海具修行　　乃至当成一切智
  亦知彼佛灌顶地　　具足无等菩提道
  方便说法悉不空　　我于一念皆明了
  亦知彼佛方便门　　转大法轮满世间
  涅槃无量诸功德　　法住久近皆能了
  亦知彼佛所调伏　　广大教法诸乘海
  显示一切诸世间　　种种差别皆明了
  我于无量无边劫　　修此喜光解脱门
  今为汝说真实义　　汝应爱乐勤修学

善男子。我唯知此菩萨出生广大欢喜调伏众生藏普光明解脱门。如诸菩萨摩诃萨。亲近供养一切如来。入一切智广大愿海。圆满一切如来愿海。得勇猛智。于一菩萨地。普入一切菩萨地海。得清净愿。于一菩萨行。普入一切菩萨行海。得自在力。于一菩萨解脱门。普入一切菩萨解脱门海。尊重恭敬诸善知识。增长善根。常无厌足。承事一切诸佛菩萨。勤求一切种智法门。爱乐观察。正念思惟。其心决定。恒无懈怠。不着一切利养恭敬赞叹名闻。于世资生。永离贪着。满众生心。如如意宝。心常爱乐一切智地。观察如来力无所畏佛不共法。勤求圆满一切菩萨波罗蜜行。远离谄幻。如说而行。常真实语。守护佛种。于一切智。其心不动。如大山王。而我云何能知能说彼功德行。善男子。此菩提场如来会中。有一夜神。名守护一切众生大愿精进力光明。汝诣彼问。菩萨云何。教化众生。令其发趣阿耨多罗三藐三菩提。云何严净一切佛刹。云何承事一切如来。云何能令一切如来皆悉欢喜。云何能于一切菩萨所学佛法。勤求修习。时善财童子。礼夜神足。绕无数匝。殷勤瞻仰。深心恋慕。辞退而去

尔时善财童子。往诣守护一切众生大愿精进力光明主夜神所。见彼夜神。在大众中。坐普照现一切众生宫殿影像摩尼王藏师子之座。普现法界差别影像。摩尼宝网弥覆其上。现一切日月星宿影像身。现随众生心普令得见身。现等诸众生差别形像身。现无边广大色相海身。现普现一切诸相威仪身。现普于十方悉能应现身。现普能成熟一切众生身。现广运速疾神通法云身。现利益众生相续遍满身。现常游虚空利益广大身。现一切佛所恭敬顶礼身。现增长一切众生善根身。现受持佛法恒不忘失身。现圆满菩萨广大誓愿身。现普光照耀充满十方身。现法灯普照除灭世闇身。现了法如幻无垢深智身。现远离一切尘闇法性身。现出生佛法觉悟一切身。现普智光照差别身。现究竟无患无烦恼身。现不可沮坏具足坚固身。现无所依住如来威力身。现性无分别体离垢染身。现性本清净显照诸法身

时善财童子。见彼夜神现如是等佛刹极微尘数差别身已。一心顶礼。举体投地。良久乃起。合掌瞻仰。于善知识。生十种心。何等为十。所谓于善知识。生同己心。令我精勤办一切智助道法故。于善知识。生自业果心。令我亲近发起清净胜善根故。于善知识。生庄严菩萨行心。令我速能庄严一切菩萨行故。于善知识。生成就一切佛法心。引导于我随顺修行诸佛道故。于善知识。生能生最胜心。令我生于佛境界中智光照故。于善知识。生出离心。令我修行普贤菩萨出离行故。于善知识。生能具足福智海心。令我积集成就福智白净法故。于善知识。生增长心。令我精进速疾增长一切智故。于善知识。生能具足诸善根心。令我志愿悉得圆满。令诸众生生欢喜故。于善知识。生能成办大利益心。令我自在利乐众生安住一切菩萨法故。成就一切种智道故。发是心已。得彼夜神与诸菩萨佛刹极微尘数同行。所谓同念心。常忆念十方三世一切佛故。同慧分别。决了一切法海差别门故。同趣善巧。开示一切如来妙法轮故。同觉。以等空智。觉悟一切三世教故。同根。成就菩萨净智光明。普照众生诸根海故。同心。善能修习无碍功德。庄严一切菩萨道故。同境。智光普照一切如来所行境故。同教。获一切智。照诸教海一切相故。同义。能以智慧。觉悟一切法自性故。同法住。深入一切法界海故。同勇猛。得不共法。摧灭一切障碍山故。同色身。随众生心。示现种种相好身故。同诸力勤求成就一切智力。不退转故。同无畏。其心清净。犹如虚空无障碍故。同精进。于无量劫。行菩萨行。无懈倦故。同辩才。得一切法无障碍智普光明故。同无等。身相清净。一切世间无能胜故。同爱语。凡所语言。令诸众生皆欢喜故。同妙音。能师子吼。普演一切法门海故。同满音。以圆满音。令诸众生随类解故。同净德。随顺修习一切如来净功德故。同净业。成就清净一切菩萨诸善业故。同智地。受一切佛所转法轮为众生故。同梵行。安住一切如来所行智境界故。同大慈。念念普覆一切国土众生海故。同大悲。兴大法云普降法雨。润泽一切诸众生故。同身业。以方便行。教化成熟诸众生故。同语业。以随类音。演说一切诸法门故。同意业。普摄众生。置一切智境界中故。同庄严。清净庄严一切十方诸佛刹故。同亲近。见一切佛出兴于世。皆亲近故。同劝请。请一切佛为诸众生。转法轮故。同供养。常乐供养承事一切诸如来故。同教化。调伏成熟一切世间诸众生故。同光明。普能自在。照了一切诸法门故。同三昧。普知一切十方世界众生心故。同充遍。以自在力。遍一切刹修诸行故。同住处。住诸菩萨神通海故。同眷属。一切菩萨共止住故。同趣入。普入世界微细处故。同心虑。普知广大诸佛刹故。同往诣。随顺往诣普入一切佛刹海故。同方便。悉能示现遍满一切诸佛刹故。同超胜。遍于一切诸佛刹中无与等故。同不退。普入十方。威德平等无障碍故。同破闇。得一切佛成菩提智普光明故。同无生忍。入一切佛道场众海。无染着故。同普遍。承事供养不可说刹诸如来故。同智证。随顺了知诸法门海。常相续故。同修行。现前勤求。顺行一切诸法门故。同希求。于清净法。周遍勤求。深乐欲故。同清净。集佛功德。而以庄严身口意故。同妙意。于一切法。正分别智。能明了故。同精进。勤求成就一切如来诸善根故。同净行。成就满足一切菩萨所行行故。同无碍。觉悟了知一切诸法皆无相故。同善巧。能于如来一切法中。智自在故。同随乐。随诸众生心之所乐。现境界故。同方便。善巧修习一切法门所应习故。同护念。得一切佛自在威力所护念故。同入地。得入一切诸佛菩萨所住地故。同所住。安住一切诸佛菩萨所证位故。同记别。普为一切诸佛如来授记别故。同三昧。于一念中普入一切三昧海故。同建立。于刹那中示现种种诸佛事故。同正念。正念随顺一切如来境界门故。同修行。尽未来劫勇猛精进。勤修一切菩萨行故。同净信。于诸如来无量智慧速疾爱敬极欣乐故。同舍离。灭除一切诸障碍故。同不退智。与诸如来智慧等故。同受生。应现成熟诸众生故。同所住。安住如来一切种智方便门故。同境界。能于甚深法性境界得自在故。同无依。永灭一切诸有染着所依心故。同说法。已甚深入种种法门平等智故。同勤修。于己身内。受持佛法。自体威德。所护念故。同神通。开悟众生。令修一切菩萨行故。同无行。不动深入一切十方诸刹海故。同神力。一念遍游十方一切世界海故。同总持。已得一切陀罗尼海普照门故。同秘密。了知一切修多罗中妙法门故。同甚深。解一切法离相清净如虚空故。同光明。放大光明。普照十方诸世界故。同智光。普照显示一切众生心体性故。同震动。为诸众生。现神通力。威德自在。普震十方诸佛刹故。同不虚。一切众生。种种方所。见闻忆念。皆悉令其心调伏故。同出离。普为满足一切菩萨诸大愿海。成就如来十力智故。同欣乐。随众生心。而为开示。令欢喜故。时善财童子。普遍观察守护一切众生大愿精进力光明主夜神。起彼十种极清净心。获此佛刹极微尘数菩萨同行。得是行已。心转清净。于善知识。发起无量无边欢喜。偏袒右肩。顶礼其足。合掌恭敬。一心瞻仰。以偈赞曰

  我发坚固自在意　　志求无上佛菩提
  今于圣者知识所　　而起自己无异心
  我以得见善知识　　普集无尽诸白法
  灭除一切众罪垢　　成就清净菩提果
  我因得见善知识　　普以功德庄严心
  尽未来劫诸刹中　　勤修利益众生道
  我念圣者善知识　　摄受饶益成就我
  为摄我故悉显示　　最胜寂静真实法
  关闭险难诸恶趣　　开示净妙人天路
  亦示一切诸如来　　所成种智无师道
  圣者希有无等伦　　是佛最胜功德藏
  无垢无量如虚空　　出一切智清净乐
  圣者福海量如空　　我今所见无边际
  念念之中能出生　　清净善根一切智
  仁今满我波罗蜜　　增我不可思议福
  令我冠佛妙法缯　　长我清净诸功德
  我念圣者善知识　　令我成满诸佛智
  我今誓愿常依止　　速疾成就诸白法
  我以善友饶益故　　一切功德咸具足
  欢喜普为诸众生　　教导宣扬一切智
  仁今与我为师范　　令我修行无上法
  我于无数亿劫中　　无能少报师恩德

尔时善财。说偈赞已。白言大圣。向所显现。不可思议菩萨境界。愿为我说。此解脱门。名为何等。发心已来。为几时耶。久如当得阿耨多罗三藐三菩提。夜神告言。善男子。此解脱门。名普化众生令生善根。我以得此解脱门故。悟一切法自性平等。入于诸法真实之性。证无依法。舍离世间。悉知诸法色相差别。亦能了达青黄赤白性皆不实无有差别。而恒示现无量无数清净色身。所谓种种色身。非一色身。无边色身。清净色身。一切庄严色身。普见色身。等一切众生形相色身。普现一切众生前色身。光明普照色身。众所乐见色身。见无厌足色身。相好清净色身。离一切恶净光普照色身。大力勇猛平等示现色身。一切世间甚深难得色身。一切世间无能映蔽色身。一切众生称叹无尽色身。念念观察种种庄严色身。示现种种诸形像云色身。出现种种形色显色色身。普现无量神力色身。普放一切众妙光明色身。一切净妙庄严色身。随顺成熟一切众生色身。随其心乐现前调伏色身。随所应度成就善根色身。现无障碍普光明照色身。净无浊秽广大光明色身。可爱端正增长不坏色身。具足庄严清净坚固色身。方便开示不思议法微妙光明色身。一切无能映夺色身。能映夺一切色身。无诸暗障色身。能破诸闇色身。普集一切诸白净法色身。具足势力大功德海色身。从于过去尊重恭敬为因所生色身。如虚空清净心所起色身。最胜广大超过妙宝色身。无断无尽大功德海色身。普遍出现大光明海色身。一切世间无依无别平等色身。遍满十方一切世界无碍色身。念念出现不可说不可说刹海显示种种色相海色身。增长一切众生种种欢喜心色身。摄取一切众生海色身。能于一一毛孔之中出师子吼说一切佛功德海色身。能净一切众生心性甚深信解海色身。决定解了一切法义无疑网色身。心无障碍种种光网普照耀色身。等虚空量净光明色身。能放广大摩尼宝王净光明色身。照现无垢法界影像色身。世无能比色身。种种妙相差别庄严色身。普照十方色身。随时示现应诸众生常不断绝色身。出生寂静调伏一切众生色身。善能除灭一切烦恼色身。一切众生功德福田色身。能清净一切教色身。一切众生所见不虚色身。现大智慧勇猛威力色身。无障碍普周遍色身。显示最胜利益世间色身。现能普集大慈海色身。普集大福山王色身。普光照现一切世趣影像色身。现能清净大智慧力色身。随顺一切世间正念色身。一切宝相光明色身。显示毗卢遮那藏色身。随顺一切众生寂静色身。一切智体相现前色身。现微笑眼能令众生普生净信色身。一切众宝最胜庄严普光明色身。不取不舍一切众生色身。无决定无执着色身。显示自在威力加持色身。显示诸法神通变化色身。种种如来善根光照色身。遍法界海远离诸恶色身。普现亲近一切如来道场众会色身。现能成就种种妙色海色身。普遍出现善行所流相似妙果色身。随所应化调伏众生色身。一切世间见无厌足色身。放种种色净光明色身。显示一切三世相海色身。能放一切焰海光明色身。显示无量圆满光明海色身。一切妙香光明普遍超诸世间色身。一一毛孔现不可说极微尘数日轮云色身。广大无垢月轮云威德色身。放无量色须弥山王妙华云光明色身。出生种种妙鬘云光明色身。显示一切宝莲华云色身。出兴一切烧香形像云普遍法界色身。念念普散一切末香藏云现前变化遍满十方色身。现一切如来广大愿云色身。现一切语言普演法海色身。现普贤菩萨形像身云色身。念念中现如是等诸色相身。充满十方一切法界。令诸众生或见色身。或闻说法。或随顺忆念。或亲近承事。或遇神通。或睹变化。如是种种不可思议自在威力。悉随心乐皆得开悟。应时调伏。舍不善业。善行圆满。善男子。当知此由往昔种种大愿力故。具一切智速疾力故。菩萨解脱广大力故。救护众生大悲力故。安乐众生大慈力故。勤求随顺不退力故。一切如来加持力故。作如是事。善男子。我入此解脱了知法性无有差别。而能示现无量色身。于一一身。显现无量诸色相海。于一一相。普放无量大光明云。一一光明。照现无量诸佛刹土。一一刹土现无量佛。出兴于世。一一如来显现无量大神通力。随诸众生心行不同。开发觉悟宿世善根。未种者令种。已种者令增长。已增长者。令成熟。于念念中。令无量众生于阿耨多罗三藐三菩提。得不退转。安住种种解脱门中

大方广佛华严经卷第二十四大方广佛华严经卷第二十五

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时夜神。告善财言。善男子。如汝所问。从几时来。发菩提心。修菩萨行。如是之义。我承佛力。当为汝说。善男子。菩萨智轮。寂静圆满。远离一切分别境界。不可以生死妄想之中长短染净广狭多少。如是诸劫。分别显示。开悟众生。何以故。菩萨智轮。本性清净。离一切分别网。超一切障碍山。随所应化而普照故。善男子。譬如日轮体无昼夜。但出时名昼。没时名夜。菩萨智轮亦复如是。无有分别。亦无三世。但随世间及菩萨智轮威德力故。于无别中建立差别。教化众生。言其止住前劫后劫染净多少。善男子。譬如日轮住阎浮空。其影悉现一切净宝及以河海池沼器物诸净水中。一切众生莫不目见。而彼日轮不来至此。菩萨净智圆满日轮。亦复如是。出诸有海。住佛实法。寂静空中。无有所依。但为化度诸众生故。而于诸趣。随类受生。实不生死。亦无染着。无长短劫诸想分别。何以故。菩萨究竟离心想。见一切颠倒。得真寂见。见法实性。知诸世间如梦如幻无我无人。但以大悲大愿力故。放无垢光广大圆满。现众生前教化调伏。善男子。譬如船师常以大船。于河流中。不依此岸。不着彼岸。不住中流。而度众生。无有休息。菩萨摩诃萨。亦复如是。以波罗蜜船。于生死流中。不厌生死。不取涅槃。不住中流。而度众生。达于彼岸。无有休息。虽于无量无数劫中。常勤精进。修菩萨行。教化众生。未曾分别劫数长短。善男子。如太虚空。一切世界于中成坏而无分别。本性清净。无染无乱。无碍无厌。非长非短。尽未来劫。持一切刹。菩萨摩诃萨。亦复如是。以等虚空界广大深心。起大愿风轮。摄诸众生。令离恶道生诸善趣。悉令安住一切智地。灭诸烦恼生死苦缚。而无忧喜疲厌之心。善男子。如幻化人。虽复具足一切色身。肢体圆满。而无入息及以出息寒热饥渴忧喜生死十种之事。菩萨摩诃萨。亦复如是。以如幻智平等法身。现众色相。于诸有趣。住无量劫。教化众生。于生死中一切境界。亦无十事所谓无欣。无厌。无爱。无恚。无苦。无乐。无取。无舍。无安。无怖。善男子。菩萨智慧。虽复如是甚深难测。我当承佛威神之力。为汝解说。令未来世诸菩萨等。满足种种广大愿门。成就增长种种诸力

善男子。乃往古世。过世界海极微尘数劫。有世界。名宝光明。劫名妙光。于其劫中。有一万佛。出兴于世。其最初佛。号法轮大声虚空云灯王如来应正等觉。十号圆满。彼四天下阎浮提中。有一王都。名一切爱乐宝庄严。城东不远。有一大林。名曰妙光。于彼林中。有菩提树名宝拘苏摩华云。于其树下。有师子座。名毗卢遮那摩尼王莲华藏。时彼如来。于此座上。成阿耨多罗三藐三菩提。满一百年。坐于最胜菩提道场。为诸菩萨诸天世人。及阎浮提宿植善根已成熟者。演说正法。是时国王。名曰胜光。时世人民寿一万岁。其中多有杀盗。淫佚。妄言。绮语。离间。粗恶。贪嗔。邪见。不孝父母。不敬沙门婆罗门等。如是诸恶。增长炽盛。时王为欲调伏彼等恶法众生。令住十善。广大成就。造立囹圄。枷锁禁闭。无量众生。于中受苦。王有太子。名能胜性。端正殊特。人所喜见。最胜清净。妙色圆满。具二十八大人之相。处自宫中。采女围绕。遥闻狱囚楚毒音声。心怀伤愍。从宫殿出。入牢狱中。见诸罪人。杻械枷锁。递相连系。置幽闇处或以火炙。或以烟熏。或被榜笞。或遭膑割。裸形乱发。饥渴羸瘦。筋断骨现。号叫苦剧。太子见已。心生悲愍。发起利益救护之心。以无畏声。安慰之言。汝莫忧恼。汝勿愁怖。我当令汝悉得解脱。便诣王所。而白王言。狱中罪人。苦毒难处。愿垂宽宥。施以无畏。时王即集五百大臣。而问之言。是事云何。诸臣答言。彼罪人者。私窃官物。谋夺王位。盗入宫闱。罪应刑戮。不宜宽恕以乱王法。有哀救者。罪亦当死。时彼太子。闻是语已。悲心转切。语大臣言。如汝所说但放罪人。所有苦事。我悉代受。随其所应可以治我。我为彼等苦恼系缚一切众生得解脱故。粉身殁命。无所顾惜。要令罪人皆得免离。何以故。若我不救此等众生令解脱者。云何能救三界牢狱诸苦众生。一切众生在三界中。为诸贪爱之所系缚。入于种种黑闇稠林。愚痴所蔽。贫无功德。堕诸恶趣。身形鄙陋。诸根放逸。其心迷惑。不求出道。失智慧光。乐着三有。断诸福德。灭诸智慧。种种烦恼浊乱其心。住苦牢狱。入魔罥网。生老病死忧悲恼害。如是诸苦。常所逼迫。我当云何令彼解脱。是故应舍一切珍财眷属妻子。乃至身命。而救拔之。令彼狱囚而得离苦。时诸大臣。闻是语已。共诣王所。悉举其手。高声唱言。大王当知。如太子意。毁坏王法。祸及万人。若王爱念。不速治责。王之宝祚。亦不久立。王闻此言。赫然大怒。令诛太子及诸罪人。王后闻之。愁忧号哭。毁形降服。尘土坌身。与千采女及诸眷属。驰诣王所。举体投地。顶礼王足。俱白王言。唯愿大王。慈恕太子。赐其余命。王即回意。语太子言。此诸狱囚。罪在难赦。故我敕汝。莫救罪人。若救罪人。必当杀汝。尔时太子。为欲开发广大心故。为欲专求一切智故。为欲利益诸众生故。为以大悲普救摄故。其心坚固无有退怯。复白王言。愿恕彼罪身当受戮。王言随意。尔时王后。既见太子。悲救决定。复白王言。愿听太子半月行施。恣意修福。然后就戮。王即听许。是时王后。眷属妃嫔。蒙王许已。悲喜交集。不自胜任。时都城北。有一大园。名曰日光。曾是往古诸仙施场。太子诣彼。设大施会。须食与食。须衣与衣。乃至车乘。华鬘璎珞。涂香末香。幢幡宝盖。及余种种宝庄严具。随有所求靡不周给。经半月已。于最后日。国王群臣。后妃采女。长者居士。城邑人众。及诸外道。悉来集会。时法轮大声虚空云灯王如来。知诸众生调伏时至。即与大众。诣此施场。所谓天王围绕。龙王供养。夜叉王守护。乾闼婆王赞叹。阿修罗王曲躬顶礼。迦楼罗王以清净心散诸宝华。紧那罗王欢喜爱敬歌咏劝请。摩睺罗伽王一心观察瞻仰尊颜。与此众俱入彼大会。尔时太子。及诸大众。遥见如来相好端严。诸根寂定。如调顺象。心无垢浊。如清净池威德自在。如大龙王。现大神通。示大自在。种种相好。庄严其身。放大光明。普照世界。一切毛孔。出香焰云震动十方无量佛刹。出兴一切庄严具云。普雨一切诸庄严具。以佛威神功德之力。一切众生见者心净。增长欢喜销灭烦恼。尔时太子。及诸大众。既见如来种种威力。心意清净。踊跃无量。即于佛前。五体投地。顶礼佛足。安施最胜清净床座。合掌恭敬。而白佛言。善来世尊。善来善逝。唯愿哀愍。摄受于我。处于此座。以佛神力。净居诸天。即变此座。为香摩尼宝莲华藏师子之座。佛坐其上。诸菩萨众。各各就座。周匝围绕。眷属庄严。时彼会中。一切众生。因见如来。患苦销灭。垢障咸除。身器清净。堪受圣法。尔时能胜性太子。见彼人天一切世主国王大臣长者居士。乃至所有童男童女。诸外道等。众会集已。普遍观察。偏袒右肩。右膝着地。合掌恭敬。一心观佛。以偈赞曰

  梵释八部五通仙　　种种辩才同赞佛
  我以微力今随赞　　如蜂随于妙翅飞
  融金色相青莲眼　　销殄魔军过失除
  威仪严净德充盈　　十力智光恒普照
  住真寂乐无明尽　　能除欲醉断邪因
  截诸爱网利群生　　十力智光恒普照
  日光天子出现时　　虽能与世为明导
  种种惑乱蔽其心　　佛日自他无不照
  雪山住世自在魔　　龙为璎珞兽皮服
  常为女色之所昏　　十力智光恒普照
  月光天子耀世间　　净空列宿为严饰
  种种惑乱覆其心　　佛月自他无不照
  青莲华眼那罗延　　除灭修罗能变化
  随眠昏醉如胎藏　　十力智光恒普照
  帝释手执金刚杵　　威德能碎阿修罗
  常为女色昏醉心　　十力智光恒普照
  力贤三十三天主　　威势能破修罗军
  由昏欲箭中其心　　十力智光恒普照
  犀牛婆薮蚁楼仙　　五通神力无能制
  贪欲愚痴常醉心　　十力智光恒普照
  胜论数论意仙等　　一切外道常所宗
  痴网所缠坠欲泥　　十力智光恒普照
  说四围陀立世界　　八面四臂胜身天
  种种无明常自昏　　十力智光恒普照
  邪天爱欲无惭耻　　那延好杀无愧心
  鬼母血食害牛羊　　频那甘酒常昏醉
  唯有如来恒住世　　智眼常明如日光
  众生痴闇覆其心　　不见善逝常迷没
  我于善逝非亲属　　于诸异道亦非怨
  异道既非夺我财　　如来亦不与珍宝
  但以世尊清净语　　决定利益无怨亲
  涤除妄垢显心源　　故我归依无等者
  能尽未来一切劫　　利安一切诸众生
  拔苦与乐无懈心　　故我顶礼慈悲者
  瞻睹如来寂静月　　或起深信或生疑
  或敬或慢或怀忧　　究竟皆同解脱果
  佛开广大青莲眼　　妙相庄严功德身
  人天共赞不能量　　譬若万流归大海
  我此舌根少称赞　　所生微分妙善根
  普施法界诸众生　　愿证法身成正觉

尔时法轮大声虚空云灯王如来。知此太子及彼会中一切众生。堪受圣化。以圆满音。说修多罗。名普照圆满。因令诸众生随类各解。时彼会中。有八十那由他众生。远尘离垢。于诸法中。得净法眼。无量那由他众生。得无学地。十千众生。住大乘道。入普贤行。成满大愿。是时十方各百佛刹极微尘数众生。于大乘中。心得调伏。无量世界。种种佛刹。一切众生。免离恶趣。复过算数无量众生。生于天上。能胜性太子。即于此时。得此菩萨普化众生令生善根解脱门

善男子。尔时太子。岂异人乎。我身是也。我因往昔起大悲心。舍身命财。一切眷属。乃至人间安乐寿命。救彼狱中受苦系缚一切众生。皆令解脱。开门大施。心无障碍。供养于佛。令生欢喜。发菩提心。得此解脱。善男子。我于尔时。但为利益一切众生不着三界。心无依止。不求果报。无所希望。不贪世间。一切名称。不欲自赞轻毁于他不恋一切世间财宝。于所行施。离有相心。于诸世间种种境界。无所贪染。无所怖畏。但唯爱乐如来境界。净菩提心。心性坚固犹若金刚。成就众生。勤求匪懈。以大悲力。灭众生苦。以如来力。开发内心。观察菩萨诸清净行。庄严大乘出要之道。常乐观察一切智门。修诸苦行。得此解脱善男子。于意云何。彼时五百大臣。于胜光王作不善语。欲害我者。岂异人乎。今提婆达多等五百徒党恶比丘是。是诸人等。蒙佛教化。调伏成熟。皆已授与阿耨多罗三藐三菩提记。于未来世。过须弥山极微尘数劫。尔时有劫。名善光明。世界名宝光。于中成佛。其五百佛。次第兴世。最初如来。号曰大悲。第二名饶益一切众生愿月王。第三名大悲师子。第四名利益一切世间乃至最后。名曰医王。虽彼诸佛大悲平等。然为调伏诸众生故。种种国土功德庄严。种族父母。受生诞生在家出家。修菩萨道。往诣道场。降伏魔军。成等正觉。转正法轮。说修多罗。语言音声。显示神通。现大威力。光明众会。寿命法住。及其名号。各各差别。善男子。彼诸罪人。我所救者。即拘留孙等贤劫千佛是。尔时百万阿僧祇诸大菩萨。见彼如来无边威力。发阿耨多罗三藐三菩提心者。今于十方一切世界。行菩萨行。修习增长。如是菩萨。普化众生。令生善根解脱者是。时胜光王。今萨遮尼干子大论师是。时王夫人内宫采女。及诸眷属。即彼尼干六万弟子。与师俱来。建大论幢。共佛论议。悉降伏之与授阿耨多罗三藐三菩提记者是。此诸人等。皆当作佛。种种佛刹。种种庄严。劫数名号。各各差别。善男子。我于尔时。救彼罪人。令解脱已。父母听我。舍离国土。妻子财宝。一切眷属。于法轮大声虚空云灯王如来所。出家学道。于千岁中。净修梵行。即得成就百亿三昧门。百亿陀罗尼门。百亿神通门。百亿菩萨大法藏。能生百亿求一切智精进门。净治百亿安忍门。增长百亿思惟心。成就百亿菩萨力。深入百亿菩萨种智门。出生百亿般若波罗蜜门。得百亿十方诸佛现前门。具百亿菩萨大愿门。成就圆满如是法已。于念念中。十方各照百亿佛刹。于念念中。十方各游百亿佛刹。于念念中。忆念十方一切世界前后际劫百亿诸佛。于念念中。能知十方一切世界百亿诸佛大变化海。于念念中。能见十方百亿佛刹所有众生。种种趣类。随业所受。生时死时。善趣恶趣。好色恶色。其诸众生种种心行。种种欲乐。种种心性。种种根器。种种业习。种种出生。种种相续。种种成就。可调伏时。皆悉明了。善男子。我于尔时。命终之后。还复于彼阎浮提中。作转轮王。彼法轮大声虚空云灯王如来。般涅槃后。次即于此。值虚空高胜吉祥王如来。承事供养。令生欢喜。次为帝释。即此道场。值释梵主藏王如来。亲近供养。令生欢喜。次为夜摩天王。即于此界。值大地威德吉祥山如来。亲近供养。令生欢喜。次为兜率天王。即于此界。值法轮光明大声王如来。亲近供养。令生欢喜。次为妙变化天王。即于此界。值虚空智灯王如来。亲近供养。令生欢喜。次为他化自在天王。即于此界。值无能坏威力幢王如来。亲近供养。令生欢喜。次为阿修罗王。即于此界。值一切法音王如来。亲近供养。令生欢喜。次为大梵天王。即于此界。值普现变化影像法音王如来。亲近供养。令生欢喜。善男子。此宝光明世界妙光劫中。有一万佛。出兴于世。我皆亲近。一一承事。恭敬供养。令生欢喜。次复有劫。名曰日光。于彼劫中。有十万佛出兴于世。最初如来。名妙相好吉祥山。我时为王。名曰大慧。于彼如来。承事供养。令生欢喜。次有佛出。名圆满肩。我为居士。亲近供养。令生欢喜。次有佛出。名无垢童子。我为辅臣。亲近供养。令生欢喜。次有佛出。名勇猛持。我为阿修罗王。亲近供养。令生欢喜。次有佛出。名为妙光。我为山神。亲近供养。令生欢喜。次有佛出。名须弥相。我为树神。亲近供养。令生欢喜。次有佛出。名离垢臂。我为商主。亲近供养。令生欢喜。次有佛出。名师子游步。我为城神。亲近供养。令生欢喜。次有佛出。名天王宝髻。我为毗沙门天王。亲近供养。令生欢喜。次有佛出。名法高称。我为乾闼婆王。亲近供养。令生欢喜。次有佛出。名普光明冠。我为鸠槃茶王。亲近供养。令生欢喜。善男子。于彼劫中。此十如来。而为上首。如是次第。十万如来。皆悉供养。善男子。此世界中。次复有劫。名妙莲华。有六十亿如来。出兴于世。我常于此。受种种身。以种种威仪。往诣于彼一一佛所。亲近承事。以种种资具。恭敬供养。令生欢喜。教化调伏无量众生。令其成熟阿耨多罗三藐三菩提心。我又于彼一一佛所。得种种三昧门。种种陀罗尼门。种种神通门。种种辩才门。种种一切智门。种种法明门。种种智慧门。照种种十方海。入种种佛刹海。见种种诸佛海。显示甚深。普遍建立。清净成就增长广大。如于此妙莲华劫中。亲近供养。尔所诸佛。令生欢喜。于一切处。一切世界海极微尘数劫。所有如来。出兴于世。亲近供养。令生欢喜。一一如来。演说妙法。我皆听闻。闻已信受。守护忆持。为他广说。教化成熟一切众生。亦复如是。如是一切诸如来所。皆悉修习此解脱门。复得无量解脱方便。尔时守护一切众生大愿精进力勇健光明主夜神。欲重宣此解脱门义。即为善财。而说偈言

  汝发大心为世日　　问我难思解脱门
  我承佛力为汝说　　汝应一心而谛听
  往昔无边广大劫　　过于刹海极微数
  彼时刹号宝光明　　其中有劫名妙光
  于此妙光大劫中　　一万如来出兴世
  我皆亲近而供养　　从其修习此解脱
  时有王都名喜严　　纵广宽平极殊丽
  杂业众生所居住　　或心清净或作恶
  彼时有王名胜光　　恒以正法御群生
  太子名为能胜性　　形体端严备众相
  尔时幽系无量人　　犯王教令当受戮
  太子见已生悲愍　　上启于王请宽宥
  王集群臣议所应　　咸言太子危王国
  如是罪人应就戮　　如何悉救令除免
  时胜光王语太子　　汝救彼罪自当受
  太子哀念情转深　　誓救众生无退怯
  时王夫人采女等　　俱来王所白王言
  愿放太子半月中　　布施众生作功德
  时王闻已即听许　　设大施会济贫乏
  一切众生靡不臻　　随有所求咸给与
  如是半月日云满　　太子就戮时将至
  大众百千万亿人　　同时瞻仰俱号泣
  佛知众会根将熟　　慈悲来此化群生
  显现神变大庄严　　靡不亲近而恭敬
  佛以圆音方便说　　法灯普照修多罗
  无量众生意调伏　　悉蒙与授菩提记
  太子闻法生欢喜　　发兴无上正觉心
  誓愿承事于如来　　普为众生作依处
  自此出家依佛住　　修行一切种智道
  尔时便得此解脱　　大悲广济诸群生
  于中住止经劫海　　谛观诸法真实性
  常于苦海救众生　　精勤修习菩提道
  劫中所有诸佛现　　悉皆承事无有余
  咸以清净信解心　　听闻持护所说法
  次于佛刹极微数　　无量无边诸劫海
  所有诸佛现世间　　一一供养皆如是
  我念昔为太子时　　见诸众生系囹圄
  誓愿舍身而救彼　　因其证此解脱门
  经于佛刹极微数　　广大劫海常修习
  念念令其得增长　　成就无边巧方便
  彼中所有诸如来　　我悉得见蒙开悟
  令我增明此解脱　　及以种种方便力
  我于无量千亿劫　　学此难思解脱门
  诸佛法海无有边　　我悉一时能普饮
  十方所有一切刹　　其身普入无所碍
  三世种种国土名　　念念了知皆悉尽
  三世所有诸佛海　　一一明见尽无余
  亦能示现其身相　　普诣于彼如来所
  复于十方一切刹　　一切诸佛导师前
  普雨一切庄严云　　供养一切无上觉
  复以无边大问海　　启请一切诸世尊
  彼佛所兴妙法云　　皆悉受持无忘失
  复于十方无量刹　　一切如来众会前
  坐于众妙庄严座　　示现种种神通力
  复于十方无量刹　　示现种种诸神变
  一身示现无量身　　无量身中现一身
  复于一一毛孔中　　悉放无数大光明
  各以种种巧方便　　除灭众生烦恼火
  复于一一毛孔中　　出现无量化身云
  充满十方诸世界　　普雨法雨济群品
  十方一切诸菩萨　　入此难思解脱门
  悉尽未来诸刹劫　　安住修行菩萨行
  随诸心乐为说法　　令彼皆除邪见网
  示以天道及二乘　　乃至如来一切智
  一切众生受生处　　示现无边种种身
  悉同其类现众像　　普应其心而说法
  若有得此解脱门　　则住无边功德海
  譬如刹海极微数　　不可思议无有量

善男子。我唯知此菩萨普化众生。令生善根解脱门。如诸菩萨摩诃萨。超诸世间。现诸趣身。慧眼明彻。永离痴翳。不住攀缘。无有障碍。了达一切诸法自性。除灭众生无明黑闇。善能观察一切诸法。善巧方便。微细思惟。得无我智。证无我法。教化调伏一切众生。恒无休息。心常安住无二法门。于三宝境。得不坏信。究竟了知诸行生灭。善说三世清净实际。普入一切诸言辞海。而我云何。能知能说彼功德海。彼勇猛智。彼心行处。彼三昧境。彼解脱力。彼自在门。彼神通事。善男子。此阎浮提从菩提树。恒河西北。迦毗罗城。有一园林。名岚毗尼。彼园有神。名妙威德圆满爱敬。汝诣彼问。菩萨云何修菩萨行。生如来家。为无尽灯。光明照世。尽未来劫。难行能行。而无厌倦。时善财童子。头面礼敬彼夜神足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

大方广佛华严经卷第二十五大方广佛华严经卷第二十六

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。正念思惟。彼大愿精进力守护一切众生光明夜神。以解脱力。现等一切众生心所见身。现等一切众生形像身。现等无边色相海身。现等一切处方俗威仪海身。普门示现。如是等身。随诸众生心之所应。以种种方便教化成熟。令其开悟。增长善根。随顺修行。证入甚深菩萨解脱。善财。如是以正念力。忆持分别。彼主夜神所得解脱。所有教法。一一字句。名相体性。以总持力。忆念摄持。以慧解力。分明显示。以行愿力。发起广大。如是随顺。获得无量殊胜功德。渐次而行。度恒河北入憍萨罗国。向迦毗罗城。诣岚毗尼林。到已右绕周旋。求觅妙德圆满爱敬林神。见在林中大宝树下。庄严圆满宝楼阁中。坐摩尼藏师子之座。二十亿那由他诸林神女。前后围绕。广为演说一切菩萨受生海经。令其皆得生如来家。疾入菩萨大功德海。善财见已。顶礼双足。合掌前立。作如是言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何生如来家。云何行菩萨行。云何能作一切众生种种照世大光明灯。时彼林神。告善财言。善男子。菩萨有十种受生藏。若诸菩萨。成就此法。则能速疾生如来家。念念增长菩萨善根。不休不懈。不退不断。无厌倦无系缚。无疑惑。无迷乱。无怯弱。无恼悔。无遗失。一切智体。等十方界。随顺佛境。入法界门。不退广大菩提之心。增长一切波罗蜜行。舍离一切世间趣类。疾入一切如来智地。神通智力常现在前。种种佛法。皆能顺入。究竟获得真实义境。何等为十。所谓愿常供事一切诸佛菩萨受生藏。普遍成就菩提心菩萨受生藏。观诸法门方便修行菩萨受生藏。以深净心普照三世菩萨受生藏。平等光明普照一切菩萨受生藏。生三世一切诸如来家菩萨受生藏。佛力光明普遍庄严菩萨受生藏。微细观察普遍智门菩萨受生藏。法界变化种种庄严菩萨受生藏。速疾履践诸如来地菩萨受生藏。善男子。云何名愿常供事一切诸佛菩萨受生藏。善男子。此菩萨初发心时。作如是愿。我当亲近承事诸佛。及诸菩萨现见诸佛。恒生欢喜。于诸佛所。以尊重心。恭敬供养。无有厌足。增长净信。心无退转。积集功德。恒不断绝。为欲清净一切智性。积集善根。令增长故。是为菩萨第一受生藏。云何名菩萨普遍成就菩提心受生藏。善男子。此菩萨发阿耨多罗三藐三菩提心。所谓起深厚大悲心。于诸众生。能救护故。起供养诸佛心。令诸如来增欢喜故。起勤求正法心。于诸所有。无吝惜故。起所作广大心。令一切智悉现前故。起圆满大慈心。为普摄取一切众生。作饶益故。起不舍众生心被求一切智坚誓甲故。起无谄幻心。得如实智。普照一切差别法故。起如说而行心。修习菩萨一切难行诸苦行故。起不诳一切诸佛心。愿常守护一切如来大誓愿故。起一切智大愿心。尽未来际调伏众生。无断绝故。此十为首。有佛刹极微尘数菩提心大功德聚。若诸菩萨。成就此法。则得常生诸如来家。是为菩萨第二受生藏。云何名菩萨观诸法门方便修行受生藏。善男子。此菩萨。于一切法门海。起现前观察心。于一切智圆满道。起成就回向心。于诸威仪清净业海。起正念观察心。于一切菩萨种种三昧海。起普遍清净心。于一切菩萨种种功德海。起修习成满心。于一切菩萨道。起庄严出生心。于一切智精进功德。起如劫火炽然不休息心。于一切众生界。起令成就普贤行心。于一切威仪中。起修菩萨种种功德心。于真实中道。起舍离有无入真实正观心。是为菩萨第三受生藏。云何名菩萨以深净心普照三世受生藏。善男子。此菩萨成就清净增上深心。得佛菩提。光明遍照。深入菩萨方便法海。其心坚固犹如金刚。摄取众生。毕竟不舍。远离一切诸有趣生。成就如来种种神变。起于菩萨殊胜行愿。具足菩萨明利诸根。增长菩萨清净善心。成就不动大誓愿力。得诸如来之所护念。破坏一切诸障碍山。与诸众生。作所依怙。是为菩萨第四受生藏。云何名菩萨平等光明普照受生藏。善男子。此菩萨具修种种方便行海。调伏成熟一切众生。一切所有悉能弃舍。成就无边清净戒体。住佛境界。具足安忍得一切佛法忍光明。以大精进勇猛志力。趣向出生一切智体。勤修清净诸三昧门。成就一切神通智力。以智慧光。照明法界。得一切法差别光明。成就清净无障碍眼。见一切佛诸色相海。悟入一切甚深法性。自在教化成熟众生。能令世间皆生欢喜。勤修差别如实法门。是为菩萨第五受生藏。云何名菩萨生三世一切诸如来家受生藏。善男子。此菩萨生如来家。随如来住成满一切殊胜行门。具足三世如来愿海。得一切佛纯一善根。与一切佛同一体性。成就出世白净法行。安住普贤广大功德。入一切佛甚深三昧。见一切佛自在神力。所化众生。咸令清净。得佛平等回向法门。能随问答辩才无尽。是为菩萨第六受生藏。云何名菩萨佛力光明普遍庄严受生藏。善男子。此菩萨深入一切佛威神力。光明遍照。心不退转。游诸佛刹无有动作。承事供养菩萨众海。无有疲厌。如实了知诸法如幻。知诸世间悉皆如梦。见一切佛示现色身。所有相好。犹如光影。知一切佛神通所作。自在游戏。犹如变化。知诸有趣随类受生。如镜中像。知一切佛所转法轮。令众生闻。如空谷响。以方便力开法界门。咸令证入。到于彼岸。是为菩萨第七受生藏。云何名菩萨微细观察普遍智门受生藏。善男子。此菩萨住童真位。获得菩萨种种威仪。一切功德具足圆满。微细观察一切智门。于一一门。尽无量劫。开演分别无边菩萨所行境界。于诸菩萨甚深三昧。心得自在。成就最胜诸波罗蜜。念念普生一切世界诸如来所。能于一切差别境中。入于平等无差别定。于无差别平等法中。现于自在有差别智。于无量无边境中。自在入出无有障碍。于无境中。起于种种差别境界。于微小境中。见广大境。于广大境中。见微小境。知诸世间皆假施设。通达诸法因缘性相皆是自心之所现起。是为菩萨第八受生藏。云何名菩萨法界变化种种庄严受生藏。善男子。此菩萨于念念中。种种庄严无量佛刹。普随众生。现变化身。得无所畏最胜彼岸。示现种种诸佛威仪。成就种种方便善巧。依止清净无碍法界。随众生心。现众色相。令其见者无不调伏。普使安住不思议乘。具足开演成菩提行。行无障碍一切智道。相续出现。转于法轮。住无中边萨婆若海。随所应化。不失其时。常能平等。正念饶益。成就如来智慧之藏。是为菩萨第九受生藏。云何名菩萨速疾履践诸如来地受生藏。善男子。此菩萨悉于三世诸如来所。受灌顶法。悉知一切三世诸佛同一体性境界次第。所谓知一切世界随心现起相续次第。知一切众生前后殁生相续次第。知一切众生种种心念相续次第。知一切菩萨前后际劫凡所受生相续次第。知一切菩萨前后际劫所行之行相续次第。知一切菩萨所有修习种种智境相续次第。知一切诸佛前后际劫现成正觉相续次第。知一切法功能善巧亲近供养相续次第。知一切劫尽前后际若成若坏种种事相种种名号相续次第。知随所应度。现成正觉。功德庄严。开悟调伏。示现威力。智慧神通。转正法轮。令诸众生亲近供养。皆不失时相续次第。于无边众生界。以巧方便而调伏故。是为菩萨第十受生藏。善男子。如是菩萨十种受生藏。一切菩萨无不从生。若诸菩萨。为欲成就广大菩提。修习增长。圆满此法。则能积集种种功德。于一庄严中。出一切庄严。普遍庄严一切佛刹。示现变化种种威仪。普遍调伏诸众生界。尽未来劫。无有休息。诸佛法海。种种因缘。种种境界。展转流通。相续不断。现前觉悟。无不周遍。现不思议佛自在力。普遍充满虚空法界。于诸众生心行海中。为摄取故。而转法轮。普于十方一切世界诸如来所。亲近不舍。无量法云。普遍现前。以清净音。演诸法海。住一切处。所行无碍。以一切法妙光明网。庄严种种菩提道场。随诸众生心之乐欲。开演无边种种法藏。显示种种诸佛境界。随应开悟一切世间。尔时岚毗尼园妙德爱敬林神。欲重宣说菩萨广大受生藏义。以佛神力。观察十方。为善财童子。而说偈言

  最上无垢深净心　　见一切佛无厌足
  愿尽未来常供养　　此明慧者受生藏
  三世一切刹海中　　所有众生及诸佛
  悉愿救度恒瞻敬　　此名称者受生藏
  受法云雨无厌足　　普观三世无所著
  身心清净如虚空　　此无比者受生藏
  心恒游止大悲海　　坚固高胜如须弥
  通达一切种智门　　此自在者受生藏
  大慈遍覆于十方　　普行无垢波罗蜜
  以法光明照群品　　此雄猛者受生藏
  觉法自性心无碍　　生于三世诸佛家
  深入法界智无边　　此明慧者受生藏
  法身清净心无著　　普诣十方无量土
  一切佛力靡不成　　此难思者受生藏
  入深智海得自在　　住三昧海咸究竟
  观一切智方便门　　此实智者受生藏
  严净一切诸佛刹　　成熟一切诸群生
  现佛神力普庄严　　此大名者受生藏
  诸佛法智皆修习　　速能普入如来地
  了知法界皆无碍　　此真佛子受生藏

善男子。若诸菩萨。具此十种受生藏。则得生如来家。为诸世间作大明灯。善男子。我得此一切菩萨自在受生解脱门。无量劫来神通游戏。显示菩萨无碍境界。善财白言。圣者。此解脱门境界云何。林神答言。善男子。我先发愿。愿一切菩萨现受生时。我身皆得亲近供养。愿入毗卢遮那如来无量广大受生海。以昔愿力。而来生此娑婆世界。此四天下阎浮提中迦毗罗城岚毗尼园。于此林中。专念菩萨何时下生。经一百年。果见世尊从兜率天而来下生。善男子。尔时菩萨将下生时。此大林中。先现十种庄严瑞相。何等为十。所谓一者此林中地忽自平坦。坑坎堆阜。悉皆不现。二者林中所有荆棘瓦砾。不净之物。皆悉不现。金刚为地。众宝庄严。如欢喜园。柔软细妙。三者园中复有宝多罗树。其根深植。下至水际。次第行列。分布庄严。四者林中复现一切香芽。一切香藏。涂香末香。幢幡宝盖。及诸妙宝摩尼形像。种种香树荫映庄严。出过人天所有香气。五者林中复有诸妙华鬘宝庄严具。处处充满。微妙分布。六者林中一切诸大宝树。自然开发摩尼宝华。于华叶间。流出真金柔软鬘线。七者林中所有一切池沼。皆生妙华。柔软鲜洁。从地涌出。弥布水上。八者时此林中。娑婆世界。所有欲色诸大天王。及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽鸠槃茶等。一切世主。莫不来集合掌而住。九者此三千世界所有欲界诸天。采女。龙女。夜叉女。乾闼婆等及诸世主一切采女。皆生欢喜。各持种种诸供养具。向毕洛叉树。恭敬而立。十者十方所有一切诸佛。皆从脐轮放大光明。名菩萨受生种种自在灯。普照林中一切诸物一一光中。悉现诸佛受生诞生。所有神变。及现一切菩萨受生种种功德。又出诸佛种种言音。令诸众生咸得闻见。是为林中十种瑞相现此相已。时诸天王及诸世主。即知菩萨当欲下生。我时见此十种瑞相难思境界。心生欢喜。踊跃无量善男子。时菩萨母摩耶夫人。出迦毗罗城。入此林时。复现十种光明瑞相。普照一切。令诸众生得一切智。法性光明。速疾增长。欢喜爱敬何等为十。所谓于此林中。众宝楼阁。香芽香藏。悉放光明。普照十方一切世界。又此林中一切池沼。所有莲华。悉放光明。于光明中。出微妙音。演说如来真实法句。又令十方一切世界初发心菩萨。悉放光明。而来照此岚毗尼林。无不遍满。又令十方一切佛刹所有住地诸大菩萨。现大神变。放大光明。而来照此岚毗尼林。又令十方一切佛刹。修行成就。圆满一切波罗蜜行。诸大菩萨。放大光明而来照此岚毗尼林。又令十方一切佛刹。住大愿海诸大菩萨。悉放一切自在无碍愿智光明。而来照此岚毗尼林。又令十方一切佛刹。住大悲海诸大菩萨。悉放一切愿智光明。而来照此岚毗尼林。又令十方一切佛刹住方便海诸大菩萨。悉放种种调伏众生善巧光明。而来照此岚毗尼林。又令十方一切佛刹。诸大菩萨。悉放真实教智光明。而来照此岚毗尼林。又令十方一切佛刹。诸大菩萨。放一切佛自在下生出家成道大智光明。而来照此岚毗尼林。此十种光出现之时。普令除灭一切众生无明黑暗善男子。时摩耶夫人。现此十种光明相已。于毕洛叉树下。将欲诞生。复现十种广大神变。何等为十。善男子。菩萨将欲诞生之时。色界天王。及诸天子。欲界诸天。及诸采女。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽一切世主。并其眷属。为供养故。皆悉云集。时摩耶夫人。色相威德庄严殊胜。身诸毛孔咸放光明。如灯如日。如融金聚。普照三千大千世界。无所障碍。其中所有一切光明。咸皆饮蔽。悉不复现。除灭一切众生烦恼及恶道苦。是为菩萨将诞生时第一神变。又善男子。当尔之时摩耶夫人。于其腹中。悉现三千大千世界一切形像。其中百亿四天下阎浮提内。种种都邑。各有园林。名号不同。一一皆有摩耶夫人。各于树下。一切世主。并其眷属围绕而住。悉现菩萨将欲诞生不可思议神变之相。是为菩萨将诞生时第二神变。又善男子。摩耶夫人。于身一切毛孔之中。悉现世尊毗卢遮那过去所修菩萨行时。亲近供养一切诸佛。及闻诸佛说法音声。普震十方一切世界。诸所现境如于明镜及净水中。能现虚空日月星宿云雷等像。摩耶夫人身诸毛孔。所现如来过去所行神通等事。亦复如是。是为菩萨将诞生时第三神变。又善男子。摩耶夫人。身诸毛孔。一一皆现如来往修菩萨行时。所住一切世界海。一切世界种。世界体性。世界形状。及世界中。城邑聚落。山林河海。泉流池沼。所度众生。所经劫数。所有佛现。所入净刹。所有受身。所有寿命。所事善友。所得法门。所修行愿。所获果证。从初发心。乃至获得不退转地。于一切处。在在所生。摩耶夫人。皆为其母。如是如来过去所有一切境界。于毛孔中。靡不皆现。是为菩萨将诞生时第四神变。又善男子。摩耶夫人。一一毛孔。显现如来过去所修菩萨行时。凡所受生。种种色相。种种形貌。种种威仪。种种资具。衣服饮食。苦乐等事。一一明现。无不辨了。是为菩萨将诞生时第五神变。又善男子。摩耶夫人。身诸毛孔。一一皆现世尊过去修施行时。舍所难舍。身分肢节。头目耳鼻。唇舌牙齿。血肉骨髓。肝胆肠胃。皮肤筋脉。及其妻妾。男女眷属。宫殿城邑。及诸珍宝。金银琉璃。珂贝璧玉。璎珞环佩。衣服饮食。如是一切内外诸物。亦见受者。种种方处。形貌言辞。是为菩萨将诞生时第六神变。又善男子。时此林中。普现过去一切劫中。所有诸佛。入母胎时。种种佛刹。种种园林。种种庄严。种种眷属。及其种种幢幡伞盖。华鬘衣服。涂香末香。摩尼宝等。种种璎珞。诸庄严具。种种妓乐。歌咏赞叹。上妙音声。遍满林中。令诸众生。普得闻见。是为菩萨将诞生时第七神变。又善男子。摩耶夫人。从其身中胎藏之内。出现菩萨应所受用。摩尼宝王宫殿楼阁。超过一切天龙。夜叉。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。及诸人王之所住处。摩尼王网。罗覆其上。复以一切人天形像摩尼宝王诸庄严具。校饰庄严。熏以无垢上妙香王。令诸众生心得清净。如是一切。遍满林间。各各差别。不相杂乱。是为菩萨将诞生时第八神变。又善男子。摩耶夫人。从其腹中。出十不可说不可说百千亿那由他佛刹极微尘数菩萨摩诃萨。其诸菩萨。身形容貌。色相光明。进止威仪。神通眷属。一切皆与毗卢遮那菩萨等无有异。悉共同时。赞叹如来。是为菩萨将诞生时第九神变。又善男子。摩耶夫人。将欲诞生菩萨之时。忽于其前。从金刚际。出大莲华。名一切宝王庄严藏。以无能胜。金刚摩尼王宝为茎。以众生影像海摩尼王宝为藏。一切上妙摩尼王宝而作其须。清净无垢如意宝王。以为其台。有十佛刹极微尘数叶。一切皆以摩尼所成。周匝庄严。光辉间发。摩尼宝王。而为其网。周匝垂覆。坚固难坏。金刚宝王。而为其盖。以覆其上。一切天王。所共执持。一切龙王。起大香云。降注香雨。一切诸天。雨天妙华。及诸严具。一切夜叉王。恭敬围绕。一切乾闼婆王。出美妙音。歌赞菩萨往昔亲近供养诸佛所有功德。一切阿修罗王。舍憍慢心。曲躬恭敬。合掌顶礼。一切迦楼罗王。衔宝缯带。庄严虚空。一切紧那罗王。发欢喜心。歌咏赞叹菩萨功德。一切摩睺罗伽王。皆生欢喜。出大音声。歌咏赞叹。普雨一切宝庄严云。是为菩萨将诞生时第十神变。善男子。我见摩耶夫人。于此林中。将诞菩萨。示现十种神通之相。不可思议种种功德。无量光明。心无厌足。摩耶夫人。然后右胁而生世尊。如虚空中现净日轮。如高山顶出于庆云。如密云中而耀电光。如夜闇中然大火炬。尔时菩萨。从母胁生。身相光明。亦复如是。善男子。菩萨是时。为欲显示一切诸法。如影如像。如梦如幻。无去无来。无生无灭。示现诞生。善男子。我当见佛毗卢遮那。于此四天下阎浮提内岚毗尼园。示现初生神变之时。亦见如来。于三千大千世界百亿四天下阎浮提中岚毗尼园。示现初生种种神变。亦见于三千大千世界极微尘数佛利。亦见于百佛世界极微尘数佛刹乃至十方一切世界极微尘数佛刹。示现初生种种神变。亦见在于十方世界极微尘中。所有种种无量佛刹。一一皆现受生诞生种种神变。如是念念尽未来际。普于十方一切法界所有刹海。一一尘中无量世界。示现初生种种神变次第相续。无有间断。虽念念中。普遍一切无边刹海。示现诞生种种神变。而心无著。无有障碍

尔时善财童子。白妙德圆满爱敬吉祥岚毗尼园主林神言。圣者。菩萨云何住最后身。要生于此大族姓中。林神告言。善男子。一切菩萨。将成正觉住最后身。皆生王宫。或生大族婆罗门家。何以故。为能成就种种利益。调伏自他。令成熟故。善男子。能利自他。有三种法。一者异熟因果。二者福德因果。三者智慧因果。云何异熟。谓有八种。一者寿量圆满二者色相圆满。三者种族圆满。四者自在圆满。五者信言圆满。六者大势圆满。七者丈夫相圆满。八者勇力圆满。善男子。云何菩萨。寿命圆满。所谓寿命长远。久住世间。云何菩萨色相圆满。所谓形色端严。相好殊胜。人所乐见。心无厌足。云何菩萨种族圆满。所谓生于豪贵。刹帝利种。婆罗门家。云何菩萨自在圆满。所谓得大财位及大眷属。所作随心。人所宗奉。云何菩萨信言圆满。所谓出言诚谛。人必信受。理诸诤讼。心无高下。凡所决断。如执权衡。言行无违。无求无谄。云何菩萨大势圆满。所谓名称高远。勇猛精进。志性柔和。毁誉不动。工巧艺业。无能过者。处大众会。咸所尊重。云何菩萨丈夫相圆满。所谓具丈夫相。离诸残缺。云何菩萨勇力圆满。所谓报力殊胜。身常无病。心力勇健。有胜堪能。如是八法。是为菩萨异熟圆满。善男子。菩萨云何。修此八种异熟之因。所谓菩萨。于诸众生。起大慈愍。无杀害心。是为寿量圆满之因。若诸菩萨。于佛菩萨形像之前。及诸一切黑闇之处。施诸光明。及施种种鲜洁衣服。是为色相圆满之因。若诸菩萨。处于种种部类之中。心常谦下。是为种族圆满之因。若诸菩萨。于诸贫匮困厄众生。随心所欲。而行给施。是为自在圆满之因。若诸菩萨。常修实语。和合语。柔软语。不变异语。是为信言圆满之因。若诸菩萨为欲摄取未来世身。种种色相。殊胜功德。发大誓愿。供养三宝及善知识父母师长。心恒不舍。承事恭敬。无有断绝。是为大势圆满之因。若诸菩萨。心恒爱乐丈夫之身。于女人相。常生厌弃。怖畏女色。犹如猛火。于丈夫身。生福德想。亦劝众生厌离女身。欣丈夫相。是为丈夫圆满之因。若诸菩萨恒以身力。供事众生。如理作役。皆往营助。于师长处。按摩涂洗。及以种种上妙饮食。施诸饥渴。咸令充饱。令其安乐。色力增盛。是为勇力圆满之因。如是菩萨。修习八种异熟之因。感异熟果。善男子。如是八种异熟之因。复由三缘而得增长。能感圆满广大饶益殊胜异熟。云何为三。一者清净心。二者清净行。三者清净境。若诸菩萨。内心清净。所有善根。悉用回向阿耨多罗三藐三菩提。及证甚深一味法界。广大信乐。纯一无杂。勤求修习。不顾身命。与善知识。同一志行。见同法者。深生欢喜。日夜思惟。念念随顺。行住坐卧。心无厌足。是为第一发清净心。若诸菩萨。即于如是广大志乐所起善根。长时修习。念念无间。方便善巧。皆使成就。未受行者令得受行。已受行者令其坚固。是为第二行清净行。若诸菩萨。于彼一切所行境中。令心清净。能正发起。令行调柔。如是趣求。至究竟果。是为第三趣清净境。善男子。云何菩萨异熟果耶。谓由菩萨寿量具足故。能得长时无间修习。所有善根。积集增长。能久住世。自利利他。是为寿命圆满之果。又由菩萨色相端严众生爱敬故。一切大众咸来归仰。凡所发言。无不乐闻。既闻法已。皆悉顺行。是为色相圆满之果。又由菩萨种族真正故。世所宗重。令诸众生。随顺菩萨所有言教。精勤修习。速疾舍离诸不善业。修诸善业。是为种族圆满之果。又由菩萨自在圆满具足财位故。能以种种珍宝仆使。给施群生。随其所须。咸令充足。以此摄取然后调伏。而成熟之。是为自在圆满之果。又由菩萨成就实语故。能以爱语。摄诸众生调伏成熟。令其信受。皆得解脱。是为信言圆满之果。又由菩萨豪贵自在。有大势力故。能令众生。感德从化。心生惭愧。尊重爱乐。凡所出言随顺不逆。是为大势圆满之果。又由菩萨具足圆满大丈夫相。诸根成就无有残缺。是故堪为胜功德器。精进勤求一切智境。得无所畏无障碍行。能大饶益一切众生。所作随心。皆无障碍。一切世间诸天及人。无能讥毁。是为具足大丈夫相圆满之果。又由菩萨成就勇力故。普能积集一切善法。安乐成就诸众生界。勇猛精进。成就智通。是为勇力圆满之果。如是名为异熟因果。云何福智。谓施戒忍三波罗蜜。名之为福。般若波罗蜜。名之为智。精进禅定。亦名为福。亦名为智。谓因精进。修施戒忍慈无量等。则名为福。若因精进。起闻思修。则名为智。又因精进。修蕴善巧。处善巧。界善巧。缘起善巧。处非处善巧。能知四谛善不善法。烦恼胜劣黑白诸业。微细观察。皆名为智。若因禅定。修四无量。是名为福。若因禅定。修行般若。及诸善巧。则名为智。是故菩萨。能大饶益一切众生。于诸佛刹大众会中。而为师首。普能随顺一切诸佛。转正法轮。能自调伏。亦能调伏一切众生。令其速入一切智道。菩萨成就如是种种殊胜因果。即能疾得阿耨多罗三藐三菩提

大方广佛华严经卷第二十六大方广佛华严经卷第二十七

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。白林神言。圣者。得此解脱。其已久如林神告言善男子乃往古世过亿佛刹极微尘数劫。复倍是数。时有世界。名普宝劫名悦乐。八十亿那由他佛。于中出现。其第一佛。名自在功德无能胜幢。十号具足。彼世界中。有四天下。名种种庄严光。阎浮提中。有一王都。名清净庄严须弥幢。其中有王。名宝光焰眼。时彼大王。第一夫人。名大焰自在欢喜光。如此世界。阎浮提中。摩耶夫人。为毗卢遮那如来之母。彼种种庄严光世界阎浮提中。大焰自在欢喜光夫人。为彼最初自在功德无能胜幢如来之母。亦复如是。善男子。时喜光夫人。将欲诞生彼菩萨时。与二十亿那由他采女前后围绕。诣圆满广大金华园中。示现种种不可思议菩萨受生神通变化。时彼园中。有一楼阁。名清净妙宝峰。有大树王。名一切施。时彼夫人。即以右手攀彼树枝。于其右胁。诞彼菩萨。诸天捧持。香水沐浴。一切世主。广陈供养。时有乳母。名无垢光。侍立其侧。于是诸天。授与乳母。乳母敬受。以手抱持。生大欢喜。即得菩萨普眼境界三昧。得此三昧故。普见十方一切世界无量诸佛。复得此一切自在受生解脱法门。善男子。如初受胎识速疾无碍。得此三昧故。速疾能见十方诸佛乘本愿力受生神变。亦复如是

善男子。于意云何。彼时乳母无垢光者。岂异人乎。我身是也。时二十亿那由他采女者。今此林中我之眷属二十亿那由他诸林神女是。彼时夫人大焰自在欢喜光者。今摩耶夫人是。时彼大王宝光焰眼者。今净饭王是。善男子。我从是来。于念念中。常见毗卢遮那菩萨自在受生大神变海。善男子。如见世尊毗卢遮那。念念于此娑婆世界及此世界一一尘中。乘本愿力。自在受生神变海门。亦见世尊普于十方一切刹海所有世界及彼尘中。示现受生自在神变。如见现在。亦见如来尽未来际十方世界。及彼世界一一尘中。示现受生自在神变。善男子。如见今佛毗卢遮那普遍受生自在神变。亦见十方一切诸佛各乘本愿。遍一切处。尽前后际。所有世界。及彼世界所有尘中。一切世界。示现受生自在神变。皆得亲近承事供养。及闻诸佛所转法轮。皆能受持。随顺悟入。尔时妙德林神。欲重宣此解脱门义。承佛威力。观察十方。而说偈言

  善哉佛子汝所问　　最胜难知诸佛境
  深生尊重信乐心　　我说此因应谛听
  亿刹尘劫复倍是　　过彼有劫名悦乐
  八十亿数那由他　　诸佛于中相续现
  最初有佛出兴世　　号自在德无胜幢
  时我在彼金华园　　见彼如来诞生相
  彼时我身为乳母　　名无垢焰而供侍
  诸天授我菩萨身　　金色光明胜无比
  我时受得天人师　　捧持谛观不见顶
  左右身量无边际　　诸相圆满叵思议
  见彼离垢清净身　　相好庄严甚微妙
  犹如妙宝真金像　　欢喜自庆发净心
  思惟彼佛诸功德　　增长无量深福海
  见佛神通无与等　　即发广大菩提心
  专求一切佛功德　　增长一切诸大愿
  严净一切微尘刹　　灭除一切险恶道
  普于十方一切国　　供养诸佛无央数
  为求解脱遍修行　　愿灭一切众生苦
  我闻彼法能受持　　获此难思解脱力
  亿刹尘数无边劫　　具修菩萨清净行
  劫中次第所兴佛　　一一我皆曾供养
  受持其法备修行　　庄严净此解脱海
  亿刹尘数刹尘劫　　过去所有十力尊
  尽持其法亦修行　　此解脱轮转清净
  我于一念皆能了　　一切佛刹极微中
  所有一切诸如来　　各各庄严诸刹海
  彼诸刹海所有佛　　园中示现初诞生
  念念所现难思议　　广大自在神通力
  我见亿刹诸菩萨　　专求最胜佛菩提
  将成正觉住天宫　　显现难思诸佛境
  或见无边刹海中　　诸佛受生神变事
  一切众会共围绕　　广说正法令开悟
  我于一念能普见　　亿刹尘数诸菩萨
  出家降魔坐道场　　示现种种佛境界
  或见一切刹尘中　　无量仁尊成正觉
  各现难思方便力　　度脱一切苦众生
  或见一切极微内　　诸佛皆转妙法轮
  悉以无尽微妙音　　普雨无边甘露法
  于念念中见一切　　亿刹尘数诸佛刹
  悉有如来现受生　　及现涅槃无所著
  如是无量佛刹海　　如来于彼现初生
  我皆普往不分身　　一一现前兴供养
  不思议刹诸界趣　　无边品类诸众生
  悉以方便现其前　　雨大法雨令开悟
  佛子我悉能知此　　最胜难思解脱门
  设于无量亿劫中　　开示称扬不能尽

善男子。我唯知此菩萨于无量劫遍一切处示现受生自在神变解脱法门。如诸菩萨摩诃萨。能以一念。为一切劫发生之藏。开显证悟诸法本性。以善方便。普现受生。愿常供养一切诸佛。精勤究竟佛法现前。诸趣受身。如影普现。一切佛所。坐莲华座。随应化度。成熟众生。普于世间。现大神变。圆满大智。通达无碍。于诸三昧。皆得自在。示成正觉。转妙法轮。证入甚深无碍法界。了知一切众生心性。开示一切功德之相。发起广大心自在力。获得一切降魔怨智。顺入一切如来境界。随诸众生。普现色身。如是菩萨智功德行。而我云何。能知能说。善男子。从此西南。迦毗罗城。有释种女。名曰瞿波。汝诣彼问。菩萨云何。于生死中。成熟众生。行菩萨行。尔时善财童子。顶礼右绕岚毗尼神。经无数匝。殷勤瞻仰。恋慕一心。辞退而去

尔时善财童子。从岚毗尼林。向迦毗罗城。思惟观察。彼神所得诸佛受生自在神变菩萨解脱。思惟修习。增长广大。随顺悟入。忆持不忘。渐次行诣菩萨集会普现法界影像光明宫殿。其中有一主宫殿神。名无忧德。与一万主宫殿神。来迎善财。作如是言。善来丈夫。有大智慧。勇猛无畏。能修菩萨不可思议受生神变自在解脱。心恒不舍广大誓愿。善能观察诸法境界。心常安住无上法城。入于清净妙法宫殿。开示无量善巧方便。调伏众生。令其悟入成就如来功德大海。得佛无尽微妙辩才无碍智轮。随众生转。令其欢喜。增长大愿。回向趣求一切智道。我观仁者。于甚深行。心无暂舍。威仪寂静。无诸垢浊。不久当得如来无上清净最胜身语意业。以诸相好。庄严其身。十力智光。莹其心地。游行世间。作大光耀。我观仁者。勇猛精进。难可沮坏。不久当得普见三世一切诸佛相好圆满。普闻诸佛所转法轮。普能受用一切菩萨禅定解脱诸三昧乐。随顺证入如来境界。何以故。由汝已能见善知识。亲近承事。恭敬供养。随其教命。念其功德。修行不断。无忧无恼。不懈不退。无有障碍。一切世间天人魔梵不能为难。不久当成无上菩提。亦令众生证佛果故。时善财童子。闻是语已。白言圣者。如向所说种种功德。愿我一切悉当具得。圣者。我愿永息众生诸烦恼热。灭除众生诸不善业。与诸众生无上安乐。令诸众生修清净行。圣者。一切众生。心常散乱。起于烦恼。造诸恶业。随业流转。堕恶趣中。身心长夜。受诸楚毒。菩萨见之。心生忧恼。圣者。譬如有人唯有一子。爱念情至。忽见被人割截肢体。其心痛切。不能自安。菩萨摩诃萨亦复如是。见诸众生集不善业。堕三恶趣。受种种苦。心大忧恼。不能自安。若见众生起身语意三种善行。生于善道。受身心乐。生大欢喜。何以故。菩萨不为利益自身求一切智。亦不为贪种种生死诸安乐故。亦不为贪五欲乐故。亦复不为专求欲界眷属爱敬庄严乐故。亦复不随想倒。心倒。见倒。诸结随眠爱见力转。于诸众生恩爱缚着。心无贪恋。亦不味着诸禅定乐。亦无种种障碍厌退。住于生死流转沉溺。菩萨但见一切众生。于有海中。具受无边诸苦逼迫。起大悲心。愿皆摄取。令其速出生死大海。以悲愿力。勤行种种难行苦行。普断一切众生烦恼。令其出离。永无退转。是故精勤求于如来一切智智。承事供养一切诸佛。见诸杂染不净刹土。为其严净诸佛刹海。见诸众生种种名相皆无真实。令其皆得清净法身。见诸众生身心杂染。令得清净庄严三业。见诸众生心行不具。令其皆得清净具足。圣者。菩萨如是。于诸众生。大悲深厚。能行一切难行苦行。经无边劫。心不疲厌。一切所行。皆得成就。犹如父母。亦如乳母。如地如水。如火如风。如太虚空。如日如月。亦如大海。如同生天。能生种种圆满利益。云何菩萨犹如父母。为其安立菩提心故。云何菩萨犹如乳母。令其成就菩萨道故。云何菩萨犹如大地。譬如大地有十种事。何等为十。所谓犹如大地广大无量。普遍成就一切事物。菩萨摩诃萨亦复如是。成就无量广大福智功德之聚。又如大地。能生世间种种资具。一切众生依之存活。菩萨摩诃萨亦复如是。能生出世功德财宝。所谓布施持戒。忍辱精进。禅定智慧。菩提分等妙法资具。养育众生功德慧命。又如大地平等饶益。无忧无喜。无分别想。菩萨摩诃萨亦复如是。于怨亲所。都无爱憎。不生二想。又如大地能受大云所注之雨。菩萨摩诃萨亦复如是。能受如来大法云雨。又如大地。一切众生依之而住。菩萨摩诃萨亦复如是。与诸众生世出世间种种乐事。而为依止。又如大地。一切种子依之而生。菩萨摩诃萨亦复如是。一切众生善法种子依之生长。又如大地。能生众宝及诸宝器。菩萨摩诃萨亦复如是。能生众生种种法器诸功德宝。又如大地。能生众药灭除诸病。菩萨摩诃萨亦复如是。依大慈悲。出生法药。灭除种种烦恼重病。又如大地。诸恶毒虫腹行之类。种种触恼。安住不动。菩萨摩诃萨亦复如是。恒被一切内外诸苦触恼。身心终无摇动。又如大地。大雷龙吼。种种恶声。不惊不惧。亦无闻想。菩萨摩诃萨亦复如是。诸魔外道种种恶声。不惊不恐无忧无怖。亦无闻想。善男子。是为菩萨具足圆满十种功德。犹如大地自在成就善男子。云何菩萨犹如于水。譬如水大。能令一切药草丛林。及大树王。生成增长。菩萨摩诃萨亦复如是。以三昧水。出生一切菩提分法种种药草。增长福德智慧大树。成就无上菩提之果。云何菩萨犹如于火。譬如火大能烧一切不净之物。及能焚爇大地所有草木稠林。菩萨摩诃萨亦复如是。能以种种大智慧火。烧诸众生所有烦恼随眠习气不净罪垢。云何菩萨犹如于风。譬如风大无有色相。亦无住处。无依无著。而能成就世界所有水陆空行一切宫殿。及须弥等大小诸山。而一切人皆不能见。菩萨摩诃萨亦复如是。于一切处。无所依着。而能成就蕴界处等。菩萨功德。一切世间声闻缘觉所不能见。云何菩萨犹如虚空。譬如虚空体无障碍。一切诸法依之成就。菩萨摩诃萨亦复如是。本性无碍。一切白法因之成就。云何如月。譬如月轮。从初一日至十五日。渐次增长。乃至圆满。菩萨摩诃萨亦复如是。从初发心一切净法渐渐增长。乃至成佛坐菩提场。一切功德具足圆满。云何如日。譬如日轮。出现之时。一切黑闇。悉皆除灭。菩萨智日亦复如是。显现之时。一切众生。无明黑闇。悉皆除灭。云何如海。譬如大海性能出生一切众宝。令诸众生受用无尽。菩萨摩诃萨亦复如是。从福智海。出生一切功德智宝。饶益众生。终无有尽。云何如同生天。譬如二天。与人同生。随逐于人。如影随形。不相舍离。菩萨摩诃萨。亦复如是。常随众生。乃至恶道崄难之处。守护随逐。不令堕落。又善男子。菩萨摩诃萨。于诸众生。为大船师。令其得度生死海故。为归依处。令离诸魔烦恼怖故。为所恃怙。令除热恼得清凉故。为大津济。引诸众生。入法海故。为海导师。令至诸佛法宝洲故。为净莲华。开敷诸佛功德心故。为庄严具。福智光明恒庄严故。为可爱乐。令成普贤清净三业悉端严故。为堪尊重。令勤舍离诸恶业故。为普贤行。令成微妙圆满体故。为所乐见。令随所乐。无不现故。为大光明。普放智慧。光明焰故。为大明灯。照种种法。咸通达故。为能照耀。令菩提心性明净故。为大勇将。摧灭一切诸魔业故。为日珠宝。能放智焰光明网故。为月爱珠。放遍法界清凉光故。为大云雨。能雨一切甘露法故。圣者。菩萨如是修诸行时。令诸众生皆生爱敬。具足成就真实法乐。尔时无忧德神。与其眷属一万神俱。于其路侧。闻善财童子自说所发菩提心相。得未曾有。踊跃欢喜。即以一切出过诸天上妙华鬘涂香末香宝庄严具。散善财上。随顺围绕。入菩萨宫殿。而说偈言

  汝为诸众生　　发心求正觉
  当于无尽劫　　为世大明灯
  无量亿劫中　　难可得见汝
  大智日今出　　照明于世间
  汝见诸众生　　无明闇所覆
  能发大悲心　　履践无师道
  汝以清净心　　专求佛功德
  能事善知识　　不顾于身命
  汝心于世间　　无依无所著
  决定恒无垢　　清净如虚空
  汝修胜智行　　转妙功德轮
  放大智慧光　　普照无边际
  汝不离世间　　不着于世间
  如风游虚空　　所行无障碍
  汝向菩提行　　勇进难屈伏
  如劫火炽然　　一切无能灭
  无畏犹师子　　坚固如金刚
  汝智行亦然　　一切无能动
  十方法界中　　所有诸佛法
  汝事善知识　　一切皆能入

尔时无忧德神。以此妙偈。称赞善财功德行已。乐闻正法。随逐善财。如影随形。不相舍离。尔时善财童子。入普现法界影像光明宫殿。周遍观察。释女瞿波。见在堂内一切菩萨大集会中。坐于普现一切宫殿影像摩尼宝王大莲华藏师子之座。八万四千采女眷属之所围绕是诸采女。莫不皆从释种中生。悉于过去修菩萨行。同种菩萨一切善根。布施。爱语。利行。同事。摄诸群品。一切智境。常现在前。已集种种佛菩提行。恒住平等无尽大悲。普摄众生。犹如一子。慈心满足。广大清净。普能随顺一切众生。曾于过去修集种种不可思议善巧方便。皆于阿耨多罗三藐三菩提。得不退转。深入菩萨诸波罗蜜。具修菩萨一切学处。心常远离妄想执着。厌离生死。爱乐正法。虽行诸有。心常清净。恒勤观察一味法界。速疾趣求萨婆若道。离诸盖网。超众患难。得净法身。化现无量。调伏成熟一切世间。成就甚深功德大海。从普贤行之所出生。速疾增长勇健大力。智灯慧日圆满普照。尔时善财童子。即前顶礼释女瞿波。右旋围绕。合掌而立。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何于生死中。而能不着生死过患。菩萨云何了法自性。而能不住一切声闻辟支佛地。菩萨云何住于佛地。而能遍入诸菩萨地。菩萨云何住菩萨位。而能入佛种种境界。菩萨云何超于世间。而能成就世间之法。菩萨云何证得法身。而能示现种种色身。菩萨云何得无相法。而随诸众生现众色相。菩萨云何知法无说。而为众生广说诸法。菩萨云何知众生空。而恒不舍化众生事。菩萨云何常知诸佛不生不灭。而勤供养无有退转。菩萨云何超过一切幻化境界。而常起幻调伏众生。菩萨云何深信诸法本性如空。而成就无边方便智慧。菩萨云何知一切法无有执着。而常供养一切诸佛深心不退。菩萨云何深入诸行无业无报。而修善行无有休息。时彼释女。告善财言。善哉善哉。善男子。汝今能问一切菩萨所修诸行种性体相。若有能修普贤行愿。乃能发起如是之问。汝今谛听。善思念之。我当承佛威神之力。为汝宣说。善男子。若诸菩萨。修习十法。则能圆满因陀罗网普智光幢菩萨之行。何等为十。一者依止诸善知识。二者获得广大信解。三者发起清净乐欲。四者积集广大福智。五者于佛听闻正法。六者亲近三世诸佛。七者同修菩萨妙行。八者得佛共所护念。九者大悲本愿悉皆清净。十者能以智力永断生死。若诸菩萨成就此法。则能圆满因陀罗网普智光幢菩萨之行。善男子。若诸菩萨。亲近承事诸善知识。则能精进勇猛。不退修习。出生广大平等无尽佛法。佛子菩萨。复以十法。事善知识。常令欢喜。何等为十。一于身命财无所吝惜。二于世资具心不贪求。三知一切法本性平等。四一切智愿恒不退舍。五常乐观察实相法界。六于诸有海心不厌离。七知法无住犹如虚空。八发无障碍菩萨大愿。九普现其身遍诸刹海。十净修菩萨无碍智轮善男子。以此十法。承事一切真善知识。皆令欢喜。所行无逆。至一切智。尔时释女瞿波。欲重宣此义。承佛威力。观察十方。而说偈言

  专求佛智利群生　　普事一切善知识
  正直离谄心无怠　　此行于世帝网行
  胜解广大恒清净　　如空遍入于三世
  佛刹及佛与众生　　此是普智光幢行
  志乐广大等虚空　　离染寂静无边际
  于诸佛所修功德　　此行于世身云行
  菩萨积集一切智　　不可思议功德海
  清净福德智慧身　　此行于世无著行
  能于一切如来所　　听闻正法无厌足
  随闻生解为慧灯　　此行于世普照行
  十方三世所有佛　　一念一切咸亲近
  心恒不舍谛思惟　　此向菩提大愿行
  普诣一切如来所　　同修菩萨方便海
  三昧愿海悉无边　　此行于世帝网行
  得一切佛所加持　　处处修行普贤道
  尽未来际无边劫　　此行于世分身行
  见诸众生受众苦　　起大慈悲现世间
  演法光明除闇冥　　此行于世智日行
  见诸众生堕诸趣　　为集无边妙法轮
  令其永断生死流　　此是修行普贤行
  菩萨修行此十法　　则能普现众生前
  恒于有海诸趣中　　度脱一切群生类
  以大慈悲方便力　　普现种种庄严身
  随心为转妙法轮　　皆令趣向菩提道

尔时瞿波。说此偈已。告善财童子言。善男子。我已获得观一切菩萨三昧境界海解脱门。善财白言。大圣此解脱门境界云何。答言。善男子。我入此解脱。知此娑婆世界过不可说不可说佛刹极微尘数劫。一一劫中所有众生种种形类。作善作恶。死此生彼。于诸趣中。受诸果报。及其修习禅定解脱。等持等至。或有出离。或不出离。正定邪定。及以不定。或有善根与烦恼俱。或有善根不与烦恼俱。或有具足善根。或有不具足善根。或有不善根所摄善根。或有善根所摄不善根。如是所集善不善法。我皆了知。无有疑惑。又彼劫中。所有诸佛。出现于世。种种名号。相续次第。我皆了知。又彼一一诸佛世尊。从初发心。求一切智。所发一切大誓愿海。所事一切善知识海。所有供养一切佛海。所行一切菩萨行海。所有庄严佛国土海。所有圆满佛功德海。所有出现成正觉海。所有示现大神通海。所有方便转法轮海。所有调伏诸众生海。我皆了知。无有挂碍。亦知彼佛众会差别。其众会中。有诸众生。依声闻乘。而得出离。其诸声闻。过去所习一切善根。所有受持声闻乘法。及其所得种种智慧。我悉了知。其众会中。有诸众生。依独觉乘。而得出离。其诸独觉所有修习一切善根。所有证悟独觉乘果。所住寂静最胜解脱。所入三昧所现神通。所化众生乃至入灭。我皆了知。亦知彼佛菩萨众会圆满普遍无有边际。其诸菩萨从初发心。种善根时。发起无量种种大愿。修行种种难行之行。圆满成就诸波罗蜜。种种庄严菩萨之道。以自在力。入于菩萨种种诸地。所谓菩萨地。种种助道菩萨地。种种自在行菩萨地。种种入出三昧菩萨地。种种自在神通菩萨地。种种自在出现菩萨地。种种建立菩萨地。种种观察菩萨地。种种净治菩萨地。种种依止菩萨地。种种相菩萨地。种种体菩萨地。种种智。菩萨摄智。菩萨成就智。菩萨住处。菩萨广大行境界。菩萨大神通。菩萨三昧海。菩萨解脱方便海。菩萨所入三昧差别海。所得一切教智光明。所得一切智电光云。所获一切忍。所有一切勇猛智。所有悟解一切法海。所入一切诸佛刹海。所度一切诸众生海。所有显示诸方便海。所有发起诸神通海。所有深广诸弘誓海。我皆了知。善男子。此娑婆世界。从过去际。至今现在。不可说不可说佛刹极微尘数劫。所有种种差别劫海。所有众生佛及众会尽未来际。所有劫海展转不断相续次第。我皆了知。善男子。如知此娑婆世界。亦知婆婆世界中出生一切世界极微尘数世界相续次第。亦知娑婆世界内一切世界相续次第。亦知娑婆世界所有一切极微尘内所有世界相续次第。亦知娑婆世界外十方无间次第建立所住世界相续次第。亦知娑婆世界所依普照十方炽然宝光明刹种所摄一切世界相续次第。亦知毗卢遮那世尊在此华藏庄严世界海中十方无量诸世界种所摄世界相续次第。亦知华藏世界海中一切世界极微尘内所有世界相续次第。又亦知彼一切世界。种种安立。种种形状。种种分量种种依住。种种际畔。种种庄严。种种成就。种种灭坏。所有眷属。所有轮辋。所有旋转。所有莲华。所有须弥。所有河海。所有草树。种种名号。我皆了知。亦知此华藏世界海。往昔皆由毗卢遮那如来本愿力故。出生如是种种世界。所有种种诸因缘海。亦知华藏世界海外。十方无边尽法界虚空界。一切世界海中一切世界。亦知世尊毗卢遮那过去所经无量劫海。所有一切诸本事海。过去所发广大愿海。过去所集诸乘教海。过去所修菩萨行海。过去所净佛国土海。过去所事一切佛海。过去所化诸众生海。过去所起诸神通海。过去所入诸方便海。过去所受诸佛法海。过去所入诸三昧海。过去所得诸自在海。过去所成诸功德海。过去所施一切资具檀波罗蜜。过去所持种种梵行戒波罗蜜。过去所受种种境界忍波罗蜜。过去所修猛利勇健勤波罗蜜。过去所入种种三昧禅波罗蜜。过去所成种种清净慧波罗蜜。过去所现遍入世间诸影像身方便波罗蜜。过去所发清净圆满普贤行海愿波罗蜜。过去所获一切如来种种自在诸神通海力波罗蜜。过去所证一切如来智光照世自在智海智波罗蜜。普摄一切诸佛菩提。普获诸佛大智光明。证于诸佛一切智性。于一切处成等正觉。神通游戏。所转法轮。所有一切道场众会。其众会中。一切菩萨。过去所种一切善根。从初发心行菩萨行。积集方便。成熟众生。及彼菩萨所事诸佛。及善知识。念念增长。获诸三昧。念念所入陀罗尼门。念念所得辩才大海。念念所起自在神通。念念所修菩萨行网。念念所集诸方便门。念念所知众生根网。念念所集菩提分法。念念证入等持等至神通门海。如是一切。皆是毗卢遮那如来普遍十方一切法界无量劫海所修行海。我悉了知。亦知十方遍满法界尽虚空界。一切如来劫海所修。乃至尽于未来际劫。神力加持。幻智境界。如是一切。我悉了知。何以故。我入此观一切菩萨三昧境界海解脱门时。于一念中。尽能了知一切众生种种心行。杂染清净。流转还灭。一切声闻种种三昧。一切独觉寂静解脱三昧神通。一切菩萨种种三昧。种种地位。种种法门。种种趣入。及能了知一切如来解脱光明神通海故

大方广佛华严经卷第二十七大方广佛华严经卷第二十八

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财。白瞿波言。圣者得此解脱。其已久如。瞿波告言。善男子。我于往世过百佛刹极微尘数劫。有劫名最胜行。世界名胜无畏。彼世界中。有四天下。名常具众乐阎浮提。中有一王都。名大树妙高吉祥。于八十四千亿王都之中。最为上首。时此王都。复有八十四千亿城而为眷属。其诸城邑一一严饰。悉皆清净。毗琉璃宝以为其地。七重宝墙周匝围绕。一一皆以杂色影像光明宝网。以覆其上。其诸宝墙。一一皆以宝堑围绕。金沙布底。香水盈满。优钵罗华。钵头摩华。拘物头华。芬陀利华。弥布水上。此一一河。皆有自然众宝栏楯。及诸宝网。庄严其岸。一一河间。复有宝多罗树。七重围绕。复有自然宝庄严树。垂诸璎珞。衣服鬘带。真金宝网。弥覆其上。其诸城邑。往来之处。所有道路左右八步。皆以种种上妙杂宝。间错庄严。发耀舒光。辉映一切。又有无量持明咒仙。严洁其身。如自在天。经行游履。保护众生。又彼城邑。一一各有无量园苑游戏之处。华果树林。无不备足。杂类众鸟哀鸣和雅。游集其中。欢乐无畏。常有无量清净微妙可爱男女。止住其中。身出妙香。普熏一切。诸天昼夜常雨妙华。色类百千。缤纷乱坠。彼诸城邑。一一皆有百千地神。而为守护。其诸城邑。内外所有。众宝树林。璎珞鬘带。及宝铃网。诸庄严具。微风吹动。演出种种妙法音声。闻皆喜悦。烦恼销除。身意清凉。法喜充满。于阿耨多罗三藐三菩提。得不退转。具足普贤常所称赞妙行功德。彼时有王。名为财主。常以正法。化周率土。妃嫔采女八万四千。辅相大臣其数五百。五百王子色力具足。形相端严。勇猛无畏。能伏怨敌。王有夫人名莲华吉祥藏。威德殊胜。颜貌第一。所生太子名威德主。端正奇特。人所乐见。具足圆满三十二相。所谓足下平满。犹如奁底。千辐轮相。圆满备足。手足柔软。如兜罗绵。其指纤长。网缦成就。足跟齐圆。足趺丰起。一一相称。光洁妙好。双腨佣圆。如仙鹿王。垂臂过膝。犹如象鼻。马王阴藏。峰势隐密。一一毛孔。各生一毛。绀发右旋。螺文不乱。身皮金色。细薄润滑。一切尘垢。所不能着。手足肩项七处平满。臂膊佣圆。脊骨不现。周圆相称。如尼拘陀树。颐颔胸臆。犹如师子。颈如绀蒲三约成就。常光四照面各一寻。四十牙齿。鲜白齐密。舌相红赤。长广覆面。梵音清美。人所乐闻。目睫青润。齐整不乱。目上下瞬。犹如牛王。青白分明。面部圆满。犹如净月。眉相纤曲。如帝释弓。白毫皎洁。文相右旋顶有肉髻。犹如天盖。如是众相。庄严其身。善男子。太子有时。受父王教。与二十千妓侍采女。并诸眷属。前后围绕。从宫城出。诣光明云峰大香芽园。游观嬉戏。是时太子。乘阎浮檀上妙宝车。其车严饰。世无伦匹。大焰金刚以为其轮。天妙金刚以为其毂。香摩尼宝以为其箱。上妙栴檀间厕严饰。众宝华网弥覆其上。大庄严藏宝摩尼王为师子座。五百采女各执宝绳。牵驭而行。不迟不速。进止合度。宝马千匹。驾以金车。前后导从。白琉璃摩尼宝王以为其盖。放不思议一切希有杂色光明。摩尼宝王而为庄校。一切影像绀琉璃王摩尼妙宝而作其竿。使人执持随覆其上。百千万人持诸宝盖。百千万人持诸宝幢。百千万人持诸宝幡。百千万人奏诸音乐。百千万人散诸宝华。百千万人持诸香炉。烧众名香。前后围绕。而为翊从。其路宽平。八衢齐列。界以杂宝。布以金沙。种种宝华而散其上。杂宝行树及宝栏楯。于八衢间次第行列。覆以种种妙宝铃网。及诸缯彩悬布树间。以为严饰。于其路侧。处处建立义堂福舍。众宝楼阁。及诸仓库。递相连接。延袤远近。珍宝财物悉皆充满。或于其中。积诸珍宝璎珞严具。或积缯彩上妙衣服。或办甘美上味饮食。或贮香华身诸资具。或畜象马杂宝车乘。或复安置端正女人及诸僮仆。善闲一切世仪礼则。一切艺能无不成就。随诸众生有来求索。悉皆施与。靡不令其意愿充满。尔时大树妙高吉祥王都之中。有一母人。名为善现。有一童女。名具足艳吉祥。颜容端正。色相严洁。洪纤得所。修短合度。众相圆备。目发绀青。言同梵音。清彻美妙。智慧聪明。人所尊重。善达技能。精通辩论。恭勤匪懈。质直柔和。少欲寡思。慈愍不害。具足惭愧。无谄无憍。志量弘深。人无与等。及与其母。乘妙宝车。将诸眷属。无量采女前后围绕。先于太子。从王都出。歌咏嬉戏。随路而行。见其太子奏诸妓乐。言辞讽咏。心生爱染。而白母言。善哉慈母。我心愿得敬事此人。若不遂情。自当殒灭。时母善现。告其女言。汝今不应生如是念。何以故。今此仁者。是王太子。具足圆满转轮王相。不久当绍转轮王位。时有女宝自然出现。飞行乘空。有大威德。我今与汝。种族卑贱。非其匹偶。此甚难得。勿生是意。是时童女。其心决定。坚固不舍。时香芽云峰园苑之侧。有一道场。名法云光明。时有如来。名胜日身。于此道场。成等正觉。已经七日。是时童女。游观疲极。暂时假寐。时彼如来。即于梦中。为现神变。从梦觉已。时有宿世守护菩萨亲友使天。于虚空中。而告之言。童女汝向所梦。是胜日身如来。于香芽云峰园苑之侧。法云光明菩提场中。成等正觉。始经七日。诸菩萨众。前后围绕。及诸天龙。夜叉。乾闼婆。阿修罗。迦楼罗。紧那罗。摩睺罗伽。梵世诸王净居天等。并诸一切主河主海。主地主水。主风主火。主山主城。主园主药。主林主稼。主方主空。主昼主夜。身众足行道场神等。男女眷属。为欲见佛听闻法故。皆悉来集。汝今亦应亲近礼敬。时具足艳。吉祥童女。以于梦中。睹佛神变。得佛功德所加持故。其心无畏。安隐快乐。以其宿心。景慕太子。即于其前。而说偈言

  我身端正无等伦　　智慧色相皆圆满
  言辞礼则咸通达　　功德名闻遍十方
  世间无量诸众生　　见我身者皆贪着
  我于彼众恒清净　　曾不生于染爱心
  我心一切无憎爱　　亦离愚痴嗔恨心
  但以清净大慈悲　　究竟饶益诸含识
  我于今时见太子　　最胜功德相庄严
  其心大喜充遍身　　诸根悦乐思亲近
  色如净妙光明宝　　毛发绀青而右旋
  鼻高修直妙端严　　额广平正眉纤曲
  身如妙宝真金聚　　相好光明无等伦
  妙眼长广若青莲　　齿白齐密踰珂雪
  月面圆明师子颊　　口方唇赤色如丹
  所发曾无非法言　　愿最胜尊哀纳我
  舌相长广能柔软　　色若赤铜众宝光
  声如梵响紧那罗　　众生闻者咸欣悦
  发言现笑辞清妙　　威光蔽众德难量
  喜颜美貌自庄严　　能令见者无厌足
  心无垢染身清净　　三十二相所庄严
  必于此界作轮王　　唯愿慈悲垂纳受

尔时威德主太子。为于世间显示女人。多诸过患。障诸世间出世间乐。乃至能障无上菩提。于众会中。即为童女。而说偈言

  世间妄计诸宗族　　爱敬适悦唯女人
  一切最胜无比伦　　能成住止诸善伴
  女为第一人中宝　　亦作天人解脱因
  绍续胜种功德身　　世智说言女为胜
  一切热恼烧心苦　　种种烦冤所逼身
  妻慰令使得清凉　　譬如毒暑逢甘雨
  凡夫心没诸忧恼　　犹遭重病之所缠
  因妻佞媚所欢娱　　妄谓除忧最胜药
  邪见众生兴是念　　女人能为世界因
  生成长育福庄严　　天地变化无能胜
  勤劳世业唯由女　　劝夫普作诸善事
  能令男子随意转　　此女无染别人心
  智人所说诸烦恼　　一切过业由女生
  况取卑族以为妻　　世间极恶无过此
  女人弊执为其性　　如地坚住匪能移
  但随富乐荣贵迁　　贫贱衰羸咸弃舍
  五通仙人大威德　　退失神通因女人
  随意自在骑项行　　王女能令寂静转
  琰魔死王及猛风　　亦如地下沃焦海
  炎火黑蛇刀毒药　　女人为害过于此
  敬心给足诸财宝　　质直承事意无违
  智慧方便或刚柔　　无有能知女心者
  见人啼笑皆过彼　　种种幻惑诱其心
  貌恭矫媚于男夫　　心藏很戾无知者
  极虚诳语示真实　　极真实言皆虚妄
  恒如毒兽害众生　　咄哉丈夫宁共处
  长时敬事益憍慢　　暂遇违缘恶转增
  若出若处一切时　　陵突于夫无愧耻
  如火焚薪恒不足　　如海吞流无满时
  琰魔不厌杀众生　　女人欲男心亦尔
  女人不观于种族　　老少贵贱与妍媸
  一切男子悉驰求　　无厌恣欲情如是
  女人志欲无厌足　　曾无少分系夫心
  犹如野牛自在行　　恒思渐食于新草
  少年盛色心流转　　富贵从夫系属人
  丰盈玉馔璎珞衣　　常愿贫穷随自意
  种种供事咸充足　　涂香沐浴妙庄严
  未尝惭愧丈夫恩　　纵意邪思心不绝
  或染欲语怜愍语　　舌上犹如甘露生
  心中猛恶兴毒害　　是故女言难定信
  女人能间夫宗族　　匪令雍穆暂同居
  父母兄弟甚怨仇　　一切姻亲皆舍离
  外现美容怀谄媚　　一切愆违满腹中
  不应观视一须臾　　况久甘其粗恶语
  女人恒于一切处　　防诸过患及猜嫌
  一行有亏众所轻　　伤风败俗人咸弃
  女人童幼及中年　　乃至老时过百岁
  内外种族皆荣贵　　动止恒须人所防
  处女居家随父母　　笄年适事又从夫
  夫亡从子护嫌疑　　由是常名不自在
  出家舍欲修寂静　　心思女境非圣贤
  犹郁金香染垢衣　　离善常为智人笑
  如囚得出思还入　　如狂遇差愿重生
  癞病已除念病时　　舍女思女过于是
  如澄静水蛟龙止　　亦如金窟猛兽居
  虽修戒定念女人　　智者观之亦如是
  智人宁吞于热铁　　不观女色乱其心
  戒定慧品遍成怨　　寂静资缘皆弃舍
  女人不观于胜族　　吉祥富贵智名闻
  唯求染欲无异心　　云何慧者所亲近
  有住诸禅及威势　　能杀勇力与王仙
  或时女色染其心　　退失调伏诸功德
  斗诤象马诸军阵　　亡躯济海集珍财
  胜族乞丐为仆隶　　行非正法皆由女
  女人喜怒情难见　　染心邪计量无涯
  世间名称诸智人　　无有能知女心者
  五通神仙及天主　　能知大海水多少
  终身计算莫能知　　一一女人差别意
  谄言悦耳甘如蜜　　心如利剑害于人
  乱意巧妙夺人心　　怀恶兴谋肆诸毒
  女人妙饰或无饰　　行住坐卧悉猜嫌
  邪视愚智诸女人　　见画像女亦憎恶
  愚童乐攀毒树枝　　痴乱欲住毒蛇窟
  狂人执持于热铁　　亲近女色过于是
  染着女色心昏醉　　违意忿毒害于身
  怖彼女人喜怒时　　智者云何亲近住
  女人恶法满其心　　如河深水蛟龙止
  不观勇力色种族　　恣欲从心无是非
  女心不定如疾风　　亦如迅速浮云电
  百岁供承资所欲　　曾无少念丈夫恩
  不敬有德轻无德　　憎贫乐富徇贪求
  美言敬养增慢高　　资财阙乏无心顾
  蚖蛇枯碛狼毒华　　共住戴持伤一世
  暂近女色过于彼　　永害未来功德身
  女人谗巧恒是非　　离间六亲及朋友
  覆藏己过扬他失　　一切过患由女人
  女心不定如猿狖　　恒思少过忘多恩
  愚夫敬事若师尊　　如奴奉主情无足
  女性如河滋泛溢　　漂诸胜法坏多身
  如流湍激两岸崩　　女人害善过于是
  女人欲网甚坚密　　顾视徐行无愧容
  笑语欢诤无异心　　罗诸富贵如昏醉
  女人染爱由妄起　　如树无根欲尽灯
  色衰爱息一须臾　　所有恩情咸灭尽
  女人爱欲须臾顷　　染心邪语信难依
  或时宝重过珠珍　　或生厌弃如刍草
  象王自在拔树力　　色如浮空大白云
  由为女象醉其心　　一切随人所调伏
  菩萨为法摄女人　　虽恒教授心远离
  若时太过而亲近　　如鸟折翼不能飞
  女人志趣恒卑下　　如河流处岸崩摧
  所往能令善法衰　　毁宗灭族皆因此
  女人能张爱欲网　　罗捕一切诸愚夫
  世间染欲诸众生　　如鱼吞钩为所食
  智者观知本不净　　九窍常流昼夜时
  如是厌离女人身　　云何于此生贪着
  女身虚幻如浮泡　　老病死苦所依处
  积集不净过山岳　　云何于此生贪着
  一切忧恼及恐怖　　皆从女色之所生
  若能观察无贪着　　解脱无忧无恐惧
  是故智者不观女　　或时观察以慈心
  想如母女及姊妹　　随应为说无贪法
  能了女人身内外　　种种不净之所生
  如何境动思欲火　　焚烧累劫诸善根

尔时妙威德主太子。说此偈已。告具足艳吉祥童女言。汝是谁女。先系属谁。为谁守护。若已属人。我则不应重摄受汝。尔时太子。以偈问曰

  汝具清净功德身　　色相端严甚微妙
  我今问汝应实答　　汝本从生及所居
  父母亲属为是谁　　汝复今依谁所住
  若已系属于他人　　我则不应重摄受
  汝不好盗他财物　　汝不无慈害有情
  汝不邪行染其心　　毕竟汝依何语住
  汝不离间他亲友　　口出一切粗恶言
  虚诳无义恼群生　　贪求境界怀嫉妒
  汝不于他生恚怒　　以邪险见自缠心
  不行谄幻诳世间　　作诸相违重业不
  尊重父母师长不　　恭敬一切善友不
  见诸困厄贫穷人　　能起慈心饶益不
  若有一切善知识　　诲示于汝真实法
  能以坚固信乐心　　恭敬勤修供养不
  汝能爱乐诸佛不　　汝能尊重菩萨不
  最胜佛法功德僧　　一切能生恭敬不
  汝能安住正法不　　汝能远离非法不
  闻赞无边功德海　　能生爱乐尊重不
  汝见孤独无所依　　能起慈心救护不
  汝见恶道诸众生　　能生广大悲心不
  于他所有荣乐事　　能生最极欢喜不
  于诸逼迫众生中　　能住平等舍心不
  汝为痴闇诸众生　　求大菩提开悟不
  无边劫海修诸行　　不起身心疲倦不

尔时太子。如是问已。女母善现。即于其前。自说童女从初诞生。乃至成长所有吉祥功德之相。而说偈言

  太子仁今应善听　　所问此女诸因缘
  初生渐次及长成　　具德庄严我当说
  曩于太子初生日　　此女亦从莲华生
  诸根清净相圆明　　肢节庄严皆具足
  我时游观于春月　　入彼最胜娑罗园
  观诸卉木华始生　　百谷药草皆荣茂
  奇树名华开众色　　发耀舒光如庆云
  黑蜂游集鸟和鸣　　闻者忘忧恣欢乐
  同游八百诸采女　　容仪端正夺人心
  袨服姝丽备庄严　　言谈歌咏皆殊妙
  园有浴池宝严饰　　名为种种莲华幢
  我将采女诣池边　　散华布地而敷座
  于彼清净芳池内　　忽生千叶宝莲华
  阎浮檀金以为台　　琉璃为茎摩尼叶
  妙香众宝为华蕊　　普放一切大光明
  众生睹相尽生疑　　中夜云何日光照
  夜分既尽日初出　　光明照此莲华开
  莲华放光出妙音　　示此童女初生相
  我时见此人间宝　　从彼莲华之所生
  往修净业悉无亏　　今获圆明诸妙果
  绀琉璃发青莲眼　　面貌端严金色光
  华鬘宝髻具庄严　　吉祥无垢莲华色
  身分肢节皆圆满　　相好光明无比伦
  俨然端坐宝华中　　犹如净妙真金像
  遍身所有诸毛孔　　咸出一切栴檀香
  口中常出青莲香　　所有言音同梵响
  或时微笑有宣说　　犹如天乐妙音声
  此是女宝世间希　　非诸下劣当斯偶
  我观世间无有人　　堪与此女为其主
  唯仁功德相庄严　　愿赐弘悲哀纳受
  此女非长亦非短　　亦复不粗亦不细
  身诸部分悉端严　　众相圆备无讥丑
  世间所有诸技艺　　文字算印工巧法
  言辞讽咏皆清妙　　唯愿仁尊哀纳受
  亦能解了诸兵法　　弓剑技术无不通
  善和斗讼以慈心　　闻名仰德咸调伏
  宿因胜行皆圆满　　一切功德自庄严
  见者欢喜永无厌　　唯愿仁尊哀纳受
  众生所有一切病　　知其因起及增损
  应病与药使无差　　能令众苦皆销灭
  阎浮一切语言法　　音声随转无量种
  名言训释各不同　　如是一切咸通达
  世间所有诸音乐　　歌舞嬉戏及赞咏
  言辞辩论适人心　　能令见者咸欣悦
  动止威仪皆有则　　取舍进退合其宜
  于染不染诸众生　　但以慈心无所著
  徐步谛观心不乱　　诸根寂静念无亏
  身口恒随智慧行　　女人过失咸皆离
  女人所有诸功德　　此女一切备修持
  人间女宝汝应知　　愿速垂悲哀纳受
  其心不悭亦不嫉　　亦无嗜欲及贪嗔
  质直柔软性调和　　言音美妙无粗犷
  恭敬一切诸尊长　　专求功德志无移
  于诸梵行悉坚持　　唯愿慈悲哀纳受
  见诸衰老及重病　　受诸困厄处贫穷
  无主无亲无所依　　常起慈心而救护
  不念自身安隐乐　　常乐利益诸众生
  以此功德庄严心　　究竟观于真实谛
  行住坐卧心无逸　　动静语默常应时
  未曾一念舍众生　　能令见者咸尊重
  虽于一切众生处　　不起凡夫染污心
  见有慈悲具德人　　常乐亲近无厌足
  普能尊重善知识　　远离一切恶知识
  心无躁竞恒顺行　　所作先思无谬失
  普于一切无怨恨　　恒修众福以严身
  智慧人间无等伦　　此女宜应奉太子

大方广佛华严经卷第二十八大方广佛华严经卷第二十九

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时威德主太子。于香牙云峰园苑之内。对诸众会。及善现前。问童女言。善女。我为求阿耨多罗三藐三菩提。愿尽未来行菩萨行。积集一切助道之法。净修一切诸波罗蜜。供事未来一切诸佛。护持一切诸佛教法。严净一切诸佛刹土。当绍一切如来种性。当誓成熟一切众生。当断一切众生苦恼。当令一切置安隐处。当净一切众生智眼。当修一切菩萨妙行。当入菩萨平等体性。当住一切诸菩萨地。当令二乘圆满佛果。当令一切众生欢喜。我为满足檀波罗蜜。究竟成就无上菩提。内外财宝乃至头目。一切皆舍无所顾恋。当于尔时。汝或于我而作障难。令我施行不得圆满。施财物时。汝心悭吝。施男女时。汝心痛恼。割肢体时。汝心忧闷。舍汝出家。汝心悔恨。尔时太子。如是问已。复为童女。而说偈言

  我为哀愍众生故　　发起广大菩提心
  当于无量亿劫中　　积集成满菩提智
  无量无边大劫海　　净修诸愿如虚空
  入地治障具修行　　究竟当获如来地
  誓于三世诸佛所　　备学一切波罗蜜
  具足方便正修持　　成就最胜菩提道
  十方所有垢秽刹　　我当普遍皆严净
  及诸恶趣苦难中　　我当救护咸令出
  一切众生居有海　　烦恼痴惑恒缠覆
  我当除灭尽无余　　普令安住如来道
  我当供养一切佛　　我当普修菩萨地
  常起广大慈悲心　　所须皆与无贪吝
  汝见一切来乞者　　于财或起悭吝心
  我心常乐施群生　　汝当随我无违逆
  我当于彼施头时　　汝心慎勿生忧恼
  我今先语汝令知　　令汝心坚恒不动
  割截肢体及手足　　乃至妻子心无吝
  汝于乞者莫憎嫌　　应可谛思无退转
  为满一切众生欲　　内外所有皆能舍
  汝能顺我菩提心　　我亦当随于汝意

尔时具足艳吉祥童女。闻是语已。即白太子威德主言。善哉丈夫。如仁所问。诸菩萨行。难行能行。难忍能忍。如是一切。我当随顺精勤修习。亲近不舍。如影随形。令仁所愿皆得成满。尔时童女。即向太子。而说偈言

  设于无量无边劫　　一切地狱火焚身
  仁尊若能眷纳我　　甘心分受无辞苦
  设于无量受生处　　以身碎末如微尘
  仁尊若能眷纳我　　坚心忍受无摇动
  设于无量无边劫　　顶戴一切金刚山
  仁尊若能眷纳我　　甘心分受无疲厌
  汝于生死诸劫海　　以我身肉施众生
  汝得安处法王家　　愿我如仁亦当获
  唯愿太子垂哀纳　　与我为主共修行
  所生劫海行施时　　常以我身施一切
  汝为愍念众生故　　而发广大菩提心
  既已普摄诸群生　　亦愿慈悲摄受我
  我心本不求豪富　　亦复不贪五欲乐
  但为同法共修行　　由是愿以仁为主
  绀青修广慈悲眼　　普观一切诸众生
  不起凡夫染污心　　必成寂静菩提果
  太子凡所经行处　　地神涌出宝莲华
  光明妙相具庄严　　必作轮王垂纳我
  我于梦中曾见此　　法云光照菩提场
  佛成正觉放光明　　无量菩萨同围绕
  梦彼如来胜日身　　如紫金山光照耀
  即时以手摩我顶　　寤已踊跃心欢喜
  空中有天名喜光　　与我昔世曾同行
  出妙言音来告我　　云彼如来今出世
  由我昔时生是念　　愿见太子功德身
  彼天告我如是言　　汝必于今当得见
  蒙佛加持今见汝　　昔所志愿悉皆圆
  愿共俱往诣如来　　同心共学菩提道

尔时太子。闻胜日身如来名已。即得速疾清净心。名见佛差别无障碍大欢喜。即散五百摩尼宝华于童女上。冠以吉祥藏摩尼宝髻。被以杂色火焰摩尼宝衣。尔时童女。端心正念。曾无摇动。亦无喜相。但一心合掌。瞻仰太子。正念现前。目不暂舍。时母善现。即向太子。而说偈言

  此女希有人间宝　　净福妙相庄严身
  宿心誓愿奉仁尊　　一切志乐今成满
  坚持净戒恒无缺　　智慧圆满念无亏
  功德具足相圆明　　一切女人无与等
  此女本从莲华生　　种姓清净无讥丑
  女人之过咸皆离　　堪随太子共修持
  其身细妙如缯纩　　手足柔软兜罗绵
  随其摩触病皆除　　身心安乐无诸苦
  身诸毛孔所出香　　芬馨超世无伦匹
  若暂嗅闻心离染　　住于净戒获身安
  身如净妙真金色　　不着尘垢如莲华
  众生见者离贪嗔　　皆具慈悲无怒害
  言音美妙声柔软　　一切众生咸乐闻
  经心历耳悦诸根　　恶业消除烦恼灭
  内心清净无瑕秽　　柔和质直性无偏
  言辞称悦不乖宜　　闻皆欢喜心调伏
  具足惭愧无欺诳　　不憍不谄有慈悲
  为求正法度众生　　恭勤善友无厌足
  不于色相及种族　　乃至荣乐无迷醉
  但以谦恭无我心　　专求无上菩提道

尔时威德主太子。与具足艳吉祥童女。及二万采女。并诸眷属。为欲亲近恭敬供养胜日身如来。各乘宝车。出香芽园。诣法云光明道场。至已下车。步进佛所。见佛身相。端严寂静。诸根调顺。犹若象王。内外清净。无诸垢浊。如大龙池。以见佛故。踊跃欢喜。心生净信。增长爱乐。顶礼佛足。绕无数匝。于时太子。及彼童女。各持五百大摩尼宝上妙莲华。奉散于佛。以佛神力。于虚空中。普覆如来一切众会。尔时太子。复为彼佛。造立精舍。其数五百。一一皆以香木所成。五百摩尼而为间错。种种杂宝。周遍庄严。时彼如来。知其太子根已成熟。即为演说普眼灯门修多罗。是时太子。闻是经已。于诸法中。证得十三昧海门。所谓得一切如来愿海出现光明三昧门。得普照三世光明藏三昧门。得现见一切佛道场三昧门。得入一切众生界光明普照三昧门。得普照一切世间智聚光明灯三昧门。得普照一切众生诸根海智灯三昧门。得救护一切众生智光明云三昧门。得调伏成熟一切众生大智光明灯三昧门。得闻持诸佛转法轮声悉现前三昧门。得圆满普贤清净行愿海云三昧门。以得如是三昧门故。于诸法中。靡不获得甚深三昧。时具足艳吉祥童女。以闻法故。即得三昧。名难摧伏智海藏。于阿耨多罗三藐三菩提。得不退转。尔时太子。与彼童女。并其眷属。闻法获益。顶礼佛足。绕无数匝。辞退还宫。诣父王所。到已礼足。而白王言。大王当知胜日身如来。出兴于世。于此国内香芽云峰园苑之侧法云光明菩提场中。成等正觉。于今未久。时财主王。忽闻是语。问太子言。是谁为汝说如是事。天耶人耶。太子白言。是此具足艳吉祥童女所说。时王闻已。欢喜无量。譬如贫人得大伏藏。作如是念。佛无上宝。难得出世。难可值遇。若有得见。必断一切烦恼恶业。不堕一切生死险道。如来出世。为大医王。能治众生烦恼重病。如来出世。为大明灯。能破众生无明黑闇。如来出世。为大导师。能引众生至一切智安隐住处。作是念已。击鼓宣令。敕诸小王群臣眷属。及刹帝利。诸婆罗门。长者居士。城邑聚落。一切人众。皆悉来集。而告之言。汝等当知。如来出世。希有难值。我今欲往亲近礼敬。王于是时。即舍王位。授与太子。灌顶讫已。与诸眷属十千人俱。往菩提场。诣如来所。到已顶礼。绕百千匝。与诸眷属。退坐一面

尔时如来。普遍观察道场众会。及财主王。并其眷属。从于眉间白毫相中。放大光明。名照现一切众生心灯。普照十方无量世界。住于一切世主之前。示现如来不可思议种种佛事广大神变。令诸众生应受化者。心得清净。尔时如来。以不思议自在神力。示现超出一切世间最高大身。以圆满音。普随一切诸语言海。为大众说陀罗尼门。名入一切法义离翳灯。以佛刹极微尘数陀罗尼门。而为眷属。时王闻已。即时获得一切法大智光明。其众会中。有阎浮提极微尘数诸菩萨等。俱时证得入一切法义离翳灯陀罗尼门。六十那由他众生。尽诸有漏。心得解脱。十千众生。远尘离垢。得法眼净。无量众生。发阿耨多罗三藐三菩提心。尔时如来。又以不思议力。普于十方一切世界。广现神变。以三乘法。教化众生。时财主王。得大法光照其心故。即作是念。今此甚深功德法味。我若在家不能证得。若佛听我亲近出家。即于是法。当得成就。作是念已。前白佛言。我今愿欲亲近如来。出家为道。佛告大王。当随汝意。宜自知时。时财主王即与眷属十千人等。同于佛所。出家学道。精勤修习。未久之间。悉皆获得入一切法义离翳灯陀罗尼门。亦得如上诸三昧门。又得菩萨十种神通门。又入菩萨无边辩才门。又得菩萨无碍清净身。普诣十方诸如来所。听佛所转微妙法轮。悉能受持。无有忘失。又于佛所。作大法师。广为众生。演说诸法。复以神力。遍十方刹。随众生心。而为现身。于诸世间。为大明灯。称赞诸佛。出现世间。称赞诸佛本修行愿称赞诸佛所集功德。称赞诸佛本生因缘。称赞诸佛自在神力。护持诸佛所有教法。尔时太子。于十五日。升于正殿。坐师子座。采女围绕。轮王七宝。自然而至。一者轮宝。名无碍行。辐网具足。百千妙宝。以为庄严。阎浮檀金光明普照。二者象宝。名金刚山。威力广大。三者马宝。名迅疾风。四者珠宝名日光藏云。五者女宝。名具足艳吉祥。六主藏臣宝。名为大财。七主兵宝。名离垢眼。如是七宝。欻然出现。具足成就。为转轮王。主四天下。威德自在。行正法化。能伏一切。人皆快乐。王有千子。端正勇健。威力雄猛。无诸怨敌。化境宽博。尽大海际。其地柔软。无诸荆棘。安隐丰乐。离众灾患。时阎浮提八万四千诸小王都。一一王都皆有僧坊。其数五百。一一僧坊。建百楼阁。环廊四绕。树林蓊郁。冬夏安居。经行之处。一切皆以众宝庄严。及诸一切资生之具无不备足。复于处处僧伽蓝内。立佛支提。皆悉高广庄严妙好。彼诸城内。皆请如来。以不思议华香幡盖妙宝缯彩诸供养具。而为供养。尔时如来。咸受其请。以自在力。其身普入一切王都。令无量众生种诸善根。无量众生心得清净。无量众生发欢喜心。无量众生增长爱敬。无量众生速疾发起大菩提意。广以大悲。饶益群品。勤修一切诸佛正法。随所修习。皆能悟入。回向诸佛一切智道。了达诸佛甚深法海。普入三世无差别智。普照三世诸众生界。知一切佛出兴于世相续次第。得一切佛种智。方便善巧调伏一切众生。发起菩萨广大行愿。清净一切诸菩萨道。安住菩萨平等智性。入佛无尽辩才大门。转佛清净无碍法轮。普现其身。遍一切刹。住于一切众生之前。知诸众生根性欲解种种心海。随应调伏。皆令成熟。尔时大威德主转轮圣王。及彼一切王都城中。皆得见彼胜日身如来。示现种种不可思议大神通力。如是自在广大饶益

善男子。于意云何。彼时太子大威德主。受于父王灌顶升位。作转轮王。供养佛者。岂异人乎。今世尊毗卢遮那如来是也。彼时父王名财主者。岂异人乎。今宝华光如来是也。其佛现在东方过世界海极微尘数刹海之外。有世界海。名普现法界虚空影像云。彼刹海中。有世界种。名普现三世影像摩尼王。彼世界种中。有一世界。名佛圆满灯。彼世界中。有菩提场。名一切世主身影像幢。宝华光如来。于此成阿耨多罗三藐三菩提。有不可说不可说佛刹极微尘数诸菩萨众。前后围绕。于众会中。转正法轮。令无量众生皆得成熟。彼佛过去为菩萨时。修习庄严此世界海。彼刹海中。去来今佛。成正等觉出兴世者皆悉是彼宝华光佛之所化度。最初令其发阿耨多罗三藐三菩提心。乃至究竟。令其成熟。善男子。时财主王。第一夫人大威德主太子之母。莲华吉祥藏者。岂异人乎。今此佛母摩耶夫人。得幻智光明无碍解脱。于其身中。含藏出生过去未来一切诸佛。今于此界。生佛世尊。毗卢遮那如来者是。时具足艳吉祥女母善现者。岂异人乎。即今我母执杖释种善目夫人是也。善男子。彼时大威德主转轮圣王所有眷属。岂异人乎。今佛世尊。所有众会一切菩萨是也。如是菩萨。皆具修集普贤所行。圆满成就普贤大愿。虽恒在此佛会道场。而能普现一切世界。住诸菩萨平等三昧。常得现见一切诸佛。悉能闻持一切如来等虚空界妙音声海所转法轮。住一切法自在智力。名称普闻诸佛国土。能普亲近一切如来道场众会。随诸众生应受化者。演说正法。悉令成熟。尽未来际一切劫海修菩萨行。恒无间断。成满普贤广大誓愿。善男子。彼时童女具足艳吉祥。与威德主转轮圣王。尽其形寿。以四事供养胜日身如来者。岂异人乎。我身是也。善男子。彼佛灭后。于此世界。复有佛出。名清净身。我于彼佛。亲近供养。闻法受持。亦为众生。行菩萨道。次有佛出。名一切智影像月身。我于彼时。亲近供养。次有佛出。名阎浮檀金光明王。次有佛出。名大梵音相庄严身。次有佛出。名种种焰妙月光。次有佛出。名妙高智观察幢。次有佛出。名广大智光明王。次有佛出。名那罗延金刚精进力。次有佛出。名智势力无能胜。次有佛出。名普观察智。次有佛出。名广大智吉祥云。次有佛出。名无畏智光明身。次有佛出。名净智焰光云。次有佛出。名功德幢。次有佛出。名智日幢。次有佛出。名莲华开敷身。次有佛出。名福德严净光。次有佛出。名智焰云。次有佛出。名毗卢遮那月。次有佛出。名庄严盖大声王。次有佛出。名大勇猛普智光明。次有佛出。名法界境界智月王。次有佛出。名普现影像开悟众生如虚空心。次有佛出。名语言相寂灭香。次有佛出。名普震随顺寂静声。次有佛出。名坚固智无障碍光网。次有佛出。名甘露山威德王。次有佛出。名法海雷音。次有佛出。名佛虚空光照髻。次有佛出。名月光毫相云。次有佛出。名月面妙圆满。次有佛出。名妙觉智拘苏摩华光。次有佛出。名宝焰山吉祥威德。次有佛出。名广大功德星宿光。次有佛出。名具一切智三昧身。次有佛出。名焰圆满身。次有佛出。名最胜威德宝光明。次有佛出。名普智速疾行。次有佛出。名光焰海门灯。次有佛出。名大法宫殿妙声王。次有佛出。名无比功德名称幢。次有佛出。名修臂。次有佛出。名清净本愿神变化月。次有佛出。名虚空智实义灯。次有佛出。名法上虚空自在王。次有佛出。名毗卢遮那德藏王。次有佛出。名那罗延法聚。次有佛出。名诸乘智积幢。次有佛出。名法海妙莲华。如是等六十百千亿那由他如来。于彼劫中。相续次第。出兴于世。我皆亲近承事供养。其最后佛。名广大欢喜出现威德。最后于此。出兴于世。尔时彼佛。来入王城。我于彼时。为王正妃。同与大王以诸供具。供养彼佛。于其佛所。闻说法门。名一切如来受生出现灯。即时获得差别智眼。名观一切菩萨三昧海微细境界解脱门

善男子。我时于彼。得此解脱。经佛刹极微尘劫。常与菩萨勤加修习。是诸劫中。所有诸佛无量无边。我皆一一亲近供养。受行其法。或有劫中承事一佛。或有劫中承事二佛。或有劫中承事三佛。或百或千。乃至或有于一劫中亲近承事不可说不可说佛。或有劫中值于佛刹极微尘数佛。如是诸佛。我皆亲近承事供养。犹未能知菩萨之身。形量色貌。及身语意。业行果报。三昧解脱。所有境界。善男子。若有众生。得见菩萨。为一切智。修诸行时。或逆或顺。若疑若信。菩萨皆以世出世间种种方便。而摄取之。以为眷属。令于阿耨多罗三藐三菩提得不退转。善男子。我从于彼广大欢喜出现威德如来之所。得此观一切菩萨三昧海微细境界解脱已。于百佛刹极微尘数劫。常与菩萨。而共修习。尔所劫中所有诸佛。出兴于世。我皆亲近承事供养。彼诸如来。各以异门说修多罗。随顺修行。忆持不忘。令此解脱。展转增广。由是能知种种修多罗。获种种功德身。得种种解脱门。见种种三世海。诣种种佛刹海。见种种成正觉。入种种佛众会。发种种菩萨愿。行种种菩萨行。满种种菩萨解脱。亦未能知菩萨所成普贤解脱。何以故。菩萨所得普贤解脱神通境界。如大虚空。如众生名。如三世海。如十方界。如法界海。无量无边无际畔故。善男子。应知菩萨所得普贤解脱法门。与诸如来境界齐等。善男子。我于尔所佛刹极微尘数劫。观菩萨身所有境界。无有厌足。如多欲人男女集会。更相染爱。于念念中。起于无量妄想思觉。随彼境转无有尽极。我亦如是。于尔所劫。观菩萨身一一毛孔。念念悉见无量无边广大世界。种种生起。种种安立种种庄严。种种形状。种种依住。种种分量种种时劫。种种际畔。种种山海。种种大地。种种云覆。种种名字。种种佛出兴。种种菩提场。现种种大神通。于种种大众会。演种种修多罗。立种种诸乘教。开种种方便门。放种种光明轮。严种种佛世界。设种种灌顶法。又于菩萨一一毛孔。于念念中。常见十方无边佛海。坐种种道场。现种种神变。转种种法轮。说种种修多罗。次第相续。恒不断绝。又于菩萨一一毛孔。念念常见十方一切诸众生海。种种住处。种种形貌。种种威仪。种种作业。种种根器。种种心量。又于菩萨一一毛孔。悉见三世诸菩萨海。无量无边诸行门。无量无边大愿海。无量无边菩萨地。无量无边波罗蜜。无量无边本生事。无量无边严刹行。无量无边大慈门。无量无边大悲云。无量无边精进海。无量无边大喜心。念念摄取无边众生。方便调伏。皆令成熟。善男子。我于尔所佛刹极微尘数劫。念念如是观于菩萨一一毛孔所有境界。已所经处更不重经。已所见处更不重见。已所闻处更不重闻。已所得处更不重得。乃至见于悉达太子处。于内宫采女围绕我以解脱力。观于菩萨一一毛孔。悉见三世一切法界。无边境界。深入无际。善男子。我唯得此观察菩萨大三昧海微细境界解脱门。如诸菩萨摩诃萨。能悉成就诸方便海。等诸众生。现随类身。普住一切众生之前。随诸众生。种种根性。演说种种诸乘教法。一切毛孔。悉能出生无量色相变化海云。知一切法本来清净。无性为性。知诸众生。同于虚空无相为相。住无分别究竟解脱。现无中边广大境界。知佛神力毕竟如如。能随大愿。普现神变。一念能入广大法界。令一切法自在。随转得一切法普遍智门。悉能游戏诸菩萨地。远离一切烦恼结使。获得清净圆满智通。知诸众生究竟寂灭。普随现身。皆令欢喜。与诸菩萨平等一缘。常共集会。不相舍离。得大神通。究竟不退。自在游行一切世界。随诸众生。现成正觉。普坐一切道场众会。普随诸趣而现受生乘不退轮。行菩萨行。见闻获益。如药树王满众生心。如如意宝。一音普演。咸令欢喜。于大智地。安立诸法。智幻神通。遍周法界。如是菩萨。行智功德。而我云何。能知能说

尔时释女瞿波。告善财言。善男子。此世界中。有大摩尼毗卢遮那宝莲华藏师子之座。佛母摩耶而坐其上。汝诣彼问。菩萨云何修菩萨行。于诸世间。无所染着。菩萨云何得自在力。于诸法中。远离尘垢。菩萨云何得信乐力供事诸佛恒无懈息。菩萨云何得勇进力。成就一切菩萨事业。菩萨云何得净智力。远离一切烦恼障碍。菩萨云何得深解力。有所闻法自然开悟。菩萨云何得现前力。成就菩萨观察智慧。菩萨云何得周遍力。普诣一切诸如来所。菩萨云何得弘誓力。普摄一切诸众生界。菩萨云何得不退力。尽未来劫修菩萨行。菩萨云何得观察力。悉见诸法无有挂碍。菩萨云何入缘起智。见一切法。悉无有我。菩萨云何得随顺智。善解一切世出世法。菩萨云何得微细智。善能观察诸法体性。菩萨云何得神通智。能为众生说诸秘密。菩萨云何发起大愿。增长一切众生善根。常无休息。菩萨云何亲近承事诸佛菩萨。及以一切声闻独觉。恒不断绝。尔时释女瞿波。欲重宣说此解脱门义。承佛威力。向善财童子。而说偈言

  若有众生见菩萨　　修集种种菩提行
  起于不善及善心　　悉皆摄取令饶益
  往昔百刹极微数　　倍是尘数复有劫
  名为平等净庄严　　刹名最胜须弥光
  彼劫有佛出兴世　　三十六亿那由他
  最后出现天人师　　号正法幢为世灯
  尔时彼佛涅槃后　　有王名智威德山
  自在统领阎浮提　　力能摧伏诸怨敌
  时王具有五百子　　端正勇健无能胜
  才智善巧悉过人　　众生瞻仰无厌足
  其王及子心清净　　深于佛法生信心
  受持守护及修行　　勇猛精进恒无退
  彼时太子名焰光　　具相庄严三十二
  离垢功德皆圆满　　善能饶益诸群生
  将其眷属五百亿　　闻法出家行学道
  皆修梵行共精勤　　勇猛护持于佛法
  时有王都名智树　　具足千亿城围绕
  林名寂静大吉祥　　宝树庄严皆胜妙
  焰光佛子住其中　　为众弘宣佛正法
  辩才智慧无穷尽　　令其闻者除烦恼
  菩萨有时因乞食　　执持衣钵入王城
  威仪寂静步安详　　谛视正观心不乱
  时彼城中有长者　　名为善称欢喜幢
  我为童女在居家　　名净日光端严相
  我时遥见此佛子　　念慧清净常现前
  诸根调伏相端严　　所有威仪皆寂静
  次行乞食至我门　　我见即时生爱染
  解身璎珞庄严具　　欢喜并珠施钵中
  我时虽以染爱心　　供养焰光真佛子
  由是不经三恶趣　　常生天上及人间
  二百五十大劫中　　所生为女皆尊胜
  恒见焰光修学处　　具相庄严离垢身
  过彼二百五十劫　　次生善现母人家
  身为童女相端严　　名妙吉祥具足艳
  见彼太子威德主　　而生尊重爱敬心
  愿得奉事共修行　　幸彼宿因蒙纳受
  我于彼时随太子　　同诣如来胜日身
  即发广大菩提心　　供养闻法生欢喜
  彼劫所有佛兴世　　六十千亿那由他
  最后佛号解脱光　　次第我皆兴供养
  于彼最后如来所　　获得觉法清净心
  观诸法性无有生　　成就宿命除烦恼
  即得菩萨三昧海　　观察微细解脱门
  一念能入于十方　　不可思议诸刹海
  普见一切诸世界　　或有杂秽或清净
  于杂秽刹无憎恶　　于清净刹不贪着
  悉见十方诸刹海　　一切世界菩提场
  如来遍坐放光明　　我于一念皆能了
  彼佛所有大众海　　我于一念皆能入
  亦知彼众所修行　　三昧解脱神通力
  彼众所有广大行　　诸地诸度诸方便
  及诸誓愿海无涯　　我于念念皆深入
  我观菩萨相好身　　一一毛孔神通事
  历劫同修诸妙行　　求其边际不可得
  一一毛孔所有刹　　不可言说无央数
  于中地水火风轮　　微细容持不相杂
  彼诸世界所安立　　形量名体皆不同
  刹中种种众生身　　色相庄严亦无量
  我又以此解脱力　　尽见十方诸刹海
  诸佛现化满其中　　调伏一切众生界
  虽于无量劫修行　　见彼诸佛神通力
  犹不能知此菩萨　　身心及智所行道

尔时善财童子。闻是法已。顶礼瞿波。绕百千匝。殷勤瞻仰。恋慕一心。辞退而去

大方广佛华严经卷第二十九大方广佛华严经卷第三十

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。一心欲往亲近佛母摩耶夫人。即时获得微细观察诸佛境界无边正智。作如是念。我当云何方便。得见此善知识。此善知识。远离世间。住无所住。超过六处。离一切着。不染欲泥。住无碍道。知如实行具净法身。以如幻业而现化身。以如幻智观察世间。以如幻愿而现色身。以佛威力加持自身。此善知识。随意生身。此善知识。无生灭身。无来去身。非虚实身。不变坏身。无起尽身。不思议身。所有诸相皆一相身。远离二边住解脱身。无依处身。无穷尽身。如影普现无分别身。如梦所见离寻伺身。如镜中像不出入身。普于十方而化现身。住于三世无变异身。非身心身。无差别身。此善知识。所行无碍。犹如虚空。超诸世间一切眼境。唯是普贤净目所见。如是之人。我今云何而得亲近承事供养令生欢喜。与其同住。观其状貌。处其众会。听其音声。思其语言。受其教诲

善财童子。作是念时。有主城神。名曰宝眼。无量城神。眷属围绕。于虚空中。而现其身。种种璎珞。以为庄严。各现无量殊异色身。手持无量诸天宝华。以恭敬心。散善财上。作如是言。善男子。汝应善巧守护心城。谓不贪一切生死境界。应庄严心城。谓观察趣求如来十力。应净治心城。谓毕竟远离悭嫉谄诳。应清凉心城。谓思惟一切诸法实性。应增长心城。谓以大精进成辨一切助道之法。应严饰心城。谓建立一切禅定解脱自在宫殿。应照耀心城。谓普入一切如来道场听受般若波罗蜜法。应增益心城。谓普能出生一切如来诸方便海。应坚固心城。谓恒勤修习增长普贤清净行愿。应防护心城。谓常能御捍烦恼恶友一切魔军。应廓彻心城。谓开引诸佛普智光明。应善补心城。谓受持诸佛甘露法雨。应扶助心城。谓深信一切佛功德海。应广大心城。谓大慈遍及一切世间。应普覆心城。谓集众善法以覆其上。应宽博心城。谓大悲哀愍一切众生。应开辟心城。谓悉舍所有随应给施一切众生。应密护心城。谓防诸生死恶欲境界不令得入。应严肃心城。谓断除一切诸不善法流转根本。应决定心城。谓集一切智助道之法恒无退转。应安立心城。谓正念三世一切如来圆满境界。应莹彻心城。谓明解一切如来法轮修多罗中所有法门。应部分心城。谓普能晓示一切众生皆令得见萨婆若道。应住持心城。谓普摄一切三世如来诸大愿海。应令心城富实。谓积集一切周遍法界大福智聚。应令心城明了。谓普知众生诸根乐欲烦恼等法。应令心城自在。谓普摄一切十方法界。应令心城清净。谓正念一切诸佛如来。应知心城自性。谓知一切法皆无有性。应知心城幻。谓以一切智了诸法性。善男子。菩萨摩诃萨。若能如是净修心城。则能积集一切善根。随所修行。皆能证入。何以故。蠲除一切诸障难故。所谓见佛障。闻法障。亲近供养诸如来障。方便摄取诸众生障。严净种种佛国土障。善男子。菩萨摩诃萨。以离如是诸障难故。若发希求善知识心。不用功力。则便得见。乃至究竟。成一切智

尔时有身众神。名莲华吉祥。及妙华光明。无量百千诸身众神。前后围绕。从道场出。住虚空中。于善财前。以妙音声。种种称叹摩耶夫人。时诸神众。各从耳珰。放无量色清净众宝焰网光明。放无量色众宝香焰云网光明。放无量色离垢清净焰网光明。放无量色普能显示众生心性清净光明。放无量色速疾增长爱乐光明。放无量色能除热恼清凉光明。放无量色能普显示清净光明。放无量色勇猛出现无著境界宝焰光明。放如是等种种众色大光明网。普照无边广大佛刹。能令善财。普见十方一切国土所有诸佛。其诸光明右绕世间经一匝已然后还来。入善财顶。乃至遍入身诸毛孔。善财童子。以得如是光明照故。即时获得十种法眼。所谓得净光明眼。永离一切愚痴闇故。得无翳眼。能了一切众生性故。得离垢眼。能观一切法性门故。得净慧眼。能观一切佛刹性故。得毗卢遮那眼。能见如来净法身故。得普光明眼。见佛平等不可思议妙色身故。得无碍光眼。观察一切无边刹海成坏相故。得普照明眼。见一切佛起大方便转正法轮出生种种修多罗故。得普境界眼。见无量佛神通威德调伏一切诸众生故。得普见眼。观察一切种种刹中一切如来出兴世故

时有守护菩萨法堂罗刹鬼王。名曰妙眼。与其眷属万罗刹俱。于虚空中。以天拘苏摩可爱妙华。及众妙香。散善财上。作如是言。善男子。菩萨具足成就十法。则得亲近诸善知识。何等为十。所谓离诸谄幻。其心质直。恒清净故。离诸分别。大悲平等。普摄众生故。觉法自性。知众生性。无真实故。知无去来。趣一切智。心不退故。具信解力。普入一切佛道场故。得净慧眼。了一切法性无生故。住平等慈。普令众生。得胜义故。开智光明。能廓自心诸妄境故。作清凉。云洒甘露雨。涤烦恼故。作广大眼。彻鉴诸法。心常随顺善知识故。若诸菩萨。具足圆满此十种法。则得亲近诸善知识。复次善男子。菩萨成就十种三昧。微细观察。则常现见诸善知识。何等为十。所谓法空无尽清净轮三昧。现见十方一切诸佛刹海三昧。于诸境界不舍离无缺减三昧。普见一切如来出现三昧。普集一切福智海藏三昧。心恒不舍诸善知识三昧。常念一切如来功德从善知识出现三昧。念常不舍诸善知识三昧。念常亲近平等供养诸善知识三昧。于善知识。方便行中。身无疲倦。心无厌足。离诸过失三昧。善男子。菩萨成就此十三昧。常得亲近诸善知识。又得善知识常转一切如来法轮三昧。得此三昧已。悉知诸佛体性平等遍一切处。常得值遇诸善知识。说是语时。善财童子。仰视空中。而报之言。善哉善哉。汝为哀愍摄受我故。显示种种巧方便门。令我得见真善知识。唯愿为我分别演说。我当云何。而得往诣善知识所。于何方处城邑聚落。求善知识。作何方便而得亲近诸善知识。罗刹答言。善男子。汝应谦下普礼十方尽虚空际一切境界求善知识。勇猛自在遍游十方。求善知识。起速疾心起随顺心。求善知识。观察身心如影如梦。求善知识

尔时善财。受罗刹教。随顺修行。即时睹见大宝莲华。从地涌出。金刚为茎。摩尼为叶。毗卢遮那宝王以为其台。现众生海摩尼宝王以为其藏。众色宝香以为其须。无数宝网弥覆其上。于其台上。有一楼阁。名普纳十方法界藏。种种奇妙以为严饰。金刚为地。千柱行列。一切皆以摩尼宝成。阎浮檀金以为其壁。众宝璎珞四面垂下。种种宝色大摩尼幢。分布行列。普遍庄严。无数妙宝。阶陛栏楯。周匝庄严。其楼阁中。有如意宝王莲华之座。种种众宝以为庄校。妙宝栏楯周匝围绕。星宿幢摩尼王间列庄严。众色宝衣内外敷设。宝帐宝网垂众宝铃。以覆其上。众宝缯幡处处垂下。微风吹动。光流响发。宝华幢中雨众妙华。宝铃铎中出美音声。宝户牖间垂诸璎珞。摩尼身中流出香水。毗卢遮那宝象口中。出莲华网。众色金刚宝师子口。吐妙香云。梵天形像众妙宝轮。出随乐音。演大慈教。金刚宝铃。出诸菩萨大愿之音。宝月幢中。出佛化形。相续不断。净藏宝王。现三世佛受生次第。日藏摩尼。放大光明。遍照十方一切佛刹。普光照耀。摩尼宝王。放一切佛圆满光明。毗卢遮那摩尼宝王。兴供养云。供养一切诸佛如来。如意珠王。念念示现普贤神变。充满法界。须弥宝王。出天宫殿。普现一切帝释天众变化身云。天诸采女种种妙音。歌赞如来不可思议微妙功德。尔时善财。见如是座。复有无量不思议数宝庄严座。周匝围绕。摩耶夫人。在彼座上。遍于一切诸众生前。现净色身。所谓超三界色身。已出一切诸有趣故。随心乐色身。于诸世间无所著故。普周遍色身。等于一切众生数故。广大力色身。令诸众生具福德故。无等比色身。令诸众生灭倒见故。无量种色身。随众生心。悉示现故。无边相色身。普现调伏众生相故。普对现色身。以大自在而示现故。化一切色身。随其所应而现前故。恒示现色身。尽众生界而无尽故。住安乐色身。亲近见闻得安乐故。无断尽色身。究竟普见如虚空故。大威德色身。灭除众生虚妄法故。无去色身。于一切趣无所灭故。无来色身。于诸世间无所出故。不生色身。无生起故。不灭色身。常寂灭故。非实色身。得如实故。非虚色身随世现故。不动色身。生灭永离故。不坏色身。法性无坏故。无相色身。言语道断故。一相色身。无相为相故。如像色身。随心应现故。如幻色身。幻智所成故。如焰色身。唯想所持故。如影色身。随愿现生故。如梦色身。随心而现故。法界色身。性净如空故。大悲色身。常护众生故。无碍色身。遍周法界故。无边色身。普净众生故。无量色身。超过言说故。无住色身。调伏众生故。无依色身。愿度世间故。无处色身。恒化众生故。无生色身。幻愿所成故。无胜色身。超诸世间故。如实色身。定心所现故。不生色身。随众生业而出现故。如意珠色身。普满一切众生愿故。无分别色身。但随众生心愿起故。离分别色身。一切众生不能知故。离虚妄色身。永离众生虚假法故。恒无尽色身。尽诸众生生死际故。清净色身。同于如来。无分别故善财童子。见于摩耶夫人。如是所现一切色身。究竟非色。所有色相如影像故。究竟非受。世间诸受咸转灭故。究竟非想。但随众生想所现故究竟非行。依如幻业而成就故。究竟非识。菩萨愿智空无性故。一切世间语言断故。灭除生死诸热恼故。安住最胜寂灭身故。尔时善财童子。复见摩耶夫人。随诸众生心之所乐。自在普现。如诸世间。或超世间种种女身。所谓或现魔女身。或现他化天女身。或现化乐天女身。或现兜率天女身。或现夜摩天女身。或现忉利天女身。或现四王天女身。或现诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人女身。于一切处。现如是等相似女身。及超过身。饶益众生。集一切智。行于平等檀波罗蜜。大悲普覆一切世间。出生如来无量功德。修习增长一切智智。观察思惟诸法实性。获深忍海。精勤速疾曾无懈息。恒转清净不退法轮。微细了知一切法性。住于平等三昧境界。得如来定。圆满光明销竭众生烦恼巨海。善能了知一切佛法。恒以智慧。观法实相。见诸如来。心无厌足。知三世佛出兴次第。见佛三昧常现在前。普集无量诸清净道。行于诸佛虚空境界。随其心乐。普摄众生。种种方便教化成熟。入佛无量清净法身。成就大愿。净诸佛刹。究竟调伏一切众生。心恒普入诸佛境界。出生一切菩萨神通。已得法身。清净无染。而恒示现无量色身。游戏如来诸自在力。摧伏魔怨力。成就善根力。出生正法力。具足诸佛力。得诸菩萨自在之力。速疾增长一切智力。得佛智光。普照一切。悉知无量众生心海。根性欲解。种种差别。其身充满十方刹海。亦知诸刹成坏之相。以广大眼。见十方海。以周遍智。知三世海。身普承事一切佛海。心恒纳受一切法海。修习圆满一切如来种种功德。随顺出生一切菩萨智慧助道。常乐观察一切菩萨。从初发心。所有修行波罗蜜行。出生一切诸菩萨地。积集一切菩萨福聚。勇猛精进。心无所畏。普遍成就一切菩萨菩提之道。恒勤守护一切众生。常乐称扬诸佛功德。光明普照一切世间。愿为一切菩萨之母。尔时善财童子。见摩耶夫人。遍一切处。现如是等阎浮提极微尘数诸方便门。既见是已。如摩耶夫人所现身数善财亦现作尔许身。于一切处摩耶之前。恭敬礼拜。即时证得无量无数诸三昧门。分别观察。修行证入。从三昧起。右绕摩耶并其眷属。合掌而立。白言。大圣文殊师利菩萨。教我发阿耨多罗三藐三菩提心。令我勤求诸善知识。我承其教。普于一一善知识所。皆往亲近。承事供养。无空过者。如是展转。渐来至此。唯愿大圣。为我宣说。菩萨云何。学菩萨行而得成就一切智智。摩耶夫人。告善财言。善男子。我已成就菩萨大愿智幻庄严解脱门。是故常为诸菩萨母。善男子。如我于此阎浮提中。迦毗罗城净饭王家。右胁而生悉达太子。现不思议广大庄严。菩萨受生自在神变。如是乃至。尽此世界海。所有一切毗卢遮那如来住最后身。示现诞生自在神变。我皆一一而为其母。彼诸菩萨皆入我身。右胁而生。成一切智。又善男子。我于净饭王宫。菩萨将欲下生之时。见菩萨身。一一毛孔。咸放光明。名一切如来受生功德轮其诸毛孔。一一皆现不可说不可说佛刹极微尘数菩萨受生神变功德庄严。彼诸光明。皆悉普照一切世界。照世界已。来入我顶。乃至一切身诸毛孔。善男子。又彼光中。普现一切菩萨名号受生神变广大庄严宫殿眷属五欲自娱。又见菩萨舍位出家。往诣道场。摧魔军已。成等正觉。坐师子座。种种菩萨前后围绕。种种世主亲近供养。为诸大众转正法轮。又见如来往昔修行菩萨道时。于诸佛所。尊重供养。发菩提心。净佛国土。念念示现无量化身。充遍十方一切世界。变化种种受生庄严。成无上觉。转妙法轮。乃至最后。现般涅槃广大神变。如是等事。靡不皆见。又善男子。彼妙光明入我身时。我身形量虽不逾本。然其实已超诸世间。所以者何。我身尔时量同虚空。于胎藏中。悉能容受十方菩萨宫殿庄严自在受生大神变故。善男子。尔时菩萨。从兜率天。将降神时。有十佛刹极微尘数诸菩萨众。皆与菩萨。同愿。同行。同善根。同庄严。同解脱。同智慧。同住地。同神通。同出现。同威力。同法身清净。同色身威德。乃至普贤功德行愿。悉皆同等。如是菩萨。前后围绕。又有八万诸大龙王。娑竭罗龙王而为上首。及诸世主。各乘种种摩尼楼阁。俱来亲近承事供养菩萨。尔时以神通力。与诸菩萨。普现一切兜率天宫。一一宫中。悉现十方一切世界阎浮提内受生影像不可思议种种神变。教化调伏无量众生。令其觉悟。不生放逸。离诸懈怠。无所执着。又以神力。放大光明。普照世间。破诸黑闇。灭诸苦恼。脱诸欲境。令诸众生。皆识宿世所有业行。永出恶道。又为救护一切众生。普现其前。作诸神变。现如是等诸奇特事。与眷属俱。从天宫下。来入我身。彼诸菩萨。于我腹中。现大神通。游行自在。或以三千大千世界。而为一步。乃至或以不可说不可说佛刹极微尘数世界。而为一步。又念念中十方不可说不可说佛刹极微尘数世界。诸如来所。菩萨众会。及四天王。三十三天须夜摩天。兜率陀天。化乐天。他化自在天。乃至色界诸梵天王俱来。欲见菩萨处胎广大神变。恭敬供养。听受正法。皆入我身。虽我腹中悉能容受如是众会。而身不广大。亦不迫窄。其诸菩萨。各见自处众会道场清净严饰。善男子。如此四天下阎浮提中。菩萨受生。我为其母。三千大千世界百亿四天下阎浮提中。悉亦如是。然我此身。本来无二。亦复非一。非一处住。非多处住。何以故。以修菩萨大愿智幻庄严解脱门故。善男子。如今世尊毗卢遮那我为其母。往昔所有无量诸佛。悉亦如是而为其母。善男子。我昔曾作莲华池神。时有菩萨。于莲华藏忽然化生。我即捧持。瞻侍养育。一切世间。皆共号我为菩萨母。又我昔为菩提场神。时有菩萨。于我怀中忽然化生。世亦号我为菩萨母。善男子。如是所有无量菩萨。住最后身。于此世界。种种方便。示现受生广大神变。我皆为母。善男子。如此世界贤劫之中。最初出现拘留孙如来。拘那含牟尼如来。迦叶如来。及今世尊释迦牟尼如来。现受生时。我为其母

大方广佛华严经卷第三十大方广佛华严经卷第三十一

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

善男子。如此贤劫未来世中。弥勒菩萨从兜率天将降神时。放大光明。普照法界。示现一切诸菩萨众住最后身受生自在广大神变。及于人间生大族家。调伏众生。我于彼时。亦为其母。如是次第。有师子如来。大法光幢如来。妙眼如来。清净拘苏摩华如来。妙华吉祥如来。提舍如来。弗沙如来。妙意如来。金刚如来。离垢如来。大月光如来。持炬如来。名称如来。金刚楯如来。清净义如来。见一义如来。绀身如来。超彼岸如来。宝焰光如来。宝焰山如来。持大炬如来。胜莲华如来。出生莲华如来。名称声如来。无量功德财如来。最胜灯吉祥如来。庄严身如来。妙称量如来。慈吉祥如来。妙威仪如来。变化如来。无住如来。胜威光如来。无边声如来。胜怨敌如来。除疑惑如来。清净如来。广博光如来。出现清净名称如来。云吉祥如来。种种色庄严顶髻如来。大树王如来。一切宝如来。种种色如来。宝耳珰如来。坚牢智如来。大海慧如来。净妙宝如来。莲华冠如来。胜力士如来。愿乐圆满如来。莲华鬘如来。大自在如来。吉祥主如来。最超胜如来。白栴檀云如来。绀青广博眼如来。微妙智如来。殊胜慧如来。观察慧如来。炽盛王如来。坚固慧如来。庄严王如来。具足吉祥如来。喜师子王如来。自在天如来。自在师子王如来。最胜顶吉祥如来。金刚智吉祥如来。山光明如来。妙德藏如来。妙宝网如来。庄严身如来。住妙慧如来。智自在如来。大自在天王如来。无得相吉祥如来。清净喜如来。善施惠如来。妙焰慧如来。水天吉祥如来。清净智如来。得上味如来。乘高峰如来。自在功德如来。护世怨如来。兴世语言如来。功德自在如来。威德幢如来。毗卢遮那妙幢如来。观身性如来。离有香如来。修习香如来。种种分别妙身如来。妙广博身如来。一切香焰王如来。种种色金刚摩尼严如来。微笑眼如来。离尘染如来。增长身如来。善变化聚集人天如来。广大天如来。财天如来。无上天如来。顺寂灭如来。开敷觉悟智如来。洗涤惑垢如来。大焰光王如来。寂诸有如来。毗舍佉天如来。金刚山如来。智焰光如来。大焰光身如来。作安乐如来。寂静师子如来。圆满清净如来清净妙贤如来。名称吉祥如来。勇猛精进如来。第一义行如来。寂静光如来。最胜增上如来。甚深声如来。一切大地主如来。绀青光如来。庄严王如来。妙音声吉祥如来。殊胜如来。尊胜吉祥如来。最胜自在如来。无上医王如来。功德月如来。微笑光如来。无碍光如来。功德聚如来。月高现如来。日天如来。无畏称如来。出诸有如来。勇猛名称如来。焰光面如来。娑罗王如来。名称聚如来。最胜如来。药王如来。宝胜如来。金刚慧如来。白净吉祥如来。寂静住处如来。摩尼王如来。无能胜如来。无能映蔽如来。众会王如来。大名称如来。速疾受持如来。无量光如来。大愿光如来。不空自在王如来。法自在王如来。高胜焰光如来。不退转地如来。清净天如来。妙善天如来。坚固行毁誉不动如来。一切善友如来。解脱音如来。游戏王如来。灭邪曲如来。薝卜净光如来。最胜德如来。极胜月如来。执明炬如来。殊妙身如来。不可说如来。最清净如来。友安众生如来。无量光明如来。无畏音声如来。水天功德如来。不动慧光如来。拘苏摩华胜如来。宝月焰光如来。不退转慧如来。离爱染如来。无著慧如来。集功德蕴如来。灭恶趣如来。不怯怖如来。普散华如来。师子吼如来。得第一义如来。得种种义如来。见无障碍如来。摧伏他众如来。疾风行如来。不动性如来。离分别海如来。无能胜如来。端严海如来。须弥山如来。香风智如来。无边座如来。斗战胜如来。无能行如来。清净住如来。最上施如来。随顺慈悲生如来。常月如来。饶益王如来。不动蕴如来。极妙意如来。随顺摄智如来。极高受如来。焰光身如来。无比名如来。饶益慧如来。持寿如来。灭我慢如来。种种色相如来。具足名称如来。大威德力如来。无灭如来。不动天如来。不思议吉祥如来。解脱月如来。最上王如来。满月蕴如来。梵供养如来。不动眼如来。希有身如来。无相慧如来。爱境界如来。极超过如来。高上事业如来。宝法慧如来。顺先古如来。无上吉祥如来。无胜梵天如来。不思议功德光如来。无上法境界如来。无边际贤如来。普顺自在如来。极尊胜天如来。如是乃至楼至如来。功德圆满住最后身。在贤劫中。于此三千大千世界当成佛者。我悉为母。如于此三千大千世界。如是于此华藏庄严世界海。一切世界种中所有世界。一一四天下阎浮提内。乃至十方一切世界海。其中所有。一切世界。尽未来际一切劫中。诸有修行普贤行愿。为欲调伏诸众生故。以自在力现受生时。我自见身悉为其母

尔时善财童子。白摩耶夫人言。大圣。得此菩萨大愿智幻庄严解脱。经几时耶。答言。善男子。乃往古世过不思议非最后身菩萨神通道眼所知劫数。尔时有劫。名为净光。世界名须弥德。虽有诸山五趣杂居。然其国土。无诸秽恶。众宝所成。清净圆满。庄严可爱。彼世界中。有千亿四天下。有一四天下。名香风威德师子幢。于中有八十亿王城。中有一城。名最胜具足幢。有转轮王。名勇猛精进大威德。彼王城北。有一道场。名种种妙色光。其道场神。名吉祥眼。时有菩萨。名无垢幢。坐于道场。将成正觉。有一恶魔。名金色光。与其眷属无量魔军。种种形状至菩萨所。欲为坏乱。彼转轮王。已得菩萨神通自在。以大神变。为欲摧碎彼魔军故。化大兵众。其数倍多。围绕道场。诸魔惶怖。悉自奔散。故彼菩萨得成阿耨多罗三藐三菩提。时道场神。见是事已。欢喜无量。便于彼王。而生子想。顶礼佛足。作是愿言。此大威德转轮圣王。在在生处。常为我子。乃至成佛。愿我常得与其为母。作是愿已。于此道场。复曾值遇十那由他佛。承事供养。令生欢喜。善男子。于意云何。彼道场神。岂异人乎。我身是也。转轮王者。今世尊毗卢遮那如来应正等觉是。我从于彼发愿已来。此佛世尊。于十方刹一切诸趣。处处受生。勇猛精进。种诸善根。供养如来。修菩萨行。教化成熟一切众生。乃至示现住最后身。念念普于十方世界。示现菩萨受生神变。常为我子。我常为母。善男子。过去现在十方无量一切世界诸佛如来。将成佛时。皆于脐中。出现种种广大光明。来照我身。及我眷属所居宫殿。彼最后身。我悉为母。善男子。我唯知此菩萨大愿智幻庄严解脱门。如诸菩萨摩诃萨。具大悲藏。以一切智。教化调伏一切众生。常无厌倦。住安忍行。恒知止足。服甘露味。心无有尽。一切众魔。及诸恶人。不能扰乱。心无动摇。心无轻躁。心无高下。心无谄幻。无稠林行。念念得入百千三昧。念念得见百千诸佛。念念得知百千佛力。念念能动百千世界。念念游履百千佛刹。念念光照百千世界。念念成熟百千众生。念念自在住百千劫。念念深入过去未来各百千劫。念念深解百千法门。念念示现百千佛身。念念示现百千菩萨。以为眷属。以自在力。念念普于一一毛孔。示现无量诸佛神变。于三宝所。究竟成就深信不坏。善巧了知种种诸行生灭分位。善巧了知种种诸法本性无生。善巧了知种种世间转变成坏。善巧了知种种诸业受生差别。善巧了知种种生死涅槃边际。善巧了知种种佛刹染净不同。善巧了知过去未来一切菩萨种种修习。善巧了知一切诸法无相无尽。而我云何能知能说彼诸菩萨行智功德。善男子。此三十三天有王。名具足正念。其王有女。名天主光。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。敬受其教。头面礼足。绕无数匝。殷勤恋慕。一心瞻仰。辞退而去

尔时善财。顺知识教。遂即往诣三十三天具足正念天王宫中。见彼天女。礼足围绕。合掌前住。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。天女告言。善男子。我得菩萨无碍念清净庄严解脱门。善财白言。圣者。此解脱门。境界云何。修行何法得此解脱。天女答言。善男子。菩萨。勤修无量不思议法门。得此解脱。汝若欲入此解脱门。亦当如是精勤修学。云何勤修不思议法门。所谓汝应勤修不可思议诸法义智。谓如实觉悟一切诸法。差别性相真实体故。汝应勤修守护正法。谓种种妙法。为人诽谤。以理摧伏。显胜义故。汝应勤修表无表戒。谓若性若遮。有罪无罪。微细观察。无缺减故。汝应勤修无诤讼法。谓世间种种绮杂言说。无益集会。常远离故。汝应勤修住安忍地。谓种种苦恼逼迫身心。审谛观察。能忍受故。汝应勤修忍耐诸境。谓恶言毁辱。怨结毒害。不坏内心。常安忍故。汝应勤修解微细法。谓知蕴界处流转还灭。善了性相不可得故。汝应勤修善巧法句。谓巧能宣说种种法门。真实性相令显现故。汝应勤修合不合法。谓了知诸法性不可夺。亦无增减。离合等故。汝应勤修观过去智。谓微细观察种种业因。善恶等相无不知故。汝应勤修未来际智。谓微细观察种种业缘。果报等相无不知故。汝应勤修三世平等。谓三世行相虽各不同。但随住法有差别故。汝应勤修三轮清净。谓过现未来一切诸法。性不可得离心意故。汝应勤修心住处法。谓普遍了知内外中间。心相本性不可得故。汝应勤修守护威仪。谓一切时中微细观察身口意业不迷惑故。汝应勤修清净威仪。谓密护根门。藏覆善法。所有不善。恒发露故。汝应勤修离不善法。谓愚痴凡夫。种种恶法不与共住。常觉悟故。汝应勤修集菩萨行。谓普遍了知勇猛精进。难行能行种种行故。汝应勤修恭敬尊长。谓床座供具。给侍奉迎。身心谦下。无懈怠故。汝应勤修摄持身心。谓普能摄持诸清净法。不失不坏。常了知故。汝应勤修随顺觉智。谓于诸世间出世间法。随顺性相而觉悟故。汝应勤修入甚深法。谓了达一切生灭法相。令心增长无生智故。汝应勤修音声法智。谓如实演说种种法门。开示语言真实性故。汝应勤修远离无益。谓以诸方便。令自及他。超过诸有无益法故。汝应勤修丈夫集会。谓诸佛菩萨声闻独觉。亲近承事。常供养故。汝应勤修远恶知识。谓远离乐起断常诸见。及懒惰等恶众生故。汝应勤修不依凡夫谓见凡夫。法皆与愚痴而共相应多过失故。汝应勤修常不轻心。谓于诸众生。了性平等。不于贫下生轻贱故。汝应勤修愍破戒者。谓以大慈悲。拔济犯罪。安置菩萨净戒中故。汝应勤修增慈悲力。谓观察十方三世众生。种种逼迫。能救护故。汝应勤修财法摄受。谓财物饮食。摄诸众生。令入甚深真实法故。汝应勤修如说能行。谓修种种善。开发自心。具足敷荣。得圆满故。汝应勤修昔相应善。谓求宿住智。善巧多闻。能知过去相应行故。汝应勤修乐独善寂。谓远离处众诸杂谈说。常乐亲近白净法故。汝应勤修少欲知足。谓衣服饮食。卧具医药。自作教他。知止足故。汝应勤修相应行法。谓三十七品菩提分法。常勤修习。令相应故。汝应勤修菩萨行境。谓十波罗蜜。一切行门。具足修习。令圆满故。汝应勤修菩萨地法。谓十种智地入住。及出相及得果。皆证知故。汝应勤修入如来地。谓若菩提智。及所断障种种体用。皆证得故。汝应勤修难了知法。谓诸佛菩萨独觉声闻皆悉了知不思议故。汝应勤修不取诸相。谓修习觉悟诸法性相。如幻如梦。同实相故。汝应勤修解脱法智。谓金刚三昧。散坏尘习澄静妄念智不动故。善男子。有如是等佛刹极微尘数不可思议种种法门。我皆勤修。得此解脱。汝能修行。亦当证得。善男子。汝向所问解脱境界。我此解脱境界无边。又善男子。我以得此解脱力故。忆念古世。尔时有劫。名优钵罗华。于彼劫中。承事供养恒河沙数诸佛如来。彼诸如来。从初出家。我皆瞻奉。守护供养。造僧伽蓝。营辨资具。又彼如来从为菩萨。入母胎时。诞生之时。行七步时。师子吼时。童子位时。处宫中时。厌弃王位初出家时。诣菩提树成正觉时。转正法轮现佛神变。教化调伏诸众生时。如是一切诸所作事。从初发心。行菩萨道。乃至法尽。我皆明记。无有遗余。常现在前。念持不忘又忆过去。劫名善地。我于彼劫。复得值遇十恒河沙诸佛如来。承事供养。复忆有劫。名为妙德。于彼值遇十佛世界极微尘数诸佛如来。承事供养。又忆往劫。名无所得。于彼值遇八十百千亿那由他诸佛如来。承事供养。复忆有劫。名为妙光。于彼值遇阎浮提极微尘数诸佛如来。承事供养。复忆往劫。名无称光。于彼值遇二十恒河沙诸佛如来。承事供养。复忆往劫。名最胜吉祥。于彼值遇一恒河沙诸佛如来。承事供养。复忆往劫。名出现日。于彼值遇八十恒河沙诸佛如来。承事供养。复忆往劫。名胜性游行。于彼值遇六十恒河沙诸佛如来。承事供养。复忆有劫。名为妙月。于彼值遇七十恒河沙诸佛如来。承事供养。善男子。如是忆念恒河沙劫。我常不离诸佛如来应正等觉。种种方便。恭敬供养。从彼一切诸如来所。皆得闻此无碍念清净庄严菩萨解脱。闻已受持。如说修行。恒不忘失。如是往劫。所有如来。从初发心。乃至法尽。诸所作事。我皆以此清净庄严解脱之力。随顺忆念。明了现前。持而顺行。念念观察。曾无懈废。善男子。我唯知此无碍念清净庄严菩萨解脱。如诸菩萨摩诃萨。出生死夜。朗然明彻。永离痴冥。未尝昏寐。心无诸盖。身行轻安。于诸法性。清净觉了。决择甚深修多罗藏了不了义。一切难处。善护自他。常勤修习菩萨净戒。若利非利。心恒平等。善巧出生神通妙智。随顺世间。种种方便。增长福慧。心无厌足。起大精进。勤修助道。积集慈悲。心无厌倦。成就如来十力无畏十八不共一切佛法。随顺开悟一切众生。昼夜精勤。更无余念。而我云何能知能说彼功德行。善男子。此迦毗罗城。有童子师。名为遍友。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。以闻法故。欢喜踊跃。不思议善根速疾增长。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财。从天宫下。向迦毗罗城。诣遍友所。礼足右绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。遍友答言。善男子。此有童子。名善知众艺。修学菩萨字智法门。汝可问之。当为汝说。尔时善财。即至其所。顶礼其足。绕无数匝。于前合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时彼童子。告善财言。善男子。我得菩萨解脱。名具足圆满善知众艺。我恒唱持此之字母。所谓。唱婀字时。能甚深入般若波罗蜜门。名以菩萨胜威德力显示诸法本无生义。唱啰字时。能甚深入般若波罗蜜门。名普遍显示无边际微细解。唱跛字时。能甚深入般若波罗蜜门。名普照法界平等际微细智。唱者字时。能甚深入般若波罗蜜门。名普轮能断差别色。唱曩(鼻音)字时。能甚深入般若波罗蜜门。名证得无依无住际。唱攞字时。能甚深入般若波罗蜜门。名离名色依处无垢污。唱娜字时。能甚深入般若波罗蜜门。名不退转方便。唱婆(摹我反)字时。能甚深入般若波罗蜜门。名金刚轮道场。唱拏字时。能甚深入般若波罗蜜门。名普圆满轮。唱洒(史我反)字时。能甚深入般若波罗蜜门。名为海藏。唱嚩(无可反)字时。能甚深入般若波罗蜜门。名普遍勤求出生安住。唱哆字时。能甚深入般若波罗蜜门。名星宿月圆满光。唱也(移我反)字时。能甚深入般若波罗蜜门。名差别积集。唱瑟吒(二合上)字时。能甚深入般若波罗蜜门。名普照光明息除烦恼。唱迦(上)字时。能甚深入般若波罗蜜门。名普云不断。唱娑(苏我反)字时。能甚深入般若波罗蜜门。名降注大雨。唱莽字时。能甚深入般若波罗蜜门。名大速疾现种种色如众高峰。唱誐(言迦反上)字时。能甚深入般若波罗蜜门。名普轮积集。唱他(上)字时。能甚深入般若波罗蜜门。名真如平等无分别藏。唱惹(上)字时。能甚深入般若波罗蜜门。名遍入世间海游行清净。唱娑嚩(二合)字时。能甚深入般若波罗蜜门。名普念诸佛一切庄严。唱驮字时。能甚深入般若波罗蜜门。名微细观察一切法聚。唱舍(上尸我反)字时。能甚深入般若波罗蜜门。名随顺诸佛教轮光明。唱佉(上)字时。能甚深入般若波罗蜜门。名因地现前智慧藏。唱乞叉(二合)字时。能甚深入般若波罗蜜门。名息诸业海出生智慧藏。唱娑(苏纥反)哆(二合上)字时。能甚深入般若波罗蜜门。名开净光明蠲诸惑障。唱娘(上)字时。能甚深入般若波罗蜜门。名出离世间智慧门。唱曷啰他(三合上)字时。能甚深入般若波罗蜜门。名利益众生无我无人智慧灯。唱婆(蒲我反)字时。能甚深入般若波罗蜜门。名圆满庄严一切宫殿。唱车(车者反上)字时。能甚深入般若波罗蜜门。名增长修行方便藏普覆轮。唱娑么(么音二合)字时。能甚深入般若波罗蜜门。名随顺十方现见诸佛旋转藏。唱诃嚩(无我反二合)字时。能甚深入般若波罗蜜门。名观察一切微细众生方便力出生海藏。唱哆娑(二合)字时。能甚深入般若波罗蜜门。名自在趣入诸功德海。唱伽字时。能甚深入般若波罗蜜门。名普持一切法云。坚固海藏。唱姹(上)字时。能甚深入般若波罗蜜门。名愿力现见十方诸佛犹如虚空。唱儜(上)字时。能甚深入般若波罗蜜门。名入字轮际无尽境界。唱颇字时。能甚深入般若波罗蜜门。名教化众生究竟圆满处。唱娑迦字时。能甚深入般若波罗蜜门。名广大藏无碍辩遍照光明轮。唱夷娑(二合)字时。能甚深入般若波罗蜜门。名演说一切佛法智。唱室者(二合)字时。能甚深入般若波罗蜜门。名入虚空一切众生界法雷大音遍吼。唱侘(上)字时。能甚深入般若波罗蜜门。名说无我法开佛境界晓悟群生。唱荼(去)字时。能甚深入般若波罗蜜门。名一切法轮差别藏。善男子。我唱如是字母之时。此四十二般若波罗蜜门为首。一切章句。随转无碍。能甚深入无量无数般若波罗蜜门。善财白言。圣者。云何修行得此解脱。答言。善男子。若诸菩萨。勤修十法。具足圆满。则能得此善知众艺菩萨解脱。何等为十。所谓具足智慧勤求善友。勇猛精进离诸障惑。正行清净尊重正教。观法性空灭除邪见。修习正道具真实智。若诸菩萨。于此十法。具足圆满。则能速疾得此解脱。所以者何。由诸菩萨具足智慧勤求善友。见已亲近。欢喜爱敬生如佛想。以亲近故。常蒙教诲。蒙教诲故。则能难行勇猛精进。得精进已。能以善法灭诸不善。灭不善故。令众善法皆得圆满。善圆满已。则能远离一切障惑。离诸障故。令身口意得大清净。正行相应。由此清净。能于一切诸佛菩萨善知识教。心生尊重。尊重教故。勤求观察诸法空寂。悟法空已。其心所向。皆无挂碍。深达缘起。离无因见。灭邪见心。修习正道。入正道已。得真实智。得实智故。得此解脱。证深法界。善财复言。此真实者。名为何等。答言。善男子。即此语言。是名真实。善财复言。云何语言。名为真实。答言。善男子。不虚诳语。是名真实。复言云何不虚诳语。众艺答言。彼语真实。体常不变。恒一性故。复言云何不变异性。答言。善男子。自身证悟解法性故。复言。法性相貌云何能所解法。为一为二。答言。善男子。如是菩萨。自所证法。不一不二。由此力故。则能平等利益自他。犹如大地能生一切。而无彼此。能所利心然其法性。亦非有相。亦非无相。体如虚空。难知难解。善男子。此法微妙。难以文字语言宣说。何以故。超过一切文字境界故。超过一切语言境界故。超过一切语业所行诸境界故。超过一切戏论分别思量境界故。超过一切寻伺计度诸境界故。超过一切愚痴众生所知境界故。超过一切烦恼相应魔事境界故。超过一切心识境界故。无此无彼。无相离相。超过一切虚妄境界故。住无住处寂静圣者境界故。善男子。彼诸圣者。自证境界。无色相。无垢净。无取舍。无浊乱。清净最胜。性常不坏。诸佛出世。若不出世。于法界性。体常一故。善男子。菩萨为此法故。行于无数难行之行。得此法体。善能饶益一切众生。令诸众生于此法中究竟安住。善男子。此是真实此不异相。此是实际。此是一切智体。此是不思议法界。此是不二法界。此是善知众艺圆满具足菩萨解脱。善男子。我唯知此解脱。如诸菩萨摩诃萨。能于一切世出世间。善巧之法。殊能异艺文字算数。咸综无遗。又善了知医方咒术。有诸众生。鬼魅所持。怨憎咒诅。妖幻所迷。死尸奔逐。癫痫羸瘦。及诸蛊毒。种种异疾。咸能救之。使得痊愈。又善别知。殊珍异货。金玉珠贝。珊瑚琉璃。摩尼砗磲。玻璃码瑙。铜铁铅锡。鸡萨罗等。一切宝藏。出生之处。品类不同。价直多少。村营国邑。大小都城。宫殿苑园。岩泉薮泽。凡是一切人众所居。菩萨咸能随方摄护。又知其身具有六百六十三相。于诸相中。校其优劣。知其苦乐。定其吉凶。辨其修短。虽具众相。不及好声。虽多好声。不如胜福。及知此福所修之业。可转不转。定不定报。又善观察天文地理。谶纬阴阳。人相吉凶。恶星变怪。云霞气候。鸟兽音声。水陆往还。征应休咎。年谷丰俭。国土安危。如是世间。所有艺能。靡不该练。尽其源本。又能分别出世之法。正名辨义。观察体相。微细甚深。决择宣说。随顺修行。智入其中。无疑无碍。无愚闇。无顽钝。无忧恼。无沉没。无不现证。而我云何能知能说彼功德行。善男子。此摩竭提国。有一聚落。名为有义。彼中有城。名婆怛那。有优婆夷。名最胜贤。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼众艺足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

大方广佛华严经卷第三十一大方广佛华严经卷第三十二

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。渐次前行。诣婆怛那城有义聚落。至于贤胜优婆夷所。顶礼其足。绕无数匝。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何。学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。贤胜告言。善男子。我得菩萨解脱。名无住处无尽轮。既自开解。复为人说。我住于此大三昧中。出生诸法。无尽无住。所谓出生一切智性眼。无尽无住。出生一切智性耳。无尽无住。出生一切智性鼻。无尽无住。出生一切智性舌。无尽无住。出生一切智性身。无尽无住。出生一切智性意。无尽无住。出生一切智性功德波涛。无尽无住。出生一切智性智电光明。无尽无住。出生一切智性照众生智。无尽无住。出生一切智性速疾神通。无尽无住。善男子。我唯知此无住处无尽轮解脱门。如诸菩萨摩诃萨。一切无著功德智行无尽法门。而我云何能知能说。善男子。于此南方。有一大城。名为沃田。彼有长者。名坚固解脱。鬻金为业。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时善财。礼贤胜足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。渐次南行。到于彼城。诣长者所。礼足右绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。长者告言。善男子。我得菩萨解脱。名无著念清净庄严。我自得是解脱已来。于十方界一切佛所。勤求正法。无有休息。善男子。我唯知此无著念清净庄严解脱门。如诸菩萨摩诃萨。获无所畏。犹师子吼。安住广大福德智慧殊胜之聚。以大音声。开悟群品。如是菩萨功德智行。而我云何能知能说。善男子。即此城中。有一长者。名为妙月。其所住宅。常有光明。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼长者足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。即诣妙月长者所。礼足右绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。妙月答言。善男子。我得菩萨解脱。名无垢智光明。善财白言。圣者云何修行得此解脱。长者告言。善男子。若诸菩萨。能行十法。则能具足得此解脱。何等为十。所谓常不舍离诸善知识。常不舍离忆念见佛。常不舍离乐闻正法。常不舍离于佛菩萨善知识所先意问讯恭敬供养。常不舍离多闻智慧善友法师能说法者。常不舍离听闻一切波罗蜜行。常不舍离听闻一切菩提分法。常不舍离三解脱门。常不舍离四梵住法。常不舍离一切智体。善男子。若诸菩萨。常不舍离如是十法。则能得此无垢智光解脱门。善财复言。圣者。此解脱门。云何现前。而能证得。长者答言。善男子。现前当作般若波罗蜜心。极令相应。随所见知。皆能证入。善财复言。圣者。为由听闻般若波罗蜜言说章句而现证耶。答言不也。何以故。般若波罗蜜。见一切法真实体性。而现证故。善财白言。岂不由于从闻生智。及思智性。得见真如。而自证悟。长者答言。不也。若从闻思。得自证悟。无有是处。善男子。我于此义。应说譬喻。汝当谛听。如大沙碛中无泉井。春夏热时。有人从西向东而行。遇有丈夫从东而来。即问之言。我今热渴。何处有水清凉树阴。我欲于中饮浴休憩除其热渴。彼大丈夫。善知善说。而告之言。从此东行。有其二路。一左一右。宜从右路。勤力而行。决定当得至甘泉所及庇清阴。善男子。于意云何。彼热渴者。虽闻如是泉及树名。思惟往趣。能除热渴获清凉不。答言不也。何以故。要依示道。至彼泉池。沐浴饮用。方除热渴。乃得清凉。善男子。菩萨亦尔。不但唯以闻思慧解而能证入一切法门。善男子。言沙碛者。即谓生死。西来人者。谓诸众生。热谓众惑。渴即贪爱。东来知道大丈夫者。即佛菩萨住一切智。得法真性平等实义是也。得清净水无热渴者。即自证悟真实是也。复次善男子。我今为汝。重说譬谕。汝应谛听。善男子。假使如来住寿一劫。种种方便。以巧言辞。为阎浮人。说天苏陀。具足众德。柔软妙触。色香美味。于意云何。彼诸众生如是听受思惟之时。知天味不。白言不也。妙月告言。此亦如是。不但闻思而能证入般若真性。善财复言。云何菩萨。善巧宣说。令诸众生真实得证。妙月告言。善男子。菩萨所证般若真性。是彼言说。决定正因。为由证得此解脱故。能为众生善巧宣说。复次菩萨。具足十法。得此解脱。何等为十。一者远离诸不善法。二者不违如来制戒。三者远离一切悭嫉。四者供养一切如来。五者勤修一切福业。六者具足智慧。七者具足方便。八者具足大愿。九者具足厌离。十者具足精进。若诸菩萨。具足十法。证此解脱。善男子。我唯知此无垢智光菩萨解脱门。如诸菩萨摩诃萨。修行种种菩萨智门。常勤作意。行无上业。其心正直。志性调柔。常乐寂静。安住大悲。不离世间。心无染着。诸所施为。不望恩报。常念诸佛广大境界。常思诸佛真实妙法。常乐亲近诸菩萨僧。常行菩萨诸波罗蜜。常住菩萨所证诸地。常观如来力无所畏不共佛法。证入无量大三昧海。究竟解脱真实法门。而我云何。能知能说彼功德行。善男子。于此南方有城。名广大声。彼有长者。名无胜军。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。是时善财。礼妙月足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。思惟所得智光解脱。渐次南行。向彼大城。诣长者所。礼足右绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无尽相。我以证此解脱门故。见无量佛。得无尽藏。善财复言。菩萨云何得此解脱。答言。善男子。菩萨若能勤修十法。则能证得如是解脱。何等为十。一者应处闲寂深观五欲。为欲修习诸禅定故。二者应勤方便入诸三昧。普现色身。化众生故。三者应以智慧平等观察生死涅槃。同一相故。四者应勤修习坚固念力。知善不善。无忘失故。五者应勤积集菩萨功德波罗蜜道。无厌足故。六者应勤种植净戒林树。于法园苑。常游戏故。七者应勤救护恶见众生。令超邪径住正见故。八者应勤给施种种法药。除灭众生烦恼病故。九者应勤观察三世诸法如梦幻等。无染着故。十者应勤摧伏外道邪论。不令异见损众生故。若诸菩萨。勤求修习。具此十法。即能证得如是解脱。亦于无数百千法门。入出自在。复次善男子。菩萨若能远离十法。得此解脱。何等为十。一者远离一切破诸禁戒补特伽罗。二者远离一切破诸正见补特伽罗。三者远离一切破正威仪补特伽罗。四者远离一切破正活命补特伽罗。五者远离一切杂说世论补特伽罗。六者远离一切懈怠懒惰补特伽罗。七者远离一切贪着欲乐补特伽罗。八者远离一切常乐亲近在家白衣补特伽罗。九者远离一切乐修邪福不住正行出家在家补特伽罗。十者远离一切深重烦恼身心放逸不可谏止补特伽罗。若诸菩萨。常能远离如是十种诸不善人而亦于彼不怀厌舍。亦不于彼生下劣心。但应慈念摄受调伏。菩萨复念一切众生处生死中。由近如是不善人故。坏诸善根。堕于恶趣。常当远离一切恶人。善男子。是为菩萨远离十法。即能证得如是解脱。善男子。我唯知此无尽相解脱门。如诸菩萨摩诃萨。大悲为首。发起众行。过去愿力。皆悉现前。坚固勤求一切智智。积集庄严种种佛土。甚深观察一切诸法一切体性。常乐勤求一切如来力无所畏。不共佛法相。及随好圆满音声。乃至一切增上功德。无不现证。于诸如来甚深解脱。能随顺解方便善巧。皆能悟入。知诸众生。我人寿命。士夫养育。补特伽罗。蕴处界等。性皆空寂。无所执着。常能利乐一切世间。令其安隐。无诸烦恼。常勤爱乐一切智智常勤救护一切众生。常勤尊重一切正法。闻法爱乐。随顺修行。能以正说饶益众生。咸令安乐。不入世趣。住胜精进。相续不断。住不退转。无杂染行。具足广大平等智道。誓度众生。无能制伏。如是菩萨功德智行。而我云何能知能说。善男子。于此城南。有一聚落。名为达磨。有婆罗门。名最寂静。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼无胜军足。绕无数匝。殷勤瞻仰。恋慕而去

尔时善财童子。思惟忆念无尽相解脱门。渐次前行。诣彼聚落。向最寂静婆罗门所。见已礼足。围绕恭敬。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时婆罗门。告善财言。善男子。我得菩萨解脱。名诚愿语。一切菩萨。由此诚愿真实语故。皆于阿耨多罗三藐三菩提。无退转者。无已退。无现退。无当退。善男子。我以住此真实威德诚愿语故。于诸世间出世间法。一切所作。无不成就。随所愿求。皆令满足。善财白言。圣者。今此解脱真实威德。名诚愿语。是何义耶。婆罗门言。善男子。诚愿语者。是如如义。不变异义。无二体义。胜义谛义。三世如来法身体义。善财复言。一切菩萨。云何修习得此法身。答言。善男子。菩萨若能修十种法。具足圆满。得此法身。何等为十。所谓平等身。清净身。无尽身。修集身。法性身。离寻伺身。不思议身。寂静身。虚空身。妙智身。若诸菩萨具此十身。则得如来清净法身。善财复言。圣者诸菩萨等。住此解脱。于何等位。得此十身。婆罗门言。善男子。菩萨初地。住此解脱。得平等身。何以故。通达法性。离诸邪曲。见法平等故。菩萨二地。住此解脱。得清净身。何以故。离犯戒垢。于一切戒性。常清净故。菩萨三地。住此解脱。得无尽身。何以故。离欲嗔恚悭嫉恶法。住诸胜定故。菩萨四地。住此解脱。得修集身。何以故。常勤修集一切诸佛菩提分法故。菩萨五地。住此解脱。得法性身。何以故。观察觉悟一切谛理。证法体性故。菩萨六地。住此解脱。得无寻伺身。何以故。观缘起理。难解难知。非寻伺境界故。菩萨七地。住此解脱。得不思议身。何以故。集诸佛法方便善巧。智行满足故。菩萨八地。住此解脱。得寂静身。何以故。一切烦恼不复现行。离诸世间戏论等事故。菩萨九地。住此解脱。得虚空身。何以故。身相无边。遍满一切故。菩萨十地。住此解脱。得妙智身。何以故。一切种智微妙境界。普集圆满故。善财复言。如来法身。与彼菩萨十种法身。有何差别。答言。善男子。当知法身体性无异。功德威力有差别耳。善财复言。是义云何。答言。善男子。谓佛菩萨所有法身。等无差别。所以者何。以一切法性相平等同一体故。如是乃至凡圣迷悟。染净因果。去来进退。皆同一相。所言功德威力异者。即如来身。功德圆满。具胜威力。菩萨不尔。由此事故。我当为汝宣说譬谕开示其义。善男子。譬如摩尼妙宝真珠。未经巧匠雕饰磨莹。无有光彩。凡所见者。不生爱重。若经磨莹。光彩炽盛。人天宝重。珠体无异。相差别故。虽诸菩萨与如来身同一体性俱名法身。不可说言难思清净功德智宝神通威力。同于如来。所以者何。以诸如来。于无数劫。净修一切微妙功德。究竟圆满。无边无量。如太虚空。满十方界。妙善清净。离诸惑垢。广大光明。无所不照。殊胜威力。普济众生。其诸菩萨。虽具法身。功德未圆。有余垢故。譬如白月。从初一日。至十五日。名体虽同。光相有异。何以故。满不满相有差别故。善男子。菩萨法身。与佛法身。亦复如是。满不满相。有差别故。以菩萨身。如从月初。至十四日。所有光明。不能圆照。如来法身。如十五日。白月圆满。光明普照。无有限碍。而彼菩萨十种法身。与如来身。同一体性。无有二相。但由所修功德有异。不可言一。是故善男子。若诸菩萨。住此解脱。具足十身。则能证得诸佛功德。圆满法身。复次菩萨由十种义。得于金刚不可坏身。何等为十。一者一切烦恼贪嗔痴毒不能坏故。二者我慢悭嫉邪见颠倒不能坏故。三者一切恶趣苦恼逼迫不能坏故。四者利衰毁誉称讥苦乐不能坏故。五者生老病死愁叹忧恼不能坏故。六者一切异见外道邪论不能坏故。七者诸烦恼魔蕴魔死魔不能坏故。八者一切天魔及魔眷属不能坏故。九者一切声闻及诸独觉不能坏故。十者一切世间可爱欲境不能坏故。菩萨若能具此十义。则得诸佛犹如金刚不可坏身。善男子。复有十种善巧正道。能正了知无邪谬说。何等为十。一若诸众生。应以大乘而调伏者。为说种种菩萨乘道。不为演说声闻乘道。二若诸众生。应声闻乘而调伏者。为说种种声闻乘道。不为演说菩萨乘道。三若诸众生。应以佛乘而调伏者。为说如来一切智道。不为演说独觉乘道。四若诸众生。应独觉乘而调伏者。为说种种独觉乘道。不为演说一切智道。五若诸众生。执着我法。为说无我及诸法空。不说我人众生寿命。士夫养育。补特伽罗。假我法道。六若诸众生。执著有无。为说处中离边际法。不说有无堕边际法。七若诸众生。其心散乱。为说寂静诸奢摩他毗钵舍那。不说种种散乱道法。八若诸众生。爱乐世法。为说出世如如智道。不说愚痴婴儿之道。九若诸众生。乐处生死。为说涅槃出生死道。不说住世化众生道。十若诸众生。执法空等。不行正道。为说正直无棘刺法。不说棘刺诸邪险道。善男子。若诸菩萨。具此十法。得入正道善能了知。无邪谬说。所言诚实。善男子。我唯知此住诚愿语无尽威德菩萨解脱。如诸菩萨摩诃萨。与诚愿语。行止无违。心常随顺。无有退转。被本愿力坚固甲胄。大慈悲心。不舍众生。增长福智。心无厌足。善巧方便。相续现前。勤修增上光明地智。随顺觉悟诸蕴界处。深入众生善知正道。菩萨地智。安住过去佛法平等清净心。安住未来佛法平等清净心。安住现在佛法平等清净心。安住戒性平等清净心。安住心性平等清净心。安住见性平等清净心。安住能断自他疑性平等清净心。安住一切正道非道智性平等清净心。安住修道灭惑智行性平等清净心。安住一切菩提分法增上修习平等清净心。安住调伏一切众生广大悲化平等清净心。言必以诚。未曾虚妄。出生无量功德智门。而我云何能知能说。善男子。于此南方有城。名妙意华门。彼有童子。名为德生。复有童女。名为有德。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。于此大法。起尊重心。礼婆罗门足。绕无数匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。于最寂静婆罗门所。得此大法。熏习其心。渐次南行。诣妙意华门城。见德生童子。有德童女顶礼其足。绕无数匝。于前合掌。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。唯愿慈哀。为我宣说。时童子童女。告善财言。善男子。我等证得菩萨解脱。名为幻住。得此解脱。具足圆满。以斯净智。遍观诸法。无非幻住幻所成就。所谓见一切世界皆幻住。因缘所生故。见一切众生皆幻住。业烦恼所起故。见一切世间皆幻住。无明有爱等展转缘生故。见一切诸法皆幻住。我见等种种幻缘所生故。见一切三世皆幻住。我见等颠倒智所生故。见一切众生生老病死忧悲苦恼皆幻住。本无今有。虚假不实。妄想分别所生故。见一切刹土皆幻住。想心见倒无明所生故。见一切声闻辟支佛皆幻住。智断分别所成故。见一切菩萨皆幻住。能自调伏成熟众生诸行愿法相续现前之所成故。见一切诸佛及诸菩萨众会变化神通威力诸所施为皆幻住。种种解行广大愿智熏习所成故。善男子。幻境自性不可思议。我等二人。但能知此幻住解脱。如诸菩萨摩诃萨。善入无边诸幻事网。随顺了知幻所成智。彼功德行。而我云何能知能说。时德生童子有德童女。说自解脱已。以不思议诸善根力。令善财身。速疾增长柔软光泽。告善财言。善男子。于此南方近海门处。有一国土。名为沃田。彼国有园。名大庄严。其中有一广大楼阁。名毗卢遮那庄严藏。从菩萨种种善根果报生。从菩萨种种念力愿力自在力神通力生。从菩萨种种善巧方便生。从菩萨种种福德智慧生。善男子。住不思议解脱菩萨。以大悲心。为诸众生。普遍显现如是境界。广大集起如是庄严。弥勒菩萨摩诃萨。安止其中。为欲摄受本所生处。父母亲属。及诸人众。令成熟故。又欲令彼同受生。同修行。同类众生。于大乘中得坚固故。又欲令彼一切众生。随所住地。随本善根。皆成熟故。又欲为汝显示菩萨解脱门故。显示菩萨遍一切处。随本愿力。受生自在故。显示菩萨以种种身。普现一切众生之前。开示觉悟常教化故。显示菩萨以大悲力。普摄一切世间资财惠施众生而不厌故。显示菩萨具修诸行。知一切行。离诸相故。显示菩萨处处受生。了一切生皆无相故。汝诣彼问。菩萨云何行菩萨行。云何修菩萨道。云何学菩萨戒。云何净菩萨心。云何发菩萨愿。云何集菩萨助道具。云何入菩萨自在地。云何满菩萨波罗蜜。云何获菩萨无生忍。云何具菩萨功德法。云何事菩萨善知识。何以故。善男子。彼菩萨摩诃萨。深入一切菩萨行愿。随顺一切众生心性。遍一切处。常现其前。教化调伏。彼菩萨。已满一切波罗蜜。已住一切菩萨地。已证一切菩萨忍。已入一切菩萨位。已蒙授与具足记。已游一切菩萨境。已入菩萨解脱门。已得一切佛神力。已蒙十方一切如来以一切智甘露法水而灌其顶。善男子。彼善知识。能润泽汝诸善根。能增长汝菩提心。能坚固汝广大志。能发起汝一切善。能增长汝菩萨根。能示教汝无碍法。能令汝入普贤地。能令汝住菩萨愿。能令汝行普贤行。能为汝说一切菩萨无量行愿所成功德。令汝显示普贤菩萨自在法门。善男子。汝今不应修一善根。照一法门。发一大愿。受一记别。住于一忍。生究竟想。不应以限量心行于最胜诸波罗蜜。不应以限量心住于菩萨圆满十地。不应以限量心严净一切诸佛国土。不应以限量心承事供养诸善知识。何以故。善男子。菩萨摩诃萨。应种无量诸善根。应集无量助道具。应修无量菩提因。应学无量巧回向。应化无量众生界。应照无量众生心。应知无量众生根。应识无量众生解。应觉悟无量众生。应调伏无量众生。应断无量烦恼。应净无量业习。应灭无量邪见。应除无量杂染心。应发无量清净心。应拔无量苦毒箭。应涸无量爱欲海。应破无量无明闇。应摧无量我慢山。应解无量生死缚。应度无量诸有流。应竭无量受生海。应令无量众生出五欲淤泥。应使无量众生离三界牢狱。应置无量众生于圣道中。应销无量贪欲行。应灭无量嗔恚行。应摧无量愚痴行。应破无量魔罥网。应舍无量魔事业。应净菩萨无量心。乐欲。应长菩萨无量巧方便。应生菩萨无量增上根。应起菩萨无量决定解。应悟菩萨无量平等体。应净菩萨无量胜功德。应治菩萨无量诸行海。应满菩萨无量清净行。应现菩萨无量世间行。应顺菩萨无量方便行。应生无量净信力。应住无量精进力。应净无量正念力。应满无量三昧力。应起无量净慧力。应坚无量胜解力。应集无量福德力。应增无量智慧力。应发无量菩萨力。应满无量如来力。应分别无量法门。应深入无量法门。应清净无量法门。应生无量法光明。应作无量法照耀。应照无量品类根。应知无量烦恼病。应集无量妙法药。应疗无量众生疾。应辨无量甘露供。应往无量佛国土。应供无量诸如来。应入无量菩萨会。应受无量如来教。应忍无量众生恼。应令无量众生离恶趣。应与无量众生胜安乐。应以四摄摄无量众生。应入无量总持门。应生无量大愿门。应修无量慈悲力。应求无量诸佛法。应起无量思惟力。应起无量神通事。应净无量智光明。应往无量众生趣。应受无量诸有生。应现无量差别身。应受无量诸苦恼。应顺无量凡夫法。应知无量众生苦。应说无量诸佛法。应舍无量内外财。应施无量福田境。应护无量诸善根。应近无量善知识。应调无量自种族。应修无量佛法。应说无量佛法。应赞无量持戒。应觉无量破戒。应回向无量善巧法。应了知无量梦幻法。应令无量众生住清净戒。应与无量众生金刚定。应令无量众生舍有见。应令无量众生速离三界。应令无量众生观无我。应令无量众生悟三乘。应入无量差别心。应思菩萨大境界。应住菩萨大宫殿。应观菩萨甚深法。应知菩萨难知境。应行菩萨难行行。应严菩萨尊重德。应践菩萨难入位。应知菩萨种种行。应现菩萨普遍神力。应受菩萨平等法云。应广菩萨无边行网。应满菩萨无边诸度。应授菩萨无量记别。应入菩萨无量忍门。应具菩萨无量智通。应入菩萨无量诸因缘。应示菩萨无量难解法。应显菩萨无量所作业。应断菩萨无量三毒苦。应尽菩萨无量惑根本。应净无量菩萨地。应说无量诸法门。应净无量诸佛刹。应擐无量菩萨甲胄。应承事无量如来。应发不思议菩萨愿。应修不思议菩萨行。应受不思议菩萨教。应知不思议菩萨顺烦恼行。应知不思议菩萨离烦恼行。应净不思议菩萨有为过。应知不思议菩萨称赞涅槃甚深利益。应知不思议如来功德。如是不思议如来赞叹。不思议如来名称。不思议涅槃名称。不思议种种世法。不思议除灭世法。不思议妙行。不思议语言。不思议杂烦恼行。不思议灭烦恼行。不思议妙行金刚句。不思议语言金刚句。不思议杂烦恼金刚句。不思议灭烦恼金刚句。不思议妙行秘密句。不思议语言秘密句。不思议杂烦恼秘密句。不思议灭烦恼秘密句。如是一切悉应修学。善男子。举要言之。应普修一切菩萨行。了法平等故。应普化一切众生界。善巧调伏故。应普入一切无边劫。愿力广大故。应普生一切诸有趣。示现受生故。应普知一切三世智。随顺觉悟故应普行一切诸佛法究竟体同故应普净一切诸佛刹平等庄严故。应普满一切菩萨愿。圆满一体故。应普供一切诸如来。胜愿现前故。应普同一切菩萨愿。一性平等故。应普事一切善知识。志求种种诸菩萨行。为令彼心生欢喜故

大方广佛华严经卷第三十二大方广佛华严经卷第三十三

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

复次善男子。汝因此故。求善知识。勿于身心而生疲倦。见善知识。勿生厌足。请问善知识。勿惮劳苦。亲近善知识。勿怀退转。供养善知识。无令间断。随顺善知识教诲。不应违逆。于善知识所有功德。不应疑惑。闻善知识演说出离门。应生决定。见善知识随顺烦恼行。勿生嫌怪。于善知识所生深信心不应变改。何以故。善男子。菩萨因善知识。闻一切菩萨行。因善知识。成就一切菩萨功德。因善知识。出生一切菩萨大愿。因善知识。引发一切菩萨善根。因善知识。积集一切。菩萨助道法。因善知识。开发一切菩萨法光明。因善知识。成就一切菩萨出离门。因善知识。修学一切菩萨清净戒。因善知识。安住一切菩萨功德法。因善知识。清净一切菩萨自性心。因善知识。发明一切菩萨坚固志。因善知识。具足一切菩萨陀罗尼辩才门。因善知识。能生一切菩萨清净藏。因善知识。出现一切菩萨智光明。因善知识。获得一切菩萨增上愿。因善知识。得与一切菩萨同一愿。因善知识。听闻一切菩萨殊胜法。因善知识。得到一切菩萨秘密处。因善知识。得至一切菩萨法宝洲。因善知识。得增一切菩萨善根芽因善知识。增广一切菩萨智慧海。因善知识。守护一切菩萨深密藏。因善知识。任持一切菩萨福德聚。因善知识。清净一切菩萨受生道。因善知识。领受一切菩萨正法云。因善知识。游入一切菩萨出。世道。因善知识。发起一切菩萨大欢喜。因善知识。获得一切如来菩提果。因善知识。摄取一切菩萨妙行。因善知识。开敷一切菩萨功德。因善知识。往一切方听受妙法。因善知识。演说一切菩萨心。因善知识。成就一切菩萨大慈力。因善知识。出生一切菩萨大悲力。因善知识。摄持一切菩萨自在力。因善知识。出生一切菩萨菩提分。因善知识。能作一切菩萨利益事

善男子。一切菩萨。由善知识任持。不堕恶趣。由善知识成就。自在受生。由善知识显示。得宿住智。由善知识开发。知一切劫。由善知识摄受。不退大乘。由善知识观察。不毁犯菩萨戒。由善知识守护。不随逐恶知识。由善知识养育。不退失菩萨法。由善知识摄取。超越凡夫地。由善知识教诲。不入二乘地。由善知识引发。得出离世间。由善知识覆护。能不染世法。由善知识抚育。修一切菩萨行。心不散乱。由善知识发起。辨一切助道具。心不退屈。由善知识势力。不为业惑之所碎坏。由善知识任持。不为诸魔之所恐怖。由善知识被忍辱甲。能受一切恶言毁辱。由善知识安慰。于世苦乐心无忧喜。由善知识生长。能灭诸憍慢常爱乐法。由善知识守护。能令菩萨净戒圆满。由善知识威力。能了诸法心无所得。由善知识安慰。能于三界心无恐怖。由善知识教示。能知善巧出三界道。由善知识劝修。信甚深法心无厌足。由善知识教导。不为名利憍慢逼迫。由善知识演说。得宿住智知过去因。由善知识加持。于未来际而得善巧。由善知识能生。得善巧智知三世等。由善知识摄受。能转众生依正业报。由善知识普守护。能内怀惭愧具足众善。由善知识随顺力。能和颜软语引导众生。由善知识修行力。能离一切断常诸见。由善知识随顺守护。能远离利衰毁誉等法。由善知识显示。不说己能。赞他功德。由善知识巧示。能勤修习菩提分法。由善知识决择。能演契经甚深理趣。由善知识劝修。能爱乐成就头陀功德。由善知识先导。于诸空法而得善巧

善男子。由依止承事善知识故。能增长一切菩萨摩诃萨无量无边菩提分法。何以故。善男子。善知识者。能清净诸恶法。能退舍诸盖缠障。能散灭无明黑暗云能解散一切诸见缚。能引出生死大苦城。能舍离决定住着处。能裂坏一切恶魔网。能拔除一切苦毒箭。能出离无明深林。能超过邪见旷野。能越度诸有瀑流。能拔出爱欲淤泥能不入诸邪恶道。能显示菩提路。能令安住不放逸。能引至修行处。能清净一切智性道。能令增长智慧眼。能令长养菩提心。能令发起大悲意。能说一切菩萨行。能诲示一切波罗蜜。能安置一切菩萨地能令获得诸忍门。能出生一切诸善根。能成辨一切助道具。能施与一切大功德。能令普到一切如来所。能显示一切功德法。能劝修一切胜利益。能策励一切所修道。能显示永出生死门。能杜绝一切诸邪径。能令趣入真实道。能以法光普照耀。能以法雨普润泽。能令尊重师长离诸懒惰能令入白净法心无厌足

善男子。善知识者。如轨范师。能以善语而诲示故。善知识者。犹如伴侣。住阿兰若不舍离故。善知识者。如胜神通。能现种种诸自在故。善知识者。如金刚剑。能截烦恼及随眠故。善知识者。如亲教师。能为忏除五犯罪故。善知识者。如胜静虑。能灭一切随烦恼故。善知识者。如摩尼镜。令现前证宿住智故。善知识者犹如桥梁。能令超度诸有流故。善知识者。能断疑网。业异熟中善决断故。善知识者。能善安处。令速入于不退地故。善知识者。能令深信。微细业果如自见故。善知识者。善能劝修。毁呰一切不善法故。善知识者。是智慧眼。一切法中不执着故。善知识者。心如明灯。顺本觉性而觉了故。善知识者。如说道者。为大丈夫处会说故。善知识者。能舍恶友。不入恶人之住处故。善知识者。舍不律仪。能令增长善律仪故。善知识者。能教时语。随众生根而发言故。善知识者。劝随顺修。令舍衣食摄众生故。善知识者。为先导师。令如所说而修行故。善知识者。令其深入等持等至皆深入故。善知识者。犹如良医。能于饮食知节量故。善知识者。如瑜伽师。能令趣入相应行故。善知识者。能为显示。令见菩萨胜境界故。善知识者。能为觉悟。令于诸法觉本性故。善知识者。能为安慰。令诸众生无忧恼故。善知识者。犹如罥索。能摄众生入佛智故。善知识者。如得王印。于一切法无障碍故。善知识者。为能引发。令诸众生趣种智故。善知识者。为法园苑。是诸菩萨爱乐处故。善知识者。如威猛将。摧伏一切诸魔军故。善知识者。为大明咒。能除一切诸苦厄故。善知识者。犹如大船。超过生死至彼岸故。善知识者。如如意珠。能令所愿皆圆满故。善知识者。能为救护。于诸恶道救众生故。善知识者。为先导相。修佛十八不共法故。善知识者。如庄严具。庄严一切净法身故。善知识者。如妙璎珞。庄严发心诸佛子故。善知识者。犹如长子。能绍佛种使不断故。善知识者。如贤德瓶。圆满诸佛智功德故。善知识者。如净摩尼。能清一切垢浊心故。善知识者。如清净戒。能令三业皆清净故。善知识者。犹如关钥。能开一切解脱门故。善知识者。犹如大路。行佛智行所行处故。善知识者。是佛境界。非诸二乘境界地故。善知识者。如正智教。非是三乘所知境故。善知识者。如等流果。从诸种智。同类生故。善知识者。如明净眼。能示众生夷险道故。善知识者。如陀罗尼。能持修学诸众生故。善知识者。为能发起。发起一切智慧明故。善知识者。为能断灭。断灭一切无明闇故。善知识者。如最胜药。能除众生诸惑病故。善知识者。如无尽藏。充满众生种种愿故。善知识者。如善方便。善巧证得诸佛地故。善知识者。犹如门户。少欲知足所行道故。善知识者。如能作业。能令勤修清净业故。善知识者。如说道者。远离险难诸因缘故。善知识者。犹如止观。息灭一切渴爱法故。善知识者。为说慧者。令入甚深无生义故。善知识者。能为照明。令见因果不失坏故。善知识者。如闲静地。能静其心修习道故。善知识者。为示道者。引诣如来集会所故。善知识者。犹如日月。能为照明甚深法故。善知识者。如轨范师。能为分别微细智故。善知识者。为能觉悟。令悟诸法如梦幻故。善知识者。为胜仪范。随顺众生常护他故。善知识者。能知世智。去来语默心无乱故。善知识者。厌不善心。性自觉悟远愚迷故。善知识者。承奉尊长。无我无人及懒惰故。善知识者。销灭诸惑。观自他身不可得故。善知识者。具觉悟智。随顺觉知世出世故。善知识者。离无益事。能令自他超诸有故。善知识者。为真实智。普知一切生灭体故。善知识者。无得无忧。观察过去自业体故。善知识者。住头陀行。以菩萨法常洗涤故。善知识者。得义无碍。觉悟差别真实体故。善知识者。不求赞美。不显己德益尊敬故。善知识者。具妙忍智。于自业果深觉悟故。善知识者。远离在家。不以利养而亲近故。善知识者。住远离行。舍无义语近真实故。善知识者。修行正境。常勤修习四念住故。善知识者。善巧问答。于诸问答无不知故。善知识者。能摧异论。善能安立摧邪见故。善知识者。不厌贫穷。于彼能生慈愍心故。善知识者。能为法摄真实法中令深入故。善知识者。能以财摄。令诸众生修善行故。善知识者。常修知足。厌离守护诸过失故。善知识者。赞叹净戒。于诸种种甚深戒果能体解故。善知识者。诃责破戒。谓于种种破戒过失深觉悟故。善知识者。能具足戒。谓无谄诳如理受持正念知故。善知识者。能善观察。于善不善一切法中勤请问故。善知识者。能为先导。劝诸众生于佛菩提令勤修故。善知识者。住不退转。舍四颠倒知倒性故。善知识者。住真实相。普知诸法皆无相故。善知识者。住真实解。谓知识灭名色等法皆不生故。善知识者。得无所畏。谓觉诸佛甚深法门体相用故。善知识者。净戒住处。谓于菩萨戒身戒相智普知故。善知识者。深入定门。谓离欲泥住三昧故。善知识者。心无垢浊。谓离盖缠住净心故。善知识者。得诸总持。谓如实演说心无著故。善知识者。知甚深门。谓能普入法本性故。善知识者。信心住处。住诸善法根本处故。善知识者。住寂静教。谓普除灭诸渴爱故。善知识者。住正直道。谓能普知苦无我故。善知识者。住菩萨地。谓于十地普了知故。善知识者。是智慧地。谓于诸法无迷惑故。善知识者。是诸佛地。谓能出生菩萨法故。善知识者。住真实道。一切二乘不能知故。善知识者。得无尽辩。能说如实知见体故。善知识者。善离忧恼。知生死苦本无我故。善知识者。非文字境。知语言道不可得故。善知识者。住无生法。谓知识性不可得故。善知识者。是能寂静。谓能除灭诸烦恼故。善知识者。能灭邪见。谓能安住正见中故复次善男子。善知识者。犹如慈母。出生一切佛种性故。善知识者。犹如严父。广大利益亲付嘱故。善知识者。犹如乳母。守护不令作恶法故。善知识者。犹如教师。示诸菩萨所应学故。善知识者。犹如善导。能示甚深波罗蜜故。善知识者。犹如良医。能治种种烦恼病故。善知识者。犹如雪山。增长一切种智药故。善知识者。犹如勇将。殄除一切诸恐怖故。善知识者。犹如船师。令度生死大瀑流故。善知识者。犹如商主。令到一切智宝洲故。善男子。汝今若能如是作意。正念思惟。当得亲近诸善知识。复次善男子。汝承事一切善知识。应发如大地心。平等荷负无疲倦故。汝应于善知识。发如金刚心。平等志愿不可坏故。汝应于善知识起如铁围山心。一切诸苦无能动故。汝应于善知识起给侍心。所有教令皆随顺故。汝应于善知识起弟子心。所有训诲无违逆故。汝应于善知识发如僮仆心。不厌一切诸作务故。汝应于善知识起如大火心。焚烧一切诸烦恼故。汝应于善知识生如佣作人心。随所教命无违逆故。汝应于善知识生除粪人心。舍离一切憍慢心故。汝应于善知识起如大水心。洗除一切烦恼垢故。汝应于善知识发如大风心。摧坏众生我慢山故。汝应于善知识发如虚空心。于五欲境无障碍故。汝应于善知识发如巨海心。诸功德宝皆圆满故。汝应于善知识发如满月心。令满清凉白净法故。汝应于善知识发如师子心。游行住处搏噬诸魔恶禽兽故。汝应于善知识发如良马心。随人到处远离恶性故。汝应于善知识发如牛王心。利益众生无厌倦故。汝应于善知识发如沙门心。正命自居离邪谄故。汝应于善知识发如莲华心。戒慧清净不染欲泥故。汝应于善知识发如商主心。引导令至佛智城故。汝应于善知识发如大车心。运载重担忘恩报故。汝应于善知识发如调顺象心。恒事伏从无卒暴故。汝应于善知识发如山王心。任持一切无倾动故。汝应于善知识发如良犬心。常于本主无嗔害故。汝应于善知识发如旃荼罗心。常自轻贱无人我故。汝应于善知识发如犗牛心。恒思顺行无威怒故。汝应于善知识发近住心。随顺师长常尊重故。汝应于善知识发如舟船心。运度往来无疲倦故。汝应于善知识发如桥梁心。济度众生到彼岸故。汝应于善知识发如孝子心。承事供养顺颜色故。汝应于善知识发如王子心。遵王教令无违犯故

复次善男子。应于自身生病苦想。于善知识生医王想。于所说法生良药想。于所修行生除病想。又善男子。应于自身生远行想。于善知识生导师想。于所说法生正道想。于所修行生远达想。又善男子。应于自身生求度想。于善知识生船师想。于所说法生舟楫想。于所修行生到岸想。又善男子。应于自身生农夫想。于善知识生龙王想。于所说法生时雨想。于所修行生成熟想。又善男子。应于自身生贫穷想。于善知识生毗沙门想。于所说法生财宝想。于所修行生富饶想。又善男子应于自身生弟子想。于善知识生良师想。于所说法生技艺想。于所修行生解了想。又善男子。应于自身生恐怖想。于善知识生勇健想。于所说法生兵仗想。于所修行生除怨想。又善男子。应于自身生商人想。于善知识生导师想。于所说法生珍宝想。于所修行生得宝想。又善男子。应于自身生儿子想。于善知识生父母想。于所说法生家业想。于所修行生绍继想。又善男子。应于自身生王子想。于善知识生大臣想。于所说法生王教想。于所修行生智慧想。住王城想。冠王冠想。系王缯想。善男子。汝应发如是心。作如是意。亲近承事于善知识。何以故。一切菩萨。以如是心。近善知识。令其志愿永得清净故

复次善男子。菩萨因善知识。常能增长一切善根。譬如雪山生长药草。因善知识。成佛法器。譬如大海吞纳众流。因善知识。成功德处。譬如大海出生众宝。因善知识。净菩提心。譬如猛火能炼真金。因善知识出诸世间。如须弥山出于大海。因善知识。不染世法。譬如莲华不着尘水。因善知识不受诸恶。譬如大海不宿死尸。因善知识增长白法。譬如白月渐次圆满。因善知识照明法界。譬如盛日照四天下。因善知识增长大愿。譬如父母养育婴儿。善男子。我今略说。菩萨若能勤求随顺善知识教。即得成就十不可说不可说百千亿那由他功德。清净十不可说不可说百千亿那由他深心。增长十不可说不可说百千亿那由他菩萨根。具足十不可说不可说百千亿那由他威德力。断除十不可说不可说百千亿阿僧祇菩萨障碍。超越十不可说不可说百千亿阿僧祇魔境。深入十不可说不可说百千亿阿僧祇法门。圆满十不可说不可说百千亿阿僧祇助道。修习十不可说不可说百千亿阿僧祇妙行。发起十不可说不可说百千亿阿僧祇大愿。善男子。我复略说。一切菩萨行。一切菩萨波罗蜜。一切菩萨所住地。一切菩萨安忍门。一切菩萨三昧门。一切菩萨神通智。一切菩萨总持门。一切菩萨回向智。一切菩萨四无量。一切菩萨广大愿。一切菩萨普遍成就。一切佛法。如是皆由善知识力。而得圆满。以善知识而为根本。从善知识来。依善知识生。依善知识长。依善知识住。善知识为因缘。善知识能发起

尔时善财童子。白言圣者。我今已知一切善法从善知识生。云何能于诸善知识善法之中。速得圆满。速得清净。得不退失。时德生童子有德童女。告善财言有二种戒。具足受持。则得圆满善知识法。何等为二。一菩萨戒。二别解脱戒。持是二戒。则能圆满善知识法。如佛所说。自不持戒。令他持戒。自未调伏。令他调伏。无有是处。若诸菩萨。具足圆满头陀功德。如是二戒。悉得清净。不失善法。善财童子。白言圣者。云何名为头陀功德。童子童女。告善财言。善男子。言头陀者。谓诸菩萨十二头陀。何等十二。第一纳衣。善男子。云何纳衣。若诸菩萨具十种法。则得圆满成就纳衣。何等为十。一者勤修令得坚固。二者令心常自谦下。三于身心无有疲厌。四于衣服心不染着。五者常乐坚固远离。六者成就坚固功德。七不自显殊胜德行。八于他人不起轻慢。九者护持净戒圆满。十者堪任一切亲近。善男子。此是菩萨住净信心具足圆满。由此心故。闻说如来清净言教。不惜身命。勤修佛法。不破不毁。以勤修故。身心不动。令于所得坚固成就。以心坚固常自谦下。心谦下故。成就无我。得无我已。心无憍慢。得无慢心谦下力故。人所弃者悉收取之。浣染成衣。远离烦恼。心无厌恶。亦无贪着。但取资身。以御寒暑。修行道业。余无所顾。于此纳衣。不见过失。不念粗弊。但见纳衣所有功德。离贪欲者。乃服此衣。服此衣者。心无烦恼。是诸圣种。顺菩萨行。诸佛如来之所赞叹。由此因缘。不自贡高。不贡高故。不嫌他人。离高嫌故。净戒圆满。戒圆满故。堪任亲近诸佛菩萨之所护念。诸天人王。及刹帝利。婆罗门等。城邑聚落。一切见闻。无不欢喜恭敬礼拜。咸共赞美称扬其德。而作是言。我等有福。感如是人居此国土。同梵行者。咸皆欢喜。善男子。是为菩萨具足十法圆满成就纳衣功德

复次善男子。菩萨有十种法具足圆满成就三衣。何等为十。一者成就知足。二者成就少欲。三者离于多求。四者离诸积聚。五者远离丧失。六者远离身苦。七者远离心忧。八者远离于恼。九者远离取舍。十者向漏尽道。善男子。如是菩萨心少欲故。趣得三衣。无所拣别。成就喜足。得喜足已。远离多求。离多求故。无诸积聚。离积聚故不怖丧失。无丧失故身得无苦。身无苦故心亦无忧。心无忧故远离于恼。恼不生故远于取舍。远取舍故向漏尽道。善男子。是为菩萨具足十法圆满成就三衣功德

复次善男子。菩萨有十种法具足圆满。而得成就不随染衣。何等为十。一者不随贪欲所行。二者不随嗔恚所行。三者不随愚痴所行。四者不随忿怒所行。五者不随很戾所行。六者不随嫉妒所行。七者不随悭吝所行。八者不随憍慢所行。九者不随名称赞誉眷属所行。十者不随亲近供养财利所行。善男子。由此不随贪等行故。不为四魔之所屈伏。遇诸毁辱。心不怯弱。设有尊重。亦不贡高。由此名为心不随顺诸染惑行。善男子。是为菩萨具足十法圆满成就不随染衣妙行功德复次善男子。菩萨有十种法。具足圆满。则得成就依常乞食。何等为十。一者慈心摄取。二者次第行乞。三者不自生恼。四者成就知足。五者普共分食。六者不嗜美食。七者饮食知量。八者疾得善法。九者愿满善根。十者离和合相。善男子。云何菩萨慈心摄取。乃至远离诸和合相。善男子。若时菩萨。见诸苦恼逼迫众生。乏少善根。为欲圆满彼善根故。随顺众生。慈心摄取。菩萨为顺平等慈心次第行乞。于行乞时。若至城邑。齐整威仪。善摄诸根。一心不乱。谛视徐行。无踰七步。正念安住。于善法中。不选高门。不弃微贱。除恶律仪旃荼罗等。为护讥嫌。悉不应往。若以慈心。平等摄取。究竟不舍。菩萨随顺次第乞时。不自生恼。设不得食。亦不生嗔。菩萨如是成就知足。随与而取。不择精粗。菩萨如是次第乞已。持至佛前。或塔庙前。以尊重心。恭敬供养。供养毕已。还本所居。分为四分。取第一分。待同梵行。以第二分。施诸贫苦。以第三分。施诸囚系。以第四分。然自充食。于所食中。亦不贪嗜。但念于身作除病想。乃至为令身得安住。受饮食时。不令太少。以自虚羸。妨修善业。亦不过多。令身困重增长睡眠。因此食故。能勤精进。疾得善法。菩萨为欲圆满一切菩提分法诸善根故。又应远离取和合相。离是相已离于我执。成就无我。乃至自身内外血肉。一切财物。不生吝惜。能与众生共所受用。善男子。是为菩萨具足十法圆满成就依常乞食妙行功德。复次善男子。菩萨有十种法。具足圆满。则得成就常一坐食。何等为十。一者如诸菩萨。一坐道场。二者降伏魔怨。心不移动。三者于出世定。成就不动。四者于出世慧。成就不动。五者于出世智。成就不动。六者于诸法空。成就不动。七者于证真道。成就不动。八者于真实际。成就不动。九者于如如性。成就不动。十者于一切智成就不动。善男子。此一坐者。谓一法坐。菩萨依彼而得不动故。说菩萨成就一坐。善男子。是为菩萨具足十法圆满成就常一坐食妙行功德

大方广佛华严经卷第三十三大方广佛华严经卷第三十四

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

复次善男子。菩萨具十种法。则得圆满成就一食。何等为十。一者成就食时性不贪求。二者成就食时性无染着。三者随得食时常知止足。四者恒依时食不堕非时。五者若为利养悉不应食。六者若得甘美亦不应食。七者若见他食亦不生嗔。八者见他食时亦无悭妒。九者乃至命尽亦常一食。十者于所食时当起药想。善男子。是为十法成就一食妙行功德

复次善男子。菩萨具十种法。则得圆满阿兰若法。何等为十。一者成就久修梵行。二者成就清净律仪。三者成就诸根不乱。四者成就常乐多闻。五者成就一切处力。六者成就远离我执。七者成就不计着身。八者成就常乐远离。九者成就正法现前。十者成就乐于独处。善男子。云何菩萨久修梵行。乃至成就乐于独处善男子。如是菩萨。得出家已。于诸如来所说教中。具足三轮戒印清净。于诸戒中。获得善巧。不由他教。能自开解。所谓随义善巧而能修行。随文善巧受持不忘。于出要道善巧随顺。于五犯聚善巧悔除随所行住。离诸犯境。于诸恶人。心常怖畏。乃至小罪亦不覆藏。于诸学处。有罪无罪。悉能了知。知如是等业之久近。堕三恶趣。复生人天。如是菩萨。善调六根。令无动乱。以是方便。住阿兰若。居无恼害。无过难处。不亲一切居人境界。不远城邑。乞食便易。药草滋茂。清净泉流。远恶禽兽。空闲寂静。依如是处而为居止。于所习诵。应自精勤。讽诵之时。调其气息。声离高下。心不外缘。专想忆持。思惟文义。离诸惛掉。止观相应。若见大臣婆罗门等来至其所。当于来者起爱敬心。先意问讯命令安坐。观其根性为说正法。咸令欢喜信受修行。若见国王。应善迎奉。方便承意。作如是言。唯愿大王。就此敷座。王既坐已。请其所欲。一切供给。或时彼王心无信乐。应以善言赞美王德。我观大王。妙得善利。今王境内。持戒多闻一切沙门。及婆罗门。良祐福田。悉于中住。以王威力。一切盗贼不来侵扰。由王德化。一切恶兽悉皆远离。王闻语已。欢喜踊跃。诸根调伏。其心寂静。堪任法器。当为宣说种种正法。或为演说厌生死法。或为演说如来功德。广大自在甚深妙法。如是一切皆令欢喜。菩萨成就如是多闻一切处力堪修正行。菩萨成就自利利他。远离一切我执烦恼。菩萨成就不计着身于阿兰若心无恐怖。菩萨成就常乐远离。住阿兰若其心寂静。菩萨成就正法现前。于诸世间悉皆舍离。菩萨成就乐于独处。犹如野鹿无鹿恐怖。善男子。是为菩萨具足十法圆满成就住阿兰若妙行功德

复次善男子。菩萨具十种法。则得成就树下而坐。何等为十。一者不近村邑聚落。二者不依太远城邑。三者不依荆棘之处。四者不依多毒草处。五者不依无枝叶树。六者不依多猿狖处。七者不依众鸟集处。八者不依恶兽住处。九者不依近怨贼处。十者不依造作非法恶律仪处。如是等处悉不应依。能令身心安隐喜乐。可修善行即应安住。善男子。是为菩萨具足十法圆满成就树下而坐妙行功德

复次善男子。菩萨具十种法。则得圆满露地而坐。何等为十。一者随寒热雨。不择温凉。二者不依墙壁。三者不依树林。四者不依草[卄/積]。五者不依危险。六者寒不覆障。七者雨不覆盖。八者热不覆障。九者风不覆障。十者若有病苦。得居房舍。菩萨应当作如是念。若于露坐。正念现前。随所修行。速除烦恼。随顺佛说头陀功德。我当勤求而得圆满。设住房舍。不生贪着。亦不应言此好彼恶。应作是念。我居寺舍。利益一切。修福众生。露坐不能为大利益。又露地坐。但能自利。不能利他而彼菩萨。虽居房舍。昼夜常作露地坐想。善男子。是为菩萨具足十法圆满成就露地而坐妙行功德。复次善男子。菩萨具十种法。则能成就住止冢间。何等为十。一者厌离世间想。二者死相现前想。三者初死未坏想。四者青瘀现前想。五者胮胀现前想。六者脓流败坏想。七者禽兽食啖想。八者火焚半然想。九者肢节分离想。十者骨锁现前想。善男子。若诸菩萨。住冢间时。于诸众生。恒住慈心及利益心。坚持净戒。摄护威仪。澡洁其身。不应食肉。何以故。止住寒林。应防二过。一离外道所讥毁故。二离非人得其便故。善男子。若彼菩萨。入僧伽蓝。先礼佛塔及诸形像。上中下座。随应礼拜。如是毕已。应当守护威仪法式。为住冢间。诸菩萨等。逆生死流。顺圣法故。善男子。若彼菩萨。入僧伽蓝。旧住比丘。应以床敷。请令就坐。菩萨审观。若有妨难。随事思惟。若无妨难。乃可就坐。应当如是谦下其心。善男子。是为菩萨具足十法圆满成就住止冢间妙行功德

复次善男子。菩萨具十种法。则得圆满成就常坐。何等为十。一者不为己身疲劳。二者不为其心热恼。三者不为懒惰睡眠。四者不为久立不安。五者为满菩提法聚。六者为修心一境性。七者为求正道现前。八者为欲坐菩提场。九者为欲利益众生。十者为欲灭除烦恼。善男子。是为菩萨具足十法成就常坐妙行功德

复次善男子。菩萨具十种法。则得圆满成就随坐。何等为十。一者随所遇座心不贪着。二者随旧敷座不自施设。三者亦不教人敷设床座。四者于诸敷具不作因缘。五者遇草叶等随时而坐。六者多毒虫处应当远离。七者若欲卧时右胁着地。八者心无放逸念当时起。九者系想在明顺法寝息。十者为欲修行令身安乐。善男子。是为菩萨具足十法成就随坐妙行功德。善男子。此十二种头陀功德。菩萨修行具足成就能令一切善知识法。圆满清净。能于一切善知识法永无退转。尔时善财童子。得闻如是清净妙行头陀功德。种种赞叹诸善知识。种种随顺菩萨行门。及能显示一切佛法。身心柔软。欢喜踊跃。速疾增长爱敬之心。顶礼童子及童女足。绕无量匝。殷勤瞻仰。一心恋慕。辞退而去

尔时善财童子。善知识教。润泽其心。正念思惟诸菩萨行。渐渐前行。向海岸国。自忆往世。经多生死不修礼敬。即时发意。深自克责。勤力而行。复忆往世。久处轮回。身心不净。即时发意。专自治洁。愿达彼岸。复忆往世。随顺世间。作诸恶业。即时发意。正念观察诸菩萨行。复忆往世。烦恼覆心。起诸妄想。即时发意。恒正思惟诸法实性。复忆往世。所修诸行。但为自身。即时发意。令心广大。普及含识。复忆往世。追求欲境。常自损耗。即时发意。修行佛法。长养诸根。复忆往世。起邪思念。颠倒相应。即时发意。生正见心。起菩萨愿。复忆往世。日夜劬劳。作诸恶事。即时发意。起大精进。成就佛法。复忆往世。受五趣生。于自他身。皆无利益。即时发意。愿以其身。饶益众生。成就佛法。发起一切众生善根。承事一切诸善知识。恒与正愿。心共相应。如是思惟。生大欢喜。复观此身。从无始际。常是一切生老病死。恩爱离别。众苦之本。愿尽未来。修行一切菩萨之道。教化成熟一切众生。见诸如来。成就佛法。游行一切诸佛刹土。承事一切善说法师。住持一切如来正教。寻求一切正法伴侣。见一切善知识。集一切诸佛法。与一切菩萨愿智身。而作因缘。作是念时。速疾增长不可思议无量善根。即于一切诸菩萨所。发起深信尊重之心。生希有想。生大师想。诸根清净。善法增益。起一切菩萨恭敬供养。作一切菩萨曲躬合掌。生一切菩萨普见世间眼。起一切菩萨普念众生想。入一切菩萨无量平等门。现一切菩萨无量愿化身。出一切菩萨清净语言愿。欲庄严一切佛土。想见过现一切诸佛。及诸菩萨威德圆满。于一切处。示现成道神通变化。乃至无有一毛端处。佛菩萨身。而不周遍。又得清净一切菩萨智光明眼。见一切菩萨所行境界。其心普入十方刹网。其愿普遍虚空法界。随顺一切。尽无余处。普修一切三世平等无分别行。相续不断。无有休息。普入一切甚深法门。如是一切。皆以信受善知识教之所致耳。善财童子。以如是尊重。如是供养。如是称赞。如是观察。如是加持。如是愿力。如是想念。如是随顺。如是思惟。如是出生。遍满无量智慧境界。于毗卢遮那庄严藏大楼阁前。五体投地。恭敬礼拜。暂时敛念。思惟观察。发起甚深广大信解。广大愿力。变化自身。遍一切处。入智慧身。住平等门。普现其身。在于一切如来前。一切菩萨前一切善知识前。一切如来塔庙前。一切如来形像前。一切诸佛一切菩萨住处前。一切法宝堂宇前。一切声闻辟支佛及其塔庙前。一切圣众福田前。一切父母尊者前。一切十方众生身前。遍一切处。皆如上说。尊重礼赞。如是充满。一切缘中。无尽愿力。加持变化。尽未来际。遍一切处。无有休息。等虚空无边量故。等法界无障碍故。等实际遍一切故。等如来无分别故。犹如影随智想现故。犹如梦从思等起故。犹如像表示一切故。犹如响善缘所发故。无有生更递兴谢故。无有相应心迁动故。无有性随缘转变故。又决定知甚深信解。如是如是。一切诸报。皆从业起。甚深信解。如是如是。一切诸果皆从因起。甚深信解。如是如是。一切诸业。皆从习起。甚深信解。如是如是。一切如来。出兴于世。皆从信起。甚深信解。如是如是。一切化现。诸供养事。皆悉从于决定解起。甚深信解如是如是。一切如来所变化佛。皆从尊重爱敬心起。甚深信解。如是如是。一切佛法从善根起。甚深信解。如是如是。一切化佛从方便起。甚深信解。如是如是。一切佛事从大愿起。甚深信解。如是如是。一切菩萨所修诸行。从回向起。甚深信解。如是如是。一切法界。广大庄严。从一切智境界而起。甚深信解。离于断见。知回向故。离于常见。知无生故。离无因见。知正因故。离颠倒见。知如实理故。离自在见。知不由他故。离自他见。知从缘起故。离诸邪见。知因果力故。离边执见。知法界无边故。离往来见。知如影像故。离有无见。知不生灭故。离一切法见。知空无生故。知不自在故。知愿力出生故。离一切相见入无相际故。知一切法如种生芽不失坏故。如印印文相续起故。知质如像故。知声如响故。知境如梦故。知业如幻故。了世心现故。了果因起故。了报业集故。了知一切诸功德法。皆从菩萨善巧方便之所流故。了知一切法非法性平等现前增长成就真法界故。善财童子。入如是智。如是思惟。如是作意。端心洁念。于楼阁前。举体投地。殷勤顶礼。不思议善根。速疾现前流注身心。清凉悦泽。然后安徐。从地而起。一心瞻仰。目不暂舍。合掌围绕毗卢遮那普庄严藏广大楼阁。经无量匝思惟作意。发起深心。曲躬恭敬。作是念言。此大楼阁是解甚深空无相愿三解脱者之所住处。此大楼阁。是于诸法了达法性无分别者之所住处。此大楼阁。是了法界本际平等无差别者之所住处。此大楼阁。是知一切诸众生界不可得者之所住处。此大楼阁。是知一切诸法无生住灭者之所住处。此大楼阁。是不执着一切世间者之所住处。此大楼阁。是不执着一切窟宅者之所住处。此大楼阁。是不爱乐一切聚落者之所住处。此大楼阁。是不依着一切境界者之所住处。此大楼阁。是能远离一切相者之所住处。此大楼阁。是能坏散一切妄想者之所住处。此大楼阁。是知诸法无自性者之所住处。此大楼阁。是断一切分别业者之所住处。此大楼阁。是离一切想心意识者之所住处。此大楼阁。是于一切法不来不去不入不出者之所住处。此大楼阁。是入一切甚深般若波罗蜜者之所住处。此大楼阁。是能方便安住一切普门法界者之所住处。此大楼阁。是能寂静息灭一切烦恼火者之所住处。此大楼阁。是以胜慧除断一切见爱慢者之所住处。此大楼阁。是出生一切诸禅解脱等持等至三昧通明而游戏者之所住处。此大楼阁。是观察一切诸大菩萨三昧境界者之所住处。此大楼阁。是安住一切诸如来所亲近依止者之所住处。此大楼阁。是以一劫入一切劫。以一切劫入于一劫。而不坏其相者之所住处。此大楼阁。是以一刹入一切刹。以一切刹入于一刹。而不坏其相者之所住处。此大楼阁。是以一法入一切法。以一切法入于一法。而不相杂乱者之所住处。此大楼阁。是以一众生入一切众生。以一切众生入一众生。而不坏其相者之所住处。此大楼阁。是以一佛入一切佛。以一切佛入于一佛。而不坏其相者之所住处。此大楼阁是于一念中而知一切三世者之所住处。此大楼阁。是于一念中往诣一切国土者之所住处。此大楼阁。是于一切众生前悉现其身者之所住处。此大楼阁。是心常利益一切世间者之所住处。此大楼阁。是得自在力能遍至一切处者之所住处。此大楼阁。是虽已出。一切世间。为欲教化诸众生故。而恒于中普现其身。不舍离者之所住处。此大楼阁。是不依着一切刹土。欲为供养一切佛故。而游一切诸佛刹者之所住处。此大楼阁。是不动本处。能普往诣一切佛刹。而庄严者之所住处。此大楼阁。是能遍亲近一切诸佛。而不起佛想者之所住处。此大楼阁。是能遍依止一切善知识。而不起善知识想者之所住处。此大楼阁。是住一切魔宫。而不耽着欲境界者之所住处。此大楼阁。是知一切心意识法。而永离一切心想见者之所住处。此大楼阁。是虽于一切众生中而现其身。然于自他不生二相者之所住处。此大楼阁。是能普入一切世界。而于法界无差别相者之所住处。此大楼阁。是愿住未来一切劫。而于诸劫无长短想者之所住处。此大楼阁。是不离一毛端处。而普现身。随顺十方一切世界者之所住处。此大楼阁。是能演说难遭遇法者之所住处。是能安住难知解法者之所住处。是能安住甚深法者之所住处。是能安住无二法者之所住处。是能安住无相法者之所住处。是能安住无对治法者之所住处。是能安住无所得法者之所住处。是能安住无戏论法者之所住处。是能安住大慈大悲者之所住处。是已越度一切二乘所知境者之所住处。是已超过一切魔境界者之所住处。是已能于一切世法无所染者之所住处。是已能到一切菩萨所到岸者之所住处。是已能住一切如来所住处者之所住处。是虽已离一切诸相。而亦不入声闻正位者之所住处。是虽已了诸法无生。而亦不住无生法性者之所住处。是虽已观贪欲不净。而不证离贪法。亦不与贪欲俱者之所住处。是虽修于慈而不证离嗔法。亦不与嗔垢俱者之所住处。是虽观一切十二缘起。而不证离痴法。亦不与痴惑俱者之所住处。是虽住四禅。而以大悲愿力。不随禅生者之所住处。是虽住四无量。为化众生故。而不生于色界者之所住处。是虽修四无色定。以大悲故。而不住无色界者之所住处。是虽勤修止观。为化众生故。而不证明脱者之所住处。是虽行于舍。而以大悲。不舍一切化众生事者之所住处。是虽观于空。然不起空见者之所住处。是虽行无相。而常教化着相众生者之所住处。是虽行无愿。而不舍菩提一切行愿者之所住处。是虽于一切业烦恼中而得自在。为欲教化成熟众生。而现随顺业烦恼者之所住处。是虽无生死。而为化众生。示受生死者之所住处。是虽已离一切诸趣。为化众生。示入诸趣者之所住处。是虽行于慈。而于诸众生。无所爱恋者之所住处。是虽行于悲。而于诸众生。无所取著者之所住处。是虽行于喜。而观苦众生。心常哀愍者之所住处。是虽行于舍。而不废舍利益他事者之所住处。是虽行九次第定。而不厌离欲界受生者之所住处。是虽知一切法无生无灭。而不于实际作证者之所住处。是虽入三解脱门。而不取声闻解脱者之所住处。是虽观四圣谛。而不住小乘圣果者之所住处。是虽观甚深缘起。而不住究竟寂灭者之所住处。是虽修八圣道。而不求永出世间者之所住处。是虽超凡夫地。而不堕声闻辟支佛地者之所住处。是虽观五取蕴。而不永灭诸蕴者之所住处。是虽超出四魔。而不分别诸魔境界者之所住处。是虽不着六处。而不永灭六处者之所住处。是虽安住真如。而不堕实际者之所住处。是虽说一切乘。而不舍大乘者之所住处。此大楼阁。是住如是一切无量诸功德者之所住处。尔时善财童子。合掌瞻仰。恭敬一心。而说偈言

  此是大悲清净智　　利益世间慈氏尊
  灌顶地中佛长子　　随顺思惟入佛境
  一切名闻诸佛子　　住大智境解脱门
  游行法界心无著　　此无等者之住处
  施戒忍进禅智慧　　方便愿力及神通
  如是大乘诸度法　　悉具足者之住处
  智慧广大如虚空　　普知三世一切法
  无碍无依无所取　　了诸有者之住处
  善能解了一切法　　无性无生无所依
  如鸟飞空得自在　　此无所畏之住处
  了知三毒真实性　　分别因缘虚妄起
  亦不厌彼而求出　　此寂静人之住处
  三解脱门八圣道　　诸蕴处界及缘起
  悉能观察不趣寂　　此善巧人之住处
  十方国土及众生　　以无碍智咸观察
  了性皆空不分别　　此寂灭人之住处
  普行法界悉无碍　　而求行性不可得
  如风行空无所行　　此无依者之住处
  普见恶道群生类　　受诸楚毒无所归
  放大慈光悉除灭　　此哀愍者之住处
  见诸众生失正道　　譬如生盲践畏途
  引其令入解脱城　　此大导师之住处
  见诸众生入魔网　　生老病死常逼迫
  令其解脱得慰安　　此勇健人之住处
  见诸众生婴惑病　　而兴广大悲愍心
  甘露智药以除灭　　此大医王之住处
  见诸众生没有海　　沉沦忧迫受众苦
  大悲法船以救之　　此善度者之住处
  见诸众生在惑海　　能发菩提妙宝心
  悉入其中而拔济　　此善渔人之住处
  恒以大愿慈悲眼　　普观一切诸众生
  从诸有海而拔出　　此妙翅王之住处
  譬如日月在虚空　　一切世间靡不烛
  愿智光明亦如是　　此照世者之住处
  菩萨为化一众生　　普尽未来无量劫
  如为一人一切尔　　此救世者之住处
  于一刹土化众生　　尽未来劫无休息
  如于一刹十方然　　此坚固意之住处
  十方诸佛所说法　　一坐普受咸令尽
  尽未来劫志无厌　　此智海人之住处
  遍游一切世界海　　普入一切道场海
  供养一切如来海　　此修行者之住处
  修行一切妙行海　　发起无边大愿海
  如是经于众劫海　　此功德者之住处
  一毛端处无量刹　　佛众生劫不可说
  如是明见靡不周　　此无碍眼之住处
  一念普摄无边劫　　国土诸佛及众生
  福智无碍波罗蜜　　此具德人之住处
  十方佛刹碎为尘　　一切大海以毛滴
  菩萨发愿数如是　　此无碍者之住处
  成就总持三昧门　　大愿诸禅及解脱
  一一皆住无边劫　　此真佛子之住处
  无量无边诸佛子　　种种说法度众生
  亦说世间众技艺　　此修行者之住处
  成就神通方便智　　修行如幻妙法门
  十方五趣悉现生　　此无碍者之住处
  菩萨始从初发心　　具足修行一切行
  化身无量遍法界　　此神力者之住处
  一念成就菩提道　　普作无边智慧业
  世情思虑悉发狂　　此难量者之住处
  成就神通无障碍　　游行法界靡不周
  其心未尝有所得　　此净慧者之住处
  菩萨修行无碍慧　　入诸国土无所著
  以无二智普照明　　此无我者之住处
  了性如空平等智　　本来寂静无所依
  常行如是境界中　　此离垢人之住处
  普见群生受众苦　　发大仁慈智慧心
  愿常利益诸世间　　此悲愍者之住处
  佛子住于此　　普现众生前
  犹如日月轮　　遍除生死暗
  佛子住于此　　普顺众生心
  变现无量身　　充满十方刹
  佛子住于此　　遍游诸世界
  一切如来所　　无量无数劫
  佛子住于此　　称量佛境界
  无量无数劫　　其心无厌倦
  佛子住于此　　念念入三昧
  一一三昧门　　阐明诸佛境
  佛子住于此　　悉知一切刹
  无量无数劫　　众生佛名号
  佛子住于此　　一念摄诸劫
  远离诸妄想　　随顺于众生
  佛子住于此　　修习诸三昧
  一一心念中　　了知三世法
  佛子住于此　　结跏身不动
  普现一切刹　　诸趣利众生
  佛子住于此　　饮诸佛法海
  深入智慧海　　具足功德海
  佛子住于此　　悉知诸刹数
  世数众生数　　佛不思议数
  佛子住于此　　一念悉能了
  一切三世中　　国土之成坏
  佛子住于此　　普知佛行愿
  菩萨所修行　　众生根性欲
  佛子住于此　　见一极微中
  无量刹道场　　众生及诸劫
  如一极微内　　一切微悉然
  种种咸具足　　处处皆无碍
  佛子住于此　　普观一切法
  众生刹及世　　无起无所有
  观察众生等　　法等如来等
  刹等诸愿等　　三世悉平等
  佛子住于此　　教化诸群生
  供养诸如来　　思惟诸法性
  无量千万劫　　所修愿智行
  广大不可量　　称扬莫能尽
  彼诸大勇猛　　所行无障碍
  安住于此中　　我合掌敬礼
  诸佛之长子　　圣德慈氏尊
  我今恭敬礼　　愿垂顾念我

大方广佛华严经卷第三十四大方广佛华严经卷第三十五

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。以如是等一切菩萨无量称扬赞叹之法。赞毗卢遮那庄严藏大楼阁中诸菩萨已。于楼阁前。恭敬顶礼。住立一心。曲躬合掌。渴仰欲见弥勒菩萨。亲近供养。乃见弥勒菩萨。从楼阁外别处而来。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。释梵护世。及本生处内外亲戚。无量眷属。婆罗门众。及余无数百千众生。前后围绕。而共来向大楼阁所。善财见已。欢喜踊跃。即前作礼。五体投地。时弥勒菩萨。观察善财。指示大众。叹其真实无量功德。而说偈言

  汝等观善财　　智慧心清净
  为求菩提行　　而来亲近我
  善来圆满慈　　善来清净悲
  善来寂灭眼　　修行无懈倦
  善来清净意　　善来广大心
  善来不退根　　修行无懈倦
  善来不动行　　常求善知识
  了世心无染　　调伏诸群生
  善来行妙道　　善来住功德
  善来趣佛果　　与世为依怙
  善来德为体　　善来法所滋
  善来无边行　　世间难可见
  善来离迷惑　　处世如莲华
  利衰毁誉等　　一切无分别
  善来施安乐　　调柔堪受化
  谄诳嗔慢心　　一切悉除灭
  善来真佛子　　普诣于十方
  增长诸功德　　调柔无懈倦
  善来三世智　　遍知一切法
  普生功德藏　　修行不疲厌
  文殊德云等　　一切诸佛子
  展转令汝来　　示汝无碍处
  具修菩萨行　　普摄诸群生
  广大不思议　　今来至我所
  为求诸如来　　清净之境界
  问诸广大愿　　而来至我所
  去来现在佛　　所成诸行业
  汝欲皆修学　　而来至我所
  汝于善知识　　欲求微妙法
  欲受菩萨行　　而来至我所
  汝念善知识　　诸佛所称叹
  令汝成菩提　　而来至我所
  汝念善知识　　生我如父母
  养我如乳母　　增长菩提分
  如医疗众疾　　如天洒甘露
  如日示正道　　如月转净轮
  如山不动摇　　如海无增减
  如船师济度　　而来至我所
  汝观善知识　　犹如大猛将
  亦如大商主　　又如大导师
  能建正法幢　　能示佛功德
  能灭诸恶道　　能开善趣门
  能显诸佛身　　能守诸佛藏
  能持诸佛法　　是故愿瞻奉
  欲满诸佛智　　欲具端正身
  欲生尊贵家　　而来至我所
  汝等观此人　　亲近善知识
  随其所修学　　一切皆顺行
  以昔福因缘　　文殊令发心
  随顺无违逆　　修行不懈倦
  父母与亲属　　宫殿及财产
  一切皆舍离　　谦下求知识
  净治如是意　　永离世间身
  当生佛国土　　受诸胜果报
  善财见众生　　生老病死苦
  为发大悲意　　勤修无上道
  善财见众生　　五趣恒流转
  为求金刚智　　破彼诸苦轮
  善财见众生　　心田甚荒秽
  为除三毒刺　　专求利智犁
  众生处痴暗　　盲冥失正道
  善财为导师　　示其安隐处
  忍铠解脱乘　　智慧为利剑
  能于三有内　　破诸烦恼贼
  善财法船师　　普济诸含识
  令过尔焰海　　疾至净宝洲
  善财正觉日　　智光大愿轮
  周行法界空　　普照群迷宅
  善财正觉月　　白法悉圆满
  慈定清凉光　　等照众生心
  善财胜智海　　依于直心住
  菩提行渐深　　出生众法宝
  善财大心龙　　升于法界空
  兴云霔甘泽　　生成一切果
  善财然法灯　　信炷慈悲油
  念器功德光　　灭除三毒暗
  觉心羯逻蓝　　悲胞慈为肉
  菩提分肢节　　长于如来藏
  增长福德藏　　清净智慧藏
  开显方便藏　　出生大愿藏
  如是大庄严　　救护诸众生
  一切天人中　　难闻难可见
  如是智慧树　　根深不可动
  众行渐增长　　普荫诸群生
  欲生一切德　　欲问一切法
  欲断一切疑　　专求善知识
  欲破诸惑魔　　欲除诸见垢
  欲解众生缚　　专求善知识
  当灭诸恶道　　当示人天路
  令修功德行　　疾入涅槃城
  当脱诸苦处　　当与安乐处
  断除诸系着　　永灭三有趣
  当度诸见难　　当截诸见网
  当枯爱欲水　　当示三有道
  当为世依救　　当作世光明
  当成三界师　　示其解脱处
  亦当令世间　　普离诸想着
  普觉烦恼睡　　普出爱欲泥
  当了种种法　　当净种种刹
  一切咸究竟　　其心大欢喜
  汝行极调柔　　汝心甚清净
  所欲修功德　　一切当圆满
  不久见诸佛　　了达一切法
  严净众刹海　　成就大菩提
  庄严福智海　　解脱众生海
  圆满诸行海　　汝当成觉海
  当到功德岸　　当生诸善品
  当与佛子等　　如是心决定
  当断一切惑　　当净一切业
  当伏一切魔　　满足如是愿
  当生妙智道　　当开正法道
  不久当舍离　　惑业诸苦道
  一切众生轮　　沉迷诸有轮
  汝当转法轮　　令其断苦轮
  汝当持佛种　　汝当净法种
  汝能集僧种　　三世悉周遍
  汝当断爱网　　汝当裂见网
  汝当救苦网　　当成此愿网
  当度众生界　　当净国土界
  当集智慧界　　当成此心界
  当令众生喜　　当令菩萨喜
  当令诸佛喜　　当成此欢喜
  当见一切趣　　当见一切刹
  当见一切法　　当成此佛见
  当放破暗光　　当放息热光
  当放灭恶光　　涤除三有苦
  当开天趣门　　当开佛道门
  当示解脱门　　普使众生入
  当示于正道　　当绝于邪道
  如是勤修行　　成就菩提道
  当修功德海　　当度三有海
  普使群生海　　出于众苦海
  当于众生海　　消竭烦恼海
  令修诸行海　　疾入大智海
  汝当增智海　　汝当修行海
  诸佛大愿海　　汝当咸满足
  汝当入刹海　　汝当观众海
  汝当以智力　　普饮诸法海
  当觐诸佛云　　当起供养云
  当听妙法云　　当兴此愿云
  普游三有室　　普坏众惑室
  普入如来室　　当行如是道
  普入三昧门　　普游解脱门
  普住神通门　　周行于法界
  普现众生前　　普对诸佛前
  譬如日月光　　当成如是力
  所行无动乱　　所行无染着
  如鸟行虚空　　当成此妙用
  譬如因陀网　　刹网如是住
  汝当悉往诣　　如风无所碍
  汝当入法界　　遍往诸世界
  普见三世佛　　心生大欢喜
  汝于诸法门　　已得及当得
  应生大喜跃　　无贪亦无厌
  汝是功德器　　能随诸佛教
  能修菩萨行　　得见此奇特
  如是诸佛子　　亿劫难值遇
  况见其功德　　所修诸妙道
  汝生于人中　　大获诸善利
  得见文殊等　　无量诸功德
  已离诸恶道　　已出诸难处
  已超众苦患　　善哉勿懈怠
  已离凡夫地　　已住菩萨地
  当满智慧地　　速入如来地
  菩萨行如海　　佛智同虚空
  汝愿亦复然　　应生大欣庆
  诸根不懈倦　　志愿恒决定
  亲近善知识　　不久悉成满
  菩萨种种行　　皆为调众生
  普行诸法门　　慎勿生疑惑
  汝具难思福　　及以真实信
  是故于今日　　得见诸佛子
  汝见诸佛子　　悉获广大利
  一一诸大愿　　一切咸信受
  汝于三有中　　修行成妙器
  是故诸佛子　　示汝解脱门
  非是法器人　　与佛子同住
  设经无量劫　　莫知其境界
  汝见诸佛子　　得闻如是法
  世间甚难有　　应生大喜庆
  诸佛护念汝　　菩萨摄受汝
  能顺其教行　　善哉住寿命
  已生菩萨家　　已具菩萨德
  已长如来种　　善哉应喜庆
  诸佛等慈父　　菩萨等天伦
  菩提分亲戚　　长养真实意
  已具菩萨种　　增长法王种
  已具法王德　　大喜充遍身
  已成最胜事　　奇特不思议
  不久汝皆得　　当升灌顶位
  如下如是种　　必获如是果
  我今庆慰汝　　汝应大欣悦
  无量诸菩萨　　无量劫行道
  未能成此行　　今汝皆获得
  信乐坚进力　　善财成此行
  若有敬慕心　　亦等如是学
  一切功德行　　皆从愿欲生
  善财已了知　　常乐勤修习
  如龙布密云　　必当霔大雨
  菩萨起愿智　　决定修诸行
  若有善知识　　示汝普贤行
  汝当好承事　　慎勿生疑惑
  汝于无量劫　　为欲妄舍身
  今为求菩提　　此舍方为善
  汝于无量劫　　具受生死苦
  不曾事诸佛　　未闻如是行
  汝今得人身　　值佛善知识
  听受菩提行　　云何不欢喜
  虽遇佛兴世　　亦值善知识
  其心不清净　　不闻如是法
  若于善知识　　信乐心尊重
  离疑不疲厌　　乃闻如是法
  若有闻此法　　而兴誓愿心
  当知如是人　　已获广大利
  汝今入此行　　最胜难思议
  善来于人中　　功德必成满
  如是心清净　　常得近诸佛
  亦近诸菩萨　　决定成菩提
  若入此法门　　则具诸功德
  永离众恶趣　　不受一切苦
  不久舍此身　　往生佛国土
  常见十方佛　　及以诸菩萨
  往因今净解　　及事善友力
  增长诸功德　　如水生莲华
  乐事善知识　　勤供一切佛
  专心听闻法　　常行勿懈倦
  汝是真法器　　当具一切法
  当修一切道　　当满一切愿
  汝以信解心　　而来礼敬我
  不久当普入　　一切诸佛会
  善哉真佛子　　恭敬一切佛
  不久具诸行　　到佛功德岸
  汝当往大智　　文殊师利所
  彼当令汝得　　普贤深妙行

尔时弥勒菩萨摩诃萨。在众会前。称赞善财无著境界圆满庄严大功德藏。善财闻彼随顺教诲。显示最胜。方便慰谕。欢喜踊跃。身毛皆竖。涕泪交流。悲泣哽噎。起立合掌。恭敬瞻仰。绕无量匝。以文殊师利心念力故。众华璎珞。种种妙宝。不觉忽然自盈其手。善财欣庆。不自胜任。即以奉散弥勒菩萨摩诃萨上。时弥勒菩萨。摩善财顶。为说偈言

  善哉善哉真佛子　　普策诸根无懈倦
  不久当具诸功德　　犹如文殊及与我

时善财童子。闻是赞已。以偈答曰

  我念善知识　　亿劫难值遇
  今得咸亲近　　而来诣尊所
  我以文殊故　　见诸难见者
  彼大功德尊　　愿速还瞻觐

尔时善财童子。合掌恭敬。重白弥勒菩萨摩诃萨言。大圣。我已先发阿耨多罗三藐三菩提心。而我未知菩萨云何学菩萨行。云何修菩萨道。我闻大圣。善能诱诲。唯愿慈哀。为我宣说。大圣。一切如来授尊者记。一生当得阿耨多罗三藐三菩提。若一生当得无上菩提。则已超越一切菩萨所住处。则已出过一切菩萨离生位。则已圆满一切波罗蜜。则已深入一切诸忍门。则已具足一切菩萨地。则已游戏一切解脱门。则已成就一切三昧法。则已通达一切菩萨行。则已证得一切陀罗尼辩才。则已于一切菩萨自在中而得自在。则已积集一切菩萨助道法。则已游戏一切菩萨智慧方便。则已出生一切善巧大智神通。则已成就一切菩萨所应学处。则已清净一切菩萨所行妙行。则已满足一切菩萨所发大愿。则已领受一切佛所记。则已了知一切诸乘门。则已堪任一切如来所护念。则已能摄一切佛菩提。则已能持一切佛法藏。则已能受一切诸佛秘密教。则已能转一切菩萨秘密轮。则已能为破烦恼魔军大勇将。则已能作出生死旷野大导师。则已能作治诸惑重病大医王。则已能于一切众生中为最胜。则已能于一切世主中得自在。则已能于一切圣人中最第一。则已能于一切声闻独觉中最增上。则已能于生死海中为船师。则已能布调伏一切众生网。则已能观一切众生根。则已能摄一切众生界。则已能守护一切菩萨众。则已能谈议一切菩萨事。则已能往诣一切如来所。则已能住止一切如来会。则已能现身一切众生前。则已能知一切诸法如幻焰。则已能观一切诸法如影像。则已能于一切世法无染着。则已能了一切诸法无生性。则已能净一切菩萨身口意。则已能以金刚定破一切魔。则已能知一切白净法本生处。则已能悟一切相不动性。则已能行波罗蜜不退转。则已能观一切法无常苦空无我。则已能起一切佛地诸善根。则已能修三十七品瑜伽行。则已于一切菩萨境界到彼岸。则已普知一切烦恼性寂灭。则已能住金刚三昧不可倾动。则已能了住三世心皆不可得。则已能证不动如山菩提心。则已能于一切世法无所著。则已能超越一切魔境界。则已能住一切佛境界。则已能到一切菩萨无碍境。则已能精勤供养一切佛。则已与一切佛法同体性。已系一切佛法缯。已受一切佛灌顶。已住一切法王位。已入一切智智境。已生一切诸佛法。已践一切种智位。大圣。菩萨云何学菩萨行。云何修菩萨道。随所修行。疾能证得一切佛法。云何菩萨悉能解了一切佛法。速能度脱所念众生。咸令究竟到于彼岸。普能成满所发大愿。普能究竟所起诸行。普能安慰一切天人。不负自身。不断三宝。不虚一切佛菩萨种。能持一切诸佛法眼。如是等事。愿皆为说

尔时弥勒菩萨摩诃萨。普观一切道场众会。指示善财。而作是言。诸仁者汝等。今者见此童子。来于我所。问菩萨行。普欲成就诸功德不。诸仁者。今此童子。勇猛精进。志愿无杂。深心坚固。恒不退转。具胜希望。心无厌足。如山不动。如救头然。爱乐亲近诸善知识。处处寻求。承事供养。请问法要。受持无失。诸仁当知。今此童子。曩于福城。受彼菩萨文殊师利教化示导。令其发心。展转询求。经由一百一十城善知识已。然后而来至于我所。曾无暂起一念疲懈。诸仁者。此善男子。甚为难有。趣向大乘住佛境界。乘大誓愿修同类行。发大勇猛。擐大悲甲。以大慈心。救护众生。起大精进。修波罗蜜。作大商主。护诸众生。为大法船。度诸有海。普集一切福智法宝。修诸广大助道之法。增长成就一切功德如是之人。难可得闻。难可得见。难得亲近。难与同行。何以故。此善男子。为欲救护一切众生。超诸恶趣。离众险难。破无明闇。出生死野。息诸趣轮。度魔境界。舍住着处。不染世法。出欲泥。断贪鞅。解见缚。坏想宅。绝迷道。摧慢幢。拔惑箭。撤睡盖。除障山。裂爱网。解痴结。出有流。离谄幻。净心垢。断疑惑。到涅槃。诸仁者。此大丈夫。为被四流漂汨者。造大法船。为被见泥没溺者。立大法桥。为堕愚痴黑闇者。然大智灯。为行一切生死旷野者。示以圣道。为婴一切惑业重病者。与其法药。为遭一切生死厄难者。饮以甘露。为入一切贪嗔痴火者。沃以定水。多忧恼者。慰谕令安。系有狱者。晓诲令出为见缚者。授以智剑。住界城者。示解脱门。在险难者。导安隐处。惧结贼者。与无畏法。堕恶趣者。授以法手。拘害蕴者。示涅槃城。界蛇所缠者。解以圣道。着于六处空聚落者。以智慧光引之令出。住邪道者。令入正济。近恶友者。示其善友。乐凡法者。诲以圣法。乐着生死诸有城者。令其趣入一切智城。诸仁者。此大丈夫。如是勤求种种方便。誓当救护一切众生。发菩提心。相续不断。于清净行。未曾休息。求大乘道。曾无懈倦。受持一切大法云雨。恒勤积集助道之法。圆满一切不舍善轭。常乐一切清净法门。修菩萨行。勇猛精进。念念勤求。无有退转。出生诸行。成满大愿。见善知识。情无厌足。事善知识。身不疲懈。闻善知识所有教诲。常思顺行。未曾违逆。诸仁者。此善男子。最极难得。若有众生。能发阿耨多罗三藐三菩提心。则于世间。是为希有。况发心已。复能如是为利众生。勇猛精勤。集诸佛法。当知是人倍为希有。又能如是勤求爱乐诸菩萨道。又能如是增长清净诸菩萨行。又能如是亲近承事诸善知识。又能如是如救头然。如山不动。又能如是随顺一切善知识教。又能如是坚固修行一切佛道。又能如是积集一切菩提分法。又能如是不乐一切名利恭敬。又能如是不舍菩萨纯一之心。又能如是不乐家宅。不欣富贵。不贪受用。不着欲乐。不恋父母亲戚知识。不顾世间一切财物。但乐追求菩萨伴侣。又能如是不顾形命。唯愿勤修一切智道。应知展转倍更难得。诸仁者。其余菩萨。经于无量百千万亿那由他劫。乃能满足菩萨愿行。乃能亲近诸佛菩提。此善男子。于一生内。则能严净一切佛刹。则能教化一切众生。则以智慧深入法界。则能成就诸波罗蜜。则能增广一切行网。则能圆满一切大愿。则能超出一切魔业。则能承事一切善友。令生欢喜。则能清净诸菩萨行。令其具足。则能修习普贤诸行。令其成就

尔时弥勒菩萨摩诃萨。如是称叹善财童子种种功德。令众会中无量百千众生。坚固无上菩提之心。告善财言。善哉善哉。善男子。汝为利乐一切世间。汝为救护一切众生。汝为勤求一切佛法故。发阿耨多罗三藐三菩提心。善男子。汝获善利。汝善得人身。汝善住寿命。汝善值如来出兴于世。汝善见文殊师利大善知识。汝身即是真善法器。为诸善根之所润泽。汝为白法之所资持。信乐广大。慧解清净。已得诸佛之所护念。已为善友共所摄受。何以故。谓能发大菩提心故。善男子。菩提心者犹如种子。能生一切诸佛法故。菩提心者犹如良田。能长众生白净法故。菩提心者犹如大地。能持一切诸世间故。菩提心者犹如大水。能涤一切烦恼垢故。菩提心者犹如大风。普行世间无所碍故。菩提心者犹如大火。能烧一切诸见薪故。菩提心者犹如净日。普照一切诸世间故。菩提心者犹如盛月。普能圆满白净法故。菩提心者犹如明灯。能放种种法光明故。菩提心者犹如净目。普见一切夷险处故。菩提心者犹如大道。普令得入大智城故。菩提心者犹如正济。令其得离诸邪法故。菩提心者犹如大车。普能运载诸菩萨故。菩提心者犹如门户。开示一切菩萨行故。菩提心者犹如宫殿。安住修习三昧法故。菩提心者犹如园苑。于中游戏受法乐故。菩提心者犹如舍宅。安隐一切诸众生故。菩提心者则为所归。利益一切诸世间故。菩提心者则为所依。诸菩萨行所依处故。菩提心者犹如严父。训导一切诸菩萨故。菩提心者犹如慈母。生长菩萨诸善根故。菩提心者犹如乳母。养育守护诸菩萨故。菩提心者犹如善友。成益一切诸菩萨故。菩提心者犹如君主。胜出一切二乘人故。菩提心者犹如帝王。一切愿中得自在故。菩提心者犹如大海。普生一切诸功德故。菩提心者如须弥山。于诸众生心平等故。菩提心者如铁围山。摄持一切诸世间故。菩提心者如大雪山。长养一切智慧药故。菩提心者犹如香山。出生一切功德香故。菩提心者如大虚空。诸妙功德广无边故。菩提心者如妙莲华。不染一切世间法故。菩提心者如调慧象。其心善顺不犷戾故。菩提心者如良善马。远离一切诸恶性故。菩提心者如调御师。守护一切大乘法故。菩提心者犹如良药。能治一切烦恼病故。菩提心者犹如坑阱。陷没一切诸恶法故。菩提心者犹如金刚。悉能穿彻一切法故。菩提心者犹如香箧。能贮一切功德香故。菩提心者犹如妙华。一切世间所乐见故。菩提心者如白栴檀。除众欲热使清凉故。菩提心者如黑沉香。能熏法界悉周遍故。菩提心者如善见药王。能破一切烦恼病故。菩提心者如毗笈摩药。能拔一切诸惑箭故。菩提心者犹如心识。能与诸根作依止故。菩提心者犹如帝释。一切主中最尊胜故。菩提心者如毗沙门。能断一切贫穷苦故。菩提心者如功德天。一切功德所庄严故。菩提心者如庄严具。庄严一切诸菩萨故。菩提心者如劫烧火。能烧一切诸有为故。菩提心者如无生根药。长养一切诸佛法故。菩提心者犹如龙珠。能销一切烦恼毒故。菩提心者如水清珠。能清一切烦恼浊故。菩提心者如如意珠。周给一切诸贫乏故。菩提心者如贤德瓶。满足一切众生愿故。菩提心者如如意树。能雨一切庄严具故。菩提心者如鹅羽衣。不受一切生死垢故。菩提心者如白[疊*毛]线。从本已来性清净故。菩提心者如快利犁。能治一切众生田故。菩提心者如那罗延。能摧一切我见敌故。菩提心者犹如快箭。能破一切诸苦的故。菩提心者犹如利矛。能穿一切烦恼甲故。菩提心者犹如坚甲。能护一切如理心故。菩提心者犹如利刀。能斩一切烦恼首故。菩提心者犹如利剑。能断一切憍慢铠故。菩提心者犹如利镰。能翦随眠微细惑故。菩提心者如勇将幢。能伏一切诸魔军故。菩提心者犹如利锯。能截一切无明树故。菩提心者犹如利斧。能伐一切诸苦树故。菩提心者犹如器仗。能防一切诸厄难故。菩提心者犹如善手。防护一切智度身故。菩提心者犹如好足。安立一切功德身故。菩提心者犹如金錍。能除一切无明翳故。菩提心者犹如钳镊。能拔一切身见刺故。菩提心者犹如卧具。息除生死诸劳苦故。菩提心者如善知识。能解一切生死缚故。菩提心者如好珍财。能除一切贫穷事故。菩提心者犹如导师。善知菩萨出要道故。菩提心者犹如伏藏。出功德财无匮乏故。菩提心者犹如涌泉。出智慧水无穷尽故。菩提心者犹如明镜。普现一切法门像故。菩提心者犹如莲华。不染一切诸罪垢故。菩提心者犹如大河流。引一切度摄法故。菩提心者如大龙王。能雨一切妙法雨故。菩提心者犹如命根。任持菩萨大悲身故。菩提心者犹如甘露。能令安住不死界故。菩提心者犹如大网。普摄一切诸众生故。菩提心者犹如罥索。摄取一切所应化故。菩提心者犹如钩饵。出有渊中所居者故。菩提心者如阿伽陀药。能除惑病永安隐故。菩提心者如除毒药。悉能消歇贪爱毒故。菩提心者如善持明。能灭一切恶寻伺故。菩提心者犹如疾风。能散一切诸障雾故。菩提心者如大宝洲。出生一切觉分宝故。菩提心者如好种子。出生一切白净法故。菩提心者犹如住宅。诸功德法所依处故。菩提心者犹如市肆。菩萨商主贸易处故。菩提心者如炼金药。能治一切烦恼垢故。菩提心者犹如好蜜。圆满一切功德味故。菩提心者犹如正道。令诸菩萨入智城故。菩提心者犹如好器。能持一切白净法故。菩提心者犹如时雨。能灭一切烦恼尘故。菩提心者犹如住处。一切菩萨所依住故。菩提心者犹如磁石。吸引一切解脱果故。菩提心者如净琉璃。自性明洁无诸垢故。菩提心者如帝青宝。出过世间二乘智故。菩提心者如更漏鼓。觉诸众生烦恼睡故。菩提心者如清净水。性本澄洁无垢浊故。菩提心者如阎浮金。映夺一切有为善故。菩提心者如大山王。超出一切诸世间故。菩提心者则为所归。不拒一切诸来者故。菩提心者则为义利。能除一切衰恼事故。菩提心者则为妙宝。能令一切心欢喜故。菩提心者如大施会。充满一切众生心故。菩提心者则为尊胜。诸众生心无与等故。菩提心者犹如伏藏。能摄一切诸佛法故。菩提心者如善讽诵。普摄菩萨诸行愿故。菩提心者如能守护。随顺长养一切法故。菩提心者如能利益。能回一切不善法故。菩提心者如因陀罗网。能伏烦恼阿修罗故。菩提心者如婆楼那风。能动一切所应化故。菩提心者如因陀罗火。能烧一切诸惑习故。菩提心者如佛支提。一切世间应供养故。善男子。菩提心者成就如是无量无边最胜功德。举要言之。应知悉与一切佛法诸功德等。何以故。因菩提心。出生一切菩萨行轮。三世十方一切如来。从菩提心而出生故。是故善男子。若有能发阿耨多罗三藐三菩提心者。则已出生无量功德。普能摄取一切智道

大方广佛华严经卷第三十五大方广佛华严经卷第三十六

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时弥勒菩萨复告善财童子。言善男子。譬如有人得无畏药。离五恐怖。何等为五。所谓火不能烧。毒不能中。刀不能伤。水不能漂。烟不能熏。菩萨摩诃萨。亦复如是。得一切智菩提心药。离五怖畏。何等为五。不为一切三毒火烧。五欲毒不中。惑刀不伤。有流不漂。诸觉观烟不能熏害。善男子。譬如有人得解脱药。终无横难。菩萨摩诃萨。亦复如是。得菩提心解脱智药。永离一切生死横难。善男子。譬如有人持摩诃应伽药。随其方所。一切毒蛇。闻此药气。即皆远去。菩萨摩诃萨。亦复如是。持菩提心大应伽药。一切烦恼。诸恶毒蛇。闻其气者。悉皆散灭。善男子。譬如有人持无能胜药。一切怨敌无能胜者。菩萨摩诃萨。亦复如是。持菩提心无能胜药。悉能降伏一切魔军。善男子。譬如有人持毗笈摩药。能令毒箭自然堕落。菩萨摩诃萨。亦复如是。持菩提心毗笈摩药。令贪嗔痴诸邪见箭自然堕落。善男子。譬如有人持善见药。能除一切所有诸病。菩萨摩诃萨。亦复如是。持菩提心善见药王。悉除一切诸烦恼病。善男子。如有药树名珊陀那。有取其皮以涂疮者。疮即除愈平复如故。亦无[病-丙+盤][病-丙+(一/艮)]。然其树皮。随取随生。终不可尽。菩萨摩诃萨。从菩提心生大智树。亦复如是。若有得见而生信者。烦恼业疮悉得销灭。一切智树初无所损。善男子。如有药树名成就根。以其力故。令阎浮提一切树根。枝叶华果。增长成就。菩萨摩诃萨菩提心树亦复如是。以胜威力。能令一切声闻独觉学无学等及诸菩萨。所有善根增长成就。善男子。譬如有药名阿蓝婆。若用涂身。身之与心。咸有堪能。菩萨摩诃萨。得菩提心阿蓝婆药。亦复如是。令其身心有胜堪能增长善法。善男子。譬如有人得念力药。能令其心念力清净。菩萨摩诃萨。亦复如是。得菩提心念力妙药。心无障碍。念力清净。善男子。譬如有药名大莲华。其有服者。住寿一劫。菩萨摩诃萨。服菩提心。大莲华药。亦复如是。于无数劫。寿命自在。修集种种波罗蜜行。善男子。譬如有人执翳形药。一切世间人及非人悉不能见。菩萨摩诃萨。持菩提心翳形妙药。亦复如是。于诸境界种种游行。一切诸魔不能得见。善男子。如海有珠名普集众宝。此珠若在一切众宝常不散失。假使劫火焚烧世间。能令此海减于一滴。无有是处。况至干竭菩萨摩诃萨菩提心珠。亦复如是。住于菩萨一切智智大愿海中。若常忆持不令退失。能坏菩萨一善根者。终无是处。若退其心。舍一切智。一切善法。即皆散灭。善男子。如有摩尼名普集光明。有以此珠璎珞其身。映蔽一切宝庄严具。所有光明悉皆不现。菩萨摩诃萨菩提心宝。亦复如是。庄严心性。映蔽一切声闻独觉所有心宝。诸庄严具。悉无光彩。善男子。如有珠宝名曰水清。若以此珠置浊水中。以珠威力水即澄清。菩萨摩诃萨菩提心珠。亦复如是。能清一切烦恼垢浊。善男子。譬如有人得住水宝。系其身上。入大海中。自在游行不为水害。菩萨摩诃萨。亦复如是。得菩提心一切智智住水妙宝。入于一切生死海中。游戏自在终不沉溺。善男子。譬如有人得龙宝珠。持入龙宫。游止大海。以珠威力。一切龙蛇及诸水族。悉不能害。菩萨摩诃萨。亦复如是。得菩提心一切智智大龙宝珠。入于欲界痴爱水中。惑业龙蛇不能为害。善男子。譬如帝释着摩尼冠。庄严其顶。映蔽一切诸余天众。菩萨摩诃萨亦复如是。着菩提心一切智智大愿宝冠。系其心顶。超过一切三界众生。善男子。譬如有人得如意珠。除灭一切贫穷之苦。菩萨摩诃萨亦复如是。得菩提心一切智智如意宝珠。出生菩萨善法资具。远离一切邪命怖畏善男子。譬如有人得日精珠。持向日光而生于火。菩萨摩诃萨。亦复如是。得菩提心一切智性日精宝珠。持向智光。而生智火。善男子。譬如有人得月爱珠。持向月光而生于水。菩萨摩诃萨。亦复如是。得菩提心月精宝珠。持此心珠。鉴回向光。而生一切善根愿水。善男子。譬如龙王首戴如意摩尼宝冠。远离一切怨敌怖畏。菩萨摩诃萨。亦复如是。着菩提心大悲宝冠。远离一切恶道诸难。善男子。如有宝珠名一切世间庄严藏。若有得者。令其所欲悉得充满。而此宝珠用无穷尽。体不损减。菩萨摩诃萨菩提心宝。亦复如是。若有得者。令其所愿悉得圆满。而菩提心用不穷尽。体无损减。善男子。如转轮王有摩尼宝。置于宫中。放大光明。破一切闇。菩萨摩诃萨。亦复如是。以菩提心一切智智大摩尼宝。住于欲界。放大智光。悉破诸趣无明黑闇。善男子。譬如帝青大摩尼宝。若有为此光明所触。即同其色。菩萨摩诃萨发菩提心一切智宝。亦复如是。观察诸法。回向善根。趣一切智。靡不即同一切智智菩提心色。善男子。如琉璃宝于百千岁处不净中。不为臭秽之所染着。最极无垢。性本净故。菩萨摩诃萨发菩提心一切智宝亦复如是。于百千劫。住欲界中。不为欲界过患所染。最极无垢。如法界性。本清净故。善男子。譬如有宝名净光明。悉能映蔽一切宝色。菩萨摩诃萨。发菩提心一切智宝。亦复如是。悉能映蔽一切凡夫有学无学二乘功德。善男子。譬如有宝名为火焰。悉能除灭一切闇冥。菩萨摩诃萨。一切智宝。亦复如是。观行相应。能灭一切无明黑闇。善男子。譬如海中有无价宝。商人采得船载入城。其诸摩尼百千万种光色。价直无与等者。菩萨摩诃萨菩提心宝亦复如是。住于生死大海之中。乘大愿船。深心相续。入解脱城。一切声闻。及辟支佛。所有功德。无能及者。善男子。如有宝珠名自在王。处阎浮洲。去日月轮四万由旬。日月宫中所有庄严。其珠影现。悉皆具足。菩萨摩诃萨发菩提心一切智智清净功德自在王宝亦复如是。住生死中。照法界空。佛智日月。一切功德。清净境界。影像庄严。悉于中现。善男子。如有宝珠名自在王。日月光明所照之处。一切财宝衣服等物。所有价直。悉不能及。菩萨摩诃萨发菩提心自在王宝亦复如是。一切智光所照之处。三世所有。天人二乘。种种善根。漏无漏法。一切功德。皆不能及。善男子。譬如海中有摩尼宝名曰海藏。普现海中诸庄严事。菩萨摩诃萨菩提心宝。亦复如是。普能显现一切智海诸庄严事。善男子。譬如天上阎浮檀金。唯除心王大摩尼宝。余无及者。菩萨摩诃萨发菩提心阎浮檀金亦复如是。除一切智心王大宝。余无及者。善男子。譬如有人善调龙法。于诸龙中而得自在。菩萨摩诃萨。亦复如是发菩提心。得一切智善调龙法。于诸一切烦恼龙中。而得自在。善男子。譬如勇士。被执铠仗。一切怨敌。无能降伏。菩萨摩诃萨。亦复如是。被执菩提大心铠仗。一切业惑诸恶怨敌。无能摧伏无能屈者。善男子。譬如天上白栴檀香。若烧一铢其香普熏小千世界。三千世界满中珍宝。所有价直。皆不能及。菩萨摩诃萨菩提心香亦复如是。一念功德普熏法界。声闻独觉。一切功德。皆所不及。善男子。如白栴檀。若以涂身。悉能除灭一切热恼。令其身心普得清凉。菩萨摩诃萨菩提心香亦复如是。发一切智。普熏身心。能除一切虚妄分别贪嗔痴等诸惑热恼。令其具足智慧清凉。善男子。如须弥山。众生近者。即同其色。菩萨摩诃萨菩提心山。亦复如是。若有近者。悉得同其一切智色。善男子。譬如波利质多罗树拘鞞陀罗树。其皮香气。阎浮提中。所有诸华。若婆师迦。若瞻博迦。若苏摩那及郁金等。如是诸华。所有香气。皆不能及。菩萨摩诃萨菩提心树。亦复如是。所发大愿功德之香。一切二乘无漏戒定智慧。解脱解脱知见。诸功德香。悉不能及。善男子。譬如波利质多罗树。拘鞞陀罗树。虽未开华。应知即是无量诸华出生之处。菩萨摩诃萨菩提心树。亦复如是。虽未开发一切智华。应知即是无数人天。有漏无漏。众菩提华所生之处。善男子。譬如波利质多罗华。一日熏衣。所出香气。瞻博迦华。婆利师迦华。苏摩那华。虽千岁熏。亦不能及。菩萨摩诃萨菩提心华。亦复如是。一生所熏诸功德香。普彻十方一切佛所。一切二乘无漏功德。百千劫熏。所不能及善男子。如海岛中生椰子树。根茎枝叶。及以华果。一切众生。恒取受用。无时暂歇。菩萨摩诃萨菩提心树。亦复如是。始从发起悲愿之心。乃至成佛。正法住世。常时利益。一切世间。无有间息。善男子。如有药汁名诃樀迦。人或得之。以其一两。变千两铜。悉成真金。非千两铜。能变此药。菩萨摩诃萨。亦复如是。以菩提心回向智药。普变一切业惑等法。悉使成于一切智相非业惑等。能变其心。善男子。如微小火。投干草[卄/積]。随所焚烧。其焰转炽。菩萨摩诃萨菩提心火。亦复如是。随其所缘善恶法聚。能令智焰展转增盛。善男子。譬如一灯然百千灯。其本一灯。无减无尽。菩萨摩诃萨菩提心灯。亦复如是。普然三世诸佛智灯。而其心灯无减无尽。善男子。譬如一灯入于闇室。百千年闇悉能破尽。发起光明。普照一切。菩萨摩诃萨菩提心灯。亦复如是。入众生心无明闇室。能灭无量百千万亿不可说劫积集一切诸业烦恼种种障碍。发生一切大智光明善男子。譬如灯炷。随其大小。而发光明。若益膏油。明终不绝。菩萨摩诃萨菩提心灯。亦复如是。大愿为炷。发智慧光。照明法界。益大悲油。教化众生。庄严国土。施作佛事。现大威德。无有休息。善男子。譬如他化自在天王冠阎浮檀真金天冠。欲界天子诸庄严具。所有光明。无能映夺。一切威力。皆不能及。菩萨摩诃萨。亦复如是。冠菩提心一切智宝大愿天冠。凡夫二乘所有功德。皆不能及。善男子。如师子王哮吼之时。师子儿闻皆增勇健。余兽闻之脂血销耗。即皆窜伏。佛师子王菩提哮吼。一切智声。应知亦尔。诸菩萨闻。养育法身。增长功德。其余一切邪执众生。闻皆退散。如冰销释。善男子。譬如有人以师子筋而为乐弦。其音既奏。余弦悉绝。菩萨摩诃萨。亦复如是。以如来师子波罗蜜身菩提心筋。为法乐弦。其音既奏。一切五欲。及以二乘诸功德弦。悉皆断灭。善男子。譬如有人以牛羊等种种诸乳。假使积集盈于大海。以师子乳一滴投中。直过无碍能令众乳一时变坏。菩萨摩诃萨。亦复如是。以如来师子菩提心乳。着无始际业烦恼中。直过无碍。悉令坏灭。终不住于二乘解脱。善男子。譬如雪山迦陵频伽鸟。在卵[穀-禾+卵]中。有大势力。一切诸鸟。所不能及。菩萨摩诃萨。亦复如是。于生死[穀-禾+卵]。发菩提心。所有大悲功德势力。声闻独觉无能及者。善男子。如金翅鸟王子。初始生时。目则明利。飞则劲捷。威势力能超过一切其余众鸟。虽久成长。无能及者。菩萨摩诃萨亦复如是。发菩提心。为诸如来金翅王子。智慧清净。大悲勇猛。具自在力神通威势。一切二乘。虽百千劫久修道行。所不能及。善男子。如有壮夫手执利矛。刺坚密甲直过无碍。菩萨摩诃萨。亦复如是。勇猛精进。执菩提心一切智智铦利快矛。刺诸邪见随眠密甲。悉能穿彻。无有障碍善男子。譬如摩诃那伽大力勇士。若奋威怒。于其额上必生疮疱。疮若未合。阎浮提中。一切人众。无能制伏。菩萨摩诃萨。亦复如是。若起大悲。必定发于菩提之心一切智疮。心未舍来。一切世间。诸魔眷属。惑业恶人。不能为害。善男子。譬如射师有诸弟子。虽未惯习师之技艺。然其智慧方便善巧。余一切人所不能及。菩萨摩诃萨初始发心。亦复如是。虽未惯习一切智行菩提事业。然其所有愿智解欲。一切世间。凡夫二乘。悉不能及。善男子。如人学射。先安其足。后习其法。及诸剑术。一切武艺。斯为根本。菩萨摩诃萨。亦复如是。欲学如来一切智道。先当安住菩提之心。然后修行一切佛法。善男子。譬如幻师。将作幻事。先当起意。忆持幻法。然后一切悉得成就。菩萨摩诃萨。亦复如是。将起一切诸佛菩萨神通幻事。先当发起大菩提心。然后一切悉得成就。善男子。譬如幻术。无色现色。一切变化。皆能显示。菩萨摩诃萨菩提心相一切智幻。亦复如是。虽无有色不可睹见。然能普于十方法界。示现种种功德庄严。善男子。譬如猫狸。才见于鼠。鼠即入穴。不敢复出。菩萨摩诃萨。发菩提心。亦复如是。暂以慧眼。观诸惑业。皆即窜灭。不复出生。善男子。譬如有人。着阎浮金庄严之具。映蔽一切众宝光明。皆如聚墨。菩萨摩诃萨。亦复如是。着菩提心一切智智金庄严具。映蔽一切凡夫二乘功德庄严。悉无光色。善男子。如好磁石。少分之力。即能吸坏一切坚牢诸铁钩锁。菩萨摩诃萨。亦复如是若起一念菩提之心。悉能坏灭一切邪见贪欲系缚无明钩锁。善男子。如有磁石。随所在处。铁若见之。即皆散灭。无留住者。菩萨摩诃萨。亦复如是。发菩提心。以智观察一切世间诸业烦恼。二乘解脱。若暂见之。即皆散灭。无有住者。善男子。譬如渔人。善入大海。一切水族。无能为害。假使入于摩竭鱼口。亦不为彼之所吞噬。菩萨摩诃萨。亦复如是。发菩提心。入生死海。诸业烦恼。一切水族。不能为害。假使入于声闻独觉实际解脱摩竭口中。亦不为其之所留难。善男子。譬如有人。饮甘露浆。一切诸毒。不能为害。菩萨摩诃萨。亦复如是。饮菩提心一切智智甘露法浆。不堕声闻辟支佛地。以具广大悲愿力故。善男子。譬如有人。得安缮那药。以涂其目。虽能自在游行人间。一切世人。所不能见。菩萨摩诃萨。亦复如是。得菩提心安缮那药。能以愿智方便。随顺入魔境界。自在游行。一切众魔。所不能见。善男子。譬如有人。依附于王。不畏余人。菩萨摩诃萨。亦复如是。依菩提心。住一切智大势力王。不畏世间一切障盖恶趣之难。善男子。譬如有人。住于水中。不畏火焚。菩萨摩诃萨。亦复如是。住菩提心善根水中。不畏一切声闻独觉解脱智火。善男子。譬如有人。依倚猛将。即不怖畏一切怨敌。菩萨摩诃萨。亦复如是。依菩提心勇猛智将。不畏一切恶行怨敌。善男子。如释天王执金刚杵。摧伏一切阿修罗众。菩萨摩诃萨。亦复如是。持菩提心金刚智杵。摧伏一切诸魔外道阿修罗众。善男子。譬如有人得最胜药。服之延龄。长得充健。不羸不瘦。不老不病。菩萨摩诃萨。亦复如是。服菩提心最胜智药。住无数劫生死之中。修菩萨行。心无疲厌。亦无染着。善男子。譬如有人。调和药汁。必当先取好清净水。于一切处平等受用。菩萨摩诃萨。亦复如是。欲修菩萨一切行愿。先当发起菩提之心。能令一切平等受润善男子。譬如有人。欲护其身。先护命根。菩萨摩诃萨。亦复如是。护持一切诸佛正法。应先守护菩提之心。善男子。譬如有人。命根若断。所务皆息。不能利益父母宗亲。菩萨摩诃萨。亦复如是。舍菩提心一切智命。所有功德。皆不成就。不能利益一切众生。善男子譬如大海。一切毒药。所不能坏。菩萨摩诃萨。亦复如是。发菩提心。一切智海。诸业烦恼。二乘之心。一切众毒。所不能坏善男子。譬如日轮。星宿光明。不能映蔽。菩萨摩诃萨。亦复如是。菩提心日。大智慧轮。一切二乘。无漏功德星宿智光。所不能蔽善男子。譬如王子初始生时。即为一切耆旧大臣之所尊重。以种族真正增上自在故。菩萨摩诃萨。亦复如是。于佛法中。初发菩提一切智心。生如来家。为法王子。即为一切久修梵行声闻缘觉所共尊重。以菩提心大悲种姓增上自在故。善男子。譬如王子。年虽幼稚。一切大臣。皆悉敬礼。然此王子。于彼大臣。心虽敬重。不应礼拜。以种姓殊胜故。菩萨摩诃萨。亦复如是。虽初发心修菩萨行。二乘耆旧。久修梵行见此菩萨。皆应敬礼以得法殊胜故。善男子。譬如王子。虽于一切臣佐之中。未得自在。辅相大臣。无能与等。以其生处极尊胜故。菩萨摩诃萨。亦复如是。虽于一切业烦恼中。未得自在。然其已发大菩提心。诸阿罗汉。及辟支佛。无能与等。以具如来圣种姓故。善男子。譬如清净摩尼宝珠。眼有翳故。见为不净。菩萨摩诃萨。亦复如是。大菩提心。本性清净。一切众生。无智翳眼。以不信故。谓为不净。善男子。譬如有药为咒所持。若有众生见闻同住。一切诸病。皆得销灭。菩萨摩诃萨。菩提心药。亦复如是一切善根。智慧方便。皆为愿智共所摄持。若有众生。见闻同住。随顺忆念。诸烦恼病。悉得除灭。善男子。譬如有人。常服甘露。其身毕竟。不变不坏。菩萨摩诃萨。亦复如是。若常忆持菩提心露。令愿智身毕竟不坏。善男子。譬如有人。被鹅羽衣。一切泥水。不能染着。菩萨摩诃萨。亦复如是。净菩提心白鹅羽衣。一切生死。诸业烦恼。不能染着。善男子。譬如桴筏。以绳贯穿。连缀竹木。不令分散。于河流中。游行自在。菩萨摩诃萨。亦复如是。以菩提心大愿智绳。摄持诸行。不令分散。法驶流中。游行自在。随顺趣入一切智海。善男子。譬如木人。若无机关。身即离散。虽具支分。不能运动。菩萨摩诃萨。亦复如是。舍菩提心。行即分散。不能成就一切佛法。善男子。如转轮王有沉香宝名曰象藏。若烧此香。王四种兵悉腾虚空。菩萨摩诃萨菩提心香。亦复如是。若发此心。即令菩萨一切善根。永出三界。行如来智。普遍无尽虚空法界。善男子。譬如金刚。唯从金刚及金处生。非余宝处之所能生。菩萨摩诃萨菩提心金刚。亦复如是。唯从大悲救护众生金刚处生。及能观察一切智境金处而生。非余众生善根处生。善男子。譬如有树名曰无根。所依住处。竟不可得。而其一切枝叶华果。悉皆繁茂。菩萨摩诃萨菩提心树。亦复如是。一切智性。无有所依。而能生长福德智慧神通大愿枝叶华果。饶益世间。普覆一切。善男子。如金刚宝。非诸劣恶及[斯/瓦]破器所能容持。唯除金银全具宝器。菩萨摩诃萨发菩提心金刚智宝。亦复如是。非余下劣薄福众生悭嫉破戒嗔恨懒惰妄念无智诸恶器中所能容持。亦非退失殊胜志愿散乱恶觉众生器中。所能容持。唯除菩萨深心宝器。善男子。譬如金刚。能钻众宝。菩萨摩诃萨菩提心金刚。亦复如是。悉能穿彻一切法宝。善男子。譬如金刚能坏一切坚固宝山。菩萨摩诃萨菩提心金刚。亦复如是。悉能摧坏诸邪见山。善男子。譬如金刚。虽破不全。犹胜众宝金庄严具。菩萨摩诃萨。亦复如是。发菩提心一切智宝。虽复志劣少有亏损。犹胜一切二乘功德。善男子。譬如金刚。虽有损缺。犹能除灭一切贫苦。菩萨摩诃萨。亦复如是。发菩提心一切智宝。虽诸戒行多有损缺。终能舍离一切生死。善男子。譬如金刚。乃至少分。悉能破坏一切诸物。菩萨摩诃萨。亦复如是。发菩提心。乃至一念。即破一切无知诸惑。善男子。譬如金刚。非诸凡下之所能得。菩萨摩诃萨菩提心金刚一切智宝。亦复如是。非诸劣意凡夫二乘之所能得。善男子。譬如金刚。不识宝人。不知其能。不得受用。菩萨摩诃萨菩提心金刚。亦复如是。钝根无智下劣凡夫。不了其能。不得其用善男子。譬如金刚无能销灭。菩萨摩诃萨菩提心金刚。亦复如是。一切诸法。无能销灭。善男子。如金刚杵。诸大力士。皆不能持。唯除有大那罗延力。菩萨摩诃萨菩提心杵。亦复如是。一切二乘。虽有大力。皆不能持。唯除菩萨广大因缘坚固善力。善男子。譬如金刚一切诸物无能坏者。而能普坏一切诸物。无有障碍。然其体性。亦不损减。菩萨摩诃萨菩提之心。亦复如是。普于三世无数劫中。教化众生。修行苦行。一切世间。声闻独觉。所不能及。咸能作之。然一切智。大心金刚。毕竟坚固。无有损减。不生疲厌。亦无障碍。善男子。譬如金刚非余地分之所能持。唯除坚厚金刚之际。菩萨摩诃萨菩提之心。亦复如是。声闻独觉。所有行愿。皆不能持。唯除趣向萨婆若道诸大菩萨坚固智力。善男子。如金刚器无有瑕隙。用盛于水。永不渗漏而令散失。菩萨摩诃萨大菩提心金刚宝器。亦复如是。体性无漏。坚固回向。盛善根水。永不散失。善男子。如金刚轮。能持大地。不令散坏。亦不陷没。菩萨摩诃萨菩提之心。亦复如是。能持菩萨一切行愿。不令坠没入于三界。善男子。譬如金刚。久处水中不烂不坏。菩萨摩诃萨菩提之心。亦复如是。于一切劫。久处生死业烦恼中。不烂不坏。善男子。譬如金刚。一切大火不能烧然。不能令热。菩萨摩诃萨菩提之心。亦复如是。一切生死。诸烦恼火。不能烧然。不能令热。善男子。譬如此界一切诸佛。将成正觉。降伏四魔。证一切智。坐道场时。唯三千界金刚地际。金刚座上之所能持。非是余座所能成就。菩萨摩诃萨菩提心座。亦复如是。能持菩萨一切行愿。诸波罗蜜圆满诸忍。深入诸地。具足善根。种种回向。蒙佛授记。修集增长诸菩萨道。亲近供养一切如来。承顺受持大法云雨。速疾增长坚固大悲。及能成辨一切愿智。乃至究竟阿耨多罗三藐三菩提。唯金刚智之所能持。非余善根所能成就。善男子。如转轮王。游四天下。七宝之中。轮宝先导。菩萨摩诃萨。亦复如是。为法轮王。利益一切菩提心宝。最为先导。善男子。譬如世间灭除怨敌。诸器仗中弓箭最胜。菩萨摩诃萨。亦复如是。于诸一切助道具中。菩提之心。最为第一。悉能灭除一切烦恼生死怨故。善男子。譬如一切水生华中。优钵罗华。而为最胜。陆生华中。瞻博迦华。而为最胜。菩萨摩诃萨菩提之心。亦复如是。一切智体。优钵罗华。大慈悲心。瞻博迦华。最为第一。能灭众生业烦恼故。善男子。如诸乘中船为第一。以行速疾。令身安乐。能达大海。到于彼岸。菩萨摩诃萨。亦复如是。于彼一切二乘之中。大菩提心而为第一。以能速疾运度众生。令其安乐达彼岸故。善男子。譬如世间一切水中雨水第一。菩萨摩诃萨。亦复如是。于诸一切三昧水中。菩提之心。而为第一。能生一切禅定解脱甘露味故。善男子。譬如盐中先陀婆盐而为第一。能除诸病。及能明眼。菩萨摩诃萨。亦复如是。于其八万四千法中。菩提之心。而为最胜。以能除灭一切众生惑业重病。生智明故。善男子。譬如乳中牛乳第一。能除诸病令人增寿。菩萨摩诃萨菩提之心。亦复如是。于诸正法甘露味中。而为最胜。能除众生诸烦恼病。及令菩萨慧命增故。善男子。此菩提心。成就如是无量无边乃至不可说不可说具足圆满殊胜功德。若有众生。发阿耨多罗三藐三菩提心。则获如是具足圆满胜功德法。善男子。汝获善利。具善名称。汝今能发阿耨多罗三藐三菩提心。求菩萨行已。得如是难行难集大功德故

大方广佛华严经卷第三十六大方广佛华严经卷第三十七

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时弥勒菩萨。告善财童子言。善男子。如汝所问。菩萨云何。学菩萨行。修菩萨道。善男子。汝可入此毗卢遮那庄严藏大楼阁中。周遍观察。则能了知一切菩萨学菩萨行学已能行圆满成就无量功德

尔时善财童子。恭敬右绕弥勒菩萨摩诃萨已。而白之言。唯愿大圣。开楼阁门。令我得入。时弥勒菩萨。前诣毗卢遮那庄严藏楼阁。即以右手弹指出声。其门即开。命善财入。善财心喜。入已还闭。见其楼阁广博无量。同于虚空。阿僧祇宝以为其地。阿僧祇宫殿。阿僧祇门闼。阿僧祇窗牖。阿僧祇阶陛。阿僧祇栏楯。阿僧祇道路。皆七宝成。阿僧祇幡。阿僧祇幢。阿僧祇盖。周回间列。阿僧祇众宝璎珞。阿僧祇白真珠璎珞。阿僧祇赤真珠璎珞。阿僧祇师子珠璎珞。处处垂下。阿僧祇半月。阿僧祇满月。阿僧祇缯带。以为严饰。阿僧祇师子幢网。阿僧祇摩尼网。阿僧祇妙金网。阿僧祇金线网。间错庄严。罗覆其上。阿僧祇宝铎。阿僧祇宝铃。风动流音。其声可爱。散阿僧祇天诸杂华。悬阿僧祇天宝鬘带。严阿僧祇众宝香炉。雨阿僧祇细妙金屑。悬阿僧祇宝镜。然阿僧祇宝灯。布阿僧祇宝衣。列阿僧祇宝帐。持阿僧祇宝竿。设阿僧祇宝座。阿僧祇宝缯。以敷座上。阿僧祇宝阎浮檀金童女像。阿僧祇杂宝诸形像。阿僧祇妙宝菩萨像。处处充遍。威德庄严。阿僧祇众鸟。出和雅音。令人爱乐。阿僧祇宝优钵罗华。阿僧祇宝波头摩华。阿僧祇宝拘物头华。阿僧祇宝芬陀利华。以为庄严。阿僧祇宝树次第行列。阿僧祇宝芭蕉树微妙庄严。阿僧祇宝经行路。金绳界道。阿僧祇宝池。香水盈满。阿僧祇宝桥飞梁云构。阿僧祇宝地。妙砌交映。阿僧祇摩尼宝。放大光明。阿僧祇众妙音声。赞大功德。有如是等无量阿僧祇诸庄严具。以为庄严。善财。又见楼阁之中。具有无量百千楼阁一一楼阁。种种庄严。悉如上说。广博严丽。皆同虚空。显现分明。犹如形影。互相映彻。无有障碍。不相杂乱。善财童子。于一处中。见一切处。一切诸处。亦如是见。如是一切。尽无有余。一一物中见皆如是

尔时善财童子。见毗卢遮那庄严藏楼阁之中。如是种种不可思议自在境界。生大爱敬。踊跃无量。身心柔软。欢喜润泽。离一切想。除一切障。灭一切惑。所见不忘。所闻能忆。所思不乱。入于无碍解脱法门。以无碍意。普运其心。一切供养。以无碍眼。普见一切微细境界。以无碍身。遍于一切恭敬作礼。以弥勒菩萨威神力故。自见其身。遍在一切诸楼阁中。具见种种不可思议自在境界。所谓或见弥勒菩萨初发无上菩提心时。如是名字。如是种族。如是善友之所开悟。令其种植如是善根。住如是寿。在如是劫。值如是佛。处于如是庄严刹土。修如是行。发如是愿。彼诸如来。如是众会。如是寿量经尔许时。亲近供养。悉皆明见。或见弥勒。最初证得慈心三昧。从是已来。号为慈氏。或见弥勒。修习一切难行妙行。成满一切诸波罗蜜。或见得忍。或见住地。或见庄严种种佛刹。或见受持一切佛教。为大法师。得无生忍。或见在于某时某处某如来所。受于无上菩提之记。或时见作转轮圣王。普令众生住十善道。或为护世。利乐众生。或为释天。诃责五欲。或为夜摩天王。为彼诸天。赞不放逸。或为兜率天王。称叹菩萨补处功德。或为化乐天王。为现菩萨变化庄严。或为他化自在天王。为说诸佛自在之法。或作魔王。说一切法皆悉无常。或为梵王。说诸禅定无量喜乐。或为阿修罗王。为其众会。说断一切憍慢醉傲。入大智海。了法如幻。或复见处阎魔罗海。放大光明。救地狱苦。或见在于饿鬼之处。施诸饮食。济彼饥渴。或见在于畜生之道。种种方便。调伏众生。或复见为护世天王众会说法。或复见为忉利天王众会说法。或复见为夜摩天王众会说法。或复见为兜率天王众会说法。或复见为化乐天王众会说法。或复见为他化自在天王众会说法。或复见为一切魔王众会说法。或复见为大梵天王众会说法。或复见为诸大龙王众会说法。或复见为夜叉罗刹王众会说法。或复见为乾闼婆紧那罗王众会说法。或复见为阿修罗陀那婆王众会说法。或复见为迦楼罗摩睺罗伽王众会说法。或复见为其余一切人非人等众会说法。或复见为一切声闻众会说法。或复见为一切独觉众会说法。或复见为初发心菩萨而演说法。或复见为修行回向乃至得忍住不退转诸菩萨众而演说法。或复见为一生所系已受灌顶诸菩萨众而演说法。或见赞说菩萨初地乃至十地所有一切最胜功德。或见赞说满足一切诸波罗蜜。或见赞说入诸忍门。或见赞说诸大三昧门。或见赞说甚深解脱门。或见赞说诸禅三昧神通境界。或见赞说诸菩萨行方便善巧。或见赞说种种出生诸大誓愿。或见与诸同行菩萨赞说世间资生工巧。于一切处。谈议种种最胜方便。调伏成熟一切众生。或见弥勒。与诸一生补处菩萨。赞说一切佛灌顶门。或见弥勒。修行精进。于百千年。身心无倦。或见弥勒。经行读诵。书写经卷。未尝休息。或见弥勒。种种方便。为众说法。或见弥勒。入诸禅定四无量心。或入遍处及诸解脱。或入三昧。以方便力。现诸神变。或见一切诸菩萨众。皆入种种变化三昧。各于其身一一毛孔。出于一切变化身云。或见出现天众身云。或见出现龙众身云。或见出现夜叉罗刹乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世转轮圣王身云。或见出现小王王子大臣官属长者居士身云。或见出现声闻独觉菩萨身云。或见出现一切如来威德身云。或见出现一切众生变化身云。或见出现一切妙音。赞诸菩萨种种法门。所谓。或见赞说发菩提心功德门。或见赞说施波罗蜜净戒安忍精进定慧方便愿力智波罗蜜功德门。或见赞说诸摄诸禅。诸无量心。及诸三昧三摩钵底。诸通诸明。总持辩才。诸谛诸智。止观解脱。诸缘诸依功德门。或见赞说念处正勤。神足根力。七菩提分。八圣道分。诸声闻乘。诸独觉乘。诸菩萨乘。诸地诸忍。诸行诸愿。如是一切。诸功德门。或复于中。见诸如来种种集会大众围绕。又亦见彼一切如来。生处种姓。身形寿命。刹劫名号。道场众会。说法利益。教住久近。种种不同。悉皆明见

尔时善财童子。又复于彼毗卢遮那庄严藏内诸楼阁中。见一楼阁高广殊丽。总摄诸阁。一切庄严。胜妙于前。最上无比。于中悉见三千大千世界。百亿四天下。百亿阎浮提。百亿兜率陀天。一一皆有弥勒菩萨。莲华藏中。降神诞生。释梵天王。捧持顶戴。游行七步。观察十方。大师子吼。现为童子。居处宫殿。游戏园苑。为一切智。踰城出家。现诸苦行。示受乳糜。往诣道场。降伏诸魔。成等正觉。观菩提树。梵王劝请。转正法轮。升天宫殿。而演说法。劫数寿量。众会庄严。所净佛刹。所修行愿。所现威德。所起方便。教化成熟一切众生。分布舍利。住持遗教。皆悉不同。尔时善财。自见其身。在彼一切诸如来所。承事供养。亦见于彼一切众会大道场中。所有佛事。忆持不忘。加持力故。通达无碍。精进勤求。安住智地。复闻一切诸楼阁内宝网铃铎。及诸乐器。皆悉演畅不可思议微妙法音。说种种法。所谓。或说菩萨发菩提心。或说修行波罗蜜行。或说诸愿。或说诸地。或说神通心自在行。或说恭敬供养如来。或说庄严诸佛刹土。或说诸佛说法差别。如上所说。一切佛法。悉闻其音。敷畅辨了。又闻某处某世界中。有某菩萨。闻某法门。某善知识之所劝导。发菩提心。令修妙行。于某劫某刹某如来所某众会中。闻某如来如是功德。发如是心。起如是愿。种于如是广大善根。经若干劫。修菩萨行。于尔许时。当得成佛。如是名号。如是寿量。如是国土。一切功德具足庄严。满如是愿。能以如是最胜方便。教化调伏如是众生。如是声闻菩萨众会。佛涅槃后。正法住世。经尔许劫。利益如是无量众生。或闻某处。某世界中。有某菩萨。广修布施波罗蜜行。难舍能舍。如是净戒。忍辱精进。禅定智慧。修习如是诸波罗蜜。或闻某处。某世界中。有某菩萨。为求法故。弃舍王位及诸珍宝妻子眷属头目手足一切身分。皆无所吝。或闻某处。某世界中。有某菩萨。守护如来所说正法。为大法师。广行法施。高建法幢。吹大法螺。击大法鼓。雨大法雨。造佛塔庙。作佛形像。种种庄严。一一殊丽。施诸众生一切乐具。或闻某处。某世界中。有某如来。于某劫中。成正等觉。如是国土。如是众会。如是寿量。说如是法。满如是愿。教化如是无量众生。现前觉悟无上菩提。善财童子。闻如是等不可思议微妙法音。身心欢喜。柔软悦泽。即得无量诸总持门。即得无量诸辩才门。诸禅诸忍。诸大行愿。诸波罗蜜。诸通诸明。及诸解脱。诸三昧门。又见一切诸宝镜中。出生无量种种形像。所谓。或见诸佛众会道场。或见菩萨众会道场。或见声闻众会道场。或见独觉众会道场。或见清净世界。或见不净世界。或见净不净世界。或见不净净世界。或见有佛世界。或见无佛世界。或见小世界。或见中世界。或见大世界。或见微细世界。或见广大世界。或见因陀罗网世界。或见覆世界。或见仰世界。或见侧世界。或见平坦世界。或见地狱畜生饿鬼所住世界。或见天人充满世界。于如是等诸世界中。见有无数大菩萨众。或行或坐。作诸事业。或见修禅。或习智慧。或起大悲。怜愍众生。或造诸论。利益世间。或教弟子。或自受持。或书或诵。或问或答。三时忏悔。回向发愿。又见一切诸宝柱中。放摩尼王大光明网。或青或黄。或赤或白。或玻璃色。或水精色。或帝青色。或虹霓色。或阎浮檀妙真金色。或作一切诸光明色。又复见彼阎浮檀金诸童女像。及众宝像。或执华云。或执衣云。或执幢幡。或执鬘盖。或持种种涂香末香。或持上妙摩尼宝网。或垂金锁。或挂璎珞。或举其臂。捧庄严具。或低其首。垂摩尼冠。曲躬瞻仰。目不暂舍。合掌而住。又见于彼真珠璎珞。常出香水。具八功德。流注无穷。琉璃璎珞。百千光明。同时照耀。幢幡网盖。如是等物一切皆以摩尼王藏。众宝庄严。令人乐见。又复见彼种种华池。优钵罗华。波头摩华。拘物头华。芬陀利华。各各生于无量诸华。或大一手。或长一肘。或复纵广量如车轮。一一华中。皆悉示现种种色像。以为严饰。所谓男色像。女色像。童男色像。童女色像。释梵护世。天龙夜叉。乾闼婆。阿修罗。迦楼罗。紧那罗。摩睺罗伽。声闻独觉。及诸菩萨。如是一切众妙色像。皆悉合掌。曲躬礼敬。亦见如来。结跏趺坐。三十二相庄严其身。又复见彼净琉璃地。一一步间。现不思议种种色像。所谓世界色像。菩萨色像如来色像。及诸楼阁庄严色像。又于宝树。枝叶华果。一一事中。悉见种种半身色像。所谓佛半身色像。菩萨半身色像。天龙。夜叉。乾闼婆。阿修罗。迦楼罗。紧那罗。摩睺罗伽。释梵护世。转轮圣王。小王王子。大臣官长。长者居士。童男童女。及以四众半身色像。其诸色像。或执华鬘。或执璎珞。或执一切诸庄严具。或有曲躬合掌礼敬。一心瞻仰目不暂舍。或有赞叹。或入三昧。其身悉以相好庄严。普放种种诸色光明。所谓。金色光明。银色光明。珊瑚色光明。兜沙罗金色光明。帝青色光明。毗卢遮那摩尼王宝色光明。一切众宝色光明。薝卜迦华光明。从于自身三十二相。出如是等一切光明。又见于彼一切楼阁半月像中。出阿僧祇日月星宿种种光明。普照十方。又见一切诸妙楼阁。种种宫殿。众宝垣墙。周回四壁。种种宝色。一一步内。一切众宝。以为庄严。一一宝中。皆现弥勒曩劫修行菩萨道时。或施头目。或施手足唇舌牙齿耳鼻血肉皮肤骨髓。乃至爪发。如是一切。悉皆能舍。妻妾男女。奴婢仆使。妓侍采女。一切眷属。城邑聚落。宫殿园林。或阎浮提。或四天下。种种富乐。尊贵自在。大小王位。或诸资具。随时饮食。上妙床敷。憩息之处。或妙宝器。或驷马车。随其所须。尽皆施与。处牢狱中。种种困厄。令得出离。身被系缚。临刑戮者。使其解脱。诸有疾病所婴缠者。为其救疗。惠以医药。令得除差。入邪径者。示其正道。或为船师。令度大海。使诸众生不失津济。或为马王。救诸众生。令离一切罗刹恶难。或为种种大智仙人。善说诸论。利益众生。或为轮王。劝修十善。或为医王。善疗众病。或孝顺父母。恭敬供养。或亲近善友。随顺听闻。或作声闻。或作独觉。或作菩萨。或作如来。教化调伏一切众生。或示种种最胜生处。成熟生处所有众生。或为法师。奉行如来所有言教。种种威仪。受持读诵。微细观察。如理思惟。立佛支提。作佛形像。一一珍饰。种种庄严。若自供养。若劝于他。涂香散华。灯油鬘盖。种种敷设。恭敬礼拜。如是等事。相续不绝。或见坐于师子之座。广演说法。劝诸众生。安住十善。一心归向佛法僧宝。受持五戒及八斋戒。出家听法。受持读诵。正念作意。如理修行。乃至见于弥勒菩萨。坐师子座。讲宣法要。开示一切诸佛菩提。又见弥勒。经百千亿那由他阿僧祇劫。修行诸度。一切色像。又见弥勒。曾所承事。诸善知识。悉以一切功德庄严。亦见自身。在彼一一善知识所。亲近供养。受行其教。乃至住于灌顶之地。时诸知识。皆以软语。告善财言。善来童子。汝今观此菩萨所有不思议事。莫生疲厌

尔时善财童子。得不忘失正念力故。得见十方清净眼故。得善观察无碍智故。得诸菩萨自在智故。得诸菩萨已入智地广大解故。于诸楼阁一一物中。悉见如是。及余无量不可思议自在境界诸庄严事。譬如有人。于睡梦中。见种种物。所谓一切城邑聚落。宫殿园苑。山林河池。衣服饮食。乃至一切资生之具。或见一切可爱歌赞鼓乐集会种种游戏。或见自身父母兄弟内外亲属。或见大海须弥山王。乃至一切诸天宫殿阎浮提等四天下事。或见其身形量广大百千由旬。房舍衣服种种功德。一切庄严。悉皆相称。谓于昼日。经无量时。不眠不寝。受诸安乐。悉皆具足一切自在。从睡觉已。乃知是梦。远离一切安乐等想。亦无时节长短之相。而能明记所见之事。一切随顺。曾无忘失。善财童子。亦复如是。以弥勒菩萨威神之力所加持故。知三界法皆如梦故。灭诸众生狭劣想故。得无障碍广大解故。住诸菩萨胜境界故。入不思议方便智故。能见如是诸大菩萨一切庄严自在境界。随顺解知。微细观察。譬如有人。将欲命终。见随其业所受报相。行恶业者。见于地狱畜生饿鬼所有一切众苦境界。或见狱卒手持兵仗。或嗔或骂。囚执将去。亦闻地狱一切众生所有号叫悲叹之声。或见灰河。或见镬汤。或见刀山。或见剑树。或见猛火焰炽洞然。或见扬波沸水腾注。种种逼迫。受诸苦恼。行善业者。即见一切诸天宫殿。无量天众。天诸采女。种种衣服。具足庄严。宫殿园林。华池河水。及诸宝山。宝劫波树。随意受用。尽皆妙好。身虽未死。而由业力。见如是事。善财童子。亦复如是。以菩萨业不思议力。得见一切庄严境界。譬如有人为鬼所持。见种种事色相眷属。随其所问悉皆能答。善财童子。亦复如是。菩萨智慧之所持故。见彼一切诸庄严事。若有问者。靡不能答。譬如有人为龙所持。自谓是龙。入于龙宫。见龙眷属。于少时间。自谓已经日月年载。善财童子。亦复如是。以住菩萨智慧想故。弥勒菩萨自在威力所加持故。于少时间。谓经无量百千万亿那由他劫。譬如梵宫。名一切众生胜庄严藏。于中悉见三千大千世界所有诸物差别影像。不相杂乱善财童子。亦复如是。于楼观中。普见一切庄严境界。种种差别。互相涉入。各各差别。不相杂乱。譬如比丘。入遍处定。若行若住。若坐若卧。随所入定。境界现前。善财童子。亦复如是。入于楼观一切庄严所见境界。甚深随顺。悉皆明了。譬如有人。于虚空中。见乾闼婆城。具足庄严。悉分别知。无有障碍。善财童子。亦复如是。见彼一切庄严境界。甚深随顺。明了无碍。譬如夜叉宫殿与人宫殿同在一处。而不相杂。亦无障碍。各随其业所见不同。譬如大海于中印现三千世界所有色像。譬如幻师善明幻法。以幻力故。现诸幻事。种种作业一切能成。善财童子亦复如是。以弥勒菩萨威神力故。及不思议幻智力故。得诸菩萨自在力故。见楼阁中一切庄严自在境界

大方广佛华严经卷第三十七大方广佛华严经卷第三十八

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时弥勒菩萨摩诃萨。入楼阁中。摄其神力。弹指出声。告善财言。善男子。起法性如是。此是菩萨知诸法智。因缘聚集显现之相。如是自性。悉不成就。如幻如梦。如影如像。尔时善财。闻弹指声。从三昧起。弥勒告言。善男子。汝见菩萨自在解脱威神力不。汝见菩萨一切助道等流力不。汝见菩萨愿智所现聚集力不。汝见菩萨种种庄严妙宫殿不。汝见菩萨种种行力所聚集不。汝见菩萨种种功德庄严刹不。汝见菩萨十地之中种种力不。汝见菩萨诸波罗蜜难思果不。汝见菩萨种种难思三昧力不。汝见如来种种最胜大愿力不。汝闻菩萨种种出生解脱门不。汝随顺解菩萨解脱不思议不。汝随顺受菩萨三昧能喜乐不。善财白言。唯然已见。是善知识加持力故。忆念力故。威德力故。圣者此解脱门。其名何等。弥勒告言。此解脱门。名入三世一切境界不忘念智庄严藏。善男子。一生菩萨。得如是等不可说不可说解脱门。善财白言。圣者此庄严事。何处去耶。弥勒告言。于来处去。曰从何处来。曰从诸菩萨智慧威力中来。依诸菩萨智慧威力而住。无有少分去来之处。无集无增。无成无立。不依于地。不依于空。远离一切。善男子。譬如龙王种种云雨。不从身出。不从心出。无有积集。建立增长。但以龙王心念力故。霈然洪霔。周遍天下。此是龙王难思境界。善男子。彼庄严事。亦复如是。不住于内。亦不住外。但由菩萨威德自在。汝善根力而非不见。善男子。譬如幻师作诸幻事。无所从来。亦无所去。无行无入。无隐无显。而以幻力。分明显现。彼庄严事。亦复如是。无所从来。亦无所去。无集无成。然以惯习不可思议幻智力故。及由过去大愿力故。如是显现。善财童子。白言大圣。从何处来。弥勒告言。善男子。一切菩萨。无来无去。如是而来。无行无住。如是而来。无处无定。不没不生。不住不迁。不动不起。无恋无著。无业无报。无起无灭。不断不常。如是而来

复次善男子。菩萨从大悲处来。愍念调伏诸众生故。从大慈处来。救护逼迫苦众生故。从净戒处来。随其所乐自在生故。从大愿处来。往昔愿力所加持故。从神通处来。于一切处随乐现故。从无动摇处来。不舍如来不动体故。从无取舍处来。不役身心使往来故。从智慧方便处来。随顺一切众生转故。从示现变化处来。犹如影像而化现故

复次善男子。汝向所问何处来者。善男子。我从生处摩罗提国房舍聚落而来于此。彼有长者。名瞿波洛迦。为化其人令入佛法。又为生处一切人众。随其根器。而为说法。亦为父母亲戚眷属婆罗门等。演说大乘。令其趣入。故住于彼。而从彼来。善财言。圣者何者是菩萨生处。弥勒答言。善男子。菩萨有十种生处。何等为十。所谓发菩提心。是菩萨生处。生菩萨家故。深心。是菩萨生处。生善知识家故。诸地。是菩萨生处。生波罗蜜家故。大愿。是菩萨生处。生妙行家故。大悲。是菩萨生处。生四摄家故。如理观察。是菩萨生处。生般若波罗蜜家故。大乘。是菩萨生处。生方便善巧家故。成熟众生。是菩萨生处。生成等正觉家故。智慧方便。是菩萨生处。生无生法忍家故。修行诸法。是菩萨生处。生三世一切如来家故。善男子。是为菩萨十种受生处

复次善男子。菩萨摩诃萨。以般若波罗蜜为母。方便善巧为父。檀那波罗蜜为乳母。尸罗波罗蜜为养母。忍辱波罗蜜为庄严具。精进波罗蜜为养育者。禅那波罗蜜为浣濯人。善知识为教授师。一切菩提分为伴侣。一切善法为亲属。一切菩萨为兄弟。菩提心为家。如理修行为家法。诸地善法为家处。得诸忍法为家族。大愿现前为家教。以清净智满足诸行为顺家法。劝发勤修不断大乘为绍家业。法水灌顶一生所系菩萨为王太子。成就广大真实菩提为净家族。善男子。菩萨如是超凡夫地。入菩萨位。生如来家。住佛种性。能修诸行。不断三宝。善能守护菩萨种族。净菩萨种生处尊胜。于诸世间。离生过恶。一切天人及诸魔梵。沙门婆罗门中。种族具足。而得成就最胜佛种。得大愿藏。普能出生诸菩萨行。善男子。菩萨摩诃萨。成就如是尊胜家已。智了诸法如影像故。于世生处。无所恶贱。知一切法如变化故。于诸有趣。无所染着。觉悟诸法无有我故。调伏众生。心无疲厌。以大慈悲。为体性故。不趣寂灭摄受众生。了达生死犹如梦故。经一切劫而无热恼。了知五蕴皆如幻故。现处生死而无疲倦。知诸界处即法界故。于诸境界无有疮疣。知一切想如阳焰故。入于诸趣不生倒惑。达一切法皆如幻故。入魔境界自在无染。成就法身净妙体故。一切烦恼不能欺诳。成就一切遍趣行故。于诸生处而得自在

善男子。我身普生一切法界等。一切众生差别色相等。一切众生殊异言音等。一切众生种种名号等。一切众生种种乐欲等。一切众生种种威仪随顺世间教化调伏等。能显示一切众生清净受生等。随顺入一切众生甚深胜解等。一切菩萨大愿变化于如是等。无量品类。而现其身。种种相貌。种种威德。充满法界。善男子。我为成熟与我往昔同修诸行今时退失菩提心者。示现生此阎浮提中。为欲调伏父母亲属。及婆罗门。令其离于种族憍慢。得生如来种性中故。生摩罗提国房舍聚落婆罗门家善男子。我于南方。及住于此毗卢遮那庄严藏大楼阁中。随诸众生心之所乐。种种方便。教化调伏。善男子。我为随顺诸众生故。为欲成熟兜率天中同行大故。为欲示现菩萨福智庄严变化超过一切诸欲界故。令舍渴爱诸欲乐故。令照诸行皆无常故。令知诸天盛必衰故。为欲示现降生瑞相。与一生菩萨。而共宣说大智法门故。为欲摄受一切生处诸众生故。为欲教化释迦如来所遣来者。令如莲华悉开悟故。而于此没。生兜率天。善男子。我愿满足。得菩提时。汝及文殊俱来见我。善男子。汝当往诣文殊师利大菩萨所。而问之言。菩萨云何学菩萨行。云何深入普贤行门。云何出生。云何成熟。云何广大。云何清净。云何随顺。云何圆满。善男子。彼当为汝分别显示。何以故。善男子。文殊师利。最胜大愿。非余无量百千亿那由他菩萨之所能有。善男子。文殊师利。其行广大。无量无边。其愿无际。相续不断。常能出生一切菩萨最胜功德。文殊师利菩萨。常为无量百千亿那由他诸佛母。令其证入甚深理故。常为无量百千亿那由他菩萨师。令其勤修深证入故。普于十方。常转法轮。教化成熟一切众生。常于十方一切世界。为说法师。常为不可说不可说一切诸佛大众会中之所赞叹。住甚深智。见法实性。从久远来。深入一切解脱境界。究竟普贤所行诸行。善男子。文殊师利善知识。能令汝得生如来家。能增长汝诸善根。能发起汝助道法。能显示汝真实善知识。能劝发汝修习诸功德。能令汝深入大愿网。能令汝安住大愿门。能令汝闻菩萨深密义。能显示汝菩萨难思行。与汝往昔同生同行。是故。善男子。汝当往诣文殊师利菩萨所。莫生疲倦。文殊师利。当令汝得一切功德。何以故。汝先所见诸善知识。闻诸菩萨行。深入解脱门。满足大愿海。皆是文殊威神之力。文殊师利。于一切处咸得究竟。时善财童子。右绕弥勒。经无量匝。顶礼双足。殷勤瞻仰。心怀恋慕。辞退而去

尔时善财童子。经游一百一十城已。诣苏摩那城。住立门所。思惟文殊师利。随顺忆念。普遍观察。希欲奉觐。尔时文殊师利童子。从一百一十由旬外。遥申右手。至苏摩那城。摩善财顶。作如是言。善哉善哉。善男子。若离信根。心生疲厌。心志下劣。功行不具。退失精勤。于少善根。而生知足。不善发起一切行愿。不能亲近诸善知识。由如是故。不能了知如是法性。如是理趣。如是法门。如是境界。如是住处。若普遍知。若少分知。若甚深知。若尽源底。若观察。若证入。若获得。皆悉不能。是时文殊师利。宣说此法示教利喜。令善财童子具足圆满无数法门。具足无边大智光明。深入种种念佛门。无边际陀罗尼门。无边际辩才门。无边际三昧门。无边际神通门。无边际愿智门。深入普贤诸行愿轮。称叹文殊本住国土一切善巧。时善财童子。白文殊师利菩萨言。圣者。云何而得成就圣者国土善巧。文殊师利。告善财言。善男子。菩萨有十种法。具足圆满。得我国土善巧成就。善财白言。何等为十。文殊师利菩萨言。善男子。一者证无生法具足圆满。二者无灭法。三者不失坏法。四者无来去法。五者超言辞境界法。六者无有言辞道法。七者无戏论法。八者不可说法。九者寂静法。十者圣者法。若诸菩萨。于此十法具足圆满。得我国土善巧成就。善财童子。白言圣者。所言国土。是何义耶。文殊师利言。是一切菩萨住处义。善财言。云何是一切菩萨住处。文殊师利言。善男子。最胜第一义。是菩萨住处。何以故。善男子。最胜第一义。不生不灭。不失不坏。不来不去。如此语言。既非言境。言说不及。不能记别。非是戏论。思度所知。本无言说。体性寂静。唯诸圣者。自内所证。善男子。因此最胜第一义故。诸佛如来出现世间。若佛出世。及不出世。不可失坏。善男子。一切菩萨。为欲证入第一义故。舍大豪富年少王位。难行能行。种种苦行。剃除须发。被服法衣。正信出家。专求妙道。精勤匪懈。如救头然。善男子。若无第一义者。所修梵行。为何所用。如来出世。为何所依。善男子。以深信有第一义故。令诸菩萨具足圆满此十种法。是故应当如是知见。如是解说。于我国土善巧成就。善财童子。白言圣者。行何等法。当得圣者净妙国土。文殊师利言。若诸菩萨。能于一切心无憍慢。于诸众生生平等心。于诸如来修真供养。得我国土。善财童子。白言圣者。云何名为无憍慢心。生平等心。修真供养。文殊师利言。善男子。菩萨有十种法。审谛思惟。具足圆满。则能成就无憍慢心。何等为十。一者一心思惟。谛观身界。作是念言。我今出家。无殊死人。所以者何。父母亲爱。朋友眷属。一切所有。皆弃舍故。如是思惟。得无憍慢。二者思惟我今此身。服坏色衣。进止威仪。不同世间。如是思惟。得无憍慢。三者思惟既毁形好。执持应器。乞丐于他。如是思惟。得无憍慢。四者思惟我今乞食。如旃陀罗。如是思惟。令心卑下。得无憍慢。五者思惟为求段食。长养我身。我之寿命。宛在他手。如是思惟。得无憍慢。六者思惟所乞之食。人畜之余。彼若嫌弃。我方得食。如是思惟。得无憍慢。七者思惟我今应当于师长所。恭敬供养。令生欢喜。如是思惟。得无憍慢。八者思惟我今欲令同梵行者。生欢喜故。具足威仪。无违法式。如是思惟。得无憍慢。九者思惟我今出家。于佛法中。未得少分。如是思惟。得无憍慢。十者思惟一切众生。于我嗔恨。我常安忍。如是思惟。得无憍慢。善男子。是为菩萨思惟十法具足圆满。则能成就无憍慢心。复次善男子。菩萨有十种法具足圆满。则于众生。得平等心。何等为十。一者于诸众生。所作平等。二者于诸众生。心无障碍。三者于诸众生。心无疲倦。四者为欲利益诸众生故。具足修行六波罗蜜。五者为诸众生。集一切智。亦不依止无二之相。六者普观众生。同于如如。无所分别。七者了达众生体性平等。而能证入平等心性。八者愿与众生。同得出离生死大火。九者自既出已。复能拔出一切众生。十者平等安置一切众生。无忧恼处。善男子。譬如世间长者居士。生育五子。平等爱念。受用资具。等无有二。而彼诸子。愚小无知。于一切处。未能分别。时彼长者。宅舍之中。欻然火起。彼诸子等。各居一处。善男子。于意云何。时彼长者。出诸子心有先后不。善财答言。彼长者心等无先后。随所亲近。即先济拔文殊师利言。善男子。菩萨摩诃萨。亦复如是。一切众生。在于生死舍宅之中。三毒炽火。忽然而起。其心愚闇。无所分别。各随业力。五趣受生。菩萨等心。调伏成熟。但随亲近。即先拔济。成熟安置寂静界中。善男子。是为菩萨有十种法具足圆满。于诸众生成就平等

复次善男子。菩萨有十种法具足圆满。则得成就修真供养一切如来。何等为十。一者以法供养。二者修行诸行。三者平等利乐一切众生。四者以慈悲心随顺摄取。五者以如来力随顺一切。六者不舍劝修一切善法。七者不舍一切菩萨事业。八者如说能行如行能说。九者长时遍修心无疲厌。十者常不舍离大菩提心。若诸菩萨。具此十法。则能成就供养如来。非以财宝饮食衣服。名真供养。何以故。如来恭敬尊重法故。犹如孝子尊重父母。承顺颜色。心无暂舍。若复有人。敬其父母。其子倍复尊重是人。诸佛如来。亦复如是。若诸众生。供养法者。是真成就供养如来。以诸如来尊重法故。善男子。如来从修行中来。若能修行。是则成就供养如来。诸佛出世。本为利乐诸众生故。为以慈悲摄众生故。随顺利乐而为力故。善男子。若不劝修一切善法。亦不利乐一切众生。若舍菩萨所修事业。是亦不能利乐众生。若复不能如说修行如行能说。是亦不能利乐众生。若心下劣。而生疲厌。是亦不能利乐众生。若暂舍离菩提心者。是亦不能利乐众生。何以故。善男子。夫为菩萨。为欲利乐诸众生故。勤求阿耨多罗三藐三菩提。若无众生。一切菩萨不成正觉。善男子。汝应如是解法供养。则得成就供养如来。非以世间财宝饮食。名为供养。善男子。是为菩萨具足十法。则能成就供养如来。尔时文殊师利。显示如是无量无边微妙法义。劝教善财。令修习已。还摄神力。忽然不现

尔时善财童子。即见三千大千世界极微尘数诸善知识。悉皆亲近。承事供养。令生欢喜。于所诱诲。随顺受行。增长趣求一切智意。于佛境界。生决定解。大悲心海。容纳出生。大慈教云。普覆一切。于毗卢遮那广大身云。增长爱敬。于诸菩萨无碍解脱。心常安住。速疾出生如来普门。无著净眼观一切佛。修行圆满功德大海。深信如来积行所修一切智体。精勤速疾增一切智助道之法。善能回向一切菩萨清净深心。善知三世一切如来。相续不断。深入一切佛法教海。随顺解了诸佛法轮。于诸世间如影普现。深入一切菩萨愿海。尽一切劫。修菩萨行。得普门智。照如来境增长一切菩萨诸根。得一切智清净光明。普照十方一切法界。于一切刹教化众生。发修行心成就利益。能随顺解生死种类。摧烦恼业一切障山。随顺证悟无障碍法。入法界藏平等地中。常住寂静菩萨解脱。勤求一切如来境界。一切诸佛威力加持。善财童子。起如是等微细观察。安住普贤甚深境界。即闻普贤菩萨名号。及普贤行最胜大愿。从初发心。最胜助道。最胜现前。出生功德。微细威仪。及闻普贤菩萨诸地。及地处所。地差别得。地自在行。地差别住。地勇猛。地威德。地同住。既闻此已。渴仰欲见普贤菩萨。即于金刚海藏菩提道场如来师子座前。一切宝莲华藏座上。起等虚空界广大心。拔一切现前执着心。集一切德无染心。净一切刹无想心。了一切法欢喜心。观一切境无碍心。入一切方周遍心。行一切行无障心。净一切智境界妙行自在心。观一切菩萨道场庄严清净明了心。深入一切如来法海广大心。调伏成熟一切众生周遍心。净一切佛刹无量心。了一切众会如影心。住一切劫无尽心。究竟如来力无所畏不共佛法无退转心

善财童子。起如是心。以自善根所润泽故。一切如来加被力故。普贤同分善根力故。欲见普贤。有十种瑞相。何等为十。一者见一切佛刹清净。一切如来道场庄严。二者见一切佛刹清净。无诸恶道一切杂类。三者见一切佛刹清净。众妙莲华以为庄严。四者见一切佛刹清净。一切众生身心清凉。五者见一切佛刹清净。众宝为体形色庄严。六者见一切佛刹清净。一切众生种种形色相好严身。七者见一切佛刹清净。诸庄严云普覆其上。八者见一切佛刹清净。一切众生互起慈心。递相利益。九者见一切佛刹清净。菩提道场形体庄严。十者见一切佛刹清净。一切众生心常随顺忆念诸佛。是为十。又见十种大光明相。何等为十。一者见一切世界所有极微。一一尘中。出一切世界极微尘数如来光网云。周遍照耀。二者见一一尘中。出一切世界极微尘数如来圆光轮云。无量无数种种色相周遍法界。三者见一一尘中。出一切世界极微尘数种种如来宝影像云。周遍法界。四者见一一尘中。出一切世界极微尘数种种如来光焰轮云。周遍法界。五者见一一尘中。出一切世界极微尘数种种妙香涂香烧香华鬘等云。周遍十方一切法界。出大音声。称赞普贤一切行愿大功德海。六者见一一尘中。出一切世界极微尘数种种日月星宿光明云。皆放普贤菩萨光明。遍满法界。七者见一一尘中。出一切世界极微尘数种种众生形像灯云。犹如佛光遍照法界。八者见一一尘中。出一切世界极微尘数种种如来身影像摩尼宝云。周遍法界。九者见一一尘中。出一切世界极微尘数种种如来影像光明身云。如大云雨。普说一切如来大愿。及威德力。十者见一一尘中。出一切世界极微尘数种种菩萨圆满光明影像身云。随诸众生种种变化。普令一切皆生爱乐。如是所作。周遍法界。是为十。尔时善财童子。见此十种光明相已。即作是念。我今必见普贤菩萨。于时善财。住自善根普光照力。住诸如来所护念力。能生佛法普智光明。于普贤行现前照了。于普贤愿深入无际。于一切如来境界。深心信解。于诸菩萨广大境界。得决定力。修集得见普贤之想。深入如来一切种智。普摄诸根令其寂静。起大精进。无有退转。身心普现十方世界。即以普眼。观察十方一切诸佛菩萨众会诸庄严具一切境界。皆作得见普贤之想。以智慧眼。观察普贤从初发心所行之道。其心广大。犹如虚空。大悲坚固。犹若金刚。威德加持。尽未来际。愿不舍离。普贤菩萨。以平等心。行普贤行。念念随顺。清净自在。常得安住如来境界。成就普贤种种智地

善财童子。具足圆满如是观已。即见普贤菩萨。在于毗卢遮那如来应正等觉前。坐莲华藏师子之座。诸菩萨众所共围绕。身相殊特。世无与等。智慧功德。种种境界。不可思议。一切菩萨。微细观察。无有边际。与诸如来平等无二。善财童子。见普贤身。一一毛孔。念念中出一切世界极微尘数种种光明云。遍法界虚空界一切世界。普光照耀。除灭一切众生苦患。见一一毛孔。念念中出一切佛刹极微尘数种种色圆光云。令一切菩萨速疾增长广大欢喜。见普贤菩萨顶及两肩。一一毛孔。念念中出一切佛刹极微尘数种种色香焰云。遍法界虚空界。一切诸佛众会道场。雨大香雨而以普熏。见一一毛孔。念念中出一切佛刹极微尘数种种华云。遍法界虚空界。一切如来众会道场。雨众妙华。见一一毛孔。念念中出一切佛刹极微尘数种种庄严香树云。遍法界虚空界。一切如来众会道场。雨于无尽涂香末香众妙香藏。见一一毛孔。念念中出一切佛刹极微尘数种种衣服云遍法界。虚空界。雨众妙衣。普覆庄严。见一一毛孔。念念中出一切佛刹极微尘数种种缯彩云。种种杂宝璎珞云。种种如意宝云。遍法界虚空界。一切如来众会道场。普雨一切璎珞缯彩。令一切众生成就爱乐。见一一毛孔。念念中出一切佛刹极微尘数种种宝树云。遍法界虚空界。复从一切宝树藏中。流散一切星宿光云。种种庄严。于一切如来众会道场。雨诸妙宝。见一一毛孔。念念中出一切佛刹极微尘数种种色界天众身云。遍法界。虚空界。叹菩提心。见一一毛孔。念念中出一切佛刹极微尘数种种梵天眷属身云。请诸如来。转妙法轮。见一一毛孔。念念中出一切佛刹极微尘数欲界天众身云。守护受持一切如来所说妙法。见一一毛孔。念念中出一切佛刹极微尘数三世一切诸佛刹云。遍法界虚空界。与诸众生无依止者。而作依止。无覆护者。而作覆护。无归趣者。而作归趣。见一一毛孔。念念中出一切佛刹极微尘数清净佛刹云。遍法界虚空界。一切诸佛于中出现。菩萨众会清净道场。令一切众生。爱敬信乐。皆得清净。见一一毛孔。念念中出一切佛刹极微尘数净不净佛刹云。遍法界虚空界。令杂染众生皆得清净。见一一毛孔。念念中出一切佛刹极微尘数不净净佛刹云。遍法界。虚空界。令纯染众生皆得清净。见一一毛孔。念念中出一切佛刹极微尘数众生身云。遍法界虚空界。随应教化一切众生。令于阿耨多罗三藐三菩提。而得成熟。见一一毛孔。念念中出一切佛刹极微尘数种种菩萨身云。遍法界虚空界。称扬种种诸佛名号。令诸众生增长善根。见一一毛孔。念念中出一切佛刹极微尘数种种菩萨身云。遍法界虚空界。宣扬显示诸佛菩萨。从初发意。严净佛刹。所生善根。见一一毛孔。念念中出一切佛刹极微尘数种种菩萨身云。遍法界虚空界。一切佛刹一一刹中。为欲清净普贤妙行。宣扬一切菩萨愿海。见一一毛孔。念念中出一切佛刹极微尘数普贤菩萨行云。令一切众生爱乐修习。速得圆满一切智体。见一一毛孔。念念中出一切佛刹极微尘数正觉身云。于一切佛刹。现成正觉。显示种智。令诸菩萨普集大法。速疾增长。现前觉悟

大方广佛华严经卷第三十八大方广佛华严经卷第三十九

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时善财童子。见普贤菩萨。如是自在神通境界。欢喜踊跃。普遍身心。重复观察。见普贤菩萨。一一身分。一一肢节。一一毛孔。悉有三千大千世界。其中一切地水火风。大海四洲。须弥铁围。及众宝山。国土城邑。宫殿园苑。乃至地狱。饿鬼畜生。阎罗王界。天龙八部。人与非人。欲界色界。无色界处。所有形色。日月星宿。风云雷电。昼夜月时。及以年劫。诸佛出世。菩萨众会。道场庄严。如是等事。悉皆明见。如见此世界。尽于东方种种世界。亦复如是。如东方。南西北方四维上下。亦复如是。如见现在十方世界。尽过去际。尽未来际。种种世界。相续不断。亦如是见。各各差别。互相涉入。不相杂乱。如于此毗卢遮那如来宝莲华藏师子座上。显示如是游戏神通。于东方莲华吉祥世界贤吉祥如来所。显示一切游戏神通。亦复如是。如贤吉祥如来所。如是尽于东方。南西北方四维上下一切世界。亦复如是。如是十方一切佛刹一一尘中。皆有法界诸佛众会。一一佛所。皆有普贤。坐宝莲华师子之座。显示一切游戏神通。悉亦如是。又于彼一一普贤身中。皆见三世一切境界。犹如明镜现其影像。所谓一切佛刹。一切资具。一切众生。一切佛出兴。一切菩萨道场众会。又闻一切众生种种音声。一切佛声。一切如来转法轮声。一切如来游戏神通声。一切菩萨善诱诲声。一切菩萨神通境界。菩萨智通。菩萨普集。菩萨说法。菩萨游戏。如是等声

尔时善财童子。见闻普贤菩萨如是无量不可思议游戏神通。即得十种智波罗蜜。何等为十。一者于念念中。令身遍满一切佛刹智波罗蜜。二者于念念中。悉能往诣一切佛所智波罗蜜。三者于念念中。悉能供养一切如来智波罗蜜。四者于念念中。普于一切诸如来所闻法受持智波罗蜜。五者于念念中。微细观察一切如来所有法轮智波罗蜜。六者于念念中。知一切佛不可思议大神通事智波罗蜜。七者于念念中。说一句法。尽未来际辩才无尽智波罗蜜。八者于念念中。智海现前观一切法智波罗蜜。九者于念念中。得一切法界教海智波罗蜜。十者于念念中。得知一切众生离众生想智波罗蜜。十一于念念中。普贤慧行皆现在前智波罗蜜。善财童子。既得是已。普贤菩萨。即伸右手。摩善财顶。善财即得深入一切佛刹极微尘数诸大三昧。各以一切佛刹极微尘数三昧。而为眷属。一一三昧。悉得一切昔所未见。昔所未闻。一切佛刹极微尘数种种世界海。诸佛大会。增长一切佛刹极微尘数一切智助道具。出现一切佛刹极微尘数一切智法门。成就一切佛刹极微尘数。初发一切智心。深入一切佛刹极微尘数一切智大愿海。出生一切佛刹极微尘数一切智出要道。修习一切佛刹极微尘数一切智菩萨行。圆满一切佛刹极微尘数一切智速疾力。得一切佛刹极微尘数一切智普光照。如此娑婆世界毗卢遮那佛所普贤菩萨。摩善财顶。所获法门。如是十方所有世界。及彼世界一一尘中。一切世界。一切佛所。普贤菩萨。悉亦如是。摩善财顶。所得法门。亦皆同等

尔时普贤菩萨摩诃萨。告善财言。善男子。汝见我此神通力不。善财白言。圣者。唯然已见。此不思议大神通事。得佛智慧。方能知之。普贤菩萨。告善财言。善男子。我于不可说不可说劫。行菩萨行。求一切智。一一劫中。为欲清净菩提心故。承事不可说不可说如来。一一劫中。为集一切智福德具故。设不可说不可说佛刹极微尘数广大施会。一切世间最胜无比。悉皆回向一切众生。一一劫中。为求一切智法故。以不可说不可说佛刹极微尘数财物。而为大舍。一一劫中。为求佛智故。以不可说不可说佛刹极微尘数国土王位。村营城邑。聚落宫殿。妻子眷属。身分肢节。眼耳鼻舌。乃至身命。而为布施。一一劫中。为求一切智首故。以不可说不可说佛刹极微尘数头。而为布施。一一劫中。为求一切智故。于不可说不可说佛刹极微尘数诸如来所。恭敬尊重。承事供养。上妙衣服卧具医药。一切所须悉皆奉施。于其法中。出家学道。受持法教。随顺修行善男子。我于尔所大劫海中。自忆未曾于一念间不顺佛教。尔所劫中。未曾一念生嗔害心。我我所心。自他差别心。未曾一念离菩提心。于生死中。起疲厌心。生下劣心。怀懒惰心。有障碍心。起迷惑心。唯住无上不可沮坏一切智性大菩提心。善男子。我普严净一切佛土。我以大悲。救护众生。教化成熟。令其清净。我供养承事一切诸佛诸善知识。于彼诸佛善知识所。为求正法。弘宣护持。一切内外。悉皆能舍。乃至身命。亦无所吝。如是无量相应圆满所行之行。一切劫海。说其因缘。劫海可尽。此不可尽。善男子。我法海中。无有一文一句。非是舍施转轮王位。而求得者。非是悉舍一切所有而求得者。善男子。我所求法。皆为救护一切众生。念念相续。微细观察。令最胜法速得现前。愿以智光照明。开示一切世间。愿为显示出世间智。愿令众生悉得安乐。愿普称赞一切如来所有功德。我如是等往昔圆满相应行门。于不可说不可说佛刹极微尘数劫海。说不可尽。是故善男子。我以如是积集助道法力。增长诸善根力。广大极深信力。修行诸功德力。如实观察一切法力。成就一切智慧眼力。为诸如来所加持力。种种大愿所引起力。无边大悲不可动力。悉能清净妙智通力。种种善友所摄受力。由此等故。得此究竟三世平等清净法身。及得无上清净色身。超诸世间。而随众生种种心乐。普为现形。入一切刹。遍一切处。普能随顺。示现神通。令诸众生靡不欣乐。善男子。汝见我此圆满广大威德身不。汝应微细思惟观察。善男子。我此妙身。无边劫海之所成就。无量百千亿那由他劫。难得出现。难得睹见。善男子。若有众生。未种善根。及少善根。犹尚不得闻我名字。况见我身。善男子。若有众生得闻我名。皆于阿耨多罗三藐三菩提。得不退转。若见若念。若迎若送。若暂随逐。乃至梦中。皆亦如是。或有众生。一日一夜忆念于我。随顺修行。而得成熟。或七日七夜。半月一月。半年一年。百年千年。一劫百劫。乃至不可说不可说佛刹极微尘数劫。忆念于我。而成熟者。或一生。或百生。乃至不可说不可说佛刹极微尘数生。忆念于我。而成熟者。或见我圆光。或见放光。或见色身。或见神通震动佛刹。或生恐怖。或生欢喜。皆得成熟。善男子。我以如是等佛刹极微尘数诸方便门。令诸众生。于阿耨多罗三藐三菩提。得不退转。复次善男子。若有众生。见闻于我清净刹者。必得生我清净刹中。若有众生。见闻于我清净身者。必得生我清净身中。善男子。汝应观我此大威德清净之身

尔时善财童子。微细观察普贤之身。见一一毛孔中。有不可说不可说诸佛刹海。一一刹海。皆有诸佛。出兴于世。遍满其中。大菩萨众海会围绕。彼诸刹海。种种建立。种种形状。种种庄严。种种大山。周匝围绕。种种色云。弥覆其上。种种佛出兴。种种演说法。如是等事。各各不同。如一毛孔。一切毛孔中。一一相中。一一好中。一一肢节中。皆亦如是。又见普贤菩萨。于一一世界海中。出一切佛刹极微尘数佛变化身云。周遍十方一切世界。教化众生。令于阿耨多罗三藐三菩提。而得成熟。时善财童子。随顺普贤善诱诲故。入普贤身及毛孔内。十方一切诸世界中。教化众生。复次善财童子。所见佛刹极微尘数诸善知识。往诣亲近。承事供养。积集增长一切善根。智慧光明。比此暂见普贤菩萨所得善根。百分不及一。千分不及一。百千分不及一。百千亿分。数分。算分。谕分。优波尼沙陀分。亦不及一。善财童子。从初发心。乃至得见普贤菩萨。于其中间。所入刹海。相续不断。今于普贤菩萨一毛孔中。一念所入诸佛刹海。相续不断。过前不可说不可说倍。如一毛孔。一切毛孔。悉亦如是。善财童子。于普贤菩萨毛孔刹中。行一步过不可说不可说佛刹极微尘数世界。如是而行。尽未来际劫。犹不能知一毛孔中种种刹海相续。刹海藏。刹海差别。刹海出生门。刹海成。刹海坏。刹海庄严。所有边际亦不能知。佛海出现相续。佛海出现藏。佛海差别。佛海出生门。佛海生。佛海灭。所有边际亦不能知。菩萨众会道场海相续。菩萨众海藏。菩萨众海差别。菩萨众海出生门。菩萨众海集。菩萨众海散。所有边际亦不能知。入众生界。知众生根。教化调伏诸众生界。觉悟成熟诸众生智。菩萨所住。自在神通。菩萨所入诸地诸道。如是等海。皆悉不知究竟边际。善财童子。于普贤毛孔刹中。或有刹中一日而行。或有刹中一年而行。乃至不可说不可说佛刹极微尘数劫。如是而行。不动不出。念念周遍无边刹海。教化调伏一切众生。令向阿耨多罗三藐三菩提。当是之时。善财童子。则次第得普贤菩萨诸行愿海。皆悉平等。与普贤等。与诸佛等。一身充满一切世界等。诸行圆满等。正觉现前等。神通大用等。种种法轮等。清净辩才等。出生言辞等。种种音声等。诸力无畏等。种种佛住等。大慈大悲等。如是乃至不可思议解脱自在。悉皆同等。尔时普贤菩萨摩诃萨。观察一切菩萨众会。及善财童子。而说偈言

  汝等应离诸疑垢　　一心不乱而谛听
  我说如来满诸度　　一切解脱真实道
  出世调柔胜丈夫　　其心清净如虚空
  常放智日大光明　　普照世间除惑暗
  如来难可得见闻　　无量亿劫今乃遇
  如优昙华时一现　　是故应听佛功德
  随顺世间诸所作　　譬如幻士现众业
  但为悦可众生心　　未曾一念生分别

尔时一切菩萨。闻此说已。一心渴仰。发大誓愿。欲闻如来真实义谛所有功德。咸作是念。普贤菩萨诸行已圆。体性清净。如说能行。如行而说。一切如来共所称赞。作是念已。深生渴仰。尔时普贤菩萨。圆满种种功德智慧。庄严身心。犹如莲华。不着三界一切尘垢。告诸菩萨言。汝等皆当一心谛听。我今欲说佛功德海一滴之相。即说偈言

  佛智广大同虚空　　普遍一切众生心
  了世妄想皆非有　　不起种种异分别
  一念悉知三世法　　亦了一切众生根
  譬如善巧大幻师　　念念示现无边量
  随诸众生心行异　　往昔诸业愿乐力
  令其所见各不同　　而佛寂然无动念
  或有处处见佛坐　　充满十方诸世界
  或有其心不清净　　无量劫中不见佛
  或有信解心无我　　一念发意见如来
  或有谄诳不净心　　亿劫专求莫能遇
  或一切处闻佛音　　其音美妙令心悦
  或有百千万亿劫　　心不净故不得闻
  或见清净大菩萨　　充满三千大千界
  皆已具足普贤行　　如来于中俨然坐
  或见此界妙无比　　佛无量劫所严净
  毗卢遮那最胜尊　　于中觉悟成菩提
  或见莲华胜妙刹　　贤首如来住在中
  无量菩萨众围绕　　皆悉勤修普贤行
  或有见佛无量寿　　观自在等共围绕
  悉已住于灌顶地　　遍满十方无量土
  或有见此三千界　　犹如妙喜具庄严
  阿閦如来住在中　　及如香象诸菩萨
  或见月觉大名称　　金刚幢等菩萨俱
  住如圆镜妙庄严　　普遍十方清净刹
  或见日藏世所尊　　住普光明清净土
  与得灌顶诸菩萨　　充满十方而说法
  或见金刚大焰佛　　与智幢等菩萨俱
  周行一切广大刹　　说法除灭众生闇
  一一毛端不可说　　诸佛具相三十二
  菩萨众会共围绕　　种种说法度众生
  或见一一佛毛孔　　具足庄严广大刹
  无量诸佛住其中　　清净佛子皆充满
  或见十方平等刹　　而全在一极微中
  无量菩萨悉充满　　不可说劫修诸行
  或有见一毛端处　　无量极微尘刹海
  种种业起各差别　　毗卢遮那转法轮
  或有世界不清净　　或清净刹众宝成
  如来住寿无量时　　乃至涅槃诸所现
  普尽十方诸世界　　种种示现不思议
  随诸众生心智殊　　靡不化度令清净
  如是无上大调御　　充满十方国土中
  示现种种神通力　　我说少分汝当听
  或见释迦成佛道　　已经不可思议劫
  或见今始为菩萨　　十方利益诸群生
  或有见此释师子　　供养诸佛修行道
  或见人中最胜尊　　显示种种神通事
  或见布施或持戒　　或忍或进或诸禅
  般若方便愿力智　　随众生心皆示现
  或见究竟波罗蜜　　或见安住于诸地
  总持三昧神通智　　如是悉现尽无余
  或现修行无量劫　　住于菩萨堪忍位
  或见住于不退地　　或现法水灌其顶
  或现梵释护世身　　或现刹利婆罗门
  种种色相所庄严　　犹如幻师现众像
  或现兜率始降神　　或见宫中受嫔御
  或见弃舍诸荣乐　　出离王宫行学道
  或见始生或见灭　　或示出家学异行
  或见坐于菩提树　　摧伏魔军成正觉
  或有见佛始涅槃　　或见起塔遍世间
  或见塔中立影像　　或随众生现身色
  或见如来无量寿　　与诸菩萨授尊记
  而成真实大导师　　次补住于安乐刹
  或见无量亿千劫　　作佛事已入涅槃
  或见今始成菩提　　或见正修诸妙行
  或见如来清净月　　在于梵世及魔宫
  自在天宫化乐宫　　示现种种诸神变
  或见在于兜率宫　　无量诸天共围绕
  为彼说法令欢喜　　一切净心供养佛
  或见住在夜摩天　　忉利护世龙神处
  如是一切诸宫殿　　莫不于中现其像
  或于然灯世尊所　　散华布发为供养
  从是了知深妙法　　恒以此道化群生
  或见久远已涅槃　　或见初始成菩提
  或见住于无量劫　　或见须臾即灭度
  身相光明与寿命　　智慧菩提及涅槃
  众会所化威仪声　　如是一一皆无量
  或现其身极广大　　譬如须弥大宝山
  或见跏趺不动摇　　充满无边诸世界
  或见圆光一寻量　　或见千万亿由旬
  或照无量国土中　　或见充满一切刹
  或见佛寿八十年　　或寿百千万亿岁
  或住不可思议劫　　如是展转倍过是
  佛智通达净无碍　　刹那普了三世法
  皆从心识因缘现　　生灭无常无自性
  于一刹中成正觉　　一切刹处悉亦然
  一切入一一亦尔　　随众生心而示现
  如来安住无上道　　成就十力四无畏
  圆满智慧无障碍　　转于十二行法轮
  普知苦集及灭道　　微细分别缘起法
  法义乐说辞无碍　　因此无畏广宣扬
  诸法无我无有相　　业性不起亦不失
  一切远离如虚空　　佛以方便能分别
  如来如是转法轮　　普震十方诸国土
  宫殿山河悉摇动　　不使众生有惊怖
  如来普演广大音　　随其根欲皆令解
  悉使发心除惑垢　　而佛未始生心念
  或闻施戒忍精进　　禅定般若方便智
  或闻慈悲及喜舍　　种种言辞差别声
  或闻四念四正勤　　神足根力觉支道
  诸念神通止观等　　无量方便诸法门
  龙神八部人非人　　梵释护世诸天众
  佛以一音为说法　　随其品类皆令解
  或有贪欲嗔恚痴　　忿覆悭嫉及憍谄
  八万四千烦恼异　　令其闻说对治门
  若白净法未修治　　令其闻说十学处
  已能布施调伏者　　令闻寂灭涅槃音
  若人志劣无慈愍　　厌恶生死自求离
  令其闻说三脱门　　使得出苦涅槃乐
  若有自性少诸欲　　厌背三有求寂静
  令其闻说诸缘起　　依独觉乘而出离
  若有清净广大心　　圆满施戒诸功德
  亲近如来具慈愍　　令其闻说大乘音
  或有国土闻一乘　　或二或三或四五
  如是乃至无有量　　悉是如来方便力
  涅槃寂静无差别　　智行胜劣有殊异
  譬如虚空体性一　　鸟飞远近各不同
  佛体音声亦如是　　普遍一切虚空界
  随诸众生心智殊　　所闻所见各差别
  佛以过去修诸行　　能随所乐演妙音
  无心计念此与彼　　我为谁说谁不说
  如来面门放大光　　具足八万四千数
  所说法门亦如是　　普照于世除烦恼
  圆满清净功德智　　而常随顺三世间
  犹如虚空无染着　　为众生故而显示
  示有生老病死苦　　亦示住寿处于世
  虽顺世间如是现　　体性清净如虚空
  一切国土无有边　　众生根乐亦无量
  如来智眼皆明见　　随所应化示佛道
  究竟十方虚空界　　所有人天大众中
  随其形相各不同　　佛现其身亦如是
  若在沙门大众会　　剃除须发服袈裟
  执持衣钵护诸根　　令其欢喜息烦恼
  若时亲近婆罗门　　则为示现羸瘦身
  执杖持瓶恒洁净　　具足智慧巧谈说
  吐故纳新自充饱　　吸风饮露无异食
  或坐或立不动摇　　现诸苦行摧异道
  或持彼戒为世师　　善达医方等诸论
  书数天文地众相　　及身休咎无不了
  深入诸禅及解脱　　三昧神通智慧行
  言谈讽咏共嬉戏　　方便皆令住佛道
  或现上服以严身　　首戴华冠荫高盖
  四兵前后共围绕　　誓众宣威伏小王
  或为听讼断狱官　　惩恶劝善多方便
  所有与夺皆明审　　令其欣敬尽钦承
  或作辅弼诸大臣　　善用诸王治政法
  十方利益皆周遍　　了达世间无有余
  或为粟散诸小王　　或作飞行转轮帝
  令诸王子采女众　　悉皆授化奉修行
  或作护世四天王　　或作夜叉龙等主
  各为其众而说法　　一切皆令大欣庆
  或作忉利大天王　　住善法堂欢喜园
  首戴华冠说妙法　　诸天觐仰无能测
  或住夜摩兜率天　　化乐自在魔王所
  居处摩尼宝宫殿　　说真实行令调伏
  或至梵天众会中　　说四无量诸禅道
  普令欢喜便舍去　　而莫知其往来相
  或至阿迦尼吒天　　为说觉分诸宝华
  及余无量圣功德　　然后舍去无知者
  如来无碍智所见　　其中一切诸众生
  悉以无边方便门　　种种教化令成熟
  譬如幻师善幻术　　现作种种诸幻事
  佛化众生亦如是　　为其示现种种身
  如净月轮在虚空　　令世众生见盈缺
  一切河池现影像　　所有星宿夺光色
  如来智月出世间　　亦以方便示增减
  菩萨心水现影像　　二乘星宿无光色
  譬如大海宝充满　　清净无浊无有边
  四洲所有诸众生　　一切于中现其像
  佛身功德海亦尔　　无垢无浊量无边
  乃至法界诸众生　　靡不于中现其像
  譬如净日放千光　　不动本处遍十方
  佛日光明亦如是　　无去无来除世闇
  譬如龙王降大雨　　不从身出及心出
  而能沾洽悉周遍　　涤除炎热使清凉
  如来法雨亦复然　　不从于佛身心出
  而能开悟诸含识　　尽能灭除三毒火
  如来清净妙法身　　一切三界无伦匹
  超出世间言语道　　本性非有亦非无
  虽无所依无不依　　如是无来亦无去
  如空如日亦如梦　　当于佛体如是观
  三界有无一切法　　不能与佛为譬谕
  譬如山林鸟兽等　　无有依空而住者
  大海摩尼无量色　　佛身差别亦复然
  如来非色非非色　　随应而现无所住
  虚空真如及实际　　涅槃法性寂灭等
  唯有如是真实法　　可以显示于如来
  刹尘心念可数知　　大海中水可饮尽
  虚空可量风可系　　无人能说佛功德
  若有闻斯功德海　　能生欢喜信乐心
  如所称扬悉当得　　慎勿于此生疑念

大方广佛华严经卷第三十九大方广佛华严经卷第四十

        罽宾国三藏般若奉　诏译

    入不思议解脱境界普贤行愿品

尔时普贤菩萨摩诃萨。称叹如来胜功德已。告诸菩萨及善财言。善男子。如来功德。假使十方一切诸佛经不可说不可说佛刹极微尘数劫。相续演说不可穷尽。若欲成就此功德门。应修十种广大行愿。何等为十。一者礼敬诸佛。二者称赞如来。三者广修供养。四者忏悔业障。五者随喜功德。六者请转法轮。七者请佛住世。八者常随佛学。九者恒顺众生。十者普皆回向

善财白言。大圣。云何礼敬乃至回向。普贤菩萨。告善财言。善男子。言礼敬诸佛者。所有尽法界。虚空界。十方三世一切佛刹极微尘数诸佛世尊。我以普贤行愿力故。起深信解。如对目前。悉以清净身语意业。常修礼敬。一一佛所。皆现不可说不可说佛刹极微尘数身。一一身遍礼不可说不可说佛刹极微尘数佛。虚空界尽。我礼乃尽。而虚空界不可尽故。我此礼敬无有穷尽。如是乃至众生界尽。众生业尽。众生烦恼尽。我礼乃尽。而众生界。乃至烦恼无有尽故。我此礼敬无有穷尽。念念相续。无有间断。身语意业无有疲厌复次善男子。言称赞如来者。所有尽法界。虚空界。十方三世一切刹土。所有极微。一一尘中。皆有一切世界极微尘数佛。一一佛所。皆有菩萨海会围绕。我当悉以甚深胜解。现前知见。各以出过辩才天女微妙舌根。一一舌根。出无尽音声海。一一音声。出一切言辞海。称扬赞叹一切如来诸功德海。穷未来际。相续不断。尽于法界。无不周遍。如是虚空界尽。众生界尽。众生业尽。众生烦恼尽。我赞乃尽。而虚空界乃至烦恼。无有尽故。我此赞叹无有穷尽。念念相续。无有间断。身语意业无有疲厌复次善男子。言广修供养者。所有尽法界。虚空界。十方三世一切佛刹极微尘中。一一各有一切世界极微尘数佛。一一佛所。种种菩萨海会围绕。我以普贤行愿力故。起深信解。现前知见。悉以上妙诸供养具。而为供养。所谓华云鬘云。天音乐云。天伞盖云。天衣服云。天种种香涂香烧香末香。如是等云。一一量如须弥山王。然种种灯。酥灯油灯诸香油灯。一一灯炷。如须弥山。一一灯油。如大海水。以如是等诸供养具。常为供养。善男子。诸供养中。法供养最。所谓如说修行供养。利益众生供养。摄受众生供养。代众生苦供养。勤修善根供养。不舍菩萨业供养。不离菩提心供养。善男子。如前供养无量功德。比法供养。一念功德。百分不及一。千分不及一。百千俱胝那由他分。迦罗分。算分。数分。谕分。优婆尼沙陀分。亦不及一。何以故。以诸如来尊重法故。以如说修行出生诸佛故。若诸菩萨。行法供养。则得成就供养如来。如是修行。是真供养故。此广大最胜供养。虚空界尽。众生界尽。众生业尽。众生烦恼尽。我供乃尽。而虚空界。乃至烦恼。不可尽故。我此供养。亦无有尽。念念相续无有间断。身语意业无有疲厌

复次善男子。言忏除业障者。菩萨自念。我于过去无始劫中。由贪嗔痴。发身口意。作诸恶业。无量无边。若此恶业。有体相者。尽虚空界不能容受。我今悉以清净三业。遍于法界极微尘刹一切诸佛菩萨众前。诚心忏悔。后不复造。恒住净戒。一切功德。如是虚空界尽。众生界尽。众生业尽。众生烦恼尽。我忏乃尽。而虚空界。乃至众生烦恼。不可尽故。我此忏悔无有穷尽。念念相续无有间断。身语意业无有疲厌

复次善男子。言随喜功德者。所有尽法界。虚空界。十方三世一切佛刹极微尘数诸佛如来。从初发心。为一切智。勤修福聚。不惜身命。经不可说不可说佛刹极微尘数劫。一一劫中。舍不可说不可说佛刹极微尘数头目手足。如是一切难行苦行。圆满种种波罗蜜门。证入种种菩萨智地。成就诸佛无上菩提。及般涅槃。分布舍利。所有善根。我皆随喜。及彼十方一切世界。六趣四生。一切种类。所有功德。乃至一尘。我皆随喜。十方三世一切声闻。及辟支佛。有学无学。所有功德。我皆随喜。一切菩萨所修无量难行苦行。志求无上正等菩提。广大功德。我皆随喜。如是虚空界尽。众生界尽。众生业尽。众生烦恼尽。我此随喜。无有穷尽。念念相续无有间断。身语意业无有疲厌

复次善男子。言请转法轮者。所有尽法界。虚空界。十方三世一切佛刹极微尘中。一一各有不可说不可说佛刹极微尘数广大佛刹。一一刹中。念念有不可说不可说。佛刹极微尘数一切诸佛成等正觉。一切菩萨海会围绕。而我悉以身口意业。种种方便。殷勤劝请。转妙法轮。如是虚空界尽。众生界尽。众生业尽。众生烦恼尽。我常劝请一切诸佛。转正法轮。无有穷尽。念念相续无有间断。身语意业无有疲厌

复次善男子。言请佛住世者。所有尽法界。虚空界。十方三世一切佛刹极微尘数诸佛如来。将欲示现般涅槃者。及诸菩萨。声闻缘觉。有学无学。乃至一切诸善知识。我悉劝请。莫入涅槃。经于一切佛刹极微尘数劫。为欲利乐一切众生。如是虚空界尽。众生界尽。众生业尽。众生烦恼尽。我此劝请无有穷尽。念念相续无有间断。身语意业无有疲厌复次善男子。言常随佛学者。如此娑婆世界。毗卢遮那如来。从初发心。精进不退。以不可说不可说身命而为布施。剥皮为纸。折骨为笔。刺血为墨。书写经典。积如须弥。为重法故。不惜身命。何况王位。城邑聚落。宫殿园林。一切所有。及余种种难行苦行。乃至树下成大菩提。示种种神通起种种变化。现种种佛身。处种种众会。或处一切诸大菩萨众会道场。或处声闻及辟支佛众会道场。或处转轮圣王小王眷属众会道场。或处刹利及婆罗门长者居士众会道场。乃至或处天龙八部人非人等众会道场。处于如是种种众会。以圆满音。如大雷震。随其乐欲成熟众生。乃至示现入于涅槃。如是一切我皆随学。如今世尊毗卢遮那。如是尽法界。虚空界。十方三世一切佛刹所有尘中。一切如来皆亦如是。于念念中。我皆随学。如是虚空界尽众生界尽。众生业尽。众生烦恼尽。我此随学无有穷尽。念念相续无有间断身语意业无有疲厌复次善男子。言恒顺众生者。谓尽法界。虚空界。十方刹海。所有众生种种差别。所谓卵生。胎生。湿生。化生。或有依于地水火风而生住者。或有依空及诸卉木而生住者。种种生类。种种色身。种种形状。种种相貌。种种寿量。种种族类。种种名号。种种心性。种种知见。种种欲乐。种种意行。种种威仪。种种衣服。种种饮食。处于种种村营聚落城邑宫殿。乃至一切天龙八部人非人等。无足二足。四足多足。有色无色。有想无想。非有想。非无想。如是等类。我皆于彼。随顺而转。种种承事。种种供养。如敬父母。如奉师长。及阿罗汉。乃至如来。等无有异。于诸病苦。为作良医。于失道者。示其正路。于闇夜中。为作光明。于贫穷者。令得伏藏。菩萨如是平等饶益一切众生。何以故。菩萨若能随顺众生。则为随顺供养诸佛。若于众生。尊重承事。则为尊重承事如来。若令众生生欢喜者。则令一切如来欢喜。何以故。诸佛如来。以大悲心而为体故。因于众生。而起大悲。因于大悲。生菩提心。因菩提心。成等正觉。譬如旷野沙碛之中。有大树王。若根得水。枝叶华果悉皆繁茂。生死旷野菩提树王。亦复如是。一切众生而为树根。诸佛菩萨而为华果。以大悲水。饶益众生。则能成就诸佛菩萨智慧华果。何以故。若诸菩萨。以大悲水。饶益众生。则能成就阿耨多罗三藐三菩提故。是故菩提。属于众生。若无众生。一切菩萨。终不能成无上正觉。善男子。汝于此义。应如是解。以于众生心平等故。则能成就圆满大悲。以大悲心。随众生故。则能成就供养如来。菩萨如是随顺众生。虚空界尽。众生界尽。众生业尽。众生烦恼尽。我此随顺无有穷尽。念念相续无有间断。身语意业无有疲厌

复次善男子。言普皆回向者。从初礼拜。乃至随顺。所有功德。皆悉回向。尽法界。虚空界一切众生。愿令众生常得安乐。无诸病苦。欲行恶法皆悉不成。所修善业。皆速成就。关闭一切诸恶趣门。开示人天涅槃正路。若诸众生。因其积集诸恶业故。所感一切极重苦果。我皆代受。令彼众生悉得解脱。究竟成就无上菩提。菩萨如是所修回向。虚空界尽。众生界尽。众生业尽。众生烦恼尽。我此回向无有穷尽。念念相续无有间断。身语意业无有疲厌。善男子。是为菩萨摩诃萨十种大愿具足圆满。若诸菩萨。于此大愿。随顺趣入。则能成熟一切众生。则能随顺阿耨多罗三藐三菩提。则能成满普贤菩萨诸行愿海。是故善男子。汝于此义。应如是知。若有善男子善女人。以满十方无量无边不可说不可说佛刹极微尘数一切世界。上妙七宝及诸人天最胜安乐。布施尔所一切世界所有众生。供养尔所一切世界诸佛菩萨。经尔所佛刹极微尘数劫。相续不断。所得功德。若复有人。闻此愿王。一经于耳。所有功德。比前功德。百分不及一。千分不及一。乃至优波尼沙陀分。亦不及一。或复有人。以深信心。于此大愿。受持读诵。乃至书写一四句偈。速能除灭五无间业。所有世间身心等病。种种苦恼。乃至佛刹极微尘数一切恶业。皆得销除。一切魔军。夜叉罗刹。若鸠槃荼若毗舍阇。若部多等。饮血啖肉诸恶鬼神。皆悉远离。或时发心。亲近守护。是故若人诵此愿者。行于世间。无有障碍。如空中月出于云翳。诸佛菩萨之所称赞。一切人天皆应礼敬。一切众生悉应供养。此善男子。善得人身。圆满普贤所有功德。不久当如普贤菩萨速得成就微妙色身。具三十二大丈夫相。若生人天。所在之处。常居胜族。悉能破坏一切恶趣。悉能远离一切恶友。悉能制伏一切外道。悉能解脱一切烦恼。如师子王摧伏群兽。堪受一切众生供养。又复是人。临命终时。最后刹那。一切诸根悉皆散坏。一切亲属悉皆舍离。一切威势悉皆退失。辅相大臣。宫城内外象马车乘。珍宝伏藏。如是一切无复相随。唯此愿王不相舍离。于一切时。引导其前。一刹那中。即得往生极乐世界。到已即见阿弥陀佛。文殊师利菩萨。普贤菩萨。观自在菩萨。弥勒菩萨等。此诸菩萨色相端严。功德具足。所共围绕。其人自见。生莲华中。蒙佛授记。得授记已。经于无数百千万亿那由他劫。普于十方不可说不可说世界。以智慧力。随众生心。而为利益。不久当坐菩提道场。降伏魔军。成等正觉。转妙法轮。能令佛刹极微尘数世界众生。发菩提心。随其根性。教化成熟。乃至尽于未来劫海。广能利益一切众生。善男子。彼诸众生。若闻若信此大愿王。受持读诵。广为人说。所有功德。除佛世尊余无知者。是故汝等。闻此愿王。莫生疑念。应当谛受。受已能读。读已能诵。诵已能持。乃至书写。广为人说。是诸人等。于一念中。所有行愿。皆得成就。所获福聚无量无边。能于烦恼大苦海中。拔济众生。令其出离。皆得往生阿弥陀佛极乐世界。尔时普贤菩萨摩诃萨。欲重宣此义。普观十方。而说偈言

  所有十方世界中　　三世一切人师子
  我以清净身语意　　一切遍礼尽无余
  普贤行愿威神力　　普现一切如来前
  一身复现刹尘身　　一一遍礼刹尘佛
  于一尘中尘数佛　　各处菩萨众会中
  无尽法界尘亦然　　深信诸佛皆充满
  各以一切音声海　　普出无尽妙言辞
  尽于未来一切劫　　赞佛甚深功德海
  以诸最胜妙华鬘　　妓乐涂香及伞盖
  如是最胜庄严具　　我以供养诸如来
  最胜衣服最胜香　　末香烧香与灯烛
  一一皆如妙高聚　　我悉供养诸如来
  我以广大胜解心　　深信一切三世佛
  悉以普贤行愿力　　普遍供养诸如来
  我昔所造诸恶业　　皆由无始贪恚痴
  从身语意之所生　　一切我今皆忏悔
  十方一切诸众生　　二乘有学及无学
  一切如来与菩萨　　所有功德皆随喜
  十方所有世间灯　　最初成就菩提者
  我今一切皆劝请　　转于无上妙法轮
  诸佛若欲示涅槃　　我悉至诚而劝请
  唯愿久住刹尘劫　　利乐一切诸众生
  所有礼赞供养福　　请佛住世转法轮
  随喜忏悔诸善根　　回向众生及佛道
  我随一切如来学　　修习普贤圆满行
  供养过去诸如来　　及与现在十方佛
  未来一切天人师　　一切意乐皆圆满
  我愿普随三世学　　速得成就大菩提
  所有十方一切刹　　广大清净妙庄严
  众会围绕诸如来　　悉在菩提树王下
  十方所有诸众生　　愿离忧患常安乐
  获得甚深正法利　　灭除烦恼尽无余
  我为菩提修行时　　一切趣中成宿命
  常得出家修净戒　　无垢无破无穿漏
  天龙夜叉鸠槃荼　　乃至人与非人等
  所有一切众生语　　悉以诸音而说法
  勤修清净波罗蜜　　恒不忘失菩提心
  灭除障垢无有余　　一切妙行皆成就
  于诸惑业及魔境　　世间道中得解脱
  犹如莲华不着水　　亦如日月不住空
  悉除一切恶道苦　　等与一切群生乐
  如是经于刹尘劫　　十方利益恒无尽
  我常随顺诸众生　　尽于未来一切劫
  恒修普贤广大行　　圆满无上大菩提
  所有与我同行者　　于一切处同集会
  身口意业皆同等　　一切行愿同修学
  所有益我善知识　　为我显示普贤行
  常愿与我同集会　　于我常生欢喜心
  愿常面见诸如来　　及诸佛子众围绕
  于彼皆兴广大供　　尽未来劫无疲厌
  愿持诸佛微妙法　　光显一切菩提行
  究竟清净普贤道　　尽未来劫常修习
  我于一切诸有中　　所修福智恒无尽
  定慧方便及解脱　　获诸无尽功德藏
  一尘中有尘数刹　　一一刹有难思佛
  一一佛处众会中　　我见恒演菩提行
  普尽十方诸刹海　　一一毛端三世海
  佛海及与国土海　　我遍修行经劫海
  一切如来语清净　　一言具众音声海
  随诸众生意乐音　　一一流佛辩才海
  三世一切诸如来　　于彼无尽语言海
  恒转理趣妙法轮　　我深智力普能入
  我能深入于未来　　尽一切劫为一念
  三世所有一切劫　　为一念际我皆入
  我于一念见三世　　所有一切人师子
  亦常入佛境界中　　如幻解脱及威力
  于一毛端极微中　　出现三世庄严刹
  十方尘刹诸毛端　　我皆深入而严净
  所有未来照世灯　　成道转法悟群有
  究竟佛事示涅槃　　我皆往诣而亲近
  速疾周遍神通力　　普门遍入大乘力
  智行普修功德力　　威神普覆大慈力
  遍净庄严胜福力　　无著无依智慧力
  定慧方便诸威力　　普能积集菩提力
  清净一切善业力　　摧灭一切烦恼力
  降伏一切诸魔力　　圆满普贤诸行力
  普能严净诸刹海　　解脱一切众生海
  善能分别诸法海　　能甚深入智慧海
  普能清净诸行海　　圆满一切诸愿海
  亲近供养诸佛海　　修行无倦经劫海
  三世一切诸如来　　最胜菩提诸行愿
  我皆供养圆满修　　以普贤行悟菩提
  一切如来有长子　　彼名号曰普贤尊
  我今回向诸善根　　愿诸智行悉同彼
  愿身口意恒清净　　诸行刹土亦复然
  如是智慧号普贤　　愿我与彼皆同等
  我为遍净普贤行　　文殊师利诸大愿
  满彼事业尽无余　　未来际劫恒无倦
  我所修行无有量　　获得无量诸功德
  安住无量诸行中　　了达一切神通力
  文殊师利勇猛智　　普贤慧行亦复然
  我今回向诸善根　　随彼一切常修学
  三世诸佛所称叹　　如是最胜诸大愿
  我今回向诸善根　　为得普贤殊胜行
  愿我临欲命终时　　尽除一切诸障碍
  面见彼佛阿弥陀　　即得往生安乐刹
  我既往生彼国已　　现前成就此大愿
  一切圆满尽无余　　利乐一切众生界
  彼佛众会咸清净　　我时于胜莲华生
  亲睹如来无量光　　现前授我菩提记
  蒙彼如来授记已　　化身无数百俱胝
  智力广大遍十方　　普利一切众生界
  乃至虚空世界尽　　众生及业烦恼尽
  如是一切无尽时　　我愿究竟恒无尽
  十方所有无边刹　　庄严众宝供如来
  最胜安乐施天人　　经一切刹微尘劫
  若人于此胜愿王　　一经于耳能生信
  求胜菩提心渴仰　　获胜功德过于彼
  即常远离恶知识　　永离一切诸恶道
  速见如来无量光　　具此普贤最胜愿
  此人善得胜寿命　　此人善来人中生
  此人不久当成就　　如彼普贤菩萨行
  往昔由无智慧力　　所造极恶五无间
  诵此普贤大愿王　　一念速疾皆销灭
  族姓种类及容色　　相好智慧咸圆满
  诸魔外道不能摧　　堪为三界所应供
  速诣菩提大树王　　坐已降伏诸魔众
  成等正觉转法轮　　普利一切诸含识
  若人于此普贤愿　　读诵受持及演说
  果报唯佛能证知　　决定获胜菩提道
  若人诵此普贤愿　　我说少分之善根
  一念一切悉皆圆　　成就众生清净愿
  我此普贤殊胜行　　无边胜福皆回向
  普愿沉溺诸众生　　速往无量光佛刹

尔时普贤菩萨摩诃萨。于如来前。说此普贤广大愿王清净偈已。善财童子。踊跃无量。一切菩萨皆大欢喜。如来赞言。善哉善哉。尔时世尊。与诸圣者菩萨摩诃萨。演说如是不可思议解脱境界胜法门时。文殊师利菩萨而为上首。诸大菩萨。及所成熟。六千比丘。弥勒菩萨而为上首。贤劫一切诸大菩萨。无垢普贤菩萨而为上首。一生补处住灌顶位诸大菩萨。及余十方种种世界。普来集会。一切刹海极微尘数诸菩萨摩诃萨众。大智舍利弗。摩诃目犍连等。而为上首。诸大声闻。并诸人天一切世主。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众。闻佛所说。皆大欢喜。信受奉行

大方广佛华严经卷第四十

南天竺乌茶国深信最胜善逝法者修行最胜大乘行者吉祥自在作清净师子王。上献摩诃支那大唐国大吉祥天子大自在师子中大王。手自书写大方广佛华严经百千偈中所说善财童子亲近承事佛刹极微尘数善知识行中五十五圣者善知识入不思议解脱境界普贤行愿品。谨奉进上。伏愿大国圣王。福聚高大超须弥山。智慧深广过四大海。十方国土通为一家。及书此经功德。愿集彼无量福聚。等虚空界一切世界海无尽众生界。一切皆如善财童子得佛正见具足智慧。见不可思议真善知识咸生欢喜。得佛广大普光明照。离诸贪着成就无垢普贤菩萨最胜行愿。伏愿书此大乘经典进奉功德。慈氏如来成佛之时。龙华会上早得奉觐大圣天王。获宿命智瞻见便识同受佛记。尽虚空遍法界广度未来一切众生速得成佛

贞元十一年十一月十八日进奉梵夹。十二年六月五日奉诏于长安崇福寺译。十四年二月二十四日译毕进上
罽宾国三藏赐紫沙门般若宣梵文
东都天宫寺沙门广济译语
西明寺赐紫沙门圆照笔受
保寿寺沙门智柔回缀
保寿寺沙门智通回缀
成都府正觉寺沙门道弘润文
章敬寺沙门鉴虚润文
大觉寺沙门道章校勘证义
千福寺沙门大通证禅义
太原府崇福寺沙门澄观详定
千福寺沙门虚邃详定
专知官右神策军散兵马使衙前马军正将兼押衙特进行邓州司法参军南珍贡右神策军护军中尉兼右街功德使元从兴元元从云麾将军右监门卫大将军知内侍省事上柱国交城县开国男食邑三百户臣霍仙鸣
左神策军护军中尉兼左街功德使元从兴元元从骠骑大将军行左监门卫大将军知内侍省事上柱国邠国公食邑三千户臣窦文场等进

大唐贞元十四年岁在戊寅四月辛亥朔。翻经沙门圆照用恩赐物。奉为皇帝圣化无穷。太子诸王福延万叶。文武百官恒居禄位。伏愿先师考妣上品往生。法界有情同沾斯益。手自书写此新译经。填续西明寺菩提院东阁一切经阙本。愿千佛出世随侍下生。同出苦源齐登正觉。又愿三宝增明法轮恒转。长留镇寺永冀传灯。有情界穷兹愿无尽

元本终识

道安滥厕僧伦。叨承祖裔。虽见性修行因地果位未成。非依经演唱教乘佛恩莫报。切见湖州路思溪法宝寺大藏经板泯于兵火只字不存。累承杭州路大明庆寺寂堂思宗师会集诸山禅教师德同声劝请。谓此一大因缘世鲜克举。若得老古山与白云一宗协力开刊流通教法。则世出世间是真续佛慧命。道安蒙斯处嘱复自念言

如来一大藏经板实非小缘。岂道安绵力之所堪任。即与庵院僧人优婆塞聚议。咸皆快然发希有心。施力施财增益我愿。又蒙江淮诸路释教都总摄所护念。准给文凭及转呈

檐八上师引觐

皇帝颁降

圣旨护持宗门作成胜事兴工之后。惟愿

诸佛龙天善友知识加被于我。使我从初至终成如是缘。心无退转亦无障碍。以此鸿因端为祝延

皇帝圣寿万安

皇后同年
太子诸王千秋文武官僚升迁禄位仍赞
大元帝师
大元国师
檐八上师
江淮诸路释教都总摄扶宗弘教大师
江淮诸路释教都总摄永福大师

大阐宗乘同增福算。更冀时和岁稔物阜民康。四恩三有尽沾恩。一切有情登彼岸

宣授浙西道杭州等路白云宗僧录南山普宁寺住持传三乘教九世孙慧照大师沙门道安谨愿。时至元十六年己卯十二月吉日拜书

如志先师和尚慧照大师。以教法任重在己。尝嘱之曰。余承明庆寂堂宗师诸山禅教之请。与本宗庵院同刊如来一大藏经板。流通教法实非小缘。我今衰迈。全仗汝徒同心协力成就我愿。兴工之后。外事则有一都寺提点任责。内事则汝措置提调。汝宜不惜身命始终相成。同报佛恩功不虚弃。如志勉承师训罔敢少懈。不料先师和尚于至元十八年春示寂于大都大延寿寺。自后继任僧录住持者凡四传。初传月潭师兄如一。至元二十一年秋月潭入寂于寺。次传之如志。越明年春愚叟如贤继之。至元二十六年冬愚叟退席。如志复继前任各钦受

圣旨护持宗教成就大缘。始自丁丑讫于庚寅。凡一十四载。由先师本愿力故得以圆成

如来一大藏经版好事所集无量功德端为祝延
皇帝圣寿万安
皇后同年
太子诸王千秋文武官僚升迁禄位仍赞
大元帝师
大元国师
檐八上师
江淮诸路释教都总摄扶宗弘教大师
江淮诸路释教都总统永福大师

弥增禄算。伏愿

尧天舜日大开一统山河圣子神孙同衍千秋福寿文登极品。武列殊勋。军奏凯歌。民安常业。佛法恒住世间相。道德尊为帝者师。统护僧门。流通教海。更冀施力施财之士福慧庄严。若闻若见之人身心饶益。四恩普报三有遍资。法界含生同圆种智者

    大藏经局刊字作头
作头何囦
作头范山

    大藏经局措置梨板勾当
勾当僧明秀
勾当僧明达

    大藏经局合造光选经板勾当
勾当僧明达
勾当僧明照
勾当僧明果
勾当僧明诂

    大藏经局点视刊板书样印造勾当
勾当僧明俊
勾当僧明信
勾当僧明礼
勾当僧明然
勾当僧明钦
勾当僧明文

    大藏经局正字勾当
勾当僧明茂
勾当僧明逸
勾当僧如空

    本寺首座书记正字勾当
勾当僧明远
勾当僧明本
勾当僧明裕

    大藏经局藏主勾当
勾当僧如聪
勾当僧如衍

    大藏经局副局监局主局勾当
勾当僧明瑞
勾当僧明了
勾当僧明俊
勾当僧如思
勾当僧如净
勾当僧明定
勾当僧如圭
勾当僧如照
勾当僧明森
勾当僧明坚

    大普宁寺知事耆旧勾当
勾当僧明皓
勾当僧明晓
勾当僧明璋
勾当僧明祖
勾当僧明广
勾当僧明仁
勾当僧如熙
勾当僧明益
勾当僧明吉
勾当僧明戒
勾当僧明实
勾当僧明行

    平江路化缘勾当
化缘勾当孝慈院僧明政
化缘勾当广济院僧如源
化缘勾当资福院僧如辉
化缘勾当真庆院僧如明

    湖州路化缘勾当
化缘勾当雨华庵僧如圆
化缘勾当真觉院僧如祥
化缘勾当宝明院僧如坚
化缘勾当普度院僧明崇
化缘勾当致庆院僧如钧
化缘勾当庆远院僧如昌
化缘勾当竹隐院僧如浩
化缘勾当净福庵僧如璋
化缘勾当常定院僧明慧
化缘勾当积庆院僧明兰
化缘勾当真武庵僧如源
化缘勾当真庆院僧如泽
化缘勾当葛山院僧如因
化缘勾当妙德院僧如是
化缘勾当妙严院僧如宁
化缘勾当妙圆院僧如常
化缘勾当十地院僧如鉴

    嘉兴路化缘勾当
化缘勾当普明院僧如坚
化缘勾当庆福院僧如实
化缘勾当崇庆院僧如琼
化缘勾当颐浩院僧如信
化缘勾当华严院僧如哲
化缘勾当圆通院僧如臻
化缘勾当志远院僧如定
化缘勾当嗣光院僧如亨
化缘勾当庆寿院僧如隆
化缘勾当普照院僧明真
化缘勾当崇福院僧如圭
化缘勾当政山院僧明净

    杭州路化缘勾当
化缘勾当慈济院僧明俊
化缘勾当政福院僧明正
化缘勾当福胜院僧明智
化缘勾当平湖院僧如胜
化缘勾当善集院僧如云
化缘勾当万寿院僧明映
化缘勾当崇兴院僧如正
化缘勾当福地院僧如祥
大藏经局提调勾当僧如莹
大藏经局提调勾当僧如信
大藏经局提调勾当僧如信
大藏经局提调勾当僧智圆
大藏经局提调勾当僧如信
大藏经局提调勾当僧如昌
大藏经局提调勾当僧道超
大藏经局提调勾当僧如春
大藏经局提调勾当僧如源
大藏经局提调勾当僧如日
大藏经局提调勾当僧如杲
大藏经局提调勾当僧如智
大藏经局提调勾当僧如贵
大藏经局提调勾当僧如通
大藏经局提调勾当僧如真
白云宗僧录司提控僧明际
白云宗僧录司提控僧如义
白云宗僧录司知事僧如观
白云宗僧判如镜

宣授白云宗前僧录南山大普宁寺住持沙门如贤
宣授白云宗前僧录南山大普宁寺住持沙门如一
白云宗前僧判绰思吉八
白云宗前僧录守进
国泰崇圣寺沙门文成检阅经藏
大云广福寺沙门处林校勘经藏
天竺灵山教寺沙门怀坦校勘经藏
天竺灵山教寺沙门法杭校勘经藏
西湖寿星教寺沙门文胜校勘经藏
奉口万安教寺沙门净芳校勘经藏
天竺灵山教寺沙门祖熏校勘经藏
天竺集庆教寺沙门普润校勘经藏
六和塔开化教寺传大乘唯识宗权讲沙门慧心校勘论藏
六和塔开化教寺住持传慈恩宗教讲经论沙门妙用校勘论藏
六和塔开化教寺前住持传慈恩宗教讲经论沙门正严校勘论藏
六和塔开化教寺前住持传慈恩宗教大乘檀主讲经论慧悟大师宗靖校勘论藏
西湖戒坛大昭庆寺前住持传律法慧大师仲宝校勘律藏
临坛宗主前住持灵芝崇福寺传律沙门仲立校勘律藏
临坛宗主前住持灵芝崇福寺传律沙门闻达校勘律藏
临坛宗主前住持明庆大兴国寺佛瑞大师梵祥校勘律藏
峨嵋山国泰崇圣寺住持传天台宗教沙门师正主席校勘经藏
仙林慈恩普济教寺讲经论传大乘戒广智圆明大师德荣校勘论藏
崇恩演福教寺前住持传天台宗教祥应大师永清详定校勘经藏
报恩光寺禅寺住持沙门义传同劝缘
灵隐景德禅寺住持沙门净伏同劝缘
径山兴圣万寿禅寺住持沙门妙高同劝缘
上天竺灵感观音教寺住持沙门思恭劝缘
明庆大兴国寺前住持佛慧大师闻思劝缘
江淮诸路释教都总统所提控顾劝缘
江淮诸路释教都总统所主事白劝缘
江淮诸路释教都总统所经历郭劝缘
宣授江淮诸路释教都总摄弘教大师加瓦八劝缘
宣授江淮诸路释教都总摄扶宗弘教大师行吉祥都劝缘
宣授江淮诸路释教都总统永福大师琏真加都劝缘

宣授白云宗僧录南山大普宁寺住持传三乘教十一世孙沙门如志谨识。时至元二十七年庚寅十月圆日顿首拜书


大方广佛华严经卷第一{60}

    No. 278 [No. 279]

大方广佛华严经卷第一

        东晋天竺三藏佛驮跋陀罗译

    世间净眼品第一之一

如是我闻。一时佛在摩竭提国寂灭道场。始成正觉。其地金刚具足严净。众宝杂华。以为庄饰。上妙宝轮。圆满清净。无量妙色。种种庄严。犹如大海。宝幢幡盖。光明照耀。妙香华鬘。周匝围绕。七宝罗网。弥覆其上。雨无尽宝。显现自在。诸杂宝树。华叶光茂佛神力故。令此场地广博严净。光明普照。一切奇特。妙宝积聚。无量善根庄严道场。其菩提树。高显殊特。清净琉璃以为其干。妙宝枝条。庄严清净。宝叶垂布犹如重云。杂色宝华间错其间。如意摩尼以为其果。树光普照十方世界。种种现化施作佛事。不可尽极。普现大乘菩萨道教。佛神力故。常出一切众妙之音。赞扬如来无量功德。不可思议师子之座。犹如大海。众妙宝华而为严饰。流光如云。周遍普照无数菩萨大海之藏。大音远震。不可思议如来光明逾摩尼尊。弥覆其上。种种变化施作佛事。一切悉睹无所挂碍。于一念顷一切现化。充满法界。如来妙藏无不遍至。无量众宝庄严宝台。如来处此宝师子座。于一切法成最正觉。了三世法平等智身。普入一切世间之身。妙音遍至一切世界。不可穷尽。犹如虚空。平等法相智慧行处。犹如虚空。等心随顺一切众生。其身遍坐一切道场。悉知一切众生所行。智慧日光照除众冥。悉能显现诸佛国土。普放三世智海光明照净境界。无量光明充满十方。不坏法云遍覆一切。以力无畏。显现无量自在力光。开方便门教化众生。悉能普现一切众会。犹如虚空而无来去。了达一切无有自性。随顺诸法平等之相。一切光明普现三世诸佛所行诸佛世界。犹如大海。不可思议音声语言悉能随顺

与十佛世界微尘数等大菩萨俱。其名曰普贤菩萨。普德智光菩萨。普明师子菩萨。普胜宝光菩萨。普德海幢菩萨。普慧光照菩萨。普宝华幢菩萨。普胜软音菩萨。普净德焰菩萨。普相光明菩萨。大光海月菩萨。云音海藏菩萨。德宝胜月菩萨。净慧光焰自在王菩萨。超趣华光菩萨。无量智云日光菩萨。大力精进金刚菩萨。香焰光幢菩萨。月德妙音菩萨。光明尊德菩萨。与如是等诸菩萨俱。皆是卢舍那佛。宿世善友。一切成就功德大海。诸波罗蜜周满普照。慧眼清净等观三世。于诸三昧具足明净。辩才大海深广无尽普现诸佛功德光耀。善知一切众生心行如应调伏。以金刚智普照境界。同一法性觉慧广大。甚深智境靡不明达。住于一地。普摄一切诸地功德。无上智愿皆已成满。具足如来深广密教。悉得一切佛所共法。皆同如来行地德力。一切三昧海门皆得自在。于众生海如应示现。随其所行善能建立。善入一切诸法之海。回转总持如来一切功德法海。充满其身。遍游一切佛世界海。出生一切净土愿海。悉得诸佛达未来际方便智慧。一切如来坐道场者。普能往诣礼事供养。悉得一切普贤愿海。于诸众生智身满足。复有佛世界微尘数金刚力士。其名曰坚固光耀力士。日光耀力士。须弥华力士。净云音力士。阿修罗主力士。胜光明力士。树音声力士。师子王力士。淳厚光藏力士。珠髻华光力士。与如是等诸力士俱。已于阿僧祇劫。发大誓愿。侍卫诸佛。佛愿行处皆已具足。无量功德皆已清净。悉行深广三昧境界。无量神力佛所游处。无不遍至。皆悉能行不可思议解脱境界。处一切众其身殊特无能映蔽。随诸众生所应度者。能现其身如应化之。复有佛世界微尘数诸道场神。其名曰净庄严神。宝积光明神。吼音声神。雨众华神。庄严宝光神。善超香神。金色云神。乐华树神。庄严光神。与如是等道场神俱。皆于先佛造立愿行。复与佛世界微尘数诸龙神俱。其名曰摩尼光龙。杂庄严龙。喜宝光龙净身光龙。香庄严龙。宝目光龙。如是一切皆于过去不可思议阿僧祇劫。常为如来庄严法堂。复与佛世界微尘数诸地神俱。其名曰净华光神。善思光明神。杂华庄严神。散宝焰神。随时乐观神。金眼胜神。毛孔散香神。应时和音神。如是一切皆同德本。于过去佛所普修愿行。复与不可思议诸树神俱。其名曰杂华云神。杂种光神。净胜光神。垂庄严神。庄严光神。乐和音神。普胜等神。华果味神。如是一切皆悉成就大喜普照。复与无边药草神俱。其名曰光焰神。栴檀香神。净光神。普称神。普力神。普净神。普光神。爱香神。胜现神。如是一切皆悉成就大悲普照。复与无量诸谷神俱。其名曰胜味神。华净神。善力神。势味神。根果神。净华神。乐净神。净光神。如是一切大喜成就。复与无量诸河神俱。其名曰普流神。胜洄澓神。洪流声神。养水性神。净海光神。普爱神。妙幢神。胜水神。海具光神。如是一切常能精勤利益众生。复与不可思议诸海神俱。其名曰宝胜光明神金刚慧神。普涌浪神。杂华龙胜神。宝华光明神。须弥庄严神。海音声神。如是一切以佛无量功德之海而自充满。复与无量阿僧祇诸火神俱。其名曰炽然光藏神。炽然光轮神。广明耀神。无尽神。杂宝胜神。照除诸冥神。焰云光明神。如是一切悉为众生照除闇冥。复与无量诸风神俱。其名曰无碍照明虚空神。遍超胜神。散须弥神。焰净味神。净除味神。发行大音神。树峰华林神。持世界神。如是一切皆能和合众生令不分散。复与无边虚空神俱。其名曰普光净胜神。无边深广神。起风神。离一切障神。广超神。无对光焰神。无碍力胜神。最上妙音神。示现十方神。如是一切心皆无垢坚固净妙。复与无量主方神俱。其名曰善住神。充满神。无量现光神。光庄严神。普转渐行神。不惑转神。净游虚空神。普行世间神。行甚深神。如是一切皆能善照一切众生。复与无量主夜神俱。其名曰妙光神。净光神。善观众生神。静时坚固神。方便胜具神。生一切树果神。无尽眷属神。主知乐净游戏神。和诤神。净福具神。如是一切于助道法深重爱乐。复与无量主昼神俱。其名曰现宫殿神。善解安立战场神。乐庄严普胜神。喜华香神。普集胜药神。乐见王神。净目高显普胜神。大悲艳光神。光明善照神。普胜垂华神。如是一切皆悉信乐正法庄严。复与无量阿修罗神俱。其名曰罗睺罗王。毗摩质多罗王。睒婆利王。明月王。金刚坚锦王。大智慧力王。胜集天女王。如是一切悉能降伏憍慢放逸。复与无量伽留罗王俱。其名曰大勇猛力王。无畏宝髻王。勇猛净眼王。不退庄严王。持大海光王。持法坚固王。胜根光明王。充满普现王。普游诸方王。普眼等观王。如是一切成就方便广润众生。复与无量紧那罗王俱。其名曰善慧王。善幢王。杂华行王。离爱慢音王。宝树光明王。善爱现王。庄严光王。善华幢王。胜地王。胜慧王。如是一切普于众生精勤劝发能使乐法。复与无量摩睺罗伽王俱。其名曰善慧王。净端严音王。众妙慧聚王。灯幢王。猛光王。师子香熏王。杂璎珞音王。坚固乐明王。如是一切普为众生除诸疑网。复与无量鸠槃荼王俱。其名曰毗楼勒王。善修幢王。足平鲜白王。能除恐怖王。净须弥林王。无量净眼王。无量目门王。如是一切皆悉修习无碍法门。复与无量鬼神王俱。其名曰毗沙门王。大音声王。净地王。大主王焰眼王。坚固眼王。庄严胜军王。大富净身王。须弥力王。如是一切普能勤护一切众生。复与无量月身天子俱。其名曰月天子。曜华天子。胜流庄严天子。乐诸世乐天子。眼光天子。净光天子。普游净光天子。星宿王天子。净觉天子。端严善光天子。如是一切勤以智慧普发众生无上宝心。复与无量日天子俱。其名曰日天子。眼焰光天子。须弥光胜天子。净宝眼天子。勇猛不退天子。妙华鬘光天子。宝觉天子。明眼天子。胜地童天子。普胜光天子。如是一切皆悉成就清净善根。常欲饶益一切众生。复与无量三十三天王俱。其名曰释提桓因天王。普称满天王。髻目天王宝光称天王。乐喜天王。乐念天王。胜音天王。净华天王。如是一切皆悉具足清净善业。能令众生生净妙处。复与无量夜摩天王俱。其名曰善时天王。无尽智天王。妙善化天王。乐乐焰天王。须弥光天王。不思议慧天王。脐轮天王。不思议天王。月姿颜天王。普庄严天王。如是一切皆悉勤修出生欢喜信乐知足。复与无量兜率天王俱。其名曰善喜天王。海乐天王。胜德天王。百光明天王。善眼天王。宝山月天王。超勇月天王。金刚善曜天王。乐超天王。如是一切皆悉成就念佛三昧。复与不可思议化乐天王俱。其名曰善化天王。净光天王。最上云音天王。妙色庄严天王。乐智慧天王。华光月天王。照方天王。如是一切皆悉成就寂静法门调伏众生。复与无量他化自在天王俱。其名曰自在转天王。善眼天王。杂宝冠天王。精进慧天王。众华音天王。乐光明天王。寂静处天王。杂色轮天王。智慧妙光天王。大力光天王。如是一切普皆勤修自在正法。复与不可思议大梵天俱。其名曰尸弃大梵。智光大梵。善光大梵。普音大梵。随世音大梵。寂静方便妙光大梵。净眼光大梵。柔软音大梵。如是一切悉具大慈度脱众生。照除热恼清凉柔软。复与无量光音天子俱。其名曰乐光天子。净光天子。大音天子。乐净音天子。善思音天子。解脱音天子。深妙音天子。无垢光天子。最高净光天子。如是一切安住喜光寂静法门。复与阿僧祇遍净天俱。其名曰净智王天。现胜天。寂胜天。须弥时天。念净眼天。无上爱光天。世慧音天。智慧炽然天。乐法化心天。化高天。如是一切常令众生安住广乐。复与无量果实天子俱。其名曰法华光天。净坚固天。慧光天。智慧王天。普门慧眼天。不转爱天。无垢静光天。净曜天。如是一切皆悉善住寂静意门。复与摩醯首罗天等无量净居天俱。其名曰善光天。大主天。大称光天。功德净眼天。大智慧光天。不动光音天。善施眼天。乐大乘天。普音声天。乐称光天。如是一切已修无相平等法界。悉在如来大众海数。于一切众生悉行平等。无量妙色皆已成就。于十力中能善安住。处一切众而不倾动。随所至方无能坏者。如来所乘常现在前。离烦恼障其心清净。诸结使山皆已摧灭。睹佛姿颜无量妙色光明普照。所以者何。如来往昔。于无量劫行菩萨道时。以四摄法善摄众生。于诸如来集诸善根。种种因缘。方便教化立如来道。深植无量如来善根。皆令安立一切智道。逮得无量功德势力。皆悉成就如来愿海。菩萨所行具足清净。各随本行皆得出要。悉由如来光明照故。乘解脱力入如来海。于佛法门悉得自在

善海摩醯首罗天。于法界虚空寂静方便光明法门。而得自在。大自在称光明天。于一切法普游法门。而得自在。功德净眼天。于一切法不生不灭方便法门。而得自在。大慧光天。于一切法方便智海游光法门。而得自在。静光音天。于一切禅无量喜乐普起法门。而得自在。施善眼天。于转痴畏游静法门。而得自在。不思议天。于无量境界入不起法门。而得自在。乐大乘天。于一切法不来不去无所依住法门。而得自在。普杂音天。于佛境界寂静法门。而得自在。乐称光天。于无量境界法门。而得自在。尔时善光海大自在天。以如来神力故。观察一切自在天众。以偈颂曰

  无尽平等妙法界　　悉皆充满如来身
  无取无起永寂灭　　为一切归故出世
  诸佛法王出世间　　能立无上正教法
  如来境界无边际　　世间自在称无上
  佛难思议无伦匹　　相好光明照十方
  大圣世尊正教道　　犹如净眼观明珠
  一切世间众生类　　不能思议佛功德
  消灭一切愚痴闇　　超升无上智慧台
  如来功德难思议　　众生见者烦恼灭
  得见不动自在尊　　能生无量悦乐心
  众生大海痴蔽心　　为现寂静微妙法
  能然无上智慧灯　　是则方便真净眼
  如来清净妙色身　　悉能显现遍十方
  此身非有无所依　　如是见佛真实观
  如来音声无挂碍　　应受化者无不闻
  湛然不动无往返　　是名善慧乐法门
  一切十方无边佛　　寂静法门天人主
  如来光明靡不照　　是庄严幢妙法门
  佛于无边诸劫海　　常求正觉悟众生
  无量方便化一切　　清净广称如是见

复有乐业光明天王。于观一切众生诸根法云法门而得自在。净坚固天。于一切佛妙色方便念观法门而得自在。乐乐天王。于一毛孔见不思议诸佛国土境界法门而得自在。普门慧眼天。于入普门观察法界法门而得自在。不转爱天于转一切众生处处受生法门而得自在。善慧光天。于入一切世间境界不可思议法门而得自在。无垢净光天。于一切众生一切法中出要法门而得自在。无垢光天。于受化者能使入佛境界法门而得自在。尔时乐业光明天王。承佛神力。观察一切果实天众。以偈颂曰

  一切佛境界　　甚深难思议
  诸余众生类　　莫能测量者
  如来善开导　　无量诸群生
  能令悉愿乐　　志求无上道
  佛以神通力　　住世普开化
  一切众生类　　各随其所闻
  痴惑障永除　　慧命净无秽
  能睹诸如来　　众妙净法海
  诸法真实相　　寂灭无所依
  如来方便力　　能为众生现
  如来于诸法　　无性无所依
  而能现众像　　显相犹明灯
  以诸缘譬谕　　方便随所乐
  为现诸如来　　智慧神通力
  因悟各异门　　无量难思议
  为建正法幢　　令入功德海
  如来神通力　　能于一毛孔
  各为众演说　　无上寂灭法
  一一诸如来　　各为其眷属
  显法无量门　　功德之大海
  皆悉师子吼　　演说诸佛法
  是则大智尊　　无上方便力
  十方诸佛土　　一切群生类
  悉能为彼现　　如来之正法
  如来未曾有　　去来之异相
  皆令彼欢喜　　不退慧境界
  如来为众生　　普现业报相
  犹若日光照　　众像靡不现
  又为彼众生　　演说寂灭法
  令彼见真实　　甚深智慧处
  如来自观察　　甚深微妙义
  随彼众生根　　普雨甘露法
  为开诸法门　　无量难思议
  悉归入寂灭　　平等真实观
  无数无量劫　　广修习大悲
  逮成等正觉　　度脱群生类
  普雨甘露法　　随器皆充满
  如龙兴庆云　　等雨于一切

复有净智天王。于观察众生善根法门而得自在。显妙天王。于一切有觉照法门而得自在。胜妙天王。于总持辩才法门而得自在。普灯天王。于乐佛出世解脱法门而得自在。智焰天王。于一切众生甚深法中能生欢喜法门而得自在。乐化天王。于化菩萨功德周备入无尽法门而得自在。踊化天王。于普观无量苦恼众生慈悲智满法门而得自在。尔时净智天王。承佛神力。普观遍净天众。以偈颂曰

  诸佛正法无障碍　　周满十方无量界
  现佛境界难思议　　离垢法门无量海
  如来处世无所依　　法身清净无起灭
  而能照现无量土　　一切悉见天中天
  无量劫海修方便　　光明普照十方界
  清净法界如如住　　寂灭微妙最无上
  众生愚痴瞽心目　　无眼轮回生死中
  如来导以清净道　　开示无上最胜门
  如来所乘无上道　　一切众生莫能思
  佛现一切妙色门　　善念乐观净眼见
  佛说微妙总持门　　如一切刹微尘等
  调伏一切众生故　　清净慧眼能照见
  如来出世甚难值　　无量亿劫时一遇
  离诸难处适众会　　唯佛世尊能应时
  一切众生难思议　　佛能悉现净妙法
  睹见如来无量德　　犹如明照见众像
  三世诸佛所得法　　教化众生难思议
  悉观念此功德已　　乐法踊跃大欢喜
  众生没在烦恼海　　愚痴邪浊大恐怖
  佛以慈悲究竟度　　见净境界如天幢
  佛放无量大光明　　一一光明无量佛
  无数方便皆悉现　　化度一切众生类

复有爱乐天子。于寂静爱乐灭众生苦法门而得自在。妙杂光天。于诸众生心净离垢广修德海法门而得自在。自在音天。于一切众生一劫所修功德于一念中出生法门而得自在。胜念智天。于世间生住灭种种清净功德法门而得自在。净乐音天。于一切菩萨在兜率宫广说供养法门而得自在。善思音天。于一劫中说诸地义以一念顷悉能受说法门而得自在。解脱光音天。于庄严道场法门而得自在。甚深音天。于无尽神足诸功德海法门而得自在。离垢称天。于一切佛诸功德海境界法门而得自在。出净光天。于过去诸佛愿力所持欢喜功德力藏法门而得自在。尔时光音天子。承佛神力。遍观光音天众。以偈颂曰

  我忆如来过去行　　我行供养亦忆念
  如本所修清净喜　　佛光明故今悉见
  如来无垢庄严身　　增长众生清净心
  安住慈悲喜舍中　　是名庄严净法门
  如来广大方便法　　无量劫海所修集
  彼生灭法如如相　　法主音声方便门
  如来神力遍十方　　普照无量诸佛刹
  十方诸佛皆悉现　　胜念方便灭愚痴
  无量刹海尘数佛　　供养恭敬生欢喜
  故能断除群生闇　　是名妙音胜境界
  无量劫海甚弥旷　　说方便地无伦匹
  所演妙法无穷尽　　心方便门得自在
  如来无量自在力　　于念念中普示现
  降神成道权无量　　是则名为妙法门
  佛持深广无与等　　神足示现不可量
  能令诸根悉清净　　得住甚深微妙地
  如来智慧无边际　　行净无比无挂碍
  普见一切两足尊　　无上离垢称方便
  于过去世菩萨时　　供养无量诸佛海
  立大誓愿难思议　　是故逮得无上智

复有尸弃大梵天。于照现诸法入不思议法门而得自在。智光明梵。于一切禅等观寂静善住法门而得自在。智光心梵。于照诸法不可思议入方便法门而得自在。普音云梵。于一切佛妙音声海平等度入法门而得自在。应时音梵。于摄伏众生最胜法门而得自在。寂静光梵。于一切刹能起安住分别诸法法门而得自在。喜光梵。于无量方便化众生法门而得自在。坚固梵。于诸法净相住寂行法门而得自在。乐目光梵。于一切有无来无去无所依止勇猛法门而得自在。柔软音梵。于无尽法随行普照法门而得自在。尔时尸弃大梵。承佛神力。遍观一切诸大梵众。以偈颂曰

  佛身清净常寂然　　普照十方诸世界
  寂灭无相无照现　　见佛身相如浮云
  一切众生莫能测　　如来法身禅境界
  无量方便难思议　　是智慧光照法门
  一佛刹尘诸法海　　一音演说悉无余
  此辩尘劫演不尽　　是名光照心法门
  如来妙音深满足　　众生随类悉得解
  一切皆谓同其语　　梵音普至最无上
  十方三世佛所得　　一切菩萨方便行
  悉于如来身中现　　而于佛身无分别
  佛身如空不可尽　　无相无碍普示现
  所可应现如幻化　　神变净音靡不周
  佛身无边如虚空　　智光净音亦如是
  佛于诸法无障碍　　犹如月光照一切
  法王安住妙法堂　　法身光明无不照
  法性如实无异相　　是名乐音海法门

复有自在天王。于教化无量众生藏法门而得自在。善眼光天。令诸众生得最上乐法门而得自在。杂宝冠天。于解众生无量性欲方便法门而得自在。精进善慧天。于众生分别义法门而得自在。勇妙杂音天。于诸众生慈念观察法门而得自在。光明乐幢天。于诸众生超出魔事法门而得自在。净境界天。于诸众生念化法门而得自在。杂色轮天。于念充满十方诸佛法门而得自在。智华妙光天。于佛功德自在觉悟充满念随顺法门而得自在。大力光天。于离世间境界法门而得自在。尔时自在天王。承佛神力。遍观一切自在天众。以偈颂曰

  如来法身等法界　　普应众生悉对现
  如来法王化众生　　随顺诸法悉调伏
  世间一切上妙乐　　圣寂灭乐为最胜
  无垢妙法如来室　　清净胜眼如实见
  如来普照诸世间　　疑地枯林降法雨
  众生蒙润疑网除　　是宝冠幢妙法门
  如来所演一妙音　　广大法海说无余
  佛以一音遍十方　　是名胜勇善法门
  一切十方诸佛土　　入佛一毛犹不满
  佛以大慈如虚空　　是名清净慧法门
  一切众生慢高山　　佛以十力碎无余
  佛慈光明照十方　　是名光幢妙法门
  得睹如来灭痴惑　　净见智慧悉充满
  永离恶趣诸恐怖　　是名寂境妙法门
  如来毛孔悉放光　　随其所应得闻法
  普导众生至善趣　　是名善幢妙法门
  一切十方诸佛事　　此众一切悉得见
  如来法界满虚空　　是名净华胜法门
  无量劫海诸佛国　　皆是最胜慧境界
  如来于此无高心　　是大力幢妙法门

复有善化天王。于一切法分别化法门而得自在。静光时天。于观一切有及我真实法门而得自在。化力光天。于诸众生离痴智慧满足法门而得自在。难胜天于诸佛音声发起一切欢喜勇猛法门而得自在念光天。于一切佛相好功德具足无尽法门而得自在。踊云音天。于净智慧次第忆念过去无量劫法门而得自在。净光胜天。于一切众生长养种种功德智慧法门而得自在。乐光髻天。于一切空界结跏趺坐无碍法门而得自在。乐智慧天。于一切方便境界无尽力法门而得自在。华光髻天。于诸众生业行苦乐等观法门而得自在。尔时善化天王。承佛神力。遍观化乐天众。以偈颂曰

  法身于世难思议　　如来普现应众生
  缘性无造非真实　　行业庄严现世间
  方便求佛无所有　　揽之十方不可得
  法身示现无真实　　出生自在如是见
  无量劫海修诸行　　断除众生愚痴冥
  如来智慧甚清净　　是名佛慧除痴力
  一切世界妙音声　　悉无能及如来音
  一音远震遍十方　　是名胜音妙法门
  一切众生诸功德　　不及如来一相福
  佛德如空无边际　　是名生光妙法门
  三世无量劫中事　　世界成败种种相
  于一毛孔悉能现　　是名清净无上智
  求空边际犹可得　　佛一毛孔无涯限
  佛德如是不思议　　是名如来净知见
  佛于先世无量劫　　具满一切波罗蜜
  勤修精进无厌怠　　是名乐见净法门
  行业因缘难思议　　佛为众生说无余
  普现诸法净无秽　　是名无上深法门
  观见如来一毛孔　　一切众生悉入中
  众生亦无往来想　　是名诸方照法门

复有兜率天王。于成就诸佛转法轮法门而得自在。乐宝髻天。于虚空界净光法门而得自在。胜幢天。于广愿海入诸众生寂静法门而得自在。百光明天。于一切法无量无相观行法门而得自在。超踊月天。于佛境界超踊觉力法门而得自在。胜眼光天。于喜修集不可沮坏菩提心法门而得自在。宿庄严天。于诸十方佛调伏众生方便法门而得自在。乐静妙天。于无边心海念念回向随器普现法门而得自在。尔时兜率天王。承佛神力。遍观兜率天众。以偈颂曰

  如来普周等法界　　为垢众生出现世
  随诸所欲为说法　　是名无上胜法王
  如来宿世无量行　　清净愿海具足满
  一切诸法悉周备　　是名方便胜功德
  如来法身不思议　　法界法性辩亦然
  光明普照一切法　　寂静诸法皆悉现
  众生痴闇结业障　　高心放逸驰境界
  如来为说寂灭法　　欢喜善乐悉能见
  一切世间最上归　　救护群生除众苦
  众生乐观无上尊　　犹如满月显高山
  诸佛境界不思议　　一切法界亦如是
  于诸法力悉究竟　　定慧方便皆成就
  清净境界功德海　　一切众生有缘者
  闻佛功德发菩提　　消除尘垢成最胜
  如世界海微尘数　　诸佛子等悉来集
  供养如来听受法　　悉睹法幢方便王

复有夜摩天王。于诸众生离忧回向善根法门而得自在。悦乐光天。于诸境界法门而得自在。无尽慧天。于离诸患具大慈悲法门而得自在。净庄严天。于分别诸根法门而得自在。持须弥天。于无量总持照明法门而得自在。不思议慧天。于诸境界业行真实不思议法门而得自在。脐轮天。于转法轮调伏众生法门而得自在。不思议光天。于众生界胜眼普观法门而得自在。月姿颜天。于诸法实普现法门而得自在。普音遍观天。于诸天众所应施作心净法门而得自在。尔时夜摩天王。承佛神力。遍观夜摩天众。以偈颂曰

  佛于无量大劫海　　生死烦恼永已尽
  能教众生清净道　　佛为一切智慧灯
  如来法身甚弥旷　　周遍十方无涯际
  智慧光明方便力　　寂灭禅乐亦无边
  生老病死忧悲苦　　毒害逼切恼众生
  为斯等类起慈悲　　以无尽智示菩提
  如来智慧随顺觉　　了达三世无障碍
  一切善行悉了知　　是名乐化明法门
  无量总持无边际　　如来辩海无穷尽
  能转清净妙法轮　　是名须弥总持门
  无上大圣一妙身　　应化周满一切世
  悉现一切众生前　　是名善光胜境界
  众生一见如来身　　悉能断除众烦恼
  远离一切诸魔事　　是名清净妙境界
  佛于一切大众海　　处此众会悉遍照
  普为众生雨法雨　　是名普音称法门

大方广佛华严经卷第一大方广佛华严经卷第二

        东晋天竺三藏佛驮跋陀罗译

    世间净眼品第一之二

复有释提桓因。于三世佛出兴住灭决定大智念喜法门。而得自在。普称满天。于众生色如来色身诸功德力清净法门。而得自在。慈眼天。于平等慈云荫覆法门。而得自在。宝光称天。于众光色具足念佛普势法门。而得自在。乐喜髻天。于观众生业报法门。而得自在。乐念净天。于诸佛国具净法门。而得自在。须弥胜音天。于观世间生灭法门。而得自在。念智慧天。于起当来菩萨诸行化众生因超念法门。而得自在。净华光天。于一切天娱乐法门。而得自在。慧日眼天。于诸天处教化流通善根法门。而得自在。尔时释提桓因。承佛神力。遍观三十三天众。以偈颂曰

  若念一切三世佛　　广能观察佛境界
  诸佛国土成败事　　以佛神力皆悉见
  佛身清净满十方　　妙色无比应一切
  光明照耀最殊特　　具足广称如是见
  本修方便大慈海　　充满一切诸众生
  悉能调伏一切众　　开清净眼见无极
  念佛功德无量故　　得生广大欢喜心
  世间无与如来等　　离垢称王住法门
  清净业海满众生　　一切悉见无有余
  种种因起深广福　　如是善见犹满月
  诸佛充满遍十方　　一切众生无不见
  既得见已悉调伏　　皆得无上方便念
  如来智身明净眼　　周遍一切十方刹
  悉令众生皆睹见　　妙音宣化无不解
  佛一毛孔现众行　　佛子见已具修习
  具足成就无量德　　如是善慧犹满月
  一切众生得悦乐　　皆因如来神力生
  如来无量功德故　　是名无垢杂华门
  若能须臾念如来　　乃至一念功德力
  永得远离众恶趣　　智慧日光灭痴闇

复有日光天子。于照十方诸众生身尽未来际正住庄严法门。而得自在。眼焰光天。于照诸色无上智海法门。而得自在。须弥光天。于起众生转胜清净功德法门。而得自在。净宝月天。于乐度一切苦行法门。而得自在。勇猛不退天。于无障碍普照法门。而得自在。妙华光天。于净日光照众生身法门。而得自在。胜光天。于光照世间积集功德法门。而得自在。宝髻天。于众宝海现种种色境界法门。而得自在。明眼天。于一切趣开清净眼观法界藏法门。而得自在。胜地天。于诸众生净乘法门。而得自在。尔时日光天子。承佛神力。遍观日天子众。以偈颂曰

  佛慧光明无边际　　普照十方无量土
  令一切众面睹佛　　种种方便化众生
  众生大海广无量　　悉能具足知其心
  开发众生智慧海　　善胜光明如是见
  如来普为出兴世　　遍照十方悉无余
  如来法身无等等　　以无上智演说法
  无数劫海诸有中　　难行苦行为众生
  是故净光如虚空　　妙身显现犹满月
  佛演妙音无障碍　　周遍十方悉无余
  分别广演一切法　　因缘方便具足说
  放大光明不思议　　十方世界悉明净
  令人欢喜发道意　　是名庄严胜法门
  一切世间诸光明　　不及佛身一毛光
  佛光微妙难思议　　最胜能现此神变
  一切诸佛法如是　　各坐十方道树下
  为众分别道非道　　清净妙眼如是见
  痴冥众生盲无目　　为斯苦类开净眼
  为彼示现智慧灯　　得见如来清净身
  方便自在无倒惑　　悉应堪受一切供
  渐教开示解脱道　　是名净眼方便地
  于一法门说无边　　无数劫中广敷演
  分别深远清净义　　是名周遍妙法门

复有月天子。于调伏众生普照法界法门。而得自在。耀华天。于普观摄一切诸法境界法门。而得自在。胜光庄严天。于诸众生心海境界皆悉令转法门。而得自在。杂乐世间天。于能生一切不可思议爱乐法门。而得自在。眼光天。于令众生实见法门。而得自在。现净光天。于大慈悲救护一切苦恼众生法门。而得自在。普游静光天。于无痴净月法门。而得自在。妙庄严天。于观诸法如幻如化空无法门。而得自在。净菩提天。于善解一切业行所起法门。而得自在。大光焰天。于灭诸天疑照度法门。而得自在。尔时月天子。承佛神力。遍观月天子众。以偈颂曰

  普于众生放大光　　十方国土见如来
  照除一切愚痴闇　　明了不可思议法
  佛界无边不可尽　　无量劫中集功德
  种种方便妙法门　　调伏一切众生类
  如来智慧甚深远　　知他无量诸心海
  随顺为转净法轮　　令生无量欢喜心
  众生远离贤圣乐　　没在世间无量苦
  佛与斯等清净法　　心得悦乐安隐住
  如来普放大光明　　分别世间诸法相
  罪福报应不败亡　　清净光天如是见
  佛是一切众生地　　能持无量善果报
  悉令众生离邪道　　善能安立方便地
  大慈悲云靡不覆　　佛身难思等众生
  普雨法雨润一切　　是佛第一上方便
  一切有无性如空　　佛是众生大光明
  常勤方便利一切　　最胜清净如是见

复有持国乾闼婆王。于摄一切众生娱乐方便法门。而得自在。乐树光乾闼婆。于佛功德庄严法门。而得自在。起净眼乾闼婆。于众生离忧喜法门。而得自在。华树乾闼婆。于灭结使法门。而得自在。乐游行乾闼婆。于调伏希望法门。而得自在。妙眼乾闼婆。于一切乐喜光藏正住法门。而得自在。师子幢乾闼婆。于一切方雨宝法门。而得自在。宝光解脱乾闼婆。于现一切妙身广智法门。而得自在。金刚树乾闼婆。于长养诸树喜光法门。而得自在。现诸庄严乾闼婆。于一切佛诸境界行悉令众生受乐法门。而得自在。尔时持国乾闼婆王。承佛神力。遍观乾闼婆众。以偈颂曰

  如来境界无量门　　一切众生莫能思
  世尊清净如虚空　　开示众生见正道
  如来无量功德海　　一一毛孔悉得见
  能令一切随意乐　　清净悦乐如是见
  众生无量忧苦海　　佛能除灭悉无余
  佛以大慈多方便　　能开众生清净眼
  诸佛刹海满十方　　如来光明悉遍照
  能除众生烦恼垢　　演说甚深清净法
  佛于无量诸劫海　　方便广修净国土
  以一切智无上音　　安慰无边众生类
  乐见如来普清净　　众生悉得无尽乐
  随顺能起解脱因　　得解脱冠心欢喜
  愚痴障盖甚坚固　　众生轮转生死海
  如来示现广大法　　演说清净建法幢
  一切众生无量门　　如来为现种种形
  多方便门照众生　　爱音如来如是现
  如来方便无边际　　善逝具足广开现
  入最胜道方便行　　金刚树下成正觉
  以无量劫为一念　　佛力能现亦不积
  能与众生一切乐　　是名乐见方便门

复有毗楼勒鸠槃荼王。于能灭一切斗诤法门。而得自在。长灯照光鸠槃荼。于一切行现前法门。而得自在。善修幢鸠槃荼。于专正诸趣法门。而得自在。饶益诸行鸠槃荼。于善恶平等清净法门。而得自在。除恐怖鸠槃荼。于一切众生无畏安隐庄严法门。而得自在。净娑罗林。鸠槃荼于除灭。无量众生爱海炽然法门。而得自在。起须弥鸠槃荼。于一切趣照明云法门。而得自在。常勤鸠槃荼。于普照法门。而得自在。无量净眼鸠槃荼。于起不退转大慈藏法门。而得自在。无量门鸠槃荼。于起一切趣所作法门。而得自在。尔时毗楼勒鸠槃荼王。承佛神力。遍观鸠槃荼众。以偈颂曰

  如来忍力成满足　　无量劫行为众生
  离放逸慢诸烦恼　　故佛身净照十方
  昔行菩萨诸行海　　调伏十方无量众
  种种方便起慈门　　令众生得一切智
  如来智慧济群生　　悉分别知众生心
  无量自在调众生　　一切见者皆欢喜
  佛神力境难思议　　于当来世一切劫
  转实法轮犹虚空　　无量众生得净眼
  众生痴垢翳心目　　如来照除见正道
  救济永离无量苦　　令无恐怖得净智
  众生没在爱苦海　　如来智照灭无余
  离欲无垢见佛身　　犹如宝树悉清净
  佛身普应无不见　　种种方便化众生
  音如雷震雨法雨　　是名山王慧法门
  佛光无垢最清净　　照除众生痴冥山
  显现如来无量德　　无痴方便见佛身
  无量劫修大悲门　　悉与众生自在乐
  种种方便灭众苦　　离垢清净如华敷
  最胜现身悉周遍　　于十方界无去来
  自觉大圣一切现　　是无量门佛能见

复有毗楼波叉龙王。于一切龙趣中除灭炽然恐怖救济法门。而得自在。海龙王。于一念中能转一切不可思议龙身法门。而得自在。云乐妙幢龙。于一切有趣转清净轮闻声法门。而得自在。须弥普幢龙。于一切众生示大功德海法门。而得自在。德叉伽龙。于离恐怖清净法门。而得自在。无量步龙。于示现一切众生无量云超度无量劫住寿法门。而得自在。焰眼善住龙。于安立一切世界分别无量佛法示现方便法门。而得自在。离垢势色龙。于一切众生离垢欢喜知足入方便法门。而得自在。普行广圣龙。于一切善恶音声具满平等观法门。而得自在。阿那婆达多龙王。于大悲云荫覆一切众生离苦法门。而得自在。尔时毗楼波叉龙王。承佛神力。遍观龙众。以偈颂曰

  观见一切最胜法　　救济十方群生类
  恶趣众生常轮转　　以大悲力能济拔
  随诸众生所乐色　　佛一毛孔皆悉现
  神足境界无有量　　佛功德海清净现
  最胜妙法无限量　　譬如大海深无底
  随其所乐令得闻　　妙声柔软发雷音
  一切众生嗔恚心　　荫盖障覆愚痴海
  如来无上大慈悲　　以神足力度脱之
  于如来身一毛孔　　众生功德皆悉现
  入深无量功德海　　须弥山幢功德现
  众生种种恐怖苦　　法王智光悉救济
  最胜毛孔演妙音　　无量众生开净眼
  十方三世诸如来　　于佛身中现色像
  无量劫中净佛土　　是名无上大龙地
  佛一毛中皆悉现　　无量神变庄严土
  佛与眷属围绕坐　　为众生说微妙法
  佛为菩萨求道时　　恭敬供养诸佛海
  种种无量方便门　　度脱一切众生海
  如来演说正法时　　充满一切众生乐
  佛音能起欢悦心　　普令众生得法喜

复有毗沙门夜叉王。于平等观方便离一切恶饶益众生法门。而得自在。音主夜叉。于一切普胜法门。而得自在。持地夜叉。于能除夺众生精气长养一切生气法门。而得自在。一切主夜叉。于观一切圣功德法门。而得自在。胜眼神足夜叉。于观一切众生智慧法门。而得自在。坚固金刚眼夜叉。于与一切众生安乐法门。而得自在。护命夜叉。于持力救济法门。而得自在。能破须弥山夜叉。于起随顺佛力法门。而得自在。尔时毗沙门夜叉王。承佛神力。遍观夜叉众。以偈颂曰

  众生罪垢甚深重　　于百千劫不见佛
  轮转生死受众苦　　为度是等佛兴世
  佛为救济一切故　　悉现十方众生前
  拔济诸趣众苦轮　　因缘音主最方便
  众生重罪恶业障　　佛以方便悉除灭
  安立众生正法中　　是名离痴方便见
  佛昔无量劫行时　　赞叹十方一切佛
  故有高远大名称　　皆悉普闻十方国
  佛慧无边等虚空　　如来法身不思议
  故能显现照十方　　明净眼王妙法门
  一切众生入邪径　　佛示正道难思议
  见诸众生堪受化　　种种方便令调伏
  一切众生诸功德　　不及如来一光福
  佛智慧海不可议　　是名宝王如是见
  无量劫数难思议　　佛于是中修十力
  是故世尊力具足　　一切世间无能坏

复有金刚眼照力士。于示现如来无量色像法门。而得自在。离垢日踊力士。于诸佛无量色法门。而得自在。须弥华光力士。于离垢自在种种现法门。而得自在。净云音力士。于如来无边净音不可量法门。而得自在。阿修罗主力士。于一切示现种种法门。而得自在。金刚光乐力士。于入一切佛法无余法门。而得自在。雷音力士。于能举一切诸天法门。而得自在。师子端严王力士。于如来功德广照法门。而得自在。胜光明力士。于除灭众生恶心安立佛境法门。而得自在。珠髻华光力士。于菩萨示现一切世间雨宝法门。而得自在。尔时金刚眼照力士。承佛神力。遍观力士众。以偈颂曰

  普为三界一切众　　于诸法中为法王
  具足无量众妙色　　悉照十方无不明
  佛身一切诸毛孔　　普放光明不可议
  映蔽一切日光明　　遍照十方靡不周
  如来大圣自在力　　充满一切诸法界
  法身示现无涯际　　悉现一切众生前
  佛音清净甚深妙　　普震十方诸世界
  柔软微妙和雅音　　灭众生垢愿满足
  十方三界诸宫殿　　最胜悉现于彼坐
  一一佛所无量众　　导师处中为说法
  法海无量无有边　　众方便门悉入中
  分别一切诸法界　　最胜示现无穷尽
  众生大海无边际　　最胜净眼能度脱
  如来光明照众生　　一切普见大导师
  悉皆恭敬兴供养　　无量尘海国土佛
  功德无量如虚空　　一切悉见大导师
  如来神力不可坏　　一切佛土皆悉现
  如来安坐净道场　　一切众生现前见
  光明普照如云兴　　众妙庄严光圆满
  普照一切诸法界　　示现诸佛深妙法

是时普贤菩萨。成就不可思议方便法门海。能入如来无量功德海。所谓出生究竟净诸佛土调伏众生法门。诣诸佛所能起一切具足功德法门。菩萨诸地愿行法门。普门示现法界尘数身云法门。持诸佛土不可思议方便轮法门。一切众中自在显现无量无边菩萨境界法门。于一念中知三世劫生灭法门。分别显现一切菩萨诸根境界海法门。其身自在充满无量无边法界法门。一切菩萨种种方便广分别法入一切智方便法门。尔时普贤菩萨。遍观一切大众。以偈颂曰

  最胜严净　　无数佛土　　无量净色
  甚深功德　　真净离垢　　佛子充满
  常闻妙法　　不思议音　　见佛处此
  师子座上　　一切尘中　　亦复如是
  而如来身　　亦不往彼　　普现佛土
  功德境界　　悉入无量　　诸地方便
  佛示一切　　诸菩萨行　　说诸方便
  不可思议　　令诸佛子　　入净法界
  离垢净眼　　住深法性　　十方无量
  无有边际　　微尘数等　　诸化佛身
  教导无量　　众生等类　　一切十方
  如来刹土　　世尊皆悉　　为平等护
  佛于方便　　悉已清净　　调伏众生
  令除垢秽　　一切尘数　　诸佛国土
  如来示现　　无量自在　　梵音和雅
  遍诸道场　　演畅最胜　　菩萨本行
  一切三世　　所有劫数　　于念念中
  悉见无余　　观彼生灭　　如实法相
  不可思议　　世护能见　　无量大众
  数不可尽　　如来真子　　欲观佛地
  一切法门　　无量无边　　非诸佛子
  所有境界　　离垢如来　　犹如虚空
  清净无著　　等真法性　　现化无量
  不可穷尽　　悉坐道树　　成等正觉
  佛以一言　　说一切地　　一切法相
  皆悉穷尽　　无量方便　　一一门中
  演畅诸法　　亦悉无余

尔时于佛师子之座。一切妙华摩尼宝轮高台楼观庄严具中。一一各出一佛世界微尘数等大菩萨众。其名曰海慧超越菩萨。无量师子吼菩萨。众宝光幢菩萨。智日超慧菩萨。不思议功德智称菩萨。方便寂静妙华髻菩萨。金光焰菩萨。法界普音菩萨。净云月幢菩萨。善超净光菩萨。如是等一一佛世界微尘数等大菩萨众。设诸供养散众妙华充满虚空。烧诸杂香气过腾云。普现一切众宝圆光。又放无量净日光明。作众妓乐诸微妙音。杂种宝树枝叶华实一切光明犹若云起雨无量宝。如是一一菩萨所供养具。各与一佛世界微尘数等。一一供具复与一佛世界微尘数等。皆大欢喜。供养世尊绕百千匝已。随其所应供养大众。犹如云雨而无断绝。随所出方。化作宝莲华藏师子之座。恭敬向佛结跏趺坐。彼菩萨等。悉得无量清净法海普明法门。于佛境界无所障碍。悉入一切辩才法海。又得不可思议照明法门。正住如来普门境界。三世智地皆已得入。具足成就大力法爱。无量功德清净圆满。常行法界毕竟空性。悉已具足供养诸佛。尔时一切海慧自在智明王菩萨。以偈颂曰

  佛觉诸法　　平等真实　　无有障碍
  净如虚空　　普悉照明　　十方世界
  处一切众　　最胜殊特　　自然正觉
  无量无边　　充满十方　　众生境界
  一切悉坐　　菩提树王　　诸众生主
  皆悉围绕　　佛有如是　　自在神力
  于一念顷　　现无量身　　普令众生
  灭除垢秽　　如来境界　　无有边际
  无量劫海　　具足修行　　如来处在
  一切有海　　种种方便　　调伏众生
  皆悉受行　　最胜正法　　众会离垢
  普得清净　　一切观佛　　深乐无厌
  最胜妙相　　庄严具足　　处莲华藏
  宝师子座　　一切众宝　　诸庄严具
  皆出无量　　微妙香熏　　杂色华鬘
  悬布虚空　　佛处如是　　宝师子座
  无量众宝　　流出妙光　　晖焰清净
  十方明耀　　如来安住　　庄严楼观
  演出清净　　微密梵音　　宣畅最胜
  无上正法　　闻者欢喜　　得净妙道
  金刚承座　　安峙坚固　　如意藏宝
  以为庄严　　宝髻菩萨　　常守护之
  世尊于此　　普现照明　　天尊处在
  宝师子座　　遍照三世　　一切导师
  无量化佛　　遍满十方　　阐扬如来
  无尽法藏

尔时佛神力故。莲华藏庄严世界海。六种十八相震动。所谓。动。遍动。等遍动起。遍起。等遍起觉。遍觉。等遍觉。震。遍震。等遍震。吼。遍吼。等遍吼。涌。遍涌。等遍涌。又令一切世界诸王。各雨不可思议诸供养具。供养如来大众海会。所谓雨一切香华云。众妙宝云。杂宝莲华云。无量色宝曼陀罗云。解脱宝云。碎末栴檀香云。清净柔软声云。宝网日云。各随其力雨众供养。如是等一一世界诸王。设不可思议诸供养云。普供一切如来大众。如此世界设众供养。一切十方诸佛国土亦复如是。此世界中佛坐道场。世界诸王各随所乐境界三昧诸方便门。欢喜厌离通达诸方勇猛之法。如来境界神力所入。诸佛无量法海之门。皆已得度。如此世界。十方一切世界亦复如是

    大方广佛华严经卢舍那佛品第二之一

尔时诸菩萨众。及一切世界诸王。咸作是念。何等是一切诸佛地。佛境界。佛持。佛行。佛力。佛无畏。佛三昧。佛自在。佛胜法。示现菩提。佛眼耳鼻舌身意诸根。佛光明音声。佛智海。世界海。众生海。法界方便海。佛海。波罗蜜海。法门海。化身海。佛名号海。佛寿量海。一切菩萨所修行海。发大乘心。出生诸波罗蜜愿智慧藏。唯愿如来慈悲方便。发起我心令得开解。时诸菩萨神力故。一切供养具中。出自然音而说偈言

  如来无量旷劫行　　自然正觉出世间
  于当来世无量劫　　身应一切如大云
  断众生疑永无余　　出生胜力得解脱
  灭除世间无量苦　　令一切得正觉乐
  无量刹尘诸菩萨　　一心合掌观最胜
  随彼所愿诸境界　　断除疑惑开法门
  何等一切诸佛地　　大圣境界佛诸持
  佛无上智力无畏　　愿为佛子平等现
  无量如实诸三昧　　诸清净行深妙法
  大圣神力无有边　　兴大雷云雨众生
  悉入法王如实趣　　于最胜境不退转
  及无量佛诸功德　　愿起慈悲悉令见
  如来眼根无限量　　耳鼻舌身亦如是
  佛意如实难思议　　愿令众生悉知见
  佛国土海众生海　　诸法界海调伏海
  佛海无量无边际　　愿令佛子平等见
  波罗蜜海不思议　　无上方便法门海
  无量无边法门海　　愿在道场具足说

尔时世尊。知诸菩萨心之所念。即于面门及一一齿间。各放佛世界尘数光明。所谓宝幢照光明。法界妙音庄严光明。生乐垂云光明。佛十种力严净道场光明。一切宝焰云光明。清净无碍充满法界光明。能成一切世界光明。净宝金刚日幢光明。往诣菩萨大众光明。演出诸佛语轮光明。如是等一一光明。各有佛世界尘数光明。以为眷属。一一光明。照十佛土微尘等刹。彼诸菩萨见此光已。得睹莲华藏庄严世界海。佛神力故。于光明中而说偈言

  无量劫海修功德　　供养十方一切佛
  教化无边众生海　　卢舍那佛成正觉
  放大光明照十方　　诸毛孔出化身云
  随众生器而开化　　令得方便清净道
  佛于往古生死中　　调伏一切诸群生
  于一念中悉解脱　　世雄无量得自在
  深心净信普庄严　　往修满足波罗蜜
  与诸刹海尘数等　　坚固安住一切力
  出微妙音遍十方　　具足实智满众心
  无量方便化众生　　是师子吼寂静法
  人尊如是德无量　　应诣供养听受法
  如佛刹等微尘数　　最胜诸子诣如来
  各雨一切供养具　　一心恭敬观导师
  如来所说一语中　　演出无边契经海
  于一切众雨甘露　　恭敬往诣两足尊
  三世诸佛无上愿　　大圣道场分别说
  亦非集在一念中　　宜速时诣觐最胜
  卢舍那佛大智海　　光明普照无有量
  如实观察真谛法　　普照一切诸法门

尔时莲华藏庄严世界海东。次有世界海。名净莲华胜光庄严。中有佛刹。名众宝金刚藏。佛号法水觉虚空法王。于彼如来大众海中。有菩萨名观胜法妙清净王。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。充满十方一切虚空。兴十种宝色光明华云。悉皆弥覆充满虚空。十种妙宝须弥山云。十种日轮云。十种宝华云。十种妙宝楼阁藏云。十种华树云。十种妙香现众色云。十种一切妙音声云。如是一切悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在于东方杂华光藏师子座上。结跏趺坐。此世界海南。次有世界海。名众宝月光庄严藏。中有佛刹。名无量光严。佛号普智光胜须弥山王。于彼如来大众海中。有菩萨名清净海慧。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切妙庄严藏众宝王云。悉皆弥覆充满虚空。十种普庄严宝王云。十种妙宝藏炽然照明叹佛功德宝王云。十种妙音充满赞叹宝王云。十种菩提树庄严道场宝王云。十种普门光明佛变化宝王云。十种不坏众光明示现宝王云。十种香灯照一切刹充满宝王云。十种不可思议佛刹如来宫殿普现宝王云。十种杂宝三世诸佛法身光明宝王云。悉皆弥覆充满虚空。来诣佛所恭敬供养礼拜已。在于南方青色莲华师子座上。结跏趺坐。此世界海西。次有世界海。名宝光乐。中有佛刹。名一切胜观。佛号香光王功德宝庄严。于彼如来大众海中。有菩萨名香焰平等庄严月光。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切杂宝香华楼阁云。悉皆弥覆充满虚空。十种一切色宝王庄严楼阁云。十种一切宝幢香焰楼阁云。十种一切解脱庄严楼阁云。十种一切宝华鬘云。十种一切宝鬘庄严宝楼阁云。十种一切普光明藏照一切庄严楼阁云。十种一切宝庄严无量庄严悉现楼阁云。十种普满庄严楼阁云。十种无量华乐云。悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在于西方金色杂宝庄严莲华藏化师子座上。结跏趺坐。此世界海北。次有世界海。名琉璃宝光充满藏。中有佛刹。名化青莲华庄严。佛号无量智慧音王。于彼如来大众海中。有菩萨名师子光庄严。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切香云。悉皆弥覆充满虚空。十种一切青色华云。十种一切妙宝树云。十种一切诸杂华云。十种一切宝庄严云。十种一切宝雷音云。十种一切妙音声云。如是一切悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在于北方大灯变化师子座上。结跏趺坐。此世界海东南方。次有世界海。名阎浮檀玻璃色幢。中有佛刹。名宝庄严藏。佛号一切法灯无所怖畏。于彼如来大众海中。有菩萨名无尽胜灯功德法藏。为佛光明所开发已。与世界海尘数菩萨眷属围绕。来向佛所。兴十种无量色莲华藏师子座云。悉皆弥覆充满虚空。十种师子座云。十种一切庄严具庄严师子座云。十种灯明师子座云。十种能出十方一切众宝师子座云。十种一切香鬘师子座云。十种一切诸佛庄严示现师子座云。十种一切宝台栏楯庄严师子座云。十种一切宝树庄严师子座云。十种日庄严师子座云。皆悉弥覆充满虚空。来诣佛所供养恭敬礼拜已。在东南方夜光幢宝藏师子座上。结跏趺坐。此世界海西南方。次有世界海。名普照庄严。中有佛刹。名香胜离垢光明。佛号一切众生普欢喜王。于彼如来大众海中。有菩萨名普智光明慧灯。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种如意宝王云。悉皆弥覆充满虚空。十种青色宝云。十种一切香云。十种一切幡云。十种一切妙色庄严云。悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在西南方众宝师子座上。结跏趺坐。此世界海西北方。次有世界海。名善光照。中有佛刹名意入。佛号普门智慧意入明净音。于彼如来大众海中。有菩萨名无量华照垂髻。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切杂宝轮盖云。悉皆弥覆充满虚空。十种华盖云。十种解脱盖云。十种宝王盖云。十种杂宝盖云。十种普宝盖云。十种琉璃宝王盖云。十种一切香盖云。悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在西北方众善光明幢师子座上。结跏趺坐。此世界海东北方。次有世界海。名宝照光明藏。中有佛刹。名香庄严乐胜藏。佛号无量功德海。于彼如来大众海中。有菩萨名无尽清净光明王。为佛光明所开发已与世界海尘数菩萨眷属围绕来向佛所。兴十种一切宝光轮云。悉皆弥覆充满虚空。十种光轮云。十种华云。十种如来变化轮云。十种一切佛境界轮云。十种一切功德宝云。十种一切众生乐不可尽示现云。十种一切诸佛所愿示现云。悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在东北方清净光明不可尽师子座上。结跏趺坐

大方广佛华严经卷第二大方广佛华严经卷第三

        东晋天竺三藏佛驮跋陀罗译

    卢舍那佛品第二之二

此世界海下方。次有世界海。名莲华妙香胜藏。中有佛刹。名宝师子光。佛号明照法界。于彼如来大众海中。有菩萨名光照分别法界。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切宝光明云。悉皆弥覆充满虚空。十种一切香光明云。十种诸佛师子吼云。十种一切佛刹功德庄严云。十种一切华楼阁云。十种一切座庄严云。悉皆弥覆充满虚空。来诣佛所。在于下方宝藏师子座上。结跏趺坐。此世界海上方。次有世界海。名杂宝光海庄严。中有佛刹名乐行清净。佛号无碍功德称离闇光王。于彼如来大众海中。有菩萨名无障碍力精进慧。为佛光明所开发已。与世界海尘数菩萨眷属围绕来向佛所。兴十种一切无量妙色宝照云。悉皆弥覆充满虚空。十种无量光普照云。十种一切庄严照明云。十种香焰云十种一切庄严云。十种佛光焰云。十种宝树华焰云。十种一切宝树坚固光明云。十种一切胜光明云。十种一切菩萨所行示现云。十种一切解脱光明云。悉皆弥覆充满虚空。来诣佛所供养恭敬礼拜已。在于上方妙音胜莲华藏师子座上。结跏趺坐。如是等十亿佛刹尘数世界海中。有十亿佛刹微尘数等大菩萨来。一一菩萨各将一佛世界尘数菩萨。以为眷属。一一菩萨各兴一佛世界微尘数等妙庄严云。悉皆弥覆充满虚空。随所来方结跏趺坐

彼诸菩萨次第坐已。一切毛孔各出十佛世界微尘数等一切妙宝净光明云。一一光中各出十佛世界微尘数菩萨。一一菩萨一切法界方便海充满一切微尘数道。一一尘中有十佛世界尘数佛刹。一一佛刹中三世诸佛皆悉显现。念念中于一一世界。各化一佛刹尘数众生。以梦自在示现法门教化。一切诸天化生法门教化。一切菩萨行处音声法门教化。震动一切佛刹建立诸佛法门教化。一切愿海法门教化。一切众生言辞入佛音声法门教化。一切佛法云雨法门教化。法界自在光明法门教化。建立一切大众海于普贤菩萨法门教化。以如是等一切法门。随其所乐而教化之。于一念顷。能灭一切世界中各如须弥山尘数众生诸恶道苦。各如须弥山尘数众生令离邪定立正定聚。各如须弥山尘数众生令立声闻缘觉之地。各如须弥山尘数众生立无上道。各如须弥山尘数众生立一切不可尽功德智慧地。各如须弥山尘数众生令立卢舍那佛愿性海中。尔时诸菩萨光明中。以偈颂言

  一切光明出妙音　　说诸菩萨具足行
  佛子功德悉成满　　普遍一切十方界
  无量劫海修行道　　欲令众生离苦故
  不自计己生死苦　　佛子善入大方便
  无量无边无有余　　穷尽一切大海劫
  遍行一切诸法门　　善说微妙寂静法
  一切三世佛所愿　　皆得清净具足满
  佛子饶益诸众生　　能自具行清净道
  皆能往诣诸佛所　　清净法身照十方
  佛子智海无边底　　普观诸法寂灭相
  一光明中有无量　　无上大慈难思议
  清净慧眼照诸法　　此是佛子妙境界
  一毛悉受诸佛刹　　又能震动诸国土
  能令众生无怖想　　是名清净方便地
  一一尘中无量身　　复现无量庄严刹
  于一念中皆悉见　　是无障碍净法门
  三世所有一切劫　　于一念中能悉现
  犹如幻化无所有　　是名诸佛无碍法
  普贤诸行皆具足　　能令众生悉清净
  诸佛子具自在法　　一一毛孔师子吼

尔时世尊。欲令一切菩萨大众。知佛无量无边境界自在法门故。放眉间白毫相一切宝色灯明云光。名一切菩萨慧光观察照十方藏。此光遍照一切佛刹。于一念中。皆悉普照一切法界。于一切世界。雨一切佛诸大愿云。显现普贤菩萨。示大众已。还从足下相轮中入。于彼复有大莲华生。以众宝为茎。一切宝王为庄严藏。其叶遍覆一切法界。一切宝香庄严其须。阎浮檀金以为其台。此华生已。如来眉间有一大菩萨出。名曰一切诸法胜音。与世界。海尘数菩萨众俱。敬绕世尊无量匝已。退坐莲华台上。眷属菩萨坐莲华须。一切诸法胜音菩萨成就无量法界欢喜。随顺诸佛境界深智。度不可思议佛海光明。悉能往诣一切佛所。尔时一切诸法胜音菩萨。以偈颂曰

  佛身充满诸法界　　普现一切众生前
  应受化器悉充满　　佛故处此菩提树
  一切佛刹微尘等　　尔所佛坐一毛孔
  皆有无量菩萨众　　各为具说普贤行
  无量刹海处一毛　　悉坐菩提莲华座
  遍满一切诸法界　　一切毛孔自在现

尔时师子焰光奋迅音菩萨。以偈颂曰

  卢舍那如来　　转清净法轮
  一切法方便　　如来云普覆
  十方国土中　　一切世界海
  佛愿力自在　　普现转法轮
  一切佛土中　　无量大众海
  言号各不同　　而转净法轮
  卢舍那佛神力故　　一切刹中转法轮
  普贤菩萨愿音声　　遍满一切世界海
  法身充满一切刹　　普雨一切诸法雨
  法相不生亦不灭　　悉照一切诸世间
  无量无数亿劫中　　一切佛刹微尘道
  卢舍那佛妙音声　　具足演说本所行
  一切佛刹微尘数　　大光明网照十方
  一一光中有诸佛　　以无上道化众生
  法身坚固不可坏　　充满一切诸法界
  普能示现诸色身　　随应化导诸群生
  三世无量诸佛刹　　其中一切诸导师
  一切音声及名字　　普见诸佛力自在
  过去未来及现在　　如是一切诸导师
  彼圣能令一切闻　　不可思议正法轮

如此四天下道场上见佛神力一切菩萨大众云集。一切世界海中亦复如是

尔时普贤菩萨。于如来前。坐莲华藏师子之座。即入一切如来净藏三昧正受。普照一切法界诸如来身无所障碍。离垢满足犹如虚空。普贤菩萨。于此世界三昧正受。尽法界虚空界等一切佛刹亦复如是。普贤菩萨。入是三昧已。十方世界海诸佛悉现。彼诸如来各各赞言。善哉善哉。善男子。汝乃能入此三昧正受。是皆卢舍那佛本愿力故。又汝于诸佛所清净行愿力故。所谓转一切诸佛法轮故。开一切如来智慧海故。尽度一切诸法方便及十方海悉无余故。除一切众生烦恼得清净故。能到一切诸佛国土无障碍故。入一切诸佛境界无碍故。一切诸佛普门功德满足故。入一切法方便深乐一切智故。方便观察一切世间法故。知一切众生诸根海故

尔时一切诸佛。与普贤菩萨入一切智力。与入无量无边法界智。与能诣三世诸佛所智。与一切世界海成坏智。与入无量众生界智。与佛甚深法门智。与一切不坏三昧住智。与入一切菩萨诸根海智。与一切众生语言海转法轮辞辩智。与一身遍满一切世界智。与一切诸佛音声智。何以故。以得此三昧法故

尔时十方诸佛各申右手。摩普贤菩萨顶。尔时一切菩萨。见十方诸佛各申右手摩普贤菩萨顶已。彼诸菩萨。一心恭敬观察普贤菩萨。即时同声以偈颂曰

  于诸佛所修善法　　满足一切大愿力
  出生清净妙法身　　如实平等同虚空
  一切诸佛国土中　　普贤菩萨常依住
  十方世界无不见　　无量功德智慧海
  悉见十方一切佛　　清净身行功德海
  能于一一微尘道　　普皆示现一切刹
  一切十方佛世界　　无量微尘诸劫数
  常见普贤真佛子　　无量三昧方便行
  法身充满诸法界　　一切十方佛国土
  遍游一切众生海　　安住深妙清净法
  永度无量诸法界　　离众烦恼不可坏
  其身周遍满虚空　　广说无量诸佛法
  一切功德海中生　　普放光明如大云
  坚固众生清净行　　微妙音说佛境界
  无量无数大劫中　　修习普贤甚深行
  无量无边诸法云　　雷震演说胜法界
  一切佛土如实性　　十力修集净庄严
  普入一切众生海　　如应为说清净法
  无量无边大众海　　一心恭敬观普贤
  无量深广智慧海　　愿转清净妙法轮

尔时普贤菩萨。承佛神力。观察一切诸世界海。一切众生海。法界业海。一切众生欲乐诸根海。一切三世诸佛海已。普告菩萨大众海言。佛子。诸佛一切世界海成败清净智。不可思议一切众生界起智。观察法界智。一切如来自在智。清净愿转法轮智。力无所畏不共法智。光明赞叹音声智。三种教化众生智。无量三昧法门不坏智。如来种种自在智。如是等一切皆不可思议。我当承佛神力具足演说。欲令一切众生入佛智海

尔时普贤菩萨。从彼三昧起。从世界微尘等三昧起。念念中不坏方便智一切三世三昧起。时彼一切诸菩萨众。一一皆得世界尘数诸三昧。世界尘数方便法海。方便辩海。诸行愿海。如此会菩萨所得功德。一切世界海。一切如来众海。诸菩萨众所得功德亦复如是。是时一切世界六种震动。一切众生安隐悦乐。一切众宝种种庄严。一切如来大众海中。雨十种宝王云。所谓胜金色幢宝王云。佛光明照宝王云。金莲华宝王云。菩萨辩才光明宝王云。一切妙音众宝王云。庄严佛土道场宝王云。一切菩萨无量功德光明轮妙音宝王云。一切如来毛孔及诸光明。以偈颂曰

  普贤悉在　　一切佛刹　　坐宝莲华
  师子座上　　如是示现　　遍一切界
  普入无量　　无边诸行　　悉能示现
  无量种身　　变化充满　　十方世界
  妙音和雅　　说法无碍　　一切三昧
  方便自在　　一切佛土　　诸如来所
  一切三昧　　皆得自在　　悉能了知
  最胜境界　　示现普贤　　无量自在
  如一切土　　诸如来前　　一切刹尘
  诸世界中　　普贤自在　　亦复如是
  尽卢舍那　　本愿底故　　普贤身相
  犹如虚空　　依于如如　　不依佛国
  现身无量　　普应众生　　随群萌类
  为现化故　　一切世界　　无量佛土
  悉能示现　　入诸法门　　普贤菩萨
  具足净愿　　如是等比　　无量自在
  一切众海　　无量无边　　各于佛土
  示现清净　　如是一切　　身中悉现
  随其起灭　　一念悉知

尔时普贤菩萨。欲令大众重欢喜故。以偈颂曰

  诸佛深智功德海　　充满无量无边刹
  方便随众所应见　　卢舍那佛转法轮
  不可思议佛刹海　　于无量劫令清净
  最胜导师照一切　　悉能调伏众生海
  众生大海难可测　　诸佛境界不思议
  众生乐恶着诸有　　不能了知无上道
  功德法海长养心　　常能亲近善知识
  恒为诸佛所护念　　是等能度得上智
  离诸谄曲心清净　　广大慈悲无边际
  深心净信无厌足　　彼闻是法喜无量
  普贤菩萨诸地愿　　安谛善住能顺行
  游心法界如虚空　　是人乃知佛境界
  一切菩萨得善利　　能见自在最胜尊
  非余境界之所知　　普贤方便皆得入
  无量无边诸众生　　一切如来所护念
  于一切处转法轮　　卢舍那佛境界力
  一切刹土及诸佛　　在我身内无所碍
  我于一切毛孔中　　现佛境界谛观察
  普贤菩萨所愿行　　无量无边悉具足
  普眼境界清净身　　我今演说仁谛听

尔时普贤菩萨。告诸菩萨言。佛子。世界海有十种事。去来今佛之所演说。所谓说世界海。起具因缘世界海。住世界海。形世界海。体世界海。庄严世界海。清净世界海。如来出世世界海。劫世界海。坏方便世界海。诸佛子世界海。有如是等十种事为首。乃至有世界海尘数种事。诸佛子当知。一切世界海。有世界海尘数因缘具故成。已成今成当成。所谓如来神力故。法应如是故。众生行业故。一切菩萨应得无上道故。普贤菩萨善根故。菩萨严净佛土愿行解脱自在故。如来无上善根依果故。普贤菩萨自在愿力故。如是等世界海尘数因缘具故。一切世界海成。尔时普贤菩萨。以偈颂曰

  佛智境界　　不可思议　　自在善住
  悉皆如是　　无量无边　　诸世界海
  卢舍那佛　　悉能严净　　如应化度
  一切菩萨　　无量愿海　　皆悉清净
  十方佛土　　一切众生　　以不思议
  而觉悟之　　一切菩萨　　无量自在
  度一切智　　方便法门　　出生一切
  无量愿海　　起诸世界　　犹如虚空
  普行一切　　菩萨善行　　入佛境界
  无量无边　　悉能严净　　十方佛刹
  一一佛土　　无量劫行　　众生心境
  不可思议　　业能悉起　　一切刹海
  众生垢秽　　国不清净　　行业无量
  世界不同　　诸佛刹海　　净庄严藏
  离垢杂宝　　以为校饰　　长养无垢
  弘誓愿海　　佛子能净　　无数国土
  若有菩萨　　修普贤行　　常能履行
  清净法界　　当知是等　　功德如佛
  能出无量　　如来刹海　　于一念中
  悉遍十方　　能现一切　　菩萨所行
  甚深清净　　犹如虚空　　等空界者
  自在如是　　一切道场　　诸如来前
  坐宝莲华　　现众妙色　　于其身内
  容一切刹　　又一念中　　示现三世
  入巧方便　　起诸刹海　　于三世国
  示现成佛　　卢舍那佛　　此土清净
  众宝成就　　无有边际

尔时普贤菩萨。告诸菩萨言。佛子。一一世界海所依住。如世界微尘数。所谓依一切庄严住。或依虚空住。或依一切宝住。或依佛光明住。或依幻业住。或依摩诃那伽金刚力士掌中住。或依普贤菩萨愿力住。是时普贤菩萨。以偈颂曰

  无量无边佛刹海　　离垢妙宝以庄严
  摩尼宝王清净照　　最胜威神靡不见
  清净刹海住虚空　　宝王妙藏光普照
  畅发无量微妙音　　宣扬佛道靡不欣
  种种华光善喜乐　　如意宝珠为庄严
  无量光网弥覆上　　种种香云遍充满
  无量无边妙莲华　　青琉璃宝以为台
  清净国土甚奇妙　　一切诸佛庄严故
  或有诸佛清净土　　以佛威神得安住
  见离垢净众妙宝　　无量菩萨悉充满
  或有诸佛清净土　　金刚力士掌中住
  十力世雄卢舍那　　常为一切转法轮
  或依宝树平正住　　依香焰云亦如是
  有依水轮住坚固　　或依金刚海座住
  有住金刚胜妙幢　　种种宝华弥覆上
  无量自在一切处　　卢舍那佛令众见
  众杂异色长光明　　普流一切佛世界
  悉见种种庄严藏　　离垢微妙甚清净
  彼以一切愿海力　　无量种种所依住
  诸如来云悉充满　　常依清净虚空住
  或有佛刹处上方　　依净菩萨天冠住
  彼现无量佛自在　　佛子妙音净业化
  诸法界等佛国土　　譬如电光亦如幻
  绀琉璃宝广清净　　悉从离垢净业起
  普现种种庄严藏　　依止虚空静安住
  行业境界不可议　　佛令众生普得见
  一切尘等诸佛刹　　普贤菩萨一念起
  无量劫行化众生　　充满法界现自在
  一一微尘中　　佛国海安住
  佛云遍护念　　弥纶覆一切
  于一微尘中　　佛现自在力
  一切微尘中　　神变亦如是
  诸佛及神力　　卢舍那示现

尔时普贤菩萨。告诸菩萨言。佛子。诸世界海有种种形。或方或圆。或非方圆。或如水洄澓。或复如华形。或种种众生形者。尔时普贤菩萨。以偈颂曰

  刹海无有量　　殊形异庄严
  十方世界海　　见诸杂种相
  或圆或四方　　或复非方圆
  三维及八隅　　状若摩尼宝
  一切诸业海　　种种别异故
  有如金刚掌　　庄严坦平正
  炼真金色　　清净妙形　　入于无量
  正法之门　　诸佛刹海　　种种之藏
  犹如大云　　悬处虚空　　彼宝轮地
  妙净分明　　卢舍那佛　　光明悉照
  诸佛国土　　起由心业　　无量种形
  而以庄严　　彼国一切　　各各自在
  如来刹海　　现无量相　　或有净秽
  苦乐不同

  法常流转　　变现如是　　一切业海
  不可思议　　一毛孔中　　无量佛刹
  庄严清净　　旷然安住　　彼一切处
  卢舍那佛　　于众海中　　演说正法
  于一尘内　　微细国土　　一切尘等
  悉于中住　　一切世界　　有种种形
  悉于其中　　转尊法轮　　是弘誓愿
  自在之力　　一一尘中　　现一切刹
  譬如幻化　　亦如虚空　　诸心业力
  之所庄严　　一一尘中　　众生数等
  诸化佛云　　神力自在　　于微尘中
  善住佛刹　　卢舍那佛　　现法如是

尔时普贤菩萨。告诸菩萨言。佛子。诸世界海有种种体。悉应当知。所谓一切宝庄严体。或一宝体。或金刚坚固地体。或众香体。或日珠轮体。尔时普贤菩萨。以偈颂曰

  或有世界海　　众宝所合成
  坚固不可坏　　安住宝莲华
  或胜光明起　　清净晖焰照
  众妙庄严刹　　依止虚空住
  或有光明刹　　依止光明住
  光明云庄严　　诸菩萨宫殿
  或有佛刹海　　犹如电光住
  言取不可得　　斯由愿力起
  或有摩尼宝　　日光明藏照
  贯真珠轮地　　菩萨悉充满
  或有宝焰刹　　光明云荫覆
  一切宝庄严　　悉皆有变化
  或有众相体　　微妙相庄严
  间错杂宝冠　　一切佛所化
  心海业所起　　国土随乐住
  谕如幻无方　　皆从妄想生
  如来身光明　　摩尼刹安住
  正觉云弥覆　　一切佛自在
  或普贤菩萨　　化现佛刹海
  一切宝校饰　　愿力所庄严

尔时普贤菩萨。告诸菩萨言。佛子。诸世界海。有世界海微尘等庄严。悉应当知。所谓一切境界种种云庄严。一切世界众生行业庄严。三世诸佛及普贤菩萨愿力庄严。有如是等世界海微尘数庄严。尔时普贤菩萨。以偈颂曰

  如世界海微尘等　　不可思议业果报
  一切十方世界海　　种种严净广无边
  无量净色普庄严　　上妙功德常充满
  杂光明云出梵音　　闻于一切诸佛刹
  菩萨无量功德海　　妙声遍满一切刹
  诸誓愿云具庄严　　声震十方世界海
  众生业海广无际　　净庄严云出妙音
  业报如宝随应变　　诸佛力故悉周满
  一切三世诸如来　　自在普现无量刹
  一一境界一切佛　　庄严刹海皆悉见
  过去未来现在劫　　一切十方诸世界
  于无量劫净庄严　　一一佛刹皆悉见
  一切境界诸佛云　　数等众生满十方
  佛自在行令众知　　是谓如来庄严刹
  众香焰流及华流　　一切众宝摩尼流
  种种众妙庄严云　　皆悉校饰诸佛刹
  十方世界诸道场　　一切众具妙庄严
  靡不睹见此刹海　　犹如空中电光现
  普贤菩萨佛子等　　悉能庄严诸佛刹
  众生等劫净行海　　于此世界悉显现

尔时普贤菩萨。告诸菩萨言。佛子当知。诸世界海。有世界尘数清净。所谓菩萨亲近善知识。成就诸善根。等利一切众生。净满一切诸波罗蜜。安住一切行地。有如是等世界尘数清净。尔时普贤菩萨。以偈颂曰

  一切佛刹诸庄严　　无数愿海方便生
  一切佛刹清净色　　无量行海所修集
  久远亲近善知识　　一切净妙诸业行
  慈悲普流润众生　　是故清净佛刹海
  一切法门三昧地　　一切佛所净德海
  禅门方便清净地　　是故严净佛刹海
  能起无量清净心　　信佛坚固不可坏
  以忍方便净无垢　　庄严刹海微妙色
  兴功德云满虚空　　利益一切修净行
  众生普获无量德　　是故严净佛刹海
  刹海方便等无量　　悉净诸度无有余
  修无尽愿波罗蜜　　是故严净佛刹海
  幻化行起无有量　　一切诸法广清净
  种种方便净众生　　起是可乐佛刹海
  方便严净一切地　　具足诸佛功德海
  令诸众生竭苦源　　是故严净佛刹海
  修净力海无与等　　能净一切众生根
  恭敬供养无量佛　　是故严净佛刹海

尔时普贤菩萨。告诸菩萨言。佛子当知。一一世界海。有世界海尘数诸佛。出兴于世。所谓有佛兴世。色身示现遍满法界。或有短寿。或无量劫。如是一一世界海。有世界海尘数佛出兴于世。尔时普贤菩萨。以偈颂曰

  佛以无量方便门　　能起一切佛刹海
  随顺众生所欲乐　　诸佛法王出兴世
  如来法身不思议　　无色无相无伦匹
  示现色身为众生　　十方受化靡不见
  或为众生现短命　　或现长寿无量劫
  法身多门现十方　　常为世间良福田
  或有能令不思议　　十方刹海悉清净
  或有能净一刹土　　是彼方便愿所立
  或说不可思议乘　　佛普示现随所乐
  或有如来说一乘　　是佛方便无有量
  自然无师得正觉　　或有济度少众生
  或有能于一念中　　化度无量众生海
  或有于一毛孔中　　化佛云出不思议
  充满一切十方界　　无量方便化众生
  或佛音声震十方　　随诸众生所欲乐
  无量亿劫不断绝　　度众生海无有边
  或有无量庄严刹　　清净大众围绕坐
  充满一切世界海　　佛遍处众如空云
  是佛方便不思议　　慈海充满遍一切
  入诸庄严方便门　　悉现一切众生前

尔时普贤菩萨。告诸菩萨言。佛子当知。世界海。有世界海微尘等劫住。所谓佛刹海。或住不可数劫。或住可数劫。有如是等世界海微尘数劫住

尔时普贤菩萨。欲分别开示故。告一切众言。诸佛子。当知此莲华藏世界海。是卢舍那佛。本修菩萨行时。于阿僧祇世界微尘数劫之所严净。于一一劫。恭敬供养世界微尘等如来。一一佛所。净修世界海微尘数愿行。佛子当知。有须弥山微尘等风轮。持此莲华藏庄严世界海。最下风轮名曰平等。彼持一切宝光明地。次上风轮名种种宝庄严。持清净光宝地。次上风轮名功德势。持密宝地。次上风轮名曰宝焰。持日不坏宝地。次上风轮名普庄严。持具足宝光明地。次上风轮名离垢清净平等。持宝华焰地。次上风轮名曰方行。持一切真珠地。次上风轮名曰一切年。持一切时一日半月一月一年。次上风轮名普持势。持一切须弥山地。次上风轮名庄严光明。能持一切有。如是次上。有须弥山微尘等风轮。最上风轮名胜藏。持一切香水海。彼香水海中有大莲华。名香幢光明庄严。持此莲华藏庄严世界海。此世界海边有金刚山周匝围绕。尔时普贤菩萨。以偈颂曰

  于此莲华藏　　庄严世界海
  一切妙宝藏　　种种净光明
  一切微尘等　　过去佛所住
  昔于诸有海　　离垢悉清净
  无量大悲云　　充满诸众生
  舍离自己身　　如佛刹尘数
  于无量行海　　常修令清净
  是故莲华藏　　世界海庄严
  一切虚空界　　光明遍充满
  安住不可动　　胜风轮常持
  一切宝庄严　　妙风常流行
  卢舍那旷愿　　令国土严净
  如意宝遍布　　种种妙华敷
  以本愿力故　　处在于虚空
  坚固善安住　　一切宝庄严
  十方一切界　　放清净光云
  诸摩尼宝中　　无量菩萨云
  遍游十方国　　光明极炽盛
  宝华盛妙色　　庄严光明轮
  充满诸法界　　十方靡不遍
  一切众净宝　　悉放光明云
  十方诸世界　　一切皆充满
  灭除一切苦　　安立无上道
  妙色悉普照　　一切世界海
  于此莲华藏　　世界海之内
  一一微尘中　　见一切法界
  一切诸佛云　　放宝光明照
  是卢舍那刹　　有无量自在
  一切众生等　　莲华中诸佛
  兴种种无量　　自在变化云
  释梵诸天众　　及转轮圣王
  一切众生类　　皆悉得安住
  变化放光明　　悉与法界等
  一切光明中　　出诸佛妙音
  知诸众生心　　所念无有余
  无数方便门　　调伏群生类
  离一切颠倒　　常住于寂静
  无量光明云　　悉与法界等
  普贤所行智　　无上胜妙地
  于光庄严中　　皆悉具足闻

佛子当知。此莲华藏世界海金刚围山。依莲华日宝王地住。彼有一切香水海。一切众宝遍布其地。金刚厚地不可破坏。出生一切众宝。又能明照一切世界。尔时普贤菩萨。以偈颂曰

  一切世界海　　有无量庄严
  宝轮无边色　　如来神力起
  庄严斫迦罗　　宝轮及香轮
  依住真珠轮　　及依种种宝
  坚固宝庄严　　阎浮檀净藏
  香光满十方　　照现斫迦罗
  持以坚固金刚宝　　金刚庄严不可坏
  种种众宝相庄严　　一切庄严清净法
  香水普流无量色　　散华摩尼栴檀香
  天衣遍覆华庄严　　众宝香华熏无量
  清净宝树云庄严　　普能照明一切身
  光明妙云悉具足　　树下安坐靡不照
  种种华香及幡盖　　一切菩萨充法界
  能说一切语言海　　是卢舍那转法轮
  彼处悉有珍宝幢　　一切宝树出光明
  卢舍那佛身清净　　彼庄严内一切见
  诸庄严中无数身　　如来变化色无量
  充满一切十方界　　调伏众生无限量
  一切庄严出妙声　　卢舍那佛所愿轮
  随其清净佛刹海　　佛自在力皆悉闻

彼大斫迦罗山内世界海中。有不可破坏摩尼宝王。映现一切众生之身。众宝莲华以为庄严大地。一切庄严妙云皆悉充满。一切妙香而以熏之。以三世佛刹庄严而庄严之。尔时普贤菩萨。以偈颂曰

  其地平正净圆满　　斫迦罗内不可坏
  平等安住甚清净　　种种杂宝而庄严
  金刚宝地可悦乐　　宝轮罗网弥覆上
  种种宝华为庄严　　杂种宝衣珍妙轮
  随次遍布一切地　　菩萨天冠宝璎珞
  离垢庄严光明照　　妙香碎宝悉充满
  光明众宝华庄严　　普放一切满十方
  宝华遍覆一切地　　悉能长养佛功德
  兴一切云满虚空　　光明普照不可尽
  光明悉满一切刹　　具说佛法甘露味
  悉入一切佛所愿　　常能广见三世法
  随顺菩萨大士行　　于此大地皆悉见
  此清净地宝庄严　　一切佛刹悉来入
  其地一一微尘中　　一切佛刹亦悉入
  众宝妙华庄严藏　　十方菩萨常往来
  常闻菩萨一切愿　　及诸菩萨自在德
  有宝光明相庄严　　离垢严净出光明
  示现一切诸佛法　　充满法界如虚空
  有得普贤所愿者　　诸佛境界无量智
  彼得无量胜自在　　能入无边佛刹海

彼大地处。有不可说佛刹微尘等香水海。众宝庄严。一切香摩尼宝王。以为其岸。宝王罗网弥覆其上。众宝色水盈满其中。一切众华皆悉开敷。细末栴檀以香其水。常出如来妙音不绝。众香次第普熏十方。杂宝阶道真珠栏楯。众宝潮浪出妙音声。恒沙佛刹微尘数等宝华楼阁。周匝围绕。无量佛刹微尘等众宝华城。以周其外。十大千世界微尘数华。一一莲华各十由旬。开敷鲜茂遍布水上。其香普熏一切世界。十佛国土尘数香树。以为庄严。尔时普贤菩萨。以偈颂曰

  于彼严净大地处　　香水宝海而庄严
  清净宝地常安住　　金刚坚固不可坏
  众香宝王以为岸　　宝云光明如日照
  真珠宝华妙璎珞　　离垢清净普庄严
  清净香水湛然满　　众宝华光为旋流
  妙声悦乐常不断　　自在普闻佛世界
  众珍校饰净阶道　　宝庄严地安不动
  真珠妙宝为栏楯　　光明宝华可悦乐
  宝树罗生缘道侧　　摩尼宝乐焕明耀
  演出无量和雅声　　庄严净音叹三宝
  香水柔软湛然满　　分陀利华遍围绕
  一切香华出光明　　清净具足而庄严
  于宝幢中有光明　　垂宝旗幡而庄严
  摩尼宝网出妙声　　闻者能入一切智
  众宝华城甚微妙　　无量宝色净光明
  十方世界靡不照　　一切具足光严饰
  垣墙周匝而围绕　　种种杂宝为庄严
  清净宝焰相任持　　具足庄严宝香海
  卢舍那佛过去行　　令佛刹海甚清净
  无数无量无边际　　彼处一切自在转

一一香水海。有四天下微尘数香水河围绕。种种宝华弥覆其上。彼诸香水河。从佛眉间白毫相出。摩尼宝王泛上随流。尔时普贤菩萨。以偈颂曰

  离垢清净香水流　　金刚宝华悉弥覆
  众宝轮地布金沙　　无量珍琦普庄严
  净妙阶道七宝成　　诸栏楯上植莲华
  真珠宝华常敷荣　　悬杂华鬘为庄严
  一切宝光微妙色　　清净香水杂宝流
  种种宝华为波浪　　众音谐雅演佛声
  栴檀宝末和清流　　无量杂宝为回复
  普出种种香光焰　　常流一切十方界
  一切香河出无量　　杂种妙胜诸珍宝
  众宝积集为华盖　　光明普照香水河
  十方无量世界中　　佛光明照见宝王
  如来道场宝轮地　　众宝香河盈流满
  诸宝罗网相扣摩　　演佛音声常不绝
  一切菩萨诸佛法　　普贤大士所修行
  诸佛世尊愿音声　　于彼宝岸常得闻
  一切如来过去行　　皆悉遍闻十方国
  一切香河诸旋流　　一切菩萨功德云
  渐渐盈满诸法界　　见一切刹无不至
  彼诸一切香水河　　净宝王云弥覆上
  佛白毫相出宝王　　其光明耀等如来

大方广佛华严经卷第三大方广佛华严经卷第四

        东晋天竺三藏佛驮跋陀罗译

    卢舍那佛品第二之三

彼香河中间一切平正。诸妙宝树以为庄严。杂种宝幔弥覆其上。一切菩萨愿力所起。佛所护念。三世庄严而庄严之。尔时普贤菩萨。以偈颂曰

  卢舍那佛遍十方　　出一切化庄严身
  彼亦不来亦不去　　佛愿力故皆悉见
  一切佛刹微尘中　　无量佛子修诸行
  悉受清净国土记　　见严净刹称本行

佛子当知。此莲华藏世界海中。一一境界。有世界海微尘数清净庄严。诸佛子。此香水海上。有不可说佛刹微尘数世界性住。或有世界性莲华上住。或在无量色莲华上住。或依真珠宝住。或依诸宝网住。或依种种众生身住。或依佛摩尼宝王住。或须弥山形。或河形。或转形。或旋流形。或轮形。或树形。或楼观形。或云形。或网形。尔时普贤菩萨。以偈颂曰

  坚固清净诸佛刹　　离垢解脱光明藏
  依止摩尼宝海住　　或有依止香海住
  或依种种方便住　　或依庄严众色住
  或复须弥树圆形　　种种方门佛刹住
  或光明身诸华藏　　宝云普放净光明
  光明充满胜世界　　宝地海藏不可坏
  或净佛刹无量色　　光明焰云众色等
  或有妙音诸世界　　自然常音不思议
  无数愿乐种种身　　自在行云音声身
  众生无量德音身　　最胜一切德音身
  种种门入诸佛刹　　渐至无尽不思议
  无数一切满十方　　无尽无量普自在
  一切诸方如来刹　　广大方便入佛界
  见十方刹渐次至　　国土不增亦不减
  以一国土满十方　　十方入一亦无余
  世界本相亦不坏　　无比功德故能尔
  一切佛刹微尘中　　见卢舍那自在力
  弘誓愿海震音声　　调伏一切众生类
  佛身充满一切刹　　无数菩萨亦如是
  教化众生无有量　　佛现自在无伦匹

尔时普贤菩萨。告诸菩萨言。佛子。彼众香水海中。有一香水海。名乐光明。有一切香摩尼宝王庄严莲华。上有世界。名清净宝网光明。佛号离垢净眼广入。彼世界上。过佛刹尘数世界。有佛国名杂香莲华胜妙庄严。依宝网住。形如师子座。佛号师子座光明胜照。彼世界上。过佛刹尘数世界。有佛国名宝庄严普光明。依诸华住。形如日轮云。佛号广大光明智胜。彼世界上。过佛刹尘数世界。有佛国名杂光莲华。佛号金刚光明普精进善起。彼世界上。过佛刹尘数世界。有佛国名无畏严净。佛号平等庄严妙音幢王。彼世界上。过佛刹尘数世界。有佛国名华开净焰。佛号爱海功德称王。彼世界上。过佛刹尘数世界。有佛国名总持。佛号净智慧海。彼世界上。过佛刹尘数世界。有佛国名解脱声。佛号善相幢。彼世界上。过佛刹尘数世界。有佛国名胜起。佛号莲华藏光。彼世界上。过佛刹尘数世界。有佛国名善住金刚不可破坏。佛号那罗延不可破坏。彼世界上。过佛刹尘数世界。有佛国名华林赤莲华。佛号杂宝华鬘智王。彼世界上。过佛刹尘数世界。有佛国名净光胜电如来藏。佛号能起一切所愿功德。彼世界上。有香水海。名净光焰起。中有世界性。名善住。次上复有香水海。名金刚眼光明。中有世界性。名法界等起。次上复有香水海。名莲华平正。中有世界性。名出十方化身。次上复有香水海。名宝地庄严光明。中有世界性。名宝枝庄严。次上复有香水海。名化香焰。中有世界性。名清净化。次上复有香水海。名宝幢。中有世界性。名佛护念。次上复有世界性名众色普光。如是次上。复有世界尘数香水海及世界性。如一方。十方亦如是。卢舍那佛常转法轮处。尔时普贤菩萨。以偈颂曰

  法界不可坏　　莲华世界海
  离垢广庄严　　安住于虚空
  此世界海中　　刹性难思议
  善住不杂乱　　各各悉自在
  平正住庄严　　依种种色住
  如来世界海　　佛刹相随顺
  种种身音声　　一切佛自在
  普见诸世界　　种种业庄严
  须弥山城网　　水旋轮圆形
  清净色莲华　　彼彼悉围绕
  尸罗幢盆形　　随顺转色形
  如是难思议　　诸佛国土形
  不思议世界　　依止莲华住
  放大光明网　　普照于一切
  一一如来刹　　放诸光明网
  照一切佛国　　充满十方海
  一切诸佛刹　　一切境界门
  一切方便入　　皆悉见无量
  不思议佛刹　　不坏不可尽
  无量净庄严　　大仙威神力
  彼如来刹顶　　不思议世界
  或成或有败　　不生亦不灭
  譬如诸树林　　华叶或生落
  如是诸佛刹　　成败亦复然
  如依种种树　　有种种果生
  如是种种刹　　有种种众生
  种子差别故　　果实生不同
  行业若干故　　佛刹种种异
  譬如意宝珠　　随意现众色
  除诸妄想故　　悉见清净刹
  譬如空中云　　龙王力能现
  如是佛愿力　　一切佛刹起
  犹如工幻师　　能现种种众
  如是众生业　　佛刹不思议
  如见彩画像　　知是画师造
  如是见佛刹　　心画师所成
  众生心不同　　随起诸妄想
  如是诸佛刹　　一切皆如化
  犹如见导师　　种种无量色
  随众生心行　　见佛刹亦然
  无量真珠华　　悉覆诸佛刹
  色现各不同　　离垢庄严现
  彼莲华网中　　佛刹网依住
  种种妙庄严　　众生所依处
  或有佛刹地　　垢秽不平正
  众生烦恼故　　起如是佛刹
  清净不清净　　佛刹不可议
  众生希望起　　菩萨之所持
  清净不清净　　无量诸佛刹
  业海因缘起　　菩萨之所化
  或放清净光　　离垢众宝体
  种种妙庄严　　诸佛令清净
  一切国土中　　火灾不可议
  示现不清净　　而刹常坚固
  或依风轮住　　或复依水轮
  无量刹成败　　众生行业故
  见无量佛刹　　或成或有败
  彼亦无有成　　亦复无有败
  于一一念中　　无量佛刹起
  诸佛所持故　　国清净离垢
  或有佛刹起　　泥土不清净
  离明常闇冥　　罪众生所住
  或有泥土刹　　烦恼大恐怖
  乐少忧苦多　　薄福之所处
  或有铁世界　　或有赤铜国
  诸石山秽恶　　众生业故起
  或有泥土刹　　众生常苦恼
  长冥离光明　　光明海能照
  诸畜生趣中　　受无量种身
  随宿行业故　　长受无量苦
  阎罗王界中　　饥渴苦常逼
  登上大火山　　长受无量苦
  或有七宝刹　　平正住庄严
  清净业力起　　微妙善安隐
  彼佛刹土中　　唯见人天趣
  功德果成就　　常受诸快乐
  一一毛孔中　　不思议亿刹
  无量形庄严　　种种业所起
  随其自业起　　众生界难议
  取种种相已　　或受乐受苦
  或刹光无量　　一切宝为地
  金刚华遍覆　　离垢净庄严
  或刹光明体　　光明轮安住
  金色栴檀香　　光明云常照
  或刹日轮体　　布众香宝衣
  或一莲华中　　菩萨悉充满
  或有无量色　　离垢宝佛刹
  绀宝光明网　　光明网电照
  或有佛刹土　　金刚华为体
  或布众宝华　　观察甚清净
  普贤菩萨愿　　所得清净国
  三世庄严刹　　悉现于此中
  诸佛子汝观　　佛世界自在
  未来一切刹　　悉见皆如梦
  十方一切刹　　过去佛国海
  于一世界见　　一切刹如化
  三世一切佛　　并一切佛土
  于一世界见　　三世佛及刹
  观微尘上刹　　一切佛自在
  无量妙庄严　　皆悉如电光
  或无量佛土　　其形犹如海
  有如须弥山　　世界难思议
  有国如珠贯　　依绀宝网住
  或依树庄严　　一切佛充满
  或依摩尼轮　　或依止莲华
  八隅杂庄严　　离垢种种色
  或如师子座　　或有国如金
  或如众宝形　　或如梵世处
  或天主月形　　又复形如日
  或如摩尼宝　　栴檀香庄严
  或如旋香鬘　　佛世界安住
  或如光明轮　　种种色庄严
  或寿命一劫　　或复寿百劫
  或复有寿命　　佛刹微尘等
  或于一劫中　　见无量刹起
  无量不可数　　不思议刹坏
  或国土无佛　　或国土有佛
  或国土一佛　　或有无量佛
  若国土无佛　　他方异世界
  有诸化佛来　　示现自在教
  从兜率舍寿　　降神处胎生
  降魔成正觉　　转无上法轮
  随众生所乐　　种种色示现
  一切时不坏　　转清净法轮
  若众生非器　　非佛令不见
  烦恼所障碍　　不见如来意
  或刹极浊恶　　常闻弊恶音
  刚强粗犷声　　不爱大恐怖
  彼地狱畜生　　饿鬼趣受苦
  是浊恶佛刹　　众生忧恼海
  或刹甘露音　　常闻柔软声
  清净业道音　　普闻一切刹
  或有佛刹闻　　释提桓因声
  梵天王妙声　　诸世界主声
  光明旋音声　　佛化身无尽
  诸菩萨音声　　当闻佛刹海
  或不思议刹　　闻转法轮声
  不可尽愿声　　所修行音声
  闻三世诸佛　　具足尊名号
  随缘起佛刹　　音声不可尽

诸佛子。乃往久远过世界海微尘数劫。复过是数。尔时有世界海。名净光普眼。中有世界性。名胜妙音。依止摩尼华网海住。清净无秽。有须弥山尘数世界。以为眷属。无量宝庄严地。有三百重众宝围山。高广严净周匝围绕。其世界性。形如须弥山。天宫庄严以念为食。彼世界性中。有香水海名清净光。彼香海中。有须弥山。名大焰华庄严幢。以十种宝栏楯围绕。彼须弥山。有林观名宝华枝。以无量华楼阁。无量宝幢楼阁。无量绀宝网。种种色华而庄严之。无量香云弥覆其上。十亿百千城周匝围绕。于彼林东。有一大城名曰焰光。纯香所成面千由旬。七宝为郭周匝围绕。其城竂观杂宝庄严。覆以杂华及诸宝网。微风吹动出妙音声。其城有门一万二千。建杂宝幢而庄严之。十亿园林周匝围绕。城中众生。皆悉成就业报神足。行同诸天。一切所欲应念即至。于彼林南。有一天城。名树华庄严。次有龙城。名曰究竟。次有夜叉城。名金刚胜妙庄严幢。次有乾闼婆城。名离垢善。次有阿修罗城。名宝轮地。次有迦楼罗城。名众宝庄严善光。次有紧那罗城。名娱乐庄严。次有摩睺罗伽城。名宝金刚幢。时彼林中。有一道场。名宝华庄严。其道场前。有大莲华名华焰具足。纵广百亿由旬。十亿莲华眷属围绕。时彼世界过百岁已。有佛出世。如是次第。有十须弥山尘数如来。出兴于世。其最初佛。名一切功德本胜须弥山云。时佛处彼大莲华上。眉间白毫放大光明。名一切功德觉。有十佛世界尘数光明。以为眷属。彼光灭除一切众生烦恼盖障。令得净心起功德海。永离三恶八难诸趣。发菩提心。诸佛子。时彼焰光城中。有王名爱见善慧。其王统领万亿诸城。有三万七千夫人采女。二万五千子。其第一子名功德胜。次名普庄严童子。时彼童子。见佛无量自在功德善根因缘故。即得十种三昧。名曰诸佛具足功德三昧。普门方便三昧。净方便云三昧。教化众生三昧。一切音声充满三昧。无量功德诚向三昧。如实觉诸法三昧。广地方便海三昧。胜解脱三昧。一切智光三昧。尔时普庄严童子。以偈颂曰

  犹如千日出　　虚空靡不照
  离垢坐道场　　光明亦如是
  无量万亿劫　　难遇之导师
  出兴于世间　　一切见最胜
  观察佛光明　　如云难思议
  一切处悉见　　如对现目前
  毛孔放光明　　如云不可尽
  随诸众生音　　赞佛无量德
  众生遇佛光　　离苦永寂灭
  悉安隐快乐　　欢喜遍充满
  观察诸菩萨　　充满十方界
  放摩尼宝云　　赞叹诸最胜
  常于道场闻　　深妙音声海
  灭诸众生苦　　睹佛自在力
  一切兴恭敬　　欢喜心无量
  往诣法王所　　瞻仰礼供养

时彼童子说偈音声。于彼世界无不普闻。尔时爱见善慧王。闻说是偈欢喜无量。以偈颂曰

  宜时普宣告　　诸王大臣等
  令知吉祥相　　咸速诣最胜
  庄饰一切城　　宜令悉清净
  建诸妙幢幡　　种种宝庄严
  设众妙宝帐　　弥覆罗其上
  兴妓乐音云　　令充遍虚空
  扫除诸街巷　　降以杂宝雨
  庄严众宝乘　　当诣见最胜
  各于其帐内　　雨种种云雨
  一切庄严云　　流行虚空中
  香莲华光云　　华盖难思议
  璎珞半月云　　雨众妙宝衣
  须弥山香水　　摩尼宝庄严
  清净众杂宝　　显现虚空中
  摩尼宝华鬘　　离垢众宝鬘
  摩尼宝灯云　　凝照停虚空
  瞩想皆念佛　　生无量欢喜
  妻子眷属俱　　当诣见最胜

尔时爱见善慧王。与七十七亿那由他眷属俱。往诣一切功德本胜须弥山云佛所。到已头面礼足于一面坐。有无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。往诣佛所。头面礼足于一面住。尔时如来。教化一切诸众生故。于彼大众海中说经。名现三世一切诸佛集会。世界尘数修多罗以为眷属。随诸众生所应解故。尔时普庄严童子。闻是经已。宿世功德因缘故。得一切法具足三昧。一切法来入安住菩提心三昧。法界师子光方便三昧。法眼清净三昧。尔时童子以偈颂曰

  我闻最胜法　　清净慧眼开
  能见一切佛　　过去功德海
  我见一切生　　如本色具足
  随本名身业　　供养一切佛
  过去诸佛所　　无量劫海行
  我见诸佛海　　清净佛刹海
  于生死海中　　舍自身无量
  修菩萨胜行　　严净佛刹海
  舍无量耳鼻　　头目及手足
  王身大臣身　　具足修净国
  一一佛刹中　　难思议亿劫
  修行菩萨道　　令佛刹海净
  普贤菩萨愿　　修习诸行海
  一切刹海中　　令佛土清净
  如日光明净　　悉见色具足
  佛智光照已　　见我本修行
  见无量诸佛　　离垢清净刹
  成等正觉声　　悉充满法界
  如彼修清净　　具足佛刹海
  一切佛神力　　应修菩萨行

说是偈时。如须弥山尘数众生。悉发无上道心。时彼如来。为此童子而说颂曰

  善哉普庄严　　德藏大名称
  能为众生故　　勇猛求菩提
  能发智慧光　　满一切法界
  无上道德云　　当得智慧海
  一国中修行　　一刹微尘劫
  当逮是智慧　　如我之所得
  懈怠者不能　　解深方便海
  精进力成就　　能净佛世界
  一切微尘数　　劫海修众行
  彼得净如是　　如我佛刹海
  一一众生故　　无量劫苦行
  不厌生死难　　能为大导师
  无量无边愿　　一切诸佛海
  能度无上道　　方便海具足
  恭敬供养我　　普庄严大力
  胜须弥山佛　　成汝无上道
  普贤常勇猛　　具足大名称
  一切法界满　　净诸佛刹海

尔时一切功德本胜须弥山云如来。寿五十亿岁。彼佛灭度后。有佛出世。号一切度离痴清净眼王如来。普庄严童子。见是如来已。即得念佛三昧。普门海藏三昧。无量智持转法三昧。甚深法乐三昧。时佛说经。名一切法界自性离垢庄严。有世界微尘等修多罗。以为眷属。普庄严童子。闻是经已。即得三昧。名一切法普门欢喜藏三昧。入一切法方便海三昧

    大方广佛华严经如来名号品第三

佛在摩竭提国寂灭道场初始得佛普光法堂。坐莲华藏师子座上。善觉智无二念。了达法性住佛所住。等诸如来至无碍趣。具不退法无坏境界。住不思议等达三世。与十佛国土微尘数等大菩萨俱。尽一生补处。悉从他方世界来集。了众生性深入法界。常善思量世间涅槃。明了业报众生心行。悉能解知诸法义味。观察世间。离世间法。究竟分别为无为性。去来现在靡不贯达。时诸菩萨咸作是念。唯愿世尊哀愍我等。随所志乐示现佛刹。示佛所住。示佛国庄严。示诸佛法。示佛土清净。示佛所说法。示佛刹体。示佛功德势力。示随佛刹起。示成正觉。开示十方一切如来所可分别菩萨十住十行十回向十藏十地十愿十定十自在十顶。菩萨随喜心。不断如来性。救众生灭烦恼。知众行解诸法。离垢秽拔众难。决疑网竭爱欲。佛无上地。佛境界。佛住寿。佛行。佛力。佛无所畏。佛定。佛神足。佛胜法。佛不动转。佛六情根。佛光。佛智。佛无上功德一切具足。如是等事悉为我现

尔时世尊。知诸菩萨心之所念。即如其像现神通力。现神力已。东方过十佛刹微尘数国。有世界名金色。佛号不动智。有菩萨字文殊师利。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于东方。化作莲华藏师子之座。结跏趺坐。南方过十佛刹微尘数国。有世界名乐色。佛号智火。有菩萨字觉首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于南方。化作莲华藏师子之座。结跏趺坐。西方过十佛刹微尘数国。有世界名华色。佛号习智。菩萨字财首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于西方。化作莲华藏师子之座。结跏趺坐。北方过十佛刹微尘数国。有世界名薝卜华色。佛号行智。菩萨字宝首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于北方。化作莲华藏师子之座。结跏趺坐。东北方过十佛刹微尘数国。有世界名青莲华色。佛号明智。菩萨字德首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于东北方。化作莲华藏师子之座。结跏趺坐。东南方过十佛刹微尘数国。有世界名金色。佛号究竟智。菩萨字目首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于东南方。化作莲华藏师子之座。结跏趺坐。西南方过十佛刹微尘数国。有世界名宝色。佛号上智。菩萨字进首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于西南方。化作莲华藏师子之座。结跏趺坐。西北方过十佛刹微尘数国。有世界名金刚色。佛号自在智。菩萨字法首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于西北方。化作莲华藏师子之座。结跏趺坐。下方过十佛刹微尘数国。有世界名玻璃色。佛号梵智。菩萨字智首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于下方。化作莲华藏师子之座。结跏趺坐。上方过十佛刹微尘数国。有世界名如实色。佛号伏怨智。菩萨字贤首。与十佛土尘数菩萨。来诣佛所恭敬供养头面礼足。即于上方。化作莲华藏师子之座。结跏趺坐。是时文殊师利菩萨。承佛神力。观察大众。叹曰快哉。今菩萨会为未曾有。诸佛子。当知佛刹不可思议。佛住。佛国。佛法。佛刹清净。佛说法。佛出世。佛刹起。诸佛阿耨多罗三藐三菩提。皆不可思议。何以故。十方诸佛说法。知彼心行随化众生。与虚空法界等。何以故。此娑婆世界中。诸四天下教化一切。种种身。种种名。处所形色长短寿命。诸得。诸入。诸根。生处。业报。如是种种不同。众生所见亦异。何以故。诸佛子。此四天下佛号不同。或称悉达。或称满月。或称师子吼。或称释迦牟尼。或称神仙。或称卢舍那。或称瞿昙。或称大沙门。或称最胜。或称能度。如是等称佛名号其数一万。诸佛子。次此东方。有四天下名曰善护。彼称如来。或号金刚。或号尊胜。或号大智。或号不坏。或号云王。或号无诤。或号平等。或号欢喜。或号无比。或号默然。如是等称佛名号其数一万。诸佛子。次此南方。有四天下名曰难养。彼称如来。或名甘露灌。或名善名称。或名离垢。或名实论师。或名调御。或名乐慧。或名大音。或名众祐。或名无量。或名胜慧。如是等称佛名号其数一万。诸佛子。次此西方。有四天下名曰佛慧。彼称如来。或谓性慧。或谓爱现。或谓无上王。或谓无恐怖。或谓实慧。或谓常化。或谓知足。或谓法慧。或谓究竟。或谓能忍。如是等称佛名号其数一万。诸佛子。次此北方。有四天下名师子言。彼称如来。或称大牟尼。或称苦行。或称婆伽婆。或称福田。或称一切智。或称善意。或称清净。或称伊那婆那。或称胜鬘。或称愿行满。如是等称佛名号其数一万。诸佛子。次此东北方。有四天下名曰安宁。彼称如来。或号法王。或号等起。或号寂静。或号妙天。或号离欲。或号胜慧。或号等心。或号无坏。或号慧音。或号远来。如是等称佛名号其数一万。诸佛子。次此东南方。有四天下名曰喜乐。或称如来。或名莲华。或名慧火。或名知人。或名密教。或名解脱。或名自然安住。或名妙行成就。或名清净眼王。或名上勇。或名精进力。如是等称佛名号其数一万。诸佛子。次此西南方。有四天下名曰坚固。彼称如来。或称不动。或称慧王。或称满慧。或称无动慧。或称常悲。或称顶王。或称胜音。或称一切施或称持仙。或称胜须弥如是等称佛名号其数一万。诸佛子。次此西北方。有四天下名须菩提。彼称如来。或号普慧。或号光明成就。或号宝髻。或号应敬念。或号无上义。或号悦乐。或号本性清净。或号光明满。或号修臂。或号本善住。如是等称佛名号其数一万。诸佛子。次此下方。有四天下名曰焰道。彼谓如来。或名长养善根。或名师子色。或名利智。或名真金焰。或名普亲。或名梵音。或名饶益。或名究竟来。或名真天。或名平等施。如是等称佛名号其数一万。诸佛子。次此上方。有四天下名曰持地。彼谓如来。或称猛慧。或称无量清净。或称觉慧。或称勇首。或称妙庄严。或称能发欢喜。或称意成满。或称火光。或称精进。或称一乘。诸佛子。如是持地四天下。称佛名号其数一万。此娑婆世界。有如是等百亿四天下。彼称如来。亦各不同有百亿万。诸佛子。此娑婆世界东。次有国土名曰密训。彼谓如来。或称平等。或称最勇。或称安慰。或称调意。或称闻慧。或称一切舍。或称自在。或称坚固身。或称大超越。或称无比智。诸佛子。如是密训国土。称佛名号有百亿万。诸佛子。此世界南。次有国土名曰最勇。彼谓如来。或称自然清净。或称意至到。或称能仁。或称解脱王。或称智惠王。或称明行足。或称善誓。或称能寂灭。或称大慈。或称大悲。如是等称佛名号有百亿万。诸佛子。此世界西。次有国土名曰离垢。彼谓如来。或称具足直心。或称分别道。或称善持。或称解脱众乱。或称论师。或称分别众宝。或称无上现。或称来化。或称一切苦行。或称具足力。如是等称佛名号有百亿万。诸佛子。此世界北。次有国土名宝境界。彼谓如来。或称薝卜华色。或称日藏。或称依精进住。或称等起住寿。或称超实。或称慧日。或称无障碍。或称月出。或称慧火势。或称清净身。如是等称佛名号有百亿万。诸佛子。此世界东北。次有国土名曰诃尼。彼称如来。或号离苦。或号一切解脱。或号因缘具足。或号解脱智慧。或号过去藏。或号宝光。或号离世间。或号至离身地。或号端严藏。或号离嗔恚心。如是等称佛名号有百亿万。诸佛子。此世界东南。次有国土名曰饶益。彼称如来。或号因缘。或号尽智。或号美音。或号根胜。或号庄严盖。或号净根。或号殊特。或号分别到彼岸。或号胜定。或号慈父。或号智海。如是等称佛名号有百亿万。诸佛子。此世界西南。次有国土名曰鲜少。彼称如来。或号牟尼主。或号乐宝。或号不二观。或号知智。或号谦意。或号有缘见。或号根主。或号天人师。或号建业。或号金刚华。如是等称佛名号。有百亿万。诸佛子。此世界西北。次有国土名曰知足。彼称如来。或号华聚。或号栴檀盖。或号莲华藏。或号超越诸法。或号法显。或号次起。或号善净盖。或号离垢善根。或号善言。或号专念法。或号五法藏。如是等称佛名号有百亿万。诸佛子。此世界下。次有国土名离搏食。彼称如来。或号真珠焰。或号普化或号法命主。或号无为。或号觉根。或号离尘。或号风无碍。或号欣施。或号分别道。或号建幢。如是等称佛名号有百亿万。诸佛子。此世界上。次有国土名解脱音。彼称如来。或号猛幢。或号无量宝。或号乐大施。或号天光。或号吉祥兴。或号离死地。或号最胜。或号不退轮。或号离非法。或号修一切智。诸佛子。此解脱音世界。称佛名号有百亿万。如娑婆国土及十世界。如是东方百千亿不可量不可数不可思议不可称无等无边无分齐不可说。虚空法界等世界中众生。称佛名号各各不同。南西北方四维上下亦复如是。是皆如来为菩萨时。有因缘者为度此故。种种方便。口业音声行业果报。法门权道诸根所乐。令诸众生知如来法

    大方广佛华严经四谛品第四之一

尔时文殊师利。告众菩萨言。佛子。所说苦谛者。于此娑婆世界。或言害。或言逼迫。或言变异。或言境界。或言聚。或言刺。或言依根。或言不实。或言痈。或言童蒙行。所说苦集谛者。或言火。或言能坏。或言受义或言觉。或言方便。或言决定。或言网。或言念。或言顺众生。或言颠倒根。所说苦灭谛者。或言无障碍。或言离垢净。或言寂静。或言无相。或言不死。或言无所有。或言因缘断。或言灭。或言真实。或言自然住所说苦灭道谛者。或言一乘。或言趣寂静。或言引导。或言究竟希望。或言常不离。或言能舍担。或言至非趣。或言圣人随行。或言仙人行。或言十藏。诸佛子。此娑婆世界中。如是等四谛名字。有四十亿百千那由他。随诸众生所应调伏。作如是说。诸佛子。如娑婆世界所称苦谛。于密训世界。或名求根。或名不可出。或名不缚根。或名作不应作。或名一切不实。或名分别羸。或名处所成就。或名第一害。或名动。或名身事。所名苦集谛者。或名受。或名枝。或名烧。或名坚固。或名坏根。或名相续。或名害行。或名喜忘。或名生元。或名分。所名苦灭谛者。或名正义。或名坚固。或名赞叹。或名安隐。或名善趣。或名调伏。或名一道。或名离烦恼。或名不乱。或名究竟。所名苦灭道谛者。或名猛将。或名不没。或名超出。或名勤方便。或名普眼。或名离边。或名觉悟。或名得妙。或名无上目。或名观方。诸佛子。彼密训世界如是等四谛名字。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所名苦谛。于最勇世界。或名恐怖。或名福断。或名应诃责。或名常给。或名粗涩。或名常怨。或名离胜。或名夺利。或名难共事。或名虚妄。或名势力。所名苦集谛者。或名因缘。或名痴元。或名怨林。或名刃枝。或名灭味。或名仇对。或名味着。或名导引。或名增闇。或名害利。所名苦灭谛者。或名大义。或名饶益分。或名义中义。或名无量。或名见。或名虚妄断。或名最胜。或名常。或名住。或名无为。所名苦灭道谛者。或名灭火。或名胜枝。或名定分别。或名不退。或名深方便。或名出。或名最上。或名至非趣。或名解脱。或名能令解脱。诸佛子。彼最勇世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所说苦谛。于离垢世界。或名悔恨。或名资待。或名分别。或名轮回。或名前行。或名一味。或名非法。或名现前地。或名最邪。或名邪见。或名不可忍。所名苦集谛者。或名虚器。或名分。或名甘忍。或名生地。或名取。或名弃。或名增。或名担。或名能生。或名坚缚。所名苦灭谛者。或名等等。或名空。或名无垢。或名胜根。或名胜等。或名无作。或名灭使。或名最上。或名毕竟。或名破印。所名苦灭道谛者。或名真坚固。或名方便分别。或名义根。或名真性。或名离爱。或名胜净。或名有边。或名寄全。或名究竟。或名净虚妄。诸佛子。离垢世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所说苦谛。于真实境世界。或名爱欲。或名险根。或名海分。或名邪方便。或名分别根。或名流转。或名生灭。或名障碍。或名倒根。或名有数。所名苦集谛者。或名爱。或名陷溺。或名不可尽。或名分。或名不正趣。或名津梁。或名事。或名障碍。或名器。或名动。所名苦灭谛者。或名相续断。或名解散。或名无名。或名不作。或名不现。或名无作。或名无色。或名无烧。或名明。或名净。所名苦灭道谛者。或名寂行。或名正行。或名修证。或名安隐道。或名无量寿。或名修究竟。或名常道。或名难得。或名彼岸。或名无敌。诸佛子。真实境世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所名苦谛者。于诃尼世界。或名掠取。或名非善友。或名战怖。或名多言。或名真地狱。或名非法调伏。或名重担。或名坏根。或名虚妄。或名虚妄根。所名苦集谛者。或名贪。或名作。或名恶。或名生。或名绞缚。或名想。或名有果。或名不爱。或名不应说。或名回转。所名苦灭谛者。或名不转。或名解脱。或名无作。或名离爱。或名坚固。或名真实。或名离痴。或名寂灭。或名贤圣。或名离怨敌。所名苦灭道谛者。或名正语。或名无诤。或名教导。或名回向心。或名广妙。或名分别方便。或名有数。或名趣寂静。或名胜智。或名善解义。诸佛子。诃尼世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所言苦谛者。于饶益世界。或名重担。或名危脆。或名贼等。或名生死。或名非欢喜。或名流转。或名疲劳。或名丑貌。或名能生。或名利刃。所言苦集谛者。或名流散。或名扰乱。或名烦恼。或名羸劣。或名漂沦。或名乖违。或名非解脱。或名所作。或名取。或名虚妄。所言苦灭谛者。或名离狱。或名真实。或名离诸难。或名覆护。或名善因。或名随至。或名根。或名离枝。或名无为。或名无次第。所言苦灭道谛者。或名达无所有。或名一切因。或名善本。或名明至。或名不转法。或名有尽。或名大道。或名能调伏。或名安隐。或名非流转

大方广佛华严经卷第四大方广佛华严经卷第五

        东晋天竺三藏佛驮跋陀罗译

    四谛品第四之二

诸佛子。饶益世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所言苦谛者。于鲜少世界。或名恶逆心。或名不长慧。或名邪念。或名流转。或名无惭愧。或名贪根。或名炽然。或名刺棘。或名火山。或名忧恼。所言苦集谛者。或名广地。或名来起。或名远智。或名众恼。或名恐怖。或名放逸。或名大失。或名著处。或名无主。或名相续。所言苦灭谛者。或名具足满。或名甘露。或名非我所。或名无主。或名虚妄断。或名安乐住。或名无量。或名断流。或名非趣。或名不二。所名苦灭道谛者。或名光明。或名坚实。或名知深义。或名正业。或名非生灭。或名非相续。或名净导。或名正趣。或名净方便。或名胜见。诸佛子。鲜少世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所名苦谛者。于知足世界。或名流转。或名失利。或名染污障。或名重担。或名恶形。或名内恶。或名非专到。或名害处。或名苦恼。所言苦集谛者。或名能持。或名方便。或名过时。或名非实法。或名无底。或名摄受。或名离戒。或名烦恼法。或名无量见。或名恶聚。所言苦灭谛者。或名坏身。或名不放逸。或名真实。或名等等。或名清净。或名离生。或名离曲。或名无相。或名具足。或名不生。所言苦灭道谛者。或名境界言断。或名功德聚。或名顺义。或名广方便。或名虚妄尽。或名住寿道。或名可称数。或名正念。或名常道。或名解脱。诸佛子。知足世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所名苦谛者。于所求世界。或名害。或名坏瓶。或名我所。或名身趣。或名流转。或名衰主。或名苦。或名轻飘。或名无味。或名来去。所名苦集谛者。或名行。或名愤毒。或名恶行。或名受枝。或名不起疾。或名杂毒。或名虚称。或名离胜。或名炽然。或名惊骇。所名苦灭谛者。或名非聚。或名非处。或名妙药。或名不可坏。或名不没。或名不可量。或名大。或名觉枝。或名离染。或名障碍。所名苦灭道谛者。或名胜行。或名离欲。或名谛究竟。或名入深义。或名实究竟。或名净现。或名持念。或名离障。或名救济。或名胜枝。诸佛子。所求世界。如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如娑婆世界所名苦谛者。于解脱音世界。或名匿疵。或名众生。或名依枝。或名坏胜。或名障碍。或名驶流。或名远。或名藏。或名受。或名苦枝。所名苦集谛者。或名遏调伏。或名心趣。或名能缚。或名常念。或名彼边。或名离修。或名虚妄。或名门。或名轻飘。或名隐覆。所言苦灭谛者。或名非处。或名无上胜。或名不还。或名灭诤。或名小。或名无害。或名善住。或名无尽。或名广。或名无价等。所言苦灭道谛者。或名自见令见。或名摧敌。或名分别印。或名入相。或名难得。或名无量义。或名能起明。或名和合道。或名向不动。或名胜义。诸佛子。解脱音世界如是等四谛名。有四十亿百千那由他。随诸众生所应调伏作如是说。诸佛子。如此娑婆世界及十方佛刹说四谛名。如是东方百千亿不可量不可数不可思议不可称无等无边无分齐不可说虚空法界等一切世界中。说四谛名。各有四十亿百千那由他。随诸众生所应调伏作如是说。南西北方四维上下亦复如是

    大方广佛华严经如来光明觉品第五

尔时世尊。从两足相轮。放百亿光明。遍照三千大千世界。百亿阎浮提。百亿弗婆提。百亿拘伽尼。百亿郁单越。百亿大海。百亿金刚围山。百亿菩萨生。百亿菩萨出家。百亿佛始成正觉。百亿如来转法轮。百亿如来般泥洹。百亿须弥山王。百亿四天王天。百亿三十三天。百亿时天。百亿兜率陀天。百亿化乐天。百亿他化乐天。百亿梵天。百亿光音天。百亿遍净天。百亿果实天。百亿色究竟天。此世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。百亿阎浮提亦复如是。以佛神力故。百亿阎浮提。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利菩萨。觉首菩萨。财首菩萨。宝首菩萨。德首菩萨。目首菩萨。精进首菩萨。法首菩萨。智首菩萨。贤首菩萨。是诸菩萨所从来国。金色世界。乐色。华色。薝卜华色。青莲华色。金色。宝色。金刚色。玻璃色。如实色世界。各于本国佛所。所谓不动智佛。智慧火佛。净智佛。具威仪智佛。明星智佛。究竟智佛。无上智佛。自在智佛。梵天智佛。伏怨智佛所。净修梵行。尔时文殊师利。以偈颂曰

  若有知正觉　　解脱离诸漏
  不着一切世　　彼非净道眼
  若有知如来　　观察无所有
  知法散灭相　　彼人疾作佛
  能见此世界　　一切处无著
  如来身亦然　　是人疾成佛
  若于佛法中　　其心随平等
  入不二法门　　彼人难思议
  若见我及佛　　安住平等相
  彼住无所住　　远离一切有
  色受无有数　　想行识亦然
  能如是知者　　彼是大牟尼
  见者无所有　　所见法亦无
  明了一切法　　彼能照世间
  一念见诸佛　　出现于世间
  而实无所起　　彼人大名称
  无我无众生　　亦无有败坏
  若转如是相　　彼则无上人
  一中解无量　　无量中解一
  展转生非实　　智者无所畏

如此处文殊师利说偈。一切处亦复如是。尔时光明过此世界。遍照东方十佛国土。南西北方四维上下亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利。乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  见众生苦逼　　痴覆爱欲刺
  常求无上道　　诸佛法如是
  离断常二边　　见法实不转
  昔所未曾转　　转此无上轮
  不可思议劫　　被弘誓德铠
  为度生死故　　大圣法如是
  导师降众魔　　勇健莫能胜
  爱语离众怖　　无上慈悲法
  内得甚深智　　能害诸烦恼
  一念见一切　　彼自在示现
  能击正法鼓　　声震十方国
  令得无上道　　自觉法如是
  不坏无量境　　能游无数刹
  不取一切有　　彼自在如佛
  无比欢喜念　　诸佛常清净
  虚空等如来　　彼是具足愿
  一一众生故　　阿鼻地狱中
  无量劫烧煮　　心净如最胜
  不惜身寿命　　常护诸佛法
  具足行忍辱　　彼得如来法

尔时光明过十世界。遍照东方百世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  如来觉诸法　　如幻如虚空
  心净无障碍　　调伏群生类
  或见初生时　　妙色如金山
  住是最后身　　照明如满月
  或见经行时　　摄无量功德
  念慧善具足　　明行人师子
  或见明净眼　　观察照十方
  或时见戏笑　　众生乐欲故
  或见师子吼　　清净无比身
  示现末后生　　所说无非实
  或见出家时　　解脱一切缚
  修习诸佛行　　常乐观寂灭
  或见坐道场　　善觉一切法
  度诸功德岸　　痴闇烦恼灭
  或见天人尊　　具足大悲心
  或见转法轮　　度脱诸群生
  或见无畏吼　　仪容甚微妙
  调伏一切世　　神力无障碍
  或见寂静心　　世间灯永灭
  或见十力尊　　显现自在法

尔时光明过百世界。遍照东方千世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  善逝法甚深　　无相亦无有
  众生颠倒故　　次第现一切
  无有我我所　　彼境界空寂
  善逝身清净　　自觉离诸尘
  等觉明解脱　　无量不可数
  无边世界中　　因缘和合起
  无诸阴界入　　永离生死苦
  不在世间数　　故号人师子
  内外俱解脱　　本来常自空
  一切离虚妄　　诸佛法如是
  离爱诸烦恼　　长流永不转
  正觉解诸法　　度无量众生
  一念不二相　　乐观寂灭法
  其心无所著　　佛自在无量
  善知因缘法　　业报及众生
  最胜无碍智　　甚深难思议
  普见十方界　　严净诸佛刹
  如来离虚妄　　度脱无量众
  佛智如炼金　　一切有非有
  随其所应化　　为说清净法

尔时光明过千世界。遍照东方万世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  离诸人天乐　　常行大慈心
  救护诸群生　　是彼净妙业
  一向信如来　　其心不退转
  不舍念诸佛　　是彼净妙业
  永离生死海　　不退佛法流
  善住清凉慧　　是彼净妙业
  身四威仪中　　观佛深功德
  昼夜常不断　　是彼净妙业
  知三世无量　　不生懈怠心
  常求佛功德　　是彼净妙业
  观身如实相　　一切皆寂灭
  离我非我着　　是彼净妙业
  观察众生心　　远离虚妄想
  成就实境界　　是彼净妙业
  能称无量土　　悉饮一切海
  成就神通智　　是彼净妙业
  计数诸佛国　　色相非色相
  一切尽无余　　是彼净妙业
  无量佛土尘　　一尘为一佛
  悉能知其数　　是彼净妙业

尔时光明过万世界。遍照东方十万世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提。亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  若以色性大神力　　而欲望见调御士
  是则翳目颠倒见　　彼为不识最胜法
  如来身色形相处　　一切世间莫能睹
  亿那由劫欲思量　　妙色威神不可极
  非以相好为如来　　无相离相寂灭法
  一切具足妙境界　　随其所应悉能现
  诸佛正法不可量　　无能分别说其相
  诸佛正法无合散　　其性本来常寂灭
  不以阴数为如来　　远离取相真实观
  得自在力决定见　　言语道断行处灭
  等观身心无异相　　一切内外悉解脱
  无量亿劫不二念　　善逝深远无所著
  普放妙光明　　遍照世境界
  净眼一切智　　自在深广义
  一能为无量　　无量能为一
  知诸众生性　　随顺一切处
  身无所从来　　去亦无所至
  虚妄非真实　　现有种种身
  一切诸世间　　皆从妄想生
  是诸妄想法　　其性未曾有
  如是真实相　　唯佛能究竟
  若能如是知　　是则见导师

尔时光明过十万世界。遍照东方百万世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  最胜自觉超世间　　无依殊特莫能胜
  大仙化度一切有　　具足净妙诸功德
  其心无染无处所　　常住无想亦无依
  永处吉祥无能毁　　威德尊重大导师
  从本净明灭众冥　　永离诸染无尘秽
  寂然不动离边想　　是名善入如来智
  欲入善逝深法海　　远离身心虚妄想
  解了诸法真实性　　永不随顺疑惑心
  一切世界如来境　　悉能为转正法轮
  于法自性无所转　　无上导师方便说
  晓了诸法无疑惑　　有无妄想永已离
  不生差别种种念　　正意思惟佛菩提
  谛了分别诸法时　　无有自性假名说
  随顺诸佛真实教　　法非一相亦不多
  众多法中无一相　　于一法中亦无多
  若能如是了诸法　　是知诸佛无量德
  观察诸法及众生　　国土世间悉寂灭
  心无所依不妄想　　是名正念佛菩提
  众生诸法及国土　　分别了知无差别
  善能观察如自性　　是则了知佛法义

尔时光明过百万世界。遍照东方一亿世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  大智无有量　　妙法无伦匹
  究竟能度彼　　生死大海岸
  寿命无终极　　永已离炽然
  彼成大功德　　是则方便力
  于诸佛深法　　随觉如自性
  常观三世法　　不生止足想
  了达所缘境　　未曾起妄想
  彼乐不思议　　是则方便力
  常乐观众生　　而无众生想
  示现有身趣　　永离诸趣想
  内常乐禅寂　　而无系心想
  彼心无所著　　是则方便力
  方便善观察　　谛了诸法相
  专念正思惟　　常行涅槃性
  乐于解脱道　　具足平等慧
  彼住寂灭法　　是则方便力
  随顺调御士　　最胜佛菩提
  摄取一切智　　广大如法性
  善入真实谛　　教化诸群生
  彼成最胜意　　是则方便力
  佛说深法义　　悉能随顺知
  入深广智慧　　灭除诸障碍
  一切至处道　　是处悉能到
  行是自觉道　　是则方便力
  心犹虚空界　　亦如变化法
  一切所依性　　是相则非相
  行于涅槃性　　犹若虚空相
  能到深妙境　　是则方便力
  常记念昼夜　　晦朔日月数
  年岁时劫分　　亦随观察知
  一切诸世界　　始终成败相
  悉能谛了知　　是则方便力
  一切群萌类　　随业受生死
  有色及无色　　有想亦非想
  彼彼姓名号　　所趣谛了知
  得此不思议　　是则方便力
  一切过去世　　未来现在法
  随顺佛所说　　善念谛观察
  觉三世平等　　如其真实相
  是诸深妙道　　无比方便力

尔时光明过一亿世界。遍照东方十亿世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  受持难行法　　坚固不退转
  日夜常精进　　未曾起疲厌
  已度难度海　　大音师子吼
  一切众生类　　我今悉当度
  漂浪生死流　　沉沦爱欲海
  痴惑结重网　　昏冥大怖畏
  离慢坚固士　　是能悉除断
  超勇成世雄　　是则佛境界
  世间诸放逸　　长迷醉五欲
  非实兴妄想　　永为大苦障
  勤修不放逸　　奉行诸佛法
  大誓能度彼　　是则佛境界
  慧者灭本际　　无量难见劫
  众生依吾我　　无穷生死转
  令入寂灭法　　奉行最胜教
  誓宣此妙法　　是则佛境界
  见彼苦众生　　孤茕无救护
  永沦诸恶趣　　三毒恒炽然
  无间无救处　　昼夜常火焚
  誓度斯等苦　　是则佛境界
  迷惑失正路　　习行诸邪径
  见彼群生类　　长处大闇冥
  为现智慧灯　　令见诸佛法
  誓能为照明　　是则佛境界
  一切三有海　　深广无涯底
  见彼群生类　　漂溺莫能济
  为彼勤方便　　兴造正法船
  普拯所应度　　是则佛境界
  无有本实见　　常依无明住
  沉没生死渊　　愚痴心迷乱
  慧者见斯苦　　为之设法桥
  大悲演说法　　是则佛境界
  见彼生死狱　　楚毒难可量
  长夜老病死　　三苦竞侵逼
  自觉深妙法　　专修方便慧
  誓度斯等苦　　是则佛境界
  闻佛甚深法　　信心无疑惑
  周满十方刹　　普行诸法界
  观察空寂法　　其心无恐怖
  现同一切身　　是则天人师

尔时光明过十亿世界。遍照东方百亿世界。千亿世界。百千亿世界。亿那由他世界。百亿那由他世界。千亿那由他。百千亿那由他。不可量不可数不可思议不可称无等无边无分齐不可说虚空法界等一切世界。乃至上方亦复如是。彼一一世界中。百亿阎浮提。乃至百亿色究竟天。世界所有一切悉现。如此见佛坐莲华藏师子座上。有十佛世界尘数菩萨眷属围绕。彼一一世界中。百亿阎浮提亦复如是。佛神力故。皆见十方各有一大菩萨。各与十世界尘数菩萨眷属俱。来诣佛所。所谓文殊师利乃至贤首等。是诸菩萨所从来国。金色世界乃至如实色世界。各于本国不动智佛乃至伏怨智佛所。净修梵行。尔时一切处文殊师利。以偈颂曰

  无量无数劫　　一念悉观察
  无来亦无去　　现在亦不住
  一切生灭法　　悉知真实相
  超度方便岸　　具足十种力
  无等大名称　　普遍十方刹
  永离生死难　　究竟一切法
  皆悉能遍至　　一切诸世界
  具足能敷演　　清净微妙法
  普为众生类　　正心奉诸佛
  是故获直心　　真实净依果
  随顺分别知　　了达如如相
  得佛自在力　　十方靡不现
  从始供养佛　　乐行忍辱法
  能入深禅定　　观察真实义
  悉令一切众　　欢喜向如来
  菩萨行是法　　速逮无上道
  能问十方佛　　其心常湛然
  信佛不退转　　威仪悉具足
  一切有无法　　了达非有无
  如是正观察　　能见真实佛
  无量净乐心　　境界满十方
  一切国土中　　能说真实义
  灭除众垢难　　安住平等法
  若能如是化　　斯人等如来
  闻佛妙音声　　逮得无上法
  常转净法轮　　甚深难知见
  最胜所说法　　具足七觉义
  如是无上观　　常见诸佛身
  不见如来空　　寂灭犹幻化
  虽见无所见　　如盲对五色
  虚妄取相者　　是人不见佛
  一切无所著　　乃见真如来
  众生种种业　　难可分别知
  十方内外身　　种种无量色
  佛身亦如是　　一切满十方
  难知能知者　　彼是大导师
  譬如无量刹　　依止虚空住
  不从十方来　　去亦无所至
  世界若成败　　本来无所依
  佛身亦如是　　充满虚空界

    大方广佛华严经菩萨明难品第六

尔时文殊师利菩萨。问觉首菩萨言。佛子。心性是一。云何能生种种果报。或至善趣或至恶趣。或具诸根或不具者。或生善处或生恶处。端正丑陋苦乐不同。业不知心心不知业。受不知报报不知受。心不知受受不知心。因不知缘缘不知因。智不知法法不知智。尔时觉首菩萨。以偈答曰

  为化众生故　　乃能问斯义
  诸法如实性　　我说仁谛听
  诸法不自在　　求实不可得
  是故一切法　　二俱不相知
  譬如驶水流　　流流无绝已
  二俱不相知　　诸法亦如是
  亦如明灯焰　　焰焰不暂停
  二俱不相知　　诸法亦如是
  亦如长风起　　鼓拂生动势
  二俱不相知　　诸法亦如是
  亦如深广地　　展转相依住
  二俱不相知　　诸法亦如是
  眼耳鼻舌身　　心意诸情根
  因此转众苦　　而实无所转
  法性无所转　　示现故有转
  于彼无示现　　示现无所有
  眼耳鼻舌身　　心意诸情根
  其性悉空寂　　虚妄无真实
  观察正思惟　　有者无所有
  彼见不颠倒　　法眼清净故
  虚妄非虚妄　　若实若不实
  世间出世间　　但有假言说

尔时文殊师利菩萨。问财首菩萨言。佛子。一切众生非众生。如来云何随众生时。随命。随身。随行。随欲乐。随愿。随意。随方便。随思惟。随筹量。随众生见。而教化之。尔时财首菩萨。以偈答曰

  明智心境界　　常乐寂灭行
  我今如实说　　仁者善谛听
  分别观内身　　我身何所有
  若能如是观　　彼达我有无
  观身一切分　　无所依止住
  谛了是身者　　于身无所著
  能解身如实　　明达一切法
  知法悉虚妄　　其心无所染
  身命相随顺　　展转更相因
  犹如旋火轮　　前后不可知
  智者能观察　　一切有无常
  诸法空无我　　则离一切相
  因缘所起业　　无我犹如梦
  果报性寂灭　　前后无异相
  一切世间法　　唯以心为主
  随乐取相者　　皆悉是颠倒
  世间所有法　　一切悉虚妄
  不能解诸法　　真实无有二
  一切生灭法　　皆悉从缘起
  念念速归灭　　始终无异相

尔时文殊师利。问宝首菩萨言。佛子。一切众生四大。悉非我非我所。云何众生。或受苦受乐。或作恶作善。或内端正或外端正。或受少报或受多报。或有现报或有后报。然诸法性无善无恶。尔时宝首菩萨。以偈答言

  随所行诸业　　受果报亦然
  造者无所有　　诸佛如是说
  犹如明净镜　　随其面像现
  内外无所有　　业性亦如是
  亦如田种子　　各各不相知
  自然能作因　　业性亦如是
  亦如大幻师　　在彼四衢道
  示现种种色　　业性亦如是
  如匠造木人　　能出种种声
  彼无我非我　　业性亦如是
  亦如众鸟类　　出[穀-禾+卵]音不同
  能作种种声　　业性亦如是
  如亲因缘会　　受生无来者
  诸根各别异　　业性亦如是
  如大地狱中　　众生受苦恼
  苦恼无来处　　业性亦如是
  亦如转轮王　　成就胜七宝
  彼无所从来　　业性亦如是
  亦如诸世界　　有成或有败
  成败无来去　　业性亦如是

尔时文殊师利。问德首菩萨言。佛子。如来唯觉一法。云何乃说无量诸法。音声遍满无量世界。悉能教化无量众生。出无量声现无量身。了知无量众生心意。示现无量神足自在示现无量无边世界。示现无量殊胜庄严。示现无量种种境界。而法性分别实不可得。尔时德首菩萨。以偈答曰

  佛子乃能问　　甚深微妙义
  智者若知此　　常乐求功德
  犹如地性一　　能持种种物
  不分别一异　　诸佛法如是
  犹如火性一　　能烧世间物
  火性无分别　　诸佛法如是
  犹如大海水　　注以百川流
  其味无别异　　诸佛法如是
  犹如风性一　　吹动一切物
  风性无分别　　诸佛法如是
  犹如龙雷震　　普雨一切地
  雨渧无分别　　诸佛法如是
  犹如大地一　　能生种种芽
  地性无别异　　诸佛法如是
  犹日无云曀　　普能照十方
  光明无异性　　诸佛法如是
  犹如空中月　　世间靡不见
  非至一切处　　诸佛法如是
  犹如大梵王　　普应现大千
  其身无别异　　诸佛法如是

尔时文殊师利。问目首菩萨言。佛子。如来福田等一无异。云何布施果报不同。有种种色。种种性。种种家。种种根。种种财。种种奇特。种种眷属。种种自在。种种功德。种种慧。如来平等无有怨亲。尔时目首菩萨。以偈答曰

  譬如大地一　　能生种种芽
  于彼无怨亲　　佛福田亦然
  譬如水一味　　因器故不同
  诸佛福田一　　众生故有异
  譬如大幻师　　能令众欢喜
  诸佛圣福田　　随愿令欣悦
  譬如辩才王　　能令众欢喜
  诸佛圣福田　　令众生悦乐
  譬如明净镜　　随对现众像
  诸佛圣福田　　众生故有异
  譬如大药王　　消灭一切毒
  诸佛圣福田　　能灭烦恼患
  譬如日出时　　能除一切闇
  诸佛圣福田　　普照十方界
  譬如净满月　　普照四天下
  诸佛圣福田　　平等无偏党
  譬如毗岚风　　震动一切地
  诸佛圣福田　　能动三界有
  譬如火劫起　　天地靡不烧
  诸佛圣福田　　能烧一切有

尔时文殊师利。问进首菩萨言。佛子。众生为见如来教断诸烦恼耶。为知色受想行识欲界色界无色界痴爱。断诸烦恼耶。若知色受想行识欲界色界无色界痴爱。断诸烦恼者。如来教法何所增损。尔时进首菩萨。以偈答曰

  佛子善谛听　　我说如实义
  或有速出要　　或有难解脱
  若欲求除灭　　无量诸过恶
  应当一切时　　勇猛大精进
  譬如微小火　　樵湿则能灭
  于佛教法中　　懈怠者亦然
  譬如人钻火　　未出数休息
  火势随止灭　　懈怠者亦然
  譬如净火珠　　离缘而求火
  毕竟不可得　　懈怠者亦然
  譬如明净日　　闭目求见色
  于佛教法中　　懈怠者亦然
  譬人无手足　　欲射过大地
  永不从彼意　　懈怠者亦然
  譬如大海水　　一毛渧求尽
  于佛教法中　　懈怠者亦然
  譬如火劫起　　欲以少水灭
  于佛教法中　　懈怠者亦然
  譬人见虚空　　便言我身满
  于佛教法中　　懈怠者亦然

尔时文殊师利。问法首菩萨言。佛子。如佛所说。闻受法者能断烦恼。云何众生等闻正法而不能断。随淫怒痴。随慢。随爱。随忿。随悭嫉。随恨。随谄曲。是诸垢法悉不离心。心无所行能断结使。尔时法首菩萨。以偈答曰

  佛子善谛听　　所问如实义
  非但积多闻　　能入如来法
  譬人水所漂　　惧溺而渴死
  不能如说行　　多闻亦如是
  譬人大惠施　　种种诸肴膳
  不食自饿死　　多闻亦如是
  譬如有良医　　具知诸方药
  自疾不能救　　多闻亦如是
  譬如贫穷人　　日夜数他宝
  自无半钱分　　多闻亦如是
  譬如帝王子　　应受无极乐
  业障故贫苦　　多闻亦如是
  譬如聋聩人　　善奏诸音声
  悦彼不自闻　　多闻亦如是
  譬如盲瞽人　　本习故能画
  示彼不自见　　多闻亦如是
  譬如海导师　　能度无量众
  拯彼不自济　　多闻亦如是
  譬人处大众　　善说胜妙事
  内自无实德　　多闻亦如是

尔时文殊师利。问智首菩萨言。佛子。于佛法中智慧为首。如来何故。或为众生。赞叹檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜慈悲喜舍。此一一法。皆不能得无上菩提。尔时智首菩萨。以偈答曰

  难知而能知　　随顺众生心
  佛子所问义　　谛听我今说
  过去未来世　　现在诸导师
  未曾以一法　　得成无上道
  如来知众生　　本性所修习
  善顺应度者　　为说净妙法
  悭者赞布施　　毁禁赞持戒
  嗔恚赞忍辱　　懈怠赞精进
  乱意赞禅定　　愚痴赞智慧
  不仁赞慈愍　　怒害赞大悲
  忧戚为赞喜　　憎爱为赞舍
  如是修习者　　渐解一切法
  譬如造宫室　　起基令坚固
  施戒亦如是　　菩萨众行本
  赞如牢坚城　　防御诸敌难
  忍进亦如是　　防护诸菩萨
  譬如大力王　　威德定天下
  禅智亦如是　　安隐诸菩萨
  譬如转轮王　　具受一切乐
  四等亦如是　　安乐诸菩萨

尔时文殊师利。问贤首菩萨言。佛子。一切诸佛。唯以一乘得出生死。云何今见一切佛刹。事事不同。所谓世界众生。说法教化。寿命光明。神力众会。佛法法住。如是等事皆悉不同。无有不具一切佛法。而能成就无上菩提。尔时贤首菩萨。以偈答曰

  文殊法常尔　　法王唯一法
  一切无碍人　　一道出生死
  一切诸佛身　　唯是一法身
  一心一智慧　　力无畏亦然
  随众生本行　　求无上菩提
  佛刹及众会　　说法悉不同
  一切诸佛刹　　平等普严净
  众生业行异　　所见各不同
  诸佛及佛法　　众生莫能见
  佛刹法身众　　说法亦如是
  本行广清净　　具足一切愿
  彼人见真实　　明达知见者
  随顺众生欲　　诸业及果报
  各令见真实　　佛力自在故
  佛刹无异相　　如来无憎爱
  随彼众生行　　自得如是见
  非是一切佛　　安住导师咎
  无量诸世界　　示现见不同
  一切诸世界　　所应受化者
  常见人中雄　　诸佛法如是

尔时诸菩萨。谓文殊师利言。佛子。我等所解各各已说。仁者辩才深入。次应敷演。何等是佛境界。何等是佛境界因。何等是佛境界所入。何等是佛境界所度。何等是佛境界随顺知。何等是佛境界随顺法。何等是佛境界分别知。何等是识佛境界。何等是决定知佛境界。何等是佛境界照。何等是佛境界广。尔时文殊师利。以偈答曰

  如来深境界　　其量齐虚空
  一切众生入　　真实无所入
  如来境界因　　唯佛能分别
  自余无量劫　　演说不可尽
  随顺众生故　　普入诸世间
  智慧常寂然　　不同世所见
  度脱诸群生　　随顺其心智
  宣畅无穷尽　　唯是佛境界
  如来一切智　　三世无障碍
  诸佛妙境界　　皆悉如虚空
  法界无异相　　随顺众生说
  若欲具分别　　唯佛之境界
  一切诸世间　　无量众音声
  随时悉了知　　其实无分别
  非识所能识　　亦非心境界
  自性真清净　　能示诸群生
  非业非烦恼　　寂灭无所住
  无明无所行　　平等行世间
  一切众生心　　普在三世中
  如来于一念　　一切悉明达

尔时此娑婆世界众生。佛神力故。见此佛刹一切众生。如所行法。如所行业。如世间行。随身所行。随根所行。随其行报所生之处。持戒毁禁说法果报。如是世界中事一切悉见。如是东方百千亿世界。不可量不可数不可思议不可称无等无边无分齐不可说虚空法界等一切世界。乃至说法果报一切悉见南西北方四维上下亦复如是

大方广佛华严经卷第五大方广佛华严经卷第六

        东晋天竺三藏佛驮跋陀罗译

    净行品第七

尔时智首菩萨。问文殊师利言。佛子。云何菩萨不染身口意业。不害身口意业。不痴身口意业。不退转身口意业。不动身口意业。应赞叹身口意业。清净身口意业。离烦恼身口意业。随智慧身口意业。云何菩萨生处成就。姓成就。家成就色相成就。念成就。智慧成就趣成就。无畏成就。觉悟成就。云何菩萨第一智慧。最上智慧。胜智慧。最胜智慧。不可量智慧。不可数智慧。不可思议智慧。不可称智慧。不可说智慧。云何菩萨因力具足。意力具足。方便力具足。缘力具足。境界力具足。根力具足。止观力具足。定力具足。云何菩萨善知阴界入。善知缘起法。善知欲色无色界。善知过去未来现在。云何菩萨修七觉意。修空无相无作。云何菩萨满足檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜慈悲喜舍。云何菩萨得是处非处智力。过去未来现在业报智力。种种诸根智力。种种性智力。种种欲智力。一切至处道智力。禅定解脱三昧垢净智力。宿命无碍智力。天眼无碍智力。断一切烦恼习气智力。云何菩萨常为诸天王守护恭敬供养。龙王。鬼神王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王梵天王等守护恭敬供养。云何菩萨为众生舍。为救为归为趣。为炬为明为灯。为导为无上导。云何菩萨。于一切众生。为第一为大为胜。为上为无上。为无等为无等等。尔时文殊师利。答智首菩萨曰。善哉善哉。佛子。多所饶益多所安隐。哀愍世间惠利一切安乐天人。问如是义。佛子。菩萨成就身口意业。能得一切胜妙功德。于佛正法心无挂碍。去来今佛所转法轮。能随顺转不舍众生。明达实相。断一切恶具足众善。色像第一。悉如普贤大菩萨等。成就如来。一切种智。于一切法悉得自在。而为众生第二尊导。佛子。何等身口意业。能得一切胜妙功德

  菩萨在家　　当愿众生　　舍离家难
  入空法中　　孝事父母　　当愿众生
  一切护养　　永得大安　　妻子集会
  当愿众生　　令出爱狱　　无恋慕心
  若得五欲　　当愿众生　　舍离贪惑
  功德具足　　若在妓乐　　当愿众生
  悉得法乐　　见法如幻　　若在房室
  当愿众生　　入贤圣地　　永离欲秽
  着宝璎珞　　当愿众生　　舍离重担
  度有无岸　　若上楼阁　　当愿众生
  升佛法堂　　得微妙法　　布施所珍
  当愿众生　　悉舍一切　　心无贪着
  若在聚会　　当愿众生　　究竟解脱
  到如来处　　若在危难　　当愿众生
  随意自在　　无所挂碍　　以信舍家
  当愿众生　　弃舍世业　　心无所著
  若入僧坊　　当愿众生　　一切和合
  心无限碍　　诣大小师　　当愿众生
  开方便门　　深入法要　　求出家法
  当愿众生　　得不退转　　心无障碍
  脱去俗服　　当愿众生　　解道修德
  无复懈怠　　除剃须发　　当愿众生
  断除烦恼　　究竟寂灭　　受着袈裟
  当愿众生　　舍离三毒　　心得欢喜
  受出家法　　当愿众生　　如佛出家
  开导一切　　自归于佛　　当愿众生
  体解大道　　发无上意　　自归于法
  当愿众生　　深入经藏　　智慧如海
  自归于僧　　当愿众生　　统理大众
  一切无碍　　受持净戒　　当愿众生
  具足修习　　学一切戒　　受行道禁
  当愿众生　　具足道戒　　修如实业
  始请和尚　　当愿众生　　得无生智
  到于彼岸　　受具足戒　　当愿众生
  得胜妙法　　成就方便　　若入房舍
  当愿众生　　升无上堂　　得不退法
  若敷床座　　当愿众生　　敷善法座
  见真实相　　正身端坐　　当愿众生
  坐佛道树　　心无所倚　　结跏趺坐
  当愿众生　　善根坚固　　得不动地
  三昧正受　　当愿众生　　向三昧门
  得究竟定　　观察诸法　　当愿众生
  见法真实　　无所挂碍　　舍跏趺坐
  当愿众生　　知诸行性　　悉归散灭
  下床安足　　当愿众生　　履践圣迹
  不动解脱　　始举足时　　当愿众生
  越度生死　　善法满足　　被着衣裳
  当愿众生　　服诸善根　　每知惭愧
  整服结带　　当愿众生　　自检修道
  不坏善法　　次着上衣　　当愿众生
  得上善根　　究竟胜法　　着僧伽梨
  当愿众生　　大慈覆护　　得不动法
  手执杨枝　　当愿众生　　心得正法
  自然清净　　晨嚼杨枝　　当愿众生
  得调伏牙　　噬诸烦恼　　左右便利
  当愿众生　　蠲除污秽　　无淫怒痴
  已而就水　　当愿众生　　向无上道
  得出世法　　以水涤秽　　当愿众生
  具足净忍　　毕竟无垢　　以水盥掌
  当愿众生　　得上妙手　　受持佛法
  澡漱口齿　　当愿众生　　向净法门
  究竟解脱　　手执锡杖　　当愿众生
  设净施会　　见道如实　　擎持应器
  当愿众生　　成就法器　　受天人供
  发趾向道　　当愿众生　　趣佛菩提
  究竟解脱　　若已在道　　当愿众生
  成就佛道　　无余所行　　涉路而行
  当愿众生　　履净法界　　心无障碍
  见趣高路　　当愿众生　　升无上道
  超出三界　　见趣下路　　当愿众生
  谦下柔软　　入佛深法　　若见险路
  当愿众生　　弃捐恶道　　灭除邪见
  若见直路　　当愿众生　　得中正意
  身口无曲　　见道扬尘　　当愿众生
  永离尘秽　　毕竟清净　　见道无尘
  当愿众生　　大悲所熏　　心意柔润
  见深坑涧　　当愿众生　　向正法界
  灭除诸难　　见听讼堂　　当愿众生
  说甚深法　　一切和合　　若见大树
  当愿众生　　离我诤心　　无有忿恨
  若见丛林　　当愿众生　　一切敬礼
  天人师仰　　若见高山　　当愿众生
  得无上善　　莫能见顶　　若见刺棘
  当愿众生　　拔三毒刺　　无贼害心
  见树茂叶　　当愿众生　　以道自荫
  入禅三昧　　见树好华　　当愿众生
  开净如华　　相好满具　　见树丰果
  当愿众生　　起道树行　　成无上果
  见诸流水　　当愿众生　　得正法流
  入佛智海　　若见陂水　　当愿众生
  悉得诸佛　　不坏正法　　若见浴池
  当愿众生　　入佛海智　　问答无穷
  见人汲井　　当愿众生　　得如来辩
  不可穷尽　　若见泉水　　当愿众生
  善根无尽　　境界无上　　见山涧水
  当愿众生　　洗濯尘垢　　意解清净
  若见桥梁　　当愿众生　　兴造法桥
  度人不休　　见修园圃　　当愿众生
  耘除秽恶　　不生欲根　　见无忧林
  当愿众生　　心得欢喜　　永除忧恼
  见好园池　　当愿众生　　勤修众善
  具足菩提　　见严饰人　　当愿众生
  三十二相　　而自庄严　　见素服人
  当愿众生　　究竟得到　　头陀彼岸
  见志乐人　　当愿众生　　清净法乐
  以道自娱　　见愁忧人　　当愿众生
  于有为法　　心生厌离　　见欢乐人
  当愿众生　　得无上乐　　憺怕无患
  见苦恼人　　当愿众生　　灭除众苦
  得佛智慧　　见强健人　　当愿众生
  得金刚身　　无有衰耄　　见疾病人
  当愿众生　　知身空寂　　解脱众苦
  见端正人　　当愿众生　　欢喜恭敬
  诸佛菩萨　　见丑陋人　　当愿众生
  远离鄙恶　　以善自严　　见报恩人
  当愿众生　　常念诸佛　　菩萨恩德
  见背恩人　　当愿众生　　常见贤圣
  不作众恶　　若见沙门　　当愿众生
  寂静调伏　　究竟无余　　见婆罗门
  当愿众生　　得真清净　　离一切恶
  若见仙人　　当愿众生　　向正真道
  究竟解脱　　见苦行人　　当愿众生
  坚固精勤　　不退佛道　　见着甲胄
  当愿众生　　誓服法铠　　得无师法
  见无铠仗　　当愿众生　　远离众恶
  亲近善法　　见论议人　　当愿众生
  得无上辩　　摧伏外道　　见正命人
  当愿众生　　得清净命　　威仪不异
  若见帝王　　当愿众生　　逮得法王
  转无碍轮　　见帝王子　　当愿众生
  履佛子行　　化生法中　　若见长者
  当愿众生　　永离爱欲　　深解佛法
  若见大臣　　当愿众生　　常得正念
  修行众善　　若见城郭　　当愿众生
  得金刚身　　心不可沮　　若见王都
  当愿众生　　明达远照　　功德自在
  若见妙色　　当愿众生　　得上妙色
  天人赞叹　　入里乞食　　当愿众生
  入深法界　　心无障碍　　到人门户
  当愿众生　　入总持门　　见诸佛法
  入人堂室　　当愿众生　　入一佛乘
  明达三世　　遇难持戒　　当愿众生
  不舍众善　　永度彼岸　　见舍戒人
  当愿众生　　超出众难　　度三恶道
  若见空钵　　当愿众生　　其心清净
  空无烦恼　　若见满钵　　当愿众生
  具足成满　　一切善法　　若得食时
  当愿众生　　为法供养　　志在佛道
  若不得食　　当愿众生　　远离一切
  诸不善行　　见惭愧人　　当愿众生
  惭愧正行　　调伏诸根　　见无惭愧
  当愿众生　　离无惭愧　　普行大慈
  得香美食　　当愿众生　　知节少欲
  情无所著　　得不美食　　当愿众生
  具足成满　　无愿三昧　　得柔软食
  当愿众生　　大悲所熏　　心意柔软
  得粗涩食　　当愿众生　　永得远离
  世间爱味　　若咽食时　　当愿众生
  禅悦为食　　法喜充满　　所食杂味
  当愿众生　　得佛上味　　化成甘露
  饭食已讫　　当愿众生　　德行充盈
  成十种力　　若说法时　　当愿众生
  得无尽辩　　深达佛法　　退坐出堂
  当愿众生　　深入佛智　　永出三界
  若入水时　　当愿众生　　深入佛道
  等达三世　　澡浴身体　　当愿众生
  身心无垢　　光明无量　　盛暑炎炽
  当愿众生　　离烦恼热　　得清凉定
  隆寒冰结　　当愿众生　　究竟解脱
  无上清凉　　讽诵经典　　当愿众生
  得总持门　　摄一切法　　若见如来
  当愿众生　　悉得佛眼　　见诸最胜
  谛观如来　　当愿众生　　悉睹十方
  端正如佛　　见佛塔庙　　当愿众生
  尊重如塔　　受天人敬　　敬心观塔
  当愿众生　　尊重如佛　　天人宗仰
  顶礼佛塔　　当愿众生　　得道如佛
  无能见顶　　右绕塔庙　　当愿众生
  履行正路　　究畅道意　　绕塔三匝
  当愿众生　　得一向意　　勤求佛道
  赞咏如来　　当愿众生　　度功德岸
  叹无穷尽　　赞佛相好　　当愿众生
  光明神德　　如佛法身　　若洗足时
  当愿众生　　得四神足　　究竟解脱
  昏夜寝息　　当愿众生　　休息诸行
  心净无秽　　晨朝觉悟　　当愿众生
  一切智觉　　不舍十方

佛子。是为菩萨身口意业。能得一切胜妙功德。诸天魔梵沙门婆罗门人及非人声闻缘觉所不能动

    大方广佛华严经贤首菩萨品第八之一

尔时文殊师利。以偈问了达深义净德。贤首菩萨曰

  佛子我已说　　菩萨清净行
  一切诸世尊　　咸共所赞叹
  又诸大士众　　甚深微妙行
  功德广大义　　仁者应演说
  贤首菩萨答　　佛子善谛听
  菩萨诸功德　　无量无有边
  我当随力说　　菩萨少功德
  我之所演畅　　如海一微渧
  菩萨于生死　　最初发心时
  一向求菩提　　坚固不可动
  彼一念功德　　深广无边际
  如来分别说　　穷劫犹不尽
  何况于无量　　无数无边劫
  具足修诸度　　诸地功德行
  十方世界中　　一切诸如来
  说彼功德云　　亦不能究竟
  今我说菩萨　　功德中少分
  如鸟履虚空　　如地一微尘
  非是无所因　　又亦非无缘
  菩萨初发意　　直心大功德
  于佛及法僧　　深起清净信
  信敬三宝故　　能发菩提心
  不求五欲乐　　宝货诸财利
  亦不求自安　　希望世名闻
  灭除众生苦　　令尽无有余
  誓度斯等类　　菩萨初发心
  常欲令众生　　离苦永安乐
  严净一切刹　　供养无量佛
  乐立佛正法　　欲得无上道
  净修一切智　　菩萨初发心
  深心净信不可坏　　恭敬供养一切佛
  尊重正法及圣僧　　信敬三宝故发心
  深信诸佛及正法　　亦信菩萨所行道
  正心信向佛菩提　　菩萨因是初发心
  信为道元功德母　　增长一切诸善法
  除灭一切诸疑惑　　示现开发无上道
  净信离垢心坚固　　灭除憍慢恭敬本
  信是宝藏第一法　　为清净手受众行
  信能舍离诸染着　　信解微妙甚深法
  信能转胜成众善　　究竟必至如来处
  清净明利诸善根　　信力坚固不可坏
  信永除灭一切恶　　信能逮得无师宝
  信于法门无障碍　　舍离八难得无难
  信能超出众魔境　　示现无上解脱道
  一切功德不坏种　　出生无上菩提树
  长养最胜智慧门　　信能示现一切佛
  是故演说次第行　　信乐最胜甚难得
  譬如灵瑞优昙华　　亦如随意妙宝珠
  若信恭敬一切佛　　则持净戒顺正教
  若持净戒顺正教　　诸佛贤圣所赞叹
  戒是无上菩提本　　应当具足持净戒
  若能具足持净戒　　一切如来所赞叹
  若信恭敬一切佛　　则能奇特供最胜
  若能奇特供最胜　　彼信佛心难思议
  若信如来正真法　　则常乐闻无厌足
  若乐闻法无厌足　　欣悟不可思议法
  若信恭敬清净僧　　则信坚固不可坏
  若信坚固不可坏　　彼人信力不可动
  若信坚固不可动　　诸根明利悉清净
  若根明利悉清净　　则离一切恶知识
  若能远离恶知识　　则能亲近善知识
  若能亲近善知识　　则修无量诸功德
  若能广修诸功德　　则能善解诸因果
  若能善解诸因果　　则成殊胜妙解脱
  若成殊胜妙解脱　　则为一切佛所护
  若为一切佛所护　　则生无上菩提心
  若生无上菩提心　　则能勤修佛功德
  若能勤修佛功德　　则能得生诸佛家
  若能得生诸佛家　　则于诸法无所著
  若于诸法无所著　　则得深心妙清净
  若得深心妙清净　　则得殊胜无上心
  若得无上殊胜心　　则修一切波罗蜜
  若修一切波罗蜜　　则能具足摩诃衍
  若能具足摩诃衍　　则法供养一切佛
  若法供养一切佛　　则念佛定不可坏
  若念佛定不可坏　　则常睹见十方佛
  若常睹见十方佛　　则知如来常安住
  若知如来常安住　　则于其人法永存
  若于其人法永存　　则得辩才无穷尽
  若得辩才无穷尽　　则能演说无量法
  若能演说无量法　　则能度脱一切众
  若能度脱一切众　　则得大悲心坚固
  若得大悲心坚固　　则常喜乐甚深法
  若能喜乐甚深法　　则能舍离有为过
  若能舍离有为过　　则离我慢诸放逸
  若离我慢诸放逸　　则能兼利一切众
  若能兼利一切众　　则处生死无忧戚
  若处生死无忧戚　　则能精进无有上
  若能精进无有上　　则得一切诸神通
  若得一切诸神通　　则解一切众生行
  若解一切众生行　　则能成就诸众生
  若能成就诸众生　　则得成就众生智
  若得成就众生智　　则能具足四摄法
  若能具足四摄法　　则与众生无量利
  若与众生无量利　　则能具足方便慧
  若能具足方便慧　　则能安住无上道
  若能安住无上道　　则一切魔不能坏
  若一切魔不能坏　　则能超出四魔道
  若能超出四魔道　　则至坚固不动地
  若至坚固不动地　　则得无生深法忍
  若得无生深法忍　　则为诸佛所授记
  若为诸佛所授记　　则常普现诸佛前
  若常普现诸佛前　　则解诸佛微密教
  若解诸佛微密教　　则为诸佛常护念
  若为诸佛常护念　　以佛功德自庄严
  若佛功德自庄严　　则得无量功德身
  若得无量功德身　　其身显耀如金山
  若身显耀如金山　　具足众相三十二
  若具众相三十二　　八十种好自庄严
  八十种好自庄严　　其身光明无有量
  若身光明无有量　　光明庄严难思议
  若光庄严难思议　　则出无量宝莲华
  若出无量宝莲华　　一一华坐无量佛
  普现十方无量刹　　教化度脱一切众
  若能度脱一切众　　则得无量自在力
  若得无量自在力　　则能严净诸佛刹
  解说甚深微妙法　　不可思议众欢喜
  若说微妙甚深法　　不可思议众欢喜
  则能具足四辩力　　自在能度一切众
  若能具足四辩力　　自在能度一切众
  彼人智慧常在前　　身口意业无错谬
  若彼智慧常在前　　身口意业无错谬
  彼人愿力得自在　　随众所宜现其身
  若彼愿力得自在　　随众所宜现其身
  为诸众生说法时　　音声微妙难思议
  若为众生说法时　　音声微妙难思议
  于彼一切众生类　　一念之中悉知心
  若彼一切众生类　　一念之中悉知心
  其人生死永无余　　寂灭一切烦恼患
  若人生死永无余　　寂灭一切烦恼患
  法身功德智慧具　　深解一切诸法实
  若身功德智慧具　　深解一切诸法实
  十地十种自在力　　皆悉究竟胜解脱
  若十地种自在力　　皆悉究竟得解脱
  授记庄严悉具足　　无量法门得自在
  若记庄严悉具足　　无量法门得自在
  尽为一切十方佛　　皆与授记无有余
  若为一切十方佛　　皆与授记无有余
  甘露法水灌其顶　　十方诸佛授记竟
  若甘露水灌其顶　　十方诸佛授记竟
  法身充满遍虚空　　安住不动十方界
  若身充满遍虚空　　安住不动十方界
  一切诸天及世人　　无等等界莫能知
  于本所行无不果　　其见闻者悉不空
  此是无上大福田　　供养施者大果报
  彼善男子威神力　　正法常住永不灭
  十善功德诸妙行　　无量法宝最无上
  彼威神力佛法海　　法宝坚固如金刚
  智慧满足不可尽　　如是无量功德海
  或有刹土无有佛　　于彼示现成正觉
  或有国土无有法　　于彼示现说法藏
  菩萨希望一切断　　于一念顷游十方
  示现十方如满月　　无量方便化众生
  于彼十方世界中　　念念示现成佛道
  转正法轮入涅槃　　现分舍利为众生
  或现声闻缘觉道　　示现成佛普庄严
  现无量劫度众生　　以三乘门广开化
  或现男女种种形　　天人龙神阿修罗
  随诸众生若干身　　无量行业诸音声
  一切示现无有余　　海印三昧势力故
  不可思议庄严刹　　恭敬供养一切佛
  光明庄严难思议　　教化众生无有量
  智慧自在不可议　　说法教化得自在
  施戒忍辱精进禅　　方便智慧诸功德
  一切自在难思议　　华严三昧势力故
  入微尘数诸三昧　　一三昧生尘等定
  一尘中现无量刹　　而彼微尘亦不增
  一尘内刹现有佛　　或现有刹而无佛
  或现有刹净不净　　或现大刹及中下
  或刹伏住或随顺　　或如野马或四方
  或有国土如天网　　世界成败无不现
  如一微尘所示现　　一切微尘亦如是
  是名三昧自在力　　亦无量称解脱力
  若欲供养一切佛　　出生无量三昧门
  能以一手覆三千　　供养一切诸如来
  十方国土胜妙华　　无价宝珠殊异香
  皆悉自然从手出　　供养道树诸最胜
  无价宝衣杂妙香　　宝幢幡盖而庄严
  金华宝帐妙校饰　　十方一切上供具
  悉从手中自然出　　供养道树诸最胜
  一切十方诸妓乐　　无量和雅妙音声
  及以种种众妙偈　　赞叹诸佛实功德
  音声遍满十方界　　悉从掌中自然出
  无量清净诸行业　　所得右手放光明
  香水普洒十方国　　供养一切照世灯
  放妙庄严大光明　　出生无量宝莲华
  于莲华中无量佛　　相好具足自庄严
  放华庄严净光明　　庄严妙华以为帐
  散诸杂华遍十方　　供养一切诸如来
  放香庄严净光明　　庄严妙香以为帐
  散诸杂香遍十方　　供养一切诸如来
  放细末香净光明　　庄严末香以为帐
  散诸末香遍十方　　供养一切诸如来
  放衣庄严净光明　　庄严宝衣以为帐
  散诸宝衣遍十方　　供养一切诸如来
  放宝庄严净光明　　庄严妙宝以为帐
  散诸妙宝遍十方　　供养一切诸如来
  放妙莲华净光明　　众妙莲华以为帐
  散诸莲华遍十方　　供养一切诸如来
  放诸璎珞净光明　　诸妙璎珞以为帐
  散诸璎珞遍十方　　供养一切诸如来
  放庄严幢净光明　　其幢青黄赤白色
  无量种种而庄严　　以幢严饰诸佛刹
  执持杂宝庄严盖　　众宝缯彩为垂带
  宝铃演出最胜音　　以此供养诸如来
  手出供具难思议　　如是供养一导师
  供一切佛亦如是　　大仙三昧自在力
  欲安一切众生类　　出生自在胜三昧
  一切所行诸功德　　无量方便度众生
  或现供养如来门　　或现一切布施门
  或现具足持戒门　　或现无尽忍辱门
  无量苦行精进门　　禅定寂静三昧门
  无量大辩智慧门　　一切所行方便门
  现四无量神通门　　大慈大悲四摄门
  无量功德智慧门　　一切缘起解脱门
  清净根力道法门　　或现声闻小乘门
  或现缘觉中乘门　　或现无上大乘门
  或现无常众苦门　　或现无我众生门
  或现不净离欲门　　寂静灭定三昧门
  随诸众生起病门　　一切对治诸法门
  随彼众生烦恼性　　如应说法广开化
  如是一切诸法门　　随其本性而济度
  一切天人莫能知　　是自在胜三昧力
  出生随乐胜三昧　　分别了知众生心
  随顺教化诸群生　　令离忧恼得欢喜
  劫中灾难饥馑时　　一切资生诸乐具
  随其所须普周给　　是为能作大施主
  肴膳香美上味食　　宝衣庄严随所乐
  己身国土珍爱施　　好施众生悉从化
  以诸相好庄严身　　上妙衣服及众华
  杂种末香以涂身　　现此严饰度众生
  一切世间所喜乐　　种种殊胜净妙色
  随其所应普示现　　令乐色者得解脱
  柔软美声如哀鸾　　拘真罗等微妙音
  具足八种梵音声　　随其所乐为说法
  八万四千诸法门　　诸佛以此度众生
  分别诸法无量门　　随众生性化导之
  众生苦乐利无利　　一切世间所行法
  悉能普应同其事　　以此摄法度众生
  无量无边大苦海　　为众生故悉能忍
  与彼同事不念苦　　饶益众生令安乐
  若有不识出家法　　乐着生死不求解
  是故菩萨舍国财　　常乐出家求寂静
  五欲所缚不离家　　欲令众生解脱故
  示现不乐处爱欲　　是故出家求解脱
  欲令具足十种行　　是佛如来本所修
  菩萨所行无有余　　修习是法度众生
  或有众生寿无量　　烦恼微细乐世间
  为斯一切众生类　　示现生老病死患
  或有贪欲嗔恚痴　　烦恼猛火常炽然
  为现生老病死苦　　化度一切众生故
  如来十力无所畏　　及佛十八不共法
  最胜无量诸功德　　以此妙法度众生
  说法教诫及神足　　住持自在神通力
  菩萨示现斯功德　　以此济度诸群生
  如是方便无有量　　随顺世间度众生
  不着世间如莲华　　能令众生大欢喜
  博综多识辩才王　　文颂谈论过世间
  示现世间众技术　　譬如幻师现众像
  或为长者邑中主　　或为贾客商人导
  或为国王及大臣　　或为良医疗众病
  或于旷野作大树　　或为良药无尽藏
  或作宝珠随所求　　迷道众生示正路
  若见世界始成立　　众生未知资生法
  是时菩萨为工匠　　为之示现种种业
  不作恶业害生具　　欲令群生寿安乐
  咒术药草学众论　　悉为诸佛所称叹
  或现仙人殊胜行　　一切群生所爱乐
  示行苦行及深法　　随其所应悉能现
  或作外道出家人　　或复示现事火法
  或现裸形无衣服　　能为彼人作师长
  见有邪命种种行　　习行非法以为胜
  一切梵志诸苦行　　能于其中而化度
  五热炙身随日转　　或受牛鹿畜生戒
  被服草衣奉事火　　为化是等作导师
  现乐游行诸天庙　　自投恒河求解脱
  食果服气而饮水　　思惟正法不放逸
  或现胡跪翘一足　　或卧刺棘灰土上
  或卧杵石求解脱　　为彼师导教化故
  如是等类诸外道　　具观彼意如应化
  菩萨苦行无与等　　外道由是得解脱
  若见世间无正见　　常依一切邪见住
  方便为说甚深法　　悉令得解真实谛
  或以鬼神边地语　　为斯等类说四谛
  或以正语说四谛　　或人天语说四谛
  或以法辩说四谛　　或以义辩说四谛
  或以辞辩说四谛　　或无尽辩说四谛
  或八部音说四谛　　或一切音说四谛
  随彼所解语言音　　为说四谛令解脱
  知一切语不思议　　是名说法三昧力
  安隐众生胜三昧　　为度一切众生故
  放大光明难思议　　以此光明救群生
  所放光明名善现　　若有众生遇斯光
  彼获果报无有量　　因是究竟无上道
  由彼显现诸如来　　亦现一切法僧道
  又现最胜塔形像　　故获光明名善现
  又放光明名清净　　映蔽一切天人光
  除灭一切诸闇冥　　普照十方无量国
  彼光觉悟一切众　　执持灯明供养佛
  以灯供养诸佛故　　得成最胜世间灯
  然诸香油及酥灯　　或以竹木为炬明
  以能然此诸灯明　　得是清净妙光明
  又放光明名济度　　彼光觉悟一切众
  当发无上菩提心　　度脱欲海诸群生
  若发无上菩提心　　度脱欲海诸群生
  彼悉能度四驶流　　示导无畏解脱处
  造立无量诸桥梁　　或作舟船度众生
  毁呰有为赞寂静　　因此得成度光明
  又放光明名除爱　　彼光觉悟一切众
  舍离五欲诸渴爱　　思乐解脱甘露水
  若能远离五欲渴　　思乐解脱甘露水
  以佛解脱甘露雨　　灭除众生诸渴爱
  惠施池井诸泉流　　以求无上佛菩提
  毁呰五欲赞诸禅　　因此得成灭爱光
  又放光明名欢喜　　彼光觉悟一切众
  欢喜爱乐佛菩提　　发心愿求无师宝
  建立如来大慈像　　相好具足坐莲华
  赞叹最胜诸功德　　因是得成喜光明

大方广佛华严经卷第六大方广佛华严经卷第七

        东晋天竺三藏佛驮跋陀罗译

    贤首菩萨品第八之二

  又放光明名爱乐　　彼光觉悟一切众
  心常爱乐诸如来　　无上法宝清净僧
  常会十方诸佛前　　逮成无上深法忍
  教化无量群生类　　心常念佛深妙法
  开发众生菩提心　　因是得成爱乐光
  又放光明名德聚　　彼光觉悟一切众
  普行种种无量施　　以此愿求无上道
  随其所求皆满足　　一切施会悉清净
  随其所求惠施故　　因是得成德聚光
  又放光明名深智　　彼光觉悟一切众
  于一法门一念中　　悉解无量诸法门
  分别诸法化众生　　及诸法相如实义
  说法说义具足故　　因是得成深智光
  又放光明名慧灯　　彼光觉悟一切众
  诸法空寂无生灭　　解达非有亦非无
  譬如野马水月形　　亦如幻梦镜中像
  诸法无主悉空寂　　因是得成慧灯光
  又放光名法自在　　彼光觉悟一切众
  陀罗尼藏不可尽　　能持如来一切法
  恭敬供养持法者　　防卫守护众贤圣
  以无量法施众生　　因是得成自在光
  又放光明名无悭　　彼光觉悟除贪惜
  解知财宝非常有　　悉能舍离无所著
  难制悭心能调伏　　解财如梦如浮云
  常能欢喜乐布施　　因是得成无悭光
  又放光明名清凉　　彼光觉悟毁禁者
  安立众生净戒中　　启导令逮无师宝
  十善业迹悉清净　　劝化众生持净戒
  开发众生求佛道　　因是得成清凉光
  又放光名忍庄严　　彼光觉悟嗔恚者
  舍离嗔恚增上慢　　常乐柔和忍辱法
  众生恶性难忍者　　悉能堪忍求佛道
  常能赞叹忍辱法　　因是得成庄严光
  又放光明名转胜　　彼光觉悟懈怠者
  常能勤修三种业　　恭敬供养佛法僧
  若能勤修三种业　　恭敬供养佛法僧
  彼能超出四魔境　　速成无上佛菩提
  劝化众生令精进　　恭敬供养佛法僧
  佛法欲灭能护持　　因是得成转胜光
  又放光明名寂静　　彼光觉悟乱意者
  舍离贪欲嗔恚痴　　正住甚深诸三昧
  远恶知识不善行　　又离十种非法语
  赞叹坐禅空闲处　　因是得成寂静光
  又放光名慧庄严　　彼光觉悟愚痴者
  善知缘起得解脱　　智慧照明了诸根
  若知缘起得解脱　　智慧照明了诸根
  得圣智慧诸三昧　　逮等正觉照世间
  舍国财宝所爱身　　精勤求法为佛道
  专心说法为众生　　因是得成慧光明
  又放光明名佛慧　　彼光觉悟一切众
  见不思议无量佛　　各各坐宝莲华上
  赞叹诸佛佛解脱　　说佛自在无有量
  广说佛力诸神通　　因是得成佛慧光
  又放光明名无畏　　彼光安慰恐怖者
  非人所持诸毒害　　无量恐怖悉除灭
  普于众生施无畏　　心常慈忍离恼害
  拯济危难无救者　　因是得成无畏光
  又放光明名安隐　　彼光所触疾病者
  灭除一切诸苦痛　　悉得正受三昧乐
  施诸良药疗众患　　摩以宝珠香涂身
  或酥油乳石蜜施　　因是得成安隐光
  又放光明名见佛　　彼光觉悟命终者
  念佛三昧必见佛　　命终之后生佛前
  见彼临终劝念佛　　又示尊像令瞻敬
  又复劝令归依佛　　因是得成见佛光
  又放光明名乐法　　彼光觉悟一切众
  听法讲说及书写　　于正法中常爱乐
  佛法欲灭能护持　　令求法者意充满
  精勤修习佛正法　　因是得成乐法光
  又放光明名妙音　　彼光觉悟诸佛子
  一切世间所有声　　闻者皆是如来音
  大音赞扬诸如来　　妓乐钟磬供养佛
  又常赞叹佛音声　　因是得成妙音光
  又放光名施甘露　　彼光觉悟一切众
  远离一切放逸行　　皆悉具足诸功德
  分别无量大苦海　　有为危脆非安隐
  宣扬赞叹寂灭乐　　因是得成甘露光
  又放光明名殊胜　　彼光觉悟一切众
  于如来所闻胜戒　　胜妙三昧胜智慧
  常叹诸佛胜妙戒　　胜妙三昧胜智慧
  一心修习求菩提　　因是得成胜光明
  又放光名宝庄严　　彼光觉悟一切众
  得胜宝藏不可尽　　以此供养诸世尊
  以宝献佛及塔庙　　兼施一切诸贫乏
  以众珍奇供最胜　　因是成宝庄严光
  又放光明名妙香　　彼光觉悟一切众
  其有众生闻是香　　具足得佛诸功德
  以人天香涂其地　　供养一切诸如来
  以香造像及塔庙　　因是得成妙香光
  又放光名杂庄严　　以幢幡盖而严饰
  和雅妓乐微妙音　　散众宝华满十方
  本以微妙妓乐音　　和末涂香众杂华
  幢盖幡帐供诸佛　　因是得成庄严光
  又放光明名端严　　令十方地平如掌
  扫除僧坊大仙塔　　因是得成端严光
  又放光明名大云　　彼光能雨妙香水
  香水洒塔及僧坊　　因是得成大云光
  又放光名衣庄严　　令裸形者得上服
  以庄严服施众生　　因是成衣庄严光
  又放光明名上味　　令饥饿者得美膳
  本施种种上味食　　因是得成上味光
  又放光名示现宝　　令诸贫乏得宝藏
  以无尽藏施三宝　　因是得成示宝光
  又放光名眼清净　　能令盲者见众色
  以灯供佛及塔庙　　因是得成净眼光
  又放光名耳清净　　能令聋者闻众音
  妓乐供佛及塔庙　　因是得成净耳光
  又放光名鼻根净　　闻若不闻悉令闻
  众香供佛及塔庙　　因是得成鼻净光
  又放光名舌根净　　以柔软音赞诸佛
  永离粗犷不善语　　因是得成净舌光
  又放光名身根净　　诸根毁坏令具足
  礼拜诸佛及塔寺　　因是得成身净光
  又放光名意根净　　令失心者得正念
  修习三昧禅定力　　因是得成意净光
  又放光名色清净　　睹见不可思议佛
  以众妙色庄严塔　　因是得成色净光
  又放光名声清净　　解声非声悉空寂
  化众令知声如响　　因是得成声净光
  又放光名香清净　　令诸臭秽成妙香
  香水洗塔菩提树　　因是得成净香光
  又放光名味清净　　悉除一切味中毒
  供养佛僧及父母　　因是得成味净光
  又放光名触清净　　坚强粗涩皆柔软
  雨刀轮戟诸锋刃　　皆悉变成宝华鬘
  柔软妙衣布道巷　　最胜行时足蹈上
  香华上服用布施　　因是得成触净光
  又放光名法清净　　一一毛孔无量佛
  各说妙法难思议　　悉令众生得欢喜
  因缘所生非生性　　如来法身非是身
  湛然常住如虚空　　因此化导成法光
  如是等比光明门　　无量无边恒沙数
  悉从大仙毛孔出　　一切业果皆悉现
  如一毛孔所放光　　无量无边恒沙数
  一切毛孔亦如是　　是大仙定自在力
  随其本行得光明　　宿世同行有缘者
  如其所应放光明　　是名大仙智自在
  所修行业有同者　　及行随喜功德分
  闻见菩萨清净行　　彼人得见此光明
  若修无量诸功德　　恭敬供养无数佛
  心常乐求无上道　　彼人觉悟是光明
  譬如生盲不见日　　非为无日出世间
  诸有目者悉睹见　　各随所务修其业
  大圣光明亦如是　　或有众生见不见
  邪见恶害所不睹　　胜智慧者乃能见
  摩尼宝殿上辇乘　　众宝香味庄严具
  有功德者自然备　　非无德者所能获
  大圣光明亦如是　　随其行业见不见
  闻是分别诸光明　　精勤恭敬信向者
  灭除一切诸疑惑　　速成无上功德幢
  出生微妙胜三昧　　诸佛眷属大庄严
  神力于此得自在　　悉能显现示众生
  三千大千妙庄严　　化一莲华满世界
  结跏趺坐悉充满　　是名自在三昧力
  十方世界微尘刹　　化作七宝大莲华
  佛子眷属共围绕　　是名自在胜三昧
  宿世成就善因缘　　具足功德求佛道
  彼等众生绕菩萨　　一切合掌观无厌
  彼大仙人法如是　　甚深正受三昧力
  菩萨处彼清净众　　如月在星独明耀
  如此一方所示现　　诸佛子等为眷属
  一切十方亦如是　　示现三昧自在力
  十方世界有缘故　　往返出入度众生
  或见菩萨入正受　　或见菩萨从定起
  或东方见入正受　　或西方见三昧起
  或西方见入正受　　或东方见三昧起
  如是出入遍十方　　或异方见入正受
  或异方见三昧起　　是大仙定自在力
  东方世界无有余　　佛刹如来难思议
  菩萨常现彼佛前　　是名寂静三昧力
  东方一切诸佛前　　常见安住入正受
  西方一切诸佛前　　常见菩萨供养佛
  西方世界无有余　　佛刹如来难思议
  于彼一切诸佛前　　常见菩萨入正受
  西方见彼入正受　　东方佛刹无有余
  于彼佛前三昧起　　恭敬供养一切佛
  如是十方诸佛前　　出入三昧无有余
  或见菩萨入正受　　或见恭敬供养佛
  于眼根中入正受　　于色法中三昧起
  示现色法不思议　　一切天人莫能知
  于色法中入正受　　于眼起定念不乱
  观眼无生无自性　　说空寂灭无所有
  于耳根中入正受　　于声法中三昧起
  分别一切诸音声　　诸天世人莫能知
  于声法中入正受　　于耳起定念不乱
  观耳无生无自性　　说空寂灭无所有
  于鼻根中入正受　　于香法中三昧起
  分别一切诸香法　　诸天世人莫能知
  于香法中入正受　　于鼻起定念不乱
  观鼻无生无自性　　说空寂灭无所有
  于舌根中入正受　　于味法中三昧起
  分别一切诸味法　　诸天世人莫能知
  于味法中入正受　　于舌起定念不乱
  观舌无生无自性　　说空寂灭无所有
  于身根中入正受　　于触法中三昧起
  分别一切诸触法　　诸天世人莫能知
  于触法中入正受　　于身起定念不乱
  观身无生无自性　　说空寂灭无所有
  于意根中入正受　　于诸法中三昧起
  分别一切诸法相　　诸天世人莫能知
  于诸法中入正受　　于意起定念不乱
  观意无生无自性　　说空寂灭无所有
  现童子身入正受　　于壮年身三昧起
  现壮年身入正受　　于老年身三昧起
  现老年身入正受　　于善女人三昧起
  现善女人入正受　　于善男子三昧起
  现善男子入正受　　比丘尼身三昧起
  比丘尼身入正受　　于比丘身三昧起
  现比丘身入正受　　于学无学三昧起
  现学无学入正受　　于缘觉身三昧起
  现缘觉身入正受　　于如来身三昧起
  现如来身入正受　　于诸天身三昧起
  现诸天身入正受　　于龙神身三昧起
  现龙神身入正受　　于大鬼神三昧起
  现大鬼神入正受　　一切鬼神三昧起
  一切鬼神入正受　　一毛孔中三昧起
  一毛孔中入正受　　一切毛孔三昧起
  一切毛孔入正受　　一毛端头三昧起
  一毛端头入正受　　一切毛端三昧起
  一切毛端入正受　　一微尘中三昧起
  一微尘中入正受　　一切微尘三昧起
  一切微尘入正受　　于金刚地三昧起
  现金刚地入正受　　摩尼宝树三昧起
  摩尼宝树入正受　　诸佛光明三昧起
  诸佛光明入正受　　于大海水三昧起
  现大海水入正受　　于大盛火三昧起
  现大盛火入正受　　于风起定心不乱
  现于风大入正受　　于地大中三昧起
  现地大中入正受　　于天宫殿三昧起
  现天宫殿入正受　　于虚空中三昧起
  是名无量功德者　　三昧自在难思议
  十方一切诸如来　　不思议劫说不尽
  一切诸佛皆共说　　众生业报难思议
  诸龙神变佛自在　　禅定三昧亦难思
  今说声闻自在力　　无可为之作譬谕
  智慧明了聪达者　　乃能解是甚深义
  得八解脱心自在　　一身能作无量身
  以无量身作一身　　于虚空中入火定
  身上出水身下火　　身上出火身下水
  行住坐卧虚空中　　于一念中自在变
  彼不具足大慈悲　　不为众生求佛道
  尚能示现难思议　　况大饶益自在力
  现作日月游虚空　　普照十方诸世界
  或作河池井泉水　　或作大海众宝器
  如是等比难思议　　普现十方诸世界
  深达三昧诸解脱　　唯有诸佛能证知
  如净水中四兵像　　各各别异皆明了
  刀剑轮戟众兵器　　如是等仗皆悉现
  随其器仗本形相　　悉现于彼净水中
  水影四兵无憎爱　　是名大仙定自在
  海中有天名妙音　　其中众生若干种
  解彼一切诸音声　　皆悉令得大欢喜
  彼有贪欲嗔恚痴　　犹能分别一切音
  况复总持自在力　　而不能令众生喜
  有一女人名辩才　　父母求天由此生
  离诸恶法乐真实　　能令众生得辩才
  彼有贪欲嗔恚痴　　犹能与众胜辩才
  亦能令彼得欢喜　　何况菩萨无量智
  譬如幻师善术法　　能现种种无量色
  示现昼夜须臾顷　　或现须臾作百年
  彼有贪欲嗔恚痴　　幻力自在悦世间
  况禅解脱神通行　　云何不令众生喜
  天阿修罗斗战时　　阿修罗众即退散
  心大恐怖而奔走　　四兵悉入藕丝孔
  彼有贪欲嗔恚痴　　能作自在不思议
  况住自在无畏法　　云何不能现神变
  释提桓因有象王　　彼知帝释欲行时
  彼化作头三十三　　一一口中有六牙
  一一牙上七浴池　　清净香水湛然满
  一一清净池水中　　各七莲华为庄严
  彼诸严饰莲华上　　各各有七天玉女
  诸女并奏微妙音　　与彼帝释相娱乐
  或时舍彼龙象身　　化作天女极庄严
  威仪巧妙最无比　　是名龙象自在力
  彼有贪欲嗔恚痴　　能作如是诸神变
  何况具足方便智　　而于诸定不自在
  如阿修罗化作身　　金刚地上安其足
  海水至深仅半身　　其首广大如须弥
  彼有贪欲嗔恚痴　　乃能现是大神力
  况伏魔怨照世灯　　而不能现大神变
  天阿修罗共战时　　帝释自在难思议
  随阿修罗军众数　　现身等彼而交战
  诸阿修罗发是念　　释提桓因来向我
  必取我身五种缚　　阿修罗众大恐怖
  帝释现身有千眼　　手执金刚出火焰
  被甲持杖自庄严　　阿修罗见即退散
  彼以微小功德力　　犹能摧破大怨敌
  何况救度一切者　　无量功德不自在
  教化忉利诸天故　　得此果报妙音声
  以诸天等放逸行　　空中自然出此音
  一切五欲悉无常　　虚伪无实如水沫
  如幻野马水中月　　有为如梦如浮云
  一切放逸有忧诤　　非甘露道生死径
  若有行诸放逸者　　入于生死摩竭口
  我所有者众苦本　　一切贤圣所厌患
  五欲功德磨灭法　　常乐清净真实行
  三十三天闻此音　　一切来集善法堂
  帝释为说微妙法　　随顺离欲寂静行
  彼音无形不可见　　犹能饶益诸天众
  何况应化众生身　　不能大利一切世
  天阿修罗共斗时　　诸天众侣大恐怖
  诸天功德势力故　　空中出声言勿惧
  诸天闻此安慰声　　即离恐畏生大力
  时阿修罗心震惧　　所将兵众悉退散
  何况甘露妙音声　　能灭众生诸恐怖
  大慈具足摧众魔　　寂静妙音除烦恼
  帝释普应诸天女　　九十有二那由他
  天女各各心自谓　　天王独与我娱乐
  现身集在善法堂　　为天说法令欢喜
  帝释能于一念中　　悉皆现此大神变
  释有贪欲嗔恚痴　　能令眷属悉欢喜
  况无量劫修神力　　而不能令一切悦
  他化自在六天王　　于欲界中得自在
  以业烦恼为罗网　　系缚一切诸凡夫
  彼有贪欲嗔恚痴　　能伏欲界诸群生
  况具十种自在力　　而不令众同其行
  三千世界大梵王　　一切诸梵所住处
  悉能现身于彼坐　　演畅微妙梵音声
  彼于世间四梵道　　禅定五通得如意
  何况超出一切世　　禅定解脱不自在
  摩醯首罗智自在　　大海龙王降雨时
  悉能分别数其渧　　于一念中皆明了
  无量亿劫勤修学　　得是无上菩提智
  云何当于一念中　　不知一切众生心
  众生业报难思议　　因大风轮起世界
  巨海诸山天宫殿　　众宝光明万物种
  亦能兴云降大雨　　亦能散灭诸云气
  亦能成熟一切谷　　亦大饶益群生类
  风不能学波罗蜜　　亦不学佛诸功德
  犹成不可思议事　　何况具足诸愿者
  男子女人诸异类　　海龙雷震大音声
  悉能了知皆如响　　逮无障碍无尽辩
  为一切众说妙法　　其有闻者悉欢喜
  如海奇特未曾有　　印现一切众像类
  大身众生妙宝藏　　众流悉入无增损
  如是众生平等印　　无尽功德禅解脱
  一切智慧诸功德　　增长众善无厌足
  龙王示现自在时　　从金刚际至他化
  兴云充遍四天下　　其云种种庄严色
  第六他化自在天　　于彼云色如黄金
  化乐天上云赤色　　兜率陀天白宝色
  夜摩天上琉璃色　　三十三天码瑙色
  四王天上玻璃色　　于大海上金刚色
  紧那罗中妙香色　　诸龙住处莲华色
  微密天中白鹅色　　阿修罗中状如山
  郁单越中金野马　　阎浮提境云青色
  余二天下杂种色　　随众所乐以应之
  又复他化自在天　　云中电耀如日光
  化乐天上如月光　　兜率天上阎浮金
  夜摩天上白宝色　　释处金云如野马
  四王天上最妙色　　于大海上赤宝色
  紧那罗中青琉璃　　诸龙住处宝藏色
  微密天中玻璃色　　阿修罗中玛瑙色
  郁单越境火珠色　　阎浮提界青宝色
  余二天下杂庄严　　随众所乐以应之
  他化雷震如梵音　　化乐天上妙音声
  兜率天上妓乐音　　夜摩天上天女音
  于彼忉利诸天上　　紧那罗女妙音声
  四王天上乾闼声　　紧那罗中箫笛声
  于彼一切大海中　　犹如两山相击声
  诸龙住处频伽声　　微密天中龙女声
  阿修罗中天鼓声　　于人道中海潮声
  又复他化自在天　　雨妙香华为庄严
  化乐天上薝卜华　　曼陀罗华及泽香
  兜率天上摩尼珠　　无上种种庄严宝
  明净髻珠如月光　　上妙细衣炼金色
  夜摩幢盖幡庄严　　华鬘涂香胜庄严
  赤真珠衣金绞络　　种种微妙众妓乐
  三十三天如意珠　　坚固殊妙旃檀香
  种种郁金诸天华　　雨杂清净华香水
  四王天雨上味膳　　众味具足生气力
  又雨不可思议宝　　龙王降是种种雨
  又复于彼大海中　　一一雨渧如车轴
  无量众宝不可尽　　又雨种种庄严宝
  紧那雨华青宝衣　　摩利妙华细末香
  种种妓乐悉具足　　如是无量妙庄严
  诸龙住处赤真珠　　微密天中火珠宝
  阿修罗中雨兵仗　　摧伏一切诸怨敌
  郁单无价宝璎珞　　弗婆俱耶二天下
  婆师波利薝卜华　　清净妙宝解脱华
  阎浮提雨清净水　　柔软悦泽常应时
  长养众果香华树　　随时成熟益众生
  如是无量难思议　　兴云雷震种种雨
  自于宫殿身不动　　能现自在不思议
  于彼海中为尊主　　示现神变难思议
  况入法海尽源底　　云何不能大神变
  如我所说诸譬谕　　为深智慧菩萨故
  无畏大士无伦匹　　逮得自在诸解脱
  微妙无量胜智者　　能说如是解脱门
  诸未曾有奇特法　　一切不能报其恩
  闻是甚深胜解脱　　信解受持为他说
  世间一切诸凡夫　　信是法者甚难得
  思惟无量诸善法　　本有因力故能信
  一切世界诸群生　　鲜有欲求声闻道
  求缘觉者转复少　　求大乘者甚希有
  求大乘者犹为易　　能信是法为甚难
  况能受持正忆念　　如说修行真实解
  若以三千大千界　　顶戴一劫身不动
  彼之所作未为难　　信是法者为甚难
  大千尘数众生类　　一劫供养诸乐具
  彼之功德未为胜　　信是法者为殊胜
  若以掌持十佛刹　　于虚空中住一劫
  彼之所作未为难　　信是法者为甚难
  十佛刹尘众生类　　一劫供养诸乐具
  彼之功德未为胜　　信是法者为殊胜
  十刹尘数诸如来　　一劫恭敬而供养
  若能受持此品者　　功德于彼为最胜
  贤首说此品竟时　　十方世界六返动
  诸魔宫殿如聚墨　　光照十方恶道灭
  一切十方诸如来　　悉皆普现贤首前
  各伸右手摩其顶　　贤首菩萨德无量
  以其右手摩顶已　　一切如来赞叹言
  善哉善哉真佛子　　快说是法我随喜

    大方广佛华严经佛升须弥顶品第九

尔时如来。威神力故。十方一切诸佛世界。诸四天下一一阎浮提。皆有如来坐菩提树下无不显现。彼诸菩萨各承佛神力。说种种法。皆悉自谓在于佛所。尔时世尊威神力故。不起此座。升须弥顶向帝释殿。尔时帝释遥见佛来。即于妙胜殿上。敷置众宝师子之座。以万种杂宝而庄严之。万种宝帐弥覆其上。以万宝网。而绞络之。次上万种众妙宝盖。天缯杂宝以为垂带。万种璎珞而庄严之。万种宝衣以敷座上。一万天子在前立侍。一万梵天而围绕之。一万光明以为照耀

尔时帝释。为佛庄严师子座已。合掌恭敬白佛言。善来世尊。唯愿哀处我此宫殿。尔时世尊。即受其请升妙胜殿。一切十方亦复如是。尔时帝释无量乐音。佛神力故寂然无声。即自忆念于过去佛所种诸善根。以偈颂曰

  迦叶如来具大慈　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  拘那牟尼慧无碍　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  拘楼佛身如金山　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  随叶如来离三垢　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  尸弃如来常寂然　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  毗婆尸佛如满月　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  弗沙明达第一义　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  提舍如来辩无碍　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  波头摩佛净无垢　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥
  锭光如来明普照　　诸吉祥中最无上
  彼佛曾来入此处　　是故此地最吉祥

如此间帝释佛神力故。以偈赞叹十佛功德。如是十方帝释。各自忆念过去佛所所种善根。以偈赞叹亦复如是。尔时世尊。升师子座结跏趺坐。坐已宫殿忽然广博。如忉利天处。一切十方亦复如是

    大方广佛华严经菩萨云集妙胜殿上说偈品第十

尔时十方各过百佛世界微尘数刹。一一方各十世界。其世界名因陀罗。次名莲华。次名众宝。次名优钵罗。次名妙行。次名善行。次名欢喜。次名星宿。次名无厌慈。次名虚空。其佛号不变月。次号无尽月。次号不动月。次号香风月。次号自在天月。次号清净月。次号无上月。次号星宿月。次号不衰变月。次号无量自在月。其菩萨名法慧。次名一切慧。次名胜慧。次名功德慧。次名精进慧。次名善慧。次名智慧。次名真实慧。次名无上慧。次名坚固慧。此诸菩萨。各于其国佛所。净修梵行。尔时佛神力故。彼一一菩萨。各将一佛世界微尘数菩萨眷属俱。来诣佛所恭敬礼拜。又佛神力故。化作宝藏师子之座。结跏趺坐充满十方。如此世界须弥山顶菩萨云集。十方世界亦复如是

尔时世尊。从两足指放百千亿妙色光明。普照十方一切世界。诸四天下菩提树下。须弥山顶妙胜殿上。如来大众皆悉显现。尔时法慧菩萨。承佛神力普观十方。以偈颂曰

  天人师悉现　　一切严净刹
  须弥山王顶　　帝释妙胜殿
  哀受天王请　　故处其宫殿
  一一各以十　　吉祥偈赞佛
  诸佛大眷属　　清净菩萨众
  斯从十方来　　跏趺正安坐
  各同其名字　　如我菩萨众
  舍离于本刹　　往诣诸佛所
  本国诸世尊　　名号皆悉同
  各于其佛所　　净修菩萨行
  诸佛子当知　　如来威神力
  一切世界中　　各谓佛在前
  今我等见佛　　坐释妙胜殿
  十方亦如是　　如来自在力
  一切世界中　　发心求佛者
  先立清净愿　　修习菩萨行
  菩萨净修行　　无量无数劫
  于法界无碍　　无能测量者
  悉普照十方　　灭除愚痴闇
  一切无与等　　是故莫能知

尔时一切慧菩萨。承佛神力普观十方。以偈颂曰

  无量无数劫　　虽常见如来
  于此正法中　　犹未睹真实
  妄想取诸法　　增长痴惑网
  轮回生死中　　盲冥不见佛
  虽复观诸法　　犹未见实相
  一切法生灭　　但着假名字
  一切法无生　　一切法无灭
  若能如是解　　诸佛常现前
  无取亦无见　　空寂无真实
  诸佛本来空　　不可得思量
  若解一切法　　不可思量者
  彼于诸烦恼　　其心无所染
  虚妄取法相　　是则为痴冥
  是故不见佛　　亦不得真实
  牟尼离三世　　相好悉具足
  于住无所住　　法界悉清净
  因缘故法生　　因缘故法灭
  如是观如来　　究竟离痴惑
  法慧先已说　　清净微妙法
  我从彼胜闻　　菩提难思议

尔时胜慧菩萨。承佛神力普观十方。以偈颂曰

  如来智甚深　　一切莫能测
  不知真实法　　世间悉迷惑
  童蒙思惟是　　虚妄取诸法
  是故不见佛　　具足清净相
  愚痴心迷惑　　妄取五阴相
  不了真实性　　是故不见佛
  分别一切法　　皆悉无真实
  如是解诸法　　则见卢舍那
  因前五阴故　　后阴相续生
  次第解五阴　　见佛难思议
  如宝在闇处　　无明故不见
  真谛无说者　　虽慧莫能睹
  如目不明净　　不见微妙色
  如是不净心　　不见诸佛法
  犹如明净日　　无目者不见
  若人心谄曲　　终不睹诸佛
  故当净慧眼　　观察诸法相
  见法相明了　　犹如镜中像
  一切慧先说　　清净微妙法
  我从彼胜闻　　见佛卢舍那

尔时功德慧菩萨。承佛神力普观十方。以偈颂曰

  诸法虚无实　　妄取坚固相
  是故童蒙者　　常转生死轮
  不善非胜法　　妄作胜法相
  是故生障碍　　愚痴常轮转
  不知八正道　　云何知自心
  彼因颠倒想　　增长一切恶
  不见诸法空　　常受无量苦
  彼人不成就　　清净法眼故
  欲知一切心　　先当求法眼
  如我所说者　　能见真实佛
  若有见佛者　　其心无所著
  彼则见真实　　如佛所说法
  若见大智慧　　如来妙法身
  能见如来故　　彼有清净眼
  无见乃能见　　一切真实法
  于法有所见　　彼则无所见
  妙哉真实法　　佛以导众生
  一切诸有中　　无生亦无死
  胜慧先已说　　清净微妙法
  我从彼胜闻　　深解诸佛道

尔时精进慧菩萨。承佛神力普观十方。以偈颂曰

  以诸妄想行　　慧眼不清净
  愚痴邪见增　　常不见诸佛
  若能见邪伪　　及以真实法
  谛了实不实　　则见清净佛
  见者则是垢　　彼则无所见
  诸佛离所见　　是故见清净
  世间语言法　　虚妄无真实
  知世从缘起　　能离生死患
  世间非世间　　观察悉平等
  二俱知真实　　是名真见者
  若能如是观　　漏尽得自在
  非有亦非无　　是名不二见
  虚妄非虚妄　　非是诸佛法
  真实无二相　　法性清净故
  法性自清净　　无相如虚空
  一切无能说　　智者如是观
  乐观一切法　　寂灭无所有
  亦知不可修　　能见牟尼尊
  如是见佛者　　功德不可量
  一切所有行　　寂静空无相

大方广佛华严经卷第七大方广佛华严经卷第八

        东晋天竺三藏佛驮跋陀罗译

    菩萨云集妙胜殿上说偈品第十之二

尔时善慧菩萨。承佛神力普观十方。以偈颂曰

  妙哉佛世尊　　无量诸如来
  离害心解脱　　自度能度彼
  正见世间灯　　如实不颠倒
  无量无数劫　　积德故见佛
  诸行空无实　　凡夫谓真谛
  一切无自性　　皆悉等虚空
  无尽智所说　　说者无所说
  了知有悉无　　故得难思议
  无尽说无尽　　众生空寂故
  知彼真实性　　则见大名称
  无见说是见　　无我说众生
  说见及众生　　是二悉非有
  见者无所见　　是见不坏相
  是名真实法　　一切佛所说
  能知真实佛　　及佛之所说
  普见一切世　　如佛卢舍那
  如来等正觉　　善说明净道
  精进慧菩萨　　演说无量法
  有无诸法相　　一相平等修
  如是能见佛　　安住真实际

尔时智慧菩萨。承佛神力普观十方。以偈颂曰

  我闻最胜教　　即生净慧光
  普照十方世　　悉见一切佛
  若计有众生　　是为最难处
  法本无真主　　但有假言说
  愚惑莫能知　　自身真实性
  如来非取相　　是故不见佛
  尘垢障慧眼　　不见等正觉
  无量无数劫　　流转生死海
  流转则生死　　非转是涅槃
  生死及涅槃　　二皆不可得
  虚诳妄说者　　生死涅槃异
  迷惑贤圣法　　不识无上道
  如是取相者　　言有佛等觉
  颠倒无正念　　是故不见佛
  能知此实法　　寂灭真如相
  则见最正觉　　超出语言道
  虚妄说诸法　　法实无所有
  一切诸世尊　　谛求不可得
  明了过去世　　未来及现在
  究竟永寂灭　　故说为如来

尔时真慧菩萨。承佛神力普观十方。以偈颂曰

  宁受无量苦　　得闻佛音声
  不受一切乐　　而不闻佛名
  所以无量劫　　受此众苦恼
  流转生死中　　不闻佛名故
  实以无实法　　正觉等真伪
  以无和合相　　是名为菩提
  现佛非缘合　　去来亦复然
  一切法无相　　是则佛真性
  若能如是观　　诸法甚深义
  则见无量佛　　法身真实相
  于实知真实　　非实知非实
  善解真实际　　故号为正觉
  觉者无所觉　　是佛真妙法
  诸佛如是修　　非一亦非二
  知一法为众　　知众法为一
  法无所依处　　云何而缘合
  作者及所作　　二俱无所有
  若能如是解　　求之不可得
  是处不可得　　诸佛所依止
  法无有所依　　觉者无所著

尔时无上慧菩萨。承佛神力普观十方。以偈颂曰

  无上摩诃萨　　远离众生相
  上相无所有　　故号为无上
  微妙无所有　　粗者亦复无
  诸佛之所得　　非望亦非作
  是法不可数　　诸佛之境界
  亦离于无数　　是名佛真法
  慧日照十方　　灭除众闇冥
  亦非有所照　　亦复非无照
  常乐寂静法　　永离有所依
  解脱无依处　　不染一切法
  善见大智者　　真实所依住
  若无有二法　　当知一亦无
  无一亦无二　　一切皆寂灭
  三种世间空　　是则诸佛见
  诸佛教众生　　安住正法中
  解达无所住　　当见真实身
  非身即是身　　不转不可见
  无转亦无见　　是名无上身
  真慧所演说　　无量诸佛法
  若闻此法者　　常得清净眼

尔时坚固慧菩萨。承佛神力普观十方。以偈颂曰

  众生不知恩　　如来发慈慧
  出现于世间　　普照除众冥
  起大慈悲心　　普观诸群生
  具受无量苦　　永缚在三有
  唯除等正觉　　最胜尊导师
  一切天人中　　无可归依者
  世界若无佛　　及众贤圣人
  彼诸群生类　　无有一切乐
  如来众贤圣　　出现于世间
  为开净慧眼　　令得永安乐
  若见如来者　　为得最大利
  闻佛名欢喜　　则是世间塔
  我等获善利　　现前觐如来
  闻斯微妙法　　悉当成佛道
  三世明解脱　　甚深诸境界
  一切众菩萨　　清净开慧眼
  我等重欢喜　　见佛卢舍那
  无量无边智　　演说不可尽
  无上慧坚固　　及诸佛子等
  无数亿劫中　　说佛德无尽

    大方广佛华严经菩萨十住品第十一

尔时法慧菩萨承佛神力。入菩萨无量方便三昧正受。入三昧已。十方千佛世界尘数佛土之外。各见千佛世界尘数诸佛。是诸如来悉号法慧。时彼诸佛。告法慧菩萨言。善哉善哉。善男子。乃能入是菩萨无量方便三昧正受。善男子。十方各千佛刹。尘数诸佛。加汝神力故。能入是三昧正受。又卢舍那佛本愿力故。威神力故。及汝善根力故。又欲令汝广说法故。长养佛慧故。开解法界故。分别众生界故。除灭障故。入无碍境界故。无等等方便入一切智陀罗尼故。觉一切法故。善知诸根故。说法持故。所谓菩萨十住。善男子。当承佛神力说微妙法。尔时一切如来。即与法慧菩萨。无碍智。无住智。无断智。无痴智。无坏智。无恶智。无量智。无胜智。无懈怠智。无退智。何以故。彼三昧力法如是故。尔时诸佛。各伸右手。摩法慧菩萨顶。摩其顶已。即从定起。告众菩萨言。诸佛子。菩萨种性甚深广大。与法界虚空等。一切菩萨。从三世诸佛种性中生。诸佛子。菩萨摩诃萨十住行。去来现在诸佛所说。何等为十。一名初发心。二名治地。三名修行。四名生贵。五名方便具足。六名正心。七名不退。八名童真。九名法王子。十名灌顶。诸佛子。是名菩萨十住。去来现在诸佛所说。诸佛子。何等是菩萨摩诃萨初发心住。此菩萨。见佛三十二相八十种好妙色具足尊重难遇。或睹神变。或闻说法。或听教诫。或见众生受无量苦。或闻如来广说佛法。发菩提心。求一切智一向不回。此菩萨。因初发心得十力分。何等为十。所谓是处非处智。业报垢净智。诸根智。欲乐智。性智。一切至处道智。一切禅定解脱三昧正受垢净起智。宿命无碍智。天眼无碍智。三世漏尽智。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学恭敬供养诸佛。赞叹诸菩萨。护众生心。亲近贤明。赞不退法。修佛功德称扬叹美生诸佛前。方便修习寂静三昧。赞叹远离生死轮回。为苦众生作归依处。何以故。欲令菩提心转胜坚固成无上道。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨治地住。此菩萨。于一切众生发十种心。何等为十。所谓大慈心。大悲心。乐心。安住心。欢喜心。度众生心。守护众生心。我所心。师心。如来心。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓先当勤学专求多闻修离欲定。近善知识。不违其教。善知时语。学无所畏。明解深义。了达正法。知坚法行。舍离痴冥。安住不动何以故。欲于一切众生增长大慈悲故。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨修行住。此菩萨。十种观一切法。何等为十。所谓观一切法无常苦空无我不自在。一切法不可乐。一切法无集散。一切法无坚固。一切法虚妄。一切法无精勤和合坚固。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学分别知一切众生界。分别知一切法界。分别知一切世界。分别知地水火风界。分别知欲色无色界。何以故。欲于一切法增长明净智慧故。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨生贵住。此菩萨。从一切圣法正教中生。修十种法。何等为十。所谓信佛不坏。究竟于法。寂然定意。分别众生。分别佛刹。分别世界。分别诸业。分别果报。分别生死。分别涅槃。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学分别去来今佛法。修行去来今佛法。具足去来今佛法。平等观察一切诸佛。何以故。欲使明达二世等观。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨具足方便住。此菩萨。闻十种法应当修行。何等为十。所行善根悉为救护一切众生。饶益一切众生。安乐一切众生。哀愍一切众生。成就一切众生。令一切众生舍离诸难。拔出一切众生生死苦恼。令一切众生欢喜快乐。令一切众生调伏。令一切众生悉得涅槃。是为具足方便住。诸佛子。彼菩萨应学十法。何等为十。所谓学知众生无有边。知众生不可数。知众生不思议。知众生种种色。知众生不可量。知众生空。知众生不自在。知众生非真实。知众生无所有。何以故。欲令其心无所染着。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨正心住。此菩萨。闻十种法得决定心。何等为十。所谓闻赞佛毁佛。于佛法中心定不动。闻赞法毁法。于佛法中心定不动。闻赞毁菩萨。于佛法中心定不动。闻赞毁菩萨所行法。于佛法中心定不动。闻众生有量无量。于佛法中心定不动。闻众生有垢无垢。于佛法中心定不动。闻众生易度难度。于佛法中心定不动。闻法界有量无量。于佛法中心定不动。闻法界若成若坏。于佛法中心定不动。闻法界若有若无。于佛法中心定不动。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学一切法无相。一切法无性。一切法不可修。一切法无所有。一切法无真实。一切法如虚空。一切法无自性。一切法如幻。一切法如梦。一切法如响。何以故。欲令得不退转无生法忍故。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨不退转住。此菩萨。闻十种法其心坚固而不动转。何等为十。所谓闻有佛无佛。于佛法中不退转。有法无法。于佛法中不退转。有菩萨无菩萨。于佛法中不退转。有菩萨行无菩萨行。于佛法中不退转。菩萨行出生死不出生死。于佛法中不退转。有过去佛无过去佛。于佛法中不退转。有未来佛无未来佛。于佛法中不退转。有现在佛无现在佛。于佛法中不退转。佛智有尽无尽。于佛法中不退转。三世法一相非一相。于佛法中不退转。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓知一即是多。多即是一。随味知义。随义知味。知非有是有。知有是非有。知非相是相。知相是非相。知非性是性。知性是非性。何以故。欲于一切法方便具足故。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨童真住。此菩萨。于十种法心得安立。何等为十。所谓身行清净。口行清净。意行清净。随意受生。知众生心。知众生种种欲乐。知众生种种性。知众生种种业。知世界成坏。神通自在无有障碍。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学知一切佛刹。震动一切佛刹。持一切佛刹。观一切佛刹。诣一切佛刹。遍至一切世界。善问难无量妙法。神通变化无量身。善解无量诸音声。于一念中恭敬供养无量诸佛。何以故。欲于一切法中出巧方便具足成就。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨法王子住。此菩萨善解十种法。何等为十。所谓善解众生趣。善解诸烦恼。善解诸习气。善解方便智。善解分别无量法。善解诸威仪。善解分别诸世界。善解去来今。善解说世谛。善解说第一义谛。是为十。诸佛子。彼菩萨应学十法。何等为十。所谓学善知法王所住处。善知法王所行威仪。善知安立法王处。善知巧入法王处。善知分别法王处。善知法王甘露灌顶。善知受持法王法。善知法王无畏法。善知法王无著法。善知赞叹法王法。何以故。欲于一切法得无障碍智。有所闻法即自开解不由他悟

诸佛子。何等是菩萨摩诃萨灌顶住。此菩萨。成就十种智住。何等为十。所谓悉能震动无量世界。悉能照明无量世界。悉能住持无量世界。悉能遍游无量世界。悉能严净无量世界。悉知无量众生心行。悉知众生随心所行。悉知无量众生诸根。悉能方便度无量众生。悉能调伏无量众生。是为十。诸佛子。彼菩萨身不可知。身业神足。神足自在。过去智。未来智。现在智。净诸佛刹智。心境界智境界。不可知。一切众生。乃至法王子菩萨。悉不能知。诸佛子。彼菩萨应学十种智。何等为十。所谓学三世智。一切佛法智。法界无障碍智。法界无量无边智。充满一切世界智。普照一切世界智。能持一切世界智。分别一切众生智。一切种智。智佛无量无边智。何以故。欲令具足一切种智。有所闻法即自开解不由他悟

尔时佛神力故。十方各万佛世界尘数佛国。六种十八相震动。雨天宝华天末香天宝鬘天杂香天宝衣天宝云天庄严具。天妙音乐不鼓自鸣。又自演出无畏之音。如此四天下须弥山顶妙胜殿上威神变化说十住法。一切十方世界亦复如是。尔时佛神力故。十方各过万佛世界尘数刹外。有十佛刹微尘数等诸大菩萨。充满十方。来诣此土。说如是言。善哉善哉。佛子。善说是法。我等诸人同名法慧。所从来国同名法云。彼诸如来同号妙法。我等佛所亦说十住。大众眷属名味句身等无有异。是故佛子。我等承佛神力。来诣此土。为汝作证。如此四天下须弥山顶妙胜殿上说十住法。十佛世界微尘数等诸大菩萨来此作证。一切十方亦复如是。尔时法慧菩萨。承佛神力。普观十方及诸法界。以偈颂曰

  见大智尊微妙身　　相好端严悉具足
  最胜尊重甚难遇　　勇猛大士初发心
  见无等等大神变　　闻说妙法及教诫
  观察五道无量苦　　无畏大士初发心
  闻诸如来普智尊　　无量功德悉具足
  解佛心相如虚空　　菩萨因此初发心
  能知是处及非处　　若我非我如是等
  欲解平等真实义　　菩萨因此初发心
  过去未来现在世　　一切善恶诸业报
  欲善观察悉平等　　菩萨因此初发心
  诸禅三昧及解脱　　随顺正受无所著
  欲善分别垢净起　　菩萨因此初发心
  随诸众生根利钝　　种种勤修精进力
  悉欲了达分别知　　菩萨因此初发心
  一切众生种种欲　　心好乐着诸希望
  悉欲了达分别知　　菩萨因此初发心
  一切众生种种性　　无量无边不可数
  悉欲了达分别知　　菩萨因此初发心
  一切诸道所至处　　八正圣路向无为
  悉欲了达知其实　　菩萨因此初发心
  一切世界众生类　　流转五道生死海
  欲得天眼悉明达　　菩萨因此初发心
  于过去世一切事　　如其体性所有相
  悉欲随顺达宿命　　菩萨因此初发心
  世间一切诸烦恼　　所有结缚余习气
  悉欲觉知究竟尽　　菩萨因此初发心
  世间所有世谛法　　名字谈论语言道
  悉欲明达世谛义　　菩萨因此初发心
  一切诸法语言断　　无有自性如虚空
  悉欲明达真谛义　　菩萨因此初发心
  震动一切佛世界　　倾覆鼓荡诸大海
  悉欲明达佛神力　　菩萨因此初发心
  一毛放演无量光　　普照十方一切刹
  欲于一光一切觉　　菩萨因此初发心
  无量佛刹难思议　　皆悉能置一掌中
  欲解一切如幻化　　菩萨因此初发心
  无量佛刹诸众生　　皆悉安置一毛端
  悉欲了达皆寂灭　　菩萨因此初发心
  一切十方大海水　　渧以一毛尽无余
  悉欲分别知渧数　　菩萨因此初发心
  不可思议诸佛刹　　皆碎为末如微尘
  悉欲分别知其数　　菩萨因此初发心
  过去未来无量劫　　一切世界成败相
  悉欲究竟达其际　　菩萨因此初发心
  三世一切等正觉　　诸辟支佛及声闻
  悉欲分别三乘道　　菩萨因此初发心
  无量无边诸世界　　能以一毛悉称举
  欲知有无真实相　　菩萨因此初发心
  金刚围山数无量　　尽能安置一毛端
  欲知至大有小相　　菩萨因此初发心
  十方一切诸世界　　能以一音遍充满
  悉欲解了净妙声　　菩萨因此初发心
  一切众生语言法　　一言演说尽无余
  悉欲解了净密音　　菩萨因此初发心
  如来清净微妙音　　充满十方诸世界
  欲得具足舌根相　　菩萨因此初发心
  一切十方诸世界　　有成坏者皆悉见
  欲得解了悉虚妄　　菩萨因此初发心
  一切十方诸佛刹　　其中无量诸如来
  悉欲了达佛正法　　菩萨因此初发心
  普能应现无量身　　一切世界微尘等
  悉欲了达如幻化　　菩萨因此初发心
  过去未来现在世　　无量无边诸如来
  欲于一念悉了知　　菩萨因此初发心
  欲具演说一句法　　阿僧祇劫无穷尽
  欲使辩才不断绝　　菩萨因此初发心
  十方一切诸群生　　随其迁变生灭相
  欲于一念悉了达　　菩萨因此初发心
  净妙身口及意行　　游步十方无障碍
  欲了三世悉空寂　　菩萨因此初发心
  菩萨如是发心已　　于十方界诸佛所
  应学尽敬供养佛　　如是说者不退教
  菩萨舍离种种乐　　不厌生死求菩提
  以此劝进欢喜叹　　如是说者不退教
  十方一切诸世界　　其中所有众贤圣
  菩萨常应赞叹彼　　如是说者不退教
  最胜最上无有比　　甚深微妙清净法
  菩萨以此化众生　　如是说者不退教
  无上清净妙善法　　一切众魔不能坏
  菩萨尊重常称叹　　如是说者不退教
  一切所有妙功德　　天人之尊悉成就
  以此安立诸菩萨　　如是说者人中王
  方便教化见诸佛　　无量无数难思议
  若能以此方便化　　如是说者不退教
  一切甚深诸三昧　　悉教众生无有余
  菩萨分别具开导　　如是说者不退教
  悉能摧灭生死轮　　具转圣道妙法轮
  一切世间无所著　　诸佛所记是菩萨
  菩萨若见无量众　　轮转生死受诸苦
  为作救护归依者　　诸佛所记是菩萨
  是说菩萨发心住　　一向志求无上道
  如我所说微妙法　　一切诸佛亦如是
  第二治地真佛子　　先应发心作是念
  愿令一切群生类　　随顺修行诸佛教
  饶益安乐众生心　　欢喜不舍众生心
  大悲救护我所心　　起大师心如来心
  发如是等胜妙心　　精勤学问求多闻
  寂然定意正思惟　　心常亲近善知识
  随顺奉行修其教　　柔软善语不放逸
  善能了知一切时　　达深法义无所畏
  明解深义了正法　　则离一切诸痴冥
  已离愚痴心安住　　是则名为真佛子
  亦名治地摩诃萨　　一向坚固求菩提
  如是善学诸佛教　　是则名为真佛子
  第三修行真佛子　　应当如是观诸法
  无常苦空无坚固　　无我无主不自在
  一切诸法不可乐　　无作虚诳不真实
  无有积集亦无散　　如是观者是菩萨
  分别观察众生界　　亦当解了诸法界
  善能分别方便观　　无量无边诸世界
  一切十方国土中　　地水火风四大界
  欲界色界无色界　　悉能观察分别知
  善能明达一切界　　真实究竟无有余
  如是真谛正法教　　随顺学者是菩萨
  第四生贵真佛子　　从诸贤圣正法生
  有无诸法无所著　　舍离生死出三界
  信佛坚固不可坏　　究竟净心不退转
  明了观察甚深法　　一切众生无真实
  行业世界诸佛刹　　生死果报及涅槃
  佛子若能如是观　　是名如来法化生
  过去未来现在世　　诸佛如来及正法
  无量方便求究竟　　成就一切大圣法
  一切三世诸如来　　平等观察无异相
  分别差别不可得　　如是观者达三世
  如我所说赞叹者　　是名四住摩诃萨
  若能如是修学者　　速成无上佛菩提
  第五菩萨真佛子　　微妙具足方便住
  深入清净巧方便　　究竟一切功德业
  所修无量诸功德　　悉为一切作归依
  饶益安乐大慈悲　　哀愍度脱诸群生
  为一切世除众难　　永拔生死令欢喜
  调伏一切诸群生　　具足功德趣涅槃
  普为一切诸群生　　分别演说清净法
  是名第五摩诃萨　　成就方便度众生
  具足一切功德者　　演说五住净妙法
  第六正心真佛子　　解真实法离愚痴
  于一切世天人中　　正念思惟灭虚妄
  闻赞毁佛及佛法　　一切菩萨所行道
  众生有量若无量　　于佛法中心不动
  众生有垢若无垢　　或有易度或难度
  法界有量若无量　　世界有成或有败
  或闻法界若有无　　过去未来今现在
  菩萨于此一切法　　寂然观察心不动
  观一切法无性相　　其义真实如虚空
  犹若幻化梦所见　　是人于法为真解
  第七不退真佛子　　闻有诸佛菩萨法
  闻无诸佛菩萨法　　若出非出不退转
  过去未来及现在　　一切诸佛有以无
  若法起灭不起灭　　若有一相若异相
  若一即多多即一　　义味寂灭悉平等
  远离一异颠倒相　　是名菩萨不退住
  若有法相及无相　　若有法性及无性
  二俱无实等虚空　　如是知者必究竟
  第八童真真佛子　　身口意行悉具足
  微妙清净无染污　　随意所欲自在生
  悉知一切众生心　　善能观察诸欲性
  了众生法无差别　　十方世界成败相
  速逮一切妙神通　　往诣十方诸佛刹
  随意自在无障碍　　闻说妙法悉受持
  六种震动一切国　　皆悉能持诸世界
  梵音遍满十方刹　　度脱无量群生类
  咨问佛义不可数　　变化其身无有量
  随受化者演法言　　如佛所说无有异
  第九王子摩诃萨　　悉能分别诸群生
  善知轻重烦恼行　　随其所应方便度
  善分别知诸法相　　明达世界先后际
  善解俗谛第一义　　具足方便无有余
  善能了达法王处　　随顺法王威仪法
  善知安入法王位　　善知分别法王界
  第十灌顶真佛子　　方便善持一切法
  如法随顺入深义　　悉能究竟分别说
  悉度众生无有余　　而于众生不取相
  寂然不动学正念　　悉在十方诸佛前
  灌顶菩萨真佛子　　悉能究竟诸胜法
  十方无量诸世界　　悉能震动光普照
  能持十方诸世界　　严净一切众生心
  悉知一切众生根　　演梵音声满十方
  调伏化度诸群生　　悉令修习菩提心
  普入十方诸佛国　　观察法界无有余
  灌顶色身及身业　　神足自在不思议
  观察三世佛国智　　乃至王子所不测
  三世诸佛及佛法　　分别了知无障碍
  法界无量无有边　　诸佛声闻悉充满
  尽于一切诸世界　　皆悉能持光普照
  尽于一切群生类　　为说究竟正觉智
  如是十住诸菩萨　　悉从如来法化生
  随其方便及境界　　一切天人莫能知
  初发无上菩提心　　充满十方悉无余
  了达三世诸法相　　具足成就一切智
  无边佛刹及世间　　无量无数众生类
  烦恼业报菩提心　　如是一切无所著
  初求佛道发一念　　世间众生及二乘
  斯等一切莫能知　　何况菩萨余功德
  十方一切诸世界　　能以一毛悉称举
  彼知菩萨具足行　　疾得如来一切智
  十方一切大海水　　能以一毛渧令尽
  于一念中悉知数　　如是行者真佛子
  一切世界末为尘　　悉能分别知其数
  菩萨所行等微尘　　是则名为真佛子
  过去未来现在佛　　一切缘觉及声闻
  分别解说不能尽　　发心菩萨诸功德
  菩萨初发菩提心　　广大无量无有边
  大慈大悲覆一切　　何况菩萨余功德

    大方广佛华严经梵行品第十二

尔时正念天子。白法慧菩萨言。佛子。一切世界中。诸菩萨摩诃萨。信家非家出家学道。舍离俗饰被服法衣。彼诸菩萨。云何方便修习梵行。具足菩萨十住道地。速成无上平等菩提。尔时法慧菩萨。答正念天子言。正士。此菩萨摩诃萨。一向专求无上菩提。先当分别十种之法。何等为十。所谓身身业。口口业。意意业。佛法僧戒。应如是观。为身是梵行耶。乃至戒是梵行耶。若身是梵行者。当知梵行则不清净。当知梵行则为非法。当知梵行则为浑浊。当知梵行则为臭恶。当知梵行则为秽污。当知梵行则为尘垢。当知梵行则为谄曲。当知梵行则为八万户虫。若身业是梵行者。当知身四威仪则为梵行。左右顾眄举足下足。则为梵行。若口是梵行者。当知音声则为梵行。当知语言则为梵行。当知心触则为梵行。当知舌动则为梵行。当知唇齿和合则为梵行。若口业是梵行者。当知语言则为梵行。当知所说作无作称讥毁誉。则为梵行。若意是梵行者。当知觉观忆念不忘思惟幻梦等。悉为梵行。若意业是梵行者。当知想是梵行。施设是梵行。寒热饥渴苦乐忧喜等。悉是梵行。若佛是梵行者。为色是佛耶。为受想行识是佛耶。为三十二相八十种好是佛耶。为一切神通业报是佛耶。若法是梵行者。为正教是法耶。为寂灭离涅槃是法耶。为生非生是法耶。为实非实是法耶。为虚妄是法耶。为合散是法耶。若僧是梵行者。为向须陀洹果是僧耶。为得须陀洹果是僧耶。为向斯陀含阿那含阿罗汉果是僧耶。为得斯陀含阿那含阿罗汉果是僧耶。为三明六通是僧耶。为时解脱是僧耶。为非时解脱是僧耶。若戒是梵行者。为戒场是戒耶。为十众是戒耶。为问清净不清净是戒耶。为戒师是戒耶。为三羯磨和尚是戒耶。为剃发法服乞食是戒耶。菩萨摩诃萨。当如是观察十种法。又知过去无所至。未来无所有。现在无作者。无知者无受报者。此世不至彼世。彼世不至此世。为何等法是梵行。梵行法为在何处。谁有是梵行法。此梵行法为是有耶。为是无耶。为是色法耶。为非色法耶。为是受想行识法耶。为非受想行识法耶。菩萨摩诃萨。正念无障碍。观察分别三世诸法平等。犹如虚空无有二相。如是观者智慧方便无所挂碍。于一切法而不取相。一切诸法无自性故。于一切佛及诸佛法。平等观察犹如虚空。是名菩萨摩诃萨方便修习清净梵行。又复修习增上十法。何等为十。所谓是处非处智。去来现在诸业报智。一切诸禅三昧正受解脱垢净起智。众生诸根智。随诸欲乐智。种种性智。至一切处道智。无障碍宿命智。无障碍天眼智。断习气智。是为十。如是观察如来十力甚深无量。具足长养大慈悲心。悉分别众生而不舍众生。亦不舍寂灭。行无上业不求果报。观一切法。如幻如梦如电如响如化。菩萨摩诃萨。如是观者。以少方便。疾得一切诸佛功德。常乐观察无二法相。斯有是处。初发心时便成正觉。知一切法真实之性。具足慧身不由他悟

大方广佛华严经卷第八大方广佛华严经卷第九

        东晋天竺三藏佛驮跋陀罗译

    初发心菩萨功德品第十三

尔时天帝释。白法慧菩萨言。佛子。初发心菩萨。为成就几功德藏。法慧答言。佛子。是处甚深难知难信难解难说难通难分别。虽然我当承佛神力具足演说。佛子。假使有人。供养东方阿僧祇世界众生一切乐具。乃至一劫。然后教令净修五戒。南西北方四维上下亦复如是。佛子。于意云何。彼人功德宁为多不。帝释言。佛子。除诸如来。其余一切。不能称量彼人功德。法慧菩萨语帝释言。佛子。初发心菩萨。功德之藏百分。彼人功德不及其一。千分百千分。亿分百亿分。千亿分百千亿分。百那由他分。千那由他分。百千那由他分。亿那由他分。百亿那由他分。千亿那由他分。百千亿那由他分。乃至不可数不可譬谕不可说分。彼人功德不及其一。佛子。复置此谕。假使有人。供养十方各十阿僧祇世界众生一切乐具。乃至百劫。然后教令净修十善。教十善已。又复供养一切乐具。乃至千劫。然后教令净修四禅。教四禅已。又复供养一切乐具至百千劫。然后教行四无量心。又复供养一切乐具。乃至亿劫。然后教行四无色定。又复供养一切乐具。至百亿劫。然后教令得须陀洹果。又复供养一切乐具。至千亿劫。然后教令得斯陀含果。又复供养一切乐具。至百千亿劫。然后教令得阿那含果。又复供养一切乐具。至亿那由他劫。然后教令得阿罗汉果。又复供养一切乐具。至千亿那由他劫。然后教令尽成缘觉。佛子。于意云何。彼人功德宁为多不。帝释白言。佛子。彼人功德唯除诸佛。其余一切悉不能知。法慧言。佛子。初发心菩萨。功德之藏。百分千分。乃至不可数不可譬谕不可说分。彼人功德不及其一。何以故。佛子。一切诸佛初发心时。不为供养十方各十阿僧祇世界众生一切乐具。百劫乃至千亿那由他劫。故出兴于世。亦不为教尔所众生净修五戒十善。四禅四无量心四无色定。须陀洹果斯陀含果。阿那含果阿罗汉果。辟支佛道。故出兴于世。欲不断佛种故。发菩提心。欲充满十方一切世界故。发菩提心。欲悉度脱一切众生故。发菩提心。欲悉知一切世界成坏故。发菩提心。欲悉知一切世界中众生垢净起故。发菩提心。欲悉知一切世界自性清净故。发菩提心。欲悉知一切群生虚妄烦恼习气故。发菩提心。欲悉知一切众生死此生彼故。发菩提心。欲悉知一切众生诸根方便故。发菩提心。欲悉知一切众生心心所念故。发菩提心。欲悉分别三世一切众生故。发菩提心。欲悉知一切诸佛平等境界故。发菩提心。佛子。复置此谕。假使有人。于一念顷。能过东方无量世界。彼人以此自在神力。从此东行。尽无量无数阿僧祇劫。犹不能得世界边际。又第二人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。此第二人从此东行。尽无量无边阿僧祇劫。犹不能得世界边际。又第三人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第四人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第五人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第六人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第七人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第八人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第九人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。又第十人神力自在。于一念顷。能过前人无量无数阿僧祇劫所行世界。彼第十人。以此最胜自在神力。从此东行。尽无量无数阿僧祇劫。犹故不得世界边际。十方世界亦复如是。如是展转乃至百人。其人以此最胜自在神力。于无量无数阿僧祇劫所至十方。尚可了知得其边际。初发心菩萨功德之藏不可得知。何以故。初发心菩萨不齐限。为尔所世界众生故发菩提心。悉为十方一切世界众生故。欲度一切众生故。欲分别知一切世界故。发菩提心。欲知微细世界即是大世界。知大世界即是微细世界。知少世界即是多世界。知多世界即是少世界。知广世界即是狭世界。知狭世界即是广世界。知一世界即是无量无边世界。知无量无边世界即是一世界。知无量无边世界入一世界。知一世界入无量无边世界。知秽世界即是净世界。知净世界即是秽世界。于一毛孔中。悉分别知一切世界。于一切世界中。悉分别知一毛孔性。知一世界出生一切世界。知一切世界犹如虚空。欲于一念知一切世界悉无有余故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人于东方无量无边阿僧祇世界。于一念中。悉分别知成败之数。此人精勤方便。念念次第。于无量无数阿僧祇劫。欲尽算知东方世界成败之数。犹不能知。又第二人。于第一人无量无数阿僧祇劫所算世界成败之数。于一念中悉能了知。此人精勤方便。念念次第。于无量无边阿僧祇劫。犹不能尽知东方世界成败之数。如是展转乃至第十。彼第十人。于第九人无量无边阿僧祇劫所算世界成败之数。于一念中悉能了知。此人精勤方便。念念次第。于无量无边阿僧祇劫。犹不能尽知东方世界成败之数。乃至十方亦复如是。十方无量无边世界成败之数。尚可了知。初发心菩萨功德之藏。不可得知。何以故。初发心菩萨摩诃萨。不为齐限。知尔所世界劫数成败故。发菩提心。菩萨摩诃萨。欲悉了知一切世界劫数成败故。发菩提心。欲知长劫即是短劫。短劫即是长劫。知一劫即是不可数阿僧祇劫。不可数阿僧祇劫即是一劫。知一切有佛劫。知一切无佛劫。知一佛劫中有无量佛。知无量佛劫中有一佛。知异劫中有无异劫。知无异劫中有异劫。知有尽劫是无尽劫。知无尽劫是有尽劫。知无量劫即是一念。知一念即是无量劫。知一切劫入无劫。知无劫入一切劫。欲悉了知过去未来际及现在一切世界劫数成败故。发阿耨多罗三藐三菩提心。是名菩萨初大誓庄严。所谓悉知一切劫智慧照明。佛子。复置此谕。假使有人。于一念中。悉知无量无数阿僧祇世界众生种种欲乐。此人精勤方便。念念次第。于无量无数阿僧祇劫。不能尽知东方一切世界众生种种欲乐。如是展转至第十人。此第十人。于第九人无量无数阿僧祇劫精勤方便所知众生种种欲乐。于一念中悉能了知。此人如是精勤方便。念念次第。无量无数阿僧祇劫。犹不能尽知东方一切世界众生种种欲乐。乃至十方亦复如是。如是十方无量无边阿僧祇世界众生。种种欲乐尚可了知。初发心菩萨功德之藏。不可得知。何以故。佛子。初发心菩萨摩诃萨不齐限。欲知尔所世界众生种种欲乐故。发菩提心。欲悉知十方一切世界众生种种欲乐故。发阿耨多罗三藐三菩提心。欲知种种无量欲乐即是一欲。而亦不坏一切欲性。欲悉知一切众生欲乐海。欲知一众生欲即是一切众生欲。欲悉知一切众生去来现在种种欲乐。欲悉知相似欲不相似欲。欲知一切欲即是一欲。一欲即是一切欲。欲得具足如来种种欲乐力。欲知有上欲无上欲。有余欲无余欲。等欲不等欲。有所依欲无所依欲。共欲不共欲。有边欲无边欲。善欲不善欲。世间欲出世间欲。大智欲净欲胜欲。无碍智欲。无碍智佛解脱欲。清净欲不清净欲。广欲狭欲。细欲粗欲故。发阿耨多罗三藐三菩提心。欲悉知一切众生一一众生有十种欲。所谓因苦生欲。方便欲。希望欲。着味欲。随因生欲随缘生欲。尽欲。一切欲。初发心菩萨摩诃萨。欲悉分别了知此诸欲网故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念中。悉知无量无边阿僧祇世界众生种种诸根。以此智慧精勤方便。念念次第。于无量无数阿僧祇劫。不能尽知东方一切世界众生种种诸根。广说乃至悉知一切众生一一众生有十种根。佛子。复置此谕。假使有人。于一念中。悉知东方无量无边阿僧祇世界众生种种希望。广说乃至悉知一切众生一一皆有十种希望。佛子。复置此谕。假使有人。于一念中。悉知无量无边阿僧祇世界众生种种方便。广说乃至悉知一切众生一一皆有十种方便。佛子。复置此谕。假使有人。于一念中。悉知无量无边阿僧祇世界众生念念心意。广说乃至悉知一切众生一一皆有十种心。佛子。复置此谕。假使有人。于一念中。悉知无量无边阿僧祇世界众生种种诸业。广说乃至悉知一切众生一一皆有十种业。佛子。复置此谕。假使有人。于一念中。悉知东方无量无边阿僧祇世界众生种种烦恼。此人精勤方便。念念次第。于无量无数阿僧祇劫。犹不能知东方一切众生种种烦恼。如是展转乃至第十。此第十人。于第九人无量无数阿僧祇劫所知众生种种烦恼。于一念中悉分别知。此人精勤方便。念念次第。于无量无数阿僧祇劫。犹不能尽知一切众生种种烦恼。乃至十方亦复如是。尔所世界一切众生种种烦恼尚可得知。初发心菩萨功德之藏不可得知。何以故。佛子。初发心菩萨不齐限。欲知尔所世界众生种种烦恼故。发阿耨多罗三藐三菩提心。欲悉分别了知一切众生种种烦恼故。发菩提心。所谓欲悉知轻烦恼。重烦恼。结使烦恼。缠烦恼。一一众生无量烦恼。一切众生种种觉观烦恼。依无明烦恼。爱相应烦恼。贪欲不善根烦恼。嗔恚不善根烦恼。愚痴不善根烦恼。等分烦恼。一切烦恼。根本烦恼。我我所烦恼。我慢烦恼。邪忆念虚妄生烦恼。因身见生六十二见等诸烦恼。盖烦恼。障碍烦恼。欲悉了知一切众生烦恼惑网。具足大慈悲大一切种智故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念中。悉见东方无量无边世界现在诸佛及彼一切众生。此人悉能恭敬礼拜。尊重赞叹一心观察种种供养无量上味。肴膳饮食香华璎珞。缯彩幢盖上妙宫殿。严饰帐幔宝网罗覆。众宝庄严师子之座。此人精勤方便。念念次第。以如是等众妙供具。无量无数阿僧祇劫供养诸佛。又复劝教彼诸众生。以如是等众妙供具。于无量无数阿僧祇劫供养诸佛。彼诸如来般涅槃已。复为一一诸如来故。以无量宝起塔供养。其塔高广一一周满无量无边世界。又以上妙众宝而庄严之。一一塔中。有无量无数如来形像。彼诸形像。光明普照无量无边诸佛世界。又复劝彼一一众生。为诸如来起众宝塔严好如前。十方世界亦复如是。佛子。于意云何。彼人功德宁为多不。帝释答言。彼人功德唯佛乃知余无能及。法慧答言。佛子。初发心菩萨摩诃萨。功德之藏百分千分。乃至不可数不可譬谕不可说分。彼人功德不及其一。佛子。假使有人。于第一人及所劝众生精勤方便。念念次第。无量无数阿僧祇劫。所作功德诸供养具。于一念中皆悉能辨。此人如是精勤方便。念念次第。于无量无数阿僧祇劫。供养功德。广说如前。如是展转乃至第十人。广说亦复如前。初发心菩萨摩诃萨。功德之藏百分千分。乃至不可数不可譬谕不可说分。彼人功德不及其一。何以故。佛子。彼菩萨不为齐限。供养尔所如来故。发阿耨多罗三藐三菩提心。欲悉供养十方法界虚空界等世界中三世诸佛故。发阿耨多罗三藐三菩提心。发是心已。得知尽过去际诸佛无障碍智。得信尽未来际诸佛功德。得知尽现在际一切诸佛所说智慧。彼三世一切诸佛功德。此菩萨摩诃萨。悉皆信向。受持修习得证身证。悉等诸佛一切功德。何以故。初发心菩萨摩诃萨。欲不断一切诸佛性故。发菩提心。欲令慈悲心充满一切世界众生悉无余故。欲悉度脱一切众生故。欲悉知一切世界成败故。欲悉知一切世界众生垢净起故。欲令三有众生悉得清净故。欲悉知一切众生心念烦恼习故。欲悉知一切众生死此生彼故。欲悉知一切众生诸根方便故。欲悉知一切众生心心行故。欲悉知一切三世众生故。欲悉知三世诸佛具足功德故。欲悉知三世诸佛无上菩提故。欲悉知三世诸佛具足净法故。欲悉知三世诸佛法平等相故。欲悉知三世诸佛无上智慧因缘清净故。欲悉知长养三世诸佛智慧力故。欲悉具足三世诸佛无畏法故。欲悉具足庄严三世诸佛不共法故。欲悉得法界等无量无边三世诸佛平等智慧故。发阿耨多罗三藐三菩提心。何以故。此初发心菩萨即是佛故。悉与三世诸如来等。亦与三世佛境界等。悉与三世佛正法等。得如来一身无量身三世诸佛平等智慧。所化众生皆悉同等。悉能震动一切世界。悉能普照一切世界。悉能休息一切世界诸恶道苦。悉能严净一切世界。悉于一切世界示现成佛。悉令一切众生皆得欢喜。悉令一切众生解深法界。悉能护持诸佛种性。悉得诸佛智慧光明。彼初发心菩萨摩诃萨。常不远离三世诸佛及诸佛法。一切菩萨缘觉声闻及所行法。世间出世间法。众生及众生法。专求菩提智慧无碍

尔时佛神力故。说初发心菩萨功德藏力故。十方各万佛刹尘数世界六种震动。雨众天华天香天末香天鬘天宝天庄严具。自然演出微妙乐声。又复震吼师子之音。放大光明普照十方。尔时十方各过十佛刹尘数世界。有万佛刹尘数诸佛。悉号法慧。各现其身。示法慧菩萨。而告之言。善哉善哉。佛子。善说初发心菩萨功德之藏。我等万佛刹尘数如来。亦悉演说发心菩萨功德之藏。十方世界一切诸佛亦复如是。法慧菩萨。说是发心菩萨功德藏时。万佛世界尘数众生。皆得初发心菩萨功德之藏。发阿耨多罗三藐三菩提心。我等今者悉授彼记。于未来世。各于十方。一时成佛。同号净心如来应供等正觉。我等悉当护持此法。普为未来诸菩萨故。如此娑婆世界四天下阎浮提菩提树下须弥山顶妙胜殿上敷演此法教化众生。十方世界千亿那由他不可量不可数不可思议无有边际不可说法界虚空界等诸世界中。亦说是法教化众生。彼说法者悉名法慧。佛神力故。佛本愿力故。显示佛法故。智慧光明普照故。解第一义故。法如是故。诸菩萨欢喜故。赞叹诸佛功德故。悉知诸佛平等故。解法界无有二故。尔时法慧菩萨。普观十方。普观一切大众。观虚空界。观成就众生界。不违业报。清净如虚空界。欲拔三有垢秽众生。欲令众生得广解脱。欲知种种诸根等。观三世正趣涅槃。及现自身甚深清净诸功德故。承佛神力。以偈颂曰

  大慈大悲心　　充满十方界
  分别诸佛刹　　佛法及三世
  欲具佛功德　　菩萨法藏海
  饶益众生故　　初发菩提心
  欲悉分别知　　虚空等法界
  一切群生类　　诸佛及佛法
  欲得一切佛　　诸道至处力
  成就不退转　　饶益诸群生
  一切众生中　　常起大慈悲
  远离嗔恚念　　修习饶益心
  慈光照十方　　为众作归依
  诸佛悉护念　　功德难思议
  欲悉分别知　　一切诸佛刹
  如来妙法身　　甚深难思议
  无量功德藏　　智慧甚深广
  因是初发心　　专求佛菩提
  欲悉分别知　　一切众生类
  十方世界中　　智慧无障碍
  粗细诸世界　　或狭广无量
  一切中知一　　一中知一切
  菩萨于彼行　　精勤不放逸
  苦乐无厌着　　欲度众生故
  一切佛现前　　乐观无厌足
  悉入甚深法　　无量功德海
  五道诸群生　　愍之如一子
  令除众垢秽　　具足清净法
  欲令诸佛种　　究竟不断绝
  降伏一切魔　　摧灭无有余
  平等观如来　　三世诸法相
  甚深微妙法　　常修不放逸
  菩萨常乐观　　一切佛境界
  是故诸如来　　甘露慧灌顶
  信心不可沮　　坚固如金刚
  于诸如来所　　知恩而报恩
  最胜之境界　　无量智慧光
  自悟不由他　　菩萨初发心
  悉能分别知　　五道众生欲
  种种诸业报　　一切心所行
  知诸根利钝　　无量无数性
  一切胜境界　　菩萨初发心
  菩提心无量　　清净法界等
  无著无所依　　无染如虚空
  成就佛智慧　　其心无障碍
  谛了真实际　　寂灭离虚妄
  了达众生心　　而无众生想
  方便分别法　　究竟到彼岸
  无量无数劫　　悉能分别知
  往诣诸佛刹　　明解甚深法
  若能分别知　　无量诸佛法
  清净法界藏　　谛了无疑惑
  深解众生根　　究竟到彼岸
  平等观诸法　　则与如来等
  清净无量心　　常在诸佛前
  恭敬而尊重　　供养人师子
  亲觐一切佛　　乐观无厌足
  彼诸如来等　　护念此菩萨
  于诸深妙法　　分别无障碍
  无著无所依　　心净如虚空
  彼知人师子　　智慧海深广
  寂然入正受　　三世观无碍
  坚固不可沮　　一切莫能坏
  专念无上道　　未曾有断绝
  离闇趣明正　　志学诸善法
  常乐观寂灭　　具足真实性
  寂默语言道　　平等无异观
  于法不分别　　是则从如生
  悉能分别知　　诸佛深境界
  寂然入正受　　三达无障碍
  十方世界中　　一切诸佛刹
  菩萨自在力　　一念悉周遍
  无量不可数　　方便悉具足
  普游十方界　　是名真佛子
  具足大悲心　　清凉除渴爱
  大慈念一切　　无碍如虚空
  于彼众生类　　不生众生想
  悉已离虚妄　　清净游十方
  于彼诸群生　　常施以无畏
  如此真实行　　是则等如来
  常说甚深法　　清净无所著
  是故十方佛　　一切悉护念
  过去未来世　　无量无数劫
  次第悉忆念　　具足分别知
  菩萨于现在　　一切十方界
  悉能普周遍　　济度诸群萌
  深智正观察　　明了无障碍
  悉知因缘合　　磨灭无坚固
  一切众生类　　诸有疑难者
  菩萨悉除灭　　安住法性中
  菩萨无畏力　　降伏一切魔
  悉能为众生　　灭除愚痴闇
  世界若成败　　悉皆分别知
  若能如是观　　佛境无疑惑
  观察三世法　　疑网永已除
  一切如来所　　净信不可坏
  信力安隐住　　智慧力成就
  智慧清净故　　决定解真实
  尽于未来际　　饶益众生故
  欲令一切众　　究竟得解脱
  无际生死中　　精勤不厌倦
  一切地狱处　　受苦为众生
  功德智慧藏　　具足皆成就
  悉能善分别　　一切众生根
  又能分别知　　众生种种业
  随彼业对治　　菩萨为说法
  以大慈悲心　　随顺世间行
  悉于一切法　　解达空无我
  一一音声中　　演说无量教
  菩萨放大光　　种种微妙色
  普照十方界　　除灭一切闇
  一一光明端　　清净宝华座
  菩萨悉处上　　为众演说法
  于一毛孔中　　普见十方刹
  彼刹妙庄严　　诸佛菩萨会
  一一如来所　　无量众围绕
  清净妙智慧　　明了众生心
  十方世界中　　无量诸佛刹
  菩萨神通力　　一念悉遍至
  恭敬供养佛　　饶益众生故
  一一导师所　　咨决甚深义
  普于诸世尊　　先起慈父想
  饶益众生故　　分别菩萨行
  明净利智慧　　解达深法藏
  出生无量智　　佛法无所碍
  无量无数劫　　分别说法界
  劫数可究竟　　法界无穷尽
  平等观诸法　　其心无所染
  不厌生死苦　　智慧无障碍
  无上佛种性　　三世法王家
  一切如来法　　菩萨由此生
  清净妙法身　　应现种种形
  犹如大幻师　　所乐无不见
  或处为众生　　究竟菩萨行
  或复现初生　　出家行学道
  或于树王下　　自然成正觉
  或处为众生　　示现入泥洹
  现住甚深妙　　无量自在法
  声闻辟支佛　　一切莫能测
  菩萨身口意　　寂灭无生相
  普应一切世　　方便无不现
  如是佛真子　　境界甚深妙
  众生若思议　　迷乱心发狂
  一切悉具足　　安住无碍智
  普现诸如来　　无量自在力
  菩萨功德藏　　世间无与等
  何况最胜尊　　无量难思议
  菩萨虽未得　　具足一切智
  无量诸法门　　究竟到彼岸
  一切胜妙法　　皆悉已具足
  一向求菩提　　究竟一乘道
  于彼诸群生　　善知时非时
  为欲利益故　　示现大神力
  一身悉充满　　一切诸佛刹
  演出净光明　　辉耀无伦匹
  遍照十方界　　除灭一切闇
  普降妙法雨　　如海大龙王
  观察一切法　　虚妄犹如幻
  烦恼业力故　　生死常轮转
  以大慈悲心　　普覆诸群生
  清净妙方便　　度脱无量众
  菩萨功德力　　与诸如来等
  无量智慧海　　清净如虚空
  无量无数劫　　具修菩萨行
  精进勤方便　　欲度一切众
  众生种种行　　悉能分别知
  令修清净业　　志求无上道
  菩萨摩诃萨　　行是胜妙法
  决定不退转　　谛观一切智
  一切诸世界　　无量难思议
  菩萨能于彼　　一念悉周遍
  远离虚妄想　　其心如虚空
  清净法身一　　普应一切世
  湛然常不动　　十方无不现
  分别一切法　　不取诸法相
  了达一切法　　其心无所染
  济度一切众　　而无解脱者
  一切群生类　　种种诸希望
  善恶无记法　　寂灭如虚空
  随顺众庶类　　种种欲乐相
  无量自在力　　悉能应化之
  犹如工幻师　　能现种种身
  菩萨自在力　　充满十方界
  菩萨净法身　　无量等虚空
  随众所欲乐　　一切无不现
  其心无所染　　真实无虚妄
  清净烦恼法　　皆悉无所有
  解脱非解脱　　其心无所染
  普施苦众生　　无上涅槃乐
  悉于诸世间　　智慧无所畏
  具足众相好　　究竟无上道
  一念悉分别　　一切诸法相
  去来现在世　　求之无所有
  菩萨观前际　　了达过去世
  分别后际相　　究竟亦如是
  一切佛世界　　分别皆悉知
  除灭众烦恼　　具足诸功德
  常好观寂静　　究竟趣涅槃
  乐无诤三昧　　其心无所依
  菩萨等实际　　一切无与等
  究竟坚固行　　决定不退转
  彼修众胜行　　寂灭无所依
  其心常安住　　不动如须弥
  菩萨净妙行　　充满诸法界
  诸佛及菩萨　　皆悉分别知
  欲求导师慧　　究竟最胜道
  甚深一切智　　无上解脱王
  勇猛勤精进　　速发菩提心
  欲求最胜乐　　应疾断诸漏
  菩萨摩诃萨　　初发清净心
  彼心功德藏　　说之不可尽
  饶益众生故　　赞叹如来行
  一心善谛听　　最胜所行道
  无量诸佛刹　　悉末为微尘
  一尘置一刹　　悉能分别知
  是诸刹土中　　一切诸如来
  说初功德藏　　犹故不可尽
  善分别众生　　而无众生想
  善解一切语　　而无言语想
  甚深无碍智　　分别诸世界
  善解劫成败　　而无成败想
  清净广大心　　犹如虚空性
  明解三世法　　一切诸世间
  除灭诸烦恼　　永尽无有余
  无碍寂灭观　　是则佛正法
  十方世界中　　一切如来所
  一念悉遍至　　其心无所染
  善解不生法　　如如真实际
  一切种种相　　皆悉无真实
  无量不可数　　一切诸如来
  清净眷属俱　　悉往礼供养
  常乐问如来　　甚深微妙法
  一切诸菩萨　　誓愿清净行
  十方世界中　　一切诸导师
  一念悉睹见　　而心无所依
  一切三有中　　最胜妙功德
  以此清净行　　庄严诸佛刹
  慧眼无障碍　　善解一切生
  分别无所有　　远离无染着
  善解众生根　　烦恼及习气
  众生种种欲　　了达不思议
  菩萨摩诃萨　　先知众生心
  随彼所应度　　慧者为说法
  善知时非时　　众生净秽行
  渐令彼清净　　究竟得解脱
  无量那由他　　甚深诸三昧
  菩萨自在力　　一念悉能入
  三昧起住相　　悉善分别知
  无量诸境界　　善解住起缘
  如是等智慧　　皆悉已具足
  不久得菩提　　一切无障碍
  常为利众生　　正趣智慧光
  彼能与众生　　无上丈夫法
  悉能善分别　　一切劫长短
  昼夜及岁月　　斯亦善观察
  正念不放逸　　善解诸世间
  分别诸佛刹　　真实无差别
  能善分别知　　一切诸世界
  于彼十方国　　无有分别想
  如是正观察　　十方诸世界
  严净一切国　　而心无所著
  成就智慧力　　与诸如来等
  是处非处力　　分别知众生
  悉知众生类　　善恶诸业报
  过去未来世　　明达无障碍
  一切诸世界　　众生种种性
  于彼三有中　　悉能分别知
  一切群生类　　诸根上中下
  菩萨摩诃萨　　悉能分别知
  一切众生类　　欲乐上中下
  清净不清净　　悉能分别知
  分别知众生　　一切至处道
  永断相续缘　　究竟离三有
  一切诸三昧　　正受禅解脱
  垢秽清净起　　悉能分别知
  次第知宿命　　随所受苦乐
  如是分别者　　是则如来力
  一切善不善　　众生烦恼业
  分别五道生　　究竟得泥洹
  诸漏若未尽　　能趣处处生
  烦恼习已灭　　究竟无上道
  方便度众生　　灭垢具净道
  慧者能分别　　是则人中雄
  具足十种力　　慧光除众冥
  安住最胜力　　疑惑究竟灭
  一一毛孔中　　无量诸佛刹
  菩萨摩诃萨　　一切皆悉见
  秽浊或清净　　种种妙庄严
  随彼诸行业　　皆悉分别知
  一一微尘中　　一切诸佛刹
  诸佛及菩萨　　佛子皆悉见
  诸刹不积聚　　不乱不迫迮
  一切入一刹　　而亦无所入
  十方诸国土　　虚空法界等
  能于一毛孔　　具足分别知
  普见十方界　　一切诸最胜
  微妙净庄严　　一切诸佛刹
  一切诸如来　　及彼严净国
  于一毛孔中　　慧者皆悉见
  三世差别相　　一切诸法界
  时节岁相续　　分别得解脱
  如是真佛子　　具足无所畏
  是名人中雄　　明达智慧者
  如是深法门　　慧者悉分别
  彼于如来所　　恭敬喜无量
  无量无数劫　　长养功德藏
  供养一切佛　　度脱众生故
  无量自在力　　种种能示现
  彼智慧境界　　与诸如来等
  无量诸佛所　　所学皆成就
  寂静深法藏　　悉乐无厌足
  一切导师所　　恭敬尊重心
  彼修菩萨行　　常饮法甘露
  悉能善分别　　长养智慧法
  菩提无碍辩　　甚深诸三昧
  信心不可动　　犹如须弥山
  长养诸众生　　一切功德藏
  菩萨摩诃萨　　大慈悲无量
  普念一切众　　其心无所著
  一切种智乐　　惠施诸众生
  悉欲救世间　　永离烦恼垢
  菩萨摩诃萨　　大悲心无量
  佛及己众生　　等观无有异
  乐观寂灭相　　诸法如虚空
  慧者如是观　　一切真实性
  菩萨初发心　　甚深功德藏
  无量无数劫　　说之不可尽
  出生诸如来　　缘觉闲静乐
  自在声闻众　　一切贤圣故
  十方世界中　　无边诸佛刹
  所有众生类　　供养无量劫
  又教修五戒　　十善及四禅
  四等无色定　　寂灭诸解脱
  复于无量劫　　供施诸乐具
  又复教转胜　　漏尽成罗汉
  如此诸功德　　犹尚可称量
  发心功德藏　　无譬不可说
  又化无量众　　悉成辟支佛
  寂静三摩提　　甚深诸功德
  彼人功德聚　　比初发心藏
  百分不及一　　乃至不可说
  无量无有边　　微尘等佛刹
  假使神力人　　一念悉能过
  如是神足力　　无量劫中行
  彼刹犹可数　　发心藏难知
  去来现在劫　　无量无有边
  如是等诸劫　　犹可知其数
  菩萨初发心　　无量功德藏
  犹如虚空界　　分际不可知
  去来现在世　　一切诸劫数
  菩萨于一念　　悉能分别故
  菩萨发心宝　　欲达去来今
  一念悉明了　　利益众生故
  十方世界中　　无量刹众生
  所有欲希望　　一念悉分别
  知诸根方便　　念念心所行
  虚空尚可量　　菩提心难知
  所以不可量　　大慈无量故
  普施一切乐　　充满十方界
  欲令悉得佛　　法藏解脱乐
  初发宝藏心　　功德力无量
  众生欲希望　　方便愿求想
  随彼种种根　　身口意所行
  能于一念中　　彼彼悉觉知
  欲得一切智　　发心愿菩提
  一切众生类　　无量烦恼业
  由斯结业故　　趣趣受诸有
  如此结业报　　犹可知边际
  发心功德藏　　不可得思议
  所以不可议　　能发无上愿
  供养一切佛　　永离诸烦恼
  兼除群生类　　一切烦恼业
  济拔三世苦　　究竟大悲心
  十方诸世界　　无量无数佛
  一念悉供养　　兼以劝众生
  熏以殊妙香　　宝幢诸幡盖
  天衣珍妙馔　　上味甘露浆
  随时诸宫观　　床卧庄严具
  清净经行地　　安身顺道心
  斯等众供具　　无量宝庄严
  摩尼发光耀　　皆是快乐因
  如是供养佛　　兼以劝众生
  不可思议劫　　常行此供养
  斯等诸功德　　尚可究竟说
  发心功德藏　　无可为譬谕
  一切诸譬谕　　如前广分别
  欲比初发心　　无量不及一
  三世人中尊　　一切功德业
  无上菩提果　　皆由初发心
  无数亿劫中　　修行无上道
  无数无有量　　出过一切量
  究竟一切智　　其力不可量
  到彼菩提岸　　超度群生趣
  初发菩萨心　　广大如虚空
  出生诸功德　　其相同法界
  等观诸法性　　如实无异相
  永离一切有　　性同坚固士
  甚深真法性　　妙智随顺入
  无边诸佛土　　一念悉周遍
  一切智所知　　无不遍观察
  无量佛境界　　了达无障碍
  常修妙功德　　一切无与等
  具足微妙戒　　清净无瑕秽
  内外一切施　　等心施一切
  一切时常施　　精勤不退转
  专念修正受　　诸禅功德藏
  常习微妙智　　深广无涯底
  于此最胜地　　成就佛真子
  逮得如实智　　平等甚深行
  去来现在世　　一切诸如来
  悉以威神护　　初发菩提心
  甚深诸三昧　　无量陀罗尼
  诸佛自在力　　庄严初发心
  一切诸世间　　莫能称算者
  无量无有边　　犹如虚空界
  初发菩提心　　无量无有边
  一切人师子　　皆由初发心
  如来十种力　　四辩无所畏
  无量诸功德　　皆由初发心
  一切诸导师　　十八不共法
  斯等殊胜慧　　皆由初发心
  诸佛妙色身　　种种相庄严
  究竟离虚妄　　清净真法身
  天人所应供　　甚深无碍智
  如是等功德　　皆由初发心
  一切辟支佛　　无量声闻众
  斯等诸贤圣　　皆由初发心
  四禅无色定　　甚深诸三昧
  斯等无量乐　　皆由初发心
  去来今现在　　十方天人类
  一切世界中　　趣趣受生乐
  方便勤精进　　诸根悉调伏
  斯等无量乐　　皆由初发心
  所以然者何　　菩萨摩诃萨
  因初发心故　　具六波罗蜜
  化诸群生类　　弃邪入正道
  故能令三界　　受兹种种乐
  菩萨深妙智　　通达无障碍
  开导诸众生　　净修殊胜业
  灭除众烦恼　　一切不善行
  修习涅槃道　　度脱一切众
  无量智慧明　　犹如净日光
  具足清白行　　譬如月盛满
  无边功德藏　　犹如十方海
  无垢无所染　　清净如虚空
  菩萨初发心　　称赞不可尽
  悉令诸众生　　具受一切乐
  无量无数劫　　广修诸大愿
  常习功德业　　调伏众生故
  无量无有数　　净愿难思议
  皆悉具足满　　令众得清净
  普观一切法　　悉空无相愿
  弘誓愿力故　　心净无所畏
  解法真实性　　清净如虚空
  定乱悉平等　　寂灭无所有
  甚深诸妙法　　无量难思议
  常为大众说　　其心无染着
  十方世界中　　一切诸如来
  彼佛常赞叹　　菩萨初发心
  无量妙功德　　庄严初发心
  至彼清净岸　　性同诸如来
  一切众生类　　无量无数劫
  称赞初发心　　功德不可尽
  诸佛功德藏　　菩萨由是生
  于诸三有中　　最胜无伦匹
  欲得一切佛　　明净智慧灯
  应建弘誓愿　　速发菩提心
  一切功德中　　菩提心为最
  能得无碍智　　从佛法化生
  一切众生心　　悉可分别知
  一切刹微尘　　尚可算其数
  十方虚空界　　一毛犹可量
  菩萨初发心　　究竟不可测
  因初菩提心　　出生三世佛
  一切诸众生　　种种上妙乐
  佛所赞功德　　因此悉具足
  于佛境界中　　其心无疑惑
  若能永远离　　一切诸疑惑
  则能灭众生　　无量诸障碍
  因初菩提心　　严净诸佛国
  普令一切众　　具足微妙智
  欲见十方刹　　三世一切佛
  又欲得无量　　甚深功德藏
  若欲灭众生　　无量生死苦
  应建坚誓愿　　速发菩提心

大方广佛华严经卷第九大方广佛华严经卷第十

        东晋天竺三藏佛驮跋陀罗译

    明法品第十四

尔时精进慧菩萨。问法慧菩萨言。佛子。初发心菩萨。成就如是无量功德之藏。以大庄严而自庄严。乘一切智乘入菩萨离生道。远离世间志求正觉。诸佛所住皆以得住。决定成就无上菩提。彼菩萨摩诃萨。云何修习功德转胜。令诸如来皆悉欢喜。具足菩萨所住功德清净之行。大愿成满得菩萨藏。随其所应而化度之。已能不舍诸波罗蜜。随所请众生皆悉度脱。兴隆三宝永使不绝。一切所为善根境界。诸行方便皆悉不虚。善哉佛子。当为我等演说此法。愿乐欲闻。如诸菩萨所修功德。灭除痴闇降伏众魔。制诸外道。离于尘垢。具足成就一切功德。究竟永离恶道诸难。具足清净甚深智慧。菩萨一切诸地功德诸波罗蜜三昧总持六通三明清净之法。庄严一切诸佛世界。具足相好。微妙音声。清净心行。一切如来力无所畏。十八不共。萨婆若智。具足佛刹随成熟众生。随时随根。无量佛事。及诸菩萨无量功德。菩萨正法菩萨所行。菩萨之道菩萨境界。皆悉满足。速成如来一切诸佛无量法藏。悉能守护。分别广说开示显现。众魔外道所不能坏。摄持正法而无穷尽。于一切世界。悉能演说天王。龙王。夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王。梵王。诸佛法王。皆悉守护此菩萨摩诃萨。一切世间恭敬供养尊重赞叹。常为诸佛之所护念。一切菩萨皆亦爱敬。得善根力增长白法。能开诸佛甚深法藏。以大正法而自庄严。次第演说菩萨所行。尔时精进慧菩萨。欲重宣此义。以偈颂曰

  善哉愿说大乘法　　菩萨所成诸功德
  深入广大无量行　　具足清净无师智
  若有菩萨初发心　　成就功德智慧乘
  入离生道出世间　　决定疾得佛菩提
  云何于佛正法中　　修习功德转增胜
  令诸如来悉欢喜　　佛所住地而得住
  所行清净大愿满　　具足菩萨智慧藏
  悉能度脱一切众　　而于群生无所著
  不舍一切波罗蜜　　诸所施为悉不虚
  所请众生皆能度　　兴隆佛法永不绝
  净眼境界无障碍　　具足功德求佛道
  人雄所行清净道　　悉为具足分别说
  灭除一切愚痴闇　　降伏众魔制外道
  离垢功德皆成就　　得人中尊妙智慧
  永离众难恶道苦　　清净智慧皆具足
  无量甚深大功德　　成就最胜诸道力
  得人中上妙智慧　　随其所应而度之
  不可思议诸佛刹　　自在无量作佛事
  一切殊胜甚深行　　分别人雄功德藏
  常能护持最胜法　　世间诸难莫能坏
  云何无畏如师子　　功德具足如满月
  犹如莲华不着水　　功德清净如最胜

尔时法慧菩萨。告精进慧菩萨言。善哉善哉。佛子。多所饶益。多所安乐。多所惠利。哀愍世间诸天人故。能问如是菩萨甚深清净之行。佛子。汝住甚深真实智慧大精进力。一心修习得不退转。超出世间。所问自在与如来等。佛子。汝今谛听善思念之。我当承佛神力为汝少说。佛子。此菩萨摩诃萨。已得发心功德之藏。应离痴闇精勤守护灭诸放逸。佛子。菩萨摩诃萨。有十种法得不放逸。何等为十。一者持戒清净。二者远离愚痴净菩提心。三者舍离谄曲哀愍众生。四者勤修善根得不退转。五者常乐寂静远离在家出家一切凡夫。六者心不愿乐世间之乐。七者专精修习诸胜善业。八者舍离二乘求菩萨道。九者常习功德心无染污。十者善能分别自知己身。佛子。是为菩萨修十种行住不放逸。佛子。菩萨摩诃萨。已能住此不放逸法。又复正行十种净法。何等为十。佛子。此菩萨摩诃萨。如说修行念智成就。舍离调戏诸放逸行。安住甚深微妙善法。常乐求法心无厌足。随所闻法得真实观。具足出生巧妙智慧。能入佛自在。心常寂定未曾散乱。闻好闻恶心无忧喜。犹如大地。等视众生。上中下类悉如佛想。恭敬供养和尚诸师及善知识菩萨法师。念念次第如一切智。佛子。是为菩萨十种净法。佛子。菩萨摩诃萨。如是精勤修习念知。不舍方便。心无所倚。修甚深法入于无诤。无量无边深妙佛法。皆悉了知。令诸如来皆悉欢喜。佛子。菩萨摩诃萨。行十种法。能令一切诸佛欢喜。何等为十。一者所行精勤而不退转。二者不惜身命。三者不求利养。四者修一切法犹如虚空。五者巧方便慧观察诸法等同法界。六者分别诸法心无所倚。七者常发大愿。八者成就清净忍智光明。九者善知一切损益诸法。十者所行法门皆悉清净。佛子。是为菩萨行十种法能令一切诸佛欢喜。佛子。菩萨复安住十法。能令一切诸佛欢喜。何等为十。安住不放逸。安住无生法忍。安住大慈。安住大悲。安住满足诸波罗蜜。安住菩萨清净之行。安住满足无量大愿。安住巧方便。安住一切力。安住一切法。犹如虚空无所依止。佛子。是为菩萨安住十法能令一切诸佛欢喜。佛子。菩萨摩诃萨。行十种法。能速成就一切诸地。何等为十。一者心常乐行诸功德事。二者行大庄严诸波罗蜜道。三者智慧明达不随他语。四者恒不远离真善知识。五者常修精进而不退转。六者善取佛意受持诸法。七者行诸善根心无忧戚。八者以大乘庄严而自庄严明利慧光普照一切。九者安住一切诸地法门。十者同三世佛善根正法。佛子。是为菩萨行十种法能速成就一切诸地。佛子。彼菩萨摩诃萨。住诸地已。先应修习巧妙方便。随其所得诸地法门。随其所得甚深智慧。随其行业。随其依果。随其境界。随其自在。随其示现。随其分别诸胜法门。得诸胜法门已。悉善分别。于一切法而无所著。所有诸法皆由心造。菩萨摩诃萨。若能如是明了观察。则能具足一切诸地。彼菩萨摩诃萨。作如是念我应速成一切诸地。何以故。我于诸地如说行时。逮得无量诸功德藏。得无量功德藏已。渐到佛地。到佛地已能作佛事。是故菩萨摩诃萨。常勤修习不舍方便心无忧戚。得大庄严住菩萨住。佛子。菩萨摩诃萨。复行十法。悉能清净菩萨诸行。何等为十。一者悉舍一切满众生意。二者持戒清净无所毁犯。三者具足忍辱无有穷尽。四者勤修方便而不退转。五者离痴正念常定不乱。六者分别明了一切诸法。七者具足成满一切众行。八者功德尊重心如山王。九者为一切众生作清凉池。十者令一切众生同诸佛法。佛子。是为菩萨行十种法悉能清净菩萨诸行。佛子。菩萨摩诃萨。如是修行清净之行。复得十种转胜妙法。何等为十。一者他方诸佛皆悉护念。二者修习长养超胜善根。三者安住如来巧密方便。四者常乐亲近依善知识。五者安住精进修不放逸。六者分别诸法非总非别。七者安住具足无上大悲。八者观法如实出生智慧。九者能善修行巧妙方便。十者一切方便观如来力。佛子。是为菩萨十种清净转胜妙法。佛子。菩萨摩诃萨。复有十种清净之愿。何等为十。愿成就众生心无忧戚。愿长养善根严净佛刹。愿恭敬供养一切如来。愿不惜身命守护正法。愿以种种诸智慧门悉令众生生诸佛刹。愿诸菩萨入不二法门入佛法门分别诸法。愿令一切所欲见佛悉得见之。愿尽未来际一切诸劫如须臾顷。愿具足普贤菩萨所愿。愿净一切种智之门。佛子。是为菩萨摩诃萨十种清净之愿。佛子。菩萨摩诃萨。修行十法。悉能满足一切诸愿。何等为十。一者生大庄严心无忧戚。二者转向胜愿念诸菩萨。三者所闻十方严净佛刹悉愿往生。四者究竟未来际。五者究竟成就一切众生满足大愿。六者住一切劫。不觉其久。七者于一切苦不以为苦。八者于一切乐心无染着。九者悉善分别无等等解脱。十者得大涅槃无有差别。佛子。是为菩萨摩诃萨悉能满足一切诸愿。菩萨摩诃萨。满诸愿已。逮得十种无尽法藏。何等为十。得见诸佛无尽之藏。得陀罗尼无尽之藏。得分别法无尽之藏。得大悲心覆护一切无尽之藏。得诸三昧无尽之藏。得满众生意功德无尽之藏。得深智慧解法真实无尽之藏。得出生诸通分别众宝无尽之藏。得一切诸佛威神守护无尽之藏。得分别无量无边世界智慧无尽之藏。佛子。是为菩萨摩诃萨得十种无尽之藏。成就无量无边功德之藏。具足净慧。随其所应而化度之。佛子。云何菩萨摩诃萨。随其所应而化众生。此菩萨。知诸众生所宜方便。知诸众生种种因缘。知诸众生心心所念。知心念已教对治法。贪欲多者教不净观。嗔恚多者教大慈观。愚痴多者教令分别一切诸法。三毒等分教以具足胜智法门。乐生死者教三种苦。着诸有者教空法门。懈怠众生教行精进。我慢众生教平等观。心谄曲者教菩萨心寂静非有。如是一切诸烦恼患。教以无量对治法门。具足次第演说义味。分别智慧平等观法先后无违。演说诸法破坏之性。而于法界无所散灭。断除疑惑令悉欢喜。随其诸根教入真谛。教诸功德入如来海。说真实际以坏众相。教等法界开示法藏。教一切依心无所染。教平等念。一切诸佛恭敬亲近。教柔软音而无所著。教一切音而无差别。教殊胜法而无伦匹。教具足一切如来平等智身。菩萨如是。常能化度一切众生。而心寂定未曾散乱。不舍一切诸波罗蜜。具足庄严六波罗蜜。普为一切群生类故。悉能舍离内外所有。而未曾起悭吝之心。是名清净檀波罗蜜。又复不生持戒相故于戒无著。是名清净尸波罗蜜。悉能堪忍一切诸苦。闻好闻恶心无忧喜。未曾倾动犹如大地。是名清净羼提波罗蜜。勇猛精进方便修习。其心坚固而不退转。究竟成就佛智慧门。是名清净毗梨耶波罗蜜。舍一切欲离生喜乐。清净次第。入于正受而无所染。烧灭烦恼生无量定。具大神通。次第超越。入于无量诸三昧门。于一三昧门入无量三昧。悉知一切三昧境界。渐具诸佛智慧之地。是名清净禅波罗蜜。于诸佛所闻法受持。恭敬亲近诸善知识心无疲倦。常乐闻法无有厌足。所闻诸法能正观察。入真实定。舍离一切颠倒邪见。妙善方便。分别了知诸法相海无有自性。修习如来深智慧门。具足一切智慧之力。乘普门慧。能入一切智慧之门。是名清净般若波罗蜜。示现一切世间威仪。教化众生心无忧戚。随其所应示现其身。一切所行心无染着。示现童蒙黠慧所行。示现生死及解脱门。善能分别诸方便行。示现无量诸庄严事。能入一切诸生趣中。解了一切众生所行。是名清净方便波罗蜜。究竟成就一切众生。究竟严净一切世界。究竟供养一切如来。究竟解达诸法真实而无障碍。究竟修行具足法界。究竟未来劫住如须臾顷。究竟未来劫犹如一念。究竟解达一切成坏。究竟示现一切佛刹。究竟逮得诸佛智慧。是名具足愿波罗蜜。自专正力。离众烦恼。具足清净。能正他力。具足成就无能坏者。大悲力满足。大慈力平等。悉能覆护一切众生。陀罗尼力。能持一切诸方便义。妙辩才力。令诸众生皆悉欢喜。诸波罗蜜力。庄严大乘。弘誓愿力。未曾断绝。诸神通力。出生无量具佛神力覆护一切。是名清净力波罗蜜。知贪欲增。知嗔恚增。知愚痴增。又知等分分别学地。于一念中。悉知众生心心所行。能知众生诸所希望。能知一切诸法真实。解达诸佛深智慧力。普知一切诸法界门。是名清净智波罗蜜。佛子。菩萨摩诃萨。如是清净诸波罗蜜。满足诸波罗蜜。不舍诸波罗蜜。乘大庄严悉能度脱所请众生。教化一切修习善行。悉令一切永离恶道。勤修精进超出众难。贪欲多者教离欲观。嗔恚多者教平等观。邪见多者教因缘观。欲界众生。教离欲恚恶不善法。色界众生。教增上观。无色界众生。教细微智慧。乐声闻缘觉教寂静行。乐大乘者教以十力庄严大乘。如初发心时。见有众生堕诸恶道。大师子吼。我当知其心病。以诸法门而济度之。菩萨具足如此智慧。皆能度脱一切众生。佛子。菩萨摩诃萨。能如是行者。则能兴隆三宝永使不绝。所以者何。菩萨摩诃萨。教化众生发菩提心。是故能令佛宝不断。开示甚深诸妙法藏。是故能令法宝不断。具足受持威仪教法。是故能令僧宝不断。复次悉能赞叹一切大愿。是故能令佛宝不断。分别解说十二缘起。是故能令法宝不断。行六和敬。是故能令僧宝不断。复次下佛种子于众生田。生正觉芽。是故能令佛宝不断。不惜身命护持正法。是故能令法宝不断。善御大众心无忧恼。是故能令僧宝不断。去来今佛所说正法不违其教。是故能令三宝不断。菩萨如是不断三宝。一切所行无有不善。彼能悉行一切回向。决定究竟无上菩提。菩萨如是安住清净身口意业已。所说善根教化众生。种种方便所言不虚。能令众生皆得欢喜。彼菩萨摩诃萨诸所施行。乃至无有一念错谬。如是一切诸深妙行。皆为智慧方便摄持。悉能回向无上菩提。如是菩萨安住离痴清白法已。于念念中。具足出生十种庄严。何等为十。色身庄严。随应示现。语言庄严。除众疑惑悉令欢喜。意行庄严。于一念中入诸正受。佛刹庄严。灭除一切诸烦恼迹。光明庄严。普照十方。眷属庄严。能集胜众悉令欢喜。神力庄严。随其所应自在示现。佛教庄严。皆能摄取诸黠慧者。涅槃地庄严。一处成道悉能充满示现十方。持法庄严。随众随时随其器量而为说法。菩萨如是于念念中。具足出生十种庄严已。身口意行悉皆清净。永离愚痴智慧成就。如此菩萨若有亲近恭敬。随逐出家听受法教。随喜忆念乃至见闻。此等众生。必定究竟无上菩提。佛子。譬如阿伽陀药。众生见者众病悉除。菩萨成就如是无量法藏。众生见者烦恼诸病皆悉除愈。于白净法心得自在。佛子。菩萨摩诃萨。若得成就如是方便。安住此法。除灭愚痴具足智慧故降伏众魔。大慈悲心故制诸外道。具足智慧功德力故。除灭一切心垢烦恼。入金刚定故。具足善根心无忧戚。于先佛所修功德力故。能离一切恶道诸难。清净智慧悉满足故。出生菩萨清净诸地诸波罗蜜一切三昧六通三明四无所畏次第方便智慧力故。净诸佛刹。相好庄严身口意净白净法力故。得佛十力四无所畏十八不共平等佛法。智慧分别速解诸法。一切种智平等正觉诸大愿力。如来神力大智慧力。随顺众生现诸佛刹。随应受化转大法轮。度脱无量无边众生。佛子。菩萨摩诃萨。如是修行无量法藏。次第具足得如来处。于无量刹修菩萨行。护持正法为大法师。守护摄持如来法藏。成就四辩。于大众中演畅深法。身相端严说法周备。于四辩才。具足无量巧妙方便。能得无尽诸智慧门。音声殊妙。演一法言能悦一切。随宜顺导令得开解入智慧门。菩萨以如是等无量方便。普为众生开阐法藏。而未曾生懈怠之心。于大众中而无所畏。一切世间无能坏者。具足增上般若波罗蜜。次第分别一切法相而无断绝。胜妙四辩说一切法。种种譬谕不可穷尽。具足大悲。能令一切清凉悦乐。修习大慈充遍十方。处师子座。广为众生说微妙法。唯除如来无能过者。无能见顶。无能观察。无能屈者。无能问难。若能穷其言论之辩。无有是处。佛子。菩萨摩诃萨。成就如是胜妙法已。无边世界满中大众。彼一一身。犹如三千大千世界。菩萨摩诃萨。处彼众中其身殊特。映蔽大会。皆悉不现。以大慈心普覆一切。甚深智慧分别彼心。成就无畏具足辩才。广为说法皆令欢喜。何以故。菩萨摩诃萨。成就无量净智慧故。成就无量巧方便故。成就无量正念力故。成就无尽巧方便故。成就分别诸法陀罗尼故。成就分别诸法深智慧故。成就诸佛威神力故。成就三世诸佛实智慧故。成就三世诸佛清净巧方便故。成就广说一切诸佛甚深法藏护持法故。成就三世诸佛胜妙智慧菩萨大愿智慧力故。尔时法慧菩萨说是渐增功德藏已。欲重宣此义。承佛威神。以偈颂曰

  菩萨住初地　　长养功德藏
  修习不放逸　　慧光照十方
  菩萨菩提心　　守护常不妄
  十方诸如来　　心皆大欢喜
  勤修行精进　　正念力坚固
  所行不退转　　不着于世间
  常乐甚深法　　成就无诤定
  十方诸最胜　　一切皆欢喜
  诸佛欢喜已　　究竟精进度
  成就功德藏　　无量深智慧
  一切行清净　　具足于诸地
  十方佛本愿　　皆悉具足满
  如是智慧成　　得诸深法藏
  得是法藏已　　随顺于世间
  成就巧方便　　分别众生心
  随所应教化　　而为演说法
  已能广说法　　不舍于自行
  具足波罗蜜　　成就大功德
  已具波罗蜜　　本所请众生
  无量生死海　　皆悉究竟度
  如是常修习　　日夜无休懈
  兴隆佛法僧　　永使不断绝
  所修无量行　　清白悉具足
  一切皆究竟　　成就最胜地
  菩萨所修行　　真实无虚伪
  度脱众生类　　离诸烦恼垢
  成就如是法　　除灭愚痴闇
  降伏一切魔　　究竟得菩提
  佛子如是行　　具足如来智
  悉能分别说　　诸佛甚深藏
  若能如是说　　法师中第一
  等为诸群生　　普雨甘露法
  无极大慈悲　　充满十方界
  悉能分别知　　一切众生心
  已了众生心　　及诸余心行
  为彼说深法　　无量无有数
  进止常安谛　　犹如大象王
  威猛如师子　　一切莫能害
  不动如须弥　　智慧如大海
  普雨甘露水　　除灭烦恼热

法慧菩萨。说是偈已。如来随喜。大众奉行

    大方广佛华严经佛升夜摩天宫自在品第十五

尔时如来威神力故。十方一切诸佛世界。诸四天下一一阎浮提。皆有如来坐菩提树下。无不显现。彼诸菩萨。各承佛神力说种种法。皆悉自谓在于佛所。尔时世尊。威神力故。不离道树及帝释宫。向夜摩天宝庄严殿。时彼天王遥见佛来。即于殿上敷莲华藏宝师子座。十万种宝以为庄严。十万宝帐弥覆其上。十万宝网以为珓珞。次上十万众妙宝盖。又复十万天诸华盖。天缯杂宝以为垂带。十万璎珞而庄严之。十万宝衣。以敷其上。十万天子在前立侍。十万梵天而围绕之。十万菩萨在前赞叹。十万光明以为照耀。十万妓乐自然演出。十万正法娱乐音声。十万善根妙相显现。十万如来威神护持。十万功德藏而长养之。十万三昧而严净之。十万愿藏以为清净。十万奇特未曾有法胜相显出。十万妙法而现在前。十万自在处处普现。十万功德妙相等起。十万音声演出诸法。时彼天王。庄严宝莲华藏师子座已。合掌恭敬白佛言。善来世尊。唯愿哀愍处此宫殿。时佛受请即升宝殿。一切十方夜摩天宫亦复如是。尔时天王。无量音乐寂然无声。即自忆念过去佛所所种善根。以偈颂曰

  名称如来闻十方　　诸吉祥中最无上
  来入摩尼庄严殿　　是故此处最吉祥
  宝王如来世间灯　　诸吉祥中最无上
  来入甘露上味殿　　是故此处最吉祥
  喜王如来慧无量　　诸吉祥中最无上
  来入杂宝庄严殿　　是故此处最吉祥
  慧眼如来世间灯　　诸吉祥中最无上
  来入殊特最胜殿　　是故此处最吉祥
  饶益如来义无量　　诸吉祥中最无上
  来入清净宝山殿　　是故此处最吉祥
  无师如来世间尊　　诸吉祥中最无上
  来入微妙宝香殿　　是故此处最吉祥
  天人中尊世间灯　　诸吉祥中最无上
  来入轻微妙香殿　　是故此处最吉祥
  无去如来论师子　　诸吉祥中最无上
  来入明净普眼殿　　是故此处最吉祥
  分别如来功德持　　诸吉祥中最无上
  来入娱乐庄严殿　　是故此处最吉祥
  苦行如来利世间　　诸吉祥中最无上
  来入等色普照殿　　是故此处最吉祥

如此间夜摩天王佛神力故忆念过去诸等正觉以偈赞叹。如是十方一切世界。夜摩天王。各自忆念过去佛所所种善根。以偈赞叹亦复如是。尔时世尊升其宝殿宝莲华藏师子座上。结跏趺坐。尔时宝殿忽然广博。犹如夜摩天处。十方世界亦复如是

    大方广佛华严经夜摩天宫菩萨说偈品第十六

尔时十方各过十万佛刹尘数世界。有世界名无量慧。次名幢慧。次名地慧。次名胜慧。次名灯慧。次名金刚慧。次名安乐慧。次名日慧。次名清净慧。次名梵慧。其佛号常住眼。次号无量眼。次号真实眼。次号不动眼。次号天眼。次号清净眼。次号安谛眼。次号明相眼。次号无上眼。次号净光泽眼。其菩萨名功德林。次名慧林。次名胜林。次名无畏林。次名惭愧林。次名精进林。次名力成就林。次名坚固林。次名如来林。次名智林。此诸菩萨。各于其国佛所净修梵行。尔时佛神力故。彼诸菩萨。各与一佛世界尘数菩萨。来诣佛所恭敬礼拜。佛神力故随所来方。化作宝藏师子之座。结跏趺坐。充满十方。如此世界夜摩天上菩萨云集。十方世界亦复如是。尔时世尊从两足指。放百千亿妙色光明。普照十方一切世界。诸四天下菩提树下。夜摩天宫莲华藏宝师子座。如来神力及诸大会。皆悉显现。尔时功德林菩萨。承佛神力普观十方。以偈颂曰

  普放净光明　　遍照十方界
  一切悉睹佛　　通达无障碍
  佛处夜摩宫　　莲华宝座上
  一切诸世间　　奇特未曾有
  赞叹十如来　　众生皆悉闻
  世尊大众会　　一切无不见
  普于十方界　　演说无上法
  亦悉同名字　　如我菩萨众
  各从十方界　　来诣于此处
  彼诸上人等　　清净修梵行
  彼诸如来等　　亦各同名号
  见佛清净刹　　自在神通力
  一切见如来　　人中或道场
  又复见世尊　　处此夜摩宫
  一切诸世间　　莫能思议佛
  随彼众生愿　　一切皆悉见
  众生见如来　　无量自在力
  离世大仙人　　功德藏无量
  游行十方界　　一切无障碍
  一身为无量　　无量身为一
  功德甚深妙　　一切莫能测
  无著无所依　　清净如虚空

尔时慧林菩萨。承佛神力普观十方。以偈颂曰

  不可思议劫　　天人师难值
  离垢诸大人　　此会亦难遇
  悉皆一切智　　慧光靡不照
  演说深妙法　　饶益于众生
  一切诸世间　　常为痴冥蔽
  如来世灯明　　皆悉能除灭
  施戒忍精进　　禅定三昧藏
  修习深妙智　　普照于一切
  如来无与等　　何况有胜者
  颠倒取诸法　　是故不见佛
  自在神通力　　无量难思议
  无来亦无去　　说法度众生
  若有得闻见　　清净天人师
  永出诸恶道　　远离一切苦
  无量无数劫　　修习求菩提
  逮成等正觉　　广度诸群生
  不可思议劫　　供养无量佛
  若能解是义　　功德胜于彼
  虽施无量刹　　满中诸珍宝
  不能解此义　　终不成正觉

尔时胜林菩萨。承佛神力普观十方。以偈颂曰

  犹如春后月　　虚空无云曀
  日曜清净光　　一切无不照
  光明无限量　　世间无能数
  有眼尚不知　　何况盲冥者
  如来亦如是　　功德光无量
  无量无数劫　　莫能分别知
  光明无来处　　去亦无所至
  不生亦不灭　　空寂无所有
  未来一切法　　悉无有来者
  无生无现在　　是故无过去
  一切法无生　　亦复无有灭
  若能如是解　　斯人睹如来
  诸法无生故　　当知无所有
  如是分别知　　此人达深义
  诸法无自性　　一切无能知
  若能如是解　　是则无所解
  所言有生者　　当知由所生
  解彼真实性　　是则无疑惑
  一切诸所生　　正观亦如是
  菩萨如是观　　具足一切智

尔时无畏林菩萨。承佛神力普观十方。以偈颂曰

  此处无边际　　广大如法界
  一切无不至　　湛然不迁变
  若闻如是法　　恭敬信乐者
  永离三恶道　　一切诸难苦
  往诣诸世界　　无量不可数
  闻此甚深法　　忆念善受持
  闻受大仙人　　清净深妙法
  一向求菩提　　究竟无上道
  深信过去佛　　及彼诸佛法
  一切世间灯　　除灭众痴闇
  若有得闻佛　　无量自在力
  决定信向者　　具足人中雄
  若能一心信　　现在一切佛
  彼成等正觉　　开示无量义
  无量无数劫　　此法甚难值
  若有得闻者　　当知本愿力
  如是佛深法　　悉能善受持
  广为众生说　　是人难思议
  是故勤精进　　修行大庄严
  闻持是正法　　究竟得菩提

尔时惭愧林菩萨。承佛神力普观十方。以偈颂曰

  得闻真谛法　　殊特未曾有
  欢喜信乐者　　除灭众疑惑
  一切知见人　　自说深妙法
  佛慧靡不照　　是故难思议
  非从智慧生　　亦非无智生
  了达一切法　　除灭世间闇
  色法非色法　　此二不为一
  愚智亦如是　　其性各别异
  生死及涅槃　　此二悉虚妄
  愚智亦如是　　二俱无真实
  世界始成立　　无有败坏相
  愚智亦如是　　二俱相乖违
  菩萨初发心　　及以最后心
  愚智亦如是　　二俱不相应
  譬如六情识　　迭用互不同
  愚智亦如是　　究竟不和合
  譬如伽陀药　　消灭一切毒
  智慧亦如是　　除灭诸痴闇
  法王无上尊　　是胜莫能过
  所说皆真实　　以故难值遇

尔时精进林菩萨。承佛神力普观十方。以偈颂曰

  诸法无差别　　唯佛分别知
  一切无不达　　智慧到彼岸
  如金及金色　　其性无差别
  如是法非法　　其性无有异
  众生非众生　　二俱无真实
  如是法非法　　其性无所有
  譬如未来世　　无有过去相
  一切法如是　　无有真实相
  譬如过去法　　无有生起相
  诸法亦如是　　皆悉无有相
  涅槃不可取　　说时有二种
  诸法亦如是　　无有差别相
  譬如种种数　　皆悉是数法
  诸法亦如是　　其性无别异
  譬如数法十　　增一至无量
  皆悉是本数　　智慧故差别
  譬如诸世界　　劫烧有终败
  虚空无损减　　无师智亦然
  十方空无异　　众生起分别
  如是取如来　　虚妄不见佛

尔时力成就林菩萨。承佛神力普观十方。以偈颂曰

  一切众生类　　悉皆三世摄
  三世诸众生　　皆为五阴摄
  五阴从业起　　诸业因心起
  心法犹如幻　　众生亦如是
  世间非自作　　亦复非他作
  不知真实性　　生死轮常转
  所谓世间转　　皆悉是苦转
  众生不知故　　生死轮常转
  世间非世间　　二俱非真实
  众生愚痴故　　妄取诸法相
  三世五阴法　　说名为世间
  斯由虚妄有　　无则出世间
  何等是五阴　　五阴有何相
  不见五阴坏　　妄取谓常住
  五阴虚妄法　　真实无所有
  空寂不迁变　　究竟离众相
  世间既虚寂　　佛及法亦然
  斯等三种法　　其性无所有
  除灭诸颠倒　　明了见真实
  一切知见人　　常现在其前

尔时坚固林菩萨。承佛神力普观十方。以偈颂曰

  譬如地种性　　自性无所有
  一切佛自在　　其性亦如是
  一切诸世间　　咸共偁赞佛
  求彼偁赞法　　十方无来处
  众生虚妄取　　谓之为真实
  分别离众生　　业性不可得
  业性无所有　　众生身非真
  种种无量色　　亦复无来处
  一切诸形色　　业性难思议
  虽见无所有　　识性亦如是
  诸佛身如是　　不可得思议
  无量妙色身　　普现一切刹
  无量身非佛　　佛非无量身
  清净妙法身　　究竟度彼岸
  若有能得见　　清净妙法身
  是人于佛法　　其心无痴惑
  过去一切法　　观察等涅槃
  彼人见如来　　究竟常安住
  修习正忆念　　明了见正觉
  无相无所有　　是名法王子

尔时如来林菩萨。承佛神力普观十方。以偈颂曰

  譬如工画师　　分布诸彩色
  虚妄取异色　　四大无差别
  四大非彩色　　彩色非四大
  不离四大体　　而别有彩色
  心非彩画色　　彩画色非心
  离心无画色　　离画色无心
  彼心不常住　　无量难思议
  显现一切色　　各各不相知
  犹如工画师　　不能知画心
  当知一切法　　其性亦如是
  心如工画师　　画种种五阴
  一切世界中　　无法而不造
  如心佛亦尔　　如佛众生然
  心佛及众生　　是三无差别
  诸佛悉了知　　一切从心转
  若能如是解　　彼人见真佛
  心亦非是身　　身亦非是心
  作一切佛事　　自在未曾有
  若人欲求知　　三世一切佛
  应当如是观　　心造诸如来

尔时智林菩萨。承佛神力普观十方。以偈颂曰

  所取不可取　　所见不可见
  所闻不可闻　　所思不可思
  于有量无量　　不应作限量
  有量及无量　　二俱无所取
  不应说而说　　是为自欺诳
  己事不成就　　不能悦众生
  若有能赞叹　　无量诸如来
  不可思议劫　　功德不可尽
  犹如随意珠　　能现无量色
  此色非真色　　诸佛亦如是
  如虚空清净　　非色不可见
  能现一切色　　其性不可见
  如是大智人　　示现无量色
  非识之所识　　一切莫能睹
  虽闻如来声　　音声非如来
  离声复不知　　如来等正觉
  是处甚深妙　　若能分别知
  庄严无上道　　远离诸虚妄
  一切诸如来　　无有说佛法
  随其所应化　　而为演说法

大方广佛华严经卷第十大方广佛华严经卷第十一

        东晋天竺三藏佛驮跋陀罗译

    功德华聚菩萨十行品第十七之一

尔时功德林菩萨摩诃萨。承佛神力。入菩萨善伏三昧。入三昧已。十方各过万佛世界尘数刹外。各见万佛世界尘数诸佛。是诸如来皆号功德林。时彼诸佛。告功德林菩萨言。善哉善哉。佛子。乃能入是善伏三昧。十方各万佛刹尘数诸佛。加汝神力故。能入是善伏三昧。卢舍那佛本愿力故。威神力故。诸菩萨善根力故。欲令汝广说甚深法故。长养一切智故。分别一切众生性故。离一切障碍入无障碍境界故。成就一切方便故。成就一切种智故。觉悟一切法故。善知诸根故。闻持一切法故。所谓菩萨十行。佛子。当承佛神力广说妙法。时彼诸佛。即与功德林菩萨无障碍法。与安住法。与无师法。与无痴法。与不杂乱法。与清净法。与无量法。与最胜法。与无垢法。与不退法。何以故。彼三昧力故。尔时诸佛各申右手。摩功德林菩萨顶。摩其顶已。即从定起。告众菩萨言。诸佛子。菩萨行业不可思议。广大如法界究竟如虚空。何以故。菩萨摩诃萨。学三世诸佛所行法故。佛子何等为菩萨摩诃萨行。菩萨有十行。三世诸佛之所宣说。何等为十。一者欢喜行。二者饶益行。三者无恚恨行。四者无尽行。五者离痴乱行。六者善现行。七者无著行。八者尊重行。九者善法行。十者真实行。是为十行。佛子。何等为菩萨摩诃萨欢喜行。此菩萨为大施主。悉能舍离一切所有。等心惠施一切众生。施已无悔。不望果报不求名誉。不求生胜处不求利养。但欲救护一切众生。欲摄取一切众生。欲饶益一切众生。欲学一切诸佛本行。欲正忆念诸佛本行。欲得清净诸佛本行。欲得受持诸佛本行。欲显现诸佛本行。欲广说诸佛本行。欲令一切离苦得乐。是名菩萨摩诃萨欢喜行。菩萨修欢喜行时。一切众生欢喜爱敬。随诸方土有贫穷处。菩萨愿往生彼。豪贵大富财宝无尽。于念念中有无量无边无数众生。诣菩萨所。白言。仁者。我等贫窭靡所资赡。愿垂慈救得济生命。菩萨念念应其所须。悉令满足靡不欢喜。菩萨不以求索烦重而生忧恼。但发无上大慈悲心施无厌足。欲令常来。来已称庆倍复欢喜作如是念。我得善利。此等众生。是我福田是我善友。不请不求自来教诲。发起我心修行佛道。我今应当如是修学。普令众生悉得欢喜。我于三世所修功德。愿速成就清净法身。神力自在。悉令众生随其所须皆得欢喜。以此功德。令诸众生悉成正觉。度脱无量众生。悉令究竟无余涅槃。我当先令一切众生满足诸愿。然后我当成等正觉。离我想众生想。我所想寿命想。种种想福伽罗想作者想。法界众生界空无差别。离欲法非真实法。无所有法非坚固法。非恃怙法非所作法。菩萨如是观时。不见施者不见受者。不见财物不见福田。不见业不见报。不见果不见大果不见小果。菩萨观察三世。发如是念。哀哉众生。为愚痴所覆烦恼所缠。常流生死。轮回苦海。于不坚固法不得坚固。我当尽学诸佛所学饶益众生。成等正觉开悟一切皆令清净。随顺寂灭观三世法。是名菩萨摩诃萨初欢喜行

佛子。何等为菩萨摩诃萨第二饶益行。此菩萨持戒清净。于色声香味触法。心无染着。广为众生说无染法。不求生于人天胜处尊贵之家。不求利养不求端正不求帝王。但坚持净戒。作如是念。我持净戒。离一切缠烦恼炽火忧悲苦恼。不负众生。诸佛欢喜。究竟成就无上菩提。菩萨如是持净戒时。于一日中。若有无量无数阿僧祇诸大魔王。一一魔王。各将无量无数阿僧祇诸天女众。皆悉端正颜貌姝妙。姿容妖艳倾惑人心。又复赍持一切乐具。欲来惑乱菩萨道意。尔时菩萨作如是念。此五欲者是障道法。乃能障碍无上菩提。是故菩萨。乃至不生一念欲心。心净如佛。除其方便教化众生。内不离菩萨一切种智。坚固正念。不为五欲因缘故。起一恶念恼乱众生。宁舍身命不加恶于人。若加恶于人无有是处。菩萨自见佛已来。未曾有心起一欲想。何况从事。若或从事无有是处。尔时菩萨作如是念。众生长夜在生死中。忆念五欲贪着五欲。爱乐五欲。心常流转五欲境界。永没五欲莫之能出。我今应当作如是学。令诸魔王天女眷属及一切众生立无上戒。立净戒已。又教令得不退转地一切种智成等正觉。乃至究竟无余涅槃。何以故。此是我业一切诸佛皆如是学。离诸非行计我无知。观一切佛平等深法。得一切智。为众生说法。断除颠倒。不离众生而有颠倒。不离颠倒而有众生。颠倒内无众生。众生内无颠倒。颠倒非众生。众生非颠倒。颠倒非内法。颠倒非外法。众生非内法。众生非外法。一切诸法但是虚妄无有真实。须臾不住无有坚固。犹如幻化欺诳愚夫。悟一切法如梦如电。如是解者。能达生死究竟菩提。未度者度未脱者脱。未调伏者令得调伏。未寂静者令得寂静。未安隐者令得安隐。未离垢者令得离垢。未清净者令得清净。未涅槃者令得涅槃。未快乐者令得快乐。我当舍离世间众事。令诸如来皆悉欢喜。具足成就一切佛法。安住无上最胜法中。平等正观一切众生。分别了知一切诸法。远离诸恶永舍虚妄。除灭一切烦恼习气。成就出要胜妙方便。悉得无量无边辩才。成就甚深空寂智慧。是名菩萨摩诃萨第二饶益行

佛子。何等为菩萨摩诃萨第三无恚恨行。此菩萨常能修习忍辱之法。谦卑恭敬和颜爱语。不自害不害他亦不俱害。不自举不举他亦不两举。不自是不是他亦不两是。不自赞叹。但作是念。我当常为众生说法离一切恶。断贪恚痴憍慢乱心悭嫉谄曲。以大忍法而安立之。菩萨成就如是清净忍法。设有无量无数众生。一一众生。各有无量无数眷属。一一众生。各有无量无数化头。头有无量阿僧祇舌。舌出无量无数恶声。声出无量无数恶骂音辞。鄙秽毁辱菩萨。又此众生。各有无量阿僧祇手。手执无量无数刀杖。捶击摧辱毁害菩萨。乃至无量阿僧祇劫未曾休息。菩萨遭此楚毒之时。作如是念。我因是苦。若生恚心。则自不调伏自不守护。自不明了自不寂静。自不修定自不真实。自爱其身。何能令彼生欢喜心而得度脱。菩萨作是思惟。因身心故。于无量劫受诸苦恼。是故重自劝励。令心欢喜善自调摄。何以故。我当安住无上法故。欲令众生亦得此法。复更思惟。此身空寂无我我所。无真实性空无有二。若苦若乐皆无所有。诸法空故。我当解了广为人说。是故我今虽遭苦毒应当忍受。为愍伤众生故。饶益众生故。安隐众生故。摄取众生故。不舍众生故。欲令众生得不退转究竟成就无上菩提。佛所行法我当修行。是名菩萨摩诃萨第三无恚恨行

佛子。何等为菩萨摩诃萨第四无尽行。此菩萨勤修精进。胜精进最胜精进。第一精进大精进微妙精进。上精进无上精进。无等精进无等等精进。彼菩萨。不为贪欲所乱。不为嗔恚愚痴憍慢恼害悭嫉嫌恨谄曲无惭无愧之所恼乱。菩萨复作是念。我不欲恼诸众生。乃至不欲恼一众生故。勤修精进。但欲舍离诸烦恼故。修行精进。欲害一切结故。修行精进。欲离一切习气故。修行精进。欲悉分别一切众生故。修行精进。欲知一切众生死此生彼故。修行精进。欲知一切众生烦恼习故。修行精进。欲知一切众生种种希望故。修行精进。欲知一切众生诸境界故。修行精进。欲知一切众生诸根故。修行精进。欲知一切众生心心所行故。修行精进。欲知一切法境界故。修行精进。欲知诸佛实法故。修行精进。欲知诸佛平等法故。修行精进。欲以善方便知三世平等故。修行精进。欲知清净平等法故。修行精进。欲得一切诸佛法故。修行精进。欲以一方便门知一切佛法故。修行精进。欲知诸佛无量无边不可思议故。修行精进。欲知诸佛大智慧善方便故。修行精进。欲知一切佛法广为众生句句分别故。修行精进。菩萨成就如是精进。若有人言。无量无数阿僧祇世界众生。汝能为此一一众生故。于无量无数阿僧祇劫。具受无择大地狱苦。令彼众生究竟涅槃。复有无量无数阿僧祇佛。出兴于世。令无量无数阿僧祇众生受种种乐。汝犹具受大地狱苦。然后汝当成阿耨多罗三藐三菩提。菩萨答言。我悉能为尔所世界一一众生受地狱苦。诸佛出世众生受乐。我亦受苦。然后我当成无上道。复有人言。汝若能以一毛渧无量无边阿僧祇诸大海水皆悉令尽。无量无边阿僧祇世界。末为微尘。悉知其数。如是念念次第常不废忘菩提之心。菩萨若闻是语。不退不悔欢喜踊跃。勤修精进作如是念。我得善利。因我故令无量无边阿僧祇世界众生永离众苦。菩萨复作是念。我当代一切众生受一切苦。普令众生离一切苦。悉皆究竟无余涅槃。然后我当成无上道。是名菩萨摩诃萨第四无尽行

佛子。何等为菩萨摩诃萨第五离痴乱行。此菩萨成就第一正念。未曾散乱。坚固不坏。第一最胜清净无量。舍离痴冥分别正念。善能受持世间出世间经论。色法非色法经论。受想行识经论。无有痴乱。死此生彼无有痴乱。处胎出胎无有痴乱。住菩提心无有痴乱。亲近善知识无有痴乱。学诸佛法无有痴乱。觉诸魔事无有痴乱。远离魔事无有痴乱。于无量劫修菩萨行。菩萨成就如是等无量无数坚固正念。于无量无数阿僧祇劫。从诸佛菩萨善知识所闻受正法。所谓甚深法。微妙法。庄严法。种种庄严法。种种名味句身法。庄严菩萨法。庄严诸佛无上法。正希望清净法。不染一切世间法。分别一切世间法。广法无量法。舍离痴暗分别世间法。共法不共法。菩萨智境界法。一切智自在法。菩萨闻此法已。于无量无边阿僧祇劫。未曾退忘。何以故。菩萨摩诃萨。本无量劫修道行时。未曾恼乱众生。正念三昧不断正法不断善根不断智慧故。此菩萨无量种声不能娆乱。所谓高大声。恼乱声。令人恐怖声。微妙声。不可爱声。散乱六根声。菩萨闻如是等无量无数好恶诸声。于正念不乱。三昧不乱。境界不乱。入微妙法不乱。菩萨行不乱。修习菩提心不乱。念佛三昧不乱。观察真实法不乱。教化众生智不乱。成就众生不乱。安立众生清净智不乱。观察甚深义不乱。不行恶业故无恶业障。不行烦恼故无烦恼障。不行不恭敬故无不恭敬障。不行谤法故无谤法障。如是等无量种声。一一音声。充满十方无量无边阿僧祇世界。于无量无边阿僧祇劫。未曾断绝悉能坏乱众生诸根。令其发狂而不能乱此菩萨甚深三昧。菩萨于三昧中。思惟分别一切音声生住灭相。善分别知生住灭性。亦善观察诸闻声者。闻好恶声心无憎爱正念不乱。于彼诸声善取其相而不染着。知一切声皆无所有非真实性。无有造者亦无本际。与法性等无有差别。是菩萨。成就寂静身口意行。不复退转。安住诸禅三昧正受。悟一切法智慧成就。得离一切音声三昧。阿僧祇三昧门以为眷属。长养大悲。于念念中。能得无量阿僧祇三昧。究竟成就一切种智。菩萨闻此能坏诸根大恶音声已。作如是念。我当令一切众生安住清净正念。于一切智得不退转。究竟成就无余涅槃。是名菩萨摩诃萨第五离痴乱行

佛子。何等为菩萨摩诃萨第六善现行。此菩萨。成就寂灭身口意业。无所有无所示现。身口意业。无缚无脱。身口意业。无缚无脱。诸所示现。无所依无所住。随心住。无量心性等一切法性。等无性相。示现无相相。甚深无底。如如性离业报。善方便出生离生。不生不灭。寂灭涅槃等。非有说有。语言道断。离一切世间。无所依住。长养菩萨所起善根。入离虚妄无缚无著法门。入真实法门。入离世间法门。分别一切世间法。菩萨作如是念。一切众生无性为性。一切诸法无为为性。一切佛刹无相为相。究竟三世皆悉无性。言语道断。于一切法而无所依。菩萨解如是等诸甚深法。解一切世间悉皆寂灭。解一切诸佛甚深妙法。解佛法世间法等无差别。世间法入佛法。佛法入世间法。佛法世间法而不杂乱。世间法不坏佛法。真实法界不可破坏。安住三世平等正法。亦不舍菩提心。不舍教化众生心。增长大慈大悲心。悉欲救度一切众生。菩萨作是念。我不成就众生。谁当成就。我不调伏众生。谁当调伏。我不寂静众生谁当寂静。我不令众生欢喜谁当令欢喜。我不清净众生谁当令清净。菩萨复作是念。我以解了此甚深法。见诸众生受大苦恼趣危险径。为诸烦恼之所缠缚。如重病人常被苦痛。恩爱系缚在生死狱。常不离地狱饿鬼畜生阎罗王处。不能永灭无量苦聚。不离三障。常处愚痴暗。不见真实明。受无穷生死不得解脱道。轮回八难。愚痴所病诸垢所染。没在无量深烦恼海。邪见所惑不睹正道。菩萨作如是观察。众生若未成熟。而舍取正觉。是所不应。我当先教化众生。于无量劫修菩萨行。未成熟者教令成熟。未调伏者教令调伏。诸未度者教令得度。是菩萨住此行时。诸天世人魔王释梵沙门婆罗门诸天乾闼婆等。见此菩萨欢喜敬仰。若有众生。恭敬供养尊重礼拜。乃至见闻皆悉不虚。毕定究竟阿耨多罗三藐三菩提。是名菩萨摩诃萨第六善现行

佛子。何等为菩萨摩诃萨第七无著行。此菩萨以无著心。于念念中。能观察阿僧祇世界。严净阿僧祇佛刹。于诸佛刹心无染着。往诣阿僧祇诸如来所。礼拜恭敬。以阿僧祇华香涂香末香。众宝华鬘天衣杂宝。宝盖幢幡诸庄严具。各阿僧祇以用供养心无所著。阿僧祇诸方便行而无所行。阿僧祇思无思法住。于念念中。见无量诸佛。于诸佛所心无所著。于佛相好心无所著。于佛光明心无所著。于诸佛刹心无所著。闻佛说法心无所著。于十方世界心无所著。于如来众心无所著。于菩萨众心无所著。闻法欢喜心无所著。正心增广摄意不乱。行菩萨行不着佛法。此菩萨摩诃萨。于十方刹一一佛所。无量无边阿僧祇劫。恭敬礼拜供养心无厌足。见佛闻法心无所著。见诸如来菩萨大众。以为庄严心无所著。见不净刹心不憎恶。何以故。菩萨摩诃萨。寂灭平等观诸法故。诸法无垢无净。无暗无明。无分别无不分别。无虚妄无真实。无安隐无危险。无正道无邪道。菩萨如是观真实法性。入众生性。教化调伏成熟众生。于彼众生心无所著。受持诸法。而于诸法心无所著。不舍菩萨心。而住佛所住。于佛所住心无所著。入种种语言道。于语言道心无所著。入众生道。于众生道心无所著。分别诸三昧正受。皆悉能入心无所著。往诣无量无边不可说诸佛国土。见彼佛国心无所著。若去佛国心无余恋。菩萨摩诃萨。于诸佛国。以无贪着心解佛实教。于无上道而无障碍。于佛正教已得安立。具足菩萨行。安住菩萨心。成就菩萨寂灭解脱不念不着菩萨所行。住菩萨净道受真实记。得授记已作如是念。凡夫愚痴。不知真谛不见真谛。暗钝无信心不真实。常行染着流转生死。不见诸佛离善知识。离于正道迷惑邪见。不求调御师。不敬十力王。不知菩萨恩。亲近恶知识。闻诸法空心大恐怖。不正思惟诽谤正法。弃舍正道好从邪径。入魔罗网远离诸佛。常着诸有受种种苦。尔时菩萨。见彼众生受诸苦已。增长大悲观诸善根心无所著。尔时菩萨。作如是念。我当为十方一一众生故。住无量无边阿僧祇劫。成熟众生心无疲厌。常共止住。不欲舍离去如毫端。以一毫端。悉遍量度十方世界。为一众生故。于一一毫端处。各住无量无边阿僧祇劫。如为一众生。为一切众生亦复如是以此大悲心。念念次第未曾断绝。而于众生心无所著。于一一毫端处。具足修习尽过去。未来际诸菩萨行。不着身不着法。不着念不着愿。不着三昧不着行。不着寂静不着境界。不着教化成熟众生。不着入深法界。何以故。菩萨如是观察。一切法界如幻。诸佛法如电。菩萨行如梦。所闻法如响。一切世界如化。业报所起如摩[少/(兔-、)]摩化身。知一切众生犹如画像。种种异形皆由心画。所说诸法皆如实际。于一念中。遍满十方修菩萨行。广大如法界。究竟如虚空。于一念中。悉知诸佛决定方便。了知心相回转迅速。而于此心无所染着。菩萨如是观察无我。见佛化度一切众生。于佛法中得无量喜。起大慈悲救护一切。心无忧恼得欢喜愿。未成熟者当令成熟。未调伏者当令调伏。远离世间。而能随顺一切世间。若闻诸方国土众生音声。众生诸业众生施设。众生和合众生流转。众生诸行众生境界。众生诸地众生兴起。我当乘大愿之力普至彼处。终不舍弘誓。教化众生。乃至不起一念染着。所以者何。以无所著故。自利利彼清净满足。是名菩萨摩诃萨第七无著行

佛子。何等为菩萨摩诃萨第八尊重行。此菩萨成就尊重善根。不坏善根。最胜善根。不思议善根。无尽善根。不退善根。无比善根。寂静善根。一切佛法善根。此菩萨修习行时。心常爱乐诸佛妙法。一向专求无上菩提。未曾暂舍菩萨大愿。于无量劫行菩萨道。不计众苦而生忧恼。一切众魔所不能坏。一切诸佛悉共护念。常行菩萨诸清净行。精勤修习一切菩萨无量苦行未曾懈倦。得不退转大乘弘愿。此菩萨安住尊重菩萨行已。于念念中能转阿僧祇劫生死苦难。长养菩萨无量大愿。若有众生。恭敬供养乃至见闻。斯等皆得住不退转。决定究竟无上菩提。彼菩萨观察众生。了达非有而不舍一切。譬如河水。不至彼岸不来此岸。不断中流。能度众生于彼此岸。以流通故。菩萨摩诃萨亦复如是。不趣生死不趣涅槃。亦复不住生死中流。而能济度此岸群生。到于彼岸。安隐无畏无忧恼处。于众生数心无所著。不离一众生着多众生。不离多众生着一众生。不增众生界。不损众生界。不生众生界。不灭众生界。不尽众生界。不长众生界。不虚众生界。不二众生界。何以故。菩萨深解众生界如法界。众生界法界无有二。无二法中无增无损。无生无灭。法性真实无来无去。无所猗着不作二相。何以故。菩萨解一切法界无二相故。菩萨如是以善方便。解深法界住无相住。清净妙相庄严其身。善能分别一切诸相。决定究竟到于彼岸。悉分别知众生之数。普能现身一切佛刹。于诸佛刹心无所著。深入佛法亦无所染。分别义味广为人说。于一切法离诸欲际。而不断菩萨道。不舍菩萨行。行无尽功德。入清净法界。譬如火珠出火不可穷尽。如是菩萨诸功德藏不可穷尽。教化众生亦不可尽。而菩萨摩诃萨。非究竟非不究竟。非离取非不离取。非依非无依。非世间法非佛法。非凡夫非得果。如是菩萨成就尊重心。修习菩萨行不教声闻辟支佛乘。不教佛法不教世间法。不教众生。不坏众生。不教正道不坏正道。不教垢不教净。何以故。菩萨解了诸法无垢无净。知一切法无受无转。亦无有退。行是寂灭甚深法时。亦不生念。我今行此法已行此法当行此法。未曾生念。有阴界入内世间外世间内外世间一切大愿诸波罗蜜。何以故。一切法中。无向声闻缘觉菩萨佛乘。亦复无向诸凡夫界。亦复无向垢净生死及涅槃界。何以故。诸法无二无不二故。譬如虚空。求之十方无有差别。非无虚空。菩萨如是观一切法悉无差别。非不究竟成等正觉。彼最真实不违正行。普能示现菩萨所行。而不舍离无量大愿。调伏众生转大法轮。不坏因果不违寂灭。平等观法。此菩萨悉与三世诸如来等。不断佛性不坏正法。兴隆正法辩才无尽。于诸法中心无所著。安住法堂分别深法住无所畏。不舍佛住不违世法。普现世间。等于世间心无所著。菩萨如是成就尊重智慧。修菩萨行。令一切众生永离世间恶道诸难。教化成就安置三世诸佛法中坚固不动。如是教已。复作是念。一切众生不知恩义更相杀害。邪见增盛迷惑正道。烦恼充满痴冥所覆。设有善知识充满世间。皆悉明达智慧具足者。我不为此等修菩萨行。何以故。我于善恶人所。不求利养不徇名誉。乃至一缕及一爱言。于无量劫行菩萨道。不生一念自求己安。但欲调伏一切众生。净一切众生。度一切众生。何以故。一切诸佛法如是故。不求利养不计人恶。常应等心行菩萨道。怨亲等观而无差别。欲令究竟至于彼岸。具足成就无上菩提。是名菩萨摩诃萨第八尊重行

佛子。何等为菩萨摩诃萨第九善法行。此菩萨为诸天人沙门婆罗门乾闼婆等一切众生。作清凉法地。守护正法。佛种不绝。得清净陀罗尼故。说法无障碍。得义陀罗尼故。义辩不可尽。得法陀罗尼故。法辩不可尽。得正语陀罗尼故。辞辩不可尽。得无障碍陀罗尼故。说义味不可尽。得佛甘露灌顶陀罗尼故。令众生欢喜辩不可尽。得自觉悟陀罗尼故。同辩不可尽。入同辩陀罗尼故。说种种义名味句身不可尽。得正语陀罗尼故。无量辩不可尽。得无量赞叹陀罗尼故。于三千大千世界。变身如佛妙音具足。于一切法无所障碍而作佛事。随所应化随所解音随众生根。以广长舌清净音声。随时说法不违大悲。随其所应。于一一言出无量音。皆令欢喜。设有众生。悉知无量不可计阿僧祇诸语言法。知无量业知无量报。如是等无量无数阿僧祇众生。充满无量无边阿僧祇世界。与菩萨为眷属。菩萨处此会中。出一法言。悉令此等众生皆得开解。有如是等无量无边阿僧祇诸大众。与菩萨为眷属。亦复如是。尔时菩萨复作是念。设一毛端处于一念中。有无量无边阿僧祇大众来会。如是念念次第。尽过去未来一切诸劫。大众来会犹故不尽。彼诸大众。言声不同所问各异。菩萨闻如是等一切问难心无所畏。而作是念。设令一切众生悉来问难。犹以一言决其疑网皆令欢喜。菩萨说法言不虚妄。于一一言。有无量无边智慧庄严。成就无边诸功德藏。慧光普照一切诸法。具足成就一切种智。此菩萨安住善法行已。能自清净。亦能饶益一切众生。如此三千大千世界。乃至无量无边不可称数诸世界中。自化其身为真金色。妙音具足。于一切法无所障碍而作佛事。以无量无边清净法门化度众生。佛子。此菩萨摩诃萨。有十种身。入无量无边法界身。除灭一切世间故。未来身。一切趣生故。不生身。深乐不生平等法故。不灭身。一切诸法言语断故。不实身。如如真实故。离痴妄身。随应化故。无来去身。离死此生彼故。不坏身。法界性无坏故。一相身。三世语言道断故。无相身。善分别诸法相故。菩萨摩诃萨。成就如是十种身。能为一切众生作舍。长养善根故。为一切众生救护。与大无畏故。为一切众生归依。令大安隐住故。为一切众生尊导。开示无上道门故。为一切众生师方便。令入真实法故。为一切众生灯。令见业报故。为一切众生明。得甚深法故。为一切众生炬。令离愚痴解真法故。为一切众生光。令得明地故。为一切众生趣趣灯。显现如来自在力故。是名菩萨摩诃萨第九善法行。此菩萨摩诃萨。安住善法行已。为一切众生。作清凉法池。得佛甚深诸法底故

佛子。何等为菩萨摩诃萨真实行。此菩萨成就第一诚谛之语。如说能行如行能说。此菩萨学三世诸佛真实语。入三世诸佛性。与三世诸佛善根等。此菩萨成就如是等一切善根。学三世诸佛无二语。随顺如来一切智慧。此菩萨成就众生是处非处智。众生去来现在一切业报智。众生诸根具足不具足智。众生种种性智。众生种种欲智。众生一切至处道智。一切禅定解脱三昧正受垢净起时非时转智。过去一切世界成坏智。无障碍天眼智。漏尽智。而不舍一切菩萨所行。何以故。欲令一切众生调伏清净故。菩萨复作是念。我见众生受无量苦。若未度此等先成正觉是所不应。我当满足大愿然后成佛。令一切众生志求菩提究竟无余涅槃。何以故。非众生请我发菩提心行菩萨行。我自发心普为众生。欲令究竟得一切种智。是故。我于一切最为殊胜。不着众生故。我于一切得为最上。调御众生故。我离一切闇。解无众生际故。我得所应得本愿具足故。我善变化。菩萨功德庄严故。我有善摄取。三世诸佛所护念故。此菩萨摩诃萨。不舍本愿故。得入无上智慧庄严。随一切众生所应悉能化度。随其本愿悉满足已。得一切法自在智慧。令一切众生皆得清净。于念念中。悉能遍游十方世界。于念念中。悉能往诣无量佛国。于念念中。悉见无量无数诸佛及庄严刹。示现如来自在神力。究竟法界虚空界等。其身无量随应悉现。无量无碍而无所依。于自身中普现佛刹。一切众生一切诸法。三世诸佛皆悉显现。此菩萨知众生种种想。种种欲。业报清净。随其所应为现其身。而调伏之。解一切法如幻如化如电众生如梦。此菩萨义身味身不可穷尽。清净正念决定了知一切诸法。入诸三昧无上智慧。寂静观察不二之地。一切众生皆依二法。菩萨摩诃萨。住大悲心修习如是诸深妙法。寂静究竟得佛十力。入因陀罗网法界自在。成就如来无碍解脱。人中雄猛大师子吼得无所畏。为法转轮王。能转无碍清净法轮。成就智慧解脱。了知一切世间所行。绝生死回流。入智慧大海。悉能饶益一切众生。护持三世诸佛正法。穷尽诸佛方便大海。是名菩萨摩诃萨第十真实行。此菩萨安住真实行已。能令一切天人八部无量众生清净欢喜

大方广佛华严经卷第十一大方广佛华严经卷第十二

        东晋天竺三藏佛驮跋陀罗译

    功德华聚菩萨十行品第十七之二

尔时佛神力故。十方世界六种震动。如来威神法应如是雨天华云。雨天香云。雨天末香云。雨天鬘云。雨天衣云。雨天宝云。雨天庄严云雨。又自然出天妓乐音。天妙光明普照一切。演出诸天微妙音声。如此四天下夜摩天宫说十行法。佛神力故。十方世界亦复如是。尔时十方各过十万佛刹尘数世界。有十万佛刹尘数菩萨。充满十方来诣此土。到已。语功德林菩萨言。善哉佛子。乃能演说诸菩萨行。我等诸来菩萨。皆同一字名功德林。我等世界皆名功德幢。佛同号普功德。我等佛所亦说十行。名味句身次第义味众会眷属亦复如是。不增不减。是故佛子。我等承佛神力。来诣此土。为汝作证。如此四天下夜摩天宫宝庄严殿说十行法我来为证。十方世界亦复如是。尔时功德林菩萨。承佛神力。普观十方一切法界及诸眷属。欲令佛种永不断绝。欲令菩萨种性清净。欲令菩萨愿种不转。欲令行种不断。欲令摄取三世佛种。欲分别说众生善根种。欲观察一切众生时根。欲乐垢净心所行种。欲普照一切诸佛菩萨种。以偈颂曰

  敬心顶礼十力尊　　清净离垢慧无碍
  境界深远无等伦　　其道清净如虚空
  人中最胜无障碍　　功德无量无所畏
  智慧无二无等等　　一切所行皆清净
  十方现在诸导师　　解真实义无所畏
  无等功德离诸恶　　彼速究竟无上道
  一切如来人中雄　　先已具发大慈悲
  游心清净法界中　　所行饶益诸群生
  十方三世无与等　　自然正觉灭痴冥
  一切佛法悉平等　　彼之功德不可坏
  十方一切世界中　　悉得睹见诸如来
  于诸如来无虚妄　　彼人所行不退转
  若见清净真法界　　甚深微妙第一义
  一切痴妄莫能惑　　彼行能成功德藏
  方便善知众生类　　入于真实妙法界
  自然觉悟不由他　　彼人所行如虚空
  无量无边诸世界　　观察究竟悉寂灭
  一切诸法无障碍　　彼人所行胜牟尼
  具足坚固不可转　　成就尊重最胜法
  清净愿满到彼岸　　谛听菩萨诸所行
  无量无边一切地　　智慧明达无障碍
  甚深微妙为境界　　是名无畏论师行
  句句广分别　　深入妙智慧
  真实解诸法　　彼修大牟尼
  远离一切恶　　常能利众生
  彼人功德藏　　等诸调御师
  普于诸群生　　常施以无畏
  清净无染着　　所行无伦比
  意净无所著　　寂静无口过
  具足妙功德　　彼修最胜行
  究竟度深义　　功德定无尽
  彼修不死行　　诸佛常护念
  离我嗔恚心　　妙音满十方
  安住正法教　　所行无可谕
  布施到彼岸　　百福自庄严
  彼慧最第一　　能令众欢喜
  善入深智地　　安住心不动
  彼行如金刚　　坚固不可沮
  悉入诸法界　　随顺到彼岸
  究竟得自在　　法日之所行
  无等等牟尼　　修习不二法
  心常乐寂静　　智慧无障碍
  细微世界中　　容受大世界
  境界无不了　　智慧山王行
  普于诸世间　　心净无所著
  持戒到彼岸　　净行之所行
  智慧不可量　　虚空法界等
  深入具足智　　是胜金刚行
  智慧悉充满　　三世诸法界
  心常无懈怠　　入于最胜境
  一切所至道　　分别十力法
  身行无障碍　　胜智之所行
  一切十方界　　无量众生类
  菩萨悉救护　　离痴之所行
  修习诸佛法　　精勤无懈怠
  普令世间净　　大龙之所行
  悉知众生根　　究竟种种欲
  了达无量性　　平等之所行
  普于十方界　　久受无量苦
  其心无忧恼　　欢喜之所行
  放诸光明网　　普照诸世间
  具足智慧明　　善修慧所行
  皆悉能震动　　十方无量界
  常能利一切　　不令生恐怖
  善解语言法　　分别到彼岸
  离垢智慧明　　不动之所行
  善解俯仰国　　分别到彼岸
  成就无尽地　　最胜慧所行
  无量诸功德　　常行求菩提
  到彼功德岸　　大称无尽行
  无上大论师　　最胜师子吼
  令众悉清净　　离垢之所行
  佛甘露灌顶　　授以法王记
  究竟方便法　　大心之所行
  分别一切众　　其心无染着
  决定持法藏　　法王之所行
  一一语言中　　能出无量音
  众生各各解　　无碍慧所行
  究竟语言法　　分别悉了知
  远离诸虚妄　　真实见所行
  安住法海印　　善印一切法
  了法无实相　　方便身所行
  能于一一刹　　无量无数劫
  穷尽诸劫行　　其心无忧厌
  无数诸如来　　名号各不同
  见之一毛孔　　善修之所行
  如一毛端处　　普见无量佛
  一切诸世界　　见佛亦如是
  无量无数劫　　能作一念顷
  非长亦非短　　解脱人所行
  见者悉不虚　　所修皆真实
  业行不可坏　　最胜之所行
  无量无数劫　　观佛无厌足
  能令众欢喜　　无碍慧所行
  无量无数劫　　观察众生界
  众生非众生　　坚固士所行
  具足智慧藏　　清凉功德池
  饶益一切众　　第一人所行
  法界无边际　　无量如虚空
  语言无所著　　无畏论师行
  于一三昧中　　入无量三昧
  升彼无上堂　　净月论师行
  究竟忍彼岸　　堪忍寂灭法
  远离嗔恚心　　无量智所行
  不离一世界　　不起一坐处
  普现十方刹　　无量身所行
  无量诸佛刹　　能入一世界
  佛刹不增减　　不思议所行
  分别处非处　　审谛入诸力
  无上力成就　　第一力所行
  去来现在世　　一切诸业报
  智慧不退转　　明智之所行
  善知时非时　　调伏一切众
  教化不失时　　善知时所行
  身行悉皆善　　口意行亦然
  一切无所著　　净智意所行
  智慧善分别　　法辩无穷尽
  境界等如实　　如来之所行
  无碍功德藏　　喜乐总持门
  深入诸法界　　随入之所行
  悉与三世佛　　等心无异想
  一相无差别　　无碍境界行
  深入智慧海　　除灭诸痴闇
  能与清净眼　　净眼之所行
  一切诸导师　　常行不二法
  神通力自在　　具足行所行
  十方佛刹中　　普雨妙法雨
  令众解实义　　法云之所行
  普于诸佛所　　逮得坚固信
  一切智解脱　　所学悉究竟
  彼于一念中　　悉知众生心
  究竟解心性　　无性性所行
  不思议世界　　变化无量身
  无等遍游行　　诸行中无比
  无量世界中　　现在诸如来
  菩萨摩诃萨　　常现彼佛前
  菩萨入三昧　　众生见一身
  菩萨出三昧　　众见无量身
  所行甚深妙　　未曾有口过
  悦乐心无量　　令众悉欢喜
  逮得无著智　　分别知诸根
  其心无所染　　无上调伏行
  方便分别法　　于法得自在
  一切世界中　　常作诸佛事
  菩萨微妙行　　所行如虚空
  何人得闻此　　其心不欣悦
  彼智无与等　　慧眼见一切
  方便无伦匹　　无等智所行
  无尽妙功德　　能灭一切恶
  到彼清净岸　　无比之所行
  成就庄严法　　安住不退转
  度脱无量众　　而无众生想
  所修无诤行　　一切智微妙
  正法化众生　　净眼之所行
  恭敬一切佛　　具足究竟慧
  成就无所畏　　方便智所行
  普能入一切　　世界及诸法
  亦入群生类　　度脱无量众
  遍于十方界　　击无上法鼓
  常施无量法　　不死之所行
  一身跏趺坐　　充满无量刹
  众生不迫迮　　清净法身力
  一味一义中　　分别无量义
  演说无穷尽　　无边慧所行
  修习佛解脱　　智慧无障碍
  成就无所畏　　无量方便德
  了诸世界海　　一切佛刹海
  法海智慧海　　度脱众生海
  或有见菩萨　　入胎及出生
  或见成正觉　　无量功德行
  处处佛刹中　　示现般涅槃
  真实无涅槃　　无畏师常住
  金刚身无异　　随应现众生
  真实无差别　　一身行所行
  平等法界一　　具足无量义
  常乐观三世　　一相无相法
  到彼诸持岸　　正法安众生
  逮得诸佛持　　最胜之所行
  无染妙法身　　慧眼清净耳
  是悉无障碍　　无碍之所行
  究竟诸神通　　具足深智慧
  智慧最殊胜　　方便智所行
  心定未曾乱　　智慧不可量
  境界无不照　　一切见所行
  到彼功德岸　　度脱无量众
  其心无疲厌　　常修之所行
  一切知见人　　在诸佛家生
  普于三世佛　　法中而化生
  语言法成就　　摧伏诸论师
  究竟无量行　　随入佛菩提
  能放一光明　　普照无量刹
  世间大明曜　　除灭一切暗
  随其所应见　　为现如来身
  调伏群生类　　严净一切刹
  菩萨行无量　　一切莫能知
  示现一切行　　欲度众生故
  无量不可数　　众生法界等
  无数劫赞叹　　菩萨德无尽
  菩萨德无量　　究竟一切德
  诸佛无量劫　　叹此德无尽
  何况世间人　　声闻及缘觉
  无量劫赞叹　　而能得穷尽

    大方广佛华严经菩萨十无尽藏品第十八

尔时功德林菩萨摩诃萨。复告诸菩萨言。佛子。菩萨摩诃萨。有十种藏。三世诸佛之所演说。何等为十。信藏。戒藏。惭藏。愧藏。闻藏。施藏。慧藏。正念藏。持藏。辩藏。是为十。何等为菩萨信藏。此菩萨信一切法空无真实。信一切法无相。信一切法无愿。信一切法无作者。信一切法不实。信一切法无坚固。信一切法无量。信一切法无上。信一切法不可度。信一切法不生。若菩萨成就如是随顺净信。闻诸佛法不可思议。心不惊怖。闻一切佛不可思议。心不惊怖。闻众生不可思议。心不惊怖。闻法界不可思议。心不惊怖。闻虚空界不可思议。心不惊怖。闻涅槃界不可思议。心不惊怖。闻过去世不可思议。心不惊怖。闻未来世不可思议。心不惊怖。闻现在世不可思议。心不惊怖。闻入一切劫不可思议。心不惊怖。何以故。菩萨于诸佛所一向坚信不可沮坏。佛如是知佛无尽无边智。十方一切世界。一一世界中三世无量无数诸佛。出兴于世。施行佛事。而般涅槃。彼诸佛智慧。不增不减。不生不灭。不尽不去。不近不远。不智不乱。菩萨成就如是等无边无尽信藏。则能乘如来乘。此菩萨成就如是等无量无边信。不退转信。不乱信。不坏信。不着信。有根信。随顺圣人信。如来家性信。则能护持一切佛法。长养一切菩萨善根。随顺一切如来善根。从一切佛善方便生。是名菩萨摩诃萨无尽信藏。菩萨住此信藏。悉能闻持诸如来法。广为一切众生演说。佛子。何等为菩萨摩诃萨戒藏。此菩萨成就饶益戒。不受戒。无著戒。安住戒。不诤戒。不恼害戒。不杂戒。离邪命戒。离恶戒。清净戒。何等为饶益戒。此菩萨先当饶益安乐众生。何等为不受戒。此菩萨不受外道戒。具足奉持三世诸佛平等净戒。何等为无著戒。此菩萨不着欲界戒。不着色界戒。不着无色界戒。何以故。不回向彼故。何等为安住戒。此菩萨成就清净无疑悔戒。何以故。菩萨不作五无间罪。永不故犯一切戒故。何等为不诤戒。此菩萨不非先制。不更造立。心常随顺向涅槃戒。皆具足持无所毁犯。不由此戒恼乱众生共相违诤。菩萨持戒。但饶益众生令欢喜故。何等为不恼害戒。此菩萨不因持戒学诸咒术药草恼害众生。何以故。菩萨欲救护众生故。持清净戒。何等为不杂戒。此菩萨离断常见。不持杂戒。但观察十二缘起。持清净戒。何等为离邪命戒。此菩萨不作持净戒相。欲使他知内无实德现实德相。但持净戒一向求法。究竟萨婆若。何等为不恶戒。此菩萨不自贡高言我持戒。见犯戒人。不轻贱诃骂令其忧恼。但一其心持清净戒。何等为清净戒。此菩萨舍离杀盗邪淫妄语恶口粗言两舌杂语贪恚邪见。具持十善。此菩萨持如是等清净戒时作是念。若有众生犯净戒者。斯由颠倒诸烦恼故。一切诸佛悉分别知是一切众生。因诸颠倒毁犯净戒。是故我当专求佛道。究竟无上菩提。广为众生说真实法。令离颠倒净持禁戒。悉令究竟无上菩提。是为菩萨摩诃萨第二无尽戒藏。佛子。何等为菩萨摩诃萨惭藏。此菩萨自忆宿命。无数世来。于六亲所行无惭行。或侮慢无礼。或淫乱无节。忍害无亲兴师相伐。迷惑颠倒无恶不造。斯由三毒邪疑使缠虚伪谄曲诸不善故。一切众生亦复如是。皆悉积习诸无惭行。斯由无智乃至谄曲故。尊卑失序不相敬顺。不能谦下遵奉明哲。常怀毒念怨结滋甚。更相屠害曾无耻惧。自惟我身及余众生。去来现在行无惭法。三世诸佛无不知见。我当云何犹行无惭。甚为不可。是故我应修习惭法。究竟菩提。广为众生说真实法。令其永离诸无惭法。成就菩提。是为菩萨摩诃萨第三无尽惭藏。佛子。何等为菩萨摩诃萨愧藏。此菩萨自愧昔来贪求色声香味触法妻子眷属钱财宝物僮仆车乘。心无厌足。我不应行是诸非法事。因是生长贪恚愚痴乃至谄曲。复作是念。众生所行无愧之法。皆以无智乃至谄曲诸恶法故。不相承顺尊敬供养。常怀毒心迭相残害。我及众生。去来现在爱乐贪求。集行是法。因是法故。受胎生死无量诸苦。三世诸佛皆悉知见。我犹行是无愧法者。三世诸佛皆不欢喜。我当修习愧法。究竟菩提。广为众生说如是法。令离无愧成就佛道。是为菩萨摩诃萨第四无尽愧藏。佛子。何等为菩萨摩诃萨多闻藏。此菩萨多闻者。所谓知是事有故是事有。是事无故是事无。是事起故是事起。是事灭故是事灭。是世间法。是出世间法。是有为法。是无为法。是有记法。是无记法。何等为是事有故是事有。所谓有无明故有行。何等为是事无故是事无。所谓无识故无名色。何等为是事起故是事起。所谓爱起故苦起何等为是事灭故是事灭。所谓有灭故生死灭。何等为世间法。所谓色受想行识。何等为出世间法。所谓戒身定身慧身解脱身解脱知见身。何等为有为法。所谓欲界色界无色界众生界。何等为无为法。所谓虚空涅槃。数缘灭非数缘灭。十二缘起及法界。何等为有记法。所谓四真谛。四沙门果。四辩。四无所畏。四念处。四正勤。四如意足。五根。五力。七觉支。八圣道分。何等为无记法。所谓世间有边世间无边。世间有边无边。世间非有边非无边。世间有常世间无常。世间有常无常。世间非有常非无常。如来灭后如去不受。如来灭后不如去亦不受。如来灭后如去不如去亦不受。如来灭后非如去非不如去亦不受。有我有众生。无我无众生。有我无我。有众生无众生。非有我非无我。非有众生非无众生。过去有几如来灭度。几声闻缘觉灭度。未来有几如来几声闻缘觉几众生生。现在有几佛几声闻缘觉。何等如来最初出世。何等声闻缘觉最初出世。何等众生最初生。何等如来最后出世。何等声闻缘觉最后出世。何等众生最后生。何等诸法最在初。何等诸法最在后。世间从何处来去至何所。有几世界成。有几世界败。世界从何所来去至何所。何等为生死最初际。何等为生死最后际。是名无记法。菩萨摩诃萨。作如是念。众生长夜流转生死。童蒙凡夫不知修道。我当昼夜精勤学问。受持一切诸佛法藏。究竟成就无上菩提。广为众生说真实法。普令一切成无上道。是为菩萨摩诃萨第五无尽多闻藏。佛子。何等为菩萨摩诃萨施藏。此菩萨修行十种施。所谓施法。最后难施法。内施法。外施法。内外施法。一切施法。过去施法。未来施法。现在施法。究竟施法。何等为菩萨修习施法。此菩萨从本以来习平等施。珍馔美味不自贪着。惠施一切。其余诸物亦复如是。所施之余然后自食。作是念言。为我身中八万户虫故。我身安乐彼亦安乐。我身饥苦彼亦饥苦。是故菩萨有所服食皆为诸虫。欲令安乐不贪其味。菩萨复作是念。我长夜为身贪求饮食。当勤精进速离此身。是为菩萨修习施法。何等为菩萨最后难施法。此菩萨若得种种上味饮食香华衣服资生之具。若自己受用则快乐长寿。若尽以施人则穷苦夭命。时有乞人一切求索。菩萨自念。吾从本际以来丧身无数。未曾损己利一众生令获大利希有之庆。当捐弃身命。悉舍一切饶益众生。究竟大施。是为菩萨最后难行施法。何等为菩萨内施法。此菩萨于少壮时形体端严。颜容殊特澡浴清净。服上妙衣严饰之具。受灌顶转轮王位。七宝具足王四天下。时有乞人来诣王所。而自陈曰。大王当知。我今衰老身婴重疾。茕独苦厄无人赡救。生路既穷必之死地。若得王身随所应用。或须手足或须血肉。或须头目。或须髓脑。若大王慈仁矜哀穷老。舍离贪身以救我者。必蒙天施得全性命。菩萨即作是念。今我此身。亦当如彼会应归死。无一饶益。宜时舍身以济其命。念已欢喜施彼众生。是为菩萨内施法。何等为菩萨外施法。此菩萨于少壮时形体端严。颜容殊特澡浴清净。服上妙衣严饰之具。受灌顶转轮王位。七宝具足王四天下。时有乞人来诣王所。作如是言。大王当知。我今衰老身又婴疾。余命无几终此贫苦。而王具足一切快乐。善哉大王。愿舍天位哀施于我。我当统领天下受王福乐。菩萨即作是念。富贵无常必归贫贱。若在贫贱无所饶益。不能满遂众生所愿。是故我今宜时舍位称悦其意。念已欢喜即舍与之。是为菩萨外施法。何等为菩萨内外施法。此菩萨于少壮时形体端严。颜色殊特澡浴清净。服上妙衣严身之具。受灌顶转轮王位。七宝具足王四天下。时有乞人来诣王所。作如是言。大王当知。今我老迈身又婴疾。不以衰贱窃希美号。善哉大王。愿以王身七宝天下转轮王位。以授于我。令我具足受王庆乐。菩萨即作是念。我身财宝俱非坚固。无常危脆磨灭之法。我今盛壮富有天下。乞者现前。三事具足。是故于此不坚固法当求坚固。作是念已倍大欢喜。即舍内外而施与之。是为菩萨内外施法。何等为菩萨一切施法。此菩萨于少壮时形体端严。颜容殊特沐浴香汤。服上妙衣严身之具。受灌顶转轮王位。七宝具足王四天下。时有乞人来诣王所。作如是言。大王当知。大王名称普闻十方。我乃在彼国服承王问。自远而来欲有所请。善哉大王。愿随所欲充满我意。尔时乞者。或求国城妻子眷属肢节血肉头目髓脑。尔时菩萨作是思惟。一切恩爱会当别离。无所饶益不能果遂众生诸愿。我今应当离贪贫行。一切速舍饶益众生。作是念已倍大欢喜。悉舍一切惠施众生。是为菩萨一切施法。何等为菩萨修习过去施法。此菩萨闻过去诸佛菩萨所行具足功德。闻已不着了达非有。不起妄想不贪不味。观察诸法心无所猗。诸法如梦无有坚固。于诸善根不起有想。心无所著。但为化众生故。示现其身广说道教。欲令众生成就佛法。又复观察过去诸法。十方推求都不可得。菩萨如是观已。复作是念。过去诸法皆悉舍离。是为菩萨修习过去施法。何等为菩萨修习未来施法。此菩萨闻未来世诸佛菩萨所行善根具足功德。闻已而不取相心无所有。不求往生彼方佛刹。无诸求想不生行愿。摄心不散不味不厌。不以善根回向于彼。不为生彼专修善根。亦不废舍。但因彼境界教化众生。欲令众生具足佛法。观察真实。此真实法。非有处所非无处所。非内非外非远非近。复作是念。若法非有不可不舍。是为菩萨修习未来施法。何等为菩萨修习现在施法。此菩萨闻四天王三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵天。梵身天。梵辅天。梵眷属天。大梵天。光天。少光天。无量光天。光音天。净天。少净天。无量净天。遍净天。密身天。少密身天。无量密身天。密果天。不烦天。不热天。善现天。善见天。色究竟天。闻声闻缘觉具足功德。闻已心不惑乱正念不忘。不懈不没亦不忧戚。其心寂灭而无所取。菩萨唯作是念。一切诸行皆悉如梦。一切所行皆非真实。众生不知故流转恶道。菩萨于彼广为说法。远离诸恶成就佛法。修菩萨道心无惑乱。是为菩萨修习现在施法。何等为菩萨究竟施法。此菩萨摩诃萨。有无量众生形类不同。往诣其所作如是言。我有所须幸垂周给。我意既足仁愿亦满。菩萨闻是语已欢喜踊跃。随其所求施令满足。菩萨摩诃萨内自观察。从初入胎不净微形。胞段诸根生老病死。又具观此身。无有真实无所有相。无惭愧物贤圣所弃。恶露臭处犹如死尸。骨节相持血肉泥涂。九窍之门常流不净。菩萨见身无量过患。乃至不起一念贪惜是身。复作是念。此身危脆我当云何。既见此身无量过患。而生贪着。应当弃舍施彼众生充满其愿。我当于此不坚法中。求坚固法。令一切众生随其所愿悉得满足。开悟示导。皆令逮得清净法身。住无所住离身心相。是为菩萨摩诃萨第六无尽施藏。佛子。何等为菩萨摩诃萨无尽慧藏。此菩萨知色苦如实。知色集如实。知色灭如实。知色道如实。知受想行识苦如实。知识集如实。知识灭如实。知识道如实。知无明苦。知无明集。知无明灭。知无明道。知爱苦。知爱集。知爱灭。知爱道。知声闻。知声闻法。知声闻集。知声闻涅槃。知缘觉。知缘觉法。知缘觉集。知缘觉涅槃。知菩萨。知菩萨法。知菩萨集。知菩萨涅槃。云何知。知从业报因缘所造。诸行非我非坚固。无真实空无所有。不取诸法坚固之相。不取诸法所有之相。知一切法悉无所有。广为众生。说真实法。云何为说说一切法不可坏。何等不可坏。色不可坏。受想行识不可坏。无明不可坏。声闻法。缘觉法。菩萨法。不可坏。何以故。一切诸法。不自作不他作。言语道断离一切处。不生不起不施不受。无有心意。菩萨成就如是等无尽慧藏。以少方便。则能逮得一切诸法善妙方便。自然明达不由他悟。此智慧藏有十种不可尽。何等为十。多闻善方便不可尽。亲近善知识不可尽。演一句法不可尽。入深法界不可尽。入无量智慧庄严不可尽。出生长养诸功德藏心无忧厌不可尽。入一切陀罗尼门不可尽。分别了知一切众生语言音声不可尽。得普令众生离诸疑惑不可尽。得一切佛自在示现教化众生所行成就不可尽。是为十种不可尽法。是为菩萨摩诃萨第七无尽慧藏。菩萨住此无尽慧藏。疾得无上平等正觉。佛子。何等为菩萨摩诃萨无尽念藏。此菩萨舍离痴冥。忆念过去一生十生百生千生万生。乃至阿僧祇不可思议无分齐。不可说亿那由他生成劫坏劫成坏劫非一成劫。非一坏劫。非一成坏劫。百劫千劫百千亿那由他劫。乃至阿僧祇不可思议无分齐。不可说亿那由他劫。念知一佛名号。乃至不可说不可说诸佛名号。念知授一佛记。乃至授不可说不可说诸佛记。念知一佛出世。乃至念知不可说不可说诸佛出世。念知从一佛所受一修多罗。乃至不可说不可说佛所受不可说不可说修多罗。祇夜。授记。伽陀。因缘。忧陀那。本事。本生。方广。未曾有。譬谕。忧波提舍。亦复如是。念知一会众一时说法。乃至不可说不可说时会说法。念知一根乃至不可说不可说诸根。念知一烦恼乃至不可说不可说诸烦恼。念知一三昧乃至不可说不可说诸三昧。菩萨作如是念。妙念。净念。不浊念。遍净念。离尘念。离种种尘念。离垢念。光曜念。乐念。无障碍念。此菩萨住是念时。一切世间不能娆乱。诸根清净不复染着。一切世间众魔外道所不能坏。念持一切诸佛法藏。决定明了未曾错乱。是为菩萨摩诃萨第八无尽念藏。佛子。何等为菩萨摩诃萨无尽闻持藏。此菩萨于诸佛所。闻持一品修多罗。乃至闻持不可说不可说修多罗。未曾忘失一字一句。于一生中而不忘失。乃至不可说不可说生。未曾忘失一字一句。闻持一佛名号。乃至闻持不可说不可说佛名号。闻持一世界名字。乃至闻持不可说不可说世界名字。闻持一劫名字。乃至闻持不可说不可说劫名字。闻持一如来记。乃至闻持不可说不可说如来记。闻持一修多罗。乃至闻持不可说不可说修多罗。闻持一会名字。乃至闻持不可说不可说会名字。闻持一时说法。乃至闻持不可说不可说时说法。闻持一根。乃至闻持不可说不可说诸根。闻持一烦恼。乃至闻持不可说不可说烦恼。闻持一三昧。乃至闻持不可说不可说三昧。是为菩萨摩诃萨第九甚深无尽闻持藏。此闻持藏。唯佛境界余无能及。佛子。何等为菩萨摩诃萨无尽辩藏。此菩萨成就甚深智慧。广为众生演说诸法。不违一切诸佛经典。说一品法。乃至说不可说不可说品法。说一佛名号。乃至说不可说不可说诸佛名号。说一世界名字。说一佛记。说一修多罗。说一会。说一时。说法。说一根。说一烦恼。说一三昧。乃至说不可说不可说诸三昧。或一日说一句一味法无尽。乃至不可说不可说劫。说一句一味法而无穷尽。一切诸劫尚可穷尽。说一句一味不可穷尽。何以故。此菩萨成就十种无尽藏故。成就此藏故。得摄一切法。陀罗尼门现在前。百万阿僧祇陀罗尼以为眷属。此菩萨成就百万阿僧祇陀罗尼眷属已。以法光明辩才。广为众生演说深法。以广长舌出妙音声。充满一切十方世界随顺诸根除灭烦恼。皆令欢喜。善入一切音声。于一切文字。得不断辩。入普照法门。说一切众生如来种子不可断故。不舍菩萨一切诸行。心无忧厌。何以故。此菩萨成就充满虚空法界清净法身故。是为菩萨摩诃萨第十无尽辩藏。此藏无量无分齐。无间不可坏。无断不可断。不退转。甚深无底。以一切法门。入一切佛法。佛子。是为菩萨摩诃萨十种无尽藏。令一切众生究竟成就无上菩提。此藏有十种无尽深法。何等为十。饶益一切众生善回向故。不断本愿一切劫行故。心无量无边观察平等如虚空故。回向有为不着无为故。一切法无尽念念知境界故。大愿不可坏究竟诸力陀罗尼行故。诸佛护念入一切法如幻化故。是为十种无尽法。能令一切世间。得无尽藏

大方广佛华严经卷第十二大方广佛华严经卷第十三

        东晋天竺三藏佛驮跋陀罗译

    如来升兜率天宫一切宝殿品第十九

尔时佛威神力故。十方一切世界。诸四天下。一一阎浮提。皆有如来坐菩提树。无不显现。彼诸菩萨。承佛神力说种种法。皆悉自谓在于佛所。尔时如来。以自在神力。不离菩提树座及须弥顶妙胜殿上夜摩天宫宝庄严殿。趣兜率天宫一切宝庄严殿。时彼天王遥见佛来。即于殿上敷如意宝藏师子之座。以种种天宝而庄严之。过去修习善根所得。一切如来威神护持。不可数那由他阿僧祇善根所生。一切诸佛净法所起。一切众生所共庄严。无量功德之所成就。离一切恶。清净业报。一切乐观无有厌足。出离世间诸法所起。清净无污。一切世间因缘所起。一切众生见不能尽。以无量庄严具而庄严之。所谓百万亿栏楯。百万亿宝网罗覆其上。百万亿华帐。以张其上。百万亿华鬘以垂四边。百万亿香帐。普熏十方。百万亿宝帐。以张其上。百万亿华盖。诸天执持。百万亿华鬘盖。百万亿宝盖。以盖其上。百万亿宝衣。以敷其上。百万亿妙宝楼阁。百万亿如意宝王网。罗覆其上。百万亿胜妙杂网。百万亿众宝璎珞。间错垂下。百万亿众妙杂宝。百万亿网盖。以覆其上。百万亿杂宝网衣。百万亿妙宝莲华。开敷光曜。百万亿无厌香网。普熏十方。百万亿大宝帐网。以覆其上。百万亿宝铃。微动出和雅音。百万亿栴檀宝帐。普熏十方。百万亿杂宝妙华。以散其上。百万亿杂色宝衣。以覆其上。百万亿菩萨大帐。百万亿杂宝盖帐。百万亿清净金帐。百万亿净琉璃帐。百万亿杂宝藏帐。百万亿一切宝帐。以覆其上。百万亿杂宝妙华。周匝围绕。百万亿宝形像帐。百万亿众妙宝鬘。百万亿香鬘。普熏十方。百万亿天曼陀罗栴檀。色香具足普熏十方。百万亿天庄严具。百万亿妙宝华鬘。百万亿胜妙宝藏。百万亿胜宝藏鬘。百万亿清净宝鬘。百万亿海宝藏鬘。百万亿因陀罗金刚妙宝。百万亿妙宝缯彩。以为垂带。百万亿无量自在妙宝。百万亿真金宝藏。清净微妙。百万亿毗楼那宝。以为照耀。百万亿因尼罗宝。杂宝校饰。百万亿首罗幢宝光曜明净。百万亿火珠宝。出大光明普照十方。百万亿天坚固宝。以为窗牖。百万亿净功德宝。无量妙色。百万亿杂宝偏阁。清净妙藏。百万亿大海月宝。百万亿离垢藏宝。百万亿心王宝。无量欢喜。百万亿师子面宝。百万亿阎浮檀宝。百万亿一切世间清净藏宝。百万亿一切世间因陀罗幢宝。百万亿罗阇藏宝。百万亿须弥山王殊胜幢宝。百万亿解脱妙宝。百万亿琉璃鬘网。周匝垂下。百万亿赤色宝鬘。百万亿乐摩尼宝。百万亿清净乐宝。百万亿众杂宝藏。百万亿赤色解脱乐见妙宝。百万亿无量色宝鬘。百万亿无比宝鬘。百万亿净光明宝。普照殊胜。百万亿摩尼宝像。百万亿因陀罗宝。百万亿黑沉水香。普熏十方。百万亿不可思议众杂妙香。普熏十方一切佛刹。百万亿十方妙香。普熏世界。百万亿最殊胜香。普熏十方。百万亿香像香彻十方。百万亿随所乐香。普熏十方。百万亿净光明香。普熏众生。百万亿种种色香。普熏佛刹。不退转香。百万亿涂香。百万亿栴檀涂香。百万亿香熏香。百万亿莲华藏黑沉香云。充满十方。百万亿丸香烟云。充满十方。百万亿妙光明香。常熏不绝。百万亿妙音声香。能转众心。百万亿明相香。普熏众味。百万亿能开悟香。远离嗔恚寂静诸根充满十方。百万亿香王香。普熏十方。雨百万亿天华云雨。百万亿天香云雨。百万亿天末香云雨。百万亿天妙莲华云雨。百万亿天种种宝华云雨。百万亿天青莲华不断云雨。百万亿天宝华云雨。百万亿天分陀利华云雨。百万亿天曼陀罗华云雨。百万亿天一切杂华云雨。百万亿天种种衣云雨。百万亿天杂宝普照十方云雨。百万亿天种种盖云雨。百万亿天无量色幡云雨。百万亿天冠云雨。百万亿天种种庄严天冠云雨。百万亿天庄严具云雨。百万亿杂色天鬘云雨。百万亿种种大庄严天鬘云雨。百万亿种种色天栴檀云雨。百万亿天沉水香云雨。百万亿天宝幢。百万亿天杂幡。百万亿天带垂下。百万亿天和香。普熏十方。百万亿天妙功德宝鬘垂下。百万亿天多罗宝。悬布光耀。百万亿天拂。执持侍立。百万亿天金铃网。微风吹动出妙音声。百万亿天宝栏楯。周匝围绕。百万亿天多罗宝墙。周回四绕。百万亿天杂宝树。围绕覆荫。百万亿天杂宝楼阁。庄严其内。百万亿天胜宝门。百万亿天真金铃。微风吹动出和雅音。百万亿清净天鬘。布列垂下。百万亿天苏婆提宝。杂相解脱。百万亿天金刚藏众妙璎珞。百万亿天杂宝盖。诸天执持。百万亿天杂宝网。百万亿天杂宝藏。光耀殊特。百万亿天净光明。普照十方。百万亿大光普耀。百万亿日藏光明。普照一切。百万亿杂色月光。百万亿离痴净香。百万亿天妙华藏。开敷鲜茂。百万亿宝网藏。百万亿华网。百万亿香网。以覆其上。百万亿天杂宝衣。以敷其上。百万亿天诸宝衣。处处敷置。百万亿天青色衣。百万亿天杂黄衣。百万亿天杂朱衣。百万亿天杂色衣。百万亿天杂宝衣。百万亿种种熏衣。百万亿殊胜宝衣。能令众生发欢喜心。如是等衣以敷其上。百万亿白净妙衣。以覆其上。百万亿天幢宝铃。出微妙音。百万亿白净宝幢。微风吹动出妙音声。百万亿天缯彩幢。百万亿香幢。出众香网。百万亿华幢。雨一切华。百万亿天妙衣幢。百万亿摩尼宝幢。百万亿天一切庄严具幢。百万亿天鬘幢。四面行列。百万亿天盖幢。一切宝铃出妙音声。百万亿天螺。出妙音声。百万亿天鼓。出大音声。百万亿天琴。出微妙音。百万亿天牟陀罗。出大音声。百万亿天娱乐具。百万亿天乐音声。充满十方一切佛刹。百万亿化音声。声彻十方。众生闻者悉解如响。百万亿天妓乐音。同时俱作。百万亿天神力妓乐。出相和音。百万亿一切诸天娱乐之具。出妙音声。百万亿妙音。赞叹如来。百万亿胜妙喜音。赞叹如来。百万亿甚深音声。赞叹如来。百万亿种种音声。叹佛果报。百万亿细微音声。称扬赞叹出三界法。百万亿寂静音声。赞叹如来本所修行。百万亿音。赞叹如来百万亿劫永离嗔恚。赞叹百万亿供养供养过去诸佛。百万亿法门。赞叹如来百万亿音。赞叹一切菩萨功德不可穷尽。百万亿音。赞叹菩萨一切诸地功德具足。百万亿音。赞叹诸佛无有厌足。百万亿音。称扬赞叹见佛之行。百万亿音。赞叹深法。其闻音者得深智慧。无有障碍。百万亿妙音。充满十方一切世界。百万亿妙音。叹诸众生。随其志愿皆令欢喜。百万亿音。叹一切世间。其闻音者解一切法真实之性。百万亿音。赞叹如来。其闻音者。悉能恭敬一切如来。百万亿音。叹佛境界一切功德。百万亿音。叹诸总持善妙方便。善知分别一切诸法。闻持一切诸如来法。百万亿音。赞叹甚深具足诸法。百万亿音。叹发心菩萨。修习长养一切种智。百万亿音。叹治地菩萨。其心欢喜。百万亿音。叹修行地菩萨。清净解脱。百万亿音。叹生贵菩萨。心得安住。百万亿音。赞叹方便具足菩萨。于摩诃衍究竟决定。百万亿音。叹善现菩萨具足一切菩萨所行。百万亿音。赞叹不退菩萨所行。一切诸地皆悉清净。百万亿音。叹童真菩萨。光明普照一切十方。百万亿音。叹王子菩萨。善入甚深不可思议诸佛境界。百万亿音。叹灌顶菩萨。能现一切诸如来力。百万亿神力自在。百万亿清净解脱。出生百万亿清净解脱。百万亿长养大欢喜法。百万亿住不坏信。百万亿长养勇猛之力。百万亿长养名闻法。百万亿分别法义。广说定慧。百万亿正念清净不乱。出生百万亿定慧。百万亿陀罗尼。悉能受持一切佛法。出生百万亿广大智慧。出生百万亿深心信佛信根坚固。出生百万亿清净檀波罗蜜。出生百万亿尸波罗蜜。出生百万亿羼提波罗蜜。不生恚心。具足诸佛羼提波罗蜜。出生百万亿毗梨耶波罗蜜。究竟具足无量。毗梨耶波罗蜜。出生百万亿禅波罗蜜。无量诸禅寂静照明。出生百万亿般若波罗蜜。照一切法。出生百万亿清净大愿。出生百万亿诸深法门智慧灯明。出生十方诸佛百万亿深妙法门。出生百万亿离痴示现善妙方便。出生百万亿诸法之行。普入百万亿诸佛之刹。百万亿清净法身。往诣十方一切佛刹。出生百万亿如来微妙音声。出生百万亿一切种智善妙方便。出生百万亿具足法门。出生百万亿正法知见。悉见一切诸佛实法。犹如宝幢。出生百万亿智慧。示现如来境界无所障碍。百万亿诸天神王。恭敬礼拜。百万亿龙王。一心谛观而无厌足。百万亿夜叉王。合掌敬立。百万亿乾闼婆王。一心恭敬目不暂舍。百万亿阿修罗王。断除憍慢敬心侍立。百万亿宝金翅鸟王。口衔缯带。百万亿紧那罗王。欢喜立侍。百万亿摩睺罗王。踊跃欢喜一心谛观。百万亿婆罗门王。恭敬礼拜。百万亿一切世间诸王。恭敬顶礼。百万亿诸释天王。恭敬尊重一心观察。百万亿夜摩天王。踊跃欢喜高声赞叹。百万亿兜率陀天王。恭敬礼拜。百万亿化乐天王。恭敬赞叹。百万亿他化自在天王。合掌恭敬一心侍立。百万亿梵天王。一心观察。百万亿摩醯首罗天王。恭敬赞叹。百万亿菩萨。恭敬赞叹。百万亿天女。恭敬供养。百万亿愿天。敬心顶礼。百万亿宿命。亲近善知识天妙声赞叹。百万亿梵身天。布身敬礼。百万亿梵辅天。恭敬顶礼。百万亿梵眷属天。围绕侍卫。百万亿大梵王。赞叹称扬无量功德。百万亿光天。五体投地。百万亿少光天。宣扬赞叹佛世难值。百万亿无量光天。赞叹礼拜。百万亿光音天。赞叹如来。难遇难见。百万亿净天。恭敬礼拜。百万亿少净天。恭敬礼拜。百万亿无量净天。乐见佛故。于虚空中自投来下。百万亿遍净天。合掌敬住。百万亿密身天。忆本功德称扬赞叹。百万亿少密身天。生如来想一心求见。百万亿无量密身天。清净善业恭敬礼拜。百万亿密果天。布身敬礼。百万亿无烦天。得坚固信恭敬礼拜。百万亿无热天。合掌观察心无厌足。百万亿善现天。恭敬礼拜。百万亿善见天。忆念无量佛所。恭敬供养心无厌足。百万亿阿迦尼吒天。恭敬礼拜。百万亿种种天。皆大欢喜恭敬赞叹。百万亿诸天。以种种善慧而庄严之

百万亿诸大菩萨。顶戴护持。百万亿华手菩萨。雨一切华百万亿香手菩萨。雨一切香百万亿鬘手菩萨。雨一切鬘。百万亿末香手菩萨。雨一切末香。百万亿衣手菩萨。雨一切宝衣。百万亿幢手菩萨。雨一切幢。百万亿幡手菩萨。雨一切幡。百万亿宝手菩萨。雨一切宝。百万亿庄严手菩萨。普雨一切诸庄严具。百万亿诸天。以天种种庄严宫殿。而以庄严。欢喜天子。以百万亿诸天庄严宫殿。而庄严之。百万亿生贵天子。法身普覆。百万亿灌顶天子。举身持座。出生百万亿菩萨清净大愿。出生百万亿菩萨初清净心。出生菩萨百万亿柔软利根。百万亿禅藏皆悉清净。菩萨百万亿清净解脱。严治菩萨百万亿诸清净业。出生菩萨百万亿安住生贵地。出生菩萨百万亿法门普照一切。成就百万亿菩萨诸地。教化调伏百万亿大众。百万亿诸善根所起。百万亿诸佛护持。百万亿功德所成。百万亿直心庄严清净。百万亿大愿庄严清净。百万亿善行所起。百万亿诸法充满。百万亿自在神力之所成就。百万亿诸功德所起。以百万亿赞法。而赞叹之。如此世界四天下兜率陀天宫。一切宝庄严殿。为如来敷摩尼宝藏师子之座。十方一切诸佛世界。诸四天下。兜率陀天宫。一切宝庄严殿。为如来敷摩尼宝藏师子之座。亦复如是

尔时兜率陀天王。为如来敷高座竟。与不可计阿僧祇兜率陀天子俱。奉迎如来。雨阿僧祇色上妙诸华。供养如来。雨不可思议香。雨无量色鬘。雨上妙栴檀。雨无量种种宝盖。雨细妙天衣。雨无量杂宝。供养如来。以欢喜心。雨天上妙诸庄严具。烧种种香。香气普熏十方世界。雨栴檀末香。沉水末香。坚固末香。供养如来。无量天子。各从其身出无量无数诸天子身。阿僧祇兜率陀天子。及他方来诸天子众。皆大欢喜恭敬作礼。阿僧祇天女众。欢喜无量。一心寂然谛观如来。不可数不可说诸大菩萨。悉从他方兜率天来。住于虚空。以不可思议诸供养具。供养如来。出过一切诸天供养。以阿僧祇胜妙音声。赞叹如来。佛神力故。过去诸佛所修善根故。如来不可思议自在神力故。一切兜率陀天子及诸天女。一心恭敬静默观佛。咸作是念。如来出世甚难值遇。功德具足智慧无碍。平等正觉我今得见。作是念已。皆大欢喜。阿僧祇那由他兜率陀天子。来诣佛所。各以身上天衣。盛种种宝。又以身上天衣。盛种种香。一切宝衣诸庄严具。栴檀末香。沉水末香。天妙宝末。诸天香华。天曼陀罗华。普散十方供养如来。亿那由他无数天子。以种种上妙供具。庄严虚空。烧众名香。香气成云。充满十方一切虚空。智境界心故。雨天华云庄严虚空。于如来所起欢喜心故。雨一切天盖云。庄严虚空充满十方。得敬佛心故。雨一切天鬘云。庄严虚空充满十方。供养佛故。以阿僧祇白净宝网。遍满虚空以为庄严。悬众金铃而间错之。自然微动出妙音声。悟三乘者令得解脱。无数宝帐。庄严虚空弥覆十方。于如来所得深信故。普雨一切妙宝鬘云。未曾断绝。以阿僧祇诸天宫殿。庄严虚空。一切天乐出微妙音。充满十方。至心踊悦。尊敬佛故。以阿僧祇种种妙衣。庄严虚空。得佛出世难遇心故。雨阿僧祇诸天宝冠。庄严虚空。于如来所得欣敬心故。雨阿僧祇上妙众宝及天宝鬘。庄严虚空。无数亿那由他天子。各从身出阿僧祇种种色华。供养如来无有穷尽。于如来所欢喜恭敬故。以无数种种随所乐香。供养如来。于如来所欢喜恭敬故。以阿僧祇栴檀末香。供养如来。于如来所得无比欢喜故。以种种宝盖。供养如来。长养念佛三昧故。以无数种种上妙宝衣。以布道路供养如来。于如来所得欢喜恭敬故。以无量无数杂色宝幢。供养如来。于如来所得无量欢喜心故。以阿僧祇杂色宝幡。供养如来。于如来所得欢喜恭敬故。以无数天乐出微妙音。供养如来。其心常定未曾散乱。不可说亿那由他菩萨。于兜率陀天宫。以离三界一切供具。从真实法生离诸烦恼大慈之心。充满十方无有障碍。具足方便诸甚深法。唯有诸佛乃能测量。余无能及。坚固净信之所长养。不可思议善根所生。无数变化因力所起。从诸如来真法化生。无行法印。一切宝盖普覆法界。供养如来。出过诸天一切所供。一切波罗蜜所起。一切华帐普覆法界。出过诸天所供养上。供养如来。清净解脱。充满一切诸佛境界。一切宝衣。普覆庄严一切法界。出过诸天所供养上。供养如来。无生法忍所起。杂宝铃网。普覆庄严一切法界。出过诸天所供养上。供养如来。入无碍智慧。以一切坚固香。庄严法界。出过诸天所供养上。供养如来。解一切法犹如幻化。敷置一切妙宝高座。庄严法界。出过诸天所供养上。供养如来。其心境界与如来等。座处境界亦同如来。建一切宝幢庄严法界。出过诸天所供养上。供养如来。善解应时。供养如来。以一切宝殿庄严法界。出过诸天所供养上。供养如来。解一切法如梦。以种种宝华庄严法界。出过诸天所供养上。供养如来。无著善根所生。充满一切法界。此等无量菩萨。皆从身出一切坚固香云。一切杂色华云。一切杂色衣云。一切栴檀香云。一切庄严宝盖云。一切种种香云。一切华鬘云。一切清净庄严具云。出过诸天所供养上。供养如来。无量菩萨。称叹如来真实功德。永离颠倒安住正法。具一切力。能令众生离诸恶难。开示善道。于一音中演无量法。从一切陀罗尼生。辩才之藏。不可穷尽。具足无畏心常欢喜。菩萨以如是等无量妙法。赞叹如来。法身充满虚空法界。心与三世诸如来等

尔时一切诸天众。及他方来诸天子众。并不可数诸佛刹一切菩萨。见如来等正觉。不可思议人中之雄。其身无量不可称数。示现不可思议神足。令一切众生皆大欢喜。周遍充满一切虚空。诸佛功德庄严一切法界。令一切众生安住一切善根。成就神力。出过一切诸语言道。一切菩萨恭敬供养。随所应化现身救度。具足一切清净善根。显现如来无上功德。智慧境界不可穷尽。无比三昧之所出生。法身普至一切众生。无有分际。令一切众生皆大欢喜。不断一切智种。住佛所住。于三世诸佛家生。无尽众生皆令清净。悉能出生一切菩萨清净智慧。发起一切菩萨诸根。一切法云普覆法界。如来教化究竟无余。随其所愿悉令满足。安立清净平等正智。出过一切众生之上。得一切智。以正觉眼普观世间。随其先世所修善根。悉能示现。普发大心。众生爱乐。智慧安住无能坏者。善知众生。分别诸刹。于不退转善法中生。不坏法性分别法界。现如来身无量无数。远离痴妄安住真实。一切众生叹无能尽。教化一切。修念佛三昧。充满法界。度脱众生无量无边。本之所请悉能化度。随其所应以法惠施。种种方便调伏众生。随彼欲性悉令清净。示现色身不可思议。等观众生心无所著。住无碍住所见无障。善解如来一切诸力。心常寂定未曾散乱。住一切智。善能演说句身味身真实之义。悉能深入无量智海。出生无量功德慧藏。如来日出普照法界。众生愿力常住不没。住佛所住坚固不坏。于我我所心无所著。所行诸法永离世间。于一切世无所染污。在大众会建智慧幢。智慧超出一切世间。无所染着。以大悲心拯拔众苦。安立众生于深妙智。饶益众生功德无尽。悉善分别菩萨智慧。信向佛道成最正觉。出于大慈显现大悲。佛身无量诸法庄严种种音声演无量法。随其所应充满其愿。于去来今心常清净。悉令群生不着境界。能与一切诸菩萨记。生于三世诸如来家。普于十方。智慧无碍。一切悉至而无所著。于诸佛世界。了达真实。善能分别一切众生。出世功德。普为一切世间灯明。生死垢恼无能染着。佛智慧月普照法界。了达诸法无真实性。无量深智观察平等。慧心明净普照十方。解了诸法如梦如化。一切世间心诸佛心及诸业报。随其所应显现真实。顺众生根为现佛身。如来境界。悉能容受一切众生。普知众生所行诸法。解了其相无有自性。知一切世间一性非性。随顺众生示现有性。欲令众生超出三界。一向正趣无上菩提。救护拯济一切众生。未曾妄取世间之相。灭诸烦恼正观世间。大乘辔勒所行不乱。成就一切诸法善利。悉能分别众生善根。业报清净。智慧明了。等入三世。永离世间一切虚妄。放光明网普照十方。令一切众普见如来。分别一切十方佛刹。相好具足乐观无厌。菩萨所行功德智慧之所兴起。善能分别诸根境界。所行佛事不失其时。成就三世诸佛无量方便。慈悲普覆一切众生。周遍普降陀罗尼雨。皆令成就诸佛功德。无量妙色庄严佛身。十方众生靡不瞻睹。除灭一切世间障碍。分别诸法解真实义。成就功德自在法王。功德日王。普能照曜一切世间。最上福田。依因一切智慧缘生。化身充满一切世间。一一化身。普放无量智慧光明。无碍天缯冠顶法王。功德无量悉能随顺分别世间。无上导师开化群生。如来智慧。一切世间无畏之乘。一切世间无上医王。了知众生所病轻重。永离痴冥坚固不退。净慧眼藏。善能分别一切世间。开示众生一切业报。众生病苦悉能除灭。无量方便而度脱之。随其所应常不失时。等观众生远离诸恶。示现业报犹如幻化。随其所应为现佛身。普令众生悉见导师。分别世间一切诸法。欢喜敬佛长养善根。得不退转。随彼所业皆分别知。一切众生长眠生死。如来出世能觉悟之。安慰世间令无怖畏。心无所著无能坏者。安住智慧方便具足。如来最胜严净众生。智慧山王开净法门。或现佛身或现菩萨。开导众生。远离众恶安置善地。无量功德庄严佛身。业行所成示现世间。一切智慧得到彼岸。成佛道时悉令清净。能满世间一切所愿。开示世间坚固善友。光明清净遍照十方。普为众生示现其身。灭除无量众生悭垢。悉令众生善根清净。随其所愿皆得满足。等观众生无上中下。摄取善根起清净业。降伏众魔除灭烦恼。出生无量无碍之力。一切世间净光明王。无碍慧日照除痴冥。常以法施一切众生。无量无边如来智藏。光明清净普照十方。令一切众生远离怨仇。随其所愿皆悉充满。最胜福田靡不归依。果报无量具足清净。少修善根获大功德。安置众生无尽智地。一切善根皆由心起。无量欢喜清净功德。能除众生恶道诸难。如是正念如来。如是观察正觉。如是入智慧渊。如是入功德海。如是至虚空智慧。如是知众生福田。如是正知如来。如是观察净业相好。如是正知法身普照十方。如是知佛示现一切不可思议自在神力。尔时诸天。见如来身一一毛孔。出阿僧祇亿那由他光明。一一光明。有阿僧祇妙色。阿僧祇清净照明阿僧祇佛刹。阿僧祇众生。阿僧祇欢喜长养阿僧祇佛勇猛精进净阿僧祇寂灭三昧。阿僧祇诸根清凉柔软。阿僧祇恭敬如来。尔时诸天。复见佛身。出不可思议杂色光明轮。一一光明轮。有不可思议色。不可思议照明。普照十方无量无边一切法界。示现如来无量无数自在神力。众生皆闻清净妙音。又自然出不可思议偈。宣扬演说出世间法。具足成就离世善根。显现阿僧祇亿那由他不可思议上妙庄严。不可思议劫赞叹光明不能穷尽。从如来无尽自在中生。悉普照现不思议刹。诸佛出世。安立众生于智慧门。入真实义。显现不可思议如来化身。普照无量无数不可思议诸佛世界及诸法界。十方一切世界。究竟法界虚空界。持一切世界故起。普令众生清净平等从如来无碍一切智佛所住生。又佛身中。出无量无数不可思议妙宝光明。本于无量无数不可思议诸如来所修功德故。得是光明。清净大愿善根所起。无量佛所修习清净不放逸行。一向专求无上菩提。得是光明。出生无量无碍善根。普令众生于如来所。除灭疑惑得见如来。又睹自在神力。安立无量众生胜善根门。度众生海。于一切佛刹。为诸菩萨。演说诸佛不思议法。尔时如来。以大慈悲普覆一切。示现一切智慧庄严。欲令无量无边不可思议诸佛世界一切众生。未信者信。已信者增长善根。已增长者令其清净。已清净者令其成熟。已成熟者令其解脱。得甚深法。具足无量智慧光明。满足誓愿。一切智心坚固不转。不坏法性。闻真实际而不惊怖。具足解达如来实法。满足一切诸波罗蜜。成就清净出世善根。具足修习普贤所行。成就如来无量自在。远离魔界入佛境界。解甚深法得不思议智。大乘弘愿坚固不转。常见诸佛得无量智。无量无边功德藏力。发胜妙心离疑网地。灭恶清净常依如来。于真实法坚固不转。得入一切诸菩萨众。常在三世诸如来家。如来显现如是等类。无量无数清净善根。调伏众生。悉欲令彼知佛功德。照明一切无碍慧藏。如来不可思议大神通力。于一切趣普现自在。本所志愿皆悉满足。具足净慧。究竟诸佛最胜善逝。成就法王一切自在。具足出生一切智门。成就最胜清净法身。三世诸佛功德平等。一切世间无能为谕。相好严身具足诸力。见无厌足。于一切劫。称说如来智慧功德。自在示现不可穷尽。一切菩萨不能究竟。普为众生圆满慧日。灭三世闇。逮得法王神力自在。出生无量清净功德。尔时兜率天王。为如来设如是等诸供具已。与无量无数阿僧祇兜率陀天子俱。恭敬合掌。白佛言。善来世尊。善来正觉。唯愿哀愍处此宫殿。尔时世尊。以佛庄严而自庄严。众生见者无不敬乐。一切菩萨之所愿求。令兜率诸天皆大欢喜。普令众生修佛境界种佛善根。功德无尽。逮得清净不可坏信。常供养佛心无厌倦。正心清净发起众生。求一切智故。受兜率天王请。即升一切宝庄严殿如意宝藏师子之座。如此世界四天下兜率天宫如来受请。升一切宝庄严殿如意宝藏师子之座。一切十方诸四天下兜率天宫一切宝庄严殿如意宝藏师子之座。亦复如是。尔时一切宝庄严殿。自然殊特。妙宝庄严。出过诸天庄严之上。一切宝网弥覆其上。普雨一切妙宝云雨。一切宝庄严云雨。一切宝衣云雨。一切栴檀云雨。一切坚固香云雨。一切杂宝庄严云雨。不可思议众华云雨。自然演出不可思议妓乐音声。宣扬如来一切种智微妙法言。如是一切诸供养具。悉过诸天所供养上。尔时佛威神力。为兜率天王故。一切音乐寂然无声不复扰乱天王正念。长养善根增益大心。勇猛精进甚大欢喜。正心清净。即发无上菩提之心。于诸法门总持不忘。尔时兜率天王。承佛神力。即自忆念过去佛所所种善根以偈颂曰

  无碍如来犹满月　　诸吉祥中最第一
  来入众宝庄严殿　　是故此处最吉祥
  无边如来智甚深　　诸吉祥中最第一
  来入清净金色殿　　是故此处最吉祥
  普眼如来甚明净　　诸吉祥中最第一
  来入宝藏莲华殿　　是故此处最吉祥
  珊瑚如来色鲜洁　　诸吉祥中最第一
  来入清净宝藏殿　　是故此处最吉祥
  最胜如来论师子　　诸吉祥中最第一
  来入因陀宝山殿　　是故此处最吉祥
  满月如来德无量　　诸吉祥中最第一
  来入妙宝华藏殿　　是故此处最吉祥
  无量如来光无际　　诸吉祥中最第一
  来入宝树庄严殿　　是故此处最吉祥
  宝幢如来离疑惑　　诸吉祥中最第一
  来入妙宝庄严殿　　是故此处最吉祥
  无量慧佛人师子　　诸吉祥中最第一
  来入香山庄严殿　　是故此处最吉祥
  功德如来光普照　　诸吉祥中最第一
  来入胜宝庄严殿　　是故此处最吉祥

如此间兜率天王承佛神力。忆念过去诸等正觉以偈赞叹。如是十方一切世界兜率天王。各自忆念过去佛所所种善根。以偈赞叹亦复如是。尔时世尊。升一切宝庄严殿如意宝藏师子之座。结跏趺坐。清净法身。三世诸佛境界自在。皆悉平等。一向寂静。以一切诸佛庄严。而自庄严。无量无数不可思议清净大菩萨众。悉从他方世界来集。如来知时而为说法。法身不二无所染着。诸佛所起。如来法身离诸所行。尔时一切宝庄严殿。自然无量无数不可思议阿僧祇诸供养具。殊特奇妙。出过诸天所供养上。所谓华鬘涂香末香。宝衣幢盖缯幡。种种众宝妓乐。恭敬供养赞叹如来。如是等不可思议一切供养诸庄严具。如此世界四天下兜率天宫。一切宝庄严殿如意宝藏师子之座。一切十方诸佛世界。亦复如是

大方广佛华严经卷第十三大方广佛华严经卷第十四

        东晋天竺三藏佛驮跋陀罗译

    兜率天宫菩萨云集赞佛品第二十

尔时佛神力故。十方各过万佛世界尘数刹外。彼有世界。名坚固宝。次名坚固乐。次名坚固宝王。次名坚固金。次名坚固摩尼。次名坚固金刚。次名坚固莲华。次名坚固青莲华。次名坚固栴檀。次名坚固香。其佛号寿无尽幢。次号风幢。次号清白幢。次号威仪幢。次号明相幢。次号常幢。次号上幢。次号自在幢。次号梵幢。次号宁泰幢。彼诸菩萨名字悉同。其名曰金刚幢。次名坚固幢。次名勇猛幢。次名夜光幢。次名智幢。次名宝幢。次名精进幢。次名离垢幢。次名真实幢。次名法幢。彼诸菩萨。各于其国佛所。净修梵行。一一菩萨。各将万佛世界微尘数等菩萨眷属。来诣佛所稽首礼敬。佛神力故。随所来方。化作如意宝藏师子之座。充满十方。结跏趺坐。白净宝网以履其身。又放阿僧祇千亿那由他光明。离垢光明无量光明。普照十方。以正直心摄取三宝。远离诸恶。菩萨大愿之所兴起。一切众生观无厌足。见者不虚无不调伏。显一切佛自在净法。为一切众生作归依处。劝化令发菩萨大愿。此诸菩萨。皆悉成就无量法门。所谓遍游十方一切佛刹无所障碍神足法门。见净法身无著法门。住持慧身能为无数变化之身。往诣无量佛所法门。入无量无边不可思议如来自在法门。无量无边一切智法门。无量光明普照诸法无畏方便法门。尽未来劫分别演说诸功德藏无尽辩法门。一切陀罗尼慧光普照法门。成就清净慧眼普观法界法门。智慧境界无量无边无缚无著究竟如虚空法门。如此世界兜率天宫菩萨云集。一切世界诸四天下兜率天宫云集菩萨。所从来国诸佛名号亦复如是。尔时世尊。从两膝放百千亿那由他光明。普照十方虚空法界等一切世界诸四天下兜率天宫。一切如来神力自在皆悉显现。彼诸菩萨其有得见如来神力自在者。皆是卢舍那如来应供等正觉。行菩萨道。修习无量诸法门时善知识也。是诸菩萨。常乐诸佛甚深解脱自在神力。得不坏法界身。得无碍三昧。见不思议佛心无所著。以无碍心充满法界。离垢宝心。常为诸佛之所护念。得佛无量住持神力。决定究竟到于彼岸。清净正念速成等觉。得诸如来心之原底。入深智慧而得自在。于甚深智究竟彼岸。清净法身住佛所住。得一切智与如来等。从智宝起。皆于如来妙趣中生。开发清净智慧法门。究竟金刚大智彼岸。成就金刚方便三昧。永离一切愚痴闇冥。教化成熟无量无边无数众生。诸佛一切决定自在。究竟彼岸。不着一切数。善学一切数。究竟一切数智。善住真实法。成就如是等无量无边不可称数不可穷尽不可言说诸功德藏。尔时金刚幢菩萨。承佛神力。普观十方。以偈颂曰

  如来不出世　　亦无有涅槃
  以本大愿力　　显现自在法
  是法难思议　　非心之境界
  究竟彼岸智　　乃见诸佛境
  色身非如来　　音声亦如是
  亦不离色声　　有佛自在力
  少智不能知　　甚深佛境界
  成就本业智　　乃达诸佛境
  诸佛无来处　　去亦无所至
  清净妙法身　　显现自在力
  无量世界中　　示现如来身
  广说微妙法　　其心无所著
  无量无边慧　　诸法无障碍
  入于深法界　　显现自在力
  众生及诸法　　了达无障碍
  变化身无量　　普现一切刹
  欲求一切智　　自然成正觉
  先当净其心　　具修菩萨行
  如是见如来　　无量自在力
  除疑常亲近　　无上善知识

尔时坚固幢菩萨。承佛神力。普观十方。以偈颂曰

  最上无过者　　甚深不可说
  一切语言断　　清净如虚空
  谛观人师子　　无量自在力
  诸佛无虚妄　　世间生妄想
  导师所演说　　其法甚深妙
  随顺因缘起　　如来清净身
  斯等大乘智　　诸佛之境界
  若欲求此智　　常应亲近佛
  清净心供养　　一切诸导师
  心常无厌足　　究竟成佛道
  无尽功德藏　　增长菩提心
  远离诸疑惑　　观佛无厌足
  究竟一切法　　法化生佛子
  彼悉能解了　　诸佛自在力
  智慧王所说　　欲为诸法本
  应起清净欲　　志求无上道
  若能敬诸佛　　知报如来恩
  彼人未曾离　　一切诸导师
  如是得见闻　　诸佛及佛法
  具足清净愿　　究竟无上道

尔时勇猛幢菩萨。承佛神力。普观十方。以偈颂曰

  有眼有日光　　能见细微色
  最胜神力故　　净心见诸佛
  勇猛勤方便　　能尽海原底
  智慧力如是　　究竟诸佛海
  譬如好良田　　植种必滋繁
  如是净心地　　出生诸佛法
  如贫得宝藏　　除灭饥寒苦
  菩萨得佛法　　离垢心清净
  譬如伽陀药　　能消一切毒
  天尊亦如是　　灭除烦恼毒
  因缘善知识　　生长信佛心
  因缘善知识　　得闻诸佛法
  无量无数劫　　常行无上施
  若能化一人　　功德超于彼
  如来相庄严　　功德难思议
  诸佛功德藏　　一切莫能知
  如来等正觉　　不起于一座
  悉能遍十方　　一切诸世界
  譬如虚空性　　不生亦不灭
  诸佛法如是　　亦复无生灭

尔时夜光幢菩萨。承佛神力。普观十方。以偈颂曰

  十方诸世界　　一切群生类
  普见天人尊　　清净妙法身
  譬如一心力　　能生种种心
  如来一法身　　出生诸佛身
  菩提无二法　　亦无有自性
  无二净法身　　庄严无不现
  究竟如虚空　　犹如幻化现
  功德不可尽　　其唯诸佛境
  三世一切佛　　法身悉清净
  随其所应化　　普现妙色身
  未曾生想念　　我为如是像
  远离诸希望　　自然应众生
  不坏诸法性　　亦不着法界
  应现种种形　　教化众生故
  法身非变化　　亦非非变化
  诸法无变化　　示现有变化
  正觉不可量　　究竟等法界
  深广无涯底　　言语道悉断
  一切趣道法　　如来知实义
  游行一切刹　　未曾有障碍

尔时智幢菩萨。承佛神力。普观十方。以偈颂曰

  入于深智慧　　一切无障碍
  其心无齐限　　修习菩萨行
  普于十方刹　　常见一切佛
  彼佛无处所　　法亦无所著
  一一诸如来　　自在力无量
  不可思议劫　　说之无穷尽
  三世诸众生　　悉可知其数
  导师功德藏　　其数不可尽
  无二不思议　　应现种种身
  十方无不见　　未曾有别异
  譬如净满月　　普现一切水
  影像虽无量　　本月未曾二
  如是无碍智　　成就等正觉
  应现一切刹　　佛身初无二
  非一亦非二　　亦复非无量
  随其所应化　　示现无量身
  佛身非过去　　亦复非未来
  一念现出生　　成佛入涅槃
  譬如幻化色　　不生亦不灭
  佛身亦如是　　寂然无生灭

尔时宝幢菩萨。承佛神力。普观十方。以偈颂曰

  如来身无量　　众生见有量
  随彼所应化　　导师为现身
  法身无处所　　充满十方界
  佛身难思议　　如空无分际
  彼无心意识　　亦无起心想
  诸佛之境界　　究竟无生灭
  譬如无目人　　不睹内外色
  如来不出世　　不见一切法
  饶益众生故　　如来出世间
  众生见有出　　而实无兴世
  佛刹非如来　　昼夜亦如是
  年月至一念　　悉非等正觉
  众生咸说言　　佛日出世间
  导师自觉悟　　如来非净日
  虚妄无所有　　言语道悉断
  三世诸如来　　出世亦如是
  譬如清净日　　不与昏夜俱
  而说日夜相　　诸佛亦如是
  三世一切劫　　不与如来俱
  而说三世佛　　导师法如是

尔时精进幢菩萨。承佛神力。普观十方。以偈颂曰

  一切诸导师　　身同义亦然
  普于十方界　　随应各别异
  观察牟尼尊　　境界甚深妙
  充满诸法界　　一切悉无余
  如来净法身　　非是内身数
  如来净法身　　亦非外身数
  随彼众生行　　种种无量业
  是故见如来　　各各悉不同
  如来妙法身　　一切莫能数
  甚深难思议　　唯是佛境界
  如我非境界　　思量所不及
  佛法身如是　　一切莫能测
  如刹难思议　　而见净庄严
  佛身亦如是　　妙相无不现
  犹如一切法　　因缘和合生
  如是因缘会　　得见诸如来
  譬如随意珠　　悉满众生意
  诸佛法如是　　能满一切愿
  无量世界中　　导师兴于世
  如来本愿力　　普应十方界

尔时离垢幢菩萨。承佛神力。普观十方。以偈颂曰

  诸佛智慧光　　圆满净世间
  能净世间已　　令入诸佛法
  设有人欲见　　众生数等佛
  如来一切应　　而实无来处
  专念佛境界　　生起无量心
  所见诸如来　　其数与心等
  具足白净法　　名闻满十方
  彼于一切智　　其心安不动
  导师为众生　　如应演说法
  随所宜见处　　普现最胜身
  佛身非我所　　世界亦如是
  说心非我所　　觉无我菩提
  一切人师子　　无量自在力
  示现念等身　　种种相庄严
  世间则是身　　身即是最胜
  知身真实性　　是佛无碍智
  一切知见人　　普明照诸法
  佛法及菩提　　求悉不可得
  导师无来去　　亦复无所住
  远离诸颠倒　　清净等正觉

尔时真实幢菩萨。承佛神力。普观十方。以偈颂曰

  正觉游十方　　一切诸世界
  不离于一刹　　普现诸国土
  如来自在力　　应现一切身
  得道转法轮　　究竟般涅槃
  谁为思议佛　　谁为不思议
  谁见诸如来　　谁为等正觉
  一切法皆如　　诸佛境亦然
  乃至无一法　　如中有生灭
  众生虚妄故　　是佛是世界
  若解真实者　　无佛无世界
  令众欢喜故　　普现一切前
  如来所现身　　毕竟不可得
  远离一切障　　无碍安隐住
  除灭诸留难　　具足诸佛法
  一切诸如来　　神通力自在
  悉于三世中　　求之不可得
  如是知心识　　明解一切法
  一切知见人　　速成等正觉
  如来自在力　　但有假言说
  诸佛及自在　　一切言语断

尔时法幢菩萨。承佛神力。普观十方。以偈颂曰

  宁于无量劫　　具受一切苦
  终不远如来　　不睹自在力
  无量生死中　　未曾发道心
  若闻见如来　　具足佛菩提
  聪达明慧者　　若发一道心
  汝莫生疑惑　　自谓不成佛
  无量无数劫　　菩提心难得
  若能一心求　　究竟无上道
  设于念念中　　供养无量佛
  不知是方便　　彼犹非供养
  若闻如是法　　诸佛从此生
  无量劫受苦　　决定求菩提
  一闻摩诃衍　　诸佛所乘乘
  一切法界中　　三世为导师
  虽尽未来劫　　一切诸佛刹
  不解方便者　　终不成菩提
  过去无量劫　　流转于生死
  不知真实法　　如来所起处
  诸法不可坏　　亦无坏法者
  照明诸世间　　示现自在法

    大方广佛华严经金刚幢菩萨十回向品第二十一之一

尔时金刚幢菩萨。承佛神力。入菩萨明智三昧正受。入正受已。十方各过百万佛刹微尘数等世界之外。各见百万佛刹微尘数诸佛。是诸如来悉号金刚幢。时彼诸佛告金刚幢菩萨言。善哉善哉。佛子。乃能入是菩萨明智三昧正受。善男子。十方各百万佛刹微尘数等世界诸佛加汝神力故。乃能入是三昧正受。又卢舍那佛本愿力故。威神力故。汝智慧清净故。诸菩萨善根力故。欲令菩萨得清净无所畏故。得无碍不断辩故。入无碍智地故。入佛一切智广大心故。具足无尽诸善根故。满足无碍白净法故。入普门法界故。显现一切佛神力变化故。净念过去际智慧不断故。分别一切佛住持诸根故。以无量法门广说法故。闻持了知无量法故。具足演说十回向故。摄取一切菩萨诸善根故。安住出世间法故。一切智不断绝故。开发大愿故。入真实义故。知法界故。令一切菩萨悉欢喜故。修一切佛同善根故。护持一切如来性故。善男子。汝当承佛神力演说此法。安住佛家故。长养出世间诸功德故。入陀罗尼光明故。入诸佛不灭度法故。普照法界故。积集白净离恶法故。住广智慧境界住故。住无障碍法光明住故。尔时诸佛。即与金刚幢菩萨无量智慧。与善方便分别句身无留碍辩。与无障碍法明。与一切如来所共之身。与无量微妙音声。与诸菩萨不可思议三昧方便。与等心回向善根智慧。与观察一切法出生无量方便。与一切处说法无断辩才。何以故。彼三昧善根力故。尔时诸佛。各申右手。摩金刚幢菩萨顶。摩其顶已。时彼菩萨即从定起。告众菩萨言。佛子。是菩萨摩诃萨不可思议大愿。悉普救护一切众生。菩萨摩诃萨。立此愿已。修学三世诸佛回向。佛子。何等为菩萨摩诃萨回向。菩萨摩诃萨回向有十。去来今佛悉共演说。何等为十。一者救护一切众生离众生相回向。二者不坏回向。三者等一切佛回向。四者至一切处回向。五者无尽功德藏回向。六者随顺平等善根回向。七者随顺等观一切众生回向。八者如相回向。九者无缚无著解脱回向。十者法界无量回向。佛子。是为菩萨摩诃萨十种回向。三世诸佛所共演说。佛子。何等为救护一切众生离众生相回向。此菩萨摩诃萨。行檀波罗蜜。净尸波罗蜜。修羼提波罗蜜。行毗梨耶波罗蜜。入禅波罗蜜。分别般若波罗蜜。修行积集慈哀愍悲欢悦喜堪忍舍。修如是等无量善根。修善根已。作如是念。我所修习善根。悉以饶益一切众生究竟清净。以此所修善根。令一切众生皆悉除灭地狱饿鬼畜生阎罗王等无量苦恼。复作是念。我以此善根回向。为一切众生作舍。令灭苦阴故。为一切众生作护。令解脱烦恼故。为一切众生作归。令离恐怖故。为一切众生作趣。令至一切智地故。为一切众生作安隐。令得究竟安隐处故。为一切众生作大明。令灭痴冥得慧光故。为一切众生作炬。令灭无明闇故。为一切众生作灯。令得安住究竟明净故。为一切众生作导。令入方便法故。为一切众生作主宝臣。令得无碍净智身故。佛子。菩萨摩诃萨。以如是等无量善根回向。令一切众生究竟一切智。佛子。此菩萨摩诃萨为怨亲故。以诸善根回向等无差别。何以故。菩萨摩诃萨。入平等观无怨亲故。常以爱眼视诸众生。若众生怀恶。于菩萨所起怨逆心。菩萨摩诃萨。为一切众生作善知识。广为分别诸深妙法。譬如大海一切众毒所不能坏。菩萨亦复如是。一切童蒙愚痴无智不知报恩。嗔恚贡高破戒生盲。如是等类无量过恶。不能动乱菩萨道心。譬如日天子出普照天下。不以盲人故隐而不现。又复不以乾闼婆城四域尘曀。阿修罗障阎浮树荫及余山障。如是等类无量障蔽故。隐而不现。菩萨摩诃萨亦复如是。常正忆念未曾散乱。深广安谛心无忧戚。正意思惟。悉欲究竟功德智慧。清净法光普照世间。示真实义。净修一切诸法智门。为诸众生常修善根。一切众生有无量恶。菩萨摩诃萨。不以恶众生故嫌恨退没不行回向。不以难调伏众生故退舍善根不行回向。虽有众生邪见嗔浊。于大庄严其心不转。不舍大愿救护众生。若见众生浊恶无信不知报恩。修习菩提未曾懈废。若与愚痴童蒙共事。心无忧恼。何以故。我以明净圆满慧日。出于世间。清净调伏一切众生。菩萨摩诃萨。不为一众生故发心求阿耨多罗三藐三菩提。善根回向。不为严净一佛刹故。不为信一佛故。不为见一佛故。不为闻一佛法故。不为满足一愿故。菩萨摩诃萨。悉欲救护一切众生故。以善根回向。具足严净一切佛刹。信一切佛见一切佛。恭敬供养一切诸佛。闻一切佛所说正法。满足一切大愿故。以诸善根。回向阿耨多罗三藐三菩提。菩萨摩诃萨。复作是念。发菩提心宝。即是如来境界之力。广大平等无有懈怠。于一切劫修学难得与诸佛等。菩萨摩诃萨。如是观诸善根。信心清净。长养大悲。以诸善根。普为众生深心回向。非但口言。于诸众生发欢喜心。明净心。柔软心。慈心。爱念心。摄取心。饶益心。安乐心。最胜心。以诸善根回向。菩萨摩诃萨。以诸善根回向时。作如是念。若我所有回向功德。令一切众生。得清净趣。得清净生。功德满足。一切世间无能坏者。不可穷尽。常得尊重心不错谬。分别了知一切诸趣。思量诸佛。具足庄严身口意业。具足庄严一切功德。复作是念。以此善根回向功德。令一切众生常见诸佛。于彼佛所得不坏信。于诸佛所听受正法离诸疑惑。忆持不忘如说修行。于如来所得柔软心净身口业。心常安住胜妙善根。永离贫法七财满足。修学一切诸佛所学。得诸善根。成就平等净妙解脱。一切种智。于一切众生得慈爱眼。其身清净相好庄严。言论辩慧功德具足。调伏诸根成就十力。发起诸善。心住满足。无所染着。令一切众生具佛快乐。得无量住住佛所住。此菩萨摩诃萨。复作是念。一切众生造作无量诸不善业。因是业故受无量苦。不见如来。不闻正法。不识净僧。此诸众生。具有无量大恶罪业。应受无量无边楚毒。我当于彼三恶道中悉代受苦令得解脱。我当代受无量苦恼。不以苦故其心退转恐怖懈怠舍离众生。何以故。我为众生荷负重担。满平等愿。度脱一切生老病死愁忧苦恼无量诸难。流转生死一切邪见。失诸善法愚痴无智。我当悉度免此众苦。众生常为爱网所缠。无明覆蔽染著有爱。为之走使不得自在。缚在苦狱随诸魔业。于诸佛所心生疑惑。不得出世道。不见安隐处。常驰无量生死旷野。受无量苦。菩萨摩诃萨。见彼众生没生死泥受众楚毒。起大悲心。饶益众生令得善利。免度苦难。善根回向。以大回向回向。如三世菩萨回向。如诸佛所说大回向经回向。令一切众生悉得清净。具足善根究竟一切智。复作是念。我当悉令一切众生得无上智王。安隐住处。不为自度。但欲令彼出生死渊。得一切智心。拔出众生恶道崄谷。救无量苦度生死流。复作是念。我当为一切众生受无量苦。令诸众生悉得免出生死沃焦。我当为一切众生。于一切刹一切地狱中。受一切苦。终不舍离。我当于一一恶道尽未来劫。代诸众生受无量苦。何以故。我宁独受诸苦。不令众生受诸楚毒。当以我身免赎一切恶道众生。令得解脱。菩萨摩诃萨。复作是念。我悉当为一切众生。作诚实语者。离恼害心不舍众生。何以故。我因众生发菩提心。度脱一切。不求尊贵。不求五欲。不求世间种种乐故。行菩萨道。何以故。五欲是世间法。诸魔境界。愚人所行诸佛诃责。彼能出生一切苦恼地狱饿鬼畜生阎罗王处。忿恚斗诤更相讼说。皆由五欲。积习五欲远离诸佛。能障生天况无上道。菩萨明见五欲有如是等无量过患。是故不以五欲修菩萨行。但欲饶益安隐众生。发菩提心求无上道。令一切众生得一切利具诸大愿。断绝众生烦恼钩饵。离无量苦。菩萨摩诃萨。复作是念。我当以诸善根回向。令一切众生得种种乐。究竟乐。饶益乐。不共乐。寂静乐。无染乐。无动乐。无量乐。不死不转乐。不灭乐。一切智乐。我当为一切众生作调御师。作主藏臣。作大明炬示安隐趣。令离诸难解一切法。我当令解诸甚深义。我当为作一切智船度生死海。我当令知无量善根回向。我当悉为示现彼岸。菩萨摩诃萨。以是无量善根回向。救护一切度生死海。令诸如来皆悉欢喜得一切智。舍离众魔远恶知识。亲近菩萨胜善知识。成就净业尽灭众恶。具足菩萨无量愿行一切善根。菩萨摩诃萨。以诸善根正回向已。作如是念。不以四天下一一众生故一一日出。但一日出世。悉能普照一切天下。又诸众生。不以自身光明知有昼夜。游行观察兴造诸业。皆由日天子出普照天下。一切众生无业不就。菩萨摩诃萨亦复如是。修诸善根回向。普为众生作如是念。彼诸众生无智慧光。尚不自照何况照他。唯我一人志独无侣。修诸善根回向。欲为度脱一切众生。普照一切众生。分别一切众生。了达一切众生。令一切众生入甚深法。摄取一切众生。成就一切众生。悦乐一切众生。柔软一切众生。灭除一切众生疑惑。菩萨摩诃萨。复作是念。我当修学如日天子普照一切不求恩报。不为恶众生故舍大庄严。亦不以一恶众生故舍离一切而不度脱。但勤修习善根回向。欲令众生得一切乐。摄少善根回向广大。若诸善根不能饶益众生者。我终不以善根回向。以诸善根悉与众生发心回向。令一切众生不着诸法故回向。以众生性回向而无所至。菩萨如是回向。亦无所著不取所有性。安住诸善根。不取相回向。业报虚妄无所有。亦无所著。不取五阴相回向。不坏五阴相回向。不取虚妄业回向。不求报。不起虚妄因缘。不生不起不住。不住坚固相。不住虚妄法。不取众生相。不分别世界。不住心颠倒想颠倒见颠倒。不着语言道。但欲令众生解真实法回向。观察一切众生平等回向。法界印印诸善根回向。离欲等法观察善根回向。解一切法。离于颠倒。得诸善根。以无二法观察法界回向。彼回向不生诸法。不灭诸法。以如是等善根回向。修行清净诸对治法回向。观一切善根。皆悉回向出世间法。于彼善根不作二相。萨婆若非即是业。亦不离业回向。观察萨婆若。不即是业。亦不离业。得萨婆若。愿智业照明清净故。报亦照明清净。报照明清净故。萨婆若亦照明清净。舍离一切动乱觉观憍慢放逸。随方便智。以诸善根回向。令一切众生。悉得真实究竟解脱。不着法性。无量无边善根回向。诸法无业报。而出生业报。菩萨摩诃萨。以如是等善根回向。则能永离一切诸恶。佛所赞叹。佛子。是名菩萨摩诃萨第一救护一切众生离众生相回向

尔时金刚幢菩萨。承佛神力。普观十方及一切众。观察法界入深句义味。大悲普覆一切众生。护持三世佛种不断。入一切佛诸功德藏。出生诸佛清净法身。善能分别诸众生心。过去所种一切善根。知时不失。具足法身。善能示现清净色身。以偈颂曰

  不思议劫所修行　　常为饶益诸群生
  精进坚强意无碍　　常求诸佛妙功德
  其心清净离嗔恚　　恭敬供养调御师
  深解诸法救众生　　彼能善入回向藏
  勇猛精进力具足　　智力照明甚清净
  忍心坚固不倾动　　常能救护诸群生
  于无等所心安住　　踊悦欢喜意清净
  菩萨忍力如大地　　悉能饶益诸众生
  不以苦行自求乐　　大慈悲起无量行
  常能救护诸群生　　彼人速入无碍地
  十方一切诸世界　　其中众生皆摄取
  常为众生心安住　　修学无量诸回向
  以欢喜心行布施　　具足护持清净戒
  勇猛精进心坚固　　清净智慧善回向
  其心广大不可量　　忍力坚强常回向
  净修一切诸禅定　　智慧深妙难思议
  十方一切世界中　　具足修习清净行
  智慧回向诸功德　　以一切乐益众生
  彼人积集众善业　　无量无边不可数
  欲令众生具修习　　住不思议深妙智
  普为一切众生故　　不思议劫住地狱
  菩萨心常无懈怠　　决定功德常回向
  不求色声诸香味　　亦不希望一切触
  常求无上最胜智　　度脱一切诸群生
  菩萨智净如虚空　　普行无量大士行
  最胜所行净业道　　无量名称常修行
  菩萨游行诸世界　　常能安隐群生类
  悉令一切皆欢喜　　修菩萨行无厌足
  除灭一切心垢秽　　思惟修习无上智
  不自为己求安乐　　常欲利益诸群生
  菩萨回向到彼岸　　除灭无量心秽毒
  具足修习三世佛　　无量清净诸功德
  菩萨未曾染着色　　受想行识亦如是
  不住一切诸三界　　所有功德悉回向
  诸佛所知众生类　　皆悉摄取无有余
  究竟度脱诸群萌　　是名菩萨殊胜行
  菩萨一切心安住　　开悟弥广不可称
  离痴正念伏诸根　　身口意业常寂然
  一切内外所有法　　皆悉虚妄无真实
  如风行空无所碍　　菩萨心行亦如是
  所起身业常清净　　能令诸佛悉欢喜
  于最胜所言不虚　　意常专向诸如来
  十方无量诸世界　　所有最胜悉往诣
  于彼睹见大悲尊　　悉能恭敬供养之
  心常远离一切恶　　处大众中无所畏
  心常安住如来道　　彼为三有清凉池
  善修分析一切法　　具足了达诸有无
  善能趣向真法性　　深入无诤胜三昧
  修习菩萨坚固行　　一切众生莫能坏
  明学了达甚深义　　于三世法无所著
  究竟回向到彼岸　　普令众生悉清净
  远离一切诸染着　　菩萨所行无所倚
  一切众生语言法　　于彼智慧无障碍
  谈论巧妙无爱着　　心常安处无碍住
  菩萨如是行回向　　无量善心功德藏
  能令十方诸世界　　一切如来皆欢喜

佛子。何等为菩萨摩诃萨第二不坏回向。此菩萨摩诃萨。于去来今诸如来所得不坏信。一切诸佛皆悉欢喜。于诸菩萨所。乃至初发一念求菩萨善根及一切智。于彼菩萨得不坏信。悉于一切诸佛法中。一向直心而不可坏。于诸佛教得不坏信。守护一切诸如来法得不坏信。常以爱眼等观一切。以善根回向。令彼众生获诸善利得不坏信。于白净善根得不坏信。何以故。修集一切诸善根故。于一切菩萨回向得不坏信。直心解脱得满足故。于一切菩萨诸法师所得不坏信。具足起如来想故。于如来自在神力得不坏信。谛信诸佛难思议故。于一切菩萨方便得不坏信。摄取种种无量无数行境界故。佛子。菩萨摩诃萨。如是安住不可坏信。于诸佛菩萨声闻缘觉如来正教。一切众生如是等无量境界。种诸善根。分别诸善根。长养菩提心。修习大慈所生善根。广修大悲平等观察。学佛所学随顺诸佛。摄取一切清净善根。深入实义。集功德藏。行大惠施。修诸功德。等观三世。菩萨摩诃萨。如是等善根功德。回向一切智。常见诸佛亲近善知识。常与无量诸菩萨会。念萨婆若心无散乱。受诸佛教兴护法心。教化成熟一切众生。心常不离出世回向。供养守护一切法师。解了诸法。修习满足一切大愿。菩萨摩诃萨。如是精勤修习无量善根。积集长养善根。正念思惟观察境界真实等义。恭敬供养。威仪具足。善根回向。菩萨摩诃萨。善根回向已。作如是念。以此善根回向所得依果。令我修行菩萨行时。于念念中见一切佛。令彼诸佛皆悉欢喜。于诸如来应供等正觉。如佛所应而以供养。以阿僧祇宝。阿僧祇华。阿僧祇香。阿僧祇涂香。阿僧祇鬘。阿僧祇衣。阿僧祇盖。阿僧祇幢。阿僧祇幡。阿僧祇庄严。阿僧祇庄严具。阿僧祇供给。阿僧祇末香。阿僧祇信乐。阿僧祇敬念。阿僧祇净信。烧阿僧祇坚固香。阿僧祇上味饭食。阿僧祇恭敬。阿僧祇礼拜。阿僧祇一切宝座。阿僧祇一切华座。阿僧祇一切香座。阿僧祇一切鬘座。阿僧祇一切清净栴檀座。阿僧祇一切衣座。阿僧祇一切金刚座。阿僧祇一切摩尼宝座。阿僧祇一切宝缯座。阿僧祇一切宝色座。阿僧祇一切宝轮。阿僧祇一切华轮。阿僧祇一切香轮。阿僧祇一切鬘庄严轮。阿僧祇一切宝衣轮。阿僧祇一切宝庄严轮。阿僧祇一切宝缯敷轮建立。阿僧祇一切宝多罗高显轮。阿僧祇一切宝栏楯轮。阿僧祇一切宝网轮罗覆其上。阿僧祇一切妙宝宫殿。严饰殊特出过诸天。阿僧祇一切华宫殿。阿僧祇一切香宫殿。阿僧祇一切宝鬘宫殿。阿僧祇一切栴檀宫殿。阿僧祇一切坚固香藏宫殿。阿僧祇一切金刚宫殿。阿僧祇一切摩尼宝宫殿。皆悉殊妙出过诸天。阿僧祇诸杂宝树。阿僧祇种种香树。阿僧祇诸宝衣树。阿僧祇妙音乐树。阿僧祇妙音声树。阿僧祇无厌宝树。阿僧祇垂宝缯幡树。阿僧祇宝庄严树。阿僧祇一切华。一切鬘一切香。一切涂香。一切盖。一切幢。一切幡树。如是等诸妙宝树。庄严殊特。以用庄严无数宫殿。阿僧祇宝栏楯庄严。阿僧祇宝窗庄严。阿僧祇宝偏楼阁庄严。阿僧祇内帐庄严。阿僧祇半月庄严。阿僧祇楼阁庄严。阿僧祇宝帐庄严。阿僧祇白宝网。罗覆其上。烧阿僧祇坚固香。阿僧祇宝衣以敷其地。以如是等诸庄严具。庄严无数宫殿。出过诸天。以如是等上妙供养。于无量无数不可说不可说劫。调伏诸根。敬心供养一切如来。此诸最胜般涅槃后。供养舍利。欲令一切众生皆悉欢喜。摄取一切众生善根。令一切众生离无量苦发菩提心。令一切众生以大庄严而自庄严。无量庄严超出一切众生境界示现佛法难可值遇。满足阿僧祇诸如来力。清净信心供养导师。受持守护一切佛法。如是供养现在诸佛。及涅槃后供养舍利。于无量阿僧祇劫。说供养具不可穷尽。诸佛成就无量功德。教化度脱一切众生。我常供养彼诸如来。心不退转。无有休息未曾懈怠。不怀忧恼亦无所著无有心想。于诸法中而无所染无所依止。不昧善根离一切着。以实法印印业法门。生一切法。住佛所住。观无生性。境界法印印彼发心。受持如来清净回向。观察平等法性回向。入无行方便出生诸行心舍一切回向。无量方便回向。离一切有回向。安住离相方便修习法门善根回向。菩萨从初发心修习一切诸妙善根皆悉回向。以此善根于生死中而不可坏。求一切智心不退转。处一切有寂定不乱。度脱一切众生。不着生死。得无碍智门。修菩萨行。而彼善根不可穷尽。世间诸法所不能坏具足清净诸波罗蜜。究竟一切智力。菩萨摩诃萨。如是舍离痴闇成菩提心。普照一切长白净法。善根回向具足众行。清净直心观察平等。深入诸法知业如幻。业报如电。诸行如化。因缘生法如响。菩萨行如影。无著法眼之所出生。无作所作。其性寂灭。入有为无为。于一切法了达无二解如实性。分别菩萨一切行相。不着诸相。善知方便入同事业。不舍一切白净善法。离一切障无碍无著。常为诸佛之所护念。远离愚痴。如是菩萨摩诃萨。成就善根出生善法。不坏业报明见真实。善解回向。以方便力。出生业报。究竟法性。得到彼岸。了达诸法。回向大智。诸业善根。其心清净行无所行。菩萨摩诃萨。如是善根回向。欲度脱一切众生佛种不断。灭诸恶业业报。回向一切众生。得无量智成一切智。离世境界灭诸烦恼。究竟清净成就智慧。入深方便舍生死苦。成就诸佛无量善根。摧伏魔业。得平等法印以印诸业。随顺萨婆若无上菩提。菩萨摩诃萨。行如是善根回向。善根明净普照一切。具足成就萨婆若乘。佛子。是名菩萨摩诃萨第二不坏回向。菩萨摩诃萨。安住此回向。得见无量阿僧祇佛。悉得无量清净妙法。普于众生得平等心。舍离愚痴入一切法。得诸如来自在神力。降伏众魔灭诸魔业。具足生贵菩提之心。得无碍智不由他悟。于一切法见真实义。于一切佛刹悉能受持分别其相。智慧具足普照众生菩萨摩诃萨。以此不坏回向力。摄取一切善根回向。尔时金刚幢菩萨。承佛神力普观十方。乃至以偈颂曰

  修习无量无数业　　所乘坚固不可坏
  能令诸佛悉欢喜　　是名智者所回向
  所供养佛难思议　　布施持戒伏诸根
  彼为一切修回向　　清净无量众生故
  一切上妙诸华香　　无量无数众宝衣
  种种庄严及宝盖　　供养一切诸如来
  如是无量诸供具　　不可思议旷劫中
  恭敬供养调御师　　心常欢喜无厌足
  专心观察诸最胜　　一切世间大明灯
  现在十方一切佛　　皆悉睹见如目前
  不可思议无量劫　　修行布施无厌足
  不可思议无量劫　　修诸善根亦无厌
  善分别知诸心想　　如实观察无虚妄
  悉知诸根无有余　　常能饶益一切众
  心大欢喜无有量　　信心清净而恭敬
  不思议劫忍住世　　饶益救度一切众
  一切诸佛灭度已　　供养舍利无厌足
  悉以无量妙杂宝　　建立恒沙诸塔庙
  造作无数尊形像　　宝藏净金而庄严
  巍巍高大如山王　　其数无量不思议
  修学积集诸功德　　胜妙坚固不可坏
  菩萨善知行回向　　分别非有亦非无
  若能如是修回向　　功德无量不可尽
  胜妙智慧观诸法　　皆能了达无所生
  方便修习令心净　　悉与一切如来等
  以不可尽诸方便　　回向无尽如来藏
  发起无上菩提心　　一切世间无所依
  普至十方诸世界　　于一切众心无碍
  方便启导众生心　　悉令出生佛菩提
  观察众生心平等　　推求真实不可得
  一切诸法悉无余　　了达其性无所有
  回向无著清净眼　　永离一切世间苦
  欲令诸有悉清净　　心不妄取诸法相
  分别所有无所有　　能令心净大欢喜
  于一佛刹无所著　　了诸佛土无坚固
  不取一切有为法　　亦不染着法自性
  方便回向萨婆若　　无上智慧自庄严
  普令诸佛悉欢喜　　是为菩萨回向业
  菩萨一心念诸佛　　无上智慧巧方便
  如诸如来无所著　　令我悉获此功德
  常欲救护一切众　　远离无量诸恶业
  常行饶益众生心　　于饶益心无虚妄
  随所住地守护法　　示现涅槃实不灭
  一切如来无二法　　愿我回向亦如是
  一切世界诸趣中　　于有为法无所著
  菩萨不缘语言道　　亦不染着无语言
  十方一切诸如来　　悉摄诸法无有余
  离一切趣而受生　　于所离生无虚妄
  以一庄严一切严　　亦不分别此诸法
  了达世间悉虚妄　　一切所行无所有

大方广佛华严经卷第十四大方广佛华严经卷第十五

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之二

佛子。何等为菩萨摩诃萨第三等诸佛回向。此菩萨摩诃萨。随顺学过去未来现在诸佛回向。此菩萨。修菩萨行时。见好恶色。其心清净而无憎爱。欢喜悦乐起无坏心。离诸忧恼得正直心。身意柔软诸根清凉。此菩萨。得如是乐时。回向诸佛。作如是念。一切诸佛。虽有无上净妙快乐。复愿诸佛具不思议佛所住乐。具足摄取不可称量佛三昧乐。成就无量大悲快乐。具足成就不可计议佛解脱乐。具足摄取诸佛神足自在快乐。无上尊重最妙快乐。普覆如来常令具足诸佛无量力乐。永离一切诸觉之乐。无上寂静不变易乐。具足无碍法门。心常寂定而无散乱。佛无二行不可坏乐。菩萨摩诃萨。以如是善根。回向诸佛已。又复回向一切菩萨。令愿未满者悉令满足。未净直心者令净直心。未满诸波罗蜜者悉令满足安住金刚菩提之心。于一切智得不退转。不舍大庄严。守护菩提门及诸善根。能令一切众生舍离放逸。发菩提心所愿成满。安住一切菩萨所住。得诸菩萨明利诸根。修习善根。证萨婆若。如是菩萨摩诃萨。以诸善根回向菩萨已。又复回向。一切众生回向。一切众生见佛闻法敬心近僧回向。具足专心念佛回向。具足念净妙法回向。念僧尊重恭敬回向。见佛未曾远离回向。成就诸清净心回向。分别诸如来法回向。成就无量功德回向。清净诸通善根回向。除灭一切疑惑如佛回向。开化一切众生声闻缘觉及诸菩萨菩萨善根回向。一切众生亦复如是。令一切众生。永离地狱饿鬼畜生阎罗王处一切恶趣无量众难。菩萨摩诃萨。令彼一切众生。悉发无上菩提之心。长养无上菩提之心。一心专求一切种智。舍离诽谤诸佛正法。常乐具足一切智地。令一切众生。究竟清净得一切智。菩萨摩诃萨所行善根。以诸大愿。摄取行等行。积聚等积聚。长养等长养。皆悉广大具足充满。菩萨摩诃萨。若在家时。与妻子俱未曾暂离菩提之心。正念思惟萨婆若境界。自度度彼。直心平等。方便示现妻子眷属菩萨善方便智皆悉成就究竟解脱。虽与同止心无所著。以本大悲故处在家属。以大慈故随顺妻子。于菩萨净道无所障碍。菩萨摩诃萨。若在家时。应以如是萨婆若心善根回向。所谓被着衣裳。若饮若食。服诸汤药。行住坐卧身口意业具足清净。诸根调伏皆悉安谛。洗浴涂身寂静徐步。回旋顾眄举足下足。若眠若觉不失威仪。善摄诸根未曾散乱。菩萨摩诃萨。以如是等一切诸行。未曾远离萨婆若心善根回向。饶益安乐一切众生。无量诸愿皆悉成就。摄取无量广大善根。修习善根救护一切。除灭一切放逸憍慢。一心正念一切种智。欲觉一切诸佛菩提。舍离烦恼及顺烦恼法修习一切菩萨所学。于一切智道无所障碍。乐修智地及诸善根。常乐爱语增长善根。令一切众生永离苦恼不着所行。一心受持诸佛教法。是为菩萨摩诃萨处在家属摄取善根一心回向无上菩提。菩萨摩诃萨。复作是念。乃至小犬及余畜生。当令此等具足修习不放逸行。离畜生趣得饶益乐。究竟解脱永度苦海。苦受。苦阴。苦觉。增上大苦。苦行。苦藏。苦根。苦舍。如是等无量无边一切众苦。菩萨摩诃萨。欲令众生悉得除灭。以净善根回向无上菩提。教一切众生回向如是境界。正念思惟彼彼善根以为上首。所谓回向一切种智。发菩提心。摄菩提心。远离生死。修习善根。出生死渊。得诸如来无碍快乐。修如来慈充满十方。大悲饶益一切众生。普令一切得清净乐。守护一切诸胜善根。令一切众生究竟佛法。远离一切诸魔境界。入彼甚深如来境界。普能拔出一切世间。具足一切如来善根。住三世佛平等法中。如是菩萨摩诃萨今集善根。已集善根。当集善根。皆悉回向。复作是念。如彼过去菩萨所行。恭敬供养一切诸佛。度脱众生。救护一切修诸善根。回向菩提而无所著。不依色。不着受。不颠倒想不作行。不取识。离六入。不住世法。乐出世法。知法如空。究竟得至非趣彼岸。照解诸法不生不灭无真实相无所染着。一切诸法无有虚妄。无所归趣。无所破坏。安住实际。无有自性。离诸性故。于一念中解一切法。无性为性。常乐习行普门善根。具足如来圆满功德显现一切。如彼过去一切如来善根回向。我亦如是。乐如是法证如是法。如是发心。修习诸法不违法相。所有起法。犹如幻化电光水月镜中之像。因缘和合假持诸法。悉分别知从业因起。唯如来地是究竟处。菩萨摩诃萨。如是随学过去诸佛所学回向。未来现在。亦复如是。菩萨摩诃萨。学三世佛所学回向诸善根已。作如是念。如彼诸佛所知菩萨回向。我亦如是回向。第一回向。胜回向。最胜回向。上回向。无上回向。无等回向。无等等回向。无比回向。无对回向。尊回向。妙回向。平等回向。正直回向。大功德回向。大愿回向。明净回向。善回向。清净回向。离恶回向。不随恶回向。如是菩萨摩诃萨。以诸善根正回向已。成就清净妙身口意。所作行业皆悉清净。住菩萨住。离诸恶住。修习善根。离身口恶业。心无选择。修萨婆若。住无量住。入一切法空无自在。修出世法。于世间法心无染着。分别了知无量诸业。成就巧方便回向诸法心无所倚。佛子。是为菩萨摩诃萨第三等诸佛回向。菩萨安住此回向已。深入一切诸如来业。趣诸如来胜妙功德。入深清净智慧境界。不离一切诸菩萨业。善能分别巧妙方便。入深法界巧妙方便。次第成就菩萨善根。入于一切诸如来性。以巧方便分别了知无量无边一切诸法。虽复示现世界中生。于诸世界心无所著。佛子。是为菩萨摩诃萨等诸佛回向。尔时金刚幢菩萨。承佛神力普观十方。以偈颂曰

  彼诸菩萨摩诃萨　　修过去佛回向法
  亦学未来现在世　　无量导师之所行
  一切种种微妙乐　　诸佛如来所赞叹
  成就明净胜法眼　　回向一切诸导师
  菩萨身根种种乐　　眼耳鼻舌诸情根
  种种上妙无量乐　　回向一切诸最胜
  一切世间诸善根　　及诸如来所成就
  于彼悉摄无有余　　随喜回向益众生
  菩萨随喜无有量　　亦以回向一切众
  人中师子所有乐　　愿令众生悉具足
  诸佛如来所知见　　一切众生清净乐
  欲令众生皆悉得　　世界灯明所受乐
  菩萨所得种种乐　　回向诸佛为众生
  欲令众生常安隐　　于彼回向无所著
  菩萨修此回向时　　兴发无量大悲心
  如佛所知回向德　　令我具足悉成满
  如诸最胜所知见　　一切智乘微妙乐
  如我在世诸所行　　一切菩萨无量乐
  一切趣中众快乐　　柔软调伏诸根乐
  皆悉回向为众生　　普令成就无上智
  身口意净离诸恶　　巧妙方便心平等
  以此回向群生类　　悉令成就无上智
  菩萨所修诸行业　　积集无量净功德
  随顺如来生佛家　　寂然不乱正回向
  十方无量世界中　　摄取一切众生类
  无量善根悉回向　　普令众生得安乐
  不为己身自求乐　　欲令一切悉安隐
  远离一切虚妄心　　悉解诸法空无我
  十方无量诸最胜　　所见一切真佛子
  以诸功德回向彼　　速令究竟无上道
  一切世间众生类　　等心摄取无有余
  以我所行诸净业　　令彼众生速成佛
  无量无边清净愿　　无等最胜所演说
  皆悉清净离诸垢　　普令佛子究竟满
  一切功德尽回向　　悉令十方诸佛刹
  种种净妙而庄严　　菩萨如是学回向
  心不称量诸二法　　了达觉悟法无二
  诸法非二非不二　　不作虚妄是佛子
  一切世间所有想　　究竟悉度无有余
  亦不坏想及非想　　决定了知众生想
  彼诸菩萨身净已　　则意清净无瑕秽
  口业已净无散乱　　当知意净无所著
  一心正念过去佛　　分别未来诸导师
  现在十方天人尊　　菩萨遍学彼佛教
  三世无量诸最胜　　慧心明达无障碍
  所行无量求菩提　　回向饶益诸世间
  彼胜妙慧广大慧　　四真谛慧离倒慧
  平等实慧清净慧　　无比慧等皆回向

佛子。何等为菩萨摩诃萨第四至一切处回向。此菩萨摩诃萨。修习一切诸善根时。以彼善根。如是回向。令此善根功德之力至一切处。譬如实际无处不至。至一切世间。至一切有。至一切众生。至一切刹。至一切法。至一切虚空。至一切三世。至一切有为及无为法。至一切语言音声。我此善根亦复如是。遍至一切诸如来所。供养三世一切诸佛。过去诸佛所愿悉满。未来诸佛具佛庄严。虚空法界等世界中现在诸佛。及无量大众以为庄严。皆悉供养犹如诸天。于一念中。悉能充满无量无边一切世界广大功德智慧无碍善根回向故。菩萨摩诃萨。复作是念。以此善根虚空法界等一切世界。世界性种种业所起。十方不可说世界。不可说佛刹。种种世界诸佛境界。无分齐世界。转翻覆世界。伏世界。转世界。一切无余世界中。现在诸佛显现无量自在神力。彼有菩萨。解虚空法界等一切诸法。为诸众生。于一切世界中。现为如来出兴于世。示现至一切处智。无量无边自在受生。法身遍至不坏法界。平等普入同佛身藏。不生不灭普应一切。善巧方便出现世间。从真实法性起。坚固不转无碍所持。诸佛无碍功德所生。菩萨摩诃萨。于诸如来应供等正觉所。种诸善根。以众杂华种种诸香鬘盖幢幡珍宝灯明。以如是等诸妙供具。供养尊像及诸塔庙。以此一切善根回向。以一心。不乱心。不动心。尊重心。离嗔心。无住心。无著心。无众生心。无谄害心。寂静心回向。复作是念。虚空法界等一切劫中去来今佛。相好具足而自庄严。以妙法界庄严。而自庄严。彼佛眷属。充满虚空法界等一切世界。随时出世未曾失时。我以善根回向。供养诸佛。以无量香盖。无量香幢。无量香幡。无量香宫殿。无量香网。无量香像。无量香光。无量香焰。无量香云。无量香座。无量香轮。无量香住处。无量香佛世界。无量香须弥山王。无量香海。无量香河。无量香树。无量香衣。无量香莲华。以如是等无量无数众香庄严。以为供养以无量华盖。广说如上。乃至无量无数众华庄严。以为供养。以无数鬘盖乃至无数众鬘庄严。以为供养。以不可思议涂香盖乃至不可思议涂香庄严。以为供养。以不可称末香盖乃至不可称末香庄严。以为供养。以无分齐妙衣盖乃至无分齐妙衣庄严。以为供养。以无边宝盖乃至无边众宝庄严。以为供养。以无量灯盖乃至无量众灯庄严。以为供养。以不可说庄严具盖乃至不可说众庄严具。以为供养。以不可说不可说摩尼宝盖。如是摩尼宝幢。摩尼宝幡。摩尼宝帐。摩尼宝网。摩尼宝鬘。摩尼宝光。摩尼宝焰。摩尼宝云。摩尼宝座。摩尼宝轮。摩尼宝宫殿。摩尼宝世界。摩尼宝须弥山王。摩尼宝海。摩尼宝河。摩尼宝树。摩尼宝衣。摩尼宝莲华。如是等不可说不可说摩尼宝庄严。以为供养。于一一境界中。各有阿僧祇栏楯。阿僧祇庄严。阿僧祇宫殿。阿僧祇楼阁。阿僧祇偏楼阁。阿僧祇半月庄严。阿僧祇内小帏帐。阿僧祇窗牖。阿僧祇清净宝。阿僧祇一切宝庄严。清净一切世界悉无有余。如是庄严。令一切众生。超出生死。成就如来十种力地。于诸法中得无碍法明。教化众生一切善根回向。调伏众生无量心。充满虚空法界等一切佛刹法无所至。出生三世无量善根。令一切众生悉得睹见无量诸佛。安住一切诸善根中。成就大乘不着诸法。具足诸善根。究竟无量行。普入无量无边一切法界善根回向。入一切如来自在神力。令一切众生。因此善根得萨婆若成无上道。譬如无我不离诸法。我诸善根亦复如是。摄取一切佛。恭敬供养故。摄取一切法。离障碍故。摄取一切菩萨。究竟一切同善根故。摄取菩萨一切行。满诸愿故。摄取菩萨一切法明。决定无碍故。摄取一切佛自在神力。成就无量诸善根故。摄取一切佛力无所畏。发无量心满一切故。摄取一切善萨三昧辩才陀罗尼门。解了世间无二法故。摄取一切佛巧妙方便。示现如来大神力故。摄取三世一切诸佛出生得道转净法轮示现涅槃。兴发供养化众生故。摄取一切世界。无上佛刹庄严故。摄取一切劫。不断一切菩萨行故。摄取一切趣。示现受生故。摄取一切众生。具足普贤菩萨行故。摄取一切众生。净烦恼习故。摄取一切众生诸根。化度无量故。摄取一切众生诸欲。净诸烦恼故。摄取一切众生。调伏成熟随其所应为现身故。摄取一切众生。令解众生如变化故。摄取一切如来性。守护受持一切佛法故。菩萨摩诃萨。如是善根回向。了无所有。业中不取虚妄报。报中不取虚妄业。离诸虚妄入深法界。心常安住胜妙善根。远离散心修习善法。不信不入一切诸法。不见有法自性成就。作者坏者皆不可得。知一切法悉无自在。解了法界无有见者无有知者。如是菩萨摩诃萨。圆满具足解了诸法。得一切法众因缘地。见一切法身。离欲实际等观诸法。解了世间犹如变化。明达众生皆是一法分别无二。不舍诸业境界方便。于有为界出无为界。而亦不坏有为之性。于无为界出有为界。而亦不坏无为之性。如是菩萨摩诃萨。乐观诸法寂灭之相。出生一切清净善根。皆悉回向救护众生。精勤修习离愚痴法。深达明了一切法海。以虚空等一切善根回向。具足无上坚固功德。得离痴冥明净法眼。善知方便回向功德。菩萨摩诃萨。如是善根回向。令一切众生净一切刹得佛自在。教化众生持诸佛法。一切世间最上福田。为诸众生作采宝导师。为一切世间出明净日。一一善根充满法界。善根回向救护众生。令一切众生悉皆成就清净功德。菩萨摩诃萨。如是善根回向。守护受持诸如来性。教化成熟诸众生性。严净一切诸佛刹性。不坏业性。分别法性。等观不二性。遍游十方性。广说离欲性。具足解脱性。普照诸根性。佛子。是名菩萨摩诃萨第四至一切处回向。菩萨摩诃萨。安住此回向。能以一切善根回向。得至一切处身业。善能应现一切世界故。得至一切处口业。微妙音声充满十方一切世界故。得至一切处意业。悉能受持一切诸佛所说法故。得至一切处神足。善能随顺一切世间行故。得至一切处法。随顺一切法故。得至一切处随顺法陀罗尼辩才。令一切众生悉欢喜故。得至一切处顺入法界。于一毛道悉能普入一切世界故。得至一切处身。令一切众生身入一众生身故。得至一切处劫。于一切劫中常见诸佛故。得至一切处刹那。于一刹那现一切佛兴于世故。佛子。菩萨摩诃萨。得至一切处善根回向。能以一切善根回向。尔时金刚幢菩萨。承佛神力普观十方。以偈颂曰

  一切内外诸世间　　菩萨大士无所著
  不舍饶益众生事　　如是妙智人中胜
  不着一切诸世界　　不取十方坚固性
  不取众生寿命相　　亦不妄取诸世间
  一切十方世界中　　摄取众生悉无余
  观察有无得自在　　至一切处善回向
  摄取有为无为法　　心不妄取诸世间
  世间诸法无差别　　照世灯明如是觉
  一切所行诸业行　　上中下品各不同
  智者诸业悉回向　　一切十方诸如来
  菩萨回向到彼岸　　随如来学悉成就
  分别甚深微妙智　　具足最胜殊特法
  清净善根悉回向　　常能利益诸群生
  悉令十方一切众　　成就无上照世灯
  未曾虚妄取众生　　亦不妄想念诸法
  不染不着一切世　　亦复不舍诸众生
  菩萨常乐寂灭法　　随顺得至寂灭境
  亦不舍离众生道　　得如是等微妙智
  不起诸业虚妄想　　于诸果报亦不着
  一切世间从缘起　　不离因缘见诸法
  如是境界随顺至　　远离一切虚妄想
  一切众生调御师　　具足明了善回向

佛子。何等为菩萨摩诃萨第五无尽功德藏回向。此菩萨摩诃萨。修悔过善根。离一切业障。于去来今佛一切善根及三世一切众生善根。皆悉随喜。于诸如来尊重恭敬礼拜供养所生善根。劝请诸佛所生善根。佛所说法闻持忆念如说修行入不思议境界善根。三世诸佛无尽善根。一切菩萨所修善根。三世诸佛得菩提时无上善根。菩萨摩诃萨。于此一切善根。皆悉随喜。随喜已。安住彼善根。三世诸佛转净法轮。度无量众生。彼诸众生所得善根。菩萨摩诃萨。皆悉随喜。三世诸佛从初发心修菩萨行。乃至成佛示现涅槃。于其中间所获善根。皆悉随喜。彼诸如来般涅槃已。受持守护诸佛正法。乃至法灭所修善根。念佛境界所修善根。自己境界所修善根。乃至无上菩提境界善根。菩萨摩诃萨。以此诸善根皆悉回向。菩萨摩诃萨。作如是念。此诸善根。若修。若学。若积集。若开解。若随喜。若具足。若成就。若有所行。若有所得。若正忆念。若受持。若坚固难坏。如此善根。尽过去际劫一切诸佛庄严世界。无量行业之所兴起。佛智所知菩萨所识。应众生起随欲清净。如来所持。如来出世净业所成。普贤菩萨净业所起。彼诸世界。若有众生成无上道。现自在力。未来一切如来应供等正觉庄严佛刹与法界等。无量无边虚空法界等。一切世界中尽未来际劫。一切诸佛。彼诸如来成就智慧。当净佛刹。杂宝庄严一切无厌。上香庄严。雨一切华庄严。一切衣云庄严。一切功德藏庄严。一切如来持智庄严。一切佛刹庄严。不可说庄严。修习不可思议功德庄严。如来等正觉净威神庄严。未来一切诸佛庄严佛刹。一切世间所不能睹。菩萨净眼之所照见。菩萨摩诃萨。修胜善根。悉入一切诸清净法。受持一切诸清净法。犹如变化。普行菩萨诸清净业。入菩萨不可思议自在三昧。佛慧光明普照世间。如未来诸佛严净佛刹。现在诸佛严净世界亦复如是。种种庄严清净具足功德普覆。无量妙色不可思议香。无量杂宝。无量宝树。阿僧祇庄严。阿僧祇宫殿。阿僧祇微妙音声。随善知识显现无量。一切功德殊胜庄严不可穷尽。一切香庄严。一切鬘庄严。一切华庄严。一切末香庄严。一切宝庄严。一切衣庄严。一切幢庄严。一切幡庄严。一切缯彩庄严。一切宝栏楯庄严。阿僧祇白宝网普覆庄严。阿僧祇河庄严。阿僧祇云雨庄严。阿僧祇自然妙音无所不闻。以如是等无量无边诸庄严具。庄严无量无边不可思议诸佛世界。彼诸世界中。若佛刹庄严。佛刹清净。佛刹平等。佛刹妙善。佛刹功德。佛刹殊胜。佛刹安乐。佛刹不坏。佛刹无尽。佛刹无量功德不可尽。佛刹不退。佛刹无所畏。佛刹光明。佛刹快乐。佛刹无厌。佛刹普照。佛刹照明。佛刹方正。佛刹第一。佛刹胜佛刹最胜。佛刹微妙。佛刹无比。佛刹无等。佛刹上。佛刹无上。佛刹无等等。如是等三世一切诸佛佛刹庄严。菩萨摩诃萨。以此善根皆悉回向。普令一切佛刹清净庄严。如是庄严于一世界中。三世一切庄严佛刹具足。清净周遍。清净积聚。等起庄严具足。庄严住持皆悉具足。如一世界中。无量无边虚空法界等世界。悉以三世诸佛庄严佛刹而庄严之。佛刹功德。佛刹观无厌足。佛刹无量。佛刹弥广。佛刹无数。佛刹不可思议。佛刹无胜。佛刹不可称。佛刹无边。皆悉具足。菩萨摩诃萨。复如是回向。令其所修一切佛刹。菩萨摩诃萨皆悉充满。此诸菩萨。具足一切清净功德。成就智慧。善能分别一切世界及众生界。入深法界。舍离愚痴入空寂界。成就念佛念不思议法。念清净僧成就念舍。法日圆满慧光普照。深智无碍。从无所有寂灭法生。出生无量清净佛法。成就殊特胜妙善根。清净善根。最胜善根。增上善根。建立无上菩提之心。善能随顺入如来力。心常志求一切种智。净诸魔业。了众生性知法空寂。舍离颠倒除灭愚痴。修诸善根满足大愿。成就如是等无量无边功德。菩萨充满其刹。悉从无量法门中生。安住如是一切功德。成就无等等胜妙善根。常作佛事。善巧方便得菩提光明。具足无痴法界智慧。一身充满一切法界。现自在力。成就大智一切智境界。善巧方便出生智慧。分别无量法界。遍游诸刹而无所著。心净如空。悉能分别一切法界。于诸菩萨不可思议三昧正受。以巧方便善能入出。趣萨婆若住诸佛刹。善能了知诸佛威神。善能分别阿僧祇诸深妙法而无所畏。随顺三世诸佛善根。普照一切如来法界。悉能受持一切诸佛所说正法。善能演出不可思议清净音声。善能分别阿僧祇诸语言法。得无上道佛自在地。悉能周遍一切世界而无障碍。悉摄一切无诤之法。心无虚妄无所染着。修习增广菩提之心。善解智慧。随时应化权变无方。了真实义具足演说。成就如是等无量功德。诸大菩萨。庄严世界。充满世界。种种庄严。顺至安住。善修熏修。淳净无杂。周遍清净惔然宴寂。于一佛刹少分处。所有无量菩萨。无数菩萨。不思议菩萨。不可称菩萨。不可量菩萨。无等菩萨。不可究竟菩萨。无分齐菩萨。不可说菩萨。不可说不可说菩萨。如一佛刹一一少分处有如是等大菩萨摩诃萨。虚空法界等一切世界。菩萨摩诃萨皆悉充满亦复如是。菩萨摩诃萨。以诸善根方便回向。回向一切佛刹。一切菩萨摩诃萨。一切如来。一切无上菩提。一切大愿。一切出要。一切众生净。一切世界常见如来。如来寿命无量。转不退转法轮与法界等。如是菩萨摩诃萨善根回向。令一切佛刹清净。令一切众生界清净。令一切菩萨清净。令一切诸佛充满法界。令如来清净法身充满一切佛刹。菩萨摩诃萨。以如是等无等等回向。趣萨婆若。心净如虚空。不动如大地。入不可思议回向。乐观一切业报皆悉寂灭。无尽功德回向。平等随顺一切法界。菩萨摩诃萨。行如是回向已。不虚妄取我及我所。不虚妄取佛及诸佛法。不虚妄取佛刹及刹清净。不虚妄取众生及调伏众生。不虚妄取诸业及取业报。不着意业及业果报。不坏因果。不取有法不坏有法。生死非杂乱。涅槃非寂静。如来境界道非他所作无法同止。菩萨摩诃萨。如是起诸善根决定回向。成熟具足等观取相。善取境界分别称量。离诸虚妄而无所著。菩萨摩诃萨。如是善根回向已。得无尽善根。常念三世一切诸佛得一切无尽善根。度无量菩萨得无尽善根。净诸佛刹得无尽善根。净众生界得无尽善根。入深法界得无尽善根。修无量心净如虚空得无尽善根。解了一切诸佛境界得无尽善根。修习一切菩萨净业得无尽善根。了达三世得无尽善根。以如是等善根回向。悉能度脱一切众生。入众生界不见众生回向。解一切法无有寿命回向。知一切法真实无有自在回向。一切诸法无福伽罗回向。观察一切诸法离诸忿诤回向。一切诸法从因缘起无有坚固回向。知一切法真实无所著回向。一切佛刹无所染着回向。不取菩萨行坚固相回向。分别了知一切境界空无所有回向。菩萨摩诃萨。如是回向。眼终不见不净佛刹。亦复不见异相众生行法不见法入智无所入。解了一切犹如虚空。于如来身得一切法。满足成就无量诸功德力。具足至一切处善根安乐众生。此菩萨摩诃萨于念念中。得不可说不可说十力地。具一切种清净善根。悉能摄取一切众生。彼菩萨摩诃萨。成就如意功德宝藏。随所游方悉能严净一切佛刹。令不可说不可说众生安住摄取诸功德力。菩萨摩诃萨。如是回向时。以此回向威力故。一切所行无有伦匹。一切世间所不能坏。威摄众魔莫能瞻对。具足成就不退功德。无量大愿皆悉成就。其心弥广等一切智。于一念中悉能周遍无量佛刹。得无量智力。悉能了知诸佛境界。常乐受持一切佛法。安住无量无边大智。菩萨初发菩提心力。悉与虚空诸法界等。佛子。是名菩萨摩诃萨第五无尽功德藏回向。菩萨摩诃萨。安住此无尽功德藏回向。复得十种无尽功德之藏。何等为十。一者常见诸佛无尽功德之藏。于一一毛孔中见无量阿僧祇诸佛。二者入无尽法功德之藏。以如来智慧。等观一切法即是一法。三者受持正念无尽功德之藏。闻一切佛所说正法闻持不忘。四者得无尽慧功德之藏。于一切如来所说经法。善能次第解其句义。五者无尽趣法功德之藏。善能分别一切法趣。六者无尽佛愿功德之藏。智慧如空。充满三世一切诸法。七者无尽功德功德之藏。充满一切诸众生意犹不可尽八者无尽智功德之藏。一切众生愚痴曀障悉能除灭。九者无尽辩才功德之藏。令一切众生悉解一切佛法平等无二。十者无尽十力四无所畏功德之藏。具足修习菩萨所行。受法王职得一切智。佛子。是名菩萨摩诃萨得十无尽功德之藏。以此无尽功德之藏。皆悉回向一切功德。尔时金刚幢菩萨。普观十方以偈颂曰

  菩萨成就直心力　　于一切法得自在
  随喜所获诸功德　　无碍方便善回向
  三世一切诸最胜　　严净刹土及世间
  具足一切胜功德　　回向净刹亦如是
  三世一切最胜法　　菩萨悉能谛分别
  净心摄取一切法　　如是庄严诸佛刹
  穷尽三世无量劫　　赞一佛刹诸功德
  三世诸劫犹可尽　　佛刹功德无穷极
  如是一切诸佛刹　　一切最胜悉严净
  菩萨严净一切刹　　与诸导师等无异
  彼真佛子心清净　　悉从如来法化生
  一切功德庄严心　　充满一切诸佛刹
  彼诸菩萨悉具足　　无量相好庄严身
  一切诸辩悉成满　　不可穷尽如大海
  观察境界心平等　　安住一切三昧门
  成就清净无等心　　光明普照十方界
  如是无余诸佛刹　　此诸菩萨悉充满
  未曾想念声闻乘　　亦复不求缘觉道
  菩萨如是心清净　　善根回向诸群生
  普令众生成正觉　　具足三世诸佛法
  十方一切诸魔王　　菩萨威德悉调伏
  勇猛安住莫能坏　　决定修行究竟法
  菩萨具足诸愿力　　回向功德无障碍
  深入无尽功德藏　　三世果报无穷尽
  善能观察一切法　　了达其性不自在
  已能分别空无我　　是故不妄取业报
  无有色法及无色　　亦无有想无无想
  亦无有法及无法　　一切诸法无所有
  亦复非有亦非无　　亦复非因非无因
  于彼一切诸缘中　　其心了达无染惑
  一切众生语言法　　悉能了知无所著
  悉知世间施设法　　决定诸法无有我
  平等观察众生类　　谛了诸法无二相
  普观三世无差别　　佛刹诸业亦如是
  菩萨如是知回向　　随所行业功德生
  明达诸佛真实性　　解一切佛深妙法
  菩萨如是净回向　　心能分别善思量
  了知自性悉非性　　于一切法无所著
  摄取一切诸境界　　回向一切群生类
  除灭一切愚痴闇　　于真实性觉如如
  菩萨一切虚妄见　　已灭已弃永无余
  远离世间烦恼热　　得到究竟清凉趣
  不坏一切诸法性　　明达真实无所生
  解了诸法犹如响　　悉于一切无所著
  了知三世众生类　　悉从因缘和合起
  善解烦恼诸习气　　不坏诸法真实性
  了达业性非是业　　亦复不坏诸业性
  又亦不坏业果报　　宣扬赞叹缘起法
  众生所生无有生　　亦无流转生死中
  不着众生说众生　　善能随顺诸世间

大方广佛华严经卷第十五大方广佛华严经卷第十六

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之三

佛子。何等为菩萨摩诃萨第六随顺一切坚固善根回向。此菩萨摩诃萨。若为王时得胜国土。安隐丰乐降伏怨敌。治以正道如法教化。功盖天下德覆十方。万国归顺无敢违命。兵仗不用自然泰平。以四摄法善摄众生。转轮圣王七宝成就。此菩萨摩诃萨。坚固安住自在功德。眷属和睦不可沮坏。端正第一观者无厌。离一切恶功德具足。相好成满颜容殊特。身体肢节端严周备。鲜洁明净见者欢喜。体力坚固不可毁坏摄取天帝那罗延身。离诸业障得清净业。具足修行一切布施。若施饮食。种种美味。诸乘衣服。众妙华鬘。杂香涂香。床座住处。房舍灯明。汤药宝器。庄严宝车。象马宝王。众妙宝座。诸盖幢幡。种种杂宝。妙庄严具。清净天冠。髻中明珠。若见狱囚受诸楚毒。起大悲心。舍诸库藏妻子眷属。以身处狱救苦众生。见送狱囚趣于死地。自舍己身以代彼命。若有人乞连肤顶发髻中明珠眼耳鼻根牙齿舌根头顶手足。坏身出血。髓肉及心肠肾肝肺肢节诸骨厚皮薄皮。或手足指连肉指爪。为求正法投身火坑。为求法故。举身具受无量众苦。为法难得故。能舍大地四海国土大小诸城村邑丘聚。国土丰乐人民炽盛园林浴池华果繁茂无量庄严。天下太平无诸怨敌。金银宝藏妻子眷属。自在法王。断除一切屠杀恶业。普施无畏。若见有人毁坏畜狩及以人根令身残阙。起大慈悲而救度之。以大音声普告一切令闻佛名。或施大地。起佛殿堂造僧房舍。安处菩萨圣众福田。或建尊庙随应一切。或施僮使。供给三尊父母知识一切福田。以身布施一切给使。复以自身普覆诸佛。以自身施一切众生。常以己身奉给诸佛。布施国土及王京都严饰大城。又施宝女侍人眷属妻妾男女。或施以家。种种庄严游戏园林。或设无数大众施会。远离诸恶净众生故。悉舍一切资生之具。心不贪着。不求果报。悉能舍离。若诸众生人与非人。贫贱富贵。或善或恶。种种福田。远近诸方一切悉来。或自来求或不来求。一切悉施无所悭吝。作如是念。摄取随顺一切坚固善根回向。摄取善色随顺一切坚固善根回向。摄取善受想行识随顺一切坚固善根回向。摄取国土。随顺一切坚固善根回向。摄取胜人随顺一切坚固善根回向。摄取眷属随顺一切坚固善根回向。摄取财利随顺一切坚固善根回向。摄取一切惠施随顺一切坚固善根回向。菩萨摩诃萨。如是诸善根回向已。作如是念。我所行施。无贪无著无染解脱。其心真直无所悭惜。以此惠施功德之力。令一切众生得大智慧。心无障碍。知食见食无所贪着。但以法食永离抟食。智慧充满摄取善根。法身智身清净游行。为化众生现受抟食。菩萨摩诃萨。若施饮时。如是回向。以此善根。令一切众生饮法甘露。成菩萨道除灭渴爱。常乐大乘离五欲爱。得净法爱法身柔软。三昧调心未曾散乱。入智慧海。兴大法云。雨法甘露。是为菩萨摩诃萨布施饮时善根回向。菩萨摩诃萨。若施众味。所谓辛酸咸淡甘苦。如是无量肴膳香味。食之无厌。能令四大柔软安乐身体充满。气力康强。发欢喜心。明净诸根。严持内身。长育柔软。肌色光润。一切毒害所不能坏。消灭众疾得无患法。菩萨摩诃萨。施如是等无量无数诸美味时。如是回向。以此善根。令一切众生得上味相甘露充满。令一切众生心得安住法味深智。悉知一切众味之业。令一切众生悉得无量深妙法味。了法界智安住实际得到法城。令一切众生法云普雨充满法界。悉能调伏成熟众生令一切众生得胜智味无上法爱柔软身心。令一切众生得上味相。不着众味。修习一切佛法诸愿。令一切众生皆善和合得一味法。出生诸佛无二之法。令一切众生得无碍味。于一切智乘得不退转。令一切众生得一切佛无杂法味。善能分别一切诸根。令一切众生法味充满。具足安住无碍佛法。是为菩萨摩诃萨施众味时善根回向。令一切众生悉得具足无碍智身。菩萨摩诃萨。布施乘时。如是回向。以此善根。令一切众生乘一切智乘。具足大乘。不可坏乘。胜乘上乘。速疾乘。大力乘。功德成就乘。出世间乘。出生无量诸菩萨乘。功德满足。是为菩萨摩诃萨布施乘时善根回向。菩萨摩诃萨。布施衣时。如是回向。以此善根。令一切众生得惭愧法服以覆其身。离诸陋形端严殊妙。颜容鲜泽肤体柔软。得身上乐诸佛之乐。无量法身普应一切。无上清净一切种智。是为菩萨摩诃萨布施衣时善根回向。菩萨摩诃萨。布施众华。鲜妙香华。种种色华。无量乐华。善现之华。乐无厌华。一切时华。天华。人华。世所乐华。无上香华。如是等无量众华。菩萨摩诃萨。悉以供养现在十方一切诸佛。及灭度后供养塔庙诸法施者比丘僧宝一切菩萨诸善知识声闻缘觉父母亲族乃至自身下及贫贱。菩萨摩诃萨。布施华时。如是回向。以此善根。令一切众生悉得诸佛三昧之华。清净开敷。妙法众华从其心出。令一切众生观无厌足得佛法爱。令一切众生常见妙色身相端严见者无厌。令一切众生未曾散乱。具足一切清净行业。令一切众生常念善知识心无变异。令一切众生如阿伽陀药。悉除一切烦恼众毒。令一切众生满足大愿。决定安住无上智王。令一切众生出智慧日。除灭一切愚痴闇冥。令一切众生如净满月。长菩提月开功德华。令一切众生入大宝海见善知识。具足成就一切善根。是为菩萨摩诃萨布施华时善根回向。令一切众生悉得无碍清净妙智。菩萨摩诃萨。布施鬘时。如是回向。以此善根。令一切众生人所乐见。见无不欣见辄亲善。见无不爱。见离忧恼。必见诸佛。得一切净智。是为菩萨摩诃萨布施鬘时善根回向。菩萨摩诃萨。布施香时。如是回向。以此善根。令一切众生具足戒香。得不坏戒。不杂戒。离垢戒。离疑戒。离缠戒。清凉戒。不犯戒。无量戒。无上戒。离世间戒。菩萨究竟至彼岸戒。令一切众生具足成就诸佛戒身。是为菩萨摩诃萨布施香时善根回向。令一切众生具足成就无碍戒身。菩萨摩诃萨。施涂香时。如是回向。以此善根。令一切众生施香普熏悉舍所有。令一切众生戒香普熏得佛净戒。令一切众生忍香普熏离毒害心。令一切众生精进之香具足普熏。勤修大乘弘誓庄严。令一切众生定香普熏。具足诸佛现前三昧。令一切众生慧香普熏。于一念中得无上智王。令一切众生法香普熏。成就无上无畏之法。令一切众生德香普熏。成就一切功德智慧。令一切众生无上菩提妙香普熏。得佛十力究竟彼岸。令一切众生白净法香具足普熏。断除一切诸不善法。是为菩萨摩诃萨施涂香时善根回向。菩萨摩诃萨施床座时。如是回向。以此善根。令一切众生得天宝座安处慧床。令一切众生得贤圣座舍凡夫意修菩提心。令一切众生得安乐座离生死苦。令一切众生得最上座。见诸如来自在神力。令一切众生得平等座等心普照一切诸法。令一切众生得最胜座。得无上业永离世间。令一切众生得安隐座。身证一切诸深妙法。令一切众生得清净座。修习如来净智境界。令一切众生得安住座。得善知识常随覆护。令一切众生得师子座。具足如来无畏之座。是为菩萨摩诃萨施床座时善根回向。令一切众生修习念慧调伏诸根。菩萨摩诃萨。施住处时。如是回向。以此善根。令一切众生悉得如来严净佛刹。修习功德庄严佛刹。安住甚深三昧境界。于彼住处而无所著。善能分别一切住处。离世间住安住佛住。摄取一切诸佛所住。究竟大道安乐善住。修习无量清净善根。未尝舍离佛无上住。是为菩萨摩诃萨施住处时善根回向。令一切众生安乐饶益救护一切。菩萨摩诃萨。施房舍时。如是回向。以此善根。令一切众生饶益安乐正念思惟。令一切众生依如来住。依大智住。依善知识住。依尊重住。依善行住。依大慈住。依大悲住。依六波罗蜜住。依无量菩提心住。依一切菩萨道住。是为菩萨摩诃萨施房舍时善根回向。令一切众生具足成就清净智慧诸通功德。菩萨摩诃萨。惠施灯明。所谓酥灯。油灯。宝灯。摩尼灯。漆灯。火灯。沉水香灯。栴檀香灯。一切香王灯。无量色光焰灯。以如是等无量灯明施时。如是回向。以此善根。饶益一切众生。摄取一切众生。令一切众生得无量光。普照一切诸如来法。令一切众生得明净光。普照一切诸微细色。令一切众生得离痴光。善能了知无众生界。令一切众生得无量光。法身净光普照一切。令一切众生得普光明。于诸佛法得不退转。令一切众生得佛光明。普照一切无量佛刹。令一切众生得无碍光。以一光明普能遍照一切法界。令一切众生得无量光。普照佛刹光明不断。令一切众生得光明幢王。慧光幢灯普照世间。令一切众生得无量色光。放自在光照一切刹。是为菩萨摩诃萨施灯明时善根回向。悉能饶益一切众生。悉能安乐一切众生。随顺善根。随摄众生善根。善摄一切众生。等施善根。等施众生。慈愍善根愍念众生。普覆善根普荫众生。布施善根满足众生。普入一切善根境界。平等善根平等众生。智慧善根分别一切。是为菩萨摩诃萨灯明施时善根回向。令一切众生得无碍回向。安住一切明净善根。菩萨摩诃萨。施汤药时。如是回向。以此善根。令一切众生离诸障碍。令一切众生舍离病身。悉得如来清净法身。令一切众生皆成药性。悉能除灭一切众生不善之病。令一切众生成阿伽陀药。安住菩萨不退转地。令一切众生成如来药。拔出一切烦恼毒刺。令一切众生习近贤圣。除灭烦恼得清净行。令一切众生得药王意。未曾厌离一切善法。令一切众生具足成就不坏药树。对治一切诸不善病。令一切众生除诸病刺。悉得一切智慧光明。令一切众生解了世间诸对治法。随应群生对治众病。菩萨摩诃萨。施药善根如是回向已。因此善根。令一切众生舍离诸病。安隐无患具足清净。得诸如来无病之法。令一切众生出诸病刺得无尽身。金刚围山所不能坏。具足坚固一切诸力。成满诸佛无上法乐。得佛神力自在法身。是为菩萨摩诃萨施汤药时善根回向。菩萨摩诃萨。悉能惠施一切诸器。所谓以真金器盛满杂宝。以白银器盛满杂宝。以琉璃器盛满杂宝。以玻璃器盛满杂种宝庄严具。以砗磲器盛赤珠宝。以码瑙器盛满珊瑚夜光众宝。又以石器盛诸美膳。以栴檀器盛众宝衣。以金刚器盛满众香。如是等无量无数诸妙宝器。盛以无量无数妙宝。或施诸佛。信佛福田不思议故。或施菩萨宝。发菩提心。诸善知识难值遇故。或施众僧。长养佛法故。或施福伽罗声闻缘觉。爱圣法故。或施父母。为尊重故。或施师长。为教如法修功德故。乃至布施下品凡劣。大慈大悲爱眼等心观众生故。不舍三世一切菩萨满足檀波罗蜜故。一向专求无上菩提故。悉舍一切内外所有。不舍一切众生类故。不着福田及财物故。菩萨摩诃萨。以如是等无量宝器。盛以无量杂宝施时。如是回向。以此善根。令一切众生成广大藏器。成虚空等广大念根。世间出世间一切经书。悉能受持不忘失故。令一切众生成清净器。普能受持佛深法故。令一切众生成无上宝器。悉能受持去来今佛一切法故。令一切众生普成如来胜法宝器。悉能受持三世诸佛无坏法故。令一切众生成庄严宝器。受持无极菩提心故。令一切众生悉成一切功德之器。志乐如来无量净智故。令一切众生成一切智内法之器。究竟如来无碍解脱一切智故。令一切众生成未来际劫一切菩萨所行之器。一切众生坚固安住一切智力故。令一切众生成三世佛胜妙法器。一切诸佛梵音说法悉受持故。令一切众生悉成内器。其身容受一切世界虚空界法界诸佛眷属。劝请诸佛转大法轮悉能受故。是为菩萨摩诃萨布施器时善根回向。令一切众生成诸法器。皆能受持普贤菩萨一切愿行

菩萨摩诃萨以无量种种庄严宝车。奉施诸佛菩萨及善知识如来大众声闻缘觉一切福田。种种众生从余方来。或承菩萨名闻故来。或是菩萨因缘故来。或闻菩萨发施愿故来。或是菩萨心愿请来。菩萨摩诃萨。或施种种庄严。妙宝金车金铃网覆。微动相扣出和雅音。垂宝璎珞种种庄严。或施清净琉璃宝车。无量珍妙以为严饰。或复施与众妙宝车。白银庄严白网罗覆。或复施与神马宝车。无量亿宝以为庄严。或复施与大象宝车。无量亿宝以为庄严。一切宝网绞络其上。或复施与栴檀香车。种种宝轮以为庄严。宝师子座以敷其上。百千采女列侍其内。人相具足颜容姝妙。众宝华盖弥覆其上。十万壮士。而牵御之。或复施与玻璃宝车。无量杂色妙宝庄严。载以无数端严采女。众杂宝帐以覆其上。宝缯幢幡周匝庄严。或复施与码瑙宝车。饰以众宝。熏以杂香。摩以涂香。散以妙华。百千采女持金璎珞。平正安详其疾如风。或复施与坚固香车。敷以种种柔软宝衣。众妙宝网罗覆其上。清净妙香而以熏之。其香殊妙能悦人心。逆风远熏闻者无厌。诸天子等在前牵御。或复施与一切宝车。种种杂色以为绞饰。众妙宝网罗覆其上。诸杂宝带周匝垂下。敷以宝衣散以末香。所爱男女悉载其上。菩萨摩诃萨。以如是等众妙宝车。施诸佛时。如是回向。以此善根。令一切众生悉皆乐求无上福田。深信施佛有无量报。令一切众生一心向佛。逮得无量清净果报。令一切众生于诸佛所无悭吝心。具足大施无所爱惜。令一切众生于诸佛所修上福田。离二乘愿。得诸如来无碍解脱一切种智。令一切众生于诸佛所种无尽善根。得佛无量功德智慧。令一切众生摄取深慧。具足清净无上智王。令一切众生所游自在。得诸如来至一切处无碍神力。令一切众生摄取大乘。得无量种智安住不动。令一切众生具足成就第一福田。皆能出生一切智地。令一切众生于一切佛无嫌恨心。种诸善根乐求佛智。令一切众生以少方便。往诣一切庄严佛刹。于一念中深入法界而无疲倦。令一切众生入虚空等菩萨神通。悉能遍至一切佛所。令一切众生得无比身。尽能遍游十方世界而无疲倦。令一切众生成广大身得随意行。令一切众生得一切佛神力庄严究竟彼岸。于一念中。显现如来自在神力。遍虚空界。令一切众生修安隐行。随顺一切诸菩萨行。令一切众生行疾无碍究竟十力智慧彼岸。令一切众生得转一切世界力波罗蜜。普入一切不坏法界。令一切众生行普贤行到于彼岸。得不退转一切种智。令一切众生乘无比智乘。随顺修行一切法界见真实性。是为菩萨摩诃萨以诸宝乘奉现在诸佛及灭度后舍利塔庙善根回向。令一切众生究竟诸佛无碍大乘。菩萨摩诃萨。施诸菩萨及善知识清净乘时。如是回向。以此善根。令一切众生不舍菩萨诸善知识知恩报恩。令一切众生同善知识义。摄取同性善根故。令一切众生亲近尊重恭敬供养诸善知识。悉舍一切摄善知识。令一切众生得正直心。随善知识未曾远离。令一切众生常见善知识不违其教。令一切众生得正直心。不舍善知识。离一切垢心不可坏。令一切众生为善知识。不惜身命。悉舍一切不违其教。令一切众生为善知识之所摄取。修习大慈远离诸恶。令一切众生顺善知识。闻佛正法悉能受持。令一切众生同善知识善根业报菩萨行愿。究竟清净平等满足。令一切众生出生正法。善知一切三昧境界。智慧具足神通自在。令一切众生远离诸趣。受持一切法。究竟到彼岸。令一切众生乘于大乘。乃至究竟一切种智。于其中间无有懈怠。令一切众生乘智慧乘。至安隐处无有退转。令一切众生知真如行远离愚痴。闻持一切诸佛正法。令一切众生皆为一切诸佛所摄。得无碍智究竟诸法。令一切众生得不死神足妙速无碍。令一切众生游行自在。调伏众生成摩诃衍。令一切众生所行不虚。皆悉究竟得智慧乘。令一切众生得无碍乘。以无碍智至一切处。是为菩萨摩诃萨施善知识种种乘时善根回向。令一切众生功德具足与佛菩萨等无差别。悉能悦可一切贤圣。菩萨摩诃萨。施如来众种种宝乘时。善学施心。慧分别心。净功德心。随顺施心。僧宝难遇心。深信僧宝心。摄取正教心。安住正直心。善能究竟大施之会。出生无量无边功德。于佛正教信心清净不可沮坏。菩萨摩诃萨。以种种乘施僧宝时。如是回向。以此善根。令一切众生向佛正法摄取正教。令一切众生专心内观。除灭邪法成就圣处。令一切众生得贤圣地。以如来法展转相教。令一切众生举世宗重言必信用。令一切众生入一切法。善能分别无二法界。令一切众生人宝围绕。从如来智境界出生。令一切众生住离垢法。皆能除灭烦恼尘垢。令一切众生悉从无上僧宝出生。离凡夫法得圣僧地。令一切众生具足圣法修无碍智。令一切众生为大众主。智慧庄严不染世间。令一切众生以善方便转慧法轮。令一切众生得一念神力。悉能周遍不可说不可说世界。令一切众生乘虚空身。于一切世间智慧无碍。令一切众生往诣虚空法界等如来大众所。令一切众生得轻举身胜妙智慧。悉能遍游诸佛世界。令一切众生得无碍神足。于一切刹普能现身。令一切众生得大自在神足彼岸。不起一座悉普应现一切世界。令一切众生得净法身。于诸世界而无所著。出生神力行疾如电。令一切众生现不思议神足境界。善能随顺教化调伏一切众生不失其宜。令一切众生得妙神足。一念遍游十方世界。一念超度一切法界无所挂碍。是为菩萨摩诃萨施如来众种种乘时善根回向。令一切众生普乘清净无上智乘。于一切世界转无碍法轮智轮。复次菩萨摩诃萨。施声闻缘觉种种乘时。发恭敬心。尊重心。福田心。功德海心。出生功德智慧心。深信如来功德心。修习无量亿那由他清净善根心。于不可说劫修习菩萨清净行心。解脱一切魔系缚心。摧灭一切魔军众心。不可称量明净智慧。善能分别一切诸法。令一切众生皆成可信第一福田。具足无上檀波罗蜜。令一切众生离无益言。乐独闲静心无二念。令一切众生成最胜清净第一福田。修习功德摄取众生。令一切众生成智慧池。能与众生无数善果。令一切众生至无碍趣。最胜福田清净圆满。令一切众生。其心安住无诤三昧。解一切法无性为性。令一切众生具足长养无量功德。常遇最胜第一福田。令一切众生示现无量自在神力。随顺摄取清净福田。令一切众生成就无尽功德福田。能与一切十力乘果。令一切众生成真实福田。具足无尽功德之藏。究竟一切智。令一切众生灭诸恶法闻佛正法。句身味身悉能受持。令一切众生普闻佛法。随所闻解其德不虚。令一切众生闻佛说法得到彼岸。所闻佛法能为众生随顺演说。令一切众生常乐如来正教之法。除灭一切九十六种外道邪见。令一切众生常见贤圣。长养一切最胜善根。令一切众生乐明行足者常得瞻对。与共同止永处安乐。令一切众生所闻不虚。解声如响见佛出生。令一切众生善分别知诸佛正教。悉能守护持佛法者。令一切众生心常乐向闻持佛法。能照显现如来法教。令一切众生深心信解如来正教一切功德。令佛欢喜善解真谛。悉舍内外究竟大施。是为菩萨摩诃萨施声闻缘觉种种乘时善根回向。令一切众生得无上智净诸神通。精勤修习无有懈怠。究竟佛智力无所畏。菩萨摩诃萨。若诸方来一切福田。或承菩萨名闻故来。或与菩萨因缘故来。或闻菩萨本愿故来。或复菩萨心愿请来。菩萨于彼悉乐惠施而无厌倦。尔时菩萨。于来求者发悔过心。作如是言。诸人当知。我应诣彼礼拜供养种种惠施。而今为我故从远来。菩萨即时敬礼悔过。爱言慰谕。屈辱远来得无疲倦。处令安隐供给所须。或施摩尼宝车。载以阎浮提内第一女宝。或施金车。载以己国最胜宝女。或施清净琉璃宝车。载以内妓。或施乐车。载以童女容貌如天。或施无量无数宝庄严车。载以宝女种种庄严。或施菩萨所乘栴檀香车。或施玻璃宝车。载以宝女。端正殊特颜容无伦。威仪具足进止安详。神珠名宝璎珞其身。乐修善法。或施码瑙宝车。载以太子。或施坚固香车。载以男女。或施种种宝庄严车。载以难坏亲爱眷属。以如是等种种宝车。随其所求皆给施之。满足彼愿欢喜无量。菩萨摩诃萨。诸乘施时。如是回向。以此善根。令一切众生乘不退转摩诃衍乘。诣不思议菩提树下。令一切众生乘大智乘。尽未来劫。一切菩萨所行之法皆能修习。令一切众生乘无所有乘。于一切法心无所著。舍离虚妄具足修习一切智道。令一切众生悉乘离垢寂静之乘。无碍神力诣诸佛刹。令一切众生决定安住一切智乘。常以诸佛法乐自娱。令一切众生乘诸菩萨清净行乘。出生菩萨十种之道。乐修菩萨一切三昧。令一切众生乘四轮乘。住正国轮。依正士轮。本功德轮。平等愿轮。菩萨净行由斯满足。令一切众生乘明法乘。遍游十方修佛智力。令一切众生乘佛法乘。于一切法究竟彼岸。令一切众生乘一切功德善根不可思议法乘。为十方众生现安隐道。令一切众生乘一切施乘。断除悭垢。令一切众生乘清净尸波罗蜜乘。具足无量无边法界等一切净戒。令一切众生乘羼提波罗蜜乘。离嗔恚心。于诸众生不起恼害。令一切众生乘不退转毗梨耶波罗蜜乘。具菩萨行往诣道场。令一切众生乘禅波罗蜜乘。速赴道场。令一切众生乘般若波罗蜜乘。化身充满一切法界及佛境界。令一切众生乘法王乘。成就无畏施一切智微妙之法。令一切众生乘无所著智慧愿乘。悉能遍入一切诸方。于真法性而无所入。令一切众生乘诸佛法乘。于一切刹示现受生。而不毁坏于摩诃衍。令一切众生乘一切智乘。满足菩萨平等大愿而无懈倦。是为菩萨摩诃萨施种种乘普施众生无量福田以欢喜心善根回向。令一切众生无量种智皆悉具足。乘于一切成满智乘

菩萨摩诃萨布施象宝。七支具足。六瘤成满。六牙如雪口净如华。身体平正毛色鲜白。珍丽奇饰庄严其身。净妙宝网以覆其上。种种杂宝庄严其首。光色晃曜仪体安雅。瞬息之顷超步万里。猛气奔踊而无疲倦。菩萨摩诃萨。布施宝马。形体殊妙毛色光泽。马相具足如天宝马。无量珍饰庄严其身。明月神珠以为光曜。金铃宝网以覆其上。行不奔骤迅踰疾风。致远不疲乘者安豫。巡游四方不失主意。以此宝乘随意施与。或施福田。或献尊重。或遗知识。或奉父母。或给贫匮。其有须者皆悉与之。大心惠施无所吝惜。心常欢喜无有悔恨。大悲充满能行大施。一向专求菩萨功德。最胜生地直心清净。以如是心善根回向。令一切众生成就人宝。生菩萨功德庄严大乘。令一切众生乘善法乘。随顺能至一切佛法。令一切众生常乐大乘。得佛无碍智慧力乘光明普照。令一切众生。乘勇猛大乘。满足诸愿。令一切众生。具足平等波罗蜜乘。成就满足一切善根。令一切众生。成就宝乘。出生佛法无上智宝。令一切众生。分别菩萨庄严之行。得是妙乘出于三界。悉开菩萨诸三昧华。令一切众生。无量阿僧祇劫。清净修习菩萨所行。乘无量乘疾解诸法。令一切众生。施大乘宝乘。以善方便具菩萨地。令一切众生。成最高广安隐大乘。悉能运载一切众生。至无上道。是为菩萨摩诃萨无量阿僧祇那由他劫施象马宝善根回向。令一切众生。乘无碍智乘。得至如来究竟宝乘。菩萨摩诃萨。施种种座。或施圣王师子之座。琉璃为足。金缕织成柔软妙衣。以敷其上。熏以一切坚固之香。建立种种上妙宝幢。无量亿宝以为庄严。白净宝网弥覆其上。金铃罗网动发妙音。百万亿那由他净妙宝像周匝围绕。其座高广清净严饰。无量阿僧祇众生。乐观无厌。功盖天下。自在大王之所坐处。处于彼座。以正治国无敢违逆。种种妙宝庄严其身。青宝珠王。大青宝珠王。胜藏宝珠以为庄严。明净犹日。清凉如月。众星庄严如海胜宝。海坚固幢。离垢明净。阎浮檀金妙色宝缯。以冠其首。一切阎浮提内大力灌顶王法。以灌其顶。具功德力大慈悲主。降伏怨敌无敢违命。菩萨摩诃萨。如是无量无数为转轮王。得法自在。正治国时。以如是等种种众宝严饰之座。或施正觉诸善知识及贤圣僧。闻法欢喜。奉施法师。供养父母诸尊重者声闻缘觉一切菩萨乃至初发大乘心者。及以一切诸佛塔庙。或施无量贫穷下劣。有所须欲皆给施之。布施座时。如是回向。以此善根。令一切众生。得菩提座。自然觉悟诸佛正法。令一切众生得自在座。具足成就于法自在。诸金刚山所不能坏。悉能降伏一切诸魔。令一切众生。得佛自在师子之座。一切众生乐观无厌。令一切众生。得不可说不可说清净庄严殊妙之座。成法自在普化众生。令一切众生。得殊胜座。三种世间所不能坏。广大善根及善根具皆悉清净。令一切众生。得高广座。充满不可说不可说世界。诸佛如来。于阿僧祇劫叹不能尽。令一切众生。处大智人座。一身充满一切法界。令一切众生。得不可思议宝庄严座。随其本愿所请众生广开法施。令一切众生。皆悉得坐净妙法座。于不可说诸世界中。显现如来自在神力。令一切众生。坐一切宝座。一切香座。一切华座。一切衣座。一切鬘座。一切摩尼宝座。不可思议净琉璃座。无量不可说世界座。净一切众生庄严座离诤座。处此座上。觉悟如来一切种智。示现诸佛功德境界。是为菩萨摩诃萨施种种座时善根回向。令一切众生。得无所著菩提之座。自然觉悟一切佛法

大方广佛华严经卷第十六大方广佛华严经卷第十七

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之四

菩萨摩诃萨。施种种盖。所谓尊重人盖。种种妙宝而庄严之。于无量无边严饰盖中。最为第一。众宝为竿金网罗覆。杂宝璎珞周匝垂下。悬众宝铃。净琉璃珠。微动相扣出和雅音。白净宝网而绞络之。百千清净众杂宝网罗覆其上。无量百千亿杂宝庄严。无量亿那由他沉水栴檀坚固香熏。阎浮檀金清净庄严。如是等无量阿僧祇那由他盖。以离恶心广大心放舍心。而行布施。或以奉献现在诸佛。及涅槃后供养塔庙。为求法故。奉施菩萨诸善知识。或施法师。或施父母。或施众僧。或复奉施一切佛法。或施种种福伽罗福田。或施师长及诸尊重。或施初发菩提心者。或施一切贫穷下劣。诸有所求皆悉施与。菩萨摩诃萨。布施盖时。如是回向。以此善根。令一切众生。为善根所覆。又为一切诸佛荫护。令一切众生。为智慧功德之所覆护。除灭世间诸烦恼垢。令一切众生。覆以净法。除灭一切尘劳热恼。令一切众生。悉得如来内智慧藏。一切众生。乐观无厌。令一切众生。以寂静白法而自覆荫。悉得究竟不坏佛法。令一切众生。得善覆身。究竟如来清净法身。令一切众生。悉为一切而作覆盖。十力智慧普覆世间。令一切众生。得随乐智慧。皆悉出过一切世间。清净明达无所染着。令一切众生得应供盖。成胜福田受一切供。令一切众生得最上盖。自然觉悟无上智盖。是为菩萨摩诃萨布施盖时善根回向。令一切众生。受持法自在盖。以一功德盖。普覆一切法界虚空界等一切世界。示现诸佛神力自在。以一功德盖庄严法界。供养诸佛妙幡幢盖。普覆十方一切如来。令一切佛刹种种宝盖而以庄严。令一切众生。皆悉乐求无上菩提。以无上盖普覆众生。令一切众生。以不可说不可说一切众宝庄严妙盖。供养一佛。供养一切诸佛亦复如是。令一切众生。自然觉悟得最正觉功德高广微妙之盖。普覆诸佛。令一切众生。以种种宝盖。供养法界虚空界等一切世界诸佛。令一切众生。以种种摩尼宝盖。诸宝璎珞周匝垂下以为庄严。一切坚固香盖。清净杂宝而以庄严。极大高广。以白净宝网罗覆其上。以金铃网周匝悬之。自然演出微妙音声。以如是等无量不可数盖。供养诸佛。令一切众生。得无碍智盖。普覆十方一切诸佛。令一切众生。得最胜智盖。普覆众生。令一切众生。得佛功德庄严宝盖。普覆众生。令一切众生。皆悉具足清净大愿诸佛功德。令一切众生。得不思议清净心宝。令一切众生。满足诸法自在之智。令一切众生。以诸善根普覆众生。令一切众生。得无上智盖。普覆众生。令一切众生。得十力盖。普覆众生。令一切众生。以一佛刹。悉能普覆一切法界。令一切众生。悉于诸法而得自在。令一切众生。得心自在。令一切众生。智慧胜广。令一切众生。以无量功德。悉能普覆一切众生。令一切众生。以诸功德而覆其心。令一切众生以平等心普覆一切。令一切众生。以大智慧等覆一切。令一切众生。具大回向。令一切众生。满足清净正直之心。令一切众生。意根清净。是为菩萨摩诃萨施种种盖时善根回向。令一切众生。皆悉成就最大回向。普覆摄取一切众生。菩萨摩诃萨。布施种种清净幢幡。无量杂宝以为其竿。种种宝缯以为垂幡。种种杂彩周匝垂下。白净宝网罗覆其上。金铃宝网以为庄严。微风吹动出和雅音。无量无数亿那由他诸妙幢幡。以为眷属。杂宝缯彩悬以为饰。半月宝像。阎浮檀金。出大光明如日普照。严饰宝幢周满大地。以一切世界随乐业报。庄严彼幢。安住一切虚空法界等诸如来刹。菩萨摩诃萨。于诸世界。随其所乐。普施妙幢。令发正直菩提之心。或施现在一切诸佛。或施塔庙。或施法宝。或施僧宝。或施善知识。或施菩萨。或施声闻。或施缘觉。或施大众。或施福伽罗。或施贫人。诸来求者普施无遗。菩萨摩诃萨。施幢幡时。如是回向。以此善根。令一切众生。建立一切善根。功德幢幡不可毁坏。令一切众生。建立一切诸法自在幢幡。守护正法。令一切众生。护正法宝。守持诸佛菩萨深法。令一切众生。建立高显功德宝幢。然智慧灯普照众生。令一切众生。成不坏幢幡。降伏一切诸魔恶业。令一切众生。皆悉建立智力幢幡。一切诸魔所不能坏。令一切众生。得大智慧那罗延殊胜幢幡。摧灭一切世间幢幡。令一切众生。建解脱慧光圆满日幢。智慧具足普照法界。令一切众生。得智慧宝庄严幢幡。充满一切诸佛世界。建不可说胜妙幢幡。供养十方一切诸佛。令一切众生。得如来幢。摧灭一切九十六种诸邪见幢。是为菩萨摩诃萨施幢幡时善根回向。令一切众生。建高广甚深菩萨行幢。建一切菩萨自在行幢。得清净道。菩萨摩诃萨。开众宝藏行布施时。如是回向。以此善根令一切众生。常见佛宝。舍离愚痴修行正念。令一切众生。得法宝明。护持一切诸佛法藏。令一切众生。摄取僧宝。离悭行施充满其意。令一切众生。得萨婆若心宝。于清净菩提心不退转。令一切众生。度智慧宝。永离愚痴究竟佛法。令一切众生。成就菩萨诸功德宝。演说无量智慧妙宝。令一切众生。赞叹无量功德之宝。修十力智得正觉宝。令一切众生。得十六智宝三昧正受。究竟增广智慧之宝。令一切众生。成就第一福田之宝。觉悟如来无上智宝。令一切众生。成增上宝。无尽辩藏演说法宝。是为菩萨摩诃萨施众宝时善根回向。令一切众生。具足究竟无上智宝。得佛无碍清净眼宝。菩萨摩诃萨。舍庄严具惠施众生。所谓一切身庄严具肢节庄严具。令身清净庄严具。无厌足庄严具。杂宝绞饰庄严具。如是等种种无量亿那由他庄严之具。布施一切善根回向。令一切众生。身净庄严。等观一切犹如一子。超出世间得佛智乐。调伏众生使乐深法。安住一切诸佛法中。令一切众生。庄严天人悉以清净智慧。而自严饰。令一切众生。身净庄严功德相门清净具足。令一切众生。妙相严身百福具好以自庄严。令一切众生。身相具足以诸相好。而自庄严。令一切众生。言辞庄严。皆悉具足无尽辩藏。令一切众生。以诸功德庄严音声。梵音清净微妙具足。令一切众生。皆悉志乐佛法庄严。听受正法诸佛欢喜。令一切众生。以心庄严而自庄严。念佛三昧普见诸佛。令一切众生。以诸陀罗尼庄严。而自庄严。得佛法明见诸佛法。令一切众生。以平等智庄严其心。以如来智庄严法身。是为菩萨摩诃萨惠施一切庄严具时善根回向。令一切众生。于无量佛法功德智慧庄严满足。令一切众生。舍离自大憍慢放逸。菩萨摩诃萨。为灌顶大王。威力自在布施天冠髻中明珠。给施一切。摄取众生。长养施心。以施熏心。向增上施。以施修慧。施修舍根。施修广觉。菩萨摩诃萨。施髻明珠时如是回向。以此善根。令一切众生。善受一切智灌顶法王。令一切众生具足顶相。获胜智顶得到彼岸。令一切众生。得胜智宝。究竟一切功德之顶。令一切众生。悉得安住智慧宝顶。堪受一切敬心顶礼。令一切众生。皆悉冠冕智慧天冠。于一切法而得自在。令一切众生。以智慧明珠而系其顶。一切世间无能见顶。令一切众生。皆悉堪受敬心顶礼。具足慧顶照明佛法。令一切众生。成十力冠以冠其顶。智宝海藏清净具足。令一切众生。安住最上大地帝主。摧诸魔顶成最正觉。究竟具足如来十力。令一切众生。成胜顶王。得一切智顶最胜光明。是为菩萨摩诃萨舍天冠明珠善根回向。令一切众生。胜妙智慧皆悉清净。得净智慧摩尼宝冠。菩萨摩诃萨。见牢狱众生。受诸楚毒。或缚或打。闭在幽冥。杻械枷锁。拷掠流血。饥渴难忍。裸形羸瘦。被发覆身。受无量苦。无能救者。菩萨摩诃萨。见如是等苦众生已。或舍财宝妻子眷属。或舍己身。于彼狱中救苦众生。如大悲菩萨善眼王。菩萨摩诃萨。于彼狱中出众生已。随其所须而给施之。或以医药咒术。令彼安隐。先令欢喜。复为说法。皆悉安立不放逸善根。于正觉法心不退转。菩萨摩诃萨。救狱人时。如是回向。以此善根。令一切众生。解脱爱缚。令一切众生。断生死流到智慧彼岸。令一切众生。灭除痴冥得明净智。拔众使根离诸尘垢。令一切众生。断三界缚得一切智。令一切众生。永灭结漏。得离烦恼地。无碍智慧。皆悉究竟到于彼岸。令一切众生。离爱慢缚。究竟成就离爱慢慧。令一切众生。脱诸欲缚。永离一切世间贪欲。住诸世间无所染着。令一切众生。得清净深心。常为诸佛之所守护。令一切众生。得无著无缚心。广大如法界。究竟如虚空。令一切众生。得菩萨神足。遍游诸刹调伏众生。舍离世间安住大乘。是为菩萨摩诃萨救苦众生善根回向。令一切众生。究竟如来智慧之地。菩萨摩诃萨。见送狱囚趣于死地。五种系缚。忧恼切心。命在须臾。众人围绕。舍阎浮提一切乐具。永离亲爱渐之死地。或以木贯置高标上。或以刀割。或以火焚。或缠身油灌以火烧之。受如是等无量诸苦。菩萨摩诃萨。见如是已。自舍身命救彼苦难。犹如持来菩萨胜进王菩萨等诸大菩萨。自舍己身受众楚毒。以救众生。作如是言。我当舍身以代彼命。设使苦痛过彼无量。悉当代受令其解脱。复作是念。见如是苦。而不代受。为失大利。何以故。我为众生故。救护众生故。发一切智菩提之心。是故舍身以代彼命。菩萨摩诃萨。救苦人时。如是回向。以此善根。令一切众生。得无尽身命。永离炽然忧悲苦恼。令一切众生。依诸佛住。受一切智力菩提记别。令一切众生。救诸怖畏永离恶道。令一切众生。得一切命。永入不死智慧境界。令一切众生。远离怨敌。佛善知识常共摄护。令一切众生。舍离刀杖修行净业。令一切众生。离诸恐怖。坐菩提树下降伏魔军。令一切众生。离大众恐怖。于无上法中。得净无畏大师子吼。令一切众生。得无障碍师子智慧行清净业。令一切众生。到无畏处救护一切苦恼众生。是为菩萨摩诃萨自舍身命救彼死囚善根回向。令一切众生。离生死苦究竟佛乐。菩萨摩诃萨。见人来乞连肤顶发及髻明珠。菩萨是时欢喜施与。如周罗宝王菩萨胜趣菩萨等诸大菩萨。有人从乞连肤顶发及明珠时。正心思惟不念余业。离诸世间专乐寂静。清净正念一切种智。修正直心。菩萨尔时手执利刀。即割肤发合髻明珠。右膝着地。敬心合掌。正念三世诸佛菩萨所行。发大欢喜。直心清净。一切正法。充满意根。心不计苦。苦者是生灭法。是无常法。作是念已。除灭众苦。欢喜布施善根回向。令一切众生。得无见顶相。成就菩萨周罗尊塔。令一切众生。得绀青发。得金刚发。得柔软发。悉能除灭诸烦恼患。令一切众生。得不乱发得光泽发。令一切众生。得柔软旋螺发。令一切众生。得右旋发。令一切众生。得佛相发。烦恼结习皆悉除灭。令一切众生。发出大光明普照十方。令一切众生。得佛清净不乱之发。令一切众生。得应供塔发。除灭恶心见如来发。令一切众生。发离诸尘垢。悉得如来无染着发。是为菩萨摩诃萨布施顶发及髻明珠善根回向。令一切众生。悉得究竟一切陀罗尼诸三昧门一切种智及佛十力。菩萨摩诃萨。布施眼时。如欢喜菩萨满月王菩萨等无量诸大菩萨。布施眼时。修施眼心。修慧眼心。得佛法眼心。向无上道心。究竟诸通心。专求智慧心。等三世菩萨。修惠施心。于乞眼者以爱眼观。以无坏信心而施彼眼。因生佛眼。增广菩提摩诃衍心。大慈大悲调伏六根。菩萨摩诃萨。修如是心。以眼惠施。常乐施与。建立正法。舍离世间欢乐放逸。厌离五欲。乐菩提心。随彼所求悉满其愿。长养平等无二布施。随彼所须悉能施与。善根回向。令一切众生。眼得开明为世作眼。令一切众生。得无障眼开广智藏。令一切众生得净肉眼。一切世间无能坏者。令一切众生。得净天眼。悉见众生死此生彼。令一切众生。得净法眼。能随顺入如来境界。令一切众生。得净慧眼。分别了知一切世间。令一切众生。得净佛眼。悉能觉悟一切诸法。令一切众生。得普净眼。究竟境界无所障碍。令一切众生。除灭痴曀得清净眼。了众生界空无所有。令一切众生。得无障眼。得到如来十力胜处。是为菩萨摩诃萨布施眼时善根回向。令一切众生。得一切智眼。菩萨摩诃萨。布施耳时。如胜王菩萨胜无怨菩萨布施耳时。修菩萨行生如来家。修习诸佛所行布施。正念一切菩萨净行。随顺诸佛菩提。出生清净诸根智慧功德。观察世间无坚固者。令一切众生。常见一切诸佛菩萨。自于己身无所染着。随顺正念一切佛法。菩萨摩诃萨。布施耳时。其心寂静调伏诸根。免济众生崄难旷野。生智慧灯功德。成就檀波罗蜜海。施心成满。知义知法。明识诸道。得智慧行。于法自在。以不坚固身。易坚固身。菩萨摩诃萨。布施耳时。如是回向。以此善根。令一切众生。得无碍耳。悉能普闻无量法音。了达无碍。令一切众生。得无碍耳。分别了知无量音声。令一切众生。得无对耳。得佛净耳。令一切众生。得清净耳。解了耳根空无所有。令一切众生。得广大耳。皆悉寂静识无所起。令一切众生。得法界等耳。能善闻持一切佛法。令一切众生。得无著耳。悉能分别无碍诸法。令一切众生。得无坏耳。一切异论无能坏者。令一切众生。得周普耳。广大清净。令一切众生。得天耳佛耳。是为菩萨摩诃萨布施耳时善根回向。令一切众生。得清净耳。菩萨摩诃萨。布施鼻时。清净如是回向。以此善根。令一切众生。得如来鼻相。得善相鼻。得爱乐鼻。得清净鼻。得随顺鼻。得高好鼻。得伏怨鼻。得如来鼻。令一切众生。得端正面门。得一切法门。得无碍门。得善现门。得无厌门。得清净门。得离恶门。得诸如来圆满面门。得一切门。得善乐无量门。是为菩萨摩诃萨布施鼻时善根回向。令一切众生。究竟得入诸佛法中。令一切众生。摄取十方诸佛正法。令一切众生。分别深解诸佛妙法。令一切众生。于诸佛法得到彼岸。令一切众生。常见诸佛。令一切众生。得诸如来无量法门。令一切众生。得究竟清净。令一切众生。得佛法明普照诸法。令一切众生。得严净佛刹。令一切众生。得佛坚固不可坏身。是为菩萨摩诃萨布施鼻时善根回向

菩萨摩诃萨。安住自在大王地时。能以牙齿布施众生。如华齿王菩萨六牙白象王菩萨。布施齿时。获难得心。如优昙华。清净施心。无尽施心。不浊施心。无著施心。无量施心。调伏舍诸根心。一切施心。一切智愿心。安隐众生心。成就施心。大施心。胜施心。身之要用牙齿为最。己所宝重。众所叹惜。而能惠施诸乞求者。菩萨摩诃萨。安住此法。舍牙齿时。如是回向。以此善根。令一切众生。得白净利牙。成最胜塔受天人供。令一切众生。得佛齐密无间齿相。令一切众生。行调伏心。进趣菩萨诸波罗蜜。令一切众生。口齿清净显现明白。令一切众生。念庄严口。牙相成就开现鲜洁。令一切众生。含齿四十。常出无量清净妙香。令一切众生。得安住旋牙。华色庄严。能调伏心。令一切众生。得清净牙。能放无量亿千光明。鲜洁圆满普照十方。令一切众生。得徐嚼牙。饭入口回。粒粒皆碎。无所味着。为上福田。令一切众生。得胜妙牙。放无量色光。授菩提记。是为菩萨摩诃萨施牙齿时善根回向。令一切众生。得无碍严净诸法智慧。菩萨摩诃萨。若有人来从乞舌时。于乞求者柔软语。爱语。慈愍心语。生抚慰心。如善口王菩萨不退转菩萨。及余无量菩萨摩诃萨等。于诸趣中受无量生时。有乞舌者。先安乞人处师子座舍己舌时。以欢喜心。不坏心。无嫌恨心。大心。生佛家心。建立菩萨家心。不浊心。勇猛精进心。不着自身心。无怨敌心。以右膝着地。出舌示已。作柔软语。爱语。慈愍心语。谓乞者言。汝取我舌。随意所用充满汝意。菩萨摩诃萨。布施舌时如是回向。以此善根。令一切众生。得广长舌相。能出一切具足音声。令一切众生。得覆面舌相。所言无二皆悉诚实。令一切众生舌。能遍覆一切佛刹。示现诸佛自在神力。令一切众生。得软薄舌。宣通清净第一上味。令一切众生。得正语舌。有所言说。一切欢喜疑网悉除。令一切众生。得净光舌。能放不可说百千亿那由他光明。令一切众生。得决定语。善能分别无尽法藏。令一切众生。得净胜舌。善众言音究竟教化。令一切众生。得音声智。善能随顺入语言海。令一切众生。善能演说一切诸法。于诸语言出生智慧。得到彼岸。是为菩萨摩诃萨布施舌时善根回向。令一切众生。得无碍智诸愿满足。菩萨摩诃萨。若有众生来乞头时。如无上智菩萨。善男子。迦叶王菩萨。如是等无量诸大菩萨。布施头时。欲得一切妙智慧首。欲得无上菩提之首。救护众生。欲见一切诸妙法首。欲见一切净智慧首。欲具一切无碍法首。欲见最胜妙首之地。欲得胜智慧首。一切众生皆悉爱念。欲具智慧正法藏首。一切众生所不能睹。欲得十力大智慧王。欲得满足一切诸法自在之首。一切世间所不能坏。菩萨摩诃萨。住是法住。则学一切诸佛所学。深信诸佛长养善根。有来求者。充满其意悉令欢喜。菩萨心净欢喜施与。爱乐佛法。得清净明。安住菩提。心不退转。能行大舍。诸根欢悦。增长妙法。正直善心能广大施。菩萨布施头时。如是回向。以此善根。令一切众生。得如来首。一切世间无能见顶。于一切处所不能坏。出过一切诸世界上。顶相具足旋发庄严。一切世间所未曾有。得佛首相严胜殊特。令一切众生。得智慧首。最胜首清净首。具智慧首。是为菩萨摩诃萨布施头时善根回向。令一切众生。具足胜法。逮得无上大智慧首。菩萨摩诃萨。施众生手足。如勇猛王菩萨无畏菩萨。如是等无量菩萨摩诃萨。于诸趣中无量生处。布施手足。修信心手。常行正法饶益众生。威仪庠序。宝手为首。无著施手。菩萨所行真实不虚。施心广大建立善根。远离悭贪具菩萨行。于如来所得不坏信。除灭恶道成就菩提。菩萨摩诃萨。施手足时。以无量无边旷大之心。开净法门。入诸佛海。见一切佛。成就施手。满众生意。悉能受持一切种智菩提诸愿。修清净心。离烦恼缠。得智身法身。无断无坏。不可磨灭。一切魔业不能倾动。亲近善知识。修习一切菩萨布施之所出生。菩萨摩诃萨。一切智境界。施手足时。如是回向。以此善根。令一切众生。悉得宝手具神通力。成宝手已。各相敬重生福田心。以种种宝更相供养。又以众宝庄严。供一切佛。兴妙宝云遍诸佛刹。令一切众生。修习慈悲不相恼害。游诸佛刹安住无畏。以少方便究竟神足。以宝手。香手。衣手。盖手。鬘手。华手。末香手。庄严具手。无量华手。无量香手。普手。以神通力诣诸佛刹。供养诸佛。能以一手。遍摩一切诸佛世界。能以神足自在之手。持一切众生。手相成就放无量光。能以一手普覆众生。得佛缦网手足相好。是为菩萨摩诃萨大回向手普覆众生。令一切众生。志常乐求无上菩提。令一切众生。出生无量功德大海。得忍辱心。见来求者皆大欢喜。观无厌足。入深法海。逮得诸佛所共善根。是为菩萨摩诃萨施手足时善根回向

菩萨摩诃萨。坏身出血布施众生。如法手菩萨喜心王菩萨等。无量菩萨摩诃萨。于诸趣中无量生处于乞求者。坏身出血。而布施之。以萨婆若心施。喜菩提心施。乐修菩萨行心施。不计苦痛心施。于来乞者无慊恨心施。趣向一切菩萨心施。长养一切菩萨心施。增广菩萨善心施。以不退转心施。不休息心施。不惜己心施。菩萨摩诃萨。坏身出血布施时。如是回向。以此善根。令一切众生。具足菩萨法身智身。令一切众生。成就微密金刚之身。令一切众生。得无尽身清净不坏。令一切众生。得现化身。遍满十方一切世间。令一切众生。得可乐身。明净鲜洁不可沮坏。令一切众生。得法界生身。于如来身无所染着。令一切众生。得宝光明身无能坏者。令一切众生。得智藏身。于不死法而得自在。令一切众生。得宝海身。一切众生所见不虚。令一切众生。得虚空等身。于诸世间。无所染着。是为菩萨摩诃萨坏身出血布施善根。大乘心回向。清净心回向。大心回向。欢喜心回向。大欢喜心回向。无厌心回向。安乐心回向。不浊心善根回向。菩萨摩诃萨。见有人来乞髓肉时。欢喜软语。谓乞者言。我身髓肉随意取用。如饶益菩萨一切施王菩萨等。无量菩萨摩诃萨。于诸趣中无量生处。舍髓肉时心大欢喜。施心深广不可测量。一切菩萨所修习心。无上大乘妙善根心。舍离尘垢正直胜心。于来求者施无尽心。能舍自己爱重身心。一向专求无量善根妙功德宝所覆之心。菩萨所行无厌足心。大布施心。离疑惑心。于来乞者所布施物无中悔心。分别布施不求报心。平等布施无选择心。菩萨摩诃萨。施髓肉时。于诸佛所生尊父心。令一切众生。清净安住严净现在诸世界中一切佛刹。大悲现前救护众生。菩提现前十力明观三世。菩萨现前满足善根。无畏现前大师子吼。三世现前智慧平等。一切世间现前尽未来际修菩萨愿。无忧现前修习无数诸菩萨行。菩萨摩诃萨。施髓肉时。如是回向。以此善根。令一切众生。得金刚藏不可坏身。令一切众生。得微密身无有疏漏。令一切众生。得佛清净庄严如意法身。令一切众生。得百福德身。三十二相而自庄严。令一切众生。得八十种好妙庄严身。具足十力不可断坏。令一切众生。逮得如来常住妙身。不可测量。令一切众生。得最胜身。一切诸魔所不能坏。令一切众生。悉得一身等三世佛。令一切众生。得无碍身。微妙清净满虚空界。令一切众生。得菩萨藏身。悉能含受一切众生。是为菩萨摩诃萨布施髓肉一切智境界心善根回向。令一切众生。得佛常住无量法身。菩萨摩诃萨。见有众生来从乞心。如无忧厌菩萨不动王菩萨。如是等无量菩萨摩诃萨。见有人来从乞心时。欢喜施与。学不断施心。一切无尽施心。大檀波罗蜜心。到檀波罗蜜彼岸心。学一切菩萨行布施心。于一切施得无尽心。修习一切大布施心。建立一切菩萨施心。现前正念诸佛施心。充满一切来求施心。菩萨摩诃萨。布施心时。以清净心施。以度脱一切众生心施。以十力菩提境界心施。以满足大愿心施。以修习菩萨行心施。以得萨婆若心施。以不舍本愿心施。以此善根回向众生。令一切众生。得金刚藏心。一切金刚围山所不能坏。得金刚庄严心。离恐怖心。不可胜心。一切世间无能尽心。勇健胜幢智慧藏心。大那罗延高胜幢心。众生大海不可尽心。不可沮坏那罗延藏心。悉能坏散诸魔魔业魔军众心。威武勇健大丈夫心。无恐怖心。大誓庄严胜坚固心。最胜生菩萨心。具诸佛法菩提庄严心。坐菩提树成就一切如来正法离诸愚痴一切种智正觉之心。具十力心。是为菩萨摩诃萨施心善根回向众生。令一切众生。具足无著十力之心。菩萨摩诃萨。见有人来乞肠肾肝肺时。如难胜菩萨灭恶自在王菩萨。如是等无量菩萨摩诃萨。见有人来乞肠肾肝肺。见已欢喜。以爱眼观起菩提爱。随彼所乐悉满其意。欢喜施与心不中悔。正念观察。于不坚固身取坚固身。我此秽身虎狼狐狗众兽所食。此身无常可弃舍物。菩萨摩诃萨。如是观已。敬心谛视来乞求者。复作是念。我若不施。不得不坚固中坚固。无常中常。不净中净。菩萨摩诃萨。如是正念。则能开发清净直心。解真实法。于来乞者。生善知识心能教化。我不坚固中而取坚固。菩萨摩诃萨。作是念已。以此善根回向众生。令一切众生。得内外清净智慧藏身。令一切众生。得智慧藏腹。悉能受持一切智愿。令一切众生。得清净身见者无厌。演放坚固妙香光明。普熏十方。令一切众生。逮得如来腹不现相。身宜相称肢节具足。令一切众生。得法味食长养智身。具佛法爱柔软充满。令一切众生。得无尽身安住法身。令一切众生。得内清净总持藏身。一切辩明普照诸法。令一切众生。得清净身。内外悉净。令一切众生。得如来智修习行身。普雨甘露智慧法雨。令一切众生。悉得内身清净寂静外身。能为众生作智慧幢王。照明一切。是为菩萨摩诃萨施肠肾肝肺善根回向众生。令一切众生。悉得内外清净之身。安住坚固无障碍智菩萨摩诃萨。见有来乞肢节诸骨。如法藏菩萨夜光菩萨。如是等无量菩萨摩诃萨。施肢节骨。见来求者。生大欢喜心。明净心。寂静心慈心安。乐心无所。着心。清净心。于来乞者生满愿心。菩萨摩诃萨。以施肢节所摄善根回向众生。令一切众生。得如化身。永离世间骨血肉身。令一切众生。得金刚力身。无能坏者。无能胜者。令一切众生。得萨婆若力。具足法身。从无缚无著法界出生。令一切众生。得智力身。诸根坚固不可断坏。令一切众生。得法力身。智力自在到于彼岸。令一切众生。得坚固身不可坏散。令一切众生。得随应化身。善能调伏成熟众生。令一切众生。得智熏身。具那罗延肢节庄严。令一切众生。得坚固流注不断绝身。究竟永离一切疲倦。令一切众生。得安住力身悉皆具足勇猛精进。令一切众生。得净法身。悉能分别一切众生。入于无量智身境界。令一切众生。得功德力身。除灭众恶。见者不虚。令一切众生。得无碍身。皆悉究竟。无染着智。令一切众生。得佛所摄身。常为一切佛所守护。令一切众生。得普饶益众生之身。悉能遍入一切诸道。令一切众生。得圆应身。十方众生悉见其面。无背佛法。清净照明常现在前。令一切众生。得具足精进身。修习究竟大乘智慧。令一切众生。舍离我慢自大放逸之身。得清净身。智慧安住不可倾动。令一切众生。得坚持戒身。成就大乘一切智业。令一切众生。得生佛家身。永离世间生死秽身。是为菩萨摩诃萨施肢节诸骨善根回向。令一切众生。皆悉清净得萨婆若。菩萨摩诃萨。见有人来手执利刀乞厚薄皮。以爱眼视。欢喜恭敬为敷座处。即作是念。福田难遇。而今自来满我本愿。决定究竟一切种智。作如是言。取我身皮随汝意用如清净藏菩萨金刚胁鹿王菩萨。如是等无量菩萨摩诃萨。布施乞人厚薄皮时。如是回向。以此善根。令一切众生。得如来薄皮相金色清净。令一切众生。得金刚坚固不坏薄皮。令一切众生。得金色皮。如阎浮檀金藏。令一切众生。得无量色皮。随应现色悉令清净。令一切众生。得明净皮不受尘垢。如乐沙门如来净色。令一切众生。得第一色皮。自然清净。令一切众生。逮得如来清净色皮。微妙相好而自庄严。令一切众生。得明净皮。放大光明普覆一切。令一切众生。得明网皮。无量光明圆满具足普覆世间。令一切众生。得润泽皮。众色清净。是为菩萨摩诃萨布施自身厚薄皮时善根回向。令一切众生。逮得无上最胜菩提。皆悉具足如来功德

大方广佛华严经卷第十七大方广佛华严经卷第十八

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之五

菩萨摩诃萨。见有人来乞手足指。如坚固精进菩萨。阎浮提自在王金光菩萨等。无量菩萨摩诃萨。施手足指时。心大欢喜颜色无异。乘大乘施。不求五欲施。不求名闻施。建立檀波罗蜜施。大施心施。离悭垢施。离嫉妒施。随顺佛施。以是施手足指所摄善根回向众生。令一切众生。得佛长指相。令一切众生。得指密相圆佣纤直。令一切众生。得赤铜甲相筒密清净。令一切众生。得大人指相。悉能摄持一切诸法。令一切众生。得具足随好十力相指。令一切众生。得大人指相纤佣紧密。令一切众生。手足指端轮相庄严。指节平满文相明显。令一切众生。得莲华色指。十力业报相好庄严。令一切众生得光明指放光明网。普照十方诸佛世界。令一切众生。得净妙指。以诸相好具足庄严。是为菩萨摩诃萨施指善根回向众生。令一切众生。心皆清净。复次菩萨摩诃萨。请求法时。若有人言。汝能施我连肉爪者。当与汝法。菩萨答言。但与我法。随汝所须恣意取用。如求法王菩萨。无尽菩萨。如是等无量菩萨摩诃萨。为求法故。欲令一切众生具正法故。以是善根回向众生。令一切众生。悉得赤铜如来相爪。令一切众生。得润泽爪。令一切众生。得佛具足清净光爪。令一切众生。得具足大人一切智爪。令一切众生。得无比爪。于诸世间无所染着。令一切众生。得庄严爪。普照众生。令一切众生。得细妙爪。微密清净不可破坏。令一切众生。得佛具足方便相好大智清净。令一切众生。得善生爪。菩萨清净行业果报。令一切众生。得萨婆若善方便爪。放无量色妙光明藏。是为菩萨摩诃萨施爪肉善根回向众生。令一切众生。得一切智爪。具足庄严如来法身。皆悉满足无障碍力。菩萨摩诃萨。为求法故。为难得法故。能施法者。作如是言。若能投身七仞火坑。当与汝法。菩萨闻此欢喜无量。作是思惟。我为法故。尚于阿鼻地狱诸恶趣中。受无量苦。况入人间微小火坑。而得闻法。奇哉正法甚为易得。免于地狱无量楚毒。入小火坑而闻正法。汝但说法我入火坑。如求善法王菩萨金刚思惟菩萨。为法欢喜入火善根回向众生。令一切众生。得佛所住一切智法。于无上道坚固不退。令一切众生。皆悉除灭恶趣火坑。受如来乐。令一切众生。得无畏心离众恐怖。令一切众生。常乐求法。皆得欢喜佛法庄严。令一切众生。离诸恶道。悉能除灭三毒炽火。令一切众生。悉得快乐。成就如来最胜妙乐。令一切众生。得菩萨心。悉能除灭贪恚痴火。令一切众生。悉得菩萨诸三昧乐。普见诸佛心大欢喜。令一切众生。常闻正法。究竟佛道未曾忘失。令一切众生。悉得菩萨自在诸通快乐。究竟具足萨婆若智。是为菩萨摩诃萨为求法故。赴火善根回向众生。令一切众生。具智慧火。远离一切诸不善业。菩萨摩诃萨。为求法故。举身具受无量诸苦。为正法故。为广说正法故。建立菩萨道故。开无上菩提故。具足无上智故。修习十力故。增广一切智心故。得无碍智故。令一切众生清净故。入一切菩萨境界故。守护大乘佛菩提故。如求正法菩萨勇健王菩萨。如是等无量菩萨摩诃萨。为求法故受无量苦乃至谤正法人。极大恶人。恶业障人。持魔业人。为正法故。代彼恶人具受诸苦。菩萨摩诃萨。为求法故。代诸众生受苦。善根回向众生。令一切众生。离一切苦得安乐利道。令一切众生。离诸苦受成就妙乐。令一切众生。永灭苦阴得如电光乐。令一切众生。超出苦狱。具足究竟智慧之行。令一切众生。见安隐道离苦恼趣。令一切众生。得法爱乐充满具足。究竟寂灭一切众苦。令一切众生。发大悲心。悉欲济度一切苦海。令一切众生。得诸佛乐断生死苦。令一切众生。得无比净乐。其身永离一切苦受。令一切众生。得一切胜乐。究竟具足佛无碍乐。是为菩萨摩诃萨为求法故悉受众苦善根回向救护众生。令一切众生。安住萨婆若无碍解脱。菩萨摩诃萨。为求法故。为法难得故。能舍大地四海国土。大小诸城村邑丘聚。国土丰乐人民炽盛。园林浴池华果繁茂。如是种种无量庄严。天下太平无有怨敌。金银宝藏妻子眷属皆悉能舍。于不坚固中求坚固法。饶益一切诸众生故。令一切众生。得佛无碍清净解脱萨婆若道。如大势妙德菩萨胜趣王菩萨。如是等无量菩萨摩诃萨。为求正法故。乃至一句一味。五体投地。敬礼顶受。正念三世诸佛勤求正法。于正法中心常欣乐。修习诸愿。求离贪法。舍离世间帝王自在之法。乐求无上法王自在胜法。不念不着一切世间。以离世法自长养心。远离一切世间恶语。寂静安立诸佛所住。菩萨摩诃萨。为求正法。以施四天下大地国土。所摄善根回向众生。令一切众生。悉能舍离内外所有。令一切众生。能舍一切心无中悔。令一切众生。不惜身命资生之具。常求正法。令一切众生。悉得法利。断除无量众生疑惑。令一切众生。常乐正法。于诸佛法得深法爱。令一切众生。能舍身命世间自在。乐求佛法大心。修习无上菩提。令一切众生。恭敬尊重诸佛正法。能舍身命究竟正法。令一切众生。护持佛法。修习如来难得闻法。令一切众生。悉得诸佛菩提明照。毕菩萨行不由他悟。令一切众生。于诸佛法而得自在。拔出疑刺心常清净。是为菩萨摩诃萨为求难得法故布施国土善根回向。令一切众生知见满足。复次菩萨摩诃萨。行法自在时。悉教断除阎浮提内城邑聚落一切屠杀二足四足。普施无畏离怨敌心。修菩萨行以政治国。灭除众生一切苦难。发起一切众生安隐心宝。具足正直胜妙心宝。能自具足三种戒法。亦令众生具三种戒。菩萨摩诃萨。以不杀等五戒善根。回向众生。令一切众生。得长寿慧。具菩提心。命根无量。令一切众生。得无量寿。恭敬供养一切诸佛。令一切众生。具足修习离老死法。一切众难不能害命。令一切众生。逮得无量离病苦身。命根自在能随意住。令一切众生。得无尽命。尽未来劫。悉具修习菩萨所行。调伏化度一切众生。令一切众生。得净命门。十力善根皆悉来入。令一切众生。善根具足。寿命无量诸愿成满。令一切众生。悉见诸佛。修习无尽长寿善根。令一切众生。于如来家学诸所学。具足成就无尽命根。于圣法中得欢喜心。令一切众生。得无老病不死命根。无尽精进安住佛智。是为菩萨摩诃萨以离杀等五戒善根回向众生。令一切众生。安住如来三种净戒。具足究竟十力智慧。菩萨摩诃萨若见众生残害不仁。若人若兽毁其男形。令身残阙受诸楚毒。见此苦已。起大慈悲而救度之。悉令贵乐珍宝具足。菩萨摩诃萨。谓恶人言。汝为何利造此恶业。随汝所须尽相资给。汝今便可舍是恶业。不能正念肆其贪欲。害彼自利以求己乐。无有是处。如此恶行诸不善法。一切如来所不赞叹。菩萨摩诃萨。悉能舍离一切所有。令彼众生不行恶业。又为彼人说微妙法。谓寂静法。长养净行除灭不善。修习慈心不恼众生。时彼恶人闻此法言。即舍恶行修清净业。菩萨摩诃萨。以慈救善根回向众生。令一切众生。得佛大人阴藏之相。令一切众生。具足男形。得丈夫意清净梵行。令一切众生。成就丈夫无欲之身。乘无碍智究竟不退。令一切众生。得大人身。永离欲心无所染着。令一切众生。皆悉成就善男子法。诸佛赞叹智慧具足。令一切众生。得大人力。具足成就十力善根。令一切众生。常得成就男子之形。坚固安住未曾有法。令一切众生。于五欲中。无著无缚。心得解脱。厌离三界。修菩萨行。令一切众生。皆得成就第一智人。一切信伏皆受道化。令一切众生。成就菩萨丈夫深智。究竟一切大乘佛趣。是为菩萨摩诃萨救毁形者善根回向。令一切众生皆悉救护诸善男子。生贤圣家。智慧具足。修习履行男子胜智。善能示现七丈夫趣。具足无上丈夫正法。常能化度一切众生善根回向。令一切众生。得佛清净丈夫胜法。复次菩萨摩诃萨。若有如来兴出于世。以大音声普告一切。如来出世如来出世。令一切众生得闻佛音。闻佛音已舍离自大憍慢放逸。得见诸佛。坚固安住念佛三昧。修佛境界。未曾废忘。恭敬供养一切诸佛。常乐见佛。以百千劫难值遇故。广为众生说佛难遇。众生闻已。常欲乐见一切诸佛。心大欢喜。恭敬供养。尊重赞叹。于如来所。闻诸佛名。于无量佛所。种诸善根。修习增长。无量众生。因如来故。悉皆清净。无量众生因如来故。悉净调伏。彼诸众生于菩萨所。生善知识心。因菩萨故。诸众生等悉具佛法。彼诸众生。无量劫中所修善根。悉作佛事。菩萨摩诃萨。以叹佛善根。回向众生。令一切众生常见诸佛。初不失时。如应受化。令佛欢喜。令一切众生。常乐见佛未曾废忘。令一切众生修习智慧。能持一切诸佛法藏。令一切众生。不离佛法。于无量劫修菩萨行。常闻正法。令一切众生。得不忘念。悉持一切诸如来智。令一切众生。不念异业。正念诸佛修习十力。令一切众生。随方见佛尽虚空界。一切如来悉得奉见。令一切众生。得佛身自在。于一切世界现成佛道。令一切众生。于善知识所。闻佛正法。于诸如来得不坏信。令一切众生。赞佛出世皆悉不虚。化度众生普令清净。是为菩萨摩诃萨叹佛出世善根回向。令一切众生。悉见诸佛如应受化。于无上道一切佛法究竟清净。复次菩萨摩诃萨。布施大地。或布施佛。起立殿堂。或施菩萨及善知识。随意所用。或施圣僧。造立坊舍。或奉父母。兴建屋宅。或施余人。声闻缘觉。一切福田诸乞求者。或施四众随意受用。令无所乏。或奉如来造立塔庙。如是等施随彼受用悉离怨敌一切恐怖。菩萨摩诃萨。以施大地善根回向。令一切众生。得萨婆若清净佛地。究竟得到普贤菩萨所行彼岸。令一切众生。得大地陀罗尼离痴正念。悉能受持诸佛妙法。令一切众生。持一切法守护佛法。令一切众生。得大地等心。于众生所。清净正直不生恶念。令一切众生。持佛族姓不断佛种。次第成立一切菩萨诸地善根。令一切众生。普为一切作安隐依。悉令调伏成就清净。令一切众生。与如来等饶益众生安立佛力。令一切众生。悉为一切之所爱乐。安住诸佛所爱乐处。令一切众生。坚固安住如来诸力无畏法中。令一切众生。得萨婆若地。于诸佛法自在究竟。是为菩萨摩诃萨布施大地善根回向。令一切众生界。究竟如来清净道地。复次菩萨摩诃萨。布施僮使。或奉诸佛菩萨知识。为欲增长如来法故。或施僧宝。或奉给父母尊重福田。或复给施诸病瘦者。全济其命。一切贫穷。诸乞求者皆悉施与。或施塔庙供给洒扫。若有人能书写佛经。为护法故。以无量亿僮仆净人。给其使令。此诸给使皆悉聪达。明了黠慧柔软调伏。常勤精进未曾懈怠。成正直心。饶益心。安乐心。慈心。离怨敌心。此诸僮仆以如是心奉给于彼。菩萨摩诃萨。随彼受者方俗所宜才能技术。以此僮仆而施与之。悉是菩萨净业所起。能令僮仆悦可彼意。菩萨摩诃萨。以施僮使善根回向。令一切众生。得调伏心。奉给诸佛。修习善根。令一切众生。随顺奉给一切诸佛。悉能闻持诸佛所说。令一切众生。随意自在进现如来。常修正念无余恶心。令一切众生。绍继佛种。随顺如来所摄善根。令一切众生。奉给如来。常不失时。所见诸佛。皆悉不虚。令一切众生。悉摄一切诸佛妙义。言辞清净游行无畏。令一切众生。悉睹诸佛。乐观无厌。于诸如来。不惜身命。令一切众生。得见诸佛。心无染着离世所依。令一切众生。依止诸佛。远离一切世间吉祥。令一切众生。随顺佛趣。一向乐求无上菩提。是为菩萨摩诃萨布施僮使善根回向。令一切众生。永离垢染。得佛净地。如来法身自在无碍。菩萨摩诃萨。以身布施为给使时。舍离憍慢谦下心。给使心如大地心。忍一切苦心。供给一切无厌足心。无懈怠心。与一切贫贱众生诸善根心。一切尊贵富乐。乃至童蒙愚小皆悉恭敬供养心。坚固安住最胜法门。正念修习一切善根心。菩萨摩诃萨。以身布施善根回向。令一切众生。僮使无乏。修菩萨行。心不退转。未曾违失菩萨正义一心专求菩萨之道。了达菩萨平等正法。得在如来种姓之数。修真实法。增菩萨行。令诸世间得净佛法。深心解脱。究竟菩提。令一切众生。增长清净胜大善根。令一切众生。向大功德。究竟一切智。菩萨摩诃萨。复作是念。以身供给。所摄善根。令一切众生。善能给侍一切诸佛。其心调柔。常闻正法。受持法。守护法。不忘法。不坏法。不选择法。不离法。善调伏法。善能调伏不调伏法。调伏寂灭法。令彼众生。于诸佛所善能随顺。以随顺功德。令一切众生。作第一塔。悉能堪受众生供养。令一切众生。作第一福田。自然正觉无上菩提。令一切众生。作最胜福田。普能饶益一切众生。令一切众生。悉作殊胜功德义藏。皆能穷尽善根源底。令一切众生。作净妙福田。悉能出生果报无量。令一切众生。得胜出道。悉能超出一切世间。令一切众生。作第一调御。随其所应悉能示导。令一切众生。得最胜陀罗尼。悉能受持诸如来法。令一切众生。逮得无量最胜法界。具足虚空无碍正道。是为菩萨摩诃萨布施己身善根回向。令一切众生逮得如来应供智身。菩萨摩诃萨。悉得法爱清净喜心。能以自身。普覆诸佛。常乐修习无上法宝。于诸佛所。生父母心。欲得究竟无碍道法。成就无数那由他智慧妙宝。诸善根门。于诸如来无量法门正念不忘。深解如来诸境界义。能以如来微密梵音。普雨一切诸佛法雨。如来法云。遍覆一切。而无所畏。能分别说一切智人地。具足究竟萨婆若乘。以无量无边大法。成满诸根。菩萨摩诃萨。于诸佛所。闻甚深法。欢喜无量。修习正道。自能除灭一切疑惑。又令众生欢喜无量。疑网悉除。功德成满。善根具足。修习无量法门。普行大愿。饶益众生安住不动。金刚藏智。正心专求无上菩提。悉能严净一切佛刹。恭敬亲近无量如来。菩萨摩诃萨。安住此法。自身普覆一切诸佛。以此善根。回向众生。令一切众生。妙身具足。悉能普覆一切诸佛。令一切众生。依如来住。常见诸佛。未曾远离。令一切众生。得最胜身。具足一切功德智慧。令一切众生。行离有梵行。能令一切诸佛欢喜。令一切众生。得无我所身。于我我所心无所著。令一切众生。悉能分身遍一切刹。于诸世界而无来去。令一切众生。得自在身。离我我所自在游方。令一切众生。出生佛身。处在如来无上身家。令一切众生。得法力身。安住法座。忍力成就。心不可坏。令一切众生。得无比身。具足如来清净法身。令一切众生。得出世间功德之身。于空法界。而得出生。是为菩萨摩诃萨自身覆佛所摄善根回向众生。令一切众生。成三世佛胜妙功德。菩萨摩诃萨。以身布施一切众生时。作如是念。令一切众生。成就善根。令一切众生。常念善根。令一切众生。能为明灯。令一切众生。安隐乐住。令一切众生。得法藏腹。悉能含受一切众生。令一切众生。作世间明。灭除众闇。令一切众生。悉作一切善根因缘。为善知识展转相成。开示正道。得无上乐。令一切众生。作明净日。菩萨摩诃萨。以身布施一切众生所摄善根。回向众生。令一切众生。究竟诸佛智慧道地。令一切众生。随顺正道。悉令究竟无上菩提。令一切众生。常处佛会。悉受正化。令一切众生。威仪具足。成就诸佛清净威仪。令一切众生。悉得涅槃深解法义。令一切众生。悉得胜法。而无厌足。常遇胜法。生如来家。令一切众生。舍世希望。逮得如来真实希望。令一切众生。坐菩提树。出生无量清净善根。令一切众生。摧灭一切烦恼怨敌。发无害心。令一切众生。得无畏法。悉能护持一切佛法。是为菩萨摩诃萨布施自身善根回向。令一切众生。饶益安隐。得无上法。菩萨摩诃萨。自以己身。奉给诸佛。于一切如来。生报恩心。生父母心。于诸佛所。生清净深心。以明净心。受持菩提。得诸佛法。舍世间法。生如来家。随顺诸佛。守护自法。远离一切众魔境界。修佛境界。自以己身。成就一切诸佛法器。菩萨摩诃萨。修如是法。自身奉给一切诸佛所摄善根。回向众生。令一切众生。安住净心。一切智宝而自庄严。令一切众生。得调伏众生与其同事。远离一切诸不善业。令一切众生。得不坏眷属。悉能摄持诸佛正法。令一切众生。悉为如来清净弟子。成就灌顶菩萨之地。令一切众生。悉为诸佛之所摄护。远离一切诸恶知识。令一切众生。随顺诸佛。修习最胜生地菩萨法行。令一切众生。入佛境界。悉皆得受一切智记。令一切众生。与如来等。于诸佛法。而得自在。令一切众生。悉为诸佛之所摄取。行无著业。令一切众生。悉为诸佛第一侍者。智慧具足。悦可诸佛。是为菩萨摩诃萨身奉事佛善根。回向无上菩提。回向救护一切众生。回向。众生超出三界。回向自心悉令清净。回向无量广大菩提。回向诸佛照明智慧。回向己身为佛所摄。回向受持一切佛法。回向乐求一切佛法。回向善根悉与三世诸如来等。回向清凉心得一切佛法

菩萨摩诃萨。布施国土时。舍世帝王自在之心。无著无缚。不求自在。远离恶业。普于众生。悉起饶益安乐之心。菩萨摩诃萨。以施国土善根回向。令一切众生。远离愚痴。明识业报。令一切众生。不乐世法。令一切众生不着一切世间生处。令一切众生。不取世界坚固之相。令一切众生。心不染着阴界诸入。令一切众生。心不染着我我所法。令一切众生。心不忘失诸菩萨行。令一切众生。未曾舍离诸善知识。令一切众生。能悉受持菩萨愿行。令一切众生。诸善知识皆悉欢喜。菩萨摩诃萨。以施国土善根回向。令一切众生得法王处。于自在法。得到彼岸。令一切众生。得法王法。调伏一切结王怨敌。令一切众生。与法王同止。赞叹佛法如来智慧。令一切众生。住佛境界法王之家。能自在转无上法轮。令一切众生。出生如来巧妙方便。得法自在。护持佛法永使不绝。令一切众生。护持无量法王正法。皆悉成就胜大菩萨。令一切众生。于净法界。得为法王。出兴于世。相继不绝。令一切众生。于诸世界作智慧王。调伏成熟一切众生。令一切众生。普为法界虚空界等世界众生。作法施主。建立一切诸众生界于摩诃衍。令一切众生。得法王法。与三世佛善根齐等。是为菩萨摩诃萨布施王位善根回向。令一切众生。皆悉究竟安隐之处。菩萨摩诃萨。见有人来乞王京都严饰大城。以欢喜心施。不乱心施。一向正求菩提心施。无量愿心施。大慈心施。大悲心施。清凉心施。为利一切众生故施。自安立摩诃衍故施。以诸佛法平等心施。行善法心施。欲一切智王心施。求法王自在意故施。欲增上智慧心施。欲一切清净功德心施。坚固广大心施。长养一切善根故施。远离众魔恐怖具足佛智故施。安住菩萨心力故施。究竟一切境界一切智菩萨所行及诸大愿故施。菩萨摩诃萨。布施京都严饰大城。所摄善根。回向众生。令一切众生。净一切刹施佛令住。令一切众生。常乐阿兰若处。安住寂静。令一切众生。不着一切国土都邑聚落大小诸城。究竟离欲。得上寂静。令一切众生。心不亲近一切世间。悉皆永离世间语言。令一切众生。得离欲心。布施所有心不中悔。令一切众生。不着家业。得净直心。令一切众生。悉舍一切。无所缚着。善施成就。令一切众生。不着住处。舍离一切居家贪着。令一切众生。舍诸苦恼。除灭一切恐怖忧戚。令一切众生。以一切世界为严净刹奉施诸佛。是为菩萨摩诃萨布施京都严饰大城善根回向。令一切众生。严净佛住。菩萨摩诃萨。布施宝女侍人眷属。技术悉备。才能巧妙。善于言戏。威仪具足。奉给恭顺。能感人心。世间功德。无不备举。庄严绮丽回动天人。言音和雅而无粗陋。侍主尽礼。不失其意。姿容殊妙。见者无厌。千亿技直供侍宝女。皆是菩萨净业果报。而用布施。以无著心施。离虚妄心施。不缚一切欲施。于一切色无所著施。不贪欲乐施。离欲觉观施。于宝女形色不生想施。菩萨摩诃萨。布施宝女眷属善根回向回向一切众生出离生死。回向悉得诸佛喜乐。回向不坚固中而得坚固。回向金刚界智不可坏心回向如来圆满大众。回向摄取坚固真实。回向无上菩提之心。回向智慧分别诸法。回向出生一切善根。回向不违三世佛教。菩萨摩诃萨住如是法。生如来家。出生一切智道。深入一切菩萨智业。舍离一切世间尘垢。调伏宝心功德。圆满无上福田。广说妙法。安立众生。令一切众生。皆悉清净。修习摄取一切善根。菩萨摩诃萨。布施宝女眷属所摄善根回向众生。令一切众生。逮得无量三昧眷属。又得菩萨不坏三昧。令一切众生。悉入诸佛庄严三昧。常乐观佛。令一切众生。悉行菩萨不可思议自在游戏三昧。安住无量自在三昧。令一切众生。入如实三昧。不坏其心。令一切众生。悉得菩萨甚深三昧。于一切三昧。皆得自在。令一切众生。皆悉成就三昧眷属。心得解脱。令一切众生。善能分别种种三昧。悉能善取诸三昧相。令一切众生。得胜智三昧。修习一切诸三昧门。令一切众生。得无碍三昧。能决定入不坏正受。令一切众生。得无著三昧。心常念行不二三昧。令一切众生。得不可坏清净眷属。菩萨眷属。令一切众生。普发清净菩提之心。满足佛法。令一切众生。萨婆若力清净满足。得无上智。令一切众生。得随顺眷属。悉与众生同意安住。令一切众生。悉得满足一切智功德。成就一切胜妙善根。令一切众生。得真实眷属。成就如来清净法身。令一切众生。成就诸辩无缚无著。广说诸佛无尽法藏。令一切众生。各为一切。作善知识。成就一切胜妙善根。令一切众生。净业满足。成就一切诸清净法。令一切众生。满足诸佛净妙法门。以诸净法。庄严世间。是为菩萨摩诃萨布施宝女眷属善根回向

复次菩萨摩诃萨。布施妻妾男女。如须达拏太子。现庄严王菩萨。如是等无量菩萨摩诃萨。乘萨婆若乘。行一切施。具足成满檀波罗蜜。严净菩萨布施之道。长养清净不悔施心。入一切施宝萨婆若心。令一切众生。皆悉清净。具正直心。具足清净正直心已。一切菩提。皆悉满足。志常乐求菩萨净道。受持诸佛菩提门愿。修习一切如来家心。如是菩萨摩诃萨。意力成就。求如来处。自知己身系属一切不得自在随彼走使。普于众生。行一切施。于未满足者。悉令满足。护持安慰一切众生。欲令自身普为世间作第一塔。令一切众生皆悉欢喜。欲于一切具平等心。欲为世间作清凉池。欲为世间作施乐主。欲为一切作大施主。智慧为首。习菩萨行。如说修行。欲成一切种智。大誓庄严。欲常专求智慧福田。悉请众生。长养善根。建立己身。崇顺正教。普为一切作智慧明。正念菩萨一切施心。一切诸佛常现在前。菩萨摩诃萨。以布施妻妾男女所摄善根。无著无缚解脱心。回向众生。令一切众生。普出无量变化之身。充满十方一切世界。转不退法轮。安立一切众生于无上道。令一切众生。不贪着身。诸愿具足。悉诣十方诸佛世界。令一切众生。得离憎爱心。断爱恚结。令一切众生。为佛真子。行如来家。令一切众生。于诸佛所。生自己心。不可沮坏。令一切众生。常为佛子。从法化生。令一切众生。得正希望成萨婆若。令一切众生。修习善根。究竟具足无上菩提。令一切众生。成就诸佛菩提解脱。施无上法。令一切众生。得无生心。不坏因缘。令一切众生。坐菩提树。得最正觉。成无上道。化生无量真法男女。是为菩萨摩诃萨布施妻妾男女善根回向。令一切众生。得无著解脱无碍智慧。菩萨摩诃萨。见有人来从乞家者。以家庄严具。具足庄严。而布施之。修习威仪。于家无著。远离居家。一切觉观。厌恶家业资生之具。于家珍妙玩好之物。不生贪心。无所味着。于家众具无染缚心。解家磨灭须臾变易。出家求道。究竟佛法。安住菩萨住。佛法庄严心。能舍一切。而不中悔。常为诸佛之所称叹。于资生物一切住处心无染着。见来求者。欢喜无量。能决定施。菩萨摩诃萨。以家布施所摄善根如是回向众生。令一切众生。舍离妻子常乐出家。令一切众生。信家非家。舍家求道。于佛法中。净修梵行。令一切众生。乐一切施。心不中退。安住离悭。令一切众生。永离家法。少欲知足。无所藏积。令一切众生。不乐俗家。常乐佛家。令一切众生。悉皆永离障碍之法。灭除一切诸障碍道。令一切众生。不染家属。虽现在家。心无所著。令一切众生。善化一切。虽现在家。说正觉智。令一切众生。示现在家。住佛所住。心常随顺如来智慧。令一切众生。在家悉能悦喜众生住佛所住。是为菩萨摩诃萨以施家善根回向。令一切众生。悉行菩萨种种诸行。满足诸愿智慧自在

菩萨摩诃萨布施庄严游戏园林时。作如是念。我当为一切众生作爱乐法林。我当为一切众生示现悦乐之处。我当与一切众生无量欢喜。我当为一切众生开净法门超出三界。我当与一切众生无上菩提满足诸愿。我当为一切众生而作慈父。智慧观察一切三界。我当惠施一切众生资生之具令无所乏。我当为一切众生而作慈母。出生善根满足诸愿。菩萨摩诃萨。善根回向无厌足心。远离一切众生诸恶回向。正心安隐一切众生回向。不求报恩回向。不求众生利养回向。不求赞叹回向。除灭一切众生无量苦恼回向。一切众生其心清净犹如虚空回向。一切善根为首观察一切诸法真实回向。一切众生以大庄严而自庄严永离苦阴回向。于摩诃衍愿而无厌足永离邪见具足修习菩萨所行及诸大愿回向。菩萨摩诃萨。以施庄严游戏园林所摄善根。回向众生令一切众生。得转胜善根。究竟成就无上菩提园林之心。令一切众生。得不动法。普见诸佛。皆悉欢喜。令一切众生。常乐法林。逮得佛刹娱乐园林。令一切众生。得净妙心。常见如来大神足林。令一切众生。悉乐如来自在游戏。智慧自在遍游十方。令一切众生修习法戏。诣诸佛刹。咨受道化。令一切众生。乐菩萨戏。尽未来劫。修菩萨行。心无疲倦。安住解脱。令一切众生。见一切佛充满法界。乐佛大心清净园林。令一切众生。诣诸佛刹。其心欣乐。供养诸佛。令一切众生。乐离欲心。清净庄严一切佛刹。是为菩萨摩诃萨布施庄严游戏园林善根回向。令一切众生。游戏一切诸佛园林。见一切佛

大方广佛华严经卷第十八大方广佛华严经卷第十九

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之六

复次菩萨摩诃萨作无量亿那由他阿僧祇大众施会。离恶清净诸佛所叹。普净众生。永离众恶。净三业迹。生萨婆若。无量境界皆悉清净。无量百千亿那由他布施之具。皆悉庄严而以惠施。菩萨摩诃萨。以大施会所摄善根。回向众生。令一切众生。悉得无上菩提之心。行无量施皆悉清净。令一切众生。皆悉究竟无量无边清净之道。令一切众生。行无量慈。随众所须。悉令满足。令一切众生。行无量悲。悉能救护一切众生。令一切众生。随顺三世如来正教。令佛欢喜。令一切众生。于诸佛所。修行布施。心不中悔。令一切众生。皆悉长养胜妙信根。于念念中。修行增进无量布施。令一切众生。得摩诃衍心。皆悉成就大乘施会。令一切众生。成大善会施。究竟施。善施。胜施。随愿施。第一施。上施。无上施。无等施。出世间施。一切诸佛所赞叹施。令一切众生。成第一施主。于诸恶道拔出众生。安置无碍清净智道。修平等愿真实善根。得无等等如来智慧。令一切众生。安住寂静诸禅定智。趣不死道。究竟一切通明智慧。勇猛精进。具足诸地。庄严佛法。究竟彼岸永不退转。令一切众生。得不退转大乘之会。给施众生而无休息。究竟无上一切种智。令一切众生种诸善根。悉到无量功德彼岸。令一切众生。诸佛所叹。普为一切作大施主。功德具足充满法界。普照十方。施无上乐。令一切众生。悉为平等大布施主。究竟善根等摄众生。令一切众生。为胜施主。建立一切于无上乘。令一切众生。为应时施主。悉离非时究竟时会。令一切众生。为善施主。具大人施法到于彼岸。令一切众生。为严净施主。至一切佛萨婆若处。令一切众生。为一切净施主。出生积聚法界等功德。令一切众生。为出过一切施主。满足大愿度脱众生。安住如来处非处力。是为菩萨摩诃萨大施善根回向。令一切众生。行无上舍。究竟佛施。成就善施。不可坏施。诸佛法施。爱眼心施。救众生施。萨婆若施。见诸佛施。具威仪施。具足菩萨所行功德佛智慧施。复次菩萨摩诃萨。悉舍一切资生之具。心无贪着。不求果报。世间富乐无所希望。舍离愚痴。深解诸法。饶益安立一切众生。真实相心解一切法。种种庄严诸资生具。无量境界种种庄严。资生之具。饶益众生。究竟施。一切施。内外施。增长直心。令一切众生具功德宝心。善能饶益无量众生。令一切众生。成就宝心。令一切众生。清净善根等三世佛具一切智。菩萨摩诃萨以施资生之具。所摄善根。回向众生。令一切众生。清净调伏。令一切众生。皆悉严净一切佛刹。除灭烦恼。令一切众生。以清净心于念念中充满法界。令一切众生。智慧充满虚空法界。令一切众生。得一切智了达三世。于一切时转不退法轮。令一切众生。悉皆示现一切种智。巧妙方便饶益众生。令一切众生。悉悟一切诸如来道尽未来劫于一切刹。广说佛法未曾休息。令一切众生。于无量劫修菩萨行心无厌倦。令一切众生。于一切世界。净世界。不净世界。小世界。中世界。大世界。微细世界。广世界。翻覆世界。伏世界。如是等一切世界皆悉严净。菩萨充满行大乘行。令一切众生。于念念中。悉作三世一切佛事。调伏众生。立萨婆若。此菩萨摩诃萨。以如是等无量阿僧祇劫饶益众生。令佛法不断以大悲心救护众生。修习大慈具菩萨行。建立一切诸如来论。令一切众生。皆悉不断诸佛善根。有来求者悉满其意而无患厌。能施一切心无有悔。舍一切物资生之具。随所来方无不欣悦。于诸众生如一子想。见来求者心大欢喜作是念言。是我善知识。尔时菩萨长养大悲心。欢喜心。不可坏心。大施心菩萨摩诃萨。见来求者随其所须悉资给之。充满其意。令无所乏。皆令欢喜。断其贫苦。具足富乐。同声称美叹德而归。菩萨尔时心大欢喜。于百千亿那由他劫受帝释乐所不能及。须夜摩天王。兜率陀天王。化自在天王。他化自在天王。百千亿那由他劫所受喜乐所不能及。梵天王乐。乃至净居天无量无边阿僧祇劫禅定快乐亦所不及。无量无数不可称说阿僧祇劫转轮王乐亦不能及。菩萨摩诃萨。如是大喜无量。信心增长。直心清净。诸根柔软。定心增广。生菩提心坚固不转。菩萨摩诃萨。善根回向。令一切众生。离毒害心。令一切众生。安隐快乐。令一切众生。得真实义。令一切众生。悉得清净无上菩提。令一切众生。悉得平等。令一切众生。得贤善心。令一切众生。逮得贤善摩诃衍心。令一切众生。所行悉善。令一切众生。具普贤菩萨所修愿行。令一切众生。觉十力乘。菩萨摩诃萨。以此善根回向时。于身口意业无著无缚解脱回向。无众生想回向。无命想。无人想。无福伽罗想。无男子想。无年少想。无禅头想。无造想。无受想。无有想。无无想。无今世后世想。无死此生彼想。无有常想。无无常想。非三有想。非无三有想。非想。非无想。无缚无著解脱心回向。无业回向。无业报回向。无虚妄回向。无真实回向。无思回向。无思报回向。无心回向。无无心回向。菩萨摩诃萨。如是回向时。不着内。不着外。不着缘。不着境界。不着因。不着因和合。不着法。不着非法。不着思。不着思果。不着色。不着色取。不着色灭。不着受想行识。不着受想行识取。不着受想行识灭。菩萨摩诃萨。若于此法中心不著者。则不缚色。不缚色取。不缚色灭。不缚受想行识。不缚受想行识取。不缚受想行识灭。若于此法而不缚者。则于诸法亦无有解。何以故。一切诸法不生不灭。无有自性。无一无二。无多无少。无有量。无无量。无善无恶。无深无浅。无静无乱。无著无离。无法无非法。无性无非性。无有无无故。菩萨如是见法。则是非法言语道断故。非法为法而亦不壤一切业迹。具修菩萨行不退一切智。解知业缘如梦如响。如镜中像。一切法如幻。而亦不违因缘业报。入甚深业。解法真实。无行无作。亦复不违业行之道。菩萨摩诃萨。以一切善根如是回向一切种智。普游十方教化众生。回向者何义。永度世间生死彼岸故说回向。度诸阴彼岸故说回向。度语言道彼岸故说回向。度众生相彼岸故说回向。度身见彼岸故说回向。度不坚固彼岸故说回向。度诸行彼岸故说回向。度诸有彼岸故说回向。度诸取彼岸故说回向。度诸世间法彼岸故说回向。菩萨摩诃萨。若能以此善根回向。则皆随顺一切诸佛。随顺法。随顺智。随顺菩提。随顺义。随顺回向。随顺行。随顺真实。随顺清净。菩萨摩诃萨。如是回向已。令一切众生。得如来法。诸佛欢喜。无佛不值。无法不了。于一切法无违无失。悉能分别一切佛法。不舍正法。不违因缘。内外诸法。法力具足。无有休息。佛子。是为菩萨摩诃萨第六随顺一切坚固善根回向。菩萨摩诃萨。住此回向。无量诸佛皆悉守护。得坚固法修一切智。解随顺义。解一切法。随顺真性。得一切法。随顺坚固善根。随顺满足诸愿。得随顺坚固法。一切金刚所不能坏。得随顺坚固愿。于一切法中而得自在。尔时金刚幢菩萨。承佛神力。观察十方。观察一切大众。观察法界。深入诸法句味之义。修无量心。大悲普覆一切众生。觉悟三世如来家法。入于一切诸佛功德。逮得诸佛自在之身。分别一切诸众生心。随所种善根。应受化时。随顺法身示现色身。以偈颂

  一切世间诸大王　　菩萨现身于彼生
  处彼尊豪大王位　　悉能调伏诸群生
  其心柔软常清净　　于一切众得自在
  常以正法治天下　　方便随顺乐世间
  菩萨清净王家生　　常能如应转法轮
  远离诸恶正治国　　十方众生无违教
  菩萨色相功德满　　具足甚深妙智慧
  坚固安住不退转　　悉能降伏一切魔
  常能具持清净戒　　决定安住忍辱力
  除灭一切嗔恚毒　　常能修习最胜法
  菩萨具行布施法　　饮食华鬘乘衣服
  涂香房舍明净灯　　如是等施无有量
  菩萨所施益众生　　常能开发广大心
  其意清净大欢喜　　布施尊胜及世间
  菩萨悉能舍无量　　内外所有一切物
  所行布施常欢喜　　未曾暂有中悔心
  菩萨悉能施头目　　手足肌肉及骨髓
  一切身分尽惠施　　其心未曾生中悔
  菩萨处在大王位　　清净豪贵人中尊
  大悲以舌施群生　　楚毒无量不中悔
  菩萨施舌净善根　　回向一切诸群生
  悉令此等众生类　　具足成就广长舌
  菩萨欢喜施妻子　　其心未曾生忧悔
  又复欣悦施国土　　亦能舍身无所吝
  随所乐求尽施与　　应时惠施无嫌恨
  一切所有能悉舍　　诸来求者皆满足
  为法舍身无央数　　修诸苦行求菩提
  又为众生受诸苦　　求无上智不退转
  听受如来正法故　　以身布施无疲厌
  内心欢喜无有量　　救护一切众生故
  菩萨得见诸佛已　　慈心恭敬设供养
  饶益欢喜悉具足　　皆能闻持诸佛法
  回向一切众生类　　悉令世间得安乐
  普能救护一切众　　永使究竟得解脱
  菩萨具足诸眷属　　色身端严顺教命
  妙庄严具为校饰　　聪睿仁贤巧智慧
  以饶益故悉布施　　而未曾有微吝心
  不为世间资生利　　饶益众生求菩提
  具足修习净功德　　履行无量诸胜业
  回向一切众生类　　亦不取业坚固相
  菩萨能舍大王位　　严饰京都诸城邑
  宫殿内外一切物　　游观园林诸池流
  无量无数百千劫　　以无上心行布施
  开悟世间示彼岸　　随顺化导群生类
  菩萨见有来求者　　悉从他方世界至
  随彼所须满其愿　　菩萨大喜充遍身
  菩萨回向施功德　　三世一切诸如来
  所学究竟到彼岸　　无上导师之境界
  菩萨观察一切法　　谁为度脱众生者
  为度脱谁至何处　　解空不舍布施心
  菩萨回向智慧故　　菩萨回向求正法
  菩萨回向甚深义　　于一切法无所著
  心不分别一切业　　于诸业报不染着
  了达菩提从缘起　　于法真性无所坏
  解了己身不染着　　其心寂灭无所依
  智慧分别无业性　　善解因缘非无业
  不虚妄取过去法　　亦复不取未来法
  了达现在无所有　　观察三世悉空寂
  菩萨究竟色彼岸　　受想行识亦如是
  永度一切到彼岸　　其心谦顺常清净
  观察五阴十八界　　分别诸入及己身
  于此诸法求菩提　　皆悉空寂不可得
  不取诸法常住相　　于断灭相亦不受
  一切诸法非有无　　诸业因缘和合生
  无有众生得菩提　　一切诸法悉寂灭
  心不染着诸佛刹　　了达三世无所有
  若能如是解正法　　亦如一切诸最胜
  虽复推求无所得　　菩萨所行亦不虚
  是故缘中求诸法　　不违一切因缘道
  分别解说诸业迹　　欲令众生悉清净
  是为智者所修行　　一切诸佛之所说
  随顺思惟入正义　　自然觉悟无上道
  诸法无生亦无灭　　亦复无来亦无去
  不于此死而彼生　　深解一切诸佛法
  了达诸法真实性　　于法性中无所著
  永离诸法虚妄相　　彼人得见诸佛智
  分别解了诸法趣　　众生诸趣佛国趣
  一切三世所有法　　皆悉了知无有余
  三世诸佛所觉法　　悉能具足闻受持
  所说三世一切法　　如是等法悉非法
  随顺修行一切法　　而亦不坏诸法相
  菩萨回向诸众生　　令彼疾得一切智

佛子。何等为菩萨摩诃萨第七等心随顺一切众生回向。佛子。此菩萨摩诃萨增长下品善根。中品善根。上品善根。无量善根。广善根。种种善根。不可测量善根。不可思议善根。阿僧祇善根。无边善根。佛境界善根。法境界善根。僧境界善根。善知识境界善根。一切众生境界善根。方便境界善根。修习微妙境界善根。内境界善根。外境界善根。无量别异功德境界善根。修习一切施境界善根。清净戒境界善根。菩萨内自专正于一切舍忍辱境界善根。精进不退转境界善根。入种种禅定境界善根。修行诸地智慧境界善根。分别一切众生心心境界善根。积集无量清净功德善根。修习正念菩萨业境界善根。普覆一切众生境界善根。菩萨摩诃萨。行如是等无量善根。修习究竟积集长养广开解已。则能安住忍力闭恶趣门。善调诸根威仪具足。永离颠倒决定正趣。堪为一切诸佛法器。普为众生作无上福田。常为诸佛之所守护。出生长养一切诸佛清净善根。随顺具满如来大愿。深乐佛业心得自在。悉与三世诸如来等。普能供养一切诸佛。究竟一切诸如来力。常为诸佛之所赞叹。不求生天。不贪利养。不着诸行。一切善根皆悉回向。为一切众生作功德藏。具足诸道普覆一切。于生死中拔出众生。教令修习一切善根。回向一切境界而不断绝。开一切智菩提之门。建立智幢。严净大道。普示众生。舍离一切世间尘垢。施心功德生如来家。清净功德皆悉满足。无上福田不着众生。不依世间。令一切众生皆悉清净。修习摄取一切善根。菩萨摩诃萨。离垢清净菩提心摄取善根。作如是念。此菩提心所起善根。菩提心思惟善根。菩提心所得善根。菩提心正希望善根。一向菩提心善根。怜愍一切众生。摄取一切种智境界。究竟十力境界。积集十力境界。不坏法界善根。不退转善根。菩萨摩诃萨。复作是念。如此善根若有果报。我当尽未来际行菩萨行。不舍众生故修行大舍。回向一切众生悉无有余。令无数世界珍宝充满。令无数世界宝衣充满。令无数世界妙香充满。令无数世界庄严具充满。令无数世界摩尼宝充满。令无数世界胜摩尼宝充满。令无数世界妙色杂华充满。令无数世界上味充满。令无数世界金银充满。令无数世界天床充满。妙宝庄严敷以天衣。令无数世界杂宝庄严天冠充满。若有一人尽未来劫常来求索。以此宝物而惠施之未曾厌倦。如一众生一切众生亦复如是。菩萨摩诃萨。如是施时。以平等心。无偏爱心。不求名心。无热恼心。无中悔心。专求一切智心。清净道心。一向施心。怜愍心。调伏心。安住一切智心。菩萨摩诃萨。善根如是回向。尽未来劫常行布施。复次菩萨摩诃萨。善根如是回向一切众生。悉无有余。我当以宝象充满无数世界。七支具足。六瘤成满。建大宝幡。真金庄严。白宝网覆。一切杂宝而庄严之。以用布施。我当以清净宝马。婆罗马王等充满无数世界。以一切马宝庄严具而庄严之。以用布施。无数世界宝女充满。娱乐具足。以用布施。无数世界男女充满。以用布施。无数世界己身充满。以用布施。无数世界己身头首充满。不放逸心。以用布施。无数世界己目充满。以用布施。无数世界己身充满。堪忍楚毒。破骨出髓。以用布施。无数世界大王座处。皆悉充满。以用布施。无数世界给使僮仆。皆悉充满。以用布施。修习平等一切施心。于一世界中尽未来劫修菩萨行。为一众生。于一切世界中尽未来劫修菩萨行。为一众生。为一切众生。亦复如是。具足大悲。远离众恶。普念一切。令我布施究竟不退。行布施时。乃至不生一念忧悔之心。菩萨摩诃萨。复作是念。我行如是无量布施。以无著心。无缚心。解脱心。大心。甚深心。摄取心。离憎爱心。离寿命心。善调伏心。不乱心。无害心。安住一切智心。慧光普照一切法心。入一切智心。菩萨摩诃萨。以此善根念念回向。令一切众生。财宝满足。令一切众生。具足无尽大功德藏。令一切众生。得安隐乐。令一切众生。长养菩萨摩诃衍业。令一切众生。满足深法。令一切众生。得不退转一切智乘。令一切众生。见一切佛。令一切众生。普于众生无所选择。令一切众生。悉得清净平等之心。令一切众生。离诸难处得一切智。令一切众生。饶益安乐无量众生。令一切众生。普于一切得平等心。令一切众生得柔软施心。令一切众生。摄取真实惠施之心。令一切众生。不失施心。令一切众生。具足施心。永灭贫穷。令一切众生。悉摄世间诸妙财宝无所乏短。令一切众生行无量施。令一切众生。行一切施。令一切众生。尽未来劫修行布施心无退转。令一切众生。悉舍一切心不中悔。令一切众生。随顺行施饶益众生。令一切众生。行胜广施。令一切众生。行种种庄严施。令一切众生。行无著施。令一切众生。行平等施。令一切众生。行大力金刚施。令一切众生。行如日光明施。令一切众生。得如来智。令一切众生。善根眷属具足成满。令一切众生善根智慧悉现在前。令一切众生。得不可坏正直之心。令一切众生。具足成就清净善根。令一切众生。于烦恼睡眠智慧觉悟。令一切众生。疑惑悉除。令一切众生得平等智清净功德。令一切众生。功德悉备无能坏者。令一切众生。具足清净不动三昧。令一切众生。具不可坏萨婆若智。令一切众生。具足菩萨无量清净自在正行。令一切众生。修习无著清净善根。令一切众生。净修正念三世诸佛。令一切众生。出生胜妙清净善根。令一切众生。除灭一切诸魔魔业障碍道法。令一切众生。皆悉履行无量功德。生诸三昧清净满足。令一切众生。常念诸佛未曾废忘。令一切众生。常见诸佛悉令欢喜初不远离。令一切众生。开净法门出生善根。诸白净法平等具足。令一切众生。悉得无量平等正直之心。令一切众生。成就清净平等施心。令一切众生。满足诸佛尸波罗蜜。平等清净。令一切众生。具大精进波罗蜜。未曾懈怠。令一切众生。得大羼提波罗蜜。令一切众生。得无量禅智慧。分别满足诸通。令一切众生。于一切法得离身般若波罗蜜。平等满足。令一切众生。得清净法界平等满足。令一切众生。悉具净妙诸通善根。令一切众生。修平等行具诸善法。令一切众生。究竟永度诸佛境界。令一切众生。身口意业平等清净。令一切众生。诸业行报平等清净。令一切众生。悉得诸法平等清净。令一切众生。悉得诸法清净平等实义。令一切众生。悉得清净诸胜妙行。令一切众生。悉得菩萨诸清净愿。令一切众生。普得平等净功德智。令一切众生以诸善根回向萨婆若乘平等满足。令一切众生。显现一切严净佛刹平等满足。令一切众生。得见诸佛除灭一切诸烦恼患。令一切众生。具诸相好功德庄严平等满足。令一切众生。得八种声百千妙声而庄严之。如来无量功德清净梵音皆悉具足。令一切众生。十力庄严成就无碍平等之心。令一切众生。得一切佛无尽法明。无量诸辩平等满足。令一切众生。得无上无畏人中之雄大师子吼。令一切众生。得一切智转不退法轮。令一切众生。出生诸法平等满足。令一切众生。善根清净应不失时平等满足。令一切众生。成就清净调御师法平等满足。令一切众生。于淳一庄严。无量庄严。大庄严。诸佛庄严。平等满足。令一切众生。观察三世分别平等。令一切众生诣诸佛所。闻法受持解了平等圆满具足。令一切众生。惭愧智慧与诸佛等。令一切众生。得平等智观察诸法。令一切众生。得不动业报离诸障碍平等满足。令一切众生。入甚深智悉分别知众生诸根平等满足。令一切众生。得无分别平等智慧皆悉等一清净满足。令一切众生。随顺无厌善根平等分别皆悉满足。令一切众生。于大神足而得自在。菩萨神力平等满足。令一切众生悉得诸佛无尽功德智慧之藏。究竟功德皆悉等一。令一切众生。于诸法中得离虚妄随顺平等。入一切法知菩提心。令一切众生。胜妙福田平等满足。令一切众生。得清净大悲。普为世间最上福田。令一切众生。坚固无坏平等满足。令一切众生。见真实法不可破坏平等满足。令一切众生。得最胜心。思惟正观平等满足。令一切众生。离诸恐怖。入甚深法到于彼岸。令一切众生。放一光明。普照十方等度一切。令一切众生。悉得菩萨不退精进。同行同愿平等满足。令一切众生。出一言音平等满足。令一切众生。于菩萨直心平等满足。令一切众生。悉得睹见诸善知识心大欢喜。令一切众生。皆悉具足菩萨诸行。调伏众生未曾休息平等满足。令一切众生。得不断辩。普入诸音平等满足。令一切众生。能以一心知一切心。一切善根平等满足。令一切众生。修诸善根而不退转。安立众生于清净智。令一切众生。得一切智平等功德清净法身。令一切众生。悉舍愚痴。观察善根平等满足。令一切众生。得一萨婆若。成等正觉平等满足。令一切众生。离诸恶趣出生一道。一切种智平等满足。令一切众生。得一众清净。悉能普净一切大众。平等智慧而庄严之。令一切众生。于一佛刹普见一切诸如来刹平等满足。令一切众生。一切庄严。不可说庄严。不可量庄严。无尽庄严。庄严一切佛刹平等满足。令一切众生分别解了无量诸法。见甚深义平等满足。令一切众生得诸圣行。诸佛自在平等满足。令一切众生。非一非异。诸神通力平等满足。令一切众生。随顺善根。普为诸佛甘露灌顶。令一切众生。清净智身平等具足。如是菩萨摩诃萨。怜愍饶益众生。大悲哀念众生。令一切众生。皆悉清净。离悭嫉结。具足无量无边善妙功德。常乐胜法。离嗔恚浊。及诸障碍。其心柔软。离痴正直而无邪曲。所行坚实不可沮坏。得不退转平等之心。白净法力皆悉成就。不信不失。善解回向。修习功德。调伏众生。除灭一切诸不善业。专精苦行。普教一切具足修习苦行善根。为诸众生具受众苦。慧眼清净观察善根。智慧圣行善根回向一切众生。令一切众生。安住清净微妙功德。远离炽然成就等心善根回向。令一切众生得萨婆若修习回向。摄取众生。一切善根平等具足。具足成就等心回向。以如是等无量善根。回向众生。令一切众生。常得安隐。令一切众生。常得清净。令一切众生。常得安乐。令一切众生。得究竟解脱。令一切众生。得究竟平等。令一切众生。得自在神力。令一切众生安住白法。令一切众生。得无障眼。令一切众生。调伏诸根。令一切众生。具足十力。教化众生。菩萨摩诃萨。修行如是回向时。不着业回向。不着报回向。不着身回向。不着利养回向。不着诸刹回向。不着诸方回向。不着众生回向。亦不离众生回向。不着一切回向。不着法回向。菩萨摩诃萨。如是回向时。作如是念。令一切众生。满足佛智。得清净心。智慧分别内心寂静。外缘不乱得在三世诸佛家生。菩萨摩诃萨。行如是回向。胜出一切无能坏者。一切众生悉共赞叹所不能尽。普行一切诸菩萨行。以少方便遍诣诸刹。悉见诸佛无所障碍。又见诸刹一切菩萨。修习众行。悉得一切巧妙方便。分别一切法陀罗尼。演说妙法。教化众生。尽未来劫未曾断绝。于念念中。不可说不可说诸佛世界悉现受生犹如电光。于念念中。悉能严净不可说不可说诸佛世界。修行严净佛刹智慧。而无厌足。令不可说不可说众生。清净成就平等满足。随其所住善根。悉能具足诸波罗蜜摄取众生。除灭垢秽成就净业。得无碍净耳。于不可说不可说世界。佛转法轮悉闻受持。于彼诸佛不生远想。乃至未曾一弹指顷不闻正法。住无所有。无依无染。无著无行。坚固不坏菩萨神力。于念念中。不可说不可说一切佛刹。随其所应。悉现其身。修菩萨行。常与同见从事不相违背。菩萨摩诃萨。修菩萨行时。成就如是无量无边清净功德。说不可尽。况成无上菩提。得最正觉。所谓一切佛刹清净平等。一切众生清净平等。一切身清净平等。一切根清净平等。一切业报清净平等。一切眷属清净平等。满足诸行清净平等。方便入一切法清净平等。满足一切如来诸愿回向清净平等。示现一切诸佛境界自在清净平等。菩萨摩诃萨。如是善根回向已。得一切清净功德法门。以诸功德而庄严之。菩萨摩诃萨。如是行回向。不违一切刹。刹不违众生。刹不违众生业。众生业不违刹。思不违心。心不违思。思不违心境界。心境界不违思。业缘不违报。报缘不违业。业不违业迹。业迹不违业。法不违相。相不违法。法生不违性。性不违法生。刹平等不违众生平等。众生平等不违刹平等。一切众生平等不违一切法平等。一切法平等不违一切众生平等。离欲际平等不违一切众生安住平等。一切众生安住平等不违离欲际平等。过去不违未来。未来不违过去。过去不违未来现在。未来现在不违过去。世平等不违佛平等。佛平等不违世平等。菩萨行不违萨婆若。萨婆若不违菩萨行。菩萨摩诃萨。行如是回向。得平等业。得平等报。得平等身。得平等道。得平等愿。得平等一切众生心。得平等一切刹。得平等一切行。得平等一切智。得三世诸佛平等。得见诸佛。及诸菩萨。得一切善根。得满一切愿。得成就一切众生。得善分别一切诸业。得见一切诸善知识。悉令欢喜。得清净大众。得究竟诸佛正教。得究竟一切白净法回向。佛子。是为菩萨摩诃萨第七等心随顺一切众生回向。菩萨摩诃萨。成就此回向已。则能摧伏一切怨敌。悉能拔出一切欲刺。得无生道。到无二处。得无量自在功德之王。救护众生。神足无碍遍游诸刹。常乐寂静。于一切身而得自在。悉能出生菩萨大行。于诸行愿得自在智。分别了知一切诸法。悉能遍生一切佛刹。得无碍耳。闻一切刹所有音声。得净慧眼。见一切佛。修诸善根未曾休息。具足成就一切诸法。菩萨摩诃萨。以此等心随顺一切众生回向。回向诸善根。尔时金刚幢菩萨。承佛神力。普观十方。以偈颂曰

  菩萨具行诸功德　　深远清净甚微妙
  所行功德虽微小　　悉能回向广无量
  菩萨一切资生具　　珍妙奇特贵无价
  象马宝王诸辇舆　　种种宝衣及众珍
  己身头目并手足　　破骨出髓割肌肉
  充满无量诸世界　　悉以惠施无贪吝
  如是无量无边劫　　一切普施不退转
  以此功德悉回向　　救度无量众生故
  菩萨饶益一切众　　清净功德诸妙愿
  安乐三有群生类　　悉令究竟证菩提
  菩萨平等发大愿　　随顺修习清净业
  令一切众得平等　　于彼愿中无所著
  普于世间无嫌恨　　悉能随顺行诸愿
  悉能回向群生类　　不违一切诸贤圣
  一切世间智慧日　　斯从布施净戒生
  勤修精进无懈怠　　于一切愿不退转
  菩萨回向到彼岸　　能开清净妙法门
  得两足尊胜智慧　　分别实义到彼岸
  菩萨梵音悉究竟　　具足坚固妙智慧
  深入正法离障碍　　菩萨于彼意无著
  菩萨心净不作二　　亦复不作不二法
  舍离二法不二法　　觉悟众生语言道
  菩萨觉悟世平等　　诸心音声一切业
  一切众生犹如化　　悉从因缘业报转
  一切世间所造作　　十方无量业音声
  悉从业缘之所起　　应灭彼业令无余
  菩萨观察一切众　　身口意业悉平等
  普令众生得平等　　犹如一切无等等
  菩萨善业悉回向　　普令众生色清净
  具足一切诸功德　　悉同无上调御士
  一切众生最殊胜　　具足功德妙法身
  功德大海悉回向　　饶益安乐诸群生
  我所修行诸功德　　普令一切悉清净
  诸佛清净无伦匹　　普令世间亦如是
  平等善根悉回向　　令一切众知实义
  微妙智慧功德满　　悉与一切如来等
  菩萨观察一切法　　世间寂灭空无余
  无有造作无造者　　亦复不坏诸业报
  于彼静乱无有二　　悉以等心正观察
  菩萨真实解世间　　远离一切诸虚妄
  如是真实佛子等　　从诸如来法化生
  无量功德悉回向　　一切疑惑悉除灭

大方广佛华严经卷第十九大方广佛华严经卷第二十

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之七

佛子。何等为菩萨摩诃萨第八如相回向。佛子。此菩萨摩诃萨。成就念智。安住不动。离痴正念。直心不动。成就坚固不可坏业。一切智境界得不退转。得大乘勇猛无畏之心。修习无尽善根。积集胜妙善根。修白净法增长大悲。得正直宝。常能正念一切诸佛白净法。回向心不退转。乐求菩萨道巧妙方便。出生清净坚固善根。正念修习智慧功德。为调御师具足出生一切善根。智慧方便回向众生。慧眼清净悉能观察一切善根。长养无量种种善根。分别境界善根。具足善根。清净善根。一向善根。修习善根。行善根。思惟善根。平等广说善根。菩萨摩诃萨。如是善根。有种种门。种种境界。种种相。种种事。种种分别。无量行。无量语言道。出生无量分别修行。种种庄严善根。悉能正持十力诸乘。菩萨摩诃萨。修习如是种种善根。一观无二。一切智境菩萨摩诃萨。以如是等善根回向。欲令具满无碍身修菩萨行。欲令口业清净无碍修菩萨行。欲令具足无碍心业安住大乘具无碍心。令菩萨行皆悉清净。得无量大施心充满一切众生。得法自在心照一切法普示世间。得最胜不可坏心。得清净一切种智。发菩萨心普照一切。正念三世一切诸佛。念佛三昧悉得具足。满足离害正直之心。远离怨敌。任持众生。充满一切。而无休息。于十力智悉得安住。得深三昧。悉能遍游一切世界。无所染着。悉住一切刹。而无厌足。化度众生未曾休息。出生无量巧便思慧。具足成就一切菩萨不思议慧。得离痴智。悉能分别一切世界。于一念中。悉能严净一切佛刹。于诸通慧而得自在。入一切法真实之相。示现严净一切世间。于一刹中见一切刹。究竟不坏智能持一切刹。以菩萨庄严具而庄严之。应现一切悉能调伏无量众生。一佛世界广大如法界。一切世界亦复如是。得究竟智诣一切刹一切普持。菩萨摩诃萨。以此善根回向佛刹。令众生充满。回向分别受持智慧。如为己身。为众生回向亦复如是。令一切众生。永离地狱饿鬼畜生阎罗王处。令一切众生。悉能除灭诸障碍业。令一切众生。悉得等心平等智慧。令诸怨敌具慈心乐清净智慧。令一切众生。智慧现前圆满具足普照一切。令一切众生。具真实智离垢正直菩提心无量智慧满足。令一切众生。示现平等安隐善趣。菩萨摩诃萨。如是回向。修习善根。及一切愿。如大云雨。令一切众生。皆悉清净。令一切众生。为功德福田。令一切众生。守护受持菩提内藏。令一切众生。离诸障碍安住无碍清净法界。令一切众生。满足无碍诸通智慧。令一切众生。得自在身。游行十方。如应示现。令一切众生。得无痴善根一切种智。令一切众生。摄取一切。悉令清净。令一切众生。远离障碍嗔恚之心。究竟成就一切种智。复次菩萨摩诃萨。若见可乐国土。林树华果。或见可乐名香上服。珍宝财物。诸庄严具。或见可乐园观村邑。聚落王都。或见可乐自在帝王。或见可乐阿练若处。菩萨摩诃萨。见如是已。修巧方便。出生无量净妙功德。乐求实义。为众生故。而不放逸。善能修习一切善根。犹如大海难可测量。具足善根不可穷尽。一切功德皆悉满足。亦不分别种种善根。巧妙方便清净回向。示现无量诸行善根。常念一切未曾忘失众生境界。如善根。平等善根。菩萨摩诃萨。善根如是回向。令一切众生。志常乐见无量诸佛。如法不取法性。无数众生平等清净。亦复如是。令一切众生。悉得诸佛随意爱乐供给侍者。令一切佛国。除灭烦恼清净可乐。令一切众生。悉得见闻无量佛法。心常爱乐。常乐守护诸菩萨行。乐以爱眼观善知识。令一切众生。见可乐法。令一切众生。乐持正法。令一切众生。于佛法中得可乐明。令一切菩萨。悉得可乐大施之心。于诸法中得无所畏乐。为众生分别广说。得菩萨可乐三昧诸陀罗尼。得一切菩萨授记智慧。得一切菩萨甚可爱乐自在示现。具足诸佛圆满说法。得可乐方便分别说法。得可乐大悲。发菩萨心。诸根悦豫。得可爱乐诸如来家。教化众生心不休息。得菩萨可乐无尽法藏。于无量劫一一世界化度众生。于现在佛所得可爱乐巧妙方便。得可爱乐深妙方便。无所障碍。永离愚痴。具足可乐平等离欲一切诸法断诸障碍。决定深解不二法界。具足可乐离欲际等一切诸法入真实际。得菩萨可乐无诤满足之法。具足可乐金刚藏心一切种智。勇猛精进清净成满。具足可乐清净善根摧伏怨敌灭障道法。具足可乐无上菩提一切种智。常现在前充满众生。如是菩萨摩诃萨长养善根。得净慧明。常为善知识之所摄护。如来慧日明照其心。灭除痴闇。净修正法。入诸智业。善学智地分别法界。一切善根善能回向。一切菩萨诸善根海。尽其原底。成就智慧。深入坚固。明解善根。了达诸度。菩萨摩诃萨。善根如是回向不着世界。不着众生界。心无所依。寂然不乱。正念诸法。具足诸佛无选择智。不违三世一切诸佛正回向门。不违一切平等正法。不坏佛相。等观三世。了众生空无所依住。顺如来道普照诸法。解真实义渐至诸地。如实分别一切诸法。智慧周满具足坚固。未曾忘失修习正业。常乐寂静正趣离生。了一切法犹如幻化。解一切法无有自体。观一切义及种种行。于语言道而无所著。所有诸法皆从缘起。观甚深法生实智回向。观察寂灭一切诸法皆入一观。不违诸法种种异相善解回向。修菩萨道善根回向。摄取众生。长养三世菩萨一切回向。如是菩萨摩诃萨以无恐怖心善根回向。一切佛法以无量心善根回向。一切众生皆悉清净以无我无我所心善根回向。于十方界无所染着以无余心善根回向。于一切境界世界无所染着。行离世间法善根回向。得出世法不着众生善根回向。见诸胜道善根回向。离虚妄法。出生真实善根回向。如法门至一切道。无量无边善根回向。如如善根亦尔。回向众生解了诸法。如性如善根亦尔。回向一切法自性无有自性。如相如善根亦尔。回向一切法无相真实相。如法如善根亦尔。回向佛法不退转。如行如善根亦尔。回向一切如来所行。如境界如善根亦尔。回向三世诸佛满足境界。如安立如善根亦尔。回向安立一切众生。如随顺如善根亦尔。回向尽未来劫随顺不断。如量如善根亦尔。回向众生心与虚空等。如充满如善根亦尔。回向一念满一切世界。如久住如善根亦尔。回向离一切世间住住究竟住。如不生如善根亦尔。回向不生满足一切佛法。如坚固如善根亦尔。回向坏散一切烦恼。如不坏如善根亦尔。回向一切众生不可破坏。如明如善根亦尔。回向普照一切。如一切处如善根亦尔。回向至一切处道。如一切时如善根亦尔。回向随顺一切时。如一切如善根亦尔。回向一切众生随顺清净。如一切平等如善根亦尔。回向一切行平等。如一切法眼如善根亦尔。回向一切众生悉得法眼如不倦如善根亦尔。回向一切行菩萨道而无疲倦。如甚深如善根亦尔。回向一切第一深法。如无所有如善根亦尔。回向知一切无所有。如不出如善根亦尔。回向一切无所显现。如离曀如善根亦尔。回向明眼离曀清净。如无比如善根亦尔。回向菩萨无比之行。如寂静如善根亦尔。回向一切常乐寂静。如无根如善根亦尔。回向究竟无根之法。如无量无边如善根亦尔。回向一切无量无边众生皆悉清净。如无著如善根亦尔。回向究竟无所著际。如无碍如善根亦尔。回向灭除一切障碍。如非世间行如善根亦尔。回向远难一切世间行法。如不系如善根亦尔。回向不系一切生死。如无行如善根亦尔。回向远离一切诸行。如住如善根亦尔。回向一切住于如住。如一切法成如善根亦尔。回向众生所学成就。如一切法平等如善根亦尔。回向一切具平等行。如一切法不舍如善根亦尔。回向不舍尽未来际一切众生。如一切法不尽如善根亦尔。回向一切无尽众生。如不违一切法如善根亦尔。回向一切众生不违三世诸佛。如摄一切法如善根亦尔。回向一切众生悉摄善根令无有余。如一切法同如善根亦尔。回向悉同三世诸佛。如一切法不离如善根亦尔。回向悉摄世间及离世间。如不可坏如善根亦尔。回向一切众生不可沮坏。如无恚如善根亦尔。回向一切众生一切魔业所不能动。如不浊如善根亦尔。回向一切菩萨行无有垢浊。如不乱如。善根亦尔。回向一切众生离诸尘乱。如不可尽如善根亦尔。回向一切世间法所不能尽。如菩提如善根亦尔。回向觉悟一切诸法。如不失如善根亦尔。回向一切众生不失直心。如照如善根亦尔。回向一切众生悉以大智光明普照一切。如不可说如善根亦尔。回向一切不可说智。如持一切众生如善根亦尔。回向一切持菩萨行。如随顺一切语言如善根亦尔。回向一切无言智慧。如离一切种种法如善根亦尔。回向示现一切佛刹及诸如来成最正觉示现无量神力自在。如离虚妄如善根亦尔。回向世间悉离虚妄。如一切身遍至如善根亦尔。回向无量身遍一切刹。如不受生如善根亦尔。回向无生巧妙方便示现受生。如无不有如善根亦尔。回向三世一切诸佛自在神力及一切刹在身内现。如夜如善根亦尔。回向一切夜施作佛事得无上明。如昼如善根亦尔。回向一切在昼众生。悉令善觉见诸如来自在神力住不退法轮离痴清净。如半月及一月如善根亦尔。回向一切众生住一切时巧妙方便。于一念中悉能分别一切时节。如年岁如善根亦尔。回向受持种种诸劫严净诸根了达诸根。如一切劫成败如善根亦尔。回向一切劫净住无染一切众生清净调伏众生。如未来如善根亦尔。回向尽一切未来际修习菩萨清净妙行。悉能满足无量大愿。如世如善根亦尔。回向一切众生。于一念中见一切佛乃至未曾一念远离。如至一切处道如善根亦尔。回向一切众生得不坏道超出三界。如有无如善根亦尔。回向一切诸有清净知无所有。如净如善根亦尔。回向一切菩萨净行出生无上菩提之具。如明净如善根亦尔。回向得菩萨一切三昧明净之心。如离垢如善根亦尔。回向离一切垢净心满足。如无我所如善根亦尔。回向摄取无我我所清净之心充满十方一切佛刹。如平等如善根亦尔。回向得无尽一切智永离痴爱普照一切。如无数如善根亦尔。回向一切智乘力住巧方便法云普覆一切世界。如平等住如善根亦尔。回向一切众生具菩萨行住一切智。如分别一切众生界如善根亦尔。回向一切善根现前满无碍智。如一切众生语言如善根亦尔。回向解了一切诸语言法。如不离一切众生如善根亦尔。回向摄取一切众生具足善根远离生死。如广如善根亦尔。回向受持三世佛所说法修习菩萨离痴之行。如不休息如善根亦尔。回向一切劫。修菩萨行未曾休息。安处众生于摩诃衍。如一切法第一如善根亦尔。回向开净法门无碍净念摄一切法。如无量赞叹如善根亦尔。回向得无量赞叹智慧菩萨实行。如离炽然如善根亦尔。回向离炽然法灭除众生炽然令得清净。如不动如善根亦尔。回向善根安住不动满足普贤菩萨愿行。如诸佛境界如善根亦尔。回向一切众生智慧境界皆悉满足。除灭一切烦恼境界。如不可坏如善根亦尔。回向善根一切魔业所不能坏悉能调伏众邪外道。如非可修非不可修如善根亦尔。回向离一切修非修虚妄断一切虚妄。如不退如善根亦尔。回向常见一切诸佛未曾中退修习庄严菩提之心。如一切语言如善根亦尔。回向分别一切语言。如不着一切法如善根亦尔。回向一切众生悉无所著。令一切众生行普贤行。如一切地如善根亦尔。回向一切众生悉得随顺智慧之地普贤庄严。如不可断如善根亦尔。回向一切法中得无畏无断一切语言周满具足能广演说。如无漏如善根亦尔。回向一切众生皆令具足无漏善根菩提之心。逮得法智解了分别。如无有觉法无有灭法如善根亦尔。回向觉悟一切诸法。于一念顷皆悉充满无量法界。如过去非同未来非故现在非异如善根亦尔。回向发起新新菩提心。愿除灭生死清净众生。如三世中不取虚妄如善根亦尔。回向过去未来皆悉清净现在念念现成正觉。如一切诸佛菩萨具足如善根亦尔。回向一切众生具足佛智大愿方便。如常净无染污如善根亦尔。回向一切众生悉除烦恼。一切种智清净满足。菩萨摩诃萨。如是回向时。等一切佛刹。净一切世界故。等一切世间。转不可坏清净法轮故。等一切菩萨。出生一切智愿故。等观诸佛无有二故。等观诸法不坏自性故。等观三世。巧方便智解语言道故。一切菩萨行等所种善根悉能回向故。知一切时。随时修习。不舍佛事故。一切业报平等不着世间。出生离世善根故。神力自在与诸佛等。随顺世间等现佛事故。佛子。是名菩萨摩诃萨第八如相回向。菩萨摩诃萨。安住此回向。得无量无边清净法门。为人中雄而无所畏。大师子吼。成就无量无数菩萨。于一切时未曾休息。得佛无量无边满足身。一身充满一切世界。得佛无量无边满足音声。发一音声。一切众生无不闻者。得佛无量无边满足力。于一毛道。安置一切世界。得佛无量无边满足自在神力。置一切众生于一微尘。得一切佛无量无边满足解脱。于一众生身中。现一切佛刹。一切如来成最正觉。得一切佛无量无数满足三昧正受。善方便力。于一三昧中。悉能出生一切三昧得一切佛无量无边满足辩才。说一句法。尽未来劫而不穷尽。悉除一切众生疑惑。得一切佛无量无边满足胜众生法。示现一切众生萨婆若十力等觉。佛子。是为菩萨摩诃萨以一切善根随顺如相回向。尔时金刚幢菩萨。承佛神力。普观十方。以偈颂曰

  菩萨心安住　　离痴常正念
  忍辱离恼害　　修集无量德
  其心无嫌恨　　正直常清净
  诸业庄饰世　　悉能善分别
  菩萨思惟业　　种种无有量
  若益众生业　　修习常履行
  善能顺世间　　普令一切喜
  随应众生业　　菩萨分别行
  永离诸恚碍　　知法亦知义
  安住调御地　　饶益一切众
  觉悟诸善法　　无量不可数
  悉能分别知　　回向益众生
  以此深方便　　具足诸地智
  灭除众烦恼　　如如善回向
  普摄一切趣　　安住如实法
  如是业回向　　悉令无所著
  深乐生处道　　修习真如法
  无性无所有　　明德者回向
  日夜及半月　　一月年数劫
  一切皆悉如　　功德亦如是
  如世及诸刹　　众生一切法
  趣非趣如实　　回向悉无余
  如如性如实　　思惟如是性
  诸功德回向　　悉皆顺真如
  如如性如是　　诸法无所有
  如如离自性　　智者业回向
  如诸相如实　　诸生亦如是
  如如自性实　　诸业亦如是
  如如无有量　　一切业如是
  无缚亦无解　　诸业悉清净
  如是真佛子　　安住不可动
  成就智慧力　　入佛方便藏
  觉悟法王法　　无缚亦无著
  无碍无转心　　亦复无所转
  法身所摄业　　随顺众生相
  深入真实相　　相亦非是相
  如是不思议　　思议不可尽
  深入不思议　　思非思寂灭
  如是思惟法　　分别一切业
  除灭诸烦恼　　是名功德王
  菩萨一切报　　无尽智所印
  尽法无尽性　　无尽方便灭
  心不在内外　　心亦无所有
  妄取故有法　　不取则寂灭
  佛子如是知　　法空无自性
  诸法无自在　　最胜觉无我
  如如等众生　　觉法性如是
  彼见不思议　　无相智不惑
  如是深修习　　一向求菩提
  所愿不退转　　饶益众生故
  菩萨舍此身　　无死虚妄想
  解了心如化　　调伏一切众
  观彼顺正念　　世间业报起
  菩萨悉救护　　三界无有余
  了知众想行　　皆悉是虚妄
  菩萨知非实　　亦不坏法性
  彼如是回向　　智慧妙善根
  怜愍一切众　　令入深方便

佛子。何等为菩萨摩诃萨。第九无缚无著解脱心回向。此菩萨摩诃萨。于一切善根。不生轻心。不轻出生死心。不轻摄善根心。不轻专求一切善根心。不轻悔过心。不轻随喜善根心。不轻礼他方佛心。不轻恭敬合掌业心。不轻礼拜塔庙尊重业心。不轻劝请他方诸佛转法轮业心。菩萨摩诃萨。常乐摄受彼诸善根。坚固不坏彼善根。安住彼善根。思惟彼善根。长养彼善根。不着彼善根。具正直心具彼善根。不选择彼善根。随顺彼诸佛境界善根。见彼善根得自在力。菩萨摩诃萨。以无缚无著解脱心。彼善根回向具足普贤身口意业。以无缚无著解脱心。修习普贤勇猛精进。以无缚无著解脱心。具足普贤无碍音声陀罗尼门。充满十方。以无缚无著解脱心。具足普贤得见一切佛诸陀罗尼。以无缚无著解脱心。具足普贤妙音陀罗尼。分别一切音声。悉能演说无量法云。以无缚无著解脱心。得持普贤一切劫行陀罗尼。于一切世界。具足修习诸菩萨行。以无缚无著解脱心。于一众生身。尽未来劫。示现普贤菩萨一切自在神力。如一众生身。一切众生身。亦复如是。以无缚无著解脱心。悉得普贤自在神力。示现现在一切诸佛菩萨众中。修菩萨行。以无缚无著解脱心。得普贤一法门。于无量无数劫。示现诸佛无尽自在。悉能度脱一切众生。以无缚无著解脱心。得普贤种种法门自在。于无量无数劫。示现诸佛无尽自在。悉能度脱一切众生。以无缚无著解脱心。得普贤自在。于念念中。令无量众生。安住十力心无厌足。以无缚无著解脱心。得普贤菩萨自在。于一切众生身。皆悉得见诸佛自在。修普贤行。以无缚无著解脱心。得普贤自在。于一言中。悉能分别一切众生音声语言。调伏一切众生。安住萨婆若地。以无缚无著解脱心。得普贤自在。于一众生身中。悉能容受一切众生。彼悉自谓逮得佛身。以无缚无著解脱心。得普贤自在。于一华中。令一切严净世界皆悉安住。菩萨摩诃萨。复作是念。以此无缚无著解脱心善根。出生普贤微妙音声。充满法界十方佛刹。随其所应皆悉得闻。以此普贤无缚无著解脱心善根。如普贤。于念念中见尽过去际无量无边世界诸佛。闻所说法受持不忘。庄严佛家。以此无缚无著解脱心善根。如普贤尽未来劫。于一切世界中。演说诸法皆悉究竟。以此无缚无著解脱心善根。于一切世界成最正觉出兴于世。以此无缚无著解脱心善根。能以一光普照虚空等一切世界。修习普贤菩萨所行。以此无缚无著解脱心善根。得无量无边智慧。皆能随顺诸地神通。成就普贤菩萨所行。以此无缚无著解脱心善根。悉得究竟如来智慧。于一切劫。说如来智。诸劫悉尽。而智无穷尽。具足普贤菩萨所行。以此无缚无著解脱心善根。于法界等一切如来菩萨所行。悉能修习身口意业。而无懈怠犹如普贤。以此无缚无著解脱心善根。得一切佛无上菩提。义身不违法身。辞辩净地而不可坏乐说辩才无尽之藏。调伏一切众生具普贤愿。以此无缚无著解脱心善根。入一一法门。普照无量不可思议世界。于一切法门。尽其原底。修习普贤菩萨所行。逮得究竟萨婆若地。以此无缚无著解脱心善根。于一一境界中。悉以一切种智。分别了知一切种智。犹无穷尽。究竟普贤庄严彼岸。修菩萨行。具足成就方便大王。以此无缚无著解脱心善根。从此生尽未来际生。具足普贤菩萨所行。及一切种智离痴法王。以此无缚无著解脱心善根。得无碍法明。普照一切诸菩萨行。常修正业。具足普贤自在方便。以此无缚无著解脱心善根。悉得无量方便。不可思议方便。菩萨方便。一切智方便。调伏菩萨方便。转无量法轮方便。不可说不可说时方便。种种说法方便。无分际无畏方便说一切法无余方便。得如是等一切随顺方便智。修习普贤菩萨所行。以此无缚无著解脱心善根。具足身业。令一切众生。皆悉欢喜。得菩萨不退转清净善根。究竟安住普贤诸业。以此无缚无著解脱心善根。得清净智。悉能分别众生语言。一切口业清净庄严。音辞微妙言无能及。修习受持普贤所行。以此无缚无著解脱心善根。悉能分别一切佛刹。一切众生。一切诸法。一切庄严。其心清净出生一切如来法藏。究竟一切智。善能随顺普贤所行。以此无缚无著解脱心善根。清净直心得一切佛无碍法身。具足解脱。修如来法。摄佛功德。住佛境界。大智普照。修习菩萨清净之行。随顺方便。悉能分别一切法藏。出生无量大乘自在。悉能示现无量无边一切众生无上大道。具足普贤行愿回向。以此无缚无著解脱心善根。得明利根。善调伏根。于一切法自在根。无穷尽根。修习一切善根根一切佛境界平等根。授一切菩萨不退转记大精进根。分别一切佛法金刚界根。一切如来智慧光照金刚焰根。分别一切诸根自在根。令一切众生安住一切智根。无量根。满足一切根。无碍清净根。平等修习诸愿根。以此无缚无著解脱心善根。得一切菩萨神力。住持无量身神力。无量智慧境界神力。不离一处悉能示现一切佛刹神力。菩萨无碍不可制持自在神力。示现摄取一切佛刹安置一处自在神力。一身充满一切佛刹自在神力。菩萨无碍解脱自在神力。少方便一念自在神力。依无所有。自在神力。以一毛悉缚无量世界。悉持游行法界等佛刹示现众生。令得究竟妙智慧门自在神力。修习普贤菩萨所行。以此无缚无著解脱心善根。于一念顷。悉能往诣无量佛刹。于一身中。悉能容受无量佛刹。逮得甚深微妙智地。善能分别诸佛世界。得无生心。悉入普贤菩萨法门。生菩萨行。以此无缚无著解脱心善根。生如来家。修菩萨行。具足无量无数不思议法。无量大愿皆悉成满。分别一切法界。及三世法界。而无懈怠。随顺普贤菩萨诸行。究竟智界。以此无缚无著解脱心善根。于一毛道。分别无量无数佛刹。悉能包容一切法界究竟空界。如一毛道。一切法界虚空界等。一切毛道亦复如是。以普贤菩萨清净法门。开智慧眼。以此无缚无著解脱心善根。能以无量无数阿僧祇劫。以为一念。能以一切众生诸念。以为一念。此诸方便。皆由普贤菩萨深心究竟。以此无缚无著解脱心善根。于一身内。悉能容受无量诸身。如一身。一切身亦复如是。具足普贤菩萨回向。以此无缚无著解脱心善根。悉入一切诸佛境界。常见诸佛虚空界等清净法身。相好庄严。神力自在。梵音微妙。具足广说无碍正法。闻彼佛法悉能受持。于彼佛身了无所有。悉得普贤菩萨无量大愿。永离众生心想见倒。以此无缚无著解脱心善根。入一切世界。入翻覆世界。入伏世界。于一念中。悉能遍入十方世界一切佛刹。分别因那网世界。分别一切平等法界。令杂世界悉为一形。无量种种世界无量方便入深法界。皆如虚空。而亦不坏世界之性。修普贤行住菩萨地。以此无缚无著解脱心善根。悉能分别一切诸想。众生想。法想。佛刹想。方想。佛想。世想。业想。行想。解脱想。根想。时想受持想。烦恼想。清净想。成熟想。见诸佛想。转法轮想。闻法解想。调伏想。种种方便出生想。种种地想。入菩萨想。修习菩萨功德想。菩萨三昧正受想。菩萨三昧起想。菩萨境界想。劫成坏想。明想。闇想。昼想。夜想。半月一月年岁时变想。去想。来想。坐想。立想。觉想。睡想。如是等一切诸想。于一念中。悉能了知心无虚妄。悉离诸想。心无所著。远离障碍。一切如来智慧充满。一切佛法。长养善根。以一切佛身以熏其身。常为诸佛之所摄取。于白净法未曾退失。善能修学等正觉法。究竟彼岸。修行诸佛普贤所行。具足诸愿。受如来记。于一念中。得入方便地。究竟智满足安住。以此无缚无著解脱心善根。以一一心观无量心。离诸虚妄而无所依。心不一故。所行各异。业相不同。令一切众生。勇猛精进。出生普贤智慧之宝。犹如普贤。以此无缚无著解脱心善根。于一处悉能分别无量诸处。如一处。一切处亦复如是。悉决定知满足普贤大愿智宝

大方广佛华严经卷第二十大方广佛华严经卷第二十一

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之八

以此无缚无著解脱心善根。于一业分别知无量诸业种种缘造。如一业。一切诸业亦复如是。修习普贤菩萨行业智地。以此无缚无著解脱心善根。于一法中。悉分别知一切诸法。于一切法中。亦知一法。分别诸法而不违不着。以此无缚无著解脱心善根。于一语中。悉分别知无量言音。犹如呼响。如一语中。一切语言亦复如是。于彼言音无所依着。住菩萨行智慧成就。逮得普贤无碍净耳。以此无缚无著解脱心善根。于一一法中。悉能演说不可说不可说诸法。长养善根。不可思议。应时说法一切时解脱决定了知众生诸根。随其所应闻佛音声。佛一妙音悦无量众。一如来所菩萨大众充满法界。究竟了知一切诸行。住普贤地。于念念中。如说入法。长养不可说妙智慧身。尽未来劫。于一切世界一切佛所。悉能修习虚空等行。勇猛如普贤。修习大智慧。具足一切行。安住普贤地。以此无缚无著解脱心善根。于一一根中。皆悉了知无量诸根。不可数意不思议境界。修普贤行法门诸根

以此无缚无著解脱心善根。具菩萨行。生真实妙智。知色微细。知身微细。知刹微细。知劫微细。知世间微细。知方微细。知时微细。知数法微细。知业微细。知报微细。知清净微细。如是等一切微细。于一念中。皆悉了知。随顺普贤菩萨所行。成就普贤真实智慧。离恐怖心。离愚痴心。离散心。离乱心。调伏诸根心。一心。正受心。善分别诸法心。善安住智慧心。行普贤行。随顺普贤菩萨回向心。以此无缚无著解脱心善根。知众生趣微细。知众生死微细。知众生生微细。知众生处微细。知众生生微细。知众生种类微细。知众生界微细。知众生行微细。知众生取微细。知众生境界微细。如是等一切微细。于一念中。悉能了知。修普贤行。而无懈倦。以此无缚无著解脱心善根。悉分别知初发意菩萨等。一切菩萨诸行微细。菩萨处微细。菩萨自在微细。菩萨游行无量佛刹微细。菩萨法明微细。菩萨净眼微细。菩萨具足深心微细。菩萨往诣诸如来大众微细。菩萨诸陀罗尼智门微细。菩萨无量无边无所畏地一切诸辩方便演说微细。菩萨无量无边三昧相微细。菩萨见一切佛三昧微细。菩萨庄严三昧微细。菩萨法界三昧智慧微细。菩萨自在三昧智慧微细。菩萨三昧智慧微细。菩萨受持尽未来际三昧智慧微细。菩萨胜妙智慧分别一切菩萨三昧微细。菩萨无量无边一切菩萨出生三昧分别了知微细。菩萨出生三昧智慧往诣一切诸如来所微细。修习一切菩萨广大甚深无碍三昧。究竟一切种智。得方便地。一切通地。分别实义地。菩萨离痴智。修习普贤无量诸行微细。以此无缚无著解脱心善根。于一念中。悉知菩萨一切住微细。悉知菩萨地微细。菩萨种种行微细。菩萨出生回向微细。菩萨得一切诸佛藏微细。菩萨分别智慧微细。菩萨大愿神力自在微细。演说菩萨三昧微细。菩萨神力方便微细。菩萨印微细。菩萨一生补处微细。菩萨生兜率天微细。菩萨处天宫微细。菩萨严净佛刹微细。菩萨观察人中微细。菩萨放大光明微细。菩萨了达家法微细。菩萨眷属法微细。菩萨一切世界受生法微细。菩萨一身示一切身命终微细。菩萨身入母胎微细。菩萨处母胎微细。菩萨在胎中显现法界等大众自在神力微细。菩萨在母胎显现一切佛自在微细。菩萨生法微细。菩萨游行七步无畏智微细。菩萨现在王宫方便法微细。菩萨出家求道调伏诸根修法微细。菩萨菩提树下坐道场法微细。菩萨降魔成最正觉法微细。如来端坐道场放光明微细。普照十方一切世界微细。显现如来无量无边自在神力微细。如来师子吼大般涅槃微细。如来教化一切众生未曾有失微细。知如来金刚菩提心微细。显现如来住持一切世界微细。于一切世界尽未来劫施作佛事而无休息微细。究竟受持一切法界微细。虚空界等一切世界为化众生故。普现佛身出兴于世微细。一如来身现无量身微细。去来现在一切诸佛智慧眷属微细。如是一切功德微细。我当悉知具足究竟得到彼岸。清净示现一切众生。于念念中。智慧周满得不退转。修菩萨行。具足普贤回向功德之地。受持一切如来菩萨所行。不离菩萨诸智慧门。一切方便皆悉清净。普能安隐一切众生。修菩萨行。具足菩萨诸地功德。得金刚幢回向之门。出生无量法界诸功德藏。常为诸佛之所护念。入诸菩萨深净法门。演说一切微妙法义。无所违失。悉能慈愍一切众生。于念念中。究竟了知思议不思议地诸功德藏。于不思议出生思议。示诸法门离语言道。得智慧地。一切菩萨皆悉同等。尽未来际。修菩萨行。未曾休息。具普贤行。远离世间一切妄想。及语言道。具足受持大愿自在。修菩萨行。未曾断绝。以此无缚无著解脱心善根。入一切众生性智微细。分别众生性智微细。具足演说众生性智微细。染着众生性智微细。众生不动性智微细。众生动性智微细。无量无边趣趣众生性智微细。不可思议众生种种行性智微细。众生无量烦恼性智微细。众生无量清净性智微细。如是等一切众生性境界智微细。于一念中。如实了知。调伏安隐一切众生。如应说法而不失时。常转法轮摄取众生。说诸法门。修菩萨道。智慧具足。化身无量。安隐众生。悉令欢喜。慧日普照。深入菩提。心得菩萨自在智觉悟。安住菩萨智境界。修习大乘智。究竟普贤行。以此无缚无著解脱心善根。悉能分别虚空法界等一切世界智微细。小世界智微细。中世界智微细。不净世界智微细。清净世界智微细。无比世界智微细。杂世界智微细。广世界智微细。狭世界智微细。无碍庄严世界智微细。一切世界诸佛出世示现一切智微细。演说一切世界智微细。一身充满一切世界智微细。放无量光普照一切世界智微细。一切世界一切诸佛显现自在神力智微细。一妙音声普闻十方一切世界智微细。一切世界现在诸佛大众围绕智微细。一切法界作一佛刹智微细。一佛刹作一切佛刹智微细。一切世界如梦智微细。一切世界如电智微细。如是等一切世界智微细。悉分别知。究竟了达菩萨诸行皆悉如幻。究竟普贤菩萨行自在智。得普贤菩萨明观。行一切菩萨行无有休息。悉离颠倒。见一切佛。及佛自在。得无碍身智无所依。诸善根法无所染着。心之所行悉无所有。舍离诸方坚固之相。严净菩萨所行之相。而未曾取一切智相。不着众生三昧庄严智慧。随顺一切法界。于一切世界。修菩萨行。以此无缚无著解脱心善根。深入无量法界智微细。演说一切法界智微细。度广法界智微细。分别不可思议法界智微细。分别一切法界智微细。于一念中。充满一切法界智微细。等观一切法界智微细。一切法界境界无所有智微细。观察一切法界无碍智微细。解一切法界不生智微细。身持一切法界自在智微细。如是等一切法界智微细。皆悉究竟。成普贤行。受持智慧。得法自在。令众生欢喜。不舍义身。不见法身。出生无碍平等之智。得无碍行。不着诸法。离一切有。真实无染。随顺世间。行语言法。常乐寂静。不舍实义。智慧清净。灭除虚妄。一切所有悉非坚固觉悟无量一切法界。一切世间平等不二。一切诸法亦复不二。无所依止。得入普贤菩萨行门。究竟成就平等智慧。以此无缚无著解脱心善根。悉能分别一切诸劫智微细。无量劫即是一念智微细。一念即无量劫智微细。阿僧祇劫即是一劫智微细。一劫即是阿僧祇劫智微细。长劫即是短劫智微细。短劫即是长劫智微细。入有佛劫无佛劫智微细。数知一切劫无余智微细。说一切劫非劫智微细。一念中觉过去未来现在际一切诸劫无余智微细。如是等一切诸劫。一念中。以如来智知。得一切菩萨行圆满王心。得普贤菩萨究竟行心。得一切离虚妄心。得不退大愿心。得示现无量无边世界网中一切如来遍充满心。得闻持诸佛善根菩萨行心。得与一切众生大无畏心。得一切劫中示现诸佛出兴世心。得一一世界中尽未来以行菩萨道无休息心。得一切世界中如来身业充满菩萨身心。以此无缚无著解脱心善根。知无量甚深法智微细。胜法智微细。杂法智微细。庄严法智微细。广说一切诸法智微细。一切法即是一法智微细。一法即是一切法智微细。一切法悉入非法智微细。非法入一切法亦不违法智微细。入一切佛法方便无有余智微细。如是一切诸微细法。以无碍智悉能了知。得一切行同一行心。得究竟无量无边法界心。得无畏力。分别法心。决定安住诸无碍行。以一切智充满诸根。一切佛智。正念方便。皆悉现前。成就诸佛广大功德。充满世界。普入一切诸如来身。示现一切菩萨身业。出妙音声普遍世界。一切佛所。得威神力智慧意业。出生无量分别方便一切种智。修普贤行。得不退转智。以此无缚无著解脱心善根。知出生一切佛刹无余智微细。出生一切众生诸通智慧无余智微细。出生诸法业报无余智微细。出生一切众生心无余智微细。出生随时说法无余智微细。出生分别一切法界无余智微细。出生虚空界等三世智慧无余智微细。出生一切语言道法无余智微细。出生一切世间诸法无余智微细。出生离世间行法无余智微细。如是等一切出生智微细。一切如来道。一切菩萨道。一切众生道。出生智微细。修菩萨行。安住普贤行。随义随味。皆如实知。如梦如电如幻如响如化寂灭。一切法界无有真实。无所染着。出生诸佛平等智慧。皆悉究竟。修普贤行。出生微细智。菩萨摩诃萨以如此无缚无著解脱心善根。皆悉回向。不妄取世间及世间法。不妄取菩提及菩萨。不妄取菩萨行及出生死道。不妄取一切佛及佛法。不妄取调伏不调伏众生。不妄取善根及回向。不妄取自己及他人。不妄取施物及受者。不妄取菩萨行及菩提。不妄取法及解法者。如是菩萨摩诃萨。无缚无著解脱心善根回向。无缚无著解脱身。无缚无著解脱口。无缚无著解脱业。无缚无著解脱报。无缚无著解脱世间。无缚无著解脱佛刹。无缚无著解脱众生。无缚无著解脱法。无缚无著解脱智。菩萨摩诃萨。如是回向时。则与三世诸佛一切菩萨回向同等。成就安住三世诸佛一切菩萨回向。于三世诸佛菩萨回向。得不退转。随顺过去一切佛教。具足未来一切佛教。得现在一切佛教。满足过去诸佛平等正法。成未来诸佛平等正法。向现在诸佛平等正法。与行过去一切佛境界。住未来一切佛境界。等现在一切佛境界。与三世诸佛善根无异。住三世诸佛所住。与三世诸佛同一境界。不违三世诸佛。佛子。是为菩萨摩诃萨第九无缚无著解脱心善根回向。菩萨摩诃萨。安住此回向。一切善根回向。一切金刚山所不能坏。于一切众生。第一殊胜。一切众魔所不能坏。悉能摧灭众魔邪业。普现一切世界。行菩萨行。以善方便。广为众生。说诸佛法。舍离愚痴。随顺一切佛法智慧。菩萨摩诃萨。随所生处。行住坐卧。一切常得不坏眷属。得清净念。悉能闻持三世一切诸如来法。尽未来际劫。行菩萨行。未曾休息。而无染着。得普贤行。诸愿满足。得一切智施作佛事悉得诸佛菩萨无量自在。尔时金刚幢菩萨。承佛神力。普观十方。以偈颂曰

  菩萨未曾有慢心　　一切诸方无比尊
  随本所修功德业　　亦复不起轻慢心
  所修一切诸功德　　不为自己及他人
  以无缚着解脱心　　回向饶益一切众
  永离一切自高愿　　亦复弃舍憍慢心
  于最胜所起身业　　劝请说法种种行
  所作无量诸功德　　饶益一切众生类
  安住无著解脱心　　回向一切诸如来
  世间无量群生类　　种种方便诸技术
  胜妙甚深微细事　　悉能具足分别知
  世间所有种种身　　斯由身业之所得
  觉悟无量生死行　　逮得不退智慧门
  十方一切无量刹　　微细胜妙伏世界
  菩萨深入智慧门　　于一毛孔悉了知
  一切众生无量心　　明者了知即一心
  菩萨觉悟智慧门　　不舍增长诸业行
  一切众生种种根　　上中下品各不同
  所有甚深诸功德　　菩萨随性悉了知
  一切众生种种业　　上中下品差别相
  菩萨深入如来力　　悉能具足分别知
  不可思议无量劫　　悉能了知即一念
  一切十方所行业　　菩萨觉悟清净知
  悉能逆顺知三世　　分别其相各不同
  而亦不违平等相　　是即离痴菩萨行
  一切众生无量行　　爱慢诸结各不同
  菩萨别相分别知　　亦复不舍无相观
  十方世界诸如来　　具足示现大自在
  难见难得难思议　　菩萨悉能分别知
  兜率陀天大导师　　无比最胜人师子
  功德甚深广清净　　一切如实见其性
  示现降神处母胎　　无量自在大神变
  成佛涅槃转法轮　　一切世间莫能转
  人中师子初生时　　一切诸胜悉奉敬
  天王帝释梵天王　　诸有智者悉敬侍
  十方一切无有余　　无量无数诸法界
  无始无末无中间　　示现无量自在力
  人中尊导现生已　　游行诸方各七步
  观察一切众生类　　无碍法门觉一切
  观见众生没五欲　　人中师子现微笑
  众生盲冥愚痴覆　　我当度脱三有苦
  大师子吼出妙音　　我为世间第一尊
  显现明净智慧灯　　永灭生死愚痴闇
  人中师子出世间　　放大光明无有量
  断除一切诸恶道　　无量众苦究竟灭
  或时示现处宫殿　　或现舍家行学道
  人中师子现自在　　饶益一切众生故
  菩萨初坐道场时　　六反震动诸大地
  普放无量大光明　　遍照五道众生类
  震动一切魔宫殿　　开发十方众生心
  昔于菩萨有缘者　　皆悉觉悟真实义
  一毛道中无量乘　　十方一切诸佛刹
  众生道乘无有量　　彼现最胜大神变
  如是方便随顺觉　　如一切佛所演说
  若诸如来所不说　　亦悉解了分别知
  除灭一切众魔怨　　普覆三千大千界
  深入一切无碍门　　能坏一切诸魔道
  如来或在诸佛刹　　或复现处诸天宫
  或复现身梵宫殿　　菩萨悉见无障碍
  转于清净妙法轮　　如来法身无边际
  悉于三世一切劫　　最胜演说无穷尽
  诸佛无等师子座　　悉皆充满十方界
  种种妙相而庄严　　佛处彼座难思议
  真佛子等悉围绕　　充满法界无有余
  说菩萨行无边际　　随顺诸佛出要道
  智者能以一方便　　摄诸佛法无有余
  种种庄严最胜法　　皆悉充满于法界
  无等无量妙自在　　示现一切种种身
  又现诸趣无量生　　或现采女众围绕
  示现出家行学道　　欲令众生诸根利
  乃至示现般涅槃　　分布舍利起塔庙
  如是种种无量行　　如来演说佛所住
  一切如来诸功德　　究竟遍知到彼岸
  如是种种无量行　　于一切劫无休息
  亦未曾生忧戚心　　菩萨皆悉善回向
  一切诸佛自在力　　及佛无量诸功德
  菩萨随顺悉了知　　普为一切众生说
  如是一切诸法王　　随彼无量诸境界
  于一念中悉觉悟　　而亦不舍菩萨行
  一切最胜甚深法　　及诸佛刹正法道
  随顺觉悟殊胜行　　究竟回向到彼岸
  有数无数一切劫　　菩萨深解即一念
  具足修习菩萨行　　于彼胜道不退转
  十方无量一切刹　　或有净妙或垢秽
  及彼一切诸如来　　菩萨皆悉分别知
  于念念中悉明了　　不可思议无量劫
  如是了知三世劫　　具足安住究竟行
  深入了达心所行　　善方便行一切法
  一切佛刹菩萨行　　悉能明了分别知
  出生智慧无有量　　出生众生及诸法
  出生菩提力自在　　一切皆悉无边际
  深入一切无有余　　分别一切诸妙法
  悉分别知同异相　　具足广修菩萨行
  十方一切诸佛刹　　彼有无量无数众
  彼彼诸性各不同　　菩萨皆能分别知
  过去一切诸如来　　未来现在诸导师
  若能如是知回向　　则与三世诸佛等
  若能如是知回向　　则与最胜功德等
  则与最胜智慧等　　则与最胜所行等
  一切世间莫能坏　　诸所学者悉成就
  随顺一切诸最胜　　善能观察于世间
  菩萨所行不可量　　无量功德悉具足
  坚固安住如来行　　具足分别自在力

佛子。何等为菩萨摩诃萨第十法界等无量回向。佛子。此菩萨摩诃萨。离垢缯系顶。受大法师记。能广法施。成大慈悲。安立众生于菩提心。饶益众生。未曾休息。以菩提心长养善根。为一切众生作调御师。示诸众生一切智道。为一切众生作法藏日。善根净光普照一切。等心普观一切众生。欲令众生常行善根。未曾休息。增长清净微妙智慧。不舍一切善根道业。为一切众生作大智慧采宝导师。开示一切安隐正道。以一切众生为首修行诸法。令一切众生。得不可坏真善知识。长养善根。菩萨摩诃萨。行法施等一切善法。摄取萨婆若心。究竟正力到于彼岸。修行坚固难坏菩提之心。常乐大愿。修习菩提。依善知识。离谄曲心。专求菩提。分别无量一切智门境界。菩萨摩诃萨。于彼善根回向广大而无限碍。乃至一句一味。佛所说法。若有能闻。若持若说。以此善根如是回向。一心正念无量无边虚空等世界中三世诸佛。行菩萨行。以此善根回向。令一切佛。常守护念。于一世界。尽未来劫。为一众生。修菩萨行。如一世界。乃至虚空法界等。一切世界尽未来劫。为一众生。修菩萨行。为一切众生。亦复如是。为一切众生。以大庄严。而自庄严。不生离佛善知识想。得是想故。常见现在一切诸佛。乃至未曾违离一佛。诸佛菩萨。所赞梵行。皆悉满足。行不缺梵行。具足不破梵行。不浊梵行。无垢梵行。不退梵行。不坏梵行。诸佛所赞梵行。无依梵行。无所有梵行。离倒清净顺行三世诸佛菩萨梵行。无碍梵行。无取梵行。无诤梵行。无择梵行。安住梵行。无比梵行。不动梵行。不乱梵行。无恚梵行。如我行梵行。令一切众生。皆悉安住此诸梵行。修习梵行。具足梵行。清净梵行。离垢梵行。明照梵行。离尘梵行。离曀梵行。离热梵行。离缠梵行。离一切疑梵行。离一切恼害梵行。得到彼岸。何以故。菩萨若自不修梵行。令他净修梵行。无有是处。菩萨自退梵行。令他具足梵行。无有是处。菩萨自破梵行。令他安立梵行。无有是处。菩萨自离梵行。令他立梵行道。无有是处。菩萨自灭梵行。令他修习梵行。无有是处。菩萨不乐梵行。令他乐修梵行。无有是处。菩萨不住梵行。令他安住梵行。无有是处。菩萨不究竟梵行。令他究竟梵行。无有是处。菩萨自舍梵行。令他不舍安住梵行。无有是处。菩萨坏散梵行。令他摄取梵行。无有是处。何以故。菩萨摩诃萨。如说修行远离颠倒。又能广说离颠倒法。实语实行。修习清净身口意业。离诸染污。行无碍处。灭一切障。菩萨摩诃萨。自正直心。令他正直心法。菩萨修习忍辱。以诸善根。调伏其心。令他修忍。以诸善根调伏其心。菩萨自离疑悔。令他离诸疑悔。菩萨自得欢喜信心。令他得不坏信。菩萨自行坚法。令他行坚法。菩萨摩诃萨。善根如是回向。复次菩萨摩诃萨。以法施等诸善根门。如是回向。以此善根。令一切众生悉得诸佛无尽法门。分别解说诸佛法门。摧灭一切外道邪论。令辞理穷屈。悉得三世一切诸佛所说法海。于一一生法。一一方便法。一一语言法。一一施设法。一一教法。一一说法。一一法门。一一入法。一一决定法。一一住法。悉得无量无边无尽法藏。得无畏法。深入四辩。广为众生。说微妙法。尽未来际。而无穷尽。成正直心。离诸颠倒。生无碍道。言无谬失。众生闻法。悉皆欢喜。解了众生一切言音。得不退转一切法明。一切众生欢喜无量。悉皆安住一切种智。具足离痴明净法辩。闻持诸法。悉能分别一切世界。得法界等无量身。于一念中。悉能充满一切法界。微妙音声。遍满无量无边法界。示现眷属。充满法界。修法界等菩萨净业。得法界等无量菩萨所住。得法界等无量决定法。学法界等无量诸法究竟。住法界等无量菩萨行。回向法界等无量菩萨内法。菩萨摩诃萨。善根如是回向。令一切众生。具足萨婆若。安住萨婆若。复次菩萨摩诃萨。善根如是回向。见法界等无量一切佛。调伏法界等无量众生。严净法界等无量佛刹。得法界等无量菩萨智。得法界等无量无所畏。得法界等无量深妙辩。得法界等无量一切菩萨陀罗尼。得法界等无量不可思议菩萨住。具足法界等无量功德藏。具足法界等无量实义善根。菩萨摩诃萨。复作是念。以此善根。令一切众生。悉得是法。具足成满如我无异。一切行等。功德等。智慧等。力等。无畏等。自在等。正觉等。说法等。如实义等。论议等。诸通等。菩萨摩诃萨。善根如是回向。复次菩萨摩诃萨。以此善根如是回向。如法界无量出生智慧。亦复如是。如法界无量所见诸佛。亦复如是。如法界无量往诸佛刹。亦复如是。如法界无量菩萨所行。亦复如是。如法界不可断得一切智。亦复如是。如法界等一得一切智。亦复如是。如法界自然清净。令一切众生清净。亦复如是。如法界随顺悉至一切。令一切众生。行普贤菩萨行。亦复如是。如法界庄严一切众生。令一切众生。得普贤菩萨庄严。亦复如是。如法界不可坏。令一切众生。得不坏善根。亦复如是。复次菩萨摩诃萨。以此善根如是回向。令一切诸佛菩萨。皆悉欢喜。令诸善根。趣萨婆若。令诸善根。趣一切智。至一切道。令一切众生。常见诸佛。菩萨摩诃萨以此善根。如是回向。见一切佛。能作佛事故回向。见一切佛。不于佛事生住着心。故回向。见一切佛。悉令众生。普得清净故回向。见一切佛。悉能了知故回向。见一切佛。悉无所著故回向。见一切佛。悉能分别无碍法故回向。见一切佛。具普贤行故回向。见一切佛。未曾失时故回向。见一切佛。出生菩萨无量诸力故回向。见一切佛。不忘其法故回向以此善根如是回向。解法界无生。解法界无自性。解法界如如。解法界无依。解法界无妄。解法界离相。解法界寂静。解法界无处所。解法界无去无集。解法界无坏。复次菩萨摩诃萨。善根如是回向。以此法施所摄善根。令一切众生。成大法师。住一切佛无量自在。令一切众生。作无上法师。安立众生于一切智。令一切众生。成无坏法师。一切问难无能穷尽。令一切众生。作无碍法师。具足诸法无碍照明。令一切众生。作智藏法师。巧方便说一切佛法。令一切众生。成就如来自在法师。能善巧说诸如来智。令一切众生。作净眼法师。广说实法。不由他教。令一切众生。作正持佛法法师。具足说法。不失一味。令一切众生。作离相法师。以诸妙相。而自庄严。放无量光。广说诸法。令一切众生。作大身法师。一身充满无数佛刹。兴大法云。普雨佛法。令一切众生作不失佛法大海法师。一切世间无能坏者。令一切众生。作具足圆满日光法师。放佛慧光。悉能显照一切诸法。令一切众生。作随顺问答法师。善巧方便广说诸法。令一切众生。作究竟众行到彼岸法师。善巧方便开无量法藏。令一切众生。作建立正法法师。分别演说如来道智。令一切众生。作了达诸法法师。赞叹功德不可穷尽。令一切众生。作不虚诳法师。入深真妙诸方便际。令一切众生。作善觉魔事法师。悉能坏散一切诸魔。令一切众生。作诸佛摄护法师。未曾暂起我我所心。令一切众生作安隐正法法师。悉得菩萨一切愿力。菩萨摩诃萨。以此善根如是回向。不选择业故回向。不选择报故回向。不选择愿故回向。不选择法故回向。不选择事故回向。不选择因故回向。不选择成法故回向。不选择名身味身句身故回向。不选择回向故回向。不选择义故回向

大方广佛华严经卷第二十一大方广佛华严经卷第二十二

        东晋天竺三藏佛驮跋陀罗译

    金刚幢菩萨十回向品第二十一之九

菩萨摩诃萨。以此善根如是回向。不着色故回向。不着声香味触法故回向。不求生天故回向。不求欲乐故回向。不着欲境界故回向。不求眷属故回向。不求自在故回向。不求生死乐故回向。不着生死故回向。不着死此生彼故回向。不求三有乐故回向。不求欲相应故回向。不求乐处故回向。不毒心故回向。不坏善根故回向。不依三界故回向。不味着诸禅解脱三昧正受故回向。不求住声闻缘觉乘故回向。但欲调伏一切众生满足萨婆若究竟无碍智故回向。欲令一切善根。清净无碍故回向欲令一切众生。超出生死得大乘智故回向。欲满足金刚菩提心故回向。欲究竟成就不死法故回向。欲无量庄严诸佛种姓。示现一切智自在故回向。欲具足菩萨一切法明神力自在故回向。欲于法界虚空界等一切佛刹。行普贤行而不退转。以离痴金刚大庄严而自庄严。安住普贤菩萨地故回向。欲尽未来劫行普贤行度脱众生。示现一切诸佛庄严行地。安住不断故回向。菩萨摩诃萨如是平等心回向。平等法心回向。一切众生无量心回向。无诤心回向。无所有心回向。不乱心回向。等入三世心回向。于三世诸佛种姓心回向。得不死神通心回向。得如来涅槃心回向。令一切众生离地狱饿鬼畜生阎罗王处故回向。令一切众生。除灭障道法故回向。令一切众生。悉具善根欢喜故回向。欲不失转法轮时故回向。欲令一切众生成十力轮。到彼岸故回向。欲令满足无量无边菩萨清净法愿故回向。欲令成就善知识器。随顺一切善知识教。具菩提心宝故回向。欲令一切住佛深法。正直修习一切佛法。具足无上智慧光明故回向。欲令一切菩萨。无碍慧明常现在前故回向。欲令一切常见诸佛现在前故回向。欲令一切得明净法门故回向。欲令一切离诸恐怖。具无所畏菩提心门故回向。欲令一切得菩萨不可思议诸住智门故回向。欲令一切大悲救护悉得清净故回向。欲令一切无余佛刹皆悉庄严故回向。欲令一切除灭一切魔业钩饵。及魔巧术故回向。欲令一切修菩萨行。不着一切佛刹故回向。欲令一切度一切佛法。得一切智广大心故回向。菩萨摩诃萨以此善根。欲令正念清净故回向。欲决定故回向。欲摄取一切佛法分别了知故回向。欲得无量无边无碍智故回向。欲得清净正直心故回向。欲令一切众生。修习大慈心故回向。修习大悲心故回向。修习喜心故回向。修习舍心故回向。得二种无碍解脱。安住善根故回向。欲分别一切缘起法故回向。欲分别缘起法。得法化生心故回向。欲得勇猛幢心故回向。欲得不坏幢藏故回向。欲坏一切魔故回向。欲得一切清净无碍法心故回向。欲行一切菩萨行。得不退转心故回向欲得乐求胜妙心故回向。欲得一切功德法自在智乐求一切智故回向欲满一切愿。灭一切恶。受离垢记。得佛自在。为一切众生。转不退法轮故回向。欲令如来诸妙胜法。无量智慧日光。庄严大智光明。普照一切众生法界故回向。欲调伏一切众生皆悉欢喜。成就大愿。尽未来劫。行菩萨行。灭诸烦恼。离垢清净。坏裂爱网。除愚痴闇。具足离垢无碍之法。修行菩萨不退转行。得一切种智故回向。欲令一切众生得无碍无上妙智慧身。示现无量诸佛身故回向。菩萨摩诃萨。善根如是回向。不着五欲。不依三界。何以故。菩萨摩诃萨。以无染污善根回向。远离嗔恚善根回向。舍离愚痴善根回向。不可沮坏善根回向。远离憍慢善根回向。除灭谄曲善根回向。以正直心善根回向。精勤修习善根回向。菩萨摩诃萨。如是回向时。得大欢喜。于菩萨行。得正希望。趣摩诃萨道。具佛种姓。得佛智慧。离一切恶。降伏众魔。悉能调伏一切众生。令善知识皆悉欢喜。己所修愿皆悉成满。请一切众生。设大施会

复次菩萨摩诃萨。以此法施善根。如是回向。令一切众生。皆悉具足清净法音。得柔软音。得和悦音。得不可思议音。得可爱乐音。得充满一切佛刹音。得不可思议功德庄严音。得灭高大散乱音。得充满法界净妙音。得摄一切众生音。令一切众生。得无量音智。令一切众生。得清净妙音。令一切众生。悉得音声妙自在智。令一切众生。得一切庄严音。令一切众生。悉得妙音。众生乐闻。无有厌足。令一切众生。得解脱音。悉到彼岸。令一切众生得欢喜音。令一切众生。得佛清净语言音。令一切众生。得佛音声。具妙辞辩。远离愚痴。令一切众生得庄严诸法妙陀罗尼。于一一法。说无量行。眷属无数充满法界。悉能闻持不可思议金刚正法。广分别说。能以无量句身味身。具足演说无量法藏。种种法相住无著处。得诸法明。令一切众生。究竟萨婆若。摄一切法。以句身味身。于诸法义。得自在音。于无碍音。具足自在。得到彼岸。令一切众生。得无忧音声。得无畏音声。得无染污音声。得功德音声。得令眷属欢喜音声。得如法音声。得诸佛法语言音声。得疾除灭一切众生疑网音声。得具足辩才不断音声。得胜觉悟众生音声。复次菩萨摩诃萨。以此善根。如是回向。令一切众生。得净法身。令一切众生。得净妙功德。令一切众生。具诸相好。令一切众生。得净业报。令一切众生。得清净萨婆若心。令一切众生。得无量清净菩提之心。令一切众生。得净方便。悉能分别众生诸根。令一切众生。得清净性。令一切众生。得清净无碍行。满足诸愿。令一切众生得清净正念智慧。不断辩才。菩萨摩诃萨。以此善根。如是回向。令一切众生。得如是等清净妙身。所谓明净身。离浊身。究竟净身。清净身。离尘身。离种种尘身。离垢身。光明身。可爱乐身。无碍身。以如是身。普应十方一切世界。示一切业。示现众生。普照一切。示现一切。犹如镜像净水之月。令一切众生。悉得如是净妙之身。示现众生菩萨诸行。示现众生诸深妙法。示现众生无量功德。示现众生真实正道。示现众生具足诸法。示现众生一切大愿。住于一刹。示现一切世界如来出世。示现一切诸佛神足自在。示现受持菩萨不思议解脱。示现普贤诸行一切愿智。菩萨摩诃萨。善根如是回向。令一切众生。成就一切功德智身。复次菩萨摩诃萨以此法施所摄善根。如是回向。令一身遍一切世界。行菩萨行。众生见者。皆悉不空。得不退转菩提之心。令一切众生。随顺真实。得不坏心。令一切众生。于一切世界。尽未来劫。行菩萨道。而无厌足。具法界等大慈悲心。教化众生。未曾失时。分别诸根。念善知识。于一念中。悉见现在一切诸佛。正念如来。未曾暂舍。修诸善根。无有虚欺。安立众生于一切智。悉得不退清净法轮。悉得一切诸佛法明。受持一切诸佛法雨。行菩萨行。入一切众生。入一切刹。入一切法。入一切世间。入一切三世。入一切众生诸业报智。入一切菩萨巧方便智。入一切菩萨出生智入一切菩萨净境界智。入一切佛住持境界。入一切无量无边法界。修菩萨行。安住诸住。是为菩萨摩诃萨法施善根回向。复次菩萨摩诃萨。修善根业。如是回向。令一切佛刹。皆悉清净。以无量庄严具而庄严之。令一佛刹。广大如法界。如一佛刹。一切佛刹。亦复如是。得最正觉。于一佛刹。悉皆显现一切佛刹。如一佛刹。一切佛刹。亦复如是。彼一一刹。以法界等诸庄严具。而庄严之。无量阿僧祇众宝庄严。无量阿僧祇清净众宝高座。诸妙宝衣。以敷其上。无量阿僧祇众妙宝帐。一切宝铃。诸宝垂带。以为庄严。无量宝盖。以张其上。无量宝云。雨一切宝。散众宝华。见者无厌。无量妙宝。以为栏楯。妙宝楼阁。而庄严之。无量宝铃。自然演畅诸佛妙法。无量宝华。周遍充满众妙宝色。以为庄严。无量宝树。充满其刹。出生无量妙宝华果。无量妙宝。以为宫殿。妙宝楼观。遍游诸刹。无量妙宝。以为栏楯。大宝庄严。无量妙宝。为偏楼阁。一切净宝。而庄严之。无量宝门。种种宝鬘。而严饰之。无量珍宝半月形像。悉以众宝而庄严之。无量无数不可思议珍宝庄严。诸佛净业善根所起。无量宝藏庄严。又以众宝。而庄严之。流出无量清净宝河。常流正法。未曾断绝。无量法海。周遍其刹。正法净水。湛然充满。无量阿僧祇宝分陀利华皆悉充满。自然演出正法华音。无量阿僧祇须弥宝山庄严。智慧须弥皆悉具足。无量阿僧祇八楞妙宝庄严。诸宝璎珞以为垂带。无量阿僧祇明净宝庄严。放大慧光。普照法界。无量阿僧祇宝铃庄严。自然演出微妙音声。无量阿僧祇众宝阶道。以为庄严。菩萨妙宝皆悉充满。无量阿僧祇宝缯庄严。不可思议宝色清净。建立无量阿僧祇宝幢庄严。半月宝像而严饰之。无量阿僧祇宝幡庄严。悉能普雨无量宝幡。无量阿僧祇宝缯庄严。充满世界庄饰虚空。敷无量阿僧祇细软宝衣。以为庄严。无量阿僧祇众宝旋流。以为庄严。示现菩萨清净一切智眼。无量阿僧祇宝鬘庄严。一一宝鬘百千菩萨。以为严饰。无量阿僧祇众宝宫殿庄严。悉能除灭诸处所爱。无量阿僧祇众宝庄严金刚摩尼。以为严饰。无量阿僧祇杂宝庄严。示现无量清净妙色。无量阿僧祇金刚围山庄严。清净明彻无所障碍。无量阿僧祇妙香庄严。其香普熏一切世界。出生无量阿僧祇诸变化身。一一化身与法界等。各放无量阿僧祇妙宝光明。一一光明。出一切光。无量阿僧祇明净宝光。以为照耀。能发众生净智慧光。放无量阿僧祇无碍宝光。一一光明。普照法界。无量阿僧祇众宝庄严。一一宝中。具一切宝。无量阿僧祇宝藏庄严。自然演说诸法宝藏。无量阿僧祇宝幢庄严。建立如来妙智慧幢。无量阿僧祇贤宝庄严。具足清净大乘贤宝。无量阿僧祇宝园庄严。菩萨三昧清凉悦乐。无量阿僧祇诸妙宝音自然演出。一一音中。出如来音。充满十方。无不闻者。无量阿僧祇宝像庄严。一一像身普放无量法宝光明。无量阿僧祇众相庄严。一切众相无相庄严。无量阿僧祇宝威仪庄严。见者乐求菩萨威仪。无量阿僧祇长养众宝庄严。出生一切妙宝库藏。无量阿僧祇众宝安住庄严。一切众宝。而严饰之。无量阿僧祇宝衣庄严。皆悉普覆。具足菩萨无量三昧。无量阿僧祇妙衣庄严。其发心者。即得菩萨善现等诸陀罗尼。无量阿僧祇修宝庄严。悉能分别业宝报应决定清净。无量阿僧祇无碍知见妙宝庄严。若有见者。悉得诸法清净法眼。无量阿僧祇宝天冠庄严。具足成就智慧天冠。无量阿僧祇宝座庄严。成佛清净宝师子座。然无量阿僧祇明净宝灯。具足明净妙智慧灯。无量阿僧祇宝多罗树庄严。一一多罗树。以宝璎珞。而严饰之。无量阿僧祇众宝凉台。以为庄严。无量阿僧祇宝树庄严。不思议鸟栖集其上。出妙音声。无量阿僧祇妙宝化华庄严。一一华上无量菩萨。结跏趺坐。遍游法界。无量阿僧祇果实庄严。具萨婆若大智慧果。无量阿僧祇众宝聚落庄严。皆悉修习清净正法。无量阿僧祇宝宅庄严。众宝街巷人民充满。无量阿僧祇大王宝都庄严。彼诸大王勇猛精进被大法铠。于无上道。坚固不退。无量阿僧祇宝舍庄严。除灭一切房室贪爱。无量阿僧祇宝衣庄严。随意受用无所贪着。无量阿僧祇宝家庄严。舍家出家菩萨充满其中。无量阿僧祇无厌足宝庄严。见者能生无量欢喜。无量阿僧祇宝轮庄严。放不思议智慧光明。转不退轮。无量阿僧祇妙宝行树庄严。以清净因那尼罗宝。而庄校之。无量阿僧祇宝地庄严。分别示现不思议宝。无量阿僧祇乐器庄严。出自然音。充满法界。无量阿僧祇乐器庄严。尽未来际。常出法音。未曾断绝。无量阿僧祇宝身庄严。充满其刹。悉能受持一切法宝。无量阿僧祇清净宝口庄严。具足一切功德藏宝。出无量阿僧祇净宝言音。常说无量净妙法宝。无量阿僧祇清净宝心庄严。得正直宝。一切智愿皆悉充满。无量阿僧祇清净宝念庄严。除灭愚痴。得一切智无上宝王。无量阿僧祇清净宝趣庄严。悉能摄受一切诸佛正法之宝。无量阿僧祇菩萨宝慧庄严。决定善知一切佛法。无量阿僧祇不放逸宝智慧庄严。一切智宝皆悉充满。无量阿僧祇清净宝眼庄严。于一切十力宝。无所障碍。无量阿僧祇清净宝耳庄严。善能听闻一切法界微妙音声。而无障碍。无量阿僧祇清净宝鼻庄严。闻净宝香。而无厌足。无量阿僧祇清净宝广长舌庄严。善说一切诸语言法。无量阿僧祇清净宝身庄严。游行十方。而无挂碍。无量阿僧祇清净宝意庄严。悉能修习普贤菩萨一切大愿。无量阿僧祇清净宝音庄严。微妙音声。皆悉充满一切世界。无量阿僧祇宝身业庄严。具足一切智慧宝业。无量阿僧祇宝口业庄严。广说无量智慧妙宝。无量阿僧祇清净宝意业庄严。究竟一切无碍宝智。菩萨摩诃萨复如是念。于彼一切诸如来刹。于一佛刹一方一毛道中。成就无量无数不可思议清净智慧。诸大菩萨皆悉充满。如一佛刹一方一毛道。尽虚空法界等。一切佛刹一切方一切毛道。亦复如是。是为菩萨摩诃萨回向妙宝庄严一切佛刹。如宝庄严一切佛刹。广说香庄严。乃至究竟无量清净。妙香意业无碍宝智。亦复如是。广说华庄严。乃至究竟净华意业无碍宝智。亦复如是。广说鬘。涂香。末香。衣盖幢幡。乃至百事庄严。亦复如是。如是菩萨摩诃萨。以此法施等所摄善根回向。长养善根故回向。严净佛刹故回向。令一切众生。清净平等故回向。令一切众生。除灭嗔恚。令一切众生。具足平等甚深佛法。令一切众生。具足平等不可坏清净功德力。令一切众生。悉得平等无尽智慧。度诸佛法。令一切众生。悉得平等清净梵音。令一切众生。悉得平等无碍净眼。究竟虚空法界等无碍智。令一切众生。悉得清净平等正念。尽过去劫。令一切众生。悉得平等无碍智。决定了知一切诸法。令一切众生。悉得平等菩提。充满法界。无所障碍。令一切众生。悉得平等诸妙善根。令一切众生。悉得平等身口意业。具足功德庄严清净。令一切众生。悉得平等普贤菩萨一切所行令一切众生。悉得平等清净佛刹。令一切众生。悉得平等具足。深入一切智行。令一切众生。离一切恶。悉得平等善根回向。令一切众生。悉得平等一切知见。皆能分别他人心念。令一切众生。悉得平等。安住白法。令一切众生。悉得平等。于一念中。具一切智。究竟满足无上菩提。令一切众生。成就一切平等道行。清净具足。菩萨摩诃萨。以此善根。普为一切平等回向。令一切众生。悉得清净分别诸法之力。广为众生解说回向

菩萨摩诃萨。复作是念。以此善根。令一切众生。修菩萨净行。得无量法海。于一一法海无量法界等。清净智慧。普照法界。令一切众生。分别解说一切句义。令一切众生。悉得一切法明三昧。普照诸法。令一切众生。皆悉具足随顺三世诸佛辩才。令一切众生。得三世佛自在之身。令一切众生。得无碍善根。起佛法爱。不退大悲。救护众生。令一切众生。得无碍智不思议法。能净欢喜一切众会。令一切众生。于一切佛刹。翻覆佛刹。俯伏佛刹。微细佛刹。广大佛刹。清净佛刹。秽浊佛刹。于如是等诸佛刹中。悉转清净不退法轮。令一切众生。于念念中。悉得无尽无所畏辩。广说佛法不可穷尽。令一切众生。常乐一向专求胜法。于一切法。得智慧自在。令一切众生。皆悉欢喜。广说一切法。复次菩萨摩诃萨。安住法界无量善根回向。法界无量身业回向。法界无量口业回向。法界无量意业回向。法界无量妙色回向。法界无量妙受想行识回向。法界无量平等阴回向。法界无量平等界回向。法界无量平等入回向。法界无量内平等回向。法界无量外平等回向。法界无量勇猛精进平等回向。法界无量正直心平等回向。法界无量方便平等回向。法界无量性平等回向。法界无量诸根平等回向。法界无量三世平等回向。法界无量业报平等回向。法界无量离诸烦恼清净平等回向。法界无量一切众生平等回向。法界无量一切佛刹平等回向。法界无量一切诸法平等回向。法界无量一切世间平等回向。法界无量一切诸佛菩萨平等回向。法界无量一切菩萨行愿平等回向。法界无量一切菩萨平等道回向。法界无量一切菩萨成就一切善根回向。法界无量一切诸法平等无二回向。法界无量一切如来眷属圆满平等回向。菩萨摩诃萨。如是回向时。安住法界等无量清净身业。安住法界等无量清净口业。安住法界等无量清净意业。安住法界等无量清净行愿。安住法界等无量清净眷属。安住法界等无量一切菩萨清净智慧。广说诸法。安住法界等无量清净身。充满一切世界法界。得一切法明清净无畏。以一言音。悉除一切众生疑惑。皆令欢喜。调伏诸根。安立无上智。诸力无畏。一切自在力。佛无量功德。上妙法中。佛子。是为菩萨摩诃萨第十法界等无量回向

菩萨摩诃萨。以此法施等一切善根。悉回向已。成就普贤菩萨无量无边一切行愿。悉能严净无量无边虚空法界等一切佛刹。令一切众生亦复如是。具足成就无量无边智慧。深入一切法。于念念中。示现无量无数一切世界诸佛出世。悉得无量无边诸佛自在。悉得无量无边如来自在。悉得无量无边广大自在。悉得无量无边无碍自在。悉得无量无边无障自在。悉得无量无边不可思议自在。悉得无量无边令一切众生清净自在。悉得无量无边一切世界住持自在。悉得无量无边一切不可言说自在。悉得无量无边一切时自在。悉得无量无边一切诸通无碍智自在。悉得无量无边广说诸法充满法界自在。悉得无量无边满足普贤菩萨净眼。悉得菩萨无量无边净耳。闻持诸佛所说正法。能以一身结跏趺坐。充满十方一切世界而不迫迮一切众生。悉得无量无边具足深入三世智慧。悉得无量无边清净菩提。清净众生。清净佛刹。清净诸佛。清净诸入。悉得无量无边虚空法界等清净智慧。悉得无量无边众生语言音声清净智慧。放大光明。普照十方一切世界。出生三世诸菩萨行。清净智慧。于一念中。皆悉究竟三世如来清净智慧。令一切众生。皆悉清净。具足成就平等正观。决定智慧。究竟到彼岸

尔时佛神力故。十方各百万佛刹微尘等世界。六种震动。佛神力故。法如是故。雨天华云。雨天鬘。天末香。天宝衣。天庄严。天香。天摩尼宝。天沉水香。天阿伽楼香。天婆罗揵驮香。天坚固香。天栴檀香。天杂色幡盖。无量阿僧祇天身。不可思议微妙法音。不可思议诸天。妙音赞叹如来。无量阿僧祇诸天。赞叹善哉云雨。无量阿僧祇那由他诸天。恭敬礼拜。无量阿僧祇那由他诸天。欢喜念佛。修习不可思议诸佛功德。无量阿僧祇诸天。出娱乐音。供养如来。放无量阿僧祇广大光明。出过诸天。普照虚空法界等一切佛刹。示现无量阿僧祇如来化身。自在威力。出过诸天。如此世界。一切四天下。兜率陀天。删兜率陀天王宫。说如是法。一切十方世界。删兜率陀天王宫。亦复如是。尔时佛神力故。十方各过百万佛刹微尘等世界。各有百万佛刹微尘等菩萨。悉来云集。咸作是言。善哉善哉。佛子。乃能说此诸大回向。我等悉同一号。名金刚幢。于金刚光世界金刚幢佛所。来诣此土。彼诸世界。佛神力故。亦说是法。大会眷属。说法句味。皆悉同等。我等承佛神力。从彼土来。为汝作证。如我来此世界为汝作证。一切十方一切四天下。删兜率陀天王宫。摩尼宝殿上。说如是法。往为作证。亦复如是。尔时金刚幢菩萨。承佛神力。观察十方。及诸眷属。一切法界诸义句味。修习无量广大之心。无上大悲普覆一切。其心安住三世一切诸佛种性。悉究竟度诸佛功德。成就诸佛自在宝身。悉能分别一切众生希望心行。随彼所种善根。悉知其时。随顺法身。示现色身。如是观已。以偈颂曰

  菩萨受此　　无量法宝　　自然正觉
  大法师记　　为调御师　　普照诸法
  善悟无碍　　最正觉道　　菩萨为法
  调御大师　　能广演说　　难得深法
  十方一切　　无量大众　　皆悉安立
  诸正法门　　菩萨悉饮　　无量法海
  兴大法云　　普雨法雨　　耀明法日
  普照世间　　说微妙法　　饶益众生
  此法施主　　甚难值遇　　具足成就
  诸法方便　　以智慧明　　普照其心
  为世无畏　　广说深法　　善能修习
  变化之心　　广能开发　　诸正法门
  成就诸门　　最胜法海　　普为世间
  击甘露鼓　　能具足说　　难得妙法
  以法长养　　一切功德　　清净正法
  真直之法　　示现众生　　甚深法藏
  最胜授彼　　灌顶法王　　具足成就
  智慧藏身　　无相妙智　　观法真相
  菩萨善法　　而得安住　　菩萨法施
  最为殊胜　　一切诸佛　　咸共赞叹
  随顺一切　　天中之天　　彼能出生
  一切诸佛　　菩萨清净　　微妙法身
  悉从诸佛　　真法化生　　明净法灯
  饶益众生　　说无量法　　除灭忧恼
  菩萨布施　　清净妙法　　随顺思惟
  一切善根　　无量世界　　所作功德
  清净智慧　　皆悉回向　　一切诸佛
  所得功德　　悉令众生　　具足成就
  分别一切　　清净功德　　究竟诸佛
  庄严彼岸　　十方一切　　无量无数
  诸如来等　　严净佛刹　　如是一切
  无余佛土　　众生庄严　　不可思议
  一切如来　　所有智慧　　悉令众生
  清净具足　　犹如普贤　　菩萨庄严
  悉令众生　　亦复如是　　具足成就
  无量自在　　充满无余　　一切世界
  一切十方　　无余众生　　皆悉安住
  彼清净行　　十方无量　　一切佛刹
  彼诸如来　　行菩萨行　　悉令十方
  一切众生　　究竟成就　　无上胜行
  一切佛子　　行佛功德　　无量无边
  不可称数　　诸佛如来　　悉分别知
  皆令众生　　具足成就　　菩萨具足
  诸神通力　　悉能善学　　一切所学
  游行十方　　一切世界　　示现无量
  自在神力　　菩萨能于　　一念之中
  悉见诸佛　　与众生等　　菩萨能于
  一毛道中　　悉见一切　　诸佛正法
  一切众生　　无量诸行　　一切最胜
  悉分别知　　常平等心　　恭敬供养
  一切十方　　无量诸佛　　种种众香
  诸杂宝华　　无量宝衣　　及诸幢盖
  悉皆充满　　无量法界　　以用供养
  一切诸佛　　菩萨能于　　一毛道中
  悉见诸佛　　数不可议　　普能供养
  世间明灯　　其所闻法　　悉能受持
  恭敬礼拜　　五体投地　　举身自归
  一切最胜　　尽未来际　　无量诸劫
  赞叹十方　　一切最胜　　于一佛所
  诸供养具　　数与一切　　众生类等
  如一佛所　　诸供养具　　一切佛所
  亦复如是　　无量无边　　一切诸劫
  菩萨恭敬　　一切导师　　穷尽无量
  一切诸劫　　恭敬供养　　而无厌足
  一切众生　　无量诸劫　　于此劫中
  修菩萨行　　恭敬供养　　一一如来
  尽一切劫　　而无厌足　　一切最胜
  所说大劫　　悉无有能　　称量数者
  尔所一切　　诸大劫中　　修菩萨行
  而无厌足　　悉能觉悟　　一切法界
  广大无边　　无有分际　　众妙宝华
  充满其中　　以用供养　　众生等佛
  诸妙宝华　　色香具足　　清净鲜洁
  无量庄严　　一切世间　　无可为譬
  而以供养　　一切最胜　　众生数等
  无量佛刹　　诸妙宝盖　　弥满其中
  悉以此盖　　奉一如来　　供一切佛
  亦复如是　　微妙最胜　　奇特涂香
  一切世间　　无有伦匹　　以此涂香
  尽众生劫　　供养一切　　诸佛如来
  如是末香　　种种杂华　　微妙香熏
  无量宝衣　　无数妙宝　　诸庄严具
  以供如来　　而无厌足　　众生数等
  一切诸佛　　于一念中　　悉成正觉
  以无量偈　　赞叹宣扬　　恭敬供养
  天人导师　　众生数等　　世间明智
  菩萨无上　　殊胜供养　　众生数等
  一切诸劫　　如来叹德　　犹不能尽
  如是供养　　一切诸佛　　具足成就
  如来自在　　安住普贤　　菩萨所行
  悉能睹见　　一切诸佛　　已作未作
  及现所作　　无量无数　　一切善根
  修习普贤　　菩萨所行　　安住普贤
  菩萨诸地　　一切世间　　悉无有余
  诸佛所知　　众生种类　　悉令成就
  智慧明达　　犹如普贤　　菩萨所得
  如佛所说　　一切诸行　　菩萨悉能
  具足修习　　悉以回向　　一切众生
  普令成就　　无上回向　　一切十方
  诸如来刹　　悉能觉悟　　了达其因
  悉令一切　　无余众生　　皆与普贤
  菩萨齐等　　成就布施　　悉如回向
  持戒具足　　如普贤力　　勇猛精进
  而不退转　　成就忍辱　　不可沮坏
  善入甚深　　诸禅正受　　分别了知
  一切三昧　　清净智慧　　了达三世
  一切世间　　所不能知　　身口诸业
  及与意业　　音声语言　　皆悉清净
  究竟成就　　菩萨诸行　　悉与普贤
  菩萨齐等　　譬如如如　　一切法界
  舍离憍慢　　诸散乱心　　永灭障碍
  普皆清净　　悉令众生　　亦复如是
  如是殊妙　　最胜回向　　一切如来
  之所演说　　以此无量　　善根回向
  具足成就　　菩萨所行　　一切无余
  诸佛真子　　普修行此　　深回向法
  摄取一切　　微妙法界　　深入安住
  诸善逝力　　若有乐求　　此殊胜行
  如来所说　　甚深弥广　　此诸佛子
  皆悉安住　　具足成就　　犹如普贤
  一切众生　　尚可知数　　一切三世
  心犹可知　　普贤菩萨　　功德深广
  无量无边　　不可了知　　一毛可量
  十方虚空　　一切刹尘　　悉可知数
  殊胜大仙　　真佛子等　　所住功德
  不可称量

大方广佛华严经卷第二十二大方广佛华严经卷第二十三

        东晋天竺三藏佛驮跋陀罗译

    十地品第二十二之一

尔时世尊。在他化自在天王宫。摩尼宝殿上。与大菩萨众俱。于阿耨多罗三藐三菩提。皆不退转。从他方世界。俱来集会。此诸菩萨。一切菩萨智慧行处。悉得自在。诸佛如来智慧入处。悉皆得入。善能教化一切世间。于念念中。普能示现神通等事。具足一切菩萨所愿。于一切世。一切劫。一切国土。常修一切诸菩萨行。具足菩萨福德智慧。而无穷尽。能为一切而作饶益。能到一切菩萨智慧方便彼岸。能令众生。背生死道。向涅槃门。不断一切菩萨所行。善游一切菩萨禅定解脱三昧。神通明慧。诸所施为。善能示现。一切菩萨无作神足。皆悉已得。于一念顷能至十方诸佛大会。劝发咨请。受持法轮。常以大心供养诸佛。常能修习诸大菩萨所行事业。其身普现无量世界。其音遍闻。无所不至。其心通达。明见三世。一切菩萨所有功德。具足修习。如是诸菩萨摩诃萨。功德无量无边。于无数劫。说不可尽。其名曰金刚藏菩萨。宝藏菩萨。莲华藏菩萨。德藏菩萨。莲华德藏菩萨。日藏菩萨。月藏菩萨。净月藏菩萨。照一切世间庄严藏菩萨。智慧照明藏菩萨。妙德藏菩萨。栴檀德藏菩萨。华德藏菩萨。优钵罗华德藏菩萨。天德藏菩萨。福德藏菩萨。无碍清净智德藏菩萨。功德藏菩萨。那罗延德藏菩萨。无垢藏菩萨。离垢藏菩萨。种种乐说庄严藏菩萨。大光明网藏菩萨。净明威德王藏菩萨。大金山光明威德王藏菩萨。一切相庄严净德藏菩萨。金刚焰德相庄严藏菩萨。焰炽藏菩萨。宿王光照藏菩萨。虚空无碍妙音藏菩萨。陀罗尼功德持一切世间愿藏菩萨。海庄严藏菩萨。须弥德藏菩萨。净一切功德藏菩萨。如来藏菩萨。佛德藏菩萨。解脱月菩萨。如是等菩萨摩诃萨。无量无边。不可思议。不可称说。金刚藏菩萨。而为上首

尔时金刚藏菩萨摩诃萨。承佛威神。入菩萨大智慧光明三昧。即时十方世界。于一方过亿佛土微尘数世界。有十亿佛土微尘数佛。皆现其身。名金刚藏。十方世界皆亦如是同声赞言。善哉善哉。金刚藏。乃能入是菩萨大智慧光明三昧。如是十方世界微尘数等诸佛。皆同一号。加汝威神。所谓卢舍那佛本愿力故本威神力故。汝有大智慧故。欲宣一切菩萨不可思议诸佛法明故。所谓入智慧地故。摄一切善根故。善分别一切佛法故。广法智故。决定说诸法故。无分别智善分别故。一切世间法不能染故。出世间善根清净故。得不可思议智力故。得一切智人智境界故。所谓如实说菩萨十地差别故。菩萨安住十地故。分别说无漏法故。大智慧光明善分别以自庄严故。入具足智门故。随所应住次第说故。得无碍乐说光明故。具足大无碍智地故。不忘失菩萨心故。教化成熟一切众生界故。得至一切处决定智故。金刚藏。汝当说此法门差别。所谓诸佛神力故。汝能堪受如来智慧神力故。自善根清净故。清净法界故。饶益众生故。入法身智身故。于一切佛。得授记故。得一切世间高大身故。过一切世间道故。净出世间善根故。即时十方诸佛与金刚藏真实无上身。与无障碍乐说辩。与善分别清净智慧。与善忆念不忘。与善决定慧。与至一切智处。与诸佛无坏力。与诸佛无所畏。与诸佛无碍智分别诸法善开法门。与一切诸佛上妙身口意业。何以故。以得菩萨大智慧光明三昧故。亦是菩萨本愿力故。直心清净故。智慧明白故。善集助道法故。善修本业故。念持无量法故。信解清净光明法故。善得陀罗尼门不可坏故。法界智印善印故。尔时十方诸佛皆申右手。摩金刚藏菩萨顶。金刚藏菩萨即从三昧起。告诸菩萨言。诸佛子。是诸菩萨愿决定。无有过。不可坏。广大如法界究竟如虚空。遍覆一切十方诸佛世界众生。为救度一切世间。为一切诸佛神力所护。何以故。诸菩萨摩诃萨。入过去诸佛智地。亦入未来现在诸佛智地。何等是诸菩萨摩诃萨智地。菩萨摩诃萨智地有十。过去未来现在诸佛已说今说当说。为是地故。我如是说。何等为十。一曰欢喜。二曰离垢。三曰明。四曰焰。五曰难胜。六曰现前。七曰远行。八曰不动。九曰善慧。十曰法云。是十地者。三世诸佛已说今说当说。我不见有诸佛国土。不说是十地者。何以故。此十地是菩萨最上妙道。最上明净法门。所谓分别十地事。诸佛子。是事不可思议所谓菩萨随顺诸地智慧。金刚藏菩萨。说诸菩萨十地名已。默然而住不复分别。时一切菩萨闻说菩萨十地名已。咸皆渴仰。欲闻解释。各作是念。何因何缘。金刚藏菩萨。说十地名已默然而住

时大菩萨众中有菩萨。名解脱月。知诸菩萨心之所念。以偈问曰

  净念智慧人　　何故说菩萨
  诸地名号已　　默然不解释
  今诸大菩萨　　心皆怀犹豫
  何故说是名　　而不演其义
  大智诸菩萨　　咸皆欲听闻
  如是诸地义　　愿为分别说
  是诸菩萨众　　清净无瑕秽
  安住坚实中　　具足智功德
  皆以恭敬心　　瞻仰于仁者
  愿欲闻所说　　如渴思甘露

时金刚藏菩萨。闻说是已。欲令众悦。以偈答曰

  诸菩萨所行　　第一难思议
  分别是十地　　诸佛之根本
  微妙甚难见　　非心所能及
  从佛智慧出　　若闻则迷没
  持心如金刚　　深信佛智慧
  以为第一妙　　心无有疑难
  远离计我心　　及心所行地
  如是诸菩萨　　尔乃能听闻
  寂灭无漏智　　分别说甚难
  如画于虚空　　如执于疾风
  我念佛智慧　　第一难思议
  众生少能信　　是故我默然

解脱月菩萨。闻说此已。语金刚藏菩萨言。佛子。是大菩萨众直心清净。善行菩萨道。善集助道法。善恭敬供养诸佛。于无量佛。多种善根。成就无量深厚功德。离痴疑悔。无有贪着。及诸结碍。深心信解。安住不动。于是法中。不随他教。是故佛子。当承佛力。敷演此义。是诸菩萨于是深法皆能证知。时解脱月菩萨。欲重宣此义。以偈颂曰

  愿说安隐法　　菩萨无上行
  分别于诸地　　令智慧清净
  众智净无垢　　安住深信解
  于诸无量佛　　证知十地义

金刚藏菩萨言。佛子。是诸大众。虽皆清净离痴疑悔。于是法中。不随他教。其余乐小法者。闻是甚深难思议事。或生疑悔。是人长夜受诸衰恼。我愍此等。是故默然。时金刚藏菩萨。欲重宣此义。以偈颂曰

  是众虽清净　　深智离疑悔
  其心已决定　　不复随他教
  无动如须弥　　不乱如大海
  其余不久行　　智慧未明了
  随识不随智　　闻已生疑悔
  彼将堕恶道　　愍念故不说

解脱月菩萨言。佛子。愿承佛力。善分别此不可思议法。佛所护念事。令易信解。所以者何。善说十地义。十方诸佛法应护念。一切菩萨护是事故。勤行精进。何以故。是菩萨最上所行。得至一切诸佛法故。譬如一切文字皆初章所摄。初章为本。无有一字不入初章者。如是佛子。十地者是一切佛法之根本。菩萨具足行是十地。能得一切智慧。是故佛子。愿说此义。诸佛护念。加以神力。令人信受。不可破坏。时解脱月菩萨。欲明显此义以偈颂曰

  善哉智慧子　　清净行具足
  愿说十地行　　所入十地法
  具足于智慧　　得以成菩提
  所有十方佛　　最胜人中尊
  皆共护念汝　　说是十地义
  十地为根本　　是名智行处
  亦为究竟道　　佛无量法聚
  譬如诸文字　　皆摄在初章
  诸佛功德智　　十地为根本

尔时诸菩萨。一时同声以偈请金刚藏菩萨言

  上妙智慧人　　乐说无有量
  德重如山王　　哀愍说十地
  戒念慧清净　　说是十地义
  十力之根本　　无碍智本行
  戒定慧功德　　集在仁者心
  憍慢诸邪见　　皆悉已灭尽
  是众无疑心　　唯愿闻善说
  譬病思良医　　如饥思美膳
  我等亦如是　　闻甘露法味
  是故旷大意　　愿开初地门
  乃至第十地　　次第为我说

尔时释迦牟尼佛。从眉间白毫相。放菩萨力光明。百千阿僧祇光。以为眷属。普照十方诸佛世界。靡不周遍。三恶道苦。皆得休息。悉照十方诸佛大会说法之众。显现如来不思议力。是光明遍照十方诸佛大会诸菩萨身已。于上虚空中。成大光明云台。十方诸佛亦复如是。从眉间白毫。俱放菩萨力光明。百千阿僧祇光。以为眷属。普现如来不思议力。悉照一切诸佛大会。及娑婆世界释迦牟尼佛一切大众。并金刚藏菩萨。及师子座。照已于上虚空中。成大光明云台。时诸大光明云台中。诸佛神力故。而说颂曰

  无等等诸佛　　功德如虚空
  十力无畏等　　最尊世间主
  于释迦佛前　　而现此神力
  以佛力开现　　法王无畏藏
  说诸地所行　　诸地义差别
  承诸佛神力　　无有能坏者
  若人闻法宝　　则为诸佛护
  渐次具诸地　　得以成佛道
  若人堪任闻　　虽在于大海
  及劫尽火中　　必得闻此经
  若人痴疑悔　　终不能得闻
  是故今佛子　　说诸地智道
  入势力观法　　次第而修行
  得至于余地　　各得所利益
  利一切世间　　愿说勿令断

尔时金刚藏菩萨。观察十方。欲令大众。增益信敬。以偈颂曰

  诸佛圣主道　　微妙甚难解
  非思量所得　　唯智者行处
  其性从本来　　寂然无生灭
  从本已来空　　灭除诸苦恼
  远离于诸趣　　等同涅槃相
  无中亦无后　　非言辞所说
  出过于三世　　其相如虚空
  诸佛所行处　　清净深寂灭
  言说所难及　　地行亦如是
  说之犹尚难　　何况以示人
  诸佛之智慧　　离诸心数道
  不可得思议　　非有阴界入
  但以智可知　　非识之所及
  如空迹难说　　何可示其相
  十地义如是　　非心意所行
  是事虽为难　　发愿行慈悲
  渐次具诸地　　智者所能及
  如是诸地行　　微妙甚难见
  不可以心知　　当承佛力说
  汝等当恭敬　　咸共一心听
  智慧所随顺　　诸地相入行
  于无量亿劫　　说之不可尽
  今如实略说　　其义无有余
  一心恭敬待　　今承佛力说
  大音唱因谕　　义名不相违
  佛神力无量　　今皆在我身
  我之所说者　　如大海一渧

金刚藏菩萨。说此偈已。告于大众。诸佛子。若众生厚集善根。修诸善行。善集助道法。供养诸佛。集诸清白法。为善知识所护。入深广心。信乐大法。心多向慈悲。好求佛智慧。如是众生。乃能发阿耨多罗三藐三菩提心。为得一切种智故。为得十力故。为得大无畏故。为得具足佛法故。为救一切世间故。为净大慈悲心故。为向十方无余无碍智故。为净一切佛国。令无余故。为于一念中。知三世事故。为自在转大法轮。广示现佛神力故。菩萨摩诃萨生如是心。诸佛子。是心以大悲为首。智慧增上。方便所护。直心深心淳至。量同佛力。善决定众生力佛力。趣向无碍智。随顺自然智。能受一切佛法。以智慧教化。广大如法界。究竟如虚空。尽未来际。菩萨发如是心。即时过凡夫地。入菩萨位。生在佛家。种姓尊贵。无可讥嫌。过一切世间道。入出世间道。住菩萨法中。在诸菩萨数。等入三世如来种中。毕定究竟阿耨多罗三藐三菩提。菩萨住如是法。名住欢喜地。以不动法故。诸佛子。菩萨摩诃萨。住欢喜地。多喜。多信。多清净。多踊悦。多调柔。多堪受。不好斗诤。不好恼乱众生。不好嗔恨。诸佛子。诸菩萨住是欢喜地。念诸佛故。生欢喜心。念诸佛法故。生欢喜心。念诸菩萨摩诃萨故。生欢喜心。念诸菩萨所行故。生欢喜心。念诸波罗蜜清净相故。生欢喜心。念诸菩萨与众殊胜故。生欢喜心。念诸菩萨力不可坏故。生欢喜心。念诸如来教化法故。生欢喜心。念能为利益众生故。生欢喜心。念一切佛一切菩萨所入智慧方便门故。生欢喜心。菩萨复作是念。我转离一切世间境界。生欢喜心。入一切佛平等中。生欢喜心。远离凡夫地。生欢喜心。近智慧地。生欢喜心。断一切恶道。生欢喜心。与一切众生作依止。生欢喜心。近见一切诸佛。生欢喜心。生诸佛境界。生欢喜心。入一切诸菩萨数。生欢喜心。离一切恐怖。生欢喜心。所以者何。是菩萨得欢喜地。所有怖畏即皆远离。所谓不活畏。恶名畏。死畏。堕恶道畏。大众威德畏。离如是等一切诸畏。何以故。是菩萨离我相故。尚不贪身。况所用物。是故菩萨无不活畏。心不希望恭敬供养。我应供养众生。供给所须。是故菩萨无恶名畏。远离我见。无我相故。无有死畏。又作是念。我若死已。所生必见诸佛菩萨。是故无有堕恶道畏。我所志乐。无与等者。何况有胜。是故无有大众威德畏。如是菩萨永离一切诸恐怖事。诸佛子。是菩萨以大悲为首。于一切众生。心无嫌恨。直心坚固自然清净。转复勤修一切善根。所谓信心增上。多行净心。解心清净。多以信心分别。出生大悲。成就大慈。心不疲懈。以惭愧庄严。成就忍辱柔和。敬顺诸佛教法。信重善知识。日夜常修一切善根。常爱乐法。求多闻无厌。如所闻法正念观察。心不贪着。不求名闻。不求利养资生之物。常生宝心无有厌足。乐一切智地。欲得诸佛。力无畏。不共法。求助诸波罗蜜法。离诸谄曲。如说能行。常行实语。不污诸佛家。不舍菩萨戒。生萨婆若。心不动如山王。不乐世间事。成就出世间善根。集善助菩提法无有厌足。常求胜中胜道。菩萨成就如是净地法。名为安住欢喜地

菩萨如是安住欢喜地。发诸大愿。生如是定心。所谓我当以清净心。供养一切诸佛。皆无有余。一切供具随意供养。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽供养一切劫中所有诸佛。以大供养具。无有休息。又一切诸佛所说经法。皆悉受持。摄一切诸佛阿耨多罗三藐三菩提。一切诸佛所教化法。悉皆随顺。一切诸佛法皆能守护。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽皆守护一切劫中一切佛法。无有休息。又一切世界。一切诸佛。从兜率天下。入胎处胎。初生出家。成佛道时。劝请转大法轮。示入大涅槃。我于尔时。尽往供养摄法为首。三时转故。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。奉迎供养一切诸佛。无有休息。又一切菩萨所行广大无量不可坏。无分别诸波罗蜜所摄。诸地所净生诸助道法。总相别相。有相无相。有成有坏。一切菩萨所行诸地道。及诸波罗蜜本行。教化一切。令其受行。心得增长。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫中菩萨所行。以诸教化。成熟众生。无有休息。又一切众生。若有色。若无色。有想。无想。非有想。非无想。卵生。胎生。湿生。化生。三界所系。入于六道一切生处。名色所摄。教化成熟。断一切世间道。令住佛法。一切智慧。使无有余。发如是大愿广大如法界。究竟如虚空。尽未来际。尽一切劫。教化一切众生。无有休息。又一切世界广狭。及中无数无量。不可分别。不可坏。不可动。不可说。粗细正住倒住。平坦方圆。随入如是世界智。如因陀罗网差别。如是十方世界差别。皆现前知。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。如是世界。皆现前知。无有休息。又一切佛土入一佛土。一佛土入一切佛土。一一佛土无量庄严。离诸垢秽。具足清净智慧。众生悉满其中。常有诸佛大神通力。随众生心。而为示现。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。净如是国土。无有休息。又一切菩萨同心同学。共集诸善。无有怨嫉。同一境界。等心和合。常不相离。随其所应。能现佛身。自于心中。悉能解知诸佛境界。神通智力。常得随意神通。悉能游行一切国土。一切佛会皆现身相。一切生处普生其中。有如是不可思议大智慧。具足菩萨行。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。行如是大智慧道。无有休息。又乘不退轮。行菩萨道。身口意业所作不空。众生见者。即必定佛法。闻我音声。即得真实智慧。有见我者。心即欢喜。离诸烦恼。如药树王。为得如是行菩萨道。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。行不退道。所作不空。无有休息。又于一切世界。皆得阿耨多罗三藐三菩提。于一毛端。示现入胎出家。坐道场。成佛道。转法轮。度众生。示大涅槃。现诸如来大神智力。随一切众生所应度者。念念中得佛道。知一切法如涅槃相。以一音声。令一切众生。皆发欢喜。示大涅槃。而不断菩萨所行。示众生大智地。使知一切法皆是假伪。以大智慧神通自在。出生变化充满法界。发如是大愿。广大如法界。究竟如虚空。尽未来际。尽一切劫。得佛道事。求大智慧。大神通等。无有休息。诸佛子。菩萨住欢喜地。以十愿为首。生如是等百万阿僧祇大愿。以十不可尽法。而生是愿。为满此愿。勤行精进。何等为十。一众生不可尽。二世界不可尽。三虚空不可尽。四法界不可尽。五涅槃不可尽。六佛出世不可尽。七诸佛智慧不可尽。八心所缘不可尽。九起智不可尽。十世间转法转智转不可尽。若众生尽。我愿乃尽。若世界。虚空。法界。涅槃。佛出世。诸佛智慧。心所缘。起智。诸转尽。我愿乃尽。而众生实不可尽。世界。虚空。法界。涅槃。佛出世。诸佛智慧。心所缘起智。诸转。实不可尽。我诸愿善根亦不可尽。诸佛子。菩萨决定发是大愿。则得利安心柔软心。调顺心。寂静心。不放逸心。寂灭心。直心。和润心。不恚心。不浊心。如是则成信者。乐以信分别功德。信诸佛本所行道。信行诸波罗蜜。而得增长。信善入诸地得殊胜功德。信得成佛十力。信具足四无所畏。信不共法不可坏。信诸佛法不可思议。信诸佛自在神力无量无边。信诸如来无量行门。信从因缘以成果报。举要言之。信诸菩萨普行。诸佛功德智慧。威神力等。诸佛子。菩萨作是念。诸佛正法如是甚深。如是离相。如是寂灭。如是空。如是无相。如是无作。如是无染。如是无量。如是广大。如是难坏。而诸凡夫。心堕邪见。无明痴冥。蔽其慧眼。常立憍慢幢。堕在渴爱网。随顺谄曲。常怀悭嫉。而作后身生处因缘。多集贪欲嗔恚愚痴。起诸重业。嫌恨猛风吹罪心火常令炽然。有所施作。皆与颠倒相应。欲流。有流。见流。无明流。相续起心意识种于三界地。生苦恼芽。所谓名色。名色和合。增长六入。根尘相对生触。触故生受。贪乐受故。生爱。爱增长故。生取。取因缘故。复起后有。有因缘故。有生老死忧悲苦恼。如是因缘。集诸苦聚。受诸苦恼。是中无我。无我所。无作者。无受者。无知者。如草木瓦石。又如影响。凡夫可愍。不知不觉。而受苦恼。菩萨于此见诸众生不免诸苦。即生大悲智慧。是诸众生我应救护。令住毕竟佛道之乐。即生大慈智慧。菩萨摩诃萨。随顺如是大慈悲法。以深妙心。住在初地。于一切物。无所贪惜。尊重诸佛大妙智故。学行大施。即时所有尽能施与。金银摩尼。砗磲码瑙。琉璃珊瑚。琥珀珂贝。珍宝璎珞。严身之具。及象马辇舆。人民奴婢。国土城邑园林游观。妻妾男女。一切所爱。皆悉施与。头目耳鼻。肢节手足。深重佛故。而不贪惜。菩萨摩诃萨住于初地。能行大施。是菩萨以大悲心。大施心。救一切众生故。勤求世间出世间利益之事。心无疲懈。是故菩萨生无疲倦功德。于诸经书。能自开解。是故生知经书功德。得如是知经书智慧。善能筹量应作不作。于上中下众生。随宜利益。是故菩萨生世智功德。得世智功德。则知时知量。惭愧庄严。修习自利利彼之道。是故则生惭愧功德。如是功德精勤修行。心不懈退。是精进不退功德。即得堪受力。得堪受力已。勤行供养一切诸佛。随佛所说。如说修行诸佛子。是菩萨悉知生起如是净地法。所谓信慈悲施。无有疲倦。知诸经书。善解世法。惭愧堪受。供养诸佛。如所说行

又是菩萨住欢喜地。少见诸佛。以愿力故。广见数百千万亿那由他诸佛世尊。心大欢喜。深心爱敬。以上乐具。供养诸佛。及一切僧。以是福德。皆回向阿耨多罗三藐三菩提。是菩萨因供养诸佛故。生教化众生法。多以二摄摄取众生。所谓布施爱语。后二摄法。以信解力行未善通达。是菩萨随所供养诸佛。教化众生。皆能受行诸净地法。如是诸功德。皆回向萨婆若。转益明显。堪任有用。譬如金师炼金随以火力调柔可用增益光色。如是菩萨供养诸佛。教化众生。行净地法。此诸功德。皆回向萨婆若。转益明显。随意所用。诸佛子。是菩萨摩诃萨于初地中。行果相貌。从诸佛菩萨善知识所。咨受请问成地之法。无有厌废。是菩萨住初地中。于诸佛菩萨善知识所。咨受请问第二地中行果相貌。无有厌足。如是第三。第四。第五。第六。第七。第八。第九。第十地中。行果相貌。从诸佛菩萨善知识所。咨受请问。成十地法。无有厌废。是菩萨善知诸地对治法。善知诸地成坏。善知诸地行果。善知分别得诸地。善知诸地清净行。善知诸地从一地至一地行。善知诸地是处非是处。善知诸地转所住处。善知诸地胜进业。善知诸地得不退转。乃至善知一切菩萨净地法入如来智地。诸佛子。如是菩萨善知诸地行。未发初地。乃知十地。无有障碍。得诸地智慧光明。乃至知诸佛智慧光明。如大商主。多将贾人。欲至大城。先问道路。退还过咎在道利害。未发初处。知道宿时。乃至善知到彼城事。能以智慧。思惟筹量。具诸资用。令无所乏。正导人众。得至大城。于险道中。免诸患难。身及众人。皆无忧恼。菩萨摩诃萨亦复如是。住于初地。而善知诸地对治法。乃至善知一切菩萨净地法。入如来智地。尔时菩萨集大福德智慧资粮为众生商主。随宜教化。令出生死险难恶处。示安隐道。乃至令住萨婆若智慧大城。无诸衰恼。是故菩萨常应心不疲倦。勤修诸地本行。乃至善知入如来智地。诸佛子。是名略说菩萨入欢喜地。广说则有无量百千万亿阿僧祇事。菩萨住欢喜地。多作阎浮提王。豪贵自在。常护正法。能以大施摄取众生。善除众生悭贪之垢。常行大施。而无穷尽。所作善业。布施。爱语。利益。同事。是诸福德。皆不离念佛。不离念法。不离念诸同行菩萨。不离念菩萨所行道。不离念诸波罗蜜。不离念十地。不离念诸力。无畏。不共法。乃至不离念具足一切种智。常生是心。我当于一切众生中。为首。为胜。为大。为妙。为上。为无上。为导。为将。为帅。为尊。乃至于一切众生中。为依止者。诸佛子。是菩萨若欲舍家勤行精进。于佛法中。便能舍家妻子五欲。得出家已。勤行精进。须臾之间。得百三昧。得见百佛。知百佛神力。能动百佛世界。能飞过百佛世界。能照百佛世界。能教化百世界众生。能住寿百劫。能知过去未来世各百劫事。能善入百法门。能变身为百。于一一身。能示百菩萨。以为眷属。若以愿力。自在示现。过于此数。百千万亿那由他劫。不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  若有诸众生　　厚修集善根
  成就清白法　　亲近于诸佛
  清净信乐力　　随顺慈悲心
  如是人能发　　无量之佛智
  诸佛一切智　　无量力清净
  堪受力坚牢　　成就诸佛法
  悲心救世间　　净修诸佛国
  敷演转法轮　　发此无上愿
  一念知三世　　而无有别异
  种种时差别　　以示于世间
  略说则尽求　　诸佛之功德
  发于广大心　　犹若如虚空
  悲心智慧首　　方便合修行
  深直心淳至　　其力无有量
  心向无障碍　　而不随他教
  同诸佛平等　　而生于大心
  诸佛子发生　　如是之宝心
  即离凡夫地　　入于佛所行
  即生如来家　　无有可讥嫌
  则同于诸佛　　必成无上道
  生如是心时　　即便得初地
  其心不可动　　犹如大山王
  是菩萨便有　　大喜相显现
  其心常清净　　堪受于大事
  心不乐斗讼　　不好恼众生
  无有嗔恨心　　乐惭愧恭敬
  又习行直心　　守护于诸根
  常念救世间　　念求诸佛智
  心生于欢喜　　我当得此事
  得于欢喜地　　即过五恐怖
  不活死恶名　　恶道众威德
  以不贪着我　　及与我所故
  是诸佛子等　　远离诸怖畏
  常行慈悲心　　恒有信恭敬
  惭愧功德备　　昼夜增善法
  乐功德实利　　不乐于诸欲
  如有所闻法　　能常善思惟
  无有贪着行　　断诸利养心
  常乐于菩提　　一心求佛智
  行诸波罗蜜　　离于谄曲心
  随说而能行　　安住实语中
  不污诸佛家　　不舍菩萨学
  远世间事愿　　乐出于世间
  求善法无厌　　精进转增益
  诸菩萨如是　　好乐诸功德
  而发于大愿　　求欲见诸佛
  护法至佛所　　行菩萨妙行
  化一切众生　　净一切佛土
  我佛国土中　　满诸大菩萨
  诸菩萨同心　　见闻皆不空
  一切微尘中　　诸佛成佛道
  发于如是等　　无量无边愿
  是愿无穷尽　　如虚空众生
  法界世涅槃　　诸佛出智慧
  心缘起智转　　我愿如是住
  如是发大愿　　心柔软调顺
  能信佛功德　　而观于众生
  知从因缘起　　则生慈悲心
  即于苦众生　　我当救度之
  为是众生故　　而行种种施
  所谓妙国土　　一切诸珍宝
  象马及车乘　　眷属与人民
  头目及手足　　肌肉施无悔
  求种种经书　　心无有疲倦
  得解其义趣　　能随世而行
  惭愧堪受力　　渐令得增长
  能以恭敬心　　供养无量佛
  智者于日夜　　如是常修行
  善根转明净　　犹若成炼金
  菩萨住是地　　能了知十住
  展转修行时　　无有诸障碍
  譬如贾客主　　欲利诸商人
  先问道路中　　诸险艰难事
  菩萨住初地　　善知诸地行
  而无有障碍　　能至于佛地
  住是初地中　　多作阎浮王
  善知于诸法　　常行慈悲心
  如法而化导　　一切皆信敬
  劝令行布施　　以求佛智慧
  菩萨若舍国　　佛法中出家
  勤行于精进　　即得百三昧
  能见百诸佛　　震动百国土
  光明照百国　　飞行亦如是
  化百土众生　　入于百法门
  念知百劫事　　示现于百身
  能以百菩萨　　眷属而示现
  若以其愿力　　过是数无量
  今明初地义　　但以略解说
  若欲广说者　　亿劫不能尽
  是初菩萨地　　名之为欢喜
  利益众生者　　今已分别竟

大方广佛华严经卷第二十三大方广佛华严经卷第二十四

        东晋天竺三藏佛驮跋陀罗译

    十地品第二十二之二

  一切菩萨众　　闻说上地义
  其心皆清净　　欢喜无有量
  各于所坐处　　踊住虚空中
  以诸上妙华　　散于金刚藏
  咸皆称赞言　　善哉金刚藏
  大智无所畏　　善说菩萨地
  解脱月大士　　知众心清净
  欲闻第二地　　行相之诸说
  即请金刚藏　　大智愿解说
  第二地行相　　一切皆欲闻

金刚藏菩萨语解脱月菩萨言。佛子。菩萨摩诃萨。已具足初地。欲得第二地者。当生十种直心。何等为十。一柔软心。二调和心。三堪受心。四不放逸心。五寂灭心。六真心。七不杂心。八无贪吝心。九胜心。十大心。菩萨以是十心。得入第二地。菩萨住离垢地。自然远离一切杀生。舍弃刀仗。无嗔恨心。有惭有愧。于一切众生。起慈悲心。常求乐事。尚不恶心恼于众生。何况加害。离诸劫盗。资生之物常知止足。若物属他。他所受用。于是物中。不与不取。离于邪淫。自足妻色。于他女人。不生一念。离于妄语。常真实语。谛语随语。乃至梦中尚不妄语。何况故作。离于两舌。无破坏心。于斗诤离散人中。常好和合。离于恶口。所有言语粗犷苦恶。自坏其身。亦坏于他。如是等语。皆悉舍离。离无义语。常自守护所可言说。应作不作。常知时语。利益语。顺法语。筹量语。乃至戏笑尚无所犯。何况故作。不贪他物。若物属他。他所摄用。不作是念。我当取之。离嗔害心。常于众生。求爱润心。慈悲心。离于占相。习行正见。决定深信罪福因缘。离于谄曲。诚信三宝。生决定心。菩萨如是常护善道。作是思惟。一切众生堕恶道者。皆由十不善道。我当自住善法。亦当为人说诸善法。示正行处。何以故。若人自不行善。为他说法。令住善者。无有是处。又深思惟行十不善道。则堕地狱。畜生。饿鬼。行十善道。则生人处。乃至有顶。又是十善道。与智慧和合修行。若心劣弱。乐少功德。厌畏三界。大悲心薄。从他闻法。至声闻乘。若行是十善道。不从他闻。自然得知。不能具足大悲方便。而能深入众因缘法。至辟支佛乘。若行是十善道。清净具足。其心广大无量无边。于众生中。起大慈悲。有方便力。志愿坚固。不舍一切众生。求佛大智慧。净菩萨诸地。净诸波罗蜜。入深广大行。则能得佛十力。四无所畏。四无碍智。大慈大悲。乃至具足一切种智。集诸佛法。是故我应行十善道。求一切智。是菩萨复作是思惟。此十不善道。上者地狱因缘。中者畜生因缘。下者饿鬼因缘。于中杀生之罪。能令众生。堕于地狱。畜生。饿鬼。若生人中。得二种果报。一者短命。二者多病。劫盗之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者贫穷。二者共财不得自在。邪淫之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者妇不贞洁。二者得不随意眷属。妄语之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者多被诽谤。二者为人所诳。两舌之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者得弊恶眷属。二者得不和眷属。恶口之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常闻恶音。二者所可言说恒有诤讼。无义语罪。亦令众生。堕三恶道。若生人中。得二种果报。一者所有言语人不信受。二者有所言说不能明了。贪欲之罪。亦令众生。堕三恶道若生人中。得二种果报。一者多欲。二者无有厌足嗔恼之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常为一切。求其长短。二者常为众人之所恼害。邪见之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者生邪见家。二者其心谄曲。诸佛子。如是十不善道。皆是众苦大聚因缘。菩萨复作是念。我何故不离是十不善道。行十善道。亦令他人。行此善道。如是念已。即离十不善道。安住十善道。亦令他人。住于善道。是菩萨尔时于一切众生。生安隐心。乐心。慈心。悲心。哀愍心。利益心。守护心。师心。大师心。自己心。作是念。是诸众生。堕于邪见随逐邪心。行邪险道。甚可哀愍。我应令彼住正见道如实法中。是诸众生常共斗诤分别彼我。我应令彼住于大慈是诸众生。常贪财物。无有厌足。恒以邪命而自生活。我应令彼住于清净身口意业。是诸众生。随逐贪欲。嗔恚。愚痴。常为种种烦恼大火之所烧然。不能志求出要方便。我应令彼灭烦恼火。置清凉处。是诸众生常为无明所覆。入大黑闇。离慧光明。入于生死大险道中。随逐种种无量邪见。我应令彼得无障碍清净慧眼。以是眼故。知一切法如实相。得不随他一切如实无障碍智。是诸众生。堕生死道。将坠地狱。畜生饿鬼。入邪见网。为种种愚痴丛林所覆。随逐虚妄邪道径路。常为愚痴之所盲冥。远离导师。非出要道谓为出要。随顺魔心。远离佛意。我应令彼度于生死险道艰难。安处令住一切智人。无畏大城。无诸衰恼。是诸众生。为诸烦恼暴水所没。欲。有。见。无明。四流所漂。随生死流。入大爱河。为诸烦恼势力所食。不能得求出要之道。常为欲觉。恚觉。恼觉。恶虫所害。又为水中身。见罗刹所执。入于五欲深流洄复。喜爱淤泥之所没溺。我慢陆地之所燋枯。无所归趣。于十二入怨贼聚落。不能得出。不遇导师能正度者。我应于彼生大慈悲。以善根力。而拔济之。得安隐处。离诸恐怖。住于一切智慧宝洲。是诸众生。深心贪着。多有忧悲。苦恼患难。憎爱所缚。欲械所系。入于三界无明稠林。我应令彼远离一切三界所著。令住离相无碍涅槃。是诸众生。深着我我所。于五阴樔窟。不能自出。常随四倒。依六入空聚。为四大毒蛇之所侵害。为诸烦恼众贼所杀。受此一切无量苦恼。我应令彼。离诸贪着。住于寂静。所谓断一切障碍。安隐涅槃。是诸众生。其心狭劣。乐于小法。远离无上一切智慧。贪着小乘。不能志求大乘出法。我应令彼住广大心无量无边诸佛道法。所谓无上大乘。诸佛子。是菩萨如是随顺持戒力。善能广生大慈悲心

是菩萨住离垢地。得见数百千万亿那由他诸佛世尊。以衣被饮食。卧具医药。资生之物。而供养之。于诸佛所。生恭敬心。复受十善道。乃至得阿耨多罗三藐三菩提。终不中失。是菩萨若干百千万亿劫。远离悭贪破戒垢故。净修布施持戒功德。譬如真金炼之以火。一切垢尽。转复明净。菩萨亦如是。住离垢地。若干百千。乃至无量百千万劫。远离悭贪破戒垢故。净修布施持戒功德。菩萨尔时于四摄法。爱语偏多。十波罗蜜。戒波罗蜜偏胜。余波罗蜜。亦皆修集。随地增长。佛子。是名菩萨摩诃萨第二离垢地。菩萨住是地。多作转轮圣王。为大法王。广得法力。七宝成就。有力自在。能除一切众生悭贪破戒之垢。以善方便。令众生住十善道。为大布施。而不穷尽。所作善业。布施爱语。利益同事。是诸福德。皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心。我当于一切众生中。为首为胜。乃至于一切众生中。为依止者。佛子。是菩萨若欲舍家勤行精进。于佛法中。便能舍家妻子五欲。得出家已。勤行精进。须臾之间。得千三昧。得见千佛。知千佛神力。能动千佛世界。能飞过千佛世界。能照千佛世界。能教化千世界众生。能住寿千劫。能知过去未来世各千劫事。能善入千法门。能变身为千。于一一身。能示千菩萨。以为眷属。若以愿力自在示现。过于此数。百千万亿那由他劫。不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  菩萨入二地　　柔软调和心
  堪受不放逸　　寂灭真不杂
  亦无有贪吝　　胜大悉具足
  得是十心已　　入于第二地
  菩萨住是地　　成就诸功德
  常离于杀生　　不恼害一切
  常离于劫盗　　亦无有邪淫
  不两舌妄语　　恶口无义言
  他所有财物　　不生于贪着
  不恼于众生　　直心行正见
  无有憍慢心　　亦无谄曲意
  柔软不放逸　　护持诸佛教
  所有剧苦恼　　地狱与畜生
  饿鬼炽然身　　皆从恶心有
  我今已永离　　如是诸恶事
  行于真实道　　寂灭之善法
  从人至有顶　　所有受乐处
  禅定三乘乐　　皆从十善生
  如是思惟已　　心常不放逸
  身自持净戒　　亦教人令持
  遍观诸众生　　种种受苦恼
  如是愍念已　　转生深悲心
  凡夫甚可愍　　堕在诸邪见
  心多怀嗔恨　　常好起诤讼
  常乐于五欲　　贪求无有厌
  起三毒因缘　　我应度此等
  深覆愚痴闇　　坠生死险道
  入大邪见网　　堕于世笼槛
  常为诸魔贼　　烦恼之所坏
  此等甚可愍　　我应度脱之
  没深烦恼水　　四流所漂转
  具受于三界　　无量诸苦毒
  住五阴深樔　　生我我所心
  我为度此苦　　当勤修行道
  舍无上佛慧　　生于下劣心
  令住佛大智　　发无量精进
  菩萨住此地　　集无量功德
  得值遇诸佛　　承事而供养
  以是因缘故　　善根转明净
  犹如好真金　　炼之以火力
  佛子住此地　　多作转轮王
  令诸众生等　　住于十善道
  从初始发心　　修集诸福德
  愿以救世间　　令得佛十力
  若欲舍王位　　出家行学道
  勤心行精进　　得入千三昧
  得见于千佛　　供养听受法
  菩萨住此地　　能示如是事
  若以其愿力　　示诸神通事
  度脱于众生　　过此数无量
  常为诸世间　　勤求好事者
  具足解说此　　第二地已竟

    第三地

  诸菩萨闻是　　不可思议行
  心皆大欢喜　　恭敬无有量
  即时虚空中　　雨众名华香
  如云而散下　　供养金刚藏
  咸赞言善哉　　善哉金刚藏
  善说诸大人　　护持净戒行
  于一切众生　　深有哀愍心
  敷演解说是　　二地之行相
  菩萨微妙行　　真实无有异
  是诸菩萨等　　清净之行足
  为一切众生　　常求好事者
  已为具演说　　第二离垢地
  天人恭敬者　　愿说第三地
  善示智所作　　菩萨之所行
  愿说诸大人　　所行布施德
  持戒及忍辱　　精进行禅定
  智慧巧方便　　并及慈悲心
  云何行是法　　净于诸佛行
  解脱月菩萨　　请金刚藏言
  菩萨入三地　　当以何等心

金刚藏菩萨语解脱月菩萨言。佛子。诸菩萨摩诃萨净第二地已。欲得第三地。当以十种深心。何等为十。一净心。二猛利心。三厌心。四离欲心。五不退心。六坚心。七明盛心。八无足心。九胜心。十大心。菩萨以是十心。得入第三地。菩萨住明地。能观一切有为法如实相。所谓无常。苦。无我。不净。不久败坏。不可信相。不生不灭。不从前际来。不去至后际。现在不住。菩萨如是观一切有为法真实相。知诸法无作无起。无来无去。而诸众生。忧悲苦恼。憎爱所系。无有停积。无定生处。但为贪恚痴火所然。增长后世苦恼大聚。无有实性。犹如幻化。见如是已。于一切有为法。转复厌离。趣佛智慧。是菩萨知如来智慧不可思议。不可称量。有大势力。无能胜者。无有杂相。无有衰恼。能至无畏安隐大城。能救无量苦恼众生。如是见知佛智无量。见有为法无量苦恼。于一切众生。转生殊胜十心。何等为十。众生可愍。孤独无救。贫无依止。三毒之火炽然不息。闭在三有牢固之狱。常住烦恼诸恶刺林。无正观力。于善法中。欲乐心薄。失佛妙法。而常随顺生死水流。怖畏涅槃。是菩萨见诸众生如是衰恼。发大精进。是众生等我应救。我应解。应令清净。应令得脱。应着善处。应令安住。应令欢喜。应令知所宜。应令得度。应使灭苦。菩萨如是厌离一切有为法。深念众生。见一切智无量利益。即时欲具佛智慧救度众生。勤行菩萨道。作是思惟。此诸众生。堕在大苦诸烦恼中。以何方便。而拔济之。使得永住毕竟之乐。即时知住无碍解脱智慧中者。乃可得此。是无碍解脱智慧不离通达。诸法如实智。无行行慧。如是慧明从何而得。当知不离多闻决定智慧。复作是念。一切佛法以何为本。不离闻法为本。菩萨如是知已。一切求法。转加精勤。日夜听受。无有厌足。喜法。爱法。依法。顺法。满法。辩法。究竟法。归法。救法。随顺行法。菩萨如是方便求法。所有珍宝无所遗惜。于此物中。不生难想。但于说法者。生难遭想。为求法故。于内外物。无不能舍。国土人民。摩尼七宝。象马辇舆。众宝璎珞。严身之具。妻妾男女。肢节手足。举身施与。无所爱惜。又为求法故。于说法者。尽心恭敬。供养给侍。破除憍慢。我慢大慢。诸恶苦恼。悉能忍受。深求法故。若得一句未曾闻法。胜得三千大千世界满中珍宝。得闻一偈。胜得转轮圣王。释提桓因。梵天王处。无量劫住。是菩萨若有人来作如是言。我有佛所说法一句。能净菩萨道。汝今若能入大火坑。受大苦者。当以相与。是菩萨作是念。我受一句法故。设令三千大千世界大火满中。尚从梵天而自投下。何况小火。我尽受一切诸地狱苦。犹应求法。何况人中诸小苦恼。为求法故。发如是心。又如所闻法。心常喜乐。悉能正观。是菩萨闻诸法已。降伏其心。于空闲处。心作是念。如说行者。乃得佛法。但以口言。无有是处。菩萨如是则离欲恶。不善法。有觉有观。离生喜乐。入初禅。灭觉观。内清净。心一处无觉无观。定生喜乐。入二禅。离喜行舍。成就念慧。身受乐。诸贤圣能说能舍。常念受乐。入三禅。断弃苦乐。忧喜已灭。不苦不乐。行舍念净。入四禅。是菩萨过一切色相。灭一切有对相。不念一切别异相。故知无边虚空。即入虚空无色定处。过一切虚空相。知无边识。即入识无色定处。过一切识相。知无所有。即入无所有无色定处。过一切无所有处。知非有想非无想安隐。即入非有想非无想无色定处。顺诸法行。而不乐着

是菩萨以慈心广大无量。无嗔恨。无恼害。以信解力。遍满十方。悲喜舍心亦复如是。是菩萨有神通力。能动大地。一身为多身。多身为一身。现没还出。石壁皆过。如行虚空。于虚空中。跏趺而去。犹如飞鸟。履水如地。入地如水。身出烟焰。如大火聚。日月威德。而能以手扪摸摩之。身力自在。乃至梵世。是菩萨天耳清净。过天人耳。悉闻人天音声远近。是菩萨以他心智。如实知他心欲心。如实知欲心。离欲心。如实知离欲心。嗔心。离嗔心。痴心。离痴心。垢心。离垢心。小心。大心。广心。狭心。乱心。无乱心。定心。不定心。缚心。解心。有上心。无上心。如实知有上心。无上心。是菩萨念知宿命诸所生处。一世二世。乃至百千万亿那由他世。一劫二劫。乃至百千万亿那由他劫。其中诸劫。无量成坏。于诸劫中。所经因缘。悉能念知。我生彼处如是种族。如是姓名。如是饮食。如是苦乐。如是久住。我于彼死。生于此间。于此间死。生于彼间。如是种种。悉能念知是。菩萨天眼清净。过天人眼。见诸众生死此生彼。形色好恶。贫贱富贵。趣善恶道随业受报。皆如实知。所谓是诸众生。成就身恶业。口恶业。意恶业。拒逆贤圣。受邪见教。起罪业因缘故。身坏命终。堕于恶道。是诸众生。成就身善业。口善业。意善业。不逆贤圣。信受正见。行善业因缘故。身坏命终。生于善处。是菩萨于诸禅定解脱三昧。能入能出。而不随生。有助菩提法处。以愿力故。能生其中。是菩萨住于明地。见数百千万亿那由他诸佛世尊。恭敬供养。尊重赞叹。衣服饮食。卧具医药。亲近诸佛。听受经法。如说修行。是菩萨观诸法不生不灭。众缘而有。于百千亿劫所集欲缚。有缚。无明缚。皆悉微薄。不复积集。不积集故。断于邪贪。邪嗔。邪痴。譬如真金。巧师炼治。转更精好。光明倍胜。菩萨亦如是。住在明地。不集三缚故。断于邪贪。邪嗔。邪痴。一切善根。转增明净。是菩萨忍辱心。美妙心。不坏心。不动心。不浊心。不高下心。一切所作不望报心。他少有所作当生报心。不谄曲心。不染乱心。转胜明净。菩萨尔时于四摄法。爱语利益偏多。十波罗蜜。忍辱波罗蜜。精进波罗蜜偏胜。余助菩提法。皆转明净。诸佛子。是名略说菩萨第三明地。菩萨住是地中。多作释提桓因。智慧猛利。能以方便。转诸众生。令离淫欲。所作善业。布施爱语。利益同事。皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心。我当于一切众生。为首为胜。乃至于一切众生。为依止者。是菩萨若欲勤行精进。于须臾间。能得十万三昧。乃至能示十万菩萨。以为眷属。若以愿力神通自在。过于此数。若干百千万亿那由他劫不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  菩萨深信心　　能得第三地
  清净猛利心　　厌离欲不退
  坚堪受无厌　　胜大悉具足
  以如是等心　　得入于三地
  智者住明地　　观有为作法
  不净无常苦　　无我坏败相
  无有牢固性　　不久念念灭
  如是思惟知　　无有来去相
  见诸有为法　　如病如痈疮
  爱心所缠缚　　生诸忧悲苦
  但为贪恚痴　　猛火所焚烧
  从无始世来　　炽然常不息
  即时于一切　　三界生厌离
  恶贱有为法　　心无所贪着
  但求诸佛智　　无量无边限
  甚深难思议　　清净无诸苦
  如是见佛智　　无诸苦恼已
  哀愍诸众生　　贫穷无福慧
  三毒火常然　　无有救护者
  堕在地狱中　　无量苦所切
  放逸凡夫人　　没诸烦恼海
  盲冥无所见　　失诸佛法宝
  常随生死流　　无怖空怖畏
  我于是众生　　当勤度脱之
  精进求智慧　　为作饶益者
  思惟何方便　　可以得救护
  唯有诸如来　　深妙无碍智
  此智何为因　　无行行慧生
  思惟是智慧　　从于多闻起
  如是筹量已　　勤求多闻法
  日夜常精进　　听受无厌倦
  读诵爱乐法　　唯法以为贵
  为欲求法故　　以诸珍宝等
  所亲爱妻子　　随意诸眷属
  国土及城邑　　资生诸宝物
  欢喜而施与　　心无所恋惜
  头目耳鼻舌　　牙齿及手足
  肢节身血肉　　心肝及髓脑
  以此等施人　　犹不以为难
  若得闻正法　　是为甚希有
  假令有一人　　语此菩萨言
  汝今若能入　　是大猛火聚
  然后当与汝　　诸佛所说法
  闻已即欢喜　　自投无有疑
  设使三千界　　大火满其中
  须弥梵世下　　不足以为难
  若为求一句　　诸佛所说法
  救诸苦恼者　　得之为甚难
  从初始发心　　乃至成佛道
  我于其中间　　尽此诸劫数
  为欲求法故　　备受阿鼻苦
  何况于人间　　小小诸苦恼
  以听法因缘　　能得正忆念
  正忆念因缘　　能生诸禅定
  深妙等三昧　　及五神通事
  次第皆能起　　自在不随生
  菩萨住是地　　能以决定心
  多供养诸佛　　听受所说法
  断邪爱恚痴　　诸缚悉微薄
  犹如成炼金　　调和得其所
  菩萨住是地　　福德藏充满
  多作忉利王　　自在化淫欲
  爱佛功德故　　化导无量众
  悉能令得住　　无上佛道中
  菩萨住是地　　能以柔软心
  勤行于精进　　得百千三昧
  见百千诸佛　　相好庄严身
  其心转猛利　　愿力者殊胜
  常为诸众生　　勤求好事者
  分别解说此　　第三明地竟

    第四地

  诸佛子闻说　　如是地行义
  深妙无有量　　心皆大欢喜
  散众名华香　　供养于如来
  地及大海水　　悉皆大震动
  天诸采女等　　于上虚空中
  同以微妙音　　歌颂此上法
  他化自在王　　闻已大欢喜
  雨摩尼珠宝　　以散于佛上
  踊跃称赞言　　善哉佛出世
  功德藏流布　　利益于我等
  我今闻说此　　菩萨地行义
  是事百千劫　　难闻而得闻
  愿更说后地　　利益诸天人
  佥皆喜欲闻　　得地诸行义
  解脱月菩萨　　重请金刚藏
  愿为诸菩萨　　说至四地行

金刚藏菩萨语解脱月菩萨言。佛子。诸菩萨摩诃萨净三地已。欲得第四地。当以十法明门。何等为十。一观察众生界。二观察法界。三观察世界。四观察虚空界。五观察识界。六观察欲界。七观察色界。八观察无色界。九观察胜信解界。十观察大心界。菩萨以此十法明门。得入第四地。菩萨住焰地。即于如来家。转有势力。得内法故。有十种智。何等为十。一心不退转。二于三宝中。得不坏心。清净毕竟。三修习观生灭。四修习诸法本来不生。五常修习世间成坏。六修习业因缘故有生七修习分别生死涅槃门差别。八修习众生业差别。九修习前际后际差别。十修习现在常灭不住行是十智心。则生佛家。转得势力。佛子。菩萨摩诃萨住是第四地。观内身循身观。精勤一心。除世间贪忧。观外身循身观。精勤一心。除世间贪忧。观内外身循身观精勤一心。除世间贪忧。观内受外受内外受。内心外心内外心。内法外法内外法循法观。精勤一心。除世间贪忧。是菩萨未生恶不善法。为不生故。勤精进发心正断。已生诸恶不善法为断故。勤精进发心正断。未生诸善法为生故。勤精进发心正行。已生诸善法为住不失修满增广故。勤精进发心正行。是菩萨修行四如意足。欲定断行成就。修如意足。依止厌依止离。依止灭。回向涅槃。精进定。心定。慧定。断行成就。修如意足。依止厌离灭。回向涅槃。是菩萨修行信根。精进根。念根。定根。慧根。依止厌离灭。回向涅槃。是菩萨修行信力。精进力。念力。定力。慧力。依止厌离灭。回向涅槃。是菩萨修行念觉分。择法觉分。精进觉分。喜觉分。猗觉分。定觉分。舍觉分。依止厌离灭。回向涅槃。是菩萨修行正见。正思惟。正语。正业。正命。正精进。正念。正定。依止厌离灭。回向涅槃。是菩萨以不舍众生心故。行以本愿助故。大悲为首故。大慈合行故。为摄一切智。为庄严佛国。为具佛诸力。无畏。不共法。三十二相。八十种好。为具足音声。为随顺佛深解脱。为思惟大智慧方便故行

诸佛子。菩萨住焰地。所有身见等。着我。着众生。着人。寿者。知者。见者。着五阴。十二入。十八界。所起屈伸。卷舒出没。推求心所行爱着。宝重所见。为归为洲。皆悉断灭。是菩萨转倍精进。智慧方便所生助道法。随所修行。心转柔和。堪任有用。无有疲倦。转求上法。增益智慧。救一切世间。随顺诸师。恭敬受教。如所说行。是菩萨尔时。知恩知报恩。心转和善。同止安乐。直心软心。无有邪曲。行正定行。无有憍慢。随顺教诲。得说者意。如是具足善心。软心。寂灭心。忍辱心。净地诸法思惟修行。是菩萨尔时成不转精进。不舍精进。不染精进。不坏精进。不厌倦精进。广大精进。无边精进猛利精进。无等等精进。救一切众生精进。是菩萨修习如是精进。直心清净。不失深心信解明利。善根增长。远离世间。垢浊不信。皆已灭尽。无疑无悔。现前具足于一切佛大信解事。不厌不舍。自然习乐无量之心。常现在前。菩萨住第四焰地。能见数百千万亿那由他诸佛世尊。恭敬供养。尊重赞叹。衣服饮食。卧具医药。亲近诸佛。一心听法。能信奉持。多于佛所。出家修道。是菩萨乐心。深心。清净信解平等。转更明了。住寿多劫。若干百千万亿那由他劫。善根转胜譬如上真金。为庄严具。余金不及。如是菩萨住此焰地善根转增。下地菩萨所不能及。譬如摩尼珠。光明清净能照四方。余宝不及。水雨浇渍。光明不灭。菩萨住焰地。下地菩萨所不能及。一切诸魔。及诸烦恼。皆不能坏。诸佛子。是名略说菩萨第四焰地。菩萨住是地中。多作须夜摩天王。教化众生。破于我心。所作善业。布施爱语。利益同事皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心我当于一切众生。为首为胜。乃至于一切众生。为依止者。是菩萨若欲勤行精进。须臾之间。得百亿三昧。乃至示现百亿菩萨。以为眷属。若以愿力自在示现。过于此数。若干百千万亿那由他劫。不可计知。尔时金刚藏菩萨。欲重明此义。以偈颂曰

  诸菩萨具足　　修治明地已
  观察诸众生　　法及于世界
  虚空识欲色　　无色胜信解
  大心清净故　　得入第四地
  即于如来家　　增长得势力
  不退于佛道　　三宝不坏信
  观诸法生灭　　一切本来空
  知世间成败　　从业而有生
  众生业差别　　生死涅槃异
  观法先后际　　常灭不住相
  诸大菩萨等　　得如是法已
  哀愍诸众生　　习身受心法
  内外四念处　　依止于厌离
  亦依止寂灭　　回向于涅槃
  除灭恶法故　　善法得增长
  习行四正法　　修四如意足
  习行于五根　　及以修五力
  修习七觉意　　行于八圣道
  修习如是法　　皆为众生故
  本愿之所助　　慈悲心为首
  为摄一切智　　庄严诸佛土
  成就十种力　　无畏不共法
  诸音声言说　　甚深妙道法
  及无碍解脱　　大智慧方便
  从身见为首　　六十二见等
  众生及我人　　寿命知见者
  于诸阴界入　　之所贪着处
  得是第四地　　皆悉已灭离
  断诸烦恼业　　其心转明净
  诸所作善业　　皆为救世间
  菩萨柔软心　　常不为放逸
  堪用正直意　　求利于众生
  如此所求事　　皆为无上道
  大智慧职位　　利益世间故
  深心敬养师　　如说乐修行
  知恩报恩者　　易化无嗔恨
  无有邪曲心　　柔和同止乐
  修习如是法　　精进不退转
  菩萨住是地　　不失深直心
  净心与信解　　增长诸善根
  世间诸垢浊　　不信疑悔事
  如是等诸法　　皆悉得除灭
  诸菩萨住是　　第四焰地中
  得值无量佛　　咨受所说法
  于是诸佛所　　出家难沮坏
  如真金庄严　　余金所不及
  菩萨住是地　　诸功德深心
  智慧及方便　　所行清净道
  乃至千亿魔　　皆所不能坏
  如真妙明珠　　不为水雨败
  菩萨住是地　　天人所供养
  多作夜摩王　　能转诸邪见
  所作诸善业　　皆为佛智慧
  其心常坚固　　不可得动转
  若勤行精进　　得百亿三昧
  能见百亿佛　　愿力则过是
  如是第四地　　清净名为焰
  无量福慧者　　今已解说竟

大方广佛华严经卷第二十四大方广佛华严经卷第二十五

        东晋天竺三藏佛驮跋陀罗译

    十地品第二十二之三

  诸菩萨闻是　　第四地行法
  心皆怀喜悦　　踊跃无有量
  雨天众宝华　　雰雰如雪下
  咸赞言善哉　　金刚藏大士
  他化自在王　　与诸眷属等
  于上虚空中　　心皆大欢喜
  放众妙光明　　作天诸妓乐
  歌叹佛功德　　及诸菩萨众
  天诸采女等　　各以清妙音
  同声称赞佛　　而说如是言
  世尊久远来　　勤苦所求愿
  无上正真道　　于今始乃得
  利益天人者　　久乃得奉见
  释迦牟尼佛　　今至于天宫
  从久远已来　　大海相始动
  久远无量世　　今乃放妙光
  众生从久远　　今始得安乐
  久乃方得闻　　大慈悲德音
  度诸功德岸　　久远今乃值
  圣王能悉破　　憍慢我心等
  无比可恭敬　　而今得供养
  能开诸天道　　使得一切智
  世尊甚清净　　无量如虚空
  不染于世法　　如莲华在水
  处世最高大　　犹如巨海中
  须弥大山王　　是故欢喜礼
  如是诸天女　　各以众妙音
  敬心歌颂已　　默然而观佛
  解脱月菩萨　　请金刚藏言
  愿说得五地　　行相之因缘

金刚藏菩萨语解脱月菩萨言。佛子。菩萨摩诃萨已具足第四地。欲得第五地。当以十平等心。何等为十。一过去佛法平等。二未来佛法平等。三现在佛法平等。四戒净平等。五心净平等。六除见疑悔净平等。七道非道净平等。八行知见净平等。九诸菩提分法转胜净平等。十化众生净平等。菩萨以是十平等心。得入第五地。菩萨住难胜地。善修菩提法故。深心清净故。求转胜道故。则能得佛。是菩萨得大愿力故。慈悲心不舍一切故。得念慧道力故。修习福慧不舍故。出生方便故。欲得转胜道上地明观法故。受诸佛神力所护故。生定不退心故。如实知是苦圣谛。是苦集谛。是苦灭谛。是苦灭道谛。是菩萨善知世谛。善知第一义谛。善知相谛。善知差别谛。善知说谛。善知事谛。善知生起谛。善知尽无生谛。善知入道谛。善知一切菩萨次第成就诸地起如来智谛。菩萨随众生意。令欢喜故。知世谛究竟一乘故。知第一义谛。分别诸法自相故。知相谛诸法各异故知差别谛。分别阴界入故。知说谛以身心苦恼故。知苦谛诸趣生相续故。知集谛毕竟灭一切恼故。知灭谛至不二法故。知道谛以一切种智。知一切法。次第成一切菩萨地故。知如来智谛以信解力故。知非得无尽谛智。菩萨如是以此诸谛智。如实知一切有为法。虚伪诳诈。假住须臾。诳惑凡人。菩萨尔时于众生中。大悲转胜。生大慈光明。得如是智慧力。不舍一切众生。常求佛智慧。如实观一切有为法先际后际。知众生从先际无明有爱故生。流转生死。于五阴归处。不能动发。增苦恼聚。是中无我。无我所。无众生。无人。无知者。无寿命者。后际亦如是。如是无所有。而愚痴贪着。不知究竟有出无出。又作是念。凡夫众生甚为可怪。无明痴故。有无量身。已灭今灭当灭。如是生死。不能于身生厌离想转更增长五道苦轮。生死水漂不能得返。归五阴舍不能舍离。不知不畏四大毒蛇。不能拔出憍慢见箭。不能灭除贪恚痴火。不能破坏无明愚闇。不能干竭爱着大海。不求十力大圣导师。常随魔意于生死城。常为诸恶觉观所转。如是苦恼。孤穷众生无有救者。无有舍者。无有究竟道者。唯我一人独无等侣。修习福慧。以是资粮。令此众生。住毕竟净。乃至得一切法中无碍智力。如是思惟。从正观生于智力发愿。所作一切善根。皆为度众生故。为一切众生求安乐故。为利益一切众生故。为解脱一切众生故。为一切众生无苦恼故。为一切众生无粗恶故。为一切众生心清净故。为调伏一切众生故。为灭一切众生诸忧恼苦。满其愿故

是菩萨住难胜地。不忘诸法故。名为念者。决定智慧故。名为智者。知经书意次第故。名为有道者。自护护彼故。名为有惭愧者。不舍持戒故。名为坚心者。善思惟是处非处故。名为觉者。不随他故。名为随智者。善分别诸法章句义故。名为随慧者。善修禅定故。名为得神通者。随世间法行故。名为方便者。善集福德资粮故。名为无厌足者。常求智慧因缘故。名为不舍者。集大慈大悲因缘故。名为无疲倦者。常正忆念故。名为远离破戒者。深心求佛十力。四无所畏。十八不共法故。名为常念佛法者。常令众生离恶修善故。名为庄严佛国者。种诸福德。庄严三十二相八十种好故。名为行种种善业者。求庄严佛身口意故。名为常行精进者。供养一切说法菩萨故。名为乐大恭敬者。一切菩萨方便中心无碍故。名为心无碍者。常乐教化众生故。名为昼夜远离余心者。菩萨如是行时。以布施教化众生。爱语利益同事。亦教化众生。又以色身示现。教化众生。亦以说法。教化众生。亦示诸菩萨行事。教化众生。亦示诸佛大事。教化众生。亦示生死过恶。教化众生。亦示诸佛智慧利益教化众生。菩萨如是修习。以大神力种种因缘方便道。教化众生。是菩萨虽种种因缘方便。心常在佛。不失善根。又复常求转胜利益众生法。是菩萨利益众生故。知世所有经书技艺。文章算数。金石诸性。治病医方。干消癞病。鬼着蛊毒等。妓乐歌舞。戏笑欢娱。国土城郭。聚落室宅。园林池观。华果药草。金银琉璃。珊瑚琥珀。砗磲码瑙。示诸宝聚。日月五星。二十八宿。占相吉凶。地动梦怪。身中诸相。布施持戒。摄伏其心。禅定神通。四无量心。四无色定。诸不恼乱。安众生事。哀众生故。出如此法。令入诸佛无上之法。菩萨住难胜地。值数百千万亿佛。恭敬供养。尊重赞叹。衣服饮食。卧具医药。亲近听法。闻法出家。而为法师。说法利益。得转胜多闻三昧。乃至过百千万亿劫。而不忘失。一切福德善根。转胜明净。譬如成炼真金。砗磲磨莹。其光转胜。菩萨住是地中。方便智慧力故。功德善根。转净明胜。下地不及。又如日月星宿。诸天宫殿。风持令去。不失法度。如是菩萨住难胜地。以方便思惟故。福德善根转倍明净。而不取证。亦不疾成于无上道。佛子。是名略说菩萨难胜地。菩萨住是地中。多作兜率陀天王。诸根猛利。悉能摧伏一切外道。有所作业。布施爱语。利益同事。皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心。我当于一切众生。为首为胜。乃至于一切众生。为依止者。佛子。是菩萨若欲勤行精进。须臾之间。得千亿三昧。乃至能示千亿菩萨。以为眷属。若以愿力神通自在。复过是数。若干百千万亿劫不可计知。时金刚藏菩萨欲重明此义。以偈颂曰

  诸菩萨具足　　四地行法已
  思惟三世佛　　戒心除疑悔
  道非道知见　　菩提化众生
  如是平等观　　得入第五地
  四念处为弓　　信五根为箭
  四正勤为马　　四如意为车
  五力以为铠　　破诸烦恼贼
  勇健不退转　　直入第五地
  惭愧无垢衣　　净戒以为香
  七觉为华鬘　　禅定为涂香
  智慧与方便　　种种念庄严
  如是则得入　　陀罗尼园林
  四如意为足　　正念为头项
  慈悲明净眼　　利智慧为牙
  以空无我吼　　破诸烦恼贼
  如是人师子　　能入第五地
  是菩萨已得　　住于第五地
  转修胜净法　　皆为佛道故
  常行慈悲心　　未曾有厌倦
  常为修习此　　第五地行法
  深集二资粮　　福德及智慧
  种种方便力　　上地明观法
  常为佛所护　　得成于念慧
  次第能善观　　如实知诸谛
  苦集灭止道　　世相第一事
  说生起差别　　无生如来智
  如是观诸谛　　心微妙清净
  虽未能逮得　　无障碍解脱
  以能有智慧　　及与信力故
  得胜于一切　　世间诸智慧
  如是观诸谛　　悉知有为法
  虚伪不真实　　无一坚固相
  能得于诸佛　　慈悲光明分
  为诸众生故　　专心求佛慧
  知有为先后　　众生甚可愍
  堕在无明闇　　爱因缘所系
  是菩萨能灭　　世间之苦恼
  知法无寿者　　犹如草木等
  众生常以二　　烦恼因缘故
  从于先世来　　后世亦如是
  相续不断绝　　不能尽苦边
  于此生愍伤　　我当度脱之
  不能出五阴　　不畏四大害
  不拔诸邪箭　　不灭三毒火
  不除无明闇　　堕在大爱海
  无有智慧眼　　离大导师故
  知如是事已　　转加勤精进
  有所作起业　　皆为度众生
  常住正念慧　　有道有惭愧
  坚心觉随智　　转更令增益
  修福慧无厌　　持戒不羸弱
  求多闻无倦　　正修净佛土
  种相好音声　　因缘无厌足
  所作诸善业　　皆为利众生
  为利世间故　　造立经书等
  金石性医方　　歌舞戏笑事
  堂阁及园林　　衣服诸饮食
  示种种宝聚　　令众得欢喜
  占日月五星　　及二十八宿
  地动吉凶相　　梦书诸怪事
  布施净戒等　　离欲修禅定
  四无量神通　　安乐世间故
  大智慧菩萨　　得此难胜地
  供养万亿佛　　从佛而听法
  所修诸善根　　皆悉得明净
  犹如砗磲宝　　莹磨于真金
  譬如宝宫殿　　风持不失法
  世法所不染　　如莲华在水
  菩萨住是地　　多作兜率王
  诸根转猛利　　破诸外道见
  所作诸善业　　皆为佛智慧
  得佛力无畏　　能度诸众生
  是菩萨勤修　　转胜精进力
  即能得千亿　　深妙诸三昧
  供养千亿佛　　动千亿世界
  随其所愿力　　过是数无量
  如是第五地　　种种诸方便
  上智慧大人　　如法解说竟

    第六地

  诸菩萨闻说　　上地之行相
  在于虚空中　　雨众妙珍宝
  放清净光明　　供养于世尊
  咸赞言善哉　　善哉金刚藏
  无量亿诸天　　心皆大欢喜
  于上虚空中　　雨种种珍宝
  光明相绮错　　微妙甚可乐
  香华诸璎珞　　幡盖散佛上
  他化自在王　　与诸眷属等
  雨众妙宝物　　雰雰如雪下
  歌颂供养佛　　称叹金刚藏
  咸赞言善哉　　快说诸地行
  千万亿天女　　于上虚空中
  作天众妓乐　　歌叹佛功德
  咸作如是言　　如来之所说
  微妙无有量　　能灭诸烦恼
  诸法本性空　　无有毫末相
  空无有分别　　同若如虚空
  无有去住相　　亦无有戏论
  本来常清净　　如如无分别
  若人能通达　　一切诸法性
  于有于无中　　其心不动摇
  但以大悲心　　为度诸众生
  是名诸佛子　　从佛口法生
  常行于布施　　利益诸众生
  本来虽清净　　持戒而坚心
  虽本心无伤　　而行于忍辱
  虽知法性离　　而行于精进
  虽先灭烦恼　　而入于诸禅
  虽先解法空　　而分别诸法
  寂灭智虽多　　而求利世间
  能灭诸恶者　　名之为大人
  如是诸天女　　百千种妙音
  称赞歌颂已　　默然而观佛
  解脱月菩萨　　请金刚藏言
  当以何行相　　得成第六地

金刚藏菩萨言。佛子。菩萨摩诃萨已具足五地。欲入六地。当以十平等法。何等为十。一以无性故。一切法平等。二以无相故。一切法平等。三以无生故。一切法平等。四以无成故。一切法平等。五以本来清净故。一切法平等。六以无戏论故。一切法平等。七以不取不舍故。一切法平等。八以离故。一切法平等。九以幻梦影响水中月故。一切法平等。十以有无不二故。一切法平等。菩萨以是十平等法。得入第六地。菩萨如是观一切法性。能忍随顺得第六地。无生法忍虽未现前。心已成就明利顺忍。是菩萨观一切法如是相。大悲为首。增长大悲故。观世间生灭相。作是念。世间所有受身生处。皆以贪着我故。若离着我。则无生处。一切凡夫。常随邪念。行邪妄道。愚痴所盲。贪着于我。习起三行。罪行福行不动行。以是行故。起有漏心种子。有漏有取心故。起生死身。所谓业为地。识为种子。无明覆蔽。爱水为润。我心溉灌种种诸见。令得增长。生名色芽。因名色故生诸根。诸根合故有触。从触生受。乐受故生爱。爱增长故有取。取因缘故有有。于有起五阴身名为生。五阴变名为老。五阴灭名为死。老死因缘。有忧悲热恼。众苦聚集。是十二因缘。无有集者。无有散者。缘合则有。缘散则无。菩萨如是。于六地中。随顺观十二因缘。又作是念。不如实知第一义故有无明。无明起业是名行。依行有初识。与识共生有四取阴。依止取阴有名色。名色成就有六入。根尘合故有触。触因缘生受。贪乐受名为爱。爱增长名为取。从取起业名为有。业报五阴名为生。五阴变名为老。五阴坏名为死。死别离时。贪着心热名为悲。发声啼哭。五识为苦。意识为忧。忧苦转多名为恼。如是但生大苦积聚。是十二因缘。无我无我所。无作者。无使作者。若有作者。则有作事。若无作者。则无作事。第一义中。无作者。无作事。又作是念。三界虚妄。但是心作。十二缘分。是皆依心。所以者何。随事生欲心。是心即是识。事是行。行诳心故名无明。识所依处名名色。名色增长名六入。三事和合有触。触共生名受。贪着所受名为爱。爱不舍名为取。彼和合故名为有。有所起名为生。生变名为老。老坏名为死。又无明有二种作。一者缘中痴。二者为行作因。行亦有二种作。一者生未来世果报。二者与识作因。识亦有二种作。一者能受生。二者与名色作因。名色亦有二种作。一者令识起相续。二者与六入作因。六入亦有二种作。一者能缘六尘。二者能与触作因。触亦有二种作。一者能触所缘。二者能与受作因。受亦有二种作。一者觉憎爱事。二者与爱作因。爱亦有二种作。一者于可染中生贪心。二者与取作因。取亦有二种作。一者能增长烦恼。二者与有作因。有亦有二种作。一者能于余道中生。二者与生作因。生亦有二种作。一者能起五阴。二者与老作因。老亦有二种作。一者令诸根熟。二者与死作因。死亦有二种作。一者坏五阴身。二者以不见知故。而令相续不绝。又无明缘诸行者。无明令行不断。助成行故。行缘识者。令识不断助成识故。识缘名色者。令名色不断助成名色故。乃至生缘老死忧悲苦恼者。令死不断助成死故。无明灭故则诸行灭。乃至生灭故老死忧悲苦恼灭。因灭故果亦灭。又无明爱取是三分。不断烦恼道。行有二分。不断业道。余因缘分。不断苦道。先后际相续故。是三道不断。是三道离我我所而有生灭。又无明及行是过去事。识名色六入触受是现在事。爱取有生老死是未来事。于是有三世转。无明灭故诸行灭。名为断。三世相续说。又十二因缘说名三苦。无明行识名色六入名为行苦。触受名为苦苦。爱取有生老死忧悲苦恼名为坏苦。无明灭故诸行灭。乃至生灭故老死灭。名为断三苦相续说。又因无明诸行生。无明灭诸行灭。以诸行性空故。余亦如是。无明因缘诸行生。以生缚说。无明灭故诸行灭。以灭缚说。余亦如是。又无明因缘诸行生。是随顺无所有观说。无明灭诸行灭。是随顺尽观说。余亦如是。如是逆顺十种观十二因缘法。所谓因缘分次第。心所摄。自助成法。不相舍离。随三道行。分别先后际。三苦差别。从因缘起。生灭缚。无所有尽观

是菩萨随十二因缘。无我无人。无众生。无寿命者。离作者使作者。无主属众因缘。如是观时。空解脱门现在前。灭此事余不相续故。无相解脱门现在前。知此二种更不乐有唯大悲心教化众生。无愿解脱门现在前。菩萨修行三解脱门。离彼我相。离作者受者相。离有无相。悲心转增。以悲心故。勤行精进。未满菩提法欲令满足。菩萨作是念。有为法和合故增。离散则减。缘具故增。不具则减。我知有为法过故。不应和合。具诸因缘。化众生故。亦不毕竟灭有为法。菩萨如是知有为法无性。离坚固相。无生无灭。与大慈悲和合。不舍众生。即得无障碍般若波罗蜜光明现在前。得是智慧具足修集阿耨多罗三藐三菩提因缘。而不住有为法。观有为法性寂灭相。亦不住其中。欲具足无上菩提法故。菩萨住现前地。得胜空三昧。性空三昧。第一义空三昧。究竟空三昧。大空三昧。合空三昧。生空三昧。如实离虚妄空三昧。略空三昧。离分别不分别空三昧。如是等万空三昧门现在前。无相无愿三昧亦如是。是菩萨住现前地。深心。决定心。真心。甚深心。不转心。不舍心。广心。无边心。乐智心。慧方便和合心。如是等心。转胜增长。随顺阿耨多罗三藐三菩提。一切论师不能倾动。入于智地。转声闻辟支佛地。决定向佛智。一切众魔。及诸烦恼。所不能坏。安住菩萨智慧明中。修空无相无愿解脱门。专以智慧方便行助菩提法。是菩萨住现前地。于般若波罗蜜偏胜。得明上顺忍。以顺是法无有违逆。菩萨住现前地。得见数百千万亿佛。恭敬供养。尊重赞叹。衣服饮食。卧具医药。亲近诸佛。于诸佛所。听受正法。如说修行。令佛欢喜。是人转胜。知佛法藏。乃至无量百千万亿劫一切善根。转妙明净。譬如真金。以琉璃磨莹光色转胜。菩萨住现前地。以慧方便故。一切善根。转胜明净。余地不及。譬如月明。能令众生。身得清凉。四种风吹不能遏绝。菩萨住现前地。善根转胜。能灭众生烦恼之火。四种恶魔所不能坏。诸佛子。是名略说菩萨现前地。菩萨住是地。多作善化自在天王。智慧猛利能破一切增上慢者。声闻问难不能穷尽。有所施作。布施爱语利益同事。皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心。我当于一切众生。为首为胜。乃至于一切众生为依止者。是菩萨若欲勤行精进。于须臾间。得百千亿三昧。乃至能示百千亿菩萨。以为眷属。若以愿力。能过是数。若干百千万亿劫。不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  诸菩萨已得　　具足五地行
  知诸法无性　　无相无生灭
  本来常清净　　无有诸戏论
  诸法常离相　　不取亦不舍
  性空犹如幻　　离二无分别
  随顺如是行　　得入第六地
  住明利顺忍　　以智慧力故
  观察于一切　　世间生灭相
  悉知诸世间　　皆从无明有
  无明若灭者　　则无有世间
  观察因缘法　　随顺第一义
  而不坏缘报　　所作及假名
  如实无作者　　亦无有受者
  如是观有为　　如云无实事
  不知真谛义　　名之为无明
  从是则生思　　身口业行果
  从行故有识　　即生于名色
  如是次第起　　生死苦恼聚
  了达于三界　　但从贪心有
  知十二因缘　　在于一心中
  如是则生死　　但从心而起
  心若得灭者　　生死则亦尽
  无明二种作　　缘痴作于业
  乃至于老死　　坏散五阴聚
  从于此事边　　具出于苦恼
  是事若尽者　　苦恼则亦灭
  无明若具足　　相续则不灭
  因缘若尽者　　相续则亦断
  无明及爱取　　即是烦恼道
  行及有是业　　余分则是苦
  痴行为过去　　识名色六入
  触受是现在　　余则未来世
  痴业识名色　　六入名为行
  触受是苦苦　　余分则是坏
  痴从众缘生　　则有于诸缚
  众缘若灭者　　诸缚则亦断
  从因而生果　　因灭则果灭
  如是观诸法　　自性则皆空
  随顺于无明　　则有诸世间
  若能不随顺　　是则断于有
  从是则有是　　是无则无是
  如是十种观　　甚深因缘法
  因缘分次第　　去来及现在
  作不舍一心　　分别有三道
  三种苦差别　　生灭于缚法
  无所有及尽　　能行逆顺观
  菩萨如是入　　十二因缘法
  知空如梦幻　　无作者受者
  如是观因缘　　智者修于空
  事灭不相续　　入于无相行
  知此二虚假　　于中无所愿
  但以大悲心　　愍度于众生
  如是诸大士　　修习解脱门
  悲心爱乐佛　　无量诸功德
  知诸有为法　　皆从和合有
  得万空三昧　　无相无愿定
  智慧转增进　　入于上顺忍
  得于诸菩萨　　无碍智解脱
  如是诸善根　　转胜利明净
  供养无量佛　　诸佛所称赞
  于诸如来所　　出家学佛道
  入佛诸法藏　　善根转增长
  犹以琉璃宝　　莹磨于真金
  光明转清净　　余所不能及
  如月行虚空　　清凉被一切
  四种风所吹　　不能令遏绝
  菩萨智慧光　　灭诸烦恼火
  四魔不能坏　　其义亦如是
  菩萨住是地　　多作善化王
  诸根悉猛利　　能破增上慢
  所作诸善业　　皆悉随智慧
  声闻诸问难　　不能得穷尽
  是佛子若欲　　如是勤精进
  须臾即能得　　百千亿三昧
  见于百千亿　　十方世界佛
  如秋清凉时　　月光明净好
  如是第六地　　深妙难知见
  声闻所不了　　大士略说竟

    第七地

  尔时诸天众　　在于虚空中
  雨香华珍宝　　如云散佛上
  踊跃发妙音　　咸赞言善哉
  善哉金刚藏　　善知第一义
  无量功德聚　　人中之莲华
  说此上妙行　　利益诸世间
  他化自在王　　雨光明宝华
  雰雰而供养　　除忧烦恼者
  诸天及天王　　咸发如是言
  若闻此地义　　则为得大利
  时作百千种　　上妙诸妓乐
  诸天女称赞　　承佛神力故
  诸佛最寂灭　　能转恶为善
  一切诸世间　　皆所共恭敬
  虽出过世间　　而示世间法
  知身同实相　　而示种种身
  虽以诸言音　　演说寂灭法
  而知于语言　　无有音声相
  能过百千土　　上妙供诸佛
  知身佛国土　　离相智自在
  虽教化众生　　而无彼我想
  广集大功德　　不于中起着
  以见取相故　　三毒火然世
  不取一切相　　慈悲起精进
  诸天及天女　　欢喜设供养
  如是赞叹已　　默然而观佛
  解脱月菩萨　　请金刚藏言
  大众皆清净　　愿说七地行

金刚藏菩萨言。佛子。菩萨摩诃萨已具足第六地。欲入第七地。从方便慧起十妙行。何等为十。善修空无相无愿。而以慈悲心处在众生。随诸佛平等法。而不舍供养诸佛。常乐思惟空智门。而广修集福德资粮。远离三界。而庄严三界。毕竟寂灭诸烦恼焰。而为众生起灭贪恚痴烦恼焰法。随顺诸法如幻如梦如水中月不二相。而起分别种种烦恼。及不失业果报。知一切佛国土空如虚空皆是离相。而起净国土行。知一切佛法身无身。而起色身三十二相八十种好。以自庄严。知诸佛音声不可说寂灭相。而随一切。起种种庄严音声。知诸佛于一念中。通达三世。而知种种相。种种时。种种劫。得阿耨多罗三藐三菩提。随众生信解。作如是说。是名从慧方便生十妙行。菩萨摩诃萨修此妙行。如是方便慧现前故。名为入七地。是菩萨住七地。入无量众生界。入无量诸佛教化众生法。入无量世界。入诸佛无量清净国土。入无量诸法差别。入无量诸佛智得无上道。入无量诸劫数。入无量诸佛通达三世。入无量众生欲乐差别。入无量诸佛色身别异。入无量诸佛知众生志行诸根差别。入无量诸佛音声语言令众生欢喜。入无量众生心心所行差别。入无量诸佛随智慧行。入示无量声闻乘信解。入诸佛无量说道因缘令众生信解。入无量辟支佛智慧习成。入诸佛无量甚深智慧所说。入诸菩萨无量所行道。入诸佛无量诸说大乘集成事。令众生得入。菩萨作是念。如是诸佛。有无量无边大势力。如是势力。我应修集。得此势力。不以分别。菩萨如是智慧思惟。修习大方便慧。安住佛智。以不动法故。常起种种度众生道。无有障碍。行住坐卧。皆悉能起度众生法。离诸阴盖。住诸威仪。常不远离如是想念。是菩萨于念念中。具足十波罗蜜。及十地行。何以故。是菩萨。于念念中。大悲为首。修习佛法。一切回向大智慧故。十波罗蜜者。菩萨以求佛道所修善根。与一切众生。是檀波罗蜜。能灭一切烦恼热。是尸波罗蜜。慈悲为首。于一切众生。心无所伤。是羼提波罗蜜。求善根无厌足。是毗梨耶波罗蜜。修道心不散。常向一切智。是禅波罗蜜。忍诸法不生门。是般若波罗蜜能起无量智门。是方便波罗蜜。求转胜智慧。是愿波罗蜜。诸魔外道不能沮坏。是力波罗蜜。于一切法相如实说。是智波罗蜜。如是念念中。具足十波罗蜜。是菩萨具足十波罗蜜时。四摄法。三十七品。三解脱门。一切助阿耨多罗三藐三菩提法。于念念中。皆悉具足。解脱月菩萨问金刚藏菩萨言。佛子。菩萨摩诃萨但七地具足助菩提法。一切诸地亦能具足。金刚藏言。佛子。菩萨摩诃萨于诸地中。皆悉具足助菩提法。远行胜故。于此地说。何以故。诸菩萨摩诃萨。于七地中。功行具足。入智慧神通道故。佛子。菩萨于初地发愿缘一切佛法故。具足助菩提法。二地除心恶垢故。具足助菩提法。三地愿转增长。得法明故。具足助菩提法。四地入道故。具足助菩提法。五地随顺行世间法故。具足助菩提法。六地入甚深法门故。具足助菩提法。此第七地起一切佛法故。具足助菩提法。何以故。菩萨摩诃萨。于此地中。得诸智慧所行道。以是力故。第八地自然得成。佛子。譬如二世界。一定清净。一定垢秽。是二中间。难可得过。欲过此界。当以神通。及大愿力。菩萨亦如是。行于杂道。难可得过。以大愿力。大智慧力。大方便力故。尔乃得过。解脱月言。第七菩萨。为是净行。为是垢行。金刚藏言。从欢喜地菩萨所行皆离罪业。何以故。回向阿耨多罗三藐三菩提故。随地所行清净不名为过。佛子。譬如转轮圣王。乘大宝象。游四天下。见诸众生。贫穷困恼。王虽无苦。而未离人。若舍王身。生于梵世。游千世界。现大威力。尔时乃名离于人身。菩萨亦如是。从初地在诸波罗蜜乘。知一切众生心所行事。及烦恼垢。不为烦恼垢之所污。虽乘善道不名为过。若舍一切所修功行。入于八地。尔时名为乘清净乘。悉知一切诸烦恼垢。不为烦恼垢之所污。乃名为过。诸佛子。菩萨住七地。过贪欲等诸烦恼垢。在此七地。不名有烦恼。不名无烦恼。何以故。一切烦恼不起故。不名有烦恼。贪求如来智慧。未满愿故。不名无烦恼

菩萨住七地。成就深净身口意业。是菩萨所有不善业随烦恼者。悉已舍离。所有善业常修习行。又世间经书。如五地说自然而得。于三千大千世界。最为希有。得为大师。唯除如来八地菩萨。无有众生深心妙行能与等者。是菩萨所有禅定神通解脱三昧。不随禅生。所欲自在。菩萨住远行地。于念念中。具足修集方便慧力。及一切助菩提法。转胜具足。能入菩萨善伏三昧。善思义三昧。进慧三昧。分别义藏三昧。如实分别法三昧。坚固安住三昧。知神通门三昧。净法界三昧。顺佛教三昧。种种义藏三昧。背生死向涅槃三昧。如是具足百万三昧。净治此地。是菩萨得是三昧智慧方便善清净故。深得大悲力故。名为过声闻辟支佛地趣佛智地。是菩萨住是地。无量身业无相行。无量口意业无相行。是菩萨清净行故。得无生法忍。照明诸法。解脱月菩萨言。佛子。菩萨住初地。有无量身业。无量口意业。已能过声闻辟支佛地。金刚藏菩萨言。缘大法故过。非实行力。第七地实行力故。一切声闻辟支佛所不能坏。譬如生在王家。即胜一切。何以故。地尊贵故。其身长大。智慧成就。尔乃真实。胜于一切。菩萨亦如是。初发心时。胜于二乘。以发大愿深心清净故。今住此地。以智慧力。胜于声闻及辟支佛。佛子。菩萨住七地。得甚深远离无行。身口意业转求胜法而不舍离。以转胜心故。虽行实际。而不证实际。解脱月言。佛子。菩萨从何地来。能入寂灭。金刚藏言。从六地来。能入寂灭。今住此地。于念念中。能入寂灭。而不证寂灭。是菩萨成就不可思议身口意业。行实际。而不证实际。譬如有人。乘船入海。善为行法。善知水相。不为水害之所沦没。如是菩萨住此七地。乘诸波罗蜜船。能行实际。而不证实际。菩萨如是以大愿力故。得智慧力故。从禅定智慧生大方便力故。虽深爱涅槃。而现身生死。虽眷属围绕。而心常远离。以愿力故。受生三界。不为世法之所污染。心常善寂。以方便力故。而还炽然。随行佛智。转声闻辟支佛地。至佛法藏。而现魔界。虽过四魔。而现魔行。虽现外道行。而不舍佛济。虽现身一切世间。而心常在出世间法。一切所有庄严之事。胜诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。人非人。四天王。释提桓因。梵天王。而不舍乐法爱法。菩萨成就如是智慧。住远行地。值百千万亿那由他佛。恭敬供养。尊重赞叹。衣服饮食。卧具医药。供养诸佛。护持佛法。诸声闻辟支佛智慧问难所不能坏。是菩萨哀愍众生故。法忍转净。是菩萨无量百千万亿那由他劫。善根转胜。譬如真金。以诸好宝庄严间错。转胜明净。余金不及。菩萨亦如是。住远行地。一切善根从方便智慧生。转胜明净。无能坏者。譬如日光。星宿月光所不能及。一切泥水悉能干竭。菩萨亦如是。住远行地。善根转胜。一切声闻辟支佛所不能及。又能干竭烦恼污泥。诸佛子。是名略说菩萨摩诃萨远行地。菩萨住是地。多作他化自在天王。诸根猛利。能发众生悟道因缘。所作善业。布施爱语。利益同事。皆不离念佛。不离念法。乃至不离念具足一切种智。常生是心。我当于一切众生。为首为胜。乃至于一切众生。为依止者。是菩萨若欲如是勤行精进。于须臾间。得百千亿那由他三昧。乃至能现百千亿那由他菩萨。以为眷属。若以愿力。自在示现。过于此数。百千万亿那由他劫。不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  深智慧定心　　具行六地已
  一时生方便　　智慧入七地
  行空无相愿　　而修慈悲心
  顺佛平等法　　而供养诸佛
  虽以智观空　　而修福无厌
  虽能严三界　　而心乐远离
  虽心常寂灭　　而起灭恶法
  行空不二相　　而行慈悲心
  虽观一切土　　空若如虚空
  而能善庄严　　清净诸佛土
  虽知诸佛身　　同法相无相
  而种三十二　　八十诸相好
  虽知音声法　　不可言说相
  而叹佛音声　　令一切欢喜
  虽知于诸佛　　一念中成道
  而示时劫刹　　引导诸众生
  如是知诸方　　则得法照明
  菩萨如是者　　即入第七地
  住是地能观　　无量众生行
  亦知于诸佛　　教化众生法
  世界及劫数　　诸法差别相
  又知诸众生　　种种之欲乐
  知说三乘法　　令众生信解
  我应修教化　　成就是众生
  以如是思惟　　方便慧和合
  于四威仪中　　常行如是道
  于一一念中　　能具菩提法
  所谓施戒等　　十种波罗蜜
  如是诸菩萨　　所修之福德
  皆与诸众生　　名檀波罗蜜
  灭除心恶垢　　名尸波罗蜜
  不为六尘伤　　羼提波罗蜜
  能起转胜法　　精进波罗蜜
  于是道不动　　名禅波罗蜜
  无生忍照明　　般若波罗蜜
  回向于佛道　　方便波罗蜜
  求于转胜法　　名愿波罗蜜
  无有能坏者　　名力波罗蜜
  能解如实说　　名智波罗蜜
  是助菩提法　　念念皆能摄
  发于广大愿　　缘于大法故
  初地中功德　　名之为具足
  第二地名为　　除诸心垢恶
  第三愿增明　　第四地入道
  第五随世行　　第六入深法
  得无生相分　　渐渐而增长
  第七集一切　　具菩提分法
  能起诸功德　　及以一切愿
  如是诸功德　　令后八地中
  一切诸所行　　自然得清净
  远行地难过　　大智力所能
  如二国中间　　难可得过度
  在于七地中　　不污如圣王
  虽住于此道　　不名一切过
  若到于第八　　菩萨智慧地
  尔时过意界　　住于智业中
  如梵王观世　　不得名为人
  菩萨罪不污　　如莲华在水
  菩萨住是地　　过诸贪欲等
  不名有烦恼　　亦不名灭尽
  入是正道中　　无有诸烦恼
  愿求佛道故　　不得名尽者
  于诸世间中　　经书技艺事
  文颂咒术等　　自然能明了
  修习诸禅定　　及诸神通等
  无量心利世　　是事皆能起
  尔时此菩萨　　过于二乘行
  安住第七地　　菩萨诸行中
  以初发心时　　大愿力故胜
  今于此地中　　自以智慧力
  犹如国王子　　生时姓尊贵
  后以功行成　　于诸人中尊
  住此得深智　　转发胜精进
  念念入寂灭　　而亦不取证
  如人善乘船　　入于大海中
  虽行深水难　　而不为所害
  菩萨行转胜　　方便智慧故
  功德悉备足　　非世所能知
  供养无量佛　　其心转清净
  如真金杂宝　　间错而庄严
  得佛智慧光　　干诸爱润水
  犹如日光明　　消涸于泥涝
  住是地多作　　他化自在王
  诸根悉猛利　　通达诸道果
  若欲勤精进　　得见百千亿
  那由他诸佛　　愿力复过是
  七地智慧净　　人天及二乘
  皆非其境界　　今已略说竟

大方广佛华严经卷第二十五大方广佛华严经卷第二十六

        东晋天竺三藏佛驮跋陀罗译

    十地品第二十二之四

  他化自在王　　诸天及菩萨
  闻说此上行　　心皆大欢喜
  雨上妙华香　　幡盖宝璎珞
  真妙摩尼珠　　散佛及大众
  天女于空中　　作种种妓乐
  供养于如来　　并及诸菩萨
  同以微妙音　　歌颂佛功德
  一切智慧者　　众生中最尊
  哀愍世间故　　现诸神通力
  华香珍宝等　　皆出如是音
  于一微尘中　　各示那由他
  无量数诸佛　　于中而说法
  于一微尘中　　见无量佛国
  须弥金刚围　　世间不迫迮
  于一微尘中　　见有三恶道
  天人阿修罗　　各各受业报
  闻诸佛国中　　一切佛妙音
  转无上法轮　　随应众生心
  诸佛世界中　　众生身种种
  随国土众生　　示现种种身
  一切诸天人　　皆悉同止住
  佛先观察已　　然后为说法
  众生悉知见　　微尘中佛国
  亦观旷大刹　　以佛威神故
  佛现如是等　　种种神通力
  若为众生说　　是事不可尽
  以是微妙音　　称叹于世尊
  心皆大欢喜　　默然而观佛
  解脱月菩萨　　请金刚藏言
  佛子愿演说　　入于八地行

金刚藏菩萨言。佛子。菩萨摩诃萨。已习七地微妙行慧。方便道净。善集助道法。具大愿力。诸佛神力所护。自善根得力。常念随顺如来力。无畏。不共法。直心深心清净。成就福德智慧。大慈大悲不舍众生。修行无量智道。入诸法本来无生。无起无相。无成无坏。无来无去。无初无中无后。入如来智。一切心意识。忆想分别。无所贪着。一切法如虚空性。是名菩萨得无生法忍入第八地。入不动地名为深行菩萨。一切世间所不能测。离一切相。离一切想。一切贪着。一切声闻辟支佛所不能坏。深大远离。而现在前。譬如比丘得于神通。心得自在。次第乃入灭尽定。一切动心。忆想分别。皆悉尽灭。菩萨亦如是。菩萨住是地。诸勤方便身口意行。皆悉息灭。住大远离。如人梦中欲渡深水。发大精进。施大方便。未渡之间。忽然便觉。诸方便事。皆悉放舍。菩萨亦如是。从初已来。发大精进。广修道行。至不动地。一切皆舍。不行二心。诸所忆想。不复现前。譬如生梵世者。欲界烦恼不现在前。菩萨亦如是。住不动地。一切心意识不现在前。乃至佛心。菩提心。涅槃心。尚不现前。何况当生诸世间心。佛子。是菩萨随顺是地。以本愿力故。又诸佛为现其身。住在诸地法流水中。与如来智慧为作因缘。诸佛皆作是言。善哉善哉。善男子。汝得是第一忍。顺一切佛法。善男子。我有十力。四无所畏。十八不共法。汝今未得为得。是故勤加精进。亦莫舍此忍门。善男子。汝虽得此第一甚深寂灭解脱。一切凡夫离寂灭法。常为烦恼觉观所害。汝当愍此一切众生。又善男子。汝应念本所愿。欲利益众生。欲得不可思议智慧门。又善男子。一切法性。一切法相。有佛无佛。常住不异。一切如来不以得此法故说名为佛。声闻辟支佛亦得此寂灭无分别法。善男子。汝观我等无量清净身相。无量智慧。无量清净国土。无量方便。无量圆光。无量净音。汝今应起如是等事。又善男子。汝今适得此一法明。所谓一切法寂灭无有分别。我等所得无量无边。汝应精勤起此诸法。善男子。十方无量国土。无量众生。无量诸法差别。汝应如实通达是事。随顺如是智。是菩萨诸佛与如是等无量无边起智慧门因缘。以此无量门故。是菩萨能起无量智业。皆悉成就。诸佛子。若诸佛不与菩萨起智慧门者。是菩萨毕竟取于涅槃。弃舍利益一切众生。以诸佛与此无量无边起智慧门故。于一念中。所生智慧。比从初地已来乃至七地。百分不及一。无量无边阿僧祇分不及一。乃至算数譬谕所不能及。所以者何。先以一身修集功德。今此地中。得无量身修菩萨道。以无量音声。无量智慧。无量生处。无量清净国土。无量教化众生。供养给侍无量诸佛。随顺无量佛法。无量神通力。无量大会差别。无量身口意业。集一切菩萨所行道。以不动法故。佛子。譬人乘船欲渡大海。未至大海多用功力。入海以风。无复艰碍。一日之行过先功力。于百千岁。所不能及。菩萨亦如是。多集善根。乘大乘船。入菩萨所行大智慧海。不施功力。能近一切诸佛智慧。比本所行。若一劫。若百千万劫。所不能及。佛子。菩萨摩诃萨。至第八地。从大方便慧生。无功用心。在菩萨道。思惟诸佛智慧势力。知世界生。世界灭。世界成。世界坏。知以何业因缘集故世界成。何业因缘灭故世界坏。是菩萨知地水火风性小相。中相。无量相。差别相。知微尘细相。知微尘差别相。于一世界中。所有微尘差别。皆悉能知。此一世界所有地水火风。若干微尘。皆悉能知。知宝物若干微尘。众生身若干微尘。世界中万物微尘差别。分别众生大身小身。以若干微尘。成地狱身畜生身。饿鬼身。以若干微尘。成阿修罗身。天身。以若干微尘成。皆悉了知。是菩萨入如是分别微尘智。知欲色无色界坏。知欲色无色界成。知欲色无色界成坏。知欲色无色界小相。中相。无量相。知欲色无色界差别相。如是知三界。是名菩萨教化众生。助智明分。善分别众生身。善观所应生处。随众生生处。随众生身。而为受身。是菩萨现身遍满三千大千世界。随众生身。各各差别譬如日月于一切水皆现其像。若二若三。乃至无量无边不可思议不可说三千大千世界身遍其中。随众生身差别。而为受身。是菩萨成就如是智慧。于一世界。身不动摇。乃至不可说诸佛世界。随众生身。随所信乐。于佛大会。而现身像。若于沙门中。示沙门形色。婆罗门中。示婆罗门形色。刹利中。示刹利形色。居士中。示居士形色。四天王中。帝释中。魔中。梵天中。示梵天形色。乃至阿迦腻吒天中。示阿迦腻吒形色。以声闻乘度者。示声闻形色。以辟支佛乘度者。示辟支佛形色。以菩萨乘度者。示菩萨形色。以佛身度者。示佛身形色。所有不可说诸佛国中。随众生身信乐差别。现为受身。而实远离身相差别。常住平等。是菩萨知众生身。知国土身。知业报身。知声闻身。知辟支佛身。知菩萨身。知如来身。知智身。知法身。知虚空身。是菩萨如是知众生深心所乐。若于众生身。作己身。若于众生身作国土身。业报身。声闻身。辟支佛身。菩萨身。如来身。智身。法身。虚空身。若于国土身。作己身。业报身。乃至虚空身。若于业报身。作己身。乃至虚空身。若于己身。作众生身。国土身。业报身。声闻身。辟支佛身。菩萨身。如来身。智身。法身。虚空身。是菩萨知众生集业身。报身。烦恼身。色身。无色身。诸佛国土小相。中相。无量相。垢相。净相。广相。倒相。平相。方差别相。知业报身假名差别。声闻身假名差别。辟支佛身假名差别。菩萨身假名差别。知如来身。菩萨身。愿身。化身。住持身。相好庄严身。势力身。如意身。福德身。智身。法身。知智身善分别如实。知法身平等不坏相。知虚空身无量相。周遍相。无形相。是菩萨善知起如是诸身。则得命自在。心自在。财自在。业自在。生自在。愿自在。信解自在。如意自在。智自在。法自在

是菩萨得十自在。为不可思议智者。无量智者。广智者。不可坏智者。菩萨随如是智慧。毕竟常起无罪身业口业意业。身业随智行。口业随智行。意业随智行。般若波罗蜜增上。大悲为首。善修方便。善起诸愿。善为诸佛神通所护。常不舍行利益众生智。悉知无边世界中差别事。举要言之。菩萨住无动地。身口意所作。皆能集一切佛法。是菩萨住此地。离一切烦恼故。善住净心力。心常不离道故。善住深心力。不舍众生故。善住大悲力。救一切世间故。善住大慈力。不忘所闻法故。善住陀罗尼力。分别观察一切佛法故。善住一切乐说力。行无边差别世界故。善住神通力。不舍一切菩萨所行故。善住愿力。修集一切佛法故。善住波罗蜜力。善起一切种智故。善住如来力。是菩萨得如是智力。示一切所作。无有过咎。诸佛子。菩萨此地不可坏故。名为不动地。智慧不转故。名为不转地。一切世间不能测知故。名威德地。无色欲故。名童真地。随意受生故。名自在地。更不作故。名为成地。决定知故。名为究竟地。善发大愿故。名为变化地。不可坏故。名为住持地。先修善根故。名为无功力地。菩萨得如是智慧。名为入佛境界。名为佛功德所照明。名为随佛威仪行趣向佛法。常为诸佛神力所护。常为四天王。释提桓因诸梵王等之所奉迎。密迹金刚神。常随侍卫。善能出生诸禅三昧。能作无量诸身差别。于诸身中。皆有势力。得大果报神通力。于无边三昧中得自在。能受无量记。随众生成就处。示成阿耨多罗三藐三菩提。是菩萨入如是大智慧。善通达诸法。常放大智光明。度无碍法界道。善知世界道差别。能示一切诸功德。随意自在。善解先际后际。能入转魔道智。入如来行境界。能于无边世界。行菩萨道。以不转相故。此地名为不动。佛子。菩萨在不动地。善生禅定力故。常见无边诸佛。不舍供养供给诸佛。是菩萨于一一劫。一一世界中。数百千万亿那由他。无量无边阿僧祇佛。恭敬供养。尊重赞叹。亲近诸佛。从诸佛受世界差别等诸法明。是菩萨转深入如来法藏。问世界差别事。无能尽者。乃至百千万亿劫。说不可尽。又诸善根。转胜明净。譬如真金。众宝间错。为转轮王。所佩璎珞。一切人民。无能夺者。菩萨摩诃萨亦如是。住无动地。善根转净。一切声闻辟支佛。乃至七地菩萨所不能坏。菩萨住是地。以善分别智门故。智慧光明。灭除一切众生恼热。譬如千世界主大梵天王。能于一时。流布慈心。满千世界。亦能放光。遍照其中。菩萨摩诃萨亦如是。住不动地。能放身光。照十万佛刹微尘世界。灭除众生诸烦恼热。令得清凉。诸佛子。是名略说菩萨不动地。若广说者。无量亿劫所不能尽。菩萨住是地。多作大梵天王。主千世界。诸根猛利。与诸众生声闻辟支佛菩萨波罗蜜道。无有穷尽。说世界差别。无能坏者。所作善业。布施爱语。利益同事。皆不离念佛。不离念法。乃至不离念一切种智。常生是心。我当于众生。为首为胜。乃至于一切众生。为依止者。是菩萨若欲勤行精进。于须臾间。得百万三千大千世界微尘数三昧。乃至能示百万三千大千世界微尘数菩萨。以为眷属。若以愿力。神通自在。能过是数若干。百千万亿劫。不可计知。时金刚藏菩萨。欲重明此义。以偈颂曰

  菩萨住七地　　慧方便已净
  善集助道法　　大愿力所系
  诸佛神力护　　善根悉成就
  求于胜智慧　　能入第八地
  善集于福慧　　而有深慈悲
  离诸有量心　　心同如虚空
  如所说法中　　心得决定力
  如是得寂灭　　微妙无生忍
  诸法从本来　　无生亦无起
  无相无有成　　亦无去来义
  诸法初中后　　与如无分别
  无有心意行　　同若如虚空
  成就如是忍　　无有诸戏论
  得是不动地　　甚深寂灭行
  一切诸世间　　不能得测量
  一切诸心相　　皆悉已灭尽
  菩萨住是地　　心识无分别
  如入灭尽定　　无复忆念想
  犹如人梦中　　方便欲渡水
  觉则意廓然　　休息诸所作
  得是深忍已　　一切想念灭
  如生于梵天　　无欲界烦恼
  以本愿力故　　及佛今劝导
  如是第一忍　　是诸佛职位
  我等深智力　　无畏不共法
  汝今无有此　　当加勤精进
  汝虽得除灭　　一切烦恼火
  当观诸世间　　烦恼常炽然
  当念本所愿　　欲利诸众生
  悉遍知诸法　　广度于一切
  诸法实性相　　常住无变异
  二乘亦得此　　而不名为佛
  但以得无碍　　甚深微妙智
  通达三世故　　乃得名为佛
  是诸无等等　　天人所恭敬
  开是起智门　　令入诸佛法
  成就无边底　　无量妙智慧
  先所行诸法　　不及今一念
  如是诸菩萨　　得妙智慧地
  能在一念中　　身遍于十方
  入是智慧门　　行道疾无碍
  如行于海中　　大风力所济
  离诸功用心　　但在于智业
  观十方世界　　成坏及与住
  能知四大一　　亦知诸别异
  小中及无量　　种种差别相
  能数知三千　　大千世界尘
  亦知众生身　　四大微尘数
  诸天身众宝　　微尘数差别
  皆悉遍明了　　余亦如是知
  智慧因缘故　　心转得调柔
  为利诸众生　　遍诸世界身
  能于众生身　　而自作己身
  及以诸佛刹　　诸余种种身
  如日月停空　　影现一切水
  菩萨亦如是　　遍满大千界
  常住于法身　　湛然不移动
  于净心众生　　各现其身像
  随诸心所乐　　而现为受生
  于诸天人会　　悉皆示其身
  菩萨于因缘　　和合中自在
  乃至能随意　　为现于佛身
  众生国土身　　业报贤圣身
  智身与法身　　知皆同平等
  以是因缘故　　得如意神通
  为令世欢喜　　而现种种身
  能得于十种　　妙大自在智
  所作随智行　　顺于慈悲心
  诸佛所有法　　皆能善修习
  住三净戒中　　不动如须弥
  能得大菩萨　　所有十种力
  一切诸魔众　　皆所不能转
  常为诸佛护　　释梵所敬礼
  密迹金刚神　　常随而侍卫
  菩萨得是地　　功德无有量
  百千万亿劫　　说之不可尽
  亲近无数佛　　增益诸善根
  如真金杂宝　　庄严王璎珞
  菩萨在是地　　多作大梵王
  典领千国土　　功德无有量
  能以三乘教　　而无有穷尽
  慈心光普照　　灭诸烦恼热
  能于须臾间　　得百万三千
  大千世界数　　微尘诸三昧
  能见十方佛　　其数亦如是
  若以其愿力　　过是无有量
  今已略解说　　第八地妙相
  若广演说者　　千亿劫不尽

    第九地

  佛子演说此　　八地妙义时
  以佛神力故　　震动无量国
  一切智身出　　无量微妙光
  遍照十方界　　众生得安乐
  百千万菩萨　　住于虚空中
  设众妙供养　　诸天所无有
  自在大梵天　　并及他化王
  欢喜设妙供　　大海功德佛
  千万诸天女　　咸恭敬欢喜
  同以微妙音　　歌叹佛功德
  以佛神力故　　出如是妙法
  善行寂灭者　　无有诸恶心
  各在于其地　　善修菩萨行
  利益世间故　　遍游于十方
  示众以佛道　　心如空无碍
  诸菩萨神力　　上妙供养具
  胜十方人天　　福德之所致
  佛子乐智者　　以此示佛力
  于一国不动　　而现一切处
  利益于世间　　如满月明净
  灭一切音声　　语言诸想念
  而以诸音声　　说法犹如响
  若众生下劣　　其心厌没者
  示以声闻道　　令出于众苦
  若复有众生　　诸根少明利
  乐于因缘法　　为说辟支佛
  若人根明利　　饶益于众生
  有大慈悲心　　为说菩萨道
  若有无上心　　决定乐大事
  为示于佛身　　说无量佛法
  譬如幻化师　　示种种身色
  如是诸身相　　皆无有实事
  如是诸佛子　　善知智慧术
  能示一切行　　心离于有无
  千万诸天女　　同以微妙音
  如是歌叹已　　默然而观佛
  解脱月又言　　佛子大会净
  一心愿乐闻　　入九地正行

金刚藏菩萨言。佛子。菩萨摩诃萨。以如是无量智慧。善观佛道。欲求转胜寂灭解脱。欲转胜思惟如来智慧。欲入如来深密法藏。欲观察不可思议大智慧。欲观察诸陀罗尼三昧重令清净。欲令神通广大。欲分别世界差别。欲修诸佛力无所畏不共法。无能坏者。欲顺行诸佛转法轮力。欲不舍所受大悲大愿。菩萨如是思惟。得入第九地。菩萨住此地。如实知善不善无记法行。知有漏无漏法行。世间出世间法行。思议不思议法行。定不定法行。声闻辟支佛法行。菩萨道法行。如来地法行。有为无为法行。随顺如是智慧。知菩提心所行难。知烦恼难。业难。诸根难。欲难。性难。直心难。使心难。生难。习气难。三聚差别难。知众生诸心差别相。庄饰世心相。速转心相。坏不坏心相。无形心相。无边自在心相。清净差别心相。垢无垢心相。缚解心相。谄曲质直心相。随道心相。皆如实知。是菩萨知烦恼深相。浅相。知心伴相。不相离相。知使缠差别相。知是心相应不相应相。随是生时得果报相。知三界中差别相。知爱痴见深入如箭相。知憍慢痴重罪相。知是三业因缘不断相。乃至如实知八万四千烦恼行差别相。是菩萨知诸业善不善无记相。分别不可分别相。心伴相。不相离相。自然尽相。行道尽相。种种集相。不失果报相。次第相。有报相。无报相。黑黑报相。白白报相。黑白黑白报相。非黑非白能尽业相。知业起相。受业法差别相。知无量因缘起业相。知世间业出世间业差别相。现报相生报相。后报相。随诸乘定相。不定相。乃至如实知八万四千诸业差别相。是菩萨知诸根软中上差别相。知先后际别异不别异相。知上中下相。知烦恼伴相。不相离相。随诸乘定相。不定相。淳熟相。未淳熟相。随根转相。易坏相。深取相相。增上相。不可坏相。转相。不转相。三世差别相。久远共生差别相。乃至如实知八万四千诸根差别相。是菩萨知诸欲软中上差别相。乃至如实知八万四千诸欲差别相。是菩萨知诸性软中上差别相。乃至如实知八万四千诸性差别相。是菩萨知直心软中上差别相。乃至如实知八万四千直心差别相。是菩萨知诸使共心生不共心生。心相应心不相应。无始来恼众生相。与一切禅定解脱神通相违相。三界系相。无量心不现前相。开烦恼门相。不知对治相。无所有相。无圣道开法门相。皆如实知。是菩萨知诸生差别相。所谓地狱。畜生饿鬼。阿修罗人天。色无色界。有想无想差别。业是田。爱是水。无明是覆。识是种子。后身是芽。名色共生而不相离。痴爱相续。欲生欲作欲受。不乐涅槃三界差别相续相。皆如实知。是菩萨知诸习气有起不起。随所生处有习气。随众生行有习气。随业烦恼有习气。善不善无记有习气。离欲有习气。随后身有习气。次第随趣有习气。久远不断持烦恼业。离则无法。皆如实知。是菩萨知众生定不定相。正定相。邪定相。不定相。正见中正定相。邪见中邪定相。离此二不定相。一一逆邪定相。五根正定相。离此二不定相。邪位邪定相。正位正定相。离此二不定相。深入邪聚难转相。修无上道因缘相。不定众生守护相。皆如实知。佛子。菩萨摩诃萨。随如是智。名为安住善慧地。菩萨住是地。知众生如是诸行差别相。随其解脱而与因缘。是菩萨化众生法。度众生法。如实知而为说法。声闻乘相。辟支佛乘相。菩萨乘相。如来地相。如实知。随众生因缘。而为说法。随心随根。随欲差别。而为说法。又随行处。随智慧处。而为说法。知一切行处。而为说法。随众生性。深入难处。而为说法。随趣随生。随烦恼。随习气转故说法。随乘令解脱故说法。是菩萨住此地。为大法师。守护诸佛法藏。入深妙义。用无量慧方便。四无碍智言辞说法。是菩萨常随四无碍智。而不可坏。何等为四。一法无碍。二义无碍。三辞无碍。四乐说无碍。是菩萨以法无碍智。知诸法自相。以义无碍智。知差别法。以辞无碍智。知说诸法不可坏。以乐说无碍智。知说诸法次第不断。复次以法无碍智。知诸法无体性。以义无碍智。知诸法生灭相。以辞无碍智。知诸法假名不断假名说。以乐说无碍智。知随假名不坏无边说。复次以法无碍智。知现在诸法差别相。以义无碍智。知过去未来诸法差别相。以辞无碍智。知过去未来现在诸法说不可坏。以乐说无碍智。于一一世。得无边法明说。复次以法无碍智。知诸法差别。以义无碍智。知诸法义差别。以辞无碍智。随诸言音。而为说法。以乐说无碍智。随所乐解。而为说法。复次以法无碍智。以法智方便。知诸法差别不可坏。以义无碍智。以比智如实知诸法差别。以辞无碍智。以世智。说诸法差别。以乐说无碍智。知善说第一义。复次以法无碍智。知诸法一相不坏。以义无碍智。知阴入界谛因缘法。以辞无碍智。以微妙音故。一切世间之所归趣。以乐说无碍智。所说转胜。能令众生。得无边法明。复次以法无碍智。知一乘究竟。摄一切无差别。以义无碍智。知诸乘差别。以辞无碍智。能说诸乘无差别。以乐说无碍智。以一法门说无边法明。复次以法无碍智。能入一切菩萨行智行法行随智行。以义无碍智。能分别说十地义差别。以辞无碍智。说随顺诸地道不可坏。以乐说无碍智。说一切行无边相。复次以法无碍智。知一切佛。于一念中得菩提。以义无碍智。知种种时。种种刹差别。以辞无碍智。随诸佛得道事差别说。以乐说无碍智。于一句法。无边劫说。而不穷尽。复次以法无碍智。知一切佛语。一切佛力。无畏。不共法。大慈大悲。无碍智。转法轮。一切种智。以义无碍智。知如来音声。说八万四千随众生心诸根欲乐差别行。以辞无碍智。以如来音声。说一切诸行不可坏。以乐说无碍智。以诸佛智力。随众生所乐音声说。菩萨摩诃萨。如是善知无碍智。安住第九地。名为得佛法藏。为大法师。得众义陀罗尼。众法陀罗尼。起智陀罗尼。众明陀罗尼。善慧陀罗尼。众财陀罗尼。名声陀罗尼。威德陀罗尼。无碍陀罗尼。无边旋陀罗尼。杂义藏陀罗尼。得如是等百万阿僧祇陀罗尼。随方便说。如是无量乐说差别门说法。是菩萨得如是无量陀罗尼门。能于无量佛所听法。闻已不忘。如所闻法。能以无量差别门。为人演说。是菩萨于一佛所。以百万阿僧祇陀罗尼。听受正法。如从一佛。余无量佛。亦复如是。是菩萨于礼敬佛时。所闻法明。非多学声闻得陀罗尼力。于十万劫。所能受持。是菩萨得如是陀罗尼力。无碍智乐说力。以说法故。在于法座。大千世界满中众生。随意说法。是菩萨在法座上。唯除诸佛。及受职菩萨。于一切中。最为殊胜。是菩萨处于法座。或以一音。欲令一切悉得解了。即得解了。或以种种音声。欲令一切各得开解。即得开解。或以默然但放光明。欲令一切各得解法。即得解法。或一切毛孔。皆出法音。或三千大千世界所有色无色物。皆出法音。或以一音。周满法界。欲令得解。即皆得解。是菩萨三千大千世界所有众生。以无量音声。一时问难。所问各异。是菩萨于一念中。悉受如是一切问难。以一音答。皆令开解。如是若二若三。若百若千。乃至不可说不可说三千大千世界满中众生广为说法。承佛神力。能为众生。广作佛事。倍复勤摄如是智明。于一尘中。有不可说不可说世界尘数大会。佛在此中。随众生心。而为说法。令一一众生。心得若干无量诸法。如一佛。一切诸佛。亦如是。如一微尘。一切十方世界。亦复如是。于是中生大忆念力。于一念中。从一切佛所受法明。不失一句。如上大会满中众生。以决定法明。演清净法。于一念中。令尔所众生。皆得开解。何况若干世界中众生。是菩萨住是地。善根转胜。深入诸佛行处。常与一切佛会。深入菩萨解脱。菩萨随顺。如是智。常见诸佛。于一一劫中。无量无边百千万亿以上供具。供养诸佛。于诸佛所。种种问难。通达诸陀罗尼。一切善根。转胜明净。佛子。如炼真金。具足庄严。为转轮王所著宝冠。一切小王无能夺者。菩萨亦如是。住善慧地。一切善根。转胜明净。声闻辟支佛。诸地菩萨所不能坏。是菩萨善根转明。能照众生烦恼难处。如大梵王。三千世界一切难处。皆悉能照。菩萨亦如是。住善慧地。善根明净。照诸众生烦恼难处。诸佛子。是名略说菩萨善慧地。若广说者。则无量无边劫。不可得尽。菩萨住是地。多作大梵王。典领三千大千世界。无有能胜。如实解义者。于自在中。而得自在。善能宣说声闻辟支佛。菩萨波罗蜜。众生问难。无能穷尽。所作善业。布施爱语。利益同事。皆不离念佛。不离念法。乃至不离念一切种智。常生是心。我当于一切众生。为首为胜。乃至于一切众生。为依止者。是菩萨若欲如是勤行精进。于一念中。得百万阿僧祇三千大千世界微尘数三昧。乃至能示百万阿僧祇三千大千世界微尘数菩萨。以为眷属。若以愿力。神通自在。复过是数。百千万亿那由他劫。不可计知

尔时金刚藏菩萨。欲重明此义。以偈颂曰

  诸菩萨随顺　　无量深智力
  第一最微妙　　一切世难知
  利益众生者　　能至第九地
  得入于诸佛　　秘密之法藏
  得微妙最上　　三昧陀罗尼
  广大神通力　　善入世界相
  智慧力决定　　能观诸佛法
  大愿悲心净　　得入第九地
  顺行此上地　　持诸佛法藏
  即能通诸法　　善不善无记
  有漏及无漏　　世间出世间
  是可思议法　　是不可思议
  知法定不定　　三乘具足相
  思惟分别此　　有为无为法
  起知如是法　　灭诸无明闇
  随顺是智心　　则为第一妙
  悉知一切难　　诸心差别相
  庄饰世轻易　　无边自在心
  烦恼深浅相　　心伴不离相
  知使缠差别　　随顺相续有
  知业种种杂　　各各差别相
  因灭果不失　　通达如是事
  又知于众生　　诸根软中上
  广大差别等　　先际后际相
  知欲软中上　　及诸性差别
  乃至能悉知　　八万四千种
  烦恼使难处　　无始来不灭
  皆与心共行　　系缚不可断
  知诸结使等　　但妄想分别
  无有方处所　　亦无定事相
  常不离于身　　又亦难得知
  禅定力能遮　　金刚道能断
  又能知诸生　　入六道差别
  爱润无明覆　　业田识是种
  生于后身芽　　名色共增长
  无始生死来　　相续在三界
  知诸天龙趣　　由烦恼业心
  若离于此法　　是则无所有
  一切诸众生　　皆在三趣中
  或没诸邪见　　或在于智道
  菩萨住是地　　悉知众生心
  诸根及欲乐　　种种差别义
  深心善思惟　　随宜而说法
  通达无碍智　　善以言辞说
  菩萨为法师　　犹如师子王
  牛王宝山王　　安住无所畏
  普于诸世界　　雨甘露法味
  犹如大龙王　　能雨满大海
  是菩萨善知　　法义辞无碍
  善能随顺行　　具足乐说力
  能得于百万　　阿僧祇总持
  能受诸佛法　　如海受龙雨
  菩萨得如是　　诸深妙清净
  无量陀罗尼　　诸三昧力故
  能于一念中　　得见无量佛
  闻已净梵音　　演说妙法宝
  是菩萨或教　　大千界众生
  随心根所好　　说法令欢喜
  如是等无量　　三千大千国
  转深勤精进　　而作是思惟
  于一微尘中　　无量佛说法
  随众生心相　　演说于妙义
  是菩萨皆受　　如地受诸种
  复作如是愿　　十方诸所有
  国土中众生　　皆合为一会
  我于一念中　　皆悉知其心
  以一音说法　　悉令断疑网
  菩萨住是地　　人天中法王
  为大说法师　　随顺众生性
  常于日夜中　　与诸佛共会
  能住甚深妙　　寂灭智解脱
  供养无量佛　　善根转明净
  犹如转轮王　　真金庄严冠
  光明照众生　　诸烦恼难处
  如梵王光明　　照于大千界
  菩萨住是地　　于三千世界
  作大梵天王　　诸根悉猛利
  善以三乘法　　示悟诸众生
  所作诸善业　　皆顺于正念
  能于一念中　　而得无有量
  世界微尘数　　诸深妙三昧
  得见十方佛　　微妙音说法
  见佛大神力　　更发无量愿
  如是第九地　　大智所行处
  深妙难知见　　今已略说竟

大方广佛华严经卷第二十六大方广佛华严经卷第二十七

        东晋天竺三藏佛驮跋陀罗译

    十地品第二十二之五

  说诸大菩萨　　所行无上事
  无数那由他　　首陀会诸天
  于上虚空中　　心皆大欢喜
  咸以恭敬心　　众妙供养佛
  那由他菩萨　　欢悦无有量
  烧诸奇妙香　　灭除诸烦恼
  他化自在王　　与诸天大众
  住在虚空中　　心皆大欢喜
  咸以恭敬心　　种种设供养
  各散众宝衣　　空中旋转下
  无量亿天女　　诸根欣悦豫
  于上虚空中　　敬心供养佛
  同作无量亿　　那由他妓乐
  一切宝器中　　皆出如是音
  佛坐于此处　　悉遍于一切
  十方国土中　　皆亦有佛现
  无量亿种种　　相好庄严身
  殊妙无有比　　充满于世界
  于一毛孔中　　出无量光明
  灭除于一切　　世间烦恼火
  十方微尘数　　尚可得计量
  一毛孔光明　　不可得穷尽
  各见有佛身　　以三十二相
  八十好庄严　　转无上法轮
  或见佛种种　　为众而说法
  或见在兜率　　教化于诸天
  或见从兜率　　来下处胞胎
  或见初生时　　或见夜出家
  或见坐道场　　而成无上道
  或见转法轮　　或见入涅槃
  于无量国土　　种种而示现
  欲度众生故　　有如是等事
  譬如巧幻师　　善知于幻术
  多示诸众生　　种种异身相
  如是佛慧中　　善巧于示现
  变化一切身　　周遍诸世界
  一切法空寂　　先来无性相
  同若如虚空　　大师亦如是
  得入第一义　　微妙之性相
  随诸法性相　　示佛大神力
  一切佛行性　　法及诸众生
  皆悉同无相　　一切法空故
  若欲得佛智　　应离诸想念
  有无俱通达　　疾作天人师
  诸天采女众　　皆出如是等
  千万种妙音　　寂然而观佛
  解脱月菩萨　　见众皆寂然
  请金刚藏言　　大名称佛子
  菩萨从第九　　至于第十地
  诸大神通力　　愿今为略说

金刚藏菩萨言。佛子。菩萨摩诃萨。如是无量智慧。善修行佛道。乃至九地善集清白法。集无量助道法。大功德智慧所护。广行大悲。深知分别世界差别。深入众生难处。入诸如来行处。念随顺如来寂灭行处。趣向诸佛力。无畏。不共法。坚持不舍。得至一切智位。菩萨摩诃萨。行如是智。近佛位地。则得菩萨离垢三昧而现在前。又入法界差别三昧。庄严道场三昧。雨一切世间华光三昧。海藏三昧。海印三昧。虚空广三昧。观察一切法性三昧。随一切众生心行三昧。如实知一切法三昧。得如来智信三昧。如是等百万阿僧祇三昧皆现在前。是菩萨悉入此三昧。善知其中功用差别。最后三昧名益一切智位。是三昧现在前。即时大宝莲华王出。周圆如百万三千大千世界。一切众宝间错庄严。过于一切人天所有。出世间善根所生。知一切法。如幻如化。空慧所成。光明能照一切世界。琉璃为茎。栴檀王为台。码瑙为须。阎浮檀金为叶。无量光明。一切妙宝。皆在其内。宝网覆上。十三千大千世界。微尘数莲华。以为眷属。尔时菩萨。其身姝妙。称可华座。菩萨得益一切智位三昧力故。身在大莲华座。即时眷属莲华上皆有菩萨。一一菩萨坐莲华上。即得百万三昧。皆一心恭敬瞻仰大菩萨。是菩萨升莲华座时。十方现在一切世界。皆大震动。一切恶道皆悉休息。光明普照十方世界。一切世界皆悉严净。皆得见闻诸佛大会。何以故。是菩萨坐大莲华上。即时足下出百万阿僧祇光明。照十方阿鼻地狱等。灭众生苦恼。两膝上放若干光明。照十方一切畜生。灭除苦恼。脐放若干光明。照十方一切饿鬼。灭除苦恼。左右胁放若干光明。照十方人。安隐快乐。两手放若干光明。照十方诸天。阿修罗宫。两肩放若干光明照十方声闻众。项放若干光明。照十方辟支佛。口放若干光明。照十方菩萨。乃至住九地者。白毫放若干光明。照十方得位菩萨。一切魔宫隐蔽不现。顶上放百万阿僧祇三千大千世界微尘数光明。照于十方诸佛大会。绕十匝已。住于虚空。成光明网。高大明净。供养诸佛。如是供养。从初发心。乃至九地。所作供养。百分不及一。乃至算数譬谕所不能及。是大光明网。胜十方世界所有华香。末香。涂香。衣服。幡盖。众宝璎珞。摩尼宝珠。供养之具。从出世间善根生故。一一诸佛大法会上。皆雨众宝。犹如大云。若有众生觉是供养者。皆是必定无上大道。如是诸光雨大供养已。绕大会十匝。入诸佛足下。尔时诸佛。及大菩萨。知某世界。某甲菩萨摩诃萨。行如是道。成就受职。即时十方无边菩萨。乃至住九地者。皆来围绕。设大供养。一心恭敬。各得万三昧。一切得职菩萨摩诃萨。于金刚庄严胸。出一大光。名破魔贼。无量百千万光。以为眷属。照十方世界。示无量神力。亦来入是大菩萨胸。此光明灭已。是菩萨即得百千万亿大势力神通智慧。尔时诸佛。出眉间白毫相光。名益一切智。有无量无边光明眷属。悉照一切十方世界。围绕十匝。示现诸佛大神通力。劝进无量百千万亿诸菩萨。十方世界六种震动。灭除一切恶道苦恼。一切魔宫。皆蔽不现。示一切诸佛得道之处。示一切诸佛大会庄严事。广大如法界。究竟如虚空。照一切世界已。集在虚空。示大神通庄严之事。入是菩萨顶。眷属光明。入眷属莲华诸菩萨顶。即时各得先所未得十千三昧。是光明入此菩萨顶。如一佛光。一切佛光皆亦如是。一切十方诸佛光明入是菩萨顶时名为得职。名为入诸佛界。具佛十力。堕在佛数。佛子。譬如转轮圣王大子成就王相。转轮圣王令子在白象宝阎浮檀金座。取四大海水。上张罗幔。种种庄严幢幡妓乐。执金钟香水。灌子顶上。即名为灌顶大王。具足转十善道故。名转轮圣王。菩萨摩诃萨亦如是。受职时。诸佛以智水灌是菩萨顶。名灌顶法王。具足佛十力故。堕在佛数。是名诸菩萨摩诃萨。大智慧职地。以是职故。菩萨摩诃萨受无量百千亿万苦行难事。是菩萨得是职已。住法云地。无量功德智慧转增。佛子。菩萨住法云地。如实知欲界集。色界集。无色界集。如实知世间性集。众生性集。识性集。有为性集。无为性集。虚空性集。法性集。涅槃性集。邪见诸烦恼性集。如实知诸世间法成坏集。声闻道集。辟支佛道集。菩萨道集。诸佛力无畏不共法色身法身集。一切智集。得佛道转法轮示灭度集。举要言之。如实知一切法差别集。是菩萨以如是智慧。随顺菩提行。如实知众生化。业化。烦恼化。诸见化。世界化。法界化。声闻化。辟支佛化。菩萨化。如来化。一切化。分别无分别化。是菩萨如实知佛力持。法持。业持。烦恼持。时持。愿持。先世持。行持。劫寿持。智持。是菩萨住十地。诸佛所有微细智。所谓行微细智。命终微细智。受胎微细智。出生微细智。出家微细智。得道微细智。神力自在微细智。转法轮微细智。持寿命微细智。示涅槃微细智。法久住微细智。如是等微细智。皆如实知。又诸佛密处。所谓身密。口密。意密。知时非时密。与菩萨授记密。摄伏众生密。诸乘差别密。八万四千诸根差别密。业如实所作密。行得菩提密。如是等密。皆如实知。是菩萨诸佛所有入劫智。所谓一劫摄阿僧祇劫。阿僧祇劫摄一劫。有数劫摄无数劫。无数劫摄有数劫。一念摄劫。劫摄一念。劫摄非劫。非劫摄劫。有佛劫摄无佛劫。无佛劫摄有佛劫。过去未来劫摄现在劫。现在劫摄过去未来劫。未来过去劫摄现在劫。现在劫摄未来过去劫。长劫摄短劫。短劫摄长劫。诸劫摄相。皆如实知。是菩萨诸佛所入微尘智。国土智。众生身心智。众生身心得道智。众生行智。至一切处智。遍行佛道智。顺行智。逆行智。不可思议智。一切世间声闻辟支佛菩萨所不能知。皆如实知。佛子。诸佛智慧广大无量。菩萨住是地。则能得入如是智慧。是菩萨摩诃萨。随是地行。得菩萨不可思议解脱。无碍解脱。净行解脱。普门明解脱。如来藏解脱。随无碍论解脱。入三世解脱。法性藏解脱。明解脱。胜进解脱。是菩萨十解脱为首。得如是等无量无边百千万亿阿僧祇解脱。百千万无量阿僧祇三昧。百千万无量阿僧祇陀罗尼。百千万无量阿僧祇神通。亦复如是。是菩萨成就如是智慧。随顺菩提。成就无量念力。能于一念顷。至十方无量佛所。无量法明。无量法雨。皆能受持。譬如娑伽罗龙王所澍大雨。唯除大海。余不能受。菩萨摩诃萨亦复如是。如来微密雨大法雨。一切众生声闻辟支佛。乃至九地菩萨所不能受。唯此菩萨住法云地。悉能受持。譬如大海一龙王起大云雨。皆能堪受。若二若三。乃至无量无边诸大龙王所起云雨。一时澍下。皆能受持。菩萨摩诃萨亦如是。住法云地。于一佛所。能受大法明雨。二佛三佛乃至不可说不可说佛。于一念中。皆能堪受如是诸佛大法云雨。是故此地名法云地。解脱月言。佛子。是菩萨。于一念中。能堪受几所大法明雨。答言。佛子。譬如十方所有不可说百千万亿那由他世界微尘。尔所微尘世界众生。假使皆得闻持陀罗尼。为佛侍者。为大声闻多闻第一。如金刚莲华上佛。善伏比丘。其一众生成就如是多闻之力。余亦如是。一人所受。余不重问。如是一切各各不同。于意云何。是一切众生受持多闻力为多不。答言甚多。不可称计。佛子。我今为汝说。是菩萨住法云地。于一念顷。于一佛所受三世法藏大法明雨。上一切众生多闻之力。百分不及一。乃至算数譬谕所不能及。如一佛所闻。十方世界微尘诸佛。皆能受持大法明雨。复能过此无量无边。于一念顷。亦能受持。是故名为法云地。佛子。菩萨摩诃萨。住法云地。自从愿力生大慈悲。福德智慧。以为密云。现种种身。以为杂色云。通明无畏。以为电光。震大雷音。说法降魔。一念一时。能于上所说微尘世界。皆悉周普。以雨善法甘露法雨。灭诸众生随心所乐无明所起烦恼焰故。是故名为法云地。复次佛子。菩萨摩诃萨。住法云地。于一世界。从兜率天来下。乃至示大涅槃。一切佛事。随所度众生。皆现神力。若二若三。乃至如上微尘数世界。又复过是百千万亿阿僧祇世界。从兜率天来下。乃至示大涅槃。一切佛事。随所度众生。皆现神力。是菩萨住此地。于智慧中。得上自在力。或以狭国为广。广国为狭。或以垢国为净。净国为垢。如是一切世界。皆有神力。是菩萨或于一微尘中。置三千大千世界铁围山川。而不迫迮。或二或三。乃至不可说不可说世界诸庄严事。示入一尘。或以一世界庄严事。示不可说不可说世界。或以不可说不可说世界众生。置一世界中。而不迫迮。或以一世界众生。置不可说不可说世界中。或以不可说不可说世界。入一尘中。而不恼众生。或于一尘中。示一切佛神通力庄严之事。或于一念中。现不可说不可说世界微尘数身。于一身中。示无量手。以一一手。执恒沙莲华。以散诸佛。杂香。末香。幡盖。宝物。如是一切庄严之具。皆以手执。供养诸佛。于一一身。亦复如是。又一一身化尘数头。于一一头。有尘数舌。以是神力。赞叹诸佛。如是等事。于念念中。遍满十方。于念念中。以神通力。无量世界。示得佛道转法轮。乃至大般涅槃。于三世中。以神通力。示现无量身。于自身中。现无量佛。无量佛土庄严事。于自身中。示一切世界成坏事。或于一毛孔。出一切风。而不恼众生。或以无量无边世界。为一海水。此海水中。作大莲华形。色光明遍无量无边世界。于中示菩提树庄严妙事。乃至示得一切种智。或自身中现一方世界摩尼宝珠。日月星宿。一切光明。乃至十方所有光明。亦复如是。或口嘘气。能令十方无量世界悉大震动。不令众生有恐畏想。或示十方世界水劫尽。风劫火劫尽。而众生身随意庄严。或于自身示作如来身。如来身作自身。如来身作己佛国。己佛国作如来身。佛子。菩萨摩诃萨。在法云地。神变如是。又余无量神力自在示现。尔时会中诸菩萨。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。四天王。释提桓因。梵天王。自在天子。净居天等。各作是念。若菩萨神通力。智慧力。如是无量无边。佛复云何。时解脱月菩萨。知大众心所念。问金刚藏菩萨言。佛子。今诸大众。闻是菩萨神通智慧力。堕在疑网。汝今当断一切疑惑。示菩萨神通庄严妙事。时金刚藏菩萨。即入一切佛国体性三昧。时诸大众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。四天王。释提桓因。梵天王。自在天子。净居天等。皆自见知。入金刚藏菩萨身中。于其身内。见三千大千世界庄严众事。若满一劫。说不可尽。于中见佛道场树。其茎周围十万三千大千世界。高百万三千大千世界。覆三千亿三千大千世界。称树高广有师子座。其座上有佛。号一切智王如来。一切大众。咸皆见佛坐在座上。其中所有庄严。上妙供养之具。满一劫说亦不可尽。金刚藏菩萨。示现如是大神力已。还令大众各在本处。一切众会生希有想。默然一心观金刚藏。时解脱月菩萨问金刚藏菩萨言。佛子。是三昧有大势力。甚为希有。是三昧者所号云何。答言。是三昧名一切佛国体性。问言。是三昧所有势力境界云何。答言。佛子。若菩萨摩诃萨。善修成是三昧力者。能以如是无量恒沙世界微尘数三千大千世界。于身中现。复过是数。菩萨在法云地。得如是无量无边百千万亿诸大三昧。是故菩萨住此地中。身身业难可测知。口口业难可测知。意意业难可测知。神力自在难可测知。观三世法难可测知。诸三昧行入难可测知。智力难可测知。游戏诸解脱难可测知。变化所作神力所作如意所作难可测知。乃至举足下足菩萨住善慧地者不能测知。佛子。菩萨法云地如是无量。若广说者。无量无边阿僧祇劫。不能得尽。解脱月言。佛子。若菩萨行处力神通力如是者。佛行处力神通力复云何。答言。佛子。譬如有人见一块土。而作是言。无边世界地性为多此耶。汝所问者。我谓如是。如来无量智慧。云何以菩萨智慧而欲测量。佛子。如人取四天下地性少分余者极多。菩萨法云地。于无量劫但可说耳。何况如来地。我今当说令汝知之。佛现为证。如十方无量无边世界微尘等诸佛世界。十地菩萨。皆满其中。是诸菩萨有无量无边业。修习菩萨功德智慧禅定。于如来功德智慧力百分不及一。百千万亿分不及一。乃至算数譬谕所不能及。佛子。是菩萨随如是智慧。顺如来身口意。不舍诸菩萨三昧。勤心供养一切诸佛。于一一劫。以一切供具。供养无量无边诸佛。能悉具受诸佛神力。转复明胜。是菩萨于法性问难。无能胜者。乃至无量无边百千万亿劫不可穷尽。佛子。譬如天金。以摩尼珠众宝间错。为自在天王严身之具。其余诸天所不能及。亦无夺者。菩萨住十地。智慧善根。从初地乃至九地所不能及。菩萨住是地。得大智照明。随顺一切智故。其余智慧所不能坏。譬如大自在天王光明。能令众生身心清凉。一切生处众生光明所不能及。菩萨摩诃萨亦如是。住法云地智慧光明。一切声闻辟支佛所不能及。乃至九地菩萨亦不能及。是菩萨住是地中。能令无量众生。住一切智道。佛子。菩萨住是地。十方诸佛为说三世智慧。法界智慧。一切世界智慧。普照住持一切世界智慧。大慈大悲普覆一切众生智慧。举要言之。具足为说至一切智道。佛子。是名菩萨摩诃萨第十法云地。菩萨住是地。多作摩醯首罗天王。智慧明达。善说声闻辟支佛菩萨波罗蜜。于法性中。有问难者。无能令尽。所作善业。布施爱语利益同事。皆不离念佛。不离念法。乃至不离念具足一切种智。常作是念。我当于一切众生。为首为胜。乃至于一切众生。为依止者。若欲如是勤行精进。于一念中。得无量百千万亿那由他不可说不可说世界微尘数三昧。乃至示尔所微尘数菩萨。以为眷属。若以愿力。神通自在。复过是数。所谓诸行上妙供具。信解起业。若身若口若光明。若诸根。若如意足。若音声。若行处。乃至若干百千万亿劫。不可称数

佛子。是菩萨十地次第顺行。趣向一切种智。如从阿耨达池四河流出。满足四天下无有穷尽。乃入大海。菩萨亦如是。从菩萨出于善根大愿之水。以四摄法。满足众生。而不穷尽。乃至一切种智。佛子。是菩萨十地因佛智故。而有差别。如因大地有十大山王。何等为十。所谓雪山王。香山王。轲梨罗山王。仙圣山王。由乾陀山王。马耳山王尼民陀罗山王斫迦罗山王宿慧山王。须弥山王。如雪山王。一切药草集在其中。而不可尽菩萨亦如是。住欢喜地。一切世间经书技艺文颂咒术。集在其中。无有穷尽。如香山王一切诸香集在其中。而不可尽。菩萨亦如是。住离垢地。持戒头陀威仪助法集在其中。无有穷尽。如轲梨罗山王。但以宝成。集诸妙华。取不可尽。菩萨亦如是。住于明地。集一切世间禅定神通解脱三昧。问不可尽。如仙圣山王。但以宝成。多有五通圣人。不可穷尽。菩萨亦如是。住于焰地。集令众生。入道因缘。种种问难。不可穷尽。如由乾陀山王。但以宝成。集夜叉大神。不可穷尽。菩萨亦如是。住难胜地。集一切自在如意神通。说不可尽。如马耳山王。但以宝成。集众妙果。取不可尽。菩萨亦如是。住现前地。集深因缘法。说声闻果。不可穷尽。如尼民陀罗山王。但以宝成。集一切大力龙神。不可穷尽。菩萨亦如是。住远行地。集种种方便智慧。说辟支佛道。不可穷尽。如斫迦罗山王。但以宝成。集心自在者。不可穷尽。菩萨亦如是。住不动地。集一切菩萨自在道。说世间性。不可穷尽。如宿慧山王但以宝成。集大神力。诸阿修罗。无有穷尽。菩萨亦如是。住善慧地。集转众生行智。说世间相。不可穷尽。如须弥山王。但以宝成。集诸天神。无有穷尽。菩萨亦如是。住法云地。集如来十力。四无所畏。说诸佛法。不可穷尽。是十宝山同在大海。因大海水。有差别相。菩萨十地亦如是。同在佛智。因一切智故。有差别相。佛子。譬如大海以十相故。名为大海。无有能坏。何等为十。一渐次深。二不受死尸。三余水失本名。四一味。五多宝。六极深难入。七广大无量。八多大身众生。九潮不失时。十能受一切大雨。无有盈溢。菩萨地亦如是。以十因缘故。无有能坏。何等为十。欢喜地中。渐生坚固愿。离垢地中。不与破戒共宿。明地中。舍诸假名。焰地中。于佛得一心不坏净信。难胜地中。生世间无量方便神通。起世间事。现前地中。观甚深因缘法。远行地中。以大广心。善观诸法。不动地中。能起大庄严示现。善慧地中。能得深解脱。通达世间行。如实不失。法云地中。能受一切诸佛大法明雨。佛子。譬如大摩尼宝珠。有十事能与众生一切宝物。何等为十。一出大海。二巧匠加治。三转精妙。四除垢秽。五以火炼治。六众宝庄严。七贯以宝缕。八置琉璃高柱。九光明四照。十随王意雨众宝物。菩萨发菩提心宝。亦有十事。何等为十。一初发心布施离悭。二修持戒头陀苦行。三以诸禅定解脱三昧令转精妙。四以道行清净。五炼以方便神通。六以深因缘法庄严。七以种种深方便智慧贯穿。八置神通自在幢上。九观众生行。放多闻智慧光明。十诸佛授智职。于一切众生。能为佛事。堕在佛数。佛子。是菩萨所行集一切智慧功德法门品。若不深种善根。不能得闻。问言。佛子。若得闻者。是人为得几所福。答言。随佛所有智慧势力。如是发萨婆若心所缘摄福德。是人得闻此法门。所得福德亦复如是。何以故。若无菩萨心。闻是法门。不能信解受持。何况以身修习能成其事。是故当知。是人随顺一切种智。得闻信解。受持修行。说是品时。十方世界。十亿佛国。微尘数世界。六种十八相动。以佛神力法如是故。诸天雨华。末香。璎珞。宝衣。幡盖。庄严身具。雨天妓乐歌颂而下。复有大音。赞叹十地殊胜之事。如此世界四天下他化自在天王宫说十地。十方一切世界皆亦如是。以佛神力故。十方过十亿佛国。微尘数刹。有十亿佛国。微尘数菩萨。诣此世界。遍满虚空。皆作是言。善哉善哉。金刚藏。善说菩萨十地之法。佛子。我等皆名金刚藏。发金刚德世界。金刚幢佛所来。所经历处。皆说是经。众会如是。言辞义趣亦如是。我等以佛神力故。来证是事。如我至此。十方一切世界。他化自在天王宫摩尼宝殿。皆有十亿佛国。微尘数菩萨。往为作证。亦复如是。时金刚藏菩萨。观察十方。观察一切大众。观察法界。赞叹初发萨婆若心。示菩萨境界。净菩萨行力。摄一切种智。随众生说。除一切世间垢秽。与众生一切种智因缘。示不可思议智慧庄严事。赞叹一切菩萨功德差别相。欲令诸地转胜明。显示众生故。承佛神力。以偈颂曰

  诸菩萨所行　　乐于善寂灭
  其心无所著　　犹若如虚空
  除贪恚痴垢　　安住于道智
  如是无上行　　愿乐欲听闻
  如是诸菩萨　　在于无量劫
  勤心常修习　　一切诸善根
  供养无量佛　　辟支阿罗汉
  为利众生故　　乃生菩提心
  精进持戒行　　头陀除罪垢
  修善忍转妙　　惭愧威德满
  福慧因缘故　　胜远心明净
  深乐于佛智　　同佛生菩提
  供养于一切　　十方三世佛
  如虚空等国　　悉皆令清净
  一切法平等　　善悉通达故
  为度诸众生　　发于菩提心
  诸菩萨如是　　生是无量心
  至于欢喜地　　息恶乐布施
  得诸本愿力　　增广慈悲心
  深行十善道　　能到离垢地
  戒闻功德备　　慈心愍世间
  永离诸垢秽　　深心常清净
  普观诸世间　　三毒火炽然
  如是之大士　　入第三明地
  观三界皆空　　无常亦如病
  如痈如疮箭　　无量苦常然
  见诸有为过　　贪乐佛功德
  得佛智明焰　　入于第四地
  成就于念慧　　得至于道智
  在此地供养　　百千诸如来
  常能思惟念　　诸佛无量德
  得入于一切　　世间难胜地
  能以慧方便　　种种而示现
  诸有所为作　　以利于世间
  供养于诸佛　　行益众生事
  无生法在前　　得入现前地
  菩萨诸所行　　一切世间知
  常无有我心　　有无皆悉离
  诸法先空寂　　十二缘故行
  善了此微妙　　入于远行地
  行慧方便等　　得法寂灭相
  如是之大士　　难知难可及
  为欲令世间　　得善寂灭故
  还起修诸行　　种种福德事
  普入于众生　　种种心行处
  如是能得入　　如空不动地
  大智诸菩萨　　善能悉具行
  种种诸智业　　得十自在力
  能以无有量　　无边限诸身
  普现十方界　　而为说妙法
  善达于世界　　及诸众生性
  如是大慈悲　　能入善慧地
  第一妙净智　　善观诸世间
  缕练烦恼业　　甚深诸难处
  为度是等故　　得诸佛法藏
  善说第一义　　悉无所违错
  如是次第行　　具足诸善法
  乃至于九地　　所修集福慧
  欲得诸佛力　　第一深妙利
  乃于一切佛　　得受智职位
  先得无数定　　智行极广大
  最后得难坏　　诸智位三昧
  若能得如是　　益智位三昧
  一切宝庄严　　莲华王即出
  菩萨称莲华　　现身坐其上
  余华诸菩萨　　咸共一心视
  尔时大菩萨　　从身放无量
  百千亿光明　　灭诸世间苦
  然后顶上出　　百千亿光明
  普照十方界　　诸佛大众会
  于上虚空中　　化成光明网
  供养诸佛已　　入诸佛足下
  时一切如来　　及诸大士等
  各知某菩萨　　得受于智职
  如是一切佛　　放眉间光明
  名益一切智　　入此菩萨顶
  一切无量佛　　与此菩萨职
  犹如转轮王　　授于太子位
  时十方世界　　普皆大震动
  乃至阿鼻等　　诸苦皆除灭
  菩萨具一切　　智慧得是职
  如是名为到　　无上法云地
  住于是地中　　智慧无边限
  善知度一切　　世间诸因缘
  入色无色法　　欲色无色界
  能知于众生　　国土及法性
  又能入可数　　不可数法中
  乃至能观察　　虚空无量性
  又此地悉知　　菩萨变化事
  诸佛威神力　　微细智密事
  又能悉通达　　一切诸劫数
  于一微尘中　　观见诸世界
  一切诸如来　　于此无上地
  初生及出家　　得道转法轮
  示入于涅槃　　皆随顺于智
  寂灭妙解脱　　悉得于此地
  此地诸大士　　忆念力大故
  诸佛大法雨　　皆悉能受持
  譬如大海水　　能持龙王雨
  诸佛广大法　　菩萨受亦尔
  若于一佛所　　一时听受法
  十方无量土　　微尘数众生
  皆多闻总持　　成于声闻乘
  不如是菩萨　　算数所不及
  以无量智慧　　及先大愿力
  能于一念中　　遍满无量国
  雨甘露法雨　　灭诸烦恼火
  是故诸如来　　名为法云地
  大士住此地　　供养诸佛具
  过诸天所有　　普示大神力
  示众转胜力　　过是数无量
  若人欲思量　　迷闷不能解
  大智住此地　　举足下足事
  一切诸菩萨　　乃至于九地
  皆悉不能知　　何况余众生
  三世诸声闻　　及与辟支佛
  住此诸佛示　　一切智慧事
  亦与令通达　　三世无碍智
  示法性寂灭　　亦示种种变
  一切诸世界　　所有众生类
  所行一切法　　深微隐远事
  一切佛功德　　次第示令知
  菩萨住此地　　能以大供具
  供养十方佛　　遍一切世界
  一切诸世间　　所有众生类
  其余诸供具　　皆所不能及
  智者住此地　　皆能破一切
  无明诸闇冥　　开示以佛道
  如自在天王　　光灭众热恼
  佛子智光明　　灭恶亦如是
  住是地多作　　三界自在王
  通达诸智慧　　善以三乘化
  能于一念中　　得无量三昧
  能见十方佛　　其数亦如是
  金刚藏菩萨　　告诸大士言
  我今略解说　　十地之妙行
  若广演说者　　千亿劫不尽
  是则名清净　　诸大菩萨地
  为得佛智故　　住于十地中
  安住不移动　　犹如大山王
  初地具一切　　经书诸技术
  犹如雪山中　　积聚众药草
  持戒及多闻　　在于二地中
  犹如香山王　　集一切香物
  如轲梨罗山　　多积诸宝华
  明地集闻智　　禅定亦如是
  焰地多积聚　　入道法不坏
  如仙圣山中　　善寂所游止
  五地诸神通　　无能得及者
  如由乾陀山　　多集夜叉众
  六地善分别　　诸果无穷尽
  犹如马耳山　　妙果无有量
  七地方便慧　　无有能及者
  如尼民陀罗　　诸龙王盈满
  住于八地中　　自在智无量
  如斫迦罗山　　多心自在者
  九地心清净　　说法无障碍
  犹如宿慧山　　阿修罗所止
  十地诸佛力　　功德无穷尽
  如须弥山王　　集一切天众
  又复初地中　　发于广大愿
  二地持戒品　　三地假名坏
  第四地专一　　五地众妙事
  六地甚深相　　七地广大心
  八地中种种　　庄严诸神通
  九地思妙智　　能过一切世
  十地能受持　　诸佛大法雨
  菩萨行大海　　难动不可尽
  发心出世间　　得入于初地
  二地净持戒　　三地修诸禅
  四地道行净　　五炼方便慧
  六因缘庄严　　七深方便慧
  八到琉璃幢　　九地观众生
  一切险难处　　智慧光普照
  十地受智职　　如珠随王意
  如是次第净　　菩提心妙宝
  十方诸世界　　所有微尘数
  可于一念中　　计知其多小
  可以一毫末　　数知于虚空
  诸佛大功德　　无量不可尽

大方广佛华严经卷第二十七大方广佛华严经卷第二十八

        东晋天竺三藏佛驮跋陀罗译

    十明品第二十三

尔时普贤菩萨摩诃萨告诸菩萨言。佛子。菩萨摩诃萨有十种明。何等为十。此菩萨摩诃萨。悉知三千大千世界众生心念。所谓善心。不善心。无记心。广心。狭心。恶心。胜心。顺生死心。背生死心。声闻心。缘觉心。菩萨心。声闻行心。缘觉行心。菩萨行心。天心。龙心。夜叉心。乾闼婆心。阿修罗心。迦楼罗心。紧那罗心。摩睺罗伽心。人心。非人心。地狱心。畜生心。饿鬼心。阎罗处众生心。诸难处众生心。如是等无量种种众生心。悉分别知。如是等百世界。千世界。百千世界。亿世界。百亿世界。千亿世界。百千亿世界。乃至百千亿那由他世界。广说乃至不可说不可说佛刹微尘数世界众生。悉能分别知其心念。佛子。是为菩萨摩诃萨第一善知他心智明。佛子。菩萨摩诃萨。悉知无量无数不可说不可说佛刹微尘数世界众生。死此生彼。善恶诸趣。若好若丑。若垢若净。若黑若白。如是等无量种种众生。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。微细众生。小众生。中众生。大众生。胜众生。如是等无量种种众生。死此生彼。菩萨摩诃萨。以无障碍明净天眼。悉能照见。随其业报所受苦乐。种种业。种种行。种种思愿。种种见。如业境界。如所回转。悉能睹见。佛子。是为菩萨摩诃萨第二无碍天眼智明。佛子。菩萨摩诃萨。忆宿命事。或自或他。悉能忆念。无量无数不可说不可说佛刹。微尘数世界众生。过去无量无数不可说不可说佛刹。微尘数劫事。如是生。如是名姓。如是食。如是苦乐。悉能了知。又忆过去无量无数不可说不可说佛刹。微尘数诸佛。如是名号。如是眷属。如是父母。如是侍者。如是声闻。如是最胜二大弟子。如是舍离王都。出家求道。如是菩提树下结跏趺坐得最正觉。如是住处。如是床座。如是说法。如是化度。如是寿命。如是作佛事已。入无余涅槃。佛灭度后。正法如是久住。悉能忆念。过去无量无数不可说不可说佛刹。微尘数佛。从初发心出生愿行。恭敬供养无量诸佛。教化调伏一切众生。大众眷属。转净法轮。随其寿命。示现神力。自在变化。无余涅槃。庄严塔庙。长养善根。乃至法住。佛子。是为菩萨摩诃萨第三深入过去际劫无碍宿命智明。佛子。菩萨摩诃萨。深入未来际劫。乃至无量无数不可说不可说佛刹。微尘数世界众生。未来生死。流转三有。知众生业。知众生报。知众生善。知众生不善。知众生出。知众生不出。知众生定。知众生不定。知众生正定。知众生邪定。知众生有使善根。知众生无使善根。知众生具足善根。知众生不具足善根。知众生摄取善。知众生摄取不善。知众生积集善。知众生积集不善。知众生积集恶法。知众生不积集恶法。知未来无量无数不可说不可说佛刹。微尘数世界诸佛。如是名号。如是眷属。如是父母。如是侍者。如是声闻。如是最胜二大弟子。如是舍离王都。出家求道。如是菩提树下结跏趺坐得最正觉。如是住处。如是床座。如是说法。如是化度。如是寿命。如是作佛事已。入无余涅槃。佛灭度后。正法如是久住。悉知未来无量无数不可说不可说佛刹。微尘数佛。从初发心出生愿行。恭敬供养无量诸佛。教化调伏一切众生。大众眷属。转净法轮。随其寿命。示现神力自在变化。无余涅槃。庄严塔庙。长养善根。乃至法住。佛子。是为菩萨摩诃萨第四深入未来际劫无碍智明。佛子。菩萨摩诃萨。出生无碍天耳。清净广大具足。不可称量。修习得证。明净离障。了达决定。菩萨成就无碍天耳。十方远近一切音声。欲闻不闻自在随意。于东方无量无数不可说不可说佛刹。微尘数诸如来。应供等正觉所说。所发。所开。所示。所制。所调伏。所教化。所念。所分别。所教。深妙善解。无量清净方便。如是一切悉能闻持。善义善味。随众。随人。随音声。随智。随识。随所化度所得功德。随境界。随所依。随出道。悉能闻持。无有忘失。广说妙法。度脱一切。乃至不失一句一味。如东方。一切十方亦复如是。佛子。是为菩萨摩诃萨第五无碍清净天耳智明。佛子。菩萨摩诃萨。安住无畏神力智明。逮得自在无作神力。平等神力。广大神力。无量神力。无依神力。念至神力。不转神力。不退转神力。无尽神力。不可坏神力。长养神力。随顺行神力。若闻十方无量阿僧祇世界。无边世界。无分齐世界。不可称量世界。不可思议世界。不可度量世界。乃至不可说不可说佛刹。微尘等一切世界现在诸佛。闻已悉能往诣彼诸佛所。恭敬礼拜。赞叹供养。深知如来清净佛刹。种种庄严。种种功德。无量功德。皆悉充满。示现无量自在。无量境界。赞叹一切如来恭敬供养。示现其身。悉在十方一切佛所。亦不离此。而往到彼。悉自了知。诣诸佛所。恭敬礼拜。赞叹供养。问菩萨法。出生佛智。见诸佛刹眷属变化。知说法相。知佛刹相。悉无所著。于一切事。皆悉究竟。到于彼岸。无损神力。速遍十方一切世界。无佛不见。无法不闻。无众不知。常闻正法。未曾断绝。乐求佛法。胜愿成满。具足修习普贤菩萨无量诸行。佛子。是为菩萨摩诃萨第六安住无畏神力智明。佛子。菩萨摩诃萨。于无量无数不可说不可说佛刹。微尘数世界众生音声语言。悉能了知。所谓中国言音。边国言音。天言音。龙言音。夜叉言音。乾闼婆言音。阿修罗言音。迦楼罗言音。紧那罗言音。摩睺罗伽言音。人言音。非人言音。如是等不可说不可说种种众生言音不同。菩萨摩诃萨悉能了知。善分别知。入一切施设。深入解了一切世谛。悉知种种诸言音法。分别了知诸言音法。入一切种言音大海。菩萨摩诃萨随其所入。游行世界。悉能了知此世界中众生之性。知其性已。悉解一切诸言音法。如日天子出照一切色。令有眼者。悉见色相。菩萨摩诃萨亦复如是。悉入一切诸言音云。善知一切诸言音法。佛子。是为菩萨摩诃萨第七分别一切言音智明。佛子。菩萨摩诃萨知一切色。法不生色。无种种色。无虚妄色。无青黄赤白等形色。而菩萨摩诃萨入深法界。住持变化种种形色。无量色。明净色。清净色。普现色。似彼色。普照色。所得色。无染污色。具足相色。清净相色。离恶色。大力色。尊重色。无穷色。无尽色。杂色。端严色。不可称量色。善学色。善长养色。成熟色。随化度色。无碍色。明彻色。离垢色。澄净色。正身色。不可思议方便色。不可坏色。最胜色。离曀色。离闇色。牢强色。善杂色。功德相色。姿好色。大我色。境界色。善调伏色。清净正直色。上色。胜广色。不可断色。无所依色。无等色。充满不可说佛刹色。长养色。最坚固色。胜色。恶色。胜功德色。随希望色。清净性色。常善色。善决定色。无障色。虚空明净色。清净长养色。无垢色。离尘色。离种种尘色。善示现色。普应现色。随时示现色。寂静色。离欲色。功德福田真实色。安隐色。离恐怖平等威仪色。超越智慧色。无碍身色。遍游行身色。离愚痴色。大慈等起色。大悲受持色。出正趣色。具足功德力色。随正念色。无量宝色。明净藏色。令一切众生欢喜色。一切智门色。欢喜眼色。一切宝庄严无比色。不着心色。不坚固色。住持自在色。种种神力自在色。如来家生色。无比色。充满法界色。随众往诣色。种种色。具足色。善行色。随化究竟色。见无厌足色。无量杂光色。放无量阿僧祇焰光色。不可说种种光色。不可思议香光普熏三界色。不可量日光焰色。不可称月形像色。放无量乐华云色。种种宝华鬘庄严云色。过一切世间一切香焰普熏色。出生一切如来功德藏色。无量音声广说一切法显现色。一切种行具足普贤菩萨色。佛子。菩萨摩诃萨。入无色法界。住持变化种种形色。随所应故。所谓见教化。正念教化。转法轮教化。随时教化。念念教化。亲近教化。随逐教化。神力教化。种种自在教化。不可思议大神变教化。悉能度脱一切众生。佛子。是为菩萨摩诃萨第八出生无量阿僧祇色身庄严智明。佛子。菩萨摩诃萨。悉知诸法无有名字。知一切法悉无有性。知一切法无来无去。知一切法别异。知一切法无别异。知一切法不二非不二。知一切法无我。知一切法无比。知一切法不生。知一切法不灭。知一切法无所从来去无所至。知一切法无坏。知一切法不实。知一切法非不实。知一切法一相无相。知一切法非有。知一切法非无。知一切法非法。知一切法非非法。知一切法非语言。知一切法。非非语言。知一切法非业。知一切法非非业。知一切法非报。知一切法非无报。知一切法非作。知一切法非不作。知一切法非第一义。知一切法非出。知一切法非不出。知一切法非量。知一切法非无量。知一切法非世间。知一切法不离世间。知一切法非因生。知一切法非无因生。知一切法非定色。知一切法非不定色。知一切法不具足色。知一切法非不具足色。知一切法不出生死。知一切法非不出生死。知一切法非虚妄。知一切法非不虚妄。知一切法非方便非不方便。菩萨摩诃萨。知如是诸法故。不着世谛。不着第一义谛。不虚妄取诸法。不起诸文字。随顺寂灭性。不舍一切愿。见第一实义。决定知诸法。兴无量法云。普雨一切甘露法雨。入不可说方便。度不可说方便。以无尽辩才。广说如实义。不违真法。善巧方便说一切法。辩才无尽。成就大慈悲。无文字境界。出生文字。义不坏文字性。观察诸法悉从缘起。无所染着。解了一切诸语言法。开发示导。称扬显现。具足清净。灭众疑网。摄取众生。不舍实法。于不二法。而不退没。具足成就无碍法门微妙音声。普雨法雨。未曾失时。佛子。是为菩萨摩诃萨第九一切诸法真实智明佛子。菩萨摩诃萨。于念念中。入灭一切法三昧正受。而不退转。亦不舍菩萨事。不舍大慈悲心。不舍诸波罗蜜。善能分别诸佛刹土。而无厌足。不舍大愿。度脱众生。不舍转法轮。不舍教化调伏众生。不舍供养恭敬一切诸佛。不舍一切诸法自在法门。不舍常见一切诸佛。不舍常闻诸佛正法。悉能出生一切无碍法。知一切法皆悉平等。具足成就一切诸佛胜法诸愿。深入一切佛刹。究竟一切诸佛种性彼岸。于一切世界。悉能善学一切所学。一切法相深入法相。善知诸法悉从缘起。了一切法无有真实。随顺世间诸语言法。于一切法无所染着。随其所应。方便演说一切诸法。菩萨摩诃萨。于一切法灭尽正受。或住一劫或住百劫。或住百千劫或住亿劫。或住百亿劫。或住百千亿劫。或住亿那由他劫或住百亿那由他劫。或住千亿那由他劫。或住百千亿那由他劫。或住无量劫。或住无边劫。或住阿僧祇劫。或住不可思议劫。或住不可称量劫。或住无分齐劫。或住不可说不可说劫。常在灭一切法三昧正受。颜容无异。体无羸损。亦不坏散。不可烧。不可没。不可失。不可尽。于有于无。悉无所作。悉能成办诸菩萨事。广能演说一切诸法。教化众生。未曾失时。长养一切诸如来法。满足一切诸菩萨行。不舍饶益一切众生。应化十方。未曾暂息。不舍普照一切诸趣。于正受地。寂然不动。佛子。是为菩萨摩诃萨第十一切诸法灭定智明。菩萨摩诃萨安住此明。一切天人不能思议。一切世间不能思议。声闻缘觉不能思议。下地菩萨不能思议。身口意业不可思议。一切三昧自在不可思议。智慧境界不可思议。唯有如来乃能演说此人功德。余无能说。佛子。是为菩萨摩诃萨十种智明。此菩萨摩诃萨住此智明。悉得三世无碍智明

    大方广佛华严经十忍品第二十四

尔时普贤菩萨摩诃萨。复告诸菩萨言。佛子。菩萨摩诃萨成就十种忍。能得一切无碍忍地。又得一切诸佛无尽无碍之法。何等为十。所谓随顺音声忍。顺忍。无生法忍。如幻忍。如焰忍。如梦忍。如响忍。如电忍。如化忍。如虚空忍。佛子。是为菩萨摩诃萨十种忍。过去诸佛已说。未来诸佛当说。现在诸佛今说。佛子。何等为菩萨摩诃萨随顺音声忍。若闻真实法。不惊。不怖。不畏。信解受持。爱乐顺入。修习安住。佛子。是为菩萨摩诃萨第一随顺音声忍。佛子。何等为菩萨摩诃萨顺忍。佛子。此菩萨随顺寂静。观一切法。平等正念。不违诸法。随顺深入一切诸法。清净直心。分别诸法。修平等观。深入具足。佛子。是为菩萨摩诃萨第二顺忍。佛子。何等为菩萨摩诃萨无生法忍。佛子。此菩萨不见有法生。不见有法灭。何以故。若不生则不灭。若不灭则无尽。若无尽则离垢。若离垢则无坏。若无坏则不动。若不动则寂灭地。若寂灭地则离欲。若离欲则无所行。若无所行则是大愿。若是大愿则住庄严。佛子。是为菩萨摩诃萨第三无生法忍。佛子。何等为菩萨摩诃萨如幻忍。佛子。此菩萨深入诸法皆悉如幻。观缘起法。于一法中。解众多法。众多法中。解了一法。菩萨摩诃萨于彼诸法。分别诸刹。入众生界法界。等观世间。等观佛出入不二入。出生住持。譬若如幻。非象兵马兵车兵步兵。非男非女。非童男童女。非树非叶。非华非果。非地水火风。非昼非夜。非半月一月。非年岁。非百年。非月非日。非劫数。非定非乱。非一非异。非纯非杂。非好非恶。非多非小。非量。非无量。非粗非细。种种众非幻。幻非种种众。但以幻故。示众色像。菩萨摩诃萨亦复如是。观一切世间皆悉如幻。所谓业世间。烦恼世间。佛刹世间。法世间。三世世间。流转世间。成世间。坏世间。行世间。菩萨摩诃萨。观察一切世间悉如幻时。不起众生。不坏众生。不起诸刹。不坏诸刹。不起诸法。不坏诸法。不取过去虚妄相。不作当来。不转当来。现在不住。亦无所著。不观察菩提。不虚妄取菩提。不取佛兴世。亦无佛涅槃。不住大愿。不取清净离生平等。无出无著。出生严净佛刹。决定知真法。出生众生界。分别知众生。决定知法界。住正法不动。等入三世。而亦不违分别三世。出生阴入。除灭所依。度脱众生。等观法界无有差别。知一切法非文字。非言说。而亦不舍诸深妙辩。不着化众生。而转法轮。为众生故。受持大悲。度脱一切。说过去因缘。实知诸法。而无所至。佛子。是为菩萨摩诃萨第四如幻忍。佛子。何等为菩萨摩诃萨如焰忍。佛子。此菩萨觉悟一切世间皆悉如焰。如热时焰。无有方处。菩萨摩诃萨。决定了知一切诸法。亦无方处。非内非外。非有非无。非常非断。观一切法。皆悉真实假名施设。非一色。非种种色。非无色地。具足证知一切诸法。佛子。是为菩萨摩诃萨第五如焰忍。佛子。何等为菩萨摩诃萨如梦忍。佛子。此菩萨解一切世间皆悉如梦。譬如梦非世间。非离世间。非欲界。非色界。非无色界。非生非死。非净非秽。非清非浊。而有示现。如是菩萨摩诃萨。觉悟一切世间皆悉如梦。不坏梦。不着梦。梦性寂灭。梦无自性。受持一切法。皆悉如梦。不坏梦。不虚妄取梦。觉悟一切世间皆悉如梦。佛子。是为菩萨摩诃萨第六如梦忍。佛子。何等为菩萨摩诃萨如响忍。佛子。此菩萨出生诸法。善学成就。究竟圣法。得到彼岸。知一切法皆悉如响。分别众声。犹如呼响。而无所至。菩萨摩诃萨解如来音。不从内出。不从外出。不从内外出。彼闻音者。不在内。不在外。亦不在内外。而能出生巧方便智。了声如响悉从缘起。亦不坏法施。深入音声。远离颠倒。善学一切。如帝释后。于一音中。出千妙音。而亦不取虚妄音声。菩萨摩诃萨亦复如是。入离虚妄法界。出生巧妙方便音声。于无量无边世界。广为众生转净法轮。度脱一切。受持如来广长舌相。出生无量无障碍音。充满十方一切世界。普令众生。悉得开解。发起善根。而音声无转。不可言说。知音声非语言。而随顺语言。亦不染着种种音声。觉悟了知一切音声。佛子。是为菩萨摩诃萨第七如响忍。佛子。何等为菩萨摩诃萨如电忍。佛子。此菩萨不生世间。不死世间。不内世间。不外世间。不行世间。非不行世间。不坏世间。非不坏世间。不起世间趣。不离世间趣。不等世间。非不等世间。非世间。非离世间。不行菩萨行。而不舍大愿。非实。非虚。所行真实。究竟一切如来正法。能办一切世间诸事。亦不随顺世间流转。亦不受持正法流转。譬如电或日。或月。山树男女。室宅墙壁。大地流水等。皆悉能照。令明净故譬水油身宝珠明镜。如是等一切清净色。悉能照明一切净界。电不离明净。明净不离电。电能远照。而电非远近。菩萨摩诃萨亦复如是。能照彼我一切境界。而其智慧不作分别。照现彼我一切境界。如种子中无有根芽茎节枝叶。而能为因。菩萨摩诃萨亦复如是。于不二法中。分别二相。修无碍际。佛子。是为菩萨摩诃萨第八如电忍。若菩萨摩诃萨成就此忍。虽不往诣诸如来所。而悉普现一切佛刹。不起此世界。不至一切世界。菩萨现身遍一切世界。如电光现。游行无碍。普至十方。金刚诸山坚固之物所不能障。具足成就佛家清净身口意业得无量清净一切色身。佛子。何等为菩萨摩诃萨第九如化忍。佛子。此菩萨知一切世间皆悉如化。所谓一切众生业化。一切众生行化。一切虚妄化。一切苦乐颠倒化。一切妄取化。一切世间无实法化。一切语言道化。一切烦恼化。诸想所起故。调伏众生化。离垢清净故。三世不退转化。无生平等故。菩萨愿化。长养菩萨行故。如来大悲化。除灭众生一切苦故。法轮方便智化。出生无量无畏智辩故。佛子。是为菩萨摩诃萨解知世间离世间化。决定知广大。知无量无际等。知如如。具足成就无量自在。于真实中。而不倾动。悉见一切无有真实。而不坏所行。譬如化不从心起。不住心中生。不由业起。亦不受报。非世间生。非世间灭。非法所摄。非法所触。非是久住。非须臾住。非世间行。非离世间。非游诸方。非诸方所摄。非量。非无量。非厌。非无厌。非休息。非无休息。非凡非圣。非净非秽。非生非死。非愚非智。非见非失。不依世间。非法界所摄。非黠慧。非愚蒙。非炽然。非寂灭。非生死。非涅槃。非有非无。如是菩萨摩诃萨处于世间。行菩萨行。受持方便。观察世间皆悉如化。不着世间。亦不着化。不妄取世间。亦不取化。不住世间。不灭世间。不住正法。不随非法。而不舍教化众生。一向正念。具足诸愿。不庄严诸法。亦复不坏诸庄严法。于一切法。悉无所有。悉能具足一切佛法。譬如化非有非无。菩萨摩诃萨亦复如是。安住如化忍中。悉能具足诸佛菩提。饶益众生。佛子。是为菩萨摩诃萨第九如化忍。佛子。若菩萨摩诃萨成就此忍。于一切佛刹。无所依着。譬如化于一切世界。无所依着。于一切佛法。不虚妄行。譬如化行无所行。离诸颠倒。譬如化非身示现一切身。譬如化。不依色。示现一切色。譬如化不着实际。平等满足自性无性。譬如化非解脱法。悉能示现一切法处。譬如化无处所性。亦非调伏。亦非清净。譬如化离一切神力。往诣一切诸如来所。譬如化不可退转。不生不灭。悉离挂碍。一切诸力金刚诸山所不能障。佛子。何等为菩萨摩诃萨第十如虚空忍。佛子。此菩萨解一切法界。犹如虚空。以无性故。譬如虚空。一切世界亦复如是。解一切佛刹无所起故。譬如虚空。一切诸法亦复如是。解无二法故。譬如虚空。一切众生行亦复如是。解行无所行故。譬如虚空。一切佛法亦复如是。解无分别故。譬如虚空。一切佛力亦复如是。解无异故。譬如虚空。一切诸禅亦复如是。解三世故。譬如虚空。一切说法亦复如是。解不可说故。譬如虚空。一切佛身亦复如是。解无碍故。譬如虚空。遍一切处。解一切法。如虚空故。佛子。如是菩萨摩诃萨。解一切法悉如虚空。得虚空等忍智。得虚空等身。得虚空等身业。得虚空等口。得虚空等口业。得虚空等心。得虚空等心业。譬如虚空不生不死。菩萨摩诃萨亦复如是。一切法身。不生不死。譬如虚空不可破坏。菩萨摩诃萨亦复如是。智慧诸力不可破坏。譬如虚空一切世间之所依止。而无所依。菩萨摩诃萨亦复如是。一切诸法之所依止。而无所依。譬如虚空不生不灭。悉为一切生灭所依。菩萨摩诃萨亦复如是。非向非成。令一切众生。皆悉清净。譬如虚空非方非非方。而能示现诸海分际。菩萨摩诃萨亦复如是。非业非业报。而能演说一切生死大海分际。譬如虚空非行非住。而能示现种种威仪。菩萨摩诃萨亦复如是。非行非住。而能分别一切诸行。譬如虚空非色非无色。而能示现百千诸色。菩萨摩诃萨亦复如是。非世间色。非离世间色。而能示现一切诸色。譬如虚空非久住非须臾住。菩萨摩诃萨亦复如是。非久趣向非须臾趣向。能广演说一切菩萨之所住行。譬如虚空非净非秽。菩萨摩诃萨亦复如是。非世间障覆。亦非清净。譬如虚空一切世间皆谓现前实非现前。菩萨摩诃萨亦复如是。一切诸法现菩萨前。而于菩萨无所现前。譬如虚空住一切处。而虚空无分齐。菩萨摩诃萨亦复如是。住一切法。而菩萨心无有分齐。何以故。菩萨摩诃萨。思惟自己善根。犹如虚空。善根清净。善根具足。善根平等。善根一分。善根寂灭。善根一味。善根一量。善根清净。如虚空色善根。趣一切道。不忘一切法。得一切不坏法。游行一切刹。具足一切身。而于诸身。悉无所著。普于十方。永离痴惑。具足成就不可坏力。满足一切功德境界。得一切种法。得深乐法。得虚空等金刚善根。出生一切诸妙音声。一切世间常转法轮。未曾失时。佛子。是为菩萨摩诃萨第十如虚空忍。若菩萨摩诃萨成就此忍。得无来身。以无去故得不生身。以不灭故。得不聚身。以无散坏故。具足不实身。以无真实故。得一相身。以无相故。得无量身。以佛力无量故。得平等身。以如相故。得不坏身。以等观三世故。得至一切处身。以净眼普照无障碍故。得离欲际身。以一切法无合散故。得虚空际功德藏。以无尽故。得无穷尽平等法辩。以一切法性如虚空一性故。得无量无碍。微妙音声。以无碍如虚空故得清净具足一切菩萨行巧妙方便。以一切法无碍清净如虚空故。得一切佛法海。以不可断如虚空故。得受持一切佛刹。以无量如虚空离贪欲故。得一切法示现自在未曾休息。以坚固如虚空故。得不可坏坚固法身。以如虚空能持一切世间故。具足成就不可沮坏金刚诸根。以示现一切世间成败故。得具足力能持一切世间。以受持智慧如虚空故。佛子。是为菩萨摩诃萨十种忍。尔时普贤菩萨。欲重宣此义。为诸菩萨。以偈颂曰

  譬如世有人　　闻有宝藏处
  闻已大欢喜　　宝藏可得故
  如是大智慧　　菩萨真佛子
  佛深寂灭法　　闻已大欢喜
  闻彼深法已　　其心不恐怖
  亦不生惊畏　　不退亦不没
  菩萨向菩提　　闻此寂灭音
  堪忍寂灭法　　于彼不生疑
  我作一切智　　天人尊导师
  以闻甚深法　　其心堪忍故
  彼闻寂灭音　　踊跃大欢喜
  一心乐专求　　一切诸佛法
  修习调伏心　　正直求菩提
  长养诸善根　　而不坏法性
  堪忍寂灭法　　随顺彼音声
  修习菩萨行　　安住音声忍
  转求胜妙道　　出生诸善法
  精进不退转　　究竟成菩提
  闻此妙音声　　菩提心清净
  得勇健善根　　令诸佛欢喜
  譬如功德人　　获大珍宝藏
  随顺身所宜　　造诸庄严具
  慧者亦如是　　闻此深法义
  增广智慧海　　随顺求诸法
  决定随顺法　　分别无所有
  随顺于真如　　得彼真实法
  得净自在心　　明彻大欢喜
  解了一切法　　悉从众缘起
  修习平等法　　分别性非性
  不坏佛法藏　　正觉一切法
  正直心坚固　　庄严净菩提
  不动如须弥　　一向求佛道
  修习深三昧　　精进不懈怠
  无量劫修行　　未曾有退失
  最胜甚深海　　究竟到彼岸
  尽诸法原底　　远离众恐怖
  等心观诸法　　如无等所说
  成就随顺忍　　平等智满足
  具足顺忍门　　顺佛之所说
  随顺真实智　　不分别法相
  三十三天中　　彼诸天子等
  共一宝器食　　所食各不同
  诸天种种食　　不从十方来
  随彼所修业　　自然食在器
  菩萨亦如是　　观察一切法
  悉从因缘起　　不生亦不灭
  若法不生灭　　是法不可尽
  了达其成败　　清净不可坏
  实际不可坏　　悉寂灭如如
  金刚愿饶益　　具佛无碍智
  专念寂灭法　　其心未曾离
  随顺世间行　　长养大悲愿
  具足诸愿力　　不着于世间
  成就甚深智　　随顺广说法
  是名无生忍　　解诸法无尽
  了达悉如如　　法界无所起
  菩萨住此忍　　一切十方界
  现在无量佛　　皆悉授彼记
  乐观寂灭法　　出生诸善根
  一念达三世　　调伏净众生
  观察诸世间　　解了悉如幻
  寂灭无所有　　于彼无染着
  诸色从心造　　示现犹如幻
  虚空非真实　　一切有如幻
  譬如工幻师　　四衢现众像
  众生见欢喜　　而实无所有
  世间亦如是　　一切皆如幻
  有无等诸法　　了知悉虚妄
  度脱一切众　　解了悉如幻
  善能平等知　　众生幻无异
  众生诸佛刹　　三世一切法
  无量诸世间　　悉了义如幻
  譬如工幻师　　示现种种形
  男女象马牛　　园林华果等
  幻无所染着　　亦无有住处
  幻法无真实　　所现悉虚妄
  佛子亦如是　　观察诸世间
  有无一切法　　了达悉如幻
  众生诸佛刹　　种种业所造
  觉悟如幻际　　于彼无所著
  菩萨摩诃萨　　常乐寂静法
  深入真实地　　究竟住法界
  随顺向正法　　最胜法化生
  善解一切想　　缠网群生类
  想如热时焰　　令众生颠倒
  菩萨善知想　　能离一切倒
  世间各别异　　形类悉不同
  佛子善明达　　了相非真相
  十方诸群生　　悉为想网覆
  菩萨慧眼净　　善见世间想
  世间犹如焰　　妄想取世间
  能断世间想　　则离三种倒
  譬如热时焰　　众生于远见
  妄想谓为水　　其实非真水
  众生亦如是　　虚妄取世间
  想如热时焰　　无碍心境界
  分别一切想　　成就无碍智
  想缚群生类　　勇健能解脱
  远离放逸慢　　除灭世间想
  究竟尽无尽　　无尽者方便
  彼能解世间　　一切法如梦
  梦性无方处　　世间亦如是
  解法离虚妄　　寂灭心无异
  明了世间行　　三世皆如梦
  梦非生死法　　非有亦非无
  三有悉如梦　　寂灭心无缚
  解世如梦性　　不依于世间
  观世间寂灭　　不染着诸趣
  明见一切世　　不起虚妄倒
  善解法如梦　　逮得如梦忍
  众生于梦见　　种种诸异相
  悉知从心造　　而实无所有
  智月如是见　　众生皆如梦
  晓了如梦已　　离一切虚妄
  菩萨方便解　　一切法如梦
  梦性无真实　　非一亦非异
  众生一切法　　佛刹诸行业
  菩萨悉明了　　一切皆如梦
  随一切垢净　　悉能如实知
  解知世如梦　　不取虚妄相
  菩萨所行行　　一切诸妙愿
  明解悉如梦　　于彼无所著
  决定解诸法　　及一切世间
  菩萨能善知　　其性皆如梦
  世间生灭法　　众生去来相
  解了净如梦　　其性无忘失
  随顺如梦行　　亦不坏世间
  了达诸威仪　　如修短无实
  是名如梦忍　　解了一切法
  成就无碍智　　度脱一切众
  菩萨摩诃萨　　广行无量行
  出生于一切　　正觉平等法
  种种诸方便　　解法真实相
  诸法无去来　　于彼心无著
  一切众生类　　无量诸音声
  菩萨深觉悟　　了之悉如响
  菩萨知音声　　非是内外法
  谛了诸音声　　一切皆如响
  一切诸音声　　皆悉是虚妄
  菩萨知非实　　于彼无所著
  菩萨悉睹见　　十方一切佛
  又闻彼如来　　梵音演说法
  彼诸大导师　　广说修多罗
  菩萨闻法音　　其心无所著
  所闻声如响　　悉无所从来
  分别一切音　　善解无坏法
  分别诸音声　　善解一切法
  解声非是声　　出无量净音
  观察一切法　　皆悉离音声
  种种语言际　　悉能善了知
  菩萨于众生　　了之悉如响
  如是能深解　　一切诸众生
  菩萨善随顺　　明达语言道
  解了一切世　　种种诸音声
  了知音声性　　常乐寂静地
  明解诸世间　　一切悉如响
  犹如语言道　　宣明种种法
  众生乐染着　　虚妄之音声
  如彼音声相　　世间亦如是
  众生相亦然　　真佛子明觉
  如此真实相　　明智之忍力
  令音净微妙　　解世皆寂灭
  彼于三世中　　了达语言道
  不取虚妄声　　其心无所著
  寂静定意为世间　　一向专求佛菩提
  未曾虚妄取世间　　心常欣乐寂灭法
  观察世间无有余　　皆悉寂灭无自性
  专求菩提为众生　　具足智力大慈悲
  不受一切世间生　　亦不解脱于世间
  一切世间无所依　　亦复不离依世间
  解知众生诸法性　　于彼法性不染着
  于诸众生无所依　　清净解脱而无缚
  于一切趣知实性　　世间生死流转法
  菩萨解法无有二　　于不二法无所著
  其心不住诸世间　　又亦不离于世间
  所行不在世间外　　了知诸法真实相
  譬如水中电光色　　彼色非内亦非外
  菩萨饶益众生故　　演说世间无真实
  众生无缚无解脱　　一切世间不可说
  世间非内亦非外　　如彼水中电光像
  如是清净离垢心　　随顺甚深微妙行
  具足智慧法灯明　　成满诸愿不退转
  智慧成就不可量　　常能饶益一切众
  安立众生无畏法　　除灭一切诸障碍
  修习甚深法　　饶益一切众
  此忍增妙智　　具足菩萨行
  深入寂灭法　　谛了悉如化
  示现无量行　　而实无所行
  胜地修菩提　　随顺如化行
  如化常寂灭　　菩萨行亦然
  了知众生类　　及无量行业
  平等悉如化　　解脱亦如是
  明解三世佛　　一切悉如化
  无量本行愿　　化成诸导师
  大慈悲弥广　　化众生清净
  清净即是化　　化力持应现
  世间悉虚妄　　菩萨解如化
  化性诸世间　　种种业庄严
  变化藏严饰　　究竟菩萨行
  随世诸行业　　种种杂无量
  化是虚妄法　　出生化虚妄
  菩萨所行法　　皆悉离虚妄
  化智海决定　　化印印世间
  化非生灭法　　智慧亦如是
  第十忍明观　　清净如虚空
  虚空众生法　　等观无别异
  智满如虚空　　除灭诸障碍
  虚空性无杂　　世间亦如是
  成就空忍力　　如空不可尽
  境界如虚空　　不取虚妄相
  虚空无自性　　虚空不可断
  虚空无种种　　智力亦如是
  譬如虚空性　　无有初中后
  虚空无异性　　智慧亦如是
  如是正观法　　皆悉如虚空
  无生亦无灭　　平等观诸法
  安住虚空法　　广为十方说
  虚空方便忍　　调伏一切魔
  虚空无自性　　世间亦如是
  有性无性法　　平等如虚空
  一方便庄严　　观世间虚空
  悉知三世法　　犹如虚空性
  菩萨智慧身　　音声如虚空
  身性亦虚空　　安住虚空智
  是名十种忍　　佛子具足行
  心安住忍力　　广为十方说
  真佛子善学　　超成智慧力
  法力定智力　　随顺修菩提
  深入此忍门　　成就无碍智
  调伏一切恶　　转无上法轮
  安住无量法　　一切莫能知
  调御师智海　　菩萨尽原底
  谦下行菩提　　得此深法忍
  妙法清净意　　悉满一切愿
  一切众生类　　诸佛刹微尘
  悉可算其数　　菩萨德难知
  若有真佛子　　成此十种忍
  一切诸众生　　无能知境界

大方广佛华严经卷第二十八大方广佛华严经卷第二十九

        东晋天竺三藏佛驮跋陀罗译

    心王菩萨问阿僧祇品第二十五

尔时心王菩萨白佛言。世尊。所谓阿僧祇。不可量。无分齐。无周遍。不可数。不可称量。不可思议。不可说。不可说不可说。世尊。云何阿僧祇。乃至不可说不可说耶。佛告心王菩萨言。善哉善哉。善男子。饶益众生故。乃能问此如来应供等正觉。佛智境界甚深之义。善男子。汝今谛听。我当说之。尔时心王菩萨白佛言。世尊。唯然善听。佛告心王菩萨言。百千百千名一拘梨。拘梨拘梨名一不变。不变不变名一那由他。那由他那由他名一鞞婆逻。鞞婆逻鞞婆逻名一作。作作名一来。来来名一胜。胜胜名一复次。复次复次名一阿婆逻。阿婆逻阿婆逻名一得胜。得胜得胜名一分界。分界分界名一充满。充满充满名一量。量量名一解。解解名一此解。此解此解名一离欲。离欲离欲名一舍。舍舍名一聚。聚聚名一通。通通名一频申。频申频申名一网。网网名一众流。众流众流名一出。出出名一分。分分名一分别。分别分别名一称。称称名一持。持持名一不颠倒。不颠倒不颠倒名一不幡。不幡不幡名一正。正正名一慧。慧慧名一第一。第一第一名一觉。觉觉名一毗遮妒。毗遮妒毗遮妒名一极高。极高极高名一妙。妙妙名一逻婆。逻婆逻婆名一诃梨婆。诃梨婆诃梨婆名一解脱。解脱解脱名一黄。黄黄名一诃梨那。诃梨那诃梨那名一因。因因名一贤觉。贤觉贤觉名一明相。明相明相名一摩楼陀。摩楼陀摩楼陀名一忍。忍忍名一枝。枝枝名一摩楼摩。摩楼摩摩楼摩名一等。等等名一离疑。离疑离疑名一种。种种名一不放逸。不放逸不放逸名一摩多罗。摩多罗摩多罗名一动。动动名一到。到到名一说。说说名一白。白白名一了别。了别了别名一究竟。究竟究竟名一清凉。清凉清凉名一阿罗。阿罗阿罗名一潮。潮潮名一油。油油名一只逻。只逻只逻名一味。味味名一泥逻。泥逻泥逻名一戏。戏戏名一斯罗。斯罗斯罗名一聚沫。聚沫聚沫名一弥罗。弥罗弥罗名一坚固。坚固坚固名一风。风风名一满。满满名一不可称量。不可称量不可称量名一根。根根名一微细。微细微细名一莲华。莲华莲华名一摩伽婆。摩伽婆摩伽婆名一不可度。不可度不可度名一醯楼。醯楼醯楼名一语。语语名一劫。劫劫名一婆婆。婆婆婆婆名一间。间间名一无间。无间无间名一离垢。离垢离垢名一实胜。实胜实胜名一弥罗覆。弥罗覆弥罗覆名一遮摩罗。遮摩罗遮摩罗名一法。法法名一波罗摩驮。波罗摩驮波罗摩驮名一决定。决定决定名一流转。流转流转名一广说。广说广说名一无尽。无尽无尽名一等真实。等真实等真实名一无我。无我无我名一阿槃陀。阿槃陀阿槃陀名一青莲华。青莲华青莲华名一数。数数名一趣。趣趣名一受。受受名一阿僧祇。阿僧祇阿僧祇名一阿僧祇转。阿僧祇转阿僧祇转名一无量。无量无量名一无量转。无量转无量转名一无分齐。无分齐无分齐名一无分齐转。无分齐转无分齐转名一无周遍。无周遍无周遍名一无周遍转。无周遍转无周遍转名一无数。无数无数名一无数转。无数转无数转名一不可称。不可称不可称名一不可称转。不可称转不可称转名一不可思议。不可思议不可思议名一不可思议转。不可思议转不可思议转名一不可量。不可量不可量名一不可量转。不可量转不可量转名一不可说。不可说不可说名一不可说转。不可说转不可说转名一不可说转转。尔时世尊。为心王菩萨。以偈颂曰

  不可言说不可说　　充满一切不可说
  不可言说诸劫中　　说不可说不可尽
  不可言说诸佛刹　　皆悉尽末为微尘
  悉于一一微尘中　　演说一切不可说
  悉能善于一念中　　说不可说诸世界
  不可称说诸劫中　　念念次第而演说
  不可说劫犹可尽　　而不可说不可尽
  悉于一一微尘中　　分别演说不可说
  不可说劫犹可尽　　而不可说不可尽
  不可言说微尘中　　悉有不可说众生
  皆共赞叹普贤德　　犹尚不能令穷尽
  设使一微毛端处　　有不可说诸普贤
  彼诸一切普贤等　　说不可说不能尽
  如一微细毛端处　　十方世界亦如是
  于彼一一毛端处　　置不可说诸佛刹
  毛端能量虚空尽　　而说佛刹不可尽
  于彼一一毛道中　　种种无量诸佛刹
  有同类者不可说　　亦有异类不可说
  于彼一一毛道中　　有不可说净佛刹
  以不可说庄严具　　庄严彼彼诸佛刹
  于彼一一毛道中　　演出名身不可说
  于彼一一诸名身　　广宣无量诸佛名
  一一如来自身中　　变化毛孔不可说
  于彼一一毛孔中　　出生异色不可说
  于彼一一异色中　　放妙光明不可说
  于彼一一光明中　　出宝莲华不可说
  于彼一一宝莲华　　各有宝叶不可说
  于彼一一宝莲叶　　有微妙色不可说
  于彼一一妙色中　　出生莲华不可说
  于彼一一莲华中　　各放光明不可说
  于彼一一光明中　　出生净月不可说
  于彼一一诸月中　　复出净月不可说
  于彼一一净月中　　出净光明不可说
  于彼一一光明中　　出不可说明净日
  于彼一一诸日中　　出不可说净妙色
  于彼一一妙色中　　出不可说净光明
  于彼净妙光明中　　出不可说师子座
  不可言说庄严具　　出不可说净光明
  于彼一一光明中　　出不可说异妙色
  于彼一一妙色中　　出不可说明净宝
  于彼一一明净宝　　出不可说不可说
  金刚宝藏如须弥　　清净具足而庄严
  于彼一宝须弥中　　有不可说不可说
  微妙殊特诸佛刹　　清净具足而庄严
  如此一宝须弥山　　一切须弥亦如是
  悉有无量不可说　　具足清净诸佛刹
  是不可说不可说　　皆悉分别不可说
  摄取不可言说转　　出生光明不可说
  于彼一一光明中　　出生诸佛不可说
  彼诸一切如来等　　说不可说清净偈
  彼偈悉于念念中　　说不可说真实谛
  示现一切未来际　　如来智慧无穷尽
  彼诸一一如来等　　出不可说梵音声
  于彼一一梵音中　　转不可说净法轮
  于彼一一法轮中　　雨不可说修多罗
  于彼一一修多罗　　分别诸法不可说
  于彼一一诸法中　　又说诸法不可说
  又复于彼诸法中　　说众生依不可说
  又于一一毛道中　　不可说劫说正法
  如彼一微毛端处　　一切十方亦如是
  不可称说无碍心　　变化诸佛不可说
  彼诸一一化如来　　所出变化不可说
  彼诸一切所变化　　遍游佛刹不可说
  不可称说变化身　　种种妙色而庄严
  彼不可说佛世界　　分别一切诸众生
  清净一切众生类　　度脱一切诸群生
  庄严庄严不可说　　成就神力不可说
  清净自在不可说　　应现众生不可说
  神力自在不可说　　智慧境界不可说
  不可称说神力持　　普转世间令清净
  不可说净方便法　　说修多罗不可说
  于彼一一修多罗　　摄诸佛法不可说
  于彼一一净法中　　复说正法不可说
  于彼一一诸法中　　说不可说决定法
  于彼一一决定中　　说不可说众生依
  不可称说种类法　　不可称说种类心
  不可称说非类法　　不可称说非类心
  不可称说非类根　　不可称说非类语
  彼悉能于念念中　　调伏众生不可说
  不可称说自在力　　应现众生不可说
  彼不可说应化时　　或有同类不同类
  菩萨皆悉分别知　　诸明算者不能数
  菩萨于一毛端处　　安置佛刹不可说
  或有微细或广狭　　净秽无量不可说
  于彼一一佛刹中　　复有佛刹不可说
  菩萨皆悉分别知　　如是佛刹不可说
  一毛端处无量刹　　而于其中不迫迮
  微小毛端亦不大　　悉容弥广诸佛刹
  不令佛刹有杂乱　　形相如本而无异
  一佛刹有无量刹　　一切佛刹亦如是
  一毛端处悉容受　　如虚空等无量刹
  佛刹形相不可说　　一毛端处各殊别
  入于一毫毛道中　　次第悉入不可说
  毛道摄取不可说　　毛道亦无究竟满
  次第劫入不可说　　常能摄取不可说
  种种方便不可说　　度脱众生不可说
  具足摄取是方便　　境界无量不可说
  菩萨深入不可说　　是名深入不可说
  意根深广不可说　　遍游诸方不可说
  勇猛精进不可说　　具足自在不可说
  彼诸大愿不可说　　所得功德不可说
  彼诸境界不可说　　能究竟度不可说
  菩萨身业不可说　　口业清净不可说
  意业清净不可说　　清净解脱不可说
  清净智慧不可说　　微妙奇特不可说
  方便深入不可说　　除灭疑惑不可说
  勇猛精进不可说　　深入正法不可说
  甚深三昧不可说　　究竟彼岸不可说
  一切众生不可说　　一切佛刹不可说
  诸众生身不可说　　众生希望不可说
  彼诸业报不可说　　知众生欲不可说
  知众生性不可说　　分别众生不可说
  彼应化时不可说　　随所出处不可说
  随方便道不可说　　彼诸出者不可说
  无上智慧不可说　　彼方便道不可说
  彼诸所说不可说　　一切转时不可说
  如是成就大慈悲　　饶益一切诸世间
  应现色像不可说　　游诸佛刹不可说
  菩萨智慧甚明净　　睹十方佛不可说
  所问正法不可说　　诸佛应答不可说
  应现色像不可说　　游行诸方不可说
  往诣佛所不可说　　示现自在不可说
  以不可说诸色像　　诣不可说如来所
  以不可说供养具　　供不可说诸如来
  不可称说清净宝　　不可称说众宝华
  不可称说妙华鬘　　供不可说诸最胜
  彼深信心不可说　　清净解脱不可说
  正直希望不可说　　恭敬供养一切佛
  成就施心不可说　　过去施心不可说
  修行布施不可说　　内外悉施不可说
  禁戒清净不可说　　信心清净不可说
  赞叹最胜不可说　　生妙法爱不可说
  具足诸忍不可说　　深解无生不可说
  成就寂灭不可说　　住寂灭地不可说
  具足精进不可说　　过去妙心不可说
  不退转心不可说　　忍辱之心不可说
  一切禅藏不可说　　观察诸法不可说
  寂静定意不可说　　了知诸禅不可说
  波罗蜜慧不可说　　成就三昧不可说
  决定解法不可说　　究竟诸佛不可说
  菩萨行门不可说　　具足诸愿不可说
  智慧境界不可说　　清净法门不可说
  彼诸法力不可说　　清净住法不可说
  菩萨正念不可说　　彼诸法界不可说
  修行智慧不可说　　善学智慧不可说
  彼智慧身不可说　　住持智慧不可说
  彼净法轮不可说　　彼法智慧不可说
  彼妙法云不可说　　彼妙法雨不可说
  彼诸神力不可说　　解方便法不可说
  彼悉能于念念中　　解深法界不可说
  成就回向不可说　　于念念中遍游行
  诸佛刹海不可说　　所诣诸佛不可说
  分别佛刹不可说　　种种庄严不可说
  庄严清净不可说　　微妙净色不可说
  种种杂色不可说　　众庄严具不可说
  清净佛刹不可说　　垢秽佛刹不可说
  深入众生不可说　　众生诸界不可说
  彼诸业报不可说　　众生所行不可说
  种种诸根不可说　　众生虚妄不可说
  众生诸性不可说　　众生欲乐不可说
  众生威仪不可说　　众生烦恼不可说
  众生清净不可说　　调伏众生不可说
  菩萨神力不可说　　所变化身不可说
  随顺诸行不可说　　度脱众生不可说
  示现自在不可说　　放大光明不可说
  光明妙色不可说　　令众生净不可说
  彼于一一毛端中　　放光明网不可说
  光明网色不可说　　普照佛刹不可说
  勇猛精进不可说　　成就无畏不可说
  寂静三昧不可说　　调伏世间不可说
  清净身业不可说　　清净口业不可说
  意业无量不可说　　清净胜行不可说
  成就智宝不可说　　深入法界不可说
  诸陀罗尼不可说　　菩萨善学不可说
  音声清净不可说　　智慧知音不可说
  真实正念不可说　　持众生语不可说
  菩萨所行不可说　　正觉清净不可说
  离众恐怖不可说　　调伏世间不可说
  不可称说真佛子　　彼清净行不可说
  赞叹佛子不可说　　欲究竟尽不可说
  不可称说诸导师　　赞叹菩萨不可说
  彼诸菩萨不可说　　清净功德不可说
  彼诸分齐不可说　　随彼所住不可说
  随住智慧不可说　　不可说劫不能说
  乐见诸佛不可说　　长养智慧不可说
  永度正法不可说　　离碍正法不可说
  正观三世不可说　　三世智慧不可说
  彼所称量不可说　　出生智慧不可说
  菩萨胜行不可说　　种种所愿不可说
  清净所愿不可说　　具足菩提不可说
  诸佛菩提不可说　　彼起智慧不可说
  分别真实不可说　　知一切法不可说
  清净佛刹不可说　　所行诸力不可说
  彼所修习不可说　　一念开悟不可说
  广说正法不可说　　诸佛自在不可说
  踊跃欢喜不可说　　示现世间不可说
  转妙法轮不可说　　离众怖畏不可说
  所说正法不可说　　度脱众生不可说
  不可称说一切劫　　赞叹菩萨诸功德
  彼诸大劫犹可尽　　赞叹功德不可尽
  不可称说诸如来　　各有无量清净根
  不可说劫常赞叹　　如来功德犹不尽
  一切十方诸众生　　皆悉一时成正觉
  彼诸正觉一一有　　不可称说净妙身
  彼净妙身一一有　　不可称说如来头
  彼如来头一一有　　不可称说广长舌
  彼广长舌一一出　　无量清净妙音声
  以彼一一妙音声　　不可说劫赞叹佛
  不可称说一切劫　　宣扬赞叹佛功德
  不可说劫犹可尽　　叹佛功德无穷尽
  若于一小微尘中　　有诸佛刹不可说
  于彼一一佛刹中　　各有贤首不可说
  贤首如来世界中　　复有佛刹不可说
  一切法界无有余　　其中所有诸微尘
  于彼一一微尘中　　佛刹成败不可说
  于彼一一微尘中　　安置佛刹不可说
  复置刹海不可说　　分别方类不可说
  于彼一一佛刹中　　不可称说诸如来
  彼诸如来所寿命　　不可称说诸大劫
  诸佛所行不可说　　微妙正法不可说
  威神道力不可说　　离障碍智不可说
  微妙智慧不可说　　境界甚深不可说
  十力功德不可说　　佛觉菩提不可说
  清净深入不可说　　清净法界不可说
  彼智慧藏不可说　　分别功德不可说
  菩萨究竟正随顺　　具足回向不可说
  分别无量诸回向　　回向一切诸导师
  不可称说诸大劫　　一心正受诸三昧
  于不可说诸佛所　　所行清净不可说
  得不可说无碍心　　悉遍游行十方界
  所修行业不可说　　神力应现不可说
  分别佛刹不可说　　诸佛现前不可说
  勇猛精进不可说　　究竟智慧不可说
  未曾离于一坐处　　而能遍游十方界
  不可称说诸大劫　　遍游十方诸佛刹
  智慧方便不可说　　如实智慧不可说
  转净智慧不可说　　念念示现不可说
  于诸一一语言中　　解佛智慧不可说
  或于一时觉菩提　　或种种时觉菩提
  入诸毛端不可说　　入诸微细不可说
  殊特胜性不可说　　见诸如来不可说
  一一方便不可说　　随顺善入诸佛性
  诸佛刹性不可说　　悉能随顺入菩提
  不坏法界不可说　　佛众生刹不可说
  三世所摄不可说　　菩萨究竟不可说

    大方广佛华严经寿命品第二十六

尔时心王菩萨摩诃萨。告诸菩萨言。佛子。如此娑婆世界释迦牟尼佛刹一劫。于安乐世界阿弥陀佛刹为一日一夜。安乐世界一劫。于圣服幢世界金刚佛刹为一日一夜。圣服幢世界一劫。于不退转音声轮世界善乐光明清净开敷佛刹为一日一夜。不退转音声轮世界一劫。于离垢世界法幢佛刹为一日一夜。离垢世界一劫。于善灯世界师子佛刹为一日一夜。善灯世界一劫。于善光明世界卢舍那藏佛刹为一日一夜。善光明世界一劫。于超出世界法光明清净开敷莲华佛刹为一日一夜。超出世界一劫。于庄严慧世界一切明光明佛刹为一日一夜。庄严慧世界一劫。于镜光明世界觉月佛刹为一日一夜。佛子。如是次第。乃至百万阿僧祇世界。最后世界一劫。于胜莲华世界贤首佛刹为一日一夜。普贤菩萨等诸大菩萨充满其中

    大方广佛华严经菩萨住处品第二十七

尔时心王菩萨摩诃萨。复告诸菩萨言。佛子。东方有菩萨住处。名仙人起山。过去诸菩萨常于中住。彼现有菩萨。名金刚胜。于其中止。有三百菩萨眷属。常为说法。南方有菩萨住处。名胜楼阁山。过去诸菩萨常于中住。彼现有菩萨。名法慧。有五百菩萨眷属。常为说法。西方有菩萨住处名金刚焰山。过去诸菩萨常于中住。彼现有菩萨。名无畏师子行。有三百菩萨眷属。常为说法。北方有菩萨住处名香聚山。过去诸菩萨常于中住。彼现有菩萨。名香象。有三千菩萨眷属。常为说法。东北方有菩萨住处。名清凉山。过去诸菩萨常于中住。彼现有菩萨。名文殊师利。有一万菩萨眷属。常为说法。东南方有菩萨住处。名枝坚固。过去诸菩萨常于中住。彼现有菩萨。名天冠。有一千菩萨眷属。常为说法。西南方有菩萨住处。名树提光明山。过去诸菩萨常于中住。彼现有菩萨。名贤首。有三千菩萨眷属。常为说法。西北方有菩萨住处。名香风山。过去诸菩萨常于中住。彼现有菩萨。名香光明。有五千菩萨眷属。常为说法。四大海中有菩萨住处。名枳怛。过去诸菩萨常于中住。彼现有菩萨。名昙无竭。有万二千菩萨眷属。常为说法。海中有菩萨住处。名功德庄严窟。过去诸菩萨常于中住。毗舍离城南有菩萨住处。名善住。过去诸菩萨常于中住。巴连弗邑有菩萨住处。名金灯僧伽蓝。过去诸菩萨常于中住。摩瑜罗国有菩萨住处。名长养功德。过去诸菩萨常于中住。拘陈那耶国有菩萨住处。名法座。过去诸菩萨常于中住。清净彼岸国有菩萨住处。名牟真邻陀功德。过去诸菩萨常于中住。风地内有菩萨住处。名无碍龙王所造。过去诸菩萨常于中住。甘菩国有菩萨住处。名最上慈。过去诸菩萨常于中住。真旦国土有菩萨住处。名那罗延山过去诸菩萨常于中住。边夷国土有菩萨住处。名牛头山。过去诸菩萨常于中住。罽宾国土有菩萨住处。名郁提尸山过去诸菩萨常于中住。难提拔檀那城有菩萨住处。名梯罗浮诃。过去诸菩萨常于中住。庵浮梨摩国有菩萨住处。名正治邪曲过去诸菩萨。常于中住乾陀罗国有菩萨住处。名寂静窟。过去诸菩萨常于中住

大方广佛华严经卷第二十九大方广佛华严经卷第三十

        东晋天竺三藏佛驮跋陀罗译

    佛不思议法品第二十八之一

尔时诸菩萨大会中。有诸菩萨。作如是念。诸佛刹土不可思议。诸佛净愿不可思议。诸佛种姓不可思议。诸佛出世不可思议。诸佛法身不可思议。诸佛音声不可思议。诸佛智慧不可思议。诸佛神力自在不可思议。诸佛无碍住不可思议。诸佛解脱不可思议

尔时世尊。知诸菩萨心之所念。即与青莲华菩萨佛神力。佛智佛辩。佛功德佛无畏。充满其身。究竟一切诸佛法界。与佛神力境界。无障碍行。分别一切如来种性。与不可数诸佛方便。尔时青莲华菩萨摩诃萨。即入甚深无碍法界一切无碍法。修菩萨行。成就普贤菩萨所愿。随顺一切佛。以大庄严而自庄严。大悲普观一切众生欲令清净。于一念中出生如来无量大智。成就如来无尽智门。成就一切诸陀罗尼诸辩光明普照一切。尔时青莲华菩萨。承佛神力。告莲华藏菩萨言。佛子。诸佛有无量无数清净妙住。诸佛安住无量自在。诸佛于一切事未曾失时。一切诸佛。悉皆平等转净法轮。诸佛四辩说无穷尽。一切佛法不可思议。一切诸佛。清净音声无所不至。一切诸佛。悉能分别无量法界。一切诸佛。光明普照。一切诸佛。所说皆入甚深法界。佛子。一切诸佛。有十种法界无量无边。何等为十。一切诸佛。色身清净无量无边。超出世间。一切诸佛。无碍眼无量无边。清净平等觉一切法一切诸佛。无碍耳无量无边。分别一切众生音声。一切诸佛。鼻入无量无边。清净究竟一切佛自在到于彼岸。一切诸佛。广长舌相无量无边。出妙音声普闻法界。一切诸佛。身业无量无边。随应众生现如来身。一切诸佛。意业无量无边。三世无碍法身清净不可破坏。一切诸佛。无碍解脱法门无量无边。示现无尽神力自在。一切诸佛。于一切世界庄严佛刹无量无边。以应众生。一切诸佛。无量无边诸菩萨行及诸胜愿。自在神力皆悉满足。悉能觉悟诸佛正法。佛子。是为一切诸佛十种法界无量无边。佛子。一切诸佛。于念念中。悉能出生十无尽智。何等为十。于一念中。悉现一切世界从兜率天命终。于一念中。悉现一切世界菩萨出生。于一念中。悉现一切世界菩萨出家。于一念中。悉现一切世界往诣道场菩提树下成等正觉。于一念中。悉现一切世界转净法轮。于一念中。悉现一切世界随应化导一切众生悉令解脱。于一念中。悉于一切世界现庄严身随应众生。于一念中。悉现一切世界种种庄严无数庄严如来自在一切智藏。于一念中。悉现一切世界清净众生。于一念中。遍一切世界。悉现三世一切诸佛。于一念中。为种种诸根精进欲性故。显现三世诸佛种姓。成等正觉。开导众生。佛子。是为一切诸佛于一念中生十种智。佛子。一切诸佛。有十种未曾失时。何等为十。一切诸佛。成等正觉未曾失时。一切诸佛。善根业报未曾失时。一切诸佛。授菩萨记未曾失时。一切诸佛。随应众生示现神力未曾失时。一切诸佛。现如来身未曾失时。一切诸佛。悉行于舍未曾失时。一切诸佛。入城聚落未曾失时。一切诸佛。摄取欢喜众生未曾失时。一切诸佛。于难化众生而放舍之。为调伏故未曾失时。一切诸佛。示现不可思议自在神力未曾失时。佛子。是为一切诸佛十种未曾失时。佛子。一切诸佛。有十种不可譬谕不可思议境界。何等为十。一跏趺坐遍满十方一切世界。一发言音。悉能演说一切佛法。放一光明。悉能普照一切世界。一身悉能现一切身。不离本处。悉遍示现一切世间。决定一法。悉于诸法无所挂碍。于一念中。悉能充满无余世界。于一念中。悉能示现诸佛功德。于一念中。悉能示现一切三世佛。教化一切众生。而不舍离诸佛寂灭无二三昧。佛子。是为一切诸佛十种不可譬谕不可思议境界

佛子。一切诸佛。有十种出生住持智慧。何等为十。一切诸法无所趣向。而能出生清净愿智。一切诸法无身。而能出生法身智慧。一切诸法悉无有二。而生正觉悟一切法。一切诸法悉无有我无有众生。而能出生化众生智。一切诸法悉无有相。而能出生种种相智。一切世界悉无成败。而能出生世成败智。一切诸法无有造者。而能出生业报智慧。一切诸法无可言说。而能出生说法界智。一切诸法无有垢净。而能出生垢净智慧。一切诸法无有生灭。而能出生缘起智慧。佛子。是为一切诸佛十种出生住持智慧。佛子。一切诸佛。有十种无量内法。何等为十。一切诸佛。内身清净随顺三世。一切诸佛。悉有三轮内法教化众生。一切诸佛。悉有内深智慧陀罗尼。分别一切佛法。一切诸佛。皆悉内有四辩法轮。于四众中转净法轮。一切诸佛。皆悉内有大慈大悲。悉能不舍一切众生。一切诸佛。内常寂定。善观众生未曾失时。一切诸佛。皆悉内有巧妙善根。调伏众生。一切诸佛。皆悉内有一切法界。住无碍住。一切诸佛。内一念中。悉能示现三世诸佛出兴于世。一切诸佛。内有分别一切三世。阿僧祇劫即是一日。佛子。是为一切诸佛十种无量内法。佛子。一切诸佛。有十种甚深大法。何等为十。一切诸佛。悉能坏散一切诸魔。一切诸佛。悉能降伏一切外道。一切诸佛。悉能应化一切众生。令其欢喜。一切诸佛。悉能往诣一切世界。教化众生。一切诸佛。悉分别知甚深法界。一切诸佛。以种种身遍诸世界。而无异身。一切诸佛。一一音声。具四种辩未曾断绝。一切诸佛。众生见者。皆令欢喜利益不虚。一切诸佛。一一毛孔次第出生一切世界微尘等佛。未曾断绝。一切诸佛。于一一微尘中。示现一切世界微尘等佛刹种种庄严。常转法轮教化众生未曾断绝。而微尘不大。世界不小。决定了知安住法界。一切诸佛。于一切法。觉悟痴闇。具足十力。广为一切众生说如实法。除灭痴曀。佛子。是为一切诸佛十种甚深大法。佛子。一切诸佛。有十种功德。离恶清净。何等为十。一切诸佛。本来修习一切功德离恶清净。一切诸佛。悉于三世如来家生。离恶清净。一切诸佛。于未来际心无所著。离恶清净。一切诸佛。不着一切三世诸法。离恶清净。一切诸佛。离种种虚妄。以一庄严而自庄严。离恶清净。一切诸佛。功德无尽安住法界等。离恶清净。一切诸佛。色身净妙无量无边。普现十方一切世界。教化众生未曾失时。离恶清净。一切诸佛。住四无畏离诸恐怖。于一切天人众中大师子吼。广说诸法令众欢喜。离恶清净。不可说不可说劫中灭度诸佛。若有众生。闻其名者。得大果报如佛现在。离恶清净。一切诸佛远在不可说不可说世界中住。若有众生。一心正念彼诸如来。即现在前。离恶清净。佛子。是为一切诸佛十种功德离恶清净。佛子。一切诸佛。有十种究竟清净。何等为十。一切诸佛。诸愿究竟清净。一切诸佛。梵行禁戒究竟清净。一切诸佛。悉得舍离优婆提究竟清净。一切诸佛。佛刹究竟清净。一切诸佛。眷属究竟清净。一切诸佛。种姓究竟清净。一切诸佛。色身相好究竟清净。一切诸佛。法身究竟清净。一切诸佛。无碍一切。智身究竟清净。一切诸佛。解脱所作已作永度彼岸究竟清净。佛子。是为一切诸佛十种究竟清净。佛子。一切诸佛。于一切世界一切时。有十种佛事。何等为十。一切诸佛。若有众生。正忆念者即现在前。一切诸佛。常为众生说摩诃衍。一切诸佛。常能长养一切众生无量善根。一切诸佛。若有众生。始离生死入正法位。悉分别知。一切诸佛。不舍众生教化时会。一切诸佛。常游一切世界。无有障碍。一切诸佛。大悲常不舍离一切众生。一切诸佛。所变化身常不断绝一切诸佛。自在神力未曾断绝。一切诸佛。普常安住清净法界。悉为众生而广演说。佛子。是为一切诸佛于一切世界一切时有十种佛事。佛子。一切诸佛。有十种无尽方便智慧大海。何等为十。一切诸佛。法身无尽智慧大海。一切诸佛。功德无尽智慧大海。一切诸佛。佛眼境界无尽智慧大海。一切诸佛。不可思议善根无尽智慧大海。一切诸佛。行一切法无尽智慧大海。一切诸佛。雨甘露法无尽智慧大海。一切诸佛。赞叹诸佛功德无尽智慧大海。一切诸佛。本愿诸行无尽智慧大海。一切诸佛。尽未来际。为一切众生常作佛事。未曾休息无有穷尽智慧大海。一切诸佛。知众生心心所行无尽智慧大海。一切诸佛。出生一切智功德无尽智慧大海。佛子。是为一切诸佛十种无尽方便智慧大海。佛子。一切诸佛。有十种常法。何等为十。一切诸佛。常行一切诸波罗蜜。一切诸佛。于一切法常离愚痴。一切诸佛。常具大悲。一切诸佛。常具无量十力。一切诸佛。常转无上法轮。一切诸佛。常度一切众生。一切诸佛。常为众生成等正觉。一切诸佛。常应化度一切众生。一切诸佛。常行正念不二之法。一切诸佛。常化众生已示现涅槃。诸佛境界无有边际。佛子。是为一切诸佛十种常法。佛子。一切诸佛。有十种无量说佛法门。何等为十。一切诸佛。悉说无量众生界门。一切诸佛。悉说无量众生种种行门。一切诸佛。悉说众生无量诸业报门。一切诸佛。悉说无量方便度众生门。一切诸佛。悉有无量净众生行门。一切诸佛。悉有无量教化一切菩萨安立菩萨行门。一切诸佛。悉说无量菩萨胜妙愿门。一切诸佛。悉说无量世界诸成败门。一切诸佛。悉说无量清净佛刹一切菩萨正希望门。一切诸佛。悉说无量一切世界去来现在诸佛。无量劫中次第出世。善分别此佛智慧门。佛子。是为一切诸佛十种无量说佛法门。佛子。一切诸佛。有十种法。常为众生而作佛事。何等为十。一切诸佛色身。常为众生而作佛事。一切诸佛音声。常为众生而作佛事。一切诸佛受施。常为众生而作佛事。一切诸佛不受施。常为众生而作佛事。一切诸佛。常以地水火风而作佛事。一切诸佛。神力住持境界。常为众生而作佛事。一切诸佛。常以名号。为诸众生而作佛事。一切诸佛。常以佛刹境界。普为众生而作佛事。一切诸佛常以清净佛刹。为诸众生而作佛事。一切诸佛。常以默然。为诸众生而作佛事。佛子。是为一切诸佛十种法常为众生而作佛事。佛子。一切诸佛。有十种坚固士法。何等为十。一切诸佛。诸愿坚固不可沮坏。如说修行言行相应。一切诸佛。尽未来际劫修菩萨行。功德庄严。未曾恐怖。一切诸佛。为化一切众生故。悉诣不可说不可说世界。而于一切世界。教化众生无有留难。一切诸佛。于信不信众生。大悲等观而无有异。一切诸佛。从初发心乃至正觉。于其中间。未曾退失菩提之心。一切诸佛。修诸功德。皆悉回向一切种智。不求世行。一切诸佛。于诸佛所。随顺修学身口意业。永离声闻缘觉之心。一向专求无上菩提。所修功德。皆悉回向一切种智。求无上道成等正觉。一切诸佛。平等普照无量无边诸佛正法净菩萨心。究竟具足一切种智。一切诸佛。悉能舍离一切世乐。不乐世间所可愿乐。不着世间。令一切众生悉灭诸苦。逮得寂灭平等快乐。一切诸佛。为一切众生故。受无量苦。皆欲建立诸佛种性。悉令众生乐求菩提。超出生死得十力地。佛子。是为一切诸佛。十种坚固士法。佛子。一切诸佛。有十种佛无障碍住。何等为十。一切诸佛悉能遍游一切世界。无障碍住。一切诸佛。悉能安住一切世界。无障碍住。一切诸佛。于一切世界行住坐卧。无障碍住。一切诸佛。于一切世界说法。无障碍住。一切诸佛。于一切世界皆悉安住兜率陀天。无障碍住。一切诸佛。于三世法界。无障碍住。一切诸佛。眷属充满一切法界。而为说法。无障碍住。一切诸佛。于一念中。悉知一切众生心心所行。以三轮教化而调伏之。无障碍住。一切诸佛。能以一身悉住一切诸佛不可思议法门。无障碍住。一切诸佛悉分别知一切众生。无障碍住。一切诸佛。悉能分别一切如来。无障碍住。佛子。是为一切诸佛十种无障碍住。佛子。一切诸佛。有十种最胜无上庄严。何等为十。一切诸佛。悉有色身相好最胜无上庄严。是为一切诸佛最胜无上色身庄严。一切诸佛。悉有八种微妙音声。一一音声。悉有五百妙音眷属。不可称数百千音声以为庄严。无量无边妙音声技。皆悉清净。普能演说一切诸佛正法义味。悉离恐怖。安住无畏大师子吼。悉令一切法界一切众生闻其音声。随其本行种种善根。皆令开解。是为一切诸佛最胜无上口业庄严。一切诸佛。悉有十力庄严意业。开敷诸佛大三昧华。十八不共庄严境界无所挂碍。住法界地。悉得诸佛法之原底。无余法界皆悉庄严于一念中。悉分别知三世一切法界一切众生心心所行。而无有余。是为一切诸佛最胜无上意业庄严。一切诸佛。悉有最胜无上光明庄严。皆悉普放大光明藏一一光明。悉有无数妙光明网。以为眷属。普照十方诸佛世界。除灭一切世间闇冥。现佛出世。作不退转最胜佛事。出生无量清净法身。是为一切诸佛最胜无上光明庄严。一切诸佛。若微笑时。悉于口中。放不可数阿僧祇亿那由他光。各有种种无量不可思议色。普照十方一切世界。悉授无量无数阿僧祇众生。阿耨多罗三藐三菩提记。是为一切诸佛最胜无上普照一切离痴示现庄严。一切诸佛。悉有无量法身离碍。清净法界无量无边。远离世间。不染世间。不着世间。解世真实。行出世法。断语言道。摄无言际。离阴界入。是为一切诸佛最胜无上法身庄严。一切诸佛。悉有无量常妙光明。普照十方一切世界。不可说不可说诸杂妙色。而庄严之。普照世间无所障碍。出生一切光明之藏。是为一切诸佛最胜无上常光庄严。一切诸佛。悉有无量妙色。悦乐妙色。清净妙色。随应一切众生妙色。映蔽三界光明妙色。究竟彼岸无上妙色。是为一切诸佛最胜无上无量妙色庄严。一切诸佛。自然清净三世佛宝圣家中生。离一切恶。修行一切清净胜法。出生一切智。如来种姓清净无碍。是为一切诸佛最胜无上清净种姓庄严。一切诸佛大慈诸力庄严其身。自然清净。远离一切不善觉观。身行永息观者无厌。心净解脱大悲具足。一切众生第一福田。无上受者。哀愍众生。普令安立一切种智。出生无量功德宝藏。一切众生。长养善根智慧功德之藏。是为一切诸佛最胜无上大慈大悲究竟功德宝藏清净庄严。佛子。是为一切诸佛最胜无上十种庄严。佛子。一切诸佛。有十种自在正法。何等为十。一切诸佛。于一切法随意自在。句身味身辩无穷尽。说一切法而无障碍。是为一切诸佛自在正法。一切诸佛。随应众生化不失时。随其所愿而为说法未曾失时。是为一切诸佛自在正法。一切诸佛。悉能六种震动十方世界。未曾恼乱于一众生。虚空等世界无量阿僧祇种种庄严。或举或下。或合或散。于一一世界。一一处所众生。亦不恼乱众生之心。亦不令其生疑惑想。是为一切诸佛自在正法。一切诸佛。能以智慧。受持一切世界种种庄严。于一念中。示现一切世界种种庄严。不可数不可数阿僧祇劫。叹庄严具而无穷尽。永离一切世界染污。庄严世间一切佛刹。是为一切诸佛自在正法。一切诸佛。若见一众生应受化者。于不可数不可数阿僧祇劫。结跏趺坐身不疲厌。专念彼人未曾废忘而不失时。为一众生。住持寿命。尽未来际劫。结跏趺坐身无疲厌。念彼众生未曾废忘。如一众生。一切众生亦复如是。是为一切诸佛自在正法。一切诸佛。悉遍往诣一切世界诸如来所。而无障碍。一一方面。各有法界等世界海。一一方无量世界网。法界等一切世界海。于一念中悉能周遍。转妙法轮而无障碍。是为一切诸佛自在正法。一切诸佛。调伏教化一切众生故。于念念中。成等正觉。非不先觉诸佛正法。亦不住学地。而成正觉。于诸佛法得无挂碍。不舍自在神力。无量智慧境界。教化众生。是为一切诸佛自在正法。一切诸佛。能以眼入作耳入佛事。能以耳入作鼻入佛事。能以鼻入作舌入佛事。能以舌入作身入佛事。能以身入作意入佛事。能以意入。于一切世界。种种境界。世间境界。出世间境界。于一一境界能作佛事。是为一切诸佛自在正法。一切诸佛。于一毛孔。悉能安置一切众生。一一众生。其身悉与不可说不可说诸佛刹等。于彼众生而不迫迮。一一众生。悉寿无量阿僧祇劫。普能游行无量世界。于诸世界。见佛兴世转净法轮。宣畅演说无数法门。广说过去不可数法。未来现在不可数法。一切众生。行四威仪而不迫迮。是为一切诸佛自在正法。一切诸佛。于一念中。现莲华宝藏师子之座。如来净身与法界等。处彼宝座成等正觉。示现如来自在神力。如一念中。示现一如来成等正觉。于一念中。示现一切世界微尘数如来成等正觉。亦复如是。如一念中。于一切念中。亦复如是。如莲华宝藏师子之座示成正觉。如是一切不可说不可说法界等清净佛刹。不可思议种种庄严世界。种种境界。不可说佛刹。或有同相或有异相。不可说阿僧祇劫。说不能尽。无量诸佛。种种念。种种时。不可思议。于一念中。一切诸佛。以少方便。示现一切众生。亦复如是。佛子。是为一切诸佛十种自在正法。佛子。一切诸佛。具足十种不思议法已。成等正觉。何等为十。一切诸佛。一一妙相。百福悉具。成等正觉。一切诸佛。具足一切佛法。成等正觉。一切诸佛。具诸善根。成等正觉。一切诸佛。具足修习诸功德行。成等正觉。一切诸佛。善知众生诸根熟已。成等正觉。一切诸佛。具足成就无坏胜法。成等正觉。一切诸佛。具足严净佛刹。成等正觉。一切诸佛。具足一切种智。成等正觉。一切诸佛。色身相好满足见者不虚。成等正觉。一切诸佛。悉具诸佛平等正法。成等正觉。一切诸佛。悉具一切诸佛事已。然后入于无余涅槃佛子。是为一切诸佛满足十种不思议法成等正觉。佛子。一切诸佛。有十种巧妙方便。何等为十。一切诸佛。悉知诸法无有究竟。而究竟说诸佛善根。是为一切诸佛巧妙方便。一切诸佛了一切法悉无所见各不相知。无缚无脱无取无集。无具足无自在无究竟。而一切佛于彼法中。实知无异离众垢污。于一切法悉得自在。于无取法中不坏实际。善究竟学大自在地。见一切法界。觉悟一切智。是为一切诸佛巧妙方便。一切诸佛。离诸相际。不住一切相。而分别知一切诸相。亦不乱自性。一切诸性无有自性。而能示现阿僧祇清净色身。种种严净佛刹妙相。佛一切智。具足智身。明净智灯除灭痴闇。普能示现一切众生。是为一切诸佛巧妙方便。一切诸佛。知众生际非过去非未来非现在。法界亦非去来现在。如如实性舍离虚妄。而能演说三世诸佛见一切佛平等境界。是为一切诸佛巧妙方便。一切诸佛。身口意业无所造作。究竟无住。离诸数法。到于彼岸。而出生无量功德宝藏。分别演说世间出世间法。具足成就无碍智慧。示现无量自在神力。度脱一切法界等众生。是为一切诸佛巧妙方便。一切诸佛。悉知一切法无知无见。非一非异。非相非无相。非庄严非不庄严。一切诸法皆无自性不生不灭。而于所有无所有法中。亦不坏世间法相。一切智人见人示现胜妙智慧。自在广说一切诸法。而于如如亦不永灭。是为一切诸佛巧妙方便。一切诸佛。能于一时。皆悉分别知一切时。不舍离生平等正法。一切时中皆所不摄。非昼非夜。非半月非一月。非一岁。非百岁。非劫成非劫败。非时不离时。而于无量时转净法轮。或须臾时。或于昼初中后时。或于夜初中后时。或于七日一月一岁百岁。乃至不可思议阿僧祇劫时。乃至尽未来际劫。于一切时转净法轮。未曾暂息。是为一切诸佛巧妙方便。一切诸佛。知一切法界非时不离时。一切诸佛。具足成就无量无畏。具足成就不可数辩。不可量辩。不可尽辩。不可坏辩。无边辩。不共辩。无穷尽辩。真实辩。方便分别演说一切句身味身辩。一切法辩。随性随根随行。广说诸法。不可说不可说亿那由他修多罗。彼诸一一修多罗。初中后善究竟善说。是为一切诸佛巧妙方便。一切诸佛正觉法界。无名无性。无三世名无众生名。无法名无非法名。无功德名无非功德名。无菩萨名。无佛名。无数名无非数名。无生名无灭名。非有名非无名。非一名非种种名。一切诸法自性无言。无方无处舍离音声。言语道断究竟彼岸。离虚妄境界。修无形法。除灭一切觉观虚妄。不着一切世间语言。而能出生一切诸法句身味身。是为一切诸佛巧妙方便。一切诸佛。知一切法不生。无有受者。知色不生受想行识不生。一切诸法皆悉寂灭。无入无界。法界无所有。而亦不坏一切法相。一切诸法无有起者。悉如虚空。一切法寂灭。无有业报。无所学。无成就。无数无非数。非有非无。非生非灭。非垢非净。无来无去。亦无有住。无众生非无众生。亦无教化。无命非无命。无因缘非无因缘。无缘起非无缘起。而善分别正定邪定不定众生。成就十力四无所畏一切种智。于大众中大师子吼如来境界。是为一切诸佛巧妙方便。佛子。是为一切诸佛十种巧妙方便

大方广佛华严经卷第三十大方广佛华严经卷第三十一

        东晋天竺三藏佛驮跋陀罗译

    佛不思议法品第二十八之二

佛子。一切诸佛。有十种佛事无量无边不可思议。一切天人不能称量。三世一切声闻缘觉所不能说。除佛神力。何等为十。一切诸佛。于无量无边虚空法界等一切世界兜率天上。修菩萨行而作佛事。无量妙色。无量功德。无量光明。无量音声。无量清净音声。无量三昧。无量智慧境界。摄取天人魔梵沙门婆罗门阿修罗等一切世间。大慈境界无碍。大悲安乐摄取众生。或令生天。或令长养诸功德力。或令诸根清净。或调伏其心摄取众生。或以清净诸乘摄取众生。或以满足大乘摄取众生。或离生死摄取众生。是为一切诸佛第一佛事。一切诸佛。从兜率天降神母胎。修菩萨行。观诸有生如幻如化如电如梦如虚空如焰。离一切诤。修真实智。离欲清净。具足大庄严藏。于最后生而作佛事。安处妙宝庄严楼阁而作佛事。或以神力而作佛事。或以正念而作佛事。或以示现大自在藏而作佛事。或以圆满慧日而作佛事。或以具足如来广大境界而作佛事。或以化满无量无边世界诸佛而作佛事。或入无量无边诸大三昧正受而作佛事。或复从彼诸三昧起而作佛事。或从初发心而作佛事。乃至无余涅槃而作佛事。此第二地究竟示现一切世间。或初生时。一切世间而作佛事。或童子时。一切世间而作佛事。或菩萨时。一切世间而作佛事。或出家时。或成佛时。或转法轮时。一切世间而作佛事。种种方便。于一切无余世界而作佛事。一切方网而作佛事。一切佛刹而作佛事。一切业报而作佛事。或于一切无余众生而作佛事。或于一切生死中变化正念法门而作佛事。佛子。是为一切诸佛第二佛事。一切诸佛。为菩萨时。于王宫中。成就一切清净胜业。善能分别知一切生。随顺众生现处王宫。欲令一切善根具足。而不着一切色。离一切声。观一切有皆悉寂灭。甚深智慧。入一切境界。持一切戒。清净满足。大悲观察内诸眷属。大慈观察众生空寂。大喜观察世无可乐。大舍观察心得自在。随意能转。究竟一切智。诸妙功德。出生法身。与法界等。清净满足而无染着。令一切眷属皆悉清净。广能为彼如应说法令厌世间。能说一切世间音声。随彼所行示现果报。出生无量种种方便。随其所应调伏教化。善根未熟悉令成熟。已成熟者令得解脱。示现无量不退佛事。广说种种法门。令无量众生心得清净。兴大悲重云。普雨无量甘露法雨。大慈平等。三转示现教化众生。虽处王宫。而普示现一切佛事。于一切世界示现佛事。出生无碍诸佛神通。具足三种巧方便业。身口二业究竟清净。意业甚深究竟无碍。得巧方便饶益众生。佛子。是为一切诸佛第三佛事。佛子。一切诸佛世间珍玩种种宝物。悉能眩惑动转人心。菩萨悉弃。舍家出家。示现世间。欲令众生不着世间。解知磨灭皆悉非常。舍离贪爱行清净法。饶益众生得出家利。示现世间舍离俗服。修无诤法满足本愿。无量功德皆悉圆满。智慧具足除世愚痴。示现众生无上福田。若有众生。于佛福田种善根者。赞叹其人。悉已具足一切功德。甚深智慧。了真实义。悉令众生得清净乐。永离诸恶。清净法门。广为众生说正法门。超出生死。为欲建立一切智幢故。舍家出家。佛子。是为一切诸佛第四佛事。一切诸佛。修无量行。一向专求萨婆若。坐于道场菩提树下。成等正觉。达一切法。坏散众魔。不可破坏法身之藏。悉能充满一切法界。离一切相究竟无尽。具足成就无量法门。于一切智境界自在。随顺其义。积集成满一切种智功德庄严一切宝座。遍一切刹。诸大菩萨悉处其座。成就菩萨无上众行。具足菩萨殊胜大愿。一切菩萨常所敬念。为诸菩萨转深法轮。无量佛境界。摄取诸菩萨。修习庄严诸菩萨行。令菩萨众皆悉清净一切世间诸佛境界。令一切众生修习善根。不可破坏一切善根。出真实地。安住无量菩萨行地。具足一切胜妙功德。悉分别知一切世界。一切众生。一切佛刹。一切诸法。一切菩萨。一切成熟。一切三世。一切教化。一切佛自在觉。一切众生性。而作佛事。佛子。是为一切诸佛第五佛事。一切诸佛。转妙法轮。不退转故。无量法轮。一切世间知故一切觉法轮。无畏大师子吼故。知一切法藏法轮。开示显现明净法门。灭痴闇故。无著法轮。智慧等虚空故。无碍法轮。观一切法非有无故。一切世间灯法轮净一切众生法眼故。示现一切智法轮。充满三世一切世间故。一切诸佛同一法轮。一切佛法不相违故。如是等无量阿僧祇法轮。随所应转。施作佛事不可思议。佛子。是为一切诸佛第六佛事。一切诸佛。若入聚落城邑大王都城。能为众生施作佛事。或入人王都城。或入天王龙王夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽罗刹毗舍遮王。入如是等一切诸王都城时。能为众生而作佛事。所谓入城门时。一切大地六种震动。光明普照。盲者得视。聋者得听。狂者得止。裸者得衣。苦者得乐。一切乐器不鼓自鸣。诸庄严具。自然演出微妙音声。如是等物亦自然出微妙音声。一切诸佛色身清净见者无厌。普为众生而作佛事。一切诸佛相好庄严。普为众生而作佛事。一切诸佛视瞻安详。未曾卒疾观察诸方。不失威仪。于一切境界诸根寂定。摄心不乱直趣涅槃。普为众生而作佛事。一切诸佛行四威仪。普为众生而作佛事。一切诸佛。或以说法。或以默然。普为众生而作佛事。一切诸佛。或以神足说法教诫。普为众生而作佛事。一切诸佛。为一切世界海中种种众生海。修大善根念佛三昧。行菩萨行。观察诸佛无有厌足。或说佛兴难可值遇。见如来已。出生无量一切善法。修习功德。行诸佛行。佛出世间。令众生净赞叹诸佛无量功德。长养未来诸佛种姓。修一切善根。令诸佛欢喜。解知如来无量妙色。随所应化普能现前。令不可思议众生。于诸佛刹得见如来。一切诸佛。以如是等无量善根。普为众生而作佛事。彼诸众生。或有见佛欢喜。或有礼拜。或有合掌。或有赞叹。或有请佛。或有受施。或见佛微笑。或有念佛。或见佛悦乐。普为众生而作佛事。一切诸佛。能以无量种种色身。示现众生而作佛事。一切诸佛以妙音声。普为众生而作佛事。一切诸佛。以如是等无量无数不思议事。普为众生而作佛事。于一切世界中。一切众生悉教化之。令不退转。大悲充满不舍本愿。具足成就一切智力。随所应化悉令调伏。佛子。是为一切诸佛第七佛事。一切诸佛。或住阿练若处。或寂静处。或离欲处而作佛事。或住佛住而作佛事。或住大三昧而作佛事。或住独处而作佛事。或不现身而作佛事。或住深智而作佛事。或住不可称量诸佛境界而作佛事。或随所应而作佛事。或以天身境界。而作佛事。或以天龙迦楼罗紧那罗摩睺罗伽罗刹人非人等一切境界而作佛事。或以声闻缘觉菩萨境界。而作佛事。或以说法而作佛事。或以默然而作佛事。或说世间有一佛而作佛事。或说世间有一切诸佛而作佛事。或说一切菩萨无量愿无量行为一而作佛事。或说一行一愿为无量而作佛事。或说世间境界为如来境界。或说如来境界为世间境界。或说非境界为如来境界而作佛事。或住一日或住一夜。或住半月一月一岁。乃至住无量无数阿僧祇劫而作佛事。佛子。是为一切诸佛第八佛事。一切诸佛。即是无尽功德之藏。能令众生发深信心。具足清净。随其所应悉能化度。诸根具足。调伏众生悉令欢喜。化一切众生以真实道。觉悟一切诸菩萨众。未发菩提心者皆令发心。已发心者令具智慧。悟不由他。或现涅槃而作佛事。或现世间无常而作佛事。或赞叹法身清净而作佛事。或说所作已办而作佛事。或说坏一切有而作佛事。或说三有根本永尽而作佛事。或教众生厌离世间随顺佛心。或为众生说寿命短促。或为众生说一切世间无可乐者。或为众生说值未来一切诸佛。或为众生说诸如来转妙法轮。或发众生佛境界心。或说随时清净念佛得见如来。灭除众苦皆令清净。专求佛道。于一切世界摄取众生。令入如来甚深境界。以如来身为一切身。摄取众生。放逸众生。悉令具足三种净戒。佛子。是为一切诸佛第九佛事。一切诸佛般涅槃时。一切众生悲泣雨泪忧恼愁毒。呜呼痛哉。如来应供等正觉。常以大悲等念众生。为大导师。哀愍饶益一切众生。救护世间。天人所归。难可值遇。无上福田于今永灭。诸佛即以此等众生忧苦悲恼感慕诸佛。而作佛事。随应化彼一切天人龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等故。碎末全身示现舍利。欲令众生欢喜供养。净正直心。调伏教化。清净众生。欲令众生功德满足。欲令众生起如来塔种种供养。一切世间天宫龙宫夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人宫。起塔供养。又以爪牙头发。起塔供养。众生见已念佛法僧。发起恭敬供养之心。或行布施或修功德。具功德已。或生天上或生人中。尊贵富乐。除灭恶趣直向正道。得见诸佛具白净法。成就正道超出三界。随彼所愿皆悉满足。常念如来知恩报恩。以诸如来常为众生作救护归依如来。虽复入于涅槃。犹为众生作无上福田无尽福田。令一切众生长养善根。具足成就一切功德。佛子。是为一切诸佛第十佛事。佛子。此十种佛事。无量无边不可思议。一切天人莫能知者。三世一切声闻缘觉所不能说。除佛神力。佛子。一切诸佛。有十种法王无异之法。何等为十。一切诸佛。与授记者言无有异。一切诸佛。若有众生修念佛者。皆令意满悉无有异。一切诸佛皆无异身。觉诸法义悉无有异。一切诸佛。于三世如来智慧无异。一切诸佛。念念普知三世诸法。悉无有异。一切诸佛。了知分别三世佛刹悉无有异。一切诸佛。一切佛语悉无有异。一切诸佛。教化众生悉无有异。一切诸佛。解一切世间法与佛法无异。三世诸佛一切善根同一善根悉无有异。佛子。是为一切诸佛十种法王无异之法。佛子。一切诸佛。有向十种住法。何等为十。一切诸佛。悉住觉一切法界。一切诸佛。悉住大悲。一切诸佛。悉住本愿。一切诸佛。悉住不舍教化众生。一切诸佛。悉住无所依法。一切诸佛。悉住无虚妄法。一切诸佛。悉住念无失法。一切诸佛。悉住无障碍心。一切诸佛。悉住定心未曾散乱。一切诸佛。悉住一切诸法平等不坏实际。佛子。是为一切诸佛向十种住法。佛子。一切诸佛。知十种法悉无有余。何等为十。一切诸佛。知过去一切法界。悉无有余。一切诸佛。知未来一切法界。悉无有余。一切诸佛。知现在一切法界。悉无有余。一切诸佛。知一切语言道。悉无有余。一切诸佛。知一切世间成坏。悉无有余。一切诸佛。知一切众生及其智慧。悉无有余。一切诸佛。知一切菩萨善根上中下相。悉无有余。一切诸佛。知一切佛满足智慧。悉无有余。一切诸佛。知一切法皆从缘起。悉无有余。一切诸佛。分别了知一切世界。悉无有余。一切诸佛。智慧分别一切法界如因陀罗网。悉无有余。佛子。是为一切诸佛知十种法悉无有余

佛子。一切诸佛。有十种最胜力。大力。无量力。大功德力。尊重力。不退转力。坚固力。不可坏力。一切世间不能思议力。一切众生不能坏力。大力那罗延幢佛所住法。何等为十。一切佛身。举世栽横所不能坏。诸佛命根。世间诸毒所不能害。一切世界火劫起时不能烧热。水劫起时不能浸溺。风劫起时不能散坏。一切魔军天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽罗刹毗舍遮人非人等一切众生悉雨金刚。如须弥山金刚围山。三千大千世界。尔所等雨。雨于佛上。不能令佛生怖畏心。一毛不竖。行住坐卧威仪不改。随诸如来所住方面。金刚雨渧终不得下。欲雨不雨。随如来意。佛所住持众生及佛使命尚不可害。何况如来。佛子。是为一切诸佛第一大力那罗延幢佛所住法。佛子。一切诸佛。一切法界等世界中。须弥山王金刚围山大金刚围山。一切大海一切诸山及一切众生。于一毛孔悉能容持。尽未来际劫。一切众生。悉不自知我住何所。除佛神力。一毛悉持一切众生。遍游十方无量世界。行住坐卧。而诸如来。不生苦恼厌倦之心。威仪无异。佛子。譬如虚空容持一切法界等世界。不生苦恼厌倦之心。一切诸佛亦复如是。于一毛孔。容持无余世界一切众生。不生苦恼厌倦之心。佛子。是为一切诸佛第二大力那罗延幢佛所住法。佛子。一切诸佛。一步能过不可说不可说世界微尘等佛刹。于一念中。能行不可说不可说世界微尘等步。以如是步。经一切世界微尘等劫。于念念中。能经一切世界微尘等劫。一金刚围山与上诸劫所经世界微尘佛刹等。如是等不可说不可说世界微尘数诸金刚围山。内一毛孔。一切毛孔。亦复如是。如来毛孔悉与一切众生毛孔数等。以如是毛孔。如是远步如是速疾。游行十方一切世界一切虚空界。尽过去未来际一切诸劫。如是诸劫犹可穷尽。而诸如来身无羸弊。心不退没。不舍三昧一切佛事。佛子。是为一切诸佛第三大力那罗延幢佛所住法。佛子。一切诸佛。一食结跏趺坐。尽过去未来际不可说不可说一切劫。身不倾动。住不思议佛住。受寂灭乐。乃至不失化一众生。以一切世界及一切众生。安置如来一指端上。尽未来际劫。彼一一众生。其身悉如不可说不可说佛刹微尘等世界。彼一一众生。其身重如一切世界。而诸如来。身无疲倦心无苦恼。如一指端。一切指端亦复如是入一一世界。入虚空界。入一切方网。如是一切处虚空界。悉无有余。究竟法界。以一毛端。量一切世界。一一毛端处结跏趺坐。尽过去未来际劫。佛子。是为一切诸佛第四大力那罗延幢佛所住法。佛子。一切诸佛。于一身化不可说不可说佛刹微尘等头。一一头。化不可说不可说佛刹微尘等舌。一一舌。出不可说不可说佛刹微尘等音声。一切法界众生无不闻者。一一音声。说不可说不可说佛刹微尘等修多罗。一一修多罗。说不可说不可说佛刹微尘等法。一一法中。说不可说不可说佛刹微尘等句身味身。如是说法。乃至尽不可说不可说佛刹微尘等劫。复不可说不可说佛刹微尘等劫。说异句身味身。尽一切世界微尘等劫。一切众生念等劫。尽未来际一切劫。此诸劫数犹可得尽。如来化身说法转一切法犹如火轮。自在智慧说一切法。转正法轮。除灭一切众生疑惑。转正法轮。照一切法。转正法轮。皆悉开发一切法藏。转正法轮。欢喜调伏庄严一切众生。转正法轮。说诸菩萨庄严法行。转正法轮。令大乘智日圆满庄严。转正法轮。令一切无余众生。以大乘智而自庄严。转正法轮。一切诸辩无畏而自庄严。如一如来一化身。转如是等不可譬谕法轮云。一切法界虚空界等世界。悉以毛端周遍度量。一一毛端处。于念念中。化不可说不可说佛刹微尘等身。乃至尽未来际劫。一一化佛身。有不可说不可说佛刹微尘等头。一一头。有不可说不可说佛刹微尘等舌。一一舌。出不可说不可说佛刹微尘等音声。一一音声。说不可说不可说佛刹微尘等修多罗。一一修多罗。说不可说不可说佛刹微尘等法。一一法中。说不可说不可说佛刹微尘等句身味身。复不可说不可说佛刹微尘等劫。说异句身味身音声。充满法界。一切众生无不闻者。尽一切未来际劫常转法轮。如来音声无异无断不可穷尽。佛子。是为一切诸佛第五大力那罗延幢佛所住法。佛子。一切诸佛。成就胜妙大庄严胸德字相。犹如金刚不可破坏。如来坐彼菩提树下。有无量化魔王军众。悉与一切众生数等。杂恶形色甚可怖畏。能发狂乱。悉能恐怖一切世间。如是等众。充满虚空法界等一切世界。杂恶形色甚可怖畏。能发狂乱。能令一切众生怖畏。能坏一切世间。能害一切众生。如来见已心无恐怖。一毛不竖颜无异容。乃至不生一念微畏之相。心安不动形色无异。远离觉观心常寂静。究竟远离一切恐怖。除灭一切爱恚烦恼。安住佛住。具足无碍大慈之力。住大悲住。诸根寂静永离恐怖。胸德字相不可破坏。坚固真实。一切诸魔魔天眷属。见如来已皆悉归依。如来于彼三轮教化。皆令调伏发菩提心悉不退转。乃至令得无上菩提。佛子。是为一切诸佛第六大力那罗延幢佛所住法。佛子。一切诸佛。出无障碍微妙音声。皆悉充满一切世界。随所应度无不闻者。彼诸如来所出音声一切众山所不能障。须弥山王宝山。小金刚围山大金刚围山。所不能障。天宫龙宫夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切宫殿。所不能障。一切世界高大音声。亦不能障。随其所应皆悉闻之。无所障碍。佛子。是为一切诸佛第七大力那罗延幢佛所住法。佛子。一切诸佛心无障碍。于不可说不可说亿那由他劫。心常清净。三世诸佛离垢清净。同一庄严离我我所。于一切法亦无所依。非内非外。非生非不生。离一切境界。寂灭无处。无所造作。离种种相。除灭一切虚妄取相。自然清净。离诸境界无所忆念。随顺境界无诤之法。离欲清净。住真实际。说法界际。法界平等而无有尽。一切众生莫能知者。永离一切有为无为。舍离一切言语道境界。究竟无碍无尽法界。随智慧转。十力庄严。净一切法行巧方便说种种法相。即一法相一切法相不相违背。不坏三世于一切法界。究竟自在到于彼岸。具足甚深自在法藏。一切方便离痴正念。安住十方一切佛刹。而无动转。具不死智尽一切漏。究竟诸法证于无漏。心慧解脱究竟实际。住无碍住常定无乱。于三世法无有障碍。于一念中。悉了三世一切众生心心所行。佛子。是为一切诸佛第八大力那罗延幢佛所住法。佛子。一切诸佛。具足成就细密法身。诸佛法身境界无量。一切世间所不能知。于三界中无所染污。随因缘应一切普现。非实非虚平等清净。非去非来无为无坏。清净常住。一相无相。是法身相。非处非方。一切身身。自在无量。妙色无量。摄一切身。作种种身。随方便身。普照一切。具足智藏。而无种种分别。其身充满无余世界。说一切法界虽动非动。清净法身。非有非无。非方便。非不方便。随众生所应。悉能示现。非灭非不灭。亦非不现。而化众生。一切功德宝所起之身。一切法佛法起。如如法身自然寂静。于一切法无所障碍。随顺一切法界。清净一切世间。分别一切世间。无有动转。无有境界。如来解脱摄一切智。随顺一切身。佛子。是为一切诸佛第九大力那罗延幢佛所住法。佛子。一切诸佛。正觉悉等。出生一切诸菩萨行。所行不虚。满足深愿。净菩萨行。具足一切菩萨行智。一切诸佛。修菩萨行悉无有异。善分别知一切菩萨行。满足菩萨诸大愿海。离一切恶生诸善行。修菩萨行皆悉清净。随顺一切佛。寂然不放逸。住一切三昧无量境界。能教一切胜道。远离一切恶道。究竟彼岸。具足成就第一智力。雨无畏法雨。随其所问悉能善答。方便说法。智慧平等周遍清净。身口意业皆悉清净。住诸佛住。诸佛种姓。佛智所作。悉不退转。一切种智。分别无量无边诸住。一切智明。随顺智慧。不可思议。一切世间所不能解。智慧明净知一切法。微细智慧无量无边。善能分别一切三世。智慧微妙。觉悟一切世界。具足了知无上道义。于一切世间作不可说佛事。智慧不退。成就一切诸如来身。入算数智。决定了知一切诸法。舍离文字。言语道断。而善能说一切文字。行净善法满普贤智。于一念中。悉能觉了一切诸法。随净众生随所应乘悉能法施。以明净智。解一切法境界。一切世界境界。一切众生境界。于一念中。悉能知见三世法界。一切如来出世境界。一切教化境界。未曾失时。至于一切清净境界。觉一切境界。皆悉究竟。于一念中。觉悟三世众生心意识行。诸佛平等。众生无边。世界无边。法界无边。三世无边。一切诸佛自在无边觉如是等无有障碍。诸佛智慧。诸佛自在转。无量无边诸佛所住。住无碍住。无碍心住。住大悲住。广说深法教化众生心无休息。是为一切诸佛第十大力那罗延幢佛所住法。佛子。是为一切诸佛十种大力那罗延幢佛所住法。无量无边不可思议三世一切众生。声闻缘觉皆不能知。除佛神力

佛子。一切诸佛。有十种定法。何等为十。一切诸佛。定于兜率天尽其寿命。一切诸佛。定示现处胎满十月生。一切诸佛。定舍宫馆乐行出家。一切诸佛。定坐菩提树下觉一切法。一切诸佛。定一念中觉一切佛法。于一切世界。普现如来神力自在。一切诸佛。定随时教化转正法轮。一切诸佛。定知随时种诸善根为彼授记。一切诸佛。定随应时不失佛事。一切诸佛。定知菩萨功德具足而为授记。一切诸佛。定随众生一切问难。于一念中悉能善答。佛子。是为一切诸佛十种定法。佛子。一切诸佛。有十种法。若有众生见如来者。皆悉疾得十种果报。何等为十。若有众生见如来者。疾得远离一切恶道。若有众生见如来者。疾得长养一切善根。若有众生见如来者。疾得满足一切善根。若有众生见如来者。疾得往生净妙天上。若有众生见如来者。疾得除灭一切疑惑。若有众生见如来者。已发菩提心者。疾得不退转。未发心者。速发阿耨多罗三藐三菩提心。若有众生见如来者。未得离生圣道。除灭有见。速令正取离生圣道。若有众生见如来者。速令清净世间。离世间一切诸根。若有众生见如来者。疾得除灭一切障碍。若有众生见如来者。疾得无畏不断辩才。佛子。是为一切诸佛众生见者皆悉疾得十种果报。佛子。一切诸佛。有十种清净法。一切菩萨应常正念。何等为十。一切诸佛过去方便。一切菩萨应常正念。一切诸佛清净妙行。一切菩萨应常正念。一切诸佛满足波罗蜜。一切菩萨应常正念。一切诸佛满足大愿。一切菩萨应常正念。一切诸佛功德积聚一切菩萨应常正念。一切诸佛过去梵行。一切菩萨应常正念。一切诸佛成等正觉。一切菩萨应常正念。一切诸佛色身无量无边。一切菩萨应常正念。一切诸佛无量无边神力境界。一切菩萨应常正念。一切诸佛十力无畏。一切菩萨应常正念。佛子。是为一切诸佛十种清净法一切菩萨应常正念

佛子。一切诸佛。有十种一切智住。何等为十。一切诸佛。于一念中。悉知一切法界三世一切众生心心所行。一切诸佛。于一念中。悉善分别三世一切众生种种业报。一切诸佛。于一念中。随一切众生所应度者。或以神足或以教诫。或以说法而教化之。一切诸佛。于一念中。悉能善取一切法界十方众生诸心心相。示现一切世间如来出世。一切诸佛。于一念中。随一切法界中一切众生希望欲性。所应化度令见如来。一切诸佛。于一念中。示现一切法界中一切众生如来住持神力自在。一切诸佛。为一切法界中一切众生。说一切佛离诸炽然。随其所应化度众生。一切诸佛。于一念中。以一切至处道。悉知一切法界中一切众生彼彼诸趣。一切诸佛。于一念中。一切法界中一切方处一切众生。念如来者悉令得见。一切诸佛。于一念中。随一切法界中众生心之所乐。如来形色悉令得见。佛子。是为一切诸佛十种一切智住。佛子。一切诸佛。有十种无量不可思议三昧。何等为十。一切诸佛。于一切法常定不乱。于一念中。为一切众生说一切法。一切诸佛。于一切法界一切众生。常定不乱。于一念中。悉为众生分别演说无我实际。一切诸佛。于一切法界三世诸法。常定不乱。于一念中入亿三昧。一切诸佛。于一切法界十方佛刹。常定不乱。于一念中。悉遍游行一切佛刹。一切诸佛。于一切法界普现无量无边佛种种身。常定不乱。于一念中。一切世界无不遍现。一切诸佛。身口意业充满一切法界。常定不乱。于一念中。分别演说一切众生心藏欲性。一切诸佛。于一切法界一切法性常定不乱。于一念中。悉能究竟离欲实际。一切诸佛。于一切法界一切世界缘起。常定不乱。于一念中。分别演说一切因缘。一切诸佛。于一切法界一切世间离世间法。常定不乱。于一念中。无量庄严。为一切众生普现诸佛无有穷尽。一切诸佛。于一切众生一切法界。正受无碍。常定不乱。于一念中。至诸佛趣无量解脱究竟彼岸。佛子。是为一切诸佛十种无量无边不可思议三昧。佛子。一切诸佛。有十种无碍解脱。何等为十。一切诸佛。于一微尘中。悉能普现不可说不可说诸佛出世。一切诸佛。于一微尘中。悉能普现不可说不可说诸佛转净法轮。一切诸佛。于一微尘中。教化调伏不可说不可说众生。一切诸佛。于一微尘中。普现不可说不可说佛刹。一切诸佛。于一微尘中。授不可说不可说菩萨记。一切诸佛。于一微尘中。普现三世诸佛出世。一切诸佛。于一微尘中。普现三世一切佛刹。一切诸佛。于一微尘中。普现三世诸佛自在神力。一切诸佛。于一微尘中。普现三世一切众生。一切诸佛。于一微尘中。普现三世一切诸佛佛事。佛子。是为一切诸佛十种无碍解脱

大方广佛华严经卷第三十一大方广佛华严经卷第三十二

        东晋天竺三藏佛驮跋陀罗译

    如来相海品第二十九

尔时普贤菩萨摩诃萨。告诸菩萨言。佛子。谛听谛听善思念之。当为汝说如来相海。如来顶上有大人相。名曰明净。三十二宝以为庄严。普放无量大光明网。遍照一切十方世界。如来顶上有大人相。名曰普照佛方便海。圆满杂宝以为庄严。种种摩尼宝王庄严。金刚光明世界所起。普照一切法界。如来顶上有大人相。名充满法界云。妙宝光明。普照一切法界一切世界。如来功德智慧十方世界海云。菩萨功德海云。如来顶上有大人相。名曰普照。悉现不可思议诸佛世界。金刚摩尼妙宝光明。观无厌足。如众宝华聚奋迅。普照一切法界佛宝光明。如来顶上有大人相。名琉璃宝。普照一切法界大自在云。摩尼宝王相种种庄严。普照一切十方世界。叹佛功德因缘所起。悉放如来大宝光云。普照菩萨于道场树结跏趺坐。普现菩萨自在神力觉如来力。普照一切十方佛刹六种震动。于大法界虚空中。普现无量自在一切智云。如来顶上有大人相。名曰平等。如来音声灯云离垢宝海。放诸光明。普照一切法界十方世界菩萨功德海。安立三世佛智幢海。如来顶上有大人相。名佛光广云。伊那罗宝如意王宝摩尼王宝。以为庄严。普照一切世界法界。菩萨光焰灯云。普照一切如来妙色音声海。及世界海净佛力海。如来有大人相。名圆满光明云。种种宝华庄严。琉璃摩尼宝王光明。赞叹法身及诸菩萨。一切十方世界海中。叹如来地。令一切众生趣向如来诸力境界。普现无量无边如来净地离垢清净。放大光明。普照一切诸佛世界。如来有大人相。名菩萨行藏光明云。无量世界中如来。放无量种种色宝光明。普照一切法界佛刹。出生无量如来妙音。皆悉分别演说如来甚深大法。如来有大人相。名普照云。琉璃伊陀罗金刚宝无量色清净摩尼宝庄严。放琉璃色光明。皆悉遍照一切诸海。出佛无量微妙音声。充满一切十方世界。普现一切佛智慧海无量化身。如来有大人相。名曰觉云。佛顶右面以杂宝华焰庄严。于一切世界庄严道场。清净一切法界世界。令一切虚妄皆悉解脱。觉净法界。如来有大人相。名光明云。以心海王如意法宝庄严。如来顶相。普照十方世界诸菩萨云。长养最上智身法身。行于一切如来相海。满足一切菩萨法界云。如来有大人相。名一切庄严云。金刚琉璃华普照庄严。一切法界海。世界众宝莲华。以为庄严。皆悉充满一切法界。四种菩萨行。自在师子吼。充满一切法界海。如来有大人相。名佛三昧海行云。庄严一切法界海。于念念中。普现无量如来庄严。充满一切不可思议法界世界。如来有大人相。名化海普照云。妙宝莲华如须弥山王。出生无量宝光明海。佛意所起。卢舍那所化。出生无量一切化海。如来有大人相名一切如来解脱云。离垢胜宝以为庄严。普照庄严一切如来师子之座。于其座内。悉现一切如来色像。放大宝光明。演说无量佛法大海。庄严一切诸佛刹海。如来有大人相。名觉佛种姓云。于琉璃华金宝莲华。放无量宝正法光明云。严净一切如来光明。普现一切清净法界。众宝光明无坏解脱。遍入甚深诸法界海。普现无量自在力海。如来有大人相。名无量宝光明轮。示现过去清净善根。出生清净智日。普照十方智慧法海。如来有大人相。名普照自在云。如来顶宝妙解脱华琉璃光明。普照一切法界海佛。悉现一切诸佛刹海。具足圆满如来智慧。如来有大人相。名入一切普照光明。如来宝相清净庄严。普照一切无量无边如来菩萨妙智慧藏一切法界。如来有大人相。名明净云。宝华琉璃月。放无量百千光明。普照一切法界虚空界一切佛刹。普现十方一切如来。如来有大人相。名觉光明云。一切宝光明普照一切法界诸佛转净法轮。悉放如来妙光明云。普照一切十方世界。如来有大人相。名普现一切庄严云。无量宝光明。于一念中。一切法界。普现一切菩萨坐于道场菩提树下成等正觉。又能普现一切诸佛。如来有大人相。名法界因云。如意妙宝庄严。见无厌足。放大宝光明网。普现一切众生诸业报海。如来有大人相。名曰普照净法轮云。能令如来正法清净。普照庄严一切佛刹。深解一切不思议法海。普照过去未来现在诸佛法界。出生无量如来化身。如来有大人相。名普照诸佛海云。十方一切世界海中。悉离障碍普见一切。如来海云。如来有大人相。名净灯云。方便深入一切众生一切菩萨一切如来不可思议法界海云。普照一切法界觉云。如来有大人相。名分别法界云。如来智慧广照佛地一切菩萨众无量法海无量佛刹。令一切众生入佛境界。具足普贤菩萨愿行佛平等智一切诸明。如来有大人相。名一切世界海安住普照云。一切法界虚空界宝光明云。见无厌足。普现道场一切菩萨诸如来身。出生无量普功德云。如来有大人相。名一切宝光焰云。于佛眉间相中。出生无量净宝光明。普照一切十方世界。净照一切诸佛菩萨行。法王光明普照法界。悉能长养一切光明。一切法界光明庄严。普照一切诸菩萨海。如来力云。普照一切十方佛刹。如来有大人相。名一切法界庄严云。如来顶相随次渐起。阎浮檀金众宝庄严。放种种金色光明。于念念中。普现一切世界诸佛。悉能普照一切佛刹。庄严一切菩萨诸功德藏。如来顶相。悉能庄严三十二相。又能庄严一切法界。如来有大人相。名普照法界遍光明云。佛眉间相。悉能普照一切妙宝一切众色一切日月一切佛海。出生十方无量光明海。庄严一切诸如来身。演说一切如来法海。如来有大人相。名自在云。佛清净眼。众宝庄严慧眼清净。于诸法界无所障碍。吉光明云示现一切。如来有大人胜妙鼻相。清净众宝以为庄严。一切众宝妙色为覆。佛宝华云。一切菩萨无能思议。悉知一切众生诸佛法海。如来有大人广长舌相。悉能遍覆十方世界一切海云。过去修习善根所得。一切宝王清净光明。普照一切法界尸罗之心。又照一切三世诸佛。悉能庄严一切法界。出生无量微妙音声。不思议宝以为庄严。普照无量诸光明海。佛妙音声。悉遍充满一切法界诸世界海。如来有大人相。名法界地云。舌掌安住。一切众宝以为庄严。安住一切法。出生十方诸佛具足音声。悉能清净一切佛刹。分别一切诸佛不可思议音声海云。如来有大人相。名顺法界云。舌端妙相。金色净宝以为庄严。出生无量金色光明。普照一切诸如来海。大师子吼震妙音声。悉皆遍至一切世界。一切众生无不闻者。于不可思议劫修行所得。普现一切诸音声海。普照一切众生。乐闻无有厌足。如来有大人相。名平等法门云。佛舌端相。令无量佛刹皆悉清净。如意妙宝以为庄严。出生无量种种音声。赞叹一切诸佛法界。普现一切菩萨法界。妙功德云。普覆一切诸佛菩萨。深入一切诸佛菩萨法。悉现一切离垢众宝清净佛刹。悉能普照一切佛刹。如来有大人龂齶相。伊陀尼罗净琉璃宝。以为庄严。诸法界地悉在其内。诸菩萨云皆悉充满。出生离垢妙宝光明。普照十方种种香云种种灯云。普照菩萨内诸楼阁。分别一切诸佛刹海。方便安住自在神力。普现不可思议诸法界云。如来有大人相。名佛大牙云。如来右面下大牙相。众宝庄严。放大光明轮。普照法界及诸佛身。普放光明网。照十方世界海及众生海。妙安隐轮以为庄严。如来有大人相。名宝焰须弥藏。如来右面上大牙相。如意宝王藏胜香焰云。照以庄严。放宝光明与法界等。一一光明内。普现一切诸佛自在。一切佛刹庄严道场。如来有大人相。名照一切宝须弥山灯云。如来左面下大牙相。分别解说一切诸相。香华众宝妙方便轮以为庄严。放宝光明云。普照一切世界海。普现一切佛莲华藏师子之座。离垢菩萨海云眷属围绕。如来有大人相。名普照佛云。如来左面上大牙相。清净众宝。及阎浮檀宝网轮华。以为庄严。出生不可思议微妙音声。普现一切如来自在神力。成就一切菩萨功德普照一切虚空。及语言法。无尽法云。一切法海。诸佛音声。及一切宝。出生分别一切诸佛众妙音声。充满法界。如来有大人相。名金慕耆婆。如来一一齿间。出无量相海门云。种种色宝。放大光明海。阎浮檀金色。普照法界一切世界一切如来。如来有大人相。名一切宝地云。如来右肩相。一切宝色。净莲华色。明净宝色。光焰普照一切菩萨内法藏云。悉照一切如来法海。如来右肩平满大人相。清净阎浮檀金色普照菩萨法轮法界。及照一切如意宝王。如来有大人左肩相。阎浮檀莲华色。如来圆满诸功德海。以为庄严。普放无量诸光明网。悉照一切世界法界。示现如来无量自在诸神力云。如来有大人相。名周遍普照云。如来左肩相。众宝庄严。放阎浮檀金色光明。悉能充满一切法界。普照一切诸如来海。种种宝香。庄严一切诸佛刹海。如来有大人相。名普照庄严云。如来右肩无有动转。出生无量佛灯光明。垂法界云。充满菩萨众普照庄严一切法界。如来有大人相。名海顶云。如来胸有胜妙相海。以为庄严。柔软细滑。种种众宝。焰轮庄严。周遍清净。开发甚深法海音声。如来有大人相。名胜妙相续普现云。如来右胁胜妙清净。法界轮地以为庄严。清净宝网而弥覆之。出生无量如来化云。普照一切十方法界。如来有大人相。名普现如来云。胜妙功德藏菩萨功德宝天冠。普照极高云。离垢清净。普现十方无量诸佛自在神力。开示三世一切诸佛法海净行。坐于道场菩提树下成等正觉。如来有大人相。名开敷华云。如来胜妙功德相续。众妙宝华宝轮庄严。放香焰光明。普现一切莲华形色世界。如来有大人相。名可悦乐金色云。一切宝王藏胜妙功德相续。一切宝心王藏。放摩尼宝光明轮。离垢清净极大高显。普照一切诸佛内方便功德藏。普照一切法界。如来有大人相。名胜海云。胜上虚空宝。放香光明。普照十方一切道场。圆满琉璃宝香灯鬘。充满十方。如来有大人相。名电光云。下第二胜功德。平等地相莲华右旋。净菩萨众坐宝莲华。放佛藏光明。普照法界海。如来有大人相。名普现法界云。第三胜相海。具足成满一切宝海刹。普照开现无量菩萨法界。如来有大人相。名普照最高云。第四胜相海。放离垢众宝光明海。普照一切法界。一切如来。一切世界庄严。一切众生海。如来有大人相。名转一切法轮妙音声云。下分胜相离垢清净。一切正法道香焰光明。照一切佛内心相海一切法界。如来有大人相。名庄严云。第十胜相。宣畅十方一切诸佛菩萨净行。觉悟离垢清净光明。三世诸佛一切智海。庄严一切诸佛刹海。如来有大人手掌相。具足千辐宝轮。种种众宝以为庄严。放大光明普照法界。转正法轮。普照一切诸如来海。充满一切佛功德海。种种妙宝庄严法界。如来有大人相。名海照云。如来宝手众宝庄严。普放净月光明焰云。庄严虚空如来菩萨诸世界海。赞叹菩萨行海。如来有大人相。名普庄严云。如来妙手因陀尼罗。琉璃宝华以为庄严。普照一切法界一切世界莲华藏菩萨安住宝藏。庄严十方一切道场。普照一切诸佛海云清净法身。如来有大人相。名离垢灯普照云。净宝光明放净光网普照十方。皆悉出生变化网云。庄严菩萨净宝光明。究竟一切诸法行海。到于彼岸。如来有大人相。名普现一切众宝云。宝藏海云。庄严如来莲华。充满一切众宝莲华。放宝光明云。普照一切法界。如来有大人相。名普照明净云。放宝焰光明海。照于法界。一切众香光焰庄严。普现宝华焰光。令一切佛世界网悉净庄严。普照一切道场。如来有大人相。名琉璃灯云。一切世界众宝色地普照庄严。皆放诸佛金色光明。以一切庄严而庄校之。于一念中。皆悉示现一切法门。如来有大人相。名智慧灯云。金刚宝华以为庄严。放阎浮檀金色光明。普照一切世界。如来有大人相。名安住莲华光明云。众宝妙华以为庄严。放大光明网。覆一切世界诸须弥山。如来有大人相。名充满法界如来云。离垢净宝以为庄严。放大光明。普照一切诸佛世界。悉见如来坐莲华藏师子之座。又复普照一切法界。现一切相如来妙手。普现一切自在之相。千辐相轮清净具足。种种众宝以为庄严。佛手充满一切刹云。普照一切诸法界云。如来有大人相。名曰成就佛刹海云。佛右手指宝相。清净法界。清净光焰。普照如净水月。出众宝华。出生一切妙宝音声。普现一切诸佛刹海。如来有大人相。名安住一切宝云。普照诸佛宝藏法界。于佛指相。出生如意妙宝王云。众宝庄严。放大光明网。普照一切法界云及诸佛云。普照庄严一切菩萨诸功德海。出生普贤菩萨净行妙音声海。一切佛刹无不闻者。又开发普照诸菩萨心。皆悉满足无量大愿。摩尼宝王以为庄严。种种日光轮。皆悉普照一切法界。如来有大人宝马藏相。隐密于右。众宝庄严。普照一切法界及虚空界。一切众宝庄严法界海。出生一切如来庄严微妙音声。如来有大人相。名曰一相现一切相海云。如来安处福田之座。一切众宝以为庄严。出生无量不可思议妙宝光明。普照十方一切法界。普现分别一切众相。现一相云。照现一切诸佛自在神力。如来有大人相。名一切法界海云。普照十方诸如来座及一切法界法轮法海。悉能示现一切相云。如来有大人相。名普示现云。如来右髀众宝庄严。放于妙法种种香光。随顺安住出诸音声。一切宝王以为庄严。于念念中。悉能示现心王海云。如来有大人相。名普照一切回向海云。如来左髀。悉遍充满一切宝海。随顺安住法海庄严。放一切光明海。悉能普照一切众生无量佛海。如来有大人相。伊尼延右腨。放阎浮檀金色光明。普照一切世界。震动无量诸佛刹土。出佛音声一切普闻。出生无量菩萨化身。充满一切诸佛世界及虚空界。放明净光明庄严普照一切。令诸佛刹皆悉清净。菩萨变化藏诸法界云犹若虚空。如来有大人相。伊尼延左腨。如炼金色。常放一切妙宝光明。充满无量诸佛世界。开发一切诸佛法化。庄严无量诸佛法海。如来有大人相。名毛端内现一切佛刹。于一毛孔。悉放一切宝光明藏。普照十方一切法界。于一毛孔。示现一切如来自在诸法界云。如来有大人相。名菩萨海庄严云。如来金刚足下。阎浮檀金色。放一切宝光明网。充满十方诸佛刹云。开发一切菩萨法化。出生无量菩萨变化。放一切宝香光明。住菩萨海。能于一步遍诸佛刹。如来有大人相。名明净云。佛足趺上。一切众宝以为庄严。放妙宝光明。示现一切诸佛菩萨大光明藏。普照无量诸如来云。如来有大人相。名曰觉云。普覆一切如来指间。众宝王庄严。放诸宝光。于念念中。示现一切诸佛自在。普照无量诸佛法海。示现一切道场。悉照未来无量际劫。如来有大人相。名曰遍照法界海云。如来足下千辐相轮。种种庄严。放百千众宝光明。普照一切法界诸世界海。众宝灯焰妙庄严藏。普照十方一切诸佛。无量香光以为庄严。普照一切净法界海。如来有大人相。名示现一切诸佛海云。清净如空。照诸法海。充满十方。发起一切诸菩萨云。出妙音声云。众宝华云以为庄严。香灯光焰。示现普照一切世界。如来有大人相。名自在光明云。众宝庄严。示现一切诸佛光明。净法界海及诸道场。常放如来智慧光明。一切众相悉为一相。法界无杂种种庄严。如来有大人相。名法界海音声云。如来足下后分。众宝庄严。普照一切诸法界海。一切诸佛自在庄严。普入化轮。覆一切法界。于一一身。出生法界妙音声云。如来有大人相。名深宝原底众宝庄严。放阎浮檀金色圆满光明。普照十方世界法界显现一切庄严道场。如来有大人相。名一切宝月光明伊那尼罗宝藏庄严照法界云。于念念中。悉能示现如来法海。如来有大人相。名普云藏。右虚空宝云最高宝。光明照一切佛道场座藏。金刚伊那尼罗宝显现庄严。如来有大人相。名平等光云。众宝妙华以为庄严。出生甚深法界音声。遍一切法界及虚空界。于一一相。普照一切诸如来海。入佛甚深自在。菩萨法界海。说不可尽。如来有大人相。名示现庄严云。清净阎浮檀金色众宝庄严。普放种种妙色光明。遍照一切庄严佛刹。佛云充满无量世界。庄严菩萨自在法海。普照一切诸佛功德及诸菩萨解脱之藏。庄严法界。如来有大人相。名诸佛自在普示现云。转诸宝轮。众宝庄严。放不思议如来光明。妙香普闻一切世界无量佛海。演出一切佛音声海。于诸世界。现菩萨门佛自在云。佛子。于佛身中。有如是等十莲华藏世界海微尘数佛大人相。于诸肢节。种种妙宝以为庄严

    大方广佛华严经佛小相光明功德品第三十

尔时佛告宝手菩萨言。如来应供等正觉。有随形好名曰海王。彼出光明名曰明净。七百万阿僧祇光以为眷属。又菩萨摩诃萨。于兜率天。放大光明名曰幢王。普照十世界微尘数刹。遍照彼处地狱众生灭除苦痛。令彼众生十种眼耳鼻舌身意诸根行业皆悉清净。彼诸众生。见光明已皆大欢喜。命终皆生兜率天上。生天上已。闻天妙音。名不可乐。此音声语诸天子言。以不放逸故。于诸佛所种善根故。遇善知识故。卢舍那佛威神力故。于地狱命终生此天上。如来足下千辐轮中有妙光明。名普照王。于彼海王随形好处。悉放四十广大光明。一名清净功德。普照六十亿那由他佛刹微尘数世界。随众生境界。随种善根。随众生意。乃至普照阿鼻地狱。其中众生。命终皆生兜率天上。生天上已。闻天妙音。作如是言。善哉善哉。诸天子。卢舍那菩萨。今住离垢三昧。应当敬念。尔时诸天子。闻天劝化微妙之音。便作是念。奇哉奇哉。何由出此微妙音声。尔时音声。语诸天子言。我此天音。诸善功德之所成就。诸天子。如我说我。而不着我不着我所。一切诸佛亦复如是。自说是佛。而不着我不着我所。诸天子。如我音声。不从东方南西北方四维上下来。诸天子。业报成佛亦复如是。非十方来。诸天子。犹如汝等昔在地狱。不从十方来。但以颠倒愚痴缠故得地狱身。本无来处。如普照王光明。不从十方来。我天音声亦复如是。非十方来。但以三昧善根力故。出生如是微妙音声。般若波罗蜜力故。示现如是自在神力。诸天子。譬如须弥山王。有三十三天净妙宫殿种种乐具。不从十方来。我天音声亦复如是。诸天子。譬如亿那由他佛刹微尘数世界末为微尘。如是微尘数众生。我为说法。随彼所应令大欢喜。然我于彼不生厌恶心。不生疲倦心。不生放逸心。不生憍慢心。诸天子。卢舍那菩萨。住离垢三昧亦复如是。于右手掌随形好中。放一光明。出生无量自在神力。一切众生声闻缘觉所不能知。汝等应当往诣卢舍那菩萨恭敬礼拜。莫着五欲障诸善根。诸天子。譬如劫尽烧须弥山悉令消灭。诸天子。五欲缠心。修念佛三昧。皆悉除灭。是故诸天子。当知报恩。一向敬念卢舍那菩萨。诸天子。其有众生不知报恩。舍是身已入三恶道。诸天子。汝昔在地狱蒙光明恩。舍地狱已来生此天。应当长养彼诸善根。诸天子。譬如我天。非男非女。而能出生百千万亿不思议法。诸天子。如天子天女五欲乐具宫殿园林。皆悉如我不生不灭。色受想行识亦复如是。若如是知是名能入无著甚深三昧海。时诸天子。闻是音声欢喜无量。皆悉化作一万华云。一万香云。一万乐云。一万幢云。一万盖云。一万赞叹云。作是化已。往诣卢舍那菩萨所住宫殿。恭敬供养于一面住。而不见卢舍那菩萨。时有天子。作如是言。此菩萨者。今已命终。生净饭王家。乘栴檀楼阁。处摩耶夫人胎。尔时诸天子。以天眼观卢舍那菩萨摩诃萨。见梵身天欲界诸天恭敬供养。时诸天子。作如是言。我等若不先往恭敬供养卢舍那菩萨。乃至一念顷住兜率天起乐着心者。我则不可。尔时一一天子。与十那由他天子眷属。欲从天下至阎浮提。诣菩萨所。时天妙音语天子言。菩萨摩诃萨。亦不命终生于彼间。随所应化悉令彼见。诸天子。譬如我今非眼所见能出音声。菩萨摩诃萨。住离垢三昧亦复如是。非眼所见。而处处示现命终受生。舍离虚妄灭除憍慢无所染着。是故诸天子。应当速发阿耨多罗三藐三菩提心。令意清净。住威仪戒。悔过一切业障烦恼障报障邪见障。以法界虚空界众生界等善身口意业。以众生界等身。众生界等头。众生界等舌。悔过四障。时诸天子闻是声已。皆大欢喜心意柔软。问天声曰。菩萨摩诃萨。云何悔过。尔时天声。以菩萨摩诃萨三昧力故。天善根力故。答诸天子言。业障等罪。不从东方南西北方四维上下来积聚于心。菩萨摩诃萨。知此业等因颠倒起。不生疑惑。诸天子。如我天声。说随业报行。随戒随喜。随定寂灭。诸佛菩萨说我众生贪恚痴业。而实无我无有我所亦复如是。所作诸业于十方求悉不可得。诸天子。如我天声。少福众生所不能闻。除地狱众生应受化者。诸天子。声非生灭。一切诸业亦复如是。非生非灭。但随业行而受果报。诸天子。如我所出音声。于无量劫不可穷尽。诸天子。若谓音声有来去者。即堕边见。一切诸佛不说断常。除为众生方便说法。诸天。子如我天声。十方世界随所应化。皆悉得闻。一切诸佛亦复如是。随应度者皆悉得见。诸天子。譬如明净锭光金玻璃镜。与十世界等。于彼镜中见无量刹。一切山川一切众生。地狱饿鬼若好若丑。形类若干悉于中现。诸天子。于意云何。彼诸影像来入镜不。答言不也。诸天子。一切业报亦复如是。无来去处。而能出生善根果报。譬如幻师能幻人目。当知。诸业亦复如是。若如是知是名清净真实悔过。说是法时。百千万亿那由他佛刹微尘数诸世界中兜率天子。皆得无生法忍。无量无边不可思议阿僧祇欲界诸天子。皆发阿耨多罗三藐三菩提心。六欲天中一切天女。皆舍女身悉为男子。得不退转菩提之心。尔时诸天子。广闻普贤回向善根。悉得十地诸力庄严。具足三昧。皆悉成就众生界等善身口意业。灭一切障皆得清净。见百千万亿那由他佛刹微尘数七宝莲华。一一华上。皆见菩萨结跏趺坐放大光明。彼诸菩萨。一一随形好中。放众生界等光明。彼光明中。见众生界等诸佛结跏趺坐。随所应度而为说法。犹未能见离垢三昧之少分也。尔时诸天子。于一一毛孔。化作众生界等妙香华云。供养卢舍那佛。散香华已。一一华中见诸如来。时彼香云普熏无量佛刹微尘数世界。众生其蒙香者身心快乐。譬如比丘入第四禅。若有众生得闻此香。诸罪业障皆悉除灭。于色声香味触。内有五百烦恼。其外亦有五百烦恼。二万一千欲行烦恼。二万一千恚行烦恼。二万一千痴行烦恼。二万一千等行烦恼。此诸烦恼皆悉除灭。彼诸众生。具足种种净香自在光明善根。若有众生。见此盖云者。彼诸众生。种一恒沙转轮圣王所植善根。所谓白净宝网转轮王等。菩萨摩诃萨。安住如是转轮王处。于百千亿那由他佛刹微尘数诸世界中。教化众生。譬如明镜世界月王如来。十方无量刹中。比丘比丘尼优婆塞优婆夷。无有乃至一念不作化身来诣佛所而听法者。彼佛常为广说经法。乃至广为说本生经。闻彼佛名。命终之后皆生其国。菩萨摩诃萨。安住白净宝网转轮王处。亦复如是。放曼陀罗自在光明。若有众生。遇斯光者。皆得菩萨十地。当知此等众生。悉是先世修善根力。如得初禅。虽未命终见梵天处。得梵天乐。如是次第。得诸禅者。虽未命终而得彼乐。如是菩萨摩诃萨。安住白净宝网转轮王处。放大光明。名周罗摩尼。若有众生。遇斯光者。皆得菩萨十地。悉得无量智慧光明。得十种眼清净行业。乃至十种意清净业。具足成就净力三昧。如是成就清净肉眼。譬如菩萨摩诃萨。以左手持亿那由他佛刹微尘。东行过亿那由他佛刹微尘数世界。乃下一尘。如是东行尽此微尘。如是菩萨摩诃萨。悉能了知彼微尘数。亦识诸尘本刹来处及下尘之刹。乃至十方亦复如是。菩萨摩诃萨。复能还集此诸微尘。作一佛刹。于此佛刹亦分别知。佛告宝手菩萨言。于意云何。如是佛刹广大可思议不。宝手菩萨。白佛言。世尊。如是佛刹无量无边不可思议。世尊。奇哉奇哉。若闻是谕此人难得。闻而信者亦复难得。佛告宝手菩萨言。如是如是。若有善男子善女人。闻而信者我授彼记。速成阿耨多罗三藐三菩提。得一切种智。佛告宝手菩萨言譬如千亿佛刹微尘数世界。如上谕说。此一切刹末为微尘。彼诸世界一一微尘。悉与一切佛刹微尘数等。菩萨摩诃萨。取此微尘。展转更种。乃至八十。彼一一微尘生果。悉与一切世界微尘数等。菩萨摩诃萨。业报清净肉眼悉分别见。亦于念念中。见百千万亿那由他佛刹微尘等如来。佛告宝手菩萨言。譬如锭光玻璃珠照十佛刹微尘等世界。此珠白净宝网转轮圣王善根所成

大方广佛华严经卷第三十二大方广佛华严经卷第三十三

        东晋天竺三藏佛驮跋陀罗译

    普贤菩萨行品第三十一

尔时普贤菩萨摩诃萨。告诸菩萨言。佛子。如向所说是微少说。何以故。一切如来应供等正觉。为受化者随应说法。愚痴众生诸缠所缠。计我我所。着吾我见。常随颠倒。生邪见惑。起邪虚妄。为缚所缚。流转生死。远如来道。为如是等诸众生故。如来应供等正觉。出兴于世。佛子。若菩萨摩诃萨。起一嗔恚心者。一切恶中无过此恶。何以故。佛子。菩萨摩诃萨。起嗔恚心。则受百千障碍法门。何等百千。所谓受不见菩提障。不闻正法障。生不净国障。生恶道障。生八难处障。多疾病障。多被谤毁障。生闇钝趣障。失正念障。少智慧障。眼耳鼻舌身意等障。近恶知识障。近恶伴党障。近恶人障。与恶人同止障。不乐贤善共事障。远正见障。生外道家障。离佛正教障。入魔境界障。不见善知识障。诸善根障。增不善法障。生恶家障。生边地障。生恶人中障。生天贫穷障。生诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽罗刹中障。不乐佛法障。习童蒙法障。乐小乘障。不乐大乘障。多生惊怖障。乐生死障。着三界障。不护佛法障。不乐闻佛自在神力障。菩萨清净诸根障。离菩萨行障。离菩萨深心希望障。不摄正念障。不发起一切智心障。不净施行障。不净业障。不净报障。不成长诸力障。断智慧根障。不受持菩萨诸行障。诽谤佛法障。远离菩提障。不入佛境障。堕诸魔界障。不能求佛法障。闻诸菩萨大庄严事生恐怖障。不乐菩萨共住障。不乐求菩萨善根业障。邪见盖疑障。增益愚痴障。舍菩萨戒随顺破戒障。不信如来戒障。闻佛赞叹诸持戒者生嗔恚心障。离忍辱乐常懈怠障。谤诸菩萨不退精进障。舍三昧慧障。诽谤般若波罗蜜巧方便障。不知是处非处方便障。不知度脱众生方便障。不入菩萨诸深智障。不出生菩萨诸道障。于菩萨十种眼生盲障。于菩萨法不能出生无碍法流障。无碍耳鼻障。不具相好障。无碍舌障。不能别知众生音声障。于众生中生懈怠心障。狂乱业障。离三种戒障。无碍诸人障。口四过意恶业障。生增上贪恚邪见障。不求正法障。于菩萨法懈怠心障。菩萨精进法中疑惑心障。舍离菩萨决定法障。损减菩萨智慧门障。损减正念障。远离佛法障。不习菩萨离生法障。菩萨谦下心障。远离声闻缘觉离生法障。不顺三世诸佛菩萨障。佛子。菩萨摩诃萨。起一嗔恚心。受如是等百障法门。乃至百千障碍法门。何以故。佛子。我不见有一恶法出过菩萨一嗔恚心。佛子。是故菩萨摩诃萨。欲疾具足菩萨行者。应当修习十种正法。何等为十。所谓不舍一切众生。于诸菩萨生如来想。常不诽谤一切佛法。于诸佛刹得无尽智恭敬信乐菩萨所行。不舍虚空法界等菩提之心。分别菩提究竟佛力到于彼岸。修习菩萨一切诸辩。教化众生心无疲厌。于一切世界示现受生而不乐着。佛子。菩萨摩诃萨。安住如是十种正法。则能摄取十种清净之法。何等为十。所谓于甚深法究竟清净。亲近善知识清净。能护诸佛正法清净。悉能分别空界清净。善入法界清净。智慧了诸心行清净。令诸菩萨善根清净。心常不着诸劫清净。智慧观察三世清净。成就诸佛种姓清净。佛子。菩萨摩诃萨。安住如是清净正法。则能具足十种正智。何等为十。所谓分别众生心心行智。分别众生诸业报智。普照一切诸佛法智。于诸佛法得方便次第智。具足一切总持门智。成就一切文字辩智。善知众生一切语智。示现一切世界身智。具足普照一切众生智。于一切趣得一切智。佛子。菩萨摩诃萨。安住如是十种正智。则入十种巧随顺入。何等为十。所谓一切世界入一毛道。一毛道出不可思议刹。一切众生身悉入一身于一身出无量诸身。不可说劫悉入一念令一念入不可说劫。一切佛法悉入一法令一法入一切佛法。一切诸入入于一入令一入入一切诸入。一切诸根入于一根令一根入一切诸根。一切诸根入非根法非根法入一切诸根。一切诸相悉入一相一相入于一切诸相。一切语音入一语音一语音入一切语音。一切三世悉入一世令一世入一切三世。佛子。菩萨摩诃萨。分别如是十种入法。则能安住十种直心。何等为十。所谓安住一切世界语言非语言法直心。安住正念一切众生直心。安住虚空界直心。安住法界无量无边直心。安住一切佛顺正法直心。安住甚深善法不坏正法直心。安住除灭一切疑惑直心。安住等观三世法直心。安住三世诸佛平等直心。安住诸佛无量力直心。佛子。菩萨摩诃萨。安住如是十种直心。则得诸佛十种巧方便法。何等为十。所谓得巧方便。普照一切诸佛深法。得巧方便。出生诸佛甚深胜法。得巧方便。分别演说一切诸佛庄严之法。得巧方便。深入一切佛平等法。得巧方便。分别别相一切佛法。得巧方便。入不可坏诸佛正法。得巧方便。入一切佛诸庄严法。得巧方便。以一方便入一切佛法。得巧方便。入佛无量诸方便法。得巧方便。于一切佛法心得自在而不退转。佛子。是为十种巧方便法。佛子。是故菩萨摩诃萨。应当一心恭敬听受是法。何以故。菩萨摩诃萨。得闻是法。以少方便。疾得阿耨多罗三藐三菩提。与三世佛等。尔时佛神力故。法如是故。十不可说亿那由他佛刹微尘等世界六种震动。雨出过诸天一切华云雨。妙香云雨。末香云雨。衣盖幢幡众宝庄严具云雨。妓乐云雨。诸菩萨云雨。不可说赞叹佛云雨。不可说赞叹善哉云雨。佛音声满法界云雨。不可说净世界云雨。不可说长养菩萨功德云雨。不可说光明云雨。不可说种种神力自在云雨。如此世界四天下佛坐道场。雨如是等种种云雨演说诸法。十方世界亦复如是。尔时佛神力故。法如是故。过十不可说世界微尘等刹。有十佛世界微尘数菩萨摩诃萨。来诣此土充满十方。作如是言。善哉善哉。佛子。能说如是诸佛如来最大誓愿授记深法。我等同号皆名普贤。于诸普胜世界诸普幢自在如来所。来诣此土。一切世界亦说此法。如是句身味身一切诸行无有增减。是故来此为汝作证。如是十佛世界微尘数菩萨摩诃萨。来此作证。一切十方诸如来所亦复如是

尔时普贤菩萨摩诃萨。以佛神力自善根力。观察十方及诸法界。欲明诸菩萨行诸佛菩提。欲说大愿。欲分别一切世界诸劫。欲明随时示现佛出世间。欲随众生根悉令受化。欲明如来诸所说法无有虚妄。欲随种善根果报不虚。欲明菩萨清净法身。出妙音声。觉悟众生。起菩提心故。以偈颂曰

  一切众欢喜　　除灭诸阴盖
  一心恭敬听　　菩萨诸愿行
  随三世菩萨　　所行诸愿行
  我当次第说　　菩萨胜妙法
  一切诸劫数　　及世界业数
  我说无等等　　应化兴于世
  见过去诸佛　　于彼发大愿
  饶益众生类　　除灭一切苦
  菩萨论师王　　所行无断绝
  得无等等法　　一切诸境界
  菩萨见过去　　一切诸导师
  放大光明网　　普照十方界
  发如是大愿　　我为世间灯
  功德庄严身　　具足十力智
  一切诸群生　　贪恚痴炽然
  我当为除灭　　无量恶道苦
  发如是誓愿　　坚固不退转
  具修菩萨众　　究竟无碍力
  如是誓愿已　　世间行不转
  所行无虚妄　　究竟论王法
  于一贤劫中　　千佛出于世
  随彼佛正法　　次第分别说
  如此贤劫佛　　无量劫亦然
  未来诸佛法　　我当次第说
  如一佛刹性　　无量刹亦然
  一切佛国性　　我悉分别说
  诸佛次兴世　　随愿随名号
  随彼所得记　　随其所寿命
  随所修正法　　专求无碍道
  随所化众生　　正法住于世
  随所净佛刹　　众生及法轮
  说法时非时　　次第净群生
  随彼众生行　　种种诸业性
  上中下差别　　随应所受化
  如是甚深智　　菩萨入是行
  修习普贤业　　具足智慧轮
  身业无障碍　　口业悉清净
  意业亦无碍　　通达三世法
  菩萨如是行　　究竟普贤道
  出生净智日　　普照诸法界
  于不可说劫　　及一切佛刹
  菩萨一念知　　于彼无所著
  行者入如是　　奇特甚深地
  菩萨妙法中　　我当说少分
  智慧无边际　　究竟佛境界
  善入一切处　　成就不退转
  具普贤净慧　　满足普贤愿
  菩萨究竟行　　深入无等智
  于一微尘中　　悉内一切刹
  见彼无量佛　　具闻演说法
  如一微尘中　　一切尘亦然
  见刹及诸佛　　是不思议智
  一一微尘中　　普现三世法
  五趣生死道　　皆悉分别知
  一一微尘中　　有无量佛刹
  一中知无量　　无量中知一
  如是法界等　　一切诸佛土
  同性及异性　　皆悉能了知
  深入微细智　　分别诸世界
  一切劫成坏　　悉能分别说
  知诸劫修短　　三世即一念
  同行不同行　　皆悉分别知
  深入诸世界　　清净不清净
  身中无量刹　　一刹无量身
  一切十方中　　无量诸世界
  种种无数性　　一切悉能知
  一切三世中　　无量佛国土
  具足甚深智　　悉了彼成败
  十方诸世界　　有成或有败
  普贤悉深入　　一切能了知
  以净慧眼见　　无量诸佛土
  分别知诸业　　随行故清净
  菩萨摩诃萨　　善知众生行
  以诸恶业故　　而得不净土
  无量无边刹　　即知为一刹
  如是入诸刹　　一切莫能知
  一切诸世界　　令入一刹中
  世界不积聚　　亦复不离散
  或伏或有仰　　或高或复下
  世界众生相　　菩萨皆悉知
  或有翻覆刹　　无量诸佛土
  知种种是一　　知一是种种
  普贤真佛子　　以不思议智
  知难思议刹　　了达无边际
  知诸世界化　　刹化众生化
  了知诸法化　　究竟诸佛化
  甚深世间法　　种种庄严事
  众生无量报　　皆心业庄严
  真佛子善学　　甚深妙法界
  具自在神力　　充满十方刹
  众生等诸劫　　常说世界法
  一切莫能知　　唯除等正觉
  世界及如来　　种种诸名号
  无量劫演说　　犹不能究竟
  何况心境界　　三世诸佛法
  真实妙法界　　诸佛一切地
  清净无碍念　　具足无碍智
  分别说法界　　智慧到彼岸
  如是诸世界　　无量业庄严
  菩萨一念中　　悉知三世刹
  于彼世界中　　行诸最胜行
  究竟等正觉　　显现自在力
  如是未来世　　一切世界中
  诸佛次兴世　　菩萨悉能知
  彼行诸妙愿　　境界修功德
  随劫成正觉　　菩萨分别知
  亦知彼寿量　　及所化众生
  随方便法门　　为众转法轮
  菩萨如是知　　具普贤行地
  成就一切智　　与诸如来等
  现在十方界　　无量诸佛土
  深入此世界　　通达诸法界
  于彼世界中　　现在无数佛
  无碍论山王　　究竟自在法
  知净土及众　　应化自在力
  尽无量亿劫　　常思惟是事
  调御世间尊　　成就自在力
  菩萨究竟度　　深入智慧藏
  菩萨具出生　　无碍眼耳身
  无碍广长舌　　令众悉欢喜
  最胜无碍心　　无量普清净
  甚深无碍智　　悉了三世法
  善学一切化　　刹化众生化
  能化世间化　　究竟化彼岸
  种种业庄严　　严饰诸世间
  成就佛智慧　　善知一切相
  一一如来身　　以无量方便
  随其所应化　　度脱无量众
  深入智境界　　出世间慧日
  所行不退转　　遍游一切刹
  深解诸世间　　如梦如幻化
  一切众生界　　了达悉如电
  不取虚妄劫　　及一切世间
  善解非真实　　于彼无所著
  无量无数劫　　解之即一念
  知念亦非念　　世间无实念
  不动于本座　　一念游十方
  无量无边劫　　常化诸众生
  不可说诸劫　　即是一念顷
  亦不令劫短　　究竟刹那法
  一切诸世间　　及诸众生心
  非一亦非二　　菩萨悉了知
  众生世界劫　　诸佛及佛法
  皆悉如幻化　　法界无有二
  普于十方刹　　示现无量身
  不取虚妄身　　法界无所著
  无二智慧中　　出生人师子
  不着不二法　　知无一二故
  菩萨知诸法　　如焰如电光
  如响亦如梦　　如幻如变化
  如是随顺入　　一切佛境界
  成就平等智　　普照深法界
  以无量大悲　　观察诸众生
  远离染着心　　清净观世间
  广净无尽身　　深入方便地
  菩萨常正念　　论师子妙法
  见世众苦恼　　发无量大愿
  所行皆清净　　普遍诸法界
  诸佛及菩萨　　佛法与世间
  菩萨方便观　　通达无差别
  清净法身藏　　一切诸世间
  世间及法身　　二俱无所著
  譬如净水中　　见影无所有
  法身至十方　　而亦无所至
  如此无所著　　世间清净身
  虽身而非身　　诸法无生故
  深入无尽身　　非生亦非灭
  非常非无常　　示现诸世间
  除灭恶邪见　　成就于正见
  平等观诸法　　不着我我所
  譬如工幻师　　示现种种幻
  本无所从来　　去亦无所至
  幻亦非有量　　亦复非无量
  于彼大众中　　示现量无量
  以此寂灭心　　修习诸善根
  出生诸佛法　　非量非无量
  有量有无量　　皆悉是妄想
  分别一切趣　　不着量无量
  诸佛甚深法　　寂灭最深妙
  甚深无量智　　知甚深诸趣
  菩萨离愚痴　　心意净无量
  修习诸善根　　具足无量愿
  度无量众生　　令至安隐处
  平等观法界　　于彼无所著
  深解真实际　　诸法无所有
  觉悟诸世间　　诸法无生灭
  深知一切法　　随应化众生
  普雨甘露法　　充满诸世间
  化无量众生　　令发菩提心
  不舍菩萨行　　皆得不退转
  随顺佛正法　　究竟得法身
  悉了知世间　　一切众生身
  分别诸众生　　及一切佛刹
  深入智慧海　　通达十方海
  如来净身中　　普现众生身
  菩萨明净眼　　悉皆能睹见
  无量亿劫中　　赞叹如来身
  穷尽一切劫　　犹尚不究竟
  菩萨摩诃萨　　于佛涅槃后
  能于念念中　　分布诸舍利
  如是未来世　　有求佛道者
  无量菩提心　　决定智能知
  如是三世中　　诸佛出于世
  安住普贤行　　皆悉分别知
  如是分别知　　无量诸行地
  成就坚固智　　能转不退转
  无量深智慧　　究竟如来境
  普贤明净智　　深入不退转
  一切最胜尊　　深入妙境界
  究竟不退转　　得无上菩提
  无量无边心　　一切种种业
  修习诸想行　　能于一念知
  染污不染污　　学心无学心
  菩萨一念中　　觉悟无量心
  了知非一二　　非秽亦非净
  亦复非积集　　皆从因缘起
  如是分别知　　一切众生心
  世间诸佛刹　　悉皆是虚妄
  如是妙方便　　深入菩萨行
  皆与普贤等　　如来法化生
  一切众生类　　善恶想不同
  或有生天上　　或堕诸恶道
  菩萨见世间　　皆从业缘起
  常着虚妄想　　流转于生死
  十方诸众生　　虚诳网所覆
  菩萨一念中　　方便令解脱
  如是诸根入　　眼耳鼻舌身
  分别知意业　　世间想不同
  一一眼境界　　出生无量眼
  种种相不同　　无量无有边
  随众生所行　　一切善恶业
  于彼得果报　　像类悉不同
  普贤清净眼　　深入诸地力
  一一眼境界　　出生无量智
  如是诸世间　　悉能分别知
  究竟一切行　　逮得不退转
  佛说菩萨说　　刹说众生说
  三世一切说　　菩萨分别知
  过去是未来　　未来是过去
  显在是去来　　菩萨悉了知
  如是无量世　　觉悟相不同
  方便究竟行　　具足诸佛智

    大方广佛华严经宝王如来性起品第三十二之一

尔时如来眉间白毫相中。放大光明。名曰明如来法。无量亿那由他阿僧祇光以为眷属。普照十方一切世界。围绕十匝显现如来无量自在。觉悟无数亿那由他诸菩萨众。一切世界六种震动。除灭一切诸恶道苦。映蔽一切诸魔光明犹若聚墨。显现一切如来菩提。显现一切诸佛大众。究竟庄严。普照法界虚空界等一切世界。复还围绕一切菩萨诸大众已。入如来性起妙德菩萨顶。尔时一切大众。心大欢喜身意柔软。作如是念。甚奇希有。如来今者放大光网。必当演说甚深正法。尔时如来性起妙德菩萨。于莲华座起。偏袒右肩。以右膝着莲华台上。一心合掌正向如来。以偈颂曰

  正觉一切法　　究竟诸境界
  三世大仙等　　是故恭敬礼
  究竟无相境　　相好庄严身
  普放离垢光　　除灭一切魔
  震动十方界　　一切诸佛刹
  众生不恐怖　　是佛威神力
  安住如虚空　　清净法界等
  除灭一切恶　　令众得清净
  无量劫苦行　　一心求佛道
  得无碍境智　　与诸如来等
  普放无量光　　震动一切刹
  显现自在力　　来入我身中
  善学诸菩萨　　皆悉来集会
  是故我发心　　应有法王事
  大众皆清净　　究竟菩萨行
  智慧无染着　　成就无所畏
  大仙行无量　　智慧力精进
  开发菩萨心　　如来甚深法
  正觉微妙义　　谁能演说者
  我今欲请问　　愿佛为显示

说是偈已。时如来口中放大光明。名无碍无畏。无量亿那由他阿僧祇光以为眷属。普照十方一切世界。围绕十匝。显现如来无量自在。觉悟无数亿那由他诸菩萨众。一切世界六种震动。除灭一切诸恶道苦。映蔽一切诸魔光明犹若聚墨。显现一切如来菩提。显现一切诸佛大众。究竟庄严。普照法界虚空界等一切世界。复还围绕一切菩萨诸大众已。入普贤菩萨摩诃萨口。尔时普贤菩萨摩诃萨身及师子座。殊胜百倍诸菩萨身及师子座。唯除如来所处之座。尔时如来性起妙德菩萨。问普贤菩萨摩诃萨言。佛子。佛所显现大威神力不可思议。是何瑞相。尔时普贤菩萨摩诃萨。答如来性起妙德菩萨言。佛子。如我惟忖。如我所见。过去如来应供等正觉。放大光明。必说如来性起正法。是故今佛放大光明。显自在力。必说如来性起正法。时如来性起妙德菩萨。闻如来性起正法名已。一切大地六种震动。出生无量论难光明。尔时如来性起妙德菩萨。问普贤菩萨摩诃萨言。佛子。云何菩萨摩诃萨。知如来应供等正觉性起正法。佛子。无数亿那由他菩萨摩诃萨清净众会。善学修行清净诸业。念慧成就。诸佛庄严。究竟彼岸。住佛威仪具如来行。正念诸佛未曾散乱。大悲观察一切众生。决定智慧。分别菩萨诸妙神通。得佛神力。安住一切诸佛功德。成就如是无量功德。诸大菩萨皆来集会。仁者。曾于无量亿那由他佛所。恭敬供养种诸善根。成就菩萨无上妙行诸三昧门。皆得自在。深入一切如来秘密。于诸佛法除众疑惑。深入佛法。善知一切众生诸根。随众生性而为说法。随顺佛智。分别演说一切佛法。究竟彼岸。成就如是等无量功德。善哉佛子。愿说如来性起正法。尔时如来性起妙德菩萨。欲重明此义。向普贤菩萨。以偈颂曰

  善哉无碍智　　觉悟一切法
  具足平等慧　　说佛无量境
  诸佛子闻已　　心皆大欢喜
  愿时为敷演　　如来性起法
  何等如来身　　清净妙音声
  云何如来心　　及无量境界
  何等如来行　　及诸佛菩提
  修习何等法　　速成等正觉
  云何转法轮　　清净妙胜法
  愿为分别说　　善逝涅槃法
  佛子等闻已　　欢喜心无量
  十方众生类　　皆见诸法王
  恭敬供养佛　　于彼种善根
  若有见诸佛　　恭敬种善根
  功德藏无量　　愿为分别说
  若有闻一切　　如来之名号
  十方现在佛　　及已般涅槃
  无尽功德藏　　闻名欢喜者
  彼得何等利　　哀愍分别说
  清净真佛子　　愿为广敷演
  分别深境界　　无量功德海
  一切诸菩萨　　皆一心合掌
  恭敬观善逝　　瞻仁兼及我
  巧语微妙音　　愿说真实义
  除灭诸疑惑　　清净如虚空
  因缘及譬谕　　为我分别说
  无量众闻已　　皆发菩提心
  一切诸如来　　相好庄严身
  充满十方国　　方便度众生
  出微妙音声　　演说无量法
  因谕随应化　　示悟佛菩提
  十方一切界　　无量佛刹中
  不可称说劫　　是会甚难见
  如此大众集　　清净诸佛子
  无量亿劫中　　难见亦难闻
  是故真佛子　　愿说微妙义
  显现广无量　　如来性起法
  一切诸菩萨　　皆一心合掌
  渴仰于大乘　　愿雨甘露法

尔时普贤菩萨摩诃萨。告如来性起妙德菩萨等诸大众言。佛子。如来应供等正觉性起正法不可思议。所以者何。非少因缘。成等正觉出兴于世。佛子。以十种无量无数百千阿僧祇因缘。成等正觉出兴于世。何等为十。一者发无量菩提之心不舍一切众生。二者过去无数劫修诸善根正直深心。三者无量慈悲救护众生。四者行无量行不退大愿。五者积无量功德心无厌足。六者恭敬供养无量诸佛教化众生。七者出生无量方便智慧。八者成就无量诸功德藏。九者具足无量庄严智慧。十者分别演说无量诸法实义。佛子。如是等十种无量无数百千阿僧祇法门。成等正觉出兴于世。佛子。譬如三千大千世界。非少因缘成。以无量因缘乃能得成。所谓兴大云雨。因大雨故起四风轮。何等为四。一名曰持。能持大水。二名渐消。渐消大水。三名曰起。起诸处所。四名庄严。庄严三千大千世界众生业报。如是四种皆众生业报及诸菩萨善根所起。佛子。如是等无量因缘。乃成三千大千世界。法如是故。无有作者亦无成者。如来应供等正觉亦复如是。非少因缘成。以无量因缘。成等正觉出兴于世。所谓菩萨摩诃萨。曾于过去无量佛所。闻受正法甘露大雨。因是能起如来四种智慧风轮。何等为四。一者正念持陀罗尼未曾忘失。如来大智风轮。能持如来一切法雨。二者止观如来大智风轮。悉能消灭一切烦恼。三者善回向如来大智风轮。成就一切功德善根。四者出生离垢诸庄严法如来大智风轮。皆令众生诸根清净相好庄严。如来无漏善根所成。法如是故。无有作者亦无成者。佛子。是为第一最胜法门成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如三千大千世界成时。大云降雨名曰洪澍。一切世界不能容持。除大千世界初始成时。如来应供等正觉。亦复如是。出兴于世。演说如来性起法雨。一切声闻缘觉不能受持。除成就诸力菩萨摩诃萨。佛子是为第二因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如众生业报大云降雨。无所从来去无所至。如来应供等正觉。亦复如是。以诸菩萨善根力故。演说如来性起法雨。无所从来去无所至。佛子。是为第三因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如大云降雨。大千世界一切众生无能知数。若欲算计令心狂乱。除大千世界主摩醯首罗天王。乃至一渧无不知者。以本善根果报力故。如来应供等正觉亦复如是。出兴于世。说如来性起甘露法雨。一切众生声闻缘觉所不能知。若欲思量令心狂乱。除一切世界主。菩萨摩诃萨乃至一句一味悉分别知。于过去佛所修地力故。佛子。是为第四因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如大云降雨。名灭炽然。或名能起。或名能坏。或名成宝。或名分别大千世界。如来应供等正觉。亦复如是。出兴于世。雨正法雨名曰除灭。除灭众生烦恼盛火。或有法雨名曰能起。能起众生一切善根。或有法雨名曰能坏。能坏众生诸恶邪见。或有法雨名曰成宝。能成众生一切智宝。或有法雨名曰分别。分别众生心心所行。佛子。是为第五因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如大云雨一味水。随其所雨而有差别。如来应供等正觉。亦复如是。雨于大悲一味法雨。随所应化种种不同。佛子。是为第六因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如三千大千世界初始成时。先成色界诸天宫殿。次成欲界诸天宫殿。次成人处及余众生诸所住处。如来应供等正觉。亦复如是。出兴于世。先起菩萨诸行智慧。次起缘觉声闻及余众生一切善根。佛子。譬如大云雨一味水。随诸众生善根力故。起种种宫殿。如来大悲一味法水。随众生器根不同故。法雨差别。佛子。是为第七因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如世界初始成时。有大水轮。遍满三千大千世界。满世界已。生大莲华名如来起。诸功德宝以为庄严。遍覆三千大千世界。光照十方一切国土。时摩醯首罗净居天等。见莲华已。即决定知如莲华数诸佛兴世。佛子。尔时有风轮起名净光明。能成色界诸天宫殿。又风轮起名净庄严。能成欲界诸天宫殿。又风轮起名不可坏。能成大小围山及金刚山。又风轮起名曰胜高。能成须弥山王。又风轮起名曰不动。能成十种大山。何等为十。所谓芭蕉山。仙人山。伏魔山。大伏魔山。持劫山。黑山。目真邻陀山。摩诃目真邻陀山。香山。雪山。又风轮起名曰安住。能成大地。又风轮起名曰庄严。能成地天宫殿乾闼婆宫殿。又风轮起名无尽藏。能成三千大千世界海。又风轮起名明净藏。能成大千世界珍宝。又风轮起名坚固根。能成一切如意树。佛子。是为大云雨一味水。以众生善根果报力故。法如是故。起种种风轮。风轮差别故。大千世界形类不同。如来应供等正觉。亦复如是。出兴于世。具诸善根。有光明。名无上大智不断如来性起不思议智。普照十方世界。授一切菩萨如来记。号成等正觉出兴于世。又能善知一一佛所有几菩萨成就功德。复有光明。名离垢净如来大智。能成如来无漏无生智。复有光明。名曰普照如来大智。能成如来不可思议法界智。复有光明。名持佛性如来大智。能成如来不动诸力。复有光明。名无坏最胜如来大智。能成如来无所畏智。复有光明。名一切明如来大智。能成如来坚固不退一切种智。复有光明。名出生变化如来大智。能令见闻恭敬供养诸如来者。善根不虚。复有光明。名普随顺至如来大智。能成如来无尽功德智慧清净法身。饶益众生。复有光明。名不可究竟如来大智。能成如来甚深妙智。不断三宝。复有光明。名种种庄严如来大智。能成如来相好严身。令一切众生皆悉欢喜得一切智。复为光明。名不可坏如来大智。能成如来法界虚空界等无有穷尽殊胜寿命。佛子。如来大悲一味之水。以诸菩萨善根力故。及余众生根差别故。法如是故。如来智慧应化不同。佛子。如来性起正法。一切如来平等智慧光明所起。一切如来一味智慧。出生无量无边功德。众生念言。此诸功德如来所造。佛子。此非如来神力所造。佛子。乃至一菩萨成无上道言佛造者无有是处。诸佛为一切群生作善知识。众生依此得大智慧。无有作法亦无作者。佛子。是为第八因缘成等正觉出兴于世。菩萨摩诃萨。应如是知。复次佛子。譬如有四风轮依虚空住能持水轮。何等为四。所谓安住。不动。常住。坚固是名为四。能持水轮。水轮能持大地令不散坏。是故说大地依水轮。水轮依风轮。风轮依虚空。虚空无所依。虚空虽无所依。能令三千大千世界而得安住。如来应供等正觉。亦复如是。依如来起四种无碍大智风轮。能持一切众生善根。何等为四。所谓摄取众生皆令欢喜大智风轮。分别诸法令众生乐求大智风轮。守护众生一切善根大智风轮。决定了知无漏法界大智风轮。是名四种大智风轮。大慈为众生归依。大悲度脱众生。大慈大悲饶益众生。大慈大悲依方便智。大方便智依于如来。如来无所依。无碍慧光普照十方一切世界。佛子。是为第九因缘成等正觉出兴于世。菩萨摩诃萨应如是知。复次佛子。譬如大千世界成已种种饶益无量众生。水性众生得水安乐。陆地众生得地安乐。宫殿众生得宫殿安乐。空中众生得虚空安乐。如来应供等正觉亦复如是。出兴于世。种种饶益一切众生。见闻如来踊跃欢喜修诸善根。住尸罗者得佛戒乐。住四禅四无量者。得圣无上智明之乐。住法门者。得真实乐。住照明者。得净智乐。如是等无量法门种种饶益一切众生。佛子。是为第十因缘成等正觉出兴于世。菩萨摩诃萨应如是知

大方广佛华严经卷第三十三大方广佛华严经卷第三十四

        东晋天竺三藏佛驮跋陀罗译

    宝王如来性起品第三十二之二

佛子。菩萨摩诃萨。又复应知。如来性起正法。功德无量。行无量故。充满十方。无来去故。离生住灭。无有行故。离心意识。无有身故。性如虚空。悉平等故。一切众生无我我所。无有尽故。一切刹无尽。无有转故。不断未来际。无有退故。如来智无疑。无二平等。观察有为无为故。成等正觉饶益众生。本行回向自在满足故。尔时普贤菩萨。欲重明此义。以偈颂曰

  一切众谛听　　如来十力法
  一切诸世间　　最胜无有上
  悉与无等等　　亦与虚空等
  功德无等者　　境界不可量
  一切诸如来　　功德无有量
  诸余众生类　　无能思议者
  如来一法门　　一切诸群生
  无量亿劫中　　思量不能尽
  十方诸佛刹　　尽末为微尘
  有人能计算　　悉了知其数
  彼人无量劫　　算数诸如来
  一毛之功德　　莫能知少分
  譬如一士夫　　能量虚空界
  又第二士夫　　随算知量数
  于亿无数劫　　算量空可尽
  如来诸功德　　不可得穷尽
  譬如有士夫　　能于一念中
  数三世众生　　心心之所行
  众生数等劫　　数之犹可尽
  如来无量德　　其数不可尽
  譬如诸法界　　分际不可得
  一切非一切　　非见不可取
  如是诸如来　　境界不可量
  一切非一切　　法界无穷尽
  譬如如如性　　离虚妄寂灭
  亦无有生者　　亦无有灭者
  如是诸如来　　及一切境界
  亦同如如性　　不增亦不减
  譬如未来际　　真实际无际
  三世性自离　　真实不可得
  等正觉如是　　境界亦复然
  一切三世中　　通达无障碍
  诸法无变易　　性空无作故
  离垢无染污　　其性如虚空
  一切诸如来　　清净性亦然
  一切性无性　　非有亦非无
  正法性远离　　一切语言道
  一切趣非趣　　皆悉寂灭性
  一切诸如来　　境界亦如是
  远离语言道　　不可为譬谕
  诸佛觉悟法　　性相皆寂灭
  如鸟飞空中　　足迹不可得
  无量大愿果　　成就净色身
  具十力功德　　示现大神变
  如来甚深法　　若有欲知者
  应当净其意　　犹若如虚空
  远离虚妄想　　及邪见颠倒
  修习清净道　　究竟得净意
  是故诸佛子　　一心善谛听
  诸善逝境界　　我当说少分
  一切诸十力　　功德不可数
  觉悟群生故　　我今少演说
  一切诸导师　　起清净身业
  口业及意业　　境界悉清净
  如来深境界　　清净妙法轮
  涅槃诸善根　　我当分别说
  譬如大千界　　国土初成时
  非是少因缘　　能成于世界
  无量方便力　　一切因缘起
  三千大千界　　安置诸群生
  如来诸最胜　　如是性起法
  无量功德藏　　一切莫能知
  十方诸世界　　皆末为微尘
  算数诸微尘　　及知众生心
  微尘众生心　　犹尚可知数
  一切诸十力　　功德不可知
  譬如因重云　　能澍降大雨
  四种风轮起　　能成三千界
  众生诸善根　　菩萨功德力
  三千世界起　　安置众生类
  如来亦如是　　因缘法云起
  大智慧风轮　　离垢清净意
  一切诸佛所　　修习诸善根
  回向与众生　　速成等正觉
  譬如虚空中　　云雨名洪澍
  一切余世界　　无堪受持者
  除三千大千　　世界初成时
  不可动风轮　　依止虚空界
  如来亦如是　　初成等正觉
  十方一切界　　法云降大雨
  充满胜法界　　无有能持者
  唯诸大菩萨　　成就无量德
  空中兴云雨　　无作无造者
  本无所从来　　去亦无所至
  如来亦如是　　法云雨甘露
  本无所从来　　去亦无所至
  一切诸菩萨　　修习无量行
  随所应受化　　为彼雨正法
  譬如大云雨　　无有能数者
  唯摩醯首罗　　悉能分别知
  善逝亦如是　　雨无量法雨
  充满诸佛刹　　无有能数者
  唯无上法王　　一切世界主
  悉能分别知　　如观掌中宝
  应灭能寂灭　　应起能令起
  除灭诸邪见　　长养功德宝
  如来雨正法　　除灭诸烦恼
  出生不可数　　无量诸善根
  修习于正见　　远离诸颠倒
  一切诸最胜　　深解功德宝
  譬如虚空中　　普雨一味水
  众生果报力　　所起物不同
  如来雨正法　　大悲一味水
  随应受化故　　种种差别说
  世界初成时　　先起色界宫
  复于欲界天　　次第起宫殿
  次复于人间　　各各造住处
  然后次第起　　乾闼诸龙处
  如来亦如是　　始成等正觉
  初起菩萨行　　次成缘觉乘
  又化心自在　　一切诸声闻
  然后令众生　　修习诸善根
  见清净莲华　　诸天知佛出
  因雨能起风　　风能起世界
  如来放光明　　分别佛菩萨
  能起智慧轮　　通达诸佛法
  水依风轮住　　地依于水轮
  众宝树依地　　虚空无所依
  智轮依如来　　慈悲依智慧
  功德依方便　　法身无所依
  譬如大地起　　饶益诸众生
  水陆群萌类　　各各得安乐
  依虚空众生　　及欲色诸天
  二足四足等　　一切悉饶益
  法王亦如是　　出兴于世间
  令一切众生　　皆悉得饶益
  若人有见闻　　恭敬供养者
  除灭诸烦恼　　深解如来法
  如来性起法　　世间莫能知
  我所说少分　　饶益众生故

尔时普贤菩萨摩诃萨。告诸菩萨言。佛子。云何菩萨摩诃萨。知见如来应供等正觉。此菩萨摩诃萨。知见如来具足成就无量功德。何以故。如来应供等正觉。非一法一行一身一刹化一众生故。此菩萨摩诃萨。知见如来具足成就无量法无量行无量身无量刹。平等教化一切众生故。佛子。譬如虚空。一切色处非色处。无处不至。而非至非不至。何以故。虚空无形色故。如来法身亦复如是。至一切处一切刹一切法一切众生。而无所至。何以故。诸如来身非是身故。随所应化示现其身。佛子。是为菩萨摩诃萨初入胜行门知见如来。复次佛子。譬如虚空弥广。悉能容受一切众生。而无染着。如来法身亦复如是。照一切众生。世间善根离世间善根。亦无染着。何以故。如来法身。于一切染着。悉已断故。佛子。是为菩萨摩诃萨第二胜行知见如来。复次佛子。譬如日出世间。以无量事饶益众生。所谓灭除闇冥。长养一切山林药草百谷卉木。消除冷湿。照空饶益虚空众生。照池则能开敷莲华。普悉照现一切色像。世间事业皆得究竟。何以故。日能普放无量光故。如来身日亦复如是。以无量事。普能饶益一切众生。所谓灭恶饶益。长养善法。普照饶益。除灭一切众生闇冥。大慈饶益。救护众生。大悲饶益。度脱一切。正法饶益。长养一切根力觉意。坚信饶益。除心垢浊。见法饶益。不坏因缘。天眼饶益。悉见众生死此生彼。离害饶益。不坏众生一切善根。慧光饶益。开敷一切众生心华。发心饶益究竟一切菩萨所行。何以故。如来身日。普放一切慧光明故。佛子。是为菩萨摩诃萨第三胜行知见如来。复次佛子。譬如日出。先照一切诸大山王。次照一切大山。次照金刚宝山。然后普照一切大地。日光不作是念。我当先照诸大山王。次第乃至普照大地。但彼山地有高下故照有先后。如来应供等正觉。亦复如是。成就无量无边法界智慧日轮。常放无量无碍智慧光明。先照菩萨摩诃萨等诸大山王。次照缘觉。次照声闻。次照决定善根众生。随应受化。然后悉照一切众生乃至邪定。为作未来饶益因缘。如来智慧日光不作是念。我当先照菩萨。乃至邪定。但放大智光普照一切。佛子。譬如日月出现世间。乃至深山幽谷无不普照。如来智慧日月。亦复如是。普照一切无不明了。但众生希望善根不同故。如来智光种种差别。佛子。是为菩萨摩诃萨第四胜行知见如来。复次佛子。譬如日出世间。生盲众生未曾睹见。何以故。无肉眼故。佛子。此生盲众生虽不见日。亦为日光之所饶益。因日光故。而得饮食资生众具。消除冷湿令体轻软。风寒痰[病-丙+(企-止+(套-大))]诸患悉除安隐快乐。如来慧日出现世间。亦复如是。一切邪见犯戒无智邪命生盲众生。未曾睹佛智慧日光。何以故。无信心眼故。佛子。生盲众生。虽不见如来智慧日光。然此众生。亦为如来智慧日光之所饶益。除灭四大一切诸苦。身体安乐。断一切烦恼毒痛根本。佛子。如来有光。名曰一切功德积聚。复有光明。名普照一切。复有光明。名曰清净自在普照。复有光明。名出大妙音。复有光明。名普照一切诸语言法。复有光明。名自在。除灭一切疑惑。复有光明。名无依普照。复有光明。名智慧自在。除灭一切境界虚妄。复有光明。名分别诸乘。随其所应出大妙音。复有光明。名曰圆满自在音声。庄严诸刹。悉令众生皆得清净。佛子。如来一一毛孔。放如是等千种光明。五百光明普照下方。五百光明普照上方。菩萨摩诃萨。各于其刹诸如来所。见此光已。彼诸菩萨。即时具足清净十头十眼十耳十鼻十舌十身十手十足十地十智。彼诸菩萨。因菩萨行地所得诸入皆悉清净。成就善根一切种智。声闻缘觉。皆悉除灭一切烦恼。少智生盲众生。身体柔软安隐快乐。离垢清净调伏诸根。具足成就四念处法。地狱饿鬼畜生恶道众生。众苦悉除皆得安乐。身坏命终生人天中。彼诸众生不知不觉。以何因缘何威神力来生此间。彼生盲者唯作是念。我是梵天我是梵化。尔时如来。安住普自在三昧。演出八种如来妙音。告众生言。汝等众生。非是梵天亦非梵化。蒙佛神力故。得生此间。彼诸众生。佛神力故。即识宿命所经恶道。来生此间。皆大欢喜。大欢喜已。各持优昙华云。香云。娱乐云。一切衣云盖云。幢云。末香云。妙宝云。师子幢云。半月楼阁云。赞叹庄严具云。诣如来所奉献供养。何以故。蒙佛神力慧眼开明。如来即授彼诸众生阿耨多罗三藐三菩提记。佛子当知。如来慧日。饶益生盲众生。长养具足成就善根。佛子。是为菩萨摩诃萨第五胜行知见如来。复次佛子。譬如满月。有四奇特未曾有法。何等为四。映蔽一切星宿光明。示现增减于阎浮提。一切净水影无不现。一切众生有睹见者皆悉对面。如来法身亦复如是。有四奇特未曾有法。何等为四。映蔽一切声闻缘觉学无学法功德星宿。随其所应示现寿命修短不同。法身常住未曾增减。影现一切世界净心众生菩提器中。随所闻法随解脱地应受化者。一切皆谓如来现前。其实法身无有彼此。究竟佛事。佛子。是为菩萨摩诃萨第六胜行知见如来。复次佛子。譬如三千大千世界大梵天王。以少方便。大千世界一切众生。各见梵王现在己前。亦不分身无种种身。佛子。如来亦复如是。亦不分身无种种身。于一切众生。随所应化示现其身。未曾生念。示现彼此若干众生。佛子。是为菩萨摩诃萨第七胜行知见如来。复次佛子。譬如大医王。善知众药对治之法。一切方论皆悉明练。彼大医王。阎浮提中一切药草。若现其前悉能识别。彼大医王。宿善根力。又能明了诸方论故。悉能疗治一切众病。彼大医王。临命终时作如是念。我命终后。一切众生无所归依。是故我应现巧方便。尔时医王。以药涂身。咒术自持。令我命终之后身不干燥又不散坏。犹能具足身四威仪。行住坐卧行医王事。疗治众病与本无异。如来应供等正觉无上医王。亦复如是。善能明了诸对治法。悉能除灭一切众生诸烦恼病。无量亿那由他劫修习善根。究竟般若波罗蜜。到于彼岸。善学方便药涂咒持。如来于昔。先善安住菩萨行地。般若波罗蜜巧妙方便药咒之力。住持寿命。如来以少方便施作佛事。救护众生除灭烦恼。佛子。是为菩萨摩诃萨第八胜行知见如来。复次佛子。譬如大海有摩尼宝。名普照明净藏。此宝光明触众生身。悉同一色若有见者眼即清净。随彼光明所照之处。雨目佉宝。皆悉遍满。饶益安乐无量众生。如来法身亦复如是。为大宝王功德积聚大智慧藏。如来有光名宝身智。若有众生触斯光者。皆悉得与佛身同色。若有众生见斯光者。皆悉逮得清净法眼。若有众生触斯光者。除贫贱苦尊贵富乐。乃至无上菩提快乐。佛子当知。如来法身无有彼此。悉能究竟一切众生而作佛事。佛子。是为菩萨摩诃萨第九胜行知见如来。复次。佛子。譬如大海有宝。名曰一切世间庄严如意摩尼宝王。具足成就百万功德。随彼宝王所住之处。一切众生所有苦患皆得除灭。随其所愿悉能充满。彼摩尼宝王。非少福众生所能得见。如来法身摩尼宝王。亦复如是。若有众生得闻见者。皆悉除灭生死之苦。若一切众生。一时专念。欲见如来皆悉睹见。能令欢喜所愿悉满。如来法身。非少福众生之所能见。除佛神力。随其所应而示现身。佛子。是为菩萨摩诃萨第十胜行知见如来。菩萨摩诃萨。具足成就无量净心。充满十方。深入法界住真实际。无生无灭三世平等。悉能除灭一切虚妄。入未来际。正法充满一切世间一切法界。一切佛身无量庄严。尔时普贤菩萨摩诃萨。欲重明此义。以偈颂曰

  譬如虚空性　　无处而不至
  十方世界中　　一切诸佛刹
  色处非色处　　一切众生类
  去来今现在　　非至非不至
  一切诸最胜　　清净妙法身
  无处而不至　　充满诸法界
  最胜妙法身　　一切莫能见
  教化众生故　　导师为示现
  譬如虚空性　　无能执持者
  普令诸群生　　无碍造众业
  虚空无是念　　我今何所作
  云何而造作　　为谁而造作
  如是诸最胜　　因此净身业
  普令群生类　　成就白净法
  如来净法身　　饶益无量众
  法身亦无念　　我利诸群萌
  譬如明净日　　出现阎浮提
  除灭一切闇　　普照悉无余
  一切众宝山　　大地诸华池
  随事而长养　　饶益一切众
  最胜日如是　　饶益一切众
  悉令群生类　　长养诸善根
  成就慧光明　　除灭一切闇
  睹见诸导师　　具足一切乐
  譬如日出时　　先照大山王
  又复次第照　　一切诸大山
  次照诸小山　　及余高显处
  然后乃普照　　世界诸大地
  善逝亦如是　　清净慧日光
  先照诸菩萨　　功德大山王
  尔乃次第照　　一切诸缘觉
  又复次第照　　声闻学无学
  然后次第照　　一切诸众生
  法身无是念　　我有所照明
  譬如明净日　　出现于世间
  生盲虽不见　　而能作饶益
  除灭饥渴患　　令身柔软乐
  当知明净日　　无所不饶益
  佛日亦如是　　出现于世间
  虽无信心眼　　而为作饶益
  或闻如来声　　或触导师光
  为彼作因缘　　究竟成菩提
  譬如盛满月　　映蔽诸星宿
  示现一切众　　有增或有减
  一切澄净水　　月影无不现
  世间群生类　　皆悉对目见
  最胜净满月　　映蔽于二乘
  随其受化者　　示现寿修短
  影现诸人天　　净心菩提器
  各各皆自谓　　我对天人尊
  譬如大梵王　　安住梵天宫
  悉于大千界　　普现梵王身
  具足自在力　　变现无量身
  无处而不见　　其身亦不分
  导师亦如是　　具足自在力
  一切十方刹　　普现无量身
  不可称量身　　一切莫能见
  普应现众生　　而亦不分身
  譬如大医王　　善知对治法
  若有得见者　　无病而不除
  临欲命终时　　而生如是念
  我身终没后　　一切无归依
  以药涂其身　　咒术而自持
  令我命终后　　如本无变异
  如是诸最胜　　无上大医王
  善学方便慧　　具足一切智
  过去无量行　　示现净法身
  众生若见者　　除灭烦恼患
  譬如大海中　　摩尼众宝王
  出生无量种　　清净妙光明
  众生触斯光　　皆悉同宝色
  若有得睹见　　彼开清净眼
  最胜宝如是　　普放慧光明
  若有触斯光　　悉与佛同色
  众生若见者　　具足五净眼
  除灭诸闇冥　　安住如来地
  譬如如意宝　　随满一切愿
  若有所求者　　皆悉满其意
  宝王不生念　　我饶益世间
  少功德众生　　不见此宝王
  善逝亦如是　　令一切愿满
  若有求愿者　　皆悉得满足
  善逝不生念　　我利益众生
  其怀恶心者　　不睹如来身

佛子。菩萨摩诃萨。云何知见如来应供等正觉微妙音声。此菩萨摩诃萨。知见如来音声无处不至。如来种种微妙音声。令一切众生皆大欢喜。演说无量诸佛正法。随应化者悉得解了。教化众生未曾失时。令身清凉心定不乱。观察平等无生无灭。譬如呼响无主。知见出生长养诸善根故。知见甚深无边底故。知见正直究竟度法界故。知见无断摄法界故。知见不可坏究竟法界故。菩萨摩诃萨。知如来音声非量非无量。非主非无主。非智非无智。何以故。譬如世界将欲坏时。法如是故。自然演出四种音声。何等为四。一曰汝等当知。初禅安乐离欲嗔恚。远离欲界。众生闻已。自然皆得成就初禅。舍欲界身生梵天处。二曰汝等当知。二禅安乐离于觉观。无觉无观远离梵身。众生闻已。自然皆得成就二禅。舍梵世身生光音天。三曰汝等当知。三禅安乐离于喜爱。众生闻已。自然皆得成就三禅。舍光音身生遍净天。四曰汝等当知。四禅安乐远离众苦。众生闻已。自然皆得成就四禅。舍遍净身生果实天。佛子。是为世界将欲坏时。法如是故。自然出生四种音声。彼声无主亦无作者。如来妙音亦复如是。亦无有主无有作者。自然出生四种妙音。随顺佛法。何等为四。一曰汝等当知。一切行苦。地狱畜生饿鬼中苦。阎罗王苦。恶行者苦。无功德苦。着我我所苦。欲生人天。当种善根修诸功德。远离八难得无难处。众生闻已。舍离颠倒修习善根。远离八难生人天中。二曰汝等当知。一切行苦皆悉炽然如烧铁丸。一切众行悉磨灭法。寂灭涅槃远离炽然清凉安乐。众生闻已皆修善根。修善根已得音声忍。得音声忍已学声闻乘。三曰汝等当知。学声闻乘者。为学小智。因他觉悟。更有胜道名缘觉乘。悟不由师。汝等应学。若有众生乐胜道者。闻此音声学缘觉乘。四曰汝等当知。过声闻缘觉。更有胜道。名曰大乘。修菩萨行。究竟六波罗蜜。具菩萨行得不退转。不舍菩萨心。永离生死。向无上菩提。若有众生诸根猛利。过去修习无量善根。又复承佛威神力故。得闻此音发菩提心。诸佛如来微妙音声。不从身出不从心出。而能饶益无量众生。佛子。是为菩萨摩诃萨初胜妙行知见如来微妙音声。复次佛子。譬如呼响因山声起。无有积聚不可睹见。随种种声悉能应对。实无所应。如来妙音亦复如是。无有方处。但随所应而出音声。音声非实。不可觉知不可言说。佛子。是为菩萨摩诃萨第二胜行知见如来微妙音声。复次佛子。譬如天妙音声。于虚空中自然而出。悉能觉悟放逸天子。而告之言。汝等当知。五欲无常。虚妄颠倒须臾变异。如逆风执火。愚夫所习。汝莫放逸。若放逸者。身坏命终堕三恶道。放逸诸天闻此音声。生恐怖心厌离五欲。各舍宫殿诣正法堂。修习善法爱乐正道。佛子。天妙音声。亦无有主亦无作者。不起不灭。而能利益放逸诸天。如来妙音亦复如是。普为放逸诸众生故。出生无量正法音声。而觉悟之。谓无著声。不放逸声。无常苦空非我之声。寂灭涅槃声。皆悉充满一切法界。随其所应悉令欢喜。各随所乐修学诸乘。出生无量大智音声。不退转声。具足菩萨。诸行音声。如来一切智慧地声。众生闻此诸音声已。无量无数阿僧祇众生。修习善法。或学声闻辟支佛乘。或学无上摩诃衍乘。如来妙音超绝众相。言语道断。佛子。是为菩萨摩诃萨第三胜行知见如来微妙音声。复次佛子。譬如自在天王有天宝女。名曰善口。于一语中。演出百千娱乐音声。于彼一一娱乐音中。复出百千娱乐音声。佛子当知。一善口声。出生无量微妙音声。如来音声亦复如是。于一音中出无量声。随其所应悉令开解。佛子。是为菩萨摩诃萨第四胜行知见如来微妙音声。复次佛子。譬如大梵天王。于梵众中出梵音声。一切大众无不闻者。彼梵音声不出众外。时梵身诸天。各作是念。大梵天王唯与我语不对余天。如来应供等正觉。亦复如是出生无量无上妙音。应受化者皆悉得闻。不出众外。何以故。彼诸众生根未熟故。闻佛音者各作是念。今日如来唯为我说。不为余人。如来所出音声亦无所出。闻佛音者亦无所闻。能为众生施作佛事。佛子。是为菩萨摩诃萨第五胜行知见如来微妙音声。复次佛子。譬如水性皆同一味。随器异故味有差别。水无是念我作众味。如来妙音亦复如是。皆悉一味。谓解脱味。随诸众生受化器异。应有差别。如来音声。不作是知不作是念。我作种种别异音声。佛子。是为菩萨摩诃萨第六胜行知见如来微妙音声。复次佛子。譬如阿耨达龙王。兴大重云。满阎浮提普降大雨。百谷草木皆悉滋长江河池泉一切盈满。此大雨水。不从龙王身心中出。而能饶益无量众生。如来应供等正觉。亦复如是兴大悲云遍满世间。普雨无上甘露正法。令一切众生皆大欢喜。出生善根。长养正法。具足诸乘。如来音声不从外来亦不内出。而能饶益一切众生。佛子。是为菩萨摩诃萨第七胜行知见如来微妙音声。复次佛子。譬如摩那斯龙王。将欲降雨。先兴重云弥覆虚空。凝停七日而未降雨。先令众生究竟诸业。何以故。彼大龙王。慈悲心故。过七日已。渐降微雨普润大地。如来应供等正觉。亦复如是。将雨法雨。先兴法云普覆众生。未便即雨甘露正法。先令众生成熟诸根。诸根熟已。然后渐降甘露法雨。若即说深法。众生恐怖。是故如来渐渐微雨一切种智甘露法味。佛子。是为菩萨摩诃萨第八胜行知见如来微妙音声。复次佛子。譬如海中有大龙王。名大庄严。或连雨十日或二十日或百日或千日或百千日。佛子。雨不作是念。我雨十日乃至百千日。但彼龙王。有不可思议自在力故。或十日雨。乃至百千日雨。如来应供等正觉。亦复如是。欲雨微妙甘露正法。或十种音声。或二十或百或千或百千。或八万四千行种种音声。乃至无量亿那由他声分别说法。令一切众生皆悉欢喜。如来妙音不作是念。我能演说种种诸法。又法界清净无有差别。化众生故所说不同。佛子。是为菩萨摩诃萨第九胜行知见如来微妙音声。复次佛子。譬如娑伽罗龙王。欲现龙王大自在力。为欲饶益群生类故。从四天下乃至他化自在天处。兴大重云遍覆六天。有种种色。或有处如阎浮檀金色。或有处如琉璃色。或有处如白银色。或有处如玻璃色。或有处如玫瑰色。或有处如码瑙色。或有处如胜宝藏色。或有处如赤真珠色。或有处如妙香色。或有处如种种衣色。或有处如清净水色。或有处如种种杂色。如是等无量色云。覆四天下乃至六天。覆已出诸电光。所谓阎浮檀金色云。出琉璃电光。琉璃色云。出阎浮檀金电光。白银色云。出玻璃电光。玻璃色云。出白银电光。玫瑰色云。出码瑙电光。码瑙色云。出玫瑰电光。胜宝藏色云。出赤真珠电光。赤真珠色云。出胜宝藏电光。妙香色云。出种种衣色电光。种种衣色云。出妙香色电光。净水色云。出种种杂色电光。种种杂色云。出净水电光。广说乃至一种色云。出种种色电光。种种色云。出一种色电光。又震种种大雷音声。令众生欢喜。所谓天女歌音。天娱乐音。龙女歌音。乾闼婆女歌音。紧那罗女歌音。大地音。大海音。鹿王音。或有异类奇妙种种鸟音。或种种歌音。尔时龙王。起若干风降微细雨。饶益安乐无量众生。从四天下上至六天。普雨种种无量异雨。所谓于大海中雨名洪澍。无有断绝。于他化自在天。普雨歌颂娱乐音声。于化自在天。普雨解脱明净光宝。于兜率陀天。普雨顶髻明月神珠。于夜摩天。普雨种种众庄严具。于三十三天。普雨妙香。于四天王。普雨宝衣。于龙王宫。普雨赤明真珠。于阿修罗处。普雨兵仗。名伏怨敌。于郁单越。普雨众华。如是广说。遍四天下。雨种种雨。然彼龙王。其心平等无有彼此。但以众生根不同故。雨有差别。如来应供等正觉无上法王。亦复如是。将欲应现无量大法。先以清净身云。普覆一切法界。随其所应示现身云。或有众生。应见如来生身之云。或有众生。应见如来神力住持身云。或有众生。应见如来色身之云。或有众生。应见如来种种身云。或有众生。应见如来功德身云。或有众生。应见如来智慧身云。或有众生。应见如来不坏身云。或有众生。应见如来无畏身云。或有众生。应见如来法界身云。佛子。如来以如是等无量身云。普覆一切世界。随其所应示现光明电光。或有众生。得见如来光明电光。名无所不至。或有众生。得见如来光明电光。名照无量无边。或有众生。得见如来光明电光名曰入佛微密之教。或有众生。得见如来光明电光。名明净普照。或有众生。得见如来光明电光。名曰净照。或有众生。得见如来光明电光。名入无尽藏陀罗尼门。或有众生。得见如来光明电光。名不乱正念。或有众生。得见如来光明电光。名不退智慧。或有众生。得见如来光明电光。名顺入诸趣。或有众生。得见如来光明电光。名普令众生满足诸愿。佛子。如是如来应供等正觉。普为众生。示现如来光明电光。现电光已。出生无量诸大三昧雷震音声。所谓出正觉三昧雷声。离垢寂静海三昧雷声。一切法自在三昧雷声。金刚圆满三昧雷声。须弥山王幢三昧雷声。海印三昧雷声。日光三昧雷声。普令众生欢喜三昧雷声。无尽功德藏三昧雷声。不坏解脱阿罗汉三昧雷声。佛子。如来应供等正觉。于佛身云。出生无量种种三昧雷声。出雷声已。欲说甘露法时。先现如来大智风轮瑞相。从无障碍大慈悲起。先令一切众生及诸菩萨身心柔软皆大欢喜。如来如是。以正法云大慈悲云不可思议云。令一切众生身心柔软。然后乃雨不可思议。大法云雨。所谓为坐道场一切菩萨。雨不可坏法界大法云雨。为最后身菩萨。雨如来密教菩萨娱乐自在大法云雨。为一生补处菩萨。雨清净普照大法云雨。为得记菩萨。雨如来庄严大法云雨。为得忍菩萨。雨功德宝智华不断菩萨行大法云雨。为向行菩萨。雨不退行入化门甚深门无有疲厌大法云雨。为初发心菩萨。雨如来定行大慈大悲救护众生大法云雨。为乐缘觉者。雨深知缘起离断常见无坏解脱果法云雨。为求声闻者。雨降伏烦恼怨敌智藏法云雨。为修习长养善根众生及决定不决定众生。雨种种欢喜法门云雨。佛子。雨如是等十种无量无边大法云雨。充满法界。佛子。如来应供等正觉。其心平等无有彼此。但以众生根不同故。如来法雨现有差别。佛子。是为菩萨摩诃萨第十胜行知见如来微妙音声

大方广佛华严经卷第三十四大方广佛华严经卷第三十五

        东晋天竺三藏佛驮跋陀罗译

    宝王如来性起品第三十二之三

复次佛子。菩萨摩诃萨。知见如来音声十种无量。何等为十。所谓知见虚空等无量。无处不至故。知见法界等无量。无处不彻故。知见众生界等无量。令一切众生悉欢喜故。知见行业等无量。广说一切果报故。知见烦恼等无量。究竟寂灭故。知见种种音声等无量。随应受化无不闻故。知见欲乐等无量。悉分别说诸解脱故。知见三世等无量。无分际故。知见智慧等无量。深入一切法故。知见佛境界不退等无量随顺如如法界故。佛子。菩萨摩诃萨。知见如来应供等正觉音声。有如是等十种无量阿僧祇。尔时普贤菩萨。欲重明此义。以偈颂曰

  世界欲坏时　　于彼虚空中
  众生福报力　　自然出四声
  于彼四禅中　　寂乐离众苦
  众生闻是已　　厌离欲界身
  十力亦如是　　自然出四声
  充满于法界　　无处而不闻
  众生因缘力　　佛应四种声
  其有闻音者　　永度生死海
  譬如因山谷　　出生呼声响
  从外一切音　　响声随应对
  种种因缘起　　闻者亦不同
  响不作是念　　我出种种音
  如来声如是　　出生无量音
  随应受化者　　一切无不闻
  皆悉令欢喜　　调伏诸众生
  音声亦无念　　我出种种音
  譬如天妙音　　于彼虚空中
  自然而演出　　觉悟诸天子
  诸天子闻此　　正法妙音声
  修习不放逸　　厌离于五欲
  十力亦如是　　出生微妙声
  法云音充满　　一切诸世界
  令众生觉悟　　彼音无生灭
  若有得闻者　　皆悉证菩提
  如自在天王　　宝女名善口
  于一音声中　　出生百千声
  复于一一音　　出生百千声
  诸天若闻者　　一切皆悦乐
  十力亦如是　　于彼一音中
  随应一时演　　众生数等音
  众生闻音已　　除灭诸烦恼
  音声不作念　　我能有所灭
  譬如大梵王　　出清净梵音
  一切梵天众　　无有不闻者
  一一梵音声　　令梵众欢喜
  遍满梵天众　　音声不出外
  功德大梵王　　安处如来座
  演出一妙音　　充满诸法界
  随应受化者　　一切无不闻
  声不出众外　　以无信心故
  譬如诸水性　　皆悉同一味
  清净离垢浊　　具足八功德
  所因地不同　　众器各别异
  随彼因缘故　　水味有差别
  佛子应当知　　一切智音声
  如来微妙音　　悉同解脱味
  众生所造行　　若干差别故
  善逝随应化　　所闻各不同
  譬如阿耨达　　自在大龙王
  兴云覆世间　　普雨润大地
  长养诸丛林　　百谷药草等
  彼所降雨水　　不从身心出
  如来亦如是　　初兴大法云
  普覆诸法界　　雨大甘露法
  令众增善根　　除灭烦恼热
  而彼甘露法　　不从身心出
  譬如大龙王　　名曰摩那斯
  七日起重云　　凝停不降雨
  普令一切众　　究竟诸事业
  渐降微细泽　　然后乃大雨
  十力兴法云　　普覆诸法界
  雨大甘露法　　饶益诸群生
  随应受化者　　为彼说深法
  闻者不恐怖　　究竟成菩提
  譬如大龙王　　名曰大庄严
  先布密重云　　然后降大雨
  或十二十日　　乃至百千日
  雨水等一味　　众生故不同
  究竟至如来　　大辩之彼岸
  或说十法门　　乃至百千门
  或说八万四　　乃至无量行
  如来不生念　　我分别法界
  譬如海龙王　　名曰娑伽罗
  先兴密重云　　弥覆四天下
  普雨一切处　　各各悉不同
  龙王心平等　　亦无有憎爱
  最胜亦如是　　无上法龙王
  兴起大悲云　　普覆于一切
  为道场菩萨　　雨大甘露法
  随其所应化　　如来心平等

佛子。云何菩萨摩诃萨。知见如来应供等正觉心。此菩萨摩诃萨。知心意识非即如来。但知如来智无量故。心亦无量。佛子。譬如虚空。悉为一切万物所依。而彼虚空无所依止。如来智慧亦复如是。悉为一切世间智慧。离世间智之所依止。而如来智无所依止。佛子。是为菩萨摩诃萨最初胜行知见如来应供等正觉心。复次佛子。譬如清净法界。悉为一切声闻缘觉菩萨解脱之所依止。而清净法界无增无减。如来智慧亦复如是。为一切世间出世间智。算数巧术一切众智之所依止。而如来智无增无减。佛子。是为菩萨摩诃萨第二胜行知见如来应供等正觉心。复次佛子。譬如四大海水。悉能泽润四天下地八十亿小洲。若有众生。于彼诸处。方便求水无往不得。而彼大海不作是念。我能资给诸众生水。如来智慧大海亦复如是。悉能泽润一切众生心。彼诸众生。各于法门修习善根。皆得智慧光明。而如来不作是念。我能悉与众生智慧。佛子。是为菩萨摩诃萨第三胜行知见如来应供等正觉心。复次。佛子。譬如大海有四种宝珠。此四种宝。悉生海中一切众宝。若无此宝。海中众宝悉皆灭失。何等为四。一名众宝积聚。二名无尽宝藏。三名远离炽然。四名一切庄严聚。是为四宝。佛子。此四种宝。一切阿修罗迦楼罗诸龙神等。悉不得见。何以故。娑伽罗龙王密置深宝藏故。此四种宝端严方正。如来应供等正觉海。亦有四种大智宝珠。出生一切声闻缘觉学无学智。及诸菩萨智慧大宝。何等为四。一名无染巧妙方便清净智宝。二名分别演说有为无为清净智宝。三名分别演说一切诸法而不坏法界清净智宝。四名应化众生未曾失时清净智宝。是为如来大海四种清净智宝。佛子。此如来四种清净智宝。一切众生无能见者。何以故。此四种智慧大宝安置如来微密法宝藏故。菩萨慧光端严殊特。佛子。是为菩萨摩诃萨第四胜行知见如来应供等正觉心。复次佛子。譬如大海有四炽然光明大宝。此四种宝。悉能消竭大海无极之水。何等为四。一名日藏光明大宝。一名离润光明大宝。三名火珠光明大宝。四名究竟无余光明大宝。佛子。若大海中无此四宝。四域天下金刚围山。乃至非想非非想处。皆悉漂没。佛子。此日藏光明大宝。能变海水。悉成为酪。离润光明大宝。能变酪海。悉成为酥。火珠光明大宝。能悉炽然酥海。究竟无余光明大宝。悉然酥海。永尽无余。如来应供等正觉海。亦有四种智光摩尼大宝。照诸菩萨。具足修习一切众行。乃至成佛平等智慧。何等为四。一者永息一切不善波浪智光大宝。二者灭一切法爱智光大宝。三者大慧智光大宝。四者与如来等无量智光大宝。佛子。彼菩萨摩诃萨修集菩提时。起无量生死不善波浪。一切诸天阿修罗等。悉无能止。如来以息一切不善波浪智光大宝。照耀菩萨不善波浪。令永止息。坚固安住无上三昧。以灭一切顺法爱智光大宝。灭一切三昧难舍味着。以大慧智光大宝。灭一切无明。净慧通达。以与如来等无量智光大宝。以少方便。出生如来智慧之地。佛子。若无如来四种智光大宝。乃至一菩萨得如来地。无有是处。佛子。是为菩萨摩诃萨第五胜行知见如来应供等正觉心。复次佛子。譬如从水轮际。上至非想非非想天。一切三千大千世界依虚空住。谓无色界众生处。色界众生处。欲界众生处。此三界处悉依虚空。而彼虚空无有迫迮。如来智慧亦复如是。一切声闻缘觉菩萨。知有为法智慧。知无为法智慧。如是等一切智慧。悉依如来智慧而起。悉依如来智慧而住。如来智慧无有迫迮。何以故。如来智慧无所不至故。佛子。是为菩萨摩诃萨第六胜行知见如来应供等正觉心。复次佛子。譬如雪山顶有药王树。名非从根生非不从生。彼药王树。从六百八十万由旬下极金刚地水轮际生。佛子。此药王树。若生根时。阎浮提树一切根生。若生茎时。阎浮提树皆悉生茎。若生枝叶华果时。阎浮提树一切悉生枝叶华果。此药王树根能生茎。茎能生根。是故名曰不从根生非不从根。佛子。此药王树。一切诸处皆悉生长。唯除二处。所谓地狱深坑及水轮中不得生长。而大药王树亦不舍生性。如来智慧大药王树亦复如是。从一切如来种姓中生。于过去世。修习大慈悲等无量无边功德。坚固正住不可倾动。三世无量善根智慧。皆悉普覆一切世间。除灭一切恶道众难。巧方便茎。净法界枝。诸禅三昧解脱之叶。七觉意华。无上解脱果。陀罗尼持初无增减。佛子。如来智慧大药王树。复有异名。名根坚固不坏。何以故。不舍不断菩萨众行。是故其根名曰不坏。彼如来智慧大药王树。初生根时。一切菩萨。悉生大慈悲根。未曾舍离一切众生。初生茎时。一切菩萨。皆悉生长坚固精进正直心茎。初生枝时。一切菩萨。生长一切波罗蜜枝。初生叶时。一切菩萨。生长一切净戒威仪头陀功德之叶。初生华时。一切菩萨。善根庄严相好华敷。初生果时。一切菩萨。得无生忍受佛记果。佛子。如来智慧大药王树。唯除二处。不得生长。所谓声闻缘觉涅槃。地狱深坑。及诸犯戒。邪见贪着。非法器等。而如来树非不生长。其余一切应受化者。皆悉生长。而如来智慧大药王树。不增不减。佛子。是为菩萨摩诃萨第七胜行知见如来应供等正觉心。复次佛子。譬如火劫起时。三千大千世界一切所有大地草木金刚围山。皆悉炽然烧尽无余。设有一人。若以干草投彼火中。宁得不然。答言不也。无不烧尽。佛子。彼所投草。犹可不尽。如来智慧。于一切众生。一切佛刹。一切劫数。一切诸法。无不悉知。若有不知。无有是处。何以故。如来智慧不可破坏。悉明达故。佛子。是为菩萨摩诃萨第八胜行知见如来应供等正觉心。复次佛子。譬如风灾坏世界时。有大风起。名曰坏散。悉能坏散磨灭大千世界金刚围山一切万物。尔时三千大千世界外。复有风起。名障坏散风灾。不令风灾得至余方。佛子。若无此障风。十方无量无边阿僧祇世界。无不散灭。如来应供等正觉亦复如是。有大智风。名曰散灭一切烦恼。悉能散灭一切菩萨烦恼习气。如来复有巧方便智风。能持一切菩萨。不令究竟尽灭。堕于声闻辟支佛地。菩萨摩诃萨。得此巧方便智风力故。能过声闻辟支佛地。究竟佛地。佛子。是为菩萨摩诃萨第九胜行知见如来应供等正觉心。复次佛子。如来智慧无处不至。何以故。无有众生无众生身。如来智慧不具足者。但众生颠倒不知如来智。远离颠倒。起一切智无师智无碍智。佛子。譬如有一经卷。如一三千大千世界。大千世界一切所有无不记录。若二千世界等悉记二千世界中事。小千世界等悉记小千世界中事。四天下等悉记四天下事。须弥山王等悉记须弥山王事。地天宫等悉记地天宫殿中事。欲天宫等悉记欲界天宫殿中事。色天宫等悉记色界天宫殿中事。若无色天宫等悉记无色界天宫殿中事。彼三千大千世界等经卷。在一微尘内。一切微尘亦复如是。时有一人。出兴于世。智慧聪达。具足成就清净天眼。见此经卷在微尘内。作如是念。云何如此广大经卷在微尘内。而不饶益众生耶。我当勤作方便破彼微尘。出此经卷饶益众生。尔时彼人。即作方便破坏微尘。出此经卷饶益众生。佛子。如来智慧。无相智慧。无碍智慧。具足在于众生身中。但愚痴众生颠倒想覆。不知不见不生信心。尔时如来。以无障碍清净天眼。观察一切众生。观已作如是言。奇哉奇哉。云何如来具足智慧在于身中。而不知见。我当教彼众生。觉悟圣道。悉令永离妄想颠倒垢缚。具见如来智慧在其身内。与佛无异。如来即时教彼众生。修八圣道。舍离虚妄颠倒。离颠倒已具如来智。与如来等饶益众生。佛子。是为菩萨摩诃萨第十胜行知见如来应供等正觉心。佛子。菩萨摩诃萨。有如是等无量无数诸胜妙行知见如来应供等正觉心。尔时普贤菩萨。欲重明此义。以偈颂曰

  欲知如来心　　应解最胜智
  如来智无量　　最胜心亦然
  十方诸世界　　一切众生类
  皆悉依虚空　　虚空无所依
  一切法界中　　众生种种乐
  方便巧智术　　依最胜智起
  一切诸智慧　　悉依善逝智
  如来最胜智　　寂然无所依
  声闻缘觉乘　　解脱智慧果
  悉从法界起　　法界无增减
  最胜智如是　　能起一切智
  学智无学智　　了达有无智
  善逝无上智　　出生一切智
  非生非不生　　皆悉无增减
  譬如大海水　　泽润一切地
  众生善方便　　求水无不得
  大海地无念　　我与众生水
  大海无增减　　方便求悉得
  十方诸世界　　一切群生类
  善逝智慧海　　皆悉能润泽
  各各勤方便　　修习诸法门
  一切修行者　　疾得智慧光
  如娑伽龙王　　有四妙宝珠
  密置深宝藏　　众生无能见
  端严而方正　　常住于大海
  因此四摩尼　　生出一切宝
  最胜四种智　　无量不可称
  出生一切众　　无量诸智慧
  安住大乘藏　　无量德庄严
  除受记菩萨　　一切莫能见
  譬如大海中　　有四摩尼宝
  光焰甚猛热　　能消大海水
  若无此四宝　　天地悉漂没
  大海无增减　　四域皆安住
  如来四种智　　无量不可称
  能止诸菩萨　　不善根波浪
  一切三世间　　欲色无色界
  离我及我所　　安住于虚空
  善逝智亦然　　一切智根本
  声闻学无学　　及诸缘觉智
  菩萨普饶益　　无量甚深智
  悉依如来智　　如来智无依
  如彼雪山顶　　有大药王树
  名不从根生　　非不从根生
  由此药王树　　生长因缘故
  悉生阎浮提　　一切诸树林
  彼树根生时　　一切树根生
  茎枝叶华实　　一切亦如是
  清净甚深智　　如来性中生
  依因如来智　　出生修行智
  一切菩萨行　　无量诸功德
  如来智树王　　平等心地生
  譬如劫尽时　　猛盛大火栽
  设人投干草　　犹可烧不尽
  善逝清净智　　无量无有边
  悉能分别知　　三世众生类
  又知一切劫　　一切诸佛刹
  如是无量法　　如来悉了知
  譬如劫尽时　　风栽名坏散
  能坏诸大地　　金刚及须弥
  刹外有风起　　名曰障散坏
  若无此风者　　十方悉磨灭
  十力亦如是　　智慧风无量
  皆悉能散灭　　菩萨诸烦恼
  如来方便智　　摄取诸菩萨
  过声闻缘觉　　安住如来地
  譬如微尘内　　有一大经卷
  三千世界等　　无益众生类
  尔时有一人　　出兴于世间
  破尘出经卷　　饶益一切世
  如来智如是　　众生悉具有
  颠倒妄想覆　　众生不知见
  如来教众生　　修习八圣道
  除灭一切障　　究竟成菩提

佛子。云何菩萨摩诃萨。知见如来应供等正觉境界。此菩萨摩诃萨。成就无量无边无碍智慧。知一切众生是如来境界。一切世间。一切刹。一切法。一切众生行。如如不坏境界。无碍法界境界。实际无际境界。无量虚空境界。非境界境界。是如来境界。佛子。一切众生无量故。如来境界无量。一切世间无量故。如来境界无量。乃至非境界境界无量故。如来境界无量。非境界至一切处。而无所至。如来境界亦复如是。佛子。菩萨摩诃萨。知心境界是如来境界。如心境界无量故。如来境界无量。何以故。随心无量。出生智慧亦复如是。佛子。譬如大龙随心降雨。雨不从内亦不从外。如来境界亦复如是。随心所念。于念念中。出生无量不思议智。彼诸智慧悉无来处。佛子。一切大海水。皆从龙王心愿所起。如来智海亦复如是悉从大愿力起。佛子。如来智海无量无边。不可言说。不可思议。我说小谕。汝今谛听。佛子。此阎浮提内。流出二千五百河水。悉入大海。俱耶尼内。流出五千河水。悉入大海。弗婆提内。流出八千四百河水。悉入大海。郁单越内。流出一万河水。悉入大海。佛子。此四天下内。如是二万五千九百河水。悉入大海。佛子。于意云何。此水多少。答言甚多。佛子。复有十光明龙王。雨大海中悉过前水。百光明龙王。雨大海中复悉过前。大庄严龙王。雨大海中复悉过前。摩那斯龙王。雨大海中复悉过前。大雷龙王。雨大海中复悉过前。难陀。跋难陀龙王。雨大海中复悉过前。无量光明龙王。雨大海中复悉过前。流注不断龙王。雨大海中复悉过前。大胜龙王。雨大海中复悉过前。金刚光明龙王。雨大海中复悉过前。佛子。如是等八十亿龙王。各雨大海展转过前。娑伽罗龙王太子名曰佛生。雨大海中复悉过前。佛子。彼十光明龙王所住渊池。流入大海复悉过前。百光明龙王所住渊池。流入大海复悉过前。大庄严龙王所住渊池。流入大海复悉过前。摩那斯龙王所住渊池。流入大海复悉过前。大雷龙王所住渊池。流入大海复悉过前。难陀。跋难陀龙王所住渊池。流入大海复悉过前。无量光明龙王所住渊池。流入大海复悉过前。流注不断龙王所住渊池。流入大海复悉过前。大胜龙王所住渊池。流入大海复悉过前。金刚光明龙王所住渊池。流入大海复悉过前。如是等广说。乃至娑伽罗龙王太子所住渊池。流入大海复悉过前。佛子。如彼十龙王。及八十亿龙王。乃至娑伽罗龙王太子。雨大海中及其渊池。皆悉不及娑伽罗龙王所雨大海。娑伽罗龙王所住渊池。涌出流入大海倍复过前。彼涌流水。青琉璃色。盈满大海。涌出有时。是故海潮常不失时。佛子。如是大海。其水无量。珍宝无量。众生无量。大地无量。佛子。于意云何。彼大海水。为无量不。答言实尔。其水深广不可为谕。佛子。如是海水深广无量。于如来无量智海。百分不及其一。乃至不可为譬。但随所应化。为作譬谕。佛子。菩萨摩诃萨。知见如来智海。深广无量。从初发心。乃至不断菩萨无量行故。知见道品宝无量。不断三宝故。知见无量众生欢喜。长养一切声闻学无学及缘觉故。知见大地无量。从欢喜地乃至究竟无碍智地故。佛子。是为菩萨摩诃萨知见如来应供等正觉。境界无量。饶益一切众生。无量智慧故。尔时普贤菩萨。欲重明此义。以偈颂曰

  离垢净境界　　无量不可称
  殊胜愿力故　　一切无有量
  譬如心境界　　无量无有边
  一切诸十力　　境界亦如是
  譬如大龙王　　不离于本处
  以心愿力故　　其雨无有量
  雨水无从来　　亦无有去处
  龙王愿力故　　随心雨无量
  一切十方刹　　十力亦如是
  本无所从来　　去亦无所至
  无量诸境界　　悉从心缘起
  一切诸法界　　皆入一毛道
  譬如大海水　　无量无有边
  众生及珍宝　　大地亦无量
  海水常湛然　　皆悉同一味
  随众生受用　　其味各不同
  最胜亦如是　　智慧海无量
  三宝最胜故　　是故宝无量
  声闻学无学　　辟支佛无量
  具修无上道　　故说地无量

佛子。云何菩萨摩诃萨。知见如来应供等正觉行。此菩萨摩诃萨。知见如来无碍行。如如行。是如来行如如。过去不灭。未来不至。现在不起。如来行亦如是。不灭不至不起。佛子。譬如法界无量无缚。何以故。法界无身故。如来行亦如是。无量无缚。何以故。如来行无身故。佛子。譬如鸟飞虚空。经百千年。所游行。处不可度量。未游行处亦不可量。何以故。虚空无分齐故。如来应供等正觉行。亦复如是。若使有人。于百千亿那由他劫。分别解说如来之行。已解说者不可限量。未解说者亦不可量。何以故。如来行无分齐故。佛子。如来应供等正觉。住如来住。无所住故。而能普为一切众生。示现开导如来之行。众生见已。出过一切诸障碍道。佛子。譬如金翅鸟王飞行虚空。安住虚空。以清净眼。观察大海龙王宫殿。奋勇猛力。以左右翅博开海水。悉令两辟。知龙男女有命尽者。而撮取之。如来应供等正觉金翅鸟王。亦复如是。安住无碍虚空之中。以清净眼。观察法界诸宫殿中。一切众生。若有善根已成熟者。奋勇猛十力。止观两翅。博开生死大爱海水。随其所应。出生死海。除灭一切妄想颠倒。安立如来无碍之行。佛子。譬如日月周行虚空。不作是念。我行虚空。从何所来。去至何所。如来亦复如是。周行无碍解脱虚空。分别一切法界。饶益一切众生。广作佛事。如来不作是念。我有去来。佛子。菩萨摩诃萨。以如是等无量无边胜行。知见如来应供等正觉行。尔时普贤菩萨。欲重明此义。以偈颂曰

  譬如如无尽　　无生亦无灭
  亦无有方处　　求之不可见
  如来亦如是　　境界不可量
  远离于三世　　其性悉如如
  譬如诸法界　　非界非不界
  非有亦非无　　非量非无量
  功德持如是　　所行不可量
  非有亦非无　　其身本无故
  如鸟飞虚空　　经由百千年
  行处未行处　　皆悉不可量
  若人百千劫　　演说如来行
  已说及未说　　皆悉不可量
  譬如金翅鸟　　安住于虚空
  观察龙王宫　　撮取其男女
  十力亦如是　　安住如来行
  善根纯熟者　　令出烦恼海
  譬如净日月　　周行于虚空
  安乐一切众　　不念我能尔
  如来亦如是　　游行诸法界
  度脱一切众　　不念我能度

佛子。云何菩萨摩诃萨。知见如来应供等正觉菩提。此菩萨摩诃萨。知见菩提。解一切义。灭除疑惑。不二等觉。无相。无行。无退。无量无边。无缚无脱。远离二边知处非处。知一切字一切语言法。知一切众生心心所行。知一切根烦恼习性。于一念中。悉知三世一切诸法。佛子。譬如大海。为一切众生色像之印。是故大海说名为印。如来应供等正觉菩提。亦复如是。一切众生心念诸根。现菩提中而无所现。故说如来为一切觉。佛子。一切诸佛菩提。一切文字所不能记。一切语言所不能说。不可为譬。但随所应。如来为之分别演说。佛子。如来应供等正觉成菩提时。住佛方便。得一切众生等身。得一切法等身。得一切刹等身。得一切三世等身。得一切如来等身。得一切诸佛等身。得一切语言等身。得一切法界等身。得虚空界等身。得无碍法界等身。得出生无量界等身。得一切行界等身。得寂灭涅槃界等身。佛子。随如来所得身。当知音声及无碍心。亦复如是。如来具足如是等三种清净无量。佛子。如来身中。悉见一切众生发菩提心。修菩萨行成等正觉。乃至见一切众生寂灭涅槃。亦复如是。皆悉一性以无性故。无相无尽。无生无灭故。我非我性故。众生非众生性故。觉无所觉故。法界无自性故。虚空界无自性故。如是等觉一切无性。无尽智。自然智。一切如来无极大悲。度脱众生。佛子。譬如虚空界。世界若成若败。常无增减。何以故。虚空无生灭故。如来应供等正觉。菩提若成未成。常无增减。一性无性舍离众性。佛子。设有一人出兴于世。彼能化作恒沙等心。彼一一心。悉能化作恒沙如来。无色无形。如是恒沙等劫。常化不绝。于意云何。彼化如来宁为多不。答曰。我知仁意。若化不化等无有异。善哉善哉。佛子。诚如所言。佛子。设使一切众生。于一念中悉成正觉。若成未成皆悉平等。何以故。菩提无性故。无增无减。如来菩提皆悉一性。所谓无性。佛子。是为菩萨摩诃萨知见如来应供等正觉菩提。佛子。如来应供等正觉。成正觉已。正受三昧。名曰善觉。正受三昧已。得菩提身。数与一切众生身等。如一三昧。一切三昧。一切法门。亦复如是。佛子。是为菩萨摩诃萨知见如来应供等正觉菩提身。复次佛子。菩萨摩诃萨。于一毛道。悉知一切众生等如来之身。如一毛道。一切毛道。一切法界处。亦复如是。何以故。如来菩提身。无处不至。无处不有故。如来应供等正觉。本求菩提勤修精进。往诣道场菩提树下。处师子座。成最正觉。究竟菩提。复次佛子。此菩萨摩诃萨。自知身中。悉有一切诸佛菩提。何以故。彼菩萨心。不离一切如来菩提故。如自心中。一切众生心中。亦复如是。无量无边。无处不有。不可破坏。不可思议。佛子。菩萨摩诃萨。以如是等无量无边不可思议方便法门知见如来应供等正觉菩提。尔时普贤菩萨。欲重明此义。以偈颂曰

  菩提非二法　　远离于二边
  除灭一切恶　　平等觉诸法
  了达一切法　　皆悉如虚空
  非我非无我　　等觉一切法
  譬如诸大海　　一切众生类
  色像悉显现　　故说一切印
  十方世界中　　一切众生类
  无上菩提海　　无法而不现
  譬如虚空性　　世界成坏时
  若成若未成　　虚空无增减
  最胜亦如是　　无上菩提道
  若觉若未觉　　一性亦无性
  譬如无量劫　　念念化诸佛
  若化若不化　　皆悉等无异
  设一切众生　　一时成正觉
  若成若未成　　菩提无增减
  最胜有三昧　　名曰为善觉
  道场成菩提　　逮得此三昧
  普放无量光　　一切众生等
  除灭一切闇　　开悟诸群生
  三世一切劫　　佛刹及诸法
  诸根心心法　　一切虚妄法
  于一佛身中　　此法皆悉现
  是故说菩提　　无量无有边

佛子。云何菩萨摩诃萨知见如来应供等正觉转法轮。此菩萨摩诃萨。知见如来一切愿。一切法转无所转。本无所起。三转圆满皆悉清净。悉能远离一切邪见。离欲际非际。一切诸法。如虚空际。不可言说。一切法寂灭。涅槃性故。菩萨摩诃萨。知见一切文字。一切语言法。悉转法轮。如来音声无所不至故。知见法轮如响。真实法性故。知见一切音声皆是一声。如来以此而转法轮。佛转法轮无有主故。知见转法轮无漏无尽。内外无所有故。佛子。譬如文字。于无量无数劫。说不可尽。如来应供等正觉转正法轮。亦复如是。一切文字。一切语言。说不可尽。如来法轮。悉入一切语言文字。而无所住。佛子。譬如字章。悉入一切字数。一切事数。一切语言数。一切算数。一切世间出世间。而无所住。如来音声亦复如是。于一切处无所不入。于一切众生。一切法。一切业。一切报。一切心。亦无所住。一切众生诸语言法。皆为法轮音声所摄。何以故。一切音声不离法轮音声故。复次佛子。此菩萨摩诃萨。知见如来应供等正觉出生法门转法轮。何等为如来出生法门转法轮。如来以一切众生念念心心行等音声。为一切众生而转法轮。何以故。佛子。如来应供等正觉有三昧。名曰究竟无碍无畏如来正受三昧。而转法轮。如来入此三昧已。出生一切众生等音。于一一音中。复生一切众生等音。而转法轮。悉令众生皆大欢喜。佛子。若如是知转法轮者。当知是人则为随顺一切佛家。不如是知。则不随顺诸如来家。佛子。是为菩萨摩诃萨知见如来应供等正觉转法轮。尔时普贤菩萨。欲重明此义。以偈颂曰

  如来转法轮　　三世无不至
  所转无所转　　求之不可得
  譬如诸文字　　说之不可尽
  十力亦如是　　转法轮无尽
  譬如章文字　　悉入一切数
  所入无所入　　法轮亦如是
  普入一切音　　所入无所入
  彼亦无自性　　能令一切喜
  出过一切数　　究竟成菩提
  欲说真实义　　是故入三昧
  以彼三昧力　　出生妙音声
  悉与众生等　　而转正法轮
  又复悉于彼　　一一诸音声
  出生无量音　　众生语言法
  大自在无念　　我出彼众音
  随其受化者　　一切无不闻
  譬如诸文字　　不内亦不外
  无漏不可尽　　亦复无积聚
  十力亦如是　　转清净法轮
  无漏不可尽　　诸佛大神力

大方广佛华严经卷第三十五大方广佛华严经卷第三十六

        东晋天竺三藏佛驮跋陀罗译

    宝王如来性起品第三十二之四

佛子。云何菩萨摩诃萨。知见如来应供等正觉大般涅槃。此菩萨摩诃萨。欲知见如来应供等正觉大般涅槃者。当如是知如如般涅槃。如来大般涅槃。亦复如是。如实际。如法界。如虚空界。如实性。如离欲际。如无相际。如我性际。如一切法性际。如真实际般涅槃。如来大般涅槃。亦复如是。何以故。涅槃非生灭法。若法不生。当知不灭去无所至。佛子。如来应供等正觉。不为菩萨演说显现如来究竟涅槃。何以故。欲令诸菩萨于一念中。普见三世一切诸佛悉现前故。出生一切如来妙色。亦复不起二不二想。何以故。菩萨摩诃萨。远离诸想。无染着故。佛子。但如来欲令众生欢喜故。出现于世。欲令众生忧悲感慕故。示现涅槃。其实如来无有出世。亦无涅槃。何以故。如来常住如法界故。为化众生示现涅槃。佛子。设有日出照现世间。圆满明净与法界等。于一切世界净水器中。影无不现。日无是念。我能普现一切净水。佛子。彼时或有一水器破。日影不现。于意云何。彼影不现。岂日过耶。答曰不也。水器破故日影不现。佛子。如来智慧圆满净日一念出现。悉能照明一切世界一切法界一切众生。灭除垢浊。净心水器影无不显。常现在前。但破器浊心众生。不见如来法身影像。应见涅槃而得度者。是故如来现般涅槃。其实如来不生不灭。永无灭度。佛子。譬如大火于一切世界能为火事。焚烧草木无不尽者。有时彼火至无草木城邑聚落。自然而灭。于意云何。一切世间火悉灭不。答曰不也。如来应供等正觉。亦复如是。于一切世界。施作佛事。或一佛刹化度已周。示现涅槃。于意云何。一切世界如来悉灭度耶。答曰不也。佛子。是为菩萨摩诃萨知见如来应供等正觉大般涅槃。复次佛子。如大幻师善知幻术。安住此术。于三千大千世界一切城邑聚落大王之都。普现幻身。住持幻身。寿命无尽。时此幻师于彼城邑聚落大王之都。随事讫处。便舍幻身。于意云何。为三千大千世界幻身悉舍灭耶。答曰不也。如来应供等正觉。亦复如是。善知大慧幻术。具足出生巧方便慧。于一切法界。普能示现如来幻身。常住如法界。究竟如虚空。随诸佛刹。教化度脱已周讫处。示现涅槃。当知不以一佛刹示现涅槃故。如来究竟永灭度也。佛子。是为菩萨摩诃萨知见如来大般涅槃。复次佛子。如来示现般涅槃时。先入不动三昧入三昧已。于一一身。各放无量亿千那由他大光。一一光明。各出无量阿僧祇妙宝莲华。一一莲华。各有不可说不可说妙宝华须。一一华须。各有宝师子座。一一座上。各有如来结跏趺坐。彼时所现诸如来身。悉与一切众生数等。功德具足。相好庄严。究竟本愿。时有众生善根熟者。见如来身。心皆调伏。禀受道化。彼如来身究竟安住。尽未来际随一切众生。所应受化未曾失时。彼如来身。无有处所。非实非虚。如来但欲究竟过去诸大愿故。欲令众生长养诸善根故。应现其身常住不灭。佛子。是为菩萨摩诃萨知见如来应供等正觉大般涅槃。复次佛子。此菩萨摩诃萨。知见如来涅槃无量无边。究竟法界。无所障碍。不生不灭。净如虚空。安住实际。随其所应而示现之。本愿所持。不舍一切众生一切佛刹一切诸法。尔时普贤菩萨。欲重明此义。以偈颂曰

  譬如圆满日　　一切法界等
  影现一切水　　唯除诸破器
  最胜亦如是　　普现一切世
  众生无信心　　谓佛入涅槃
  譬如猛盛火　　焚烧一切物
  无草木聚落　　火则自然灭
  最胜亦如是　　充满于法界
  究竟诸佛事　　示现入涅槃
  譬如大幻师　　示现无量身
  如来亦如是　　普现一切身
  究竟诸佛事　　示现般涅槃
  随应受化者　　以此而示现
  最胜有三昧　　名曰不可动
  究竟佛事已　　然后入此定
  念出无数佛　　又放无量光
  光有无量华　　华有无量佛
  最胜无量身　　充满诸法界
  积集功德者　　一切无不见
  善逝净法身　　无量法界等
  寿命净庄严　　一切悉具足
  犹如无生性　　如来兴亦然
  犹如无生性　　涅槃亦如是
  悉离语言道　　不可为譬谕
  天中天难胜　　具足一切德

佛子。云何菩萨摩诃萨知见于如来应供等正觉所见闻恭敬供养所种善根。此菩萨摩诃萨。知见于如来所见闻恭敬供养所种善根。皆悉不虚。功德无尽。离一切爱究竟解脱。果报不虚满足诸愿。于一切有为法中。不可穷尽。而能随顺无为智慧。起诸佛智。究竟未来际。具足一切诸如来地。佛子。譬如丈夫食少金刚。终竟不消。要从身过。至金刚轮际。然后乃住。所以者何。以彼金刚不可消故。如是佛子。于如来所。少植善根。能坏一切有为烦恼。乃至究竟如来涅槃智慧。然后乃住。所以者何。于如来所。植诸善根。不可尽故。佛子。譬如须弥山等大干草聚。若有人持如芥子火。悉能烧尽。何以故。火性悉能烧故。佛子。于如来所。种少善根。亦复如是。悉能烧灭一切烦恼。无有遗余。究竟涅槃。何以故。于如来所。种诸善根。性究竟故。佛子。譬如雪山有大药王。名曰善现。若有见者眼得清净。若有闻者耳得清净。若闻香者鼻得清净。若尝味者舌得清净。若有触者身得清净。若取彼地土。悉能除灭无量众病。安隐快乐。如来应供等正觉无上药王。亦复如是。常以一切诸方便行。饶益众生。若有得见如来色身。眼得清净。若有得闻如来名号。耳得清净。若有得闻如来戒香。鼻得清净。若有得味如来法味。舌得清净。得金刚广长清净舌根。悉能演说一切言音。若有得触如来光者。彼人即得清净色身。究竟逮得无上法身。若有念如来者。得念佛三昧。正念不乱。若有得经卷地。如来塔庙礼拜供养。彼众生等具足善根。灭烦恼患得贤圣乐。佛子。乃至不信邪见众生。见闻佛者。彼诸众生。于见闻中。所种善根果报不虚。乃至究竟涅槃。断一切恶诸不善根。具足善根。佛子。于如来所。见闻供养恭敬。所种善根不可言说。不可为谕。何以故。如来不可思议过思议故。但随所应佛为作谕。佛子。是为菩萨摩诃萨知见于如来所见闻恭敬供养种诸善根。尔时诸菩萨摩诃萨。白普贤菩萨言。佛子。当何名此经。云何奉持。佛子。此经名为一切诸佛微密法藏。一切世间不能思议。如来所印。大智光明。开发示现如来种性。长养一切菩萨功德。一切世间无能破坏。随顺一切如来境界。令一切众生皆悉清净。分别演说佛究竟法。佛子。如是经典。但为乘不思议乘。菩萨摩诃萨。一向专心求菩提者。分别解说不为余人。何以故。此经不入一切众生之手。唯除菩萨。佛子。譬如转轮圣王所有七宝。因此宝故。行转轮王法。圣王七宝无堪持者。唯除第一夫人所生太子。具足成就圣王相者。佛子。若转轮王无此太子具众德者。王命终后。此诸宝等自然散灭。佛子。此经如是。不入一切众生之手。唯除如来法王真子。从诸如来种姓家生。种如来相诸善根者。若无此等佛之真子。斯经则灭。何以故。一切声闻缘觉不闻此经。何况受持书写解说。无有是处。唯除菩萨摩诃萨能自诵持书写经卷。佛子。是故菩萨摩诃萨。闻此经者。欢喜恭敬顶戴受持。何以故。菩萨摩诃萨。信乐此经。少作方便。必决定得无上菩提。佛子。菩萨摩诃萨。虽无量亿那由他劫。行六波罗蜜。修习道品善根。未闻此经。虽闻不信受持随顺。是等犹为假名菩萨。不从如来种姓家生。佛子。若菩萨摩诃萨。得闻此经。闻已信向受持随顺。当知此等为真佛子。从佛家生。随顺一切如来境界。具足一切菩萨正法。安住一切种智境界。远离一切世间诸法。出生长养如来所行。到一切菩萨诸法彼岸。于如来自在正法。心无疑惑。究竟安住无师之地。深入一切如来境界。佛子。菩萨摩诃萨。闻此经已。应当发平等意行无量心。远离一切虚妄之想。究竟直心。面对正念一切如来。修习平等清净犹如虚空。分别观察一切菩萨行业与法界等。具足成就一切智智。远离一切世间垢浊。发清净心。充满一切十方世界。深入一切菩萨法门。平等观察三世诸佛。具足善根功德智慧。深入此等一切诸法而无所入。不念一法不念二法。悉平等观无量诸法。佛子。菩萨摩诃萨。成就如是等功德。少作方便得无师智。尔时普贤菩萨。欲重明此义以偈颂曰

  若见闻如来　　恭敬及供养
  所植诸善根　　无量不可称
  一切有为中　　不可得穷尽
  寂灭诸烦恼　　离苦得涅槃
  譬如有一人　　吞服少金刚
  究竟不可消　　下至金刚际
  如是十力所　　见闻供养福
  具足金刚智　　烦恼灭无余
  譬如干草积　　等彼须弥山
  投火如芥子　　烧尽悉无余
  如是善逝所　　若植少功德
  烧灭诸烦恼　　正趣到涅槃
  譬如雪山中　　有大药王树
  见闻嗅味触　　除灭一切患
  十力亦如是　　若有见闻者
  修习胜功德　　究竟成菩提

尔时十方不可说不可说。百千亿那由他佛刹微尘等世界六种震动。东涌西没。西涌东没。南涌北没。北涌南没。边涌中没。中涌边没。及十八相动。所谓动。遍动。等遍动。起。遍起。等遍起。觉。遍觉。等遍觉。震。遍震。等遍震。吼。遍吼。等遍吼。涌。遍涌。等遍涌。尔时佛神力故。法如是故。雨众华云。胜过诸天。雨宝衣云。盖云。幢云。幡云。香云。涂香云。鬘云庄严云。众宝云。菩萨赞叹云。菩萨身云。三藐三菩提云。普令不可思议世界皆悉清净。雨如来妙音声云。充满无量无边法界。如此四天下佛神力故。令诸菩萨皆大欢喜。一切十方亦复如是。尔时十方各过八十不可说百千亿那由他佛刹微尘等世界之外。各有八十不可说百千亿那由他世界微尘等如来。悉现其身。若近对面。同号普贤。现已咸作是言。善哉善哉。佛子。乃能承佛神力。随顺深法。解说不可思议如来性起正法。佛子。我等诸佛亦说此法。十方一切诸佛。及诸菩萨亦复如是。说此经时。百千佛刹微尘等菩萨。得菩萨一切明。一切三昧。授一生记。当成阿耨多罗三藐三菩提。一佛刹微尘等众生发菩提心。我等悉与授记。于未来世当成佛道。悉同一号号佛胜境界。是故我等普为未来诸菩萨故。护持此经。令久住世。如此四天下所度众生。十方无量阿僧祇不可思议不可称不可量不可说法界虚空界等。一切世界所度众生。亦复如是。卢舍那佛本愿力故。法如是故。善根力故。如来无尽智故。如来不失时故。随其所应化菩萨故。广行普贤菩萨行故。示现一切种智故。尔时十方各过十不可说百千亿那由他佛刹微尘等世界之外。各有十不可说百千亿那由他佛刹微尘等菩萨。来诣此土。充满一切法界。示现菩萨大妙庄严。放大光明网。震动一切世界。坏散一切诸魔宫殿。除灭一切恶道诸难。照明一切如来功德。赞叹一切如来正法。普雨无量无边供养云雨。示现无量种种异身。示现己身是无量诸佛法门之器。时彼诸菩萨承佛神力。各作是言。善哉善哉。佛子。乃能说是如来不可坏法。佛子。我等一切悉名普贤。于普光明世界普胜如来所。净修梵行。彼诸佛所亦说是经。如是句。如是味。如是行。如是相貌。佛子。我等承佛神力故。法如是故。于彼世界来诣此土为汝作证。一切十方尽法界虚空界等一切世界。亦复如是。尔时普贤菩萨。承佛神力。观察一切诸菩萨众。欲重明如来性起正法。欲说如来无量功德。欲明如来正法不可沮坏。欲生一切菩萨无量智慧法明。欲说一切具足佛法。欲观察一切群生类心。欲随所应化不失时。欲分别一切无量无边菩萨正法。欲显现一切如来变化自在庄严。欲明一切如来一身无异。欲出生一切菩萨无量本行。以偈颂曰

  一切诸如来　　所成就威仪
  举世悉称誉　　无能为譬谕
  为饶益众生　　令悉开解故
  以非谕为谕　　显现真实义
  如是微密法　　无量劫难闻
  精进智慧者　　乃闻如来藏
  若有闻此经　　欢喜恭敬者
  此等已过去　　供养无量佛
  当知如此人　　诸天常赞叹
  一切诸善逝　　摄取常守护
  一切诸善逝　　世上世间胜
  最胜欢喜众　　此经为内藏
  能出生无量　　一切白净道
  是故离放逸　　一心常奉持

    大方广佛华严经离世间品第三十三之一

尔时世尊。在摩竭提国寂灭道场普光法堂。坐莲华藏宝师子座。成等正觉。念不二念。无相念。住佛所住。等一切佛。到无碍趣。得不还法无碍境界。住不思议远离三世。于一切世界普现其身。知一切法。具足成就一切妙行。永灭疑惑离虚妄身。能与一切菩萨无量智慧。住佛无二法。究竟到彼岸。具足如来不可沮坏智慧法门。究竟无量无边虚空法界等如来诸地。与百千亿那由他不可说一切佛刹微尘等菩萨摩诃萨。俱悉是一生当成阿耨多罗三藐三菩提。各从十方世界来集。具足成就一切菩萨方便智慧。善巧方便调伏众生。悉令安住菩萨正法。分别了知一切世界。观察明达解脱境界。悉已除灭一切虚妄。具足成就一切妙行。善摄众生。深入无量巧方便法。善知一切众生果报。善知一切众生心使诸根境界方便。三世一切诸佛所说句味及义。善闻受持广为人说。善入无量无边世间离世间法。善能解了诸有为法皆悉无二。于一念中得一切佛智。于念念中善能示现成等正觉。令一切众生。发菩提心成等正觉。入一众生境界。善知一切众生心之境界。不舍如来地。现菩萨身。得不退转一切智地。不舍菩萨行。深入无行智。为一切众生故。于无量无数劫。修菩萨行。于无量无数劫。难得值遇菩萨之宝。转正法轮调伏众生。悉令逮得明净法眼。成就三世一切诸佛净住行愿。具足如是等无量无边功德。一切诸佛。尽未来劫说不可尽。其名曰普贤菩萨。普正法菩萨。普化菩萨。普慧菩萨。普眼菩萨。普光菩萨。普观察菩萨。普照菩萨。普幢菩萨。普觉菩萨。如是等百万亿那由他不可说佛刹微尘等菩萨摩诃萨。皆悉具足普贤行愿。随诸世界有佛兴世。悉能往诣请转法轮。悉能受持诸佛正法。令一切佛种姓不断。悉能了达一切诸佛次第授记。随诸世界成等正觉转净法轮。于无佛世界现身为佛出兴于世。令有染者悉得清净。除灭一切菩萨业障。入无碍法界。尔时普贤菩萨正受三昧。其三昧名佛华严。入三昧已。十方一切世界六种十八相震动出微妙音。一切世界无不闻者。然后安详从三昧起。尔时普慧菩萨。知诸菩萨大众云集。问普贤菩萨言。佛子。何等为诸菩萨摩诃萨依果。何等为奇特想。何等为行。何等为善知识。何等为勤修精进。何等为正希望。何等为成就众生。何等为戒。何等为自知受记法。何等为入。何等为入如来。何等为入众生心行。何等为入世界。何等为入劫。何等为说三世。何等为入三世间。何等为离忧心无厌悔。何等为无坏智。何等为陀罗尼。何等为知分别说佛。何等为发普贤心。何等为普贤愿行法。何等为大悲。何等为发菩提心因缘。何等为于善知识起恭敬心。何等为清净。何等为波罗蜜。何等为随顺觉知。何等为决定智。何等为力。何等为平等。何等为佛法句。何等为说法。何等为受持。何等为辩。何等为胜法。何等为无著。何等为平等心。何等为出生智慧。何等为变化。何等为持。何等为大正希望。何等为深入佛法。何等为依止。何等为发无畏心。何等为除灭一切疑惑发无疑心。何等为不思议。何等为巧方便微密语。何等为巧方便分别智。何等为正受三昧。何等为一切处。何等为法门。何等为通。何等为明。何等为解脱。何等为园林。何等为宫殿。何等为乐。何等为庄严。何等为发不动心。何等为不舍深心。何等为智观察。何等为分别法。何等为无垢。何等为智印。何等为智慧光明。何等为不可称量住。何等为无懈怠心。何等为须弥山王正直之心。何等为深入智慧大海成。无上菩提。何等为宝住。何等为发金刚心庄严大乘。何等为发大事。何等为究竟大事。何等为不坏信。何等为授记。何等为善根回向。何等为得智慧。何等为发无量无边广心。何等为藏。何等为调顺。何等为自在。何等为众生自在。何等为刹自在。何等为法自在。何等为身自在。何等为愿自在。何等为境界自在。何等为智自在。何等为通自在。何等为神力自在。何等为力自在。何等为游戏神通。何等为胜行。何等为力。何等为无畏。何等为不共法。何等为业。何等为身。何等为身业。何等为净身业。何等为口。何等为净口业。何等为净口业得诸守护。何等为口业成办大事。何等为心。何等为发心。何等为心满。何等为根。何等为直心。何等为深心。何等为方便。何等为乐修。何等为解脱深入世界。何等为入众生性。何等为习气。何等为炽然。何等为趣。何等为具足法。何等为退失佛法。何等为离生。何等为决定法。何等为出生佛道法。何等为得。善男子名号。何等为道。何等为无量道。何等为道具。何等为修道。何等为庄严道。何等为足。何等为手。何等为腹。何等为藏。何等为心。何等为庄严。何等为器仗。何等为头。何等为眼。何等为耳。何等为鼻。何等为舌。何等为身。何等为意。何等为行。何等为住。何等为坐。何等为卧。何等为住。何等为行。何等为观察。何等为周遍观察。何等为奋迅。何等为师子吼。何等为净施。何等为净戒。何等为净忍。何等为净精进。何等为净禅。何等为净慧。何等为净慈。何等为净悲。何等为净喜。何等为净舍。何等为义。何等为法。何等为功德具。何等为智具。何等为明足。何等为求法。何等为明了法。何等为向法。何等为魔。何等为魔业。何等为舍离魔业。何等为见佛。何等为佛业。何等为慢业。何等为智业。何等为魔摄持。何等为佛摄持。何等为法摄持。何等为住兜率天所行事业。何等为兜率天示现命终。何等为示现降神母胎事。何等为示现微细趣。何等为生。何等为大庄严。何等为游行七步。何等为示现童子地。何等为示现采女眷属。何等为示现舍家出家。何等为示现苦行。何等为往诣道场。何等为坐道场。何等为坐道场时显奇特相。何等为示现降魔。何等为成等正觉。何等为转法轮。何等为因转法轮得白净法。佛子。何等为如来应供等正觉示现大般涅槃。善哉。佛子。如向所问愿具演说

尔时普贤菩萨摩诃萨。告普慧等诸菩萨言。佛子。菩萨摩诃萨。有十种依果。何等为十。所谓菩提心依果。究竟不忘失故。善知识依果。随顺和合故。善根依果。长养诸善根故。诸波罗蜜依果。究竟修行故。一切法依果。永出生死故。诸愿依果。长养菩提故。诸行依果。广修习故。菩萨依果。一生补处故。供养佛依果。信心不坏故。一切如来依果。正教离颠倒故。佛子。是为菩萨摩诃萨十种依果。若菩萨摩诃萨。住此依果。则得如来无上智依果。佛子。菩萨摩诃萨。有十种奇特想。何等为十。所谓于一切善根生自善根想。于一切善根生菩提种子想。于一切众生生菩提器想。于一切愿生自愿想。于一切法生出生死想。于一切行生自行想。于一切法生佛法想。于一切语言生语言道想。于一切佛生慈父想。于一切如来生无二想。佛子。是为菩萨摩诃萨十种奇特想。若菩萨摩诃萨。安住此想。则得无上巧妙方便转一切想。佛子。菩萨摩诃萨。有十种行。何等为十。所谓令一切众生专求正法行。善根淳熟行。善学一切戒行。长养一切善根行。一心不乱修三昧行。分别一切诸智慧行。修习一切所修行。庄严一切世界行。恭敬供养善知识行。恭敬供养诸如来行。佛子。是为菩萨摩诃萨十种行。若菩萨摩诃萨。安住此行。则得如来无上大智行。佛子。菩萨摩诃萨。有十种善知识。何等为十。所谓能令安住菩提心善知识。能令修习善根善知识。能令究竟诸波罗蜜善知识。能令分别解说一切法善知识。能令安住成熟一切众生善知识。能令具足辩才随问能答善知识。能令不着一切生死善知识。能令于一切劫行菩萨行心无厌倦善知识。能令安住普贤行善知识。能令深入一切佛智善知识。佛子。是为菩萨摩诃萨十种善知识。佛子。菩萨摩诃萨。有十种勤修精进。何等为十。所谓教化一切众生勤修精进。入一切法勤修精进。令一切世界清净勤修精进。究竟一切菩萨所学勤修精进。令一切众生灭一切恶勤修精进。除灭一切地狱饿鬼畜生阎罗王苦勤修精进。降一切魔勤修精进。为一切众生作清净眼勤修精进。恭敬供养一切诸佛勤修精进。令一切如来皆悉欢喜勤修精进。佛子。是为菩萨摩诃萨十种勤修精进。若菩萨摩诃萨。住此精进。则具如来无上精进波罗蜜。佛子。菩萨摩诃萨。有十种正希望。何等为十。所谓自住菩提心亦令众生住菩提心正希望。自离忿诤亦令一切众生离于忿诤正希望。自离愚痴安住佛法。亦令众生舍离愚痴安住佛法正希望。自修善根专求正法亦令众生修习善根专求正法正希望。自究竟诸波罗蜜得到彼岸亦令众生究竟诸波罗蜜得到彼岸正希望。自生如来种姓家亦令众生生如来种姓家正希望。自深入观一切法无尽性亦令众生深入观一切法无尽性正希望。自不诽谤一切佛法亦令众生不诽谤一切佛法正希望。自满一切智愿亦令众生满一切智愿正希望。自深入一切如来无尽智藏亦令众生深入一切如来无尽智藏正希望。佛子。是为菩萨摩诃萨十种正希望。若菩萨摩诃萨。安住此法。则得如来无上平等大智正希望。佛子。菩萨摩诃萨。有十种法成就众生。何等为十。所谓布施成就众生。色身端严成就众生。说法成就众生。同意成就众生。无染着成就众生。叹菩萨行成就众生。示现一切世界炽然成就众生。叹如来功德成就众生。示现神力自在成就众生。种种巧方便微密随顺世间行成就众生。佛子。是为菩萨摩诃萨十种成就众生。若菩萨摩诃萨。安住此法。则能成就一切众生

大方广佛华严经卷第三十六大方广佛华严经卷第三十七

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之二

佛子。菩萨摩诃萨。有十种戒。何等为十。所谓不坏菩提心戒。离声闻缘觉地戒。饶益观察一切众生戒。令一切众生住佛法戒。一切菩萨学戒戒。一切无所有戒。一切善根回向菩提戒。不着一切如来身戒。佛子。菩萨摩诃萨。有十种自知受记法。令彼菩萨自知受记。何等为十。所谓一向发菩提心菩萨受记。不厌菩萨行菩萨受记。于一切劫修诸苦行菩萨受记。随顺一切佛法菩萨受记。于一切如来所说决定信向菩萨受记。具足修习一切善根菩萨受记。令一切众生安住菩提菩萨受记。于一切善知识和合随顺菩萨受记。于一切善知识生如来想菩萨受记。守护菩提本愿菩萨受记。佛子。是为菩萨摩诃萨十种自知受记法。令彼菩萨自知受记。佛子。菩萨摩诃萨有十种入。何等为十。所谓入愿。入行。入聚。入波罗蜜。入具足。入分别愿。入性。入庄严刹。入神力自在。入示现出生。佛子。是为菩萨摩诃萨十种入。亦入三世一切菩萨所入。佛子。菩萨摩诃萨。有十种深入如来。何等为十。所谓深入无量无边诸佛菩提。深入无量无边转净法轮。深入无量无边诸方便法。深入无量无边微妙音声。深入无量无边调伏众生。深入无量无边神力自在。深入无量无边种种异身。深入无量无边三昧。深入无量无边力无所畏。深入无量无边示现涅槃。佛子。是为菩萨摩诃萨十种深入如来。此十种深入法。三世诸佛悉亦共入。佛子。菩萨摩诃萨。有十种入众生心行。何等为十。所谓入过去一切众生心行。入未来一切众生心行。入现在一切众生心行。入一切众生诸善根行。入一切众生不善根行。入一切众生心心所行。入一切众生诸根行。入一切众生种性行。入一切众生烦恼使习气行。入一切众生时非时调伏行。佛子。是为十种入众生心行。因是十种入众生心行。则能普入一切众生心行。佛子。菩萨摩诃萨。有十种入世界。何等为十。所谓入不净世界。入清净世界。入小世界。入中世界。入微尘世界。入微细世界。入伏世界。入仰世界。入有佛世界。入无佛世界。佛子。是为菩萨摩诃萨十种入世界。因此十种入世界。则能普入一切世界。佛子。菩萨摩诃萨。有十种入劫。何等为十。所谓入过去劫。入未来劫。入现在劫。入可数劫。入不可数劫。入可数不可数劫。入不可数可数劫。入一切劫非劫。入非劫一切劫。入一切劫即是一念。佛子。是为菩萨摩诃萨十种入劫。因此十种入劫。则能普入一切诸劫

佛子。菩萨摩诃萨。有十种说三世。何等为十。所谓过去世说过去世。过去世说未来世。过去世说现在世。未来世说过去世。未来世说现在世。未来世说无尽。现在世说未来世。现在世说过去世。现在世说平等。现在世说三世即一念。佛子。是为菩萨摩诃萨十种说三世。因此十种说三世。则能普说一切三世。佛子。菩萨摩诃萨。有十种入三世间。何等为十。所谓入世间。入语言道。入性。入施设。入想。入名字。入语言。入无尽。入离欲。入寂灭。佛子。是为菩萨摩诃萨十种入三世间。因此十种入三世间。则能普入一切三世间。佛子。菩萨摩诃萨有十种舍离忧恼心无厌悔。何等为十。所谓供养一切佛舍离忧恼心无厌悔。亲近一切善知识舍离忧恼心无厌悔。专求一切法舍离忧恼心无厌悔。常闻正法舍离忧恼心无厌悔。常说正法舍离忧恼心无厌悔。教化调伏一切众生舍离忧恼心无厌悔。令一切众生安住佛道舍离忧恼心无厌悔。于一一世界中行不可说不可说菩萨行舍离忧恼心无厌悔。游行一切世界教化众生舍离忧恼心无厌悔。出生一切佛法舍离忧恼心无厌悔。佛子。是为菩萨摩诃萨十种舍离忧恼心无厌悔。若菩萨摩诃萨安住此法。则得如来无上智慧。永离厌悔。佛子。菩萨摩诃萨。有十种不可坏智。何等为十。所谓知众生智不可坏。知诸根智不可坏。知受生智不可坏。知世界智不可坏。知法界智不可坏。知佛智不可坏。知法智不可坏。知僧智不可坏。知三世智不可坏。知一切语言道智不可坏。佛子。是为菩萨摩诃萨十种不可坏智。若菩萨摩诃萨安住此智。则得如来无上不可坏智。佛子。菩萨摩诃萨。有十种陀罗尼。何等为十。所谓闻持陀罗尼。不忘一切法故。持正法陀罗尼。巧方便分别一切法如实故。不生一切法陀罗尼。觉一切法无自性故。法明陀罗尼。普照不可思议诸佛法故。三昧陀罗尼。于现在一切佛所闻法不乱故。音声圆满陀罗尼。究竟解了不可思议语言法故。三世陀罗尼。分别说一切三世佛不思议法故。种种辩才陀罗尼。分别解说无量无边诸佛法故。出生无碍耳陀罗尼。不可说佛所说诸法悉能闻故。持一切佛法陀罗尼。安住如来十力无畏故。佛子。是为菩萨摩诃萨十种陀罗尼。若菩萨摩诃萨欲得此法。应勤修学。佛子。菩萨摩诃萨。知分别说十种佛。何等为十。所谓正觉佛。愿佛。业报佛。住持佛。化佛。法界佛。心佛。三昧佛。性佛。如意佛。佛子。是为菩萨摩诃萨知分别说十种佛

佛子。菩萨摩诃萨。有十种发普贤心。何等为十。所谓发大慈心。救护一切众生故。发大悲心。代一切众生受一切苦毒故。发一切施为首心。悉舍一切诸所有故。发正念一切智为首心。乐求一切佛法故。发功德庄严心。学一切菩萨诸行故。发金刚心。一切受生不忘失故。发大海心。一切白净法悉流入故。发须弥山王心。一切诽谤苦言悉堪忍故。发安隐心。施一切众生无畏故。发究竟般若波罗蜜到彼岸心。巧分别一切法无所有故。佛子。是为菩萨摩诃萨十种发普贤心。若菩萨摩诃萨安住此心。以少方便则具足普贤巧方便智。佛子。菩萨摩诃萨。有十种普贤愿行法。何等为十。所谓尽未来劫行菩萨行普贤愿行法。恭敬供养未来一切佛普贤愿行法。立一切众生于普贤菩萨愿行普贤愿行法。积集一切善根普贤愿行法。入一切波罗蜜普贤愿行法。满足一切菩萨愿行普贤愿行法。庄严一切世界普贤愿行法。往生一切佛所普贤愿行法。善巧方便求一切法普贤愿行法。于一切十方佛刹成无上菩提普贤愿行法。佛子。是为菩萨摩诃萨十种普贤愿行法。若菩萨摩诃萨修此愿行。疾得具足普贤愿行。佛子。菩萨摩诃萨。有十种大悲常观众生。何等为十。所谓观察众生无所归依而起大悲。观察众生随逐邪道而起大悲。观察众生贫无善根而起大悲。观察众生长寝生死而起大悲。观察众生行不善法而起大悲。观察众生欲缚所缚而起大悲。观察众生在生死海而起大悲。观察众生久远长病而起大悲。观察众生无欲善法而起大悲。观察众生失诸佛法而起大悲。佛子。是为菩萨摩诃萨十种大悲常观众生。佛子。菩萨摩诃萨。有十种发菩提心因缘。何等为十。所谓教化成熟一切众生发菩提心因缘。除灭一切众生苦发菩提心因缘。与一切众生种种快乐发菩提心因缘。除灭一切众生愚闇发菩提心因缘。与一切众生佛智发菩提心因缘。恭敬供养一切诸佛发菩提心因缘。随如来教令佛欢喜发菩提心因缘。见佛色身相好发菩提心因缘。入一切佛智发菩提心因缘。显现佛力无畏发菩提心因缘。佛子。是为菩萨摩诃萨十种发菩提心因缘。若菩萨摩诃萨发菩提心应当恭敬供养亲近善知识。何以故。欲速觉一切智故。彼菩萨摩诃萨恭敬供养亲近善知识。起十种心。何等为十。所谓于善知识。起给侍心。不违心。随顺心。欢喜心。不求利心。一向心。同善根心。同愿心。如来心。同满行心。佛子。是为菩萨摩诃萨于善知识起十种心。佛子。若菩萨摩诃萨发如是十种心。则得十种清净。何等为十。所谓正直心清净。究竟不失故。色身清净。随所应化无不见故。音声圆满清净。究竟一切语言法故。辩才清净。巧方便说不可思议诸佛法故。智慧清净。除灭一切愚痴闇故。受生清净。具足菩萨自在力故。眷属清净。成就过去同行众生诸善根故。果报清净。除灭一切业障故。诸愿清净。同一切菩萨故。诸行清净。究竟普贤菩萨行故。佛子。是为菩萨摩诃萨十种清净佛子。菩萨摩诃萨。有十种波罗蜜。何等为十。所谓檀波罗蜜。舍一切有故。尸波罗蜜。净佛戒故。羼提波罗蜜。具足佛忍故。精进波罗蜜。于一切时不退转故。禅波罗蜜。正念不乱故。般若波罗蜜。观一切法悉如如故。智波罗蜜。深入佛力故。愿波罗蜜。普贤菩萨愿行满故。神力波罗蜜。示现一切神通力故。法波罗蜜摄取一切法故。佛子。是为菩萨摩诃萨十种波罗蜜。若菩萨摩诃萨安住此法。则得如来无上究竟智波罗蜜。佛子。菩萨摩诃萨。有十种随顺觉知。何等为十。所谓随顺觉知一切世界。随顺觉知一切众生不可思议。随顺觉知一切诸法不一不异。随顺觉知一切法界。随顺觉知一切虚空界。随顺觉知一切世界入过去世。随顺觉知一切世界入未来世。随顺觉知一切世界入现在世。随顺觉知一切如来于一念中具足愿行。随顺觉知三世诸佛悉同一行。佛子。是为菩萨摩诃萨十种随顺觉知。若菩萨摩诃萨安住此法。则得一切法自在。普照随意满愿。于一念中觉无上道。一切佛法悉现在前。佛子。菩萨摩诃萨。有十种决定智。何等为十。所谓决定了知一切诸法于一念中。决定了知一切诸法以无碍智。决定了知一切众生心心所行。决定了知一切众生皆悉同根。决定了知一切众生烦恼习气诸行。决定了知一切众生诸心使行。决定了知一切众生善不善行。决定了知一切菩萨愿行。决定了知神力自在变化住持。决定了知一切如来成就十力。佛子。是为菩萨摩诃萨十种决定智。若菩萨摩诃萨安住此法。则得一切诸法巧妙方便。佛子。菩萨摩诃萨。有十种力。何等为十。所谓深入一切法力。解一切法犹如化力。解一切法犹如幻力。令一切法入佛法力。于一切法无染着力。专求一切善妙法力。一向恭敬供养一切善知识力。令一切善根悉究竟得无上智力。深心信解一切佛法不诽谤力。究竟不退一切智心力。佛子。是为菩萨摩诃萨十种力。若菩萨摩诃萨安住此力。则能具足如来无上十力。佛子。菩萨摩诃萨。有十种平等。何等为十。所谓一切众生平等。一切法平等。一切佛刹平等。一切佛乘平等。一切善根平等。一切菩提平等。一切愿平等。一切波罗蜜平等。一切行平等。一切佛平等。佛子。是为菩萨摩诃萨十种平等。若菩萨摩诃萨住此平等。则具足一切诸佛无上平等。佛子。菩萨摩诃萨。有十种方便佛法句。何等为十。所谓说一切法言说方便佛法句。一切法如幻。一切法如电。一切法缘起。一切法净业。一切法文字。一切法实际。一切法无相。一切法真实义。一切法法界。佛子。是为菩萨摩诃萨十种方便佛法句。若菩萨摩诃萨安住此法。则得无上方便一切智。佛子。菩萨摩诃萨有十种说法。何等为十。所谓说甚深法。说胜妙法。说种种庄严法。说一切智法。说随顺波罗蜜法。说出生如来力法。分别说三世法。说不退菩萨法。说赞叹一切佛功德法。说一切菩萨行一切佛平等一切如来境界法。佛子。是为菩萨摩诃萨十种说法。若菩萨摩诃萨住此说法。则得如来无上说法。佛子。菩萨摩诃萨。有十种受持。何等为十。所谓受持一切善根功德。受持一切佛所说法。受持一切譬谕。受持一切方便法门。受持一切出生陀罗尼门。受持一切除疑惑法。受持一切菩萨具足法受持一切如来所。说平等三昧法门。受持一切普照法门。受持一切诸佛自在神力。佛子。是为菩萨摩诃萨十种受持。若菩萨摩诃萨安住此法。则得如来无上智慧持法。佛子。菩萨摩诃萨。有十种辩。何等为十。所谓不虚妄取一切法辩。于一切法无所行辩。于一切法无所著辩。于一切法悉空无辩。于一切法无闇障辩。于一切法佛所持辩。于一切法不由他悟辩。于一切法巧方便说句味身辩。于一切法说众生辩。于一切众生等心观察令欢喜辩。佛子。是为菩萨摩诃萨十种辩。若菩萨摩诃萨安住此辩。则得如来无上巧方便辩。佛子。菩萨摩诃萨。有十种胜法。何等为十。所谓成熟一切众生胜法。普照一切诸法胜法。修习一切善根一切行胜法。大乘智慧胜法。具足无著净戒胜法。一切善根悉回向菩提胜法。勤修精进不退胜法。降伏一切众魔胜法。发菩提心自在游行胜法。随时应化现成菩提胜法。佛子。是为菩萨摩诃萨十种胜法。若菩萨摩诃萨安住此法。则得如来无上大智胜法。佛子。菩萨摩诃萨。有十种无著。何等为十。所谓于一切世界无著。于一切众生无著。于一切法无著。于一切所作无著。于一切善根无著。于一切生处无著。于一切愿无著。于一切行无著。于一切菩萨无著。于一切佛无著。佛子。是为菩萨摩诃萨十种无著。若菩萨摩诃萨安住此法。则能速转一切众想。得清净无上无所著智。佛子。菩萨摩诃萨。有十种平等心。何等为十。所谓长养一切功德平等心。一切语言法平等心。于一切众生平等心。于一切众生业报平等心。入一切法平等心。于一切净秽佛刹平等心。于一切众生性若好若丑平等心。于一切行无所选择平等心。入一切如来力无所畏平等心。入一切如来智慧平等心。佛子。是为菩萨摩诃萨十种平等心。若菩萨摩诃萨安住此心。则得如来无上平等心。佛子。菩萨摩诃萨。有十种出生智慧。何等为十。所谓入一切众生性出生智慧。入一切佛刹无一无异出生智慧。入分别十方一切世界网出生智慧。入一切俯仰翻覆世界等出生智慧。巧方便入一切诸法无一无异出生智慧。入一切种种异身出生智慧。入一切世间颠倒惑网悉无所著出生智慧。入一切法究竟一乘出生智慧。入一切法界自在神力出生智慧。入三世一切众生诸佛种性常不断绝出生智慧。佛子。是为菩萨摩诃萨十种出生智慧。若菩萨摩诃萨安住此法。则得无尽法藏。佛子。菩萨摩诃萨。有十种变化。何等为十。所谓众生变化。身变化。佛刹变化。供养变化。音声变化。行愿变化。调伏成熟众生变化。菩提变化。说法变化。住持变化。佛子。是为菩萨摩诃萨十种变化。若菩萨摩诃萨安住此法。则得一切无上化法

佛子。菩萨摩诃萨。有十种持。何等为十。所谓佛持。法持。众生持。业持。愿持。行持。境界持。妙持。善持。智持。佛子。是为菩萨摩诃萨十种持。若菩萨摩诃萨安住此持。则于一切法得自在持。佛子。菩萨摩诃萨。有十种大正希望。何等为十。所谓菩萨摩诃萨发如是心。尽未来世一切诸佛出兴于世。我当随顺奉行悉令欢喜。得大正希望。彼一切如来应供等正觉。我当以无上恭敬供养而供养之。得大正希望。恭敬供养彼诸佛已。必当具足诲我正法。闻正法已。三世菩萨一切诸地所生功德。令我悉得。得大正希望。菩萨摩诃萨发如是心。我当于不可说不可说劫修菩萨行。常不离佛及诸菩萨。得大正希望。菩萨摩诃萨发如是心。我当正向菩提离一切畏。所谓不活畏。恶名畏。死畏。恶道畏。大众畏。如是等畏我当远离休息除灭。一切众魔外道不能坏我。得大正希望。菩萨摩诃萨发如是心。令一切众生究竟成就无上菩提。安住菩提。成菩提已。我当于彼佛所。尽其形寿修菩萨行。恭敬供养彼诸如来。彼诸如来灭度之后。我当悉取舍利起无量塔而供养之。受持守护彼诸佛法。得大正希望。菩萨摩诃萨发如是心。令十方一切世界。悉以无上庄严而庄严之。平等清净住持出生。神力自在六种震动。得大正希望。菩萨摩诃萨发如是心。令一切众生悉除疑惑。清净直心除灭烦恼。永闭恶道开善趣门。成就慧光照除痴闇。降伏众魔置安隐处。得大正希望。菩萨摩诃萨发如是心。无量无数劫。如来难值正法难闻。譬如优昙钵华。我欲见佛听受正法应念见闻。于彼佛所直心清净。离众谄曲舍幻伪法。常见诸佛一心恭敬。得大正希望。菩萨摩诃萨发如是心。我当击大法鼓。雨甘露法。作大法施。清净无畏大师子吼。满足大愿安住法界。于无量无数劫。常为众生讲说正法。安住大悲身口意业未曾疲厌。得大正希望。佛子。是为菩萨摩诃萨十种大正希望。若菩萨摩诃萨安住此法。则得无上智慧大正希望

佛子。菩萨摩诃萨有十种深入佛法。何等为十。所谓一切世界入过去世。是为第一深入佛法。一切世界入未来世。是为第二深入佛法。一切世界入现在世。所有世界数。世界行。世界说。世界清净。世界智。悉入现在世。是为第三深入佛法。一切世界悉分别入一切世界。是为第四深入佛法。悉分别入一切众生业报。是为第五深入佛法。悉分别入一切菩萨行。是为第六深入佛法。悉次第知过去一切如来。是为第七深入佛法。悉次第知未来一切诸佛出兴于世。是为第八深入佛法。悉知现在十方世界一切佛刹。佛及眷属说法教化。法界虚空界等众生。是为第九深入佛法。知世间法。知声闻缘觉菩萨法。知如来法。于彼诸法。无一无异。而说一异。于彼诸法。悉入法界。无所入故。如法相说。无所染着。是为第十深入佛法。佛子。是为菩萨摩诃萨十种深入佛法。若菩萨摩诃萨安住此法。则能深入阿耨多罗三藐三菩提甚深智慧。佛子。菩萨摩诃萨。有十种依止。菩萨依此行菩萨行。何等为十。所谓依善知识行菩萨行。依一切善根行菩萨行。依清净佛刹行菩萨行。依不舍一切众生行菩萨行。依深入一切波罗蜜行菩萨行。依一切菩萨满足诸愿行菩萨行。依无量菩提心行菩萨行。依一切诸佛菩提行菩萨行。佛子。是为菩萨摩诃萨十种依止。菩萨依此行菩萨行

佛子。菩萨摩诃萨。有十种发无畏心。何等为十。所谓灭一切业障发无畏心。佛灭度后受持守护正法发无畏心。降一切魔发无畏心。不惜身命发无畏心。如法调伏一切外道发无畏心。令一切众生皆悉欢喜发无畏心。令一切大众皆悉欢喜发无畏心。调伏一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽发无畏心。远离声闻缘觉地入甚深法发无畏心。于不可说不可说劫修菩萨行心无疲厌发无畏心。佛子。是为菩萨摩诃萨十种发无畏心。若菩萨摩诃萨安住此心。则得如来大智无所畏心。佛子。菩萨摩诃萨。有十种除灭一切疑惑发无疑心。何等为十。所谓菩萨摩诃萨发如是心。布施摄取一切众生。戒忍精进定慧慈悲喜舍摄取一切众生。不生疑惑。若生疑惑无有是处。是为第一除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。未来一切诸佛出兴于世。我当奉给恭敬供养。于彼不生疑惑。若生疑惑无有是处。是为第二除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。令一切世界。种种庄严。放大光明网。皆悉普照。于彼不生疑惑。若生疑惑无有是处。是为第三除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当尽未来际劫修菩萨行。无量无数。不可思议。不可称量。不可分齐。不可说不可说。一切算数所不能及。法界虚空界等众生。悉以无上教化调伏。成熟彼诸众生心无疲厌。于彼不生疑惑。若生疑惑无有是处。是为第四除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当成满诸愿。行菩萨行。出生一切智。安住一切智。于彼不生疑惑。若生疑惑无有是处。是为第五除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当为一切世间行菩萨行。作大灯明普照佛法。于彼不生疑惑。若生疑惑无有是处。是为第六除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当说一切法悉是佛法。随其所应化一切故。于彼不生疑惑。若生疑惑无有是处。是为第七除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当得无碍法门。除灭一切障碍。究竟逮得无上正觉。于彼不生疑惑。若生疑惑无有是处。是为第八除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当知一切世间法即是出世间法。断一切颠倒。以一庄严而自庄严。无所庄严。不由他悟。于彼不生疑惑。若生疑惑无有是处。是为第九除灭一切疑惑发无疑心。菩萨摩诃萨发如是心。我当成等正觉。得一切智。永灭一切颠倒疑惑。成一念智。无二智。无所有智。无碍智。无为智。无著智。不可说实际境界智。于彼不生疑惑。若生疑惑无有是处。是为第十除灭一切疑惑发无疑心。佛子。是为菩萨摩诃萨十种除灭一切疑惑发无疑心。若菩萨摩诃萨安住此法。则于一切佛法得无疑心

佛子。菩萨摩诃萨。有十种不可思议。何等为十。所谓一切善根不可思议。一切愿不可思议。解一切法如幻不可思议。发菩提心修菩萨行。善根无所依住。而亦不失无所染着。是为第四不可思议。深解一切法亦不灭度。一切诸愿未成满故。是为第五不可思议。行菩萨行。示现受胎出生。出家苦行。往诣道场。降伏众魔。成最正觉。转正法轮。于一切法而得自在。示现大般涅槃。而亦不舍大愿。大慈救护众生。是为第六不可思议。示现如来十力自在。而亦不舍法界等心。教化成熟一切众生。是为第七不可思议。解一切法无相有相。有相无相。非劫是劫。劫是非劫。非有是有。有是非有。非行是行。行是非行。非说是说。说是非说。是为第八不可思议。解发菩提心与菩提等。解菩提与发菩提心等。解初发菩提心及菩提与一切众生等。亦不生心颠倒。想颠倒。见颠倒。是为第九不可思议。于念念中入灭尽三昧正受。灭一切漏而不证实际。又亦不尽有漏善根。知一切法无漏。亦知漏灭尽。知一切佛法是世间法。于佛法中不取世间相。于世间法中不取佛法相。一切诸法悉入法界。无所入故。解一切法悉无二。不变易故。佛子。是为菩萨摩诃萨第十不可思议。若菩萨摩诃萨安住此法。则得如来不可思议法。佛子。菩萨摩诃萨。有十种巧方便微密语。何等为十。所谓于一切经典巧方便微密语。于一切受生处巧方便微密语。觉一切菩萨神力自在巧方便微密语。于一切众生业报巧方便微密语。于一切众生垢净起巧方便微密语。于一切法究竟无碍门巧方便微密语。于一切虚空界一一方面世界成坏无处不现巧方便微密语。于一切法界一切诸方乃至微细处现成等正觉如来充满一切法界乃至示现大般涅槃悉分别见巧方便微密语。解一切众生悉同涅槃无变易故而不舍大愿。乃至究竟满足一切智愿巧方便微密语。解一切法不由他悟而亦不离诸善知识恭敬如来随顺善知识修诸善根回向善根安住善根相续善根同一善根一道善根一成就善根巧方便微密语。佛子。是为菩萨摩诃萨十种巧方便微密语。若菩萨摩诃萨安住此法。则得如来无上巧方便微密语

大方广佛华严经卷第三十七大方广佛华严经卷第三十八

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之三

佛子。菩萨摩诃萨有十种巧方便分别智。何等为十。所谓入一切佛刹巧方便分别智。入一切众生处巧方便分别智。入一切众生心心所行巧方便分别智。入一切众生根巧方便分别智。入一切众生诸行业报巧方便分别智。入一切声闻行巧方便分别智。入一切缘觉行巧方便分别智。入一切菩萨行巧方便分别智。入一切世间法巧方便分别智。入一切佛法巧方便分别智。佛子。是为菩萨摩诃萨十种巧方便分别智。若菩萨摩诃萨。安住此法。则得一切诸佛无上巧方便分别智。佛子。菩萨摩诃萨有十种正受三昧。何等为十。所谓一切世界正受三昧。一切众生身正受三昧。一切法正受三昧。见一切诸佛正受三昧。善巧住持一切劫正受三昧。巧方便出生不可思议身正受三昧。一切如来身正受三昧。巧随顺觉一切众生平等正受三昧。于一念中正受一切菩萨三昧。于一念中以无碍智具足成就一切菩萨行不舍大愿善巧智慧正受三昧。佛子。是为菩萨摩诃萨十种正受三昧。若菩萨摩诃萨。安住此三昧。则得一切诸佛无上巧方便智正受三昧。佛子。菩萨摩诃萨。有十种一切处。何等为十。所谓一切众生处。一切佛刹处。一切众生性处。一切火灾处。一切水灾处。一切佛处。一切出生庄严处。一切如来无量功德处。一切分别说法处。一切如来种种供养处。佛子。是为菩萨摩诃萨十种一切处。若菩萨摩诃萨安住此处。则得如来无上一切大智处。佛子。菩萨摩诃萨。有十种法门。何等为十。所谓一身充满一切世界法门。示现一切世界种种无量色法门。一切世界入一佛刹法门。住持一切众生法门。如来庄严身充满一切世界法门。遍至一切世界法门。于一念中游行一切世界法门。于一佛刹示现一切如来出世法门。一身充满一切法界法门。于一念中示现一切诸佛神力法门。佛子。是为菩萨摩诃萨十种法门。若菩萨摩诃萨住此法门。则得如来无上法门。佛子。菩萨摩诃萨有十种神通。何等为十。所谓出生念宿命方便智通。出生无碍天耳方便智通。出生知一切众生不可思议心心数法方便智通。出生无碍天眼观察众生方便智通。出生不可思议自在神力示现众生方便智通。出生一身示现不可思议世界方便智通。出生于一念中往诣不可说世界方便智通。出生不可思议庄严具庄严一切世界方便智通。出生不可说不可说化身示现众生方便智通。出生不可说世界成阿耨多罗三藐三菩提不可思议示现众生方便智通。佛子。是为菩萨摩诃萨十种神通。若菩萨摩诃萨。安住此通。则得无上大方便智通。显现诸佛自在神力

佛子。菩萨摩诃萨。有十种明。何等为十。所谓出生知一切众生业报方便智明。出生知一切众生境界解脱寂灭净心方便智明。出生入一切境界一切众生种种决定一切法无所有金刚方便智明。出生不可思议净妙音声无量世界无不普闻方便智明。出生智慧除灭一切毁害染着方便智明。出生受生方便不受生方便方便智明。于一切境界转诸受想方便智明。知一切法无性无非性。无相无非相。一性无性故。而于无量劫种种说法。修习善根成阿耨多罗三藐三菩提方便智明。知一切众生生。亦知无生。知一切众生灭。亦知无灭。知因知缘。知事知境界知行。知生知灭。知众生说。知愚痴知离愚痴。知颠倒知非颠倒。知垢浊知清净。知生死知涅槃。知有知无。知着知不着。知坚固知离。知转知不转。知起知不起。知坏知道知成就知根。知众生受化。随器应故。教化众生。未曾忘失菩萨所行。何以故。菩萨摩诃萨发阿耨多罗三藐三菩提心。为教化众生故。是故菩萨摩诃萨。常化众生。而不失菩萨行。身无疲倦。不违一切众生。观察缘起方便智明。不着诸刹不起着心。不着诸佛不起着心。不着一切法不起着心。不着世界不起着心。不着众生不起着心。不见众生。不化众生。不调伏众生。不为众生说法。而亦不舍菩萨行愿。长养大悲。见一切佛。听受正法未曾忘失。得佛依果种诸善根。于如来所不舍恭敬供养之心。增长恭敬供养之心。具足成就法界等心。自在神力六种震动不可思议无量世界知种种说法。知众生数。知种种众生。知苦起知苦灭。知一切行苦。知一切行悉如电光。行菩萨行永断一切生死根本。悉能救护一切众生。行菩萨行无所染污。不断一切如来种性。发须弥山王心。不可倾动。除灭一切颠倒众想。一切智门悉现在前。不动不坏成等正觉。于生死海悉能济渡一切众生。方便智明。佛子。是为菩萨摩诃萨十种明。若菩萨摩诃萨安住此明。则得如来无上巧方便智明。佛子。菩萨摩诃萨。有十种解脱。何等为十。所谓烦恼解脱。邪见解脱。炽然解脱。阴界入解脱。超出声闻缘觉地解脱。无生法忍解脱。不着一切佛刹一切众生一切诸法。住无量无边诸菩萨住。离一切菩萨行。住如来地解脱。于一念中悉能了知一切三世诸法解脱。佛子。是为菩萨摩诃萨十种解脱。若菩萨摩诃萨住此解脱。则能普为一切众生。而作无上佛事

佛子。菩萨摩诃萨。有十种园林。何等为十。所谓生死园林。行菩萨行不起忧恼故。教化众生园林。不厌众生故。一切劫园林。摄取菩萨一切大行故。清净世界园林。性无著故。一切魔宫殿园林。降魔境界故。听受正法园林。正念观察故。六波罗蜜四摄法三十七道品园林。修习慈父境界故。十力四无所畏乃至一切佛法园林。不念异法故。菩萨示现一切无量无边功德神力园林。转净法轮调伏众生故。于念念中为一切众生现成正觉园林。法身如虚空充满一切世界平等觉故。佛子。是为菩萨摩诃萨十种园林。若菩萨摩诃萨住此园林。则得如来无上离忧快乐园林。佛子。菩萨摩诃萨。有十种宫殿。何等为十。所谓发菩提心宫殿。不忘失故。十善业迹功德智慧宫殿。教化成熟欲界众生故。四梵住处宫殿。教化成熟色界众生故。净居天受生宫殿。一切烦恼不能染故。无色界天受生宫殿。除灭众生障难处故。降生不净世界宫殿。欲令众生断一切烦恼故。现处深宫采女妻子色味宫殿。教化成熟本同行众生故。现为四天下王四大天王帝释梵王宫殿。为调伏自在心众生故。一切菩萨神力自在命行宫殿。一切诸禅解脱三昧智慧自在故。于诸佛所受无上自在一切智王记宫殿。十力庄严行一切法自在法王事故。佛子。是为菩萨摩诃萨十种宫殿。若菩萨摩诃萨安住此法。则得一切法王受记自在法。佛子。菩萨摩诃萨有十种乐。何等为十。所谓乐寂静。不散乱故。乐明慧。善分别法故。乐往诣一切佛所。现前闻法受持故。乐一切佛。充满十方故。乐菩萨自在神力。无量法门示现众生身故。乐三昧。于一三昧门。出生一切三昧门故。乐陀罗尼门。持一切法。教化众生。不忘失故。乐辩才。于一句身味身不可说劫说无穷尽故。乐菩提。以无量法门。现众生等身。成正觉故。乐转法轮。如法调伏一切外道故。佛子。是为菩萨摩诃萨十种乐。若菩萨摩诃萨。安住此乐。则得一切诸佛无上法乐。佛子。菩萨摩诃萨。有十种庄严。何等为十。所谓力庄严。不可坏故。无畏庄严。不生恐怖故。义庄严。说不可说义法门无穷尽故。法庄严。说八万四千法藏不忘失故。愿庄严。一切菩萨愿事不退转故。行庄严。究竟普贤菩萨行故。佛刹庄严。受持一切佛刹为一佛刹故。妙音庄严。雨大甘露法。充满一切佛刹故。受持庄严。于一切劫。行菩萨行。不断绝故。变化庄严。于一众生身。示现一切众生等身。一切众生无不知见。专求十力一切智不退转故。佛子。是为菩萨摩诃萨十种庄严。若菩萨摩诃萨。安住此法。则得一切诸佛无上庄严。佛子。菩萨摩诃萨有十种发不动心。何等为十。所谓一切所有皆悉能舍发不动心。出生一切诸佛正法发不动心。恭敬供养一切诸佛发不动心。等心观察一切众生发不动心。摄取一切众生发不动心。一向专求一切佛法未曾休息发不动心。一切众生等劫修菩萨行发不动心。成就有根信不浊信离垢信明净信恭敬供养一切佛信不退转信不坏信发不动心。具足成就究竟一切智发不动心。成就一切菩萨诸行发不动心。佛子。是为菩萨摩诃萨十种发不动心。若菩萨摩诃萨。安住此法。则得无上一切智不动心。佛子。菩萨摩诃萨。有十种不舍深心。何等为十。所谓觉一切佛菩提不舍深心。教化成熟一切众生不舍深心。不断一切诸佛种性不舍深心。亲近善知识不舍深心。于一切佛刹恭敬供养一切诸佛不舍深心。专求大乘及一切功德不舍深心。于一切佛所修行梵行护持净戒不舍深心。摄取一切菩萨不舍深心。闻持一切佛法不舍深心。修习一切菩萨行愿一向专求一切佛法不舍深心。佛子。是为菩萨摩诃萨十种不舍深心。若菩萨摩诃萨安住此法。则得一切诸佛不舍深心正法。佛子。菩萨摩诃萨有十种智观察。何等为十。所谓智慧观察善巧分别一切诸法。智慧观察三世一切善根。智慧观察一切菩萨行神力自在。智慧观察一切诸法巧方便门。智慧观察一切佛持。智慧观察一切陀罗尼门。智慧观察一切世界常说正法。智慧观察深入一切法界。智慧观察十方一切世界不可思议。智慧观察一切佛法。智慧观察无障碍智。佛子。是为菩萨摩诃萨十种智观察。若菩萨摩诃萨安住此法。则得如来无上大智观察。佛子。菩萨摩诃萨有十种分别法。何等为十。所谓分别一切法悉从缘起。分别一切法皆悉如幻。分别一切法皆悉无诤。分别一切法无量无边。分别一切法无所依止。分别一切法悉如金刚。分别一切法悉是如来。分别一切法皆悉寂静。分别一切法悉是正道。分别一切法悉是一相一义。佛子。是为菩萨摩诃萨十种分别法。若菩萨摩诃萨。安住此法。则得巧方便。悉能分别一切诸法。佛子。菩萨摩诃萨有十种无垢。何等为十。所谓深心无垢。除灭疑惑无垢。远离邪见无垢。境界无垢。欲得一切智无垢。诸辩无垢。无畏无垢。一切菩萨所住无垢。一切菩萨正受三昧无垢。三十二相百福庄严成就一切诸白净法究竟逮得无上菩提无垢。佛子。是为菩萨摩诃萨十种无垢。若菩萨摩诃萨安住此法。则得一切佛无上无垢法。佛子。菩萨摩诃萨。有十种智印。何等为十。所谓菩萨摩诃萨知苦苦。变易苦。行苦。不生懈怠修菩萨行。一向专求无上菩提。不恐不怖不惊不畏。不舍大愿菩提之心。坚固不退究竟阿耨多罗三藐三菩提。是为第一印。一切凡夫众生悉有烦恼颠倒惑乱。彼诸众生粗鄙恶言诃骂菩萨。或以刀杖瓦石而加害之。菩萨尔时心无忧恼。修菩萨行正向菩提。修习忍法受证离生。是为第二印。菩萨摩诃萨。闻甚深佛法赞一切智。闻已一向信解。是为第三印。菩萨摩诃萨。作如是念。我发菩提心。究竟成就阿耨多罗三藐三菩提。一切众生流转五道受无量苦。我当令彼皆大欢喜。勤行精进修习善根。度生死流永得安乐。是为第四印。菩萨摩诃萨。解如来智无量无边。而未与如来等。于如来所闻无量无边智。于文字中。分别解了与如来等。是为第五印。菩萨摩诃萨成就善欲。不可坏欲。甚深欲。胜欲。功德欲。庄严欲。无比欲。无上欲。坚固欲。究竟正求无上菩提一切众魔外道及其眷属不能坏欲。不退无上菩提欲。是为第六印。菩萨摩诃萨不惜身命无所怖畏。修菩萨行发菩提心趣一切智。得一切佛智慧光明。不舍佛菩提。不舍善知识。是为第七印。菩萨摩诃萨。若善男子善女人。学大乘者。长养诸佛善根。安住善根。摄取一切智。心不退菩提。是为第八印。菩萨摩诃萨令一切众生。住平等心。修一切智。为众生说法。悉令不退无上菩提。长养大悲。是为第九印。菩萨摩诃萨。随顺三世诸佛一切善根。绍继佛种生一切智。是为第十印。佛子。是为菩萨摩诃萨十种智印。若菩萨摩诃萨。成就此印。疾得阿耨多罗三藐三菩提。具足如来无上智印。佛子。菩萨摩诃萨。有十种智慧光明。何等为十。所谓菩萨摩诃萨。于阿耨多罗三藐三菩提决定智慧光明。见一切佛智慧光明。见一切众生死此生彼智慧光明。开悟一切众生。悉令正求修多罗法智慧光明。依善知识。发菩提心。长养善根智慧光明。示现一切诸佛智慧光明。化一切众生。悉令成熟安住佛地智慧光明。分别解说不思议法智慧光明。于一切佛神力住持善巧方便智慧光明。满足一切波罗蜜智慧光明。佛子。是为菩萨摩诃萨十种智慧光明。若菩萨摩诃萨安住此法。则得一切佛法无上智慧光明。佛子。菩萨摩诃萨。有十种不可称量住。一切众生及声闻缘觉不能称量。何等为十。所谓菩萨摩诃萨。住实际住而不受证一切所愿未成满故。是为第一菩萨住不可称量。菩萨摩诃萨。种如法界等清净善根。于彼善根无所染着。是为第二菩萨住不可称量。菩萨摩诃萨。解菩萨行犹如变化。一切诸法皆悉寂灭。于诸佛法不生疑惑。是为第三菩萨住不可称量。菩萨摩诃萨。离生死心。于不可说劫修菩萨行。满一切大愿。而不中起厌怠之心。是为第四菩萨住不可称量。菩萨摩诃萨。住一切法无所依止。皆悉寂灭而不证涅槃。一切智道未成满故。是为第五菩萨住不可称量。菩萨摩诃萨。知一切劫非劫。而实说一切劫。是为第六菩萨住不可称量。菩萨摩诃萨。知一切法非行。而不舍道行正求佛法。是为第七菩萨住不可称量。菩萨摩诃萨。解心是三界心是三世。了知彼心无量无边。是为第八菩萨住不可称量。菩萨摩诃萨。为一众生故。于不可说劫修菩萨行。欲令安住一切智地。如一众生。一切众生亦复如是。不生厌心。是为第九菩萨住不可称量。菩萨摩诃萨。虽具足满菩萨诸行。而不取正觉。何以故。菩萨摩诃萨。作如是念。我不受正觉故行菩萨行。于无量劫中。无量众生。悉令安住无上菩提。是为第十菩萨住不可称量。若菩萨摩诃萨。安住此法。则得一切佛法无上大智不可称量住。佛子。菩萨摩诃萨。有十种发无懈怠心。何等为十。所谓菩萨摩诃萨。作如是念。我降伏一切魔及其眷属。发无懈怠心。如法调伏一切外道。发无懈怠心。说深妙法令一切众生皆悉欢喜。发无懈怠心。满足一切法界等诸波罗蜜。发无懈怠心。令一切众生积集成满一切功德藏。发无懈怠心。一切如来无上菩提。弥广大事甚难成满。我当修菩萨行具足成就。发无懈怠心。以无上法教化调伏一切众生。悉令成熟。发无懈怠心。于一切世界种种异色无量庄严成就正觉。发无懈怠心。菩萨摩诃萨。发如是心。我修菩萨行时。若有众生来求我身。或求手足耳鼻血肉。骨髓妻子象马国土。如是等类皆悉能舍。乃至不生一念悔心。悉能惠施。饶益安乐一切众生。不求果报。大慈悲心以为上首。发无懈怠心。菩萨摩诃萨。作如是念。于一念中。三世一切佛。一切佛法。一切众生。一切刹。一切世界。一切空界。一切法界。一切施设语界。一切寂灭涅槃界。如是等一切诸法。以一念相应慧。悉别相觉知。明了修。分别修。知智断证。于一切法不取虚妄。无一无异无所分别无所修习。无境界无所有。无二智慧。觉一切二。无相智慧。觉一切相。无劫智慧。觉一切劫。无异智慧。觉一切异。光明智慧。觉一切世间光明界。趣智慧。觉一切世界。非世智慧。觉一切世。众生地智慧。觉一切众生界。无著智慧。究竟无著行。无坚固智慧。觉一切坚固无染智慧。觉一切烦恼。无尽际智慧。觉一切尽。法界等智慧。于一切世界示现其身。离一切言音智慧。出生一切微妙言音。一性智慧。说无性法。一境智慧。示现种种诸异境界。觉不可说诸法智慧。示现无量大自在神变。觉一切地智慧。显现大自在神变。一切智自在神变。教化成熟一切众生。发无懈怠心。佛子。是为菩萨摩诃萨十种发无懈怠心。若菩萨摩诃萨安住此心。则得一切诸佛无上无懈怠法。佛子。菩萨摩诃萨。有十种须弥山王正直之心。何等为十。所谓菩萨摩诃萨。常修正念一切智法。是为第一决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。观察一切法空。一切法无所有。是为第二决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。于无量无数劫。行菩萨行。以一切具足白净法。发心决定。了知如来无量智法。趣向积聚诸白净法。是为第三决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。为一切佛法等心。恭敬供养诸善知识。不起疑心不求利养。又复远离盗法之心。但起无上恭敬供养一切施心。是为第四决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。若一切众生诃责骂辱。生一切苦。乃至夺命。菩萨摩诃萨。不因此故舍菩提心。心亦不散。不生恚心。于一切众生不舍大悲庄严。长养大悲。何以故。菩萨摩诃萨。成就一切法如如舍故。决定了知如来大忍法故。是为第五决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。成就增上功德。天增上功德。人增上功德。色增上功德。力增上。眷属增上。欲增上。王法增上。自在增上。智慧。彼菩萨不着味乐。不着欲乐。不着财乐。不着眷属乐。但专求正法谛满正法谛辨正法。究竟正法。向正法灯明。向正法救护。向正法归依。向正法道。向正法义。乐求正法乐住寂静法。菩萨摩诃萨。虽成就如是一切快乐。而悉远离众魔境界。何以故。菩萨摩诃萨。于过去世发如是心。令一切众生。皆悉远离众魔境界。住佛境界。是为第六决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。勤修精进。正求阿耨多罗三藐三菩提。于阿僧祇劫修菩萨行。犹谓我今初发阿耨多罗三藐三菩提心。亦不惊不怖不畏。行菩萨行虽能速成正觉。为化众生故。于无量劫修菩萨行。是为第七决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。知一切众生难伏难度。不知恩不知报恩。为彼众生故。发大庄严而自庄严。欲令一切众生。心得自在随意境界。不生恶心。不于他所生烦恼心。是为第八决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。作如是念。我不依他发菩提心修菩萨行。都无有人助我修习菩萨之行。但我一身尽未来际劫修菩萨苦行。积集一切诸佛正法。成阿耨多罗三藐三菩提。身自清净。亦令一切众生清净。自知境界知他境界。我当悉同三世诸佛境界。是为第九决定阿耨多罗三藐三菩提须弥山王正直之心。菩萨摩诃萨。如是知见。无有一法修菩萨行。无有一法满菩萨行。无有一法调伏众生。无有一法化度众生。不见有法恭敬供养一切诸佛。不见有法过去成阿耨多罗三藐三菩提。不见有法未来成阿耨多罗三藐三菩提。不见有法现在成阿耨多罗三藐三菩提。无有一法过去说法未来说法现在说法。无有一法能说法者亦无法可说。而菩萨摩诃萨。不舍阿耨多罗三藐三菩提大愿之心。何以故。菩萨摩诃萨。如是出生阿耨多罗三藐三菩提。深入一切甚深诸法行。无所有行。而此菩萨摩诃萨。修习积聚善业善根。清净一切诸对治法。智慧成满。于念念中悉能积集长养一切诸善根法。若一切法无所有者。我有何义求无上道。是故不生恐怖惊畏之心。是为第十决定阿耨多罗三藐三菩提须弥山王正直之心。佛子。是为菩萨摩诃萨十种须弥山王正直之心。若菩萨摩诃萨。安住此心。则得一切诸佛无上智慧须弥山王正直之心

佛子。菩萨摩诃萨。有十种深入智慧大海。成阿耨多罗三藐三菩提。何等为十。所谓入无量一切众生界。是为第一深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。入一切世界不取虚妄。是为第二深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。知一切虚空界等入十方一切世界。无所障碍。是为第三深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。善入法界。入无碍。入不断。入不常。入无量。入不生。入不灭。入知一切。是为第四深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。于过去未来现在诸佛菩萨法师声闻缘觉。及一切众生所种善根。过去诸佛已成无上菩提善根。未来诸佛当成无上菩提善根。现在诸佛今成无上菩提善根。过去诸佛说法教化调伏成熟众生善根。未来诸佛说法教化调伏成熟众生善根。现在诸佛说法教化调伏成熟众生善根。菩萨摩诃萨。皆悉随喜。长养积集如是等一切善根。心无厌足。是为第五深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。于念念中入过去世。观察不可说劫。于一劫中。或百亿佛出兴于世。或千亿佛。百千亿佛。无量佛。阿僧祇佛。不可思议佛。不可称量佛。无分齐佛。无边际佛。不可说。不可说佛。算数譬谕所不及佛。出兴于世。彼诸如来。及其眷属菩萨大众。诸声闻僧。说法教化。寿命住持。种种法住。如一劫中。一切诸劫亦复如是。若无佛劫中。有诸众生。为阿耨多罗三藐三菩提所种善根。亦悉了知。又睹众生种见佛善根。得值未来无量诸佛。如是观察过去一切劫。而无厌足。是为第六深入智慧大海。成阿耨多罗三藐三菩提。菩萨摩诃萨。入未来世观察一切劫。知劫有佛知劫无佛。知彼诸劫各有几佛出兴于世。世界如来名号何等。又知所度众生多少。亦知如来寿命长短。如是入未来世一切诸劫。分别了知而无厌足。是为第七深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。入现在世。观察十方一切世界。无量无边不可说不可说诸世界中。一切如来舍家学道往诣道场。菩提树下藉菩提草结跏趺坐。降魔官属。成阿耨多罗三藐三菩提已。起入城邑升天宫殿。说微妙法转正法轮。调伏教化无量众生。现如来无量自在神力。付属阿耨多罗三藐三菩提。乃至舍寿入无余涅槃。如来灭后。大众普会结集经藏。护持正法令久住世。为舍利故起无量塔。种种庄严恭敬供养。又化众生。令见诸佛听受正法。忆念护持智慧观察。长养胜趣深心。充满无量法界。于一切佛法而无错谬。何以故。菩萨摩诃萨。知一切如来皆悉如梦。而能往诣一切佛所。恭敬供养。不着自身。不着佛身。不着世界不着大众。不著闻法不着诸劫。见佛闻法观察世界。解一切劫而无厌足。是为第八深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。于不可说不可说劫。恭敬供养无量诸佛。于一一劫中。恭敬供养不可说不可说佛。示现没此生彼。以出三界众供养具。供养诸佛菩萨大众及声闻僧。诸佛灭后。以无上供具供养舍利。广行大施。满足一切众生意愿所行。大施不可思议。不求果报。为哀愍饶益摄取众生。于不可说不可说劫。恭敬供养一切诸佛。护持正法化度众生。成阿耨多罗三藐三菩提。而无厌足。是为第九深入智慧大海成阿耨多罗三藐三菩提。菩萨摩诃萨。于一切佛所。一切菩萨所。一切法师所。一向专求教菩萨法。菩萨威仪。菩萨随顺法。菩萨清净法。菩萨长养法。菩萨调伏法。菩萨平等法。菩萨出生道。受持菩萨陀罗尼门。摄取一切众生。而为说法调伏成熟。令不可说不可说众生。发一切智心。得不退转。住阿耨多罗三藐三菩提。随顺修习一切佛法。教化众生而无厌足。是为第十深入智慧大海成阿耨多罗三藐三菩提。佛子。是为菩萨摩诃萨十种深入智慧大海成阿耨多罗三藐三菩提。若菩萨摩诃萨。安住此法。则得一切诸佛无上智慧大海

大方广佛华严经卷第三十八大方广佛华严经卷第三十九

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之四

佛子。菩萨摩诃萨。有十种宝住成阿耨多罗三藐三菩提。何等为十。所谓菩萨摩诃萨。悉能往诣无量阿僧祇世界诸如来所。恭敬礼拜亲近供养。是为菩萨摩诃萨第一宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。于不可思议诸如来所。闻法受持正念不忘。智慧分别长养胜趣。出生智慧充满十方。是为菩萨摩诃萨第二宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。不离此土而于异刹示现受生。于一切佛法心不惑乱。是为菩萨摩诃萨第三宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。出生一法别相。分别知一切法。一切诸法究竟无一无异义故。是为菩萨摩诃萨第四宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。知息烦恼知离烦恼知断烦恼。而善住修习菩萨诸行。不证实际。究竟到于实际彼岸。善学成就巧妙方便。本愿成满心无疲厌。是为菩萨摩诃萨第五宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。知一切众生心无处所。而说众生心有处所。无著无行。修菩萨行化度众生。是为菩萨摩诃萨第六宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。知一切法一性。所谓无性。无一无异无来无去。不可称量不可赞叹。悉无实性。以一异求皆不可得。而菩萨摩诃萨。决定了知此是佛法。是菩萨法是缘觉法是声闻法是凡夫法。是善法是不善法。是世间法是出世间法。是染污法是不染污法。是有漏法是无漏法。乃至是有为法是无为法。是为菩萨摩诃萨第七宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。求佛不可得。求菩萨不可得。求法不可得。求众生不可得。而亦不舍本愿。教化一切众生。成无上道。何以故。菩萨所修善根。欲令一切成无上道。善知众生善根。善知众生境界。善知教化众生。善知一切众生涅槃。修菩萨行。欲令一切大愿成满。是为菩萨摩诃萨第八宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。随其所应。善巧说法而调伏之。巧妙方便示现涅槃。知实非虚亦非颠倒。而安住三世菩萨正法。不离如如不住实际。亦不见众生。亦不见众生已受化今受化当受化。解我所行非为虚妄。解了无有乃至一法可求得者。无生灭故。而菩萨所愿皆悉不虚。无所依止。是为菩萨摩诃萨第九宝住成阿耨多罗三藐三菩提。菩萨摩诃萨。于不可思议诸佛。一一佛所。闻不可说不可说受记法。名号各异劫数不同。从一劫中次第闻法。乃至不可说不可说劫闻受记法。闻是法已。不惊不怖不畏。行菩萨行心无疑惑。解如来智不可思议。如来所说言无有二。本愿满足随应受化。令成阿耨多罗三藐三菩提。满一切愿了达法界。是为菩萨摩诃萨第十宝住成阿耨多罗三藐三菩提。若菩萨摩诃萨。安住此法。则得一切诸佛阿耨多罗三藐三菩提大智慧宝

佛子。菩萨摩诃萨。有十种发金刚心庄严大乘。何等为十。所谓菩萨摩诃萨。作如是念。一切诸法无有分际。不可究竟。菩萨发如是心。我当觉了三世一切诸法。悉无有余。是为菩萨摩诃萨第一发金刚心庄严大乘。菩萨摩诃萨。作如是念。于一毛端处。有无量无边不可数菩萨。何况一切法界耶。菩萨发如是心。我当发大庄严而自庄严。化度众生。皆令成阿耨多罗三藐三菩提。以大般涅槃而般涅槃。是为菩萨摩诃萨第二发金刚心庄严大乘。菩萨摩诃萨。作如是念十方世界无量无边无有分际。菩萨发如是大愿。我当以无上清净庄严。庄严此等一切世界。彼诸庄严皆实不虚。是为菩萨摩诃萨第三发金刚心庄严大乘。菩萨摩诃萨。作如是念。众生无量无边无有分际。不可穷尽。菩萨发如是心。我当以诸善根回向一切众生。以无上大智慧光。普照一切众生。是为菩萨摩诃萨第四发金刚心庄严大乘。菩萨摩诃萨。作如是念。一切诸佛无量无边不可穷尽。菩萨发如是心。我所种善根回向奉给供养一切诸佛。然后我乃成等正觉。是为菩萨摩诃萨第五发金刚心庄严大乘。菩萨摩诃萨。见一切佛。闻所说法。发大欢喜心。不着自身及如来身。解知佛身非实非虚。非有非无。非有性非无性。非色非无色。非相非无相。非生非灭。解知如来实无所有。亦不坏有相。何以故。一切摄取故。是为菩萨摩诃萨第六发金刚心庄严大乘。菩萨摩诃萨。若有众生诃骂毁辱。或截手足耳鼻。或挑其目或级其头。菩萨不因此故生恚害心。于不可说不可说劫。修菩萨行。摄取众生心不废舍。何以故。菩萨摩诃萨。住不二法。善学菩萨所学清净直心。于一切众生无嗔恚心。忍住众苦心无加报。自身堪受一切众苦。是为菩萨摩诃萨第七发金刚心庄严大乘。菩萨摩诃萨。作如是念。未来世劫无量无边。无有分际不可穷尽。菩萨发如是心。我当尽一切未来世法界虚空界等劫。于一世界行菩萨道教化众生。如一世界。尽法界虚空界等一切世界。亦复如是。心亦不惊不怖不畏。行菩萨行。何以故。菩萨法应如是。为一切众生修菩萨行。是为菩萨摩诃萨第八发金刚心庄严大乘。菩萨摩诃萨。作如是念。阿耨多罗三藐三菩提。以心为本。心清净故。能积集成满一切善根。若心得自在。则能成就无上菩提。行菩萨行满足诸愿。究竟教化一切众生。是为菩萨摩诃萨第九发金刚心庄严大乘。菩萨摩诃萨。知佛不可得。菩提不可得。菩萨不可得。一切法不可得。众生不可得。心不可得。行不可得。过去不可得。未来现在不可得。一切众生不可得。有为无为不可得。菩萨摩诃萨。如是住寂静。住甚深。住寂灭。住无诤。住不可言。住无二。住无等。住真实。住成就。住解脱。住涅槃。住实际。而亦不舍一切大愿。不舍发一切智心。不舍修菩萨行。不舍教化众生。不舍恭敬供养诸佛。不舍说法。不舍庄严一切世界。何以故。菩萨摩诃萨。出生大愿故。善知如是法相。长养大悲无量功德。摄取众生。不舍众生。一切诸法无有真实。凡愚众生不知不觉。一切诸佛安住寂灭。演说正法教化众生。不舍大悲。一切众生。未得菩提。佛法未足。大愿未满。我本请一切众生。为无上大法施主。唱实语不虚语。一切诸佛种姓语。发大愿门心。发饶益一切众生心。发长养一切善根心。发安住善巧方便心。发内身含受一切众生心。发一切众生所平等心。令一切众生所愿成满。我当云何未度众生而舍大悲。是为菩萨摩诃萨第十发金刚心庄严大乘。佛子。是为菩萨摩诃萨十种发金刚心庄严大乘。若菩萨摩诃萨。安住此法。则得一切诸佛无上金刚智明。佛子。菩萨摩诃萨。有十种发大事。何等为十。所谓恭敬供养一切诸佛。是为菩萨摩诃萨第一发大事。长养一切菩萨善根。是为菩萨摩诃萨第二发大事。一切如来灭度之后。悉取舍利起无量塔。种种妙宝以为庄严。以一切华一切鬘。一切香一切涂香一切末香。一切衣一切盖。一切幢一切幡。而供养之。受持守护诸佛正法。是为菩萨摩诃萨第三发大事。教化成熟一切众生。令得阿耨多罗三藐三菩提。是为菩萨摩诃萨第四发大事。以诸佛刹无上清净庄严。庄严一切世界。是为菩萨摩诃萨第五发大事。菩萨摩诃萨。作如是念。我当为一众生。于一一世界尽未来际阿僧祇劫修菩萨行。如为一众生。为一切众生。亦复如是。出生大悲。令一切众生安住菩提。乃至不生一念疲厌之心。是为菩萨摩诃萨第六发大事。我当于不可思议阿僧祇劫。恭敬供养彼诸如来。是为菩萨摩诃萨第七发大事。彼诸如来灭度之后。我当悉取舍利而起塔庙。其塔高广。与不可说诸世界等。造如来像。巍巍高大。如不可思议世界。于不可思议劫。以众妙宝幢幡缯盖华香而供养之。乃至不生一念休息之心。教化众生。受持守护赞叹正法。亦无一念休息之心。是为菩萨摩诃萨第八发大事。修习彼诸善根。成阿耨多罗三藐三菩提。悉与一切诸如来等。逮得一切诸如来地。是为菩萨摩诃萨第九发大事。我成菩提已。于一切世界不可说劫。说微妙法。示现如来不可思议自在神变。其身口意未曾暂生疲厌之想。但发专念正法之心。如来力心。充满一切众生愿心。大慈悲心。观察诸法真实之心。安住实语证寂灭法。一切众生悉不可得。而亦不违一切诸业。随顺三世一切诸佛。究竟一切法界虚空界。观察诸法无所有相。不生不灭。具足成就一切诸佛无上大愿。施作一切诸佛大事。悉能化度一切众生。是为菩萨摩诃萨第十发大事。佛子。是为菩萨摩诃萨十种发大事。若菩萨摩诃萨。安住此法。则得一切诸佛无上智慧。不断一切菩萨所行。佛子。菩萨摩诃萨。有十种究竟大事。何等为十。所谓恭敬供养一切如来。究竟大事。随所请众生皆悉度脱。究竟大事。专求一切诸佛正法。究竟大事。长养一切善根。究竟大事。出生一切诸如来法。究竟大事。成满一切清净大愿。究竟大事。行一切菩萨行。究竟大事。恭敬奉事一切善知识。究竟大事。往诣一切世界佛所。究竟大事。闻持一切诸佛正法。深入一切诸佛大众。究竟大事。佛子。是为菩萨摩诃萨十种究竟大事。若菩萨摩诃萨。安住此法则得阿耨多罗三藐三菩提究竟智慧大事。佛子。菩萨摩诃萨。有十种不坏信。何等为十。所谓于一切佛不坏信。于一切佛法不坏信。于一切圣僧不坏信。于一切菩萨不坏信。于一切善知识不坏信。于一切众生不坏信。于一切菩萨大愿不坏信。于一切菩萨行不坏信。恭敬供养一切诸佛不坏信。教化一切众生成就菩萨巧妙方便不坏信。佛子。是为菩萨摩诃萨十种不坏信。若菩萨摩诃萨。安住此法。则得一切诸佛无上智慧不可坏信。佛子。菩萨摩诃萨。有十种授记。何等为十。所谓专求解脱菩萨授记。谛满谛辩菩萨善根菩萨授记。广行菩萨无量诸行菩萨授记。现前菩萨授记。秘密菩萨授记。因自心得菩提菩萨授记。得法忍菩萨授记。教化成熟众生菩萨授记。究竟一切劫菩萨授记。一切菩萨自在修行菩萨授记。佛子。是为菩萨摩诃萨十种授记。若菩萨摩诃萨。安住此法。则于一切佛所而得授记。佛子。菩萨摩诃萨。有十种善根回向。何等为十。所谓一切善根回向同善知识愿。一切善根回向同善知识正直心。一切善根回向同善知识行。一切善根回向同善知识善根。一切善根回向随顺善知识善根。一切善根回向同善知识正念。一切善根回向同善知识清净。一切善根回向同善知识住。一切善根回向同善知识入成满平等。一切善根回向同善知识不坏深心。若如是同则无异同。佛子。是为菩萨摩诃萨十种善根回向。若菩萨摩诃萨。安住此法。则得一切无上善根回向。佛子。菩萨摩诃萨。有十种得智慧。何等为十。所谓于一切施自在智慧。乐一切佛法解脱自在智慧。深入一切如来无量无边自在智慧。随问能答灭一切疑自在智慧。深解实义自在智慧。解一切如来巧妙方便深入一切诸佛解脱自在智慧。解一切佛所种少善根。必能满足一切白净善根出生如来一切智自在智慧。具足成就菩萨不思议住自在智慧。于一念中悉能往诣不可说佛所自在智慧。觉悟一切诸佛菩提深入一切法界闻持一切佛法深入一切如来庄严语言自在智慧。佛子。是为菩萨摩诃萨十种得智慧。若菩萨摩诃萨。安住此法。则得一切如来无上自在智慧。佛子。菩萨摩诃萨。有十种发无量无边广心。何等为十。所谓发无量无边广心于一切佛。发无量无边广心度脱一切众生。发无量无边广心令一切众生一切世一切刹悉入法界。发无量无边广心观一切法悉如虚空。发无量无边广心观察一切菩萨诸行。发无量无边广心正念三世一切诸佛。发无量无边广心了达不可思议诸业果报。发无量无边广心严净一切诸如来刹。发无量无边广心深入一切如来大众。发无量无边广心观察一切如来妙音。佛子。是为菩萨摩诃萨十种发无量无边广心。若菩萨摩诃萨。安住此心。则得一切佛法无量无边智慧大海。佛子。菩萨摩诃萨。有十种藏。何等为十。所谓分别数知一切法藏。出生一切法藏。普照一切陀罗尼法藏。分别解说一切法辩藏。于一切法觉不可说巧方便藏。示现一切佛自在力大神变藏。于一切法出生平等巧方便藏。不离常见一切佛藏。入不思议劫皆悉如幻巧方便藏。于一切诸佛菩萨欢喜恭敬藏。佛子。是为菩萨摩诃萨十种藏。若菩萨摩诃萨。安住此藏。则得一切诸佛大智慧藏。悉能度脱一切众生。佛子。菩萨摩诃萨。有十种调顺。何等为十。所谓不谤一切佛法调顺。于一切佛信不可坏调顺。尊重恭敬一切菩萨调顺。亲近一切善知识调顺。远离一切声闻缘觉调顺。长养菩萨一切三昧调顺。平等观察一切众生调顺。究竟成满一切善根调顺。悉能降伏一切诸魔调顺。成满一切波罗蜜调顺。佛子。是为菩萨摩诃萨十种调顺。若菩萨摩诃萨。安住此法。则得无上大智调顺

佛子。菩萨摩诃萨。有十种自在。何等为十。所谓寿命自在。无量无边不可说劫住持寿命故。心自在。出生阿僧祇三昧入深智故。庄严自在。以大庄严悉能庄严一切刹故。业自在。随时受报故。受生自在。于一切刹示现生故。解脱自在。见一切世界诸佛充满故。愿自在。随时随刹成菩提故。神力自在。示现一切大神变故。法自在。示现无量无边法门故。智自在。于念念中。示现觉悟如来十力无所畏故。佛子。是为菩萨摩诃萨十种自在。若菩萨摩诃萨。安住此法则得一切诸佛菩萨究竟成满一切智自在。佛子。菩萨摩诃萨。有十种自在。何等为十。所谓众生自在。刹自在。法自在。身自在。愿自在。境界自在。智自在。通自在。神力自在。力自在。佛子。是为菩萨摩诃萨十种自在。佛子。何等为菩萨摩诃萨众生自在。佛子。菩萨摩诃萨。有十种众生自在。何等为十。所谓度脱一切众生自在。持一切众生想自在。为一切众生说法未曾失时自在。变化一切众生自在。安置一切众生于一毛道而不迫迮自在。于一切世界一切众生中示现为王自在。于一切众生中示现帝释梵王自在。于一切众生中示现声闻缘觉不转威仪自在。于一切众生中示现行菩萨行自在。于一切众生中示现佛身相好庄严觉悟一切智力自在。佛子。是为菩萨摩诃萨十种众生自在。佛子。菩萨摩诃萨。有十种刹自在。何等为十。所谓令一切刹为一刹自在。令一切刹入一毛道自在。于一切刹深入无尽方便自在。于一切刹示现一身结跏趺坐充满自在。令一切刹现入己身自在。神力震动一切佛刹不令众生恐怖自在。以一切刹庄严庄严一刹示现自在。以一刹庄严庄严一切刹示现自在。一如来身及其眷属。皆悉充满一切佛刹示现众生自在。一切刹小刹中刹大刹广刹深刹翻覆刹俯刹仰刹平正刹以此等刹示现众生自在。佛子。是为菩萨摩诃萨。十种刹自在。佛子。菩萨摩诃萨。有十种法自在。何等为十。所谓一切法即是一法。一法即是一切法。而不违众生法相自在。般若波罗蜜出生一切法。觉悟一切众生。无不了知自在。于一切法悉离法想。普令众生入胜法自在。一切诸法入一方便。分别解说无量方便自在。一切诸法言语道断。而能演说无量法门自在。于一切法巧方便。转普门法轮。无尽自在。一切诸法入一法门。于不可说劫。分别解说不可穷尽自在。一切法悉入佛法殊胜众生自在。一切法示现无量无边自在。一切法无碍实际无量无边犹如幻网。于无量劫为众生说不可穷尽自在。佛子。是为菩萨摩诃萨十种法自在

佛子。菩萨摩诃萨。有十种身自在。何等为十。所谓令一切众生入己身自在。己身示现一切众生身自在。一切佛身示现一佛身自在。一佛身示现一切佛身自在。一切刹置己身内自在。一法身充满三世示现众生自在。一身入三昧无量身起三昧自在。一身成最正觉示现众生等身自在。一切众生身作一众生身示现一切众生身自在。一切众生身示现法身法身示现一切众生身自在。佛子。是为菩萨摩诃萨十种身自在。佛子。菩萨摩诃萨。有十种愿自在。何等为十。所谓一切菩萨愿即是己愿愿自在。以一切佛愿力菩提示现众生愿自在。随其所应悉令成就阿耨多罗三藐三菩提愿自在。于不可数阿僧祇劫大愿不断愿自在。远离识身不着智身而示现一切身愿自在。不舍己事而能成满一切他事愿自在。教化成熟一切众生令不退转愿自在。于一切阿僧祇劫修菩萨行未曾断绝愿自在。于一毛道成等正觉愿力充满一切佛刹。为一一众生示现不可说不可说世界愿自在。说一句法。法云普覆一切法界。震实法雷耀明解脱电光澍甘露法雨。充满一切众生心愿愿自在。佛子。是为菩萨摩诃萨十种愿自在。佛子。菩萨摩诃萨。有十种境界自在。何等为十。所谓菩萨在法界境界而示现在众生境界。在佛境界而示现在众魔境界。在涅槃境界而不离生死境界。在一切智境界而不离菩萨境界。在寂灭境界而不舍散乱众生境界。在离一切虚妄境界而不离虚妄境界。在庄严力境界而示现非一切智境界。在无众生实际境界而不舍化度一切众生境界。在诸禅三昧解脱通明智离欲境界而示现一切世界受生在如来行菩提庄严境界而示现声闻缘觉寂静威仪境界。佛子。是为菩萨摩诃萨十种境界自在。佛子。菩萨摩诃萨。有十种智自在。何等为十。所谓无尽辩智自在。不惑一切陀罗尼智自在。法定知一切众生诸根智自在。于一念中以无碍心智悉知一切众生心心数法智自在。知一切众生心心使烦恼习气随病对治法智自在。于一念中深入如来十力智自在。无碍智知三世众生随时度脱智自在。于一念中成等正觉示现一切众生智自在。于一众生想了达一切众生业行智自在。于一众生音声示现一切众生音声智自在。佛子。是为菩萨摩诃萨十种智自在。佛子。菩萨摩诃萨。有十种通自在。何等为十。所谓一切世界示现身一身境界通自在。于一如来大众中坐听受正法。悉能闻持一切诸佛大众会法通自在。于一众生一念境界成不可说无上菩提。一切众生无不知者通自在。出一妙音皆能充遍一切世界。出生一切音声各各别异。一切众生无不开解通自在。于一念中示现尽过去际劫。一切众生诸业果报无不知者通自在。令一切世界皆悉庄严通自在。观察三世平等通自在。出生一切诸佛菩提及众生愿。放大法光明通自在。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽帝释梵王及一切声闻缘觉诸菩萨等悉恭敬尊重。善能护持诸如来力一切善根通自在。佛子。略说菩萨平等观察一切诸法通自在。佛子。是为菩萨摩诃萨十种通自在。佛子。菩萨摩诃萨。有十种神力自在。何等为十。所谓以不可说世界入一微尘神力自在。于一微尘中显现一切法界等一切佛刹神力自在。于一毛孔皆悉容受一切大海。能持游行一切世界。不令众生有恐怖心神力自在。以一切世界内己身中。悉能显现一切众事神力自在。以一毛系不可思议金刚围山。悉持游行一切世界。不令众生有恐怖心神力自在。不可说劫示现一劫。一劫示现不可说诸成败劫。不令众生有恐怖心神力自在。于一切世界示现水火风灾成败。不令众生有恐怖心神力自在。一切世界水火风灾坏时。悉能住持一切众生资生之具神力自在。以不可思议世界置于掌中。远掷他方过不可说世界。不令众生有恐怖心神力自在。令一切众生解一切佛刹犹如虚空神力自在。佛子。是为菩萨摩诃萨十种神力自在。佛子。菩萨摩诃萨。有十种力自在。何等为十。所谓众生力自在。不舍众生教化调伏故。佛刹力自在。以不可说庄严具庄严显现诸佛刹故。法力自在。令一切身入无身故。劫力自在。不断一切菩萨行故。佛力自在觉悟生死长寝众生故。行力自在。摄取一切菩萨行故。如来力自在。度脱一切众生故。无师智力自在。自然觉悟一切法故。一切智力自在。一切智人智觉悟故。大悲力自在。不舍一切众生故。佛子。是为菩萨摩诃萨十种力自在。佛子。是为菩萨摩诃萨众生自在等十种自在。若菩萨摩诃萨。成就此十种自在者。欲成无上菩提不成无上菩提自在随意。虽成菩提而亦不断菩萨诸行。何以故。菩萨摩诃萨。出生诸大愿故。善巧方便示现无量自在法门

佛子。菩萨摩诃萨。有十种游戏神通。何等为十。所谓菩萨摩诃萨。于众生身作佛刹身。而不坏众生身。是为第一游戏神通。菩萨摩诃萨。于佛刹身作众生身。而不离佛刹身。是为第二游戏神通。菩萨摩诃萨。于佛身示现声闻缘觉身。而不减如来身。是为第三游戏神通。菩萨摩诃萨。于声闻缘觉身示现如来身。而不增长声闻缘觉身。是为第四游戏神通。菩萨摩诃萨。于菩萨身示现无上菩提身。而不舍菩萨行。是为第五游戏神通。菩萨摩诃萨。于无上菩提身示现菩萨身。而不减菩提身。是为第六游戏神通。菩萨摩诃萨。于涅槃界示现生死相续不绝。而不着涅槃界。是为第七游戏神通。菩萨摩诃萨。于生死界示现涅槃界。亦不究竟无余涅槃。是为第八游戏神通。菩萨摩诃萨。正受三昧行住坐卧现诸威仪。而不舍于正受三昧。是为第九游戏神通。菩萨摩诃萨。于一佛所闻法受持。悉能往诣不可说佛所。听受正法而不离本坐。亦不分身不起三昧。念念于一一三昧身门。出生不可说不可说三昧身门。一切诸劫犹可穷尽。菩萨出生三昧身门。不可穷尽。是为第十游戏神通。佛子。是为菩萨摩诃萨十种游戏神通。若菩萨摩诃萨。安住此法。则得一切诸佛无上大智游戏神通。佛子。菩萨摩诃萨。有十种胜行。何等为十。所谓一切法界以无量方便门普现众生胜行。以无量庄严庄严一切世界普现众生胜行。知出生一切众生界皆悉如化胜行。于如来身出生菩萨身于菩萨身出生如来身胜行。于虚空界出生世界于世界出生虚空界胜行。于生死界出生涅槃界于涅槃界出生生死界胜行。于一众生音声出生一切佛法音声胜行。于无量身门示现一身于一身门示现分别一切诸身胜行。以一身充遍一切世界胜行。于一念中令一切众生出生无量无边法门成等正觉胜行。佛子。是为菩萨摩诃萨十种胜行。若菩萨摩诃萨。安住此行。则得一切诸佛无上大智胜行

佛子。菩萨摩诃萨。有十种力。何等为十。所谓直心力。于一切世界无染着故。深心力。不坏一切诸佛法故。方便力。究竟菩萨一切行故。智慧力。知一切众生诸心行故。愿力。令一切众生愿满足故。行力。尽一切未来际劫不断绝故。乘力。出生普现一切诸乘不转大乘故。游戏神通力。于一毛道示现一切清净世界一切如来出兴世故。菩提力。觉悟菩提与一切众生念等故。转法轮力。于一句法说一切众生希望诸根故。佛子。是为菩萨摩诃萨十种力。若菩萨摩诃萨。安住此力。则得一切诸佛一切智无上十力。佛子。菩萨摩诃萨。有十种无畏。何等为十。所谓菩萨摩诃萨。悉能闻持一切问难。作如是念。十方一切世界有来问我。若不能答。无有是处。乃至不见微畏之相。不见微畏相故。菩萨究竟一切无畏。安住无畏。一切众生随其所问。悉断疑惑。是为第一无畏。菩萨摩诃萨。一切语言音声。一切文字如来授记无碍辩才。究竟彼岸。作如是念。十方世界一切众生来问难我。若不能答。无有是处。乃至不见微畏之相。不见微畏相故。悉能除灭一切疑惑。安住无畏。是为第二无畏。菩萨摩诃萨。知一切法空。离我我所。无造无造者。无知者无命者。无长养者无福伽罗。离阴界入。离诸邪见。心如虚空。作如是念。一切众生若能令我起身口意恶。无有是处。何以故。菩萨常离我我所故。若生怖畏无有是处。乃至不见微畏之相。不见微畏相故。行菩萨行不可沮坏。是为第三无畏。菩萨摩诃萨。为诸佛所护。成如来力行如来行。如来威仪未曾转易。作如是念。若有能来诃我威仪。无有是处。乃至不见微畏之相。不见微畏相故。于大众中说微妙法。是为第四无畏。菩萨摩诃萨。身口意净远离众恶。作如是念。若有能来诃我身口意恶。无有是处。乃至不见微畏之相。不见微畏相故。悉能教化一切众生。是为第五无畏。菩萨摩诃萨。金刚力士常随侍卫一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽帝释梵王等。常随侍卫尊敬供养。一切诸佛常护念之。菩萨作如是念。一切众魔眷属及诸外道。有见众生来诣我所。能障碍我无上菩提。无有是处。乃至不见微畏之相。不见微畏相故。安住无畏。欢喜修行菩萨行业。是为第六无畏。菩萨摩诃萨。离痴正念随如来生。成就第一意根。作如是念。一切诸佛所说正法。句身味身随顺菩提。我若不能如法受持。无有是处。乃至不见微畏之相。不见微畏相故。受持守护如来正法。是为第七无畏。菩萨摩诃萨。具足成就巧方便智慧。究竟菩萨诸力彼岸。清净直心教化众生。发大菩提愿。于众生所起大悲故。于烦恼浊世而现受生。现受五欲畜养妻子及诸眷属。为化众生故。菩萨复作是念。我虽在此。不生惑乱障于菩提解脱三昧法门辩才。若能障碍无有是处。何以故。菩萨于一切法而得自在。究竟彼岸修菩萨行安住菩提。一切世间受生惑乱所不能乱。若能惑乱无有是处。乃至不见微畏之相。不见微畏相故。于一切世界。示现受生。是为第八无畏。菩萨摩诃萨。舍离愚痴知一切智。住菩萨道乘于大乘住一切智。心力示现声闻缘觉不改威仪。菩萨作如是念。我终不证声闻辟支佛道。我若受证无有是处。乃至不见微畏之相。不见微畏相故。安住无畏。悉能示现一切诸乘。具足究竟平等大乘。是为第九无畏。菩萨摩诃萨。成就一切诸白净法。积集善根。成满一切诸愿通明。坚住菩提。具足成满菩萨诸行。于一切佛所。顶受如来一切智记。教化众生不舍菩萨行。作如是念。其有众生应受化者。若不能应时示现如来境界。无有是处。乃至不见微畏之相。不见微畏相故。安住无畏。随受化者。普为应现如来境界。而亦不断菩萨愿行。是为第十无畏。佛子。是为菩萨摩诃萨十种无畏。若菩萨摩诃萨。安住此法。则得一切诸佛无上无畏。而亦不舍菩萨无畏

大方广佛华严经卷第三十九大方广佛华严经卷第四十

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之五

佛子菩萨摩诃萨。有十种不共法。何等为十。所谓菩萨摩诃萨。修习六波罗蜜。不由他悟。平等心施无所悭吝。持戒清净远离恶戒。忍辱成就心不可动。勤修精进于一切劫未曾退转。深入禅定离一切乱。出生智慧远离邪见。是为菩萨摩诃萨修习六波罗蜜随顺波罗蜜道不由他悟第一不共法。菩萨摩诃萨。摄一切众生而饶益之。常以法施于一切众生。和颜爱语远离恶言。于一切众生。常起乐心真实利益。令一切众生解悟菩提。远离恶心。具足成就平等实义。是为菩萨摩诃萨摄取众生随顺摄道不由他悟第二不共法。菩萨摩诃萨。善解回向不求果报。随顺回向诸佛菩提。不着一切世间三昧。回向佛智饶益众生。是为菩萨摩诃萨善解回向专求一切诸佛善根无上智慧饶益众生不由他悟第三不共法。菩萨摩诃萨。善巧方便究竟彼岸。随顺世间亲近世间而无疲厌。正向圣行。远离一切声闻缘觉出要之道。教化成熟一切众生。不着己乐。善知一切诸禅解脱三昧。正受三昧。起于诸三昧而得自在。于生死中心无疲厌。游于生死如园观想。安住一切诸魔宫殿。示现帝释梵王无量自在。于一切生死。慧光明净照除痴闇。于一切众舍家出家。不着异见。示现一切世间书疏文诵谈论语言算术印法一切娱乐。现为女身才术巧妙。能转人心。于世间法离世间法。悉能问答究竟彼岸。于世间事离世间事。亦悉究竟到于彼岸。常观众生。示现一切声闻缘觉。不转威仪不忘大乘。于念念中。现成如来无上菩提。而亦不断菩萨所行。是为菩萨摩诃萨具足修习巧妙方便到于彼岸不由他悟第四不共法。菩萨摩诃萨善知俱变三昧。翻覆三昧。游戏智慧通明。究竟智慧彼岸。常在涅槃而现生死门。知无众生际。而教化成熟一切众生。常在究竟寂灭彼岸。而示现处炽然烦恼。常在金刚一妙法身。而现众生无量身门。常能正受诸禅三昧。而现众生五欲娱乐。常乐寂静远离三界。而教化一切众生。长养善根常乐正法。而现百千天女围绕共相娱乐。百福相好庄严其身。而现贫贱鄙陋之形。常离诸恶长养善业。而现受生一切恶道。究竟到于佛智彼岸。而亦不舍菩萨智身。菩萨成就如是等无量智慧。一切声闻缘觉无能知者。何况一切童蒙众生。是为菩萨摩诃萨第五不共法。菩萨摩诃萨。身口意业智慧为首。一切威仪诸业清净。成就大慈永离杀心。乃至远离邪见具足正见。是为菩萨摩诃萨身口意业随智慧行第六不共法。菩萨摩诃萨。成就大悲。不舍一切众生。代一切众生。受诸地狱畜生饿鬼阎罗王苦。利益众生心无疲厌。度脱一切诸群生界。于一切欲乐心无染着。常为众生灭诸苦阴不舍大悲。是为菩萨摩诃萨第七不共法。菩萨摩诃萨。为一切众生之所爱敬。帝释梵王四天王等。皆恭敬供养。一切众生心常乐见无有厌足。何以故。菩萨本修行业心无染着。皆悉清净威仪具足故。一切众生乐见无厌。是为菩萨摩诃萨第八不共法。菩萨摩诃萨。一切智心坚固正直。以大庄严而庄严之。虽至难处诸恶人处声闻缘觉处。终不退失一切智心。清净妙宝。譬如水珠名曰净光。虽处浊水宝性无异。能令浊水皆悉清净。菩萨亦复如是。虽在众难诸恶人处声闻缘觉处。终不舍离一切种智清净宝心。令一切众生灭除邪见烦恼垢浊。住一切智清净宝心。是为菩萨摩诃萨第九不共法。菩萨摩诃萨。自觉智法到于彼岸受无师记。离垢法缯以冠其顶。于如来所。不舍恭敬供养之心。亦不舍离诸善知识。是为菩萨摩诃萨第十不共法。佛子。是为菩萨摩诃萨十种不共法。若菩萨摩诃萨。安住此法。则得一切诸佛无上大不共法

佛子。菩萨摩诃萨。有十种业。何等为十。所谓世界业。悉能严净一切世界故。如来业。奉给供养一切佛故。菩萨善友业。善根同故。众生业。教化成熟一切众生故。未来世业。摄取一切尽未来际故。神力业。不舍本处而能游行一切世界故。净光业。放无量无边色光。一一光端悉有七宝清净莲华。一一华台各有菩萨。结跏趺坐。悉显现故。三宝不断业。一切诸佛灭度之后。受持守护佛正法故。变化业。游十方说法化众生故。持业。随所发心示现众生。令满一切诸大愿故。佛子。是为菩萨摩诃萨十种业。若菩萨摩诃萨。安住此业。则得一切诸佛无上大业。佛子。菩萨摩诃萨。有十种身。何等为十。所谓菩萨不来身。于一切趣不受生故。菩萨不去身。一切趣求不可得故。菩萨不实身。如一切世间之所得故。菩萨不虚身。如诸世间解真实故。菩萨不尽身。未来际不可断故。菩萨坚固身。一切众魔不能坏故。菩萨不动身。一切众魔及诸外道不能动故。菩萨相身。示现清净百福相故。菩萨无相身。法相究竟无众相故。菩萨普至身。悉与三世如来等故。佛子。是为菩萨摩诃萨十种身。若菩萨摩诃萨。安住此身。则得一切诸佛无上无尽之身。佛子。菩萨摩诃萨。有十种身业。何等为十。所谓以一身充遍一切世界菩萨身业。于一切众生前悉为现身菩萨身业。于趣趣中悉现受生菩萨身业。游行一切世界菩萨身业。往诣一切佛所及诸大众菩萨身业。以一手掌悉能普覆一切世界菩萨身业。一切金刚围山能以手磨悉如微尘菩萨身业。于己身中示一切众生一切佛刹成坏菩萨身业。能以一身遍覆一切众生菩萨身业。于己身中普现一切严净佛刹一切众生究竟成就无上菩提菩萨身业。佛子。是为菩萨摩诃萨十种身业。若菩萨摩诃萨。安住此业。则得一切诸佛无上大法。悉能开悟一切众生。佛子。菩萨摩诃萨。有十种身。何等为十。所谓波罗蜜身。正向菩提故。四摄身。不舍众生故。大悲身。代一切众生。受无量苦无疲厌故。大慈身。救护一切众生故。功德身饶益一切众生故。智慧身。一切诸佛金刚身故。净法身。远离诸趣生死故。方便身。普能示现一切众生故。神力身。示现一切自在力故。菩提身。随一切时成菩提故。佛子。是为菩萨摩诃萨十种身。若菩萨摩诃萨。安住此身。则得一切诸佛无上大智慧身。佛子。菩萨摩诃萨。有十种口。何等为十。所谓柔软口。安乐一切众生故。甘露口。清凉一切众生故。不虚口。说真实故。如实转口。乃至梦中无虚言故。尊重口。一切释梵四天王等恭敬尊重故。甚深口。显现真实法故。坚固口。说无量法不可尽故。正直口。一切音声具足辩故。庄严口。随时随业报普示现故。一切智口。随其所应度众生故。佛子。是为菩萨摩诃萨十种口。若菩萨摩诃萨。安住此口。则得一切诸佛无上清净妙口。佛子。菩萨摩诃萨。有十种清净业。庄严菩萨口业。何等为十。所谓乐闻如来清净音声净菩萨口业。乐闻菩萨清净音声净菩萨口业。不说一切众生不乐闻语净菩萨口业。于过去世离口四过净菩萨口业。欢喜赞叹如来净菩萨口业。于如来塔庙高声赞佛如实功德净菩萨口业。一向普施众生正法净菩萨口业。音乐歌颂赞叹如来净菩萨口业。于诸佛所不惜身命听受正法净菩萨口业。一向不舍菩萨法师听受正法奉给供养净菩萨口业。佛子。是为菩萨摩诃萨十种净业净菩萨口业。出生菩萨清净口业。佛子。菩萨摩诃萨。出生如是清净口业。则得十种守护。何等为十。所谓诸天王及诸天守护。龙王夜叉王乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。梵王及诸梵天。一切诸佛法王所共守护。佛子。是为菩萨摩诃萨出生清净口业得十种守护。若菩萨摩诃萨。出生如是清净口业。得十种守护者。则能成辨十种大事。何等为十。所谓令一切众生界皆悉欢喜。一切刹界无不闻知。悉能发起一切诸根。悉能清净一切性界。拔出一切诸烦恼界。远离一切诸习气界。明净一切诸直心界。长养一切诸深心界。充满一切诸法性界。照明一切大涅槃界。是为十。佛子。菩萨摩诃萨。有十种心。何等为十。所谓大地等心。持一切众生诸善根故。大海等心。受持无量无边诸佛智慧大法海故。须弥山王等心。令一切众生安住无上善根故。摩尼宝心。远离烦恼净直心故。金刚心。决定了知一切法故。坚固金刚围山心。一切诸魔外道不能坏故。莲华等心。一切世法不能染故。优昙钵华等心。于一切劫难值遇故。净日等心。除灭一切众生愚痴曀障闇故。虚空等心。一切众生无能量故。佛子。是为菩萨摩诃萨十种心。若菩萨摩诃萨。安住此心。则得一切诸佛无上清净大心。佛子。菩萨摩诃萨。有十种发心。何等为十。所谓发度脱一切众生心。发拔出一切众生烦恼心。发断除一切习气心。发断除一切疑惑具足清净无疑惑心。发除灭一切众生苦恼心。发除灭一切恶道诸难心。发随顺一切诸佛教心。发一切菩萨所学心。发觉悟一切诸佛菩提示现一切众生非凡愚所入心。发击大法鼓音声闻于一切世界普照一切众生诸根心。佛子。是为菩萨摩诃萨十种发心。若菩萨摩诃萨。安住此心。则得一切诸佛无上发心。佛子。菩萨摩诃萨。有十种满心。何等为十。所谓满一切虚空界。众生无边故。满一切法界。深入无量无边故。满一切三世。于一念中悉解脱故。满一切佛。降神受胎出生舍家得道转正法轮。乃至大般涅槃悉明了故。满一切众生界。决定了知希望习气及诸根故。满智慧光。随顺了知一切法界故。满无量无边。解一切法如幻网故。满无生。一切诸法无自性故。满无碍。自心他心无障碍故。满自在。于念念中现成菩提故。佛子。是为菩萨摩诃萨十种心满。若菩萨摩诃萨。安住此心。则能成满一切佛法无上无量庄严。佛子。菩萨摩诃萨。有十种根。何等为十。所谓欢喜根。于一切佛信不坏故。乐菩萨根。觉悟一切佛菩提故。不退菩萨根。究竟一切事故。住菩萨根。安住一切菩萨行故。甚深根。觉般若波罗蜜巧方便故。不休息根。究竟一切众生事故。金刚等根。决定了知一切法故。金刚光明焰根。普照一切佛境界故。不杂根。一切如来同一身故。无碍际根。深入如来十种力故。佛子。是为菩萨摩诃萨十种根。若菩萨摩诃萨安住此根。则得一切诸佛无上净根。佛子。菩萨摩诃萨。有十种直心。何等为十。所谓不染一切世间法直心。不染声闻缘觉直心。随顺菩提直心。不违一切智道直心。一切众魔及诸外道不能沮坏直心。不染如来圆满清净智慧直心。随所闻法悉能摄取受持直心。于一切受生处无所选择直心。深入细微智慧直心。善巧修习一切佛法直心。佛子。是为菩萨摩诃萨十种直心。若菩萨摩诃萨。安住此心。则得一切诸佛无上清净直心。佛子。菩萨摩诃萨。有十种深心。何等为十。所谓不退深心。长养一切诸善法故。离疑深心。解一切佛微密语故。正持深心。不舍菩萨大愿行故。无上正直深心。深入一切诸佛法故。了达深心。于一切佛法得自在故。殊胜深心。深入种种方便法故。为首深心。于一切境界悉究竟故。自在深心。庄严一切三昧自在不断绝故。具足深心。摄取本大愿故。不舍深心。教化一切群生类故。佛子。是为菩萨摩诃萨十种深心。若菩萨摩诃萨。安住此心。则得一切诸佛无上清净深心

佛子。菩萨摩诃萨。有十种方便。何等为十。所谓布施方便悉舍一切不求报故。学一切学持一切戒具行头陀威仪清净方便。不轻他故。离一切缠颠倒嗔恚我慢忍一切众生诸恶方便。远离一切彼我想故。精进不退方便。究竟身口意业一切境界不忘失故。一切诸禅三昧解脱诸通方便。远离一切五欲诸烦恼故。正向智慧方便。长养一切功德心无厌足故。大慈方便。说一切众生无众生故。代一切众生受诸苦恼不舍大悲方便。解一切法无自性故。十力觉悟方便。决定无碍智示现一切众生故。转不退法轮方便。转至众生心故。佛子。是为菩萨摩诃萨十种方便。若菩萨摩诃萨。安住此法。则得一切诸佛无上大智方便。佛子。菩萨摩诃萨。有十种乐修。何等为十。所谓乐修最胜。尊重方便诸善根故。乐修庄严。出生种种诸庄严故。乐修广事。心弥旷故。乐修寂灭。深入甚深方便法故。乐修无边。发无量心故。乐修善持。一切诸佛所护念故。乐修不坏。一切魔业不能坏故。乐修决定。解了一切诸业报故。乐修现在。随意能现自在神力大变化故。乐修听受。于一切佛得授记故。乐修自在。随意随时成菩提故。佛子。是为菩萨摩诃萨十种乐修。若菩萨摩诃萨。安住此修。则得一切诸佛无上乐修。佛子。菩萨摩诃萨。有十种解脱深入世界。何等为十。所谓一切世界入一世界。一世界入一切世界。一莲华座一如来身充满一切世界。示现一切世界皆悉虚空。诸佛庄严庄严一切世界。一菩萨身充满一切世界。于一毛孔中安置一切世界。一切世界入一众生身。一佛道场一菩提树充满一切世界。一妙音声充满一切世界。随其所应无不闻解皆为欢喜。佛子。是为菩萨摩诃萨十种解脱深入世界。若菩萨摩诃萨。安住此法。则得一切诸佛出生佛刹无上解脱。佛子。菩萨摩诃萨。有十种入众生性。何等为十。所谓一切众生界入无身性。一切众生界悉入一众生身。一切众生界悉入菩萨身。一切众生界悉入如来性藏。一切众生界悉入一众生界。一切众生界悉入诸佛法器。一切众生界悉入帝释梵王随众生形类而普示现。一切众生界示现入一切声闻缘觉不转威仪。一切众生界入菩萨功德庄严庄严一切众生。一切众生界入如来相好庄严色身寂静威仪示现众生。佛子。是为菩萨摩诃萨十种入众生性。若菩萨摩诃萨。安住此性。则得一切诸佛无上自在性。佛子。菩萨摩诃萨。有十种习气。何等为十。所谓菩提心习气。善根习气。教化众生习气。见佛习气。于清净土受生习气。菩萨行习气。大愿习气。波罗蜜习气。出生平等法习气。种种分别境界习气。佛子。是为菩萨摩诃萨十种习气。若菩萨摩诃萨。安住此法。则能除灭一切众生烦恼习气。得佛无上大智习气。佛子。菩萨摩诃萨。有十种炽然。何等为十。所谓炽然一切众生界。教化究竟令成熟故。炽然世界。悉严净故。炽然如来。究竟菩萨一切行故。炽然善根。积集如来功德诸相好故。炽然大悲。除灭一切众生苦故。炽然大慈。令一切众生安住如来无上乐故。炽然波罗蜜。积集菩萨诸庄严故。炽然巧方便。随其所应悉示现故。炽然菩提。得无碍智故。略说菩萨皆悉炽然一切诸法。明达了知一切法故。佛子。是为菩萨摩诃萨十种炽然。若菩萨摩诃萨。安住此法。则能究竟不断菩萨诸行。除灭一切烦恼炽然。则得一切诸佛无上炽然正法。佛子。菩萨摩诃萨。有十种趣。何等为十。所谓趣波罗蜜。趣学。趣智。趣实义。趣正法。趣出生善根。趣见佛。趣菩萨诸行门。趣无上菩提。趣转法轮。佛子。是为菩萨摩诃萨十种趣。若菩萨摩诃萨。安住此趣。则得一切诸佛无上趣法。佛子。菩萨摩诃萨。有十种事。则能具足一切佛法。何等为十。所谓深信善知识具足佛法。深信佛教具足佛法。不谤正法具足佛法。离放逸行摧灭憍慢巧妙方便回向善根。具足佛法。深信诸佛境界无量具足佛法。深入一切世界具足佛法。安住法界具足佛法。离诸魔界具足佛法。正念一切佛具足佛法。深信如来成就十力具足佛法。佛子。是为菩萨摩诃萨十种事则能具足一切佛法。若菩萨摩诃萨。安住此法。则得具足一切诸佛无上大智。佛子。菩萨摩诃萨。有十种退失佛法。应当远离。何等为十。所谓于善知识生憍慢心失佛法道。畏生死苦失佛法道。厌菩萨行失佛法道。厌恶受生失佛法道。乐着三昧失佛法道。于诸善根起疑惑心失佛法道。诽谤正法失佛法道。断菩萨行失佛法道。乐求声闻及缘觉乘失佛法道。起嗔恚心失佛法道。应当远离。佛子。是为菩萨摩诃萨十种退失佛法。若菩萨摩诃萨。远离此法。则得一切菩萨正趣离生圣行正道

佛子。菩萨摩诃萨。有十种离生。何等为十。所谓出生般若波罗蜜菩萨离生。观察一切众生远离一切邪见断一切缚度脱一切众生菩萨离生。不念一切相亦不舍离着相众生菩萨离生。不着三界亦复不着一切世界菩萨离生。永离烦恼而亲近众生菩萨离生。于诸法中得离欲法常以大悲哀念众生菩萨离生。现处眷属令乐寂静菩萨离生。离世界生现此殁彼生行菩萨行菩萨离生。行一切世间事而不染世法菩萨离生。决定了知无上菩提而亦不舍菩萨行愿菩萨离生。佛子。是为菩萨摩诃萨十种离生永离世间大圣正法。不共一切众生及声闻缘觉。若菩萨摩诃萨。安住此法。则得一切菩萨十种决定法。何等为十。所谓于一切如来种姓中生。深入一切如来境界。深解一切诸菩萨行。正向一切诸波罗蜜。出生一切诸佛善根。安住一切如来无上姓中。安住一切诸佛净力。随顺一切如来菩提。与一切佛共同一身。与一切佛同住而无有异。佛子。是为菩萨摩诃萨十种决定法。佛子。菩萨摩诃萨。有十种出生佛道法。何等为十。所谓随顺善知识出生佛道法。同善根故。深信一切佛法出生佛道法。乐求如来无尽自在故。于一切大愿得正希望出生佛道法。修习广心故。决定了知己身善根出生佛道法。所行诸业无虚妄故。于一切劫修菩萨行出生佛道法。尽未来际无疲厌故。于阿僧祇世界诸处受生出生佛道法。善巧方便教化一切众生故。修习不断菩萨所行出生佛道法。长养大悲故。以无量心出生佛道法。于一念中充满一切虚空界故。深入甚深诸大愿行出生佛道法。本生善根不坏不失故善持守护一切如来种姓出生佛道法。令一切众生发菩提心。志常乐求无上菩提。长养一切善根故。佛子。是为菩萨摩诃萨十种出生佛道法。若菩萨摩诃萨。安住此法。则得善男子十种名号。何等为十。所谓菩萨名号。菩提智身故。摩诃萨名号。住大乘故。第一萨埵名号。最第一无间道法故。胜萨埵名号。觉胜菩提故。无比萨埵名号。智慧无比故。上萨埵名号。上精进故。无上萨埵名号。开示显现无上法故。力萨埵名号。广知十力故。无等萨埵名号。一切众生无与等故。不思议萨埵名号。随其心念觉菩提故。佛子。是为菩萨摩诃萨得善男子十种名号。佛子。菩萨摩诃萨。有十种道。何等为十。所谓一道是菩萨道。不舍菩提心故。二道是菩萨道。出生智慧方便故。三道是菩萨道。空方便无相际无际无愿三昧三界无染故。四行是菩萨道。悔过除罪随喜功德。恭敬劝请无量诸佛。善知回向故。长养五根是菩萨道。住有信根不可沮坏。发大精进究竟一切事而不退转。安住正念除灭乱想。三昧方便决定了知。智慧境界善巧分别故。六通自在是菩萨道。天眼。悉见一切世界有色众生死此生彼。天耳。悉闻一切诸佛所说经法。皆能受持广为一切众生解说。出生无碍知他心智。悉知一切众生心念。宿命智通。悉知过去一切阿僧祇劫。长养善根身通自在。随其所应现大神变。漏尽智通。知见实际生菩萨道不断绝故。七念是菩萨道。念佛。于一毛道见一切佛教化众生。念法。不离一如来众。于一切佛所对面闻法悉能受持。随应众生诸根希望而度脱之。念僧。见不退转菩萨大众。令一切众生常见菩萨大众。念施。行一切菩萨布施。正念长养菩萨布施功德。念戒。不离菩提心一切善根回向众生。念天。念兜率陀天一生补处菩萨。念一切众生。善巧方便智慧教化。悉令安隐随顺无上菩提故。八正道分是菩萨道。所谓正见。远离邪见。正思惟。正念一切智远离虚妄。正语。随顺圣教离口四过。正业饶益教化一切众生未曾失时。正命。安住四圣种成头陀功德。具足净威仪。远离一切恶。正精进。勤修一切菩萨苦行。修佛十力无所挂碍。正念。悉能忆持一切音声。除灭世间一切乱想。正定。善巧方便。于一三昧。出生菩萨不可思议法门一切三昧故。九次第定是菩萨道。所谓离欲恶不善法。因觉观起一切口业无所障碍。说法教化一切众生。令得一切智喜悦。远离退过休息喜悦。离世苦乐常见诸佛。逮得无上菩提快乐。不动三昧出生四无色定。亦不离欲界色界受生。正受灭尽三昧。而亦不息菩萨行故。如来十力是菩萨道。所谓巧方便善知是处非处。善知一切众生去来现在业因果报。善知一切众生种种诸根。随彼诸根而为说法。善知众生无量诸性。善知一切众生种种欲乐。随应说法。菩萨净身。皆悉充满一切众生一切刹一切世一切劫。普现如来具足威仪。而亦不舍菩萨所行。善巧方便。知一切禅三昧解脱垢净起。知时非时。出生菩萨无量法门。善知一切众生死此生彼。于一念中。善知三世一切阿僧祇劫。善知一切众生。除灭一切烦恼结使及诸习气。而亦不舍菩萨行故。佛子。是为菩萨摩诃萨十种道。若菩萨摩诃萨。安住此道。则得一切诸佛无上巧方便道。佛子。菩萨摩诃萨。有无量道无量道具。无量修道无量庄严道。何以故。菩萨摩诃萨。有十种无量道故。何等为十。所谓虚空界无量。法界无量。众生界无尽无量。世界无分齐无量。阿僧祇劫无尽究竟无量。众生语法无量。如来身无量。佛音声无量。如来力无量。一切智无量。佛子。是为菩萨摩诃萨十种无量道。何以故。如虚空界无量。菩萨积集道具。亦复如是。如法界无量无边。菩萨积集道具。亦复如是。如众生界无尽无量。菩萨积集道具。亦复如是。如世界无分齐无量。菩萨积集道具。亦复如是。如一切劫算数不可尽。菩萨积集道具。亦复如是。一切众生悉共算数所不能尽。如一切众生语言无量。菩萨积集道具出生智慧诸语言法。亦复如是。如如来身无量。菩萨积集道具。充满一切众生一切刹一切世一切劫。亦复如是。如佛音声无量。出一言音。皆悉充满一切法界。一切众生无不闻知。菩萨积集道具。亦复如是。如如来力无量。菩萨积集道具。长养如来力。亦复如是。如一切智无量。菩萨积集道具。亦复如是。佛子。是为菩萨摩诃萨十种道具。若菩萨摩诃萨。安住此法。则得一切诸佛无量无边智慧。佛子。菩萨摩诃萨。有十种修道。何等为十。所谓不着不出修。身口意无忘失故。无增减修。知诸法真实故。非有非无修。入非有非无性故。如幻如梦如电如响如镜中像如热时焰如水中月修。于一切法无所著故。空无相无愿修。见三界不舍长养诸善根故。不可言说修。不着法施设故。不坏法界修。决定了知一切法故。如实际不可坏修。如如虚空际平等至一切故。菩萨智修。不舍勇猛精进力故。如来十力四无所畏一切智平等修。于一切法悉除疑惑故。佛子。是为菩萨摩诃萨十种修道。若菩萨摩诃萨。安住此法。则得一切诸佛无上一切智巧方便修。佛子。菩萨摩诃萨。有十种庄严道。何等为十。所谓菩萨摩诃萨。不离欲界。悉能正受色无色界禅定解脱。亦不因此于彼受生。是为第一庄严道。菩萨摩诃萨。入声闻道。亦不乘此道出于三界。是为第二庄严道。菩萨摩诃萨。入缘觉道。亦不舍大悲。是为第三庄严道。菩萨摩诃萨。虽百千天女眷属围绕。端严殊特颜容无伦。技术悉备音乐巧妙。菩萨闻此妙音。未曾暂舍诸禅解脱三昧。是为第四庄严道。菩萨摩诃萨。与一切众生设众妓乐共相娱乐。乃至一念不舍诸禅解脱三昧。是为第五庄严道。菩萨摩诃萨。不着一切世间诸法。究竟世间得到彼岸度脱众生。是为第六庄严道。菩萨摩诃萨。安住正智修习正道趣于邪道。欲令众生远离邪道。于此邪道。不取真实清净之相。是为第七庄严道。菩萨摩诃萨。远离身口意恶业。常持净戒。一向正求如来净戒。示现一切凡愚童蒙众生持戒威仪。为教化成熟犯戒众生故。菩萨具足成满一切清净功德。正趣菩萨趣。而现受生地狱畜生饿鬼阎罗王及诸难趣。令彼众生离恶趣故。而实菩萨不摄彼趣。是为第八庄严道。菩萨摩诃萨。于一切佛法不由他悟。得无碍辩明净智慧。普照一切诸佛正法。安住一切诸佛自在。共一切佛清净法身。具足成就一切坚固大人明净正法。安住一切平等诸乘。向一切佛境界法门。一切众生所应赞叹恭敬供养。为一切众生作无上师。专求正法未曾舍离。示现于法有疑。示现师受恭敬供养和尚阿阇梨。而实为一切天人无上法师。何以故。菩萨摩诃萨。善知方便住菩萨道。随其所应方便示现。是为第九庄严道。菩萨摩诃萨。具足成就甚深智慧。究竟菩萨一切无上法行。一切如来。以甘露法而灌其顶。究竟一切法自在彼岸。离垢无碍清净法缯。以冠其首。于一切世界。普现如来无碍法身。转不可坏清净法轮。清净法身。于一切世界无处不至。究竟一切法自在彼岸。具足成就一切菩萨自在之法。巧妙方便于一切刹示现受生。与三世佛共一境界。而亦不断菩萨所行。不舍菩萨法。不转菩萨业。不舍菩萨道。未曾废舍菩萨威仪。不舍菩萨炽然。不舍善巧方便。不离菩萨事。修菩萨行心无疲厌。不离菩萨受持法行。何以故。菩萨摩诃萨。欲速成阿耨多罗三藐三菩提故。不舍菩萨行。观察众生。是为第十庄严道。佛子。是为菩萨摩诃萨十种庄严道。若菩萨摩诃萨。安住此道。则得一切诸佛无上道宝庄严。而不舍菩萨道

大方广佛华严经卷第四十大方广佛华严经卷第四十一

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之六

佛子。菩萨摩诃萨。有十种足。何等为十。所谓净戒足。积集成满一切大愿故。精进足。积集一切菩提枝至不退转故。诸通足。随众生愿令欢喜故。身通足。不离一坐而能悉诣一切佛刹故。深心足。究竟一切胜妙法故。坚誓足。所求诸事悉究竟故。摄右法足。不违一切尊重教故。闻法无厌足。闻持一切佛所说法无疲倦故。如法资生具足。入一切众诸根无异故。正向菩萨行足。离一切恶故。佛子。是为菩萨摩诃萨十种足。若菩萨摩诃萨。安住此足。则得一切诸佛无上胜足。能一举足。皆悉遍至一切世界。佛子。菩萨摩诃萨。有十种手。何等为十。所谓信手。于一切佛所说正法。一向信心究竟受持故。不着财施手。有来乞者令欢喜故。先意善来问讯手。右掌相显现故。恭敬供养一切佛手。长养无量功德无疲厌故。善解多闻手。除一切众生诸疑惑故。远离三界离生寂静手。拔欲污泥众生类故。安置彼岸手。救济四流漂没众生故。离吝法手。尽能开说一切法故。一切世间离世间诸论智手。除灭一切身心病故。智慧宝手。除灭一切烦恼痴闇。示现一切不可称说法光明故。佛子。是为菩萨摩诃萨十种手。若菩萨摩诃萨。安住此手。则得一切诸佛无上之手。能以一掌。普覆十方一切世界

佛子。菩萨摩诃萨。有十种腹。何等为十。所谓离谄曲腹。直心清净故。离幻伪腹。身口意业皆真正故。不为事腹。离藏恶故。无穷尽腹。于一切法无所著故。灭烦恼腹。智明净故。清净心腹。离一切恶故。观察一切食想腹。正念真实法故。观察一切行腹。善觉缘起故。善觉一切道腹。具足成就正希望故。离一切烦恼诸邪见腹。令一切众生得如来腹故。佛子。是为菩萨摩诃萨十种腹。若菩萨摩诃萨。安住此腹。则得一切诸佛无上之腹。悉能容受一切众生。佛子。菩萨摩诃萨。有十种藏。何等为十。所谓不断如来种姓是菩萨藏。广说佛法长养无量诸善法故。受持守护如来正法是菩萨藏。开示众生大智明故。长养僧宝是菩萨藏。摄取不退正法轮故。觉悟正定众生是菩萨藏。度脱众生不失时故。教化成熟不定众生是菩萨藏。善根相续因不断故。发大悲心救护邪定众生是菩萨藏。起彼未来善根因缘故。满足如来十力不可沮坏是菩萨藏。降伏众魔具足成就不退善根故。住四无畏大师子吼是菩萨藏。令一切众生悉欢喜故。得佛十八不共法是菩萨藏。一切智慧无不至故。平等觉悟一切众生一切刹一切法一切佛是菩萨藏。于一念中深入平等故。佛子。是为菩萨摩诃萨十种藏。若菩萨摩诃萨。安住此藏。则得一切诸佛无上善根大智慧藏。佛子。菩萨摩诃萨。有十种心。何等为十。所谓勇猛心。所发事业悉究竟故。无懈怠心。积集相好诸善根故。勇健力心。摧伏一切诸恶魔故。正思惟心。除灭一切烦恼垢故。不退转心。往诣道场究竟菩提故。性清净心觉心无所至无所著故。知众生心。随众生性令彼觉悟得解脱故。入大梵天住住佛法心。种种众生性悉救护故。空无相无愿无行心。远离相见不着三界故。金刚庄严心。众生数等魔乃至不能动一毛故。佛子。是为菩萨摩诃萨十种心。若菩萨摩诃萨。安住此心。则得一切诸佛无上金刚藏心。佛子。菩萨摩诃萨。有十种庄严。何等为十。所谓大慈庄严。救护一切众生故。大悲庄严。堪忍一切苦故。大愿庄严。所可发愿悉究竟故。回向庄严。建立一切诸佛功德妙庄严故。功德庄严。饶益一切众生故。波罗蜜庄严。度脱一切众生故。智慧庄严。除灭一切众生烦恼愚痴闇故。方便庄严。出生普门诸善根故。一切智心坚固不乱庄严。不乐异乘故。决定庄严。于正法中灭疑惑故。佛子。是为菩萨摩诃萨十种庄严。若菩萨摩诃萨。安住此法。则得一切诸佛无上庄严。降一切魔。佛子。菩萨摩诃萨。有十种器仗。何等为十。所谓远离悭吝惠施心仗。除灭一切悭贪垢故。持戒仗。拔出一切诸恶戒故。平等观察一切法仗。远离一切虚妄法故。智慧仗。除灭众生诸烦恼故。正命仗。远离一切诸邪命故。方便仗。一切示现故。略说贪恚痴一切烦恼是菩萨仗。以烦恼门化众生故。生死仗。不断菩萨行教化众生故。说实法仗。一切无著故。一切智门仗。不离菩萨行门故。佛子。是为菩萨摩诃萨十种器仗。若菩萨摩诃萨。安住此法。则能除灭一切众生长夜积集烦恼结使习气。佛子。菩萨摩诃萨。有十种头。何等为十。所谓涅槃首。无见顶故。恭敬尊重首。一切世间天人恭敬供养故。深妙首。于一切三千大千世界最第一故。一切善根首。三界众生应供养故。荷负一切众生首。得无上金刚顶故。无量无边首。摄取一切最胜法故。般若波罗蜜首。乐法王法故。方便首。示现一切众生平等首故。教化成熟一切众生首。为一切众生无上师故。守护如来正法首。不断三宝故。佛子。是为菩萨摩诃萨十种头。若菩萨摩诃萨。安住此法。则得一切诸佛无上智顶。佛子。菩萨摩诃萨。有十种眼。何等为十。所谓肉眼见一切色故。天眼。见一切众生死此生彼故。慧眼。见一切众生诸根故。法眼。见一切法真实相故。佛眼。见如来十力故。智眼。分别一切法故。明眼。见一切佛光明故。出生死眼。见涅槃故。无碍眼。见一切法无障碍故。普眼。平等法门见法界故。佛子。是为菩萨摩诃萨十种眼。若菩萨摩诃萨。成就此眼。则得一切诸佛无上大智慧眼。佛子。菩萨摩诃萨。有十种耳。何等为十。所谓闻赞叹声。断除贪爱。闻毁訾声。断除嗔恚。闻声闻缘觉声。不起求心。闻菩萨道声。发起欢喜奇特之心。闻地狱畜生饿鬼阎罗王阿修罗一切难处贫苦音声。发起大悲庄严而自庄严。闻天人趣胜妙音声。观一切法皆悉无常。闻佛功德音声。勤修精进究竟满足一切功德。闻波罗蜜四摄菩萨经藏音声。发究竟心到于彼岸。闻十方世界一切音声。悉了如响。菩萨摩诃萨。从初发心乃至道场。常正受法耳。而亦不舍教化成熟一切众生。佛子。是为菩萨摩诃萨十种耳。若菩萨摩诃萨。成就此耳。则得一切诸佛无上大智慧耳。佛子。菩萨摩诃萨。有十种鼻。何等为十。所谓所闻秽气观察不臭。所闻香气观察不香。所闻香臭观察平等。闻非香非臭观察舍离。闻衣服床褥卧具及身肢节香。则知彼人贪恚愚痴等分烦恼。闻大宝藏诸药草香。悉能了知一切宝藏。闻下至阿鼻地狱上至非想非非想处众生之香。悉能了知诸根本行。闻声闻施戒闻慧香。住一切智心未曾散乱。闻一切菩萨行香。摄取如来智地。闻一切佛智境界香。不断菩萨所行。佛子。是为菩萨摩诃萨十种鼻。若菩萨摩诃萨。成就此鼻。则得一切诸佛无量无边无上清净鼻。佛子。菩萨摩诃萨。有十种舌。何等为十。所谓分别解说一切众生无尽行舌。分别解说无尽法舌。赞叹诸佛无尽功德舌。无尽辩舌。演说无尽大乘法舌。普覆十方虚空界舌。普照一切佛世界舌。平等赞叹一切众生舌。随顺诸佛令欢喜舌。降一切魔及诸外道。除灭一切生死烦恼。悉令众生至涅槃舌。佛子。是为菩萨摩诃萨十种舌。若菩萨摩诃萨。成就此舌。则得诸佛无上大金刚舌。普覆一切世界。佛子。菩萨摩诃萨。有十种身。何等为十。所谓人身。教化成熟一切人故。非人身。教化成熟地狱畜生饿鬼阎罗王故。天身。教化成熟欲界色界无色界众生故。学身。示现学地故。无学身。示现阿罗汉地故。缘觉身。教化令入缘觉地故。菩萨身。积集大乘故。如来身。授如来智记故。摩[少/兔]摩身。巧方便出生无量功德故。无漏法身。以少方便普现一切众生身故。佛子。是为菩萨摩诃萨十种身。若菩萨摩诃萨。成就此身。则得一切诸佛无上法身。佛子。菩萨摩诃萨。有十种意。何等为十。所谓上首意。出生一切善根故。随顺佛教意。如说修行故。深入意。解一切佛法故。内意。深入众生希望故。不乱意。不为烦恼所乱故。清净意。不受垢染故。善调伏意。不失时故。正思惟业意。远离一切恶故。调伏诸根意。于境界中诸根不驰骋故。深定意。佛三昧不可称量故。佛子。是为菩萨摩诃萨十种意。若菩萨摩诃萨。成就此意。则得一切诸佛无上意。佛子。菩萨摩诃萨。有十种行。何等为十。所谓闻法行。乐听受法故。说法行。利益众生故。不随爱嗔痴怖行。调伏自心故。欲界行。教化成熟欲界众生故。色无色界三昧行。令速转故。义法行。速成净慧故。一切趣行。教化众生故。一切佛刹行。恭敬礼拜供养一切佛故。涅槃行。断生死相续故。成满诸佛行。不断菩萨行故。佛子。是为菩萨摩诃萨十种行。若菩萨摩诃萨。成就此行。则得一切诸佛行非行如来行。佛子。菩萨摩诃萨。有十种住。何等为十。所谓菩提心住。未曾忘失故。波罗蜜住。不厌功德故。乐闻正义住。明净智慧故。阿练若处住。成就诸大三昧故。随顺一切智头陀威仪四圣种住。少欲知足故。随顺住。顺正法故。亲近如来住。成满佛威仪故。诸明住。满足大智故。无生忍住。受记满足故。道场菩提住。满足力无畏一切佛法故。佛子。是为菩萨摩诃萨十种住。若菩萨摩诃萨。安住此住。则得一切诸佛无上一切智住。佛子。菩萨摩诃萨。有十种坐。何等为十。所谓转轮王坐。兴十善故。四天王坐。欲于一切世界诸佛正法得自在故。帝释坐。于一切众生最第一故。梵天坐。自心他心。得自在故。师子坐。分别演说甚深义故。正法坐。欲明陀罗尼诸力辩故。坚固三昧坐。究竟大誓故。大慈坐。令恶心众生悉欢喜故。大悲坐。能忍一切诸苦恼故。金刚坐。调伏众魔诸外道故。佛子。是为菩萨摩诃萨十种坐。若菩萨摩诃萨。安住此坐。则得一切诸佛无上尊坐。佛子。菩萨摩诃萨。有十种卧。何等为十。所谓寂静卧。身心憺怕故。禅定卧。正念思惟观诸法故。诸三昧卧。身心柔软故。梵天卧。不恼自他故。思惟业卧。后心无悔故。顺正法卧。不可倾动故。正道卧。善知识觉悟故。妙愿卧。善知回向故。一切事毕卧。所作究竟故。舍方便卧。究竟本事故。佛子。是为菩萨摩诃萨十种卧。若菩萨摩诃萨。安住此法。则得一切诸佛无上道卧。悉能觉悟一切众生。佛子。菩萨摩诃萨。有十种住。何等为十。所谓大慈住。等心观察一切众生故。大悲住。不轻未学众生故。大喜住。灭忧恼故。大舍住。有为无为悉平等故。一切波罗蜜住。菩提心为首故。一切种空住。善解诸法故。无相住。离生受证不退转故。无愿住。舍受生故。念慧住。忍法成满故。一切法平等住。得授记法故。佛子。是为菩萨摩诃萨十种住。若菩萨摩诃萨。安住此住。则得一切诸佛无上无碍住。佛子。菩萨摩诃萨。有十种行。何等为十。所谓正念行。满足四念处故。诸趣行。正觉法趣故。慧行。随顺诸佛故。波罗蜜行。满足一切智故。四摄行。教化成熟诸众生故。生死行。长养一切诸善根故。一切众生言戏行。拔出众生故。贪炽然行。觉悟一切众生诸根故。巧方便行。长养般若波罗蜜故。道场行。觉一切智不断菩萨行故。佛子。是为菩萨摩诃萨十种行。若菩萨摩诃萨。安住此行。则得一切诸佛无上大智慧行

佛子。菩萨摩诃萨。有十种观察。何等为十。所谓观察善业。乃至微色悉照见故。观察死此生彼。不着一切众生故。观察一切众生诸根。决定了知无根法故。观察妙法。法界不可坏故。观察现前。于一切佛法修佛眼故。观察智慧。随器说法故。观察无生法忍。决定得佛法故。观察不退佛地。除灭一切烦恼。超出三界二乘地故。观察甘露灌顶法地。于一切佛法得自在不动故。观察佛三昧。于一切十方作佛事故。佛子。是为菩萨摩诃萨十种观察。若菩萨摩诃萨。安住此法。则得一切诸佛无上大智观察。佛子。菩萨摩诃萨。有十种周遍观察。何等为十。所谓周遍观察诸来求者。慈心施与满彼意故。周遍观察诸犯戒者。安置如来清净戒故。周遍观察害心众生。安置如来堪忍力故。周遍观察诸懈怠者。令彼众生勤修精进究竟大乘故。周遍观察乱心众生。除彼乱心安置如来一切智地故。周遍观察愚痴众生。除彼疑惑一切有见故。周遍观察诸善知识。随如来教住佛法故。周遍观察随所闻法。具足成就无上义故。周遍观察一切众生。不舍大悲故。周遍观察一切佛法。觉一切智故。佛子。是为菩萨摩诃萨十种周遍观察。若菩萨摩诃萨。安住此法。则得一切诸佛无上大智周遍观察。佛子。菩萨摩诃萨。有十种奋迅。何等为十。所谓色奋迅。于天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等一切众中现最胜故。象奋迅。示现象宝心故。龙奋迅。兴大法云普覆一切。曜明解脱电光。震实义雷。降诸根力觉意禅定解脱三昧甘露法雨故。大金翅鸟王奋迅。坏灭愚痴闇曀[穀-禾+卵]膜。消竭爱水。于大苦海。搏撮烦恼诸恶龙故。师子奋迅。安住无畏被执平等大智铠仗。摧伏众魔诸外道故。勇健奋迅。能于生死大战阵中。摧灭一切烦恼大怨敌故。智慧奋迅。决定了知阴界诸入十二缘起。现一切佛自在法故。陀罗尼奋迅。闻持一切法未曾忘失。广为群生分别说故。辩才奋迅。分别一切句身味身无所挂碍。随问即答悉令欢喜言不虚故。如来奋迅。坐师子座降伏众魔调伏外道。满足一切智。具一念相应慧。所得所知所觉所成。皆悉觉知。成无上菩提故。佛子。是为菩萨摩诃萨十种奋迅。若菩萨摩诃萨。安住此法则得一切诸佛无上自在奋迅。佛子。菩萨摩诃萨。有十种师子吼。何等为十。所谓我必成佛。是菩提心师子吼。于一切众生起大悲心。未度者度。未脱者脱。未安者安。未涅槃者令得涅槃。是大悲师子吼。守护受持不断三宝性。是报如来恩师子吼。令一切佛刹皆悉清净。是究竟大誓师子吼。除灭一切恶道诸难。是自持净戒师子吼。满足如来身口意相好庄严。是积集功德无厌足师子吼。成满一切诸佛智慧。是积集智慧众具无厌足师子吼。除灭一切魔事。专求正道。是除灭烦恼师子吼。知一切法无我无我所无命无福伽罗空无相愿。观一切法净如虚空。是于一切法得无生忍师子吼。一生补处菩萨摩诃萨。严净震动一切佛刹。释梵四天王咸悉请求降神下生。以无碍慧眼普观世间。一切众生无胜我者。示现出生游行七步大师子吼。我于世间最胜第一。我永究竟生老死法。是如说修行师子吼。佛子。是为菩萨摩诃萨十种师子吼。若菩萨摩诃萨。安住此法。则得一切诸佛无上大师子吼。佛子。菩萨摩诃萨。有十种净施。何等为十。所谓平等心施。无恶众生故。随意施。满一切愿故。无乱心施。不退转故。随应供施。分别了知福伽罗故。不选择施。不求果报故。一向施。于一切物心无著故。内外一切施。究竟清净故。回向菩提施。远离有为无为故。教化成熟众生施。乃至道场不舍离故。三种圆满清净施。施者受者财物平等。清净如虚空故。佛子。是为菩萨摩诃萨十种净施。若菩萨摩诃萨。安住此施。则得一切诸佛无上清净大施。佛子。菩萨摩诃萨。有十种净戒。何等为十。所谓身净戒。防护身三恶故。口净戒。远离口四过故。心净戒。永离贪恚诸邪见故。具一切净戒。于天人中最胜妙故。守护菩提心净戒。不乐小智故。守护如来所说净戒。乃至微细罪大怖畏故。微密净戒。善拔犯戒诸众生故。不作一切恶净戒。积集一切诸善法故远离一切有见净戒。于戒无著故。守护一切众生净戒。出生大悲故。佛子。是为菩萨摩诃萨十种净戒。若菩萨摩诃萨。安住此戒。则得一切诸佛远离众恶无上净戒。佛子。菩萨摩诃萨。有十种净忍。何等为十。所谓若他骂辱悉能堪忍。护彼心故。若他刀杖加害亦能堪忍。护彼我故。知一切嗔恚忍。自然不动故。自在处忍。能害不害故。众生归趣忍。不惜身命故。远离我慢忍。不轻未学故。割截肢节忍。观察如幻故。一切恶事忍。离自他想故。烦恼忍。远离烦恼境界故。随顺一切菩萨方便智忍。得无生忍。于一切智境界不由他悟故。佛子。是为菩萨摩诃萨十种净忍。若菩萨摩诃萨。安住此忍。则得一切诸佛无上法忍。不由他悟。佛子。菩萨摩诃萨。有十种净精进。何等为十。所谓净身业精进。恭敬供养奉给一切诸佛菩萨。尊重福田不退转故。净口业精进。闻持一切诸佛正法未曾忘失。赞叹如来随所闻法。广为人说无疲倦故。净意业精进。巧方便入慈悲喜舍禅定解脱三昧相续起无退转故。净直心精进。远离谄曲正直。一切事一切方便究竟不退转故。净深心精进。常趣胜趣。积集无上智慧白净法故。行不虚妄净精进。摄取布施戒忍多闻及不放逸。乃至道场不中息故。降伏一切众魔怨敌净精进。悉能除灭贪恚愚痴烦恼邪见诸缠障盖故。满足慧光净精进。有所施作悉善思惟心无中悔。究竟众事。得一切佛不共法故。无所染着净精进。离心境界身口心相非相甚深法门。普观境界决定了知真实如如故。具足成就法明净精进。次第进入一切诸地。于诸佛所。得甘露灌顶受法王记。无漏法身现舍天寿。降神世间出家成道。转净法轮入大涅槃。究竟具足普贤行故。佛子。是为菩萨摩诃萨十种净精进。若菩萨摩诃萨。安住此法。则得一切诸佛无上大净精进。佛子。菩萨摩诃萨。有十种净禅。何等为十。所谓常乐出家净禅。舍离一切有故。亲近善知识净禅。咨受修习正法道故。乐阿练若处净禅。远离我我所法故。离言戏愦闹处净禅。乐寂灭故。心柔软净禅。诸根不乱故。智慧寂静净禅。一切音声诸禅定刺不能乱故。七觉八道净禅。于一切智境界智慧决定故。离味禅等诸烦恼垢净禅。不取欲界故。诸通明内净禅。决定了知一切众生诸根故。以少方便现前游戏神通净禅。如来三昧不可称量故。佛子。是为菩萨摩诃萨十种净禅。若菩萨摩诃萨。安住此禅。则得一切诸佛无上净禅

佛子。菩萨摩诃萨。有十种净慧。何等为十。所谓知因净慧。不坏果报故。解一切缘净慧。不坏和合故。解一切法不常不断净慧。了缘起如如故。拔出一切邪见净慧。不取众生相故。解一切众生心心所行净慧。观一切法皆如幻故。诸辩胜智净慧。随问能答无挂碍故。降伏众魔及诸外道出过声闻缘觉净慧。深入如来方便智故。见一切佛清净法身见一切众生皆悉清净见一切法皆悉寂灭见一切世界皆悉虚空净慧。于一切相智慧无碍故。摄取一切陀罗尼辩诸波罗蜜巧方便净慧。得一切胜智故。一念相应金刚智觉一切法平等净慧。具足成就无上智故。佛子。是为菩萨摩诃萨十种净慧。若菩萨摩诃萨。安住此慧。则得一切诸佛无上大智。佛子。菩萨摩诃萨。有十种净慈。何等为十。所谓等心净慈。不选择众生故。饶益净慈。于一切众生有所施作悉能办故。救护净慈。究竟度脱一切众生生死崄难故。哀愍不舍一切众生净慈。长养有为善根故。解脱净慈。灭一切众生诸烦恼故。出生菩提净慈。令一切众生乐求菩提故。于一切众生无碍净慈。放无量光明普照众生故。虚空净慈。救护一切众生故。法缘净慈。觉悟真实法故。无缘净慈。证取菩萨离生法故。佛子。是为菩萨摩诃萨十种净慈。若菩萨摩诃萨。安住此慈。则得一切诸佛无上清净大慈。佛子。菩萨摩诃萨。有十种净悲。何等为十。所谓不共净悲。自大悲故。不厌净悲。代一切众生受大苦故。处一切恶道净悲。受生死度众生故。一切天人中受生净悲。示现一切法悉无常故。为邪定众生净悲。于无量劫大誓庄严不舍离故。不着己乐净悲。与众生乐故。不求报净悲。自心清净故。除灭一切众生倒惑净悲。说实法故。知一切法自性清净。空无所有客尘所染。菩萨于彼而起净悲。说真净法故。解一切法如虚空足迹。众生痴曀不知真实。菩萨于彼而起净悲。欲令众生发大乘心。究竟涅槃故。佛子。是为菩萨摩诃萨十种净悲。若菩萨摩诃萨。安住此悲。则得一切诸佛无上清净大悲

大方广佛华严经卷第四十一大方广佛华严经卷第四十二

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之七

佛子。菩萨摩诃萨。有十种净喜。何等为十。所谓发菩提心净喜。舍一切所有净喜。于犯戒人不生恶心教化成就净喜。于一切诤讼众生悉令和合得无上智净喜。不惜身命守护正法净喜。远离五欲常乐正法净喜。令一切众生不着资生之具常乐正法净喜。见一切佛恭敬供养无有厌足而不坏法界净喜。令一切众生常乐禅定解脱三昧相续净喜。令一切众生专求寂静除灭乱想得无上慧远离邪见满足诸愿究竟菩萨苦行净喜。佛子。是为菩萨摩诃萨十种净喜。若菩萨摩诃萨。安住此喜。则得一切诸佛无上清净大喜。佛子。菩萨摩诃萨。有十种净舍。何等为十。所谓一切众生恭敬供养不生爱着一切众生轻慢毁辱不生嗔恚净舍。常行世间不为八法之所染污净舍。于器知时于非器不生恶心净舍。不求声闻缘觉学无学净舍。远离五欲一切烦恼乃至不生一念恶心净舍。不叹修行二乘及厌生死净舍。远离世间语非涅槃语非离欲语戏笑语恼他语声闻缘觉语乃至一切障菩提语净舍。若有众生待时受化菩萨净舍。若有众生应受佛化菩萨净舍。菩萨摩诃萨远离二法无上无下无取无舍无虚无实观察平等安住真实得忍净舍。佛子。是为菩萨摩诃萨十种净舍。若菩萨摩诃萨。安住此舍。则得一切诸佛无上清净大舍。佛子。菩萨摩诃萨。有十种义。何等为十。所谓多闻义。如说修行故。法义。善巧方便分别解故。空义。解第一空故。寂灭义。令一切众生离生死故。不可说义。一切语言无所著故。如义。一切三世等观察故。入法义。悉一味故。如来义。顺如来故。实际义。觉真实故。大般涅槃义。灭一切苦不断菩萨行故。佛子。是为菩萨摩诃萨十种义。若菩萨摩诃萨。安住此义。则得一切诸佛无上一切智义。佛子。菩萨摩诃萨。有十种法。何等为十。所谓真实法。如说修行故。无害法。远离嗔恚故。无诤法。除灭一切诸烦恼故。寂灭法。离炽然故。离欲法。永离欲垢诸烦恼故。不虚法。离虚妄故。不生法。一切诸法悉虚空故。无为法。离三相故。性净法。自然清净故。报身烦恼灭无余涅槃法。行菩萨行受持不舍故。佛子。是为菩萨摩诃萨十种法。若菩萨摩诃萨。安住此法。则得一切诸佛无上之法。佛子。菩萨摩诃萨。有十种功德具。何等为十。所谓劝发众生起菩提心是功德具。不断三宝故。随顺十种回向是功德具。断一切不善法集一切善法故。智慧正教是功德具。于三界功德最殊胜故。心无疲厌是功德具。度脱一切众生到彼岸故。悉能舍离内外所有是功德具。于一切物悉无著故。相好满足精进不退是功德具。止心驰骋故。不轻三品善根是功德具。善巧方便回向菩提故。于邪定犯戒众生不起轻慢增长大悲是功德具。显现大人法故。恭敬供养一切如来。于一切菩萨起如来想。于一切众生所作究竟是功德具。长养守护正直心故。菩萨摩诃萨。于阿僧祇劫。具足修习一切善根。皆悉能舍与一众生心无忧悔。如一众生。一切众生亦复如是。是为第十虚空界等大功德具。具足成就广大智慧故。佛子。是为菩萨摩诃萨十种功德具。若菩萨摩诃萨。安住此法。则得一切诸佛无上大功德具。佛子。菩萨摩诃萨。有十种智具。何等为十。所谓亲近真实多闻善知识。恭敬尊重礼拜供养。奉给随顺不违其教。是第一智具。远离谄曲故。离慢下意心无放逸。身口及意皆悉柔软。无有轻躁心。常欢喜护持净戒。和颜爱语先意问讯。远离邪伪。是第二智具。自然成就佛法器故。安住念慧不舍正觉除灭乱想。修习六念行六和敬不求其报。是第三智具。出生长养十种智故。乐法乐义勤修正法。学无厌足。远离世论及世间语。乐闻离世间语。远离小乘乐求大乘。是第四智具。修习正念不可思议故。正求六波罗蜜受持修习具足成就四种梵住。顺诸明法能问智人。远离恶趣专向善趣。慈心调伏。离诃责讥论。防护他心。是第五智具。如说修行诸佛真实法故。常乐出家不乐三界。守护自心远离三觉不生恶心。身口及意皆悉柔软。善知心性。是第六智具。令自他心俱清净故。观阴如幻界如毒蛇入如空聚。观一切法如化如焰水月镜像。如梦如电。如呼声响。如旋火轮。如空中字。如因陀罗阵。如日月光。非常非断。无来无去无住。深心信解不起诽谤。是无生住灭第七智具。具足成就一切法空净智慧故。无我无众生。无福伽罗。无思无义。无贪恚痴。无所有。无毁无誉。无取无舍。无主无行。究竟涅槃。若菩萨摩诃萨。闻此深法。能信能解除灭疑惑。是第八智具。究竟具足深解脱故。以正方便思惟止观。调伏诸根。一切诸法无所造作。无生无为皆悉寂灭。众生计我者。究竟无所有。无缚无脱。无身口心。亦无精进观察一切众生一切法一切心一切行。无前无后皆悉平等。是第九智具。远离一切相。究竟到彼岸故。菩萨摩诃萨。善知缘起故见法清净。见法清净故见刹清净。见刹清净故见虚空清净。见虚空清净故见法界清净。见法界清净故则见智慧。是第十智具。积集一切智故。佛子。是为菩萨摩诃萨十种智具。若菩萨摩诃萨。安住此法。则得一切诸佛一切法中无上无碍清净大智

佛子。菩萨摩诃萨。有十种明足。何等为十。所谓深知佛法明足。一切法中除痴闇明足。远离邪见明足。慧光清净普照诸根明足。正方便勤修精进明足。深入菩萨真谛正趣离生明足。灭烦恼业成就尽智无生智明足。思惟净慧清净天眼明足。清净忆念念宿命明足。具足净地清净诸明除灭诸漏漏尽智明足。佛子。是为菩萨摩诃萨十种明足。若菩萨摩诃萨。安住此法。则得一切诸佛一切法中无上大明。佛子。菩萨摩诃萨。有十种求法。何等为十。所谓直心求法。离于谄曲虚伪心故。精勤求法。离懈怠故。一向求法不惜身命故。为断一切众生烦恼求法。不求资生具故。为饶益一切众生求法。不自利故。为深入智慧求法。不轻彼故。欲令正法常坚固求法。不乐世间故。为愍悼众生求法。不舍菩提心故。为随一切众生所问能答求法。悉能除灭诸疑惑故。为具满佛法求法。不乐余乘故。佛子。是为菩萨摩诃萨十种求法。若菩萨摩诃萨。安住此法。则得一切诸佛法中无上无碍智不由他悟。佛子。菩萨摩诃萨。有十种明了法。何等为十。所谓随顺世间明了法。为欲长养一切世间凡夫善根故。无碍不坏信明了法。解法真性信行人故。安住法界明了法。解法行人故。远离八邪向八正道明了法。解八人故。除灭众结。断生死漏。见真实谛明了法。解须陀洹故。观味是患。还来受生明了法。解斯陀含故。乃至须臾不乐三界。不着受生。专求尽漏明了法。解阿那含故。六通自在游八解脱。随意正受九次第定诸辩。明了法。解阿罗汉故。常乐寂静。因外缘解知足少事不由他悟。成就智慧明了法。解缘觉故。成就胜智诸根明利。心常解脱。长养无量功德智慧。满足诸佛十力四无所畏。一切佛法明了法。解菩萨故。佛子。是为菩萨摩诃萨十种明了法。若菩萨摩诃萨。安住此法。则得一切诸佛无上大智慧明了法。佛子。菩萨摩诃萨。有十种向法。何等为十。所谓随顺恭敬善知识向法。觉悟诸天向法。于一切佛常怀惭愧向法。哀念众生不断生死向法。究竟一切事不起虚妄心向法。远离余乘专修菩萨大乘向法。远离邪道专求正道向法。降伏众魔。灭除烦恼向法。安住佛地知一切众生诸根随应闻法广为演说向法。安住无量无边清净法界向法。佛子。是为菩萨摩诃萨十种向法。若菩萨摩诃萨。安住此法。则得一切诸佛无上向法

佛子。菩萨摩诃萨。有十种魔。何等为十。所谓五阴魔。贪着五阴故。烦恼魔烦恼染故。业魔。能障碍故。心魔。自憍慢故。死魔。离受生故。天魔。起憍慢放逸故。失善根魔。心不悔故。三昧魔。味着故。善知识魔。于彼生着心故。不知菩提正法魔。不能出生诸大愿故。佛子。是为菩萨摩诃萨十种魔。应作方便速远离之。佛子。菩萨摩诃萨。有十种魔业。何等为十。所谓忘失菩提心修诸善根。是为魔业。恶心布施嗔持戒者是为魔业。弃舍恶性懈怠众生。轻慢厌恶乱心无智众生。是为魔业。悭惜正法。诃责法器众生。贪求利养为人说法。为非器人说深妙法。是为魔业。不闻波罗蜜。虽闻不修行。生懈怠心。不求深妙无上菩提。是为魔业。远离善知识。亲近恶知识。乐求二乘。于受生处。起离欲寂静除灭之心。是为魔业。于菩萨所起嗔恚心。说其过恶断彼利养。常求罪衅恶眼视之。是为魔业。诽谤正法。不闻契经。闻不赞叹。若有法师说法。不能恭敬下意自谦。我说是义彼说非义。是为魔业。学世间论。巧于文字。善于句味。手笔文诵乐说二乘。隐覆深法开演杂语。于非器所说甚深法。远离菩提安住邪道。是为魔业。已度已安者。亲近恭敬而供养之。未度未安者。永不亲近恭敬供养。亦不教化。是为魔业。堕增上慢增长诸慢轻蔑众生。不求正法真实智慧。诸根散乱难可化度。是为魔业。佛子。是为菩萨摩诃萨十种魔业。菩萨摩诃萨。应速远离正求佛业。佛子。菩萨摩诃萨。有十种舍离魔业。何等为十。所谓亲近善知识舍离魔业。不自尊举不自赞叹。舍离魔业。信佛深法不生诽谤。舍离魔业。未曾忘失一切智心。舍离魔业。安住不放逸修习甚深法。舍离魔业。安住菩萨藏正求一切法。舍离魔业。常欲听法乐闻深义心无疲倦。舍离魔业。归依十方一切诸佛。舍离魔业。信心正念一切诸佛菩提树。舍离魔业。一切菩萨出生善根皆悉不二。舍离魔业。佛子。是为菩萨摩诃萨十种舍离魔业。若菩萨摩诃萨。安住此业。则离一切诸魔业道。佛子。菩萨摩诃萨。有十种见佛。何等为十。所谓无著佛安住世间成正觉故。愿佛出生故。业报佛信故。持佛随顺故。涅槃佛永度故。法界佛无处不至故。心佛安住故。三昧佛无量无著故。性佛决定故。如意佛普覆故。佛子。是为菩萨摩诃萨十种见佛。若菩萨摩诃萨。安住此法。则能睹见无上如来。佛子。菩萨摩诃萨。有十种佛业。何等为十。所谓劝化众生是第一佛业。随顺长养诸佛法故。梦中见佛是第二佛业。发起过去诸善根故。多闻是第三佛业。逮得无疑决定智故。为悔缠所缠者。善巧方便说悔过法。是第四佛业。除灭一切诸疑悔故。若有众生。起悭心无智心声闻心缘觉心害心疑心憍慢心者。现如来身相好庄严化斯等类。是第五佛业。出生长养过去诸善根故。正法难时广为众生说净妙法。众生闻已便得具足陀罗尼。智慧神通如应示现饶益众生。是第六佛业。心力清净故。若魔事起。种种方便速远离之。以虚空界等微妙音声。亦不轻蔑他人。除灭一切魔业。具足忍辱。是第七佛业。正直功德故。行无量行。不证声闻缘觉离生圣行。诸根未熟者。不为彼人说解脱果。但除爱本。是第八佛业。出生本愿故。断除一切生死漏缚一切诸结。出生菩萨行。于一切众生长养大悲。深心信解菩萨所行究竟涅槃。是第九佛业。不断菩萨行故。菩萨摩诃萨。为自他故。求解脱道而无厌足。离一切行及一切法。于如来色身无所染着。精勤专求无碍智慧不由他悟。令一切佛刹严饰清净。决定了知皆悉虚空。教化成熟一切众生。而不舍无我性。安住法界。诸通自在。具足成就一切种智。而不舍菩萨行。转净法轮令一切众生皆得欢喜。广为众生说甚深法。示现如来无量自在。而不舍菩萨身。现大涅槃而不舍离一切处生。佛子。菩萨摩诃萨。出生如是等乃至翻覆三昧。是第十佛业。佛子。是为菩萨摩诃萨十种佛业。若菩萨摩诃萨。安住此业。则得一切诸佛无上无师大业不由他悟。佛子。菩萨摩诃萨。有十种慢业。何等为十。所谓于尊重福田和尚阿阇梨。父母沙门婆罗门所。而不尊重恭敬供养。是为慢业。有诸法师得胜妙法。乘于大乘。深知出生死道。得陀罗尼成就多闻。具智慧藏善能说法。而不信受恭敬供养。是为慢业。听受法时。若闻深法发离欲心欢喜无量。而不赞法师令众欢喜。是为慢业。起憍慢心自高降彼。不省己实不调自心。是为慢业。起计我心。见有功德智慧者不赞其美。见无德者反说其善。若闻赞他。于彼人所起妒嫉心。是为慢业。若有法师。知是法是律是实是佛语。以憎嫉故说言非法非律非实非佛语。欲坏他信心故。是为慢业。自敷高座。我为法师不应执事。不应宗敬供养余人。诸修梵行尊长有德。悉应恭敬供养于我。是为慢业。远离嚬蹙恶眼视彼。常以和颜等观众生。言常柔软无有粗犷。离恚恨心。而于彼法师求其过恶。是为慢业。以我慢心。于多闻者不往恭敬。起闻法留难。亦不咨问。何等为善何等不善。何等应作何等不应作。作何等业长夜饶益一切众生。作何等行不益众生。作何等行从明入明。作何等行从冥入冥。如是人辈为我心漂没。不能得见出要正道。是为慢业。起慢心故。不值诸佛难得之法。消尽宿世所种善根。不应说而说。起诃责心更相讥论。住如是法应入邪道。但菩提心力故。而不永舍菩萨所行。虽不舍菩萨道。而于无量百千万劫尚不值佛。何况闻法。是为慢业。佛子。是为菩萨摩诃萨十种慢业。若菩萨摩诃萨。离此慢业。则得一切诸佛十种无上清净意业

佛子。菩萨摩诃萨。有十种智业。何等为十。所谓信解因缘。不坏因果。是为智业。不舍菩提心常念一切佛。是为智业。亲近一切诸善知识。恭敬供养心无懈怠。是为智业。乐法乐义多闻无厌。专求正法远离邪念修习正念。是为智业。于一切众生不起我心。于一切菩萨起如来想。爱乐菩萨犹如己身。爱重正法如惜己命。爱敬如来如护己目。于持戒者生诸佛想。是为智业。离身口意诸不善业。修行清净身口意业。叹诸贤圣随顺菩提。是为智业。不违缘起离诸邪见。除灭痴闇照一切法。是为智业。于十回向起慈母想。于诸波罗蜜起慈父想。于巧方便。起菩提想。是为智业。于布施净戒多闻。专求止观功德智慧。心无疲厌。是为智业。若业诸佛所赞。能降众魔。灭除烦恼诸缠障碍。教化众生。顺智律仪摄取正法。严净佛刹正向通明。是为智业。佛子。是为菩萨摩诃萨十种智业若菩萨摩诃萨。安住此业。则得一切诸佛出生巧妙方便无上智业。佛子。菩萨摩诃萨。有十种魔所摄持。何等为十。所谓懈怠心魔所摄持。舍佛正法魔所摄持。贪求无厌魔所摄持。专念自度魔所摄持。不发大愿魔所摄持。远离烦恼常乐寂静魔所摄持。断生死漏魔所摄持。舍菩萨行魔所摄持。舍教化成熟一切众生心魔所摄持。于正法中生疑惑心诽谤佛法魔所摄持。佛子。是为菩萨摩诃萨十种魔所摄持。应速远离。若菩萨摩诃萨。能弃舍此魔所摄持。则得一切诸佛十种摄持。何等为十。所谓佛摄持故。初发菩提心。佛摄持故。常于生生未曾忘失菩提之心。佛摄持故。觉一切魔事能悉远离。佛摄持故。闻六波罗蜜如说修行。佛摄持故。知生死苦而不厌恶。佛摄持故。观甚深法得解脱果佛摄持故。为众生说声闻缘觉解脱而不乐彼乘。佛摄持故。观无为性。心不乐住。于有为法。不生二相。佛摄持故。令不相续得寂灭相续。佛摄持故。得一切智自在。而不舍众生种姓所行。佛子。是为菩萨摩诃萨十种佛摄持。若菩萨摩诃萨。安住此持。则得一切诸佛十力所持。佛子。菩萨摩诃萨。有十种法摄持。何等为十。所谓一切行无常。法所摄持。一切行苦。法所摄持。一切法无我。法所摄持。寂灭涅槃。法所摄持。法从缘起无缘则不起。法所摄持。不正思惟故起无明行乃至老死。不正思惟灭故则无明灭。无明灭故乃至老死灭。法所摄持。三解脱门出生声闻乘。决定无诤法出生缘觉乘。法所摄持。六波罗蜜四摄法出生大乘。法所摄持。知一切刹一切法一切众生一切世间是佛境界。法所摄持。断一切念舍一切取。离过去未来随顺涅槃。法所摄持。佛子。是为菩萨摩诃萨十种法摄持。若菩萨摩诃萨。安住此持。则得一切诸佛无上法持

佛子。菩萨摩诃萨。住兜率天有十种业。何等为十。所谓菩萨摩诃萨。为欲界诸天说离欲法。纵逸自在皆悉无常。一切快乐皆悉苦恼。劝发开导彼诸天子发菩提心。是为住兜率天第一所行事业。菩萨摩诃萨。为色界诸天。说诸禅解脱三昧。相续起彼诸禅支。有味著者。因味起身见邪见无明烦恼。为说实智。于一切妙色起颠倒心。妄想取净。为说不净观察无常。劝发开导彼诸天子发菩提心。是为住兜率天第二所行事业。菩萨摩诃萨。住兜率天。正受三昧名光明庄严。于自身中。放大光明。普照一切三千大千世界。随其所应以种种音声而为说法。彼诸众生闻说法已皆大欢喜。起恭敬心。命终之后生兜率天。复为说法皆悉令发菩提之心。是为住兜率天第三所行事业。菩萨摩诃萨以无碍净眼。普观十方一切兜率天菩萨摩诃萨。彼诸菩萨亦见此菩萨摩诃萨。各相见已。为彼菩萨广说正法。谓降神母胎出生世间。舍家求道往诣道场。以大庄严而自庄严。发起过去所行。忆过去行成就功德。不离此座现如是等一切诸事。是为住兜率天第四所行事业。菩萨摩诃萨。住兜率天。十方一切兜率天菩萨。欲见此菩萨摩诃萨恭敬供养礼拜故。皆来诣此。尔时菩萨摩诃萨。欲令彼诸菩萨。皆悉欢喜满其愿故。说大法门。随彼菩萨所住之地。所行所断所修所证。具足广说。彼诸菩萨闻说法已皆大欢喜。各还本刹所住宫殿。是为住兜率天第五所行事业。菩萨摩诃萨。住兜率天讲说正法时。欲界主天魔波旬眷属围绕。诣菩萨所坏乱说法。尔时菩萨住金刚智所摄般若波罗蜜巧妙方便。深入智门说甘露法。承佛神力说如来法。皆悉降伏彼诸魔众。时彼魔众见菩萨如是自在神力。又闻说法。皆发阿耨多罗三藐三菩提心。是为住兜率天第六所行事业。菩萨摩诃萨。住兜率天。知欲界天子不识苦故。不乐闻法。尔时菩萨摩诃萨。放大音声告诸天子。今日菩萨摩诃萨出内眷属。若欲见者应速诣此。闻是音已。无量亿那由他天子悉往诣彼尔时菩萨摩诃萨。普现宫内一切眷属。彼诸天子未曾闻见。见已皆大欢喜。此菩萨眷属音乐之中。出如是声而告之言。诸天子。一切众行皆悉无常。一切众行皆悉大苦。一切诸法皆悉无我。寂灭涅槃。又复告言。汝等皆应修菩萨行。究竟菩提具一切智。时诸天子闻是音已。心大恐怖。一向正求无上菩提。是为住兜率天第七所行事业。菩萨摩诃萨。住兜率天。不舍兜率天所坐之处。悉能往诣一切佛所。见诸如来恭敬礼拜供养听法。尔时诸佛为菩萨说甘露灌顶授记之法。一切诸明菩萨行地。欲令菩萨以一念相应慧具足一切枝。一切种深入一切智。是为住兜率天第八所行事业。菩萨摩诃萨。住兜率天。以法界虚空界等一切供养恭敬供养一切世界诸佛。见此供养时。无量无边众生发菩提心。是为住兜率天第九所行事业。菩萨摩诃萨。住兜率天。出生无量无边法门。示现一切世界中种种色种种形。种种威仪种种方便。随其所应而为说法。欲令一切众生悉欢喜故。是为住兜率天第十所行事业。佛子。是为菩萨摩诃萨住兜率天十种所行事业。若菩萨摩诃萨。具足此业。则能下生人间。佛子。菩萨摩诃萨。于兜率天临命终时。有十种示现事。何等为十。所谓菩萨于兜率天临命终时。于足下相轮放大光明。名安乐庄严。普照三千大千世界一切诸难恶道。众生触斯光者。灭一切苦皆得安乐。尔时众生咸作是念。今日忽有奇特大人出现于世。是为第一所示现事。菩萨摩诃萨。于兜率天临命终时。放眉间白毫相光。名曰觉悟。普照三千大千世界。触彼宿世同行菩萨摩诃萨身。触已咸作是念。彼菩萨摩诃萨。于兜率天今将命终。时诸菩萨即化作无量无边供养之具。疾往诣彼菩萨摩诃萨所。是为第二所示现事。菩萨摩诃萨。临命终时。于右掌中出大光明。名净境界。悉能严净三千大千世界。此世界中若有无漏诸辟支佛。觉斯光者即舍寿命。若不觉者。光明力故。徙置他方余世界中。一切诸魔及众外道。有见众生悉皆徙置他方世界。除如来住持所化众生。是为第三所示现事。菩萨摩诃萨。从其两膝放大光明。名曰离垢清净庄严。普照最下诸天宫殿。上至净居诸天宫殿无不明了。时诸天子咸作是念。今此菩萨摩诃萨。于兜率天将舍寿命时诸天子疾办供具香华璎珞涂香末香衣盖幢幡及诸音乐。诣菩萨所恭敬供养。我等咸皆随侍守护。从此命终乃至示现大般涅槃是为第四所示现事。菩萨摩诃萨。于兜率天临命终时。从其心中放大光明名曰金刚净妙庄严。普照一切世界金刚力士。尔时百亿金刚力士咸作是念。此是菩萨摩诃萨。于兜率天将欲命终故。以此相示现我等。我等咸当随侍守护。乃至示现大般涅槃。是为第五所示现事。菩萨摩诃萨。于兜率天临命终时。从一切毛孔放大光明。名曰分别一切众生。普照三千大千世界。遍触一切诸菩萨身。触已复触一切诸天世人。时诸菩萨咸作是念。我等当往诣彼。恭敬供养如来。并复教化彼诸众生。是为第六所示现事。菩萨摩诃萨。于兜率天临命终时。于摩尼宝藏正法堂中。放大光明名善调伏。随彼菩萨所降神处。普照王宫。彼诸菩萨各作是念。随此菩萨所生之处。若于其家若于聚落。若于城邑。若阎浮提内受生之处。我当生彼。为欲教化诸众生故。是为第七所示现事。菩萨摩诃萨。于兜率天临命终时。天楼阁中放大光明。名净庄严一切宫殿。放斯光明照所生母。照已彼菩萨母安隐快乐。具足成就一切功德。其母身内自然楼阁七宝庄严。为欲安处菩萨身故。是为第八所示现事。菩萨摩诃萨。于兜率天临命终时。放足下光明。名曰安住。若诸天子及诸梵天其命将终。蒙斯光故。皆得住寿供养菩萨。从此命终。乃至示现大般涅槃。是为第九所示现事。菩萨摩诃萨。于兜率天从其小相放大光明。名严净日眼。示现菩萨种种诸业。时有人天。或见菩萨在兜率天。或见命终。或见处胎。或见出生。或见舍家或见成佛。或见转法轮。或见如来大般涅槃。是为第十所示现事。佛子。菩萨摩诃萨。或于坐处。或于楼阁。或于宫殿。放如是等百万阿僧祇光。放斯光时。显现无量诸菩萨业。佛子。菩萨摩诃萨。具足如是等一切净业故。从兜率天下生世间。佛子。菩萨摩诃萨。有十种事故。降神母胎。何等为十。所谓为教化成熟小心众生故。示现处胎。不令小心众生作如是念。菩萨自然化生。善根智慧不从行得。是为第一事示现处胎。又复欲令父母诸亲。长养宿世同行善根故。是为第二事示现处胎。菩萨摩诃萨。初受胎时远离愚痴。正念思惟除灭乱想。成就念慧心未曾乱。是为第三事示现处胎。菩萨摩诃萨。处母胎时常讲说法。十方世界诸菩萨众。释梵四天王来诣菩萨。菩萨即时广为说法。示现菩萨自在神力。菩萨摩诃萨。具足成就无量无边诸智慧故。现如是等奇特之事。是为第四事示现处胎。菩萨摩诃萨。于母胎中为化众生故。令彼众生本愿满故。是为第五事示现处胎。菩萨摩诃萨。于人中成道。应具人法受生故。是为第六事示现处胎。菩萨摩诃萨。于母胎中。三千大千世界众生。普见菩萨处于母胎。如明镜中见其面像。尔时大心诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。悉诣菩萨恭敬供养。是为第七事示现处胎。菩萨摩诃萨。处母胎时。余方世界一生补处在母胎者。悉共讲说菩萨无尽智慧之藏。是为第八事示现处胎。菩萨摩诃萨。初受胎时。正受离垢三昧。一切兜率天宫。一切供养庄严之具。悉入母胎。三昧力故令其母身无诸苦患。是为第九事示现处胎。佛子。菩萨摩诃萨。处母胎时。具足成就无量无边功德藏故。十方世界一切供具。悉以供养一切如来。彼诸如来为此菩萨演说无量无边法界法门。是为第十事示现处胎。若菩萨摩诃萨。住此法门。则能示现菩萨十种微细趣。何等为十。所谓菩萨摩诃萨。处母胎时。示现初发菩提之心。乃至甘露灌顶授记之地。在母胎中。又复现处兜率陀天。在母胎中示现出生。在母胎中示现童子地。在母胎中现在宫殿色味之间。在母胎中示现出家。在母胎中现行苦行。往诣道场成等正觉。在母胎中现转法轮。在母胎中示现大般涅槃。在母胎中示现微细诸法。一切菩萨行。一切如来自在神力无量行门。佛子。是为菩萨摩诃萨十种微细趣。若菩萨摩诃萨。安住此趣。则得一切诸佛无上智慧大微细趣

大方广佛华严经卷第四十二大方广佛华严经卷第四十三

        东晋天竺三藏佛驮跋陀罗译

    离世间品第三十三之八

佛子。菩萨摩诃萨。有十种生。何等为十。所谓离愚痴生。放大光明网普照三千大千世界生。除灭一切未来世最后身生。不生生。知三界诸劫悉如幻生。于十方世界普现身生。具足一切智身生。放一切如来光明普照觉悟一切众生生。正受大智自在诸禅三昧身生。佛子。菩萨生时。一切佛刹六种震动。一切众生皆得解脱。一切恶道皆悉除灭。映蔽一切诸魔光明。悉如聚墨。无量菩萨普来云集。佛子。是为菩萨摩诃萨十种生。为欲化度众生类故。示现是生。佛子。菩萨摩诃萨。有十种大庄严而自庄严。何等为十。所谓菩萨摩诃萨。作如是念。一切世间没五欲泥。除我一人无能济彼。如是知故。发大庄严而自庄严。烦恼愚痴覆众生眼皆悉盲瞽。我今智慧自在。当普开导众生慧眼悉令清净。发大庄严而自庄严。我今因此假名身故。得如来无上清净法身。充满三世。发大庄严而自庄严。菩萨摩诃萨。以无碍净眼。悉遍观察十方一切诸梵天处。乃至大自在天处。是等众生皆自谓我成就自在智慧之力。菩萨悉能摧灭彼我慢心。发大庄严而自庄严。菩萨摩诃萨。见诸众生于过去世种诸善根今欲退没。我今还令彼诸众生住不退地。发大庄严而自庄严。欲令众生种少善根得无量果。发大庄严而自庄严。见佛无量自在神力。发大庄严而自庄严。观见过去同行菩萨。染着余事不成正觉。发大庄严而自庄严。菩萨摩诃萨。见诸天人疲顿厌倦退正希望。发大庄严而自庄严。菩萨摩诃萨。为一切如来光明触故。长养一切大正希望。发大庄严而自庄严。佛子。是为菩萨摩诃萨十种大庄严。为教化众生故。发此庄严而自庄严。佛子。菩萨摩诃萨。有十种事故游行七步。何等为十。所谓现菩萨力故游行七步。现七宝故游行七步。满地神愿故游行七步。现超出三界相故游行七步。现大象王牛王师子王最胜行故游行七步。现金刚地相故游行七步。欲与众生力故游行七步。现七觉宝相故游行七步。具足成就一切佛法不由他悟故游行七步。欲自称我于世最胜无伦匹故游行七步。佛子。是为菩萨摩诃萨十种事故游行七步。教化众生故作是示现。佛子。菩萨摩诃萨。有十种事故现童子地。何等为十。所谓书数算计刻印方便现此业故现童子地。现乘象马车乘弓射诸武艺故现童子地。欲学一切世间巧妙谈论诸嬉戏故现童子地。离身口意一切恶业故现童子地。现正向般涅槃正受三昧充满一切诸世界故现童子地。现菩萨力过天人龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵四天王故现童子地。现殊妙色出过一切释梵四天王故现童子地。欲令众生远离五欲常乐正法故现童子地。为现尊重正法供养一切世界诸如来故现童子地。常乐正法普现一切受持正法故现童子地。佛子。是为菩萨摩诃萨十种事故现童子地。佛子。菩萨摩诃萨。现童子地已。有十种事故现处中宫。何等为十。所谓令修同行者增长善根故现处中宫。欲明菩萨诸善根故现处中宫。欲着乐天人故现处中宫。于五浊世随应化故现处中宫。于深宫内正受三昧欲明菩萨功德力故现处中宫。欲令宿世同行众生满本愿故现处中宫。欲令父母亲属满本愿故现处中宫。欲以妓乐出妙法音供养一切佛故现处中宫。菩萨摩诃萨于其宫内入甚深三昧成等正觉乃至示现大般涅槃故现处中宫。随顺守护法故现处中宫。佛子。是为菩萨摩诃萨十种事故现处中宫。以此事故最后生菩萨示现出家。佛子。菩萨摩诃萨。有十种事故示现出家。何等为十所谓欲令众生厌离家故。示现出家。为着家众生故示现出家。欲现随顺诸贤圣道故示现出家。欲宣扬赞叹出家法故示现出家。欲令众生离二见故示现出家。欲令众生离欲乐我乐故示现出家。欲现出三界相故示现出家。欲显自在不由他悟故示现出家。欲随顺如来十力四无畏故示现出家。一切最后生菩萨法应尔故示现出家。佛子。是为菩萨摩诃萨十种事故示现出家。为化众生故。佛子。菩萨摩诃萨。为十种事故示现苦行。何等为十。所谓菩萨摩诃萨。欲教化成熟小心众生故示现苦行。为拔着邪见众生故示现苦行。为无业报邪见众生欲令知业报故示现苦行。为随顺五浊世界众生故示现苦行。为懈怠众生故示现苦行。欲令众生乐求法故示现苦行。为着欲乐我乐众生故示现苦行。为显菩萨殊胜行故示现苦行。欲令未来众生发精进故示现苦行。诸天世人诸根未熟待时熟故示现苦行。佛子。是为菩萨摩诃萨为十种事故示现苦行

佛子。菩萨摩诃萨。有十种事故往诣道场。何等为十。所谓欲普照一切世界。故往诣道场。为震动一切世界故往诣道场。欲于一切世界普现身故往诣道场。为觉悟一切菩萨一切众生一切同行故往诣道场。为示现道场庄严事故往诣道场。为随应受化示现庄严菩提树故往诣道场。欲对见十方世界一切佛故往诣道场。欲于举足下足念念悉入无量正受诸三昧门成等正觉故往诣道场。为受一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽乃至释梵四天王等恭敬供养各不相知故往诣道场。欲以无碍智眼普观一切世界正念一切佛于一切刹现成佛故往诣道场。佛子。是为菩萨摩诃萨十种事故往诣道场。为教化众生故。佛子。菩萨摩诃萨。有十种事故坐于道场。何等为十。所谓种种震动一切刹故坐于道场。普照一切诸世界故坐于道场。除灭一切诸恶道故坐于道场。变一切刹为金刚故坐于道场。观一切佛师子吼故坐于道场。离一切虚妄心净如虚空故坐于道场。示现随顺净身威仪故坐于道场。随顺圆满金刚三昧故坐于道场。受一切佛清净坐处故坐于道场。自善根力悉能受持一切众生故坐于道场。佛子。是为菩萨摩诃萨十种事故坐于道场。佛子。菩萨摩诃萨。坐道场时。有十种奇特未曾有法。何等为十。所谓菩萨摩诃萨。坐道场时。十方世界一切诸佛。观此菩萨咸举右手赞言。善哉善哉无上导师。是一奇特未曾有法。菩萨摩诃萨。坐道场时。一切如来应供等正觉皆悉护持。是二奇特未曾有法。菩萨摩诃萨。坐道场时。宿世同行菩萨悉来云集。以种种庄严具恭敬供养。是三奇特未曾有法。菩萨摩诃萨。坐道场时。十方一切世界草木丛林非众生类。皆悉曲躬归向道场。是四奇特未曾有法。菩萨摩诃萨。坐道场时。正受三昧名善知法界。得此三昧故究竟菩萨一切诸行。是五奇特未曾有法。菩萨摩诃萨。坐道场时。得陀罗尼。名曰离垢胜妙海藏。菩萨摩诃萨。住此陀罗尼故。一切诸佛降甘露法雨此菩萨。是六奇特未曾有法。菩萨摩诃萨。坐道场时。以神通力。恭敬供养一切诸佛。是七奇特未曾有法。菩萨摩诃萨。坐道场时。入于无上智慧法门善巧方便。悉知一切众生诸根。是八奇特未曾有法。菩萨摩诃萨。坐道场时。正受三昧名曰善觉。菩萨摩诃萨。入此定已得净法身。满虚空界一切三世。是九奇特未曾有法。菩萨摩诃萨。坐道场时。清净身业摄取三世。无碍智慧普照一切。是十奇特未曾有法。佛子。是为菩萨摩诃萨坐道场时得十种奇特未曾有法。佛子。菩萨摩诃萨。坐道场时。有十种义故示现降魔。何等为十。所谓五浊恶世众生乐相征伐。欲显菩萨功德力故。示现降魔。悉灭天人诸疑惑故。示现降魔。为欲化度魔眷属故。示现降魔。诸天世人乐征伐者令集受化故。示现降魔。集天人已显现菩萨功德之力不可破坏调伏众生故示现降魔。发起一切众生力故。示现降魔。哀愍未来一切众生故。示现降魔。乃至道场现有魔事。悉能超出众魔境故。示现降魔。显现烦恼力势羸劣。大悲善根势强盛故。示现降魔。顺五浊世诸众生故。示现降魔。佛子。是为菩萨摩诃萨十种义故坐道场时示现降魔。佛子。菩萨摩诃萨。有十种觉如来力。何等为十。所谓超出一切众魔事业除灭烦恼。究竟一切菩萨所行。觉如来力。于一切菩萨三昧而得自在。觉如来力。具足成就一切菩萨诸禅三昧。觉如来力。满足一切诸白净法。觉如来力。分别善法调伏世间法。觉如来力。以净法身满一切刹。觉如来力。所出净音悉与一切众生心等。觉如来力。悉能受持一切佛法。觉如来力。得与三世如来身口意等。于一念中知三世法。觉如来力。得善觉三昧具佛十力。所谓是处非处智乃至漏尽智。觉如来力。佛子。是为菩萨摩诃萨十种觉如来力。菩萨摩诃萨。具此力故得名如来。佛子。如是得成如来应供等正觉已。能转十行清净法轮。何等为十。一者具足清净四无所畏。二者出生四辩净妙音声。三者明了四谛。四者随顺诸佛无碍法门。五者清净等心悉能普覆一切众生。六者所说不虚决定济度众生苦际。七者宿世大悲所持。八者以妙法音充满世界一切众生无不闻知。九者阿僧祇劫常说正法未曾暂息。十者转诸根力觉意解脱诸禅三昧相续不绝。佛子。如来应供等正觉。转如是十行等无量行法轮。佛子。如来应供等正觉。清净法轮。因十种白净法故。转入众生心。出生无相。决定不虚。何等为十。所谓过去愿力故。大悲所持故。不舍众生故。智慧自在随其所应为说法故。未曾失时故。随彼法器不增减故。决定了知三世智故。身行最胜故。口行无虚故。智行随音声悉觉悟故。佛子。是为因十种白净法故能转法轮入众生心出生无相决定不虚。佛子。如来应供等正觉。究竟佛事已。有十种义。示现大般涅槃。何等为十。所谓明一切行悉无常故。明一切有为非安隐故。明般涅槃趣最安隐故。明般涅槃远离一切诸怖畏故。以诸天人乐着色身。明色身无常是磨灭法。令求常住净法身故。明无常力强不可转故。明有为法不随爱行不自在故。明三界法悉如坯器无坚牢故。明般涅槃最为真实不可坏故。明般涅槃远离生死非起灭故。佛子。以此十种义故。如来应供等正觉示现大般涅槃。佛子。一切如来应供等正觉法皆如是。所愿已成已转法轮。所应度者皆悉已度。已与菩萨授尊记号。一切佛事皆悉究竟。安住不变示现大般涅槃。佛子。是为如来应供等正觉以十义故示现大般涅槃

佛子。是为菩萨摩诃萨清净胜行大妙法门。诸佛所说无量深义。能令一切诸有智者皆悉欢喜。究竟一切菩萨大愿。不断所行。佛子。若有众生闻此经者。信心清净不起诽谤。如说修行。彼诸众生。速成阿耨多罗三藐三菩提。何以故。菩萨摩诃萨如说行故。佛子。是故菩萨摩诃萨。应如说行一心敬信受持此经。佛子。此经出生一切菩萨诸行功德深妙义华。深入智慧。摄一切法门。远离世间。声闻缘觉一切众生所不共法。悉能普照一切法门。长养善根度脱众生。是故菩萨摩诃萨。应一心听受护持此经。若菩萨摩诃萨。受持此经。则能出生一切诸愿。以少方便疾得阿耨多罗三藐三菩提。说此出生一切菩萨诸行功德深妙义华深入智慧摄一切法门远离世间声闻缘觉一切众生所不共法悉能普照一切法门长养善根度脱众生经时。佛神力故。此经法如是故。十方无量阿僧祇世界六种震动。大光普照。尔时十方诸佛面对观视普贤菩萨欢喜赞言。善哉佛子。乃能说此出生一切菩萨诸行功德深妙义华深入智慧摄一切法门远离世间声闻缘觉一切众生所不共法悉能普照一切法门长养善根度脱众生经。佛子。汝已善学此法。善知此法。快说此法。我等诸佛亦说此法。一切诸佛亦复如是。是故佛子。我等悉共守护此经。令未来菩萨未闻者闻。尔时普贤菩萨。承佛神力。观察十方一切大众一切法界。以偈颂曰

  无量无数劫　　勤修诸苦行
  供养无量佛　　生此真佛子
  化度无量众　　安立无上道
  菩萨无等行　　我说善谛听
  供养无量佛　　皆悉无染着
  化度一切众　　不起众生想
  常求佛功德　　其心无所依
  说彼胜妙行　　令众悉欢喜
  降伏一切魔　　灭三界烦恼
  已具圣功德　　示现童子地
  灭恶烦恼痴　　其心常寂然
  示现无量行　　我说彼功德
  远离一切恶　　究竟到彼岸
  无量众生中　　种种现变化
  知心生住灭　　示现一切事
  说彼妙功德　　令众悉欢喜
  见三有众生　　无量苦逼迫
  流转于生死　　烦恼火炽然
  欲令彼解脱　　一向求菩提
  略说彼净德　　一心善谛听
  施戒忍精进　　禅定得自在
  具足慧方便　　大慈度众生
  无量无数劫　　乐修悲喜舍
  我说彼功德　　仁等当谛听
  枯槁无量身　　常正求菩提
  不惜其寿命　　究竟无上道
  常为利众生　　不求自安乐
  慈悲心牟尼　　我说彼胜行
  无量无数劫　　说少分不尽
  虚空可度量　　海水可渧数
  菩萨功德海　　无可为譬谕
  饶益众生故　　略说其小分
  持众生善根　　长养白净法
  远离憍慢心　　求法无厌足
  令众得安止　　长养智慧树
  菩萨心如地　　饶益一切众
  柔软慈心根　　无上大悲茎
  功德叶智华　　持戒为妙香
  如来净慧光　　开敷菩萨华
  不著有为水　　普令众生喜
  直心为种子　　慈悲为根芽
  智慧方便茎　　五度为枝条
  禅叶诸明华　　一切智为果
  法树神力鸟　　普覆三世间
  真实谛为足　　白净法为身
  正念为颈顶　　智首解脱顶
  慈悲明净眼　　实义幽谷出
  菩萨法师子　　调伏一切魔
  生死为旷野　　烦恼诸恶道
  边见为贼难　　痴盲迷正路
  菩萨大导师　　见彼迷冥者
  开示其正道　　引至安隐处
  贪恚诸烦恼　　常恼害众生
  无量众苦患　　长夜而逼切
  菩萨见彼苦　　为发大悲心
  具说八万四　　对治济度之
  菩萨为法王　　正道化众生
  远恶修众善　　一向求菩提
  一切诸佛所　　受自在智记
  广施贤圣珍　　令具七觉宝
  清净戒为毂　　精进以为辐
  三昧正受辋　　三转净法轮
  清净心为楯　　明利智慧剑
  摧灭诸烦恼　　外道众魔怨
  甚深智慧海　　正法一味水
  禅觉宝充满　　一切莫能知
  直心净弥广　　一切智为潮
  菩萨智慧海　　演说不可尽
  世间高无上　　于彼无所著
  禅明智慧山　　坚正不倾动
  若有亲近者　　疾得同彼慧
  住智须弥顶　　普观一切世
  深心如金刚　　一切悉坚固
  三宝一切智　　信心不可坏
  降伏一切魔　　除灭诸烦恼
  安住无所畏　　度脱诸群生
  兴起大慈云　　普覆于一切
  明曜大悲电　　雷震法洪音
  四辩澍法雨　　八正甘露水
  除灭烦恼火　　安住一切义
  白净法为城　　智慧为墙壁
  无上智楼阁　　惭愧为深堑
  三空解脱门　　正念为防守
  四道为正路　　游之出三界
  建无上法幢　　摧灭一切魔
  法身金翅鸟　　四如意为足
  慈悲明净眼　　住一切智树
  菩萨金翅王　　生死大海中
  搏撮天人龙　　安置涅槃岸
  净戒圆满日　　清净智光明
  神足为疾行　　消竭爱欲水
  觉长夜众生　　长养根力药
  菩萨明净日　　一切无不照
  圆满法界月　　众生观无厌
  映蔽于二乘　　小智萤火光
  菩萨清凉月　　游于毕竟空
  垂光照三界　　心法无不现
  自在诸法王　　功德色严身
  方便净智眼　　安住胜妙法
  相好庄严身　　一切观无厌
  彼法自在王　　如法治众生
  除灭欲烦恼　　超出于三界
  常乐勤修习　　慈悲喜舍法
  菩萨大梵王　　普现种种身
  演出净妙音　　三界无不闻
  远离一切行　　境界常清净
  逮得不退智　　具足法自在
  永离二乘道　　诸佛所授记
  乘于无上乘　　究竟一切智
  心净如虚空　　永离一切有
  行于世间事　　其心无所依
  究竟白净行　　亦令众生然
  菩萨慧弥广　　清净如虚空
  无量方便地　　饶益诸群生
  清凉慈悲水　　消灭炽烦恼
  智慧猛盛火　　烧尽烦恼习
  风驰游十方　　广作诸佛事
  菩萨如意宝　　除灭众贫苦
  智慧如金刚　　摧灭诸邪见
  无量德庄严　　悉令众生喜
  究竟无上行　　安住如来处
  菩萨功德华　　七觉令开敷
  诸愿为宝鬘　　严饰世间顶
  菩萨净戒香　　远离诸恶戒
  以此净戒香　　涂熏一切众
  菩萨无上盖　　普覆诸世间
  建立智慧幢　　摧灭众魔幢
  菩萨庄严行　　净妙智慧幡
  惭愧功德衣　　普覆一切众
  菩萨无上乘　　乘之出三界
  其心善调顺　　安住宝象王
  菩萨大龙王　　具足自在力
  普降甘露法　　泽润诸群生
  菩萨甚难值　　犹如优昙华
  降伏一切魔　　除灭诸烦恼
  佛所转法轮　　彼能随顺转
  慧灯除众闇　　普令见正道
  菩萨功德河　　随顺正道流
  常为生死桥　　度人无休息
  菩萨正法船　　泛游诸愿海
  智慧悉成满　　度人到彼岸
  菩萨净园林　　实乐乐众生
  正法解脱华　　明净智宫殿
  菩萨雪山顶　　出生药树王
  除灭烦恼病　　悉令一切喜
  菩萨等如来　　觉悟诸众生
  除灭愚痴闇　　得成等正觉
  最胜所从来　　菩萨如是来
  逮得平等智　　究竟到彼岸
  菩萨大导师　　教化诸群生
  自然成正觉　　一切智境界
  具足无量力　　一切莫能坏
  安住无所畏　　知法了众生
  乃至色界中　　所有诸众生
  一切语言音　　皆悉能随顺
  过色至无色　　现彼一切事
  一切诸众生　　说之不能尽
  菩萨悉成就　　如是等功德
  解了性非性　　所有无所有
  具足真实智　　除灭一切缚
  究竟一切智　　其心无所著
  说彼甚深行　　令众悉欢喜
  了达一切法　　皆悉如幻化
  发起方便悲　　一切佛护持
  出生智化门　　普现无量事
  仁等当谛听　　菩萨诸功德
  一身无边际　　普现无量身
  非心非心境　　应现一切众
  出于一妙音　　究竟语言法
  悉摄众生类　　一切语言音
  远离烦恼身　　随应示现身
  无量方便身　　一切音说法
  其心常寂灭　　清净如虚空
  以心庄严刹　　示现一切众
  示现种种身　　于彼无所著
  远离一切生　　亦不坏彼因
  随顺一切趣　　受生无所著
  了身如虚空　　随其所应现
  菩萨现如是　　无量无边事
  恭敬供养彼　　最胜两足尊
  涂香末香华　　幢盖幡音乐
  无上供养具　　直心供诸佛
  不离一佛会　　普在诸佛所
  善巧能问难　　听受深妙法
  闻此正法故　　逮得诸三昧
  一一三昧中　　生无量定门
  又复能普现　　无量三昧起
  智慧巧方便　　究竟到彼岸
  觉悟一切法　　皆悉如幻化
  示现种种身　　出生无量音
  入众生想网　　其心无染着
  或时现众生　　随顺世间义
  或示菩提行　　无量无有边
  布施持净戒　　忍辱勤精进
  定慧四无量　　修行四摄法
  或现行成满　　或得无生忍
  或受灌顶记　　或一生补处
  或现声闻乘　　或复现缘觉
  无量刹涅槃　　不舍菩萨行
  或现为帝释　　或现梵天王
  或天女围绕　　或复独宴默
  或现比丘像　　净戒调诸根
  或现自在王　　或现入法网
  或现巧术女　　或现修苦行
  或现在五欲　　或复在禅定
  或现般涅槃　　或复现受生
  或现童子身　　或复现衰老
  若有思议者　　迷乱心发狂
  或在天宫殿　　或现终下生
  或现处母胎　　成佛转法轮
  或复现出生　　或现般涅槃
  或现童子术　　或复现出家
  或现坐道场　　或成无上道
  或复示现转　　自在正法轮
  或现求正法　　或现为佛身
  充满无量刹　　不退菩萨行
  深入无量劫　　究竟到彼岸
  无量劫一念　　一念无量劫
  一切劫非劫　　示现众生劫
  无来无积聚　　示现诸劫事
  于一微尘中　　普见一切佛
  一切诸群生　　无处不有佛
  一切诸佛刹　　及众生境界
  悉能分别知　　一切诸法印
  一切劫可尽　　法印无穷已
  如是知众生　　无量无有边
  彼一众生有　　无量百千万
  那由他等身　　因缘亦如是
  如彼一众生　　一切亦复然
  如是究竟知　　亦令一切学
  悉知众生根　　上中下不同
  诸根常流转　　知是器非器
  一根一切根　　展转相依持
  菩萨微细智　　皆悉分别知
  亦知诸欲性　　种种烦恼垢
  了过去心行　　未来今现在
  悉知众生行　　究竟到彼岸
  知行无所行　　为众说妙法
  如是知心行　　染污及清净
  菩萨一念中　　逮得一切智
  深入如来心　　究竟难思议
  一念悉能知　　诸佛无上智
  究竟神力智　　具足诸通明
  能于一念中　　悉诣十方刹
  如是疾游行　　无量无数劫
  不离本坐处　　安住甚深法
  犹如工幻师　　种种现形色
  非色非无色　　幻化无所有
  菩萨亦如是　　深知广方便
  示现众变化　　充满一切世
  譬如明净日　　出现于世间
  悉能除众冥　　一切靡不照
  菩萨智慧日　　明净甚圆满
  出净心境界　　普照一切法
  犹如人梦中　　造作种种事
  无量劫可尽　　梦性无穷尽
  菩萨于一念　　示现梦等法
  无量劫可尽　　智慧无终极
  常乐居山泽　　远离世间语
  究竟语言道　　其心无染着
  菩萨悉了知　　诸法真实性
  普说众生音　　不起虚妄想
  譬如春月时　　众生见焰气
  愚者谓为水　　寻之增渴爱
  菩萨如是见　　众生烦恼覆
  如焰增渴爱　　一向求解脱
  知众生非实　　而更增大悲
  观色如聚沫　　受如水上泡
  想如春时焰　　众行如芭蕉
  心如工幻师　　示现种种事
  善分别五阴　　其心无所著
  诸入悉空寂　　远离自在事
  诸界无实性　　示众生界分
  第一真实谛　　决定寂灭性
  广演分别法　　而心不染着
  菩萨知五阴　　无有去来今
  因由烦恼业　　转此三苦轮
  演说缘起法　　非有亦非无
  深解真实义　　于彼无所著
  菩萨净智慧　　解说三世法
  示现诸群生　　皆悉是一念
  欲色无色界　　示现众生事
  三乘戒解脱　　究竟一切智
  了知处非处　　知业知诸根
  欲性诸烦恼　　一切至处道
  宿命智天眼　　除灭诸烦恼
  知佛十种力　　而犹未究竟
  随顺诸佛法　　深解诸法空
  悉灭众烦恼　　而不尽诸漏
  广入甚深道　　教化诸群生
  佛子住无畏　　不舍菩萨行
  无谬无漏失　　亦不舍正念
  精进欲三昧　　智慧无损减
  三种常清净　　明达于三世
  大慈念众生　　一切无障碍
  深入诸法门　　具足如是行
  我说其少分　　庄严功德义
  无量无数劫　　说之不可尽
  我所说少分　　如大地一尘
  常依如来智　　而亦无所依
  常修奇特想　　大悲坚强故
  安住清净戒　　常勤修精进
  教化诸群生　　授真佛子记
  究竟佛功德　　知刹知众生
  分别三世劫　　其心无疲倦
  具陀罗尼力　　深解真实义
  思惟无等法　　逮得无上道
  一切妙功德　　发愿求菩提
  慈悲因缘力　　令菩提净胜
  具足波罗蜜　　随顺善究竟
  决定诸智力　　觉悟无上道
  成就方便智　　乐说甚深法
  随顺常守护　　逮得法王处
  安住胜妙法　　于彼无所著
  出生智慧化　　觉悟胜菩提
  住持一切劫　　菩萨得正望
  安住甚深法　　除灭众生疑
  修习甚深智　　善能分别法
  究竟定慧境　　觉悟一切智
  智入诸解脱　　究竟到彼岸
  具足诸通明　　离垢清凉园
  具足白净法　　示现种种行
  普现庄严法　　皆悉不可议
  善知众生心　　能说令究竟
  清净菩提印　　智光照一切
  一切莫能称　　远离懈怠法
  安住如山王　　具功德智海
  金刚妙宝法　　安住大庄严
  究竟诸大事　　一切莫能坏
  得授菩提记　　安住广大心
  得佛无尽藏　　觉悟一切法
  世智常自在　　游戏诸神通
  一切法境界　　自在无障碍
  身愿行自在　　智慧亦自在
  无量亿自在　　示现于一切
  具足诸自在　　游戏诸通力
  深入佛境界　　一切莫能坏
  黠慧所庄严　　无畏不共法
  修行佛子业　　远离一切恶
  清净身身业　　清净口口业
  诸佛守护故　　成办十大事
  心心所起住　　显现无上事
  安住诸根定　　逮得最胜根
  清净正直心　　远离诸谄曲
  深入众生性　　示现种种事
  除灭烦恼习　　究竟无上行
  具足深智慧　　逮得一切智
  远离一切恶　　方便趣寂灭
  出生功德道　　善学一切学
  无量道心境　　修习无所著
  安住深智慧　　示现道庄严
  手足及心腹　　无上智慧藏
  其心如金刚　　智慧为器仗
  智慧观察顶　　深入菩提行
  清净戒为鼻　　除灭诸炽然
  四辩广长舌　　无处不至身
  净妙智慧心　　诸善行为行
  道场安隐住　　师子座为坐
  梵住为安卧　　无碍第一义
  观察善逝智　　普照于一切
  遍观众生行　　种种妙功德
  以此为奋迅　　离贪为净施
  不慢清净戒　　不动为净忍
  不转净精进　　自在为净禅
  不行愚痴智　　虚空慈普救
  不忧恼为悲　　清净法为喜
  离诸烦恼舍　　寂静为深义
  境界为正法　　回向功德具
  智具如利剑　　普照为众明
  闻法无厌足　　是为正求法
  不惜身寿命　　是为明正法
  随顺诸佛教　　除灭诸魔道
  清净正直心　　摄取诸佛业
  远离众魔业　　长养诸智慧
  远离魔所持　　安住诸佛持
  究竟得法持　　住无住智慧
  作业已命终　　降神入母胎
  示现微细趣　　又复现出生
  现称我最胜　　示现行七步
  现为童子地　　复现处深宫
  现出家学道　　庄严诸道场
  普放无量光　　觉悟诸群生
  降伏一切魔　　得成无上道
  现转净法轮　　示现如来地
  增长白净法　　现大般涅槃
  菩萨修诸行　　无量无有边
  如我向所说　　略举其少分
  无量劫修习　　令众住菩提
  众生诸法行　　于彼无染着
  如是具足行　　成就力自在
  以无量诸刹　　安置一毛道
  掌持无量刹　　遍游诸世界
  还置于本处　　众生无恐怖
  菩萨以一切　　严净诸佛刹
  安置一毛孔　　众生无不见
  能以一毛孔　　悉受一切海
  大海不增减　　众生无娆害
  示现如是等　　一切诸事相
  无量金刚山　　手摩为微尘
  以此一切尘　　遍散诸佛刹
  复末尘下刹　　遍布余世界
  一切尘可知　　智慧不可尽
  于一毛孔中　　放演净光明
  普照一切世　　悉蔽日月光
  珠火天神光　　隐没悉不现
  除灭恶道苦　　为说无上法
  菩萨一言音　　出生一切音
  一切诸众生　　无不悉闻者
  以闻此法音　　皆得大欢喜
  具足广宣畅　　诸佛所说法
  过去一切劫　　安置未来今
  未来现在劫　　回置过去世
  十方一切刹　　皆悉现成坏
  以一切众生　　安置一毛道
  过去及现在　　一切诸如来
  具足自在力　　悉于身中现
  深知变化法　　善能随所应
  普现无量身　　于彼悉无著
  帝释梵王身　　四天大王身
  诸天清净身　　一切众生身
  声闻缘觉身　　如来清净身
  普现一切身　　善修菩萨行
  现入众想网　　上中下诸品
  一切智所持　　普现佛及刹
  具足深智慧　　除灭诸想网
  示现菩萨行　　究竟成菩提
  示现如是等　　无量自在力
  一切无不现　　举世莫能知
  示现无所现　　究竟无有上
  随顺应众生　　为说决定行
  净身等虚空　　妙音满世间
  净戒为涂香　　惭愧衣普覆
  离垢正法缯　　一切智摩尼
  功德庄严身　　拜署无上王
  波罗蜜金轮　　诸通为象宝
  神足为马宝　　净慧无上珠
  妙行为女宝　　四摄宝藏臣
  方便主兵宝　　无上转轮王
  胜妙三昧城　　空观妙宫殿
  慈悲大庄严　　智慧为利剑
  坚强正念弓　　明利根为箭
  诸佛护持盖　　建立智慧幢
  直入诸魔军　　忍力悉摧灭
  陀罗尼平地　　净妙行流水
  深智为涌泉　　净慧清凉林
  空为澄净池　　七觉妙华敷
  神足以庄严　　三昧为娱乐
  法门为歌颂　　思惟正法女
  甘露法之食　　解脱味为浆
  御调顺三乘　　游戏无上园
  此等诸胜行　　及余无上法
  无量劫修学　　其心无疲倦
  供养一切佛　　严净一切刹
  普令一切众　　安住一切智
  一切刹微尘　　悉可知其数
  一切虚空界　　皆悉可度量
  一切众生心　　念念可知数
  佛子诸功德　　说之不可尽
  欲具此功德　　及余胜妙法
  欲灭一切苦　　安乐诸群生
  欲与诸如来　　身口意齐等
  应发金刚心　　究竟此胜行

大方广佛华严经卷第四十三大方广佛华严经卷第四十四

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之一

尔时佛在舍卫城祇树给孤独园。大庄严重阁讲堂。与五百菩萨摩诃萨俱。普贤菩萨。文殊师利菩萨。而为上首。夜光幢菩萨。须弥山幢菩萨。宝幢菩萨。无碍幢菩萨。华幢菩萨。离垢幢菩萨。日光幢菩萨。正幢菩萨。离尘幢菩萨。明净幢菩萨。大地端严菩萨。宝端严菩萨。大慧端严菩萨。金刚智端严菩萨。离垢端严菩萨。法日端严菩萨。功德山端严菩萨。智光端严菩萨。普妙德端严菩萨。大地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。净德藏菩萨。法印藏菩萨。明净藏菩萨。脐藏菩萨。莲华藏菩萨。善德眼菩萨。普见眼菩萨。清净眼菩萨。离垢眼菩萨。无碍眼菩萨。普眼菩萨。善观眼菩萨。青莲华眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。善眼菩萨。天冠菩萨。普照法界慧天冠菩萨。道场天冠菩萨。普照十方天冠菩萨。生诸佛藏天冠菩萨。一切世间最上天冠菩萨。明净天冠菩萨。无量宝天冠菩萨。受一切如来师子座天冠菩萨。普照法界虚空天冠菩萨。梵王周罗菩萨。龙王周罗菩萨。一切佛化光明周罗菩萨。道场周罗菩萨。一切愿海音摩尼宝王周罗菩萨。出生如来光众宝自在周罗菩萨。庄严一切虚空宝摩尼宝王周罗菩萨。一切如来自在光幢摩尼王网普覆周罗菩萨。一切佛音转法轮周罗菩萨。三世慧音周罗菩萨。大光菩萨。离垢光菩萨。宝光菩萨。离尘光菩萨。夜光菩萨。法光菩萨。寂静光菩萨。日光菩萨。自在光菩萨。天光菩萨。功德幢菩萨。智幢菩萨。法幢菩萨。诸通幢菩萨。光幢菩萨。华幢菩萨。摩尼幢菩萨。菩提幢菩萨。梵幢菩萨。普光幢菩萨。梵音菩萨。海音菩萨。大地音菩萨。世主音菩萨。山相击音菩萨。充满一切法界音菩萨。一切法海雷音菩萨。降伏一切魔音菩萨。大悲方便云雷音菩萨。灭一切苦安慰音菩萨。法上菩萨。胜上菩萨。智上菩萨。功德须弥山上菩萨。功德珊瑚上菩萨。称上菩萨。普光上菩萨。大慈上菩萨。智海上菩萨。如来性起上菩萨。光妙德菩萨。胜妙德菩萨。上妙德菩萨。明净妙德菩萨。法妙德菩萨。月妙德菩萨。虚空妙德菩萨。宝妙德菩萨。妙德幢菩萨。智妙德菩萨。娑罗林王菩萨。法王菩萨。众生王菩萨。梵王菩萨。山王菩萨。宝王菩萨。离生王菩萨。寂静王菩萨。不动王菩萨。仙王菩萨。胜王菩萨。寂静音菩萨。无碍音菩萨。说大地音菩萨。大海雷音菩萨。云音菩萨。法光音菩萨。虚空音菩萨。一切众生善根雷音菩萨。开悟过去愿音菩萨。圆满道音菩萨。智须弥山音菩萨。虚空觉菩萨。离垢觉菩萨。无碍觉菩萨。善觉菩萨。普照三世觉菩萨。广觉菩萨。普光觉菩萨。法界光觉菩萨。如是等五百菩萨。此诸菩萨皆悉出生普贤之行。境界无碍。充满一切诸佛刹故。持无量身。悉能往诣一切佛故。具足无碍净眼。见一切佛明自在故。至无量处一切诸佛成正觉时。悉能往诣现前见佛无休息故。无量智光。普照一切诸法海故。于无量劫说不可尽辩清净故。究竟虚空界。智慧境界悉清净故。无所依止。随其所应现色身故。除灭痴曀。善分别知众生界故。虚空智慧放大光网。普照一切诸法界故。复与五百大声闻俱。悉觉真谛证如实际。深入法性离生死海。安住如来虚空境界。离结使缚不着一切。游行虚空。于诸佛所疑惑悉灭。深入信向诸佛大海。复与诸天王俱。悉已恭敬供养过去诸佛。长夜饶益一切众生。心常行慈未曾忘失。守护群生入胜智门。不舍一切众生。出生诸佛正法境界。守护佛法受持佛性。生如来家专求一切智门

尔时诸菩萨声闻天人及其眷属。咸作是念。如来行。如来智境界。如来持。如来力。如来无畏。如来三昧。如来住。如来胜妙功德。如来身。如来智。如来法。一切天人无能知。无能度。无能得底。无能受。无能思惟。无能观察。无能分别。无能开发。无能宣明。无能为人如实解说。除佛持力。自在力。威神力。如来本愿力。过去善根力。亲近善知识力。清净信心方便力。乐求胜妙法力。清净正直菩提心力。深心一切智愿力。又诸大众种种意。种种欲。种种解。种种语。种种地。种种根。种种方便。种种心境界。种种依如来功德。种种乐闻法。世尊往昔发一切智。愿求一切智。菩萨诸愿清净波罗蜜。菩萨诸地。菩萨满足行。菩萨庄严。菩萨方便庄严。菩萨道庄严。菩萨出生方便海庄严。菩萨自在庄严。菩萨本生海。菩提门自在海。如来自在转法轮。如来刹清净自在。如来方便庄严众生界。如来法王法。如来道明普照一切。如来自在入一切众生处。如来为一切众生作最上福田。如来为一切众生说功德达嚫。三轮化度一切群生。唯愿世尊。大悲慈愍具足显现。尔时世尊。知诸大众心之所念。以大悲身。大悲门。大悲为首。大悲随顺方便法。入师子奋迅三昧。令一切众生乐清净法。入三昧已。时大庄严重阁讲堂忽然广博无量无边不可破坏。金刚宝地清净庄严。一切摩尼宝王遍布其地。散无量宝华。奇妙众宝琉璃为柱。以明净宝而庄严之。众宝庄校微密无间。阎浮檀宝以为楼阁。众宝栏楯却敌竂向。阿僧祇栏楯而以庄饰。诸天王宝。坚固众宝而庄严之。摩尼宝网弥覆其上。建众宝幢悬诸幡盖。放大光网普照法界。又以不可说众杂妙宝庄严其外。四边阶道众宝合成。尔时佛神力故。令祇洹林忽然广博。与不可说佛刹微尘数世界等。众宝庄严不可说宝遍布其地。阿僧祇宝以为垣墙。宝多罗树列植道侧。无量香河微流盈满。一切宝华以为波浪。皆悉右旋。演说一切佛法音声不可思议。分陀利华皆悉开敷。弥布水上。众宝华树高显荣茂。列植其岸。不可思议楼阁摩尼宝网罗覆其上。阿僧祇。妙宝庄严光明普照。阿僧祇摩尼宝王严饰其地。出众妙香。建立无量摩尼王幢香幢。衣幢幡幢。缯幢华幢。庄严具幢。鬘幢。宝垂带幢。众宝盖幢。大摩尼幢。普照摩尼宝幢。出佛音幢。师子宝王幢。出一切佛本生海幢。一切法界幢。摩尼宝王幢。以为庄严。时祇洹林上虚空中。有不可思议天宝宫殿云。不可思议众香树云。不可说须弥山云。庄严虚空。不可说不可说众宝乐器。演妙法音赞咏如来。不可说宝树云弥覆虚空。不可说众宝座云覆以宝衣。菩萨处上叹佛功德。不可说天宝像云以为庄严。不可说白净真珠网云以为庄严。不可说解脱楼阁云以为庄严。不可说妙解脱音乐云雨以为庄严。何以故。如来善根不可思议故。如来白净法不可思议故。如来威神不可思议故。如来一身充满一切法界自在不可思议故。一切佛刹庄严入一佛身不可思议故。一微尘中现一切佛一切法界不可思议故。一毛孔中尽过去际一切如来次第显现不可思议故。放一光明照一切刹不可思议故。如来一毛孔中出一切佛刹微尘等化身云充满一切世界不可思议故。如来一毛孔中现一切佛刹成坏不可思议故。如此祇树给孤独园见严净佛刹。一切法界虚空界一切世界所见严净亦复如是。如来充满来诣祇洹。菩萨充满一切如来大众海安住。普雨一切妙庄严云。雨一切众宝光明普照一切摩尼王云。雨一切盖云。庄严一切天身云。雨一切华树云。庄严一切杂色衣云。雨一切鬘云。流注庄严一切摩尼宝王庄严云。雨一切众生身杂色香云。雨宝华云。诸天女云。各持妙宝。于虚空中回转庄严。一切众宝。钵昙摩华。杂宝师子座。庄严虚空

尔时东方。过不可说佛刹微尘等世界海。有世界。名金刚云明净灯庄严。佛号明净妙德王。彼大众中有菩萨。名明净愿光明。与不可说佛刹微尘等菩萨俱来向此土。兴种种云庄严虚空。所谓兴天华云。散天末香云。垂天鬘带云。雨天宝云。天庄严云。天宝盖云。天宝衣云。天幢盖云。充满虚空。以可悦乐众宝庄严。来诣佛所礼拜供养。即于东方化作一切庄严楼阁宝莲华藏师子之座。如意宝网罗覆其身。与其眷属结跏趺坐。南方过不可说佛刹微尘等世界。有世界。名金刚藏。佛号普照妙德王。彼大众中有菩萨。名不可坏精进势王。与不可说佛刹微尘等菩萨俱来向此土。皆悉赍持一切妙香。神力持故。普熏一切佛世界海。执持一切摩尼宝网。华鬘璎珞。宝衣宝像。妙德光明诸庄严具。一切妙师子宝以为庄严。神力持故充满一切诸佛世界。来诣佛所礼拜供养。即于南方。化作白净妙宝楼阁普照十方宝莲华藏师子之座。结跏趺坐。以宝华网罗覆其身。西方过不可说佛刹微尘等世界。有世界名宝灯须弥山幢。佛号法界智灯。彼大众中有菩萨。名无上普妙德王。与世界海微尘等菩萨俱来向此土。兴不可说佛刹微尘等种种色香须弥山云。充满一切法界。不可说佛刹微尘等种种色香水须弥山云。充满一切法界。不可说佛刹微尘等种种色摩尼宝王须弥山云。充满一切法界。不可说佛刹微尘等种种色光明庄严宝幢须弥山云。充满一切法界。不可说佛刹微尘等种种色金刚藏摩尼宝王须弥山云。充满一切法界。不可说佛刹微尘等阎浮檀宝幢须弥山云。充满一切法界。不可说佛刹微尘等摩尼宝王遍照一切法界须弥山云。普覆虚空。一切如来不可说佛刹微尘等相好摩尼宝王普照须弥山云。充满一切众生境界。一切如来为菩萨时不可说佛刹微尘等所行须弥山云。充满法界。一切如来示现不可说佛刹微尘等庄严道场。来诣佛所礼拜供养。即于西方。化作一切香王楼阁以真珠宝网罗覆其上。如帝释幢宝莲华藏师子之座。结跏趺坐。金色宝网罗覆其身。如意宝王为髻明珠。北方过不可说佛刹微尘等世界。有世界。名宝衣光明幢。佛号法界虚空妙德。彼大众中有菩萨。名无碍妙德藏王。与世界海微尘等菩萨俱来向此土以一切宝缯云庄严虚空。神力持故充满虚空。杂宝衣云。杂香熏衣云。日幢摩尼宝衣云。金色妙衣云。众宝网衣云。阎浮檀金色庄严衣云。白净宝衣云。明净宝王衣云。妙光宝衣云。海庄严宝王衣云。庄严虚空。神力持故皆悉充满一切虚空。来诣佛所礼拜供养。即于北方。化作大海摩尼宝王楼阁琉璃宝莲华藏师子之座。结跏趺坐。妙宝王网罗覆其身。清净宝王为髻明珠。东北方过不可说佛刹微尘等世界。有世界。名放离垢欢喜光明网。佛号无碍眼。彼大众中有菩萨。名法界善化愿月王。与世界海微尘等菩萨俱来向此土。兴宝楼阁云。皆悉充满一切世界。香楼阁云。香烟楼阁云。华楼阁云。栴檀楼阁云。金刚楼阁云。摩尼楼阁云。金楼阁云。宝衣楼阁云。钵昙摩楼阁云。皆悉普覆一切佛刹。来诣佛所礼拜供养。即于东北方。化作一切法界门宝山楼阁不可称香王宝莲华藏师子之座。结跏趺坐。摩尼华网罗覆其身。妙庄严藏摩尼宝王以为天冠。东南方过不可说佛刹微尘等世界。有世界。名香云庄严幢。佛号龙自在王。彼大众中有菩萨。名法义慧焰王。与世界微尘等菩萨俱来向此土。兴无量金色圆满光云。普覆虚空。无量宝色圆满光云。佛白毫相圆满光云。众宝杂色圆满光云。宝莲华藏圆满光云。众宝树华圆满光云。如来无见顶相圆满光云。阎浮檀金色圆满光云。日光圆满光云。月光圆满光云。普覆虚空。来诣佛所礼拜供养。即于东南方。化作明净摩尼宝王楼阁金刚宝莲华藏师子之座。结跏趺坐。宝焰光网罗覆其身。西南方过不可说佛刹微尘等世界。有世界。名曰光藏。佛号法月普照智王。彼大众中有菩萨。名坏散一切众魔智幢王。与世界微尘等菩萨俱来向此土。一一毛孔。普兴虚空界等宝华焰云。遍照一切世界。放香焰云。众宝焰云金刚焰云。香烟焰云。大龙自在电光焰云。明净摩尼宝焰云。金色宝焰云。妙德藏摩尼宝王网焰云。一一毛孔。各放虚空界等如来光明海云。普照三世。来诣佛所礼拜供养。即于西南方。化作一切方门光网普照法界摩尼楼阁香灯焰宝莲华藏师子之座。结跏趺坐。摩尼宝藏王妙光明网罗覆其身。冠一切众生向解脱音摩尼宝王冠。西北方过不可说佛刹微尘等世界。有世界。名净愿摩尼宝藏。佛号普明净妙德须弥山王。彼大众中有菩萨。名明净愿智幢王。与世界微尘等菩萨俱来向此土。于念念中。一切相好一切毛孔。皆出三世一切诸佛身云。充满一切虚空界。又出一切菩萨身云。一切如来眷属身云。一切如来变化身云。一切如来本生身云。一切声闻缘觉身云。一切如来道场菩提树云。一切如来自在云。一切世界王身云。一切严净佛刹云。于念念中。一切相好一切毛孔。皆出如是等云充满虚空。来诣佛所礼拜供养。即于西北方。化作诸方清净摩尼妙宝楼阁清净一切众生摩尼宝莲华藏师子之座。结跏趺坐。坚固光明真珠宝网罗覆其身。首冠普覆摩尼宝冠。下方过不可说佛刹微尘等世界。有世界。名一切如来光圆满清净。佛号无碍虚空智幢王。彼大众中有菩萨。名坏散一切障智慧势王。与世界微尘等菩萨俱来向此土。于一切毛孔。出一切众生语海音云。三世菩萨行海音云。一切菩萨愿音云。一切菩萨成满清净波罗蜜音云。一切菩萨行妙音声云。充满一切世界一切菩萨积集自在音云。一切菩萨往诣道场降伏众魔成最正觉自在音云。一切诸佛转正法轮修多罗音云。随其所应化度众生方便音云。令一切众生随时方便得妙智慧善根音云。来诣佛所礼拜供养。即于下方。化作诸佛宝光明藏庄严楼阁宝莲华藏师子之座。结跏趺坐。普照道场摩尼宝王为髻明珠。上方过不可说佛刹微尘等世界。有世界。名说无尽觉佛号圆满普智光音。彼大众中有菩萨。名分别法界智通王。与世界海微尘等菩萨俱。来向娑婆世界释迦牟尼佛所。一切相好。一切毛孔。一切肢节。一切身分。一切庄严具。一切衣服中。出卢舍那等过去一切诸佛未来一切已受记佛未受记佛现在十方一切世界一切诸佛及眷属云。皆悉显现。过去所行檀波罗蜜及受施者。皆悉显现。过去所修尸波罗蜜持戒清净。过去羼提波罗蜜。割截肢节心不动乱。过去修习毗梨耶波罗蜜。过去修习一切如来禅波罗蜜海。过去修习一切如来转净法轮。过去一切悉舍不着寿命。过去欢喜乐求诸菩萨道。过去出生菩萨清净大庄严愿。过去一切菩萨力波罗蜜。过去一切菩萨圆满智慧。皆悉具足。出如是等诸自在云。充满法界皆悉显现。来诣佛所礼拜供养。即于上方。化作金刚庄严藏楼阁青金刚宝莲华藏师子之座。结跏趺坐。一切宝网罗覆其身。三世佛号摩尼宝王为髻明珠。是诸菩萨及其眷属。皆悉具足普贤行愿。成就三世诸佛清净智眼。转一切佛净妙法轮。摄取诸佛胜妙音声修多罗海。具足一切菩萨自在究竟彼岸。于念念中。悉诣一切诸如来所。现自在力。一切充满一切世界。能于一切如来众生现清净身。于一微尘悉能示现一切世界。随所应化成熟众生未曾失时。于一毛孔出一切佛妙法雷音。知众生界皆悉如幻。知一切佛悉如电光。知一切有趣皆悉如梦。知一切果报如镜中像。知一切生如热时焰。知一切世间皆如变化。具足成就如来十力无所畏法。于大众中能师子吼。深入无尽一切辩海。决定了知一切众生语言法海。于净法界行无碍行。知一切法皆悉无诤。具足菩萨诸通妙智。勤修精进摧伏诸魔。安住三世胜妙智慧。无所染着。清净妙行得佛庄严一切智地。知一切有悉无所有。深入一切法界智海。以不坏智入一切世界。于一切世界普现自在。示现一切世界受生。知一切世界种种形色。以微细境界现广佛刹。以广佛刹现微细境界。于一念中。住一切佛住。得一切佛住持智身。得清净慧。了知十方一切刹海。于一念中。悉能出生无量自在。遍满十方一切世界海。此诸菩萨。皆悉成就如是等无量功德。满祇洹林。皆是如来威神力故。尔时诸大声闻。舍利弗。目揵连摩诃迦叶。离婆多。须菩提。阿泥卢豆。难陀。金毗罗。迦旃延。富楼那弥多罗尼子。如是等诸大声闻。在祇洹林。而悉不见如来自在。如来庄严。如来境界。如来变化。如来师子吼。如来妙功德。如来自在行。如来势力。如来住持力。清净佛刹。如是等事皆悉不见。亦复不见不可思议菩萨大会。菩萨境界自在变化。菩萨眷属随所来方妙宝庄严诸师子座。菩萨宫殿三昧自在周遍观察。菩萨奋迅勤行精进供养诸佛。菩萨授记长养善根。菩萨受身清净法身智身愿身色身相好。无量光明圆满庄严放大光网变化身云。菩萨充满一切方网菩萨诸行圆满具足。如是等事。一切声闻诸大弟子。皆悉不见。何以故。修习别异善根行故。本不修习能见如来自在善根。亦不修习净佛土行。又不赞叹见佛自在所得功德。不于生死中教化众生发阿耨多罗三藐三菩提心。亦不安立众生于佛菩提。亦不守护如来种姓令不断绝。亦不摄取一切众生。亦不成就诸波罗蜜。不为众生称叹胜妙智慧眼地。亦不修习一切智行。不求诸佛离世善根。亦不出生自在净刹。不求菩萨诸通明眼。不修菩萨境界不坏善根。亦不出生佛力住持菩萨大愿。又亦不知诸法如幻菩萨集会悉皆如梦。亦不修习菩萨离生圣行之心。不得普贤清净智眼。是诸功德。不与声闻辟支佛共。以是因缘。诸大弟子。不见不闻。不入不知。不觉不念。不能遍观。亦不生意。何以故。此是菩萨智慧境界非诸声闻智慧境界。是故诸大弟子在祇洹林。不见如来自在神力。亦无三昧清净智眼于微细处见诸境界。亦无法门神力境界。亦无诸力胜妙功德。亦无是处智。亦无智眼能见闻觉知及生意念。亦不乐说。不能赞叹。不能显现。不能施与。不能劝化安立众生于彼妙法。何以故。以声闻乘出三界故。又以满足声闻之道住声闻果。不能具足无所有智。住真实谛。常乐寂静远离大悲。常自调伏舍离众生。是故虽与如来对面。而坐不能觉知神变自在。譬如饿鬼裸形饥渴。举身烧然。为诸虎狼毒兽所逼。往诣恒河欲求水饮。或见枯竭或见灰炭。所以者何。悉由宿行罪业障故。一切声闻亦复如是。虽在祇洹不睹如来自在神力。所以者何。无明障曀覆净眼故。譬如有人于大会中昏寝。梦见诸天城郭帝释宫殿。园观林流众宝庄严。散诸杂华。宝树行列妙衣覆上。诸天男女游戏其中。自然妙音共相娱乐。受天快乐。其人自睹安住此处。见天宫殿无量庄严。其余大会悉不知见。所以者何。觉梦异故。一切菩萨世界诸王。亦复如是。如彼梦中无所不见。深入菩萨妙法门故。积集善根出生一切智愿故。决定明了佛功德故。正向菩萨弘誓道故。满足一切智故。满足普贤诸行愿故得一切菩萨圆满地故。得一切菩萨三昧自在故。行一切菩萨无碍智故。是故一切诸大菩萨。悉睹如来不可思议神变境界。深入明达究竟彼岸。一切声闻诸大弟子皆不能知譬如雪山有诸药草。贤明良医悉分别知。虽有捕猎放牧人等游止彼山悉不能知。菩萨摩诃萨亦复如是。具足一切智。出生一切菩萨自在。明了如来神足变化。彼诸声闻大弟子众。虽处祇洹悉不觉知。所以者何。常求自安不广济故。譬如地中有诸宝藏。唯咒术者悉能别知。记录库藏。以自资给奉养父母。赈恤亲属拯济贫乏。菩萨摩诃萨亦复如是。以净慧眼。入佛自在不可思议神力境界。普入无量方便大海诸三昧海。恭敬供养一切诸佛。守护正法。以四摄法摄取众生。诸大声闻虽处祇洹。不睹如来自在神变。譬如盲人至大宝洲。行住坐卧不见众宝。此诸声闻亦复如是。在祇洹林大法宝洲。亲侍世尊。不睹如来自在神变菩萨大众。所以者何。不得菩萨清净眼故。不能次第觉法界故。譬如有人以明净药而用治眼。于夜闇中处在大众。悉见众人行住坐卧。余人不见。如来亦尔。逮得无碍清净智眼。悉能知见一切世间。示现无量自在神变及菩萨众。诸大声闻。不睹如来自在神变及菩萨众。譬如比丘在大会中入一切处定。所谓地水火风天众生境界。其余大众。悉不能见地水火风乃至境界诸一切处。如来所现不可思议。菩萨悉见。诸大声闻不知不见。譬如有人以曀身药自涂其目。行住坐卧无能见者。唯有彼人悉能睹见。如来亦复如是。永离世间无能见者。唯一切智菩萨境界。非诸声闻之所能知。如人从生有二种天常随侍卫。一曰同生。二曰同名。天常见人人不见天。如来神变亦复如是。非诸声闻所能知见。唯诸菩萨乃能睹见。譬如比丘于大众中入灭尽定。不舍诸根亦不灭度。而不知见诸大众事。所以者何。灭定力故。诸大声闻亦复如是。处祇洹林大众之中。诸根现前。而不睹见如来神变。不入不知不觉不念。不生心意。所以者何。如来境界甚深弥旷。难知难见难得原底。无有限量。远离世间。不可思议无能坏者。非诸声闻缘觉境界。尔时明净愿光明菩萨。承佛神力。观察十方。以偈颂曰

  瞻察坚固人　　菩提难思议
  祇洹林显现　　无量自在法
  如来神力持　　显现无量德
  世间悉迷惑　　不知诸佛法
  法王甚深法　　无量难思议
  显现大变化　　一切莫能测
  如来庄严相　　赞叹不可尽
  以法无相故　　宣明一切佛
  最胜于祇洹　　显现自在力
  甚深不可议　　远离语言道
  观察无量德　　菩萨众云集
  不思议刹来　　供养于最胜
  悉满诸大愿　　常修无碍行
  一切诸世间　　莫能知其心
  一切诸缘觉　　无量大声闻
  皆悉不能知　　菩萨行境界
  菩萨大智慧　　一切莫能坏
  远离诸乱想　　究竟深智地
  最大名称人　　深入无量定
  显现自在力　　充满诸法界

尔时不可坏精进势王菩萨。承佛神力。观察十方。以偈颂曰

  瞻察真佛子　　功德智慧藏
  究竟菩萨道　　安隐诸世间
  无量智明鉴　　禅定心不动
  智慧甚深广　　境界不可测
  闲静祇洹林　　无量妙庄严
  菩萨皆充满　　悉依正觉住
  无量大众海　　一切无所著
  十方来会此　　处华师子座
  除灭众虚妄　　一切无所染
  离垢无碍心　　究竟诸法界
  建立智慧幢　　不动如金刚
  诸法无变化　　示现无量变
  一切十方界　　无量亿佛刹
  悉能遍往诣　　而亦不分身
  瞻仰释师子　　无量力自在
  以佛威神故　　十方大众集
  佛子悉究竟　　一切语言道
  佛法不可坏　　安住法界地
  法性不可坏　　牟尼甚深法
  句身及味身　　分别无穷尽

尔时无上普妙德王菩萨。承佛神力。观察十方。以偈颂曰

  瞻察坚固人　　智慧广圆满
  善知时非时　　为众演说法
  远离诸外道　　调伏诸论师
  随其所应化　　为现自在力
  正觉非量法　　亦非无量法
  牟尼悉超越　　有量无量法
  譬如明净日　　除灭一切闇
  道师智亦然　　普照三世法
  譬如十五日　　圆满明净月
  最胜亦如是　　白净法圆满
  譬如虚空中　　净日光明耀
  普照于一切　　佛自在亦然
  譬如虚空性　　一切无障碍
  世间灯如是　　自在无障碍
  譬如大地性　　能持诸群生
  世间灯法轮　　能持亦如是
  譬如大风性　　飘疾无障碍
  佛法亦如是　　速遍诸世间
  譬如大水轮　　世界所依住
  智慧轮亦然　　三世佛所依

尔时无碍妙德藏王菩萨。承佛神力。观察十方。以偈颂曰

  譬如大宝山　　饶益诸群生
  如来功德山　　饶益亦如是
  譬如大海水　　清凉而澄净
  如来亦如是　　能除热渴爱
  譬如须弥山　　安峙于大海
  如来山亦然　　安住深法海
  譬如大海中　　能出一切宝
  无师智亦然　　觉难觉无难
  导师甚深智　　无量无有数
  显现自在力　　无能思议者
  譬如工幻师　　示现种种事
  佛智亦如是　　现诸自在力
  譬如如意珠　　能满一切意
  最胜亦如是　　悉满诸净愿
  譬如明净宝　　悉能照一切
  导师智如是　　普照一切法
  譬如随方宝　　正住诸方现
  无碍灯亦然　　诸法于中现
  譬如净水珠　　澄清诸浊水
  见佛亦如是　　诸根悉清净

尔时法界善化愿月王菩萨。承佛神力。观察十方。以偈颂曰

  譬如青宝珠　　能青一切色
  若有见佛者　　皆悉同菩提
  一一微尘中　　最胜现自在
  悉能净无量　　无边诸菩萨
  逮得甚深法　　种种庄严事
  唯诸菩萨境　　世间莫能测
  具足诸庄严　　如来净妙行
  成就菩萨道　　深入诸法界
  正觉所示现　　不可思议刹
  一切现在佛　　菩萨悉充满
  释师子成就　　无量自在法
  示现大神变　　无量无有边
  菩萨种种行　　无量无有边
  如来自在力　　为之悉显现
  佛子善修学　　甚深诸法界
  成就无碍智　　明了一切法
  如来威神力　　为众转法轮
  出生胜功德　　令世悉清净
  如来净境界　　甚深圆满智
  实智大龙王　　度脱一切众

尔时法义慧焰王菩萨。承佛神力。观察十方。以偈颂曰

  最胜有三世　　声闻诸弟子
  皆悉不能知　　如来举足事
  去来今现在　　一切诸缘觉
  亦复不能知　　如来举足事
  何况世凡夫　　结使所缠缚
  愚闇覆净眼　　而能知导师
  最胜无量德　　具足诸智慧
  超出语言道　　一切莫能知
  譬如明净月　　光明无能知
  导师亦如是　　功德不可议
  如来一方便　　出生无量化
  无数劫思算　　不能知少分
  如来一方便　　出生无量德
  一切智正法　　皆悉无能知
  若有求菩提　　修习菩萨行
  是彼之境界　　所能分别知
  不思议方便　　超度生死海
  若灭吾我心　　是则能究竟
  清净心无量　　大愿悉成满
  逮得佛菩提　　最胜之境界

大方广佛华严经卷第四十四大方广佛华严经卷第四十五

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之二

尔时坏散一切众魔智幢王菩萨。承佛神力。观察十方。以偈颂曰

  大智无碍身　　非身难思议
  如来净法身　　一切莫能测
  不思议行业　　起此清净身
  无量妙庄严　　不染于三界
  普明照一切　　清净诸法界
  开发菩提门　　出生深定智
  永离诸垢染　　除灭一切障
  世间明净日　　普放慧光明
  永绝生死流　　悉令三界净
  具足菩萨德　　成就佛菩提
  显现无量色　　于彼无所染
  所可现众色　　一切莫能思
  人王胜智慧　　能于念念中
  具无量菩提　　一切莫能知
  具足无尽智　　一切莫能坏
  彼于一念中　　明达三世佛
  分别一切业　　正念思菩提
  于思而非思　　思法寂灭故
  甚深不可说　　远离语言道
  如来从此起　　佛业难思议

尔时明净愿智幢王菩萨。承佛神力。观察十方。以偈颂曰

  离痴清净念　　闻持一切法
  深慧能分别　　诸佛无尽海
  菩萨决定心　　修习菩萨行
  出生甚深智　　除灭诸疑惑
  其心无疲厌　　远离于懈怠
  常勤修精进　　究竟诸佛法
  具足信智慧　　安住不可动
  常乐甚深智　　观察无所著
  无量无边劫　　积集诸功德
  专心常回向　　诸佛甚深法
  虽在生死中　　其心无染着
  安住诸佛法　　常乐如来行
  世间诸所有　　阴界等诸法
  无畏悉除断　　安住佛正法
  世间颠倒惑　　生死轮常转
  修习无碍行　　实利益众生
  菩萨行难称　　一切莫能知
  除灭一切苦　　安乐诸群生
  善觉菩提智　　普照诸世间
  除灭愚痴闇　　度脱一切众

尔时坏散一切障智慧势王菩萨。承佛神力。观察十方。以偈颂曰

  无量无数劫　　佛音难得闻
  何况亲奉觐　　除灭诸疑惑
  如来世间灯　　究竟一切法
  无上胜福田　　令众悉清净
  如来妙色身　　一切莫能思
  无量劫谛观　　其心无厌足
  佛子善观察　　如来妙色身
  除灭一切障　　究竟成菩提
  如来妙色身　　出生净妙音
  无碍诸辩才　　广开菩提门
  普照一切众　　无量难思议
  建立大乘智　　授以菩提记
  功德圆满日　　出兴照世间
  长养一切世　　无量功德身
  若有值如来　　远离诸恶道
  除灭一切苦　　具足智慧身
  若有见如来　　能发无量心
  长养无数智　　值遇诸导师
  若有见如来　　得定菩提心
  能自决定知　　我必成菩提

尔时分别法界智通王菩萨。承佛神力。观察十方。以偈颂曰

  菩萨见如来　　无量净功德
  皆悉善回向　　究竟一切智
  饶益众生故　　如来出世间
  具足大悲心　　为世转法轮
  一切无能报　　大仙普慈恩
  不可思议劫　　代众受苦故
  无量亿劫中　　受诸地狱苦
  不舍一切众　　悉令得见佛
  普能代众生　　具受无量苦
  其心无疲倦　　为度一切故
  一切诸世间　　所有恶道苦
  如来常处中　　悉令闻正法
  一一地狱住　　不可思议劫
  具受无量苦　　终不离诸佛
  所以无量劫　　常在三恶道
  欲令诸群生　　长养智慧故
  众生见如来　　除灭诸苦恼
  安立于大智　　一切佛境界
  若有见佛者　　除灭一切障
  长养功德藏　　究竟成菩提
  如来能除灭　　世间诸疑惑
  随其所应化　　悉满彼大愿

尔时普贤菩萨。观察一切大众。欲重开发显现照明。以法界等方便。广说师子奋迅三昧。法界等。虚空界等。三世等。一切众生界等。一切劫等。一切业性等。众生希望等。众生欲等。法光明等。随时教化等。一切众生根等。为诸菩萨十种广说师子奋迅三昧。何等为十。所谓广说一切法界中。一切佛刹微尘等佛。次第兴世演说正法。广说虚空界等一切佛刹中。尽未来劫一切诸佛所说广说一切佛刹中。一切如来现成正觉。广说虚空界等一切佛刹中。佛坐道场眷属围绕。菩萨大众皆悉往诣。广说一念中三世一切佛出变化身充满一切法界。广说一身充满一切世界海。一切佛刹海平等照持。广说一一境界中。显现三世一切诸佛自在功德地。广说一一微尘中。显现三世一切佛刹。微尘等佛自在神力。广说一一毛孔出三世一切佛大愿海音。开发化导尽未来劫一切菩萨。广说处法界等师子之座。大众围绕庄严道场。各随其处转妙法轮。尽未来劫未曾断绝。佛子。此师子奋迅三昧。有如是等不可说佛刹微尘等广说。唯是如来智慧境界。尔时普贤菩萨摩诃萨。欲重明师子奋迅三昧。承佛神力。观察如来。观察大众。观察如来不可思议境界。观察诸佛三昧。观察不可思议世界。观察不可思议智慧。观察一切法皆悉如幻。观察不可思议诸佛平等。观察无量无边一切音声语言道故。以偈颂曰

  一一毛孔中　　普现最胜海
  佛处如来座　　菩萨众围绕
  一一毛孔中　　无量诸佛海
  道场处华座　　转净妙法轮
  一一毛孔中　　一切刹尘等
  最胜跏趺坐　　演说普贤行
  最胜坐一刹　　充满十方界
  无尽菩萨云　　来诣于佛所
  无量亿佛刹　　尘数菩萨集
  围绕于如来　　为说诸法界
  显现诸佛刹　　入法界智海
  安住普贤行　　满足诸佛行
  安住于如来　　一切诸世界
  深入菩萨行　　乐闻胜法云
  一一刹无量　　亿劫修诸行
  修习彼行已　　究竟深法海
  满足大愿海　　安住如来地
  出生最胜法　　具足普贤行
  成就功德海　　得无量自在
  如来身云覆　　一切诸佛刹
  普雨甘露法　　令众住佛道

尔时世尊。欲令诸菩萨安住师子奋迅三昧故。放眉间白毫相光。名普照三世法界门。不可说世界微尘等光明以为眷属。普照十方一切世界海。时祇洹林菩萨大众普云集者悉见一切法界。虚空界等一切佛刹。种种色种种清净。种种安住。种种形。如是等一切世界诸大菩萨。现坐道场。菩萨围绕。诸天供养成等正觉。或见于不可说佛刹微尘等诸眷属中。出妙音声。充满法界。转净法轮。或见在天宫殿。在龙宫殿。夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽及人非人等诸宫殿中。或见在人聚落城邑大王京都。现种种身。种种姓名。种种色。种种圆光。种种光网。种种辩。种种眷属。种种持。种种教持。种种音声。而为说法。如此间。如来为诸菩萨现甚深三昧神力变化。一切法界。虚空界等。十方一切世界海中。现国土身及众生身诸业所起。乃至一毛孔中一切悉现。亦复如是。而不坏三世。不坏众生。普照一切诸众生心。色身清净。随所应化。普现一切众生类前。开示一切诸佛妙法。调伏众生。显现如来自在神力。其有众生。见闻念知如来自在神通力者。皆佛宿世善知识也。皆悉修习四摄善根。一向专求无上菩提。摄诸善根成就方便。逮得如来不可思议自在三昧。悉与法界虚空界等。或得法身或得色身。或得菩萨具足诸行。或得清净诸波罗蜜。或得菩萨圆满净行。或得菩萨诸地。或得菩提自在。或得如来不坏三昧。或得如来诸行智力。或得如来无碍辩才。此诸菩萨。得如是等十不可说佛刹微尘等诸妙功德。所谓种种道。种种门。种种入。种种度。种种方便。种种至。种种方。种种光明。种种功德。种种功德具。种种自在。深入菩萨诸三昧海。所谓普庄严法界菩萨三昧。普照三世无碍三昧不坏法界智三昧。随时深入如来境界三昧。普照虚空三昧。行如来力三昧。如来无畏庄严师子奋迅三昧。一切法界方便藏三昧。无碍法界净月三昧。清净庄严法云三昧。除灭痴障法王幢三昧。一一境界中悉见一切佛海三昧。一切世间不可坏身清净光明智幢三昧。深入佛身无坏三昧。随顺一切世藏三昧。诸法无迹无依三昧。圆满普照寂灭三昧。无所有善化普化遍照三昧。摄持一切佛刹三昧。庄严一切佛刹现成菩提三昧。行一切王法三昧。行一切众生境界无碍三昧。生一切诸佛三昧。究竟一切佛德海三昧。一一境界出生尽未来际功德三昧。解了一切如来本生海三昧。护持尽未来际一切如来种性三昧。令现在十方一切佛刹海悉净三昧。于一念中普照一切佛住三昧。远离障碍深入一切境界三昧。令一切刹入一佛刹三昧。出一切佛化身三昧。决定智慧金刚王入一切根海三昧。住持一切佛身皆一身藏无差别三昧。于一念中住一切佛法界方便无尽三昧。于一切法界佛刹中示现涅槃三昧。住无上地三昧。令一切世界众生悉见其身无别异三昧。一切佛智现前三昧。知一切法实相三昧。于一念中具分别知三世三昧。于一念中知一切法界藏三昧。皆随顺知如来智师子行三昧。于一切境界慧眼圆满三昧。十力境界等三昧。于一切境界以平等眼示现三昧。出生一切妙色众生见无厌足三昧。无动藏三昧。一法摄一切法三昧。一言普说一切音声三昧。一切佛无二法三昧。离三世三昧。分别一切劫不坏智三昧。微细方便十力内三昧。一切劫出生菩萨行无断三昧。一切十方普云现前三昧。菩提自在法界无碍三昧。分别一切觉正希望安隐幢三昧。一切庄严庄严虚空三昧。于念念中出生化云三昧。离垢如空如来月光三昧。一切佛持如空三昧。一切法庄严法光三昧。开一切法义灯三昧。十力圆满光三昧。三世一切佛幢三昧。一切佛同一藏三昧。于念念中发起究竟一切事三昧。无尽功德藏三昧。示现无量无边诸佛境界三昧。住一切法金刚师子座三昧。出生显现一切如来变化无不知见三昧。一切念如来日三昧。一日悉觉三世三昧。自然寂静解脱三昧。见一切佛三昧。钵昙摩华庄严一切法界决定智三昧。一切法无著虚空净眼三昧。一方摄十方海三昧。深入无底法界三昧。一切法海三昧。放一切光寂静身三昧。一念出生一切通明愿三昧。一切时一切处成菩提三昧。一切法界入一庄严三昧。一切佛住持三昧。一切众生胜地智明三昧。一念中一身充满法界三昧。一身中显现清净法界三昧。普门入法界显现大庄严三昧。一切佛法圆满轮智住持三昧。一切法方便一方便庄严三昧。因陀罗网摄众生界诸愿精进住持三昧。分别一切世界轮三昧。莲华妙德自在三昧。分别一切众生身三昧。对现一切众生身三昧。分别一切音声海三昧。了知一切众生地三昧。不可坏大悲藏三昧。一切佛入如来际三昧。修习一切佛法门三昧。观察师子奋迅菩萨三昧。如是等不可说佛刹微尘等三昧门。入如来海。入一切佛自在三昧。于念念中充满法界。彼诸菩萨一一皆有妙师子座。悉与十佛世界等。现大自在甚深智慧。悉得诸地明净智慧。普观一切从智性生。专求一切智。具足成就离痴慧眼。悉为众生作调御师。修行诸佛平等正法。决定了知一切境界。分别了知一切世界。乐寂灭法。远离世间。常好闲静。游诸佛刹无所染着。于一切法心无所依。安住庄严妙法宫殿。教化成熟一切众生。为一切众生显现佛刹。具足成就无上智门。顺离欲际得智慧身。消竭一切诸有为海。为一切众生显真实际。法海慧光具足圆满。皆悉安住坚固三昧以大悲心。常念众生。解一切众生皆悉如梦。一切如来悉如电光。一切言音皆悉如响。了一切法皆悉如化。满足诸愿具菩萨行。普智圆满方便清净。心乐寂静。成满一切诸陀罗尼。智慧境界。具足十力远离恐怖。安住法界具净法眼。得一切法无所有门。修行无量智慧大海。究竟到于智慧彼岸。悉得般若波罗蜜力。成就神通波罗蜜。度众生海。于三昧波罗蜜悉得自在。善知一切智无错谬。巧妙方便开示法藏。具足辩才成就大愿。具足诸力法云无尽。于大众中能师子吼而无所畏。常求正法心无所著。以净慧眼灭除痴闇。智月圆满照世生灭。成就智慧。放大光明。照一切谛。善巧方便。智慧功德。金刚之山。超出三世一切法王。觉无所畏。智功德幢。灭诸魔幢。建立精进圆满智幢。具足成就无上之身。得一切法无碍智慧。觉了无尽智真实际。安住真际。修行决定无相三昧。巧方便生诸菩萨行。无二智慧谛见境界。世间诸趣。普照佛刹无所染着。于一切法除灭痴闇。究竟智慧皆悉圆满。放净法光照十方界。为一切众生作不虚福田。若见闻者所愿成满。为一切世间功德须弥。远离恐怖伏诸外道。以微妙音遍一切刹。常见诸佛心无厌足。成就如来自在法身。随其所应而化度之。能以一身满一切刹。以少方便具足清净自在神力。普游十方无所障碍。智慧圆满遍照法界。为一切众耀明净日。随其所应赞叹功德。了一切众生诸根希望。于一切法得无诤境界。分别了知诸法自性。大小相摄。决了如来甚深之地。说句味身诸法深义。无有穷尽。于一言中。普说一切修多罗海。究竟一切诸陀罗尼。广智慧身。究竟无量劫陀罗尼。于一念中。决定了知不可说劫。于一念中。了达三世法陀罗尼。普照无量诸佛法海。为一切众生起净智慧。转正法轮无能坏者。成就如来智慧境界。常入善现三昧正受。远离障碍深入诸法。于一切法得胜智自在。清净庄严一切境界。深入十方甚深法界。摄取十方一切法界。于一一微尘中。现成正觉。于无色性现一切色。能以一方摄一切方。彼诸菩萨。具足成满如是等无量功德智慧之藏。常为一切诸佛赞叹。以句味身说其功德。不能穷尽。皆悉云集于祇洹林。尔时彼诸菩萨。深入如来功德大海。入已于菩萨身中。及楼阁中。庄严具中。师子座中。以乐法力故。不可思议力故。于念念中。各放无量光明云。普照法界觉悟众生。所谓出一切宝香光明云。赞叹三世诸佛功德。微妙音声充满十方。出一切众生云。境界光明。说一切众生清净业报。微妙音声充满十方。出一切菩萨愿行庄严光云。说一切菩萨愿行功德。出一切佛变化身云。一切如来微妙音声充满十方。出一切菩萨身云。相好庄严。于一切佛刹。以微妙音赞叹诸佛充满十方。出三世佛庄严道场云现一切佛成等正觉。充满十方。于一切境界中。出龙王云。雨一切香充满十方。出一切佛身云。叹普贤行充满十方。出一切佛刹净光明云。一切如来转法轮音充满十方。时诸菩萨威神力故。此法力故。出如是等不可说佛刹微尘等云。尔时文殊师利菩萨摩诃萨。承佛神力。观察十方。欲赞叹祇洹林中无量庄严。以偈颂曰

  观察祇洹中　　如来自在力
  一切境界出　　无量功德云
  无量净妙色　　种种而庄严
  皆悉普照现　　十方诸佛刹
  佛子身毛孔　　出佛音声云
  种种宝庄严　　充满十方刹
  其身如梵王　　威仪常安静
  遍游十方刹　　演出妙音声
  如来毛孔出　　不可思议身
  皆悉如普贤　　众妙相庄严
  菩萨普成就　　三世功德海
  充满于虚空　　出生庄严云
  于此祇洹中　　演出妙音声
  普说一切众　　善净业果报
  一一境界中　　悉现佛刹海
  三世诸如来　　无量自在力
  如来毛孔中　　一切诸世界
  微尘等佛刹　　皆悉分别现
  一切境界中　　出生诸佛云
  无量善方便　　度脱一切众
  华云香焰云　　清净摩尼宝
  种种庄严云　　充满于十方
  三世一切佛　　庄严妙道场
  于此祇洹林　　一切悉显现
  普贤等佛子　　无量种庄严
  众生等劫中　　所修严净刹
  如是诸世界　　悉现祇洹林

时彼一切诸菩萨众。以如来三昧照故。一一皆得不可说佛刹微尘等大悲法门。饶益安乐摄取众生。彼诸菩萨。于一一毛孔。各出不可说佛刹微尘等光明。一一光明端。各出不可说佛刹微尘等菩萨。其身尊重。于诸世间最为殊胜。随其所应皆悉显现。充满法界教化众生。未度者度未脱者脱。现不可说佛刹微尘等诸天宫殿无常死相。一切诸法皆悉如梦。赞叹道场。说一切菩萨诸大愿门。或于一切世界。示现受生。为一切众生。广现檀波罗蜜门。或现一切诸佛圆满净戒功德尸罗波罗蜜门。或现断一切肢节羼提波罗蜜门。或现勤修精进毗梨耶波罗蜜门。或现一切菩萨禅定三昧相续解脱法门。如来圆满智慧光明。专求一切佛法。为一一句身味身义故。能舍无量无数之身。诣诸佛所。问无量法门。善知时会。随其所应而为现法。令一切众生住一切智。逮得方便智光海门。悉能供养诸佛菩萨。降伏众魔制诸外道。悉能显现菩萨力门。知一切技术明净智地。欲令众生得胜妙法。悉能了知众生诸根。烦恼习气。种种业报。及智慧地。以如是等不可说佛刹微尘等法门。教化众生。或现天宫。或现龙宫夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等宫。或现梵宫。或现人宫。或现阎罗王宫。或现地狱饿鬼畜生处。大悲智慧及诸大愿不可沮坏。摄取众生不舍方便。或以名号教化。或以忆念教化。或以音声教化。或以圆满光明教化。或以光明网教化。随其所应悉现其前。现处处庄严。不离佛所。不离楼阁座。而普现十方。或放化身云。或现无二身。游行十方教化众生。或现声闻色像。或现梵天色像。或现一切苦行色像。或现良医色像。或现商人色像。或现正命色像。或现妓人色像。或现天色像。或现一切技术色像。或现一切城邑聚落京都色像。随其所应往诣其所。或现种种色身音声。教化众生。或现诸语言法。种种威仪。种种菩萨行。种种巧术。一切智明为世间灯。普照众生。业报庄严。分别诸方。悉行圆满菩萨诸行。悉现一切城邑聚落京都。化度众生。尔时文殊师利童子。从善安住楼阁出。与一切同行诸菩萨俱。金刚力士常随侍卫。本愿足天。乐闻法地天。常习大悲泉池方天。除灭愚痴夜天。出生佛昼日天。庄严正法界虚空河天。度众生生死海天。长养一切善根萨婆若山天。庄严一切众生身满足诸愿供养一切佛身天。守护一切众生城天。守护一切众生夜叉王。令一切众生欢喜乾闼婆王。除灭一切饿鬼趣鸠槃茶王。于生死海拔济众生迦楼罗王正求萨婆若阿修罗王。见佛欢喜无厌足摩睺罗伽王。常厌生死诸天王。常敬礼佛诸梵天王等。俱诣佛所头面礼足。设诸供养已。辞游南方。尔时尊者。舍利弗承佛神力。见文殊师利童子。以菩萨庄严而自庄严。出祇洹林游行南方。见已作如是念。我今当与文殊师利菩萨俱行。尔时尊者舍利弗。与六千比丘眷属围绕。从自房出来诣佛所礼足辞退。向文殊师利。此六千比丘。是舍利弗共行弟子。皆新出家。其名曰海智比丘。大善调伏比丘。功德光比丘。大童子比丘。电光兴比丘。清净行比丘。天妙德比丘。因陀罗慧比丘。梵天比丘。寂静慧比丘。如是等六千比丘。已曾供养过去诸佛。于诸佛所种诸善根。性乐清净信心明彻。行诸大愿观佛境界。了法实相饶益众生。常乐专求诸佛功德。此等比丘。皆是文殊师利之所化度。尔时尊者舍利弗。观察大众。告海智比丘言。汝可观察文殊师利菩萨清净之身。相好庄严。一切天人莫能思议。光明圆满。令无量众生发欢喜心。放大庄严妙光明网。除灭众生无量苦恼。观其眷属成就善根。观其游步威仪庠序。所游行处自然平正十方无碍。观其功德所行道路。其傍悉有众妙宝藏。自然发出。观其供养过去诸佛善根依果。从众林树出庄严藏。观彼一切诸天大王恭敬礼拜供养云雨。海智。汝观文殊师利。一切如来眉间毫相。放无量光。说诸佛法。悉入其顶。尔时尊者舍利弗。为诸比丘。赞说文殊师利无量功德诸大庄严。彼诸比丘。闻赞叹已皆悉欢喜。其心清净离诸垢秽。身体柔软调伏诸根。远离障碍现见诸佛。正求菩提。逮得菩萨清净诸根。具菩萨力长养大悲。入诸波罗蜜发弘誓愿。悉见十方诸如来海。时诸比丘。白尊者舍利弗言唯然大师。愿俱往诣文殊师利。尔时尊者舍利弗。与诸比丘往诣其所。到已谓文殊师利。此诸比丘。皆新出家。欲见仁者。尔时文殊师利童子。即为显现菩萨自在。如象王回顾视比丘。时诸比丘头面礼足。却住一面合掌而立。作如是念。我等以此礼拜功德。知法实相如和上舍利弗。释迦牟尼世尊。得清净身相好音声神力自在。如文殊师利。尔时文殊师利。告诸比丘。汝等当知。若善男子善女人。成就十种大心。则得佛地。况菩萨地。何等为十。所谓发广大心。长养一切善根。究竟不退。心无厌足。见一切佛。恭敬供养。心无厌足。正求一切佛法。心无厌足。遍行菩萨诸波罗蜜。心无厌足。具足一切菩萨三昧。心无厌足。于一切三世流转。心无厌足。严净佛刹。充满十方。心无厌足。教化成熟一切众生。心无厌足。于一切刹。一切劫中。行菩萨行。心无厌足。发广大心。修习一切佛刹微尘等诸波罗蜜。度脱一切众生。具佛十力。心无厌足。若善男子善女人。成就如是十种大法。则能长养一切善根。离生死趣一切世间性。超出声闻缘觉之地。生如来家。具足成就菩萨大愿。行菩萨行住菩萨地。成就如来功德之力。降伏众魔制诸外道。彼诸比丘闻此法已。皆得无碍净眼三昧。悉见十方一切如来。及其眷属无量众生。亦见种种世界形类。众宝宫殿。及诸微尘。乃至如来。十眼境界。皆悉睹见。彼诸如来以种种句身味身。种种辩才。微妙音声。所说法海。皆悉闻知。彼世界中一切众生。心念诸根。皆悉了知。知彼众生过去未来诸趣受生。又能知彼过去未来各十劫事。知彼如来十种本生。十种成就菩提自在。十种转法轮。十种神力。十种教诫。十种说法。十种辩才。得此三昧时。具足成就十种实际菩提之心。一万三昧。一万净波罗蜜。得大智慧圆满光明。菩萨十明住菩提心。尔时文殊师利菩萨。劝诸比丘。修普贤行住普贤行。彼诸比丘出生大愿海。生大愿海已。身心清净。得不死通明。得是明已。不离此处。出生一切如来法身。充满十方。具足一切佛法。尔时文殊师利菩萨。建立彼诸比丘菩提心已。与其眷属渐游南方。至觉城东。住庄严幢娑罗林中大塔庙处。过去诸佛所游止处。亦是过去诸佛为菩萨时修苦行处。此处常为一切天龙夜叉乾闼婆阿修罗人非人等之所供养。时文殊师利。即于此处。说普照一切法界修多罗有百万亿修多罗。以为眷属。说此法时。于大海中有无量千亿龙王。与眷属俱。来诣文殊师利。闻此法已。厌离龙趣正求佛道。舍龙身已生天人中。一万龙王。于阿耨多罗三藐三菩提。得不退转。时觉城人。闻文殊师利在庄严幢娑罗林中大塔庙处。闻已。优婆塞。优婆夷。童男童女。皆悉往诣文殊师利。时有优婆塞。名曰大智。与千优婆塞眷属俱。其名曰须达多优婆塞。婆须达多优婆塞。功德光优婆塞。名称德优婆塞。寂静德优婆塞。欢喜德优婆塞。善慧优婆塞。大慧优婆塞。贤优婆塞。贤妙德优婆塞。如是等千优婆塞俱。头面礼足退坐一面。复有五百优婆夷。其名曰大慧光优婆夷。善光优婆夷。善身优婆夷。可乐身优婆夷。跋陀罗优婆夷。贤德优婆夷。贤光优婆夷。光明幢优婆夷。妙德光优婆夷。善眼优婆夷。如是等五百优婆夷俱。头面礼足退坐一面。复有五百童子。其名曰善财童子。善行童子。善戒童子。善威仪童子。善精进童子。善心童子。善慧童子。善觉童子。善眼童子。善臂童子。善光胜童子。如是等五百童子俱。头面礼足退坐一面。复有五百童女。其名曰善行童女。跋陀罗童女。悦乐颜童女。坚固慧童女。妙功德童女。胜体童女。梵天与童女。功德光童女。善光明童女。如是等五百童女俱。头面礼足退坐一面。尔时文殊师利。知觉城大众集已。随其所应。以大慈力令彼清凉。大悲现前将为说法。甚深智慧分别其心以大辩力而为说法。观察善财童子。以何因缘名曰善财。此童子者。初受胎时。于其宅内有七大宝藏。其藏普出七宝楼阁。自然周备。金银琉璃玻璃真珠砗磲码瑙。从此七宝生七种芽。时此童子处胎十月。出生端正肢体具足。其七种宝芽。高二寻广七寻。又其家内自然具有五百宝器。盛满众宝。金器盛银。银器盛金。金刚器盛众香。众香器盛宝衣。玉石器盛上味馔。摩尼器盛杂宝。种种宝器盛酥油蜜。及以醍醐资生之具。琉璃器盛众宝。玻璃器盛砗磲。砗磲器盛玻璃。码瑙器盛赤珠。赤珠器盛码瑙。火珠器盛净水珠。净水珠器盛火珠。如是等五百宝器。自然行列。又雨众宝。满诸库藏。以此事故婆罗门中善明相师。字曰善财。此童子者。已曾供养过去诸佛。深种善根。常乐清净。近善知识。身口意净。修菩萨道。求一切智。修诸佛法。心净如空。具菩萨行。尔时文殊师利菩萨。如象王回。观察善财。而告之曰。吾当为汝说微妙法。即为分别诸佛正法。分别诸佛次兴世法。净眷属法。转梵轮法。诸佛色身。相好清净庄严之法。一切诸佛具法身法。诸佛音声妙庄严法。说一切如来平等正法。尔时文殊师利。知善财等一切大众闻说此法。皆大欢喜发菩提心。显明过去诸善根已。不舍本座。如应化度觉城众生已。游行南方。尔时善财童子从文殊师利。闻佛如是诸妙功德。专求菩提。随从文殊师利。以偈颂曰

  三有为城郭　　高慢为园墙
  诸趣为却敌　　染爱为深堑
  愚痴闇覆蔽　　三毒常炽然
  恶魔为君王　　童蒙依止住
  贪爱所缠缚　　谄曲坏正行
  疑惑障慧眼　　流转诸邪道
  悭嫉所系缚　　趣向饿鬼难
  生老病死逼　　愚痴转趣轮
  圆满无上悲　　清净智慧日
  消竭烦恼海　　愿顾少观察
  圆满无上慈　　慧光安众生
  一切无不曜　　月王愿照我
  一切法界王　　净法为四兵
  常转正法轮　　愿化我妙法
  具足菩提愿　　积集功德藏
  饶益一切众　　大师愿度我
  忍铠庄严身　　执持智慧剑
  于魔崄恶道　　济我免众难
  住法须弥顶　　妙定天女侍
  降伏阿修罗　　帝释观察我
  具足离垢力　　分别一切有
  世间明净灯　　愿示我正趣
  远离诸恶道　　悉令善趣净
  开我解脱门　　超出诸世难
  着常乐我净　　迷惑于生死
  清净智慧眼　　愿开解脱门
  远离诸颠倒　　无畏知正道
  了达诸正趣　　示现我菩提
  安住正见地　　诸佛功德树
  常雨正觉华　　愿示我菩提
  世间明净日　　三世诸如来
  如法而来去　　愿令我悉见
  分别一切业　　深知诸法性
  决定智慧乘　　示我摩诃衍
  诸愿轮成满　　大悲不可尽
  净妙德庄严　　安我菩提乘
  具足净法界　　大慈为观察
  功德华庄严　　赐我第一乘
  安住梵行座　　三昧女朝侍
  微妙法音乐　　示我法王道
  无尽四摄藏　　功德庄严智
  光明照一切　　愿速示胜道
  施惠圆满光　　栴檀戒涂身
  忍辱大庄严　　愿速示正道
  深入诸禅定　　教化群生类
  具足方便乘　　安我胜法乘
  诸愿圆满轮　　永绝生死轮
  具足持智力　　安我妙法乘
  一切悉殊妙　　大悲观众生
  究竟胜妙行　　安我实智乘
  安住金刚慧　　究竟一切智
  除灭诸障碍　　安我贤圣乘
  慈悲甚弥广　　安乐诸群生
  法界等净眼　　安我无上乘
  除灭众苦阴　　诸业烦恼轮
  降伏一切魔　　安我正法乘
  智慧照十方　　庄严诸法界
  满足众生愿　　安我胜妙乘
  心净如虚空　　除灭邪见爱
  饶益一切众　　安我胜法乘
  安住如风轮　　普持一切刹
  令众住定地　　安我殊胜乘
  安住如大地　　具足大悲力
  智慧益众生　　安我最胜乘
  四摄光圆满　　饶益群生类
  总持清净光　　示我明净日
  开发净慧眼　　庄严妙智王
  冠以无上冠　　法王慈顾我

大方广佛华严经卷第四十五大方广佛华严经卷第四十六

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之三

尔时文殊师利。如象王回。观善财童子。作如是言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。求善知识亲近善知识。问菩萨行求菩萨道。善男子。是为菩萨第一之藏。具一切智。所谓求善知识。亲近恭敬而供养之。是故善男子应求善知识亲近恭敬。一心供养而无厌足。问菩萨行。云何修习菩萨道。云何满足菩萨行。云何清净菩萨行。云何究竟菩萨行。云何出生菩萨行。云何正念菩萨道。云何缘于菩萨境界道。云何增广菩萨道。云何菩萨具普贤行。尔时文殊师利。为善财童子以偈颂曰

  善哉功德藏　　能来诣我所
  发广大悲心　　专求无上道
  先发诸大愿　　除灭众生苦
  究竟菩萨行　　成就无上道
  若有诸菩萨　　不厌生死苦
  具足普贤行　　一切莫能坏
  功德光胜来　　清净功德海
  正求普贤行　　饶益一切众
  无量无有边　　世界诸佛所
  闻说净法云　　受持不忘失
  悉于十方界　　普见无量佛
  成满诸愿海　　具足菩萨行
  究竟方便海　　安住如来地
  随顺诸佛教　　逮得一切智
  一切世界中　　法王积劫行
  具足普贤道　　究竟佛菩提
  一切刹劫海　　修习菩萨行
  满足诸大愿　　成就普贤乘
  无量诸众生　　闻彼名号者
  修习普贤愿　　得成无上道

尔时文殊师利。说此偈已。告善财言。善男子。于此南方。有一国土。名曰可乐。其国有山。名曰和合。于彼山中。有一比丘。名功德云。汝诣彼问。云何菩萨学菩萨行。修菩萨道。乃至云何具普贤行。善男子。彼比丘者。善能显说菩萨所行。时善财童子。从文殊师利。闻法欢喜。头面礼足。绕无数匝。瞻仰悲恋。泣涕辞退

渐渐南行。向可乐国。登和合山。于彼山中。十方周遍一心观察。求觅太师为在何所。如是寻求。乃至七日。尔时善财见彼比丘。乃在山顶静思经行。见已驰诣。头面礼足。右绕而住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻大师善能宣畅。唯愿垂慈。具足演说。时彼比丘。告善财言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。问菩萨行。善男子。如是事者。难中之难。所谓能问菩萨所行。修菩萨道。入菩萨境界。出生清净菩萨之道。求于菩萨清净广心。具足诸愿。随顺世间所应化者。于生死中求解脱门。有为无为心不染着。善男子。我于解脱力。逮得清净方便慧眼。普照观察一切世界。境界无碍。除一切障。一切佛化陀罗尼力。或见东方一佛二佛。十百千万十亿百亿千亿百千亿佛。或见百亿那由他千亿那由他百千亿那由他佛。或见无量阿僧祇。不可思议不可称。无分齐无边际。不可量不可说。不可说不可说佛。或见阎浮提微尘等佛。或见四天下微尘等佛。或见小千世界微尘等佛。或见二千世界微尘等佛。或见三千大千世界微尘等佛。南西北方四维上下亦复如是。种种形色。种种自在游戏神通。种种眷属庄严放大光网。种种清净庄严佛刹随受化者。示现自在菩提法门。见诸如来。于大众中而师子吼。善男子。我唯知此普门光明观察正念诸佛三昧。岂能了知菩萨圆满清净智行。诸大菩萨得圆满普照念佛三昧门。悉能睹见一切诸佛及其眷属。严净佛刹。得一切众生远离颠倒念佛三昧门。随一切众生所应悉令清净。得一切力究竟念佛三昧门。正念修习诸佛十力。得诸法中心无颠倒念佛三昧门。悉得睹见一切佛云。于彼佛所闻法受持。得分别十方一切如来念佛三昧门。悉见一切世界海中诸如来海。得不可见不可入念佛三昧门。于微细境界。见一切佛自在境界。得诸劫不颠倒念佛三昧门。于一切劫。常见诸佛未曾远离。得随时念佛三昧门。于一切时常见诸佛得严净佛刹念佛三昧门。起一切佛刹。无能坏者。普见诸佛。得三世不颠倒念佛三昧门。悉见三世诸佛及其眷属。得无坏境界念佛三昧门。于一切境界悉见诸佛。得寂静念佛三昧门。于一念中。悉见一切世界中一切如来。示现涅槃。得离月离时念佛三昧门。于一日中。悉见一切如来游行教化。得广大念佛三昧门。见一佛身结跏趺坐。充满法界。得微细念佛三昧门。于一毛孔。见一切佛成等正觉。得庄严念佛三昧门。于一念中。见一切佛。于一切世界。成等正觉。神力自在。得清净事念佛三昧门。见一切佛。慧光普照。转妙法轮。得净心念佛三昧门。自心明了。见一切佛。得净业念佛三昧门。见一切众生诸业如镜中像得自在念佛三昧门。见一切庄严法界诸佛充满。得虚空等念佛三昧门。见如来身普照法界及虚空界。尔时功德云比丘告善财言。善男子。南方有国。名曰海门。彼有比丘。名曰海云。汝应诣彼问菩萨行。善男子。彼比丘者。能分别说善根。具因善根。大地善根。大力善。能赞叹菩提因缘。广摩诃衍。增广波罗蜜力。显现一切菩萨行海。善能清净圆满大愿。能令出生清净普门。庄严法门生大悲力。时善财童子。从功德云比丘。闻法欢喜。头面礼足绕无数匝。眷仰顾恋辞退南行

尔时善财童子。一心正念善知识教。智慧光明菩萨法门。菩萨三昧。观察一切菩萨诸方便海。圆满功德。心常乐见一切菩萨。念一切佛次第兴世清净功德。渐趣南方海门国土。诣海云比丘。头面礼足。右绕毕退住一面。白言大圣。我已先发阿耨多罗三藐三菩提心。欲度一切智慧大海。而未知菩萨云何离生死性。得不退转生如来家。度生死海逮得如来一切智海。舍凡夫地得如来地。断生死流入菩萨流。灭诸趣轮满诸愿轮。降伏众魔具佛功德。竭爱欲海长大悲海。闭诸恶道开天人路。诸解脱门。出三界城到一切智城。舍离一切玩好之具。发弘誓愿摄取众生。尔时海云比丘。告善财言。善男子。汝已发阿耨多罗三藐三菩提心耶。答言唯然。善男子。若不深植善根。则不能发阿耨多罗三藐三菩提心。得普门善根。普照光明法门。长养正道。三昧慧光。出生种种功德海藏。长白净法。未曾退失。亲近善知识。恭敬供养。不惜身命。无所藏积。离诸高慢。心安不动犹如大地。大慈愍念一切群生。远离一切诸生死门。好乐佛境界者。能发菩提心。大悲心救护一切众生故。大慈心安乐一切众生故。无疲倦心灭一切众生诸苦恼故。饶益心灭一切众生不善法故。无畏心除灭一切诸恼害故。无碍心灭一切障故。广大心充满一切法界故。无边心等虚空界故。广心见一切如来故。清净心于三世法智不违故。智心究竟一切智海故。善男子。我住此海门国。十有二年。境界大海。观察大海。思惟大海。无量无边思惟大海。甚深难得源底思惟大海。渐渐深广思惟大海。无量妙宝而庄严之。思惟大海无量水聚。思惟大海水色种种不可思议。思惟大海大身众生之所依止。思惟大海水性所居。思惟大海大云弥覆。思惟大海未曾增减。善男子。我如是思惟时。复作是念。世间颇更有法广此大海。深此大海。庄严于此大海者不。作是念已。即见海底水轮之际。妙宝莲华自然涌出。伊那尼罗宝为茎。阎浮檀金为叶。沉水香宝为台。码瑙宝为须。弥覆大海。百万阿修罗王。悉共执持。百万摩尼宝庄严网。罗覆其上。百万龙王。雨以香水。百万迦楼罗王。衔妙宝缯带。垂下庄严。百万罗刹王慈心观察。百万夜叉王。恭敬礼拜。百万乾闼婆王。赞叹供养。百万天王。雨天香华末香幢幡妙宝衣云。百万梵王。稽首敬礼。百万净居天。各敬礼已合掌而住。百万转轮王。七宝庄严。百万海神王。从大海出恭敬礼拜。百万夜光宝光明网。普照一切。百万净宝。百万明净宝。以为庄严。百万宝藏。出无量光明普照一切。百万阎浮檀宝。安住庄严。百万金刚师子宝。不可沮坏。清净庄严。百万日藏宝。明净光明普照一切。百万不可坏摩尼宝。出生长养一切善行。百万如意宝珠。无尽庄严。彼宝莲华如来无上善根所起。悉令一切菩萨诸愿成满。十方世界无不显现。出生一切诸法如幻。从净法生。无诤方便法之所庄严。行如梦法无为法印。究竟到于无碍方便。普覆十方一切法界。唯佛境界。随顺世间。无量阿僧祇劫叹不可尽。见彼华上。有一如来。结跏趺坐。彼佛净身。上至非想非非想天。无不充满。见彼如来。坐此庄严宝莲华座。不可思议大众围绕。见不可思议圆满光明庄严。见不可思议相好庄严。见不可思议神力自在。见不可思议如来妙色。见不可思议无见顶相。见不可思议广长舌相。念不可思议清净音声。思惟不可思议圆满音声。见不可思议如来诸力。解了不可思议清净无畏。解了不可思议一切诸辩。忆念菩萨过去不可思议大劫本行。见不可思议菩提自在。见不可思议正法云。见不可思议普门庄严身。见不可思议身左右端严。见辨一切不可思议事饶益众生。时彼如来即申右手。而摩我顶。说普眼经。唯是如来境界。出生一切菩萨净行。普照一切法界。摄取圆满一切法界。普照一切严净佛刹。降伏一切众魔外道。悉令一切众生欢喜。普照一切众生所行。随其所应无不显现。普照一切众生根轮。善男子。我从佛闻此普眼经。皆悉受持。读诵通利。正念思惟。善男子。假使有人。以大海等墨。须弥聚笔。书写此经。一一品。一一法门。一一方便。一一生法门。一一句中义味。犹不能尽。善男子。我于佛所。千二百岁闻受此经。于一一日。受阿僧祇品多闻陀罗尼光明力故。究竟阿僧祇品百门陀罗尼光明力故。摄取阿僧祇品无量旋陀罗尼光明力故。分别阿僧祇品随顺分别诸地陀罗尼光明力故。净阿僧祇品严胜陀罗尼光明力故。出生阿僧祇品随谕庄严陀罗尼光明力故。说阿僧祇品明净音声陀罗尼光明力故。照阿僧祇品。虚空藏陀罗尼光明力故。广阿僧祇品树提沙陀罗尼光明力故。成阿僧祇品海藏陀罗尼光明力故。其有十方诸天天王。诸龙龙王。夜叉夜叉王。乾闼婆乾闼婆王。阿修罗阿修罗王。迦楼罗迦楼罗王。紧那罗紧那罗王。人人王。梵天梵天王。若来问我。我即为彼开发显现。分别赞说。悉令安住此普眼经。善男子。我唯知此一法门。岂能尽知菩萨诸行。何以故。诸菩萨等究竟一切行故。究竟大愿海。一切劫海不断绝故。入众生海。应受化者悉随顺故。深入一切众生心海。出生如来十力智光明故。悉知一切众生诸根。随所应化不失时故。入一切佛刹海。出生佛刹坚固愿故。究竟恭敬供养一切佛海大愿力故。度一切法海解脱智故。深入功德海。如说修行故。度一切众生语言海。于十方刹转法轮故。善男子。汝诣南方。六十由旬。有一国土名曰海岸。彼有比丘名曰善住。应往问彼。云何菩萨修清净行。时善财童子。头面礼足绕无数匝。眷仰无量辞退南行

尔时善财童子。正念善知识教。正念普眼经。思惟彼佛自在神力。受持彼佛句味法云。修习正法入深法海。尽法源底摄取胜法。除灭痴曀了法宝洲至海岸国。周遍十方。推求大师。今在何所。见彼比丘经行虚空。阿僧祇天眷属围绕。时诸天众。为供养善住比丘故。于虚空中散诸天华。作众妓乐出微妙音。阿僧祇宝幢庄严虚空。时诸龙王。为供养故。兴不可思议沉水香云。遍满虚空。紧那罗王。为供养故作诸妓乐出妙音声。充满虚空。诸海神王。为供养故啸和雅音。阿修罗王。为供养故。兴不可思议宝云。庄严虚空。放不可思议光明。普照一切。以不可思议珍玩之具。庄严虚空。不可思议紧那罗王。充满虚空。离杀害心。恭敬供养善住比丘。不可思议诸罗刹王。与诸恶形罗刹鬼等眷属围绕。充满虚空。善住比丘大慈力故。不可思议诸夜叉王。与夜叉众俱。充满虚空。为守护善住比丘故。周匝围绕。不可思议诸梵天王。在虚空中。合掌敬礼。以人音声赞彼比丘。于一面住。不可思议诸净居天。与宫殿俱。为供养故。诣善住比丘。尔时善财童子。见虚空中如是供养。合掌敬礼善住比丘。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何正向佛法专求佛法。恭敬佛法修诸佛法。长养佛法积集佛法。熏修佛法净诸佛法。遍净佛法至诸佛法。我闻大圣善能教授诸菩萨法。云何菩萨修习佛法。常见诸佛未曾远离。常见菩萨同其善根。不离佛法智慧满足。不舍大愿。于一切众生究竟其事。于一切劫修菩萨行心无疲倦。不舍佛刹。普能庄严一切世界。悉能知见诸佛自在。不离有为修菩萨行。悉了如幻入一切趣。现受生死而无起灭。常闻正法未曾远离。悉能受持诸佛法云。不离慧光普照三世。尔时善住比丘。告善财言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。能问佛法一切智法及无师法。善男子。我已成就菩萨无碍法门。我已修习分别明了。逮得无碍明净慧光。得慧光已。观察一切众生心行无所障碍。观一切众生死此生彼无所障碍。于宿命智无所障碍。于未来智无所障碍。于现在世知一切众生无所障碍。于一切众生语言法中无所障碍。若一切众生来问难者悉能应答无所障碍。知一切众生根无所障碍。教化众生无所障碍。分别了知一切刹那罗婆摩睺姤路无所障碍。于三世海无所障碍。己身充满十方佛刹无所障碍。何以故。依无所有无作神通力故。善男子。我得此神通力故。于虚空中行住坐卧。游腾十方。于一念中。遍至东方一佛世界百佛世界。千佛百千佛无量佛世界。乃至不可说不可说诸佛世界。阎浮提微尘等世界。乃至不可说不可说佛刹微尘等世界。悉得睹见彼世界中一切诸佛及其眷属。以一切华香末香涂香。宝鬘幢幡。杂彩缯盖。众妙宝网。一切形像。供养彼如来应供等正觉。彼诸如来所可开现。宣明赞叹。悉闻受持。分别通达。彼佛所有过去净刹。我悉忆念。南西北方四维上下亦复如是。若有众生得见我者。皆悉毕定阿耨多罗三藐三菩提。如我所见。一切众生若大若小。若好若丑若苦若乐。为化度故。随其所应现同彼身。若有众生来至我所。悉令安住于此正法。善男子。我唯知此一无碍法门。云何能说菩萨修大悲戒。诸波罗蜜戒。乘大乘戒。不舍菩萨道戒。灭障碍戒。菩萨藏戒。不舍菩提心戒。一切佛法深心戒。念一切智不忘失戒。如虚空戒。一切世间无所依戒。不可坏戒。无譬谕戒。不浊戒。不杂戒。离疑戒。清净戒。离尘戒。离垢净戒。善男子。菩萨有如是等无量功德。我岂能知如实解说。善男子。于此南方。有一国土名曰自在。城名咒药。彼有良医名曰弥伽。汝诣彼问。云何菩萨向菩萨行。时善财童子。礼善住比丘足。乃至辞退南行

尔时善财童子。一心正念法光法门。具足法力正念诸佛。不断三宝叹离欲性。念善知识。普照三世。念诸大愿。究竟一切法界众生。于一切有为心无所著。观察一切诸法无常。悉能严净一切佛刹。心无懈怠。于一切佛及其眷属。心无所著。渐至彼国。入咒药城。求良医弥伽。今在何所。尔时童子。见彼良医。处正法堂。论师子座。与一万大众前后围绕为说轮字庄严光经。时善财童子。诣医弥伽。头面礼足。右绕毕。退住一面。合掌白言。大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何向菩萨行。云何学菩萨行。云何于生死中。常能不失菩提之心。云何得平等心。而无所趣。云何逮得坚固正直之心。一切世间无能坏者。云何生大悲力。而无忧恼。云何证净普门陀罗尼力。云何生智慧光。于一切法除灭痴闇。云何证诸辩力。分别诸法真实之藏。云何得正念力。受持一切清净法轮。未曾忘失。云何得净趣力。于一切趣普照诸法。云何得智慧力。于一切法得决定智了真实义。尔时良医。谓善财言。善男子。汝已先发阿耨多罗三藐三菩提心耶。答言唯然。尔时良医下师子座。五体投地敬礼善财。礼已。散妙金华。诸杂宝华。无价摩尼。胜末栴檀。无价宝衣。而以覆之。以如是等众妙供具。而供养之。敬重赞叹。作如是言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。若有能发阿耨多罗三藐三菩提心者。则为守护一切佛性。严净一切诸佛刹性。化众生性。为一切众生说如法性。顺一切业性。成满一切菩萨行性。不断一切诸大愿性。解离欲性。智慧明净普照三世一切法性。建解脱性。为一切佛之所护持。一切诸佛常共护念。善能随顺一切菩萨。一切贤圣。皆悉随喜为一切梵天恭敬礼拜。一切诸天恭敬供养。一切夜叉王之所建立。一切罗刹王恭敬供养。一切龙王而顶戴之。一切紧那罗王敬心赞叹。一切世界王皆悉敬念。彼为安慰一切众生。灭三恶道远离众难。救拔一切贫穷根本。安置天人快乐之处。遇善知识未曾远离。闻佛妙法发菩提心因净菩提心枝。得明净光照菩萨道。顺菩萨智住菩萨地。善男子。当知菩萨能为一切众生。作甚难事。难值难见。为一切众生而作父母。庄严众生。摄取一切诸天世人。除灭众生无量苦难。守护众生远离忧恼。菩萨为大风轮。安持众生。不令坠落三恶道故。菩萨为大地。生长一切诸善根故。菩萨为大海。具足无尽功德藏故。菩萨为日。明净慧光。普照世间。灭痴闇故。菩萨为须弥山王。功德善根最高大故。菩萨为月。令一切众生悉清凉故。菩萨为大将。悉能降伏一切魔故。菩萨为善丈夫。于法城中为君王故。菩萨为火。能烧众生诸贪爱故。菩萨为云。雨甘露法故。菩萨为正见。悉能长养诸妙根故。菩萨为方。显法海故。菩萨为桥。令诸众生度生死海故。尔时良医。称扬赞叹善财童子及诸菩萨。已即从口中放大光云。普照三千大千世界。照已。时大千世界。大神力天乃至诸梵天等。悉诣良医。时彼良医。即为方便。随顺分别广演显现。说轮字庄严光经。时彼大众。闻此经已。于阿耨多罗三藐三菩提。得不退转。所应作已还升本座。告善财言。善男子。我已成就所言不虚法门。分别了知三千大千世界诸天语言。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切语言。如此三千大千世界。十方无量无边不可说不可说三千大千世界。亦复如是。善男子。我唯知此菩萨所言不虚法门。云何能说诸菩萨行。彼诸菩萨随顺深入众生一切相海。随顺深入众生一切施设海。随顺深入诸名号海。随顺深入诸语言海。随顺深入诸句相续海。随顺深入诸解说句次第海。随顺深入诸解说句相续次第海。随顺深入诸如来海。随顺深入分别诸句海。随顺深入一切众生诸语言海。逮得一切圆满庄严微妙音声。出生分别诸文字轮。善男子。于此南方。有一国土名曰住林。彼有长者名曰解脱。汝诣彼问。云何菩萨。向菩萨道修菩萨道。成菩萨道思菩萨道。时善财童子。于良医所闻此法门。发深净信心。恭敬于法。决定知见。因善知识。得萨婆若。头面礼足。乃至辞退南行

尔时善财童子。正念菩萨所言不虚法门。入菩萨语言海。念一切众生微细方便海。思惟菩萨诸垢净法。出生菩萨善根光明。净修菩萨教化众生巧方便门。明净菩萨摄众生智。坚固菩萨正直心力。长养菩萨深心之力。净修菩萨种种欲力。信菩萨心。远离诸恶。愿心坚固。以大庄严而自庄严。心无疲倦。勇猛精进心不退转。具不可坏净信心力。金刚那罗延。所不能坏。摄取一切善知识教。无碍境界皆悉清净。无垢境界妙心现前。逮得普眼方便光明陀罗尼地。了法界地心常现前。知平等地非地。庄严清净。不着我所无二境界。逮得清净无碍智慧。了知法地无所障碍。知诸方地而不退转。分别了知一切业地。严净显现诸佛大地。得智慧轮分别三世。逮得普乐光明三昧。遍照身心。顺至一切诸境界地。如来智慧普照境界。兴起一切智慧波浪身。常不离佛法势力。为诸如来之所护持。其心悉与一切佛等。随顺智慧普照一切。其身充满一切刹网。成就大愿。己身容受一切法界。如是念已。渐渐游行。经十二年至住林国。周遍推求解脱长者。见已礼足。于一面住。作如是念。我得善利。见善知识。善知识者出兴世难。至其所难。得值遇难。得见知难。得亲近难。得共住难。得其意难。得随顺难。念已。白言大圣。我已先发阿耨多罗三藐三菩提心。欲值一切佛。欲见一切佛。欲得一切佛意。欲知一切佛心。欲得一切诸佛三昧。随顺一切佛一切大愿。欲满一切佛一切大愿。欲求一切佛智慧光明。欲自身中出一切佛。欲得诸明知一切佛自在神通。欲净一切佛力无畏法。欲闻一切佛法心无厌足。欲受一切佛法。欲持一切佛法。欲分别一切佛法。欲护一切佛教。欲与一切诸菩萨同。欲与菩萨同善根友。欲具菩萨诸波罗蜜。欲满一切诸菩萨行。欲发菩萨清净大愿。欲得一切诸佛菩萨因缘法藏。欲得一切菩萨无量法藏智慧光明。欲得一切菩萨诸三昧藏。欲出生一切菩萨诸通明藏。欲发大悲藏。教化众生无有穷尽。欲分别知游戏神通藏。欲分别知自在之藏。欲于自在藏心得自在。欲清净十种藏一向专求此诸功德诣长者所。欲满诸愿。欲超出生死。欲得自在法。欲具恭敬门。欲具方便门。欲远离诸垢。欲清净庄严。欲身心柔软。欲调伏诸根。白言。我闻大圣善教菩萨方便正道。普照一切显现妙法。示导津济开正法门。除灭颠倒拔疑惑刺。心离迷垢照除重闇。离诸烦恼永得清凉。弃舍谄曲超出生死。离不善根长养善根。远离诸趣无所染着。灭一切障求萨婆若。到法王城。其心安住大慈大悲。教菩萨行修诸三昧。其心安住随顺法门。发广大心具足诸力。照明一切诸群生心。唯愿大圣。为我分别。云何菩萨。向菩萨道修菩萨道。既修习已。令速清净菩萨之行。具成菩萨圆满净行。时解脱长者。以过去善根力佛威神力文殊师利忆念力故。入菩萨三昧门。其三昧门。名摄一切佛刹无量旋陀罗尼。入已。得清净身。于其身内。十方各见十佛世界微尘等佛及严净刹。一切大众过去所行。彼诸如来神力自在。一切大愿功德之具。诸清净行庄严正道。成等正觉转净法轮。教化众生究竟诸法。于其身内皆悉显现。而无杂乱不相障碍。如本相住。形色不同。种种庄饰。菩萨大众围绕庄严。显现一切诸佛自在。说诸愿门。示现无量自在神力。或于一刹。处兜率天。而作佛事。或于一刹。示现命终。或现受胎。或现处胎。显自在力。或现出生。或现处中宫。或现出家。或现往诣庄严道场。或现降魔。或现成佛。或现天宫夜叉乾闼婆诸世界王。大众围绕请转法轮。或现转法轮。或现入诸趣。或现般涅槃。或现分舍利。或现起塔种种庄严。彼诸如来为种种众生诸众生海。种种方便。种种根。种种烦恼习气。或于小众而现大众。所谓一由旬众现十由旬众。乃至不可说佛刹微尘等由旬众。而为说法。彼诸如来。以微妙音所说正法。善财童子悉闻受持。又见彼佛自在神力。不可思议菩萨三昧。尔时解脱长者。从三昧起。告善财言。善男子。我已成就如来无碍庄严法门。得此法门已。睹见东方阎浮檀光世界。星宿王如来应供等正觉。明净藏菩萨等一切大众。又见南方诸力世界。普香如来应供等正觉。心王菩萨等一切大众。又见西方香光世界。须弥灯王如来应供等正觉。无碍心菩萨等一切大众。又见北方圣服幢世界。自在神力无有能坏如来应供等正觉。自在势菩萨等一切大众。又见东北方一切乐宝世界。无碍眼如来应供等正觉。无碍化菩萨等一切大众。又见东南方香焰光世界。香智如来应供等正觉。自在慧焰光菩萨等一切大众。又见西南方普照慧日世界。法界轮幢如来应供等正觉。散一切化幢菩萨等一切大众。又见西北方普净现世界。一切佛宝无上幢如来应供等正觉。法幢王菩萨等一切大众。又见上方无尽佛性世界。无量慧光圆满幢如来应供等正觉。法界地幢王菩萨等一切大众。又见下方佛解脱光世界。无碍慧幢如来应供等正觉。一切众生世界幢王菩萨等一切大众。善男子。我见十方各一万佛刹微尘等如来。彼诸如来不来至此。我不往彼。善男子。我若欲见安乐世界无量寿佛。随意即见。妙乐世界阿閦如来。善住世界师子如来。善现圆满光明世界月慧如来。宝师子庄严世界毗楼遮那如来。善男子。如是等一切诸佛。随意即见。彼诸如来不来至此。我不往彼。知一切佛无所从来。我无所至。知一切佛及与我心皆悉如梦。知一切佛悉如电光。了知己心如水中像。知一切佛皆悉如幻。己心亦尔。知一切佛音声如响。己心亦尔。如是知。如是解。如是入。善男子。当知菩萨皆由己心。得诸佛法修菩萨行。净一切刹教化众生。出诸大愿一切智城。游戏神通不思议门。诸佛菩提一切自在无碍境界。皆由己心。具甚深智了一切法。是故善男子。以诸善根增长己心雨甘露法润泽其心。于境界中令心清净。勤修精进令心坚固。专念正法令心不乱。智慧明净远离心垢。明净慧光照察其心。生自在心发广大心。与诸佛等。如来十力以照其心。善男子。我唯修此如来无碍法门。云何能说菩萨诸行。无障碍智。无碍净行。安住观察现在诸佛三昧。得无涅槃三昧。具足三世平等正法。善知平等三昧境界之地。具足净身。住诸佛住。不坏境界。一切诸方法门境界。智门圆满。智慧观察。普照一切于己身中悉现一切世界成坏。而于己身及诸世界不生二想。究竟众行功德具足。善男子。于此南方。有一国土名曰庄严阎浮提顶。彼有比丘名曰海幢。汝诣彼问。云何菩萨。向菩萨道修菩萨行。时善财童子。头面敬礼解脱长者足。右绕毕。赞叹无量阿僧祇功德。眷仰观察。心无厌足。悲泣流泪。专念善知识。顺善知识。观善知识。由善知识得一切智。于善知识远离谄曲。于善知识发慈母心。远离一切无益法故。于善知识发慈父心。能生一切诸善法故。辞退南行

大方广佛华严经卷第四十六大方广佛华严经卷第四十七

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之四

尔时善财童子。正念思惟解脱长者教。念不可思议菩萨法门。思惟不可思议菩萨慧光。随顺深入不可思议甚深法界。摄取菩萨不可思议净妙功德。显现如来不可思议自在神力。解了不可思议庄严佛刹。分别知佛不可思议住持庄严安住境界。思惟不可思议菩萨境界三昧庄严。分别不可思议世界究竟无碍。向不可思议菩萨坚固净业深心。受持不可思议净业诸愿。渐趣南方。至庄严阎浮提顶国。周遍推求海幢比丘。见在静处结跏趺坐。三昧正受灭出入息。身安不动寂然无觉。从其足下出阿僧祇长者。阿僧祇婆罗门。皆悉顶冠众宝天冠。各赍妙宝上味饮食一切宝衣香华宝鬘末香涂香资生之具。摄诸贫穷安慰抚接。雨众宝物。令一切众生皆大欢喜充满十方。从其两膝出刹利婆罗门。皆悉聪慧。形色威仪服饰庄严皆悉不同。以微妙音训导众生。离恶修善住真实义。说四摄法。令众生欢喜充满十方。从腰两边。出一切众生数等五通仙人。或服草衣或树皮衣。皆执澡瓶持三奇杖。威仪庠序无有变异。游行虚空赞叹三宝。为众生说清净梵行。调伏诸根演真实义。摄取世间。令诸众生入智慧海。又复演说世间诸论。令次第住一切善根。充满十方。从其两胁出不可思议龙。不可思议龙女。显现不可思议诸龙自在。摄取众生。雨不可思议香庄严云。华庄严云。鬘庄严云。宝盖庄严云。宝幡庄严云。众宝庄严云。无价摩尼宝庄严云。宝璎珞庄严云。宝座庄严云。宝宫殿庄严云。宝莲华庄严云。宝冠庄严云。天形像庄严云。天女庄严云雨如是等云。各不可思议。普照十方一切世界。而以供养一切如来。普令众生皆大欢喜。充满法界。从胸德字。出无量阿僧祇阿修罗王。示现阿修罗王不可思议自在神力。震动一切诸大海水及百千世界。令诸山王皆相冲击。震动一切诸天宫殿。映蔽一切诸魔光明。悉如聚墨。降伏一切诸魔军众。除灭众生放逸高慢。离怒害心灭不善法。坏烦恼山弃舍战诤。又以神力觉悟诸生。厌离诸恶永绝生死。不着诸趣普令众生常乐寂灭。住菩提心。净菩萨行。住诸波罗蜜。究竟菩萨地。照一切法。普照诸佛方便之法。充满法界。从其背出阿僧祇声闻缘觉。应以二乘化众生故。着我见者教不净观。贪欲多者教慈心观。嗔恚多者教缘起观。愚痴多者教方便智观察诸法。为等分者说无著法。着境界者说妙愿境界。乐寂灭者教入诸趣饶益众生。充满法界。从其两肩出阿僧祇诸夜叉王。诸罗刹王。种种恶身。长短形色。乘种种乘。各与其众而自围绕。其有众生能行善者。及众贤圣诸菩萨等。若向正道若得果证。皆悉防卫而守护之。或作金刚力士守护诸佛及佛住处。若有众生。遭诸恐怖。亦防护之悉令无畏。诸疾病者令得除愈。诸在难者悉令解脱。除灭横死离诸热恼。教化众生令得实利。坏生死轮赞叹法轮摧外道轮。充满法界。从其腹出百千阿僧祇紧那罗王。各与百千阿僧祇阿僧祇紧那罗女眷属围绕。出百千阿僧祇乾闼婆王。各与百千阿僧祇阿僧祇乾闼婆女眷属围绕。出百千阿僧祇天娱乐音。说实相法赞叹诸佛。称美菩提及菩萨行。叹菩提门入法轮门。好乐一切自在法门。演说一切般涅槃门。摄持一切诸佛教门。欢喜一切众生之门。严净一切诸佛刹门。讲说一切诸法界门。除灭一切诸障碍门。宣明一切诸善根门。充满法界。从其口出百千阿僧祇转轮圣王。七宝具足四兵围绕。放无悭光雨摩尼宝。诸贫苦者悉令富乐无财施者令得惠施。为诸群生叹离杀盗邪淫之法。修习慈心。常说爱语。饶益众生。除灭妄语。远离恶口。摄取众生。远离两舌说和合语。离无义语说甚深法。悉令众生远离口过。赞叹大悲。令众生欢喜离嗔恚心。分别世间一切正法。观察因缘照明真谛。拔诸群生邪见毒刺。除灭疑惑离一切障。明法实义。充满法界。从其两目出百千阿僧祇日。普照十方灭一切闇。悉令众生除灭垢曀。远离一切恶道苦毒。令寒者得温。于垢浊佛刹。放明净光。广说乃至普照金银琉璃等一切世界及众生类。除灭众生心之重闇。悉令欢喜。能辨众生无量事业。庄严一切世界。妙法境界。充满法界。从其眉间出百千阿僧祇天王帝释。无量杂宝以为庄严。持释王法。普照一切诸天宫殿。震动一切须弥山王。悉令诸天于天境界生厌离心。叹功德力明智慧力。起直心力长深心力。严净念力坚固菩提心。远离欲乐。赞叹乐见一切诸佛。不叹乐境界乐。叹闻法乐。离世间乐。观察诸法智慧之乐。离阿修罗战斗恐怖灭烦恼军远离死畏。愿降众魔兴妙法山。说须弥山等广大法句。能辨众生无量事业。充满法界。从其额上出无量梵天。妙色端严世界无伦威仪庠序。演出妙音赞叹诸佛劝请说法。令众生欢喜。乃至能辨众生无量事业。充满法界。从其头上。出阿僧祇诸菩萨众。种种形色相好严身。放无量光网。现檀波罗蜜。赞叹布施。远离悭吝无所贪着。庄严一切世界。称扬净戒远离恶戒。安立众生菩萨律仪。叹大乘戒。出生大悲功德之藏。说一切有皆悉如梦。说五欲乐无有滋味。安立众生离烦恼法。称扬赞叹金色身业。赞叹慈心远离杀害。灭畜生趣。叹多闻力。安立众生于忍辱力。叹普照自在。远离放逸。安立众生于不放逸。叹禅波罗蜜。心得自在。拔邪见刺。赞叹正见。般若波罗蜜。乐智自在。叹随世间远离生死。而于诸趣自在受生。叹愿力满足。出诸通明自在寿命。赞叹一切陀罗尼力。出生愿力。净三昧力。现自在生。赞叹智慧。普照一切众生诸根。分别演说诸心心行。照十力智。赞叹自在萨婆若。充满法界。从其顶上。出百千阿僧祇佛身分。具足相好庄严。犹如金山。普照一切。出妙音声。充满法界。显现无量无边神力自在。普雨一切甘露法云。为坐道场菩萨。雨平等法云。为灌顶菩萨。雨普门法云。为深忍菩萨。雨普庄严法云。为童真菩萨。雨坚固山法云。为不退菩萨雨海藏法云。为成就直心菩萨雨普境界法云。为方便道菩萨雨自性地音声法云。为生贵菩萨雨随顺世间法云。为修行菩萨雨厌离法云。为治地菩萨雨长养法藏法云。为初发心菩萨雨精进法云。为信行者雨无尽门法云。为色界众生雨无尽平等法云。为大梵天雨普藏法云。为大自在天雨生力法云。为魔天王雨心幢法云。为化乐天雨净念法云。为兜率天雨净意法云。为夜摩天雨欢喜法云。为帝释天雨庄严虚空法云为夜叉王雨欢喜法云。为乾闼婆王雨自在圆满法云。为阿修罗王雨大境界法云。为迦楼罗王雨无量世界法云。为紧那罗王雨饶益众生胜智法云。为诸人王雨不可乐法云。为诸龙王雨欢喜幢法云。为摩睺罗伽王雨寂静法云。为地狱众生雨不乱念庄严法云。为诸畜生雨智慧法云。为阎罗王处雨无畏法云。为饿鬼处雨正希望法云。悉令众生向贤圣门。充满法界。彼诸如来。一一毛孔。各放阿僧祇净光明网。阿僧祇妙色。阿僧祇庄严。阿僧祇境界。辨阿僧祇事。充满十方

尔时善财。一心观察海幢比丘。念彼三昧法门。思惟不可思议菩萨境界。思惟无量无作现在庄严普门法门。观察法界庄严智慧。依佛智住。出菩萨力。建菩萨愿力。增广菩萨诸行。如是正立观察一日一夜。乃至七日七夜。半月一月。乃至六月六日。过此以后。海幢比丘从三昧起。尔时善财。叹未曾有。合掌白言。甚奇大圣。如此三昧最为甚深。如此三昧最为广大。如此三昧境界无量。如此三昧不可思议神力自在。如此三昧不可称量。如此三昧慧光明净。如此三昧阿僧祇庄严以为庄严。如此三昧境界不可坏。如此三昧无有退转。如此三昧普照十方一切世界。如此三昧具有无量义趣方便。大圣。其有菩萨入此三昧。能为一切除灭众苦。永绝地狱饿鬼畜生一切楚毒。远离诸难。令天人趣悉得寂静。令众生欢喜。常乐甚深禅定境界。厌离有为超出三界。发菩提心。长养智慧功德因缘。长养弥广无上大悲。生大愿力。照菩萨道。智慧庄严大波罗蜜。究竟出生大乘境界。智慧遍照普贤所行。得菩萨诸地智慧光明。具一切菩萨清净愿行。证一切智境。大圣。此三昧者。名为何等。善男子。此三昧名普眼舍得。又名清净光明般若波罗蜜境界。又名清净庄严普门。善男子。修习般若波罗蜜故。得此三昧。得此三昧时。即得百万阿僧祇三昧。大圣。此三昧唯有此功德境界。复有余耶。善男子。此三昧者。分别一切世界。无所障碍。究竟一切世界。无所障碍。游行一切世界。无所障碍。庄严一切世界。无所障碍。修治一切世界。无所障碍。严净一切世界。无所障碍。见一切佛。无所障碍。观一切佛功德。无所障碍。知一切佛自在神力。无所障碍。究竟一切佛力。无所障碍。度一切佛功德大海。无所障碍。雨一切佛净妙法云。无所障碍。度一切佛法。无所障碍。得一切佛转法轮智不可破坏。无所障碍。得一切佛清净大众海之源底。无所障碍。随顺普入十方世界。无所障碍。随顺观察十方佛法。无所障碍。大悲摄取十方众生。无所障碍。大慈充满十方世界。无所障碍。见十方佛心无厌足。无所障碍。随顺遍入众生大海。无所障碍。了知众生一切根海。无所障碍。分别一切诸众生海。无所障碍。善男子。我唯知此清净光明般若波罗蜜三昧法门。云何能说诸大菩萨究竟之行。诸大菩萨皆悉深入智慧大海。善能分别清净法界。智慧究竟一切法趣。慧光无量。充满一切。得大陀罗尼自在光明。一切三昧圆满清净。出生一切自在通明。深入一切无尽辩海。雷震一切诸地音声。悉能救护一切众生。我尚不能说彼所行。况其功德。显其境界。说其境界。照其法门。明其积聚诸功德藏。说其正道。诸三昧流平等智慧。善男子。于此南方有一住处。名曰海潮。彼有园林名普庄严。有优婆夷名曰休舍。汝诣彼问。云何菩萨。修菩萨道净菩萨道。时善财童子。欢喜无量。于海幢比丘所。不坚固中而得坚固。于不实中而得真实。究竟功德妙藏境界。得明净智。普照一切。逮得甚深三昧光明。到净解脱方便。观察一切世界。净诸法门。明净智慧。普照十方。头面礼足绕无数匝。眷仰观察辞退南行

尔时善财童子。正念思惟海幢比丘。心未曾舍。乐见无厌。顾恋圣音。目想慈颜。正念思惟。其心境界。三昧境界。愿行境界。正念思惟明净智慧。敬善知识。向善知识。念善知识教。于善知识起爱恭敬。又作是念。因善知识得见诸佛。善知识者。开示显现一切佛法。善知识者是奇特法。令人得见诸佛法故。善知识者为明净眼。令人见佛如虚空故。善知识者为善津济。令人于佛华池得源底故。渐渐南行至海潮处。见普庄严园林。七宝垣墙周匝围绕。诸妙宝树行列庄严。一切华树雨华如云布散其地。香树芬馨普熏十方。鬘树垂鬘宝树雨宝遍布庄严。众宝衣树弥覆一切。诸音乐树出微妙音。以如是等诸珍玩具而以庄严。此园林中有一万讲堂众宝合成。一万楼阁阎浮檀金以覆其上。一万宫殿毗楼遮那宝藏庄严。一万浴池众宝合成。七宝栏楯周匝围绕。八功德水湛然盈满。阎浮檀金沙净水宝珠遍布池底。四面宝阶端严齐正。宝多罗树周匝行列。凫雁鸳鸯孔雀哀鸾。异类众鸟游戏其中出和雅音。覆以金网。风自然起出微妙声。设众宝帐宝树周遍。建阿僧祇殊胜宝幢。放大光明照百由旬。百万池沼黑栴檀泥凝积池底。生宝莲华充满其中。从彼莲华出大光明普照一切。彼园林中有大宫殿名庄严幢。海藏妙宝以为其地。琉璃宝柱庄严殊妙。巍巍高大。犹若金山。众生见者无不喜乐。有阿僧祇净摩尼宝普照一切。出自然香。谓明相香。香王香。觉悟香等敷众宝座。谓莲华藏座。照诸方藏座。明净藏座。众生悦乐藏座。师子藏座。离垢宝藏座。不思议藏座。普门摩尼妙宝藏座。光严藏座。大海藏座。金刚师子藏座。无量窗牖妙宝庄饰。又张一万众妙宝帐。谓宝衣帐。妙宝华帐。宝树枝帐。摩尼宝帐。金帐。庄严帐。香帐。娱乐帐。自在龙王帐。马王帐。释天庄严宝帐。一万宝网绞络其上。谓金铃网。珍宝盖网。众宝像网。海藏珠网。青琉璃摩尼宝网。师子吼网。月摩尼网。香像网。众宝山网。宝王网。一万光明普照世界。谓夜光摩尼光明。日藏摩尼净宝光明。月幢摩尼妙宝光明。香阎光明。妙藏摩尼宝光明。钵昙摩光明。夜光摩尼净宝光明。大灯摩尼净宝光明。普照诸方摩尼光明。又出十种大香电光。雨十种云。出过诸天。谓十种黑栴檀云。十种曼陀罗华云。十种庄严云。十种鬘云。十种杂色衣云。十种宝云。十种天子云。十种天女云。十种菩萨云。常乐闻法。尔时休舍优婆夷。处金色藏座。海藏宝庄严网罗覆其身。吉由罗庄严出过诸天。大摩尼网庄严其首。师子珠宝无量如意净摩尼宝严饰其身。无量亿众恭敬围绕合掌而住。东方无量众生。诸梵天王梵身大梵梵辅。他化自在天王。乃至人及非人。一切诸王。来诣其所。南西北方四维上下亦复如是。其有得见此优婆夷者。一切众病皆悉除愈。心净离垢拔邪见刺。除灭障碍净无碍地。于彼地中长养善根成就诸根方便。摄一切智。一切陀罗尼门。一切三昧门。皆现在前。发一切愿门。究竟一切行门。出生一切净门。其心广大。出生一切通。得无碍身靡所不至。尔时善财童子。入普庄严园林。周遍观察。见休舍优婆夷处金色座。往诣其所。头面礼足绕无数匝。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。唯愿为我具足演说。答言。善男子。我唯成就一法门。若见闻念知亲近我者。皆悉不虚。善男子。若有众生。不种善根。不亲近善知识。不为诸佛所护念者。彼诸众生不能见我。善男子。若有众生。能见我者。则于阿耨多罗三藐三菩提得不退转。东方诸佛常来我所。处宝师子座为我说法。南西北方四维上下一切诸佛悉来我所。处宝师子座为我说法。善男子。我常见诸佛菩萨。未曾远离。善男子。我此大众有八万四千亿菩萨。皆我同行于阿耨多罗三藐三菩提得不退转。此普庄严园林一切众会。亦于阿耨多罗三藐三菩提得不退转。善财白言。大圣。发菩提心来。为久如耶。答言。善男子。我念过去。于锭光佛所。出家求道净修梵行。恭敬供养闻法受持。次于离垢佛所。出家求道净修梵行。恭敬供养闻法受持。次于妙幢佛。妙德佛。功德藏佛。毗楼遮那佛。普眼佛。梵寿佛。自在佛。善天佛。善男子。我于如是等三十六恒河沙佛所。出家求道净修梵行。恭敬供养闻法受持。了知一切诸佛智慧。初发菩萨心。充满法界。无量大悲摄取众生。发诸菩萨无量大愿。究竟十方法界。无量大悲普覆众生。于一切刹一切劫中。修习菩萨无量诸行无量三昧力。不舍不转菩萨正道。菩萨无量陀罗尼力。善能护持一切众生。菩萨无量净智慧力。方便正念普照三世。菩萨无量诸通明力。遍游一切诸世界网。菩萨无量诸辩才力。能以一言悦一切众。善男子。我有菩萨无量自在神力。能以一身满一切刹。善财白言。大圣久如当成阿耨多罗三藐三菩提。善男子。菩萨不为教化一众生故发菩提心。不为教化百众生。乃至不为教化不可说不可说转众生故发菩提心。广说如阿僧祇品。不可教化一世界众生故发菩提心。乃至不为教化不可说不可说世界众生故发菩提心。不为教化阎浮提微尘等众生故。不为教化三千大千世界微尘等众生故。乃至不为教化不可说不可说三千大千世界微尘等众生故发菩提心。菩萨不为恭敬供养一如来故发菩提心。乃至不为恭敬供养不可说不可说诸如来故发菩提心。菩萨不为净一刹故发菩提心。乃至不为净不可说不可说刹故发菩提心。菩萨不为净阎浮提微尘等刹故发菩提心。乃至不为净不可说不可说三千大千世界微尘等刹故发菩提心。菩萨不为护持一佛法故发菩提心。广说如上。菩萨不为满一愿故发菩提心。不为庄严一刹故。不为知一佛眷属故不为受持一佛法故。不为知一众生心海故。不为度一众生根海故不为知一世界诸劫次第成败故不为知一众生烦恼习气故。不为断一众生烦恼故。不为满一众生行故。发菩提心。欲教化一切众生故发菩提心。欲恭敬供养一切诸佛。欲严净一切佛刹。欲守护受持一切佛法。欲满足一切大愿。欲知一切佛眷属。欲知一切众生心海。欲知一切众生心心所行。欲知一切众生诸根轮。欲知一切世界一切劫数次第成败。欲知一切众生烦恼习气。欲断一切众生烦恼。欲满一切众生行故发菩提心。善男子。略说菩萨有如是等百万阿僧祇方便法门。菩萨悉应究竟了知。随顺智慧。究竟修习菩萨等行。净一切佛刹。心无倒惑。善男子。是故我发此愿。净一切刹。我愿乃满。断一切众生烦恼习气。我愿乃满。大圣。此法门者。名为何等。善男子。此法门名离忧安隐幢。我唯知此法门。诸大菩萨其心如海。悉能容受一切佛法。我当云何能知其行。诸菩萨心坚固正直。如须弥山。诸大菩萨则为见药。若有见者除灭烦恼。诸大菩萨则为净日。除灭一切众生痴闇。诸大菩萨则为大地。悉能载持一切众生。诸大菩萨则为智风。长养一切众生实义。诸大菩萨则为自在。以净智光普照一切。诸大菩萨则为庆云。随其所应雨甘露法。诸大菩萨则为净月。放诸功德光明之网。诸大菩萨则为帝释。悉能守护一切众生。我当云何能知其行。善男子。于此南方有一国土。名曰海潮。彼有仙人名毗目多罗。善能解说菩萨诸行。汝诣彼问。时善财童子。头面礼足绕无数匝。观察无厌悲泣流泪。正念思惟。得菩提难。遇善知识难。得与上人共同止难。得菩萨诸根难。满足菩萨正直心难。值遇同意善知识难。观真实难。如法正教难。出生妙心难。念一切智难。长养法明难。作是念已辞退南行

尔时善财童子。思惟随顺菩萨正教。净菩萨行。心能长养菩萨德力。心见诸佛。心欲菩提。心能发起长养大愿。心照十方一切诸法。心见法实。心覆一切无有散乱。心净智慧。观诸法界除灭痴闇。心净正直除灭障碍。心能降伏一切众魔。渐渐游行至海潮国。周遍推求仙人毗目多罗。时彼仙人在大林中。阿僧祇树庄严此林。宝叶普覆。诸华果树常以严饰。宝树雨宝遍散其地。大栴檀树周匝行列。诸沉水树常出妙香。尼拘律树。阎浮檀树。雨甘香果。优钵罗。钵昙摩。分陀利华。以为庄严。尔时善财。见彼仙人在此林中。服树皮衣萦发草坐。一万仙人以为眷属。如栴檀林栴檀围绕。往诣其所五体敬礼。念善知识能开导我萨婆若门。念善知识现真实道。念善知识能安置我一切智地。念善知识然智宝灯。明净慧光长养十力智慧光明。善知识道即一切智无尽之藏。善知识为灯。照一切智境界故。善知识为桥。度生死故。善知识为盖。生大慈力覆一切故。善知识为不虚。照一切法真实相故。善知识为海潮。满足大悲故。作是念已绕无数匝合掌而立。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。时彼仙人。观察大众而作是言。汝等当知。此童子者。已发阿耨多罗三藐三菩提心。请一切众生普施无畏。饶益一切众生。向深智海。欲饮一切诸佛法雨。欲尽一切法海源底。欲成世间智慧大海。欲兴大悲重云。欲雨甘露法雨。欲出世间明净智月。欲灭世间诸烦恼闇。欲长养一切众生善根。尔时大众。各持种种金色妙华香可悦乐。散童子上。头面礼足曲躬敬绕。作如是言。此童子者。悉能救护一切众生。灭三恶道。离阎罗趣一切诸难。消竭欲海除灭苦阴。舍愚痴闇断贪爱缚。能升功德金刚围山。建立世间智慧须弥。于世间出明净智日。显曜一切善根诸法。示导世间明识善恶。时彼仙人。告大众言。若有能发阿耨多罗三藐三菩提心者。得一切智。净一切佛功德之地。时彼仙人告善财言。善男子。我已成就菩萨无坏幢智慧法门。善财白言。大圣。彼法门者。境界云何。时彼仙人即申右手摩善财顶。摩已执善财手。即时善财自见其身。在于十方十佛世界微尘等佛所。见彼诸佛相好庄严。以阿僧祇宝珍玩之具。庄严其刹。又见彼佛眷属大海。所从闻法悉能受持。乃至不失一句一味。分别受持正法梵轮。受诸法云入佛大愿。净修诸力清净愿行。究竟诸功德藏。见彼诸佛。随应化度一切众生。见一切佛清净圆满大光明网。见已随顺无碍智慧光明。究竟佛力。或自见身。于一佛所。一日一夜。或复自见于余佛所。七日七夜。如是次第。于余佛所。或有半月一月。一岁百岁千岁。或百千岁百千亿岁。或百亿那由他岁。或半劫一劫百劫千劫百千劫。或百亿那由他劫。乃至不可说不可说那由他劫。或阎浮提微尘等劫。乃至不可说不可说世界微尘等劫。尔时善财。为无坏幢智慧法门照故。得明净藏三昧。无尽法门三昧照故。得游一切方陀罗尼光明。金刚圆满光明法门照故。得分别智意楼阁三昧。住平地庄严法藏般若波罗蜜精进照故。得佛虚空藏三昧光明。一切诸佛法轮三昧光明相照故。得三世圆满智无尽光明。时彼仙人放善财手。尔时善财即自见身还在本处。时彼仙人问善财言。汝忆念耶。答言唯然。大圣。善知识力故。善男子。我唯知此菩萨无坏幢智慧法门。我岂能知大菩萨行。诸大菩萨。皆得一切众生自在三昧。于一切时轮而得自在。出生诸佛无尽智慧。证一切佛严净慧灯。于一念中了三世事。于一切世间现净慧身。充满法界。随众生所应悉现其前。了知一切众生所行。圆满清净悉可爱乐。我岂能知大菩萨行。妙功德愿。严净佛刹。善察论机。智慧境界。甚深三昧。神力自在。解脱境界。游戏神通。法身音声。究竟智慧。如是等事非我境界。善男子。于此南方。有一国土。名曰进求。有婆罗门名方便命。汝诣彼问。云何菩萨向菩萨道。修菩萨道。时善财童子。欢喜无量。恭敬礼已绕无数匝。瞻仰观察辞退南行

尔时善财童子。为无坏幢智慧法门所照。决了诸佛不可思议自在神力。善知菩萨不可思议法门。又不可思议菩萨三昧智慧。以照其心。得一切时三昧光明。得一切相三昧境界光明。得明净智。令一切众生得胜妙处。得一切至处道法门。随顺世间行。心无有二。以明净智普照境界。得一切声闻明净忍藏。得无生忍知法实相。常行菩萨行。不舍菩萨心。增长萨婆若心。得十力明普照一切。乐妙法音心无厌足。如说修行住萨婆若。究竟一切智境界。出生无量菩萨庄严心。满足菩萨清净大愿。于一念顷。遍至一切诸佛刹网。教化成熟无量众生海。心无懈倦。悉见菩萨无量行境界。悉分别见一切世间。见诸佛刹种种庄严。于微细境界。悉能安置无量世界。又能见彼种种庄严。悉能分别无量世界诸语言法。又知无量众生欲乐。知诸众生无量所行。以无量方便教化众生。善知殊方。随其所应化度众生。念善知识渐渐游行至进求国。周遍推求彼婆罗门。时婆罗门。修诸苦行求一切智四面火聚犹如大山。中有刀山高峻无极。从彼山上自投火聚。尔时善财。诣婆罗门。头面礼足合掌而立。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。愿为我说。答言。善男子。汝今若能登此刀山投火聚者。菩萨诸行皆悉清净。尔时善财。作如是念。得人身难。离诸难难。得无难难。得净法难。值佛世难。具诸根难。闻佛法难。遇善知识难。得与同止难。得闻正教难。得正命难。顺趣正法难。此将非魔魔所使耶。非善知识而现善知识相。将非恶菩萨耶。而今为我作寿命难。作善根难萨婆若难。此非正教险恶道耳。远离法门萨婆若等一切佛法。作是念时。十万梵天在虚空中。作如是言。善男子。莫作是念。莫作是念。此是大圣。具足金刚智慧光明。精进不退。悉已究竟一切境界。欲竭一切众生贪爱大海。欲裂一切诸邪见网。欲烧一切众生烦恼。除灭愚闇普照一切。令一切众生离生死险难。除灭三世愚痴闇冥。放净光明普照一切。时诸梵天及自在天。众生主天等诸邪见天。作如是言。我造众生。我为一切世间最胜。我为最上。我为第一。是诸天等。见婆罗门修大苦行。五热炙身。见如是已。各于诸禅不得滋味。来诣其所。时婆罗门。以自在力而为说法。令灭邪见舍离我心。发大慈悲普覆众生。长养菩提正直之心。开四种道求佛法身。随所应化悉能示现。佛微妙音一切悉闻无有障碍。复有一万魔。在虚空中。以种种摩尼宝华散婆罗门。告善财言。善男子。此婆罗门苦行力故。放大光明。令我宫殿诸庄严具悉如聚墨。我不复乐。即与无量诸天天女眷属围绕来诣其所。为我说法。悉于阿耨多罗三藐三菩提得不退转。复有一万他化自在天。在虚空中。各持天华恭敬供养。作如是言。善男子。此婆罗门苦行力故。放大光明。令我宫殿诸庄严具悉如聚墨。我不复乐。即与眷属来诣其所。为我说法。令我于心而得自在。于烦恼中而得自在。于受生中而得自在。除灭障碍而得自在。于一切三昧而得自在。于庄严具而得自在。于寿命中而得自在。乃至令我于一切佛法而得自在。复有一万化自在天。在虚空中。以天妓乐恭敬供养。作如是言。善男子。此婆罗门五热炙身。放大光明。照我宫殿及庄严具。照已悉令我等不乐五欲不求欲乐身心柔软。与眷属俱来诣其所。为我说法。净心。明净心。善奇特心。柔软心。欢喜心。乃至逮得清净十力。长养离生出生无量清净之身。乃至得佛清净法身。得清净口。微妙音声遍至一切无所障碍。乃至得一切智。复有一万兜率陀天。与其眷属在虚空中。雨一切末香云。恭敬供养。作如是言。善男子。此婆罗门五热炙身时。我自于宫殿不乐须臾来诣其所。为我解说无著之法。少欲知足。长养善根。发菩提心。乃至究竟一切佛法。复有一万诸天三十三天及阿修罗。与眷属俱在虚空中。雨曼陀罗华云。摩诃曼陀罗华云。恭敬供养。作如是言。善男子。此婆罗门五热炙身时。我于天乐不须臾乐着。来诣其所。为我说法。远离欲乐。乃至为我说无常法变易不住。断除一切放逸高慢。长养发起菩提之心。又善男子。我见此婆罗门时。须弥山顶六种震动。我于尔时。心大恐怖。专求一切智。复有一万大龙王。伊那槃那难陀跋难陀等。兴黑栴檀香云。诸龙王女出妙乐音。雨天华云天香水云。恭敬供养。作如是言。善男子。此婆罗门五热炙身时。放大光明。普照一切龙王宫殿。令诸龙王离热沙苦金翅鸟怖。灭嗔恚热身体清凉。发欢喜心。发喜心已。而为说法。厌恶龙趣至诚悔过除灭业障。发阿耨多罗三藐三菩提心。乃至住一切智。复有一万夜叉王。种种供养此婆罗门及以善财。作如是言。善男子。此婆罗门五热炙身时。我及罗刹鸠槃荼等。悉于众生发大慈心。无所娆害。慈心力故。不乐宫殿。与眷属俱来诣其所。彼婆罗门。以大慈心荫覆我等。令我欢喜身心柔软安隐快乐。为我说法。乃至令无量夜叉罗刹鸠槃荼等。发阿耨多罗三藐三菩提心。复有一万乾闼婆王。在虚空中。作如是言。善男子。此婆罗门五热炙身时。放大光明照我宫殿。悉令我等得不思议乐。来诣其所。为我说法。乃至令发阿耨多罗三藐三菩提心得不退转。复有一万阿修罗王。在虚空中。右膝胡跪一心合掌。恭敬供养。作如是言。善男子。此婆罗门五热炙身时。一切阿修罗宫殿大地大海皆悉震动。我等尔时除灭高心。来诣其所。为我说法。远离一切谄曲幻心。得深法忍。安住不动。具足十力。复有一万迦楼罗王。勇力持等。化为外道童子。在虚空中。作如是言。乃至为我说法。安立大慈。赞叹大悲。度生死海。没于五欲泥者。叹净直心门。生慧方便翅。随其所应皆悉化度。复有一万紧那罗王。在虚空中。作如是言。善男子。此婆罗门五热炙身时。于我宝多罗树中。金铃网中。宝璎珞中。诸宝树中。种种乐器中。自然演出微妙音声。佛声法声比丘僧声。不退转诸菩萨声。菩提心声。某方某国有某菩萨。发菩提心。修行苦行。修大布施。庄严道场。往诣道场。成正觉声。善男子。我闻是声即大欢喜来诣其所。为我说法。令无量众生于阿耨多罗三藐三菩提得不退转。复有无量欲界诸天。在虚空中。供养恭敬。作如是言。善男子。此婆罗门五热炙身时。放大光明。乃至普照阿鼻地狱。除灭苦痛。若有众生见斯光者命终生天。知报恩故舍五欲乐。来诣其所乐观无厌。为我说法。乃至令无量众生发菩提心。尔时善财童子。闻奇特法。心大欢喜。于婆罗门所。发起真实善知识心。头面礼足。如是白言。向疑圣教。违知识教。唯愿大圣。受我悔过。时婆罗门。为善财童子。而说偈言

  欲求菩提者　　当顺知识教
  除灭诸疑惑　　一心常恭敬
  修习于正道　　知法真实相
  安住于道场　　成就佛菩提

尔时善财童子。即登刀山自投火聚。未至中间。即得菩萨安住三昧。既至火焰。复得菩萨寂静安乐照明三昧。得三昧已。白言。甚奇。大圣。如是刀山及大火聚。我身触时安隐快乐。时婆罗门。告善财言。善男子。我唯成此菩萨无尽法门。明净法王诸菩萨行。满足诸愿。悉灭众生烦恼邪见。得不退转。不可尽心。离懈怠心。一切无畏。得金刚那罗延藏。究竟大境界。无有疲倦。远离诸垢。不动如风轮。精进不退。以大庄严而自庄严。饶益众生。如是法门。我当云何能知能说。善男子。于此南方有城名师子奋迅。有一童女名弥多罗尼。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面礼足绕无数匝。观察无厌辞退南行

大方广佛华严经卷第四十七大方广佛华严经卷第四十八

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之五

尔时善财童子。起不可思议恭敬之心。好乐净法专向大乘。求诸佛智亲近如来。观法境界无所障碍。决定实际住实境界。至三世际。解了三世如虚空际。决定了知三世法际。不作法际住无碍际。不违业际。决定了知佛际非际。住如来住。灭一切妄想。不着一切佛。一切眷属。一切世界。知一切众生非我无实。一切音声离语言道。解一切色犹如电光。渐渐南行。至彼城已。周遍推问弥多罗女。为在何所。时有人答。今在师子幢王宫内。闻已即诣门下。求见彼女。时无量人众悉入宫中。善财问言。诸人今者为诣何所。答言。我等欲诣弥多罗女听受正法。尔时善财。作如是念。此王宫门。自在出入无所障碍。善财即入。见彼女人。处在明净宝藏法堂。地玻璃色。琉璃为柱。金刚为壁。阎浮檀金栏楯窗牖。光明普照。阿僧祇摩尼宝而庄校之。又千宝藏摩尼宝镜圆满庄严。众生所乐明净妙宝。以为严饰。又阿僧祇摩尼宝网。罗覆其上。百千金铃出微妙音。有如是等不可思议众宝校具。庄严讲堂。见彼女人。身如真金。目发绀色。处净水香宝师子座。覆以金网。敷众宝衣。大众围绕。以梵音声而为说法。见已头面礼足绕无数匝。合掌恭敬于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。答言。善男子。汝谛观此法堂庄严。尔时善财。见一一琉璃柱中。一一金刚壁中。一一摩尼镜中。一一形像中。一一宝中。一一庄严中。一一金铃中。一一宝树中。一一宝形像中。一一宝璎珞中。悉见法界等一切如来。从初发心。修菩萨行。成满大愿。功德庄严。成等正觉。转净法轮。乃至示现无余涅槃。如净水中见月影像。善财童子。于一切境界庄严具中。见一切佛。从初发心。乃至示现无余涅槃。亦复如是。皆是彼女过去善根依果力故。尔时善财。正念诸佛。恭敬合掌。白言大圣。此何法门。答言。善男子。是般若波罗蜜普庄严法门。我于三十六恒沙佛所。修此法门。彼诸如来各以异门。令我入此般若波罗蜜普庄严法门。善财白言。大圣。此法门者。境界云何。答言。善男子。我入此法门。正念思惟。分别受持。生平等时。得普门陀罗尼等百万阿僧祇陀罗尼门。以为眷属。所谓佛刹陀罗尼门。佛陀罗尼门。法陀罗尼门。众生陀罗尼门。过去陀罗尼门。未来陀罗尼门。现在陀罗尼门。安住实际陀罗尼门。功德陀罗尼门。功德具陀罗尼门。智陀罗尼门。智具陀罗尼门。诸愿陀罗尼门。分别诸愿陀罗尼门。行陀罗尼门。修集行陀罗尼门。净行陀罗尼门。满足行陀罗尼门。业陀罗尼门。不违业陀罗尼门。业流陀罗尼门。业所作陀罗尼门。远离恶业陀罗尼门。向正业陀罗尼门。业自在陀罗尼门。善行陀罗尼门。善行三昧陀罗尼门。三昧陀罗尼门。随顺三昧陀罗尼门。分别三昧陀罗尼门。无坏三昧陀罗尼门。诸通明陀罗尼门。心海陀罗尼门。种种心陀罗尼门。净心地陀罗尼门。普照重恶心陀罗尼门。心喜调御师陀罗尼门。发起众生陀罗尼门。烦恼陀罗尼门。习气陀罗尼门。烦恼方便陀罗尼门。欲陀罗尼门。众生所行陀罗尼门。众生种种业行陀罗尼门。众生世间自性陀罗尼门。众生相陀罗尼门。方陀罗尼门。说法陀罗尼门。大悲陀罗尼门。大慈陀罗尼门。寂灭陀罗尼门。诸言语道陀罗尼门。方便非方便陀罗尼门。随顺陀罗尼门。分别陀罗尼门。摄取陀罗尼门。无碍实际陀罗尼门。普陀罗尼门。佛法陀罗尼门。菩萨法陀罗尼门。缘觉法陀罗尼门。声闻法陀罗尼门。世间法陀罗尼门。世界起陀罗尼门。世界灭陀罗尼门。世界形色陀罗尼门。净世界陀罗尼门。垢世界陀罗尼门。于净世界现垢浊刹陀罗尼门。于垢世界现清净刹陀罗尼门。纯净世界陀罗尼门。纯垢世界陀罗尼门。平等世界陀罗尼门。翻覆世界陀罗尼门。伏住世界陀罗尼门。入因陀罗网陀罗尼门。回转世界陀罗尼门。住相陀罗尼门。小处置大陀罗尼门。大处置小陀罗尼门。分别佛身陀罗尼门。放佛庄严光明网陀罗尼门。分别如来圆满音声陀罗尼门。佛正法轮陀罗尼门。生佛法轮陀罗尼门。分别佛法轮陀罗尼门。无坏佛法轮陀罗尼门。佛辩法轮陀罗尼门。向佛法轮陀罗尼门。能作佛事陀罗尼门。向诸佛众陀罗尼门。分别诸佛大众陀罗尼门。诸佛无尽大眷属海陀罗尼门。普照佛力陀罗尼门。如来三昧陀罗尼门。如来三昧神力自在陀罗尼门。究竟佛事陀罗尼门。住佛所住陀罗尼门。佛持陀罗尼门。佛化陀罗尼门。佛知众生心心所行陀罗尼门。佛神力自在陀罗尼门。住兜率天陀罗尼门。乃至示现入般涅槃陀罗尼门。饶益无量众生陀罗尼门。诸甚深法陀罗尼门。诸庄严法陀罗尼门。菩提心色法方便陀罗尼门。菩提心起色陀罗尼门。愿色陀罗尼门。行色陀罗尼门。通明色陀罗尼门。出生死色陀罗尼门。清净智色陀罗尼门。清净慧色陀罗尼门。菩提无量色陀罗尼门。自心净色陀罗尼门。善男子。我唯知此般若波罗蜜普庄严法门。诸大菩萨心如虚空。入深法界功德成满。安住出世法。远离世间行。具足清净离痴慧眼。决定了知无量法界。智慧无量与虚空等。得无碍眼。于一切境界无所障碍。住无碍地藏。普照一切。善能分别一切法义。一切世间无能坏者。行世间行无所染着。善巧方便。饶益摄取一切众生。随其所应悉能示现。于一切时转正法轮而得自在。如是功德。我当云何能知能说。善男子。于此南方。有一国土。名曰救度。彼有比丘名曰善现。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面礼足。绕无数匝。辞退南行

尔时善财童子。正念思惟甚深法门。思惟甚深法界。思惟甚深法地。思惟甚深众生。思惟甚深诸行。思惟甚深众生心流。思惟甚深众生如光。思惟甚深诸法之性。思惟甚深众生语法。思惟甚深法界圆满庄严。思惟甚深种诸业行。思惟甚深世间业所庄饰。渐渐游行至救度国。于城都聚落村邑市里。仙人住处山林旷野。周遍推求善现比丘。见彼比丘在林经行。形貌端严颜容姝妙。其发右旋如绀青色。顶有肉髻身色紫金。其目长广如青莲华。唇口丹色如频婆果。颈项圆直修短得所。胸有德字。胜妙庄严。七处平满。其臂纤长。手指缦网。金轮庄严。佣髀鹿腨。腰腹不现。师子上身如净居天。其身圆满如尼拘树王。相好庄严。如雪山王。出诸良药。圆光一寻。诸根调伏。目视安谛。智慧无碍。犹如大海其心不动。一切世间。所不能坏。天龙八部恭敬围绕。彼比丘经行时。地天。持地步天。出宝莲华随覆其迹。无尽圆满天。除灭众闇。觉天。雨杂华云。不动藏天。现诸宝藏。普光胜虚空天。庄严虚空。妙德海天。散宝供养。离垢藏须弥山天。合掌礼侍恭敬供养。无碍力天。起香华风云而供养之。夜天。以庄严身五体敬礼。常觉日天。持明净宝幢。庄严虚空除灭闇冥。尔时善财。往诣其所。头面礼足。白言大圣。我向阿耨多罗三藐三菩提。求菩萨行。我闻大圣。善能开导诸菩萨道。云何菩萨学菩萨行。修菩萨道。愿分别说。答言。善男子。我年既少出家日近。自我生来。于三十八恒沙佛所。净修梵行。或于一佛所。七日七夜净修梵行。或余佛所。半月一月。一岁百岁。亿那由他岁。乃至不可说不可说岁。或一小劫半劫一劫。或阿僧祇劫。乃至不可说不可说阿僧祇劫。净修梵行。彼诸佛所。闻法受持。不违其教。庄严诸愿。究竟净修菩萨诸行。具足六波罗蜜。知菩提境界。知种种法轮。守护佛法。乃至正法灭尽。严净一切诸佛世界。出生三昧大愿力故。究竟菩萨一切净行。出生菩萨一切行愿力故。净一切佛诸波罗蜜。出生普贤诸行力故。善男子。我不离此经行处。悉见十方。智慧无碍故。一切法界。悉现在前。于一念中。过不可说不可说诸世界故。于一念中。严净不可说诸佛世界。出生大愿力故。不可说不可说众生方便门。悉现在前。具十力智。出生普贤菩萨行愿力故。见不可说不可说诸佛。悉现在前。于一念中。恭敬供养不可说不可说世界微尘等佛恭敬供养如来愿力故。能闻受持不可说不可说诸佛法云。分别了知阿僧祇诸法趣。出生法轮陀罗尼力故。不可说不可说菩萨行。悉现在前。一切诸行皆悉清净。满足菩萨因陀罗网行愿力故。不可说不可说诸三昧海。悉现在前。一切三昧皆悉净。满一三昧。出生一切三昧力故。不可说不可说诸根海。皆现在前。一切根轮。随顺时轮。出生安住诸根际愿力故。不可说不可说时轮。悉现在前。能一切时转净法轮。出生究竟众生愿力故。一切三世海。悉现在前。分别一切世界三世。出生随顺智慧光明愿力故。善男子。我唯知此随顺菩萨灯明法门。诸金刚灯菩萨生诸佛家。具足成就不死命根。无尽智慧。成无坏身肢体具足。随其所应悉能显现。具妙形色世无伦匹毒刃火灾所不能害。身如金刚不可沮坏。降伏众魔制诸外道。身真金色超出世间。随其所应无不闻见。普观世间雨甘露法。普照一切灭诸障碍。见者无厌。拔断一切诸不善根。起妙善根。难遇难见。我当云何能知能说彼功德行。善男子。于此南方。有一国土名曰输那。彼有童子名释天主。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。专求菩萨庄严正道。菩萨诸力照心修行。菩萨无坏无尽诸功德行。成满菩萨坚固大愿。以大庄严而自庄严。一切无畏。不退坚固正直之心。受持一切菩萨行云。受持菩萨正法之云。而无厌足。恭敬一切菩萨功德。摄取一切众生。常欲超出生死旷野。乐欲见闻恭敬亲近。于善知识心无厌倦。头面礼足恭敬无量。随顺教诲辞退南行

尔时善财童子。与天龙大众眷属围绕。至输那国。周遍推求释天主童子。时虚空中有诸天龙。而告之曰。善男子。此童子。在善城门外河水之侧尔时善财。见释天主与一万童子弄沙嬉戏。即诣其所。头面礼足绕无数匝。合掌恭敬于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。唯愿解说。答言。善男子。文殊师利。教我相黡子法。算数法。印法。我因知此三种法故。得一切巧术智慧法门。善男子。我因此法门故。知黡子算数印性。疾病中毒。为鬼所著。诸魔所持。悉能消伏。立大小城都邑聚落善恶之相。田业商估一切众生身肢节相。善趣恶趣行业之相。知此众生之于善趣。知此众生之于恶趣。此声闻。此缘觉。此如来地。诸方便相。如是等事我悉了知。普令众生修学此法。复次善男子。我亦了知菩萨算数之法。所谓百千为一罗叉。百千罗叉为一拘利。百千拘利为一那由他。广说如阿僧祇品。善男子。若有无量百由旬等大沙聚。我悉分别算知其数。善男子。如算法能知沙聚。算知东方一切世界。南西北方四维上下亦复如是。算知一切世界中。一切劫。一切佛。一切法。一切菩萨。一切业。算数了知。一切世界中。一切四谛名号。亦复如是。善男子。我唯知此巧术智慧法门。诸大菩萨深入一切算数法门。算数一切法。深入三世算数之法。算数一切众生。算数一切法。算数一切佛。算数一切佛名号。算数一切菩萨。一切算数转自在轮。菩萨我当云何能知能说彼功德行。发明境界。赞叹诸力。显正直心。说功德具。说诸大愿。显现清净诸波罗蜜。说功德藏胜妙智慧。善男子。于此南方。有城名曰海住。有优婆夷名曰自在。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。闻善知识教欢喜无量。得未曾有奇特正直心宝。其心弘广普覆众生。得算数诸佛次第出世自在法门。净法圆满智慧究竟。分别显现一切诸趣。于三世境界无所障碍。出生无尽功德海心。得大智慧自在光明。断三界缚。头面礼足。右绕三匝。辞退南行

尔时善财童子。于善知识心无厌足。犹如大海吞纳众流。善知识日。明净慧光开发其心。犹莲华敷。长养一切善根萌芽茎节枝叶功德大树。善知识月。能以清凉教法光明。除众热恼。善知识者如夏雪山。众兽所集乐。善知识心。犹如大海众宝充满。善知识教。长养法身。如阎浮树华果具足。心常乐住。善知识教法。譬如龙王于虚空中神变自在。善知识教起大宝山。显现一切。以善知识教而自围绕。犹如帝释降阿修罗无能坏者。渐渐游行至海住城。周遍推求自在优婆夷。时有人言。善男子。此优婆夷。在此城中深宫之内。善财闻已。往诣宫门敬心而立。彼优婆夷所住之处。广博严饰。众宝垣墙。周匝围绕。开置四门。阿僧祇宝以为庄严。善财进入见优婆夷。处师子座年在盛美。容色殊妙观者无厌。除庄严具素服被发。身色光明除佛菩萨余无能及。于其宫内敷十亿床出过天人。菩萨宿世行业所造。衣服饮食众妙宝物诸庄严具。常开四门周给一切而无穷尽。一万女众眷属围绕。容色威仪悉如诸天。犹如庄严众妙宝树。口常演出天妙音声。敬乐观察此优婆夷。礼拜供养。彼诸女身常出妙香普熏大城。若有闻者。皆得不退菩提之心。无怒害心。无怨敌心。无悭嫉心。无幻伪心。无谄曲心。无贪爱心。无嗔恚心。无懈怠心。无量心。平等心。大慈心。益众生心。净持戒心。无求欲心。闻彼音声皆悉欢喜身心柔软。其有见者皆得离欲。尔时善财。头面礼彼优婆夷足。敬心右绕于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。答言善男子。我成就无尽功德藏庄严法门。以一器食施百众生。随其所欲皆得充满千众生。百千众生。亿众生。千亿众生。百千亿众生。那由他众生。百那由他众生。百千那由他众生。乃至不可说不可说众生阎浮提微尘等众生。乃至不可说不可说佛刹微尘等众生。随其所欲皆悉充满而无损减。又复施与上味美膳辇舆衣服华鬘妙香末香涂香宝庄严具。又施床座车乘妙盖幢幡。如是等种种诸物。随其所欲悉令充满皆大欢喜。善男子。于东方一世界。乃至不可说不可说世界。阎浮提微尘等世界。乃至不可说不可说佛刹微尘等世界中。一切声闻缘觉。食我食已。悉成道果。又于东方。乃至不可说不可说佛刹微尘等世界中。一生补处菩萨。食我食已。降魔成道。南西北方四维上下亦复如是。善男子。汝见我此一万眷属女不。唯然已见。善男子。如是等百万阿僧祇菩萨。悉我同行。同愿。同善根。同修道。同欲性。同净正念。同清净趣。同菩提无量。同得诸根。同心依果。同境界。同正趣离生。同真实义。同明正法。同具菩萨清净妙色。同无量力。同坚精进。同正法音。同语言道。同诸功德。同清净业。同清净报。同清净大悲救护一切。同清净业不违因缘。同清净口业。于一切佛众随其所应悉为说法。同恭敬供养诸佛。同决定知一切诸法。同得菩萨清净诸地。此诸菩萨。取我器食。于一念顷遍游十方。供养一切声闻缘觉菩萨诸佛。及施饿鬼悉令满足。而我器食无所损减。善男子。我此器食。随应诸天悉令充满。乃至施人亦复如是。善男子。且待须臾汝自见之。善财即见无量人众从四门入。彼优婆夷皆令安坐。随所适乐悉令充悦。善男子。我唯得此无尽功德藏庄严法门。诸大菩萨无尽功德藏海。犹如虚空。以无量功德熏修其心。如随意宝。满足一切众生愿故。大功德城悉灭一切诸贫苦故。功德须弥雨众宝故。大功德藏开法城门故。功德灯明灭贫闇故。大功德盖胜妙善根覆一切众生故。我当云何能知能说彼功德行。善男子。于此南方有城。名曰大兴。彼有长者名甘露顶。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面礼足绕无数匝。忆念不舍辞退南行

尔时善财童子。得无尽功德光明法门。正念思惟彼功德海。观察彼虚空功德。趣彼功德聚。登彼功德山。摄彼功德藏。尽彼功德底。度彼功德海。净彼圆满功德。周遍观察彼诸功德。随彼功德藏。持彼功德教。净彼功德性。渐渐游行至大兴城。周遍推求长者甘露顶。乐求善知识。以善知识熏其身心。于善知识起正直心。观善知识常无厌足。学善知识勇猛精进。求善知识一切善根。同善知识一切善根。于善知识无嫌恨心满功德藏。学善知识种种方便。虽不由他悟。而常亲近诸善知识。长诸善根。净修菩提正直之心。增长一切菩萨诸根。成就一切善根。满足大愿。发广大悲。近一切智。不离诸佛。增长普贤菩萨所行。如来光明常照其心。尔时善财。见甘露顶。于彼城内。处七宝堂阿僧祇宝师子座上。金刚伊尼罗宝以为座足。离垢宝藏而以校饰。五百宝像以为庄严。建众宝幢。垂宝幡缯。张众宝帐。无量宝网罗覆其上。有人手执阎浮檀金盖。琉璃为竿。复有执持离垢宝佛。侍立左右。众妙杂香而以熏之。雨天华云。作五百种胜妙妓乐。娱乐城内。一万大众周匝围绕。颜容姝妙天人无伦。成就菩萨直心。庄严众生。悉常随顺甘露顶教。宿世同修诸善根故。尔时善财。头面礼足绕无数匝。恭敬合掌于一面住。白言大圣。我为利益一切众生故。发阿耨多罗三藐三菩提心。所谓灭一切众生苦恼。令安隐住究竟快乐。度生死海到法宝洲。消竭贪爱修大悲念。除五欲渴乐一切智。令究竟度生死旷野。常乐一切诸佛功德。超出三界至萨婆若城。而未知菩萨云何学菩萨行。修菩萨道。摄一切众生。长者答言。善哉善哉。童子。乃能发阿耨多罗三藐三菩提心。若能发心学菩萨道。修菩萨行。此人难得。求善知识。见善知识。亲近恭敬。于善知识其心不退而无厌足。善男子。汝见我此一万眷属不。唯然已见。我本为彼说种种法。令发阿耨多罗三藐三菩提心。生如来家修白净法。满足无量诸波罗蜜。具佛十力。离世间姓立如来姓。坏生死轮转净法轮。灭三恶道立正法趣。善男子。当知菩萨悉能救护一切众生。善男子。我成就此如意功德宝藏法门。随其所须悉满彼愿。谓以众宝车乘象马僮仆。衣服饮食香华末香。灯明汤药幢幡缯盖。随意眷属天冠宝饰。一切珍玩资生之具。尽给施之。乃至以法广施众生。善男子。且待须臾。汝自见之。即时善财。见诸方国城邑聚落。一切众生来诣其所。悉命令坐。时甘露顶。仰视虚空。随诸来会一切所须悉从空下。满足其愿。既充愿已。为说正法。悉令长养诸功德藏。消生死爱渴仰佛法。乃至具足大人味味之相。灭贫穷苦富甘露财。降伏众魔无能坏者。成就十力无上智慧。如是等类。悉满愿已。皆大欢喜。随所来方各还本处。善男子。我唯知此如意功德宝藏法门。诸大菩萨具足一切自在功德。成就宝手覆一切刹。雨无量云。谓众宝云。种种色庄严云。种种色宝天冠云。种种色衣云。种种妙声云。种种华云。种种周罗摩尼宝云。种种色香云。种种色盖云。种种色幢幡云。皆悉充满一切世界一切佛刹。一切诸佛及其眷属。为教化一切众生。令供养一切佛故。我当云何能知能说彼菩萨行。显其自在。善男子。于此南方有城。名师子重阁。彼有长者。名法宝周罗。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。欢喜踊跃。头面敬礼。绕无数匝。如弟子法。作如是念。因善知识。得一切智。于善知识。生无坏心。闻善知识教。悉能随顺。调伏诸根。作是念已。辞退南行

尔时善财童子。正念如意功德宝藏法门。守护彼功德藏。净彼功德须弥山王。得彼功德海之源底。开彼功德藏。观彼功德藏。圆满清净彼功德藏。摄彼功德藏。出生长养彼功德藏力。渐渐游行至于彼城。周遍推求长者法宝周罗。于道遇见。头面礼足。合掌恭敬。于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。时彼长者。执善财手。将归其家。善男子。且观我家。尔时善财。遍观舍宅。悉阎浮檀金色。七宝为墙。周匝围绕琉璃庄严。砗磲为柱。敷赤真珠宝师子座。建师子宝幢。张琉璃宝帐。如意珠网罗覆其上。阿僧祇宝而庄严之。马瑙宝池。八功德水盈满其中。一切宝树周匝围绕。其宅广大十重八门。尔时善财。见最下重。设众肴膳。惠施一切。见第二重。施杂宝衣。见第三重。施惠一切宝庄严具。见第四重。施内眷属。悉履善行巧于语言。见第五重。乃至五住菩萨。云集其中结集正法。离世间乐。出一切论。诸陀罗尼三昧法印。分别三昧智慧光明。见第六重。得般若波罗蜜菩萨充满其中。具甚深智。得寂静明智慧藏地无碍法门。超出三有。境界无碍。念不二法。结集般若波罗蜜门。分别解说般若波罗蜜门。所谓寂灭藏般若波罗蜜门。分别一切众生般若波罗蜜门。不动转般若波罗蜜门。离欲普照般若波罗蜜门。不可坏藏般若波罗蜜门。一切众生净眼般若波罗蜜门。海藏般若波罗蜜门。普眼般若波罗蜜门。一切无尽方便海般若波罗蜜门。随顺众生普照无碍般若波罗蜜门。庆云渐下般若波罗蜜门。结集如是等百万阿僧祇般若波罗蜜门。彼菩萨众。不可说庄严而庄严之。见第七重。响忍菩萨充满其中。出方便智。悉能闻持诸佛法云。见第八重。常住菩萨充满其中。具诸神通。遍一切刹。照一切众生。一切法界。具足法身。诣一切佛无所障碍。悉能受持一切佛法。见第九重。补处菩萨充满其中。见第十重。一切如来充满其中。从初发心修菩萨行。超出生死满足大愿。神力自在。一切佛刹及其眷属。转净法轮化度众生。显现住持。尔时善财。见如是等奇特事已。白言大圣。我未曾见如是清净大众。昔于何处种诸善根。今得如是胜妙果报。善男子。我忆过去。无量光明法界普庄严王如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出兴于世。彼佛入城。我以香华妓乐。而供养之。供养已。持此善根回向三处。谓灭除贫苦。常见诸佛菩萨及善知识。恒闻正法故获斯报。善男子。我唯知此满足大愿法门。诸大宝海菩萨。得不可坏清净法身。不可坏法云普覆一切。具足成就不可坏功德。不可坏大功德网。普覆一切。入不可坏三昧境界。具足菩萨不可坏善根。住不可坏如来所住。不可坏智慧。究竟三世。住一切劫。而无疲倦。住不可坏普眼境界地。我当云何能知能说彼功德行。善男子。于此南方。有一国土。名实利根。城名普门。彼有长者。名普眼妙香。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼法宝周罗足已。辞退南行

大方广佛华严经卷第四十八大方广佛华严经卷第四十九

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之六

尔时善财童子。思惟诸佛无量法门。逮得菩萨无量诸行。菩萨无量妙方便道。普照身心。乐求无量方便法门。成就菩萨清净解脱。菩萨无量清净诸根。菩萨无量诸清净力。心随菩萨无量诸行。出生菩萨无量大愿力。逮得菩萨不可沮坏妙智慧幢。普照一切。渐渐游行至于彼国。求普门城。心无休息精进不退。念善知识。赞善知识。随顺善知识诸根。专向普门法门。远离一切诸放逸行。开净慧眼度生死海。见普门城。百千小城周匝围绕高峻坚固。妙巧无比种种庄严。见普眼妙香长者。于此城中坐众香座。往诣其所头面礼足。恭敬合掌于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。答言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。我知一切众生病。风寒热病。及诸杂病狂横病。鬼着病。毒病。诸咒术病。如是等类。一切诸病我悉了知。随其所应皆能疗治。善男子。十方众生诸有病者。来诣我所。我悉能治。除其患已。沐浴香汤。香华璎珞。名衣上服而庄严之。肴膳饮食而供养之。无量珍宝而惠施之。然后为说种种法门。贪欲多者教不净观。嗔恚多者教慈心观。愚痴多者教法相观。等分行者教胜法门。称扬赞叹诸佛功德。发菩提心故。说长养大悲。于无量生死苦。心不厌故。分别广说诸波罗蜜。长养无量净智慧故。说诸大愿。教化成熟一切众生故。说普贤菩萨行。显现清净尸波罗蜜故。说不可思议如来功德。显现羼提波罗蜜故。说如来无坏清净法身。显现毗梨耶波罗蜜故。说如来无与等者。显现如来禅波罗蜜故。说清净法身。显现般若波罗蜜故。说一切净法身。令一切众生皆悉睹见。显现方便波罗蜜故。说于生死中住一切劫。显现愿波罗蜜故。说严净一切佛刹。显现诸力波罗蜜故。说净法身。随其所应悉令欢喜。显现智波罗蜜故。说常乐见清净法身。远离一切不善法故。善男子。我以如是等种种法施。悉令满足欢喜而还。善男子。我又善知和众香法。所谓不可称王香。新头香。胜香。觉香。明相香。沉水香。坚固香。栴檀香。云香。不动诸根香。知如是等一切诸香。烧此香时。一心向佛发大誓心。满一切愿。所谓救护一切众生。严净一切佛刹。恭敬供养一切诸佛。乃至烧一丸香时。充满十方一切法界。一切如来及其眷属。香帐庄严一切法界香。宫殿香。垣墙香。楼阁香。栏楯香。却敌香。窗牖香。半月香。盖香。幢香。幡香。网香。形像香。光明香。庄严具香云雨。庄严十方一切法界。一切诸佛及其眷属。善男子。我唯知此令一切众生欢喜普门法门。见一切佛身。诸大药王菩萨。若有闻见。亲近忆念。执持名号。皆悉不虚。其有见者。烦恼悉灭。得诸如来法之原底。灭除苦阴。永离一切生死恐怖。得无所畏。具一切智。破坏无量生死高山。安住正法。我当云何能知能说彼功德行。善男子。于此南方有城。名曰满幢王名满足。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼普眼妙香长者。绕无数匝辞退南行

尔时善财童子。次第忆念诸善知识。正念思惟善知识教。复作是念。善知识者。能摄取我。能守护我。令我不退阿耨多罗三藐三菩提。如是思惟。得大欢喜心。无量欢喜心。发清净心。寂灭心。广大心。庄严心。无著心。无碍心。虚空心。见诸佛菩萨心。自在心。顺诸法心。于一念中充满一切佛刹心。见如来心。念十力心。不舍诸佛善知识心。渐经人众城邑聚落。至满幢城。问满足王今在何所。有人答言。今在正殿。行于王法教化众生。应摄取者而摄取之应罚者罚。应治者治。诸有诤者断其诤讼。有恐怖者施以无畏。赞叹不杀。不盗。不邪淫。不妄言。不两舌。不恶口。不无义语。无贪恚痴。尔时善财。遥见彼王处金刚师子座。阿僧祇宝而以庄严。无量宝像以为庄饰。种种香云而普熏之。无量宝衣以敷其上。又复建立无量宝幢。无量宝幡。周遍垂下。张众宝帐顶冠如意摩尼宝冠。阎浮檀金半月庄严。发绀青色。耳普垂[耳*垂]。身佩无价摩尼璎珞。百千宝网罗覆其上。阎浮檀金盖。众宝为铃。常出妙音琉璃为竿。夜光宝藏。普照诸方。彼满足王。有大势力。离诸怨敌。无量自在。一万大臣。各处常位。修理王事。勇将一万。持仗侍卫。尔时善财。见无量众生犯王法者。身被五缚。或断手足。或截耳鼻。或挑双目。或斩身首。或投沸灰。或叠缠油灌。以火焚之。以如是等无量楚毒。而苦治之。尔时善财。作如是念。我为一切众生故。学菩萨行修菩萨道。今见此王。行大恶逆诸不善法。此乃恶中之恶。第一恶人。作是念时。虚空有天。而告之曰。善男子。汝当忆念普眼妙香善知识教。善财即时仰观虚空而答之言。我常忆念。天又语言。若常忆念。何故疑怪。善男子。菩萨方便不可思议。菩萨智慧不可思议。摄取众生不可思议。调伏众生不可思议。教化众生不可思议。愍念众生不可思议。度脱众生不可思议。尔时善财。闻天教已。诣彼王所头面礼足。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。时满足王。王事讫已。手执善财。将入宫内。命就宝师子座。而告之曰。善男子。汝观我家。善财即观。广大无极。七宝垣墙周匝围绕。七宝讲堂。无量百千众宝楼阁。而庄严之。乃至不可思议摩尼宝网。罗覆其上。五百侍女端严如天。如上所说。善男子。见我此报所因业不。答言已见。善男子。我成就菩萨幻化法门。我此国土杀生偷盗。乃至邪见诸群生类。不可教化离诸恶业。我为调伏令解脱故。化作人众种种苦治。令舍十不善道一切诸恶。具足十善得究竟乐。发阿耨多罗三藐三菩提心。具足一切智。善男子。当知我身口意。乃至蚁子不生害心。何况人耶。人是福田生诸善根。善男子。我唯知此幻化法门诸大菩萨得无生法忍。知一切有趣皆悉如幻。知菩萨行悉如变化。一切世间悉如电光。一切诸法皆悉如梦。深入无碍法界。具菩萨妙行境界无碍。摄一切行。于无量旋陀罗尼。而得自在。我当云何能知能说彼功德行。善男子。于此南方有城。名曰善光。王名大光。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子头面礼足。绕无数匝。辞退南行

尔时善财童子一心正念彼王智慧幻化法门。观一切法皆悉如幻。分别诸业专求正法。一心思惟彼王变化救度众生。思惟世间一切如幻。分别了知三世愿行悉如幻化。入净法界。渐经人众聚落城邑旷野诸难。心无疲倦。至善光城。问众人曰此城何名。答言。善光。尔时善财。作如是念。我善知识在此城中。我今必定见善知识。闻菩萨行。菩萨正法及诸法门。菩萨功德不可思议。境界不可思议。自在不可思议。平等法门不可思议。勇猛之力不可思议。我今必闻菩萨究竟境界。作是念已入善光城。见城七宝无量庄严。七重深堑周匝围绕。八功德水盈满其中。底布金沙。优钵罗。钵昙摩。拘牟头。分陀利华。遍满其中七宝垣墙七重围绕。所谓金刚师子垣墙。不可坏金刚垣墙。精进金刚垣墙。不可坏精进垣墙。无底金刚垣墙。净网垣墙。离欲清净金刚垣墙。是七重垣墙。阿僧祇宝而庄严之。其城奇特高峻广大十亿街巷。一一街巷。各有无量亿那由他阿僧祇人众。阿僧祇阎浮檀金楼阁。琉璃宝网。罗覆其上。不可思议白银楼阁。赤真珠网。罗覆其上。不可思议琉璃楼阁。庄严藏摩尼宝网。罗覆其上。不可思议玻璃楼阁。离垢摩尼宝藏网。罗覆其上。不可思议明净宝楼阁。日藏摩尼宝网。罗覆其上。阿僧祇因陀罗尼宝楼阁。妙宝光明网。罗覆其上。阿僧祇坚固宝楼阁。夜光宝焰网。罗覆其上。不可思议金刚楼阁。不可坏幢摩尼宝网。罗覆其上。不可思议沉水栴檀楼阁。摩诃曼陀罗华网。罗覆其上。如是等不可称说妙宝楼阁。以种种网罗覆其上。不可思议妙宝网。不可思议金铃网。不可思议香网。不可思议华网。不可思议衣网。罗覆其上。又张不可思议诸妙宝帐。不可思议珍妙宝盖。以覆其上。建立不可思议杂宝幢幡。而庄严之。当此城中。有一楼阁。名曰众生乐见无厌。阿僧祇摩尼宝。而以庄严。彼大光王常处其中。尔时善财。于此一切严饰珍妙。心无染着。一心乐欲见善知识。见大光王。处于法堂宝师子座。结跏趺坐。众宝庄严。敷以宝衣。万阿僧祇宝像以为庄严。种种妓乐而娱乐之。有二十八大人之相八十种好。而以庄严。身真金色如明净日。普照一切。如盛满月众宿中明。如梵天王处于大众。如大海中有众珍宝。如雪山中出诸良药。如大龙王雷震诸法实相音声。如虚空清净不受尘垢。如须弥山四种宝色。普照众生性海。譬如宝洲智宝充满。彼王殿前及诸街巷城四门外。处处安置众珍宝聚及诸宝衣。无量亿那由他诸采女众。容饰端严五欲无伦。姿好巧妙回动天人。六十四术无不备举。无量乳牛其角金色。乳味甘香一[穀-(一/禾)+牛]一石。又有无量诸庄严具。种种甘香。百味肴膳。无量音乐。及诸汤药。资生之具。一一街巷两边。各有二十亿菩萨。以此一切资生之具。而用惠施。摄众生故。悦众生故。净众生心故。灭众生烦恼故。令诸众生解实义故。安立众生一切智故。令众生离恶心故。拔出众生邪见刺故。净众生业道故。尔时善财。五体敬礼大光王已。右绕一匝于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻大圣善能解说。唯愿敷演。答言。善男子。我成就菩萨大慈幢行。清净满足。我于无量不可说不可说诸佛菩萨所。闻此妙法。观察清净。修习庄严。善男子。我住此行。如法治国。观察众生。顺行世间。如法教化众生。摄取众生。安置众生。饶益众生。如法熏众生。如法教众生。令修善根。观法真实。令诸众生。得慈心。大慈心。大慈力心。饶益心。离恐怖心。摄众生心。不舍众生心。发于大愿灭诸苦心。安隐众生令得快乐。身心柔软远离心垢。舍生死乐常乐正法。除烦恼垢得清净心。以一切善熏众生心。断生死流入深法海。灭诸有趣出无碍心。得一切智净诸心海。信力坚固无能坏者。善男子。我以如是安住此行。如法治国。令诸人民离众怖畏。有贫穷者来至我所。随所求索。常开库藏。而告之曰。恣意取之勿作众恶。此城众生悉向大乘。各见此城种种不同。或见垢秽。或见清净。或见木石。或见琉璃。或见无坏幢墙周匝围绕。或见不可思议楼阁。阿僧祇宝而以庄严。以正直心。修诸善根。于诸佛所求一切智。为我宿世所摄众生修菩萨行者。乃见此城众宝严净。余见垢秽。善男子。此城众生。五浊恶时。行诸不善。我愍念彼。入于菩萨大慈为首顺世三昧。入此定时。彼诸众生。恶心恼心。诤心害心。皆悉除灭。所以者何。此三昧力法如是故。善男子。且待须臾。汝自见之。时王即入大慈为首顺世三昧。入已善光大城六种震动。诸宝垣墙。楼阁宫殿。栏楯窗牖。却敌半月。宝铃罗网。诸宝形像。出妙音声赞叹彼王。其城内外一切人民。皆大欢喜。一心合掌敬礼彼王。诸畜生等慈心相向。亦礼彼王。山原树林。皆悉曲躬而向彼王。河池泉流皆悉向王。一万龙王。兴黑重云。雷震曜电。雨众香水。一万释天王。夜摩天王。删兜率天王。化自在天王。他化自在天王等。于虚空中。作亿那由他妓乐音声。阿僧祇天采女众妙音歌颂。雨阿僧祇华云。香云末香云鬘云盖云。杂色衣云。阿僧祇宝幢幡盖。庄严虚空。供养彼王。伊那槃那龙王。敷大莲华普覆虚空。垂阿僧祇妙彩缯带。阿僧祇宝而庄严之。阿僧祇宝鬘璎珞。天庄严具。诸妙华香。充满虚空。供养彼王。阿僧祇天女。充满虚空。称赞彼王。阿僧祇罗刹鬼等。常在大海。阎浮提住。饮血食肉。水陆恶兽。常害众生。皆得慈心。及寂静心。明信后世远离诸恶。心大欢喜五体投地。敬礼彼王。皆得无量身心快乐。阿僧祇毗舍阇鬼。及四天下毒害众生。三千大千世界。乃至十方各百万亿那由他世界中。毒害众生。亦复如是。时大光王。从三昧起。告善财言。善男子。我唯知此菩萨大慈幢行三昧。诸大菩萨以大慈盖。普覆救护一切众生。上中下品等观无二。慈如大地载育众生。菩萨满月。出功德光除众恼热。菩萨净日。智慧光明普照一切。菩萨明灯。除灭重闇。菩萨净水珠。灭众生心海烦恼垢浊。菩萨如意宝珠。随众生心悉令满足。菩萨疾风。速令众生修习三昧入一切智城。我当云何能知能说彼功德行。赞叹称量彼功德山。观彼功德。知大愿风轮。得真实地。分别了知庄严大乘普贤菩萨之所修行及诸三昧。赞大悲云。善男子。于此南方有城。名曰安住。有优婆夷。名曰不动。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。敬礼彼王。绕无数匝。辞退南行

尔时善财童子。正念思惟大光王教。思惟菩萨大慈幢行大慈为首随顺世间三昧。出生不可思议功德愿力。长养菩萨不可思议坚固智慧。思惟菩萨不共之法。思惟不可思议诸法实相。思惟菩萨不可思议眷属。思惟菩萨不可思议众事。作是思惟已。得欢喜心。离欲心。极踊跃心。谦下心。离垢心。明净心。坚固心。无畏心。无尽心。作是念时。悲泣流泪。复作是念。见善知识。则能出生一切功德。起菩萨行。清净正念陀罗尼。出生菩萨三昧光明。见一切佛。雨诸佛法云。分别解说菩萨诸愿。出生菩萨不可思议智慧光明。长养菩萨坚固诸根。念善知识。能离险道。念善知识。开示正路。念善知识。顺平等法。念善知识。显摩诃衍。念善知识。究竟普贤菩萨所行。念善知识。现一切智城。念善知识。度一切法界海。念善知识。普照三世一切法海。念善知识。长养一切诸白净法。念善知识。成满一切诸贤圣法。善财如是悲心念时。如来使天。随菩萨天。于虚空中。而告之曰。善男子。其有随顺善知识教。诸佛欢喜。其有随顺善知识教。近一切智。于善知识教。心无厌故。一切诸义悉现在前。善男子。汝诣安住王城。不动优婆夷所。是汝知识不久当见。尔时善财。从智慧光明三昧起。渐渐游行。至安住城。推问不动优婆夷今在何所。时有人言。善男子。不动优婆夷。在其家内。父母守护亲近。眷属周匝围绕。为无量众演说正法。尔时善财。欢喜无量即诣其门。入彼家内见其宫殿。金色光明皆悉普照。触斯光者身心柔软。尔时善财。光明触身。即得五百三昧门。所谓觉一切三昧门。奇特幢三昧门。寂静三昧门。远离一切众生三昧门。普眼三昧门。如来藏三昧门。得如是等五百三昧门。身心柔软如七日胎。又闻妙香出过天人。前诣其所合掌恭敬。一心观察见彼形色。天龙八部诸采女众。所不能及。十方世界一切女人无与等者。容色妙绝十方无伦。况有胜者。唯除诸佛。其宫殿严饰。十方世界无与等者。口出妙香。十方世界无与等者。其庄严具。十方世界无与等者。其眷属众。十方世界无与等者。何况有胜。除如来众。如是胜妙。不令众生起染着心。其有见者除灭烦恼。如梵天王。欲界烦恼不现在前。其有得见此优婆夷。一切烦恼皆悉除灭。十方众生乐观无厌。除明行足。尔时善财。见彼女人。不可思议法。不可思议三昧。不可思议无比妙色无量光明网一切无障。不可思议饶益众生。不可穷尽诸眷属海。观察不可思议身。无有厌足。尔时善财。以偈颂曰

  常持清净戒　　精进修忍辱
  譬如盛满月　　星中独明耀

尔时善财。偈赞叹已。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻大圣善能解说。愿为敷演。尔时彼女。以善语爱语。答善财言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。我成就菩萨无坏法门。修学菩萨坚固之行。得一切法平等地陀罗尼。得一切法平等法门。得离有庄严三昧。善财白言。菩萨无坏法门。乃至离有庄严三昧。境界云何。善男子。是处难知难说。善财白言。唯愿大圣。承佛神力。为我解说。我当因善知识。信知分别正念观察一心随顺。远离虚妄解了平等。尔时优婆夷答言。善男子。于过去世离垢劫中。有如来应供等正觉。号曰修臂。出兴于世。时有国王。名曰电光。我为王女。中夜寂静废音乐时。五百侍女皆悉昏寐。我在楼上仰观星宿。见彼如来在虚空中。如宝山王。天龙八部。不可思议大菩萨众。恭敬围绕。放大光明网。普照十方。彼佛毛孔出微妙香。我闻是香身体柔软。心大欢喜。恭敬礼拜一心合掌。仰观彼佛不见顶相。观身左右不见边际。相好庄严见无厌足。善男子。我于尔时。作如是念修何等业。出生如是身。长养如是身。具足如是身。清净如是身。自在如是身。光明眷属。诸庄严具。功德智慧。三昧陀罗尼。诸辩才藏。不可譬谕。善男子。时彼如来。知我心念。而告我言。汝应发不可坏心。除灭烦恼发胜妙心。不着一切有。发不懈怠心。随顺深入方便之法。发忍辱心。调伏众生诸恶心海。发离痴心。远离一切诸生死趣。发无厌心。见一切佛心无厌倦。发无知足心。悉饮一切诸佛法云。发寂静心。以一切佛方便。随顺世间。发守护心。护持一切诸佛法轮。发分别心。随其所应演说法宝。皆令欢喜。善男子。我于尔时。从彼如来。闻此法教。清净法门。求一切智。如来十力。所言不虚。光明庄严。清净法身。相好庄严。如来眷属。严净佛刹。如来威仪。如来寿命。我发是心时。一切烦恼。声闻缘觉。金刚诸山所不能坏。善男子。我发此心已。于阎浮提微尘等劫。不生欲想。何况其事。于尔所劫。自于眷属不生嗔心。何况余人。于尔所劫不生我见心。况我所心。于尔所劫。不生愚痴心。不生无记心。乃至胎中常起正念。何况余时。于尔所劫。乃至梦中见一切佛。况十眼观。于尔所劫。闻持一切诸佛法云。未曾忘失一句。乃至世间语言。尚不忘失。况如来语。于尔所劫。悉饮一切诸佛法海。乃至世法亦分别知。出生一切方便诸三昧门。心无虚妄。于尔所劫。受持一切诸佛法轮。于法轮中。不失一法。乃至无有二智。除化众生。于尔所劫。见一切佛海及诸化佛。于彼佛所满足大愿。于尔所劫。于一切菩萨海所。具足出生清净菩萨行海。于尔所劫。若有众生。得见我者。皆发阿耨多罗三藐三菩提心。乃至不生一念二乘之心。于尔所劫。于一切佛法。乃至一句一味不生疑惑。无有二想。无虚妄想。无种种想。无染着想。无好丑想。无爱恚想。善男子。我初发心来。常见诸佛菩萨及善知识。闻佛大愿修菩萨行。诸波罗蜜。智慧诸地无尽法藏。普入无量无边一切世界。分别无量众生界。不离清净智慧光明。除灭一切众生烦恼。长养发起众生善根。随其所应悉能显现。未曾舍离微妙音声。其有闻者皆悉欢喜。善男子。我入此无坏法门。观察一切法平等陀罗尼。显现无量自在神变。汝欲见不。唯然欲见

尔时不动优婆夷。入万三昧门。正念观察。所谓专求庄严正法心无疲厌三昧门。离痴庄严三昧门。十力三昧门。佛无尽藏三昧门。住如是等三昧门时。十不可说佛刹微尘等世界六种震动。净如琉璃。一一世界中。各见百亿如来。一一如来大众围绕。放大光明普照十方。或现兜率天。或现于一切世界。以妙音声转净法轮。乃至示现大般涅槃

时优婆夷。从三昧起告善财言善男子。汝见此不。唯然已见。善男子。我唯成就此无坏法门为一切众生。说微妙法。皆令欢喜。诸大菩萨。游行十方无有障碍。如金翅鸟王。悉得众生大海源底。若见众生有菩提因。从生死海而撮取之。安置菩提。譬如商人入大宝洲。专求如来十力大宝。游生死海教化众生除灭烦恼。如明净日。消竭爱水。开敷一切众生莲华。譬如疾风。游行十方。摧灭一切众生邪见烦恼树枝。譬如大地。长养一切众生。善根。如转轮王。以四摄法摄取众生。我当云何能知能说彼功德行。善男子。于此南方。有一国土。名不可称。城名知足。有出家外道。名曰随顺一切众生。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面礼足。绕无数匝。辞退南行

尔时善财童子。一心正念彼优婆夷。是我真善知识。念彼正教。念彼所说。念彼所发。念彼所开。念彼示现。念彼所叹。念彼所明。念彼广演。念彼修习。随顺思惟。修遍修寂静寂灭。照明观察。渐渐经由城邑聚落。于日没时入知足城。周遍推求随顺一切众生外道。今在何所。于中夜时。见彼城北有一大山。光明照耀如日初出。尔时善财。天明出城登彼山上。遥见外道静处经行。成就妙色超逾梵王。一万梵天眷属围绕。往诣其所。头面礼足。却住一面。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。答言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。我已安住至一切处菩萨之行。成就普观三昧法门无依无作神足。以平等般若波罗蜜光明。观察分别一切诸趣。一切众生。死此生彼流转诸有。种种杂类形色好丑。种种欲乐诸趣受生。所谓天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。地狱饿鬼畜生。阎罗王处人非人处。彼诸众生或着邪见。或好二乘。或乐大乘。以妙智慧种种方便。饶益众生。或教世间种种技艺。欲令众生得诸巧术陀罗尼门。或以四摄摄取众生。欲令一切得萨婆若。或叹诸波罗蜜。欲令众生得一切智回向。或叹发菩提心。欲令众生于诸善根不可沮坏。或叹菩萨行。欲令众生严净佛刹。满足大愿教化众生。或说厌离法。欲令众生知恶行果受三涂苦。或说净法。欲令众生发欢喜心。于诸佛所植众德本。得一切智果。或叹如来应供等正觉。欲令众生发弘誓愿。一向专求清净法身。或叹如来功德。欲令众生一向乐求佛无坏身。或叹如来无比妙法。欲令众生得佛一切无坏功德。复次善男子。此知足城内。一切人民男女长幼。随其所应我悉化度。彼诸众生莫知我谁。此阎浮提九十六种外道邪见。我悉为彼种种说法断其邪见。三千大千世界。乃至十方一切世界诸众生海。以种种智方便法门。种种诸事色像音声。化度饶益。亦复如是。善男子。我唯知此菩萨至一切处行法门。诸大菩萨身与一切众生数等。悉得分别一切众生身三昧。出生变化轮。遍游一切世界。一切诸趣。普现十方一切众生前。其有见者乐观无厌。悉能长养一切善根。住一切劫不舍大愿。得因那罗庄严光明之行。不着一切。专求实义。随顺众生。三世平等。照无我界。具足无尽大悲之藏。我当云何能知能说彼清净行功德智慧。善男子。于此南方。有一国土。名甘露味。彼有长者。名青莲华香。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼彼外道足。绕无数匝辞退南行

尔时善财童子。不惜身命不着财宝。远离炽然不着诸趣。不着世间五欲快乐。不着眷属势力自在。常乐化度一切众生。严净一切诸佛世界。恭敬供养一切诸佛。心无厌足。知一切法真实之相。欲得一切菩萨功德巨海满足大愿。于一切劫修菩萨行诣一切佛及眷属海。入一切菩萨三昧。悉能显现一切菩萨神力自在。于一毛孔见一切佛。心无厌足。悉闻受持一切诸佛正法轮云。心无厌足。专求此等一切菩萨诸佛功德。渐渐游行。至甘露味国。诣青莲华香长者所。头面礼足。绕无数匝。于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。向无上道。志求一切诸佛智慧。欲满一切诸佛大愿。欲净一切诸佛色身。欲见一切诸佛法身。欲知一切诸佛智身。欲净满一切菩萨诸行。欲照一切菩萨诸三昧门。欲成就一切菩萨诸陀罗尼。欲悉除灭一切障碍。欲遍游一切诸佛世界。而未知菩萨云何学菩萨行修菩萨道。生一切智。答言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。我能善知一切诸香。一切和香。一切熏香。一切涂香一切末香。一切香王。一切天香龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等香。除灭一切众疾病香。灭忧恼香。生一切众生诸喜乐香。长养诸烦恼香。除灭诸烦恼香。喜乐有为香。厌离有为香。放逸香。不放逸香。念诸佛香。顺正法香。贤圣人香。分别一切诸菩萨香。一切菩萨地香。一切菩萨住香。如是等香。我悉了知。彼香生起。所行成就。具足清净安隐。方便境界。行业根本。皆悉了知。善男子。人中有香。名大象藏。因龙斗生。若烧一丸。兴大光网云。覆甘露味国。七日七夜降香水雨。若着身者身则金色。若着衣服宫殿楼阁。亦悉金色。若有众生得闻此香。七日七夜欢喜悦乐。灭一切病无有狂横。远离恐怖危害之心。专向大慈普念众生。我知彼已而为说法。令无量众生。于阿耨多罗三藐三菩提。得不退转

大方广佛华严经卷第四十九大方广佛华严经卷第五十

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之七

善男子。复有香。名牛头栴檀。从离垢山王生。若以涂身火不能烧。复有香。名不可坏。从大海生。若以涂身。出妙音声降伏怨敌。复有香。名莲华黑沉水。从阿耨达池四岸边生。若烧一丸。悉能普熏阎浮提界。若有众生得闻此香。离一切恶具清净戒。复有香。名曰明相。从雪山王生。若有众生闻此香者。离诸垢染心得清净。而为说法。令彼悉得菩萨离垢圆满三昧。复有香。名曰海藏。从罗刹国生。应转轮王。若烧一丸。令四种兵列住虚空。复有香。名清净庄严。从善法堂生。若烧一丸。悉令诸天得念佛三昧。复有香。名曰净藏。从夜摩天生。若烧一丸。令彼诸天皆悉云集。诣夜摩天王听受正法。复有香。名先陀婆。从兜率天生。常在补处菩萨座前。若烧一丸。兴大香云。普覆十方一切法界。雨无量庄严。供一切佛及其眷属。复有香。名曰转意。从化自在天生。若烧一丸。于化自在天。七日七夜雨庄严雨。善男子。我唯知此香。诸大菩萨远离一切不善习气。永离五欲。灭除烦恼降伏众魔。断一切缚离三有趣。智慧妙香而自庄严。一切世间无所染着。具足成就无碍戒香。除灭障碍。智慧境界通达无滞。心常平等。我当云何能知能说彼功德行。清净戒门。身口意业离一切恶。善男子。于此南方有城。名曰楼阁。彼有海师。名曰自在。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼彼长者足。绕无数匝辞退南行

尔时善财童子。向楼阁城。观察正道。专求正道。观夷险道。垢净道。安危道。复作是念。因善知识。得菩萨道诸波罗蜜道。摄取众生入无碍法界。随顺一切众生。除灭一切烦恼炽然一切邪见。拔一切不善刺。度一切生死海。必至一切智城。何以故。因善知识。得一切善根。因善知识。得一切智。作是念已。渐渐游行至楼阁城。周遍推求自在海师。见在海岸船舶处住。十万商人及无量众。而围绕之。欲闻胜法。入大海法。佛功德海法。往诣其所。头面礼足。却住一面。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。答言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。能咨问我大乘妙宝。度生死海到一切智洲。得不可坏摩诃衍法。离二乘难住寂灭乐。远离生死洄澓流渊。逮得菩萨至处道法陀罗尼轮。菩萨庄严道。萨婆若道波浪。成就普法门。于一切法无所障碍。度一切智海。善男子。我成就大悲幢净行法门。在此海边楼阁城中。为贫穷者修诸苦行。欲令一切随意所求。悉充足已广为说法。皆令欢喜发起善根。长养功德智慧之藏。利菩萨根。发菩提心。净菩萨直心。增益菩萨深心。出生长养大悲之力。除生死苦。游生死海。而无疲倦。摄取众生海。令住功德海。得一切法智海光明。见一切佛海。度一切智海。善男子。我住此城。如是思惟。如是正念。饶益众生。善男子。我知海中一切宝洲。一切宝相。一切生宝。一切净宝及不净宝。知一切宝价。一切宝器。知一切宝随所应用。知作一切宝。知一切宝境界。知一切宝光明。知一切龙宫殿灭一切龙难。知一切罗刹宫殿灭一切罗刹难。知一切大身众生宫殿灭一切大身众生难。知趣知舍洄澓恐怖能离波浪。知相水色。知日月星宿。知诸算数。知昼知夜。知刹那罗婆摩睺姤路。知去知住安危之法。知海船舶牢不牢法。明候风相。而回转之。了所至处。善男子。我已成就如是智慧。利益众生故。入于大海。因为说法。悉令欢喜离生死怖。入一切智海。竭爱欲海。逮得三世光明智海。度一切苦海。清净一切众生心海。严净一切诸佛刹海。遍游一切十方界海。无所障碍。知一切众生诸根愿海。随顺一切众生行海。知一切众生随所应海。善男子。我成就此大悲幢净行法门。若有见闻忆念我者。皆悉不虚。善男子。我唯知此法门。诸大菩萨行于生死烦恼大海。无所染着。离邪见海。入实法海以善方便摄众生海。住一切智海。灭一切众生诸放逸海。善分别知时非时海。善方便知化众生海。未曾失时。我当云何能知能说彼功德行。善男子。于此南方有城。名曰可乐。彼有长者。名无上胜。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面礼足绕无数匝。悲泣流泪辞退南行

尔时善财童子。增广大慈大悲润泽。长养功德智慧庄严。离烦恼垢。入平等法。心不放逸拔不善刺灭一切障精进坚固修习菩萨不可思议三昧。慧光普照寂静快乐。功德水池解脱华敷。满足大愿。充满法界无所障碍。趣一切智。一向专求菩萨正道。渐渐游行至可乐城。周遍推求无上胜长者。城东有林。名离忧恼妙庄严幢。时彼长者在此林中。无量长者周匝围绕。理断国事。因为说法。离我我所及一切有。远离嫉妒。清净心海。安住净心。常见诸佛。得无垢信力。受诸佛法。起菩萨力。行菩萨行。出生菩萨诸三昧力。显现菩萨诸智慧力。演说菩萨正念之力。乐发无上菩提之心。尔时善财。诣长者所。以敬法故。五体投地。良久乃起。白言大圣。我是善财。我是善财。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。教化众生。常见诸佛。咨问正法悉能受持诸佛法云。专向一切诸方便门。于一切世界一切劫中。行菩萨行。知一切佛自在神力。能受一切诸佛所持。得诸佛力。时彼长者。告善财言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。我成就至一切趣菩萨净行庄严法门。无依无作神足之力。善男子。何等为至一切趣菩萨净行庄严法门。善男子。此三千大千世界一切阿修罗世间。一切迦楼罗。地狱饿鬼。夜叉罗刹。鸠槃荼乾闼婆。人非人等世间。三十三天。须夜摩天。删兜率天。乃至魔天世间。欲界所住一切生趣。一切天宫。一切龙宫。一切夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等宫。人中国土城邑聚落。于中说法。灭除诤讼诸恚害心。悉解系缚皆令出狱。离诸恐怖。灭不善业杀害众生乃至邪见。断诸王事及国土事。远不善法。悉令众生除灭诸恶。教以巧术及种种论。饶益一切皆令欢喜。随顺一切诸外道众。现胜妙智远离邪见乐于佛法。乃至梵天。广为说法。如此三千大千世界。乃至十方不可说不可说亿那由他佛刹微尘等世界中。广说正法。所谓佛法。菩萨法。众生法。声闻法。缘觉法。说地狱饿鬼畜生阎罗趣法。现恶道苦。说诸天趣。现诸天乐。说世间法。离世间法。显菩萨道离生死恶。说一切智诸妙功德。灭愚痴苦及诸障碍。欲令众生得离世乐。离诸虚妄解真实法。远离恶业灭诸烦恼。转净法轮。善男子。我唯知此至一切趣菩萨净行庄严法门。无依无作神通之力。诸大菩萨具足成就诸神通明佛刹等身。得普眼地。知语言道神力自在。具足智慧离诸诤讼。逮得大人广长舌相。出微妙音无能坏者。分别一切三世诸佛。亦无二想。明净智慧照三世法。境界无量净如虚空。我当云何能知能说彼功德行。善男子。于此南方。有一国土。名曰难忍。城名迦陵伽婆提。有比丘尼。名师子奋迅。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼彼长者足。绕无数匝。眷仰观察。辞退南行

尔时善财童子。渐渐游行至彼国城。周遍推问彼比丘尼。时有无量男女大众。答善财言。此比丘尼今在王园日光林中。以法饶益一切众生。尔时善财。诣彼园林周遍观察。见一大树名曰满月。放大光明照百由旬。复见大树名曰普覆。其形如盖放青光明。复见华树名曰华藏。高如雪山雨众华云。如天帝释波利质多罗树。复见大树名曰柔软。光明普照常有果实。复见大树名曰明净。不可譬谕。摩泥庄严。出阿僧祇清净妙宝。复见衣树。出阿僧祇妙宝衣藏。复见欢喜树。自然演出微妙音声。复见普庄严香熏树。出一切香。普熏十方无所障碍。复见彼园泉流渊池。栴檀行树周匝围绕。七宝栏楯以为庄严。黑栴檀泥凝渟其底。布以金沙。八功德水充满其中。优钵罗。钵昙摩。拘牟头。分陀利华。敷荣鲜茂遍覆其上。宝树周遍端严殊妙。一一树下。各敷无量师子之座。布以宝衣。熏以众香。张众宝帐。白净宝网罗覆其上。金铃网中出妙音声。或有树下敷莲华藏师子之座。或有树下敷香藏座。或有树下敷龙庄严藏座。或有树下敷宝聚师子座。或有树下敷明净普照藏座。或有树下敷师子乐藏座。彼一一座。各有十万宝师子座眷属围绕。无量庄严。散无量宝充满其中如海宝洲。宝衣布地柔软妙好。蹈则没足。举则还复。异类众鸟出和雅音。超越帝释欢喜之园。种种华树常雨华云。超胜帝释照明之园。妙香普熏。超于帝释善法讲堂。宝树乐树出微妙声。超过善口天女歌音。无量百千楼阁庄严。观者无厌。超逾帝释善现大城。此园一切诸庄严具。如梵天宫众生乐见。尔时善财。见此园林。皆是菩萨业行所成。出诸世间善根所起。供养不可思议诸佛所得。无能坏者。此皆师子奋迅比丘尼。了法如幻。长养功德藏善根所成。三千大千世界天龙八部无量众生。悉入此园而不迫迮。何以故。此比丘尼不可思议威神力故。尔时善财。见比丘尼遍处一切宝师子座。端严姝妙威仪庠序。其心寂静调伏诸根。譬如龙象。如澄净渊。如意宝珠。五欲不染犹如莲华。心无所畏如师子王。安住净戒不可倾动如须弥山。灭除众生诸烦恼热如凉香王。灭除众病如良药王。见者不虚。如婆楼那天。长养善根。犹如良田。见处一座。净居天众眷属围绕。为说无尽法门。又见处座。悦乐梵等梵众围绕。为说普妙音声法门。又见处座。无量他化自在天王等。天子天女眷属围绕。为说菩萨清净自在法门。又见处座。化自在天王等。天子天女眷属围绕。为说清净一切庄严法门。又见处座。删兜率天王等。天子天女眷属围绕。为说心藏旋复法门。又见处座。夜摩天王等。天子天女眷属围绕。为说无量庄严法门。又见处座。释天王等。天子天女眷属围绕。为说厌离法门。又见处座。娑伽罗龙王。十光明龙王。难陀跋难陀龙王。摩那斯龙王。伊那槃那龙王。阿耨达龙王等龙子龙女眷属围绕。为说善方便救护众生法门。又见处座。提头赖吒天王等乾闼婆男女。眷属围绕。为说无尽法门。又见处座。摩睺罗伽。阿修罗王等。眷属围绕。为说法界方便智庄严法门。又见处座。大势力迦楼罗王等。眷属围绕。为说于生死海无畏法门。又见处座。屯紧那罗王等。眷属围绕。为说佛行光明法门。又见处座。云山摩睺罗伽王等。眷属围绕。为说佛喜法门。又见处座。无量男子女人童男童女眷属围绕。为说胜趣法门。又见处座。常夺众生命罗刹王等。眷属围绕。为说起大慈大悲法门。又见处座。乐声闻者眷属围绕。为说胜智光明法门。又见处座。乐缘觉者眷属围绕。为说明净如来功德光明法门。又见处座。乐大乘者眷属围绕。为说普门三昧智慧光明法门。又见处座。初发心菩萨眷属围绕。为说一切佛大愿法门。又见处座。二地菩萨眷属围绕。为说离垢三昧法门。又见处座。三地菩萨眷属围绕。为说寂静庄严法门。又见处座。四地菩萨眷属围绕。为说一切智势力境界法门。又见处座。五地菩萨眷属围绕。为说净心华藏法门。又见处座。六地菩萨眷属围绕。为说明净藏法门。又见处座。七地菩萨眷属围绕。为说普地藏法门。又见处座。八地菩萨眷属围绕。为说法界法身境界法门。又见处座。九地菩萨眷属围绕。为说无有无著庄严法门。又见处座。十地菩萨眷属围绕。为说无碍三昧法门。又见处座。金刚力士眷属围绕。为说智慧金刚法门。见处如是等一切诸座。一切诸趣。一切众生。眷属围绕。种善根者为说善根。长善根者为说增长一切善根。随其所应而为说法。乃至于阿耨多罗三藐三菩提。得不退转。何以故。此比丘尼成就百万阿僧祇般若波罗蜜门故。所谓普眼般若波罗蜜门。说一切佛法般若波罗蜜门。分别法界般若波罗蜜门。坏散一切障碍般若波罗蜜门。出生长养一切众生善法般若波罗蜜门。胜庄严般若波罗蜜门。无碍藏般若波罗蜜门。法界圆满般若波罗蜜门。清净心藏般若波罗蜜门。一切众生乐藏般若波罗蜜门。得如是等百万阿僧祇般若波罗蜜门。于此园中。所有众生。皆于阿耨多罗三藐三菩提。得不退转。尔时善财。见师子奋迅比丘尼诸奇特事。所谓园林资生之具。经行威仪。宝师子座。大众眷属。诸妙功德。神力自在。微妙音声。如是一切诸奇特事。又闻微妙清净音声。宣扬赞叹不思议法。无量法云之所润泽。身心柔软。五体投地。恭敬礼已。将欲绕旋。见比丘尼遍一切座。自见己身及无量众树木园林。皆悉右旋。绕无数匝。如是见已。合掌恭敬于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。唯愿大圣。为我解说。善男子。我成就菩萨一切智底法门。大圣。如此法门体性云何。善男子。此法门者。智光庄严。于一念中普照三世。大圣。此智光庄严法门境界云何。善男子。入此法门。现前正受一切法林三昧时。十方一切世界诸佛。处兜率天者。于彼一一佛所。从其自身。出生不可说不可说佛刹微尘等摩[少/兔]摩身。恭敬礼拜。又赍不可说不可说佛刹微尘等华香缨珞。诸妙宝鬘。末香涂香。衣盖幢幡种种宝华云。乃至一切庄严具云。宝网宝帐庄严网等种种宝座。以如是等诸供养具。供养如来。如兜率天所兴供养。降神母胎。出生在宫。舍家学道。诣菩提树。成最正觉。转净法轮。在诸天上人非人中。乃至般涅槃所兴供养。亦复如是。若有众生。知我供养。皆于阿耨多罗三藐三菩提。得不退转。其有众生来至我所。即为彼说般若波罗蜜。我不起众生想。不取众生相。知一切语言而不着语言。见一切佛不取佛相。深解法身故。受持一切诸佛法轮。而亦不取法轮之相。解了诸佛真实相故。于念念中。悉能充满一切法界。而亦不取法界之相。了一切法犹如幻故。善男子。我唯知此菩萨一切智底法门。诸大菩萨究竟法界一切无著。一身结跏趺坐充满法界。于自身内。悉能显现一切佛刹。于一念中。悉能往诣一切佛所。于自身内。悉能显现诸佛神力。能以一毛举不可说不可说诸佛世界。于一毛孔。现不可说不可说世界成败。于一念中。摄取不可说不可说众生。于一念中。摄取不可说不可说劫。我当云何能知能说彼功德行。善男子。于此南方。有一国土。名曰险难。城名宝庄严。有一女人。名婆须蜜多。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼比丘尼足。绕无数匝。眷仰观察。辞退南行

尔时善财童子。大慧光明以照其心。具足长养一切种智。一心思惟诸法实相。建立一切语言陀罗尼藏。广修受持一切法轮陀罗尼。为众生归长大悲力。方便观察一切种智。满法界等清净大愿。明净慧光普照十方众生。一切庄严诸通明力。充满十方一切世界。究竟成满菩萨诸业。渐渐游行。至险难国宝庄严城。推问婆须蜜多女。今在何所。尔时有人。不知彼女深智慧者。作如是念。今此童子威仪庠序。其心寂静调伏诸根。远离放逸颠倒惑乱。念慧现前视瞻详审。言音和雅不着形色。正念思惟甚深法相。远离懈倦心如大海。此非染欲颠倒之人。无情欲想。不没欲泥。不随诸根。行出魔界。不服五欲。不为一切诸魔所缚。所不应作已能不为。有何等意而求此女。其中有人。先知彼女有智慧者。作如是言。善哉。童子。得大善利。乃能推求深智女人。当知童子。一向求佛。悉欲摄取一切众生拔诸欲刺坏散净想。善男子。今此女人。在此城中深宫之内。尔时善财闻此语已。心大欢喜往诣其门见彼宫宅严饰广大。十重宝墙周匝围绕。列植十行宝多罗树。十重深堑。八功德水充满其中。底布金沙。妙宝莲华。优钵罗。钵昙摩。拘牟头。分陀利。敷荣鲜茂弥覆水上。出微妙香。能转人心不生垢染。众宝宫殿台观楼阁。阿僧祇宝以为严饰。绀琉璃地洒以香水。熏以沉香。涂以栴檀。宝网罗覆。阎浮檀金以为垂铃。出和雅音。散众宝华犹如降云。诸妙庄严说不可尽。金刚摩尼真珠宝藏充满宅内。十种园林以为庄严。尔时善财见彼女人处宝师子座。颜貌端严妙相成就。身如真金目发绀色。不长不短。不白不黑。身分具足。一切欲界无与等者。何况有胜。言音婉妙世无伦匹。善知字轮技艺诸论。成就幻智菩萨方便。以阿僧祇宝庄严其身。宝网罗覆。首冠天冠。大众围绕皆悉修善。同其愿行成就善根不可沮坏。具足无尽功德宝藏。身出光明普照一切。触斯光者欢喜悦乐。身心柔软灭烦恼热。尔时善财头面礼足。绕无数匝。恭敬合掌。于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。答言。善男子。我已成就离欲实际清净法门。若天见我我为天女。若人见我我为人女。乃至非人见我。我为非人女。形体姝妙。光明色像殊胜无比。若有众生。欲所缠者。来诣我所。为其说法皆悉离欲。得无著境界三昧。若有见我得欢喜三昧。若有众生。与我语者。得无碍妙音三昧。若有众生。执我手者。得诣一切佛刹三昧。若有众生。共我宿者。得解脱光明三昧。若有众生。目视我者。得寂静诸行三昧。若有众生。见我频申者。得坏散外道三昧。若有众生。观察我者。得一切佛境界光明三昧。若有众生。阿梨宜我者。得摄一切众生三昧。若有众生。阿众鞞我者。得诸功德密藏三昧。如是等类一切众生。来诣我者。皆得离欲实际法门。善财白言。大圣。昔于何所种诸善根。修何等业得此法门。答言。善男子。过去有佛。号曰常住如来应供等正觉。出兴于世。彼佛哀愍饶益诸群生故。入安乐城。足蹈门阃。即时大地六种震动。其城自然奇妙广博众宝庄严。散诸杂华。自然演出娱乐之音。放大光明。一切诸天充满虚空。广说如佛入城经中现奇特事。善男子。我于尔时为长者妇。名曰善女。见如是等诸奇特事。从夫长者出于道巷。奉彼如来妙宝天冠。时文殊师利。为佛侍者。为我说法。发阿耨多罗三藐三菩提心。善男子。我唯知此离欲实际法门。诸大菩萨。成就无量方便智慧广大智藏。智慧境界无能坏者。我当云何能知能说彼功德行。善男子。于此南方有城。名首婆波罗。彼有长者。名曰安住。彼常供养栴檀佛塔。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼彼女人足。乃至辞退南行

尔时善财童子渐渐游行。至于彼城。诣长者所。乃至白言。大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。答言。善男子。我已成就不灭度际菩萨法门。住此法门。普见十方一切世界。去来今佛无涅槃者。除化众生方便灭度。善男子。我开栴檀佛塔户时。念念正受无尽佛性三昧门。于念念中。得无量无边胜妙诸法。白言大圣。此三昧者境界云何。答言。善男子。我入此三昧时。见此世界迦叶佛拘那含牟尼佛。尸弃佛。毗婆尸佛。提舍佛。弗沙佛。无上胜佛。无上莲华佛。见如是等不可说不可说诸佛。阎浮提微尘等佛。乃至不可说不可说佛刹微尘等佛。见此诸佛。从初发心。神力自在。一切大愿清净妙行。诸波罗蜜。次第成就。菩萨诸地。得深法忍。降伏众魔。长养成就自在菩提。净诸佛刹。种种大众。教化众生。放大光明。转净法轮。神力变化。皆悉受持正念思惟。智慧分别。彼诸佛法显现众生。见知未来弥勒佛等一切诸佛。现在卢舍那佛等一切诸佛。亦复如是。如此世界见知十方三世一切诸佛声闻缘觉菩萨。亦复如是。善男子。我唯知此不灭度际菩萨法门。诸大菩萨一念悉知三世诸法念际平等而无有二。住佛所住。于一切劫而无劫想。随顺诸佛平等正法。如来及我一切众生等无有二。净庄严智照三世间。成就诸佛不转威仪。分别一切法界境界。我当云何能知能说彼功德行。善男子。于此南方有山。名曰光明。彼有菩萨。名观世音。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子头面敬礼彼长者足。绕无数匝。眷仰观察。辞退南行

大方广佛华严经卷第五十大方广佛华严经卷第五十一

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之八

尔时善财童子。正念思惟彼长者教。随顺菩萨解脱之藏。正念菩萨诸忆念力。次第分别一切诸佛及诸佛法。一心正念诸佛法流。忆念受持彼诸佛法。及佛庄严长养菩提。思惟正念一切诸佛不思议业。渐渐游行至光明山。登彼山上周遍推求。见观世音菩萨住山西阿。处处皆有流泉浴池。林木郁茂地草柔软。结跏趺坐金刚宝座。无量菩萨恭敬围绕。而为演说大慈悲经。普摄众生。见已。欢喜踊跃不能自胜。合掌谛观目不暂瞬。作如是念。善知识者则是如来。善知识者一切法云。善知识者诸功德藏。善知识者十力妙宝。善知识者难见难遇。善知识者无尽智藏。善知识者功德山王。善知识者开发示导一切智门。能令一切入萨婆若海。究竟清净无上菩提。时观世音遥见善财。告言。善来童子。专求大乘摄取众生。直心深心乐求佛法。长养大悲救护一切。向普贤行。清净成满一切大愿。欲闻受持一切诸佛一切法云。增长善根而无厌足。顺善知识不违其教。从文殊师利智慧功德大海所起。成就善根。得佛势力光明三昧。离懈怠心专求正法常见诸佛。远离众恶修诸善行。智慧成满净如虚空。尔时善财诣观世音。头面礼足绕无数匝。恭敬合掌于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。答言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。我已成就大悲法门光明之行。教化成熟一切众生。常于一切诸佛所住。随所应化普现其前。或以惠施摄取众生。乃至同事摄取众生。显现妙身不思议色摄取众生。放大光网。除灭众生诸烦恼热。出微妙音而化度之。威仪说法。神力自在。方便觉悟。显变化身。现同类身。乃至同止摄取众生。善男子。我行大悲法门光明行时。发弘誓愿。名曰摄取一切众生。欲令一切离险道恐怖。热恼恐怖。愚痴恐怖。系缚恐怖。杀害恐怖。贫穷恐怖。不活恐怖。诤讼恐怖。大众恐怖。死恐怖。恶道恐怖。诸趣恐怖。不同意恐怖。爱不爱恐怖。一切恶恐怖。逼迫身恐怖。逼迫心恐怖。愁忧恐怖。复次善男子。我出生现在正念法门。名字轮法门故。出现一切众生等身。种种方便。随其所应。除灭恐怖而为说法。令发阿耨多罗三藐三菩提心。得不退转。未曾失时。善男子。我唯知此菩萨大悲法门光明之行。诸大菩萨一切普贤大愿成满。究竟成就普贤所行。不断一切诸善根流。不断一切菩萨诸三昧流。一切劫流。修菩萨行未曾断绝顺三世流。善知一切成败诸世界流。断一切众生不善根流。出生一切众生诸善根流。除灭一切诸生死流。我当云何能知能说彼功德行。尔时东方有一菩萨。名曰正趣。来诣此土。住金刚山顶。至此山时。娑婆世界六种震动。众宝庄严。放大光明映蔽日月释梵天龙八部光明。悉如聚墨。普照地狱饿鬼畜生阎罗王处。灭除众苦。断除烦恼及诸病苦。普雨宝雨充满佛刹。乃至普雨一切庄严云雨。供养如来。随其所应示现其身。然后来诣观世音所。时观世音告善财言。善男子。汝见此众中正趣菩萨不。答言。唯然已见。善男子。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼观世音足。绕无数匝观察无厌。正念圣教深入智海。辞诣正趣。头面礼足右绕毕。恭敬合掌于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道

善男子。我已成就菩萨普门速行法门。白言大圣。于何佛所得此法门。所从来刹去此几何。发来久如。答言。善男子。此处难知。一切诸天人非人等所不能了。唯精进不退。近善知识。佛所护念。具足善根。净正直心。得菩萨根。开智慧眼。多闻多知。菩萨境界。唯愿大圣。为我解说。我当承佛神力善知识力而得信解。答言。善男子。我所从来刹。名曰妙藏。佛号妙德。于彼佛所得此法门。从彼发来。已经不可说佛刹微尘等劫。于一念中。行不可说佛刹微尘等步。一步过不可说佛刹微尘等世界。所经诸国佛皆现在。以一切菩萨诸供养具而供养之。悉能了知彼世界中诸群生海。分别诸根。随其所应而为说法。放大光网普照十方。出妙音声演说正法。饶益度脱彼诸众生。乃至十方亦复如是。善男子。我唯知此菩萨普门速行法门。诸大菩萨。普于十方无所不至。境界无量无能坏者。清净法身充满法界。分别了知诸众生道。满一切刹顺一切法。等观三世说平等法。随顺世间不着佛道。普至诸道无著无碍。我当云何能知能说彼功德行。善男子。于此南方有城。名婆罗波提。彼有一天。名曰大天。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼正趣菩萨。绕无数匝。眷仰观察。辞退南行

尔时善财童子。正念思惟菩萨无障碍行。一向专求正趣菩萨智慧境界。出生通明境界一切功德。精进坚固。欢喜无量。得不思议游戏神通。决定了知诸功德地。诸三昧地陀罗尼地。诸大愿地。诸辩才地。具诸力地。渐渐游行至于彼城。推问大天今在何所。时有人言。善男子。在此城内大法堂上。化现其身。大众围绕而为说法。尔时善财往诣其所。头面敬礼彼大天足。绕无数匝。恭敬合掌。于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。尔时大天出四长臂。取四海水。澡洗其面。洗已。取诸金华以散善财。作如是言。善男子。菩萨难闻难见。乃是世间奇特之法。诸男子中分陀利华。为众生归依。摄取饶益载育众生。普照一切。显现正道。远离愚痴。为众生师。救护正法。为众生将救护安隐。悉令得至一切智城。具足成就净身口业。永离众恶。于众生类。常以爱语。随其所应悉现其前。未曾失时。善男子。我已成就菩萨云网法门。白言大圣。此法门者境界云何。尔时大天。于善财前。积天金聚犹如山王。白银琉璃玻璃砗磲码瑙夜光离垢藏宝。明净宝。诸方便门摩尼宝。周罗宝。璎珞宝。吉由罗宝。庄严发宝。庄严童子宝。弥阿罗庄严宝。弥拘罗宝。赤真珠宝。庄严一切诸肢节宝。如意珠宝。皆悉积聚犹若山王。一切华。一切香。一切涂香。一切末香。一切鬘。一切衣。一切盖。一切幢。一切幡。一切娱乐具五欲境界。如是等积悉如山王。又复显现阿僧祇诸童女众。语善财言。善男子。汝取此诸物供养如来。惠施一切摄取众生。悉令众生。修檀波罗蜜。学檀波罗蜜。舍离一切。善男子。我以此物教汝惠施。教一切众生亦复如是。悉令众生以无贪善根普熏身心。近善知识。恭敬供养诸佛菩萨。出生长养一切善根。发阿耨多罗三藐三菩提心。复次善男子。若有众生贪五欲者。为彼显现不净境界。若嗔恚放逸憍慢诤讼。如罗刹鬼饮血食肉。悉教彼等修大慈悲。皆令永离嗔恚放逸。若懈怠者。为现水火盗贼恶王怨敌等难。善男子。如是等类诸恶众生种种方便灭不善根长养善根。除灭一切波罗蜜障碍怨敌。具足成满诸波罗蜜。超出障碍得无碍法。善男子。我唯知此菩萨云网法门。诸大菩萨帝释天王。灭一切烦恼阿修罗难。诸菩萨水。灭烦恼火。诸菩萨火。能烧一切众生贪爱。诸菩萨风。能散一切诸染着心。菩萨金刚。摧灭一切吾我之想。我当云何能知能说彼功德行。善男子。此阎浮提内。有一国土。名摩竭提。有道场地神。名曰安住。汝诣彼问。云何菩萨学菩萨行修菩萨道

时善财童子。头面敬礼彼大天足。乃至辞退。趣摩竭国。诣彼道场安住地神。尔时一万地天各作是言。此来童子能摄众生即是佛藏。能破一切众生无明[穀-禾+卵]膜。生法王家。离垢无碍宝缯以冠其顶。智慧宝藏摧外道轮。时安住地天等一万地天。雨众香水以洒其地。扫以香风而以庄严。放大光明。普照三千大千世界。众宝庄严。一切华树开敷鲜茂。一切果树悉成果实。一切泉源河池流相灌注。演出种种娱乐音声。诸天众宝庄严楼阁。异类众鸟皆悉欢喜出哀和音。无量宝藏自然涌出。尔时安住地神。告善财言。善来童子。汝欲自见曾于此处所种善根果报不乎。尔时善财。头面敬礼彼地神足。恭敬合掌于一面住。白言大圣。唯然欲见。时彼地神。即以足指按地。无量阿僧祇那由他宝藏开发显现。善男子。汝昔所种善根果报致此宝藏。自在随汝。善男子。我已成就菩萨不可坏藏法门。我于然灯佛来。常护菩萨。修习菩萨行。深入智慧境界。尽其源底。大愿成满。净菩萨行。出生菩萨一切通明。具足菩萨诸力功德。成就菩萨不可坏法。游诸佛刹。闻一切佛所授记法。转一切法轮。一切修多罗法云。以大法光明教化众生。受持诸佛自在神力。善男子。乃往古世。过须弥山微尘等劫。有劫名庄严。世界名月幢。佛号善眼。于彼佛所得此法门。修习长养净此法门。于其中间。常遇不可说不可说佛刹微尘等佛。彼诸如来。往诣道场自在神力皆悉奉觐。于此佛所修集善根。善男子。我唯知此法门。诸大菩萨。常能随侍一切诸佛。悉闻受持彼诸佛法。深入诸佛秘密教法。于念念中。出净法身等一切佛。一切佛影藏出一切佛法。所行无坏。我当云何能知能说彼功德行。善男子。此阎浮提有城。名曰迦毗罗婆。彼有夜天。名婆娑婆陀。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼安住地神。绕无数匝。辞诣彼城

尔时善财童子。正念思惟安住天教菩萨不可坏藏法门。修诸三昧明诸三昧。观察菩萨诸法律仪。菩萨自在游戏神通。观察菩萨一切净法。深入菩萨甚深智慧。究竟菩萨无坏法门。随顺菩萨无坏法门。深入菩萨诸法门海。渐渐游行至于彼城。从东门入中城而住。尔时善财。日没未久。随顺一切菩萨所教。一心欲见婆娑婆陀夜天。于善知识发如来想。普眼境界显现诸方。智慧悉至一切境界。清净法眼普见一切诸法界海。大智慧眼观察十方。见彼夜天。于彼城上虚空中住。处宝楼阁香莲华座。身如真金目发绀色。端严殊妙见者无厌。身服朱衣众宝庄严。顶上结发犹如梵王。于其身上。现一切星宿及其光明。化度无量世界众生。远离恶道。于一毛孔。皆悉睹见所化众生。或有生天。或得声闻缘觉。修菩萨行。种种方便。形色音声。诸语言法。所说正教。化度众生。随所经劫。诸菩萨等。教化众生。悉令修习菩萨诸行。勇猛精进修诸三昧诸神力门。菩萨自在神力境界。菩萨所住。菩萨光明。菩萨奋迅。菩萨法门以化众生。于一毛孔皆悉见闻。尔时善财。见闻此已心大欢喜。头面敬礼彼夜天足。绕无数匝恭敬合掌。于一面住。白言天神。我已先发阿耨多罗三藐三菩提心。信解因善知识得诸佛法。唯愿天神。开示显现一切智道。若有菩萨向此道者得十力地。尔时夜天。告善财言。善哉善哉。善男子。敬善知识随顺其教。若有菩萨随其教者。疾得阿耨多罗三藐三菩提。善男子。我已成就菩萨光明普照诸法。坏散众生愚痴法门。善男子。我于恶众生发大慈心。于不善业众生发大悲心。于修善众生发欢喜心。于善恶众生发无二心。于染污众生发清净心。于邪道众生发正道心。于乐不净众生发乐净心。于乐生死众生发随顺法轮心。于乐声闻缘觉众生发安立一切智道心。善男子。我常如是思惟教化众生。于夜闇人静鬼神盗贼所游行时。比丘离威仪时。重云烟尘昏蔽日月不见色时。若有众生。在城邑聚落山岩旷野。八方大海。乃至一切水陆众生。于此众生。以种种方便灭其恐怖。若有众生。遭于海难云难山难。大风洄澓及以波浪。迷惑失道不见边岸。遭如是等种种海难。我于尔时。或作船形。或作马王象王狗王阿修罗王海神王形。作如是等形。方便度脱众生海难。为陆地众生。或作净月及诸星宿。炬火电光诸宝光明。天身光明菩萨光明。以如是等无量方便救护众生。发如是心。我为一切众生常作归依。除灭烦恼。令畏死者得无畏法。令贫穷者皆得富乐。为在山众生。或作果树或作流泉。迦陵频伽鸟等出妙音声。或作山神或作平地。以如是等无量方便度脱众生。发如是心。令诸众生免此山难。又令一切越生死山。为旷野众生。种种方便令其悦乐。入正见道。除灭饥渴。于如是等无量难中。救众生已。复作是念愿令众生速灭众苦。究竟一切安隐智道。见乐着国土众生受诸苦恼。种种方便灭其乐着。作如是念愿。令众生除五阴着。住一切佛萨婆若境。见着聚落众生受诸苦恼。种种方便而为说法。令其厌离以法摄之。复作是念。令一切众生。离六入空聚超出生死。究竟得入一切智城。复次善男子。若有众生。迷于十方。以东为西。以西为东。乃至以上为下。以下为上。为此众生。无量方便断其迷惑。若欲出者开示门户。若失道者示导正路。若欲度者示以津济。无舟楫者而资给之。不知方域示其乐土。以如是等无量方便。显现开道而度脱之。发如是心。我已照除长夜昏冥。世间众事无不宣叙。又令众生永灭痴闇得清净眼。离众生相及诸邪见。常乐我净。计着众生及福伽罗。阴界诸入。不了因果。行不善道。杀害众生。乃至邪见不孝父母。不供养沙门婆罗门。远离正道行不善业。诽谤正道欲坏法轮。毁菩萨众憎恶大乘。不赞菩提毁呰贤圣。行恶人法造五逆业。如是等类诸恶众生。我以明净慧光除其愚闇。令发阿耨多罗三藐三菩提心。究竟普贤菩萨所行。开十力道远离生死。现一切智城。诸佛境界诸佛神通。具足诸力现法持力。安住诸佛平等正法。现一切佛悉同一身。复次善男子。我见贫苦老病众生。种种方便而救济之。复作是念。以无上法摄彼众生。灭诸烦恼令得解脱。离生老病死忧悲苦恼恶道诸难。近善知识深入法界。离诸恶业净佛法身。置无老病死常住法界。复次善男子。我见诸恶众生。远离正道趣于邪径。着诸倒见虚妄迷惑。具行不善身口意业。种种放逸依止恶法。于非正觉为正觉想。于正觉所非正觉想。近恶知识受诸苦恼。我见此已。无量方便除其邪惑安立正见。令于天人最为殊胜。复作是念。令诸众生。得出世间无上正道。不复退转。于一切智。满足普贤菩萨大愿。得一切智。而亦不离菩萨诸地。不坏众生性。尔时夜天。欲重宣明此法门义。承佛神力观察十方。即为善财以偈颂曰

  我所成妙法　　知时诸门地
  照除愚痴闇　　普观一切法
  无量无数劫　　我常修大慈
  普覆诸群生　　善财应速具
  成就大悲海　　出生三世佛
  除灭一切苦　　善财速究竟
  佛子心欢喜　　远离世间恶
  超出三界苦　　受诸贤圣乐
  远离有为恶　　声闻智解脱
  满足如来力　　佛子应究竟
  我以净天眼　　普观十方刹
  于彼世界中　　见佛处道场
  相好庄严身　　无量众围绕
  放大光明海　　普照化众生
  睹诸群生类　　死此而生彼
  回流五趣中　　常受无量苦
  以净天耳海　　普闻十方音
  一切语言海　　皆悉能受持
  一切诸如来　　无量微妙声
  所转净法轮　　悉闻能受持
  我以净鼻根　　法海中无碍
  能入诸法门　　善财应究竟
  我成大人相　　清净广长舌
  随应演妙法　　佛子应究竟
  清净妙法身　　三世如如等
  随其所应化　　一切无不现
  我心无所染　　清净如虚空
  普摄一切佛　　而亦无所著
  了知无量刹　　群生诸心海
  分别一切根　　远离众虚妄
  我以神通力　　遍游无量刹
  普覆一切众　　调伏诸众生
  智慧如虚空　　无比无尽藏
  供养诸如来　　饶益一切众
  清净广智慧　　分别诸法海
  除灭众生惑　　佛子应究竟
  通达三世法　　深入诸佛海
  明了一切法　　无能测量者
  一一微尘中　　悉见佛刹海
  又睹诸如来　　此是普力地
  见卢舍那佛　　道场成正觉
  十方刹微尘　　悉转正法轮

尔时善财童子。白言天神。发阿耨多罗三藐三菩提心。为几时耶。得此法门其已久如乃能如是饶益众生。答言。佛子。乃往古世。过如须弥山微尘等劫。有世界名宝德。劫名寂静。有五百亿佛出兴于世。时有大城。名莲华光。有转轮圣王。名善法度。如圣王法成就七宝。城东有林名曰妙德。于此林中有菩提树。名一切佛自在光明。尔时一切法雷王佛。坐此树下成等正觉。放大光明普照世界。王玉女宝。名法慧月莲华光。于彼城内有一夜天。名曰净月。于中夜时。出微妙音告此玉女。汝应当知。一切法雷王佛。出兴于世。称扬赞叹彼佛功德。显现如来自在神力。发阿耨多罗三藐三菩提心。赞叹普贤菩萨一切愿行。时王玉女。供养彼佛及诸菩萨诸声闻众。善男子。尔时玉女法慧月莲华光者。岂异人乎。我身是也。善男子。我于彼佛种善根力。于须弥山微尘等劫。不堕地狱饿鬼畜生阎罗王处。不生下贱之家。具足诸根除灭众苦。常于天人中胜。不离善知识诸佛菩萨。不生五浊劫中。于彼诸佛菩萨所增长善根。于八十须弥山微尘等劫。安隐快乐。而未满足菩萨善根。复次善男子。过此须弥山微尘等劫已。复过一万劫。有劫名离忧。世界名离垢胜。有须弥寂静眼如来应供等正觉等五百如来。出兴于世。其佛国土或净或秽。彼世界中有一四天下。名曰离垢。城名庄严。我于尔时。为明胜长者女。名胜慧光。端正殊妙。彼净月天。以本愿力生此城中。复作夜天。名清净眼。时彼夜天。复于中夜来诣我家。显现妙色赞叹如来。又劝导我诣彼如来。放大光明在前引导。我于尔时与父母俱及其眷属。往诣须弥寂静眼如来所。供养恭敬。听佛说法。得菩萨三昧。名曰见佛教化众生明净慧光普照三世。得此三昧已。忆念过去须弥山微尘等劫所见诸佛。又闻彼佛所说经法。得光明普照诸法坏散众生愚痴法门。放大光明。照十佛刹微尘等世界。见彼刹中一切如来。往诣其所。知彼众生诸语言法心根欲性。为彼众生作善知识。随其所应显现其身。于念念中长养此法门。一身充满世界微尘等世界。乃至充满世界海微尘等世界海。悉见彼世界海微尘等世界海中一切如来。往诣其所。彼佛说法我悉闻持。分别了知彼诸如来本事愿海。彼诸如来严净佛刹。我亦严净。于彼世界中。随其所应示现其身化度众生。念念长养于此法门与法界等。善男子。我唯知此光明普照诸法坏散众生愚痴法门。诸大菩萨。究竟无量无边普贤所行。深入法界海。建智慧幢。得诸三昧。游戏神通。大愿成满。守护受持十方世界一切佛法。于念念中。悉能严净一切佛刹。满功德海。于念念中。教化一切诸群生海。智慧净日普照三世一切世界。教化一切众生。离垢净月。除灭一切众生热恼疑惑痴闇。于一切有海。心无所著。演出清净圆满妙音。充满十方一切法界。于一一微尘中。显现一切自在神力。明净慧光普照三世。我当云何能知能说彼功德行。善男子。此阎浮提摩竭提国有一夜天。名甚深妙德离垢光明。汝诣彼问。云何菩萨学菩萨行修菩萨道。尔时善财。即以偈赞彼夜天曰

  我见清净身　　相好自庄严
  如文殊师利　　亦如宝山王
  具足净法身　　三世悉平等
  普摄诸群生　　其心无所著
  放演净光明　　遍照一切趣
  于一毛孔中　　悉见诸星宿
  离垢清净心　　如空满十方
  摄取诸法王　　明净深智慧
  一一毛孔中　　悉放无量光
  十方诸佛所　　普雨功德云
  一一毛孔中　　出诸变化身
  充满十方界　　方便度众生
  本为菩萨时　　净不思议刹
  一一毛孔中　　皆悉得显现
  若有见闻者　　悉获功德利
  专求菩萨道　　成就佛菩提
  若有见闻者　　发大欢喜心
  远离恶道难　　除灭诸烦恼
  千刹微尘劫　　赞叹其功德
  诸劫犹可尽　　功德无穷已

时善财童子。头面敬礼彼夜天足。绕无数匝眷仰观察心无厌足。辞退游行向摩竭国

尔时善财童子。一心思惟彼夜天神初发道心圆满清净。思惟是已。即得深入诸菩萨藏。出生菩萨诸大愿海。净诸菩萨波罗蜜道。逮得菩萨圆满诸地。住诸菩萨圆满行业。穷尽菩萨发趣道海。善能深入一切智海。皆悉救护一切众生。长养增广大慈悲云。于一切刹。出生普贤诸大愿行。渐渐游行。至甚深妙德离垢光明夜天所。头面礼足绕无数匝。恭敬合掌于一面住。白言天神。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何修菩萨行具足诸地。答言。善哉善哉。童子。乃能发阿耨多罗三藐三菩提心。问菩萨行具足诸地。善男子。菩萨成就十法。则能具足菩萨所行。何等为十。一者得现前三昧见一切佛。二者得清净眼见一切佛相好严身。三者分别了知一切诸佛无量无边功德大海。四者无量无边佛光明海。悉能普照一切法界。五者于一毛孔。放一切众生数等大光明海。随其所应度脱众生。六者于一一毛孔。悉见一切宝光焰海。七者于念念中。出一切佛变化大海。充满法界。究竟一切诸佛境界。教化众生而无障碍。八者出一切佛妙音声海。转三世佛清净法轮。九者演说一切修多罗云。究竟佛音。深入一切诸如来海。十者现不思议佛自在神力化度众生。善男子。若有菩萨。具此十法。则满足菩萨一切诸行。善男子。我已成就菩萨寂灭定乐精进法门。悉见三世严净佛刹。一切诸佛及眷属海。无量无边佛神力海。分别了知佛名号海。转法轮海。知彼诸佛寿命无量音声微妙。法身清净充满法界。亦不着如来一切诸相。何以故。如来非过去。除灭世间一切取故。如来非未来。无所起故。如来非现在。无生身故。如来非灭。离语言道故。如来非实。现幻法故。如来非虚妄。饶益一切众生出兴世故。如来去无所至。灭死此生彼故。如来不可坏。法性无坏故。如来一性。离语言道故。如来无性。究竟法性故。善男子。我如是了知一切如来。开发增广菩萨寂灭定乐精进法门。照明庄严。深入随顺平等坚固境界。分别了知远离虚妄。发起大悲摄取众生。未曾舍离一心寂定。正受初禅。除灭意业。得寂智力。摄取众生。欢喜悦乐。入第二禅。舍离生死。寂灭涅槃。观众生性。修第三禅。灭一切众生诸烦恼苦。修第四禅。增长一切智菩提心愿。出生菩萨一切三昧海。巧妙方便。究竟菩萨一切法门海。成就菩萨游戏神通。出生菩萨自在所行。明净智慧深入普门法界。善男子。我如是修习菩萨寂灭定乐精进法门。种种方便度脱众生。在家放逸贪欲众生。令修不净想。不乐想。忧恼想。逼迫想。系缚想。罗刹想。无常想。苦想。无我想。空想。不自在想。老死想。令彼众生远离五欲。常乐正法信家非家。出家学道思惟坐禅。为障乱声除鬼神怖。若于中夜欲出行时为开门户。光明照路除灭闇冥。赞佛法僧及善知识。又复赞叹近善知识。令诸众生。未生恶法方便不生。已生恶法方便令灭。未生善法方便令生。已生善法方便增广。行菩萨行修波罗蜜满足大愿。出生一切智习大慈悲。欲令众生得人天乐除灭妄想。增长善法顺萨婆若。善男子。我唯知此菩萨寂灭定乐精进法门。诸大菩萨。满普贤愿。具足普贤菩萨所行。究竟得离痴闇法界。具诸善根。成就如来智力光明。于佛境界无所障碍。住生死中心无所染。萨婆若愿具足成满。深入一切诸佛刹海。摄取一切诸佛大海。受一切佛妙法云海。灭一切众生生死闇海。萨婆若光照生死夜。我当云何能知能说彼功德行。善男子。去此不远。如来右面有一夜天。名曰喜目观察众生。汝诣彼问。云何菩萨学菩萨行修菩萨道。尔时甚深妙德离垢光明夜天。欲重宣明此法门义。以偈颂曰

  入于现前定　　普见三世佛
  离垢清净眼　　分别诸佛海
  观察诸佛身　　相好自庄严
  一念无量力　　自在满法界
  卢舍那如来　　道场成正觉
  一切法界中　　转于净法轮
  最胜知法相　　寂灭无有二
  妙色相庄严　　显现一切众
  佛身难思议　　悉满诸法界
  普于十方刹　　随应悉现前
  一念放光明　　一切刹尘等
  无量微妙色　　普照诸法界
  如来一毛孔　　放不思议光
  普照诸群生　　除灭众烦恼
  如来一毛孔　　出无尽化海
  充满诸法界　　显现众生类
  如来一妙音　　充满诸法界
  普雨甘露法　　令发菩提心
  无量劫修行　　摄取诸群生
  普见诸佛刹　　皆悉如电光
  如来出世间　　普见群萌类
  众生性境界　　悉能分别知
  一切诸菩萨　　所住诸法门
  于佛一毛孔　　悉能分别知
  不远有夜天　　名喜目观察
  汝往诣彼问　　云何菩萨行

时善财童子。头面敬礼彼夜天足。绕无数匝眷仰辞退。向喜目观察众生夜天

大方广佛华严经卷五十一大方广佛华严经卷第五十二

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之九

尔时善财童子。专求善知识。念因善知识生诸善法。善知识者。难见难遇。见善知识。灭诸乱想。见善知识。除灭一切诸缠障碍。见善知识。得萨婆若智慧光明。见善知识。深入佛海。见善知识。得正念法云陀罗尼。受持一切佛净法轮云。见善知识。具大悲海救护众生。见善知识。智慧明净。悉能普照诸法界海。时喜目观察众生夜天。以威神力加善财童子。赞善知识诣善知识恭敬供养。善知识者则是菩提。善知识者则是精进。善知识者难见难遇。善知识者是不可坏力。因善知识遍游十方断生死流。悉能成辨一切大事。庄严正道。得普门法门一切无碍。见善知识。不离本处。遍至十方一切佛所。尔时善财。即时了知见善知识成满无量诸大愿海。得一切智饶益众生。灭除未来无量劫苦。以大庄严而自庄严。一一微尘中。修行一切诸法界法。见十方海。知未来劫诸语言法及菩萨行。究竟一切诸菩萨行。于念念中得一切智。神力自在。诸庄严道。等三世佛。净法界流。不离法界境界。而能往诣充满法界善知识所。尔时善财。往诣喜目观察众生夜天。见彼夜天在如来所。于大众中。处宝莲华师子之座。正受菩萨普光喜幢法门。一切毛孔出众妙云。其有见者欣悦无厌。所谓智慧行云。饶益众生离于诤讼不着诸法。以平等心普摄众生。显三世菩萨修行布施。悉舍内外难舍之物。十方众生皆悉睹见。又于一切毛孔。出众生数等菩萨变化身云。充满法界现众生前。显示正受不动三昧觉悟众生。不乐三界远离世间灭除生死。现天人中种种成败。教诸众生修不净观除净想倒。说有为行无常变易苦恼之法。令诸众生深入佛戒。未曾暂离。受持诸佛清净禁戒。现无疑戒及以香戒。戒香普熏一切众生。又于一切毛孔。出众生数等妙色身云。显示众生截诸肢节。皆悉能忍堪受众苦。一切诃责恶骂皆悉忍受。于彼众生不生恚心。恭敬赞叹不生爱心。于一切众生不起我慢。显现诸法自性之忍。显现无尽菩提心智。除灭一切众生烦恼。修习忍法行菩萨行。显现清净金刚之身。显现如来清净无上色身。随其所应教化众生。又于一切毛孔。出诸趣种种色身云。勇猛精进。现一切智勇猛精进。现菩提境界而不退转。勇猛精进降伏诸魔。勇猛精进。于生死海。悉能救度一切众生。勇猛精进。除灭一切恶道诸难。勇猛精进。坏无智山。勇猛精进。恭敬供养一切如来。心无疲倦。勇猛精进。受持守护诸佛法轮。勇猛精进。坏散一切诸障碍山。勇猛精进。严净一切诸如来刹。得诸如来清净精进。教化度脱一切众生。又于一切毛孔。出种种色身云。以诸方便。除灭众生愁忧苦恼。悉令欢喜。厌恶五欲。赞叹惭愧。调伏诸根。修行无上清净梵行。身口意善。显现世间一切所欲。皆不可乐。建立众生。令乐正法。出生正受九次第定。除灭众生一切烦恼。显现菩萨诸三昧海。通明自在神力境界。令诸众生皆悉欢喜身心柔软。灭烦恼热得清凉乐长养正法。又于一切毛孔。出诸趣种种身云。诣一切刹诸佛师长善知识所。恭敬供养心无疲倦。受持一切诸佛法轮。究竟一切佛海。显现一切法海。显现一切诸法实相。显现一切诸三昧门。清净智慧。分别一切众生心海。金刚智慧。坏散一切众生诸邪见山。出生圆满明净慧日。于一念中。悉能除灭一切众生愚痴闇冥。令诸众生皆悉欢喜得萨婆若。又于一切毛孔。出一切众生数等身云。现种种色身。不思议身。随其所应悉现其前。以无量音。为诸众生。演说世间功德之藏。世间行业。一切三界皆不可乐。叹离三界诸恶邪见。远离邪道向一切智。超出声闻缘觉之地。于有为无为心无所著。背舍生死正向涅槃。而亦不舍诸趣往来。不舍发菩提心。成等正觉教化众生得一切智。又于一一毛孔。出一切佛刹微尘等变化身云。普现一切诸众生前。修普贤行满普贤愿。赞叹究竟一切大愿。于念念中。严净一切诸世界海。于念念中。恭敬供养一切诸佛。于念念中。悉能受持一切法海。于念念中。一一微尘中。出生一切世界海微尘等法界方便海。住持一切刹一切劫。净一切智道未曾休息。于念念中。悉入一切诸如来力。究竟三世方便海。于一切刹现自在力。令一切众生修菩萨行成满大愿得一切智。又于一一毛孔。出一切众生心等身云。悉现一切诸众生前。显现无量一切智力。不可穷尽。无能坏者。修不退转菩萨诸行。于生死法心无所染。降伏众魔灭烦恼力。坏散一切障碍山力。具大悲力。于一切劫修菩萨行心无疲倦。震动一切诸佛世界。令众生喜转净法轮。建立法幢制诸外道。修菩萨行力波罗蜜得一切智。又于一一毛孔。出一切众生心等种种色身云。充满无量诸众生界。随其所应现菩萨行。智力精进度众生海。分别了知一切众生心心所行海。一切众生诸根海。一切众生行海。教化众生未曾失时。明净智慧究竟法性。于念念中。明净智慧充满法界。了知一切世界成败及其庄严。自在神力诣诸佛所。恭敬供养。守护受持正法轮云。如是显现智波罗蜜。悉令众生皆大欢喜熙怡悦乐。身心柔软除灭热恼。远离忧戚弃舍众恶。调伏诸根心得解脱。于一切智得不退转。如显现诸波罗蜜化度众生。显现菩萨一切功德化度众生。亦复如是。又于一切毛孔。显现喜目观察众生夜天。从初发心所为功德。求善知识往诣诸佛。恭敬供养修习善根。行檀波罗蜜。难舍能施。行尸波罗蜜。弃捐天下宫殿眷属。出家学道净修禁戒。行羼提波罗蜜。一切众生悉加恶言。无量逼切皆悉能忍。行毗梨耶波罗蜜。修诸苦行专求菩提。其心坚固而不退转。行禅波罗蜜。诸方便道满足。清净禅波罗蜜。于诸三昧而得自在。究竟一切诸三昧海。相续次第未曾断绝。行般若波罗蜜。清净菩萨圆满智慧。出明净慧日无尽慧藏。究竟智海。行方便波罗蜜。出生一切诸方便身。方便功德。方便清净。方便本事。行愿波罗蜜。出生一切诸愿净身。成满诸愿。随应行愿。及愿波罗蜜本事。行力波罗蜜。力波罗蜜因缘功德。力波罗蜜方便海。分别演说力波罗蜜本事。行智波罗蜜。智波罗蜜出生。智波罗蜜净身。智波罗蜜说。智波罗蜜境界。智波罗蜜所摄。智波罗蜜光明。智波罗蜜本事。智波罗蜜分别行。智波罗蜜深入。智波罗蜜摄取诸法。随顺知法。知业。知刹。知劫。知三世。知佛出世。知佛智。知菩萨。知菩萨智。知菩萨住。知菩萨功德。知菩萨回向。知诸大愿。知转法轮。知分别法。知入法海。知方便海。知法旋流。知诸法趣。如是等一切智波罗蜜。于一切毛孔皆悉显现化度众生。又于一切毛孔。出无量身云。所谓阿迦尼吒天身云。净居天身云。善现天身云。不热天身云。果实天身云。遍净天身云。无量净天身云。少净天身云。净果天身云。无量净果天身云。少净果天身云。光音天身云。无量光音天身云。少光音天身云。大梵天身云。梵辅天身云。梵身天身云。他化自在天王及他化自在天子天女身云。化自在天王及化自在天子天女身云。兜率天王及兜率天子天女身云。夜摩天王及夜摩天子天女身云。三十三天王及三十三天天子天女身云。提头赖吒天王及一切乾闼婆男女身云。毗楼勒叉天王及一切鸠槃荼男女身云。毗楼博叉天王及一切龙男女身云。毗沙门天王及一切夜叉男女身云。紧那罗王及一切紧那罗男女身云。摩睺罗伽王及一切摩睺罗伽男女身云。迦楼罗王及一切迦楼罗男女身云。阿修罗王及一切阿修罗男女身云。阎罗王及一切阎罗王男女身云。人王身云。男子女人童男童女身云。出如是等一切诸趣身云。声闻缘觉仙人身云。地水火风神。海神河神。山神林神。树神谷神味神药草神。园观神城郭神道场神。夜神昼神。虚空神方神道路神。身形神金刚力士神。出如是等一切身云。充满十方一切世界法界。为一切众生。现喜目观察众生夜天。从初发心所行功德。积集无量诸波罗蜜。次第受生死此生彼及其名号。近善知识值遇诸佛闻持正法。行菩萨行得诸三昧。次第睹见一切佛刹。及诸如来次第诸劫。得净智慧深入法界观察众生。知众生海死此生彼。得净天耳。次第悉闻一切音声。知他心智。次第了知众生心念。无依神足。次第自在充满十方。得诸菩萨次第法门。究竟菩萨诸法门海。菩萨自在。菩萨精进。菩萨得证正趣离生众生想。菩萨想菩萨胜妙清净功德。如是等类一切功德。彼化身云。悉为众生。以诸音声。分别解说开示显现。所谓风轮音声。水轮音声。火焰音声。大海音声。大地震动音声。山王相击音声。天城震动音声。天宝音声。诸天音声。龙王音声。夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王等音声。人王音声。梵王音声。天女歌颂音声。天乐音声。摩尼宝王音声。如来音声。菩萨音声。如来化身音声。以如是等种种音声。为诸众生。分别演说。喜目观察众生夜天从初发心一切功德。彼一一身云说此法时。念念中于一一方。严净不可说不可说诸佛世界。无量无边众生灭恶道苦。无量无边众生成就天乐。无量无边众生度生死海。无量无边众生安立声闻辟支佛地。无量无边众生得菩萨不可思议喜幢自在法门。于念念中。无量无边众生住如来地

尔时善财童子。皆得见闻如上一切诸奇特事。正念思惟观察分别。深入定智安住平等。何以故。与彼夜天先同行故。佛护念故。成就不可思议诸善根故。具足菩萨根故。生佛家故。得善知识力故。一切诸佛神力持故。卢舍那佛本愿力故。善根熟故。堪受普贤菩萨行故。尔时善财。得菩萨欢喜净光明海。得十方一切诸如来力。得彼夜天离垢喜幢法门。即恭敬合掌。以偈赞叹彼夜天曰

  无量无数劫　　深学最胜法
  随应所受化　　显现妙色身
  了知诸群生　　愚痴颠倒惑
  种种身方便　　度脱众生类
  清净妙法身　　除灭烦恼热
  非二现有二　　为化众生故
  阴入及诸界　　皆悉无所著
  具行及色身　　度脱一切众
  不着内外法　　越度生死海
  明净智慧光　　普照于一切
  喜目天无著　　除灭众虚妄
  众生乐着世　　为现佛法力
  无碍三昧力　　一一毛孔中
  出诸化身云　　供养十方佛
  念念中出生　　诸佛方便力
  摄取诸众生　　究竟一切法
  观察诸有海　　业行庄严身
  演说无碍法　　令众清净故
  相好自庄严　　犹若普贤身
  随应受化者　　显现无量身

尔时善财童子。偈赞叹已。白言天神。发阿耨多罗三藐三菩提心。为几时耶。得此法门其已久如。尔时夜天。以偈答言

  忆念过去世　　无量刹尘劫
  尔时有一劫　　名曰寂静音
  有都名香水　　其王名智慧
  十二亿百千　　那由四天下
  彼圣转轮王　　清净妙色身
  三十二相具　　八十好庄严
  妙身清净藏　　阎浮檀金色
  光明照一切　　详步游虚空
  彼王有千子　　勇猛身端正
  大臣有一亿　　智慧悉贤明
  采女有十亿　　端严如天后
  大慈心柔软　　瞻奉给侍王
  彼圣转轮王　　常以正法治
  统领诸山地　　一切四天下
  我时为宝女　　具足净梵音
  身出金色光　　周照四万里
  日光既已没　　中夜闲寂然
  我当于尔时　　神瑞降善梦
  见佛出世间　　号曰功德海
  显现自在力　　充满十方界
  放大光明海　　一切刹尘等
  无量自在身　　充满于十方
  大地六种动　　自然出妙音
  如来兴出世　　天人悉欢喜
  一切毛孔中　　出佛化身海
  充满十方界　　随应而说法
  我梦见如是　　如来自在力
  闻说深妙法　　其心大欢喜
  一万夜天神　　充满虚空中
  赞叹彼如来　　闻已即觉悟
  彼天告我言　　贤慧女速起
  佛已兴汝国　　劫海难值遇
  闻此音欢喜　　即见明净光
  观察从何来　　道场树王所
  时见如来身　　犹若宝山王
  一切毛孔中　　放大光明海
  见佛自在力　　其心大欢喜
  即发弘誓愿　　令我获此德
  我时觉大王　　普及诸眷属
  见彼佛光明　　欢喜心无量
  我时与彼王　　无量那由他
  眷属四种兵　　往诣如来所
  我于二万岁　　供养彼如来
  七宝四天下　　一切悉奉施
  时彼如来说　　功德普云经
  大愿海庄严　　随应度众生
  我发如是愿　　来世作夜天
  诸有放逸者　　悉令远离之
  尔时我初发　　无上菩提心
  生死有为中　　未曾有忘失
  从是后供养　　十亿那由佛
  生死海受乐　　饶益诸群生
  初佛功德海　　第二功德灯
  第三宝幢佛　　第四虚空智
  第五莲华藏　　六无碍音月
  第七法月王　　八圆满智灯
  第九宝焰佛　　无上天人尊
  第十化音声　　我已悉供养
  如是等诸佛　　十亿那由他
  犹未得慧眼　　究竟生死海
  次第复有劫　　名曰天妙胜
  世界名宝光　　五百佛兴世
  初佛圆满月　　第二明净日
  第三光明佛　　四须弥山王
  第五华焰海　　第六智慧海
  第七然灯佛　　第八天德藏
  九光明王幢　　第十普智王
  如是等诸佛　　我已悉供养
  未离乐五阴　　非乐生乐想
  次第复有劫　　名庄严梵音
  尔时有世界　　名莲华灯云
  彼有无量佛　　及其大眷属
  我已悉供养　　闻受持正法
  初佛宝须弥　　第二功德海
  法界须弥幢　　第四法须弥
  第五法幢佛　　第六法地佛
  第七法力佛　　第八虚空慧
  第九光焰山　　第十照明山
  如是等诸佛　　我已悉供养
  犹未了真实　　究竟诸法海
  次第复有劫　　名曰欢喜德
  尔时有世界　　名曰功德幢
  彼劫有八十　　那由他诸佛
  无量供养具　　奉彼诸最胜
  初乾闼婆王　　二寿命树王
  三功德须弥　　第四宝眼佛
  第五卢舍那　　六光明庄严
  第七法胜佛　　第八明净德
  第九世间主　　十一切法王
  如是等诸佛　　我已悉供养
  犹未得妙智　　深入法界海
  次第复有劫　　名曰寂静慧
  尔时有世界　　名普光明云
  有千佛兴世　　无量德庄严
  除灭烦恼垢　　一切众清净
  初佛号无诤　　第二无碍力
  三法界光明　　四一切灯王
  五婆楼那天　　第六众生归
  七忍圆满灯　　八法具足灯
  九光明严海　　第十光明王
  如是等诸佛　　我已悉供养
  犹未解真法　　游行一切刹
  次第复有劫　　名曰香灯云
  尔时有世界　　名曰清净起
  一亿佛兴世　　严净一切劫
  彼佛所说法　　我悉闻受持
  初佛无量称　　第二法海佛
  第三勇猛王　　四功德法王
  第五胜法云　　第六天冠佛
  第七智焰佛　　第八虚空音
  第九等胜起　　第十妙德光
  供彼诸佛已　　成就八正道
  次第复有劫　　名明净坚固
  尔时有世界　　名曰宝幢王
  五百佛兴世　　彼诸如来等
  我已悉供养　　求无碍法门
  初佛圆满德　　第二寂静音
  第三功德海　　第四日王佛
  第五功德王　　第六须弥相
  第七法王佛　　第八功德王
  第九须弥山　　第十光明王
  如是等诸佛　　我已悉供养
  我皆悉严净　　一切最胜道
  犹未得具足　　究竟深法忍
  次第复有劫　　名曰为胜主
  尔时有世界　　名寂静音声
  八十那由他　　诸佛兴出世
  我已悉供养　　于彼修正道
  初佛号华聚　　第二海藏佛
  第三功德起　　第四天周罗
  第五摩尼藏　　第六金山佛
  第七宝聚佛　　第八寂静幢
  第九法幢佛　　第十智王佛
  如是等诸佛　　我已悉供养
  次第复有劫　　名曰千功德
  尔时有世界　　名善化幢灯
  六亿那由他　　诸佛兴出世
  我已悉供养　　彼一切如来
  初佛寂静幢　　第二智慧幢
  第三百灯佛　　四功德云王
  寂静光明王　　第六明净日
  第七法灯佛　　第八光焰佛
  九天功德藏　　第十智慧灯
  如是等诸佛　　我已悉供养
  未得无生忍　　究竟诸法海
  次第复有劫　　名无著庄严
  尔时有世界　　名无量胜光
  时有三十六　　那由他佛出
  如是等诸佛　　我已悉供养
  初功德须弥　　第二虚空心
  第三庄严智　　第四庄严藏
  五法音声海　　六持法音声
  第七化音声　　第八功德海
  九功德海灯　　第十功德幢
  彼诸如来等　　我皆悉值遇
  功德幢如来　　出兴于世时
  我为功德天　　供养彼最胜
  时佛为我说　　庄严大愿海
  陀罗尼念力　　皆悉能受持
  我得明净眼　　三昧陀罗尼
  于一一念中　　悉见最胜海
  出生大悲藏　　深入方便云
  心净如虚空　　悉得诸佛力
  观察诸众生　　常乐我净倒
  愚痴闇所覆　　烦恼起虚妄
  邪见贪欲等　　无量诸恶业
  一切诸趣中　　具受不善报
  一切诸趣中　　种种业受身
  生老病死患　　无量苦逼迫
  我发无上心　　安乐彼众生
  令至诸佛所　　成满如来力
  满足大愿云　　常见一切佛
  修习于正道　　具足诸功德
  一向广专求　　无量功德云
  法门波罗蜜　　充满诸法界
  佛子我尔时　　即得普贤行
  分别深法界　　摄取一切法
  成满一切地　　三世方便海
  修习无碍行　　一念具佛智

善男子。尔时智慧转轮王者。岂异人乎。文殊师利童子是也。绍继转轮王姓诸如来种。使不断绝。时王贤慧宝女者我身是也。尔时夜天觉悟我者。普贤菩萨所变化也。我于尔时。初发阿耨多罗三藐三菩提心。发道心已。于佛刹微尘等劫。不堕恶道。常生天人。睹见诸佛。乃至功德幢佛所。得此普光喜幢法门。得此法门已。饶益化度无量众生。善男子。我唯知此法门。诸大菩萨于念念中。普诣一切诸如来所。具足成就精进大海。于念念中。满足一切诸大愿海。于念念中。出生一切未来劫菩萨诸行。于一一菩萨行中。出生一切佛刹微尘等身。彼一一身。充满一切诸法界海。于一一法界中。显现一切佛刹。随其所应现菩萨行。于一一佛刹中。究竟一切佛刹微尘等诸佛海。于一一佛所。究竟一切法界等如来自在神力。一一如来所。分别过去诸劫。行菩萨行。一一如来所。守护受持一切法轮。究竟三世如来诸方便海。我当云何能知能说彼功德行。善男子。此佛众中有一夜天。名曰妙德救护众生。汝诣彼问。云何菩萨学菩萨行具菩萨行净菩萨行。时善财童子。头面敬礼喜目观察众生夜天足。辞退而行

尔时善财童子。正念思惟普光喜幢法门。分别深入开发显现。随顺善知识教。一向专求见善知识身心诸根。普游方面求善知识。思念善知识道。勇猛精进乃得值遇。同善知识一切善根。具足成就深妙方便。因善知识出生长养一切善根。发诸大愿。于一切劫。不离善知识。往诣妙德救护众生夜天所。尔时夜天。为善财童子。显现菩萨教化一切世间法门境界。相好严身。眉间白毫相中放大光明。名曰普慧焰灯净幢。无量光明以为眷属。普照一切世界。照已入善财顶充满其身。尔时善财。即得菩萨离垢圆满三昧。得此三昧已。于一切地水火风微尘。众宝微尘。香微尘。金刚微尘。摩尼微尘碎末微尘。一切庄严具微尘。一切境界微尘。如是等一一微尘中。悉见佛刹微尘等世界成败。风轮水轮金刚轮地轮。种种庄严众山围绕。无量大海诸天宫殿。诸杂宝树种种庄严。诸龙宫殿夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等城郭宫殿。地狱饿鬼畜生阎罗王处。悉见五道众生死此生彼。分别了知彼诸世界。或有世界净。或有世界不净。或有世界趣净。或有世界趣不净。或有世界净不净。或有世界不净净。或有世界一向净。或有世界其形平正。或有世界其形如伏。或有世界其形四方。如是等一切世界。一切趣中。见彼夜天。于一切时。普现一切诸众生前。随其所应而度脱之。为地狱众生灭诸楚毒。为诸畜生灭恼害畏。为饿鬼众生除饥渴苦。为诸龙等灭一切畏。为欲界众生除欲界苦。为诸人类除闇冥畏。不活畏。恶名畏。大众畏。恶道畏。死畏。失善根畏。失菩提心畏。近恶知识畏。失善知识畏。声闻缘觉地畏。生死畏。不同意畏。非时受生畏。生恶人家畏。行恶业畏。业障畏。烦恼障畏。报障畏。诸贪着畏。诸系缚畏。灭如是等一切怖畏。又复教化四生众生。所谓卵生胎生。湿生化生。有色无色。有想无想。非有想非无想众生。常现其前而教化之。满大愿力故。菩萨三昧力故。诸通明力故。出生普贤菩萨行力故。出生长养大悲海故。无碍大慈覆一切众生故。安乐一切众生故。摄取一切众生故。深入菩萨自在境界法门故。普现一切诸佛刹中为严净故。在一切法中智慧觉悟故。在一切佛所恭敬供养故。在一切佛法中守护正法故。在一切众生心海中度脱众生故。在一切众生诸根中调伏诸根故。在一切众生欲海中为除障碍得清净故。在一切众生愚痴闇中出生一切智光明故。尔时善财。见彼夜天自在神力不可思议菩萨境界一切世界教化众生成就菩萨一切法门自在神力。欢喜无量。头面礼足恭敬合掌。于一面住一心观察。尔时夜天。即舍相好妙庄严身。现夜天形。而不舍离自在神力。尔时善财。以偈颂曰

  善财合掌住　　谛观无厌足
  见无量神力　　其心大欢喜
  我见尊妙身　　相好自庄严
  清净如虚空　　一切莫能坏
  所放殊胜光　　无量刹尘等
  种种微妙色　　普照于十方
  一一毛孔放　　众生等光明
  一一光明端　　出生宝莲华
  从华出化身　　除灭众生苦
  放诸香光明　　普熏十方界
  雨无量华云　　供养诸最胜
  放无量宝光　　一一如须弥
  普照一切众　　除灭愚痴闇
  口放净光明　　犹如无量日
  普照卢舍那　　无量之境界
  眼放净光明　　犹如无量月
  普照群生类　　除灭愚痴曀
  妙相等众生　　出生化身海
  充满诸法界　　度脱三有海
  清净微妙身　　一切无不见
  远离水火贼　　王等一切难
  喜目观察天　　教我诣尊所
  见尊白毫相　　演出明净光
  普照十方海　　除灭一切闇
  显现自在力　　从我顶上入
  光明入身已　　举体柔软乐
  即得离垢定　　普见十方佛
  悉能分别知　　一切诸微尘
  一一微尘中　　普见十方刹
  或有净世界　　或有不净刹
  不净世界中　　众生受诸苦
  不净世界中　　众生受苦故
  示现三乘像　　而往救度之
  清净佛国土　　无量宝庄严
  诸佛大菩萨　　常乐于中住
  一一微尘中　　普见净刹海
  卢舍那积劫　　令彼土清净
  一切佛刹中　　现坐菩提树
  得成最正觉　　而转净法轮
  我见妙德天　　诣彼严净刹
  一切如来所　　恭敬而供养

尔时善财。偈赞叹已。白言天神。甚奇甚特。此菩萨法门最为甚深。此法门者名为何等。得此法门其已久如。本修何行而致之乎。善男子。此处甚深。一切人天声闻缘觉所不能知。何以故。满普贤菩萨行者境界。大悲菩萨藏境界。救护一切众生菩萨境界。除灭一切恶道诸难菩萨境界。一切佛刹中守护一切佛法令不断绝菩萨境界。一切劫中修菩萨行满大愿海菩萨境界。具足成就明净慧光灭一切众生愚痴闇障普照一切菩萨境界。于一念中明净智慧普照三世诸方便海菩萨境界。善男子。谛听谛听。我当承佛神力为汝解说佛子。乃往古世。过世界微尘等劫。有劫名离垢圆满。世界名明净妙德幢。有须弥山微尘等如来。出现于世。其佛世界七宝合成。众宝庄严。其土圆满。离垢清净。宝网罗覆。金刚围山周匝围绕。有十万亿那由他四域天下。或有天下清净众生亦净。或有天下不净众生不净。或有天下净不净杂众生亦杂。或有天下清净一切众生善根具足无诸疾患。或有天下严净殊胜。但诸菩萨彼世界东际。近金刚山有四天下。名华灯幢。妙宝楼阁台观宫殿。上味饮食自然具足。瞻卜华树普覆一切。种种香树出妙香云。诸宝鬘树普雨鬘云。诸杂华树雨不思议众妙华云。诸末香树雨末香云。诸香王树雨妙香云。摩尼宝树雨种种宝。诸音乐树微风吹动。出和雅音充满虚空。日月明净妙宝光明普照一切。彼四天下有百万亿那由他诸王京都。一一王都有千渠水。微流回映众华普被。自然演出天音乐声。岸植宝树行列庄严。众宝为地。一一水间。有十亿千城。彼一一城。有十亿百千那由他聚落围绕。彼一一城。及一一聚落。各有无量亿那由他妙宝楼阁。而庄严之。彼阎浮提有一王都。名宝华灯。安隐丰乐人民炽盛。此诸众生。具足修行十善业道。时彼城中有转轮王。名曰明净宝藏妙德。为大法王。治以正法。从莲华生。具三十二大人之相。七宝成就。王有千子端正勇猛。有十亿大臣。王有宝女。名妙德成满。端严姝妙目发绀色身如天金。梵音清净。身出光明照千由旬。彼有一女。名妙德眼。一切诸行皆悉具足。端正殊特观者无厌。有十亿百千那由他诸采女众。皆与圣王同善根行。身真金色。一切毛孔皆出妙香。众宝庄严超逾天女。尔时众生寿命无量。或有不定或有中夭。形色不同长短名号。音声善根精进方便。亦悉不同。有好有丑有赞有毁。尔时有人。谓一人言。我色端严汝形鄙陋。共相陵毁。作恶业已。寿命色力所受快乐。皆悉损减。时彼城北有道场树。名普光明妙法音幢。众宝为根无能坏者。茎节枝叶众宝合成。皆悉齐等。出众宝云普覆一切。放众宝光普照十方。演妙音声宣扬如来自在神力。于其树前有香水池。名宝华光明真法音云。众宝为岸。有十亿百千那由他宝树围绕。彼一一树。如菩提树。宝璎珞树周匝垂下。清净妙宝以为庄严。众宝楼阁无量无数周遍道场。彼香池中有一莲华。名三世一切佛庄严境界云。最初妙德幢佛。于彼华上成等正觉。化众生故。放大光明。名曰万岁。众生见者。知后万岁佛当出世。次后放光。名一切众生离垢欢喜灯。众生见者。知九千岁佛当出世。次后放光。名离垢灯妙德藏。众生见者悉睹妙色。知八千岁佛当出世。次后放光。名一切众生业报音声。众生见者。分别了知自己业报。知七千岁佛当出世。次后放光。名起一切善根音声。若有众生诸根不具。触斯光明皆悉具足。知六千岁佛当出世。次后放光。名曰显现不可思议诸佛境界音声。众生见者。悉发明净自在之心。知五千岁佛当出世。次后放光。名曰严净一切佛刹。众生见者。见一切如来严净佛刹。知四千岁佛当出世。次后放光。名一切佛不可坏境界明净灯。众生见者。知佛自在无所不至。知三千岁佛当出世。次后放光名普照三世一切诸佛本事音声。众生见者。知一切如来过去本事无量大海。知二千岁佛当出世。次后放光。名离痴曀智如来净灯。众生见者。得平等净眼。普见一切严净佛刹。一切如来。一切众生。知一千岁佛当出世。次后放光。名一切众生见诸如来长养善根。众生见者。知后七日佛当出世。次后放光。名一切众生欢喜音声。众生见者。一心欢喜欲见如来。佛子。彼佛于一万岁中。放如是等无量光明。教化众生。满七日已。佛神力故。一切世界六种震动。尔时众生。于念念中见一切佛刹。皆悉清净众宝庄严。时彼世界众生。悉诣道场。一切金刚围山。须弥山王。一切诸山。一切变化。一切音声。一切大地。一切城邑垣墙宫殿。如是等一切诸物。出微妙音歌颂赞佛。又出一切香云。一切宝光明云。一切宝形像云。一切宝衣云。一切华云。一切末香云。一切宝庄严云。一切如来圆满光云。一切如来大愿声云。一切如来妙音声云。一切如来诸相好云。显现不可思议如来瑞应相云。出如是等一切妙云。供养如来。时彼三世一切佛庄严境界云莲华周匝。出生十佛世界微尘等众宝莲华。彼一一莲华须上。有宝莲华藏师子之座。彼师子座上。有十佛世界微尘等菩萨摩诃萨。尔时妙德幢佛。于一切世界。随其所应转净法轮。令无量众生离恶道苦。无量众生生人天中。立无量众生于声闻缘觉之地。立无量众生于勇猛精进菩萨之行。立无量众生于离垢幢精进菩萨之行。立无量众生于法光明菩萨之行。立无量众生于清净根菩萨之行。立无量众生于平等诸力菩萨之行。立无量众生于一向专求入正法城菩萨之行。立无量众生于至一切处不可破坏神力自在菩萨之行。立无量众生于一切方便菩萨之行。立无量众生出生菩萨三昧安住菩提。立无量众生修一切净行安住菩提。立无量众生发菩提心。立无量众生住菩萨道。立无量众生清净诸波罗蜜。立无量众生于菩萨初地。乃至立无量众生于菩萨十地。立无量众生于菩萨大愿殊胜之行。立无量众生于普贤菩萨清净愿行。何以故。如来转不可思议自在法轮故。于念念中随其所应。以种种身种种方便种种说法。度脱无量众生。尔时普贤菩萨。知宝华灯城王都众生。自恃色貌陵蔑他人。化现妙身端严殊特。往诣彼城。放大光明普照一切。时彼圣王身之光明。诸宝光明。宝女光明。宝树光明。日月星宿光明。皆悉映蔽。犹如聚墨在真金山。普贤菩萨身色光明。映蔽众光亦复如是。尔时众生。各作是念。今此光明。悉蔽我等不复显现。为是梵天诸天光耶

大方广佛华严经卷第五十二大方广佛华严经卷第五十三

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十

尔时普贤菩萨。在彼圣王宝宫殿上。于虚空中而告之言。大王当知。佛兴于世。今在普光明妙法音幢菩提树下。时彼众生。见普贤菩萨相好严身无量光明。闻妙音声。欢喜无量发如是愿。令我等所作善根。得此妙身相好庄严。威仪无异。神力自在。除灭一切众生愚闇。觉悟一切。佛兴于世。趣趣受生。愿常不离此善知识。时彼圣王。与其宝女及诸眷属千子大臣并四种兵。上升虚空。放大光明照四天下。普为众生。以偈颂曰

  如来出世间　　普救诸群生
  汝等应速起　　往诣导师所
  无量无数劫　　或有佛兴世
  演说深妙法　　饶益一切众
  普见诸群生　　愚痴颠倒惑
  流转生死苦　　于彼起大悲
  无量无数劫　　修习菩萨行
  为化众生故　　发起无上悲
  头目手足等　　难舍悉能施
  无量无数劫　　专求佛菩提
  无量无边劫　　如来难值遇
  其有见闻者　　一切悉不虚
  如来在道场　　处佛正法座
  降伏一切魔　　得成最正觉
  观察如来身　　放演无量光
  种种微妙色　　除灭一切闇
  一一毛孔中　　放光不思议
  除灭愚痴曀　　令众悉欢喜
  各辨众供具　　发大精进心
  咸诣如来所　　恭敬设供养

尔时转轮圣王。赞叹佛已。以转轮王功德善根。兴十种云普覆虚空。往诣道场供养如来。所谓一切宝云。一切华云。一切衣云。一切宝衣云。一切宝网金铃云。一切坚固香云。一切如意珠云。一切妙宝幢云。一切宝宫殿云。一切庄严云。普覆一切庄严虚空供养如来。往诣佛所头面礼足绕无数匝。退坐普照宝藏之座。尔时妙德眼女。即解身上诸庄严具。奉散如来。时庄严具。于虚空中变成宝盖。众宝庄严。悉与一切诸宫殿等。端严齐整十宝庄严。金刚围山周匝围绕。其形犹如明净楼阁众宝庄严。无量龙王悉共执持。宝树围绕妙香普熏。于其盖中有菩提树。枝叶荣茂普覆法界。以无量庄严而庄严之。见卢舍那佛坐此树下。与不可说佛刹微尘等大菩萨俱。皆悉具足普贤菩萨一切所行。住菩萨住。无能坏者。又见一切世界诸王围绕如来。又见彼佛神力自在。又见一切诸劫次第世界成败。又见一切诸佛次第出世。又见普贤菩萨在一切佛所恭敬供养教化众生。又见彼一一世界中。悉有佛刹微尘等世界。种种安住种种庄严。种种清净种种劫。种种如来出兴于世。种种三世种种国土。种种法界种种诸道。种种入法界种种虚空。种种道场种种佛光。种种诸佛庄严师子之座。种种如来眷属。种种如来方便。种种转法轮。种种如来妙音说种种音声海说种种修多罗云。时彼女人见闻如是欢喜无量。尔时妙德幢佛。于大众中说修多罗。名一切如来法轮妙音。十佛世界微尘等修多罗。以为眷属。时彼女人闻此经已。即得一万三昧。身心柔软如初受胎。又如众生初受胜业果报。又如初生坚固吉树。所谓见现在一切诸佛三昧。普照一切佛刹三昧。深入三世三昧。一切如来妙音转法轮三昧。知一切佛愿海三昧。灭一切众生生死苦恼三昧。灭一切众生痴闇满足庄严大愿三昧。灭一切众生诸苦三昧。令一切众生具足快乐三昧。教化一切众生心无疲倦三昧。一切菩萨无碍幢三昧。菩萨降神母胎庄严三昧。得如是等一万三昧。复得净三昧心。不动心。欢喜心。正希望心。广大心。顺善知识教心。甚深萨婆若心。随顺方便海心。一切无著心。舍离一切世间境界心。究竟如来境界心。普照一切色海心。灭嗔恚心。爱念心。平等心。无疲倦心。不退转心。离懈怠心。观一切法寂静心。随顺一切法海心。随顺分别一切法心。分别一切众生海心。救护一切众生心。普照一切世界心。满一切佛大愿海心。坏散一切障碍山心。积集无量功德山心。向佛十力心。普照一切菩萨境界心。长养一切菩萨诸功德心。充满一切十方海心。发平等心。成满佛刹微尘等诸愿海心。愿净一切如来刹心。如是等心。出生十佛世界微尘等法门。所谓教化一切众生法门。分别一切法界法门。究竟一切法海法门。于一切世界尽未来劫出生菩萨行法门。于一切世界尽未来劫住菩萨行法门。往诣一切佛所法门。值遇一切善知识法门。恭敬供养一切佛法门。于念念中出生一切智不断菩萨行法门。出生如是等十佛世界微尘等法门。出生普贤菩萨愿行。专求一切智。时彼女人得诸如来初发心愿。善男子。复于是前。过十大劫有世界。名日轮光照。佛号因陀罗妙德幢。此妙德眼女。因普贤菩萨善知识故。造莲华如来像。众宝庄严。发菩提心。善男子。尔时明净宝藏妙德转轮圣王者。岂异人乎。今弥勒菩萨是也。时宝女妙德成满者。今寂静音夜天是也。妙德眼女者。我身是也。善男子。我以庄严具。供养妙德幢如来故。见佛无量自在神力。闻说正法。闻正法已。即得教化一切众生法门。恭敬供养须弥山微尘等一切如来。闻彼诸佛所说经法。皆悉受持。于一念中。见彼一切佛刹一切如来及菩萨众。善男子。其后有劫名大光明。世界名种种庄严。有五百佛出兴于世。我悉恭敬供养此诸如来。其最初佛。名大悲幢。我为夜天恭敬供养。次后如来。名金刚那罗延幢。时我为转轮王。恭敬供养彼佛。为我说修多罗。名起一切如来性。十佛世界微尘等修多罗。以为眷属。次后如来。名无碍妙德住。时我为转轮王。恭敬供养彼佛。为我说修多罗。名普照一切众生诸根。须弥山微尘等修多罗。以为眷属。悉闻受持。次后如来。名明净焰妙德山庄严。时我为长者。恭敬供养彼佛。为我说修多罗。名普照三世藏。阎浮提微尘等修多罗。以为眷属。悉闻受持。次后如来。名一切法海起王。时我为阿修罗。恭敬供养彼佛。为我说经。名分别一切法界。五百修多罗。以为眷属。悉闻受持。次后如来。名甚深妙法海光。时我为龙女。雨如意摩尼宝云。恭敬供养彼佛。为我说修多罗。名长养欢喜海。百万亿修多罗。以为眷属。悉闻受持。次后如来。名宝焰功德山灯。时我为海神。雨众宝华云。恭敬供养彼佛。为我说修多罗。名法界方便海。世界微尘等修多罗。以为眷属。悉闻受持。次后如来。名功德海光圆满妙德。时我为仙人。在雪山住。与六万仙人俱。往诣彼佛。雨宝华云。恭敬供养彼佛。为我说修多罗。名法灯无所著。六万修多罗。以为眷属。悉闻受持。次后如来。名明净妙德藏。时我为地天。名夜平等义。与无量天俱。往诣彼佛。雨一切宝一切宝藏一切庄严云。恭敬供养彼佛。为我说修多罗。名起一切如来智藏。无量修多罗。以为眷属。悉闻受持。佛子。如是五百如来次第兴世。其最后佛。名法界虚空宝山妙德灯。时我为妓人。名曰善口。彼佛入城。我在空中。以一千偈。赞叹如来。尔时世尊。眉间白毫相。放大光明。名普照法界庄严。普照十方。照已入我身中。即得法界方便不退藏法门。佛子。如是等世界微尘等劫。诸佛兴世。我悉恭敬供养彼诸如来。所说正法悉闻受持。未曾忘失一句一味。于一一佛所。得三世甚深法界清净法身。一切智光普照一切。摄取普贤菩萨所行。于念念中。悉见无量无边诸佛。得无量无边净慧光明。普照一切。先未得未证普贤所行。今悉成满。何以故。说无量无边故。尔时妙德救护众生夜天。欲重明此义。以偈颂曰

  善财应谛听　　甚深难见法
  普照于三世　　分别深法界
  如我初发心　　专求无上道
  随所得法门　　谛听我今说
  过去久远世　　佛刹微尘劫
  尔时有一劫　　名离垢圆满
  时有世界名　　明净妙德幢
  须弥微尘等　　如来出兴世
  初佛妙德幢　　二普慧光焰
  法幢德须弥　　第四师子佛
  第五寂静王　　六号除灭恶
  第七功德聚　　第八须弥山
  第九妙德佛　　第十明净月
  如是十如来　　彼劫初出世
  次复有十佛　　初虚空方便
  第二普光明　　三安住诸方
  第四功德海　　第五高无上
  第六最胜云　　第七功德佛
  第八光焰山　　第九莲华佛
  第十法界化　　是为第二十
  初光明幢王　　第二智慧佛
  第三心义佛　　因陀罗妙德
  第五妙天佛　　第六勇猛王
  第七智慧德　　第八光明幢
  第九如来号　　超出一切世
  第十莲华佛　　是为第三十
  第一光焰山　　第二功德海
  第三法光明　　第四妙莲华
  第五众生眼　　第六香光明
  七妙德宝山　　八乾闼婆王
  第九明净智　　第十寂静色
  初佛光智慧　　第二宝光明
  三虚空妙德　　第四妙相佛
  圆满功德光　　第六那罗延
  第七妙须弥　　八功德转轮
  九不可坏王　　第十宝山佛
  初佛娑罗王　　第二妙德藏
  第三光明王　　第四真实起
  第五光明德　　六陀罗尼德
  七光明甚深　　八法海音佛
  第九须弥幢　　光明妙德佛
  宝光焰如来　　是为第十佛
  初佛梵光焰　　第二虚空音
  第三法界光　　第四圆满光
  第五分别光　　第六光明幢
  第七虚空灯　　第八乐妙德
  第九明净光　　妙功德如来
  十寂静妙德　　大悲云如来
  初佛力光慧　　二众生现前
  第三无上福　　第四妙德光
  第五法起佛　　六风速妙德
  第七净幢佛　　第八宝盖佛
  第九妙德佛　　十普照三世
  初佛号愿海　　第二光明德
  第三金刚身　　四须弥妙德
  第五正念佛　　六幢王妙德
  第七智慧灯　　第八无量宝
  第九号方便　　明净法界佛
  第十号法海　　明净智妙德
  初佛号法宝　　功德转轮王
  第三功德云　　第四忍辱灯
  第五寂静音　　第六寂静幢
  第七众生灯　　第八大愿佛
  第九如来号　　不可坏幢王
  第十号智慧　　焰起妙德佛
  初佛号法王　　第二无碍智
  三照语言海　　第四妙音声
  第五妙德音　　第六自在佛
  七十方一切　　众生现前佛
  第八平等意　　九无上如来
  第十号自然　　贤妙德最胜
  如是等一切　　须弥尘数佛
  彼诸如来等　　我已悉供养
  佛刹微尘劫　　所出诸如来
  悉恭敬供养　　逮得此法门
  我于无量劫　　修行得法门
  善财闻思惟　　应当速究竟

善男子。我唯知此教化众生菩萨法门。诸大菩萨。究竟无量无边菩萨所行。悉从种种性海中。起种种正直身心。满诸根海。具足一切诸大愿门。修行无量诸三昧门。具足成就无量神力。修行无量智慧之行。入种种智。诸法光明普照一切。我当云何能知能说彼功德行。善男子。于此道场去我不远。有一夜天名寂静音。处宝幢莲华藏师子之座。百万阿僧祇诸天眷属围绕。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼妙德救护众生夜天足。绕无数匝敬心辞退

尔时善财童子。往诣寂静音夜天所。头面礼足绕无数匝。恭敬合掌于一面住。白言天神。我已先发阿耨多罗三藐三菩提心。我依善知识。学菩萨行入菩萨行。入菩萨行地。住菩萨行住。唯愿天神。为我解说。尔时夜天。告善财言。善哉善哉。善男子。乃能依善知识求菩萨道。善男子。我成就菩萨无量欢喜庄严法门。白言天神。此法门者为何所作。境界云何。何等方便为何等行。答言。善男子。我能清净一切众生心海。除灭尘垢。不断清净庄严之心。得不退境界坚固之心。不可动心。决定了知功德宝山庄严无染着心。常现前护一切众生心。见一切佛诸菩萨海无厌足心。清净菩萨正直力心。普照一切智慧海心。善男子。我为众生。灭除忧恼无量众苦。令其永离诸恶色声香味触意法。除灭众生爱别离苦怨憎会苦及余一切诸恶因缘坏败大苦。住生死苦生老病死忧悲恼苦。令得如来无上快乐。一切城邑聚落众生。我悉救护令得安乐。广为说法。教令渐求一切种智。若见众生在家宫殿心乐著者。为彼说法。令知诸法真实之性。若见众生。与父母兄弟欢娱宴集。为彼说法。令与诸佛菩萨共会。若见众生妻子欢会。为彼说法。令竭生死爱欲之海。具足大悲等观一切。若见众生处王宫殿。为彼说法。悉令逮得贤圣快乐。若见众生着境界者。为彼说法。令得如来甚深境界。若见众生起嗔恚者。为彼说法。令得如来羼提波罗蜜。为懈怠者演说正法。令得菩萨清净毗梨耶波罗蜜。为乱心者演说正法。令得如来禅波罗蜜。为邪痴者演说正法。令得般若波罗蜜。为着三界者演说正法。令出三有。为乐小法者演说正法。令其满足菩提大愿。为自安者演说正法。令具大愿饶益一切。为心劣者演说正法。令得菩萨力波罗蜜。为无智者演说正法。令得菩萨智波罗蜜。为无色者演说正法。令得如来清净色身。为危脆身者演说正法。令得无上清净法身。为恶色者演说正法。令得如来清净妙色。为苦恼者演说正法。令得如来无上快乐。为贫穷者演说正法。令得菩萨诸清净藏。为园观者演说正法。令一向求诸佛妙法。为在路者演说正法。令得一切智道。为聚落者演说正法。令出三界。为国土者演说正法。令过声闻缘觉及菩萨地。住如来地。为在城郭者演说正法。令入法王城普照一切。为在隅者演说正法。令得三世平等智慧。为在方者演说正法。令一切智常现在前观一切法。为贪欲多者演说正法。令观不净灭生死爱。为嗔恚多者演说正法。令得究竟大慈之海。为愚痴多者演说正法。令得智慧观诸法海。为等分者演说正法。令其分别诸胜愿海离生死乐灭生死苦显佛正法不着五阴常行妙法。为懈怠者演说正法。令得庄严胜道。为憍慢者演说正法。令观一切诸法平等。为谄曲者演说正法。令得菩萨清净直心。善男子。我以如是等无量法施。摄取众生。灭恶道苦处天人乐。永离三界具诸功德。种种方便而化度之。欢喜无量

复次善男子。我常观察菩萨大海。种种愿行。种种净身。种种净光。种种光焰。种种诸道趣萨婆若。入种种三昧海。显现种种自在神力。出生种种妙音声海。种种妙庄严身。种种方便入如来海。往诣种种诸佛刹海。究竟种种诸如来海。深入种种诸辩才海。普照种种如来境界。成就种种诸智慧海。超度种种三昧印海。安住种种游戏法门。以种种门趣萨婆若。种种庄严虚空法界。种种庄严云普覆虚空。观察种种诸大众海。十方世界一切刹中。诸如来所。菩萨眷属。普雨种种妙庄严云。皆悉来会。安处种种庄严之座。深入如来方便大海。行诸法海。度种种智海。我见此已。起无量欢喜。与佛力等。又善男子。卢舍那佛不可思议清净色身。相好庄严。我见此已。起无量欢喜。卢舍那佛。于念念中。放法界等光。普照一切诸法界海。我见是已。起无量欢喜。卢舍那佛。于念念中。一一毛孔。放无量佛刹微尘等光。一一光明。有无量佛刹微尘等光。以为眷属。普照一切充满法界。除灭众生一切苦恼。我见是已。起无量欢喜。卢舍那佛。于念念中。从顶上两肩上。放一切佛刹微尘等宝光山云。普照一切充满法界。我见是已。起无量欢喜。卢舍那佛。一一毛孔。放一切佛刹微尘等香云。普熏十方一切佛刹。我见是已。起无量欢喜。卢舍那佛。一一相中。出一切佛刹微尘等相。充满一切诸世界海。我见是已。起无量欢喜。卢舍那佛。一一毛孔。出一切佛刹微尘等自在力云。初发心等清净波罗蜜。庄严菩萨诸地。我见是已。起无量欢喜。卢舍那佛。一一毛孔。念念出生不可说不可说佛刹微尘等诸龙王身。为见龙身而受化故。又出不可说不可说佛刹微尘等诸夜叉身乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等身。为见彼身而受化故。我见是已。起无量欢喜。卢舍那佛。一一毛孔。出不可说不可说佛刹微尘等转轮王身云。七宝成就。神力自在。充满法界。为见彼身而受化故。我见是已。起无量欢喜。卢舍那佛。一一毛孔。出不可说不可说佛刹微尘等梵王身云。出净梵音。为众生说法。为见闻彼而受化故。我见是已。于念念中。起无量欢喜。悉与法界萨婆若等。起者非起。得者非得。见者非见。入者非入。度者非度。满者非满。闻者非闻。何以故。分别了知法界性故。解三世法悉一性故。佛子。此菩萨无量欢喜庄严法门。有如是等无量境界。佛子。此法门者无量无边。究竟方便诸法海故。此法门者不可损减。萨婆若心不可坏故。此法门者不可穷尽。众生妄想不可尽故。此法门者最为甚深。寂静智境界故。此法门者最为广大。一切佛境界故。此法门者不可破坏。菩萨智所知故。此法门者不可称量。不可破坏满法界故。此法门者即是普门。于一相中。摄取一切自在力故。此法门者是第一法。一切法无身行无二故。此法门者非生。一切诸法悉如幻故。此法门者如电。摄萨婆若诸大愿故。此法门者如化。善能变化菩萨行故。此法门者如大地轮。饶益一切诸众生故。此法门者如大水轮。以广大悲润众生故。此法门者如大火轮。消竭众生诸贪爱故。此法门者如大风轮。立一切众生萨婆若故。此法门者犹如大海。功德庄严一切众生故。此法门者如须弥山。一切功德海中起故。此法门者如大城郭。一切法街巷而庄严故。此法门者犹如虚空。三世诸佛自在最无上故。此法门者犹如庆云。普雨众生甘露法故。此法门者犹如白日。普照一切灭痴闇故。此法门者犹如满月。满足众生功德海故。此法门者如如。至一切故。此法门者如影。善能应化诸业报故。此法门者如响。随其所应为说法故。此法门者犹如电光。随其所应悉照知故。此法门者犹如树王。一切诸佛功德妙华。成就一切智果实故。此法门者犹如金刚。一切世间无能坏故。此法门者如随意宝王。出生无量自在力故。此法门者如离垢宝。悉分别知三世佛故。此法门者犹如宝幢。出一切佛平等法轮妙音声故。佛子。如此诸谕非谕为谕。尔时善财。白寂静音夜天言。菩萨修何等法。得此法门。答言。佛子。菩萨修行十妙法故。得此法门。何等为十。所谓菩萨修行布施。令一切众生海皆悉欢喜。修行净戒。成满诸佛功德大海。修行忍辱。了知一切诸法真性。修行精进。于萨婆若坚固不退。修行禅定。除灭一切众生烦恼。修行智慧。分别了知一切法海。修行方便。教化成熟一切众生海。修行大愿。于一切佛刹海。尽未来劫修菩萨行。修行诸力。于念念中。现一切刹成等正觉。修行无尽智。了三世法无所障碍。佛子。是为十妙法。菩萨摩诃萨。修行此法。起此法门。得此法门。净此法门。成此法门。长养增广不可沮坏。善财白言。天神。发阿耨多罗三藐三菩提心。为久如耶。答言。佛子。乃往古世。过二佛刹微尘等劫。有劫名普照幢。于此莲华藏庄严世界海东。过十世界海。有一世界海。名曰离垢众宝庄严。彼世界海中。有世界性。名一切佛光明愿音。彼世界性中。有一世界。名离垢光金色庄严。一切宝云而庄严之。众宝为地坚固不动。形如一切香妙德王。庄严楼阁皆悉清净。诸天宫殿充满其中。彼有王都。名曰普满妙德藏王。彼有道场。名一切众宝庄严藏月光明。其佛号不退法界妙音。于此道场。得阿耨多罗三藐三菩提。我于尔时。为菩提树神。名功德灯无边光幢。我见彼佛成等正觉。显现无量自在神力。我于尔时。发阿耨多罗三藐三菩提心。于彼佛所逮得三昧。名普照佛功德海。彼道场上。次有如来出兴于世。号法树功德山。彼菩提树神命终之后还生此处。为菩提树夜天。名妙德慧功德光明。闻彼如来转正法轮。复得无量欢喜。普照一切境界三昧。彼道场上。次有如来出兴于世。号一切法海妙音声王。值彼如来复得三昧。名成就一切法地。彼道场上。次有如来出兴于世。号宝光焰灯幢王。值彼如来复得三昧。名分别一切普照云。彼道场上。次有如来出兴于世。号功德须弥光王。值彼如来复得三昧。名照诸佛海。彼道场上。次有如来出兴于世。号法云妙音声王。值彼如来复得三昧。名一切法海灯。彼道场上。次有如来出兴于世。号智慧炬明净灯王。时我为天女。值彼如来复得三昧。名明净灯灭众生苦。彼道场上。次有如来出兴于世。号法勇幢妙德。值彼如来复得三昧。名三世佛普照藏。彼道场上。次有如来出兴于世。号法灯勇猛智慧师子。值彼如来复得三昧。名明净智普照一切无所障碍。彼道场上。次有如来出兴于世。号智力山王。值彼如来复得三昧。名普照三世众生根行。佛子。彼普照幢劫。离垢光金色庄严世界。如是次第有十佛世界微尘等如来。出兴于世。我于尔时。或为天王龙王夜叉王乾闼婆王阿修罗王迦楼罗王紧那罗王摩睺罗伽王。或为人王梵王。男子女人童男童女。皆悉值彼一切如来。恭敬供养。彼佛说法悉闻受持。于彼佛刹二佛世界微尘等劫。修菩萨行。经佛刹微尘等受生。最后命终。生此莲华藏庄严世界海。娑婆世界中。作道场夜神。值拘楼孙如来。得三昧眼。名离垢一切香王光明。次值拘那含牟尼如来。复得三昧。名随顺普照一切刹海。次值迦叶如来。复得三昧。名妙音声海。分别一切众生音海。今复值见卢舍那佛。坐于道场菩提树下。成等正觉。于念念中。显现无量自在力海。复得菩萨无量欢喜庄严法门。得法门已。深入十不可说不可说世界海微尘等法界方便海。以此法界方便海。于一切佛刹微尘。一一微尘中。悉见十不可说不可说佛刹微尘等世界及彼诸佛。彼诸如来所说正法悉闻受持。又见卢舍那佛。于念念中。一切世界坐于道场成等正觉。出生无量自在神力。一一神力满法界海。我悉诣彼。所说正法悉闻受持。又复见彼一切诸佛。一一毛孔。出化身海满法界海。显现种种自在神力。于一切佛刹海。一切世界性。一切世界。一切诸趣。一切众生中。随其所应转正法轮。我以精进闻持陀罗尼故。悉能受持。正念思惟知味知义。明智慧藏圆满清净。分别了知一切法海。观察三世诸佛平等。出生一切方便法门。于一一方便。出生一切修多罗云。一一修多罗云。成就一切诸正法海。一一法海。摄取一切诸回转法。一一回转法。普出一切诸妙法云。一一法云。出生一切诸法波浪。一一波浪。逮得一切欢喜法海。一一欢喜法海。出生一切诸功德地。一一功德地。出生一切诸三昧海。一一三昧海。见一切佛海。一一佛所。得一切光明海。一一光明海。普照三世。得圆满智地。普照十方。知无量佛过去行海。照一切佛无量本事海。难舍能施。持无量净戒。行无量忍。长养清净菩萨精进。清净无量诸禅定海。了知如来般若波罗蜜海。普照如来无量方便海。了知如来长养功德智慧力波罗蜜。分别如来无量智波罗蜜海。普照如来过去无量菩萨诸地。无量佛地。神力自在。无量劫中所修习起。净无量佛过去菩萨地。修无量佛过去智地。照无量佛诸智慧地。知无量佛为菩萨时相续善根。知无量佛为菩萨时于一切劫海中一切佛海所修菩萨行。知无量佛为菩萨时出生佛刹海。无量菩萨行充满法界。种种方便门教化众生。普照十方诸世界海。为诸众生现自在力。普照如来一切智地转净法轮。悉闻受持一切法云。显现无量菩萨自在神力。普照诸佛相海行海力海。于念念中。知彼诸佛从初发心乃至无余涅槃遗法灭尽。善男子。汝所问我发心已来为几时者。如上所说。乃至来生此刹。供养卢舍那佛。如此世界供养拘楼孙佛乃至卢舍那佛。供养贤劫未来诸佛亦复如是。如供养贤劫诸佛。供养一切世界未来诸佛亦复如是。而彼离垢光金色庄严世界。今犹现在。是故善男子。汝当一心修此法门。尔时寂静音夜天。欲重明此法门义。以偈颂曰

  善财应谛听　　我说此法门
  应生欢喜心　　勤修令究竟
  无量诸劫海　　修习菩萨行
  心净如虚空　　入一切智藏
  闻三世佛法　　一心乐专求
  于彼如来所　　修习诸功德
  我见过去佛　　恭敬悉供养
  闻佛说正法　　欢喜心无量
  亦已悉恭敬　　供养于父母
  一心乐专求　　究竟此法门
  老病贫穷等　　诸根不具者
  除灭彼苦恼　　悉令得安乐
  水火官贼难　　怨敌诸恐怖
  及海中诸难　　我皆救济之
  众生烦恼业　　种种受报苦
  摧破生死山　　救护诸群生
  一切诸恶道　　无量楚毒苦
  生老病死痛　　我当悉除灭
  我愿无量劫　　安隐一切众
  常见一切佛　　灭除生死苦

善男子。我唯成就此无量欢喜庄严法门。诸大菩萨深入法海。分别一切劫。善知一切诸世界海成败之事。我当云何能知能说彼功德行。善男子。此道场上。如来众中。有一夜天。名曰妙德守护诸城。汝诣彼问。云何菩萨学菩萨行修菩萨道。尔时善财。赞叹寂静音夜天。以偈颂曰

  我受知识教　　来诣天神所
  见无量净身　　安处天宝座
  虚妄取诸相　　染着一切法
  无智众生等　　不能知境界
  清净妙色身　　一切诸天众
  无量劫谛观　　其心无厌足
  远离于五阴　　一切无所著
  超出世疑惑　　显现自在力
  不染内外法　　无碍心不动
  明净智慧眼　　见佛自在力
  身为正法藏　　心是无碍智
  成佛智慧光　　普照诸群生
  分别说心业　　庄饰诸世间
  知心业自性　　现身等众生
  知世悉如梦　　了佛如电光
  一切法如响　　令众无所著
  念念悉除灭　　三世众生惑
  不取三世相　　而能演说法
  一切佛刹海　　一切诸佛海
  无量众生海　　无著修法门

时善财童子。头面敬礼彼夜天足。绕无数匝敬心辞退

尔时善财童子。正念思惟。智慧分别。随顺正趣。修广身证无量欢喜庄严法门。往诣妙德守护诸城夜天所。见彼夜天。处普照一切宫殿宝师子座。不可说诸天眷属围绕。随方面身。一切众生色身。普现一切众生前身。一切众生无所著身。一切众生身身。一切众生无上身。随顺教化一切众生身。游十方身。至一切十方身。究竟佛身。究竟教化一切众生身。善财见此身已。欢喜无量。头面礼足绕无数匝。恭敬合掌于一面住。白言天神。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨道饶益众生。以无上摄法摄取众生顺如来业亲近法王。时彼夜天。告善财言。善哉善哉。佛子。为救护一切众生故。问菩萨行。为严净一切佛刹。供养一切佛。住一切劫。救护一切众生。守护一切如来种姓。究竟十方一切法界海平等之心。充满一切。悉闻受持一切诸佛所转法轮。随其所应雨甘露法故。问菩萨行。善男子。我已成就甚深妙德自在音声法门。是故佛子。我为胜大法师。无所挂碍。于一切法心无所著。分别如来一切法藏。安住如来大慈大悲。建立众生于菩提心。得一切利不舍菩提心。长养一切善根。为一切众生调御大师。安立众生一切智道故。于一切世界为明净日。照一切众生无量善根故。等心观察一切众生。不舍一切众生。出生长养一切善根。甚深智慧观净尔焰。断一切不善业行诸善业救护众生。显现一切诸佛世界。修行严净诸本事业。立一切众生清净善根。令值一切诸善知识无能坏者。立一切众生佛正教故。佛子。我常以法施为首。出生长养诸白净法。一切智心坚固不动。如金刚藏不可沮坏。心常依止佛力。魔力。善知识力。心坏一切诸结业山。心能专求一切智因满白净法无碍法门一切种智。佛子。我以如是智慧光明净诸众生。无量善法饶益一切。复次佛子。我以十行观察法界。随顺法界摄取法界。何等为十。所谓知法界无量。智慧无量故。知法界无量无边。悉见一切诸如来故。知佛法界无量无边。诣一切刹。恭敬供养一切佛故。知法界无分齐。于一切世界海。行菩萨行故。知法界不可坏。究竟如来不可沮坏圆满智故。知法界一。如来妙音一切众生无不闻故。知法界自然清净。教化一切众生满佛愿故。知法界遍至众生。深入普贤菩萨行故。知法界一切庄严。普贤菩萨行自在庄严故。知法界不可灭。一切智善根充满法界。令诸众生悉清净故。佛子。我以此十行观察法界。增长善根。知佛奇特境界不可思议。佛子。我如是正念思惟。以一万陀罗尼为众生说法。所谓摄取一切诸法圆满陀罗尼。持一切法圆满陀罗尼。一切法云雷震圆满陀罗尼。诸佛起住圆满陀罗尼。转一切佛名号轮圆满陀罗尼。分别演说三世诸佛大愿海圆满陀罗尼。摄一切乘海圆满陀罗尼。照一切众生业海灯藏圆满陀罗尼。一切法现前旋流勇猛圆满陀罗尼。一切智勇猛圆满陀罗尼。以如是等万陀罗尼。为一切众生分别说法

大方广佛华严经卷第五十三大方广佛华严经卷第五十四

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十一

复次佛子。我或为众生说闻慧法。或为众生说思慧法。或为众生说修慧法。或说一有。或说一切有海。或说一佛海。或说一切佛名号海。或说一世界。或说一切世界海。或说授一记。或说授一切记海。或说一佛眷属海。或说一切佛眷属海。或说一佛法轮。或说一切佛法轮海。或说一修多罗。或说一切佛修多罗海。或说一会。或说一切会海。或说一萨婆若心。或说一切菩提心海。或说一乘。或说一切乘海。佛子。以如是等无量方便。为诸众生敷演不可说不可说法。佛子。我深入此无坏法界。皆悉究竟如来正法。以无上法施摄取众生。尽未来劫。修习普贤菩萨所行。佛子。我已成就此甚深妙德自在音声法门。于念念中。悉能长养一切法门。充满法界。尔时善财白夜天言。妙哉。天神。如此法门最为甚深。得此法门其已久如。答言。佛子。乃往古世。过转世界微尘等劫。有劫名离垢光明。时有世界。名法界妙德云。有四天下微尘等香须弥山庄严。于莲华中出一切佛妙愿音声。一切众生净业所起众宝合成。形如莲华清净无垢。有须弥山微尘等众妙宝树。周匝围绕。有须弥山微尘等众妙宝香。以为庄严。有须弥山微尘等诸四天下。庄严世界。一一四天下。各有不可说不可说城。彼世界中有四天下。名庄严幢。彼四天下有王都城。名普宝华光。于彼城外有道场。名法王宫殿光明。其道场上。有须弥山微尘等佛。出兴于世。其最初佛号法海雷音光明王。时有转轮王。名离垢光明。于彼佛所守护正法。闻持正法修多罗海。佛灭度后出家学道。正法欲灭。于大劫中有恶劫起。烦恼炽盛。众生恚怒忿毒交诤。诸比丘众背功德利。心乐放逸。常好王论贼论女论国论海论世间之论。乐如是等种种诸论。时王比丘作如是念。如来无量阿僧祇劫修集妙法。云何此诸比丘而共毁灭。彼王比丘即升虚空。放大光明云。无量种色。普照十方一切世界。除灭一切众生烦恼。立无量众生无上菩提。复令正法于六万五千岁而得兴盛。时有比丘尼。名法轮化光。是彼转轮王女。十万比丘尼以为眷属。见父王比丘光明神变。即发阿耨多罗三藐三菩提心。得一切佛灯明三昧甚深妙德自在音声法门。得已。身心柔软。法海雷音光明王佛。神力自在。一切功德悉现在前。佛子。时转轮王。随彼如来。转正法轮。兴隆法者。岂异人乎今普贤菩萨摩诃萨是也。法轮化光比丘尼者。我身是也。我于尔时。守护佛法。建立十万比丘尼众。得不退转地。又令摄取一切如来法门三昧。法轮光明三昧。又复建立入一切法海方便般若波罗蜜。佛子。次有如来。出兴于世。名离垢法山。我得值遇。次有如来。名法圆满光明周罗。次有如来。名法日妙德云。次有如来。名法海分别妙音声王。次有如来。名法日圆满灯。次有如来。名法化幢云。次有如来。名法焰山幢王。次有如来。名甚深法妙德月。次有如来。名法智普光明藏。次有如来。名普智境界觉悟众生。次有如来。名妙德山王。次有如来。名普门普贤须弥山。次有如来。名一切法精进幢。次有如来。名宝华妙德云。次有如来。名寂静甚深光明周罗。次有如来。名法焰大慈光明月。次有如来。名光焰妙德海。次有如来。名智慧日普照一切。次有如来。名圆满普智。次有如来。名无上智觉明王。次有如来。名功德焰华灯。次有如来。名智慧师子幢王。次有如来。名普日光明王。次有如来。名须弥相庄严。次有如来。名勇猛日普光明。次有如来。名法网觉妙德月。次有如来。名法莲华敷善德妙音。次有如来。名相日普光明。次有如来。名普光妙德正法音声。次有如来。名无畏妙德那罗延师子。次有如来。名普智健幢。次有如来。名敷法莲华身。次有如来。名功德华妙法海。次有如来。名道场觉妙德月。次有如来。名法炬妙德月。次有如来。名普照光明周罗。次有如来。名法幢灯。次有如来。名妙德海幢云。次有如来。名名称山妙德云。次有如来。名栴檀妙德月。次有如来。名明净普妙德华。次有如来。名普照众生光明王。次有如来。名钵头摩华妙功德藏。次有如来。名香焰光明王。次有如来。名钵头摩因。次有如来。名明净相山。次有如来。名普称功德幢。次有如来。名普门光明须弥山。次有如来。名妙德法城光明。次有如来。名明净功德山。次有如来。名胜相妙德。次有如来。名法力勇猛幢。次有如来。名法轮光明妙音。次有如来。名功德光焰楼阁智光。次有如来。名无上妙法轮月。次有如来。名明净法钵头摩觉幢。次有如来。名宝钵头摩光藏。次有如来。名宝尸弃云灯。次有如来。名智觉华。次有如来。名种种焰妙德须弥山藏。次有如来。名圆满焰妙德王。次有如来。名功德云庄严光明。次有如来。名法山云幢。次有如来。名普明净功德山。次有如来。名法日云灯王。次有如来。名法云名声自在王。次有如来。名法圆满云。次有如来。名善觉明净智幢。次有如来。名法圆满善觉妙德月。次有如来。名金色山贤。次有如来。名明净贤妙德须弥山。次有如来。名普智慧云妙声。次有如来。名法力妙德楼阁。次有如来。名香焰妙德王。次有如来。名金色摩尼山妙声。次有如来。名白毫藏一切法圆满光明。次有如来。名明净法轮。次有如来。名无上清净尸罗山。次有如来。名普精进炬光照云。次有如来。名广三昧海天冠光明。次有如来。名宝焰妙德王。次有如来名法炬宝帐妙声。次有如来。名法云空光明师子。次有如来。名相好庄严幢月。次有如来。名光明焰山电云。次有如来。名无碍虚空法光。次有如来。名乐智华敷。次有如来。名世间主光明妙声。次有如来。名法三昧光明妙音。次有如来。名法音真宝藏。次有如来。名法光明焰妙声海。次有如来。名普照三世相幢。次有如来。名法圆满山光明。次有如来。名法界师子光明。次有如来。名法界师子焰。次有如来。名明净妙德须弥山。次有如来。名一切三昧海师子。次有如来。名普智光明灯。佛子。于离垢光明劫中。如是等须弥山微尘等如来。出兴于世。其最后佛。名法界城明净智灯。彼诸如来我悉恭敬供养。闻法受持出家学道。守护佛法。于彼诸佛所。种种方便入此甚深妙德自在音声法门。以种种方便化众生海。复次。佛子。复有佛刹微尘等劫中诸佛出世。我亦皆悉恭敬供养。是故。佛子。一切众生长寝生死。唯我独觉。复能觉悟一切众生。守护心城离三界城。入一切智无上法城。善男子。我唯成就此甚深妙德自在音声法门。除灭众生两舌口过。令净实语。诸大菩萨。决了众生诸语言道。于一念中。觉悟一切众生之心。深入众生语言音海。善知众生施设语法。分别了知一切法海。深入摄取一切诸法陀罗尼海。善巧方便为众生出一切法云。究竟度脱一切众生。摄取众生立无上业。随顺净智分别业藏。能师子吼法施一切。得诸法地圆满陀罗尼。我当云何能知能说彼功德行。善男子。此佛众中。有一夜天。名开敷树华。汝诣彼问。云何菩萨学一切智。安立众生于萨婆若。尔时妙德守护诸城夜天。欲重明此法门义。以偈颂曰

  佛子深法门　　虚空如如性
  分别三世佛　　无量诸法界
  出生无量门　　不思议诸法
  长养无碍智　　了达三世法
  过转刹尘劫　　劫名离垢光
  世界妙德云　　城名宝华光
  彼劫次第有　　须弥尘等佛
  初佛号法海　　雷音光明王
  后佛法界城　　明净智慧灯
  我皆悉供养　　闻法大欢喜
  见法海雷音　　光明王如来
  众妙相庄严　　犹如须弥山
  见佛即发心　　专求一切智
  心大如虚空　　其性同如如
  充满于三世　　诸佛菩萨众
  大悲心普覆　　一切刹众生
  清净妙法身　　充满诸佛刹
  随其所应化　　悉为显现身
  我初发心时　　震动一切刹
  教化诸群生　　悉令大欢喜
  次值第二佛　　闻法而供养
  即时得睹见　　十刹海尘佛
  如是次第值　　须弥尘等佛
  恭敬供养彼　　一切诸如来
  闻法悉受持　　逮得此法门
  广度一切众　　究竟到彼岸
  转刹尘等劫　　诸佛兴出世
  我亦悉诣彼　　恭敬而供养
  闻法悉受持　　清净此法门

尔时善财。得此甚深妙德自在音声法门。入菩萨无量无边诸三昧海。出生无量无边陀罗尼海。得菩萨神通诸明光耀。入诸辩海。长养一切甚深法海。欲赞叹彼妙德守护诸城夜天。以偈颂曰

  智慧海成满　　永度生死海
  长寿智慧藏　　普照于十方
  了达内外法　　皆悉如虚空
  无碍清净慧　　究竟于三世
  念念能分别　　无量无有边
  一切诸境界　　而心无所著
  无量大悲心　　度脱众生海
  明净智慧眼　　了众生无性
  深入佛法海　　穷尽其原底
  种种巧方便　　化度诸群生
  普于一切法　　了达其真性
  修习萨婆若　　令众悉清净
  天是调御师　　究尽一切智
  充满诸法界　　说法化众生
  顺卢舍那愿　　无碍度众生
  安住至处道　　普见十方佛
  天心甚深妙　　除灭烦恼热
  清净如虚空　　离垢无染着
  摄取于三世　　佛刹诸如来
  一切菩萨众　　一切群生类
  一念分别知　　刹那及罗婆
  昼夜月半月　　乃至无量劫
  十方诸群生　　有色及无色
  有想无想等　　知死此生彼
  除灭一切众　　虚妄颠倒想
  善知语言法　　显现菩提道
  出卢舍那愿　　一切佛法海
  无碍法身心　　随应现众生

时善财童子。以偈赞叹彼夜天已。头面礼足绕无数匝敬心辞退

尔时善财童子。正念思惟。增广甚深妙德自在音声法门。往诣开敷树华夜天所。见彼夜天。在众宝香树楼阁之内。处宝树芽师子法座。百万诸天眷属围绕。尔时善财。头面敬礼彼夜天足。绕无数匝恭敬合掌于一面住。白言天神。我已先发阿耨多罗三藐三菩提心。云何菩萨学菩萨行。修菩萨道趣萨婆若。唯愿天神为我解说。答言。善男子。我于日没优钵罗钵昙摩华皆悉还合。若诸人众游园观者。废舍纵逸归其家时。为放光明。在险径者照示平路。令彼专求一切智道。若于山岩深水旷野。在如是等种种难处。悉放光照。令免众苦。得安隐乐。又善男子。若诸众生放逸五欲。为其显现老病死苦。悉令睹见舍离放逸修习善根。为悭贪者赞叹布施。若犯戒者。安立净戒。为嗔恚者。赞叹大慈安立忍辱。若懈怠者。教令修行菩萨精进。若乱心者。教令修习诸禅三昧。若愚痴者。令其深入般若波罗蜜。乐小法者。教以大乘。着三界者。令住菩萨圆满无著诸波罗蜜。若诸众生功德羸弱。为众结业之所逼迫。令住菩萨力波罗蜜。顺无智者。令住菩萨智波罗蜜舍离痴闇。善男子。我已成就无量欢喜知足光明法门。善财白言。天神。此法门者境界云何。答言。善男子。如来方便光明摄取众生。佛子。若有众生受快乐者。悉蒙佛力诸光明力。随如来教佛威神力。随顺佛道闻佛正法入佛善根。如来圆满明净智日。如来性净业力。普照一切。悉蒙如是功德力故。普令众生受诸快乐。佛子。我入此法门时。正念思惟。深入卢舍那如来应供等正觉过去所行菩萨行海。善男子。我知菩萨本发菩萨地心时。见诸众生着我我所。无明覆蔽入诸邪见随顺贪爱。欲恚所缚心乱颠倒。悭嫉所缠贫穷逼切。于生死中受众苦恼。不值诸佛。见如是已。发大悲心摄取众生除诸苦患普饶益之。令得一切无染着心。于诸施物不求果报。分别了知一切因缘诸法实相。具足成就大慈大悲圆满法盖。普覆众生。以知足法养智慧象。摧散一切诸烦恼山。安乐众生。随所应化雨甘露法。以圣法利等施众生。得十力果无上快乐。成就菩萨通力自在。充满法界。悉现一切诸众生前。雨一切物。悉令欢喜充足其意。救护众生灭生死苦不求恩报。严净一切众生心宝。悉同一切诸佛善根。增长萨婆若。教化成熟一切众生。以无上净法净诸佛刹。于念念中。满一切法界。以明净智分别三世。充满虚空。于一切时。转净法轮教化众生。令诸众生生一切智清净诸持。觉悟一切诸佛菩提。分别一切未来诸劫。于一切劫行菩萨行心无有二。悉能遍游一切世界。其身容受一切刹海。悉皆摄取一切世界。分别解说一切世界种种形色。种种庄严种种依住。或不清净或净不净。或纯清净或纯垢秽。或广或狭或大或小或覆或仰。如是等诸世界海中。生菩萨行证菩萨行。于念念中。出生菩萨诸自在行。于念念中。为众生现三世诸佛清净法身。佛子。卢舍那佛。于过去世行菩萨行时。见诸群生无智功德愚痴所覆。着我我所无明曀障。不正思惟入诸邪见。不识因果顺烦恼业。不修圣道得无作法。常于生死险道流转受种种苦。发起大悲。令诸众生出生菩萨无量诸行。修习一切诸波罗蜜。安立坚固胜妙善根。除灭众苦长功德藏。了知因果不违业报。知法真实。悉分别知众生欲乐及一切刹。守护受持一切佛法令不断绝。灭不善法满萨婆若。佛子。以如是等无量法施。摄取众生。令一向求萨婆若法。修行菩萨诸波罗蜜。具贤圣利。长萨婆若。满善根海。显现如来无量自在。以如是等种种方便。摄取众生。显现如来无量功德。安立众生于菩萨诸摄智慧。善财白言。天神。发阿耨多罗三藐三菩提心。其已久如。答言。佛子。此事难知难信难入难说难得。一切诸天声闻缘觉所不能知。除佛神力。依善知识成满善根。净正直心远离谄曲。灭诸染污。逮得普照智慧光明。哀愍众生。降伏诸魔。拔烦恼树。必欲成就一切种智。除灭生死忧悲恼海。得如来乐。入佛功德精进之海。安住佛地。满足如来一切智力。究竟十力。如此人者乃能信解。能知能入能说能得。何以故。此佛境界。一切众生及诸菩萨。所不能知。我当承佛神力为调伏众生。直心清净广修善根。得甚深心乐闻此法。为如此等随其所应分别解说。尔时夜天。欲重明此义。观察三世诸佛境界。以偈颂曰

  佛子此法门　　甚深佛境界
  不思刹尘劫　　说之无穷尽
  贪欲嗔恚痴　　高慢众生等
  皆悉不能知　　最胜寂静法
  悭嫉心谄曲　　烦恼业覆者
  一切不能知　　甚深佛境界
  着诸阴入界　　及起吾我见
  心想见颠倒　　不知佛境法
  清净离虚妄　　如来深境界
  依住生死者　　皆悉不能知
  出生如来家　　诸佛常守护
  奉持佛法藏　　慧眼之境界
  亲近善知识　　满足白净法
  究竟诸佛力　　闻此法欢喜
  心净离虚妄　　犹如虚空性
  慧灯除痴闇　　是彼之境界
  以大慈悲心　　普覆诸众生
  等心观一切　　是彼之境界
  其心大欢喜　　等观众生类
  舍离于一切　　离垢之境界
  净心离诸恶　　乃至畏微罪
  随顺诸佛法　　离垢之境界
  安住忍辱法　　其心不可动
  如实不违业　　无尽心境界
  勇猛勤精进　　安住不退心
  究竟萨婆若　　调伏之境界
  入于寂定心　　除灭烦恼热
  深入智慧海　　寂静起境界
  了达群生类　　诸法真实相
  深法之境界　　是慧灯法门
  觉悟众生性　　不着诸有海
  普照一切心　　是导师法门
  悉从三世佛　　清净愿性生
  普于一切刹　　穷尽未来劫
  修习菩萨行　　是普贤法门
  入诸方便海　　遍观诸刹海
  无碍深智慧　　悉知刹成败
  一一尘中见　　诸佛坐道场
  成佛化众生　　无碍眼法门
  善财至我所　　亲近善知识
  闻此甚深法　　精进勤修习
  此卢舍那境　　甚深难思议
  我承佛神力　　为汝分别说

佛子。乃往古世。过世界海微尘等劫。有一世界海。名明净山。彼有如来出兴于世。号智慧法界山诸方寂静普照王如来应供等正觉。彼佛为菩萨时。净彼世界海。彼世界海中。有佛刹微尘等世界性。彼一一世界性中。有世界微尘等佛。出兴于世。一一如来。说世界微尘等修多罗。一一修多罗中。授佛刹微尘等诸菩萨记。显现如来种种神力无量方便。种种诸乘教化众生。佛子。彼世界海中。有一世界性。名普门庄严。彼世界性中。有一世界。名曰一切宝色妙德普照一切宝华海。以为庄严。众宝为体状若天城。清净严饰。普照一切诸佛道场。显现诸佛变化光明。彼世界中。有须弥山微尘等四天下。彼四天下中。有一四天下。名宝山幢。彼四天下。有阎浮提。纵广十万由旬。彼阎浮提内。有十万大城。彼诸城中。有一王都。名坚固宝庄严云灯。有一万城周匝围绕。人寿万岁。时有大王。名一切法师子吼圆盖妙音。有五百大臣六万采女七百王子。端正勇健。尔时彼王。威德普被一阎浮提。无有怨敌。彼大劫中有恶劫起五浊炽然。尔时人民行十恶业。远离十善死入恶道。寿命短促形色鄙陋。贫穷下贱多苦少乐。更相诤讼互相谤毁。离他眷属深入邪见。以诸贪着行非法故。风雨不时。卉木丛林百谷苗稼皆悉枯槁。彼时人民饥馑病瘦。悉诣王都高声大呼。时诸人众无量无数围绕王城。或举两手或复合掌。或号天扣地。或举身自扑。或右膝着地。或着弊衣眼无光色。悲声大叫。咸言。大王。我等今者大苦大苦。饥渴寒冻疾病危困。无所归依无救济者。如在牢狱。种种苦逼转趣死路。作如是等无量楚毒悲声上诉。求自全济安隐快乐。大王则是众生宝藏清凉之池。善正治法大智大乘。为大宝洲真实利益。能与众生天人之乐。时彼大王。闻此悲苦楚毒音声。即得百万阿僧祇大悲法门。一心思惟。即发十大悲语。何等为十。所谓呜呼痛哉。一切众生。坠于无底生死深坑。无所归依。我当为彼作归依者。悉令逮得如来之地。哀哉众生。为烦恼乱无有救济。我当为彼作救护者。悉令安立一切善业。哀哉众生。生老病死无有救护。我当为彼作救护者。除灭一切身心苦痛。哀哉众生。有诸恐怖无有救护。我当为彼作救护者。令住一切智安隐之处。哀哉众生。为身见疑之所覆蔽。我当为彼作明净灯。普照一切现明净智。哀哉众生。为愚痴覆。我当为彼作大明炬。现一切智正法之城。哀哉众生。为诸悭嫉谄曲幻伪。浊乱其心。我当令彼悉得无上清净法身。哀哉众生。为生死长流之所漂溺。我当令彼度生死海到佛彼岸。哀哉众生。从生盲瞽。我当令彼见真实义同一切佛。哀哉众生。根不调伏。我当令彼调伏诸根。除灭障碍。得一切智。时彼大王。发如是等十大悲语。击鼓宣令。一切众生安隐勿怖。随汝所须我皆资给。即时颁下阎浮提内大小诸城都邑聚落。悉开库藏。金银珍宝衣服肴膳。香华璎珞床席被褥。宫殿宅舍诸妙宝幢。夜光宝幢摩尼宝幢。医师汤药。种种诸器盛众杂宝。诸金刚器盛众妙香。种种香器盛诸衣服。种种车乘幡彩幢盖。又复击鼓。宣令天下一切诸城都邑聚落。今施汝等国土城邑聚落妻子。头目齿舌心肝血肉肠胃手足一切肢节。时城东门外有大会处。名曰明净摩尼妙德。其地平正。广博清净无诸杂秽。众宝为地散杂宝华。熏以众香。一切香云充满虚空。宝树围绕。无量华网及诸宝网。罗覆其上。自然演出无量亿那由他娱乐音声。有如是等无量珍妙。而庄严之。皆是菩萨净业果报。于彼会中王所住处。十宝为地。十宝栏楯。十种宝树周匝围绕。形色金刚不可沮坏。众宝庄严悬诸宝幡。白净宝网。金铃宝网。众华宝网。摩尼宝网。杂衣宝网。罗覆其上。熏以名香。自然演出无量微妙歌颂音声。时彼大王处师子座。端严殊妙。具大人相。肢节周备。那罗延身不可沮坏。王姓中生以正治国。于财心法悉得自在。功德无量无违命者。众妙宝盖以覆其上。其盖常出无量光明。阎浮金色。覆以净妙摩尼宝网。金宝诸铃出和雅音宣扬善行。尔时阎浮提内。无量阿僧祇众生。悉来归命。赞言。大王。王是智人。天下第一。功德须弥。功德明净犹如满月。得菩萨心。等观众生普施一切。时王见已欢喜无量。于彼大众。发大悲心善知识心。随所求者悉令充足。而摄取之。时王即得无量快乐。释提桓因乃至化自在天王。无量百亿那由他劫。受诸快乐所不能及。他化自在天王。不思议劫受诸快乐。亦所不及。大梵天王不可说劫住梵住乐。亦所不及。乃至净居天。无分齐劫住寂静乐。亦所不及。复次善男子。譬如有人仁慈至孝。遭世事难。违离父母。经历年岁后忽遇会。瞻奉亲颜欣慰踊悦。不能自胜。时彼大王。见来求者心大欢喜亦复如是。信心坚固长养菩提。何以故。此菩萨专求一切智。饶益安乐一切众生。成满大愿。远不善法修行诸善。救护众生开萨婆若门。摄一切智满众生愿。入一切佛诸功德海。坏一切烦恼魔业障山。随顺一切诸如来教。入深智流不违正道。出诸法流成满大愿。住大人法。满足普门善根之藏。离一切恶心无所染。了达诸法犹如虚空。复次佛子。时彼大王。见诸众生。发一子想父母想。福田想难报恩想。师想佛想。大慈悲心悉普覆之。随其所须。衣服饮食。华香末香涂香。鬘盖幢幡诸庄严具。床座被褥。舍宅宫殿园观浴池。车乘辇舆象马众宝。所住宫殿及其眷属。内诸库藏城邑聚落。如是一切悉施众生普令充足。时彼会中有一童女。名宝光明。端正姝妙颜容无伦。身如真金目发绀色。口演妙音身出名香。众宝庄严。常怀惭愧。正念无乱。威仪庠序。于诸师长恭敬尊重。诸根寂定念慧现前。所闻诸法能持能解。宿世长养无量善根。诸妙善法润泽其身。近善知识好乐大乘。心如虚空自安安彼。常乐见佛求萨婆若。与六十童女俱。去王不远。一心恭敬合掌而住。作如是念。我得善利。见善知识遇善知识。于彼王所。起大师想善知识想慈悲人想。生此念时。欢喜无量。脱庄严具置彼王前。发如是愿。今此大王。安隐无量无边众生。愿我来世亦复如是。大王智慧。大王正道。大王所乘。大王相好。大王财宝。无能坏者。愿我来世亦复如是。随所生处我亦随生。时彼大王。告此女言。我今悉舍内外所珍。恣汝取之。时彼女人。倍增欢喜。以偈颂曰

  大王未兴世　　坚固庄严都
  一切不可乐　　犹如饿鬼处
  众生相残害　　窃盗纵淫佚
  两舌不实语　　无义粗恶言
  贪利他财物　　嗔恚怀害心
  邪见不善行　　命终堕恶道
  如是众生等　　愚痴所覆蔽
  种种行诸恶　　天旱不降泽
  以无时雨故　　百谷悉不生
  草木皆枯槁　　泉流亦干渴
  大王未兴世　　一切诸河池
  皆悉干枯涸　　犹如大旷野
  大王初生时　　天兴庆重云
  降雨普流泽　　河池悉盈溢
  除灭一切恶　　远离诸恐怖
  人民皆欢喜　　大王生世故
  往昔诸群生　　各各相残害
  饮食人血肉　　今悉修慈心
  百谷昔不生　　卉木皆枯燥
  饥渴所逼迫　　种种受苦恼
  大王既兴世　　粳米自然生
  树出妙衣服　　王世所归故
  昔日竞微利　　强弱相陵夺
  今种种庄严　　如释难陀园
  昔人贪欲重　　种种放逸行
  侵犯他妻色　　而共相危害
  今日诸人民　　众宝妙庄严
  贞洁无邪淫　　犹如兜率天
  昔日诸众生　　妄言非法语
  纵口无义言　　谄曲取人意
  今日群生类　　远离诸恶语
  爱眼视众生　　口发柔和音
  昔日诸众生　　种种行邪见
  合掌恭敬礼　　牛羊犬豕类
  今闻王正法　　远离诸邪见
  善知苦乐法　　悉从因缘起
  大王演妙音　　无不爱乐者
  梵释等音声　　皆悉不能及
  大王众宝盖　　悬处虚空中
  覆以诸宝网　　普出妙香熏
  金铃自然出　　如来和雅音
  宣扬甚深法　　除灭众烦恼
  次复广演说　　十方诸佛刹
  一切诸劫中　　如来及眷属
  又复次第说　　过去十方刹
  一切诸劫中　　如来及眷属
  又出微妙音　　充满于天下
  梵王诸群生　　悉闻业果报
  众生闻音已　　自知诸业藏
  离恶修众善　　专求无上道
  王父名净光　　母曰莲华光
  父于五浊世　　正法治天下
  五百莲华池　　宝树悉围绕
  底布以金沙　　宝华悉敷茂
  于彼池岸上　　有诸妙法堂
  众宝为栏楯　　种种宝庄严
  末世恶法起　　积年不降雨
  池流皆枯涸　　卉木悉焦然
  七日王当生　　先降灵瑞相
  诸人见欢喜　　救护出世间
  彼时于中夜　　大地六种动
  自然演妙光　　犹如明净日
  浴池有五百　　功德水充满
  一切诸宝树　　如本悉荣茂
  河流诸泉原　　一切皆盈满
  灵泽普津液　　沾洽阎浮提
  树木诸丛林　　杂卉众药草
  百谷苗稼等　　生长普滋茂
  岩崿诸高山　　幽邃深险谷
  普及一切地　　自然悉平正
  山陵诸卉木　　沙砾杂秽等
  悉于一念中　　变成众宝玉
  人见此奇特　　欢喜而发言
  快哉大善利　　我得清凉池
  时彼净光王　　与内眷属俱
  一切大臣等　　欢喜游园观
  五百浴池中　　有池名欢喜
  池上妙法堂　　王眷属游止
  时王语夫人　　我愿悉成满
  国土还丰乐　　人民普安隐
  时彼浴池中　　千叶宝华生
  普放清净光　　明耀须弥顶
  明净金刚茎　　众宝为华叶
  阎浮檀金台　　诸妙香为须
  于彼莲华中　　出生一童子
  相好庄严身　　诸天悉敬礼
  王见大欢喜　　入池抚掬之
  安置后膝上　　汝子应欣庆
  宝藏普涌出　　宝树生妙衣
  天乐奏妙声　　充满虚空中
  时彼诸人民　　合掌恭敬礼
  欢喜如是言　　此是世归依
  身放大光明　　普照于一切
  若有遇斯光　　诸漏悉除灭
  一切恶鬼神　　毒害众生类
  悉舍不善心　　自然生慈愍
  恶名失善利　　疾病鬼所持
  如是众苦灭　　一切皆欢喜
  天下诸群生　　相视如父母
  离恶修慈心　　专求一切智
  远离诸恶趣　　广开天人路
  显现无上道　　度脱诸群生
  我等得善利　　遇斯大施主
  众生失正路　　导师今出世

尔时宝光明童女。偈赞王已。头面礼足绕无数匝。恭敬合掌于一面住。王赞女言。善哉善哉。乃能信知他人功德。是为希有。若有愚痴。不知报恩。无有智慧。浊心邪见。具如是等非法众生。不知不信诸佛菩萨清净功德一切智境。汝今专求无上菩提。修菩萨行。摄取安隐饶益众生。王赞女已。以无价衣手自授与。而告之曰。汝自着之。时彼女人以膝着地。敬礼合掌顶受而着。时王复与六十女。衣彼着衣已。与眷属俱。绕毕辞退。诸女衣中。普出一切星宿光明。众人见已咸叹之曰。此诸女等皆悉端正。如净夜天星宿庄严。善男子。尔时一切法师子吼圆盖妙音王者。岂异人乎。今卢舍那如来应供等正觉是也。净光王者。今净饭王是也。莲华光夫人者。摩耶夫人是也。时国人者。今大众是也。悉于阿耨多罗三藐三菩提。得不退转。或住初地乃至十地。大愿成就。住诸法门修方便道。求一切智住诸解脱。尔时开敷树华夜天。欲重明此义。以偈颂曰

  我有清净眼　　悉见世界海
  生死五趣中　　众生常流转
  见诸佛菩萨　　往诣菩提树
  得道转法轮　　化度诸群生
  我以净天耳　　境界一切音
  诸佛所说法　　悉闻欢喜持
  我有无二智　　一切无等等
  能于一念中　　了众生心海
  我得宿命智　　念一切劫海
  自身及他人　　分别悉了达
  我于一念知　　诸刹海尘劫
  诸佛及菩萨　　五道众生类
  彼佛初发愿　　专求佛菩提
  究竟悉满足　　无量菩萨行
  觉了等正觉　　种种巧方便
  转净妙法轮　　显现诸乘海
  为众演说法　　度脱于一切
  乃至遗法住　　我悉一念知
  我于无量劫　　修习此法门
  真佛子应速　　究竟此法门

佛子。我唯知此菩萨无量欢喜知足光明法门。诸大菩萨。于一切佛所。修行一切诸佛行海。求一切智。清净满足一切大愿。于一菩萨地。修行一切菩萨地海。于一菩萨行。摄取一切菩萨行海。于一法门自在。修摄一切法门。我当云何能知能说彼功德行。佛子。于此道场有一夜天。名愿勇光明守护众生。汝诣彼问。云何菩萨学菩萨行修菩萨道。成就众生无上菩提。净诸佛刹值一切佛。修习一切如来正法。时善财童子。头面敬礼彼夜天足。绕毕辞退

大方广佛华严经卷第五十四大方广佛华严经卷第五十五

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十二

尔时善财童子。往诣愿勇光明守护众生夜天所。见彼夜天在大众中。处于普照摩尼王藏师子之座。摩尼王网罗覆其身。光明普照一切法界。一切日月星宿光明。以为其身。一切众生形类色像。悉于中现。又现一切诸色海身。诸威仪身。诸方面身。应现一切众生前身。游行十方自在力身。于一切时现众生前不失时身。诣诸佛所敬礼之身。长养一切诸善根身。受持一切佛正法云不忘失身。满足一切菩萨愿身。普照一切诸世界身。除灭痴闇普照一切明净灯身。知法如幻离垢深慧了诸法身。觉悟一切普现意身。离炽然身不可坏身。无所依住佛行持身。无有染污清净法身。善财见已五体投地。起佛世界微尘等念。念彼天身良久乃起。恭敬合掌一心谛观。于善知识得十种心。何等为十。所谓得自己心。勇猛精进求萨婆若能受持故。得具一切智法心。随顺一切正教道故。得自受生心。安住无上正法门故。得同行心。共普贤菩萨诸行愿故。得具一切功德藏心。长养一切白净法故。得勇猛心。长养诸佛大精进故。得具一切诸善根心。成满一切诸大愿故。得辨一切大利益心。具足菩萨自在力故。是为于善知识得十种心。尔时善财。一心观察彼夜天已。得世界微尘等菩萨共法。所谓正念共法。念十方三世一切佛故。大慧共法。分别了知一切法海故。诸趣共法。一切佛法轮不可坏故。觉悟共法。智如虚空。普照三世一切方便海故。诸根共法。以明净慧普照众生一切根海故。净心共法。修菩萨道得一切智。无碍功德庄严故。境界共法。明净智慧照佛境故。随顺方便共法。究竟一切智方便海。普照一切故。知义共法。知一切法真实性故。法无畏共法。坏散一切诸怨敌故。清净色身共法。随其所应现净身故。诸力共法。于萨婆若不退转故。无畏共法。净正直心如虚空故。精进共法。于一切劫行菩萨行不退转故。辩才共法。明净智慧深入诸法照一切故。无比共法。一切众生无能胜故。语言共法。于大众中说净妙法无所畏故。妙声共法。能师子吼出微妙声满一切法海故。净音共法。一切众生悉乐闻故。净德共法。令一切众生悉清净故。智地共法。于一切佛受法轮故。梵行共法。安住一切佛境界故。大慈共法。于念念中普覆一切众生海故。大悲共法。雨甘露法救一切众生故。身业共法。于一切众生随所作故。口业共法。分别一切语言法故。意业共法。立一切众生萨婆若心故。庄严共法。严净一切诸佛刹故。诣一切佛共法。见一切佛出兴世故。劝请共法。请诸如来转法轮故。供养共法。供养一切诸如来故。教化共法。度脱一切诸众生故。光明共法。照一切法故。三昧共法。于一切众生心海得不动故。充满共法。诸菩萨等自在神力满诸佛刹故。菩萨法门共法。出生菩萨自在力故。眷属共法。乐与菩萨共同止故。深入共法。分别一切诸世界故。了心共法。广净佛刹故。随顺共法。入一切佛世界海故。充满方便共法。分别了知一切世界故。无上共法。普现一切诸佛刹故。不退共法。游行十方无障碍故。除灭一切愚痴共法。得一切佛圆满智故。不生共法。与一切佛为眷属故。满一切佛刹网共法。恭敬供养一切佛故。决定智共法。分别了知诸法海故。如说修行共法。顺入一切诸法门故。专求共法。欲求一切诸净法故。清净共法。诸佛功德庄严身口意故。净意共法。于一切法智满净故。勇猛共法。究竟一切事满善根故。净行共法。满足一切菩萨行故。无碍共法。分别了知诸法相故。方便共法。具足自在智法门故。净入共法。随其所应现境界故。菩萨门共法。修行一切诸佛法故。护持共法。一切诸佛所护持故。离生共法。次第逮得菩萨地故。安住共法。安住一切菩萨住故。演说共法。了知诸佛授记法故。禅定共法。于一念中悉入一切诸三昧故。三昧起共法。一切佛事种种相故。净念共法。知一切念故。菩萨行共法。尽未来劫行菩萨行不断绝故。净信共法。欢喜增长佛智慧故。长养共法。除灭一切诸障碍故。不退智共法。与一切佛智慧等故。受生共法。随时应化一切众生故。住共法。住一切智故。境界共法。法界境界故。无著共法。心不染着一切有故。善知法相共法。等心观察一切法故。容受共法。于己身内受持一切诸佛法故。通明共法。分别了知一切世间故。神力共法。以少方便游行一切佛刹海故。陀罗尼共法。普照一切陀罗尼海故。持一切佛法轮共法。悉能受持一切修多罗法故。深入共法。解一切法如虚空故。净光共法。普照一切诸世界故。明净共法。随其所应现众生故。震动共法。动诸佛刹为诸众生现自在故。不虚共法。见闻念者悉不虚故。圣道共法。满一切愿十力智故。得如是等佛刹微尘等菩萨共法。尔时善财。入如是等菩萨共法。于善知识。得无量无边净正直心。偏袒右肩恭敬合掌。以偈赞叹彼夜天曰

  我以无上心　　专求佛菩提
  今于善知识　　而起自己心
  远离诸恶业　　成就清净行
  由见善知识　　得无尽白法
  我见知识已　　功德庄严心
  尽未来刹劫　　修行菩萨道
  唯愿善知识　　哀愍摄取我
  为我悉显现　　正教真实法
  闭塞诸恶趣　　广开天人路
  佛一切智道　　为我悉显现
  念彼善知识　　一切功德藏
  我于念念得　　虚空功德海
  授我波罗蜜　　不思议功德
  长养诸善福　　智缯速冠顶
  我念善知识　　一切种智道
  依止善知识　　满足白净法
  具足众善利　　功德普成满
  究竟一切法　　成就萨婆若
  知识为大师　　安立无上法
  无量无数劫　　不能报其恩

尔时善财。说偈赞已。白言天神。向所显现不思议法。此法门者名为何等。发道心来为几时耶。久如当成无上菩提。答言。善男子。此法门者。名随应化觉悟众生长养善根。善男子。我入此法门。觉悟一切诸法平等。知一切法真实之相。远离世间无所染着。解一切色非一非异。了色非色。而能显现无量诸色。所谓种种色。清净色。庄严色。放一切庄严色。普现色。同一切众生色。一切世间现前色。普照色见无厌色。相好净色。离恶色。现勇猛色。甚深色。一切世间无能尽色。叹无尽色。种种云色。诸形像色。显现无量自在力色。可爱乐色。一切善起色。随应现前色。随应度众生色。普照无碍色。离垢色。不坏净身色。不思议法方便光明色。非比非无比妙绝色。非明闇色。灭一切闇色。积集一切白净法色。功德大海之所生色。过去修行恭敬生色。净直心生如虚空色。胜广大色。无断无尽色。海光明色。一切世间无所依止不可坏色。充满一切十方无碍色。念念色。海色。令一切众生大欢喜色。摄取一切众生坚固色。一切毛孔中如来功德师子吼色。净一切众生深心色。显现一切法义色。圆满光明无碍色。离垢虚空等色。不依垢无著色。普照离垢法界色。不可称色。随眼见色。照诸方色。随时显现应众生色。寂静色。灭一切烦恼色。一切众生功德福田光明色。见不虚色。大智光色。无碍法身满一切色。显现威仪不虚色。积集大慈海色。具足功德须弥山色。普照一切趣色。净大智色。正念一切世间色。一切宝光色。净宝藏色。不坏净众生色。趣萨婆若色。悦众生眼色。一切宝庄严胜光明色。不取不舍一切众生色。无决定无究竟色。显现自在诸持力色。一切自在神足色。佛种姓色。远离众恶满法界色。悉诣一切诸佛大众照一切色。成诸海色。善行依果色。随化授色。一切世间见无厌色。种种光明普照色。显现三世一切色。显现一切海色。放一切光明海色。种种光色。过一切世间一切香光色。显现圆满诸日云色。持圆满净月云色。放须弥山妙华云色。出种种鬘云色。显现一切钵昙摩华云色。一切香像云充满法界色。散一切末香云色。现一切佛净愿身色。一切音声出师子吼法界海色。普贤菩萨清净身色。于念念中。现如是等色。充满十方教化众生。或见或念而得度脱。或现转法轮。或现随时应。或现亲近。或现觉悟。或现自在神力。或现种种变化。或现不可思议自在神力变化。度脱众生。灭不善法安立善法。满足大愿。一切智势力。菩萨法门势力。具足成就大慈大悲。佛子。我住此法门。现无量色身。分别了达一切色海。放无量无边法云。普照一切诸佛世界。现无量无边诸佛。现无量无边自在神力。觉悟众生长养善根。于念念中。令不可思议众生。于阿耨多罗三藐三菩提得不退转。佛子。如汝所问。得此法门为几时者。我今承佛神力为汝解说。佛子。菩萨圆满智慧。离一切虚妄。本性清净。一切种智。超出一切诸障碍山。随所应化皆悉普照。佛子。譬如日性无有暗冥。但日没已天下则闇。出则大明。菩萨圆满明净智日。亦复如是。离一切虚妄。普照一切教化众生。佛子。譬如净日出阎浮提。普照天下众宝山树。影现一切大海河池。众生之类莫不对见。日亦不来入此池流。菩萨智日。亦复如是。出三有海。于佛实法虚空中行。住于寂灭。应现一切趣趣生处。同众生身而化度之。实不生死无所染着。离一切虚妄无修短想。何以故。佛子。菩萨摩诃萨。离诸颠倒。了一切世悉如梦幻。解真实法无有众生。圆满大悲皆悉对现。一切众生而教化之。佛子。譬如大船。不依此岸不乐彼岸不着中流。于大海中济度众生。菩萨摩诃萨。亦复如是。以波罗蜜力船。于生死海济度众生。不依此岸不乐彼岸而度众生。于一切劫修菩萨行。不起劫想。亦不见劫有修短相。佛子。譬如虚空出过法界。一切世界有成有败。而彼虚空本性清净。无所染污不可沮坏。远离恐怖一切障碍。而能普持未来诸劫。一切佛刹。菩萨摩诃萨心。亦复如是。以虚空等圆满智慧。庄严其心。发起一切大愿风轮。持一切众生。令灭恶道生诸善趣。心无忧喜。安立众生一切智道。除灭烦恼生死过患。佛子。譬如化人无有实形生老病死饥渴等苦。菩萨出生如化智慧不可沮坏妙色法身。亦复如是。于一切劫诸生死中。化度众生而无所著。亦无恐怖。无贪无恚。除灭一切炽然烦恼。心不贪乐一切趣生。佛子。菩萨智慧。虽复如是甚深难测。我当承佛神力为汝解说。令未来世诸菩萨等。满足大愿成就诸力。佛子。乃往古世。过世界海微尘等劫。复过是数有劫。名善光。彼有世界。名曰宝光。于彼劫中。有万如来出兴于世。最初如来号法轮音声虚空灯。彼阎浮提中。有宝庄严王都。彼有大林名善光明。于此林中。有一道场名曰善华。彼道场上。有宝莲花师子之座。时彼如来。于此座上。成阿耨多罗三藐三菩提。尔时人民寿十千岁。杀盗淫佚妄言两舌恶口绮语贪恚邪见。行如是等十不善道。时彼如来。于百岁中坐于道场。为诸菩萨及诸天王并阎浮提宿植德者。而为说法。其余众生待善根熟。尔时国王名曰胜光。时彼人民行十不善贪着五欲。作种种恶远离善法。不孝父母。不敬沙门婆罗门。有无量众生犯王治法。囚执囹圄受诸楚毒。尔时彼王。有一太子。名曰善伏。端正殊特成就妙色。具二十八大人之相。处在中宫采女围绕。闻彼狱人楚毒音声。闻已忧恼起大悲心。入彼狱中见诸罪人。裸形乱发系缚搒笞。悲号流泪苦毒无量。太子见已发大悲心。慰谕之言莫恐莫怖。我今能令汝等解脱。于是太子往诣王所。白言大王。狱中罪人愿施无畏。大王。哀愍幸垂矜赦。时彼大王。召诸群臣而共参议。此事云何。群臣答言。彼诸罪人窃盗官物。谋弑大王侵犯宫人。有如是罪必应刑戮。若救彼者罪应至死。时彼太子大悲深至。救护彼故作如是言。我代狱囚受诸楚毒。愿苦治我。我为救彼不惜身命。欲令罪囚悉得解脱。所以者何。若我不救此众生者。云何能济三界牢狱。诸在生死牢狱众生。悉为贪爱之所缠缚。愚痴所蔽受种种苦。身形鄙陋心常放逸。而不能知出要之道。无智慧光着诸法界。无有福慧远离实智。染缚结垢幽闭苦狱。随顺恶魔生老病死。常为忧恼之所逼迫。我当云何令彼解脱。我今应当舍自身命而救拔之。尔时五百大臣。咸发声言。大王当知。如太子意。放狱囚者。毁坏王法危及我等。不治太子国不久立。王闻此言即发威怒令诛太子。王后闻之毁容降服。与千采女驰诣王所。头面礼足。如是请言。大王当知。太子有罪。愿垂慈恕赐其寿命。时彼大王即召太子。太子既至。复白王言。愿垂哀赦狱囚苦人。若不矜恕。我代受苦。王言随意。尔时太子。即入狱中。放诸罪人。代受楚毒曾无中悔。一向正念一切种智。大悲为首饶益众生。夫人白王。愿听太子。在外半月。布施修福。然后随王如法苦治。王即听许。时彼都城北有一大林。名曰日光。太子诣彼设大施会。须食与食须衣与衣。乃至车乘华鬘涂香末香幢幡缯盖。及余一切宝庄严具。期限既满。尔时国王及诸群臣。长者居士男女大小。并诸外道皆悉云集。尔时法轮音声虚空灯如来。知诸众生应化时至。与大众俱。天王围绕。龙王供养。夜叉王守护。乾闼婆王赞叹。阿修罗王礼侍。迦楼罗王以清净心散诸杂宝。紧那罗王欢喜赞叹。供养过去诸佛。摩睺罗伽王悲泣正观。与如是等无量大众前后围绕。来诣彼会。尔时太子及诸大众。遥见佛来。端严殊特诸根寂定。如大象王。神心澄明净若渊海。显现如来自在境界。胜妙功德相好严身。圆满光明。普照一切。震动十方无量世界。一切毛孔。普出如来微妙香云。普雨种种诸庄严云。行佛威仪。除灭一切众生烦恼。尔时太子。既见如来欢喜无量。五体投地。合掌白言。善来世尊。念哀取我。唯愿世尊。处摩尼座。诸菩萨众皆就宝座。周匝围绕。时佛坐已。除灭一切众生苦患。离诸障盖堪圣法器。尔时如来。知诸众生应受化者。而为演说圆满因缘修多罗。时彼大众。闻正法已。八十那由他众生。皆起离垢清净法眼。得无学地。一万众生得大乘道。满足普贤菩萨行愿。见十方佛转正法轮。现自在力。百佛世界微尘等众生。具摩诃衍。灭十方世界无量众生恶道苦难。生天人趣。时彼太子。得随应化觉悟众生。长养善根法门。佛子。尔时太子。岂异人乎。我身是也。我于一切众生。起大悲心普饶益之。不着三界。又亦不求名誉果报。舍离憍慢不轻他人。不加彼恶不贪财利。远离三有庄严大乘。开一切智门。普行菩萨无量诸行。佛子。我于尔时得此法门。时诸大臣。今五百恶人调达眷属是也。彼诸人等。佛皆教化。令发阿耨多罗三藐三菩提心。过未来世须弥山微尘等劫。成等正觉。所住世界同名宝光。国界庄严。父母种姓。受胎出生。弃家学道。往诣道场。转正法轮。说修多罗。语言音声。光明眷属。寿命法住。及其名号。皆悉不同。其最初佛号饶益月。第二佛号大悲师子。第三佛号救护众生。最后如来号大医王。佛子当知。本诸罪人。我所救者。即拘楼孙等贤劫千佛。及百万阿僧祇诸大菩萨。于无量精进妙德慧佛所。发阿耨多罗三藐三菩提心。今悉现在十方国土。行菩萨行。修习增广。此随应化。觉悟众生。长养善根法门者是也。佛子。时王胜光者。今萨遮尼揵子大论师是也。时王宫人诸眷属者。即彼尼揵六万弟子。与师俱来。共佛论义。悉降伏之。授阿耨多罗三藐三菩提记者是也。此诸人等当成正觉。世界劫号皆悉不同。佛子。我于尔时救罪人已。父母听我舍离国土妻子眷属。于法轮音声虚空灯佛所。出家学道。五百岁中净修梵行。于此中间。得一万三昧。一万陀罗尼门。一万诸明。一万法藏。一万萨婆若勇猛精进。一万清净忍门。一万寂灭禅定。一万方便般若波罗蜜。各于十方。现前对见一万如来。出生一万菩萨大愿。长养菩萨一万诸力。又得菩萨一万神通。于念念中。各游十方一万佛刹。于念念中。各忆十方一万佛海。见彼如来一万化海。普游十方教化众生。于念念中。见十佛世界众生。于诸趣中死此生彼。或好或丑。或之善处或入恶道。知彼众生诸心心法。心意所行及诸根海。行业善根皆悉明达。佛子。我于尔时命终之后。即复于彼阎浮提中。王宫受生作转轮王。彼法轮音声虚空灯如来灭度之后。我于尔时守护正法。次值法虚空妙德王佛。次为释王。即彼道场。值天藏佛。次为焰摩天王。即彼世界。值大地功德山佛。复值法轮光音声王佛。次为化乐天王。即彼世界。值虚空灯智王佛。次为阿修罗王。即彼世界。值一切法雷震王佛。次为他化自在天王。即彼世界。值不可坏力幢佛。次为梵王。即彼世界。值法轮化普光音佛。佛子。于彼宝光世界善光劫中。一万如来出兴于世。我悉值遇。次复有劫。名曰日光。六十亿佛出兴于世。时我为王。名大智慧。值最初相好功德山佛。复值妙音声佛。次为大臣。值离垢童子佛。次为阿修罗王。值勇猛精进佛复值究竟相好佛。次为商人。值离垢臂佛。次为城天。值师子行佛。次为毗沙门天王。值天周罗佛。次为乾闼婆王。值法上名称佛。次为鸠槃荼王。值光明天冠佛。恭敬供养。佛子。我诸趣受身。供养如是等六十亿佛。于一一佛所。教化无量无边众生。我于一一佛所。得种种三昧门。种种陀罗尼门。具足诸辩。种种智慧种种法光。照十方海诸佛刹海。见诸佛海。如一劫中值遇诸佛恭敬供养。于世界微尘等劫一切世界中。诸佛兴世我悉值遇恭敬供养。闻法受持守护正法。亦复如是。于诸佛所修此法门。尔时愿勇光明守护众生夜天。欲重明此义。以偈颂曰

  欢喜恭敬心　　能问甚深法
  我当承佛力　　为汝分别说
  过于不思议　　世界海尘劫
  尔时有一劫　　名曰为善光
  彼时有世界　　名曰为宝光
  于彼世界中　　十千佛兴世
  我值彼诸佛　　恭敬悉供养
  于彼如来所　　修习此法门
  尔时有王都　　名曰可爱乐
  广博悉平正　　种种妙庄严
  众生杂行起　　世界有净秽
  时彼诸众生　　多行不善法
  尔时有大王　　号曰为胜光
  正法治天下　　等心于一切
  彼王有太子　　号名曰善伏
  端严甚姝妙　　相好庄严身
  时彼诸人民　　有犯王法者
  幽闭在牢狱　　太子悉救之
  尔时诸臣等　　俱白大王言
  太子欲危王　　宜应加苦治
  时王用臣言　　如法治太子
  诸臣送太子　　至彼刑戮处
  王后闻此已　　来白大王言
  愿听十五日　　布施修功德
  时王即听许　　令其修福业
  肴膳车乘等　　随欲悉给之
  所期日已尽　　将至刑戮处
  彼时一切众　　悲感悉号泣
  时法轮音声　　虚空灯如来
  知众生根熟　　往诣大众所
  显现自在力　　演说圆满经
  无量诸众生　　悉授菩提记
  尔时王太子　　即发菩提心
  愿我悉度脱　　一切诸群萌
  供养彼如来　　即随佛出家
  勇猛精进力　　专求无上道
  具足此法门　　大悲念众生
  知法真实相　　劫海修菩提
  一切诸导师　　次第兴出世
  我皆悉恭敬　　供养护持法
  刹海微尘等　　一切诸劫中
  如来出兴世　　恭敬悉供养
  善伏我身是　　修习大悲心
  不惜身寿命　　救护彼苦人
  逮得此法门　　劫海常修习
  念念悉增长　　无量诸功德
  所见诸最胜　　方便为我说
  闻已即修习　　此寂灭法门
  无量劫修此　　不思议法门
  佛雨甘露海　　我已悉饮之
  依止此法门　　普游十方界
  一念悉分别　　三世诸佛刹
  依此法门故　　见三世佛海
  于诸最胜所　　现身如电光
  依此法门故　　遍诣十方佛
  各现大神力　　胜妙威仪法
  依此法门故　　能为问难海
  不思议诸佛　　所说闻受持
  依此法门故　　于十方世界
  诸佛大众中　　自在显神变
  依此法门故　　种种现色身
  能于一身中　　显现诸佛身
  依此法门故　　一一毛孔中
  放大光明海　　除众生烦恼
  依此法门故　　一一毛孔中
  出化无量身　　法雨济众生
  此法难思议　　菩萨所修学
  依住此法门　　尽来劫修行
  除灭诸邪见　　随应化众生
  悉令得安住　　一切种智地
  不可思议趣　　显现种种身
  随其所应化　　而为演说法

佛子。我唯成就此法门。诸大菩萨。超出世间普照诸趣。悉能究竟一切境界。坏障碍山。了达法相。善巧方便。分别诸法。解法无我。摄取教化度脱众生。皆悉了知三世法界。善知一切语言道海。我当云何能入如是大智慧海。大智境界。三昧解脱。法门自在。善男子。此阎浮提有一园林。名流弥尼。彼有天名妙德圆满。汝诣彼问。云何菩萨行菩萨行。生如来家为世间灯。尽未来劫修菩萨行心无疲倦。时善财童子。头面敬礼彼夜天足。绕毕辞退

尔时善财童子。正念思惟彼夜天教。修习增长。随所应化觉悟众生。长养善根法门。渐渐游行至彼林中。周遍推求妙德圆满林天。见坐众宝楼阁之上。二万那由他诸天围绕。为说菩萨受生海经。生如来家。长养菩萨功德。尔时善财。头面礼足。白言天神。我已先发阿耨多罗三藐三菩提心。云何菩萨行菩萨行。生如来家为世间灯。答言。佛子。菩萨有十种受生法。若有菩萨行是法者生如来家。于念念中长养善根。不退不怖不恼不乱。不懈不悔至一切智。顺知法界修解脱道。于一念中。长养一切诸波罗蜜。舍离世间具足佛地。智慧猛盛佛法现前。顺真实义满萨婆若。何等为十。所谓供养一切佛方便虚空愿藏菩萨受生法。满菩提心枝藏菩萨受生法。现前方便观察寂灭虚空藏菩萨受生法。以净直心普照三世藏菩萨受生法。普照一切藏菩萨受生法。生如来家藏菩萨受生法。佛光明力藏菩萨受生法。具足分别萨婆若门藏菩萨受生法。一切法界化庄严藏菩萨受生法。勇猛精进至佛地藏菩萨受生法。佛子。何等为供养一切佛方便虚空愿藏受生法。此菩萨摩诃萨。发如是愿。我当恭敬供养一切诸佛。无量喜心见佛无厌。具不坏信积集功德。供养诸佛心无厌足。佛子。是为初受生法。萨婆若初门长养善根故。佛子。何等为满足菩提心枝藏受生法。此菩萨摩诃萨。发阿耨多罗三藐三菩提心。起大悲心。救护一切众生故。值遇佛心。常见佛故。求正法心。无所惜故。大庄严心。向萨婆若故。发大慈心。普覆摄取一切众生故。不舍一切众生心。萨婆若庄严不可坏故。离谄曲心。得实智故。如说行心。得菩萨道故。不欺一切佛心。满足诸佛大誓愿故。为萨婆若发大愿心。教化未来一切众生故。如是等佛刹微尘等菩提心枝满足。生如来家佛子。是为第二受生法。佛子。何等为现前方便观察寂灭虚空藏受生法。此菩萨摩诃萨。观察寂灭一切法海心。究竟满足一切智道不疲倦心。正念善法业海心。一切菩萨诸三昧海清净心。具一切菩萨诸功德心。出生一切菩萨庄严道心。于无量劫勇猛精进不休息心。出生普贤行化一切众生心。善学威仪住菩萨德一切诸有悉非有心。佛子。是为第三受生法。佛子。何等为以净直心普照三世藏受生法。此菩萨摩诃萨。净直心界照佛菩提。深入菩萨方便法海。深心不坏犹若金刚。背一切有诸生死趣。向一切佛具自在力。趣诸胜道增益菩萨根。离垢净心不可动转。长养大愿。常为诸佛之所护念。坏散一切诸障碍山。悉为众生而作归依。佛子。是为第四受生法。佛子。何等为普照一切藏受生法。此菩萨摩诃萨。具足方便教化众生不贪财利。以清净心悉舍一切。持无量净戒。住佛境界。具足忍法。得一切佛忍光明法。勇猛精进。究竟一切智境界。修习诸禅。具足清净圆满普门三昧智慧。以明净慧日普照法界。得无碍眼见一切佛海。深入一切诸法原底。智者所赞。令众生欢喜。修习正法见真实相。佛子。是为第五受生法。佛子。何等为生如来家藏受生法。此菩萨摩诃萨。生如来家随诸佛教。具足一切甚深法门。同三世一切诸佛大愿。同三世一切诸佛善根。同三世一切诸佛法身。远离世间向离世间趣。长养白净法。住大功德法门。得佛持定见诸如来。随所应化净诸众生。不舍大愿闻法受持。佛子。是为第六受生法。佛子。何等为佛光明力藏受生法。此菩萨摩诃萨。深入佛力遍游十方。供养诸佛心无疲倦。知一切法如幻如梦。色如电光。成就如化自在通明。知一切有生趣如影。知一切佛所转法轮皆悉如响。悉究竟说一切法界。佛子。是为第七受生法。佛子。何等为具足分别萨婆若门藏受生法。此菩萨摩诃萨。以童子身。住菩萨住。观萨婆若。于无量劫。观察一一诸智慧门。劫犹可尽。诸智慧门不可穷尽究竟菩萨自在境界诸三昧门。念念悉诣十方佛所。入不可坏三昧境界。不可坏法。不可坏智。无边境界。得非境界。于少境界悉具足。得不可说地。于无量中得有量法。知诸世间名假施设。分别一切语言之法。佛子。是为第八受生法。佛子。何等为一切法界化庄严藏受生法。此菩萨摩诃萨。种种庄严无量佛刹。究竟众生。诸变化身。佛应化身。无所依止。清净法化。悉行一切无碍法界。应受化者为彼现身。教示种种诸菩萨行。善能出生离诸障碍一切智门净智慧藏。教化众生未曾失时。佛子。是为第九受生法。佛子。何等为勇猛精进至佛地藏受生法。此菩萨摩诃萨。悉于三世诸如来所受灌顶法。一切世界境界无障碍。菩萨悉知三世众生死此生彼。修菩萨行。知诸众生心次第起。知三世佛次成正觉。善巧方便知法次第。知一切劫次第成败。随应众生显现庄严。成等正觉显现次第转正法轮。教化无量无边众生。佛子。是为第十受生法。菩萨摩诃萨。住是法已。种种庄严一切佛刹。无量亿劫。无量法海。无量境界。教化众生。觉悟无量诸法界流。显现诸佛不可思议。如虚空等深法境界。无量诸行摄取众生。现转法轮。于一切世界。护持佛法。悉于一切境界。以微妙音说不可说佛正法云。住诸法门趣无碍道。以一切法庄严道场。随所应度成佛兴世。教化成熟无边众生。时彼林天。欲重明此义。以偈颂曰

  清净正直心　　先发如是愿
  普见一切佛　　供养无厌足
  皆悉净庄严　　三世诸佛刹
  以愿庄严心　　度脱诸群生
  修习寂灭法　　其心无厌足
  三世无障碍　　身心如虚空
  深入大悲海　　直心如须弥
  穷尽大智海　　是为人中雄
  大慈覆一切　　增广诸度海
  教化诸群生　　此是无上人
  知法真实相　　三世佛家生
  究竟诸法海　　是为智慧者
  清净妙法身　　其心无障碍
  己身满十方　　具足如来力
  甚深智慧中　　逮得自在力
  专求一切智　　究竟三昧海
  严净诸佛刹　　教化一切众
  显现自在力　　是为称庄严
  深入最胜力　　长养萨婆若
  法界无障碍　　此是真佛子

佛子。菩萨摩诃萨。具此十法。生如来家为世间灯。佛子。我成就此无量境界自在法门。尔时善财。白言天神。此法门者境界云何。答言。佛子。我已具足一切菩萨受生大愿。是故我来生此林中。本愿力故。正念菩萨受生之法。于后百年。菩萨从彼兜率陀天。降神下生。时此林中有十种瑞相。何等为十。一者此林忽然广博地平如掌。二者土石杂秽变为金刚众妙庄严。三者宝娑罗树周匝行列。四者时此林中沉水末香。出过诸天种种庄严。五者诸妙华鬘宝庄严具皆悉充满。六者诸宝树中自然流出种种妙宝。七者诸池水中出芙蓉华。八者时此林中娑婆世界欲色诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。恭敬作礼合掌而住。九者天女乃至摩睺罗伽女。赍供养具。合掌恭敬于一面住。十者十方一切佛脐中放光明。名曰菩萨受生自在灯。普照此林。于彼一一诸光明中。现一切佛受生自在出家自在。一切菩萨功德自在。又出如来微妙音声。佛子。是为林中十种瑞相。此相现时。诸天王等。知必当有菩萨下生。我见此瑞欢喜无量。佛子。摩耶夫人。出迦毗罗城。入此园林。生太子时。自然而有十种光明。因此光故。一切众生得法光明。何等为十。所谓宝芽藏光。一切香光。钵昙摩光。出微妙声赞善生光。十方菩萨初发心光。一切菩萨得入诸地自在法光。一切菩萨诸波罗蜜大智慧光。出生菩萨无量大智愿光。方便化度众生智光。普照一切法界诸佛受胎出生弃家学道成正觉光。佛子。是为十种光明。此光普照无量无边诸众生心。佛子。摩耶夫人。于此林中。在毕利叉树下坐。时现菩萨十种受生自在。何等为十。尔时欲界一切天王。天子天女。色界诸天。及龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽并其眷属。皆悉云集。为欲供养彼菩萨故。尔时摩耶夫人。放大功德妙色光明。普照一切。其余光明悉蔽不现犹如聚墨。除灭众生一切烦恼一切恶道苦。又于一切诸毛孔中放大光明。普照十方。无所障碍。是为菩萨第一受生自在。复次。佛子。摩耶夫人腹内。悉能容受三千大千世界。又能显现百亿四天下。于彼百亿阎浮提中。王都京邑所住园林名字各异。摩耶夫人。遍坐彼处。诸天围绕。悉为显现不可思议智慧自在。是为菩萨第二受生自在。复次。佛子。摩耶夫人。一一毛孔中。显现如来于过去世为菩萨时。恭敬尊重供养诸佛。彼诸如来所说正法。于毛孔中皆悉得闻。譬如明镜。净池水中见日月像。摩耶夫人诸毛孔中。显现如来于过去世为菩萨时。恭敬尊重供养诸佛。彼诸如来所说正法皆悉得闻。亦复如是。是为菩萨第三受生自在。复次。佛子。摩耶夫人一一毛孔中。显现如来于过去世诸世界中。城邑聚落山林河池。一切诸处行菩萨行。随彼诸劫所值诸佛清净善根。寿命名号及善知识。如是等事皆悉显现。菩萨于彼诸受生时。摩耶夫人常为其母。是为菩萨第四受生自在。复次。佛子。摩耶夫人一一毛孔中。显现如来于过去世为菩萨时。其身色相行业威仪所受苦乐。是为菩萨第五受生自在。复次。佛子。摩耶夫人一一毛孔中。显现如来于过去世为菩萨时。所行布施身体手足眼耳鼻舌。骨齿髓脑心血皮肉。妻子眷属城邑聚落。宫殿宝物一切内外。并诸受者皆悉显现。又闻求者所言音声。是为菩萨第六受生自在。复次。佛子。摩耶夫人身中。普出过去诸佛本为菩萨最后生时。庄严佛刹。众生树林。华鬘诸香涂香末香。摩尼宝王娱乐赞叹。如是等事充满此林。皆悉闻见。是为菩萨第七受生自在。复次。佛子。摩耶夫人身中。又出诸天宫殿龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽及人宫殿。众宝庄严妙香普熏无能坏者。出过诸天。为欲供养彼菩萨故。充满此林。是为菩萨第八受生自在。复次。佛子。摩耶夫人身中。又出十不可说亿那由他世界微尘等菩萨。其身色像相好庄严。光明自在及其眷属。皆悉同彼卢舍那佛。是诸大士。从彼出已。赞叹菩萨。是为菩萨第九受生自在。复次。佛子。菩萨生时。于摩耶夫人前地金刚轮中。生大莲华。金刚为茎。有十世界微尘等宝叶。摩尼宝王以为其台。众宝香鬘。以阿僧祇宝网罗覆其上。一切天王所共执持。一切乾闼婆王普雨香云。赞叹过去诸佛功德。一切夜叉王围绕守护。自然出生众妙宝华娱乐音声。一切阿修罗王皆悉降伏头面敬礼。一切迦楼罗王以宝缯幡庄严虚空。一切紧那罗王欢喜谛观心无厌足。赞叹歌颂菩萨功德。一切摩睺罗伽王欢喜踊跃。普雨种种庄严云。是为菩萨第十受生自在。佛子。摩耶夫人生菩萨时。如虚空中现明净日。如雷电光。如山起云。如闇中灯。菩萨尔时虽现出生。而悉解达一切诸法。如电梦幻。不来不去不生不灭。佛子。我一念中。悉知菩萨此阎浮提受生自在出生自在。亦知百亿阎浮提受生自在出生自在。亦知三千大千世界微尘等佛刹。十佛世界微尘等佛刹。乃至悉知一切世界微尘等佛刹。菩萨受生自在出生自在。亦复如是

大方广佛华严经卷第五十五大方广佛华严经卷第五十六

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十三

尔时善财。白圆满妙德林天言。天神。得此菩萨受生自在法门其已久如。答言。佛子。乃往古世。过亿佛刹微尘等劫。有劫名可悦乐。彼有世界。名一切宝。彼劫世界中。有八十那由他佛。出兴于世。其最初佛。号不可坏自在幢王。彼世界中。一阎浮提有一王都。名庄严幢。王名宝焰眼光。第一夫人。名善喜光。如此世界摩耶夫人为卢舍那佛母。彼世界中善喜光夫人。为最初如来母。亦复如是。善喜光夫人生菩萨时。与二百万那由他诸采女众。诣金色园林。攀宝树枝。生彼如来。时有乳母。名离垢光。诸天王等。以杂香汤洗浴太子。抱授乳母。乳母敬受欢喜无量。即得菩萨普眼境界三昧。得三昧已。见十方佛无所障碍。复得菩萨受生自在法门。佛子。譬如初受胎识速疾无碍。得此法门。知一切佛受生自在。亦复如是。佛子。于意云何。彼乳母者。岂异人乎。我身是也。我从是来。念念常见菩萨受生自在法海。卢舍那佛教化众生自在神力。佛子。我念念中。悉得三千大千世界微尘等净智慧眼。常见一切世界微尘等刹及彼诸佛。知彼如来自在受生。又复了知卢舍那佛初发大愿。乃至悉知十方诸佛初发大愿。亦复如是。亦恭敬供养彼诸如来。彼佛说法我悉得闻受持修行。时彼林天。承佛神力观察十方。欲重明此一切境界菩萨受生自在法门义故。以偈颂曰

  佛子汝所问　　最胜寂灭境
  一心善谛听　　我今说因缘
  过亿刹尘劫　　劫名可悦乐
  八十那由他　　如来出兴世
  最初如来名　　无坏自在幢
  我时见彼佛　　金色林中生
  乳母离垢光　　今则我身是
  太子金色身　　天王抱授我
  敬受无上人　　观察不见顶
  圆体难思议　　视之无厌足
  离垢清净身　　相好自庄严
  我见妙宝像　　欢喜心无量
  思惟难思议　　长养功德海
  见彼自在力　　我发菩提心
  专求佛功德　　具足诸愿海
  严净诸世界　　远离三恶道
  于诸世界中　　供养一切佛
  专求大愿海　　除灭众生苦
  闻彼初佛法　　成就此法门
  我于亿刹尘　　一切诸劫中
  修习菩萨行　　严净此法门
  彼劫中诸佛　　我已悉供养
  守护其正法　　净修法门海
  亿刹尘等劫　　诸佛出兴世
  持彼正法轮　　修难议法门
  一念悉了知　　一切刹微尘
  一一微尘中　　见无量刹海
  彼佛初生时　　显现自在力
  我于一念中　　皆悉分别见
  不可思议刹　　见彼诸菩萨
  或处兜率天　　专求佛菩提
  无量刹海中　　见彼生自在
  无量众围绕　　而为其说法
  一念中悉见　　无量诸刹海
  一切诸菩萨　　出家诣道场
  不可思议刹　　得成最正觉
  显现诸方便　　除灭众生苦
  一一微尘中　　转无尽法轮
  无尽妙音海　　普雨甘露法
  念念中悉见　　一一微尘中
  亿刹尘等佛　　示现般涅槃
  见无量刹海　　如来初受生
  一一诸佛所　　无量身供养
  不思议刹海　　无量诸群生
  我以诸方便　　为说甘露法
  佛子我知此　　不思议法门
  无量诸劫数　　称赞不可尽

佛子。我唯知此菩萨受生自在法门。诸大菩萨。能以诸劫为一念藏。显现一切诸妙方便。供养诸佛满足大愿。觉了一切诸佛正法。示现一切诸趣受生。生诸佛所教化众生未曾失时。为众生现受生自在。于诸佛刹现自在云。常生一切诸如来家。我当云何能知能说彼诸功德。佛子。迦毗罗城有释迦女。名曰瞿夷。汝诣彼问。云何菩萨游生死中教化众生。时善财童子。头面敬礼彼林天足。绕毕辞退

向于彼城。正念思惟增惟广明净菩萨受生自在法门。渐渐游行。至菩萨会庄严讲堂离忧妙德天所。尔时彼天。一万诸天以为眷属。来迎善财。白言。善来大智慧人。修不思议菩萨法门。以净直心满足大愿。广菩萨行向正法城。究竟菩萨无量方便。我观仁者。勇猛精进。修菩萨道心无懈倦。威仪庠序诸根调伏。不久必当逮得无上清净庄严佛身口意。相好严身。十力智慧庄严其心。游行十方教化众生。我观仁者。修行勇猛精进力故。必当得见三世诸佛。受诸如来一切法云。修习菩萨禅定法门寂灭之法。入于甚深如来法门。何以故。诣善知识亲近供养。正念思惟善知识教。无有退转疲倦之心。除灭障碍。降伏诸魔。无能坏者。令一切众生得欢喜故。善财答言如天所说。我愿如是。欲令一切众生欢喜。除灭烦恼诸不善法。具足善法得安隐乐。一切众生。以众恶业烦恼结故。入三恶道受无量苦。菩萨见已起忧悲心。譬如有人。唯有一子。爱念情重。忽有人来。割截其身肢节手足慈父见已悼恻悲念。菩萨若见众生造恶业缘烦恼结故入三恶道受无量苦。见如是已痛心悲念。亦复如是。菩萨若见众生具身口意诸善业故。生天人中受身心乐。见如是已欢乐无量。何以故。菩萨摩诃萨。不自为故求萨婆若。不贪生死五欲快乐。不随心想诸见颠倒结使缠缚贪爱邪见。不着众生种种乐想。不着禅味。不为结碍流转生死。菩萨但见诸有海中。一切众生受无量苦。发大悲愿而摄取之。常以大悲大愿力故。行菩萨行。供养诸佛求萨婆若。欲令众生远离烦恼。净佛世界。调伏一切恶心众生。悉令具足清净身心。行菩萨行而无疲倦。若有菩萨如是行者。悉能庄严一切众生。出生长养天人乐故。为父母皆令安立菩提心故。为养育。皆令究竟菩萨道故。为卫护。皆令远离三恶道故。为大船师。皆令得度生死海故。为归依。令舍诸魔烦恼怖故。为导师。皆令逮得清凉处故。为知济。皆令得度佛刹海故。为主藏臣。皆令得入法宝洲故。为净妙华。令开一切佛功德华故。为大光明。普放功德智慧光故。为欢喜。皆令端严胜殊妙故。为所尊。远离一切诸恶业故。为普贤具足一切诸功德故。为灯明。常放智慧净妙光故。为庆云。常雨一切甘露法故。天神。菩萨摩诃萨。如是行者。一切众生。悉皆爱念乐正法故。尔时善财。将升法堂。彼离忧妙德天与百万眷属。各各赍持妙香华鬘及诸杂宝。散善财上。以偈颂曰

  无量无数劫　　世灯或出现
  普为众生故　　正求佛菩提
  无量亿诸劫　　难见难值遇
  功德日今出　　照除世间闇
  见诸众生类　　愚惑痴所覆
  广发大悲心　　专求无师道
  清净正直心　　不惜身寿命
  亲近善知识　　专求佛菩提
  一切无所依　　不着于世间
  离垢清净心　　无碍如虚空
  行诸菩萨行　　具满妙功德
  放大智慧光　　普照一切世
  不离于世间　　亦不着世间
  行世无障碍　　如风游虚空
  譬如大灾起　　一切无能灭
  勇猛精进火　　求道亦如是
  勇猛大精进　　一切莫能坏
  金刚慧师子　　游行无所畏
  一切法海中　　一切诸佛海
  亲近善知识　　速见彼诸佛

尔时离忧妙德天。偈赞叹已。恭敬法故俱升法堂。升法堂已。周遍推求彼释迦女。即见坐于宝莲华藏师子之座。八万四千众女围绕。皆是贵族王者之女。悉于过去彼菩萨所修行诸行。同彼菩萨一切善根。常以布施爱语摄取众生。求萨婆若利益一切。令诸众生同佛菩提。大悲为首。普念众生如一子想。修习大慈普覆一切。过去已曾于菩萨所。修不思议胜妙智慧。于阿耨多罗三藐三菩提得不退转。具足成满诸波罗蜜心无所著。直心智慧皆悉清净。求萨婆若。离障盖网。超出诸难。得净法身。行普贤行。长养菩萨一切诸力。成就圆满净智慧日。尔时善财。五体投地敬礼瞿夷。礼已合掌于一面住。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何行生死中而无所染。觉了一切诸法实相。超出声闻缘觉之地。住如来地。而不舍离菩萨所行。修菩萨行。不离佛地。超出世间。法身圆满。应世受生。普现种种诸方便身。知法无性。示现一切众生之身。解甚深法。以妙音声。而为说法知众生空。而能不舍化诸世间。知一切佛不生不灭。而能供养心无退转。知无业报。而行善业无有休息。尔时瞿夷。作如是言。善哉善哉。善男子。能问诸菩萨摩诃萨所行之法。修习普贤诸行愿者。能如是问。谛听谛听。善思念之。我当承佛神力为汝解说。善男子。若有菩萨。成就十法。则能满足因陀罗网普智光明菩萨之行。何等为十。所谓依善知识。广发无量诸弘誓愿。修净胜妙。正直希望。集一切智功德。闻佛出世欢喜无量。心常乐住三世佛所。随顺一切诸大菩萨。悉为一切佛所护持。清净大悲远离生死。是为十法。若有菩萨。成就此法。则能满足因陀罗网普智光明菩萨之行。佛子。若诸菩萨。勇猛精进心无退转。出生修习佛无尽法。值善知识故。佛子。菩萨有十法。值善知识。何等为十。所谓不惜身命。不求世乐。知诸法相。而不舍离一切智愿。观察法界。离三有海。无所依住。深入一切菩萨诸愿。普照一切诸佛世界。净修菩萨圆满智慧。是为十法值善知识。尔时瞿夷。承佛神力观察十方。欲重明此义。以偈颂曰

  无谄于知识　　智慧广无量
  专求佛菩提　　利益诸众生
  恭敬善知识　　其心如佛想
  勇猛精进力　　具因陀网行
  解脱心增广　　其量均虚空
  摄取于三世　　佛刹及众生
  直心如虚空　　远离烦恼垢
  出生佛功德　　是为身云行
  不思议智慧　　积集功德海
  清净福业藏　　不染于世间
  一切诸佛所　　闻法无厌足
  智慧灯普照　　是为照世行
  一念皆能诣　　十方刹海佛
  闻法分别知　　是为随顺行
  见佛眷属海　　究竟三昧海
  满足诸大愿　　是因陀网行
  未来劫修行　　诸佛所护念
  普照诸世界　　是为法光行
  大悲见众生　　智日出世间
  法光除痴闇　　是为智日行
  见诸趣众生　　回流生死中
  为转净法轮　　是为普贤行
  智慧身无量　　随应而示现
  普于一切趣　　度脱诸群生
  发起大慈悲　　普覆于一切
  遍照诸群生　　令得佛菩提

善男子。我已成就分别观察一切菩萨三昧海法门。善财白言。大圣。此法门者境界云何。答言。善男子。我入是法门。知此娑婆世界众生佛刹微尘等劫中。死此生彼。作善恶业受诸果报。在生死道出生死者。正定邪定及不定聚。有使善根。无使善根。具足善根。不具足善根。不善善根。善根摄不善根。不善根摄善根。善根所起。不善根所起。一切善恶皆悉了知。彼诸劫中。佛兴于世。我悉了知。知彼诸佛初发道心。行菩萨行。出生一切诸大愿海。知彼供养一切诸佛。具菩萨行。成等正觉转正法轮。现自在力化度众生。知彼眷属。声闻缘觉之所修行。过去修习一切善根。得明净智。成就寂灭自在法门。显现种种自在神力。教化众生而般涅槃。知彼眷属诸菩萨众。初发道心修习善根。出生种种诸大愿行。成就满足诸波罗蜜。种种庄严菩萨之道。菩萨诸地自在之力。菩萨诸地住。分别修习诸菩萨地。净菩萨地。修菩萨地。菩萨诸地相。菩萨诸地智。菩萨诸摄智。菩萨善巧方便教化众生。菩萨诸住。菩萨圆满净行。菩萨自在行。菩萨三昧海。菩萨方便。于念念中。悉知菩萨诸三昧海。一切种智电光法云。得诸法忍。尽一切智底。知彼菩萨诸佛刹海。究竟法海。知众生海。修习一切菩萨法门。满足大愿。显现种种自在神力。如是等事我悉了知。如此娑婆世界。知十方世界。世界性。世界海。世界轮。世界圆满。世界分别。世界旋。世界转。世界莲华。世界须弥。世界相中事。亦复如是。卢舍那佛本愿力故。我悉深入分别念知。何以故。此法门者。悉知一切众生心海。知一切众生积集善根。知一切众生有垢有净。知一切众生性。知一切声闻三昧自在法门。知一切缘觉菩萨诸佛三昧自在法门。如是等事悉分别知。善财白言。大圣。发阿耨多罗三藐三菩提心来。其已久如。答言。佛子。乃往古世。过世界微尘等劫。有劫名胜光明。时有世界。名离恐怖。彼世界中有四天下。彼阎浮提中有一王都。名妙德树须弥山。于八十王都。最为殊胜。彼有王。名一切宝主。有六万采女。五百大臣。五百王子。端正勇健摧伏怨敌。其王太子名增上功德主。颜貌殊胜相好严身。与万采女俱。持妙幢盖。散众宝华。作诸妓乐。乘妙宝车。诣香芽山。游戏园林。时彼道路坦然平正。种种庄严。散众妙华。宝树行列。众妙宝帐以覆其上。于彼路侧。积众宝聚杂种宝衣。诸庄严具肴膳饮食。如是等事随其所须皆给施之。时有母人。名曰善现。将一童女。名离垢妙德。端严姝妙修短得所。颜容无伦。目发绀色。唇齿丹素。口出梵音。才能巧妙。言语聪辩。修习慈心见者无厌。少贪恚痴常怀惭愧心无谄曲。乘妙宝车采女围绕。从母游观。先太子前至香芽园。太子见已。生染爱心。语其母言。欲娉贤女以为我妻。母语女言。太子今欲求汝为妃。于意云何。女白母言。若欲使我为彼妃者。当自殒灭。母报女曰。勿作此言。所以者何。今此太子。悉已具足转轮王相。必为圣主。有玉女宝。汝当尔时不堪给使。此处尊胜莫生难心。时彼园外有一道场。名法云光。有胜日光如来应供等正觉。出兴于世。于彼道场成无上道。时女梦见彼如来身。于梦觉已。空中有天而告之曰。汝梦所见是胜日光佛。成道已来始经七日。今在道场。无量菩萨大众围绕。彼佛众会一切天龙八部鬼神。乃至无量净居诸天。地神。风神。海神。火神。山神。树神。丛林药草城郭等神。皆悉云集。奉觐世尊听受正法。时彼女人闻是语已。诣太子所合掌而立。以偈白言

  我色世间最　　智慧无伦匹
  才妙善言论　　观者无厌足
  太子应当知　　我心善贞洁
  志尚心端直　　清净无所染
  远离于嗔恚　　贪欲及愚痴
  以真净直心　　饶益诸群生
  我见太子身　　相好自庄严
  见已喜无量　　诸根悉调伏
  妙体犹净金　　发美绀青色
  额广目明彻　　必为自在王
  其身逾金山　　相好自严饰
  我今太子所　　合掌恭敬住
  其目净修广　　方臆如师子
  观者无厌足　　妙音应纳我
  舌相广长妙　　犹如赤铜色
  演出梵音声　　闻者踊跃喜
  口方牙深固　　齿白而齐密
  若有睹见者　　一切皆欢喜
  离垢清净身　　具相三十二
  成就此妙相　　必为转轮王

尔时太子。语彼女言。汝是谁女。为谁守护。若先属他。我则不宜起染爱心。尔时太子。说偈问言

  清净功德身　　见者无厌足
  谁为汝父母　　为谁所守护
  若先有所属　　我不起欲想
  非分生淫心　　命终堕恶道
  不应为豪贵　　种种富乐故
  发起如是等　　放逸贪乱心
  种种生邪见　　幻诳诸谄伪
  如是造诸恶　　流转于世间
  父母知识所　　应起恭敬心
  慈悲广覆护　　一切诸群萌
  若于一切处　　所从闻法者
  能生诸善故　　应起恭敬心
  一切诸导师　　正法菩萨众
  圣僧功德海　　皆悉应恭敬
  修习诸功德　　远离一切恶
  安住于正法　　广行菩萨道
  若无归依者　　应起大慈心
  诸在三恶道　　应发大悲念
  一切诸法界　　有成必有败
  舍心平等观　　莫随烦恼魔
  应发菩提心　　觉悟诸群生
  无量劫修行　　不起疲倦想

时彼女母。说偈白言

  唯愿太子听　　此女从生来
  乃至今长成　　一切诸因缘
  太子所生日　　女从莲华生
  其目净修广　　肢节悉具足
  我曾于春月　　游观娑罗园
  睹见诸卉木　　种种华荣茂
  同游八百女　　容仪悉端严
  皆已具足知　　诸巧技能法
  彼园有浴池　　名曰众庄严
  我于池岸坐　　采女众围绕
  时彼浴池中　　千叶莲华生
  宝叶琉璃茎　　阎浮檀金台
  众妙宝香须　　普放净光明
  遍照阎浮提　　犹若日初出
  时见此玉女　　从彼莲华生
  睹者皆念言　　此则善业报
  目发绀青色　　其身如紫金
  众宝以庄严　　观者心无厌
  离垢净无秽　　肢节悉具足
  犹如真金像　　安处宝莲华
  毛孔栴檀香　　普熏于一切
  口出莲华香　　演妙梵音声
  此是玉女宝　　世间所希有
  身相悉具足　　种种妙庄严
  一切诸技术　　世间言论法
  究竟悉缕练　　愿为哀纳受
  此是玉女宝　　身分悉圆满
  功德具庄严　　宿行之所得
  善知众生病　　起患之所由
  又知对治法　　除灭众疑惑
  一切阎浮提　　众生语言法
  种种妓乐音　　无不善通达
  此女修功德　　远离女人法
  能转众生心　　唯愿哀纳受
  舍离嫉妒心　　不醉于五欲
  不起嗔恚心　　修习忍智慧
  精进持净戒　　能辨一切事
  专求诸功德　　太子愿纳受
  若见诸贫穷　　老病众苦逼
  无所归依者　　大悲普慈念
  常欲利众生　　不求自安乐
  功德庄严身　　饶益于一切
  于诸威仪中　　常修不放逸
  修习诸善法　　见者无不悦
  功德普庄严　　远离染污心
  常求善知识　　恭敬乐供养
  修习大慈法　　弃舍怨结心
  智慧无与等　　唯愿哀纳受

尔时太子答言。善女。我已先发阿耨多罗三藐三菩提心。欲无量劫行菩萨行。积集一切功德智慧。净修一切诸波罗蜜。恭敬供养一切诸佛。护持正法。严净一切诸佛世界。令如来种相续不断。教化众生。灭生死苦住究竟乐。欲令众生净智慧眼。住菩萨道修菩萨行。具足一切菩萨诸地。令一切众生心大欢喜。我当尽未来劫。行檀波罗蜜。悉舍一切国城妻子。肢节手足。头目髓脑。或在家布施出家修道。汝于尔时。莫作障碍坏我道心。尔时太子。重为彼女而说偈言

  哀愍众生故　　我发菩提心
  无量无数劫　　积集智功德
  无量劫海中　　修习诸大愿
  广修菩萨行　　具足一切地
  三世诸佛所　　学六波罗蜜
  闻法能修行　　专求菩萨道
  十方垢浊刹　　我悉令严净
  除灭诸群生　　三恶道苦患
  以诸方便力　　广度一切众
  除灭愚痴闇　　住一切智道
  供养诸佛海　　净修一切地
  发起大慈悲　　内外一切舍
  若我施来求　　妻子诸眷属
  在家及出家　　汝莫作障碍
  若能如是者　　我则纳受汝

时女答言。敬从来教。乃至出家不敢有碍。即说偈言

  一切劫海中　　地狱火烧身
  若能眷纳我　　甘心受此苦
  一切生死身　　碎末如微尘
  若能眷纳我　　甘心受此苦
  无量劫顶戴　　一切金刚山
  若能眷纳我　　甘心受此苦
  一切生死海　　以我施无悔
  若得法王处　　愿令我亦然
  无量无数劫　　修行菩萨道
  有来求我者　　欢喜愿施与
  太子见众苦　　发起菩提心
  无量大慈悲　　摄众生及我
  我不求豪富　　不贪五欲乐
  但愿共行法　　而为太子妻
  修广明净眼　　慈愍观众生
  不起染污心　　必成菩提道
  太子游行时　　地出众宝华
  此相无有疑　　必为转轮王
  我昔于梦见　　正觉胜日光
  菩提树下坐　　大众悉围绕
  梦中见彼佛　　以手摩我顶
  觉已大欢喜　　踊跃无有量
  空中时有天　　名曰清净身
  彼天为我说　　道场佛兴世
  我发如是念　　若见太子者
  当为分别说　　胜日光佛兴
  我昔所志愿　　于今悉成满
  唯愿俱往诣　　供养彼如来

尔时太子。闻彼如来出兴于世。心大欢喜踊跃无量。欲见彼佛。以五百宝散彼女人。又与妙德光藏净周罗宝并妙衣服。时彼女母。即为太子。而说偈言

  今此玉女宝　　功德庄严身
  我昔所志乐　　此愿今成满
  持戒不放逸　　智慧诸功德
  普于一切世　　最胜无伦匹
  此女莲华生　　种姓无讥嫌
  远离诸不善　　太子同志愿
  此女身柔软　　犹如天缯纩
  蒙彼手摩者　　众患悉除灭
  毛孔所出香　　芬馨无伦比
  众生若闻者　　悉住于净戒
  其身净无垢　　譬如真金像
  若有睹见者　　离害具慈心
  口出微妙音　　无不乐闻者
  若有听斯音　　远离诸恶业
  心净无瑕秽　　质直无谄曲
  随其所闻法　　如说能修行
  恭敬善知识　　及所尊重者
  远离贪欲心　　专求于正法
  此女心不恃　　妙色莲花生
  世间诸荣乐　　唯求无上道

时彼太子。与此女俱。并一万采女。出香芽园。各乘宝车。往诣道场。下车步进。遥见如来相好严身。其心澄净如镜渊渟。诸根调伏犹如象王。心大欢喜踊跃无量。与采女众。往诣佛所头面礼足。恭敬供养绕无数匝。各持五百众妙宝华。供散彼佛。为彼如来。兴立五百众香楼阁杂宝严饰。时彼如来。为说普门灯明修多罗。闻说经已。于一切法中得三昧海。所谓诸佛愿海三昧。普照三世光藏三昧。对见一切诸佛三昧。普照一切众生三昧。普照世界海净智灯光明三昧。普照众生根海智光明三昧。救护众生光云三昧。教化众生现前智灯明三昧。闻持诸佛法轮三昧。具普贤行净云三昧。于一切法中。得如是等诸三昧海。时彼玉女。于诸法中。得不可坏寂静法门。于阿耨多罗三藐三菩提得不退转。时彼太子。与诸眷属礼彼如来。绕无数匝辞退还宫。诣父王所头面敬礼。白言大王。彼道场上。胜日光佛始成正觉。王问太子。从谁闻乎。答言。从彼离垢妙德女闻。时王闻已欢喜无量。犹如贫人得大宝藏。作如是念。佛无上宝难值难遇。能灭众生恶道贫苦。为无上医善对治法。除灭众生诸烦恼患。为善导师。于生死海济度众生置涅槃处。作是念已召诸小王及诸群臣。并婆罗门刹利居士。皆悉集会。而告之曰。我闻太子无上吉语云。胜日光佛出兴于世。我闻是已欢喜无量。无以酬报。今舍王位授与太子。王舍位已与诸眷属。往诣道场胜日光佛所。头面礼足退坐一面

尔时如来。观察彼王及诸眷属。白毫相中放大光明。名曰一切众生心灯。普照十方无量世界一切诸王。显现如来不可思议自在神力。应受化者令彼心净。具足不可思议功德。超出世间。其身清净。以微妙音。为大众说离痴曀法真实灯陀罗尼门。佛刹微尘等陀罗尼以为眷属。彼王闻已。即得广大智慧光明。阎浮提微尘等菩萨得此陀罗尼。六十那由他人得诸漏尽。一万众生皆得离垢清净法眼。无量众生悉发阿耨多罗三藐三菩提心。又以不可思议自在神力。于十方刹以三乘法化度众生。尔时彼王。作如是念。此诸功德。若不出家则不能辨。我今应当于如来所出家修道。前白佛言。今从世尊出家学道。佛答王言。宜知是时。时王即与一万眷属出家修道。皆得离痴曀法真实灯陀罗尼门及世界微尘等陀罗尼。又得菩萨十明及无量辩。净无碍身诣诸佛所。悉闻受持佛正法轮。为大法师。以神通力遍诸世界。随所应化为彼现身。赞叹佛法并诸过去菩萨所行菩萨本生。又赞叹佛无量无边自在神力。守护正法

尔时太子。月十五日王得道时。于其正殿采女围绕。七宝自至。一金轮宝。名胜自在。二象宝。名曰青山。三绀马宝。名勇疾风。四神珠宝。名光藏云。五主藏臣宝。名曰大财。六玉女宝。名净妙德。七主兵臣宝。名离垢眼。得是七宝。于阎浮提作转轮王。时有千子。端正勇猛能伏怨敌。时彼人民炽盛丰乐自在。八万王城。城各建立五百楼阁。大僧伽蓝众宝庄严。一一僧伽蓝。起广大塔。一切众宝以为庄严。香华缯盖而供养之。一一王城。次第请佛。以不思议众妙供具。供养如来。时佛入城。无量众生皆大欢喜。长养善根发菩提心。以广大悲饶益众生。正求佛法知真实义。平等观察三世诸法。明净智慧普照三世。知三世佛次第出世。摄取众生向菩萨道。行菩萨行。安住菩萨平等正法。逮得如来法轮智光。深入法海。能于己身见一切刹。善知诸根弘誓愿海。得一切智。尔时如来。次第受彼诸王请时。如是饶益无量众生。佛子。尔时太子增上功德主。岂异人乎。今释迦牟尼佛是也。尔时王宝主。宝华佛是也。宝华如来。今在东方过世界海微尘等世界海。有一世界海。名法界虚空光云。中有世界。名佛圆满光妙德灯。彼有道场。名曰一切天王光幢。彼佛始成正觉。与不可说佛刹微尘等菩萨大众围绕说法。彼宝华佛为菩萨时。净彼刹海。彼刹海中。三世诸佛出兴世者。皆宝华佛为菩萨时。教化令发阿耨多罗三藐三菩提心。尔时女母善现者。今我母善目是也。王眷属者。彼如来所大众是也。皆悉具足普贤诸行。成就大愿。清净法身普照世间。其心无坏。逮得菩萨诸三昧门。以清净眼。皆悉对见一切诸佛一切如来。以虚空等妙音声云。转正法轮。悉闻受持。于诸法中得自在力。出入息顷。遍游一切诸佛世界。以微妙音为众生说法。而未曾离一切佛所。尽未来劫修菩萨行。随所应化悉为现身。尔时离垢妙德宝女。共增上功德主转轮王。四事供养。胜日光佛者。我身是也。彼佛灭度后。其世界中。有六十百千亿那由他佛出兴于世。其最初佛号明净身。次名净明月普照智。次名智观幢。次名广智光明王。次名精进金刚那罗延。次名不坏智。次名智普缘。次名净德智云。次名师子智光。次名周罗光明。次名功德光幢。次名智日幢。次名开宝莲华身。次名功德光。次名智光云。次名普明净月。次名庄严盖妙音。次名师子勇猛智照。次名法界慧月。次名觉众生心虚空电光。次名善鼻妙香。次名寂灭响。次名甘露山。次名法海雷音。次名无坏智音。次名觉空电光周罗。次名月光白毫相云。次名圆面净慧。次名善觉智华光。次名宝焰山妙德王。次名广德夜光。次名妙宝月幢。次名具三昧身。次名胜宝光王。次名现普智光。次名焰海门灯。次名离垢妙音王。次名无等功德。次名胜幢。次名修臂。次名本愿净月。次名真实智灯。次名法上妙音。次名明净妙德藏王。次名乘幢。次名法海莲华。佛子。彼一劫中。如是次第。六十百千亿那由他佛。出兴于世。我悉亲近恭敬供养。其最后佛。名广解脱光。于彼佛所得净智眼。佛子。尔时彼佛初成正觉。入城教化。我时为王夫人。与彼大王恭敬供养。闻彼佛说如来性起灯修多罗。闻已得净智眼。又得观察菩萨三昧海法门。佛子。我得此法门已。于世界微尘等劫。受持修习。是诸劫中。值无量佛出兴于世。我悉恭敬供养。佛子。我或一劫。值一如来出兴于世。恭敬供养。或二或三。或不可说。或于一劫。值世界微尘等佛出兴于世。我悉恭敬供养。而未能知诸大菩萨身量像貌。及其身业心行智慧三昧境界。佛子。我若见修菩萨行者。欢喜无量恭敬供养。以诸方便而摄取之。令于阿耨多罗三藐三菩提得不退转。佛子。我于世界微尘等劫。值遇诸佛恭敬供养。彼佛说法悉闻受持。时彼诸佛。各以种种修多罗。为我说此法门。我闻是已。悉于三世佛刹海中诸如来所佛眷属所。修此法门。又行菩萨行。菩萨大愿海。种种法门中。修此法门。犹未能知普贤菩萨所行法门。何以故。佛子。普贤法门犹如虚空。无量无边。又如众生。及三世海。十方刹海。及诸法界。无量无边。佛子。普贤菩萨法门。与诸佛身境界齐等。我于世界微尘等劫。观菩萨身心无厌足。何以故。我于菩萨一一毛孔中。念念悉见无量无边庄严世界。佛坐道场成等正觉。于大众中。以微妙音转正法轮。说种种修多罗。种种诸乘。种种清净。复次佛子。我于菩萨一一毛孔中。念念悉见诸众生海。各有所住。及其境界诸根不同。于三世中发菩提心。行菩萨行具大愿海。净诸菩萨无量无边波罗蜜海。及诸菩萨本生之海。无量无边大慈悲海。摄取众生悉令欢喜。乃至悉见一切菩萨。现处中宫采女围绕。佛子。我于菩萨一一毛孔中。皆悉睹见如是等事。佛子。我唯知此法门。诸大菩萨。皆悉究竟诸方便海。显现一切众生等身。随顺世间。于一切毛孔。普放一切相海光明。了法无性。诸众生类等如虚空。一切至处皆悉如如。显现神变。于诸法界得自在力。游戏普门。一切诸地法门海中。我当云何能知能说彼功德行。尔时瞿夷。语善财言。善男子。此迦毗罗城摩耶夫人汝诣彼问。云何菩萨修习诸行。不染世法。供养诸佛。于菩萨行得不退转。除灭障碍。不由他悟入诸法门。常能应现一切佛所。摄取众生。尽未来劫修菩萨行而不退转。究竟满足大乘诸愿。长养一切众生善根。尔时瞿夷。承佛神力。欲重明此义。以偈颂曰

  我见乐修行　　菩萨诸行者
  欢喜心无量　　皆悉摄取之
  乃昔久远世　　过百刹尘劫
  有劫名清净　　世界名光明
  尔时彼劫中　　六十百千亿
  那由他诸佛　　出兴于世间
  最后等正觉　　号为法幢灯
  彼佛灭度后　　有王名智山
  以大自在力　　王领阎浮提
  悉能广降伏　　一切诸怨敌
  王子有五百　　端正身姝妙
  其体净圆满　　见者无厌足
  深信诸佛法　　恭敬而供养
  守护正法藏　　受持乐修习
  彼王有太子　　名曰善光明
  三十相严身　　饶益诸群生
  五百亿人俱　　出家行学道
  勇猛精进力　　护持彼佛法
  王都名智树　　一亿城围绕
  有林名静德　　众宝树庄严
  善光住此林　　广说佛正法
  辩才无穷尽　　令众悉清净
  或为乞食故　　入彼王都城
  庠序有威仪　　见者莫不欣
  游步如师子　　志意常安谛
  诸根悉调伏　　念慧现在前
  尔时有长者　　名曰欢喜幢
  我为长者女　　名曰随顺光
  时我于城中　　遇见善光明
  相好庄严身　　欢喜心无量
  次乞至我门　　我以染心施
  摩尼庄严具　　投彼善光钵
  虽以染爱心　　供养彼佛子
  二百五十劫　　不经三恶道
  常于天人中　　尊贵王家生
  恒见善光明　　妙相庄严身
  于后所过劫　　二百有五十
  善现女家生　　名离垢妙德
  我见胜自在　　发起供养心
  不惜身寿命　　随其所施与
  时与太子俱　　觐佛胜日光
  欢喜心无量　　发起菩提心
  彼劫最后佛　　名广解脱光
  出兴于世间　　我值悉供养
  从彼最后佛　　得净智慧眼
  了知诸法相　　除灭虚妄倒
  得观察菩萨　　三昧海法门
  一念悉睹见　　不可思议刹
  见彼诸佛刹　　或净或垢秽
  于净不贪乐　　于秽不憎恶
  普见诸世界　　如来坐道场
  一念见诸佛　　不思议光海
  亦见佛眷属　　一切三摩提
  一切诸法门　　皆悉无障碍
  又知彼业行　　随其所住地
  及诸大愿海　　一念悉了知
  我于菩萨身　　见诸菩萨等
  无量劫修行　　一切莫能测
  一一毛孔见　　阿僧祇劫刹
  风轮水火轮　　一切大地轮
  种种所依住　　世界形类相
  诸妙庄严具　　众生身差别
  又见世界海　　一切诸世界
  诸佛出兴世　　说法度众生
  我于无量劫　　修习菩萨行
  犹不知菩萨　　身业心智慧

时善财童子。头面敬礼彼瞿夷足。绕毕辞退

大方广佛华严经卷第五十六大方广佛华严经卷第五十七

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十四

尔时善财童子作如是念。我当云何见善知识。善知识者远离世间。住无所住不着诸入。超出障碍趣无碍道。具净法身善业化身。以明净智观诸世间。大愿成满。持佛法身。如意法身。非生灭身。非来去身。非虚实身。非聚散身。一切诸相即一相身。离边见身。无所著身。无穷尽身。灭众虚妄如电光身。如幻梦身。如镜像身。如净日身。充满一切诸方化身。于三世中无坏法身。非身之身。如是等身。一切世间所不能见。唯是普贤菩萨所见。彼善知识行无碍行。我当云何能见亲近。知其相貌闻法受持。作是念已。时有城天。名曰宝眼。眷属围绕在虚空中。为善财现妙庄严身。以天宝冠宝庄严具。供养善财。作如是言。善男子。应守护心城。离生死故。应庄严心城。得十力故。应净心城。远离悭嫉诸谄曲故。应灭炽然猛焰心城。诸禅三昧法门相续得自在故。应照心城。常以般若波罗蜜光。照如来海及眷属故。应长养心城。摄取诸佛方便道故。应坚固心城。出生普贤诸行愿故。应修心城。诸魔魔民及余怨敌莫能坏故。应明心城。得诸如来智光明故。应修无坏心城。能受如来正法云故。应具心城。己心悉受一切如来功德海故。应广心城。大慈普覆一切众生故。应盖心城。以法普覆障不善故。应进心城。无量大悲救一切众生故。应开心城门。正念一切三世佛故。应达心城。悉知诸佛转正法轮修多罗法门因缘起故。应知心城道。开示显现一切智道故。应持心城。具三世佛诸愿海故。应知心城力。长养法界功德力故。应放心城普照光明。知一切众生诸根欲性结业习气诸垢净故。应知心城自在力。摄取一切诸法界故。应莹心城。住佛念故。应知心城实相。了达诸法无实性故。应知心城如幻。入一切智正法城故。菩萨摩诃萨。若如是知诸心城者。则能积集一切善根。何以故。蠲除无量诸障碍故。所谓见佛障。闻法障。供养佛障。摄众生障。净佛刹障。佛子。菩萨摩诃萨。若有如是无障碍心。以少方便。能见一切诸善知识。究竟成就一切种智。尔时有天。名法妙德。在虚空中。妙声赞叹摩耶夫人。又放种种色光明网。广照无量诸佛世界。尔时善财。见光明网。照诸佛身绕一匝已。然后还来入善财顶充满其身。尔时善财。即得离垢净光明眼。除灭一切愚痴闇障。得离翳眼。了知一切众生实性。得离垢眼。观一切法性。得净慧眼。观一切刹性。得净光眼。见佛法身。得普明眼。观不思议如来色身。得无碍光眼。观察一切世界成败。得遍光眼。见一切佛转正法轮出生修多罗。得普境界眼。观察无量诸佛神力教化众生。得普见眼。观一切世界随因缘起诸佛兴世。时有守护菩萨法堂罗刹鬼王。名曰善眼。与妻子俱。一万罗刹眷属围绕。在虚空中散众妙华。语善财言。善男子。若有菩萨。成就十法。则能亲近诸善知识。何等为十。所谓直心清净远离谄曲。不坏大悲摄取众生。观察众生非真实性。于萨婆若心不退转。于佛大众得坚信力。以净慧眼观诸法性。无坏大悲普覆众生。明净慧光了诸法界。善对治法雨甘露云。除生死苦顺善知识。以明净眼观诸法性相续不断。菩萨成就此十法者。则能亲近诸善知识。复次佛子。菩萨成就十三昧门。则能睹见诸善知识。何等为十。所谓净法虚空圆满三昧。观察一切方海三昧。分别一切境界三昧。对见十方诸佛三昧。长养功德藏海三昧。念念不舍善知识三昧。现前见一切如来功德善知识三昧。诣善知识三昧。常得不离一切善知识三昧。恭敬供养善知识无过失三昧。善男子。菩萨成就此十三昧门。则能睹见诸善知识。又得诸善知识微妙音声。转正法轮三昧法门。若有菩萨。住此法门。悉知一切诸佛平等。常能睹见诸善知识。尔时善财答罗刹言。善哉善哉。以哀愍故。方便教我见善知识。愿为我说。云何往诣善知识所。于何方处城邑聚落。求善知识。答言。善男子。敬礼十方求善知识。正念思惟一切境界求善知识。勇猛自在遍游十方求善知识。知身知行。如梦如电。诣善知识。尔时善财随顺其教。即时睹见大宝莲华从地涌出。金刚为茎。摩尼为叶。净宝为台。众妙香须以阿僧祇摩尼宝网罗覆其上。莲华台上有一楼观。名曰摄取法界方藏。金刚为地。楼有千柱。一切摩尼众宝合成。种种庄严。悬阿僧祇妙宝璎珞阿僧祇宝以为栏楯。尔时善财。见楼观中。有摩尼宝师子之座。众宝庄饰杂宝栏楯。敷众妙衣。宝网覆上。建宝幢盖。于金铃中出妙音声。雨妙香华。诸宝铃中。出诸菩萨愿行音声。宝月幢中出佛化身。净摩尼中。显现如来次第受生。日摩尼中。放无量光照十方刹。摩尼宝王光明幢中。放一切佛圆满光明。明净宝中。出众供具一切众生灯佛正法云。如意宝中。念念出生普贤自在充满法界。须弥幢中。出天妙声赞叹如来。尔时善财。见此不可思议庄严高座。不可思议眷属围绕。见摩耶夫人处彼座上。端正姝妙。具净色身。出三世间色身。一切世间对现色身。远离一切有趣色身。随其所应教化色身。一切众生不染色身。起广大色身。与一切众生等色身。一切众生无等色身。一切众生见不虚色身。种种色身。随所应化显现色身。无量形像色身。普门形像色身。一切众生对现色身。广大自在门庄严色身。教化一切众生色身。一切众生对现垂形色身。一切时现种种不坏色身。一切众生究竟不究竟住持色身。不去色身。于一切趣无所灭故。不来色身。于一切趣无所生故。不起色身。不起不现故。不灭色身。离一切世间语言道故。不虚色身。随所得故。不欺色身。随应世间故。无所至色身。不生不死故。不坏色身。法性无坏故。无相色身。三世语言断故。一相色身。无相善说相故。如电色身。随应一切众生心故。如幻色身。智幻满故。如焰色身。持众生想故。如影色身。一切众生本愿相续不断故。如梦色身。随应众生不可坏故。究竟法界色身。净如虚空故。现大悲色身。成就一切众生故。显现无碍门色身。于念念中满法界故。无量无边色身。净一切世门离语言道故。无所依色身。教化众生究竟愿故。住持色身。能辨一切众生事故。不生色身。幻愿满故。无比色身。出世间故。随应色身。随应度故。不杂色身。随业相续故。如意珠色身。满足一切众生愿故。离虚妄色身。一切众生虚妄起故。离觉观色身。一切众生不能思察故。不究竟色身。除灭生死故。清净色身。离如来觉观故。如是色非色。色如电故。受非受。除灭世间苦受故。离一切想。分别一切众生想故。出生行非行。诸业如幻故。离识境界。满足菩萨智慧愿故。空无所有。一切众生语言断故。色身成就。妙色不灭故。尔时善财。见摩耶夫人随应众生。示现如是种种无量色身。众生或见过他化自在天王女身。乃至过四天王女身。或见过龙王女身。乃至过人王女身。尔时善财。见如是等种种色身。长养一切众生善根。行不可坏檀波罗蜜。大悲普念一切众生。出生如来无量功德。勇猛精进求萨婆若。知一切法皆寂灭相。入深忍海。具足一切无坏禅定。修习一切三昧境界。逮得如来圆满禅定。灭一切众生诸烦恼海。皆悉严净一切法界。分别了知诸佛法轮。以明净智观一切法海。见一切佛心无厌足。次第观察三世如来。开一切佛门。见三世佛次第兴世。净佛道戒。如如如空。摄一切众生。而教化之。得净法身。净一切佛刹诸大誓愿。究竟化度一切众生。一念充遍诸佛境界。出生菩萨自在神力。显现无量清净色身。降一切魔力。增长功德力。生善法力。得一切佛力。具菩萨力。生一切智力。如来智慧普照一切。悉知无量众生心海。了知众生诸根欲性。一身充满十方无量无边佛刹。悉分别知佛刹成败。开净智眼。见三世海诸佛法海。出生一切如来功德。知一切菩萨所修功德。从初发心乃至究竟。长养一切众生善根。于一切世间。赞叹一切诸佛功德。成满一切菩萨母愿。尔时善财。见摩耶夫人有如是等阎浮提微尘等未曾有事。即变化己身。悉与摩耶夫人身等。合掌礼敬五体投地。即得无量无边诸三昧门。正念修习分别观察。随顺出生印证。证已从三昧起。起已敬绕摩耶夫人及诸眷属。恭敬合掌于一面住。白言大圣。文殊师利菩萨。往昔教我发阿耨多罗三藐三菩提心。求善知识亲近供养。我已渐求至大圣所。愿为演说。云何菩萨学菩萨行修菩萨道。答言。佛子。我已成就大愿智幻法门。得此法门故。为卢舍那如来母。于此阎浮提迦毗罗城净饭王宫。从右胁生悉达太子。显现不可思议自在神力。善男子。菩萨。于兜率天命终时。一一毛孔放大光明。名一切如来受生圆满功德。显现不可说不可说佛刹微尘等菩萨受生庄严。普照一切世界。照已来触我顶。遍入我身一切毛孔。入已普见菩萨受生自在庄严。又见出家往诣道场成等正觉。菩萨天人大众围绕恭敬供养转正法轮。彼诸如来。于过去世行菩萨行。于诸佛所恭敬供养。发菩提心。净诸佛刹。无量化身充满法界。教化众生。乃至示现大般涅槃。如是等事皆悉睹见。又善男子。彼妙光明来入我身。我身尔时。超出世间与虚空等。亦不过人身。悉能容受十方菩萨庄严宫殿尔时菩萨。从兜率天降神下时。与十佛刹微尘等菩萨俱。皆悉同行。大愿善根庄严法门。智慧自在一切诸地。清净法身无量色身。究竟普贤诸大愿行。悉皆同等。如是菩萨眷属围绕。又与八万诸龙王俱。娑伽罗龙王等及诸夜叉八部神等恭敬供养。降神下时。放大光明普照世界。现自在力。除灭一切诸恶道苦。以巧方便。教化不可思议众生。皆悉令知宿世业行。令诸菩萨修不放逸无所染着。救护众生令悉睹见此菩萨身。现如是等诸奇特事。与大众俱来处我胎。彼诸菩萨。于我胎内游行自在。或以三千大千世界。以为一步。或不可说不可说佛刹微尘等世界。以为一步。又念念中。十方一切世界。一切佛所。不可说不可说菩萨眷属。及四天王忉利天王乃至梵王。如是等一切天王。皆入我胎。欲见菩萨恭敬供养听受正法。悉皆容受如是等众。而胎不广大。亦不迫迮。于此世界。示现如是神变受生。十方一切阎浮提中亦复如是。亦不分身。种种现化随其所应为菩萨母。何以故。修此大愿智幻法门故。善男子。我为卢舍那佛母。拘楼孙佛。拘那含牟尼佛。迦叶佛。弥勒佛。师子佛。法幢佛。善眼佛。净华佛。妙德华佛。提舍佛。弗沙佛。欢喜意佛。自在佛。离垢佛。明净月佛。执炬佛。乐静佛。金刚楯佛。清净义佛。阿私陀佛。度彼岸佛。高焰山佛。执灯佛。宝莲华佛。功德称佛。无量德持佛。妙德灯佛。庄严身佛。善威仪佛。妙德慈佛。善幢佛。智盛佛。无量音佛。无诤佛。散疑佛。清净佛。广光佛。速净佛。妙德云佛。庄严顶发佛。树王佛。庄严宝冠佛。智海佛。净宝佛。坚天冠佛。具诸愿佛。大自在佛。妙德王佛。胜妙德佛。栴檀云佛。广净眼佛。殊胜慧佛。修习智佛。高王佛。自在慧佛。离色佛。师子喜佛。无上王佛。妙德顶佛。金刚智山佛。妙德藏佛。宝网严身佛。善慧佛。自在天佛。大地天佛。无著功德佛。众牙佛。慧光佛。妙德天佛。无上坐佛。无上德佛。仙人伏根佛。随顺语佛。自在德幢佛。明净幢佛。分别支佛。毗舍佉佛。放一切众生香光明佛。金刚宝严佛。欢喜眼佛。灭欲尘佛。高大身佛。善天佛。无上天佛。向寂灭佛。觉智佛。离尘垢佛。光焰王佛。安住佛。毗舍佉天佛。金刚山佛。智焰盛妙德佛。安隐佛。优波提舍佛。具净德佛。乐贤德佛。第一义勇佛。百光焰佛。一增上佛。深音声佛。大地王佛。白净佛。山音声佛。殊胜佛。不可坏佛。无上医佛。功德月佛。不违逆佛。功德聚佛。月出佛。功德天佛。光明盛佛。娑罗阴佛。药王佛。胜宝佛。金刚慧佛。八十妙德佛。一切无坏佛。大名称王佛。勇进持佛。无量光佛。大庄严焰佛。法王不虚佛。不退地佛。明净天佛。苦行佛。净天佛。同意佛。解脱音佛。无坏王佛。灭谄伪佛。净薝卜光佛。善胜月佛。执明炬佛。庄严身佛。不可说佛。观众生佛。无量光佛。无畏音佛。最胜天佛。无畏智盛佛。妙德华佛。月光焰佛。不退慧佛。离爱佛。不着慧佛。长养德聚佛。灭恶道佛。无量化师子吼佛。义不退佛。见无碍佛。降众魔佛。不着相佛。离虚妄海佛。清净海佛。不可沮坏须弥山佛。无著智佛。无量坐佛。与魔战佛。随师行佛。无上调佛。常月佛。饶益王佛。不动阴佛。饶益名佛。饶益慧佛。寿持佛。寿名佛。满称佛。无坏盛佛。色明净佛。无相智佛。勇无动佛。难思妙德佛。同月行佛。无量身佛。随顺王佛。增寿天佛。佛子。如是等贤劫一切佛。于此世界成等正觉。我悉为母。亦于十方一切世界教化众生。尔时善财。白言大圣。得此法门其已久如。答言。佛子乃往古世。过不可思议非诸菩萨通明境界不可数劫。有劫名净光明。有世界。名曰妙德须弥山王。其土清净无诸垢秽。众宝合成种种严饰。见者无厌。彼世界中。有千亿四天下。诸四天下中。有一四天下。彼四天下中。有八十亿大王之都。彼王都中。有一王都名曰智幢。有转轮王名曰勇盛。彼王都北。有一道场名月光明。其道场神名慈妙德。时有菩萨名离垢幢。坐于道场临成正觉。时有恶魔名金刚光明。与眷属俱至菩萨所。坏其道行。时勇盛王。具足菩萨神力自在。化作兵众。多彼魔军而摧伏之。时彼菩萨得成正觉。时道场神见此事已。欢喜无量发如是愿。此转轮王乃至成佛。我为其母。善男子。我曾于彼道场。供养十那由他佛。善男子。彼道场神。岂异人乎。我身是也。转轮王者。卢舍那佛是也。善男子。我从尔时发愿已来。卢舍那佛。于一切有。行菩萨行教化众生。乃至最后受生。我常为母。复次善男子。现在过去十方无量无边诸佛。放大光明。来照我身宫殿住处者。彼最后生。我悉为母。善男子。我唯知此大愿智幻法门。诸大菩萨具大悲藏。教化众生心无厌足。得自在法。一一毛孔。现一切佛自在神力。我当云何能知能说彼功德行。尔时摩耶夫人告善财童子言。善男子。于此世界三十三天。有王名正念王。有童女。名天主光。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子敬受其教。头面作礼绕无数匝。恋慕瞻仰却行而退

遂往天宫见彼童女。礼足围绕合掌前住。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。天女答言。善男子。我得菩萨解脱。名无碍念清净庄严。善男子。我念过去。有最胜劫。名青莲华。我于彼劫中。供养恒河沙等诸佛如来。彼诸如来。从初出家。我皆瞻奉守护供养。造僧伽蓝营辨什物。又彼诸佛。从为菩萨住母胎时。诞生之时。行七步时。大师子吼时。住童子位在宫中时。向菩提树成正觉时。转正法轮现佛神变教化调伏众生之时。如是一切诸所作事。从初发心乃至法尽。我皆明忆无有遗余。常现在前念持不忘。又忆过去。劫名善地。我于彼供养十恒河沙等诸佛如来。又过去劫名为妙德。我于彼供养一佛世界微尘等诸佛如来。又劫名无所得。我于彼供养八十四亿百千那由他诸佛如来。又劫名善光。我于彼供养阎浮提微尘等诸佛如来。又劫名无量光。我于彼供养二十恒河沙等诸佛如来。又劫名精进德。我于彼供养一恒河沙等诸佛如来。又劫名善悲。我于彼供养八十恒河沙等诸佛如来。又劫名胜游。我于彼供养六十恒河沙等诸佛如来。又劫名妙月。我于彼供养七十恒河沙等诸佛如来。善男子。如是忆念恒河沙劫。我常不舍诸佛如来应正等觉。从彼一切诸如来所。闻此无碍念清净庄严菩萨解脱。受持修行恒不间断随顺趣入。如是先劫所有如来。从初菩萨乃至法尽。一切神变。我以净严解脱之力。皆随忆念明了现前。持而顺行曾无懈废。善男子。我唯知此无碍念清净解脱。如诸菩萨摩诃萨。出生死夜朗然明彻。永离痴冥未尝惛寐。心无诸盖身行轻安。于诸法性清净觉了。成就十力开悟群生。而我云何能知能说彼功德行。善男子。迦毗罗城有童子师。名曰遍友。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。以闻法故身心遍悦。不思议善根流派增广。头面敬礼天主光足。绕无数匝恋仰辞去

从天宫下渐向彼城。至遍友所礼足围绕。合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。遍友答言。善男子。此有童子。名善知众艺。学菩萨字智。汝可问之。当为汝说

尔时善财。即至其所。头顶礼敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。时彼童子告善财言。善男子。我得菩萨解脱名善知众艺。我恒唱持入此解脱根本之字。唱阿字时。入般若波罗蜜门。名菩萨威德各别境界。唱罗字时。入般若波罗蜜门。名平等一味最上无边。唱波字时。入般若波罗蜜门。名法界无异相。唱者字时。入般若波罗蜜门。名普轮断差别。唱多字时。入般若波罗蜜门。名得无依无上。唱逻字时。入般若波罗蜜门。名离依止无垢。唱荼(徒假反)字时。入般若波罗蜜门。名不退转之行。唱婆字时。入般若波罗蜜门。名金刚场。唱荼字时。入般若波罗蜜门。名曰普轮。唱沙字时。入般若波罗蜜门。名为海藏。唱他字时。入般若波罗蜜门。名普生安住。唱那字时。入般若波罗蜜门。名圆满光。唱那字时。入般若波罗蜜门。名差别积聚。唱史吒字时。入般若波罗蜜门。名普光明息诸烦恼。唱迦字时。入般若波罗蜜门。名差别一味。唱娑字时。入般若波罗蜜门。名霈然法雨。唱摩字时。入般若波罗蜜门。名大流湍激众峰齐峙。唱伽字时。入般若波罗蜜门。名普上安立。唱娑他字时。入般若波罗蜜门。名真如藏遍平等。唱社字时。入般若波罗蜜门。名入世间海清净。唱室者字时。入般若波罗蜜门。名一切诸佛正念庄严。唱拖字时。入般若波罗蜜门。名观察圆满法聚。唱奢字时。入般若波罗蜜门。名一切诸佛教授轮光。唱佉字时。入般若波罗蜜门。名净修因地现前智藏。唱叉字时。入般若波罗蜜门。名息诸业海藏蕴。唱娑多字时。入般若波罗蜜门。名蠲诸惑障开净光明。唱壤字时。入般若波罗蜜门。名作世间了悟因。唱颇字时。入般若波罗蜜门。名智慧轮断生死。唱婆字时。入般若波罗蜜门。名一切宫殿具足庄严。唱车字时。入般若波罗蜜门。名修行戒藏各别圆满。唱娑摩字时。入般若波罗蜜门。名随十方现见诸佛。唱诃娑字时。入般若波罗蜜门。名观察一切无缘众生方便摄受令生海藏。唱诃字时。入般若波罗蜜门。名修行趣入一切功德海。唱伽字时。入般若波罗蜜门。名持一切法云坚固海藏。唱吒字时。入般若波罗蜜门。名十方诸佛随愿现前。唱拏字时。入般若波罗蜜门。名不动字轮聚集诸亿字。唱娑颇字时。入般若波罗蜜门。名化众生究竟处。唱娑迦字时。入般若波罗蜜门。名诸地满足无著无碍解脱光明轮遍照。唱阇字时。入般若波罗蜜门。名宣说一切佛法境界。唱多娑字时。入般若波罗蜜门。名一切虚空法雷遍吼。唱佗(耻加反)字时。入般若波罗蜜门。名晓诸迷识无我明灯。唱陀字时。入般若波罗蜜门。名一切法轮出生之藏。善男子。我唱如是入诸解脱根本字时。此四十二般若波罗蜜门为首。入无量无数般若波罗蜜门。善男子。我唯知此善知众艺菩萨解脱。如诸菩萨摩诃萨能。于一切世出世间善巧之法。以智通达到于彼岸。殊方异艺咸综无遗。文字算数蕴其深解。医药咒术善疗众病。有诸众生。鬼魅所持怨憎咒诅。恶星变怪死尸奔逐。癫痫羸瘦种种诸疾。咸能救之使得痊愈。又善别知金玉珠贝珊瑚琉璃摩尼砗磲鸡萨罗等。一切宝藏出生之处。品类不同价直多少。村营乡邑大小都城。宫殿苑园岩泉薮泽。凡是一切人众所居。菩萨咸能随方摄护。又善观察天文地理。人相吉凶鸟兽音声。云霞气候。年谷丰俭国土安危。如是世间所有技艺。莫不该练尽其源本。又能分别出世之法。正名辩义观察体相。随顺修行智入其中。无疑无碍。无愚闇。无顽钝。无忧恼。无沉没。无不现证。而我云何能知能说彼功德行。善男子。此摩竭提国有一聚落。彼中有城。名婆呾那。有优婆夷号曰贤胜。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。头面敬礼众艺之足。绕无数匝恋仰辞去

向聚落城至贤胜所。礼足围绕合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。贤胜答言。善男子。我得菩萨法门。名无依处道场。既自开解复为人说。又得无尽三昧。非彼三昧法有尽无尽。以能出生一切智性眼无尽故。又能出生一切智性耳无尽故。又能出生一切智性鼻无尽故。又能出生一切智性舌无尽故。又能出生一切智性身无尽故。又能出生一切智性意无尽故。又能出生一切智性种种慧明无尽故。又能出生一切智性周遍神通无尽故。又能出生一切智性如海波涛无量功德皆无尽故。又能出生一切智性遍世间光无尽故。善男子。我唯知此无依处道场法门。如诸菩萨摩诃萨一切无著功德行。而我云何尽能知说。善男子。南方有城。名为沃田。彼有长者。名坚固解脱。汝可往问。云何菩萨学菩萨行修菩萨道。尔时善财。礼贤胜足绕无数匝。恋慕瞻仰辞退南行

到于彼城诣长者所。礼足围绕合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说长者答言。善男子。我得菩萨解脱。名无著清净念。我自得是解脱已来。法愿充满。于十方佛所无复希求。善男子。我唯知此净念解脱。如诸菩萨摩诃萨。获无所畏大师子吼。安住高广福慧之聚。而我云何能知能说彼功德行。善男子。即此城中有一长者。名为妙月。其长者宅常有光明。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。礼坚固足绕无数匝。辞退而行

向妙月所。礼足围绕合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。妙月答言。善男子。我得菩萨解脱。名净智光明。善男子。我唯知此智光解脱。如诸菩萨摩诃萨。证得无量解脱法门。而我云何能知能说彼功德行。善男子。于此南方。有城名出生。彼有长者名无胜军。汝诣彼问。云何菩萨学菩萨行修菩萨道。是时善财。礼妙月足。绕无数匝恋仰辞去

渐向彼城。至长者所。礼足围绕。合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无尽相。我以证此菩萨解脱。见无量佛得无尽藏。善男子。我唯知此无尽相解脱。如诸菩萨摩诃萨。得无限智无碍辩才。而我云何能知能说彼功德行。善男子。于此城南有一聚落。名之为法。彼聚落中有婆罗门。名尸毗最胜。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。礼无胜军足绕无数匝。恋仰辞去渐次南行

诣彼聚落见尸毗最胜。礼足围绕合掌恭敬于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。我闻圣者善能诱诲。愿为我说。婆罗门答言。善男子。我得菩萨法门。名诚愿语。过去现在未来菩萨。以是语故。乃至于阿耨多罗三藐三菩提无有退转。无已退无现退无当退。善男子。我以住于诚愿语故。随意所作莫不成满。善男子。我唯知此诚语法门。如诸菩萨摩诃萨。与诚愿语行止无违。言必以诚未曾虚妄。无量功德因之出生。而我云何能知能说。善男子。于此南方。有城名妙意华门。彼有童子。名曰德生。复有童女名为有德。汝诣彼问。云何菩萨学菩萨行修菩萨道。时善财童子。于法尊重。礼婆罗门足。绕无数匝恋仰而去

渐次南行至于彼城。见童子童女。顶礼其足。围绕毕已。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。唯愿慈哀为我宣说。时童子童女告善财言。善男子。我等证得菩萨解脱。名为幻住。以斯净智。观诸世间皆幻住。因缘生故。一切众生皆幻住。业烦恼所起故。一切法皆幻住。无明有爱等展转缘生故。一切三界皆幻住。颠倒智所生故。一切众生生灭生老死忧悲苦恼皆幻住。虚妄分别所生故。一切国土皆幻住。想倒心倒见倒无明所现故。一切声闻辟支佛皆幻住。智断分别所成故。一切菩萨皆幻住。能自调伏教化众生殊胜智心及诸行愿之所成故。一切菩萨众会变化调伏诸所施为皆幻住。愿及智所摄成故。善男子。幻境自性不可思议。善男子。我等二人但能知此菩萨解脱。如诸菩萨摩诃萨。善入无边诸事幻网。彼功德行我等云何能知能说。时童子童女。说自解脱已。诸善根力不思议故。令善财身柔软光泽。自说本愿

大方广佛华严经卷第五十七大方广佛华严经卷第五十八

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十五

又作是言。善男子。于此南方有一国土。名曰海涧。彼有园林。名大庄严藏。于彼林中有大楼观。名严净藏。菩萨往昔善根所起。菩萨诸愿自在诸通智力。巧妙方便功德大悲。法门所起。彼园中有菩萨摩诃萨。名曰弥勒。常化父母亲戚眷属及同行者。又复长养其余无量众生善根。令住大乘。亦欲为汝显现菩萨方便法门。欲明菩萨受生自在。欲对现教化一切众生令厌诸有。宣明菩萨大慈悲力。觉悟菩萨无相法门。明诸有趣悉无自相。汝诣彼问。云何菩萨净菩萨道。云何菩萨学菩萨戒。云何菩萨净菩萨心。云何菩萨发诸大愿。云何菩萨积功德具。云何菩萨得菩萨地。云何菩萨满足一切诸波罗蜜。云何菩萨得诸忍法。云何菩萨住功德行。云何菩萨近善知识。何以故。彼菩萨摩诃萨。究竟一切诸菩萨行。分别了知众生心行。以巧便智而教化之。满足一切诸波罗蜜。住菩萨地得诸忍门。证于菩萨离生之法。于诸佛所而得授记。于菩萨法自在游戏。持诸佛持。无量诸佛以一切智甘露正法而灌其顶。善男子。彼菩萨摩诃萨。能示导汝真善知识。坚菩提心长养善根。住正直心现菩萨根。说无碍法平等诸地。赞叹菩萨所出生道。具诸菩萨愿行功德。能广演说普贤所行。善男子。汝不应于一善根中生知足想。一光明法。一行一愿。一授记别。得法忍门。六波罗蜜。菩萨诸地所净佛刹。近善知识。于是事中生知足想。何以故。善男子。菩萨摩诃萨。应一向求无量善根。积集无量菩提具。积集无量菩提因缘。修习无量诸大回向。教化成熟无量众生。了知无量诸众生心诸根欲性众生诸行。除灭无量众生烦恼结业习气。除灭无量众生邪见诸染污心。令发无量诸清净心。拔出无量诸苦恼刺。消竭无量爱欲之海。远离无量愚痴闇冥。坏散无量大憍慢山。解散无量生死系缚。越度无量烦恼有流。煎竭无量受生海源。拯拔无量爱欲淤泥。于三界狱免济苦难。悉令安立八圣道支。普令灭除三毒炽然。断绝无量诸魔钩饵。远离无量诸恶魔业。净修无量菩萨直心。长养菩萨无量方便。出生菩萨无量诸根。净修菩萨无量欲性。深入菩萨无量等法。修行菩萨无量胜行。清净菩萨无量功德。净修菩萨无量威仪。示现菩萨无量随顺世间。发起无量不坏信心。发起无量大精进力。净修无量诸正念力。成满无量诸三昧力。开发无量诸大慧力。坚固无量诸欲性力。积聚无量诸功德力。长养无量诸净智力。发起无量菩萨诸力。成满无量诸如来力。悉分别知无量法门。普入无量诸法方面。净修无量法门。发起无量法明。照无量法无量诸根。了知无量诸烦恼病。积集无量诸妙法药。以善方便疗众结病。修习无量甘露正法。诣诸佛刹。恭敬供养无量如来。遍入菩萨大众源底。护持无量如来正法。不讥无量众生罪咎。除灭无量恶道诸难。令无量众生生天人中。总摄无量诸众生类。净修无量陀罗尼门。成满无量诸大愿行。修习无量大慈愿力。不惜寿命求无量法。修习无量寂灭法力。出生无量净智通明。知无量众生诸趣受生。而为应现无量化身。知无量心诸语言法。悉入菩萨无量诸行。修菩萨法。观察菩萨甚深法门。觉悟菩萨难知境界。到诸菩萨难至之趣。摄持菩萨勇猛功德。证于菩萨离生净妙难证之法。觉悟菩萨诸庄严行。于一切处。显现菩萨自在神力。受持菩萨无坏法云。增广菩萨无量无边净智慧行。究竟无量诸波罗蜜。受于菩萨无量记别。深入菩萨无量忍门。修治菩萨不思议地诸正法门。于无量劫以大弘誓而自庄严。供养诸佛。净不可说诸佛世界。发不可说菩萨愿行。善男子。略说菩萨教化一切众生。于一切劫行菩萨行。于一切趣应现受生。以明净智了一切三世。净一切刹满一切愿。供养一切佛。与一切菩萨同修愿行。亲近一切诸善知识。是故善男子。应一向求诸善知识。若见闻法恭敬供养。于善知识。勿生嫌疑身心懈厌。令一切善知识心大欢悦。何以故。因善知识。究竟一切诸菩萨行。成满一切菩萨功德。一切菩萨大愿。一切菩萨善根。一切菩萨助道法。生一切菩萨法明净一切菩萨法门。净修一切菩萨禁戒。一切菩萨禅定三昧。一切菩萨坚固无上菩提之心。一切菩萨摠持辩才。净一切菩萨功德藏。同一切菩萨大愿。解一切菩萨密法。一切菩萨法宝。长养一切菩萨诸根。积集一切菩萨智聚。护一切菩萨功德法藏。清净一切菩萨受生。闻持一切菩萨法云。出生一切菩萨正道。发起一切菩萨道心。成就一切诸佛菩提。一切菩萨诸行。了知十方一切法界。赞一切菩萨直心功德。起一切菩萨大慈悲力。摄一切菩萨无量善根。得一切菩萨道支。得一切菩萨饶益众生心。远离恶道安住大乘。修菩萨行远恶知识。于菩萨法心不退转。超出凡夫声闻缘觉。一切世间心无惑乱无所染着。广修菩萨无量诸行。长养一切诸善功德。除灭烦恼一切诸魔莫能沮坏。因善知识。悉能成辨如是等事。何以故。善知识者。能令除灭诸障碍故。远不善法离恶知识。灭无明闇诸邪见缚。超出生死一切世间。断魔钩饵拔苦恼刺。出无智险难邪惑山涧。越度有流诸恶邪径。示导清净菩提正道。教菩萨法。修习四道。明净慧眼。安立萨婆若。增长菩提心。广大慈悲。修波罗蜜。住菩萨地。得深法忍。净一切善根。积集一切菩萨功德。施与一切菩萨功德。见一切佛心大欢喜。护持净戒解真实义。出正法门离诸邪道。现明法门普照一切。闻持无量诸佛法云。灭一切烦恼。增益一切智。住一切佛法。复次善男子。善知识者则为慈母。生佛家故。善知识者则为慈父。以无量事益众生故。善知识者则为养育守护。不为一切恶故。善知识者则为大师。教化令学菩萨戒故。善知识者则为导师。教化令至彼岸道故。善知识者则为良医。疗治一切烦恼患故。善知识者则为雪山。长养明净智慧药故。善知识者则为勇将。防护一切诸恐怖故。善知识者则为牢船。悉令越度生死海故。善知识者则为船师。令至一切智法宝洲故。是故。善男子。应当如是正念思惟诣善知识。又善男子。诣善知识。发大地心。持一切事无疲倦故。发金刚心。坚固正直不可坏故。发金刚山心。一切苦患不能坏故。发无自心。随彼意故。发弟子心。不违一切教故。发僮仆心。一切苦役不疲厌故。发养育心。不畏烦恼所污染故。发佣作心随所受教不违逆故。发卑下心。远离自大增上慢故。发成熟心。善知时非时故。发宝马心。离[怡-台+龍]悷心。不调故。发大车心。载一切故。发大象心。伏诸根故。发大山心。一切恶风不能动故。发小犬心。离嗔恚故。发栴陀罗心。离憍慢故。发折角心。离威势故。发大风心。无所著故。发大船心。于彼此岸往返不疲故。发桥梁心。度善知识教故。发孝子心。见善知识无厌足故。发王子心。顺君教故。又善男子。应于自身生病苦想。于善知识生医王想。于所说教生良药想。又于自身生远行想。于善知识生导师想。于所说教生正路想。又于自身生趣彼岸想。于善知识生知济想。于所说法生凉池想。又于自身生农夫想。于善知识生龙王想。于所说法生时泽想。于随说行生成熟想。又于自身生贫穷想。于善知识生毗沙门宝天王想。于所说教生珍宝想。又于自身生弟子想。于善知识生大师想。于所说法生修学想。又于自身生怯劣想。于善知识生勇健想。于所说法生器仗想。又于自身生商人想。于善知识生导师想。于所说法生珍宝想。随闻说行生胜宝想。又于自身生子息想。于善知识生慈父想。于所说法生立家想。又于自身生王子想。于善知识生大臣想。于所说法学王教想。善男子。诣善知识。应正思念发如是想。何以故。因净直心见善知识。随顺其教增长善根。如依雪山出众药草。为佛法器如海吞流。生诸胜德如海出宝。净菩提心如炼真金。超出世间如海须弥。不染世间如水莲华。不没诸恶如海死尸。长白净法如月盛满。普照法界如日回耀。长菩萨身如母养子。善男子。略说菩萨摩诃萨若能随顺善知识教。得十不可说百千亿那由他诸功德。明十不可说百千亿那由他净直深心。增长十不可说百千亿那由他菩萨诸根。净十不可说百千亿那由他菩萨诸持。灭十不可说百千亿那由他诸障碍法。超十不可说百千亿那由他诸恶魔业。入十不可说百千亿那由他菩萨法门。满十不可说百千亿那由他诸妙功德。修十不可说百千亿那由他菩萨所行。具十不可说百千亿那由他菩萨大愿。善男子。略说菩萨因善知识究竟一切菩萨行。一切菩萨波罗蜜。一切菩萨地。一切菩萨忍。一切菩萨陀罗尼。一切菩萨三昧门。一切菩萨通明智自在。一切菩萨回向。一切菩萨大愿。善男子。如是等一切法。善知识为本。依善知识起。依善知识生。依善知识取。依善知识发。依善知识长。依善知识住。依善知识得

尔时善财。闻如是等赞善知识诸菩萨行如来正法。心大欢喜踊跃无量。正念思惟菩萨所行。渐渐游行向海涧国。以过去际修身业力。及清净心。远离恶行。超出世间虚妄惑倒。求佛法实义。长养诸根。满足大愿具精进力。不惜身命饶益众生。修菩萨行积集佛法。见诸如来净一切刹。供养法师护持正法。成就菩萨诸净愿身。善知缘起。修习不可思议善根。作是念已。净心信敬一切菩萨。如世尊想。修习诸根心不颠倒。正念恭敬离世间想满足诸愿。出生无量菩萨化身。赞叹三世一切诸佛菩萨法门。智慧觉悟如来菩萨一切至处自在神力。乃至一毛孔中佛菩萨身。皆悉充满无碍智眼。观十方法界及虚空界三世诸法。尔时善财。如是恭敬供养。具诸愿忍。以无量智观境界地。尔时善财。五体敬礼彼严净藏高大楼观。作如是念。此是诸佛菩萨诸善知识。是诸佛塔。是如来像。诸佛菩萨法宝住处。是声闻缘觉。亦是其塔。此是众圣。亦是父母。亦是福田。此是一切法界境界。作是念已。又复等观犹如虚空。等观如法界无有障碍。等观如实际至一切处。等观如如来。除诸虚妄无所染着。等观如影如梦如电如响。悉从缘起非有非无。深心信解。随诸业因而受果报。知从信心成等正觉。因解佛功德供养诸佛。因恭敬心出佛化身。因修善根起诸佛法。因般若波罗蜜起一切波罗蜜。因坚固愿起诸佛法。因诸回向起一切菩萨行。一切智境界法界解了回向。非常非断。非生非灭。非无因作。舍离有见诸颠倒惑。谓从自在而生诸法。本有实性次第而出。离我我所。深达缘起。入诸法界。见有为法犹如镜像。离有无见。不生不灭。灭邪痴惑。了诸法空悉无自在。超出诸相入无相际。而亦不违种生芽法。悉知一切从因缘生。如因印故而生印像。如镜中像。如电如梦如响如幻。各随因有。一切诸法亦复如是。随业受报。以善方便润泽诸法。尔时善财。礼未起间。知法如是得不思议善根柔软身心。稽首礼毕敬绕十匝。合掌谛观复作是念。此是解空无相愿者之所住处。离虚妄者之所住处。住法界者。了知众生非实有者。知不生者。知一切世间无所著者。方便分别一切众生者。一切无所依者。离一切相者。知一切法无自性者。不虚妄取一切业者。了知一切心意识相者。知一切道非出非不出者。住一切甚深大智度者。方便充满普门法界者。寂灭一切众烦恼者。智慧断除见爱慢者。一切禅定解脱三昧神通游戏者。修一切菩萨三昧境界者。安住一切如来所者。以一劫为一切劫。以一切劫为一劫者。以一切刹为一刹。以一刹。为一切刹。而亦不坏诸刹相者。以一法为一切法。以一切法为一法。而亦不坏诸法相者。以一众生为一切众生。以一切众生为一众生。而解众生无差别者。以一佛为一切佛。以一切佛为一佛。而解诸佛无有二者。以三世为一念。以一念为三世者。于一念中诣一切刹者。普照饶益一切众生者。得一切入者。出过众生为教化故而不舍离者。不依一切刹。而游行庄严一切世界供养佛者。诣一切佛无染著者。依善知识不味法者。住一切魔宫不乐欲者。入一切相而不舍离一切智者。了一切众生身无我无众生无二观者。自身容受一切世界。而不坏法性者。尽未来劫修诸愿行。而不取劫长短相者。不离一毛端处。而现一切世界。普为众生说正法者。可尊重者。解甚深法者。达无二者。了无性者。善对治者。体法空者。住慈悲者。远离一切声闻缘觉地者。超出一切魔境界者。不染一切世间境界者。究竟一切菩萨法门者。随顺一切佛法门者。厌一切生死。而不证声闻离生法者。知一切法无生。而亦不起不生见者。观不净法。不证离欲法不染爱者。修习大慈。不为除灭嗔恚法者。观于缘起。一切法中无愚痴者。住于四禅不随生者。住四无量。不生无色为教化者。修习止观。不证明脱化众生者。住空三昧。灭无见者。住无相三昧。为化众生不舍相者。住无愿三昧。不舍菩萨一切愿者。一切烦恼业中得自在力为教化故。示现随顺烦恼业者。离于生死而现受生为教化者。离一切趣现入诸趣化众生者。修大慈悲不随爱者。修习喜心。见众生苦常忧戚者。修习舍心。而不舍离利他事者。得九次第定。而不厌离欲界生者。离于诸受。而不证实际者。住三脱门。而不证声闻解脱法者。观四真谛。而不证诸果者。观于缘起。离边见者。修八正道。而不永出生死难者。超凡夫地。而不堕于二乘地者。观阴炽然。而不永灭于五阴者。离四魔道。而不永舍诸魔觉者。舍六入障。而现受者。观真如相。而不证于实际法者。现学一切乘。而不舍离摩诃衍者。如此楼观。住一切功德者之所住处。尔时善财。以偈颂曰

  安住大慈心　　弥勒摩诃萨
  具足妙功德　　饶益诸群生
  住于灌顶地　　诸佛之长子
  思惟佛境界　　安住此法堂
  一切诸佛子　　常履大乘行
  游行诸法界　　安住此法堂
  施戒忍精进　　禅智方便愿
  究竟彼岸者　　安住此法堂
  无碍智如空　　普照三世法
  了知一切者　　安住此法堂
  解了一切法　　真实无生相
  如鸟游空者　　安住此法堂
  除灭贪恚痴　　一切诸颠倒
  常乐寂静者　　安住此法堂
  三脱门道观　　阴入界缘起
  远离恶道者　　安住此法堂
  深入无碍智　　等观众生刹
  知法无性者　　安住此法堂
  三世法无碍　　犹如空中风
  无所染著者　　安住此法堂
  见众生受苦　　无有归依处
  大悲普济者　　安住此法堂
  见盲冥众生　　舍正入险路
  为示正道者　　安住此法堂
  见诸有为中　　生老病死逼
  令免恐怖者　　安住此法堂
  见众生结患　　积集智慧药
  悲心医王者　　安住此法堂
  见无量众生　　漂溺生死海
  大悲船度者　　安住此法堂
  深入生死海　　摧灭烦恼龙
  采佛智宝者　　安住此法堂
  愿地慈悲眼　　观海出众生
  如金翅鸟者　　安住此法堂
  法界空中行　　犹如净日月
  慧光普照者　　安住此法堂
  为一一众生　　尽未来际劫
  荷负诸苦者　　安住此法堂
  一一诸刹中　　尽来劫修行
  金刚精进者　　安住此法堂
  一坐处闻持　　诸佛法无厌
  大智慧海者　　安住此法堂
  遍游世界海　　及诸大众海
  供养佛海者　　安住此法堂
  一切劫海中　　修诸愿行海
  出生功德者　　安住此法堂
  一一毛孔中　　佛刹劫众生
  无碍眼见者　　安住此法堂
  一念中遍入　　不可说诸劫
  知念无碍者　　安住此法堂
  一切刹微尘　　众生水渧等
  生此等愿者　　安住此法堂
  无量劫修行　　总持禅定愿
  解脱法门者　　安住此法堂
  一切诸佛子　　出生无量德
  饶益众生者　　安住此法堂
  成就无碍智　　通明巧方便
  随应现生者　　安住此法堂
  从初发道心　　究竟一切行
  化身满法界　　显现自在力
  一念成正觉　　入无量智业
  莫能测量者　　安住此法堂
  无碍净慧力　　游行诸法界
  无垢智观者　　安住此法堂
  成就无碍足　　一切无所著
  了刹无二者　　安住此法堂
  观诸寂灭法　　皆悉如虚空
  离垢境界者　　安住此法堂
  大悲观众生　　诸苦所逼迫
  拔济饶益者　　安住此法堂
  不离一坐处　　普现众生前
  如明净日月　　除灭魔钩饵
  佛子住此堂　　哀愍诸群生
  出无量化身　　充满诸法界
  佛子住此堂　　遍游诸世界
  一切如来所　　无量无数劫
  无依入此堂　　称量佛境界
  无量无数劫　　其心无厌倦
  佛子住此堂　　念念入诸定
  一一三昧门　　显现佛境界
  佛子住此堂　　觉了一切刹
  三世一切劫　　众生佛名号
  佛子住此堂　　诸劫为一念
  远离妄想惑　　随顺于众生
  佛子住此堂　　修习诸三昧
  一一心念中　　了达三世法
  佛子住此堂　　一处跏趺坐
  普现一切刹　　一切诸趣中
  佛子住此堂　　悉饮佛法海
  深入智慧海　　超度功德海
  无碍智思量　　三世无数刹
  诸劫诸如来　　无数众生类
  佛子住此堂　　常于一念中
  了知于三世　　诸佛刹成败
  善知诸最胜　　所修诸行愿
  并众生诸根　　修习佛境界
  一一微尘中　　见一切劫刹
  诸佛及眷属　　一切众生类
  佛子住此堂　　常观一切法
  众生刹世劫　　皆悉无自性
  观察众生等　　法等如来等
  愿等世界等　　三世悉平等
  佛子住此堂　　教化诸群生
  供养诸如来　　思惟诸法界
  无量智慧业　　满足诸大愿
  无数劫演说　　不可得穷尽
  一切诸佛子　　具足无量德
  安住此法堂　　我合掌敬礼
  诸佛之长子　　弥勒无碍行
  我今合掌礼　　唯愿慈矜愍

尔时善财。赞叹楼观诸菩萨已。合掌恭敬。供养礼讫。于门下立。欲见弥勒菩萨。尔时遥见弥勒菩萨。与无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等大众围绕从外而来。威德特尊普照一切。不染世法。超出一切世间众魔境界。灭诸障碍。深入如来菩萨境界。供养诸佛等诸佛法。冠解脱缯净妙天冠。住大智网。于诸佛所得一切智甘露灌顶。生诸佛法得萨婆若。尔时善财。头面敬礼一心合掌。白言大圣。云何菩萨学菩萨行修菩萨道。既修学已。具一切佛法。随所请众生悉令度脱。成就大愿。究竟一切菩萨所行。安慰一切诸天世人。不负本心。不违三宝。不欺天人。不罔众生。不断佛种。持菩萨家如来正法。如是等事。唯愿演说。尔时弥勒。观察大众。指善财言。汝等见是童子问菩萨行具足一切功德者不。此童子者。勇猛精进专求实义。以正直心得不退转。常修胜法心无厌足。如救头然。求善知识。亲近供养闻法受持。此童子者。昔于频陀伽罗城。受文殊师利教。求善知识。展转经由一百一十诸善知识。问菩萨行。心无疲倦。次来我所。如是童子学大乘者。甚为希有。成满大愿。能辨大事。具大庄严。常以大慈救护众生。起大精进波罗蜜。示导大众。乘大法船度生死海。令住大道得大法宝长养大智。如是之人难得闻见。亲近共住同行亦难。何以故。此童子者。发心救护一切众生。除灭众苦恶道诸难邪见险路愚痴之闇。超出生死。坏一切趣轮。度魔境界。于一切世间无所染着。出欲泥。解贪缚。除邪倒。摧慢幢。拔使刺。废诸盖。裂爱网。灭无明。竭有流。离谄幻。净心垢。释疑惑。度无智海。厌生死苦。乘大法船济四使流。于大爱河造智慧桥。愚痴闇中然智慧灯。于生死路示以正道。烦恼病者令服法药。生老死者授甘露法。三毒盛者灭以定水令得清凉。诸忧怖者施以无畏。三有狱者开以智门。邪见缚者断以慧剑。住三界城开解脱门。在危险者示安隐处。惧结贼者施以无畏。坠三恶堑者俯接令出。为阴贼害者置涅槃城。着众生者示八正道。住六入空聚者拯以慧明。失津要者示以正济。近恶知识者令亲善友。乐童蒙者诱以圣法。乐住生死宅者普令超入一切智城。救护一切众生之类。不舍清净求菩提心。积集大乘心无疲倦。饮正法雨而无厌足。勇猛究竟诸功德事。净诸法门修菩萨行心无疲懈。不退方便出生大愿。见善知识心乐无厌奉给所为随顺其教。不以为苦。诸善男子。世间有能发起无上菩提心者。甚为希有。若发心已。如是精进求佛法者。亦甚希有。如是乐欲净菩萨道。具菩萨行。不惜身命。求善知识。不违其教。集菩提分。不贪利养。不舍菩萨正直之心。不着家业不染五欲。不恋父母及诸亲族。但乐专修一切种智。如是之人倍复希有。诸善男子。若有菩萨。如是学者。则能究竟菩萨所行。成满大愿。近佛菩提。净一切刹。教化众生。深入法界。具足一切诸波罗蜜。广菩萨行。毕本意性。出于魔业。值遇一切诸善知识。于一生中。能具普贤菩萨诸行。此童子者。入威仪海诸智慧海。修菩提海菩萨行海。成满一切诸佛愿海。诣诸刹海见诸佛海。入眷属海行供养海。闻正法海饮妙法海。成满一切菩萨力海。显现一切自在力云。一切众生无不见者。灭一切烦恼处。入一切佛处。入诸法门处。入诸三昧处。住诸通明处。游行法界处。如日月出照一切众生处。不依诸相如空中鸟。常乐寂静无坏法门。遍游因陀罗网世界诸佛世界。如风无碍。深入法界。现诸世间。见三世佛。心大欢喜踊跃无量。随诸佛教。为圣法器。得诸法门。具菩萨行。现自在力。善财。汝今得最大利。于无量劫难闻见者。汝悉闻见知彼功德。所谓得见文殊师利。积无量德。远离一切险难恶道。安住正法。过童蒙地。住诸菩萨功德之地。具智慧地。得诸佛地菩萨行海。成满虚空等诸佛智藏。专求无量诸妙功德。心无厌倦。若能如是坚直心者。则能乐求诸善知识。具菩萨行教化众生。具不思议清净之信诸妙功德正法义者。悉得睹见一切佛子。善财。汝今获大善利。次第睹见诸佛真子。随彼自说愿行所得。汝从闻已。皆悉具得如是行者。于无量劫之所难办。以是因缘。诸佛子等次第为说。难闻见者汝悉闻见。从彼闻法现自在力。为一切佛之所护念。菩萨所摄随顺彼教。得大善利。长养一切诸菩萨性。学诸功德。不断佛种。常为诸佛甘露灌顶。不久当与诸佛子等。随前众生。因其修善。皆悉令获胜妙果报。善财。汝应发大欢喜。不久当得大果报故。无量菩萨。于无数劫修菩萨行。汝今一生皆悉具得。皆由直心精进力故。其有欲得如是法者。当如善财之所修学。便得究竟诸菩萨行。满一切愿达一切法。譬如庆云随所覆处能降甘泽。随智慧愿具菩萨行。亦复如是。善财当知。我所显说。皆是普贤菩萨所行。应当了知近善知识。过去诸佛专求菩提修习此行。于无量劫诸有为中受无量苦。犹不值遇过去诸佛。不具是行。善财。汝今皆得成就。闻诸佛法行菩萨行。其有众生。闻是行者。得大善利成满大愿。亲近诸佛。为佛真子。必成佛道清净解脱。除灭诸恶远离众苦。积功德聚清净法身。游行十方。见诸如来菩萨大众。长养善根如水莲华。值遇诸佛闻持正法。安住佛道具诸佛愿。究竟诸佛功德彼岸。尔时弥勒。告善财言。汝可往诣文殊师利问诸法门智慧境界普贤所行。彼当为汝分别演说。尔时善财。闻是语已。悲泣流泪。文殊师利即时申臂。遥授善财华宝璎珞。善财得已欢喜供散弥勒菩萨。弥勒菩萨即以右手摩善财顶。赞言。善哉善哉。佛子。汝亦不久当与我等。尔时善财。踊跃无量。以偈颂曰

  无量无数劫　　难得闻见者
  我今得奉觐　　无上善知识
  文殊我所尊　　究竟功德岸
  蒙见善知识　　愿速还亲近

尔时善财。五体敬礼弥勒菩萨。合掌白言。大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行修菩萨道。大圣今者。已为诸佛授一生记。证于菩萨离生正法。住菩萨住。究竟一切诸波罗蜜。具足一切诸法忍门。成就菩萨一切诸地。自在游戏一切法门。得一切三昧。到于菩萨随所至趣。逮得一切陀罗尼辩才方便光明。具足成就菩萨自在。积集一切助菩提分。游戏巧方便慧。得一切通明。随所修学。悉已究竟菩萨诸行。具一切愿。知诸乘门。持如来持。摄佛菩提。守护一切诸佛法藏。出生智宝。菩萨功德如来密教。常为菩萨大众上首。为烦恼贼所逼迫者。以勇猛力能为摧灭令得安隐。生死旷野迷正路者示以正道。烦恼患者治以良医。诸众生尊为天中天。为无上圣。胜出二乘。生死海者为作导师而度脱之。张大教网亘生死海。诸调伏者摄而取之。长养善根。安立菩萨于无碍乘。究竟一切诸菩萨事。住诸佛所。唯愿大圣为我演说。云何菩萨学菩萨行修菩萨道。尔时弥勒菩萨摩诃萨。观察善财。指示大众。叹其功德。以偈颂曰

  善财童子者　　净直心智慧
  专求菩萨行　　而来至我所
  善来大悲云　　能雨甘露法
  具足三净眼　　菩萨行无厌
  善来正直心　　精进无懈惓
  诸根悉调伏　　专求菩萨行
  善来无坏行　　常求善知识
  了达一切法　　教化诸群生
  善来清净道　　安住功德藏
  勇猛精进力　　逮得最胜地
  善来难见者　　诸佛功德子
  增长诸善根　　深入无量境
  善来平等者　　利衰及毁誉
  苦乐世间法　　其心无所染
  善来安乐者　　直心离谄曲
  除灭于憍慢　　嗔恚放逸法
  善来最胜藏　　观察一切众
  长养功德藏　　其心无疲倦
  善来三世智　　圆满诸法界
  了佛功德藏　　其心无疲倦
  善来妙莲华　　增长名称云
  诸佛子教来　　我示无碍趣
  成就智慧网　　了达不思议
  广修菩萨行　　教化诸群生
  专求佛菩提　　修习离垢行
  闻持诸大愿　　至此无疲倦
  去来现在佛　　所成诸行业
  善财欲修学　　故来至我所
  志求真法师　　演说正道法
  善教菩萨者　　故来至我所
  佛子修智慧　　具足于菩提
  亲近善知识　　故来至我所
  众生慈父母　　长养诸功德
  究竟菩提道　　故来至我所
  生老病死者　　无上良医王
  众生之释天　　雨甘露法药
  众生明净日　　普照诸正道
  众生之净月　　功德圆满故
  譬如须弥山　　怨亲心不动
  犹如大海水　　未曾有增减
  犹如海导师　　度脱无量众
  一切无所著　　故来至我所
  勇健精进力　　拯救诸众生
  悉令得安乐　　专求善知识
  建立正法幢　　显现佛功德
  除灭恶道苦　　开诸善趣门
  能诣诸导师　　睹见佛妙身
  闻持彼密教　　专求黠慧师
  欲具妙智色　　托生种姓家
  究竟诸功德　　故来至我所
  无比正直心　　亲近善知识
  闻其所说教　　皆悉能奉行
  因昔无量德　　文殊令发心
  随顺其教命　　专求佛菩提
  舍天宫家属　　父母诸亲戚
  世间一切乐　　谦苦求知识
  如是清净行　　于此命终已
  得诸胜妙果　　升入佛法堂
  善财见众生　　生老病死苦
  为发大悲心　　专求佛菩提
  见五道轮转　　众苦所逼迫
  修智金刚轮　　坏散苦趣轮
  众生田荒秽　　贪恚邪见刺
  为净修治故　　专求利智犁
  众生处痴闇　　盲冥失正路
  善财为导师　　慧光示正道
  忍辱为密铠　　执持慧利剑
  乘于三脱门　　摧灭烦恼贼
  善财勇猛力　　普为三界众
  除灭诸恐怖　　令置安隐处
  善财为海师　　造立大法船
  越度尔焰海　　令住净宝洲
  善财为一切　　法界中净日
  以愿智慧光　　普照众生类
  善财为觉月　　妙法悉圆满
  慈定清凉光　　灭诸烦恼热
  善财智海依　　直心金刚地
  菩萨行渐深　　出生妙法宝
  菩提心龙王　　升于法界空
  兴云雨甘露　　长养白净果
  净信心为炷　　慈悲为香油
  正念为宝器　　然彼耀世灯
  道心迦罗逻　　慈悲为胞段
  菩提分肢节　　长养如来藏
  增益功德藏　　清净智慧藏
  炽盛智慧藏　　成满诸愿藏
  如是大庄严　　救护诸群生
  一切天人中　　难闻难得见
  如是智慧树　　根深不可动
  方便为敷茂　　饶益诸群生
  欲闻一切法　　除灭诸疑惑
  具足妙功德　　专求善知识
  摧灭烦恼魔　　消灭邪爱垢
  悉令得解脱　　专求智慧者
  安住功德道　　究竟灭三涂
  开示诸善趣　　令具涅槃道
  显现八正路　　除灭诸邪见
  坏裂烦恼网　　消竭爱欲海
  善财明净日　　普照群萌类
  能为调御士　　拯济三有众
  觉悟于一切　　永出五欲泥
  除灭虚妄想　　为开解脱门
  分别诸法界　　严净如来刹
  究竟一切法　　善财应欢喜
  勇猛修方便　　信心不可坏
  积集妙功德　　成满诸大愿
  不久见诸佛　　了达一切法
  严净诸佛刹　　成就佛菩提
  随顺威仪海　　究竟诸行海
  度脱于一切　　无量众生海
  出生诸善法　　具足妙功德
  与诸佛子等　　圆满解脱法
  成满诸大愿　　降伏一切魔
  具足清净业　　除灭诸烦恼
  成就一切智　　了达甚深法
  除灭诸群生　　烦恼众苦患
  一切众生轮　　回流生死轮
  为转净法轮　　除灭众苦轮
  守护佛种姓　　净修法种姓
  摄取僧种性　　了三世种姓
  成满大愿网　　坏散邪见网
  [國*瓜]裂诸爱网　　决破众苦网
  成就直心性　　具足智慧性
  严净世界性　　度脱众生性
  善财令一切　　无量诸群生
  诸佛及菩萨　　皆悉大欢喜
  善财净慧光　　普照诸刹法
  一切众生类　　皆见无量佛
  照明诸法界　　清净众生界
  远离诸恶道　　除灭三有苦
  令众离邪道　　显现诸善道
  修习八正道　　安立解脱道
  普令诸群生　　度脱生死海
  除灭诸烦恼　　安住功德海
  消竭烦恼海　　令度三有海
  诸根悉调伏　　不染于世间

大方广佛华严经卷第五十八大方广佛华严经卷第五十九

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十六

尔时弥勒菩萨。以如是等。赞叹善财诸妙功德令无量众生。发道心已。告善财言。善哉善哉。童子。乃能发阿耨多罗三藐三菩提心。专求一切佛法。饶益一切世间。救护一切众生。善男子。汝得善利。人身寿命。值遇诸佛。得见文殊师利大善知识。汝为法器。善根润泽。长清白法。净胜欲性。为善知识之所总摄。诸佛护念。何以故。菩提心者。则为一切诸佛种子。能生一切诸佛法故。菩提心者。则为良田。长养众生白净法故。菩提心者。则为大地。能持一切诸世间故。菩提心者。则为净水。洗濯一切烦恼垢故。菩提心者。则为大风。一切世间无障碍故。菩提心者。则为盛火。能烧一切邪见爱故。菩提心者。则为净日。普照一切众生类故。菩提心者。则为明月。诸白净法悉圆满故。菩提心者。则为净灯。普照一切诸法界故。菩提心者。则为净眼。悉能睹见邪正道故。菩提心者。则为大道。皆令得入一切智城故。菩提心者。则为正济。悉令得到出要处。故。菩提心者。则为大乘。容载一切诸菩萨故。菩提心者。则为门户。令入一切菩萨行故。菩提心者。则为宫殿。安住修习三昧法故。菩提心者。则为园观。于中游戏受法乐故。菩提心者。则为胜宅。一切众生所归依故。菩提心者。则为依止。因修一切菩萨行故。菩提心者。则为守护。能满菩萨诸大愿故。菩提心者。则为慈母。增长一切诸菩萨故。菩提心者。则为养育。守护一切诸菩萨故。菩提心者。则为善知识。离一切恶诸恐怖故。菩提心者。则为大王。胜诸声闻缘觉心故。菩提心者。则为最胜。成满一切无比愿故。菩提心者。则为大海。悉能容受诸功德故。菩提心者。则为须弥山王。等观众生心不动故。菩提心者。则为金刚围山。摄持一切诸众生故。菩提心者。则为雪山。长养智慧清凉药故。菩提心者。则为香山。出生一切功德香故。菩提心者。则为虚空。诸妙功德无边际故。菩提心者。则为莲华。不染一切世间法故。菩提心者。则为宝象。悉能调伏一切根故。菩提心者。则为宝马。远离诸恶[怡-台+龍]悷法故。菩提心者。则为调御师。悉能守护摩诃衍故。菩提心者。则为良药。疗治一切烦恼病故。菩提心者。则为沃焦。消尽一切不善法故。菩提心者。则为金刚。坏散一切诸恶法故。菩提心者。则为和香。出生一切功德香故。菩提心者。则为妙华。一切世间所爱乐故。菩提心者。则为白栴檀。除灭五欲诸热病故。菩提心者。则为乐器。微妙音声闻法界故。菩提心者。则为勇健。摧灭烦恼诸怨敌故。菩提心者。则为善镊。拔出一切烦恼刺故。菩提心者。则为尊主。于余一切莫能胜故。菩提心者。则为毗沙门天王。舍离一切诸贫苦故。菩提心者。则为妙德。庄严一切诸功德故。菩提心者。则为庄严具。严饰一切诸菩萨故。菩提心者。则为火灾。焚烧一切有为法故。菩提心者。则为无坏药王树根。长养一切诸佛法故。菩提心者。则为龙珠。除灭无量烦恼毒故。菩提心者。则为水珠。净诸心垢烦恼浊故。菩提心者。则为如意珠。具足一切功德利故。菩提心者。则为天德瓶。满足一切所欲乐故。菩提心者。则为劫初树。出生一切庄严具故。菩提心者。则为恒娑衣。不受一切诸尘垢故。菩提心者。则为正业。本性净故。菩提心者。则为利犁。修治一切众生田故。菩提心者。则为那罗延箭。悉能鉴彻身见铠故。菩提心者。则为厌离。决定了知苦患相故。菩提心者。则为利槊。能刺一切烦恼贼故。菩提心者。则为甘露雨。能灭一切烦恼火故。菩提心者。则为利剑。斩除一切烦恼恶故。菩提心者。则为金椎。坏散一切憍慢山故。菩提心者。则为利刀。斩截七使烦恼铠故。菩提心者。则为勇健幢。倾倒一切诸魔幢故。菩提心者。则为釿斧。斫伐无知诸苦树故。菩提心者。则为器仗。防护一切诸艰难故。菩提心者。则为善手。防护一切诸度身故。菩提心者。则为妙足。安立一切诸功德故。菩提心者。则为眼药。除灭一切无明曀故。菩提心者。则为善拔刺。悉能拔出身见刺故。菩提心者。则为安隐床。除灭一切生死苦床故。菩提心者。则为善友。度脱无量生死难故。菩提心者。则为善利。远离一切衰耗法故。菩提心者。则为天人师。善知菩萨出要道故。菩提心者。则为宝藏。无量功德不可尽故。菩提心者。则为涌泉。清冷智慧无穷尽故。菩提心者。则为净镜。显现一切诸法门故。菩提心者。则为净池。洗濯一切诸垢秽故。菩提心者。则为大河流。引诸度四摄法故。菩提心者。则为龙王。悉能普雨甘露法故。菩提心者。则为命根。任持菩萨大悲法故。菩提心者。则为甘露。能令安住不死法故。菩提心者。则为罗网。网取一切所应化故。菩提心者。则为善罥。摄取一切诸众生故。菩提心者。则为钩饵。钓出生死渊居众生故。菩提心者。则为阿伽陀药。除灭一切诸恶患故。菩提心者。则为波罗提毗叉药。悉能疗治五欲毒故。菩提心者。则为大地。消灭无量邪想水故。菩提心者。则为风轮。坏散一切诸障盖故。菩提心者。则为宝洲。出生道品功德宝故。菩提心者。则为种性长养一切白净法故。菩提心者。则为居宅。纳受一切功德宝故。菩提心者。则为大城。菩萨商人所住处故。菩提心者。则为金药。消烦恼垢令清净故。菩提心者。则为香蜜。具足一切功德味故。菩提心者。则为正道。令入一切智城故。菩提心者。则为宝器。容受一切白净法故。菩提心者。则为时泽。悉能除灭烦恼尘故。菩提心者。则为安住。出生菩萨之所住故。菩提心者。则为寿行。不取声闻诸解脱故。菩提心者。则为琉璃宝。其性净妙不受垢故。菩提心者。则为伊尼罗宝。胜诸声闻缘觉智故。菩提心者。则为法鼓。觉悟烦恼长寝众生故。菩提心者。则为净水。其性清净无垢浊故。菩提心者。则为阎浮檀金。令有为善如聚墨故。菩提心者。则为山王。超出一切诸世间故。菩提心者。则为归依。悉能救护诸众生故。菩提心者。则为实义。远离一切虚妄法故。菩提心者。则为无上宝。悉令欢喜得满足故。菩提心者。则为大会。随彼所须令充悦故。菩提心者。则为尊长。于诸众生无伦匹故。菩提心者。则为宝藏。受持一切诸佛法故。菩提心者。则为因陀罗网。摄诸烦恼阿修罗故。菩提心者。则为毗楼那风。震动教化众生心故。菩提心者。则为因陀罗火。焚烧一切烦恼习故。菩提心者。则为无上塔。一切天人应供养故。佛子。菩提心者。如是无量功德成就。悉与一切诸佛菩萨诸功德等。何以故。因菩提心。出生一切诸菩萨行。三世诸佛成正觉故

善男子。譬如有人得自在药。离五恐怖。何等为五。所谓火不能烧。水不能漂。毒不能中。刀不能伤。熏不能害。菩萨摩诃萨。亦复如是。发菩提心。摄萨婆若。离五恐怖。何等为五。所谓不为欲火所烧。诸有流水所不能漂。嗔恚恶毒所不能中。烦恼利刀所不能伤。邪觉观烟熏不能害。善男子。譬如有人得解脱药。终不横死。菩萨摩诃萨。亦复如是。得菩提心妙智慧药。生死过患所不能害。善男子。譬如有人得龙王药。若有毒虫。闻其药气即避远去。菩萨摩诃萨。亦复如是。得菩提心大龙王药。一切烦恼诸恶毒虫。闻其药气皆悉散灭。善男子。譬如有人得不可坏药。一切怨敌不得其便。菩萨摩诃萨。亦复如是。得菩提心不坏法药。一切烦恼诸魔怨敌。所不能坏。善男子。譬如有人得频伽陀药。能出毒刺。菩萨摩诃萨。亦复如是。得菩提心频伽陀药。能出三毒诸邪见刺。善男子。譬如有人得善见药王。灭一切病。菩萨摩诃萨。亦复如是。得菩提心善见药王。灭一切众生诸烦恼病。善男子。譬如删陀那大药王树。其有众生在彼树荫。身诸恶疮皆得除愈。菩萨摩诃萨。亦复如是。得菩提心删陀药树。其有众生依荫此树。一切烦恼不善业疮皆得除愈。善男子。譬如药王树。名无坏根。以其力故。长养一切阎浮提树。菩提心树。亦复如是。以其力故。长养一切学无学菩萨善根。善男子。譬如药草名阿蓝婆。若用涂体身得柔泽。意离诸恶。菩萨摩诃萨。亦复如是。得菩提心阿蓝婆药。长身口意诸善行业。善男子。譬如有人得念力药。有所闻法终不忘失。菩萨摩诃萨。亦复如是。得菩提心念力药者。闻持一切佛法不忘。善男子。譬如有药。名曰莲华。其有服者住寿一劫。菩萨摩诃萨。亦复如是。服菩提心莲华药者。阿僧祇劫而得自在。善男子。譬如有人执翳身药。一切众生所不能见。菩萨摩诃萨。亦复如是。得菩提心翳身药者。一切诸魔所不能见。善男子。譬如大海有摩尼宝。名积众宝。若不至他方。设火灾起。乃至消减海水一渧。无有是处。菩提之心积众宝珠。亦复如是。处于菩萨直心海中。乃至以一善根回向萨婆若。有忘失者无有是处。而萨婆若无所染着。不离善根。善男子。譬如摩尼名净光明。有人以此璎珞身者。蔽余宝光悉如聚墨。菩萨摩诃萨。亦复如是。以菩提心摩尼宝珠。璎珞其身。映蔽声闻缘觉心宝。善男子。譬如水珠置浊水中。水即澄清。菩提心珠。亦复如是。除灭一切烦恼垢浊。善男子。譬如有人得住水宝珠。璎珞其身。入深水中而不没溺。菩萨摩诃萨。亦复如是。得菩提心住水宝珠。入生死海。而不沉没。善男子。譬如有人得大龙宝珠。往到龙所龙不为害。菩萨摩诃萨。亦复如是。得菩提心大龙宝珠。入欲界中。烦恼恶龙所不能害。善男子。譬如帝释有摩尼宝。璎珞其身。于天中尊。菩萨摩诃萨。亦复如是。着菩提心宝璎珞者。悉于一切三界中尊。善男子。譬如有人得随意珠。除灭一切贫穷困苦。菩萨摩诃萨。亦复如是。得菩提心随意宝珠。除灭一切邪命贫苦。善男子。譬如火珠因日光发能出猛焰。得菩提心明净火珠。亦复如是。因大慧光所感发故。出智慧火。善男子。譬如月珠因月光发出清凉水。得菩提心净月宝珠。亦复如是。因彼回向善根月光所感发已。出生善根诸大愿水。善男子。譬如龙王着如意宝冠远离恐怖。菩萨摩诃萨。亦复如是。着菩提心大悲如意宝冠。远离一切恶道诸难。善男子。譬如庄严一切众生藏摩尼宝。悉能成满一切所愿。无所损减。得菩提心妙庄严藏摩尼宝者。成满菩萨及余众生所欲愿乐。无所损减。善男子。譬如转轮王有摩尼宝。普照宫殿灭一切闇。菩萨摩诃萨。亦复如是。得菩提心摩尼宝者。悉能普照五趣宫殿。灭一切闇。善男子。譬如有人为绀色宝光明所触。即同其色。菩萨摩诃萨。亦复如是。得菩提心绀色宝光。观察诸法。善根回向。同萨婆若色。善男子。如琉璃宝。于百千岁处不净中不为所染。菩提之心净琉璃宝。亦复如是。于百千劫。住欲界中。不为五欲之所染污。其性净故。善男子。如离垢光净摩尼宝出一切宝。菩提之心离垢光宝。亦复如是。出生凡夫声闻缘觉菩萨诸佛功德珍宝。善男子。譬如大摩尼宝。悉能除灭一切诸闇。菩提心宝亦复如是。除灭一切无知闇冥善男子。譬如大海有无价宝。商人船车载之入城。余摩尼宝无与等者。菩提之心无价宝珠。亦复如是。处生死海。菩萨摩诃萨。以大愿船。载入解脱城。声闻缘觉诸功德宝所不能及。善男子。譬如离垢大摩尼宝。处阎浮提。能照四万由旬。日月宫殿皆悉显现。菩提之心离垢宝珠。亦复如是。住于生死照法界空。佛境宫宅悉令显现。善男子。譬如摩尼风王能持日月所照境界。所有香华一切品类。菩提之心摩尼风王。亦复如是。悉能摄持一切种智所照境界。一切天人声闻缘觉诸佛菩萨。及诸有漏无漏善根。善男子。譬如海中有摩尼宝。名曰海藏。显现海中诸庄严事。菩提之心海藏宝珠。亦复如是。显现一切智境诸庄严事。善男子。譬如阎浮檀金。除如意宝胜一切宝。菩提之心阎浮檀金。亦复如是。除一切智胜诸功德。善男子。譬如有人善能咒龙。于诸龙中而得自在。菩萨摩诃萨。亦复如是。得菩提心善咒术法。于一切烦恼龙。而得自在。善男子。譬如勇士被执铠仗。一切怨敌所不能坏。菩萨摩诃萨。亦复如是。被菩提心大庄严具。一切烦恼诸魔怨敌。所不能坏。善男子。譬如忧陀伽娑罗栴檀。若烧一铢。香气普熏小千世界。三千大千世界珍宝。所不能及。菩提心香亦复如是。以妙功德普熏法界。一切声闻缘觉功德。所不能及。善男子。譬如白栴檀以涂其身。除诸恼热得清凉乐。菩提心香亦复如是。除灭觉观贪恚痴热。令智慧身悉得凉乐。善男子。譬如须弥山。众生品类近彼山者。悉同其色。菩提心山亦复如是。若有近者。皆得同彼萨婆若色。善男子。譬如波利质多树华香。阎浮提中诸婆师华。薝卜华等。所不能及。菩提心香亦复如是。妙功德香。声闻缘觉无漏戒定。智慧解脱解脱知见。所不能及。善男子。譬如波利质多树华。未开敷时其香普熏阎浮提内一切华香所不能及。菩提心华亦复如是。一切天人有漏无漏功德华香。所不能及。善男子。譬如波利质多树华。一日熏衣。薝卜华婆师华。虽千岁熏所不能及。菩提心华亦复如是。一日所熏功德香。彻十方佛所。一切声闻缘觉。以无漏心熏诸功德。于百千劫所不能及。善男子。譬如那利罗树。根茎枝叶及其华果。悉益众生。菩提心树亦复如是。依因菩萨大慈悲生。从初发心。乃至究竟一切佛法。常能饶益一切众生。善男子。譬如一两阿罗娑药。变千两铜以为真金。于彼药分无所损减。菩提心药亦复如是。摄回向智。除灭一切烦恼业障。净一切法。同萨婆若色。烦恼恶业不能损减。譬如小火。随所焚烧其焰转盛。菩提心火亦复如是。随所缘法慧火猛盛。譬如一灯。然百千灯无所损减。菩提心灯亦复如是。悉然三世诸佛慧灯。无所损减。譬如明灯入大闇室。悉能照除一切闇冥。菩提心灯亦复如是。入心闇室。于无量劫积集痴闇。悉能除灭。具足菩萨明净智慧。譬如灯炷随其精粗光明亦尔。若益膏油光明转增。菩提心炷亦复如是。随其本愿出智慧光。普照法界增大悲油。教化众生净佛世界。行诸佛事无有穷尽。譬如他化自在天王。冠阎浮檀金自然天冠。欲界诸天所不能坏。菩萨摩诃萨。亦复如是。冠菩提心大愿天冠。声闻缘觉所不能坏。譬如大师子吼。小师子闻皆悉勇健。一切禽兽远避窜伏。佛师子吼。诸菩萨等若闻赞叹菩提心声长养法身。妄见众生潜伏退散。譬如有人用师子筋以为琴弦。音声既奏余弦断绝。一切如来波罗蜜身。出菩提心功德音声。若乐五欲二乘法者。闻悉断灭。譬如牛马羊乳合在一器。以师子乳投彼器中。余乳消尽直过无碍。如来师子菩提心乳。着无量劫所积诸业烦恼乳中。皆悉消尽。不住声闻缘觉法中。譬如迦毗伽鸟在[穀-禾+卵]中时。有大势力。余鸟弗及。菩萨摩诃萨。亦复如是。于生死[穀-禾+卵]。发菩提心功德势力。声闻缘觉所不能及。譬如金翅鸟初始生时。其目明净有大势力。大小诸鸟所不能及。菩萨摩诃萨。亦复如是。生如来家发菩提心。慧眼明净有大势力。声闻缘觉于百千劫。修习智慧所不能及。譬如健士以那罗延金刚利箭射坚密铠。直过无碍。菩萨摩诃萨。亦复如是。以菩提心智慧利箭。射诸邪见烦恼密铠。彻过无碍。譬如摩诃那伽大力勇士。奋威怒时。阎浮提人无能坏者。菩萨摩诃萨。亦复如是。发大慈悲修菩提心。一切世间诸魔眷属及烦恼业。所不能坏。譬如有人学大技术。虽未究竟。诸余巧能所不能及。菩萨摩诃萨。亦复如是。学菩提心愿。虽未究竟。声闻缘觉诸余众生所不能及。譬如有人学善射术。先自安立。菩萨摩诃萨。亦复如是。学一切智地。先自安立菩提之心。必得一切佛法。譬如幻师。先读幻术。然后示现一切幻事。菩萨摩诃萨。亦复如是。发菩提心。然后显现一切诸佛菩萨正法。譬如幻术。非色现色。菩提心相亦复如是。显现法界功德庄严。譬如有人着阎浮檀金庄严之具。映蔽一切悉如聚墨。菩萨摩诃萨。亦复如是。以菩提心庄严之具。蔽诸众生声闻缘觉所有功德。譬如阿夜揵多铁。此铁少分。悉能毁坏一切余铁诸钩锁缚。菩提之心亦复如是。断诸邪见烦恼爱缚。譬如疾风随去无碍。菩提心风亦复如是。随所行处除诸烦恼。悉无障碍。不住声闻缘觉解脱。譬如有人善入大海而不没溺。摩伽罗鱼所不能害。菩萨摩诃萨。亦复如是。以菩提心入生死海。不为生死之所染污。亦不证实际。声闻缘觉摩伽罗鱼所不能害。譬如有人服食甘露。一切众患所不能害。菩萨摩诃萨。亦复如是。服菩提心甘露法药。不堕声闻缘觉之地。修习大悲满足愿行。譬如有人用翳身药以涂其目。自在游行无能见者。菩萨摩诃萨。亦复如是。得菩提心满足大愿。自在游行入魔境界。一切众魔所不能见。譬如有人依恃大王不畏余人。菩萨摩诃萨。亦复如是。依菩提心大力法王。除灭障盖不畏恶道。譬如有人居深水内不畏火焚。菩萨摩诃萨。亦复如是。居菩提心善根水内。声闻缘觉解脱之火。所不能烧。譬如有人依恃猛将不畏怨敌。菩萨摩诃萨。亦复如是。依菩提心不畏诸恶。譬如释天执持金刚。降伏一切诸。阿修罗。菩萨摩诃萨。亦复如是。执菩提心。摧灭诸魔及余外道。譬如有人服阿罗娑药。不瘦不老延寿无穷。菩萨摩诃萨。亦复如是。服菩提心阿罗娑药。于无量劫在生死中。修菩萨行无所染着。譬如阿罗娑药初用净水。菩提心药亦复如是。一切菩萨所修行中。最为先首。譬如有人诸根法中命根为首。菩萨摩诃萨。亦复如是。诸佛正法菩提之心。最为其首。譬如有人命根断故。不能利益父母亲族。菩萨摩诃萨。亦复如是。离菩提心。不能饶益一切众生。譬如大海无能坏者。菩提心海亦复如是。声闻缘觉不能沮坏。譬如日光。诸星宿光所不能蔽。菩提心日亦复如是。圆满大愿智慧日光。声闻缘觉无漏慧光所不能蔽。譬如太子初生。已为大臣之所尊重。菩萨摩诃萨。亦复如是。发菩提心。已为一切声闻缘觉所共尊重。修大悲故。譬如王子年虽幼少。一切大臣皆悉敬礼。菩萨摩诃萨。亦复如是。发菩提心。声闻缘觉皆悉敬礼。譬如王子虽未自在。已具成就国王仪相。菩萨摩诃萨。亦复如是。虽为烦恼业障所覆。以具成就菩提心相。譬如目翳。见真净宝谓为不净。菩提心宝亦复如是。无智不信起不净想。譬如咒药。若有众生见闻共住。一切众病皆悉除愈。菩提心药亦复如是。长养善根摄智慧药。满足大愿菩萨慧身。若有众生见闻共住。修正念者。皆悉除灭烦恼诸病。譬如恒娑相衣不受尘垢。菩提心衣亦复如是。不受一切生死尘垢。譬如有人常持甘露。专念不散。而能分别一切诸法。菩萨摩诃萨。亦复如是。持菩提心甘露正法。正念不散。而能教化一切众生。令具大愿成智慧身。譬如犁无有扼则不堪用。菩提之心亦复如是。离正直心。于如来法无有实义。譬如转轮王有妙天冠。名曰象藏。洗彼冠时。四种兵众游行虚空。菩提心冠亦复如是。净诸菩萨一切善根远离三有。如来智慧。无为境界虚空中行。譬如金刚从金性生。非余宝生。菩提心宝亦复如是。大悲救护众生性生。非余善生。譬如有树不从根生。而能长养枝叶华果。菩提心树亦复如是。无所依止。而能长养一切种智。通明大愿普覆世间。譬如金刚非一切器尽能发明。亦非诸器尽能容持。菩提心宝。亦复如是。小心悭结无智者器。不能发明。谄曲邪见众生器中。不能容持。譬如金刚能坏众宝。菩提之心亦复如是。决定了知一切诸法。譬如金刚能坏众山。菩提之心亦复如是。坏散一切诸邪见山。譬如金刚虽破不全。一切众宝犹不能及。菩提之心亦复如是。虽小懈怠。声闻缘觉诸功德宝所不能及。譬如破金刚犹能除灭诸贫困苦。菩提之心亦复如是。虽复小失威仪趣法。犹能除灭诸贫穷苦。譬如小金刚悉能破坏一切诸物。菩提之心亦复如是。缘小境界。能破一切无知痴惑。譬如金刚非常人所得。菩提之心亦复如是。非小心众生之所能得。譬如金刚无智术者所不能识。菩提之心亦复如是。无智众生所不能识譬如金刚无能消灭。菩提之心亦复如是。一切诸法不能消尽。譬如金刚器仗。一切众生。乃至摩诃那伽不能执持。除那罗延力。菩提之心亦复如是。声闻缘觉不能受持。除诸菩萨摩诃萨。譬如金刚器仗无不鉴彻。非余器仗之所能为。菩提之心亦复如是。观察三世教化众生。阿僧祇劫受无量苦。声闻缘觉所不能及。譬如金刚余不能持。除金刚地。菩提之心亦复如是出生菩萨行愿功德。声闻缘觉所不能持。除萨婆若正直心者。譬如金刚器中盛水。不可消尽。菩提之心亦复如是。安住胜妙回向善根。入生死趣。诸不善法不能消尽。譬如金刚能持大地不令坠没。菩提之心亦复如是。持诸菩萨一切愿行。不令坠落没于三界。譬如金刚于百千劫处于水中。而不烂坏亦无变异。菩提之心亦复如是。于无量劫处生死中。诸烦恼业不能断灭亦无损减。譬如金刚一切大火不能烧热。菩提之心亦复如是。一切生死贪恚痴火不能烧热。譬如金刚道场之座。能持菩萨降伏诸魔成等正觉。余不能持。菩提之心亦复如是。能持一切菩萨愿行诸波罗蜜。诸忍诸地回向受记。修菩提道供养诸佛闻法受行。一切诸心所不能持。善男子。菩提之心。成就如是无量功德。若有众生。发菩提心。则具如是无量功德。是故善男子。汝得善利。发阿耨多罗三藐三菩提心。修菩萨行。具足如是无量功德。善男子。汝先所问。云何菩萨学菩萨行修菩萨道者。汝今入是明净庄严藏大楼观者。则能了知。学菩萨行修菩萨道。具足成就无量功德

尔时善财童子。敬绕弥勒菩萨。合掌白言。唯愿大圣。开楼观门令我得入。尔时弥勒菩萨。即弹右指。门自然开。善财即入。入已还闭。尔时善财。观察楼观。广大无量犹如虚空。众宝为地。有阿僧祇窗牖。却敌栏楯七宝合成。阿僧祇幡幢盖庄严。阿僧祇宝璎珞垂带。阿僧祇大师子幢半月宝像诸宝缯彩。又阿僧祇天冠宝衣。而以庄严。阿僧祇宝网。罗覆其上。阿僧祇金铃。自然演出微妙音声。又雨无量宝华鬘云。诸妙香云。雨阿僧祇细末金屑。放阿僧祇胜妙光明。普照一切。有阿僧祇异类众鸟。出和雅音。雨阿僧祇优钵罗钵昙摩分陀利华。出阿僧祇摩尼宝光。普照一切。于楼观内。具有百千诸妙楼观。不相障碍。庄校严饰亦如上说。尔时善财。睹见楼观不可思议众妙庄严。心大欢喜踊跃无量。其心柔软离诸妄想。除灭一切愚痴闇障。正念思惟专求妙趣。以无碍身恭敬作礼。礼已。弥勒菩萨威神力故。诸楼观中自见其身。又见无量自在神力不思议事。或见弥勒随本种姓。寿命知识。长养善根。诸劫世界。一切佛所及诸眷属。因诸大愿。初发阿耨多罗三藐三菩提心。或见初得慈心三昧因以为名。或见弥勒行菩萨行。满足一切诸波罗蜜诸忍诸地。净佛世界见诸如来。闻法受持守护正法。为大法师得无生忍。知某方处某如来所劫数多少而得受记。或见弥勒为转轮王。十善化世。或为四天王。饶益一切众生。或为帝释。诃责五欲。或为夜摩天王。赞不放逸。或为兜率天王。赞叹一生菩萨功德。或为化乐天王。赞自在法。或为魔王。说无常法。或为他化自在天王。赞叹菩萨庄严化身。或为梵王。赞叹四无量心。或为阿修罗王。调伏眷属入大智海。了达诸法悉如幻化。或为阎罗王。放大光明普照地狱灭一切苦。或以肴膳饮食施诸饿鬼。或为畜生受种种身。而为说法除其痴闇。或为四天王眷属说法。乃至为诸梵天王眷属说法。或为诸龙眷属说法。乃至为人非人等眷属说法。或为声闻缘觉及诸菩萨大众说法。或为发心菩萨乃至十地菩萨说法。或见赞叹初发心菩萨乃至十地菩萨功德。或见满足一切波罗蜜。入于平等诸法忍门。广三昧门乐深法门。修禅三昧出生通明。充满一切行菩萨行。随顺世间成就大愿。或见与同行菩萨俱饶益众生。或见与一生菩萨诸佛现前授记者俱。或见弥勒于百千劫。经行诵念书写经卷无有懈息。或观法门思惟实义。或入诸禅四无量心。解脱三昧一切入等。或见出生菩萨通明。或见正受变化三昧。一一毛孔出化身云。所谓天身云。诸龙夜叉乃至摩睺罗伽身云。四天王身云。乃至梵王身云。转轮圣王王子大臣长者居士声闻缘觉如来身云。复见一一毛孔中。出一切众生等化身云。或出菩萨法门。所谓赞叹菩提心功德门。檀波罗蜜门。乃至愿波罗蜜门。四摄诸禅无量三昧。通明总持诸谛诸辩。止观解脱缘起。念处正勤神足根力觉道。声闻缘觉二乘所行。菩萨大乘诸地诸忍。菩萨愿行。现如是等一切法门。或于楼观见诸如来大众围绕。又知诸佛家族不同种姓不同。其身寿量劫刹。教授无量法门。正法住世。分别了知皆悉不同。尔时善财。诸楼观中见一楼观。高广严饰胜妙于前。包容三千大千世界。百亿阎浮提。百亿兜率天。菩萨命终降神。受胎出生。游行七步。观察十方大师子吼。帝释梵王恭敬奉侍。现童子身处宫殿中。出游园观。以萨婆若心出家苦行。现受乳糜。往诣道场降伏众魔。观菩提树转正法轮。升天宫殿。方土劫数眷属寿量。行菩萨行满足大愿。演说正法教化众生。现分舍利皆悉不同

大方广佛华严经卷第五十九大方广佛华严经卷第六十

        东晋天竺三藏佛驮跋陀罗译

    入法界品第三十四之十七

尔时善财。自见己身在诸佛所。见如是等诸奇特事。又闻楼观诸金铃中。出不思议微妙音声。所谓初发菩提心声。菩萨所行诸度愿声。恭敬供养不可思议诸佛音声。净佛刹声。佛法云声。诸庄严具。亦出如是微妙音声。又闻某菩萨在某世界。于某劫中某知识化。回向善根出生大愿。于某佛所。大众之中。发菩提心声。又闻菩萨修习诸行劫数多小。于某刹中成正觉声。如是名号寿量长短。满足大愿化众生声。于诸菩萨声闻缘觉大众之中。现般涅槃法住世声。又闻菩萨于某世界。悉能广行檀波罗蜜。净持禁戒。修习忍辱。发行精进。入诸禅定。习应智慧。为求法故。舍诸珍宝国城妻子头目手足。守护正法。为大法师施清净法。设大法会建大法幢。击法鼓吹法螺雨法雨。兴立塔庙种种庄严。安乐众生护佛法藏。又闻某佛在某世界。于某劫中成等正觉。眷属多小寿命长短。满足大愿教化众生。闻如是等不可思议微妙音声。身心柔软欢喜无量。即得无量陀罗尼门辩才门忍门精进门大愿门通明门智慧门解脱门波罗蜜门三昧门

尔时善财。于宝镜中见诸如来及其眷属。诸大菩萨声闻缘觉。净世界。不净世界。杂世界。或世界有佛。或世界无佛。或上中下世界。或有世界如因陀罗网。或有翻覆仰伏世界。又复睹见平正世界。悉分别知五道别异。又见无量阿僧祇诸大菩萨经行禅定观察诸法。发大悲心普覆众生。造种种论辩众义趣。或书经卷。或问或答。或见出生三种回向及诸大愿。悉皆睹见如是等事。又见诸宝柱中。普放无量青黄赤白净玻璃色。因尼罗宝阎浮檀金诸光明网。又见珠璎珞中。出八功德香水。琉璃宝中。出无量光明。又见优钵罗钵昙摩分陀利中。生诸妙华大如车轮。华中悉见男女大小。释梵四王诸龙夜叉乃至人非人等及诸象马。声闻菩萨一切众生种种形类。皆悉恭敬合掌礼佛。又宝树中。悉见种种妙色之身。所谓如来身。菩萨身。天龙八部等身。释梵天身。转轮王身。四部众身。各各执持众供养具。尊重赞叹恭敬礼拜。又见半月像中。放阿僧祇日月光明。又见弥勒于过去世修菩萨行。布施头目髓脑手足肢节。一切身分国城妻子种种诸物。随其所须尽给施之。又见弥勒赞叹诸佛恭敬供养。或为医王疗治众病。失正路者示以正道。或为大船师导至宝洲。或为马王荷负众生令离鬼难。或为论师造诸经论。或为转轮王十善化世。或见孝顺父母近善知识不违其教。或见声闻缘觉菩萨如来形色教化众生。或为法师赞叹佛法。禅思诵念兴诸福业。造立塔庙诸妙形像。以香华鬘恭敬供养。或教众生三归五戒八斋十善。出家学道闻法受持。正念思惟住菩提心。又见弥勒于无量劫行六波罗蜜化众生事。又见弥勒无量劫中诸善知识。尔时弥勒菩萨。告善财言。善来童子。汝见楼观诸大菩萨不可思议自在力不。唯然已见。譬如有人梦中睹见山林河池大海须弥诸天宫殿四天下中一切像类。见如是已欢喜无量。尔时善财亦复如是。以大菩萨威神力故。远离虚妄。见三界法皆悉如梦。菩萨智慧无碍法门。入诸菩萨庄严法门。究竟菩萨不可思议诸妙方便。显现菩萨神力自在。譬如有人当命终时见中阴相。所谓行恶业者。见于地狱畜生饿鬼。受诸楚毒。或见阎罗王持诸兵仗囚执将去。或见刀山或见剑树。或见利叶割截众生。或见镬汤鬻治众生。或闻种种悲苦音声。若修善者。当命终时。悉见一切诸天宫殿。或见天女种种庄严游戏快乐。见如是等诸妙胜事。而不自觉死此生彼。但见不可思议行业境界。善财童子亦复如是。于楼观内。见诸菩萨不可思议胜业境界。譬如有人为非人所持。见种种形类。若有问难悉能应答。善财童子亦复如是。以大菩萨威神力故。悉能分别正念思惟一切诸法。譬如有人入于龙宫。七日半月一岁百岁谓为须臾。善财童子亦复如是。入弥勒菩萨神力宫殿。于百千劫谓如须臾。譬如梵宫名庄严藏。于中悉见三千世界异类形像。善财童子亦复如是。于楼观中。悉见一切未曾有事。譬如比丘得一切入定。行立坐卧随彼境界悉现在前。善财童子亦复如是。于楼观中。随彼境界悉分别知。譬如人见乾闼婆城。无所障碍。善财童子亦复如是。于楼观中。见一切法无所障碍。譬如有人升天宫殿。见人住处无所障碍。譬如大海于中悉见三千世界一切品类。譬如幻师悉能显现一切形色。善财童子亦复如是。于楼观中。弥勒菩萨威神力故。悉见一切未曾有事。无所障碍。尔时弥勒菩萨摄威神力。即时弹指告善财言。善男子。汝从定起。从定起已。而告之曰。汝睹见此菩萨神力自在大愿功德依果。菩萨庄严修习奇特。诸深妙行出生死道。一切法门无量庄严。诸佛大愿不可思议。菩萨三昧如是等事。汝悉见不。善财答言。唯然已见。蒙善知识威神力故。尔时善财。白言大圣。此何法门。答言。入三世智正念思惟庄严藏法门。善男子。一生菩萨。得如是等不可说不可说法门。大圣。此诸奇特妙庄严法从何所来。答言。菩萨神力之所出生。而亦不在神力之中。不来不去无积聚处。譬如龙雨不从身心。但以发意欲雨则雨。然彼境界不可思议。善男子。此诸奇特妙庄严法亦复如是。无所从来。但以菩萨神力出生。善男子。譬如幻师现种种事。无来去处。但以幻力现种种事。此诸奇特妙庄严法亦复如是。无来无去。无住无著。不生不灭。但学菩萨智愿力故。现如是事。尔时善财。白言大圣。从何所来。答言。佛子。菩萨无来趣。无行住趣。无所著趣。不生不死趣。不往不至趣。不离不起趣。不舍不着趣。无业无报趣。无起无依趣不常不断趣。善男子。菩萨但为教化救护众生。从大慈悲来。灭众生苦故。从菩萨净戒道来。随其所乐自在生故。从菩萨大愿道来。本发意故。从菩萨神通道来。灭众生苦住佛所故。从菩萨无增损趣来。不失身心诸善业故。从菩萨慧方便来。随顺一切众生类故。从菩萨化身趣来。如电镜像故。善男子。汝所问我何所来者。我从生处摩离国来。彼有聚落。名曰楼观。有长者子。名瞿波罗。我为说法令立菩提。我本生处诸群生等。随所应化而为说法。亦为父母及诸亲属。随应说法安立大乘。而来至此。善财白言。大圣。何等为菩萨生处。答言。善男子。菩萨有十种生处。何等为十。所谓菩提心是菩萨生处。生菩萨家故。正直心是菩萨生处。生善知识家故。安住诸地是菩萨生处。生诸波罗蜜家故。出生大愿是菩萨生处。生菩萨行家故。大悲是菩萨生处。生四摄家故。真实观法是菩萨生处。生般若波罗蜜家故。摩诃衍是菩萨生处。生方便波罗蜜家故。教化众生是菩萨生处。生菩提家故。智慧方便是菩萨生处。生无生法忍家故。随顺诸法是菩萨生处。生三世诸佛家故。善男子。菩萨摩诃萨。以般若波罗蜜为母。大方便为父。檀波罗蜜为乳。尸波罗蜜为乳母。羼提波罗蜜为庄严具。毗梨耶波罗蜜为养育者。禅波罗蜜为洁净。善知识为师菩提分为朋友。一切善根为亲族。一切菩萨为兄弟。菩提心为家。如说修行为家地。菩萨所住为家处。菩萨忍法为豪尊。出生大愿为巨富。具菩萨行为顺家法。赞摩诃衍为绍家法。甘露灌顶一生菩萨为王太子。能净修治三世佛家。佛子。如是菩萨超凡夫地证离生法。生如来家住佛种姓不断三宝。守护一切菩萨种姓。净所生处离诸恶道。悉为一切天人释梵沙门婆罗门。恭敬供养以生佛家。满足一切大愿藏故。佛子。菩萨摩诃萨。生如是家。知一切法悉如电光。一切趣中受生无厌。了趣如化。虽现处中而无所著。达一切法悉无有我。心无忧悔。以大慈悲教化众生。而不疲倦。了达生死皆悉如梦。于一切劫行菩萨行。而不懈废。了知五阴皆悉如幻。不畏生死知诸法界。心无所著。了一切法如热时焰。于一切行不生倒惑。游戏幻法超魔境界。得净法身离烦恼业。于诸趣中而得自在。无颠倒惑。善男子。我净法身充满一切法界。现一切众生等色。一切众生等音声。一切众生等名号。一切众生等威仪。现一切众生等随顺世间。现一切众生等受生。现一切众生等童子身。一切众生等想。出生一切菩萨大愿。为变化身与众生等充满法界。若诸同行失道心者。还令发起菩提心故。我于此阎浮提南界摩离国内。拘提聚落婆罗门家种姓中生。为欲灭彼憍慢心故。化度父母及亲族故。于中受生。善男子。我于南方。随诸众生所应示现而化度之。于此命终生兜率天。为欲化度彼诸天故。显现胜妙智慧功德。消欲渴爱。令知诸行皆悉无常。天趣寿命盛必有衰。入摩诃衍一生菩萨。皆悉云集。为欲教化诸同行故。欲开释迦牟尼世尊所化莲华。现彼受生。善男子。我于彼中寿终下生成正觉时。汝及文殊师利俱得见我。善男子。汝今往诣文殊师利问。云何菩萨学菩萨行修菩萨道。具足成就普贤所行。彼当为汝分别演说。何以故。文殊师利。满足无量亿那由他菩萨愿行。常为无量亿那由他诸佛之母。又为无量亿那由他诸菩萨师。勇猛精进教化众生。名称普闻十方世界。常于一切诸佛众中为大法师。悉为诸佛之所赞叹。安住甚深智慧法门。分别了知一切法界。于无量劫修诸法门。究竟普贤菩萨所行。善男子。文殊师利是汝善知识。能令汝得生如来家。长养善根积功德聚。能示语汝诸善知识满足大愿。显现一切菩萨不可思议功德。是故善男子。汝应一心尊重恭敬往诣其所。何以故。汝先所见诸善知识。修菩萨行满足大愿得诸法门。皆由文殊师利威神力故。时善财童子。头面敬礼弥勒菩萨。绕无数匝辞退而行

尔时善财童子。如是经游百一十城。到普门城边。思惟而住。观察十方一心专求文殊师利。何当会遇面奉慈颜。作是念时。文殊师利遥伸右手。过百一十由旬。至普门城。摩善财顶。而作是言。善哉善哉。善男子。若离信根忧悔心没。功行不具退失精勤。于少功德便以为足。于一善根。心生住着。不善发起菩萨行愿不为善知识之所摄护。不为如来之所忆念。是等皆悉不能了知。如是法性如是理趣。如是所行如是所住。若周遍知若种种知。若尽原底若渐趣入。若解说若分别。若证知若获得。皆悉不能。是时文殊师利。为善财童子示教诲已。慰谕令其欢喜踊跃。令得成就阿僧祇法门。得无量大智光明。无量菩萨陀罗尼。无量大愿无量三昧。无量神通无量智慧。皆已成就。复令得入普贤所行道场之内。既置善财自所住已。文殊师利还摄不现。于是善财得见三千大千世界微尘等诸善知识。不违其教。增长萨婆若大慈悲藏。以净慧眼普观众生。安住菩萨寂静法门。分别了知诸法境界。入佛甚深大功德海。具解脱道长养精进。为萨婆若修正直心。入于三世甚深法海。随顺诸佛清净法轮。现入诸趣。于一切劫修菩萨行。满足大愿。明净慧光照一切智境。净菩萨根。以净慧光除愚痴翳。照一切法。了达法界一切佛刹及诸众生坏障碍山。住无碍法。具足成就诸地法藏。修习普贤菩萨所行。善财童子。得闻普贤菩萨名号行愿功德诸地。地具地法。地得地次第。地修地住。地境界地持。地共地正道。一心欲见普贤菩萨

尔时善财正念起如来金刚藏道场一切宝莲华藏师子座心。虚空界等心。一切无著心。净一切刹无障碍心。于一切法境界无障碍心。充满一切十方心。得萨婆若境界无量心。庄严道场心。深入分别法海心。教化成熟一切众生广大心。于一切劫行菩萨行。究竟如来十力心。尔时善财起是心时。自善根力。佛威神力。普贤菩萨诸善根力。即见十种瑞相。何等为十。所谓见一切净刹庄严菩提。见一切刹无诸恶道。见一切刹净如莲华。见一切刹一切众生身心柔软。见一切刹无量庄严。见一切刹一切众生三十二相庄严其身。见一切刹庄严云覆。见一切刹一切众生成就慈心。见一切刹庄严道场。见一切刹一切众生皆悉修习念佛三昧。是为十。又见十种光相。见一切世界微尘。一一微尘中。放一切如来光明网云。与一切世界微尘等。一一微尘中。放一切佛种种色光。与一切世界微尘等。普照法界。一一微尘中。放一切宝云光明。与一切世界微尘等。普照法界。一一微尘中。放如来光焰轮云。普照法界。一一微尘中。出一切香云。普熏法界。赞叹普贤菩萨诸行一切大愿诸功德海。一一微尘中。放一切日月光云。放普贤菩萨光明。普照法界。一一微尘中。出一切众生等身云。相好庄严。放佛光明普照法界。一一微尘中。出一切菩萨身云。究竟一切行。充满法界。一一微尘中。出一切宝形像云。充满十方一切世界。一一微尘中。出一切如来身云。与一切世界微尘等。普雨一切甘露正法。充满法界。是为十。尔时善财。见十种瑞相已。即作是念。我今必见普贤菩萨。增长善根。究竟菩萨妙行。见一切佛。若见普贤菩萨。得一切智想。一心恭敬。欲见普贤菩萨。尔时善财。即见普贤菩萨在金刚藏道场。于如来前处莲华藏师子之座大众围绕。心如虚空无所染着。除灭障碍净一切刹。以无碍法充满十方。住一切智。入诸法界教化众生。于一切劫行菩萨行。恭敬供养一切诸佛心无退转。于众生中最胜最上。一切世间无能坏者。一切菩萨不能察其智慧境界。具不思议诸妙功德。普观三世等诸如来。尔时善财。见普贤菩萨。一一毛孔放一切世界微尘等光明。普照一切虚空法界等世界。除灭一切众生苦患。悉能长养菩萨善根。一一毛孔出种种香云。普熏十方一切如来及诸眷属。一一毛孔出一切世界微尘等华云。一一毛孔。出一切世界微尘等诸香树云。出众妙香庄严法界。一一毛孔。出一切世界微尘等妙宝衣云。庄严虚空。一一毛孔。出一切世界微尘等种种宝树。充满虚空以为庄严。雨种种宝供佛大众。一一毛孔。出一切世界微尘等色界天身。充满一切法界一切众生界。赞叹菩提。一一毛孔。出一切梵王身云劝请如来转妙法轮。一一毛孔。出一切欲天身云。皆悉护持诸佛法轮。一一毛孔念念中。出一切世界微尘等三世诸佛。充满虚空。无依众生为作归依。一一毛孔念念中。出一切世界微尘等清净佛刹。诸佛菩萨充满其中。教化成熟无量众生。一一毛孔念念中出一切世界微尘等净不净佛刹。充满虚空。令染污者皆悉清净。一一毛孔念念中。出一切世界微尘等不净净刹。调伏不净众生。一一毛孔念念中。出一切世界微尘等一切众生身云随顺世间教化众生。一一毛孔念念中。出一切世界微尘等菩萨身云。赞叹诸佛。长养一切众生善根。一一毛孔念念中。出一切世界微尘等初发心菩萨身云。于一切刹示现初发菩提之心。一一毛孔念念中。出一切世界微尘等菩萨身云。于一一刹。赞一切佛功德愿海普贤菩萨所行妙行。一一毛孔念念中。出一切世界微尘等普贤所行。雨甘露法。令一切众生修萨婆若。一一毛孔念念中。出一切世界微尘等佛。初成正觉出兴于世。尔时善财。见如是等不可思议自在神力。见已欢喜踊跃无量。重观普贤一一身分。一一肢节。一一毛孔中。悉见三千大千世界。风轮水轮火轮地轮。大海宝山须弥山王金刚围山。一切舍宅诸妙宫殿众生等类。一切地狱饿鬼畜生阎罗王处。诸天梵王乃至人非人等。欲界色界及无色界。一切劫数。诸佛菩萨教化众生。如是等事皆悉显现。十方一切世界。亦复如是。如此娑婆世界卢舍那如来应供等正觉所现自在力。东方莲华妙德世界贤首佛所显现。神力亦复如是。如贤首佛所。如是东方一切世界一切佛所显现。神力亦复如是。如东方。南西北方四维上下。一切世界一切佛所显现。神力亦复如是。于一切世界一切微尘。一一微尘中。现自在力亦复如是。尔时善财。见普贤菩萨不可思议自在神力。即得十不可坏智慧法门。何等为十。所谓于念念中能以一身遍一切刹。于念念中诣一切佛所。于念念中恭敬供养一切诸佛。于念念中一切佛所闻持正法。得一切佛法轮智波罗蜜门。得不思议佛自在智波罗蜜门。得无尽辩智慧法门。得般若波罗蜜观诸法门。得一切法界海大方便波罗蜜门。得知一切众生欲性智慧波罗蜜门。得普贤所行智慧波罗蜜门。尔时普贤菩萨。即伸右手。摩善财顶。摩已善财复得一切世界微尘等诸三昧门。一一三昧门。各有一切世界微尘等三昧。以为眷属。一一三昧中。见一切世界微尘等诸如来海。长养一切世界微尘等诸功德。具生萨婆若。满大愿海。安住正道。究竟一切诸菩萨行。发萨婆若勇猛精进。为一切佛光明所照。如此娑婆世界卢舍那佛所。普贤菩萨摩善财顶。令得具足一切世界微尘等三昧门诸妙功德。普贤菩萨。在于十方一切世界诸如来所摩善财顶。所得功德亦复如是。尔时普贤菩萨。告善财言。善男子。汝今见我自在神力奇特事不。答言。唯然已见。此不思议莫能测者。唯除如来。善男子。我于过去不可说不可说世界海微尘等劫。修菩萨行专求菩提。一一劫中。见不可说不可说世界海微尘等佛。修菩提心。一一劫中。于一切世界。设不可说不可说广大施会。给施一切。或施妻子城邑聚落头目髓脑肢节血肉一切身分。不惜寿命。一向专求一切种智。于一一劫。恭敬供养不可说不可说世界海微尘等佛。于彼佛所。出家学道受持正法。未曾生于贪恚痴心。我我所心。乐着生死虚妄之心。轻慢他心。诸障碍心。修不可坏佛菩提心。未曾忘失。善男子。我所修行菩萨诸行。净佛世界。教化众生。长养大悲。供养诸佛及善知识。护持正法。悉舍一切内外诸物。修习世间出世间智。令一切众生背生死苦赞叹一切诸佛功德。如是等事。于不可说不可说劫中演说。劫犹可尽此诸功德不可穷尽。善男子。我得如是功德具力。诸善根力。乐胜法力。修功德力。观察诸法寂灭性力。净慧眼力。佛威神力。诸大愿力。大慈悲力。净通明力。善知识力。得是力故。逮得本性清净法身。三世不坏。又得无上清净色身。超出一切世间。随应化者莫不睹见。游一切刹无处不至。现自在力见者无厌。善男子。汝且观我清净法身。无量劫海行菩萨行之所成就。无量劫中难闻难见。种少善根声闻菩萨犹尚不得闻我名字。况见我身。善男子。若有众生。闻我名者。于阿耨多罗三藐三菩提不复退转。若见若触。若迎送若随行。若见光明若见震动诸佛世界。乃至梦中见闻我者。亦复如是。若思惟念我。若一日一夜。若七日七夜。若半月若一月。若一岁若百岁。若一劫若百劫。乃至不可说不可说世界微尘等劫。若一生念我。若百生。乃至不可说不可说世界微尘等生念我。亦复如是。以如是等世界微尘等诸妙方便。令一切众生发阿耨多罗三藐三菩提心住不退转。善男子。若有众生。闻我修习净佛刹者。必得往生清净世界。若有众生见闻我身。必得生我清净身中。善男子。汝复观我清净法身。尔时善财。于普贤菩萨相好肢节诸毛孔中。见不可说不可说世界海。诸佛充满。一一如来。以不可说不可说大菩萨众。以为眷属。见彼一一如来刹海。所依不同。形色各异。金刚围山。大云弥覆。佛兴世间。所转法轮。如是等事皆悉不同。又见普贤菩萨。于十方刹出一切世界微尘等如来化身。教化众生。令发阿耨多罗三藐三菩提心。尔时善财童子。经由亲近一佛世界微尘等诸善知识。所得功德。于见普贤菩萨所得功德。百分不及一。百千万分乃至算数譬谕所不能及。何以故。善财童子。于念念中入不可说不可说佛世界海。得不可说不可说微尘等诸功德藏。知诸佛海次第兴世。菩萨众海眷属围绕。了众生根。现自在力而化度之。或一世界于一劫中修菩萨行。乃至不可说不可说世界微尘等劫修菩萨行。不此世界没。不彼世界生。而能教化无量无边世界众生。令发阿耨多罗三藐三菩提心。尔时善财童子。能自究竟普贤所行诸大愿海。不久当与一切佛等。一身充满一切世界刹等。身等。行等。正觉等。自在力等。转法轮等。诸辩才等。妙音声等。方便等。无畏力等。佛所住等。大慈悲等。不思议法门自在力等。尔时普贤菩萨。欲重明此义。以偈颂曰

  汝等离烦恼　　清净心谛听
  说佛一切行　　真实波罗蜜
  超出诸世间　　无上调御士
  远离烦恼垢　　清净如虚空
  圆满智慧日　　除灭烦恼闇
  普照一切法　　安乐诸群生
  如来无量劫　　时乃出兴世
  譬如优昙华　　难见难值遇
  普为诸群萌　　苦行无量劫
  随顺诸世间　　其心无染着
  时诸菩萨众　　既闻普贤教
  敬心听如来　　自在真实义
  普贤真佛子　　究竟一切行
  常为佛所叹　　言必不虚妄
  普贤功德华　　不染三界法
  劝发大众听　　无尽智慧海
  诸佛微妙智　　清净如虚空
  明了一切行　　其心无所著
  一念悉了达　　三世一切法
  善知众生根　　随其所应化
  众生心烦恼　　诸业善不善
  所乐皆悉知　　而为说正法
  或见如来坐　　充满十方界
  众生罪所障　　虽近而不见
  或见初发心　　远离诸放逸
  无量无数劫　　修习菩萨行
  或闻诸最胜　　妙音演说法
  罪垢众生等　　不闻佛名号
  或见大菩萨　　充满三千界
  究竟普贤行　　如来为说法
  或见卢舍那　　无量无数劫
  严净此世界　　得成最正觉
  或见贤首佛　　普贤大菩萨
  斯等悉充满　　莲华妙德刹
  或见阿弥陀　　观世音菩萨
  灌顶授记者　　充满诸法界
  或见阿閦佛　　香象大菩萨
  斯等悉充满　　妙乐严净刹
  或见月慧佛　　金幢大菩萨
  斯等悉充满　　明净镜妙刹
  或见日藏佛　　智灌大菩萨
  斯等悉充满　　清净光明刹
  或见十方界　　诸佛放光明
  为众转法轮　　除灭愚痴暗
  或见一毛孔　　不可说佛刹
  诸佛庄严身　　佛子众围绕
  为转正法轮　　度脱诸群生
  或于一毛孔　　普见诸佛子
  无数亿劫中　　修习菩萨行
  或于一一尘　　悉见无量刹
  或净或垢秽　　诸行业所起
  或见卢舍那　　于彼转法轮
  显现自在力　　方便入涅槃
  观察众生类　　一切业烦恼
  显现自在力　　化之令解脱
  如是诸法王　　十方世界中
  显现自在力　　我今说少分
  或见释迦文　　初成等正觉
  饶益诸群生　　一切莫能测
  或见为菩萨　　供养一切佛
  或住童子地　　显现自在力
  或见行施戒　　忍辱勤精进
  深入诸禅定　　住慧方便地
  或见究竟住　　一切种智地
  三昧陀罗尼　　出生诸通明
  或见无量劫　　修习菩萨行
  逮得不退转　　甘露灌顶记
  或见为梵身　　帝释四天王
  刹利婆罗门　　示现此等身
  或见从兜率　　命终降神生
  或见住宫殿　　舍欲而出家
  或见坐道场　　降魔成正觉
  转净妙法轮　　涅槃后起塔
  或见无量寿　　最胜天人尊
  为授灌顶记　　成无上导师
  或见十力尊　　教化已周讫
  般涅槃已来　　无量无数劫
  或见论师月　　现处梵王宫
  亦现大自在　　魔王宫殿中
  或见兜率宫　　诸天众围绕
  为彼说正法　　悉令大欢喜
  或见处夜摩　　帝释四天王
  诸龙夜叉王　　八部宫殿中
  锭光如来所　　供养得授记
  如是等方便　　教化诸群生
  光明身寿命　　净慧及眷属
  教化威仪声　　皆悉不可数
  见佛同众生　　或身如须弥
  或现跏趺坐　　充满于世界
  或见光一寻　　或百千由旬
  或现照法界　　或照一切刹
  或现寿百岁　　百千万亿岁
  无量那由他　　不可思议劫
  无碍清净慧　　一念知三世
  悉从因缘起　　而实无自性
  一刹成正觉　　普现诸世界
  能现一世界　　而作无量刹
  示现无量刹　　而为一世界
  安住无上道　　具足无畏力
  无碍智慧转　　十二行法轮
  知苦习尽道　　十二支缘起
  四辩无碍智　　演说一切法
  无我无我所　　亦无有自性
  无生亦无灭　　无来亦无去
  皆悉如虚空　　而不坏诸业
  如来为众生　　方便分别说
  转此法轮时　　震动一切刹
  大海金刚山　　无有恐怖者
  如来一音说　　各随所应解
  灭诸烦恼垢　　令住萨婆若
  如来一音说　　或闻施戒忍
  精进禅智慧　　慈悲及喜舍
  四念四正勤　　如意诸根力
  觉道止观念　　神通诸法门
  如来一音说　　八部人非人
  梵释四天王　　随类音声解
  若多贪恚痴　　憍慢悭嫉结
  八万四千垢　　各闻对治法
  未修净业者　　闻说十善道
  已修施戒者　　闻说般涅槃
  染着于生死　　懈怠诸群生
  闻说解脱门　　除灭生死苦
  少欲知足者　　乐处于闲静
  如是等众生　　闻说二乘音
  或修广大心　　具诸功德藏
  亲近诸佛者　　闻说大乘声
  或有一世界　　闻说一乘音
  或二三四五　　乃至无量乘
  智慧行有异　　解脱无差别
  犹如虚空性　　无有若干相
  如来微妙音　　其性亦如是
  随所应化者　　所闻各不同
  佛以过去行　　得一微妙音
  无心于彼此　　而能应一切
  佛口放妙光　　八万四千数
  普照诸世界　　除灭众烦恼
  具足智功德　　三种顺众生
  离世如虚空　　常现于世间
  虽复随世现　　生老病死苦
  或复现住寿　　其性如虚空
  如来分别知　　一切众生类
  诸根及性欲　　令住萨婆若
  诸佛尊导师　　示入于大众
  随其所应化　　善现威仪法
  为诸声闻现　　出家威仪法
  常乐修寂灭　　无余涅槃证
  婆罗门众中　　示现羸老身
  萦发而苦行　　语论无穷尽
  服气或断食　　五热以炙身
  如是现苦行　　降伏诸异学
  或持异道戒　　善算多方术
  星历地动相　　种种众生相
  深入诸禅定　　三昧及解脱
  种种现嬉戏　　令得萨婆若
  示现乐衣服　　种种庄严身
  勇健善兵法　　降伏刹利故
  现知治正法　　时节诸义利
  软语摄众生　　降伏大臣故
  或诣四天王　　八部鬼神所
  方便为说法　　皆令大欢喜
  或现为帝释　　安住善法堂
  诸天众围绕　　为彼演说法
  夜摩或兜率　　化乐化自在
  梵王至净居　　为彼演说法
  如是现无数　　种种威仪法
  无量方便力　　度脱诸群生
  譬如工幻师　　能现种种事
  佛为化众生　　示现种种身
  如月游虚空　　睹者谓增损
  影现诸河池　　映蔽荧火光
  如来净智月　　示现有增损
  处于直心水　　映蔽二乘光
  譬如深大海　　珍宝不可尽
  于中悉显现　　众生形类像
  甚深因缘海　　功德宝无尽
  清净法身中　　无像而不现
  譬如明净月　　照除世间闇
  如来净智日　　悉除三世闇
  如龙兴庆云　　普雨于一切
  身心不降雨　　除热得清凉
  如来亦如是　　兴起大悲云
  普雨甘露法　　灭除三毒火
  此法亦不从　　如来身心出
  如来净法身　　三界无伦匹
  超出诸世间　　非有亦非无
  其实无所依　　不去而遍至
  譬如梦所见　　亦如空中画
  非色非无色　　非相非无相
  非有亦非无　　其性如虚空
  如海摩尼宝　　能出种种宝
  众生诸光明　　而光无所有
  导师亦如是　　虽有而非有
  不于一处中　　积集功德宝
  大仙现虚空　　如自性实际
  涅槃离欲灭　　皆悉是一性
  众生心微尘　　海水渧可数
  虚空亦可量　　佛德说无尽
  闻此法欢喜　　信心无疑者
  速成无上道　　与诸如来等　大方广佛华严经卷第六十

华严经梵本凡十万偈。昔道人支法领。从于阗国得此三万六千偈。以晋义熙十四年岁次鹑火三月十日。于扬州司空谢石所立道场寺。请天竺禅师佛度跋陀罗。手执梵文译梵为晋沙门释法业亲从笔受。时吴郡内史孟顗右卫将军褚叔度为檀越。至元熙二年六月十日出讫


大方广佛华严经入法界品

    No. 295 [Part of No. 278(34), 279(39), 293]

大方广佛华严经入法界品

        唐天竺三藏地婆诃罗译

尔时。摩耶夫人。复告善财童子言。善男子。于此世界三十三天。有王名正念。王有童女。名天主光。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。敬受其教。头面作礼。绕无数匝。恋慕瞻仰。却行而退。遂往天宫。见彼童女。礼足围绕。合掌前住。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。天女答言。善男子。我得菩萨解脱。名无碍念清净庄严。善男子。我念过去。有最胜劫。名青莲华。我于彼劫中。供养恒河沙等诸佛如来。彼诸如来。从初出家。我皆瞻奉。守护供养。造僧伽蓝。营办什物。又彼诸佛。从为菩萨住母胎时。诞生之时。行七步时。大师子吼时。住童子位。在宫中时。向菩提树。成正觉时。转正法轮。现佛神变。教化调伏众生之时。如是一切诸所作事。从初发心。乃至法尽。我皆明忆无有遗余。常现在前念持不忘。又忆念过去。劫名善地。我于彼供养十恒河沙等诸佛如来。又过去劫。名为妙德。我于彼供养一佛世界微尘等诸佛如来。又劫名无所得。我于彼供养八十四亿百千那由他诸佛如来。又劫名善光。我于彼供养阎浮提微尘等诸佛如来。又劫名无量光。我于彼供养二十恒河沙等诸佛如来。又劫名精进德。我于彼供养一恒河沙等诸佛如来。又劫名善悲。我于彼供养八十恒河沙等诸佛如来。又劫名胜游。我于彼供养六十恒河沙等诸佛如来。又劫名妙月。我于彼供养七十恒河沙等诸佛如来。善男子。如是忆念恒河沙劫。我常不舍诸佛如来应正等觉。从彼一切诸如来所。闻此无碍念清净庄严菩萨解脱。受持修行恒不间断。随顺趣入。如是先劫所有如来。从初菩萨。乃至法尽。一切神变。我以净严解脱之力皆随忆念明了现前。持而顺行曾无懈废。善男子。我唯知此无碍念清净解脱。如诸菩萨摩诃萨。出生死夜。朗然明彻。永离痴冥。未尝惛寐。心无诸盖。身行轻安。于诸法性。清净觉了。成就十力开悟群生。而我云何能知能说彼功德行。善男子。迦毗罗城。有童子师名曰遍友。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。以闻法故。身心喜悦。不思议善根。流派增广。头面敬礼天主光足。绕无数匝。恋仰辞去。从天宫下。渐向彼城。至遍友所。礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。遍友答言。善男子。此有童子名善知众艺。学菩萨字智。汝可问之。当为汝说

尔时善财即至其所。头顶礼敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨。云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。时彼童子。告善财言。善男子。我得菩萨解脱。名善知众艺。我恒唱持。入此解脱根本之字。唱阿字时。入般若波罗蜜门。名菩萨威德各别境界。唱罗字时。入般若波罗蜜门。名平等一味最上无边。唱波字时。入般若波罗蜜门。名法界无异相。唱者字时。入般若波罗蜜门。名普轮断差别。唱多字时。入般若波罗蜜门。名得无依无上。唱逻字时。入般若波罗蜜门。名离依止无垢。唱荼(徒假反)字时。入般若波罗蜜门。名不退转之行。唱婆字时。入般若波罗蜜门。名金刚场。唱荼字时。入般若波罗蜜门。名曰普轮。唱沙字时。入般若波罗蜜门。名为海藏。唱他字时。入般若波罗蜜门。名普生安住。唱那字时入般若波罗蜜门。名圆满光。唱耶字时入般若波罗蜜门。名差别积聚。唱史吒字时。入般若波罗蜜门。名普光明息诸烦恼。唱迦字时。入般若波罗蜜门。名差别一味。唱婆字时。入般若波罗蜜门。名霈然法雨。唱摩字时。入般若波罗蜜门。名大流湍激众峰齐峙。唱伽字时。入般若波罗蜜门。名普上安立。唱娑他字时。入般若波罗蜜门。名真如藏遍平等。唱社字时。入般若波罗蜜门。名入世间海清净。唱室者字时。入般若波罗蜜门。名一切诸佛正念庄严。唱陀字时。入般若波罗蜜门。名观察圆满法聚。唱奢字时。入般若波罗蜜门。名一切诸佛教授轮光。唱佉字时。入般若波罗蜜门。名净修因地现前智藏。唱叉字时。入般若波罗蜜门。名息诸业海藏蕴。唱娑多字时。入般若波罗蜜门。名蠲诸惑障开净光明。唱壤字时。入般若波罗蜜门。名作世间了悟因。唱颇字时。入般若波罗蜜门。名智慧轮断生死。唱婆字时。入般若波罗蜜门。名一切宫殿具足庄严。唱车字时。入般若波罗蜜门。名修行戒藏各别圆满。唱娑摩字时。入般若波罗蜜门。名随十方现见诸佛。唱诃婆字时。入般若波罗蜜门。名观察一切无缘众生方便摄受令生海藏。唱诃字时。入般若波罗蜜门。名修行趣入一切功德海。唱伽字时。入般若波罗蜜门。名持一切法云坚固海藏。唱吒字时。入般若波罗蜜门。名十方诸佛随愿现前。唱拏字时。入般若波罗蜜门。名不动字轮聚集诸亿字。唱娑颇字时。入般若波罗蜜门。名化众生究竟处。唱娑迦字时。入般若波罗蜜门。名诸地满足无著无碍解光明轮遍照。唱阇字时。入般若波罗蜜门。名宣说一切佛法境界。唱多娑字时。入般若波罗蜜门。名一切虚空法雷遍吼。唱侘(耻加反)字时。入般若波罗蜜门。名晓诸迷识无我明灯。唱陀字时。入般若波罗蜜门。名一切法轮出生之藏。善男子。我唱如是入诸解脱根本字时。此四十二般若波罗蜜门为首。入无量无数般若波罗蜜门。善男子。我唯知此善知众艺菩萨解脱。如诸菩萨摩诃萨。能于一切世出世间善巧之法。以智通达到于彼岸。殊方异艺咸综无遗。文字算数蕴其深解。医药咒术善疗众病。有诸众生。鬼魅所持。怨憎咒诅。恶星变怪。死尸奔逐。颠痫羸瘦。种种诸疾。咸能救之。使得痊愈。又善别知金玉珠贝。珊瑚琉璃。摩尼车磲鸡萨罗等。一切宝藏出生之处。品类不同。价直多少。村营乡邑。大小都城。宫殿苑园。岩泉薮泽。凡是一切人众所居。菩萨咸能随方摄护。又善观察天文地理。人相吉凶。鸟兽音声。云霞气候。年榖丰俭。国土安危。如是世间所有技艺。莫不该练尽其源本。又能分别出世之法。正名辩义。观察体相。随顺修行。智入其中。无疑无碍。无愚暗无顽钝。无忧恼无沉没。无不现证。而我云何能知能说彼功德行。善男子。此摩竭提国有一聚落。彼中有城名婆咀那。有优婆夷号曰贤胜。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼众艺之足。绕无数匝。恋仰辞去。向聚落城。至贤胜所礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。贤胜答言。善男子。我得菩萨法门。名无依处道场。既自开解。复为人说。又得无尽三昧。非彼三昧。法有尽无尽。以能出生一切智性眼无尽故。又能出生一切智性耳无尽故。又能出生一切智性鼻无尽故。又能出生一切智性舌无尽故。又能出生一切智性身无尽故。又能出生一切智性意无尽故。又能出生一切智性种种慧明无尽。故又能出生一切智性周遍神通无尽故。又能出生一切智性如海波涛无量功德皆无尽故。又能出生一切智性遍世间光无尽故。善男子。我唯知此无依处道场法门。如诸菩萨摩诃萨一切无著功德行。而我云何尽能知说。善男子。南方有城名为[泛-之+(犮-乂+又)]田。彼有长者名坚固解脱。汝可往问。云何菩萨学菩萨行。修菩萨道。尔时善财。礼贤胜足。绕无数匝。恋慕瞻仰。辞退南行。到于彼城。诣长者所。礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无著清净念。我自得是解脱已来。法愿充满。于十方佛所。无复悕求。善男子。我唯知此净念解脱。如诸菩萨摩诃萨。获无所畏大师子吼安住高广福慧之聚。而我云何能知能说彼功德行。善男子。即此城中。有一长者名为妙月。其长者宅常有光明。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。礼坚固足。绕无数匝。辞退而行。向妙月所。礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。妙月答言。善男子。我得菩萨解脱。名净智光明。善男子。我唯知此智光解脱。如诸菩萨摩诃萨证得无量解脱法门。而我云何能知能说彼功德行。善男子。于此南方。有城名出生。彼有长者名无胜军。汝诣彼问。云何菩萨学菩萨行。修菩萨道。是时善财。礼妙月足。绕无数匝。恋仰辞去。渐向彼城。至长者所。礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无尽相。我以证此菩萨解脱。见无量佛。得无尽藏。善男子。我唯知此无尽相解脱。如诸菩萨摩诃萨。得无限智无碍辩才。而我云何能知能说彼功德行。善男子。于此城南。有一聚落。名之为法。彼聚落中有婆罗门。名尸毗最胜。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。礼无胜军足。绕无数匝。恋仰辞去。渐次南行。诣彼聚落。见尸毗最胜。礼足围绕。合掌恭敬。于一面立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。我闻圣者。善能诱诲。愿为我说。婆罗门答言。善男子。我得菩萨法门。名诚愿语。过去现在未来菩萨。以是语故。乃至于阿耨多罗三藐三菩提。无有退转。无已退无现退无当退。善男子。我以住于诚愿语故。随意所作莫不成满。善男子。我唯知此诚语法门。如诸菩萨摩诃萨。与诚愿语行止无违。言必以诚未曾虚妄。无量功德因之出生。而我云何。能知能说。善男子。于此南方有城。名妙意花门。彼有童子名曰德生。复有童女名为有德。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。于法尊重。礼婆罗门足。绕无数匝。恋仰而去。渐次南行。至于彼城。见童子童女。顶礼其足。围绕毕已。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。唯愿慈哀。为我宣说。时童子童女告善财言。善男子。我等证得菩萨解脱。名为幻住。以斯净智。观诸世间皆幻住。因缘生故。一切众生皆幻住。业烦恼所起故。一切法皆幻住。无明有爱等展转缘生故。一切三界皆幻住。颠倒智所生故。一切众生生灭生老死忧悲苦恼皆幻住。虚妄分别所生故。一切国土皆幻住。想倒心倒见倒无明所现故。一切声闻辟支佛。皆幻住。智断分别所成故。一切菩萨皆幻住。能自调伏教化众生殊胜智心及诸行愿之所成故。一切菩萨众会变化调伏诸所施为皆幻住。愿及智所摄成故。善男子。幻境自性不可思议。善男子。我等二人。但能知此菩萨解脱。如诸菩萨摩诃萨。善入无边诸事幻网。彼功德行。我等云何能知能说。时童子童女。说自解脱已。诸善根力不思议故。令善财身。柔软光泽大方广佛华严经入法界品一卷


大方广普贤所说经一卷

    No. 298

    大方广普贤所说经一卷

        唐于阗三藏实叉难陀译

如是我闻。一时佛在如来神力所持之处。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。前后围绕。而为说法。皆已成就普贤之行。普贤菩萨摩诃萨。而为上首。时众会中。有十菩萨摩诃萨。各与十不可说不可说百千亿那由他佛刹微尘等菩萨眷属。从十方处。忽然出现。皆坐无碍庄严师子之座。其名曰普光藏菩萨。甚深藏菩萨。威德光明藏菩萨。云音藏菩萨。金刚藏菩萨。普音不动威光藏菩萨。普名称威光藏菩萨。山王不动威光藏菩萨。普现众像威光藏菩萨。十力清净威光藏菩萨。彼诸菩萨。出现之时。于此会中。唯除普贤。其余一切菩萨大众。靡不倾动。所有威光亦尽不现。一一菩萨。皆雨十不可说不可说百千亿那由他香云涂香云。鬘云衣云。宝盖幢幡云。清净世界云。众宝楼阁云。菩萨众会道场云。大光明网普照云。菩提道场庄严云。如来形像袈裟云。各兴如是不可思议诸供养云。充满法界。供养如来。斯诸菩萨所坐之座。众宝庄严。微妙清净。于彼一一庄严事中。普现一切无量世界无量众生无量诸佛无量菩萨。又现不可说不可说过去未来无量世界。及彼诸佛。现坐道场。为化众生。转妙法轮。诸菩萨众。供养如来。净修一切波罗蜜行。常无断绝。尔时众会。咸作是念。此诸菩萨。从何世界诸佛所来。即共请问普贤菩萨。时普贤菩萨。普告一切菩萨众言。诸佛子。汝等各自推其来处。时无碍眼菩萨。则入普迅疾三昧。遍至三昧。明照法界三昧。具一切神通三昧。了一切境界三昧。现一切众生身神通三昧。知一切佛刹三昧。入如是等十阿僧祇百千亿那由他菩萨三昧。以三昧力。自见其身。悉诣十方一切世界乃至一切微尘处中。而不能见彼诸菩萨所从来土。及于如来修梵行处。其余一切菩萨大众。各各别入菩萨三昧。皆不能见。亦复如是。咸从定起。白普贤菩萨言。我等各入十阿僧祇百千亿那由他菩萨三昧。了不能见彼诸菩萨所从来处。普贤菩萨。复告之言。彼所从来诸佛国土。甚深广大极难可见。汝等今可更共推求。时诸菩萨一一复入十佛刹微尘等菩萨三昧。求亦不见。各以其事。重白普贤。尔时普贤菩萨。从座而起。上升虚空。右绕世尊。无数匝已。即于空中。普观众会。作如是言。诸佛子。汝观佛身。无碍庄严。三世平等。法界诸刹。无不普入。十方所有一切世界。一切如来。一切菩萨。一切众生。一切诸趣。靡不影现如来身中。随诸众生心之所乐。悉令开悟。汝等应住普境界眼。尽虚空界清净慧眼。了一切境广大智眼。又应普请十方一切诸佛护念。皆应一心离一切处。一切依止。一切执着。一切诸有。观如来身。应入十力微细境界。于一境界。了达一切无尽境界。观如来身。时诸菩萨。敬顺其教。咸向如来。头面作礼。一心瞻仰。忽见世尊毗卢遮那。双足轮中有世界。名法界轮。其土有佛。名法界庄严王。住世说法。彼普光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于双[跳-兆+尃]中有世界名无碍藏。其土有佛名无碍净光。住世说法。彼甚深藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于双膝中有世界名真金藏。其土有佛名金藏王。住世说法。彼威德光明藏菩萨摩诃萨。与十不可说不可说百千亿那由他。佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于双股中有世界名一切宝庄严藏。其土有佛名众妙光。住世说法。彼云音藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于其脐中有世界名毗卢遮那藏。其土有佛名毗卢遮那威德庄严王。住世说法。彼金刚藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于其心中有世界名胜光藏。其土有佛名妙相庄严藏。住世说法。彼普音不动威光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于两肩中有世界名金色。其土有佛名金色王。住世说法。彼普名称威光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于其口中有世界名妙宝庄严。其土有佛名无量光严王。住世说法。彼山王不动威光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于其眉间有世界名法界无尽藏。其土有佛名三世无尽智。住世说法。彼普现众像威光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。于其头中有世界名覆持不散。其土有佛名宝花积。住世说法。彼十力清净威光藏菩萨摩诃萨。与十不可说不可说百千亿那由他佛刹微尘等菩萨摩诃萨俱。从彼佛刹。来此会坐。时诸菩萨。既见如是无尽世界如来道场菩萨众会佛神变已。一一皆得法界藏三昧。等十佛刹微尘数诸大三昧一切法地陀罗尼。等十佛刹微尘数诸陀罗尼离垢藏般若波罗蜜。等十佛刹微尘数诸波罗蜜力电光。等十佛刹微尘数一切智电光。时普贤菩萨。复告大众。诸佛子。此法唯是行普贤行。为善知识。所摄受者。乃得闻见。是故汝等。于此法门。作金刚心。增上意乐。说持读诵。勿令忘失。说此法时。彼诸菩萨摩诃萨等。欢喜信受大方广普贤所说经


大方广如来不思议境界经一卷

    No. 301 [No. 300]

    大方广如来不思议境界经一卷

        大唐于阗三藏实叉难陀奉　制译

如是我闻。一时佛在摩竭提国菩提树下。成正等觉。其菩提树。名阿摄波。磐根深固。擢本修直。周圆无节。如栴檀柱。常于其上。飞禽回翼。无能过者。皮肤细润。众色间发。犹如罗绮。密叶青翠。繁枝布濩。周匝皆有妙花开敷。吐曜飞芳。甚可爱乐。除俱鞞罗。波利质多。余无比者。复有无量小树围绕。而此树王。森蔚颖秀。如妙高山。俯冠群岳。一由旬外。靡不齐睹。香气周流。荣光照曜。远夜望之。疑大火聚。其下严丽。如欢喜园。四面夷敞。芳草[卄/(仁-二+(公/几))]茂。如孔雀王颈藿靡芬馥。观者无厌。如来于此。端严而坐。大众环绕。如星中月。时有十佛刹微尘等他方诸佛。为欲庄严毗卢遮那道场众故。示菩萨形来在会坐。其名曰观自在菩萨。文殊师利菩萨。地藏菩萨。虚空藏菩萨。金刚藏菩萨。维摩诘菩萨。善威光菩萨。灭诸盖菩萨。宝手菩萨。大慧菩萨。普贤菩萨。如是等菩萨摩诃萨。而为上首。复有无量千亿菩萨。现声闻形。亦来会坐。其名曰舍利弗。大目揵连。须菩提。罗睺罗。阿若憍陈如。摩诃迦叶。优波离。阿那律。离婆多。阿难。提婆达多跋难陀等而为上首。皆已久修六波罗蜜。近佛菩提。为化众生。于杂染土。现声闻形。复有无量千比丘尼。摩诃波阇波提。而为上首。皆已成就大丈夫业。为欲调伏下劣众生故现女身。复有无量释梵护世。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。此中皆是大菩萨众。无凡夫者

尔时世尊。坐菩提树。严净微妙。譬于质多树下置如意珠。正念不动如须弥山。为令诸菩萨众及一切众生。了知诸佛深密禅定威神力故。入于三昧。名如来不思议境界。即时世尊。三十二相。一一相中。皆现十方无量佛刹及彼诸佛。犹如明镜显现众色。又随好中。一一复现如来往修菩萨行时。从光明王。乃至最后。然灯佛所。难行苦行。悉舍一切头目身体。皮肉手足。妻子仆从。及国王位。宫殿等事。由是三昧。有大势力。一切诸佛。食时行时。说法时。涅槃时。常入此定。何以故。一切如来。依此三昧。成就无量大威神力。乃至证入一切法空。能于十方一切佛刹。示现种种自在事故。譬如有人。梦见种种变异事等。及其觉已。所见皆无。凡夫亦尔。无明梦故。妄于诸法生实体想。诸佛觉已。皆无所著故能十方一切世界。一念示现无量佛事自在无碍。利益成就一切众生。皆令悟入无量深妙解脱门故。尔时德藏菩萨。修菩提行。未成满故。问普贤菩萨摩诃萨言。如来今者。所入三昧。其名云何。复云何得。十方一切世界自在示现种种佛事度脱众生。尔时。普贤菩萨。告德藏菩萨言。谛听谛听。当为汝说。时诸菩萨。一心瞻仰。同声叹言。善哉所问。甚深微妙。尊者普贤一切知见。今当演说。即时大地六种震动。天雨妙花。一切众生烦恼众苦。皆少休息。普贤菩萨言。佛子。此三昧名如来不思议境界。即是一切诸佛菩提。以诸如来常依住故。世尊始从然灯佛所。得受记已。即入此定。常无功用。自然应现无量佛事。谓于虚空一毛端处。有一切佛刹微尘等诸佛世界。于中或现生兜率天。或从彼没下生入胎。或现适生游行七步。自言我今即为生死边际。或现在宫出家苦行。或现降魔成等正觉转妙法轮。或现住世经无量劫度诸众生皆令离苦。或复示现入于涅槃。或一切劫为一刹那。或一刹那为一切劫。劫与刹那无增无减。乃至一切众生未尽解脱。刹那刹那一时普于此诸世界。常作如是种种佛事。未曾休息而无功用。如彼虚空一毛端处。无量刹中。念念普现诸佛种种威仪法则。而无功用。乃至遍空毛端量处。亦复如是。又是诸刹一切微尘。一一尘中。复有过一切佛刹微尘等土。亦一刹那一一土中。自然普现一切诸佛威仪所行。或生天宫。乃至灭度。解脱无量阿僧祇众生。如是念念穷未来际。常作佛事。利益众生。乃至虚空众生界尽。常不休息。而佛刹不减。微尘不增。何以故。以一切法犹如幻焰不坚牢故。譬如此会十佛世界微尘数等大菩萨众。皆共住此摩竭提国十二由旬。不相障碍。彼一一尘各受无数诸佛世界。或仰或覆。或相向背。或复傍住。或相涉入。而无障碍。亦复如是。如人梦中见于一处。有种种事。以非实故。而无所碍。是一切刹。靡不唯其心之所现。或见劫烧。或已烧尽。或风所成。或净或秽。或复无佛。皆由众生随自心业。见如是等种种不同。譬如饿鬼饥渴所逼。诣恒河所。或有见水。或有见灰脓血便痢。不净充满。众生亦尔。各各随业。见其佛土或净或秽。或佛在世。或入涅槃。或处道场。为众说法。或有闻说第一义谛。或复闻说赞叹施法。或见行住。或见坐食。或见身长世人一倍乃至七倍或一由旬。或百由旬。或千由旬。或见威光如日初出或如满月。或由业障值佛世尊久已灭度。或有不闻诸佛名字。如彼饿鬼。于恒河中。都不见水。但见种种杂秽之物。或见诸佛。各从本土。示现威德大菩萨形。来入此会或一刹中。众生唯见劫火所烧。或一刹中。众生充满咸共见佛。或见如来摄一切刹入一佛刹。以一佛刹入一切刹。如众翳者。同于一处。见各差别。互不相碍。皆由眼翳。不见正色众生亦尔。色性无碍。心缘异故。蔽于正见。不了真实。佛子。今更为汝。略说住此三昧之法。如佛世尊住此三昧于一念中。遍虚空界毛端量处无量佛土及彼佛土。一一尘中。各有法界微尘等刹。为欲利益诸众生故。刹那刹那。遍一一刹。现十佛刹微尘等诸佛方便威仪所行。如是乃至一切众生。未尽证得无上菩提。常无断绝。如此一佛第二第三。乃至十方一切诸佛。一一所现大威德力。亦复如是。时德藏菩萨。闻是说已。即于座上。得此三昧。即时见彼无量诸佛及知诸佛威德方便。以三昧力。亦能如是。调伏众生。百恒河沙诸菩萨众。各别证得种种三昧忍及诸地。观自在等诸大菩萨。住十地者功德妙行。悉圆满故。皆已久远得此三昧。一刹那中摄无量劫。一微尘中纳无量土。于一念中遍一切刹。度无量众生。常无功用。自然示现诸佛事故。虽闻此法。更无所进。如满瓶水置于雨中不容一渧。斯诸菩萨。亦复如是。尔时世尊。在三昧中。放眉间光名大显发。所有一切有功用行。未证十地诸菩萨等。遇斯光已。悉见空中诸毛端处及微尘中无量佛刹。如琉璃瓶盛白芥子。观者悉见彼诸菩萨。见微尘中一切佛刹。亦复如是。及见彼刹一切诸佛。于一一佛身见一切佛身。一一诸佛有无量名。皆为利益一一众生。念念常于一一佛刹。自然应现。成阿耨多罗三藐三菩提。譬于高幢。置如意珠。自然普雨种种珍宝。随众生意。悉令满足。如来亦尔。现正等觉。自然度脱无量众生。是诸刹中。众生各异。而不相碍。如神力者。游行虚空。山河石壁。无所挂碍。何以故。一切诸趣。皆如幻焰。无坚实故。诸菩萨众。既睹是已。各见其身。遍一切刹。于一念中一一佛前。或经一劫二劫三劫。或百千劫。或一念顷。或一须臾。恭敬供养。或闻佛说诸波罗蜜陀罗尼门。或说诸地。或现神变。以一切劫入一念中。生甚奇特难遭之想。作是念言。云何世尊。威德自在。于一刹那。令我具足无量劫中善根福德。速证如来不思议境界三昧大威神力

尔时德藏菩萨。为欲利益诸众生故。复问普贤菩萨言。其有欲证此三昧者。修何福德施戒智慧。时普贤菩萨。遍于十方一切净刹。现成正觉。化众生者。告德藏菩萨言。佛子。若欲证得此三昧者。先应修福集诸善根。谓常供养佛法僧众。及以父母。所有一切贫穷苦恼无救无归可悲愍者。摄取不舍。乃至身肉。无所吝惜。何以故。供养佛者。得大福德。速成阿耨多罗三藐三菩提。令诸众生。皆获安乐。供养法者。增长智慧。证法自在。能正了知诸法实性。供养僧者。增长无量福智资粮。致成佛道。供养父母和上尊师及世间中曾致饶益赖其恩者。应念倍增报恩供养。何以故。以知恩者。虽在生死。不坏善根。不知恩者。善根断灭。作诸恶业。故诸如来。称赞知恩。毁背恩者。又常愍济诸苦众生。菩萨由此广大善根。永不退失。若人有能勤修福德。常念报恩。悲愍众生则为菩提。已在其手。应知佛说。能随供养。此三种田。一一成就无量善根。德藏当知。菩萨次应植广大种。由是故生此三昧牙。成菩提果。云何植种。谓持种种微妙花鬘。涂香末香。及众伎乐。恭敬供养现在诸佛。或佛形像。作是思惟。如上所说。遍于虚空毛端量处及微尘内无量刹中。一一所见。诸佛威力。及菩萨众。我悉于彼诸佛会中。一心正念。普皆供养。如所供养一佛法性。即是一切诸佛法性。若我供养一如来者。即为供养一切如来。随彼一一诸佛神力。能以几劫入于一念。亦尔所劫供养如来。若有众生。信解此法。种植大种。即能得是如来不思议境界广大三昧。故善男子。应以此法。日日供养。由是下至于诸佛所。但一敬礼。亦能令此种子增长三昧牙生。又应常以布施持戒大愿智慧。而溉灌之。又复菩萨为灌三昧。修行施时。不简福田怨亲善恶。持戒破戒。富贵贫穷。又复思惟。施于富者。虽无所用。然我自应修习施行。菩萨又应清净持戒。见毁禁者。起大悲愍。不应于彼生嫌恚心。又应深发大菩提愿。我当决定。念念普于遍满虚空毛端量处。乃至一切佛刹尘中。无量世界。成等正觉。转妙法轮度诸众生。如今世尊毗卢遮那。等无有异。不起功用。摄无量劫入于一念。即于如是一一刹中。各现佛刹微尘等诸佛威仪。一一威仪。各度恒河沙等众生。皆令离苦。乃至虚空众生界尽。常无休息。佛子。修智慧者。一心谛听。今为汝说。若善男子善女人。为求无上菩提。发心欲证此三昧者。是人要须先修智慧。以此三昧由慧得故。修智慧者。应当远离妄语绮语及诸散乱无益之事。于诸众生。虽起大悲而常摄心。不染不散。诣精舍中。睹佛形像。金色庄严。或纯金成。身相具足。无量化佛。入于三昧。在圆光中。次第而坐。即于像前。头面礼足。作是思惟。我闻十方无量诸佛。今现在世。所谓一切义成佛。阿弥陀佛。宝幢佛。阿閦佛。毗卢遮那佛。宝月佛。宝光佛等。于彼诸佛。随心所乐。尊重之处。生大净信。想佛形像。作彼如来真实之身。恭敬尊重。如现前见。上下谛观。一心不乱。往空闲处。端坐思惟。如佛现前。一手量许。心常系念。不令忘失。若暂忘失。复应往观。如是观时。生极尊重恭敬之心。如佛真身现在其前。了了明见。不复于彼作形像解。见已即应于彼佛所。以妙花鬘。末香涂香。恭敬右绕。种种供养。彼应如是一心系念。常如世尊现其前住。然佛世尊。一切见者。一切闻者。一切知者。悉知我心。如是审复想见成已。还诣空处。系念在前。不令忘失。一心勤修。满三七日。若福德者。即见如来现在其前。其有先世造恶业障。不得见者。若能一心精勤不退。更无异相。还得速见。何以故。若有为求无上菩提。于一事中。专心修习。无不成办。若于所修。数数怯退。彼尚不能自得解脱。何况度脱诸苦众生。若遇如是。疾得菩提正真之道。不能勤修。当知徒是地之重担。譬如有人。于大海中。饮一掬水。即为已饮阎浮提中一切河水。菩萨如是。若能修习此菩提海。则为已修一切三昧诸忍诸地诸陀罗尼。是故常应勤修匪懈。离于放逸。系念一心。要令自得现前见佛。如是修习初见佛时。作是思惟。为真佛耶。为形像耶。若知所见是真佛者。便于佛前。两膝着地。合掌恭敬。忆念虚空毛端量处及微尘中一切诸佛无量威德。大慈悲故。来现我前。即应启请唯愿世尊。为我演说如来不思议境界大三昧法。若闻如来一切所说。应决定信。勿生疑惑。即于是处。得此三昧。若先业障。不能问者。则应思惟。一切诸法。如幻如焰。如翳如影。如像如梦。如是谛观。法性空寂。然知如来了一切法。皆如幻梦。如来自性。非幻非梦。犹如虚空能以智悲。出现我前。愿为我放大悲青光。灭除众苦。时佛即为放眉间光。名曰青焰。其光才照。诸苦销除。即坐证得法光明忍。悉能了达无量三昧。第七日夜。梦见如来为授阿耨多罗三藐三菩提记。若知所见。是形像者。应思诸佛及诸众生皆亦如像。但随想见无实体性。既知如来如幻如化。如梦如焰。如是自然现前见佛。亦如梦中。无实可得。非生而生。非灭而灭。非去而去。非识而识。非有为而现诸行。非言说而演诸法。非我非寿。非众生非养育。非趣生。非想非作。非知非食。非即蕴非在蕴而示诸蕴。乃至界处。亦复如是。一切非有亦复非无。是故诸佛及一切法。真实平等。皆同一相。如阳焰等。一切众生。诸佛及土。皆唯自心。识想所现。识想为缘。所生诸色。毕竟非有。如来已离一切识想。是故不应以色像见。知所见像。随想生故。乃至虚空毛端量处。一切真佛。皆亦如是。犹如虚空平等无异。若我分别。即见于佛。若离分别。即无所见。自心作佛。离心无佛。乃至三世一切诸佛。亦复如是。皆无所有。唯依自心。菩萨。若能了知诸佛及一切法皆唯心量。得随顺忍。或入初地。舍身速生妙喜世界。或生极乐净佛土中。常见如来。亲承供养

尔时德藏菩萨。复白普贤菩萨言。若有众生闻此法门。受持读诵。解说书写。得几所福。普贤菩萨言。佛子谛听。若有人。能摄三界中一切众生。令脱生死。得阿罗汉。一一罗汉。各于百劫以天上妙衣服卧具。饮食汤药。种种供养。般涅槃后。一一复为起七宝塔。恭敬供养。若复有人。一百劫中。净持禁戒。或修忍辱精进禅定。是人虽复得无量福。不如有人。闻此法门。尊重信受。不生毁谤。其福胜彼。速成正觉。是时十方一切刹土无量诸佛。皆自现身。赞普贤菩萨言。善哉善哉。佛子。如汝所说。时释迦牟尼如来。从其面门。放无量色光。遍照三有。雨种种花。诸妙音乐。不鼓自鸣。大地微动。于光中。而说偈言

  若闻此法心清净　　得诸地定陀罗尼
  戒忍自在神通力　　速证无上佛菩提
  转未曾有妙法轮　　亦如过去大仙等
  于一念中摄多劫　　一尘普现无量刹
  无量众生没三界　　诸苦所恼常逼切
  邪见缠缚失正道　　念念皆令得解脱

普贤菩萨。于此法门。久已证故。为众说时。亿千天人。度一切苦。皆于阿耨多罗三藐三菩提。得不退转。德藏菩萨。及余一切菩萨众会。世间天龙阿修罗等。皆大欢喜。信受奉行大方广如来不思议境界经


大方广入如来智德不思议经一卷

    No. 304 [Nos. 302, 303]

    大方广入如来智德不思议经一卷

        大唐于阗三藏实叉难陀译

如是我闻。一时佛在摩竭提国寂灭道场普光明殿。无量功德之所集起。见者靡不生大喜乐。永离一切轻毁之心。佛于其中。坐宝莲华师子之座。证净等觉。所行无二。住佛所住。悉与一切诸佛平等。到无障碍不退转法。一切所行。无能制伏。常作佛事。未曾休息。体法无相。住不思议。三世所生。了无差别。其身充遍一切世界。智达诸法。尝无迷惑。觉一切行。断诸疑网。其身微妙。不可分别。到无二智究竟彼岸。为诸菩萨之所宗仰。住无差别如来解脱。入无中边佛平等地。通达一切处空法界。穷未来劫。常转法轮。与大比丘众六十二亿人俱。皆悉了达诸法实相。自性平等。犹如虚空。无所依着。永离一切烦恼盖缠。一切如来。智慧方便。皆能随入。于一法中了一切法。无分别智常现在前。常勤修习趣种智道。心无退转。皆已成就。到彼岸智。随一切境。所行方便。无不具足。其名曰舍利弗。大目揵连。摩诃迦旃延。摩诃迦叶。那提迦叶。伽耶迦叶。摩诃劫宾那。离婆多。阿[少/兔]楼驮。须菩提。富楼那弥多罗尼子。憍梵波提。周利槃陀。财力士子。佉陀罗。商主准陀。摩诃俱絺罗。难陀。罗睺罗。阿难。如是等诸大弟子。而为上首。复与六十亿比丘尼俱。皆已久集清净白法。近佛种智。了达方便。证一切法无性无相安住实际。解一切法无生无灭。无所除断。住不思议解脱三昧。随诸众生应可调伏。示现种种威仪色相。而于其中。无所分别。其名曰摩诃波阇波提。及耶输陀罗。而为上首。复与十佛刹不可说百千亿那由他微尘等菩萨摩诃萨俱。皆是一生补处。从余方界。来集于此。尽能普入十方世界。得涅槃道善方便智。安住菩萨观察成就一切众生方便法门。摄诸众生。令断一切戏论执取。了达诸法无边无中。知诸众生善恶业果皆不可得亦不失坏。又能究其意乐烦恼诸根所行。具持三世如来所说诸法句义。无有忘失。通达一切有为无为世出世法。成就三世诸佛智轮。于念念中。现天宫没。受生出家。修行苦行诣菩提树降魔成佛。转正法轮。般涅槃相。常不厌舍一切众生。觉悟令发大菩提心。能于一众生心所缘境。入一切众生心所缘境。成就自然智。而受菩萨身。一切智行。未曾退转虽常修习。而无所作。能无量劫。为一众生。住世说法。护持法藏。绍诸佛种。于无佛处现佛出世。如众生数。示成正觉。得加趺坐。充遍十方。圆满大智。严净一切杂秽国土。灭除一切菩萨业障。虚空法界。一切功德。皆悉具足。证法实际。无所障碍。得一切法平等智印。印知诸法。自性平等。所见所闻。如影如响。住不思议解脱三昧自在游戏首楞严定。成就出生诸佛相好陀罗尼门。具三世佛清净行愿。成就普贤殊胜意乐。诸佛出世。咸诣其所。恭敬劝请。于一毛道中现一切世界。于一毛道中现于十方。始从下生。乃至最后般涅槃相。以十方一切诸佛众会。现一佛众会。以一佛众会。现十方一切诸佛众会。现十方界入自身中。于自身中现一切众生身。随为演说无量法要。现一切佛身入一佛身。以一佛身入一切佛身。于一众生身现无量众生身。于一切众生身现一众生身。于一生身现三世生身。三世生身现一生身。现过去世入未来世。以未来世入过去世。以过去世入现在世。以现在世入过去世。于一身中入深禅定。于无量无数身起。无量无数身入深禅定于一身起。于一佛身现一切众生身。一切众生身现一佛身。于众生身现净法身。于净法身现众生身。以一佛刹及庄严事。现一切净刹。以一切佛刹及庄严事现一净刹。以十方界入一毛孔。为诸众生。显示一切诸佛愿力。普于十方随可化度。为现无上正等菩提。于无数劫。一一世界。行菩萨行。而无休息。于一微尘。容纳无边不可称量算数世界。令诸众生无有迫窄。促无量不思议劫为一须臾。演一须臾为无量不思议劫。一刹那中。普于十方一切世界。随诸众生。卵生胎生。湿生化生。有形无形。有色无色。无足二足。四足多足。天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。释梵护世。人非人等。应可调伏。为现种种威仪所行。而其身心。无分别用。斯诸菩萨。皆得如是善巧方便及余无量阿僧祇功德。其名曰普贤菩萨。普眼菩萨。普化菩萨。普慧菩萨。普目菩萨。普光菩萨。普明菩萨。普照菩萨。普幢菩萨。普觉菩萨。大速疾菩萨。大速疾持菩萨。大神变菩萨。大神变王菩萨。大精进菩萨。大勇健菩萨。大奋迅菩萨。大奋迅力菩萨。大众生菩萨。大香象菩萨。大月菩萨。妙月菩萨。功德月菩萨。宝月菩萨。普月菩萨。法无垢月菩萨。毗卢遮那月菩萨。名称月菩萨。光明月菩萨。满月菩萨。梵音菩萨。梵主雷音菩萨。地音菩萨。法界音菩萨。破一切魔音菩萨。震法鼓音菩萨。普觉音菩萨。无分别音菩萨。地上音菩萨。蔽一切声音菩萨。平等藏菩萨。离垢藏菩萨。功德藏菩萨。光明藏菩萨。宝藏菩萨。月藏菩萨。日藏菩萨。日生藏菩萨。莲花藏菩萨。慧藏菩萨。大慧菩萨。胜慧菩萨。名称慧菩萨。无上慧菩萨。增长慧菩萨。无量慧菩萨。广慧菩萨。佛慧菩萨。无尽慧菩萨。海慧菩萨。弥楼灯菩萨。大灯菩萨。法灯菩萨。照十方灯菩萨。普灯菩萨。破一切暗灯菩萨。照一切处灯菩萨。决定照灯菩萨。月灯菩萨。日灯菩萨。文殊师利菩萨。观世音菩萨。大势至菩萨。金刚藏菩萨。功德藏菩萨。离恶趣菩萨。药王菩萨。药上菩萨。雷音菩萨。花首菩萨。日光菩萨。离垢勇猛菩萨金刚慧菩萨。灭诸盖菩萨。降魔菩萨。宝髻菩萨。千光菩萨。降伏大魔菩萨。难见菩萨。难伏菩萨。难量菩萨。胜智菩萨。灭恶趣菩萨。弥勒菩萨。如是等菩萨摩诃萨。而为上首。复有无量不可思议不可称量天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗摩睺罗伽。释梵护世。皆从十方佛刹来集。时此世界。复有百亿六欲诸天魔王太子商主为首。与无量诸天眷属俱诣佛所。为见如来礼拜供养听受法故。复有百亿大梵天王。乃至百亿色究竟天。魔醯首罗。而为上首。亦与无量诸天眷属。俱诣佛所。为见如来礼拜供养听受法故。复有百亿八部王众及无量人非人。优婆塞优婆夷等。各与眷属。俱诣佛所。为见如来礼拜供养听受法故。复有一切草木丛林诸药神等。及弥楼山。摩诃弥楼山。目真邻陀山。摩诃目真邻陀山。雪山铁围山等。一切山神。河海陂池。国邑聚落。所有诸神。并八部众。诸宫殿神。亦与眷属。俱诣佛所。为见如来礼拜供养听受法故。复有百亿日月诸天。及阿那婆达多龙王。各与无量眷属围绕。俱诣佛所。为见如来礼拜供养听受法故。是诸大众。以佛神力。不相障碍。无有迫隘。尔时世尊。光明显照。蔽于众会。犹如白月十五日满。净除云翳。光明显照。映蔽众星。亦如须弥山王。安住不动。如来光明。普蔽一切释梵诸天。高显特尊。亦复如是

尔时。文殊师利童子。告灭诸盖菩萨言。如来今者。安住于此。身不动摇。汝知之乎。彼即答言。文殊师利。如来今者。虽在此会安住不动。有诸天人。或见出家修行苦行。或见往诣菩提树下安处道场。降伏魔怨。成等正觉。诸天龙王。夜叉乾闼婆。阿修罗迦楼罗。紧那罗摩睺罗伽。释梵护世。咸共赞言。善哉大师。能胜怨敌。或见释梵护世诸天劝请说法。或见为其说布施法。或见为说持戒忍辱精进禅定智慧方便力愿智法。或见为说声闻乘法。或见为说独觉乘法。或见为说无上乘法。或见为说畜生饿鬼阎摩罗界。四天王天。三十三天。乃至梵宫。受生等法。或见为说生人趣法。或见为说生转轮王法。又文殊师利。于此众中。或见如来身高一寻。或一俱卢。或二俱卢。或半由旬。或一由旬。或二由旬。或十由旬。或百或千。或万由旬。或见五万。十万百万。或五百万。乃至或见超过一切数量由旬。或见佛身作真金色。或琉璃色。或帝青摩尼色。或大青摩尼色。或光明摩尼色。或红莲花摩尼色。或释迦毗楞伽摩尼色。或金刚光明摩尼色。或天光摩尼色。或日月光摩尼色。或水精摩尼色。或颇梨摩尼色。或自在王摩尼色。或集众光摩尼色。或师子鬘摩尼色。或师子幢摩尼色。或海住净光摩尼色。或如意摩尼色。随诸众生应见如来是众色相而调伏者。所见各殊。随闻如来。为说何法。而成就者。所闻各异。随依何教。而修行者。各如说行。皆得成就。文殊师利。设于十方无量不可思议不可称量世界满中天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。释梵护世。人非人等。犹如竹林甘蔗胡麻。若诸众生。应见如来而调伏者。见佛色相。各各不同。面向其前。一寻而住。为其说法。如说修行。皆得成就。如来虽作如是众事。自然应现。而无分别。文殊师利。如满月轮夜半之时。阎浮提中。一切众生。各见月轮。在其前现。是月未曾作念分别。令诸众生。各睹我现。法尔而有如是事起。如来亦尔。虽复普现诸众生前。亦不分别令诸众生皆得见我现前而住。但随众生可调伏者。各自见佛现在其前。何以故。随应众生不共法故。文殊师利。如一切众生由上中下业果力故。所作诸行。亦有三品。而是诸行。终不自生三种分别。但由业故。自然有是上中下品诸行事起。如来亦尔。由诸众生业果力故。各自见佛如来亦无上中下念。自然应现如是等事。文殊师利。如净颇梨。置诸衣上。作种种色。若在黄衣便作黄色。在青赤衣作青赤色。随其所置。虽作彼色。是净颇梨。终无分别。如来亦尔。由众生感。作种种色。若诸众生。应见金色而调伏者。便见金色。若有应见琉璃真珠。帝青大青。集众光摩尼。海住净光摩尼。师子鬘摩尼。师子幢摩尼。电灯摩尼。水精摩尼。是诸宝色而调伏者。便见如来作如是等众宝色相。或有应以释梵护世而调伏者。便见释梵护世色相。如是乃至应以地狱饿鬼畜生。阎罗王处。色无色界。卵生胎生。湿生化生。有色无色。有想无想。非有想非无想。随何趣生。威仪色相而调伏者。则见如来作如是等种种色相。然佛未曾分别念言。令此众生。惟见金色莫见琉璃。惟见琉璃莫见帝青。如是乃至惟见师子鬘摩尼。莫见师子幢摩尼色。虽无如是异念分别。随一切处。自然有是诸色相现。文殊师利。譬如出生自在摩尼王处。不生诸铁。是摩尼王。终不念言。令彼宝处。但生于我。莫生于铁。然其宝处。铁自不生。如来所生刹土亦尔。自无一切外道异论诸恶贼乱五无间罪十不善业非法王教。亦无一切日月诸天及摩尼宝火电等光及以须臾日月岁数。除佛变现化诸众生。虽有所现而无分别。由众生故自然有是种种事起。文殊师利。譬如大青摩尼宝光触者皆作大青宝色。而宝终无异念分别。如来亦尔。触佛作意所缘光者。靡不皆成一切智色。然佛亦无异念分别。自然而有如是事起。文殊师利。如善磨莹大琉璃宝。随于其边。安置种种手足头颈众庄严具。以宝威力。彼庄严具。莫不明显。如来亦尔。随其所行威仪住处有修行者。以佛威力。令其所行。皆自增胜。然佛未曾动念分别。自然而有如是事起。文殊师利。如众卉木依地而住各得增长。然地了无种种分别。如来亦尔。令诸众生一切善根。依如来住。各得增长。而实曾无异念分别。自然而有如是事起。文殊师利。譬如大云普覆一切草木丛林。等澍甘雨。随一味水所及之处。令诸草木皆得增长。种种色味差别不同。彼云未曾有所分别。自然有是种种相异。如来亦尔。兴正觉云。遍覆一切。随诸众生先所积集种种善根。种种愿乐。种种信解。种种解脱。等澍法雨。令诸众生一切善根。随其势力。各得增长。如来亦不分别念言。我当令是众生善根。生声闻智。我当令是众生善根。生独觉智。我当令是众生善根。生如来智。我当令是众生善根。生四天王天。三十三天。如是乃至净居等天。我当令是众生善根。得作国王。及与人中种种生处。然佛虽无种种分别。随诸众生所集善根愿乐等力。自然有是种种事起。由佛已舍一切处着。无分别故。文殊师利。如日才现放无量亿百千光明。破阎浮提一切黑暗。是日虽复不分别言。我当破暗。自然而有破暗事生。如来日轮。亦复如是。出世间已。放无量亿智慧光明。灭除世间诸见黑暗。除佛威力。示现成熟诸众生者。如来虽不分别念言。令众生见。现破当破。于一切处。自然有此种种事起。由佛已舍一切处着。无分别故。文殊师利。譬如幻师幻作众像。虽有种种形类不同。幻无分别。不可称说。无起无尽。无字无声。无有方所。无体无相。不可思议。无二无行。无等无对。但由幻师。现是众相。如来亦尔。由众生故。入于种种威仪行处。一切皆见。然实如来。可不称说。无起无尽。无字无声。无有方所。无性无相。无二无行。等真法界。非可触对。文殊师利。譬如日映须弥山故。四洲众生。或见初出。或见日中。或见渐暮。或见初没。或见夜半。或见渐曙。但一日轮。随四天下诸众生见。各各不同。日无分别。但由山蔽。自然四洲所见各异。如来亦尔。于一众会。或见如来将成正觉。已成正觉。将入涅槃。已入涅槃。或见成佛已经十年。乃至已经不可说劫。或见涅槃已经十年。乃至已经百千亿劫。或见如来一十二十。或四十年。在世说法。或见法住或见法灭。然佛曾无异念分别。由众生故。自然有是种种事起。文殊师利譬如大风吹阎浮提一切草木枝叶纷乱。东西南北。或靡或起。草木终无种种分别但由风故。种种相生。如来亦尔。常无分别。由众生力。于念念中。见有如是无量众行威仪相起。乃至作意。缘诸众生。令尔所劫。得断地狱畜生饿鬼阎罗等趣。文殊师利。如来成就如是无量微妙功德。文殊师利。如来作意。一念所缘。诸大菩萨。无量百千那由他劫。住不思议解脱三昧。不能知其功德边际。文殊师利。譬如日轮从大海出。住虚空中。放无量亿那由他光。遍照一切城邑聚落。破大黑暗。销涸洿池。增长一切草木丛林。悉令成熟。发起一切所作事业。光影普入诸河池中。而常未曾离于本事。是日虽无种种分别。自然而有是等事现。如来亦尔。出诸有海。住法虚空。放无量亿智慧光明。遍照十方一切世界。灭诸众生无明翳膜。枯竭一切烦恼浊流。令诸众生善根福慧增长成熟。虽同一时。现是众事。亦常湛然。本处不动。由佛已离念想分别。自然应现是诸相故

文殊师利。若有善男子善女人。于恒河沙劫。以天上味及天妙衣。施十方界微尘等一切诸佛及声闻众。彼佛灭后。为一一佛。遍满十方一一世界。造十方界微尘等塔。其塔皆是阎浮檀金。电光摩尼。互相间错。集众光宝。周围栏楯。宝幢遐建。宝铃流响。蛇卫栴檀。以为涂香。覆以自在摩尼王网。其上复有天宝盖云。宝幡幢云。妙花香云。摩尼王云。如意珠云。徘徊散空。满三千界。日日三时。如是供养。经恒沙劫。兼复教化无数众生。如是供养。不如有人闻此入如来智德不思议境界法门。心生信解。其福过彼。无量阿僧祇。文殊师利。若有菩萨。信解此法。则速成满菩萨摩诃萨无量亿那由他诸波罗蜜。证入无量亿那由他地。背舍无量亿那由他生死。了知无量亿那由他诸佛神通。破无量阿僧祇我慢山。倒无量阿僧祇悭嫉幢。竭无量阿僧祇爱河。渡无量阿僧祇生死海。断无量阿僧祇魔网。掩蔽一切日月释梵护世威光。从一佛刹。至一佛刹。能救地狱饿鬼畜生阎罗王界诸苦众生。常得亲近诸佛菩萨。具足成就海印三昧。持一切法三昧。法自在三昧。诸相庄严三昧。宝生三昧。安乐三昧。莲花庄严三昧。虚空藏三昧。随入世间三昧。妙法花三昧。境界自在三昧。大奋迅三昧。虚空心三昧。师子奋迅三昧。日灯三昧。无量旋三昧。澍甘露三昧。金刚幢三昧。如金刚三昧。金刚齐三昧。地持三昧。须弥灯三昧。须弥幢三昧。宝藏三昧。心自在三昧。一切众生心自在三昧。增长一切行三昧。深密方便三昧。种种辩才三昧。无能见三昧。了诸法三昧。游戏三昧。出生一切神通三昧。降魔三昧。现一切色相三昧。一切色最胜三昧。观身三昧。具一切行三昧。智灯三昧。菩提光三昧。乐说辩才三昧。入一切功德三昧。说诸法实相三昧。寂静神通三昧。首楞严三昧。海潮三昧。又得无量佛身相陀罗尼。大智陀罗尼。净音陀罗尼。无尽箧陀罗尼。无量旋陀罗尼。海印陀罗尼。入决定辩才陀罗尼。诸佛住持陀罗尼。又得随顺一切众生殊胜行一切法无师智。断一切法疑。得佛神通。具菩萨行善巧方便。文殊师利。譬如须弥山王。高显秀丽。映蔽余山。菩萨信解此法门者。功德严净。蔽诸众生一切善根。亦复如是

尔时文殊师利。告灭诸盖菩萨言。佛子。复更有余胜法。若诸菩萨。能信解者。便得成就余胜功德。灭诸盖菩萨。闻是说已。复白文殊师利言。若有菩萨。信解五法。则能除此胜法。得余无量殊胜功德。何等为五。一者信解一切诸法。不生不灭。不可称说。无比无对。二者信解如来无功用。无分别。入过阎浮提微尘等威仪行处。刹那刹那常起不绝。三者信解释迦如来。往昔教化苏陀婆王。但为成熟诸众生故。然实已于恒河沙劫。久成正觉。四者信解释迦如来。示然灯佛。授记已来。乃至成佛。于是中间。修菩萨行。而实已于无量劫来。成等正觉。住佛境界。五者信解释迦如来。现托王宫。释种被害。但为成熟诸众生故。而实已于无量劫来。成等正觉。文殊师利。菩萨若能于此五种。生信解者。则能除此胜法。更得成就余胜功德。文殊师利。若善男子善女人。于恒河沙劫。日日以天百味饮食。及天妙衣。施十方界微尘等诸阿罗汉具六神通八解脱者。所得功德不如有人于一日中但以饮食施一独觉。其福胜彼阿僧祇倍。又文殊师利。若善男子善女人。遍十方界。为阿僧祇辟支佛等。造十方界微尘等精舍。一一皆以阎浮檀金所成。摩尼为柱。阶陛栏楯。楼阁户牖。咸以众宝。种种庄严。施大宝帐涂妙栴檀。日日以天百味饮食。及天妙衣。恭敬供养。于恒沙劫。不如有人。或闻佛名。或世尊名。或如来名。或一切智名。所得功德。复过于彼。阿僧祇倍。况以彩画。或以泥塑。作如来像。观见之者。福又过彼。阿僧祇倍。况以灯油。香花伎乐。种种供养。福又过彼。阿僧祇倍。何况有能于佛法中下至一日。护持一戒。福转过彼。阿僧祇倍。文殊师利。若有善男子善女人。于恒河沙劫。日日以天百味饮食。及天妙衣。供十方界微尘等诸佛菩萨。及声闻众。诸佛灭后。一一皆起十方界微尘等塔。一一塔量。遍四天下。形制奇妙。众宝庄严。幡盖伎乐。诸供养具。踰胜于前。虽诸功德皆悉具足。未能信解此法门者。不如有人能信解是入如来智德不思议境界法门。乃至以一抟食。施于畜生。其福过彼。阿僧祇倍。文殊师利。若有菩萨。信解此经。如其所说。供养诸佛。有余菩萨。闻已欢喜。生净信心。从坐而起。合掌作礼。随其所堪。修行供养。福又过彼。阿僧祇倍。是人不久得佛智故。说是经时。彼诸比丘。及菩萨众。一切世间。天人阿修罗等。欢喜信受。作礼奉行大方广入如来智德不思议经


大方广总持宝光明经卷第一

    No. 299

大方广总持宝光明经卷第一

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

如是我闻。一时世尊。在王舍城鹫峰山中。与大比丘众百千人俱。圆满一切白法。大师子吼智慧无量得大善利。并诸菩萨摩诃萨众。其名曰

普贤菩萨摩诃萨。宝印手菩萨摩诃萨。常现菩萨摩诃萨。功德庄严菩萨摩诃萨。福德音菩萨摩诃萨。大慧菩萨摩诃萨。德严菩萨摩诃萨。金刚慧菩萨摩诃萨。金刚藏菩萨摩诃萨。金刚光菩萨摩诃萨。金刚器仗菩萨摩诃萨。妙金刚菩萨摩诃萨。持地菩萨摩诃萨现一切法菩萨摩诃萨。观自在菩萨摩诃萨。得大势至菩萨摩诃萨。坚牢慧菩萨摩诃萨。金刚吉祥菩萨摩诃萨。金刚手菩萨摩诃萨。妙吉祥菩萨摩诃萨。灭恶趣菩萨摩诃萨。除一切烦恼慧菩萨摩诃萨。安祥步菩萨摩诃萨。离取舍菩萨摩诃萨。栴檀香菩萨摩诃萨。海慧菩萨摩诃萨。难胜菩萨摩诃萨。宝胜菩萨摩诃萨。慧行菩萨摩诃萨。辩积菩萨摩诃萨。妙香菩萨摩诃萨。慈氏菩萨摩诃萨。如是等无量菩萨摩诃萨。皆住不可思议解脱勇猛三摩地门。亦得不空无量音声故。观一切音声。诸佛刹土寂然憺怕。寿命无量得大名称。三界无著亦无破坏。一切智者而为眷属。出生无量诸三摩地三摩钵底。能满众愿。皆悉到于般若波罗蜜多故。获得不空身语意业。得住一切智智无量行愿。了达空无相无愿解脱法门。如是等诸大菩萨众皆来会坐

尔时普贤菩萨摩诃萨。于众会中。从座而起。顶礼佛足。而白佛言。世尊。法界应云何知。佛言。善男子。此法界无性无能知者。何以故。善男子。由如虚空。离诸戏论。非离戏论。非取非舍。非性非无性。亦无处所。善男子。是故法界应如是知

尔时普贤菩萨。复白佛言。世尊。法界应云何住。佛言。善男子。处所尚无。况复有住。善男子。此法界不可思不可议无自性无能了知。善男子。彼法界性不可知不可见。普贤菩萨。复白佛言。世尊。菩提者为有几何。佛言。善男子。菩提有无量相不可测量。普贤菩萨言。世尊。法界复云何分别。佛言。善男子。法界本无分别。普贤菩萨言。世尊。若法界不可分别者。云何凡夫众生而能解了。佛言。善男子。有分别者即是一切愚迷众生于无分别而生分别。普贤菩萨。白佛言。世尊。如来菩提如是甚深微妙难解。佛言。善男子。如是如是如汝所说。佛复告言。善男子。菩提者即一切法也。离诸戏论。是故无有分别

时彼众中妙吉祥童子。亦在会坐。从座而起。顶礼佛足。白佛言。世尊。愿为我等。说此宝光明总持法门。佛言。善男子。汝今问彼一切法海辩才菩萨摩诃萨。彼为汝说。于是妙吉祥童子。在如来前。合十指爪掌。白佛言。世尊如来是一切智者。一切见者。云何不说。佛言。善男子。为有如是大菩萨摩诃萨。以是义故。如来不说妙吉祥言。唯然。世尊。如来何故不自说耶弃舍我等。佛言。善男子。吾非弃舍有情界故。善男子。为欲显示彼菩萨摩诃萨所说校量不可思议故

时妙吉祥童子。复白佛言。世尊。唯愿如来大慈无量为我说是宝光明总持法门。佛言。善男子。汝今问此普贤菩萨摩诃萨必当为汝说此法门。善男子。当知此菩萨摩诃萨。智慧无量。妙吉祥言。如来若令我问彼普贤菩萨摩诃萨我今当问。佛言。妙吉祥。汝自已得微尘等三摩地门。何故问于如来。妙吉祥言。世尊。我非但一佛所说之法。乃至一切如来所说真如实性。我能忆持不忘。由如今日。佛言。善哉善哉。善男子。汝今善说。佛言。妙吉祥。汝当问此普贤菩萨摩诃萨总持法门。时妙吉祥童子。白佛言。世尊。此普贤菩萨摩诃萨。深达实相大乘法行。佛言。善男子。汝等皆是自在法王之子岂得异乎。善男子。汝福德无量了达空法。得不可思议解脱三摩地门。于时妙吉祥童子。承佛圣旨。在普贤菩萨摩诃萨前。合十指爪掌一心恭敬。白普贤菩萨摩诃萨言。佛子。愿为我说二字法门

时普贤菩萨言。善男子。汝今所问二字者何。是时妙吉祥童子。白普贤菩萨言。佛子。觉与觉者二字为何等相。普贤菩萨言。佛子。觉本无相无性不可思议无有等等。离诸戏论非离戏论非言议之所能及。善男子。是故诸佛觉性如是。妙吉祥言。佛子。若佛法非戏论者。云何佛法作如是说。普贤菩萨告妙吉祥言。佛子。离言说故作如是说。妙吉祥言。佛子。云何离言说。普贤菩萨言。妙吉祥。智离言说。妙吉祥言。佛子。智云何知。普贤菩萨言。妙吉祥。谓智无性智非无性。妙吉祥言。佛子。云何智无性智非无性。应云何说三乘法。普贤菩萨言。妙吉祥。法界离染云何有说。妙吉祥言。云何一切法此亦无性云何说如来性无漏五蕴性不可得故。妙吉祥言。云何菩提有戏论耶。普贤菩萨言。佛子。菩提无有戏论非离戏论。此菩提有戏论非戏论者非言非说也。是时世尊。赞普贤菩萨摩诃萨言。善哉善哉。善男子。如汝所说是不可思议法门幽邃深远。是真实言天上人间无能解了。时妙吉祥童子。白佛言。世尊。一切法不可知不可见无法可说。佛言。善男子。如是如是。时普贤菩萨摩诃萨。复白佛言。世尊。今此清净法门难解难知。佛言。善男子。如是如是

是时海慧菩萨。白佛言。世尊。此普贤菩萨善说如是清净法门。佛言。善男子。如是如是。复次善男子。一切诸法清净若此霔大法雨

是时平等寂静婆罗大娑罗子。白佛言。世尊。此不可思议平等菩提。离文字相不可见离诸色相。佛言。善男子。如是如是。法界性离泯绝诸相。是时妙吉祥童子。白佛言。世尊。空云何相为声为色为是相好。佛言。妙吉祥。空离声色离诸言说非离言说。善男子法性如是。空离文字故说空又离言故说空。善男子。空者一切法法之自性故。是时长老舍利弗。白佛言。世尊。如来观此得大变现不可思议解脱菩萨耶。佛告长老舍利弗言。此阿罗汉智慧与初发心菩萨智慧甚远。何况此菩萨故。所以者何。初发心菩萨当得成佛。阿罗汉终不能得。是时一切法自在王菩萨。白佛言。世尊。如佛所说我悉了知。此声闻应不得声闻法。佛言。善男子。此声闻非不得声闻法。复次善男子。若声闻与菩萨对论智慧有殊是故所不能及。是时妙吉祥。白佛言。世尊。如来云何说此舍利弗得智慧第一。佛告妙吉祥。如我所说实无所得。是时妙吉祥童子。语长老舍利弗言。长老汝云何得声闻法。舍利弗言。我所不任。妙吉祥言。汝岂非凡夫不。不也。善男子。妙吉祥言。舍利弗。汝应云何学。舍利弗言。我无所学。妙吉祥言。云何得智慧第一。舍利弗言。我亦不任。妙吉祥复语长老舍利弗言。汝既非凡夫。又非智慧第一。为是何人。舍利弗言。善男子。我亦不知。汝智慧无量由如巨海。是故我今非汝对论。妙吉祥言。长老舍利弗。莫作是说。汝自耆年宿德。何故谦让。舍利弗言。善男子。我虽耆年。无德无证。复次善男子。譬如一切差别万法由如巨岳。金刚一击殒碎如尘。善男子。汝亦如是。于一毛孔所有智慧量等微尘数。一切众生皆悉如我亦所不及。善男子。况我一人乎。是故我今亦所不任。善男子。如大恶象其身伟大气力便多。人用其钩而能制伏。我亦如是。善男子。所以者何。汝有大智力。我力怯弱。善男子。汝等同于大龙。云何我力与仁者敌。长老舍利弗。白佛言。世尊。如生盲人。欲往他州在道路中。决定不能见彼城邑。云何而能周遍游历。善男子。此亦如是。我对仁者。如彼盲人。我今亦尔。佛道悬旷。由来甚远。当云何知。佛告舍利弗。勿作是说。如来威德能令一切众生。暂历耳根尚得此法。舍利弗。况汝已得此不可思议三摩地故。是时世尊。说是法时。天上人间有九万二千众生皆得是法。是时法慧菩萨。承佛威神。即入三昧。名菩萨无边相应宝光明三摩地。于时法慧菩萨。即便入于十方十千佛刹微尘等世界。于一一方。各各有十千佛刹微尘等诸佛世尊。皆现在前。时彼诸佛世尊。语法慧菩萨言。一方如是十方亦然。彼佛世尊赞言。善哉善哉法慧。汝能入此菩萨无边相应三摩地故。复次善男子。是时于一一方。有此一切十方十千佛刹微尘等如来位。彼如是等一切如来皆同一号。皆是世尊毗卢遮那如来最初威德本愿力故。得大善利。乃至转大法轮。彼如是等诸佛同说偈言

  佛智本清净　　普周于法界
  及观众生界　　遍入无碍智
  无等相应门　　善一切言语
  速得一切智　　圆满于诸法
  三世智皆圆　　善说如是法

善男子。汝今以佛威神力故。说此菩萨十住法门。是时彼佛世尊。各以无碍智往照法慧菩萨复得如是三摩地门。所谓无碍无断不空法不空智无漏无际无尽无来无去无边本性无著。得如是等三摩地门。是时彼佛世尊。各伸右手。摩法慧菩萨顶。彼佛世尊。摩菩萨顶已。即时法慧菩萨。从三摩地起。告诸菩萨言。佛子。菩萨族类广大无量。周遍法界虚空界。佛子。菩萨摩诃萨。于过去如来族中已生。现在如来族中今生。未来如来族中当生。是时彼诸菩萨摩诃萨。告法慧菩萨言。佛子。如汝所说。彼菩萨摩诃萨。云何得过去现在未来诸如来族中生。复云何说彼菩萨。得菩萨住故。彼诸菩萨摩诃萨。告法慧菩萨言。佛子。善哉愿为我等说此菩萨十住法门。彼过去佛已说。现在佛今说。未来佛当说。佛子。云何说菩萨十住法行。所谓一发心住。二治地住。三相应住。四生贵住。五方便具足住。六正心住。七不退住。八童真住。九王子住。十灌顶住。佛子。是为菩萨十住法行。此过去未来现在三世诸佛世尊。已说今说当说。佛子。云何彼菩萨发心住。谓此菩萨得睹诸佛世尊色相巍巍殊特妙好广大无比说法广大化众生广大。见如是等广大变现。又闻广大法故。得未曾有。复见如是苦恼众生。是故菩萨。发阿耨多罗三藐三菩提心。为求如来一切智一切相智。是故名为初发心住。又学如是十力。何等为十。谓一处非处智力。二过现未来福业报智力。三禅定解脱三昧智力。四至一切处道智力。五无数种种界智力。六无数种种胜解智力。七根胜劣智力。八宿住忆念智力。九天眼智力。十无漏智力。佛子。此初发心菩萨。应学此十住力故。彼初发心菩萨。于一切时恭敬供养诸如来故。彼菩萨安住称赞故。为世间最上第一世主故。求佛无量最上智慧故。为求寂静相应三摩地故。远离轮回故。转正法轮故。救度一切苦恼众生故。何以故。为真实法发心故。听受亲近离诸散乱相续不断故。佛子。是故名为菩萨初发心住。佛子。复云何名菩萨治地住。佛子。此治地住菩萨为诸众生。先发十种心。何等为十。谓信心。念心。精进心。慧心。愿心。戒心护法心。舍心。定心。回向心。佛子。此治地住菩萨。复发如是十种心故。佛子。此治地住菩萨。常念多闻相续不断。常乐奉事善知识故。供承亲近于一切时能觉察故。发言谦敬故。求坚固无畏智故。发趣菩提智故。志求寂静勇猛智故。志求妙法离诸虚假故。心不迷惑。何以故。谓发如是诚实心。求一切佛法故。乃至随方有圣法处躬自往彼听受亲近。离诸散乱相续不断未曾暂舍。佛子。是故名菩萨治地住。佛子。复云何名菩萨相应住。佛子。此相应住菩萨。有十所观求一切法。何等为十。谓求一切无上法故。远离一切忧苦故。观法无自性故。空无体相故。一切法无有常故。一切法不可度量故。离诸疑惑故。不可改变故。非有非无故。非取非舍故。佛子相应住菩萨。复观一切众生界平等法界平等世界平等地界平等水界火界风界虚空界欲界色界无色界如是诸界悉皆平等。何以故。谓如是一切法自性平等故。为求胜法往诣十方。于诸佛前亲近听受。离诸散乱念念相续无有间断。佛子。是故名菩萨相应住。佛子。复云何名菩萨生贵住。得生十种圆满净业解圣言说故。何等为十。谓此菩萨有所说法众必崇受。渐渐增长坚固不退。了达诸法观诸世间无坏灭故。观一切业性离妄想故。观诸果报无取舍故。观于轮回无去来相故。观于涅槃湛然寂静故。佛子。此生贵住菩萨。得是十种圆满净业解圣言说故。复言佛子。生贵住菩萨。观过去佛法平等恒时忆念相续不断故。观未来佛法平等愿当学故。观现在佛法平等勤修习故。观诸佛法如是平等。是故。得过去际未来际现在际。于此三际皆得值遇。如是修习。忆持不忘一切佛法殷勤恭敬。复观过去佛法学平等增长故。未来佛法亦如是学平等增长故。观现佛法亦如是学平等增长故。佛子。此生贵住菩萨。如是观察趣向一切佛法。普皆平等增长修习故。何以故。谓三世平等最胜真实住无虚假故。乃至闻彼他方有如是法。亲自往诣勤求精进心不散乱念念相续无有间断。佛子。是故此名菩萨生贵住。佛子。复云何名菩萨方便具足住。佛子。此方便具足住菩萨。观于无量无边无数阿僧祇不可思议无等等众生界。由如虚空不生不灭自性清净。同真际等法性。如是观察一切众生。是名菩萨方便具足住。佛子。此方便具足住菩萨。有十种事。所修善业皆为方便利乐一切众生故。谓令一切众生于无上道心不退转故。爱乐一切众生不舍离故。饶益安乐一切众生故。悲愍一切众生故。欲令一切众生皆得不可思议解脱道故。洗涤一切众生业垢故。摄伏一切众生故。欲令一切众生欢喜无厌故。以诸方便引导一切众生故。欲令一切众生究竟涅槃寂灭乐故。佛子。此方便具足住菩萨。如是乃至闻彼他方说如是法。亲自往诣勤求修习心不散乱念念相续无有间断。佛子。是名菩萨方便具足住。佛子。复云何名菩萨正心住。佛子。此正心住菩萨。有十种法。应当乐闻勤求志意于佛法中得正心住。佛子。何等为十。谓说佛有色无色于佛法中得正心住。说法有色无色于佛法中得正心住。说菩萨所行之行有色无色。于佛法中得正心住。如是乃至说此众生界。大生众生界。有烦恼众生界。无烦恼众生界。易化众生界。难化众生界。乃至大法界。出生法界。有色世界。无色世界。有法世界。无法世界。佛子。此正心住菩萨。如是乃至于佛法中闻此法故。是为菩萨得正心住。佛子。此正心住菩萨。复闻此十种法故。入理勤求乃至闻于一切无上法亦皆修学。何等为十。谓无相。无性。无实。无染。远离。无著。无自性。如幻。如梦。离诸疑惑。闻如是一切法故。应勤修习。何以故。为此正心住菩萨入于真实法门故。如是乃至闻彼他方说如是法。亲自往诣勤求修习心不散乱念念相续无有间断。佛子。是名菩萨正心住。佛子。复云何名菩萨不退住。佛子。此不退住菩萨闻十无著法。于佛法中心不退转故。何等为十。谓闻非有佛非无佛。此菩萨于佛法中心不退转故。非有法非无法。于佛法中心不退转故。非有菩萨非无菩萨。于佛法中心不退转故。非取菩萨非不取菩萨。非离菩萨行非不离菩萨行。菩萨非出生非不出生。于佛法中心不退转故。过去诸佛非去非不去。未来诸佛非来非不来。现在诸佛非住非不住。如是三世诸佛智慧平等一相无相。非尽非不尽离诸挂碍。此菩萨闻如是法故。非佛法中心不退转故。佛子。如是名菩萨不退住。佛子。此不退住菩萨。复闻十种法。而能修习。何等为十。谓闻一多众生于一切法精勤修习故。此胜义谛为一多缘起为胜义谛故。即性即无性即相即无相即有色即无色离诸相好心得决定殷勤修习。何以故。谓闻如是一切诸法因果该彻通达无碍真实法故。成熟解了。如是乃至闻彼他方说如是法。亲自往诣勤求修习心不散乱。念念相续无有间断。佛子。是故此名菩萨不退住。佛子。复云何名菩萨童真住。佛子。此童真住菩萨。得十种法。何等为十。谓得身业清净。口业清净。意业清净。得察一切众生起心动念。彼诸众生凡所施为悉能了知。能知众生如是解脱。能知种种众生界种种法界种种世界及地界水界火界风界虚空界欲界色界无色界。如是诸界悉能了知。神通奋迅随念而至。佛子。如是名菩萨童真住。佛子。此童真住菩萨复闻十种法。而能修习。何等为十。谓闻一佛刹智。震动一切佛刹。观一切佛刹。访寻一切佛刹。游行一切佛刹。往诣阿僧祇世界。问阿僧祇义趣。远离种种自性差别。发一念心而能周遍阿僧祇佛刹听闻修习故。何以故。谓闻如是真实法故。成熟解了第一义故。如是乃至闻彼他方说如是法。亲自往诣勤求修习心不散乱。念念相续无有间断。佛子。是故此名菩萨童真住。佛子。复云何名菩萨法王子住。佛子。此法王子住菩萨。有十种法皆能了知。何等为十。谓能知一切众生所生之处。能知一切众生烦恼。能知一切众生恋着。能知一切众生方所。能知诸佛深妙法故。能知诸佛方便真实性故。能知世界种种差别法故。能知过去未来现在三世诸佛智慧故。能知一切世间广大不坚牢法故。能知真性如如湛然寂静故。佛子。是故此名菩萨法王子住。佛子。此法王子住菩萨。复有十种法。应勤修习。何等为十。谓善学一切王城种种作用故。善一切王城礼乐故。善一切王城安住故。善入一切王城故善能自在遍游历一切王城故。住法王灌顶故。住法王观察故。得法王自在力故。继绍法王位故。得住法王辩说故。何以故。谓修习一切无碍真实法故。如是乃至闻彼他方说如是法。亲自往诣勤求修习心不散乱念念相续无有间断。佛子。是名菩萨法王子住。佛子。复云何名菩萨灌顶住。此菩萨得十种神通。何等为十。谓能令阿僧祇世界种种动摇故。能照曜种种阿僧祇世界故。能观察种种阿僧祇世界故。能于种种阿僧祇世界同时一心修习故。能于阿僧祇世界成就种种善业故。能于阿僧祇世界种种众生差别心同时能知故。能于阿僧祇世界一一众生种种心行能一时行故。能于阿僧祇世界一一众生有种种根器同时能解了故。能教化阿僧祇世界种种众生故。能遍知阿僧祇一切众生心所作用故。复次善男子。此灌顶住菩萨。潜行密用施为佛事无人能知。所以者何。谓身业不能知。口业不能知。意业不能知。变现不能知。观察种种变化不能知。观过去所行之行不能知。于刹那顷所行之行皆不能知。观智慧不能知。心意不能知。一切智用不能知。佛子。此灌顶住地菩萨。乃至法王子位菩萨。终不能知故。佛子灌顶位菩萨。复闻佛世尊。十住。何等为十。谓闻三世智。佛智。法智。法界分别智。法界中边智。一切世界量等法界智。照察一切世界智。圆满一切众生智。一切法智。无边佛智。此菩萨住一切诸佛智故。何以故。谓闻如是一切实际理智故。佛子。是故此名菩萨灌顶住

大方广总持宝光明经卷第一大方广总持宝光明经卷第二

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

尔时法慧菩萨摩诃萨。为诸菩萨说是菩萨十住法已。于时十方以佛神力。于一一方。各有十千佛刹微尘等世界。一一佛刹微尘等世界。地皆六种震动。所谓。动遍动。等遍动。震遍震。等遍震。击遍击。等遍击。涌遍涌。等遍涌。吼遍吼。等遍吼。起遍起等遍起。是时以佛神力。复雨种种天华云种种天香云。种种天涂香云。种种天鬘云。种种天粖香云。种种天衣云。种种天伞盖云。种种天宝云。种种天妙莲华云。种种天诸璎珞云。种种天庄严云。如是等种种供养云。周匝遍雨。复有种种天妙音乐。于虚空中。不鼓自鸣。出大音声。光明晃曜遍四大洲。妙高铁围周遍十方普皆供养。是时法慧菩萨。说是法时。一切十方世界同时亦说此十住法故。乃至文字句义不增不减皆悉同等。复以佛威神力故。于一一十千佛刹微尘等世界。各各有十千佛刹微尘等菩萨。从于十方云集。而来告法慧菩萨言。佛子。善哉善哉。佛子。如汝所说菩萨十住法。佛子。与我名同说法亦同。如是等一切同名法慧菩萨。从彼十方一切如来所而来至此。彼法云世界以佛威德于一切处同时转此法轮。如是。种种性相文字句义不增不减。佛子。于时众会以佛威德皆见彼众而来诣此。如我到此世界。亦复如是于一切十方世界一切四大洲妙高山顶帝释宫中。十千佛刹微尘等菩萨亦同来集。是时法慧菩萨。承佛威力。观察十方法界众会。欲重宣此义。而说偈言

  见诸如来清净智　　巍巍变化力如是
  十力功德众庄严　　是故发此菩提心
  见此种种神通力　　说法利益诸群生
  复见轮回诸苦恼　　是故发此菩提心
  于此普贤如来前　　得闻一切功德海
  由如虚空无有相　　是故发此菩提心
  一切住处及所生　　一一性行皆明了
  各各差别性智求　　是故发此菩提心
  是时过去及现在　　乃至未来众善恶
  为求此智善修习　　是故发此菩提心
  禅定解脱及三昧　　等持清净悉皆然
  为求此智恭敬彼　　是故发此菩提心
  能遍世间诸根力　　如如湛净皆同等
  为求此智彼义学　　是故发此菩提心
  菩提解脱遍世间　　其中各有种种意
  为求此智无数论　　是故发此菩提心
  种种无数三界中　　于中复有种种界
  界之自性智应求　　是故发此菩提心
  遍诣一切求此法　　如是依止得安乐
  自性真实解了知　　是故发此菩提心
  一切刹中而出生　　由如众生依地有
  无数智眼同此求　　是故发此菩提心
  过去现在及未来　　若干众生何性相
  如是过去事皆知　　是故发此菩提心
  积聚众生满世间　　乃至一一遍亲近
  如是烦恼尽能知　　是故发此菩提心
  三界智慧彼皆知　　无尽法门能解了
  为求如是真实智　　是故发此菩提心
  一切诸法无依倚　　本性如空亦无著
  为求胜义真实知　　是故发此菩提心
  能动佛刹微尘数　　亦令江海涌沸腾
  为求如来如是智　　是故发此菩提心
  普放光明照十方　　一一光明从口出
  为求彼智一光明　　是故发此菩提心
  不可思议种种刹　　饮食供给珍玩具
  我愿亦具如彼智　　是故发此菩提心
  一切众生及佛刹　　能令远离伤杀生
  为求此法寿延长　　是故发此菩提心
  假使大海所有水　　一毛滴数尽能知
  如是此智愿当求　　是故发此菩提心
  十方所有一切刹　　一一刹中微尘数
  如是此智要尽知　　是故发此菩提心
  过去及与未来劫　　现在一切诸世间
  如是劫数要尽知　　是故发此菩提心
  三世一切诸如来　　及以声闻辟支佛
  法之自性悉皆知　　是故发此菩提心
  无量无数诸世界　　一毛端中尽称量
  性之自性悉能知　　是故发此菩提心
  不可思议轮围界　　一毛端量尽能秤
  为此广大微妙知　　是故发此菩提心
  无量无数诸世间　　一刹那间声周遍
  为求此智清净声　　是故发此菩提心
  一切世间诸语言　　一字演说尽无余
  为此自性真实知　　是故发此菩提心
  无数化导三界中　　一切众生悉皆卫
  为求辩说广大舌　　是故发此菩提心
  如说一切诸佛刹　　一刹那中悉能见
  为求说法无碍智　　是故发此菩提心
  如来所有一切刹　　一刹那中皆周遍
  如此佛法真实知　　是故发此菩提心
  无数微尘等世界　　皆从自性而出生
  为求如是种种智　　是故发此菩提心
  过去及与未来佛　　乃至现在诸世间
  一刹那中心尽知　　是故发此菩提心
  一句所说不思议　　如是劫尽彼无尽
  为求如是语言知　　是故发此菩提心
  八方一切诸世间　　如是相续不断绝
  为此自性心了知　　是故发此菩提心
  所有身口意三业　　作彼十方一切行
  因此能解三世空　　是故发此菩提心
  菩提心发应如是　　殷勤最上奉诸佛
  十方无数劫尽行　　是故尊重心不退
  乃至世间一切尊　　八方各各皆周遍
  如是彼佛皆说法　　一一尊重心不退
  若一菩萨获安乐　　行彼行故免轮回
  能作世间圆满相　　是故此尊心不退
  最上妙法最殊特　　甚深难解离言说
  彼诸菩萨妙敷扬　　为敬彼尊心不退
  世间不动及住所　　如是难得甚希有
  演说清净妙法音　　是故此尊心不退
  得生一切如来中　　无我无人离憍慢
  为求此法常在前　　是故殷勤心不退
  无数无等阿僧祇　　得诸如来三摩地
  行彼菩萨如是行　　是故殷勤心不退
  乃至究竟三摩地　　超生彼岸解了知
  如是说彼诸佛法　　是故此尊心不退
  远离轮回三界中　　转于如是妙法轮
  于诸世间常无间　　菩萨应当如是说
  一切世间诸苦恼　　如是浊恶灾难中
  怜愍一切诸有情　　是故菩萨应当说
  菩萨最初说此法　　因兹发起菩提心
  持戒说法无有时　　是故名为发心住
  是时菩萨治地住　　最初降伏如是心
  安乐利益于世间　　如佛远离老病死
  信心念心及精进　　慧心愿心并持戒
  护法舍离无去来　　决定回向诸含识
  若以住彼如是心　　读诵受持大乘典
  远离喧嚣居闲静　　访寻一切亲善友
  善言亲近善知识　　勤求如是真实智
  了达一切诸语言　　胜义谛理亦如是
  晓了如来胜义已　　离诸颠倒无疑惑
  如是平等湛然安　　是名说法真佛子
  治地住中如是得　　善能观察诸菩萨
  演说妙法奉诸佛　　是故佛子应当学
  复次菩萨第三住　　法王教中求佛行
  苦空无常悉了知　　一切自性无来去
  诸法本寂离自性　　明了通达决定心
  住此一切无有惑　　佛子应当如是说
  为知一切众生界　　及阐一切诸法界
  如是世界悉尽知　　是故名为相应行
  地界水界及火界　　如是风界虚空界
  欲界色界无色界　　是诸世界悉尽知
  乃至差别诸世界　　悉见法界自性体
  如是广大智慧尊　　勇猛精进求佛智
  是时菩萨生贵住　　出家生诸如来中
  有性无性心决定　　所生之处常正见
  此地菩萨无退转　　为求佛道心无厌
  于一切法恒修习　　观诸众生如自性
  世间众罪如尘刹　　远离轮回诸果报
  佛子善能分别生　　菩萨悉令离衰老
  过去现在及未来　　一切法智皆明了
  宿殖善友悉同生　　如佛出世亦复尔
  一切如来殊妙好　　入彼三世平等意
  能作如是上妙生　　超越三世种种行
  此名第四菩萨住　　彼能称赞此妙色
  是法悉能解了知　　觉彼菩萨如是生
  此后菩萨称第五　　说名方便具足住
  种种方便化群生　　乐求福业遍往诣
  所作如是广大福　　令诸众生皆解脱
  尽心回向悉获安　　怜愍有情令离系
  世间患难皆救济　　摄伏令彼生欢喜
  各各引导诸众生　　得大涅槃心寂静
  无边一切诸世间　　如是无量无有数
  过诸称量无等伦　　非性非相非究竟
  此为菩萨第五住　　具足方便化群生
  彼佛如是妙圆明　　示现一切诸功德
  无边一切诸众生　　观法自性无迷惑
  疑网有无智了知　　天上人间能坚固
  于佛于法菩萨中　　常行妙行离诸色
  于是广大诸众生　　听闻演说方便法
  烦恼众生使清净　　易化难化悉调伏
  法界或广略敷扬　　非来非去绝诸相
  法界体性非有无　　菩萨三世乐听受
  观察一切心无动　　如是专注于佛法
  泯绝性相孰有无　　本性离染我亦尔
  晓了劫性如幻梦　　为闻如是上妙法
  不退菩萨应如是　　于佛于法菩萨中
  并观行相为有无　　不退非有亦非无
  如来非去非有住　　亦无来与非不来
  生与不生尽不尽　　有相无相非一异
  种种众多彼如一　　胜义谛理离有无
  各各差别众宝严　　菩萨于彼心不退
  真如妙相非有无　　以无相智能解了
  如是差别往集会　　一一天上悉听闻
  复次菩萨童真住　　身口意业悉清净
  施作佛事无有着　　是故随意所生得
  皆从众生行法生　　游行见彼诸刹土
  智慧速疾随意得　　十方殷勤恭敬礼
  菩萨于此无异心　　闻佛演畅微妙法
  能知刹土悉动摇　　如是尽知无有余
  演说游行于佛刹　　刹那遍诣阿僧祇
  随问演说无数义　　自性差别性亦然
  方便音声能照察　　无数佛刹一念中
  复说菩萨王子住　　密行众生非测量
  烦恼障闭妄想除　　事理相应方便说
  种种妙行悉能行　　分别世间过未来
  真俗二谛能了知　　谛求如是微妙法
  善能方便入王城　　如是遍游悉周匝
  于彼往还能自在　　所有王城能照察
  由如灌顶王妙法　　如是威德力亦然
  入彼王城善演说　　是故此为王子住
  此能随顺诸众生　　如佛所化亦如是
  调御出兴悉同然　　得佛安隐住王子
  佛子菩萨灌顶住　　处长最上能利他
  一毛滴水为校量　　思惟校计莫能测
  如是行于诸佛法　　由若一切微尘刹
  众生莫测尘可知　　是故无数应是说
  一切如来及菩萨　　并与过去未来佛
  若以现在十方中　　乃至声闻辟支佛
  从种发生菩提心　　如是此数莫能测
  功德数量莫能知　　最初一念菩提心
  如是世界化群生　　无能超越过于彼

是时普贤菩萨摩诃萨。告法慧菩萨言。善男子。善哉善哉。汝今善说此宝光总持法门。复次善男子。彼诸众生。当得爱乐不可思议诸佛功德一切智慧。善男子。若有众生。但闻此宝光总持正法名号不须受持读诵。一心恭敬究竟决定得证佛果。时法慧菩萨言。佛子。如是如是如汝所说。普贤菩萨言。佛子。彼等已得如来灌顶甚深智慧。若有善男子善女人。至此会中。得闻如是法者。或有众生手持是经者。是诸众生于佛法中皆得授记是时长老舍利弗。从座而起。顶礼佛足。而白佛言。世尊。我等今者如生盲人。从昔已来未曾见闻如是正法。世尊非但我故。若诸众生不闻此法。彼如是等一切众生亦如生盲。佛言。长老。如是如是如汝所说。舍利弗。即白佛言。唯愿说此不可思议甚深法故。佛言。舍利弗。汝当往诣命彼梵王帝释护世诸天同来此会。如来敕语舍利弗。此最胜法印宝光总持之法。于彼道场众会而说。是时尊者舍利弗。受佛教敕为问此宝光总持法门。承佛圣旨。往彼梵王帝释护世诸天。到已作如是言。宝光道场佛待汝来。同时听受此如是法。今正是时。如来将说此宝光总持不可思议法故。汝等速集勿过此时。甚难得值后必追悔。如是最胜法宝。世间难得。甚为希有。时彼诸天闻是说已即运神通。于刹那顷。梵王帝释护世诸天皆来集会。到世尊所。右绕三匝。合掌恭敬。住立佛前。劝请世尊。唯愿如来。哀愍我等及末法众生说此宝光总持法门。于时世尊。默然不答。时诸天众梵王帝释护世诸天。如是三白。殷勤劝请。世尊默然。是时尊者舍利弗。白世尊言。唯愿如来。说此宝光明总持法故。复言善逝。唯愿说之。是时世尊。即于舌根从口而出种种音声。遍于三千大千世界。同时得闻。若有善男子。为此宝光总持法故。请于如来。是诸众生。皆得不退转于阿耨多罗三藐三菩提

是时世尊。复语尊者舍利弗言。尊者舍利弗。汝当往诣请妙吉祥童子。说如是法时。妙吉祥童子。在于异处钵攞(二合)叉娑罗树下。端身正念结跏趺坐。过于百千万俱胝那庾多日月光明。住大宝庄严楼阁中。梵王帝释护世诸天围绕恭敬。身皆金色。吉祥庄严。光明照耀。是时尊者舍利弗奉佛教命。往诣妙吉祥童子所。到已即白妙吉祥言。善男子。如来请汝为于我等说此宝光总持法故。于时妙吉祥童子。语尊者舍利弗言。此如来者。为何等义。舍利弗言。善男子。汝智慧深远。我非汝曹。是故不任与汝论议。妙吉祥言。止舍利弗。汝甚愚痴。汝若乐闻。我当为说。舍利弗言。善男子。我今乐闻。惟愿仁者。广为我说。是时妙吉祥童子。说是语时。即时三千大千世界。乃至清净天宫。及诸天众。上至阿迦腻吒天众。下至四大天王并诸眷属无数俱胝大药叉。将诸梵天王及天帝释护世诸天并诸天女。各各乐闻如是大法皆来集会。及诸比丘比丘尼优婆塞优婆夷。并余三十三天夜摩天。睹史陀天。化乐天。他化自在天。大梵天王阿迦腻吒天。如是诸天众等。皆来集会。复有诸大声闻众。其名曰尊者须菩提。尊者摩诃迦叶。尊者大目干连。尊者舍利弗。尊者摩诃迦旃延。尊者阿[寧*頁]噜驮。尊者誐耶迦叶。尊者摩贺俱絺罗。尊者祖拏判姹迦。尊者梨嚩多。尊者曩祢迦叶。尊者乌噜尾螺迦叶。尊者布啰拏梅怛啰(二合)尼子。尊者罗护罗。尊者钹捺啰(二合)波罗。尊者么涩波。(二合)尊者阿难陀。如是等诸大声闻众。及耶输陀罗五百比丘尼等皆悉来集。复有转轮王及诸小王。刹帝利婆罗门。长者居士。皆来集会

是时尊者舍利弗。绕佛三匝。而作是言。世尊。何因何缘。即于今日。如是大众皆悉云集。云何当知。佛言尊者舍利弗。是宝光总持法威德力故。舍利弗言。世尊。此宝光总持法门我今乐闻。佛言。尊者舍利弗。汝当往诣请彼妙吉祥童子普贤菩萨。此二大士必为汝说。是时尊者舍利弗。白妙吉祥童子言。善男子。汝今当说此宝光三摩地微妙法宝。妙吉祥言。尊者舍利弗。汝等今者为欲闻此宝光总持法故。舍利弗言。今此四众梵王帝释护世诸天。为听是法故来至此。于时妙吉祥。即告长老舍利弗作如是言。舍利弗。此法秘要不可视听如幻如化。云何当说说听是谁。舍利弗言。善男子。汝今当说我欲乐闻。妙吉祥问尊者舍利弗此说当云何言。答言。妙吉祥。空作是说。妙吉祥又问舍利弗空云何说。答言。妙吉祥。空离言说。妙吉祥言。尊者舍利弗。此空若离言说。我云何说。尊者舍利弗。既一切诸法皆离言说。若作是说谁能听受。长老舍利弗言。善男子。彼一切法皆离文字语言故。作如是说。是故说空无相无愿。非取非舍。非异非不。异非离戏论非不离戏论。是时妙吉祥童子。尊者舍利弗。说是法时。彼诸菩萨及于梵王帝释护世诸天。心大欢喜同声赞言。善哉善男子。善说此宝光总持法故

是时尊者须菩提。白妙吉祥童子言。善男子。菩萨摩诃萨云何受持读诵。为他解说此宝光总持法故。妙吉祥言。须菩提。此总持法无生清净如理受持离性离相非离言说非取非舍。此法应如是受持为他解说。妙吉祥童子。说是法时。有九十二菩萨。皆得勇猛三摩地。复有人天六十二众生。得无生法忍

尔时普贤菩萨摩诃萨。从座而起。偏袒右肩。合掌恭敬。白佛言。世尊云何为菩萨摩诃萨大悲。佛言。善男子。此菩萨摩诃萨大悲者。若菩萨摩诃萨。不舍三界名为大悲。若令一切众生得见诸佛净妙刹土名为大悲。若诸破戒众生悉能怜愍护持名为大悲。若能令一切众生志求般若波罗蜜多亲近修习名为大悲。若为一切众生不惜身命名为大悲。乃至头目髓脑难舍能舍难行能行为诸众生名为大悲。复告。善男子。菩萨摩诃萨为诸众生无有异心等以安乐离诸邪见悉令解脱。善男子。是为菩萨摩诃萨大悲。应如是解

尔时普贤菩萨摩诃萨。白佛言。世尊。唯愿如来大慈无量为诸众生安乐世间说此宝光总持法故。并此大会诸天及人皆得安乐利益。即时世尊。愍诸众生以梵音声。普告诸菩萨摩诃萨言。汝等今者于未来世后五百岁。法欲灭时谁能受持广宣流布此宝光总持法故是时普贤菩萨。离一切忧暗菩萨。药王菩萨。辩积菩萨。出生一切法王菩萨。无尽意菩萨。海慧菩萨。宝师子菩萨。宝贤菩萨。宝光菩萨。宝髻菩萨。观自在菩萨。等观菩萨。常观菩萨。宝手菩萨。宝积菩萨。宝庄严菩萨。吉祥幢菩萨。法吉祥菩萨。财吉祥菩萨。福德吉祥菩萨。栴檀吉祥菩萨。法慧菩萨。甘露慧菩萨。不思议菩萨。福德庄严菩萨。功德庄严菩萨。相严菩萨。常欢喜根菩萨。众智山峰王菩萨。辩说菩萨。常举手菩萨。持地菩萨。辩意菩萨。虚空藏菩萨。月藏菩萨。清净月藏菩萨。日藏菩萨。出生王菩萨。摩诃弥卢菩萨。坚牢慧菩萨。弥勒菩萨摩诃萨。如是等六十二百千俱胝那庾多菩萨摩诃萨。以一音声同时告言。世尊。我等今者能于未来世后五百岁法欲灭时。常当受持广宣流布为诸众生说此宝光总持法门。佛言。善哉善哉。善男子。希有希有。善男子。汝等为诸众生能发如是清净大愿。尔时世尊告普贤菩萨摩诃萨言。谛听谛听。善男子。此宝光总持微妙正法。为欲利益安乐一切众生。尔时世尊说是语已。即升大宝庄严师子之座。结跏趺坐即说宝光明总持陀罗尼曰

  【◇】
曩　莫(入)　三　满　多　跋　捺啰(二合引)　野　冒(引)
【◇】
地　萨　怛嚩(二合引)　野　么　贺(引)　萨　怛嚩(二合引)
【◇】
野　么　贺(引)　迦(引)　噜　抳　迦(引)　野　怛
【◇】
儞也(二合引)　他(引)　唵(引)　婆(引)　啰　胝(引)　婆　啰
【◇】
胝(引)　婆　啰　婆　冷　帝　萨嚩(二合引)　贺(引)是时世尊。如是三说此宝光总持秘密微妙最上甚深广大法宝。是时普贤菩萨摩诃萨。白佛言。世尊。法与法者是义云何。佛言。善男子。无法即法即一切义即无性义一切法义即等虚空义一切法即无数义无数义即一切义无数义即一切法义。普贤菩萨。白佛言。世尊。云何说此一切法。佛言。善男子。吾说此一切法者。谓眼耳鼻舌身意。如是此六识及十二缘行。善男子。是故我今作此说故。一切诸法亦复如是。复次善男子。一切诸法本无生灭。是时妙吉祥童子。白普贤菩萨摩诃萨。作如是言。佛子。此宝光总持法门菩萨云何受持。普贤菩萨摩诃萨。告妙吉祥如是说言。善男子。此宝光总持如法而说如理受持。何故。本性不生不灭故。非相非空故。无性即自性故。自性即无性故。善男子。此宝光总持如是不应执着受持观察故。智慧决了应如是住分别解说。善男子。此宝光总持观法自性义故

大方广总持宝光明经卷第二大方广总持宝光明经卷第三

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

是时尊者舍利弗。白妙吉祥童子言。善男子。如此妙法住世几何。妙吉祥言。舍利弗。如此三毒贪嗔痴故。舍利弗言。善男子。此贪嗔痴住当几何。妙吉祥言。舍利弗。此三毒住由如地界故。舍利弗言。善男子。此地界复住几何。妙吉祥言。舍利弗。此三毒地界如无明界故。舍利弗言。善男子。此无明三毒住当几何。妙吉祥言。舍利弗。如虚空界故。舍利弗言。善男子。此三毒虚空界住当几何。妙吉祥言。舍利弗。如无性自性法故。是时尊者舍利弗。白妙吉祥作如是言。善男子。汝等智辩若此。云何我有如是智力与汝詶对。复次善男子。譬如一切猫狸践须弥山终不能尽。如是如是。善男子。我等亦复如是。如彼猫狸。何以故。如一切声闻与一菩萨共同论义。毕竟不能屈彼菩萨。况复此妙吉祥童子故。是时普贤菩萨摩诃萨。告妙吉祥童子言。善男子。汝于今者请问如来。白言世尊。于当来世后五百岁。彼宝光总持法王云何护持。持经法师云何怜愍令得坚固。于时妙吉祥童子。从自法座安祥而起。即白佛言。世尊。若有法师受持读诵为他解说此正法者。得何功德。佛言。妙吉祥。若有比丘。持此法王者。当得生于清净法身故。当得究竟佛菩提故。如是中间常得住于诸佛法中心不退转。一切天魔及诸眷属不能娆恼。若有善男子。于彼法师。暂起慈心。一弹指顷。是人即得远离轮回。究竟亦得佛菩提故。复次妙吉祥。持此宝光法王者。若起轻慢诬谤之心。是人世世得牙齿疏缺平鼻无舌手脚挛躄身常重病痴騃盲聋。生于下贱懈怠懒惰。佛告妙吉祥。如是愚迷众生我今略说。善男子。彼诸众生命终之后。受无数地狱。如一一孔毛。种种苦恼从地狱出。若生人中。常得生盲喑哑。复次妙吉祥。若有见此正法众经之王轻毁之者。是人当得身穿为窍丑唇褰缩身皆破裂裸形黑瘦皮肤粗涩由如饿鬼。妙吉祥重白佛言。我知如来智慧无量不可思议。世尊。彼如是等愚迷众生得生何处。妙吉祥言。唯愿说之唯愿说之。佛言。妙吉祥止。汝不应问。我若说彼愚迷众生谤法之者所生之处。天上人间若闻是说。皆悉恐怖皆悉闷绝宛转躄地。妙吉祥言。唯愿世尊。大慈大悲广演分别。彼诸众生若闻是说。于此不生不灭微妙正法不起慢心。佛告妙吉祥。于此地下。有诸地狱名号不同。所谓炎热地狱。极炎热地狱。黑绳地狱。炽然地狱。极炽然地狱。极恶地狱。钳口地狱。铁丸地狱。铁棒地狱。崩埋地狱。悬头地狱。倒悬地狱。猴面地狱。焰恒炽地狱。脓血地狱。常臭地狱。拖扑地狱。常杀地狱。生极大疼痛地狱。佛告妙吉祥。彼如是等地狱。即彼谤法众生所生之处

是时普贤菩萨摩诃萨。白佛言。世尊。彼持经法师命终之后生何国土。复次普贤菩萨。若有善男子善女人及诸法师持此经者。于此命终即得往生宝庄严世界。世尊。彼世界中有佛刹不可思议乐大辩说如来。复有无数诸菩萨众。身色巍巍殊特妙好。善男子。是诸众生临命终时。彼世界中有六十二俱胝佛同时现前。善男子。我今略说。若广说者。功德无量无数经百千劫不能穷尽。普贤菩萨。重白佛言。世尊。云何于未来世时。若诸众生闻此正法不生诽谤。佛告普贤菩萨。若四辈弟子得闻是经。言非正法作如是说是邪说非如来说应自说故。非真经典或言我先已闻此非正法作是轻慢诽谤之者。永不闻法远离三宝名字。彼如是等愚痴众生命终之后当堕黑暗地狱。其狱之中有大铁轮刃如锋铓常拂其头拂已还生。如是经无量百千劫。从此狱出设得人身。复经无量百千万劫常无两目。是时复经过百千劫。不复人身纵生人中。于一切处亦复生盲。又无舌根头面颠倒腰脊伛偻脚癵狗声常困饥渴羸瘦憔悴面色干枯口气常臭人皆恶贱。一切众生见者生嗔人皆弃舍。是时彼一切众会。异口同音作是唱言。如来今者为我等故。已说是法如是正法我等已闻。快说世尊快说善逝我等于未来世。见有受持是经典者。不生诽谤轻慢之心。我等愚迷由如稚子。不觉不知无有智慧。世尊。佛说是时彼大声闻及天帝释大梵天王护世诸天比丘比丘尼优婆塞优婆夷。各作是言。世尊。我等闻说谤此法者有如是罪身皆悚栗恐怖无量。佛言。如是如是。如汝所说。非但汝等吾今已得一切圣智上由恐怖。况复汝等我诸弟子。时诸善男子。于彼法师深生敬仰不能自胜。若诸天龙药叉干达嚩等人及非人无能破坏。善男子。若沙门婆罗门见此法王如佛塔庙。此经亦尔天上人间如敬宝箧。是时妙吉祥童子。重白佛言。世尊。若诸四辈弟子于此经王深信受持者得几所福。佛告妙吉祥。若人于此妙法及彼法师受持之者乃至名字。或于一日一弹指顷。发起慈心我悉知之或时发心饮食供给。或施园林净地用作僧房种种供养。是时尊者舍利弗。白世尊言。如是等人于五无间罪为灭为不灭。佛告长老舍利弗。止。勿作是说。所以者何。若诸众生受持正法者。即得消除五无间业。佛言。舍利弗。五无间者为闻此经威德力故。此五无间业速疾消除还复人身。数数得生佛法之中。永不复堕于三恶趣故。是时尊者舍利弗。悲泣雨泪。白佛言。世尊。如向所说谤此经者。乃有如是广大业报。昔所未见。如是罪报乃至梦中亦未曾见。是时世尊告长老舍利弗言。止。舍利弗勿作是念。复次舍利弗。我说此无碍妙法。数告汝等。舍利弗。彼诸众生。以自业力作种种罪。自作自受非彼他人。各各众生自业力故。受是痛苦非如来过。舍利弗。我常说言是诸众生汝等访诸善友。乐求安乐离诸怖畏。乐求涅槃乐甘露味。我常开示菩提正路。是时复说彼诸众生。恣纵贪嗔自作身业口业意业。心生邪见不自正知。造作众罪各各邪视。于身分别造众恶业。因堕地狱受种种苦。众生自过非如来咎。复次舍利弗。我常如是兴于大悲为诸众生乃至一一众生尽于一劫我皆代受地狱之苦终不弃舍一众生故。舍利弗。如来大悲恒常如是。譬如天上人间父母唯生一子。端严殊特色妙无比福相圆满。彼于一日忽然命终。时彼父母为此子故。心生懊恼情地慞惶悲号痛切苦恼。如是舍利弗。如来应正等觉亦复如是。悲愍众生如见一子。如来烦恼终不能着悉已远离。何以故。舍利弗。譬如大海不宿死尸。舍利弗。如来亦尔烦恼不着。又谓舍利弗。身如幻梦。亦如影向。四大合成假名为人中无有实。见诸行相非行非住。非处非无处。无滞无碍自他不着。舍利弗。如来亦复如是。观诸行相化导群生不贪说行。虽作一切种种行相。不可指不可示。等虚空界。离诸疑惑无有戏论。如来亦尔无有疑惑离於戏论。是时众生一向迷惑无有回转。如来大悲而能随顺。如有众生欲来佛亦随来去亦随去。何以故。是诸如来本愿力故。复次舍利弗。如来应正等觉无有错谬。如来无有无明。如来智慧亦无迷惑。舍利弗。吾今于天上人间。最尊最贵最上第一。不可称量无有等等。舍利弗。是不诳语者。不异语者。佛言。若有众生在家出家于此正法而生诽谤者。如前所说一切恶相。种种地狱众苦所受。是时尊者须菩提。合掌恭敬白佛言。世尊。此法微妙甚难得闻。世尊彼诸众生于此正法而生诽谤者当得何报。佛告须菩提。谤斯法者。得生大舌纵广百千由旬。上有五百俱胝铁犁长时耕舌。复从口出极热猛火。耸焰上腾炎炽辉赫合成一聚。经百千劫受大极苦。云何而得须菩提如是业报。彼愚痴众生。皆因口业所作。须菩提。彼愚痴众生。谤此法者受如是报。是时一切众会。以佛威力。同作是言。如来说此极大恶报甚为希有。是时帝释天主白佛言。世尊。我当于彼比丘持经法师。于未来世。常生尊重。以诸华香饮食衣药涂香末香种种供养。昼夜三时恭敬礼拜尊重赞叹。志心护持。世尊。是善男子已生如来法身中。与诸如来同一名号。何以故。如灌顶刹帝利王所生之子。端严巍巍具足王相。见者欢喜。彼诸人民皆悉尊重拜跪问讯。见彼法师。亦应如是礼拜尊重。尔时世尊告普贤菩萨摩诃萨言。善男子此帝释天主善能说之。为彼比丘持经法师。怜愍饶益潜加护持。普贤菩萨言。世尊我亦如是。于未来世彼善男子善女人。亦复护持怜愍饶益。息诸灾患令得安乐。周遍百由旬外不令娆恼。尔时世尊赞普贤菩萨摩诃萨言。善哉善哉。善男子。汝今善说。尔时世尊以梵音声。重说偈言

  令他安乐心悲愍　　悉能随顺诸众生
  三业清净善称扬　　无等功德真实宝

是时普贤菩萨摩诃萨。白佛言。世尊菩萨摩诃萨。云何当得此宝光总持法故。佛言。善男子。菩萨摩诃萨。于宝光总持当行一法。云何为一法。谓于一切众生。不起杀意。令得安乐。普贤菩萨。复有二法。云何为二。谓离于嗔恚。善言诱喻。普贤菩萨。此为二法。若能如是。即得宝光总持法故。复次普贤菩萨摩诃萨。为一切众生意根不乱无时暂舍。是时复告善男子。菩萨摩诃萨。为诸众生皆离一切憎爱故。是时菩萨。说此宝光总持功德时。复以称扬赞叹此最胜功德。于时天上人间有无量无数众生。皆得此法。复出宝光总持最胜功德。称赞法师

尔时尊者阿难从座而起。偏袒右肩。右膝着地。合掌恭敬住立佛前。白佛言。世尊。此宝光总持微妙正法。如是深邃。佛告阿难。如是如是。此色相甚深。受想行识甚深。如空甚深。如虚空甚深。阿难白言。我于如来前。得闻八万四千法藏未曾得闻如是妙法。佛告阿难。此宝光正法难遇难闻。阿难言。佛说如是微妙正法。于未来世后五百岁中法欲灭时。有诸众生欲作佛事。当依何法。佛告阿难。依我释迦牟尼如来说此正法。及彼法师。若有书写受持供养恭敬此正法者。眼常无病。鼻亦无病。舌亦无病。齿亦无病。手亦无病。脚亦无病。头亦无病。耳亦无病。诸根具足。身不臭秽。亦无中夭。寿命延长。彼一切诸天人及非人。常时卫护。时彼法师。于此命终。复得生于善逝世界。天中而生。离诸喧杂一切戏论。阿难白言。世尊。是何因缘说此正法。魔王毒害不能障蔽。佛告阿难。一切魔王。于此正法。终不能作障难之者。尔时世尊。作是语已。时彼魔王。生毒害心。作是念言。若有说此宝光总持法。时我当往彼作其障难。是时魔王以自业力。自见猛火来烧其身。恐怖无量退散而走。阿难此法如是深妙难测不可思议。若此正法。随所住处如佛塔庙。阿难白言。若如来在彼正法住处。我于是处。得见如来。往到佛所。先礼如来。后礼此法。为有何过。佛告阿难。汝有过失。何以故。汝既如是轻慢正法。云何我得天上人间最尊最贵最上第一。复次阿难。我于过去先闻此法后证菩提。阿难白言世尊。于何如来恭敬供养。复于何处闻彼如来说此宝光三摩地法。佛告阿难。我非于天上人间干达嚩处。恭敬供养求此法故。我于往昔为菩萨时。有佛世尊号不空积聚开妙众宝光明藏如来。前得闻此法。佛告阿难。彼如来即不与我授记。我从是来。过百千俱胝那庾多劫。难行苦行。为闻此法。阿难。是故汝应先礼此法后礼如来。是时一切梵王帝释护世诸天。以一音声。同作是言。叹此法故。是无上法。是最胜法。是无等等法。神变如是。若有闻此微妙正法乃至名字。应随向礼。何以故。若有受持读诵为他解说者。如见如来等无有异。尔时世尊。赞彼梵王帝释护世诸天言。善哉善哉。圣众善说。尔时世尊。从口而出广长舌相遍照三千大千世界已。告普贤菩萨摩诃萨言。善男子。汝今谛听。我今请汝为诸众生说此法故。云何众生于此宝聚。不自守护。展转息利。如生盲人不见日光。又如商贾无有方便不自贸易。亦如贫人。不自精勤。常奉他颜。见诸众生。不闻此法。亦复如是。为诸众生。譬喻言说。于是普贤菩萨摩诃萨。从座而起。偏袒右肩。右膝着地。合掌恭敬。住立佛前。即时普贤菩萨摩诃萨。从自法座安详起已。即时三千大千世界。诸天宫殿。六种震动。所谓动。遍动。等遍动。震遍震。等遍震。击。遍击。等遍击。吼。遍吼。等遍吼。涌。遍涌。等遍涌。起。遍起。等遍起。大光晃耀一切世间。于是普贤菩萨摩诃萨。白言世尊。云何问我世尊。云何问我善逝世尊。是具足一切智者。何不为诸众生大悲怜愍。我名如来之子。云何我有如来智。云何我有如来力。我于是时。常依佛言。依如来言。我常依止。由如甘露。不敢违背。恒时随顺。于时世尊。赞普贤菩萨摩诃萨言。善哉善哉。佛子。汝即如来长子最胜最上。我为众生说此正法。善男子。汝当依我如法护持恒常尊敬。由如宝箧。盛以珍玩。勿生舍离。未来世时。有破戒比丘。不生敬信。善男子。彼不依此。普贤菩萨言。世尊于意云何。彼出家者。有何行故。佛言。善男子。止。勿应问此。普贤菩萨言。世尊唯愿说之。唯愿说之。若不说者。云何而能为诸众生。佛言。普贤菩萨。汝今谛听。我说此法由如众海。文殊师利观世音。无量无数无有边际菩萨摩诃萨等一心谛听。于未来世。彼出家者。修何行业。

尔时世尊。告普贤菩萨摩诃萨言。佛子。彼出家者。于此正法多生轻慢。乐求舍宅贪着利养。畜积财宝精舍房堂衣服卧具饮食医药。造恶业因自破自坏为是愚迷众生。我说是经。广令流布久住不灭度脱众生。是时十方一切天龙药叉干达嚩等。来白佛言。世尊。我等天人八部并诸眷属。尽生恒时守护是经并彼法师一切比丘及诸法藏不令娆恼。我常随侍尊重恭敬。香华衣服种种珍宝一切所须。我皆供给令法久住。尔时世尊。为普贤等九十二俱胝菩萨。而说偈言

  谛听一切妙语言　　最圣功德超彼岸
  欺诳凶险皆弃舍　　一心专意乐谛听
  闻佛摩竭提国中　　菩提大树仁师子
  住大解脱三摩地　　当处如是大树王
  尽彼十方微尘刹　　佛子周游无所畏
  此名如来三昧族　　是诸三昧彼当得
  恒时知彼仁王行　　得见文殊真境界
  尽彼十方微尘刹　　汝观如来真色相
  十方无数此佛刹　　佛子悉皆名吉祥
  一切十方微尘刹　　佛子善能遍游历
  为彼世间得值遇　　文殊师利无边智
  问大众生贤吉祥　　佛子功德云何得
  是时实际广功德　　无边众生能解了
  问大众生贤吉祥　　文殊功德妙菩提
  佛子若说此法已　　得解清净佛功德
  复次佛子应云何　　当得如是功德行
  佛子谛听贤吉祥　　无边最胜彼功德
  我今略说于少分　　如添大海一滴水
  乃至得证佛菩提　　若有众生初发心
  无边功德莫能测　　一一功德尽赞扬
  波罗蜜多功德地　　如有经行于多劫
  不能说尽彼功德　　如是十方一切佛
  彼于是时说少分　　出生无边胜功德
  如鸟飞空不可量　　大地一尘无能比
  非无因故从何生　　菩提功德随心意
  发信一念生佛法　　如是和合生心已
  彼非爱乐王福乐　　非自求安非名利
  除灭世间诸苦恼　　为众心故生世间
  彼意恒为诸众生　　清净佛刹兴供养
  修习此法证菩提　　从心发生清净智
  彼常恭敬求解脱　　尊重一切生佛想
  一切诸法功德同　　生心如是恒恭敬
  发心归向于佛法　　佛子兴心行此行
  无边菩提发是时　　生大丈夫猛利意
  发心力如人中主　　广兴供养不思议
  众法无坏莫能量　　生心供养应如是
  发心能免胞胎苦　　养育劬劳一切行
  随乐快乐悉从心　　是故见于安乐处
  发起无边恭敬心　　我人憍慢皆弃舍
  发心即妙珍伏藏　　如手摄持获安乐
  发心能为欢喜舍　　发心踊跃作佛事
  发心求胜功德林　　得佛所说皆往诣
  勇猛利根光明照　　发心坚固无能坏
  种种烦恼顿皆除　　发心能说佛功德
  发心和合不和合　　一刹那中悉皆离
  发心能越魔王界　　见彼最胜妙解脱
  功德种子不朽因　　发心种大菩提树
  最上胜智皆增长　　发心见诸一切佛
  彼说过去行大行　　解脱妙行发心求
  此法世间甚难遇　　由如大海众宝王
  若常发心恭敬佛　　无戒无行彼皆离
  离诸过患众僭尤　　复能称赞彼功德
  持戒见获菩提心　　方便修学功德地
  能依戒法善修习　　彼常依佛所教敕
  若常发心恭敬佛　　彼佛广大兴供养
  于佛广大供养已　　复能殷重不思议
  若常发心供养法　　闻彼佛法心无厌
  若于佛法心无厌　　不思议法妙解脱
  若常发心恭敬僧　　彼于僧中心不退
  如是发心僧不退　　当得发心不退力
  若得发心不退力　　彼以根利现光明
  若得根利现光明　　彼常远离恶知识
  若已远离恶知识　　应当求法访善友
  若法善友寻求已　　彼获广大妙安乐
  若获广大妙安乐　　因力自大皆弃舍
  若已弃舍我慢因　　即得广大胜解脱
  如是广大解脱已　　即得诸佛常照察
  若以诸佛常照察　　彼即生大菩提心
  若得生大菩提心　　即获解脱大功德
  若得解脱大功德　　即得生于如来家
  既得生于如来家　　即得解脱妙相应
  若常解脱妙相应　　彼发心意皆清净

大方广总持宝光明经卷第三大方广总持宝光明经卷第四

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

  若得发心净觉意　　彼说最上最殊胜
  若得最上殊胜已　　常行波罗蜜多行
  若行波罗蜜多行　　则能随顺此大乘
  若能随顺此大乘　　则能随顺供养佛
  若得随顺供养佛　　则得智慧志坚固
  若能智慧志坚固　　常见彼佛不思议
  若常见佛不思议　　见佛无去无有住
  若得见佛无去住　　此法住世恒不灭
  若见此法恒不灭　　远离积集诸烦恼
  若得远离烦恼因　　则能说法无边际
  若得说法无边际　　彼为兴慈住世间
  若为慈心住世间　　则是大悲坚牢本
  若得大悲坚牢本　　即是为他法喜乐
  若得喜乐法根本　　彼舍造作种种罪
  若舍造作众罪已　　无我无人离众非
  若得无我离众非　　彼常自利及利他
  若常自利及利他　　永免轮回诸苦恼
  若离轮回诸苦恼　　彼得大力最为胜
  若得大力最殊胜　　则得出生清净智
  若生清净智慧已　　彼入世间修行网
  若能入此修行网　　成熟世间甚希有
  若得成熟于世间　　积集世间妙智慧
  若得世间妙智慧　　则能随顺于四摄
  若能随顺于四摄　　则于世间广施设
  若于世间广施设　　则住方便智慧力
  若得方便智慧力　　则住勇猛无上道
  若住勇猛无上道　　永不见彼魔军众
  若得不见魔军众　　则能远离四魔道
  若得远离四魔道　　则能到于不退地
  若得到于不退地　　即得名为无生忍
  若得如是无生忍　　得佛授记号世灯
  若得授记号世灯　　则住一切如来前
  若得住于如来前　　得佛秘密变化智
  若得如来变化智　　一切如来皆授记
  若得诸佛授记已　　一切功德众庄严
  若得功德众庄严　　得妙福德清净身
  若得如是清净身　　由若金山光照耀
  若得如是金山光　　即得具相三十二
  若得具相三十二　　即得相好庄严身
  若得相好庄严已　　身放光明普皆照
  若得光明普照已　　不思议光众严饰
  若得如是众严饰　　光明足步莲花生
  若得光明莲花行　　得佛境界莲花座
  若得如来花座已　　则能照见十方界
  若得照见十方界　　教化众生不空行
  若得教化不空行　　即得智辩无边际
  若得智辩无边际　　说此不可思议法
  若得说法不思议　　令彼无量众忻庆
  若得无量众忻庆　　积行不可思议刹
  若得如是广大行　　各各智力尽能知
  若得如是智慧力　　世间随类化群生
  若得随化群生已　　宿命住智彼皆得
  若得如是宿命智　　三业清净恒无间
  若得三业恒无间　　以自愿力随念至
  若得愿力随念至　　随诸众生现众类
  若得随现众生类　　得不思议妙音声
  若得如是妙音声　　能出种种众语言
  所出如是妙言辞　　则能周遍诸世界
  如是周遍诸世界　　一刹那中尽能知
  若得如是了众心　　不生不灭无退转
  若离生灭无退转　　一切障恼不复生
  若得障恼不复生　　法身功德智慧圆
  若得法身智慧圆　　法行光明照世间
  若得法光照世间　　则得十地十种身
  若得十地十种身　　则得般若解脱道
  若得般若解脱道　　灌顶庄严为最上
  若得如是灌顶已　　三摩地道悉皆成
  如是三摩地得已　　各见十方一切佛
  若见如是诸佛已　　如是诸佛念灌顶
  作是思惟是事已　　十方诸佛同灌顶
  诸佛同时灌顶已　　各伸右手摩其顶
  既得诸佛摩顶已　　则能变现等虚空
  如是变现等虚空　　随所住处能坚固
  若得随所能坚固　　天上人间莫能测
  既以人天无能测　　如是所作离称量
  过诸称量离语言　　是为一切不空力
  以是一切不空力　　闻名见身获大辩
  既以大辩力如是　　能作世间大施主
  复名不空大丈夫　　以住本性丈夫故
  不舍大慈演妙法　　于诸恶道化群生
  演说宝光最上乘　　由如金刚宝云聚
  彼之自性如海宝　　不增不减无有损
  无边功德亦复然　　有刹无佛不闻法
  于彼现作佛菩提　　见彼由如大法藏
  彼常说法离众惑　　十方世界无挂碍
  亦如月光普照耀　　教化众生千方便
  刹那刹那佛菩提　　即见十方诸世界
  常转法轮安世间　　勇猛遍转十方界
  彼诸声闻辟支地　　无边变化佛庄严
  复经不可思议劫　　化诸众生亲往诣
  若男若女童男女　　天人修罗龙王类
  药叉乃至摩护罗　　以解脱智皆悉见
  若诸世间众形类　　随众语言悉皆同
  一切勇猛皆尽见　　如是勇猛尽观察
  海印三昧从口生　　得是海印众三昧
  能严不可思议刹　　严饰不思议刹已
  供养十方诸如来　　如是种种供养已
  复得光明众严饰　　若得光严不思议
  则得无边解脱智　　若得无边解脱智
  得不思议身变化　　若得如是身变化
  口辩智辩亦如是　　若得口智无碍辩
  布施变化不思议　　若得布施不思议
  持戒忍进亦复然　　若得持戒忍进通
  禅定神变莫能测　　若得禅定神通变
  出生方便神变智　　得是方便神变智
  出生无边诸功德　　从佛口生三摩地
  三摩地入一微尘　　一切微尘皆尽入
  一微尘中难思刹　　一一微尘皆悉见
  如是佛刹微尘数　　其中佛刹尽皆睹
  种种微细清净众　　无上贵重微妙刹
  如实远离出兴世　　其中秘密妙升腾
  有以除暗放光明　　帝网重重复无尽
  由如见一大光明　　如是一切微尘尽
  此大仙行三摩地　　即是无边胜解脱
  三摩地力供养佛　　一切如来供养已
  复于手中变千万　　作大丈夫兴广供
  乃至十方妙华鬘　　涂香发越珍奇宝
  一一手中亲施与　　菩提大树诣佛所
  价直千万妙香衣　　种种幢幡及伞盖
  阎浮檀金庄严具　　彼自手中亲施与
  无边一切所受用　　清净供养于大仙
  手中奉上皆舍施　　住佛菩提大树王
  乃至一切众妓乐　　击鼓出众妙音声
  种种雅乐琴箜篌　　一一手中亲抚击
  种种赞呗妙伽陀　　种种称赞真实德
  无边一切十方界　　一一皆自手中作
  或以光明兴佛事　　皆从右旋而动作
  香水普洒诸佛刹　　供养一切世间灯
  光明严丽适意香　　莲华璎珞不思议
  莲华妙色无央数　　一一自作供诸佛
  放大光明严饰华　　种种微妙华云海
  如是妙华普周遍　　广大供养作佛事
  放大光明严饰香　　种种微妙香云海
  如是妙香普周遍　　广大供养作佛事
  放大光明涂香献　　种种涂香妙云海
  如是涂香普周遍　　广大供养作佛事
  放大光明鬘严饰　　种种微妙鬘云海
  如是妙鬘普周遍　　广大供养作佛事
  放大光明粖香严　　种种粖香妙云海
  如是妙香普周遍　　广大供养作佛事
  放大光明严饰衣　　种种微妙衣云海
  如是妙衣普周遍　　广大供养作佛事
  放大光明严饰盖　　种种微妙盖云海
  如是妙盖普周遍　　广大供养作佛事
  放大光明宝严饰　　种种微妙宝云海
  如是妙宝普周遍　　广大供养作佛事
  放大光明莲华严　　种种莲花妙云海
  如是妙花普周遍　　广大供养作佛事
  放大光明璎珞严　　种种璎珞妙云海
  如是璎珞普周遍　　广大供养作佛事
  放大光明幢庄严　　彼幢青黄具赤白
  无数妙宝众庄严　　众幢严饰彼佛刹
  种种严饰摩尼网　　悬缯幡盖妙花鬘
  垂珠璎珞演佛音　　持盖常在如来上
  假使供养一如来　　手自供给不可数
  如是尽诸一切佛　　此仙变化三摩地
  摄诸世间神通智　　是为最上三摩地
  善行一切众方便　　如是化导诸群生
  或有供养诸如来　　种种行施不思议
  尸罗清净头陀行　　无尽忍辱非动摇
  或有勇猛勤精进　　寂然禅定善修习
  智慧了达诸义趣　　能行一切善方便
  或行慈悲喜舍愿　　同事爱语利他力
  以智积集众福业　　解脱四谛十二缘
  或有根力觉道行　　声闻乘中得解脱
  观缘清净缘觉乘　　神通变化最上乘
  或见无常诸苦恼　　非命非身卒暴众
  非横烦恼障所缠　　三摩地力能蠲除
  于诸世间行精进　　演畅妙法化群生
  普愿一切皆解脱　　诱诸众生随世间
  彼诸形类莫能测　　神通密演三摩地
  严持欲乐妙变化　　随意引导诸世间
  悉令欢喜获安乐　　思念众生无暂舍
  若逢饥馑众难中　　种种安乐世所有
  一切爱乐悉从心　　为诸世间广施设
  常以珍味之饮食　　种种丽服及库藏
  王物我所爱乐舍　　一切世间随意施
  殊特妙好相严身　　巍巍上行无倾动
  涂香花鬘悦众心　　现是色相化群有
  见者爱乐生欢喜　　上妙智慧种种色
  见诸最上微妙色　　随意化导于世间
  迦陵频伽出妙音　　白鹄计罗俱拏声
  紧那罗鼓出梵音　　恒演如来解脱法
  八万四千如来藏　　一切胜义尽能行
  差别万法妙能宣　　随意化导诸众生
  众生苦恼悉同行　　非恶非善亦复尔
  造作一切诸行业　　随意化导诸众生
  若逢灾难苦恼中　　见彼如是难堪忍
  代诸众生受众苦　　安乐一切诸世间
  若法或有或不至　　无智无福无解脱
  与王于彼同敷畅　　拔济众生超彼岸
  能离贪爱众结缚　　名为世间解脱主
  一切欲乐尽能超　　出离解脱光明照
  彼放光明十种行　　能行调御众方便
  一切仙行悉了知　　观见世间随所作
  众生等同无量寿　　坦然安隐而快乐
  生老病苦不能侵　　决定自见无常趣
  如有众生乐灯明　　世间痴暗然大炬
  老病死苦恒炽然　　世间引导诸众生
  十力精进四无畏　　如来十八不共法
  我意思惟广大功　　于诸世间作佛事
  譬如世间诸幻术　　能现种种众色相
  见诸如来化亦然　　如是神变导诸有
  彼以种种方便行　　善言诱喻诸众生
  譬如莲华不着水　　随意造作差别行
  华辞捷利众语言　　妓舞戏玩相叉扑
  璎珞庄严舞旋转　　如幻现相各不同
  或作村营商主尊　　长者贾客市中主
  辅相大臣主给使　　医方大辩众论师
  或于旷野作大树　　珍宝妙药无尽藏
  如意摩尼给所须　　失路迷人为导引
  尽知未来生世间　　众生不知自作业
  经营农务众方便　　世间工巧种种行
  或现怨亲无憎爱　　安乐一切诸众生
  洞明方论种种法　　彼仙开决光明道
  若行最上大仙行　　天上人间皆解脱
  若诸出家苦行辈　　开彼最上一切智
  若诸外道出家众　　常持不语憍答摩
  裸形不动沙门相　　亦自依禀本师教
  或有常持舍身法　　或即执有执本无
  长发[髟/酉]髻童子相　　亦自依禀于本师
  或有事日五炙身　　狗戒牛戒鹿皮衣
  巡访三时行供养　　亦自依禀于本师
  或有常乐天中智　　无善无恶拨无因
  寻求根果水为食　　执为上味难思法
  或有蹲坐红色衣　　或有涂灰或卧草
  持捧题名搭肩行　　亦自依禀于本师
  乃至一一诸外道　　皆悉令彼离结缚
  彼行利智恶苦行　　如是外道皆接引
  世间同类皆教化　　邪见栖托本灵迹
  于彼方便演妙法　　说此正法令他作
  或演大乘真言行　　正法秘要妙言辞
  或于正直演实言　　其中或演天妙句
  或以文字得解脱　　法集妙义金刚句
  智慧破坏外论句　　论说种种解脱言
  或于人中演神咒　　宣扬一切妙章句
  其中或有天语言　　龙王语言药叉句
  或于罗刹步多言　　药叉毕舍干达嚩
  紧那罗女誐噜拏　　演斯妙法解脱义
  彼以智慧如法说　　若佛若法如是尽
  智道不可思议法　　说此三摩地变化
  解了世间三摩地　　行于一切诸世间
  或放光明难思议　　光明引接诸众生
  或放光明名妙观　　乃至众生因光信
  彼得不空妙观察　　无上智及无上因
  得见诸佛并闻法　　及见僧徒诸功德
  见塔赞佛甚希有　　及见清净光明照
  或放光明名普照　　遍照一切诸世间
  一一微尘彼尽知　　为欲安乐世间说
  彼光普照诸众生　　常持灯明供养佛
  持灯供养诸佛已　　世间所有众灯明
  或以酥灯及油灯　　松脂草竹及苇灯
  众香美味珍宝灯　　尽持光明施诸佛
  又放光明名遍照　　悉能观察诸众生
  贪爱轮回生死海　　为欲拔济诸群生
  光照轮回贪爱海　　悉令利乐诸有情
  皆得远离于四魔　　苦恼逼迫令安乐
  作诸桥梁无有数　　或于河路作船筏
  吒呵假伪赞息灾　　彼放光明皆尽照
  光明警悟渴乏者　　彼能觉悟诸众生
  远离贪欲获善利　　得为说法之导师
  若离欲贪获善利　　说法化导亦复尔
  得佛降霔甘露水　　济拔世间饥渴者
  或作池河及井潭　　穿凿造作为菩提
  呵毁爱欲称赞定　　呵责贪爱彼悉除
  怜愍众生放光明　　彼光遍警诸群有
  乐他变化住菩提　　念念生心我当得
  庄严相好莲华座　　大悲怜愍诸众生
  恒时演说佛功德　　放光令彼生忻庆
  又放光明名适意　　是光能觉诸有情
  于佛于法生爱敬　　及乐恒时事众僧
  既得佛法生忻庆　　及以给侍于众僧
  即礼如来圣功德　　是故得佛无上行
  遇诸如来并妙法　　得最无上忍辱行
  觉此众多诸有情　　念佛念法圣功德
  一一功德心觉悟　　彼放光明令趣求
  又放光明集福德　　此光能觉诸有情
  舍施无数种种行　　劝请无上大菩提
  所求如意皆满足　　如是种种物能施
  一切随意施设已　　积集福德放光明
  如是智者放光明　　彼光照察诸众生
  一法口宣无有尽　　刹那宣畅能观察
  法慧摄诸众生义　　智智悉能尽了知
  妙法胜义已宣扬　　即智放彼大光明
  若以智灯放光明　　彼光照察诸众生
  众生不空无生灭　　诸法自性即无性
  如幻如雾水月等　　如梦亦如镜中像
  法无主宰依于空　　善说出生智慧灯
  法力变化放光明　　彼光警悟诸众生
  无尽总持谁易得　　持诸如来妙法藏
  总持妙法修习已　　大仙之法常护持
  宣畅是法为世间　　是为法化放光明
  或以好舍放光明　　彼光能觉诸众生
  无常不久知快乐　　如是舍离彼皆得
  若诸众生我难伏　　了知自性如浮云
  知已好慧善安和　　是为好施放光明
  又放光明名忏悔　　照察毁禁诸众生
  戒法清净忏悔已　　心生远望当得佛
  若诸众生因持戒　　现业毁禁获清净
  彼同发此菩提心　　放此光明彼尽忏
  忍辱放光众严饰　　彼光照察诸众生
  嗔心极恶意难调　　先以忍辱彼即除
  自业难行忍辱行　　于心不动菩提道
  恒时称赞忍辱行　　是为忍辱众严饰
  又放光明光熠耀　　照察懈怠诸众生
  三宝上妙诸方便　　相续长时而供养
  三宝种种诸方便　　相续方便供养已
  即能远离于四魔　　疾得无上大菩提
  化诸众生行精进　　如是供养三宝已
  恒持妙法无尽时　　熠耀光明彼即得
  又放光明作忍辱　　普周觉察诸众生
  菩提远离贪嗔痴　　得心恒时无间断
  所有业行悉皆除　　远离一切诸不善
  称扬息灾赞禅定　　忍辱清净放光明
  智慧严饰放光明　　能觉痴暗诸众生
  若说正法得解脱　　遍能证入诸智根
  若闻正法得解脱　　遍能往诣根源已
  即得日灯三摩地　　得佛智慧妙光明
  王之所有我能施　　为求妙法住菩提
  即得常时演是法　　智慧光明庄严得
  若佛放此大光明　　彼光照察诸众生
  无数难思千如来　　现座妙好莲花上
  大觉如来解脱我　　无边变化演佛音
  作诸如来照察力　　即得放此佛光明
  又放光明施无畏　　部多恐怖诸众生
  救诸患难羁锁缚　　如是恐怖灾难者
  令诸众生得安隐　　悉能远离于杀生
  救诸业道患难者　　得大无畏放光明
  又放光明名安乐　　安诸得病缠绵者
  一切疾疫尽疗治　　安乐禅定三摩地
  种种医药花果实　　涂香末香珍宝味
  香水乳蜜及酥油　　饮食供养皆充足
  见诸如来放光明　　照察众生命终时
  教令念佛即见佛　　命终决定生佛刹
  临命终时若念佛　　见于佛像生爱敬
  佛为往彼而救度　　得见诸佛为说法
  又放光明名法光　　此光能觉诸众生
  闻法书写读诵持　　常得爱乐于诸法
  开敷妙法甚难值　　勤求妙法圆满意
  以诸方便获斯法　　是故说法光明得
  又放光明名语言　　佛子觉悟彼众生
  本愿声振三千界　　闻诸如来众言音
  高声称赞于大仙　　大声响亮钟铃施
  为诸世间佛语言　　是故得此语言光
  又放光明施甘露　　彼光能觉诸众生
  了知众生起心时　　一切功德相应行
  无数苦恼灾难中　　恒说虚假无安隐
  若常止息灾难除　　说施甘露悉皆得
  又放光明名最胜　　此光能觉诸众生
  胜戒三摩地亦然　　闻佛最胜大智慧
  无等净戒三摩地　　智慧第一大能仁
  称扬赞叹施菩提　　彼当得此胜光明
  为施无尽妙珍宝　　此宝供养于大仙
  施宝供佛及佛塔　　众生求宝而不获
  施诸珍宝得为佛　　是故放光如宝严
  又放光明往照耀　　是光觉悟诸众生
  适意涂香人不嗅　　彼行如来功德行
  天上人间所出香　　用为供养诸如来
  众多佛塔我尽涂　　是故放此涂香光

大方广总持宝光明经卷第四大方广总持宝光明经卷第五

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

  又放光明种种严　　种种幢幡及伞盖
  作诸妓乐及众香　　严持上妙杂花香
  如是种种供养佛　　花香烧香及粖香
  幢幡妙盖垂宝帐　　能出种种妙庄严
  又放光明发净心　　手持众宝而住立
  清净大仙佛塔处　　得此清净妙光明
  又放广大光明云　　复雨种种妙涂香
  涂香水洒塔界地　　是故得此光明云
  又放光明种种严　　裸者得衣而庄饰
  种种璎珞种种衣　　是故出生庄严施
  又放光明名众味　　施诸上味饥渴者
  种种上味之饮食　　施已获得大光明
  又放光明名胜义　　库藏珍宝施贫穷
  及施三宝无有尽　　是故檀行胜义成
  又放光明眼清净　　盲者得视众色相
  以灯供佛及佛塔　　获得放光清净眼
  又放光明耳清净　　聋者各得闻众声
  施佛音乐及佛塔　　获得清净光明耳
  又放光明清净鼻　　鼻根不具闻妙香
  施妙涂香佛及塔　　获得清净光明鼻
  又放光明清净舌　　得佛柔软慈意语
  远离粗犷杂秽言　　获得光明舌相好
  又放光明身清净　　身根不具复圆满
  舍身量等佛及塔　　是故得此清净身
  又放光明意清净　　一切妙意彼皆得
  因心意作三摩地　　得此清净意光明
  又放光明色清净　　思见仁王众色相
  种种妙色靡不周　　得获庄严光明塔
  又放光明声清净　　非声空声悉尽知
  生信由如于谷向　　放此清净声光明
  又放清净香光明　　一切臭气为妙香
  妙香水洒佛塔庙　　放光住此菩提树
  又放清净味光明　　有毒无毒变上味
  供佛声闻及父母　　施诸上味得光明
  又放光明触清净　　涩滑软触悉安乐
  剑戟箭枪如云雨　　变为柔软妙花鬘
  无数软衣触获安　　渡生往诣于佛所
  妙花涂香清净衣　　得施鬘盖放光明
  又放清净法光明　　一切毛端难思法
  为诸世间而出现　　得佛演说一切法
  信法自性本不生　　法身报身亦复尔
  法常寂住等虚空　　是故得获清净法
  光明现前应是作　　于大仙面一毛端
  出生殑伽沙等光　　一切各各随业因
  亦如现前一毛尘　　出现殑伽微尘等
  如是一切毛皆尽　　此三摩地大仙现
  若放光明如本行　　是光所作过去同
  彼若不现此光明　　云何神变等大仙
  彼得福德既同因　　随喜劝请亦如是
  若有得见悉获安　　是光自他俱解了
  若作福业善安和　　相续不断供养佛
  如来功德应忻求　　睹此光明如是作
  由如盲人不睹日　　不分昼夜及世间
  云何眼等能了色　　各各法义而得解
  调御放光亦如是　　分明示彼不自见
  未离颠倒妄想言　　毕竟不得廓彻意
  乘宝宫殿众严持　　种种资具妙香华
  大众无有能知者　　彼之疾病甚难袪
  调御光明亦如是　　此光自障不能知
  处诳妄语未能除　　毕竟不能心广大
  睹此光明能了别　　常得乐说而安乐
  彼身无疑妄想除　　离我即大功德幢
  变化主伴而庄严　　依此无上三摩地
  无边一切诸十方　　显示佛子并主伴
  种种三千微尘刹　　光明严饰莲花座
  一切身同跏趺坐　　变化示此三摩地
  自他十刹微尘等　　莲花坐彼诸眷属
  各各佛子众围绕　　安住遍入三摩地
  彼以大仙化导力　　众生从佛功德出
  互相围绕大莲华　　同时合掌而恭敬
  此法是大调御师　　若入寂静三摩地
  得诸弟子众围绕　　由如众星中朗月
  如彼入于一方中　　显示佛子并眷属
  一切方中此皆尽　　变化示此三摩地
  彼方覆闭悉蠲除　　最上三摩地行入
  或有从于三昧起　　自身显示于十方
  或有东方三昧中　　西方不起能摇动
  或有西方三昧中　　东方现起大人相
  悉能入此十方中　　异方复现诸三昧
  广能现此功德智　　大仙神变三摩地
  若尽异方一切刹　　无数如来皆往诣
  一一足下而致敬　　现住安乐三摩地
  或以三昧视众生　　西方尽刹而湛然
  一切如来悉现前　　现作无数诸供养
  如是西方尽见已　　复往阿僧祇佛刹
  于彼足下而致敬　　得住安乐三摩地
  彼以等持而正见　　尽于东方诸刹土
  一切如来悉现前　　又睹无数诸供养
  入此十方佛刹已　　一一方尽无动摇
  于中现起诸三昧　　种种供养世间灯
  彼于眼尘三昧中　　能现大色诸境界
  见此不可思议色　　天上人间悉愕然
  既睹色尘三昧已　　作是思惟眼尘境
  眼之自性非生灭　　是故开阐无相空
  或有耳尘三昧中　　能现大声诸境界
  入于一切语言音　　天上人间悉愕然
  既睹声尘三昧已　　审谛思惟耳尘境
  耳之自性非生灭　　是故开阐无相空
  或有鼻尘三昧中　　能现大香诸境界
  如是妙香悉遍入　　天上人间悉愕然
  既睹香尘三昧已　　复谛思惟鼻尘境
  鼻之自性非生灭　　是故开阐无相空
  或有舌尘三昧中　　能现大舌尘境界
  如是上味普周遍　　天上人间悉愕然
  既得上味三昧已　　审谛思惟舌尘境
  舌之自性非生灭　　是故开阐无相空
  或有身尘三昧中　　能现大触尘境界
  世间触尘普遍入　　天上人间悉愕然
  既睹触尘三昧已　　身尘遍起谛思惟
  身之自性非生灭　　是故开阐无相空
  或有心尘三昧中　　能现大法尘境界
  既睹法尘三昧已　　复谛思惟心尘境
  心之自性非生灭　　是故开阐无相空
  彼以三昧婴孩身　　出现盛年壮色住
  彼现盛年三昧已　　复住衰老朽痼身
  住此衰老身三昧　　复发心作优婆塞
  住此优婆塞三昧　　改质现作比丘身
  住此比丘身三昧　　即得多闻比丘身
  住此多闻身三昧　　即得有学无学身
  既住如是身三昧　　即得住于如来身
  住是如来身三昧　　得佛最上妙色身
  住此最上身三昧　　化身现作天人形
  从此天形身三昧　　出生众多大龙身
  从此大龙身三昧　　出生诸大药叉身
  从此药叉身三昧　　出生一切步多身
  从此步多身三昧　　现前出生一毛端
  从此一毛端三昧　　出生一切众毛端
  从此一切毛端中　　出生一发毛端尘
  从此一发尘三昧　　出现一切发尘境
  一一发尘三昧中　　复能出现微尘数
  若见一尘三昧已　　出生一切微尘尽
  若见一一尘三昧　　出生大海金刚际
  从此金刚际三昧　　出生摩尼树花果
  从此摩尼树三昧　　出现如来大光明
  从此如来光三昧　　出现一切江海水
  从此江海三昧中　　复现大火尘境界
  从此火尘三昧中　　出生风尘之思念
  从此风尘之三昧　　出生大地尘境界
  从此地尘三昧中　　出生一切天宫殿
  于此宫殿三昧中　　思念等彼虚空界
  三昧解脱不思议　　悉得无边诸功德
  复能照耀无边劫　　一切如来尽难量
  一切如来同说此　　世间业果难思议
  龙化云水佛入定　　定中变化不思议
  见彼出生说少分　　于中彼众悉惊怪
  法师方便智令知　　所说敏速能解了
  即得住于八解脱　　声闻得一即为多
  或是得多由如一　　观彼虚空光炽焰
  炎赫炽盛俱洞然　　周匝俱为炽火城
  火城下彻于水轮　　于轮坐卧而安住
  刹那身变不思议　　彼众无有大悲心
  菩提行远弃世间　　身虽变化不思议
  不能利他为世间　　譬如日月游虚空
  悉能照见十方界　　陂湖池沼及渊泉
  方圆大小宝海河　　悉现不思议色相
  如日照见于十方　　如智解脱诸三昧
  若见如来佛亦然　　澄湛池边四兵众
  各各于中而现形　　利剑弓刀箭甲胄
  兜鍪覆膊绦铁札　　亦如众色而庄严
  见彼如来光明网　　不分憎爱离疑惑
  解脱功德三摩地　　天中海内说彼名
  乃至众生出生海　　闻彼所说尽能知
  自身语言皆欢喜　　爱乐贪恚杂语言
  一切随类能了知　　得妙总持法之力
  人间天上过有无　　名为睹噜婆惹娑
  婆罗门女称赞彼　　志愿无有爱恚心
  为无嫉妒得超身　　虽有辩才爱恚存
  不能成就大檀行　　名称远闻于世间
  无人不喜智功德　　譬如明智作幻术
  能现种种无边色　　或于昼夜月一念
  百年由如于风烛　　云何幻化有爱恚
  世间变化如幻梦　　定知远离于解脱
  如智善修人皆喜　　天与修罗共斗战
  天得修罗自退散　　以盖覆上乘车辇
  兵甲自退而散走　　修罗于彼生爱恚
  自说身变不思议　　富贵勇猛无能敌
  现身变化能如是　　能持大龙及金刚
  帝释眷属乘大象　　此象头现三十三
  一一复现于六牙　　一一牙上现七池
  池中现水皆盈满　　一一池现七莲花
  莲花种种而庄严　　一一华中复现七
  天女一切悉能知　　能解歌舞众妓乐
  帝释天众同娱乐　　知彼自身复龙形
  得同一切而变化　　种种造作等庄严
  或时现龙为最上　　彼现有爱有恚痴
  随自福业现神变　　智力方便相应行
  非三摩地不能作　　由如罗睺身变现
  变为金刚缚足下　　现身海中水至脐
  头与妙高而同等　　彼有爱恚贪嗔痴
  罗睺神变力如是　　魔王破坏世间灯
  若现神变无有边　　帝释化现不思议
  天与修罗共战时　　制伏修罗不能变
  彼现自身于帝释　　能知修罗勇猛力
  同时自往帝释前　　各各执持于金刚
  修罗执持而战栗　　变现千眼能怖畏
  光明炽盛执金刚　　身披甲胄有大力
  修罗既睹而退走　　彼以薄福力不任
  帝释为天现神变　　一切世间尽能救
  说此神变福无尽　　空中天鼓劝诸天
  说于彼众业果报　　知天耽着于欲乐
  天鼓出声而救度　　观身无常不久停
  此等自性不能了　　如幻如云翳星月
  万物自性如梦觉　　一切烦恼怨家因
  除得甘露离无常　　其中若有乐耽着
  无常迅速如摩竭　　一切眷属悉遭苦
  圣者增长于一切　　乐着欲乐如盲人
  若有闻法免无常　　鼓为帝释常诫劝
  及诸天众说妙法　　恒时演畅妙语言
  无边烦恼能广说　　彼能现此无色相
  天鼓出于大音声　　随诸天意现众色
  广为无作诸众生　　天与修罗相持时
  以天福力胜于彼　　天鼓空中劝天人
  出众音声悉同彼　　天鼓劝令生忻喜
  得生远离兵怖畏　　修罗王众自退散
  刹那恐惧尽消除　　鼓施甘露经劫数
  救度一切诸世间　　彼离烦恼魔王众
  不受烦恼说安乐　　帝释天女九十二
  化身令他悉欢喜　　一一幻身与彼同
  一切天女各同示　　诸女同时贪欲乐
  若住自性妙法中　　而为开示演妙法
  帝释神变一刹那　　帝释有爱有恚痴
  唯自娱乐诸眷属　　无人于世恒方便
  世间变化离爱欲　　魔王斗诤住世间
  摄伏一切众生类　　烦恼业力索普缚
  愚迷众生不能脱　　彼等有爱有恚痴
  一切世间魔王摄　　住于十种业道中
  一切世间自破坏　　梵王宫殿三千主
  乃至梵王三千宫　　普现其身于中住
  梵天王出妙音声　　梵王于彼世间中
  定知梵王能变化　　彼经劫数如刹那
  不能一念生悲智　　过于三灾坏劫已
  不思议心诸世间　　众生业报心生风
  风能成就器世间　　四海众山天宫殿
  广大种子光明宝　　风能生云而降雨
  雨止风卷云自收　　风能成熟世所有
  安乐众多诸世间　　彼不学于波罗蜜
  亦复不学佛功德　　能现世间不思议
  虽能如是人莫睹　　乃至飞禽走战声
  女声童男童女声　　云雷震吼海潮声
  众生各各悉闻知　　各各闻于自性声
  以广大辩无碍知　　江河各出广大声
  世间娱乐妙音声　　如来法海甚希有
  能摄一切诸众海　　海得妙宝水无尽
  江河竞澍复不增　　由如一切世间海
  定慧解脱福无尽　　智智出生诸功德
  得福功德亦不增　　娑誐罗龙能自在
  从下往诣化乐天　　广布慈云四大洲
  无数种种而庄严　　化乐天中阎浮名
  现云普遍众妙色　　或变红珠光晃耀
  睹史多天金雪色　　焰摩天中吠琉璃
  忉利天中琉璃藏　　四大王天水精色
  金刚坚固海云色　　紧那罗宫香发越
  龙王宫中莲花色　　坚守大力乌黑色
  阿修罗宫山石色　　上妙金光阳焰色
  异域他州种种严　　赡部洲中青碧色
  云色各各随洲变　　化乐天中现金云
  由如闪电日光色　　妙色等同清净月
  睹史多天紫金色　　焰摩天中金雪同
  忉利天中琉璃色　　四大王天水精色
  金刚坚固海云色　　紧那罗宫香充满
  龙王宫中莲花色　　坚守大力乌黑色
  阿修罗宫铁山色　　上妙清净摩尼照
  种种差别而庄严　　赡部洲中月摩尼
  电光所至亦如云　　化乐天与梵王天
  同现鼓声悉周遍　　睹史多天雅乐声
  焰摩宫中天女声　　四大王天干达嚩
  山相击声海潮声　　紧那罗笛俱拏声
  龙宫迦陵频伽声　　坚守宫中龙女声
  修罗宫中琴瑟声　　人声海声笙簧声
  化乐天中天妙香　　雨花种种而庄严
  妙摩尼月妙月中　　曼陀花鬘及涂香
  睹史多天摩尼色　　种种妙宝众严饰
  如月光明摩尼髻　　缤纷乱雨金色衣
  种种幢幡及宝盖　　严持涂香妙华鬘
  金色真珠红色衣　　焰摩天中恒时雨
  忉利天中如意珠　　涂香栴檀及沉水
  功姑摩蕊天妙鬘　　香水及雨众妙花
  珍异饮食增长力　　得香美味貌熙怡
  殊特妙宝不思议　　雨四天王及龙宫
  雨于大海能坚牢　　如是无量无有尽
  库藏无尽甚广大　　恒雨无边胜妙宝
  妙衣庄严彼充满　　又雨粖香末利香
  或作雅妙琴瑟声　　紧那罗女雨璎珞
  龙宫恒雨红色珠　　坚守光明摩尼宝
  破坏冤家弓敏捷　　修罗宫中雨剑戟
  无价璎珞令彼安　　雨鬘末利瞻波迦
  雨于清净俱阑拏　　更雨种种妙灯光
  阎浮提人皆欢喜　　复能忻乐妙法雨
  花树果树及香树　　天妙众物安世间
  如是难思云庄严　　霹雳雷声雨庄严
  如是龙变难思议　　彼恒住于大海水
  龙现变化上难思　　若入法海功德中
  无边变化非测量　　此义譬喻说少分
  如是说彼调御师　　此勇猛智离譬喻
  若此现住解脱门　　说此解脱为最上
  广大微妙无上意　　得未曾有真实意
  如是胜上甚深意　　是法难行希希有
  世间所有行行人　　若闻最上解脱已
  世间恭敬而称赞　　众生身道难得闻
  如是此法能尊重　　若能作福获安乐
  自他因力而恭敬　　彼于人间离疑惑
  声闻乘中不生疑　　辟支佛乘亦复然
  彼复不疑众多乘　　住彼大乘未为难
  恭敬此经甚难得　　云何读诵而受持
  若住此法云何行　　假使三千山及海
  尽未来劫而顶戴　　如是勤苦未为难
  恭敬此经甚为难　　三千微尘等众生
  一一于前经劫住　　如是胜福未为难
  信此经者甚为难　　假使十刹山及海
  如此而能掌中持　　如是勤苦未为难
  恭敬此经甚难得　　十刹微尘等众生
  一一面前经劫住　　最胜福报未为难
  信此经者甚难得　　十刹微尘等如来
  一一经劫面前住　　若于此法读诵持
  胜前功德阿庾多　　如来开此解脱门
  若于十方一切刹　　悉能降伏魔王宫
  导引无罪悉安隐　　若诸十方仁师子
  彼从口中现一切　　舒手安于头顶上
  无边功德普吉祥　　一切如来口中出
  如来以手摩其顶　　解脱法门应善说
  汝等应当广流布　　勿令此法而断绝
  世尊佛说此伽他　　说已默然而寂住

尔时三千大千世界。一切诸天及诸人民海会圣众同作是言。此是如来第二会转此法轮。赞言善哉善说世尊希有希有。我等过去未曾闻。说如是正法。若有众生。闻此正法。甚为希有。即得不生贫穷下贱之家。心得平等。由如供养恭敬众多如来。是诸众生展转相教。如佛塔庙。彼诸众生。天上人间。魔王眷属。彼不能害。若诸人天在家出家。是诸国王及诸大臣长者宰官亦不能害

是时尊者须菩提。白佛言世尊。希有如来云何得此。如是宝光明经正法行于世间。此众经中宝。皆是如来威神力故。出现世间。复次是诸众生。得闻是法。亦是如来威神力故

尔时世尊复开金口。告尊者阿难言。汝当受持。阿难。如是正法。勤心精进受持读诵。是时尊者阿难。绕佛三匝而作是言。世尊。我当受持如是正法永不忘失。佛说此经已。一切圣众菩萨。普贤菩萨。妙吉祥童子。尊者舍利弗等。诸大声闻。天人阿修罗干达嚩等。闻佛所说。皆大欢喜顶礼而去

大方广总持宝光明经卷第五


大周新译大方广佛华严经序

    No. 279 [No. 278]

    大周新译大方广佛华严经序

        天册金轮圣神皇帝制

盖闻造化权舆之首。天道未分。龟龙系象之初。人文始着。虽万八千岁。同临有截之区。七十二君。讵识无边之义。由是人迷四忍。轮回于六趣之中。家缠五盖。没溺于三涂之下。及夫鹫岩西峙。象驾东驱。慧日法王。超四大而高视。中天调御。越十地以居尊。包括铁围。延促沙劫。其为体也。则不生不灭。其为相也。则无去无来。念处正勤。三十七品。为其行。慈悲喜舍。四无量法。运其心。方便之力难思。圆对之机多绪混大空而为量。岂算数之能穷。入纤芥之微区。匪名言之可述。无得而称者其唯大觉欤。朕曩劫植因。叨承佛记。金仙降旨。大云之偈先彰。玉扆披祥。宝雨之文后及。加以积善余庆。俯集微躬。遂得地平天成。河清海晏。殊祯绝瑞。既日至而月书。贝牒灵文。亦时臻而岁洽。逾海越漠。献賝之礼备焉。架险航深。重译之辞罄矣

大方广佛华严经者。斯乃诸佛之密藏。如来之性海。视之者莫识其指归。挹之者。罕测其涯际。有学无学。志绝窥觎。二乘三乘。宁希听受。最胜种智。庄严之迹既隆。普贤文殊。愿行之因斯满。一句之内。包法界之无边。一毫之中。置刹土而非隘。摩竭陀国。肇兴妙会之缘。普光法堂。爰敷寂灭之理。缅惟奥义。译在晋朝。时逾六代。年将四百。然一部之典。才获三万余言。唯启半珠。未窥全宝。朕闻其梵本。先在于阗国中。遣使奉迎。近方至此。既睹百千之妙颂。乃披十万之正文。粤以证圣元年。岁次乙未。月旅沽洗。朔惟戊申。以其十四日辛酉。于大遍空寺。亲受笔削。敬译斯经。遂得甘露流津。预梦庚申之夕。膏雨洒润。后覃壬戌之辰。式开实相之门。还符一味之泽。以圣历二年。岁次己亥。十月壬午朔。八日己丑。缮写毕功。添性海之波澜。廓法界之疆域。大乘顿教。普被于无穷。方广真筌。遐该于有识。岂谓后五百岁。忽奉金口之言。娑婆境中。俄启珠函之秘。所冀。阐扬沙界。宣畅尘区。并两曜而长悬。弥十方而永布。一窥宝偈。庆溢心灵。三复幽宗。喜盈身意。虽则无说无示。理符不二之门。然因言显言。方阐大千之义。辄申鄙作。爰题序云

大方广佛华严经卷第一

        于阗国三藏实叉难陀奉　制译

    世主妙严品第一之一

如是我闻。一时佛在摩竭提国。阿兰若法菩提场中。始成正觉。其地坚固。金刚所成。上妙宝轮。及众宝华。清净摩尼。以为严饰。诸色相海。无边显现。摩尼为幢。常放光明。恒出妙音。众宝罗网。妙香华缨。周匝垂布。摩尼宝王。变现自在。雨无尽宝及众妙华。分散于地。宝树行列。枝叶光茂。佛神力故。令此道场一切庄严于中影现。其菩提树高显殊特。金刚为身。琉璃为干。众杂妙宝以为枝条。宝叶扶疏垂荫如云。宝华杂色。分枝布影。复以摩尼而为其果。含辉发焰。与华间列。其树周圆。咸放光明。于光明中雨摩尼宝。摩尼宝内。有诸菩萨。其众如云。俱时出现。又以如来威神力故。其菩提树。恒出妙音。说种种法。无有尽极。如来所处宫殿楼阁。广博严丽。充遍十方。众色摩尼之所集成。种种宝华以为庄校。诸庄严具。流光如云。从宫殿间。萃影成幢。无边菩萨。道场众会。咸集其所。以能出现诸佛光明不思议音。摩尼宝王而为其网。如来自在神通之力。所有境界。皆从中出。一切众生居处屋宅。皆于此中现其影像。又以诸佛神力所加。一念之间。悉包法界。其师子座。高广妙好。摩尼为台。莲华为网。清净妙宝。以为其轮。众色杂华而作璎珞。堂榭楼阁。阶砌户牖。凡诸物像。备体庄严。宝树枝果。周回间列。摩尼光云。互相照耀。十方诸佛。化现珠玉。一切菩萨。髻中妙宝。悉放光明而来莹烛。复以诸佛威神所持。演说如来广大境界。妙音遐畅。无处不及。尔时世尊。处于此座。于一切法。成最正觉。智入三世悉皆平等。其身充满一切世间。其音普顺十方国土。譬如虚空具含众像。于诸境界无所分别。又如虚空普遍一切。于诸国土。平等随入。身恒遍坐一切道场。菩萨众中。威光赫奕。如日轮出。照明世界。三世所行。众福大海。悉已清净。而恒示生诸佛国土。无边色相。圆满光明。遍周法界。等无差别。演一切法。如布大云。一一毛端。悉能容受一切世界而无障碍。各现无量神通之力。教化调伏一切众生。身遍十方而无来往。智入诸相。了法空寂。三世诸佛。所有神变。于光明中。靡不咸睹一切佛土。不思议劫。所有庄严。悉令显现

有十佛世界微尘数菩萨摩诃萨。所共围绕。其名曰普贤菩萨摩诃萨。普德最胜灯光照菩萨摩诃萨。普光师子幢菩萨摩诃萨。普宝焰妙光菩萨摩诃萨。普音功德海幢菩萨摩诃萨。普智光照如来境菩萨摩诃萨。普宝髻华幢菩萨摩诃萨。普觉悦意声菩萨摩诃萨。普清净无尽福光菩萨摩诃萨。普光明相菩萨摩诃萨。海月光大明菩萨摩诃萨。云音海光无垢藏菩萨摩诃萨。功德宝髻智生菩萨摩诃萨。功德自在王大光菩萨摩诃萨。善勇猛莲华髻菩萨摩诃萨。普智云日幢菩萨摩诃萨。大精进金刚脐菩萨摩诃萨。香焰光幢菩萨摩诃萨。大明德深美音菩萨摩诃萨。大福光智生菩萨摩诃萨。如是等而为上首。有十佛世界微尘数。此诸菩萨。往昔皆与毗卢遮那如来。共集善根。修菩萨行。皆从如来善根海生。诸波罗蜜。悉已圆满。慧眼明彻。等观三世。于诸三昧。具足清净。辩才如海。广大无尽。具佛功德。尊严可敬。知众生根。如应化伏入法界藏。智无差别证佛解脱。甚深广大。能随方便。入于一地。而以一切愿海所持。恒与智俱尽未来际。了达诸佛希有广大秘密之境。善知一切佛平等法。已践如来普光明地。入于无量三昧海门。于一切处。皆随现身。世法所行。悉同其事。总持广大。集众法海。辩才善巧。转不退轮。一切如来功德大海。咸入其身。一切诸佛所在国土。皆随愿往。已曾供养一切诸佛。无边际劫。欢喜无倦。一切如来得菩提处。常在其中。亲近不舍。恒以所得普贤愿海。令一切众生智身具足。成就如是无量功德

复有佛世界微尘数执金刚神。所谓妙色那罗延执金刚神。日轮速疾幢执金刚神。须弥华光执金刚神。清净云音执金刚神。诸根美妙执金刚神。可爱乐光明执金刚神。大树雷音执金刚神。师子王光明执金刚神。密焰胜目执金刚神。莲华光摩尼髻执金刚神。如是等而为上首。有佛世界微尘数。皆于往昔无量劫中。恒发大愿。愿常亲近供养诸佛。随愿所行。已得圆满到于彼岸。积集无边清净福业。于诸三昧所行之境。悉已明达。获神通力。随如来住。入不思议解脱境界。处于众会。威光特达。随诸众生所应现身。而示调伏。一切诸佛。化形所在。皆随化往。一切如来所住之处。常勤守护

复有佛世界微尘数身众神。所谓华髻庄严身众神。光照十方身众神。海音调伏身众神。净华严髻身众神。无量威仪身众神。最上光严身众神。净光香云身众神。守护摄持身众神。普现摄取身众神。不动光明身众神。如是等而为上首。有佛世界微尘数。皆于往昔。成就大愿供养承事一切诸佛

复有佛世界微尘数足行神。所谓。宝印手足行神。莲华光足行神。清净华髻足行神。摄诸善见足行神。妙宝星幢足行神。乐吐妙音足行神。栴檀树光足行神。莲华光明足行神。微妙光明足行神。积集妙华足行神。如是等而为上首。有佛世界微尘数。皆于过去无量劫中。亲近如来。随逐不舍

复有佛世界微尘数道场神。所谓。净庄严幢道场神。须弥宝光道场神。雷音幢相道场神。雨华妙眼道场神。华缨光髻道场神。雨宝庄严道场神。勇猛香眼道场神。金刚彩云道场神。莲华光明道场神。妙光照耀道场神。如是等而为上首。有佛世界微尘数。皆于过去。值无量佛。成就愿力。广兴供养

复有佛世界微尘数主城神。所谓。宝峰光耀主城神。妙严宫殿主城神。清净喜宝主城神。离忧清净主城神。华灯焰眼主城神。焰幢明现主城神。盛福光明主城神。清净光明主城神。香髻庄严主城神。妙宝光明主城神。如是等而为上首。有佛世界微尘数。皆于无量不思议劫。严净如来所居宫殿

复有佛世界微尘数主地神。所谓。普德净华主地神。坚福庄严主地神。妙华严树主地神。普散众宝主地神。净目观时主地神。妙色胜眼主地神。香毛发光主地神。悦意音声主地神。妙华旋髻主地神。金刚严体主地神。如是等而为上首。有佛世界微尘数。皆于往昔。发深重愿。愿常亲近诸佛如来。同修福业

复有无量主山神。所谓。宝峰开华主山神。华林妙髻主山神。高幢普照主山神。离尘净髻主山神。光照十方主山神。大力光明主山神。威光普胜主山神。微密光轮主山神。普眼现见主山神。金刚密眼主山神。如是等而为上首。其数无量。皆于诸法。得清净眼

复有不可思议数主林神。所谓。布华如云主林神。擢干舒光主林神。生芽发耀主林神。吉祥净叶主林神。垂布焰藏主林神。清净光明主林神。可意雷音主林神。光香普遍主林神。妙光回耀主林神。华果光味主林神。如是等而为上首。不思议数。皆有无量可爱光明

复有无量主药神。所谓。吉祥主药神。栴檀林主药神。清净光明主药神。名称普闻主药神。毛孔光明主药神。普治清净主药神。大发吼声主药神。蔽日光幢主药神。明见十方主药神。益气明目主药神。如是等而为上首。其数无量。性皆离垢。仁慈祐物

复有无量主稼神。所谓。柔软胜味主稼神。时华净光主稼神。色力勇健主稼神。增长精气主稼神。普生根果主稼神。妙严环髻主稼神。润泽净华主稼神。成就妙香主稼神。见者爱乐主稼神。离垢净光主稼神。如是等而为上首。其数无量。莫不皆得大喜成就

复有无量主河神。所谓。普发迅流主河神。普洁泉涧主河神。离尘净眼主河神。十方遍吼主河神。救护众生主河神。无热净光主河神。普生欢喜主河神。广德胜幢主河神。光照普世主河神。海德光明主河神。如是等而为上首。有无量数。皆勤作意。利益众生

复有无量主海神。所谓。出现宝光主海神。成金刚幢主海神。远尘离垢主海神。普水宫殿主海神。吉祥宝月主海神。妙华龙髻主海神。普持光味主海神。宝焰华光主海神。金刚妙髻主海神。海潮雷声主海神。如是等而为上首。其数无量。悉以如来功德大海。充满其身。复有无量主水神。所谓。普兴云幢主水神。海潮云音主水神。妙色轮髻主水神。善巧漩澓主水神。离垢香积主水神。福桥光音主水神。知足自在主水神。净喜善音主水神。普现威光主水神。吼音遍海主水神。如是等而为上首。其数无量。常勤救护一切众生。而为利益。复有无数主火神。所谓。普光焰藏主火神。普集光幢主火神。大光普照主火神。众妙宫殿主火神。无尽光髻主火神。种种焰眼主火神。十方宫殿如须弥山主火神。威光自在主火神。光明破暗主火神。雷音电光主火神。如是等而为上首。不可称数。皆能示现种种光明。令诸众生热恼除灭

复有无量主风神。所谓。无碍光明主风神。普现勇业主风神。飘击云幢主风神。净光庄严主风神。力能竭水主风神。大声遍吼主风神。树杪垂髻主风神。所行无碍主风神。种种宫殿主风神。大光普照主风神。如是等而为上首。其数无量。皆勤散灭我慢之心

复有无量主空神。所谓。净光普照主空神。普游深广主空神。生吉祥风主空神。离障安住主空神。广步妙髻主空神。无碍光焰主空神。无碍胜力主空神。离垢光明主空神。深远妙音主空神。光遍十方主空神。如是等而为上首。其数无量。心皆离垢。广大明洁

复有无量主方神。所谓。遍住一切主方神。普现光明主方神。光行庄严主方神。周行不碍主方神。永断迷惑主方神。普游净空主方神。大云幢音主方神。髻目无乱主方神。普观世业主方神。周遍游览主方神。如是等而为上首。其数无量。能以方便。普放光明。恒照十方。相续不绝

复有无量主夜神。所谓。普德净光主夜神。喜眼观世主夜神。护世精气主夜神。寂静海音主夜神。普现吉祥主夜神。普发树华主夜神。平等护育主夜神。游戏快乐主夜神。诸根常喜主夜神。出生净福主夜神。如是等而为上首。其数无量。皆勤修习。以法为乐

复有无量主昼神。所谓。示现宫殿主昼神。发起慧香主昼神。乐胜庄严主昼神。香华妙光主昼神。普集妙药主昼神。乐作喜目主昼神。普现诸方主昼神。大悲光明主昼神。善根光照主昼神。妙华璎珞主昼神。如是等而为上首。其数无量。皆于妙法。能生信解。恒共精勤。严饰宫殿

复有无量阿修罗王。所谓。罗睺阿修罗王。毗摩质多罗阿修罗王。巧幻术阿修罗王。大眷属阿修罗王。大力阿修罗王。遍照阿修罗王。坚固行妙庄严阿修罗王。广大因慧阿修罗王。出现胜德阿修罗王。妙好音声阿修罗王。如是等而为上首

其数无量。悉已精勤。摧伏我慢及诸烦恼

复有不可思议数迦楼罗王。所谓大速疾力迦楼罗王。无能坏宝髻迦楼罗王。清净速疾迦楼罗王。心不退转迦楼罗王。大海处摄持力迦楼罗王。坚固净光迦楼罗王。巧严冠髻迦楼罗王。普捷示现迦楼罗王。普观海迦楼罗王。普音广目迦楼罗王。如是等而为上首。不思议数。悉已成就大方便力。善能救摄一切众生

复有无量紧那罗王。所谓。善慧光明天紧那罗王。妙华幢紧那罗王。种种庄严紧那罗王。悦意吼声紧那罗王。宝树光明紧那罗王。见者欣乐紧那罗王。最胜光庄严紧那罗王。微妙华幢紧那罗王。动地力紧那罗王。摄伏恶众紧那罗王。如是等而为上首。其数无量。皆勤精进。观一切法。心恒快乐。自在游戏

复有无量摩睺罗伽王。所谓。善慧摩睺罗伽王。清净威音摩睺罗伽王。胜慧庄严髻摩睺罗伽王。妙目主摩睺罗伽王。如灯幢为众所归摩睺罗伽王。最胜光明幢摩睺罗伽王。师子臆摩睺罗伽王。众妙庄严音摩睺罗伽王。须弥坚固摩睺罗伽王。可爱乐光明摩睺罗伽王。如是等而为上首。其数无量。皆勤修习广大方便。令诸众生永割痴网

复有无量夜叉王。所谓。毗沙门夜叉王。自在音夜叉王。严持器仗夜叉王。大智慧夜叉王。焰眼主夜叉王。金刚眼夜叉王。勇健臂夜叉王。勇敌大军夜叉王。富资财夜叉王。力坏高山夜叉王。如是等而为上首。其数无量。皆勤守护一切众生

复有无量诸大龙王。所谓。毗楼博叉龙王。娑竭罗龙王。云音妙幢龙王。焰口海光龙王。普高云幢龙王。德叉迦龙王。无边步龙王。清净色龙王。普运大声龙王。无热恼龙王。如是等而为上首。其数无量。莫不勤力。兴云布雨。令诸众生热恼消灭

复有无量鸠槃荼王。所谓。增长鸠槃荼王。龙主鸠槃荼王。善庄严幢鸠槃荼王。普饶益行鸠槃荼王。甚可怖畏鸠槃荼王。美目端严鸠槃荼王。高峰慧鸠槃荼王。勇健臂鸠槃荼王。无边净华眼鸠槃荼王。广大天面阿修罗眼鸠槃荼王。如是等而为上首。其数无量。皆勤修学无碍法门。放大光明

复有无量乾闼婆王。所谓。持国乾闼婆王。树光乾闼婆王。净目乾闼婆王。华冠乾闼婆王。普音乾闼婆王。乐摇动妙目乾闼婆王。妙音师子幢乾闼婆王。普放宝光明乾闼婆王。金刚树华幢乾闼婆王。乐普现庄严乾闼婆王。如是等而为上首。其数无量。皆于大法。深生信解。欢喜爱重。勤修不倦

复有无量月天子。所谓。月天子。华王髻光明天子。众妙净光明天子。安乐世间心天子。树王眼光明天子。示现清净光天子。普游不动光天子。星宿王自在天子。净觉月天子。大威德光明天子。如是等而为上首。其数无量。皆勤显发众生心宝

复有无量日天子。所谓。日天子。光焰眼天子。须弥光可畏敬幢天子。离垢宝庄严天子。勇猛不退转天子。妙华缨光明天子。最胜幢光明天子。宝髻普光明天子。光明眼天子。持胜德天子。普光明天子。如是等而为上首。其数无量。皆勤修习。利益众生。增其善根

复有无量三十三天王。所谓。释迦因陀罗天王。普称满音天王。慈目宝髻天王。宝光幢名称天王。发生喜乐髻天王。可爱乐正念天王。须弥胜音天王。成就念天王。可爱乐净华光天王。智日眼天王。自在光明能觉悟天王。如是等而为上首。其数无量。皆勤发起一切世间广大之业

复有无量须夜摩天王。所谓。善时分天王。可爱乐光明天王。无尽慧功德幢天王。善变化端严天王。总持大光明天王。不思议智慧天王。轮脐天王。光焰天王。光照天王。普观察大名称天王。如是等而为上首。其数无量。皆勤修习广大善根。心常喜足

复有不可思议数兜率陀天王。所谓。知足天王。喜乐海髻天王。最胜功德幢天王。寂静光天王。可爱乐妙目天王。宝峰净月天王。最胜勇健力天王。金刚妙光明天王。星宿庄严幢天王。可爱乐庄严天王。如是等而为上首不思议数。皆勤念持一切诸佛所有名号

复有无量化乐天王。所谓。善变化天王。寂静音光明天王。变化力光明天王。庄严主天王。念光天王。最上云音天王。众妙最胜光天王。妙髻光明天王。成就喜慧天王。华光髻天王。普见十方天王。如是等而为上首。其数无量。皆勤调伏一切众生。令得解脱

复有无数他化自在天王。所谓。得自在天王。妙目主天王。妙冠幢天王。勇猛慧天王。妙音句天王。妙光幢天王。寂静境界门天王。妙轮庄严幢天王。华蕊慧自在天王。因陀罗力妙庄严光明天王。如是等而为上首。其数无量。皆勤修习自在方便广大法门

复有不可数大梵天王。所谓。尸弃天王。慧光天王。善慧光明天王。普云音天王。观世言音自在天王。寂静光明眼天王。光遍十方天王。变化音天王。光明照耀眼天王。悦意海音天王。如是等而为上首。不可称数。皆具大慈。怜愍众生。舒光普照。令其快乐

复有无量光音天王。所谓。可爱乐光明天王。清净妙光天王。能自在音天王。最胜念智天王。可爱乐清净妙音天王。善思惟音天王。普音遍照天王。甚深光音天王。无垢称光明天王。最胜净光天王。如是等而为上首。其数无量。皆住广大寂静喜乐无碍法

复有无量遍净天王。所谓。清净名称天王。最胜见天王。寂静德天王。须弥音天王。净念眼天王。可爱乐最胜光照天王。世间自在主天王。光焰自在天王。乐思惟法变化天王。变化幢天王。星宿音妙庄严天王。如是等而为上首。其数无量。悉已安住广大法门。于诸世间。勤作利益

复有无量广果天王。所谓。爱乐法光明幢天王。清净庄严海天王。最胜慧光明天王。自在智慧幢天王。乐寂静天王。普智眼天王。乐旋慧天王。善种慧光明天王。无垢寂静光天王。广大清净光天王。如是等而为上首。其数无量。莫不皆以寂静之法。而为宫殿安住其中

复有无数大自在天王。所谓。妙焰海天王。自在名称光天王。清净功德眼天王。可爱乐大慧天王。不动光自在天王。妙庄严眼天王。善思惟光明天王。可爱乐大智天王。普音庄严幢天王。极精进名称光天王。如是等而为上首。不可称数。皆勤观察无相之法。所行平等

大方广佛华严经卷第一大方广佛华严经卷第二

        于阗国三藏实叉难陀奉　制译

    世主妙严品第一之二

尔时如来道场众海。悉已云集。无边品类。周匝遍满。形色部从。各各差别。随所来方。亲近世尊。一心瞻仰。此诸众会。已离一切烦恼心垢及其余习。摧重障山。见佛无碍。如是皆以毗卢遮那如来往昔之时。于劫海中修菩萨行。以四摄事而曾摄受。一一佛所。种善根时。皆已善摄。种种方便。教化成熟。令其安立一切智道。种无量善。获众大福。悉已入于方便愿海。所行之行。具足清净。于出离道。已能善出。常见于佛。分明照了。以胜解力。入于如来功德大海。得于诸佛解脱之门。游戏神通。所谓妙焰海大自在天王。得法界虚空界寂静方便力解脱门。自在名称光天王。得普观一切法悉自在解脱门。清净功德眼天王。得知一切法不生不灭不来不去无功用行解脱门。可爱乐大慧天王。得现见一切法真实相智慧海解脱门。不动光自在天王。得与众生无边安乐大方便定解脱门。妙庄严眼天王。得令观寂静法灭诸痴暗怖解脱门。善思惟光明天王。得善入无边境界不起一切诸有思惟业解脱门。可爱乐大智天王。得普往十方说法而不动无所依解脱门。普音庄严幢天王。得入佛寂静境界普现光明解脱门。名称光善精进天王。得住自所悟处而以无边广大境界为所缘解脱门。尔时妙焰海天王。承佛威力。普观一切自在天众。而说颂言

  佛身普遍诸大会　　充满法界无穷尽
  寂灭无性不可取　　为救世间而出现
  如来法王出世间　　能然照世妙法灯
  境界无边亦无尽　　此自在名之所证
  佛不思议离分别　　了相十方无所有
  为世广开清净道　　如是净眼能观见
  如来智慧无边际　　一切世间莫能测
  永灭众生痴暗心　　大慧入此深安住
  如来功德不思议　　众生见者烦恼灭
  普使世间获安乐　　不动自在天能见
  众生痴暗常迷覆　　如来为说寂静法
  是则照世智慧灯　　妙眼能知此方便
  如来清净妙色身　　普现十方无有比
  此身无性无依处　　善思惟天所观察
  如来音声无限碍　　堪受化者靡不闻
  而佛寂然恒不动　　此乐智天之解脱
  寂静解脱天人主　　十方无处不现前
  光明照耀满世间　　此无碍法严幢见
  佛于无边大劫海　　为众生故求菩提
  种种神通化一切　　名称光天悟斯法

复次可爱乐法光明幢天王。得普观一切众生根为说法断疑解脱门。净庄严海天王。得随忆念令见佛解脱门。最胜慧光明天王。得法性平等无所依庄严身解脱门。自在智慧幢天王。得了知一切世间法一念中安立不思议庄严海解脱门。乐寂静天王。得于一毛孔现不思议佛刹无障碍解脱门。普智眼天王。得入普门观察法界解脱门。乐旋慧天王。得为一切众生种种出现无边劫常现前解脱门。善种慧光明天王。得观一切世间境界入不思议法解脱门。无垢寂静光天王。得示一切众生出要法解脱门。广大清净光天王。得观察一切应化众生令入佛法解脱门

尔时可爱乐法光明幢天王。承佛威力。普观一切少广天无量广天广果天众。而说颂言

  诸佛境界不思议　　一切众生莫能测
  普令其心生信解　　广大意乐无穷尽
  若有众生堪受法　　佛威神力开导彼
  令其恒睹佛现前　　严海天王如是见
  一切法性无所依　　佛现世间亦如是
  普于诸有无依处　　此义胜智能观察
  随诸众生心所欲　　佛神通力皆能现
  各各差别不思议　　此智幢王解脱海
  过去所有诸国土　　一毛孔中皆示现
  此是诸佛大神通　　爱乐寂静能宣说
  一切法门无尽海　　同会一法道场中
  如是法性佛所说　　智眼能明此方便
  十方所有诸国土　　悉在其中而说法
  佛身无去亦无来　　爱乐慧旋之境界
  佛观世法如光影　　入彼甚深幽奥处
  说诸法性常寂然　　善种思惟能见此
  佛善了知诸境界　　随众生根雨法雨
  为启难思出要门　　此寂静天能悟入
  世尊恒以大慈悲　　利益众生而出现
  等雨法雨充其器　　清净光天能演说

复次清净慧名称天王。得了达一切众生解脱道方便解脱门。最胜见天王。得随一切诸天众所乐如光影普示现解脱门。寂静德天王。得普严净一切佛境界大方便解脱门。须弥音天王。得随诸众生永流转生死海解脱门。净念眼天王。得忆念如来调伏众生行解脱门。可爱乐普照天王。得普门陀罗尼海所流出解脱门。世间自在主天王。得能令众生值佛生信藏解脱门。光焰自在天王。得能令一切众生闻法信喜而出离解脱门。乐思惟法变化天王。得入一切菩萨调伏行如虚空无边无尽解脱门。变化幢天王。得观众生无量烦恼普悲智解脱门。尔时清净慧名称天王。承佛威力。普观一切少净天无量净天遍净天众。而说颂言

  了知法性无碍者　　普现十方无量刹
  说佛境界不思议　　令众同归解脱海
  如来处世无所依　　譬如光影现众国
  法性究竟无生起　　此胜见王所入门
  无量劫海修方便　　普净十方诸国土
  法界如如常不动　　寂静德天之所悟
  众生愚痴所覆障　　盲暗恒居生死中
  如来示以清净道　　此须弥音之解脱
  诸佛所行无上道　　一切众生莫能测
  示以种种方便门　　净眼谛观能悉了
  如来恒以总持门　　譬如刹海微尘数
  示教众生遍一切　　普照天王此能入
  如来出世甚难值　　无量劫海时一遇
  能令众生生信解　　此自在天之所得
  佛说法性皆无性　　甚深广大不思议
  普使众生生净信　　光焰天王能善了
  三世如来功德满　　化众生界不思议
  于彼思惟生庆悦　　如是乐法能开演
  众生没在烦恼海　　愚痴见浊甚可怖
  大师哀愍令永离　　此化幢王所观境
  如来恒放大光明　　一一光中无量佛
  各各现化众生事　　此妙音天所入门

复次可爱乐光明天王。得恒受寂静乐而能降现消灭世间苦解脱门。清净妙光天王。得大悲心相应海一切众生喜乐藏解脱门。自在音天王。得一念中普现无边劫一切众生福德力解脱门。最胜念智天王。得普使成住坏一切世间皆悉如虚空清净解脱门。可爱乐净妙音天王。得爱乐信受一切圣人法解脱门。善思惟音天王。得能经劫住演说一切地义及方便解脱门。演庄严音天王。得一切菩萨从兜率天宫没下生时大供养方便解脱门。甚深光音天王。得观察无尽神通智慧海解脱门。广大名称天王。得一切佛功德海满足出现世间方便力解脱门。最胜净光天王。得如来往昔誓愿力发生深信爱乐藏解脱门。尔时可爱乐光明天王。承佛威力。普观一切少光天无量光天极光天众。而说颂言

  我念如来昔所行　　承事供养无边佛
  如本信心清净业　　以佛威神今悉见
  佛身无相离众垢　　恒住慈悲哀愍地
  世间忧患悉使除　　此是妙光之解脱
  佛法广大无涯际　　一切刹海于中现
  如其成坏各不同　　自在音天解脱力
  佛神通力无与等　　普现十方广大刹
  悉令严净常现前　　胜念解脱之方便
  如诸刹海微尘数　　所有如来咸敬奉
  闻法离染不唐捐　　此妙音天法门用
  佛于无量大劫海　　说地方便无伦匹
  所说无边无有穷　　善思音天知此义
  如来神变无量门　　一念现于一切处
  降神成道大方便　　此庄严音之解脱
  威力所持能演说　　及现诸佛神通事
  随其根欲悉令净　　此光音天解脱门
  如来智慧无边际　　世中无等无所著
  慈心应物普现前　　广大名天悟斯道
  佛昔修习菩提行　　供养十方一切佛
  一一佛所发誓心　　最胜光闻大欢喜

复次尸弃梵王。得普住十方道场中说法而所行清净无染着解脱门。慧光梵王。得使一切众生入禅三昧住解脱门善思慧光明梵王。得普入一切不思议法解脱门。普云音梵王。得入诸佛一切音声海解脱门。观世言音自在梵王。得能忆念菩萨教化一切众生方便解脱门。寂静光明眼梵王。得现一切世间业报相各差别解脱门。普光明梵王。得随一切众生品类差别皆现前调伏解脱门。变化音梵王。得住一切法清净相寂灭行境界解脱门。光耀眼梵王。得于一切有无所著无边际无依止常勤出现解脱门。悦意海音梵王。得常思惟观察无尽法解脱门。尔时尸弃大梵王。承佛神力。普观一切梵身天梵辅天梵众天大梵天众。而说颂言

  佛身清净常寂灭　　光明照耀遍世间
  无相无行无影像　　譬如空云如是见
  佛身如是定境界　　一切众生莫能测
  示彼难思方便门　　此慧光王之所悟
  佛刹微尘法门海　　一言演说尽无余
  如是劫海演不穷　　善思慧光之解脱
  诸佛圆音等世间　　众生随类各得解
  而于音声不分别　　普音梵天如是悟
  三世所有诸如来　　趣入菩提方便行
  一切皆于佛身现　　自在音天之解脱
  一切众生业差别　　随其因感种种殊
  世间如是佛皆现　　寂静光天能悟入
  无量法门皆自在　　调伏众生遍十方
  亦不于中起分别　　此是普光之境界
  佛身如空不可尽　　无相无碍遍十方
  所有应现皆如化　　变化音王悟斯道
  如来身相无有边　　智慧音声亦如是
  处世现形无所著　　光耀天王入此门
  法王安处妙法宫　　法身光明无不照
  法性无比无诸相　　此海音王之解脱

复次自在天王。得现前成熟无量众生自在藏解脱门。善目主天王。得观察一切众生乐令入圣境界乐解脱门。妙宝幢冠天王。得随诸众生种种欲解令起行解脱门。勇猛慧天王。得普摄为一切众生所说义解脱门。妙音句天王。得忆念如来广大慈增进自所行解脱门。妙光幢天王。得示现大悲门摧灭一切憍慢幢解脱门。寂静境天王。得调伏一切世间嗔害心解脱门。妙轮庄严幢天王。得十方无边佛随忆念悉来赴解脱门。华光慧天王。得随众生心念普现成正觉解脱门。因陀罗妙光天王。得普入一切世间大威力自在法解脱门。尔时自在天王。承佛威神。遍观一切自在天众。而说颂言

  佛身周遍等法界　　普应众生悉现前
  种种教门常化诱　　于法自在能开悟
  世间所有种种乐　　圣寂灭乐为最胜
  住于广大法性中　　妙眼天王观见此
  如来出现遍十方　　普应群心而说法
  一切疑念皆除断　　此妙幢冠解脱门
  诸佛遍世演妙音　　无量劫中所说法
  能以一言咸说尽　　勇猛慧大之解脱
  世间所有广大慈　　不及如来一毫分
  佛慈如空不可尽　　此妙音天之所得
  一切众生慢高山　　十力摧殄悉无余
  此是如来大悲用　　妙光幢王所行道
  慧光清净满世间　　若有见者除痴暗
  令其远离诸恶道　　寂静天王悟斯法
  毛孔光明能演说　　等众生数诸佛名
  随其所乐悉得闻　　此妙轮幢之解脱
  如来自在不可量　　法界虚空悉充满
  一切众会皆明睹　　此解脱门华慧入
  无量无边大劫海　　普现十方而说法
  未曾见佛有去来　　此主光天之所悟

复次善化天王。得开示一切业变化力解脱门。寂静音光明天王。得舍离一切攀缘解脱门。变化力光明天王。得普灭一切众生痴暗心令智慧圆满解脱门。庄严主天王。得示现无边悦意声解脱门。念光天王。得了知一切佛无尽福德相解脱门。最上云音天王。得普知过去一切劫成坏次第解脱门。胜光天王。得开悟一切众生智解脱门。妙髻天王。得舒光疾满十方虚空界解脱门。喜慧天王。得一切所作无能坏精进力解脱门。华光髻天王。得知一切众生业所受报解脱门。普见十方天王。得示现不思议众生形类差别解脱门。尔时善化天王。承佛威力。普观一切善化天众。而说颂言

  世间业性不思议　　佛为群迷悉开示
  巧说因缘真实理　　一切众生差别业
  种种观佛无所有　　十方求觅不可得
  法身示现无真实　　此法寂音之所见
  佛于劫海修诸行　　为灭世间痴暗惑
  是故清净最照明　　此是力光心所悟
  世间所有妙音声　　无有能比如来音
  佛以一音遍十方　　入此解脱庄严主
  世间所有众福力　　不与如来一相等
  如来福德同虚空　　此念光天所观见
  三世所有无量劫　　如其成败种种相
  佛一毛孔皆能现　　最上云音所了知
  十方虚空可知量　　佛毛孔量不可得
  如是无碍不思议　　妙髻天王已能悟
  佛于曩世无量劫　　具修广大波罗蜜
  勤行精进无厌怠　　喜慧能知此法门
  业性因缘不可思　　佛为世间皆演说
  法性本净无诸垢　　此是华光之入处
  汝应观佛一毛孔　　一切众生悉在中
  彼亦不来亦不去　　此普见王之所了

复次知足天王。得一切佛出兴世圆满教轮解脱门。喜乐海髻天王。得尽虚空界清净光明身解脱门。最胜功德幢天王。得消灭世间苦净愿海解脱门。寂静光天王。得普现身说法解脱门。善目天王。得普净一切众生界解脱门。宝峰月天王。得普化世间常现前无尽藏解脱门。勇健力天王。得开示一切佛正觉境界解脱门。金刚妙光天王。得坚固一切众生菩提心令不可坏解脱门。星宿幢天王。得一切佛出兴咸亲近观察调伏众生方便解脱门。妙庄严天王。得一念悉知众生心随机应现解脱门。尔时知足天王。承佛威力。普观一切知足天众。而说颂言

  如来广大遍法界　　于诸众生悉平等
  普应群情阐妙门　　令入难思清净法
  佛身普现于十方　　无著无碍不可取
  种种色像世咸见　　此喜髻天之所入
  如来往昔修诸行　　清净大愿深如海
  一切佛法皆令满　　胜德能知此方便
  如来法身不思议　　如影分形等法界
  处处阐明一切法　　寂静光天解脱门
  众生业惑所缠覆　　憍慢放逸心驰荡
  如来为说寂静法　　善目照知心喜庆
  一切世间真导师　　为救为归而出现
  普示众生安乐处　　峰月于此能深入
  诸佛境界不思议　　一切法界皆周遍
  入于诸法到彼岸　　勇慧见此生欢喜
  若有众生堪受化　　闻佛功德趣菩提
  令住福海常清净　　妙光于此能观察
  十方刹海微尘数　　一切佛所皆往集
  恭敬供养听闻法　　此庄严幢之所见
  众生心海不思议　　无住无动无依处
  佛于一念皆明见　　妙庄严天斯善了

复次时分天王。得发起一切众生善根令永离忧恼解脱门。妙光天王。得普入一切境界解脱门。无尽慧功德幢天王。得灭除一切患大悲轮解脱门。善化端严天王。得了知三世一切众生心解脱门。总持大光明天王。得陀罗尼门光明忆持一切法无忘失解脱门。不思议慧天王。得善入一切业自性不思议方便解脱门。轮脐天王。得转法轮成熟众生方便解脱门。光焰天王。得广大眼普观众生而往调伏解脱门。光照天王。得超出一切业障不随魔所作解脱门。普观察大名称天王。得善诱诲一切诸天众令受行心清净解脱门。尔时时分天王。承佛威力。普观一切时分天众。而说颂言

  佛于无量久远劫　　已竭世间忧恼海
  广辟离尘清净道　　永耀众生智慧灯
  如来法身甚广大　　十方边际不可得
  一切方便无限量　　妙光明天智能入
  生老病死忧悲苦　　逼迫世间无暂歇
  大师哀愍誓悉除　　无尽慧光能觉了
  佛如幻智无所碍　　于三世法悉明达
  普入众生心行中　　此善化天之境界
  总持边际不可得　　辩才大海亦无尽
  能转清净妙法轮　　此是大光之解脱
  业性广大无穷尽　　智慧觉了善开示
  一切方便不思议　　如是慧天之所入
  转不思议妙法轮　　显示修习菩提道
  永灭一切众生苦　　此是轮脐方便地
  如来真身本无二　　应物随形满世间
  众生各见在其前　　此是焰天之境界
  若有众生一见佛　　必使净除诸业障
  离诸魔业永无余　　光照天王所行道
  一切众会广如海　　佛在其中最威耀
  普雨法雨润众生　　此解脱门名称入

复次释迦因陀罗天王。得忆念三世佛出兴乃至刹成坏皆明见大欢喜解脱门。普称满音天王。得能令佛色身最清净广大世无能比解脱门。慈目宝髻天王。得慈云普覆解脱门。宝光幢名称天王。得恒见佛于一切世主前现种种形相威德身解脱门。发生喜乐髻天王。得知一切众生城邑宫殿从何福业生解脱门。端正念天王。得开示诸佛成熟众生事解脱门。高胜音天王。得知一切世间成坏劫转变相解脱门。成就念天王。得忆念当来菩萨调伏众生行解脱门。净华光天王。得了知一切诸天快乐因解脱门。智日眼天王。得开示一切诸天子受生善根俾无痴惑解脱门。自在光明天王。得开悟一切诸天众令永断种种疑解脱门。尔时释迦因陀罗天王。承佛威力。普观一切三十三天众。而说颂言

  我念三世一切佛　　所有境界悉平等
  如其国土坏与成　　以佛威神皆得见
  佛身广大遍十方　　妙色无比利群生
  光明照耀靡不及　　此道普称能观见
  如来方便大慈海　　往劫修行极清净
  化导众生无有边　　宝髻天王斯悟了
  我念法王功德海　　世中最上无与等
  发生广大欢喜心　　此宝光天之解脱
  佛知众生善业海　　种种胜因生大福
  皆令显现无有余　　此喜髻天之所见
  诸佛出现于十方　　普遍一切世间中
  观众生心示调伏　　正念天王悟斯道
  如来智身广大眼　　世界微尘无不见
  如是普遍于十方　　此云音天之解脱
  一切佛子菩提行　　如来悉现毛孔中
  如其无量皆具足　　此念天王所明见
  世间所有安乐事　　一切皆由佛出生
  如来功德胜无等　　此解脱处华王入
  若念如来少功德　　乃至一念心专仰
  诸恶道怖悉永除　　智眼于此能深悟
  寂灭法中大神通　　普应群心靡不周
  所有疑惑皆令断　　此光明王之所得

复次日天子。得净光普照十方众生尽未来劫常为利益解脱门。光焰眼天子。得以一切随类身开悟众生令入智慧海解脱门。须弥光欢喜幢天子。得为一切众生主令勤修无边净功德解脱门。净宝月天子。得修一切苦行深心欢喜解脱门。勇猛不退转天子。得无碍光普照令一切众生益其精爽解脱门。妙华缨光明天子。得净光普照众生身令生欢喜信解海解脱门。最胜幢光明天子。得光明普照一切世间令成办种种妙功德解脱门。宝髻普光明天子。得大悲海现无边境界种种色相宝解脱门。光明眼天子。得净治一切众生眼令见法界藏解脱门。持德天子。得发生清净相续心令不失坏解脱门。普运行光明天子。得普运日宫殿照十方一切众生令成就所作业解脱门。尔时日天子。承佛威力。遍观一切日天子众。而说颂言

  如来广大智慧光　　普照十方诸国土
  一切众生咸见佛　　种种调伏多方便
  如来色相无有边　　随其所乐悉现身
  普为世间开智海　　焰眼如是观于佛
  佛身无等无有比　　光明照耀遍十方
  超过一切最无上　　如是法门欢喜得
  为利世间修苦行　　往来诸有无量劫
  光明遍净如虚空　　宝月能知此方便
  佛演妙音无障碍　　普遍十方诸国土
  以法滋味益群生　　勇猛能知此方便
  放光明网不思议　　普净一切诸含识
  悉使发生深信解　　此华缨天所入门
  世间所有诸光明　　不及佛一毛孔光
  佛光如是不思议　　此胜幢光之解脱
  一切诸佛法如是　　悉坐菩提树王下
  令非道者住于道　　宝髻光明如是见
  众生盲闇愚痴苦　　佛欲令其生净眼
  是故为然智慧灯　　善目于此深观察
  解脱方便自在尊　　若有曾见一供养
  悉使修行至于果　　此是德天方便力
  一法门中无量门　　无量千劫如是说
  所演法门广大义　　普运光天之所了

复次月天子。得净光普照法界摄化众生解脱门。华王髻光明天子。得观察一切众生界令普入无边法解脱门。众妙净光天子。得了知一切众生心海种种攀缘转解脱门。安乐世间心天子。得与一切众生不可思议乐令踊跃大欢喜解脱门。树王眼光明天子。得如田家作业种芽茎等随时守护令成就解脱门。出现净光天子。得慈悲救护一切众生令现见受苦受乐事解脱门。普游不动光天子。得能持清净月普现十方解脱门。星宿王自在天子。得开示一切法如幻如虚空无相无自性解脱门。净觉月天子。得普为一切众生起大业用解脱门。大威德光明天子。得普断一切疑惑解脱门。尔时月天子。承佛神力。普观一切月宫殿中诸天众会。而说颂曰

  佛放光明遍世间　　照耀十方诸国土
  演不思议广大法　　永破众生痴惑暗
  境界无边无有尽　　于无量劫常开导
  种种自在化群生　　华髻如是观于佛
  众生心海念念殊　　佛智宽广悉了知
  普为说法令欢喜　　此妙光明之解脱
  众生无有圣安乐　　沉迷恶道受诸苦
  如来示彼法性门　　安乐思惟如是见
  如来希有大慈悲　　为利众生入诸有
  说法劝善令成就　　此目光天所了知
  世尊开阐法光明　　分别世间诸业性
  善恶所行无失坏　　净光见此生欢喜
  佛为一切福所依　　譬如大地持宫室
  巧示离忧安隐道　　不动能知此方便
  智火大明周法界　　现形无数等众生
  普为一切开真实　　星宿王天悟斯道
  佛如虚空无自性　　为利众生现世间
  相好庄严如影像　　净觉天王如是见
  佛身毛孔普演音　　法云覆世悉无余
  听闻莫不生欢喜　　如是解脱光天悟

大方广佛华严经卷第二大方广佛华严经卷第三

        于阗国三藏实叉难陀奉　制译

    世主妙严品第一之三

复次持国乾闼婆王。得自在方便摄一切众生解脱门。树光乾闼婆王。得普见一切功德庄严解脱门。净目乾闼婆王。得永断一切众生忧苦出生欢喜藏解脱门。华冠乾闼婆王。得永断一切众生邪见惑解脱门。喜步普音乾闼婆王。得如云广布普荫泽一切众生解脱门。乐摇动美目乾闼婆王。得现广大妙好身令一切获安乐解脱门。妙音师子幢乾闼婆王。得普散十方一切大名称宝解脱门。普放宝光明乾闼婆王。得现一切大欢喜光明清净身解脱门。金刚树华幢乾闼婆王。得普滋荣一切树令见者欢喜解脱门。普现庄严乾闼婆王。得善入一切佛境界与众生安乐解脱门。尔时持国乾闼婆王。承佛威力。普观一切乾闼婆众。而说颂言

  诸佛境界无量门　　一切众生莫能入
  善逝如空性清净　　普为世间开正道
  如来一一毛孔中　　功德大海皆充满
  一切世间咸利乐　　此树光王所能见
  世间广大忧苦海　　佛能消竭悉无余
  如来慈愍多方便　　净目于此能深解
  十方刹海无有边　　佛以智光咸照耀
  普使涤除邪恶见　　此树光王所入门
  佛于往昔无量劫　　修习大慈方便行
  一切世间咸慰安　　此道普音能悟入
  佛身清净皆乐见　　能生世间无尽乐
  解脱因果次第成　　美目于斯善开示
  众生迷惑常流转　　愚痴障盖极坚密
  如来为说广大法　　师子幢王能演畅
  如来普现妙色身　　无量差别等众生
  种种方便照世间　　妙音如是观于佛
  大智方便无量门　　佛为群生普开阐
  入胜菩提真实行　　此金刚幢善观察
  一刹那中百千劫　　佛力能现无所动
  等以安乐施群生　　此乐庄严之解脱

复次增长鸠槃荼王。得灭一切怨害力解脱门。龙主鸠槃荼王。得修习无边行门海解脱门。庄严幢鸠槃荼王。得知一切众生心所乐解脱门。饶益行鸠槃荼王。得普成就清净大光明所作业解脱门。可怖畏鸠槃荼王。得开示一切众生安隐无畏道解脱门。妙庄严鸠槃荼王。得消竭一切众生爱欲海解脱门。高峰慧鸠槃荼王。得普现诸趣光明云解脱门。勇健臂鸠槃荼王。得普放光明灭如山重障解脱门。无边净华眼鸠槃荼王。得开示不退转大悲藏解脱门。广大面鸠槃荼王。得普现诸趣流转身解脱门。尔时增长鸠槃荼王。承佛威力。普观一切鸠槃荼众。而说颂言

  成就忍力世导师　　为物修行无量劫
  永离世间憍慢惑　　是故其身最严净
  佛昔普修诸行海　　教化十方无量众
  种种方便利群生　　此解脱门龙主得
  佛以大智救众生　　莫不明了知其心
  种种自在而调伏　　严幢见此生欢喜
  神通应现如光影　　法轮真实同虚空
  如是处世无央劫　　此饶益王之所证
  众生痴翳常蒙惑　　佛光照现安隐道
  为作救护令除苦　　可畏能观此法门
  欲海漂沦具众苦　　智光普照灭无余
  既除苦已为说法　　此妙庄严之所悟
  佛身普应无不见　　种种方便化群生
  音如雷震雨法雨　　如是法门高慧入
  清净光明不唐发　　若遇必令消重障
  演佛功德无有边　　勇臂能明此深理
  为欲安乐诸众生　　修习大悲无量劫
  种种方便除众苦　　如是净华之所见
  神通自在不思议　　其身普现遍十方
  而于一切无来去　　此广面王心所了

复次毗楼博叉龙王。得消灭一切诸龙趣炽然苦解脱门。娑竭罗龙王。得一念中转自龙形示现无量众生身解脱门。云音幢龙王。得于一切诸有趣中以清净音说佛无边名号海解脱门。焰口龙王。得普现无边佛世界建立差别解脱门。云幢龙王。得开示一切众生大喜乐福德海解脱门。德叉迦龙王。得以清净救护音灭除一切怖畏解脱门。无边步龙王。得示现一切佛色身及住劫次第解脱门。清净色速疾龙王。得出生一切众生大爱乐欢喜海解脱门。普行大音龙王。得示现一切平等悦意无碍音解脱门。无热恼龙王。得以大悲普覆云灭一切世间苦解脱门。尔时毗楼博叉龙王。承佛威力。普观一切诸龙众已。即说颂言

  汝观如来法常尔　　一切众生咸利益
  能以大慈哀愍力　　拔彼畏涂沦坠者
  一切众生种种别　　于一毛端皆示现
  神通变化满世间　　娑竭如是观于佛
  佛以神通无限力　　广演名号等众生
  随其所乐普使闻　　如是云音能悟解
  无量无边国土众　　佛能令入一毛孔
  如来安坐彼会中　　此焰口龙之所见
  一切众生嗔恚心　　缠盖愚痴深若海
  如来慈愍皆灭除　　焰龙观此能明见
  一切众生福德力　　佛毛孔中皆显现
  现已令归大福海　　此高云幢之所观
  佛身毛孔发智光　　其光处处演妙音
  众生闻者除忧畏　　德叉迦龙悟斯道
  三世一切诸如来　　国土庄严劫次第
  如是皆于佛身现　　广步见此神通力
  我观如来往昔行　　供养一切诸佛海
  于彼咸增喜乐心　　此速疾龙之所入
  佛以方便随类音　　为众说法令欢喜
  其音清雅众所悦　　普行闻此心欣悟
  众生逼迫诸有中　　业惑漂转无人救
  佛以大悲令解脱　　无热大龙能悟此

复次毗沙门夜叉王。得以无边方便救护恶众生解脱门。自在音夜叉王。得普观察众生方便救护解脱门。严持器仗夜叉王。得能资益一切甚羸恶众生解脱门。大智慧夜叉王。得称扬一切圣功德海解脱门。焰眼主夜叉王。得普观察一切众生大悲智解脱门。金刚眼夜叉王。得种种方便利益安乐一切众生解脱门。勇健臂夜叉王。得普入一切诸法义解脱门。勇敌大军夜叉王。得守护一切众生令住于道无空过者解脱门。富财夜叉王。得增长一切众生福德聚令恒受快乐解脱门。力坏高山夜叉王。得随顺忆念出生佛力智光明解脱门。尔时多闻大夜叉王。承佛威力。普观一切夜叉众会。而说颂言

  众生罪恶深可怖　　于百千劫不见佛
  漂流生死受众苦　　为救是等佛兴世
  如来救护诸世间　　悉现一切众生前
  息彼畏涂轮转苦　　如是法门音主入
  众生恶业为重障　　佛示妙理令开解
  譬以明灯照世间　　此法严仗能观见
  佛昔劫海修诸行　　称赞十方一切佛
  故有高远大名闻　　此智慧王之所了
  智慧如空无有边　　法身广大不思议
  是故十方皆出现　　焰目于此能观察
  一切趣中演妙音　　说法利益诸群生
  其声所暨众苦灭　　入此方便金刚眼
  一切甚深广大义　　如来一句能演说
  如是教理等世间　　勇健慧王之所悟
  一切众生住邪道　　佛示正道不思议
  普使世间成法器　　此勇敌军能悟解
  世间所有众福业　　一切皆由佛光照
  佛智慧海难测量　　如是富财之解脱
  忆念往劫无央数　　佛于是中修十力
  能令诸力皆圆满　　此高幢王所了知

复次善慧摩睺罗伽王。得以一切神通方便令众生集功德解脱门。净威音摩睺罗伽王。得使一切众生除烦恼得清凉悦乐解脱门。胜慧庄严髻摩睺罗伽王。得普使一切善不善思觉众生入清净法解脱门。妙目主摩睺罗伽王。得了达一切无所著福德自在平等相解脱门。灯幢摩睺罗伽王。得开示一切众生令离黑闇怖畏道解脱门。最胜光明幢摩睺罗伽王。得了知一切佛功德生欢喜解脱门。师子臆摩睺罗伽王。得勇猛力为一切众生救护主解脱门。众妙庄严音摩睺罗伽王。得令一切众生随忆念生无边喜乐解脱门。须弥臆摩睺罗伽王。得于一切所缘决定不动到彼岸满足解脱门。可爱乐光明摩睺罗伽王。得为一切不平等众生开示平等道解脱门。尔时善慧威光摩睺罗伽王。承佛威力。普观一切摩睺罗伽众。而说颂言

  汝观如来性清净　　普现威光利群品
  示甘露道使清凉　　众苦永灭无所依
  一切众生居有海　　诸恶业惑自缠覆
  示彼所行寂静法　　离尘威音能善了
  佛智无等叵思议　　知众生心无不尽
  为彼阐明清净法　　如是严髻心能悟
  无量诸佛现世间　　普为众生作福田
  福海广大深难测　　妙目大王能悉见
  一切众生忧畏苦　　佛普现前而救护
  法界虚空靡不周　　此是灯幢所行境
  佛一毛孔诸功德　　世间共度不能了
  无边无尽同虚空　　如是广大光幢见
  如来通达一切法　　于彼法性皆明照
  如须弥山不倾动　　入此法门师子臆
  佛于往昔广大劫　　集欢喜海深无尽
  是故见者靡不欣　　此法严音之所入
  了知法界无形相　　波罗蜜海悉圆满
  大光普救诸众生　　山臆能知此方便
  汝观如来自在力　　十方降现罔不均
  一切众生咸照悟　　此妙光明能善入

复次善慧光明天紧那罗王。得普生一切喜乐业解脱门。妙华幢紧那罗王。得能生无上法喜令一切受安乐解脱门。种种庄严紧那罗王。得一切功德满足广大清净信解藏解脱门。悦意吼声紧那罗王。得恒出一切悦意声令闻者离忧怖解脱门。宝树光明紧那罗王。得大悲安立一切众生令觉悟所缘解脱门。普乐见紧那罗王。得示现一切妙色身解脱门。最胜光庄严紧那罗王。得了知一切殊胜庄严果所从生业解脱门。微妙华幢紧那罗王。得善观察一切世间业所生报解脱门。动地力紧那罗王。得恒起一切利益众生事解脱门。威猛主紧那罗王。得善知一切紧那罗心巧摄御解脱门。尔时善慧光明天紧那罗王。承佛威力。普观一切紧那罗众。而说颂言

  世间所有安乐事　　一切皆由见佛兴
  导师利益诸众生　　普作救护归依处
  出生一切诸喜乐　　世间咸得无有尽
  能令见者不唐捐　　此是华幢之所悟
  佛功德海无有尽　　求其边际不可得
  光明普照于十方　　此庄严王之解脱
  如来大音常演畅　　开示离忧真实法
  众生闻者咸欣悦　　如是吼声能信受
  我观如来自在力　　皆由往昔所修行
  大悲救物令清净　　此宝树王能悟入
  如来难可得见闻　　众生亿劫时乃遇
  众相为严悉具足　　此乐见王之所睹
  汝观如来大智慧　　普应群生心所欲
  一切智道靡不宣　　最胜庄严此能了
  业海广大不思议　　众生苦乐皆从起
  如是一切能开示　　此华幢王所了知
  诸佛神通无间歇　　十方大地恒震动
  一切众生莫能知　　此广大力恒明见
  处于众会现神通　　放大光明令觉悟
  显示一切如来境　　此威猛主能观察

复次大速疾力迦楼罗王。得无著无碍眼普观察众生界解脱门。不可坏宝髻迦楼罗王。得普安住法界教化众生解脱门。清净速疾迦楼罗王。得普成就波罗蜜精进力解脱门。不退心庄严迦楼罗王。得勇猛力入如来境界解脱门。坚法净光迦楼罗王。得成就无边众生差别智解脱门。妙严冠髻迦楼罗王。得庄严佛法城解脱门。普捷示现迦楼罗王。得成就不可坏平等力解脱门。普观海迦楼罗王。得了知一切众生身而为现形解脱门。龙音大目精迦楼罗王。得普入一切众生殁生行智解脱门。尔时大速疾力迦楼罗王。承佛威力。普观一切迦楼罗众。而说颂言

  佛眼广大无边际　　普见十方诸国土
  其中众生不可量　　现大神通悉调伏
  佛神通力无所碍　　遍坐十方觉树下
  演法如云悉充满　　宝髻听闻心不逆
  佛于往昔修诸行　　普净广大波罗蜜
  供养一切诸如来　　此速疾王深信解
  如来一一毛孔中　　一念普现无边行
  如是难思佛境界　　不退庄严悉明睹
  佛行广大不思议　　一切众生莫能测
  导师功德智慧海　　此执持王所行处
  如来无量智慧光　　能灭众生痴惑网
  一切世间咸救护　　此是坚法所持说
  法城广大不可穷　　其门种种无数量
  如来处世大开阐　　此妙冠髻能明入
  一切诸佛一法身　　真如平等无分别
  佛以此力常安住　　普捷现王斯具演
  佛昔诸有摄众生　　普放光明遍世间
  种种方便示调伏　　此胜法门观海悟
  佛观一切诸国土　　悉依业海而安住
  普雨法雨于其中　　龙音解脱能如是

复次罗睺阿修罗王。得现为大会尊胜主解脱门。毗摩质多罗阿修罗王。得示现无量劫解脱门。巧幻术阿修罗王。得消灭一切众生苦令清净解脱门。大眷属阿修罗王。得修一切苦行自庄严解脱门。婆稚阿修罗王。得震动十方无边境界解脱门。遍照阿修罗王。得种种方便安立一切众生解脱门。坚固行妙庄严阿修罗王。得普集不可坏善根净诸染着解脱门。广大因慧阿修罗王。得大悲力无疑惑主解脱门。现胜德阿修罗王。得普令见佛承事供养修诸善根解脱门。善音阿修罗王。得普入一切趣决定平等行解脱门。尔时罗睺阿修罗王。承佛威力。普观一切阿修罗众。而说颂言

  十方所有广大众　　佛在其中最殊特
  光明遍照等虚空　　普现一切众生前
  百千万劫诸佛土　　一刹那中悉明现
  舒光化物靡不周　　如是毗摩深赞喜
  如来境界无与等　　种种法门常利益
  众生有苦皆令灭　　苦末罗王此能见
  无量劫中修苦行　　利益众生净世间
  由是牟尼智普成　　大眷属王斯见佛
  无碍无等大神通　　遍动十方一切刹
  不使众生有惊怖　　大力于此能明了
  佛出于世救众生　　一切智道咸开示
  悉令舍苦得安乐　　此义遍照所弘阐
  世间所有众福海　　佛力能生普令净
  佛能开示解脱处　　坚行庄严入此门
  佛大悲身无与等　　周行无碍悉令见
  犹如影像现世间　　因慧能宣此功德
  希有无等大神通　　处处现身充法界
  各在菩提树下坐　　此义胜德能宣说
  如来往修三世行　　诸趣轮回靡不经
  脱众生苦无有余　　此妙音王所称赞

复次示现宫殿主昼神。得普入一切世间解脱门。发起慧香主昼神。得普观察一切众生皆利益令欢喜满足解脱门。乐胜庄严主昼神。得能放无边可爱乐法光明解脱门。华香妙光主昼神。得开发无边众生清净信解心解脱门。普集妙药主昼神。得积集庄严普光明力解脱门。乐作喜目主昼神。得普开悟一切苦乐众生皆令得法乐解脱门。观方普现主昼神。得十方法界差别身解脱门。大悲威力主昼神。得救护一切众生令安乐解脱门。善根光照主昼神。得普生喜足功德力解脱门。妙华璎珞主昼神。得声称普闻众生见者皆获益解脱门。尔时示现宫殿主昼神。承佛威力。普观一切主昼神众。而说颂言

  佛智如空无有尽　　光明照耀遍十方
  众生心行悉了知　　一切世间无不入
  知诸众生心所乐　　如应为说众法海
  句义广大各不同　　具足慧神能悉见
  佛放光明照世间　　见闻欢喜不唐捐
  示其深广寂灭处　　此乐庄严心悟解
  佛雨法雨无边量　　能令见者大欢喜
  最胜善根从此生　　如是妙光心所悟
  普入法门开悟力　　旷劫修治悉清净
  如是皆为摄众生　　此妙药神之所了
  种种方便化群生　　若见若闻咸受益
  皆令踊跃大欢喜　　妙眼昼神如是见
  十力应现遍世间　　十方法界悉无余
  体性非无亦非有　　此观方神之所入
  众生流转险难中　　如来哀愍出世间
  悉令除灭一切苦　　此解脱门悲力住
  众生闇覆沦永夕　　佛为说法大开晓
  皆使得乐除众苦　　大善光神入此门
  如来福量同虚空　　世间众福悉从生
  凡有所作无空过　　如是解脱华璎得

复次普德净光主夜神。得寂静禅定乐大勇健解脱门。喜眼观世主夜神。得广大清净可爱乐功德相解脱门。护世精气主夜神。得普现世间调伏众生解脱门。寂静海音主夜神。得积集广大欢喜心解脱门。普现吉祥主夜神。得甚深自在悦意言音解脱门。普发树华主夜神。得光明满足广大欢喜藏解脱门。平等护育主夜神。得开悟众生令成熟善根解脱门。游戏快乐主夜神。得救护众生无边慈解脱门。诸根常喜主夜神。得普现庄严大悲门解脱门。示现净福主夜神。得普使一切众生所乐满足解脱门。尔时普德净光主夜神。承佛威力。遍观一切主夜神众。而说颂言

  汝等应观佛所行　　广大寂静虚空相
  欲海无涯悉治净　　离垢端严照十方
  一切世间咸乐见　　无量劫海时一遇
  大悲念物靡不周　　此解脱门观世睹
  导师救护诸世间　　众生悉见在其前
  能令诸趣皆清净　　如是护世能观察
  佛昔修治欢喜海　　广大无边不可测
  是故见者咸欣乐　　此是寂音之所了
  如来境界不可量　　寂而能演遍十方
  普使众生意清净　　尸利夜神闻踊悦
  佛于无福众生中　　大福庄严甚威曜
  示彼离尘寂灭法　　普发华神悟斯道
  十方普现大神通　　一切众生悉调伏
  种种色相皆令见　　此护育神之所观
  如来往昔念念中　　悉净方便慈悲海
  救护世间无不遍　　此福乐神之解脱
  众生愚痴常乱浊　　其心坚毒甚可畏
  如来慈愍为出兴　　此灭怨神能悟喜
  佛昔修行为众生　　一切愿欲皆令满
  由是具成功德相　　此现福神之所入

复次遍住一切主方神。得普救护力解脱门。普现光明主方神。得成辨化一切众生神通业解脱门。光行庄严主方神。得破一切闇障生喜乐大光明解脱门。周行不碍主方神。得普现一切处不唐劳解脱门。永断迷惑主方神。得示现等一切众生数名号发生功德解脱门。遍游净空主方神。得恒发妙音令听者皆欢喜解脱门。云幢大音主方神。得如龙普雨令众生欢喜解脱门。髻目无乱主方神。得示现一切众生业无差别自在力解脱门。普观世业主方神。得观察一切趣生中种种业解脱门。周遍游览主方神。得所作事皆究竟生一切众生欢喜解脱门。尔时。遍住一切主方神。承佛威力。普观一切主方神众。而说颂言

  如来自在出世间　　教化一切诸群生
  普示法门令悟入　　悉使当成无上智
  神通无量等众生　　随其所乐示诸相
  见者皆蒙出离苦　　此现光神解脱力
  佛于闇障众生海　　为现法炬大光明
  其光普照无不见　　此行庄严之解脱
  具足世间种种音　　普转法轮无不解
  众生听者烦恼灭　　此遍往神之所悟
  一切世间所有名　　佛名等彼而出生
  悉使众生离痴惑　　此断迷神所行处
  若有众生至佛前　　得闻如来美妙音
  莫不心生大欢喜　　遍游虚空悟斯法
  佛于一一刹那中　　普雨无边大法雨
  悉使众生烦恼灭　　此云幢神所了知
  一切世间诸业海　　佛悉开示等无异
  普使众生除业惑　　此髻目神之所了
  一切智地无有边　　一切众生种种心
  如来照见悉明了　　此广大门观世入
  佛于往昔修诸行　　无量诸度悉圆满
  大慈哀愍利众生　　此遍游神之解脱

复次净光普照主空神。得普知诸趣一切众生心解脱门。普游深广主空神。得普入法界解脱门。生吉祥风主空神。得了达无边境界身相解脱门。离障安住主空神。得能除一切众生业惑障解脱门。广步妙髻主空神。得普观察思惟广大行海解脱门。无碍光焰主空神。得大悲光普救护一切众生厄难解脱门。无碍胜力主空神。得普入一切无所著福德力解脱门。离垢光明主空神。得能令一切众生心离诸盖清净解脱门。深远妙音主空神。得普见十方智光明解脱门。光遍十方主空神。得不动本处而普现世间解脱门。尔时。净光普照主空神。承佛威力。普观一切主空神众。而说颂言

  如来广大目　　清净如虚空
  普见诸众生　　一切悉明了
  佛身大光明　　遍照于十方
  处处现前住　　普游观此道
  佛身如虚空　　无生无所取
  无得无自性　　吉祥风所见
  如来无量劫　　广说诸圣道
  普灭众生障　　圆光悟此门
  我观佛往昔　　所集菩提行
  悉为安世间　　妙髻行斯境
  一切众生界　　流转生死海
  佛放灭苦光　　无碍神能见
  清净功德藏　　能为世福田
  随以智开觉　　力神于此悟
  众生痴所覆　　流转于险道
  佛为放光明　　离垢神能证
  智慧无边际　　悉现诸国土
  光明照世间　　妙音斯见佛
  佛为度众生　　修行遍十方
  如是大愿心　　普现能观察

复次无碍光明主风神。得普入佛法及一切世间解脱门。普现勇业主风神。得无量国土佛出现咸广大供养解脱门。飘击云幢主风神。得以香风普灭一切众生病解脱门。净光庄严主风神。得普生一切众生善根令摧灭重障山解脱门。力能竭水主风神。得能破无边恶魔众解脱门。大声遍吼主风神。得永灭一切众生怖解脱门。树杪垂髻主风神。得入一切诸法实相辩才海解脱门。普行无碍主风神。得调伏一切众生方便藏解脱门。种种宫殿主风神。得入寂静禅定门灭极重愚痴闇解脱门。大光普照主风神。得随顺一切众生行无碍力解脱门。尔时。无碍光明主风神。承佛威力。普观一切主风神众。而说颂言

  一切诸佛法甚深　　无碍方便普能入
  所有世间常出现　　无相无形无影像
  汝观如来于往昔　　一念供养无边佛
  如是勇猛菩提行　　此普现神能悟了
  如来救世不思议　　所有方便无空过
  悉使众行离诸苦　　此云幢神之解脱
  众生无福受众苦　　重盖密障常迷覆
  一切皆令得解脱　　此净光神所了知
  如来广大神通力　　克殄一切魔军众
  所有调伏诸方便　　勇健威力能观察
  佛于毛孔演妙音　　其音普遍于世间
  一切苦畏皆令息　　此遍吼神之所了
  佛于一切众刹海　　不思议劫常演说
  此如来地妙辩才　　树杪髻神能悟解
  佛于一切方便门　　智入其中悉无碍
  境界无边无与等　　此普行神之解脱
  如来境界无有边　　处处方便皆令见
  而身寂静无诸相　　种种宫神解脱门
  如来劫海修诸行　　一切诸力皆成满
  能随世法应众生　　此普照神之所见

大方广佛华严经卷第三大方广佛华严经卷第四

        于阗国三藏实叉难陀奉　制译

    世主妙严品第一之四

复次普光焰藏主火神。得悉除一切世间闇解脱门。普集光幢主火神。得能息一切众生诸惑漂流热恼苦解脱门。大光遍照主火神。得无动福力大悲藏解脱门。无尽光髻主火神。得光明照耀无边虚空界解脱门。种种焰眼主火神。得种种福庄严寂静光解脱门。十方宫殿如须弥山主火神。得能灭一切世间诸趣炽然苦解脱门。威光自在主火神。得自在开悟一切世间解脱门。光照十方主火神。得永破一切愚痴执着见解脱门。雷音电光主火神。得成就一切愿力大震吼解脱门。尔时普光焰藏主火神承佛威力。遍观一切主火神众。而说颂言

  汝观如来精进力　　广大亿劫不思议
  为利众生现世间　　所有暗障皆令灭
  众生愚痴起诸见　　烦恼如流及火然
  导师方便悉灭除　　普集光幢于此悟
  福德如空无有尽　　求其边际不可得
  此佛大悲无动力　　光照悟入心生喜
  我观如来之所行　　经于劫海无边际
  如是示现神通力　　众妙宫神所了知
  亿劫修成不可思　　求其边际莫能知
  演法实相令欢喜　　无尽光神所观见
  十方所有广大众　　一切现前瞻仰佛
  寂静光明照世间　　此妙焰神所能了
  牟尼出现诸世间　　坐于一切宫殿中
  普雨无边广大法　　此十方神之境界
  诸佛智慧最甚深　　于法自在现世间
  能悉阐明真实理　　威光悟此心欣庆
  诸见愚痴为暗盖　　众生迷惑常流转
  佛为开阐妙法门　　此照方神能悟入
  愿门广大不思议　　力度修治已清净
  如昔愿心皆出现　　此震音神之所了

复次普兴云幢主水神。得平等利益一切众生慈解脱门。海潮云音主水神。得无边法庄严解脱门。妙色轮髻主水神。得观所应化方便普摄解脱门。善巧漩澓主水神。得普演诸佛甚深境界解脱门。离垢香积主水神。得普现清净大光明解脱门。福桥光音主水神。得清净法界无相无性解脱门。知足自在主水神。得无尽大悲海解脱门。净喜善音主水神。得于菩萨众会道场中为大欢喜藏解脱门。普现威光主水神。得以无碍广大福德力普出现解脱门。吼声遍海主水神。得观察一切众生发起如虚空调伏方便解脱门。尔时普兴云幢主水神。承佛威力。遍观一切主水神众。而说颂言

  清净慈门刹尘数　　共生如来一妙相
  一一诸相莫不然　　是故见者无厌足
  世尊往昔修行时　　普诣一切如来所
  种种修治无懈倦　　如是方便云音入
  佛于一切十方中　　寂然不动无来去
  应化众生悉令见　　此是髻轮之所知
  如来境界无边量　　一切众生不能了
  妙音演说遍十方　　此善旋神所行处
  世尊光明无有尽　　充遍法界不思议
  说法教化度众生　　此净香神所观见
  如来清净等虚空　　无相无形遍十方
  而令众会靡不见　　此福光神善观察
  佛昔修习大悲门　　其心广遍等众生
  是故如云现于世　　此解脱门知足了
  十方所有诸国土　　悉见如来坐于座
  朗然开悟大菩提　　如是喜音之所入
  如来所行无挂碍　　遍往十方一切刹
  处处示现大神通　　普现威光已能悟
  修习无边方便行　　等众生界悉充满
  神通妙用靡暂停　　吼声遍海斯能入

复次出现宝光主海神。得以等心施一切众生福德海众宝庄严身解脱门。不可坏金刚幢主海神。得巧方便守护一切众生善根解脱门。不杂尘垢主海神。得能竭一切众生烦恼海解脱门。恒住波浪主海神。得令一切众生离恶道解脱门。吉祥宝月主海神。得普灭大痴暗解脱门。妙华龙髻主海神。得灭一切诸趣苦与安乐解脱门。普持光味主海神。得净治一切众生诸见愚痴性解脱门。宝焰华光主海神。得出生一切宝种性菩提心解脱门。金刚妙髻主海神。得不动心功德海解脱门。海潮雷音主海神。得普入法界三昧门解脱门。尔时。出现宝光主海神。承佛威力。普观一切主海神众。而说颂言

  不可思议大劫海　　供养一切诸如来
  普以功德施群生　　是故端严最无比
  一切世间皆出现　　众生根欲靡不知
  普为弘宣大法海　　此是坚幢所欣悟
  一切众生烦恼覆　　流转诸趣受众苦
  为其开示如来境　　普水宫神入此门
  佛于难思劫海中　　修行诸行无有尽
  永截众生痴惑网　　宝月于此能明入
  佛见众生常恐怖　　流转生死大海中
  示彼如来无上道　　龙髻悟解生欣悦
  诸佛境界不思议　　法界虚空平等相
  能净众生痴惑网　　如是持味能宣说
  佛眼清净不思议　　一切境界悉该览
  普示众生诸妙道　　此是华光心所悟
  魔军广大无央数　　一刹那中悉摧灭
  心无倾动难测量　　金刚妙髻之方便
  普于十方演妙音　　其音法界靡不周
  此是如来三昧境　　海潮音神所行处

复次普发迅流主河神。得普雨无边法雨解脱门。普洁泉涧主河神。得普现一切众生前令永离烦恼解脱门。离尘净眼主河神。得以大悲方便普涤一切众生诸惑尘垢解脱门。十方遍吼主河神。得恒出饶益众生音解脱门。普救护众生主河神。得于一切含识中恒起无恼害慈解脱门。无热净光主河神。得普示一切清凉善根解脱门。普生欢喜主河神。得修行具足施令一切众生永离悭着解脱门。广德胜幢主河神。得作一切欢喜福田解脱门。光照普世主河神。得能令一切众生杂染者清净嗔毒者欢喜解脱门。海德光明主河神。得能令一切众生入解脱海恒受具足乐解脱门。尔时普发迅流主河神。承佛威力。遍观一切主河神众。而说颂言

  如来往昔为众生　　修治法海无边行
  譬如霈泽清炎暑　　普灭众生烦恼热
  佛昔难宣无量劫　　以愿光明净世间
  诸根熟者令悟道　　此普洁神心所悟
  大悲方便等众生　　悉现其前常化诱
  普使净治烦恼垢　　净眼见此深欢悦
  佛演妙音普使闻　　众生爱乐心欢喜
  悉使涤除无量苦　　此遍吼神之解脱
  佛昔修习菩提行　　为利众生无量劫
  是故光明遍世间　　护神忆念生欢喜
  佛昔修行为众生　　种种方便令成熟
  普净福海除众苦　　无热见此心欣庆
  施门广大无穷尽　　一切众生咸利益
  能令见者无悭着　　此普喜神之所悟
  佛昔修行实方便　　成就无边功德海
  能令见者靡不欣　　此胜幢神心悟悦
  众生有垢咸净治　　一切怨害等生慈
  故得光照满虚空　　普世河神见欢喜
  佛是福田功德海　　能令一切离诸恶
  乃至成就大菩提　　此海光神之解脱

复次柔软胜味主稼神。得与一切众生法滋味令成就佛身解脱门。时华净光主稼神。得能令一切众生受广大喜乐解脱门。色力勇健主稼神。得以一切圆满法门净诸境界解脱门。增益精气主稼神。得见佛大悲无量神通变化力解脱门。普生根果主稼神。得普现佛福田令下种无失坏解脱门。妙严环髻主稼神。得普发众生净信华解脱门。润泽净华主稼神。得大慈愍济诸众生令增长福德海解脱门。成就妙香主稼神。得广开示一切行法解脱门。见者爱乐主稼神。得能令法界一切众生舍离懈怠忧恼等诸恶普清净解脱门。离垢光明主稼神。得观察一切众生善根随应说法令众会欢喜满足解脱门。尔时柔软胜味主稼神。承佛威力。遍观一切主稼神众。而说颂言

  如来无上功德海　　普现明灯照世间
  一切众生咸救护　　悉与安乐无遗者
  世尊功德无有边　　众生闻者不唐捐
  悉使离苦常欢喜　　此是时华之所入
  善逝诸力皆圆满　　功德庄严现世间
  一切众生悉调伏　　此法勇力能明证
  佛昔修治大悲海　　其心念念等世间
  是故神通无有边　　增益精气能观见
  佛遍世间常现前　　一切方便无空过
  悉净众生诸惑恼　　此普生神之解脱
  佛是世间大智海　　放净光明无不遍
  广大信解悉从生　　如是严髻能明入
  如来观世起慈心　　为利众生而出现
  示彼恬怡最胜道　　此净华神之解脱
  善逝所修清净行　　菩提树下具宣说
  如是教化满十方　　此妙香神能听受
  佛于一切诸世间　　悉使离忧生大喜
  所有根欲皆治净　　可爱乐神斯悟入
  如来出现于世间　　普观众生心所乐
  种种方便而成熟　　此净光神解脱门

复次吉祥主药神。得普观一切众生心而勤摄取解脱门。栴檀林主药神。得以光明摄众生俾见者无空过解脱门。离尘光明主药神。得能以净方便灭一切众生烦恼解脱门。名称普闻主药神。得能以大名称增长无边善根海解脱门。毛孔现光主药神。得大悲幢速赴一切病境界解脱门。破暗清净主药神。得疗治一切盲冥众生令智眼清净解脱门。普发吼声主药神。得能演佛音说诸法差别义解脱门。蔽日光幢主药神。得能作一切众生善知识令见者咸生善根解脱门。明见十方主药神。得清净大悲藏能以方便令生信解解脱门。普发威光主药神。得方便令念佛灭一切众生病解脱门。尔时吉祥主药神。承佛威力。遍观一切主药神众。而说颂言

  如来智慧不思议　　悉知一切众生心
  能以种种方便力　　灭彼群迷无量苦
  大雄善巧难测量　　凡有所作无空过
  必使众生诸苦灭　　栴檀林神能悟此
  汝观诸佛法如是　　往悉勤修无量劫
  而于诸有无所著　　此离尘光所入门
  佛百千劫难可遇　　若有得见及闻名
  必令获益无空过　　此普称神之所了
  如来一一毛孔中　　悉放光明灭众患
  世间烦恼皆令尽　　此现光神所入门
  一切众生痴所盲　　惑业众苦无量别
  佛悉蠲除开智照　　如是破暗能观见
  如来一音无限量　　能开一切法门海
  众生听者悉了知　　此是大音之解脱
  汝观佛智难思议　　普现诸趣救群生
  能令见者皆从化　　此蔽日幢深悟了
  如来大悲方便海　　为利世间而出现
  广开正道示众生　　此见方神能了达
  如来普放大光明　　一切十方无不照
  令随念佛生功德　　此发威光解脱门

复次布华如云主林神。得广大无边智海藏解脱门。擢干舒光主林神。得广大修治普清净解脱门。生芽发耀主林神。得增长种种净信芽解脱门。吉祥净叶主林神。得一切清净功德庄严聚解脱门。垂布焰藏主林神。得普门清净慧恒周览法界解脱门。妙庄严光主林神。得普知一切众生行海而兴布法云解脱门。可意雷声主林神。得忍受一切不可意声演清净音解脱门。香光普遍主林神。得十方普现昔所修治广大行境界解脱门。妙光回耀主林神。得以一切功德法饶益世间解脱门。华果光味主林神。得能令一切见佛出兴常敬念不忘庄严功德藏解脱门。尔时布华如云主林神。承佛威力。普观一切主林神众。而说颂言

  佛昔修习菩提行　　福德智慧悉成满
  一切诸力皆具足　　放大光明出世间
  悲门无量等众生　　如来往昔普净治
  是故于世能为益　　此擢干神之所了
  若有众生一见佛　　必使入于深信海
  普示一切如来道　　此妙芽神之解脱
  一毛所集诸功德　　劫海宣扬不可尽
  诸佛方便难思议　　净叶能明此深义
  我念如来于往昔　　供养刹尘无量佛
  一一佛所智渐明　　此焰藏神之所了
  一切众生诸行海　　世尊一念悉了知
  如是广大无碍智　　妙庄严神能悟入
  恒演如来寂妙音　　普生无等大欢喜
  随其解欲皆令悟　　此是雷音所行法
  如来示现大神通　　十方国土皆周遍
  佛昔修行悉令见　　此普香光所入门
  众生譣诐不修德　　迷惑沈流生死中
  为彼阐明众智道　　此妙光神之所见
  佛为业障诸众生　　经于亿劫时乃现
  其余念念常令见　　此味光神所观察

复次宝峰开华主山神。得入大寂定光明解脱门。华林妙髻主山神。得修集慈善根成熟不可思议数众生解脱门。高幢普照主山神。得观察一切众生心所乐严净诸根解脱门。离尘宝髻主山神。得无边劫海勤精进无厌怠解脱门。光照十方主山神。得以无边功德光普觉悟解脱门。大力光明主山神。得能自成熟复令众生舍离愚迷行解脱门。威光普胜主山神。得拔一切苦使无有余解脱门。微密光轮主山神。得演教法光明显示一切如来功德解脱门。普眼现见主山神。得令一切众生乃至于梦中增长善根解脱门。金刚坚固眼主山神。得出现无边大义海解脱门。尔时开华匝地主山神。承佛威力。普观一切主山神众。而说颂言

  往修胜行无有边　　今获神通亦无量
  法门广辟如尘数　　悉使众生深悟喜
  众相严身遍世间　　毛孔光明悉清净
  大慈方便示一切　　华林妙髻悟此门
  佛身普现无有边　　十方世界皆充满
  诸根严净见者喜　　此法高幢能悟入
  历劫勤修无懈倦　　不染世法如虚空
  种种方便化群生　　悟此法门名宝髻
  众生盲暗入险道　　佛哀愍彼舒光照
  普使世间从睡觉　　威光悟此心生喜
  昔在诸有广修行　　供养刹尘无数佛
  令众生见发大愿　　此地大力能明入
  见诸众生流转苦　　一切业障恒缠覆
  以智慧光悉灭除　　此普胜神之解脱
  一一毛孔出妙音　　随众生心赞诸佛
  悉遍十方无量劫　　此是光轮所入门
  佛遍十方普现前　　种种方便说妙法
  广益众生诸行海　　此现见神之所悟
  法门如海无边量　　一音为说悉令解
  一切劫中演不穷　　入此方便金刚目

复次普德净华主地神。得以慈悲心念念普观一切众生解脱门。坚福庄严主地神。得普现一切众生福德力解脱门。妙华严树主地神。得普入诸法出生一切佛刹庄严解脱门。普散众宝主地神。得修习种种诸三昧令众生除障垢解脱门。净目观时主地神。得令一切众生常游戏快乐解脱门。金色妙眼主地神。得示现一切清净身调伏众生解脱门。香毛发光主地神。得了知一切佛功德海大威力解脱门。寂音悦意主地神。得普摄持一切众生言音海解脱门。妙华旋髻主地神。得充满佛刹离垢性解脱门。金刚普持主地神。得一切佛法轮所摄持普出现解脱门。尔时普德净华主地神。承佛威力。普观一切主地神众。而说颂言

  如来往昔念念中　　大慈悲门不可说
  如是修行无有已　　故得坚牢不坏身
  三世众生及菩萨　　所有一切众福聚
  悉现如来毛孔中　　福严见已生欢喜
  广大寂静三摩地　　不生不灭无来去
  严净国土示众生　　此树华神之解脱
  佛于往昔修诸行　　为令众生消重障
  普散众宝主地神　　见此解脱生欢喜
  如来境界无边际　　念念普现于世间
  净目观时主地神　　见佛所行心庆悦
  妙音无限不思议　　普为众生灭烦恼
  金色眼神能了悟　　见佛无边胜功德
  一切色形皆化现　　十方法界悉充满
  香毛发光常见佛　　如是普化诸众生
  妙音普遍于十方　　无量劫中为众说
  悦意地神心了达　　从佛得闻深敬喜
  佛毛孔出香焰云　　随众生心遍世间
  一切见者皆成熟　　此是华旋所观处
  坚固难坏如金刚　　不可倾动逾须弥
  佛身如是处世间　　普持得见生欢喜

复次宝峰光耀主城神。得方便利益众生解脱门。妙严宫殿主城神。得知众生根教化成熟解脱门。清净喜宝主城神。得常欢喜令一切众生受诸福德解脱门。离忧清净主城神。得救诸怖畏大悲藏解脱门。华灯焰眼主城神。得普明了大智慧解脱门。焰幢明现主城神。得普方便示现解脱门。盛福威光主城神。得普观察一切众生令修广大福德海解脱门。净光明身主城神。得开悟一切愚暗众生解脱门。宝峰光目主城神。得能以大光明破一切众生障碍山解脱门。尔时宝峰光耀主城神。承佛威力。普观一切主城神众。而说颂言

  导师如是不思议　　光明遍照于十方
  众生现前悉见佛　　教化成熟无央数
  诸众生根各差别　　佛悉了知无有余
  妙严宫殿主城神　　入此法门心庆悦
  如来无量劫修行　　护持往昔诸佛法
  意常承奉生欢喜　　妙宝城神悟此门
  如来昔已能除遣　　一切众生诸恐怖
  而恒于彼起慈悲　　此离忧神心悟喜
  佛智广大无有边　　譬如虚空不可量
  华目城神斯悟悦　　能学如来之妙慧
  如来色相等众生　　随其乐欲皆令见
  焰幢明现心能悟　　习此方便生欢喜
  如来往修众福海　　清净广大无边际
  福德幢光于此门　　观察了悟心欣庆
  众生愚迷诸有中　　如世生盲卒无睹
  佛为利益兴于世　　清净光神入此门
  如来自在无有边　　如云普遍于世间
  乃至现梦令调伏　　此是香幢所观见
  众生痴暗如盲瞽　　种种障盖所缠覆
  佛光照彻普令开　　如是宝峰之所入

复次净庄严幢道场神。得出现供养佛广大庄严具誓愿力解脱门。须弥宝光道场神。得现一切众生前成就广大菩提行解脱门。雷音幢相道场神。得随一切众生心所乐令见佛于梦中为说法解脱门。雨华妙眼道场神。得能雨一切难舍众宝庄严具解脱门。清净焰形道场神。得能现妙庄严道场广化众生令成熟解脱门。华缨垂髻道场神。得随根说法令生正念解脱门。雨宝庄严道场神。得能以辩才普雨无边欢喜法解脱门。勇猛香眼道场神。得广称赞诸佛功德解脱门。金刚彩云道场神。得示现无边色相树庄严道场解脱门。莲华光明道场神。得菩提树下寂然不动而充遍十方解脱门。妙光照耀道场神。得显示如来种种力解脱门。尔时净庄严幢道场神。承佛威力。普观一切道场神众。而说颂言

  我念如来往昔时　　于无量劫所修行
  诸佛出兴咸供养　　故获如空大功德
  佛昔修行无尽施　　无量刹土微尘等
  须弥光照菩提神　　忆念善逝心欣庆
  如来色相无有穷　　变化周流一切刹
  乃至梦中常示现　　雷幢见此生欢喜
  昔行舍行无量劫　　能舍难舍眼如海
  如是舍行为众生　　此妙眼神能悟悦
  无边色相宝焰云　　现菩提场遍世间
  焰形清净道场神　　见佛自在生欢喜
  众生行海无有边　　佛普弥纶雨法雨
  随其根解除疑惑　　华缨悟此心欢喜
  无量法门差别义　　辩才大海皆能入
  雨宝严具道场神　　于心念念恒如是
  于不可说一切土　　尽世言辞称赞佛
  故获名誉大功德　　此勇眼神能忆念
  种种色相无边树　　普现菩提树王下
  金刚彩云悟此门　　恒观道树生欢喜
  十方边际不可得　　佛坐道场智亦然
  莲华步光净信心　　入此解脱深生喜
  道场一切出妙音　　赞佛难思清净力
  及以成就诸因行　　此妙光神能听受

复次宝印手足行神。得普雨众宝生广大欢喜解脱门。莲华光足行神。得示现佛身坐一切光色莲华座令见者欢喜解脱门。最胜华髻足行神。得一一心念中建立一切如来众会道场解脱门。摄诸善见足行神。得举足发步悉调伏无边众生解脱门。妙宝星幢足行神。得念念中化现种种莲华网光明普雨众宝出妙音声解脱门。乐吐妙音足行神。得出生无边欢喜海解脱门。栴檀树光足行神。得以香风普觉一切道场众会解脱门。莲华光明足行神。得一切毛孔放光明演微妙法音解脱门。微妙光明足行神。得其身遍出种种光明网普照耀解脱门。积集妙华足行神。得开悟一切众生令生善根海解脱门。尔时宝印手足行神。承佛神力。遍观一切足行神众。而说颂言

  佛昔修行无量劫　　供养一切诸如来
  心恒庆悦不疲厌　　喜门深大犹如海
  念念神通不可量　　化现莲华种种香
  佛坐其上普游往　　红色光神皆睹见
  诸佛如来法如是　　广大众会遍十方
  普现神通不可议　　最胜华神悉明瞩
  十方国土一切处　　于中举足若下足
  悉能成就诸群生　　此善见神心悟喜
  如众生数普现身　　此一一身充法界
  悉放净光雨众宝　　如是解脱星幢入
  如来境界无边际　　普雨法雨皆充满
  众会睹佛生欢喜　　此妙音声之所见
  佛音声量等虚空　　一切音声悉在中
  调伏众生靡不遍　　如是栴檀能听受
  一切毛孔出化音　　阐扬三世诸佛名
  闻此音者皆欢喜　　莲华光神如是见
  佛身变现不思议　　步步色相犹如海
  随众生心悉令见　　此妙光明之所得
  十方普现大神通　　一切众生悉开悟
  众妙华神于此法　　见已心生大欢喜

复次净喜境界身众神。得忆佛往昔誓愿海解脱门。光照十方身众神。得光明普照无边世界解脱门。海音调伏身众神。得大音普觉一切众生令欢喜调伏解脱门。净华严髻身众神。得身如虚空周遍住解脱门。无量威仪身众神。得示一切众生诸佛境界解脱门。最胜光严身众神。得令一切饥乏众生色力满足解脱门。净光香云身众神。得除一切众生烦恼垢解脱门。守护摄持身众神。得转一切众生愚痴魔业解脱门。普现摄化身众神。得普于一切世主宫殿中显示庄严相解脱门。不动光明身众神。得普摄一切众生皆令生清净善根解脱门。尔时净喜境界身众神。承佛威力。普观一切身众神众。而说颂言

  我忆须弥尘劫前　　有佛妙光出兴世
  世尊于彼如来所　　发心供养一切佛
  如来身放大光明　　其光法界靡不充
  众生遇者心调伏　　此照方神之所见
  如来声震十方国　　一切言音悉圆满
  普觉群生无有余　　调伏闻此心欢庆
  佛身清净恒寂灭　　普现众色无诸相
  如是遍住于世间　　此净华神之所入
  导师如是不思议　　随众生心悉令见
  或坐或行或时住　　无量威仪所悟门
  佛百千劫难逢遇　　出兴利益能自在
  令世悉离贫穷苦　　最胜光严入斯处
  如来一一齿相间　　普放香灯光焰云
  灭除一切众生惑　　离垢云神如是见
  众生染惑为重障　　随逐魔径常流转
  如来开示解脱道　　守护执持能悟入
  我观如来自在力　　光布法界悉充满
  处王宫殿化众生　　此普现神之境界
  众生迷妄具众苦　　佛在其中常救摄
  皆令灭惑生喜心　　不动光神所观见

复次妙色那罗延执金刚神。得见如来示现无边色相身解脱门。日轮速疾幢执金刚神。得佛身一一毛如日轮现种种光明云解脱门。须弥华光执金刚神。得化现无量身大神变解脱门。清净云音执金刚神。得无边随类音解脱门。妙臂天主执金刚神。得现为一切世间主开悟众生解脱门。可爱乐光明执金刚神。得普开示一切佛法差别门咸尽无遗解脱门。大树雷音执金刚神。得以可爱乐庄严具摄一切树神解脱门。师子王光明执金刚神。得如来广大福庄严聚皆具足明了解脱门。密焰吉祥目执金刚神。得普观察险恶众生心为现威严身解脱门。莲华摩尼髻执金刚神。得普雨一切菩萨庄严具摩尼髻解脱门。尔时妙色那罗延执金刚神。承佛威力。普观一切执金刚神众。而说颂言

  汝应观法王　　法王法如是
  色相无有边　　普现于世间
  佛身一一毛　　光网不思议
  譬如净日轮　　普照十方国
  如来神通力　　法界悉周遍
  一切众生前　　示现无尽身
  如来说法音　　十方莫不闻
  随诸众生类　　悉令心满足
  众见牟尼尊　　处世宫殿中
  普为诸群生　　阐扬于大法
  法海漩澓处　　一切差别义
  种种方便门　　演说无穷尽
  无边大方便　　普应十方国
  遇佛净光明　　悉见如来身
  供养于诸佛　　亿刹微尘数
  功德如虚空　　一切所瞻仰
  神通力平等　　一切刹皆现
  安坐妙道场　　普现众生前
  焰云普照明　　种种光圆满
  法界无不及　　示佛所行处

大方广佛华严经卷第四大方广佛华严经卷第五

        于阗国三藏实叉难陀奉　制译

    世主妙严品第一之五

复次普贤菩萨摩诃萨。入不思议解脱门方便海。入如来功德海。所谓。有解脱门。名严净一切佛国土调伏众生令究竟出离。有解脱门。名普诣一切如来所修具足功德境界。有解脱门。名安立一切菩萨地诸大愿海。有解脱门。名普现法界微尘数无量身。有解脱门。名演说遍一切国土不可思议数差别名。有解脱门。名一切微尘中悉现无边诸菩萨神通境界。有解脱门。名一念中现三世劫成坏事。有解脱门。名示现一切菩萨诸根海各入自境界。有解脱门。名能以神通力化现种种身遍无边法界。有解脱门。名显示一切菩萨修行法次第门入一切智广大方便。尔时普贤菩萨摩诃萨。以自功德。复承如来威神之力。普观一切众会海已。即说颂言

  佛所庄严广大刹　　等于一切微尘数
  清净佛子悉满中　　雨不思议最妙法
  如于此会见佛坐　　一切尘中悉如是
  佛身无去亦无来　　所有国土皆明现
  显示菩萨所修行　　无量趣地诸方便
  及说难思真实理　　令诸佛子入法界
  出生化佛如尘数　　普应群生心所欲
  入深法界方便门　　广大无边悉开演
  如来名号等世间　　十方国土悉充遍
  一切方便无空过　　调伏众生皆离垢
  佛于一切微尘中　　示现无边大神力
  悉坐道场能演说　　如佛往昔菩提行
  三世所有广大劫　　佛念念中皆示现
  彼诸成坏一切事　　不思议智无不了
  佛子众会广无限　　欲共测量诸佛地
  诸佛法门无有边　　能悉了知甚为难
  佛如虚空无分别　　等真法界无所依
  化现周行靡不至　　悉坐道场成正觉
  佛以妙音广宣畅　　一切诸地皆明了
  普现一一众生前　　尽与如来平等法

复次净德妙光菩萨摩诃萨。得遍往十方菩萨众会庄严道场解脱门。普德最胜灯光照菩萨摩诃萨。得一念中现无尽成正觉门教化成熟不思议众生界解脱门。普光师子幢菩萨摩诃萨。得修习菩萨福德庄严出生一切佛国土解脱门。普宝焰妙光菩萨摩诃萨。得观察佛神通境界无迷惑解脱门。普音功德海幢菩萨摩诃萨。得于一众会道场中示现一切佛土庄严解脱门。普智光照如来境菩萨摩诃萨。得随逐如来观察甚深广大法界藏解脱门。普清净无尽福威光菩萨摩诃萨。得普入一切世间行出生菩萨无边行门解脱门。普相最胜光菩萨摩诃萨。得能于无相法界中出现一切诸佛境界解脱门。尔时净德妙光菩萨摩诃萨。承佛威力。普观一切菩萨解脱门海已。即说颂言

  十方所有诸国土　　一刹那中悉严净
  以妙音声转法轮　　普遍世间无与等
  如来境界无边际　　一念法界悉充满
  一一尘中建道场　　悉证菩提起神变
  世尊往昔修诸行　　经于百千无量劫
  一切佛刹皆庄严　　出现无碍如虚空
  佛神通力无限量　　充满无边一切劫
  假使经于无量劫　　念念观察无疲厌
  汝应观佛神通境　　十方国土皆严净
  一切于此悉现前　　念念不同无量种
  观佛百千无量劫　　不得一毛之分限
  如来无碍方便门　　此光普照难思刹
  如来往劫在世间　　承事无边诸佛海
  是故一切如川骛　　咸来供养世所尊
  如来出现遍十方　　一一尘中无量土
  其中境界皆无量　　悉住无边无尽劫
  佛于曩劫为众生　　修习无边大悲海
  随诸众生入生死　　普化众会令清净
  佛住真如法界藏　　无相无形离诸垢
  众生观见种种身　　一切苦难皆消灭

复次海月光大明菩萨摩诃萨。得出生菩萨诸地诸波罗蜜教化众生及严净一切佛国土方便解脱门。云音海光离垢藏菩萨摩诃萨。得念念中普入法界种种差别处解脱门。智生宝髻菩萨摩诃萨。得不可思议劫于一切众生前现清净大功德解脱门。功德自在王净光菩萨摩诃萨。得普见十方一切菩萨初诣道场时种种庄严解脱门。善勇猛莲华髻菩萨摩诃萨。得随诸众生根解海普为显示一切佛法解脱门。普智云日幢菩萨摩诃萨。得成就如来智永住无量劫解脱门。大精进金刚脐菩萨摩诃萨。得普入一切无边法印力解脱门。香焰光幢菩萨摩诃萨。得显示现在一切佛始修菩萨行乃至成就智慧聚解脱门。大明德深美音菩萨摩诃萨。得安住毗卢遮那一切大愿海解脱门。大福光智生菩萨摩诃萨。得显示如来遍法界甚深境界解脱门。尔时。海月光大明菩萨摩诃萨。承佛威力。普观一切菩萨众庄严海已。即说颂言

  诸波罗蜜及诸地　　广大难思悉圆满
  无量众生尽调伏　　一切佛土皆严净
  如佛教化众生界　　十方国土皆充满
  一念心中转法轮　　普应群情无不遍
  佛于无量广大劫　　普现一切众生前
  如其往昔广修治　　示彼所行清净处
  我睹十方无有余　　亦见诸佛现神通
  悉坐道场成正觉　　众会闻法共围绕
  广大光明佛法身　　能以方便现世间
  普随众生心所乐　　悉称其根而雨法
  真如平等无相身　　离垢光明净法身
  智慧寂静身无量　　普应十方而演法
  法王诸力皆清净　　智慧如空无有边
  悉为开示无遗隐　　普使众生同悟入
  如佛往昔所修治　　乃至成于一切智
  今放光明遍法界　　于中显现悉明了
  佛以本愿现神通　　一切十方无不照
  如佛往昔修治行　　光明网中皆演说
  十方境界无有尽　　无等无边各差别
  佛无碍力发大光　　一切国土皆明显

尔时如来师子之座。众宝妙华轮台基陛。及诸户牖。如是一切庄严具中。一一各出佛刹微尘数菩萨摩诃萨。其名曰海慧自在神通王菩萨摩诃萨。雷音普震菩萨摩诃萨。众宝光明髻菩萨摩诃萨。大智日勇猛慧菩萨摩诃萨。不思议功德宝智印菩萨摩诃萨。百目莲华髻菩萨摩诃萨。金焰圆满光菩萨摩诃萨。法界普音菩萨摩诃萨。云音净月菩萨摩诃萨。善勇猛光明幢菩萨摩诃萨。如是等而为上首。有众多佛刹微尘数。同时出现。此诸菩萨。各兴种种供养云。所谓。一切摩尼宝华云。一切莲华妙香云。一切宝圆满光云。无边境界香焰云。日藏摩尼轮光明云。一切悦意乐音云。无边色相一切宝灯光焰云。众宝树枝华果云。无尽宝清净光明摩尼王云。一切庄严具摩尼王云。如是等诸供养云。有佛世界微尘数。彼诸菩萨。一一皆兴如是供养云。雨于一切道场众海。相续不绝。现是云已。右绕世尊。经无量百千匝。随其方面。去佛不远。化作无量种种宝莲华师子之座。各于其上。结跏趺坐。是诸菩萨所行清净广大如海。得智慧光照普门法。随顺诸佛。所行无碍。能入一切辩才法海。得不思议解脱法门。住于如来普门之地。已得一切陀罗尼门。悉能容受一切法海。善住三世平等智地。已得深信广大喜乐。无边福聚。极善清净。虚空法界靡不观察。十方世界。一切国土。所有佛兴。咸勤供养。尔时海慧自在神通王菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  诸佛所悟悉已知　　如空无碍皆明照
  光遍十方无量土　　处于众会普严洁
  如来功德不可量　　十方法界悉充满
  普坐一切树王下　　诸大自在共云集
  佛有如是神通力　　一念现于无尽相
  如来境界无有边　　各随解脱能观见
  如来往昔经劫海　　在于诸有勤修行
  种种方便化众生　　令彼受行诸佛法
  毗卢遮那具严好　　坐莲华藏师子座
  一切众会皆清净　　寂然而住同瞻仰
  摩尼宝藏放光明　　普发无边香焰云
  无量华缨共垂布　　如是座上如来坐
  种种严饰吉祥门　　恒放灯光宝焰云
  广大炽然无不照　　牟尼处上增严好
  种种摩尼绮丽窗　　妙宝莲华所垂饰
  恒出妙音闻者悦　　佛坐其上特明显
  宝轮承座半月形　　金刚为台色焰明
  持髻菩萨常围绕　　佛在其中最光耀
  种种变化满十方　　演说如来广大愿
  一切影像于中现　　如是座上佛安坐

尔时雷音普震菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  世尊往集菩提行　　供养十方无量佛
  善逝威力所加持　　如来座中无不睹
  香焰摩尼如意王　　填饰妙华师子座
  种种庄严皆影现　　一切众会悉明瞩
  佛座普现庄严相　　念念色类各差别
  随诸众生解不同　　各见佛坐于其上
  宝枝垂布莲华网　　华开踊现诸菩萨
  各出微妙悦意声　　称赞如来坐于座
  佛功德量如虚空　　一切庄严从此生
  一一地中严饰事　　一切众生不能了
  金刚为地无能坏　　广博清净极夷坦
  摩尼为网垂布空　　菩提树下皆周遍
  其地无边色相殊　　真金为末布其中
  普散名华及众宝　　悉以光莹如来座
  地神欢喜而踊跃　　刹那示现无有尽
  普兴一切庄严云　　恒在佛前瞻仰住
  宝灯广大极炽然　　香焰流光无断绝
  随时示现各差别　　地神以此为供养
  十方一切刹土中　　彼地所有诸庄严
  今此道场无不现　　以佛威神故能尔

尔时众宝光明髻菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  世尊往昔修行时　　见诸佛土皆圆满
  如是所见地无尽　　此道场中皆显现
  世尊广大神通力　　舒光普雨摩尼宝
  如是宝藏散道场　　其地周回悉严丽
  如来福德神通力　　摩尼妙宝普庄严
  其地及以菩提树　　递发光音而演说
  宝灯无量从空雨　　宝王间错为严饰
  悉吐微妙演法音　　如是地神之所现
  宝地普现妙光云　　宝炬焰明如电发
  宝网遐张覆其上　　宝枝杂布为严好
  汝等普观于此地　　种种妙宝所庄严
  显示众生诸业海　　令彼了知真法性
  普遍十方一切佛　　所有圆满菩提树
  莫不皆现道场中　　演说如来清净法
  随诸众生心所乐　　其地普出妙音声
  如佛座上所应演　　一一法门咸具说
  其地恒出妙香光　　光中普演清净音
  若有众生堪受法　　悉使得闻烦恼灭
  一一庄严悉圆满　　假使亿劫无能说
  如来神力靡不周　　是故其地皆严净

尔时大智日勇猛慧菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  世尊凝睟处法堂　　炳然照耀宫殿中
  随诸众生心所乐　　其身普现十方土
  如来宫殿不思议　　摩尼宝藏为严饰
  诸庄严具咸光耀　　佛坐其中特明显
  摩尼为柱种种色　　真金铃铎如云布
  宝阶四面列成行　　门闼随方咸洞启
  妙华缯绮庄严帐　　宝树枝条共严饰
  摩尼璎珞四面垂　　智海于中湛然坐
  摩尼为网妙香幢　　光焰灯明若云布
  覆以种种庄严具　　超世正知于此坐
  十方普现变化云　　其云演说遍世间
  一切众生悉调伏　　如是皆从佛宫现
  摩尼为树发妙华　　十方所有无能匹
  三世国土庄严事　　莫不于中现其影
  处处皆有摩尼聚　　光焰炽然无量种
  门牖随方相间开　　栋宇庄严极殊丽
  如来宫殿不思议　　清净光明具众相
  一切宫殿于中现　　一一皆有如来坐
  如来宫殿无有边　　自然觉者处其中
  十方一切诸众会　　莫不向佛而来集

尔时不思议功德宝智印菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  佛昔修治众福海　　一切刹土微尘数
  神通愿力所出生　　道场严净无诸垢
  如意珠王作树根　　金刚摩尼以为身
  宝网遐施覆其上　　妙香氛氲共旋绕
  树枝严饰备众宝　　摩尼为干争耸擢
  枝条密布如重云　　佛于其下坐道场
  道场广大不思议　　其树周回尽弥覆
  密叶繁华相庇映　　华中悉结摩尼果
  一切枝间发妙光　　其光遍照道场中
  清净炽然无有尽　　以佛愿力如斯睹
  摩尼宝藏以为华　　布影腾辉若绮云
  匝树垂芳无不遍　　于道场中普严饰
  汝观善逝道场中　　莲华宝网俱清净
  光焰成轮从此现　　铃音铎响云间发
  十方一切国土中　　所有妙色庄严树
  菩提树中无不现　　佛于其下离众垢
  道场广大福所成　　树枝雨宝恒无尽
  宝中出现诸菩萨　　悉往十方供事佛
  诸佛境界不思议　　普令其树出乐音
  如昔所集菩提道　　众会闻音咸得见

尔时百目莲华髻菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  一切摩尼出妙音　　称扬三世诸佛名
  彼佛无量神通事　　此道场中皆现睹
  众华竞发如缨布　　光云流演遍十方
  菩提树神持向佛　　一心瞻仰为供养
  摩尼光焰悉成幢　　幢中炽然发妙香
  其香普熏一切众　　是故其处皆严洁
  莲华垂布金色光　　其光演佛妙声云
  普荫十方诸刹土　　永息众生烦恼热
  菩提树王自在力　　常放光明极清净
  十方众会无有边　　莫不影现道场中
  宝枝光焰若明灯　　其光演音宣大愿
  如佛往昔于诸有　　本所修行皆具说
  树下诸神刹尘数　　悉共依于此道场
  各各如来道树前　　念念宣扬解脱门
  世尊往昔修诸行　　供养一切诸如来
  本所修行及名闻　　摩尼宝中皆悉现
  道场一切出妙音　　其音广大遍十方
  若有众生堪受法　　莫不调伏令清净
  如来往昔普修治　　一切无量庄严事
  十方一切菩提树　　一一庄严无量种

尔时金焰圆满光菩萨摩诃萨。承佛威力。普观一切道场众海。即说颂言

  佛昔修习菩提行　　于诸境界解明了
  处与非处净无疑　　此是如来初智力
  如昔等观诸法性　　一切业海皆明彻
  如是今于光网中　　普遍十方能具演
  往劫修治大方便　　随众生根而化诱
  普使众会心清净　　故佛能成根智力
  如诸众生解不同　　欲乐诸行各差别
  随其所应为说法　　佛以智力能如是
  普尽十方诸刹海　　所有一切众生界
  佛智平等如虚空　　悉能显现毛孔中
  一切处行佛尽知　　一念三世毕无余
  十方刹劫众生时　　悉能开示令现了
  禅定解脱力无边　　三昧方便亦复然
  佛为示现令欢喜　　普使涤除烦恼闇
  佛智无碍包三世　　刹那悉现毛孔中
  佛法国土及众生　　所现皆由随念力
  佛眼广大如虚空　　普见法界尽无余
  无碍地中无等用　　彼眼无量佛能演
  一切众生具诸结　　所有随眠与习气
  如来出现遍世间　　悉以方便令除灭

尔时法界普音菩萨摩诃萨。承佛威力。普观一切道场众会海已。即说颂言

  佛威神力遍十方　　广大示现无分别
  大菩提行波罗蜜　　昔所满足皆令见
  昔于众生起大悲　　修行布施波罗蜜
  以是其身最殊妙　　能令见者生欢喜
  昔在无边大劫海　　修治净戒波罗蜜
  故获净身遍十方　　普灭世间诸重苦
  往昔修行忍清净　　信解真实无分别
  是故色相皆圆满　　普放光明照十方
  往昔勤修多劫海　　能转众生深重障
  故能分身遍十方　　悉现菩提树王下
  佛久修行无量劫　　禅定大海普清净
  故令见者深欢喜　　烦恼障垢悉除灭
  如来往修诸行海　　具足般若波罗蜜
  是故舒光普照明　　克殄一切愚痴暗
  种种方便化众生　　令所修治悉成就
  一切十方皆遍往　　无边际劫不休息
  佛昔修行大劫海　　净治诸愿波罗蜜
  是故出现遍世间　　尽未来际救众生
  佛无量劫广修治　　一切法力波罗蜜
  由是能成自然力　　普现十方诸国土
  佛昔修治普门智　　一切智性如虚空
  是故得成无碍力　　舒光普照十方刹

尔时云音净月菩萨摩诃萨。承佛威力。普观一切道场众会海已。即说颂言

  神通境界等虚空　　十方众生靡不见
  如昔修行所成地　　摩尼果中咸具说
  清净勤修无量劫　　入于初地极欢喜
  出生法界广大智　　普见十方无量佛
  一切法中离垢地　　等众生数持净戒
  已于多劫广修行　　供养无边诸佛海
  积集福德发光地　　奢摩他藏坚固忍
  法云广大悉已闻　　摩尼果中如是说
  焰海慧明无等地　　善了境界起慈悲
  一切国土平等身　　如佛所治皆演畅
  普藏等门难胜地　　动寂相顺无违返
  佛法境界悉平等　　如佛所净皆能说
  广大修行慧海地　　一切法门咸遍了
  普现国土如虚空　　树中演畅此法音
  周遍法界虚空身　　普照众生智慧灯
  一切方便皆清净　　昔所远行令具演
  一切愿行所庄严　　无量刹海皆清净
  所有分别无能动　　此无等地咸宣说
  无量境界神通力　　善入教法光明力
  此是清净善慧地　　劫海所行皆备阐
  法云广大第十地　　含藏一切遍虚空
  诸佛境界声中演　　此声是佛威神力

尔时善勇猛光幢菩萨摩诃萨。承佛威神。观察十方。即说颂言

  无量众生处会中　　种种信解心清净
  悉能悟入如来智　　了达一切庄严境
  各起净愿修诸行　　悉曾供养无量佛
  能见如来真实体　　及以一切诸神变
  或有能见佛法身　　无等无碍普周遍
  所有无边诸法性　　悉入其身无不尽
  或有见佛妙色身　　无边色相光炽然
  随诸众生解不同　　种种变现十方中
  或见无碍智慧身　　三世平等如虚空
  普随众生心乐转　　种种差别皆令见
  或有能了佛音声　　普遍十方诸国土
  随诸众生所应解　　为出言音无障碍
  或见如来种种光　　种种照耀遍世间
  或有于佛光明中　　复见诸佛现神通
  或有见佛海云光　　从毛孔出色炽然
  示现往昔修行道　　令生深信入佛智
  或见佛相福庄严　　及见此福所从生
  往昔修行诸度海　　皆佛相中明了见
  如来功德不可量　　充满法界无边际
  及以神通诸境界　　以佛力故能宣说

尔时华藏庄严世界海。以佛神力。其地一切六种。十八相震动。所谓。动遍动。普遍动。起。遍起。普遍起。涌。遍涌。普遍涌。震。遍震。普遍震。吼。遍吼。普遍吼。击。遍击。普遍击。此诸世主。一一皆现不思议诸供养云。雨于如来道场众海。所谓。一切香华庄严云。一切摩尼妙饰云。一切宝焰华网云。无边种类摩尼宝圆光云。一切众色宝真珠藏云。一切宝栴檀香云。一切宝盖云。清净妙声摩尼王云。日光摩尼璎珞轮云。一切宝光明藏云一切各别庄严具云。如是等诸供养云。其数无量不可思议。此诸世主。一一皆现如是供养云。雨于如来道场众海。靡不周遍。如此世界中。一一世主。心生欢喜。如是供养。其华藏庄严。世界海中。一切世界。所有世主。悉亦如是而为供养。其一切世界中。悉有如来。坐于道场。一一世主各各信解。各各所缘。各各三昧方便门。各各修习助道法。各各成就。各各欢喜。各各趣入。各各悟解诸法门。各各入如来神通境界。各各入如来力境界。各各入如来解脱门。如于此华藏世界海。十方尽法界。虚空界。一切世界海中。悉亦如是

大方广佛华严经卷第五大方广佛华严经卷第六

        于阗国三藏实叉难陀奉　制译

    如来现相品第二

尔时诸菩萨。及一切世间主。作是思惟。云何是诸佛地。云何是诸佛境界。云何是诸佛加持。云何是诸佛所行。云何是诸佛力。云何是诸佛无所畏。云何是诸佛三昧。云何是诸佛无能摄取。云何是诸佛眼。云何是诸佛耳。云何是诸佛鼻。云何是诸佛舌。云何是诸佛身。云何是诸佛意。云何是诸佛身光。云何是诸佛光明。云何是诸佛声。云何是诸佛智。唯愿世尊。哀愍我等。开示演说。又十方世界海。一切诸佛。皆为诸菩萨。说世界海。众生海。佛海。佛波罗蜜海。佛解脱海。佛变化海。佛演说海。佛名号海。佛寿量海。及一切菩萨誓愿海。一切菩萨发趣海。一切菩萨助道海。一切菩萨乘海。一切菩萨行海。一切菩萨出离海。一切菩萨神通海。一切菩萨波罗蜜海。一切菩萨地海。一切菩萨智海。愿佛世尊。亦为我等。如是而说。尔时诸菩萨。威神力故。于一切供养具云中。自然出音。而说颂言

  无量劫中修行满　　菩提树下成正觉
  为度众生普现身　　如云充遍尽未来
  众生有疑皆使断　　广大信解悉令发
  无边际苦普使除　　诸佛安乐咸令证
  菩萨无数等刹尘　　俱来此会同瞻仰
  愿随其意所应受　　演说妙法除疑惑
  云何了知诸佛地　　云何观察如来境
  佛所加持无有边　　愿示此法令清净
  云何是佛所行处　　而以智慧能明入
  佛力清净广无边　　为诸菩萨应开示
  云何广大诸三昧　　云何净治无畏法
  神通力用不可量　　愿随众生心乐说
  诸佛法王如世主　　所行自在无能制
  及余一切广大法　　为利益故当开演
  佛眼云何无有量　　耳鼻舌身亦复然
  意无有量复云何　　愿示能知此方便
  如诸刹海众生海　　法界所有安立海
  及诸佛海亦无边　　愿为佛子咸开畅
  永出思议众度海　　普入解脱方便海
  所有一切法门海　　此道场中愿宣说

尔时世尊。知诸菩萨心之所念。即于面门众齿之间。放佛刹微尘数光明。所谓。众宝华遍照光明。出种种音庄严法界光明。垂布微妙云光明。十方佛坐道场现神变光明。一切宝焰云盖光明。充满法界无碍光明。遍庄严一切佛刹光明迥建立清净金刚宝幢光明。普庄严菩萨众会道场光明。妙音称扬一切佛名号光明。如是等佛刹微尘数。一一复有佛刹微尘数光明。以为眷属。其光悉具众妙宝色。普照十方各一亿佛刹微尘数世界海。彼世界海诸菩萨众。于光明中。各得见此华藏庄严世界海。以佛神力。其光于彼一切菩萨众会之前。而说颂言

  无量劫中修行海　　供养十方诸佛海
  化度一切众生海　　今成妙觉遍照尊
  毛孔之中出化云　　光明普照于十方
  应受化者咸开觉　　令趣菩提净无碍
  佛昔往来诸趣中　　教化成熟诸群生
  神通自在无边量　　一念皆令得解脱
  摩尼妙宝菩提树　　种种庄严悉殊特
  佛于其下成正觉　　放大光明普威耀
  大音震吼遍十方　　普为弘宣寂灭法
  随诸众生心所乐　　种种方便令开晓
  往修诸度皆圆满　　等于千刹微尘数
  一切诸力悉已成　　汝等应往同瞻礼
  十方佛子等刹尘　　悉共欢喜而来集
  已雨诸云为供养　　今在佛前专觐仰
  如来一音无有量　　能演契经深大海
  普雨妙法应群心　　彼两足尊宜往见
  三世诸佛所有愿　　菩提树下皆宣说
  一刹那中悉现前　　汝可速诣如来所
  毗卢遮那大智海　　面门舒光无不见
  今待众集将演音　　汝可往观闻所说

尔时十方世界海。一切众会。蒙佛光明所开觉已。各共来诣毗卢遮那如来所。亲近供养。所谓。此华藏庄严世界海东。次有世界海。名清净光莲华庄严。彼世界种中有国土。名摩尼璎珞金刚藏。佛号法水觉虚空无边王。于彼如来大众海中。有菩萨摩诃萨。名观察胜法莲华幢。与世界海微尘数诸菩萨俱。来诣佛所。各现十种菩萨身相云。遍满虚空。而不散灭。复现十种雨一切宝莲华光明云。复现十种须弥宝峰云。复现十种日轮光云。复现十种宝华璎珞云。复现十种一切音乐云。复现十种末香树云。复现十种涂香烧香众色相云。复现十种一切香树云。如是等世界海微尘数诸供养云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于东方。各化作种种华光明藏师子之座。于其座上。结跏趺坐。此华藏世界海南。次有世界海。名一切宝月光明庄严藏。彼世界种中有国土。名无边光圆满庄严。佛号普智光明德须弥王。于彼如来大众海中。有菩萨摩诃萨。名普照法海慧。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切庄严光明藏摩尼王云。遍满虚空。而不散灭。复现十种雨一切宝庄严具普照耀摩尼王云。复现十种宝焰炽然称扬佛名号摩尼王云。复现十种说一切佛法摩尼王云。复现十种众妙树庄严道场摩尼王云。复现十种宝光普照现众化佛摩尼王云。复现十种普现一切道场庄严像摩尼王云。复现十种密焰灯说诸佛境界摩尼王云。复现十种不思议佛刹宫殿像摩尼王云。复现十种普现三世佛身像摩尼王云。如是等世界海微尘数摩尼王云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于南方。各化作帝青宝阎浮檀金莲华藏师子之座。于其座上。结跏趺坐。此华藏世界海西。次有世界海。名可爱乐宝光明。彼世界种中有国土。名出生上妙资身具。佛号香焰功德宝庄严。于彼如来大众海中。有菩萨摩诃萨。名月光香焰普庄严。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切宝香众妙华楼阁云遍满。虚空而不散灭。复现十种无边色相众宝王楼阁云。复现十种宝灯香焰楼阁云。复现十种一切真珠楼阁云。复现十种一切宝华楼阁云。复现十种宝璎珞庄严楼阁云。复现十种普现十方一切庄严光明藏楼阁云。复现十种众宝末间错庄严楼阁云。复现十种周遍十方一切庄严楼阁云。复现十种华门铎网楼阁云。如是等世界海微尘数楼阁云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于西方。各化作真金叶大宝藏师子之座。于其座上。结跏趺坐。此华藏世界海北。次有世界海。名毗琉璃莲华光圆满藏。彼世界种中有国土。名优钵罗华庄严。佛号普智幢音王。于彼如来大众海中。有菩萨摩诃萨。名师子奋迅光明。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切香摩尼众妙树云。遍满虚空。而不散灭。复现十种密叶妙香庄严树云。复现十种化现一切无边色相树庄严树云。复现十种一切华周布庄严树云。复现十种一切宝焰圆满光庄严树云。复现十种现一切栴檀香菩萨身庄严树云。复现十种现往昔道场处不思议庄严树云。复现十种众宝衣服藏如日光明树云。复现十种普发一切悦意音声树云。如是等世界海微尘数树云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于北方。各化作摩尼灯莲华藏师子之座。于其座上。结跏趺坐。此华藏世界海东北方。次有世界海。名阎浮檀金玻璃色幢。彼世界种中有国土。名众宝庄严。佛号一切法无畏灯。于彼如来大众海中。有菩萨摩诃萨。名最胜光明灯无尽功德藏。与世界海微尘数诸菩萨俱。来诣佛所。各现十种无边色相宝莲华藏师子座云。遍满虚空。而不散灭。复现十种摩尼王光明藏师子座云。复现十种一切庄严具种种校饰师子座云。复现十种众宝鬘灯焰藏师子座云。复现十种普雨宝璎珞师子座云。复现十种一切香华宝璎珞藏师子座云。复现十种示现一切佛座庄严摩尼王藏师子座云。复现十种户牖阶砌及诸璎珞一切庄严师子座云。复现十种一切摩尼树宝枝茎藏师子座云。复现十种宝香间饰日光明藏师子座云。如是等世界海微尘数师子座云。悉遍虚空。而不散灭。现是云已。向佛作礼以为供养。即于东北方。各化作宝莲华摩尼光幢师子之座。于其座上。结跏趺坐。此华藏世界海东南方。次有世界海。名金庄严琉璃光普照。彼世界种中有国土。名清净香光明。佛号普喜深信王。于彼如来大众海中。有菩萨摩诃萨。名慧灯普明。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切如意王摩尼帐云。遍满虚空。而不散灭。复现十种帝青宝一切华庄严帐云。复现十种一切香摩尼帐云。复现十种宝焰灯帐云。复现十种示现佛神通说法摩尼王帐云。复现十种现一切衣服庄严色像摩尼帐云。复现十种一切宝华丛光明帐云。复现十种宝网铃铎音帐云。复现十种摩尼为台莲华为网帐云。复现十种现一切不思议庄严具色像帐云。如是等世界海微尘数众宝帐云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于东南方。各化作宝莲华藏师子之座。于其座上。结跏趺坐。此华藏世界海西南方。次有世界海。名日光遍照。彼世界种中有国土。名师子日光明。佛号普智光明音。于彼如来大众海中。有菩萨摩诃萨。名普华光焰髻。与世界海微尘数诸菩萨俱。来诣佛所。各现十种众妙庄严宝盖云。遍满虚空。而不散灭。复现十种光明庄严华盖云。复现十种无边色真珠藏盖云。复现十种出一切菩萨悲愍音摩尼王盖云。复现十种众妙宝焰鬘盖云。复现十种妙宝严饰垂网铎盖云。复现十种摩尼树枝庄严盖云。复现十种日光普照摩尼王盖云。复现十种一切涂香烧香盖云。复现十种栴檀藏盖云。复现十种广大佛境界普光明庄严盖云。如是等世界海微尘数众宝盖云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于西南方。各化作帝青宝光焰庄严藏师子之座。于其座上。结跏趺坐。此华藏世界海西北方。次有世界海。名宝光照耀。彼世界种中有国土。名众香庄严。佛号无量功德海光明。于彼如来大众海中。有菩萨摩诃萨。名无尽光摩尼王。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切宝圆满光云。遍满虚空。而不散灭。复现十种一切宝焰圆满光云。复现十种一切妙华圆满光云。复现十种一切化佛圆满光云。复现十种十方佛土圆满光云。复现十种佛境界雷声宝树圆满光云。复现十种一切琉璃宝摩尼王圆满光云。复现十种一念中现无边众生相圆满光云。复现十种演一切如来大愿音圆满光云。复现十种演化一切众生音摩尼王圆满光云。如是等世界海微尘数圆满光云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于西北方。各化作无尽光明威德藏师子之座。于其座上。结跏趺坐。此华藏世界海下方。次有世界海。名莲华香妙德藏。彼世界种中有国土。名宝师子光明照耀。佛号法界光明。于彼如来大众海中。有菩萨摩诃萨。名法界光焰慧。与世界海微尘数诸菩萨俱。来诣佛所。各现十种一切摩尼藏光明云。遍满虚空。而不散灭。复现十种一切香光明云。复现十种一切宝焰光明云。复现十种出一切佛说法音光明云。复现十种现一切佛土庄严光明云。复现十种一切妙华楼阁光明云。复现十种现一切劫中诸佛教化众生事光明云。复现十种一切无尽宝华蕊光明云。复现十种一切庄严座光明云。如是等世界海微尘数光明云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于下方。各化作宝焰灯莲华藏师子之座。于其座上。结跏趺座。此华藏世界海上方。次有世界海。名摩尼宝照耀庄严。彼世界种中有国土。名无相妙光明。佛号无碍功德光明王。于彼如来大众海中。有菩萨摩诃萨。名无碍力精进慧。与世界海微尘数诸菩萨俱。来诣佛所。各现十种无边色相宝光焰云。遍满虚空。而不散灭。复现十种摩尼宝网光焰云。复现十种一切广大佛土庄严光焰云。复现十种一切妙香光焰云。复现十种一切庄严光焰云。复现十种诸佛变化光焰云。复现十种众妙树华光焰云。复现十种一切金刚光焰云。复现十种说无边菩萨行摩尼光焰云。复现十种一切真珠灯光焰云。如是等世界海微尘数光焰云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。即于上方。各化作演佛音声光明莲华藏师子之座。于其座上。结跏趺坐。如是等十亿佛刹微尘数世界海中。有十亿佛刹微尘数菩萨摩诃萨。一一各有世界海微尘数诸菩萨众。前后围绕。而来集会。是诸菩萨。一一各现世界海微尘数种种庄严诸供养云。悉遍虚空。而不散灭。现是云已。向佛作礼。以为供养。随所来方。各化作种种宝庄严师子之座。于其座上。结跏趺坐。如是坐已。其诸菩萨。身毛孔中。一一各现十世界海微尘数一切宝种种色光明。一一光中。悉现十世界海微尘数诸菩萨。皆坐莲华藏师子之座。此诸菩萨。悉能遍入一切法界诸安立海所有微尘。彼一一尘中。皆有十佛世界微尘数诸广大刹。一一刹中。皆有三世诸佛世尊。此诸菩萨。悉能遍往亲近供养。于念念中。以梦自在。示现法门。开悟世界海微尘数众生。念念中。以示现一切诸天没生法门。开悟世界海微尘数众生。念念中。以说一切菩萨行法门。开悟世界海微尘数众生。念念中。以普震动一切刹叹佛功德神变法门。开悟世界海微尘数众生。念念中。以严净一切佛国土显示一切大愿海法门。开悟世界海微尘数众生。念念中。以普摄一切众生言辞佛音声法门。开悟世界海微尘数众生。念念中。以能雨一切佛法云法门。开悟世界海微尘数众生。念念中。以光明普照十方国土周遍法界示现神变法门。开悟世界海微尘数众生。念念中。以普现佛身。充遍法界一切如来解脱力法门。开悟世界海微尘数众生。念念中。以普贤菩萨建立一切众会道场海法门。开悟世界海微尘数众生。如是普遍一切法界。随众生心。悉令开悟。念念中。一一国土。各令如须弥山微尘数众生堕恶道者永离其苦。各令如须弥山微尘数众生住邪定者入正定聚。各令如须弥山微尘数众生随其所乐生于天上。各令如须弥山微尘数众生安住声闻辟支佛地。各令如须弥山微尘数众生事善知识具众福行。各令如须弥山微尘数众生发于无上菩提之心。各令如须弥山微尘数众生趣于菩萨不退转地。各令如须弥山微尘数众生得净智眼见于如来所见一切诸平等法。各令如须弥山微尘数众生安住诸力诸愿海中以无尽智而为方便净诸佛国。各令如须弥山微尘数众生皆得安住毗卢遮那广大愿海。生如来家

尔时诸菩萨。光明中同时发声。说此颂言

  诸光明中出妙音　　普遍十方一切国
  演说佛子诸功德　　能入菩提之妙道
  劫海修行无厌惓　　令苦众生得解脱
  心无下劣及劳疲　　佛子善入斯方便
  尽诸劫海修方便　　无量无边无有余
  一切法门无不入　　而恒说彼性寂灭
  三世诸佛所有愿　　一切修治悉令尽
  即以利益诸众生　　而为自行清净业
  一切诸佛众会中　　普遍十方无不往
  皆以甚深智慧海　　入彼如来寂灭法
  一一光明无有边　　悉入难思诸国土
  清净智眼普能见　　是诸菩萨所行境
  菩萨能住一毛端　　遍动十方诸国土
  不令众生有怖想　　是其清净方便地
  一一尘中无量身　　复现种种庄严刹
  一念没生普令见　　获无碍意庄严者
  三世所有一切劫　　一刹那中悉能现
  知身如幻无体相　　证明法性无碍者
  普贤胜行皆能入　　一切众生悉乐见
  佛子能住此法门　　诸光明中大音吼

尔时世尊欲令一切菩萨大众得于如来无边境界神通力故。放眉间光。此光名一切菩萨智光明。普照耀十方藏。其状犹如宝色灯云。遍照十方一切佛刹。其中国土及以众生。悉令显现。又普震动诸世界网。一一尘中。现无数佛。随诸众生性欲不同。普雨三世一切诸佛妙法轮云。显示如来波罗蜜海。又雨无量诸出离云。令诸众生永度生死。复雨诸佛大愿之云。显示十方诸世界中。普贤菩萨。道场众会。作是事已。右绕于佛。从足下入。尔时佛前有大莲华。忽然出现。其华具有十种庄严。一切莲华。所不能及。所谓。众宝间错。以为其茎。摩尼宝王。以为其藏。法界众宝。普作其叶。诸香摩尼而作其须。阎浮檀金。庄莹其台。妙网覆上。光色清净。于一念中。示现无边诸佛神变。普能发起一切音声。摩尼宝王影现佛身。于音声中普能演说一切菩萨所修行愿。此华生已。一念之间。于如来白毫相中。有菩萨摩诃萨。名一切法胜音。与世界海微尘数诸菩萨众。俱时而出右绕如来。经无量匝。礼佛足已。时胜音菩萨。坐莲华台。诸菩萨众。坐莲华须。各于其上。次第而住。其一切法胜音菩萨。了深法界。生大欢喜。入佛所行。智无凝滞。入不可测佛法身海。往一切刹诸如来所。身诸毛孔。悉现神通。念念普观一切法界。十方诸佛。共与其力。令普安住一切三昧。尽未来劫。常见诸佛。无边法界。功德海身。乃至一切三昧解脱。神通变化。即于众中。承佛威神。观察十方。而说颂曰

  佛身充满于法界　　普现一切众生前
  随缘赴感靡不周　　而恒处此菩提座
  如来一一毛孔中　　一切刹尘诸佛坐
  菩萨众会共围绕　　演说普贤之胜行
  如来安处菩提座　　一毛示现多刹海
  一一毛现悉亦然　　如是普周于法界
  一一刹中悉安立　　一切刹土皆周遍
  十方菩萨如云集　　莫不咸来诣道场
  一切刹土微尘数　　功德光明菩萨海
  普在如来众会中　　乃至法界咸充遍
  法界微尘诸刹土　　一切众中皆出现
  如是分身智境界　　普贤行中能建立
  一切诸佛众会中　　胜智菩萨佥然坐
  各各听法生欢喜　　处处修行无量劫
  已入普贤广大愿　　各各出生众佛法
  毗卢遮那法海中　　修行克证如来地
  普贤菩萨所开觉　　一切如来同赞喜
  已获诸佛大神通　　法界周流无不遍
  一切刹土微尘数　　常现身云悉充满
  普为众生放大光　　各雨法雨称其心

尔时众中复有菩萨摩诃萨。名观察一切胜法莲华光慧王。承佛威神。观察十方。而说颂曰

  如来甚深智　　普入于法界
  能随三世转　　与世为明导
  诸佛同法身　　无依无差别
  随诸众生意　　令见佛色形
  具足一切智　　遍知一切法
  一切国土中　　一切无不现
  佛身及光明　　色相不思议
  众生信乐者　　随应悉令见
  于一佛身上　　化为无量佛
  雷音遍众刹　　演法深如海
  一一毛孔中　　光网遍十方
  演佛妙音声　　调彼难调者
  如来光明中　　常出深妙音
  赞佛功德海　　及菩萨所行
  佛转正法轮　　无量无有边
  所说法无等　　浅智不能测
  一切世界中　　现身成正觉
  各各起神变　　法界悉充满
  如来一一身　　现佛等众生
  一切微尘刹　　普现神通力

尔时众中复有菩萨摩诃萨。名法喜慧光明。承佛威神。观察十方。而说颂曰

  佛身常显现　　法界悉充满
  恒演广大音　　普震十方国
  如来普现身　　遍入于世间
  随众生乐欲　　显示神通力
  佛随众生心　　普现于其前
  众生所见者　　皆是佛神力
  光明无有边　　说法亦无量
  佛子随其智　　能入能观察
  佛身无有生　　而能示出生
  法性如虚空　　诸佛于中住
  无住亦无去　　处处皆见佛
  光明靡不周　　名称悉远闻
  无体无住处　　亦无生可得
  无相亦无形　　所现皆如影
  佛随众生心　　为兴大法云
  种种方便门　　示悟而调伏
  一切世界中　　见佛坐道场
  大众所围绕　　照耀十方国
  一切诸佛身　　皆有无尽相
  示现虽无量　　色相终不尽

尔时众中复有菩萨摩诃萨。名香焰光普明慧。承佛威神。观察十方而说颂曰

  此会诸菩萨　　入佛难思地
  一一皆能见　　一切佛神力
  智身能遍入　　一切刹微尘
  见身在彼中　　普见于诸佛
  如影现众刹　　一切如来所
  于彼一切中　　悉现神通事
  普贤诸行愿　　修治已明洁
  能于一切刹　　普见佛神变
  身住一切处　　一切皆平等
  智能如是行　　入佛之境界
  已证如来智　　等照于法界
  普入佛毛孔　　一切诸刹海
  一切佛国土　　皆现神通力
  示现种种身　　及种种名号
  能于一念顷　　普现诸神变
  道场成正觉　　及转妙法轮
  一切广大刹　　亿劫不思议
  菩萨三昧中　　一念皆能现
  一切诸佛土　　一一诸菩萨
  普入于佛身　　无边亦无尽

尔时众中复有菩萨摩诃萨。名师子奋迅慧光明。承佛威神。遍观十方。而说颂曰

  毗卢遮那佛　　能转正法轮
  法界诸国土　　如云悉周遍
  十方中所有　　诸大世界海
  佛神通愿力　　处处转法轮
  一切诸刹土　　广大众会中
  名号各不同　　随应演妙法
  如来大威力　　普贤愿所成
  一切国土中　　妙音无不至
  佛身等刹尘　　普雨于法雨
  无生无差别　　现一切世间
  无数诸亿劫　　一切尘刹中
  往昔所行事　　妙音咸具演
  十方尘国土　　光网悉周遍
  光中悉有佛　　普化诸群生
  佛身无差别　　充满于法界
  能令见色身　　随机善调伏
  三世一切刹　　所有众导师
  种种名号殊　　为说皆令见
  过未及现在　　一切诸如来
  所转妙法轮　　此会皆得闻

尔时众中复有菩萨摩诃萨。名法海慧功德藏。承佛威神。观察十方。而说颂曰

  此会诸佛子　　善修众智慧
  斯人已能入　　如是方便门
  一一国土中　　普演广大音
  说佛所行处　　周闻十方刹
  一一心念中　　普观一切法
  安住真如地　　了达诸法海
  一一佛身中　　亿劫不思议
  修习波罗蜜　　及严净国土
  一一微尘中　　能证一切法
  如是无所碍　　周行十方国
  一一佛刹中　　往诣悉无余
  见佛神通力　　入佛所行处
  诸佛广大音　　法界靡不闻
  菩萨能了知　　善入音声海
  劫海演妙音　　其音等无别
  智周三世者　　入彼音声地
  众生所有音　　及佛自在声
  获得音声智　　一切皆能了
  从地而得地　　住于力地中
  亿劫勤修行　　所获法如是

尔时众中复有菩萨摩诃萨。名慧灯普明。承佛威神。观察十方。而说颂曰

  一切诸如来　　远离于众相
  若能知是法　　乃见世导师
  菩萨三昧中　　慧光普明了
  能知一切佛　　自在之体性
  见佛真实体　　则悟甚深法
  普观于法界　　随愿而受身
  从于福海生　　安住于智地
  观察一切法　　修行最胜道
  一切佛刹中　　一切如来所
  如是遍法界　　悉见真实体
  十方广大刹　　亿劫勤修行
  能游正遍知　　一切诸法海
  唯一坚密身　　一切尘中见
  无生亦无相　　普现于诸国
  随诸众生心　　普现于其前
  种种示调伏　　速令向佛道
  以佛威神故　　出现诸菩萨
  佛力所加持　　普见诸如来
  一切众导师　　无量威神力
  开悟诸菩萨　　法界悉周遍

尔时众中复有菩萨摩诃萨。名华焰髻普明智。承佛威力。观察十方。而说颂曰

  一切国土中　　普演微妙音
  称扬佛功德　　法界悉充满
  佛以法为身　　清净如虚空
  所现众色形　　令入此法中
  若有深信喜　　及为佛摄受
  当知如是人　　能生了佛智
  诸有少智者　　不能知此法
  慧眼清净人　　于此乃能见
  以佛威神力　　观察一切法
  入住及出时　　所见皆明了
  一切诸法中　　法门无有边
  成就一切智　　入于深法海
  安住佛国土　　出兴一切处
  无去亦无来　　诸佛法如是
  一切众生海　　佛身如影现
  随其解差别　　如是见导师
  一切毛孔中　　各各现神通
  修行普贤愿　　清净者能见
  佛以一一身　　处处转法轮
  法界悉周遍　　思议莫能及

尔时众中复有菩萨摩诃萨。名威德慧无尽光。承佛威神。观察十方。而说颂曰

  一一佛刹中　　处处坐道场
  众会共围绕　　魔军悉摧伏
  佛身放光明　　遍满于十方
  随应而示现　　色相非一种
  一一微尘内　　光明悉充满
  普见十方土　　种种各差别
  十方诸刹海　　种种无量刹
  悉平坦清净　　帝青宝所成
  或覆或傍住　　或似莲华合
  或圆或四方　　种种众形相
  法界诸刹土　　周行无所碍
  一切众会中　　常转妙法轮
  佛身不思议　　国土悉在中
  于其一切处　　导世演真法
  所转妙法轮　　法性无差别
  依于一实理　　演说诸法相
  佛以圆满音　　阐明真实理
  随其解差别　　现无尽法门
  一切刹土中　　见佛坐道场
  佛身如影现　　生灭不可得

尔时众中复有菩萨摩诃萨。名法界普明慧。承佛威力。观察十方。而说颂曰

  如来微妙身　　色相不思议
  见者生欢喜　　恭敬信乐法
  佛身一切相　　悉现无量佛
  普入十方界　　一一微尘中
  十方国土海　　无量无边佛
  咸于念念中　　各各现神通
  大智诸菩萨　　深入于法海
  佛力所加持　　能知此方便
  若有已安住　　普贤诸行愿
  见彼众国土　　一切佛神力
  若人有信解　　及以诸大愿
  具足深智慧　　通达一切法
  能于诸佛身　　一一而观察
  色声无所碍　　了达于诸境
  能于诸佛身　　安住智所行
  速入如来地　　普摄于法界
  佛刹微尘数　　如是诸国土
  能令一念中　　一一尘中现
  一切诸国土　　及以神通事
  悉现一刹中　　菩萨力如是

尔时众中复有菩萨摩诃萨。名精进力无碍慧。承佛威神。观察十方。而说颂曰

  佛演一妙音　　周闻十方刹
  众音悉具足　　法雨皆充遍
  一切言辞海　　一切随类音
  一切佛刹中　　转于净法轮
  一切诸国土　　悉见佛神变
  听佛说法音　　闻已趣菩提
  法界诸国土　　一一微尘中
  如来解脱力　　于彼普现身
  法身同虚空　　无碍无差别
  色形如影像　　种种众相现
  影像无方所　　如空无体性
  智慧广大人　　了达其平等
  佛身不可取　　无生无起作
  应物普现前　　平等如虚空
  十方所有佛　　尽入一毛孔
  各各现神通　　智眼能观见
  毗卢遮那佛　　愿力周法界
  一切国土中　　恒转无上轮
  一毛现神变　　一切佛同说
  经于无量劫　　不得其边际

如此四天下道场中。以佛神力。十方各有一亿世界海微尘数诸菩萨众。而来集会。应知一切世界海。一一四天下。诸道场中。悉亦如是

大方广佛华严经卷第六大方广佛华严经卷第七

        于阗国三藏实叉难陀奉　制译

    普贤三昧品第三

尔时普贤菩萨摩诃萨。于如来前。坐莲华藏。师子之座。承佛神力。入于三昧。此三昧名一切诸佛。毗卢遮那如来藏身。普入一切佛平等性。能于法界。示众影像。广大无碍。同于虚空。法界海漩。靡不随入。出生一切诸三昧法。普能包纳十方法界。三世诸佛。智光明海。皆从此生。十方所有。诸安立海。悉能示现。含藏一切佛力解脱。诸菩萨智。能令一切国土微尘。普能容受无边法界。成就一切佛功德海。显示如来诸大愿海。一切诸佛。所有法轮。流通护持。使无断绝。如此世界中。普贤菩萨。于世尊前。入此三昧。如是尽法界虚空界。十方三世。微细无碍。广大光明。佛眼所见。佛力能到。佛身所现。一切国土。及此国土。所有微尘。一一尘中。有世界海。微尘数佛刹。一一刹中。有世界海。微尘数诸佛。一一佛前。有世界海。微尘数普贤菩萨。皆亦入此一切诸佛。毗卢遮那。如来藏身三昧

尔时一一普贤菩萨。皆有十方一切诸佛。而现其前。彼诸如来。同声赞言。善哉善哉。善男子。汝能入此一切诸佛。毗卢遮那如来藏身。菩萨三昧。佛子。此是十方一切诸佛。共加于汝。以毗卢遮那如来。本愿力故。亦以汝修一切诸佛。行愿力故。所谓。能转一切佛法轮故。开显一切如来。智慧海故。普照十方诸安立海。悉无余故。令一切众生。净治杂染。得清净故。普摄一切诸大国土。无所著故。深入一切诸佛境界。无障碍故。普示一切佛功德故。能入一切诸法实相。增智慧故。观察一切诸法门故。了知一切众生根故。能持一切诸佛如来教文海故

尔时十方一切诸佛。即与普贤菩萨摩诃萨。能入一切智性力智。与入法界无边量智。与成就一切佛境界智。与知一切世界海成坏智。与知一切众生界广大智。与住诸佛甚深解脱。无差别诸三昧智。与入一切菩萨。诸根海智。与知一切众生语言海。转法轮辞辩智。与普入法界。一切世界海身智。与得一切佛音声智。如此世界中。如来前。普贤菩萨。蒙诸佛与如是智。如是一切世界海。及彼世界海。一一尘中。所有普贤。悉亦如是。何以故。证彼三昧法。如是故。是时十方诸佛。各舒右手。摩普贤菩萨顶。其手皆以相好庄严。妙网光舒香流焰发。复出诸佛。种种妙音。及以自在神通之事。过现未来。一切菩萨。普贤愿海。一切如来。清净法轮。及三世佛。所有影像。皆于中现。如此世界中。普贤菩萨。为十方佛。所共摩顶。如是一切世界海。及彼世界海。一一尘中。所有普贤。悉亦如是。为十方佛之所摩顶

尔时。普贤菩萨。即从是三昧而起。从此三昧而起时。即从一切世界海微尘数。三昧海门起。所谓。从知三世。念念无差别。善巧智三昧门起。从知三世一切法界。所有微尘三昧门起。从现三世一切佛刹。三昧门起。从现一切众生舍宅。三昧门起。从知一切众生心海。三昧门起。从知一切众生。各别名字。三昧门起。从知十方法界。处所各差别三昧门起。从知一切微尘中。各有无边广大佛身云。三昧门起。从演说一切法理趣海。三昧门起。普贤菩萨。从如是等三昧门起时。其诸菩萨。一一各得世界海微尘数。三昧海云。世界海微尘数。陀罗尼海云。世界海微尘数。诸法方便海云世界海微尘数。辩才门海云世界海微尘数。修行海云。世界海微尘数。普照法界。一切如来。功德藏智。光明海云。世界海微尘数。一切如来。诸力智慧。无差别方便海云。世界海微尘数。一切如来。一一毛孔中。各现众刹海云。世界海微尘数。一一菩萨。示现从兜率天宫没。下生成佛。转正法轮。般涅槃等海云如此世界中。普贤菩萨。从三昧起。诸菩萨众。获如是益。如是一切世界海。及彼世界海。所有微尘。一一尘中。悉亦如是

尔时。十方一切世界海。以诸佛威神力。及普贤菩萨。三昧力故。悉皆微动。一一世界。众宝庄严。及出妙音。演说诸法。复于一切如来。众会道场海中。普雨十种。大摩尼王云。何等为十。所谓。妙金星幢。摩尼王云光明照耀。摩尼王云。宝轮垂下。摩尼王云。众宝藏现菩萨像。摩尼王云。称扬佛名。摩尼王云。光明炽盛。普照一切佛刹道场。摩尼王云。光照十方。种种变化。摩尼王云称赞一切菩萨功德。摩尼王云。如日光炽盛。摩尼王云。悦意乐音。周闻十方。摩尼王云普雨如是十种大摩尼王云已。一切如来。诸毛孔中。咸放光明。于光明中。而说颂言

  普贤遍住于诸刹　　坐宝莲华众所观
  一切神通靡不现　　无量三昧皆能入
  普贤恒以种种身　　法界周流悉充满
  三昧神通方便力　　圆音广说皆无碍
  一切刹中诸佛所　　种种三昧现神通
  一一神通悉周遍　　十方国土无遗者
  如一切刹如来所　　彼刹尘中悉亦然
  所现三昧神通事　　毗卢遮那之愿力
  普贤身相如虚空　　依真而住非国土
  随诸众生心所欲　　示现普身等一切
  普贤安住诸大愿　　获此无量神通力
  一切佛身所有刹　　悉现其形而诣彼
  一切众海无有边　　分身住彼亦无量
  所现国土皆严净　　一刹那中见多劫
  普贤安住一切刹　　所现神通胜无比
  震动十方靡不周　　令其观者悉得见
  一切佛智功德力　　种种大法皆成满
  以诸三昧方便门　　示己往昔菩提行
  如是自在不思议　　十方国土皆示现
  为显普入诸三昧　　佛光云中赞功德

尔时。一切菩萨众。皆向普贤。合掌瞻仰。承佛神力。同声赞言

  从诸佛法而出生　　亦因如来愿力起
  真如平等虚空藏　　汝已严净此法身
  一切佛刹众会中　　普贤遍住于其所
  功德智海光明者　　等照十方无不见
  普贤广大功德海　　遍往十方亲近佛
  一切尘中所有刹　　悉能诣彼而明现
  佛子我曹常见汝　　诸如来所悉亲近
  住于三昧实境中　　一切国土微尘劫
  佛子能以普遍身　　悉诣十方诸国土
  众生大海咸济度　　法界微尘无不入
  入于法界一切尘　　其身无尽无差别
  譬如虚空悉周遍　　演说如来广大法
  一切功德光明者　　如云广大力殊胜
  众生海中皆往诣　　说佛所行无等法
  为度众生于劫海　　普贤胜行皆修习
  演一切法如大云　　其音广大靡不闻
  国土云何得成立　　诸佛云何而出现
  及以一切众生海　　愿随其义如实说
  此中无量大众海　　悉在尊前恭敬住
  为转清净妙法轮　　一切诸佛皆随喜

    大方广佛华严经世界成就品第四

尔时。普贤菩萨摩诃萨。以佛神力。遍观察一切世界海。一切众生海。一切诸佛海。一切法界海。一切众生业海。一切众生根欲海。一切诸佛法轮海。一切三世海。一切如来愿力海。一切如来神变海。如是观察已。普告一切道场众海。诸菩萨言。佛子。诸佛世尊。知一切世界海。成坏清净智。不可思议。知一切众生业海智。不可思议。知一切法界。安立海智。不可思议。说一切无边佛海智。不可思议。入一切欲解根海智。不可思议。一念普知一切三世智。不可思议。显示一切如来。无量愿海智。不可思议。示现一切佛神变海智。不可思议。转法轮智。不可思议。建立演说海。不可思议。清净佛身。不可思议。无边色相海普照明。不可思议。相及随好。皆清净。不可思议。无边色相。光明轮海。具足清净。不可思议。种种色相。光明云海。不可思议。殊胜宝焰海。不可思议。成就言音海。不可思议。示现三种自在海。调伏成熟一切众生。不可思议。勇猛调伏诸众生海。无空过者。不可思议。安住佛地。不可思议。入如来境界。不可思议。威力护持。不可思议。观察一切佛智所行。不可思议。诸力圆满。无能摧伏。不可思议。无畏功德。无能过者。不可思议。住无差别三昧。不可思议。神通变化。不可思议。清净自在智。不可思议。一切佛法。无能毁坏。不可思议。如是等一切法。我当承佛神力。及一切如来。威神力故。具足宣说。为令众生。入佛智慧海故。为令一切菩萨。于佛功德海中。得安住故。为令一切世界海。一切佛自在。所庄严故。为令一切劫海中。如来种性。恒不断故。为令于一切世界海中。显示诸法真实性故。为令随一切众生。无量解海。而演说故。为令随一切众生。诸根海方便。令生诸佛法故。为令随一切众生乐欲海。摧破一切障碍山故。为令随一切众生心行海。令净修治出要道故。为令一切菩萨。安住普贤愿海中故。是时普贤菩萨。复欲令无量道场众海。生欢喜故。令于一切法。增长爱乐故。令生广大真实。信解海故。令净治普门法界藏身故。令安立普贤愿海故。令净治入三世平等智眼故。令增长普照一切世间藏。大慧海故。令生陀罗尼力。持一切法轮故。令于一切道场中。尽佛境界。悉开示故。令开阐一切如来法门故。令增长法界。广大甚深。一切智性故。即说颂言

  智慧甚深功德海　　普现十方无量国
  随诸众生所应见　　光明遍照转法轮
  十方刹海叵思议　　佛无量劫皆严净
  为化众生使成熟　　出兴一切诸国土
  佛境甚深难可思　　普示众生令得入
  其心乐小着诸有　　不能通达佛所悟
  若有净信坚固心　　常得亲近善知识
  一切诸佛与其力　　此乃能入如来智
  离诸谄诳心清净　　常乐慈悲性欢喜
  志欲广大深信人　　彼闻此法生欣悦
  安住普贤诸愿地　　修行菩萨清净道
  观察法界如虚空　　此乃能知佛行处
  此诸菩萨获善利　　见佛一切神通力
  修余道者莫能知　　普贤行人方得悟
  众生广大无有边　　如来一切皆护念
  转正法轮靡不至　　毗卢遮那境界力
  一切刹土入我身　　所住诸佛亦复然
  汝应观我诸毛孔　　我今示汝佛境界
  普贤行愿无边际　　我已修行得具足
  普眼境界广大身　　是佛所行应谛听

尔时普贤菩萨摩诃萨。告诸大众言。诸佛子。世界海。有十种事。过去现在未来诸佛。已说。现说。当说。何者为十。所谓世界海起具因缘。世界海所依住。世界海形状。世界海体性。世界海庄严。世界海清净。世界海佛出兴。世界海劫住。世界海劫转变差别世界海无差别门。诸佛子。略说世界海。有此十事。若广说者。与世界海微尘数等。过去现在未来诸佛。已说。现说。当说。诸佛子。略说以十种因缘故。一切世界海。已成现成当成。何者为十。所谓如来神力故。法应如是故。一切众生行业故。一切菩萨。成一切智所得故。一切众生。及诸菩萨。同集善根故。一切菩萨。严净国土愿力故。一切菩萨。成就不退行愿故。一切菩萨。清净胜解自在故。一切如来。善根所流。及一切诸佛成道时。自在势力故。普贤菩萨自在愿力故。诸佛子。是为略说十种因缘。若广说者。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  所说无边众刹海　　毗卢遮那悉严净
  世尊境界不思议　　智慧神通力如是
  菩萨修行诸愿海　　普随众生心所欲
  众生心行广无边　　菩萨国土遍十方
  菩萨趣于一切智　　勤修种种自在力
  无量愿海普出生　　广大刹土皆成就
  修诸行海无有边　　入佛境界亦无量
  为净十方诸国土　　一一土经无量劫
  众生烦恼所扰浊　　分别欲乐非一相
  随心造业不思议　　一切刹海斯成立
  佛子刹海庄严藏　　离垢光明宝所成
  斯由广大信解心　　十方所住咸如是
  菩萨能修普贤行　　游行法界微尘道
  尘中悉现无量刹　　清净广大如虚空
  等虚空界现神通　　悉诣道场诸佛所
  莲华座上示众相　　一一身包一切刹
  一念普现于三世　　一切刹海皆成立
  佛以方便悉入中　　此是毗卢所严净

尔时普贤菩萨。复告大众言。诸佛子。一一世界海。有世界海微尘数所依住。所谓。或依一切庄严住。或依虚空住。或依一切宝光明住。或依一切佛光明住。或依一切宝色光明住。或依一切佛音声住。或依如幻业生。大力阿修罗形。金刚手住。或依一切世主身住。或依一切菩萨身住。或依普贤菩萨愿所生。一切差别庄严海住。诸佛子。世界海。有如是等。世界海微尘数所依住。尔时普贤菩萨。欲重宣其义。承佛威力观察十方。而说颂言

  遍满十方虚空界　　所有一切诸国土
  如来神力之所加　　处处现前皆可见
  或有种种诸国土　　无非离垢宝所成
  清净摩尼最殊妙　　炽然普现光明海
  或有清净光明刹　　依止虚空界而住
  或在摩尼宝海中　　复有安住光明藏
  如来处此众会海　　演说法轮皆巧妙
  诸佛境界广无边　　众生见者心欢喜
  有以摩尼作严饰　　状如华灯广分布
  香焰光云色炽然　　覆以妙宝光明网
  或有刹土无边际　　安住莲华深大海
  广博清净与世殊　　诸佛妙善庄严故
  或有刹海随轮转　　以佛威神得安住
  诸菩萨众遍在中　　常见无央广大宝
  或有住于金刚手　　或复有住天主身
  毗卢遮那无上尊　　常于此处转法轮
  或依宝树平均住　　香焰云中亦复然
  或有依诸大水中　　有住坚固金刚海
  或有依止金刚幢　　或有住于华海中
  广大神通无不周　　毗卢遮那此能现
  或修或短无量种　　其相旋环亦非一
  妙庄严藏与世殊　　清净修治乃能见
  如是种种各差别　　一切皆依愿海住
  或有国土常在空　　诸佛如云悉充遍
  或有在空悬覆住　　或时而有或无有
  或有国土极清净　　住于菩萨宝冠中
  十方诸佛大神通　　一切皆于此中见
  诸佛音声咸遍满　　斯由业力之所化
  或有国土周法界　　清净离垢从心起
  如影如幻广无边　　如因陀网各差别
  或现种种庄严藏　　依止虚空而建立
  诸业境界不思议　　佛力显示皆令见
  一一国土微尘内　　念念示现诸佛刹
  数皆无量等众生　　普贤所作恒如是
  为欲成熟众生故　　是中修行经劫海
  广大神变靡不兴　　法界之中悉周遍
  法界国土一一尘　　诸大刹海住其中
  佛云平等悉弥覆　　于一切处咸充满
  如一尘中自在用　　一切尘内亦复然
  诸佛菩萨大神通　　毗卢遮那悉能现
  一切广大诸刹土　　如影如幻亦如焰
  十方不见所从生　　亦复无来无去处
  灭坏生成互循复　　于虚空中无暂已
  莫不皆由清净愿　　广大业力之所持

尔时普贤菩萨。复告大众言。诸佛子。世界海。有种种差别形相。所谓。或圆或方。或非圆方。无量差别。或如水漩形。或如山焰形。或如树形。或如华形。或如宫殿形。或如众生形。或如佛形。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  诸国土海种种别　　种种庄严种种住
  殊形共美遍十方　　汝等咸应共观察
  其状或圆或有方　　或复三维及八隅
  摩尼轮状莲华等　　一切皆由业令异
  或有清净焰庄严　　真金间错多殊好
  门闼竞开无壅滞　　斯由业广意无杂
  刹海无边差别藏　　譬如云布在虚空
  宝轮布地妙庄严　　诸佛光明照耀中
  一切国土心分别　　种种光明而照现
  佛于如是刹海中　　各各示现神通力
  或有杂染或清净　　受苦受乐各差别
  斯由业海不思议　　诸流转法恒如是
  一毛孔内难思刹　　等微尘数种种主
  一一皆有遍照尊　　在众会中宣妙法
  于一尘中大小刹　　种种差别如尘数
  平坦高下各不同　　佛悉往诣转法轮
  一切尘中所现刹　　皆是本愿神通力
  随其心乐种种殊　　于虚空中悉能作
  一切国土所有尘　　一一尘中佛皆入
  普为众生起神变　　毗卢遮那法如是

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有种种体。所谓。或以一切宝庄严为体。或以一宝种种庄严为体。或以一切宝光明为体。或以种种色光明为体。或以一切庄严光明为体。或以不可坏金刚为体。或以佛力持为体。或以妙宝相为体。或以佛变化为体。或以日摩尼轮为体。或以极微细宝为体。或以一切宝焰为体。或以种种香为体。或以一切宝华冠为体。或以一切宝影像为体。或以一切庄严所示现为体。或以一念心。普示现境界为体。或以菩萨形宝为体。或以宝华蕊为体。或以佛言音为体。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  或有诸刹海　　妙宝所合成
  坚固不可坏　　安住宝莲华
  或是净光明　　出生不可知
  一切光庄严　　依止虚空住
  或净光为体　　复依光明住
  光云作严饰　　菩萨共游处
  或有诸刹海　　从于愿力生
  犹如影像住　　取说不可得
  或以摩尼成　　普放日藏光
  珠轮以严地　　菩萨悉充满
  有刹宝焰成　　焰云覆其上
  众宝光殊妙　　皆由业所得
  或从妙相生　　众相庄严地
  如冠共持戴　　斯由佛化起
  或从心海生　　随心所解住
  如幻无处所　　一切是分别
  或以佛光明　　摩尼光为体
  诸佛于中现　　各起神通力
  或普贤菩萨　　化现诸刹海
  愿力所庄严　　一切皆殊妙

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有种种庄严。所谓。或以一切庄严具中。出上妙云庄严。或以说一切菩萨。功德庄严。或以说一切众生。业报庄严。或以示现一切菩萨。愿海庄严。或以表示一切三世佛。影像庄严。或以一念顷。示现无边劫。神通境界庄严。或以出现一切佛身庄严。或以出现一切宝香云庄严。或以示现一切道场中。诸珍妙物。光明照耀庄严。或以示现一切普贤行愿庄严。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  广大刹海无有边　　皆由清净业所成
  种种庄严种种住　　一切十方皆遍满
  无边色相宝焰云　　广大庄严非一种
  十方刹海常出现　　普演妙音而说法
  菩萨无边功德海　　种种大愿所庄严
  此土俱时出妙音　　普震十方诸刹网
  众生业海广无量　　随其感报各不同
  于一切处庄严中　　皆由诸佛能演说
  三世所有诸如来　　神通普现诸刹海
  一一事中一切佛　　如是严净汝应观
  过去未来现在劫　　十方一切诸国土
  于彼所有大庄严　　一一皆于刹中见
  一切事中无量佛　　数等众生遍世间
  为令调伏起神通　　以此庄严国土海
  一切庄严吐妙云　　种种华云香焰云
  摩尼宝云常出现　　刹海以此为严饰
  十方所有成道处　　种种庄严皆具足
  流光布迥若彩云　　于此刹海咸令见
  普贤愿行诸佛子　　等众生劫勤修习
  无边国土悉庄严　　一切处中皆显现

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有世界海微尘数。清净方便海。所谓。诸菩萨亲近一切善知识。同善根故。增长广大功德云。遍法界故。净修广大诸胜解故。观察一切菩萨境界。而安住故。修治一切诸波罗蜜。悉圆满故。观察一切菩萨诸地。而入住故。出生一切净愿海故。修习一切出要行故。入于一切庄严海故。成就清净方便力故。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  一切刹海诸庄严　　无数方便愿力生
  一切刹海常光耀　　无量清净业力起
  久远亲近善知识　　同修善业皆清净
  慈悲广大遍众生　　以此庄严诸刹海
  一切法门三昧等　　禅定解脱方便地
  于诸佛所悉净治　　以此出生诸刹海
  发生无量决定解　　能解如来等无异
  忍海方便已修治　　故能严净无边刹
  为利众生修胜行　　福德广大常增长
  譬如云布等虚空　　一切刹海皆成就
  诸度无量等刹尘　　悉已修行令具足
  愿波罗蜜无有尽　　清净刹海从此生
  净修无等一切法　　生起无边出要行
  种种方便化群生　　如是庄严国土海
  修习庄严方便地　　入佛功德法门海
  普使众生竭苦源　　广大净刹皆成就
  力海广大无与等　　普使众生种善根
  供养一切诸如来　　国土无边悉清净

尔时普贤菩萨。复告大众言。诸佛子。应知一一世界海。有世界海微尘数佛。出现差别。所谓。或现小身。或现大身。或现短寿。或现长寿。或唯严净一佛国土。或有严净无量佛土。或唯显示一乘法轮。或有显示不可思议。诸乘法轮。或现调伏少分众生。或示调伏无边众生。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  诸佛种种方便门　　出兴一切诸刹海
  皆随众生心所乐　　此是如来善权力
  诸佛法身不思议　　无色无形无影像
  能为众生现众相　　随其心乐悉令见
  或为众生现短寿　　或现住寿无量劫
  法身十方普现前　　随宜出现于世间
  或有严净不思议　　十方所有诸刹海
  或唯严净一国土　　于一示现悉无余
  或随众生心所乐　　示现难思种种乘
  或有唯宣一乘法　　一中方便现无量
  或有自然成正觉　　令少众生住于道
  或有能于一念中　　开悟群迷无有数
  或于毛孔出化云　　示现无量无边佛
  一切世间皆现睹　　种种方便度群生
  或有言音普周遍　　随其心乐而说法
  不可思议大劫中　　调伏无量众生海
  或有无量庄严国　　众会清净俨然坐
  佛如云布在其中　　十方刹海靡不充
  诸佛方便不思议　　随众生心悉现前
  普住种种庄严刹　　一切国土皆周遍

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有世界海微尘数劫住。所谓。或有阿僧祇劫住。或有无量劫住。或有无边劫住。或有无等劫住。或有不可数劫住。或有不可称劫住。或有不可思劫住。或有不可量劫住。或有不可说劫住。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  世界海中种种劫　　广大方便所庄严
  十方国土咸观见　　数量差别悉明了
  我见十方世界海　　劫数无量等众生
  或长或短或无边　　以佛音声今演说
  我见十方诸刹海　　或住国土微尘劫
  或有一劫或无数　　以愿种种各不同
  或有纯净或纯染　　或复染净二俱杂
  愿海安立种种殊　　住于众生心想中
  往昔修行刹尘劫　　获大清净世界海
  诸佛境界具庄严　　永住无边广大劫
  有名种种宝光明　　或名等音焰眼藏
  离尘光明及贤劫　　此清净劫摄一切
  有清净劫一佛兴　　或一劫中无量现
  无尽方便大愿力　　入于一切种种劫
  或无量劫入一劫　　或复一劫入多劫
  一切劫海种种门　　十方国土皆明现
  或一切劫庄严事　　于一劫中皆现睹
  或一劫内所庄严　　普入一切无边劫
  始从一念终成劫　　悉依众生心想生
  一切刹海劫无边　　以一方便皆清净

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有世界海微尘数劫转变差别。所谓。法如是故。世界海。无量成坏劫转变。染污众生住故。世界海。成染污劫转变。修广大福众生住故。世界海。成染净劫转变。信解菩萨住故。世界海。成染净劫转变。无量众生。发菩提心故。世界海。纯清净劫转变。诸菩萨各各游诸世界故。世界海。无边庄严劫转变。十方一切世界海。诸菩萨云集故。世界海。无量大庄严劫转变。诸佛世尊。入涅槃故。世界海。庄严灭劫转变。诸佛出现于世故。一切世界海。广博严净劫转变。如来神通变化故。世界海。普清净劫转变。如是等。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  一切诸国土　　皆随业力生
  汝等应观察　　转变相如是
  染污诸众生　　业惑缠可怖
  彼心令刹海　　一切成染污
  若有清净心　　修诸福德行
  彼心令刹海　　杂染及清净
  信解诸菩萨　　于彼劫中生
  随其心所有　　杂染清净见
  无量诸众生　　悉发菩提心
  彼心令刹海　　住劫恒清净
  无量亿菩萨　　往诣于十方
  庄严无有殊　　劫中差别见
  一一微尘内　　佛刹如尘数
  菩萨共云集　　国土皆清净
  世尊入涅槃　　彼土庄严灭
  众生无法器　　世界成杂染
  若有佛兴世　　一切悉珍好
  随其心清净　　庄严皆具足
  诸佛神通力　　示现不思议
  是时诸刹海　　一切普清净

尔时普贤菩萨。复告大众言。诸佛子。应知世界海。有世界海微尘数无差别。所谓。一一世界海中。有世界海微尘数。世界无差别。一一世界海中。诸佛出现。所有威力无差别。一一世界海中。一切道场遍十方法界无差别。一一世界海中。一切如来。道场众会无差别。一一世界海中。一切佛光明。遍法界无差别。一一世界海中。一切佛变化。名号无差别。一一世界海中。一切佛音声。普遍世界海。无边劫住无差别。一一世界海中。法轮方便无差别。一一世界海中。一切世界海。普入一尘无差别。一一世界海中。一一微尘。一切三世。诸佛世尊。广大境界。皆于中现无差别。诸佛子。世界海无差别。略说如是。若广说者。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛威力。观察十方。而说颂言

  一微尘中多刹海　　处所各别悉严净
  如是无量入一中　　一一区分无杂越
  一一尘内难思佛　　随众生心普现前
  一切刹海靡不周　　如是方便无差别
  一一尘中诸树王　　种种庄严悉垂布
  十方国土皆同现　　如是一切无差别
  一一尘内微尘众　　悉共围绕人中主
  出过一切遍世间　　亦不迫隘相杂乱
  一一尘中无量光　　普遍十方诸国土
  悉现诸佛菩提行　　一切刹海无差别
  一一尘中无量身　　变化如云普周遍
  以佛神通导群品　　十方国土亦无别
  一一尘中说众法　　其法清净如轮转
  种种方便自在门　　一切皆演无差别
  一尘普演诸佛音　　充满法器诸众生
  遍住刹海无央劫　　如是音声亦无异
  刹海无量妙庄严　　于一尘中无不入
  如是诸佛神通力　　一切皆由业性起
  一一尘中三世佛　　随其所乐悉令见
  体性无来亦无去　　以愿力故遍世间

大方广佛华严经卷第七大方广佛华严经卷第八

        于阗国三藏实叉难陀奉　制译

    华藏世界品第五之一

尔时普贤菩萨。复告大众言诸佛子此华藏庄严世界海。是毗卢遮那如来。往昔于世界海微尘数劫修菩萨行时。一一劫中。亲近世界海微尘数佛。一一佛所。净修世界海微尘数。大愿之所严净。诸佛子。此华藏庄严世界海。有须弥山。微尘数风轮所持其最下风轮。名平等住。能持其上。一切宝焰。炽然庄严。次上风轮。名出生种种宝庄严。能持其上。净光照耀。摩尼王幢。次上风轮。名宝威德。能持其上。一切宝铃。次上风轮。名平等焰。能持其上。日光明相。摩尼王轮。次上风轮。名种种普庄严。能持其上。光明轮华。次上风轮。名普清净。能持其上。一切华焰师子座。次上风轮。名声遍十方。能持其上。一切珠王幢。次上风轮。名一切宝光明。能持其上。一切摩尼王树华。次上风轮。名速疾普持。能持其上。一切香摩尼须弥云。次上风轮。名种种宫殿游行。能持其上。一切宝色香台云。诸佛子。彼须弥山微尘数风轮。最在上者。名殊胜威光藏。能持普光摩尼。庄严香水海。此香水海。有大莲华。名种种光明蕊香幢。华藏庄严世界海。住在其中。四方均平。清净坚固。金刚轮山。周匝围绕。地海众树。各有区别。是时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  世尊往昔于诸有　　微尘佛所修净业
  故获种种宝光明　　华藏庄严世界海
  广大悲云遍一切　　舍身无量等刹尘
  以昔劫海修行力　　今此世界无诸垢
  放大光明遍住空　　风力所持无动摇
  佛藏摩尼普严饰　　如来愿力令清净
  普散摩尼妙藏华　　以昔愿力空中住
  种种坚固庄严海　　光云垂布满十方
  诸摩尼中菩萨云　　普诣十方光炽然
  光焰成轮妙华饰　　法界周流靡不遍
  一切宝中放净光　　其光普照众生海
  十方国土皆周遍　　咸令出苦向菩提
  宝中佛数等众生　　从其毛孔出化形
  梵主帝释轮王等　　一切众生及诸佛
  化现光明等法界　　光中演说诸佛名
  种种方便示调伏　　普应群心无不尽
  华藏世界所有尘　　一一尘中见法界
  宝光现佛如云集　　此是如来刹自在
  广大愿云周法界　　于一切劫化群生
  普贤智地行悉成　　所有庄严从此出

尔时普贤菩萨。复告大众言。诸佛子。此华藏庄严世界海。大轮围山。住日珠王莲华之上。栴檀摩尼。以为其身。威德宝王。以为其峰。妙香摩尼。而作其轮。焰藏金刚。所共成立。一切香水。流注其间。众宝为林。妙华开敷。香草布地。明珠间饰。种种香华。处处盈满。摩尼为网。周匝垂覆。如是等。有世界海微尘数。众妙庄严。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  世界大海无有边　　宝轮清净种种色
  所有庄严尽奇妙　　此由如来神力起
  摩尼宝轮妙香轮　　及以真珠灯焰轮
  种种妙宝为严饰　　清净轮围所安住
  坚固摩尼以为藏　　阎浮檀金作严饰
  舒光发焰遍十方　　内外映彻皆清净
  金刚摩尼所集成　　复雨摩尼诸妙宝
  其宝精奇非一种　　放净光明普严丽
  香水分流无量色　　散诸华宝及栴檀
  众莲竞发如衣布　　珍草罗生悉芬馥
  无量宝树普庄严　　开华发蕊色炽然
  种种名衣在其内　　光云四照常圆满
  无量无边大菩萨　　执盖焚香充法界
  悉发一切妙音声　　普转如来正法轮
  诸摩尼树宝末成　　一一宝末现光明
  毗卢遮那清净身　　悉入其中普令见
  诸庄严中现佛身　　无边色相无央数
  悉往十方无不遍　　所化众生亦无限
  一切庄严出妙音　　演说如来本愿轮
  十方所有净刹海　　佛自在力咸令遍

尔时普贤菩萨。复告大众言。诸佛子。此世界海。大轮围山内。所有大地。一切皆以金刚所成。坚固庄严。不可沮坏。清净平坦。无有高下。摩尼为轮。众宝为藏。一切众生。种种形状。诸摩尼宝。以为间错。散众宝末。布以莲华。香藏摩尼。分置其间。诸庄严具。充遍如云。三世一切。诸佛国土。所有庄严。而为校饰。摩尼妙宝。以为其网。普现如来。所有境界。如天帝网。于中布列。诸佛子。此世界海地。有如是等。世界海微尘数庄严。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  其地平坦极清净　　安住坚固无能坏
  摩尼处处以为严　　众宝于中相间错
  金刚为地甚可悦　　宝轮宝网具庄严
  莲华布上皆圆满　　妙衣弥覆悉周遍
  菩萨天冠宝璎珞　　悉布其地为严好
  栴檀摩尼普散中　　咸舒离垢妙光明
  宝华发焰出妙光　　光焰如云照一切
  散此妙华及众宝　　普覆于地为严饰
  密云兴布满十方　　广大光明无有尽
  普至十方一切土　　演说如来甘露法
  一切佛愿摩尼内　　普现无边广大劫
  最胜智者昔所行　　于此宝中无不见
  其地所有摩尼宝　　一切佛刹咸来入
  彼诸佛刹一一尘　　一切国土亦入中
  妙宝庄严华藏界　　菩萨游行遍十方
  演说大士诸弘愿　　此是道场自在力
  摩尼妙宝庄严地　　放净光明备众饰
  充满法界等虚空　　佛力自然如是现
  诸有修治普贤愿　　入佛境界大智人
  能知于此刹海中　　如是一切诸神变

尔时普贤菩萨。复告大众言。诸佛子。此世界海大地中。有不可说。佛刹微尘数香水海。一切妙宝。庄严其底。妙香摩尼。庄严其岸。毗卢遮那。摩尼宝王。以为其网。香水映彻。具众宝色。充满其中。种种宝华。旋布其上。栴檀细末。澄垽其下。演佛言音。放宝光明。无边菩萨。持种种盖。现神通力。一切世界。所有庄严。悉于中现。十宝阶陛。行列分布。十宝栏楯。周匝围绕。四天下微尘数。一切宝庄严。芬陀利华。敷荣水中。不可说百千亿。那由他数。十宝尸罗幢。恒河沙数。一切宝衣铃网幢。恒河沙数。无边色相。宝华楼阁。百千亿那由他数。十宝莲华城。四天下微尘数。众宝树林。宝焰摩尼。以为其网。恒河沙数栴檀香。诸佛言音。光焰摩尼。不可说百千亿。那由他数。众宝垣墙。悉共围绕。周遍严饰。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  此世界中大地上　　有香水海摩尼严
  清净妙宝布其底　　安住金刚不可坏
  香藏摩尼积成岸　　日焰珠轮布若云
  莲华妙宝为璎珞　　处处庄严净无垢
  香水澄渟具众色　　宝华旋布放光明
  普震音声闻远近　　以佛威神演妙法
  阶陛庄严具众宝　　复以摩尼为间饰
  周回栏楯悉宝成　　莲华珠网如云布
  摩尼宝树列成行　　华蕊敷荣光赫奕
  种种乐音恒竞奏　　佛神通力令如是
  种种妙宝芬陀利　　敷布庄严香水海
  香焰光明无暂停　　广大圆满皆充遍
  明珠宝幢恒炽盛　　妙衣垂布为严饰
  摩尼铃网演法音　　令其闻者趣佛智
  妙宝莲华作城廓　　众彩摩尼所严莹
  真珠云影布四隅　　如是庄严香水海
  垣墙缭绕皆周匝　　楼阁相望布其上
  无量光明恒炽然　　种种庄严清净海
  毗卢遮那于往昔　　种种刹海皆严净
  如是广大无有边　　悉是如来自在力

尔时普贤菩萨。复告大众言。诸佛子。一一香水海。各有四天下。微尘数香水河。右旋围绕。一切皆以金刚为岸。净光摩尼。以为严饰。常现诸佛。宝色光云。及诸众生。所有言音。其河所有。漩澓之处。一切诸佛。所修因行。种种形相。皆从中出。摩尼为网。众宝铃铎。诸世界海。所有庄严。悉于中现。摩尼宝云。以覆其上。其云普现华藏世界。毗卢遮那。十方化佛。及一切佛。神通之事。复出妙音。称扬三世。佛菩萨名。其香水中。常出一切宝焰光云。相续不绝若广说者。一一河各有世界海。微尘数庄严。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  清净香流满大河　　金刚妙宝为其岸
  宝末为轮布其地　　种种严饰皆珍好
  宝阶行列妙庄严　　栏楯周回悉殊丽
  真珠为藏众华饰　　种种缨鬘共垂下
  香水宝光清净色　　恒吐摩尼竞疾流
  众华随浪皆摇动　　悉奏乐音宣妙法
  细末栴檀作泥垽　　一切妙宝同洄澓
  香藏氛氲布在中　　发焰流芬普周遍
  河中出生诸妙宝　　悉放光明色炽然
  其光布影成台座　　华盖珠璎皆具足
  摩尼王中现佛身　　光明普照十方刹
  以此为轮严饰地　　香水映彻常盈满
  摩尼为网金为铎　　遍覆香河演佛音
  克宣一切菩提道　　及以普贤之妙行
  宝岸摩尼极清净　　恒出如来本愿音
  一切诸佛曩所行　　其音普演皆令见
  其河所有漩流处　　菩萨如云常踊出
  悉往广大刹土中　　乃至法界咸充满
  清净珠王布若云　　一切香河悉弥覆
  其珠等佛眉间相　　炳然显现诸佛影

尔时普贤菩萨。复告大众言。诸佛子。此诸香水河。两间之地。悉以妙宝。种种庄严。一一各有四天下。微尘数众宝庄严。芬陀利华。周匝遍满。各有四天下微尘数。众宝树林。次第行列。一一树中。恒出一切诸庄严云。摩尼宝王。照耀其间。种种华香。处处盈满。其树复出微妙音声。说诸如来。一切劫中。所修大愿。复散种种摩尼宝王。充遍其地。所谓。莲华轮摩尼宝王。香焰光云。摩尼宝王。种种严饰。摩尼宝王。现不可思议。庄严色摩尼宝王。日光明衣藏。摩尼宝王。周遍十方。普垂布光网云。摩尼宝王现一切诸佛神变。摩尼宝王。现一切众生业报海。摩尼宝王。如是等。有世界海微尘数。其香水河。两间之地。一切悉具如是庄严。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  其地平坦极清净　　真金摩尼共严饰
  诸树行列荫其中　　耸干垂条华若云
  枝条妙宝所庄严　　华焰成轮光四照
  摩尼为果如云布　　普使十方常现睹
  摩尼布地皆充满　　众华宝末共庄严
  复以摩尼作宫殿　　悉现众生诸影像
  诸佛影像摩尼王　　普散其地靡不周
  如是赫奕遍十方　　一一尘中咸见佛
  妙宝庄严善分布　　真珠灯网相间错
  处处悉有摩尼轮　　一一皆现佛神通
  众宝庄严放大光　　光中普现诸化佛
  一一周行靡不遍　　悉以十力广开演
  摩尼妙宝芬陀利　　一切水中咸遍满
  其华种种各不同　　悉现光明无尽歇
  三世所有诸庄严　　摩尼果中皆显现
  体性无生不可取　　此是如来自在力
  此地一切庄严中　　悉现如来广大身
  彼亦不来亦不去　　佛昔愿力皆令见
  此地一一微尘中　　一切佛子修行道
  各见所记当来刹　　随其意乐悉清净

尔时普贤菩萨。复告大众言。诸佛子。诸佛世尊世界海。庄严不可思议。何以故。诸佛子。此华藏庄严世界海。一切境界。一一皆以世界海微尘数。清净功德之所庄严。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  此刹海中一切处　　悉以众宝为严饰
  发焰腾空布若云　　光明洞彻常弥覆
  摩尼吐云无有尽　　十方佛影于中现
  神通变化靡暂停　　一切菩萨咸来集
  一切摩尼演佛音　　其音美妙不思议
  毗卢遮那昔所行　　于此宝内恒闻见
  清净光明遍照尊　　庄严具中皆现影
  变化分身众围绕　　一切刹海咸周遍
  所有化佛皆如幻　　求其来处不可得
  以佛境界威神力　　一切刹中如是现
  如来自在神通事　　悉遍十方诸国土
  以此刹海净庄严　　一切皆于宝中见
  十方所有诸变化　　一切皆如镜中像
  但由如来昔所行　　神通愿力而出生
  若有能修普贤行　　入于菩萨胜智海
  能于一切微尘中　　普现其身净众刹
  不可思议亿大劫　　亲近一切诸如来
  如其一切之所行　　一刹那中悉能现
  诸佛国土如虚空　　无等无生无有相
  为利众生普严净　　本愿力故住其中

尔时普贤菩萨。复告大众言。诸佛子。此中有何等世界住。我今当说。诸佛子。此不可说。佛刹微尘数。香水海中。有不可说。佛刹微尘数。世界种安住。一一世界种。复有不可说。佛刹微尘数世界。诸佛子。彼诸世界种。于世界海中。各各依住。各各形状。各各体性。各各方所。各各趣入。各各庄严。各各分齐。各各行列。各各无差别。各各力加持。诸佛子。此世界种。或有依大莲华海住。或有依无边色。宝华海住。或有依一切真珠藏宝。璎珞海住。或有依香水海住。或有依一切华海住。或有依摩尼宝网海住。或有依漩流光海住。或有依菩萨。宝庄严冠海住。或有依种种众生身海住。或有依一切佛音声。摩尼王海住。如是等。若广说者。有世界海微尘数。诸佛子。彼一切世界种。或有作须弥山形。或作江河形。或作回转形。或作漩流形。或作轮辋形。或作坛墠形。或作树林形。或作楼阁形。或作山幢形。或作普方形。或作胎藏形。或作莲华形。或作佉勒迦形。或作众生身形。或作云形。或作诸佛相好形。或作圆满光明形。或作种种珠网形。或作一切门闼形。或作诸庄严具形。如是等。若广说者。有世界海微尘数。诸佛子。彼一切世界种。或有以十方摩尼云为体。或有以众色焰为体。或有以诸光明为体。或有以宝香焰为体。或有以一切宝庄严。多罗华为体。或有以菩萨影像为体。或有以诸佛光明为体。或有以佛色相为体。或有以一宝光为体。或有以众宝光为体。或有以一切众生。福德海音声为体。或有以一切众生。诸业海音声为体。或有以一切佛境界。清净音声为体。或有以一切菩萨。大愿海音声为体。或有以一切佛。方便音声为体。或有以一切刹庄严具。成坏音声为体。或有以无边佛音声为体。或有以一切佛。变化音声为体。或有以一切众生。善音声为体。或有以一切佛功德海。清净音声为体。如是等。若广说者。有世界海微尘数。尔时普贤菩萨。欲重宣其义。承佛神力。观察十方。而说颂言

  刹种坚固妙庄严　　广大清净光明藏
  依止莲华宝海住　　或有住于香海等
  须弥城树坛墠形　　一切刹种遍十方
  种种庄严形相别　　各各布列而安住
  或有体是净光明　　或是华藏及宝云
  或有刹种焰所成　　安住摩尼不坏藏
  灯云焰彩光明等　　种种无边清净色
  或有言音以为体　　是佛所演不思议
  或是愿力所出音　　神变音声为体性
  一切众生大福业　　佛功德音亦如是
  刹种一一差别门　　不可思议无有尽
  如是十方皆遍满　　广大庄严现神力
  十方所有广大刹　　悉来入此世界种
  虽见十方普入中　　而实无来无所入
  以一刹种入一切　　一切入一亦无余
  体相如本无差别　　无等无量悉周遍
  一切国土微尘中　　普见如来在其所
  愿海言音若雷震　　一切众生悉调伏
  佛身周遍一切刹　　无数菩萨亦充满
  如来自在无等伦　　普化一切诸含识

尔时普贤菩萨。复告大众言。诸佛子。此不可说。佛刹微尘数香水海。在华藏庄严。世界海中。如天帝网。分布而住。诸佛子。此最中央香水海。名无边妙华光。以现一切菩萨形。摩尼王幢为底。出大莲华。名一切香。摩尼王庄严。有世界种。而住其上。名普照十方。炽然宝光明。以一切庄严具为体。有不可说佛刹。微尘数世界。于中布列。其最下方有世界。名最胜光遍照。以一切金刚庄严。光耀轮为际。依众宝摩尼华而住。其状犹如摩尼宝形。一切宝华庄严云。弥覆其上。佛刹微尘数世界。周匝围绕。种种安住。种种庄严。佛号净眼离垢灯。此上过佛刹。微尘数世界。有世界。名种种香。莲华妙庄严。以一切庄严具为际。依宝莲华网而住。其状犹如师子之座。一切宝色珠帐云。弥覆其上。二佛刹微尘数世界。周匝围绕。佛号师子光胜照。此上过佛刹。微尘数世界。有世界。名一切宝庄严普照光。以香风轮为际。依种种宝华璎珞住。其形八隅。妙光摩尼日轮云。而覆其上。三佛刹微尘数世界。周匝围绕。佛号净光智胜幢。此上过佛刹。微尘数世界。有世界。名种种光明华庄严。以一切宝王为际。依众色金刚。尸罗幢海住。其状犹如摩尼莲华。以金刚摩尼宝光云。而覆其上。四佛刹微尘数世界。周匝围绕纯一清净。佛号金刚光明无量精进力善出现。此上过佛刹。微尘数世界。有世界。名普放妙华光。以一切宝铃。庄严网为际。依一切树林庄严。宝轮网海住。其形普方。而多有隅角。梵音摩尼王云。以覆其上。五佛刹微尘数世界。周匝围绕。佛号香光喜力海。此上过佛刹。微尘数世界。有世界。名净妙光明。以宝王庄严幢为际。依金刚宫殿海住。其形四方。摩尼轮髻帐云。而覆其上。六佛刹微尘数世界。周匝围绕。佛号普光自在幢。此上过佛刹。微尘数世界。有世界。名众华焰庄严。以种种华庄严为际。依一切宝色焰海住。其状犹如楼阁之形。一切宝色衣。真珠栏楯云。而覆其上。七佛刹微尘数世界。周匝围绕。纯一清净。佛号欢喜海功德名称自在光。此上过佛刹。微尘数世界。有世界。名出生威力地。以出一切声。摩尼王庄严为际。依种种宝色。莲华座虚空海住。其状犹如因陀罗网。以无边色华网云。而覆其上。八佛刹微尘数世界。周匝围绕。佛号广大名称智海幢。此上过佛刹。微尘数世界。有世界。名出妙音声。以心王摩尼。庄严轮为际。依恒出一切。妙音声庄严云。摩尼王海住。其状犹如梵天身形。无量宝庄严。师子座云。而覆其上。九佛刹微尘数世界。周匝围绕。佛号清净月光明相无能摧伏。此上过佛刹。微尘数世界。有世界。名金刚幢。以无边庄严。真珠藏宝。璎珞为际。依一切庄严。宝师子座。摩尼海住。其状周圆。十须弥山。微尘数。一切香摩尼华。须弥云。弥覆其上。十佛刹微尘数世界。周匝围绕。纯一清净。佛号一切法海最胜王。此上过佛刹。微尘数世界。有世界。名恒出现帝青宝光明。以极坚牢。不可坏金刚。庄严为际。依种种殊异华海住。其状犹如半月之形。诸天宝帐云。而覆其上。十一佛刹微尘数世界。周匝围绕。佛号无量功德法。此上过佛刹。微尘数世界。有世界。名光明照耀。以普光庄严为际。依华旋香水海住。状如华旋。种种衣云。而覆其上。十二佛刹微尘数世界。周匝围绕。佛号超释梵。此上过佛刹。微尘数世界。至此世界。名娑婆。以金刚庄严为际。依种种色。风轮所持。莲华网住。状如虚空。以普圆满天宫殿。庄严虚空而覆其上。十三佛刹微尘数世界。周匝围绕。其佛即是毗卢遮那如来世尊。此上过佛刹。微尘数世界。有世界。名寂静离尘光。以一切宝庄严为际。依种种宝衣海住。其状犹如执金刚形。无边色金刚云。而覆其上。十四佛刹微尘数世界。周匝围绕。佛号遍法界胜音。此上过佛刹。微尘数世界。有世界。名众妙光明灯。以一切庄严帐为际。依净华网海住。其状犹如卍字之形。摩尼树香水海云。而覆其上。十五佛刹微尘数世界。周匝围绕。纯一清净。佛号不可摧伏力普照幢。此上过佛刹。微尘数世界。有世界。名清净光遍照。以无尽宝云。摩尼王为际。依种种香焰莲华海住。其状犹如龟甲之形。圆光摩尼轮栴檀云。而覆其上。十六佛刹微尘数世界。周匝围绕。佛号清净日功德眼。此上过佛刹。微尘数世界。有世界。名宝庄严藏。以一切众生形。摩尼王为际。依光明藏。摩尼王海住。其形八隅。以一切轮围山。宝庄严华树网。弥覆其上。十七佛刹微尘数世界。周匝围绕。佛号无碍智光明遍照十方。此上过佛刹。微尘数世界。有世界。名离尘。以一切殊妙相。庄严为际。依众妙华。师子座海住。状如珠璎。以一切宝香。摩尼王圆光云。而覆其上。十八佛刹微尘数世界。周匝围绕。纯一清净。佛号无量方便最胜幢。此上过佛刹。微尘数世界。有世界。名清净光普照。以出无尽宝云。摩尼王为际。依无量色香焰。须弥山海住。其状犹如宝华旋布。以无边色光明。摩尼王帝青云。而覆其上。十九佛刹微尘数世界。周匝围绕。佛号普照法界虚空光。此上过佛刹。微尘数世界。有世界。名妙宝焰。以普光明。日月宝为际。依一切诸天形。摩尼王海住。其状犹如宝庄严具。以一切宝衣幢云。及摩尼灯藏网。而覆其上。二十佛刹微尘数世界。周匝围绕。纯一清净。佛号福德相光明。诸佛子。此遍照十方炽然宝光明世界种。有如是等。不可说。佛刹微尘数。广大世界。各各所依住。各各形状。各各体性。各各方面。各各趣入。各各庄严。各各分齐。各各行列。各各无差别。各各力加持周匝围绕。所谓。十佛刹微尘数。回转形世界。十佛刹微尘数。江河形世界。十佛刹微尘数。漩流形世界。十佛刹微尘数。轮辋形世界。十佛刹微尘数。坛墠形世界。十佛刹微尘数。树林形世界。十佛刹微尘数。楼观形世界。十佛刹微尘数。尸罗幢形世界。十佛刹微尘数。普方形世界。十佛刹微尘数。胎藏形世界。十佛刹微尘数。莲华形世界。十佛刹微尘数。佉勒迦形世界。十佛刹微尘数。种种众生形世界。十佛刹微尘数。佛相形世界。十佛刹微尘数。圆光形世界。十佛刹微尘数。云形世界。十佛刹微尘数。网形世界。十佛刹微尘数。门闼形世界。如是等有不可说。佛刹微尘数。此一一世界。各有十佛刹微尘数。广大世界。周匝围绕。此诸世界。一一复有如上所说微尘数世界。而为眷属。如是所说。一切世界。皆在此无边妙华光。香水海。及围绕此海。香水河中

大方广佛华严经卷第八大方广佛华严经卷第九

        于阗国三藏实叉难陀奉　制译

    华藏世界品第五之二

尔时普贤菩萨。复告大众言。诸佛子。此无边妙华光。香水海东。次有香水海。名离垢焰藏。出大莲华。名一切香。摩尼王妙庄严。有世界种而住其上。名遍照刹旋。以菩萨行吼音为体。此中最下方。有世界。名宫殿庄严幢。其形四方。依一切宝。庄严海住。莲华光网云。弥覆其上。佛刹微尘数。世界围绕。纯一清净。佛号眉间光遍照。此上过佛刹。微尘数世界。有世界。名德华藏。其形周圆。依一切宝。华蕊海住。真珠幢。师子座云。弥覆其上。二佛刹微尘数。世界围绕。佛号一切无边法海慧。此上过佛刹。微尘数世界。有世界。名善变化妙香轮。形如金刚依一切宝。庄严铃网海住。种种庄严圆光云。弥覆其上。三佛刹微尘数。世界围绕。佛号功德相光明普照。此上过佛刹。微尘数世界。有世界。名妙色光明。其状犹如摩尼宝轮。依无边色宝。香水海住。普光明真珠。楼阁云。弥覆其上。四佛刹微尘数。世界围绕纯一清净。佛号善眷属出兴遍照。此上过佛刹。微尘数世界。有世界。名善盖覆。状如莲华。依金刚香水海住。离尘光明香水云。弥覆其上。五佛刹微尘数。世界围绕。佛号法喜无尽慧。此上过佛刹。微尘数世界。有世界。名尸利华光轮。其形三角。依一切坚固。宝庄严海住。菩萨摩尼冠光明云。弥覆其上。六佛刹微尘数。世界围绕。佛号清净普光明云。此上过佛刹。微尘数世界。有世界。名宝莲华庄严。形如半月。依一切莲华。庄严海住。一切宝华云。弥覆其上。七佛刹微尘数。世界围绕。纯一清净。佛号功德华清净眼。此上过佛刹。微尘数世界。有世界。名无垢焰庄严。其状犹如宝灯行列。依宝焰藏海住。常雨香水。种种身云。弥覆其上。八佛刹微尘数。世界围绕。佛号慧力无能胜。此上过佛刹。微尘数世界。有世界。名妙梵音。形如卍字。依宝衣幢海住。一切华庄严帐云。弥覆其上。九佛刹微尘数。世界围绕。佛号广大目如空中净月。此上过佛刹。微尘数世界。有世界。名微尘数音声。其状犹如因陀罗网。依一切宝水海住。一切乐音宝盖云。弥覆其上。十佛刹微尘数。世界围绕。纯一清净。佛号金色须弥灯。此上过佛刹。微尘数世界。有世界。名宝色庄严。形如卍字。依帝释形。宝王海住。日光明华云。弥覆其上。十一佛刹微尘数。世界围绕。佛号回照法界光明智。此上过佛刹。微尘数世界。有世界。名金色妙光。其状犹如广大城廓。依一切宝。庄严海住。道场宝华云。弥覆其上。十二佛刹微尘数。世界围绕。佛号宝灯普照幢。此上过佛刹。微尘数世界。有世界。名遍照光明轮。状如华旋。依宝衣旋海住。佛音声宝王楼阁云。弥覆其上。十三佛刹微尘数。世界围绕。纯一清净。佛号莲华焰遍照。此上过佛刹。微尘数世界。有世界。名宝藏庄严。状如四洲。依宝璎珞须弥住。宝焰摩尼云弥覆其上。十四佛刹微尘数。世界围绕。佛号无尽福开敷华。此上过佛刹。微尘数世界。有世界。名如镜像普现。其状犹如阿修罗身。依金刚莲华海住。宝冠光影云。弥覆其上。十五佛刹微尘数。世界围绕。佛号甘露音。此上过佛刹。微尘数世界。有世界。名栴檀月。其形八隅。依金刚栴檀宝海住。真珠华摩尼云。弥覆其上。十六佛刹微尘数。世界围绕。纯一清净。佛号最胜法无等智。此上过佛刹。微尘数世界。有世界。名离垢光明。其状犹如香水漩流。依无边色宝光海住。妙香光明云。弥覆其上。十七佛刹微尘数。世界围绕。佛号遍照虚空光明音。此上过佛刹。微尘数世界。有世界。名妙华庄严。其状犹如旋绕之形。依一切华海住。一切乐音摩尼云。弥覆其上。十八佛刹微尘数。世界围绕。佛号普现胜光明。此上过佛刹。微尘数世界。有世界。名胜音庄严。其状犹如师子之座。依金师子座海住。众色莲华藏。师子座云。弥覆其上。十九佛刹微尘数。世界围绕。佛号无边功德称普光明。此上过佛刹。微尘数世界。有世界。名高胜灯。状如佛掌。依宝衣服香幢海住。日轮普照。宝王楼阁云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号普照虚空灯

诸佛子。此离垢焰藏。香水海南。次有香水海。名无尽光明轮。世界种。名佛幢庄严。以一切佛功德海。音声为体。此中最下方。有世界。名爱见华。状如宝轮。依摩尼树藏宝王海住。化现菩萨形宝藏云。弥覆其上。佛刹微尘数。世界围绕。纯一清净。佛号莲华光欢喜面。此上过佛刹。微尘数世界。有世界。名妙音。佛号须弥宝灯。此上过佛刹。微尘数世界。有世界。名众宝庄严光。佛号法界音声幢。此上过佛刹。微尘数世界。有世界。名香藏金刚。佛号光明音。此上过佛刹。微尘数世界。有世界。名净妙音。佛号最胜精进力。此上过佛刹。微尘数世界。有世界。名宝莲华庄严。佛号法城云雷音。此上过佛刹。微尘数世界。有世界。名与安乐。佛号大名称智慧灯。此上过佛刹。微尘数世界。有世界。名无垢网。佛号师子光功德海。此上过佛刹。微尘数世界。有世界。名华林幢遍照。佛号大智莲华光。此上过佛刹。微尘数世界。有世界。名无量庄严。佛号普眼法界幢。此上过佛刹。微尘数世界。有世界。名普光宝庄严。佛号胜智大商主。此上过佛刹。微尘数世界。有世界。名华王。佛号月光幢。此上过佛刹。微尘数世界。有世界。名离垢藏。佛号清净觉。此上过佛刹。微尘数世界。有世界。名宝光明。佛号一切智虚空灯。此上过佛刹。微尘数世界。有世界。名出生宝璎珞。佛号诸度福海相光明。此上过佛刹。微尘数世界。有世界。名妙轮遍覆。佛号调伏一切染着心令欢喜。此上过佛刹。微尘数世界。有世界。名宝华幢。佛号广博功德音大名称。此上过佛刹。微尘数世界。有世界。名无量庄严。佛号平等智光明功德海。此上过佛刹。微尘数世界。有世界。名无尽光庄严幢。状如莲华。依一切宝网海住。莲华光摩尼网。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号法界净光明诸佛子。此无尽光明轮。香水海右旋。次有香水海。名金刚宝焰光。世界种。名佛光庄严藏。以称说一切如来名音声为体。此中最下方。有世界。名宝焰莲华。其状犹如摩尼色。眉间毫相。依一切宝色。水漩海住。一切庄严楼阁云。弥覆其上。佛刹微尘数。世界围绕。纯一清净。佛号无垢宝光明。此上过佛刹。微尘数世界。有世界。名光焰藏。佛号无碍自在智慧光。此上过佛刹。微尘数世界。有世界。名宝轮妙庄严。佛号一切宝光明。此上过佛刹。微尘数世界。有世界。名栴檀树华幢。佛号清净智光明。此上过佛刹。微尘数世界。有世界。名佛刹妙庄严。佛号广大欢喜音。此上过佛刹。微尘数世界。有世界。名妙光庄严。佛号法界自在智。此上过佛刹。微尘数世界。有世界。名无边相。佛号无碍智。此上过佛刹。微尘数世界。有世界。名焰云幢。佛号演说不退轮。此上过佛刹。微尘数世界。有世界。名众宝庄严清净轮。佛号离垢华光明。此上过佛刹。微尘数世界。有世界。名广大出离。佛号无碍智日眼。此上过佛刹。微尘数世界。有世界。名妙庄严金刚座佛号法界智大光明。此上过佛刹。微尘数世界。有世界。名智慧普庄严。佛号智炬光明王。此上过佛刹。微尘数世界。有世界。名莲华池深妙音。佛号一切智普照。此上过佛刹。微尘数世界。有世界。名种种色光明。佛号普光华王云。此上过佛刹。微尘数世界。有世界。名妙宝幢。佛号功德光。此上过佛刹。微尘数世界。有世界。名摩尼华毫相光。佛号普音云。此上过佛刹。微尘数世界。有世界。名甚深海。佛号十方众生主。此上过佛刹微尘数世界。有世界。名须弥光。佛号法界普智音。此上过佛刹。微尘数世界。有世界。名金莲华。佛号福德藏普光明。此上过佛刹。微尘数世界。有世界。名宝庄严藏。形如卍字。依一切香。摩尼庄严树海住。清净光明云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号大变化光明网

诸佛子。此金刚宝焰。香水海右旋。次有香水海。名帝青宝庄严。世界种。名光照十方。依一切妙庄严。莲华香云住。无边佛音声为体。于此最下方。有世界。名十方无尽色藏轮。其状周回。有无量角。依无边色一切宝藏海住。因陀罗网。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号莲华眼光明遍照。此上过佛刹。微尘数世界。有世界。名净妙庄严藏。佛号无上慧大师子。此上过佛刹。微尘数世界。有世界。名出现莲华座。佛号遍照法界光明王。此上过佛刹。微尘数世界。有世界。名宝幢音。佛号大功德普名称。此上过佛刹。微尘数世界。有世界。名金刚宝庄严藏。佛号莲华日光明。此上过佛刹。微尘数世界。有世界。名因陀罗华月。佛号法自在智慧幢。此上过佛刹。微尘数世界。有世界。名妙轮藏。佛号大喜清净音。此上过佛刹。微尘数世界。有世界。名妙音藏。佛号大力善商主。此上过佛刹。微尘数世界。有世界。名清净月。佛号须弥光智慧力。此上过佛刹。微尘数世界。有世界。名无边庄严相。佛号方便愿净月光。此上过佛刹。微尘数世界。有世界。名妙华音。佛号法海大愿音。此上过佛刹。微尘数世界。有世界。名一切宝庄严。佛号功德宝光明相。此上过佛刹。微尘数世界。有世界。名坚固地。佛号美音最胜天。此上过佛刹。微尘数世界。有世界。名普光善化。佛号大精进寂静慧。此上过佛刹。微尘数世界。有世界。名善守护庄严行。佛号见者生欢喜。此上过佛刹。微尘数世界。有世界。名栴檀宝华藏。佛号甚深不可动智慧光遍照。此上过佛刹。微尘数世界。有世界。名现种种色相海。佛号普放不思议胜义王光明。此上过佛刹。微尘数世界。有世界。名化现十方大光明。佛号胜功德威光无与等。此上过佛刹。微尘数世界。有世界。名须弥云幢。佛号极净光明眼。此上过佛刹。微尘数世界。有世界。名莲华遍照。其状周圆。依无边色。众妙香。摩尼海住。一切乘庄严云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号解脱精进日

诸佛子。此帝青宝庄严。香水海右旋。次有香水海。名金刚轮庄严底。世界种。名妙宝间错因陀罗网。普贤智所生。音声为体。此中最下方。有世界。名莲华网。其状犹如须弥山形。依众妙华。山幢海住。佛境界摩尼王帝网云。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号法身普觉慧。此上过佛刹。微尘数世界。有世界。名无尽日光明。佛号最胜大觉慧。此上过佛刹。微尘数世界。有世界。名普放妙光明。佛号大福云无尽力。此上过佛刹。微尘数世界。有世界。名树华幢。佛号无边智法界音。此上过佛刹。微尘数世界。有世界。名真珠盖。佛号波罗蜜师子频申。此上过佛刹。微尘数世界。有世界。名无边音。佛号一切智妙觉慧。此上过佛刹。微尘数世界。有世界。名普见树峰。佛号普现众生前。此上过佛刹。微尘数世界。有世界。名师子帝网光。佛号无垢日金色光焰云。此上过佛刹。微尘数世界。有世界。名众宝间错。佛号帝幢最胜慧。此上过佛刹。微尘数世界。有世界。名无垢光明地。佛号一切力清净月。此上过佛刹。微尘数世界。有世界。名恒出叹佛功德音。佛号如虚空普觉慧。此上过佛刹。微尘数世界。有世界。名高焰藏。佛号化现十方大云幢。此上过佛刹。微尘数世界。有世界。名光严道场。佛号无等智遍照。此上过佛刹。微尘数世界。有世界。名出生一切宝庄严。佛号广度众生神通王。此上过佛刹。微尘数世界。有世界。名光严妙宫殿。佛号一切义成广大慧。此上过佛刹。微尘数世界。有世界。名离尘寂静。佛号不唐现。此上过佛刹。微尘数世界。有世界。名摩尼华幢。佛号悦意吉祥音。此上过佛刹。微尘数世界。有世界。名普云藏。其状犹如楼阁之形。依种种宫殿。香水海住。一切宝灯云弥覆其上。二十佛刹微尘数。世界围绕纯一清净。佛号最胜觉神通王。诸佛子。此金刚轮庄严底。香水海右旋。次有香水海。名莲华因陀罗网。世界种。名普现十方影。依一切香。摩尼庄严。莲华住。一切佛智光音声为体。此中最下方。有世界。名众生海宝光明。其状犹如真珠之藏。依一切摩尼。璎珞海漩住。水光明摩尼云。而覆其上。佛刹微尘数。世界围绕纯一清净。佛号不思议功德遍照月。此上过佛刹。微尘数世界。有世界。名妙香轮。佛号无量力幢。此上过佛刹。微尘数世界。有世界。名妙光轮。佛号法界光音觉悟慧。此上过佛刹。微尘数世界。有世界。名吼声摩尼幢。佛号莲华光恒垂妙臂。此上过佛刹。微尘数世界。有世界。名极坚固轮。佛号不退转功德海光明。此上过佛刹。微尘数世界。有世界。名众行光庄严。佛号一切智普胜尊。此上过佛刹。微尘数世界。有世界。名师子座遍照。佛号师子光无量力觉慧。此上过佛刹。微尘数世界。有世界。名宝焰庄严。佛号一切法清净智。此上过佛刹。微尘数世界。有世界。名无量灯。佛号无忧相。此上过佛刹。微尘数世界。有世界。名常闻佛音。佛号自然胜威光。此上过佛刹。微尘数世界。有世界。名清净变化。佛号金莲华光明。此上过佛刹。微尘数世界。有世界。名普入十方。佛号观法界频申慧。此上过佛刹。微尘数世界。有世界。名炽然焰。佛号光焰树紧那罗王。此上过佛刹。微尘数世界。有世界。名香光遍照。佛号香灯善化王。此上过佛刹。微尘数世界。有世界。名无量华聚轮。佛号普现佛功德。此上过佛刹。微尘数世界。有世界。名众妙普清净。佛号一切法平等神通王。此上过佛刹。微尘数世界。有世界。名金光海。佛号十方自在大变化。此上过佛刹。微尘数世界。有世界。名真珠华藏。佛号法界宝光明不可思议慧。此上过佛刹。微尘数世界。有世界。名帝释须弥师子座。佛号胜力光。此上过佛刹。微尘数世界。有世界。名无边宝普照。其形四方。依华林海住。普雨无边色。摩尼王帝网。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号遍照世间最胜音诸佛子。此莲华因陀罗网。香水海右旋。次有香水海。名积集宝香藏。世界种。名一切威德庄严。以一切佛法轮音声为体。此中最下方。有世界。名种种出生。形如金刚。依种种金刚山幢住。金刚宝光云。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号莲华眼。此上过佛刹。微尘数世界。有世界。名喜见音。佛号生喜乐。此上过佛刹。微尘数世界。有世界。名宝庄严幢。佛号一切智。此上过佛刹。微尘数世界。有世界。名多罗华普照。佛号无垢寂妙音。此上过佛刹。微尘数世界。有世界。名变化光。佛号清净空智慧月。此上过佛刹。微尘数世界。有世界。名众妙间错。佛号开示福德海密云相。此上过佛刹。微尘数世界。有世界。名一切庄严具。妙音声。佛号欢喜云。此上过佛刹。微尘数世界。有世界。名莲华池。佛号名称幢。此上过佛刹。微尘数世界。有世界。名一切宝庄严。佛号频申观察眼。此上过佛刹。微尘数世界。有世界。名净妙华。佛号无尽金刚智。此上过佛刹。微尘数世界。有世界。名莲华庄严城。佛号日藏眼普光明。此上过佛刹。微尘数世界。有世界。名无量树峰。佛号一切法雷音。此上过佛刹。微尘数世界。有世界。名日光明。佛号开示无量智。此上过佛刹。微尘数世界。有世界。名依止莲华叶。佛号一切福德山。此上过佛刹。微尘数世界。有世界。名风普持。佛号日曜根。此上过佛刹。微尘数世界。有世界。名光明显现。佛号身光普照。此上过佛刹。微尘数世界。有世界。名香雷音。金刚宝普照。佛号最胜华开敷相。此上过佛刹。微尘数世界。有世界。名帝网庄严。形如栏楯。依一切庄严海住。光焰楼阁云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号示现无畏云

诸佛子。此积集宝香藏。香水海右旋。次有香水海。名宝庄严。世界种。名普无垢。以一切微尘中。佛刹神变声为体。此中最下方。有世界。名净妙。平坦形如宝身。依一切宝光轮海住。种种栴檀。摩尼真珠云。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号难摧伏无等幢。此上过佛刹。微尘数世界。有世界。名炽然妙庄严。佛号莲华慧神通王。此上过佛刹。微尘数世界。有世界。名微妙相轮幢。佛号十方大名称无尽光。此上过佛刹。微尘数世界。有世界。名焰藏摩尼妙庄严。佛号大智慧见闻皆欢喜。此上过佛刹。微尘数世界。有世界。名妙华庄严。佛号无量力最胜智。此上过佛刹。微尘数世界。有世界。名出生净微尘。佛号超胜梵。此上过佛刹。微尘数世界。有世界。名普光明变化香。佛号香象金刚大力势。此上过佛刹。微尘数世界。有世界。名光明旋。佛号义成善名称。此上过佛刹。微尘数世界。有世界。名宝璎珞海。佛号无比光遍照。此上过佛刹。微尘数世界。有世界。名妙华灯幢。佛号究竟功德无碍慧灯。此上过佛刹。微尘数世界。有世界。名善巧庄严。佛号慧日波罗蜜。此上过佛刹。微尘数世界。有世界。名栴檀华普光明。佛号无边慧法界音。此上过佛刹。微尘数世界。有世界。名帝网幢。佛号灯光迥照。此上过佛刹。微尘数世界。有世界。名净华轮。佛号法界日光明。此上过佛刹。微尘数世界。有世界。名大威耀。佛号无边功德海法轮音。此上过佛刹。微尘数世界。有世界。名同安住。宝莲华池。佛号开示入不可思议智。此上过佛刹。微尘数世界。有世界。名平坦地。佛号功德宝光明王。此上过佛刹。微尘数世界。有世界。名香摩尼聚。佛号无尽福德海妙庄严。此上过佛刹。微尘数世界。有世界。名微妙光明。佛号无等力普遍音。此上过佛刹。微尘数世界。有世界。名十方普坚固。庄严照耀。其形八隅。依心王摩尼轮海住。一切宝庄严帐云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号普眼大明灯

诸佛子此宝庄严香水海右旋。次有香水海。名金刚宝聚。世界种。名法界行。以一切菩萨地。方便法音声为体。此中最下方。有世界。名净光照耀。形如珠贯。依一切宝色。珠璎海住。菩萨珠髻。光明摩尼云。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号最胜功德光。此上过佛刹。微尘数世界。有世界。名妙盖。佛号法自在慧。此上过佛刹。微尘数世界。有世界。名宝庄严师子座。佛号大龙渊。此上过佛刹。微尘数世界。有世界。名出现金刚座。佛号升师子座莲华台。此上过佛刹。微尘数世界。有世界。名莲华胜音。佛号智光普开悟。此上过佛刹。微尘数世界。有世界。名善惯习。佛号持地妙光王。此上过佛刹。微尘数世界。有世界。名喜乐音。佛号法灯王。此上过佛刹。微尘数世界。有世界。名摩尼藏。因陀罗网。佛号不空见。此上过佛刹。微尘数世界。有世界。名众妙地藏。佛号焰身幢。此上过佛刹。微尘数世界。有世界。名金光轮。佛号净治众生行。此上过佛刹。微尘数世界。有世界。名须弥山庄严。佛号一切功德云普照。此上过佛刹。微尘数世界。有世界。名众树形。佛号宝华相净月觉。此上过佛刹。微尘数世界。有世界。名无怖畏。佛号最胜金光炬。此上过佛刹。微尘数世界。有世界。名大名称龙王幢。佛号观等一切法。此上过佛刹。微尘数世界。有世界。名示现摩尼色。佛号变化日此上过佛刹。微尘数世界。有世界。名光焰灯庄严。佛号宝盖光遍照。此上过佛刹。微尘数世界。有世界。名香光云。佛号思惟慧。此上过佛刹。微尘数世界。有世界。名无怨仇。佛号精进胜慧海。此上过佛刹。微尘数世界。有世界。名一切庄严具光明幢。佛号普现悦意莲华自在王。此上过佛刹。微尘数世界。有世界。名毫相庄严。形如半月。依须弥山摩尼华海住。一切庄严。炽盛光摩尼王云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号清净眼

诸佛子。此金刚宝聚。香水海右旋。次有香水海。名天城宝堞。世界种。名灯焰光明。以普示一切。平等法轮音为体。此中最下方。有世界。名宝月光焰轮。形如一切庄严具。依一切宝。庄严华海住。琉璃色师子座云。而覆其上。佛刹微尘数。世界围绕。纯一清净。佛号日月自在光。此上过佛刹。微尘数世界。有世界。名须弥宝光。佛号无尽法宝幢。此上过佛刹。微尘数世界。有世界。名众妙光明幢。佛号大华聚。此上过佛刹。微尘数世界。有世界。名摩尼光明华。佛号人中最自在。此上过佛刹。微尘数世界。有世界。名普音。佛号一切智遍照。此上过佛刹。微尘数世界。有世界。名大树紧那罗音。佛号无量福德自在龙。此上过佛刹。微尘数世界。有世界。名无边净光明。佛号功德宝华光。此上过佛刹。微尘数世界。有世界。名最胜音。佛号一切智庄严。此上过佛刹。微尘数世界。有世界。名众宝间饰。佛号宝焰须弥山。此上过佛刹。微尘数世界。有世界。名清净须弥音。佛号出现一切行光明。此上过佛刹。微尘数世界。有世界。名香水盖。佛号一切波罗蜜无碍海。此上过佛刹。微尘数世界。有世界。名师子华网。佛号宝焰幢。此上过佛刹。微尘数世界。有世界。名金刚妙华灯。佛号一切大愿光。此上过佛刹。微尘数世界。有世界。名一切法光明地。佛号一切法广大真实义。此上过佛刹。微尘数世界。有世界。名真珠末。平坦庄严。佛号胜慧光明网。此上过佛刹。微尘数世界。有世界。名琉璃华。佛号宝积幢。此上过佛刹。微尘数世界。有世界。名无量妙光轮。佛号大威力智海藏。此上过佛刹。微尘数世界。有世界。名明见十方。佛号净修一切功德幢。此上过佛刹。微尘数世界。有世界。名可爱乐梵音。形如佛手。依宝光网海住。菩萨身一切庄严云。弥覆其上。二十佛刹微尘数。世界围绕。纯一清净。佛号普照法界无碍光

大方广佛华严经卷第九大方广佛华严经卷第十

        于阗国三藏实叉难陀奉　制译

    华藏世界品第五之三

尔时普贤菩萨。复告大众言。诸佛子。彼离垢焰藏香水海东。次有香水海。名变化微妙身。此海中。有世界种。名善布差别方。次有香水海。名金刚眼幢。世界种。名庄严法界桥。次有香水海。名种种莲华妙庄严。世界种。名恒出十方变化。次有香水海。名无间宝王轮。世界种。名宝莲华茎密云。次有香水海。名妙香焰普庄严。世界种。名毗卢遮那变化行。次有香水海。名宝末阎浮幢。世界种。名诸佛护念境界。次有香水海。名一切色炽然光。世界种。名最胜光遍照。次有香水海。名一切庄严具境界。世界种。名宝焰灯。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名玻璃地。世界种。名常放光明。以世界海。清净劫音声为体。此中最下方。有世界。名可爱乐净光幢。佛刹微尘数。世界围绕。纯一清净。佛号最胜三昧精进慧。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名香庄严幢。十佛刹微尘数。世界围绕。纯一清净。佛号无障碍法界灯。此上过三佛刹。微尘数世界。与娑婆世界齐等。有世界。名放光明藏。佛号遍法界无障碍慧明。此上过七佛刹。微尘数世界。至此世界种最上方。有世界。名最胜身香。二十佛刹。微尘数世界围绕。纯一清净。佛号觉分华

诸佛子。彼无尽光明轮香水海外。次有香水海。名具足妙光。世界种。名遍无垢。次有香水海。名光耀盖。世界种。名无边普庄严。次有香水海。名妙宝庄严。世界种。名香摩尼轨度形。次有香水海。名出佛音声。世界种。名善建立庄严。次有香水海。名香幢须弥藏。世界种。名光明遍满。次有香水海。名栴檀妙光明。世界种。名华焰轮。次有香水海。名风力持。世界种。名宝焰云幢。次有香水海。名帝释身庄严。世界种。名真珠藏。次有香水海。名平坦严净。世界种。名毗琉璃末。种种庄严。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名妙树华。世界种。名出生诸方广大刹。以一切佛。摧伏魔音为体。此中最下方。有世界。名焰炬幢。佛号世间功德海。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名出生宝。佛号师子力宝云。此上与娑婆世界齐等。有世界。名衣服幢。佛号一切智海王。于此世界种最上方。有世界。名宝璎珞。师子光明。佛号善变化莲华幢

诸佛子。彼金刚焰光明。香水海外。次有香水海。名一切庄严具莹饰幢。世界种。名清净行庄严。次有香水海。名一切宝华光耀海。世界种。名功德相庄严。次有香水海。名莲华开敷。世界种。名菩萨摩尼冠庄严。次有香水海。名妙宝衣服。世界种。名净珠轮。次有香水海。名可爱华遍照。世界种。名百光云照耀。次有香水海。名遍虚空大光明。世界种。名宝光普照。次有香水海。名妙华庄严幢。世界种。名金月眼璎珞。次有香水海。名真珠香海藏。世界种。名佛光明。次有香水海。名宝轮光明。世界种。名善化现佛境界光明。如是等不可说佛刹。微尘数香水海。其最近轮围山香水海。名无边轮庄严底。世界种。名无量方差别。以一切国土。种种言说音为体。此中最下方。有世界。名金刚华盖。佛号无尽相光明普门音。此上过十佛刹。微尘数世界。有世界。与金刚幢世界齐等。名出生宝衣幢。佛号福德云大威势。此上与娑婆世界齐等。有世界。名众宝具妙庄严。佛号胜慧海。于此世界种最上方。有世界。名日光明衣服幢。佛号智日莲华云

诸佛子彼帝青宝庄严。香水海外。次有香水海。名阿修罗宫殿。世界种。名香水光所持。次有香水海。名宝师子庄严。世界种。名遍示十方一切宝。次有香水海。名宫殿色光明云。世界种。名宝轮妙庄严。次有香水海。名出大莲华。世界种。名妙庄严遍照法界。次有香水海。名灯焰妙眼。世界种。名遍观察十方变化。次有香水海。名不思议庄严轮。世界种。名十方光明普名称。次有香水海。名宝积庄严。世界种。名灯光照耀。次有香水海。名清净宝光明。世界种。名须弥无能为碍风。次有香水海。名宝衣栏楯。世界种。名如来身光明。如是等不可说佛刹。微尘数香水海。其最近轮围山香水海。名树庄严幢。世界种。名安住帝网以一切菩萨。智地音声为体。此中最下方。有世界。名妙金色。佛号香焰胜威光。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名摩尼树华。佛号无碍普现。此上与娑婆世界齐等。有世界。名毗琉璃妙庄严。佛号法自在坚固慧。于此世界种最上方。有世界。名梵音妙庄严。佛号莲华开敷光明王

诸佛子。彼金刚轮庄严底。香水海外。次有香水海。名化现莲华处。世界种。名国土平正。次有香水海。名摩尼光。世界种。名遍法界无迷惑。次有香水海。名众妙香日摩尼。世界种。名普现十方。次有香水海。名恒纳宝流。世界种。名普行佛言音。次有香水海。名无边深妙音。世界种。名无边方差别。次有香水海。名坚实积聚。世界种。名无量处差别。次有香水海。名清净梵音。世界种。名普清净庄严。次有香水海。名栴檀栏楯音声藏。世界种。名迥出幢。次有香水海。名妙香宝王光庄严。世界种。名普现光明力

诸佛子。彼莲华因陀罗网。香水海外。次有香水海。名银莲华妙庄严。世界种。名普遍行。次有香水海。名毗琉璃竹密焰云。世界种。名普出十方音。次有香水海。名十方光焰聚。世界种。名恒出。变化。分布十方。次有香水海。名出现真金摩尼幢。世界种。名金刚幢相。次有香水海。名平等大庄严。世界种。名法界勇猛旋次有香水海。名宝华丛无尽光。世界种。名无边净光明。次有香水海。名妙金幢。世界种。名演说微密处。次有香水海。名光影遍照。世界种。名普庄严。次有香水海。名寂音。世界种。名现前垂布。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名密焰云幢。世界种。名一切光庄严。以一切如来。道场众会音为体。于此最下方。有世界。名净眼庄严。佛号金刚月遍照十方。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名莲华德。佛号大精进善觉慧。此上与娑婆世界齐等。有世界。名金刚密庄严。佛号娑罗王幢。此上过七佛刹。微尘数世界。有世界。名净海庄严。佛号威德绝伦无能制伏

诸佛子。彼积集宝香藏。香水海外。次有香水海。名一切宝光明遍照。世界种。名无垢称庄严。次有香水海。名众宝华开敷。世界种。名虚空相。次有香水海。名吉祥幄遍照。世界种。名无碍光普庄严。次有香水海。名栴檀。树华。世界种。名普现十方旋。次有香水海。名出生妙色宝。世界种。名胜幢周遍行。次有香水海。名普生金刚华。世界种。名现不思议庄严。次有香水海。名心王摩尼轮严饰。世界种。名示现无碍佛光明。次有香水海。名积集宝璎珞。世界种。名净除疑。次有香水海。名真珠轮普庄严。世界种。名诸佛愿所流。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名阎浮檀宝藏轮。世界种。名普音幢。以入一切智门。音声为体。此中最下方。有世界。名华蕊焰。佛号精进施。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名莲华光明幢。佛号一切功德最胜心王。此上过三佛刹。微尘数世界。与娑婆世界齐等。有世界。名十力庄严。佛号善出现无量功德王。于此世界种最上方。有世界。名摩尼香山幢。佛号广大善眼净除疑

诸佛子。彼宝庄严香水海外。次有香水海。名持须弥光明藏。世界种。名出生广大云。次有香水海。名种种庄严。大威力境界。世界种。名无碍净庄严。次有香水海。名密布宝莲华。世界种。名最胜灯庄严。次有香水海。名依止一切宝庄严。世界种。名日光明网藏。次有香水海。名众多严净。世界种。名宝华依处。次有香水海。名极聪慧行。世界种。名最胜形庄严。次有香水海。名持妙摩尼峰。世界种。名普净虚空藏。次有香水海。名大光遍照。世界种。名帝青炬光明。次有香水海。名可爱摩尼珠。充满遍照。世界种。名普吼声。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名出帝青宝。世界种。名周遍无差别。以一切菩萨震吼声为体。此中最下方。有世界。名妙胜藏。佛号最胜功德慧。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名庄严相。佛号超胜大光明。此上与娑婆世界齐等。有世界。名琉璃轮普庄严。佛号须弥灯。于此世界种最上方。有世界。名华幢海。佛号无尽变化妙慧云

诸佛子。彼金刚宝聚。香水海外。次有香水海。名崇饰宝埤堄。世界种。名秀出宝幢。次有香水海。名宝幢庄严。世界种。名现一切光明。次有香水海。名妙宝云。世界种。名一切宝庄严。光明遍照。次有香水海。名宝树华庄严。世界种。名妙华间饰。次有香水海。名妙宝衣庄严。世界种。名光明海。次有香水海。名宝树峰。世界种。名宝焰云。次有香水海。名示现光明。世界种。名入金刚无所碍。次有香水海。名莲华普庄严。世界种。名无边岸海渊。次有香水海。名妙宝庄严。世界种。名普示现国土藏。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名不可坏海。世界种。名妙轮间错莲华场。以一切佛力。所出音为体。此中最下方。有世界。名最妙香。佛号变化无量尘数光。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名不思议。差别庄严门。佛号无量智。此上与娑婆世界齐等。有世界。名十方光明。妙华藏。佛号师子眼光焰云。于此最上方。有世界。名海音声。佛号水天光焰门

诸佛子。彼天城宝堞。香水海外。次有香水海。名焰轮赫奕光。世界种。名不可说种种庄严。次有香水海。名宝尘路。世界种。名普入无量旋。次有香水海。名具一切庄严。世界种。名宝光遍照。次有香水海。名布众宝网。世界种。名安布深密。次有香水海。名妙宝庄严幢。世界种。名世界海明了音。次有香水海。名日宫清净影。世界种。名遍入因陀罗网。次有香水海。名一切鼓乐美妙音。世界种。名圆满平正。次有香水海。名种种妙庄严。世界种。名净密光焰云。次有香水海。名周遍宝焰灯。世界种。名随佛本愿种种形。如是等。不可说佛刹。微尘数香水海。其最近轮围山香水海。名积集璎珞衣。世界种。名化现妙衣。以三世一切佛。音声为体。此中最下方。有香水海。名因陀罗华藏。世界。名发生欢喜。佛刹微尘数世界围绕。纯一清净。佛号坚悟智。此上过十佛刹。微尘数世界。与金刚幢世界齐等。有世界。名宝网庄严。十佛刹微尘数。世界围绕。纯一清净。佛号无量欢喜光。此上过三佛刹。微尘数世界。与娑婆世界齐等。有世界。名宝莲华师子座。十三佛刹微尘数。世界围绕。佛号最清净不空闻。此上过七佛刹。微尘数世界。至此世界种最上方。有世界。名宝色龙光明。二十佛刹微尘数。世界围绕。纯一清净。佛号遍法界普照明

诸佛子。如是十不可说佛刹。微尘数香水海中。有十不可说佛刹。微尘数世界种皆依现一切菩萨形。摩尼王幢。庄严莲华住。各各庄严际。无有间断。各各放宝色光明。各各光明云。而覆其上各各庄严具。各各劫差别。各各佛出现。各各演法海。各各众生遍充满。各各十方普趣入。各各一切佛神力所加持。此一一世界种中。一切世界。依种种庄严住。递相接连。成世界网。于华藏庄严世界海。种种差别。周遍建立。尔时普贤菩萨。欲重宣其义。承佛威力。而说颂言

  华藏世界海　　法界等无别
  庄严极清净　　安住于虚空
  此世界海中　　刹种难思议
  一一皆自在　　各各无杂乱
  华藏世界海　　刹种善安布
  殊形异庄严　　种种相不同
  诸佛变化音　　种种为其体
  随其业力见　　刹种妙严饰
  须弥山城网　　水旋轮圆形
  广大莲华开　　彼彼互围绕
  山幢楼阁形　　旋转金刚形
  如是不思议　　广大诸刹种
  大海真珠焰　　光网不思议
  如是诸刹种　　悉在莲华住
  一一诸刹种　　光网不可说
  光中现众刹　　普遍十方海
  一切诸刹种　　所有庄严具
  国土悉入中　　普见无有尽
  刹种不思议　　世界无边际
  种种妙严好　　皆由大仙力
  一切刹种中　　世界不思议
  或成或有坏　　或有已坏灭
  譬如林中叶　　有生亦有落
  如是刹种中　　世界有成坏
  譬如依树林　　种种果差别
  如是依刹种　　种种众生住
  譬如种子别　　生果各殊异
  业力差别故　　众生刹不同
  譬如心王宝　　随心见众色
  众生心净故　　得见清净刹
  譬如大龙王　　兴云遍虚空
  如是佛愿力　　出生诸国土
  如幻师咒术　　能现种种事
  众生业力故　　国土不思议
  譬如众缋像　　画师之所作
  如是一切刹　　心画师所成
  众生身各异　　随心分别起
  如是刹种种　　莫不皆由业
  譬如见导师　　种种色差别
  随众生心行　　见诸刹亦然
  一切诸刹际　　周布莲华网
  种种相不同　　庄严悉清净
  彼诸莲华网　　刹网所安住
  种种庄严事　　种种众生居
  或有刹土中　　险恶不平坦
  由众生烦恼　　于彼如是见
  杂染及清净　　无量诸刹种
  随众生心起　　菩萨力所持
  或有刹土中　　杂染及清净
  斯由业力起　　菩萨之所化
  有刹放光明　　离垢宝所成
  种种妙严饰　　诸佛令清净
  一一刹种中　　劫烧不思议
  所现虽败恶　　其处常坚固
  由众生业力　　出生多刹土
  依止于风轮　　及以水轮住
  世界法如是　　种种见不同
  而实无有生　　亦复无灭坏
  一一心念中　　出生无量刹
  以佛威神力　　悉见净无垢
  有刹泥土成　　其体甚坚鞕
  黑闇无光照　　恶业者所居
  有刹金刚成　　杂染大忧怖
  苦多而乐少　　薄福之所处
  或有用铁成　　或以赤铜作
  石山险可畏　　罪恶者充满
  刹中有地狱　　众生苦无救
  常在黑闇中　　焰海所烧然
  或复有畜生　　种种丑陋形
  由其自恶业　　常受诸苦恼
  或见阎罗界　　饥渴所煎逼
  登上大火山　　受诸极重苦
  或有诸刹土　　七宝所合成
  种种诸宫殿　　斯由净业得
  汝应观世间　　其中人与天
  净业果成就　　随时受快乐
  一一毛孔中　　亿刹不思议
  种种相庄严　　未曾有迫隘
  众生各各业　　世界无量种
  于中取着生　　受苦乐不同
  有刹众宝成　　常放无边光
  金刚妙莲华　　庄严净无垢
  有刹光为体　　依止光轮住
  金色栴檀香　　焰云普照明
  有刹月轮成　　香衣悉周布
  于一莲华内　　菩萨皆充满
  有刹众宝成　　色相无诸垢
  譬如天帝网　　光明恒照耀
  有刹香为体　　或是金刚华
  摩尼光影形　　观察甚清净
  或有难思刹　　华旋所成就
  化佛皆充满　　菩萨普光明
  或有清净刹　　悉是众华树
  妙枝布道场　　荫以摩尼云
  有刹净光照　　金刚华所成
  有是佛化音　　无边列成网
  有刹如菩萨　　摩尼妙宝冠
  或有如座形　　从化光明出
  或是栴檀末　　或是眉间光
  或佛光中音　　而成斯妙刹
  有见清净刹　　以一光庄严
  或见多庄严　　种种皆奇妙
  或用十国土　　妙物作严饰
  或以千土中　　一切为庄校
  或以亿刹物　　庄严于一土
  种种相不同　　皆如影像现
  不可说土物　　庄严于一刹
  各各放光明　　如来愿力起
  或有诸国土　　愿力所净治
  一切庄严中　　普见众刹海
  诸修普贤愿　　所得清净土
  三世刹庄严　　一切于中现
  佛子汝应观　　刹种威神力
  未来诸国土　　如梦悉令见
  十方诸世界　　过去国土海
  咸于一刹中　　现像犹如化
  三世一切佛　　及以其国土
  于一刹种中　　一切悉观见
  一切佛神力　　尘中现众土
  种种悉明见　　如影无真实
  或有众多刹　　其形如大海
  或如须弥山　　世界不思议
  有刹善安住　　其形如帝网
  或如树林形　　诸佛满其中
  或作宝轮形　　或有莲华状
  八隅备众饰　　种种悉清净
  或有如座形　　或复有三隅
  或如佉勒迦　　城廓梵王身
  或如天主髻　　或有如半月
  或如摩尼山　　或如日轮形
  或有世界形　　譬如香海旋
  或作光明轮　　佛昔所严净
  或有轮辋形　　或有坛墠形
  或如佛毫相　　肉髻广长眼
  或有如佛手　　或如金刚杵
  或如焰山形　　菩萨悉周遍
  或如师子形　　或如海蚌形
  无量诸色相　　体性各差别
  于一刹种中　　刹形无有尽
  皆由佛愿力　　护念得安住
  有刹住一劫　　或住于十劫
  乃至过百千　　国土微尘数
  或于一劫中　　见刹有成坏
  或无量无数　　乃至不思议
  或有刹有佛　　或有刹无佛
  或有唯一佛　　或有无量佛
  国土若无佛　　他方世界中
  有佛变化来　　为现诸能事
  没天与降神　　处胎及出生
  降魔成正觉　　转无上法轮
  随众生心乐　　示现种种相
  为转妙法轮　　悉应其根欲
  一一佛刹中　　一佛出兴世
  经于亿千岁　　演说无上法
  众生非法器　　不能见诸佛
  若有心乐者　　一切处皆见
  一一刹土中　　各有佛兴世
  一切刹中佛　　亿数不思议
  此中一一佛　　现无量神变
  悉遍于法界　　调伏众生海
  有刹无光明　　黑闇多恐惧
  苦触如刀剑　　见者自酸毒
  或有诸天光　　或有宫殿光
  或日月光明　　刹网难思议
  有刹自光明　　或树放净光
  未曾有苦恼　　众生福力故
  或有山光明　　或有摩尼光
  或以灯光照　　悉众生业力
  或有佛光明　　菩萨满其中
  有是莲华光　　焰色甚严好
  有刹华光照　　有以香水照
  涂香烧香照　　皆由净愿力
  有以云光照　　摩尼蚌光照
  佛神力光照　　能宣悦意声
  或以宝光照　　或金刚焰照
  净音能远震　　所至无众苦
  或有摩尼光　　或是严具光
  或道场光明　　照耀众会中
  佛放大光明　　化佛满其中
  其光普照触　　法界悉周遍
  有刹甚可畏　　嗥叫大苦声
  其声极酸楚　　闻者生厌怖
  地狱畜生道　　及以阎罗处
  是浊恶世界　　恒出忧苦声
  或有国土中　　常出可乐音
  悦意顺其教　　斯由净业得
  或有国土中　　恒闻帝释音
  或闻梵天音　　一切世主音
  或有诸刹土　　云中出妙声
  宝海摩尼树　　及乐音遍满
  诸佛圆光内　　化声无有尽
  及菩萨妙音　　周闻十方刹
  不可思议国　　普转法轮声
  愿海所出声　　修行妙音声
  三世一切佛　　出生诸世界
  名号皆具足　　音声无有尽
  或有刹中闻　　一切佛力音
  地度及无量　　如是法皆演
  普贤誓愿力　　亿刹演妙音
  其音若雷震　　住劫亦无尽
  佛于清净国　　示现自在音
  十方法界中　　一切无不闻

大方广佛华严经卷第十大方广佛华严经卷第十一

        于阗国三藏实叉难陀奉　制译

    毗卢遮那品第六

尔时。普贤菩萨。复告大众言。诸佛子。乃往古世。过世界微尘数劫。复倍是数。有世界海。名普门净光明。此世界海中有世界。名胜音。依摩尼华网海住。须弥山微尘数世界。而为眷属。其形正圆。其地具有无量庄严。三百重众宝树轮围山。所共围绕。一切宝云。而覆其上。清净无垢。光明照耀。城邑宫殿。如须弥山。衣服饮食。随念而至。其劫名曰种种庄严。诸佛子。彼胜音世界中。有香水海。名清净光明。其海中。有大华。须弥山出现。名华焰普庄严幢。十宝栏楯。周匝围绕。于其山上。有一大林。名摩尼华枝轮。无量华楼阁。无量宝台观。周回布列。无量妙香幢。无量宝山幢。迥极庄严。无量宝芬陀利华。处处敷荣。无量香摩尼莲华网。周匝垂布。乐音和悦。香云照耀。数各无量。不可纪极。有百万亿那由他城。周匝围绕。种种众生。于中止住。诸佛子。此林东有一大城。名焰光明。人王所都。百万亿那由他城。周匝围绕。清净妙宝。所共成立。纵广各有七千由旬。七宝为廓。楼橹却敌。悉皆崇丽。七重宝堑香水盈满。优钵罗华。波头摩华。拘物头华。芬陀利华。悉是众宝。处处分布。以为严饰。宝多罗树。七重围绕。宫殿楼阁。悉宝庄严。种种妙网。张施其上。涂香散华。芬莹其中。有百万亿那由他门。悉宝庄严。一一门前。各有四十九宝尸罗幢。次第行列

复有百万亿园林。周匝围绕。其中皆有种种杂香。摩尼树香。周流普熏。众鸟和鸣。听者欢悦。此大城中。所有居人。靡不成就业报神足。乘空往来。行同诸天。心有所欲。应念皆至。其城次南。有一天城。名树华庄严。其次右旋。有大龙城。名曰究竟。次有夜叉城。名金刚胜妙幢。次有乾闼婆城。名曰妙宫。次有阿修罗城。名曰宝轮。次有迦楼罗城。名妙宝庄严。次有梵天王城。名种种妙庄严。如是等。百万亿那由他数。此一一城。各有百万亿那由他楼阁。所共围绕。一一皆有无量庄严。诸佛子。此宝华枝轮大林之中。有一道场。名宝华遍照。以众大宝。分布庄严。摩尼华轮。遍满开敷。然以香灯。具众宝色焰云弥覆。光网普照。诸庄严具。常出妙宝。一切乐中。恒奏雅音。摩尼宝王。现菩萨身。种种妙华。周遍十方。其道场前。有一大海。名香摩尼金刚。出大莲华。名华蕊焰轮。其华广大。百亿由旬。茎叶须台。皆是妙宝。十不可说。百千亿那由他莲华。所共围绕。常放光明。恒出妙音。周遍十方。诸佛子。彼胜音世界。最初劫中。有十须弥山。微尘数如来。出兴于世。其第一佛。号一切功德山须弥胜云。诸佛子。应知彼佛将出现时。一百年前。此摩尼华枝轮大林中。一切庄严。周遍清净。所谓。出不思议宝焰云。发叹佛功德音。演无数佛音声。舒光布网。弥覆十万。宫殿楼阁。互相照耀。宝华光明。腾聚成云。复出妙音。说一切众生。前世所行。广大善根。说三世一切。诸佛名号。说诸菩萨。所修愿行。究竟之道。说诸如来。转妙法轮。种种言辞。现如是等。庄严之相。显示如来。当出于世。其世界中。一切诸王。见此相故。善根成熟。悉欲见佛。而来道场。尔时。一切功德山须弥胜云佛。于其道场。大莲华中。忽然出现。其身周普。等真法界。一切佛刹。皆示出生。一切道场。悉诣其所。无边妙色。具足清净。一切世间。无能映夺。具众宝相。一一分明。一切宫殿。悉现其像。一切众生。咸得目见。无边化佛。从其身出。种种色光。充满法界。如于此清净光明香水海。华焰庄严幢须弥顶上。摩尼华枝轮大林中。出现其身。而坐于座。其胜音世界。有六十八千亿须弥山顶。悉亦于彼。现身而坐。尔时彼佛即于眉间。放大光明。其光名发起一切善根音。十佛刹微尘数光明。而为眷属。充满一切十方国土。若有众生。应可调伏。其光照触。即自开悟。息诸惑热。裂诸盖网。摧诸障山。净诸垢浊。发大信解。生胜善根。永离一切诸难恐怖。灭除一切身心苦恼。起见佛心。趣一切智。时一切世间主。并其眷属。无量百千。蒙佛光明。所开觉故。悉诣佛所。头面礼足

诸佛子。彼焰光明大城中有王。名喜见善慧。统领百万亿那由他城。夫人采女。三万七千人。福吉祥为上首。王子五百人。(别本云二万五千人)大威光为上首。大威光太子有十千夫人。妙见为上首。尔时。大威光太子。见佛光明已。以昔所修善根力故。即时证得十种法门。何谓为十。所谓。证得一切诸佛。功德轮三昧。证得一切佛法。普门陀罗尼。证得广大方便藏。般若波罗蜜。证得调伏一切众生。大庄严大慈。证得普云音大悲。证得生无边功德。最胜心大喜。证得如实觉悟一切法大舍。证得广大方便。平等藏大神通。证得增长信解力大愿。证得普入一切智。光明辩才门。尔时。大威光太子。获得如是法光明已。承佛威力。普观大众。而说颂言

  世尊坐道场　　清净大光明
  譬如千日出　　普照虚空界
  无量亿千劫　　导师时乃现
  佛今出世间　　一切所瞻奉
  汝观佛光明　　化佛难思议
  一切宫殿中　　寂然而正受
  汝观佛神通　　毛孔出焰云
  照耀于世间　　光明无有尽
  汝应观佛身　　光网极清净
  现形等一切　　遍满于十方
  妙音遍世间　　闻者皆欣乐
  随诸众生语　　赞叹佛功德
  世尊光所照　　众生悉安乐
  有苦皆灭除　　心生大欢喜
  观诸菩萨众　　十方来萃止
  悉放摩尼云　　现前称赞佛
  道场出妙音　　其音极深远
  能灭众生苦　　此是佛神力
  一切咸恭敬　　心生大欢喜
  共在世尊前　　瞻仰于法王

诸佛子。彼大威光太子。说此颂时。以佛神力。其声普遍胜音世界。时喜见善慧王。闻此颂已。心大欢喜。观诸眷属。而说颂言

  汝应速召集　　一切诸王众
  王子及大臣　　城邑宰官等
  普告诸城内　　疾应击大鼓
  共集所有人　　俱行往见佛
  一切四衢道　　悉应鸣宝铎
  妻子眷属俱　　共往观如来
  一切诸城廓　　宜令悉清净
  普建胜妙幢　　摩尼以严饰
  宝帐罗众网　　妓乐如云布
  严备在虚空　　处处令充满
  道路皆严净　　普雨妙衣服
  巾驭汝宝乘　　与我同观佛
  各各随自力　　普雨庄严具
  一切如云布　　遍满虚空中
  香焰莲华盖　　半月宝璎珞
  及无数妙衣　　汝等皆应雨
  须弥香水海　　上妙摩尼轮
  及清净栴檀　　悉应雨满空
  众宝华璎珞　　庄严净无垢
  及以摩尼灯　　皆令在空住
  一切持向佛　　心生大欢喜
  妻子眷属俱　　往见世所尊

尔时喜见善慧王。与三万七千夫人采女俱。福吉祥为上首。五百王子俱。大威光为上首。六万大臣俱。慧力为上首。如是等。七十七百千亿那由他众。前后围绕。从焰光明大城出。以王力故。一切大众。乘空而往。诸供养具。遍满虚空。至于佛所。顶礼佛足。却坐一面。复有妙华城。善化幢天王。与十亿那由他眷属俱

复有究竟大城。净光龙王。与二十五亿眷属俱。复有金刚胜幢城。猛健夜叉王与七十七亿眷属俱。复有无垢城。喜见乾闼婆王。与九十七亿眷属俱。复有妙轮城。净色思惟阿修罗王。与五十八亿眷属俱。复有妙庄严城。十力行迦楼罗王。与九十九千眷属俱

复有游戏快乐城。金刚德紧那罗王。与十八亿眷属俱。复有金刚幢城。宝称幢摩睺罗伽王。与三亿百千那由他眷属俱。复有净妙庄严城。最胜梵王。与十八亿眷属俱。如是等百万亿那由他大城中。所有诸王。并其眷属。悉共往诣一切功德须弥胜云如来所。顶礼佛足。却坐一面

时彼如来。为欲调伏诸众生故。于众会道场海中。说普集一切三世佛。自在法修多罗。世界微尘数修多罗。而为眷属。随众生心。悉令获益。是时。大威光菩萨。闻是法已。即获一切功德须弥胜云佛。宿世所集法海光明。所谓。得一切法聚。平等三昧智光明。一切法悉入最初菩提心中住智光明。十方法界普光明藏。清净眼智光明。观察一切佛法。大愿海智光明。入无边功德海。清净行智光明。趣向不退转。大力速疾藏智光明。法界中无量变化力。出离轮智光明。决定入无量功德。圆满海智光明。了知一切佛决定解。庄严成就海智光明。了知法界无边佛。现一切众生前。神通海智光明。了知一切佛。力无所畏。法智光明。尔时大威光菩萨。得如是无量智光明已。承佛威力。而说颂言

  我闻佛妙法　　而得智光明
  以是见世尊　　往昔所行事
  一切所生处　　名号身差别
  及供养于佛　　如是我咸见
  往昔诸佛所　　一切皆承事
  无量劫修行　　严净诸刹海
  舍施于自身　　广大无涯际
  修治最胜行　　严净诸刹海
  耳鼻头手足　　及以诸宫殿
  舍之无有量　　严净诸刹海
  能于一一刹　　亿劫不思议
  修习菩提行　　严净诸刹海
  普贤大愿力　　一切佛海中
  修行无量行　　严净诸刹海
  如因日光照　　还见于日轮
  我以佛智光　　见佛所行道
  我观佛刹海　　清净大光明
  寂静证菩提　　法界悉周遍
  我当如世尊　　广净诸刹海
  以佛威神力　　修习菩提行

诸佛子。时大威光菩萨。以见一切功德山须弥胜云佛。承事供养故。于如来所。心得悟了。为一切世间。显示如来往昔行海。显示往昔菩萨行方便。显示一切佛功德海。显示普入一切法界清净智。显示一切道场中。成佛自在力。显示佛力无畏。无差别智。显示普示现如来身。显示不可思议佛神变。显示庄严无量。清净佛土。显示普贤菩萨。所有行愿。令如须弥山。微尘数众生。发菩提心。佛刹微尘数众生。成就如来清净国土。尔时一切功德山须弥胜云佛。为大威光菩萨。而说颂言

  善哉大威光　　福藏广名称
  为利众生故　　发趣菩提道
  汝获智光明　　法界悉充遍
  福慧咸广大　　当得深智海
  一刹中修行　　经于刹尘劫
  如汝见于我　　当获如是智
  非诸劣行者　　能知此方便
  获大精进力　　乃能净刹海
  一一微尘中　　无量劫修行
  彼人乃能得　　庄严诸佛刹
  为一一众生　　轮回经劫海
  其心不疲懈　　当成世导师
  供养一一佛　　悉尽未来际
  心无暂疲厌　　当成无上道
  三世一切佛　　当共满汝愿
  一切佛会中　　汝身安住彼
  一切诸如来　　誓愿无有边
  大智通达者　　能知此方便
  大光供养我　　故获大威力
  令尘数众生　　成熟向菩提
  诸修普贤行　　大名称菩萨
  庄严佛刹海　　法界普周遍

诸佛子。汝等应知。彼大庄严劫中。有恒河沙数小劫。人寿命二小劫。诸佛子。彼一切功德须弥胜云佛。寿命五十亿岁。彼佛灭度后。有佛出世。名波罗蜜善眼庄严王。亦于彼摩尼华枝轮大林中。而成正觉。尔时。大威光童子。见彼如来。成等正觉。现神通力。即得念佛三昧。名无边海藏门。即得陀罗尼。名大智力法渊。即得大慈。名普随众生。调伏度脱。即得大悲。名遍覆一切境界云。即得大喜。名一切佛功德海威力藏。即得大舍。名法性虚空。平等清净。即得般若波罗蜜。名自性离垢。法界清净身。即得神通。名无碍光普随现。即得辩才。名善入离垢渊。即得智光。名一切佛法清净藏。如是等十千法门。皆得通达。尔时。大威光童子。承佛威力。为诸眷属。而说颂言

  不可思议亿劫中　　导世明师难一遇
  此土众生多善利　　而今得见第二佛
  佛身普放大光明　　色相无边极清净
  如云充满一切土　　处处称扬佛功德
  光明所照咸欢喜　　众生有苦悉除灭
  各令恭敬起慈心　　此是如来自在用
  出不思议变化云　　放无量色光明网
  十方国土皆充满　　此佛神通之所现
  一一毛孔现光云　　普遍虚空发大音
  所有幽冥靡不照　　地狱众苦咸令灭
  如来妙音遍十方　　一切言音咸具演
  随诸众生宿善力　　此是大师神变用
  无量无边大众海　　佛于其中皆出现
  普转无尽妙法轮　　调伏一切诸众生
  佛神通力无有边　　一切刹中皆出现
  善逝如是智无碍　　为利众生成正觉
  汝等应生欢喜心　　踊跃爱乐极尊重
  我当与汝同诣彼　　若见如来众苦灭
  发心回向趣菩提　　慈念一切诸众生
  悉住普贤广大愿　　当如法王得自在

诸佛子。大威光童子。说此颂时。以佛神力。其声无碍。一切世界。皆悉得闻。无量众生。发菩提心。时大威光王子。与其父母。并诸眷属。及无量百千亿那由他众生。前后围绕。宝盖如云。遍覆虚空。共诣波罗蜜善眼庄严王如来所。其佛为说法界体性。清净庄严。修多罗。世界海微尘等修多罗。而为眷属。彼诸大众。闻此经已。得清净智。名入一切净方便。得于地。名离垢光明。得波罗蜜轮。名示现一切世间。爱乐庄严。得增广行轮。名普入一切刹土。无边光明清净见。得趣向行轮。名离垢福德云光明幢。得随入证轮。名一切法海。广大光明。得转深发趣行。名大智庄严。得灌顶智慧海。名无功用修极妙见。得显了大光明。名如来功德海相。光影遍照。得出生愿力清净智。名无量愿力信解藏。时彼佛。为大威光菩萨。而说颂言

  善哉功德智慧海　　发心趣向大菩提
  汝当得佛不思议　　普为众生作依处
  汝已出生大智海　　悉能遍了一切法
  当以难思妙方便　　入佛无尽所行境
  已见诸佛功德云　　已入无尽智慧地
  诸波罗蜜方便海　　大名称者当满足
  已得方便总持门　　及以无尽辩才门
  种种行愿皆修习　　当成无等大智慧
  汝已出生诸愿海　　汝已入于三昧海
  当具种种大神通　　不可思议诸佛法
  究竟法界不思议　　广大深心已清净
  普见十方一切佛　　离垢庄严众刹海
  汝已入我菩提行　　昔时本事方便海
  如我修行所净治　　如是妙行汝皆悟
  我于无量一一刹　　种种供养诸佛海
  如彼修行所得果　　如是庄严汝咸见
  广大劫海无有尽　　一切刹中修净行
  坚固誓愿不可思　　当得如来此神力
  诸佛供养尽无余　　国土庄严悉清净
  一切劫中修妙行　　汝当成佛大功德

诸佛子。波罗蜜善眼庄严王如来。入涅槃已。喜见善慧王。寻亦去世。大威光童子。受转轮王位。彼摩尼华枝轮大林中。第三如来。出现于世。名最胜功德海。时大威光转轮圣王。见彼如来。成佛之相。与其眷属。及四兵众。城邑聚落。一切人民。并持七宝。俱往佛所。以一切香。摩尼庄严。大楼阁。奉上于佛。时彼如来。于其林中。说菩萨普眼。光明行修多罗。世界微尘数修多罗。而为眷属。尔时。大威光菩萨。闻此法已。得三昧。名大福德普光明。得此三昧故。悉能了知一切菩萨。一切众生。过现未来。福非福海。时彼佛。为大威光菩萨。而说颂言

  善哉福德大威光　　汝等今来至我所
  愍念一切众生海　　发胜菩提大愿心
  汝为一切苦众生　　起大悲心令解脱
  当作群迷所依怙　　是名菩萨方便行
  若有菩萨能坚固　　修诸胜行无厌怠
  最胜最上无碍解　　如是妙智彼当得
  福德光者福幢者　　福德处者福海者
  普贤菩萨所有愿　　是汝大光能趣入
  汝能以此广大愿　　入不思议诸佛海
  诸佛福海无有边　　汝以妙解皆能见
  汝于十方国土中　　悉见无量无边佛
  彼佛往昔诸行海　　如是一切汝咸见
  若有住此方便海　　必得入于智地中
  此是随顺诸佛学　　决定当成一切智
  汝于一切刹海中　　微尘劫海修诸行
  一切如来诸行海　　汝皆学已当成佛
  如汝所见十方中　　一切刹海极严净
  汝刹严净亦如是　　无边愿者所当得
  今此道场众会海　　闻汝愿已生欣乐
  皆入普贤广大乘　　发心回向趣菩提
  无边国土一一中　　悉入修行经劫海
  以诸愿力能圆满　　普贤菩萨一切行

诸佛子。彼摩尼华枝轮大林中。复有佛出。号名称普闻莲华眼幢。是时大威光。于此命终。生须弥山上。寂静宝宫。天城中。为大天王。名离垢福德幢。共诸天众俱诣佛所。雨宝华云。以为供养。时彼如来。为说广大方便。普门遍照修多罗。世界海微尘数修多罗。而为眷属。时天王众。闻此经已。得三昧。名普门欢喜藏。以三昧力。能入一切法实相海。获是益已。从道场出。还归本处

大方广佛华严经卷第十一大方广佛华严经卷第十二

        于阗国三藏实叉难陀奉　制译

    如来名号品第七

尔时世尊。在摩竭提国阿兰若法菩提场中。始成正觉。于普光明殿。坐莲华藏师子之座。妙悟皆满。二行永绝。达无相法。住于佛住。得佛平等。到无障处。不可转法。所行无碍。立不思议。普见三世。与十佛刹微尘数。诸菩萨俱。莫不皆是一生补处。悉从他方。而共来集。普善观察诸众生界。法界世界。涅槃界。诸业果报。心行次第。一切文义。世出世间。有为无为。过现未来。时诸菩萨。作是思惟。若世尊见愍我等。愿随所乐。开示佛刹。佛住。佛刹庄严。佛法性。佛刹清净。佛所说法。佛刹体性。佛威德。佛刹成就。佛大菩提。如十方一切世界。诸佛世尊。为成就一切菩萨故。令如来种性。不断故。救护一切众生故。令诸众生。永离一切烦恼故。了知一切诸行故。演说一切诸法故。净除一切杂染故。永断一切疑网故。拔除一切希望故。灭坏一切爱着处故。说诸菩萨。十住十行。十回向十藏。十地十愿。十定十通。十顶。及说如来地。如来境界。如来神力。如来所行。如来力。如来无畏。如来三昧。如来神通。如来自在。如来无碍。如来眼。如来耳。如来鼻。如来舌。如来身。如来意。如来辩才。如来智慧。如来最胜。愿佛世尊。亦为我说

尔时世尊。知诸菩萨。心之所念。各随其类。为现神通。现神通已。东方过十佛刹。微尘数世界。有世界。名金色。佛号不动智。彼世界中。有菩萨。名文殊师利。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于东方。化作莲华藏师子之座。结跏趺坐。南方过十佛刹。微尘数世界。有世界。名妙色。佛号无碍智。彼有菩萨。名曰觉首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于南方。化作莲华藏师子之座。结跏趺坐。西方过十佛刹。微尘数世界。有世界。名莲华色。佛号灭暗智。彼有菩萨。名曰财首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于西方。化作莲华藏师子之座。结跏趺坐。北方过十佛刹。微尘数世界。有世界。名薝卜华色。佛号威仪智。彼有菩萨。名曰宝首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于北方。化作莲华藏师子之座。结跏趺坐。东北方。过十佛刹。微尘数世界。有世界。名优钵罗华色。佛号明相智。彼有菩萨。名功德首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于东北方。化作莲华藏师子之座。结跏趺坐。东南方。过十佛刹。微尘数世界。有世界。名金色。佛号究竟智。彼有菩萨。名目首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于东南方。化作莲华藏师子之座。结跏趺坐。西南方。过十佛刹。微尘数世界。有世界。名宝色。佛号最胜智。彼有菩萨。名精进首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于西南方。化作莲华藏师子之座。结跏趺坐。西北方。过十佛刹。微尘数世界。有世界。名金刚色。佛号自在智。彼有菩萨。名法首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于西北方。化作莲华藏师子之座。结跏趺坐。下方过十佛刹。微尘数世界。有世界。名玻璃色。佛号梵智。彼有菩萨。名智首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于下方。化作莲华藏师子之座。结跏趺坐。上方过十佛刹。微尘数世界。有世界。名平等色。佛号观察智。彼有菩萨。名贤首。与十佛刹。微尘数诸菩萨俱。来诣佛所。到已作礼。即于上方。化作莲华藏师子之座。结跏趺坐

尔时。文殊师利菩萨摩诃萨。承佛威力普观一切菩萨众会。而作是言。此诸菩萨。甚为希有。诸佛子。佛国土不可思议。佛住佛刹庄严。佛法性。佛刹清净。佛说法。佛出现。佛刹成就。佛阿耨多罗三藐三菩提。皆不可思议。何以故。诸佛子。十方世界。一切诸佛。知诸众生。乐欲不同。随其所应。说法调伏。如是乃至等法界虚空界。诸佛子。如来于此娑婆世界。诸四天下。种种身。种种名。种种色相。种种修短。种种寿量。种种处所。种种诸根。种种生处。种种语业。种种观察。令诸众生。各别知见。诸佛子。如来于此四天下中。或名一切义成。或名圆满月。或名师子吼。或名释迦牟尼。或名第七仙。或名毗卢遮那。或名瞿昙氏。或名大沙门。或名最胜。或名导师。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下东。次有世界。名为善护。如来于彼。或名金刚。或名自在。或名有智慧。或名难胜。或名云王。或名无诤。或名能为主。或名心欢喜。或名无与等。或名断言论。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下南。次有世界。名为难忍。如来于彼。或名帝释。或名宝称。或名离垢。或名实语。或名能调伏。或名具足喜。或名大名称。或名能利益。或名无边。或名最胜。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下西。次有世界。名为亲慧。如来于彼。或名水天。或名喜见。或名最胜王。或名调伏天。或名真实慧。或名到究竟。或名欢喜。或名法慧。或名所作已办。或名善住。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下北。次有世界。名有师子。如来于彼。或名大牟尼。或名苦行。或名世所尊。或名最胜田。或名一切智。或名善意。或名清净。或名瑿罗跋那。或名最上施。或名苦行得。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下东北方。次有世界。名妙观察。如来于彼。或名调伏魔。或名成就。或名息灭。或名贤天。或名离贪。或名胜慧。或名心平等。或名无能胜。或名智慧音。或名难出现。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下东南方。次有世界。名为喜乐。如来于彼。或名极威严。或名光焰聚。或名遍知。或名秘密。或名解脱。或名性安住。或名如法行。或名净眼王。或名大勇健。或名精进力。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下西南方。次有世界。名甚坚牢。如来于彼或名安住。或名智王。或名圆满。或名不动。或名妙眼。或名顶王。或名自在音。或名一切施。或名持众仙。或名胜须弥。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下西北方。次有世界。名为妙地。如来于彼。或名普遍。或名光焰。或名摩尼髻。或名可忆念。或名无上义。或名常喜乐。或名性清净。或名圆满光。或名修臂。或名住本。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下。次下方有世界。名为焰慧。如来于彼。或名集善根。或名师子相。或名猛利慧。或名金色焰。或名一切知识。或名究竟音。或名作利益。或名到究竟。或名真实天。或名普遍胜。如是等。其数十千。令诸众生。各别知见。诸佛子。此四天下。次上方有世界。名曰持地。如来于彼。或名有智慧。或名清净面。或名觉慧。或名上首。或名行庄严。或名发欢喜。或名意成满。或名如盛火。或名持戒。或名一道。如是等。其数十千。令诸众生。各别知见。诸佛子。此娑婆世界。有百亿四天下。如来于中。有百亿万。种种名号。令诸众生。各别知见。诸佛子。此娑婆世界东。次有世界。名为密训。如来于彼。或名平等。或名殊胜。或名安慰。或名开晓意。或名真实语。或名得自在。或名最胜身。或名大勇猛。或名无等智。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界南。次有世界。名曰丰溢。如来于彼。或名本性。或名勤意。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界西。次有世界。名为离垢。如来于彼。或名意成。或名知道。或名安住本。或名能解缚。或名通达义。或名乐分别。或名最胜见。或名调伏行。或名众苦行。或名具足力。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界北。次有世界。名曰丰乐。如来于彼。或名薝卜华色。或名日藏。或名善住。或名现神通。或名性超迈。或名慧日。或名无碍。或名如月现。或名迅疾风。或名清净身。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界东北方。次有世界。名为摄取。如来于彼。或名永离苦。或名普解脱。或名大伏藏。或名解脱智。或名过去藏。或名宝光明。或名离世间。或名无碍地。或名净信藏。或名心不动。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界东南方。次有世界。名为饶益。如来于彼。或名现光明。或名尽智。或名美音。或名胜根。或名庄严盖。或名精进根。或名到分别彼岸。或名胜定。或名简言辞。或名智慧海。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界西南方。次有世界。名为鲜少。如来于彼。或名牟尼主。或名具众宝。或名世解脱。或名遍知根。或名胜言辞。或名明了见。或名根自在。或名大仙师。或名开导业。或名金刚师子。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界西北方。次有世界。名为欢喜。如来于彼。或名妙华聚。或名栴檀盖。或名莲华藏。或名超越诸法。或名法宝。或名复出生。或名净妙盖。或名广大眼。或名有善法。或名专念法。或名网藏。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界。次下方有世界。名为关钥。如来于彼。或名发起焰。或名调伏毒。或名帝释弓。或名无常所。或名觉悟本。或名断增长。或名大速疾。或名常乐施。或名分别道。或名摧伏幢。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。此娑婆世界。次上方有世界。名曰振音。如来于彼。或名勇猛幢。或名无量宝。或名乐大施。或名天光。或名吉兴。或名超境界。或名一切主。或名不退轮。或名离众恶。或名一切智。如是等。百亿万种种名号。令诸众生。各别知见。诸佛子。如娑婆世界。如是。东方百千亿。无数无量。无边无等。不可数不可称。不可思不可量。不可说。尽法界虚空界。诸世界中。如来名号。种种不同。南西北方。四维上下。亦复如是。如世尊昔为菩萨时。以种种谈论。种种语言。种种音声。种种业。种种报。种种处。种种方便。种种根。种种信解。种种地位。而得成熟。亦令众生。如是知见。而为说法

    大方广佛华严经四圣谛品第八

尔时文殊师利菩萨摩诃萨。告诸菩萨言。诸佛子。苦圣谛。此娑婆世界中。或名罪。或名逼迫或名变异。或名攀缘。或名聚。或名刺。或名依根。或名虚诳。或名痈疮处。或名愚夫行。诸佛子苦集圣谛。此娑婆世界中。或名系缚。或名灭坏。或名爱着义。或名妄觉念。或名趣入。或名决定。或名网。或名戏论。或名随行。或名颠倒根。诸佛子。苦灭圣谛。此娑婆世界中。或名无诤。或名离尘。或名寂静。或名无相。或名无没。或名无自性。或名无障碍。或名灭。或名体真实。或名住自性。诸佛子。苦灭道圣谛。此娑婆世界中。或名一乘。或名趣寂。或名导引。或名究竟无分别。或名平等。或名舍担。或名无所趣。或名随圣意。或名仙人行。或名十藏。诸佛子。此娑婆世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼密训世界中。或名营求根。或名不出离。或名系缚本。或名作所不应作。或名普斗诤。或名分析悉无力。或名作所依。或名极苦。或名躁动。或名形状物。诸佛子。所言苦集圣谛者。彼密训世界中。或名顺生死。或名染着。或名烧然。或名流转。或名败坏根。或名续诸有。或名恶行。或名爱着。或名病源。或名分数。诸佛子。所言苦灭圣谛者。彼密训世界中。或名第一义。或名出离。或名可赞叹。或名安隐。或名善入处。或名调伏。或名一分。或名无罪。或名离贪。或名决定。诸佛子。所言苦灭道圣谛者。彼密训世界中。或名猛将。或名上行。或名超出。或名有方便。或名平等眼。或名离边。或名了悟。或名摄取。或名最胜眼。或名观方。诸佛子。密训世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼最胜世界中。或名恐怖。或名分段。或名可厌恶。或名须承事。或名变异。或名招引怨。或名能欺夺。或名难共事。或名妄分别。或名有势力。诸佛子。所言苦集圣谛者。彼最胜世界中。或名败坏。或名痴根。或名大怨。或名利刃。或名灭味。或名仇对。或名非己物。或名恶导引。或名增黑闇。或名坏善利。诸佛子。所言苦灭圣谛者。彼最胜世界中。或名大义。或名饶益。或名义中义。或名无量。或名所应见。或名离分别。或名最上调伏。或名常平等。或名可同住。或名无为。诸佛子。所言苦灭道圣谛者。彼最胜世界中。或名能烧然。或名最上品。或名决定。或名无能破。或名深方便。或名出离。或名不下劣。或名通达。或名解脱性。或名能度脱。诸佛子。最胜世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏诸佛子。此娑婆世界。所言苦圣谛者。彼离垢世界中。或名悔恨。或名资待。或名展转。或名住城。或名一味。或名非法。或名居宅。或名妄着处。或名虚妄见。或名无有数。诸佛子。所言苦集圣谛者。彼离垢世界中。或名无实物。或名但有语。或名非洁白。或名生地。或名执取。或名鄙贱。或名增长。或名重担。或名能生。或名粗犷。诸佛子。所言苦灭圣谛者。彼离垢世界中。或名无等等。或名普除尽。或名离垢。或名最胜根。或名称会。或名无资待。或名灭惑。或名最上。或名毕竟。或名破印。诸佛子。所言苦灭道圣谛者。彼离垢世界中。或名坚固物。或名方便分。或名解脱本。或名本性实。或名不可毁。或名最清净。或名诸有边。或名受寄全。或名作究竟。或名净分别。诸佛子。离垢世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼丰溢世界中。或名爱染处。或名险害根。或名有海分。或名积集成。或名差别根。或名增长。或名生灭。或名障碍。或名刀剑本。或名数所成。诸佛子。所言苦集圣谛者。彼丰溢世界中。或名可恶。或名名字。或名无尽。或名分数。或名不可爱。或名能攫噬。或名粗鄙物。或名爱着。或名器。或名动。诸佛子。所言苦灭圣谛者。彼丰溢世界中。或名相续断。或名开显。或名无文字。或名无所修。或名无所见。或名无所作。或名寂灭。或名已烧尽。或名舍重担。或名已除坏。诸佛子。所言苦灭道圣谛者。彼丰溢世界中。或名寂灭行。或名出离行。或名勤修证。或名安隐去。或名无量寿。或名善了知。或名究竟道。或名难修习。或名至彼岸。或名无能胜。诸佛子。丰溢世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼摄取世界中。或名能劫夺。或名非善友。或名多恐怖。或名种种戏论。或名地狱性。或名非实义。或名贪欲担。或名深重根。或名随心转。或名根本空。诸佛子。所言苦集圣谛者。彼摄取世界中。或名贪着。或名恶成辨。或名过恶。或名速疾。或名能执取。或名想。或名有果。或名无可说。或名无可取。或名流转。诸佛子。所言苦灭圣谛者彼摄取世界中。或名不退转。或名离言说。或名无相状。或名可欣乐。或名坚固。或名上妙。或名离痴。或名灭尽。或名远恶。或名出离。诸佛子。所言苦灭道圣谛者。彼摄取世界中。或名离言。或名无诤。或名教导。或名善回向。或名大善巧。或名差别方便。或名如虚空。或名寂静行。或名胜智。或名能了义。诸佛子。摄取世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼饶益世界中。或名重担。或名不坚。或名如贼。或名老死。或名爱所成。或名流转。或名疲劳。或名恶相状。或名生长。或名利刃。诸佛子。所言苦集圣谛者。彼饶益世界中。或名败坏。或名浑浊。或名退失。或名无力。或名丧失。或名乖违。或名不和合。或名所作。或名取。或名意欲。诸佛子。所言苦灭圣谛者。彼饶益世界中。或名出狱。或名真实。或名离难。或名覆护。或名离恶。或名随顺。或名根本。或名舍因。或名无为。或名无相续。诸佛子。所言苦灭道圣谛者。彼饶益世界中。或名达无所有。或名一切印。或名三昧藏。或名得光明。或名不退法。或名能尽有。或名广大路。或名能调伏。或名有安隐。或名不流转根。诸佛子。饶益世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼鲜少世界中。或名险乐欲。或名系缚处。或名邪行。或名随受。或名无惭耻。或名贪欲根。或名恒河流。或名常破坏。或名炬火性。或名多忧恼。诸佛子。所言苦集圣谛者。彼鲜少世界中。或名广地。或名能趣。或名远慧。或名留难。或名恐怖。或名放逸。或名摄取。或名著处。或名宅主。或名连缚。诸佛子。所言苦灭圣谛者。彼鲜少世界中。或名充满。或名不死。或名无我。或名无自性。或名分别尽。或名安乐住。或名无限量。或名断流转。或名绝行处。或名不二。诸佛子。所言苦灭道圣谛者。彼鲜少世界中。或名大光明。或名演说海。或名拣择义。或名和合法。或名离取着。或名断相续。或名广大路。或名平等因。或名净方便。或名最胜见。诸佛子。鲜少世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏诸佛子。此娑婆世界。所言苦圣谛者。彼欢喜世界中。或名流转。或名出生。或名染着。或名重担。或名差别。或名内险。或名集会。或名恶舍宅。或名苦恼性。诸佛子。所言苦集圣谛者。彼欢喜世界中。或名地。或名方便。或名非时。或名非实法。或名无底。或名摄取。或名离戒。或名烦恼法。或名狭劣见。或名垢聚。诸佛子。所言苦灭圣谛者。彼欢喜世界中。或名破依止。或名不放逸。或名真实。或名平等。或名善净。或名无病。或名无曲。或名无相。或名自在。或名无生。诸佛子。所言苦灭道圣谛者。彼欢喜世界中。或名入胜界。或名断集。或名超等类。或名广大性。或名分别尽。或名神力道。或名众方便。或名正念行。或名常寂路。或名摄解脱。诸佛子。欢喜世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏诸佛子。此娑婆世界。所言苦圣谛者。彼关钥世界中。或名败坏相。或名如坏器。或名我所成。或名诸趣身。或名数流转。或名众恶门或名性苦。或名可弃舍。或名无味。或名来去诸佛子。所言苦集圣谛者。彼关钥世界中。或名行。或名愤毒。或名和合。或名受支。或名我心。或名杂毒。或名虚称。或名乖违。或名热恼。或名惊骇。诸佛子。所言苦灭圣谛者。彼关钥世界中。或名无积集。或名不可得。或名妙药。或名不可坏。或名无著。或名无量。或名广大。或名觉分。或名离染。或名无障碍。诸佛子。所言苦灭道圣谛者。彼关钥世界中。或名安隐行。或名离欲。或名究竟实。或名入义。或名性究竟。或名净现。或名摄念。或名趣解脱。或名救济。或名胜行。诸佛子。关钥世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。此娑婆世界。所言苦圣谛者。彼振音世界中。或名匿疵。或名世间。或名所依。或名傲慢。或名染着性。或名驶流。或名不可乐。或名覆藏。或名速灭。或名难调。诸佛子。所言苦集圣谛者。彼振音世界中。或名须制伏。或名心趣。或名能缚。或名随念起。或名至后边。或名共和合。或名分别。或名门。或名飘动。或名隐覆诸佛子。所言苦灭圣谛者。彼振音世界中。或名无依处。或名不可取。或名转还。或名离诤。或名小。或名大。或名善净。或名无尽。或名广博。或名无等价。诸佛子。所言苦灭道圣谛者。彼振音世界中。或名观察。或名能摧敌。或名了知印。或名能入性。或名难敌对。或名无限义。或名能入智。或名和合道。或名恒不动。或名殊胜义。诸佛子。振音世界。说四圣谛。有如是等。四百亿十千名。随众生心。悉令调伏

诸佛子。如此娑婆世界中。说四圣谛。有四百亿十千名。如是。东方百千亿。无数无量。无边无等。不可数不可称。不可思不可量。不可说。尽法界虚空界。所有世界。彼一一世界中。说四圣谛。亦各有四百亿十千名随众生心。悉令调伏。如东方。南西北方。四维上下。亦复如是。诸佛子。如娑婆世界。有如上所说。十方世界。彼一切世界。亦各有如是。十方世界。一一世界中。说苦圣谛。有百亿万种名。说集圣谛。灭圣谛。道圣谛。亦各有百亿万种名。皆随众生。心之所乐。令其调伏

大方广佛华严经卷第十二大方广佛华严经卷第十三

        于阗国三藏实叉难陀奉　制译

    光明觉品第九

尔时世尊。从两足轮下。放百亿光明。照此三千大千世界。百亿阎浮提。百亿弗婆提。百亿瞿耶尼。百亿郁单越。百亿大海。百亿轮围山。百亿菩萨受生。百亿菩萨出家。百亿如来成正觉。百亿如来转法轮。百亿如来入涅槃。百亿须弥山王。百亿四天王众天。百亿三十三天。百亿夜摩天。百亿兜率天。百亿化乐天。百亿他化自在天。百亿梵众天。百亿光音天。百亿遍净天。百亿广果天。百亿色究竟天。其中所有。悉皆明现。如此处见佛世尊。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。其百亿阎浮提中。百亿如来。亦如是坐。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其名曰文殊师利菩萨。觉首菩萨。财首菩萨。宝首菩萨。功德首菩萨。目首菩萨。精进首菩萨。法首菩萨。智首菩萨。贤首菩萨。是诸菩萨。所从来国。所谓金色世界。妙色世界。莲华色世界。薝卜华色世界。优钵罗华色世界。金色世界。宝色世界。金刚色世界。玻璃色世界。平等色世界。此诸菩萨。各于佛所净修梵行。所谓。不动智佛。无碍智佛。解脱智佛。威仪智佛。明相智佛。究竟智佛。最胜智佛。自在智佛。梵智佛。观察智佛。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  若有见正觉　　解脱离诸漏
  不着一切世　　彼非证道眼
  若有知如来　　体相无所有
  修习得明了　　此人疾作佛
  能见此世界　　其心不摇动
  于佛身亦然　　当成胜智者
  若于佛及法　　其心了平等
  二念不现前　　当践难思位
  若见佛及身　　平等而安住
  无住无所入　　当成难遇者
  色受无有数　　想行识亦然
  若能如是知　　当作大牟尼
  世及出世见　　一切皆超越
  而能善知法　　当成大光耀
  若于一切智　　发生回向心
  见心无所生　　当获大名称
  众生无有生　　亦复无有坏
  若得如是智　　当成无上道
  一中解无量　　无量中解一
  了彼亘生起　　当成无所畏

尔时光明过此世界。遍照东方。十佛国土。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。如此处见佛世尊。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。彼一一世界中。各有百亿阎浮提。百亿如来。亦如是坐。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  众生无智慧　　爱刺所伤毒
  为彼求菩提　　诸佛法如是
  普见于诸法　　二边皆舍离
  道成永不退　　转此无等轮
  不可思议劫　　精进修诸行
  为度诸众生　　此是大仙力
  导师降众魔　　勇健无能胜
  光中演妙义　　慈悲故如是
  以彼智慧心　　破诸烦恼障
  一念见一切　　此是佛神力
  击于正法鼓　　觉寤十方刹
  咸令向菩提　　自在力能尔
  不坏无边境　　而游诸亿刹
  于有无所著　　彼自在如佛
  诸佛如虚空　　究竟常清净
  忆念生欢喜　　彼诸愿具足
  一一地狱中　　经于无量劫
  为度众生故　　而能忍是苦
  不惜于身命　　常护诸佛法
  无我心调柔　　能得如来道

尔时光明过十世界。遍照东方百世界。南西北方。四维上下。亦复如是。彼诸世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  佛了法如幻　　通达无障碍
  心净离众着　　调伏诸群生
  或有见初生　　妙色如金山
  住是最后身　　永作人中月
  或见经行时　　具无量功德
  念慧皆善巧　　丈夫师子步
  或见绀青目　　观察于十方
  有时现戏笑　　为顺众生欲
  或见师子吼　　殊胜无比身
  示现最后生　　所说无非实
  或有见出家　　解脱一切缚
  修治诸佛行　　常乐观寂灭
  或见坐道场　　觉知一切法
  到功德彼岸　　痴暗烦恼尽
  或见胜丈夫　　具足大悲心
  转于妙法轮　　度无量众生
  或见师子吼　　威光最殊特
  超一切世间　　神通力无等
  或见心寂静　　如世灯永灭
  种种现神通　　十力能如是

尔时光明过百世界。遍照东方千世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  佛于甚深法　　通达无与等
  众生不能了　　次第为开示
  我性未曾有　　我所亦空寂
  云何诸如来　　而得有其身
  解脱明行者　　无数无等伦
  世间诸因量　　求过不可得
  佛非世间蕴　　界处生死法
  数法不能成　　故号人师子
  其性本空寂　　内外俱解脱
  离一切妄念　　无等法如是
  体性常不动　　无我无来去
  而能寤世间　　无边悉调伏
  常乐观寂灭　　一相无有二
  其心不增减　　现无量神力
  不作诸众生　　业报因缘行
  而能了无碍　　善逝法如是
  种种诸众生　　流转于十方
  如来不分别　　度脱无边类
  诸佛真金色　　非有遍诸有
  随众生心乐　　为说寂灭法

尔时光明过千世界。遍照东方十千世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  发起大悲心　　救护诸众生
  永出人天众　　如是业应作
  意常信乐佛　　其心不退转
  亲近诸如来　　如是业应作
  志乐佛功德　　其心永不退
  住于清凉慧　　如是业应作
  一切威仪中　　常念佛功德
  昼夜无暂断　　如是业应作
  观无边三世　　学彼佛功德
  常无厌倦心　　如是业应作
  观身如实相　　一切皆寂灭
  离我无我着　　如是业应作
  等观众生心　　不起诸分别
  入于真实境　　如是业应作
  悉举无边界　　普饮一切海
  此神通智力　　如是业应作
  思惟诸国土　　色与非色相
  一切悉能知　　如是业应作
  十方国土尘　　一尘为一佛
  悉能知其数　　如是业应作

尔时光明过十千世界。遍照东方。百千世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等

尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  若以威德色种族　　而见人中调御师
  是为病眼颠倒见　　彼不能知最胜法
  如来色形诸相等　　一切世间莫能测
  亿那由劫共思量　　色相威德转无边
  如来非以相为体　　但是无相寂灭法
  身相威仪悉具足　　世间随乐皆得见
  佛法微妙难可量　　一切言说莫能及
  非是和合非不合　　体性寂灭无诸相
  佛身无生超戏论　　非是蕴聚差别法
  得自在力决定见　　所行无畏离言道
  身心悉平等　　内外皆解脱
  永劫住正念　　无著无所系
  意净光明者　　所行无染着
  智眼靡不周　　广大利众生
  一身为无量　　无量复为一
  了知诸世间　　现形遍一切
  此身无所从　　亦无所积聚
  众生分别故　　见佛种种身
  心分别世间　　是心无所有
  如来知此法　　如是见佛身

尔时光明过百千世界。遍照东方。百万世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等

尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  如来最自在　　超世无所依
  具一切功德　　度脱于诸有
  无染无所著　　无想无依止
  体性不可量　　见者咸称叹
  光明遍清净　　尘累悉蠲涤
  不动离二边　　此是如来智
  若有见如来　　身心离分别
  则于一切法　　永出诸疑滞
  一切世间中　　处处转法轮
  无性无所转　　导师方便说
  于法无疑惑　　永绝诸戏论
  不生分别心　　是念佛菩提
  了知差别法　　不着于言说
  无有一与多　　是名随佛教
  多中无一性　　一亦无有多
  如是二俱舍　　普入佛功德
  众生及国土　　一切皆寂灭
  无依无分别　　能入佛菩提
  众生及国土　　一异不可得
  如是善观察　　名知佛法义

尔时光明过百万世界。遍照东方。一亿世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。各见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  智慧无等法无边　　超诸有海到彼岸
  寿量光明悉无比　　此功德者方便力
  所有佛法皆明了　　常观三世无厌倦
  虽缘境界不分别　　此难思者方便力
  乐观众生无生想　　普见诸趣无趣想
  恒住禅寂不系心　　此无碍慧方便力
  善巧通达一切法　　正念勤修涅槃道
  乐于解脱离不平　　此寂灭人方便力
  有能劝向佛菩提　　趣如法界一切智
  善化众生入于谛　　此住佛心方便力
  佛所说法皆随入　　广大智慧无所碍
  一切处行悉已臻　　此自在修方便力
  恒住涅槃如虚空　　随心化现靡不周
  此依无相而为相　　到难到者方便力
  昼夜日月及年劫　　世界始终成坏相
  如是忆念悉了知　　此时数智方便力
  一切众生有生灭　　色与非色想非想
  所有名字悉了知　　此住难思方便力
  过去现在未来世　　所有言说皆能了
  而知三世悉平等　　此无比解方便力

尔时光明过一亿世界。遍照东方。十亿世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等

尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  广大苦行皆修习　　日夜精勤无厌怠
  已度难度师子吼　　普化众生是其行
  众生流转爱欲海　　无明网覆大忧迫
  至仁勇猛悉断除　　誓亦当然是其行
  世间放逸着五欲　　不实分别受众苦
  奉行佛教常摄心　　誓度于斯是其行
  众生着我入生死　　求其边际不可得
  普事如来获妙法　　为彼宣说是其行
  众生无怙病所缠　　常沦恶趣起三毒
  大火猛焰恒烧热　　净心度彼是其行
  众生迷惑失正道　　常行邪径入闇宅
  为彼大然正法灯　　永作照明是其行
  众生漂溺诸有海　　忧难无涯不可处
  为彼兴造大法船　　皆令得度是其行
  众生无知不见本　　迷惑痴狂险难中
  佛哀愍彼建法桥　　正念令升是其行
  见诸众生在险道　　老病死苦常逼迫
  修诸方便无限量　　誓当悉度是其行
  闻法信解无疑惑　　了性空寂不惊怖
  随形六道遍十方　　普教群迷是其行

尔时光明过十亿世界。遍照东方。百亿世界。千亿世界。百千亿世界。那由他亿世界。百那由他亿世界。千那由他亿世界。百千那由他亿世界。如是。无数无量。无边无等。不可数不可称。不可思不可量。不可说。尽法界。虚空界。所有世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有。悉皆明现。彼一一阎浮提中。悉见如来。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹。微尘数诸菩萨俱。来诣佛所。其大菩萨。谓文殊师利等。所从来国。谓金色世界等。本所事佛。谓不动智如来等。尔时一切处。文殊师利菩萨。各于佛所。同时发声。说此颂言

  一念普观无量劫　　无去无来亦无住
  如是了知三世事　　超诸方便成十力
  十方无比善名称　　永离诸难常欢喜
  普诣一切国土中　　广为宣扬如是法
  为利众生供养佛　　如其意获相似果
  于一切法悉顺知　　遍十方中现神力
  从初供佛意柔忍　　入深禅定观法性
  普劝众生发道心　　以此速成无上果
  十方求法情无异　　为修功德令满足
  有无二相悉灭除　　此人于佛为真见
  普往十方诸国土　　广说妙法兴义利
  住于实际不动摇　　此人功德同于佛
  如来所转妙法轮　　一切皆是菩提分
  若能闻已悟法性　　如是之人常见佛
  不见十力空如幻　　虽见非见如盲睹
  分别取相不见佛　　毕竟离着乃能见
  众生随业种种别　　十方内外难尽见
  佛身无碍遍十方　　不可尽见亦如是
  譬如空中无量刹　　无来无去遍十方
  生成灭坏无所依　　佛遍虚空亦如是

    大方广佛华严经菩萨问明品第十

尔时文殊师利菩萨。问觉首菩萨言。佛子。心性是一。云何见有种种差别。所谓。往善趣恶趣。诸根满缺受生同异。端正丑陋。苦乐不同。业不知心。心不知业。受不知报。报不知受。心不知受。受不知心。因不知缘。缘不知因。智不知境。境不知智。时觉首菩萨。以颂答曰

  仁今问是义　　为晓悟群蒙
  我如其性答　　惟仁应谛听
  诸法无作用　　亦无有体性
  是故彼一切　　各各不相知
  譬如河中水　　湍流竞奔逝
  各各不相知　　诸法亦如是
  亦如大火聚　　猛焰同时发
  各各不相知　　诸法亦如是
  又如长风起　　遇物咸鼓扇
  各各不相知　　诸法亦如是
  又如众地界　　展转因依住
  各各不相知　　诸法亦如是
  眼耳鼻舌身　　心意诸情根
  以此常流转　　而无能转者
  法性本无生　　示现而有生
  是中无能现　　亦无所现物
  眼耳鼻舌身　　心意诸情根
  一切空无性　　妄心分别有
  如理而观察　　一切皆无性
  法眼不思议　　此见非颠倒
  若实若不实　　若妄若非妄
  世间出世间　　但有假言说

尔时文殊师利菩萨。问财首菩萨言。佛子。一切众生非众生。云何如来。随其时。随其命。随其身。随其行。随其解。随其言论。随其心乐。随其方便。随其思惟。随其观察。于如是诸众生中。为现其身。教化调伏。时财首菩萨。以颂答曰

  此是乐寂灭　　多闻者境界
  我为仁宣说　　仁今应听受
  分别观内身　　此中谁是我
  若能如是解　　彼达我有无
  此身假安立　　住处无方所
  谛了是身者　　于中无所著
  于身善观察　　一切皆明见
  知法皆虚妄　　不起心分别
  寿命因谁起　　复因谁退灭
  犹如旋火轮　　初后不可知
  智者能观察　　一切有无常
  诸法空无我　　永离一切相
  众报随业生　　如梦不真实
  念念常灭坏　　如前后亦尔
  世间所见法　　但以心为主
  随解取众相　　颠倒不如实
  世间所言论　　一切是分别
  未曾有一法　　得入于法性
  能缘所缘力　　种种法出生
  速灭不暂停　　念念悉如是

尔时文殊师利菩萨。问宝首菩萨言。佛子。一切众生。等有四大。无我无我所。云何而有受苦受乐。端正丑陋。内好外好。少受多受。或受现报。或受后报。然法界中。无美无恶。时宝首菩萨。以颂答曰

  随其所行业　　如是果报生
  作者无所有　　诸佛之所说
  譬如净明镜　　随其所对质
  现像各不同　　业性亦如是
  亦如田种子　　各各不相知
  自然能出生　　业性亦如是
  又如巧幻师　　在彼四衢道
  示现众色相　　业性亦如是
  如机关木人　　能出种种声
  彼无我非我　　业性亦如是
  亦如众鸟类　　从[穀-禾+卵]而得出
  音声各不同　　业性亦如是
  譬如胎藏中　　诸根悉成就
  体相无来处　　业性亦如是
  又如在地狱　　种种诸苦事
  彼悉无所从　　业性亦如是
  譬如转轮王　　成就胜七宝
  来处不可得　　业性亦如是
  又如诸世界　　大火所烧然
  此火无来处　　业性亦如是

尔时文殊师利菩萨。问德首菩萨言。佛子。如来所悟。唯是一法。云何乃说无量诸法。现无量刹。化无量众。演无量音。示无量身。知无量心。现无量神通。普能震动无量世界。示现无量殊胜庄严。显示无边种种境界。而法性中。此差别相。皆不可得。时德首菩萨。以颂答曰

  佛子所问义　　甚深难可了
  智者能知此　　常乐佛功德
  譬如地性一　　众生各别住
  地无一异念　　诸佛法如是
  亦如火性一　　能烧一切物
  火焰无分别　　诸佛法如是
  亦如大海一　　波涛千万异
  水无种种殊　　诸佛法如是
  亦如风性一　　能吹一切物
  风无一异念　　诸佛法如是
  亦如大云雷　　普雨一切地
  雨滴无差别　　诸佛法如是
  亦如地界一　　能生种种芽
  非地有殊异　　诸佛法如是
  如日无云曀　　普照于十方
  光明无异性　　诸佛法如是
  亦如空中月　　世间靡不见
  非月往其处　　诸佛法如是
  譬如大梵王　　应现满三千
  其身无别异　　诸佛法如是

尔时文殊师利菩萨。问目首菩萨言。佛子。如来福田。等一无异。云何而见众生布施。果报不同。所谓。种种色。种种形。种种家。种种根。种种财。种种主。种种眷属。种种官位。种种功德。种种智慧。而佛于彼。其心平等。无异思惟。时目首菩萨。以颂答曰

  譬如大地一　　随种各生芽
  于彼无怨亲　　佛福田亦然
  又如水一味　　因器有差别
  佛福田亦然　　众生心故异
  亦如巧幻师　　能令众欢喜
  佛福田如是　　令众生敬悦
  如有才智王　　能令大众喜
  佛福田如是　　令众悉安乐
  譬如净明镜　　随色而现像
  佛福田如是　　随心获众报
  如阿揭陀药　　能疗一切毒
  佛福田如是　　灭诸烦恼患
  亦如日出时　　照曜于世间
  佛福田如是　　灭除诸黑暗
  亦如净满月　　普照于大地
  佛福田亦然　　一切处平等
  譬如毗蓝风　　普震于大地
  佛福田如是　　动三有众生
  譬如大火起　　能烧一切物
  佛福田如是　　烧一切有为

尔时文殊师利菩萨。问勤首菩萨言。佛子。佛教是一。众生得见。云何不即悉断一切诸烦恼缚。而得出离。然其色蕴。受蕴想蕴。行蕴识蕴。欲界色界。无色界。无明贪爱。无有差别。是则佛教。于诸众生。或有利益。或无利益时勤首菩萨。以颂答曰

  佛子善谛听　　我今如实答
  或有速解脱　　或有难出离
  若欲求除灭　　无量诸过恶
  当于佛法中　　勇猛常精进
  譬如微少火　　樵湿速令灭
  于佛教法中　　懈怠者亦然
  如钻燧求火　　未出而数息
  火势随止灭　　懈怠者亦然
  如人持日珠　　不以物承影
  火终不可得　　懈怠者亦然
  譬如赫日照　　孩稚闭其目
  怪言何不睹　　懈怠者亦然
  如人无手足　　欲以芒草箭
  遍射破大地　　懈怠者亦然
  如以一毛端　　而取大海水
  欲令尽干竭　　懈怠者亦然
  又如劫火起　　欲以少水灭
  于佛教法中　　懈怠者亦然
  如有见虚空　　端居不摇动
  而言普腾蹑　　懈怠者亦然

尔时文殊师利菩萨。问法首菩萨言。佛子。如佛所说。若有众生。受持正法。悉能除断一切烦恼。何故复有受持正法。而不断者。随贪嗔痴。随慢随覆。随忿随恨。随嫉随悭。随诳随谄。势力所转。无有离心。能受持法。何故复于心行之内。起诸烦恼。时法首菩萨。以颂答曰

  佛子善谛听　　所问如实义
  非但以多闻　　能入如来法
  如人水所漂　　惧溺而渴死
  于法不修行　　多闻亦如是
  如人设美膳　　自饿而不食
  于法不修行　　多闻亦如是
  如人善方药　　自疾不能救
  于法不修行　　多闻亦如是
  如人数他宝　　自无半钱分
  于法不修行　　多闻亦如是
  如有生王宫　　而受餧与寒
  于法不修行　　多闻亦如是
  如聋奏音乐　　悦彼不自闻
  于法不修行　　多闻亦如是
  如盲缋众像　　示彼不自见
  于法不修行　　多闻亦如是
  譬如海船师　　而于海中死
  于法不修行　　多闻亦如是
  如在四衢道　　广说众好事
  内自无实德　　不行亦如是

尔时文殊师利菩萨。问智首菩萨言。佛子。于佛法中。智为上首。如来何故。或为众生。赞叹布施。或赞持戒。或赞堪忍。或赞精进。或赞禅定。或赞智慧。或复赞叹慈悲喜舍。而终无有唯以一法。而得出离。成阿耨多罗三藐三菩提者。时智首菩萨。以颂答曰

  佛子甚希有　　能知众生心
  如仁所问义　　谛听我今说
  过去未来世　　现在诸导师
  无有说一法　　而得于道者
  佛知众生心　　性分各不同
  随其所应度　　如是而说法
  悭者为赞施　　毁禁者赞戒
  多嗔为赞忍　　好懈赞精进
  乱意赞禅定　　愚痴赞智慧
  不仁赞慈愍　　怒害赞大悲
  忧戚为赞喜　　曲心赞叹舍
  如是次第修　　渐具诸佛法
  如先立基堵　　而后造宫室
  施戒亦复然　　菩萨众行本
  譬如建城廓　　为护诸人众
  忍进亦如是　　防护诸菩萨
  譬如大力王　　率土咸戴仰
  定慧亦如是　　菩萨所依赖
  亦如转轮王　　能与一切乐
  四等亦如是　　与诸菩萨乐

尔时文殊师利菩萨。问贤首菩萨言。佛子。诸佛世尊。唯以一道。而得出离。云何今见一切佛土。所有众事。种种不同。所谓。世界众生界。说法调伏。寿量光明。神通众会。教仪法住。各有差别。无有不具一切佛法。而成阿耨多罗三藐三菩提者。时贤首菩萨。以颂答曰

  文殊法常尔　　法王唯一法
  一切无碍人　　一道出生死
  一切诸佛身　　唯是一法身
  一心一智慧　　力无畏亦然
  如本趣菩提　　所有回向心
  得如是刹土　　众会及说法
  一切诸佛刹　　庄严悉圆满
  随众生行异　　如是见不同
  佛刹与佛身　　众会及言说
  如是诸佛法　　众生莫能见
  其心已清净　　诸愿皆具足
  如是明达人　　于此乃能睹
  随众生心乐　　及以业果力
  如是见差别　　此佛威神故
  佛刹无分别　　无憎无有爱
  但随众生心　　如是见有殊
  以是于世界　　所见各差别
  非一切如来　　大仙之过咎
  一切诸世界　　所应受化者
  常见人中雄　　诸佛法如是

尔时诸菩萨谓文殊师利菩萨言。佛子。我等所解。各自说已。唯愿仁者。以妙辩才。演畅如来。所有境界。何等是佛境界。何等是佛境界因。何等是佛境界度。何等是佛境界入。何等是佛境界智。何等是佛境界法。何等是佛境界说。何等是佛境界知。何等是佛境界证。何等是佛境界现。何等是佛境界广。时文殊师利菩萨。以颂答曰

  如来深境界　　其量等虚空
  一切众生入　　而实无所入
  如来深境界　　所有胜妙因
  亿劫常宣说　　亦复不能尽
  随其心智慧　　诱进咸令益
  如是度众生　　诸佛之境界
  世间诸国土　　一切皆随入
  智身无有色　　非彼所能见
  诸佛智自在　　三世无所碍
  如是慧境界　　平等如虚空
  法界众生界　　究竟无差别
  一切悉了知　　此是如来境
  一切世间中　　所有诸音声
  佛智皆随了　　亦无有分别
  非识所能识　　亦非心境界
  其性本清净　　开示诸群生
  非业非烦恼　　无物无住处
  无照无所行　　平等行世间
  一切众生心　　普在三世中
  如来于一念　　一切悉明达

尔时此娑婆世界中。一切众生所有法差别。业差别。世间差别。身差别。根差别。受生差别。持戒果差别。犯戒果差别。国土果差别。以佛神力。悉皆明现。如是。东方百千亿那由他。无数无量。无边无等。不可数不可称。不可思不可量。不可说。尽法界虚空界。一切世界中。所有众生。法差别。乃至国土果差别。悉以佛神力故。分明显现。南西北方。四维上下。亦复如是

大方广佛华严经卷第十三大方广佛华严经卷第十四

        于阗国三藏实叉难陀奉　制译

    净行品第十一

尔时智首菩萨。问文殊师利菩萨言。佛子。菩萨云何得无过失身语意业。云何得不害身语意业。云何得不可毁身语意业。云何得不可坏身语意业。云何得不退转身语意业。云何得不可动身语意业。云何得殊胜身语意业。云何得清净身语意业。云何得无染身语意业。云何得智为先导身语意业。云何得生处具足。种族具足。家具足。色具足。相具足。念具足。慧具足。行具足。无畏具足。觉悟具足。云何得胜慧。第一慧。最上慧。最胜慧。无量慧。无数慧。不思议慧。无与等慧。不可量慧。不可说慧。云何得因力。欲力。方便力。缘力所缘力。根力。观察力。奢摩他力。毗钵舍那力。思惟力。云何得蕴善巧。界善巧。处善巧。缘起善巧。欲界善巧。色界善巧。无色界善巧。过去善巧未来善巧。现在善巧。云何善修习念觉分。择法觉分。精进觉分。喜觉分。猗觉分。定觉分。舍觉分。空无相无愿。云何得圆满檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅那波罗蜜。般若波罗蜜。及以圆满慈悲喜舍。云何得处非处智力。过未现在业报智力。根胜劣智力。种种界智力。种种解智力。一切至处道智力。禅解脱三昧染净智力。宿住念智力。无障碍天眼智力。断诸习智力。云何常得天王。龙王。夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王。梵王之所守护。恭敬供养。云何得与一切众生。为依为救。为归为趣。为炬为明。为照为导。为胜导为普导。云何于一切众生中。为第一为大。为胜为最胜。为妙为极妙。为上为无上。为无等为无等等

尔时文殊师利菩萨。告智首菩萨言。善哉佛子。汝今为欲多所饶益。多所安隐。哀愍世间。利乐天人。问如是义。佛子。若诸菩萨。善用其心。则获一切胜妙功德。于诸佛法。心无所碍。住去来今。诸佛之道。随众生住。恒不舍离。如诸法相。悉能通达。断一切恶。具足众善。当如普贤。色像第一。一切行愿。皆得具足。于一切法。无不自在。而为众生第二导师。佛子。云何用心。能获一切胜妙功德。佛子

  菩萨在家　　当愿众生　　知家性空
  免其逼迫　　孝事父母　　当愿众生
  善事于佛　　护养一切　　妻子集会
  当愿众生　　怨亲平等　　永离贪着
  若得五欲　　当愿众生　　拔除欲箭
  究竟安隐　　妓乐聚会　　当愿众生
  以法自娱　　了妓非实　　若在宫室
  当愿众生　　入于圣地　　永除秽欲
  着璎珞时　　当愿众生　　舍诸伪饰
  到真实处　　上升楼阁　　当愿众生
  升正法楼　　彻见一切　　若有所施
  当愿众生　　一切能舍　　心无爱着
  众会聚集　　当愿众生　　舍众聚法
  成一切智　　若在厄难　　当愿众生
  随意自在　　所行无碍　　舍居家时
  当愿众生　　出家无碍　　心得解脱
  入僧伽蓝　　当愿众生　　演说种种
  无乖诤法　　诣大小师　　当愿众生
  巧事师长　　习行善法　　求请出家
  当愿众生　　得不退法　　心无障碍
  脱去俗服　　当愿众生　　勤修善根
  舍诸罪轭　　剃除须发　　当愿众生
  永离烦恼　　究竟寂灭　　着袈裟衣
  当愿众生　　心无所染　　具大仙道
  正出家时　　当愿众生　　同佛出家
  救护一切　　自归于佛　　当愿众生
  绍隆佛种　　发无上意　　自归于法
  当愿众生　　深入经藏　　智慧如海
  自归于僧　　当愿众生　　统理大众
  一切无碍　　受学戒时　　当愿众生
  善学于戒　　不作众恶　　受阇梨教
  当愿众生　　具足威仪　　所行真实
  受和尚教　　当愿众生　　入无生智
  到无依处　　受具足戒　　当愿众生
  具诸方便　　得最胜法　　若入堂宇
  当愿众生　　升无上堂　　安住不动
  若敷床座　　当愿众生　　开敷善法
  见真实相　　正身端坐　　当愿众生
  坐菩提座　　心无所著　　结跏趺坐
  当愿众生　　善根坚固　　得不动地
  修行于定　　当愿众生　　以定伏心
  究竟无余　　若修于观　　当愿众生
  见如实理　　永无乖诤　　舍跏趺坐
  当愿众生　　观诸行法　　悉归散灭
  下足住时　　当愿众生　　心得解脱
  安住不动　　若举于足　　当愿众生
  出生死海　　具众善法　　着下裙时
  当愿众生　　服诸善根　　具足惭愧
  整衣束带　　当愿众生　　检束善根
  不令散失　　若着上衣　　当愿众生
  获胜善根　　至法彼岸　　着僧伽梨
  当愿众生　　入第一位　　得不动法
  手执杨枝　　当愿众生　　皆得妙法
  究竟清净　　嚼杨枝时　　当愿众生
  其心调净　　噬诸烦恼　　大小便时
  当愿众生　　弃贪嗔痴　　蠲除罪法
  事讫就水　　当愿众生　　出世法中
  速疾而往　　洗涤形秽　　当愿众生
  清净调柔　　毕竟无垢　　以水盥掌
  当愿众生　　得清净手　　受持佛法
  以水洗面　　当愿众生　　得净法门
  永无垢染　　手执锡杖　　当愿众生
  设大施会　　示如实道　　执持应器
  当愿众生　　成就法器　　受天人供
  发趾向道　　当愿众生　　趣佛所行
  入无依处　　若在于道　　当愿众生
  能行佛道　　向无余法　　涉路而去
  当愿众生　　履净法界　　心无障碍
  见升高路　　当愿众生　　永出三界
  心无怯弱　　见趣下路　　当愿众生
  其心谦下　　长佛善根　　见斜曲路
  当愿众生　　舍不正道　　永除恶见
  若见直路　　当愿众生　　其心正直
  无谄无诳　　见路多尘　　当愿众生
  远离尘坌　　获清净法　　见路无尘
  当愿众生　　常行大悲　　其心润泽
  若见险道　　当愿众生　　住正法界
  离诸罪难　　若见众会　　当愿众生
  说甚深法　　一切和合　　若见大柱
  当愿众生　　离我诤心　　无有忿恨
  若见丛林　　当愿众生　　诸天及人
  所应敬礼　　若见高山　　当愿众生
  善根超出　　无能至顶　　见棘刺树
  当愿众生　　疾得翦除　　三毒之刺
  见树叶茂　　当愿众生　　以定解脱
  而为荫映　　若见华开　　当愿众生
  神通等法　　如华开敷　　若见树华
  当愿众生　　众相如华　　具三十二
  若见果实　　当愿众生　　获最胜法
  证菩提道　　若见大河　　当愿众生
  得预法流　　入佛智海　　若见陂泽
  当愿众生　　疾悟诸佛　　一味之法
  若见池沼　　当愿众生　　语业满足
  巧能演说　　若见汲井　　当愿众生
  具足辩才　　演一切法　　若见涌泉
  当愿众生　　方便增长　　善根无尽
  若见桥道　　当愿众生　　广度一切
  犹如桥梁　　若见流水　　当愿众生
  得善意欲　　洗除惑垢　　见修园圃
  当愿众生　　五欲圃中　　耘除爱草
  见无忧林　　当愿众生　　永离贪爱
  不生忧怖　　若见园苑　　当愿众生
  勤修诸行　　趣佛菩提　　见严饰人
  当愿众生　　三十二相　　以为严好
  见无严饰　　当愿众生　　舍诸饰好
  具头陀行　　见乐着人　　当愿众生
  以法自娱　　欢爱不舍　　见无乐着
  当愿众生　　有为事中　　心无所乐
  见欢乐人　　当愿众生　　常得安乐
  乐供养佛　　见苦恼人　　当愿众生
  获根本智　　灭除众苦　　见无病人
  当愿众生　　入真实慧　　永无病恼
  见疾病人　　当愿众生　　知身空寂
  离乖诤法　　见端正人　　当愿众生
  于佛菩萨　　常生净信　　见丑陋人
  当愿众生　　于不善事　　不生乐着
  见报恩人　　当愿众生　　于佛菩萨
  能知恩德　　见背恩人　　当愿众生
  于有恶人　　不加其报　　若见沙门
  当愿众生　　调柔寂静　　毕竟第一
  见婆罗门　　当愿众生　　永持梵行
  离一切恶　　见苦行人　　当愿众生
  依于苦行　　至究竟处　　见操行人
  当愿众生　　坚持志行　　不舍佛道
  见着甲胄　　当愿众生　　常服善铠
  趣无师法　　见无铠仗　　当愿众生
  永离一切　　不善之业　　见论议人
  当愿众生　　于诸异论　　悉能摧伏
  见正命人　　当愿众生　　得清净命
  不矫威仪　　若见于王　　当愿众生
  得为法王　　恒转正法　　若见王子
  当愿众生　　从法化生　　而为佛子
  若见长者　　当愿众生　　善能明断
  不行恶法　　若见大臣　　当愿众生
  恒守正念　　习行众善　　若见城廓
  当愿众生　　得坚固身　　心无所屈
  若见王都　　当愿众生　　功德共聚
  心恒喜乐　　见处林薮　　当愿众生
  应为天人　　之所叹仰　　入里乞食
  当愿众生　　入深法界　　心无障碍
  到人门户　　当愿众生　　入于一切
  佛法之门　　入其家已　　当愿众生
  得入佛乘　　三世平等　　见不舍人
  当愿众生　　常不舍离　　胜功德法
  见能舍人　　当愿众生　　永得舍离
  三恶道苦　　若见空钵　　当愿众生
  其心清净　　空无烦恼　　若见满钵
  当愿众生　　具足成满　　一切善法
  若得恭敬　　当愿众生　　恭敬修行
  一切佛法　　不得恭敬　　当愿众生
  不行一切　　不善之法　　见惭耻人
  当愿众生　　具惭耻行　　藏护诸根
  见无惭耻　　当愿众生　　舍离无惭
  住大慈道　　若得美食　　当愿众生
  满足其愿　　心无羡欲　　得不美食
  当愿众生　　莫不获得　　诸三昧味
  得柔软食　　当愿众生　　大悲所熏
  心意柔软　　得粗涩食　　当愿众生
  心无染着　　绝世贪爱　　若饭食时
  当愿众生　　禅悦为食　　法喜充满
  若受味时　　当愿众生　　得佛上味
  甘露满足　　饭食已讫　　当愿众生
  所作皆辨　　具诸佛法　　若说法时
  当愿众生　　得无尽辩　　广宣法要
  从舍出时　　当愿众生　　深入佛智
  永出三界　　若入水时　　当愿众生
  入一切智　　知三世等　　洗浴身体
  当愿众生　　身心无垢　　内外光洁
  盛暑炎毒　　当愿众生　　舍离众恼
  一切皆尽　　暑退凉初　　当愿众生
  证无上法　　究竟清凉　　讽诵经时
  当愿众生　　顺佛所说　　总持不忘
  若得见佛　　当愿众生　　得无碍眼
  见一切佛　　谛观佛时　　当愿众生
  皆如普贤　　端正严好　　见佛塔时
  当愿众生　　尊重如塔　　受天人供
  敬心观塔　　当愿众生　　诸天及人
  所共瞻仰　　顶礼于塔　　当愿众生
  一切天人　　无能见顶　　右绕于塔
  当愿众生　　所行无逆　　成一切智
  绕塔三匝　　当愿众生　　勤求佛道
  心无懈歇　　赞佛功德　　当愿众生
  众德悉具　　称叹无尽　　赞佛相好
  当愿众生　　成就佛身　　证无相法
  若洗足时　　当愿众生　　具神足力
  所行无碍　　以时寝息　　当愿众生
  身得安隐　　心无动乱　　睡眠始寤
  当愿众生　　一切智觉　　周顾十方

佛子若诸菩萨。如是用心。则获一切胜妙功德。一切世间。诸天魔梵。沙门婆罗门。乾闼婆。阿修罗等。及以一切声闻缘觉。所不能动

    大方广佛华严经贤首品第十二之一

尔时文殊师利菩萨。说无浊乱清净行。大功德已。欲显示菩提心功德故。以偈问贤首菩萨曰

  我今已为诸菩萨　　说佛往修清净行
  仁亦当于此会中　　演畅修行胜功德

尔时贤首菩萨。以偈答曰

  善哉仁者应谛听　　彼诸功德不可量
  我今随力说少分　　犹如大海一滴水
  若有菩萨初发心　　誓求当证佛菩提
  彼之功德无边际　　不可称量无与等
  何况无量无边劫　　具修地度诸功德
  十方一切诸如来　　悉共称扬不能尽
  如是无边大功德　　我今于中说少分
  譬如鸟足所履空　　亦如大地一微尘
  菩萨发意求菩提　　非是无因无有缘
  于佛法僧生净信　　以是而生广大心
  不求五欲及王位　　富饶自乐大名称
  但为永灭众生苦　　利益世间而发心
  常欲利乐诸众生　　庄严国土供养佛
  受持正法修诸智　　证菩提故而发心
  深心信解常清净　　恭敬尊重一切佛
  于法及僧亦如是　　至诚供养而发心
  深信于佛及佛法　　亦信佛子所行道
  及信无上大菩提　　菩萨以是初发心
  信为道元功德母　　长养一切诸善法
  断除疑网出爱流　　开示涅槃无上道
  信无垢浊心清净　　灭除憍慢恭敬本
  亦为法藏第一财　　为清净手受众行
  信能惠施心无吝　　信能欢喜入佛法
  信能增长智功德　　信能必到如来地
  信令诸根净明利　　信力坚固无能坏
  信能永灭烦恼本　　信能专向佛功德
  信于境界无所著　　远离诸难得无难
  信能超出众魔路　　示现无上解脱道
  信为功德不坏种　　信能生长菩提树
  信能增益最胜智　　信能示现一切佛
  是故依行说次第　　信乐最胜甚难得
  譬如一切世间中　　而有随意妙宝珠
  若常信奉于诸佛　　则能持戒修学处
  若常持戒修学处　　则能具足诸功德
  戒能开发菩提本　　学是勤修功德地
  于戒及学常顺行　　一切如来所称美
  若常信奉于诸佛　　则能兴集大供养
  若能兴集大供养　　彼人信佛不思议
  若常信奉于尊法　　则闻佛法无厌足
  若闻佛法无厌足　　彼人信法不思议
  若常信奉清净僧　　则得信心不退转
  若得信心不退转　　彼人信力无能动
  若得信力无能动　　则得诸根净明利
  若得诸根净明利　　则能远离恶知识
  若能远离恶知识　　则得亲近善知识
  若得亲近善知识　　则能修集广大善
  若能修集广大善　　彼人成就大因力
  若人成就大因力　　则得殊胜决定解
  若得殊胜决定解　　则为诸佛所护念
  若为诸佛所护念　　则能发起菩提心
  若能发起菩提心　　则能勤修佛功德
  若能勤修佛功德　　则得生在如来家
  若得生在如来家　　则善修行巧方便
  若善修行巧方便　　则得信乐心清净
  若得信乐心清净　　则得增上最胜心
  若得增上最胜心　　则常修习波罗蜜
  若常修习波罗蜜　　则能具足摩诃衍
  若能具足摩诃衍　　则能如法供养佛
  若能如法供养佛　　则能念佛心不动
  若能念佛心不动　　则常睹见无量佛
  若常睹见无量佛　　则见如来体常住
  若见如来体常住　　则能知法永不灭
  若能知法永不灭　　则得辩才无障碍
  若得辩才无障碍　　则能开演无边法
  若能开演无边法　　则能慈愍度众生
  若能慈愍度众生　　则得坚固大悲心
  若得坚固大悲心　　则能爱乐甚深法
  若能爱乐甚深法　　则能舍离有为过
  若能舍离有为过　　则离憍慢及放逸
  若离憍慢及放逸　　则能兼利一切众
  若能兼利一切众　　则处生死无疲厌
  若处生死无疲厌　　则能勇健无能胜
  若能勇健无能胜　　则能发起大神通
  若能发起大神通　　则知一切众生行
  若知一切众生行　　则能成就诸群生
  若能成就诸群生　　则得善摄众生智
  若得善摄众生智　　则能成就四摄法
  若能成就四摄法　　则与众生无限利
  若与众生无限利　　则具最胜智方便
  若具最胜智方便　　则住勇猛无上道
  若住勇猛无上道　　则能摧殄诸魔力
  若能摧殄诸魔力　　则能超出四魔境
  若能超出四魔境　　则得至于不退地
  若得至于不退地　　则得无生深法忍
  若得无生深法忍　　则为诸佛所授记
  若为诸佛所授记　　则一切佛现其前
  若一切佛现其前　　则了神通深密用
  若了神通深密用　　则为诸佛所忆念
  若为诸佛所忆念　　则以佛德自庄严
  若以佛德自庄严　　则获妙福端严身
  若获妙福端严身　　则身晃耀如金山
  若身晃耀如金山　　则相庄严三十二
  若相庄严三十二　　则具随好为严饰
  若具随好为严饰　　则身光明无限量
  若身光明无限量　　则不思议光庄严
  若不思议光庄严　　其光则出诸莲华
  其光若出诸莲华　　则无量佛坐华上
  示现十方靡不遍　　悉能调伏诸众生
  若能如是调众生　　则现无量神通力
  若现无量神通力　　则住不可思议土
  演说不可思议法　　令不思议众欢喜
  若说不可思议法　　令不思议众欢喜
  则以智慧辩才力　　随众生心而化诱
  若以智慧辩才力　　随众生心而化诱
  则以智慧为先导　　身语意业恒无失
  若以智慧为先导　　身语意业恒无失
  则其愿力得自在　　普随诸趣而现身
  若其愿力得自在　　普随诸趣而现身
  则能为众说法时　　音声随类难思议
  若能为众说法时　　音声随类难思议
  则于一切众生心　　一念悉知无有余
  若于一切众生心　　一念悉知无有余
  则知烦恼无所起　　永不没溺于生死
  若知烦恼无所起　　永不没溺于生死
  则获功德法性身　　以法威力现世间
  若获功德法性身　　以法威力现世间
  则获十地十自在　　修行诸度胜解脱
  若获十地十自在　　修行诸度胜解脱
  则获灌顶大神通　　住于最胜诸三昧
  若获灌顶大神通　　住于最胜诸三昧
  则于十方诸佛所　　应受灌顶而升位
  若于十方诸佛所　　应受灌顶而升位
  则蒙十方一切佛　　手以甘露灌其顶
  若蒙十方一切佛　　手以甘露灌其顶
  则身充遍如虚空　　安住不动满十方
  若身充遍如虚空　　安住不动满十方
  则彼所行无与等　　诸天世人莫能知
  菩萨勤修大悲行　　愿度一切无不果
  见闻听受若供养　　靡不皆令获安乐
  彼诸大士威神力　　法眼常全无缺减
  十善妙行等诸道　　无上胜宝皆令现
  譬如大海金刚聚　　以彼威力生众宝
  无减无增亦无尽　　菩萨功德聚亦然
  或有刹土无有佛　　于彼示现成正觉
  或有国土不知法　　于彼为说妙法藏
  无有分别无功用　　于一念顷遍十方
  如月光影靡不周　　无量方便化群生
  于彼十方世界中　　念念示现成佛道
  转正法轮入寂灭　　乃至舍利广分布
  或现声闻独觉道　　或现成佛普庄严
  如是开阐三乘教　　广度众生无量劫
  或现童男童女形　　天龙及以阿修罗
  乃至摩睺罗伽等　　随其所乐悉令见
  众生形相各不同　　行业音声亦无量
  如是一切皆能现　　海印三昧威神力
  严净不可思议刹　　供养一切诸如来
  放大光明无有边　　度脱众生亦无限
  智慧自在不思议　　说法言辞无有碍
  施戒忍进及禅定　　智慧方便神通等
  如是一切皆自在　　以佛华严三昧力
  一微尘中入三昧　　成就一切微尘定
  而彼微尘亦不增　　于一普现难思刹
  彼一尘内众多刹　　或有有佛或无佛
  或有杂染或清净　　或有广大或狭小
  或复有成或有坏　　或有正住或傍住
  或如旷野热时焰　　或如天上因陀网
  如一尘中所示现　　一切微尘悉亦然
  此大名称诸圣人　　三昧解脱神通力
  若欲供养一切佛　　入于三昧起神变
  能以一手遍三千　　普供一切诸如来
  十方所有胜妙华　　涂香末香无价宝
  如是皆从手中出　　供养道树诸最胜
  无价宝衣杂妙香　　宝幢幡盖皆严好
  真金为华宝为帐　　莫不皆从掌中雨
  十方所有诸妙物　　应可奉献无上尊
  掌中悉雨无不备　　菩提树前持供佛
  十方一切诸妓乐　　钟鼓琴瑟非一类
  悉奏和雅妙音声　　靡不从于掌中出
  十方所有诸赞颂　　称叹如来实功德
  如是种种妙言辞　　皆从掌内而开演
  菩萨右手放净光　　光中香水从空雨
  普洒十方诸佛土　　供养一切照世灯
  又放光明妙庄严　　出生无量宝莲华
  其华色相皆殊妙　　以此供养于诸佛
  又放光明华庄严　　种种妙华集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明香庄严　　种种妙香集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明末香严　　种种末香聚为帐
  普散十方诸国土　　供养一切大德尊
  又放光明衣庄严　　种种名衣集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明宝庄严　　种种妙宝集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明莲庄严　　种种莲华集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明璎庄严　　种种妙璎集为帐
  普散十方诸国土　　供养一切大德尊
  又放光明幢庄严　　其幢绚焕备众色
  种种无量皆殊好　　以此庄严诸佛土
  种种杂宝庄严盖　　众妙缯幡共垂饰
  摩尼宝铎演佛音　　执持供养诸如来
  手出供具难思议　　如是供养一导师
  一切佛所皆如是　　大士三昧神通力
  菩萨住在三昧中　　种种自在摄众生
  悉以所行功德法　　无量方便而开诱
  或以供养如来门　　或以难思布施门
  或以头陀持戒门　　或以不动堪忍门
  或以苦行精进门　　或以寂静禅定门
  或以决了智慧门　　或以所行方便门
  或以梵住神通门　　或以四摄利益门
  或以福智庄严门　　或以因缘解脱门
  或以根力正道门　　或以声闻解脱门
  或以独觉清净门　　或以大乘自在门
  或以无常众苦门　　或以无我寿者门
  或以不净离欲门　　或以灭尽三昧门
  随诸众生病不同　　悉以法药而对治
  随诸众生心所乐　　悉以方便而满足
  随诸众生行差别　　悉以善巧而成就
  如是三昧神通相　　一切天人莫能测
  有妙三昧名随乐　　菩萨住此普观察
  随宜示现度众生　　悉使欢心从法化
  劫中饥馑灾难时　　悉与世间诸乐具
  随其所欲皆令满　　普为众生作饶益
  或以饮食上好味　　宝衣严具众妙物
  乃至王位皆能舍　　令好施者悉从化
  或以相好庄严身　　上妙衣服宝璎珞
  华鬘为饰香涂体　　威仪具足度众生
  一切世间所好尚　　色相颜容及衣服
  随应普现惬其心　　俾乐色者皆从道
  迦陵频伽美妙音　　俱枳罗等妙音声
  种种梵音皆具足　　随其心乐为说法
  八万四千诸法门　　诸佛以此度众生
  彼亦如其差别法　　随世所宜而化度
  众生苦乐利衰等　　一切世间所作法
  悉能应现同其事　　以此普度诸众生
  一切世间众苦患　　深广无涯如大海
  与彼同事悉能忍　　令其利益得安乐
  若有不识出离法　　不求解脱离諠愦
  菩萨为现舍国财　　常乐出家心寂静
  家是贪爱系缚所　　欲使众生悉免离
  故示出家得解脱　　于诸欲乐无所受
  菩萨示行十种行　　亦行一切大人法
  诸仙行等悉无余　　为欲利益众生故
  若有众生寿无量　　烦恼微细乐具足
  菩萨于中得自在　　示受老病死众患
  或有贪欲嗔恚痴　　烦恼猛火常炽然
  菩萨为现老病死　　令彼众生悉调伏
  如来十力无所畏　　及以十八不共法
  所有无量诸功德　　悉以示现度众生
  记心教诫及神足　　悉是如来自在用
  彼诸大士皆示现　　能使众生尽调伏
  菩萨种种方便门　　随顺世法度众生
  譬如莲华不着水　　如是在世令深信
  雅思渊才文中王　　歌舞谈说众所欣
  一切世间众技术　　譬如幻师无不现
  或为长者邑中主　　或为贾客商人导
  或为国王及大臣　　或作良医善众论
  或于旷野作大树　　或为良药众宝藏
  或作宝珠随所求　　或以正道示众生
  若见世界始成立　　众生未有资身具
  是时菩萨为工匠　　为之示现种种业
  不作逼恼众生物　　但说利益世间事
  咒术药草等众论　　如是所有皆能说
  一切仙人殊胜行　　人天等类同信仰
  如是难行苦行法　　菩萨随应悉能作
  或作外道出家人　　或在山林自勤苦
  或露形体无衣服　　而于彼众作师长
  或现邪命种种行　　习行非法以为胜
  或现梵志诸威仪　　于彼众中为上首
  或受五热随日转　　或持牛狗及鹿戒
  或着坏衣奉事火　　为化是等作导师
  或有示谒诸天庙　　或复示入恒河水
  食根果等悉示行　　于彼常思已胜法
  或现蹲踞或翘足　　或卧草棘及灰上
  或复卧杵求出离　　而于彼众作师首
  如是等类诸外道　　观其意解与同事
  所示苦行世靡堪　　令彼见已皆调伏
  众生迷惑禀邪教　　住于恶见受众苦
  为其方便说妙法　　悉令得解真实谛
  或边咒语说四谛　　或善密语说四谛
  或人直语说四谛　　或天密语说四谛
  分别文字说四谛　　决定义理说四谛
  善破于他说四谛　　非外所动说四谛
  或八部语说四谛　　或一切语说四谛
  随彼所解语言音　　为说四谛令解脱
  所有一切诸佛法　　皆如是说无不尽
  知语境界不思议　　是名说法三昧力

大方广佛华严经卷第十四大方广佛华严经卷第十五

        于阗国三藏实叉难陀奉　制译

    贤首品第十二之二

  有胜三昧名安乐　　能普救度诸群生
  放大光明不思议　　令其见者悉调伏
  所放光明名善现　　若有众生遇此光
  必令获益不唐捐　　因是得成无上智
  彼光示现于诸佛　　示法示僧示正道
  亦示佛塔及形像　　是故得成此光明
  又放光明名照耀　　映蔽一切诸天光
  所有闇障靡不除　　普为众生作饶益
  此光觉悟一切众　　令执灯明供养佛
  以灯供养诸佛故　　得成世中无上灯
  然诸油灯及酥灯　　亦然种种诸明炬
  众香妙药上宝烛　　以是供佛获此光
  又放光明名济度　　此光能觉一切众
  令其普发大誓心　　度脱欲海诸群生
  若能普发大誓心　　度脱欲海诸群生
  则能越度四瀑流　　示导无忧解脱城
  于诸行路大水处　　造立桥梁及船筏
  毁呰有为赞寂静　　是故得成此光明
  又放光明名灭爱　　此光能觉一切众
  令其舍离于五欲　　专思解脱妙法味
  若能舍离于五欲　　专思解脱妙法味
  则能以佛甘露雨　　普灭世间诸渴爱
  惠施池井及泉流　　专求无上菩提道
  毁呰五欲赞禅定　　是故得成此光明
  又放光明名欢喜　　此光能觉一切众
  令其爱慕佛菩提　　发心愿证无师道
  造立如来大悲像　　众相庄严坐华座
  恒叹最胜诸功德　　是故得成此光明
  又放光明名爱乐　　此光能觉一切众
  令其心乐于诸佛　　及以乐法乐众僧
  若常心乐于诸佛　　及以乐法乐众僧
  则在如来众会中　　逮成无上深法忍
  开悟众生无有量　　普使念佛法僧宝
  及示发心功德行　　是故得成此光明
  又放光明名福聚　　此光能觉一切众
  令行种种无量施　　以此愿求无上道
  设大施会无遮限　　有来求者皆满足
  不令其心有所乏　　是故得成此光明
  又放光明名具智　　此光能觉一切众
  令于一法一念中　　悉解无量诸法门
  为诸众生分别法　　及以决了真实义
  善说法义无亏减　　是故得成此光明
  又放光明名慧灯　　此光能觉一切众
  令知众生性空寂　　一切诸法无所有
  演说诸法空无主　　如幻如焰水中月
  乃至犹如梦影像　　是故得成此光明
  又放光名法自在　　此光能觉一切众
  令得无尽陀罗尼　　悉持一切诸佛法
  恭敬供养持法者　　给侍守护诸贤圣
  以种种法施众生　　是故得成此光明
  又放光明名能舍　　此光觉悟悭众生
  令知财宝悉非常　　恒乐惠施心无著
  悭心难调而能调　　解财如梦如浮云
  增长惠施清净心　　是故得成此光明
  又放光明名除热　　此光能觉毁禁者
  普使受持清净戒　　发心愿证无师道
  劝引众生受持戒　　十善业道悉清净
  又令发向菩提心　　是故得成此光明
  又放光明名忍严　　此光觉悟嗔恚者
  令彼除嗔离我慢　　常乐忍辱柔和法
  众生暴恶难可忍　　为菩提故心不动
  常乐称扬忍功德　　是故得成此光明
  又放光明名勇猛　　此光觉悟懒堕者
  令彼常于三宝中　　恭敬供养无疲厌
  若彼常于三宝中　　恭敬供养无疲厌
  则能超出四魔境　　速成无上佛菩提
  劝化众生令进策　　常勤供养于三宝
  法欲灭时专守护　　是故得成此光明
  又放光明名寂静　　此光能觉乱意者
  令其远离贪恚痴　　心不动摇而正定
  舍离一切恶知识　　无义谈说杂染行
  赞叹禅定阿兰若　　是故得成此光明
  又放光明名慧严　　此光觉悟愚迷者
  令其证谛解缘起　　诸根智慧悉通达
  若能证谛解缘起　　诸根智慧悉通达
  则得日灯三昧法　　智慧光明成佛果
  国财及己皆能舍　　为菩提故求正法
  闻已专勤为众说　　是故得成此光明
  又放光明名佛慧　　此光觉悟诸含识
  令见无量无边佛　　各各坐宝莲华上
  赞佛威德及解脱　　说佛自在无有量
  显示佛力及神通　　是故得成此光明
  又放光明名无畏　　此光照触恐怖者
  非人所持诸毒害　　一切皆令疾除灭
  能于众生施无畏　　遇有恼害皆劝止
  拯济厄难孤穷者　　以是得成此光明
  又放光明名安隐　　此光能照疾病者
  令除一切诸苦痛　　悉得正定三昧乐
  施以良药救众患　　妙宝延命香涂体
  酥油乳蜜充饮食　　以是得成此光明
  又放光明名见佛　　此光觉悟将没者
  令随忆念见如来　　命终得生其净国
  见有临终劝念佛　　又示尊像令瞻敬
  俾于佛所深归仰　　是故得成此光明
  又放光明名乐法　　此光能觉一切众
  令于正法常欣乐　　听闻演说及书写
  法欲尽时能演说　　令求法者意充满
  于法爱乐勤修行　　是故得成此光明
  又放光明名妙音　　此光开悟诸菩萨
  能令三界所有声　　闻者皆是如来音
  以大音声称赞佛　　及施铃铎诸音乐
  普使世间闻佛音　　是故得成此光明
  又放光名施甘露　　此光开悟一切众
  令舍一切放逸行　　具足修习诸功德
  说有为法非安隐　　无量苦恼悉充遍
  恒乐称扬寂灭乐　　是故得成此光明
  又放光明名最胜　　此光开悟一切众
  令于佛所普听闻　　戒定智慧增上法
  常乐称扬一切佛　　胜戒胜定殊胜慧
  如是为求无上道　　是故得成此光明
  又放光明名宝严　　此光能觉一切众
  令得宝藏无穷尽　　以此供养诸如来
  以诸种种上妙宝　　奉施于佛及佛塔
  亦以惠施诸贫乏　　是故得成此光明
  又放光明名香严　　此光能觉一切众
  令其闻者悦可意　　决定当成佛功德
  人天妙香以涂地　　供养一切最胜主
  亦以造塔及佛像　　是故得成此光明
  又放光名杂庄严　　宝幢幡盖无央数
  焚香散华奏众乐　　城邑内外皆充满
  本以微妙妓乐音　　众香妙华幢盖等
  种种庄严供养佛　　是故得成此光明
  又放光明名严洁　　令地平坦犹如掌
  庄严佛塔及其处　　是故得成此光明
  又放光明名大云　　能起香云雨香水
  以水洒塔及庭院　　是故得成此光明
  又放光明名严具　　令裸形者得上服
  严身妙物而为施　　是故得成此光明
  又放光明名上味　　能令饥者获美食
  种种珍馔而为施　　是故得成此光明
  又放光明名大财　　令贫乏者获宝藏
  以无尽物施三宝　　是故得成此光明
  又放光名眼清净　　能令盲者见众色
  以灯施佛及佛塔　　是故得成此光明
  又放光名耳清净　　能令聋者悉善听
  鼓乐娱佛及佛塔　　是故得成此光明
  又放光名鼻清净　　昔未闻香皆得闻
  以香施佛及佛塔　　是故得成此光明
  又放光名舌清净　　能以美音称赞佛
  永除粗恶不善语　　是故得成此光明
  又放光名身清净　　诸根缺者令具足
  以身礼佛及佛塔　　是故得成此光明
  又放光名意清净　　令失心者得正念
  修行三昧悉自在　　是故得成此光明
  又放光名色清净　　令见难思诸佛色
  以众妙色庄严塔　　是故得成此光明
  又放光名声清净　　令知声性本空寂
  观声缘起如谷响　　是故得成此光明
  又放光名香清净　　令诸臭秽悉香洁
  香水洗塔菩提树　　是故得成此光明
  又放光名味清净　　能除一切味中毒
  恒供佛僧及父母　　是故得成此光明
  又放光名触清净　　能令恶触皆柔软
  戈鋋剑戟从空雨　　皆令变作妙华鬘
  以昔曾于道路中　　涂香散华布衣服
  迎送如来令蹈上　　是故今获光如是
  又放光名法清净　　能令一切诸毛孔
  悉演妙法不思议　　众生听者咸欣悟
  因缘所生无有生　　诸佛法身非是身
  法性常住如虚空　　以说其义光如是
  如是等比光明门　　如恒河沙无限数
  悉从大仙毛孔出　　一一作业各差别
  如一毛孔所放光　　无量无数如恒沙
  一切毛孔悉亦然　　此是大仙三昧力
  如其本行所得光　　随彼宿缘同行者
  今放光明故如是　　此是大仙智自在
  往昔同修于福业　　及有爱乐能随喜
  见其所作亦复然　　彼于此光咸得见
  若有自修众福业　　供养诸佛无央数
  于佛功德常愿求　　是此光明所开觉
  譬如生盲不见日　　非为无日出世间
  诸有目者悉明见　　各随所务修其业
  大士光明亦如是　　有智慧者皆悉见
  凡夫邪信劣解人　　于此光明莫能睹
  摩尼宫殿及辇乘　　妙宝灵香以涂莹
  有福德者自然备　　非无德者所能处
  大士光明亦如是　　有深智者咸照触
  邪信劣解凡愚人　　无有能见此光明
  若有闻此光差别　　能生清净深信解
  永断一切诸疑网　　速成无上切德幢
  有胜三昧能出现　　眷属庄严皆自在
  一切十方诸国土　　佛子众会无伦匹
  有妙莲华光庄严　　量等三千大千界
  其身端坐悉充满　　是此三昧神通力
  复有十刹微尘数　　妙好莲华所围绕
  诸佛子众于中坐　　住此三昧威神力
  宿世成就善因缘　　具足修行佛功德
  此等众生绕菩萨　　悉共合掌观无厌
  譬如明月在星中　　菩萨处众亦复然
  大士所行法如是　　入此三昧威神力
  如于一方所示现　　诸佛子众共围绕
  一切方中悉如是　　住此三昧威神力
  有胜三昧名方网　　菩萨住此广开示
  一切方中普现身　　或现入定或从出
  或于东方入正定　　而于西方从定出
  或于西方入正定　　而于东方从定出
  或于余方入正定　　而于余方从定出
  如是入出遍十方　　是名菩萨三昧力
  尽于东方诸国土　　所有如来无数量
  悉现其前普亲近　　住于三昧寂不动
  而于西方诸世界　　一切诸佛如来所
  皆现从于三昧起　　广修无量诸供养
  尽于西方诸国土　　所有如来无数量
  悉现其前普亲近　　住于三昧寂不动
  而于东方诸世界　　一切诸佛如来所
  皆现从于三昧起　　广修无量诸供养
  如是十方诸世界　　菩萨悉入无有余
  或现三昧寂不动　　或现恭敬供养佛
  于眼根中入正定　　于色尘中从定出
  示现色性不思议　　一切天人莫能知
  于色尘中入正定　　于眼起定心不乱
  说眼无生无有起　　性空寂灭无所作
  于耳根中入正定　　于声尘中从定出
  分别一切语言音　　诸天世人莫能知
  于声尘中入正定　　于耳起定心不乱
  说耳无生无有起　　性空寂灭无所作
  于鼻根中入正定　　于香尘中从定出
  普得一切上妙香　　诸天世人莫能知
  于香尘中入正定　　于鼻起定心不乱
  说鼻无生无有起　　性空寂灭无所作
  于舌根中入正定　　于味尘中从定出
  普得一切诸上味　　诸天世人莫能知
  于味尘中入正定　　于舌起定心不乱
  说舌无生无有起　　性空寂灭无所作
  于身根中入正定　　于触尘中从定出
  善能分别一切触　　诸天世人莫能知
  于触尘中入正定　　于身起定心不乱
  说身无生无有起　　性空寂灭无所作
  于意根中入正定　　于法尘中从定出
  分别一切诸法相　　诸天世人莫能知
  于法尘中入正定　　从意起定心不乱
  说意无生无有起　　性空寂灭无所作
  童子身中入正定　　壮年身中从定出
  壮年身中入正定　　老年身中从定出
  老年身中入正定　　善女身中从定出
  善女身中入正定　　善男身中从定出
  善男身中入正定　　比丘尼身从定出
  比丘尼身入正定　　比丘身中从定出
  比丘身中入正定　　学无学身从定出
  学无学身入正定　　辟支佛身从定出
  辟支佛身入正定　　现如来身从定出
  于如来身入正定　　诸天身中从定出
  诸天身中入正定　　大龙身中从定出
  大龙身中入正定　　夜叉身中从定出
  夜叉身中入正定　　鬼神身中从定出
  鬼神身中入正定　　一毛孔中从定出
  一毛孔中入正定　　一切毛孔从定出
  一切毛孔入正定　　一毛端头从定出
  一毛端头入正定　　一微尘中从定出
  一微尘中入正定　　一切尘中从定出
  一切尘中入正定　　金刚地中从定出
  金刚地中入正定　　摩尼树上从定出
  摩尼树上入正定　　佛光明中从定出
  佛光明中入正定　　于河海中从定出
  于河海中入正定　　于火大中从定出
  于火大中入正定　　于风起定心不乱
  于风大中入正定　　于地大中从定出
  于地大中入正定　　于天宫殿从定出
  于天宫殿入正定　　于空起定心不乱
  是名无量功德者　　三昧自在难思议
  十方一切诸如来　　于无量劫说不尽
  一切如来咸共说　　众生业报难思议
  诸龙变化佛自在　　菩萨神力亦难思
  欲以譬谕而显示　　终无有谕能谕此
  然诸智慧聪达人　　因于譬故解其义
  声闻心住八解脱　　所有变现皆自在
  能以一身现多身　　复以多身为一身
  于虚空中入火定　　行住坐卧悉在空
  身上出水身下火　　身上出火身下水
  如是皆于一念中　　种种自在无边量
  彼不具足大慈悲　　不为众生求佛道
  尚能现此难思事　　况大饶益自在力
  譬如日月游虚空　　影像普遍于十方
  泉池陂泽器中水　　众宝河海靡不现
  菩萨色像亦复然　　十方普现不思议
  此皆三昧自在法　　唯有如来能证了
  如净水中四兵像　　各各别异无交杂
  剑戟弧矢类甚多　　铠胄车舆非一种
  随其所有相差别　　莫不皆于水中现
  而水本自无分别　　菩萨三昧亦如是
  海中有神名善音　　其音普顺海众生
  所有语言皆辩了　　令彼一切悉欢悦
  彼神具有贪恚痴　　犹能善解一切音
  况复总持自在力　　而不能令众欢喜
  有一妇人名辩才　　父母求天而得生
  若有离恶乐真实　　入彼身中生妙辩
  彼有贪欲嗔恚痴　　犹能随行与辩才
  何况菩萨具智慧　　而不能与众生益
  譬如幻师知幻法　　能现种种无量事
  须臾示作日月岁　　城邑丰饶大安乐
  幻师具有贪恚痴　　犹能幻力悦世间
  况复禅定解脱力　　而不能令众欢喜
  天阿修罗斗战时　　修罗败衄而退走
  兵仗车舆及徒旅　　一时窜匿莫得见
  彼有贪欲嗔恚痴　　尚能变化不思议
  况住神通无畏法　　云何不能现自在
  释提桓因有象王　　彼知天主欲行时
  自化作头三十三　　一一六牙皆具足
  一一牙上七池水　　清净香洁湛然满
  一一清净池水中　　各七莲华妙严饰
  彼诸严饰莲华上　　各各有七天玉女
  悉善技艺奏众乐　　而与帝释相娱乐
  彼象或复舍本形　　自化其身同诸天
  威仪进止悉齐等　　有此变现神通力
  彼有贪欲嗔恚痴　　尚能现此诸神通
  何况具足方便智　　而于诸定不自在
  如阿修罗变作身　　蹈金刚际海中立
  海水至深仅其半　　首共须弥正齐等
  彼有贪欲嗔恚痴　　尚能现此大神通
  况伏魔怨照世灯　　而无自在威神力
  天阿修罗共战时　　帝释神力难思议
  随阿修罗军众数　　现身等彼而与敌
  诸阿修罗发是念　　释提桓因来向我
  必取我身五种缚　　由是彼众悉忧悴
  帝释现身有千眼　　手持金刚出火焰
  被甲持杖极威严　　修罗望见咸退伏
  彼以微小福德力　　犹能摧破大怨敌
  何况救度一切者　　具足功德不自在
  忉利天中有天鼓　　从天业报而生得
  知诸天众放逸时　　空中自然出此音
  一切五欲悉无常　　如水聚沫性虚伪
  诸有如梦如阳焰　　亦如浮云水中月
  放逸为怨为苦恼　　非甘露道生死径
  若有作诸放逸行　　入于死灭大鱼口
  世间所有众苦本　　一切圣人皆厌患
  五欲功德灭坏性　　汝应爱乐真实法
  三十三天闻此音　　悉共来升善法堂
  帝释为说微妙法　　咸令顺寂除贪爱
  彼音无形不可见　　犹能利益诸天众
  况随心乐现色身　　而不济度诸群生
  天阿修罗共斗时　　诸天福德殊胜力
  天鼓出音告其众　　汝等宜应勿忧怖
  诸天闻此所告音　　悉除忧畏增益力
  时阿修罗心震惧　　所将兵众咸退走
  甘露妙定如天鼓　　恒出降魔寂静音
  大悲哀愍救一切　　普使众生灭烦恼
  帝释普应诸天女　　九十有二那由他
  令彼各各心自谓　　天王独与我娱乐
  如天女中身普应　　善法堂内亦如是
  能于一念现神通　　悉至其前为说法
  帝释具有贪恚痴　　能令眷属悉欢喜
  况大方便神通力　　而不能令一切悦
  他化自在六天王　　于欲界中得自在
  以业惑苦为罥网　　系缚一切诸凡夫
  彼有贪欲嗔恚痴　　犹于众生得自在
  况具十种自在力　　而不能令众同行
  三千世界大梵王　　一切梵天所住处
  悉能现身于彼坐　　演畅微妙梵音声
  彼住世间梵道中　　禅定神通尚如意
  况出世间无有上　　于禅解脱不自在
  摩醯首罗智自在　　大海龙王降雨时
  悉能分别数其滴　　于一念中皆辨了
  无量亿劫勤修学　　得是无上菩提智
  云何不于一念中　　普知一切众生心
  众生业报不思议　　为大风力起世间
  巨海诸山天宫殿　　众宝光明万物种
  亦能兴云降大雨　　亦能散灭诸云气
  亦能成熟一切谷　　亦能安乐诸群生
  风不能学波罗蜜　　亦不学佛诸功德
  犹成不可思议事　　何况具足诸愿者
  男子女人种种声　　一切鸟兽诸音声
  大海川流雷震声　　皆能称悦众生意
  况复知声性如响　　逮得无碍妙辩才
  普应众生而说法　　而不能令世间喜
  海有希奇殊特法　　能为一切平等印
  众生宝物及川流　　普悉包容无所拒
  无尽禅定解脱者　　为平等印亦如是
  福德智慧诸妙行　　一切普修无厌足
  大海龙王游戏时　　普于诸处得自在
  兴云充遍四天下　　其云种种庄严色
  第六他化自在天　　于彼云色如真金
  化乐天上赤珠色　　兜率陀天霜雪色
  夜摩天上琉璃色　　三十三天码瑙色
  四王天上玻璃色　　大海水上金刚色
  紧那罗中妙香色　　诸龙住处莲华色
  夜叉住处白鹅色　　阿修罗中山石色
  郁单越处金焰色　　阎浮提中青宝色
  余二天下杂庄严　　随众所乐而应之
  又复他化自在天　　云中电耀如日光
  化乐天上如月光　　兜率天上阎浮金
  夜摩天上珂雪色　　三十三天金焰色
  四王天上众宝色　　大海之中赤珠色
  紧那罗界琉璃色　　龙王住处宝藏色
  夜叉所住玻璃色　　阿修罗中码瑙色
  郁单越境火珠色　　阎浮提中帝青色
  余二天下杂庄严　　如云色相电亦然
  他化雷震如梵音　　化乐天中大鼓音
  兜率天上歌唱音　　夜摩天上天女音
  于彼三十三天上　　如紧那罗种种音
  护世四王诸天所　　如乾闼婆所出音
  海中两山相击声　　紧那罗中箫笛声
  诸龙城中频伽声　　夜叉住处龙女声
  阿修罗中天鼓声　　于人道中海潮声
  他化自在雨妙香　　种种杂华为庄严
  化乐天雨多罗华　　曼陀罗华及泽香
  兜率天上雨摩尼　　具足种种宝庄严
  髻中宝珠如月光　　上妙衣服真金色
  夜摩中雨幢幡盖　　华鬘涂香妙严具
  赤真珠色上好衣　　及以种种众妓乐
  三十三天如意珠　　坚黑沉水栴檀香
  郁金鸡罗多摩等　　妙华香水相杂雨
  护世城中雨美膳　　色香味具增长力
  亦雨难思众妙宝　　悉是龙王之所作
  又复于彼大海中　　注雨不断如车轴
  复雨无尽大宝藏　　亦雨种种庄严宝
  紧那罗界雨璎珞　　众色莲华衣及宝
  婆利师迦末利香　　种种乐音皆具足
  诸龙城中雨赤珠　　夜叉城内光摩尼
  阿修罗中雨兵仗　　摧伏一切诸怨敌
  郁单越中雨璎珞　　亦雨无量上妙华
  弗婆瞿耶二天下　　悉雨种种庄严具
  阎浮提雨清净水　　微细悦泽常应时
  长养众华及果药　　成熟一切诸苗稼
  如是无量妙庄严　　种种云电及雷雨
  龙王自在悉能作　　而身不动无分别
  彼于世界海中住　　尚能现此难思力
  况入法海具功德　　而不能为大神变
  彼诸菩萨解脱门　　一切譬谕无能显
  我今以此诸譬谕　　略说于其自在力
  第一智慧广大慧　　真实智慧无边慧
  胜慧及以殊胜慧　　如是法门今已说
  此法希有甚奇特　　若人闻已能忍可
  能信能受能赞说　　如是所作甚为难
  世间一切诸凡夫　　信是法者甚难得
  若有勤修清净福　　以昔因力乃能信
  一切世界诸群生　　少有欲求声闻乘
  求独觉者转复少　　趣大乘者甚难遇
  趣大乘者犹为易　　能信此法倍更难
  况复持诵为人说　　如法修行真实解
  有以三千大千界　　顶戴一劫身不动
  彼之所作未为难　　信是法者乃为难
  有以手擎十佛刹　　尽于一劫空中住
  彼之所作未为难　　能信此法乃为难
  十刹尘数众生所　　悉施乐具经一劫
  彼之福德未为胜　　信此法者为最胜
  十刹尘数如来所　　悉皆承事尽一劫
  若于此品能诵持　　其福最胜过于彼

时贤首菩萨。说此偈已。十方世界。六返震动。魔宫隐蔽。恶道休息。十方诸佛。普现其前。各以右手。而摩其顶。同声赞言。善哉善哉。快说此法。我等一切悉皆随喜

大方广佛华严经卷第十五大方广佛华严经卷第十六

        于阗国三藏实叉难陀奉　制译

    升须弥山顶品第十三

尔时如来威神力故。十方一切世界。一一四天下。阎浮提中。悉见如来坐于树下。各有菩萨。承佛神力。而演说法。靡不自谓恒对于佛

尔时世尊。不离一切菩提树下。而上升须弥。向帝释殿。时天帝释。在妙胜殿前。遥见佛来。即以神力。庄严此殿。置普光明藏师子之座。其座悉以妙宝所成。十千层级。迥极庄严。十千金网。弥覆其上。十千种帐。十千种盖。周回间列。十千缯绮。以为垂带。十千珠璎周遍交络。十千衣服。敷布座上。十千天子。十千梵王。前后围绕。十千光明。而为照耀。尔时帝释。奉为如来。敷置座已。曲躬合掌。恭敬向佛。而作是言。善来世尊。善来善逝。善来如来。应正等觉。唯愿哀愍。处此宫殿。尔时世尊。即受其请。入妙胜殿。十方一切诸世界中。悉亦如是。尔时帝释。以佛神力。诸宫殿中。所有乐音。自然止息。即自忆念过去佛所。种诸善根。而说颂言

  迦叶如来具大悲　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  拘那牟尼见无碍　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  迦罗鸠驮如金山　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  毗舍浮佛无三垢　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  尸弃如来离分别　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  毗婆尸佛如满月　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  弗沙明达第一义　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  提舍如来辩无碍　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  波头摩佛净无垢　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥
  然灯如来大光明　　诸吉祥中最无上
  彼佛曾来入此殿　　是故此处最吉祥

如此世界中。忉利天王。以如来神力故。偈赞十佛所有功德。十方世界。诸释天王。悉亦如是。赞佛功德。尔时。世尊。入妙胜殿。结跏趺坐。此殿忽然。广博宽容。如其天众。诸所住处。十方世界。悉亦如是

    大方广佛华严经须弥顶上偈赞品第十四

尔时。佛神力故。十方各有一大菩萨。一一各与佛刹微尘数菩萨俱。从百佛刹。微尘数国土外。诸世界中。而来集会。其名曰法慧菩萨。一切慧菩萨。胜慧菩萨。功德慧菩萨。精进慧菩萨。善慧菩萨。智慧菩萨。真实慧菩萨。无上慧菩萨。坚固慧菩萨。所从来土。所谓。因陀罗华世界。波头摩华世界。宝华世界。优钵罗华世界。金刚华世界。妙香华世界。悦意华世界。阿卢那华世界。那罗陀华世界。虚空华世界。各于佛所。净修梵行。所谓。殊特月佛。无尽月佛。不动月佛。风月佛。水月佛。解脱月佛。无上月佛。星宿月佛。清净月佛。明了月佛。是诸菩萨。至佛所已。顶礼佛足。随所来方。各化作毗卢遮那藏师子之座。于其座上。结跏趺坐。如此世界中。须弥顶上。菩萨来集。一切世界。悉亦如是。彼诸菩萨。所有名字。世界佛号。悉等无别。尔时世尊。从两足指。放百千亿妙色光明。普照十方一切世界。须弥顶上。帝释宫中。佛及大众。靡不皆现。尔时法慧菩萨。承佛威神。普观十方。而说颂曰

  佛放净光明　　普见世导师
  须弥山王顶　　妙胜殿中住
  一切释天王　　请佛入宫殿
  悉以十妙颂　　称赞诸如来
  彼诸大会中　　所有菩萨众
  皆从十方至　　化座而安坐
  彼会诸菩萨　　皆同我等名
  所从诸世界　　名字亦如是
  本国诸世尊　　名号悉亦同
  各于其佛所　　净修无上行
  佛子汝应观　　如来自在力
  一切阎浮提　　皆言佛在中
  我等今见佛　　住于须弥顶
  十方悉亦然　　如来自在力
  一一世界中　　发心求佛道
  依于如是愿　　修习菩提行
  佛以种种身　　游行遍世间
  法界无所碍　　无能测量者
  慧光恒普照　　世闇悉除灭
  一切无等伦　　云何可测知

尔时一切慧菩萨。承佛威力。普观十方。而说颂言

  假使百千劫　　常见于如来
  不依真实义　　而观救世者
  是人取诸相　　增长痴惑网
  系缚生死狱　　盲冥不见佛
  观察于诸法　　自性无所有
  如其生灭相　　但是假名说
  一切法无生　　一切法无灭
  若能如是解　　诸佛常现前
  法性本空寂　　无取亦无见
  性空即是佛　　不可得思量
  若知一切法　　体性皆如是
  斯人则不为　　烦恼所染着
  凡夫见诸法　　但随于相转
  不了法无相　　以是不见佛
  牟尼离三世　　诸相悉具足
  住于无所住　　普遍而不动
  我观一切法　　皆悉得明了
  今见于如来　　决定无有疑
  法慧先已说　　如来真实性
  我从彼了知　　菩提难思议

尔时胜慧菩萨。承佛威力普观十方。而说颂言

  如来大智慧　　希有无等伦
  一切诸世间　　思惟莫能及
  凡夫妄观察　　取相不如理
  佛离一切相　　非彼所能见
  迷惑无知者　　妄取五蕴相
  不了彼真性　　是人不见佛
  了知一切法　　自性无所有
  如是解法性　　则见卢舍那
  因前五蕴故　　后蕴相续起
  于此性了知　　见佛难思议
  譬如闇中宝　　无灯不可见
  佛法无人说　　虽慧莫能了
  亦如目有翳　　不见净妙色
  如是不净心　　不见诸佛法
  又如明净日　　瞽者莫能见
  无有智慧心　　终不见诸佛
  若能除眼翳　　舍离于色想
  不见于诸法　　则得见如来
  一切慧先说　　诸佛菩提法
  我从于彼闻　　得见卢舍那

尔时功德慧菩萨。承佛威力。普观十方。而说颂言

  诸法无真实　　妄取真实相
  是故诸凡夫　　轮回生死狱
  言辞所说法　　小智妄分别
  是故生障碍　　不了于自心
  不能了自心　　云何知正道
  彼由颠倒慧　　增长一切恶
  不见诸法空　　恒受生死苦
  斯人未能有　　清净法眼故
  我昔受众苦　　由我不见佛
  故当净法眼　　观其所应见
  若得见于佛　　其心无所取
  此人则能见　　如佛所知法
  若见佛真法　　则名大智者
  斯人有净眼　　能观察世间
  无见即是见　　能见一切法
  于法若有见　　此则无所见
  一切诸法性　　无生亦无灭
  奇哉大导师　　自觉能觉他
  胜慧先已说　　如来所悟法
  我等从彼闻　　能知佛真性

尔时精进慧菩萨。承佛威力。观察十方。而说颂言

  若住于分别　　则坏清净眼
  愚痴邪见增　　永不见诸佛
  若能了邪法　　如实不颠倒
  知妄本自真　　见佛则清净
  有见则为垢　　此则未为见
  远离于诸见　　如是乃见佛
  世间言语法　　众生妄分别
  知世皆无生　　乃是见世间
  若见见世间　　见则世间相
  如实等无异　　此名真见者
  若见等无异　　于物不分别
  是见离诸惑　　无漏得自在
  诸佛所开示　　一切分别法
  是悉不可得　　彼性清净故
  法性本清净　　如空无有相
  一切无能说　　智者如是观
  远离于法想　　不乐一切法
  此亦无所修　　能见大牟尼
  如德慧所说　　此名见佛者
  所有一切行　　体性皆寂灭

尔时善慧菩萨。承佛威力。普观十方。而说颂言

  希有大勇健　　无量诸如来
  离垢心解脱　　自度能度彼
  我见世间灯　　如实不颠倒
  如于无量劫　　积智者所见
  一切凡夫行　　莫不速归尽
  其性如虚空　　故说无有尽
  智者说无尽　　此亦无所说
  自性无尽故　　得有难思尽
  所说无尽中　　无众生可得
  知众生性尔　　则见大名称
  无见说为见　　无生说众生
  若见若众生　　了知无体性
  能见及所见　　见者悉除遣
  不坏于真法　　此人了知佛
  若人了知佛　　及佛所说法
  则能照世间　　如佛卢舍那
  正觉善开示　　一法清净道
  精进慧大士　　演说无量法
  若有若无有　　彼想皆除灭
  如是能见佛　　安住于实际

尔时智慧菩萨。承佛威力。普观十方。而说颂言

  我闻最胜教　　即生智慧光
  普照十方界　　悉见一切佛
  此中无少物　　但有假名字
  若计有我人　　则为入险道
  诸取着凡夫　　计身为实有
  如来非所取　　彼终不得见
  此人无慧眼　　不能得见佛
  于无量劫中　　流转生死海
  有诤说生死　　无诤即涅槃
  生死及涅槃　　一俱不可得
  若逐假名字　　取着此二法
  此人不如实　　不知圣妙道
  若生如是想　　此佛此最胜
  颠倒非实义　　不能见正觉
  能知此实体　　寂灭真如相
  则见正觉尊　　超出语言道
  言语说诸法　　不能显实相
  平等乃能见　　如法佛亦然
  正觉过去世　　未来及现在
  永断分别根　　是故说名佛

尔时真实慧菩萨。承佛威力。普观十方。而说颂言

  宁受地狱苦　　得闻诸佛名
  不受无量乐　　而不闻佛名
  所以于往昔　　无数劫受苦
  流转生死中　　不闻佛名故
  于法不颠倒　　如实而现证
  离诸和合相　　是名无上觉
  现在非和合　　去来亦复然
  一切法无相　　是则佛真体
  若能如是观　　诸法甚深义
  则见一切佛　　法身真实相
  于实见真实　　非实见不实
  如是究竟解　　是故名为佛
  佛法不可觉　　了此名觉法
  诸佛如是修　　一法不可得
  知以一故众　　知以众故一
  诸法无所依　　但从和合起
  无能作所作　　唯从业想生
  云何知如是　　异此无有故
  一切法无住　　定处不可得
  诸佛住于此　　究竟不动摇

尔时无上慧菩萨。承佛威力。普观十方。而说颂言

  无上摩诃萨　　远离众生想
  无有能过者　　故号为无上
  诸佛所得处　　无作无分别
  粗者无所有　　微细亦复然
  诸佛所行境　　于中无有数
  正觉远离数　　此是佛真法
  如来光普照　　灭除众暗冥
  是光非有照　　亦复非无照
  于法无所著　　无念亦无染
  无住无处所　　不坏于法性
  此中无有二　　亦复无有一
  大智善见者　　如理巧安住
  无中无有二　　无二亦复无
  三界一切空　　是则诸佛见
  凡夫无觉解　　佛令住正法
  诸法无所住　　悟此见自身
  非身而说身　　非起而现起
  无身亦无见　　是佛无上身
  如是实慧说　　诸佛妙法性
  若闻此法者　　当得清净眼

尔时坚固慧菩萨。承佛威力。普观十方。而说颂言

  伟哉大光明　　勇健无上士
  为利群迷故　　而兴于世间
  佛以大悲心　　普观诸众生
  见在三有中　　轮回受众苦
  唯除正等觉　　具德尊导师
  一切诸天人　　无能救护者
  若佛菩萨等　　不出于世间
  无有一众生　　而能得安乐
  如来等正觉　　及诸贤圣众
  出现于世间　　能与众生乐
  若见如来者　　为得大善利
  闻佛名生信　　则是世间塔
  我等见世尊　　为得大利益
  闻如是妙法　　悉当成佛道
  诸菩萨过去　　以佛威神力
  得清净慧眼　　了诸佛境界
  今见卢舍那　　重增清净信
  佛智无边际　　演说不可尽
  胜慧等菩萨　　及我坚固慧
  无数亿劫中　　说亦不能尽

    大方广佛华严经十住品第十五

尔时。法慧菩萨。承佛威力。入菩萨无量方便三昧。以三昧力。十方各千佛刹。微尘数世界之外。有千佛刹。微尘数诸佛。皆同一号。名曰法慧。普现其前。告法慧菩萨言。善哉善哉。善男子。汝能入是菩萨。无量方便三昧。善男子。十方各千佛刹。微尘数诸佛。悉以神力。共加于汝。又是毗卢遮那如来。往昔愿力。威神之力。及汝所修。善根力故。入此三昧。令汝说法。为增长佛智故。深入法界故。善了众生界故。所入无碍故。所行无障故。得无等方便故。入一切智性故。觉一切法故。知一切根故。能持说一切法故。所谓。发起诸菩萨十种住。善男子。汝当承佛威神之力。而演此法。是时诸佛。即与法慧菩萨。无碍智无著智。无断智无痴智。无异智无失智。无量智无胜智。无懈智无夺智。何以故。此三昧力。法如是故。是时诸佛。各申右手。摩法慧菩萨顶。法慧菩萨。即从定起。告诸菩萨言。佛子。菩萨住处广大。与法界虚空等。佛子。菩萨住三世诸佛家。彼菩萨住。我今当说。诸佛子。菩萨住有十种。过去未来现在诸佛。已说。当说。今说。何者为十。所谓。初发心住。治地住。修行住。生贵住。具足方便住。正心住。不退住。童真住。王子住。灌顶住。是名菩萨十住。去来现在。诸佛所说

佛子。云何为菩萨发心住。此菩萨。见佛世尊。形貌端严。色相圆满。人所乐见。难可值遇。有大威力。或见神足。或闻记别。或听教诫。或见众生受诸剧苦。或闻如来广大佛法。发菩提心。求一切智。此菩萨。缘十种难得法。而发于心。何者为十。所谓。是处非处智。善恶业报智。诸根胜劣智。种种解差别智。种种界差别智。一切至处道智。诸禅解脱三昧智。宿命无碍智。天眼无碍智。三世漏普尽智。是为十。佛子。此菩萨。应劝学十法。何者为十。所谓。勤供养佛乐住生死。主导世间令除恶业。以胜妙法常行教诲。叹无上法学佛功德。生诸佛前恒蒙摄受。方便演说寂静三昧。赞叹远离生死轮回。为苦众生作归依处。何以故。欲令菩萨。于佛法中。心转增广。有所闻法。即自开解。不由他教故

佛子。云何为菩萨治地住。此菩萨。于诸众生。发十种心。何者为十。所谓。利益心。大悲心。安乐心。安住心。怜愍心。摄受心。守护心。同己心。师心。导师心。是为十。佛子。此菩萨。应劝学十法。何者为十。所谓。诵习多闻。虚闲寂静。近善知识。发言和悦。语必知时。心无怯怖。了达于义。如法修行。远离愚迷。安住不动。何以故。欲令菩萨。于诸众生。增长大悲。有所闻法。即自开解。不由他教故

佛子。云何为菩萨修行住。此菩萨。以十种行。观一切法。何等为十。所谓。观一切法无常。一切法苦。一切法空。一切法无我。一切法无作。一切法无味。一切法不如名。一切法无处所。一切法离分别。一切法无坚实。是为十。佛子。此菩萨。应劝学十法。何者为十。所谓。观察众生界。法界。世界。观察地界。水界。火界。风界。观察欲界。色界。无色界。何以故。欲令菩萨。智慧明了。有所闻法。即自开解。不由他教故

佛子。云何为菩萨生贵住。此菩萨。从圣教中生。成就十法。何者为十。所谓。永不退转于诸佛所。深生净信。善观察法。了知众生。国土。世界。业行。果报。生死。涅槃。是为十。佛子。此菩萨。应劝学十法。何者为十。所谓。了知过去。未来。现在。一切佛法。修集过去。未来。现在。一切佛法。圆满过去。未来。现在。一切佛法。了知一切诸佛平等。何以故。欲令增进于三世中。心得平等。有所闻法。即自开解。不由他教故

佛子。云何为菩萨具足方便住。此菩萨。所修善根。皆为救护一切众生。饶益一切众生。安乐一切众生。哀愍一切众生。度脱一切众生。令一切众生。离诸灾难。令一切众生。出生死苦。令一切众生。发生净信。令一切众生。悉得调伏。令一切众生。咸证涅槃。佛子。此菩萨。应劝学十法。何者为十。所谓。知众生无边。知众生无量。知众生无数。知众生不思议。知众生无量色。知众生不可量。知众生空。知众生无所作。知众生无所有。知众生无自性。何以故。欲令其心。转复增胜。无所染着。有所闻法。即自开解。不由他教故

佛子。云何为菩萨正心住。此菩萨。闻十种法。心定不动。何者为十。所谓。闻赞佛毁佛。于佛法中。心定不动。闻赞法毁法。于佛法中。心定不动。闻赞菩萨毁菩萨。于佛法中。心定不动。闻赞菩萨毁菩萨所行法。于佛法中。心定不动。闻说众生有量无量。于佛法中。心定不动。闻说众生有垢无垢。于佛法中。心定不动。闻说众生易度难度。于佛法中。心定不动。闻说法界有量无量。于佛法中。心定不动。闻说法界有成有坏。于佛法中。心定不动。闻说法界若有若无。于佛法中。心定不动。是为十。佛子。此菩萨。应劝学十法。何者为十。所谓。一切法无相。一切法无体。一切法不可修。一切法无所有。一切法无真实。一切法空。一切法无性。一切法如幻。一切法如梦。一切法无分别。何以故。欲令其心。转复增进。得不退转。无生法忍。有所闻法。即自开解。不由他教故

佛子。云何为菩萨不退住。此菩萨。闻十种法。坚固不退。何者为十。所谓。闻有佛无佛。于佛法中。心不退转。闻有法无法。于佛法中。心不退转。闻有菩萨无菩萨。于佛法中。心不退转。闻有菩萨行无菩萨行。于佛法中。心不退转。闻菩萨修行出离。修行不出离。于佛法中。心不退转。闻过去有佛。过去无佛。于佛法中。心不退转。闻未来有佛。未来无佛。于佛法中。心不退转。闻现在有佛。现在无佛。于佛法中。心不退转。闻佛智有尽。佛智无尽。于佛法中。心不退转。闻三世一相。三世非一相。于佛法中。心不退转。是为十。佛子。此菩萨。应劝学十种广大法。何者为十。所谓。说一即多。说多即一。文随于义。义随于文。非有即有。有即非有。无相即相。相即无相。无性即性。性即无性。何以故。欲令增进于一切法。善能出离。有所闻法。即自开解。不由他教故

佛子。云何为菩萨童真住。此菩萨。住十种业。何者为十。所谓。身行无失。语行无失。意行无失。随意受生。知众生种种欲。知众生种种解。知众生种种界。知众生种种业。知世界成坏。神足自在。所行无碍。是为十。佛子。此菩萨。应劝学十种法。何者为十。所谓。知一切佛刹。动一切佛刹。持一切佛刹。观一切佛刹。诣一切佛刹。游行无数世界。领受无数佛法。现变化自在身。出广大遍满音。一刹那中。承事供养无数诸佛。何以故。欲令增进于一切法。能得善巧。有所闻法。即自开解。不由他教故

佛子。云何为菩萨王子住。此菩萨。善知十种法。何者为十。所谓。善知诸众生受生。善知诸烦恼现起。善知习气相续。善知所行方便。善知无量法。善解诸威仪。善知世界差别。善知前际后际事。善知演说世谛。善知演说第一义谛。是为十。佛子。此菩萨。应劝学十种法。何者为十。所谓。法王处善巧。法王处轨度。法王处宫殿。法王处趣入。法王处观察。法王灌顶。法王力持。法王无畏。法王宴寝。法王赞叹。何以故。欲令增进。心无障碍。有所闻法。即自开解。不由他教故

佛子。云何为菩萨灌顶住。此菩萨。得成就十种智。何者为十。所谓。震动无数世界。照耀无数世界。住持无数世界。往诣无数世界。严净无数世界。开示无数众生。观察无数众生。知无数众生根。令无数众生趣入。令无数众生调伏。是为十。佛子。此菩萨。身及身业。神通变现。过去智未来智现在智。成就佛土。心境界智境界。皆不可知。乃至法王子菩萨。亦不能知。佛子。此菩萨。应劝学诸佛十种智。何者为十。所谓。三世智。佛法智。法界无碍智。法界无边智。充满一切世界智。普照一切世界智。住持一切世界智。知一切众生智。知一切法智。知无边诸佛智。何以故。欲令增长一切种智。有所闻法。即自开解。不由他教故

尔时。佛神力故。十方各一万佛刹。微尘数世界。六种震动。所谓。动。遍动。等遍动。起。遍起。等遍起。涌遍涌。等遍涌。震。遍震。等遍震。吼。遍吼。等遍吼。击。遍击。等遍击。雨天妙华。天末香。天华鬘。天杂香。天宝衣。天宝云。天庄严具天诸音乐。不鼓自鸣。放大光明。及妙音声。如此四天下。须弥山顶。帝释殿上。说十住法。现诸神变。十方所有。一切世界。悉亦如是。又以佛神力故。十方各过一万佛刹。微尘数世界。有十佛刹。微尘数菩萨。来诣于此。充满十方。作如是言。善哉善哉。佛子。善说此法。我等诸人。同名法慧。所从来国。同名法云。彼土如来。皆名妙法。我等佛所。亦说十住。众会眷属。文句义理。悉亦如是。无有增减。佛子。我等承佛神力。来入此会。为汝作证。如于此会。十方所有。一切世界。悉亦如是。尔时法慧菩萨。承佛威力。观察十方。暨于法界。而说颂曰

  见最胜智微妙身　　相好端严皆具足
  如是尊重甚难遇　　菩萨勇猛初发心
  见无等比大神通　　闻说记心及教诫
  诸趣众生无量苦　　菩萨以此初发心
  闻诸如来普胜尊　　一切功德皆成就
  譬如虚空不分别　　菩萨以此初发心
  三世因果名为处　　我等自性为非处
  欲悉了知真实义　　菩萨以此初发心
  过去未来现在世　　所有一切善恶业
  欲悉了知无不尽　　菩萨以此初发心
  诸禅解脱及三昧　　杂染清净无量种
  欲悉了知入住出　　菩萨以此初发心
  随诸众生根利钝　　如是种种精进力
  欲悉了达分别知　　菩萨以此初发心
  一切众生种种解　　心所好乐各差别
  如是无量欲悉知　　菩萨以此初发心
  众生诸界各差别　　一切世间无有量
  欲悉了知其体性　　菩萨以此初发心
  一切有为诸行道　　一一皆有所至处
  悉欲了知其实性　　菩萨以此初发心
  一切世界诸众生　　随业漂流无暂息
  欲得天眼皆明见　　菩萨以此初发心
  过去世中曾所有　　如是体性如是相
  欲悉了知其宿住　　菩萨以此初发心
  一切众生诸结惑　　相续现起及习气
  欲悉了知究竟尽　　菩萨以此初发心
  随诸众生所安立　　种种谈论语言道
  如其世谛悉欲知　　菩萨以此初发心
  一切诸法离言说　　性空寂灭无所作
  欲悉明达此真义　　菩萨以此初发心
  欲悉震动十方国　　倾覆一切诸大海
  具足诸佛大神通　　菩萨以此初发心
  欲一毛孔放光明　　普照十方无量土
  一一光中觉一切　　菩萨以此初发心
  欲以难思诸佛刹　　悉置掌中而不动
  了知一切如幻化　　菩萨以此初发心
  欲以无量刹众生　　置一毛端不迫隘
  悉知无人无有我　　菩萨以此初发心
  欲以一毛滴海水　　一切大海悉令竭
  而悉分别知其数　　菩萨以此初发心
  不可思议诸国土　　尽抹为尘无遗者
  欲悉分别知其数　　菩萨以此初发心
  过去未来无量劫　　一切世间成坏相
  欲悉了达穷其际　　菩萨以此初发心
  三世所有诸如来　　一切独觉及声闻
  欲知其法尽无余　　菩萨以此初发心
  无量无边诸世界　　欲以一毛悉称举
  如其体相悉了知　　菩萨以此初发心
  无量无数轮围山　　欲令悉入毛孔中
  如其大小皆得知　　菩萨以此初发心
  欲以寂静一妙音　　普应十方随类演
  如是皆令净明了　　菩萨以此初发心
  一切众生语言法　　一言演说无不尽
  悉欲了知其自性　　菩萨以此初发心
  世间言音靡不作　　悉令其解证寂灭
  欲得如是妙舌根　　菩萨以此初发心
  欲使十方诸世界　　有成坏相皆得见
  而悉知从分别生　　菩萨以此初发心
  一切十方诸世界　　无量如来悉充满
  欲悉了知彼佛法　　菩萨以此初发心
  种种变化无量身　　一切世界微尘等
  欲悉了达从心起　　菩萨以此初发心
  过去未来现在世　　无量无数诸如来
  欲于一念悉了知　　菩萨以此初发心
  欲具演说一句法　　阿僧祇劫无有尽
  而令文义各不同　　菩萨以此初发心
  十方一切诸众生　　随其流转生灭相
  欲于一念皆明达　　菩萨以此初发心
  欲以身语及意业　　普诣十方无所碍
  了知三世皆空寂　　菩萨以此初发心
  菩萨如是发心已　　应令往诣十方国
  恭敬供养诸如来　　以此使其无退转
  菩萨勇猛求佛道　　住于生死不疲厌
  为彼称叹使顺行　　如是令其无退转
  十方世界无量刹　　悉在其中作尊主
  为诸菩萨如是说　　以此令其无退转
  最胜最上最第一　　甚深微妙清净法
  劝诸菩萨说与人　　如是教令离烦恼
  一切世间无与等　　不可倾动摧伏处
  为彼菩萨常称赞　　如是教令不退转
  佛是世间大力主　　具足一切诸功德
  令诸菩萨住是中　　以此教为胜丈夫
  无量无边诸佛所　　悉得往诣而亲近
  常为诸佛所摄受　　如是教令不退转
  所有寂静诸三昧　　悉皆演畅无有余
  为彼菩萨如是说　　以此令其不退转
  摧灭诸有生死轮　　转于清净妙法轮
  一切世间无所著　　为诸菩萨如是说
  一切众生堕恶道　　无量重苦所缠迫
  与作救护归依处　　为诸菩萨如是说
  此是菩萨发心住　　一向志求无上道
  如我所说教诲法　　一切诸佛亦如是
  第二治地住菩萨　　应当发起如是心
  十方一切诸众生　　愿使悉顺如来教
  利益大悲安乐心　　安住怜愍摄受心
  守护众生同己心　　师心及以导师心
  已住如是胜妙心　　次令诵习求多闻
  常乐寂静正思惟　　亲近一切善知识
  发言和悦离粗犷　　言必知时无所畏
  了达于义如法行　　远离愚迷心不动
  此是初学菩提行　　能行此行真佛子
  我今说彼所应行　　如是佛子应勤学
  第三菩萨修行住　　当依佛教勤观察
  诸法无常苦及空　　无有我人无动作
  一切诸法不可乐　　无如名字无处所
  无所分别无真实　　如是观者名菩萨
  次令观察众生界　　及以劝观于法界
  世界差别尽无余　　于彼咸应劝观察
  十方世界及虚空　　所有地水与火风
  欲界色界无色界　　悉劝观察咸令尽
  观察彼界各差别　　及其体性咸究竟
  得如是教勤修行　　此则名为真佛子
  第四生贵住菩萨　　从诸圣教而出生
  了达诸有无所有　　超过彼法生法界
  信佛坚固不可坏　　观法寂灭心安住
  随诸众生悉了知　　体性虚妄无真实
  世间刹土业及报　　生死涅槃悉如是
  佛子于法如是观　　从佛亲生名佛子
  过去未来现在世　　其中所有诸佛法
  了知积集及圆满　　如是修学令究竟
  三世一切诸如来　　能随观察悉平等
  种种差别不可得　　如是观者达三世
  如我称扬赞叹者　　此是四住诸功德
  若能依法勤修行　　速成无上佛菩提
  从此第五诸菩萨　　说名具足方便住
  深入无量巧方便　　发生究竟功德业
  菩萨所修众福德　　皆为救护诸群生
  专心利益与安乐　　一向哀愍令度脱
  为一切世除众难　　引出诸有令欢喜
  一一调伏无所遗　　皆令具德向涅槃
  一切众生无有边　　无量无数不思议
  及以不可称量等　　听受如来如是法
  此第五住真佛子　　成就方便度众生
  一切功德大智尊　　以如是法而开示
  第六正心圆满住　　于法自性无迷惑
  正念思惟离分别　　一切天人莫能动
  闻赞毁佛与佛法　　菩萨及以所行行
  众生有量若无量　　有垢无垢难易度
  法界大小及成坏　　若有若无心不动
  过去未来今现在　　谛念思惟恒决定
  一切诸法皆无相　　无体无性空无实
  如幻如梦离分别　　常乐听闻如是义
  第七不退转菩萨　　于佛及法菩萨行
  若有若无出不出　　虽闻是说无退转
  过去未来现在世　　一切诸佛有以无
  佛智有尽或无尽　　三世一相种种相
  一即是多多即一　　文随于义义随文
  如是一切展转成　　此不退人应为说
  若法有相及无相　　若法有性及无性
  种种差别互相属　　此人闻已得究竟
  第八菩萨童真住　　身语意行皆具足
  一切清净无诸失　　随意受生得自在
  知诸众生心所乐　　种种意解各差别
  及其所有一切法　　十方国土成坏相
  逮得速疾妙神通　　一切处中随念往
  于诸佛所听闻法　　赞叹修行无懈倦
  了知一切诸佛国　　震动加持亦观察
  超过佛土不可量　　游行世界无边数
  阿僧祇法悉咨问　　所欲受身皆自在
  言音善巧靡不充　　诸佛无数咸承事
  第九菩萨王子住　　能见众生受生别
  烦恼现习靡不知　　所行方便皆善了
  诸法各异威仪别　　世界不同前后际
  如其世俗第一义　　悉善了知无有余
  法王善巧安立处　　随其处所所有法
  法王宫殿若趣入　　及以于中所观见
  法王所有灌顶法　　神力加持无怯畏
  宴寝宫室及叹誉　　以此教诏法王子
  如是为说靡不尽　　而令其心无所著
  于此了知修正念　　一切诸佛现其前
  第十灌顶真佛子　　成满最上第一法
  十方无数诸世界　　悉能震动光普照
  住持往诣亦无余　　清净庄严皆具足
  开示众生无有数　　观察知根悉能尽
  发心调伏亦无边　　咸令趣向大菩提
  一切法界咸观察　　十方国土皆往诣
  其中身及身所作　　神通变现难可测
  三世佛土诸境界　　乃至王子无能了
  一切见者三世智　　于诸佛法明了智
  法界无碍无边智　　充满一切世界智
  照耀世界住持智　　了知众生诸法智
  及知正觉无边智　　如来为说咸令尽
  如是十住诸菩萨　　皆从如来法化生
  随其所有功德行　　一切天人莫能测
  过去未来现在世　　发心求佛无有边
  十方国土皆充满　　莫不当成一切智
  一切国土无边际　　世界众生法亦然
  惑业心乐各差别　　依彼而发菩提意
  始求佛道一念心　　世间众生及二乘
  斯等尚亦不能知　　何况所余功德行
  十方所有诸世界　　能以一毛悉称举
  彼人能知此佛子　　趣向如来智慧行
  十方所有诸大海　　悉以毛端滴令尽
  彼人能知此佛子　　一念所修功德行
  一切世界抹为尘　　悉能分别知其数
  如是之人乃能见　　此诸菩萨所行道
  去来现在十方佛　　一切独觉及声闻
  悉以种种妙辩才　　开示初发菩提心
  发心功德不可量　　充满一切众生界
  众智共说无能尽　　何况所余诸妙行

大方广佛华严经卷第十六大方广佛华严经卷第十七

        于阗国三藏实叉难陀奉　制译

    梵行品第十六

尔时正念天子。白法慧菩萨言。佛子。一切世界。诸菩萨众。依如来教。染衣出家。云何而得梵行清净。从菩萨位。逮于无上菩提之道。法慧菩萨言。佛子。菩萨摩诃萨。修梵行时。应以十法。而为所缘。作意观察。所谓。身。身业。语。语业。意。意业。佛。法。僧。戒。应如是观。为身是梵行耶。乃至戒是梵行耶。若身是梵行者。当知梵行。则为非善。则为非法。则为浑浊。则为臭恶。则为不净。则为可厌。则为违逆。则为杂染。则为死尸。则为虫聚。若身业是梵行者。梵行则是行住坐卧。左右顾视。屈伸俯仰。若语是梵行者。梵行则是音声风息。胸舌喉吻。吐纳抑纵。高低清浊。若语业是梵行者。梵行则是起居问讯。略说广说。谕说直说。赞说毁说。安立说。随俗说。显了说。若意是梵行者。梵行则应是觉是观。是分别。是种种分别。是忆念。是种种忆念。是思惟。是种种思惟。是幻术。是眠梦。若意业是梵行者。当知梵行则是思想。寒热饥渴。苦乐忧喜。若佛是梵行者。为色是佛耶。受是佛耶。想是佛耶。行是佛耶。识是佛耶。为相是佛耶。好是佛耶。神通是佛耶。业行是佛耶。果报是佛耶。若法是梵行者。为寂灭是法耶。涅槃是法耶。不生是法耶。不起是法耶。不可说是法耶。无分别是法耶。无所行是法耶。不合集是法耶。若僧是梵行者。为预流向是僧耶。预流果是僧耶。一来向是僧耶。一来果是僧耶。不还向是僧耶。不还果是僧耶。阿罗汉向是僧耶。阿罗汉果是僧耶。三明是僧耶。六通是僧耶。若戒是梵行者。为坛场是戒耶。问清净是戒耶。教威仪是戒耶。三说羯磨是戒耶。和尚是戒耶。阿阇梨是戒耶。剃发是戒耶。着袈裟衣是戒耶。乞食是戒耶。正命是戒耶。如是观已。于身无所取。于修无所著。于法无所住。过去已灭。未来未至。现在空寂。无作业者。无受报者。此世不移动。彼世不改变。此中何法。名为梵行。梵行从何处来。谁之所有。体为是谁。由谁而作。为是有。为是无。为是色。为非色。为是受。为非受。为是想为非想。为是行。为非行。为是识。为非识。如是观察。梵行法不可得故。三世法皆空寂故。意无取着故。心无障碍故。所行无二故。方便自在故。受无相法故。观无相法故。知佛法平等故。具一切佛法故。如是名为清净梵行。复应修习十种法。何者为十。所谓。处非处智。过现未来业报智。诸禅解脱三昧智。诸根胜劣智。种种解智。种种界智。一切至处道智。天眼无碍智。宿命无碍智。永断习气智。于如来十力。一一观察。一一力中。有无量义。悉应咨问。闻已应起大慈悲心。观察众生。而不舍离。思惟诸法。无有休息。行无上业。不求果报。了知境界。如幻如梦。如影如响。亦如变化。若诸菩萨。能与如是观行相应。于诸法中。不生二解。一切佛法。疾得现前。初发心时。即得阿耨多罗三藐三菩提。知一切法。即心自性。成就慧身。不由他悟

    大方广佛华严经初发心功德品第十七

尔时。天帝释。白法慧菩萨言。佛子。菩萨初发菩提之心。所得功德。其量几何。法慧菩萨言。此义甚深。难说难知。难分别难信解。难证难行。难通达难思惟。难度量难趣入。虽然。我当承佛威神之力。而为汝说。佛子。假使有人。以一切乐具。供养东方阿僧祇世界。所有众生。经于一劫。然后教令净持五戒。南西北方。四维上下。亦复如是。佛子。于汝意云何。此人功德。宁为多不。天帝言。佛子。此人功德。唯佛能知。其余一切。无能量者。法慧菩萨言。佛子。此人功德。比菩萨初发心功德。百分不及一。千分不及一。百千分不及一。如是。亿分百亿分。千亿分百千亿分。那由他亿分。百那由他亿分。千那由他亿分。百千那由他亿分。数分。歌罗分。算分。谕分。优波尼沙陀分。亦不及一。佛子。且置此谕。假使有人。以一切乐具。供养十方。十阿僧祇世界。所有众生。经于百劫。然后教令修十善道。如是供养。经于千劫。教住四禅。经于百千劫。教住四无量心。经于亿劫。教住四无色定。经于百亿劫。教住须陀洹果。经于千亿劫。教住斯陀含果。经于百千亿劫。教住阿那含果。经于那由他亿劫。教住阿罗汉果。经于百千那由他亿劫。教住辟支佛道。佛子。于意云何。是人功德。宁为多不。天帝言。佛子。此人功德。唯佛能知。法慧菩萨言。佛子。此人功德。比菩萨初发心功德。百分不及一。千分不及一。百千分不及一。乃至优波尼沙陀分。亦不及一。何以故。佛子。一切诸佛。初发心时。不但为以一切乐具。供养十方。十阿僧祇世界。所有众生。经于百劫。乃至百千那由他亿劫故。发菩提心。不但为教尔所众生。令修五戒。十善业道。教住四禅。四无量心。四无色定。教得须陀洹果。斯陀含果。阿那含果。阿罗汉果。辟支佛道故。发菩提心。为令如来种性。不断故。为充遍一切世界故。为度脱一切世界众生故。为悉知一切世界成坏故。为悉知一切世界中。众生垢净故。为悉知一切世界。自性清净故。为悉知一切众生。心乐烦恼习气故。为悉知一切众生。死此生彼故。为悉知一切众生。诸根方便故。为悉知一切众生。心行故。为悉知一切众生。三世智故。为悉知一切佛境界。平等故。发于无上菩提之心。佛子。复置此谕假使有人。于一念顷。能过东方阿僧祇世界。念念如是。尽阿僧祇劫。此诸世界。无有能得知其边际。又第二人。于一念顷。能过前人。阿僧祇劫。所过世界。如是亦尽阿僧祇劫。次第展转。乃至第十。南西北方。四维上下。亦复如是。佛子。此十方中。凡有百人。一一如是。过诸世界。是诸世界。可知边际。菩萨初发阿耨多罗三藐三菩提心。所有善根。无有能得知其际者。何以故。佛子。菩萨不齐限。但为往尔所世界。得了知故。发菩提心。为了知十方世界故。发菩提心。所谓。欲了知妙世界。即是粗世界。粗世界。即是妙世界。仰世界。即是覆世界。覆世界。即是仰世界。小世界。即是大世界。大世界。即是小世界。广世界。即是狭世界。狭世界。即是广世界。一世界。即是不可说世界。不可说世界。即是一世界。不可说世界。入一世界。一世界入不可说世界。秽世界。即是净世界。净世界。即是秽世界。欲知一毛端中。一切世界。差别性。一切世界中。一毛端。一体性。欲知一世界中。出生一切世界。欲知一切世界。无体性。欲以一念心。尽知一切广大世界。而无障碍故。发阿耨多罗三藐三菩提心。佛子。复置此谕假使有人。于一念顷。能知东方阿僧祇世界。成坏劫数。念念如是。尽阿僧祇劫。此诸劫数。无有能得知其边际。有第二人。于一念顷。能知前人。阿僧祇劫。所知劫数。如是广说。乃至第十。南西北方。四维上下。亦复如是。佛子。此十方阿僧祇世界。成坏劫数。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。菩萨不齐限。但为知尔所世界。成坏劫数故。发阿耨多罗三藐三菩提心。为悉知一切世界。成坏劫尽。无余故。发阿耨多罗三藐三菩提心。所谓。知长劫与短劫平等。短劫与长劫平等。一劫与无数劫平等。无数劫与一劫平等。有佛劫与无佛劫平等。无佛劫与有佛劫平等。一佛劫中。有不可说佛。不可说佛劫中。有一佛。有量劫与无量劫平等。无量劫与有量劫平等。有尽劫与无尽劫平等。无尽劫与有尽劫平等。不可说劫。与一念平等。一念与不可说劫平等。一切劫入非劫。非劫入一切劫。欲于一念中。尽知前际后际。及现在一切世界。成坏劫故。发阿耨多罗三藐三菩提心。是名初发心。大誓庄严。了知一切劫神通智。佛子。复置此谕。假使有人。于一念顷。能知东方阿僧祇世界。所有众生。种种差别解。念念如是。尽阿僧祇劫。有第二人。于一念顷。能知前人。阿僧祇劫。所知众生。诸解差别。如是亦尽阿僧祇劫。次第展转。乃至第十。南西北方。四维上下。亦复如是。佛子。此十方众生。种种差别解。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。佛子。菩萨不齐限。但为知尔所众生解故。发阿耨多罗三藐三菩提心。为尽知一切世界。所有众生。种种差别解故。发阿耨多罗三藐三菩提心。所谓。欲知一切差别解。无边故。一众生解。无数众生解。平等故。欲得不可说差别解。方便智光明故。欲悉知众生海。各各差别解。尽无余故。欲悉知过现未来。善不善。种种无量解故。欲悉知相似解。不相似解故。欲悉知一切解。即是一解。一解即是一切解故。欲得如来解力故。欲悉知有上解无上解。有余解无余解。等解不等解。差别故。欲悉知有依解无依解。共解不共解。有边解无边解。差别解无差别解。善解不善解。世间解出世间解。差别故。欲于一切妙解。大解无量解。正位解中。得如来解脱。无障碍智故。欲以无量方便悉知十方。一切众生界。一一众生。净解染解。广解略解。细解粗解。尽无余故。欲悉知深密解方便解。分别解自然解。随因所起解。随缘所起解。一切解网。悉无余故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。能知东方无数世界。一切众生。诸根差别。念念如是。经阿僧祇劫。有第二人。于一念顷。能知前人。阿僧祇劫。念念所知。诸根差别。如是广说。乃至第十。南西北方。四维上下。亦复如是。佛子。此十方世界。所有众生。诸根差别。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。菩萨不齐限。但为知尔所世界众生根故。发阿耨多罗三藐三菩提心。为尽知一切世界中。一切众生根。种种差别。广说乃至。欲尽知一切诸根网故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。能知东方无数世界。所有众生。种种欲乐。念念如是。尽阿僧祇劫。次第广说。乃至第十。南西北方。四维上下。亦复如是。此十方众生。所有欲乐。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。佛子。菩萨不齐限。但为知尔所众生。欲乐故。发阿耨多罗三藐三菩提心。为尽知一切世界。所有众生。种种欲乐。广说乃至。欲尽知一切欲乐网故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。能知东方无数世界。所有众生。种种方便。如是广说。乃至第十。南西北方。四维上下。亦复如是。此十方众生。种种方便。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。佛子。菩萨不齐限。但为知尔所。世界众生。种种方便故。发阿耨多罗三藐三菩提心。为尽知一切世界。所有众生。种种方便。广说乃至。欲尽知一切方便网故。发阿耨多罗三藐三菩提心。佛子复置此谕。假使有人。于一念顷。能知东方无数世界。所有众生。种种差别心。广说乃至。此十方世界。所有众生。种种差别心。可知边际。菩萨初发阿耨多罗三藐三菩提心。功德善根。无有能得知其际者。何以故。佛子。菩萨不齐限。但为知尔所。众生心故。发阿耨多罗三藐三菩提心。为悉知尽法界虚空界。无边众生。种种心。乃至欲尽知一切心网故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。能知东方无数世界。所有众生。种种差别业。广说乃至。此十方众生。种种差别业。可知边际。菩萨初发阿耨多罗三藐三菩提心。善根边际。不可得知。何以故。佛子。菩萨不齐限。但为知尔所。众生业故。发阿耨多罗三藐三菩提心。欲悉知三世。一切众生业。乃至欲悉知一切业网故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。能知东方无数世界。所有众生。种种烦恼。念念如是。尽阿僧祇劫。此诸烦恼。种种差别。无有能得知其边际。有第二人。于一念顷。能知前人。阿僧祇劫。所知众生。烦恼差别。如是复尽阿僧祇劫。次第广说。乃至第十。南西北方。四维上下。亦复如是。佛子。此十方众生。烦恼差别。可知边际。菩萨初发阿耨多罗三藐三菩提心。善根边际。不可得知。何以故。佛子。菩萨不齐限。但为知尔所世界众生烦恼故。发阿耨多罗三藐三菩提心。为尽知一切世界。所有众生。烦恼差别故。发阿耨多罗三藐三菩提心。所谓。欲尽知轻烦恼重烦恼。眠烦恼起烦恼。一一众生。无量烦恼。种种差别。种种觉观。净治一切诸杂染故。欲尽知依无明烦恼。爱相应烦恼。断一切诸有趣。烦恼结故。欲尽知贪分烦恼。嗔分烦恼。痴分烦恼。等分烦恼。断一切烦恼根本故。欲悉知我烦恼。我所烦恼。我慢烦恼。觉悟一切烦恼。尽无余故。欲悉知从颠倒分别生。根本烦恼。随烦恼。因身见生。六十二见。调伏一切烦恼故。欲悉知盖烦恼障烦恼。发大悲救护心。断一切烦恼网。令一切智性。清净故。发阿耨多罗三藐三菩提心。佛子。复置此谕。假使有人。于一念顷。以诸种种上味饮食。香华衣服。幢幡伞盖。及僧伽蓝。上妙宫殿。宝帐网幔。种种庄严。师子之座。及众妙宝。供养东方无数诸佛。及无数世界。所有众生。恭敬尊重。礼拜赞叹。曲躬瞻仰。相续不绝。经无数劫。又劝彼众生。悉令如是供养于佛。至佛灭后。各为起塔。其塔高广。无数世界。众宝所成。种种庄严。一一塔中。各有无数如来形像。光明遍照无数世界。经无数劫。南西北方。四维上下。亦复如是。佛子。于汝意云何。此人功德。宁为多不。天帝言。是人功德。唯佛乃知。余无能测。佛子。此人功德。比菩萨初发心功德。百分不及一。千分不及一。百千分不及一。乃至优波尼沙陀分。亦不及一。佛子。复置此谕。假使复有第二人。于一念中。能作前人。及无数世界。所有众生。无数劫中。供养之事。念念如是。以无量种。供养之具。供养无量诸佛如来。及无量世界。所有众生。经无量劫。其第三人。乃至第十人。皆亦如是。于一念中。能作前人。所有供养。念念如是。以无边无等。不可数不可称。不可思不可量。不可说。不可说不可说。供养之具。供养无边。乃至不可说不可说诸佛。及尔许世界。所有众生。经无边乃至不可说不可说劫。至佛灭后。各为起塔。其塔高广。乃至住劫。亦复如是。佛子。此前功德。比菩萨初发心功德。百分不及一。千分不及一。百千分不及一。乃至优波尼沙陀分。亦不及一。何以故。佛子。菩萨摩诃萨。不齐限。但为供养尔所佛故。发阿耨多罗三藐三菩提心。为供养尽法界虚空界。不可说不可说。十方无量。去来现在。所有诸佛故。发阿耨多罗三藐三菩提心。发是心已。能知前际一切诸佛。始成正觉。及般涅槃。能信后际一切诸佛。所有善根。能知现在一切诸佛。所有智慧。彼诸佛所有功德。此菩萨能信能受。能修能得。能知能证。能成就。能与诸佛。平等一性。何以故。此菩萨。为不断一切如来种性故。发心。为充遍一切世界故。发心。为度脱一切世界众生故。发心。为悉知一切世界成坏故。发心。为悉知一切众生垢净故。发心。为悉知一切世界。三有清净故。发心。为悉知一切众生。心乐烦恼习气故。发心。为悉知一切众生。死此生彼故。发心。为悉知一切众生。诸根方便故。发心。为悉知一切众生心行故。发心。为悉知一切众生三世智故。发心。以发心故。常为三世一切诸佛之所忆念。当得三世一切诸佛。无上菩提。即为三世一切诸佛。与其妙法。即与三世一切诸佛。体性平等。已修三世一切诸佛。助道之法。成就三世一切诸佛。力无所畏。庄严三世一切诸佛。不共佛法。悉得法界一切诸佛。说法智慧。何以故。以是发心。当得佛故。应知此人。即与三世诸佛同等。即与三世诸佛如来境界平等。即与三世诸佛如来功德平等。得如来一身无量身究竟平等。真实智慧。才发心时。即为十方一切诸佛。所共称叹。即能说法。教化调伏一切世界。所有众生。即能震动一切世界。即能光照一切世界。即能息灭一切世界。诸恶道苦。即能严净一切国土。即能于一切世界中。示现成佛。即能令一切众生。皆得欢喜。即能入一切法界性。即能持一切佛种性。即能得一切佛智慧光明。此初发心菩萨。不于三世。少有所得。所谓。若诸佛。若诸佛法。若菩萨。若菩萨法。若独觉。若独觉法。若声闻。若声闻法。若世间。若世间法。若出世间。若出世间法。若众生。若众生法。唯求一切智。于诸法界。心无所著。尔时。佛神力故。十方各一万佛刹。微尘数世界。六种震动。所谓。动。遍动。等遍动。起。遍起。等遍起。涌。遍涌。等遍涌。震。遍震。等遍震。吼。遍吼。等遍吼击。遍击。等遍击。雨众天华。天香天末香。天华鬘。天衣天宝。天庄严具。作天妓乐放天光明。及天音声。是时。十方各过十佛刹。微尘数世界外。有万佛刹。微尘数佛。同名法慧。各现其身。在法慧菩萨前。作如是言。善哉善哉。法慧。汝于今者。能说此法。我等十方。各万佛刹。微尘数佛。亦说是法。一切诸佛悉如是说。汝说此法时。有万佛刹。微尘数菩萨。发菩提心。我等今者。悉授其记。于当来世。过千不可说无边劫。同一劫中。而得作佛。出兴于世。皆号清净心如来。所住世界。各各差别。我等悉当护持此法。令未来世。一切菩萨。未曾闻者。皆悉得闻。如此娑婆世界。四天下。须弥顶上。说如是法。令诸众生。闻已受化。如是十方。百千亿那由他。无数无量。无边无等。不可数不可称。不可思不可量。不可说。尽法界虚空界。诸世界中。亦说此法。教化众生。其说法者。同名法慧。悉以佛神力故。世尊本愿力故。为欲显示佛法故。为以智光普照故。为欲开阐实义故。为令证得法性故。为令众会悉欢喜故。为欲开示佛法因故。为得一切佛平等故。为了法界无有二故。说如是法

尔时。法慧菩萨。普观尽虚空界。十方国土。一切众会。欲悉成就诸众生故。欲悉净治诸业果报故。欲悉开显清净法界故。欲悉拔除杂染根本故。欲悉增长广大信解故。欲悉令知无量众生根故。欲悉令知三世法平等故。欲悉令观察涅槃界故。欲增长自清净善根故。承佛威力。即说颂言

  为利世间发大心　　其心普遍于十方
  众生国土三世法　　佛及菩萨最胜海
  究竟虚空等法界　　所有一切诸世间
  如诸佛法皆往诣　　如是发心无退转
  慈念众生无暂舍　　离诸恼害普饶益
  光明照世为所归　　十力护念难思议
  十方国土悉趣入　　一切色形皆示现
  如佛福智广无边　　随顺修因无所著
  有刹仰住或傍覆　　粗妙广大无量种
  菩萨一发最上心　　悉能往诣皆无碍
  菩萨胜行不可说　　皆勤修习无所住
  见一切佛常欣乐　　普入于其深法海
  哀愍五趣诸群生　　令除垢秽普清净
  绍隆佛种不断绝　　摧灭魔宫无有余
  已住如来平等性　　善修微妙方便道
  于佛境界起信心　　得佛灌顶心无著
  两足尊所念报恩　　心如金刚不可沮
  于佛所行能照了　　自然修习菩提行
  诸趣差别想无量　　业果及心亦非一
  乃至根性种种殊　　一发大心悉明见
  其心广大等法界　　无依无变如虚空
  趣向佛智无所取　　谛了实际离分别
  知众生心无生想　　了达诸法无法想
  虽普分别无分别　　亿那由刹皆往诣
  无量诸佛妙法藏　　随顺观察悉能入
  众生根行靡不知　　到如是处如世尊
  清净大愿恒相应　　乐供如来不退转
  人天见者无厌足　　常为诸佛所护念
  其心清净无所依　　虽观深法而不取
  如是思惟无量劫　　于三世中无所著
  其心坚固难制沮　　趣佛菩提无障碍
  志求妙道除蒙惑　　周行法界不告劳
  知语言法皆寂灭　　但入真如绝异解
  诸佛境界悉顺观　　达于三世心无碍
  菩萨始发广大心　　即能遍往十方刹
  法门无量不可说　　智光普照皆明了
  大悲广度最无比　　慈心普遍等虚空
  而于众生不分别　　如是清净游于世
  十方众生悉慰安　　一切所作皆真实
  恒以净心不异语　　常为诸佛共加护
  过去所有皆忆念　　未来一切悉分别
  十方世界普入中　　为度众生令出离
  菩萨具足妙智光　　善了因缘无有疑
  一切迷惑皆除断　　如是而游于法界
  魔王宫殿悉摧破　　众生翳膜咸除灭
  离诸分别心不动　　善了如来之境界
  三世疑网悉已除　　于如来所起净信
  以信得成不动智　　智清净故解真实
  为令众生得出离　　尽于后际普饶益
  长时勤苦心无厌　　乃至地狱亦安受
  福智无量皆具足　　众生根欲悉了知
  及诸业行无不见　　如其所乐为说法
  了知一切空无我　　慈念众生恒不舍
  以一大悲微妙音　　普入世间而演说
  放大光明种种色　　普照众生除黑闇
  光中菩萨坐莲华　　为众阐扬清净法
  于一毛端现众刹　　诸大菩萨皆充满
  众会智慧各不同　　悉能明了众生心
  十方世界不可说　　一念周行无不尽
  利益众生供养佛　　于诸佛所问深义
  于诸如来作父想　　为利众生修觉行
  智慧善巧通法藏　　入深智处无所著
  随顺思惟说法界　　经无量劫不可尽
  智虽善入无处所　　无有疲厌无所著
  三世诸佛家中生　　证得如来妙法身
  普为群生现众色　　譬如幻师无不作
  或现始修殊胜行　　或现初生及出家
  或现树下成菩提　　或为众生示涅槃
  菩萨所住希有法　　唯佛境界非二乘
  身语意想皆已除　　种种随宜悉能现
  菩萨所得诸佛法　　众生思惟发狂乱
  智入实际心无碍　　普现如来自在力
  此于世间无与等　　何况复增殊胜行
  虽未具足一切智　　已获如来自在力
  已住究竟一乘道　　深入微妙最上法
  善知众生时非时　　为利益故现神通
  分身遍满一切刹　　放净光明除世闇
  譬如龙王起大云　　普雨妙雨悉充洽
  观察众生如幻梦　　以业力故常流转
  大悲哀愍咸救拔　　为说无为净法性
  佛力无量此亦然　　譬如虚空无有边
  为令众生得解脱　　亿劫勤修而不倦
  种种思惟妙功德　　善修无上第一业
  于诸胜行恒不舍　　专念生成一切智
  一身示现无量身　　一切世界悉周遍
  其心清净无分别　　一念难思力如是
  于诸世间不分别　　于一切法无妄想
  虽观诸法而不取　　恒救众生无所度
  一切世间唯是想　　于中种种各差别
  知想境界险且深　　为现神通而救脱
  譬如幻师自在力　　菩萨神变亦如是
  身遍法界及虚空　　随众生心靡不见
  能所分别二俱离　　杂染清净无所取
  若缚若解智悉忘　　但愿普与众生乐
  一切世间唯想力　　以智而入心无畏
  思惟诸法亦复然　　三世推求不可得
  能入过去毕前际　　能入未来毕后际
  能入现在一切处　　常勤观察无所有
  随顺涅槃寂灭法　　住于无诤无所依
  心如实际无与等　　专向菩萨永不退
  修诸胜行无退怯　　安住菩萨不动摇
  佛及菩萨与世间　　尽于法界皆明了
  欲得最胜第一道　　为一切智解脱王
  应当速发菩提心　　永尽诸漏利群生
  趣向菩提心清净　　功德广大不可说
  为利众生故称述　　汝等诸贤应善听
  无量世界尽为尘　　一一尘中无量刹
  其中诸佛皆无量　　悉能明见无所取
  善知众生无生想　　善知言语无语想
  于诸世界心无碍　　悉善了知无所著
  其心广大如虚空　　于三世事悉明达
  一切疑惑皆除灭　　正观佛法无所取
  十方无量诸国土　　一念往诣心无著
  了达世间众苦法　　悉住无生真实际
  无量难思诸佛所　　悉往彼会而觐谒
  常为上首问如来　　菩萨所修诸愿行
  心常忆念十方佛　　而无所依无所取
  恒劝众生种善根　　庄严国土令清净
  一切众生三有处　　以无碍眼咸观察
  所有习性诸根解　　无量无边悉明见
  众生心乐悉了知　　如是随宜为说法
  于诸染净皆通达　　令彼修治入于道
  无量无数诸三昧　　菩萨一念皆能入
  于中想智及所缘　　悉善了知得自在
  菩萨获此广大智　　疾向菩提无所碍
  为欲利益诸群生　　处处宣扬大人法
  善知世间长短劫　　一月半月及昼夜
  国土各别性平等　　常勤观察不放逸
  普诣十方诸世界　　而于方处无所取
  严净国土悉无余　　亦不曾生净分别
  众生是处若非处　　及以诸业感报别
  随顺思惟入佛力　　于此一切悉了知
  一切世间种种性　　种种所行住三有
  利根及与中下根　　如是一切咸观察
  净与不净种种解　　胜劣及中悉明见
  一切众生至处行　　三有相续皆能说
  禅定解脱诸三昧　　染净因起各不同
  及以先世苦乐殊　　净修佛力咸能见
  众生业惑续诸趣　　断此诸趣得寂灭
  种种漏法永不生　　并其习种悉了知
  如来烦恼皆除尽　　大智光明照于世
  菩萨于佛十力中　　虽未证得亦无疑
  菩萨于一毛孔中　　普现十方无量刹
  或有杂染或清净　　种种业作皆能了
  一微尘中无量刹　　无量诸佛及佛子
  诸刹各别无杂乱　　如一一切悉明见
  于一毛孔见十方　　尽虚空界诸世间
  无有一处空无佛　　如是佛刹悉清净
  于毛孔中见佛刹　　复见一切诸众生
  三世六趣各不同　　昼夜月时有缚解
  如是大智诸菩萨　　专心趣向法王位
  于佛所住顺思惟　　而获无边大欢喜
  菩萨分身无量亿　　供养一切诸如来
  神通变现胜无比　　佛所行处皆能住
  无量佛所皆钻仰　　所有法藏悉耽味
  见佛闻法勤修行　　如饮甘露心欢喜
  已获如来胜三昧　　善入诸法智增长
  信心不动如须弥　　普作群生功德藏
  慈心广大遍众生　　悉愿疾成一切智
  而恒无著无依处　　离诸烦恼得自在
  哀愍众生广大智　　普摄一切同于己
  知空无相无真实　　而行其心不懈退
  菩萨发心功德量　　亿劫称扬不可尽
  以出一切诸如来　　独觉声闻安乐故
  十方国土诸众生　　皆悉施安无量劫
  劝持五戒及十善　　四禅四等诸定处
  复于多劫施安乐　　令断诸惑成罗汉
  彼诸福聚虽无量　　不与发心功德比
  又教亿众成缘觉　　获无诤行微妙道
  以彼而校菩提心　　算数譬谕无能及
  一念能过尘数刹　　如是经于无量劫
  此诸刹数尚可量　　发心功德不可知
  过去未来及现在　　所有劫数无边量
  此诸劫数犹可知　　发心功德无能测
  以菩提心遍十方　　所有分别靡不知
  一念三世悉明达　　利益无量众生故
  十方世界诸众生　　欲解方便意所行
  及以虚空际可测　　发心功德难知量
  菩萨志愿等十方　　慈心普洽诸群生
  悉使修成佛功德　　是故其力无边际
  众生欲解心所乐　　诸根方便行各别
  于一念中悉了知　　一切智智心同等
  一切众生诸惑业　　三有相续无暂断
  此诸边际尚可知　　发心功德难思议
  发心能离业烦恼　　供养一切诸如来
  业惑既离相续断　　普于三世得解脱
  一念供养无边佛　　亦供无数诸众生
  悉以香华及妙鬘　　宝幢幡盖上衣服
  美食珍座经行处　　种种宫殿悉严好
  毗卢遮那妙宝珠　　如意摩尼发光耀
  念念如是持供养　　经无量劫不可说
  其人福聚虽复多　　不及发心功德大
  所说种种众譬谕　　无有能及菩提心
  以诸三世人中尊　　皆从发心而得生
  发心无碍无齐限　　欲求其量不可得
  一切智智誓必成　　所有众生皆永度
  发心广大等虚空　　生诸功德同法界
  所行普遍如无异　　永离众着佛平等
  一切法门无不入　　一切国土悉能往
  一切智境咸通达　　一切功德皆成就
  一切能舍恒相续　　净诸戒品无所著
  具足无上大功德　　常勤精进不退转
  入深禅定恒思惟　　广大智慧共相应
  此是菩萨最胜地　　出生一切普贤道
  三世一切诸如来　　靡不护念初发心
  悉以三昧陀罗尼　　神通变化共庄严
  十方众生无有量　　世界虚空亦如是
  发心无量过于彼　　是故能生一切佛
  菩提心是十力本　　亦为四辩无畏本
  十八不共亦复然　　莫不皆从发心得
  诸佛色相庄严身　　及以平等妙法身
  智慧无著所应供　　悉以发心而得有
  一切独觉声闻乘　　色界诸禅三昧乐
  及无色界诸三昧　　悉以发心作其本
  一切人天自在乐　　及以诸趣种种乐
  进定根力等众乐　　靡不皆由初发心
  以因发起广大心　　则能修行六种度
  劝诸众生行正行　　于三界中受安乐
  住佛无碍实义智　　所有妙业咸开阐
  能令无量诸众生　　悉断惑业向涅槃
  智慧光明如净日　　众行具足犹满月
  功德常盈譬巨海　　无垢无碍同虚空
  普发无边功德愿　　悉与一切众生乐
  尽未来际依愿行　　常勤修习度众生
  无量大愿难思议　　愿令众生悉清净
  空无相愿无依处　　以愿力故皆明显
  了法自性如虚空　　一切寂灭悉平等
  法门无数不可说　　为众生说无所著
  十方世界诸如来　　悉共赞叹初发心
  此身无量德所严　　能到彼岸同于佛
  如众生数尔许劫　　说其功德不可尽
  以住如来广大家　　三界诸法无能谕
  欲知一切诸佛法　　宜应速发菩提心
  此心功德中最胜　　必得如来无碍智
  众生心行可数知　　国土微尘亦复然
  虚空边际乍可量　　发心功德无能测
  出生三世一切佛　　成就世间一切乐
  增长一切胜功德　　永断一切诸疑惑
  开示一切妙境界　　尽除一切诸障碍
  成就一切清净刹　　出生一切如来智
  欲见十方一切佛　　欲施无尽功德藏
  欲灭众生诸苦恼　　宜应速发菩提心

大方广佛华严经卷第十七大方广佛华严经卷第十八

        于阗国三藏实叉难陀奉　制译

    明法品第十八

尔时精进慧菩萨。白法慧菩萨言。佛子。菩萨摩诃萨。初发求一切智心。成就如是。无量功德。具大庄严。升一切智乘。入菩萨正位。舍诸世间法。得佛出世法。去来现在。诸佛摄受。决定至于无上菩提。究竟之处。彼诸菩萨。于佛教中。云何修习。令诸如来。皆生欢喜。入诸菩萨。所住之处。一切大行。皆得清净。所有大愿。悉使满足。获诸菩萨。广大之藏。随所应化。常为说法。而恒不舍波罗蜜行。所念众生。咸令得度。绍三宝种。使不断绝。善根方便。皆悉不虚。佛子。彼诸菩萨。以何方便。能令此法。当得圆满。愿垂哀愍。为我宣说。此诸大会。靡不乐闻。复次如诸菩萨摩诃萨。常勤修习。灭除一切无明黑暗。降伏魔怨制诸外道。永涤一切烦恼心垢。悉能成就一切善根。永出一切恶趣诸难。净治一切大智境界。成就一切菩萨诸地。诸波罗蜜。总持三昧。六通三明。四无所畏。清净功德。庄严一切诸佛国土。及诸相好。身语心行。成就满足。善知一切诸佛如来。力无所畏。不共佛法。一切智智。所行境界。为欲成熟一切众生。随其心乐。而取佛土。随根随时。如应说法。种种无量。广大佛事。及余无量。诸功德法。诸行诸道。及诸境界。皆悉圆满。疾与如来。功德平等。于诸如来。应正等觉。百千阿僧祇劫。修菩萨行时。所集法藏。悉能守护。开示演说。诸魔外道。无能沮坏。摄持正法。无有穷尽。于一切世界。演说法时。天王夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王。梵王。如来法王。皆悉守护。一切世间恭敬供养。同灌其顶。常为诸佛之所护念。一切菩萨。亦皆爱敬。得善根力。增长白法。开演如来。甚深法藏。摄持正法以自庄严。一切菩萨所行次第愿皆演说。尔时精进慧菩萨。欲重宣其义。而说颂言

  大名称者善能演　　菩萨所成功德法
  深入无边广大行　　具足清净无师智
  若有菩萨初发心　　成就福德智慧乘
  入离生位超世间　　普获正等菩提法
  彼复云何佛教中　　坚固勤修转增胜
  令诸如来悉欢喜　　佛所住地速当入
  所行清净愿皆满　　及得广大智慧藏
  常能说法度众生　　而心无依无所著
  菩萨一切波罗蜜　　悉善修行无缺减
  所念众生咸救度　　常持佛种使不绝
  所作坚固不唐捐　　一切功成得出离
  如诸胜者所修行　　彼清净道愿宣说
  永破一切无明暗　　降伏众魔及外道
  所有垢秽悉涤除　　得近如来大智慧
  永离恶趣诸险难　　净治大智殊胜境
  获妙道力邻上尊　　一切功德皆成就
  证得如来最胜智　　住于无量诸国土
  随众生心而说法　　及作广大诸佛事
  云何而得诸妙道　　开演如来正法藏
  常能受持诸佛法　　无能超胜无与等
  云何无畏如师子　　所行清净如满月
  云何修习佛功德　　犹如莲华不着水

尔时法慧菩萨。告精进慧菩萨言。善哉佛子。汝今为欲多所饶益。多所安乐。多所惠利。哀愍世间。诸天及人。问于如是菩萨所修清净之行。佛子。汝住实法。发大精进。增长不退。已得解脱。能作是问。同于如来。谛听谛听。善思念之。我今承佛威神之力。为汝于中。说其少分。佛子。菩萨摩诃萨。已发一切智心。应离痴暗。精勤守护。无令放逸。佛子。菩萨摩诃萨。住十种法。名不放逸。何者为十。一者护持众戒。二者远离愚痴。净菩提心。三者心乐质直。离诸谄诳。四者勤修善根无有退转。五者恒善思惟自所发心。六者不乐亲近在家出家。一切凡夫。七者修诸善业。而不愿求世间果报。八者永离二乘。行菩萨道。九者乐修众善。令不断绝。十者恒善观察。自相续力。佛子。若诸菩萨。行此十法。是则名为住不放逸。佛子。菩萨摩诃萨。住不放逸。得十种清净。何者为十。一者如说而行。二者念智成就。三者住于深定。不沈不举。四者乐求佛法。无有懈息。五者随所闻法。如理观察。具足出生巧妙智慧。六者入深禅定。得佛神通。七者其心平等。无有高下。八者于诸众生。上中下类。心无障碍。犹如大地。等作利益。九者若见众生。乃至一发菩提之心。尊重承事。犹如和尚。十者于授戒和尚。及阿阇梨。一切菩萨。诸善知识。法师之所。常生尊重。承事供养。佛子。是名菩萨。住不放逸。十种清净。佛子。菩萨摩诃萨。住不放逸。发大精进。起于正念。生胜欲乐。所行不息。于一切法。心无依处。于甚深法。能勤修习。入无诤门。增广大心。佛法无边。能顺了知。令诸如来。皆悉欢喜。佛子。菩萨摩诃萨。复有十法。能令一切诸佛欢喜。何等为十。一者精进不退。二者不惜身命。三者于诸利养。无有希求。四者知一切法。皆如虚空。五者善能观察。普入法界。六者知诸法印。心无倚着。七者常发大愿。八者成就清净忍智光明。九者观自善法。心无增减。十者依无作门。修诸净行。佛子。是为菩萨。住十种法。能令一切如来欢喜。佛子。复有十法。能令一切诸佛欢喜。何者为十。所谓。安住不放逸。安住无生忍。安住大慈。安住大悲。安住满足诸波罗蜜。安住诸行。安住大愿。安住巧方便。安住勇猛力。安住智慧。观一切法。皆无所住。犹如虚空。佛子。若诸菩萨。住此十法。能令一切诸佛欢喜。佛子。有十种法。令诸菩萨。速入诸地。何等为十。一者善巧圆满。福智二行。二者能大庄严波罗蜜道。三者智慧明达。不随他语。四者承事善友。恒不舍离。五者常行精进。无有懈怠。六者善能安住如来神力。七者修诸善根。不生疲倦。八者深心利智。以大乘法。而自庄严。九者于地地法门。心无所住。十者与三世佛。善根方便。同一体性。佛子。此十种法。令诸菩萨。速入诸地。复次佛子。诸菩萨。初住地时。应善观察。随其所有。一切法门。随其所有。甚深智慧。随所修因。随所得果。随其境界。随其力用。随其示现。随其分别。随其所得。悉善观察。知一切法。皆是自心。而无所著。如是知已。入菩萨地。能善安住。佛子。彼诸菩萨。作是思惟。我等宜应速入诸地。何以故。我等若于地地中住。成就如是广大功德。具功德已。渐入佛地。住佛地已。能作无边广大佛事。是故宜应常勤修习无有休息。无有疲厌。以大功德。而自庄严。入菩萨地。佛子。有十种法。令诸菩萨。所行清净。何等为十。一者悉舍资财。满众生意。二者持戒清净。无所毁犯。三者柔和忍辱。无有穷尽。四者勤修诸行。永不退转。五者以正念力。心无迷乱。六者分别了知无量诸法。七者修一切行。而无所著。八者其心不动。犹如山王。九者广度众生犹如桥梁。十者知一切众生。与诸如来。同一体性。佛子。是为十法。令诸菩萨。所行清净。菩萨既得行清净已。复获十种增胜法。何等为十。一者他方诸佛。皆悉护念。二者善根增胜。超诸等列。三者善能领受佛加持力。四者常得善人。为所依怙。五者安住精进。恒不放逸。六者知一切法。平等无异。七者心恒安住。无上大悲。八者如实观法。出生妙慧。九者能善修行巧妙方便。十者能知如来。方便之力。佛子。是为菩萨。十种增胜法。佛子。菩萨。有十种清净愿。何等为十。一愿成熟众生。无有疲倦。二愿具行众善。净诸世界。三愿承事如来。常生尊重。四愿护持正法。不惜躯命。五愿以智观察。入诸佛土。六愿与诸菩萨。同一体性。七愿入如来门。了一切法。八愿见者生信。无不获益。九愿神力。住世尽未来劫。十愿具普贤行。净治一切种智之门。佛子。是为菩萨。十种清净愿。佛子。菩萨住十种法。令诸大愿。皆得圆满。何等为十。一者心无疲厌。二者具大庄严。三者念诸菩萨。殊胜愿力。四者闻诸佛土。悉愿往生。五者深心长久。尽未来劫。六者愿悉成就一切众生。七者住一切劫。不以为劳。八者受一切苦。不生厌离。九者于一切乐。心无贪着。十者常勤守护。无上法门。佛子。菩萨满足如是愿时。即得十种无尽藏。何等为十。所谓。普见诸佛无尽藏。总持不忘无尽藏。决了诸法无尽藏。大悲救护无尽藏。种种三昧无尽藏。满众生心。广大福德无尽藏。演一切法。甚深智慧无尽藏。报得神通无尽藏。住无量劫无尽藏。入无边世界无尽藏。佛子。是为菩萨。十无尽藏。菩萨得是十种藏已。福德具足。智慧清净。于诸众生。随其所应。而为说法。佛子。菩萨云何于诸众生。随其所应。而为说法。所谓。知其所作。知其因缘。知其心行。知其欲乐。贪欲多者。为说不净。嗔恚多者。为说大慈。愚痴多者。教勤观察。三毒等者。为说成就胜智法门。乐生死者。为说三苦。若着处所。说处空寂。心懈怠者。说大精进。怀我慢者。说法平等。多谄诳者。为说菩萨。其心质直。乐寂静者。广为说法。令其成就。菩萨如是。随其所应。而为说法。为说法时。文相连属。义无舛谬。观法先后。以智分别。是非审定。不违法印。次第建立无边行门。令诸众生。断一切疑。善知诸根。入如来教。证真实际。知法平等。断诸法爱。除一切执。常念诸佛。心无暂舍。了知音声。体性平等。于诸言说。心无所著。巧说譬谕。无相违反。悉令得悟。一切诸佛。随应普现平等智身。菩萨如是。为诸众生。而演说法。则自修习。增长义利。不舍诸度。具足庄严波罗蜜道。是时菩萨。为令众生。心满足故。内外悉舍。而无所著。是则能净檀波罗蜜。具持众戒。而无所著。永离我慢。是则能净尸波罗蜜。悉能忍受一切诸恶。于诸众生。其心平等。无有动摇。譬如大地。能持一切。是则能净忍波罗蜜。普发众业常修靡懈。诸有所作。恒不退转。勇猛势力。无能制伏。于诸功德。不取不舍。而能满足。一切智门。是则能净精进波罗蜜。于五欲境。无所贪着。诸次第定。悉能成就。常正思惟。不住不出。而能销灭一切烦恼。出生无量诸三昧门。成就无边大神通力。逆顺次第。入诸三昧。于一三昧门。入无边三昧门。悉知一切三昧境界。与一切三昧。三摩钵底智印。不相违背。能速入于一切智地。是则能净禅波罗蜜。于诸佛所。闻法受持。近善知识。承事不倦。常乐闻法。心无厌足。随所听受。如理思惟。入真三昧。离诸僻见。善观诸法。得实相印。了知如来。无功用道。乘普门慧。入于一切智智之门。永得休息。是则能净般若波罗蜜。示现一切世间作业。教化众生。而不厌倦。随其心乐。而为现身。一切所行。皆无染着。或现凡夫。或现圣人。所行之行。或现生死。或现涅槃。善能观察一切所作。示现一切诸庄严事。而不贪着。遍入诸趣。度脱众生。是则能净方便波罗蜜。尽成就一切众生。尽庄严一切世界。尽供养一切诸佛。尽通达无障碍法。尽修行遍法界行。身恒住尽未来劫智。尽知一切心念。尽觉悟流转还灭。尽示现一切国土。尽证得如来智慧。是则能净愿波罗蜜。具深心力。无有杂染故。具深信力。无能摧伏故。具大悲力。不生疲厌故。具大慈力。所行平等故。具总持力。能以方便。持一切义故。具辩才力。令一切众生。欢喜满足故。具波罗蜜力。庄严大乘故。具大愿力。永不断绝故。具神通力。出生无量故。具加持力。令信解领受故。是则能净力波罗蜜。知贪欲行者。知嗔恚行者。知愚痴行者。知等分行者。知修学地行者。一念中知无边众生行。知无边众生心。知一切法真实。知一切如来力。普觉悟法界门。是则能净智波罗蜜。佛子。菩萨如是。清净诸波罗蜜时。圆满诸波罗蜜时。不舍诸波罗蜜时。住大庄严菩萨乘中。随其所念一切众生。皆为说法。令增净业。而得度脱。堕恶道者。教使发心。在难中者。令勤精进。多贪众生。示无贪法。多嗔众生。令行平等。着见众生。为说缘起。欲界众生。教离欲恚恶不善法。色界众生。为其宣说毗钵舍那。无色界众生。为其宣说微妙智慧。二乘之人。教寂静行。乐大乘者。为说十力。广大庄严。如其往昔。初发心时。见无量众生。堕诸恶道。大师子吼。作如是言。我当以种种法门。随其所应。而度脱之。菩萨具足如是智慧。广能度脱一切众生。佛子。菩萨具足如是智慧。令三宝种。永不断绝。所以者何。菩萨摩诃萨。教诸众生。发菩提心。是故能令佛种不断。常为众生。开阐法藏。是故能令法种不断。善持教法。无所乖违。是故能令僧种不断。复次悉能称赞一切大愿。是故能令佛种不断。分别演说因缘之门。是故能令法种不断。常勤修习六和敬法。是故能令僧种不断。复次于众生田中。下佛种子。是故能令佛种不断。护持正法。不惜身命。是故能令法种不断。统理大众。无有疲倦。是故能令僧种不断。复次于去来今佛。所说之法。所制之戒。皆悉奉持。心不舍离。是故能令佛法僧种。永不断绝。菩萨如是。绍隆三宝。一切所行。无有过失。随有所作。皆以回向一切智门。是故三业。皆无瑕玷。无瑕玷故。所作众善。所行诸行。教化众生。随应说法。乃至一念。无有错谬。皆与方便智慧相应。悉以向于一切智智。无空过者。菩萨如是。修习善法。念念具足十种庄严。何者为十。所谓。身庄严。随诸众生。所应调伏。而为示现故。语庄严。断一切疑。皆令欢喜故。心庄严。于一念中。入诸三昧故。佛刹庄严。一切清净。离诸烦恼故。光明庄严。放无边光。普照众生故。众会庄严。普摄众会。皆令欢喜故。神通庄严。随众生心。自在示现故。正教庄严。能摄一切聪慧人故。涅槃地庄严。于一处成道。周遍十方。悉无余故。巧说庄严。随处随时。随其根器。为说法故。菩萨成就如是庄严。于念念中。身语意业。皆无空过。悉以回向一切智门。若有众生。见此菩萨。当知亦复无空过者。以必当成阿耨多罗三藐三菩提故。若闻名若供养。若同住若忆念。若随出家。若闻说法。若随喜善根。若遥生钦敬。乃至称扬。赞叹名字。皆当得阿耨多罗三藐三菩提。佛子。譬如有药。名为善见。众生见者。众毒悉除。菩萨如是。成就此法。众生若见。诸烦恼毒。皆得除灭。善法增长。佛子。菩萨摩诃萨。住此法中。勤加修习。以智慧明。灭诸痴闇。以慈悲力。摧伏魔军。以大智慧。及福德力。制诸外道。以金刚定。灭除一切心垢烦恼。以精进力。集诸善根。以净佛土。诸善根力。远离一切恶道诸难。以无所著力。净智境界。以方便智慧力。出生一切菩萨诸地。诸波罗蜜。及诸三昧。六通三明。四无所畏。悉令清净。以一切善法力。成满一切诸佛净土。无边相好。身语及心。具足庄严。以智自在观察力。知一切如来。力无所畏。不共佛法。悉皆平等。以广大智慧力。了知一切智智境界。以往昔誓愿力。随所应化。现佛国土。转大法轮。度脱无量无边众生。佛子。菩萨摩诃萨。勤修此法。次第成就。诸菩萨行。乃至得与诸佛平等。于无边世界中。为大法师。护持正法。一切诸佛之所护念。守护受持广大法藏。获无碍辩。深入法门。于无边世界。大众之中。随类不同。普现其身。色相具足。最胜无比。以无碍辩。巧说深法。其音圆满。善巧分布故。能令闻者。入于无尽智慧之门。知诸众生。心行烦恼。而为说法。所出言音。具足清净故。一音演畅。能令一切皆生欢喜。其身端正。有大威力故。处于众会。无能过者。善知众心故。能普现身。善巧说法故。音声无碍。得心自在故。巧说大法。无能沮坏。得无所畏故。心无怯弱。于法自在故。无能过者。于智自在故。无能胜者。般若波罗蜜自在故。所说法相。不相违背。辩才自在故。随乐说法。相续不断。陀罗尼自在故。决定开示诸法实相。辩才自在故。随所演说。能开种种譬谕之门。大悲自在故。勤诲众生。心无懈息。大慈自在故。放光明网。悦可众心。菩萨如是。处于高广师子之座。演说大法。唯除如来。及胜愿智。诸大菩萨。其余众生。无能胜者。无见顶者。无映夺者。欲以难问令其退屈。无有是处。佛子。菩萨摩诃萨。得如是自在力已。假使有不可说世界量。广大道场。满中众生。一一众生。威德色相。皆如三千大千世界主。菩萨于此。才现其身。悉能映蔽如是大众。以大慈悲。安其怯弱。以深智慧。察其欲乐。以无畏辩。为其说法。能令一切。皆生欢喜。何以故。佛子。菩萨摩诃萨。成就无量智慧轮故。成就无量巧分别故。成就广大正念力故。成就无尽善巧慧故。成就决了诸法实相陀罗尼故。成就无边际。菩提心故。成就无错谬。妙辩才故。成就得一切佛加持。深信解故。成就普入三世诸佛。众会道场。智慧力故。成就知三世诸佛。同一体性。清净心故。成就三世一切如来智。一切菩萨大愿智。能作大法师。开阐诸佛正法藏。及护持故。尔时。法慧菩萨。欲重宣其义。承佛神力。而说颂言

  心住菩提集众福　　常不放逸植坚慧
  正念其意恒不忘　　十方诸佛皆欢喜
  念欲坚固自勤励　　于世无依无退怯
  以无诤行入深法　　十方诸佛皆欢喜
  佛欢喜已坚精进　　修行福智助道法
  入于诸地净众行　　满足如来所说愿
  如是而修获妙法　　既得法已施群生
  随其心乐及根性　　悉顺其宜为开演
  菩萨为他演说法　　不舍自己诸度行
  波罗蜜道既已成　　常于有海济群生
  昼夜勤修无懈倦　　令三宝种不断绝
  所行一切白净法　　悉以回向如来地
  菩萨所修众善行　　普为成就诸群生
  令其破闇灭烦恼　　降伏魔军成正觉
  如是修行得佛智　　深入如来正法藏
  为大法师演妙法　　譬如甘露悉沾洒
  慈悲哀愍遍一切　　众生心行靡不知
  如其所乐为开阐　　无量无边诸佛法
  进止安徐如象王　　勇猛无畏犹师子
  不动如山智如海　　亦如大雨除众热

时法慧菩萨。说此颂已。如来欢喜。大众奉行

大方广佛华严经卷第十八大方广佛华严经卷第十九

        于阗国三藏实叉难陀奉　制译

    升夜摩天宫品第十九

尔时如来威神力故。十方一切世界。一一四天下。南阎浮提。及须弥顶上。皆见如来。处于众会。彼诸菩萨。悉以佛神力故。而演说法。莫不自谓恒对于佛。尔时世尊。不离一切菩提树下。及须弥山顶。而向于彼夜摩天宫。宝庄严殿。时夜摩天王。遥见佛来。即以神力。于其殿内。化作宝莲华藏师子之座。百万层级。以为庄严。百万金网。以为交络。百万华帐。百万鬘帐。百万香帐。百万宝帐。弥覆其上。华盖鬘盖。香盖宝盖。各亦百万。周回布列。百万光明。而为照耀。百万夜摩天王。恭敬顶礼。百万梵王。踊跃欢喜。百万菩萨。称扬赞叹。百万天乐。各奏百万种法音。相续不断。百万种华云。百万种鬘云。百万种庄严具云。百万种衣云。周匝弥覆。百万种摩尼云。光明照耀。从百万种善根所生。百万诸佛之所护持。百万种福德之所增长。百万种深心。百万种誓愿之所严净。百万种行之所生起。百万种法之所建立。百万种神通之所变现。恒出百万种言音。显示诸法。时彼天王。敷置座已。向佛世尊。曲躬合掌。恭敬尊重。而白佛言。善来世尊。善来善逝。善来如来。应正等觉。唯愿哀愍。处此宫殿。时佛受请。即升宝殿。一切十方。悉亦如是。尔时天王。即自忆念过去佛所。所种善根。承佛神力。而说颂言

  名称如来闻十方　　诸吉祥中最无上
  彼曾入此摩尼殿　　是故此处最吉祥
  宝王如来世间灯　　诸吉祥中最无上
  彼曾入此清净殿　　是故此处最吉祥
  喜目如来见无碍　　诸吉祥中最无上
  彼曾入此庄严殿　　是故此处最吉祥
  然灯如来照世间　　诸吉祥中最无上
  彼曾入此殊胜殿　　是故此处最吉祥
  饶益如来利世间　　诸吉祥中最无上
  彼曾入此无垢殿　　是故此处最吉祥
  善觉如来无有师　　诸吉祥中最无上
  彼曾入此宝香殿　　是故此处最吉祥
  胜天如来世中灯　　诸吉祥中最无上
  彼曾入此妙香殿　　是故此处最吉祥
  无去如来论中雄　　诸吉祥中最无上
  彼曾入此普眼殿　　是故此处最吉祥
  无胜如来具众德　　诸吉祥中最无上
  彼曾入此善严殿　　是故此处最吉祥
  苦行如来利世间　　诸吉祥中最无上
  彼曾入此普严殿　　是故此处最吉祥

如此世界中夜摩天王。承佛神力。忆念往昔。诸佛功德。称扬赞叹。十方世界。夜摩天王。悉亦如是。叹佛功德。尔时世尊。入摩尼庄严殿。于宝莲华藏。师子座上。结跏趺坐。此殿忽然。广博宽容。如其天众。诸所住处。十方世界。悉亦如是

    大方广佛华严经夜摩宫中偈赞品第二十

尔时。佛神力故。十方各有一大菩萨。一一各与佛刹。微尘数菩萨俱。从十万佛刹。微尘数国土外。诸世界中。而来集会其名。曰功德林菩萨。慧林菩萨。胜林菩萨。无畏林菩萨。惭愧林菩萨。精进林菩萨。力林菩萨。行林菩萨。觉林菩萨。智林菩萨。此诸菩萨。所从来国。所谓。亲慧世界。幢慧世界。宝慧世界。胜慧世界。灯慧世界。金刚慧世界。安乐慧世界。日慧世界。净慧世界。梵慧世界。此诸菩萨。各于佛所。净修梵行。所谓。常住眼佛。无胜眼佛。无住眼佛。不动眼佛。天眼佛。解脱眼佛。审谛眼佛。明相眼佛。最上眼佛。绀青眼佛。是诸菩萨。至佛所已。顶礼佛足。随所来方。各化作摩尼藏。师子之座。于其座上。结跏趺坐。如此世界中。夜摩天上。菩萨来集。一切世界。悉亦如是。其诸菩萨。世界如来。所有名号。悉等无别。尔时世尊。从两足上。放百千亿。妙色光明。普照十方。一切世界。夜摩宫中。佛及大众。靡不皆现。尔时功德林菩萨。承佛威力。普观十方。而说颂言

  佛放大光明　　普照于十方
  悉见天人尊　　通达无障碍
  佛坐夜摩宫　　普遍十方界
  此事甚奇特　　世间所希有
  须夜摩天王　　偈赞十如来
  如此会所见　　一切处咸尔
  彼诸菩萨众　　皆同我等名
  十方一切处　　演说无上法
  所从诸世界　　名号亦无别
  各于其佛所　　净修于梵行
  彼诸如来等　　名号悉亦同
  国土皆丰乐　　神力悉自在
  十方一切处　　皆谓佛在此
  或见在人间　　或见住天宫
  如来普安住　　一切诸国土
  我等今见佛　　处此天宫殿
  昔发菩提愿　　普及十方界
  是故佛威力　　充遍难思议
  远离世所贪　　具足无边德
  故获神通力　　众生靡不见
  游行十方界　　如空无所碍
  一身无量身　　其相不可得
  佛功德无边　　云何可测知
  无住亦无去　　普入于法界

尔时慧林菩萨。承佛威力。普观十方。而说颂言

  世间大导师　　离垢无上尊
  不可思议劫　　难可得值遇
  佛放大光明　　世间靡不见
  为众广开演　　饶益诸群生
  如来出世间　　为世除痴冥
  如是世间灯　　希有难可见
  已修施戒忍　　精进及禅定
  般若波罗蜜　　以此照世间
  如来无与等　　求比不可得
  不了法真实　　无有能得见
  佛身及神通　　自在难思议
  无去亦无来　　说法度众生
  若有得见闻　　清净天人师
  永出诸恶趣　　舍离一切苦
  无量无数劫　　修习菩提行
  不能知此义　　不可得成佛
  不可思议劫　　供养无量佛
  若能知此义　　功德超于彼
  无量刹珍宝　　满中施于佛
  不能知此义　　终不成菩提

尔时胜林菩萨。承佛威力。普观十方。而说颂言

  譬如孟夏月　　空净无云曀
  赫日扬光晖　　十方靡不充
  其光无限量　　无有能测知
  有目斯尚然　　何况盲冥者
  诸佛亦如是　　功德无边际
  不可思议劫　　莫能分别知
  诸法无来处　　亦无能作者
  无有所从生　　不可得分别
  一切法无来　　是故无有生
  以生无有故　　灭亦不可得
  一切法无生　　亦复无有灭
  若能如是解　　斯人见如来
  诸法无生故　　自性无所有
  如是分别知　　此人达深义
  以法无性故　　无有能了知
  如是解于法　　究竟无所解
  所说有生者　　以现诸国土
  能知国土性　　其心不迷惑
  世间国土性　　观察悉如实
  若能于此知　　善说一切义

尔时无畏林菩萨。承佛威力。普观十方。而说颂言

  如来广大身　　究竟于法界
  不离于此座　　而遍一切处
  若闻如是法　　恭敬信乐者
  永离三恶道　　一切诸苦难
  设往诸世界　　无量不可数
  专心欲听闻　　如来自在力
  如是诸佛法　　是无上菩提
  假使欲暂闻　　无有能得者
  若有于过去　　信如是佛法
  已成两足尊　　而作世间灯
  若有当得闻　　如来自在力
  闻已能生信　　彼亦当成佛
  若有于现在　　能信此佛法
  亦当成正觉　　说法无所畏
  无量无数劫　　此法甚难值
  若有得闻者　　当知本愿力
  若有能受持　　如是诸佛法
  持已广宣说　　此人当成佛
  况复勤精进　　坚固心不舍
  当知如是人　　决定成菩提

尔时惭愧林菩萨。承佛威力。普观十方。而说颂言

  若人得闻是　　希有自在法
  能生欢喜心　　疾除疑惑网
  一切知见人　　自说如是言
  如来无不知　　是故难思议
  无有从无智　　而生于智慧
  世间常暗冥　　是故无能生
  如色及非色　　此二不为一
  智无智亦然　　其体各殊异
  如相与无相　　生死及涅槃
  分别各不同　　智无智如是
  世界始成立　　无有败坏相
  智无智亦然　　二相非一时
  如菩萨初心　　不与后心俱
  智无智亦然　　二心不同时
  譬如诸识身　　各各无和合
  智无智如是　　究竟无和合
  如阿伽陀药　　能灭一切毒
  有智亦如是　　能灭于无智
  如来无有上　　亦无与等者
  一切无能比　　是故难值遇

尔时精进林菩萨。承佛威力。普观十方。而说颂言

  诸法无差别　　无有能知者
  唯佛与佛知　　智慧究竟故
  如金与金色　　其性无差别
  法非法亦然　　体性无有异
  众生非众生　　二俱无真实
  如是诸法性　　实义俱非有
  譬如未来世　　无有过去相
  诸法亦如是　　无有一切相
  譬如生灭相　　种种皆非实
  诸法亦复然　　自性无所有
  涅槃不可取　　说时有二种
  诸法亦复然　　分别有殊异
  如依所数物　　而有于能数
  彼性无所有　　如是了知法
  譬如算数法　　增一至无量
  数法无体性　　智慧故差别
  譬如诸世间　　劫烧有终尽
  虚空无损败　　佛智亦如是
  是十方众生　　各取虚空相
  诸佛亦如是　　世间妄分别

尔时力林菩萨。承佛威力。普观十方。而说颂言

  一切众生界　　皆在三世中
  三世诸众生　　悉住五蕴中
  诸蕴业为本　　诸业心为本
  心法犹如幻　　世间亦如是
  世间非自作　　亦复非他作
  而其得有成　　亦复得有坏
  世间虽有成　　世间虽有坏
  了达世间者　　此二不应说
  云何为世间　　云何非世间
  世间非世间　　但是名差别
  三世五蕴法　　说名为世间
  彼灭非世间　　如是但假名
  云何说诸蕴　　诸蕴有何性
  蕴性不可灭　　是故说无生
  分别此诸蕴　　其性本空寂
  空故不可灭　　此是无生义
  众生既如是　　诸佛亦复然
  佛及诸佛法　　自性无所有
  能知此诸法　　如实不颠倒
  一切知见人　　常见在其前

尔时行林菩萨。承佛威力。普观十方。而说颂言

  譬如十方界　　一切诸地种
  自性无所有　　无处不周遍
  佛身亦如是　　普遍诸世界
  种种诸色相　　无主无来处
  但以诸业故　　说名为众生
  亦不离众生　　而有业可得
  业性本空寂　　众生所依止
  普作众色相　　亦复无来处
  如是诸色相　　业力难思议
  了达其根本　　于中无所见
  佛身亦如是　　不可得思议
  种种诸色相　　普现十方刹
  身亦非是佛　　佛亦非是身
  但以法为身　　通达一切法
  若能见佛身　　清净如法性
  此人于佛法　　一切无疑惑
  若见一切法　　本性如涅槃
  是则见如来　　究竟无所住
  若修习正念　　明了见正觉
  无相无分别　　是名法王子

尔时觉林菩萨。承佛威力。遍观十方。而说颂言

  譬如工画师　　分布诸彩色
  虚妄取异相　　大种无差别
  大种中无色　　色中无大种
  亦不离大种　　而有色可得
  心中无彩画　　彩画中无心
  然不离于心　　有彩画可得
  彼心恒不住　　无量难思议
  示现一切色　　各各不相知
  譬如工画师　　不能知自心
  而由心故画　　诸法性如是
  心如工画师　　能画诸世间
  五蕴悉从生　　无法而不造
  如心佛亦尔　　如佛众生然
  应知佛与心　　体性皆无尽
  若人知心行　　普造诸世间
  是人则见佛　　了佛真实性
  心不住于身　　身亦不住心
  而能作佛事　　自在未曾有
  若人欲了知　　三世一切佛
  应观法界性　　一切唯心造

尔时智林菩萨。承佛威力。普观十方。而说颂言

  所取不可取　　所见不可见
  所闻不可闻　　一心不思议
  有量及无量　　二俱不可取
  若有人欲取　　毕竟无所得
  不应说而说　　是为自欺诳
  己事不成就　　不令众欢喜
  有欲赞如来　　无边妙色身
  尽于无数劫　　无能尽称述
  譬如随意珠　　能现一切色
  无色而现色　　诸佛亦如是
  又如净虚空　　非色不可见
  虽现一切色　　无能见空者
  诸佛亦如是　　普现无量色
  非心所行处　　一切莫能睹
  虽闻如来声　　音声非如来
  亦不离于声　　能知正等觉
  菩提无来去　　离一切分别
  云何于是中　　自言能得见
  诸佛无有法　　佛于何有说
  但随其自心　　谓说如是法

    大方广佛华严经十行品第二十一之一

尔时功德林菩萨。承佛神力。入菩萨善思惟三昧。入是三昧已。十方各过万佛刹。微尘数世界外。有万佛刹。微尘数诸佛。皆号功德林。而现其前。告功德林菩萨言。善哉佛子。乃能入此善思惟三昧。善男子。此是十方。各万佛刹。微尘数同名。诸佛共加于汝。亦是毗卢遮那如来。往昔愿力。威神之力。及诸菩萨。众善根力。令汝入是三昧。而演说法。为增长佛智故。深入法界故。了知众生界故。所入无碍故。所行无障故。得无量方便故。摄取一切智性故。觉悟一切诸法故。知一切诸根故。能持说一切法故。所谓。发起诸菩萨十种行。善男子。汝当承佛威神之力。而演此法。是时诸佛。即与功德林菩萨。无碍智无著智。无断智无师智。无痴智无异智。无失智无量智。无胜智无懈智。无夺智。何以故。此三昧力。法如是故。尔时诸佛。各申右手。摩功德林菩萨顶。时功德林菩萨即从定起。告诸菩萨言。佛子。菩萨行不可思议。与法界虚空界等。何以故。菩萨摩诃萨。学三世诸佛。而修行故。佛子。何等是菩萨摩诃萨行。佛子。菩萨摩诃萨。有十种行。三世诸佛之所宣说。何等为十。一者欢喜行。二者饶益行。三者无违逆行。四者无屈桡行。五者无痴乱行。六者善现行。七者无著行。八者难得行。九者善法行。十者真实行。是为十。佛子。何等为菩萨摩诃萨。欢喜行。佛子。此菩萨。为大施主。凡所有物。悉能惠施。其心平等。无有悔吝。不望果报。不求名称。不贪利养。但为救护一切众生。摄受一切众生。饶益一切众生。为学习诸佛本所修行。忆念诸佛本所修行。爱乐诸佛本所修行。清净诸佛本所修行。增长诸佛本所修行。住持诸佛本所修行。显现诸佛本所修行。演说诸佛本所修行。令诸众生。离苦得乐。佛子。菩萨摩诃萨。修此行时。令一切众生。欢喜爱乐。随诸方土。有贫乏处。以愿力故。往生于彼。豪贵大富。财宝无尽。假使于念念中。有无量无数众生。诣菩萨所。白言仁者。我等贫乏。靡所资赡。饥羸困苦。命将不全。唯愿慈哀。施我身肉。令我得食。以活其命。尔时菩萨。即便施之。令其欢喜。心得满足。如是无量百千众生。而来乞求。菩萨于彼。曾无退怯。但更增长慈悲之心。以是众生。咸来乞求。菩萨见之。倍复欢喜。作如是念。我得善利。此等众生。是我福田。是我善友。不求不请。而来教我。入佛法中。我今应当如是修学。不违一切众生之心。又作是念。愿我已作。现作。当作。所有善根。令我未来。于一切世界。一切众生中。受广大身。以是身肉。充足一切饥苦众生。乃至若有一小众生。未得饱足。愿不舍命。所割身肉。亦无有尽。以此善根。愿得阿耨多罗三藐三菩提。证大涅槃。愿诸众生。食我肉者。亦得阿耨多罗三藐三菩提。获平等智。具诸佛法。广作佛事。乃至入于无余涅槃。若一众生。心不满足。我终不证阿耨多罗三藐三菩提。菩萨如是。利益众生。而无我想。众生想。有想命想。种种想。补伽罗想。人想摩纳婆想。作者想受者想。但观法界众生界。无边际法。空法。无所有法。无相法。无体法。无处法。无依法。无作法。作是观时。不见自身。不见施物。不见受者。不见福田。不见业。不见报。不见果。不见大果。不见小果。尔时菩萨。观去来今。一切众生。所受之身。寻即坏灭。便作是念。奇哉众生。愚痴无智。于生死内。受无数身。危脆不停。速归坏灭。若已坏灭。若今坏灭。若当坏灭。而不能以不坚固身。求坚固身。我当尽学诸佛所学。证一切智。知一切法。为诸众生。说三世平等。随顺寂静。不坏法性。令其永得安隐快乐。佛子。是名菩萨摩诃萨。第一欢喜行。佛子。何等为菩萨摩诃萨。饶益行。此菩萨。护持净戒。于色声香味触。心无所著。亦为众生。如是宣说。不求威势。不求种族。不求富饶。不求色相。不求王位。如是一切。皆无所著。但坚持净戒。作如是念。我持净戒。必当舍离一切缠缚。贪求热恼。诸难逼迫。毁谤乱浊。得佛所赞。平等正法。佛子。菩萨如是。持净戒时。于一日中。假使无数。百千亿那由他。诸大恶魔。诣菩萨所。一一各将无量无数。百千亿那由他天女。皆于五欲。善行方便。端正姝丽。倾惑人心。执持种种珍玩之具。欲来惑乱菩萨道意。尔时菩萨。作如是念。此五欲者。是障道法。乃至障碍无上菩提。是故不生一念欲想。心净如佛。唯除方便。教化众生。而不舍于一切智心。佛子。菩萨不以欲因缘故。恼一众生。宁舍身命。而终不作恼众生事。菩萨自得见佛已来。未曾心生一念欲想。何况从事。若或从事。无有是处。尔时菩萨。但作是念。一切众生。于长夜中。想念五欲。趣向五欲。贪着五欲。其心决定。耽染沉溺。随其流转。不得自在。我今应当令此诸魔。及诸天女。一切诸生。住无上戒。住净戒已。于一切智。心无退转。得阿耨多罗三藐三菩提。乃至入于无余涅槃。何以故。此是我等。所应作业。应随诸佛。如是修学。作是学已。离诸恶行。计我无知。以智入于一切佛法。为众生说。令除颠倒。然知不离众生有颠倒。不离颠倒有众生。不于颠倒内有众生。不于众生内有颠倒。亦非颠倒是众生。亦非众生是颠倒。颠倒非内法。颠倒非外法。众生非内法。众生非外法。一切诸法。虚妄不实。速起速灭。无有坚固。如梦如影。如幻如化。诳惑愚夫。如是解者。即能觉了一切诸行。通达生死。及与涅槃。证佛菩提。自得度。令他得度。自解脱。令他解脱。自调伏。令他调伏。自寂静。令他寂静。自安隐。令他安隐。自离垢。令他离垢。自清净。令他清净。自涅槃。令他涅槃。自快乐。令他快乐。佛子。此菩萨。复作是念。我当随顺一切如来。离一切世间行。具一切诸佛法。住无上平等处。等观众生。明达境界。离诸过失。断诸分别。舍诸执着。善巧出离。心恒安住。无上无说。无依无动。无量无边。无尽无色。甚深智慧。佛子。是名菩萨摩诃萨。第二饶益行佛子。何等为菩萨摩诃萨。无违逆行。此菩萨常修忍法。谦下恭敬。不自害。不他害。不两害。不自取。不他取。不两取。不自着。不他着。不两着。亦不贪求名闻利养。但作是念。我当常为众生说法。令离一切恶。断贪嗔痴憍慢覆藏。悭嫉谄诳。令恒安住忍辱柔和。佛子。菩萨成就如是忍法。假使有百千亿。那由他阿僧祇众生。来至其所。一一众生。化作百千亿。那由他阿僧祇口。一一口出百千亿。那由他阿僧祇语。所谓。不可喜语。非善法语。不悦意语。不可爱语。非仁贤语。非圣智语。非圣相应语。非圣亲近语。深可厌恶语。不堪听闻语。以是言辞。毁辱菩萨。又此众生。一一各有百千亿。那由他阿僧祇手。一一手各执百千亿。那由他阿僧祇器仗。逼害菩萨。如是经于阿僧祇劫。曾无休息。菩萨遭此极大楚毒。身毛皆竖。命将欲断。作是念言。我因是苦。心若动乱。则自不调伏。自不守护。自不明了。自不修习。自不正定。自不寂静。自不爱惜。自生执着。何能令他。心得清净。菩萨尔时。复作是念。我从无始劫。住于生死。受诸苦恼。如是思惟。重自劝励。令心清净。而得欢喜。善自调摄。自能安住于佛法中。亦令众生。同得此法。复更思惟。此身空寂。无我我所。无有真实。性空无二。若苦若乐。皆无所有。诸法空故。我当解了。广为人说。令诸众生。灭除此见。是故我今。虽遭苦毒。应当忍受。为慈念众生故。饶益众生故。安乐众生故。怜愍众生故。摄受众生故。不舍众生故。自得觉悟故。令他觉悟故。心不退转故。趣向佛道故。是名菩萨摩诃萨。第三无违逆行

佛子。何等为菩萨摩诃萨。无屈桡行。此菩萨。修诸精进。所谓。第一精进。大精进。胜精进。殊胜精进。最胜精进。最妙精进。上精进。无上精进。无等精进。普遍精进。性无三毒。性无憍慢。性不覆藏。性不悭嫉。性无谄诳。性自惭愧。终不为恼一众生故。而行精进。但为断一切烦恼故。而行精进。但为拔一切惑本故。而行精进。但为除一切习气故。而行精进。但为知一切众生界故。而行精进。但为知一切众生。死此生彼故。而行精进。但为知一切众生。烦恼故。而行精进。但为知一切众生。心乐故。而行精进。但为知一切众生。境界故。而行精进。但为知一切众生。诸根胜劣故。而行精进。但为知一切众生。心行故。而行精进。但为知一切法界故。而行精进。但为知一切佛法。根本性故。而行精进。但为知一切佛法。平等性故。而行精进。但为知三世平等性故。而行精进。但为得一切佛法。智光明故。而行精进。但为证一切佛法智故。而行精进。但为知一切佛法。一实相故。而行精进。但为知一切佛法。无边际故。而行精进。但为得一切佛法。广大决定。善巧智故。而行精进。但为得分别演说一切佛法。句义智故。而行精进。佛子。菩萨摩诃萨。成就如是。精进行已。设有人言。汝颇能为无数世界。所有众生。以一一众生故。于阿鼻地狱。经无数劫。备受众苦。令彼众生。一一得值无数诸佛。出兴于世。以见佛故。具受众乐。乃至入于无余涅槃。汝乃当成阿耨多罗三藐三菩提。能尔。不耶。答言。我能。设复有人。作如是言。有无量阿僧祇大海。汝当以一毛端滴之。令尽有无量阿僧祇世界。尽抹为尘。彼滴及尘。一一数之。悉知其数。为众生故。经尔许劫。于念念中。受苦不断。菩萨不以闻此语故。而生一念。悔恨之心。但更增上欢喜踊跃。深自庆幸。得大善利。以我力故。令彼众生。永脱诸苦。菩萨以此所行方便。于一切世界中。令一切众生。乃至究竟。无余涅槃。是名菩萨摩诃萨。第四无屈桡行

佛子。何等为菩萨摩诃萨。离痴乱行。此菩萨。成就正念。心无散乱。坚固不动。最上清净。广大无量。无有迷惑。以是正念故。善解世间。一切语言。能持出世。诸法言说。所谓。能持色法。非色法言说。能持建立色。自性言说。乃至能持建立受想行识。自性言说心无痴乱。于世间中。死此生彼。心无痴乱。入胎出胎。心无痴乱。发菩提意。心无痴乱。事善知识。心无痴乱。勤修佛法。心无痴乱。觉知魔事。心无痴乱。离诸魔业。心无痴乱。于不可说劫。修菩萨行。心无痴乱。此菩萨。成就如是无量正念。于无量阿僧祇劫中。从诸佛菩萨。善知识所。听闻正法。所谓。甚深法。广大法。庄严法。种种庄严法。演说种种名句文身法。菩萨庄严法。佛神力光明无上法。正希望决定解清净法。不着一切世间法。分别一切世间法。甚广大法。离痴翳照了一切众生法。一切世间共法。不共法。菩萨智无上法。一切智自在法。菩萨听闻如是法已。经阿僧祇劫。不忘不失。心常忆念。无有间断。何以故。菩萨摩诃萨。于无量劫。修诸行时。终不恼乱一众生。令失正念。不坏正法。不断善根。心常增长广大智故。复次此菩萨摩诃萨。种种音声。不能惑乱。所谓。高大声。粗浊声。极令人恐怖声。悦意声。不悦意声。諠乱耳识声。沮坏六根声。此菩萨。闻如是等。无量无数。好恶音声。假使充满阿僧祇世界。未曾一念。心有散乱。所谓正念不乱。境界不乱。三昧不乱。入甚深法不乱。行菩提行不乱。发菩提心不乱忆念诸佛不乱。观真实法不乱。化众生智不乱。净众生智不乱。决了甚深义不乱。不作恶业故。无恶业障。不起烦恼故。无烦恼障。不轻慢法故。无有法障。不诽谤正法故。无有报障。佛子。如上所说。如是等声。一一充满。阿僧祇世界。于无量无数劫。未曾断绝。悉能坏乱众生身心。一切诸根。而不能坏此菩萨心。菩萨入三昧中。住于圣法。思惟观察一切音声。善知音声。生住灭相。善知音声。生住灭性。如是闻已。不生于贪。不起于嗔。不失于念。善取其相。而不染着。知一切声。皆无所有。实不可得。无有作者。亦无本际。与法界等。无有差别。菩萨如是。成就寂静身语意行。至一切智。永不退转。善入一切诸禅定门。知诸三昧。同一体性。了一切法。无有边际。得一切法。真实智慧。得离音声。甚深三昧。得阿僧祇诸三昧门。增长无量广大悲心。是时菩萨。于一念中。得无数百千三昧。闻如是声。心不惑乱。令其三昧。渐更增广。作如是念。我当令一切众生。安住无上。清净念中。于一切智。得不退转。究竟成就无余涅槃。是名菩萨摩诃萨。第五离痴乱行佛子。何等为菩萨摩诃萨。善现行。此菩萨。身业清净。语业清净。意业清净。住无所得。示无所得。身语意业。能知三业。皆无所有。无虚妄故。无有系缚。凡所示现。无性无依。住如实心。知无量心自性。知一切法自性。无得无相。甚深难入。住于正位。真如法性。方便出生。而无业报。不生不灭。住涅槃界。住寂静性。住于真实。无性之性。言语道断。超诸世间。无有所依。入离分别。无缚着法。入最胜智。真实之法。入非诸世间。所能了知。出世间法。此是菩萨。善巧方便。示现生相。佛子。此菩萨。作如是念。一切众生。无性为性。一切诸法。无为为性。一切国土。无相为相。一切三世。唯有言说。一切言说。于诸法中。无有依处。一切诸法。于言说中。亦无依处。菩萨如是。解一切法。皆悉甚深。一切世间。皆悉寂静。一切佛法。无所增益。佛法不异世间法。世间法不异佛法。佛法世间法。无有杂乱。亦无差别。了知法界体性平等。普入三世。永不舍离。大菩提心。恒不退转。化众生心。转更增长。大慈悲心。与一切众生。作所依处。菩萨尔时。复作是念。我不成熟众生。谁当成熟。我不调伏众生。谁当调伏。我不教化众生。谁当教化。我不觉悟众生。谁当觉悟。我不清净众生。谁当清净。此我所宜。我所应作。复作是念。若我自解此甚深法。唯我一人于阿耨多罗三藐三菩提。独得解脱。而诸众生。盲冥无目。入大险道。为诸烦恼之所缠缚。如重病人。恒受苦痛。处贪爱狱。不能自出。不离地狱。饿鬼畜生。阎罗王界。不能灭苦。不舍恶业。常处痴闇。不见真实。轮回生死。无得出离。住于八难。众垢所著。种种烦恼。覆障其心。邪见所迷。不行正道。菩萨如是。观诸众生。作是念言。若此众生。未成熟。未调伏。舍而取证阿耨多罗三藐三菩提。是所不应。我当先化众生。于不可说不可说劫。行菩萨行。未成熟者。先令成熟。未调伏者。先令调伏。是菩萨。住此行时。诸天魔梵。沙门婆罗门。一切世间。乾闼婆阿修罗等。若有得见。暂同住止。恭敬尊重。承事供养。及暂耳闻。一经心者。如是所作。悉不唐捐。必定当成阿耨多罗三藐三菩提。是名菩萨摩诃萨。第六善现行

大方广佛华严经卷第十九大方广佛华严经卷第二十

        于阗国三藏实叉难陀奉　制译

    十行品第二十一之二

佛子何等。为菩萨摩诃萨。无著行。佛子。此菩萨以无著心。于念念中。能入阿僧祇世界。严净阿僧祇世界。于诸世界。心无所著。往诣阿僧祇。诸如来所。恭敬礼拜。承事供养。以阿僧祇华。阿僧祇香。阿僧祇鬘。阿僧祇涂香。末香。衣服珍宝。幢幡妙盖。诸庄严具。各阿僧祇。以用供养。如是供养。为究竟无作法故。为住不思议法故。于念念中。见无数佛。于诸佛所。心无所著。于诸佛刹。亦无所著。于佛相好。亦无所著。见佛光明。听佛说法。亦无所著。于十方世界。及佛菩萨。所有众会。亦无所著。听佛法已。心生欢喜。志力广大。能摄能行。诸菩萨行。然于佛法。亦无所著。此菩萨。于不可说劫。见不可说佛。出兴于世。一一佛所。承事供养。皆悉尽。于不可说劫。心无厌足。见佛闻法。及见菩萨。众会庄严。皆无所著。见不净世界。亦无憎恶。何以故。此菩萨。如诸佛法。而观察故。诸佛法中。无垢无净。无闇无明。无异无一。无实无妄。无安隐无险难。无正道无邪道。菩萨如是。深入法界。教化众生。而于众生。不生执着。受持诸法。而于诸法。不生执着。发菩提心。住于佛住。而于佛住。不生执着。虽有言说。而于言说。心无所著。入众生趣。于众生趣。心无所著。了知三昧。能入能住。而于三昧。心无所著。往诣无量诸佛国土。若入若见。若于中住。而于佛土。心无所著。舍去之时。亦无顾恋。菩萨摩诃萨。以能如是。无所著故。于佛法中。心无障碍。了佛菩提。证法毗尼。住佛正教。修菩萨行。住菩萨心。思惟菩萨解脱之法。于菩萨住处。心无所染。于菩萨所行。亦无所著。净菩萨道。受菩萨记。得受记已。作如是念。凡夫愚痴。无知无见。无信无解。无聪敏行。顽嚚贪着。流转生死。不求见佛。不随明导。不信调御。迷误失错。入于险道。不敬十力王。不知菩萨恩。恋着住处。闻诸法空。心大惊怖。远离正法。住于邪法。舍夷坦道。入险难道。弃背佛意。随逐魔意。于诸有中。坚执不舍。菩萨如是。观诸众生。增长大悲。生诸善根。而无所著。菩萨尔时。复作是念。我当为一众生。于十方世界。一一国土。经不可说不可说劫。教化成熟。如为一众生。为一切众生。皆亦如是。终不以此。而生疲厌。舍而余去。又以毛端。遍量法界。于一毛端处。尽不可说不可说劫。教化调伏一切众生。如一毛端处。一一毛端处。皆亦如是。乃至不于一弹指顷。执着于我。起我我所想。于一一毛端处。尽未来劫。修菩萨行。不着身。不着法。不着念。不着愿。不着三昧。不着观察。不着寂定。不着境界。不着教化调伏众生。亦复不着入于法界。何以故。菩萨作是念。我应观一切法界如幻。诸佛如影。菩萨行如梦。佛说法如响。一切世间如化。业报所持故。差别身如幻。行力所起故。一切众生如心。种种杂染故。一切法如实际。不可变异故。又作是念。我当尽虚空遍法界。于十方国土中。行菩萨行。念念明达。一切佛法。正念现前。无所取着。菩萨如是。观身无我。见佛无碍。为化众生。演说诸法。令于佛法。发生无量。欢喜净信。救护一切。心无疲厌。无疲厌故。于一切世界。有众生。未成熟。未调伏处。悉诣于彼。方便化度。其中众生。种种音声。种种诸业。种种取着。种种施设。种种和合。种种流转。种种所作。种种境界。种种生。种种没。以大誓愿。安住其中。而教化之。不令其心。有动有退。亦不一念。生染着想。何以故。得无所著。无所依故。自利利他。清净满足。是名菩萨摩诃萨。第七无著行

佛子。何等为菩萨摩诃萨。难得行。此菩萨。成就难得善根。难伏善根。最胜善根。不可坏善根。无能过善根。不思议善根。无尽善根。自在力善根。大威德善根。与一切佛。同一性善根。此菩萨。修诸行时。于佛法中。得最胜解。于佛菩提。得广大解。于菩萨愿。未曾休息。尽一切劫。心无疲倦。于一切苦。不生厌离。一切众魔。所不能动。一切诸佛之所护念。具行一切菩萨苦行。修菩萨行。精勤匪懈。于大乘愿。恒不退转。是菩萨。安住此难得行已。于念念中。能转阿僧祇劫生死。而不舍菩萨大愿。若有众生。承事供养。乃至见闻。皆于阿耨多罗三藐三菩提。得不退转。此菩萨。虽了众生非有。而不舍一切众生界。譬如船师。不住此岸。不住彼岸。不住中流。而能运度此岸众生。至于彼岸。以往返无休息故。菩萨摩诃萨。亦复如是。不住生死。不住涅槃。亦复不住生死中流。而能运度此岸众生。置于彼岸。安隐无畏。无忧恼处。亦不于众生数。而有所著。不舍一众生。着多众生。不舍多众生。着一众生。不增众生界。不减众生界。不生众生界。不灭众生界。不尽众生界。不长众生界。不分别众生界。不二众生界。何以故。菩萨深入众生界。如法界。众生界法界。无有二。无二法中。无增无减。无生无灭。无有无无。无取无依。无著无二。何以故。菩萨了一切法。法界无二故。菩萨如是。以善方便。入深法界。住于无相。以清净相。庄严其身。了法无性。而能分别一切法相。不取众生。而能了知众生之数。不着世界。而现身佛刹。不分别法。而善入佛法。深达义理。而广演言教。了一切法。离欲真际。而不断菩萨道。不退菩萨行。常勤修习无尽之行。自在入于清净法界。譬如钻木。以出于火。火事无量。而火不灭。菩萨如是。化众生事。无有穷尽。而在世间。常住不灭。非究竟。非不究竟。非取。非不取。非依。非无依。非世法。非佛法。非凡夫。非得果。菩萨成就如是难得心。修菩萨行时。不说二乘法。不说佛法。不说世间。不说世间法。不说众生。不说无众生。不说垢。不说净。何以故。菩萨知一切法。无染无取。不转不退故。菩萨于如是。寂灭微妙。甚深最胜法中。修行时。亦不生念。我现修此行。已修此行。当修此行。不着蕴界处。内世间。外世间。内外世间。所起大愿。诸波罗蜜。及一切法。皆无所著。何以故。法界中。无有法名。向声闻乘。向独觉乘。无有法名。向菩萨乘。向阿耨多罗三藐三菩提。无有法名。向凡夫界。无有法名。向染向净。向生死向涅槃。何以故。诸法无二。无不二故。譬如虚空。于十方中。若去来今。求不可得。然非无虚空。菩萨如是。观一切法。皆不可得。然非无一切法。如实无异。不失所作。普示修行菩萨诸行。不舍大愿。调伏众生。转正法轮。不坏因果。亦不违于平等妙法。普与三世。诸如来等。不断佛种。不坏实相。深入于法。辩才无尽。闻法不着。至法渊底。善能开演。心无所畏。不舍佛住。不违世法。普现世间。而不着世间。菩萨如是。成就难得智慧心。修习诸行。于三恶趣。拔出众生。教化调伏。安置三世。诸佛道中。令不动摇。复作是念。世间众生。不知恩报。更相双对。邪见执着。迷惑颠倒。愚痴无智。无有信心。随逐恶友。起诸恶慧。贪爱无明。种种烦恼。皆悉充满。是我所修。菩萨行处。设有知恩。聪明慧解。及善知识。充满世间。我不于中。修菩萨行。何以故。我于众生。无所适莫。无所冀望。乃至不求一缕一毫。及以一字。赞美之言。尽未来劫。修菩萨行。未曾一念。自为于己。但欲度脱一切众生。令其清净。永得出离。何以故。于众生中。为明导者。法应如是。不取不求。但为众生。修菩萨道。令其得至安隐彼岸。成阿耨多罗三藐三菩提。是名菩萨摩诃萨。第八难得行。佛子。何等为菩萨摩诃萨。善法行。此菩萨。为一切世间。天人魔梵。沙门婆罗门。乾闼婆等。作清凉法池。摄持正法。不断佛种。得清净光明。陀罗尼故。说法授记。辩才无尽。得具足义。陀罗尼故。义辩无尽。得觉悟实法。陀罗尼故。法辩无尽。得训释言辞。陀罗尼故。辞辩无尽。得无边文句。无尽义无碍门。陀罗尼故。无碍辩无尽。得佛灌顶陀罗尼。灌其顶故。欢喜辩无尽。得不由他悟。陀罗尼门故。光明辩无尽。得同辩陀罗尼门故。同辩无尽。得种种义身。句身文身中。训释陀罗尼门故。训释辩无尽。得无边旋陀罗尼故。无边辩无尽。此菩萨。大悲坚固。普摄众生。于三千大千世界。变身金色。施作佛事。随诸众生。根性欲乐。以广长舌。于一音中。现无量音。应时说法。皆令欢喜。假使有不可说。种种业报。无数众生。共会一处。其会广大充满。不可说世界。菩萨。于彼众会中坐是。中众生。一一皆有不可说。阿僧祇口。一一口。能出百千亿。那由他音。同时发声。各别言辞。各别所问。菩萨于一念中。悉能领受。皆为酬对。令除疑惑。如一众会中。于不可说众会中。悉亦如是。复次假使一毛端处。念念出不可说不可说。道场众会。一切毛端处。皆亦如是。尽未来劫。彼劫可尽。众会无尽。是诸众会。于念念中。以各别言辞。各别所问。菩萨于一念中。悉能领受。无怖无怯。无疑无谬。而作是念。设一切众生。以如是语业。俱来问我。我为说法。无断无尽。皆令欢喜。住于善道。复令善解一切言辞。能为众生。说种种法。而于言语。无所分别。假使不可说不可说。种种言辞。而来问难。一念悉领。一音咸答。普使开悟。无有遗余。以得一切智灌顶故。以得无碍藏故。以得一切法。圆满光明故。具足一切智智故。佛子。此菩萨摩诃萨。安住善法行已。能自清净。亦能以无所著方便。而普饶益一切众生。不见有众生。得出离者。如于此三千大千世界。如是乃至于不可说。三千大千世界。变身金色。妙音具足。于一切法。无所障碍。而作佛事。佛子。此菩萨摩诃萨。成就十种身。所谓。入无边法界。非趣身。灭一切世间故。入无边法界。诸趣身。生一切世间故。不生身。住无生平等法故。不灭身。一切灭言说不可得故。不实身。得如实故。不妄身。随应现故。不迁身。离死此生彼故。不坏身。法界性无坏故。一相身。三世语言道断故。无相身。善能观察法相故。菩萨成就如是十种身。为一切众生舍。长养一切善根故。为一切众生救。令其得大安隐故。为一切众生归。与其作大依处故。为一切众生导。令得无上出离故。为一切众生师。令入真实法中故。为一切众生灯。令其明见业报故。为一切众生光。令照甚深妙法故。为一切三世炬。令其晓悟实法故。为一切世间照。令入光明地中故。为一切诸趣明。示现如来自在故。佛子。是名菩萨摩诃萨。第九善法行。菩萨安住此行。为一切众生。作清凉法池。能尽一切佛法源故

佛子。何等为菩萨摩诃萨。真实行。此菩萨。成就第一诚谛之语。如说能行。如行能说。此菩萨。学三世诸佛真实语。入三世诸佛种性。与三世诸佛善根同等。得三世诸佛无二语。随如来学。智慧成就。此菩萨。成就知众生。是处非处智。去来现在业报智。诸根利钝智。种种界智。种种解智。一切至处道智。诸禅解脱。三昧垢净。起时非时智。一切世界。宿住随念智。天眼智。漏尽智。而不舍一切菩萨行。何以故。欲教化一切众生悉令清净故。此菩萨。复生如是增上心。若我不令一切众生。住无上解脱道。而我先成阿耨多罗三藐三菩提者。则违我本愿。是所不应。是故要当。先令一切众生。得无上菩提。无余涅槃。然后成佛。何以故。非众生请我发心。我自为众生。作不请之友。欲先令一切众生。满足善根。成一切智。是故我为最胜。不着一切世间故。我为最上。住无上调御地故。我为离翳。解众生无际故。我为已办。本愿成就故。我为善变化。菩萨功德庄严故。我为善依怙。三世诸佛摄受故。此菩萨摩诃萨。不舍本愿故。得入无上智慧庄严。利益众生。悉令满足。随本誓愿。皆得究竟。于一切法中。智慧自在。令一切众生。普得清净。念念遍游十方世界。念念普诣不可说不可说。诸佛国土。念念悉见不可说不可说诸佛。及佛庄严。清净国土。示现如来。自在神力。普遍法界。虚空界。此菩萨。现无量身。普入世间。而无所依。于其身中。现一切刹。一切众生。一切诸法。一切诸佛。此菩萨。知众生种种想。种种欲。种种解。种种业报。种种善根。随其所应。为现其身。而调伏之。观诸菩萨如幻。一切法如化。佛出世如影。一切世间如梦。得义身文身无尽藏。正念自在。决定了知一切诸法。智慧最胜。入一切三昧。真实相。住一性无二地。菩萨摩诃萨。以诸众生。皆着于二。安住大悲。修行如是寂灭之法。得佛十力。入因陀罗网法界。成就如来。无碍解脱。人中雄猛。大师子吼。得无所畏。能转无碍清净法轮。得智慧解脱。了知一切世间境界。绝生死回流。入智慧大海。为一切众生。护持三世诸佛正法。到一切佛法海。实相源底。菩萨。住此真实行已。一切世间。天人魔梵。沙门婆罗门。乾闼婆阿修罗等。有亲近者。皆令开悟。欢喜清净。是名菩萨摩诃萨。第十真实行

尔时。佛神力故。十方各有佛刹。微尘数世界。六种震动。所谓。动。遍动。等遍动。起。遍起。等遍起。涌。遍涌。等遍涌。震。遍震。等遍震。吼。遍吼。等遍吼。击。遍击。等遍击。雨天妙华。天香天末香。天鬘天衣。天宝天庄严具。奏天乐音。放天光明演畅诸天微妙音声。如此世界。夜摩天宫。说十行法。所现神变。十方世界。悉亦如是。复以佛神力故。十方各过十万佛刹。微尘数世界外。有十万佛刹。微尘数菩萨俱。来诣此土。充满十方。语功德林菩萨言。佛子。善哉善哉。善能演说诸菩萨行。我等一切同名功德林。所住世界。皆名功德幢。彼土如来。同名普功德。我等佛所。亦说此法。众会眷属。言辞义理。悉亦如是。无有增减。佛子。我等皆承佛神力。来入此会。为汝作证。十方世界。悉亦如是

尔时。功德林菩萨。承佛神力。普观十方。一切众会。暨于法界。欲令佛种性不断故。欲令菩萨种性。清净故。欲令愿种性。不退转故。欲令行种性。常相续故。欲令三世种性。悉平等故。欲摄三世一切。佛种性故。欲开演所种。诸善根故。欲观察一切诸根欲解烦恼习气。心行所作故。欲照了一切佛菩提故。而说颂曰

  一心敬礼十力尊　　离垢清净无碍见
  境界深远无伦匹　　住如虚空道中者
  过去人中诸最胜　　功德无量无所著
  勇猛第一无等伦　　彼离尘者行斯道
  现在十方诸国土　　善能开演第一义
  离诸过恶最清净　　彼无依者行斯道
  未来所有人师子　　周遍游行于法界
  已发诸佛大悲心　　彼饶益者行斯道
  三世所有无比尊　　自然除灭愚痴暗
  于一切法皆平等　　彼大力人行此道
  普见无量无边界　　一切诸有及诸趣
  见已其心不分别　　彼无动者行斯道
  法界所有皆明了　　于第一义最清净
  永破嗔慢及愚痴　　彼功德者行斯道
  于诸众生善分别　　悉入法界真实性
  自然觉悟不由他　　彼等空者行斯道
  尽空所有诸国土　　悉往说法广开谕
  所说清净无能坏　　彼胜牟尼行此道
  具足坚固不退转　　成就尊重最胜法
  愿力无尽到彼岸　　彼善修者所行道
  无量无边一切地　　广大甚深妙境界
  悉能知见靡有遗　　彼论师子所行道
  一切句义皆明了　　所有异论悉摧伏
  于法决定无所疑　　彼大牟尼行此道
  远离世间诸过患　　普与众生安隐乐
  能为无等大导师　　彼胜德者行斯道
  恒以无异施众生　　普令一切皆欣庆
  其心清净离染浊　　彼无等者行斯道
  意业清净极调善　　离诸戏论无口过
  威光圆满众所钦　　彼最胜者行斯道
  入真实义到彼岸　　住功德处心永寂
  诸佛护念恒不忘　　彼灭有者行斯道
  远离于我无恼害　　恒以大音宣正法
  十方国土靡不周　　彼绝譬者行斯道
  檀波罗蜜已成满　　百福相好所庄严
  众生见者皆欣悦　　彼最胜慧行斯道
  智地甚深难可入　　能以妙慧善安住
  其心究竟不动摇　　彼坚固行行斯道
  法界所有悉能入　　随所入处咸究竟
  神通自在靡不该　　彼法光明行此道
  诸无等等大牟尼　　勤修三昧无二相
  心常在定乐寂静　　彼普见者行斯道
  微细广大诸国土　　更相涉入各差别
  如其境界悉了知　　彼智山王行此道
  意常明洁离诸垢　　于三界中无所著
  护持众戒到彼岸　　此净心者行斯道
  智慧无边不可说　　普遍法界虚空界
  善能修学住其中　　彼金刚慧行斯道
  三世一切佛境界　　智慧善入悉周遍
  未尝暂起疲厌心　　彼最胜者行斯道
  善能分别十力法　　了知一切至处道
  身业无碍得自在　　彼功德身行此道
  十方无量无边界　　所有一切诸众生
  我皆救护而不舍　　彼无畏者行斯道
  于诸佛法勤修习　　心常精进不懈倦
  净治一切诸世间　　彼大龙王行此道
  了知众生根不同　　欲解无量各差别
  种种诸界皆明达　　此普入者行斯道
  十方世界无量刹　　悉往受生无有数
  未曾一念生疲厌　　彼欢喜者行斯道
  普放无量光明网　　照耀一切诸世间
  其光所照入法性　　此善慧者行斯道
  震动十方诸国土　　无量亿数那由他
  不令众生有惊怖　　此利世者所行道
  善解一切语言法　　问难酬对悉究竟
  聪哲辩慧靡不知　　此无畏者所行道
  善解覆仰诸国土　　分别思惟得究竟
  悉使住于无尽地　　此胜慧者所行道
  功德无量那由他　　为求佛道皆修习
  于其一切到彼岸　　此无尽行所行道
  超出世间大论师　　辩才第一师子吼
  普使群生到彼岸　　此净心者所行道
  诸佛灌顶第一法　　已得此法灌其顶
  心恒安住正法门　　彼广大心行此道
  一切众生无量别　　了达其心悉周遍
  决定护持佛法藏　　彼如须弥行此道
  能于一一语言中　　普为示现无量音
  令彼众生随类解　　此无碍见行斯道
  一切文字语言法　　智皆善入不分别
  住于真实境界中　　此见性者所行道
  安住甚深大法海　　善能印定一切法
  了法无相真实门　　此见实者所行道
  一一佛土皆往诣　　尽于无量无边劫
  观察思惟靡暂停　　此匪懈者所行道
  无量无数诸如来　　种种名号各不同
  于一毛端悉明见　　此净福者所行道
  一毛端处见诸佛　　其数无量不可说
  一切法界悉亦然　　彼诸佛子行斯道
  无量无边无数劫　　于一念中悉明见
  知其修促无定相　　此解脱行所行道
  能令见者无空过　　皆于佛法种因缘
  而于所作心无著　　彼诸最胜所行道
  那由他劫常遇佛　　终不一念生疲厌
  其心欢喜转更增　　此不空见所行道
  尽于无量无边劫　　观察一切众生界
  未曾见有一众生　　此坚固士所行道
  修习无边福智藏　　普作清凉功德池
  利益一切诸群生　　彼第一人行此道
  法界所有诸品类　　普遍虚空无数量
  了彼皆依言说住　　此师子吼所行道
  能于一一三昧中　　普入无数诸三昧
  悉至法门幽奥处　　此论月者行斯道
  忍力勤修到彼岸　　能忍最胜寂灭法
  其心平等不动摇　　此无边智所行道
  于一世界一坐处　　其身不动恒寂然
  而于一切普现身　　彼无边身行此道
  无量无边诸国土　　悉令共入一尘中
  普得包容无障碍　　彼无边思行此道
  了达是处及非处　　于诸力处普能入
  成就如来最上力　　彼第一力所行道
  过去未来现在世　　无量无边诸业报
  恒以智慧悉了知　　此达解者所行道
  了达世间时非时　　如应调伏诸众生
  悉顺其宜而不失　　此善了者所行道
  善守身语及意业　　恒令依法而修行
  离诸取着降众魔　　此智心者所行道
  于诸法中得善巧　　能入真如平等处
  辩才宣说无有穷　　此佛行者所行道
  陀罗尼门已圆满　　善能安住无碍藏
  于诸法界悉通达　　此深入者所行道
  三世所有一切佛　　悉与等心同智慧
  一性一相无有殊　　此无碍种所行道
  已决一切愚痴膜　　深入广大智慧海
  普施众生清净眼　　此有目者所行道
  已具一切诸导师　　平等神通无二行
  获于如来自在力　　此善修者所行道
  遍游一切诸世间　　普雨无边妙法雨
  悉令于义得决了　　此法云者所行道
  能于佛智及解脱　　深生净信永不退
  以信而生智慧根　　此善学者所行道
  能于一念悉了知　　一切众生无有余
  了彼众生心自性　　达无性者所行道
  法界一切诸国土　　悉能化往无有数
  其身最妙绝等伦　　此无比行所行道
  佛刹无边无有数　　无量诸佛在其中
  菩萨于彼悉现前　　亲近供养生尊重
  菩萨能以独一身　　入于三昧而寂定
  令见其身无有数　　一一皆从三昧起
  菩萨所住最深妙　　所行所作超戏论
  其心清净常悦乐　　能令众生悉欢喜
  诸根方便各差别　　能以智慧悉明见
  而了诸根无所依　　调难调者所行道
  能以方便巧分别　　于一切法得自在
  十方世界各不同　　悉在其中作佛事
  诸根微妙行亦然　　能为众生广说法
  谁其闻者不欣庆　　此等虚空所行道
  智眼清净无与等　　于一切法悉明见
  如是智慧巧分别　　此无等者所行道
  所有无尽广大福　　一切修行使究竟
  令诸众生悉清净　　此无比者所行道
  普劝修成助道法　　悉令得住方便地
  度脱众生无有数　　未曾暂起众生想
  一切机缘悉观察　　先护彼意令无诤
  普示众生安隐处　　此方便者所行道
  成就最上第一智　　具足无量无边智
  于诸四众无所畏　　此方便智所行道
  一切世界及诸法　　悉能遍入得自在
  亦入一切众会中　　度脱群生无有数
  十方一切国土中　　击大法鼓悟群生
  为法施主最无上　　此不灭者所行道
  一身结跏而正坐　　充满十方无量刹
  而令其身不迫隘　　此法身者所行道
  能于一义一文中　　演说无量无边法
  而其边际不可得　　此无边智所行道
  于佛解脱善修学　　得佛智慧无障碍
  成就无畏为世雄　　此方便者所行道
  了知十方世界海　　亦知一切佛刹海
  智海法海悉了知　　众生见者咸欣庆
  或现入胎及初生　　或现道场成正觉
  如是皆令世间见　　此无边者所行道
  无量亿数国土中　　示现其身入涅槃
  实不舍愿归寂灭　　此雄论者所行道
  坚固微密一妙身　　与佛平等无差别
  随诸众生各异见　　一实身者所行道
  法界平等无差别　　具足无量无边义
  乐观一相心不移　　三世智者所行道
  于诸众生及佛法　　建立加持悉究竟
  所有持力同于佛　　最上持者行斯道
  神足无碍犹如佛　　天眼无碍最清净
  耳根无碍善听闻　　此无碍意所行道
  所有神通皆具足　　随其智慧悉成就
  善知一切靡所俦　　此贤智者所行道
  其心正定不摇动　　其智广大无边际
  所有境界皆明达　　一切见者所行道
  已到一切功德岸　　能随次第度众生
  其心毕竟无厌足　　此常勤者所行道
  三世所有诸佛法　　于此一切咸知见
  从于如来种性生　　彼诸佛子行斯道
  随顺言辞已成就　　乖违谈论善摧伏
  常能趣向佛菩提　　无边慧者所行道
  一光照触无涯限　　十方国土悉充遍
  普使世间得大明　　此破闇者所行道
  随其应见应供养　　为现如来清净身
  教化众生百千亿　　庄严佛刹亦如是
  为令众生出世间　　一切妙行皆修习
  此行广大无边际　　云何而有能知者
  假使分身不可说　　而与法界虚空等
  悉共称扬彼功德　　百千万劫无能尽
  菩萨功德无有边　　一切修行皆具足
  假使无量无边佛　　于无量劫说不尽
  何况世间天及人　　一切声闻及缘觉
  能于无量无边劫　　赞叹称扬得究竟

大方广佛华严经卷第二十大方广佛华严经卷第二十一

        于阗国三藏实叉难陀奉　制译

    十无尽藏品第二十二

尔时功德林菩萨。复告诸菩萨言。佛子。菩萨摩诃萨。有十种藏。过去未来现在诸佛。已说当说今说。何等为十。所谓。信藏。戒藏。惭藏。愧藏。闻藏。施藏。慧藏。念藏。持藏。辩藏。是为十。佛子。何等为菩萨摩诃萨信藏。此菩萨。信一切法空。信一切法无相。信一切法无愿。信一切法无作。信一切法无分别。信一切法无所依。信一切法不可量。信一切法无有上。信一切法难超越。信一切法无生。若菩萨能如是。随顺一切法。生净信已。闻诸佛法。不可思议。心不怯弱。闻一切佛。不可思议。心不怯弱。闻众生界。不可思议。心不怯弱。闻法界不可思议。心不怯弱。闻虚空界。不可思议。心不怯弱。闻涅槃界。不可思议。心不怯弱。闻过去世。不可思议。心不怯弱。闻未来世。不可思议。心不怯弱。闻现在世。不可思议。心不怯弱。闻入一切劫。不可思议。心不怯弱。何以故。此菩萨。于诸佛所。一向坚信。知佛智慧。无边无尽。十方无量。诸世界中。一一各有无量诸佛。于阿耨多罗三藐三菩提。已得今得当得。已出世。今出世。当出世。已入涅槃。今入涅槃。当入涅槃。彼诸佛智慧。不增不减。不生不灭。不进不退。不近不远。无知无舍。此菩萨。入佛智慧。成就无边无尽信。得此信已。心不退转。心不杂乱。不可破坏。无所染着。常有根本。随顺圣人。住如来家。护持一切诸佛种性。增长一切菩萨信解。随顺一切如来善根。出生一切诸佛方便。是名菩萨摩诃萨信藏。菩萨住此信藏。则能闻持一切佛法。为众生说。皆令开悟

佛子。何等为菩萨摩诃萨戒藏。此菩萨。成就普饶益戒。不受戒。不住戒。无悔恨戒。无违诤戒。不损恼戒。无杂秽戒。无贪求戒。无过失戒。无毁犯戒。云何为普饶益戒。此菩萨。受持净戒。本为利益一切众生。云何为不受戒。此菩萨。不受行外道。诸所有戒。但性自精进。奉持三世。诸佛如来。平等净戒。云何为不住戒。此菩萨。受持戒时。心不住欲界。不住色界。不住无色界。何以故。不求生彼。而持戒故。云何为无悔恨戒。此菩萨。恒得安住。无悔恨心。何以故。不作重罪。不行谄诈。不破净戒故。云何为无违诤戒。此菩萨。不非先制。不更造立。心常随顺。向涅槃戒。具足受持。无所毁犯。不以持戒。恼他众生。令其生苦。但愿一切心常欢喜。而持于戒。云何为不恼害戒。此菩萨。不因于戒。学诸咒术。造作方药。恼害众生。但为救护一切众生。而持于戒。云何为不杂戒。此菩萨不着边见。不持杂戒。但观缘起。持出离戒。云何为无贪求戒。此菩萨不现异相。彰己有德。但为满足出离法故。而持于戒。云何为无过失戒。此菩萨。不自贡高。言我持戒。见破戒人。亦不轻毁。令他愧耻。但一其心。而持于戒。云何为无毁犯戒。此菩萨。永断杀盗。邪淫妄语。两舌恶口。及无义语。贪嗔邪见。具足受持十种善业。菩萨持此无犯戒时。作是念言。一切众生。毁犯净戒。皆由颠倒。唯佛世尊。能知众生。以何因缘。而生颠倒。毁犯净戒。我当成就无上菩提。广为众生。说真实法。令离颠倒。是名菩萨摩诃萨第二戒藏

佛子。何等为菩萨摩诃萨惭藏。此菩萨。忆念过去。所作诸恶。而生于惭。谓彼菩萨。心自念言。我无始世来。与诸众生。皆悉互作父母兄弟。姊妹男女。具贪嗔痴。憍慢谄诳。及余一切诸烦恼故。更相恼害。递相陵夺。奸淫伤杀。无恶不造。一切众生。悉亦如是。以诸烦恼。备造众恶。是故各各不相恭敬。不相尊重。不相承顺。不相谦下。不相启导。不相护惜。更相杀害。互为怨仇。自惟我身。及诸众生。去来现在。行无惭法。三世诸佛。无不知见。今若不断此无惭行。三世诸佛。亦当见我。我当云何犹行不止。甚为不可。是故我应专心断除。证阿耨多罗三藐三菩提。广为众生。说真实法。是名菩萨摩诃萨第三惭藏

佛子。何等为菩萨摩诃萨愧藏。此菩萨。自愧昔来。于五欲中。种种贪求。无有厌足。因此增长贪恚痴等。一切烦恼。我今不应复行是事。又作是念。众生无智。起诸烦恼。具行恶法。不相恭敬。不相尊重。乃至展转。互为怨仇。如是等恶。无不备造。造已欢喜。追求称叹。盲无慧眼。无所知见。于母人腹中。入胎受生。成垢秽身。毕竟至于发白面皱。有智慧者。观此但是从淫欲生不净之法。三世诸佛。皆悉知见。若我于今。犹行是事。则为欺诳三世诸佛。是故我当修行于愧。速成阿耨多罗三藐三菩提。广为众生。说真实法。是名菩萨摩诃萨第四愧藏

佛子。何等为菩萨摩诃萨闻藏。此菩萨。知是事有故。是事有。是事无故。是事无。是事起故。是事起。是事灭故。是事灭。是世间法。是出世间法。是有为法。是无为法。是有记法。是无记法。何等为是事有故。是事有。谓无明有故。行有。何等为是事无故。是事无。谓识无故。名色无。何等为是事起故。是事起。谓爱起故。苦起。何等为是事灭故。是事灭。谓有灭故。生灭。何等为世间法。所谓。色受想行识。何等为出世间法。所谓。戒定慧。解脱。解脱知见。何等为有为法。所谓。欲界色界。无色界众生界。何等为无为法。所谓。虚空涅槃。数缘灭非数缘灭。缘起法性住。何等为有记法。谓四圣谛四沙门果。四辩四无所畏。四念处。四正勤。四神足。五根五力。七觉分八圣道分。何等为无记法。谓世间有边。世间无边。世间亦有边亦无边。世间非有边非无边。世间有常。世间无常。世间亦有常亦无常。世间非有常非无常。如来灭后有。如来灭后无。如来灭后。亦有亦无。如来灭后。非有非无。我及众生有。我及众生无。我及众生。亦有亦无。我及众生。非有非无。过去。有几如来般涅槃。几声闻辟支佛般涅槃。未来。有几如来。几声闻辟支佛。几众生。现在。有几佛住。几声闻辟支佛住。几众生住。何等如来。最先出。何等声闻辟支佛。最先出。何等众生。最先出。何等如来。最后出。何等声闻辟支佛。最后出。何等众生。最后出。何法最在初。何法最在后。世间从何处来。去至何所。有几世界成。有几世界坏。世界从何处来。去至何所。何者为生死最初际。何者为生死最后际。是名无记法。菩萨摩诃萨。作如是念。一切众生于生死中。无有多闻。不能了知此一切法。我当发意。持多闻藏。证阿耨多罗三藐三菩提。为诸众生。说真实法。是名菩萨摩诃萨第五多闻藏

佛子。何等为菩萨摩诃萨施藏。此菩萨。行十种施。所谓。分减施。竭尽施。内施外施。内外施。一切施。过去施。未来施。现在施。究竟施。佛子。云何为菩萨分减施。此菩萨。禀性仁慈。好行惠施。若得美味。不专自受。要与众生。然后方食。凡所受物。悉亦如是。若自食时。作是念言。我身中有八万户虫。依于我住。我身充乐。彼亦充乐。我身饥苦。彼亦饥苦。我今受此。所有饮食。愿令众生。普得充饱。为施彼故。而自食之。不贪其味。复作是念。我于长夜。爱着其身。欲令充饱。而受饮食。今以此食。惠施众生。愿我于身。永断贪着。是名分减施。云何为菩萨竭尽施。佛子。此菩萨。得种种上味饮食。香华衣服。资生之具。若自以受用。则安乐延年。若辍己施人。则穷苦夭命。时或有人。来作是言。汝今所有。悉当与我。菩萨自念。我无始已来。以饥饿故。丧身无数。未曾得有如毫末许。饶益众生。而获善利。今我亦当同于往昔。而舍其命。是故应为饶益众生。随其所有。一切皆舍。乃至尽命。亦无所吝。是名竭尽施。云何为菩萨内施。佛子。此菩萨。年方少盛。端正美好。香华衣服。以严其身。始受灌顶。转轮王位。七宝具足。王四天下。时或有人。来白王言。大王当知。我今衰老。身婴重疾。茕独羸顿。死将不久。若得王身。手足血肉。头目骨髓。我之身命。必冀存活。唯愿大王。莫更筹量。有所顾惜。但见慈念。以施于我。尔时菩萨。作是念言。今我此身。后必当死。无一利益。宜时疾舍。以济众生。念已施之。心无所悔。是名内施。云何为菩萨外施。佛子。此菩萨。年盛色美。众相具足。名华上服。而以严身。始受灌顶。转轮王位。七宝具足。王四天下。时或有人。来白王言。我今贫窭。众苦逼迫唯愿仁慈。特垂矜念。舍此王位。以赡于我。我当统领。受王福乐。尔时菩萨。作是念言。一切荣盛。必当衰歇。于衰歇时。不能复更饶益众生。我今宜应随彼所求。充满其意。作是念已。即便施之。而无所悔。是名外施。云何为菩萨内外施。佛子。此菩萨。如上所说。处轮王位。七宝具足。王四天下。时或有人。而来白言。此转轮位。王处已久。我未曾得。唯愿大王。舍之与我。并及王身。为我臣仆。尔时菩萨。作是念言。我身财宝。及以王位。悉是无常。败坏之法。我今盛壮。富有天下。乞者现前。当以不坚。而求坚法。作是念已。即便施之。乃至以身。恭勤作役。心无所悔。是名内外施。云何为菩萨一切施。佛子。此菩萨。亦如上说。处轮王位。七宝具足。王四天下。时有无量。贫穷之人。来诣其前。而作是言。大王名称。周闻十方。我等钦风。故来至此。吾曹今者。各有所求。愿普垂慈。令得满足。时诸贫人。从彼大王。或乞国土。或乞妻子。或乞手足。血肉心肺。头目髓脑。菩萨是时。心作是念。一切恩爱。会当别离。而于众生。无所饶益。我今为欲永舍贪爱。以此一切必离散物。满众生愿。作是念已。悉皆施与。心无悔恨。亦不于众生。而生厌贱。是名一切施。云何为菩萨过去施。此菩萨。闻过去诸佛菩萨。所有功德。闻已不着。了达非有。不起分别。不贪不味。亦不求取。无所依倚。见法如梦。无有坚固。于诸善根。不起有想。亦无所倚。但为教化取着众生。成熟佛法。而为演说。又复观察过去诸法。十方推求。都不可得。作是念已。于过去法。毕竟皆舍。是名过去施。云何为菩萨未来施。此菩萨。闻未来诸佛之所修行。了达非有。不取于相。不别乐往生诸佛国土。不味不着。亦不生厌。不以善根。回向于彼。亦不于彼。而退善根。常勤修行。未曾废舍。但欲因彼境界。摄取众生。为说真实。令成熟佛法。然此法者。非有处所。非无处所。非内非外。非近非远。复作是念。若法非有。不可不舍。是名未来施。云何为菩萨现在施。此菩萨。闻四天王众天。三十三天夜摩天。兜率陀天。化乐天。他化自在天。梵天梵身天。梵辅天梵众天。大梵天。光天少光天。无量光天光音天。净天少净天。无量净天遍净天。广天少广天。无量广天广果天。无烦天无热天。善见天善现天。色究竟天。乃至闻声闻缘觉。具足功德。闻已其心。不迷不没。不聚不散。但观诸行。如梦不实。无有贪着。为令众生。舍离恶趣。心无分别。修菩萨道。成就佛法。而为开演。是名现在施。云何为菩萨究竟施。佛子。此菩萨。假使有无量众生。或有无眼。或有无耳。或无鼻舌。及以手足。来至其所。告菩萨言。我身薄祜。诸根残缺。唯愿仁慈。以善方便。舍己所有。令我具足。菩萨闻之。即便施与。假使由此。经阿僧祇劫。诸根不具。亦不心生一念悔惜。但自观身。从初入胎。不净微形。胞段诸根。生老病死。又观此身。无有真实。无有惭愧。非贤圣物。臭秽不洁。骨节相持。血肉所涂。九孔常流。人所恶贱。作是观已。不生一念爱着之心。复作是念。此身危脆。无有坚固。我今云何。而生恋着。应以施彼。充满其愿。如我所作。以此开导一切众生。令于身心。不生贪爱。悉得成就清净智身。是名究竟施。是为菩萨摩诃萨第六施藏

佛子。何等为菩萨摩诃萨慧藏。此菩萨。于色如实知。色集如实知。色灭如实知。色灭道如实知。于受想行识如实知。受想行识集如实知。受想行识灭如实知。受想行识灭道如实知。于无明如实知。无明集如实知。无明灭如实知。无明灭道如实知。于爱如实知。爱集如实知。爱灭如实知。爱灭道如实知。于声闻如实知。声闻法如实知。声闻集如实知。声闻涅槃如实知。于独觉如实知。独觉法如实知。独觉集如实知。独觉涅槃如实知。于菩萨如实知。菩萨法如实知。菩萨集如实知。菩萨涅槃如实知。云何知知从业报。诸行因缘之所造作。一切虚假。空无有实。非我非坚固。无有少法。可得成立。欲令众生。知其实性。广为宣说。为说何等。说诸法不可坏。何等法不可坏。色不可坏。受想行识不可坏。无明不可坏。声闻法独觉法。菩萨法不可坏。何以故。一切法。无作无作者。无言说无处所。不生不起。不与不取。无动转无作用。菩萨成就如是等无量慧藏。以少方便。了一切法。自然明达。不由他悟。此慧无尽藏。有十种不可尽故。说为无尽。何等为十。所谓。多闻善巧不可尽故。亲近善知识不可尽故。善分别句义不可尽故。入深法界不可尽故。以一味智庄严不可尽故。集一切福德心无疲倦不可尽故。入一切陀罗尼门不可尽故。能分别一切众生语言音声不可尽故。能断一切众生疑惑不可尽故。为一切众生现一切佛神力教化调伏令修行不断不可尽故。是为十。是为菩萨摩诃萨第七慧藏。住此藏者。得无尽智慧。普能开悟一切众生

佛子。何等为菩萨摩诃萨念藏。此菩萨。舍离痴惑。得具足念。忆念过去。一生二生。乃至十生。百生千生。百千生无量百千生。成劫坏劫成坏劫。非一成劫。非一坏劫。非一成坏劫。百劫千劫。百千亿那由他。乃至无数无量无边无等。不可数不可称。不可思不可量。不可说。不可说不可说劫。念一佛名号。乃至不可说不可说佛名号。念一佛出世说授记。乃至不可说不可说。佛出世说授记。念一佛出世。说修多罗。乃至不可说不可说。佛出世说修多罗。如修多罗。祇夜。授记。伽他。尼陀那。优陀那。本事。本生。方广。未曾有。譬谕论议。亦如是。念一众会。乃至不可说不可说众会。念演一法。乃至演不可说不可说法。念一根种种性。乃至不可说不可说根种种性。念一根无量种种性。乃至不可说不可说根无量种种性。念一烦恼种种性。乃至不可说不可说烦恼种种性。念一三昧种种性。乃至不可说不可说三昧种种性。此念有十种。所谓。寂静念。清净念。不浊念。明彻念。离尘念。离种种尘念。离垢念。光耀念。可爱乐念。无障碍念。菩萨住是念时。一切世间。无能娆乱。一切异论。无能变动。往世善根。悉得清净。于诸世法。无所染着。众魔外道。所不能坏。转身受生。无所忘失。过现未来。说法无尽。于一切世界中。与众生同住。曾无过咎。入一切诸佛。众会道场。无所障碍。一切佛所。悉得亲近。是名菩萨摩诃萨第八念藏

佛子。何等为菩萨摩诃萨持藏。此菩萨。持诸佛所说。修多罗。文句义理。无有忘失。一生持。乃至不可说不可说生持。持一佛名号。乃至不可说不可说佛名号。持一劫数。乃至不可说不可说劫数。持一佛授记。乃至不可说不可说佛授记。持一修多罗。乃至不可说不可说修多罗。持一众会。乃至不可说不可说众会。持演一法。乃至演不可说不可说法。持一根无量种种性。乃至不可说不可说根。无量种种性。持一烦恼种种性。乃至不可说不可说烦恼种种性。持一三昧种种性。乃至不可说不可说三昧种种性。佛子。此持藏。无边难满。难至其底。难得亲近。无能制伏。无量无尽。具大威力。是佛境界。唯佛能了。是名菩萨摩诃萨第九持藏

佛子。何等为菩萨摩诃萨辩藏。此菩萨。有深智慧。了知实相。广为众生。演说诸法。不违一切诸佛经典。说一品法。乃至不可说不可说品法。说一佛名号。乃至不可说不可说佛名号。如是。说一世界。说一佛授记。说一修多罗。说一众会。说演一法。说一根无量种种性。说一烦恼无量种种性。说一三昧无量种种性。乃至说不可说不可说。三昧无量种种性。或一日说。或半月一月说。或百年千年。百千年说。或一劫。百劫千劫。百千劫说。或百千亿那由他劫说。或无数无量。乃至不可说不可说劫说。劫数可尽。一文一句。义理难尽。何以故。此菩萨。成就十种无尽藏故。成就此藏。得摄一切法。陀罗尼门现在前。百万阿僧祇陀罗尼以为眷属。得此陀罗尼已。以法光明。广为众生。演说于法。其说法时。以广长舌出妙音声。充满十方一切世界。随其根性。悉令满足。心得欢喜。灭除一切烦恼缠垢。善入一切音声言语。文字辩才。令一切众生。佛种不断。净心相续。亦以法光明。而演说法。无有穷尽。不生疲倦。何以故。此菩萨。成就尽虚空遍法界无边身故。是为菩萨摩诃萨第十辩藏。此藏无穷尽。无分段。无间无断。无变异。无隔碍。无退转。甚深无底。难可得入。普入一切佛法之门

佛子。此十种无尽藏。有十种无尽。令诸菩萨。究竟成就无上菩提。何等为十。饶益一切众生故。以本愿善回向故。一切劫无断绝故。尽虚空界悉开悟心无限故。回向有为而不着故。一念境界一切法无尽故。大愿心无变异故。善摄取诸陀罗尼故。一切诸佛所护念故。了一切法皆如幻故。是为十种无尽法。能令一切世间所作。悉得究竟无尽大藏

大方广佛华严经卷第二十一大方广佛华严经卷第二十二

        于阗国三藏实叉难陀奉　制译

    升兜率天宫品第二十三

尔时佛神力故。十方一切世界。一一四天下。阎浮提中。皆见如来。坐于树下。各有菩萨。承佛神力。而演说法。靡不自谓恒对于佛

尔时世尊。复以神力。不离于此菩提树下。及须弥顶。夜摩天宫。而往诣于兜率陀天。一切妙宝所庄严殿。时兜率天王。遥见佛来。即于殿上。敷摩尼藏师子之座。其师子座。天诸妙宝之所集成。过去修行。善根所得。一切如来。神力所现。无量百千亿。那由他阿僧祇。善根所生。一切如来。净法所起。无边福力之所严莹。清净业报。不可沮坏。观者欣乐。无所厌足。是出世法。非世所染。一切众生。咸来观察。无有能得究其妙好。有百万亿层级。周匝围绕。百万亿金网。百万亿华帐。百万亿宝帐。百万亿鬘帐。百万亿香帐。张施其上。华鬘垂下。香气普熏。百万亿华盖。百万亿鬘盖。百万亿宝盖。诸天执持。四面行列。百万亿宝衣。以敷其上。百万亿楼阁。绮焕庄严。百万亿摩尼网。百万亿宝网。弥覆其上。百万亿宝璎珞网。四面垂下。百万亿庄严具网。百万亿盖网。百万亿衣网。百万亿宝帐网。以张其上。百万亿宝莲华网。开敷光荣。百万亿宝香网。其香美妙。称悦众心。百万亿宝铃帐。其铃微动。出和雅音。百万亿栴檀宝帐。香气普熏。百万亿宝华帐。其华敷荣。百万亿众妙色衣帐。世所希有。百万亿菩萨帐。百万亿杂色帐。百万亿真金帐。百万亿琉璃帐。百万亿种种宝帐。悉张其上。百万亿一切宝帐。大摩尼宝。以为庄严。百万亿妙宝华。周匝莹饰。百万亿频婆帐。殊妙间错。百万亿宝鬘。百万亿香鬘。四面垂下。百万亿天坚固香。其香普熏。百万亿天庄严具璎珞。百万亿宝华璎珞。百万亿胜藏宝璎珞。百万亿摩尼宝璎珞。百万亿海摩尼宝璎珞。庄严座身。百万亿妙宝缯彩。以为垂带。百万亿因陀罗金刚宝。百万亿自在摩尼宝。百万亿妙色真金藏。以为间饰。百万亿毗卢遮那摩尼宝。百万亿因陀罗摩尼宝。光明照耀。百万亿天坚固摩尼宝。以为窗牖。百万亿清净功德摩尼宝。彰施妙色。百万亿清净妙藏宝。以为门闼。百万亿世中最胜半月宝。百万亿离垢藏摩尼宝。百万亿师子面摩尼宝。间错庄严。百万亿心王摩尼宝。所求如意。百万亿阎浮檀摩尼宝。百万亿清净藏摩尼宝。百万亿帝幢摩尼宝。咸放光明。弥覆其上。百万亿白银藏摩尼宝。百万亿须弥幢摩尼宝。庄严其藏。百万亿真珠璎珞。百万亿琉璃璎珞。百万亿赤色宝璎珞。百万亿摩尼璎珞。百万亿宝光明璎珞。百万亿种种藏。摩尼璎珞。百万亿甚可乐见。赤真珠璎珞。百万亿无边色相藏。摩尼宝璎珞。百万亿极清净。无比宝璎珞。百万亿胜光明。摩尼宝璎珞。周匝垂布。以为庄严。百万亿摩尼身。殊妙严饰。百万亿因陀罗妙色宝。百万亿黑栴檀香。百万亿不思议境界香。百万亿十方妙香。百万亿最胜香。百万亿甚可爱乐香。咸发香气。普熏十方。百万亿频娑罗香。普散十方。百万亿净光香。普熏众生。百万亿无边际。种种色香。普熏一切。诸佛国土。永不歇灭。百万亿涂香。百万亿熏香。百万亿烧香。香气发越。普熏一切。百万亿莲华藏沉水香。出大音声。百万亿游戏香。能转众心。百万亿阿楼那香。香气普熏。其味甘美。百万亿能开悟香。普遍一切。令其闻者。诸根寂静

复有百万亿无比香王香。种种庄严。雨百万亿天华云。雨百万亿天香云。雨百万亿天末香云。雨百万亿天拘苏摩华云。雨百万亿天波头摩华云。雨百万亿天优钵罗华云。雨百万亿天拘物头华云。雨百万亿天芬陀利华云。雨百万亿天曼陀罗华云。雨百万亿一切天华云。雨百万亿天衣云。雨百万亿摩尼宝云。雨百万亿天盖云。雨百万亿天幡云雨百万亿天冠云。雨百万亿天庄严具云。雨百万亿天宝鬘云。雨百万亿天宝璎珞云。雨百万亿天栴檀香云。雨百万亿天沉水香云。建百万亿宝幢。悬百万亿宝幡。垂百万亿宝缯带。然百万亿香炉。布百万亿宝鬘。持百万亿宝扇。执百万亿宝拂。悬百万亿宝铃网。微风吹动。出妙音声。百万亿宝栏楯。周匝围绕。百万亿宝多罗树。次第行列。百万亿妙宝窗牖。绮丽庄严。百万亿宝树。周匝垂阴。百万亿宝楼阁。延袤绮饰。百万亿宝门。垂布璎珞。百万亿金铃。出妙音声。百万亿吉祥相璎珞。严净垂下。百万亿宝悉底迦。能除众恶。百万亿金藏。金缕织成。百万亿宝盖。众宝为竿。执持行列。百万亿一切宝庄严具网。间错庄严。百万亿光明宝。放种种光。百万亿光明。周遍照耀。百万亿日藏轮。百万亿月藏轮。并无量色宝之所集成。百万亿香焰。光明映彻。百万亿莲华藏。开敷鲜荣。百万亿宝网。百万亿华网。百万亿香网。弥覆其上。百万亿天宝衣。百万亿天青色衣。百万亿天黄色衣。百万亿天赤色衣。百万亿天奇妙色衣。百万亿天种种宝奇妙衣。百万亿种种香熏衣。百万亿一切宝所成衣。百万亿鲜白衣。悉善敷布。见者欢喜。百万亿天铃幢。百万亿金网幢。出微妙音。百万亿天缯幢。众彩具足。百万亿香幢。垂布香网。百万亿华幢。雨一切华。百万亿天衣幢。悬布妙衣。百万亿天摩尼宝幢。众宝庄严。百万亿天庄严具幢。众具校饰。百万亿天鬘幢。种种华鬘。四面行布。百万亿天盖幢。宝铃和鸣。闻皆欢喜。百万亿天螺。出妙音声。百万亿天鼓。出大音声。百万亿天箜篌。出微妙音。百万亿天牟陀罗。出大妙音。百万亿天诸杂乐。同时俱奏。百万亿天自在乐。出妙音声。其声普遍一切佛刹。百万亿天变化乐。其声如响。普应一切。百万亿天鼓。因于抚击。而出妙音。百万亿天如意乐。自然出声。音节相和。百万亿天诸杂乐。出妙音声。灭诸烦恼。百万亿悦意音。赞叹供养。百万亿广大音。赞叹承事。百万亿甚深音。赞叹修行。百万亿众妙音。叹佛业果。百万亿微细音。叹如实理。百万亿无障碍真实音。叹佛本行。百万亿清净音。赞叹过去。供养诸佛。百万亿法门音。赞叹诸佛。最胜无畏。百万亿无量音。叹诸菩萨。功德无尽。百万亿菩萨地音。赞叹开示一切菩萨地相应行。百万亿无断绝音。叹佛功德。无有断绝。百万亿随顺音。赞叹称扬见佛之行。百万亿甚深法音。赞叹一切法。无碍智相应理。百万亿广大音。其音充满一切佛刹。百万亿无碍清净音。随其心乐。悉令欢喜。百万亿不住三界音。令其闻者。深入法性。百万亿欢喜音。令其闻者。心无障碍。深信恭敬。百万亿佛境界音。随所出声。悉能开示一切法义。百万亿陀罗尼音。善宣一切法句差别。决了如来。秘密之藏。百万亿一切法音。其音和畅。克谐众乐。有百万亿初发心菩萨。才见此座。倍更增长一切智心。百万亿治地菩萨。心净欢喜。百万亿修行菩萨。悟解清净。百万亿生贵菩萨。住胜志乐。百万亿方便具足菩萨。起大乘行。百万亿正心住菩萨。勤修一切菩萨道。百万亿不退菩萨。净修一切菩萨地。百万亿童真菩萨。得一切菩萨三昧光明。百万亿法王子菩萨。入不思议诸佛境界。百万亿灌顶菩萨。能现无量。如来十力。百万亿菩萨。得自在神通。百万亿菩萨。生清净解。百万亿菩萨。心生爱乐。百万亿菩萨。深信不坏。百万亿菩萨。势力广大。百万亿菩萨。名称增长。百万亿菩萨。演说法义。令智决定。百万亿菩萨。正念不乱。百万亿菩萨。生决定智。百万亿菩萨。得闻持力。持一切佛法。百万亿菩萨。出生无量。广大觉解。百万亿菩萨。安住信根。百万亿菩萨。得檀波罗蜜。能一切施。百万亿菩萨。得尸波罗蜜。具持众戒。百万亿菩萨。得忍波罗蜜。心不妄动。悉能忍受。一切佛法。百万亿菩萨。得精进波罗蜜。能行无量。出离精进。百万亿菩萨。得禅波罗蜜。具足无量禅定光明。百万亿菩萨。得般若波罗蜜。智慧光明。能普照耀。百万亿菩萨。成就大愿。悉皆清净。百万亿菩萨。得智慧灯。明照法门。百万亿菩萨。为十方诸佛。法光所照。百万亿菩萨。周遍十方。演离痴法。百万亿菩萨。普入一切诸佛刹土。百万亿菩萨。法身随到一切佛国。百万亿菩萨。得佛音声。能广开悟。百万亿菩萨。得出生一切智方便。百万亿菩萨。得成就一切法门。百万亿菩萨。成就法智。犹如宝幢。能普显示一切佛法。百万亿菩萨。能悉示现如来境界。百万亿诸天王。恭敬礼拜。百万亿龙王。谛观无厌。百万亿夜叉王。顶上合掌。百万亿乾闼婆王。起净信心。百万亿阿修罗王。断憍慢意。百万亿迦楼罗王。口衔缯带。百万亿紧那罗王。欢喜踊跃。百万亿摩睺罗伽王。欢喜瞻仰百万亿世主。稽首作礼。百万亿忉利天王。瞻仰不瞬。百万亿夜摩天王。欢喜赞叹。百万亿兜率天王。布身作礼。百万亿化乐天王。头顶礼敬。百万亿他化天王。恭敬合掌。百万亿梵天王。一心观察。百万亿摩醯首罗天王。恭敬供养。百万亿菩萨。发声赞叹。百万亿天女。专心供养。百万亿同愿天。踊跃欢喜。百万亿往昔同住天。妙声称赞。百万亿梵身天。布身敬礼。百万亿梵辅天。合掌于顶。百万亿梵众天。围绕侍卫。百万亿大梵天。赞叹称扬。无量功德。百万亿光天。五体投地。百万亿少光天。宣扬赞叹佛世难值。百万亿无量光天。遥向佛礼。百万亿光音天。赞叹如来。甚难得见。百万亿净天。与宫殿俱。而来诣此。百万亿少净天。以清净心。稽首作礼。百万亿无量净天。愿欲见佛。投身而下。百万亿遍净天。恭敬尊重。亲近供养。百万亿广天。念昔善根。百万亿少广天。于如来所。生希有想。百万亿无量广天。决定尊重。生诸善业。百万亿广果天。曲躬恭敬。百万亿无烦天。信根坚固。恭敬礼拜。百万亿无热天。合掌念佛。情无厌足。百万亿善见天。头面作礼。百万亿善现天。念供养佛。心无懈歇。百万亿阿迦尼吒天。恭敬顶礼。百万亿种种天。皆大欢喜。发声赞叹。百万亿诸天。各善思惟。而为庄严百万亿菩萨天。护持佛座。庄严不绝。百万亿华手菩萨。雨一切华。百万亿香手菩萨。雨一切香。百万亿鬘手菩萨。雨一切鬘。百万亿末香手菩萨。雨一切末香。百万亿涂香手菩萨。雨一切涂香。百万亿衣手菩萨。雨一切衣。百万亿盖手菩萨。雨一切盖。百万亿幢手菩萨。雨一切幢。百万亿幡手菩萨。雨一切幡。百万亿宝手菩萨。雨一切宝。百万亿庄严手菩萨。雨一切庄严具。百万亿诸天子。从天宫出。至于座所。百万亿诸天子。以净信心。并宫殿俱。百万亿生贵天子。以身持座。百万亿灌顶天子。举身持座。百万亿思惟菩萨。恭敬思惟。百万亿生贵菩萨。发清净心。百万亿菩萨。诸根悦乐。百万亿菩萨。深心清净。百万亿菩萨。信解清净。百万亿菩萨。诸业清净。百万亿菩萨。受生自在。百万亿菩萨。法光照耀。百万亿菩萨。成就于地。百万亿菩萨。善能教化一切众生。百万亿善根所生。百万亿诸佛护持。百万亿福德所圆满。百万亿殊胜心所清净。百万亿大愿所严洁。百万亿善行所生起。百万亿善法所坚固。百万亿神力所示现。百万亿功德所成就。百万亿赞叹法。而以赞叹。如此世界。兜率天王。奉为如来。敷置高座。一切世界。兜率天王。悉为于佛。如是敷座。如是庄严。如是仪则。如是信乐。如是心净。如是欣乐。如是喜悦。如是尊重。如是而生希有之想。如是踊跃。如是渴仰。悉皆同等

尔时兜率天王。为如来。敷置座已。心生尊重。与十万亿阿僧祇。兜率天子。奉迎如来。以清净心。雨阿僧祇色华云。雨不思议色香云。雨种种色鬘云。雨广大清净栴檀云。雨无量种种盖云。雨细妙天衣云。雨无边众妙宝云。雨天庄严具云。雨无量种种烧香云。雨一切栴檀沉水。坚固末香云。诸天子众。各从其身。出此诸云时。百千亿阿僧祇。兜率天子。及余在会。诸天子众。心大欢喜。恭敬顶礼。阿僧祇天女。踊跃欣慕。谛观如来。兜率宫中。不可说诸菩萨众。住虚空中。精勤一心。以出过诸天。诸供养具。供养于佛。恭敬作礼。阿僧祇音乐。一时同奏。尔时如来。威神力故。往昔善根之所流故。不可思议。自在力故。兜率宫中。一切诸天。及诸天女。皆遥见佛。如对目前。同兴念言。如来出世。难可值遇。我今得见具一切智于法无碍正等觉者。如是思惟。如是观察。与诸众会。悉共同时。奉迎如来。各以天衣。盛一切华。盛一切香。盛一切宝。盛一切庄严具。盛一切天栴檀末香。盛一切天沉水末香。盛一切天妙宝末香。盛一切天香华。盛一切天曼陀罗华。悉以奉散。供养于佛。百千亿那由他阿僧祇。兜率陀天子。住虚空中。咸于佛所。起智慧境界心。烧一切香。香气成云。庄严虚空。又于佛所。起欢喜心。雨一切天华云。庄严虚空。又于佛所。起尊重心。雨一切天盖云。庄严虚空。又于佛所。起供养心。散一切天鬘云。庄严虚空。又于佛所。生信解心。布阿僧祇金网。弥覆虚空。一切宝铃。常出妙音。又于佛所。生最胜福田心。以阿僧祇帐。庄严虚空。雨一切璎珞云。无有断绝。又于佛所。生深信心。以阿僧祇。诸天宫殿。庄严虚空。一切天乐。出微妙音。又于佛所。生最胜难遇心。以阿僧祇种种色天衣云。庄严虚空。雨于无比。种种妙衣。又于佛所。生无量欢喜踊跃心。以阿僧祇诸天宝冠。庄严虚空。雨无量天冠。广大成云。又于佛所。起欢喜心。以阿僧祇种种色宝。庄严虚空。雨一切璎珞云。无有断绝。百千亿那由他阿僧祇天子。咸于佛所。生净信心。散无数种种色天华。然无数种种色天香。供养如来。又于佛所。起大庄严变化心。持无数种种色。天栴檀末香。奉散如来。又于佛所。起欢喜踊跃心。持无数种种色盖。随逐如来。又于佛所。起增上心。持无数种种色天宝衣。敷布道路。供养如来。又于佛所。起清净心。持无数种种色天宝幢。奉迎如来。又于佛所。起增上欢喜心。持无数种种色。天庄严具。供养如来。又于佛所。生不坏信心。持无数天宝鬘。供养如来。又于佛所。生无比欢喜心。持无数种种色天宝幡。供养如来。百千亿那由他阿僧祇诸天子。以调顺寂静。无放逸心。持无数种种色天乐。出妙音声。供养如来。百千亿那由他不可说。先住兜率宫。诸菩萨众。以从超过三界法所生。离诸烦恼行所生。周遍无碍心所生。甚深方便法所生。无量广大智所生。坚固清净信所增长。不思议善根所生起。阿僧祇善巧变化所成就。供养佛心之所现。无作法门之所印。出过诸天。诸供养具。供养于佛。以从波罗蜜所生。一切宝盖。于一切佛境界。清净解所生。一切华帐。无生法忍所生一切衣。入金刚法。无碍心所生。一切铃网。解一切法。如幻心所生。一切坚固香。周遍一切佛境界。如来座心所生。一切佛众宝妙座。供养佛不懈心所生。一切宝幢。解诸法如梦。欢喜心所生。佛所住一切宝宫殿。无著善根。无生善根所生。一切宝莲华云。一切坚固香云。一切无边色华云。一切种种色妙衣云。一切无边清净栴檀香云。一切妙庄严宝盖云。一切烧香云。一切妙鬘云。一切清净。庄严具云。皆遍法界。出过诸天。供养之具。供养于佛。其诸菩萨。一一身。各出不可说百千亿那由他菩萨。皆充满法界虚空界。其心等于三世诸佛。以从无颠倒法所起。无量如来力所加。开示众生。安隐之道。具足不可说名味句。普入无量法。一切陀罗尼种中。生不可穷尽。辩才之藏。心无所畏。生大欢喜。以不可说。无量无尽。如实赞叹法。赞叹如来。无有厌足

尔时一切诸天。及诸菩萨众。见于如来应正等觉不可思议人中之雄。其身无量。不可称数。现不思议。种种神变。令无数众生。心大欢喜。普遍一切虚空界。一切法界。以佛庄严。而为庄严。令一切众生。安住善根。示现无量。诸佛神力。超过一切。诸语言道。诸大菩萨。所共钦敬。随所应化。皆令欢喜。住于诸佛广大之身功德善根。悉已清净。色相第一。无能映夺。智慧境界。不可穷尽。无比三昧之所出生。其身无际。遍住一切众生身中。令无量众生。皆大欢喜。令一切智。种性不断。住于诸佛。究竟所住。生于三世。诸佛之家。令不可数众生。信解清净。令一切菩萨。智慧成就。诸根悦豫。法云普覆。虚空法界。教化调伏。无有遗余。随众生心。悉令满足。令其安住无分别智。出过一切众生之上。获一切智。放大光明。宿世善根。皆令显现。普使一切。发广大心。令一切众生。安住普贤。不可坏智。遍住一切。众生国土。从于不退正法中生。住于一切平等法界。明了众生心之所宜。现不可说不可说。种种差别。如来之身。非世言辞。而叹可尽。能令一切。常思念佛。充满法界。广度群生。随初发心。所欲利益。以法惠施。令其调伏。信解清净。示现色身。不可思议。等观众生。心无所著。住无碍住。得佛十力。无所障碍。心常寂定。未曾散乱。住一切智。善能开演种种文句。真实之义。能悉深入无边智海。出生无量。功德慧藏。恒以佛日。普照法界。随本愿力。常现不没。恒住法界。住佛所住。无有变异。于我我所。俱无所著。住出世法。世法无染。于一切世间。建智慧幢。其智广大。超过世间。无所染着。拔诸众生。令出淤泥。置于最上。智慧之地。所有福德。饶益众生。而无有尽。了知一切菩萨智慧。信向决定。当成正觉。以大慈悲。现不可说。无量佛身。种种庄严。以妙音声。演无量法。随众生意。悉令满足。于去来今。心常清净。令诸众生。不着境界。恒与一切诸菩萨记。令其皆入佛之种性。生在佛家。得佛灌顶。常游十方。未曾休息。而于一切。无所乐着。法界佛刹。悉能遍往。诸众生心。靡不了知。所有福德。离世清净。不住生死。而于世间。如影普现。以智慧月。普照法界。了达一切。悉无所得。恒以智慧。知诸世间。如幻如影。如梦如化。一切皆以心为自性。如是而住。随诸众生。业报不同。心乐差别。诸根各异。而现佛身。如来恒以无数众生。而为所缘。为说世间。皆从缘起。知诸法相。皆悉无相。唯是一相。智慧之本。欲令众生。离诸相着。示现一切。世间性相。而行于世。为其开示无上菩提。为欲救护一切众生。出现世间。开示佛道。令其得见如来身相。攀缘忆念。勤加修习。除灭世间。烦恼之相。修菩提行。心不散动。于大乘门。皆得圆满。成就一切。诸佛义利。悉能观察众生善根。而不坏灭。清净业报。智慧明了。普入三世。永离一切世间分别。放光明网。普照十方。一切世界。无不充满。色身妙好。见者无厌。以大功德。智慧神通。出生种种。菩萨诸行。诸根境界。自在圆满。作诸佛事。作已便没。善能开示过现未来。一切智道。为诸菩萨。普雨无量陀罗尼雨。令其发起广大欲乐。受持修习。成就一切诸佛功德。圆满炽盛。无边妙色。庄严其身。一切世间。靡不现睹。永离一切障碍之法。于一切法。真实之义。已得清净。于功德法。而得自在。为大法王。如日普照。为世福田。具大威德。于一切世间。普现化身。放智慧光。悉令开悟。欲令众生。知佛具足无边功德。以无碍缯。系顶受位。随顺世间。方便开导。以智慧手。安慰众生。为大医王。善疗众病。一切世间。无量国土。悉能遍往。未曾休息。清净慧眼。离诸障翳。悉能明见于作不善。恶业众生。种种调伏。令其入道。善取时宜。无有休息。若诸众生。起平等心。即为化现。平等业报。随其心乐。随其业果。为现佛身。种种神变。而为说法。令其悟解。得法智慧。心大欢喜。诸根踊跃。见无量佛。起深重信。生诸善根。永不退转。一切众生。随业所系。长眠生死。如来出世。能觉悟之。安慰其心。使无忧怖。若得见者。悉令证入无依义智。智慧善巧。了达境界。庄严妙好。无能映夺。智山法芽。悉已清净。或现菩萨。或现佛身。令诸众生。至无患地。无数功德之所庄严。业行所成。现于世间。一切诸佛。庄严清净。莫不皆以一切智业之所成就。常守本愿。不舍世间。作诸众生。坚固善友。清净第一。离垢光明。令一切众生。皆得现见。六趣众生。无量无边。佛以神力。常随不舍。若有往昔。同种善根。皆令清净。而于六趣一切众生。不舍本愿。无所欺诳。悉以善法。方便摄取。令其修习清净之业。摧破一切。诸魔斗诤。从无碍际。出广大力。最胜日藏。无有障碍。于净心界。而现影像。一切世间。无不睹见。以种种法。广施众生。佛是无边。光明之藏。诸力智慧。皆悉圆满。恒以大光。普照众生。随其所愿。皆令满足。离诸怨敌。为上福田。一切众生。共所依怙。凡有所施。悉令清净。修少善行。受无量福。悉令得入无尽智地。为一切众生。种植善根。净心之主。为一切众生。发生福德。最上良田。智慧甚深。方便善巧。能救一切。三恶道苦。如是信解。如是观察。如是入于智慧之渊。如是游于功德之海。如是普至虚空智慧。如是而知众生福田。如是正念。现前观察。如是观佛。诸业相好。如是观佛。普现世间。如是观佛。神通自在。时彼大众。见如来身。一一毛孔。出百千亿那由他。阿僧祇光明。一一光明。有阿僧祇色。阿僧祇清净。阿僧祇照明。令阿僧祇众观察。阿僧祇众欢喜。阿僧祇众快乐。阿僧祇众深信增长。阿僧祇众志乐清净。阿僧祇众诸根清凉。阿僧祇众恭敬尊重。尔时大众。咸见佛身。放百千亿那由他。不思议大光明。一一光明。皆有不思议色。不思议光。照不思议无边法界。以佛神力。出大妙音。其音演畅。百千亿那由他。不思议赞颂。超诸世间。所有言辞。出世善根之所成就。复现百千亿那由他。不思议微妙庄严。于百千亿那由他。不思议劫。叹不可尽。皆是如来。无尽自在之所出生。又现不可说。诸佛如来。出兴于世。令诸众生。入智慧门。解甚深义。又现不可说。诸佛如来。所有变化。尽法界虚空界。令一切世间。平等清净。如是皆从如来所住。无障碍一切智生。亦从如来所修行。不思议胜德生。复现百千亿那由他不思议妙宝光焰。从昔大愿。善根所起。以曾供养无量如来。修清净行。无放逸故。萨婆若心。无有障碍。生善根故。为显如来。力广遍故。为断一切众生疑故。为令咸得见如来故。令无量众生住善根故。显示如来神通之力无映夺故。欲令众生普得入于究竟海故。为令一切诸佛国土菩萨大众皆来集故。为欲开示不可思议佛法门故。尔时如来。大悲普覆。示一切智。所有庄严。欲令不可说。百千亿那由他阿僧祇世界中众生。未信者信。已信者增长。已增长者。令其清净。已清净者。令其成熟。已成熟者。令心调伏。观甚深法。具足无量智慧光明。发生无量广大之心。萨婆若心。无有退转。不违法性。不怖实际。证真实理。满足一切。波罗蜜行。出世善根。皆悉清净。犹如普贤。得佛自在。离魔境界。入诸佛境了知深法。获难思智。大乘誓愿。永不退转。常见诸佛。未曾舍离。成就证智。证无量法。具足无边福德藏力。发欢喜心入无疑地。离恶清净。依一切智。见法不动。得入一切菩萨众会。常生三世。诸如来家。世尊所现。如是庄严。皆是过去。先所积集。善根所成。为欲调伏诸众生故。开示如来大威德故。照明无碍智慧藏故。示现如来无边胜德极炽然故。显示如来不可思议大神变故。以神通力于一切趣现佛身故。示现如来神通变化无边际故。本所志愿悉成满故。显示如来勇猛智慧能遍往故。于法自在成法王故。出生一切智慧门故。示现如来身清净故。又现其身最殊妙故。显示证得三世诸佛平等法故。开示善根清净藏故。显示世间无能为谕上妙色故。显示具足十力之相令其见者无厌足故。为世间日照三世故。自在法王。一切功德。皆从往昔。善根所现。一切菩萨。于一切劫。称扬赞说。不可穷尽。尔时兜率陀天王。奉为如来。严辨如是。诸供具已。与百千亿那由他阿僧祇兜率天子。向佛合掌。白佛言。善来世尊。善来善逝。善来如来应正等觉。唯见哀愍。处此宫殿

尔时世尊。以佛庄严。而自庄严。具大威德。为令一切众生生大欢喜故。一切菩萨发深悟解故。一切兜率陀天子增益欲乐故。兜率陀天王供养承事无厌足故。无量众生缘念于佛而发心故。无量众生种见佛善根福德无尽故。常能发起清净信故。见佛供养无所求故。所有志愿皆清净故。勤集善根无懈息故。发大誓愿求一切智故。受天王请。入一切宝庄严殿。如此世界。十方所有。一切世界。悉亦如是

尔时一切宝庄严殿。自然而有妙好庄严。出过诸天。庄严之上。一切宝网。周匝弥覆。普雨一切上妙宝云。普雨一切庄严具云。普雨一切宝衣云。普雨一切栴檀香云。普雨一切坚固香云。普雨一切宝庄严盖云。普雨不可思议华聚云。普出不可思议妓乐音声。赞扬如来一切种智。悉与妙法。而共相应。如是一切。诸供养具。悉过诸天。供养之上。时兜率宫中。妓乐歌赞。炽然不息。以佛神力。令兜率王。心无动乱。往昔善根。皆得圆满。无量善法。益加坚固。增长净信。起大精进。生大欢喜。净深志乐。发菩提心。念法无断。总持不忘。尔时兜率陀天王。承佛威力。即自忆念过去佛所。所种善根。而说颂言

  昔有如来无碍月　　诸吉祥中最殊胜
  彼曾入此庄严殿　　是故此处最吉祥
  昔有如来名广智　　诸吉祥中最殊胜
  彼曾入此金色殿　　是故此处最吉祥
  昔有如来名普眼　　诸吉祥中最殊胜
  彼曾入此莲华殿　　是故此处最吉祥
  昔有如来号珊瑚　　诸吉祥中最殊胜
  彼曾入此宝藏殿　　是故此处最吉祥
  昔有如来论师子　　诸吉祥中最殊胜
  彼曾入此山王殿　　是故此处最吉祥
  昔有如来名日照　　诸吉祥中最殊胜
  彼曾入此众华殿　　是故此处最吉祥
  昔有佛号无边光　　诸吉祥中最殊胜
  彼曾入此树严殿　　是故此处最吉祥
  昔有如来名法幢　　诸吉祥中最殊胜
  彼曾入此宝宫殿　　是故此处最吉祥
  昔有如来名智灯　　诸吉祥中最殊胜
  彼曾入此香山殿　　是故此处最吉祥
  昔有佛号功德光　　诸吉祥中最殊胜
  彼曾入此摩尼殿　　是故此处最吉祥

如此世界。兜率天王。承佛神力。以颂赞叹过去诸佛。十方一切。诸世界中。兜率天王。悉亦如是。叹佛功德

尔时世尊。于一切宝庄严殿。摩尼宝藏。师子座上。结跏趺坐。法身清净。妙用自在。与三世佛。同一境界。住一切智。与一切佛。同入一性。佛眼明了。见一切法。皆无障碍。有大威力。普游法界。未尝休息。具大神通。随有可化。众生之处。悉能遍往。以一切诸佛。无碍庄严。而严其身。善知其时。为众说法。不可说诸菩萨众。各从他方。种种国土。而共来集。众会清净。法身无二。无所依止。而能自在。起佛身行。坐此座已。于其殿中。自然而有无量无数。殊特妙好。出过诸天。供养之具。所谓。华鬘衣服。涂香末香。宝盖幢幡。妓乐歌赞。如是等事。一一皆悉不可称数。以广大心。恭敬尊重。供养于佛。十方一切。兜率陀天。悉亦如是

大方广佛华严经卷第二十二大方广佛华严经卷第二十三

        于阗国三藏实叉难陀奉　制译

    兜率宫中偈赞品第二十四

尔时佛神力故。十方各有一大菩萨。一一各与万佛刹。微尘数诸菩萨俱。从万佛刹。微尘数国土外。诸世界中。来诣佛所。其名曰。金刚幢菩萨。坚固幢菩萨。勇猛幢菩萨。光明幢菩萨。智幢菩萨。宝幢菩萨。精进幢菩萨。离垢幢菩萨。星宿幢菩萨。法幢菩萨。所从来国。谓妙宝世界。妙乐世界。妙银世界。妙金世界。妙摩尼世界。妙金刚世界。妙波头摩世界。妙优钵罗世界。妙栴檀世界。妙香世界。各于佛所。净修梵行。所谓。无尽幢佛。风幢佛。解脱幢佛。威仪幢佛。明相幢佛。常幢佛。最胜幢佛。自在幢佛。梵幢佛。观察幢佛。其诸菩萨。至佛所已。顶礼佛足。以佛神力。即化作妙宝藏师子之座。宝网弥覆。周匝遍满。诸菩萨众。随所来方。各于其上。结跏趺坐。其身悉放百千亿。那由他阿僧祇。清净光明。此无量光。皆从菩萨。清净心宝。离众过恶。大愿所起。显示一切。诸佛自在。清净之法。以诸菩萨。平等眼力。能普救护一切众生。一切世间之所乐见。见者不虚。悉得调伏。其菩萨众。悉已成就无量功德。所谓。遍游一切诸佛国土。无所障碍。见无依止。清净法身。以智慧身。现无量身。遍往十方。承事诸佛。入于诸佛。无量无边。不可思议。自在之法。住于无量。一切智门。以智光明。善了诸法。于诸法中。得无所畏。随所演说。穷未来际。辩才无尽。以大智慧。开总持门。慧眼清净。入深法界。智慧境界。无有边际。究竟清净。犹若虚空。如此世界。兜率天宫。诸菩萨众。如是来集。十方一切。兜率天宫。悉有如是。名号菩萨。而来集会。所从来国。诸佛名号。亦皆同等。无有差别。尔时世尊。从两膝轮。放百千亿那由他光明。普照十方尽法界虚空界。一切世界。彼诸菩萨。皆见于此佛神变相。此诸菩萨。亦见于彼一切如来。神变之相。如是菩萨。皆与毗卢遮那如来。于往昔时。同种善根。修菩萨行。悉已悟入诸佛自在。甚深解脱。得无差别。法界之身。入一切土。而无所住。见无量佛。悉往承事。于一念中。周行法界。自在无碍。心意清净。如无价宝。无量无数。诸佛如来。常加护念。共与其力。到于究竟第一彼岸。恒以净念。住无上觉。念念恒入一切智处。以小入大。以大入小。皆得自在。通达无碍。已得佛身。与佛同住。获一切智。从一切智。而生其身。一切如来。所行之处。悉能随入。开阐无量智慧法门。到金刚幢。大智彼岸。获金刚定。断诸疑惑。已得诸佛。自在神通。普于一切。十方国土。教化调伏百千万亿。无数众生。于一切数。虽无所著。善能修学。成就究竟。方便安立一切诸法。如是等。百千亿那由他不可说。无尽清净。三世一切。无量功德藏。诸菩萨众。皆来集会。在于佛所。因光所见。一切佛所。悉亦如是。尔时金刚幢菩萨。承佛神力。普观十方。而说颂言

  如来不出世　　亦无有涅槃
  以本大愿力　　示现自在法
  是法难思议　　非心所行处
  智慧到彼岸　　乃见诸佛境
  色身非是佛　　音声亦复然
  亦不离色声　　见佛神通力
  少智不能知　　诸佛实境界
  久修清净业　　于此乃能了
  正觉无来处　　去亦无所从
  清净妙色身　　神力故显现
  无量世界中　　示现如来身
  广说微妙法　　其心无所著
  智慧无边际　　了达一切法
  普入于法界　　示现自在力
  众生及诸法　　了达皆无碍
  普现众色像　　遍于一切刹
  欲求一切智　　速成无上觉
  应以净妙心　　修习菩提行
  若有见如来　　如是威神力
  当于最胜尊　　供养勿生疑

尔时坚固幢菩萨。承佛神力。普观十方。而说颂言

  如来胜无比　　甚深不可说
  出过言语道　　清净如虚空
  汝观人师子　　自在神通力
  已离于分别　　而令分别见
  导师为开演　　甚深微妙法
  以是因缘故　　现此无比身
  此是大智慧　　诸佛所行处
  若欲了知者　　常应亲近佛
  意业常清净　　供养诸如来
  终无疲厌心　　能入于佛道
  具无尽功德　　坚住菩提心
  以是疑网除　　观佛无厌足
  通达一切法　　是乃真佛子
  此人能了知　　诸佛自在力
  广大智所说　　欲为诸法本
  应起胜希望　　志求无上觉
  若有尊敬佛　　念报于佛恩
  彼人终不离　　一切诸佛住
  何有智慧人　　于佛得见闻
  不修清净愿　　履佛所行道

尔时勇猛幢菩萨。承佛神力。普观十方。而说颂言

  譬如明净眼　　因日睹众色
  净心亦复然　　佛力见如来
  如以精进力　　能尽海源底
  智力亦如是　　得见无量佛
  譬如良沃田　　所种必滋长
  如是净心地　　出生诸佛法
  如人获宝藏　　永离贫穷苦
  菩萨得佛法　　离垢心清净
  譬如伽陀药　　能消一切毒
  佛法亦如是　　灭诸烦恼患
  真实善知识　　如来所称赞
  以彼威神故　　得闻诸佛法
  设于无数劫　　财宝施于佛
  不知佛实相　　此亦不名施
  无量众色相　　庄严于佛身
  非于色相中　　而能见于佛
  如来等正觉　　寂然恒不动
  而能普现身　　遍满十方界
  譬如虚空界　　不生亦不灭
  诸佛法如是　　毕竟无生灭

尔时光明幢菩萨。承佛神力。普观十方。而说颂言

  人间及天上　　一切诸世界
  普见于如来　　清净妙色身
  譬如一心力　　能生种种心
  如是一佛身　　普现一切佛
  菩提无二法　　亦复无诸相
  而于二法中　　现相庄严身
  了法性空寂　　如幻而生起
  所行无有尽　　导师如是现
  三世一切佛　　法身悉清净
  随其所应化　　普现妙色身
  如来不念言　　我作如是身
  自然而示现　　未尝起分别
  法界无差别　　亦无所依止
  而于世间中　　示现无量身
  佛身非变化　　亦复非非化
  于无化法中　　示有变化形
  正觉不可量　　法界虚空等
  深广无涯底　　言语道悉绝
  如来善通达　　一切处行道
  法界众国土　　所往皆无碍

尔时智幢菩萨。承佛神力。普观十方。而说颂言

  若人能信受　　一切智无碍
  修习菩提行　　其心不可量
  一切国土中　　普现无量身
  而身不在处　　亦不住于法
  一一诸如来　　神力示现身
  不可思议劫　　算数莫能尽
  三世诸众生　　悉可知其数
  如来所示现　　其数不可得
  或时示一二　　乃至无量身
  普现十方刹　　其实无二种
  譬如净满月　　普现一切水
  影像虽无量　　本月未曾二
  如是无碍智　　成就等正觉
  普现一切刹　　佛体亦无二
  非一亦非二　　亦复非无量
  随其所应化　　示现无量身
  佛身非过去　　亦复非未来
  一念现出生　　成道及涅槃
  如幻所作色　　无生亦无起
  佛身亦如是　　示现无有生

尔时宝幢菩萨。承佛神力。普观十方。而说颂言

  佛身无有量　　能示有量身
  随其所应睹　　导师如是现
  佛身无处所　　充满一切处
  如空无边际　　如是难思议
  非心所行处　　心不于中起
  诸佛境界中　　毕竟无生灭
  如翳眼所睹　　非内亦非外
  世间见诸佛　　应知亦如是
  饶益众生故　　如来出世间
  众生见有出　　而实无兴世
  不可以国土　　昼夜而见佛
  岁月一刹那　　当知悉如是
  众生如是说　　某日佛成道
  如来得菩提　　实不系于日
  如来离分别　　非世超诸数
  三世诸导师　　出现皆如是
  譬如净日轮　　不与昏夜合
  而说某日夜　　诸佛法如是
  三世一切劫　　不与如来合
  而说三世佛　　导师法如是

尔时精进幢菩萨。承佛神力。普观十方。而说颂言

  一切诸导师　　身同义亦然
  普于十方刹　　随应种种现
  汝观牟尼尊　　所作甚奇特
  充满于法界　　一切悉无余
  佛身不在内　　亦复不在外
  神力故显现　　导师法如是
  随诸众生类　　先世所集业
  如是种种身　　示现各不同
  诸佛身如是　　无量不可数
  唯除大觉尊　　无有能思议
  如以我难思　　心业莫能取
  佛难思亦尔　　非心业所现
  如刹不可思　　而见净庄严
  佛难思亦尔　　妙相无不现
  譬如一切法　　众缘故生起
  见佛亦复然　　必假众善业
  譬如随意珠　　能满众生心
  诸佛法如是　　悉满一切愿
  无量国土中　　导师兴于世
  随其愿力故　　普应于十方

尔时离垢幢菩萨。承佛神力。普观十方。而说颂言

  如来大智光　　普净诸世间
  世间既净已　　开示诸佛法
  设有人欲见　　众生数等佛
  靡不应其心　　而实无来处
  以佛为境界　　专念而不息
  此人得见佛　　其数与心等
  成就白净法　　具足诸功德
  彼于一切智　　专念心不舍
  导师为众生　　如应演说法
  随于可化处　　普现最胜身
  佛身及世间　　一切皆无我
  悟此成正觉　　复为众生说
  一切人师子　　无量自在力
  示现念等身　　其身各不同
  世间如是身　　诸佛身亦然
  了知其自性　　是则说名佛
  如来普知见　　明了一切法
  佛法及菩提　　二俱不可得
  导师无来去　　亦复无所住
  远离诸颠倒　　是名等正觉

尔时星宿幢菩萨。承佛神力。普观十方。而说颂言

  如来无所住　　普住一切刹
  一切土皆往　　一切处咸见
  佛随众生心　　普现一切身
  成道转法轮　　及以般涅槃
  诸佛不思议　　谁能思议佛
  谁能见正觉　　谁能现最胜
  一切法皆如　　诸佛境亦然
  乃至无一法　　如中有生灭
  众生妄分别　　是佛是世界
  了达法性者　　无佛无世界
  如来普现前　　令众生信喜
  佛体不可得　　彼亦无所见
  若能于世间　　远离一切着
  无碍心欢喜　　于法得开悟
  神力之所现　　即此说名佛
  三世一切时　　求悉无所有
  若能如是知　　心意及诸法
  一切悉知见　　疾得成如来
  言语中显示　　一切佛自在
  正觉超语言　　假以语言说

尔时法幢菩萨。承佛神力。普观十方。而说颂言

  宁可恒具受　　一切世间苦
  终不远如来　　不睹自在力
  若有诸众生　　未发菩提心
  一得闻佛名　　决定成菩提
  若有智慧人　　一念发道心
  必成无上尊　　慎莫生疑惑
  如来自在力　　无量劫难遇
  若生一念信　　速登无上道
  设于念念中　　供养无量佛
  未知真实法　　不名为供养
  若闻如是法　　诸佛从此生
  虽经无量苦　　不舍菩提行
  一闻大智慧　　诸佛所入法
  普于法界中　　成三世导师
  虽尽未来际　　遍游诸佛刹
  不求此妙法　　终不成菩提
  众生无始来　　生死久流转
  不了真实法　　诸佛故兴世
  诸法不可坏　　亦无能坏者
  自在大光明　　普示于世间

    大方广佛华严经十回向品第二十五之一

尔时金刚幢菩萨。承佛神力。入菩萨智光三昧。入是三昧已。十方各过十万佛刹微尘数世界外。有十万佛刹微尘数诸佛。皆同一号。号金刚幢。而现其前。咸称赞言。善哉善哉。善男子。乃能入此菩萨智光三昧。善男子。此是十方。各十万佛刹微尘数。诸佛神力。共加于汝。亦是毗卢遮那如来。往昔愿力。威神之力。及由汝智慧清净故。诸菩萨善根增胜故。令汝入是三昧。而演说法。为令诸菩萨。得清净无畏故。具无碍辩才故。入无碍智地故。住一切智大心故。成就无尽善根故。满足无碍白法故。入于普门法界故。现一切佛神力故。前际念智不断故。得一切佛护持诸根故。以无量门。广说众法故。闻悉解了。受持不忘故。摄诸菩萨一切善根故。成辨出世助道故。不断一切智智故。开发大愿故。解释实义故。了知法界故。令诸菩萨皆悉欢喜故。修一切佛平等善根故。护持一切如来种性故。所谓演说诸菩萨十回向。佛子。汝当承佛威神之力。而演此法。得佛护念故。安住佛家故。增益出世功德故。得陀罗尼光明故。入无障碍佛法故。大光普照法界故。集无过失净法故。住广大智境界故。得无障碍法光故。尔时诸佛。即与金刚幢菩萨。无量智慧。与无留碍辩。与分别句义善方便。与无碍法光明。与如来平等身。与无量差别净音声。与菩萨不思议善观察三昧。与不可沮坏。一切善根。回向智。与观察一切法。成就巧方便。与一切处。说一切法无断辩。何以故。入此三昧善根力故。尔时诸佛。各以右手。摩金刚幢菩萨顶。金刚幢菩萨。得摩顶已。即从定起。告诸菩萨言。佛子。菩萨摩诃萨。有不可思议大愿。充满法界。普能救护一切众生。所谓。修学去来现在。一切佛回向。佛子。菩萨摩诃萨回向有几种。佛子。菩萨摩诃萨。回向有十种。三世诸佛。咸共演说。何等为十。一者救护一切众生离众生相回向。二者不坏回向。三者等一切诸佛回向。四者至一切处回向。五者无尽功德藏回向。六者入一切平等善根回向。七者等随顺一切众生回向。八者真如相回向。九者无缚无著解脱回向。十者入法界无量回向。佛子。是为菩萨摩诃萨十种回向。过去未来现在诸佛。已说当说今说

佛子。云何为菩萨摩诃萨救护一切众生离众生相回向。佛子。此菩萨摩诃萨。行檀波罗蜜。净尸波罗蜜。修羼提波罗蜜。起精进波罗蜜。入禅波罗蜜。住般若波罗蜜。大慈大悲。大喜大舍。修如是等无量善根。修善根时。作是念言。愿此善根。普能饶益一切众生。皆使清净。至于究竟。永离地狱。饿鬼畜生。阎罗王等。无量苦恼。菩萨摩诃萨。种善根时。以己善根。如是回向。我当为一切众生作舍。令免一切诸苦事故。为一切众生作护。悉令解脱诸烦恼故。为一切众生作归。皆令得离诸怖畏故。为一切众生作趣。令得至于一切智故。为一切众生作安。令得究竟安隐处故。为一切众生作明。令得智光灭痴暗故。为一切众生作炬。破彼一切无明闇故。为一切众生作灯。令住究竟清净处故。为一切众生作导师。引其令入真实法故。为一切众生作大导师。与其无碍大智慧故。佛子。菩萨摩诃萨。以诸善根。如是回向。平等饶益一切众生。究竟皆令得一切智。佛子。菩萨摩诃萨。于非亲友。守护回向。与其亲友。等无差别。何以故。菩萨摩诃萨。入一切法平等性故。不于众生而起一念非亲友想。设有众生。于菩萨所。起怨害心。菩萨亦以慈眼视之。终无恚怒。普为众生。作善知识。演说正法。令其修习。譬如大海。一切众毒。不能变坏。菩萨亦尔。一切愚蒙。无有智慧。不知恩德。嗔很顽毒。憍慢自大。其心盲瞽。不识善法。如是等类。诸恶众生。种种逼恼。无能动乱。譬如日天子。出现世间。不以生盲不见故。隐而不现。又复不以乾闼婆城。阿修罗手。阎浮提树。崇岩邃谷。尘雾烟云。如是等物之所覆障故。隐而不现。亦复不以时节变改故。隐而不现。菩萨摩诃萨。亦复如是。有大福德。其心深广。正念观察。无有退屈。为欲究竟功德智慧。于上胜法。心生志欲。法光普照。见一切义。于诸法门。智慧自在。常为利益一切众生。而修善法。曾不误起舍众生心。不以众生其性弊恶。邪见嗔浊。难可调伏。便即弃舍。不修回向。但以菩萨。大愿甲胄。而自庄严。救护众生。恒无退转。不以众生。不知报恩。退菩萨行。舍菩提道。不以凡愚。共同一处。舍离一切如实善根。不以众生。数起过恶。难可忍受。而于彼所。生疲厌心。何以故。譬如日天子。不但为一事故。出现世间。菩萨摩诃萨。亦复如是。不但为一众生故。修诸善根。回向阿耨多罗三藐三菩提。普为救护一切众生故。而修善根。回向阿耨多罗三藐三菩提。如是。不但为净一佛刹故。不但为信一佛故。不但为见一佛故。不但为了一法故。起大智愿。回向阿耨多罗三藐三菩提。为普净一切佛刹故。普信一切诸佛故。普承事供养。一切诸佛故。普解一切佛法故。发起大愿。修诸善根。回向阿耨多罗三藐三菩提。佛子。菩萨摩诃萨。以诸佛法。而为所缘。起广大心。不退转心。无量劫中。修集希有难得心宝。与一切诸佛。悉皆平等。菩萨如是。观诸善根。信心清净。大悲坚固。以甚深心。欢喜心。清净心。最胜心。柔软心。慈悲心。怜愍心。摄护心。利益心。安乐心。普为众生。真实回向。非但口言。佛子。菩萨摩诃萨。以诸善根。回向。之时。作是念言。以我善根。愿一切趣生。一切众生。皆得清净。功德圆满。不可沮坏。无有穷尽。常得尊重。正念不忘。获决定慧。具无量智。身口意业。一切功德。圆满庄严。又作是念。以此善根。令一切众生。承事供养一切诸佛。无空过者。于诸佛所。净信不坏。听闻正法。断诸疑惑。忆持不忘。如说修行。于如来所。起恭敬心。身业清净。安住无量广大善根。永离贫穷。七财满足。于诸佛所。常随修学。成就无量胜妙善根。平等悟解。住一切智。以无碍眼。等视众生。众相严身。无有玷缺。言音净妙。功德圆满。诸根调伏。十力成就。善心满足。无所依住。令一切众生。普得佛乐。得无量住。住佛所住。佛子。菩萨摩诃萨。见诸众生。造作恶业。受诸重苦。以是障故。不见佛。不闻法。不识僧。便作是念。我当于彼诸恶道中。代诸众生。受种种苦。令其解脱。菩萨如是。受苦毒时。转更精勤。不舍不避。不惊不怖。不退不怯。无有疲厌。何以故。如其所愿。决欲荷负一切众生。令解脱故。菩萨尔时。作是念言。一切众生。在生老病死。诸苦难处。随业流转。邪见无智。丧诸善法。我应救之。令得出离。又诸众生。爱网所缠。痴盖所覆。染着诸有。随逐不舍。入苦笼槛。作魔业行。福智都尽。常怀疑惑。不见安隐处。不知出离道在于生死轮转不息。诸苦淤泥恒所没溺。菩萨见已。起大悲心。大饶益心。欲令众生。悉得解脱。以一切善根回向。以广大心回向。如三世菩萨。所修回向。如大回向经所说回向。愿诸众生。普得清净。究竟成就一切种智。复作是念。我所修行。欲令众生。皆悉得成无上智王。不为自身。而求解脱。但为救济一切众生。令其咸得一切智心。度生死流。解脱众苦。复作是念。我当普为一切众生。备受众苦。令其得出无量生死。众苦大壑。我当普为一切众生。于一切世界。一切恶趣中。尽未来劫。受一切苦。然常为众生。勤修善根。何以故。我宁独受如是众苦。不令众生堕于地狱。我当于彼地狱畜生。阎罗王等。险难之处。以身为质。救赎一切恶道众生。令得解脱。复作是念。我愿保护一切众生。终不弃舍。所言诚实。无有虚妄。何以故。我为救度一切众生。发菩提心。不为自身。求无上道。亦不为求五欲境界。及三有中。种种乐故。修菩提行。何以故。世间之乐。无非是苦。众魔境界。愚人所贪。诸佛所诃。一切苦患。因之而起。地狱饿鬼。及以畜生。阎罗王处。忿恚斗讼。更相毁辱。如是诸恶。皆因贪着五欲所致。耽着五欲。远离诸佛。障碍生天。何况得于阿耨多罗三藐三菩提。菩萨如是。观诸世间。贪少欲味。受无量苦。终不为彼五欲乐故。求无上菩提。修菩萨行。但为安乐一切众生。发心修习。成满大愿。断截众生。诸苦罥索。令得解脱。佛子。菩萨摩诃萨。复作是念。我当以善根。如是回向。令一切众生。得究竟乐。利益乐。不受乐。寂静乐。无依乐。无动乐。无量乐。不舍不退乐。不灭乐一切智乐。复作是念。我当与一切众生。作调御师。作主兵臣。执大智炬。示安隐道。令离险难。以善方便。俾知实义。又于生死海。作一切智善巧船师。度诸众生。使到彼岸。佛子。菩萨摩诃萨。以诸善根。如是回向。所谓随宜救护一切众生。令出生死。承事供养一切诸佛。得无障碍。一切智智。舍离众魔。远恶知识。亲近一切菩萨善友。灭诸过罪。成就净业。具足菩萨。广大行愿。无量善根。佛子。菩萨摩诃萨。以诸善根。正回向己。作如是念。不以四天下。众生多故。多日出现。但一日出。悉能普照一切众生。又诸众生。不以自身光明故。知有昼夜。游行观察。兴造诸业。皆由日天子出。成辨斯事。然彼日轮。但一无二。菩萨摩诃萨。亦复如是。修集善根回向之时。作是念言。彼诸众生。不能自救。何能救他。唯我一人。志独无侣。修集善根。如是回向。所谓为欲广度一切众生故。普照一切众生故。示导一切众生故。开悟一切众生故。顾复一切众生故。摄受一切众生故。成就一切众生故。令一切众生欢喜故。令一切众生悦乐故。令一切众生断疑故。佛子。菩萨摩诃萨。复作是念。我应如日。普照一切。不求恩报。众生有恶。悉能容受。终不以此。而舍誓愿。不以一众生恶故。舍一切众生。但勤修习善根回向。普令众生。皆得安乐。善根虽少。普摄众生。以欢喜心。广大回向。若有善根。不欲饶益一切众生。不名回向。随一善根。普以众生。而为所缘。乃名回向。安置众生。于无所著法性回向。见众生自性。不动不转回向于回向。无所依无所取回向。不取善根相回向。不分别业报体性回向。不着五蕴相回向。不坏五蕴相回向。不取业回向。不求报回向。不染着因缘回向。不分别因缘所起回向。不著名称回向。不着处所回向。不着虚妄法回向。不着众生相世界相心意相回向。不起心颠倒想颠倒见颠倒回向。不着语言道回向。观一切法真实性回向。观一切众生平等相回向。以法界印印诸善根回向。观诸法离贪欲回向。解一切法。无种植善根。亦如是。观诸法无二无生无灭回向。亦如是。以如是等善根回向。修行清净。对治之法。所有善根。皆悉随顺出世间法。不作二相。非即业修习一切智非离业回向一切智。一切智。非即是业。然不离业。得一切智。以业如光影清净故。报亦如光影清净。报如光影清净故。一切智智。亦如光影清净。离我我所。一切动乱。思惟分别。如是了知。以诸善根。方便回向。菩萨如是。回向之时。度脱众生。常无休息。不住法相。虽知诸法。无业无报。善能出生一切业报。而无违诤。如是方便。善修回向。菩萨摩诃萨。如是回向时。离一切过。诸佛所赞。佛子。是为菩萨摩诃萨第一救护一切众生离众生相回向

尔时金刚幢菩萨。观察十方。一切众会。暨于法界。入深句义。以无量心。修习胜行。大悲普覆一切众生。不断三世诸如来种。入一切佛功德法藏。出生一切诸佛法身。善能分别诸众生心。知其所种。善根成熟。住于法身。而为示现清净色身。承佛神力。即说颂言

  不思议劫修行道　　精进坚固心无碍
  为欲饶益群生类　　常求诸佛功德法
  调御世间无等人　　修治其意甚明洁
  发心普救诸含识　　彼能善入回向藏
  勇猛精进力具足　　智慧聪达意清净
  普救一切诸群生　　其心堪忍不倾动
  心善安住无与等　　意常清净大欢悦
  如是为物勤修行　　譬如大地普容受
  不为自身求快乐　　但欲救护诸众生
  如是发起大悲心　　疾得入于无碍地
  十方一切诸世界　　所有众生皆摄受
  为救彼故善住心　　如是修学诸回向
  修行布施大欣悦　　护持净戒无所犯
  勇猛精进心不动　　回向如来一切智
  其心广大无边际　　忍力安住不倾动
  禅定甚深恒照了　　智慧微妙难思议
  十方一切世界中　　具足修治清净行
  如是功德皆回向　　为欲安乐诸含识
  大士勤修诸善业　　无量无边不可数
  如是悉以益众生　　令住难思无上智
  普为一切众生故　　不思议劫处地狱
  如是曾无厌退心　　勇猛决定常回向
  不求色声香与味　　亦不希求诸妙触
  但为救度诸群生　　常求无上最胜智
  智慧清净如虚空　　修习无边大士行
  如佛所行诸行法　　彼人如是常修学
  大士游行诸世界　　悉能安隐诸群生
  普使一切皆欢喜　　修菩萨行无厌足
  除灭一切诸心毒　　思惟修习最上智
  不为自己求安乐　　但愿众生得离苦
  此人回向得究竟　　心常清净离众毒
  三世如来所付嘱　　住于无上大法城
  未曾染着于诸色　　受想行识亦如是
  其心永出于三有　　所有功德尽回向
  佛所知见诸众生　　尽皆摄取无有余
  誓愿皆令得解脱　　为彼修行大欢喜
  其心念念恒安住　　智慧广大无与等
  离痴正念常寂然　　一切诸业皆清净
  彼诸菩萨处于世　　不着内外一切法
  如风无碍行于空　　大士用心亦复然
  所有身业皆清净　　一切语言无过失
  心常归向于如来　　能令诸佛悉欢喜
  十方无量诸国土　　所有佛处皆往诣
  于中睹见大悲尊　　靡不恭敬而瞻奉
  心常清净离诸失　　普入世间无所畏
  已住如来无上道　　复为三有大法池
  精勤观察一切法　　随顺思惟有非有
  如是趣于真实理　　得入甚深无诤处
  以此修成坚固道　　一切众生莫能坏
  善能了达诸法性　　普于三世无所著
  如是回向到彼岸　　普使群生离众垢
  永离一切诸所依　　得入究竟无依处
  一切众生语言道　　随其种类各差别
  菩萨悉能分别说　　而心无著无所碍
  菩萨如是修回向　　功德方便不可说
  能令十方世界中　　一切诸佛皆称叹

大方广佛华严经卷第二十三大方广佛华严经卷第二十四

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之二

佛子。云何为菩萨摩诃萨不坏回向。佛子。此菩萨摩诃萨。于去来今。诸如来所。得不坏信。悉能承事一切佛故。于诸菩萨。乃至初发一念之心。求一切智。得不坏信。誓修一切菩萨善根。无疲厌故。于一切佛法。得不坏信。发深志乐故。于一切佛教。得不坏信。守护住持故。于一切众生。得不坏信。慈眼等观。善根回向。普利益故。于一切白净法。得不坏信。普集无边诸善根故。于一切菩萨回向道。得不坏信。满足殊胜诸欲解故。于一切菩萨法师。得不坏信。于诸菩萨。起佛想故。于一切佛。自在神通。得不坏信。深信诸佛。难思议故。于一切菩萨。善巧方便行。得不坏信。摄取种种。无量无数。行境界故。佛子。菩萨摩诃萨。如是安住不坏信时。于佛菩萨。声闻独觉。若诸佛教。若诸众生。如是等种种境界中。种诸善根。无量无边。令菩提心。转更增长。慈悲广大。平等观察。随顺修学诸佛所作。摄取一切清净善根。入真实义。集福德行。行大惠施。修诸功德。等观三世。菩萨摩诃萨。以如是等。善根功德。回向一切智。愿常见诸佛。亲近善友。与诸菩萨。同共止住。念一切智。心无暂舍。受持佛教。勤加守护。教化成熟一切众生。心常回向出世之道。供养瞻待一切法师。解了诸法。忆持不忘。修行大愿。悉使满足。菩萨如是。积集善根。成就善根。增长善根。思惟善根。系念善根。分别善根。爱乐善根。修习善根。安住善根。菩萨摩诃萨。如是积集诸善根已。以此善根。所得依果修菩萨行。于念念中。见无量佛。如其所应。承事供养。以阿僧祇宝。阿僧祇华。阿僧祇鬘。阿僧祇衣。阿僧祇盖。阿僧祇幢。阿僧祇幡。阿僧祇庄严具。阿僧祇给侍。阿僧祇涂饰地。阿僧祇涂香。阿僧祇末香。阿僧祇和香。阿僧祇烧香。阿僧祇深信。阿僧祇爱乐。阿僧祇净心。阿僧祇尊重。阿僧祇赞叹。阿僧祇礼敬。阿僧祇宝座。阿僧祇华座。阿僧祇香座。阿僧祇鬘座。阿僧祇栴檀座。阿僧祇衣座。阿僧祇金刚座。阿僧祇摩尼座。阿僧祇宝缯座。阿僧祇宝色座。阿僧祇宝经行处。阿僧祇华经行处。阿僧祇香经行处。阿僧祇鬘经行处。阿僧祇衣经行处。阿僧祇宝间错经行处。阿僧祇一切宝缯彩经行处。阿僧祇一切宝多罗树经行处。阿僧祇一切宝栏楯经行处。阿僧祇一切宝铃网弥覆经行处。阿僧祇一切宝宫殿。阿僧祇一切华宫殿。阿僧祇一切香宫殿。阿僧祇一切鬘宫殿。阿僧祇一切栴檀宫殿。阿僧祇一切坚固妙香藏宫殿。阿僧祇一切金刚宫殿。阿僧祇一切摩尼宫殿。皆悉殊妙。出过诸天。阿僧祇诸杂宝树。阿僧祇种种香树。阿僧祇诸宝衣树。阿僧祇诸音乐树。阿僧祇宝庄严具树。阿僧祇妙音声树。阿僧祇无厌宝树。阿僧祇宝缯彩树。阿僧祇宝珰树。阿僧祇一切华香。幢幡鬘盖。所严饰树。如是等树。扶疏荫映。庄严宫殿。其诸宫殿。复有阿僧祇轩槛庄严。阿僧祇窗牖庄严。阿僧祇门闼庄严。阿僧祇楼阁庄严。阿僧祇半月庄严。阿僧祇帐庄严。阿僧祇金网。弥覆其上。阿僧祇香。周匝普熏。阿僧祇衣。敷布其地。佛子。菩萨摩诃萨。以如是等。诸供养具。于无量无数不可说不可说劫。净心尊重。恭敬供养一切诸佛。恒不退转。无有休息。一一如来。灭度之后。所有舍利。悉亦如是。恭敬供养。为令一切众生。生净信故。一切众生。摄善根故。一切众生。离诸苦故。一切众生。广大解故。一切众生。以大庄严。而庄严故。无量庄严。而庄严故。诸有所作。得究竟故。知诸佛兴。难可值故。满足如来。无量力故。庄严供养佛塔庙故。住持一切诸佛法故。如是供养现在诸佛。及灭度后。所有舍利。其诸供养。于阿僧祇劫。说不可尽。如是修集无量功德。皆为成熟一切众生。无有退转。无有休息。无有疲厌。无有执着。离诸心想。无有依止。永绝所依。远离于我。及以我所。如实法印。印诸业门。得法无生。住佛所住。观无生性。印诸境界诸佛护念发心回向。与诸法性相应回向。入无作法。成就所作方便回向。舍离一切诸事想着方便回向。住于无量善巧回向。永出一切诸有回向。修行诸行不住于相善巧回向。普摄一切善根回向。普净一切菩萨诸行广大回向。发无上菩提心回向。与一切善根同住回向。满足最上信解心回向。佛子。菩萨摩诃萨。以诸善根。如是回向时。虽随生死。而不改变。求一切智未曾退转。在于诸有。心无动乱。悉能度脱一切众生。不染有为法。不失无碍智。菩萨行位。因缘无尽。世间诸法。无能变动。具足清净诸波罗蜜。悉能成就一切智力菩萨如是。离诸痴暗。成菩提心。开示光明。增长净法。回向胜道。具足众行。以清净意。善能分别。了一切法。悉随心现。知业如幻。业报如像。诸行如化。因缘生法。悉皆如响。菩萨诸行。一切如影。出生无著。清净法眼。见于无作。广大境界。证寂灭性。了法无二。得法实相。具菩萨行。于一切相。皆无所著。善能修行。同事诸业。于白净法。恒无废舍。离一切着。住无著行。菩萨如是。善巧思惟。无有迷惑。不违诸法。不坏业因。明见真实。善巧回向知法自性。以方便力。成就业报。到于彼岸。智慧观察一切诸法。获神通智。诸业善根。无作而行。随心自在。菩萨摩诃萨。以诸善根。如是回向。为欲度脱一切众生。不断佛种。永离魔业。见一切智。无有边际。信乐不舍离世境界。断诸杂染。亦愿众生。得清净智。入深方便。出生死法。获佛善根。永断一切诸魔事业。以平等印。普印诸业。发心趣入一切种智。成就一切出世间法。佛子。是为菩萨摩诃萨第二不坏回向。菩萨摩诃萨。住此回向时。得见一切无数诸佛。成就无量清净妙法。普于众生。得平等心。于一切法。无有疑惑。一切诸佛。神力所加。降伏众魔。永离其业。成就生贵。满菩提心。得无碍智。不由他解。善能开阐一切法义。能随想力。入一切刹。普照众生。悉使清净。菩萨摩诃萨。以此不坏回向之力。摄诸善根。如是回向。尔时金刚幢菩萨。观察十方。承佛神力。即说颂言

  菩萨已得不坏意　　修行一切诸善业
  是故能令佛欢喜　　智者以此而回向
  供养无量无边佛　　布施持戒伏诸根
  为欲利益诸众生　　普使一切皆清净
  一切上妙诸香华　　无量差别胜衣服
  宝盖及以庄严具　　供养一切诸如来
  如是供养于诸佛　　无量无数难思劫
  恭敬尊重常欢喜　　未曾一念生疲厌
  专心想念于诸佛　　一切世间大明灯
  十方所有诸如来　　靡不现前如目睹
  不可思议无量劫　　种种布施心无厌
  百千万亿众劫中　　修诸善法悉如是
  彼诸如来灭度已　　供养舍利无厌足
  悉以种种妙庄严　　建立难思众塔庙
  造立无等最胜形　　宝藏净金为庄严
  巍巍高大如山王　　其数无量百千亿
  净心尊重供养已　　复生欢喜利益意
  不思议劫处世间　　救护众生令解脱
  了知众生皆妄想　　于彼一切无分别
  而能善别众生根　　普为群生作饶益
  菩萨修集诸功德　　广大最胜无与比
  了达体性悉非有　　如是决定皆回向
  以最胜智观诸法　　其中无有一法生
  如是方便修回向　　功德无量不可尽
  以是方便令心净　　悉与一切如来等
  此方便力不可尽　　是故福报无尽极
  发起无上菩提心　　一切世间无所依
  普至十方诸世界　　而于一切无所碍
  一切如来出世间　　为欲启导众生心
  如其心性而观察　　毕竟推求不可得
  一切诸法无有余　　悉入于如无体性
  以是净眼而回向　　开彼世间生死狱
  虽令诸有悉清净　　亦不分别于诸有
  知诸有性无所有　　而令欢喜意清净
  于一佛土无所依　　一切佛土悉如是
  亦不染著有为法　　知彼法性无依处
  以是修成一切智　　以是无上智庄严
  以是诸佛皆欢喜　　是为菩萨回向业
  菩萨专心念诸佛　　无上智慧巧方便
  如佛一切无所依　　愿我修成此功德
  专心救护于一切　　令其远离众恶业
  如是饶益诸群生　　系念思惟未曾舍
  住于智地守护法　　不以余乘取涅槃
  唯愿得佛无上道　　菩萨如是善回向
  不取众生所言说　　一切有为虚妄事
  虽复不依言语道　　亦复不着无言说
  十方所有诸如来　　了达诸法无有余
  虽知一切皆空寂　　而不于空起心念
  以一庄严严一切　　亦不于法生分别
  如是开悟诸群生　　一切无性无所观

佛子。云何为菩萨摩诃萨等一切佛回向。佛子。此菩萨摩诃萨。随顺修学去来现在。诸佛世尊。回向之道。如是修学回向道时。见一切色。乃至触法。若美若恶。不生爱憎。心得自在。无诸过失。广大清净。欢喜悦乐。离诸忧恼。心意柔软。诸根清凉。佛子。菩萨摩诃萨。获得如是安乐之时。复更发心。回向诸佛。作如是念。愿以我今所种善根。令诸佛乐。转更增胜。所谓。不可思议佛所住乐。无有等比佛三昧乐。不可限量大慈悲乐。一切诸佛解脱之乐。无有边际大神通乐。最极尊重大自在乐。广大究竟无量力乐。离诸知觉寂静之乐。住无碍住恒正定乐。行无二行不变异乐。佛子。菩萨摩诃萨。以诸善根。回向佛已。复以此善。回向菩萨。所谓。愿未满者。令得圆满。心未净者。令得清净。诸波罗蜜。未满足者。令得满足。安住金刚菩提之心。于一切智。得不退转。不舍大精进。守护菩提门。一切善根。能令众生。舍离我慢。发菩提心。所愿成满。安住一切菩萨所住。获得菩萨明利诸根。修习善根。证萨婆若。佛子。菩萨摩诃萨。以诸善根。如是回向菩萨已。复以回向一切众生。愿一切众生所有善根。乃至极少。一弹指顷。见佛闻法。恭敬圣僧。彼诸善根。皆离障碍。念佛圆满。念法方便。念僧尊重。不离见佛。心得清净。获诸佛法。集无量德。净诸神通。舍法疑念。依教而住。如为众生。如是回向。为声闻辟支佛回向。亦复如是。又愿一切众生。永离地狱。饿鬼畜生阎罗王等。一切恶处。增长无上菩提之心。专意勤求一切种智。永不毁谤诸佛正法。得佛安乐。身心清净。证一切智。佛子。菩萨摩诃萨。所有善根。皆以大愿。发起正发起。积集正积集增长正增长。悉令广大。具足充满。佛子。菩萨摩诃萨。在家宅中。与妻子俱。未曾暂舍菩提之心。正念思惟萨婆若境。自度度彼。令得究竟。以善方便。化己眷属。令入菩萨智。令成熟解脱。虽与同止。心无所著。以本大悲。处于居家。以慈心故。随顺妻子。于菩萨清净道。无所障碍。菩萨摩诃萨。虽在居家。作诸事业。未曾暂舍一切智心。所谓。若着衣裳。若啖滋味。若服汤药。澡漱涂摩回旋顾视。行住坐卧。身语意业。若睡若寤。如是一切诸有所作。心常回向萨婆若道。系念思惟。无时舍离。为欲饶益一切众生安住菩提。无量大愿。摄取无数广大善根。勤修诸善。普救一切。永离一切憍慢放逸。决定趣于一切智地。终不发意。向于余道。常观一切诸佛菩提。永舍一切诸杂染法。修行一切菩萨所学。于一切智道。无所障碍。住于智地。爱乐诵习。以无量智。集诸善根。心不恋乐一切世间。亦不染着所行之行。专心受持诸佛教法。菩萨如是。处在居家。普摄善根。令其增长。回向诸佛。无上菩提。佛子。菩萨尔时。乃至施与畜生之食。一抟一粒。咸作是愿。当令此等。舍畜生道。利益安乐。究竟解脱。永度苦海。永灭苦受。永除苦蕴。永断苦觉。苦聚苦行。苦因苦本。及诸苦处。愿彼众生。皆得舍离。菩萨如是。专心系念一切众生。以彼善根。而为上首。为其回向一切种智。菩萨初发菩提之心。普摄众生。修诸善根。悉以回向。欲令永离生死旷野。得诸如来。无碍快乐。出烦恼海。修佛法道。慈心遍满。悲力广大。普使一切。得清净乐。守护善根。亲近佛法。出魔境界。入佛境界。断世间种。植如来种。住于三世。平等法中。菩萨摩诃萨。如是所有。已集当集现集善根。悉以回向。复作是念。如过去诸佛菩萨所行。恭敬供养一切诸佛。度诸众生。令永出离。勤加修习一切善根。悉以回向。而无所著。所谓不依色。不着受。无倒想。不作行。不取识。舍离六处。不住世法。乐出世间。知一切法。皆如虚空。无所从来。不生不灭。无有真实。无所染着。远离一切诸分别见。不动不转。不失不坏。住于实际。无相离相。唯是一相。如是深入一切法性。常乐习行普门善根。悉见一切诸佛众会。如彼过去。一切如来。善根回向。我亦如是。而为回向。解如是法。证如是法。依如是法。发心修习。不违法相。知所修行。如幻如影。如水中月。如镜中像。因缘和合之所显现。乃至如来。究竟之地。佛子。菩萨摩诃萨。复作是念。如过去诸佛。修菩萨行时。以诸善根。如是回向。未来现在。悉亦如是。我今亦应如彼诸佛。如是发心。以诸善根。而为回向。第一回向。胜回向。最胜回向。上回向。无上回向。无等回向。无等等回向。无比回向。无对回向。尊回向。妙回向。平等回向。正直回向。大功德回向。广大回向。善回向。清净回向。离恶回向。不随恶回向。菩萨如是。以诸善根。正回向已。成就清净身语意业。住菩萨住。无诸过失。修习善业。离身语恶。心无瑕秽。修一切智。住广大心。知一切法。无有所作。住出世法。世法不染。分别了知无量诸业。成就回向。善巧方便。永拔一切取着根本。佛子。是为菩萨摩诃萨第三等一切佛回向。菩萨摩诃萨。住此回向。深入一切诸如来业。趣向如来胜妙功德。入深清净智慧境界。不离一切诸菩萨业。善能分别巧妙方便。入深法界。善知菩萨修行次第。入佛种性。以巧方便。分别了知无量无边。一切诸法。虽复现身。于世中生。而于世法。心无所著。尔时金刚幢菩萨。承佛神力。普观十方。即说颂言

  彼诸菩萨摩诃萨　　修过去佛回向法
  亦学未来现在世　　一切导师之所行
  于诸境界得安乐　　诸佛如来所称赞
  广大光明清净眼　　悉以回向大聪哲
  菩萨身根种种乐　　眼耳鼻舌亦复然
  如是无量上妙乐　　悉以回向诸最胜
  一切世间众善法　　及诸如来所成就
  于彼悉摄无有余　　尽以随喜益众生
  世间随喜无量种　　今此回向为众生
  人中师子所有乐　　愿使群萌悉圆满
  一切国土诸如来　　凡所知见种种乐
  愿令众生皆悉得　　而为照世大明灯
  菩萨所得胜妙乐　　悉以回向诸群生
  虽为群生故回向　　而于回向无所著
  菩萨修行此回向　　兴起无量大悲心
  如佛所修回向德　　愿我修行悉成满
  如诸最胜所成就　　一切智乘微妙乐
  及我在世之所行　　诸菩萨行无量乐
  示入众趣安隐乐　　恒守诸根寂静乐
  悉以回向诸群生　　普使修成无上智
  非身语意即是业　　亦不离此而别有
  但以方便灭痴冥　　如是修成无上智
  菩萨所修诸行业　　积集无量胜功德
  随顺如来生佛家　　寂然不乱正回向
  十方一切诸世界　　所有众生咸摄受
  悉以善根回向彼　　愿令具足安隐乐
  不为自身求利益　　欲令一切悉安乐
  未曾暂起戏论心　　但观诸法空无我
  十方无量诸最胜　　所见一切真佛子
  悉以善根回向彼　　愿使速成无上觉
  一切世间含识类　　等心摄取无有余
  以我所行诸善业　　令彼众生速成佛
  无量无边诸大愿　　无上导师所演说
  愿诸佛子皆清净　　随其心乐悉成满
  普观十方诸世界　　悉以功德施于彼
  愿令皆具妙庄严　　菩萨如是学回向
  心不称量诸二法　　但恒了达法无二
  诸法若二若不二　　于中毕竟无所著
  十方一切诸世间　　悉是众生想分别
  于想非想无所得　　如是了达于诸想
  彼诸菩萨身净已　　则意清净无瑕秽
  语业已净无诸过　　当知意净无所著
  一心正念过去佛　　亦忆未来诸导师
  及以现在天人尊　　悉学于其所说法
  三世一切诸如来　　智慧明达心无碍
  为欲利益众生故　　回向菩提集众业
  彼第一慧广大慧　　不虚妄慧无倒慧
  平等实慧清净慧　　最胜慧者如是说

佛子。云何为菩萨摩诃萨至一切处回向。佛子。此菩萨摩诃萨。修习一切诸善根时。作是念言。愿此善根功德之力。至一切处。譬如实际。无处不至。至一切物。至一切世间。至一切众生。至一切国土。至一切法。至一切虚空。至一切三世。至一切有为无为。至一切语言音声。愿此善根。亦复如是。遍至一切诸如来所。供养三世。一切诸佛。过去诸佛。所愿悉满。未来诸佛。具足庄严。现在诸佛。及其国土。道场众会。遍满一切虚空法界。愿以信解。大威力故。广大智慧。无障碍故。一切善根。悉回向故。以如诸天诸供养具。而为供养。充满无量无边世界。佛子。菩萨摩诃萨。复作是念。诸佛世尊。普遍一切虚空法界。种种业所起。十方不可说。一切世界种世界。不可说佛国土。佛境界。种种世界。无量世界。无分齐世界。转世界侧世界。仰世界覆世界。如是一切诸世界中。现住于寿。示现种种。神通变化。彼有菩萨。以胜解力。为诸众生。堪受化者。于彼一切。诸世界中。现为如来。出兴于世。以至一切处智。普遍开示如来无量。自在神力。法身遍往。无有差别。平等普入一切法界。如来藏身。不生不灭。善巧方便。普现世间。证法实性。超一切故。得不退转。无碍力故。生于如来。无障碍见。广大威德。种性中故。佛子。菩萨摩诃萨。以其所种。一切善根。愿于如是。诸如来所。以众妙华。及众妙香。鬘盖幢幡。衣服灯烛。及余一切。诸庄严具。以为供养。若佛形像。若佛塔庙。悉亦如是。以此善根。如是回向。所谓。不乱回向。一心回向。自意回向。尊敬回向。不动回向。无住回向。无依回向。无众生心回向。无躁竞心回向。寂静心回向。复作是念。尽法界虚空界。去来现在。一切劫中。诸佛世尊。得一切智。成菩提道。无量名字。各各差别。于种种时。现成正觉。悉皆住寿。尽未来际。一一各以法界庄严。而严其身。道场众会。周遍法界。一切国土。随时出兴。而作佛事。如是一切诸佛如来。我以善根。普皆回向。愿以无数香盖。无数香幢。无数香幡。无数香帐。无数香网。无数香像。无数香光。无数香焰。无数香云。无数香座。无数香经行地。无数香所住处。无数香世界。无数香山。无数香海。无数香河。无数香树。无数香衣服。无数香莲华。无数香宫殿。无量华盖。广说。乃至无量华宫殿。无边鬘盖。广说。乃至无边鬘宫殿。无等涂香盖。广说。乃至无等涂香宫殿。不可数末香盖。广说。乃至不可数。末香宫殿。不可称衣盖。广说。乃至不可称衣宫殿。不可思宝盖。广说。乃至不可思宝宫殿。不可量灯光明盖。广说。乃至不可量灯。光明宫殿。不可说庄严具盖。广说。乃至不可说庄严具宫殿。不可说不可说摩尼宝盖。不可说不可说摩尼宝幢。如是。摩尼宝幡。摩尼宝帐。摩尼宝网。摩尼宝像。摩尼宝光。摩尼宝焰。摩尼宝云。摩尼宝座。摩尼宝经行地。摩尼宝所住处。摩尼宝刹。摩尼宝山。摩尼宝海。摩尼宝河。摩尼宝树。摩尼宝衣服。摩尼宝莲华。摩尼宝宫殿。皆不可说不可说。如是一一。诸境界中。各有无数栏楯。无数宫殿。无数楼阁。无数门闼。无数半月。无数却敌。无数窗牖。无数清净宝。无数庄严具。以如是等。诸供养物。恭敬供养。如上所说。诸佛世尊。愿令一切世间。皆得清净。一切众生。咸得出离。住十力地。于一切法中。得无碍法明。令一切众生具足善根。悉得调伏。其心无量。等虚空界。往一切刹。而无所至。入一切土。施诸善法。常得见佛。植诸善根。成就大乘。不着诸法。具足众善。立无量行。普入无边一切法界。成就诸佛。神通之力。得于如来。一切智智譬如无我。普摄诸法。我诸善根。亦复如是。普摄一切。诸佛如来。咸悉供养。无有余故。普摄一切。无量诸法。悉能悟入无障碍故。普摄一切诸菩萨众。究竟皆与同善根故。普摄一切诸菩萨行。以本愿力皆圆满故。普摄一切菩萨法明。了达诸法。皆无碍故。普摄诸佛。大神通力。成就无量。诸善根故。普摄诸佛。力无所畏。发无量心。满一切故。普摄菩萨。三昧辩才。陀罗尼门。善能照了。无二法故。普摄诸佛。善巧方便。示现如来。大神力故。普摄三世。一切诸佛。降生成道。转正法轮。调伏众生。入般涅槃。恭敬供养。悉周遍故。普摄十方。一切世界。严净佛刹。咸究竟故。普摄一切。诸广大劫。于中出现。修菩萨行。无断绝故。普摄一切。所有趣生。悉于其中。现受生故。普摄一切。诸众生界。具足普贤菩萨行故。普摄一切。诸惑习气。悉以方便。令清净故。普摄一切。众生诸根。无量差别。咸了知故。普摄一切。众生解欲。令离杂染。得清净故。普摄一切。化众生行。随其所应。为现身故。普摄一切。应众生道。悉入一切。众生界故。普摄一切。如来智性。护持一切。诸佛教故。佛子。菩萨摩诃萨。以诸善根。如是回向时。用无所得。而为方便。不于业中分别报。不于报中分别业。虽无分别。而普入法界。虽无所作。而恒住善根。虽无所起。而勤修胜法。不信诸法。而能深入。不有于法。而悉知见。若作不作。皆不可得。知诸法性。恒不自在。虽悉见诸法。而无所见。普知一切。而无所知。菩萨如是。了达境界。知一切法。因缘为本。见于一切诸佛法身。至一切法。离染实际。解了世间。皆如变化。明达众生。唯是一法。无有二性。不舍业境。善巧方便。于有为界。示无为法。而不灭坏有为之相。于无为界。示有为法。而不分别无为之相。菩萨如是。观一切法。毕竟寂灭。成就一切清净善根。而起救护众生之心。智慧明达。一切法海。常乐修行。离愚痴法。已具成就出世功德。不更修学世间之法。得净智眼。离诸痴翳。以善方便。修回向道。佛子。菩萨摩诃萨。以诸善根。如是回向。称可一切诸佛之心。严净一切诸佛国土。教化成熟一切众生。具足受持一切佛法。作一切众生最上福田。为一切商人智慧导师。作一切世间清净日轮。一一善根。充遍法界。悉能救护一切众生。皆令清净具足功德。佛子。菩萨摩诃萨。如是回向时。能护持一切佛种。能成熟一切众生。能严净一切国土。能不坏一切诸业。能了知一切诸法。能等观诸法无二。能遍往十方世界。能了达离欲实际。能成就清净信解。能具足明利诸根。佛子。是为菩萨摩诃萨第四至一切处回向。菩萨摩诃萨。住此回向时。得至一切处身业。普能应现一切世界故。得至一切处语业。于一切世界中。演说法故。得至一切处意业。受持一切佛所说法故。得至一切处神足通。随众生心。悉往应故。得至一切处随证智。普能了达一切法故。得至一切处。总持辩才。随众生心。令欢喜故。得至一切处入法界。于一毛孔中。普入一切世界故。得至一切处遍入身。于一众生身。普入一切。众生身故。得至一切处普见劫。一一劫中。常见一切。诸如来故。得至一切处普见念。一一念中。一切诸佛。悉现前故。佛子。菩萨摩诃萨。得至一切处回向。能以善根。如是回向。尔时金刚幢菩萨。承佛威力。普观十方。而说颂言

  内外一切诸世间　　菩萨悉皆无所著
  不舍饶益众生业　　大士修行如是智
  十方所有诸国土　　一切无依无所住
  不取活命等众法　　亦不妄起诸分别
  普摄十方世界中　　一切众生无有余
  观其体性无所有　　至一切处善回向
  普摄有为无为法　　不于其中起妄念
  如于世间法亦然　　照世灯明如是觉
  菩萨所修诸业行　　上中下品各差别
  悉以善根回向彼　　十方一切诸如来
  菩萨回向到彼岸　　随如来学悉成就
  恒以妙智善思惟　　具足人中最胜法
  清净善根普回向　　利益群迷恒不舍
  悉令一切诸众生　　得成无上照世灯
  未曾分别取众生　　亦不妄想念诸法
  虽于世间无染着　　亦复不舍诸含识
  菩萨常乐寂灭法　　随顺得至涅槃境
  亦不舍离众生道　　获如是等微妙智
  菩萨未曾分别业　　亦不取着诸果报
  一切世间从缘生　　不离因缘见诸法
  深入如是诸境界　　不于其中起分别
  一切众生调御师　　于此明了善回向

大方广佛华严经卷第二十四大方广佛华严经卷第二十五

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之三

佛子。云何为菩萨摩诃萨。无尽功德藏回向。佛子。此菩萨摩诃萨。以忏除一切。诸业重障。所起善根。礼敬三世。一切诸佛。所起善根。劝请一切。诸佛说法。所起善根。闻佛说法。精勤修习。悟不思议。广大境界。所起善根。于去来今。一切诸佛。一切众生。所有善根。皆生随喜。所起善根。去来今世。一切诸佛。善根无尽。诸菩萨众。精勤修习。所得善根。三世诸佛。成等正觉。转正法轮。调伏众生。菩萨悉知。发随喜心。所生善根。三世诸佛。从初发心。修菩萨行。成最正觉。乃至示现入般涅槃。般涅槃已。正法住世。乃至灭尽。于如是等。皆生随喜。所有善根。菩萨如是。念不可说。诸佛境界。及自境界。乃至菩提。无障碍境。如是广大。无量差别。一切善根。凡所积集。凡所信解。凡所随喜。凡所圆满。凡所成就。凡所修行。凡所获得。凡所知觉。凡所摄持。凡所增长。悉以回向。庄严一切。诸佛国土。如过去世。无边际劫。一切世界。一切如来。所行之处。所谓。无量无数。佛世界种。佛智所知。菩萨所识。大心所受。庄严佛刹。清净业行。所流所引。应众生起。如来神力之所示现。诸佛出世。净业所成。普贤菩萨妙行所兴。一切诸佛。于中成道。示现种种自在神力。尽未来际。所有如来。应正等觉。遍法界住。当成佛道。当得一切。清净庄严。功德佛土。尽法界虚空界。无边无际。无断无尽。皆从如来。智慧所生。无量妙宝之所庄严。所谓。一切香庄严。一切华庄严。一切衣庄严。一切功德藏庄严。一切诸佛力庄严。一切佛国土庄严。如来所都。不可思议。同行宿缘。诸清净众。于中止住。未来世中。当成正觉。一切诸佛之所成就。非世所睹。菩萨净眼。乃能照见。此诸菩萨。具大威德。宿植善根。知一切法。如幻如化。普行菩萨。诸清净业。入不思议。自在三昧。善巧方便。能作佛事。放佛光明。普照世间。无有限极。现在一切。诸佛世尊。悉亦如是。庄严世界。无量形相。无量光色。悉是功德之所成就。无量香无量宝。无量树无数庄严。无数宫殿无数音声。随顺宿缘。诸善知识。示现一切。功德庄严。无有穷尽。所谓一切香庄严。一切鬘庄严。一切末香庄严。一切宝庄严。一切幡庄严。一切宝缯彩庄严。一切宝栏楯庄严。阿僧祇金网庄严。阿僧祇河庄严。阿僧祇云雨庄严。阿僧祇音乐。奏微妙音。如是等无量无数。庄严之具。庄严一切。尽法界虚空界。十方无量。种种业起。佛所了知。佛所宣说。一切世界。其中所有。一切佛土。所谓庄严佛土。清净佛土。平等佛土。妙好佛土。威德佛土。广大佛土。安乐佛土。不可坏佛土。无尽佛土。无量佛土。无动佛土。无畏佛土。光明佛土。无违逆佛土。可爱乐佛土。普照明佛土。严好佛土。精丽佛土。妙巧佛土。第一佛土。胜佛土。殊胜佛土。最胜佛土。极胜佛土。上佛土。无上佛土。无等佛土。无比佛土。无譬谕佛土。如是过去未来现在。一切佛土。所有庄严。菩萨摩诃萨。以己善根。发心回向。愿以如是。去来现在。一切诸佛。所有国土。清净庄严。悉以庄严于一世界。如彼一切。诸佛国土。所有庄严。皆悉成就。皆悉清净。皆悉聚集。皆悉显现。皆悉严好。皆悉住持。如一世界。如是尽法界虚空界。一切世界。悉亦如是。三世一切。诸佛国土。种种庄严。皆悉具足。佛子。菩萨摩诃萨。复以善根。如是回向愿我所修。一切佛刹。诸大菩萨。皆悉充满。其诸菩萨。体性真实。智慧通达。善能分别一切世界。及众生界。深入法界。及虚空界。舍离愚痴。成就念佛。念法真实。不可思议。念僧无量。普皆周遍。亦念于舍。法日圆满。智光普照。见无所碍。从无得生。生诸佛法。为众胜上善根之主。发生无上菩提之心。住如来力。趣萨婆若。破诸魔业。净众生界。深入法性。永离颠倒。善根大愿。皆悉不空。如是菩萨。充满其土。生如是处。有如是德。常作佛事。得佛菩提。清净光明。具法界智。现神通力。一身充满。一切法界。得大智慧。入一切智。所行之境。善能分别。无量无边。法界句义。于一切刹。皆无所著。而能普现。一切佛土。心如虚空。无有所依。而能分别一切法界。善能入出不可思议甚深三昧。趣萨婆若。住诸佛刹。得诸佛力。开示演说阿僧祇法。而无所畏。随顺三世诸佛善根。普照一切如来法界。悉能受持一切佛法。知阿僧祇。诸语言法。善能演出不可思议。差别音声。入于无上。佛自在地。普游十方。一切世界。而无障碍。行于无诤无所依法。无所分别。修习增广菩提之心。得善巧智。善知句义。能随次第。开示演说。愿令如是。诸大菩萨。庄严其国。充满分布。随顺安住。熏修极熏修。纯净极纯净。恬然宴寂。于一佛刹。随一方所。皆有如是无数无量。无边无等。不可数不可称不可思不可量。不可说。不可说不可说。诸大菩萨。周遍充满。如一方所。一切方所。亦复如是。如一佛刹。尽虚空遍法界。一切佛刹。悉亦如是。佛子。菩萨摩诃萨。以诸善根。方便回向一切佛刹。方便回向一切菩萨。方便回向一切如来。方便回向一切佛菩提。方便回向一切广大愿。方便回向一切出要道。方便回向净一切众生界。方便回向于一切世界常见诸佛出兴于世。方便回向常见如来寿命无量。方便回向常见诸佛遍周法界。转无障碍不退法轮。佛子。菩萨摩诃萨。以诸善根。如是回向时。普入一切佛国土故。一切佛刹。皆悉清净。普至一切众生界故。一切菩萨。皆悉清净。普愿一切诸佛国土。佛出兴故。一切法界。一切佛土。诸如来身。超然出现。佛子。菩萨摩诃萨。以如是等无比回向。趣萨婆若。其心广大。犹如虚空。无有限量。入不思议。知一切业。及以果报。皆悉寂灭。心常平等。无有边际。普能遍入一切法界。佛子。菩萨摩诃萨。如是回向时。不分别我及以我所。不分别佛及以佛法。不分别刹及以严净。不分别众生及以调伏。不分别业及业果报。不着于思及思所起。不坏因。不坏果。不取事。不取法。不谓生死有分别。不谓涅槃恒寂静。不谓如来证佛境界。无有少法。与法同止。佛子。菩萨摩诃萨。如是回向时。以诸善根。普施众生。决定成熟。平等教化。无相无缘。无称量无虚妄。远离一切分别取着。菩萨摩诃萨。如是回向已。得无尽善根。所谓念三世一切诸佛故。得无尽善根。念一切菩萨故。得无尽善根。净诸佛刹故。得无尽善根。净一切众生界故。得无尽善根。深入法界故。得无尽善根。修无量心。等虚空界故。得无尽善根。深解一切佛境界故。得无尽善根。于菩萨业。勤修习故。得无尽善根。了达三世故。得无尽善根。佛子。菩萨摩诃萨。以一切善根。如是回向时。了一切众生界。无有众生。解一切法。无有寿命。知一切法。无有作者。悟一切法。无补伽罗。了一切法。无有忿诤。观一切法。皆从缘起。无有住处。知一切物。皆无所依。了一切刹。悉无所住。观一切菩萨行。亦无处所。见一切境界。悉无所有。佛子。菩萨摩诃萨。如是回向时。眼终不见不净佛刹。亦复不见异相众生。无有少法为智所入。亦无少智而入于法。解如来身。非如虚空。一切功德。无量妙法。所圆满故。于一切处。令诸众生。积集善根。悉充足故。佛子。此菩萨摩诃萨。于念念中。得不可说不可说十力地。具足一切福德。成就清净善根。为一切众生福田。此菩萨摩诃萨。成就如意摩尼功德藏。随有所须。一切乐具。悉皆得故。随所游方。悉能严净。一切国土。随所行处。令不可说不可说众生。皆悉清净。摄取福德。修治诸行故。佛子。菩萨摩诃萨。如是回向时。修一切菩萨行。福德殊胜。色相无比。威力光明。超诸世间。魔及魔民。莫能瞻对。善根具足。大愿成就。其心弥广。等一切智。于一念中。悉能周遍。无量佛刹。智力无量。了达一切诸佛境界。于一切佛。得深信解。住无边智。菩提心力。广大如法界。究竟如虚空。佛子。是名菩萨摩诃萨第五无尽功德藏回向。菩萨摩诃萨。住此回向。得十种无尽藏。何等为十。所谓得见佛无尽藏。于一毛孔。见阿僧祇诸佛。出兴世故。得入法无尽藏。以佛智力。观一切法。悉入一法故。得忆持无尽藏。受持一切佛所说法。无忘失故。得决定慧无尽藏。善知一切佛所说法。秘密方便故。得解义趣无尽藏。善知诸法。理趣分齐故。得无边悟解无尽藏。以如虚空智。通达三世一切法故。得福德无尽藏。充满一切诸众生意。不可尽故。得勇猛智觉无尽藏。悉能除灭一切众生愚痴翳故。得决定辩才无尽藏。演说一切佛平等法。令诸众生。悉解了故。得十力无畏无尽藏。具足一切菩萨所行。以离垢缯。而系其顶。至无障碍一切智故。是为十。佛子。菩萨摩诃萨。以一切善根回向时。得此十种无尽藏。尔时金刚幢菩萨。普观十方。而说颂言

  菩萨成就深心力　　普于诸法得自在
  以其劝请随喜福　　无碍方便善回向
  三世所有诸如来　　严净佛刹遍世间
  所有功德靡不具　　回向净刹亦如是
  三世所有诸佛法　　菩萨皆悉谛思惟
  以心摄取无有余　　如是庄严诸佛刹
  尽于三世所有劫　　赞一佛刹诸功德
  三世诸劫犹可尽　　佛刹功德无穷尽
  如是一切诸佛刹　　菩萨悉见无有余
  总以庄严一佛土　　一切佛土悉如是
  有诸佛子心清净　　悉从如来法化生
  一切功德庄严心　　一切佛刹皆充满
  彼诸菩萨悉具足　　无量相好庄严身
  辩才演说遍世间　　譬如大海无穷尽
  菩萨安住诸三昧　　一切所行皆具足
  其心清净无与等　　光明普照十方界
  如是无余诸佛刹　　此诸菩萨皆充满
  未曾忆念声闻乘　　亦复不求缘觉道
  菩萨如是心清净　　善根回向诸群生
  普欲令其成正道　　具足了知诸佛法
  十方所有众魔怨　　菩萨威力悉摧破
  勇猛智慧无能胜　　决定修行究竟法
  菩萨以此大愿力　　所有回向无留碍
  入于无尽功德藏　　去来现在常无尽
  菩萨善观诸行法　　了达其性不自在
  既知诸法性如是　　不妄取业及果报
  无有色法无色法　　亦无有想无无想
  有法无法皆悉无　　了知一切无所得
  一切诸法因缘生　　体性非有亦非无
  而于因缘及所起　　毕竟于中无取着
  一切众生语言处　　于中毕竟无所得
  了知名相皆分别　　明解诸法悉无我
  如众生性本寂灭　　如是了知一切法
  三世所摄无有余　　刹及诸业皆平等
  以如是智而回向　　随其悟解福业生
  此诸福相亦如解　　岂复于中有可得
  如是回向心无垢　　永不称量诸法性
  了达其性皆非性　　不住世间亦不出
  一切所行众善业　　悉以回向诸群生
  莫不了达其真性　　所有分别皆除遣
  所有一切虚妄见　　悉皆弃舍无有余
  离诸热恼恒清凉　　住于解脱无碍地
  菩萨不坏一切法　　亦不灭坏诸法性
  解了诸法犹如响　　悉于一切无所著
  了知三世诸众生　　悉从因缘和合起
  亦知心乐及习气　　未曾灭坏一切法
  了达业性非是业　　而亦不违诸法相
  又亦不坏业果报　　说诸法性从缘起
  了知众生无有生　　亦无众生可流转
  无实众生而可说　　但依世俗假宣示

佛子。云何为菩萨摩诃萨随顺坚固一切善根回向。佛子。此菩萨摩诃萨。或为帝王。临御大国。威德广被。名震天下。凡诸怨敌。靡不归顺。发号施令。悉依正法。执持一盖。溥荫万方。周行率土。所向无碍。以离垢缯。而系其顶。于法自在。见者咸伏。不刑不罚。感德从化。以四摄法。摄诸众生。为转轮王。一切周给。菩萨摩诃萨。安住如是自在功德。有大眷属。不可沮坏。离众过失。见者无厌。福德庄严。相好圆满。形体肢分。均调具足。获那罗延坚固之身。大力成就。无能屈伏。得清净业。离诸业障。具足修行一切布施。或施饮食。及诸上味。或施车乘。或施衣服。或施华鬘。杂香涂香。床座房舍。及所住处。上妙灯烛。病缘汤药。宝器宝车。调良象马。悉皆严饰。欢喜布施。或有来乞王所处座。若盖若伞。幢幡宝物。诸庄严具。顶上宝冠。髻中明珠。乃至王位。皆无所吝。若见众生。在牢狱中。舍诸财宝。妻子眷属。乃至以身。救彼令脱。若见狱囚。将欲被戮。即舍其身。以代彼命。或见来乞连肤顶发。欢喜施与。亦无所吝。眼耳鼻舌。及以牙齿。头顶手足。血肉骨髓。心肾肝肺。大肠小肠。厚皮薄皮。手足诸指。连肉爪甲。以欢喜心。尽皆施与。或为求请未曾有法。投身而下深大火坑。或为护持如来正法。以身忍受一切苦毒。或为求法。乃至一字。悉能遍舍四海之内。一切所有。恒以正法。化导群生。令修善行。舍离诸恶。若见众生。损败他形。慈心救之。令舍罪业。若见如来。成最正觉。称扬赞叹。普使闻知。或施于地。造立僧坊。房舍殿堂。以为住处。及施僮仆。供承作役。或以自身。施来乞者。或施于佛。为求法故。欢喜踊跃。为众生故。承事供养。或舍王位。城邑聚落。宫殿园林。妻子眷属。随所乞求。悉满其愿。或舍一切资生之物。普设无遮大施之会。其中众生。种种福田。或从远来。或从近来。或贤或愚。或好或丑。若男若女。人与非人。心行不同。所求各异。等皆施与。悉令满足。佛子。菩萨摩诃萨。如是施时。发善摄心。悉以回向。所谓善摄色。随顺坚固。一切善根。善摄受想行识。随顺坚固。一切善根。善摄王位。随顺坚固。一切善根。善摄眷属。随顺坚固。一切善根。善摄资具。随顺坚固。一切善根。善摄惠施。随顺坚固。一切善根。佛子。菩萨摩诃萨。随所施物。无量无边。以彼善根。如是回向。所谓以上妙食。施众生时。其心清净。于所施物。无贪无著。无所顾吝。具足行施。愿一切众生。得智慧食。心无障碍。了知食性。无所贪着。但乐法喜。出离之食。智慧充满。以法坚住。摄取善根。法身智身。清净游行。哀愍众生。为作福田。现受抟食。是为菩萨摩诃萨布施食时善根回向。佛子。菩萨摩诃萨。若施饮时。以此善根。如是回向。所谓。愿一切众生。饮法味水。精勤修习。具菩萨道。断世渴爱。常求佛智。离欲境界。得法喜乐。从清净法。而生其身。常以三昧。调摄其心。入智慧海。兴大法云。霔大法雨。是为菩萨摩诃萨布施饮时善根回向。佛子。菩萨摩诃萨。布施种种。清净上味。所谓辛酸咸淡。及以甘苦。种种诸味。润泽具足。能令四大。安隐调和。肌体盈满。气力强壮。其心清净。常得欢喜。咽咀之时。不欬不逆。诸根明利。内藏充实。毒不能侵。病不能伤。始终无患。永得安乐。以此善根。如是回向。所谓愿一切众生。得最上味。甘露充满。愿一切众生。得法智味。了知一切诸味业用。愿一切众生。得无量法味。了达法界。安住实际。大法城中。愿一切众生。作大法云。周遍法界。普雨法雨。教化调伏一切众生。愿一切众生。得胜智味。无上法喜。充满身心。愿一切众生。得无贪着。一切上味。不染世间。一切诸味。常勤修习一切佛法。愿一切众生。得一法味。了诸佛法。悉无差别。愿一切众生。得最胜味。乘一切智。终无退转。愿一切众生。得入诸佛无异法味。悉能分别一切诸根。愿一切众生。法味增益。常得满足。无碍佛法。是为菩萨摩诃萨布施味时善根回向。为令一切众生。勤修福德。皆悉具足。无碍智身故。佛子。菩萨摩诃萨。施车乘时。以诸善根。如是回向。所谓愿一切众生。皆得具足一切智乘。乘于大乘。不可坏乘。最胜乘。最上乘。速疾乘。大力乘。福德具足乘。出世间乘。出生无量诸菩萨乘。是为菩萨摩诃萨施车乘时善根回向。佛子。菩萨摩诃萨。布施衣时。以诸善根。如是回向。所谓愿一切众生。得惭愧衣。以覆其身。舍离邪道。露形恶法。颜色润泽。皮肤细软。成就诸佛。第一之乐。得最清净。一切种智。是为菩萨摩诃萨布施衣时善根回向。佛子。菩萨摩诃萨。常以种种。名华布施。所谓微妙香华。种种色华。无量奇妙华。善见华。可喜乐华。一切时华。天华人华。世所珍爱华。甚芬馥悦意华。以如是等无量妙华。供养一切现在诸佛。及佛灭后。所有塔庙。或以供养说法之人。或以供养比丘僧宝。一切菩萨。诸善知识。声闻独觉。父母宗亲。下至自身。及余一切贫穷孤露。布施之时。以诸善根。如是回向。所谓愿一切众生。皆得诸佛三昧之华。悉能开敷一切诸法。愿一切众生。皆得如佛。见者欢喜。心无厌足。愿一切众生。所见顺惬。心无动乱。愿一切众生。具行广大清净之业。愿一切众生。常念善友。心无变异。愿一切众生。如阿伽陀药。能除一切烦恼众毒。愿一切众生。成满大愿。皆悉得为无上智王。愿一切众生。智慧日光。破愚痴暗。愿一切众生。菩提净月。增长满足。愿一切众生。入大宝洲。见善知识。具足成就一切善根。是为菩萨摩诃萨布施华时善根回向。为令众生。皆得清净。无碍智故。佛子。菩萨摩诃萨。布施鬘时。以诸善根。如是回向。所谓愿一切众生。人所乐见。见者钦叹。见者亲善。见者爱乐。见者渴仰。见者除忧。见者生喜。见者离恶。见者常得亲近于佛。见者清净。获一切智。是为菩萨摩诃萨布施鬘时善根回向。佛子。菩萨摩诃萨。布施香时。以诸善根。如是回向。愿一切众生。具足戒香。得不缺戒。不杂戒。不污戒。无悔戒。离缠戒。无热戒。无犯戒。无边戒。出世戒。菩萨波罗蜜戒。愿一切众生。以是戒故。皆得成就诸佛戒身。是为菩萨摩诃萨布施香时善根回向。为令众生。悉得圆满无碍戒蕴故。佛子。菩萨摩诃萨。施涂香时。以诸善根。如是回向。所谓。愿一切众生。施香普熏。悉能惠舍一切所有。愿一切众生。戒香普熏。得于如来究竟净戒。愿一切众生。忍香普熏。离于一切险害之心。愿一切众生。精进香普熏。常服大乘。精进甲胄。愿一切众生。定香普熏。安住诸佛。现前三昧。愿一切众生。慧香普熏。一念得成无上智王。愿一切众生。法香普熏。于无上法。得无所畏。愿一切众生。德香普熏。成就一切大功德智。愿一切众生。菩提香普熏。得佛十力。到于彼岸。愿一切众生。清净白法。妙香普熏。永灭一切不善之法。是为菩萨摩诃萨施涂香时善根回向。佛子。菩萨摩诃萨。施床座时。以诸善根。如是回向。所谓愿一切众生。得诸天床座。证大智慧。愿一切众生。得贤圣床座。舍凡夫意。住菩提心。愿一切众生。得安乐床座。永离一切生死苦恼。愿一切众生。得究竟床座。得见诸佛。自在神通。愿一切众生。得平等床座。恒普熏修一切善法。愿一切众生。得最胜床座。具清净业。世无与等。愿一切众生。得安隐床座。证真实法。具足究竟。愿一切众生。得清净床座。修习如来。净智境界。愿一切众生。得安住床座。得善知识。常随覆护。愿一切众生。得师子床座。常如如来。右胁而卧。是为菩萨摩诃萨施床座时善根回向。为令众生。修习正念。善护诸根故。佛子。菩萨摩诃萨。施房舍时。以诸善根。如是回向。所谓愿一切众生。皆得安住。清净佛刹。精勤修习一切功德。安住甚深。三昧境界。舍离一切住处执着。了诸住处。皆无所有。离诸世间。住一切智。摄取一切诸佛所住。住究竟道。安乐住处。恒住第一清净善根。终不舍离佛无上住是为菩萨摩诃萨施房舍时善根回向。为欲利益一切众生。随其所应。思惟救护故。佛子。菩萨摩诃萨。施住处时。以诸善根。如是回向。所谓愿一切众生。常获善利其心安乐。愿一切众生。依如来住。依大智住。依善智识住。依尊胜住。依善行住。依大慈住。依大悲住。依六波罗蜜住。依大菩提心住。依一切菩萨道住。是为菩萨摩诃萨施住处时善根回向。为令一切。福德清净故。究竟清净故。智清净故。道清净故。法清净故。戒清净故。志乐清净故。信解清净故。愿清净故。一切神通功德清净故。佛子。菩萨摩诃萨。施诸灯明。所谓酥灯油灯。宝灯摩尼灯。漆灯火灯。沉水灯栴檀灯。一切香灯。无量色光灯。施如是等无量灯时。为欲利益一切众生。为欲摄受一切众生。以此善根。如是回向。所谓愿一切众生。得无量光。普照一切诸佛正法。愿一切众生。得清净光。照见世间。极微细色。愿一切众生。得离翳光。了众生界。空无所有。愿一切众生。得无边光。身出妙光。普照一切。愿一切众生。得普照光。于诸佛法。心无退转。愿一切众生。得佛净光。一切刹中。悉皆显现。愿一切众生。得无碍光。一光遍照。一切法界。愿一切众生。得无断光。照诸佛刹。光明不断。愿一切众生。得智幢光。普照世间。愿一切众生。得无量色光。照一切刹。示现神力。菩萨如是。施灯明时。为欲利益一切众生。安乐一切众生故。以此善根。随逐众生。以此善根。摄受众生。以此善根。分布众生。以此善根。慈愍众生。以此善根。覆育众生。以此善根。救护众生。以此善根。充满众生。以此善根。缘念众生。以此善根。等益众生。以此善根。观察众生。是为菩萨摩诃萨施灯明时善根回向。如是回向。无有障碍。普令众生。住善根中。佛子。菩萨摩诃萨。施汤药时。以诸善根。如是回向。所谓愿一切众生。于诸盖缠究竟得出。愿一切众生。永离病身。得如来身。愿一切众生。作大良药。灭除一切不善之病。愿一切众生。成阿伽陀药。安住菩萨不退转地。愿一切众生。成如来药。能拔一切烦恼毒箭。愿一切众生。亲近贤圣。灭诸烦恼。修清净行。愿一切众生。作大药王。永除众病。不令重发。愿一切众生。作不坏药树。悉能救疗一切众生。愿一切众生。得一切智光。出众病箭。愿一切众生。善解世间。方药之法。所有疾病。为其救疗。菩萨摩诃萨。施汤药时。为令一切众生。永离众病故。究竟安隐故。究竟清净故。如佛无病故。拔除一切病箭故。得无尽坚固身故。得金刚围山所不坏身故。得坚固满足力故。得圆满不可夺佛乐故。得一切佛。自在坚固身故。以诸善根。如是回向。佛子。菩萨摩诃萨。悉能惠施一切器物。所谓黄金器。盛满杂宝。白银器。盛众妙宝。琉璃器。盛种种宝。玻璃器。盛满无量宝庄严具。砗磲器。盛赤真珠。码瑙器。盛满珊瑚摩尼珠宝。白玉器。盛众美食。栴檀器。盛天衣服。金刚器。盛众妙香。无量无数。种种宝器。盛无量无数。种种众宝。或施诸佛。信佛福田。不思议故。或施菩萨。知善知识。难值遇故。或施圣僧。为令佛法。久住世故。或施声闻。及辟支佛。于诸圣人。生净信故。或施父母。为尊重故。或施师长。为恒诱诲。令依圣教。修功德故。或施下劣。贫穷孤露。大慈大悲。爱眼等视诸众生故。专意满足。去来今世。一切菩萨。檀波罗蜜故。以一切物。普施一切。终不厌舍。诸众生故。如是施时。于其施物。及以受者。皆无所著。菩萨摩诃萨。以如是等种种宝器。盛无量宝。而布施时。以诸善根。如是回向。所谓愿一切众生。成等虚空无边藏器。念力广大。悉能受持世出世间。一切经书。无有忘失。愿一切众生。成清净器。能悟诸佛甚深正法。愿一切众生。成无上宝器。悉能受持三世佛法。愿一切众生。成就如来。广大法器。以不坏信。摄受三世佛菩提法。愿一切众生。成就最胜。宝庄严器。住大威德。菩提之心。愿一切众生。成就功德。所依处器。于诸如来。无量智慧。生净信解。愿一切众生。成就趣入一切智器。究竟如来无碍解脱。愿一切众生。得尽未来劫。菩萨行器。能令众生。普皆安住。一切智力。愿一切众生。成就三世。诸佛种性。胜功德器。一切诸佛。妙音所说。悉能受持。愿一切众生。成就容纳。尽法界虚空界。一切世界。一切如来。众会道场器。为大丈夫。赞说之首。劝请诸佛。转正法轮。是为菩萨摩诃萨布施器时善根回向。为欲普令一切众生。皆得圆满。普贤菩萨。行愿器故

大方广佛华严经卷第二十五大方广佛华严经卷第二十六

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之四

佛子。菩萨摩诃萨。以种种车。众宝严饰。奉施诸佛。及诸菩萨。师长善友。声闻缘觉。如是无量种种福田。乃至贫穷。孤露之者。此诸人众。或从远来。或从近来。或承菩萨名闻故来。或是菩萨因缘故来。或闻菩萨。往昔所发。施愿故来。或是菩萨。心愿请来。菩萨是时。或施宝车。或施金车。悉妙庄严。铃网覆上。宝带垂下。或施上妙。琉璃之车。无量珍奇。以为严饰。或复施与白银之车。覆以金网。驾以骏马。或复施与无量杂宝。所庄严车。覆以宝网。驾以香象。或复施与栴檀之车。妙宝为轮。杂宝为盖。宝师子座。敷置严好。百千采女。列坐其上。十万丈夫。牵御而行。或复施与玻璃宝车。众杂妙宝。以为严饰。端正女人。充满其中。宝帐覆上。幢幡侍侧。或复施与码瑙藏车。饰以众宝。熏诸杂香。种种妙华。散布庄严。百千采女。持宝璎珞。驾驭均调。涉险能安。或复施与坚固香车。众宝为轮。庄严巨丽。宝帐覆上。宝网垂下。种种宝衣。敷布其中。清净好香。流芬外彻。其香美妙。称悦人心。无量诸天。翼从而行。载以众宝。随时给施。或复施与光明宝车。种种诸宝。妙色映彻。众妙宝网。罗覆其上。杂宝璎珞。周匝垂下。散以末香。内外芬洁。所爱男女。悉载其上。佛子。菩萨摩诃萨。以如是等众妙宝车。奉施佛时。以此善根。如是回向。所谓愿一切众生。悉解供养。最上福田。深信施佛。得无量报。愿一切众生。一心向佛。常遇无量。清净福田。愿一切众生。于诸如来。无所吝惜。具足成就大舍之心。愿一切众生。于诸佛所。修行施行。离二乘愿。逮得如来无碍解脱一切智智。愿一切众生。于诸佛所。行无尽施。入佛无量功德智慧。愿一切众生。入佛胜智。得成清净无上智王。愿一切众生。得佛遍至无碍神通。随所欲往。靡不自在。愿一切众生。深入大乘。获无量智。安住不动。愿一切众生。皆能出生一切智法。为诸天人。最上福田。愿一切众生。于诸佛所。无嫌恨心。勤种善根。乐求佛智。愿一切众生。任运能往一切佛刹。一刹那中。普周法界。而无懈倦。愿一切众生。逮得菩萨。自在神通。分身遍满等虚空界。一切佛所。亲近供养。愿一切众生。得无比身。遍往十方。而无厌倦。愿一切众生。得广大身。飞行迅疾。随意所往。终无懈退。愿一切众生。得佛究竟。自在威力。一刹那中。尽虚空界。悉现诸佛神通变化。愿一切众生。修安乐行。随顺一切。诸菩萨道。愿一切众生。得速疾行。究竟十力。智慧神通。愿一切众生。普入法界。十方国土。悉尽边际。等无差别。愿一切众生。行普贤行。无有退转。到于彼岸。成一切智。愿一切众生。升于无比。智慧之乘。随顺法性。见如实理。是为菩萨摩诃萨以众宝车奉施现在一切诸佛及佛灭后所有塔庙善根回向。为令众生。得于如来。究竟出离。无碍乘故。佛子。菩萨摩诃萨。以众宝车。施菩萨等善知识时。以诸善根。如是回向。所谓愿一切众生。心常忆持善知识教。专勤守护。令不忘失。愿一切众生。与善知识。同一义利。普摄一切。与共善根。愿一切众生。近善知识。尊重供养。悉舍所有。顺可其心。愿一切众生。得善志欲。随逐善友。未尝舍离。愿一切众生。常得值遇诸善知识。专意承奉。不违其教。愿一切众生。乐善知识。常不舍离。无间无杂。亦无误失。愿一切众生。能以其身。施善知识。随其教命。靡有违逆。愿一切众生。为善知识之所摄受。修习大慈。远离诸恶。愿一切众生。随善知识。听闻诸佛所说正法。愿一切众生。与善知识。同一善根。清净业果。与诸菩萨。同一行愿。究竟十力。愿一切众生。悉能受持善知识法。逮得一切三昧境界。智慧神通。愿一切众生。悉能受持一切正法。修习诸行。到于彼岸。愿一切众生。乘于大乘。无所障碍。究竟成就一切智道。愿一切众生。悉得上于一切智乘。至安隐处。无有退转。愿一切众生。知如实行。随其所闻一切佛法。皆得究竟。永无忘失。愿一切众生。普为诸佛之所摄受。得无碍智。究竟诸法。愿一切众生。得无退失。自在神通。所欲往诣。一念皆到。愿一切众生。往来自在。广行化导。令住大乘。愿一切众生。所行不空。载以智乘。到究竟位。愿一切众生。得无碍乘。以无碍智。至一切处。是为菩萨摩诃萨施善知识种种车时善根回向。为令众生。功德具足。与佛菩萨。等无异故。佛子。菩萨摩诃萨。以众宝车。布施僧时。起学一切施心。智善了心。净功德心。随顺舍心。僧宝难遇心。深信僧宝心。摄持正教心。住胜志乐。得未曾有。为大施会。出生无量广大功德。深信佛教。不可沮坏。以诸善根。如是回向。所谓愿一切众生。普入佛法。忆持不忘。愿一切众生。离凡愚法。入贤圣处。愿一切众生。速入圣位。能以佛法。次第开诱。愿一切众生。举世宗重。言必信用。愿一切众生。善入一切诸法平等。了知法界。自性无二。愿一切众生。从于如来智境而生。诸调顺人。所共围绕。愿一切众生。住离染法。灭除一切烦恼尘垢。愿一切众生。皆得成就无上僧宝。离凡夫地。入贤圣众。愿一切众生。勤修善法。得无碍智。具圣功德。愿一切众生。得智慧心。不着三世。于诸众中。自在如王。愿一切众生。乘智慧乘。转正法轮。愿一切众生。具足神通。一念能往不可说不可说世界。愿一切众生。乘虚空身。于诸世间。智慧无碍。愿一切众生。普入一切。虚空法界。诸佛众会。成就第一波罗蜜行。愿一切众生。得轻举身。殊胜智慧。悉能遍入一切佛刹。愿一切众生。获无边际。善巧神足。于一切刹。普现其身。愿一切众生。得于一切无所依身。以神通力。如影普现。愿一切众生。得不思议。自在神力。随应可化。即现其前。教化调伏。愿一切众生。得入法界。无碍方便。一念遍游十方国土。是为菩萨摩诃萨施僧宝车善根回向。为令众生。普乘清净。无上智乘。于一切世间。转无碍法。智慧轮故。佛子。菩萨摩诃萨。以众宝车。布施声闻。独觉之时。起如是心。所谓福田心。尊敬心。功德海心。能出生功德智慧心。从如来功德势力所生心。百千亿那由他劫修习心。能于不可说劫修菩萨行心。解脱一切魔系缚心。摧灭一切魔军众心。慧光照了无上法心。以此施车。所有善根。如是回向。所谓。愿一切众生。为世所信。第一福田。具足无上。檀波罗蜜。愿一切众生。离无益语。常乐独处。心无二念。愿一切众生。成最第一。清净福田摄诸众生。令修福业。愿一切众生。成智慧渊。能与众生。无量无数。善根果报。愿一切众生。住无碍行。满足清净。第一福田。愿一切众生。住无诤法。了一切法。皆无所作。无性为性。愿一切众生。常得亲近。最上福田。具足修成。无量福德。愿一切众生。能现无量。自在神通。以净福田。摄诸含识。愿一切众生。具足无尽。功德福田。能与众生。如来十力。第一乘果。愿一切众生。为能辨果。真实福田。成一切智。无尽福聚。愿一切众生。得灭罪法。悉能受持所未曾闻。佛法句义。愿一切众生。常勤听受一切佛法。闻悉解悟。无空过者。愿一切众生。听闻佛法。通达究竟如其所闻。随顺演说。愿一切众生。于如来教。信解修行。舍离一切九十六种外道邪见。愿一切众生。常见贤圣。增长一切最胜善根。愿一切众生。心常信乐。智行之士。与诸圣哲。同止共欢。愿一切众生。听闻佛名。悉不唐捐。随其所闻。咸得目见。愿一切众生。善分别知。诸佛正教。悉能守护持佛法者。愿一切众生。常乐听闻一切佛法。受持读诵。开示照了。愿一切众生。信解佛教。如实功德。悉舍所有。恭敬供养。是为菩萨摩诃萨施声闻独觉种种车时善根回向。为令众生皆得成就清净第一。智慧神通。精进修行。无有懈怠。获一切智。力无畏故。佛子。菩萨摩诃萨。以众宝车。施诸福田。乃至贫穷。孤独者时。随其所求。一切悉舍。心生欢喜。无有厌倦。仍向彼人。自悔责言。我应往就供养供给。不应劳汝。远来疲顿。言已拜跪。问讯起居。凡有所须。一切施与。或时施彼摩尼宝车。以阎浮提。第一女宝充满其上。或复施与金庄严车。人间女宝。充满其上。或复施与妙琉璃车。内宫妓女。充满其上。或施种种。奇妙宝车。童女充满。如天采女。或施无数。宝庄严车。宝女满中。柔明辩慧。或施所乘。妙栴檀车。或复施与玻璃宝车。悉载宝女。充满其上。颜容端正。色相无比。袨服庄严。见者欣悦。或复施与码瑙宝车。灌顶王子。身载其上。或时施与坚固香车。所有男女。悉载其中。或施一切宝庄严车。载以难舍亲善眷属。佛子。菩萨摩诃萨。以如是等无量宝车。随其所求。恭敬施与。皆令遂愿。欢喜满足。以此善根。如是回向。所谓愿一切众生。乘不退转。无障碍轮。广大之乘。诣不可议。菩提树下。愿一切众生。乘清净因。大法智乘。尽未来劫。修菩萨行。永不退转。愿一切众生。乘一切法。无所有乘。永离一切。分别执着。而常修习一切智道。愿一切众生。乘无谄诳。正直之乘。往诸佛刹。自在无碍。愿一切众生。随顺安住一切智乘。以诸佛法。共相娱乐。愿一切众生。皆乘菩萨。清净行乘。具足菩萨。十出离道。及三昧乐。愿一切众生。乘四轮乘。所谓住好国土。依止善人。集胜福德。发大誓愿。以此成满一切菩萨。清净梵行。愿一切众生。得普照十方。法光明乘。修学一切如来智力。愿一切众生。乘佛法乘。到一切法。究竟彼岸。愿一切众生。载众福善。难思法乘。普示十方。安隐正道。愿一切众生。乘大施乘。舍悭吝垢。愿一切众生。乘净戒乘。持等法界。无边净戒。愿一切众生。乘忍辱乘。常于众生。离嗔浊心。愿一切众生。乘大精进不退转乘。坚修胜行。趣菩提道。愿一切众生。乘禅定乘。速至道场。证菩提智。愿一切众生。乘于智慧。巧方便乘。化身充满。一切法界。诸佛境界。愿一切众生。乘法王乘。成就无畏。恒普惠施。一切智法。愿一切众生。乘无所著。智慧之乘。悉能遍入一切十方。于真法性。而无所动。愿一切众生。乘于一切诸佛法乘。示现受生。遍十方刹。而不失坏大乘之道。愿一切众生。乘一切智最上宝乘。满足普贤菩萨行愿。而无厌倦。是为菩萨摩诃萨以众宝车施诸福田乃至贫穷孤露之人善根回向。为令众生。具无量智。欢喜踊跃。究竟皆得一切智乘故。佛子。菩萨摩诃萨。布施象宝。其性调顺。七支具足。年齿盛壮。六牙清净。口色红赤。犹如莲华。形体鲜白。譬如雪山。金幢为饰。宝网罗覆。种种妙宝。庄严其鼻。见者欣玩。无有厌足。超步万里。曾不疲倦。或复施与调良马宝。诸相具足。犹如天马。妙宝月轮。以为光饰。真金铃网。罗覆其上。行步平正。乘者安隐。随意所往。迅疾如风。游历四洲。自在无碍。菩萨以此象宝马宝。或奉养父母。及善知识。或给施贫乏。苦恼众生。其心旷然。不生悔吝。但倍增欣庆。益加悲愍。修菩萨德。净菩萨心。以此善根。如是回向。所谓愿一切众生。住调顺乘。增长一切菩萨功德。愿一切众生。得善巧乘。能随出生一切佛法。愿一切众生。得信解乘。普照如来无碍智力。愿一切众生。得发趣乘。能普发兴一切大愿。愿一切众生。具足平等。波罗蜜乘。成满一切。平等善根。愿一切众生。成就宝乘。生诸佛法。无上智宝。愿一切众生。成就菩萨行庄严乘。开敷菩萨。诸三昧华。愿一切众生。得无边速疾乘。于无数劫。净菩萨心。精勤思惟。了达诸法。愿一切众生。成就最胜。调顺大乘。以善方便。具菩萨地。愿一切众生。成最高广。坚固大乘。普能运载一切众生。皆得至于一切智位。是为菩萨摩诃萨施象马时善根回向。为令众生。皆得乘于无碍智乘。圆满究竟。至佛乘故

佛子。菩萨摩诃萨。布施座时。或施所处。师子之座。其座高广殊特妙好。琉璃为足。金缕所成。柔软衣服。以敷其上。建以宝幢。熏诸妙香。无量杂宝。庄严之具。以为庄校。金网覆上。宝铎风摇。出妙音声。奇珍万计。周匝填饰。一切臣民。所共瞻仰。灌顶大王。独居其上。宣布法化。万邦遵奉。其王复以妙宝严身。所谓普光明宝。帝青宝。大帝青宝。胜藏摩尼宝。明净如日。清凉犹月。周匝繁布。譬如众星。上妙庄严。第一无比。海殊妙宝。海坚固幢宝。奇文异表。种种庄严。于大众中。最尊最胜。阎浮檀金。离垢宝缯。以冠其首。享灌顶位。王阎浮提。具足无量大威德力。以慈为主。伏诸怨敌。教令所行。靡不承顺。时转轮王。以如是等百千万亿。无量无数。宝庄严座。施于如来。第一福田。及诸菩萨。真善知识。贤圣僧宝。说法之师。父母宗亲。声闻独觉。及以发趣菩萨乘者。或如来塔。乃至一切。贫穷孤露。随其所须悉皆施与。以此善根。如是回向。所谓愿一切众生。坐菩提座。悉能觉悟诸佛正法。愿一切众生。处自在座。得法自在。诸金刚山。所不能坏。能悉摧伏一切魔军。愿一切众生。得佛自在。师子之座。一切众生之所瞻仰。愿一切众生。得不可说不可说种种殊妙。宝庄严座。于法自在。化导众生。愿一切众生。得三种世间。最殊胜座。广大善根之所严饰。愿一切众生。得周遍不可说不可说世界座。阿僧祇劫叹之无尽。愿一切众生。得大深密。福德之座。其身充满。一切法界。愿一切众生。得不思议。种种宝座。随其本愿所念众生。广开法施。愿一切众生。得善妙座。现不可说。诸佛神通。愿一切众生。得一切宝座。一切香座。一切华座。一切衣座。一切鬘座。一切摩尼座。一切琉璃等。不思议种种宝座。无量不可说世界座。一切世间。庄严清净座。一切金刚座。示现如来。威德自在。成最正觉。是为菩萨摩诃萨。施宝座时。善根回向。为令众生获离世间。大菩提座。自然觉悟一切佛法故。佛子。菩萨摩诃萨。施诸宝盖。此盖殊特。尊贵所用。种种大宝。而为庄严。百千亿那由他。上妙盖中。最为第一。众宝为竿。妙网覆上。宝绳金铃。周匝垂下。摩尼璎珞。次第悬布。微风吹动。妙音克谐。珠玉宝藏。种种充满。无量奇珍。悉以严饰。栴檀沉水。妙香普熏。阎浮檀金。光明清净。如是无量百千亿那由他阿僧祇。众妙宝物。具足庄严。以清净心。奉施于佛。及佛灭后。所有塔庙。或为法故。施诸菩萨。及善知识。名闻法师。或施父母。或施僧宝。或复奉施一切佛法。或施种种。众生福田。或施师僧。及诸尊宿。或施初发菩提之心。乃至一切。贫穷孤露。随有求者。悉皆施与。以此善根。如是回向。所谓愿一切众生。勤修善根。以覆其身。常为诸佛之所庇荫。愿一切众生功德智慧以为其盖。永离世间一切烦恼。愿一切众生覆以善法除灭世间尘垢热恼。愿一切众生。得智慧藏。令众乐见。心无厌足。愿一切众生。以寂静白法。而自覆荫。皆得究竟。不坏佛法。愿一切众生。善覆其身。究竟如来。清净法身。愿一切众生。作周遍盖。十力智慧。遍覆世间。愿一切众生。得妙智慧。出过三世。无所染着。愿一切众生。得应供盖。成胜福田。受一切供。愿一切众生。得最上盖。获无上智。自然觉悟。是为菩萨摩诃萨布施盖时善根回向。为令一切众生。得自在盖。能持一切诸善法故。为令一切众生。能以一盖。普覆一切。虚空法界。一切刹土。示现诸佛。自在神通。无退转故。为令一切众生。能以一盖。庄严十方。一切世界。供养佛故。为令一切众生。以妙幢幡。及诸宝盖。供养一切。诸如来故。为令一切众生。得普庄严盖。遍覆一切。诸佛国土。尽无余故。为令一切众生。得广大盖。普盖众生。皆令于佛。生信解故。为令一切众生。以不可说。众妙宝盖。供养一佛。于不可说。一一佛所。皆如是故。为令一切众生。得佛菩提。高广之盖。普覆一切。诸如来故。为令一切众生。得一切摩尼。宝庄严盖。一切宝璎珞庄严盖。一切坚固。香庄严盖。种种宝清净庄严盖。无量宝清净庄严盖。广大宝清净庄严盖。宝网弥覆宝铃垂下。随风摇动。出微妙音。普覆法界虚空界。一切世界。诸佛身故。为令一切众生。得无障无碍智。庄严盖。普覆一切诸如来故。又欲令一切众生。得第一智慧故。又欲令一切众生。得佛功德庄严故。又欲令一切众生。于佛功德。生清净欲愿心故。又欲令一切众生。得无量无边。自在心宝故。又欲令一切众生。满足诸法自在智故。又欲令一切众生。以诸善根。普覆一切故。又欲令一切众生。成就最胜。智慧盖故。又欲令一切众生。成就十力。普遍盖故。又欲令一切众生。能以一盖。弥覆法界。诸佛刹故。又欲令一切众生。于法自在为法王故。又欲令一切众生。得大威德。自在心故。又欲令一切众生。得广大智。恒无绝故。又欲令一切众生。得无量功德。普覆一切。皆究竟故。又欲令一切众生。以诸功德。盖其心故。又欲令一切众生。以平等心。覆众生故。又欲令一切众生。得大智慧。平等盖故。又欲令一切众生。具大回向。巧方便故。又欲令一切众生。获胜欲乐。清净心故。又欲令一切众生。得善欲乐。清净意故。又欲令一切众生。得大回向。普覆一切。诸众生故。佛子。菩萨摩诃萨。或施种种上妙幢幡。众宝为竿。宝缯为幡。种种杂彩。以为其幢。宝网垂覆。光色遍满。宝铎微摇。音节相和。奇特妙宝。形如半月。阎浮檀金。光逾皦日。悉置幢上。随诸世界。业果所现。种种妙物。以为严饰。如是无数。千万亿那由他。诸妙幢幡。接影连辉递相间发。光明严洁。周遍大地。充满十方。虚空法界。一切佛刹。菩萨摩诃萨。净心信解。以如是等。无量幢幡。或施现在。一切诸佛。及佛灭后。所有塔庙。或施法宝。或施僧宝。或施菩萨。诸善知识。或施声闻。及辟支佛。或施大众。或施别人。诸来求者。普皆施与。以此善根。如是回向。所谓愿一切众生。皆能建立一切善根。福德幢幡。不可毁坏。愿一切众生。建一切法。自在幢幡。尊重爱乐。勤加守护。愿一切众生。常以宝缯。书写正法。护持诸佛。菩萨法藏。愿一切众生。建高显幢。然智慧灯。普照世间。愿一切众生。立坚固幢。悉能摧殄一切魔业。愿一切众生。建智力幢。一切诸魔。所不能坏。愿一切众生。得大智慧。那罗延幢。摧灭一切。世间幢幡。愿一切众生。得智慧日。大光明幢。以智日光。普照法界。愿一切众生。具足无量。宝庄严幢。充满十方一切世界。供养诸佛。愿一切众生。得如来幢。摧灭一切。九十六种。外道邪见。是为菩萨摩诃萨施幢幡时善根回向。为令一切众生。得甚深高广。菩萨行幢。及诸菩萨。神通行幢。清净道故。佛子。菩萨摩诃萨。开众宝藏。以百千亿那由他。诸妙珍宝。给施无数。一切众生。随意与之。心无吝惜。以诸善根。如是回向。所谓愿一切众生。常见佛宝。舍离愚痴。修行正念。愿一切众生。皆得具足法宝光明。护持一切诸佛法藏。愿一切众生。能悉摄受一切僧宝。周给供养。恒无厌足。愿一切众生。得一切智。无上心宝。净菩提心。无有退转。愿一切众生。得智慧宝。普入诸法。心无疑惑。愿一切众生。具足菩萨。诸功德宝。开示演说。无量智慧。愿一切众生。得于无量。妙功德宝。修成正觉。十力智慧。愿一切众生。得妙三昧。十六智宝。究竟成满。广大智慧。愿一切众生。成就第一。福田之宝。悟入如来。无上智慧。愿一切众生。得成第一。无上宝主。以无尽辩。开演诸法。是为菩萨摩诃萨施众宝时善根回向。为令一切众生。皆得成满第一智宝。如来无碍。净眼宝故。佛子。菩萨摩诃萨。或以种种。妙庄严具。而为布施。所谓一切身庄严具。令身净妙。靡不称可。菩萨摩诃萨。等观一切。世间众生。犹如一子。欲令皆得身净庄严。成就世间。最上安乐。佛智慧乐。安住佛法。利益众生。以如是等。百千亿那由他。种种殊妙。宝庄严具。勤行布施。行布施时。以诸善根。如是回向。所谓愿一切众生。成就无上。妙庄严具。以诸清净。功德智慧。庄严人天。愿一切众生。得清净庄严相。以净福德。庄严其身。愿一切众生。得上妙庄严相。以百福相。庄严其身。愿一切众生。得不杂乱庄严相。以一切相。庄严其身。愿一切众生。得善净语言庄严相。具足种种。无尽辩才。愿一切众生。得一切功德。声庄严相。其音清净。闻者喜悦。愿一切众生。得可爱乐。诸佛语言庄严相令。诸众生闻法欢喜。修清净行。愿一切众生。得心庄严相。入深禅定。普见诸佛。愿一切众生。得总持庄严相。照明一切诸佛正法。愿一切众生。得智慧庄严相。以佛智慧。庄严其心。是为菩萨摩诃萨惠施一切庄严具时善根回向。为令众生。具足一切。无量佛法。功德智慧。圆满庄严。永离一切憍慢放逸故。佛子。菩萨摩诃萨。以受灌顶。自在王位。摩尼宝冠。及髻中珠。普施众生。心无吝惜。常勤修习。为大施主。修学施慧。增长舍根。智慧善巧。其心广大。给施一切。以彼善根。如是回向。所谓愿一切众生。得诸佛法之所灌顶。成一切智。愿一切众生。具足顶髻。得第一智。到于彼岸。愿一切众生。以妙智宝。普摄众生。皆令究竟功德之顶。愿一切众生。皆得成就智慧宝顶。堪受世间之所礼敬。愿一切众生。以智慧冠。庄严其首。为一切法自在之王。愿一切众生。智慧明珠。系其顶上。一切世间。无能见者。愿一切众生。皆悉堪受世间顶礼。成就慧顶。照明佛法。愿一切众生。首冠十力。庄严之冠。智慧宝海。清净具足。愿一切众生。至大地顶。得一切智。究竟十力。破欲界顶。诸魔眷属。愿诸众生。得成第一。无上顶王。获一切智。光明之顶。无能映夺。是为菩萨摩诃萨施宝冠时善根回向。为令众生。得第一智。最清净处。智慧摩尼。妙宝冠故。佛子。菩萨摩诃萨。见有众生。处在牢狱。黑暗之处。杻械枷锁。检系其身。起坐不安。众苦竞集。无有亲识。无归无救。裸露饥羸。酸剧难忍。菩萨见已。舍其所有。一切财宝。妻子眷属。及以自身。于牢狱中。救彼众生。如大悲菩萨。妙眼王菩萨。既救度已。随其所须。普皆给施。除其苦患。令得安隐。然后施以无上法宝。令舍放逸。安住善根。于佛教中。心无退转。佛子。菩萨摩诃萨。于牢狱中。救众生时。以诸善根。如是回向。所谓愿一切众生。究竟解脱。贪爱缠缚。愿一切众生。断生死流。升智慧岸。愿一切众生。除灭愚痴。生长智慧。解脱一切。烦恼缠缚。愿一切众生。灭三界缚。得一切智。究竟出离。愿一切众生。永断一切。烦恼结缚。到无烦恼。无障碍地。智慧彼岸。愿一切众生。离诸动念。思惟分别。入于平等。不动智地。愿一切众生。脱诸欲缚。永离世间。一切贪欲。于三界中。无所染着。愿一切众生。得胜志乐。常蒙诸佛。为说法门。愿一切众生。得无著无缚解脱心。广大如法界。究竟如虚空。愿一切众生。得菩萨神通。一切世界。调伏众生。令离世间。住于大乘。是为菩萨摩诃萨救度牢狱苦众生时善根回向。为令众生。普入如来。智慧地故。佛子。菩萨摩诃萨。见有狱囚。五处被缚。受诸苦毒。防卫驱逼。将之死地。欲断其命。舍阎浮提。一切乐具。亲戚朋友。悉将永诀。置高砧上。以刀屠割。或用木枪。竖贯其体。衣缠油沃以火焚烧。如是等苦。种种逼迫。菩萨见已。自舍其身。而代受之。如阿逸多菩萨。殊胜行王菩萨。及余无量。诸大菩萨。为众生故。自舍身命。受诸苦毒。菩萨尔时。语主者言。我愿舍身。以代彼命。如此等苦。可以与我。如治彼人。随意皆作。设过彼苦。阿僧祇倍。我亦当受。令其解脱。我若见彼。将被杀害。不舍身命。救赎其苦。则不名为住菩萨心。何以故。我为救护一切众生。发一切智菩提心故。佛子。菩萨摩诃萨。自舍身命。救众生时以诸善根。如是回向。所谓愿一切众生。得无断尽。究竟身命。永离一切。灾横逼恼。愿一切众生。依诸佛住。受一切智。具足十力。菩提记别。愿一切众生。普救含识。令无怖畏。永出恶道。愿一切众生。得一切命。入于不死。智慧境界。愿一切众生。永离怨敌。无诸厄难。常为诸佛。善友所摄。愿一切众生。舍离一切。刀剑兵仗。诸恶苦具。修行种种。清净善业。愿一切众生。离诸怖畏。菩提树下。摧伏魔军。愿一切众生。离大众怖。于无上法。心净无畏。能为最上。大师子吼。愿一切众生。得无障碍。师子智慧。于诸世间。修行正业。愿一切众生。到无畏处。常念救护诸苦众生。是为菩萨摩诃萨自舍身命。救彼临刑诸狱囚时。善根回向。为令众生。离生死苦。得于如来。上妙乐故

大方广佛华严经卷第二十六大方广佛华严经卷第二十七

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之五

佛子。菩萨摩诃萨。布施乞者。连肤顶髻。如宝髻王菩萨。胜妙身菩萨。及余无量。诸菩萨等。菩萨是时。见乞者来。心生欢喜。而语之言。汝今若须连肤顶髻。可就我取。我此顶髻。阎浮提中。最为第一。作是语时。心无动乱。不念余业。舍离世间。志求寂静。究竟清净。精勤质直。向一切智。便执利刀。割其头上。连肤顶髻。右膝着地。合十指掌。一心施与。正念三世。一切诸佛。菩萨所行。发大欢喜。增上志乐。于诸法中。意善开解。不取于苦。了知苦受。无相无生。诸受互起。无有常住。是故我应同去来今。一切菩萨。修行大舍。发深信乐。求一切智。无有退转。不由他教。善知识力。菩萨摩诃萨。作是施时。以诸善根。如是回向。所谓愿一切众生。得无见顶。成就菩萨。如塔之髻。愿一切众生。得绀青发。金刚发。细软发。能灭众生。一切烦恼。愿一切众生。得润泽发。密致发。不侵鬓额发。愿一切众生。得柔软发。尽于鬓额而生发。愿一切众生。得如卍字发。螺文右旋发。愿一切众生。得佛相发。永离一切。烦恼结习。愿一切众生。得光明发。其光普照十方世界。愿一切众生。得无乱发。如如来发。净妙无杂。愿一切众生。得成应供。顶塔之发。令其见者。如见佛发。愿一切众生。皆得如来无染着发。永离一切。闇翳尘垢。是为菩萨摩诃萨施连肤髻时善根回向。为令众生。其心寂静。皆得圆满。诸陀罗尼。究竟如来一切种智。十种力故。佛子。菩萨摩诃萨。以眼布施。诸来乞者。如欢喜行菩萨。月光王菩萨。及余无量。诸菩萨等。所行惠施。菩萨摩诃萨。布施眼时。起清净施眼心。起清净智眼心。起依止法光明心。起现观无上佛道心。发回向广大智慧心。发与三世菩萨。平等舍施心。发于无碍眼。起不坏净信心。于其乞者。起欢喜摄受心。为究竟一切神通故。为生佛眼故。为增广大菩提心故。为修习大慈悲故。为制伏六根故。于如是法。而生其心。佛子。菩萨摩诃萨。布施眼时。于其乞者。心生爱乐。为设施会。增长法力。舍离世间。爱见放逸。除断欲缚。修习菩提。随彼所求。心安不动。不违其意。皆令满足。而常随顺。无二舍行。以此善根。如是回向。所谓愿一切众生。得最胜眼。示导一切。愿一切众生。得无碍眼。开广智藏。愿一切众生。得净肉眼。光明鉴彻。无能蔽者。愿一切众生。得净天眼。悉见众生。生死业果。愿一切众生。得净法眼。能随顺入如来境界。愿一切众生。得智慧眼。舍离一切。分别取着。愿一切众生。具足佛眼。悉能觉悟一切诸法。愿一切众生。成就普眼。尽诸境界。无所障碍。愿一切众生。成就清净。离痴翳眼。了众生界。空无所有。愿一切众生。具足清净。无障碍眼。皆得究竟如来十力。是为菩萨摩诃萨布施眼时善根回向。为令众生。得一切智。清净眼故。佛子。菩萨摩诃萨。能以耳鼻。施诸乞者。如胜行王菩萨。无怨胜菩萨。及余无量。诸菩萨等。布施之时。亲附乞者。专心修习。诸菩萨行。具佛种性。生如来家。念诸菩萨。所修施行。常勤发起诸佛菩提。清净诸根。功德智慧。观察三有。无一坚固。愿常得见诸佛菩萨。随顺忆念一切佛法。知身虚妄。空无所有。无所贪惜。菩萨如是。施耳鼻时。心常寂静。调伏诸根。免济众生。险恶诸难。生长一切。智慧功德。入大施海。了达法义。具修诸道。依智慧行。得法自在。以不坚身。易坚固身。佛子。菩萨摩诃萨。布施耳时。以诸善根。如是回向。所谓愿一切众生。得无碍耳。普闻一切说法之音。愿一切众生。得无障耳。悉能解了一切音声。愿一切众生。得如来耳。一切聪达。无所壅滞。愿一切众生。得清净耳。不因耳处。生分别心。愿一切众生。得无聋聩耳。令蒙昧识。毕竟不生。愿一切众生。得遍法界耳。悉知一切诸佛法音。愿一切众生。得无碍耳。开悟一切无障碍法。愿一切众生。得无坏耳。善知诸论。无能坏者。愿一切众生。得普闻耳。广大清净。为诸耳王。愿一切众生。具足天耳。及以佛耳。是为菩萨摩诃萨布施耳时善根回向。为令众生。皆悉获得清净耳故。佛子。菩萨摩诃萨。布施鼻时。如是回向。所谓愿一切众生。得隆直鼻。得随好鼻。得善相鼻。得可爱乐鼻。得净妙鼻。得随顺鼻。得高显鼻。得伏怨鼻。得善见鼻。得如来鼻。愿一切众生。得离恚怒面。得一切法面。得无障碍面。得善见面。得随顺面。得清净面。得离过失面。得如来圆满面。得遍一切处面。得无量美好面。是为菩萨摩诃萨布施鼻时善根回向。为令众生。究竟得入诸佛法故。为令众生。究竟摄受诸佛法故。为令众生。究竟了知诸佛法故。为令众生。究竟住持诸佛法故。为令众生。究竟常见诸如来故。为令众生。皆悉证得佛法门故。为令众生。究竟成就无能坏心故。为令众生。皆能照了诸佛正法故。为令众生。普悉严净诸佛国土故。为令众生。皆得如来。大威力身故。是为菩萨摩诃萨施耳鼻时善根回向。佛子。菩萨摩诃萨。安住坚固。自在地中。能以牙齿。施诸众生。犹如往昔。华齿王菩萨。六牙象王菩萨。及余无量。诸菩萨等。菩萨摩诃萨。施牙齿时。其心清净。希有难得。如优昙华。所谓无尽心施。大信心施。步步成就无量舍心施。调伏诸根心施。一切悉舍心施。一切智愿心施。安乐众生心施。大施极施。胜施最胜施。辍身要用无所嫌恨心施。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得铦白牙齿。成最胜塔。受天人供。愿一切众生。得齐平牙齿。如佛相好。无有疏缺。愿一切众生。得调伏心。善趣菩萨。波罗蜜行。愿一切众生。口善清净。牙齿鲜白。分明显现。愿一切众生。得可忆念。庄严牙齿其口清净。无可恶相。愿一切众生。牙齿成就。具满四十。常出种种。希有妙香。愿一切众生。意善调伏。牙齿鲜洁。如白莲华。文理回旋。卍字成就。愿一切众生。口唇鲜净。牙齿洁白。放无量光。周遍照耀。愿一切众生。牙齿坚利。食无完粒。无所味着。为上福田。愿一切众生。于牙齿间。常放光明。授诸菩萨。第一记别。是为菩萨摩诃萨施牙齿时善根回向。为令众生。具一切智。于诸法中。智慧清净故。佛子。菩萨摩诃萨。若有人来。从乞舌时。于乞者所。以慈悲心。软语爱语。犹如往昔。端正面王菩萨。不退转菩萨。及余无量。诸菩萨等。佛子。菩萨摩诃萨。于诸趣中。而受生时。有无量百千亿那由他众生。而来乞舌。菩萨尔时。安置其人。在师子座。以无恚心。无害心。无恨心。大威德心。从佛种性所生心。住于菩萨所住心。常不浊乱心。住大势力心。于身无著心。于语无著心。两膝着地。开口出舌。以示乞者。慈心软语。而告之言。我今此身。普皆属汝。可取我舌。随意所用。令汝所愿。皆得满足。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得周普舌。悉能宣示诸语言法。愿一切众生。得覆面舌。所言无二。皆悉真实。愿一切众生。得普覆一切佛国土舌。示现诸佛。自在神通。愿一切众生。得软薄舌。恒受美妙。清净上味。愿一切众生。得辩才舌。能断一切。世间疑网。愿一切众生。得光明舌。能放无数。万亿光明。愿一切众生。得决定舌。辩说诸法。无有穷尽。愿一切众生。得普调伏舌。善能开示一切秘要。所有言说。皆令信受。愿一切众生。得普通达舌。善入一切语言大海。愿一切众生。得善说一切诸法门舌。于言语智。悉到彼岸。是为菩萨摩诃萨布施舌时善根回向。为令众生。皆得圆满无碍智故。佛子。菩萨摩诃萨。以头布施诸来乞者。如最胜智菩萨。及大丈夫。迦尸国王等。诸大菩萨。所行布施。为欲成就入一切法。最胜智首。为欲成就证大菩提。救众生首。为欲具足。见一切法。最第一首。为得正见。清净智首。为欲成就无障碍首。为欲证得第一地首。为求世间。最胜智首。欲成三界。无能见顶。净智慧首。为得示现。普到十方。智慧王首。为欲满足一切诸法。无能破坏。自在之首。佛子。菩萨摩诃萨。安住是法。精勤修习。则为已入诸佛种性。学佛行施。于诸佛所。生清净信。增长善根。令诸乞者。皆得喜足。其心清净。庆悦无量。心净信解。照明佛法。发菩提意。安住舍心。诸根悦豫。功德增长。生善乐欲。常好修行广大施行。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得如来头。得无见顶。于一切处。无能映蔽。于诸佛刹。最为上首。其发右旋。光净润泽。卍字严饰。世所希有。具足佛首。成就智首。一切世间。最第一首。为具足首。为清净首。为坐道场圆满智首。是为菩萨摩诃萨布施头时善根回向。为令众生。得最胜法。成于无上。大智慧故。佛子。菩萨摩诃萨。以其手足。施诸众生。如常精进菩萨。无忧王菩萨。及余无量。诸菩萨等。于诸趣中。种种生处。布施手足。以信为手。起饶益行。往返周旋。勤修正法。愿得宝手。以手为施。所行不空。具菩萨道。常舒其手。拟将广惠。安步游行。勇猛无怯。以净信力。具精进行。除灭恶道。成就菩提。佛子。菩萨摩诃萨。如是施时。以无量无边。广大之心。开净法门。入诸佛海。成就施手。周给十方。愿力任持。一切智道。住于究竟离垢之心。法身智身。无断无坏。一切魔业。不能倾动。依善知识。坚固其心。同诸菩萨。修行施度。佛子。菩萨摩诃萨。为诸众生。求一切智。施手足时。以诸善根。如是回向。所谓愿一切众生。具神通力。皆得宝手。得宝手已。各相尊敬。生福田想。以种种宝。更相供养。又以众宝。供养诸佛。兴妙宝云。遍诸佛土。令诸众生。互起慈心。不相恼害。游诸佛刹。安住无畏。自然具足究竟神通。又令皆得宝手华手。香手衣手。盖手华鬘手。末香手庄严具手。无边手无量手。普手。得是手已。以神通力。常勤往诣一切佛土。能以一手。遍摩一切。诸佛世界。以自在手。持诸众生。得妙相手。放无量光。能以一手。普覆众生。成于如来。手指网缦。赤铜爪相。菩萨尔时。以大愿手。普覆众生。愿一切众生。志常乐求无上菩提。出生一切功德大海。见来乞者。欢喜无厌。入佛法海。同佛善根。是为菩萨摩诃萨施手足时善根回向。佛子。菩萨摩诃萨。坏身出血。布施众生。如法业菩萨。善意王菩萨。及余无量。诸菩萨等。于诸趣中。施身血时。起成就一切智心。起欣仰大菩提心。起乐修菩萨行心。起不取苦受心。起乐见乞者心。起不嫌来乞心。起趣向一切菩萨道心。起守护一切菩萨舍心。起增广菩萨善施心。起不退转心。不休息心。无恋己心。以诸善根。如是回向。所谓愿一切众生。皆得成就法身智身。愿一切众生。得无劳倦身。犹如金刚。愿一切众生。得不可坏身。无能伤害。愿一切众生。得如变化身。普现世间。无有尽极。愿一切众生。得可爱乐身。净妙坚固。愿一切众生。得法界生身。同于如来。无所依止。愿一切众生。得如妙宝光明之身。一切世人。无能映蔽。愿一切众生。得智藏身。于不死界。而得自在。愿一切众生。得宝海身。见皆获益。无空过者。愿一切众生。得虚空身。世间恼患。无能染着。是为菩萨摩诃萨施身血时以大乘心清净心广大心欣悦心庆幸心欢喜心增上心安乐心无浊心善根回向。佛子。菩萨摩诃萨。见有乞求其身髓肉。欢喜软语。谓乞者言。我身髓肉。随意取用。如饶益菩萨。一切施王菩萨。及余无量。诸菩萨等。于诸趣中。种种生处。以其髓肉。施乞者时。欢喜广大。施心增长。同诸菩萨。修习善根。离世尘垢。得深志乐。以身普施。心无有尽。具足无量广大善根。摄受一切妙功德宝。如菩萨法。受行无厌。心常爱乐布施功德。一切周给。心无有悔。审观诸法。从缘无体。不贪施业。及业果报。随所会遇。平等施与。佛子。菩萨摩诃萨。如是施时。一切诸佛。皆悉现前。想之如父。得护念故。一切众生。皆悉现前。普令安住清净法故。一切世界。皆悉现前。严净一行佛国土故。一切众生。皆悉现前。以大悲心。普救护故。一切佛道。皆悉现前。乐观如来。十种力故。去来现在。一切菩萨。皆悉现前。同共圆满诸善根故。一切无畏。皆悉现前。能作最上。师子吼故。一切三世。皆悉现前。得平等智。普观察故。一切世间。皆悉现前。发广大愿。尽未来劫。修菩提故。一切菩萨。无疲厌行。皆悉现前。发无数量。广大心故。佛子。菩萨摩诃萨。施髓肉时。以此善根。如是回向。所谓愿一切众生。得金刚身。不可沮坏。愿一切众生。得坚密身。恒无缺减。愿一切众生。得意生身。犹如佛身。庄严清净。愿一切众生。得百福相身。三十二相。而自庄严。愿一切众生。得八十种好。妙庄严身。具足十力。不可断坏。愿一切众生。得如来身。究竟清净。不可限量。愿一切众生。得坚固身。一切魔怨。所不能坏。愿一切众生。得一相身。与三世佛。同一身相。愿一切众生。得无碍身。以净法身。遍虚空界。愿一切众生。得菩提藏身。普能容纳一切世间。是为菩萨摩诃萨求一切智施髓肉时善根回向。为令众生。皆得如来。究竟清净。无量身故。佛子。菩萨摩诃萨。以心布施诸来乞者。如无悔厌菩萨。无碍王菩萨。及余无量。诸大菩萨。以其自心。施乞者时。学自在施心。修一切施心。习行檀波罗蜜心。成就檀波罗蜜心。学一切菩萨。布施心。一切悉舍无尽心。一切悉施惯习心。荷负一切菩萨施行心。正念一切诸佛现前心。供养一切诸来乞者。无断绝心。菩萨摩诃萨。如是施时。其心清净。为度一切诸众生故。为得十力菩提处故。为依大愿。而修行故。为欲安住菩萨道故。为欲成就一切智故。为不舍离本誓愿故。以诸善根。如是回向。所谓愿一切众生。得金刚藏心。一切金刚围山等。所不能坏。愿一切众生。得卍相庄严金刚界心。得无能动摇心。得不可恐怖心。得利益世间常无尽心。得大勇猛幢智慧藏心。得如那罗延坚固幢心。得如众生海不可尽心。得那罗延藏无能坏心。得灭诸魔业魔军众心。得无所畏心。得大威德心。得常精进心。得大勇猛心。得不惊惧心。得被金刚甲胄心。得诸菩萨最上心。得成就佛法菩提光明心。得菩提树下坐安住一切诸佛正法离诸迷惑成一切智心。得成就十力心。是为菩萨摩诃萨布施心时善根回向。为令众生。不染世间。具足如来。十力心故。佛子。菩萨摩诃萨。若有乞求肠肾肝肺。悉皆施与。如善施菩萨。降魔自在王菩萨。及余无量。诸大菩萨。行此施时。见乞者来。其心欢喜。以爱眼观。为求菩提。随其所须。悉皆施与。心不中悔。观察此身。无有坚固。我应施彼。取坚固身。复念此身。寻即败坏。见者生厌。狐狼饿狗之所啖食。此身无常。会当弃舍。为他所食。无所觉知。佛子。菩萨摩诃萨。作是观时。知身无常。秽污之极。于法解悟。生大欢喜。敬心谛视。彼来乞者。如善知识。而来护想。随所乞求。无不惠施。以不坚身。易坚固身。佛子。菩萨摩诃萨。如是施时。所有善根。悉以回向。愿一切众生。得智藏身。内外清净。愿一切众生。得福藏身。能普任持一切智愿。愿一切众生。得上妙身。内蕴妙香。外发光明。愿一切众生。得腹不现身。上下端直。肢节相称。愿一切众生。得智慧身。以佛法味。充悦滋长。愿一切众生。得无尽身。修习安住。甚深法性。愿一切众生。得陀罗尼。清净藏身。以妙辩才。显示诸法。愿一切众生。得清净身。若身若心。内外俱净。愿一切众生。得如来智。深观行身。智慧充满。雨大法雨。愿一切众生。得内寂身。外为众生。作智幢王。放大光明。普照一切。是为菩萨摩诃萨施肠肾肝肺善根回向。为令众生。内外清净。皆得安住。无碍智故。佛子。菩萨摩诃萨。布施乞者。肢节诸骨。如法藏菩萨。光明王菩萨。及余无量。诸大菩萨。施其身分。肢节骨时。见乞者来。生爱乐心。欢喜心。净信心。安乐心。勇猛心。慈心。无碍心。清净心。随所乞求皆施与心。菩萨摩诃萨。施身骨时。以诸善根。如是回向。所谓愿一切众生。得如化身。不复更受骨肉血身。愿一切众生。得金刚身。不可破坏。无能胜者。愿一切众生。得一切智。圆满法身。于无缚无著。无系界生。愿一切众生。得智力身。诸根圆满。不断不坏。愿一切众生。得法力身。智力自在。到于彼岸。愿一切众生。得坚固身。其身贞实。常无散坏。愿一切众生。得随应身。教化调伏一切众生。愿一切众生。得智熏身。具那罗延。肢节大力。愿一切众生。得坚固相续不断绝身。永离一切疲极劳倦。愿一切众生。得大力安住身。悉能具足精进大力。愿一切众生。得遍世间平等法身。住于无量。最上智处。愿一切众生。得福德力身。见者蒙益。远离众恶。愿一切众生。得无依处身。皆得具足无依着智。愿一切众生。得佛摄受身。常为一切诸佛加护。愿一切众生。得普饶益诸众生身。悉能遍入一切诸道。愿一切众生。得普现身。普能照现一切佛法。愿一切众生。得具足精进身。专念勤修大乘智行。愿一切众生。得离我慢贡高清净身。智常安住。无所动乱。愿一切众生。得坚固行身。成就大乘。一切智业。愿一切众生。得佛家身。永离世间。一切生死。是为菩萨摩诃萨施身骨时善根回向。为令众生。得一切智。永清净故。佛子。菩萨摩诃萨。见有人来。手执利刀。乞其身皮。心生欢喜。诸根悦豫。譬如有人。惠以重恩。逢迎引纳。敷座令坐。曲躬恭敬。而作是念。此来乞者。甚为难遇。斯欲满我一切智愿。故来求索饶益于我。欢喜和颜。而语之言。我今此身。一切皆舍。所须皮者。随意取用。犹如往昔。清净藏菩萨。金胁鹿王菩萨。及余无量。诸大菩萨。等无有异。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得微细皮。犹如如来。色相清净。见者无厌。愿一切众生。得不坏皮。犹如金刚。无能坏者。愿一切众生。得金色皮。如阎浮檀。上妙真金。清净明洁。愿一切众生。得无量色皮。随其心乐。现清净色。愿一切众生。得净妙色皮。具足沙门。善软清净。如来色相。愿一切众生。得第一色皮。自性清净。色相无比。愿一切众生。成就如来。清净色皮。以诸相好。而自庄严。愿一切众生。得妙色皮。放大光明。普照一切。愿一切众生。得明网皮。如世高幢。放不可说。圆满光明。愿一切众生。得润泽色皮。一切色相。悉皆清净。是为菩萨摩诃萨施身皮时善根回向。为令众生。皆得一切。严净佛刹。具足如来。大功德故。佛子。菩萨摩诃萨。以手足指。施诸乞者。如坚精进菩萨。阎浮提自在王菩萨。及余无量。诸大菩萨。菩萨尔时。颜貌和悦。其心安善。无有颠倒。乘于大乘。不求美欲。不尚名闻。但发菩萨。广大之意。远离悭嫉。一切诸垢。专向如来。无上妙法。佛子。菩萨摩诃萨。如是施时。摄诸善根。悉以回向。愿一切众生。得纤长指。与佛无异。愿一切众生。得佣圆指。上下相称。愿一切众生。得赤铜甲指。其甲隆起。清净鉴彻。愿一切众生。得一切智胜丈夫指。悉能摄持一切诸法。愿一切众生。得随好指。具足十力。愿一切众生。得大人指。纤佣齐等。愿一切众生。得轮相指。指节圆满。文相右旋。愿一切众生。得如莲华卍字旋指。十力业报。相好庄严。愿一切众生。得光藏指。放大光明。照不可说。诸佛世界。愿一切众生。得善安布指。善巧分布。网缦具足。是为菩萨摩诃萨布施指时善根回向。为令众生。一切皆得心清净故。佛子。菩萨摩诃萨。请求法时。若有人言。汝能施我。连肉爪甲。当与汝法。菩萨答言。但与我法。连肉爪甲。随意取用。如求法自在王菩萨。无尽菩萨。及余无量。诸大菩萨。为求法故。欲以正法。开示演说。饶益众生。一切皆令得满足故。舍连肉爪甲。与诸乞者。菩萨尔时。以此善根。如是回向。所谓愿一切众生。皆得诸佛赤铜相爪。愿一切众生。得润泽爪。随好庄严。愿一切众生。得光净爪。鉴彻第一。愿一切众生。得一切智爪。具大人相。愿一切众生。得无比爪。于诸世间。无所染着。愿一切众生。得妙庄严爪。光明普照一切世间。愿一切众生。得不坏爪。清净无缺。愿一切众生。得入一切佛法方便相爪。广大智慧。皆悉清净。愿一切众生。得善生爪。菩萨业果。无不净妙。愿一切众生。得一切智大导师爪。放无量色。妙光明藏。是为菩萨摩诃萨为求法故施连肉爪甲时善根回向。为令众生。具足诸佛一切智爪。无碍力故。佛子。菩萨摩诃萨。求佛法藏。恭敬尊重。生难得想。有能说者。来语之言。若能投身。七仞火坑。当施汝法。菩萨闻已。欢喜踊跃。作是思惟。我为法故。尚应久住。阿鼻狱等。一切恶趣。受无量苦。何况才入人间火坑。即得闻法。奇哉正法。甚为易得。不受地狱。无量楚毒。但入火坑即便得闻。但为我说。我入火坑。如求善法王菩萨金刚思惟菩萨。为求法故。入火坑中。菩萨尔时。以此善根。如是回向。所谓愿一切众生。住佛所住。一切智法。永不退转。无上菩提。愿一切众生。离诸险难。受佛安乐。愿一切众生。得无畏心。离诸恐怖。愿一切众生。常乐求法。具足喜乐。众法庄严。愿一切众生。离诸恶趣。灭除一切三毒炽火。愿一切众生。常得安乐。具足如来。胜妙乐事。愿一切众生。得菩萨心。永离一切。贪恚痴火。愿一切众生。悉得菩萨。诸三昧乐。普见诸佛。心大欢喜。愿一切众生。善说正法。于法究竟。常无忘失。愿一切众生。具足菩萨。神通妙乐。究竟安住一切种智。是为菩萨摩诃萨为求正法投火坑时善根回向。为令众生。离障碍业。皆得具足智慧火故。佛子。菩萨摩诃萨。为求正法。分别演说。开菩萨道。示菩提路。趣无上智。勤修十力。广一切智心。获无碍智法。令众生清净。住菩萨境界。勤修大智。护佛菩提时。以身具受无量苦恼。如求善法菩萨。勇猛王菩萨。及余无量。诸大菩萨。为求法故。受无量苦。乃至摄取诽谤正法。恶业所覆。魔业所持。极大恶人。彼所应受一切苦恼。以求法故。悉皆为受。以此善根。如是回向。所谓愿一切众生。永离一切。苦恼逼迫。成就安乐。自在神通。愿一切众生。永离诸苦。得一切乐。愿一切众生。永灭苦蕴。得照现身。恒受安乐。愿一切众生。超出苦狱。成就智行。愿一切众生。见安隐道。离诸恶趣。愿一切众生。得法喜乐。永断众苦。愿一切众生。永拔众苦。互相慈爱。无损害心。愿一切众生。得诸佛乐离生死苦。愿一切众生。成就清净。无比安乐。一切苦恼。无能损害。愿一切众生。得一切胜乐。究竟具足。佛无碍乐。是为菩萨摩诃萨。为求法故。受众苦时。善根回向。为欲救护一切众生。令离险难。住一切智。无所障碍。解脱处故。佛子。菩萨摩诃萨。处于王位。求正法时。乃至但为一文一字。一句一义。生难得想。能悉罄舍海内所有。若近若远。国土城邑。人民库藏。园池屋宅。树林华果。乃至一切。珍奇妙物。宫殿楼阁。妻子眷属。及以王位。悉能舍之。于不坚中。求坚固法。为欲利益一切众生。勤求诸佛。无碍解脱。究竟清净。一切智道。如大势德菩萨。胜德王菩萨。及余无量。诸大菩萨。勤求正法。乃至极少。为于一字。五体投地。正念三世。一切佛法。爱乐修习。永不贪着。名闻利养。舍诸世间。自在王位。求佛自在。法王之位。于世间乐。心无所著。以出世法。长养其心。永离世间一切戏论。住于诸佛无戏论法。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。常乐惠施。一切悉舍。愿一切众生。能舍所有。心无中悔。愿一切众生。常求正法。不惜身命。资生之具。愿一切众生。悉得法利。能断一切。众生疑惑。愿一切众生。得善法欲。心常喜乐。诸佛正法。愿一切众生。为求佛法。能舍身命。及以王位。大心修习无上菩提。愿一切众生。尊重正法。常深爱乐。不惜身命。愿一切众生。护持诸佛。甚难得法。常勤修习。愿一切众生。皆得诸佛。菩提光明。成菩提行。不由他悟。愿一切众生。常能观察一切佛法。拔除疑箭。心得安隐。是为菩萨摩诃萨为求正法舍国城时善根回向。为令众生。知见圆满。常得住于安隐道故。佛子。菩萨摩诃萨。作大国王。于法自在。普行教命。令除杀业。阎浮提内。城邑聚落。一切屠杀皆令禁断。无足二足。四足多足。种种生类。普施无畏。无欺夺心。广修一切菩萨诸行。仁慈莅物。不行侵恼。发妙宝心。安隐众生。于诸佛所。立深志乐。常自安住三种净戒。亦令众生如是安住。菩萨摩诃萨。令诸众生住于五戒永断杀业。以此善根如是回向。所谓愿一切众生。发菩萨心。具足智慧。永保寿命。无有终尽。愿一切众生。住无量劫。供一切佛。恭敬勤修。更增寿命。愿一切众生。具足修行。离老死法。一切栽毒。不害其命。愿一切众生。具足成就。无病恼身。寿命自在。能随意住。愿一切众生。得无尽命。穷未来劫。住菩萨行。教化调伏一切众生。愿一切众生。为寿命门。十力善根。于中增长。愿一切众生。善根具足。得无尽命。成满大愿。愿一切众生。悉见诸佛。供养承事。住无尽寿。修集善根。愿一切众生。于如来处。善学所学。得圣法喜。无尽寿命。愿一切众生。得不老不病。常住命根。勇猛精进。入佛智慧。是为菩萨摩诃萨住三聚净戒永断杀业善根回向。为令众生得佛十力圆满智故。佛子。菩萨摩诃萨。见有众生。心怀残忍。损诸人畜。所有男形。令身缺减。受诸楚毒。见是事已。起大慈悲。而哀救之。令阎浮提一切人民。皆舍此业。菩萨尔时。语其人言。汝何所为。作是恶业。我有库藏。百千万亿。一切乐具。悉皆充满。随汝所须。尽当相给。汝之所作。众罪由生。我今劝汝。莫作是事。汝所作业。不如道理。设有所获。于何可用。损他益己。终无是处。如此恶行。诸不善法。一切如来。所不称叹。作是语已。即以所有。一切乐具。尽皆施与。复以善语。为说妙法。令其欢悦。所谓示寂静法。令其信受。灭除不善。修行净业。互起慈心。不相损害。彼人闻已。永舍罪恶。菩萨尔时。以此善根。如是回向。所谓愿一切众生。具丈夫形。成就如来。马阴藏相。愿一切众生。具男子形。发勇猛心。修诸梵行。愿一切众生。具勇猛力。恒为主导。住无碍智。永不退转。愿一切众生。皆得具足。大丈夫身。永离欲心。无所染着。愿一切众生。悉得成就善男子法。智慧增长。诸佛所叹。愿一切众生。普得具于大人之力。常能修习十力善根。愿一切众生。永不失坏男子之形。常修福智。未曾有法。愿一切众生。于五欲中。无著无缚。心得解脱。厌离三有。住菩萨行。愿一切众生。成就第一智慧丈夫。一切宗信。伏从其化。愿一切众生。具足菩萨。丈夫智慧。不久当成无上大雄。是为菩萨摩诃萨禁绝一切毁败男形善根回向。为令众生。具丈夫形。皆能守护诸善丈夫。生贤圣家。智慧具足。常勤修习丈夫胜行。有丈夫用。巧能显示七丈夫道。具足诸佛。善丈夫种。丈夫正教。丈夫勇猛。丈夫精进。丈夫智慧。丈夫清净。普令众生。究竟皆得

大方广佛华严经卷第二十七大方广佛华严经卷第二十八

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之六

佛子。菩萨摩诃萨。若见如来。出兴于世。开演正法。以大音声。普告一切。如来出世。如来出世。令诸众生。得闻佛名。舍离一切我慢戏论。复更劝导。令速见佛。令忆念佛。令归向佛。令攀缘佛。令观察佛。令赞叹佛。复为广说佛难值遇。千万亿劫。时乃一出。众生由此。得见于佛。生清净信。踊跃欢喜。尊重供养。复于佛所。闻诸佛名。转更值遇无数诸佛。植诸善本。修习增长。尔时。无数百千万亿那由他众生。因见佛故。皆得清净。究竟调伏。彼诸众生。于菩萨所。皆生最上善知识想。因菩萨故。成就佛法。以无数劫。所种善根。普于世间。施作佛事。佛子。菩萨摩诃萨。开示众生。令见佛时。以诸善根。如是回向。所谓愿一切众生。不待劝诱。自往见佛。承事供养。皆令欢喜。愿一切众生。常乐见佛。心无废舍。愿一切众生。常勤修习广大智慧。受持一切。诸佛法藏。愿一切众生。随所闻声。皆悟佛法。于无量劫。修菩萨行。愿一切众生。安住正念。恒以智眼。见佛出兴。愿一切众生。不念异业。常忆见佛。勤修十力。愿一切众生。于一切处。常见诸佛。了达如来。遍虚空界。愿一切众生。皆得具足佛自在身。普于十方。成道说法。愿一切众生。遇善知识。常闻佛法。于诸如来。得不坏信。愿一切众生。悉能称叹。诸佛出兴。令其见者。普得清净。是为菩萨摩诃萨叹佛出世善根回向。为令众生。见一切佛。供养承事。于无上法。究竟清净故。佛子。菩萨摩诃萨。舍于大地。或施诸佛。造立精舍。或施菩萨。及善知识。随意所用。或施众僧。以为住处。或施父母。或施别人。声闻独觉。种种福田。乃至一切。贫穷孤露。及余四众。随意悉与。令无所乏。或施造立如来塔庙。于如是等诸处之中。悉为辨具。资生什物。令随意用。无所恐惧。菩萨摩诃萨。随何方所。布施地时。以诸善根。如是回向。所谓愿一切众生。具足清净。一切智地。悉到普贤。众行彼岸。愿一切众生。得总持地。正念受持一切佛法。愿一切众生。得住持力。常能守护一切佛教。愿一切众生。得如地心。于诸众生。意常清净。无有恶念。愿一切众生。持诸佛种。成就菩萨。诸地次第。无有断绝。愿一切众生。普为一切。作安隐处。悉令调伏。住清净道。愿一切众生。同诸如来。利益世间。普使勤修。安住佛力。愿一切众生。普为世间之所爱乐。悉令安住无上佛乐。愿一切众生。获善方便。住佛诸力。无畏法中。愿一切众生。得如地智。自在修行一切佛法。是为菩萨摩诃萨。施大地时。善根回向。为令众生。皆得究竟一切如来。清净地故。佛子。菩萨摩诃萨。布施僮仆。供养一切诸佛菩萨。真善知识。或施僧宝。或奉父母。尊胜福田。或复给施病苦众生。令无阙乏。以存其命。或复施与贫穷孤露。及余一切无瞻侍者。或为守护如来塔庙。或为书持诸佛正法。以百千亿那由他仆使。随时给施。其诸仆使。皆聪慧善巧。性自调顺。常勤精进无有懈惰。具质直心。安乐心。利益心。仁慈心。恭恪心。无怨恨心。无仇敌心。能随受者。方俗所宜。于彼彼中。作诸利益。又皆从菩萨净业所感。才能技艺。工巧算数。靡不通达。善能供侍。悦可其心。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得调顺心。一切佛所。修习善根。愿一切众生。随顺供养一切诸佛。于佛所说。悉能听受。愿一切众生。得佛摄受。常观如来。更无余念。愿一切众生。不坏佛种。勤修一切。顺佛善根。愿一切众生。常勤供养一切诸佛。无空过时。愿一切众生。摄持一切。诸佛妙义。言辞清净。游行无畏。愿一切众生。常乐见佛。心无厌足。于诸佛所。不惜身命。愿一切众生。得见诸佛。心无染着。离世所依。愿一切众生。但归于佛。永离一切。邪归依处。愿一切众生。随顺佛道。心常乐观无上佛法。是为菩萨摩诃萨施仆使时善根回向。为令众生。远离尘垢。净治佛地。能现如来。自在身故。佛子。菩萨摩诃萨。以身布施诸来乞者。布施之时。生谦下心。生如地心。生忍受众苦。无变动心。生给侍众生。不疲厌心。生于诸众生。犹如慈母。所有众善悉回与心。生于诸愚险极恶众生种种侵陵皆宽宥心。安住善根。精勤给事。菩萨尔时。悉以善根。如是回向。所谓愿一切众生。随其所须。常无阙乏。修菩萨行。恒不间断。不舍一切菩萨义利。善住菩萨。所行之道。了达菩萨。平等法性。得在如来。种族之数。住真实语。持菩萨行。令诸世间。得净佛法。深心信解。证法究竟。令诸众生。出生清净。增上善根。住大功德。具一切智。又以此善根。令一切众生。常得供养一切诸佛。解一切法。受持读诵。不忘不失。不坏不散。心善调伏。不调令调。以寂静法。而调习之。令彼众生。于诸佛所。住如是事。又以此善根。令一切众生。作第一塔。应受世间。种种供养。令一切众生。成最上福田。得佛智慧。开悟一切。令一切众生。作最上受者。普能饶益一切众生。令一切众生。成最上福利。能使具足一切善根。令一切众生。成第一好施处。能使获得无量福报。令一切众生。于三界中。皆得出离。令一切众生。作第一导师。能为世间。示如实道。令一切众生。得妙总持。具持一切。诸佛正法。令一切众生。证得无量第一法界。具足虚空。无碍正道。是为菩萨摩诃萨施自己身善根回向。为令众生皆得应供。无量智身故。佛子。菩萨摩诃萨。闻法喜悦。生净信心。能以其身。供养诸佛。欣乐信解。无上法宝。于诸佛所。生父母想。读诵受持。无碍道法。普入无数。那由他法。大智慧宝。诸善根门。心常忆念无量诸佛。入佛境界。深达义理。能以如来。微密梵音。兴佛法云。雨佛法雨。勇猛自在。能分别说一切智人。第一之地。具足成就萨婆若乘。以无量百千亿那由他大法。成满诸根。佛子。菩萨摩诃萨。于诸佛所。闻如是法。欢喜无量。安住正法。自断疑惑。亦令他断。心恒怡畅。功德成满。善根具足。意恒相续。利益众生。心常不匮。获最胜智。成金刚藏。亲近诸佛。净诸佛刹。常勤供养一切如来。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。皆得圆满最胜之身。一切诸佛之所摄受。愿一切众生。常近诸佛。依诸佛住。恒得觐仰。未曾远离。愿一切众生。皆得清净。不坏之身。具足一切。功德智慧。愿一切众生。常勤供养一切诸佛。行无所得。究竟梵行。愿一切众生。得无我身。离我我所。愿一切众生。悉能分身。遍十方刹。犹如影现。而无来往。愿一切众生。得自在身。普往十方。无我无受。愿一切众生。从佛身生。处在如来。无上身家。愿一切众生。得法力身。忍辱大力。无能坏者。愿一切众生。得无比身。成就如来。清净法身。愿一切众生。成就出世。功德之身。生无所得。清净法界。是为菩萨摩诃萨以身供佛善根回向。为令众生。永住三世。诸佛家故。佛子。菩萨摩诃萨。以身布施一切众生。为欲普令成就善根。忆念善根。菩萨摩诃萨。自愿其身。为大明灯。普能照耀一切众生。为众乐具。普能摄受一切众生。为妙法藏。普能任持一切众生。为净光明。普能开晓一切众生。为世光影。普令众生。常得睹见。为善根因缘。普令众生。常得值遇。为真善知识。令一切众生。悉蒙教诱。为平坦道。令一切众生。皆得履践。为无有上。具足安乐。令一切众生。离苦清净。为明净日。普作世间。平等利益。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。常亲近佛。入佛智地。愿一切众生。得随顺智。住无上觉。愿一切众生。常处佛会。意善调伏。愿一切众生。所行有则。具佛威仪。愿一切众生。悉得涅槃。深解法义。愿一切众生。具知足行。生如来家。愿一切众生。舍无明欲。住佛志乐。愿一切众生。生胜善根。坐菩提树。愿一切众生。杀烦恼贼。离怨害心。愿一切众生。具足护持一切佛法。是为菩萨摩诃萨以身布施一切众生善根回向。为欲利益一切众生。令得无上。安隐处故。佛子。菩萨摩诃萨。自以其身。给侍诸佛。于诸佛所。念报重恩。如父母想。于诸如来。起深信乐。以清净心。护佛菩提。住诸佛法。离世间想。生如来家。随顺诸佛。离魔境界。了达一切诸佛所行。成就一切诸佛法器。菩萨尔时。以此善根。如是回向。所谓愿一切众生。得清净心。一切智宝。而自庄严。愿一切众生。住善调伏。远离一切诸不善业。愿一切众生。得不可坏。坚固眷属。普能摄受诸佛正法。愿一切众生。为佛弟子。到于菩萨。灌顶之地。愿一切众生。常为诸佛之所摄受。永离一切不善之法。愿一切众生。随顺诸佛。修行菩萨最胜之法。愿一切众生。入佛境界。悉皆得授一切智记。愿一切众生。与诸如来。皆悉平等。一切佛法。无不自在。愿一切众生。悉为诸佛之所摄受。常能修行无取着业。愿一切众生。常为诸佛。第一侍者。一切佛所。修智慧行。是为菩萨摩诃萨给侍诸佛善根回向。为欲证得诸佛菩提。为欲救护一切众生。为欲出离一切三界。为欲成就无损恼心。为得无量广大菩提。为欲成就照佛法智。为欲常蒙诸佛摄受。为得诸佛之所护持。为欲信解一切佛法。为欲成就与三世佛。平等善根。为欲圆满无悔恨心。证得一切。诸佛法故。佛子。菩萨摩诃萨。布施国土。一切诸物。乃至王位。悉亦能舍。于诸世事。心得自在。无系无缚。无所恋着。远离恶业。饶益众生。不着业果。不乐世法。不复贪染诸有生处。虽住世间。非此处生。心不执着蕴界处法。于内外法。心无依住。常不忘失诸菩萨行。未曾远离诸善知识。持诸菩萨。广大行愿。常乐承事一切善友。菩萨尔时。以此善根。如是回向。所谓愿一切众生。为大法王。于法自在。到于彼岸。愿一切众生。成佛法王。摧灭一切烦恼怨贼。愿一切众生。住佛王位。得如来智。开演佛法。愿一切众生。住佛境界。能转无上。自在法轮愿一切众生。生如来家。于法自在。护持佛种。永使不绝。愿一切众生。开示无量。法王正法。成就无边。诸大菩萨。愿一切众生。住净法界。为大法王。现佛出兴。相继不断。愿一切众生。于诸世界。作智慧王。化导群生。无时暂舍。愿一切众生。普为法界。虚空界等。诸世界中。一切众生。作法施主。使其咸得住于大乘。愿一切众生。得成具足众善之王。与三世佛。善根齐等。是为菩萨摩诃萨布施王位善根回向。为欲令彼一切众生。究竟住于安隐处故。佛子。菩萨摩诃萨。见有人来。乞王京都。严丽大城。及以关防。所有输税。尽皆施与。心无吝惜。专向菩提。发大誓愿。住于大慈。行于大悲。志意欢悦。利益众生。以广大智。解了深法。安住诸佛。平等法性。发心为求一切智故。于自在法。起深乐故。于自在智。求证得故。净修一切诸功德故。住于坚固。广大智故。广集一切。诸善根故。修行一切佛法愿故。自然觉悟大智法故。安住菩提。心无退故。修习一切菩萨行愿。一切种智。尽究竟故。而行布施。以此善根。如是回向。所谓愿一切众生。悉能严净无量刹土。奉施诸佛。以为住处。愿一切众生。常乐居止阿兰若处。寂静不动。愿一切众生。永不依止王都聚落。心乐寂静。永得究竟。愿一切众生。永不乐着一切世间。于世语言。常乐远离。愿一切众生。得离贪心。施诸所有。心无中悔。愿一切众生。得出离心。舍诸家业。愿一切众生。得无吝心。常行惠施。愿一切众生。得不着心。离居家法。愿一切众生。得离众苦。除灭一切。栽横怖畏愿一切众生。严净十方。一切世界。奉施诸佛。是为菩萨摩诃萨布施王都善根回向。为令众生。悉能严净诸佛刹故。佛子。菩萨摩诃萨所有一切。内宫眷属。妓侍众女。皆颜貌端正。才能具足。谈笑歌舞。悉皆巧妙。种种衣服。种种华香。而以严身。见者欢喜。情无厌足。如是宝女。百千万亿。那由他数。皆由菩萨。善业所生。随意自在。敬顺无失。尽以布施诸来乞者。而于其中。无爱乐心。无顾恋心。无耽着心。无系缚心。无执取心。无贪染心。无分别心。无随逐心。无取相心。无乐欲心。菩萨尔时。观诸善根。为欲令一切众生。咸得出离故回向。得佛法喜故回向。于不坚固中。而得坚固故回向。得金刚智。不可坏心故回向。入佛道场故回向。到于彼岸故回向。得无上菩提心故回向。能以智慧。了达诸法故回向。出生一切善根故回向。入三世诸佛家故回向。佛子。菩萨摩诃萨。住如是法。生如来家。增长诸佛清净胜因。出生最胜一切智道。深入菩萨广大智业。灭除一切世间垢恼。常能供施功德福田。为诸众生。宣说妙法善巧安立。令其修习诸清净行。常勤摄取一切善根。菩萨尔时。以诸善根。如是回向所谓愿一切众生。常得无量三昧眷属。菩萨胜定。相续不断。愿一切众生。常乐见佛。悉入诸佛庄严三昧。愿一切众生。成就菩萨不思议定。自在游戏。无量神通。愿一切众生。入如实定。得不坏心。愿一切众生。尽获菩萨甚深三昧。于诸禅定而得自在。愿一切众生。得解脱心。成就一切三昧眷属。愿一切众生。种种三昧。皆得善巧。悉能摄取诸三昧相。愿一切众生。得胜智三昧。普能学习诸三昧门。愿一切众生。得无碍三昧。入深禅定。终不退失。愿一切众生。得无著三昧。心恒正受不取二法。是为菩萨摩诃萨布施一切内宫眷属时善根回向。为欲令一切众生。皆得不坏。清净眷属故。为欲令一切众生。皆得菩萨眷属故。为欲令一切众生。悉得满足佛法故。为欲令一切众生。满足一切智力故。为欲令一切众生。证于无上智慧故为欲令一切众生。得于随顺眷属故。为欲令一切众生。得同志行人共居故。为欲令一切众生。具足一切福智故。为欲令一切众生。成就清净善根故。为欲令一切众生。得善和眷属故。为欲令一切众生。成就如来清净法身故。为欲令一切众生。成就次第。如理辩才。善说诸佛。无尽法藏故。为欲令一切众生。永舍一切世俗善根。同修出世清净善根故。为欲令一切众生。净业圆满。成就一切清净法故。为欲令一切众生。一切佛法。皆悉现前。以法光明。普严净故。佛子。菩萨摩诃萨。能以所爱妻子布施。犹如往昔。须达拏太子。现庄严王菩萨。及余无量诸菩萨等。菩萨尔时。乘萨婆若心。行一切施。净修菩萨布施之道。其心清净。无有中悔。罄舍所珍。求一切智。令诸众生。净深志乐。成菩提行。观菩萨道。念佛菩提。住佛种性。菩萨摩诃萨。成辨如是。布施心已。决定志求如来之身。自观己身。继属一切。不得自在。又以其身。普摄众生。犹如宝洲。给施一切。未满足者。令其满足。菩萨如是。护念众生。欲令自身。作第一塔。普使一切。皆生欢喜。欲于世间。生平等心。欲为众生。作清凉池。欲与众生。一切安乐。欲为众生。作大施主。智慧自在。了知菩萨所行之行。而能如是。大誓庄严。趣一切智。愿成无上。智慧福田。普念众生。常随守护。而能成辨。自身利益。智慧光明。普照于世。常勤忆念菩萨施心。恒乐观察如来境界。佛子。菩萨摩诃萨。以无缚无著解脱心。布施妻子。所集善根。如是回向。所谓愿一切众生。住佛菩提。起变化身。周遍法界。转不退轮。愿一切众生。得无著身。愿力周行。一切佛刹。愿一切众生。舍爱憎心。断贪恚结。愿一切众生。为诸佛子。随佛所行。愿一切众生。于诸佛所。生自己心。不可沮坏。愿一切众生。常为佛子。从法化生。愿一切众生。得究竟处。成就如来。自在智慧。愿一切众生。证佛菩提。永离烦恼。愿一切众生。能具演说佛菩提道。常乐修行无上法施。愿一切众生。得正定心。不为一切诸缘所坏。愿一切众生。坐菩提树。成最正觉。开示无量。从法化生。诸善男女。是为菩萨摩诃萨布施。妻子善根回向。为令众生。皆悉证得无碍解脱。无著智故。佛子。菩萨摩诃萨。庄严舍宅。及诸资具。随有乞求。一切施与。行布施法。于家无著。远离一切居家觉观。厌恶家业。资生之具。不贪不味。心无系着。知家易坏。心恒厌舍。都于其中。无所爱乐。但欲出家。修菩萨行。以诸佛法。而自庄严。一切悉舍。心无中悔。常为诸佛之所赞叹。舍宅财物。随处所有。悉以惠施。心无恋着。见有乞求。心生喜庆。菩萨尔时。以此善根。如是回向。所谓愿一切众生。舍离妻子。成就出家第一之乐。愿一切众生。解脱家缚。入于非家。诸佛法中。修行梵行。愿一切众生。舍离悭垢。乐一切施。心无退转。愿一切众生。永离家法。少欲知足。无所藏积。愿一切众生。出世俗家。住如来家。愿一切众生。得无碍法。灭除一切障碍之道。愿一切众生。离家属爱。虽现居家。心无所著。愿一切众生。善能化诱。不离家法。说佛智慧。愿一切众生。身现在家。心常随顺佛智而住。愿一切众生。在居家地。住于佛地。普令无量无边众生。发欢喜心。是为菩萨摩诃萨布施舍宅时善根回向。为令众生。成就菩萨。种种行愿。神通智故。佛子。菩萨摩诃萨。布施种种。园林台榭。游戏快乐。庄严之处。作是念言。我当为一切众生。作好园林。我当为一切众生。示现法乐。我当施一切众生。欢喜之意。我当示一切众生。无边喜乐。我当为一切众生。开净法门。我当令一切众生。发欢喜心。我当令一切众生。得佛菩提。我当令一切众生。成满大愿。我当于一切众生。犹如慈父。我当令一切众生。智慧观察。我当施一切众生。资生之具。我当于一切众生。犹如慈母。生长一切。善根大愿。佛子。菩萨摩诃萨。如是修行诸善根时。于恶众生。不生疲厌。亦不误起弃舍之心。设满世间。一切众生。悉不知恩。菩萨于彼。初无嫌恨。不生一念。求反报心。但欲灭其无量苦恼。于诸世间。心如虚空。无所染着。普观诸法真实之相。发大誓愿。灭众生苦。永不厌舍。大乘志愿。灭一切见。修诸菩萨平等行愿。佛子。菩萨摩诃萨。如是观察已。摄诸善根。悉以回向。所谓愿一切众生。念念滋生无量善法。成就无上。园林之心。愿一切众生。得不动法。见一切佛。皆令欢喜。愿一切众生。乐法园苑。得诸佛刹。园苑妙乐。愿一切众生。得净妙心。常见如来。神足园林。愿一切众生。得佛戏乐。常善游戏智慧境界。愿一切众生。得游戏乐。普诣佛刹。道场众会。愿一切众生。成就菩萨。解脱游戏。尽未来劫。行菩萨行。心无疲倦。愿一切众生。见一切佛。充满法界。发广大心。住佛园林。愿一切众生。悉能遍往一切佛刹。一一刹中。供养诸佛。愿一切众生。得善欲心。清净庄严一切佛刹。是为菩萨摩诃萨布施一切园林台榭善根回向。为令众生。见一切佛。游戏一切。佛园林故。佛子。菩萨摩诃萨。作百千亿那由他。无量无数。广大施会。一切清净。诸佛印可。终不损恼于一众生。普令众生。远离众恶。净三业道。成就智慧。开置无量百千亿那由他阿僧祇。清净境界。积集无量百千亿那由他阿僧祇。资生妙物。发甚难得菩提之心。行无限施。令诸众生。住清净道。初中后善。生净信解。随百千亿无量众生。心之所乐。悉令欢喜。以大慈悲。救护一切。承事供养三世诸佛。为欲成就一切佛种。修行布施。心无中悔。增长信根。成满胜行。念念增进檀波罗蜜。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。发大乘心。悉得成就摩诃衍施。愿一切众生。皆悉能行大会施。尽施善施。最胜施。无上施。最无上施。无等等施。超诸世间。施一切诸佛所称叹施。愿一切众生。作第一施主。于诸恶趣。免济众生。皆令得入无碍智道。修平等愿。如实善根。得无差别。证自境智。愿一切众生。安住寂静。诸禅定智。入不死道。究竟一切神通智慧。勇猛精进。具足诸地。庄严佛法。到于彼岸。永不退转。愿一切众生。设大施会。终不疲厌。给济众生。无有休息。究竟无上。一切种智。愿一切众生。恒勤种植一切善根。到于无量功德彼岸。愿一切众生。常蒙诸佛之所称叹。普为世间。作大施主。功德具足。充满法界。遍照十方。施无上乐。愿一切众生。设大施会。广集善根。等摄众生。到于彼岸。愿一切众生。成最胜施。普令众生。住第一乘。愿一切众生。为应时施。永离非时。大施究竟。愿一切众生。成就善施。到佛丈夫。大施彼岸。愿一切众生。究竟常行大庄严施。尽以一切诸佛为师。悉皆亲近。兴大供养。愿一切众生。住清净施。集等法界。无量福德。到于彼岸。愿一切众生。于诸世间。为大施主。誓度群品。住如来地。是为菩萨摩诃萨设大施会善根回向。为令众生。行无上施。究竟佛施。成就善施。不可坏施。供诸佛施。无恚恨施。救众生施。成一切智施。常见诸佛施。善精进施。成就一切菩萨功德诸佛智慧广大施故。佛子。菩萨摩诃萨。布施一切资生之物。心无贪惜。不求果报。于世富乐。无所希望。离妄想心。善思惟法。为欲利益一切众生。审观一切诸法实性。随诸众生。种种不同。所用所求。各各差别。成辨无量。资生之具。所有严饰。悉皆妙好。行无边施。行一切施。尽内外施。行此施时。增志乐力。获大功德。成就心宝。常能守护。一切众生。皆令发生。殊胜志愿。初未曾有。求反报心。所有善根。等三世佛。悉以圆满一切种智。佛子。菩萨摩诃萨。以此布施。所有善根。回向众生。愿一切众生。清净调伏。愿一切众生。灭除烦恼。严净一切诸佛刹土。愿一切众生。以清净心。于一念中。周遍法界。愿一切众生。智慧充满虚空法界。愿一切众生。得一切智。普入三世。调伏众生。于一切时。常转清净不退法轮。愿一切众生。具一切智。善能示现神通方便。饶益众生。愿一切众生。悉能悟入诸佛菩提。尽未来劫。于十方界。常说正法。曾无休息。令诸众生。普得闻知。愿一切众生。于无量劫。修菩萨行。悉得圆满。愿一切众生。于一切世界。若染若净。若小若大。若粗若细。若覆若仰。或一庄严。或种种庄严。所可演说。在世界数。诸世界中。修菩萨行。靡不周遍。愿一切众生。于念念中。常作三世。一切佛事。教化众生。向一切智。佛子。菩萨摩诃萨。随诸众生。一切所须。以如是等。阿僧祇物。而为给施。为令佛法。相续不断。大悲普救一切众生。安住大慈。修菩萨行。于佛教诲。终无违犯。以巧方便。修行众善。不断一切诸佛种性。随求悉与。而无患厌。一切悉舍。未曾中悔。常勤回向一切智道。时十方国土。种种形类。种种趣生。种种福田。皆来集会。至菩萨所。种种求索。菩萨见已。普皆摄受。心生欢喜。如见善友。大悲哀愍。思满其愿。舍心增长。无有休息。亦不疲厌。随其所求。悉令满足。离贫穷苦。时诸乞者。心大欣庆。转更称传。赞扬其德。美声遐布。悉来归往。菩萨见已。欢喜无量。假使百千亿那由他劫。受帝释乐。无数劫。受夜摩天乐。无量劫。受兜率陀天乐。无边劫。受善变化天乐。无等劫。受他化自在天乐。不可数劫。受梵王乐。不可称劫。受转轮王。王三千乐。不可思劫。受遍净天乐。不可说劫。受净居天乐。悉不能及。菩萨摩诃萨。见乞者来。欢喜爱乐。欣庆踊跃。信心增长。志乐清净。诸根调顺。信解成满。乃至增进诸佛菩提。佛子。菩萨摩诃萨。以此善根。为欲利益一切众生故回向。为欲安乐一切众生故回向。为令一切众生。得大义利故回向。为令一切众生。悉得清净故回向。为令一切众生。悉求菩提故回向。为令一切众生。悉得平等故回向。为令一切众生。悉得贤善心故回向。为令一切众生。悉入摩诃衍故回向。为令一切众生。悉得贤善智慧故回向。为令一切众生。悉具普贤菩萨行愿。满十力乘。现成正觉故回向

佛子。菩萨摩诃萨。以诸善根。如是回向时。身口意业。皆悉解脱。无著无系。无众生想。无命者想。无补伽罗想。无人想。无童子想。无生者想。无作者想。无受者想。无有想。无无想。无今世后世想。无死此生彼想。无常想。无无常想。无三有想。无无三有想。非想非非想。如是。非缚回向。非缚解回向。非业回向。非业报回向。非分别回向。非无分别回向。非思回向。非思已回向。非心回向。非无心回向。佛子。菩萨摩诃萨。如是回向时。不着内。不着外。不着能缘。不着所缘。不着因。不着果。不着法。不着非法。不着思。不着非思。不着色。不着色生。不着色灭。不着受想行识。不着受想行识生。不着受想行识灭。佛子。菩萨摩诃萨若能于此诸法不着。则不缚色。不缚色生。不缚色灭。不缚受想行识。不缚受想行识生。不缚受想行识灭。若能于此诸法不缚。则亦于诸法不解。何以故。无有少法。若现生。若已生。若当生。无法可取。无法可着。一切诸法。自相如是。无有自性。自性相离。非一非二。非多非无量。非小非大。非狭非广。非深非浅。非寂静非戏论。非处非非处。非法非非法。非体非非体。非有非非有。菩萨如是。观察诸法。则为非法。于言语中。随世建立。非法为法。不断诸业道。不舍菩萨行。求一切智。终无退转。了知一切。业缘如梦。音声如响。众生如影。诸法如幻。而亦不坏因缘业力。了知诸业。其用广大。解一切法。皆无所作。行无作道。未尝暂废。佛子。此菩萨摩诃萨。住一切智。若处非处。普皆回向一切智性。于一切处。皆悉回向。无有退转。以何义故。说名回向。永度世间。至于彼岸。故名回向。永出诸蕴。至于彼岸。故名回向。度言语道。至于彼岸。故名回向。离种种想。至于彼岸。故名回向。永断身见。至于彼岸。故名回向。永离依处。至于彼岸。故名回向。永绝所作。至于彼岸。故名回向。永出诸有。至于彼岸。故名回向。永舍诸取。至于彼岸。故名回向。永出世法。至于彼岸。故名回向。佛子。菩萨摩诃萨。如是回向时。则为随顺佛住。随顺法住。随顺智住。随顺菩提住。随顺义住。随顺回向住。随顺境界住。随顺行住。随顺真实住。随顺清净住。佛子。菩萨摩诃萨。如是回向。则为了达一切诸法。则为承事一切诸佛。无有一佛而不承事。无有一法而不供养。无有一法而可灭坏。无有一法而可乖违。无有一物而可贪着。无有一法而可厌离。不见内外。一切诸法。有少灭坏。违因缘道。法力具足。无有休息。佛子。是为菩萨摩诃萨第六随顺坚固一切善根回向。菩萨摩诃萨。住此回向时。常为诸佛之所护念。坚固不退。入深法性。修一切智。随顺法义。随顺法性。随顺一切坚固善根。随顺一切圆满大愿。具足随顺坚固之法。一切金刚。所不能坏。于诸法中。而得自在

尔时金刚幢菩萨。观察十方。观察众会。观察法界已。入于字句甚深之义。修习无量广大之心。以大悲心。普覆世间。长去来今。佛种性心。入于一切诸佛功德。成就诸佛自在力身。观诸众生。心之所乐。随其善根。所可成熟。依法性身。为现色身。承佛神力。而说颂言

  菩萨现身作国王　　于世位中最无等
  福德威光胜一切　　普为群萌兴利益
  其心清净无染着　　于世自在咸遵敬
  弘宣正法以训人　　普使众生获安隐
  现生贵族升王位　　常依正教转法轮
  禀性仁慈无毒虐　　十方敬仰皆从化
  智慧分别常明了　　色相才能皆具足
  临驭率土靡不从　　摧伏魔军悉令尽
  坚持净戒无违犯　　决志堪忍不动摇
  永愿蠲除忿恚心　　常乐修行诸佛法
  饮食香鬘及衣服　　车骑床褥座与灯
  菩萨悉以给济人　　并及所余无量种
  为利益故而行施　　令其开发广大心
  于尊胜处及所余　　意皆清净生欢喜
  菩萨一切皆周给　　内外所有悉能舍
  必使其心永清净　　不令暂尔生狭劣
  或施于头或施眼　　或施于手或施足
  皮肉骨髓及余物　　一切皆舍心无吝
  菩萨身居大王位　　种族豪贵人中尊
  开口出舌施群生　　其心欢喜无忧恋
  以彼施舌诸功德　　回向一切诸众生
  普愿藉此胜因缘　　悉得如来广长舌
  或施妻子及王位　　或施其身作僮仆
  其心清净常欢喜　　如是一切无忧悔
  随所乐求咸施与　　应时给济无疲厌
  一切所有皆能散　　诸来求者普满足
  为闻法故施其身　　修诸苦行求菩提
  复为众生舍一切　　求无上智不退转
  以于佛所闻正法　　自舍其身充给侍
  为欲普救诸群生　　发生无量欢喜心
  彼见世尊大导师　　能以慈心广饶益
  是时踊跃生欢喜　　听受如来深法味
  菩萨所有诸善根　　悉以回向诸众生
  普皆救护无有余　　永使解脱常安乐
  菩萨所有诸眷属　　色相端严能辩慧
  华鬘衣服及涂香　　种种庄严皆具足
  此诸眷属甚希有　　菩萨一切皆能施
  专求正觉度群生　　如是之心无暂舍
  菩萨如是谛思惟　　备行种种广大业
  悉以回向诸含识　　而不生于取着心
  菩萨舍彼大王位　　及以国土诸城邑
  宫殿楼阁与园林　　僮仆侍卫皆无吝
  彼于无量百千劫　　处处周行而施与
  因以教导诸群生　　悉使超升无上岸
  无量品类各差别　　十方世界来萃止
  菩萨见已心欣庆　　随其所乏令满足
  如三世佛所回向　　菩萨亦修如是业
  调御人尊之所行　　悉皆随学到彼岸
  菩萨观察一切法　　谁为能入此法者
  云何为入何所入　　如是布施心无住
  菩萨回向善巧智　　菩萨回向方便法
  菩萨回向真实义　　于其法中无所著
  心不分别一切业　　亦不染着于业果
  如菩提性从缘起　　入深法界无违逆
  不于身中而有业　　亦不依止于心住
  智慧了知无业性　　以因缘故业不失
  心不妄取过去法　　亦不贪着未来事
  不于现在有所住　　了达三世悉空寂
  菩萨已到色彼岸　　受想行识亦如是
  超出世间生死流　　其心谦下常清净
  谛观五蕴十八界　　十二种处及己身
  于此一一求菩提　　体性毕竟不可得
  不取诸法常住相　　于断灭相亦不着
  法性非有亦非无　　业理次第终无尽
  不于诸法有所住　　不见众生及菩提
  十方国土三世中　　毕竟求之无可得
  若能如是观诸法　　则如诸佛之所解
  虽求其性不可得　　菩萨所行亦不虚
  菩萨了法从缘有　　不违一切所行道
  开示解说诸业迹　　欲使众生悉清净
  是为智者所行道　　一切如来之所说
  随顺思惟入正义　　自然觉悟成菩提
  诸法无生亦无灭　　亦复无来无有去
  不于此死而生彼　　是人解悟诸佛法
  了达诸法真实性　　而于法性无分别
  知法无性无分别　　此人善入诸佛智
  法性遍在一切处　　一切众生及国土
  三世悉在无有余　　亦无形相而可得
  一切诸佛所觉了　　悉皆摄取无有余
  虽说三世一切法　　如是等法悉非有
  如诸法性遍一切　　菩萨回向亦复然
  如是回向诸众生　　常于世间无退转

大方广佛华严经卷第二十八大方广佛华严经卷第二十九

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之七

佛子。云何为菩萨摩诃萨等随顺一切众生回向。佛子。此菩萨摩诃萨。随所积集一切善根。所谓。小善根。大善根。广善根。多善根。无量善根。种种善根。微尘数善根。阿僧祇善根。无边际善根。不可思善根。不可量善根。佛境界善根。法境界善根。僧境界善根。善知识境界善根。一切众生境界善根。方便善巧境界善根。修诸善心境界善根。内境界善根。外境界善根。无边助道法境界善根。勤修一切舍善根。立胜志究竟持净戒善根。一切舍无不受堪忍善根。常精进心无退善根。以大方便入无量三昧善根。以智慧善观察善根。知一切众生心行差别善根。集无边功德善根。勤修习菩萨业行善根。普覆育一切世间善根。佛子。菩萨摩诃萨。于此善根修行安住。趣入摄受。积集辨具。悟解心净。开示发起。时得堪忍心。闭恶趣门。善摄诸根。威仪具足。远离颠倒。正行圆满。堪为一切诸佛法器。能作众生福德良田。为佛所念。长佛善根。住诸佛愿。行诸佛业。心得自在。等三世佛。趣佛道场。入如来力。具佛色相。超诸世间。不乐生天。不贪富乐。不着诸行。一切善根。悉以回向。为诸众生功德之藏。住究竟道。普覆一切。于虚妄道中。拔出众生。令其安住一切善法。遍诸境界。无断无尽。开一切智菩提之门。建立智幢。严净大道。普能示现一切世间。令除垢染。心善调伏。生如来家。净佛种性。功德具足。作大福田。为世所依。安立众生。咸令清净。常勤修习一切善根。佛子。菩萨摩诃萨。以净志愿菩提心力。修诸善根时。作是念言。此诸善根。是菩提心之所积集。是菩提心之所思惟。是菩提心之所发起。是菩提心之所志乐。是菩提心之所增益。皆为怜愍一切众生。皆为趣求一切种智。皆为成就如来十力。作是念时。善根增进。永不退转。佛子。菩萨摩诃萨。复作是念。愿我以此善根果报。尽未来劫。修菩萨行。悉以惠施一切众生。悉以回向一切众生。普遍无余。愿令阿僧祇世界。珍宝充满。阿僧祇世界。衣服充满。阿僧祇世界。妙香充满。阿僧祇世界。庄严具充满。阿僧祇世界。无量摩尼宝充满。阿僧祇世界。妙华充满。阿僧祇世界。上味充满。阿僧祇世界。财货充满。阿僧祇世界。床座充满。盖以宝帐。敷以妙衣。阿僧祇世界。种种庄严。宝冠充满。假使一人。尽未来劫。常来求索。以此等物。而惠施之。未曾厌倦而有休息。如于一人。于一切众生。悉亦如是。佛子。菩萨摩诃萨。如是施时。无虚伪心。无希望心。无名誉心。无中悔心。无热恼心。但发专求一切智道心。一切悉舍心。哀愍众生心。教化成熟心。皆令安住一切智智心。佛子。菩萨摩诃萨。以诸善根。如是回向。尽未来劫。常行惠施。佛子。菩萨摩诃萨。复作是念。我为一众生故。欲令阿僧祇世界。宝象充满。七支具足。性极调顺。上立金幢。金网弥覆。种种妙宝。而为庄严。以用布施。愿令阿僧祇世界。宝马充满。如龙马王。种种众宝。庄严之具。而严饰之。持用布施。愿令阿僧祇世界。妓女充满。悉能敷奏种种妙音。持用布施。愿令阿僧祇世界。男女充满。持用布施。愿令阿僧祇世界。己身充满。发菩提心。而用布施。愿令阿僧祇世界。己头充满。起不放逸心。而用布施。愿令阿僧祇世界。己眼充满。而用布施。愿令阿僧祇世界。己身血肉。及以骨髓。充满其中。心无顾恋。持用布施。愿令阿僧祇世界。自在王位。充满其中。持用布施。愿令阿僧祇世界。奴仆作使。充满其中。持用布施。菩萨摩诃萨。以如是等种种诸物。尽未来劫。安住广大一切施心。施一众生。如一众生。尽众生界一切众生。皆如是施。佛子。菩萨摩诃萨。于一世界。尽未来劫。修菩萨行。以是等物。施一众生。如是给施一切众生。皆令满足。如于一世界。于尽虚空遍法界一切世界中。悉亦如是。大悲普覆。终无间息。普加哀愍。随其所须。供给供养。不令施行。遇缘而息。乃至不于一弹指顷。生疲倦心。佛子。菩萨摩诃萨。如是施时。生于此心。所谓无著心。无缚心。解脱心。大力心。甚深心。善摄心。无执心。无寿者心。善调伏心。不散乱心。不妄计心。具种种宝性心。不求果报心。了达一切法心。住大回向心。善决诸义心。令一切众生。住无上智心。生大法光明心。入一切智智心。佛子。菩萨摩诃萨。以所集善根。于念念中。如是回向。所谓愿一切众生。财宝丰足。无所乏少。愿一切众生成就无尽大功德藏。愿一切众生。具足一切安隐快乐。愿一切众生。增长菩萨摩诃萨业。愿一切众生。成满无量第一胜法。愿一切众生。得不退转一切智乘。愿一切众生。普见十方一切诸佛。愿一切众生。永离世间诸惑尘垢。愿一切众生。皆得清净平等之心。愿一切众生。离诸难处。得一切智

佛子。菩萨摩诃萨。如是回向时。发欢喜心。为令一切众生。得利益安乐故。为令一切众生。得平等心故。为令一切众生。住能舍心故。为令一切众生。住一切施心故。为令一切众生。住欢喜施心故。为令一切众生。住永离贫穷施心故。为令一切众生。住一切财宝施心故。为令一切众生。住无数财宝施心故。为令一切众生。住普施无量施一切施心故。为令一切众生。住尽未来劫。无断施心故。为令一切众生。住一切悉舍。无悔无恼施心故。为令一切众生。住悉舍一切资生之物施心故。为令一切众生。住随顺施心故。为令一切众生。住摄取施心故。为令一切众生。住广大施心故。为令一切众生。住舍无量庄严具供养施心故。为令一切众生。住无著施心故。为令一切众生。住平等施心故。为令一切众生。住如金刚极大力施心故。为令一切众生。住如日光明施心故。为令一切众生。住摄如来智施心故。为令一切众生。善根眷属具足故。为令一切众生。善根智慧常现在前故。为令一切众生。得不可坏净心圆满故。为令一切众生。成就最胜清净善根故。为令一切众生。于烦恼睡眠中。得觉悟故。为令一切众生。灭除一切诸疑惑故。为令一切众生。得平等智慧净功德故。为令一切众生。功德圆满。无能坏者故。为令一切众生。具足清净不动三昧故。为令一切众生。住不可坏一切智智故。为令一切众生。成满菩萨无量清净神通行故。为令一切众生。修集无著善根故。为令一切众生。念去来今一切诸佛心清净故。为令一切众生。出生清净胜善根故。为令一切众生。灭除一切魔所作业障道法故。为令一切众生。具足无碍清净平等功德法故。为令一切众生。以广大心。常念诸佛。无懈废故。为令一切众生。常近诸佛。勤供养故。为令一切众生。广开一切诸善根门。普能圆满白净法故。为令一切众生。无量心。广大心。最胜心。悉清净故。为令一切众生。成就清净等施心故。为令一切众生。奉持诸佛尸波罗蜜等清净故。为令一切众生。得大堪忍波罗蜜故。为令一切众生。住精进波罗蜜。常无懈故。为令一切众生。住无量定。能起种种神通智故。为令一切众生。得知一切法无体性般若波罗蜜故。为令一切众生。圆满无边净法界故。为令一切众生。成满一切神通清净善根故。为令一切众生。住平等行。积集善法。悉圆满故。为令一切众生。善入一切诸佛境界。悉周遍故。为令一切众生。身口意业。普清净故。为令一切众生。善业果报。普清净故。为令一切众生。了达诸法。普清净故。为令一切众生。了达实义。普清净故。为令一切众生。修诸胜行。普清净故。为令一切众生。成就一切菩萨大愿。普清净故。为令一切众生。证得一切功德智慧。普清净故。为令一切众生。成就一切同体善根。回向出生。一切智乘。普圆满故。为令一切众生。严净一切诸佛国土。普圆满故。为令一切众生。见一切佛。而无所著。普圆满故。为令一切众生具诸相好。功德庄严。普圆满故。为令一切众生。得六十种音声。发言诚谛。皆可信受。百千种法。而以庄严。如来无碍。功德妙音。悉圆满故。为令一切众生。成就十力庄严无碍平等心故。为令一切众生。得一切佛无尽法明。一切辩才。普圆满故。为令一切众生。得无上无畏。人中之雄。师子吼故。为令一切众生得一切智转不退转无尽法轮故。为令一切众生。了一切法。开示演说。普圆满故。为令一切众生。以时修习清净善法。普圆满故。为令一切众生。成就导师。无上法宝等清净故。为令一切众生。于一庄严。无量庄严。大庄严。诸佛庄严。普圆满故。为令一切众生。等入三世所有境界。悉周遍故。为令一切众生。悉能往诣一切佛刹。听受正法。无不遍故。为令一切众生。智慧利益。为世所宗。与佛等故。为令一切众生。以一切智。知一切法。普圆满故。为令一切众生。行不动业。得无碍果。普圆满故。为令一切众生。所有诸根。咸得神通。能知一切众生根故。为令一切众生。得无差别平等智慧。于一相法。普清净故。为令一切众生。与理无违。一切善根。悉具足故。为令一切众生。于一切菩萨自在神通。悉明达故。为令一切众生。得一切佛。无尽功德。若福若智。悉平等故。为令一切众生。发菩提心。解一切法。平等一相。无遗缺故。为令一切众生。了达正法。为世最上福德田故。为令一切众生。成就平等。清净大悲。为诸施者。大力田故。为令一切众生。坚固第一。无能沮坏故。为令一切众生。见必蒙益。无能摧伏故。为令一切众生。成满最胜平等心故。为令一切众生。善能了达一切诸法。得大无畏故。为令一切众生。放一光明。普照十方一切世界故。为令一切众生。普修一切菩萨精进行。无懈退故。为令一切众生。以一行愿。普满一切诸行愿故。为令一切众生。以一妙音。普使闻者。皆得解故。为令一切众生。悉能具足一切菩萨。清净心故。为令一切众生。普得值遇诸善知识。咸承事故。为令一切众生。修菩萨行。调伏众生。不休息故。为令一切众生。以妙辩才。具一切音。随机广演。无断尽故。为令一切众生。能以一心。知一切心。以一切善根。等回向故。为令一切众生。常乐积集一切善根。安立众生。于净智故。为令一切众生得一切智。福德智慧。清净身故。为令一切众生。善知一切众生善根。观察回向。普成就故。为令一切众生。得一切智。成等正觉。普圆满故。为令一切众生。得具足神通智。于一处出兴。一切诸处。皆出兴故。为令一切众生。得普庄严智。严净一众会。一切众会。皆严净故。为令一切众生。于一佛国土。普见一切佛国土故。为令一切众生。以一切庄严具。不可说庄严具。无量庄严具。无尽庄严具。庄严一切诸佛国土。普周遍故。为令一切众生。于一切法。悉能决了甚深义故。为令一切众生。得诸如来。最上第一自在神通故。为令一切众生。得非一非异。一切功德。自在神通故。为令一切众生。具足一切平等善根。普为诸佛。灌其顶故。为令一切众生。悉得成满清净智身。于诸有中。最尊胜故。佛子。菩萨摩诃萨。如是悲愍。利益安乐。一切众生。咸令清净。远离悭嫉。受胜妙生。具大威德。生大信解。永离嗔恚。及诸翳浊。其心清净。质直柔软。无有谄曲。迷惑愚痴。行出离行。坚固不坏。平等之心。永无退转。白净法力。具足成就。无恼无失。善巧回向。常修正行。调伏众生。灭除一切诸不善业。修行苦行一切善根。又劝众生。令其修集。普为含识。具受众苦。以大智眼。观诸善根。知其悉以智慧为性。方便回向一切众生。为令一切众生。悉得安住一切清净。功德处故。为令一切众生。悉能摄受一切善根。知诸功德性及义故。为令一切众生。普净一切。诸善根故。为令一切众生。于福田境界中。种诸善法。心无悔故。为令一切众生。普能摄受一切众生。一一皆令趣一切智故。为令一切众生。普摄一切所有善根。一一皆与平等回向。而相应故。又以诸善根。如是回向。所谓愿一切众生。究竟安隐。愿一切众生。究竟清净。愿一切众生。究竟安乐。愿一切众生。究竟解脱。愿一切众生。究竟平等。愿一切众生。究竟了达。愿一切众生。究竟安住诸白净法。愿一切众生。得无碍眼。愿一切众生。善调其心。愿一切众生。具足十力。调伏众生。佛子。菩萨摩诃萨。如是回向时。不着业。不着报。不着身。不着物。不着刹。不着方。不着众生。不着无众生。不着一切法。不着无一切法。佛子。菩萨摩诃萨。如是回向时。以此善根。普施世间。愿一切众生。成满佛智。得清净心。智慧明了。内心寂静。外缘不动。增长成就三世佛种。佛子。菩萨摩诃萨。修行如是回向之时。超出一切。无能过者。一切世间。所有言辞。悉共称赞。亦不可尽。普修一切菩萨诸行。悉能往诣一切佛土。普见诸佛。无所障碍。又能普见一切世界。菩萨所行。以善方便。为诸众生。分别诸法。甚深句义。得陀罗尼。演说妙法。尽未来劫。无有断绝。为众生故。念念于不可说不可说世界。犹如影像。普现其身。供养诸佛。念念严净不可说不可说诸佛国土。悉令周遍。修行严净佛刹智慧。而无厌足。念念令不可说不可说百千亿那由他众生。清净成就。平等满足。于彼一切诸国土中。勤修一切诸波罗蜜。摄取众生。成就净业。得无碍耳。于不可说不可说。诸佛世界。一一如来。所转法轮。听闻受持。精勤修习。不生一念舍离之心。住无所得。无依止。无作无著。菩萨神通。于一刹那。一弹指顷。分身普诣不可说诸佛世界。与诸菩萨。等同一见。佛子。菩萨摩诃萨。如是修习菩萨行时。尚能成满无量不可说不可说。清净功德。忆念称赞。所不能尽。况复得成无上菩提。一切佛刹。平等清净。一切众生。平等清净。一切身平等清净。一切根平等清净。一切业果。平等清净。一切众会道场。平等清净。一切圆满行。平等清净。一切法方便智。平等清净。一切如来。诸愿回向。平等清净。一切诸佛。神通境界。平等清净。佛子。菩萨摩诃萨。如是回向时。得一切功德清净。欢喜法门。无量功德。圆满庄严。如是回向时。众生不违一切刹。刹不违一切众生。刹众生不违业。业不违刹众生。思不违心。心不违思。思心不违境界。境界不违思心。业不违报。报不违业。业不违业道。业道不违业。法性不违相。法相不违性。法生不违性。法性不违生。刹平等不违众生平等。众生平等不违刹平等。一切众生平等。不违一切法平等。一切法平等。不违一切众生平等。离欲际平等。不违一切众生安住平等。一切众生安住平等。不违离欲际平等。过去不违未来。未来不违过去。过去未来。不违现在。现在不违过去未来。世平等不违佛平等。佛平等不违世平等。菩萨行不违一切智。一切智不违菩萨行。佛子。菩萨摩诃萨。如是回向时。得业平等。得报平等。得身平等。得方便平等。得愿平等。得一切众生平等。得一切刹平等。得一切行平等。得一切智平等。得三世诸佛平等。得承事一切诸佛。得供养一切菩萨。得种一切善根。得满一切大愿。得教化一切众生。得了知一切业。得承事供养一切善知识。得入一切清净众会道场。得通达一切正教。得成满一切白法。佛子。是为菩萨摩诃萨第七等随顺一切众生回向。菩萨摩诃萨。成就此回向。则能摧灭一切魔怨。拔诸欲刺。得出离乐。住无二性。具大威德。救护众生。为功德王。神足无碍。往一切刹。入寂灭处。具一切身。成菩萨行。于诸行愿。心得自在。分别了知一切诸法。悉能遍生一切佛刹。得无碍耳。闻一切刹。所有音声。得净慧眼。见一切佛。未尝暂舍于一切境界。成就善根。心无高下。于一切法。得无所得。菩萨摩诃萨。以一切善根。等随顺一切众生。如是回向。尔时金刚幢菩萨。承佛神力。普观十方。而说颂言

  菩萨所作诸功德　　微妙广大甚深远
  乃至一念而修行　　悉能回向无边际
  菩萨所有资生具　　种种丰盈无限亿
  香象宝马以驾车　　衣服珍财悉殊妙
  或以头目并手足　　或持身肉及骨髓
  悉遍十方无量刹　　普施一切令充遍
  无量劫中所修习　　一切功德尽回向
  为欲救度诸群生　　其心毕竟不退转
  菩萨为度众生故　　常修最胜回向业
  普令三界得安乐　　悉使当成无上果
  菩萨普兴平等愿　　随其所集清净业
  悉以回施诸群生　　如是大誓终无舍
  菩萨愿力无限碍　　一切世间咸摄受
  如是回向诸群生　　未曾暂起分别心
  普愿众生智明了　　布施持戒悉清净
  精进修行不懈废　　如是大誓无休息
  菩萨回向到彼岸　　普开清净妙法门
  智慧同于两足尊　　分别实义得究竟
  菩萨言辞已通达　　种种智慧亦如是
  说法如理无障碍　　而于其中心不着
  常于诸法不作二　　亦复不作于不二
  于二不二并皆离　　知其悉是语言道
  知诸世间悉平等　　莫非心语一切业
  众生幻化无有实　　所有果报从兹起
  一切世间之所有　　种种果报各不同
  莫不皆由业力成　　若灭于业彼皆尽
  菩萨观察诸世间　　身口意业悉平等
  亦令众生住平等　　犹如无等大圣尊
  菩萨善业悉回向　　普令众生色清净
  福德方便皆具足　　同于无上调御士
  菩萨利益诸群生　　功德大海尽回向
  愿使威光特超世　　得成勇猛大力身
  凡所修习诸功德　　愿使世间普清净
  诸佛清净无伦匹　　众生清净亦如是
  菩萨于义得善巧　　能知诸佛最胜法
  以众善业等回向　　愿令庶品同如来
  菩萨了知诸法空　　一切世间无所有
  无有造作及作者　　众生业报亦不失
  诸法寂灭非寂灭　　远离此二分别心
  知诸分别是世见　　入于正位分别尽
  如是真实诸佛子　　从于如来法化生
  彼能如是善回向　　世间疑惑悉除灭

大方广佛华严经卷第二十九大方广佛华严经卷第三十

         于阗国三藏实叉难陀奉　制译

    十回向品第二十五之八

佛子。何者是菩萨摩诃萨真如相回向。佛子。此菩萨摩诃萨。正念明了。其心坚住。远离迷惑。专意修行。深心不动。成不坏业。趣一切智。终不退转。志求大乘。勇猛无畏。植诸德本。普安世间。生胜善根。修白净法。大悲增长。心宝成就。常念诸佛。护持正法。于菩萨道。信乐坚固。成就无量净妙善根。勤修一切功德智慧。为调御师。生众善法。以智方便。而为回向。菩萨尔时。慧眼普观所有善根。无量无边。其诸善根。修集之时。若求缘若辨具。若治净若趣入。若专励若起行。若明达若精审。若开示。如是一切。有种种门。种种境。种种相。种种事。种种分。种种行。种种名字。种种分别。种种出生。种种修习。其中所有。一切善根。悉是趣向十力乘心之所建立。皆悉回向一切种智。唯一无二。以诸善根。如是回向。所谓愿得圆满。无碍身业。修菩萨行。愿得清净无碍口业。修菩萨行。愿得成就无碍意业。安住大乘。愿得圆满无障碍心。净修一切诸菩萨行。愿起无量广大施心。周给无边一切众生。愿于诸法。心得自在。演大法明。无能障蔽。愿得明达一切智处。发菩提心。普照世间。愿常正念三世诸佛。谛想如来常现在前。愿住圆满增上志乐。远离一切诸魔怨敌。愿得安住佛十力智。普摄众生。无有休息。愿得三昧。游诸世界。而于世间。无所染着。愿住诸世界。无有疲厌。教化众生。恒不休息。愿起无量。思慧方便。成就菩萨不思议道。愿得诸方不迷惑智。悉能分别一切世间。愿得自在神通智力。于一念中。悉能严净一切国土。愿得普入诸法自性。见一切世间悉皆清净。愿得生起无差别智。于一刹中。入一切刹。愿以一切刹庄严之事。显示一切教化无量。无边众生。愿于一佛刹中。示无边法界。一切佛刹。悉亦如是。愿得自在。大神通智。普能往诣一切佛土。佛子。菩萨摩诃萨。以诸善根。愿得庄严一切佛国。愿得周遍一切世界。愿得成就智慧观察。如为己身。如是回向。如是而为一切众生。所谓愿一切众生。永离一切。地狱畜生。阎罗王趣。愿一切众生。除灭一切障碍之业。愿一切众生。得周普心。平等智慧。愿一切众生。于怨于亲。等心摄受。皆令安乐。智慧清净。愿一切众生。智慧圆满。净光普照。愿一切众生。思慧成满。了真实义。愿一切众生。以净志乐。趣求菩提。获无量智。愿一切众生。普能显示安隐住处。佛子。菩萨摩诃萨。恒以善心。如是回向。为令一切众生。遇清凉云。霔法雨故。为令一切众生。常值福田。胜境界故。为令一切众生。皆能善入菩提心藏。自护持故。为令一切众生。离诸盖缠。善安住故。为令一切众生。皆获无碍神通智故。为令一切众生。得自在身。普示现故。为令一切众生。成就最胜一切种智。普兴利益。无空过故。为令一切众生。普摄群品。令清净故。为令一切众生。皆能究竟一切智故。为令一切众生。心不动摇。无障碍故。佛子。菩萨摩诃萨。见可爱乐。国土园林。草木华果。名香上服。珍宝财物。诸庄严具。或见可乐村邑聚落。或见帝王威德自在。或见住处离诸諠杂。见是事已。以方便智。精勤修习。出生无量胜妙功德。为诸众生。勤求善法。心无放逸。广集众善。犹如大海。以无尽善。普覆一切。为众善法所依之处。以诸善根。方便回向。而无分别。开示无量种种善根。智常观察一切众生。心恒忆念善根境界。以等真如。平等善根。回向众生。无有休息。菩萨尔时。以诸善根。如是回向。所谓愿一切众生。得诸如来可爱乐见。见法真性。平等平等。无所取着。圆满清净。愿一切众生。见诸如来甚可爱乐。圆满供养。愿一切众生。往生一切无诸烦恼。甚可爱乐。清净佛刹。愿一切众生。得见诸佛可爱乐法。愿一切众生。常乐护持一切菩萨。可爱乐行。愿一切众生。得善知识可爱乐眼。见无所碍。愿一切众生。常见一切可爱乐物。无有违逆。愿一切众生。证得一切可爱乐法。而勤护持。愿一切众生。于一切佛可乐法中。得净光明。愿一切众生。修诸菩萨一切能舍可爱乐心。愿一切众生。得无所畏。能说一切可爱乐法。愿一切众生。得诸菩萨。极可爱乐。甚深三昧。愿一切众生。得诸菩萨。甚可爱乐。陀罗尼门。愿一切众生。得诸菩萨。甚可爱乐。善观察智。愿一切众生。能现菩萨。甚可爱乐。自在神通。愿一切众生。能于诸佛大众会中。说可爱乐甚深妙法。愿一切众生。能以方便。开示演说甚可爱乐差别之句。愿一切众生。常能发起甚可爱乐平等大悲。愿一切众生。念念发起甚可爱乐大菩提心。常令诸根。欢喜悦豫。愿一切众生。能入一切甚可爱乐诸如来家。愿一切众生。得可爱乐。能调伏行。调伏众生。无有休息。愿一切众生。得诸菩萨甚可爱乐。无尽辩才。演说诸法。愿一切众生。于不可说不可说劫。住于一切可乐世界。教化众生。心无厌倦。愿一切众生。以无量方便。普能悟入甚可爱乐诸佛法门。愿一切众生。得可爱乐无碍方便。知一切法无有根本。愿一切众生。得可爱乐离贪欲际。知一切法毕竟无二。断一切障。愿一切众生。得可爱乐离贪欲际。知一切法。平等真实。愿一切众生。具足成满一切菩萨。甚可爱乐。无戏论法。愿一切众生。得金刚藏精进之心。成可爱乐一切智道。愿一切众生。具可爱乐无碍善根。摧伏一切烦恼怨敌。愿一切众生。得可爱乐一切智门。普于世间。现成正觉。佛子。菩萨摩诃萨。修习如是诸善根时。得智慧明。为善知识之所摄受。如来慧日。明照其心。永灭痴冥。勤修正法。入诸智业。善学智地。流布善根。充满法界。以智回向。尽诸菩萨善根源底。以智深入大方便海。成就无量广大善根

佛子。菩萨摩诃萨。以此善根。如是回向。所谓不着世间。不取众生。其心清净。无所依止。正念诸法。离分别见。不舍一切。佛自在慧。不违三世一切诸佛。正回向门。随顺一切平等正法。不坏如来真实之相。等观三世。无众生相。善顺佛道。善说于法。深了其义。入最胜地。悟真实法。智慧圆满。信乐坚固。虽善修正业。而知业性空。了一切法皆如幻化。知一切法无有自性。观一切义及种种行。随世言说。而无所著。除灭一切执着因缘。知如实理。观诸法性。皆悉寂灭。了一切法同一实相。知诸法相。不相违背。与诸菩萨。而共同止。修行其道。善摄众生。入去来今一切菩萨。回向之门。于诸佛法。心无惊怖。以无量心。令诸众生。普得清净。于十方世界。不起执取我我所心。于诸世间。无所分别。于一切境界。不生染着。勤修一切出世间法。于诸世间。无取无依。于深妙道。正见牢固。离诸妄见。了真实法。譬如真如遍一切处。无有边际。善根回向亦复如是。遍一切处。无有边际。譬如真如真实为性。善根回向亦复如是。了一切法。真实为性。譬如真如恒守本性。无有改变。善根回向。亦复如是。守其本性。始终不改。譬如真如以一切法无性为性。善根回向亦复如是。了一切法。无性为性。譬如真如无相为相。善根回向亦复如是。了一切法。无相为相。譬如真如若有得者。终无退转。善根回向亦复如是。若有得者。于诸佛法。永不退转。譬如真如一切诸佛之所行处。善根回向亦复如是。一切如来所行之处。譬如真如离境界相。而为境界。善根回向亦复如是。离境界相。而为三世一切诸佛。圆满境界。譬如真如能有安立。善根回向亦复如是。悉能安立一切众生。譬如真如性常随顺。善根回向亦复如是。尽未来劫。随顺不断。譬如真如无能测量。善根回向亦复如是。等虚空界。尽众生心。无能测量。譬如真如充满一切。善根回向亦复如是。一刹那中。普周法界。譬如真如常住无尽。善根回向。亦复如是。究竟无尽。譬如真如无有比对。善根回向亦复如是。普能圆满一切佛法。无有比对。譬如真如体性坚固。善根回向亦复如是。体性坚固。非诸惑恼之所能沮。譬如真如不可破坏。善根回向亦复如是。一切众生。不能损坏。譬如真如照明为体。善根回向亦复如是。以普照明。而为其性。譬如真如无所不在。善根回向亦复如是。于一切处。悉无不在。譬如真如遍一切时。善根回向亦复如是。遍一切时。譬如真如性常清净。善根回向亦复如是。住于世间。而体清净。譬如真如于法无碍。善根回向亦复如是。周行一切。而无所碍。譬如真如为众法眼。善根回向亦复如是。能为一切众生作眼。譬如真如性无劳倦。善根回向亦复如是。修行一切菩萨诸行。恒无劳倦。譬如真如体性甚深。善根回向亦复如是。其性甚深。譬如真如无有一物。善根回向亦复如是。了知其性。无有一物。譬如真如性非出现。善根回向亦复如是。其体微妙。难可得见。譬如真如离众垢翳。善根回向亦复如是。慧眼清净。离诸痴翳。譬如真如性无与等。善根回向亦复如是。成就一切诸菩萨行。最上无等。譬如真如体性寂静。善根回向亦复如是。善能随顺寂静之法。譬如真如无有根本。善根回向亦复如是。能入一切无根本法。譬如真如体性无边。善根回向亦复如是。净诸众生。其数无边。譬如真如体性无著。善根回向亦复如是。毕竟远离一切诸着。譬如真如无有障碍。善根回向亦复如是。除灭一切世间障碍。譬如真如非世所行。善根回向亦复如是。非诸世间之所能行。譬如真如体性无住。善根回向亦复如是。一切生死。皆非所住。譬如真如性无所作。善根回向亦复如是。一切所作。悉皆舍离。譬如真如体性安住。善根回向亦复如是。安住真实。譬如真如与一切法。而共相应。善根回向亦复如是。与诸菩萨。听闻修习。而共相应。譬如真如一切法中。性常平等。善根回向亦复如是。于诸世间。修平等行。譬如真如不离诸法。善根回向亦复如是。尽未来际。不舍世间。譬如真如一切法中。毕竟无尽。善根回向亦复如是。于诸众生。回向无尽。譬如真如与一切法。无有相违。善根回向亦复如是。不违三世一切佛法。譬如真如普摄诸法。善根回向亦复如是。尽摄一切众生善根。譬如真如与一切法。同其体性。善根回向亦复如是。与三世佛。同一体性。譬如真如与一切法。不相舍离。善根回向亦复如是。摄持一切世出世法。譬如真如无能映蔽。善根回向亦复如是。一切世间。无能映蔽。譬如真如不可动摇。善根回向亦复如是。一切魔业。无能动摇。譬如真如性无垢浊。善根回向亦复如是。修菩萨行。无有垢浊。譬如真如无有变易。善根回向亦复如是。愍念众生。心无变易。譬如真如不可穷尽。善根回向亦复如是。非诸世法。所能穷尽。譬如真如性常觉悟。善根回向亦复如是。普能觉悟一切诸法。譬如真如不可失坏。善根回向亦复如是。于诸众生。起胜志愿。永不失坏。譬如真如能大照明。善根回向亦复如是。以大智光。照诸世间。譬如真如不可言说。善根回向亦复如是。一切言语。所不可说。譬如真如持诸世间。善根回向亦复如是。能持一切菩萨诸行。譬如真如随世言说。善根回向亦复如是。随顺一切智慧言说。譬如真如遍一切法。善根回向亦复如是。遍于十方一切佛刹。现大神通。成等正觉。譬如真如无有分别。善根回向亦复如是。于诸世间。无所分别。譬如真如遍一切身。善根回向亦复如是。遍十方刹。无量身中。譬如真如体性无生。善根回向亦复如是。方便示生。而无所生。譬如真如无所不在。善根回向亦复如是。十方三世。诸佛土中。普现神通。而无不在。譬如真如遍在于夜。善根回向亦复如是。于一切夜。放大光明。施作佛事。譬如真如遍在于昼。善根回向亦复如是。悉令一切在昼众生。见佛神变。演不退轮。离垢清净。无空过者。譬如真如遍在半月及以一月。善根回向亦复如是。于诸世间。次第时节。得善方便。于一念中。知一切时。譬如真如遍在年岁。善根回向亦复如是。住无量劫。明了成熟一切诸根。皆令圆满。譬如真如遍成坏劫。善根回向亦复如是。住一切劫。清净无染。教化众生。咸令清净。譬如真如尽未来际。善根回向亦复如是。尽未来际。修诸菩萨清净妙行。成满大愿。无有退转。譬如真如遍住三世。善根回向亦复如是。令诸众生。于一刹那。见三世佛。未曾一念。而有舍离。譬如真如遍一切处。善根回向亦复如是。超出三界。周行一切。悉得自在。譬如真如住有无法。善根回向亦复如是。了达一切有无之法。毕竟清净。譬如真如体性清净。善根回向亦复如是。能以方便。集助道法。净治一切。诸菩萨行。譬如真如体性明洁。善根回向亦复如是。令诸菩萨。悉得三昧明洁之心。譬如真如体性无垢。善根回向亦复如是。远离诸垢。满足一切。诸清净意。譬如真如。无我我所。善根回向亦复如是。以无我我所清净之心。充满十方诸佛国土。譬如真如体性平等。善根回向亦复如是。获得平等一切智智。照了诸法。离诸痴翳。譬如真如超诸数量。善根回向亦复如是。与超数量。一切智乘。大力法藏。而同止住。兴遍十方一切世界。广大法云。譬如真如平等安住。善根回向亦复如是。发生一切诸菩萨行。平等住于一切智道。譬如真如遍住一切诸众生界。善根回向亦复如是。满足无碍一切种智。于众生界。悉现在前。譬如真如。无有分别。普住一切音声智中。善根回向亦复如是。具足一切诸言音智。能普示现种种言音。开示众生。譬如真如永离世间。善根回向亦复如是。普使众生。永出世间。譬如真如体性广大。善根回向亦复如是。悉能受持去来今世。广大佛法。恒不忘失。勤修一切菩萨诸行。譬如真如无有间息。善根回向亦复如是。为欲安处一切众生于大智地。于一切劫。修菩萨行。无有间息。譬如真如体性宽广。遍一切法。善根回向亦复如是。净念无碍。普摄一切宽广法门。譬如真如遍摄群品。善根回向亦复如是。证得无量品类之智。修诸菩萨真实妙行。譬如真如无所取着。善根回向亦复如是。于一切法。皆无所取。除灭一切世间取着。普令清净。譬如真如体性不动。善根回向亦复如是。安住普贤。圆满行愿。毕竟不动。譬如真如是佛境界。善根回向亦复如是。令诸众生满足一切。大智境界。灭烦恼境。悉令清净。譬如真如无能制伏。善根回向亦复如是。不为一切众魔事业。外道邪论之所制伏。譬如真如非是可修。非不可修。善根回向亦复如是。舍离一切妄想取着。于修不修。无所分别。譬如真如无有退舍。善根回向亦复如是。常见诸佛。发菩提心。大誓庄严。永无退舍。譬如真如普摄一切世间言音。善根回向亦复如是。能得一切。差别言音。神通智慧。普发一切种种言辞。譬如真如于一切法。无所希求。善根回向亦复如是。令诸众生。乘普贤乘。而得出离。于一切法。无所贪求。譬如真如住一切地。善根回向亦复如是。令一切众生。舍世间地。住智慧地。以普贤行。而自庄严。譬如真如无有断绝。善根回向亦复如是。于一切法。得无所畏。随其类音。处处演说。无有断绝。譬如真如舍离诸漏。善根回向亦复如是。令一切众生。成就法智。了达于法。圆满菩提无漏功德。譬如真如无有少法而能坏乱。令其少分。非是觉悟。善根回向亦复如是。普令开悟一切诸法。其心无量。遍周法界。譬如真如过去非始。未来非末。现在非异。善根回向亦复如是。为一切众生。新新恒起菩提心愿。普使清净。永离生死。譬如真如于三世中。无所分别。善根回向亦复如是。现在念念。心常觉悟。过去未来。皆悉清净。譬如真如成就一切诸佛菩萨。善根回向亦复如是。发起一切大愿方便。成就诸佛广大智慧。譬如真如究竟清净。不与一切诸烦恼俱。善根回向亦复如是。能灭一切众生烦恼。圆满一切清净智慧。佛子。菩萨摩诃萨。如是回向时。得一切佛刹平等。普严净一切世界故。得一切众生平等。普为转无碍法轮故。得一切菩萨平等。普出生一切智愿故。得一切诸佛平等。观察诸佛。体无二故。得一切法平等。普知诸法性无易故。得一切世间平等。以方便智。善解一切语言道故。得一切菩萨行平等。随种善根。尽回向故。得一切时平等。勤修佛事。于一切时。无断绝故。得一切业果平等。于世出世所有善根。皆无染着。咸究竟故。得一切佛自在神通平等。随顺世间。现佛事故。佛子。是为菩萨摩诃萨第八真如相回向。菩萨摩诃萨。住此回向。证得无量清净法门。能为如来大师子吼。自在无畏。以善方便。教化成就无量菩萨。于一切时。未曾休息。得佛无量圆满之身。一身充遍一切世界。得佛无量圆满音声。一音开悟一切众生。得佛无量圆满之力。一毛孔中。普能容纳一切国土。得佛无量圆满神通。置诸众生于一尘中。得佛无量圆满解脱。于一众生身。示现一切诸佛境界。成等正觉。得佛无量圆满三昧。一三昧中。普能示现一切三昧。得佛无量圆满辩才。说一句法。穷未来际。而不可尽。悉除一切众生疑惑。得佛无量圆满众生。具佛十力。尽众生界。示成正觉。佛子。是为菩萨摩诃萨以一切善根顺真如相回向。尔时金刚幢菩萨。承佛威力。普观十方。而说颂言

  菩萨志乐常安住　　正念坚固离痴惑
  其心善软恒清凉　　积集无边功德行
  菩萨谦顺无违逆　　所有志愿悉清净
  已得智慧大光明　　善能照了一切业
  菩萨思惟业广大　　种种差别甚希有
  决意修行无退转　　以此饶益诸群生
  诸业差别无量种　　菩萨一切勤修习
  随顺众生不违意　　普令心净生欢喜
  已升调御人尊地　　离诸热恼心无碍
  于法于义悉善知　　为利群生转勤习
  菩萨所修众善行　　无量无数种种别
  于彼一切分别知　　为利群生故回向
  以妙智慧恒观察　　究竟广大真实理
  断诸有处悉无余　　如彼真如善回向
  譬如真如遍一切　　如是普摄诸世间
  菩萨以此心回向　　悉令众生无所著
  菩萨愿力遍一切　　譬如真如无不在
  若见不见念悉周　　悉以功德而回向
  夜中随住昼亦住　　半月一月亦随住
  若年若劫悉住中　　真如如是行亦然
  所有三世及刹土　　一切众生与诸法
  悉住其中无所住　　以如是行而回向
  譬如真如本自性　　菩萨如是发大心
  真如所在无不在　　以如是行而回向
  譬如真如本自性　　其中未曾有一法
  不得自性是真性　　以如是业而回向
  如真如相业亦尔　　如真如性业亦尔
  如真如性本真实　　业亦如是同真如
  譬如真如无边际　　业亦如是无有边
  而于其中无缚着　　是故此业得清净
  如是聪慧真佛子　　志愿坚固不动摇
  以其智力善通达　　入于诸佛方便藏
  觉悟法王真实法　　于中无著亦无缚
  如是自在心无碍　　未曾见有一法起
  如来法身所作业　　一切世间如彼相
  说诸法相皆无相　　知如是相是知法
  菩萨住是不思议　　于中思议不可尽
  入此不可思议处　　思与非思皆寂灭
  如是思惟诸法性　　了达一切业差别
  所有我执皆除灭　　住于功德无能动
  菩萨一切业果报　　悉为无尽智所印
  如是无尽自性尽　　是故无尽方便灭
  菩萨观心不在外　　亦复不得在于内
  知其心性无所有　　我法皆离永寂灭
  彼诸佛子如是知　　一切法性常空寂
  无有一法能造作　　同于诸佛悟无我
  了知一切诸世间　　悉与真如性相等
  见是不可思议相　　是则能知无相法
  若能住是甚深法　　常乐修行菩萨行
  为欲利益诸群生　　大誓庄严无退转
  是则超过于世间　　不起生死妄分别
  了达其心如幻化　　勤修众行度群生
  菩萨正念观世间　　一切皆从业缘得
  为欲救度修诸行　　普摄三界无遗者
  了知众生种种异　　悉是想行所分别
  于此观察悉明了　　而不坏于诸法性
  智者了知诸佛法　　以如是行而回向
  哀愍一切诸众生　　令于实法正思惟

大方广佛华严经卷第三十大方广佛华严经卷第三十一

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之九

佛子。云何为菩萨摩诃萨。无著无缚解脱回向。佛子。是菩萨摩诃萨。于一切善根。心生尊重。所谓于出生死。心生尊重。于摄取一切善根。心生尊重。于希求一切善根。心生尊重。于悔诸过业。心生尊重。于随喜善根。心生尊重。于礼敬诸佛。心生尊重。于合掌恭敬。心生尊重。于顶礼塔庙。心生尊重。于劝佛说法。心生尊重。于如是等种种善根。皆生尊重。随顺忍可。佛子。菩萨摩诃萨。于彼善根。皆生尊重。随顺忍可时。究竟欣乐。坚固信解。自得安住。令他安住。勤修无著。自在积集。成胜志乐。住如来境。势力增长。悉得知见。以诸善根。如是回向。所谓以无著无缚解脱心。成就普贤身业。以无著无缚解脱心。清净普贤语业。以无著无缚解脱心。圆满普贤意业。以无著无缚解脱心。发起普贤广大精进。以无著无缚解脱心。具足普贤无碍音声陀罗尼门。其声广大。普遍十方。以无著无缚解脱心。具足普贤见一切佛陀罗尼门。恒见十方一切诸佛。以无著无缚解脱心。成就解了一切音声陀罗尼门。同一切音。说无量法。以无著无缚解脱心。成就普贤一切劫住陀罗尼门。普于十方。修菩萨行。以无著无缚解脱心。成就普贤自在力。于一众生身中。示修一切菩萨行。尽未来劫。常无间断。如一众生身。一切众生身悉如是。以无著无缚解脱心。成就普贤自在力。普入一切众道场。普现一切诸佛前。修菩萨行。以无著无缚解脱心。成就普贤佛自在力。于一门中。示现经不可说不可说劫。无有穷尽。令一切众生。皆得悟入。以无著无缚解脱心。成就普贤佛自在力。于种种门中。示现经不可说不可说劫。无有穷尽。令一切众生。皆得悟入。其身普现一切佛前。以无著无缚解脱心。成就普贤自在力。念念中。令不可说不可说众生。住十力智。心无疲倦。以无著无缚解脱心。成就普贤自在力。于一切众生身中。现一切佛自在神通。令一切众生。住普贤行。以无著无缚解脱心。成就普贤自在力。于一一众生语言中。作一切众生语言。令一切众生。一一皆住一切智地。以无著无缚解脱心。成就普贤自在力。于一一众生身中。普容纳一切众生身。令皆自谓成就佛身。以无著无缚解脱心。成就普贤自在力。能以一华。庄严一切十方世界。以无著无缚解脱心。成就普贤自在力。出大音声。普遍法界。周闻一切诸佛国土。摄受调伏一切众生。以无著无缚解脱心。成就普贤自在力。尽未来际。不可说不可说劫。于念念中。悉能遍入一切世界。以佛神力。随念庄严。以无著无缚解脱心。成就普贤自在力。尽未来际。所住之劫。常能遍入一切世界。示现成佛。出兴于世。以无著无缚解脱心。成普贤行。一光普照尽虚空界一切世界。以无著无缚解脱心。成普贤行得无量智慧。具一切神通。说种种法。以无著无缚解脱心。成普贤行。入于如来尽一切劫。不可测量神通智慧。以无著无缚解脱心。成普贤行。住尽法界诸如来所。以佛神力。修习一切诸菩萨行。身口意业。曾无懈倦。以无著无缚解脱心。成普贤行。不违于义。不坏于法。言辞清净。乐说无尽。教化调伏一切众生。令其当得一切诸佛无上菩提。以无著无缚解脱心。修普贤行。入一法门时。放无量光。照不思议一切法门。如一法门。一切法门。皆亦如是。通达无碍。究竟当得一切智地。以无著无缚解脱心。住菩萨行。于法自在。到于普贤庄严彼岸。于一一境界。皆以一切智。观察悟入。而一切智。亦不穷尽。以无著无缚解脱心。始从此生。尽未来际。住普贤行。常不休息。得一切智。悟不可说不可说真实法。于法究竟。无有迷惑。以无著无缚解脱心。修普贤业。方便自在。得法光明。于诸菩萨所行之行。照了无碍。以无著无缚解脱心。修普贤行。得一切方便智。知一切方便。所谓无量方便。不思议方便。菩萨方便。一切智方便。一切菩萨调伏方便。转无量法轮方便。不可说时方便。说种种法方便。无边际无畏藏方便。说一切法无余方便。以无著无缚解脱心。住普贤行。成就身业。令一切众生。见者欢喜。不生诽谤。发菩提心。永不退转。究竟清净。以无著无缚解脱心。修普贤行。得了一切众生语言清净智一切言辞。具足庄严。普应众生。皆令欢喜。以无著无缚解脱心。住普贤行。立殊胜志。具清净心。得广大神通。广大智慧。普诣一切广大世间。广大国土。广大众生。所说一切如来。不可说广大法。广大庄严圆满藏。以无著无缚解脱心。成满普贤。回向行愿。得一切佛。清净身。清净心。清净解摄佛功德。住佛境界。智印普照。示现菩萨清净之业。善入一切差别句义。示诸佛菩萨广大自在。为一切众生。现成正觉。以无著无缚解脱心。勤修普贤诸根行愿。得聪利根。调顺根。一切法自在根。无尽根。勤修一切善根根。一切佛境界平等根。授一切菩萨不退转记大精进根。了知一切佛法金刚界根。一切如来智慧光照金刚焰根。分别一切诸根自在根。安立无量众生于一切智根。无边广大根。一切圆满根。清净无碍根。以无著无缚解脱心。修普贤行。得一切菩萨神力。所谓无量广大力神力。无量自在智神力。不动其身普现一切佛刹神力。无碍不断自在神力。普摄一切佛刹置于一处神力。一身遍满一切佛刹神力。无碍解脱游戏神力。无所作一念自在神力。住无性无依神力。一毛孔中次第安立不可说世界遍游法界诸佛道场示诸众生皆令得入大智慧门神力。以无著无缚解脱心。入普贤门。生菩萨行。以自在智。于一念顷。普入无量诸佛国土。一身容受无量佛刹。获能严净佛国土智。恒以智慧。观见无边诸佛国土。永不发起二乘之心。以无著无缚解脱心。修普贤方便行。入智慧境界。生如来家。住菩萨道。具足不可说不可说。无量不思议殊胜心。行无量愿。未曾休息。了知三世一切法界。以无著无缚解脱心。成就普贤清净法门。于一毛端量处。悉包容尽虚空遍法界不可说不可说一切国土。皆使明见。如一毛端量处。遍法界虚空界。一一毛端量处。悉亦如是。以无著无缚解脱心。成就普贤深心方便。于一念心中。现一众生不可说不可说劫念心。如是乃至。现一切众生尔许劫念心。以无著无缚解脱心。入普贤回向。行方便地。于一身中。悉能包纳尽法界不可说不可说身。而众生界。无所增减。如一身。乃至周遍法界一切身。悉亦如是。以无著无缚解脱心。成就普贤大愿方便。舍离一切想倒。心倒见倒。普入一切诸佛境界。常见诸佛。虚空界等。清净法身。相好庄严。神力自在。常以妙音。开示演说。无碍无断。令其闻者。如说受持。于如来身。了无所得。以无著无缚解脱心。修普贤行。住菩萨地。于一念中。入一切世界。所谓入仰世界。覆世界。不可说不可说十方网一切处广大世界。以因陀罗网。分别方便。普分别一切法界。以种种世界。入一世界。以不可说不可说无量世界。入一世界。以一切法界所安立无量世界。入一世界。以一切虚空界所安立无量世界。入一世界。而亦不坏安立之相。悉令明见。以无著无缚解脱心。修习普贤菩萨行愿。得佛灌顶。于一念中。入方便地。成满安住众行智宝。悉能了知一切诸想。所谓众生想。法想刹想。方想佛想。世想业想。行想界想。解想根想。时想持想。烦恼想清净想。成熟想见佛想。转法轮想。闻法解了想。调伏想无量想。出离想。种种地想。无量地想。菩萨了知想。菩萨修习想。菩萨三昧想。菩萨三昧起想。菩萨成想。菩萨坏想。菩萨没想。菩萨生想。菩萨解脱想。菩萨自在想。菩萨住持想。菩萨境界想。劫成坏想。明想闇想。昼想夜想。半月一月。一时一岁。变异想。去想来想。住想坐想。睡想觉想。如是等想。于一念中。悉能了知。而离一切想。无所分别。断一切障。无所执着。一切佛智。充满其心。一切佛法。长其善根。与诸如来。等同一身。一切诸佛之所摄取。离垢清净。一切佛法。皆随修学。到于彼岸。以无著无缚解脱心。为一切众生。修普贤行。生大智宝。于一一心中。知无量心。随其依止。随其分别。随其种性。随其所作。随其业用。随其相状。随其思觉。种种不同。靡不明见。以无著无缚解脱心。成就普贤大愿智宝。于一处中。知于无量不可说处。如于一处。于一切处。悉亦如是。以无著无缚解脱心。修习普贤行业智地。于一业中。能知无量不可说不可说业。其业各以种种缘造。明了知见。如于一业。于一切业。悉亦如是。以无著无缚解脱心。修习普贤知诸法智。于一法中。知不可说不可说法。于一切法中。而知一法。如是诸法。各各差别。无有障碍。无违无著。以无著无缚解脱心。住菩萨行。得具普贤无碍耳根。于一言音中。知不可说不可说言音。无量无边。种种差别。而无所著。如于一言音。于一切言音。悉亦如是。以无著无缚解脱心。修普贤智。起普贤行。住普贤地。于一一法中。演说不可说不可说法。其法广大。种种差别。教化摄受。不可思议方便相应。于无量时。于一切时。随诸众生。所有欲解。随根随时。以佛音声。而为说法。以一妙音。令不可说道场众会。无量众生。皆悉欢喜。一如来所无量菩萨。充满法界。立殊胜志。生广大见。究竟了知一切诸行。住普贤地。随所说法。于念念中。悉能证入一刹那顷。增长无量不可说不可说大智慧聚。尽未来劫。如是演说。于一切刹。修习广大虚空等行。成就圆满。以无著无缚解脱心。修习普贤诸根行门。成大行王。于一一根中。悉能了知无量诸根。无量心乐。不思议境界。所生妙行。以无著无缚解脱心。住普贤行。大回向心。得色甚微细智。身甚微细智。刹甚微细智。劫甚微细智。世甚微细智。方甚微细智。时甚微细智。数甚微细智。业报甚微细智。清净甚微细智。如是等一切甚微细。于一念中。悉能了知。而心不恐怖。心不迷惑。不乱不散。不浊不劣。其心一缘。心善寂定。心善分别。心善安住。以无著无缚解脱心。住菩萨智。修普贤行。无有懈倦。能知一切众生趣甚微细。众生死甚微细。众生生甚微细。众生住甚微细。众生处甚微细。众生品类甚微细。众生境界甚微细。众生行甚微细。众生取甚微细。众生攀缘甚微细。如是等一切甚微细。于一念中。悉能了知。以无著无缚解脱心。立深志乐。修普贤行。能知一切菩萨。从初发心。为一切众生。修菩萨行甚微细。菩萨住处甚微细。菩萨神通甚微细。菩萨游行无量佛刹甚微细。菩萨法光明甚微细。菩萨清净眼甚微细。菩萨成就殊胜心甚微细。菩萨往诣一切如来道场众会甚微细。菩萨陀罗尼门智甚微细。菩萨无量无畏地一切辩才藏演说甚微细。菩萨无量三昧相甚微细。菩萨见一切佛三昧智甚微细。菩萨甚深三昧智甚微细。菩萨大庄严三昧智甚微细。菩萨法界三昧智甚微细。菩萨大自在神通三昧智甚微细。菩萨尽未来际广大行住持三昧智甚微细。菩萨出生无量差别三昧智甚微细。菩萨出生一切诸佛前勤修供养恒不舍离三昧智甚微细。菩萨修行一切甚深广博无障无碍三昧智甚微细。菩萨究竟一切智地住持行智地大神通地决定义地离翳三昧智甚微细。如是等一切甚微细。悉能了知。以无著无缚解脱心。修普贤行。悉知一切菩萨安立智甚微细。菩萨地甚微细。菩萨无量行甚微细。菩萨出生回向甚微细。菩萨得一切佛藏甚微细。菩萨观察智甚微细。菩萨神通愿力甚微细。菩萨演说三昧甚微细。菩萨自在方便甚微细。菩萨印甚微细。菩萨一生补处甚微细。菩萨生兜率天甚微细。菩萨住止天宫甚微细。菩萨严净佛国甚微细。菩萨观察人中甚微细。菩萨放大光明甚微细。菩萨种族殊胜甚微细。菩萨道场众会甚微细。菩萨遍一切世界受生甚微细。菩萨于一身示现一切身命终甚微细。菩萨入母胎甚微细。菩萨住母胎甚微细。菩萨在母胎中自在示现一切法界道场众会甚微细。菩萨在母胎中示现一切佛神力甚微细。菩萨示现诞生事甚微细。菩萨师子游行七步智甚微细。菩萨示处王宫巧方便智甚微细。菩萨出家修调伏行甚微细。菩萨菩提树下坐道场甚微细。菩萨破魔军众成阿耨多罗三藐三菩提甚微细。如来坐菩提座放大光明照十方界甚微细。如来示现无量神变甚微细。如来师子吼大涅槃甚微细。如来调伏一切众生而无所碍甚微细。如来不思议自在力如金刚菩提心甚微细。如来普护念一切世间境界甚微细。如来普于一切世界施作佛事尽未来劫而无休息甚微细。如来无碍神力周遍法界甚微细。如来于尽虚空界一切世界普现成佛调伏众生甚微细。如来于一佛身现无量佛身甚微细。如来于去来今三世中皆处道场自在智甚微细。如是等一切微细。悉能了知。成就清净。普能示现一切世间。于念念中。增长智慧。圆满不退。善巧方便。修菩萨行。无有休息。成就普贤回向之地。具足一切如来功德。永不厌舍菩萨所行。出生菩萨现前境界。无量方便。皆悉清净。普欲安隐一切众生。修菩萨行。成就菩萨大威德地。得诸菩萨心之乐欲。获金刚幢回向之门。出生法界诸功德藏。常为诸佛之所护念。入诸菩萨。深妙法门。演说一切。真实之义。于法善巧。无所违失。起大誓愿。不舍众生。于一念中。尽知一切。心非心地。境界之藏。于非心处。示生于心远离语言。安住智慧。同诸菩萨。所行之行。以自在力。示成佛道。尽未来际。常无休息。一切世间。众生劫数。妄想言说之所建立。神通愿力。悉能示现。以无著无缚解脱心。修普贤行。得一切众生界甚微细智。所谓众生界分别甚微细智。众生界言说甚微细智。众生界执着甚微细智。众生界异类甚微细智。众生界同类甚微细智。众生界无量趣甚微细智。众生界不思议。种种分别所作甚微细智。众生界无量杂染甚微细智。众生界无量清净甚微细智。如是等一切众生界境界甚微细。于一念中。能以智慧。皆如实知。广摄众生。而为说法。开示种种清净法门。令修菩萨广大智慧。化身无量。见者欢喜。以智日光。照菩萨心。令其开悟智慧自在。以无著无缚解脱心。为一切众生。于一切世界。修普贤行。得尽虚空界法界。一切世界。甚微细智。所谓小世界甚微细智。大世界甚微细智。杂染世界甚微细智。清净世界甚微细智。无比世界甚微细智。种种世界甚微细智。广世界甚微细智。狭世界甚微细智。无碍庄严世界甚微细智。遍一切世界佛出现甚微细智。遍一切世界说正法甚微细智。遍一切世界普现身甚微细智。遍一切世界放大光明甚微细智。尽一切世界示现诸佛自在神通甚微细智。尽一切世界以一音声。示一切音甚微细智。入一切世界一切佛刹道场众会甚微细智。以一切法界佛刹作一佛刹甚微细智。以一佛刹作一切法界佛刹甚微细智。知一切世界如梦甚微细智。知一切世界如像甚微细智。知一切世界如幻甚微细智。如是了知。出生一切。菩萨之道。入普贤行。智慧神通。具普贤观。修菩萨行。常无休息。得一切佛。自在神变。具无碍身。住无依智。于诸善法。无所取着。心之所行。悉无所得。于一切处。起远离想。于菩萨行。起净修想。于一切智。无取着想。以诸三昧。而自庄严。智慧随顺一切法界。以无著无缚解脱心。入普贤菩萨行门。得无量法界甚微细智。演说一切法界甚微细智。入广大法界甚微细智。分别不思议法界甚微细智。分别一切法界甚微细智。一念遍一切法界甚微细智。普入一切法界甚微细智。知一切法界无所得甚微细智。观一切法界无所碍甚微细智。知一切法界无有生甚微细智。于一切法界现神变甚微细智。如是等一切法界甚微细。以广大智。皆如实知。于法自在。示普贤行。令诸众生。皆悉满足。不舍于义。不着于法。出生平等无碍之智。知无碍本。不住一切法。不坏诸法性。如实无染。犹若虚空。随顺世间。起于言说。开真实义。示寂灭性。于一切境无依无住。无有分别。明见法界。广大安立。了诸世间。及一切法。平等无二。离一切着。以无著无缚解脱心。修普贤行。生诸劫甚微细智。所谓以不可说劫为一念甚微细智。以一念为不可说劫甚微细智。以阿僧祇劫。入一劫甚微细智。以一劫入阿僧祇劫甚微细智。以长劫入短劫甚微细智。以短劫入长劫甚微细智。入有佛劫无佛劫甚微细智。知一切劫数甚微细智。知一切劫非劫甚微细智。一念中见三世一切劫甚微细智。如是等一切诸劫甚微细以如来智。于一念中。皆如实知。得诸菩萨。圆满行王心。入普贤行心。离一切分别异道戏论心。发大愿无懈息心。普见无量世界网无量诸佛充满心。于诸佛善根诸菩萨行能闻持心。于安慰一切众生广大行闻已不忘心。能于一切劫现佛出世心。于一一世界尽未来际行不动行无休息心。于一切世界中以如来身业充满菩萨身心。以无著无缚解脱心。修普贤行。成不退转。得一切法甚微细智。所谓甚深法甚微细智。广大法甚微细智。种种法甚微细智。庄严法甚微细智。一切法无有量甚微细智。一切法入一法甚微细智。一法入一切法甚微细智。一切法入非法甚微细智。无法中安立一切法而不相违甚微细智。入一切佛法方便无有余甚微细智。如是等一切世界。一切言说。所安立法。诸微细智。与彼同等。其智无碍。皆如实知。得入无边法界心。于一一法界。深心坚住。成无碍行。以一切智。充满诸根。入诸佛智。正念方便。成就诸佛广大功德。遍满法界。普入一切诸如来身。现诸菩萨。所有身业。随顺一切世界言辞。演说于法。得一切佛神力所加。智慧意业。出生无量。善巧方便。分别诸法。萨婆若智。以无著无缚解脱心。修普贤行。出生一切甚微细智。所谓。知一切刹甚微细智。知一切众生甚微细智。知一切法果报甚微细智。知一切众生心甚微细智。知一切说法时甚微细智。知一切法界甚微细智。知一切尽虚空界三世甚微细智。知一切语言道甚微细智。知一切世间行甚微细智。知一切出世行甚微细智。乃至知一切如来道一切菩萨道一切众生道甚微细智。修菩萨行。住普贤道。若文若义。皆如实知。生如影智。生如梦智。生如幻智。生如响智。生如化智。生如空智。生寂灭智。生一切法界智。生无所依智。生一切佛法智。佛子。菩萨摩诃萨。以无著无缚解脱心回向。不分别若世间。若世间法。不分别若菩提。若菩提萨埵。不分别若菩萨行。若出离道。不分别若佛。若一切佛法。不分别若调伏众生。若不调伏众生。不分别若善根。若回向。不分别若自若他。不分别若施物。若受施者。不分别若菩萨行。若等正觉。不分别若法若智。佛子。菩萨摩诃萨。以彼善根。如是回向。所谓心无著无缚解脱。身无著无缚解脱。口无著无缚解脱。业无著无缚解脱。报无著无缚解脱。世间无著无缚解脱。佛刹无著无缚解脱。众生无著无缚解脱。法无著无缚解脱。智无著无缚解脱。菩萨摩诃萨。如是回向时。如三世诸佛。为菩萨时。所修回向。而行回向。学过去诸佛回向。成未来诸佛回向。住现在诸佛回向。安住过去诸佛回向道。不舍未来诸佛回向道。随顺现在诸佛回向道。勤修过去诸佛教。成就未来诸佛教。了知现在诸佛教。满足过去诸佛平等。成就未来诸佛平等。安住现在诸佛平等。行过去诸佛境界。住未来诸佛境界。等现在诸佛境界。得三世一切诸佛善根。具三世一切诸佛种性。住三世一切诸佛所行。顺三世一切诸佛境界。佛子。是为菩萨摩诃萨第九无著无缚解脱心回向。菩萨摩诃萨。住此回向时。一切金刚轮围山。所不能坏。于一切众生中。色相第一。无能及者。悉能摧破诸魔邪业。普现十方一切世界。修菩萨行。为欲开悟一切众生。以善方便。说诸佛法。得大智慧。于诸佛法。心无迷惑。在在生处。若行若住。常得值遇不坏眷属。三世诸佛。所说正法。以清净念。悉能受持。尽未来劫。修菩萨行。常不休息。无所依着。普贤行愿。增长具足。得一切智。施作佛事。成就菩萨自在神通。尔时金刚幢菩萨。承佛神力。普观十方。而说颂言

  普于十方无等尊　　未曾一起轻慢心
  随其所修功德业　　亦复恭敬生尊重
  所修一切诸功德　　不为自己及他人
  恒以最上信解心　　利益众生故回向
  未尝暂起高慢心　　亦复不生下劣意
  如来所有身等业　　彼悉请问勤修习
  所修种种诸善根　　悉为利益诸含识
  安住深心广大解　　回向人尊功德位
  世间所有无量别　　种种善巧奇特事
  粗细广大及甚深　　靡不修行皆了达
  世间所有种种身　　以身平等入其中
  于此修行得了悟　　慧门成就无退转
  世间国土无量种　　微细广大仰覆别
  菩萨能以智慧门　　一毛孔中无不见
  众生心行无有量　　能令平等入一心
  以智慧门悉开悟　　于所修行不退转
  众生诸根及欲乐　　上中下品各不同
  一切甚深难可知　　随其本性悉能了
  众生所有种种业　　上中下品各差别
  菩萨深入如来力　　以智慧门普明见
  不可思议无量劫　　能令平等入一念
  如是见已遍十方　　修行一切清净业
  过去未来及现在　　了知其相各不同
  而亦不违平等理　　是则大心明达行
  世间众生行不同　　或显或隐无量种
  菩萨悉知差别相　　亦知其相皆无相
  十方世界一切佛　　所现自在神通力
  广大难可得思议　　菩萨悉能分别知
  一切世界兜率中　　自然觉悟人师子
  功德广大净无等　　如其体相悉能见
  或现降神处母胎　　无量自在大神变
  成佛说法示灭度　　普遍世间无暂已
  人中师子初生时　　一切胜智悉承奉
  诸天帝释梵王等　　靡不恭敬而瞻侍
  十方一切无有余　　无量无边法界中
  无始无末无遐迩　　示现如来自在力
  人中尊导现生已　　游行诸方各七步
  欲以妙法悟群生　　是故如来普观察
  见诸众生沈欲海　　盲暗愚痴之所覆
  人中自在现微笑　　念当救彼三有苦
  大师子吼出妙音　　我为世间第一尊
  应然明净智慧灯　　灭彼生死愚痴闇
  人师子王出世时　　普放无量大光明
  令诸恶道皆休息　　永灭世间众苦难
  或时示现处王宫　　或现舍家修学道
  为欲饶益众生故　　示其如是自在力
  如来始坐道场时　　一切大地皆动摇
  十方世界悉蒙光　　六趣众生咸离苦
  震动一切魔宫殿　　开悟十方众生心
  昔曾受化及修行　　皆使了知真实义
  十方所有诸国土　　悉入毛孔无有余
  一切毛孔刹无边　　于彼普现神通力
  一切诸佛所开演　　无量方便皆随悟
  设诸如来所不说　　亦能解了勤修习
  遍满三千大千界　　一切魔军兴斗诤
  所作无量种种恶　　无碍智门能悉灭
  如来或在诸佛刹　　或复现处诸天宫
  或在梵宫而现身　　菩萨悉见无障碍
  佛现无量种种身　　转于清净妙法轮
  乃至三世一切劫　　求其边际不可得
  宝座高广最无等　　遍满十方无量界
  种种妙相而庄严　　佛处其上难思议
  诸佛子众共围绕　　尽于法界悉周遍
  开示菩提无量行　　一切最胜所由道
  诸佛随宜所作业　　无量无边等法界
  智者能以一方便　　一切了知无不尽
  诸佛自在神通力　　示现一切种种身
  或现诸趣无量生　　或现采女众围绕
  或于无量诸世界　　示现出家成佛道
  乃至最后般涅槃　　分布其身起塔庙
  如是种种无边行　　导师演说佛所住
  世尊所有大功德　　誓愿修行悉令尽
  以彼善根回向时　　住于如是方便法
  如是修习菩提行　　其心毕竟无厌怠
  如来所有大神通　　及以无边胜功德
  乃至世间诸智行　　一切悉知无不尽
  如是一切人中主　　随其所有诸境界
  于一念中皆了悟　　而亦不舍菩提行
  诸佛所有微细行　　及一切刹种种法
  于彼悉能随顺知　　究竟回向到彼岸
  有数无数一切劫　　菩萨了知即一念
  于此善入菩提行　　常勤修习不退转
  十方所有无量刹　　或有杂染或清净
  及彼一切诸如来　　菩萨悉能分别知
  于念念中悉明见　　不可思议无量劫
  如是三世无有余　　具足修治菩萨行
  于一切心平等入　　入一切法亦平等
  尽空佛刹斯亦然　　彼最胜行悉了知
  出生众生及诸法　　所有种种诸智慧
  菩萨神力亦复然　　如是一切无穷尽
  诸微细智各差别　　菩萨尽摄无有余
  同知异相悉善知　　如是修行广大行
  十方无量诸佛刹　　其中众生各无量
  趣生族类种种殊　　住行力已悉能知
  过去未来现在世　　所有一切诸导师
  若人知此而回向　　则与彼佛行平等
  若人能修此回向　　则为学佛所行道
  当得一切佛功德　　及以一切佛智慧
  一切世间莫能坏　　一切所学皆成就
  常能忆念一切佛　　常见一切世间灯
  菩萨胜行不可量　　诸功德法亦如是
  已住如来无上行　　悉知诸佛自在力

大方广佛华严经卷第三十一大方广佛华严经卷第三十二

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之十

佛子。云何为菩萨摩诃萨。等法界无量回向。佛子。此菩萨摩诃萨。以离垢缯。而系其顶。住法师位。广行法施。起大慈悲。安立众生于菩提心。常行饶益。无有休息。以菩提心。长养善根。为诸众生。作调御师。示诸众生。一切智道。为诸众生。作法藏日。善根光明。普照一切。于诸众生。其心平等。修诸善行。无有休息。心净无染。智慧自在。不舍一切善根道业。作诸众生大智商主。普令得入安隐正道。为诸众生。而作导首。令修一切善根法行。为诸众生。作不可坏坚固善友。令其善根。增长成就。佛子。此菩萨摩诃萨。以法施为首。发生一切清净白法。摄受趣向一切智心。殊胜愿力。究竟坚固。成就增益。具大威德。依善知识。心无谄诳。思惟观察一切智门。无边境界。以此善根。如是回向。愿得修习。成就增长。广大无碍。一切境界。愿得于佛正教之中。乃至听闻一句一偈。受持演说。愿得忆念。与法界等。无量无边。一切世界。去来现在。一切诸佛。既忆念已。修菩萨行。又愿以此念佛善根。为一众生。于一世界。尽未来劫。修菩萨行。如于一世界。尽法界虚空界。一切世界。皆亦如是。如为一众生。为一切众生。亦复如是。以善方便。一一皆为尽未来劫。大誓庄严。终无离佛善知识想。常见诸佛。现在其前。无有一佛。出兴于世。不得亲近。一切诸佛。及诸菩萨。所赞所说。清净梵行。誓愿修行。悉令圆满。所谓不破梵行。不缺梵行。不杂梵行。无点梵行。无失梵行。无能蔽梵行。佛所赞梵行。无所依梵行。无所得梵行。增益菩萨清净梵行。三世诸佛所行梵行。无碍梵行。无著梵行。无诤梵行。无灭梵行。安住梵行。无比梵行。无动梵行。无乱梵行。无恚梵行。佛子。菩萨摩诃萨。若能为己。修行如是清净梵行。则能普为一切众生。令一切众生。皆得安住。令一切众生。皆得开晓。令一切众生。皆得成就。令一切众生。皆得清净。令一切众生。皆得无垢。令一切众生。皆得照明。令一切众生。离诸尘染。令一切众生。无诸障翳。令一切众生。离诸热恼。令一切众生。离诸缠缚。令一切众生。永离诸恶。令一切众生。无诸恼害。毕竟清净。何以故。菩萨摩诃萨。自于梵行。不能清净。不能令他。而得清净。自于梵行。而有退转。不能令他。无有退转。自于梵行。而有失坏。不能令他。无有失坏。自于梵行。而有远离。不能令他。常不远离。自于梵行。而有懈怠。不能令他。不生懈怠。自于梵行。不生信解。不能令他。心生信解。自于梵行。而不安住。不能令他。而得安住。自于梵行。而不证入。不能令他。心得证入。自于梵行。而有放舍。不能令他。恒不放舍。自于梵行。而有散动。不能令他。心不散动。何以故。菩萨摩诃萨。住无倒行。说无倒法。所言诚实。如说修行。净身口意。离诸杂染。住无碍行。灭一切障。菩萨摩诃萨。自得净心。为他演说。清净心法。自修和忍。以诸善根。调伏其心。令他和忍。以诸善根。调伏其心。自离疑悔。亦令他人。永离疑悔。自得净信。亦令他得不坏净信。自住正法。亦令众生。安住正法。佛子。菩萨摩诃萨。复以法施。所生善根。如是回向。所谓愿我获得一切诸佛无尽法门。普为众生。分别解说。皆令欢喜。心得满足。摧灭一切外道异论。愿我能为一切众生。演说三世诸佛法海。于一一法生起。一一法义理。一一法名言。一一法安立。一一法解说。一一法显示。一一法门户。一一法悟入。一一法观察。一一法分位。悉得无边无尽法藏。获无所畏。具四辩才。广为众生。分别解说。穷未来际。而无有尽。为欲令一切众生。立胜志愿。出生无碍。无谬失辩。为欲令一切众生。皆生欢喜。为欲令一切众生。成就一切净法光明。随其类音。演说无断。为欲令一切众生。深信欢喜。住一切智。辨了诸法。俾无迷惑。作是念言。我当普于一切世界。为诸众生。精勤修习。得遍法界无量自在身。得遍法界无量广大心。具等法界无量清净音声。现等法界无量众会道场。修等法界无量菩萨业。得等法界无量菩萨住。证等法界无量菩萨平等。学等法界无量菩萨法。住等法界无量菩萨行。入等法界无量菩萨回向。是为菩萨摩诃萨以诸善根而为回向。为令众生。悉得成就一切智故。佛子。菩萨摩诃萨。复以善根。如是回向。所谓为欲见等法界无量诸佛。调伏等法界无量众生。住持等法界无量佛刹。证等法界无量菩萨智。获等法界无量无所畏。成等法界无量诸菩萨陀罗尼。得等法界无量诸菩萨不思议住。具等法界无量功德。满等法界无量利益众生善根。又愿以此善根故。令我得福德平等。智慧平等。力平等。无畏平等。清净平等。自在平等。正觉平等。说法平等。义平等。决定平等。一切神通平等。如是等法皆悉圆满。如我所得。愿一切众生。亦如是得。如我无异。佛子。菩萨摩诃萨。复以善根。如是回向。所谓如法界无量善根回向。亦复如是。所得智慧。终无有量。如法界无边善根回向。亦复如是。见一切佛。无有其边。如法界无限善根回向。亦复如是。诣诸佛刹。无有齐限。如法界无际善根回向。亦复如是。于一切世界。修菩萨行。无有涯际。如法界无断善根回向。亦复如是。住一切智。永不断绝。如法界一性善根回向。亦复如是。与一切众生。同一智性。如法界自性清净善根回向。亦复如是。令一切众生。究竟清净。如法界随顺善根回向。亦复如是。令一切众生。悉皆随顺普贤行愿。如法界庄严善根回向。亦复如是。令一切众生。以普贤行。而为庄严。如法界不可失坏善根回向。亦复如是。令诸菩萨。永不失坏诸清净行。佛子。菩萨摩诃萨。复以此善根。如是回向。所谓愿以此善根。承事一切诸佛菩萨。皆令欢喜。愿以此善根。速得趣入一切智性。愿以此善根。遍一切处。修一切智。愿以此善根。令一切众生。常得往觐一切诸佛。愿以此善根。令一切众生。常见诸佛。能作佛事。愿以此善根。令一切众生。恒得见佛。不于佛事生怠慢心。愿以此善根。令一切众生。常得见佛。心喜清净。无有退转。愿以此善根。令一切众生。常得见佛。心善解了。愿以此善根。令一切众生。常得见佛。不生执着。愿以此善根。令一切众生。常得见佛。了达无碍。愿以此善根。令一切众生。常得见佛。成普贤行。愿以此善根。令一切众生。常见诸佛。现在其前。无时暂舍。愿以此善根。令一切众生。常见诸佛。出生菩萨无量诸力。愿以此善根。令一切众生。常见诸佛。于一切法。永不忘失。佛子。菩萨摩诃萨。又以诸善根。如是回向。所谓如法界无起性回向。如法界根本性回向。如法界自体性回向。如法界无依性回向。如法界无忘失性回向。如法界空无性回向。如法界寂静性回向。如法界无处所性回向。如法界无迁动性回向。如法界无差别性回向。佛子。菩萨摩诃萨。复以法施。所有宣示。所有开悟。及因此起一切善根。如是回向。所谓愿一切众生。成菩萨法师。常为诸佛之所护念。愿一切众生。作无上法师。方便安立一切众生于一切智。愿一切众生。作无屈法师。一切问难。莫能穷尽。愿一切众生。作无碍法师。得一切法。无碍光明。愿一切众生。作智藏法师。能善巧说一切佛法。愿一切众生。成诸如来。自在法师。善能分别如来智慧。愿一切众生。作如眼法师。说如实法。不由他教。愿一切众生。作忆持一切佛法法师。如理演说。不违句义。愿一切众生。作修行无相道法师。以诸妙相。而自庄严。放无量光。善入诸法。愿一切众生。作大身法师。其身普遍一切国土。兴大法云。雨诸佛法。愿一切众生。作护法藏法师。建无胜幢。护诸佛法。令正法海。无所缺减。愿一切众生。作一切法日法师。得佛辩才。巧说诸法。愿一切众生。作妙音方便法师。善说无边法界之藏。愿一切众生。作到法彼岸法师。以智神通。开正法藏。愿一切众生。作安住正法法师。演说如来究竟。智慧。愿一切众生。作了达诸法法师。能说无量无尽功德。愿一切众生。作不诳世间法师。能以方便。令入实际。愿一切众生。作破诸魔众法师。善能觉知一切魔业。愿一切众生。作诸佛所摄受法师。离我我所。摄受之心。愿一切众生。作安隐一切世间法师。成就菩萨说法愿力。佛子。菩萨摩诃萨。复以诸善根。如是回向。所谓不以取着业故回向。不以取着报故回向。不以取着心故回向。不以取着法故回向。不以取着事故回向。不以取着因故回向。不以取着语言音声故回向。不以取著名句文身故回向。不以取着回向故回向。不以取着利益众生故回向。佛子。菩萨摩诃萨。复以善根。如是回向。所谓不为耽着色境界故回向。不为耽着声香味触法境界故回向。不为求生天故回向。不为求欲乐故回向。不为着欲境界故回向。不为求眷属故回向。不为求自在故回向。不为求生死乐故回向。不为着生死故回向。不为乐诸有故回向。不为求和合乐故回向。不为求可乐着处故回向。不为怀毒害心故回向。不坏善根故回向。不依三界故回向。不着诸禅解脱三昧故回向。不住声闻辟支佛乘故回向。但为教化调伏一切众生故回向。但为成满一切智智故回向。但为得无碍智故回向。但为得无障碍清净善根故回向。但为令一切众生。超出生死。证大智慧故回向。但为令大菩提心。如金刚。不可坏故回向。但为成就究竟不死法故回向。但为以无量庄严。庄严佛种性。示现一切智。自在故回向。但为求菩萨一切法明。大神通智故回向。但为于尽法界虚空界。一切佛刹。行普贤行。圆满不退。被坚固大愿铠。令一切众生。住普贤地故回向。但为尽未来劫。度脱众生。常无休息。示现一切智地。无碍光明。恒不断故回向。佛子。菩萨摩诃萨。以彼善根。回向时。以如是心回向。所谓以本性平等心回向。以法性平等心回向。以一切众生无量平等心回向。以无诤平等心回向。以自性无所起平等心回向。以知诸法无乱心回向。以入三世平等心回向。以出生三世诸佛种性心回向。以得不退失神通心回向。以生成一切智行心回向。又为令一切众生。永离一切地狱故回向。为令一切众生。不入畜生趣故回向。为令一切众生。不往阎罗王处故回向。为令一切众生。除灭一切障道法故回向。为令一切众生。满足一切善根故回向。为令一切众生。能应时转法轮。令一切欢喜故回向。为令一切众生。入十力轮故回向。为令一切众生。满足菩萨无边清净法愿故回向。为令一切众生。随顺一切善知识教。菩提心器。得满足故回向。为令一切众生。受持修行甚深佛法。得一切佛智光明故回向。为令一切众生。修诸菩萨无障碍行。常现前故回向。为令一切众生。常见诸佛。现其前故回向。为令一切众生。清净法光明。常现前故回向。为令一切众生。无畏大菩提心。常现前故回向。为令一切众生。菩萨不思议智。常现前故回向。为令一切众生。普救护众生。令清净大悲心。常现前故回向。为令一切众生。以不可说不可说。胜妙庄严具。庄严一切诸佛刹故回向。为令一切众生。摧灭一切众魔斗诤。罗网业故回向。为令一切众生。于一切佛刹。皆无所依。修菩萨行故回向。为令一切众生。发一切种智心。入一切佛法广大门故回向。佛子。菩萨摩诃萨。又以此善根。正念清净回向。智慧决定回向。尽知一切佛法方便回向。为成就无量无碍智故回向。欲满足清净。殊胜心故回向。为一切众生住大慈故回向。为一切众生住大悲故回向。为一切众生住大喜故回向。为一切众生住大舍故回向。为永离二着住胜善根故回向。为思惟观察分别演说一切缘起法故回向。为立大勇猛幢心故回向。为立无能胜幢藏故回向。为破诸魔众故回向。为得一切法清净无碍心故回向。为修一切菩萨行不退转故回向。为得乐求第一胜法心故回向。为得乐求诸功德法自在清净一切智智心故回向。为满一切愿除一切诤。得佛自在无碍清净法。为一切众生。转不退法轮故回向。为得如来。最上殊胜法智慧日。百千光明之所庄严。普照一切法界众生故回向。为欲调伏一切众生随其所乐。常令满足。不舍本愿。尽未来际。听闻正法。修习大行。得净智慧。离垢光明。断除一切憍慢消灭一切烦恼。裂爱欲网。破愚痴闇。具足无垢。无障碍法故回向。为一切众生。于阿僧祇劫。常勤修习一切智行。无有退转。一一令得无碍妙慧。示现诸佛。自在神通。无有休息故回向。佛子。菩萨摩诃萨。以诸善根。如是回向时。不应贪着三有。五欲境界。何以故。菩萨摩诃萨。应以无贪善根回向。应以无嗔善根回向。应以无痴善根回向。应以不害善根回向。应以离慢善根回向。应以不谄善根回向。应以质直善根回向。应以精勤善根回向。应以修习善根回向。佛子。菩萨摩诃萨。如是回向时。得净信心。于菩萨行。欢喜忍受。修习清净大菩萨道。具佛种性。得佛智慧。舍一切恶。离众魔业。亲近善友。成己大愿。请诸众生。设大施会。佛子。菩萨摩诃萨。复以此法施。所生善根。如是回向。所谓令一切众生。得净妙音。得柔软音。得天鼓音。得无量无数不思议音。得可爱乐音。得清净音。得周遍一切佛刹音。得百千那由他不可说。功德庄严音。得高远音。得广大音。得灭一切散乱音。得充满法界音。得摄取一切众生语言音。得一切众生。无边音声智。得一切清净语言音声智。得无量语言音声智。得最自在音。入一切音声智。得一切清净庄严音。得一切世间无厌足音。得究竟不系属一切世间音。得欢喜音。得佛清净语言音。得说一切佛法。远离痴翳。名称普闻音。得令一切众生。得一切法。陀罗尼庄严音。得说一切无量种法音。得普至法界。无量众会道场音。得普摄持不可思议法。金刚句音。得开示一切法音。得能说不可说。字句差别智藏音。得演说一切法。无所著不断音。得一切法。光明照耀音。得能令一切世间。清净究竟。至于一切智音。得普摄一切法句义音。得神力护持。自在无碍音。得到一切世间。彼岸智音。又以此善根。令一切众生。得不下劣音。得无怖畏音。得无染着音。得一切众会。道场欢喜音。得随顺美妙音。得善说一切佛法音。得断一切众生疑念。皆令觉悟音。得具足辩才音。得普觉悟一切众生。长夜睡眠音。佛子。菩萨摩诃萨。复以诸善根。如是回向。所谓愿一切众生。得离众过恶。清净法身。愿一切众生。得离众过恶。净妙功德。愿一切众生。得离众过恶。清净妙相。愿一切众生。得离众过恶。清净业果。愿一切众生。得离众过恶。清净一切智心。愿一切众生。得离众过恶。无量清净菩提心。愿一切众生。得离众过恶。了知诸根。清净方便。愿一切众生。得离众过恶。清净信解。愿一切众生。得离众过恶。清净勤修。无碍行愿。愿一切众生。得离众过恶。清净正念。智慧辩才。佛子。菩萨摩诃萨。复以诸善根。为一切众生。如是回向。愿得种种清净妙身。所谓光明身。离浊身。无染身。清净身极清净身。离尘身。极离尘身。离垢身。可爱乐身。无障碍身。于一切世界。现诸业像。于一切世间。现言说像。于一切宫殿。现安立像。如净明镜。种种色像。自然显现。示诸众生。大菩提行。示诸众生。甚深妙法。示诸众生。种种功德。示诸众生。修行之道。示诸众生。成就之行。示诸众生。菩萨行愿。示诸众生。于一世界。一切世界。佛兴于世。示诸众生一切诸佛。神通变化。示诸众生。一切菩萨。不可思议。解脱威力。示诸众生。成满普贤菩萨行愿。一切智性。菩萨摩诃萨。以如是等。微妙净身方便摄取一切众生。悉令成就清净功德一切智身。佛子。菩萨摩诃萨。复以法施。所生善根。如是回向。愿身随住一切世界。修菩萨行。众生见者。皆悉不虚。发菩提心。永无退转。顺真实义。不可倾动。于一切世界。尽未来劫。住菩萨道。而无疲厌。大悲均普。量同法界。知众生根。应时说法。常不休息。于善知识。心常正念。乃至不舍一刹那顷。一切诸佛。常现在前。心常正念。未曾暂懈。修诸善根。无有虚伪。置诸众生于一切智。令不退转。具足一切佛法光明。持大法云。受大法雨。修菩萨行。入一切众生。入一切佛刹。入一切诸法。入一切三世。入一切众生业报智。入一切菩萨。善巧方便智。入一切菩萨出生智。入一切菩萨。清净境界智。入一切佛。自在神通。入一切无边法界。于此安住。修菩萨行

大方广佛华严经卷第三十二大方广佛华严经卷第三十三

        于阗国三藏实叉难陀奉　制译

    十回向品第二十五之十一

佛子。菩萨摩诃萨。复以法施。所修善根。如是回向。愿一切佛刹。皆悉清净。以不可说不可说庄严具。而庄严之。一一佛刹。其量广大。同于法界。纯善无碍。清净光明。诸佛于中。现成正觉。一佛刹中。清净境界。悉能显现一切佛刹。如一佛刹。一切佛刹。亦复如是。其一一刹。悉以等法界。无量无边。清净妙宝。庄严之具。而为严饰。所谓阿僧祇清净宝座敷众宝衣。阿僧祇宝帐宝网垂布。阿僧祇宝盖一切妙宝互相映彻。阿僧祇宝云普雨众宝。阿僧祇宝华周遍清净。阿僧祇众宝所成栏楯轩槛清净庄严。阿僧祇宝铃常演诸佛微妙音声周流法界。阿僧祇宝莲华种种宝色开敷荣耀。阿僧祇宝树周匝行列无量妙宝以为华果。阿僧祇宝宫殿无量菩萨止住其中。阿僧祇宝楼阁广博崇丽延袤远近。阿僧祇宝却敌大宝所成庄严妙好。阿僧祇宝门闼妙宝璎珞周匝垂布。阿僧祇宝窗牖不思议宝清净庄严。阿僧祇宝多罗形如半月众宝集成。如是一切。悉以众宝而为严饰。离垢清净。不可思议。无非如来善根所起。具足无数宝藏庄严。复有阿僧祇宝河流出一切清净善法。阿僧祇宝海法水盈满。阿僧祇宝芬陀利华常出妙法芬陀利声。阿僧祇宝须弥山智慧山王秀出清净。阿僧祇八楞妙宝宝线贯穿严净无比。阿僧祇净光宝常放无碍大智光明普照法界。阿僧祇宝铃铎更相扣击出妙音声。阿僧祇清净宝诸菩萨宝具足充满。阿僧祇宝缯彩处处垂下色相光洁。阿僧祇妙宝幢以宝半月而为严饰。阿僧祇宝幡悉能普雨无量宝幡。阿僧祇宝带垂布空中庄严殊妙。阿僧祇宝敷具能生种种微细乐触。阿僧祇妙宝旋示现菩萨一切智眼。阿僧祇宝璎珞一一璎珞百千菩萨上妙庄严。阿僧祇宝宫殿。超过一切妙绝无比。阿僧祇宝庄严具金刚摩尼以为严饰。阿僧祇种种妙宝庄严具常现一切清净妙色。阿僧祇清净宝殊形异彩光鉴映彻。阿僧祇宝山以为垣墙周匝围绕清净无碍。阿僧祇宝香其香普熏一切世界。阿僧祇宝化事一一化事周遍法界。阿僧祇宝光明一一光明现一切光。复有阿僧祇宝光明。清净智光。照了诸法。复有阿僧祇无碍宝光明。一一光明。周遍法界。有阿僧祇宝处。一切诸宝。皆悉具足。阿僧祇宝藏。开示一切正法藏宝。阿僧祇宝幢。如来幢相。回然高出。阿僧祇宝贤。大智贤像。具足清净。阿僧祇宝园。生诸菩萨。三昧快乐。阿僧祇宝音。如来妙音。普示世间。阿僧祇宝形。其一一形。皆放无量妙法光明。阿僧祇宝相。其一一相。悉超众相。阿僧祇宝威仪。见者皆生菩萨喜乐。阿僧祇宝聚。见者皆生智慧宝聚。阿僧祇宝安住。见者皆生善住宝心。阿僧祇宝衣服。其有著者。生诸菩萨无比三昧。阿僧祇宝袈裟。其有著者。才始发心。则得善见陀罗尼门。阿僧祇宝修习。其有见者。知一切宝。皆是业果。决定清净。阿僧祇宝无碍知见。其有见者。得了一切清净法眼。阿僧祇宝光藏。其有见者。则得成就大智慧藏。阿僧祇宝座。佛坐其上。大师子吼。阿僧祇宝灯。常放清净智慧光明。阿僧祇宝多罗树。次第行列。缭以宝绳。庄严清净。其树复有阿僧祇宝干。从身耸擢。端直圆洁。阿僧祇宝枝。种种众宝。庄严稠密。不思议鸟。翔集其中。常吐妙音。宣扬正法。阿僧祇宝叶。放大智光。遍一切处。阿僧祇宝华。一一华上。无量菩萨。结跏趺坐。遍游法界。阿僧祇宝果。见者当得一切智智。不退转果。阿僧祇宝聚落。见者舍离世聚落法。阿僧祇宝都邑。无碍众生。于中盈满。阿僧祇宝宫殿。王处其中。具足菩萨那罗延身。勇猛坚固。被法甲胄。心无退转。阿僧祇宝舍。入者能除恋舍宅心。阿僧祇宝衣。著者能令解了无著。阿僧祇宝宫殿。出家菩萨。充满其中。阿僧祇宝珍玩。见者咸生无量欢喜。阿僧祇宝轮。放不思议智慧光明。转不退轮。阿僧祇宝跋陀树。因陀罗网。庄严清净。阿僧祇宝地。不思议宝。间错庄严。阿僧祇宝吹。其音清亮。充满法界。阿僧祇宝鼓。妙音克谐。穷劫不绝。阿僧祇宝众生。尽能摄持无上法宝。阿僧祇宝身。具足无量功德妙宝。阿僧祇宝口。常演一切妙法宝音。阿僧祇宝心。具清净意。大智愿宝。阿僧祇宝念。断诸愚惑。究竟坚固一切智宝。阿僧祇宝明。诵持一切诸佛法宝。阿僧祇宝慧。决了一切诸佛法藏。阿僧祇宝智。得大圆满。一切智宝。阿僧祇宝眼。鉴十力宝。无所障碍。阿僧祇宝耳。听闻无量。尽法界声。清净无碍。阿僧祇宝鼻。常嗅随顺。清净宝香。阿僧祇宝舌。能说无量诸语言法。阿僧祇宝身。遍游十方。而无挂碍。阿僧祇宝意。常勤修习普贤行愿。阿僧祇宝音。净妙音声。遍十方界。阿僧祇宝身业。一切所作。以智为首。阿僧祇宝语业。常说修行无碍智宝。阿僧祇宝意业。得无障碍。广大智宝。究竟圆满。佛子。菩萨摩诃萨。于彼一切诸佛刹中。于一佛刹。一方一处。一毛端量。有无量无边不可说数。诸大菩萨。皆悉成就清净智慧。充满而住。如一佛刹。一方一处。一毛端量。如是。尽虚空遍法界。一一佛刹。一一方。一一处。一一毛端量。悉亦如是。是为菩萨摩诃萨以诸善根而为回向。普愿一切诸佛国土。悉具种种妙宝庄严。如宝庄严。如是广说。如是香庄严。华庄严。鬘庄严。涂香庄严。烧香庄严。末香庄严。衣庄严。盖庄严。幢庄严。幡庄严。摩尼宝庄严。次第乃至过此百倍。皆如宝庄严。如是广说。佛子。菩萨摩诃萨。以法施等。所集善根。为长养一切善根故回向。为严净一切佛刹故回向。为成就一切众生故回向。为令一切众生。皆心净不动故回向。为令一切众生。皆入甚深佛法故回向。为令一切众生。皆得无能过。清净功德故回向。为令一切众生。皆得不可坏。清净福力故回向。为令一切众生。皆得无尽智力。度诸众生。令入佛法故回向。为令一切众生。皆得平等。无量清净言音故回向。为令一切众生。皆得平等无碍眼。成就尽虚空遍法界等智慧故回向。为令一切众生。皆得清净念。知前际劫一切世界故回向。为令一切众生。皆得无碍大智慧。悉能决了一切法藏故回向。为令一切众生。皆得无限量大菩提。周遍法界。无所障碍故回向。为令一切众生。皆得平等无分别同体善根故回向。为令一切众生。皆得一切功德。具足庄严。清净身语意业故回向。为令一切众生。皆得同于普贤行故回向。为令一切众生。皆得入一切同体清净佛刹故回向。为令一切众生。悉观察一切智。皆趣入圆满故回向。为令一切众生。皆得远离不平等善根故回向。为令一切众生。皆得平等无异相。深心次第。圆满一切智故回向。为令一切众生。皆得安住一切白法故回向。为令一切众生。皆于一念中。证一切智。得究竟故回向。为令一切众生。皆成满清净一切智道故回向。佛子。菩萨摩诃萨。以诸善根。普为一切众生。如是回向已。复以此善根。欲普圆满。演说一切清净行法力故回向。欲成就清净行威力。得不可说不可说法海故回向。欲于一一法海。具足无量等法界。清净智光明故回向。欲开示演说一切法差别句义故回向。欲成就无边广大。一切法光明三昧故回向。欲随顺三世诸佛辩才故回向。欲成就去来现在。一切佛自在身故回向。为尊重一切佛可爱乐无障碍法故回向。为满足大悲心。救护一切众生。常无退转故回向。欲成就不思议差别法。无障碍智心。无垢染诸根清净。普入一切众会道场故回向。欲于一切若覆若仰。若粗若细。若广若狭。小大染净。如是等诸佛国土。常转平等不退法轮故回向。欲于念念中。得无所畏。无有穷尽。种种辩才。妙法光明。开示演说故回向。为乐求众善。发心修习。诸根转胜。获一切法。大神通智。尽能了知一切诸法故回向。欲于一切众会道场。亲近供养。为一切众生。演一切法。咸令欢喜故回向。佛子。菩萨摩诃萨。又以此善根。如是回向。所谓以住法界无量住回向。以住法界无量身业回向。以住法界无量语业回向。以住法界无量意业回向。以住法界无量色平等回向。以住法界无量受想行识平等回向。以住法界无量蕴平等回向。以住法界无量界平等回向。以住法界无量处平等回向。以住法界无量内平等回向。以住法界无量外平等回向。以住法界无量发起平等回向。以住法界无量深心平等回向。以住法界无量方便平等回向。以住法界无量信解平等回向。以住法界无量诸根平等回向。以住法界无量初中后际平等回向。以住法界无量业报平等回向。以住法界无量染净平等回向。以住法界无量众生平等回向。以住法界无量佛刹平等回向。以住法界无量法平等回向。以住法界无量世间光明平等回向。以住法界无量诸佛菩萨平等回向。以住法界无量菩萨行愿平等回向。以住法界无量菩萨出离平等回向。以住法界无量菩萨教化调伏平等回向。以住法界无量法界无二平等回向。以住法界无量如来众会道场平等回向。佛子。菩萨摩诃萨。如是回向时。安住法界无量平等清净身。安住法界无量平等清净语。安住法界无量平等清净心。安住法界无量平等诸菩萨清净行愿。安住法界无量平等清净众会道场。安住法界无量平等为一切菩萨广说诸法清净智。安住法界无量平等能入尽法界一切世界身。安住法界无量平等一切法光明清净无畏。能以一音。尽断一切众生疑网。随其根欲。皆令欢喜。住于无上一切种智。力无所畏。自在神通。广大功德。出离法中。佛子。是为菩萨摩诃萨第十住等法界无量回向。菩萨摩诃萨。以法施等一切善根。如是回向时。成满普贤无量无边。菩萨行愿。悉能严净尽虚空等法界。一切佛刹。令一切众生。亦得如是具足成就无边智慧。了一切法。于念念中。见一切佛出兴于世。于念念中。见一切佛无量无边自在力。所谓广大自在力。无著自在力。无碍自在力。不思议自在力。净一切众生自在力。立一切世界自在力。现不可说语言自在力。随时应现自在力。住不退转神通智自在力。演说一切无边法界俾无有余自在力。出生普贤菩萨无边际眼自在力。以无碍耳识闻持无量诸佛正法自在力。一身结跏趺坐周遍十方无量法界于诸众生无所迫隘自在力。以圆满智普入三世无量法自在力。又得无量清净。所谓一切众生清净。一切佛刹清净。一切法清净。一切处遍知智清净。遍虚空界无边智清净。得一切差别言音智。以种种言音。普应众生清净。放无量圆满光。普照一切无边世界清净。出生一切三世菩萨行智清净。一念中普入三世一切诸佛众会道场智清净。入无边一切世间。令一切众生。皆作所应作清净。如是等。皆得具足。皆得成就。皆已修治。皆得平等。皆悉现前。皆悉知见。皆悉悟入。皆已观察。皆得清净。到于彼岸。尔时。佛神力故。十方各百万佛刹微尘数世界。六种震动。所谓动。遍动。等遍动。起。遍起。等遍起。涌。遍涌。等遍涌。震。遍震。等遍震。吼。遍吼。等遍吼。击。遍击。等遍击。佛神力故。法如是故。雨众天华。天鬘天末香。天诸杂香。天衣服。天珍宝。天庄严具。天摩尼宝。天沉水香。天栴檀香。天上妙盖。天种种幢。天杂色幡。阿僧祇诸天身。无量百千亿不可说天妙法音。不可思议天赞佛音。阿僧祇天欢喜音。咸称善哉。无量阿僧祇百千那由他诸天。恭敬礼拜。无数天子。常念诸佛。希求如来。无量功德。心不舍离。无数天子。作众妓乐。歌咏赞叹。供养如来。百千阿僧祇诸天。放大光明。普照尽虚空遍法界。一切佛刹。现无量阿僧祇。诸佛境界。如来化身。出过诸天。如于此世界兜率陀天宫说如是法。周遍十方。一切世界。兜率天宫。悉亦如是。尔时。复以佛神力故。十方各过百万佛刹。微尘数世界外。各有百万佛刹。微尘数诸菩萨。而来集会。周遍十方。咸作是言。善哉善哉。佛子。乃能说此诸大回向。佛子我等。皆同一号。名金刚幢。悉从金刚光世界。金刚幢佛所。来诣此土。彼诸世界。悉以佛神力故。而说是法。众会眷属。文辞句义。皆亦如是。不增不减。我等皆承佛神力。从彼土来。为汝作证。如我来此众会为汝作证。十方所有。一切世界。兜率天宫。宝庄严殿。诸菩萨众。来为作证。亦复如是

尔时金刚幢菩萨。承佛神力。观察十方。一切众会。暨于法界已。善知文义。增广大心。大悲普覆一切众生。系心安住三世佛种。善入一切佛功德法。成就诸佛自在之身。观诸众生心之所乐。及其所种。一切善根。悉分别知随顺法身。为现清净妙色之身。即于是时。而说颂曰

  菩萨成就法智慧　　悟解无边正法门
  为法光明调御师　　了知无碍真实法
  菩萨为法大导师　　开示甚深难得法
  引导十方无量众　　悉令安住正法中
  菩萨已饮佛法海　　法云普雨十方界
  法日出现于世间　　阐扬妙法利群生
  常为难遇法施主　　了知入法巧方便
  法光清净照其心　　于世说法恒无畏
  善修于法自在心　　悉能悟入诸法门
  成就甚深妙法海　　普为众生击法鼓
  宣说甚深希有法　　以法长养诸功德
  具足清净法喜心　　示现世间佛法藏
  诸佛法王所灌顶　　成就法性智藏身
  悉能解了法实相　　安住一切众善法
  菩萨修行第一施　　一切如来所赞喜
  所作皆蒙佛忍可　　以此成就人中尊
  菩萨成就妙法身　　亲从诸佛法化生
  为利众生作法灯　　演说无量最胜法
  随所修行妙法施　　则亦观察彼善根
  所作众善为众生　　悉以智慧而回向
  所有成佛功德法　　悉以回施诸群生
  愿令一切皆清净　　到佛庄严之彼岸
  十方佛刹无有量　　悉具无量大庄严
  如是庄严不可思　　尽以庄严一国土
  如来所有清净智　　愿令众生皆具足
  犹如普贤真佛子　　一切功德自庄严
  成就广大神通力　　往诣世界悉周遍
  一切众生无有余　　皆使修行菩萨道
  诸佛如来所开悟　　十方无量诸众生
  一切皆令如普贤　　具足修行最上行
  诸佛菩萨所成就　　种种差别诸功德
  如是功德无有边　　愿使众生悉圆满
  菩萨具足自在力　　所应学处皆往学
  示现一切大神通　　普诣十方无量土
  菩萨能于一念顷　　觐等众生无数佛
  又复于一毛端中　　尽摄诸法皆明见
  世间众生无有量　　菩萨悉能分别知
  诸佛无量等众生　　大心供养咸令尽
  种种名香上妙华　　众宝衣裳及幡盖
  分布法界咸充满　　发心普供十方佛
  一毛孔中悉明见　　不思议数无量佛
  一切毛孔皆如是　　普礼一切世间灯
  举身次第恭敬礼　　如是无边诸最胜
  亦以言辞普称赞　　穷尽未来一切劫
  一如来所供养具　　其数无量等众生
  如是供养一如来　　一切如来亦复然
  供养赞叹诸如来　　尽彼世间一切劫
  世间劫数可终尽　　菩萨供养无休懈
  一切世间种种劫　　于尔所劫修诸行
  恭敬供养一如来　　尽一切劫无厌足
  如无量劫供一佛　　供一切佛皆如是
  亦不分别是劫数　　于所供养生疲厌
  法界广大无边际　　菩萨观察悉明了
  以大莲华遍布中　　施等众生无量佛
  宝华香色皆圆满　　清净庄严甚微妙
  一切世间无可谕　　持以供养人中尊
  众生数等无量刹　　诸妙宝盖满其中
  悉以供养一如来　　供一切佛皆如是
  涂香无比最殊胜　　一切世间未曾有
  以此供养天人师　　穷尽众生数等劫
  末香烧香上妙华　　众宝衣服庄严具
  如是供养诸最胜　　欢喜奉事无厌足
  等众生数照世灯　　念念成就大菩提
  亦以无边偈称述　　供养人中调御者
  如众生数佛世尊　　皆修无上妙供养
  如众生数无量劫　　如是赞叹无穷尽
  如是供养诸佛时　　以佛神力皆周遍
  悉见十方无量佛　　安住普贤菩萨行
  过去未来及现在　　所有一切诸善根
  令我常修普贤行　　速得安住普贤地
  一切如来所知见　　世间无量诸众生
  悉愿具足如普贤　　为聪慧者所称赞
  此是十方诸大士　　共所修治回向行
  诸佛如来为我说　　此回向行最无上
  十方世界无有余　　其中一切诸众生
  莫不咸令得开觉　　悉使常如普贤行
  如其回向行布施　　亦复坚持于禁戒
  精进长时无退怯　　忍辱柔和心不动
  禅定持心常一缘　　智慧了境同三昧
  去来现在皆通达　　世间无有得其边
  菩萨身心及语业　　如是所作皆清净
  一切修行无有余　　悉与普贤菩萨等
  譬如法界无分别　　戏论染着皆永尽
  亦如涅槃无障碍　　心常如是离诸取
  智者所有回向法　　诸佛如来已开示
  种种善根悉回向　　是故能成菩萨道
  佛子善学此回向　　无量行愿悉成满
  摄取法界尽无余　　是故能成善逝力
  若欲成就佛所说　　菩萨广大殊胜行
  宜应善住此回向　　是诸佛子号普贤
  一切众生犹可数　　三世心量亦可知
  如是普贤诸佛子　　功德边际无能测
  一毛度空可得边　　众刹为尘可知数
  如是大仙诸佛子　　所住行愿无能量

大方广佛华严经卷第三十三大方广佛华严经卷第三十四

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之一

尔时世尊。在他化自在天王宫摩尼宝藏殿。与大菩萨众俱。其诸菩萨。皆于阿耨多罗三藐三菩提。不退转。悉从他方世界来集。住一切菩萨智所住境。入一切如来智所入处。勤行不息。善能示现种种神通。诸所作事。教化调伏一切众生。而不失时。为成菩萨。一切大愿。于一切世。一切劫一切刹。勤修诸行。无暂懈息。具足菩萨。福智助道。普益众生。而恒不匮。到一切菩萨。智慧方便。究竟彼岸。示入生死。及以涅槃。而不废舍。修菩萨行。善入一切菩萨。禅定解脱三昧。三摩钵底。神通明智。诸所施为。皆得自在。获一切菩萨自在神力。于一念顷。无所动作。悉能往诣一切如来。道场众会。为众上首。请佛说法。护持诸佛正法之轮。以广大心。供养承事一切诸佛。常勤修习一切菩萨。所行事业。其身普现一切世间。其音普及十方法界。心智无碍。普见三世。一切菩萨。所有功德。悉已修行。而得圆满。于不可说劫。说不能尽。其名曰。金刚藏菩萨。宝藏菩萨。莲华藏菩萨。德藏菩萨。莲华德藏菩萨。日藏菩萨。苏利耶藏菩萨。无垢月藏菩萨。于一切国土普现庄严藏菩萨。毗卢遮那智藏菩萨。妙德藏菩萨。栴檀德藏菩萨。华德藏菩萨。俱苏摩德藏菩萨。优钵罗德藏菩萨。天德藏菩萨。福德藏菩萨。无碍清净智德藏菩萨。功德藏菩萨。那罗延德藏菩萨。无垢藏菩萨。离垢藏菩萨。种种辩才庄严藏菩萨。大光明网藏菩萨。净威德光明王藏菩萨。金庄严大功德光明王藏菩萨。一切相庄严净德藏菩萨。金刚焰德相庄严藏菩萨。光明焰藏菩萨。星宿王光照藏菩萨。虚空无碍智藏菩萨。妙音无碍藏菩萨。陀罗尼功德持一切众生愿藏菩萨。海庄严藏菩萨。须弥德藏菩萨。净一切功德藏菩萨。如来藏菩萨。佛德藏菩萨。解脱月菩萨。如是等。无数无量。无边无等。不可数不可称。不可思不可量。不可说。诸菩萨摩诃萨众。金刚藏菩萨。而为上首

尔时金刚藏菩萨。承佛神力。入菩萨大智慧光明三昧。入是三昧已。即时十方。各过十亿佛刹微尘数世界外。各有十亿佛刹微尘数诸佛。同名金刚藏。而现其前。作如是言。善哉善哉。金刚藏。乃能入是菩萨大智慧光明三昧。善男子。此是十方。各十亿佛刹。微尘数诸佛。共加于汝。以毗卢遮那如来。应正等觉。本愿力故。威神力故。亦是汝胜智力故。欲令汝为一切菩萨。说不思议诸佛法光明故。所谓令入智地故。摄一切善根故。善拣择一切佛法故。广知诸法故。善能说法故。无分别智清净故。一切世法不染故。出世善根清净故。得不思议智境界故。得一切智人智境界故。又令得菩萨十地始终故。如实说菩萨十地。差别相故。缘念一切佛法故。修习分别无漏法故。善选择观察大智光明巧庄严故。善入决定智门故。随所住处。次第显说。无所畏故。得无碍辩才光明故。住大辩才地。善决定故。忆念菩萨。心不忘失故。成熟一切众生界故。能遍至一切处。决定开悟故。善男子。汝当辩说此法门。差别善巧法。所谓承佛神力。如来智明所加故。净自善根故。普净法界故。普摄众生故。深入法身智身故。受一切佛灌顶故。得一切世间。最高大身故。超一切世间道故。清净出世善根故。满足一切智智故。尔时十方诸佛。与金刚藏菩萨。无能映夺身。与无碍乐说辩。与善分别清净智。与善忆念不忘力。与善决定明了慧。与至一切处开悟智。与成道自在力。与如来无所畏。与一切智人观察分别诸法门辩才智。与一切如来上妙身语意具足庄严。何以故。得此三昧法如是故。本愿所起故。善净深心故。善净智轮故。善积集助道故。善修治所作故。念其无量法器故。知其清净信解故。得无错谬总持故。法界智印善印故

尔时十方诸佛。各伸右手。摩金刚藏菩萨顶。摩顶已。金刚藏菩萨。从三昧起。普告一切菩萨众言。诸佛子。诸菩萨。愿善决定。无杂不可见。广大如法界。究竟如虚空。尽未来际。遍一切佛刹。救护一切众生。为一切诸佛所护。入过去未来。现在诸佛智地。佛子。何等为菩萨摩诃萨智地。佛子。菩萨摩诃萨智地。有十种。过去未来。现在诸佛。已说。当说。今说。我亦如是说。何等为十。一者欢喜地。二者离垢地。三者发光地。四者焰慧地。五者难胜地。六者现前地。七者远行地。八者不动地。九者善慧地。十者法云地。佛子。此菩萨十地。三世诸佛。已说。当说。今说。佛子。我不见有诸佛国土。其中如来。不说此十地者。何以故。此是菩萨摩诃萨。向菩提最上道。亦是清净法光明门。所谓分别演说菩萨诸地。佛子。此处不可思议。所谓诸菩萨随证智

尔时金刚藏菩萨。说此菩萨十地名已。默然而住。不复分别。是时一切菩萨众。闻菩萨十地名。不闻解释。咸生渴仰。作如是念。何因何缘。金刚藏菩萨。唯说菩萨十地名。而不解释。解脱月菩萨。知诸大众心之所念。以颂问金刚藏菩萨曰

  何故净觉人　　念智功德具
  说诸上妙地　　有力不解释
  一切咸决定　　勇猛无怯弱
  何故说地名　　而不为开演
  诸地妙义趣　　此众皆欲闻
  其心无怯弱　　愿为分别说
  众会悉清净　　离懈怠严洁
  能坚固不动　　具功德智慧
  相视咸恭敬　　一切悉专仰
  如蜂念好蜜　　如渴思甘露

尔时大智无所畏金刚藏菩萨。闻说是已。欲令众会。心欢喜故。为诸佛子。而说颂言

  菩萨行地事　　最上诸佛本
  显示分别说　　第一希有难
  微细难可见　　离念超心地
  出生佛境界　　闻者悉迷惑
  持心如金刚　　深信佛胜智
  知心地无我　　能闻此胜法
  如空中彩画　　如空中风相
  牟尼智如是　　分别甚难见
  我念佛智慧　　最胜难思议
  世间无能受　　默然而不说

尔时解脱月菩萨。闻是说已。白金刚藏菩萨言。佛子。今此众会。皆悉已集。善净深心。善洁思念。善修诸行。善集助道。善能亲近百千亿佛。成就无量。功德善根。舍离痴惑。无有垢染。深心信解。于佛法中。不随他教。善哉佛子。当承佛神力。而为演说。此诸菩萨。于如是等。甚深之处。皆能证知。尔时解脱月菩萨。欲重宣其义。而说颂曰

  愿说最安隐　　菩萨无上行
  分别于诸地　　智净成正觉
  此众无诸垢　　志解悉明洁
  承事无量佛　　能知此地义

尔时金刚藏菩萨言。佛子。虽此众集。善净思念。舍离愚痴。及以疑惑。于甚深法。不随他教。然有其余。劣解众生。闻此甚深难思议事。多生疑惑。于长夜中。受诸衰恼。我愍此等。是故默然。尔时金刚藏菩萨。欲重宣其义。而说颂曰

  虽此众净广智慧　　甚深明利能决择
  其心不动如山王　　不可倾覆犹大海
  有行未久解未得　　随识而行不随智
  闻此生疑堕恶道　　我愍是等故不说

尔时解脱月菩萨。重白金刚藏菩萨言。佛子。愿承佛神力。分别说此不思议法。此人当得如来护念。而生信受。何以故。说十地时。一切菩萨。法应如是。得佛护念。得护念故。于此智地。能生勇猛。何以故。此是菩萨。最初所行。成就一切诸佛法故。譬如书字。数说一切。皆以字母为本。字母究竟。无有少分离字母者。佛子。一切佛法。皆以十地为本。十地究竟。修行成就。得一切智。是故佛子。愿为演说。此人必为如来所护。令其信受。尔时解脱月菩萨。欲重宣其义。而说颂曰

  善哉佛子愿演说　　趣入菩提诸地行
  十方一切自在尊　　莫不护念智根本
  此安住智亦究竟　　一切佛法所从生
  譬如书数字母摄　　如是佛法依于地

尔时诸大菩萨众。一时同声。向金刚藏菩萨。而说颂言

  上妙无垢智　　无边分别辩
  宣畅深美言　　第一义相应
  念持清净行　　十力集功德
  辩才分别义　　说此最胜地
  定戒集正心　　离我慢邪见
  此众无疑念　　惟愿闻善说
  如渴思冷水　　如饥念美食
  如病忆良药　　如蜂贪好蜜
  我等亦如是　　愿闻甘露法
  善哉广大智　　愿说入诸地
  成十力无碍　　善逝一切行

尔时世尊。从眉间出清净光明。名菩萨力焰明。百千阿僧祇光明。以为眷属。普照十方。一切世界。靡不周遍。三恶道苦。皆得休息。又照一切如来众会。显现诸佛。不思议力。又照十方。一切世界。一切诸佛。所加说法。菩萨之身。作是事已。于上虚空中。成大光明云网台而住。时十方诸佛。悉亦如是。从眉间出清净光明。其光名号。眷属作业。悉同于此。又亦照此娑婆世界。佛及大众。并金刚藏菩萨身。师子座已。于上虚空中。成大光明云网台。时光台中。以诸佛威神力故。而说颂言

  佛无等等如虚空　　十力无量胜功德
  人间最胜世中上　　释师子法加于彼
  佛子当承诸佛力　　开此法王最胜藏
  诸地广智胜妙行　　以佛威神分别说
  若为善逝力所加　　当得法宝入其心
  诸地无垢次第满　　亦具如来十种力
  虽住海水劫火中　　堪受此法必得闻
  其有生疑不信者　　永不得闻如是义
  应说诸地胜智道　　入住展转次修习
  从行境界法智生　　利益一切众生故

尔时金刚藏菩萨。观察十方。欲令大众。增净信故。而说颂曰

  如来大仙道　　微妙难可知
  非念离诸念　　求见不可得
  无生亦无灭　　性净恒寂然
  离垢聪慧人　　彼智所行处
  自性本空寂　　无二亦无尽
  解脱于诸趣　　涅槃平等住
  非初非中后　　非言辞所说
  出过于三世　　其相如虚空
  寂灭佛所行　　言说莫能及
  地行亦如是　　难说难可受
  智起佛境界　　非念离心道
  非蕴界处门　　智知意不及
  如空中鸟迹　　难说难可示
  如是十地义　　心意不能了
  慈悲及愿力　　出生入地行
  次第圆满心　　智行非虑境
  是境界难见　　可知不可说
  佛力故开演　　汝等应敬受
  如是智入行　　亿劫说不尽
  我今但略说　　真实义无余
  一心恭敬待　　我承佛力说
  胜法微妙音　　譬谕字相应
  无量佛神力　　咸来入我身
  此处难宣示　　我今说少分

佛子。若有众生。深种善根。善修诸行。善集助道。善供养诸佛。善集白净法。为善知识。善摄善清净深心。立广大志。生广大解。慈悲现前。为求佛智故。为得十力故。为得大无畏故。为得佛平等法故。为救一切世间故。为净大慈悲故。为得十方无余智故。为净一切佛刹无障碍故。为一念知一切三世故。为转大法轮无所畏故。佛子。菩萨起如是心。以大悲为首。智慧增上。善巧方便所摄。最上深心所持。如来力无量。善观察分别。勇猛力智。力无碍智。现前随顺自然智。能受一切佛法。以智慧教化。广大如法界。究竟如虚空。尽未来际。佛子。菩萨始发如是心。即得超凡夫地。入菩萨位。生如来家。无能说其种族过失。离世间趣。入出世道。得菩萨法。住菩萨处。入三世平等。于如来种中。决定当得无上菩提。菩萨住如是法。名住菩萨欢喜地。以不动相应故佛子。菩萨住欢喜地。成就多欢喜。多净信。多爱乐。多适悦。多欣庆。多踊跃。多勇猛。多无斗诤。多无恼害。多无嗔恨。佛子。菩萨住此欢喜地。念诸佛故生欢喜。念诸佛法。故生欢喜。念诸菩萨。故生欢喜。念诸菩萨行。故生欢喜。念清净诸波罗蜜。故生欢喜。念诸菩萨地殊胜。故生欢喜。念菩萨不可坏。故生欢喜。念如来教化众生。故生欢喜。念能令众生得利益。故生欢喜。念入一切如来智方便。故生欢喜。复作是念。我转离一切世间境界。故生欢喜。亲近一切佛。故生欢喜。远离凡夫地。故生欢喜。近智慧地。故生欢喜。永断一切恶趣。故生欢喜。与一切众生作依止处。故生欢喜。见一切如来。故生欢喜。生佛境界中。故生欢喜。入一切菩萨平等性中。故生欢喜。远离一切怖畏毛竖等事。故生欢喜。何以故。此菩萨。得欢喜地已。所有怖畏。悉得远离。所谓不活畏。恶名畏。死畏。恶道畏。大众威德畏。如是怖畏。皆得永离。何以故。此菩萨。离我想故。尚不爱自身。何况资财。是故无有不活畏。不于他所。希求供养。唯专给施一切众生。是故无有恶名畏。远离我见。无有我想。是故无有死畏。自知死已。决定不离诸佛菩萨。是故无有恶道畏。我所志乐。一切世间。无与等者。何况有胜。是故无有大众威德畏。菩萨如是。远离惊怖毛竖等事

佛子。此菩萨。以大悲为首。广大志乐。无能沮坏。转更勤修一切善根。而得成就。所谓信增上故。多净信故。解清净故。信决定故。发生悲愍故。成就大慈故。心无疲懈故。惭愧庄严故。成就柔和故。敬顺尊重诸佛教法故。日夜修集善根无厌足故。亲近善知识故。常爱乐法故。求多闻无厌足故。如所闻法。正观察故。心无依着故。不耽着利养名闻恭敬故。不求一切。资生之物故。生如宝心。无厌足故。求一切智地故。求如来力无畏不共佛法故。求诸波罗蜜助道法故。离诸谄诳故。如说能行故。常护实语故。不污如来家故。不舍菩萨戒故。生一切智心如山王。不动故。不舍一切世间事。成就出世间道故。集助菩提分法。无厌足故。常求上上。殊胜道故。佛子。菩萨。成就如是净治地法。名为安住菩萨欢喜地

佛子。菩萨住此欢喜地。能成就如是大誓愿。如是大勇猛。如是大作用。所谓生广大清净决定解。以一切供养之具。恭敬供养一切诸佛。令无有余。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿受一切佛法轮。愿摄一切佛菩提。愿护一切诸佛教。愿持一切诸佛法。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿一切世界。佛兴于世。从兜率天宫没。入胎住胎。初生出家。成道说法。示现涅槃。皆悉往诣。亲近供养。为众上首。受行正法。于一切处。一时而转。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿愿一切菩萨行。广大无量。不坏不杂。摄诸波罗蜜。净治诸地。总相别相。同相异相。成相坏相。所有菩萨行。皆如实说。教化一切。令其受行。心得增长。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿一切众生界。有色无色。有想无想。非有想非无想。卵生胎生。湿生化生。三界所系。入于六趣。一切生处。名色所摄。如是等类。我皆教化。令入佛法。令永断一切世间趣。令安住一切智智道。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿一切世界。广大无量。粗细乱住。倒住正住。若入若行若去。如帝网差别。十方无量。种种不同。智皆明了。现前知见。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿一切国土。入一国土。一国土。入一切国土。无量佛土。普皆清净。光明众具。以为庄严。离一切烦恼。成就清净道。无量智慧众生。充满其中。普入广大诸佛境界。随众生心。而为示现。皆令欢喜。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿与一切菩萨。同一志行。无有怨嫉。集诸善根。一切菩萨。平等一缘。常共集会。不相舍离。随意能现种种佛身。任其自心。能知一切如来境界。威力智慧。得不退如意神通。游行一切世界。现形一切众会。普入一切生处。成就不思议大乘。修菩萨行。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿乘不退轮。行菩萨行。身语意业。悉不唐捐。若暂见者。则必定佛法。暂闻音声。则得实智慧。才生净信。则永断烦恼。得如大药王树身。得如如意宝身。修行一切菩萨行。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。又发大愿。愿于一切世界。成阿耨多罗三藐三菩提。不离一毛端处。于一切毛端处。皆悉示现。初生出家。诣道场。成正觉。转法轮。入涅槃。得佛境界。大智慧力。于念念中。随一切众生心。示现成佛。令得寂灭。以一三菩提。知一切法界。即涅槃相。以一音说法。令一切众生。心皆欢喜。示入大涅槃。而不断菩萨行。示大智慧地。安立一切法。以法智通。神足通。幻通。自在变化。充满一切法界。广大如法界。究竟如虚空。尽未来际。一切劫数。无有休息。佛子。菩萨住欢喜地。发如是大誓愿。如是大勇猛。如是大作用。以此十愿门为首。满足百万阿僧祇大愿。佛子。此大愿以十尽句。而得成就。何等为十。所谓众生界尽。世界尽。虚空界尽。法界尽。涅槃界尽。佛出现界尽。如来智界尽。心所缘界尽。佛智所入境界界尽。世间转法转智转界尽。若众生界尽。我愿乃尽。若世界。乃至世间转法转智转界尽。我愿乃尽。而众生界。不可尽。乃至世间转法转智转界不可尽故。我此大愿善根。无有穷尽

佛子。菩萨发如是大愿已。则得利益心。柔软心。随顺心。寂静心。调伏心。寂灭心。谦下心。润泽心。不动心。不浊心。成净信者。有信功用。能信如来。本行所入。信成就诸波罗蜜。信入诸胜地。信成就力。信具足无所畏。信生长不可坏不共佛法。信不思议佛法。信出生无中边佛境界。信随入如来无量境界。信成就果。举要言之。信一切菩萨行。乃至如来智地说力故

佛子。此菩萨。复作是念。诸佛正法。如是甚深。如是寂静。如是寂灭。如是空。如是无相。如是无愿。如是无染。如是无量。如是广大。而诸凡夫。心堕邪见。无明覆翳。立憍慢高幢。入渴爱网中。行谄诳稠林。不能自出。心与悭嫉。相应不舍。恒造诸趣。受生因缘。贪恚愚痴。积集诸业。日夜增长。以忿恨风。吹心识火。炽然不息。凡所作业。皆颠倒相应。欲流有流。无明流见流。相续起。心意识种子。于三界田中。复生苦芽。所谓名色。共生不离。此名色增长。生六处聚落。于中相对生触。触故生受。因受生爱。爱增长故。生取。取增长故。生有。有生故。有生老死。忧悲苦恼。如是众生。生长苦聚。是中皆空。离我我所。无知无觉。无作无受。如草木石壁。亦如影像。然诸众生。不觉不知。菩萨见诸众生。于如是苦聚。不得出离。是故即生大悲智慧。复作是念。此诸众生。我应救拔。置于究竟安乐之处。是故即生大慈光明智佛子。菩萨摩诃萨。随顺如是。大悲大慈。以深重心。住初地时。于一切物。无所吝惜。求佛大智。修行大舍。凡是所有。一切能施。所谓财谷仓库。金银摩尼。真珠琉璃。珂贝璧玉。珊瑚等物。珍宝璎珞。严身之具。象马车乘。奴婢人民。城邑聚落。园林台观。妻妾男女。内外眷属。及余所有珍玩之具。头目手足。血肉骨髓。一切身分。皆无所惜。为求诸佛。广大智慧。是名菩萨住于初地大舍成就。佛子。菩萨以此慈悲大施心。为欲救护一切众生。转更推求世出世间。诸利益事。无疲厌故。即得成就无疲厌心。得无疲厌心已。于一切经论。心无怯弱。无怯弱故。即得成就一切经论智。获是智已。善能筹量。应作不应作。于上中下。一切众生。随应随力。随其所习。如是而行。是故菩萨。得成世智。成世智已。知时知量。以惭愧庄严。勤修自利利他之道。是故成就惭愧庄严。于此行中。勤修出离。不退不转。成坚固力。得坚固力已。勤供诸佛。于佛教法。能如说行。佛子。菩萨如是。成就十种净诸地法。所谓信悲慈舍。无有疲厌。知诸经论。善解世法。惭愧坚固力。供养诸佛。依教修行

佛子。菩萨住此欢喜地已。以大愿力。得见多佛。所谓见多百佛。多千佛。多百千佛。多亿佛。多百亿佛。多千亿佛。多百千亿佛。多亿那由他佛。多百亿那由他佛。多千亿那由他佛。多百千亿那由他佛。悉以大心深心。恭敬尊重。承事供养。衣服饮食。卧具医药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。皆悉回向无上菩提。佛子。此菩萨。因供养诸佛故。得成就众生法。以前二摄。摄取众生。谓布施爱语。后二摄法。但以信解力故。行未善通达。是菩萨。十波罗蜜中。檀波罗蜜增上。余波罗蜜。非不修行。但随力随分。是菩萨。随所勤修。供养诸佛。教化众生。皆以修行清净地法。所有善根。悉以回向一切智地。转转明净。调柔成就。随意堪用。佛子。譬如金师。善巧炼金。数数入火。转转明净。调柔成就。随意堪用。菩萨亦复如是。供养诸佛。教化众生。皆为修行清净地法。所有善根。悉以回向一切智地。转转明净。调柔成就。随意堪用

佛子。菩萨摩诃萨。住于初地。应从诸佛菩萨。善知识所。推求请问。于此地中。相及得果。无有厌足。为欲成就此地法故。亦应从诸佛菩萨。善知识所。推求请问。第二地中。相及得果。无有厌足。为欲成就彼地法故。亦应如是。推求请问。第三第四。第五第六。第七第八。第九第十地中。相及得果。无有厌足。为欲成就彼地法故。是菩萨。善知诸地障对治。善知地成坏。善知地相果。善知地得修。善知地法清净。善知地地转行。善知地地处非处。善知地地殊胜智。善知地地不退转。善知净治一切菩萨地。乃至转入如来地。佛子。菩萨如是。善知地相。始于初地。起行不断。如是乃至入第十地。无有断绝。由此诸地智光明故。成于如来。智慧光明。佛子。譬如商主。善知方便。欲将诸商人。往诣大城。未发之时。先问道中。功德过失。及住止之处。安危可不。然后具道资粮。作所应作。佛子。彼大商主。虽未发足。能知道中。所有一切安危之事。善以智慧。筹量观察。备其所须。令无乏少。将诸商众。乃至安隐。到彼大城。身及众人。悉免忧患。佛子。菩萨商主。亦复如是。住于初地。善知诸地障对治。乃至善知一切菩萨地清净。转入如来地。然后乃具福智资粮。将一切众生。经生死旷野险难之处。安隐得至萨婆若城。身及众生。不经患难。是故菩萨。常应匪懈。勤修诸地。殊胜净业。乃至趣入如来智地。佛子。是名略说。菩萨摩诃萨。入菩萨初地门。广说则有无量无边百千阿僧祇差别事

佛子菩萨摩诃萨。住此初地。多作阎浮提王。豪贵自在。常护正法。能以大施。摄取众生。善除众生悭贪之垢。常行大施。无有穷尽。布施爱语利益同事。如是一切诸所作业。皆不离念佛。不离念法。不离念僧。不离念同行菩萨。不离念菩萨行。不离念诸波罗蜜。不离念诸地。不离念力。不离念无畏。不离念不共佛法。乃至不离念具足一切种一切智智。复作是念。我当于一切众生中。为首为胜。为殊胜。为妙为微妙。为上为无上。为导为将为帅。乃至为一切智智依止者。是菩萨。若欲舍家。于佛法中。勤行精进。便能舍家妻子五欲。依如来教。出家学道。既出家已。勤行精进。于一念顷。得百三昧。得见百佛。知百佛神力。能动百佛世界。能过百佛世界。能照百佛世界。能教化百世界众生。能住寿百劫。能知前后际。各百劫事。能入百法门。能示现百身。于一一身。能示百菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于是数。百劫千劫。百千劫。乃至百千亿那由他劫。不能数知。尔时。金刚藏菩萨。欲重宣其义。而说颂曰

  若人集众善　　具足白净法
  供养天人尊　　随顺慈悲道
  信解极广大　　志乐亦清净
  为求佛智慧　　发此无上心
  净一切智力　　及以无所畏
  成就诸佛法　　救摄群生众
  为得大慈悲　　及转胜法轮
  严净佛国土　　发此最胜心
  一念知三世　　而无有分别
  种种时不同　　以示于世间
  略说求诸佛　　一切胜功德
  发生广大心　　量等虚空界
  悲先慧为主　　方便共相应
  信解清净心　　如来无量力
  无碍智现前　　自悟不由他
  具足同如来　　发此最胜心
  佛子始发生　　如是妙宝心
  则超凡夫位　　入佛所行处
  生在如来家　　种族无瑕玷
  与佛共平等　　决成无上觉
  才生如是心　　即得入初地
  志乐不可动　　譬如大山王
  多喜多爱乐　　亦复多净信
  极大勇猛心　　及以庆跃心
  远离于斗诤　　恼害及嗔恚
  惭敬而质直　　善守护诸根
  救世无等者　　所有众智慧
  此处我当得　　忆念生欢喜
  始得入初地　　即超五怖畏
  不活死恶名　　恶趣众威德
  以不贪着我　　及以于我所
  是诸佛子等　　远离诸怖畏
  常行大慈愍　　恒有信恭敬
  惭愧功德备　　日夜增善法
  乐法真实利　　不爱受诸欲
  思惟所闻法　　远离取着行
  不贪于利养　　唯乐佛菩提
  一心求佛智　　专精无异念
  修行波罗蜜　　远离谄虚诳
  如说而修行　　安住实语中
  不污诸佛家　　不舍菩萨戒
  不乐于世事　　常利益世间
  修善无厌足　　转求增胜道
  如是好乐法　　功德义相应
  恒起大愿心　　愿见于诸佛
  护持诸佛法　　摄取大仙道
  常生如是愿　　修行最胜行
  成熟诸群生　　严净佛国土
  一切诸佛刹　　佛子悉充满
  平等共一心　　所作皆不空
  一切毛端处　　一时成正觉
  如是等大愿　　无量无边际
  虚空与众生　　法界及涅槃
  世间佛出兴　　佛智心境界
  如来智所入　　及以三转尽
  彼诸若有尽　　我愿方始尽
  如彼无尽期　　我愿亦复然
  如是发大愿　　心柔软调顺
  能信佛功德　　观察于众生
  知从因缘起　　则兴慈念心
  如是苦众生　　我今应救脱
  为是众生故　　而行种种施
  王位及珍宝　　乃至象马车
  头目与手足　　乃至身血肉
  一切皆能舍　　心得无忧悔
  求种种经书　　其心无厌倦
  善解其义趣　　能随世所行
  惭愧自庄严　　修行转坚固
  供养无量佛　　恭敬而尊重
  如是常修习　　日夜无懈倦
  善根转明净　　如火炼真金
  菩萨住于此　　净修于十地
  所作无障碍　　具足不断绝
  譬如大商主　　为利诸商众
  问知道险易　　安隐至大城
  菩萨住初地　　应知亦如是
  勇猛无障碍　　到于第十地
  住此初地中　　作大功德王
  以法化众生　　慈心无损害
  统领阎浮地　　化行靡不及
  皆令住大舍　　成就佛智慧
  欲求最胜道　　舍己国王位
  能于佛教中　　勇猛勤修习
  则得百三昧　　及见百诸佛
  震动百世界　　光照行亦尔
  化百土众生　　入于百法门
  能知百劫事　　示现于百身
  及现百菩萨　　以为其眷属
  若自在愿力　　过是数无量
  我于地义中　　略述其少分
  若欲广分别　　亿劫不能尽
  菩萨最胜道　　利益诸群生
  如是初地法　　我今已说竟

大方广佛华严经卷第三十四大方广佛华严经卷第三十五

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之二

  诸菩萨闻此　　最胜微妙地
  其心尽清净　　一切皆欢喜
  皆从于座起　　踊住虚空中
  普散上妙华　　同时共称赞
  善哉金刚藏　　大智无畏者
  善说于此地　　菩萨所行法
  解脱月菩萨　　知众心清净
  乐闻第二地　　所有诸行相
  即请金刚藏　　大慧愿演说
  佛子皆乐闻　　所住第二地

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。已修初地。欲入第二地。当起十种深心。何等为十。所谓正直心。柔软心。堪能心。调伏心。寂静心。纯善心。不杂心。无顾恋心。广心。大心。菩萨以此十心。得入第二离垢地。佛子。菩萨住离垢地。性自远离一切杀生。不畜刀杖。不怀怨恨。有惭有愧。仁恕具足。于一切众生。有命之者。常生利益慈念之心。是菩萨。尚不恶心恼诸众生。何况于他。起众生想。故以重意。而行杀害。性不偷盗。菩萨于自资财。常知止足。于他慈恕。不欲侵损。若物属他。起他物想。终不于此。而生盗心。乃至草叶。不与不取。何况其余。资生之具。性不邪淫。菩萨于自妻知足。不求他妻。于他妻妾。他所护女。亲族媒定。及为法所护。尚不生于贪染之心。何况从事。况于非道。性不妄语。菩萨常作实语。真语时语。乃至梦中。亦不忍作覆藏之语。无心欲作。何况故犯。性不两舌。菩萨于诸众生。无离间心。无恼害心。不将此语。为破彼故。而向彼说。不将彼语。为破此故。而向此说。未破者不令破。已破者不增长。不喜离间。不乐离间。不作离间语。不说离间语。若实若不实。性不恶口。所谓毒害语。粗犷语。苦他语。令他嗔恨语。现前语。不现前语。鄙恶语。庸贱语。不可乐闻语。闻者不悦语。嗔忿语。如火烧心语。怨结语。热恼语。不可爱语。不可乐语。能坏自身他身语。如是等语。皆悉舍离。常作润泽语。柔软语。悦意语。可乐闻语。闻者喜悦语。善入人心语。风雅典则语。多人爱乐语。多人悦乐语。身心踊悦语。性不绮语。菩萨常乐思审语。时语实语。义语法语。顺道理语。巧调伏语。随时筹量决定语。是菩萨。乃至戏笑尚恒思审。何况故出散乱之言。性不贪欲。菩萨于他财物。他所资用。不生贪心。不愿。不求。性离嗔恚。菩萨于一切众生。恒起慈心。利益心。哀愍心。欢喜心。和润心。摄受心。永舍嗔恨。怨害热恼。常思顺行。仁慈祐益。又离邪见。菩萨住于正道。不行占卜。不取恶戒。心见正直。无诳无谄。于佛法僧。起决定信。佛子。菩萨摩诃萨。如是护持十善业道。常无间断。复作是念。一切众生。堕恶趣者。莫不皆以十不善业。是故我当自修正行。亦劝于他。令修正行。何以故。若自不能修行正行。令他修者。无有是处。佛子。此菩萨摩诃萨。复作是念。十不善业道。是地狱畜生饿鬼受生因。十善业道。是人天乃至有顶处受生因。又此上品。十善业道。以智慧修习。心狭劣故。怖三界故。阙大悲故。从他闻声。而解了故。成声闻乘。又此上品。十善业道。修治清净。不从他教。自觉悟故。大悲方便。不具足故。悟解甚深。因缘法故。成独觉乘。又此上品。十善业道。修治清净。心广无量故。具足悲愍故。方便所摄故。发生大愿故。不舍众生故。希求诸佛大智故。净治菩萨诸地故。净修一切诸度故。成菩萨广大行。又此上上。十善业道。一切种清净故。乃至证十力四无畏故。一切佛法。皆得成就。是故我今。等行十善。应令一切具足清净。如是方便。菩萨当学

佛子。此菩萨摩诃萨。又作是念。十不善业道。上者地狱因。中者畜生因。下者饿鬼因。于中杀生之罪。能令众生堕于地狱畜生饿鬼。若生人中。得二种果报。一者短命。二者多病。偷盗之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者贫穷。二者共财不得自在。邪淫之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者妻不贞良。二者不得随意眷属。妄语之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者多被诽谤。二者为他所诳。两舌之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者眷属乖离。二者亲族毙恶。恶口之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常闻恶声。二者言多诤讼。绮语之罪。亦令众生堕三恶道。若生人中。得二种果报。一者言无人受。二者语不明了。贪欲之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者心不知足。二者多欲无厌。嗔恚之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常被他人求其长短。二者恒被于他之所恼害。邪见之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者生邪见家。二者其心谄曲。佛子。十不善业道。能生此等无量无边众大苦聚。是故菩萨。作如是念。我当远离十不善道。以十善道。为法园苑。爱乐安住。自住其中。亦劝他人。令住其中。佛子。此菩萨摩诃萨。复于一切众生。生利益心。安乐心。慈心悲心。怜愍心。摄受心。守护心。自己心。师心大师心。作是念言。众生可愍。堕于邪见。恶慧恶欲。恶道稠林。我应令彼。住于正见。行真实道。又作是念。一切众生。分别彼我。互相破坏。斗诤嗔恨。炽然不息。我当令彼。住于无上。大慈之中。又作是念。一切众生。贪取无厌。唯求财利。邪命自活。我当令彼。住于清净身语意业。正命法中。又作是念。一切众生。常随三毒。种种烦恼。因之炽然。不解志求出要方便。我当令彼。除灭一切烦恼大火。安置清凉涅槃之处。又作是念。一切众生。为愚痴重闇。妄见厚膜之所覆故。入阴翳稠林。失智慧光明。行旷野险道。起诸恶见。我当令彼。得无障碍。清净智眼。知一切法。如实相。不随他教。又作是念。一切众生。在于生死。险道之中。将堕地狱。畜生饿鬼。入恶见网中。为愚痴稠林所迷。随逐邪道。行颠倒行。譬如盲人。无有导师。非出要道。谓为出要。入魔境界。恶贼所摄。随顺魔心。远离佛意。我当拔出如是险难。令住无畏一切智城。又作是念。一切众生。为大瀑水波浪所没。入欲流有流。无明流见流生死洄澓。爱河漂转。湍驰奔激。不暇观察。为欲觉恚觉害觉。随逐不舍。身见罗刹。于中执取。将其永入爱欲稠林。于所贪爱深生染着。住我慢原阜。安六处聚落。无善救者。无能度者。我当于彼。起大悲心。以诸善根。而为救济。令无灾患。离染寂静。住于一切智慧宝洲。又作是念。一切众生。处世牢狱。多诸苦恼。常怀爱憎。自生忧怖。贪欲重械之所系缚。无明稠林。以为覆障。于三界内。莫能自出。我当令彼。永离三有。住无障碍。大涅槃中。又作是念。一切众生。执着于我。于诸蕴窟宅。不求出离。依六处空聚。起四颠倒行。为四大毒蛇之所侵恼。五蕴怨贼之所杀害。受无量苦。我当令彼。住于最胜。无所著处。所谓灭一切障碍。无上涅槃。又作是念。一切众生。其心狭劣。不行最上。一切智道。虽欲出离。但乐声闻辟支佛乘。我当令住广大佛法。广大智慧。佛子。菩萨如是。护持于戒。善能增长慈悲之心

佛子。菩萨住此离垢地。以愿力故。得见多佛。所谓见多百佛。多千佛。多百千佛。多亿佛。多百亿佛。多千亿佛。多百千亿佛。如是。乃至见多百千亿那由他佛。于诸佛所。以广大心深心。恭敬尊重。承事供养。衣服饮食。卧具医药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。回向阿耨多罗三藐三菩提。于诸佛所。以尊重心。复更受行十善道法。随其所受。乃至菩提。终不忘失。是菩萨。于无量百千亿那由他劫。远离悭嫉。破戒垢故。布施持戒。清净满足。譬如真金。置矾石中。如法炼已。离一切垢。转复明净。菩萨住此离垢地。亦复如是。于无量百千亿那由他劫。远离悭嫉。破戒垢故。布施持戒。清净满足。佛子。此菩萨四摄法中。爱语偏多。十波罗蜜中。持戒偏多。余非不行。但随力随分。佛子。是名略说菩萨摩诃萨第二离垢地。菩萨住此地。多作转轮圣王。为大法主。具足七宝。有自在力。能除一切众生。悭贪破戒垢。以善方便。令其安住。十善道中。为大施主。周给无尽。布施爱语。利行同事。如是一切。诸所作业。皆不离念佛。不离念法。不离念僧。乃至不离念具足一切种。一切智智。又作是念。我当于一切众生中为首。为胜为殊胜。为妙为微妙。为上为无上。乃至为一切智智依止者。是菩萨。若欲舍家。于佛法中。勤行精进。便能舍家妻子五欲。既出家已。勤行精进。于一念顷。得千三昧。得见千佛。知千佛神力。能动千世界。乃至能示现千身。于一一身。能示现千菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于是数。百劫千劫。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义。而说颂曰

  质直柔软及堪能　　调伏寂静与纯善
  速出生死广大意　　以此十心入二地
  住此成就戒功德　　远离杀生不恼害
  亦离偷盗及邪淫　　妄恶乖离无义语
  不贪财物常慈愍　　正道直心无谄伪
  离险舍慢极调柔　　依教而行不放逸
  地狱畜生受众苦　　饿鬼烧然出猛焰
  一切皆由罪所致　　我当离彼住实法
  人中随意得受生　　乃至顶天禅定乐
  独觉声闻佛乘道　　皆因十善而成就
  如是思惟不放逸　　自持净戒教他护
  复见群生受众苦　　转更增益大悲心
  凡愚邪智不正解　　常怀忿恨多诤讼
  贪求境界无足期　　我应令彼除三毒
  愚痴大暗所缠覆　　入大险道邪见网
  生死笼槛怨所拘　　我应令彼摧魔贼
  四流漂荡心没溺　　三界焚如苦无量
  计蕴为宅我在中　　为欲度彼勤行道
  设求出离心下劣　　舍于最上佛智慧
  我欲令彼住大乘　　发勤精进无厌足
  菩萨住此集功德　　见无量佛咸供养
  亿劫修治善更明　　如以好药炼真金
  佛子住此作轮王　　普化众生行十善
  所有善法皆修习　　为成十力救于世
  欲舍王位及财宝　　即弃居家依佛教
  勇猛精勤一念中　　获千三昧见千佛
  所有种种神通力　　此地菩萨皆能现
  愿力所作复过此　　无量自在度群生
  一切世间利益者　　所修菩萨最胜行
  如是第二地功德　　为诸佛子已开演

    第三地

  佛子得闻此地行　　菩萨境界难思议
  靡不恭敬心欢喜　　散华空中为供养
  赞言善哉大山王　　慈心愍念诸众生
  善说智者律仪法　　第二地中之行相
  是诸菩萨微妙行　　真实无异无差别
  为欲利益诸群生　　如是演说最清净
  一切人天供养者　　愿为演说第三地
  与法相应诸智业　　如其境界希具阐
  大仙所有施戒法　　忍辱精进禅智慧
  及以方便慈悲道　　佛清净行愿皆说
  时解脱月复请言　　无畏大士金刚藏
  愿说趣入第三地　　柔和心者诸功德

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。已净第二地。欲入第三地。当起十种深心。何等为十。所谓清净心。安住心。厌舍心。离贪心。不退心。坚固心。明盛心。勇猛心。广心。大心。菩萨以是十心。得入第三地佛子。菩萨摩诃萨。住第三地已。观一切有为法如实相。所谓无常苦。不净不安隐。败坏不久住。刹那生灭。非从前际生。非向后际去。非于现在住。又观此法。无救无依。与忧与悲。苦恼同住。爱憎所系。愁戚转多。无有停积。贪恚痴火。炽然不息。众患所缠。日夜增长。如幻不实。见如是已。于一切有为。倍增厌离。趣佛智慧。见佛智慧。不可思议。无等无量。难得无杂。无恼无忧。至无畏城。不复退还。能救无量。苦难众生。菩萨如是。见如来智慧。无量利益。见一切有为。无量过患。则于一切众生。生十种哀愍心。何等为十。所谓见诸众生孤独无依生哀愍心。见诸众生贫穷困乏生哀愍心。见诸众生三毒火然生哀愍心。见诸众生诸有牢狱之所禁闭生哀愍心。见诸众生烦恼稠林恒所覆障生哀愍心。见诸众生不善观察生哀愍心。见诸众生无善法欲生哀愍心。见诸众生失诸佛法生哀愍心。见诸众生随生死流生哀愍心。见诸众生失解脱方便生哀愍心。是为十。菩萨如是。见众生界。无量苦恼。发大精进。作是念言。此等众生。我应救。我应脱。我应净。我应度。应着善处。应令安住。应令欢喜。应令知见。应令调伏。应令涅槃。菩萨。如是厌离一切有为。如是愍念一切众生。知一切智智。有胜利益。欲依如来智慧。救度众生。作是思惟。此诸众生。堕在烦恼大苦之中。以何方便。而能拔济。令住究竟涅槃之乐。便作是念。欲度众生。令住涅槃。不离无障碍解脱智。无障碍解脱智。不离一切法如实觉。一切法如实觉。不离无行无生行慧光。无行无生行慧光。不离禅善巧决定观察智。禅善巧决定观察智。不离善巧多闻。菩萨如是。观察了知已。倍于正法。勤求修习。日夜唯愿闻法喜法乐法依法。随法解法。顺法到法。住法行法。菩萨如是。勤求佛法。所有珍财。皆无吝惜。不见有物。难得可重。但于能说佛法之人。生难遭想。是故菩萨。于内外财。为求佛法。悉能舍施。无有恭敬而不能行。无有憍慢而不能舍。无有承事而不能作。无有勤苦而不能受。若闻一句。未曾闻法。生大欢喜。胜得三千大千世界。满中珍宝。若闻一偈。未闻正法。生大欢喜。胜得转轮圣王位。若得一偈。未曾闻法。能净菩萨行。胜得帝释梵王位。住无量百千劫。若有人言。我有一句。佛所说法。能净菩萨行。汝今若能入大火坑。受极大苦。当以相与。菩萨尔时。作如是念。我以一句。佛所说法。净菩萨行故。假使三千大千世界。大火满中。尚欲从于梵天之上。投身而下。亲自受取。况小火坑。而不能入。然我今者。为求佛法。应受一切地狱众苦。何况人中。诸小苦恼。菩萨如是。发勤精进。求于佛法。如其所闻。观察修行。此菩萨。得闻法已。摄心安住。于空闲处。作是思惟。如说修行。乃得佛法。非但口言。而可清净

佛子。是菩萨。住此发光地时。即离欲恶不善法。有觉有观。离生喜乐。住初禅。灭觉观。内净一心。无觉无观。定生喜乐。住第二禅。离喜住舍。有念正知。身受乐。诸圣所说。能舍有念受乐。住第三禅。断乐先除。苦喜忧灭。不苦不乐。舍念清净。住第四禅。超一切色想。灭有对想。不念种种想。入无边虚空。住虚空无边处。超一切虚空无边处。入无边识。住识无边处。超一切识无边处。入无少所有。住无所有处。超一切无所有处。住非有想非无想处。但随顺法故。行而无所乐着

佛子。此菩萨。心随于慈广大无量不二。无怨无对。无障无恼。遍至一切处。尽法界虚空界。遍一切世间。住悲喜舍。亦复如是

佛子。此菩萨。得无量神通力。能动大地。以一身为多身。多身为一身。或隐或显。石壁山障。所往无碍。犹如虚空。于虚空中。跏趺而去。同于飞鸟。入地如水。履水如地。身出烟焰。如大火聚。复雨于水。犹如大云。日月在空。有大威力。而能以手。扪摸摩触。其身自在。乃至梵世。此菩萨。天耳清净。过于人耳。悉闻人天。若近若远。所有音声。乃至蚊蚋。虻蝇等声。亦悉能闻。此菩萨。以他心智。如实而知他众生心。所谓有贪心如实知有贪心。离贪心如实知离贪心。有嗔心离嗔心。有痴心离痴心。有烦恼心无烦恼心。小心广心。大心无量心。略心非略心。散心非散心。定心非定心。解脱心非解脱心。有上心无上心。杂染心非杂染心。广心非广心。皆如实知。菩萨如是。以他心智。知众生心。此菩萨。念知无量宿命差别。所谓念知一生。念知二生。三生四生。乃至十生。二十三十。乃至百生。无量百生。无量千生。无量百千生。成劫坏劫。成坏劫。无量成坏劫。我曾在某处。如是名。如是姓。如是种族。如是饮食。如是寿命。如是久住。如是苦乐。我于彼死。生于某处。从某处死。生于此处。如是形状。如是相貌。如是言音。如是过去。无量差别。皆能忆念。此菩萨。天眼清净。过于人眼。见诸众生。生时死时。好色恶色。善趣恶趣。随业而去。若彼众生。成就身恶行。成就语恶行。成就意恶行。诽谤贤圣。具足邪见。及邪见业因缘。身坏命终。必堕恶趣。生地狱中。若彼众生。成就身善行。成就语善行。成就意善行。不谤贤圣。具足正见。正见业因缘。身坏命终。必生善趣。诸天之中。菩萨天眼。皆如实知。此菩萨。于诸禅三昧。三摩钵底能入能出。然不随其力受生。但随能满菩提分处。以意愿力。而生其中

佛子。是菩萨。住此发光地。以愿力故。得见多佛。所谓见多百佛。见多千佛。见多百千佛。乃至见多百千亿那由他佛。悉以广大心深心。恭敬尊重。承事供养。衣服饮食。卧具汤药一切资生。悉以奉施。亦以供养一切众僧。以此善根。回向阿耨多罗三藐三菩提。于其佛所。恭敬听法。闻已受持。随力修行。此菩萨。观一切法。不生不灭。因缘而有。见缚先灭。一切欲缚。色缚有缚。无明缚。皆转微薄。于无量百千亿那由他劫。不积集故。邪贪邪嗔。及以邪痴。悉得除断。所有善根。转更明净。佛子。譬如真金。善巧炼治。称两不减。转更明净。菩萨。亦复如是。住此发光地。不积集故。邪贪邪嗔。及以邪痴。皆得除断。所有善根。转更明净。此菩萨。忍辱心。柔和心。谐顺心。悦美心。不嗔心。不动心。不浊心。无高下心。不望报心。报恩心。不谄心。不诳心。无譣诐心。皆转清净。此菩萨。于四摄中。利行偏多。十波罗蜜中。忍波罗蜜偏多。余非不修。但随力随分。佛子。是名菩萨第三发光地。菩萨住此地。多作三十三天王。能以方便。令诸众生。舍离贪欲。布施爱语。利行同事。如是一切诸所作业。皆不离念佛。不离念法。不离念僧。乃至不离念具足一切种。一切智智。复作是念。我当于一切众生中为首。为胜为殊胜。为妙为微妙。为上为无上。乃至为一切智智依止者。若勤行精进。于一念顷。得百千三昧。得见百千佛。知百千佛神力。能动百千佛世界。乃至示现百千身。一一身。百千菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于此数。百劫千劫。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义。而说颂曰

  清净安住明盛心　　厌离无贪无害心
  坚固勇猛广大心　　智者以此入三地
  菩萨住此发光地　　观诸行法苦无常
  不净败坏速归灭　　无坚无住无来往
  观诸有为如重病　　忧悲苦恼惑所缠
  三毒猛火恒炽然　　无始时来不休息
  厌离三有不贪着　　专求佛智无异念
  难测难思无等伦　　无量无边无逼恼
  见佛智已愍众生　　孤独无依无救护
  三毒炽然常困乏　　住诸有狱恒受苦
  烦恼缠覆盲无目　　志乐下劣丧法宝
  随顺生死怖涅槃　　我应救彼勤精进
  将求智慧益众生　　思何方便令解脱
  不离如来无碍智　　彼复无生慧所起
  心念此慧从闻得　　如是思惟自勤励
  日夜听习无间然　　唯以正法为尊重
  国城财贝诸珍宝　　妻子眷属及王位
  菩萨为法起敬心　　如是一切皆能舍
  头目耳鼻舌牙齿　　手足骨髓心血肉
  此等皆舍未为难　　但以闻法为最难
  设有人来语菩萨　　孰能投身大火聚
  我当与汝佛法宝　　闻已投之无怯惧
  假使火满三千界　　身从梵世而投入
  为求法故不为难　　况复人间诸小苦
  从初发意至得佛　　其间所有阿鼻苦
  为闻法故皆能受　　何况人中诸苦事
  闻已如理正思惟　　获得四禅无色定
  四等五通次第起　　不随其力而受生
  菩萨住此见多佛　　供养听闻心决定
  断诸邪惑转清净　　如炼真金体无减
  住此多作忉利王　　化导无量诸天众
  令舍贪心住善道　　一向专求佛功德
  佛子住此勤精进　　百千三昧皆具足
  见百千佛相严身　　若以愿力复过是
  一切众生普利益　　彼诸菩萨最上行
  如是所有第三地　　我依其义已解释

大方广佛华严经卷第三十五大方广佛华严经卷第三十六

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之三

  佛子闻此广大行　　可乐深妙殊胜地
  心皆踊悦大欢喜　　普散众华供养佛
  演说如是妙法时　　大地海水皆震动
  一切天女咸欢喜　　悉吐妙音同赞叹
  自在天王大欣庆　　雨摩尼宝供养佛
  赞言佛为我出兴　　演说第一功德行
  如是智者诸地义　　于百千劫甚难得
  我今忽然而得闻　　菩萨胜行妙法音
  愿更演说聪慧者　　后地决定无余道
  利益一切诸天人　　此诸佛子皆乐闻
  勇猛大心解脱月　　请金刚藏言佛子
  从此转入第四地　　所有行相愿宣说

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。第三地善清净已。欲入第四焰慧地。当修行十法明门。何等为十。所谓观察众生界。观察法界。观察世界。观察虚空界。观察识界。观察欲界。观察色界。观察无色界。观察广心信解界。观察大心信解界。菩萨以此十法明门。得入第四焰慧地

佛子。菩萨住此焰慧地。则能以十种智。成熟法故。得彼内法。生如来家。何等为十。所谓深心不退故。于三宝中。生净信。毕竟不坏故。观诸行生灭故。观诸法自性无生故。观世间成坏故。观因业有生故。观生死涅槃故。观众生国土业故。观前际后际故。观无所有尽故。是为十。佛子。菩萨住此第四地。观内身循身观。勤勇念知。除世间贪忧。观外身循身观。勤勇念知。除世间贪忧。观内外身循身观。勤勇念知。除世间贪忧。如是。观内受外受内外受循受观。观内心外心内外心循心观。观内法外法内外法循法观。勤勇念知。除世间贪忧。复次此菩萨。未生诸恶不善法为不生故。欲生勤精进发心正断已生诸恶不善法为断故。欲生勤精进发心正断。未生诸善法为生故。欲生勤精进发心正行。已生诸善法为住不失故。修令增广故。欲生勤精进发心正行。复次此菩萨。修行欲定断行。成就神足。依止厌。依止离。依止灭。回向于舍。修行精进定心定观定断行。成就神足。依止厌。依止离。依止灭。回向于舍。复次此菩萨。修行信根。依止厌。依止离。依止灭。回向于舍。修行精进根。念根。定根。慧根。依止厌。依止离。依止灭。回向于舍。复次此菩萨。修行信力。依止厌。依止离。依止灭。回向于舍。修行精进力。念力。定力。慧力。依止厌。依止离。依止灭。回向于舍。复次此菩萨。修行念觉分。依止厌。依止离。依止灭。回向于舍。修行择法觉分。精进觉分。喜觉分。猗觉分。定觉分。舍觉分。依止厌。依止离。依止灭。回向于舍。复次此菩萨。修行正见。依止厌。依止离。依止灭。回向于舍。修行正思惟。正语正业。正命正精进。正念正定。依止厌。依止离。依止灭。回向于舍。菩萨修行如是功德。为不舍一切众生故。本愿所持故。大悲为首故。大慈成就故。思念一切智智故。成就庄严佛土故。成就如来力无所畏不共佛法相好音声悉具足故。求于上上殊胜道故。随顺所闻甚深佛解脱故。思惟大智善巧方便故

佛子。菩萨住此焰慧地。所有身见为首。我人众生。寿命。蕴界处。所起执着。出没思惟。观察治故。我所故。财物故。着处故。于如是等。一切皆离。此菩萨。若见业。是如来所诃。烦恼所染。皆悉舍离。若见业。是顺菩萨道。如来所赞。皆悉修行

佛子。此菩萨。随所起方便慧。修习于道及助道分。如是而得润泽心。柔软心。调顺心。利益安乐心。无杂染心。求上上胜法心。求殊胜智慧心。救一切世间心。恭敬尊德无违教命心。随所闻法皆善修行心。此菩萨。知恩知报恩。心极和善。同住安乐。质直柔软。无稠林行。无有我慢。善受教诲。得说者意。此菩萨。如是忍成就。如是调柔成就。如是寂灭成就。如是忍调柔寂灭成就。净治后地业。作意修行时。得不休息精进。不杂染精进。不退转精进。广大精进。无边精进。炽然精进。无等等精进。无能坏精进。成熟一切众生精进。善分别道非道精进。是菩萨。心界清净。深心不失。悟解明利。善根增长。离世垢浊。断诸疑惑。明断具足。喜乐充满。佛亲护念。无量志乐。皆悉成就。佛子。菩萨住此焰慧地。以愿力故。得见多佛。所谓见多百佛。见多千佛。见多百千佛。乃至见多百千亿那由他佛。皆恭敬尊重。承事供养。衣服卧具。饮食汤药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。皆悉回向阿耨多罗三藐三菩提。于彼佛所。恭敬听法。闻已受持。具足修行。复于彼诸佛法中。出家修道。又更修治。深心信解。经无量百千亿那由他劫。令诸善根。转复明净。佛子。譬如金师炼治真金。作庄严具。余所有金。皆不能及。菩萨摩诃萨。亦复如是。住于此地。所有善根。下地善根。所不能及。如摩尼宝。清净光轮。能放光明。非诸余宝之所能及。风雨等缘。悉不能坏。菩萨摩诃萨。亦复如是。住于此地。下地菩萨。所不能及。众魔烦恼。悉不能坏。此菩萨。于四摄中。同事偏多。十波罗蜜中。精进偏多。余非不修。但随力随分。佛子。是名略说菩萨摩诃萨第四焰慧地。菩萨住此地。多作须夜摩天王。以善方便。能除众生身见等惑。令住正见。布施爱语。利行同事。如是一切诸所作业。皆不离念佛。不离念法。不离念僧。乃至不离念具足一切种。一切智智。复作是念。我当于一切众生中为首。为胜为殊胜。为妙为微妙。为上为无上。乃至为一切智智依止者。是菩萨。若发勤精进。于一念顷。得入亿数三昧。得见亿数佛。得知亿数佛神力。能动亿数世界。乃至能示现亿数身。一一身。亿数菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于此数。百劫千劫。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义。而说颂言

  菩萨已净第三地　　次观众生世法界
  空界识界及三界　　心解悉了能趣入
  始登焰地增势力　　生如来家永不退
  于佛法僧信不坏　　观法无常无有起
  观世成坏业有生　　生死涅槃刹等业
  观前后际亦观尽　　如是修行生佛家
  得是法已增慈愍　　转更勤修四念处
  身受心法内外观　　世间贪爱皆除遣
  菩萨修治四勤行　　恶法除灭善增长
  神足根力悉善修　　七觉八道亦如是
  为度众生修彼行　　本愿所护慈悲首
  求一切智及佛土　　亦念如来十种力
  四无所畏不共法　　殊特相好深美音
  亦求妙道解脱处　　及大方便修行彼
  身见为首六十二　　我及我所无量种
  蕴界处等诸取着　　此四地中一切离
  如来所诃烦恼行　　以无义利皆除断
  智者修行清净业　　为度众生无不作
  菩萨勤修不懈怠　　即得十心皆具足
  专求佛道无厌倦　　志期受职度众生
  恭敬尊德修行法　　知恩易诲无愠暴
  舍慢离谄心调柔　　转更精勤不退转
  菩萨住此焰慧地　　其心清净永不失
  悟解决定善增长　　疑网垢浊悉皆离
  此地菩萨人中胜　　供那由他无量佛
  听闻正法亦出家　　不可沮坏如真金
  菩萨住此具功德　　以智方便修行道
  不为众魔心退转　　譬如妙宝无能坏
  住此多作焰天王　　于法自在众所尊
  普化群生除恶见　　专求佛智修善业
  菩萨勤加精进力　　获三昧等皆亿数
  若以愿智力所为　　过于此数无能知
  如是菩萨第四地　　所行清净微妙道
  功德义智共相应　　我为佛子已宣说

    第五地

  菩萨闻此胜地行　　于法解悟心欢喜
  空中雨华赞叹言　　善哉大士金刚藏
  自在天王与天众　　闻法踊跃住虚空
  普放种种妙光云　　供养如来喜充遍
  天诸采女奏天乐　　亦以言辞歌赞佛
  悉以菩萨威神故　　于彼声中发是言
  佛愿久远今乃满　　佛道久远今乃得
  释迦文佛至天宫　　利天人者久乃见
  大海久远今始动　　佛光久远今乃放
  众生久远始安乐　　大悲音声久乃闻
  功德彼岸皆已到　　憍慢黑闇皆已灭
  最极清净如虚空　　不染世法犹莲华
  大牟尼尊现于世　　譬如须弥出巨海
  供养能尽一切苦　　供养必得诸佛智
  此应供处供无等　　是故欢心供养佛
  如是无量诸天女　　发此言辞称赞已
  一切恭敬喜充满　　瞻仰如来默然住
  是时大士解脱月　　复请无畏金刚藏
  第五地中诸行相　　唯愿佛子为宣说

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。第四地所行道。善圆满已。欲入第五难胜地。当以十种平等清净心趣入。何等为十。所谓于过去佛法平等清净心。未来佛法平等清净心。现在佛法平等清净心。戒平等清净心。心平等清净心。除见疑悔平等清净心。道非道智平等清净心。修行智见平等清净心。于一切菩提分法上上观察平等清净心。教化一切众生平等清净心。菩萨摩诃萨。以此十种平等清净心。得入菩萨第五地。佛子。菩萨摩诃萨。住此第五地已。以善修菩提分法故。善净深心故。复转求上胜道故。随顺真如故。愿力所持故。于一切众生慈愍不舍故。积集福智助道故。精勤修习不息故。出生善巧方便故。观察照明上上地故。受如来护念故。念智力所持故。得不退转心。佛子。此菩萨摩诃萨。如实知此是苦圣谛。此是苦集圣谛。此是苦灭圣谛。此是苦灭道圣谛。善知俗谛。善知第一义谛。善知相谛。善知差别谛。善知成立谛。善知事谛。善知生谛。善知尽无生谛。善知入道智谛。善知一切菩萨地。次第成就谛。乃至善知如来智成就谛。此菩萨。随众生心乐令欢喜故。知俗谛通达一实相故。知第一义谛觉法自相共相故。知相谛了诸法分位差别故。知差别谛善分别蕴界处故。知成立谛觉身心苦恼故。知事谛觉诸趣生相续故。知生谛一切热恼毕竟灭故。知尽无生智谛出生无二故。知入道智谛正觉一切行相故。善知一切菩萨地。次第相续成就。乃至如来智成就谛。以信解智力知。非以究竟智力知。佛子。此菩萨摩诃萨。得如是诸谛智已。如实知一切有为法。虚妄诈伪。诳惑愚夫。菩萨尔时。于诸众生。转增大悲。生大慈光明。佛子。此菩萨摩诃萨。得如是智力。不舍一切众生。常求佛智。如实观一切有为行。前际后际。知从前际无明。有爱故生生死流转。于诸蕴宅。不能动出。增长苦聚。无我无寿者。无养育者。无更数取后趣身者。离我我所。如前际后际。亦如是。皆无所有。虚妄贪着。断尽出离。若有若无。皆如实知。佛子。此菩萨摩诃萨。复作是念。此诸凡夫。愚痴无智。甚为可愍。有无数身。已灭。今灭。当灭。如是尽灭。不能于身而生厌想。转更增长。机关苦事。随生死流。不能还返。于诸蕴宅。不求出离。不知忧畏四大毒蛇。不能拔出诸慢见箭。不能息灭贪恚痴火。不能破坏无明黑暗。不能干竭爱欲大海。不求十力大圣导师。入魔意稠林。于生死海中。为觉观波涛之所漂溺。佛子。此菩萨摩诃萨。复作是念。此诸众生。受如是苦。孤穷困迫。无救无依。无洲无舍。无导无目。无明覆翳。黑暗缠裹。我今为彼一切众生。修行福智助道之法。独一发心。不求伴侣。以是功德。令诸众生。毕竟清净。乃至获得如来十力。无碍智慧。佛子。此菩萨摩诃萨。以如是智慧。观察所修善根。皆为救护一切众生。利益一切众生。安乐一切众生。哀愍一切众生。成就一切众生。解脱一切众生。摄受一切众生。令一切众生。离诸苦恼。令一切众生。普得清净。令一切众生。悉皆调伏。令一切众生。入般涅槃。佛子。菩萨摩诃萨。住此第五难胜地。名为念者。不忘诸法故。名为智者。能善决了故。名为有趣者。知经意趣。次第连合故。名为惭愧者。自护护他故。名为坚固者。不舍戒行故。名为觉者。能观是处非处故。名为随智者。不随于他故。名为随慧者。善知义非义句差别故。名为神通者。善修禅定故。名为方便善巧者。能随世行故。名为无厌足者。善集福德故。名为不休息者。常求智慧故。名为不疲倦者。集大慈悲故。名为为他勤修者。欲令一切众生。入涅槃故。名为勤求不懈者。求如来力无畏不共法故。名为发意能行者。成就庄严佛土故。名为勤修种种善业者。能具足相好故。名为常勤修习者。求庄严佛身语意故。名为大尊重恭敬法者。于一切菩萨法师处。如教而行故。名为心无障碍者。以大方便。常行世间故。名为日夜远离余心者。常乐教化一切众生故。佛子。菩萨摩诃萨。如是勤修行时。以布施教化众生。以爱语利行同事。教化众生。示现色身。教化众生。演说诸法。教化众生。开示菩萨行。教化众生显示如来大威力。教化众生。示生死过患。教化众生。称赞如来智慧利益。教化众生。现大神通力。教化众生。以种种方便行。教化众生。佛子。此菩萨摩诃萨。能如是勤方便。教化众生。心恒相续。趣佛智慧。所作善根。无有退转。常勤修学殊胜行法。佛子。此菩萨摩诃萨。为利益众生故。世间技艺。靡不该习。所谓文字算数。图书印玺。地水火风。种种诸论。咸所通达。又善方药。疗治诸病。颠狂干消。鬼魅蛊毒。悉能除断。文笔赞咏。歌舞妓乐。戏笑谈说。悉善其事。国城村邑。宫宅园苑。泉流陂池。草树花药。凡所布列。咸得其宜。金银摩尼。真珠琉璃。螺贝璧玉。珊瑚等藏。悉知其处。出以示人。日月星宿。鸟鸣地震。夜梦吉凶。身相休咎。咸善观察。一无错谬。持戒入禅。神通无量。四无色等。及余一切世间之事。但于众生。不为损恼。为利益故。咸悉开示。渐令安住无上佛法

佛子。菩萨住是难胜地。以愿力故。得见多佛。所谓见多百佛。见多千佛。见多百千佛。乃至见多百千亿那由他佛。悉恭敬尊重。承事供养。衣服饮食。卧具汤药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。回向阿耨多罗三藐三菩提。于诸佛所。恭敬听法。闻已受持。随力修行。复于彼诸佛法中。而得出家。既出家已。又更闻法。得陀罗尼。为闻持法师。住此地中。经于百劫。经于千劫。乃至无量百千亿那由他劫。所有善根。转更明净。佛子。譬如真金。以砗磲磨莹。转更明净。此地菩萨。所有善根。亦复如是。以方便慧。思惟观察。转更明净。佛子。菩萨住此难胜地。以方便智。成就功德。下地善根。所不能及。佛子。如日月星宿。宫殿光明。风力所持。不可沮坏。亦非余风所能倾动。此地菩萨。所有善根。亦复如是。以方便智。随逐观察。不可沮坏。亦非一切声闻独觉世间善根所能倾动。此菩萨。十波罗蜜中。禅波罗蜜偏多。余非不修。但随力随分。佛子。是名略说菩萨摩诃萨第五难胜地。菩萨住此地。多作兜率陀天王。于诸众生。所作自在。摧伏一切外道邪见。能令众生。住实谛中。布施爱语利行同事。如是一切诸所作业。皆不离念佛。不离念法。不离念僧。乃至不离念具足一切种。一切智智。复作是念。我当于众生中。为首。为胜为殊胜。为妙为微妙。为上为无上。乃至为一切智智依止者。此菩萨。若发勤精进。于一念顷。得千亿三昧。见千亿佛。知千亿佛神力。能动千亿佛世界。乃至示现千亿身。一一身。示千亿菩萨。以为眷属。若以菩萨殊胜愿力。自在示现。过于此数。百劫千劫。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义。而说颂曰

  菩萨四地已清净　　思惟三世佛平等
  戒心除疑道非道　　如是观察入五地
  念处为弓根利箭　　正勤为马神足车
  五力坚铠破怨敌　　勇健不退入五地
  惭愧为衣觉分鬘　　净戒为香禅涂香
  智慧方便妙庄严　　入总持林三昧苑
  如意为足正念颈　　慈悲为眼智慧牙
  人中师子无我吼　　破烦恼怨入五地
  菩萨住此第五地　　转修胜上清净道
  志求佛法不退转　　思念慈悲无厌倦
  积集福智胜功德　　精勤方便观上地
  佛力所加具念慧　　了知四谛皆如实
  善知世谛胜义谛　　相谛差别成立谛
  事谛生尽及道谛　　乃至如来无碍谛
  如是观谛虽微妙　　未得无碍胜解脱
  以此能生大功德　　是故超过世智慧
  既观谛已知有为　　体性虚伪无坚实
  得佛慈愍光明分　　为利众生求佛智
  观诸有为先后际　　无明黑闇爱缠缚
  流转迟回苦聚中　　无我无人无寿命
  爱取为因受来苦　　欲求边际不可得
  迷妄漂流无返期　　此等可愍我应度
  蕴宅界蛇诸见箭　　心火猛炽痴闇重
  爱河漂转不暇观　　苦海沦胥阙明导
  如是知已勤精进　　所作皆为度众生
  名为有念有慧者　　乃至觉解方便者
  习行福智无厌足　　恭敬多闻不疲倦
  国土相好皆庄严　　如是一切为众生
  为欲教化诸世间　　善知书数印等法
  亦复善解诸方药　　疗治众病悉令愈
  文词歌舞皆巧妙　　宫宅园池悉安隐
  宝藏非一咸示人　　利益无量众生故
  日月星宿地震动　　乃至身相亦观察
  四禅无色及神通　　为益世间皆显示
  智者住此难胜地　　供那由佛亦听法
  如以妙宝磨真金　　所有善根转明净
  譬如星宿在虚空　　风力所持无损动
  亦如莲华不着水　　如是大士行于世
  住此多作兜率王　　能摧异道诸邪见
  所修诸善为佛智　　愿得十力救众生
  彼复修行大精进　　即时供养千亿佛
  得定动刹亦复然　　愿力所作过于是
  如是第五难胜地　　人中最上真实道
  我以种种方便力　　为诸佛子宣说竟

大方广佛华严经卷第三十六大方广佛华严经卷第三十七

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之四

  菩萨既闻诸胜行　　其心欢喜雨妙华
  放净光明散宝珠　　供养如来称善说
  百千天众皆欣庆　　共在空中散众宝
  华鬘璎珞及幢幡　　宝盖涂香咸供佛
  自在天王并眷属　　心生欢喜住空中
  散宝成云持供养　　赞言佛子快宣说
  无量天女空中住　　共以乐音歌赞佛
  音中悉作如是言　　佛语能除烦恼病
  法性本寂无诸相　　犹如虚空不分别
  超诸取着绝言道　　真实平等常清净
  若能通达诸法性　　于有于无心不动
  为欲救世勤修行　　此佛口生真佛子
  不取众相而行施　　本绝诸恶坚持戒
  解法无害常堪忍　　知法性离具精进
  已尽烦恼入诸禅　　善达性空分别法
  具足智力能博济　　灭除众恶称大士
  如是妙音千万种　　赞已默然瞻仰佛
  解脱月语金刚藏　　以何行相入后地

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。已具足第五地。欲入第六现前地。当观察十平等法。何等为十。所谓一切法无相故平等。无体故平等。无生故平等。无成故平等。本来清净故平等。无戏论故平等。无取舍故平等。寂静故平等。如幻如梦如影如响如水中月如镜中像如焰如化故平等。有无不二故平等。菩萨如是。观一切法。自性清净。随顺无违。得入第六现前地。得明利随顺忍。未得无生法忍

佛子。此菩萨摩诃萨。如是观已。复以大悲为首。大悲增上。大悲满足。观世间生灭。作是念。世间受生。皆由着我。若离此着。则无生处。复作是念。凡夫无智。执着于我。常求有无。不正思惟。起于妄行。行于邪道罪行福行不动行。积集增长。于诸行中。植心种子。有漏有取。复起后有。生及老死。所谓业为田。识为种。无明闇覆。爱水为润。我慢溉灌。见网增长。生名色芽。名色增长。生五根。诸根相对。生触。触对生受。受后希求生爱。爱增长生取。取增长生有。有生已。于诸趣中。起五蕴身名生。生已衰变为老。终殁为死。于老死时。生诸热恼。因热恼故。忧愁悲叹。众苦皆集。此因缘故。集无有集者。任运而灭。亦无灭者。菩萨如是。随顺观察缘起之相。佛子。此菩萨摩诃萨。复作是念。于第一义谛。不了故名无明。所作业果是行。行依止初心是识。与识共生四取蕴为名色。名色增长为六处。根境识三事和合是触。触共生有受。于受染着是爱。爱增长是取。取所起有漏业为有。从业起蕴为生。蕴熟为老。蕴坏为死。死时离别。愚迷贪恋。心胸烦闷为愁。涕泗咨嗟为叹。在五根为苦。在意地为忧。忧苦转多为恼。如是但有苦树增长。无我无我所。无作无受者。复作是念。若有作者。则有作事。若无作者。亦无作事。第一义中。俱不可得。佛子。此菩萨摩诃萨。复作是念。三界所有。唯是一心。如来于此。分别演说十二有支。皆依一心。如是而立。何以故。随事贪欲。与心共生。心是识。事是行。于行迷惑。是无明。与无明及心共生是名色。名色增长是六处。六处三分合为触。触共生是受。受无厌足是爱。爱摄不舍是取。彼诸有支生是有。有所起名生。生熟为老。老坏为死。佛子。此中无明。有二种业。一令众生。迷于所缘。二与行作生起因。行亦有二种业。一能生未来报。二与识作生起因。识亦有二种业。一令诸有相续。二与名色作生起因。名色亦有二种业。一互相助成。二与六处作生起因。六处亦有二种业。一各取自境界。二与触作生起因。触亦有二种业。一能触所缘。二与受作生起因。受亦有二种业。一能领受爱憎等事。二与爱作生起因爱亦有二种业。一染着可爱事。二与取作生起因。取亦有二种业。一令诸烦恼相续。二与有作生起因。有亦有二种业。一能令于余趣中生。二与生作生起因。生亦有二种业。一能起诸蕴。二与老作生起因。老亦有二种业。一令诸根变异。二与死作生起因。死亦有二种业。一能坏诸行。二不觉知故相续不绝。佛子。此中无明缘行。乃至生缘老死者。由无明乃至生为缘。令行乃至老死。不断助成故。无明灭。则行灭。乃至生灭。则老死灭者。由无明乃至生不为缘。令诸行乃至老死。断灭不助成故。佛子。此中无明爱取不断。是烦恼道。行有不断。是业道。余分不断。是苦道。前后际分别灭三道断。如是三道。离我我所。但有生灭。犹如束芦。复次无明缘行者。是观过去。识乃至受。是观现在。爱乃至有。是观未来。于是以后。展转相续。无明灭行灭者。是观待断。复次十二有支。名为三苦。此中无明行。乃至六处。是行苦。触受是苦苦。余是坏苦。无明灭行灭者。是三苦断。复次无明缘行者。无明因缘。能生诸行。无明灭行灭者。以无无明。诸行亦无。余亦如是。又无明缘行者。是生系缚。无明灭行灭者。是灭系缚。余亦如是。又无明缘行者。是随顺无所有观。无明灭行灭者。是随顺尽灭观。余亦如是。佛子。菩萨摩诃萨。如是十种。逆顺观诸缘起。所谓有支相续故。一心所摄故。自业差别故。不相舍离故。三道不断故。观过去现在未来故。三苦聚集故。因缘生灭故。生灭系缚故。无所有尽观故

佛子。菩萨摩诃萨。以如是十种相观诸缘起。知无我无人。无寿命自性空。无作者无受者。即得空解脱门现在前。观诸有支。皆自性灭。毕竟解脱。无有少法相生。即时得无相解脱门现在前。如是入空无相已。无有愿求。唯除大悲为首。教化众生。即时得无愿解脱门现在前。菩萨如是。修三解脱门。离彼我想。离作者受者想。离有无想

佛子。此菩萨摩诃萨。大悲转增。精勤修习。为未满菩提分法。令圆满故。作是念。一切有为。有和合则转。无和合则不转。缘集则转。缘不集则不转。我如是。知有为法。多诸过患。当断此和合因缘。然为成就众生故。亦不毕竟灭于诸行。佛子。菩萨如是。观察有为。多诸过患。无有自性。不生不灭。而恒起大悲。不舍众生。即得般若波罗蜜现前。名无障碍智光明。成就如是智光明已。虽修习菩提分因缘。而不住有为中。虽观有为法自性寂灭。亦不住寂灭中。以菩提分法。未圆满故

佛子。菩萨住此现前地。得入空三昧。自性空三昧。第一义空三昧。第一空三昧。大空三昧。合空三昧。起空三昧。如实不分别空三昧。不舍离空三昧。离不离空三昧。此菩萨得如是十空三昧门为首。百千空三昧。皆悉现前。如是十无相。十无愿三昧门为首。百千无相无愿三昧门。皆悉现前

佛子。菩萨住此现前地。复更修习满足不可坏心。决定心。纯善心。甚深心。不退转心。不休息心。广大心。无边心。求智心。方便慧相应心。皆悉圆满

佛子。菩萨以此心。顺佛菩提不惧异论。入诸智地。离二乘道。趣于佛智。诸烦恼魔。无能沮坏。住于菩萨智慧光明。于空无相无愿法中。皆善修习。方便智慧。恒共相应。菩提分法。常行不舍。佛子。菩萨住此现前地中。得般若波罗蜜行增上。得第三明利顺忍。以于诸法如实相。随顺无违故

佛子。菩萨住此现前地已。以愿力故。得见多佛。所谓见多百佛。乃至见多百千亿那由他佛。悉以广大心深心。供养恭敬。尊重赞叹。衣服饮食。卧具汤药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。回向阿耨多罗三藐三菩提。于诸佛所。恭敬听法。闻已受持。得如实三昧。智慧光明。随顺修行。忆持不舍。又得诸佛甚深法藏。经于百劫。经于千劫。乃至无量百千亿那由他劫。所有善根。转更明净。譬如真金。以毗琉璃宝。数数磨莹。转更明净。此地菩萨。所有善根。亦复如是。以方便慧。随逐观察。转更明净。转复寂灭。无能映蔽。譬如月光。照众生身。令得清凉。四种风轮。所不能坏。此地菩萨。所有善根。亦复如是。能灭无量百千亿那由他众生烦恼炽火。四种魔道。所不能坏。此菩萨。十波罗蜜中。般若波罗蜜偏多。余非不修。但随力随分。佛子。是名略说菩萨摩诃萨第六现前地。菩萨住此地。多作善化天王。所作自在。一切声闻。所有问难。无能退屈。能令众生。除灭我慢。深入缘起。布施爱语利行同事。如是一切诸所作业。皆不离念佛。乃至不离念具足一切种。一切智智。复作是念。我当于一切众生中。为首为胜。乃至为一切智智依止者。此菩萨。若勤行精进。于一念顷。得百千亿三昧。乃至示现百千亿菩萨。以为眷属。若以愿力。自在示现。过于此数。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义。而说颂曰

  菩萨圆满五地已　　观法无相亦无性
  无生无成本清净　　无有戏论无取舍
  体相寂灭如幻等　　有无不二离分别
  随顺法性如是观　　此智得成入六地
  明利顺忍智具足　　观察世间生灭相
  以痴闇力世间生　　若灭痴闇世无有
  观诸因缘实义空　　不坏假名和合用
  无作无受无思念　　诸行如云遍兴起
  不知真谛名无明　　所作思业愚痴果
  识起共生是名色　　如是乃至众苦聚
  了达三界依心有　　十二因缘亦复然
  生死皆由心所作　　心若灭者生死尽
  无明所作有二种　　缘中不了为行因
  如是乃至老终殁　　从此苦生无有尽
  无明为缘不可断　　彼缘若尽悉皆灭
  愚痴爱取烦恼支　　行有是业余皆苦
  痴至六处是行苦　　触受增长是苦苦
  所余有支是坏苦　　若见无我三苦灭
  无明与行为过去　　识至于受现在转
  爱取有生未来苦　　观待若断边际尽
  无明为缘是生缚　　于缘得离缚乃尽
  从因生果离则断　　观察于此知性空
  随顺无明起诸有　　若不随顺诸有断
  此有彼有无亦然　　十种思惟心离着
  有支相续一心摄　　自业不离及三道
  三际三苦因缘生　　系缚起灭顺无尽
  如是普观缘起行　　无作无受无真实
  如幻如梦如光影　　亦如愚夫逐阳焰
  如是观察入于空　　知缘性离得无相
  了其虚妄无所愿　　唯除慈愍为众生
  大士修行解脱门　　转益大悲求佛法
  知诸有为和合作　　志乐决定勤行道
  空三昧门具百千　　无相无愿亦复然
  般若顺忍皆增上　　解脱智慧得成满
  复以深心多供佛　　于佛教中修习道
  得佛法藏增善根　　如金琉璃所磨莹
  如月清凉被众物　　四风来触无能坏
  此地菩萨超魔道　　亦息群生烦恼热
  此地多作善化王　　化导众生除我慢
  所作皆求一切智　　悉已超胜声闻道
  此地菩萨勤精进　　获诸三昧百千亿
  亦见若干无量佛　　譬如盛夏空中日
  甚深微妙难见知　　声闻独觉无能了
  如是菩萨第六地　　我为佛子已宣说

    第七地

  是时天众心欢喜　　散宝成云在空住
  普发种种妙音声　　告于最胜清净者
  了达胜义智自在　　成就功德百千亿
  人中莲华无所著　　为利群生演深行
  自在天王在空中　　放大光明照佛身
  亦散最上妙香云　　普供除忧烦恼者
  尔时天众皆欢喜　　悉发美音同赞述
  我等闻斯地功德　　则为已获大善利
  天女是时心庆悦　　竞奏乐音千万种
  悉以如来神力故　　音中共作如是言
  威仪寂静最无比　　能调难调世应供
  已超一切诸世间　　而行于世阐妙道
  虽现种种无量身　　知身一一无所有
  巧以言辞说诸法　　不取文字音声相
  往诣百千诸国土　　以诸上供供养佛
  智慧自在无所著　　不生于我佛国想
  虽勤教化诸众生　　而无彼己一切心
  虽已修成广大善　　而于善法不生着
  以见一切诸世间　　贪恚痴火常炽然
  于诸想念悉皆离　　发起大悲精进力
  一切诸天及天女　　种种供养称赞已
  悉共同时默然住　　瞻仰人尊愿闻法
  时解脱月复请言　　此诸大众心清净
  第七地中诸行相　　唯愿佛子为宣说

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。具足第六地行已。欲入第七远行地。当修十种方便慧。起殊胜道。何等为十。所谓虽善修空无相无愿三昧。而慈悲不舍众生。虽得诸佛平等法。而乐常供养佛。虽入观空智门。而勤集福德。虽远离三界。而庄严三界。虽毕竟寂灭诸烦恼焰。而能为一切众生。起灭贪嗔痴烦恼焰。虽知诸法如幻如梦如影如响如焰如化如水中月如镜中像自性无二。而随心作业无量差别。虽知一切国土犹如虚空。而能以清净妙行。庄严佛土。虽知诸佛法身本性无身。而以相好。庄严其身。虽知诸佛音声性空寂灭不可言说。而能随一切众生。出种种差别清净音声。虽随诸佛了知三世唯是一念。而随众生意解分别。以种种相。种种时。种种劫数。而修诸行。菩萨以如是十种方便慧。起殊胜行。从第六地。入第七地。入已此行常现在前。名为住第七远行地。佛子。菩萨摩诃萨。住此第七地已。入无量众生界。入无量诸佛教化众生业。入无量世界网。入无量诸佛清净国土。入无量种种差别法。入无量诸佛现觉智。入无量劫数。入无量诸佛觉了三世智。入无量众生差别信解。入无量诸佛示现种种名色身。入无量众生欲乐诸根差别。入无量诸佛语言音声令众生欢喜。入无量众生种种心行。入无量诸佛了知广大智。入无量声闻乘信解。入无量诸佛说智道令信解。入无量辟支佛所成就。入无量诸佛说甚深智慧门令趣入。入无量诸菩萨方便行。入无量诸佛所说大乘集成事令菩萨得入。此菩萨作是念。如是无量如来境界。乃至于百千亿那由他劫。不能得知。我悉应以无功用无分别心。成就圆满。佛子。此菩萨。以深智慧。如是观察。常勤修习方便慧。起殊胜道。安住不动。无有一念休息废舍。行住坐卧。乃至睡梦。未曾暂与盖障相应。常不舍于如是想念。此菩萨于念念中。常能具足十波罗蜜。何以故。念念皆以大悲为首。修行佛法。向佛智故。所有善根。为求佛智。施与众生。是名檀那波罗蜜。能灭一切诸烦恼热。是名尸罗波罗蜜。慈悲为首。不损众生。是名羼提波罗蜜。求胜善法。无有厌足。是名毗梨耶波罗蜜。一切智道。常现在前。未尝散乱。是名禅那波罗蜜。能忍诸法。无生无灭。是名般若波罗蜜。能出生无量智。是名方便波罗蜜。能求上上胜智。是名愿波罗蜜。一切异论。及诸魔众。无能沮坏。是名力波罗蜜。如实了知一切法。是名智波罗蜜。佛子。此十波罗蜜。菩萨于念念中。皆得具足。如是四摄四持。三十七品。三解脱门。略说乃至一切菩提分法。于念念中。皆悉圆满

尔时解脱月菩萨。问金刚藏菩萨言。佛子。菩萨但于此第七地中。满足一切菩提分法。为诸地中。亦能满足。金刚藏菩萨言。佛子。菩萨于十地中。皆能满足。菩提分法。然第七地。最为殊胜。何以故。此第七地。功用行满。得入智慧自在行故。佛子。菩萨于初地中。缘一切佛法愿求故。满足菩提分法。第二地离心垢故。第三地愿转增长得法光明故。第四地入道故。第五地顺世所作故。第六地入甚深法门故。第七地起一切佛法故。皆亦满足菩提分法。何以故。菩萨从初地。乃至第七地成就智功用分。以此力故。从第八地。乃至第十地无功用行。皆悉成就。佛子。譬如有二世界。一处杂染。一处纯净。是二中间。难可得过。唯除菩萨有大方便神通愿力。佛子。菩萨诸地。亦复如是。有杂染行。有清净行。是二中间。难可得过。唯除菩萨有大愿力方便智慧。乃能得过。解脱月菩萨言。佛子。此七地菩萨。为是染行。为是净行。金刚藏菩萨言。佛子。从初地至七地。所行诸行。皆舍离烦恼业。以回向无上菩提故。分得平等道故。然未名为超烦恼行。佛子。譬如转轮圣王。乘天象宝。游四天下。知有贫穷困苦之人。而不为彼众患所染。然未名为超过人位。若舍王身。生于梵世。乘天宫殿。见千世界。游千世界。示现梵天光明威德。尔乃名为超过人位。佛子。菩萨亦复如是。始从初地。至于七地。乘波罗蜜乘。游行世间。知诸世间烦恼过患。以乘正道故。不为烦恼过失所染。然未名为超烦恼行。若舍一切有功用行。从第七地。入第八地。乘菩萨清净乘游行世间。知烦恼过失不为所染。尔乃名为超烦恼行。以得一切尽超过故。佛子。此第七地菩萨尽超过多贪等诸烦恼众住此地。不名有烦恼者。不名无烦恼者。何以故。一切烦恼。不现行故。不名有者。求如来智。心未满故。不名无者

佛子。菩萨住此第七地。以深净心。成就身业。成就语业。成就意业。所有一切不善业道。如来所诃。皆已舍离。一切善业。如来所赞。常善修行。世间所有。经书技术。如五地中说。皆自然而行。不假功用。此菩萨。于三千大千世界中。为大明师。唯除如来及八地已上。其余菩萨。深心妙行。无与等者。诸禅三昧。三摩钵底。神通解脱。皆得现前。然是修成。非如八地报得成就。此地菩萨。于念念中。具足修习方便智力及一切菩提分法。转胜圆满佛子。菩萨住此地。入菩萨善观择三昧。善择义三昧。最胜慧三昧。分别义藏三昧。如实分别义三昧。善住坚固根三昧。智慧神通门三昧。法界业三昧。如来胜利三昧。种种义藏生死涅槃门三昧。入如是等具足大智神通门百万三昧。净治此地。是菩萨。得此三昧。善治净方便慧故。大悲力故。超过二乘地。得观察智慧地

佛子。菩萨住此地。善净无量身业无相行。善净无量语业无相行。善净无量意业无相行故。得无生法忍光明。解脱月菩萨言。佛子。菩萨从初地来。所有无量。身语意业。岂不超过二乘耶。金刚藏菩萨言。佛子。彼悉超过。然但以愿求诸佛法故。非是自智观察之力。今第七地自智力故。一切二乘。所不能及。譬如王子。生在王家。王后所生。具足王相。生已即胜一切臣众。但以王力。非是自力。若身长大。艺业悉成。乃以自力。超过一切。菩萨摩诃萨。亦复如是。初发心时。以志求大法故。超过一切声闻独觉。今住此地。以自所行。智慧力故。出过一切二乘之上。佛子。菩萨住此第七地。得甚深远离无行常行。身语意业。勤求上道。而不舍离。是故菩萨。虽行实际。而不作证解脱月菩萨言。佛子。菩萨从何地来。能入灭定。金刚藏菩萨言。佛子。菩萨从第六地来。能入灭定。今住此地。能念念入。亦念念起。而不作证。故此菩萨。名为成就不可思议。身语意业。行于实际。而不作证。譬如有人。乘船入海。以善巧力。不遭水难。此地菩萨。亦复如是。乘波罗蜜船。行实际海。以愿力故。而不证灭

佛子。此菩萨得如是三昧智力。以大方便。虽示现生死。而恒住涅槃。虽眷属围绕。而常乐远离。虽以愿力三界受生。而不为世法所染。虽常寂灭。以方便力。而还炽然。虽然不烧。虽随顺佛智。而示入声闻辟支佛地。虽得佛境界藏。而示住魔境界。虽超魔道。而现行魔法。虽示同外道行。而不舍佛法。虽示随顺一切世间。而常行一切出世间法。所有一切庄严之事。出过一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。人及非人。帝释梵王。四天王等之所有者。而不舍离乐法之心。佛子。菩萨成就如是智慧。住远行地。以愿力故。得见多佛。所谓见多百佛。乃至见多百千亿那由他佛。于彼佛所。以广大心。增胜心。供养恭敬。尊重赞叹。衣服饮食。卧具医药。一切资生。悉以奉施。亦以供养一切众僧。以此善根。回向阿耨多罗三藐三菩提。复于佛所。恭敬听法。闻已受持。获如实三昧智慧光明。随顺修行。于诸佛所。护持正法。常为如来之所赞喜。一切二乘。所有问难。无能退屈。利益众生。法忍清净。如是。经无量百千亿那由他劫。所有善根。转更增胜。譬如真金。以众妙宝。间错庄严。转更增胜。倍益光明。余庄严具。所不能及。菩萨住此第七地。所有善根。亦复如是。以方便慧力。转更明净。非是二乘之所能及。佛子。譬如日光。星月等光。无能及者。阎浮提地。所有泥潦。悉能干竭。此远行地菩萨。亦复如是。一切二乘无有能及。悉能干竭一切众生诸惑泥潦。此菩萨。十波罗蜜中。方便波罗蜜偏多。余非不行。但随力随分。佛子。是名略说菩萨摩诃萨第七远行地。菩萨住此地。多作自在天王。善为众生。说证智法。令其证入。布施爱语利行同事。如是一切诸所作业。皆不离念佛。乃至不离念具足一切种。一切智智。复作是念。我当于一切众生中。为首为胜。乃至为一切智智依止者。此菩萨。若发勤精进。于一念顷。得百千亿那由他三昧。乃至示现百千亿那由他菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于此数。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣此义。而说颂曰

  第一义智三昧道　　六地修行心满足
  即时成就方便慧　　菩萨以此入七地
  虽明三脱起慈悲　　虽等如来勤供佛
  虽观于空集福德　　菩萨以此升七地
  远离三界而庄严　　灭除惑火而起焰
  知法无二勤作业　　了刹皆空乐严土
  解身不动具诸相　　达声性离善开演
  入于一念事各别　　智者以此升七地
  观察此法得明了　　广为群迷兴利益
  入众生界无有边　　佛教化业亦无量
  国土诸法与劫数　　解欲心行悉能入
  说三乘法亦无限　　如是教化诸群生
  菩萨勤求最胜道　　动息不舍方便慧
  一一回向佛菩提　　念念成就波罗蜜
  发心回向是布施　　灭惑为戒不害忍
  求善无厌斯进策　　于道不动即修禅
  忍受无生名般若　　回向方便希求愿
  无能摧力善了智　　如是一切皆成满
  初地攀缘功德满　　二地离垢三诤息
  四地入道五顺行　　第六无生智光照
  七住菩提功德满　　种种大愿皆具足
  以是能令八地中　　一切所作咸清净
  此地难过智乃超　　譬如世界二中间
  亦如圣王无染着　　然未名为总超度
  若住第八智地中　　尔乃逾于心境界
  如梵观世超人位　　如莲处水无染着
  此地虽超诸惑众　　不名有惑非无惑
  以无烦恼于中行　　而求佛智心未足
  世间所有众技艺　　经书词论普明了
  禅定三昧及神通　　如是修行悉成就
  菩萨修成七住道　　超过一切二乘行
  初地愿故此由智　　譬如王子力具足
  成就甚深仍进道　　心心寂灭不取证
  譬如乘船入海中　　在水不为水所溺
  方便慧行功德具　　一切世间无能了
  供养多佛心益明　　如以妙宝庄严金
  此地菩萨智最明　　如日舒光竭爱水
  又作自在天中主　　化导群生修正智
  若以勇猛精勤力　　获多三昧见多佛
  百千亿数那由他　　愿力自在复过是
  此是菩萨远行地　　方便智慧清净道
  一切世间天及人　　声闻独觉无能知

大方广佛华严经卷第三十七大方广佛华严经卷第三十八

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之五

  是时天王及天众　　闻此胜行皆欢喜
  为欲供养于如来　　及以无央大菩萨
  雨妙华幡及幢盖　　香鬘璎珞与宝衣
  无量无边千万种　　悉以摩尼作严饰
  天女同时奏天乐　　普发种种妙音声
  供养于佛并佛子　　共作是言而赞叹
  一切见者两足尊　　哀愍众生现神力
  令此种种诸天乐　　普发妙音咸得闻
  于一毛端百千亿　　那由他国微尘数
  如是无量诸如来　　于中安住说妙法
  一毛孔内无量刹　　各有四洲及大海
  须弥铁围亦复然　　悉见在中无迫隘
  一毛端处有六趣　　三种恶道及人天
  诸龙神众阿修罗　　各随自业受果报
  于彼一切刹土中　　悉有如来演妙音
  随顺一切众生心　　为转最上净法轮
  刹中种种众生身　　身中复有种种刹
  人天诸趣各各异　　佛悉知已为说法
  大刹随念变为小　　小刹随念亦变大
  如是神通无有量　　世间共说不能尽
  普发此等妙音声　　称赞如来功德已
  众会欢喜默然住　　一心瞻仰欲听说
  时解脱月复请言　　今此众会皆寂静
  愿说随次之所入　　第八地中诸行相

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。于七地中。善修习方便慧。善清净诸道。善集助道法。大愿力所摄。如来力所加。自善力所持。常念如来。力无所畏。不共佛法。善清净深心思觉。能成就福德智慧。大慈大悲。不舍众生。入无量智道。入一切法。本来无生。无起无相。无成无坏。无尽无转。无性为性。初中后际。皆悉平等。无分别如如智之所入处。离一切心意识分别想。无所取着。犹如虚空入一切法。如虚空性。是名得无生法忍佛子。菩萨成就此忍。即时得入第八不动地。为深行菩萨。难可知无差别。离一切相。一切想。一切执着。无量无边。一切声闻辟支佛。所不能及。离诸諠诤。寂灭现前。譬如比丘。具足神通。得心自在。次第乃至入灭尽定。一切动心。忆想分别。悉皆止息。此菩萨摩诃萨。亦复如是。住不动地。即舍一切功用行。得无功用法。身口意业。念务皆息。住于报行。譬如有人。梦中见身。堕在大河。为欲渡故。发大勇猛。施大方便。以大勇猛。施方便故。即便觉寤。既觉寤已。所作皆息。菩萨亦尔。见众生身在四流中。为救度故。发大勇猛。起大精进。以勇猛精进故。至不动地。既至此已。一切功用。靡不皆息。二行相行。悉不现前。佛子。如生梵世。欲界烦恼。皆不现前。住不动地。亦复如是。一切心意识行。皆不现前。此菩萨摩诃萨。菩萨心佛心。菩提心涅槃心。尚不现起。况复起于世间之心。佛子。此地菩萨。本愿力故。诸佛世尊。亲现其前。与如来智。令其得入法流门中。作如是言。善哉善哉。善男子。此忍第一。顺诸佛法。然善男子。我等所有。十力无畏。十八不共诸佛之法。汝今未得。汝应为欲成就此法。勤加精进。勿复放舍于此忍门。又善男子。汝虽得是寂灭解脱。然诸凡夫。未能证得。种种烦恼。皆悉现前。种种觉观。常相侵害。汝当愍念如是众生。又善男子。汝当忆念本所誓愿。普大饶益一切众生。皆令得入不可思议智慧之门。又善男子。此诸法法性。若佛出世。若不出世。常住不异。诸佛不以得此法故名为如来。一切二乘。亦能得此无分别法。又善男子。汝观我等身相。无量智慧。无量国土。无量方便。无量光明。无量清净音声。亦无有量。汝今宜应成就此事。又善男子。汝今适得此一法明。所谓一切法。无生无分别。善男子。如来法明。无量入。无量作。无量转。乃至百千亿那由他劫。不可得知。汝应修行。成就此法。又善男子。汝观十方无量国土。无量众生。无量法。种种差别。悉应如实。通达其事。佛子。诸佛世尊。与此菩萨。如是等。无量起智门。令其能起无量无边。差别智业。佛子。若诸佛。不与此菩萨。起智门者。彼时即入究竟涅槃。弃舍一切利众生业。以诸佛与如是等无量无边。起智门故。于一念顷。所生智业。从初发心。乃至七地。所修诸行。百分不及一。乃至百千亿那由他分。亦不及一。如是。阿僧祇分。歌罗分。算数分。譬谕分。优波尼沙陀分。亦不及一。何以故。佛子。是菩萨。先以一身起行。今住此地。得无量身。无量音声。无量智慧。无量受生。无量净国。教化无量众生。供养无量诸佛。入无量法门。具无量神通。有无量众会。道场差别。住无量身语意业。集一切菩萨行。以不动法故。佛子。譬如乘船欲入大海。未至于海。多用功力。若至海已。但随风去。不假人力。以至大海。一日所行。比于未至。其未至时。设经百岁。亦不能及。佛子。菩萨摩诃萨。亦复如是。积集广大善根资粮。乘大乘船到菩萨行海。于一念顷以无功用智。入一切智智境界。本有功用行。经于无量百千亿那由他劫。所不能及

佛子。菩萨住此第八地。以大方便善巧智。所起无功用觉慧。观一切智智所行境。所谓观世间成。观世间坏。由此业集故成。由此业尽故坏。几时成。几时坏。几时成住。几时坏住。皆如实知。又知地界。小相大相。无量相。差别相。知水火风界。小相大相。无量相。差别相。知微尘细相。差别相。无量差别相。随何世界中。所有微尘聚。及微尘差别相。皆如实知。随何世界中。所有地水火风界各若干微尘。所有宝物若干微尘。众生身若干微尘。国土身若干微尘。皆如实知。知众生大身小身。各若干微尘成。知地狱身畜生身。饿鬼身阿修罗身。天身人身。各若干微尘成。得如是知微尘差别智。又知欲界色界。无色界成。知欲界色界无色界坏。知欲界色界。无色界小相大相。无量相差别相。得如是观三界差别智。佛子。此菩萨。复起智明。教化众生。所谓善知众生身差别。善分别众生身。善观察所生处。随其所应而为现身。教化成熟。此菩萨。于一三千大千世界。随众生身。信解差别。以智光明。普现受生。如是若二若三。乃至百千。乃至不可说。三千大千世界。随众生身。信解差别。普于其中。示现受生。此菩萨。成就如是智慧故。于一佛刹。其身不动。乃至不可说。佛刹众会中。悉现其身。佛子。此菩萨。随诸众生。身心信解。种种差别。于彼佛国。众会之中。而现其身。所谓于沙门众中。示沙门形。婆罗门众中。示婆罗门形。刹利众中。示刹利形。如是。毗舍众。首陀众。居士众。四天王众。三十三天众。夜摩天众。兜率陀天众。化乐天众。他化自在天众。魔众。梵众。乃至阿迦尼吒天众中。各随其类。而为现形。又应以声闻身得度者。现声闻形。应以辟支佛身得度者。现辟支佛形。应以菩萨身得度者。现菩萨形。应以如来身得度者。现如来形。佛子。菩萨如是。于一切不可说。佛国土中。随诸众生。信乐差别。如是如是而为现身。佛子。此菩萨。远离一切身想分别。住于平等。此菩萨。知众生身。国土身。业报身。声闻身。独觉身。菩萨身。如来身。智身。法身。虚空身。此菩萨。知诸众生心之所乐。能以众生身。作自身。亦作国土身。业报身。乃至虚空身。又知众生心之所乐。能以国土身。作自身。亦作众生身。业报身。乃至虚空身。又知诸众生心之所乐。能以业报身。作自身。亦作众生身。国土身。乃至虚空身。又知众生心之所乐。能以自身。作众生身。国土身。乃至虚空身。随诸众生。所乐不同。则于此身。现如是形。此菩萨。知众生集业身。报身。烦恼身。色身。无色身。又知国土身。小相大相无量相。染相净相。广相。倒住相。正住相。普入相。方网差别相。知业报身。假名差别。知声闻身独觉身。菩萨身假名差别。知如来身。有菩提身。愿身化身。力持身。相好庄严身。威势身。意生身。福德身。法身智身。知智身善思量相。如实决择相。果行所摄相。世间出世间差别相。三乘差别相。共相不共相。出离相非出离相。学相无学相。知法身平等相。不坏相。随时随俗。假名差别相。众生非众生法差别相。佛法圣僧法差别相。知虚空身无量相。周遍相。无形相。无异相。无边相。显现色身相。佛子。菩萨成就如是身智已。得命自在。心自在。财自在。业自在。生自在。愿自在。解自在。如意自在。智自在。法自在。得此十自在故。则为不思议智者。无量智者。广大智者。无能坏智者

此菩萨。如是入已。如是成就已。得毕竟无过失身业。无过失语业。无过失意业。身语意业。随智慧行。般若波罗蜜增上。大悲为首。方便善巧。善能分别。善起大愿。佛力所护。常勤修习利众生智。普住无边差别世界。佛子。举要言之。菩萨住此不动地。身语意业。诸有所作。皆能积集一切佛法。佛子。菩萨住此地得善住深心力。一切烦恼。不行故。得善住胜心力。不离于道故。得善住大悲力。不舍利益众生故。得善住大慈力。救护一切世间故。得善住陀罗尼力。不忘于法故。得善住辩才力。善观察分别一切法故。得善住神通力。普往无边世界故。得善住大愿力。不舍一切菩萨所作故。得善住波罗蜜力。成就一切佛法故。得如来护念力。一切种一切智智现前故。此菩萨。得如是智力。能现一切诸所作事。于诸事中。无有过咎

佛子。此菩萨智地。名为不动地。无能沮坏故。名为不转地。智慧无退故。名为难得地。一切世间。无能测故。名为童真地。离一切过失故。名为生地。随乐自在故。名为成地。更无所作故。名为究竟地。智慧决定故。名为变化地。随愿成就故。名为力持地。他不能动故。名为无功用地。先已成就故。佛子。菩萨成就如是智慧。入佛境界。佛功德照。顺佛威仪。佛境现前。常为如来之所护念。梵释四王。金刚力士。常随侍卫。恒不舍离诸大三昧。能现无量诸身差别。于一一身。有大势力。报得神通三昧自在。随有可化众生之处。示成正觉佛子。菩萨如是。入大乘会。获大神通。放大光明。入无碍法界。知世界差别。示现一切诸大功德。随意自在善能通达前际后际。普伏一切。魔邪之道。深入如来所行境界。于无量国土。修菩萨行。以能获得不退转法。是故说名住不动地。佛子。菩萨住此不动地已。以三昧力。常得现见无量诸佛。恒不舍离承事供养。此菩萨。于一一劫。一一世界。见无量百佛。无量千佛。乃至无量百千亿那由他佛。恭敬尊重。承事供养。一切资生。悉以奉施。于诸佛所。得于如来甚深法藏。受世界差别等。无量法明。若有问难世界差别。如是等事。无能屈者。如是经于无量百劫。无量千劫。乃至无量百千亿那由他劫。所有善根。转增明净。譬如真金。治作宝冠。置阎浮提主。圣王顶上。一切臣民。诸庄严具无与等者。此地菩萨。所有善根。亦复如是。一切二乘。乃至第七地菩萨。所有善根。无能及者。以住此地。大智光明。普灭众生。烦恼黑闇。善能开阐智慧门故。佛子。譬如千世界主。大梵天王。能普运慈心。普放光明。满千世界。此地菩萨。亦复如是。能放光明。照百万佛刹微尘数世界。令诸众生。灭烦恼火。而得清凉。此菩萨。十波罗蜜中。愿波罗蜜增上。余波罗蜜。非不修行。但随力随分。是名略说诸菩萨摩诃萨第八不动地。若广说者。经无量劫。不可穷尽。佛子。菩萨摩诃萨。住此地。多作大梵天王。主千世界。最胜自在。善说诸义。能与声闻辟支佛诸菩萨波罗蜜道。若有问难世界差别。无能退屈。布施爱语利行同事。如是一切诸所作业。皆不离念佛。乃至不离念一切种。一切智智。复作是念。我当于一切众生中。为首为胜。乃至为一切智智依止者。此菩萨。若以发起大精进力。于一念顷。得百万三千大千世界微尘数三昧。乃至示现百万三千大千世界微尘数菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于是数。乃至百千亿那由他劫。不能数知。尔时金刚藏菩萨。欲重宣其义而说颂曰

  七地修治方便慧　　善集助道大愿力
  复得人尊所摄持　　为求胜智登八住
  功德成就恒慈愍　　智慧广大等虚空
  闻法能生决定力　　是则寂灭无生忍
  知法无生无起相　　无成无坏无尽转
  离有平等绝分别　　超诸心行如空住
  成就是忍超戏论　　甚深不动恒寂灭
  一切世间无能知　　心相取着悉皆离
  住于此地不分别　　譬如比丘入灭定
  如梦渡河觉则无　　如生梵天绝下欲
  以本愿力蒙劝导　　叹其忍胜与灌顶
  语言我等众佛法　　汝今未获当勤进
  汝虽已灭烦恼火　　世间惑焰犹炽然
  当念本愿度众生　　悉使修因趣解脱
  法性真常离心念　　二乘于此亦能得
  不以此故为世尊　　但以甚深无碍智
  如是人天所应供　　与此智慧令观察
  无边佛法悉得成　　一念超过曩众行
  菩萨住兹妙智地　　则获广大神通力
  一念分身遍十方　　如船入海因风济
  心无功用任智力　　悉知国土成坏住
  诸界种种各殊异　　小大无量皆能了
  三千世界四大种　　六趣众生身各别
  及以众宝微尘数　　以智观察悉无余
  菩萨能知一切身　　为化众生同彼形
  国土无量种种别　　悉为现形无不遍
  譬如日月住虚空　　一切水中皆现影
  住于法界无所动　　随心现影亦复然
  随其心乐各不同　　一切众中皆现身
  声闻独觉与菩萨　　及以佛身靡不现
  众生国土业报身　　种种圣人智法身
  虚空身相皆平等　　普为众生而示作
  十种圣智普观察　　复顺慈悲作众业
  所有佛法皆成就　　持戒不动如须弥
  十力成就不动摇　　一切魔众无能转
  诸佛护念天王礼　　密迹金刚恒侍卫
  此地功德无边际　　千万亿劫说不尽
  复以供佛善益明　　如王顶上庄严具
  菩萨住此第八地　　多作梵王千界主
  演说三乘无有穷　　慈光普照除众惑
  一念所获诸三昧　　百万世界微尘等
  诸所作事悉亦然　　愿力示现复过是
  菩萨第八不动地　　我为汝等已略说
  若欲次第广分别　　经于亿劫不能尽

    第九地

  说此菩萨八地时　　如来现大神通力
  震动十方诸国土　　无量亿数难思议
  一切知见无上尊　　其身普放大光明
  照耀彼诸无量土　　悉使众生获安乐
  菩萨无量百千亿　　俱时踊在虚空住
  以过诸天上妙供　　供养说中最胜者
  大自在王自在天　　悉共同心喜无量
  各以种种众供具　　供养甚深功德海
  复有天女千万亿　　身心欢喜悉充遍
  各奏乐音无量种　　供养人中大导师
  是时众乐同时奏　　百千万亿无量别
  悉以善逝威神力　　演出妙音而赞叹
  寂静调柔无垢害　　随所入地善修习
  心如虚空诣十方　　广说佛道悟群生
  天上人间一切处　　悉现无等妙庄严
  以从如来功德生　　令其见者乐佛智
  不离一刹诣众土　　如月普现照世间
  音声心念悉皆灭　　譬犹谷响无不应
  若有众生心下劣　　为彼演说声闻行
  若心明利乐辟支　　则为彼说中乘道
  若有慈悲乐饶益　　为说菩萨所行事
  若有最胜智慧心　　则示如来无上法
  譬如幻师作众事　　种种形相皆非实
  菩萨智幻亦如是　　虽现一切离有无
  如是美音千万种　　歌赞佛已默然住
  解脱月言今众净　　愿说九地所行道

尔时金刚藏菩萨。告解脱月菩萨言。佛子。菩萨摩诃萨。以如是无量智。思量观察。欲更求转胜。寂灭解脱。复修习如来智慧。入如来秘密法。观察不思议。大智性净。诸陀罗尼三昧门。具广大神通。入差别世界。修力无畏不共法。随诸佛转法轮。不舍大悲本愿力。得入菩萨第九善慧地

佛子。菩萨摩诃萨。住此善慧地。如实知善不善。无记法行。有漏无漏法行。世间出世间法行。思议不思议法行。定不定法行。声闻独觉法行。菩萨行法行。如来地法行。有为法行。无为法行。此菩萨。以如是智慧。如实知众生心稠林。烦恼稠林。业稠林。根稠林。解稠林。性稠林。乐欲稠林。随眠稠林。受生稠林。习气相续稠林。三聚差别稠林。此菩萨。如实知众生心种种相。所谓杂起相。速转相。坏不坏相。无形质相。无边际相。清净相。垢无垢相。缚不缚相。幻所作相。随诸趣生相。如是。百千万亿。乃至无量。皆如实知。又知诸烦恼种种相。所谓久远随行相。无边引起相。俱生不舍相。眠起一义相。与心相应不相应相。随趣受生而住相。三界差别相。爱见痴慢如箭深入过患相。三业因缘不绝相。略说。乃至八万四千。皆如实知。又知诸业种种相。所谓善不善无记相。有表示无表示相。与心同生不离相。因自性刹那坏而次第集果不失相。有报无报相。受黑黑等众报相。如田无量相。凡圣差别相。现受生受后受相。乘非乘定不定相。略说。乃至八万四千。皆如实知。又知诸根。软中胜相。先际后际差别无差别相。上中下相。烦恼俱生不相离相。乘非乘定不定相。淳熟调柔相。随根网轻转坏相。增上无能坏相。退不退差别相。远随共生不同相。略说。乃至八万四千。皆如实知。又知诸解软中上。诸性软中上。乐欲软中上。皆略说。乃至八万四千。又知诸随眠种种相。所谓与深心共生相。与心共生相。心相应不相应差别相。久远随行相。无始不拔相。与一切禅定解脱三昧三摩钵底神通相违相。三界相续受生系缚相。令无边心相续现起相。开诸处门相。坚实难治相。地处成就不成就相。唯以圣道拔出相。又知受生种种相。所谓随业受生相。六趣差别相。有色无色差别相。有想无想差别相。业为田爱水润无明暗覆识为种子生后有芽相。名色俱生不相离相。痴爱希求续有相。欲受欲生无始乐着相。妄谓出三界贪求相。又知习气种种相。所谓行不行差别相。随趣熏习相。随众生行熏习相。随业烦恼熏习相。善不善无记熏习相。随入后有熏习相。次第熏习相。不断烦恼远行不舍熏习相。实非实熏习相。见闻亲近声闻独觉菩萨如来熏习相。又知众生。正定邪定不定相。所谓正见正定相。邪见邪定相。二俱不定相。五逆邪定相。五根正定相。二俱不定相。八邪邪定相。正性正定相。更不作二俱离不定相。深着邪法邪定相。习行圣道正定相。二俱舍不定相。佛子。菩萨随顺如是智慧。名住善慧地。住此地已。了知众生诸行差别。教化调伏。令得解脱

佛子。此菩萨。善能演说声闻乘法独觉乘法。菩萨乘法。如来地法。一切行处。智随行故。能随众生根性欲解。所行有异。诸聚差别。亦随受生烦恼眠缚。诸业习气。而为说法。令生信解。增益智慧。各于其乘。而得解脱

佛子。菩萨住此善慧地。作大法师。具法师行。善能守护如来法藏。以无量善巧智。起四无碍辩。用菩萨言辞。而演说法。此菩萨。常随四无碍智转。无暂舍离。何等为四。所谓法无碍智。义无碍智。辞无碍智。乐说无碍智。此菩萨。以法无碍智。知诸法自相。义无碍智。知诸法别相。辞无碍智。无错谬说。乐说无碍智。无断尽说。复次以法无碍智。知诸法自性。义无碍智。知诸法生灭。辞无碍智。安立一切法不断说。乐说无碍智。随所安立。不可坏无边说。复次以法无碍智。知现在法差别。义无碍智。知过去未来法差别。辞无碍智。于去来今法。无错谬说。乐说无碍智。于一一世。无边法明了说。复次以法无碍智。知法差别。义无碍智。知义差别。辞无碍智。随其言音说。乐说无碍智。随其心乐说。复次法无碍智。以法智。知差别不异。义无碍智。以比智。知差别如实。辞无碍智。以世智。差别说。乐说无碍智。以第一义智。善巧说。复次法无碍智。知诸法一相不坏。义无碍智。知蕴界处。谛缘起善巧。辞无碍智。以一切世间。易解了。美妙音声。文字说。乐说无碍智。以转胜无边法明说。复次法无碍智。知一乘平等性。义无碍智。知诸乘差别性。辞无碍智。说一切乘无差别。乐说无碍智。说一一乘无边法。复次法无碍智。知一切菩萨。行智行法。行智随证。义无碍智。知十地分位义差别。辞无碍智。说地道无差别相。乐说无碍智。说一一地无边行相。复次法无碍智。知一切如来。一念成正觉。义无碍智。知种种时。种种处等。各差别。辞无碍智。说成正觉差别。乐说无碍智。于一一句法。无量劫说不尽。复次法无碍智。知一切如来语。力无所畏。不共佛法。大慈大悲。辩才方便。转法轮。一切智智随证。义无碍智。知如来随八万四千。众生心行。根解差别音声。辞无碍智。随一切众生行。以如来音声差别说。乐说无碍智。随众生信解。以如来智。清净行圆满说

佛子。菩萨住第九地。得如是善巧无碍智。得如来妙法藏。作大法师。得义陀罗尼。法陀罗尼。智陀罗尼。光照陀罗尼。善慧陀罗尼。众财陀罗尼。威德陀罗尼。无碍门陀罗尼。无边际陀罗尼。种种义陀罗尼。如是等。百万阿僧祇陀罗尼门。皆得圆满。以百万阿僧祇善巧音声辩才门而演说法。此菩萨。得如是百万阿僧祇陀罗尼门已。于无量佛所。一一佛前。悉以如是百万阿僧祇陀罗尼门。听闻正法。闻已不忘。以无量差别门。为他演说。此菩萨。初见于佛。头顶礼敬。即于佛所。得无量法门。此所得法门。非彼闻持。诸大声闻。于百千劫。所能领受。此菩萨。得如是陀罗尼。如是无碍智。坐于法座。而说于法。大千世界。满中众生。随其心乐差别为说。唯除诸佛。及受职菩萨。其余众会。威德光明。无能与比。此菩萨。处于法座。欲以一音。令诸大众。皆得解了。即得解了。或时欲以种种音声。令诸大众。皆得开悟。或时心欲放大光明。演说法门。或时心欲于其身上。一一毛孔。皆演法音。或时心欲乃至三千大千世界。所有一切。形无形物。皆悉演出妙法言音。或时心欲发一言音。周遍法界。悉令解了。或时心欲一切言音。皆作法音。恒住不灭。或时心欲一切世界。箫笛钟鼓。及以歌咏。一切乐声。皆演法音。或时心欲于一字中。一切法句。言音差别。皆悉具足。或时心欲令不可说。无量世界。地水火风。四大聚中。所有微尘。一一尘中。皆悉演出不可说法门。如是所念。一切随心。无不得者

佛子。此菩萨。假使三千大千世界。所有众生咸至其前。一一皆以无量言音。而兴问难。一一问难。各各不同。菩萨。于一念顷。悉能领受。仍以一音。普为解释。令随心乐。各得欢喜。如是乃至不可说世界所有众生。一刹那间。一一皆以无量言音。而兴问难。一一问难。各各不同。菩萨于一念顷。悉能领受。亦以一音。普为解释。各随心乐。令得欢喜。乃至不可说不可说世界。满中众生。菩萨皆能随其心乐。随根随解。而为说法。承佛神力。广作佛事。普为一切作所依怙。佛子。此菩萨。复更精进。成就智明。假使一毛端处。有不可说世界微尘数。诸佛众会。一一众会。有不可说世界。微尘数众生。一一众生。有不可说世界。微尘数性欲。彼诸佛。随其性欲。各与法门。如一毛端处。一切法界处。悉亦如是。如是所说。无量法门。菩萨于一念中。悉能领受。无有忘失佛子。菩萨住此第九地。昼夜专勤。更无余念。唯入佛境界。亲近如来。入诸菩萨甚深解脱常在三昧。恒见诸佛。未曾舍离。一一劫中。见无量佛。无量百佛。无量千佛。乃至无量百千亿那由他佛。恭敬尊重。承事供养。于诸佛所。种种问难。得说法陀罗尼所有善根。转更明净。譬如真金。善巧金师用作宝冠。转轮圣王。以严其首。四天下内。一切小王。及诸臣民。诸庄严具。无与等者。此第九地。菩萨善根。亦复如是。一切声闻辟支佛。及下地菩萨。所有善根。无能与等。佛子。譬如二千世界主。大梵天王。身出光明。二千界中。幽远之处。悉能照耀。除其黑闇。此地菩萨。所有善根。亦复如是。能出光明照众生心。烦恼黑闇。皆令息灭。此菩萨。十波罗蜜中。力波罗蜜最胜。余波罗蜜。非不修行。但随力随分。佛子。是名略说菩萨摩诃萨第九善慧地。若广说者。于无量劫。亦不能尽。佛子。菩萨摩诃萨。住此地。多作二千世界主。大梵天王。善能统理。自在饶益。能为一切声闻缘觉。及诸菩萨。分别演说波罗蜜行。随众生心。所有问难。无能屈者。布施爱语利行同事。如是一切诸所作业。皆不离念佛。乃至不离念一切种。一切智智。复作是念。我当于一切众生中。为首为胜。乃至为一切智智依止者。此菩萨。若发勤精进。于一念顷。得百万阿僧祇国土微尘数三昧。乃至示现百万阿僧祇国土微尘数菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于此数。乃至百千亿那由他劫。不能数知

尔时。金刚藏菩萨。欲重宣其义。而说颂曰

  无量智力善观察　　最上微妙世难知
  普入如来秘密处　　利益众生入九地
  总持三昧皆自在　　获大神通入众刹
  力智无畏不共法　　愿力悲心入九地
  住于此地持法藏　　了善不善及无记
  有漏无漏世出世　　思不思议悉善知
  若法决定不决定　　三乘所作悉观察
  有为无为行差别　　如是而知入世间
  若欲知诸众生心　　则能以智如实知
  种种速转坏非坏　　无质无边等众相
  烦恼无边恒共伴　　眠起一义续诸趣
  业性种种各差别　　因坏果集皆能了
  诸根种种下中上　　先后际等无量别
  解性乐欲亦复然　　八万四千靡不知
  众生惑见恒随缚　　无始稠林未除翦
  与志共俱心并生　　常相羁系不断绝
  但唯妄想非实物　　不离于心无处所
  禅定境排仍退转　　金刚道灭方毕竟
  六趣受生各差别　　业田爱润无明覆
  识为种子名色芽　　三界无始恒相续
  惑业心习生诸趣　　若离于此不复生
  众生悉在三聚中　　或溺于见或行道
  住于此地善观察　　随其心乐及根解
  悉以无碍妙辩才　　如其所应差别说
  处于法座如师子　　亦如牛王宝山王
  又如龙王布密云　　霔甘露雨充大海
  善知法性及奥义　　随顺言辞能辩说
  总持百万阿僧祇　　譬如大海受众雨
  总持三昧皆清净　　能于一念见多佛
  一一佛所皆闻法　　复以妙音而演畅
  若欲三千大千界　　教化一切诸群生
  如云广布无不及　　随其根欲悉令喜
  毛端佛众无有数　　众生心乐亦无极
  悉应其心与法门　　一切法界皆如是
  菩萨勤加精进力　　复获功德转增胜
  闻持尔所诸法门　　如地能持一切种
  十方无量诸众生　　咸来亲近会中坐
  一念随心各问难　　一音普对悉充足
  住于此地为法王　　随机诲诱无厌倦
  日夜见佛未曾舍　　入深寂灭智解脱
  供养诸佛善益明　　如王顶上妙宝冠
  复使众生烦恼灭　　譬如梵王光普照
  住此多作大梵王　　以三乘法化众生
  所行善业普饶益　　乃至当成一切智
  一念所入诸三昧　　阿僧祇刹微尘数
  见佛说法亦复然　　愿力所作复过此
  此是第九善慧地　　大智菩萨所行处
  甚深微妙难可见　　我为佛子已宣说

大方广佛华严经卷第三十八大方广佛华严经卷第三十九

        于阗国三藏实叉难陀奉　制译

    十地品第二十六之六

  净居天众那由他　　闻此地中诸胜行
  空中踊跃心欢喜　　悉共虔诚供养佛
  不可思议菩萨众　　亦在空中大欢喜
  俱然最上悦意香　　普熏众会令清净
  自在天王与天众　　无量亿数在虚空
  普散天衣供养佛　　百千万种缤纷下
  天诸采女无有量　　靡不欢欣供养佛
  各奏种种妙乐音　　悉以此言而赞叹
  佛身安坐一国土　　一切世界悉现身
  身相端严无量亿　　法界广大悉充满
  于一毛孔放光明　　普灭世间烦恼暗
  国土微尘可知数　　此光明数不可测
  或见如来具众相　　转于无上正法轮
  或见游行诸佛刹　　或见寂然安不动
  或现住于兜率宫　　或现下生入母胎
  或示住胎或出胎　　悉令无量国中见
  或现出家修世道　　或现道场成正觉
  或现说法或涅槃　　普使十方无不睹
  譬如幻师知幻术　　在于大众多所作
  如来智慧亦复然　　于世间中普现身
  佛住甚深真法性　　寂灭无相同虚空
  而于第一实义中　　示现种种所行事
  所作利益众生事　　皆依法性而得有
  相与无相无差别　　入于究竟皆无相
  若有欲得如来智　　应离一切妄分别
  有无通达皆平等　　疾作人天大导师
  无量无边天女众　　种种言音称赞已
  身心寂静共安乐　　瞻仰如来默然住
  即时菩萨解脱月　　知诸众会咸寂静
  向金刚藏而请言　　大无畏者真佛子
  从第九地入十地　　所有功德诸行相
  及以神通变化事　　愿聪慧者为宣说

尔时金刚藏菩萨摩诃萨。告解脱月菩萨言。佛子。菩萨摩诃萨。从初地。乃至第九地。以如是无量智慧。观察觉了已。善思惟修习。善满足白法。集无边助道法。增长大福德智慧。广行大悲。知世界差别。入众生界稠林。入如来所行处。随顺如来寂灭行。常观察如来力无所畏。不共佛法。名为得一切种一切智智受职位。佛子。菩萨摩诃萨。以如是智慧。入受职地已。即得菩萨离垢三昧。入法界差别三昧。庄严道场三昧。一切种华光三昧。海藏三昧。海印三昧。虚空界广大三昧。观一切法自性三昧。知一切众生心行三昧。一切佛皆现前三昧。如是等百万阿僧祇三昧。皆现在前菩萨于此一切三昧。若入若起。皆得善巧。亦善了知一切三昧。所作差别。其最后三昧。名受一切智胜职位。此三昧现在前时。有大宝莲华。忽然出生。其华广大。量等百万三千大千世界。以众妙宝。间错庄严。超过一切世间境界。出世善根之所生起。知诸法如幻性。众行所成。恒放光明。普照法界。非诸天处之所能有。毗琉璃摩尼宝为茎。栴檀王为台。码瑙为须。阎浮檀金为叶。其华常有无量光明。众宝为藏。宝网弥覆。十三千大千世界。微尘数莲华。以为眷属。尔时菩萨。坐此华座。身相大小。正相称可。无量菩萨。以为眷属。各坐其余莲华之上。周匝围绕。一一各得百万三昧。向大菩萨。一心瞻仰。佛子。此大菩萨。并其眷属。坐华座时。所有光明。及以言音。普皆充满十方法界。一切世界。咸悉震动。恶趣休息。国土严净。同行菩萨。靡不来集。人天音乐。同时发声。所有众生。悉得安乐。以不思议供养之具。供一切佛。诸佛众会。悉皆显现。佛子。此菩萨。坐彼大莲华座时。于两足下。放百万阿僧祇光明。普照十方诸大地狱。灭众生苦。于两膝轮。放百万阿僧祇光明。普照十方诸畜生趣。灭众生苦。于脐轮中。放百万阿僧祇光明。普照十方阎罗王界。灭众生苦。从左右胁。放百万阿僧祇光明。普照十方一切人趣。灭众生苦。从两手中。放百万阿僧祇光明。普照十方一切诸天。及阿修罗。所有宫殿。从两肩上。放百万阿僧祇光明。普照十方一切声闻。从其项背。放百万阿僧祇光明。普照十方辟支佛身。从其面门。放百万阿僧祇光明。普照十方初始发心。乃至九地。诸菩萨身。从两眉间。放百万阿僧祇光明。普照十方受职菩萨。令魔宫殿。悉皆不现。从其顶上。放百万阿僧祇。三千大千世界。微尘数光明。普照十方一切世界。诸佛如来。道场众会。右绕十匝。住虚空中。成光明网。名炽然光明。发起种种诸供养事。供养于佛。余诸菩萨从初发心。乃至九地。所有供养。而比于此。百分不及一。乃至算数譬谕。所不能及。其光明网。普于十方一一如来。众会之前。雨众妙香。华鬘衣服。幢幡宝盖。诸摩尼等。庄严之具。以为供养。皆从出世善根所生。超过一切世间境界。若有众生。见知此者。皆于阿耨多罗三藐三菩提。得不退转。佛子。此大光明。作于如是供养事毕。复绕十方一切世界。一一诸佛。道场众会。经十匝已。从诸如来足下而入。尔时诸佛。及诸菩萨。知某世界中。某菩萨摩诃萨。能行如是广大之行。到受职位。佛子。是时十方。无量无边。乃至九地。诸菩萨众。皆来围绕。恭敬供养。一心观察。正观察时。其诸菩萨。即各获得十千三昧。当尔之时。十方所有。受职菩萨。皆于金刚庄严。臆德相中。出大光明。名能坏魔怨。百万阿僧祇光明。以为眷属。普照十方。现于无量。神通变化。作是事已。而来入此菩萨摩诃萨。金刚庄严。臆德相中。其光入已。令此菩萨。所有智慧。势力增长。过百千倍

尔时十方一切诸佛。从眉间出清净光明。名增益一切智神通。无数光明。以为眷属。普照十方一切世界。右绕十匝。示现如来。广大自在。开悟无量。百千亿那由他。诸菩萨众。周遍震动一切佛刹。灭除一切诸恶道苦。隐蔽一切诸魔宫殿。示一切佛。得菩提处。道场众会。庄严威德。如是普照尽虚空遍法界。一切世界已而来至此菩萨会上。周匝右绕。示现种种庄严之事。现是事已。从大菩萨顶上而入。其眷属光明。亦各入彼诸菩萨顶。当尔之时。此菩萨。得先所未得百万三昧。各为已得受职之位。入佛境界。具足十力。堕在佛数。佛子。如转轮圣王所生太子。母是正后。身相具足。其转轮王。令此太子。坐白象宝妙金之座。张大网幔。建大幢幡。然香散花。奏诸音乐。取四大海水。置金瓶内。王执此瓶。灌太子顶。是时即名受王职位。堕在灌顶刹利王数。即能具足。行十善道。亦得名为转轮圣王。菩萨受职。亦复如是。诸佛智水。灌其顶故。名为受职。具足如来十种力故。堕在佛数。佛子。是名菩萨受大智职。菩萨以此大智职故。能行无量。百千万亿那由他。难行之行。增长无量智慧功德。名为安住法云地

佛子。菩萨摩诃萨。住此法云地。如实知欲界集。色界集。无色界集。世界集。法界集。有为界集。无为界集。众生界集。识界集。虚空界集。涅槃界集。此菩萨。如实知诸见烦恼行集。知世界成坏集。知声闻行集。辟支佛行集。菩萨行集。如来力无所畏。色身法身集。一切种一切智智集。示得菩提转法轮集。入一切法分别决定智集。举要言之。以一切智。知一切集。佛子。此菩萨摩诃萨。以如是上上觉慧。如实知众生业化。烦恼化。诸见化。世界化。法界化。声闻化。辟支佛化。菩萨化。如来化。一切分别无分别化。如是等。皆如实知。又如实知佛持。法持。僧持。业持。烦恼持。时持。愿持。供养持。行持。劫持。智持。如是等。皆如实知。又如实知诸佛如来入微细智。所谓修行微细智。命终微细智。受生微细智。出家微细智。现神通微细智。成正觉微细智。转法轮微细智。住寿命微细智。般涅槃微细智。教法住微细智。如是等。皆如实知。又入如来秘密处。所谓身秘密。语秘密。心秘密。时非时思量秘密。授菩萨记秘密。摄众生秘密。种种乘秘密。一切众生根行差别秘密。业所作秘密。得菩提行秘密。如是等。皆如实知。又知诸佛所有入劫智。所谓一劫入阿僧祇劫。阿僧祇劫入一劫。有数劫入无数劫。无数劫入有数劫。一念入劫。劫入一念。劫入非劫。非劫入劫。有佛劫入无佛劫。无佛劫入有佛劫。过去未来劫入现在劫。现在劫入过去未来劫。过去劫入未来劫。未来劫入过去劫。长劫入短劫。短劫入长劫。如是等。皆如实知。又知如来诸所入智。所谓入毛道智。入微尘智。入国土身正觉智。入众生身正觉智。入众生心正觉智。入众生行正觉智。入随顺一切处正觉智。入示现遍行智。入示现顺行智。入示现逆行智。入示现思议不思议。世间了知不了知行智。入示现声闻智。辟支佛智。菩萨行如来行智。佛子。一切诸佛。所有智慧。广大无量。此地菩萨。皆能得入

佛子。菩萨摩诃萨。住此地。即得菩萨不思议解脱。无障碍解脱。净观察解脱。普照明解脱。如来藏解脱。随顺无碍轮解脱。通达三世解脱。法界藏解脱。解脱光明轮解脱。无余境界解脱。此十为首。有无量百千阿僧祇解脱门。皆于此第十地中得。如是乃至无量百千阿僧祇三昧门。无量百千阿僧祇陀罗尼门。无量百千阿僧祇神通门。皆悉成就

佛子。此菩萨摩诃萨。通达如是智慧。随顺无量菩提。成就善巧念力。十方无量诸佛所有。无量大法明。大法照。大法雨。于一念顷。皆能安能受。能摄能持。譬如娑伽罗龙王。所霔大雨。唯除大海。余一切处。皆不能安。不能受。不能摄。不能持。如来秘密藏。大法明。大法照。大法雨。亦复如是。唯除第十地菩萨。余一切众生。声闻独觉。乃至第九地菩萨。皆不能安。不能受。不能摄。不能持。佛子譬如大海。能安能受。能摄能持。一大龙王。所霔大雨。若二若三。乃至无量诸龙王雨。于一念间。一时霔下。皆能安能受。能摄能持。何以故。以是无量。广大器故。住法云地菩萨。亦复如是。能安能受。能摄能持。一佛法明。法照法雨。若二若三。乃至无量。于一念顷。一时演说。悉亦如是。是故此地。名为法云。解脱月菩萨言。佛子。此地菩萨。于一念间。能于几如来所。安受摄持。大法明。大法照。大法雨。金刚藏菩萨言。佛子。不可以算数能知。我当为汝。说其譬谕。佛子。譬如十方。各有十不可说百千亿那由他佛刹微尘数世界。其世界中。一一众生。皆得闻持陀罗尼。为佛侍者。声闻众中。多闻第一。如金刚莲华上佛所。大胜比丘。然一众生。所受之法。余不重受。佛子。于汝意云何。此诸众生。所受之法。为有量耶。为无量耶。解脱月菩萨言。其数甚多。无量无边。金刚藏菩萨言。佛子。我为汝说。令汝得解。佛子。此法云地菩萨。于一佛所。一念之顷。所安所受。所摄所持。大法明。大法照。大法雨。三世法藏。前尔所世界。一切众生。所闻持法。于此。百分不及一。乃至譬谕。亦不能及。如一佛所。如是十方。如前所说尔所世界微尘数佛。复过此数。无量无边。于彼一一诸如来所。所有法明。法照法雨。三世法藏。皆能安能受。能摄能持。是故此地。名为法云。佛子。此地菩萨。以自愿力。起大悲云。震大法雷。通明无畏。以为电光。福德智慧。而为密云。现种种身。周旋往返。于一念顷。普遍十方百千亿那由他世界微尘数国土。演说大法。摧伏魔怨。复过此数。于无量百千亿那由他世界。微尘数国土。随诸众生心之所乐。霔甘露雨。灭除一切众惑尘焰。是故此地。名为法云。佛子。此地菩萨。于一世界。从兜率天下。乃至涅槃。随所应度众生心。而现佛事。若二若三。乃至如上。微尘数国土。复过于此。乃至无量百千亿那由他世界。微尘数国土。皆亦如是。是故此地。名为法云佛子。此地菩萨。智慧明达。神通自在。随其心念。能以狭世界。作广世界。广世界作狭世界。垢世界作净世界。净世界作垢世界。乱住次住。倒住正住。如是无量。一切世界。皆能互作。或随心念。于一尘中。置一世界。须弥卢等。一切山川。尘相如故。世界不减。或复于一微尘之中。置二置三。乃至不可说世界。须弥卢等。一切山川。而彼微尘。体相如本。于中世界。悉得明现。或随心念。于一世界中。示现二世界庄严。乃至不可说世界庄严。或于一世界庄严中。示现二世界乃至不可说世界。或随心念。以不可说世界中众生。置一世界。或随心念。以一世界中众生。置不可说世界。而于众生。无所娆害。或随心念。于一毛孔。示现一切佛境界。庄严之事。或随心念。于一念中。示现不可说世界。微尘数身。一一身。示现如是微尘数手。一一手。各执恒河沙数。华奁香箧。鬘盖幢幡。周遍十方。供养于佛。一一身。复示现尔许微尘数头。一一头。复现尔许微尘数舌。于念念中。周遍十方。叹佛功德。或随心念。于一念间。普遍十方。示成正觉。乃至涅槃。及以国土。庄严之事。或现其身。普遍三世。而于身中。有无量诸佛。及佛国土。庄严之事。世界成坏。靡不皆现。或于自身。一毛孔中。出一切风。而于众生。无所恼害。或随心念。以无边世界。为一大海。此海水中。现大莲华。光明严好。遍覆无量无边世界。于中示现大菩提树。庄严之事。乃至示成一切种智。或于其身。现十方世界。一切光明。摩尼宝珠。日月星宿。云电等光。靡不皆现。或以口嘘气。能动十方无量世界。而不令众生。有惊怖想。或现十方。风灾火灾。及以水灾。或随众生心之所乐。示现色身。庄严具足。或于自身。示现佛身。或于佛身。而现自身。或于佛身。现己国土。或于己国土。而现佛身。佛子。此法云地菩萨。能现如是。及余无量。百千亿那由他。自在神力

尔时会中诸菩萨。及天龙夜叉乾闼婆阿修罗护世四王。释提桓因。梵天净居。摩醯首罗。诸天子等。咸作是念。若菩萨。神通智力。能如是者。佛复云何。尔时解脱月菩萨。知诸众会心之所念。白金刚藏菩萨言。佛子。今此大众。闻其菩萨。神通智力。堕在疑网。善哉仁者。为断彼疑。当少示现菩萨神力庄严之事。时金刚藏菩萨。即入一切佛国土体性三昧。入此三昧时。诸菩萨。及一切大众。皆自见身。在金刚藏菩萨身内。于中悉见三千大千世界所有种种庄严之事。经于亿劫。说不能尽。又于其中。见菩提树。其身周围。十万三千大千世界。高百万三千大千世界。枝叶所荫。亦复如是。称树形量。有师子座。座上有佛。号一切智通王。一切大众。悉见其佛。坐菩提树下。师子座上。种种诸相。以为庄严。假使亿劫。说不能尽。金刚藏菩萨。示现如是大神力已。还令众会。各在本处。时诸大众。得未曾有。生奇特想。默然而住。向金刚藏。一心瞻仰

尔时解脱月菩萨。白金刚藏菩萨言。佛子。今此三昧。甚为希有。有大势力。其名何等。金刚藏言。此三昧。名一切佛国土体性。又问此三昧境界云何。答言佛子。若菩萨。修此三昧。随心所念。能于身中。现恒河沙世界微尘数佛刹。复过此数。无量无边。佛子。菩萨住法云地。得如是等无量百千诸大三昧。故此菩萨。身。身业。不可测知。语。语业。意。意业。神通自在。观察三世。三昧境界。智慧境界。游戏一切诸解脱门。变化所作。神力所作。光明所作。略说乃至举足下足。如是一切诸有所作。乃至法王子住。善慧地菩萨。皆不能知。佛子。此法云地菩萨。所有境界。略说如是。若广说者。假使无量百千阿僧祇劫。亦不能尽。解脱月菩萨言。佛子。若菩萨。神通境界如是。佛神通力。其复云何。金刚藏言。佛子。譬如有人。于四天下。取一块土。而作是言。为无边世界大地土多。为此土多。我观汝问。亦复如是。如来智慧。无边无等。云何而与菩萨比量。复次佛子。如四天下。取少许土。余者无量。此法云地。神通智慧。于无量劫。但说少分。况如来地。佛子。我今为汝。引事为证。令汝得知如来境界。佛子。假使十方一一方。各有无边世界。微尘数诸佛国土。一一国土。得如是地菩萨充满。如甘蔗竹苇。稻麻丛林。彼诸菩萨。于百千亿那由他劫。修菩萨行。所生智慧。比一如来。智慧境界。百分不及一。乃至优波尼沙陀分。亦不能及

佛子。此菩萨。住如是智慧。不异如来。身语意业。不舍菩萨诸三昧力。于无数劫。承事供养一切诸佛。一一劫中。以一切种。供养之具。而为供养。一切诸佛。神力所加。智慧光明。转更增胜。于法界中。所有问难。善为解释。百千亿劫。无能屈者。佛子。譬如金师。以上妙真金。作严身具。大摩尼宝。钿厕其间。自在天王。身自服戴。其余天人。庄严之具。所不能及。此地菩萨。亦复如是。始从初地。乃至九地。一切菩萨。所有智行。皆不能及。此地菩萨。智慧光明。能令众生。乃至入于一切智智。余智光明。无能如是。佛子。譬如摩醯首罗天王光明。能令众生。身心清凉。一切光明。所不能及。此地菩萨。智慧光明。亦复如是。能令众生。皆得清凉。乃至住于一切智智。一切声闻辟支佛。乃至第九地菩萨。智慧光明。悉不能及。佛子。此菩萨摩诃萨。已能安住如是智慧。诸佛世尊。复更为说三世智。法界差别智。遍一切世界智。照一切世界智。慈念一切众生智。举要言之。乃至为说得一切智智。此菩萨。十波罗蜜中。智波罗蜜。最为增上。余波罗蜜。非不修行。佛子。是名略说菩萨摩诃萨第十法云地。若广说者。假使无量阿僧祇劫。亦不能尽。佛子。菩萨住此地。多作摩醯首罗天王。于法自在。能授众生。声闻独觉。一切菩萨。波罗蜜行。于法界中。所有问难。无能屈者。布施爱语利行同事。如是一切诸所作业。皆不离念佛。乃至不离念具足一切种。一切智智。复作是念。我当于一切众生。为首为胜。乃至为一切智智依止者。若勤加精进。于一念顷。得十不可说百千亿那由他佛刹微尘数三昧。乃至示现。尔所微尘数菩萨。以为眷属。若以菩萨。殊胜愿力。自在示现。过于此数。所谓若修行。若庄严。若信解。若所作。若身若语。若光明若诸根。若神变若音声。若行处。乃至百千亿那由他劫。不能数知

佛子。此菩萨摩诃萨。十地行相。次第现前。则能趣入一切智智。譬如阿耨达池。出四大河。其河流注。遍阎浮提。既无尽竭。复更增长。乃至入海。令其充满。佛子。菩萨亦尔。从菩提心。流出善根大愿之水。以四摄法充满众生。无有穷尽。复更增长。乃至入于一切智海。令其充满。佛子。菩萨十地。因佛智故。而有差别。如因大地有十山王。何等为十。所谓雪山王。香山王。鞞陀梨山王。神仙山王。由乾陀山王。马耳山王。尼民陀罗山王。斫羯罗山王。计都末底山王。须弥卢山王。佛子。如雪山王。一切药草。咸在其中。取不可尽。菩萨所住欢喜地。亦复如是。一切世间。经书技艺。文颂咒术。咸在其中。说不可尽。佛子。如香山王。一切诸香。咸集其中。取不可尽。菩萨所住离垢地。亦复如是。一切菩萨。戒行威仪。咸在其中。说不可尽。佛子。如鞞陀梨山王。纯宝所成。一切众宝。咸在其中。取不可尽。菩萨所住发光地。亦复如是。一切世间。禅定神通。解脱三昧。三摩钵底。咸在其中。说不可尽。佛子。如神仙山王。纯宝所成。五通神仙。咸住其中。无有穷尽。菩萨所住焰慧地。亦复如是。一切道中。殊胜智慧。咸在其中。说不可尽。佛子。如由乾陀罗山王。纯宝所成。夜叉大神。咸住其中。无有穷尽。菩萨所住难胜地。亦复如是。一切自在。如意神通。咸在其中。说不可尽。佛子。如马耳山王。纯宝所成。一切诸果。咸在其中。取不可尽。菩萨所住现前地。亦复如是。入缘起理。声闻果证。咸在其中。说不可尽。如尼民陀罗山王。纯宝所成。大力龙神。咸住其中。无有穷尽。菩萨所住远行地。亦复如是。方便智慧。独觉果证。咸在其中。说不可尽。如斫羯罗山王。纯宝所成。诸自在众。咸住其中。无有穷尽。菩萨所住不动地。亦复如是。一切菩萨自在行差别世界。咸在其中。说不可尽。如计都山王。纯宝所成。大威德阿修罗王。咸住其中。无有穷尽。菩萨所住善慧地。亦复如是。一切世间。生灭智行。咸在其中。说不可尽。如须弥卢山王纯宝所成。大威德诸天。咸住其中。无有穷尽。菩萨所住法云地。亦复如是。如来力无畏。不共法。一切佛事。咸在其中。问答宣说。不可穷尽。佛子。此十宝山王。同在大海。差别得名。菩萨十地。亦复如是。同在一切智中。差别得名。佛子。譬如大海。以十种相。得大海名。不可移夺。何等为十。一次第渐深。二不受死尸。三余水入中皆失本名。四普同一味。五无量珍宝。六无能至底。七广大无量。八大身所居。九潮不过限。十普受大雨。无有盈溢。菩萨行亦复如是。以十相故。名菩萨行。不可移夺。何等为十。所谓欢喜地。出生大愿。渐次深故。离垢地。不受一切。破戒尸故。发光地。舍离世间。假名字故。焰慧地。与佛功德。同一味故。难胜地。出生无量方便神通。世间所作。众珍宝故。现前地。观察缘生。甚深理故。远行地。广大觉慧。善观察故。不动地。示现广大庄严事故。善慧地。得深解脱。行于世间。如实而知。不过限故。法云地。能受一切。诸佛如来。大法明雨。无厌足故。佛子。譬如大摩尼珠。有十种性。出过众宝。何等为十。一者从大海出。二者巧匠治理。三者圆满无缺。四者清净离垢。五者内外明彻。六者善巧钻穿。七者贯以宝缕。八者置在琉璃高幢之上。九者普放一切种种光明。十者能随王意。雨众宝物。如众生心。充满其愿。佛子。当如菩萨亦复如是。有十种事。出过众圣。何等为十。一者发一切智心。二者持戒头陀。正行明净。三者诸禅三昧。圆满无缺。四者道行清白。离诸垢秽。五者方便神通。内外明彻。六者缘起智慧。善能钻穿。七者贯以种种方便智缕。八者置于自在高幢之上。九者观众生行。放闻持光。十者受佛智职。堕在佛数。能为众生。广作佛事

佛子。此集一切种一切智功德菩萨行法门品。若诸众生。不种善根。不可得闻。解脱月菩萨言闻此法门。得几所福。金刚藏菩萨言。如一切智。所集福德。闻此法门。福德如是。何以故。非不闻此功德法门。而能信解受持读诵。何况精进。如说修行。是故当知。要得闻此集一切智功德法门。乃能信解。受持修习。然后至于一切智地

尔时佛神力故。法如是故。十方各有十亿佛刹微尘数世界。六种十八相动。所谓动遍动等遍动。起遍起等遍起。涌遍涌等遍涌。震遍震等遍震。吼遍吼等遍吼。击遍击等遍击。雨众天华。天鬘天衣。及诸天宝。庄严之具。幢幡缯盖。奏天妓乐。其音和雅。同时发声。赞一切智地。所有功德。如此世界。他化自在天王宫。演说此法。十方所有。一切世界。悉亦如是。尔时复以佛神力故。十方各十亿佛刹微尘数世界外。有十亿佛刹微尘数菩萨。而来此会。作如是言。善哉善哉。金刚藏。快说此法。我等悉亦同名金刚藏。所住世界。各各差别。悉名金刚德。佛号金刚幢。我等住在本世界中。皆承如来威神之力而说此法。众会悉等。文字句义。与此所说。无有增减。悉以佛神力。而来此会。为汝作证。如我等今者入此世界。如是十方一切世界。悉亦如是。而往作证

尔时金刚藏菩萨。观察十方一切众会。普周法界。欲赞叹发一切智智心。欲示现菩萨境界。欲净治菩萨行力。欲说摄取一切种智道。欲除灭一切世间垢。欲施与一切智。欲示现不思议智庄严。欲显示一切菩萨诸功德。欲令如是地义。转更开显。承佛神力。而说颂言

  其心寂灭恒调顺　　平等无碍如虚空
  离诸垢浊住于道　　此殊胜行汝应听
  百千亿劫修诸善　　供养无量无边佛
  声闻独觉亦复然　　为利众生发大心
  精勤持戒常柔忍　　惭愧福智皆具足
  志求佛智修广慧　　愿得十力发大心
  三世诸佛咸供养　　一切国土悉严净
  了知诸法皆平等　　为利众生发大心
  住于初地生是心　　永离众恶常欢喜
  愿力广修诸善法　　以悲愍故入后位
  戒闻具足念众生　　涤除垢秽心明洁
  观察世间三毒火　　广大解者趣三地
  三有一切皆无常　　如箭入身苦炽然
  厌离有为求佛法　　广大智人趣焰地
  念慧具足得道智　　供养百千无量佛
  常观最胜诸功德　　斯人趣入难胜地
  智慧方便善观察　　种种示现救众生
  复供十力无上尊　　趣入无生现前地
  世所难知而能知　　不受于我离有无
  法性本寂随缘转　　得此微妙向七地
  智慧方便心广大　　难行难伏难了知
  虽证寂灭勤修习　　能趣如空不动地
  佛劝令从寂灭起　　广修种种诸智业
  具十自在观世间　　以此而升善慧地
  以微妙智观众生　　心行业惑等稠林
  为欲化其令趣道　　演说诸佛胜义藏
  次第修行具众善　　乃至九地集福慧
  常求诸佛最上法　　得佛智水灌其顶
  获得无数诸三昧　　亦善了知其作业
  最后三昧名受职　　住广大境恒不动
  菩萨得此三昧时　　大宝莲华忽然现
  身量称彼于中坐　　佛子围绕同观察
  放大光明百千亿　　灭除一切众生苦
  复于顶上放光明　　普入十方诸佛会
  悉住空中作光网　　供养佛已从足入
  即时诸佛悉了知　　今此佛子登职位
  十方菩萨来观察　　受职大士舒光照
  诸佛眉间亦放光　　普照而来从顶入
  十方世界咸震动　　一切地狱苦消灭
  是时诸佛与其职　　如转轮王第一子
  若蒙诸佛与灌顶　　是则名登法云地
  智慧增长无有边　　开悟一切诸世间
  欲界色界无色界　　法界世界众生界
  有数无数及虚空　　如是一切咸通达
  一切化用大威力　　诸佛加持微细智
  秘密劫数毛道等　　皆能如实而观察
  受生舍俗成正道　　转妙法轮入涅槃
  乃至寂灭解脱法　　及所未说皆能了
  菩萨住此法云地　　具足念力持佛法
  譬如大海受龙雨　　此地受法亦复然
  十方无量诸众生　　悉得闻持持佛法
  于一佛所所闻法　　过于彼数无有量
  以昔智愿威神力　　一念普遍十方土
  霔甘露雨灭烦恼　　是故佛说名法云
  神通示现遍十方　　超出人天世间境
  复过是数无量亿　　世智思惟必迷闷
  一举足量智功德　　乃至九地不能知
  何况一切诸众生　　及以声闻辟支佛
  此地菩萨供养佛　　十方国土悉周遍
  亦供现前诸圣众　　具足庄严佛功德
  住于此地复为说　　三世法界无碍智
  众生国土悉亦然　　乃至一切佛功德
  此地菩萨智光明　　能示众生正法路
  自在天光除世暗　　此光灭暗亦如是
  住此多作三界王　　善能演说三乘法
  无量三昧一念得　　所见诸佛亦如是
  此地我今已略说　　若欲广说不可尽
  如是诸地佛智中　　如十山王嶷然住
  初地艺业不可尽　　譬如雪山集众药
  二地戒闻如香山　　三如鞞陀发妙华
  焰慧道宝无有尽　　譬如仙山仁善住
  五地神通如由干　　六如马耳具众果
  七地大慧如尼民　　八地自在如轮围
  九如计都集无碍　　十如须弥具众德
  初地愿首二持戒　　三地功德四专一
  五地微妙六甚深　　七广大慧八庄严
  九地思量微妙义　　出过一切世间道
  十地受持诸佛法　　如是行海无尽竭
  十行超世发心初　　持戒第二禅第三
  行净第四成就五　　缘生第六贯穿七
  第八置在金刚幢　　第九观察众稠林
  第十灌顶随王意　　如是德宝渐清净
  十方国土碎为尘　　可于一念知其数
  毫末度空可知量　　亿劫说此不可尽

大方广佛华严经卷第三十九大方广佛华严经卷第四十

        于阗国三藏实叉难陀奉　制译

    十定品第二十七之一

尔时世尊。在摩竭提国。阿兰若法菩提场中。始成正觉。于普光明殿。入刹那际诸佛三昧。以一切智自神通力。现如来身。清净无碍。无所依止。无有攀缘。住奢摩他最极寂静。具大威德。无所染着。能令见者。悉得开悟。随宜出兴。不失于时。恒住一相。所谓无相。与十佛刹微尘数菩萨摩诃萨俱。靡不皆入灌顶之位。具菩萨行。等于法界无量无边。获诸菩萨普见三昧。大悲安隐一切众生。神通自在。同于如来。智慧深入。演真实义。具一切智。降伏众魔。虽入世间。心恒寂静。住于菩萨无住解脱。其名曰。金刚慧菩萨。无等慧菩萨。义语慧菩萨。最胜慧菩萨。常舍慧菩萨。那伽慧菩萨。成就慧菩萨。调顺慧菩萨。大力慧菩萨。难思慧菩萨。无碍慧菩萨。增上慧菩萨。普供慧菩萨。如理慧菩萨。善巧慧菩萨。法自在慧菩萨。法慧菩萨。寂静慧菩萨。虚空慧菩萨。一相慧菩萨。善慧菩萨。如幻慧菩萨。广大慧菩萨。势力慧菩萨。世间慧菩萨。佛地慧菩萨。真实慧菩萨。尊胜慧菩萨。智光慧菩萨。无边慧菩萨。念庄严菩萨。达空际菩萨。性庄严菩萨。甚深境菩萨。善解处非处菩萨。大光明菩萨。常光明菩萨。了佛种菩萨。心王菩萨。一行菩萨。常现神通菩萨。智慧芽菩萨。功德处菩萨。法灯菩萨。照世菩萨。持世菩萨。最安隐菩萨。最上菩萨。无上菩萨。无比菩萨。超伦菩萨。无碍行菩萨。光明焰菩萨。月光菩萨。一尘菩萨。坚固行菩萨。霔法雨菩萨。最胜幢菩萨。普庄严菩萨。智眼菩萨。法眼菩萨。慧云菩萨。总持王菩萨。无住愿菩萨。智藏菩萨。心王菩萨。内觉慧菩萨。住佛智菩萨。陀罗尼勇健力菩萨。持地力菩萨。妙月菩萨。须弥顶菩萨。宝顶菩萨。普光照菩萨。威德王菩萨。智慧轮菩萨。大威德菩萨。大龙相菩萨。质直行菩萨。不退转菩萨。持法幢菩萨。无忘失菩萨。摄诸趣菩萨。不思议决定慧菩萨。游戏无边智菩萨。无尽妙法藏菩萨。智日菩萨。法日菩萨。智藏菩萨。智泽菩萨。普见菩萨。不空见菩萨。金刚通菩萨。金刚智菩萨。金刚焰菩萨。金刚慧菩萨。普眼菩萨。佛日菩萨。持佛金刚秘密义菩萨。普眼境界智庄严菩萨。如是等。菩萨摩诃萨。十佛刹微尘数。往昔皆与毗卢遮那如来。同修菩萨诸善根行

尔时普眼菩萨摩诃萨。承佛神力。从座而起。偏袒右肩。右膝着地。合掌白佛言。世尊。我于如来应正等觉。欲有所问。愿垂哀许。佛言普眼。恣汝所问。当为汝说。令汝心喜。普眼菩萨言。世尊。普贤菩萨。及住普贤。所有行愿。诸菩萨众。成就几何三昧解脱。而于菩萨诸大三昧。或入或出。或时安住。以于菩萨不可思议广大三昧。善入出故。能于一切三昧自在。神通变化。无有休息。佛言。善哉普眼。汝为利益去来现在诸菩萨众。而问斯义。普眼。普贤菩萨。今现在此。已能成就不可思议自在神通。出过一切诸菩萨上。难可值遇。从于无量菩萨行生。菩萨大愿悉已清净。所行之行皆无退转。无量波罗蜜门。无碍陀罗尼门。无尽辩才门。皆悉已得。清净无碍。大悲利益一切众生。以本愿力。尽未来际。而无厌倦。汝应请彼。彼当为汝。说其三昧自在解脱

尔时会中。诸菩萨众。闻普贤名。即时获得不可思议。无量三昧。其心无碍。寂然不动。智慧广大。难可测量。境界甚深。无能与等。现前悉见无数诸佛。得如来力。同如来性。去来现在。靡不明照。所有福德。不可穷尽。一切神通。皆已具足。其诸菩萨。于普贤所。心生尊重。渴仰欲见。悉于众会。周遍观察。而竟不睹。亦不见其所坐之座。此由如来威力所持。亦是普贤神通自在。使其然耳

尔时普眼菩萨。白佛言。世尊。普贤菩萨。今何所在。佛言普眼。普贤菩萨。今现在此道场众会。亲近我住。初无动移。是时普眼。及诸菩萨。复更观察道场众会。周遍求觅。白佛言。世尊。我等今者。犹未得见普贤菩萨。其身及座。佛言如是。善男子。汝等何故而不得见。善男子。普贤菩萨。住处甚深。不可说故。普贤菩萨。获无边智慧门。入师子奋迅定。得无上自在用。入清净无碍际。生如来十种力。以法界藏为身。一切如来。共所护念。于一念顷。悉能证入三世诸佛。无差别智。是故汝等不能见耳

尔时普眼菩萨。闻如来说普贤菩萨清净功德。得十千阿僧祇三昧。以三昧力。复遍观察。渴仰欲见普贤菩萨。亦不能睹。其余一切诸菩萨众。俱亦不见。时普眼菩萨。从三昧起。白佛言。世尊。我已入十千阿僧祇三昧。求见普贤。而竟不得。不见其身及身业。语及语业。意及意业。座及住处。悉皆不见。佛言。如是如是。善男子。当知皆以普贤菩萨。住不思议解脱之力。普眼。于汝意云何。颇有人能说幻术文字中。种种幻相所住处不。答言不也。佛言普眼。幻中幻相。尚不可说。何况普贤菩萨。秘密身境界。秘密语境界。秘密意境界。而于其中。能入能见。何以故。普贤菩萨。境界甚深。不可思议。无有量已过量。举要言之。普贤菩萨。以金刚慧。普入法界。于一切世界。无所行。无所住。知一切众生身。皆即非身。无去无来。得无断尽。无差别。自在神通。无依无作。无有动转。至于法界究竟边际。善男子。若有得见普贤菩萨。若得承事。若得闻名。若有思惟。若有忆念。若生信解。若勤观察。若始趣向。若正求觅。若兴誓愿。相续不绝。皆获利益。无空过者。尔时普眼。及一切菩萨众。于普贤菩萨。心生渴仰。愿得瞻觐。作如是言。南无一切诸佛。南无普贤菩萨。如是三称。头顶礼敬。尔时佛告普眼菩萨及诸众会言。诸佛子。汝等宜更礼敬普贤。殷勤求请。又应专至。观察十方。想普贤身。现在其前。如是思惟。周遍法界。深心信解。厌离一切。誓与普贤。同一行愿。入于不二真实之法。其身普现一切世间。悉知众生诸根差别。遍一切处。集普贤道。若能发起如是大愿。则当得见普贤菩萨。是时普眼。闻佛此语。与诸菩萨。俱时顶礼。求请得见普贤大士

尔时普贤菩萨。即以解脱神通之力。如其所应。为现色身。令彼一切诸菩萨众。皆见普贤亲近如来。于此一切菩萨众中。坐莲华座。亦见于余一切世界。一切佛所。从彼次第。相续而来。亦见在彼一切佛所。演说一切诸菩萨行。开示一切智智之道。阐明一切菩萨神通。分别一切菩萨威德。示现一切三世诸佛。是时。普眼菩萨。及一切菩萨众。见此神变。其心踊跃。生大欢喜。莫不顶礼普贤菩萨。心生尊重。如见十方一切诸佛。是时以佛大威神力及诸菩萨信解之力。普贤菩萨本愿力故。自然而雨十千种云。所谓种种华云。种种鬘云。种种香云。种种末香云。种种盖云。种种衣云。种种严具云。种种珍宝云。种种烧香云。种种缯彩云。不可说世界。六种震动。奏天音乐。其声远闻不可说世界。放大光明。其光普照不可说世界。令三恶趣。悉得除灭。严净不可说世界。令不可说菩萨。入普贤行。不可说菩萨。成普贤行。不可说菩萨。于普贤行愿。悉得圆满。成阿耨多罗三藐三菩提

尔时普眼菩萨。白佛言。世尊。普贤菩萨。是住大威德者。住无等者。住无过者。住不退者。住平等者。住不坏者。住一切差别法者。住一切无差别法者。住一切众生善巧心所住者。住一切法自在解脱三昧者。佛言。如是如是。普眼。如汝所说。普贤菩萨。有阿僧祇清净功德。所谓无等庄严功德。无量宝功德。不思议海功德。无量相功德。无边云功德。无边际不可称赞功德。无尽法功德。不可说功德。一切佛功德。称扬赞叹不可尽功德

尔时如来。告普贤菩萨言。普贤。汝应为普眼及此会中。诸菩萨众。说十三昧。令得善入。成满普贤所有行愿。诸菩萨摩诃萨。说此十大三昧故。令过去菩萨。已得出离。现在菩萨。今得出离。未来菩萨。当得出离。何者为十。一者普光大三昧。二者妙光大三昧。三者次第遍往诸佛国土大三昧。四者清净深心行大三昧。五者知过去庄严藏大三昧。六者智光明藏大三昧。七者了知一切世界佛庄严大三昧。八者众生差别身大三昧。九者法界自在大三昧。十者无碍轮大三昧。此十大三昧。诸大菩萨。乃能善入。去来现在。一切诸佛。已说。当说。现说。若诸菩萨。爱乐尊重。修习不懈。则得成就。如是之人。则名为佛。则名如来。亦则名为得十力人。亦名导师。亦名大导师。亦名一切智。亦名一切见。亦名住无碍。亦名达诸境。亦名一切法自在。此菩萨。普入一切世界。而于世界无所著。普入一切众生界。而于众生。无所取。普入一切身。而于身无所碍。普入一切法界。而知法界无有边。亲近三世一切佛。明见一切诸佛法。巧说一切文字。了达一切假名。成就一切菩萨清净道。安住一切菩萨差别行。于一念中。普得一切三世智。普知一切三世法。普说一切诸佛教。普转一切不退轮。于去来现在一一世。普证一切菩提道。于此一一菩提中。普了一切佛所说。此是诸菩萨法相门。是诸菩萨智觉门。是一切种智无胜幢门。是普贤菩萨诸行愿门。是猛利神通誓愿门。是一切总持辩才门。是三世诸法差别门。是一切诸佛示现门。是以萨婆若安立一切众生门。是以佛神力严净一切世界门。若菩萨。入此三昧。得法界力。无有穷尽。得虚空行。无有障碍。得法王位。无量自在。譬如世间。灌顶受职。得无边智。一切通达。得广大力。十种圆满。成无诤心。入寂灭际。大悲无畏。犹如师子。为智慧丈夫。然正法明灯。一切功德。叹不可尽。声闻独觉。莫能思议。得法界智。住无动际。而能随俗。种种开演。住于无相。善入法相。得自性清净藏。生如来清净家。善开种种差别法门。而以智慧。了无所有。善知于时。常行法施。开悟一切。名为智者。普摄众生。悉令清净。以方便智。示成佛道。而常修行菩萨之行。无有断尽。入一切智方便境界。示现种种广大神通。是故普贤。汝今应当分别。广说一切菩萨十大三昧。今此众会。咸皆愿闻。尔时普贤菩萨。承如来旨。观普眼等诸菩萨众。而告之言。佛子。云何为菩萨摩诃萨。普光明三昧。佛子。此菩萨摩诃萨有十种无尽法。何者为十。所谓诸佛出现智无尽。众生变化智无尽。世界如影智无尽。深入法界智无尽。善摄菩萨智无尽。菩萨不退智无尽。善观一切法义智无尽。善持心力智无尽。住广大菩提心智无尽。住一切佛法一切智愿力智无尽。佛子。是名菩萨摩诃萨十种无尽法。佛子。此菩萨摩诃萨。发十种无边心。何等为十。所谓发度脱一切众生无边心。发承事一切诸佛无边心。发供养一切诸佛无边心。发普见一切诸佛无边心。发受持一切佛法。不忘失无边心。发示现一切佛。无量神变无边心。发为得佛力故。不舍一切菩提行无边心。发普入一切智。微细境界。说一切佛法无边心。发普入佛不思议广大境界无边心。发于佛辩才。起深志乐。领受诸佛法无边心。发示现种种自在身。入一切如来道场众会无边心。是为十。佛子。此菩萨摩诃萨。有十种入三昧差别智。何者为十。所谓东方入定西方起。西方入定东方起。南方入定北方起。北方入定南方起。东北方入定。西南方起。西南方入定。东北方起。西北方入定。东南方起。东南方入定。西北方起。下方入定上方起。上方入定下方起。是为十。佛子。此菩萨摩诃萨。有十种入大三昧善巧智。何者为十。佛子。菩萨摩诃萨。以三千大千世界。为一莲华。现身遍此莲华之上。结跏趺坐。身中复现三千大千世界。其中有百亿四天下。一一四天下。现百亿身。一一身入百亿百亿三千大千世界于彼世界一一四天下。现百亿百亿菩萨修行。一一菩萨修行。生百亿百亿决定解。一一决定解。令百亿百亿根性圆满。一一根性。成百亿百亿菩萨法不退业。然所现身。非一非多。入定出定。无所错乱。佛子。如罗睺阿修罗王。本身长七百由旬。化形长十六万八千由旬。于大海中。出其半身。与须弥山。而正齐等。佛子。彼阿修罗王。虽化其身。长十六万八千由旬。然亦不坏本身之相。诸蕴界处。悉皆如本。心不错乱。不于变化身。而作他想。于其本身。生非己想。本受生身。恒受诸乐。化身常现种种自在神通威力。佛子。阿修罗王。有贪恚痴。具足憍慢。尚能如是变现其身。何况菩萨摩诃萨。能深了达心法如幻。一切世间。皆悉如梦。一切诸佛。出兴于世。皆如影像。一切世界。犹如变化。言语音声。悉皆如响。见如实法。以如实法。而为其身。知一切法。本性清净。了知身心。无有实体。其身普住。无量境界。以佛智慧。广大光明。净修一切菩提之行。佛子。菩萨摩诃萨。住此三昧。超过世间。远离世间。无能惑乱。无能映夺。佛子。譬如比丘。观察内身。住不净观。审见其身。皆是不净。菩萨摩诃萨。亦复如是。住此三昧。观察法身。见诸世间普入其身。于中明见一切世间。及世间法。于诸世间及世间法。皆无所著。佛子。是名菩萨摩诃萨。第一普光明大三昧善巧智

佛子。云何为菩萨摩诃萨。妙光明三昧。佛子。此菩萨摩诃萨。能入三千大千世界微尘数三千大千世界。于一一世界。现三千大千世界微尘数身。一一身。放三千大千世界微尘数光。一一光。现三千大千世界微尘数色。一一色。照三千大千世界微尘数世界。一一世界中。调伏三千大千世界微尘数众生。是诸世界。种种不同。菩萨悉知。所谓世界杂染。世界清净。世界所因。世界建立。世界同住。世界光色。世界来往。如是一切。菩萨悉知。菩萨悉入是诸世界。亦悉来入菩萨之身。然诸世界。无有杂乱。种种诸法。亦不坏灭。佛子。譬如日出。绕须弥山。照七宝山。其七宝山。及宝山间。皆有光影。分明显现。其宝山上。所有日影。莫不显现山间影中。其七山间。所有日影。亦悉显现山上影中。如是展转。更相影现。或说日影出七宝山。或说日影出七山间。或说日影入七宝山。或说日影入七山间。但此日影。更相照现。无有边际。体性非有。亦复非无。不住于山。不离于山。不住于水。亦不离水。佛子。菩萨摩诃萨。亦复如是。住此妙光广大三昧。不坏世界安立之相。不灭世间诸法自性。不住世界内。不住世界外。于诸世界。无所分别。亦不坏于世界之相。观一切法。一相无相。亦不坏于诸法自性。住真如性。恒不舍离。佛子。譬如幻师。善知幻术。住四衢道。作诸幻事。于一日中。一须臾顷。或现一日。或现一夜。或复现作七日七夜。半月一月。一年百年。随其所欲。皆能示现城邑聚落。泉流河海。日月云雨。宫殿屋宅。如是一切。靡不具足。不以示现经年岁故。坏其根本。一日一时。不以本时。极短促故。坏其所现。日月年岁。幻相明现。本日不灭。菩萨摩诃萨。亦复如是。入此妙光广大三昧。现阿僧祇世界。入一世界。其阿僧祇世界。一一皆有地水火风。大海诸山。城邑聚落。园林屋宅。天宫龙宫。夜叉宫。乾闼婆宫。阿修罗宫。迦楼罗宫。紧那罗宫。摩睺罗伽宫。种种庄严。皆悉具足。欲界色界无色界。小千世界。大千世界。业行果报。死此生彼。一切世间。所有时节。须臾昼夜。半月一月。一岁百岁。成劫坏劫。杂染国土。清净国土。广大国土。狭小国土。于中诸佛。出兴于世。佛刹清净。菩萨众会。周匝围绕。神通自在。教化众生。其诸国土。所在方处。无量人众。悉皆充满。殊形异趣。种种众生。无量无边。不可思议。去来现在。清净业力。出生无量上妙珍宝。如是等事。咸悉示现。入一世界。菩萨于此。普皆明见。普入普观。普思普了。以无尽智。皆如实知。不以彼世界多故坏此一世界。不以此世界一故。坏彼多世界。何以故。菩萨知一切法皆无我故。是名入无命法。无作法者。菩萨于一切世间。勤修行无诤法故。是名住无我法者。菩萨如实。见一切身。皆从缘起故。是名住无众生法者。菩萨知一切生灭法皆从因生故。是名住无补伽罗法者。菩萨知诸法本性平等故。是名住无意生无摩纳婆法者。菩萨知一切法。本性寂静故。是名住寂静法者。菩萨知一切法一相故。是名住无分别法者。菩萨知法界无有种种差别法故。是名住不思议法者。菩萨勤修一切方便。善调伏众生故。是名住大悲法者。佛子。菩萨如是。能以阿僧祇世界。入一世界。知无数众生种种差别。见无数菩萨。各各发趣。观无数诸佛。处处出兴。彼诸如来。所演说法。其诸菩萨。悉能领受。亦见自身于中修行。然不舍此处而见在彼。亦不舍彼处而见在此。彼身此身。无有差别。入法界故。常勤观察。无有休息。不舍智慧。无退转故。如有幻师随于一处。作诸幻术。不以幻地故坏于本地。不以幻日故坏于本日。菩萨摩诃萨。亦复如是。于无国土。现有国土。于有国土。现无国土。于有众生。现无众生。于无众生。现有众生。无色现色。色现无色。初不乱后。后不乱初。菩萨了知一切世法。悉亦如是。同于幻化。知法幻故。知智幻。知智幻故。知业幻。知智幻业幻已。起于幻智。观一切业。如世幻者。不于处外。而现其幻。亦不于幻外。而有其处。菩萨摩诃萨。亦复如是。不于虚空外入世间。亦不于世间外入虚空。何以故。虚空世间。无差别故。住于世间。亦住虚空。菩萨摩诃萨。于虚空中。能见能修。一切世间。种种差别。妙庄严业。于一念顷。悉能了知无数世界。若成若坏。亦知诸劫。相续次第。能于一念。现无数劫。亦不令其一念广大。菩萨摩诃萨。得不思议解脱幻智。到于彼岸。住于幻际。入世幻数。思惟诸法。悉皆如幻。不违幻世。尽于幻智。了知三世。与幻无别。决定通达。心无边际。如诸如来住如幻智。其心平等。菩萨摩诃萨。亦复如是。知诸世间皆悉如幻。于一切处。皆无所著。无有我所。如彼幻师作诸幻事。虽不与彼幻事同住。而于幻事。亦无迷惑。菩萨摩诃萨。亦复如是。知一切法。到于彼岸。心不计我。能入于法。亦不于法。而有错乱。是为菩萨摩诃萨。第二妙光明大三昧善巧智

大方广佛华严经卷第四十大方广佛华严经卷第四十一

        于阗国三藏实叉难陀奉　制译

    十定品第二十七之二

佛子。云何为菩萨摩诃萨。次第遍往诸佛国土。神通三昧。佛子。此菩萨摩诃萨。过于东方无数世界。复过尔所世界。微尘数世界。于彼诸世界中。入此三昧。或刹那入。或须臾入。或相续入。或日初分时入。或日中分时入。或日后分时入。或夜初分时入。或夜中分时入。或夜后分时入。或一日入。或五日入。或半月入。或一月入。或一年入。或百年入。或千年入。或百千年入。或亿年入。或百千亿年入。或百千那由他亿年入。或一劫入。或百劫入。或百千劫入。或百千那由他亿劫入。或无数劫入。或无量劫入。或无边劫入。或无等劫入。或不可数劫入。或不可称劫入。或不可思劫入。或不可量劫入。或不可说劫入。或不可说不可说劫入。若久若近。若法若时。种种不同。菩萨于彼。不生分别。心无染着。不作二。不作不二。不作普。不作别。虽离此分别。而以神通方便。从三昧起。于一切法。不忘不失。至于究竟。譬如日天子。周行照曜。昼夜不住。日出名昼。日没名夜。昼亦不生。夜亦不灭。菩萨摩诃萨。于无数世界。入神通三昧。入三昧已。明见尔所无数世界。亦复如是。佛子。是为菩萨摩诃萨第三次第遍往诸佛国土神通大三昧善巧智。佛子。云何为菩萨摩诃萨。清净深心行三昧。佛子。此菩萨摩诃萨。知诸佛身。数等众生。见无量佛。过阿僧祇世界微尘数。于彼一一诸如来所。以一切种种妙香。而作供养。以一切种种妙华。而作供养。以一切种种盖大如阿僧祇佛刹。而作供养。以超过一切世界一切上妙庄严具。而作供养。散一切种种宝而作供养。以一切种种庄严具庄严经行处。而作供养。以一切无数上妙摩尼宝藏。而作供养。以佛神力所流出过诸天上味饮食。而作供养。一切佛刹种种上妙诸供养具。能以神力。普皆摄取。而作供养。于彼一一诸如来所。恭敬尊重。头顶礼敬。举身布地。请问佛法。赞佛平等。称扬诸佛广大功德。入于诸佛所入大悲。得佛平等无碍之力。于一念顷。一切佛所。勤求妙法。然于诸佛。出兴于世。入般涅槃。如是之相。皆无所得。如散动心。了别所缘。心起不知何所缘起。心灭不知何所缘灭。此菩萨摩诃萨。亦复如是。终不分别如来出世。及涅槃相。佛子。如日中阳焰。不从云生。不从池生。不处于陆。不住于水。非有非无。非善非恶。非清非浊。不堪饮漱。不可秽污。非有体非无体。非有味非无味。以因缘故。而现水相。为识所了。远望似水。而兴水想。近之则无。水想自灭。此菩萨摩诃萨。亦复如是。不得如来。出兴于世。及涅槃相。诸佛有相。及以无相。皆是想心之所分别。佛子。此三昧。名为清净深心行。菩萨摩诃萨。于此三昧。入已而起。起已不失。譬如有人。从睡得寤。忆所梦事。觉时虽无。梦中境界。而能忆念。心不忘失。菩萨摩诃萨。亦复如是。入于三昧。见佛闻法。从定而起。忆持不忘。而以此法。开晓一切道场众会。庄严一切诸佛国土。无量义趣。悉得明达。一切法门。皆亦清净。然大智炬。长诸佛种。无畏具足。辩才不竭。开示演说甚深法藏。是为菩萨摩诃萨第四清净深心行大三昧善巧智佛子。云何为菩萨摩诃萨。知过去庄严藏三昧。佛子。此菩萨摩诃萨。能知过去诸佛出现。所谓劫次第中。诸刹次第。刹次第中。诸劫次第。劫次第中。诸佛出现次第。佛出现次第中。说法次第。说法次第中。诸心乐次第。心乐次第中。诸根次第。根次第中。调伏次第。调伏次第中。诸佛寿命次第。寿命次第中。知亿那由他年岁数量次第。佛子。此菩萨摩诃萨。得如是无边次第智故。则知过去诸佛。则知过去诸刹。则知过去诸法门。则知过去诸劫。则知过去诸法。则知过去诸心。则知过去诸解。则知过去诸众生。则知过去诸烦恼。则知过去诸仪式。则知过去诸清净。佛子。此三昧。名过去清净藏。于一念中。能入百劫。能入千劫。能入百千劫。能入百千亿那由他劫。能入无数劫。能入无量劫。能入无边劫。能入无等劫。能入不可数劫。能入不可称劫。能入不可思劫。能入不可量劫。能入不可说劫。能入不可说不可说劫。佛子。彼菩萨摩诃萨。入此三昧。不灭现在。不缘过去。佛子。彼菩萨摩诃萨。从此三昧起。于如来所。受十种不可思议灌顶法。亦得。亦清净。亦成就。亦入亦证。亦满亦持。平等了知。三轮清净。何等为十。一者辩不违义。二者说法无尽。三者训辞无失。四者乐说不断。五者心无恐畏。六者语必诚实。七者众生所依。八者救脱三界。九者善根最胜。十者调御妙法。佛子。此是十种灌顶法。若菩萨入此三昧。从三昧起。无间则得如歌罗逻入胎藏时。于一念间。识则托生。菩萨摩诃萨。亦复如是。从此定起。于如来所。一念则得此十种法。佛子。是名菩萨摩诃萨第五知过去庄严藏大三昧善巧智

佛子。云何为菩萨摩诃萨。智光明藏三昧。佛子。彼菩萨摩诃萨。住此三昧。能知未来一切世界。一切劫中所有诸佛。若已说。若未说。若已授记。若未授记。种种名号。各各不同。所谓无数名。无量名。无边名。无等名。不可数名。不可称名。不可思名。不可量名。不可说名。当出现于世。当利益众生。当作法王。当兴佛事。当说福利。当赞善义。当说白分义。当净治诸恶。当安住功德。当开示第一义谛。当入灌顶位。当成一切智。彼诸如来修圆满行。发圆满愿。入圆满智。有圆满众。备圆满庄严。集圆满功德。悟圆满法。得圆满果。具圆满相。成圆满觉。彼诸如来。名姓种族。方便善巧。神通变化。成熟众生。入般涅槃。如是一切皆悉了知。此菩萨。于一念中。能入一劫。百劫千劫。百千劫。百千亿那由他劫。入阎浮提微尘数劫。入四天下微尘数劫。入小千世界微尘数劫。入中千世界微尘数劫。入大千世界微尘数劫。入佛刹微尘数劫。入百千佛刹微尘数劫。入百千亿那由他佛刹微尘数劫。入无数佛刹微尘数劫。入无量佛刹微尘数劫。入无边佛刹微尘数劫。入无等佛刹微尘数劫。入不可数佛刹微尘数劫。入不可称佛刹微尘数劫。入不可思佛刹微尘数劫。入不可量佛刹微尘数劫。入不可说佛刹微尘数劫。入不可说不可说佛刹微尘数劫。如是未来一切世界。所有劫数。能以智慧。皆悉了知。以了知故。其心复入十种持门。何者为十。所谓入佛持故。得不可说佛刹微尘数诸佛护念。入法持故。得十种陀罗尼光明无尽辩才。入行持故。出生圆满殊胜诸愿。入力持故。无能映蔽无能摧伏。入智持故。所行佛法无有障碍。入大悲持故。转于不退清净法轮。入差别善巧句持故。转一切文字轮净一切法门地。入师子受生法持故。开法关钥出欲淤泥。入智力持故。修菩萨行常不休息。入善友力持故。令无边众生普得清净。入无住力持故。入不可说不可说广大劫。入法力持故。以无碍方便智。知一切法自性清净。佛子。菩萨摩诃萨。住此三昧已。善巧住不可说不可说劫。善巧住不可说不可说刹。善巧知不可说不可说种种众生。善巧知不可说不可说众生异相。善巧知不可说不可说同异业报。善巧知不可说不可说精进诸根习气相续差别诸行。善巧知不可说不可说无量染净种种思惟。善巧知不可说不可说法种种义无量文字演说言辞。善巧知不可说不可说种种佛出现种族时节现相说法施为佛事入般涅槃。善巧知不可说不可说无边智慧门。善巧知不可说不可说一切神通无量变现。佛子。譬如日出。世间所有。村营城邑。宫殿屋宅。山泽鸟兽。树林华果。如是一切种种诸物。有目之人。悉得明见。佛子。日光平等。无有分别。而能令目见种种相。此大三昧。亦复如是。体性平等。无有分别。能令菩萨知不可说不可说百千亿那由他差别之相。佛子。此菩萨摩诃萨。如是了知时。令诸众生。得十种不空。何等为十。一者见不空。令诸众生。生善根故。二者闻不空。令诸众生。得成熟故。三者同住不空。令诸众生。心调伏故。四者发起不空。令诸众生。如言而作。通达一切诸法义故。五者行不空。令无边世界。皆清净故。六者亲近不空。于不可说不可说佛刹诸如来所。断不可说不可说众生疑故。七者愿不空。随所念众生。令作胜供养。成就诸愿故。八者善巧法不空。皆令得住无碍解脱。清净智故。九者雨法雨不空。于不可说不可说诸根众生中。方便开示一切智行。令住佛道故。十者出现不空。现无边相令一切众生。皆蒙照故。佛子。菩萨摩诃萨。住此三昧。得十种不空时。诸天王众。皆来顶礼诸龙王众。兴大香云。诸夜叉王。顶礼其足。阿修罗王。恭敬供养。迦楼罗王。前后围绕。诸梵天王。悉来劝请。紧那罗王。摩睺罗伽王。咸共称赞。乾闼婆王。常来亲近。诸人王众。承事供养。佛子。是为菩萨摩诃萨第六智光明藏大三昧善巧智

佛子。云何为菩萨摩诃萨了知一切世界佛庄严三昧。佛子。此三昧。何故名了知一切世界佛庄严。佛子。菩萨摩诃萨。住此三昧。能次第入东方世界。能次第入南方世界。西方北方。四维上下。所有世界。悉亦如是。能次第入。皆见诸佛出兴于世。亦见彼佛一切神力亦见诸佛所有游戏。亦见诸佛广大威德。亦见诸佛最胜自在。亦见诸佛大师子吼。亦见诸佛所修诸行。亦见诸佛种种庄严。亦见诸佛神足变化。亦见诸佛众会云集。众会清净。众会广大。众会一相。众会多相。众会处所。众会居止。众会成熟。众会调伏。众会威德。如是一切悉皆明见。亦见众会其量大小。等阎浮提。亦见众会等四天下。亦见众会等小千界。亦见众会等中千界。亦见众会量等三千大千世界。亦见众会充满百千亿那由他佛刹亦见众会充满阿僧祇佛刹。亦见众会充满百佛刹微尘数佛刹。亦见众会充满千佛刹微尘数佛刹。亦见众会充满百千亿那由他佛刹微尘数佛刹。亦见众会充满无数佛刹微尘数佛刹。亦见众会充满无量佛刹微尘数佛刹。亦见众会充满无边佛刹微尘数佛刹。亦见众会充满无等佛刹微尘数佛刹。亦见众会充满不可数佛刹微尘数佛刹。亦见众会充满不可称佛刹微尘数佛刹。亦见众会充满不可思佛刹微尘数佛刹。亦见众会充满不可量佛刹微尘数佛刹。亦见众会充满不可说佛刹微尘数佛刹。亦见众会充满不可说不可说佛刹微尘数佛刹。亦见诸佛于彼众会道场中。示现种种相。种种时。种种国土。种种变化。种种神通。种种庄严。种种自在。种种形量。种种事业。菩萨摩诃萨。亦见自身往彼众会。亦自见身在彼说法。亦自见身受持佛语。亦自见身善知缘起。亦自见身住在虚空。亦自见身住于法身。亦自见身不生染着。亦自见身不住分别。亦自见身无有疲倦。亦自见身普入诸智。亦自见身普知诸义。亦自见身普入诸地。亦自见身普入诸趣。亦自见身普知方便。亦自见身普住佛前。亦自见身普入诸力。亦自见身普入真如。亦自见身普入无诤。亦自见身普入诸法。如是见时。不分别国土。不分别众生。不分别佛。不分别法。不执着身。不执着身业。不执着心。不执着意。譬如诸法。不分别自性。不分别音声。而自性不舍。名字不灭。菩萨摩诃萨。亦复如是。不舍于行。随世所作。而于此二。无所执着。佛子。菩萨摩诃萨。见佛无量光色。无量形相。圆满成就。平等清净。一一现前。分明证了。或见佛身种种光明。或见佛身圆光一寻。或见佛身如盛日色。或见佛身微妙光色。或见佛身作清净色。或见佛身作黄金色。或见佛身作金刚色或见佛身作绀青色。或见佛身作无边色。或见佛身作大青摩尼宝色。或见佛身其量七肘。或见佛身其量八肘。或见佛身其量九肘。或见佛身其量十肘。或见佛身二十肘量。或见佛身三十肘量。如是乃至一百肘量。一千肘量。或见佛身一俱卢舍量。或见佛身半由旬量。或见佛身一由旬量。或见佛身十由旬量。或见佛身百由旬量。或见佛身千由旬量。或见佛身百千由旬量。或见佛身阎浮提量。或见佛身四天下量。或见佛身小千界量。或见佛身中千界量。或见佛身大千界量。或见佛身百大千世界量。或见佛身千大千世界量。或见佛身百千大千世界量。或见佛身百千亿那由他大千世界量。或见佛身无数大千世界量。或见佛身无量大千世界量。或见佛身无边大千世界量。或见佛身无等大千世界量。或见佛身不可数大千世界量。或见佛身不可称大千世界量。或见佛身不可思大千世界量。或见佛身不可量大千世界量。或见佛身不可说大千世界量。或见佛身不可说不可说大千世界量。佛子。菩萨如是。见诸如来无量色相。无量形状。无量示现。无量光明。无量光明网。其光分量。等于法界。于法界中。无所不照。普令发起无上智慧。又见佛身无有染着。无有障碍。上妙清净。佛子。菩萨如是。见于佛身。而如来身。不增不减。譬如虚空。于虫所食芥子孔中。亦不减小。于无数世界中。亦不增广。其诸佛身。亦复如是。见大之时。亦无所增。见小之时。亦无所减。佛子。譬如月轮。阎浮提人。见其形小。而亦不减。月中住者。见其形大。而亦不增。菩萨摩诃萨。亦复如是。住此三昧。随其心乐。见诸佛身种种化相。言辞演法。受持不忘。而如来身。不增不减。佛子。譬如众生命终之后。将受生时。不离于心。所见清净。菩萨摩诃萨。亦复如是。不离于此甚深三昧。所见清净。佛子。菩萨摩诃萨。住此三昧。成就十种速疾法。何者为十。所谓速增诸行。圆满大愿。速以法光。照耀世间。速以方便。转于法轮。度脱众生。速随众生业。示现诸佛清净国土。速以平等智。趣入十力。速与一切如来同住。速以大慈力。摧破魔军。速断众生疑。令生欢喜。速随胜解。示现神变。速以种种妙法言辞。净诸世间。佛子。此菩萨摩诃萨。复得十种法印。印一切法。何等为十。一者同去来今。一切诸佛平等善根。二者同诸如来得无边际智慧法身。三者同诸如来住不二法。四者同诸如来观察三世无量境界。皆悉平等。五者同诸如来。得了达法界无碍境界。六者同诸如来。成就十力。所行无碍。七者同诸如来。永绝二行。住无诤法。八者同诸如来。教化众生。恒不止息。九者同诸如来。于智善巧。义善巧中。能善观察。十者同诸如来。与一切佛平等无二。佛子。若菩萨摩诃萨。成就此了知一切世界佛庄严大三昧善巧方便门。是无师者。不由他教。自入一切佛法故。是丈夫者。能开悟一切众生故。是清净者。知心性本净故。是第一者。能度脱一切世间故。是安慰者。能开晓一切众生故。是安住者。未住佛种性者。令得住故。是真实知者。入一切智门故。是无异想者。所言无二故。是住法藏者。誓愿了知一切佛法故。是能雨法雨者。随众生心乐。悉令充足故。佛子。譬如帝释于顶髻中。置摩尼宝。以宝力故。威光转盛。其释天王。初获此宝。则得十法。出过一切三十三天。何等为十。一者色相。二者形体。三者示现。四者眷属。五者资具。六者音声。七者神通。八者自在。九者慧解。十者智用。如是十种。悉过一切三十三天。菩萨摩诃萨。亦复如是。初始获得此三昧时。则得十种广大智藏。何等为十。一者照耀一切佛刹智。二者知一切众生受生智。三者普作三世变化智。四者普入一切佛身智。五者通达一切佛法智。六者普摄一切净法智。七者普令一切众生入法身智。八者现见一切法普眼清净智。九者一切自在到于彼岸智。十者安住一切广大法普尽无余智。佛子。菩萨摩诃萨。住此三昧。复得十种最清净威德身。何等为十。一者为照耀不可说不可说世界故。放不可说不可说光明轮。二者为令世界咸清净故。放不可说不可说无量色相光明轮。三者为调伏众生故。放不可说不可说光明轮。四者为亲近一切诸佛故。化作不可说不可说身。五者为承事供养一切诸佛故。雨不可说不可说种种殊妙香华云。六者为承事供养一切佛。及调伏一切众生故。于一一毛孔中。化作不可说不可说种种音乐。七者为成熟众生故。现不可说不可说种种无量。自在神变。八者为于十方种种名号。一切佛所。请问法故。一步超过不可说不可说世界。九者为令一切众生见闻之者。皆不空故。现不可说不可说种种无量。清净色相身。无能见顶。十者为与众生。开示无量秘密法故。发不可说不可说音声语言。佛子。菩萨摩诃萨。得此十种最清净威德身已。能令众生得十种圆满。何等为十。一者能令众生。得见于佛。二者能令众生。深信于佛。三者能令众生。听闻于法。四者能令众生。知有佛世界。五者能令众生。见佛神变。六者能令众生。念所集业。七者能令众生。定心圆满。八者能令众生。入佛清净。九者能令众生。发菩提心。十者能令众生。圆满佛智。佛子。菩萨摩诃萨。令众生。得十种圆满已。复为众生。作十种佛事。何等为十。所谓以音声作佛事。为成熟众生故。以色形作佛事。为调伏众生故。以忆念作佛事。为清净众生故。以震动世界作佛事。为令众生。离恶趣故。以方便觉悟作佛事。为令众生。不失念故。以梦中现相作佛事。为令众生。恒正念故。以放大光明作佛事。为普摄取诸众生故。以修菩萨行作佛事。为令众生。住胜愿故。以成正等觉作佛事。为令众生。知幻法故。以转妙法轮作佛事。为众说法。不失时故。以现住寿命作佛事。为调伏一切众生故。以示般涅槃作佛事。知诸众生。起疲厌故。佛子。是为菩萨摩诃萨第七了知一切世界佛庄严大三昧善巧智

大方广佛华严经卷第四十一大方广佛华严经卷第四十二

        于阗国三藏实叉难陀奉　制译

    十定品第二十七之三

佛子。云何为菩萨摩诃萨。一切众生差别身三昧。佛子。菩萨摩诃萨。住此三昧。得十种无所著。何者为十。所谓于一切刹无所著。于一切方无所著。于一切劫无所著。于一切众无所著。于一切法无所著。于一切菩萨无所著。于一切菩萨。愿无所著。于一切三昧无所著。于一切佛无所著。于一切地无所著。是为十。佛子。菩萨摩诃萨。于此三昧。云何入。云何起。佛子。菩萨摩诃萨。于此三昧。内身入外身起。外身入内身起。同身入异身起。异身入同身起。人身入夜叉身起。夜叉身入龙身起。龙身入阿修罗身起。阿修罗身入天身起。天身入梵王身起。梵王身入欲界身起。天中入地狱起。地狱入人间起。人间入余趣起。千身入一身起。一身入千身起。那由他身入一身起。一身入那由他身起。阎浮提众生众中入。西瞿陀尼众生众中起。西瞿陀尼众生众中入。北拘卢众生众中起。北拘卢众生众中入。东毗提诃众生众中起。东毗提诃众生众中入。三天下众生众中起。三天下众生众中入。四天下众生众中起。四天下众生众中入。一切海差别众生众中起。一切海差别众生众中入。一切海神众中起。一切海神众中入。一切海水大中起。一切海水大中入。一切海地大中起。一切海地大中入。一切海火大中起。一切海火大中入。一切海风大中起。一切海风大中入。一切四大种中起。一切四大种中入。无生法中起。无生法中入。妙高山中起。妙高山中入。七宝山中起。七宝山中入。一切地种种稼穑树林黑山中起。一切地种种稼穑树林黑山中入。一切妙香华宝庄严中起。一切妙香华宝庄严中入。一切四天下下方上方一切众生受生中起。一切四天下下方上方一切众生受生中入。小千世界众生众中起。小千世界众生众中入。中千世界众生众中起。中千世界众生众中入。大千世界众生众中起。大千世界众生众中入。百千亿那由他三千大千世界众生众中起。百千亿那由他三千大千世界众生众中入。无数世界众生众中起。无数世界众生众中入。无量世界众生众中起。无量世界众生众中入。无边佛刹众生众中起。无边佛刹众生众中入。无等佛刹众生众中起。无等佛刹众生众中入。不可数世界众生众中起。不可数世界众生众中入。不可称世界众生众中起。不可称世界众生众中入。不可思世界众生众中起。不可思世界众生众中入。不可量世界众生众中起。不可量世界众生众中入。不可说世界众生众中起。不可说世界众生众中入。不可说不可说世界众生众中起。不可说不可说世界众生众中入。杂染众生众中起。杂染众生众中入。清净众生众中起。清净众生众中入。杂染众生众中起。眼处入耳处起。耳处入眼处起。鼻处入舌处起。舌处入鼻处起。身处入意处起。意处入身处起。自处入他处起。他处入自处起。一微尘中入。无数世界微尘中起。无数世界微尘中入。一微尘中起。声闻入独觉起。独觉入声闻起。自身入佛身起。佛身入自身起。一念入亿劫起。亿劫入一念起。同念入别时起。别时入同念起。前际入后际起。后际入前际起。前际入中际起。中际入前际起。三世入刹那起。刹那入三世起。真如入言说起。言说入真如起。佛子。譬如有人。为鬼所持。其身战动。不能自安。鬼不现身。令他身然。菩萨摩诃萨。住此三昧。亦复如是。自身入定他身起。他身入定自身起。佛子。譬如死尸以咒力故。而能起行。随所作事。皆得成就。尸之与咒。虽各差别。而能和合。成就彼事。菩萨摩诃萨。住此三昧。亦复如是。同境入定异境起。异境入定同境起。佛子。譬如比丘得心自在。或以一身作多身。或以多身作一身。非一身没多身生。非多身没一身生。菩萨摩诃萨。住此三昧。亦复如是。一身入定多身起。多身入定一身起。佛子。譬如大地其味一种。所生苗稼。种种味别。地虽无差别。然味有殊异。菩萨摩诃萨。住此三昧。亦复如是。无所分别。然有一种入定多种起。多种入定一种起。佛子。菩萨摩诃萨。住此三昧。得十种称赞法之所称赞。何者为十。所谓入真如故。名为如来。觉一切法故。名之为佛。为一切世间所称赞故。名为法师。知一切法故。名一切智。为一切世间所归依故。名所依处。了达一切法方便故。名为导师。引一切众生。入萨婆若道故。名大导师。为一切世间灯故。名为光明。心志圆满。义利成就。所作皆辨。住无碍智。分别了知一切诸法故。名为十力自在。通达一切法轮故。名一切见者。是为十。佛子。菩萨摩诃萨。住此三昧。复得十种光明照耀。何者为十。所谓得一切诸佛光明。与彼平等故。得一切世界光明。普能严净故。得一切众生光明。悉往调伏故。得无量无畏光明。法界为场演说故。得无差别光明。知一切法。无种种性故。得方便光明。于一切法离欲际。而证入故。得真实光明。于一切法离欲际。心平等故。得遍一切世间神变光明。蒙佛所加。恒不息故。得善思惟光明。到一切佛自在岸故。得一切法真如光明。于一毛孔中。善说一切故。是为十。佛子。菩萨摩诃萨。住此三昧。复得十种无所作。何者为十。所谓身业无所作。语业无所作。意业无所作。神通无所作。了法无性无所作。知业不坏无所作。无差别智无所作。无生起智无所作。知法无灭无所作。随顺于文不坏于义无所作。是为十。佛子。菩萨摩诃萨。住此三昧。无量境界。种种差别。所谓一入多起。多入一起。同入异起。异入同起。细入粗起。粗入细起。大入小起。小入大起。顺入逆起。逆入顺起。无身入有身起。有身入无身起。无相入有相起。有相入无相起。起中入入中起。如是皆是此之三昧自在境界。佛子。譬如幻师。持咒得成。能现种种差别形相。咒与幻别。而能作幻。咒唯是声。而能幻作。眼识所知。种种诸色。耳识所知。种种诸声。鼻识所知。种种诸香。舌识所知。种种诸味。身识所知。种种诸触。意识所知。种种境界。菩萨摩诃萨。住此三昧。亦复如是。同中入定异中起。异中入定同中起。佛子。譬如三十三天。共阿修罗。斗战之时。诸天得胜。修罗退衄。阿修罗王。其身长大。七百由旬。四兵围绕。无数千万。以幻术力。将诸军众。同时走入藕丝孔中。菩萨摩诃萨。亦复如是。已善成就诸幻智地。幻智即是菩萨。菩萨即是幻智。是故能于无差别法中入定。差别法中起。差别法中入定。无差别法中起。佛子。譬如农夫田中下种。种子在下。果生于上。菩萨摩诃萨。住此三昧。亦复如是。一中入定多中起。多中入定一中起。佛子。譬如男女。赤白和合。或有众生。于中受生。尔时名为歌罗逻位。从此次第。住母胎中。满足十月。善业力故。一切肢分。皆得成就。诸根不缺。心意明了。其歌罗逻。与彼六根。体状各别。以业力故。而能令彼次第成就。受同异类。种种果报。菩萨摩诃萨。亦复如是。从一切智歌罗逻位。信解愿力。渐次增长。其心广大。任运自在。无中入定有中起。有中入定无中起。佛子。譬如龙宫依地而立。不依虚空。龙依宫住。亦不在空。而能兴云。遍满空中有人仰视。所见宫殿。当知皆是乾闼婆城。非是龙宫。佛子。龙虽处下。而云布上。菩萨摩诃萨。住此三昧。亦复如是。于无相入有相起。于有相入无相起。佛子。譬如妙光大梵天王所住之宫。名一切世间最胜清净藏。此大宫中。普见三千大千世界诸四天下。天宫龙宫。夜叉宫。乾闼婆宫。阿修罗宫。迦楼罗宫。紧那罗宫。摩睺罗伽宫。人间住处。及三恶道。须弥山等。种种诸山。大海江河。陂泽泉源。城邑聚落。树林众宝。如是一切种种庄严。尽大轮围。所有边际。乃至空中。微细游尘。莫不皆于梵宫显现。如于明镜。见其面像。菩萨摩诃萨。住此一切众生差别身大三昧。知种种刹。见种种佛。度种种众。证种种法。成种种行。满种种解。入种种三昧。起种种神通。得种种智慧。住种种刹那际。佛子。此菩萨摩诃萨。到十种神通彼岸。何者为十。所谓到诸佛尽虚空遍法界神通彼岸。到菩萨究竟无差别自在神通彼岸。到能发起菩萨广大行愿。入如来门佛事神通彼岸。到能震动一切世界一切境界悉令清净神通彼岸。到能自在知一切众生不思议业果皆如幻化神通彼岸。到能自在知诸三昧粗细入出差别相神通彼岸。到能勇猛入如来境界而于其中发生大愿神通彼岸。到能化作佛化转法轮调伏众生令生佛种令入佛乘速得成就神通彼岸。到能了知不可说一切秘密文句而转法轮令百千亿那由他不可说不可说法门皆得清净神通彼岸。到不假昼夜年月劫数一念悉能三世示现神通彼岸。是为十。佛子。是名菩萨摩诃萨第八一切众生差别身大三昧善巧智

佛子。云何为菩萨摩诃萨。法界自在三昧。佛子。此菩萨摩诃萨。于自眼处乃至意处。入三昧。名法界自在。菩萨于自身一一毛孔中。入此三昧。自然能知诸世间。知诸世间法。知诸世界。知亿那由他世界。知阿僧祇世界。知不可说佛刹微尘数世界。见一切世界中。有佛出兴。菩萨众会。悉皆充满。光明清净。淳善无杂。广大庄严。种种众宝。以为严饰。菩萨于彼。或一劫百劫。千劫亿劫。百千亿那由他劫。无数劫无量劫。无边劫无等劫。不可数劫不可称劫。不可思劫不可量劫。不可说劫。不可说不可说劫。不可说不可说佛刹微尘数劫。修菩萨行。常不休息。又于如是无量劫中。住此三昧。亦入亦起。亦成就世界。亦调伏众生。亦遍了法界。亦普知三世。亦演说诸法。亦现大神通种种方便。无著无碍。以于法界。得自在故。善分别眼。善分别耳。善分别鼻。善分别舌。善分别身。善分别意。如是种种。差别不同。悉善分别。尽其边际。菩萨如是。善知见已。能生起十千亿。陀罗尼法光明。成就十千亿清净行。获得十千亿诸根。圆满十千亿神通。能入十千亿三昧。成就十千亿神力。长养十千亿诸力。圆满十千亿深心。运动十千亿力持。示现十千亿神变。具足十千亿菩萨无碍。圆满十千亿菩萨助道。积集十千亿菩萨藏。照明十千亿菩萨方便。演说十千亿诸义。成就十千亿诸愿。出生十千亿回向。净治十千亿菩萨正位。明了十千亿法门。开示十千亿演说。修治十千亿菩萨清净。佛子。菩萨摩诃萨。复有无数功德。无量功德。无边功德。无等功德。不可数功德。不可称功德。不可思功德。不可量功德。不可说功德。无尽功德。佛子。此菩萨。于如是功德。皆已辨具。皆已积集。皆已庄严。皆已清净。皆已莹彻。皆已摄受。皆能出生。皆可称叹。皆得坚固。皆已成就。佛子。菩萨摩诃萨。住此三昧。为东方十千阿僧祇佛刹微尘数名号诸佛之所摄受。一一名号。复有十千阿僧祇佛刹微尘数佛。各各差别。如东方。南西北方。四维上下。亦复如是。彼诸佛。悉现其前。为现诸佛清净刹。为说诸佛无量身。为说诸佛难思眼。为说诸佛无量耳。为说诸佛清净鼻。为说诸佛清净舌。为说诸佛无住心。为说如来无上神通。令修如来无上菩提。令得如来清净音声。开示如来不退法轮。显示如来无边众会。令入如来无边秘密。赞叹如来一切善根。令入如来平等之法。宣说如来三世种性。示现如来无量色相。阐扬如来护念之法。演畅如来微妙法音。辩明一切诸佛世界。宣扬一切诸佛三昧。示现诸佛众会次第。护持诸佛不思议法。说一切法。犹如幻化。明诸法性。无有动转。开示一切无上法轮。赞美如来无量功德。令入一切诸三昧云。令知其心。如幻如化。无边无尽。佛子。菩萨摩诃萨。住此法界自在三昧时。彼十方各十千阿僧祇佛刹微尘数名号如来。一一名中。各有十千阿僧祇佛刹微尘数佛。同时护念。令此菩萨。得无边身。令此菩萨。得无碍心。令此菩萨。于一切法。得无忘念。令此菩萨。于一切法。得决定慧。令此菩萨。转更聪敏。于一切法。皆能领受。令此菩萨。于一切法。悉能明了。令此菩萨。诸根猛利。于神通法。悉得善巧。令此菩萨。境界无碍。周行法界。恒不休息。令此菩萨。得无碍智。毕竟清净。令此菩萨。以神通力。一切世界。示现成佛。佛子。菩萨摩诃萨。住此三昧。得十种海。何者为十。所谓得诸佛海。咸睹见故。得众生海。悉调伏故。得诸法海。能以智慧。悉了知故。得诸刹海。以无性无作神通。皆往诣故。得功德海。一切修行。悉圆满故。得神通海。能广示现。令开悟故。得诸根海。种种不同。悉善知故。得诸心海。知一切众生。种种差别。无量心故。得诸行海。能以愿力。悉圆满故。得诸愿海。悉使成就。永清净故。佛子。菩萨摩诃萨。得如是十种海已。复得十种殊胜。何等为十。一者于一切众生中。最为第一。二者于一切诸天中。最为殊特。三者于一切梵王中。最极自在。四者于诸世间。无所染着。五者一切世间。无能映蔽。六者一切诸魔。不能惑乱。七者普入诸趣。无所挂碍。八者处处受生。知不坚固。九者一切佛法。皆得自在。十者一切神通。悉能示现。佛子。菩萨摩诃萨。得如是十种殊胜已。复得十种力。于众生界。修习诸行。何等为十。一谓勇健力。调伏世间故。二谓精进力。恒不退转故。三谓无著力。离诸垢染故。四谓寂静力。于一切法。无诤论故。五谓逆顺力。于一切法。心自在故。六谓法性力。于诸义中。得自在故。七谓无碍力。智慧广大故。八谓无畏力。能说诸法故。九谓辩才力。能持诸法故。十谓开示力。智慧无边故。佛子。此十种力。是广大力。最胜力。无能摧伏力。无量力。善集力。不动力。坚固力。智慧力。成就力。胜定力。清净力。极清净力。法身力。法光明力。法灯力。法门力。无能坏力。极勇猛力。大丈夫力。善丈夫修习力。成正觉力。过去积集善根力。安住无量善根力。住如来力。力心思惟力。增长菩萨欢喜力。出生菩萨净信力。增长菩萨勇猛力。菩提心所生力。菩萨清净深心力。菩萨殊胜深心力。菩萨善根熏习力。究竟诸法力。无障碍身力。入方便善巧法门力。清净妙法力。安住大势一切世间。不能倾动力。一切众生无能映蔽力。佛子。此菩萨摩诃萨。于如是无量功德法。能生能成就。能圆满能照明。能具足能遍具足。能广大能坚固。能增长能净治。能遍净治。此菩萨功德边际。智慧边际。修行边际。法门边际。自在边际。苦行边际。成就边际。清净边际。出离边际。法自在边际。无能说者。此菩萨。所获得。所成就。所趣入。所现前。所有境界。所有观察。所有证入。所有清净。所有了知。所有建立。一切法门。于不可说劫。无能说尽。佛子。菩萨摩诃萨。住此三昧。能了知无数无量无边无等不可数不可称不可思不可量不可说不可说不可说一切三昧。彼一一三昧。所有境界。无量广大。于境界中。若入若起。若住。所有相状。所有示现。所有行处。所有等流。所有自性。所有除灭。所有出离。如是一切靡不明见。佛子。譬如无热恼大龙王宫。流出四河。无浊无杂。无有垢秽。光色清净。犹如虚空。其池四面。各有一口。一一口中。流出一河。于象口中。出恒伽河。师子口中。出私陀河。于牛口中。出信度河。于马口中。出缚刍河。其四大河流出之时。恒伽河口。流出银沙。私陀河口。出金刚沙。信度河口。流出金沙。缚刍河口。出琉璃沙。恒伽河口。作白银色。私陀河口。作金刚色。信度河口。作黄金色。缚刍河口。作琉璃色一一河口。广一由旬。其四大河既流出已。各共围绕大池七匝。随其方面。四向分流澒涌奔驰。入于大海。其河旋绕。一一之间。有天宝所成。优钵罗华。波头摩华。拘物头华。芬陀利华。奇香发越。妙色清净。种种华叶。种种台蕊。悉是众宝。自然映彻。咸放光明。互相照现。其无热池。周围广大。五十由旬众宝妙沙。遍布其底。种种摩尼。以为严饰。无量妙宝。庄严其岸。栴檀妙香。普散其中。优钵罗华。波头摩华。拘物头华。芬陀利华。及余宝华。皆悉遍满。微风吹动。香气远彻。华林宝树。周匝围绕。日光出时。普皆照明。池河内外。一切众物。接影连辉。成光明网。如是众物。若远若近。若高若下。若广若狭。若粗若细。乃至极小。一沙一尘。悉是妙宝。光明鉴彻。靡不于中日轮影现。亦复展转。更相现影。如是众影。不增不减。非合非散。皆如本质。而得明见。佛子。如无热大池。于四口中。流出四河入于大海。菩萨摩诃萨。亦复如是。从四辩才。流出诸行。究竟入于一切智海。如恒伽大河。从银色象口。流出银沙。菩萨摩诃萨。亦复如是。以义辩才。说一切如来所说一切义门。出生一切清净白法。究竟入于无碍智海。如私陀大河。从金刚色师子口。流出金刚沙。菩萨摩诃萨。亦复如是。以法辩才。为一切众生。说佛金刚句。引出金刚智。究竟入于无碍智海。如信度大河。从金色牛口。流出金沙。菩萨摩诃萨。亦复如是。以训辞辩。说随顺世间缘起方便。开悟众生。令皆欢喜。调伏成熟。究竟入于缘起方便海。如缚刍大河。于琉璃色马口。流出琉璃沙。菩萨摩诃萨。亦复如是。以无尽辩。雨百千亿那由他不可说法。令其闻者。皆得润洽。究竟入于诸佛法海。如四大河。随顺围绕无热池已四方入海。菩萨摩诃萨。亦复如是。成就随顺身业随顺语业。随顺意业。成就智为前导身业。智为前导语业。智为前导意业。四方流注。究竟入于一切智海。佛子。何者名为菩萨四方。佛子。所谓见一切佛。而得开悟。闻一切法。受持不忘。圆满一切波罗蜜行。大悲说法。满足众生如四大河围绕大池。于其中间。优钵罗华。波头摩华。拘物头华。芬陀利华。皆悉遍满。菩萨摩诃萨。亦复如是。于菩提心中间。不舍众生说法调伏悉令圆满无量三昧。见佛国土。庄严清净。如无热大池宝树围绕。菩萨摩诃萨亦复如是。现佛国土庄严围绕。令诸众生。趣向菩提。如无热大池。其中纵广。五十由旬。清净无浊。菩萨摩诃萨。亦复如是。菩提之心。其量无边。善根充满。清净无浊。如无热大池。以无量宝。庄严其岸。散栴檀香遍满其中。菩萨摩诃萨。亦复如是。以百千亿十种智宝。严菩提心大愿之岸。普散一切众善妙香。如无热大池。底布金沙。种种摩尼。间错庄严。菩萨摩诃萨。亦复如是。微妙智慧。周遍观察。不可思议菩萨解脱。种种法宝。间错庄严。得一切法无碍光明。住于一切诸佛所住。入于一切甚深方便。如阿那婆达多龙王。永离龙中所有热恼。菩萨摩诃萨。亦复如是。永离一切世间忧恼。虽现受生。而无染着。如四大河。润泽一切。阎浮提地。既润泽已。入于大海。菩萨摩诃萨。亦复如是。以四智河。润泽天人沙门婆罗门。令其普入阿耨多罗三藐三菩提智慧大海。以十种力。而为庄严。何者为四。一者愿智河。救护调伏一切众生。常不休息。二者波罗蜜智河。修菩提行。饶益众生。去来今世。相续无尽。究竟入于诸佛智海。三者菩萨三昧智河。无数三昧。以为庄严。见一切佛。入诸佛海。四者大悲智河。大慈自在。普救众生。方便摄取。无有休息。修行秘密功德之门。究竟入于十力大海。如四大河从无热池。既流出已。究竟无尽。入于大海。菩萨摩诃萨。亦复如是。以大愿力。修菩萨行。自在知见。无有穷尽。究竟入于一切智海。如四大河入于大海。无能为碍令不入者。菩萨摩诃萨。亦复如是。常勤修习普贤行愿。成就一切智慧光明。住于一切佛菩提法。入如来智。无有障碍。如四大河。奔流入海。经于累劫。亦无疲厌。菩萨摩诃萨。亦复如是。以普贤行愿。尽未来劫。修菩萨行。入如来海。不生疲厌。佛子。如日光出时。无热池中。金沙银沙。金刚沙琉璃沙。及余一切种种宝物。皆有日影于中显现。其金沙等。一切宝物。亦各展转。而现其影。互相鉴彻。无所妨碍。菩萨摩诃萨。亦复如是。住此三昧。于自身一一毛孔中。悉见不可说不可说佛刹微尘数诸佛如来。亦见彼佛所有国土。道场众会。一一佛所。听法受持。信解供养。各经不可说不可说亿那由他劫。而不想念。时节长短。其诸众会。亦无迫隘。何以故。以微妙心。入无边法界故。入无等差别业果故。入不思议三昧境界故。入不思议思惟境界故。入一切佛自在境界故。得一切佛所护念故。得一切佛大神变故。得诸如来。难得难知。十种力故。入普贤菩萨行。圆满境界故。得一切佛无劳倦神通力故。佛子。菩萨摩诃萨。虽能于定。一念入出。而亦不废长时在定。亦无所著。虽于境界。无所依住。而亦不舍一切所缘。虽善入刹那际。而为利益一切众生。现佛神通。无有厌足。虽等入法界。而不得其边。虽无所住。无有处所。而恒趣入一切智道。以变化力。普入无量众生众中。具足庄严一切世界。虽离世间。颠倒分别。超过一切分别之地。亦不舍于种种诸相。虽能具足方便善巧而究竟清净。虽不分别菩萨诸地。而皆已善入。佛子。譬如虚空。虽能容受一切诸物。而离有无。菩萨摩诃萨。亦复如是。虽普入一切世间。而离世间想。虽勤度一切众生。而离众生想。虽深知一切法。而离诸法想。虽乐见一切佛。而离诸佛想。虽善入种种三昧。而知一切法。自性皆如。无所染着。虽以无边辩才。演无尽法句。而心恒住离文字法。虽乐观察无言说法。而恒示现清净音声。虽住一切离言法际。而恒示现种种色相。虽教化众生。而知一切法。毕竟性空。虽勤修大悲。度脱众生。而知众生界无尽无散。虽了达法界。常住不变。而以三轮。调伏众生。恒不休息。虽常安住如来所住。而智慧清净。心无怖畏。分别演说种种诸法。转于法轮。常不休息。佛子。是为菩萨摩诃萨第九法界自在大三昧善巧智

大方广佛华严经卷第四十二大方广佛华严经卷第四十三

        于阗国三藏实叉难陀奉　制译

    十定品第二十七之四

佛子。云何为菩萨摩诃萨。无碍轮三昧。佛子。菩萨摩诃萨。入此三昧时。住无碍身业。无碍语业。无碍意业。住无碍佛国土。得无碍成就众生智。获无碍调伏众生智。放无碍光明。现无碍光明网。示无碍广大变化。转无碍清净法轮。得菩萨无碍自在。普入诸佛力。普住诸佛智。作佛所作。净佛所净。现佛神通。令佛欢喜。行如来行。住如来道。常得亲近无量诸佛。作诸佛事。绍诸佛种。佛子。菩萨摩诃萨。住此三昧已。观一切智。总观一切智。别观一切智。随顺一切智。显示一切智。攀缘一切智。见一切智。总见一切智。别见一切智。于普贤菩萨。广大愿。广大心。广大行。广大所趣。广大所入。广大光明。广大出现。广大护念。广大变化。广大道。不断不退。无休无替。无倦无舍。无散无乱。常增进。恒相续。何以故。此菩萨摩诃萨。于诸法中。成就大愿。发行大乘。入于佛法大方便海。以胜愿力。于诸菩萨所行之行。智慧明照。皆得善巧。具足菩萨神通变化。善能护念一切众生。如去来今一切诸佛之所护念。于诸众生。恒起大悲。成就如来不变异法。佛子。譬如有人。以摩尼宝。置色衣中。其摩尼宝。虽同衣色。不舍自性。菩萨摩诃萨。亦复如是。成就智慧。以为心宝。观一切智。普皆明现。然不舍于菩萨诸行。何以故。菩萨摩诃萨。发大誓愿。利益一切众生。度脱一切众生。承事一切诸佛。严净一切世界。安慰众生。深入法海。为净众生界。现大自在。给施众生。普照世间。入于无边幻化法门。不退不转。无疲无厌。佛子。譬如虚空持众世界。若成若住。无厌无倦。无羸无朽。无散无坏。无变无异。无有差别。不舍自性。何以故。虚空自性。法应尔故。菩萨摩诃萨。亦复如是。立无量大愿。度一切众生。心无厌倦。佛子。譬如涅槃去来现在。无量众生。于中灭度。终无厌倦。何以故。一切诸法。本性清净。是谓涅槃。云何于中。而有厌倦。菩萨摩诃萨。亦复如是。为欲度脱一切众生。皆令出离。而现于世。云何而起疲厌之心。佛子。如萨婆若。能令过去未来现在一切菩萨。于诸佛家。已现当生。乃至令成无上菩提。终不疲厌。何以故。一切智与法界。无二故。于一切法。无所著故。菩萨摩诃萨。亦复如是。其心平等。住一切智。云何而有疲厌之心。佛子。此菩萨摩诃萨。有一莲华。其华广大。尽十方际。以不可说叶。不可说宝。不可说香。而为庄严。其不可说宝。复各示现种种众宝。清净妙好。极善安住。其华常放众色光明。普照十方一切世界。无所障碍。真金为网。弥覆其上。宝铎徐摇。出微妙音。其音演畅一切智法。此大莲华。具足如来清净庄严。一切善根之所生起。吉祥为表。神力所现。有十千阿僧祇清净功德。菩萨妙道之所成就。一切智心之所流出。十方佛影。于中显现。世间瞻仰。犹如佛塔。众生见者。无不礼敬。从能了幻。正法所生。一切世间。不可为谕。菩萨摩诃萨。于此华上。结跏趺坐。其身大小。与华相称。一切诸佛。神力所加。令菩萨身一一毛孔。各出百万亿那由他不可说佛刹微尘数光明。一一光明。现百万亿那由他不可说佛刹微尘数摩尼宝。其宝皆名普光明藏。种种色相。以为庄严。无量功德之所成就。众宝及华。以为罗网。弥覆其上。散百千亿那由他殊胜妙香。无量色相。种种庄严。复现不思议宝庄严盖。以覆其上。一一摩尼宝。悉现百万亿那由他不可说佛刹微尘数楼阁。一一楼阁。现百万亿那由他不可说佛刹微尘数莲华藏师子之座。一一师子座。现百万亿那由他不可说佛刹微尘数光明。一一光明。现百万亿那由他不可说佛刹微尘数色相。一一色相。现百万亿那由他不可说佛刹微尘数光明轮。一一光明轮。现百万亿那由他不可说佛刹微尘数毗卢遮那摩尼宝华。一一华。现百万亿那由他不可说佛刹微尘数台。一一台。现百万亿那由他不可说佛刹微尘数佛。一一佛。现百万亿那由他不可说佛刹微尘数神变。一一神变。净百万亿那由他不可说佛刹微尘数众生众。一一众生众中。现百万亿那由他不可说佛刹微尘数诸佛自在。一一自在。雨百万亿那由他不可说佛刹微尘数佛法。一一佛法。有百万亿那由他不可说佛刹微尘数修多罗。一一修多罗。说百万亿那由他不可说佛刹微尘数法门。一一法门。有百万亿那由他不可说佛刹微尘数金刚智。所入法轮。差别言辞。各别演说。一一法轮。成熟百万亿那由他不可说佛刹微尘数众生界。一一众生界。有百万亿那由他不可说佛刹微尘数众生。于佛法中。而得调伏。佛子。菩萨摩诃萨。住此三昧。示现如是神通境界。无量变化。悉知如幻。而不染着。安住无边不可说法。自性清净。法界实相。如来种性。无碍际中。无去无来。非先非后。甚深无底。现量所得。以智自入。不由他悟。心不迷乱。亦无分别。为去来今一切诸佛之所称赞。从诸佛力之所流出。入于一切诸佛境界。体性如实。净眼现证。慧眼普见。成就佛眼。为世明灯。行于智眼。所知境界。广能开示微妙法门。成菩提心。趣胜丈夫。于诸境界。无有障碍。入智种性。出生诸智。离世生法。而现受生。神通变化。方便调伏。如是一切。无非善巧。功德解欲。悉皆清净。最极微妙。具足圆满。智慧广大。犹如虚空。善能观察。众圣境界。信行愿力。坚固不动。功德无尽。世所称叹。于一切佛所观之藏。大菩提处。一切智海。集众妙宝。为大智者。犹如莲华。自性清净。众生见者。皆生欢喜。咸得利益。智光普照。见无量佛。净一切法。所行寂静。于诸佛法。究竟无碍。恒以方便。住佛菩提。功德行中。而得出生。具菩萨智。为菩萨首。一切诸佛。共所护念。得佛威神。成佛法身。念力难思。于境一缘。而无所缘。其行广大。无相无碍。等于法界无量无边。所证菩提。犹如虚空无有边际。无所缚着。于诸世间。普作饶益。一切智海。善根所流。悉能通达。无量境界。已善成就清净施法。住菩萨心。净菩萨种。能随顺生诸佛菩提。于诸佛法。皆得善巧。具微妙行。成坚固力。一切诸佛。自在威神。众生难闻。菩萨悉知入不二门。住无相法。虽复永舍一切诸相。而能广说种种诸法。随诸众生。心乐欲解。悉使调伏。咸令欢喜。法界为身。无有分别。智慧境界。不可穷尽。志常勇猛。心恒平等。见一切佛。功德边际。了一切劫。差别次第。开示一切法。安住一切刹。严净一切诸佛国土。显现一切正法光明。演去来今一切佛法。示诸菩萨所住之处。为世明灯。生诸善根。永离世间。常生佛所。得佛智慧。明了第一。一切诸佛。皆共摄受。已入未来诸佛之数。从诸善友。而得出生。所有志求。皆无不果。具大威德。住增上意。随所听闻。咸能善说。亦为开示闻法善根。住实际轮。于一切法。心无障碍。不舍诸行。离诸分别。于一切法。心无动念。得智慧明。灭诸痴闇。悉能明照一切佛法。不坏诸有。而生其中。了知一切诸有境界。从本已来。无有动作。身语意业。皆悉无边。虽随世俗。演说种种。无量文字。而恒不坏离文字法。深入佛海。知一切法。但有假名。于诸境界。无系无著。了一切法。空无所有。所修诸行。从法界生。犹如虚空无相无形。深入法界。随顺演说于一境门。生一切智。观十力地。以智修学。智为桥梁。至萨婆若。以智慧眼。见法无碍。善入诸地。知种种义。一一法门。悉得明了。所有大愿。靡不成就。佛子。菩萨摩诃萨。以此开示一切如来。无差别性。此是无碍方便之门。此能出生菩萨众会。此法唯是三昧境界。此能勇进。入萨婆若。此能开显诸三昧门。此能无碍。普入诸刹。此能调伏一切众生。此能住于无众生际。此能开示一切佛法。此于境界。皆无所得。虽一切时演说开示。而恒远离妄想分别。虽知诸法皆无所作。而能示现一切作业。虽知诸佛无有二相。而能显示一切诸佛。虽知无色。而演说诸色。虽知无受。而演说诸受。虽知无想。而演说诸想。虽知无行。而演说诸行。虽知无识。而演说诸识。恒以法轮。开示一切。虽知法无生。而常转法轮。虽知法无差别。而说诸差别门。虽知诸法无有生灭。而说一切生灭之相。虽知诸法无粗无细。而说诸法粗细之相。虽知诸法无上中下。而能宣说最上之法。虽知诸法不可言说。而能演说清净言辞。虽知诸法无内无外。而说一切内外诸法。虽知诸法不可了知。而说种种智慧观察。虽知诸法无有真实。而说出离真实之道。虽知诸法毕竟无尽。而能演说尽诸有漏。虽知诸法无违无诤。然亦不无自他差别。虽知诸法毕竟无师。而常尊敬一切师长。虽知诸法不由他悟。而常尊敬诸善知识。虽知法无转。而转法轮。虽知法无起。而示诸因缘。虽知诸法无有前际。而广说过去。虽知诸法无有后际。而广说未来。虽知诸法无有中际。而广说现在。虽知诸法无有作者。而说诸作业。虽知诸法无有因缘。而说诸集因。虽知诸法无有等比。而说平等不平等道。虽知诸法无有言说。而决定说三世之法。虽知诸法无有所依。而说依善法而得出离。虽知法无身。而广说法身。虽知三世诸佛无边。而能演说唯有一佛。虽知法无色。而现种种色。虽知法无见。而广说诸见。虽知法无相。而说种种相。虽知诸法无有境界。而广宣说智慧境界。虽知诸法无有差别。而说行果种种差别。虽知诸法无有出离。而说清净诸出离行。虽知诸法本来常住。而说一切诸流转法。虽知诸法无有照明。而恒广说照明之法。佛子。菩萨摩诃萨。入如是大威德三昧智轮。则能证得一切佛法。则能趣入一切佛法。则能成就。则能圆满。则能积集。则能清净。则能安住。则能了达。与一切法自性相应。而此菩萨摩诃萨。不作是念。有若干诸菩萨。若干菩萨法。若干菩萨究竟。若干幻究竟。若干化究竟。若干神通成就。若干智成就。若干思惟。若干证入。若干趣向。若干境界。何以故。菩萨三昧。如是体性。如是无边。如是殊胜故。此三昧种种境界。种种威力。种种深入。所谓入不可说智门。入离分别诸庄严。入无边殊胜波罗蜜。入无数禅定。入百千亿那由他不可说广大智。入见无边佛胜妙藏。入于境界不休息。入清净信解助道法。入诸根猛利大神通。入于境界心无碍。入见一切佛平等眼。入积集普贤胜志行。入住那罗延妙智身。入说如来智慧海。入起无量种自在神变。入生一切佛无尽智门。入住一切佛现前境界。入净普贤菩萨自在智。入开示无比普门智。入普知法界一切微细境界。入普现法界一切微细境界。入一切殊胜智光明。入一切自在边际。入一切辩才法门际。入遍法界智慧身。入成就一切处遍行道。入善住一切差别三昧。入知一切诸佛心。佛子。此菩萨摩诃萨。住普贤行。念念入百亿不可说三昧。然不见普贤菩萨三昧。及佛境界庄严前际。何以故。知一切法究竟无尽故。知一切佛刹无边故。知一切众生界不思议故。知前际无始故。知未来无穷故。知现在尽虚空遍法界无边故。知一切诸佛境界不可思议故。知一切菩萨行无数故。知一切诸佛辩才所说境界不可说无边故。知一切幻心所缘法无量故。佛子。如如意珠随有所求。一切皆得。求者无尽。意皆满足。而珠势力。终不匮止。菩萨摩诃萨。亦复如是。入此三昧。知心如幻。出生一切诸法境界。周遍无尽。不匮不息。何以故。菩萨摩诃萨。成就普贤无碍行智。观察无量广大幻境。犹如影像。无增减故。佛子。譬如凡夫。各别生心。已生现生。及以当生。无有边际。无断无尽。其心流转。相续不绝不可思议。菩萨摩诃萨。亦复如是。入此普幻门三昧。无有边际。不可测量。何以故。了达普贤菩萨普幻门无量法故。佛子。譬如难陀跋难陀。摩那斯龙王。及余大龙。降雨之时。滴如车轴。无有边际。虽如是雨。云终不尽。此是诸龙。无作境界。菩萨摩诃萨。亦复如是。住此三昧。入普贤菩萨诸三昧门。智门法门。见诸佛门。往诸方门。心自在门。加持门。神变门。神通门。幻化门。诸法如幻门。不可说不可说诸菩萨充满门。亲近不可说不可说佛刹微尘数如来正觉门。入不可说不可说广大幻网门。知不可说不可说差别广大佛刹门。知不可说不可说有体性无体性世界门。知不可说不可说众生想门。知不可说不可说时差别门。知不可说不可说世界成坏门。知不可说不可说覆住仰住诸佛刹门。于一念中。皆如实知。如是入时。无有边际。无有穷尽。不疲不厌。不断不息。无退无失。于诸法中。不住非处。恒正思惟。不沈不举。求一切智。常无退舍。为一切佛刹。照世明灯。转不可说不可说法轮。以妙辩才。咨问如来。无穷尽时。示成佛道。无有边际。调伏众生。恒无废舍。常勤修习普贤行愿。未曾休息。示现无量不可说不可说色相身。无有断绝。何以故。譬如然火。随所有缘。于尔所时。火起不息。菩萨摩诃萨。亦复如是。观察众生界。法界世界。犹如虚空。无有边际。乃至能于一念之顷。往不可说不可说佛刹微尘数佛所。一一佛所。入不可说不可说一切智种种差别法。令不可说不可说众生界。出家为道。勤修善根。究竟清净。令不可说不可说菩萨。于普贤行愿。未决定者。而得决定。安住普贤智慧之门。以无量方便。入不可说不可说三世成住坏。广大差别劫。于不可说不可说成住坏世间。差别境界。起于尔所大悲大愿。调伏无量一切众生悉使无余。何以故。此菩萨摩诃萨。为欲度脱一切众生。修普贤行。生普贤智。满足普贤所有行愿。是故。诸菩萨。应于如是种类。如是境界。如是威德。如是广大。如是无量。如是不思议。如是普照明。如是一切诸佛现前住。如是一切如来所护念。如是成就往昔善根。如是其心无碍不动。三昧之中。勤加修习。离诸热恼。无有疲厌。心不退转。立深志乐。勇猛无怯。顺三昧境界。入难思智地。不依文字。不着世间。不取诸法。不起分别。不染着世事。不分别境界。于诸法智。但应安住。不应称量。所谓亲近一切智。悟解佛菩提。成就法光明。施与一切众生善根。于魔界中。拔出众生。令其得入佛法境界。令不舍大愿。勤观出道。增广净境。成就诸度。于一切佛。深生信解。常应观察一切法性。无时暂舍。应知自身。与诸法性。普皆平等。应当明解世间所作。示其如法。智慧方便。应常精进。无有休息。应观自身。善根鲜少。应勤增长他诸善根。应自修行一切智道。应勤增长菩萨境界。应乐亲近诸善知识。应与同行而共止住。应不分别佛。应不舍离念。应常安住平等法界。应知一切心识如幻。应知世间诸行如梦。应知诸佛愿力出现。犹如影像。应知一切诸广大业。犹如变化。应知言语悉皆如响。应观诸法一切如幻。应知一切生灭之法。皆如音声。应知所往一切佛刹。皆无体性。应为请问如来佛法。不生疲倦。应为开悟一切世间。勤加教诲。而不舍离。应为调伏一切众生。知时说法。而不休息。佛子。菩萨摩诃萨。如是修行普贤之行。如是圆满菩萨境界。如是通达出离之道。如是受持三世佛法。如是观察一切智门。如是思惟不变异法。如是明洁增上志乐。如是信解一切如来。如是了知佛广大力。如是决定无所碍心。如是摄受一切众生

佛子。菩萨摩诃萨。入普贤菩萨所住。如是大智慧三昧时。十方各有不可说不可说国土。一一国土。各有不可说不可说佛刹微尘数如来名号。一一名号。各有不可说不可说佛刹微尘数诸佛。而现其前。与如来念力。令不忘失如来境界。与一切法究竟慧。令入一切智。与知一切法种种义决定慧。令受持一切佛法趣入无碍。与无上佛菩提。令入一切智开悟法界。与菩萨究竟慧。令得一切法光明无诸黑闇。与菩萨不退智。令知时非时善巧方便调伏众生。与无障碍菩萨辩才。令悟解无边法演说无尽。与神通变化力。令现不可说不可说差别身无边色相种种不同开悟众生。与圆满言音。令现不可说不可说差别音声种种言辞开悟众生。与不唐捐力。令一切众生若得见形若得闻法皆悉成就无空过者。佛子。菩萨摩诃萨。如是满足普贤行故。得如来力。净出离道。满一切智。以无碍辩才。神通变化。究竟调伏一切众生。具佛威德。净普贤行。住普贤道。尽未来际。为欲调伏一切众生。转一切佛。微妙法轮。何以故。佛子。此菩萨摩诃萨。成就如是殊胜大愿。诸菩萨行。则为一切世间法师。则为一切世间法日。则为一切世间智月。则为一切世间须弥山王。嶷然高出。坚固不动。则为一切世间。无涯智海。则为一切世间正法明灯。普照无边。相续不断。为一切众生。开示无边清净功德。皆令安住功德善根。顺一切智。大愿平等。修习普贤广大之行。常能劝发无量众生。住不可说不可说广大行三昧。现大自在。佛子。此菩萨摩诃萨。获如是智。证如是法。于如是法。审住明见。得如是神力。住如是境界。现如是神变。起如是神通。常安住大悲。常利益众生。开示众生。安隐正道。建立福智。大光明幢。证不思议解脱。住一切智解脱。到诸佛解脱彼岸。学不思议解脱方便门。已得成就。入法界差别门。无有错乱。于普贤不可说不可说三昧。游戏自在。住师子奋迅智。心意无碍。其心恒住十大法藏。何者为十。所谓住忆念一切诸佛。住忆念一切佛法。住调伏一切众生大悲。住示现不思议清净国土智。住深入诸佛境界决定解。住去来现在一切佛平等相菩提。住无碍无著际。住一切法无相性。住去来现在一切佛平等善根。住去来现在一切如来法界无差别身语意业先导智。住观察三世一切诸佛受生出家诣道场成正觉转法轮般涅槃悉入刹那际。佛子。此十大法藏。广大无量。不可数不可称。不可思不可说。无穷尽。难忍受。一切世智。无能称述。佛子。此菩萨摩诃萨。已到普贤诸行彼岸。证清净法。志力广大。开示众生无量善根。增长菩萨一切势力。于念念顷。满足菩萨一切功德。成就菩萨一切诸行。得一切佛陀罗尼法。受持一切诸佛所说。虽常安住真如实际。而随一切世俗言说。示现调伏一切众生。何以故。菩萨摩诃萨。住此三昧。法如是故。佛子。菩萨摩诃萨。以此三昧。得一切佛广大智。得巧说一切广大法自在辩才。得一切世中最为殊胜清净无畏法。得入一切三昧智。得一切菩萨善巧方便。得一切法光明门。到安慰一切世间法彼岸。知一切众生时非时。照十方世界一切处。令一切众生得胜智。作一切世间无上师。安住一切诸功德。开示一切众生清净三昧。令入最上智。何以故。菩萨摩诃萨。如是修行。则利益众生。则增长大悲。则亲近善知识。则见一切佛。则了一切法。则诣一切刹。则入一切方。则入一切世。则悟一切法平等性。则知一切佛平等性。则住一切智平等性。于此法中。作如是业。不作余业。住未足心。住不散乱心。住专一心。住勤修心。住决定心。住不变异心。如是思惟。如是作业。如是究竟。佛子。菩萨摩诃萨。无异语异作。有如语如作。何以故。譬如金刚以不可坏。而得其名。终无有时离于不坏。菩萨摩诃萨。亦复如是。以诸行法。而得其名。终无有时离诸行法。譬如真金。以有妙色。而得其名。终无有时离于妙色。菩萨摩诃萨。亦复如是。以诸善业。而得其名。终无有时离诸善业。譬如日天子。以光明轮。而得其名。终无有时离光明轮。菩萨摩诃萨。亦复如是。以智慧光。而得其名。终无有时离智慧光。譬如须弥山王。以四宝峰。处于大海。迥然高出。而得其名。终无有时舍离四峰。菩萨摩诃萨。亦复如是。以诸善根。处在于世。迥然高出。而得其名。终无有时舍离善根。譬如大地。以持一切。而得其名。终无有时舍离能持。菩萨摩诃萨。亦复如是。以度一切。而得其名。终无有时舍离大悲。譬如大海。以含众水。而得其名。终无有时舍离于水。菩萨摩诃萨。亦复如是。以诸大愿。而得其名。终不暂舍度众生愿。譬如军将。以能惯习战斗之法。而得其名。终无有时舍离此能。菩萨摩诃萨。亦复如是。以能惯习如是三昧。而得其名。乃至成就一切智智。终无有时舍离此行。如转轮王。驭四天下。常勤守护一切众生。令无横死。恒受快乐。菩萨摩诃萨。亦复如是。入如是等诸大三昧。常勤化度一切众生。乃至令其究竟清净。譬如种子植之于地。乃至能令茎叶增长。菩萨摩诃萨。亦复如是。修普贤行。乃至能令一切众生。善法增长。譬如大云于夏暑月。降霔大雨。乃至增长一切种子。菩萨摩诃萨。亦复如是。入如是等诸大三昧。修菩萨行。雨大法雨。乃至能令一切众生。究竟清净。究竟涅槃。究竟安隐。究竟彼岸。究竟欢喜。究竟断疑。为诸众生。究竟福田。令其施业。皆得清净。令其皆住不退转道。令其同得一切智智。令其皆得出离三界。令其皆得究竟之智。令其皆得诸佛如来。究竟之法。置诸众生一切智处。何以故。菩萨摩诃萨。成就此法。智慧明了。入法界门。能净菩萨不可思议。无量诸行。所谓能净诸智。求一切智故。能净众生。使调伏故。能净刹土。常回向故。能净诸法。普了知故。能净无畏。无怯弱故。能净无碍辩。巧演说故。能净陀罗尼。于一切法。得自在故。能净亲近行。常见一切佛兴世故。佛子。菩萨摩诃萨。住此三昧。得如是等百千亿那由他不可说不可说清净功德。于如是等三昧境界。得自在故。一切诸佛所加被故。自善根力之所流故。入智慧地。大威力故。诸善知识。引导力故。摧伏一切诸魔力故。同分善根。淳净力故。广大誓愿。欲乐力故。所种善根。成就力故。超诸世间无尽之福。无对力故。佛子。菩萨摩诃萨。住此三昧。得十种法。同去来今一切诸佛。何者为十。所谓得诸相好。种种庄严。同于诸佛。能放清净大光明网。同于诸佛神通变化。调伏众生。同于诸佛。无边色身。清净圆音。同于诸佛。随众生业。现净佛国。同于诸佛。一切众生。所有语言。皆能摄持。不忘不失。同于诸佛。无尽辩才。随众生心。而转法轮。令生智慧。同于诸佛。大师子吼。无所怯畏。以无量法。开悟群生。同于诸佛。于一念顷。以大神通。普入三世。同于诸佛。普能显示一切众生。诸佛庄严。诸佛威力。诸佛境界。同于诸佛

尔时普眼菩萨。白普贤菩萨言。佛子。此菩萨摩诃萨。得如是法。同诸如来。何故不名佛。何故不名十力。何故不名一切智。何故不名一切法中。得菩提者。何故不得名为普眼。何故不名一切境中无碍见者。何故不名觉一切法。何故不名与三世佛无二住者。何故不名住实际者。何故修行普贤行愿犹未休息。何故不能究竟法界舍菩萨道。尔时普贤菩萨。告普眼菩萨言。善哉佛子。如汝所言。若此菩萨摩诃萨。同一切佛。以何义故。不名为佛。乃至不能舍菩萨道。佛子。此菩萨摩诃萨。已能修习去来今世。一切菩萨种种行愿。入智境界。则名为佛。于如来所。修菩萨行。无有休息。说名菩萨。如来诸力。皆悉已入。则名十力。虽成十力。行普贤行。而无休息。说名菩萨。知一切法。而能演说。名一切智。虽能演说一切诸法。于一一法。善巧思惟。未尝止息。说名菩萨。知一切法。无有二相。是则说名悟一切法。于二不二一切诸法差别之道。善巧观察。展转增胜。无有休息。说名菩萨。已能明见普眼境界。说名普眼。虽能证得普眼境界。念念增长。未曾休息。说名菩萨。于一切法悉能明照。离诸闇障。名无碍见。常勤忆念无碍见者。说名菩萨。已得诸佛智慧之眼。是则说名觉一切法。观诸如来正觉智眼。而不放逸。说名菩萨。住佛所住。与佛无二。说名与佛无二住者。为佛摄受。修诸智慧。说名菩萨。常观一切。世间实际。是则说名住实际者。虽常观察诸法实际。而不证入。亦不舍离。说名菩萨。不来不去。无同无异。此等分别。悉皆永息。是则说名休息愿者。广大修习。圆满不退。则名未息普贤愿者。了知法界。无有边际。一切诸法。一相无相。是则说名。究竟法界舍菩萨道。虽知法界。无有边际。而知一切种种异相。起大悲心。度诸众生。尽未来际。无有疲厌。是则说名普贤菩萨。佛子。譬如伊罗钵那象王。住金胁山七宝窟中。其窟周围。悉以七宝。而为栏楯。宝多罗树。次第行列。真金罗网。弥覆其上。象身洁白。犹如珂雪。上立金幢。金为璎珞。宝网覆鼻。宝铃垂下。七肢成就。六牙具足。端正充满。见者欣乐。调良善顺。心无所逆。若天帝释。将欲游行。尔时象王。即知其意。便于宝窟。而没其形。至忉利天。释主之前。以神通力。种种变现。令其身有三十三头。于一一头。化作七牙。于一一牙。化作七池。一一池中。有七莲华。一一华中。有七采女。一时俱奏百千天乐。是时帝释。乘兹宝象。从难胜殿。往诣华园。芬陀利华。遍满其中。是时帝释。至华园已。从象而下。入于一切宝庄严殿。无量采女。以为侍从。歌咏妓乐。受诸快乐。尔时象王。复以神通。隐其象形。现作天身。与三十三天。及诸采女。于芬陀利华园之内。欢娱戏乐。所现身相。光明衣服。往来进止。语笑观瞻。皆如彼天。等无有异。无能分别。此象此天。象之与天。更互相似。佛子。彼伊罗钵那象王。于金胁山七宝窟中。无所变化。至于三十三天之上。为欲供养释提桓因。化作种种诸可乐物。受天快乐。与天无异。佛子。菩萨摩诃萨。亦复如是。修习普贤菩萨行愿。及诸三昧。以为众宝庄严之具。七菩提分。为菩萨身。所放光明。以之为网。建大法幢。鸣大法钟。大悲为窟。坚固大愿。以为其牙。智慧无畏。犹如师子。法缯系顶。开示秘密。到诸菩萨行愿彼岸。为欲安处菩提之座成一切智。得最正觉。增长普贤广大行愿。不退不息。不断不舍。大悲精进。尽未来际。度脱一切。苦恼众生。不舍普贤道。现成最正觉。现不可说不可说成正觉门。现不可说不可说转法轮门。现不可说不可说住深心门。于不可说不可说广大国土。现涅槃变化门。于不可说不可说差别世界。而现受生。修普贤行。现不可说不可说如来。于不可说不可说广大国土。菩提树下。成最正觉。不可说不可说菩萨众。亲近围绕。或于一念顷。修普贤行。而成正觉。或须臾顷。或于一时。或于一日。或于半月。或于一月。或于一年。或无数年。或于一劫。如是乃至不可说不可说劫。修普贤行。而成正觉。复于一切诸佛刹中。而为上首。亲近于佛。顶礼供养。请问观察。如幻境界。净修菩萨无量诸行。无量诸智。种种神变。种种威德。种种智慧。种种境界。种种神通。种种自在。种种解脱。种种法明。种种教化。调伏之法。佛子。菩萨摩诃萨。本身不灭。以行愿力。于一切处。如是变现。何以故。欲以普贤自在神力。调伏一切诸众生故。令不可说不可说众生。得清净故。令其永断生死轮故。严净广大诸世界故。常见一切诸如来故。深入一切佛法流故。忆念三世诸佛种故。忆念十方一切佛法。及法身故。普修一切菩萨诸行。使圆满故。入普贤流。自在能证一切智故。佛子。汝应观此菩萨摩诃萨。不舍普贤行。不断菩萨道。见一切佛。证一切智。自在受用一切智法。如伊罗钵那象王。不舍象身。往三十三天。为天所乘。受天快乐。作天游戏。承事天主。与天采女。而作欢娱。同于诸天。无有差别。佛子。菩萨摩诃萨。亦复如是。不舍普贤大乘诸行。不退诸愿。得佛自在。具一切智。证佛解脱。无障无碍。成就清净。于诸国土。无所染着。于佛法中。无所分别。虽知诸法普皆平等。无有二相。而恒明见一切佛土。虽已等同三世诸佛。而修菩萨行。相续不断。佛子。菩萨摩诃萨。安住如是普贤行愿。广大之法。当知是人。心得清净。佛子。此是菩萨摩诃萨。第十无碍轮大三昧殊胜心广大智。佛子。此是菩萨摩诃萨。所住普贤行十大三昧轮

大方广佛华严经卷第四十三大方广佛华严经卷第四十四

        于阗国三藏实叉难陀奉　制译

    十通品第二十八

尔时普贤菩萨摩诃萨。告诸菩萨言。佛子。菩萨摩诃萨。有十种通。何者为十。佛子。菩萨摩诃萨。以他心智通。知一三千大千世界众生心差别。所谓善心不善心。广心狭心。大心小心。顺生死心。背生死心。声闻心。独觉心。菩萨心。声闻行心。独觉行心。菩萨行心。天心龙心。夜叉心乾闼婆心。阿修罗心迦楼罗心。紧那罗心摩睺罗伽心。人心非人心。地狱心畜生心。阎魔王处心。饿鬼心。诸难处众生心。如是等。无量差别。种种众生心。悉分别知。如一世界。如是百世界。千世界。百千世界。百千亿那由他世界。乃至不可说不可说佛刹微尘数世界中。所有众生心。悉分别知。是名菩萨摩诃萨。第一善知他心智神通

佛子。菩萨摩诃萨。以无碍清净天眼智通。见无量不可说不可说佛刹微尘数世界中众生。死此生彼。善趣恶趣。福相罪相。或好或丑。或垢或净。如是品类。无量众生。所谓天众龙众。夜叉众乾闼婆众。阿修罗众迦楼罗众。紧那罗众摩睺罗伽众。人众非人众。微细身众生众。广大身众生众。小众大众。如是种种众生众中。以无碍眼。悉皆明见。随所积集业。随所受苦乐。随心随分别。随见随言说。随因随业。随所缘。随所起。悉皆见之。无有错谬。是名菩萨摩诃萨。第二无碍天眼智神通佛子。菩萨摩诃萨。以宿住随念智通。能知自身及不可说不可说佛刹微尘数世界中一切众生。过去不可说不可说佛刹微尘数劫宿住之事。所谓某处生。如是名。如是姓。如是种族。如是饮食。如是苦乐。从无始来。于诸有中。以因以缘。展转滋长。次第相续。轮回不绝。种种品类。种种国土。种种趣生。种种形相。种种业行。种种结使。种种心念。种种因缘。受生差别。如是等事。皆悉了知。又忆过去尔所佛刹微尘数劫。尔所佛刹微尘数世界中。有尔所佛刹微尘数诸佛。一一佛。如是名号。如是出兴。如是众会。如是父母。如是侍者。如是声闻。如是最胜。二大弟子。于如是城邑。如是出家。复于如是菩提树下。成最正觉。于如是处。坐如是座。演说如是若干经典。如是利益尔所众生。于尔所时。住于寿命。施作如是若干佛事。依无余依般涅槃界。而般涅槃。般涅槃后。法住久近。如是一切悉能忆念。又忆念不可说不可说佛刹微尘数诸佛名号。一一名号。有不可说不可说佛刹微尘数佛。从初发心。起愿修行。供养诸佛。调伏众生。众会说法。寿命多少。神通变化。乃至入于无余涅槃。般涅槃后。法住久近。造立塔庙。种种庄严。令诸众生。种植善根。皆悉能知。是名菩萨摩诃萨。第三知过去际劫宿住智神通

佛子。菩萨摩诃萨。以知尽未来际劫智通。知不可说不可说佛刹微尘数世界中所有劫。一一劫中。所有众生。命终受生。诸有相续。业行果报。若善若不善。若出离若不出离。若决定若不决定。若邪定若正定。若善根与使俱。若善根不与使俱。若具足善根。若不具足善根。若摄取善根。若不摄取善根。若积集善根。若不积集善根。若积集罪法。若不积集罪法。如是一切。皆能了知。又知不可说不可说佛刹微尘数世界尽未来际。有不可说不可说佛刹微尘数劫。一一劫。有不可说不可说佛刹微尘数诸佛名号。一一名号。有不可说不可说佛刹微尘数诸佛如来。一一如来。从初发心。起愿立行。供养诸佛。教化众生。众会说法。寿命多少。神通变化。乃至入于无余涅槃。般涅槃后。法住久近。造立塔庙。种种庄严。令诸众生。种植善根。如是等事。悉能了知。是名菩萨摩诃萨。第四知尽未来际劫智神通

佛子。菩萨摩诃萨。成就无碍清净天耳。圆满广大聪彻离障。了达无碍。具足成就。于诸一切所有音声。欲闻不闻。随意自在。佛子。东方有不可说不可说佛刹微尘数佛。是诸佛所说所示。所开所演。所安立所教化。所调伏所忆念。所分别。甚深广大。种种差别。无量方便。无量善巧。清净之法。于彼一切皆能受持。又于其中。若义若文。若一人。若众会。如其音辞。如其智慧。如所了达。如所示现。如所调伏。如其境界。如其所依。如其出道。于彼一切悉能记持。不忘不失。不断不退。无迷无惑。为他演说。令得悟解。终不忘失。一文一句。如东方。南西北方。四维上下。亦复如是。是名菩萨摩诃萨。第五无碍清净。天耳智神通佛子。菩萨摩诃萨。住无体性神通。无作神通。平等神通。广大神通。无量神通。无依神通。随念神通。起神通。不起神通。不退神通。不断神通。不坏神通。增长神通。随诣神通。此菩萨。闻极远一切世界中诸佛名。所谓。无数世界。无量世界。乃至不可说不可说佛刹微尘数世界中诸佛名。闻其名已。即自见身。在彼佛所。彼诸世界。或仰或覆。各各形状。各各方所。各各差别。无边无碍。种种国土。种种时劫。无量功德。各别庄严。彼彼如来。于中出现。示现神变。称扬名号。无量无数。各各不同。此菩萨。一得闻彼诸如来名。不动本处。而见其身。在彼佛所。礼拜尊重。承事供养。问菩萨法。入佛智慧。悉能了达诸佛国土。道场众会。及所说法。至于究竟无所取着。如是。经不可说不可说佛刹微尘数劫。普至十方。而无所往。然诣佛刹。观佛听法请道。无有断绝。无有废舍。无有休息。无有疲厌。修菩萨行。成就大愿。悉令具足。曾无退转。为令如来广大种性。不断绝故。是名菩萨摩诃萨。第六住无体性无动作往一切佛刹智神通

佛子。菩萨摩诃萨。以善分别一切众生言音智通。知不可说不可说佛刹微尘数世界中众生。种种言辞。所谓圣言辞非圣言辞。天言辞龙言辞。夜叉言辞。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。乃至不可说不可说众生。所有言辞。各各表示。种种差别。如是一切。皆能了知。此菩萨。随所入世界。能知其中一切众生。所有性欲。如其性欲。为出言辞。悉令解了。无有疑惑。如日光出现。普照众色。令有目者。悉得明见。菩萨摩诃萨。亦复如是。以善分别一切言辞智。深入一切言辞云。所有言辞。令诸世间聪慧之者。悉得解了。是名菩萨摩诃萨。第七善分别一切言辞智神通

佛子。菩萨摩诃萨。以出生无量阿僧祇色身庄严智通。知一切法。远离色相。无差别相。无种种相。无无量相。无分别相。无青黄赤白相。菩萨如是。入于法界。能现其身。作种种色。所谓无边色无量色。清净色庄严色。普遍色无比色。普照色增上色。无违逆色。具诸相色。离众恶色。大威力色。可尊重色。无穷尽色。众杂妙色。极端严色。不可量色。善守护色。能成熟色。随化者色。无障碍色。甚明彻色。无垢浊色。极澄净色。大勇健色。不思议方便色。不可坏色。离瑕翳色。无障闇色。善安住色。妙庄严色。诸相端严色。种种随好色。大尊贵色。妙境界色。善磨莹色。清净深心色。炽然明盛色。最胜广大色。无间断色。无所依色。无等比色。充满不可说佛刹色。增长色。坚固摄受色。最胜功德色。随诸心乐色。清净解了色。积集众妙色。善巧决定色。无有障碍色。虚空明净色。清净可乐色。离诸尘垢色。不可称量色。妙见色。普见色。随时示现色。寂静色。离贪色。真实福田色。能作安隐色。离诸怖畏色。离愚痴行色。智慧勇猛色。身相无碍色。游行普遍色。心无所依色。大慈所起色。大悲所现色。平等出离色。具足福德色。随心忆念色。无边妙宝色。宝藏光明色。众生信乐色。一切智现前色。欢喜眼色。众宝庄严第一色。无有处所色。自在示现色。种种神通色。生如来家色。过诸譬谕色。周遍法界色。众皆往诣色。种种色。成就色。出离色。随所化者威仪色。见无厌足色。种种明净色。能放无数光网色。不可说光明种种差别色。不可思香光明超过三界色。不可量日轮光明照耀色。示现无比月身色。无量可爱乐华云色。出生种种莲华鬘云庄严色。超过一切世间香焰普熏色。出生一切如来藏色。不可说音声开示演畅一切法色。具足一切普贤行色。佛子。菩萨摩诃萨。深入如是无色法界。能现此等种种色身。令所化者见。令所化者念。为所化者转法轮。随所化者时。随所化者相。令所化者亲近。令所化者开悟。为所化者。起种种神通。为所化者。现种种自在。为所化者。施种种能事。是名菩萨摩诃萨。为度一切众生故勤修成就第八无数色身智神通。佛子。菩萨摩诃萨。以一切法智通。知一切法。无有名字。无有种性。无来无去。非异非不异。非种种非不种种。非二非不二。无我无比。不生不灭。不动不坏。无实无虚。一相无相。非无非有。非法非非法。不随于俗。非不随俗。非业非非业。非报非非报。非有为非无为。非第一义。非不第一义。非道非非道。非出离非不出离。非量非无量。非世间非出世间。非从因生。非不从因生。非决定非不决定。非成就非不成就。非出非不出。非分别非不分别。非如理非不如理。此菩萨。不取世俗谛。不住第一义。不分别诸法。不建立文字。随顺寂灭性。不舍一切愿。见义知法。兴布法云。降霔法雨。虽知实相。不可言说。而以方便无尽辩才。随法随义。次第开演。以于诸法言辞辩说。皆得善巧。大慈大悲。悉已清净。能于一切离文字法中。出生文字。与法与义。随顺无违。为说诸法。悉从缘起。虽有言说。而无所著。演一切法。辩才无尽。分别安立。开发示导。令诸法性。具足明显。断众疑网。悉得清净。虽摄众生。不舍真实。于不二法。而无退转。常能演说无碍法门。以众妙音。随众生心。普雨法雨。而不失时。是名菩萨摩诃萨。第九一切法智神通

佛子。菩萨摩诃萨。以一切法灭尽三昧智通。于念念中。入一切法灭尽三昧。亦不退菩萨道。不舍菩萨事。不舍大慈大悲心。修习波罗蜜。未尝休息。观察一切佛国土。无有厌倦。不舍度众生愿。不断转法轮事。不废教化众生业。不舍供养诸佛行。不舍一切法自在门。不舍常见一切佛。不舍常闻一切法。知一切法平等无碍。自在成就一切佛法。所有胜愿皆得圆满。了知一切国土差别。入佛种性。到于彼岸。能于彼彼。诸世界中。学一切法。了法无相。知一切法。皆从缘起。无有体性。然随世俗。方便演说。虽于诸法。心无所住。然顺众生诸根欲乐。方便为说种种诸法。此菩萨。住三昧时。随其心乐。或住一劫。或住百劫。或住千劫。或住亿劫。或住百亿劫。或住千亿劫。或住百千亿劫。或住那由他亿劫。或住百那由他亿劫。或住千那由他亿劫。或住百千那由他亿劫。或住无数劫。或住无量劫。乃至或住不可说不可说劫。菩萨入此一切法灭尽三昧。虽复经于尔所劫住。而身不离散。不羸瘦。不变异。非见非不见。不灭不坏。不疲不懈。不可尽竭。虽于有于无。悉无所作。而能成辨诸菩萨事。所谓恒不舍离一切众生。教化调伏。未曾失时。令其增长一切佛法。于菩萨行。悉得圆满。为欲利益一切众生。神通变化。无有休息。譬如光影。普现一切。而于三昧。寂然不动。是为菩萨摩诃萨。入一切法灭尽三昧智神通。佛子。菩萨摩诃萨。住于如是十种神通。一切天人。不能思议。一切众生。不能思议。一切声闻。一切独觉。及余一切诸菩萨众。如是皆悉不能思议。此菩萨。身业不可思议。语业不可思议。意业不可思议。三昧自在不可思议。智慧境界不可思议。唯除诸佛。及有得此神通菩萨。余无能说此人功德称扬赞叹。佛子。是为菩萨摩诃萨十种神通。若菩萨摩诃萨。住此神通。悉得一切三世无碍智神通

    大方广佛华严经十忍品第二十九

尔时普贤菩萨。告诸菩萨言。佛子。菩萨摩诃萨。有十种忍。若得此忍。则得到于一切菩萨无碍忍地。一切佛法。无碍无尽。何者为十。所谓音声忍。顺忍。无生法忍。如幻忍。如焰忍。如梦忍。如响忍。如影忍。如化忍。如空忍。此十种忍。三世诸佛。已说。今说。当说

佛子。云何为菩萨摩诃萨音声忍。谓闻诸佛所说之法。不惊不怖不畏。深信悟解。爱乐趣向。专心忆念。修习安住。是名菩萨摩诃萨第一音声忍

佛子。云何为菩萨摩诃萨顺忍。谓于诸法。思惟观察。平等无违。随顺了知。令心清净。正住修习。趣入成就。是名菩萨摩诃萨第二顺忍。佛子。云何为菩萨摩诃萨。无生法忍。佛子。此菩萨摩诃萨。不见有少法生。亦不见有少法灭。何以故。若无生则无灭。若无灭则无尽。若无尽则离垢。若离垢则无差别。若无差别则无处所。若无处所则寂静。若寂静则离欲。若离欲则无作。若无作则无愿。若无愿则无住。若无住则无去无来。是名菩萨摩诃萨第三无生法忍

佛子。云何为菩萨摩诃萨如幻忍。佛子。此菩萨摩诃萨。知一切法皆悉如幻。从因缘起。于一法中解多法。于多法中解一法。此菩萨。知诸法如幻已。了达国土。了达众生。了达法界。了达世间平等。了达佛出现平等。了达三世平等。成就种种神通变化。譬如幻。非象非马。非车非步。非男非女。非童男非童女。非树非叶。非华非果。非地非水。非火非风。非昼非夜。非日非月。非半月非一月。非一年非百年。非一劫非多劫。非定非乱。非纯非杂。非一非异。非广非狭。非多非少。非量非无量。非粗非细。非是一切种种众物。种种非幻。幻非种种。然由幻故。示现种种差别之事。菩萨摩诃萨。亦复如是。观一切世间如幻。所谓业世间。烦恼世间。国土世间。法世间。时世间。趣世间。成世间。坏世间。运动世间。造作世间。菩萨摩诃萨。观一切世间如幻时。不见众生生。不见众生灭。不见国土生。不见国土灭。不见诸法生。不见诸法灭。不见过去可分别。不见未来有起作。不见现在一念住。不观察菩提。不分别菩提。不见佛出现。不见佛涅槃。不见住大愿。不见入正住。不出平等性。是菩萨。虽成就佛国土。知国土无差别。虽成就众生界。知众生无差别。虽普观法界。而安住法性寂然不动。虽达三世平等。而不违分别三世法。虽成就蕴处。而永断所依。虽度脱众生。而了知法界平等。无种种差别。虽知一切法远离文字。不可言说。而常说法。辩才无尽。虽不取着化众生事。而不舍大悲。为度一切转于法轮。虽为开示过去因缘。而知因缘性。无有动转。是名菩萨摩诃萨第四如幻忍

佛子。云何为菩萨摩诃萨如焰忍。佛子。此菩萨摩诃萨。知一切世间。同于阳焰。譬如阳焰。无有方所。非内非外。非有非无。非断非常。非一色非种种色。亦非无色。但随世间言说显示。菩萨如是。如实观察。了知诸法。现证一切。令得圆满。是名菩萨摩诃萨第五如焰忍佛子。云何为菩萨摩诃萨如梦忍。佛子。此菩萨摩诃萨。知一切世间如梦。譬如梦。非世间非离世间。非欲界非色界。非无色界。非生非没。非染非净。而有示现。菩萨摩诃萨。亦复如是。知一切世间。悉同于梦。无有变异故。如梦自性故。如梦执着故。如梦性离故。如梦本性故。如梦所现故。如梦无差别故。如梦想分别故。如梦觉时故。是名菩萨摩诃萨第六如梦忍

佛子。云何为菩萨摩诃萨。如响忍。佛子。此菩萨摩诃萨。闻佛说法。观诸法性。修学成就。到于彼岸。知一切音声。悉同于响。无来无去。如是示现。佛子。此菩萨摩诃萨。观如来声。不从内出。不从外出。亦不从于内外而出。虽了此声非内非外。非内外出。而能示现善巧名句。成就演说。譬如谷响。从缘所起。而与法性。无有相违。令诸众生。随类各解。而得修学。如帝释夫人阿修罗女。名曰舍支。于一音中。出千种音。亦不心念。令如是出。菩萨摩诃萨。亦复如是。入无分别界。成就善巧随类之音。于无边世界中。恒转法轮。此菩萨。善能观察一切众生。以广长舌相。而为演说。其声无碍。遍十方土令随所宜闻。法各异。虽知声无起。而普现音声。虽知无所说。而广说诸法。妙音平等。随类各解。悉以智慧。而能了达。是各菩萨摩诃萨第七如响忍

佛子。云何为菩萨摩诃萨如影忍。佛子。此菩萨摩诃萨。非于世间生。非于世间没。非在世间内。非在世间外。非行于世间。非不行世间。非同于世间。非异于世间。非往于世间。非不往世间。非住于世间。非不住世间。非是世间。非出世间。非修菩萨行。非舍于大愿。非实非不实。虽常行一切佛法。而能辨一切世间事。不随世间流。亦不住法流。譬如日月。男子女人。舍宅山林。河泉等物。于油于水。于身于宝。于明镜等。清净物中。而现其影。影与油等。非一非异。非离非合。于川流中。亦不漂度。于池井内。亦不沉没。虽现其中。无所染着。然诸众生。知于此处。有是影现。亦知彼处。无如是影。远物近物。虽皆影现。影不随物。而有近远。菩萨摩诃萨。亦复如是。能知自身。及以他身。一切皆是智之境界。不作二解。谓自他别。而于自国土。于他国土。各各差别。一时普现。如种子中。无有根芽。茎节枝叶。而能生起。如是等事。菩萨摩诃萨。亦复如是。于无二法中。分别二相。善巧方便。通达无碍。是名菩萨摩诃萨第八如影忍。菩萨摩诃萨。成就此忍。虽不往诣十方国土。而能普现一切佛刹。亦不离此。亦不到彼。如影普现。所行无碍。令诸众生。见差别身。同于世间坚实之相。然此差别。即非差别。别与不别。无所障碍。此菩萨。从于如来种性而生。身语及意。清净无碍。故能获得无边色相清净之身佛子。云何为菩萨摩诃萨如化忍。佛子。此菩萨摩诃萨。知一切世间。皆悉如化。所谓一切众生意业化。觉想所起故。一切世间诸行化。分别所起故。一切苦乐颠倒化。妄取所起故。一切世间不实法化。言说所现故。一切烦恼分别化。想念所起故。复有清净调伏化。无分别所现故。于三世不转化。无生平等故。菩萨愿力化。广大修行故。如来大悲化。方便示现故。转法轮方便化。智慧无畏。辩才所说故。菩萨如是。了知世间出世间化。现证知。广大知。无边知。如事知。自在知。真实知。非虚妄见所能倾动。随世所行。亦不失坏。譬如化不从心起。不从心法起。不从业起。不受果报。非世间生。非世间灭。不可随逐。不可揽触。非久住。非须臾住。非行世间。非离世间。不专系一方。不普属诸方。非有量。非无量。不厌不息。非不厌息。非凡非圣。非染非净。非生非死。非智非愚。非见。非不见。非依世间。非入法界。非黠慧。非迟钝。非取非不取。非生死。非涅槃。非有非无有。菩萨如是。善巧方便。行于世间。修菩萨道。了知世法。分身化往。不着世间。不取自身。于世于身。无所分别。不住世间。不离世间。不住于法。不离于法。以本愿故。不弃舍一众生界。不调伏少众生界。不分别法。非不分别。知诸法性无来无去。虽无所有。而满足佛法。了法如化。非有非无。佛子。菩萨摩诃萨。如是安住如化忍时。悉能满足一切诸佛菩提之道。利益众生。是名菩萨摩诃萨第九如化忍。菩萨摩诃萨。成就此忍。凡有所作。悉同于化。譬如化士。于一切佛刹。无所依住。于一切世间。无所取着。于一切佛法。不生分别。而趣佛菩提。无有懈倦。修菩萨行。离诸颠倒。虽无有身。而现一切身。虽无所住。而住众国土。虽无有色。而普现众色。虽不着实际。而明照法性。平等圆满。佛子。此菩萨摩诃萨。于一切法。无所依止。名解脱者。一切过失。悉皆舍离。名调伏者。不动不转。普入一切如来众会。名神通者。于无生法。已得善巧。名无退者。具一切力。须弥铁围。不能为障。名无碍者

佛子。云何为菩萨摩诃萨如空忍。佛子。此菩萨摩诃萨。了一切法界犹如虚空。以无相故。一切世界犹如虚空。以无起故。一切法犹如虚空。以无二故。一切众生行犹如虚空。无所行故。一切佛犹如虚空。无分别故。一切佛力犹如虚空。无差别故。一切禅定犹如虚空。三际平等故。所说一切法犹如虚空。不可言说故。一切佛身犹如虚空。无著无碍故。菩萨如是。以如虚空方便。了一切法皆无所有。佛子。菩萨摩诃萨。以如虚空忍智。了一切法时。得如虚空身。身业。得如虚空语。语业。得如虚空意。意业。譬如虚空一切法依。不生不殁。菩萨摩诃萨。亦复如是。一切法身。不生不殁。譬如虚空。不可破坏。菩萨摩诃萨。亦复如是。智慧诸力。不可破坏。譬如虚空一切世间之所依止。而无所依。菩萨摩诃萨。亦复如是。一切诸法之所依止。而无所依。譬如虚空。无生无灭。能持一切世间生灭。菩萨摩诃萨。亦复如是。无向无得。能示向得。普使世间。修行清净。譬如虚空。无方无隅。而能显现无边方隅。菩萨摩诃萨。亦复如是。无业无报。而能显示种种业报。譬如虚空。非行非住。而能示现种种威仪。菩萨摩诃萨。亦复如是。非行非住。而能分别一切诸行。譬如虚空。非色非非色。而能示现种种诸色。菩萨摩诃萨。亦复如是。非世间色。非出世间色。而能示现一切诸色。譬如虚空。非久非近。而能久住。现一切物。菩萨摩诃萨。亦复如是。非久非近。而能久住。显示菩萨所行诸行。譬如虚空非净非秽。不离净秽。菩萨摩诃萨。亦复如是。非障非无障。不离障无障。譬如虚空一切世间。皆现其前。非现一切世间之前。菩萨摩诃萨。亦复如是。一切诸法。皆现其前。非现一切诸法之前。譬如虚空普入一切。而无边际。菩萨摩诃萨。亦复如是。普入诸法。而菩萨心。无有边际。何以故。菩萨所作。如虚空故。谓所有修习。所有严净。所有成就。皆悉平等。一体一味一种。分量如虚空。清净遍一切处。如是证知一切诸法。于一切法。无有分别。严净一切诸佛国土。圆满一切无所依身。了一切方。无有迷惑。具一切力。不可摧坏。满足一切无边功德。已到一切甚深法处。通达一切波罗蜜道。普坐一切金刚之座。普发一切随类之音。为一切世间。转于法轮。未曾失时。是名菩萨摩诃萨第十如空忍。菩萨摩诃萨。成就此忍。得无来身。以无去故。得无生身。以无灭故。得无动身。以无坏故。得不实身。离虚妄故。得一相身。以无相故。得无量身。佛力无量故。得平等身。同如相故。得无差别身。等观三世故。得至一切处身。净眼等照。无障碍故。得离欲际身。知一切法无合散故。得虚空无边际身。福德藏无尽。如虚空故。得无断无尽法性平等辩才身。知一切法相。唯是一相。无性为性。如虚空故。得无量无碍音声身。无所障碍。如虚空故。得具足一切善巧清净菩萨行身。于一切处。皆无障碍。如虚空故。得一切佛法海次第相续身。不可断绝。如虚空故。得一切佛刹中现无量佛刹身。离诸贪着。如虚空无边故。得示现一切自在法无休息身。如虚空大海。无边际故。得一切不可坏坚固势力身。如虚空任持一切世间故。得诸根明利如金刚坚固不可坏身。如虚空一切劫火。不能烧故。得持一切世间力身。智慧力如虚空故。佛子。是名菩萨摩诃萨十种忍。尔时。普贤菩萨摩诃萨。欲重宣其义。而说颂言

  譬如世有人　　闻有宝藏处
  以其可得故　　心生大欢喜
  如是大智慧　　菩萨真佛子
  听闻诸佛法　　甚深寂灭相
  闻此深法时　　其心得安隐
  不惊亦不怖　　亦不生恐畏
  大士求菩提　　闻斯广大音
  心净能堪忍　　于此无疑惑
  自念以闻此　　甚深微妙法
  当成一切智　　人天大导师
  菩萨闻此音　　其心大欢喜
  发生坚固意　　愿求诸佛法
  以乐菩提故　　其心渐调伏
  令信益增长　　于法无违谤
  是故闻此音　　其心得堪忍
  安住而不动　　修行菩萨行
  为求菩提故　　专行向彼道
  精进无退转　　不舍众善轭
  以求菩提故　　其心无恐畏
  闻法增勇猛　　供佛令欢喜
  如有大福人　　获得真金藏
  随身所应服　　造作庄严具
  菩萨亦如是　　闻此甚深义
  思惟增智海　　以修随顺法
  法有亦顺知　　法无亦顺知
  随彼法如是　　如是知诸法
  成就清净心　　明彻大欢喜
  知法从缘起　　勇猛勤修习
  平等观诸法　　了知其自性
  不违佛法藏　　普觉一切法
  志乐常坚固　　严净佛菩提
  不动如须弥　　一心求正觉
  以发精进意　　复修三昧道
  无量劫勤行　　未曾有退失
  菩萨所入法　　是佛所行处
  于此能了知　　其心无厌怠
  如无等所说　　平等观诸法
  非不平等忍　　能成平等智
  随顺佛所说　　成就此忍门
  如法而了知　　亦不分别法
  三十三天中　　所有诸天子
  共同一器食　　所食各不同
  所食种种食　　不从十方来
  如其所修业　　自然咸在器
  菩萨亦如是　　观察一切法
  悉从因缘起　　无生故无灭
  无灭故无尽　　无尽故无染
  于世变异法　　了知无变异
  无异则无处　　无处则寂灭
  其心无染着　　愿度诸群生
  专念于佛法　　未尝有散动
  而以悲愿心　　方便行于世
  勤求于十力　　处世而不住
  无去亦无来　　方便善说法
  此忍最为上　　了法无有尽
  入于真法界　　实亦无所入
  菩萨住此忍　　普见诸如来
  同时与授记　　斯名受佛职
  了达三世法　　寂灭清净相
  而能化众生　　置于善道中
  世间种种法　　一切皆如幻
  若能如是知　　其心无所动
  诸业从心生　　故说心如幻
  若离此分别　　普灭诸有趣
  譬如工幻师　　普现诸色像
  徒令众贪乐　　毕竟无所得
  世间亦如是　　一切皆如幻
  无性亦无生　　示现有种种
  度脱诸众生　　令知法如幻
  众生不异幻　　了幻无众生
  众生及国土　　三世所有法
  如是悉无余　　一切皆如幻
  幻作男女形　　及象马牛羊
  屋宅池泉类　　园林华果等
  幻物无知觉　　亦无有住处
  毕竟寂灭相　　但随分别现
  菩萨能如是　　普见诸世间
  有无一切法　　了达悉如幻
  众生及国土　　种种业所造
  入于如幻际　　于彼无依着
  如是得善巧　　寂灭无戏论
  住于无碍地　　普现大威力
  勇猛诸佛子　　随顺入妙法
  善观一切想　　缠网于世间
  众想如阳焰　　令众生倒解
  菩萨善知想　　舍离一切倒
  众生各别异　　形类非一种
  了达皆是想　　一切无真实
  十方诸众生　　皆为想所覆
  若舍颠倒见　　则灭世间想
  世间如阳焰　　以想有差别
  知世住于想　　远离三颠倒
  譬如热时焰　　世见谓为水
  水实无所有　　智者不应求
  众生亦复然　　世趣皆无有
  如焰住于想　　无碍心境界
  若离于诸想　　亦离诸戏论
  愚痴着想者　　悉令得解脱
  远离憍慢心　　除灭世间想
  住尽无尽处　　是菩萨方便
  菩萨了世法　　一切皆如梦
  非处非无处　　体性恒寂灭
  诸法无分别　　如梦不异心
  三世诸世间　　一切悉如是
  梦体无生灭　　亦无有方所
  三界悉如是　　见者心解脱
  梦不在世间　　不在非世间
  此二不分别　　得入于忍地
  譬如梦中见　　种种诸异相
  世间亦如是　　与梦无差别
  住于梦定者　　了世皆如梦
  非同非是异　　非一非种种
  众生诸刹业　　杂染及清净
  如是悉了知　　与梦皆平等
  菩萨所行行　　及以诸大愿
  明了皆如梦　　与世亦无别
  了世皆空寂　　不坏于世法
  譬如梦所见　　长短等诸色
  是名如梦忍　　因此了世法
  疾成无碍智　　广度诸群生
  修行如是行　　出生广大解
  巧知诸法性　　于法心无著
  一切诸世间　　种种诸音声
  非内亦非外　　了之悉如响
  如闻种种响　　心不生分别
  菩萨闻音声　　其心亦如是
  瞻仰诸如来　　及听说法音
  演契经无量　　虽闻无所著
  如响无来处　　所闻声亦然
  而能分别法　　与法无乖谬
  善了诸音声　　于声不分别
  知声悉空寂　　普出清净音
  了法不在言　　善入无言际
  而能示言说　　如响遍世间
  了知言语道　　具足音声分
  知声性空寂　　以世言音说
  如世所有音　　示同分别法
  其音悉周遍　　开悟诸群生
  菩萨获此忍　　净音化世间
  善巧说三世　　于世无所著
  为欲利世间　　专意求菩提
  而常入法性　　于彼无分别
  普观诸世间　　寂灭无体性
  而恒为饶益　　修行意不动
  不住于世间　　不离于世间
  于世无所依　　依处不可得
  了知世间性　　于性无染着
  虽不依世间　　化世令超度
  世间所有法　　悉知其自性
  了法无有二　　无二亦无著
  心不离世间　　亦不住世间
  非于世间外　　修行一切智
  譬如水中影　　非内亦非外
  菩萨求菩提　　了世非世间
  不于世住出　　以世不可说
  亦不在内外　　如影现世间
  入此甚深义　　离垢悉明彻
  不舍本誓心　　普照智慧灯
  世间无边际　　智入悉齐等
  普化诸群生　　令其舍众着
  观察甚深法　　利益群生众
  从此入于智　　修行一切道
  菩萨观诸法　　谛了悉如化
  而行如化行　　毕竟永不舍
  随顺化自性　　修习菩提道
  一切法如化　　菩萨行亦然
  一切诸世间　　及以无量业
  平等悉如化　　毕竟住寂灭
  三世所有佛　　一切亦如化
  本愿修诸行　　变化成如来
  佛以大慈悲　　度脱化众生
  度脱亦如化　　化力为说法
  知世皆如化　　不分别世间
  化事种种殊　　皆由业差别
  修习菩提行　　庄严于化藏
  无量善庄严　　如业作世间
  化法离分别　　亦不分别法
  此二俱寂灭　　菩萨行如是
  化海了于智　　化性印世间
  化非生灭法　　智慧亦如是
  第十忍明观　　众生及诸法
  体性皆寂灭　　如空无处所
  获此如空智　　永离诸取着
  如空无种种　　于世无所碍
  成就空忍力　　如空无有尽
  境界如虚空　　不作空分别
  虚空无体性　　亦复非断灭
  亦无种种别　　智力亦如是
  虚空无初际　　亦复无中后
  其量不可得　　菩萨智亦然
  如是观法性　　一切如虚空
  无生亦无灭　　菩萨之所得
  自住如空法　　复为众生说
  降伏一切魔　　皆斯忍方便
  世间相差别　　皆空无有相
  入于无相处　　诸相悉平等
  唯以一方便　　普入众世间
  谓知三世法　　悉等虚空性
  智慧与音声　　及以菩萨身
  其性如虚空　　一切皆寂灭
  如是十种忍　　佛子所修行
  其心善安住　　广为众生说
  于此善修学　　成就广大力
  法力及智力　　为菩提方便
  通达此忍门　　成就无碍智
  超过一切众　　转于无上轮
  所修广大行　　其量不可得
  调御师智海　　乃能分别知
  舍我而修行　　入于深法性
  心常住净法　　以是施群生
  众生及刹尘　　尚可知其数
  菩萨诸功德　　无能度其限
  菩萨能成就　　如是十种忍
  智慧及所行　　众生莫能测

大方广佛华严经卷第四十四大方广佛华严经卷第四十五

        于阗国三藏实叉难陀奉　制译

    阿僧祇品第三十

尔时心王菩萨。白佛言。世尊。诸佛如来。演说阿僧祇无量无边无等不可数不可称不可思不可量不可说不可说不可说。世尊云何。阿僧祇乃至不可说不可说耶。佛告心王菩萨言。善哉善哉。善男子。汝今为欲令诸世间。入佛所知数量之义。而问如来应正等觉。善男子。谛听谛听。善思念之。当为汝说。时心王菩萨。唯然受教。佛言。善男子。一百洛叉。为一俱胝。俱胝俱胝。为一阿庾多。阿庾多阿庾多。为一那由他。那由他那由他。为一频波罗。频波罗频波罗。为一矜羯罗。矜羯罗矜羯罗。为一阿伽罗。阿伽罗阿伽罗。为一最胜。最胜最胜。为一摩婆(上声呼)罗。摩婆罗摩婆罗。为一阿婆(上)罗。阿婆罗阿婆罗。为一多婆(上)罗。多婆罗多婆罗。为一界分。界分界分。为一普摩。普摩普摩。为一祢摩。祢摩祢摩。为一阿婆(上)钤。阿婆钤阿婆钤。为一弥伽(上)婆。弥伽婆弥伽婆。为一毗攞伽。毗攞伽毗攞伽。为一毗伽(上)婆。毗伽婆毗伽婆。为一僧羯逻摩。僧羯逻摩僧羯逻摩。为一毗萨罗。毗萨罗毗萨罗。为一毗赡婆。毗赡婆毗赡婆。为一毗盛(上)伽。毗盛伽毗盛伽。为一毗素陀。毗素陀毗素陀。为一毗婆诃。毗婆诃毗婆诃。为一毗薄底。毗薄底毗薄底。为一毗佉担。毗佉担毗佉担。为一称量。称量称量。为一一持。一持一持。为一异路。异路异路。为一颠倒。颠倒颠倒。为一三末耶。三末耶三末耶。为一毗睹罗。毗睹罗毗睹罗。为一奚婆(上)罗。奚婆罗奚婆罗。为一伺察。伺察伺察。为一周广。周广周广。为一高出。高出高出。为一最妙。最妙最妙。为一泥罗婆。泥罗婆泥罗婆。为一诃理婆。诃理婆诃理婆。为一一动。一动一动。为一诃理蒲。诃理蒲诃理蒲。为一诃理三。诃理三诃理三。为一奚鲁伽。奚鲁伽奚鲁伽。为一达攞步陀。达攞步陀达攞步陀。为一诃鲁那。诃鲁那诃鲁那。为一摩鲁陀。摩鲁陀摩鲁陀。为一忏慕陀。忏慕陀忏慕陀。为一瑿攞陀。瑿攞陀瑿攞陀。为一摩鲁摩。摩鲁摩摩鲁摩。为一调伏。调伏调伏。为一离憍慢。离憍慢离憍慢。为一不动。不动不动。为一极量。极量极量为一阿么怛罗。阿么怛罗阿么怛罗。为一勃么怛罗。勃么怛罗勃么怛罗。为一伽么怛罗。伽么怛罗伽么怛罗。为一那么怛罗。那么怛罗那么怛罗。为一奚么怛罗。奚么怛罗奚么怛罗。为一鞞么怛罗。鞞么怛罗鞞么怛罗。为一钵罗么怛罗。钵罗么怛罗钵罗么怛罗。为一尸婆么怛罗。尸婆么怛罗尸婆么怛罗。为一翳罗。翳罗翳罗。为一薜罗。薜罗薜罗。为一谛罗。谛罗谛罗。为一偈罗。偈罗偈罗。为一窣步罗。窣步罗窣步罗为一泥罗。泥罗泥罗为一计罗。计罗计罗。为一细罗。细罗细罗。为一睥罗。睥罗睥罗。为一谜罗。谜罗谜罗。为一娑攞荼。娑攞荼娑攞荼。为一谜鲁陀。谜鲁陀谜鲁陀。为一契鲁陀。契鲁陀契鲁陀。为一摩睹罗。摩睹罗摩睹罗。为一娑母罗。娑母罗娑母罗。为一阿野娑。阿野娑阿野娑。为一迦么罗。迦么罗迦么罗。为一摩伽婆。摩伽婆摩伽婆。为一阿怛罗。阿怛罗阿怛罗。为一醯鲁耶。醯鲁耶醯鲁耶。为一薜鲁婆。薜鲁婆薜鲁婆。为一羯罗波。羯罗波羯罗波。为一诃婆婆。诃婆婆诃婆婆。为一毗婆(上)罗。毗婆罗毗婆罗。为一那婆(上)罗。那婆罗那婆罗。为一摩攞罗。摩攞罗摩攞罗。为一娑婆(上)罗。娑婆罗娑婆罗。为一迷攞普。迷攞普迷攞普。为一者么罗。者么罗者么罗。为一驮么罗。驮么罗驮么罗。为一钵攞么陀。钵攞么陀钵攞么陀。为一毗迦摩。毗迦摩毗迦摩。为一乌波跋多。乌波跋多乌波跋多。为一演说。演说演说。为一无尽。无尽无尽。为一出生。出生出生。为一无我。无我无我。为一阿畔多。阿畔多阿畔多。为一青莲华。青莲华青莲华。为一钵头摩。钵头摩钵头摩。为一僧祇。僧祇僧祇。为一趣。趣趣。为一至。至至。为一阿僧祇。阿僧祇阿僧祇。为一阿僧祇转。阿僧祇转阿僧祇转。为一无量。无量无量。为一无量转。无量转无量转。为一无边。无边无边。为一无边转。无边转无边转。为一无等。无等无等。为一无等转。无等转无等转。为一不可数。不可数不可数。为一不可数转。不可数转不可数转。为一不可称。不可称不可称。为一不可称转。不可称转不可称转。为一不可思。不可思不可思。为一不可思转。不可思转不可思转。为一不可量。不可量不可量。为一不可量转。不可量转不可量转。为一不可说。不可说不可说。为一不可说转。不可说转不可说转。为一不可说不可说。此又不可说不可说。为一不可说不可说转。尔时世尊。为心王菩萨。而说颂曰

  不可言说不可说　　充满一切不可说
  不可言说诸劫中　　说不可说不可尽
  不可言说诸佛刹　　皆悉碎末为微尘
  一尘中刹不可说　　如一一切皆如是
  此不可说诸佛刹　　一念碎尘不可说
  念念所碎悉亦然　　尽不可说劫恒尔
  此尘有刹不可说　　此刹为尘说更难
  以不可说算数法　　不可说劫如是数
  以此诸尘数诸劫　　一尘十万不可说
  尔劫称赞一普贤　　无能尽其功德量
  于一微细毛端处　　有不可说诸普贤
  一切毛端悉亦尔　　如是乃至遍法界
  一毛端处所有刹　　其数无量不可说
  尽虚空量诸毛端　　一一处刹悉如是
  彼毛端处诸国土　　无量种类差别住
  有不可说异类刹　　有不可说同类刹
  不可言说毛端处　　皆有净刹不可说
  种种庄严不可说　　种种奇妙不可说
  于彼一一毛端处　　演不可说诸佛名
  一一名有诸如来　　皆不可说不可说
  一一诸佛于身上　　现不可说诸毛孔
  于彼一一毛孔中　　现众色相不可说
  不可言说诸毛孔　　咸放光明不可说
  于彼一一光明中　　悉现莲华不可说
  于彼一一莲华内　　悉有众叶不可说
  不可说华众叶中　　各现色相不可说
  彼不可说诸色内　　复现众叶不可说
  叶中光明不可说　　光中色相不可说
  此不可说色相中　　一一现光不可说
  光中现月不可说　　月复现月不可说
  于不可说诸月中　　一一现光不可说
  于彼一一光明内　　复现于日不可说
  于不可说诸日中　　一一现色不可说
  于彼一一诸色内　　又现光明不可说
  于彼一一光明内　　现不可说师子座
  一一严具不可说　　一一光明不可说
  光中妙色不可说　　色中净光不可说
  于彼一一净光内　　复现种种妙光明
  此光复现种种光　　不可言说不可说
  如是种种光明内　　各现妙宝如须弥
  一一光中所现宝　　不可言说不可说
  彼如须弥一妙宝　　现众刹土不可说
  尽须弥宝无有余　　示现刹土皆如是
  以一刹土末为尘　　一尘色相不可说
  众刹为尘尘有相　　不可言说不可说
  如是种种诸尘相　　皆出光明不可说
  光中现佛不可说　　佛所说法不可说
  法中妙偈不可说　　闻偈得解不可说
  不可说解念念中　　显了真谛不可说
  示现未来一切佛　　常演说法无穷尽
  一一佛法不可说　　种种清净不可说
  出妙音声不可说　　转正法轮不可说
  于彼一一法轮中　　演修多罗不可说
  于彼一一修多罗　　分别法门不可说
  于彼一一法门中　　又说诸法不可说
  于彼一一诸法中　　调伏众生不可说
  或复于一毛端处　　不可说劫常安住
  如一毛端余悉然　　所住劫数皆如是
  其心无碍不可说　　变化诸佛不可说
  一一变化诸如来　　复现于化不可说
  彼佛法身不可说　　彼佛分身不可说
  庄严无量不可说　　往诣十方不可说
  周行国土不可说　　观察众生不可说
  清净众生不可说　　调伏众生不可说
  彼诸庄严不可说　　彼诸神力不可说
  彼诸自在不可说　　彼诸神变不可说
  所有神通不可说　　所有境界不可说
  所有加持不可说　　所住世间不可说
  清净实相不可说　　说修多罗不可说
  于彼一一修多罗　　演说法门不可说
  于彼一一法门中　　又说诸法不可说
  于彼一一诸法中　　所有决定不可说
  于彼一一决定中　　调伏众生不可说
  不可言说同类法　　不可言说同类心
  不可言说异类法　　不可言说异类心
  不可言说异类根　　不可言说异类语
  念念于诸所行处　　调伏众生不可说
  所有神变不可说　　所有示现不可说
  于中时劫不可说　　于中差别不可说
  菩萨悉能分别说　　诸明算者莫能辨
  一毛端处大小刹　　杂染清净粗细刹
  如是一切不可说　　一一明了可分别
  以一国土碎为尘　　其尘无量不可说
  如是尘数无边刹　　俱来共集一毛端
  此诸国土不可说　　共集毛端无迫隘
  不使毛端有增大　　而彼国土俱来集
  于中所有诸国土　　形相如本无杂乱
  如一国土不乱余　　一切国土皆如是
  虚空境界无边际　　悉布毛端使充满
  如是毛端诸国土　　菩萨一念皆能说
  于一微细毛孔中　　不可说刹次第入
  毛孔能受彼诸刹　　诸刹不能遍毛孔
  入时劫数不可说　　受时劫数不可说
  于此行列安住时　　一切诸劫无能说
  如是摄受安住已　　所有境界不可说
  入时方便不可说　　入已所作不可说
  意根明了不可说　　游历诸方不可说
  勇猛精进不可说　　自在神变不可说
  所有思惟不可说　　所有大愿不可说
  所有境界不可说　　一切通达不可说
  身业清净不可说　　语业清净不可说
  意业清净不可说　　信解清净不可说
  妙智清净不可说　　妙慧清净不可说
  了诸实相不可说　　断诸疑惑不可说
  出离生死不可说　　超升正位不可说
  甚深三昧不可说　　了达一切不可说
  一切众生不可说　　一切佛刹不可说
  知众生身不可说　　知其心乐不可说
  知其业果不可说　　知其意解不可说
  知其品类不可说　　知其种性不可说
  知其受身不可说　　知其生处不可说
  知其正生不可说　　知其生已不可说
  知其解了不可说　　知其趣向不可说
  知其言语不可说　　知其作业不可说
  菩萨如是大慈悲　　利益一切诸世间
  普现其身不可说　　入诸佛刹不可说
  见诸菩萨不可说　　发生智慧不可说
  请问正法不可说　　敷扬佛教不可说
  现种种身不可说　　诣诸国土不可说
  示现神通不可说　　普遍十方不可说
  处处分身不可说　　亲近诸佛不可说
  作诸供具不可说　　种种无量不可说
  清净众宝不可说　　上妙莲华不可说
  最胜香鬘不可说　　供养如来不可说
  清净信心不可说　　最胜悟解不可说
  增上志乐不可说　　恭敬诸佛不可说
  修行于施不可说　　其心过去不可说
  有求皆施不可说　　一切悉施不可说
  持戒清净不可说　　心意清净不可说
  赞叹诸佛不可说　　爱乐正法不可说
  成就诸忍不可说　　无生法忍不可说
  具足寂静不可说　　住寂静地不可说
  起大精进不可说　　其心过去不可说
  不退转心不可说　　不倾动心不可说
  一切定藏不可说　　观察诸法不可说
  寂然在定不可说　　了达诸禅不可说
  智慧通达不可说　　三昧自在不可说
  了达诸法不可说　　明见诸佛不可说
  修无量行不可说　　发广大愿不可说
  甚深境界不可说　　清净法门不可说
  菩萨法力不可说　　菩萨法住不可说
  彼诸正念不可说　　彼诸法界不可说
  修方便智不可说　　学甚深智不可说
  无量智慧不可说　　究竟智慧不可说
  彼诸法智不可说　　彼净法轮不可说
  彼大法云不可说　　彼大法雨不可说
  彼诸神力不可说　　彼诸方便不可说
  入空寂智不可说　　念念相续不可说
  无量行门不可说　　念念恒住不可说
  诸佛刹海不可说　　悉能往诣不可说
  诸刹差别不可说　　种种清净不可说
  差别庄严不可说　　无边色相不可说
  种种间错不可说　　种种妙好不可说
  清净佛土不可说　　杂染世界不可说
  了知众生不可说　　知其种性不可说
  知其业报不可说　　知其心行不可说
  知其根性不可说　　知其解欲不可说
  杂染清净不可说　　观察调伏不可说
  变化自在不可说　　现种种身不可说
  修行精进不可说　　度脱众生不可说
  示现神变不可说　　放大光明不可说
  种种色相不可说　　令众生净不可说
  一一毛孔不可说　　放光明网不可说
  光网现色不可说　　普照佛刹不可说
  勇猛无畏不可说　　方便善巧不可说
  调伏众生不可说　　令出生死不可说
  清净身业不可说　　清净语业不可说
  无边意业不可说　　殊胜妙行不可说
  成就智宝不可说　　深入法界不可说
  菩萨总持不可说　　善能修学不可说
  智者音声不可说　　音声清净不可说
  正念真实不可说　　开悟众生不可说
  具足威仪不可说　　清净修行不可说
  成就无畏不可说　　调伏世间不可说
  诸佛子众不可说　　清净胜行不可说
  称叹诸佛不可说　　赞扬无尽不可说
  世间导师不可说　　演说赞叹不可说
  彼诸菩萨不可说　　清净功德不可说
  彼诸边际不可说　　能住其中不可说
  住中智慧不可说　　尽诸劫住无能说
  欣乐诸佛不可说　　智慧平等不可说
  善入诸法不可说　　于法无碍不可说
  三世如空不可说　　三世智慧不可说
  了达三世不可说　　住于智慧不可说
  殊胜妙行不可说　　无量大愿不可说
  清净大愿不可说　　成就菩提不可说
  诸佛菩提不可说　　发生智慧不可说
  分别义理不可说　　知一切法不可说
  严净佛刹不可说　　修行诸力不可说
  长时修习不可说　　一念悟解不可说
  诸佛自在不可说　　广演正法不可说
  种种神力不可说　　示现世间不可说
  清净法轮不可说　　勇猛能转不可说
  种种开演不可说　　哀愍世间不可说
  不可言说一切劫　　赞不可说诸功德
  不可说劫犹可尽　　不可说德不可尽
  不可言说诸如来　　不可言说诸舌根
  叹佛不可言说德　　不可说劫无能尽
  十方所有诸众生　　一切同时成正觉
  于中一佛普能现　　不可言说一切身
  此不可说中一身　　示现于头不可说
  此不可说中一头　　示现于舌不可说
  此不可说中一舌　　示现于声不可说
  此不可说中一声　　经于劫住不可说
  如一如是一切佛　　如一如是一切身
  如一如是一切头　　如一如是一切舌
  如一如是一切声　　不可说劫恒赞佛
  不可说劫犹可尽　　叹佛功德无能尽
  一微尘中能悉有　　不可言说莲华界
  一一莲华世界中　　贤首如来不可说
  乃至法界悉周遍　　其中所有诸微尘
  世界若成若住坏　　其数无量不可说
  一微尘处无边际　　无量诸刹普来入
  十方差别不可说　　刹海分布不可说
  一一刹中有如来　　寿命劫数不可说
  诸佛所行不可说　　甚深妙法不可说
  神通大力不可说　　无障碍智不可说
  入于毛孔不可说　　毛孔因缘不可说
  成就十力不可说　　觉悟菩提不可说
  入净法界不可说　　获深智藏不可说
  种种数量不可说　　如其一切悉了知
  种种形量不可说　　于此靡不皆通达
  种种三昧不可说　　悉能经劫于中住
  于不可说诸佛所　　所行清净不可说
  得不可说无碍心　　往诣十方不可说
  神力示现不可说　　所行无际不可说
  往诣众刹不可说　　了达诸佛不可说
  精进勇猛不可说　　智慧通达不可说
  于法非行非不行　　入诸境界不可说
  不可称说诸大劫　　恒游十方不可说
  方便智慧不可说　　真实智慧不可说
  神通智慧不可说　　念念示现不可说
  于不可说诸佛法　　一一了知不可说
  能于一时证菩提　　或种种时而证入
  毛端佛刹不可说　　尘中佛刹不可说
  如是佛刹皆往诣　　见诸如来不可说
  通达一实不可说　　善入佛种不可说
  诸佛国土不可说　　悉能往诣成菩提
  国土众生及诸佛　　体性差别不可说
  如是三世无有边　　菩萨一切皆明见

    大方广佛华严经寿量品第三十一

尔时心王菩萨摩诃萨。于众会中。告诸菩萨言。佛子。此娑婆世界。释迦牟尼佛刹一劫。于极乐世界阿弥陀佛刹。为一日一夜。极乐世界一劫。于袈裟幢世界金刚坚佛刹。为一日一夜。袈裟幢世界一劫。于不退转音声轮世界善胜光明莲华开敷佛刹。为一日一夜。不退转音声轮世界一劫。于离垢世界法幢佛刹。为一日一夜。离垢世界一劫。于善灯世界师子佛刹。为一日一夜。善灯世界一劫。于妙光明世界光明藏佛刹。为一日一夜。妙光明世界一劫。于难超过世界法光明莲华开敷佛刹为一日一夜。难超过世界一劫。于庄严慧世界一切神通光明佛刹。为一日一夜。庄严慧世界一劫。于镜光明世界月智佛刹。为一日一夜。佛子。如是次第。乃至过百万阿僧祇世界。最后世界一劫。于胜莲华世界贤胜佛刹。为一日一夜。普贤菩萨。及诸同行大菩萨等。充满其中

    大方广佛华严经诸菩萨住处品第三十二

尔时心王菩萨摩诃萨。于众会中。告诸菩萨言。佛子。东方有处。名仙人山。从昔已来。诸菩萨众。于中止住。现有菩萨。名金刚胜。与其眷属。诸菩萨众。三百人俱。常在其中。而演说法。南方有处。名胜峰山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰法慧。与其眷属。诸菩萨众。五百人俱。常在其中。而演说法。西方有处。名金刚焰山。从昔已来。诸菩萨众。于中止住。现有菩萨。名精进无畏行。与其眷属。诸菩萨众。三百人俱。常在其中。而演说法。北方有处。名香积山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰香象。与其眷属。诸菩萨众。三千人俱。常在其中。而演说法。东北方有处。名清凉山。从昔已来。诸菩萨众。于中止住。现有菩萨。名文殊师利。与其眷属。诸菩萨众。一万人俱。常在其中。而演说法。海中有处。名金刚山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰法起。与其眷属。诸菩萨众。千二百人俱。常在其中。而演说法。东南方有处。名支提山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰天冠。与其眷属。诸菩萨众。一千人俱。常在其中。而演说法。西南方有处。名光明山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰贤胜。与其眷属。诸菩萨众。三千人俱。常在其中。而演说法。西北方有处。名香风山。从昔已来。诸菩萨众。于中止住。现有菩萨。名曰香光。与其眷属。诸菩萨众。五千人俱。常在其中。而演说法。大海之中。复有住处。名庄严窟。从昔已来。诸菩萨众。于中止住。毗舍离南。有一住处。名善住根。从昔已来。诸菩萨众。于中止住。摩度罗城。有一住处。名满足窟。从昔已来。诸菩萨众。于中止住。俱珍那城。有一住处。名曰法座。从昔已来。诸菩萨众。于中止住。清净彼岸城。有一住处。名目真邻陀窟。从昔已来。诸菩萨众。于中止住。摩兰陀国。有一住处。名无碍龙王建立。从昔已来。诸菩萨众。于中止住。甘菩遮国。有一住处。名出生慈。从昔已来。诸菩萨众。于中止住。震旦国。有一住处。名那罗延窟。从昔已来。诸菩萨众。于中止住。疏勒国。有一住处。名牛头山。从昔已来。诸菩萨众。于中止住。迦叶弥罗国。有一住处。名曰次第。从昔已来。诸菩萨众。于中止住。增长欢喜城。有一住处。名尊者窟。从昔已来。诸菩萨众。于中止住。庵浮梨摩国。有一住处。名见亿藏光明。从昔已来。诸菩萨众。于中止住。乾陀罗国。有一住处。名苫婆罗窟。从昔已来。诸菩萨众。于中止住

大方广佛华严经卷第四十五大方广佛华严经卷第四十六

        于阗国三藏实叉难陀奉　制译

    佛不思议法品第三十三之一

尔时大会中。有诸菩萨。作是念。诸佛国土。云何不思议。诸佛本愿。云何不思议。诸佛种性。云何不思议。诸佛出现。云何不思议。诸佛身。云何不思议。诸佛音声。云何不思议。诸佛智慧。云何不思议。诸佛自在。云何不思议。诸佛无碍。云何不思议。诸佛解脱。云何不思议。尔时世尊。知诸菩萨心之所念。则以神力加持。智慧摄受。光明照曜。威势充满。令青莲华藏菩萨。住佛无畏。入佛法界。获佛威德。神通自在。得佛无碍广大观察。知一切佛种性次第。住不可说佛法方便。尔时青莲华藏菩萨。则能通达无碍法界。则能安住离障深行。则能成满普贤大愿。则能知见一切佛法。以大悲心。观察众生。欲令清净精勤修习。无有厌怠。受行一切诸菩萨法。于一念中。出生佛智。解了一切无尽智门。总持辩才。皆悉具足。承佛神力。告莲华藏菩萨言。佛子。诸佛世尊。有无量住。所谓常住。大悲住。种种身作诸佛事住。平等意转净法轮住。四辩才说无量法住。不思议一切佛法住。清净音遍无量土住。不可说甚深法界住。现一切最胜神通住。能开示无有障碍。究竟之法。佛子。诸佛世尊。有十种法。普遍无量无边法界。何等为十。所谓一切诸佛有无边际身。色相清净。普入诸趣。而无染着。一切诸佛有无边际无障碍眼。于一切法。悉能明见一切诸佛有无边际无障碍耳。悉能解了一切音声。一切诸佛有无边际鼻。能到诸佛自在彼岸。一切诸佛有广长舌。出妙音声。周遍法界。一切诸佛有无边际身。应众生心。咸令得见。一切诸佛有无边际意。住于无碍平等法身。一切诸佛有无边际无碍解脱。示现无尽大神通力。一切诸佛有无边际清净世界。随众生乐。现众佛土。具足无量。种种庄严。而于其中。不生染着。一切诸佛。有无边际菩萨行愿。得圆满智。游戏自在。悉能通达一切佛法。佛子。是为如来应正等觉。普遍法界无边际。十种佛法。佛子。诸佛世尊。有十种念念出生智。何等为十。所谓一切诸佛。于一念中。悉能示现无量世界从天来下。一切诸佛。于一念中。悉能示现无量世界菩萨受生。一切诸佛。于一念中。悉能示现无量世界出家学道。一切诸佛。于一念中。悉能示现无量世界菩提树下。成等正觉。一切诸佛。于一念中。悉能示现无量世界转妙法轮。一切诸佛。于一念中。悉能示现无量世界教化众生。供养诸佛。一切诸佛。于一念中。悉能示现无量世界不可言说。种种佛身。一切诸佛。于一念中。悉能示现无量世界种种庄严。无数庄严。如来自在。一切智藏。一切诸佛。于一念中。悉能示现无量世界无量无数。清净众生。一切诸佛。于一念中。悉能示现无量世界三世诸佛。种种根性。种种精进。种种行解。于三世中。成等正觉。是为十。佛子。诸佛世尊。有十种不失时。何等为十。所谓一切诸佛。成等正觉不失时。一切诸佛。成熟有缘不失时。一切诸佛。授菩萨记不失时。一切诸佛。随众生心。示现神力不失时。一切诸佛。随众生解。示现佛身不失时。一切诸佛。住于大舍不失时。一切诸佛。入诸聚落不失时。一切诸佛。摄诸净信不失时。一切诸佛。调恶众生不失时。一切诸佛。现不思议。诸佛神通不失时。是为十。佛子。诸佛世尊。有十种无比不思议境界。何等为十。所谓一切诸佛。一跏趺坐。遍满十方无量世界。一切诸佛。说一义句。悉能开示一切佛法。一切诸佛。放一光明。悉能遍照一切世界。一切诸佛。于一身中。悉能示现一切诸身。一切诸佛。于一处中。悉能示现一切世界。一切诸佛。于一智中。悉能决了一切诸法。无所挂碍。一切诸佛。于一念中。悉能遍往十方世界。一切诸佛。于一念中。悉现如来无量威德。一切诸佛。于一念中。普缘三世佛及众生。心无杂乱。一切诸佛。于一念中。与去来今一切诸佛。体同无二。是为十。佛子。诸佛世尊。能出生十种智。何者为十。所谓一切诸佛。知一切法无所趣向。而能出生回向愿智。一切诸佛。知一切法皆无有身。而能出生清净身智。一切诸佛。知一切法本来无二。而能出生能觉悟智。一切诸佛。知一切法无我无众生。而能出生调众生智。一切诸佛。知一切法本来无相。而能出生了诸相智。一切诸佛。知一切世界。无有成坏。而能出生了成坏智。一切诸佛。知一切法无有造作。而能出生知业果智。一切诸佛。知一切法无有言说。而能出生了言说智。一切诸佛。知一切法无有染净。而能出生知染净智。一切诸佛。知一切法无有生灭。而能出生了生灭智。是为十。佛子。诸佛世尊。有十种普入法。何等为十。所谓一切诸佛。有净妙身。普入三世一切诸佛。皆悉具足三种自在。普化众生。一切诸佛。皆悉具足诸陀罗尼。普能受持一切佛法。一切诸佛。皆悉具足四种辩才。普转一切清净法轮。一切诸佛。皆悉具足平等大悲。恒不舍离一切众生。一切诸佛。皆悉具足甚深禅定。恒普观察一切众生。一切诸佛。皆悉具足利他善根。调伏众生。无有休息。一切诸佛。皆悉具足无所碍心。普能安住一切法界。一切诸佛。皆悉具足无碍神力。一念普现三世诸佛。一切诸佛。皆悉具足无碍智慧。一念普立三世劫数。是为十。佛子。诸佛世尊。有十种难信受广大法。何等为十。所谓一切诸佛。悉能摧灭一切诸魔。一切诸佛。悉能降伏一切外道。一切诸佛。悉能调伏一切众生。咸令欢悦。一切诸佛。悉能往诣一切世界。化导群品。一切诸佛。悉能智证甚深法界。一切诸佛。悉皆能以无二之身。现种种身。充满世界。一切诸佛。悉皆能以清净音声。起四辩才。说法无断。凡有信受。功不唐捐。一切诸佛。皆悉能于一毛孔中。出现诸佛。与一切世界微尘数等。无有断绝。一切诸佛。皆悉能于一微尘中。示现众刹。与一切世界微尘数等。具足种种上妙庄严。恒于其中。转妙法轮。教化众生。而微尘不大。世界不小。常以证智。安住法界。一切诸佛。皆悉了达清净法界。以智光明。破世痴闇。令于佛法。悉得开晓。随逐如来。住十力中。是为十。佛子。诸佛世尊。有十种大功德。离过清净。何等为十。所谓一切诸佛。具大威德。离过清净。一切诸佛。悉于三世如来家生。种族调善。离过清净。一切诸佛。尽未来际。心无所住。离过清净。一切诸佛。于三世法。皆无所著。离过清净。一切诸佛。知种种性。皆是一性。无所从来。离过清净。一切诸佛。前际后际。福德无尽。等于法界。离过清净。一切诸佛。无边身相。遍十方刹。随时调伏一切众生。离过清净。一切诸佛。获四无畏。离诸恐怖。于众会中。大师子吼。明了分别一切诸法。离过清净。一切诸佛。于不可说不可说劫。入般涅槃。众生闻名。获无量福。如佛现在。功德无异。离过清净。一切诸佛。远在不可说不可说世界中。若有众生。一心正念。则皆得见。离过清净。是为十。佛子。诸佛世尊。有十种究竟清净。何等为十。所谓一切诸佛。往昔大愿。究竟清净。一切诸佛。所持梵行。究竟清净。一切诸佛。离世众惑。究竟清净。一切诸佛。庄严国土。究竟清净。一切诸佛。所有眷属。究竟清净。一切诸佛。所有种族。究竟清净。一切诸佛。色身相好。究竟清净。一切诸佛。法身无染。究竟清净。一切诸佛。一切智智。无有障碍。究竟清净。一切诸佛。解脱自在。所作已辨。到于彼岸。究竟清净。是为十。佛子。诸佛世尊。于一切世界一切时。有十种佛事。何等为十。一者若有众生。专心忆念。则现其前。二者若有众生。心不调顺。则为说法。三者若有众生。能生净信。必令获得无量善根。四者若有众生。能入法位。悉皆现证。无不了知。五者教化众生。无有疲厌。六者游诸佛刹。往来无碍。七者大悲不舍一切众生。八者现变化身。恒不断绝。九者神通自在。未尝休息。十者安住法界。能遍观察。是为十。佛子。诸佛世尊。有十种无尽智海法。何等为十。所谓一切诸佛。无边法身。无尽智海法。一切诸佛。无量佛事。无尽智海法。一切诸佛。佛眼境界。无尽智海法。一切诸佛。无量无数。难思善根。无尽智海法。一切诸佛。普雨一切甘露妙法。无尽智海法。一切诸佛。赞佛功德。无尽智海法。一切诸佛。往昔所修。种种愿行。无尽智海法。一切诸佛。尽未来际。恒作佛事。无尽智海法。一切诸佛。了知一切众生心行。无尽智海法。一切诸佛。福智庄严。无能过者。无尽智海法。是为十。佛子。诸佛世尊。有十种常法。何等为十。所谓一切诸佛。常行一切诸波罗蜜。一切诸佛。于一切法。常离迷惑。一切诸佛。常具大悲。一切诸佛。常有十力。一切诸佛。常转法轮。一切诸佛。常为众生。示成正觉。一切诸佛。常乐调伏一切众生。一切诸佛。心常正念不二之法。一切诸佛。化众生已。常示入于无余涅槃。诸佛境界。无边际故。是为十。佛子。诸佛世尊。有十种演说无量诸佛法门。何等为十。所谓一切诸佛。演说无量众生界门。一切诸佛。演说无量众生行门。一切诸佛。演说无量众生业果门。一切诸佛演说无量化众生门。一切诸佛。演说无量净众生门。一切诸佛。演说无量菩萨行门。一切诸佛。演说无量菩萨愿门。一切诸佛。演说无量一切世界。成坏劫门。一切诸佛。演说无量菩萨深心。净佛刹门。一切诸佛。演说无量一切世界。三世诸佛。于彼彼劫。次第出现门。一切诸佛。演说一切诸佛智门。是为十。佛子。诸佛世尊。有十种为众生作佛事。何等为十。所谓一切诸佛。示现色身。为众生作佛事。一切诸佛。出妙音声。为众生作佛事。一切诸佛。有所受。为众生作佛事。一切诸佛。无所受。为众生作佛事。一切诸佛。以地水火风。为众生作佛事。一切诸佛。神力自在。示现一切所缘境界。为众生作佛事。一切诸佛。种种名号。为众生作佛事。一切诸佛。以佛刹境界。为众生作佛事。一切诸佛。严净佛刹。为众生作佛事。一切诸佛。寂寞无言。为众生作佛事。是为十。佛子。诸佛世尊。有十种最胜法。何等为十。所谓一切诸佛。大愿坚固。不可沮坏。所言必作。言无有二。一切诸佛。为欲圆满一切功德。尽未来劫。修菩萨行。不生懈倦。一切诸佛。为欲调伏一众生故。往不可说不可说世界。如是而为一切众生。而无断绝。一切诸佛。于信于毁二种众生。大悲普观。平等无异。一切诸佛。从初发心。乃至成佛。终不退失菩提之心。一切诸佛。积集无量诸善功德。皆以回向一切智性。于诸世间。终无染着。一切诸佛。于诸佛所。修学三业。唯行佛行。非二乘行。皆为回向一切智性。成于无上正等菩提。一切诸佛。放大光明。其光平等。照一切处。及照一切诸佛之法。令诸菩萨。心得清净。满一切智。一切诸佛。舍离世乐。不贪不染。而普愿世间离苦得乐。无诸戏论。一切诸佛。愍诸众生。受种种苦。守护佛种。行佛境界。出离生死。逮十力地。是为十。佛子。诸佛世尊。有十种无障碍住。何等为十。所谓一切诸佛。皆能往一切世界。无障碍住。一切诸佛。皆能住一切世界。无障碍住。一切诸佛。皆能于一切世界。行住坐卧。无障碍住。一切诸佛。皆能于一切世界。演说正法。无障碍住。一切诸佛。皆能于一切世界。住兜率天宫。无障碍住。一切诸佛。皆能入法界一切三世。无障碍住。一切诸佛。皆能坐法界一切道场。无障碍住。一切诸佛。皆能念念观一切众生心行。以三种自在。教化调伏。无障碍住。一切诸佛。皆能以一身。住无量不思议佛所及一切处。利益众生。无障碍住。一切诸佛。皆能开示无量诸佛。所说正法。无障碍住。是为十。佛子。诸佛世尊。有十种最胜无上庄严。何等为十。一切诸佛。皆悉具足诸相随好。是为诸佛第一最胜无上身庄严。一切诸佛。皆悉具足六十种音。一一音。有五百分。一一分。无量百千清净之音。以为严好。能于法界一切众中。无诸恐怖。大师子吼。演说如来甚深法义。众生闻者。靡不欢喜。随其根欲。悉得调伏。是为诸佛第二最胜无上语庄严。一切诸佛。皆具十力。诸大三昧。十八不共。庄严意业。所行境界。通达无碍一切佛法。咸得无余法界庄严。而为庄严。法界众生。心之所行。去来现在。各各差别。于一念中。悉能明见。是为诸佛第三最胜无上意庄严。一切诸佛。皆悉能放无数光明。一一光明。有不可说光明网。以为眷属。普照一切诸佛国土。灭除一切世间黑闇。示现无量诸佛出兴。其身平等。悉皆清净。所作佛事。咸不唐捐。能令众生。至不退转。是为诸佛第四最胜无上光明庄严。一切诸佛。现微笑时。皆于口中。放百千亿那由他阿僧祇光明。一一光明。各有无量不思议种种色。遍照十方一切世界。于大众中。发诚实语。授无量无数不思议众生。阿耨多罗三藐三菩提记。是为诸佛第五离世痴惑最胜无上现微笑庄严。一切诸佛。皆有法身清净无碍。于一切法。究竟通达。住于法界。无有边际。虽在世间。不与世杂。了世实性。行出世法。言语道断。超蕴界处。是为诸佛第六最胜无上法身庄严。一切诸佛。皆有无量常妙光明。不可说不可说种种色相。以为严好。为光明藏。出生无量圆满光明。普照十方。无有障碍。是为诸佛第七最胜无上常妙光明庄严。一切诸佛。皆有无边妙色。可爱妙色。清净妙色。随心所现妙色。映蔽一切三界妙色。到于彼岸无上妙色。是为诸佛第八最胜无上妙色庄严。一切诸佛。皆于三世佛种中生。积众善宝。究竟清净。无诸过失。离世讥谤。一切法中。最为殊胜清净妙行之所庄严。具足成就一切智智。种族清净。无能讥毁。是为诸佛第九最胜无上种族庄严。一切诸佛。以大慈力。庄严其身。究竟清净。无诸渴爱。身行永息。心善解脱。见者无厌。大悲救护一切世间。第一福田。无上受者。哀愍利益一切众生。悉令增长无量福德。智慧之聚。是为诸佛第十最胜无上大慈大悲功德庄严。是为十。佛子。诸佛世尊。有十种自在法。何等为十。所谓一切诸佛。于一切法。悉得自在。明达种种句身味身。演说诸法。辩才无碍。是为诸佛第一自在法。一切诸佛。教化众生。未曾失时。随其愿乐。为说正法。咸令调伏。无有断绝。是为诸佛第二自在法。一切诸佛。能令尽虚空界。无量无数种种庄严。一切世界。六种震动。令彼世界。或举或下。或大或小。或合或散。未曾恼害。于一众生。其中众生。不觉不知。无疑无怪。是为诸佛第三自在法。一切诸佛。以神通力。悉能严净一切世界。于一念顷。普现一切世界庄严。此诸庄严。经无数劫。说不能尽。悉皆离染。清净无比。一切佛刹严净之事。皆令平等。入一刹中。是为诸佛第四自在法。一切诸佛。见一众生。应受化者。为其住寿。经不可说不可说劫。乃至尽未来际。结跏趺坐。身心无倦。专心忆念。未曾废忘。方便调伏。而不失时。如为一众生。为一切众生。悉亦如是。是为诸佛第五自在法。一切诸佛。悉能遍往一切世界。一切如来所行之处。而不暂舍一切法界。十方各别。一一方有无量世界海。一一世界海。有无量世界种。佛以神力。一念咸到。转于无碍清净法轮。是为诸佛第六自在法。一切诸佛。为欲调伏一切众生。念念中。成阿耨多罗三藐三菩提。而于一切佛法。非已现觉。亦非当觉。亦不住于有学之地。而悉知见。通达无碍。无量智慧。无量自在。教化调伏一切众生。是为诸佛第七自在法。一切诸佛。能以眼处。作耳处佛事。能以耳处。作鼻处佛事。能以鼻处。作舌处佛事。能以舌处。作身处佛事。能以身处。作意处佛事。能以意处。于一切世界中。住世出世间种种境界。一一境界中。能作无量广大佛事。是为诸佛第八自在法。一切诸佛。其身毛孔。一一能容一切众生。一一众生。其身悉与不可说诸佛刹等。而无迫隘。一一众生。步步能过无数世界。如是展转。尽无数劫。悉见诸佛出现于世。教化众生。转净法轮。开示过去未来现在不可说法。尽虚空界。一切众生。诸趣受身。威仪往来。及其所受。种种乐具。皆悉具足。而于其中。无所障碍。是为诸佛第九自在法。一切诸佛。于一念顷。现一切世界微尘数佛。一一佛。皆于一切法界。众妙莲华。广大庄严世界。莲华藏师子座上。成等正觉。示现诸佛自在神力。如于众妙莲华广大庄严世界。如是。于一切法界中。不可说不可说。种种庄严。种种境界。种种形相。种种示现。种种劫数。清净世界。如于一念。如是。于无量无边阿僧祇劫。一切念中。一念一切现。一念无量住。而未曾用少方便力。是为诸佛第十自在法。佛子。诸佛世尊。有十种无量不思议圆满佛法。何等为十。所谓一切诸佛。一一净相。皆具百福。一切诸佛。皆悉成就一切佛法。一切诸佛。皆悉成就一切善根。一切诸佛。皆悉成就一切功德。一切诸佛。皆能教化一切众生。一切诸佛。皆悉能为众生作主。一切诸佛。皆悉成就清净佛刹。一切诸佛。皆悉成就一切智智。一切诸佛。皆悉成就色身相好。见者获益。功不唐捐。一切诸佛。皆具诸佛平等正法。一切诸佛。作佛事已。莫不示现入于涅槃。是为十。佛子。诸佛世尊。有十种善巧方便。何等为十。一切诸佛。了知诸法皆离戏论。而能开示诸佛善根。是为第一善巧方便。一切诸佛。知一切法。悉无所见。各不相知。无缚无解。无受无集。无成就自在究竟。到于彼岸。然于诸法真实。而知不异不别。而得自在。无我无受。不坏实际。已得至于大自在地。常能观察一切法界。是为第二善巧方便。一切诸佛。永离诸相。心无所住。而能悉知不乱不错。虽知一切相皆无自性。而如其体性。悉能善入。而亦示现无量色身。及以一切清净佛土。种种庄严无尽之相。集智慧灯。灭众生惑。是为第三善巧方便。一切诸佛。住于法界。不住过去未来现在。如如性中。无去来今三世相故。而能演说去来今世。无量诸佛。出现世间。令其闻者。普见一切诸佛境界。是为第四善巧方便。一切诸佛。身语意业。无所造作。无来无去。亦无有住。离诸数法。到于一切诸法彼岸。而为众法藏。具无量智。了达种种世出世法。智慧无碍。示现无量自在神力。调伏一切法界众生。是为第五善巧方便。一切诸佛。知一切法不可见。非一非异。非量非无量。非来非去。皆无自性。亦不违于世间诸法。一切智者。无自性中。见一切法。于法自在。广说诸法。而常安住真如实性。是为第六善巧方便。一切诸佛。于一时中。知一切时。具净善根。入于正位。而无所著。于其日月年劫成坏。如是等时。不住不舍。而能示现。若昼若夜。初中后时。一日七日。半月一月。一年百年。一劫多劫。不可思劫。不可说劫。乃至尽于未来际劫。恒为众生。转妙法轮。不断不退。无有休息。是为第七善巧方便。一切诸佛。恒住法界。成就诸佛无量无畏。及不可数辩。不可量辩。无尽辩。无断辩。无边辩。不共辩。无穷辩。真实辩。方便开示一切句辩。一切法辩。随其根性。及以欲解。以种种法门。说不可说不可说百千亿那由他修多罗。初中后善。皆悉究竟。是为第八善巧方便。一切诸佛。住净法界。知一切法。本无名字。无过去名。无现在名。无未来名。无众生名。无非众生名。无国土名。无非国土名。无法名。无非法名。无功德名。无非功德名。无菩萨名。无佛名。无数名。无非数名。无生名。无灭名。无有名。无无名。无一名。无种种名。何以故。诸法体性。不可说故。一切诸法。无方无处。不可集说。不可散说。不可一说。不可多说。音声莫逮。言语悉断。虽随世俗种种言说。无所攀缘。无所造作。远离一切虚妄想着。如是究竟。到于彼岸。是为第九善巧方便。一切诸佛。知一切法本性寂静。无生故非色。无戏论故非受。无名数故非想。无造作故非行。无执取故非识。无入处故非处。无所得故非界。然亦不坏一切诸法。本性无起。如虚空故。一切诸法。皆悉空寂。无业果。无修习。无成就。无出生。非数非不数。非有非无。非生非灭。非垢非净。非入非出。非住非不住。非调伏非不调伏。非众生非无众生。非寿命非无寿命。非因缘非无因缘。而能了知正定邪定。及不定聚。一切众生。为说妙法。令到彼岸。成就十力四无所畏。能师子吼。具一切智。住佛境界。是为第十善巧方便。佛子。是为诸佛成就十种。善巧方便

大方广佛华严经卷第四十六大方广佛华严经卷第四十七

        于阗国三藏实叉难陀奉　制译

    佛不思议法品第三十三之二

佛子。诸佛世尊。有十种广大佛事。无量无边。不可思议。一切世间。诸天及人。皆不能知。去来现在。所有一切声闻独觉。亦不能知。唯除如来威神之力。何等为十。所谓一切诸佛。于尽虚空遍法界。一切世界。兜率陀天。皆现受生。修菩萨行。作大佛事。无量色相。无量威德。无量光明。无量音声。无量言辞。无量三昧。无量智慧。所行境界。摄取一切人天魔梵。沙门婆罗门。阿修罗等。大慈无碍。大悲究竟。平等饶益一切众生。或令生天。或令生人。或净其根。或调其心。或时为说差别三乘。或时为说圆满一乘。普皆济度。令出生死。是为第一广大佛事。佛子。一切诸佛。从兜率天。降神母胎。以究竟三昧。观受生法。如幻如化。如影如空。如热时焰。随乐而受。无量无碍。入无诤法。起无著智。离欲清净。成就广大妙庄严藏。受最后身。住大宝庄严楼阁。而作佛事。或以神力。而作佛事。或以正念。而作佛事。或现神通。而作佛事。或现智日。而作佛事。或现诸佛广大境界。而作佛事。或现诸佛无量光明。而作佛事。或入无数广大三昧。而作佛事。或现从彼诸三昧起。而作佛事。佛子。如来尔时。在母胎中。为欲利益一切世间。种种示现。而作佛事。所谓或现初生。或现童子。或现在宫。或现出家。或复示现成等正觉。或复示现转妙法轮。或示现于入般涅槃。如是皆以种种方便。于一切方。一切网。一切旋。一切种。一切世界中。而作佛事。是为第二广大佛事。佛子。一切诸佛。一切善业。皆已清净。一切生智。皆已明洁。而以生法。诱导群迷。令其开悟。具行众善。为众生故。示诞王宫。一切诸佛。于诸色欲宫殿妓乐。皆已舍离。无所贪染。常观诸有。空无体性。一切乐具。悉不真实。持佛净戒。究竟圆满。观诸内宫妻妾侍从。生大悲愍。观诸众生虚妄不实。起大慈心。观诸世间无一可乐。而生大喜。于一切法。心得自在。而起大舍。具佛功德。现生法界。身相圆满。眷属清净。而于一切。皆无所著。以随类音。为众演说。令于世法。深生厌离。如其所行。示所得果。复以方便。随应教化。未成熟者。令其成熟。已成熟者。令得解脱。为作佛事。令不退转。复以广大慈悲之心。恒为众生。说种种法。又为示现三种自在。令其开悟。心得清净。虽处内宫。众所咸睹。而于一切诸世界中。施作佛事。以大智慧。以大精进。示现种种诸佛神通。无碍无尽。恒住三种巧方便业。所谓身业究竟清净。语业常随智慧而行。意业甚深无有障碍。以是方便。利益众生。是为第三广大佛事。佛子。一切诸佛。示处种种庄严宫殿。观察厌离。舍而出家。欲使众生。了知世法皆是妄想。无常败坏。深起厌离。不生染着。永断世间贪爱烦恼。修清净行。利益众生。当出家时。舍俗威仪。住无诤法。满足本愿无量功德。以大智光。灭世痴闇。为诸世间无上福田。常为众生。赞佛功德。令于佛所。植诸善本。以智慧眼。见真实义。复为众生。赞说出家。清净无过。永得出离。长为世间智慧高幢。是为第四广大佛事。佛子。一切诸佛。具一切智。于无量法。悉已知见。菩提树下。成最正觉。降伏众魔。威德特尊。其身充满一切世界。神力所作。无边无尽。于一切智所行之义。皆得自在。修诸功德。悉已圆满。其菩提座。具足庄严。周遍十方一切世界。佛处其上。转妙法轮。说诸菩萨所有行愿。开示无量诸佛境界。令诸菩萨。皆得悟入。修行种种清净妙行。复能示导一切众生。令种善根。生于如来平等地中。住诸菩萨无边妙行。成就一切功德胜法。一切世界。一切众生。一切佛刹。一切诸法。一切菩萨。一切教化。一切三世。一切调伏。一切神变。一切众生心之乐欲。悉善了知。而作佛事。是为第五广大佛事。佛子。一切诸佛。转不退法轮。令诸菩萨。不退转故。转无量法轮。令一切世间。咸了知故。转开悟一切法轮。能大无畏师子吼故。转一切法智藏法轮。开法藏门。除闇障故。转无碍法轮。等虚空故。转无著法轮。观一切法非有无故。转照世法轮。令一切众生。净法眼故。转开示一切智法轮。悉遍一切三世法故。转一切佛同一法轮。一切佛法。不相违故。一切诸佛。以如是等无量无数百千亿那由他法轮。随诸众生。心行差别。而作佛事。不可思议。是为第六广大佛事。佛子。一切诸佛。入于一切王都城邑。为诸众生。而作佛事。所谓人王都邑。天王都邑。龙王夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。罗刹王。毗舍阇王。如是等王。一切都邑。入城门时。大地震动。光明普照。盲者得眼。聋者得耳。狂者得心。裸者得衣。诸忧苦者。悉得安乐。一切乐器。不鼓自鸣。诸庄严具。若着不着。咸出妙音。众生闻者。无不欣乐。一切诸佛。色身清净。相好具足。见者无厌。能为众生。作于佛事。所谓若顾视。若观察。若动转。若屈伸。若行若住。若坐若卧。若默若语。若现神通。若为说法。若有教敕。如是一切。皆为众生。而作佛事。一切诸佛。昔于一切无数世界。种种众生。心乐海中。劝令念佛。常勤观察。种诸善根。修菩萨行。叹佛色相微妙第一。一切众生。难可值遇。若有得见。而兴信心。则生一切无量善法。集佛功德。普皆清净。如是。称赞佛功德已。分身普往十方世界。令诸众生。悉得瞻奉。思惟观察。承事供养。种诸善根。得佛欢喜。增长佛种。悉当成佛。以如是行。而作佛事。或为众生。示现色身。或出妙音。或但微笑。令其信乐。头顶礼敬。曲躬合掌。称扬赞叹。问讯起居。而作佛事。一切诸佛。以如是等无量无数不可言说不可思议种种佛事。于一切世界中。随诸众生心之所乐。以本愿力。大慈悲力。一切智力。方便教化。悉令调伏。是为第七广大佛事。佛子。一切诸佛。或住阿兰若处。而作佛事。或住寂静处。而作佛事。或住空闲处。而作佛事。或住佛住处。而作佛事。或住三昧。而作佛事。或独处园林。而作佛事。或隐身不现。而作佛事。或住甚深智。而作佛事。或住诸佛无比境界。而作佛事。或住不可见种种身行。随诸众生心乐欲解。方便教化。无有休息。而作佛事。或以天身求一切智。而作佛事。或以龙身。夜叉身。乾闼婆身。阿修罗身。迦楼罗身。紧那罗身。摩睺罗伽。人非人等身。求一切智。而作佛事。或以声闻身。独觉身。菩萨身。求一切智。而作佛事。或时说法。或时寂默。而作佛事。或说一佛。或说多佛。而作佛事。或说诸菩萨。一切行。一切愿。为一行愿。而作佛事。或说诸菩萨。一行一愿。为无量行愿。而作佛事。或说佛境界即世间境界。而作佛事。或说世间境界即佛境界。而作佛事。或说佛境界即非境界。而作佛事。或住一日。或住一夜。或住半月。或住一月。或住一年。乃至住不可说劫。为诸众生。而作佛事。是为第八广大佛事。佛子。一切诸佛。是生清净善根之藏。令诸众生。于佛法中。生净信解。诸根调伏。永离世间。令诸菩萨。于菩提道。具智慧明。不由他悟。或现涅槃。而作佛事。或现世间。皆悉无常。而作佛事。或说佛身。而作佛事。或说所作。皆悉已辨。而作佛事。或说功德圆满无缺。而作佛事。或说永断诸有根本。而作佛事。或令众生。厌离世间。随顺佛心。而作佛事。或说寿命终归于尽。而作佛事。或说世间无一可乐。而作佛事。或为宣说尽未来际。供养诸佛。而作佛事。或说诸佛转净法轮。令其得闻。生大欢喜。而作佛事。或为宣说诸佛境界。令其发心。而修诸行。而作佛事。或为宣说念佛三昧。令其发心。常乐见佛。而作佛事。或为宣说诸根清净。勤求佛道。心无懈退。而作佛事。或诣一切诸佛国土。观诸境界种种因缘。而作佛事。或摄一切诸众生身。皆为佛身。令诸懈怠放逸众生。悉住如来清净禁戒。而作佛事。是为第九广大佛事。佛子。一切诸佛。入涅槃时。无量众生。悲号涕泣。生大忧恼。递相瞻顾。而作是言。如来世尊。有大慈悲。哀愍饶益一切世间。与诸众生。为救为归。如来出现。难可值遇。无上福田。于今永灭。即以如是。令诸众生。悲号恋慕。而作佛事。复为化度一切天人。龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等故。随其乐欲。自碎其身。以为舍利。无量无数不可思议。令诸众生。起净信心。恭敬尊重。欢喜供养。修诸功德。具足圆满。复起于塔。种种严饰。于诸天宫。龙宫夜叉宫。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等诸宫殿中。以为供养。牙齿爪发。咸以起塔。令其见者。皆悉念佛念法念僧。信乐不回。诚敬尊重。在在处处。布施供养。修诸功德。以是福故。或生天上。或处人间。种族尊荣。财产备足。所有眷属。悉皆清净。不入恶趣。常生善道。恒得见佛。具众白法。于三有中。速得出离。各随所愿。获自乘果。于如来所。知恩报恩。永与世间。作所归依。佛子。诸佛世尊。虽般涅槃。仍与众生。作不思议清净福田。无尽功德。最上福田。令诸众生。善根具足。福德圆满。是为第十广大佛事。佛子。此诸佛事。无量广大。不可思议。一切世间。诸天及人。及去来今。声闻独觉。皆不能知。唯除如来威神所加。佛子。诸佛世尊。有十种无二行自在法。何等为十。所谓一切诸佛。悉能善说。授记言辞。决定无二。一切诸佛。悉能随顺众生心念。令其意满。决定无二。一切诸佛。悉能现觉一切诸法。演说其义。决定无二。一切诸佛。悉能具足去来今世。诸佛智慧。决定无二。一切诸佛。悉知三世一切刹那。即一刹那决定无二。一切诸佛。悉知三世一切佛刹。入一佛刹。决定无一。一切诸佛。悉知三世一切佛语。即一佛语。决定无二。一切诸佛。悉知三世一切诸佛。与其所化一切众生。体性平等。决定无二。一切诸佛悉知世法。及诸佛法。性无差别。决定无二。一切诸佛。悉知三世一切诸佛。所有善根。同一善根。决定无二。是为十。佛子。诸佛世尊。有十种住。住一切法。何等为十。所谓一切诸佛。住觉悟一切法界。一切诸佛。住大悲语。一切诸佛。住本大愿。一切诸佛。住不舍调伏众生。一切诸佛。住无自性法。一切诸佛。住平等利益。一切诸佛。住无忘失法。一切诸佛。住无障碍心。一切诸佛。住恒正定心。一切诸佛。住等入一切法。不违实际相。是为十。佛子。诸佛世尊。有十种知一切法尽无有余。何等为十。所谓知过去一切法。尽无有余。知未来一切法。尽无有余。知现在一切法。尽无有余。知一切言语法。尽无有余。知一切世间道。尽无有余。知一切众生心。尽无有余。知一切菩萨善根。上中下。种种分位。尽无有余。知一切佛圆满智。及诸善根。不增不减。尽无有余。知一切法。皆从缘起。尽无有余。知一切世界种。尽无有余。知一切法界中。如因陀罗网。诸差别事。尽无有余。是为十

佛子。诸佛世尊。有十种广大力最上力。无量力。大威德力。难获力不退力。坚固力不可坏力。一切世间不思议力。一切众生无能动力。大那罗延幢勇健法。何者为十。所谓一切诸佛。身不可坏。命不可断世间毒药。所不能中。一切世界。水火风灾。皆于佛身。不能为害。一切诸魔。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人毗舍阇罗刹等。尽其势力。雨大金刚。如须弥山及铁围山。遍于三千大千世界。一时俱下。不能令佛心有惊怖。乃至一毛。亦不摇动。行住坐卧初无变易。佛所住处。四方远近。不令其下。则不能雨。假使不制。而从雨之。终不为损。若有众生。为佛所持。及佛所使。尚不可害。况如来身。是为诸佛第一大那罗延幢勇健法。佛子。一切诸佛。以一切法界。诸世界中。须弥山王。及铁围山。大铁围山。大海山林宫殿屋宅。置一毛孔。尽未来劫。而诸众生。不觉不知。唯除如来神力所被。佛子。尔时诸佛。于一毛孔。持于尔所一切世界。尽未来劫。或行或住。或坐或卧。不生一念劳倦之心。佛子。譬如虚空。普持一切遍法界中。所有世界。而无劳倦。一切诸佛。于一毛孔。持诸世界。亦复如是。是为诸佛第二大那罗延幢勇健法。佛子。一切诸佛。能于一念。起不可说不可说世界微尘数步。一一步。过不可说不可说佛刹微尘数国土。如是而行。经一切世界微尘数劫。佛子。假使有一大金刚山。与上所经一切佛刹。其量正等。如是量等。大金刚山。有不可说不可说佛刹微尘数诸佛。能以如是诸山。置一毛孔。佛身毛孔。与法界中一切众生毛孔数等。一一毛孔。悉置尔许大金刚山。持尔许山。游行十方。入尽虚空一切世界。从于前际。尽未来际。一切诸劫。无有休息。佛身无损。亦不劳倦。心常在定。无有散乱。是为诸佛第三大那罗延幢勇健法。佛子。一切诸佛。一坐食已。结跏趺坐。经前后际不可说劫。入佛所受不思议乐。其身安住。寂然不动。亦不废舍化众生事。佛子。假使有人。于遍虚空一一世界。悉以毛端。次第度量。诸佛能于一毛端处。结跏趺坐。尽未来劫。如一毛端处。一切毛端处。悉亦如是。佛子。假使十方一切世界。所有众生。一一众生。其身大小。悉与不可说佛刹微尘数世界量等。轻重亦尔。诸佛能以尔所众生。置一指端。尽于后际所有诸劫。一切指端。皆亦如是。尽持尔许一切众生。入遍虚空一一世界。尽于法界。悉使无余。而佛身心。曾无劳倦。是为诸佛第四大那罗延幢勇健法。佛子。一切诸佛。能于一身。化现不可说不可说佛刹微尘数头。一一头。化现不可说不可说佛刹微尘数舌。一一舌。化出不可说不可说佛刹微尘数差别音声。法界众生。靡不皆闻。一一音声。演不可说不可说佛刹微尘数修多罗藏。一一修多罗藏。演不可说不可说佛刹微尘数法。一一法。有不可说不可说佛刹微尘数文字句义。如是演说。尽不可说不可说佛刹微尘数劫。尽是劫已。复更演说。尽不可说不可说佛刹微尘数劫。如是次第。乃至尽于一切世界微尘数。尽一切众生心念数。未来际劫。犹可穷尽。如来化身。所转法轮。无有穷尽。所谓智慧演说法轮。断诸疑惑法轮。照一切法法轮。开无碍藏法轮。令无量众生。欢喜调伏法轮。开示一切。诸菩萨行法轮。高升圆满。大智慧日法轮。普然照世。智慧明灯法轮。辩才无畏。种种庄严法轮。如一佛身。以神通力。转如是等差别法轮。一切世法无能为谕。如是尽虚空界。一一毛端。分量之处。有不可说不可说佛刹微尘数世界。一一世界中。念念现不可说不可说佛刹微尘数化身。一一化身。皆亦如是。所说音声。文字句义。一一充满一切法界。其中众生。皆得解了。而佛言音。无变无断。无有穷尽。是为诸佛第五大那罗延幢勇健法。佛子。一切诸佛。皆以德相。庄严胸臆。犹若金刚不可损坏。菩提树下。结跏趺坐。魔王军众。其数无边。种种异形。甚可怖畏。众生见者。靡不惊慑。悉发狂乱。或时致死。如是魔众。遍满虚空。如来见之。心无恐怖。容色不变。一毛不竖。不动不乱。无所分别。离诸喜怒。寂然清净。住佛所住。具慈悲力。诸根调伏。心无所畏。非诸魔众。所能倾动。而能摧伏。一切魔军。皆使回心。稽首归依。然后复以三轮教化。令其悉发阿耨多罗三藐三菩提意。永不退转。是为诸佛第六大那罗延幢勇健法。佛子。一切诸佛。有无碍音。其音普遍十方世界。众生闻者。自然调伏。彼诸如来。所出音声。须弥卢等。一切诸山。不能为障。天宫龙宫。夜叉宫。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切诸宫。所不能障。一切世界。高大音声。亦不能障。随所应化。一切众生。靡不皆闻文字句义悉得解了。是为诸佛第七大那罗延幢勇健法。佛子。一切诸佛。心无障碍。于百千亿那由他不可说不可说劫。恒善清净。去来现在。一切诸佛。同一体性。无浊无翳。无我无我所。非内非外。了境空寂。不生妄想。无所依无所作。不住诸相。永断分别。本性清净。舍离一切攀缘忆念。于一切法。常无违诤。住于实际。离欲清净。入真法界。演说无尽。离量非量。所有妄想。绝为无为。一切言说。于不可说无边境界。悉已通达。无碍无尽。智慧方便。成就十力一切功德。庄严清净。演说种种无量诸法。皆与实相。不相违背。于诸法界三世诸法。悉等无异。究竟自在。入一切法最胜之藏。一切法门。正念不惑。安住十方一切佛刹。而无动转。得不断智。知一切法究竟无余。尽诸有漏。心善解脱。慧善解脱。住于实际。通达无碍。心常正定。于三世法。及以一切众生心行。一念了达。皆无障碍。是为诸佛第八大那罗延幢勇健法。佛子。一切诸佛。同一法身。境界无量身。功德无边身。世间无尽身。三界不染身。随念示现身。非实非虚平等清净身。无来无去无为不坏身。一相无相法自性身。无处无方遍一切身。神变自在。无边色相身。种种示现普入一切身。妙法方便身。智藏普照身。示法平等身。普遍法界身。无动无分别非有非无常清净身。非方便非不方便。非灭非不灭。随所应化一切众生。种种信解。而示现身。从一切功德宝所生身。具一切诸佛法真如身。本性寂静。无障碍身。成就一切无碍法身。遍住一切清净法界身。分形普遍一切世间身。无攀缘无退转。永解脱。具一切智。普了达身。是为诸佛第九大那罗延幢勇健法。佛子。一切诸佛。等悟一切诸如来法。等修一切诸菩萨行。若愿若智。清净平等。犹如大海。悉得满足。行力尊胜。未曾退怯。住诸三昧。无量境界。示一切道。劝善诫恶。智力第一。演法无畏。随有所问。悉能善答。智慧说法。平等清净。身语意行。悉皆无杂。住佛所住。诸佛种性。以佛智慧。而作佛事。住一切智。演无量法。无有根本。无有边际。神通智慧。不可思议。一切世间。无能解了。智慧深入。见一切法。微妙广大。无量无边。三世法门。咸善通达。一切世界。悉能开晓。以出世智。于诸世间。作不可说种种佛事。成不退智。入诸佛数。虽已证得不可言说离文字法。而能开示种种言辞。以普贤智。集诸善行。成就一念相应妙慧。于一切法。悉能觉了。如先所念。一切众生。皆依自乘。而施其法。一切诸法。一切世界。一切众生。一切三世。于法界内。如是境界。其量无边。以无碍智。悉能知见。佛子。一切诸佛。于一念顷。随所应化。出兴于世。住清净土。成等正觉。现神通力。开悟三世一切众生。心意及识。不失于时。佛子。众生无边。世界无边。法界无边。三世无边。诸佛最胜。亦无有边。悉现于中。成等正觉。以佛智慧。方便开悟。无有休息。佛子。一切诸佛。以神通力。现最妙身。住无边处。大悲方便。心无障碍。于一切时。常为众生。演说妙法。是为诸佛第十大那罗延幢勇健法。佛子。此一切诸佛大那罗延幢勇健法。无量无边不可思议。去来现在一切众生。及以二乘。不能解了。唯除如来神力所加。佛子。诸佛世尊。有十种决定法。何等为十。所谓一切诸佛。定从兜率寿尽下生。一切诸佛。定示受生。处胎十月。一切诸佛。定厌世俗。乐求出家。一切诸佛。决定坐于菩提树下。成等正觉。悟诸佛法。一切诸佛。定于一念。悟一切法。一切世界。示现神力。一切诸佛。定能应时。转妙法轮。一切诸佛。定能随彼。所种善根。应时说法。而为授记。一切诸佛。定能应时。为作佛事。一切诸佛。定能为诸成就菩萨。而授记别。一切诸佛。定能一念。普答一切众生所问。是为十。佛子。诸佛世尊。有十种速疾法。何等为十。所谓一切诸佛。若有见者。速得远离一切恶趣。一切诸佛。若有见者。速得圆满殊胜功德。一切诸佛。若有见者。速能成就广大善根。一切诸佛。若有见者。速得往生净妙天上。一切诸佛。若有见者。速能除断一切疑惑。一切诸佛。若已发菩提心。而得见者。速得成就广大信解。永不退转。能随所应。教化众生。若未发心。即能速发阿耨多罗三藐三菩提心。一切诸佛。若未入正位。而得见者。速入正位。一切诸佛。若有见者。速能清净世出世间。一切诸根。一切诸佛。若有见者。速得除灭一切障碍。一切诸佛。若有见者。速能获得无畏辩才。是为十。佛子。诸佛世尊。有十种应常忆念清净法。何等为十。所谓一切诸佛。过去因缘。一切菩萨。应常忆念。一切诸佛。清净胜行。一切菩萨。应常忆念。一切诸佛。满足诸度。一切菩萨。应常忆念。一切诸佛。成就大愿。一切菩萨。应常忆念。一切诸佛。积集善根。一切菩萨。应常忆念。一切诸佛。已具梵行。一切菩萨。应常忆念。一切诸佛。现成正觉。一切菩萨。应常忆念。一切诸佛。色身无量。一切菩萨。应常忆念。一切诸佛。神通无量。一切菩萨。应常忆念。一切诸佛。十力无畏。一切菩萨。应常忆念。是为十。佛子。诸佛世尊。有十种一切智住。何等为十。所谓一切诸佛。于一念中。悉知三世一切众生。心心所行。一切诸佛。于一念中。悉知三世一切众生。所集诸业。及业果报。一切诸佛。于一念中。悉知一切众生所宜。以三种轮。教化调伏。一切诸佛。于一念中。尽知法界一切众生。所有心相。于一切处。普现佛兴。令其得见。方便摄受。一切诸佛。于一念中。普随法界一切众生。心乐欲解。示现说法。令其调伏。一切诸佛。于一念中。悉知法界一切众生心之所乐。为现神力。一切诸佛。于一念中。遍一切处。随所应化一切众生。示现出兴。为说佛身。不可取着。一切诸佛。于一念中。普至法界一切处。一切众生。彼彼诸道。一切诸佛。于一念中。随诸众生。有忆念者。在在处处。无不往应。一切诸佛。于一念中。悉知一切众生解欲。为其示现无量色相。是为十。佛子。诸佛世尊。有十种无量不可思议佛三昧。何等为十。所谓一切诸佛。恒在正定。于一念中。遍一切处。普为众生。广说妙法。一切诸佛。恒在正定。于一念中。遍一切处。普为众生。说无我际。一切诸佛。恒住正定。于一念中。遍一切处。普入三世。一切诸佛。恒在正定。于一念中。遍一切处。普入十方。广大佛刹。一切诸佛。恒在正定。于一念中。遍一切处。普现无量。种种佛身。一切诸佛。恒在正定。于一念中。遍一切处。随诸众生种种心解。现身语意。一切诸佛。恒在正定。于一念中。遍一切处。说一切法离欲真际。一切诸佛。恒住正定。于一念中。遍一切处。演说一切缘起自性。一切诸佛。恒住正定。于一念中。遍一切处。示现无量世出世间。广大庄严。令诸众生。常得见佛。一切诸佛。恒住正定。于一念中。遍一切处。令诸众生。悉得通达一切佛法。无量解脱。究竟到于无上彼岸。是为十。佛子。诸佛世尊。有十种无碍解脱。何等为十。所谓一切诸佛。能于一尘。现不可说不可说诸佛。出兴于世。一切诸佛。能于一尘。现不可说不可说诸佛。转净法轮。一切诸佛。能于一尘。现不可说不可说众生。受化调伏。一切诸佛。能于一尘。现不可说不可说诸佛国土。一切诸佛。能于一尘。现不可说不可说菩萨授记。一切诸佛。能于一尘。现去来今一切诸佛。一切诸佛。能于一尘。现去来今诸世界种。一切诸佛。能于一尘。现去来今一切神通。一切诸佛。能于一尘。现去来今。一切众生。一切诸佛。能于一尘。现去来今一切佛事。是为十

大方广佛华严经卷第四十七大方广佛华严经卷第四十八

        于阗国三藏实叉难陀奉　制译

    如来十身相海品第三十四

尔时普贤菩萨摩诃萨。告诸菩萨言。佛子。今当为汝。演说如来所有相海。佛子。如来顶上。有三十二宝庄严大人相。其中。有大人相。名光照一切方普放无量大光明网。一切妙宝。以为庄严。宝发周遍。柔软密致。一一咸放摩尼宝光。充满一切无边世界。悉现佛身。色相圆满。是为一。次有大人相。名佛眼光明云。以摩尼王。种种庄严。出金色光。如眉间毫相。所放光明。其光普照一切世界。是为二。次有大人相。名充满法界云。上妙宝轮。以为庄严。放于如来福智灯明。普照十方一切法界。诸世界海。于中普现一切诸佛。及诸菩萨。是为三。次有大人相。名示现普照云。真金摩尼。种种庄严。其诸妙宝。咸放光明。照不思议诸佛国土。一切诸佛。于中出现。是为四。次有大人相。名放宝光明云。摩尼宝王。清净庄严。毗琉璃宝。以为华蕊。光照十方一切法界。于中普现种种神变。赞叹如来往昔所行。智慧功德。是为五。次有大人相。名示现如来遍法界大自在云。菩萨神变。宝焰摩尼。以为其冠。具如来力觉悟一切宝焰光轮。以为其鬘。其光普照十方世界。于中示现一切如来。坐于道场。一切智云。充满虚空无量法界。是为六。次有大人相。名如来普灯云。以能震动法界国土大自在宝海。而为庄严。放净光明。充满法界。于中普现十方诸菩萨功德海。过现未来。佛智慧幢海。是为七。次有大人相。名普照诸佛广大云。因陀罗宝如意王宝摩尼王宝。以为庄严。常放菩萨焰灯光明。普照十方一切世界。于中显现一切诸佛。众色相海。大音声海。清净力海。是为八。次有大人相。名圆满光明云。上妙琉璃摩尼王种种宝华。以为庄严。一切众宝。舒大焰网。充满十方一切世界。一切众生。悉见如来。现坐其前。赞叹诸佛。及诸菩萨。法身功德。令入如来清净境界。是为九。次有大人相。名普照一切菩萨行藏光明云。众宝妙华。以为庄严。宝光普照无量世界。宝焰普覆一切国土。十方法界。通达无碍。震动佛音。宣畅法海。是为十。次有大人相。名普光照耀云。毗琉璃。因陀罗。金刚摩尼宝。以为庄严。琉璃宝光。色相明彻。普照一切诸世界海出妙音声。充满法界。如是皆从诸佛智慧大功德海之所化现。是为十一。次有大人相。名正觉云。以杂宝华。而为庄严。其诸宝华。悉放光明。皆有如来坐于道场。充满一切无边世界。令诸世界。普得清净。永断一切妄想分别。是为十二。次有大人相。名光明照曜云。以宝焰藏海。心王摩尼。而为庄严。放大光明。光中显现无量菩萨及诸菩萨。所行之行。一切如来。智身法身。诸色相海。充满法界。是为十三。次有大人相。名庄严普照云。以金刚华。毗琉璃宝。而为庄严。放大光明。光中有大宝莲华座。具足庄严。弥覆法界。自然演说四菩萨行。其音普遍诸法界海。是为十四。次有大人相。名现佛三昧海行云。于一念中。示现如来无量庄严。普遍庄严一切法界。不思议世界海。是为十五。次有大人相。名变化海普照云。妙宝莲华如须弥山。以为庄严。众宝光明。从佛愿生。现诸变化。无有穷尽。是为十六。次有大人相。名一切如来解脱云。清净妙宝。以为庄严。放大光明。庄严一切佛师子座。示现一切诸佛色像。及无量佛法。诸佛刹海。是为十七。次有大人相。名自在方便普照云。毗琉璃华。真金莲华。摩尼王灯。妙法焰云。以为庄严。放一切诸佛。宝焰密云。清净光明。充满法界。于中普现一切妙好庄严之具。是为十八。次有大人相。名觉佛种性云。无量宝光。以为庄严。具足千轮。内外清净。从于往昔善根所生。其光遍照十方世界。发明智日。宣布法海。是为十九。次有大人相。名现一切如来相自在云。众宝璎珞。琉璃宝华。以为庄严。舒大宝焰。充满法界。于中普现等一切佛刹微尘数去来现在无量诸佛。如师子王。勇猛无畏。色相智慧。皆悉具足。是为二十。次有大人相。名遍照一切法界云。如来宝相。清净庄严。放大光明。普照法界。显现一切无量无边诸佛菩萨。智慧妙藏。是为二十一。次有大人相。名毗卢遮那如来相云。上妙宝华。及毗琉璃。清净妙月。以为庄严。悉放无量百千万亿。摩尼宝光。充满一切虚空法界。于中示现无量佛刹。皆有如来结跏趺坐。是为二十二。次有大人相。名普照一切佛光明云。众宝妙灯。以为庄严。放净光明。遍照十方一切世界。悉现诸佛转于法轮。是为二十三。次有大人相。名普现一切庄严云。种种宝焰。以为庄严。放净光明。充满法界。念念常现不可说不可说一切诸佛。与诸菩萨。坐于道场。是为二十四。次有大人相。名出一切法界音声云。摩尼宝海。上妙栴檀。以为庄严。舒大焰网。充满法界。其中普演微妙音声。示诸众生一切业海。是为二十五。次有大人相。名普照诸佛变化轮云。如来净眼。以为庄严。光照十方一切世界。于中普现去来今佛。所有一切庄严之具。复出妙音。演不思议。广大法海。是为二十六。次有大人相。名光照佛海云。其光普照一切世界。尽于法界。无所障碍。悉有如来结跏趺坐。是为二十七。次有大人相。名宝灯云。放于如来广大光明。普照十方一切法界。于中普现一切诸佛。及诸菩萨。不可思议。诸众生海。是为二十八。次有大人相。名法界无差别云。放于如来大智光明。普照十方诸佛国土。一切菩萨。道场众会。无量法海。于中普现种种神通。复出妙音。随诸众生心之所乐。演说普贤菩萨行愿。令其回向。是为二十九。次有大人相。名安住一切世界海普照云。放宝光明。充满一切虚空法界。于中普现净妙道场。及佛菩萨。庄严身相。令其见者。得无所见。是为三十。次有大人相。名一切宝清净光焰云。放于无量诸佛菩萨。摩尼妙宝。清净光明。普照十方一切法界。于中普现诸菩萨海。莫不具足如来神力。常游十方尽虚空界。一切刹网。是为三十一。次有大人相。名普照一切法界庄严云。最处于中。渐次隆起。阎浮檀金。因陀罗网。以为庄严。放净光云。充满法界。念念常现一切世界诸佛菩萨。道场众会。是为三十二。佛子。如来顶上。有如是三十二种大人相。以为严好。佛子。如来眉间。有大人相。名遍法界光明云。摩尼宝华。以为庄严。放大光明。具众宝色。犹如日月洞彻清净。其光普照十方国土。于中显现一切佛身。复出妙音。宣畅法海。是为三十三。如来眼。有大人相。名自在普见云。以众妙宝。而为庄严。摩尼宝光。清净映彻。普见一切。皆无障碍。是为三十四。如来鼻。有大人相。名一切神通智慧云。清净妙宝。以为庄严。众宝色光。弥覆其上。于中出现无量化佛。坐宝莲华。往诸世界。为一切菩萨。一切众生。演不思议。诸佛法海。是为三十五。如来舌。有大人相。名示现音声影像云。众色妙宝。以为庄严。宿世善根之所成就。其舌广长。遍覆一切诸世界海。如来若或熙怡微笑。必放一切摩尼宝光。其光普照十方法界。能令一切心得清凉。去来现在。所有诸佛。皆于光中。炳然显现。悉演广大微妙之音。遍一切刹。住无量劫。是为三十六。如来舌。复有大人相。名法界云。其掌安平。众宝为严。放妙宝光。色相圆满。犹如眉间。所放光明。其光普照一切佛刹。唯尘所成。无有自性。光中复现无量诸佛。咸发妙音。说一切法。是为三十七。如来舌端。有大人相。名照法界光明云。如意宝王。以为庄严。自然恒出金色宝焰。于中影现一切佛海。复震妙音。充满一切无边世界。一一音中。具一切音。悉演妙法。听者心悦。经无量劫。玩味不忘。是为三十八。如来舌端。复有大人相。名照耀法界云。摩尼宝王。以为严饰。演众色相。微妙光明。充满十方无量国土。尽于法界。靡不清净。于中悉有无量诸佛。及诸菩萨各吐妙音。种种开示。一切菩萨。现前听受。是为三十九。如来口上齶。有大人相。名示现不思议法界云。因陀罗宝。毗琉璃宝。以为庄严放香灯焰。清净光云。充满十方一切法界。示现种种神通方便。普于一切诸世界海。开演甚深不思议法。是为四十。如来口右辅下牙。有大人相。名佛牙云。众宝摩尼。卍字相轮。以为庄严。放大光明。普照法界。于中普现一切佛身。周流十方。开悟群生。是为四十一。如来口右辅上牙。有大人相。名宝焰弥卢藏云。摩尼宝藏。以为庄严。放金刚香焰。清净光明。一一光明。充满法界。示现一切诸佛神力。复现一切十方世界。净妙道场。是为四十二。如来口左辅下牙。有大人相。名宝灯普照云。一切妙宝。舒华发香。以为庄严。放灯焰云。清净光明。充满一切诸世界海。于中显现一切诸佛。坐莲华藏师子之座。诸菩萨众。所共围绕。是为四十三。如来口左辅上牙。有大人相。名照现如来云。清净光明。阎浮檀金。宝网宝华。以为庄严。放大焰轮。充满法界。于中普现一切诸佛。以神通力。于虚空中。流布法乳法灯法宝。教化一切诸菩萨众。是为四十四。如来齿。有大人相。名普现光明云。一一齿间。相海庄严。若微笑时。悉放光明。具众宝色。摩尼宝焰。右旋宛转。流布法界。靡不充满。演佛言音。说普贤行。是为四十五。如来唇。有大人相。名影现一切宝光云。放阎浮檀。真金色。莲华色。一切宝色。广大光明。照于法界。悉令清净。是为四十六。如来颈。有大人相。名普照一切世界云。摩尼宝王。以为庄严。绀蒲成就。柔软细滑。放毗卢遮那清净光明。充满十方一切世界。于中普现一切诸佛。是为四十七。如来右肩。有大人相。名佛广大一切宝云。放一切宝色。真金色。莲华色光明。成宝焰网。普照法界。于中普现一切菩萨。是为四十八。如来右肩。复有大人相。名最胜宝普照云。其色清净。如阎浮金。放摩尼光充满法界。于中普现一切菩萨。是为四十九。如来左肩。有大人相。名最胜光照法界云。犹如顶上。及以眉间。种种庄严。放阎浮檀金。及莲华色。众宝光明。成大焰网。充满法界。于中示现一切神力。是为五十。如来左肩。复有大人相。名光明遍照云。其相右旋。阎浮檀金色。摩尼宝王。以为庄严。放众宝华。香焰光明。充遍法界。于中普现一切诸佛。及以一切严净国土。是为五十一。如来左肩。复有大人相。名普照耀云。其相右旋。微密庄严。放佛灯焰云。清净光明。充遍法界。于中显现一切菩萨。种种庄严。悉皆妙好。是为五十二。如来胸臆。有大人相。形如卍字。名吉祥海云。摩尼宝华。以为庄严。放一切宝色。种种光焰轮。充满法界。普令清净。复出妙音。宣畅法海。是为五十三。吉祥相右边。有大人相。名示现光照云。因陀罗网。以为庄严。放大光轮。充满法界。于中普现无量诸佛。是为五十四。吉祥相右边复有大人相。名普现如来云。以诸菩萨摩尼宝冠。而为庄严。放大光明。普照十方一切世界。悉令清净。于中示现去来今佛。坐于道场。普现神力。广宣法海。是为五十五。吉祥相右边。复有大人相。名开敷华云。摩尼宝华。以为庄严。放宝香焰灯。清净光明。状如莲华。充满世界。是为五十六。吉祥相右边。复有大人相。名可悦乐金色云。以一切宝。心王藏摩尼王。而为庄严。放净光明。照于法界。于中普现。犹如佛眼。广大光明。摩尼宝藏。是为五十七。吉祥相右边

复有大人相。名佛海云。毗琉璃宝。香灯华鬘。以为庄严。放满虚空。摩尼宝王。香灯大焰。清净光明。充遍十方一切国土。于中普现道场众会。是为五十八。吉祥相左边。有大人相。名示现光明云。无数菩萨。坐宝莲华。以为庄严。放摩尼王。种种间错。宝焰光明。普净一切诸法界海。于中示现无量诸佛。及佛妙音。演说诸法。是为五十九。吉祥相左边。复有大人相。名示现遍法界光明云。摩尼宝海。以为庄严。放大光明。遍一切刹。于中普现诸菩萨众。是为六十。吉祥相左边。复有大人相。名普胜云。日光明摩尼王宝轮鬘。而为庄严。放大光焰。充满法界。诸世界海。于中示现一切世界。一切如来。一切众生。是为六十一。吉祥相左边。复有大人相。名转法轮妙音云。一切法灯。清净香蕊。以为庄严。放大光明。充满法界。于中普现一切诸佛。所有相海。及以心海。是为六十二。吉祥相左边。复有大人相。名庄严云以去来今一切佛海。而为庄严。放净光明。严净一切诸佛国土。于中普现十方一切诸佛菩萨。及佛菩萨。所行之行。是为六十三。如来右手。有大人相。名海照云。众宝庄严。恒放月焰清净光明。充满虚空。一切世界。发大音声。叹美一切诸菩萨行。是为六十四。如来右手。复有大人相。名影现照耀云。以毗琉璃。帝青摩尼宝华。而为庄严。放大光明。普照十方菩萨所住。莲华藏。摩尼藏等。一切世界。于中悉现无量诸佛。以净法身。坐菩提树。震动一切十方国土。是为六十五。如来右手。复有大人相。名灯焰鬘普严净云。毗卢遮那宝。以为庄严。放大光明。成变化网。于中普现诸菩萨众。咸戴宝冠。演诸行海。是为六十六。如来右手。复有大人相。名普现一切摩尼云。莲华焰灯。而为庄严。放海藏光。充遍法界。于中普现无量诸佛。坐莲华座。是为六十七。如来右手。复有大人相。名光明云。摩尼焰海。以为庄严。放众宝焰。香焰华焰。清净光明。充满一切诸世界网。于中普现诸佛道场。是为六十八。如来左手。有大人相。名毗琉璃清净灯云。宝地妙色。以为庄严。放于如来。金色光明。念念常现一切上妙庄严之具。是为六十九。如来左手。复有大人相。名一切刹智慧灯音声云。以因陀罗网。金刚华。而为庄严。放阎浮檀金。清净光明。普照十方一切世界。是为七十。如来左手。复有大人相。名安住宝莲华光明云。众宝妙华。以为庄严。放大光明。如须弥灯。普照十方一切世界。是为七十一。如来左手。复有大人相。名遍照法界云。以妙宝鬘宝轮宝瓶。因陀罗网。及众妙相。以为庄严。放大光明。普照十方一切国土。于中示现一切法界。一切世界海。一切如来。坐莲华座。是为七十二。如来右手指。有大人相。名现诸劫刹海旋云。水月焰藏摩尼王。一切宝华。以为庄严。放大光明。充满法界。其中恒出微妙音声。满十方刹。是为七十三。如来左手指。有大人相。名安住一切宝云。以帝青金刚宝。而为庄严。放摩尼王。众宝光明。充满法界。其中普现一切诸佛。及诸菩萨。是为七十四。如来右手掌。有大人相。名照耀云。以摩尼王。千辐宝轮。而为庄严。放宝光明。其光右旋。充满法界。于中普现一切诸佛。一一佛身。光焰炽然。说法度人。净诸世界。是为七十五。如来左手掌。有大人相。名焰轮普增长化现法界道场云。以日光摩尼王。千辐轮。而为庄严。放大光明。充满一切诸世界海。于中示现一切菩萨。演说普贤所有行海。普入一切诸佛国土。各各开悟无量众生。是为七十六。如来阴藏。有大人相。名普流出佛音声云。一切妙宝。以为庄严。放摩尼灯。华焰光明。其光炽盛。具众宝色。普照一切虚空法界。其中普现一切诸佛游行往来。处处周遍。是为七十七。如来右臀。有大人相。名宝灯鬘普照云。诸摩尼宝。以为庄严。放不思议宝焰光明。弥布十方一切法界。与虚空法界。同为一相。而能出生一切诸相。一一相中。悉现诸佛自在神变。是为七十八。如来左臀。有大人相。名示现一切法界海光明弥覆虚空云。犹如莲华。清净妙宝。以为严饰。放光明网。遍照十方。一切法界。于中普现种种相云。是为七十九。如来右髀。有大人相。名普现云。以众色摩尼。而为庄严。其髀与腨。上下相称。放摩尼焰。妙法光明。于一念中。能普示现一切宝王。游步相海。是为八十。如来左髀。有大人相。名现一切佛无量相海云。一切宝海。随顺安住。以为庄严。广大游行。放净光明。普照众生。悉使希求无上佛法。是为八十一。如来右边。伊尼延鹿王腨。有大人相。名一切虚空法界云。光明妙宝。以为庄严。其相圆直。善能游步。放阎浮金色。清净光明。遍照一切诸佛世界。发大音声。普皆震动。复现一切诸佛国土。住于虚空。宝焰庄严。无量菩萨。从中化现。是为八十二。如来左边。伊尼延鹿王腨。有大人相。名庄严海云。色如真金。能遍游行一切佛刹。放一切宝清净光明。充满法界。施作佛事。是为八十三。如来宝腨上毛。有大人相。名普现法界影像云。其毛右旋。一一毛端。放宝光明。充满十方一切法界。示现一切诸佛神力。其诸毛孔。悉放光明。一切佛刹。于中显现。是为八十四。如来足下。有大人相。名一切菩萨海安住云。色如金刚。阎浮檀金。清净莲华。放宝光明。普照十方诸世界海。宝香焰云。处处周遍。举足将步。香气周流。具众宝色。充满法界。是为八十五。如来右足上。有大人相。名普照一切光明云。一切众宝。以为庄严。放大光明。充满法界。示现一切诸佛菩萨。是为八十六。如来左足上。有大人相。名普现一切诸佛云。宝藏摩尼。以为庄严。放宝光明。于念念中。现一切佛。神通变化。及其法海。所坐道场。尽未来际劫。无有间断。是为八十七。如来右足指间。有大人相。名光照一切法界海云。须弥灯摩尼王。千辐焰轮。种种庄严。放大光明。充满十方一切法界。诸世界海。于中普现一切诸佛。所有种种。宝庄严相。是为八十八。如来左足指间。有大人相。名现一切佛海云。摩尼宝华。香焰灯鬘。一切宝轮。以为庄严。恒放宝海清净光明。充满虚空。普及十方一切世界。于中示现一切诸佛。及诸菩萨。圆满音声。卍字等相。利益无量一切众生。是为八十九。如来右足跟。有大人相。名自在照耀云。帝青宝末。以为庄严。常放如来。妙宝光明。其光妙好。充满法界。皆同一相。无有差别。于中示现一切诸佛。坐于道场。演说妙法。是为九十。如来左足跟。有大人相。名示现妙音演说诸法海云。以变化海摩尼宝。香焰海须弥华摩尼宝。及毗琉璃。而为庄严。放大光明。充满法界。于中普现诸佛神力。是为九十一。如来右足趺。有大人相。名示现一切庄严光明云。众宝所成。极妙庄严。放阎浮檀金色。清净光明。普照十方一切法界。其光明相。犹如大云。普覆一切诸佛道场。是为九十二。如来左足趺。有大人相。名现众色相云。以一切月焰藏。毗卢遮那宝。因陀罗尼罗宝。而为庄严。念念游行诸法界海。放摩尼灯。香焰光明。其光遍满一切法界。是为九十三。如来右足四周。有大人相。名普藏云。因陀罗尼罗金刚宝。以为庄严。放宝光明。充满虚空。于中示现一切诸佛坐于道场。摩尼宝王师子之座。是为九十四。如来左足四周。有大人相。名光明遍照法界云。摩尼宝华。以为庄严。放大光明。充满法界。平等一相。于中示现一切诸佛。及诸菩萨。自在神力。以大妙音。演说法界。无尽法门。是为九十五。如来右足指端。有大人相。名示现庄严云。甚可爱乐。阎浮檀清净真金。以为庄严。放大光明。充满十方一切法界。于中示现一切诸佛。及诸菩萨。无尽法海。种种功德。神通变化。是为九十六。如来左足指端。有大人相。名现一切佛神变云。不思议佛光明。月焰普香。摩尼宝焰轮。以为庄严。放众宝色。清净光明。充满一切。诸世界海。于中示现一切诸佛。及诸菩萨。演说一切诸佛法海。是为九十七。佛子。毗卢遮那如来。有如是等。十华藏世界海微尘数。大人相。一一身分。众宝妙相。以为庄严

    大方广佛华严经如来随好光明功德品第三十五

尔时世尊。告宝手菩萨言。佛子。如来应正等觉。有随好。名圆满王。此随好中。出大光明。名为炽盛。七百万阿僧祇光明。而为眷属。佛子。我为菩萨时。于兜率天宫。放大光明。名光幢王。照十佛刹微尘数世界。彼世界中。地狱众生。遇斯光者。众苦休息。得十种清净眼。耳鼻舌身意。亦复如是。咸生欢喜。踊跃称庆。从彼命终。生兜率天。天中有鼓。名甚可爱乐。彼天生已。此鼓发音。而告之言。诸天子。汝以心不放逸。于如来所。种诸善根。往昔亲近众善知识。毗卢遮那。大威神力。于彼命终。来生此天。佛子。菩萨足下千辐轮。名光明普照王。此有随好。名圆满王。常放四十种光明。中有一光。名清净功德。能照亿那由他佛刹微尘数世界。随诸众生种种业行。种种欲乐。皆令成熟。阿鼻地狱。极苦众生。遇斯光者。皆悉命终。生兜率天。既生天已。闻天鼓音。而告之言。善哉善哉。诸天子。毗卢遮那菩萨。入离垢三昧。汝当敬礼。尔时诸天子。闻天鼓音。如是劝诲。咸生是念。奇哉希有。何因发此微妙之音。是时天鼓。告诸天子言。我所发声。诸善根力之所成就。诸天子。如我说我。而不着我。不着我所。一切诸佛。亦复如是。自说是佛。不着于我。不着我所。诸天子。如我音声。不从东方来。不从南西北方四维上下来。业报成佛。亦复如是。非十方来。诸天子。譬如汝等。昔在地狱。地狱及身。非十方来。但由于汝颠倒恶业。愚痴缠缚。生地狱身。此无根本。无有来处。诸天子。毗卢遮那菩萨。威德力故。放大光明。而此光明。非十方来。诸天子。我天鼓音。亦复如是。非十方来。但以三昧善根力故。般若波罗蜜威德力故。出生如是清净音声。示现如是种种自在。诸天子。譬如须弥山王。有三十三天。上妙宫殿。种种乐具。而此乐具。非十方来。我天鼓音。亦复如是。非十方来。诸天子。譬如亿那由他佛刹微尘数世界。尽末为尘。我为如是尘数众生。随其所乐。而演说法。令大欢喜。然我于彼。不生疲厌。不生退怯。不生憍慢。不生放逸。诸天子。毗卢遮那菩萨。住离垢三昧。亦复如是。于右手掌。一随好中。放一光明。出现无量。自在神力。一切声闻。辟支佛。尚不能知。况诸众生。诸天子。汝当往诣彼菩萨所。亲近供养。勿复贪着五欲乐具。着五欲乐。障诸善根。诸天子。譬如劫火。烧须弥山。悉令除尽。无余可得。贪欲缠心。亦复如是。终不能生念佛之意。诸天子。汝等应当知恩报恩。诸天子。其有众生。不知报恩。多遭横死。生于地狱。诸天子。汝等昔在地狱之中。蒙光照身。舍彼生此。汝等今者。宜疾回向。增长善根。诸天子。如我天鼓。非男非女。而能出生无量无边不思议事。汝天子天女。亦复如是。非男非女。而能受用种种上妙。宫殿园林。如我天鼓。不生不灭。色受想行识。亦复如是。不生不灭。汝等若能于此悟解。应知则入无依印三昧。时诸天子。闻是音已。得未曾有。即皆化作一万华云。一万香云。一万音乐云。一万幢云。一万盖云。一万歌赞云。作是化已。即共往诣毗卢遮那菩萨。所住宫殿。合掌恭敬。于一面立。欲申瞻觐。而不得见。时有天子。作如是言。毗卢遮那菩萨。已从此没。生于人间。净饭王家。乘栴檀楼阁。处摩耶夫人胎。时诸天子。以天眼。观见菩萨身。处在人间净饭王家。梵天欲天。承事供养。诸天子众。咸作是念。我等若不往菩萨所问讯起居。乃至一念。于此天宫。而生爱着。则为不可。时一一天子。与十那由他眷属。欲下阎浮提。时天鼓中。出声告言。诸天子。菩萨摩诃萨。非此命终。而生彼间。但以神通。随诸众生心之所宜。令其得见。诸天子。如我今者。非眼所见。而能出声。菩萨摩诃萨。入离垢三昧。亦复如是。非眼所见。而能处处。示现受生。离分别。除憍慢。无染着。诸天子。汝等应发阿耨多罗三藐三菩提心。净治其意。住善威仪。悔除一切业障烦恼障。报障见障。以尽法界。众生数等身。以尽法界。众生数等头。以尽法界。众生数等舌。以尽法界。众生数等。善身业。善语业。善意业。悔除所有诸障过恶。时诸天子。闻是语已。得未曾有。心大欢喜。而问之言。菩萨摩诃萨。云何悔除一切过恶。尔时天鼓。以菩萨三昧善根力故。发声告言。诸天子。菩萨。知诸业不从东方来。不从南西北方四维上下来。而共积集。止住于心。但从颠倒生。无有住处。菩萨如是。决定明见。无有疑惑。诸天子。如我天鼓。说业说报。说行说戒。说喜说安。说诸三昧。诸佛菩萨。亦复如是。说我说我所。说众生说贪恚痴。种种诸业。而实无我。无有我所。诸所作业。六趣果报。十方推求。悉不可得。诸天子。譬如我声。不生不灭。造恶诸天。不闻余声。唯闻以地狱觉悟之声。一切诸业。亦复如是。非生非灭。随有修集。则受其报。诸天子。如我天鼓所出音声。于无量劫。不可穷尽。无有间断。若来若去。皆不可得。诸天子。若有去来。则有断常。一切诸佛。终不演说有断常法。除为方便。成熟众生。诸天子。譬如我声。于无量世界。随众生心。皆使得闻。一切诸佛。亦复如是。随众生心。悉令得见。诸天子。如有玻璃镜。名为能照。清净鉴彻。与十世界。其量正等。无量无边诸国土中。一切山川。一切众生。乃至地狱。畜生饿鬼。所有影像。皆于中现。诸天子。于汝意云何。彼诸影像。可得说言来入镜中。从镜去不。答言不也。诸天子。一切诸业。亦复如是。虽能出生诸业果报。无来去处。诸天子。譬如幻师。幻惑人眼。当知诸业。亦复如是。若如是知。是真实忏悔。一切罪恶悉得清净。说此法时。百千亿那由他佛刹微尘数世界中。兜率陀诸天子。得无生法忍。无量不思议阿僧祇六欲诸天子。发阿耨多罗三藐三菩提心。六欲天中。一切天女。皆舍女身。发于无上菩提之意。尔时诸天子。闻说普贤广大回向。得十地故。获诸力庄严三昧故。以众生数等清净三业。悔除一切诸重障故。即见百千亿那由他佛刹微尘数。七宝莲华。一一华上。皆有菩萨。结跏趺坐。放大光明。彼诸菩萨。一一随好。放众生数等光明。彼光明中。有众生数等诸佛。结跏趺坐。随众生心。而为说法。而犹未现离垢三昧少分之力

尔时彼诸天子。以上众华。复于身上。一一毛孔。化作众生数等众妙华云。供养毗卢遮那如来。持以散佛。一切皆于佛身上住。其诸香云。普雨无量佛刹。微尘数世界。若有众生。身蒙香者。其身安乐。譬如比丘。入第四禅。一切业障。皆得销灭。若有闻者。彼诸众生于色声香味触。其内具有五百烦恼。其外亦有五百烦恼。贪行多者。二万一千。嗔行多者。二万一千。痴行多者。二万一千。等分行者。二万一千。了知如是悉是虚妄。如是知已。成就香幢云。自在光明。清净善根。若有众生。见其盖者。种一清净金网转轮王一恒河沙善根。佛子。菩萨住此转轮王位。于百千亿那由他佛刹微尘数世界中。教化众生。佛子。譬如明镜世界月智如来。常有无量诸世界中。比丘比丘尼。优婆塞优婆夷等。化现其身。而来听法。广为演说本生之事。未曾一念。而有间断。若有众生。闻其佛名。必得往生彼佛国土。菩萨安住清净金网转轮王位。亦复如是。若有暂得遇其光明。必获菩萨第十地位。以先修行善根力故。佛子。如得初禅。虽未命终。见梵天处所有宫殿。而得受于梵世安乐。得诸禅者。悉亦如是。菩萨摩诃萨。住清净金网转轮王位。放摩尼髻。清净光明。若有众生。遇斯光者。皆得菩萨第十地位。成就无量智慧光明。得十种清净眼。乃至十种清净意。具足无量甚深三昧。成就如是清净肉眼。佛子。假使有人。以亿那由他佛刹。碎为微尘。一尘一刹。复以尔许微尘数佛刹。碎为微尘。如是微尘。悉置左手。持以东行。过尔诸微尘数世界。乃下一尘。如是东行。尽此微尘。南西北方四维上下。亦复如是。如是十方所有世界。若着微尘。及不著者。悉以集成一佛国土。宝手。于汝意云何。如是佛土。广大无量可思议不。答曰不也。如是佛土。广大无量。希有奇特。不可思议。若有众生。闻此譬谕。能生信解。当知更为希有奇特。佛言宝手。如是如是。如汝所说。若有善男子善女人。闻此譬谕。而生信者。我授彼记。决定当成阿耨多罗三藐三菩提。当获如来无上智慧。宝手设复有人。以千亿佛刹微尘数。如上所说。广大佛土。末为微尘。以此微尘。依前譬谕。一一下尽。乃至集成一佛国土。复末为尘。如是次第。展转乃至经八十返。如是一切广大佛土。所有微尘。菩萨业报。清净肉眼。于一念中。悉能明见。亦见百亿广大佛刹微尘数佛。如玻璃镜清净光明。照十佛刹微尘数世界。宝手如是。皆是清净金网转轮王。甚深三昧福德善根之所成就

大方广佛华严经卷第四十八大方广佛华严经卷第四十九

        于阗国三藏实叉难陀奉　制译

    普贤行品第三十六

尔时普贤菩萨摩诃萨。复告诸菩萨大众言。佛子。如向所演。此但随众生根器所宜。略说如来少分境界。何以故。诸佛世尊。为诸众生。无智作恶。计我我所。执着于身。颠倒疑惑。邪见分别。与诸结缚。恒共相应。随生死流。远如来道故。出兴于世。佛子。我不见一法为大过失。如诸菩萨。于他菩萨。起嗔心者。何以故。佛子。若诸菩萨。于余菩萨。起嗔恚心。即成就百万障门故。何等为百万障。所谓不见菩提障。不闻正法障。生不净世界障。生诸恶趣障。生诸难处障。多诸疾病障。多被谤毁障。生顽钝诸趣障。坏失正念障。阙少智慧障。眼障耳障。鼻障舌障。身障意障。恶知识障。恶伴党障。乐习小乘障。乐近凡庸障。不信乐大威德人障。乐与离正见人同住障。生外道家障。住魔境界障。离佛正教障。不见善友障。善根留难障。增不善法障。得下劣处障。生边地障。生恶人家障。生恶神中障。生恶龙恶夜叉。恶乾闼婆。恶阿修罗。恶迦楼罗。恶紧那罗。恶摩睺罗伽。恶罗刹中障。不乐佛法障。习童蒙法障。乐着小乘障。不乐大乘障。性多惊怖障。心常忧恼障。爱着生死障。不专佛法障。不喜见闻佛自在神通障。不得菩萨诸根障。不行菩萨净行障。退怯菩萨深心障。不生菩萨大愿障。不发一切智心障。于菩萨行懈怠障。不能净治诸业障。不能摄取大福障。智力不能明利障。断于广大智慧障。不护持菩萨诸行障。乐诽谤一切智语障。远离诸佛菩提障。乐住众魔境界障。不专修佛境界障。不决定发菩萨弘誓障。不乐与菩萨同住障。不求菩萨善根障。性多见疑障。心常愚闇障。不能行菩萨平等施故起不舍障。不能持如来戒故起破戒障。不能入堪忍门故起愚痴恼害嗔恚障。不能行菩萨大精进故起懈怠垢障。不能得诸三昧故起散乱障。不修治般若波罗蜜故起恶慧障。于处非处中无善巧障。于度众生中无方便障。于菩萨智慧中不能观察障。于菩萨出离法中不能了知障。不成就菩萨十种广大眼故。眼如生盲障。耳不闻无碍法故口如哑羊障。不具相好故鼻根破坏障。不能辨了众生语言故成就舌根障。轻贱众生故成就身根障。心多狂乱故成就意根障。不持三种律仪故成就身业障。恒起四种过失故成就语业障。多生贪嗔邪见故成就意业障。贼心求法障。断绝菩萨境界障。于菩萨勇猛法中心生退怯障。于菩萨出离道中心生懒惰障。于菩萨智慧光明门中心生止息障。于菩萨念力中心生劣弱障。于如来教法中不能住持障。于菩萨离生道不能亲近障。于菩萨无失坏道不能修习障。随顺二乘正位障。远离三世诸佛菩萨种性障。佛子。若菩萨。于诸菩萨。起一嗔心。则成就如是等百万障门。何以故。佛子。我不见有一法为大过恶。如诸菩萨。于余菩萨。起嗔心者。是故。诸菩萨摩诃萨。欲疾满足诸菩萨行。应勤修十种法。何等为十。所谓心不弃舍一切众生。于诸菩萨。生如来想。永不诽谤一切佛法。知诸国土。无有穷尽。于菩萨行。深生信乐。不舍平等虚空法界。菩提之心。观察菩提。入如来力。精勤修习。无碍辩才。教化众生。无有疲厌。住一切世界。心无所著。是为十。佛子。菩萨摩诃萨。安住此十法已。则能具足十种清净。何等为十。所谓通达甚深法清净。亲近善知识清净。护持诸佛法清净。了达虚空界清净。深入法界清净。观察无边心清净。与一切菩萨同善根清净。不着诸劫清净。观察三世清净。修行一切诸佛法清净。是为十。佛子。菩萨摩诃萨。住此十法已。则具足十种广大智。何等为十。所谓知一切众生心行智。知一切众生业报智。知一切佛法智。知一切佛法深密理趣智。知一切陀罗尼门智。知一切文字辩才智。知一切众生语言音声辞辩善巧智。于一切世界中普现其身智。于一切众会中普现影像智。于一切受生处中具一切智智。是为十。佛子。菩萨摩诃萨。住此十智已。则得入十种普入。何等为十。所谓一切世界入一毛道。一毛道入一切世界。一切众生身入一身。一身入一切众生身。不可说劫入一念。一念入不可说劫。一切佛法入一法。一法入一切佛法。不可说处入一处。一处入不可说处。不可说根入一根。一根入不可说根。一切根入非根。非根入一切根。一切想入一想。一想入一切想。一切言音入一言音。一言音入一切言音。一切三世入一世。一世入一切三世。是为十。佛子。菩萨摩诃萨。如是观察已。则住十种胜妙心。何等为十。所谓住一切世界语言非语言胜妙心。住一切众生想念无所依止胜妙心。住究竟虚空界胜妙心。住无边法界胜妙心。住一切深密佛法胜妙心。住甚深无差别法胜妙心。住除灭一切疑惑胜妙心。住一切世平等无差别胜妙心。住三世诸佛平等胜妙心。住一切诸佛力无量胜妙心。是为十。佛子。菩萨摩诃萨。住此十种胜妙心已。则得十种佛法善巧智。何等为十。所谓了达甚深佛法善巧智。出生广大佛法善巧智。宣说种种佛法善巧智。证入平等佛法善巧智。明了差别佛法善巧智。悟解无差别佛法善巧智。深入庄严佛法善巧智。一方便入佛法善巧智。无量方便入佛法善巧智。知无边佛法无差别善巧智。以自心自力于一切佛法不退转善巧智。是为十。佛子。菩萨摩诃萨。闻此法已。咸应发心。恭敬受持。何以故。菩萨摩诃萨。持此法者。少作功力。疾得阿耨多罗三藐三菩提。皆得具足一切佛法。悉与三世诸佛法等

尔时。佛神力故。法如是故。十方各有十不可说百千亿那由他佛刹微尘数世界。六种震动。雨出过诸天一切华云。香云末香云。衣盖幢幡。摩尼宝等。及以一切庄严具云。雨众妓乐云。雨诸菩萨云。雨不可说如来色相云。雨不可说赞叹如来善哉云。雨如来音声充满一切法界云。雨不可说庄严世界云。雨不可说增长菩提云。雨不可说光明照耀云。雨不可说神力说法云。如此世界四天下。菩提树下。菩提场。菩萨宫殿中。见于如来成等正觉。演说此法。十方一切诸世界中。悉亦如是。尔时。佛神力故。法如是故。十方各过十不可说佛刹微尘数世界外。有十佛刹微尘数菩萨摩诃萨。来诣此土。充满十方。作如是言。善哉善哉。佛子。乃能说此诸佛如来最大誓愿。授记深法。佛子。我等一切。同名普贤。各从普胜世界。普幢自在如来所。来诣此土。悉以佛神力故。于一切处。演说此法。如此众会。如是所说。一切平等无有增减。我等皆承佛威神力。来此道场。为汝作证。如此道场。我等十佛刹。微尘数菩萨。而来作证。十方一切诸世界中。悉亦如是

尔时。普贤菩萨摩诃萨。以佛神力。自善根力。观察十方。洎乎法界。欲开示菩萨行。欲宣说如来菩提界。欲说大愿界。欲说一切世界劫数。欲明诸佛随时出现。欲说如来随根熟众生出现令其供养。欲明如来出世功不唐捐。欲明所种善根。必获果报。欲明大威德菩萨为一切众生现形说法令其开悟。而说颂言

  汝等应欢喜　　舍离于诸盖
  一心恭敬听　　菩萨诸愿行
  往昔诸菩萨　　最胜人师子
  如彼所修行　　我当次第说
  亦说诸劫数　　世界并诸业
  及以无等尊　　于彼而出兴
  如是过去佛　　大愿出于世
  云何为众生　　灭除诸苦恼
  一切论师子　　所行相续满
  得佛平等法　　一切智境界
  见于过去世　　一切人师子
  放大光明网　　普照十方界
  思惟发是愿　　我当作世灯
  具足佛功德　　十力一切智
  一切诸众生　　贪恚痴炽然
  我当悉救脱　　令灭恶道苦
  发如是誓愿　　坚固不退转
  具修菩萨行　　获十无碍力
  如是誓愿已　　修行无退怯
  所作皆不虚　　说名论师子
  于一贤劫中　　千佛出于世
  彼所有普眼　　我当次第说
  如一贤劫中　　无量劫亦然
  彼未来佛行　　我当分别说
  如一佛刹种　　无量刹亦然
  未来十力尊　　诸行我今说
  诸佛次兴世　　随愿随名号
  随彼所得记　　随其所寿命
  随所修正法　　专求无碍道
  随所化众生　　正法住于世
  随所净佛刹　　众生及法轮
  演说时非时　　次第净群生
  随诸众生业　　所行及信解
  上中下不同　　化彼令修习
  入于如是智　　修其最胜行
  常作普贤业　　广度诸众生
  身业无障碍　　语业悉清净
  意行亦如是　　三世靡不然
  菩萨如是行　　究竟普贤道
  出生净智日　　普照于法界
  未来世诸劫　　国土不可说
  一念悉了知　　于彼无分别
  行者能趣入　　如是最胜地
  此诸菩萨法　　我当说少分
  智慧无边际　　通达佛境界
  一切皆善入　　所行不退转
  具足普贤慧　　成满普贤愿
  入于无等智　　我当说彼行
  于一微尘中　　悉见诸世界
  众生若闻者　　迷乱心发狂
  如于一微尘　　一切尘亦然
  世界悉入中　　如是不思议
  一一尘中有　　十方三世法
  趣刹皆无量　　悉能分别知
  一一尘中有　　无量种佛刹
  种种皆无量　　于一靡不知
  法界中所有　　种种诸异相
  趣类各差别　　悉能分别知
  深入微细智　　分别诸世界
  一切劫成坏　　悉能明了说
  知诸劫修短　　三世即一念
  众行同不同　　悉能分别知
  深入诸世界　　广大非广大
  一身无量刹　　一刹无量身
  十方中所有　　异类诸世界
  广大无量相　　一切悉能知
  一切三世中　　无量诸国土
  具足甚深智　　悉了彼成败
  十方诸世界　　有成或有坏
  如是不可说　　贤德悉深了
  或有诸国土　　种种地严饰
  诸趣亦复然　　斯由业清净
  或有诸世界　　无量种杂染
  斯由众生感　　一切如其行
  无量无边刹　　了知即一刹
  如是入诸刹　　其数不可知
  一切诸世界　　悉入一刹中
  世界不为一　　亦复无杂乱
  世界有仰覆　　或高或复下
  皆是众生想　　悉能分别知
  广博诸世界　　无量无有边
  知种种是一　　知一是种种
  普贤诸佛子　　能以普贤智
  了知诸刹数　　其数无边际
  知诸世界化　　刹化众生化
  法化诸佛化　　一切皆究竟
  一切诸世界　　微细广大刹
  种种异庄严　　皆由业所起
  无量诸佛子　　善学入法界
  神通力自在　　普遍于十方
  众生数等劫　　说彼世界名
  亦不能令尽　　唯除佛开示
  世界及如来　　种种诸名号
  经于无量劫　　说之不可尽
  何况最胜智　　三世诸佛法
  从于法界生　　充满如来地
  清净无碍念　　无边无碍慧
  分别说法界　　得至于彼岸
  过去诸世界　　广大及微细
  修习所庄严　　一念悉能知
  其中人师子　　修佛种种行
  成于等正觉　　示现诸自在
  如是未来世　　次第无量劫
  所有人中尊　　菩萨悉能知
  所有诸行愿　　所有诸境界
  如是勤修行　　于中成正觉
  亦知彼众会　　寿命化众生
  以此诸法门　　为众转法轮
  菩萨如是知　　住普贤行地
  智慧悉明了　　出生一切佛
  现在世所摄　　一切诸佛土
  深入此诸刹　　通达于法界
  彼诸世界中　　现在一切佛
  于法得自在　　言论无所碍
  亦知彼众会　　净土应化力
  尽无量亿劫　　常思惟是事
  调御世间尊　　所有威神力
  无尽智慧藏　　一切悉能知
  出生无碍眼　　无碍耳鼻身
  无碍广长舌　　能令众欢喜
  最胜无碍心　　广大普清净
  智慧遍充满　　悉知三世法
  善学一切化　　刹化众生化
  世化调伏化　　究竟化彼岸
  世间种种别　　皆由于想住
  入佛方便智　　于此悉明了
  众会不可说　　一一为现身
  悉使见如来　　度脱无边众
  诸佛甚深智　　如日出世间
  一切国土中　　普现无休息
  了达诸世间　　假名无有实
  众生及世界　　如梦如光影
  于诸世间法　　不生分别见
  善离分别者　　亦不见分别
  无量无数劫　　解之即一念
  知念亦无念　　如是见世间
  无量诸国土　　一念悉超越
  经于无量劫　　不动于本处
  不可说诸劫　　即是须臾顷
  莫见修与短　　究竟刹那法
  心住于世间　　世间住于心
  于此不妄起　　二非二分别
  众生世界劫　　诸佛及佛法
  一切如幻化　　法界悉平等
  普于十方刹　　示现无量身
  知身从缘起　　究竟无所著
  依于无二智　　出现人师子
  不着无二法　　知无二非二
  了知诸世间　　如焰如光影
  如响亦如梦　　如幻如变化
  如是随顺入　　诸佛所行处
  成就普贤智　　普照深法界
  众生刹染着　　一切皆舍离
  而兴大悲心　　普净诸世间
  菩萨常正念　　论师子妙法
  清净如虚空　　而兴大方便
  见世常迷倒　　发心咸救度
  所行皆清净　　普遍诸法界
  诸佛及菩萨　　佛法世间法
  若见其真实　　一切无差别
  如来法身藏　　普入世间中
  虽在于世间　　于世无所著
  譬如清净水　　影像无来去
  法身遍世间　　当知亦如是
  如是离染着　　身世皆清净
  湛然如虚空　　一切无有生
  知身无有尽　　无生亦无灭
  非常非无常　　示现诸世间
  除灭诸邪见　　开示于正见
  法性无来去　　不着我我所
  譬如工幻师　　示现种种事
  其来无所从　　去亦无所至
  幻性非有量　　亦复非无量
  于彼大众中　　示现量无量
  以此寂定心　　修习诸善根
  出生一切佛　　非量非无量
  有量及无量　　皆悉是妄想
  了达一切趣　　不着量无量
  诸佛甚深法　　广大深寂灭
  甚深无量智　　知甚深诸趣
  菩萨离迷倒　　心净常相续
  巧以神通力　　度无量众生
  未安者令安　　安者示道场
  如是遍法界　　其心无所著
  不住于实际　　不入于涅槃
  如是遍世间　　开悟诸群生
  法数众生数　　了知而不着
  普雨于法雨　　充洽诸世间
  普于诸世界　　念念成正觉
  而修菩萨行　　未曾有退转
  世间种种身　　一切悉了知
  如是知身法　　则得诸佛身
  普知诸众生　　诸劫及诸刹
  十方无涯际　　智海无不入
  众生身无量　　一一为现身
  佛身无有边　　智者悉观见
  一念之所知　　出现诸如来
  经于无量劫　　称扬不可尽
  诸佛能现身　　处处般涅槃
  一念中无量　　舍利各差别
  如是未来世　　有求于佛果
  无量菩提心　　决定智悉知
  如是三世中　　所有诸如来
  一切悉能知　　名住普贤行
  如是分别知　　无量诸行地
  入于智慧处　　其轮不退转
  微妙广大智　　深入如来境
  入已不退转　　说名普贤慧
  一切最胜尊　　普入佛境界
  修行不退转　　得无上菩提
  无量无边心　　各各差别业
  皆由想积集　　平等悉了知
  染污非染污　　学心无学心
  不可说诸心　　念念中悉知
  了知非一二　　非染亦非净
  亦复无杂乱　　皆从自想起
  如是悉明见　　一切诸众生
  心想各不同　　起种种世间
  以如是方便　　修诸最胜行
  从佛法化生　　得名为普贤
  众生皆妄起　　善恶诸趣想
  由是或生天　　或复堕地狱
  菩萨观世间　　妄想业所起
  妄想无边故　　世间亦无量
  一切诸国土　　想网之所现
  幻网方便故　　一念悉能入
  眼耳鼻舌身　　意根亦如是
  世间想别异　　平等皆能入
  一一眼境界　　无量眼皆入
  种种性差别　　无量不可说
  所见无差别　　亦复无杂乱
  各随于自业　　受用其果报
  普贤力无量　　悉知彼一切
  一切眼境界　　大智悉能入
  如是诸世间　　悉能分别知
  而修一切行　　亦复无退转
  佛说众生说　　及以国土说
  三世如是说　　种种悉了知
  过去中未来　　未来中现在
  三世互相见　　一一皆明了
  如是无量种　　开悟诸世间
  一切智方便　　边际不可得

大方广佛华严经卷第四十九大方广佛华严经卷第五十

        于阗国三藏实叉难陀奉　制译

    如来出现品第三十七之一

尔时世尊。从眉间白毫相中。放大光明。名如来出现。无量百千亿那由他阿僧祇光明。以为眷属。其光普照十方尽虚空法界一切世界右绕十匝。显现如来无量自在。觉悟无数诸菩萨众。震动一切十方世界。除灭一切诸恶道苦。映蔽一切诸魔宫殿。显示一切诸佛如来。坐菩提座。成等正觉。及以一切道场众会。作是事已。而来右绕菩萨众会。入如来性起妙德菩萨顶。时此道场。一切大众。身心踊跃。生大欢喜。作如是念。甚奇希有。今者如来。放大光明。必当演说甚深大法。尔时。如来性起妙德菩萨。于莲华座上。偏袒右肩。右跽合掌。一心向佛。而说颂言

  正觉功德大智出　　普达境界到彼岸
  等于三世诸如来　　是故我今恭敬礼
  已升无相境界岸　　而现妙相庄严身
  放于离垢千光明　　破魔军众咸令尽
  十方所有诸世界　　悉能震动无有余
  未曾恐怖一众生　　善逝威神力如是
  虚空法界性平等　　已能如是而安住
  一切含生无数量　　咸令灭恶除众垢
  苦行勤劳无数劫　　成就最上菩提道
  于诸境界智无碍　　与一切佛同其性
  导师放此大光明　　震动十方诸世界
  已现无量神通力　　而复还来入我身
  决定法中能善学　　无量菩萨皆来集
  令我发起问法心　　是故我今请法王
  今此众会皆清净　　善能度脱诸世间
  智慧无边无染着　　如是贤胜咸来集
  利益世间尊导师　　智慧精进皆无量
  今以光明照大众　　令我问于无上法
  谁于大仙深境界　　而能真实具开演
  谁是如来法长子　　世间尊导愿显示

尔时如来。即于口中。放大光明。名无碍无畏。百千亿阿僧祇光明。以为眷属。普照十方尽虚空等法界。一切世界。右绕十匝。显现如来种种自在。开悟无量诸菩萨众。震动一切十方世界。除灭一切诸恶道苦。映蔽一切诸魔宫殿。显示一切诸佛如来。坐菩提座。成等正觉。及以一切道场众会。作是事已。而来右绕。菩萨众会。入普贤菩萨摩诃萨口。其光入已。普贤菩萨身。及师子座。过于本时。及诸菩萨。身座百倍。唯除如来师子之座

尔时。如来性起妙德菩萨。问普贤菩萨摩诃萨言。佛子。佛所示现。广大神变。令诸菩萨。皆生欢喜不可思议。世莫能知。是何瑞相。普贤菩萨摩诃萨言。佛子。我于往昔。见诸如来应正等觉。示现如是广大神变。即说如来出现法门。如我惟忖。今现此相。当说其法。说是语时。一切大地。悉皆震动。出生无量问法光明。时性起妙德菩萨。问普贤菩萨言。佛子。菩萨摩诃萨。应云何知诸佛如来应正等觉。出现之法。愿为我说。佛子。此诸无量百千亿那由他。菩萨众会。皆久修净业。念慧成就。到于究竟大庄严岸。具一切佛威仪之行。正念诸佛。未曾忘失。大悲观察一切众生。决定了知诸大菩萨神通境界。已得诸佛神力所加。能受一切如来妙法。具如是等无量功德。皆已来集。佛子。汝已曾于无量百千亿那由他佛所。承事供养。成就菩萨最上妙行。于三昧门皆得自在。入一切佛秘密之处。知诸佛法。断众疑惑。为诸如来神力所加。知众生根。随其所乐。为说真实解脱之法。随顺佛智。演说佛法。到于彼岸。有如是等无量功德。善哉佛子。愿说如来应正等觉。出现之法。身相言音。心意境界。所行之行。成道转法。乃至示现入般涅槃。见闻亲近。所生善根。如是等事。愿皆为说。时如来性起妙德菩萨。欲重明此义。向普贤菩萨。而说颂曰

  善哉无碍大智慧　　善觉无边平等境
  愿说无量佛所行　　佛子闻已皆欣庆
  菩萨云何随顺入　　诸佛如来出兴世
  云何身语心境界　　及所行处愿皆说
  云何诸佛成正觉　　云何如来转法轮
  云何善逝般涅槃　　大众闻已心欢喜
  若有见佛大法王　　亲近增长诸善根
  愿说彼诸功德藏　　众生见已何所获
  若有得闻如来名　　若现在世若涅槃
  于彼福藏生深信　　有何等利愿宣说
  此诸菩萨皆合掌　　瞻仰如来仁及我
  大功德海之境界　　净众生者愿为说
  愿以因缘及譬谕　　演说妙法相应义
  众生闻已发大心　　疑尽智净如虚空
  如遍一切国土中　　诸佛所现庄严身
  愿以妙音及因谕　　示佛菩提亦如彼
  十方千万诸佛土　　亿那由他无量劫
  如今所集菩萨众　　于彼一切悉难见
  此诸菩萨咸恭敬　　于微妙义生渴仰
  愿以净心具开演　　如来出现广大法

尔时普贤菩萨摩诃萨。告如来性起妙德等诸菩萨大众言。佛子。此处不可思议。所谓如来应正等觉。以无量法。而得出现。何以故。非以一缘。非以一事。如来出现。而得成就。以十无量。百千阿僧祇事。而得成就。何等为十。所谓过去无量摄受一切众生。菩提心所成故。过去无量清净殊胜。志乐所成故。过去无量救护一切众生。大慈大悲。所成故。过去无量。相续行愿。所成故。过去无量。修诸福智。心无厌足。所成故。过去无量。供养诸佛。教化众生。所成故。过去无量。智慧方便。清净道所成故。过去无量。清净功德藏。所成故。过去无量。庄严道智。所成故。过去无量。通达法义。所成故。佛子。如是无量阿僧祇法门圆满。成于如来。佛子。譬如三千大千世界。非以一缘。非以一事。而得成就。以无量缘无量事。方乃得成。所谓兴布大云。降霔大雨。四种风轮。相续为依。其四者何。一名能持。能持大水故。二名能消。能消大水故。三名建立。建立一切诸处所故。四名庄严。庄严分布。咸善巧故如是皆由众生共业。及诸菩萨。善根所起。令于其中一切众生。各随所宜。而得受用。佛子。如是等无量因缘。乃成三千大千世界。法性如是。无有生者。无有作者。无有知者。无有成者。然彼世界。而得成就。如来出现。亦复如是。非以一缘。非以一事。而得成就。以无量因缘。无量事相。乃得成就。所谓。曾于过去佛所。听闻受持大法云雨。因此能起如来四种大智风轮。何等为四。一者念持不忘陀罗尼大智风轮。能持一切如来大法云雨故。二者出生止观大智风轮。能消竭一切烦恼故。三者善巧回向大智风轮。能成就一切善根故。四者出生离垢差别庄严大智风轮。令过去所化。一切众生。善根清净。成就如来无漏善根力故。如来如是成等正觉。法性如是无生无作。而得成就。佛子。是为如来应正等觉出现第一相。菩萨摩诃萨。应如是知。复次佛子。譬如三千大千世界。将欲成时。大云降雨。名曰洪霔。一切方处。所不能受。所不能持。唯除大千界。将欲成时。佛子。如来应正等觉。亦复如是。兴大法云。雨大法雨。名成就如来出现。一切二乘。心志狭劣。所不能受。所不能持。唯除诸大菩萨。心相续力。佛子。是为如来应正等觉出现第二相。菩萨摩诃萨。应如是知。复次佛子。譬如众生。以业力故。大云降雨。来无所从。去无所至。如来应正等觉。亦复如是。以诸菩萨。善根力故。兴大法云。雨大法雨。亦无所从来。无所至去。佛子。是为如来应正等觉出现第三相。菩萨摩诃萨。应如是知。复次佛子。譬如大云。降霔大雨。大千世界。一切众生。无能知数。若欲算计。徒令发狂。唯大千世界主。摩醯首罗。以过去所修善根力故。乃至一滴。无不明了。佛子。如来应正等觉。亦复如是。兴大法云。雨大法雨。一切众生。声闻独觉。所不能知。若欲思量。心必狂乱。唯除一切世间主。菩萨摩诃萨以过去所修。觉慧力故。乃至一文一句。入众生心。无不明了。佛子。是为如来应正等觉出现第四相。菩萨摩诃萨。应如是知。复次佛子。譬如大云。降雨之时。有大云雨。名为能灭。能灭火灾。有大云雨。名为能起。能起大水。有大云雨。名为能止。能止大水。有大云雨。名为能成。能成一切摩尼诸宝。有大云雨。名为分别。分别三千大千世界。佛子。如来出现。亦复如是。兴大法云。雨大法雨。有大法雨。名为能灭。能灭一切众生烦恼。有大法雨。名为能起。能起一切众生善根。有大法雨。名为能止。能止一切众生见惑。有大法雨。名为能成。能成一切智慧法宝。有大法雨。名为分别。分别一切众生心乐。佛子。是为如来应正等觉出现第五相。菩萨摩诃萨。应如是知。复次佛子。譬如大云。雨一味水。随其所雨。无量差别。如来出现。亦复如是。雨于大悲一味法水。随宜说法。无量差别。佛子。是为如来应正等觉出现第六相。菩萨摩诃萨。应如是知。复次佛子。譬如三千大千世界。初始成时。先成色界诸天宫殿。次成欲界诸天宫殿。次成于人及余众生。诸所住处。佛子。如来出现。亦复如是。先起菩萨诸行智慧。次起缘觉诸行智慧。次起声闻善根诸行智慧。次起其余众生有为善根诸行智慧。佛子。譬如大云。雨一味水。随诸众生。善根异故。所起宫殿。种种不同。如来大悲。一味法雨。随众生器。而有差别。佛子。是为如来应正等觉出现第七相。菩萨摩诃萨。应如是知。复次佛子。譬如世界。初欲成时。有大水生。遍满三千大千世界。生大莲华。名如来出现功德宝庄严。遍覆水上。光照十方一切世界。时摩醯首罗。净居天等。见是华已。即决定知于此劫中。有尔所佛。出兴于世。佛子。尔时其中。有风轮起。名善净光明。能成色界诸天宫殿。有风轮起。名净光庄严。能成欲界诸天宫殿。有风轮起。名坚密无能坏。能成大小诸轮围山。及金刚山。有风轮起。名胜高。能成须弥山王。有风轮起。名不动。能成十大山王。何等为十。所谓。佉陀罗山。仙人山。伏魔山。大伏魔山。持双山。尼民陀罗山。目真邻陀山。摩诃目真邻陀山。香山。雪山。有风轮起。名为安住。能成大地。有风轮起。名为庄严。能成地天宫殿。龙宫殿。乾闼婆宫殿。有风轮起。名无尽藏。能成三千大千世界。一切大海。有风轮起。名普光明藏。能成三千大千世界。诸摩尼宝。有风轮起。名坚固根。能成一切诸如意树。佛子。大云所雨。一味之水。无有分别。以众生善根不同故。风轮不同。风轮差别故。世界差别。佛子。如来出现。亦复如是。具足一切善根功德。放于无上。大智光明。名不断如来种不思议智。普照十方一切世界。与诸菩萨。一切如来。灌顶之记。当成正觉。出兴于世。佛子。如来出现。复有无上。大智光明。名清净离垢。能成如来。无漏无尽智。复有无上大智光明。名普照。能成如来普入法界不思议智。复有无上大智光明。名持佛种性。能成如来不倾动力。复有无上大智光明。名迥出无能坏。能成如来无畏无坏智。复有无上大智光明。名一切神通。能成如来诸不共法。一切智智。复有无上大智光明。名出生变化。能成如来。令见闻亲近。所生善根。不失坏智。复有无上大智光明。名普随顺。能成如来无尽福德。智慧之身。为一切众生。而作饶益。复有无上大智光明。名不可究竟。能成如来甚深妙智。随所开悟。令三宝种。永不断绝。复有无上大智光明。名种种庄严。能成如来相好严身。令一切众生。皆生欢喜。复有无上大智光明。名不可坏。能成如来法界虚空界等。殊胜寿命。无有穷尽。佛子。如来大悲。一味之水。无有分别。以诸众生。欲乐不同。根性各别。而起种种大智风轮。令诸菩萨。成就如来。出现之法。佛子。一切如来。同一体性。大智轮中。出生种种智慧光明。佛子。汝等应知。如来于一解脱味。出生无量不可思议种种功德。众生念言。此是如来。神力所造。佛子。此非如来。神力所造。佛子。乃至一菩萨。不于佛所。曾种善根。能得如来少分智慧。无有是处。但以诸佛威德力故。令诸众生。具佛功德。而佛如来。无有分别。无成无坏。无有作者。亦无作法。佛子。是为如来应正等觉出现第八相。菩萨摩诃萨。应如是知。复次佛子。如依虚空。起四风轮。能持水轮。何等为四。一名安住。二名常住。三名究竟。四名坚固。此四风轮。能持水轮。水轮能持大地。令不散坏。是故说地轮依水轮。水轮依风轮。风轮依虚空。虚空无所依。虽无所依。能令三千大千世界。而得安住。佛子。如来出现。亦复如是。依无碍慧光明。起佛四种大智风轮。能持一切众生善根。何等为四。所谓普摄众生皆令欢喜大智风轮。建立正法令诸众生皆生爱乐大智风轮。守护一切众生善根大智风轮。具一切方便通达无漏界大智风轮。是为四。佛子。诸佛世尊。大慈救护一切众生。大悲度脱一切众生。大慈大悲。普遍饶益。然大慈大悲。依大方便善巧。大方便善巧。依如来出现。如来出现。依无碍慧光明。无碍慧光明。无有所依。佛子。是为如来应正等觉出现第九相。菩萨摩诃萨。应如是知复次佛子。譬如三千大千世界。既成就已。饶益无量种种众生。所谓水族众生。得水饶益。陆地众生。得地饶益。宫殿众生。得宫殿饶益。虚空众生。得虚空饶益。如来出现。亦复如是。种种饶益无量众生。所谓见佛生欢喜者。得欢喜益。住净戒者。得净戒益。住诸禅定。及无量者。得圣出世大神通益。住法门光明者。得因果不坏益。住无所有光明者。得一切法不坏益。是故。说言如来出现饶益一切无量众生。佛子。是为如来应正等觉出现第十相。菩萨摩诃萨。应如是知。佛子。菩萨摩诃萨。知如来出现。则知无量。知成就无量行故。则知广大。知周遍十方故。则知无来去。知离生住灭故。则知无行无所行。知离心意识故。则知无身。知如虚空故。则知平等。知一切众生。皆无我故。则知无尽。知遍一切刹。无有尽故。则知无退。知尽后际。无断绝故。则知无坏。知如来智。无有对故。则知无二。知平等观察。为无为故。则知一切众生皆得饶益。本愿回向自在满足故。尔时普贤菩萨摩诃萨。欲重明此义。而说颂言

  十力大雄最无上　　譬如虚空无等等
  境界广大不可量　　功德第一超世间
  十力功德无边量　　心意思量所不及
  人中师子一法门　　众生亿劫莫能知
  十方国土碎为尘　　或有算计知其数
  如来一毛功德量　　千万亿劫无能说
  如人持尺量虚空　　复有随行计其数
  虚空边际不可得　　如来境界亦如是
  或有能于刹那顷　　悉知三世众生心
  设经众生数等劫　　不能知佛一念性
  譬如法界遍一切　　不可见取为一切
  十力境界亦复然　　遍于一切非一切
  真如离妄恒寂静　　无生无灭普周遍
  诸佛境界亦复然　　体性平等不增减
  譬如实际而非际　　普在三世亦非普
  导师境界亦如是　　遍于三世皆无碍
  法性无作无变易　　犹如虚空本清净
  诸佛性净亦如是　　本性非性离有无
  法性不在于言论　　无说离说恒寂灭
  十力境界性亦然　　一切文辞莫能辩
  了知诸法性寂灭　　如鸟飞空无有迹
  以本愿力现色身　　令见如来大神变
  若有欲知佛境界　　当净其意如虚空
  远离妄想及诸取　　令心所向皆无碍
  是故佛子应善听　　我以少譬明佛境
  十力功德不可量　　为悟众生今略说
  导师所现于身业　　语业心业诸境界
  转妙法轮般涅槃　　一切善根我今说
  譬如世界初安立　　非一因缘而可成
  无量方便诸因缘　　成此三千大千界
  如来出现亦如是　　无量功德乃得成
  刹尘心念尚可知　　十力生因莫能测
  譬如劫初云澍雨　　而起四种大风轮
  众生善根菩萨力　　成此三千各安住
  十力法云亦如是　　起智风轮清净意
  昔所回向诸众生　　普导令成无上果
  如有大雨名洪澍　　无有处所能容受
  唯除世界将成时　　清净虚空大风力
  如来出现亦如是　　普雨法雨充法界
  一切劣意无能持　　唯除清净广大心
  譬如空中澍大雨　　无所从来无所去
  作者受者悉亦无　　自然如是普充洽
  十力法雨亦如是　　无去无来无造作
  本行为因菩萨力　　一切大心咸听受
  譬如空云澍大雨　　一切无能数其滴
  唯除三千自在王　　具功德力悉明了
  善逝法雨亦如是　　一切众生莫能测
  唯除于世自在人　　明见如观掌中宝
  譬如空云澍大雨　　能灭能起亦能断
  一切珍宝悉能成　　三千所有皆分别
  十力法雨亦如是　　灭惑起善断诸见
  一切智宝皆使成　　众生心乐悉分别
  譬如空中雨一味　　随其所雨各不同
  岂彼雨性有分别　　然随物异法如是
  如来法雨非一异　　平等寂静离分别
  然随所化种种殊　　自然如是无边相
  譬如世界初成时　　先成色界天宫殿
  次及欲天次人处　　乾闼婆宫最后成
  如来出现亦如是　　先起无边菩萨行
  次化乐寂诸缘觉　　次声闻众后众生
  诸天初见莲华瑞　　知佛当出生欢喜
  水缘风力起世间　　宫殿山川悉成立
  如来宿善大光明　　巧别菩萨与其记
  所有智轮体皆净　　各能开示诸佛法
  譬如树林依地有　　地依于水得不坏
  水轮依风风依空　　而其虚空无所依
  一切佛法依慈悲　　慈悲复依方便立
  方便依智智依慧　　无碍慧身无所依
  譬如世界既成立　　一切众生获其利
  地水所住及空居　　二足四足皆蒙益
  法王出现亦如是　　一切众生获其利
  若有见闻及亲近　　悉使灭除诸惑恼
  如来出现法无边　　世间迷惑莫能知
  为欲开悟诸含识　　无譬谕中说其譬

佛子。诸菩萨摩诃萨。应云何见如来应正等觉身。佛子。诸菩萨摩诃萨。应于无量处。见如来身。何以故。诸菩萨摩诃萨。不应于一法。一事一身。一国土一众生。见于如来。应遍一切处。见于如来。佛子。譬如虚空遍至一切。色非色处。非至非不至。何以故。虚空无身故。如来身亦如是。遍一切处。遍一切众生。遍一切法。遍一切国土。非至非不至。何以故。如来身无身故。为众生故。示现其身。佛子。是为如来身第一相。诸菩萨摩诃萨。应如是见。复次佛子。譬如虚空。宽广非色。而能显现一切诸色。而彼虚空。无有分别。亦无戏论。如来身亦复如是。以智光明。普照明故。令一切众生世出世间诸善根业。皆得成就。而如来身。无有分别。亦无戏论。何以故。从本已来。一切执着。一切戏论。皆永断故。佛子。是为如来身第二相。诸菩萨摩诃萨。应如是见。复次佛子。譬如日出于阎浮提。无量众生。皆得饶益。所谓。破闇作明。变湿令燥。生长草木。成熟谷稼。廓彻虚空。开敷莲华。行者见道。居者辨业。何以故。日轮普放无量光故。佛子。如来智日。亦复如是。以无量事。普益众生。所谓灭恶生善。破愚为智。大慈救护。大悲度脱。令其增长根力觉分。令生深信。舍离浊心。令得见闻。不坏因果。令得天眼。见殁生处。令心无碍。不坏善根。令智修明。开敷觉华。令其发心。成就本行。何以故。如来广大。智慧日身。放无量光。普照耀故。佛子。是为如来身第三相。诸菩萨摩诃萨。应如是见。复次佛子。譬如日出于阎浮提。先照一切须弥山等诸大山王。次照黑山。次照高原。然后普照一切大地。日不作念。我先照此。后照于彼。但以山地有高下故。照有先后。如来应正等觉。亦复如是。成就无边法界智轮。常放无碍智慧光明。先照菩萨摩诃萨等诸大山王。次照缘觉。次照声闻。次照决定善根众生。随其心器。示广大智。然后普照一切众生。乃至邪定。亦皆普及。为作未来利益因缘。令成熟故。而彼如来大智日光。不作是念。我当先照菩萨大行。乃至后照邪定众生。但放光明。平等普照。无碍无障。无所分别。佛子。譬如日月。随时出现。大山幽谷。普照无私。如来智慧。复亦如是。普照一切。无有分别。随诸众生根欲不同。智慧光明。种种有异。佛子。是为如来身第四相。诸菩萨摩诃萨。应如是见。复次佛子。譬如日出。生盲众生。无眼根故。未曾得见。虽未曾见。然为日光之所饶益。何以故。因此得知昼夜时节。受用种种衣服饮食。令身调适。离众患故。如来智日。亦复如是。无信无解。毁戒毁见。邪命自活。生盲之类。无信眼故。不见诸佛。智慧日轮。虽不见佛智慧日轮。亦为智日之所饶益。何以故。以佛威力。令彼众生。所有身苦。及诸烦恼。未来苦因。皆消灭故。佛子。如来有光明。名积集一切功德。有光明名普照一切。有光明。名清净自在照。有光明。名出大妙音。有光明。名普解一切语言法令他欢喜。有光明。名示现永断一切疑自在境界。有光明。名无住智自在普照。有光明。名永断一切戏论自在智。有光明。名随所应出妙音声。有光明。名出清净自在音庄严国土成熟众生。佛子如来一一毛孔。放如是等千种光明。五百光明。普照下方。五百光明。普照上方种种刹中。种种佛所。诸菩萨众。其菩萨等。见此光明。一时皆得如来境界。十头十眼。十耳十鼻。十舌十身。十手十足。十地十智。皆悉清净。彼诸菩萨。先所成就。诸处诸地。见彼光明。转更清净。一切善根。皆悉成熟。趣一切智。住二乘者。灭一切垢。其余一分。生盲众生。身既快乐。心亦清净。柔软调伏。堪修念智。地狱饿鬼。畜生诸趣。所有众生。皆得快乐。解脱众苦。命终皆生天上人间。佛子。彼诸众生不觉不知。以何因缘。以何神力。而来生此。彼生盲者。作如是念。我是梵天。我是梵化。是时如来。住普自在三昧。出六十种妙音。而告之言。汝等。非是梵天。亦非梵化。亦非帝释护世所作。皆是如来。威神之力。彼诸众生。闻是语已。以佛神力。皆知宿命。生大欢喜。心欢喜故。自然而出优昙华云。香云音乐云。衣云盖云。幢云幡云。末香云宝云。师子幢半月楼阁云。歌咏赞叹云。种种庄严云。皆以尊重心。供养如来。何以故。此诸众生。得净眼故。如来与彼。授阿耨多罗三藐三菩提记。佛子。如来智日。如是利益生盲众生。令得善根。具足成熟。佛子。是为如来身第五相。诸菩萨摩诃萨。应如是见。复次佛子。譬如月轮有四奇特。未曾有法。何等为四。一者映蔽一切星宿光明。二者随逐于时示现亏盈。三者于阎浮提澄净水中影无不现。四者一切见者皆对目前。而此月轮。无有分别。无有戏论。佛子。如来身月。亦复如是。有四奇特未曾有法。何等为四。所谓映蔽一切声闻独觉。学无学众。随其所宜。示现寿命修短不同。而如来身。无有增减。一切世界。净心众生。菩提器中。影无不现。一切众生。有瞻对者。皆谓如来。唯现我前。随其心乐。而为说法。随其地位。令得解脱。随所应化。令见佛身。而如来身。无有分别。无有戏论。所作利益。皆得究竟。佛子。是为如来身第六相。诸菩萨摩诃萨。应如是见。复次佛子。譬如三千大千世界。大梵天王。以少方便。于大千世界。普现其身。一切众生。皆见梵王现在己前。而此梵王。亦不分身。无种种身。佛子。诸佛如来。亦复如是。无有分别。无有戏论。亦不分身。无种种身。而随一切众生心乐。示现其身。亦不作念。现若干身。佛子。是为如来身第七相。诸菩萨摩诃萨。应如是见。复次佛子。譬如医王善知众药及诸咒论。阎浮提中。诸所有药。用无不尽。复以宿世诸善根力。大明咒力。为方便故。众生见者。病无不愈。彼大医王。知命将终。作是念言。我命终后。一切众生无所依怙。我今宜应为现方便。是时医王。合药涂身。明咒力持。令其终后。身不分散。不萎不枯。威仪视听。与本无别。凡所疗治。悉得除差。佛子。如来应正等觉。无上医王。亦复如是。于无量百千亿那由他劫。炼治法药。已得成就。修学一切方便善巧。大明咒力。皆到彼岸。善能除灭一切众生。诸烦恼病。及住寿命。经无量劫。其身清净。无有思虑。无有动用。一切佛事。未尝休息。众生见者。诸烦恼病。悉得消灭。佛子。是为如来身第八相。诸菩萨摩诃萨。应如是见。复次佛子。譬如大海有大摩尼宝。名集一切光明毗卢遮那藏。若有众生。触其光者。悉同其色。若有见者。眼得清净。随彼光明所照之处。雨摩尼宝。名为安乐。令诸众生。离苦调适。佛子。诸如来身。亦复如是。为大宝聚一切功德大智慧藏。若有众生。触佛身宝智慧光者。同佛身色。若有见者。法眼清净。随彼光明所照之处。令诸众生。离贫穷苦。乃至具足佛菩提乐。佛子。如来法身。无所分别。亦无戏论。而能普为一切众生。作大佛事。佛子。是为如来身第九相。诸菩萨摩诃萨。应如是见。复次佛子。譬如大海有大如意摩尼宝王。名一切世间庄严藏。具足成就百万功德。随所住处。令诸众生。灾患消除。所愿满足。然此如意摩尼宝王。非少福众生所能得见。如来身如意宝王。亦复如是。名为能令一切众生皆悉欢喜。若有见身闻名赞德。悉令永离生死苦患。假使一切世界。一切众生。一时专心。欲见如来。悉令得见。所愿皆满。佛子。佛身非是少福众生所能得见。唯除如来自在神力。所应调伏。若有众生。因见佛身。便种善根。乃至成熟。为成熟故。乃令得见如来身耳。佛子。是为如来身第十相。诸菩萨摩诃萨。应如是见。以其心无量遍十方故。所行无碍。如虚空故。普入法界故。住真实际故。无生无灭故。等住三世故。永离一切分别故。住尽后际誓愿故。严净一切世界故。庄严一一佛身故。尔时。普贤菩萨摩诃萨。欲重明此义。而说颂言

  譬如虚空遍十方　　若色非色有非有
  三世众生身国土　　如是普在无边际
  诸佛真身亦如是　　一切法界无不遍
  不可得见不可取　　为化众生而现形
  譬如虚空不可取　　普使众生造众业
  不念我今何所作　　云何我作为谁作
  诸佛身业亦如是　　普使群生修善法
  如来未曾有分别　　我今于彼种种作
  譬如日出阎浮提　　光明破闇悉无余
  山树池莲地众物　　种种品类皆蒙益
  诸佛日出亦如是　　生长人天众善行
  永除痴闇得智明　　恒受尊荣一切乐
  譬如日光出现时　　先照山王次余山
  后照高原及大地　　而日未始有分别
  善逝光明亦如是　　先照菩萨次缘觉
  后照声闻及众生　　而佛本来无动念
  譬如生盲不见日　　日光亦为作饶益
  令知时节受饮食　　永离众患身安隐
  无信众生不见佛　　而佛亦为兴义利
  闻名及以触光明　　因此乃至得菩提
  譬如净月在虚空　　能蔽众星示盈缺
  一切水中皆现影　　诸有观瞻悉对前
  如来净月亦复然　　能蔽余乘示修短
  普现天人净心水　　一切皆谓对其前
  譬如梵王住自宫　　普现三千诸梵处
  一切人天咸得见　　实不分身向于彼
  诸佛现身亦如是　　一切十方无不遍
  其身无数不可称　　亦不分身不分别
  如有医王善方术　　若有见者病皆愈
  命虽已尽药涂身　　令其作务悉如初
  最胜医王亦如是　　具足方便一切智
  以昔妙行现佛身　　众生见者烦恼灭
  譬如海中有宝王　　普出无量诸光明
  众生触者同其色　　若有见者眼清净
  最胜宝王亦如是　　触其光者悉同色
  若有得见五眼开　　破诸尘闇住佛地
  譬如如意摩尼宝　　随有所求皆满足
  少福众生不能见　　非是宝王有分别
  善逝宝王亦如是　　悉满所求诸欲乐
  无信众生不见佛　　非是善逝心弃舍

大方广佛华严经卷第五十大方广佛华严经卷第五十一

        于阗国三藏实叉难陀奉　制译

    如来出现品第三十七之二

佛子。菩萨摩诃萨。应云何知如来应正等觉音声。佛子。菩萨摩诃萨。应知如来音声遍至普遍无量诸音声故。应知如来音声。随其心乐。皆令欢喜。说法明了故。应知如来音声。随其信解。皆令欢喜。心得清凉故。应知如来音声化不失时。所应闻者。无不闻故。应知如来音声无生灭。如呼响故。应知如来音声无主。修习一切。业所起故。应知如来音声甚深。难可度量故。应知如来音声无邪曲。法界所生故。应知如来音声无断绝。普入法界故。应知如来音声无变易。至于究竟故。佛子。菩萨摩诃萨。应知如来音声非量非无量。非主非无主。非示非无示。何以故。佛子。譬如世界。将欲坏时。无主无作。法尔而出四种音声。其四者何。一曰。汝等当知初禅安乐。离诸欲恶。超过欲界。众生闻已。自然而得成就初禅。舍欲界身。生于梵天。二曰。汝等当知二禅安乐。无觉无观。超于梵天。众生闻已。自然而得成就二禅。舍梵天身。生光音天。三曰。汝等当知三禅安乐。无有过失。超光音天。众生闻已。自然而得成就三禅。舍光音身。生遍净天。四曰。汝等当知四禅寂静。超遍净天。众生闻已。自然而得成就四禅。舍遍净身。生广果天。是为四。佛子。此诸音声。无主无作。但从众生诸善业力之所出生。佛子。如来音声。亦复如是。无主无作。无有分别。非入非出。但从如来功德法力。出于四种广大音声。其四者何。一曰。汝等当知一切诸行。皆悉是苦。所谓地狱苦。畜生苦。饿鬼苦。无福德苦。着我我所苦。作诸恶行苦。欲生人天。当种善根。生人天中。离诸难处。众生闻已。舍离颠倒。修诸善行。离诸难处。生人天中。二曰。汝等当知一切诸行。众苦炽然。如热铁丸。诸行无常。是磨灭法。涅槃寂静。无为安乐。远离炽然。消诸热恼。众生闻已。勤修善法。于声闻乘。得随顺音声忍。三曰。汝等当知声闻乘者。随他语解。智慧狭劣。更有上乘。名独觉乘。悟不由师。汝等应学。乐胜道者。闻此音已。舍声闻道。修独觉乘。四曰。汝等当知过二乘位。更有胜道。名为大乘。菩萨所行。顺六波罗蜜。不断菩萨行。不舍菩提心。处无量生死。而不疲厌。过于二乘。名为大乘第一乘胜乘最胜乘上乘无上乘利益一切众生乘。若有众生。信解广大。诸根猛利。宿种善根。为诸如来神力所加。有胜乐欲。希求佛果。闻此音已。发菩提心。佛子。如来音声。不从身出。不从心出。而能利益无量众生。佛子。是为如来音声第一相。诸菩萨摩诃萨。应如是知。复次佛子。譬如呼响。因于山谷及音声起。无有形状。不可睹见。亦无分别。而能随逐一切语言。如来音声。亦复如是。无有形状。不可睹见。非有方所。非无方所。但随众生欲解缘出。其性究竟。无言无示。不可宣说。佛子。是为如来音声第二相。诸菩萨摩诃萨。应如是知。复次佛子。譬如诸天有大法鼓。名为觉悟。若诸天子。行放逸时。于虚空中。出声告言。汝等当知一切欲乐。皆悉无常。虚妄颠倒。须臾变坏。但诳愚夫。令其恋着。汝莫放逸。若放逸者。堕诸恶趣。后悔无及。放逸诸天。闻此音已。生大忧怖。舍自宫中所有欲乐。诣天王所。求法行道。佛子。彼天鼓音。无主无作。无起无灭。而能利益无量众生。当知如来。亦复如是。为欲觉悟放逸众生。出于无量妙法音声。所谓无著声。不放逸声。无常声。苦声。无我声。不净声。寂灭声。涅槃声。无有量自然智声。不可坏菩萨行声。至一切处如来无功用智地声。以此音声。遍法界中。而开悟之。无数众生。闻是音已。皆生欢喜。勤修善法。各于自乘。而求出离。所谓或修声闻乘。或修独觉乘。或习菩萨无上大乘。而如来音。不住方所。无有言说。佛子。是为如来音声第三相。诸菩萨摩诃萨。应如是知。复次佛子。譬如自在天王。有天采女。名曰善口。于其口中。出一音声。其声则与百千种乐。而共相应。一一乐中。复有百千差别音声。佛子。彼善口女。从口一声。出于如是。无量音声。当知如来。亦复如是。于一音中。出无量声。随诸众生心乐差别。皆悉遍至。悉令得解。佛子。是为如来音声第四相。诸菩萨摩诃萨。应如是知。复次佛子。譬如大梵天王。住于梵宫。出梵音声。一切梵众。靡不皆闻。而彼音声。不出众外。诸梵天众。咸生是念。大梵天王。独与我语。如来妙音。亦复如是。道场众会。靡不皆闻。而其音声。不出众外。何以故。根未熟者。不应闻故。其闻音者。皆作是念。如来世尊。独为我说。佛子。如来音声。无出无住。而能成就一切事业。是为如来音声第五相。诸菩萨摩诃萨。应如是知。复次佛子。譬如众水皆同一味。随器异故。水有差别。水无念虑。亦无分别。如来言音。亦复如是。唯是一味。谓解脱味。随诸众生心器异故。无量差别。而无念虑。亦无分别。佛子。是为如来音声第六相。诸菩萨摩诃萨。应如是知。复次佛子。譬如阿那婆达多龙王。兴大密云。遍阎浮提。普霔甘雨。百谷苗稼。皆得生长。江河泉池。一切盈满。此大雨水。不从龙王身心中出。而能种种。饶益众生。佛子。如来应正等觉。亦复如是。兴大悲云。遍十方界。普雨无上甘露法雨。令一切众生。皆生欢喜。增长善法。满足诸乘。佛子。如来音声。不从外来。不从内出。而能饶益一切众生。是为如来音声第七相。诸菩萨摩诃萨。应如是知。复次佛子。譬如摩那斯龙王。将欲降雨。未便即降。先起大云。弥覆虚空。凝停七日。待诸众生。作务究竟。何以故。彼大龙王。有慈悲心。不欲恼乱诸众生故。过七日已。降微细雨。普润大地。佛子。如来应正等觉。亦复如是。将降法雨。未便即降。先兴法云。成熟众生。为欲令其心无惊怖。待其熟已。然后普降甘露法雨。演说甚深微妙善法。渐次令其满足如来一切智智无上法味。佛子。是为如来音声第八相。诸菩萨摩诃萨。应如是知。复次佛子。譬如海中。有大龙王。名大庄严。于大海中。降雨之时。或降十种庄严雨。或百或千。或百千种庄严雨。佛子。水无分别。但以龙王不思议力。令其庄严。乃至百千无量差别。如来应正等觉。亦复如是。为诸众生说法之时。或以十种。差别音说。或百或千。或以百千。或以八万四千音声。说八万四千行。乃至或以无量百千亿那由他音声。各别说法。令其闻者。皆生欢喜。如来音声。无所分别。但以诸佛于甚深法界。圆满清净。能随众生根之所宜。出种种言音。皆令欢喜。佛子。是为如来音声第九相。诸菩萨摩诃萨。应如是知。复次佛子。譬如娑竭罗龙王。欲现龙王大自在力。饶益众生。咸令欢喜。从四天下。乃至他化自在天处。兴大云网。周匝弥覆。其云色相。无量差别。或阎浮檀金光明色。或毗琉璃光明色。或白银光明色。或玻璃光明色。或牟萨罗光明色。或码瑙光明色。或胜藏光明色。或赤真珠光明色。或无量香光明色。或无垢衣光明色。或清净水光明色。或种种庄严具光明色。如是云网。周匝弥布。既弥布已。出种种色电光。所谓阎浮檀金色云。出琉璃色电光。琉璃色云。出金色电光。银色云。出玻璃色电光。玻璃色云。出银色电光。牟萨罗色云。出码瑙色电光。码瑙色云。出牟萨罗色电光。胜藏宝色云。出赤真珠色电光。赤真珠色云。出胜藏宝色电光。无量香色云。出无垢衣色电光。无垢衣色云。出无量香色电光。清净水色云。出种种庄严具色电光。种种庄严具色云。出清净水色电光。乃至种种色云。出一色电光。一色云。出种种色电光。复于彼云中。出种种雷声。随众生心。皆令欢喜。所谓或如天女歌咏音。或如诸天妓乐音。或如龙女歌咏音。或如乾闼婆女歌咏音。或如紧那罗女歌咏音。或如大地震动声。或如海水波潮声。或如兽王哮吼声。或如好鸟鸣啭声。及余无量。种种音声。既震雷已。复起凉风。令诸众生。心生悦乐。然后乃降种种诸雨。利益安乐无量众生。从他化天。至于地上。于一切处。所雨不同。所谓于大海中。雨清冷水。名无断绝。于他化自在天。雨箫笛等种种乐音。名为美妙。于化乐天。雨大摩尼宝。名放大光明。于兜率天。雨大庄严具。名为垂髻。于夜摩天。雨大妙华。名种种庄严具。于三十三天。雨众妙香。名为悦意。于四天王天。雨天宝衣。名为覆盖。于龙王宫。雨赤真珠。名涌出光明。于阿修罗宫。雨诸兵仗。名降伏怨敌。于此郁单越。雨种种华。名曰开敷。余三天下。悉亦如是。然各随其处。所雨不同。虽彼龙王。其心平等。无有彼此。但以众生善根异故。雨有差别。佛子如来应正等觉无上法王。亦复如是。欲以正法。教化众生。先布身云。弥覆法界。随其乐欲。为现不同。所谓或为众生。现生身云。或为众生。现化身云。或为众生。现力持身云。或为众生。现色身云。或为众生。现相好身云。或为众生。现福德身云。或为众生。现智慧身云。或为众生。现诸力不可坏身云。或为众生。现无畏身云。或为众生。现法界身云。佛子如来。以如是等。无量身云。普覆十方一切世界。随诸众生所乐各别。示现种种光明电光。所谓或为众生。现光明电光。名无所不至。或为众生。现光明电光。名无边光明。或为众生。现光明电光。名入佛秘密法。或为众生。现光明电光。名影现光明。或为众生。现光明电光。名光明照耀。或为众生。现光明电光。名入无尽陀罗尼门。或为众生。现光明电光。名正念不乱。或为众生。现光明电光。名究竟不坏。或为众生现光明电光。名顺入诸趣。或为众生。现光明电光。名满一切愿皆令欢喜。佛子。如来应正等觉。现如是等无量光明电光已。复随众生心之所乐。出生无量三昧雷声。所谓善觉智三昧雷声。明盛离垢海三昧雷声。一切法自在三昧雷声。金刚轮三昧雷声。须弥山幢三昧雷声。海印三昧雷声。日灯三昧雷声。无尽藏三昧雷声。不坏解脱力三昧雷声。佛子。如来身云中。出如是等无量差别三昧雷声已。将降法雨。先现瑞相。开悟众生。所谓从无障碍。大慈悲心。现于如来大智风轮。名能令一切众生。生不思议。欢喜适悦。此相现已。一切菩萨。及诸众生。身之与心。皆得清凉。然后从如来大法身云。大慈悲云。大不思议云。雨不思议广大法雨。令一切众生。身心清净。所谓为坐菩提场菩萨。雨大法雨。名法界无差别为最后身菩萨。雨大法雨。名菩萨游戏如来秘密教。为一生所系菩萨。雨大法雨。名清净普光明。为灌顶菩萨。雨大法雨。名如来庄严具所庄严。为得忍菩萨。雨大法雨。名功德宝智慧华开敷不断菩萨大悲行。为住向行菩萨。雨大法雨。名入现前变化甚深门而行菩萨行无休息无疲厌。为初发心菩萨。雨大法雨。名出生如来大慈悲行救护众生。为求独觉乘众生。雨大法雨。名深知缘起法远离二边得不坏解脱果。为求声闻乘众生。雨大法雨。名以大智慧剑断一切烦恼怨。为积集善根决定不决定众生。雨大法雨。名能令成就种种法门生大欢喜。佛子。诸佛如来。随众生心。雨如是等广大法雨。充满一切无边世界。佛子。如来应正等觉。其心平等。于法无吝。但以众生根欲不同。所雨法雨。示有差别。是为如来音声第十相。诸菩萨摩诃萨。应如是知。复次佛子。应知如来音声。有十种无量。何等为十。所谓如虚空界无量。至一切处故。如法界无量。无所不遍故。如众生界无量。令一切心喜故。如诸业无量。说其果报故。如烦恼无量。悉令除灭故。如众生言音无量。随解令闻故。如众生欲解无量。普观救度故。如三世无量。无有边际故。如智慧无量。分别一切故。如佛境界无量。入佛法界故。佛子。如来应正等觉音声。成就如是等阿僧祇无量。诸菩萨摩诃萨。应如是知。尔时普贤菩萨摩诃萨。欲重明此义。而说颂言

  三千世界将坏时　　众生福力声告言
  四禅寂静无诸苦　　令其闻已悉离欲
  十力世尊亦如是　　出妙音声遍法界
  为说诸行苦无常　　令其永度生死海
  譬如深山大谷中　　随有音声皆响应
  虽能随逐他言语　　而响毕竟无分别
  十力言音亦复然　　随其根熟为示现
  令其调伏生欢喜　　不念我今能演说
  如天有鼓名能觉　　常于空中震法音
  诫彼放逸诸天子　　令其闻已得离着
  十力法鼓亦如是　　出于种种妙音声
  觉悟一切诸群生　　令其悉证菩提果
  自在天王有宝女　　口中善奏诸音乐
  一声能出百千音　　一一音中复百千
  善逝音声亦如是　　一声而出一切音
  随其性欲有差别　　各令闻已断烦恼
  譬如梵王吐一音　　能令梵众皆欢喜
  音唯及梵不出外　　一一皆言己独闻
  十力梵王亦复然　　演一言音充法界
  唯沾众会不远出　　以无信故未能受
  譬如众水同一性　　八功德味无差别
  因地在器各不同　　是故令其种种异
  一切智音亦如是　　法性一味无分别
  随诸众生行不同　　故使听闻种种异
  譬如无热大龙王　　降雨普洽阎浮地
  能令草树皆生长　　而不从身及心出
  诸佛妙音亦如是　　普雨法界悉充洽
  能令生善灭诸恶　　不从内外而得有
  譬如摩那斯龙王　　兴云七日未先雨
  待诸众生作务竟　　然后始降成利益
  十力演义亦如是　　先化众生使成熟
  然后为说甚深法　　令其闻者不惊怖
  大庄严龙于海中　　霔于十种庄严雨
  或百或千百千种　　水虽一味庄严别
  究竟辩才亦如是　　说十二十诸法门
  或百或千至无量　　不生心念有殊别
  最胜龙王娑竭罗　　兴云普覆四天下
  于一切处雨各别　　而彼龙心无二念
  诸佛法王亦如是　　大悲身云遍十方
  为诸修行雨各异　　而于一切无分别

佛子。诸菩萨摩诃萨。应云何知如来应正等觉心。佛子。如来心意识。俱不可得。但应以智无量故。知如来心。譬如虚空为一切物所依。而虚空无所依。如来智慧。亦复如是。为一切世间出世间智所依。而如来智无所依。佛子。是为如来心第一相。诸菩萨摩诃萨。应如是知。复次佛子。譬如法界常出一切声闻独觉菩萨解脱。而法界无增减。如来智慧。亦复如是。恒出一切世间出世间。种种智慧。而如来智无增减。佛子。是为如来心第二相。诸菩萨摩诃萨。应如是知。复次佛子。譬如大海其水潜流四天下地。及八十亿。诸小洲中。有穿凿者。无不得水。而彼大海。不作分别。我出于水。佛智海水。亦复如是。流入一切众生心中。若诸众生。观察境界。修习法门。则得智慧清净明了。而如来智。平等无二。无有分别。但随众生心行异故。所得智慧。各各不同。佛子。是为如来心第三相。诸菩萨摩诃萨。应如是知。复次佛子。譬如大海有四宝珠。具无量德。能生海内一切珍宝。若大海中。无此宝珠。乃至一宝。亦不可得。何等为四。一名积集宝。二名无尽藏。三名远离炽然。四名具足庄严。佛子。此四宝珠。一切凡夫。诸龙神等。悉不得见。何以故。娑竭龙王。以此宝珠。端严方正。置于宫中深密处故。佛子。如来应正等觉。大智慧海。亦复如是。于中有四大智宝珠。具足无量福智功德。由此能生一切众生。声闻独觉。学无学位。及诸菩萨智慧之宝。何等为四。所谓无染着巧方便大智慧宝。善分别有为无为法大智慧宝。分别说无量法而不坏法性大智慧宝。知时非时未曾误失大智慧宝。若诸如来。大智海中。无此四宝。有一众生。得入大乘。终无是处。此四智宝。薄福众生。所不能见。何以故。置于如来深密藏故。此四智宝。平均正直。端洁妙好。普能利益诸菩萨众。令其悉得智慧光明。佛子。是为如来心第四相。诸菩萨摩诃萨。应如是知。复次佛子。譬如大海。有四炽然光明大宝。布在其底。性极猛热。常能饮缩百川所注无量大水。是故大海。无有增减。何等为四。一名日藏。二名离润。三名火焰光。四名尽无余佛子。若大海中。无此四宝。从四天下乃至有顶。其中所有。悉被漂没。佛子。此日藏大宝光明。照触海水。悉变为乳。离润大宝光明。照触其乳。悉变为酪。火焰光大宝光明。照触其酪。悉变为酥。尽无余大宝光明。照触其酥。变成醍醐。如火炽然。悉尽无余。佛子。如来应正等觉。大智慧海。亦复如是。有四种大智慧宝。具足无量威德光明。此智宝光。触诸菩萨乃至令得如来大智。何等为四。所谓灭一切散善波浪大智慧宝。除一切法爱大智慧宝。慧光普照大智慧宝。与如来平等无边无功用大智慧宝。佛子。诸菩萨。修习一切助道法时。起无量散善波浪。一切世间。天人阿修罗。所不能坏。如来以灭一切散善波浪大智慧宝光明。触彼菩萨。令舍一切散善波浪。持心一境。住于三昧。又以除一切法爱大智慧宝光明。触彼菩萨。令舍离三昧味着。起广大神通。又以慧光普照大智慧宝光明。触彼菩萨。令舍所起广大神通。住大明功用行。又以与如来平等无边无功用大智慧宝光明。触彼菩萨。令舍所起大明功用行。乃至得如来平等地。息一切功用。令无有余。佛子。若无如来此四智宝。大光照触。乃至有一菩萨。得如来地。无有是处。佛子是为如来心第五相。诸菩萨摩诃萨。应如是知。复次佛子。如从水际。上至非想非非想天。其中所有。大千国土。欲色无色。众生之处。莫不皆依虚空而起。虚空而住。何以故。虚空普遍故。虽彼虚空普容三界。而无分别。佛子。如来智慧。亦复如是若声闻智。若独觉智。若菩萨智。若有为行智。若无为行智。一切皆依如来智起。如来智住。何以故。如来智慧。遍一切故。虽复普容无量智慧。而无分别。佛子。是为如来心第六相。诸菩萨摩诃萨。应如是知。复次佛子。如雪山顶。有药王树。名无尽根。彼药树根。从十六万八千由旬。下尽金刚地水轮际生。彼药王树。若生根时。令阎浮提一切树根生。若生茎时。令阎浮提一切树茎生。枝叶华果。悉皆如是。此药王树根能生茎。茎能生根。根无有尽。名无尽根。佛子。彼药王树。于一切处。皆令生长。唯于二处。不能为作生长利益。所谓地狱深坑。及水轮中。然亦于彼。初无厌舍。佛子。如来智慧。大药王树。亦复如是。以过去所发。成就一切智慧善法。普覆一切诸众生界。除灭一切诸恶道苦。广大悲愿。而为其根。于一切如来真实智慧种性中生。坚固不动。善巧方便。以为其茎。遍法界智。诸波罗蜜。以为其枝。禅定解脱。诸大三昧。以为其叶。总持辩才。菩提分法。以为其华。究竟无变。诸佛解脱。以为其果。佛子。如来智慧。大药王树。何故得名为无尽根。以究竟无休息故。不断菩萨行故。菩萨行即如来性。如来性即菩萨行。是故得名为无尽根。佛子。如来智慧。大药王树。其根生时。令一切菩萨。生不舍众生大慈悲根。其茎生时。令一切菩萨。增长坚固精进深心茎。其枝生时。令一切菩萨。增长一切诸波罗蜜枝。其叶生时。令一切菩萨。生长净戒头陀功德少欲知足叶。其华生时。令一切菩萨。具诸善根相好庄严华。其果生时。令一切菩萨。得无生忍。乃至一切佛灌顶忍果。佛子。如来智慧。大药王树。唯于二处。不能为作生长利益。所谓二乘堕于无为。广大深坑。及坏善根。非器众生。溺大邪见。贪爱之水。然亦于彼。曾无厌舍。佛子。如来智慧。无有增减。以根善安住。生无休息故。佛子。是为如来心第七相。诸菩萨摩诃萨。应如是知。复次佛子。譬如三千大千世界。劫火起时。焚烧一切。草木丛林。乃至铁围大铁围山。皆悉炽然无有遗余。佛子。假使有人。手执干草。投彼火中。于意云何。得不烧不。答言不也。佛子。彼所投草。容可不烧。如来智慧。分别三世一切众生。一切国土。一切劫数。一切诸法。无不知者。若言不知。无有是处。何以故。智慧平等。悉明达故。佛子。是为如来心第八相。诸菩萨摩诃萨。应如是知。复次佛子。譬如风灾。坏世界时。有大风起。名曰散坏。能坏三千大千世界铁围山等。皆成碎末。复有大风。名为能障。周匝三千大千世界。障散坏风。不令得至余方世界。佛子。若令无此能障大风。十方世界。无不坏尽。如来应正等觉。亦复如是。有大智风。名为能灭。能灭一切诸大菩萨。烦恼习气。有大智风。名为巧持。巧持其根未熟菩萨。不令能灭。大智风轮。断其一切烦恼习气。佛子。若无如来巧持智风。无量菩萨。皆堕声闻辟支佛地。由此智故。令诸菩萨。超二乘地。安住如来究竟之位。佛子。是为如来心第九相。诸菩萨摩诃萨。应如是知。复次佛子。如来智慧。无处不至。何以故。无一众生。而不具有如来智慧。但以妄想颠倒执着。而不证得。若离妄想。一切智自然智无碍智。则得现前。佛子。譬如有大经卷。量等三千大千世界。书写三千大千世界中事。一切皆尽。所谓书写大铁围山中事。量等大铁围山。书写大地中事。量等大地。书写中千世界中事。量等中千世界。书写小千世界中事。量等小千世界。如是若四天下。若大海。若须弥山。若地天宫殿。若欲界空居天宫殿。若色界宫殿。若无色界宫殿。一一书写。其量悉等此大经卷。虽复量等大千世界。而全住在一微尘中。如一微尘。一切微尘。皆亦如是。时有一人。智慧明达。具足成就清净天眼。见此经卷。在微尘内。于诸众生。无少利益。即作是念。我当以精进力。破彼微尘。出此经卷。令得饶益一切众生。作是念已。即起方便。破彼微尘。出此大经。令诸众生。普得饶益。如于一尘。一切微尘。应知悉然。佛子。如来智慧。亦复如是。无量无碍。普能利益一切众生。具足在于众生身中。但诸凡愚。妄想执着。不知不觉。不得利益。尔时如来。以无障碍。清净智眼。普观法界一切众生而作是言。奇哉奇哉。此诸众生。云何具有如来智慧。愚痴迷惑。不知不见。我当教以圣道。令其永离妄想执着。自于身中。得见如来广大智慧。与佛无异。即教彼众生。修习圣道。令离妄想。离妄想已。证得如来无量智慧。利益安乐一切众生。佛子。是为如来心第十相。诸菩萨摩诃萨。应如是知。佛子。菩萨摩诃萨。应以如是等无量无碍。不可思议广大相。知如来应正等觉心。尔时普贤菩萨摩诃萨。欲重明此义。而说颂言

  欲知诸佛心　　当观佛智慧
  佛智无依处　　如空无所依
  众生种种乐　　及诸方便智
  皆依佛智慧　　佛智无依止
  声闻与独觉　　及诸佛解脱
  皆依于法界　　法界无增减
  佛智亦如是　　出生一切智
  无增亦无减　　无生亦无尽
  如水潜流地　　求之无不得
  无念亦无尽　　功力遍十方
  佛智亦如是　　普在众生心
  若有勤修行　　疾得智光明
  如龙有四珠　　出生一切宝
  置之深密处　　凡人莫能见
  佛四智亦然　　出生一切智
  余人莫能见　　唯除大菩萨
  如海有四宝　　能饮一切水
  令海不流溢　　亦复无增减
  如来智亦尔　　息浪除法爱
  广大无有边　　能生佛菩萨
  下方至有顶　　欲色无色界
  一切依虚空　　虚空不分别
  声闻与独觉　　菩萨众智慧
  皆依于佛智　　佛智无分别
  雪山有药王　　名为无尽根
  能生一切树　　根茎叶华实
  佛智亦如是　　如来种中生
  既得菩提已　　复生菩萨行
  如人把干草　　置之于劫烧
  金刚犹洞然　　此无不烧理
  三世劫与刹　　及其中众生
  彼草容不烧　　此佛无不知
  有风名散坏　　能坏于大千
  若无别风止　　坏及无量界
  大智风亦尔　　灭诸菩萨惑
  别有善巧风　　令住如来地
  如有大经卷　　量等三千界
  在于一尘内　　一切尘悉然
  有一聪慧人　　净眼悉明见
  破尘出经卷　　普饶益众生
  佛智亦如是　　遍在众生心
  妄想之所缠　　不觉亦不知
  诸佛大慈悲　　令其除妄想
  如是乃出现　　饶益诸菩萨

大方广佛华严经卷第五十一大方广佛华严经卷第五十二

        于阗国三藏实叉难陀奉　制译

    如来出现品第三十七之三

佛子。菩萨摩诃萨。应云何知如来应正等觉境界。佛子。菩萨摩诃萨。以无障无碍智慧。知一切世间境界。是如来境界。知一切三世境界。一切刹境界。一切法境界。一切众生境界。真如无差别境界。法界无障碍境界。实际无边际境界。虚空无分量境界。无境界境界。是如来境界。佛子。如一切世间境界无量。如来境界亦无量。如一切三世境界无量。如来境界亦无量。乃至如无境界境界无量。如来境界亦无量。如无境界境界一切处无有。如来境界。亦如是。一切处无有。佛子。菩萨摩诃萨。应知心境界是如来境界。如心境界。无量无边。无缚无脱。如来境界。亦无量无边。无缚无脱。何以故。以如是如是。思惟分别。如是如是。无量显现故。佛子。如大龙王。随心降雨。其雨不从内出。不从外出。如来境界。亦复如是。随于如是思惟分别。则有如是无量显现。于十方中。悉无来处。佛子。如大海水。皆从龙王心力所起。诸佛如来。一切智海。亦复如是。皆从如来往昔大愿之所生起。佛子。一切智海。无量无边。不可思议。不可言说。然我今者。略说譬谕。汝应谛听。佛子。此阎浮提。有二千五百河。流入大海。西拘耶尼。有五千河。流入大海。东弗婆提。有七千五百河。流入大海。北郁单越。有一万河。流入大海。佛子。此四天下。如是二万五千河。相续不绝。流入大海。于意云何。此水多不。答言甚多。佛子。复有十光明龙王。雨大海中。水倍过前。百光明龙王。雨大海中。水复倍前。大庄严龙王。摩那斯龙王。雷震龙王。难陀跋难陀龙王。无量光明龙王。连霔不断龙王。大胜龙王。大奋迅龙王。如是等八十亿诸大龙王。各雨大海。皆悉展转。倍过于前。娑竭罗龙王太子。名阎浮幢。雨大海中。水复倍前。佛子。十光明龙王。宫殿中水。流入大海。复倍过前。百光明龙王。宫殿中水。流入大海。复倍过前。大庄严龙王。摩那斯龙王。雷震龙王。难陀跋难陀龙王。无量光明龙王。连霔不断龙王。大胜龙王。大奋迅龙王。如是等八十亿诸大龙王。宫殿各别。其中有水。流入大海。皆悉展转。倍过于前。娑竭罗龙王太子。阎浮幢宫殿中水。流入大海。复倍过前。佛子。娑竭罗龙王。连雨大海。水复倍前。其娑竭罗龙王。宫殿中水。涌出入海。复倍于前其所出水。绀琉璃色。涌出有时。是故大海。潮不失时。佛子。如是大海。其水无量。众宝无量。众生无量。所依大地。亦复无量。佛子。于汝意云何。彼大海。为无量不。答言。实为无量。不可为谕。佛子。此大海无量。于如来智海无量。百分不及一。千分不及一。乃至优波尼沙陀分。不及其一。但随众生心。为作譬谕。而佛境界。非譬所及。佛子。菩萨摩诃萨。应知如来智海无量。从初发心。修一切菩萨行不断故。应知宝聚无量。一切菩提分法。三宝种不断故。应知所住众生无量。一切学无学。声闻独觉。所受用故。应知住地无量。从初欢喜地。乃至究竟无障碍地。诸菩萨所居故。佛子。菩萨摩诃萨。为入无量智慧。利益一切众生故。于如来应正等觉境界。应如是知。尔时。普贤菩萨摩诃萨。欲重明此义。而说颂言

  如心境界无有量　　诸佛境界亦复然
  如心境界从意生　　佛境如是应观察
  如龙不离于本处　　以心威力霔大雨
  雨水虽无来去处　　随龙心故悉充洽
  十力牟尼亦如是　　无所从来无所去
  若有净心则现身　　量等法界入毛孔
  如海珍奇无有量　　众生大地亦复然
  水性一味等无别　　于中生者各蒙利
  如来智海亦如是　　一切所有皆无量
  有学无学住地人　　悉在其中得饶益

佛子。菩萨摩诃萨。应云何知如来应正等觉行。佛子。菩萨摩诃萨。应知无碍行是如来行。应知真如行是如来行。佛子如真如前际不生后际不动现在不起。如来行亦如是。不生不动不起。佛子。如法界非量非无量无形故。如来行亦如是。非量非无量无形故。佛子。譬如鸟飞虚空。经于百年。已经过处。未经过处。皆不可量。何以故。虚空界无边际故。如来行亦如是。假使有人。经百千亿那由他劫分别演说。已说未说。皆不可量。何以故。如来行无边际故。佛子。如来应正等觉。住无碍行。无有住处。而能普为一切众生。示现所行。令其见已。出过一切诸障碍道。佛子。譬如金翅鸟王。飞行虚空。回翔不去。以清净眼。观察海内诸龙宫殿。奋勇猛力。以左右翅。鼓扬海水。悉令两辟。知龙男女。命将尽者。而搏取之。如来应正等觉金翅鸟王。亦复如是。住无碍行。以净佛眼。观察法界诸宫殿中一切众生。若曾种善根。已成熟者。如来奋勇猛十力。以止观两翅。鼓扬生死大爱水海。使其两辟而撮取之。置佛法中。令断一切妄想戏论。安住如来无分别无碍行。佛子。譬如日月。独无等侣。周行虚空。利益众生。不作是念。我从何来。而至何所。诸佛如来。亦复如是。性本寂灭。无有分别。示现游行一切法界。为欲饶益诸众生故。作诸佛事。无有休息。不生如是戏论分别。我从彼来。而向彼去。佛子。菩萨摩诃萨应以如是等无量方便。无量性相。知见如来应正等觉。所行之行。尔时普贤菩萨。欲重明此义。而说颂言

  譬如真如不生灭　　无有方所无能见
  大饶益者行如是　　出过三世不可量
  法界非界非非界　　非是有量非无量
  大功德者行亦然　　非量无量无身故
  如鸟飞行亿千岁　　前后虚空等无别
  众劫演说如来行　　已说未说不可量
  金翅在空观大海　　辟水搏取龙男女
  十力能拔善根人　　令出有海除众惑
  譬如日月游虚空　　照临一切不分别
  世尊周行于法界　　教化众生无动念

佛子。诸菩萨摩诃萨。应云何知如来应正等觉成正觉。佛子。菩萨摩诃萨。应知如来成正觉。于一切义。无所观察。于法平等。无所疑惑。无二无相。无行无止。无量无际。远离二边。住于中道。出过一切文字言说。知一切众生。心念所行。根性欲乐。烦恼染习。举要言之。于一念中。悉知三世一切诸法。佛子。譬如大海。普能印现四天下中。一切众生。色身形像。是故共说。以为大海。诸佛菩提。亦复如是。普现一切众生心念。根性乐欲。而无所现。是故说名诸佛菩提。佛子。诸佛菩提。一切文字所不能宣。一切音声所不能及。一切言语所不能说。但随所应方便开示。佛子。如来应正等觉。成正觉时。得一切众生量等身。得一切法量等身。得一切刹量等身。得一切三世量等身。得一切佛量等身。得一切语言量等身。得真如量等身。得法界量等身。得虚空界量等身。得无碍界量等身。得一切愿量等身。得一切行量等身。得寂灭涅槃界量等身佛。子。如所得身。言语及心。亦复如是。得如是等无量无数。清净三轮。佛子。如来成正觉时。于其身中。普见一切众生成正觉。乃至普见一切众生入涅槃。皆同一性。所谓无性。无何等性。所谓无相性。无尽性。无生性。无灭性。无我性。无非我性。无众生性。无非众生性。无菩提性。无法界性。无虚空性。亦复无有成正觉性。知一切法。皆无性故。得一切智。大悲相续。救度众生。佛子。譬如虚空。一切世界。若成若坏。常无增减。何以故。虚空无生故。诸佛菩提。亦复如是。若成正觉。不成正觉。亦无增减。何以故。菩提无相无非相。无一无种种故。佛子。假使有人。能化作恒河沙等心。一一心复化作恒河沙等佛。皆无色无形无相。如是尽恒河沙等劫。无有休息。佛子。于汝意云何。彼人化心。化作如来。凡有几何。如来性起妙德菩萨言。如我解于仁所说义。化与不化。等无有别。云何问言凡有几何。普贤菩萨言。善哉善哉。佛子。如汝所说。设一切众生。于一念中。悉成正觉。与不成正觉。等无有异。何以故。菩提无相故。若无有相。则无增无减。佛子。菩萨摩诃萨。应如是知。成等正觉。同于菩提。一相无相。如来成正觉时。以一相方便。入善觉智三昧。入已于一成正觉广大身。现一切众生数等身。住于身中。如一成正觉广大身。一切成正觉广大身。悉亦如是。佛子。如来有如是等无量成正觉门。是故应知。如来所现身无有量。以无量故。说如来身。为无量界。等众生界。佛子。菩萨摩诃萨。应知。如来身一毛孔中。有一切众生数等诸佛身。何以故。如来成正觉身。究竟无生灭故。如一毛孔。遍法界。一切毛孔。悉亦如是。当知无有少许处空无佛身。何以故。如来成正觉。无处不至故。随其所能。随其势力。于道场菩提树下师子座上。以种种身。成等正觉。佛子。菩萨摩诃萨。应知。自心念念。常有佛成正觉。何以故。诸佛如来。不离此心成正觉故。如自心。一切众生心。亦复如是。悉有如来成等正觉。广大周遍。无处不有。不离不断。无有休息。入不思议方便法门。佛子。菩萨摩诃萨。应如是知。如来成正觉。尔时。普贤菩萨摩诃萨。欲重明此义。而说颂言

  正觉了知一切法　　无二离二悉平等
  自性清净如虚空　　我与非我不分别
  如海印现众生身　　以此说其为大海
  菩提普印诸心行　　是故说名为正觉
  譬如世界有成败　　而于虚空不增减
  一切诸佛出世间　　菩提一相恒无相
  如人化心化作佛　　化与不化性无异
  一切众生成菩提　　成与不成无增减
  佛有三昧名善觉　　菩提树下入此定
  放众生等无量光　　开悟群品如莲敷
  如三世劫刹众生　　所有心念及根欲
  如是数等身皆现　　是故正觉名无量

佛子。菩萨摩诃萨。应云何知如来应正等觉转法轮。佛子。菩萨摩诃萨。应如是知。如来以心自在力。无起无转。而转法轮。知一切法。恒无起故。以三种转。断所应断。而转法轮。知一切法。离边见故。离欲际非际。而转法轮。入一切法。虚空际故。无有言说。而转法轮。知一切法。不可说故。究竟寂灭。而转法轮。知一切法。涅槃性故。一切文字。一切言语。而转法轮。如来音声。无处不至故。知声如响。而转法轮。了于诸法。真实性故。于一音中。出一切音。而转法轮。毕竟无主故。无遗无尽。而转法轮。内外无著故。佛子。譬如一切文字语言。尽未来劫。说不可尽。佛转法轮。亦复如是。一切文字。安立显示。无有休息。无有穷尽。佛子。如来法轮。悉入一切语言文字。而无所住。譬如书字。普入一切事。一切语。一切算数。一切世间出世间处。而无所住。如来音声。亦复如是。普入一切处。一切众生。一切法。一切业。一切报中。而无所住。一切众生。种种语言。皆悉不离如来法轮。何以故。言音实相。即法轮故。佛子。菩萨摩诃萨。于如来转法轮。应如是知。复次佛子。菩萨摩诃萨。欲知如来。所转法轮。应知如来法轮。所出生处。何等为如来法轮。所出生处。佛子。如来随一切众生。心行欲乐。无量差别。出若干音声。而转法轮。佛子。如来应正等觉。有三昧。名究竟无碍无畏。入此三昧已。于成正觉。一一身一一口。各出一切众生数等言音。一一音中。众音具足。各各差别。而转法轮。令一切众生。皆生欢喜。能如是知转法轮者。当知此人。则为随顺一切佛法。不如是知。则非随顺。佛子。诸菩萨摩诃萨。应如是知。佛转法轮。普入无量众生界故

尔时普贤菩萨摩诃萨。欲重明此义。而说颂言

  如来法轮无所转　　三世无起亦无得
  譬如文字无尽时　　十力法轮亦如是
  如字普入而无至　　正觉法轮亦复然
  入诸言音无所入　　能令众生悉欢喜
  佛有三昧名究竟　　入此定已乃说法
  一切众生无有边　　普出其音令悟解
  一一音中复更演　　无量言音各差别
  于世自在无分别　　随其欲乐普使闻
  文字不从内外出　　亦不失坏无积聚
  而为众生转法轮　　如是自在甚奇特

佛子。菩萨摩诃萨。应云何知如来应正等觉。般涅槃。佛子。菩萨摩诃萨。欲知如来大涅槃者。当须了知根本自性。如真如涅槃。如来涅槃亦如是。如实际涅槃。如来涅槃亦如是。如法界涅槃。如来涅槃亦如是。如虚空涅槃。如来涅槃亦如是。如法性涅槃。如来涅槃亦如是。如离欲际涅槃。如来涅槃亦如是。如无相际涅槃。如来涅槃亦如是。如我性际涅槃。如来涅槃亦如是。如一切法性际涅槃。如来涅槃亦如是。如真如际涅槃。如来涅槃亦如是。何以故。涅槃无生无出故。若法无生无出。则无有灭。佛子。如来不为菩萨。说诸如来。究竟涅槃。亦不为彼。示现其事。何以故。为欲令见一切如来。常住其前。于一念中。见过去未来。一切诸佛。色相圆满。皆如现在。亦不起二不二想。何以故。菩萨摩诃萨。永离一切诸想着故。佛子。诸佛如来。为令众生。生欣乐故。出现于世。欲令众生。生恋慕故。示现涅槃。而实如来。无有出世。亦无涅槃。何以故。如来常住清净法界。随众生心。示现涅槃。佛子。譬如日出。普照世间。于一切净水器中。影无不现。普遍众处。而无来往。或一器破。便不现影。佛子。于汝意云何。彼影不现。为日咎不。答言不也。但由器坏。非日有咎。佛子。如来智日。亦复如是。普现法界。无前无后。一切众生。净心器中。佛无不现。心器常净。常见佛身。若心浊器破。则不得见。佛子。若有众生。应以涅槃。而得度者。如来则为示现涅槃。而实如来。无生无殁。无有灭度。佛子。譬如火大。于一切世间。能为火事。或时一处。其火息灭。于意云何。岂一切世间。火皆灭耶。答言不也。佛子。如来应正等觉。亦复如是。于一切世界。施作佛事。或于一世界。能事已毕。示入涅槃。岂一切世界。诸佛如来。悉皆灭度。佛子。菩萨摩诃萨。应如是知。如来应正等觉。大般涅槃。复次佛子。譬如幻师。善明幻术。以幻术力。于三千大千世界。一切国土。城邑聚落。示现幻身。以幻力持。经劫而住。然于余处。幻事已讫。隐身不现。佛子。于汝意云何。彼大幻师。岂于一处。隐身不现便一切处。皆隐灭耶。答言不也。佛子。如来应正等觉。亦复如是。善知无量智慧方便。种种幻术。于一切法界。普现其身。持令常住。尽未来际。或于一处。随众生心。所作事讫。示现涅槃。岂以一处。示入涅槃。便谓一切悉皆灭度。佛子。菩萨摩诃萨。应如是知如来应正等觉大般涅槃。复次佛子。如来应正等觉。示涅槃时。入不动三昧。入此三昧已。于一一身。各放无量百千亿那由他大光明。一一光明各出阿僧祇莲华。一一莲华。各有不可说。妙宝华蕊。一一华蕊有师子座。一一座上。皆有如来。结跏趺坐。其佛身数。正与一切众生数等。皆具上妙功德庄严。从本愿力之所生起。若有众生。善根熟者。见佛身已。则皆受化。然彼佛身。尽未来际。究竟安住。随宜化度一切众生。未曾失时。佛子。如来身者。无有方处。非实非虚。但以诸佛本誓愿力。众生堪度。则便出现。菩萨摩诃萨。应如是知。如来应正等觉。大般涅槃。佛子。如来住于无量无碍。究竟法界。虚空界。真如法性。无生无灭。及以实际。为诸众生。随时示现。本愿持故。无有休息。不舍一切众生。一切刹。一切法。尔时普贤菩萨摩诃萨。欲重明此义。而说颂言

  如日舒光照法界　　器坏水漏影随灭
  最胜智日亦如是　　众生无信见涅槃
  如火世间作火事　　于一城邑或时息
  人中最胜遍法界　　化事讫处示终尽
  幻师现身一切刹　　能事毕处则便谢
  如来化讫亦复然　　于余国土常见佛
  佛有三昧名不动　　化众生讫入此定
  一念身放无量光　　光出莲华华有佛
  佛身无数等法界　　有福众生所能见
  如是无数一一身　　寿命庄严皆具足
  如无生性佛出兴　　如无灭性佛涅槃
  言辞譬谕悉皆断　　一切义成无与等

佛子。菩萨摩诃萨。应云何知于如来应正等觉。见闻亲近。所种善根。佛子。菩萨摩诃萨。应知于如来所。见闻亲近。所种善根。皆悉不虚。出生无尽觉慧故。离于一切障难故。决定至究竟故。无有虚诳故。一切愿满故。不尽有为行故。随顺无为智故。生诸佛智故。尽未来际故。成一切种胜行故。到无功用智地故。佛子。譬如丈夫。食少金刚。终竟不消。要穿其身。出在于外。何以故。金刚不与肉身杂秽。而同止故。于如来所。种少善根。亦复如是。要穿一切有为诸行。烦恼身过。到于无为究竟智处。何以故。此少善根。不与有为诸行烦恼。而共住故。佛子。假使干草。积同须弥。投火于中。如芥子许。必皆烧尽。何以故。火能烧故。于如来所。种少善根。亦复如是。必能烧尽一切烦恼。究竟得于无余涅槃。何以故。此少善根。性究竟故。佛子。譬如雪山。有药王树。名曰善见。若有见者。眼得清净。若有闻者。耳得清净。若有嗅者。鼻得清净。若有尝者。舌得清净。若有触者。身得清净。若有众生。取彼地土。亦能为作除病利益。佛子。如来应正等觉。无上药王。亦复如是。能作一切饶益众生。若有得见如来色身。眼得清净。若有得闻如来名号。耳得清净。若有得嗅如来戒香。鼻得清净。若有得尝如来法味。舌得清净。具广长舌。解语言法。若有得触如来光者。身得清净。究竟获得无上法身。若于如来。生忆念者。则得念佛三昧清净。若有众生。供养如来。所经土地。及塔庙者。亦具善根。灭除一切诸烦恼患。得贤圣乐。佛子。我今告汝。设有众生。见闻于佛。业障缠覆。不生信乐。亦种善根。无空过者。乃至究竟。入于涅槃。佛子。菩萨摩诃萨。应如是知。于如来所。见闻亲近。所种善根。悉离一切诸不善法。具足善法。佛子。如来以一切譬谕。说种种事。无有譬谕。能说此法。何以故。心智路绝。不思议故。诸佛菩萨。但随众生心。令其欢喜。为说譬谕。非是究竟。佛子。此法门。名为如来秘密之处。名一切世间所不能知。名入如来印。名开大智门。名示现如来种性。名成就一切菩萨。名一切世间所不能坏。名一向随顺如来境界。名能净一切诸众生界。名演说如来根本实性。不思议究竟法。佛子。此法门。如来不为余众生说。唯为趣向大乘菩萨说。唯为乘不思议乘菩萨说。此法门。不入一切余众生手。唯除诸菩萨摩诃萨。佛子。譬如转轮圣王。所有七宝。因此宝故。显示轮王。此宝不入余众生手。唯除第一夫人所生太子。具足成就圣王相者。若转轮王。无此太子具众德者。王命终后。此诸宝等。于七日中。悉皆散灭。佛子。此经珍宝。亦复如是。不入一切余众生手。唯除如来法王真子。生如来家。种如来相。诸善根者。佛子。若无此等佛之真子。如是法门。不久散灭。何以故。一切二乘。不闻此经。何况受持。读诵书写。分别解说。唯诸菩萨。乃能如是。是故菩萨摩诃萨。闻此法门。应大欢喜。以尊重心。恭敬顶受。何以故。菩萨摩诃萨。信乐此经。疾得阿耨多罗三藐三菩提故。佛子。设有菩萨。于无量百千亿那由他劫。行六波罗蜜。修习种种菩提分法。若未闻此如来不思议。大威德法门。或时闻已。不信不解。不顺不入不得名为真实菩萨。以不能生如来家故。若得闻此如来无量不可思议。无障无碍。智慧法门。闻已信解。随顺悟入。当知此人。生如来家。随顺一切如来境界。具足一切诸菩萨法。安住一切种智境界。远离一切诸世间法。出生一切如来所行。通达一切菩萨法性。于佛自在。心无疑惑。住无师法。深入如来无碍境界。佛子。菩萨摩诃萨。闻此法已。则能以平等智。知无量法。则能以正直心。离诸分别。则能以胜欲乐。现见诸佛。则能以作意力。入平等虚空界。则能以自在念。行无边法界。则能以智慧力。具一切功德。则能以自然智。离一切世间垢。则能以菩提心。入一切十方网。则能以大观察。知三世诸佛。同一体性。则能以善根回向智。普入如是法。不入而入。不于一法。而有攀缘。恒以一法。观一切法。佛子。菩萨摩诃萨。成就如是功德。少作功力。得无师自然智。尔时普贤菩萨。欲重明此义。而说颂言

  见闻供养诸如来　　所得功德不可量
  于有为中终不尽　　要灭烦恼离众苦
  譬人吞服少金刚　　终竟不消要当出
  供养十力诸功德　　灭惑必至金刚智
  如干草积等须弥　　投芥子火悉烧尽
  供养诸佛少功德　　必断烦恼至涅槃
  雪山有药名善见　　见闻嗅触消众疾
  若有见闻于十力　　得胜功德到佛智

尔时佛神力故。法如是故。十方各有十不可说。百千亿那由他世界。六种震动。所谓东涌西没。西涌东没。南涌北没。北涌南没。边涌中没。中涌边没。十八相动。所谓动。遍动。等遍动。起。遍起。等遍起。涌。遍涌。等遍涌。震。遍震。等遍震。吼。遍吼。等遍吼。击。遍击。等遍击。雨出过诸天。一切华云。一切盖云。幢云幡云。香云鬘云。涂香云。庄严具云。大光明摩尼宝云。诸菩萨赞叹云。不可说菩萨各差别身云。雨成正觉云。严净不思议世界云。雨如来言语音声云。充满无边法界。如此四天下。如来神力。如是示现。令诸菩萨。皆大欢喜。周遍十方一切世界。悉亦如是。是时十方。各过八十不可说。百千亿那由他佛刹微尘数世界外。各有八十不可说百千亿那由他佛刹微尘数如来。同名普贤。皆现其前。而作是言。善哉佛子。乃能承佛威力。随顺法性。演说如来出现不思议法。佛子。我等十方八十不可说百千亿那由他佛刹微尘数。同名诸佛。皆说此法。如我所说。十方世界。一切诸佛。亦如是说。佛子。今此会中。十万佛刹微尘数。菩萨摩诃萨。得一切菩萨。神通三昧。我等皆与授记。一生当得阿耨多罗三藐三菩提。佛刹微尘数众生。发阿耨多罗三藐三菩提心。我等亦与授记。于当来世。经不可说佛刹微尘数劫。皆得成佛。同号佛殊胜境界。我等为令未来诸菩萨。闻此法故。皆共护持。如此四天下。所度众生。十方百千亿那由他。无数无量。乃至不可说不可说。法界虚空等。一切世界中。所度众生。皆亦如是。尔时十方诸佛威神力故。毗卢遮那本愿力故。法如是故。善根力故。如来起智不越念故。如来应缘不失时故。随时觉悟诸菩萨故。往昔所作无失坏故。令得普贤广大行故。显现一切智自在故。十方各过十不可说百千亿那由他佛刹微尘数世界外。各有十不可说百千亿那由他佛刹微尘数菩萨。来诣于此。充满十方一切法界。示现菩萨广大庄严。放大光明网。震动一切十方世界。坏散一切诸魔宫殿。消灭一切诸恶道苦。显现一切如来威德。歌咏赞叹。如来无量差别功德法。普雨一切种种雨。示现无量差别身。领受无量诸佛法。以佛神力。各作是言。善哉佛子。乃能说此如来不可坏法。佛子。我等一切皆名普贤。各从普光明世界。普幢自在如来所。而来于此。彼一切处。亦说是法。如是文句。如是义理。如是宣说。如是决定。皆同于此。不增不减。我等皆以佛神力故。得如来法故。来诣此处。为汝作证。如我来此。十方等虚空遍法界。一切世界。诸四天下。亦复如是

尔时普贤菩萨。承佛神力。观察一切菩萨大众。欲重明如来出现。广大威德。如来正法。不可沮坏。无量善根。皆悉不空。诸佛出世。必具一切最胜之法。善能观察诸众生心。随应说法。未曾失时。生诸菩萨。无量法光。一切诸佛。自在庄严。一切如来。一身无异。从本大行之所生起。而说颂言

  一切如来诸所作　　世间譬谕无能及
  为令众生得悟解　　非谕为谕而显示
  如是微密甚深法　　百千万劫难可闻
  精进智慧调伏者　　乃得闻此秘奥义
  若闻此法生欣庆　　彼曾供养无量佛
  为佛加持所摄受　　人天赞叹常供养
  此为超世第一财　　此能救度诸群品
  此能出生清净道　　汝等当持莫放逸

大方广佛华严经卷第五十二大方广佛华严经卷第五十三

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之一

尔时世尊。在摩竭提国阿兰若法菩提场中普光明殿。坐莲华藏师子之座。妙悟皆满。二行永绝。达无相法。住于佛住。得佛平等。到无障处。不可转法。所行无碍。立不思议。普见三世。身恒充遍一切国土。智恒明达一切诸法。了一切行。尽一切疑。无能测身。一切菩萨。等所求智。到佛无二究竟彼岸。具足如来平等解脱。证无中边。佛平等地。尽于法界。等虚空界。与不可说。百千亿那由他佛刹微尘数。菩萨摩诃萨俱。皆一生当得阿耨多罗三藐三菩提。各从他方。种种国土而共来集。悉具菩萨。方便智慧。所谓善能观察一切众生。以方便力。令其调伏。住菩萨法。善能观察一切世界。以方便力。普皆往诣。善能观察涅槃境界。思惟筹量。永离一切戏论分别。而修妙行。无有间断。善能摄受一切众生。善入无量诸方便法。知诸众生。空无所有。而不坏业果。善知众生心。使诸根境界方便。种种差别。悉能受持三世佛法。自得解了。复为他说。于世出世无量诸法。皆善安住。知其真实。于有为无为。一切诸法。悉善观察。知无有二。于一念中。悉能获得三世诸佛。所有智慧。于念念中。悉能示现成等正觉。令一切众生。发心成道。于一众生心之所缘。悉知一切众生境界。虽入如来一切智地。而不舍菩萨行。诸所作业。智慧方便。而无所作。为一一众生。住无量劫。而于阿僧祇劫。难可值遇。转正法轮。调伏众生。皆不唐捐。三世诸佛。清净行愿。悉已具足。成就如是无量功德。一切如来。于无边劫。说不可尽。其名曰普贤菩萨。普眼菩萨。普化菩萨。普慧菩萨。普见菩萨。普光菩萨。普观菩萨。普照菩萨。普幢菩萨。普觉菩萨。如是等十不可说百千亿那由他佛刹微尘数。皆悉成就普贤行愿。深心大愿。皆已圆满。一切诸佛。出兴世处。悉能往诣。请转法轮。善能受持诸佛法眼。不断一切诸佛种性。善知一切诸佛兴世。授记次第。名号国土。成等正觉。转于法轮。无佛世界。现身成佛。能令一切杂染众生。皆悉清净。能灭一切菩萨业障。入于无碍清净法界

尔时普贤菩萨摩诃萨入广大三昧。名佛华庄严。入此三昧时。十方所有。一切世界。六种十八相动。出大音声。靡不皆闻。然后从其三昧而起。尔时普慧菩萨。知众已集。问普贤菩萨言。佛子。愿为演说。何等为菩萨摩诃萨依。何等为奇特想。何等为行。何等为善知识。何等为勤精进。何等为心得安隐。何等为成就众生。何等为戒。何等为自知受记。何等为入菩萨。何等为入如来。何等为入众生心行。何等为入世界。何等为入劫。何等为说三世。何等为入三世。何等为发无疲厌心。何等为差别智。何等为陀罗尼。何等为演说佛。何等为发普贤心。何等为普贤行法。以何等故。而起大悲。何等为发菩提心因缘。何等为于善知识。起尊重心。何等为清净。何等为诸波罗蜜。何等为智随觉。何等为证知。何等为力。何等为平等。何等为佛法实义句。何等为说法。何等为持。何等为辩才。何等为自在。何等为无著性。何等为平等心。何等为出生智慧。何等为变化。何等为力持。何等为得大欣慰。何等为深入佛法。何等为依止。何等为发无畏心。何等为发无疑惑心。何等为不思议。何等为巧密语。何等为巧分别智。何等为入三昧。何等为遍入。何等为解脱门。何等为神通。何等为明。何等为解脱。何等为园林。何等为宫殿。何等为所乐。何等为庄严。何等为发不动心。何等为不舍深大心。何等为观察。何等为说法。何等为清净。何等为印。何等为智光照。何等为无等住。何等为无下劣心。何等为如山增上心。何等为入无上菩提如海智。何等为如宝住。何等为发如金刚大乘誓愿心。何等为大发起。何等为究竟大事。何等为不坏信。何等为授记。何等为善根回向。何等为得智慧。何等为发无边广大心。何等为伏藏。何等为律仪。何等为自在。何等为无碍用。何等为众生无碍用。何等为刹无碍用。何等为法无碍用。何等为身无碍用。何等为愿无碍用。何等为境界无碍用。何等为智无碍用。何等为神通无碍用。何等为神力无碍用。何等为力无碍用。何等为游戏。何等为境界。何等为力。何等为无畏。何等为不共法。何等为业。何等为身。何等为身业。何等为身。何等为语。何等为净修语业。何等为得守护。何等为成辨大事。何等为心。何等为发心。何等为周遍心。何等为诸根。何等为深心。何等为增上深心。何等为勤修。何等为决定解。何等为决定解入世界。何等为决定解入众生界。何等为习气。何等为取。何等为修。何等为成就佛法。何等为退失佛法道。何等为离生道。何等为决定法。何等为出生佛法道。何等为大丈夫名号。何等为道。何等为无量道。何等为助道。何等为修道。何等为庄严道。何等为足。何等为手。何等为腹。何等为藏。何等为心。何等为被甲。何等为器仗。何等为首。何等为眼。何等为耳。何等为鼻。何等为舌。何等为身。何等为意。何等为行。何等为住。何等为坐。何等为卧。何等为所住处。何等为所行处。何等为观察。何等为普观察。何等为奋迅。何等为师子吼。何等为清净施。何等为清净戒。何等为清净忍。何等为清净精进。何等为清净定。何等为清净慧。何等为清净慈。何等为清净悲。何等为清净喜。何等为清净舍。何等为义。何等为法。何等为福德助道具。何等为智慧助道具。何等为明足。何等为求法。何等为明了法。何等为修行法。何等为魔。何等为魔业。何等为舍离魔业。何等为见佛。何等为佛业。何等为慢业。何等为智业。何等为魔所摄持。何等为佛所摄持。何等为法所摄持。何等为住兜率天所作业。何故于兜率天宫殁。何故现处胎。何等为现微细趣。何故现初生。何故现微笑。何故示行七步。何故现童子地。何故现处内宫。何故现出家。何故示苦行。云何往诣道场。云何坐道场。何等为坐道场时奇特相。何故示降魔。何等为成如来力。云何转法轮。何故因转法轮。得白净法。何故如来应正等觉。示般涅槃。善哉佛子。如是等法。愿为演说

尔时普贤菩萨。告普慧等。诸菩萨言。佛子。菩萨摩诃萨。有十种依。何等为十。所谓以菩提心为依。恒不忘失故。以善知识为依。和合如一故。以善根为依。修集增长故。以波罗蜜为依。具足修行故。以一切法为依。究竟出离故。以大愿为依。增长菩提故。以诸行为依。普皆成就故。以一切菩萨为依。同一智慧故。以供养诸佛为依。信心清净故。以一切如来为依。如慈父教诲不断故。是为十。若诸菩萨。安住此法。则得为如来无上大智。所依处。佛子。菩萨摩诃萨。有十种奇特想。何等为十。所谓于一切善根。生自善根想。于一切善根。生菩提种子想。于一切众生。生菩提器想。于一切愿。生自愿想。于一切法。生出离想。于一切行。生自行想。于一切法。生佛法想。于一切语言法。生语言道想。于一切佛。生慈父想。于一切如来。生无二想。是为十。若诸菩萨。安住此法。则得无上善巧想。佛子。菩萨摩诃萨。有十种行。何等为十。所谓一切众生行。普令成熟故。一切求法行。咸悉修学故。一切善根行。悉使增长故。一切三昧行。一心不乱故。一切智慧行。无不了知故。一切修习行。无不能修故。一切佛刹行。皆悉庄严故。一切善友行。恭敬供养故。一切如来行。尊重承事故。是为十。若诸菩萨。安住此法。则得如来无上大智慧行。佛子。菩萨摩诃萨。有十种善知识。何等为十。所谓令住菩提心善知识。令生善根善知识。令行诸波罗蜜善知识。令解说一切法善知识。令成熟一切众生善知识。令得决定辩才善知识。令不着一切世间善知识。令于一切劫。修行无厌倦善知识。令安住普贤行善知识。令入一切佛智所入善知识。是为十。佛子。菩萨摩诃萨。有十种勤精进。何等为十。所谓教化一切众生勤精进。深入一切法勤精进。严净一切世界勤精进。修行一切菩萨所学勤精进。灭除一切众生恶勤精进。止息一切三恶道苦勤精进。摧破一切众魔勤精进。愿为一切众生。作清净眼勤精进。供养一切诸佛勤精进。令一切如来。皆悉欢喜勤精进。是为十。若诸菩萨安住此法。则得具足如来无上精进波罗蜜。佛子。菩萨摩诃萨。有十种心得安隐。何等为十。所谓自住菩提心。亦当令他住菩提心。心得安隐。自究竟离忿诤。亦当令他离忿诤。心得安隐。自离凡愚法。亦令他离凡愚法。心得安隐。自勤修善根。亦令他勤修善根。心得安隐。自住波罗蜜道。亦令他住波罗蜜道。心得安隐。自生在佛家。亦当令他生于佛家。心得安隐。自深入无自性真实法。亦令他入无自性真实法。心得安隐。自不诽谤一切佛法。亦令他不诽谤一切佛法。心得安隐。自满一切智菩提愿。亦令他满一切智菩提愿。心得安隐。自深入一切如来。无尽智藏。亦令他入一切如来。无尽智藏。心得安隐。是为十。若诸菩萨。安住此法。则得如来无上大智安隐。佛子。菩萨摩诃萨。有十种成就众生。何等为十。所谓以布施成就众生。以色身成就众生。以说法成就众生。以同行成就众生。以无染着成就众生。以开示菩萨行。成就众生。以炽然示现一切世界。成就众生。以示现佛法大威德。成就众生。以种种神通变现。成就众生。以种种微密。善巧方便。成就众生。是为十。菩萨以此。成就众生界。佛子。菩萨摩诃萨。有十种戒。何等为十。所谓不舍菩提心戒。远离二乘地戒。观察利益一切众生戒。令一切众生住佛法戒。修一切菩萨所学戒。于一切法。无所得戒。以一切善根。回向菩提戒。不着一切如来身戒。思惟一切法。离取着戒。诸根律仪戒。是为十。若诸菩萨。安住此法。则得如来无上广大。戒波罗蜜。佛子。菩萨摩诃萨。有十种受记法。菩萨以此。自知受记。何等为十。所谓以殊胜意。发菩提心。自知受记。永不厌舍诸菩萨行。自知受记。住一切劫。行菩萨行。自知受记。修一切佛法。自知受记。于一切佛教。一向深信。自知受记。修一切善根。皆令成就。自知受记。置一切众生。于佛菩提。自知受记。于一切善知识。和合无二。自知受记。于一切善知识。起如来想。自知受记。恒勤守护菩提本愿。自知受记。是为十。佛子。菩萨摩诃萨。有十种入。入诸菩萨。何等为十。所谓入本愿。入行入聚。入诸波罗蜜。入成就。入差别愿。入种种解。入庄严佛土。入神力自在。入示现受生。是为十。菩萨以此。普入三世一切菩萨。佛子。菩萨摩诃萨。有十种入。入诸如来。何等为十。所谓入无边成正觉。入无边转法轮。入无边方便法。入无边差别音声。入无边调伏众生。入无边神力自在。入无边种种差别身。入无边三昧。入无边力无所畏。入无边示现涅槃。是为十。菩萨以此。普入三世一切如来。佛子。菩萨摩诃萨。有十种入众生行。何等为十。所谓入一切众生过去行。入一切众生未来行。入一切众生现在行。入一切众生善行。入一切众生不善行。入一切众生心行。入一切众生根行。入一切众生解行。入一切众生。烦恼习气行。入一切众生。教化调伏。时非时行。是为十。菩萨以此。普入一切诸众生行。佛子。菩萨摩诃萨。有十种入世界。何等为十。所谓入染世界。入净世界。入小世界。入大世界。入微尘中世界。入微细世界。入覆世界。入仰世界。入有佛世界。入无佛世界。是为十。菩萨以此。普入十方一切世界。佛子。菩萨摩诃萨。有十种入劫。何等为十。所谓入过去劫。入未来劫。入现在劫。入可数劫。入不可数劫。入可数劫即不可数劫。入不可数劫即可数劫。入一切劫即非劫。入非劫即一切劫。入一切劫即一念。是为十。菩萨以此。普入一切劫。佛子。菩萨摩诃萨。有十种说三世。何等为十。所谓过去世说过去世。过去世说未来世。过去世说现在世。未来世说过去世。未来世说现在世。未来世说无尽。现在世说过去世。现在世说未来世。现在世说平等。现在世说三世即一念。是为十。菩萨以此。普说三世。佛子。菩萨摩诃萨。有十种知三世。何等为十。所谓知诸安立。知诸语言。知诸谈议。知诸轨则。知诸称谓。知诸制令。知其假名。知其无尽。知其寂灭。知一切空。是为十。菩萨以此。普知一切三世诸法。佛子。菩萨摩诃萨。发十种无疲厌心。何等为十。所谓供养一切诸佛无疲厌心。亲近一切善知识无疲厌心。求一切法无疲厌心。听闻正法无疲厌心。宣说正法无疲厌心。教化调伏一切众生无疲厌心。置一切众生。于佛菩提无疲厌心。于一一世界。经不可说不可说劫。行菩萨行无疲厌心。游行一切世界无疲厌心。观察思惟一切佛法无疲厌心。是为十。若诸菩萨。安住此法。则得如来无疲厌无上大智。佛子。菩萨摩诃萨。有十种差别智。何等为十。所谓知众生差别智。知诸根差别智。知业报差别智。知受生差别智。知世界差别智。知法界差别智。知诸佛差别智。知诸法差别智。知三世差别智。知一切语言道差别智。是为十。若诸菩萨。安住此法。则得如来无上广大差别智。佛子。菩萨摩诃萨。有十种陀罗尼。何等为十。所谓闻持陀罗尼持一切法。不忘失故。修行陀罗尼。如实巧观一切法故。思惟陀罗尼。了知一切诸法性故。法光明陀罗尼。照不思议诸佛法故。三昧陀罗尼。普于现在一切佛所。听闻正法。心不乱故。圆音陀罗尼。解了不思议。音声语言故。三世陀罗尼。演说三世不可思议。诸佛法故。种种辩才陀罗尼。演说无边诸佛法故。出生无碍耳陀罗尼。不可说佛所说之法。悉能闻故。一切佛法陀罗尼。安住如来力无畏故。是为十。若诸菩萨。欲得此法当勤修学。佛子。菩萨摩诃萨。说十种佛。何等为十。所谓成正觉佛。愿佛。业报佛。住持佛。涅槃佛。法界佛。心佛。三昧佛。本性佛。随乐佛。是为十

佛子。菩萨摩诃萨。发十种普贤心。何等为十。所谓发大慈心。救护一切众生故。发大悲心。代一切众生受苦故。发一切施心。悉舍所有故。发念一切智为首心。乐求一切佛法故。发功德庄严心。学一切菩萨行故。发如金刚心。一切处受生。不忘失故。发如海心。一切白净法。悉流入故。发如大山王心。一切恶言。皆忍受故。发安隐心。施一切众生。无怖畏故。发般若波罗蜜究竟心。巧观一切法。无所有故。是为十。若诸菩萨。安住此心。疾得成就普贤善巧智。佛子。菩萨摩诃萨。有十种普贤行法。何等为十。所谓愿住未来一切劫普贤行法。愿供养恭敬本来一切佛普贤行法。愿安置一切众生。于普贤菩萨行普贤行法。愿积集一切善根普贤行法。愿入一切波罗蜜普贤行法。愿满足一切菩萨行普贤行法。愿庄严一切世界普贤行法。愿生一切佛刹普贤行法。愿善观察一切法普贤行法。愿于一切佛国土。成无上菩提普贤行法。是为十。若诸菩萨。勤修此法。疾得满足普贤行愿。佛子。菩萨摩诃萨。以十种观众生。而起大悲。何等为十。所谓观察众生。无依无怙。而起大悲。观察众生。性不调顺。而起大悲。观察众生。贫无善根。而起大悲。观察众生。长夜睡眠。而起大悲。观察众生。行不善法。而起大悲。观察众生。欲缚所缚。而起大悲。观察众生。没生死海。而起大悲。观察众生。长婴疾苦。而起大悲。观察众生。无善法欲。而起大悲。观察众生。失诸佛法。而起大悲。是为十。菩萨恒以此心。观察众生。佛子。菩萨摩诃萨。有十种发菩提心因缘。何等为十。所谓为教化调伏一切众生故。发菩提心。为除灭一切众生苦聚故。发菩提心。为与一切众生。具足安乐故。发菩提心。为断一切众生愚痴故。发菩提心。为与一切众生佛智故。发菩提心。为恭敬供养一切诸佛故。发菩提心。为随如来教。令佛欢喜故。发菩提心。为见一切佛。色身相好故。发菩提心。为入一切佛。广大智慧故。发菩提心。为显现诸佛力无所畏故。发菩提心。是为十。佛子。若菩萨发无上菩提心。为悟入一切智智故。亲近供养善知识时。应起十种心。何等为十。所谓起给侍心。欢喜心。无违心。随顺心。无异求心。一向心。同善根心。同愿心。如来心。同圆满行心。是为十。佛子。若菩萨摩诃萨。起如是心。则得十种清净。何等为十。所谓深心清净。到于究竟无失坏故。色身清净。随其所宜。为示现故。音声清净。了达一切诸语言故。辩才清净。善说无边诸佛法故。智慧清净。舍离一切愚痴暗故。受生清净。具足菩萨。自在力故。眷属清净。成就过去同行众生。诸善根故。果报清净。除灭一切诸业障故。大愿清净。与诸菩萨。性无二故。诸行清净。以普贤乘。而出离故。是为十。佛子。菩萨摩诃萨。有十种波罗蜜。何等为十。所谓施波罗蜜。悉舍一切诸所有故。戒波罗蜜。净佛戒故。忍波罗蜜。住佛忍故。精进波罗蜜。一切所作。不退转故。禅波罗蜜。念一境故。般若波罗蜜。如实观察一切法故。智波罗蜜。入佛力故。愿波罗蜜。满足普贤诸大愿故。神通波罗蜜。示现一切自在用故。法波罗蜜。普入一切诸佛法故。是为十。若诸菩萨。安住此法。则得具足如来无上大智波罗蜜。佛子。菩萨摩诃萨。有十种智随觉。何等为十。所谓一切世界。无量差别智随觉。一切众生界。不可思议智随觉。一切诸法。一入种种。种种入一智随觉。一切法界。广大智随觉。一切虚空界。究竟智随觉。一切世界。入过去世智随觉。一切世界入未来世智随觉一切世界。入现在世智随觉。一切如来。无量行愿。皆于一智。而得圆满智随觉。三世诸佛。皆同一行。而得出离智随觉是为十。若诸菩萨。安住此法。则得一切法。自在光明。所愿皆满。于一念顷。悉能解了一切佛法。成等正觉。佛子。菩萨摩诃萨。有十种证知。何等为十。所谓知一切法一相。知一切法无量相。知一切法在一念。知一切众生心行无碍。知一切众生诸根平等。知一切众生烦恼习气行。知一切众生心使行。知一切众生善不善行。知一切菩萨愿行自在。住持变化。知一切如来具足十力。成等正觉。是为十。若诸菩萨。安住此法。则得一切法善巧方便。佛子。菩萨摩诃萨。有十种力。何等为十。所谓入一切法自性力。入一切法如化力。入一切法如幻力。入一切法皆是佛法力。于一切法无染着力。于一切法甚明解力。于一切善知识。恒不舍离。尊重心力。令一切善根。顺至无上智王力。于一切佛法。深信不谤力。令一切智心。不退善巧力。是为十。若诸菩萨。安住此法。则具如来无上诸力。佛子。菩萨摩诃萨。有十种平等。何等为十。所谓于一切众生平等。一切法平等。一切刹平等。一切深心平等。一切善根平等。一切菩萨平等。一切愿平等。一切波罗蜜平等。一切行平等。一切佛平等。是为十。若诸菩萨。安住此法。则得一切诸佛无上平等法。佛子。菩萨摩诃萨。有十种佛法实义句。何等为十。所谓。一切法但有名。一切法犹如幻。一切法犹如影。一切法但缘起。一切法业清净。一切法但文字所作。一切法实际。一切法无相。一切法第一义。一切法法界。是为十。若诸菩萨。安住此法。则善入一切智智无上真实义。佛子。菩萨摩诃萨。说十种法。何等为十。所谓说甚深法。说广大法。说种种法。说一切智法。说随顺波罗蜜法。说出生如来力法。说三世相应法。说令菩萨不退法。说赞叹佛功德法。说一切菩萨学一切佛平等。一切如来境界相应法。是为十。若诸菩萨。安住此法。则得如来无上巧说法。佛子。菩萨摩诃萨。有十种持。何等为十。所谓持所集一切福德善根。持一切如来所说法。持一切譬谕。持一切法理趣门。持一切出生陀罗尼门。持一切除疑惑法。持成就一切菩萨法。持一切如来所说平等三昧门。持一切法照明门。持一切诸佛神通游戏力。是为十。若诸菩萨。安住此法。则得如来无上大智住持力。佛子。菩萨摩诃萨。有十种辩才。何等为十。所谓于一切法。无分别辩才。于一切法。无所作辩才。于一切法。无所著辩才。于一切法。了达空辩才。于一切法。无疑暗辩才。于一切法。佛加被辩才。于一切法。自觉悟辩才。于一切法。文句差别。善巧辩才。于一切法。真实说辩才。随一切众生。心令欢喜辩才。是为十。若诸菩萨。安住此法。则得如来无上巧妙辩才。佛子。菩萨摩诃萨。有十种自在。何等为十。所谓教化调伏一切众生自在。普照一切法自在。修一切善根行自在。广大智自在。无所依戒自在。一切善根回向菩提自在。精进不退转自在。智慧摧破一切众魔自在。随所乐欲令发菩提心自在。随所应化现成正觉自在。是为十。若诸菩萨。安住此法。则得如来无上大智自在。佛子。菩萨摩诃萨。有十种无著。何等为十。所谓于一切世界无著。于一切众生无著。于一切法无著。于一切所作无著。于一切善根无著。于一切受生处无著。于一切愿无著。于一切行无著。于一切菩萨无著。于一切佛无著。是为十。若诸菩萨。安住此法。则能速转一切众想。得无上清净智慧。佛子。菩萨摩诃萨。有十种平等心。何等为十。所谓积集一切功德平等心。发一切差别愿平等心。于一切众生身平等心。于一切众生业报平等心。于一切法平等心。于一切净秽国土平等心。于一切众生解平等心。于一切行无所分别平等心。于一切佛力无畏平等心。于一切如来智慧平等心。是为十。若诸菩萨。安住其中。则得如来无上大平等心。佛子。菩萨摩诃萨。有十种出生智慧。何等为十。所谓知一切众生解。出生智慧。知一切佛刹。种种差别。出生智慧。知十方网分齐。出生智慧。知覆仰等一切世界。出生智慧。知一切法。一性种种性。广大住。出生智慧。知一切种种身。出生智慧。知一切世间颠倒妄想。悉无所著。出生智慧。知一切法究竟。皆以一道出离。出生智慧。知如来神力。能入一切法界。出生智慧。知三世一切众生。佛种不断。出生智慧。是为十。若诸菩萨。安住此法。则于诸法。无不了达。佛子。菩萨摩诃萨。有十种变化。何等为十。所谓一切众生变化。一切身变化。一切刹变化。一切供养变化。一切音声变化。一切行愿变化。一切教化调伏众生变化。一切成正觉变化。一切说法变化。一切加持变化。是为十。若诸菩萨。安住此法。则得具足一切无上变化法。佛子。菩萨摩诃萨。有十种力持。何等为十。所谓佛力持。法力持。众生力持。业力持。行力持。愿力持。境界力持。时力持。善力持。智力持。是为十。若诸菩萨。安住此法。则于一切法得无上自在力持

大方广佛华严经卷第五十三大方广佛华严经卷第五十四

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之二

佛子。菩萨摩诃萨。有十种大欣慰。何等为十。所谓诸菩萨。发如是心。尽未来世。所有诸佛。出兴于世。我当皆得随逐承事。令生欢喜。如是思惟。心大欣慰。复作是念。彼诸如来。出兴于世。我当悉以无上供具。恭敬供养。如是思惟。心大欣慰。复作是念。我于诸佛所。兴供养时。彼诸如来。必示诲我法。我悉以深心。恭敬听受。如说修行。于菩萨地。必得已生。现生当生。如是思惟。心大欣慰。复作是念。我当于不可说不可说劫。行菩萨行。常与一切诸佛菩萨。而得共俱。如是思惟。心大欣慰。复作是念。我于往昔。未发无上大菩提心。有诸怖畏。所谓不活畏。恶名畏。死畏。堕恶道畏。大众威德畏。自一发心。悉皆远离。不惊不恐。不畏不惧。不怯不怖。一切众魔。及诸外道。所不能坏。如是思惟。心大欣慰。复作是念。我当令一切众生。成无上菩提。成菩提已。我当于彼佛所。修菩萨行。尽其形寿。以大信心。兴所应供佛。诸供养具。而为供养。及涅槃后。各起无量塔。供养舍利。及受持守护。所有遗法。如是思惟。心大欣慰。又作是念。十方所有一切世界。我当悉以无上庄严。而庄严之。皆令具足。种种奇妙。平等清净。复以种种。大神通力住持震动。光明照曜。普使周遍。如是思惟。心大欣慰。复作是念。我当断一切众生疑惑。净一切众生欲乐。启一切众生心意。灭一切众生烦恼。闭一切众生恶道门。开一切众生善趣门。破一切众生黑闇。与一切众生光明。令一切众生。离众魔业。使一切众生。至安隐处。如是思惟。心大欣慰。菩萨摩诃萨。复作是念。诸佛如来。如优昙华。难可值遇。于无量劫。莫能一见。我当于未来世。欲见如来。则便得见。诸佛如来。常不舍我。恒住我所。令我得见。为我说法。无有断绝。既闻法已。心意清净。远离谄曲。质直无伪。于念念中。常见诸佛。如是思惟。心大欣慰。复作是念。我于未来。当得成佛。以佛神力。于一切世界。为一切众生。各别示现成等正觉。清净无畏。大师子吼。以本大愿周遍法界。击大法鼓。雨大法雨。作大法施。于无量劫。常演正法。大悲所持。身语意业。无有疲厌。如是思惟。心大欣慰。佛子。是为菩萨摩诃萨。十种大欣慰。若诸菩萨。安住此法。则得无上成正觉智慧。大欣慰。佛子。菩萨摩诃萨。有十种深入佛法。何等为十。所谓入过去世一切世界。入未来世一切世界。入现在世世界数。世界行。世界说。世界清净。入一切世界种种性。入一切众生。种种业报。入一切菩萨种种行。知过去一切佛次第。知未来一切佛次第。知现在十方虚空法界等。一切诸佛。国土众会。说法调伏。知世间法。声闻法独觉法。菩萨法如来法。虽知诸法。皆无分别。而说种种法。悉入法界。无所入故。如其法说。无所取着。是为十。若诸菩萨。安住此法。则得入于阿耨多罗三藐三菩提。大智慧甚深性。佛子。菩萨摩诃萨。有十种依止。菩萨依此。行菩萨行。何等为十。所谓依止供养一切诸佛。行菩萨行。依止调伏一切众生。行菩萨行。依止亲近一切善友。行菩萨行。依止积集一切善根。行菩萨行。依止严净一切佛土。行菩萨行。依止不舍一切众生。行菩萨行。依止深入一切波罗蜜。行菩萨行。依止满足。一切菩萨愿。行菩萨行。依止无量菩提心。行菩萨行。依止一切佛菩提。行菩萨行。是为十。菩萨依此行菩萨行。佛子。菩萨摩诃萨。有十种发无畏心。何等为十。所谓灭一切障碍业。发无畏心。于佛灭后。护持正法。发无畏心。降伏一切魔。发无畏心。不惜身命。发无畏心。摧破一切外道邪论。发无畏心。令一切众生欢喜。发无畏心。令一切众会。皆悉欢喜。发无畏心。调伏一切天龙夜叉。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。发无畏心。离二乘地。入甚深法。发无畏心。于不可说不可说劫。行菩萨行。心无疲厌。发无畏心。是为十。若诸菩萨。安住此法。则得如来无上大智。无所畏心。佛子。菩萨摩诃萨。发十种无疑心。于一切佛法。心无疑惑。何等为十。所谓菩萨摩诃萨。发如是心。我当以布施。摄一切众生。以戒忍精进禅定智慧。慈悲喜舍。摄一切众生。发此心时。决定无疑。若生疑心。无有是处。是为第一发无疑心。菩萨摩诃萨。又作是念。未来诸佛。出兴于世。我当一切承事供养。发此心时。决定无疑。若生疑心。无有是处。是为第二发无疑心。菩萨摩诃萨。又作是念。我当以种种奇妙光明网。周遍庄严一切世界。发此心时。决定无疑。若生疑心。无有是处。是为第三发无疑心。菩萨摩诃萨。又作是念。我当尽未来劫。修菩萨行。无数无量无边无等。不可数不可称不可思不可量不可说不可说不可说。过诸算数。究竟法界虚空界。一切众生。我当悉以无上教化调伏法。而成熟之。发此心时。决定无疑。若生疑心。无有是处。是为第四发无疑心。菩萨摩诃萨。又作是念。我当修菩萨行。满大誓愿。具一切智。安住其中。发此心时。决定无疑。若生疑心。无有是处。是为第五发无疑心。菩萨摩诃萨。又作是念。我当普为一切世间。行菩萨行。为一切法清净光明。照明一切所有佛法。发此心时。决定无疑。若生疑心。无有是处。是为第六发无疑心。菩萨摩诃萨。又作是念。我当知一切法皆是佛法。随众生心。为其演说。悉令开悟。发此心时。决定无疑。若生疑心。无有是处。是为第七发无疑心。菩萨摩诃萨。又作是念。我当于一切法。得无障碍门。知一切障碍。不可得故。其心如是。无有疑惑。住真实性。乃至成于阿耨多罗三藐三菩提。发此心时。决定无疑。若生疑心。无有是处。是为第八发无疑心。菩萨摩诃萨。又作是念。我当知一切法。莫不皆是出世间法。远离一切。妄想颠倒。以一庄严。而自庄严。而无所庄严。于此自了。不由他悟。发此心时。决定无疑。若生疑心。无有是处。是为第九发无疑心。菩萨摩诃萨。又作是念。我当于一切法。成最正觉。离一切妄想颠倒故。得一念相应智故。若一若异。不可得故。离一切数故。究竟无为故。离一切言说故。住不可说境界际故。发此心时。决定无疑。若生疑心。无有是处。是为第十发无疑心。若诸菩萨。安住此法。则于一切佛法。心无所疑。佛子。菩萨摩诃萨。有十种不可思议。何等为十。所谓一切善根。不可思议。一切誓愿。不可思议。知一切法如幻不可思议。发菩提心。修菩萨行。善根不失。无所分别。不可思议。虽深入一切法。亦不取灭度。以一切愿。未成满故。不可思议。修菩萨道。而示现降神。入胎诞生。出家苦行。往诣道场。降伏众魔。成最正觉。转正法轮。入般涅槃。神变自在无有休息。不舍悲愿。救护众生。不可思议。虽能示现如来十力神变自在。而亦不舍等法界心。教化众生。不可思议。知一切法无相是相。相是无相。无分别是分别。分别是无分别。非有是有。有是非有。无作是作。作是无作。非说是说。说是非说。不可思议。知心与菩提等。知菩提与心等。心及菩提。与众生等。亦不生心颠倒。想颠倒。见颠倒。不可思议。于念念中。入灭尽定。尽一切漏。而不证实际。亦不尽有漏善根。虽知一切法无漏。而知漏尽。亦知漏灭。虽知佛法即世间法。世间法即佛法。而不于佛法中。分别世间法。不于世间法中。分别佛法。一切诸法。悉入法界。无所入故。知一切法。皆无二。无变易故。是为第十不可思议。佛子。是为菩萨摩诃萨。十种不可思议。若诸菩萨。安住其中。则得一切诸佛无上不可思议法。佛子。菩萨摩诃萨。有十种巧密语。何等为十。所谓于一切佛经中巧密语。于一切受生处巧密语。于一切菩萨。神通变现。成等正觉巧密语。于一切众生。业报巧密语。于一切众生。所起染净巧密语。于一切法。究竟无障碍门巧密语。于一切虚空界。一一方处。悉有世界。或成或坏。间无空处巧密语。于一切法界。一切十方。乃至微细处。悉有如来。示现初生。乃至成佛。入般涅槃。充满法界。悉分别见巧密语。见一切众生。平等涅槃。无变易故。而不舍大愿。以一切智愿。未得圆满。令满足故巧密语。虽知一切法不由他悟。而不舍离诸善知识。于如来所。转加尊敬。与善知识。和合无二。于诸善根。修集种植。回向安住。同一所作。同一体性。同一出离。同一成就巧密语。是为十。若诸菩萨。安住其中。则得如来无上善巧微密语。佛子。菩萨摩诃萨。有十种巧分别智。何等为十。所谓入一切刹。巧分别智。入一切众生处。巧分别智。入一切众生心行。巧分别智。入一切众生根。巧分别智。入一切众生业报。巧分别智。入一切声闻行。巧分别智。入一切独觉行。巧分别智。入一切菩萨行。巧分别智。入一切世间法。巧分别智。入一切佛法。巧分别智。是为十。若诸菩萨。安住其中。则得一切诸佛无上善巧。分别诸法智。佛子。菩萨摩诃萨。有十种入三昧。何等为十。所谓于一切世界入三昧。于一切众生身入三昧。于一切法入三昧。见一切佛入三昧。住一切劫入三昧。从三昧起。现不思议身入三昧。于一切佛身入三昧。觉悟一切众生平等入三昧。一念中入一切菩萨三昧智入三昧。一念中以无碍智。成就一切诸菩萨行愿。无有休息入三昧。是为十。若诸菩萨。安住其中。则得一切诸佛无上善巧三昧法。佛子。菩萨摩诃萨。有十种遍入。何等为十。所谓众生遍入。国土遍入。世间种种相遍入。火灾遍入。水灾遍入。佛遍入。庄严遍入。如来无边功德身遍入。一切种种说法遍入。一切如来种种供养遍入。是为十。若诸菩萨。安住其中。则得如来无上大智遍入法。佛子。菩萨摩诃萨。有十种解脱门。何等为十。所谓一身周遍一切世界解脱门。于一切世界。示现无量种种色相解脱门。以一切世界。入一佛刹解脱门。普加持一切众生界解脱门。以一切佛庄严身。充满一切世界解脱门。于自身中。见一切世界解脱门。一念中往一切世界解脱门。于一世界。示现一切如来出世解脱门。一身充满一切法界解脱门。一念中示现一切佛游戏神通解脱门。是为十。若诸菩萨。安住其中。则得如来无上解脱门。佛子。菩萨摩诃萨。有十种神通。何等为十。所谓忆念宿命。方便智通。天耳无碍。方便智通。知他众生不思议心行。方便智通。天眼观察。无有障碍。方便智通。随众生心。现不思议大神通力。方便智通。一身普现无量世界。方便智通。一念遍入不可说不可说世界。方便智通。出生无量庄严具。庄严不思议世界。方便智通。示现不可说变化身。方便智通。随不思议众生心。于不可说世界。现成阿耨多罗三藐三菩提方便智通。是为十。若诸菩萨。安住其中。则得如来无上大善巧神通。为一切众生。种种示现。令其修学。佛子。菩萨摩诃萨。有十种明。何等为十。所谓知一切众生。业报善巧智明。知一切众生境界。寂灭清净。无诸戏论。善巧智明。知一切众生种种所缘。唯是一相。悉不可得。一切诸法。皆如金刚。善巧智明。能以无量微妙音声。普闻十方一切世界。善巧智明。普坏一切心所染着。善巧智明。能以方便。示现受生。或不受生。善巧智明。舍离一切想受境界。善巧智明。知一切法非相非无相。一性无性。无所分别。而能了知种种诸法。于无量劫。分别演说。住于法界。成阿耨多罗三藐三菩提。善巧智明。菩萨摩诃萨。知一切众生。生本无有生。了达受生。不可得故。而知因知缘。知事。知境界。知行。知生知灭。知言说。知迷惑知离迷惑。知颠倒知离颠倒。知杂染知清净。知生死知涅槃。知可得知不可得。知执着知无执着。知住知动。知去知还。知起知不起。知失坏。知出离。知成熟。知诸根。知调伏。随其所应。种种教化。未曾忘失菩萨所行。何以故。菩萨但为利益众生故。发阿耨多罗三藐三菩提心。无余所为。是故菩萨。常化众生。身无疲倦。不违一切世间所作。是名缘起善巧智明。菩萨摩诃萨。于佛无著。不起着心。于法无著。不起着心。于刹无著。不起着心。于众生无著。不起着心。不见有众生。而行教化。调伏说法。然亦不舍菩萨诸行。大悲大愿。见佛闻法。随顺修行。依于如来。种诸善根。恭敬供养。无有休息。能以神力。震动十方无量世界。其心广大。等法界故。知种种说法。知众生数。知众生差别。知苦生。知苦灭。知一切行皆如影像。行菩萨行。永断一切受生根本。但为救护一切众生。行菩萨行。而无所行。随顺一切诸佛种性。发如大山王心。知一切虚妄颠倒。入一切种智门。智慧广大。不可倾动。当成正觉。于生死海。平等济渡一切众生。善巧智明。是为十。若诸菩萨。安住其中。则得如来无上大善巧智明。佛子。菩萨摩诃萨。有十种解脱。何等为十。所谓烦恼解脱。邪见解脱。诸取解脱。蕴界处解脱。超二乘解脱。无生法忍解脱。于一切世间。一切刹。一切众生。一切法。离着解脱。无边住解脱。发起一切菩萨行。入如来无分别地解脱。于一念中。悉能了知一切三世解脱。是为十。若诸菩萨。安住此法。则能施作无上佛事。教化成熟一切众生。佛子。菩萨摩诃萨。有十种园林。何等为十。所谓生死是菩萨园林。无厌舍故。教化众生。是菩萨园林。不疲倦故。住一切劫。是菩萨园林。摄诸大行故。清净世界。是菩萨园林。自所止住故。一切魔宫殿。是菩萨园林。降伏彼众故。思惟所闻法。是菩萨园林。如理观察故。六波罗蜜。四摄事。三十七菩提分法。是菩萨园林。绍继慈父境界故。十力四无所畏。十八不共。乃至一切佛法。是菩萨园林。不念余法故。示现一切菩萨。威力自在神通。是菩萨园林。以大神力。转正法轮。调伏众生。无休息故。一念于一切处。为一切众生。示成正觉。是菩萨园林。法身周遍。尽虚空一切世界故。是为十。若诸菩萨。安住此法。则得如来无上离忧恼。大安乐行。佛子。菩萨摩诃萨。有十种宫殿。何等为十。所谓菩提心是菩萨宫殿。恒不忘失故。十善业道。福德智慧。是菩萨宫殿。教化欲界众生故。四梵住禅定。是菩萨宫殿。教化色界众生故。生净居天。是菩萨宫殿。一切烦恼不染故。生无色界。是菩萨宫殿。令诸众生。离难处故。生杂染世界。是菩萨宫殿。令一切众生。断烦恼故。现处内宫妻子眷属。是菩萨宫殿。成就往昔同行众生故。现居轮王护世释梵。是菩萨宫殿。为调伏自在心众生故。住一切菩萨行。游戏神通。皆得自在。是菩萨宫殿。善游戏诸禅解脱三昧智慧故。一切佛所受。无上自在。一切智王灌顶记。是菩萨宫殿。住十力庄严。作一切法王自在事故。是为十。若诸菩萨。安住其中。则得法灌顶。于一切世间。神力自在。佛子。菩萨摩诃萨。有十种所乐。何等为十。所谓乐正念。心不散乱故。乐智慧。分别诸法故。乐往诣一切佛所。听法无厌故。乐诸佛充满十方无边际故。乐菩萨。自在为诸众生。以无量门。而现身故。乐诸三昧门。于一三昧门。入一切三昧门故。乐陀罗尼。持法不忘。转受众生故。乐无碍辩才。于一文一句。经不可说劫。分别演说。无穷尽故。乐成正觉。为一切众生。以无量门。示现于身。成正觉故。乐转法轮。摧灭一切异道法故。是为十。若诸菩萨。安住此法。则得一切诸佛如来无上法乐。佛子。菩萨摩诃萨。有十种庄严。何等为十。所谓力庄严不可坏故。无畏庄严。无能伏故。义庄严。说不可说义无穷尽故。法庄严。八万四千法聚。观察演说。无忘失故。愿庄严。一切菩萨。所发弘誓。无退转故。行庄严。修普贤行。而出离故。刹庄严。以一切刹。作一刹故。普音庄严。周遍一切诸佛世界。雨法雨故。力持庄严。于一切劫。行无数行。不断绝故。变化庄严。于一众生身。示现一切众生数等身。令一切众生。悉得知见。求一切智。无退转故。是为十。若诸菩萨。安住此法。则得如来一切无上法庄严。佛子。菩萨摩诃萨。发十种不动心。何等为十。所谓于一切所有。悉皆能舍不动心。思惟观察一切佛法不动心。忆念供养一切诸佛不动心。于一切众生。誓无恼害不动心。普摄众生。不拣怨亲不动心。求一切佛法。无有休息不动心。一切众生数等不可说不可说劫。行菩萨行。不生疲厌。亦无退转不动心。成就有根信。无浊信。清净信。极清净信。离垢信。明彻信。恭敬供养一切佛信。不退转信。不可尽信。无能坏信。大欢喜踊跃信不动心。成就出生一切智方便道不动心。闻一切菩萨行法。信受不谤不动心。是为十。若诸菩萨。安住此法。则得无上一切智不动心。佛子。菩萨摩诃萨。有十种不舍深大心。何等为十。所谓不舍成满一切佛菩提深大心。不舍教化调伏一切众生深大心。不舍不断一切诸佛种性深大心。不舍亲近一切善知识深大心。不舍供养一切诸佛深大心。不舍专求一切大乘功德法深大心。不舍于一切佛所。修行梵行。护持净戒深大心。不舍亲近一切菩萨深大心。不舍求一切佛法方便护持深大心。不舍满一切菩萨行愿集一切诸佛法深大心。是为十。若诸菩萨。安住其中。则能不舍一切佛法。佛子。菩萨摩诃萨。有十种智慧观察。何等为十。所谓善巧分别。说一切法智慧观察。了知三世一切善根智慧观察。了知一切诸菩萨行。自在变化智慧观察。了知一切诸法义门智慧观察。了知一切诸佛威力智慧观察。了知一切陀罗尼门智慧观察。于一切世界普说正法智慧观察。入一切法界智慧观察。知一切十方不可思议智慧观察。知一切佛法智慧光明。无有障碍智慧观察。是为十。若诸菩萨。安住其中。则得如来无上大智慧观察。佛子。菩萨摩诃萨。有十种说法。何等为十。所谓说一切法。皆从缘起。说一切法。皆悉如幻。说一切法。无有乖诤。说一切法。无有边际。说一切法。无所依止。说一切法。犹如金刚。说一切法。皆悉如如。说一切法。皆悉寂静。说一切法。皆悉出离。说一切法。皆住一义。本性成就。是为十。若诸菩萨。安住其中。则能善巧。说一切法。佛子。菩萨摩诃萨。有十种清净。何等为十。所谓深心清净。断疑清净。离见清净。境界清净。求一切智清净。辩才清净。无畏清净。住一切菩萨智清净。受一切菩萨律仪清净。具足成就无上菩提。三十二种百福相白净法一切善根清净。是为十。若诸菩萨。安住其中。则得一切如来无上清净法。佛子。菩萨摩诃萨。有十种印。何等为十。所谓菩萨摩诃萨。知苦苦坏苦行苦。专求佛法。不生懈怠。行菩萨行。无有疲懈。不惊不畏。不恐不怖。不舍大愿。求一切智。坚固不退。究竟阿耨多罗三藐三菩提。是为第一印。菩萨摩诃萨。见有众生愚痴狂乱。或以粗弊恶语。而相毁辱。或以刀杖瓦石。而加损害。终不以此境界。舍菩萨心。但忍辱柔和。专修佛法。住最胜道。入离生位。是为第二印。菩萨摩诃萨。闻说与一切智相应。甚深佛法。能以自智。深信忍可。解了趣入。是为第三印。菩萨摩诃萨。又作是念。我发深心。求一切智。我当成佛。得阿耨多罗三藐三菩提。一切众生。流转五趣。受无量苦。亦当令其发菩提心。深信欢喜。勤修精进。坚固不退。是为第四印。菩萨摩诃萨。知如来智无有边际。不以齐限测如来智。菩萨曾于无量佛所。闻如来智无有边际故。能不以齐限测度一切世间。文字所说皆有齐限。悉不能知如来智慧。是为第五印。菩萨摩诃萨。于阿耨多罗三藐三菩提。得最胜欲。甚深欲。广欲大欲。种种欲。无能胜欲。无上欲。坚固欲。众魔外道并其眷属无能坏欲。求一切智不退转欲。菩萨住如是等欲。于无上菩提。毕竟不退。是为第六印。菩萨摩诃萨。行菩萨行。不顾身命。无能沮坏。发心趣向一切智故。一切智性。常现前故。得一切佛智光明故。终不舍离佛菩提。终不舍离善知识。是为第七印。菩萨摩诃萨。若见善男子善女人趣大乘者。令其增长求佛法心。令其安住一切善根。令其摄取一切智心。令其不退无上菩提。是为第八印。菩萨摩诃萨。令一切众生。得平等心。劝令勤修一切智道。以大悲心。而为说法。令于阿耨多罗三藐三菩提。永不退转。是为第九印。菩萨摩诃萨。与三世诸佛。同一善根。不断一切诸佛种性。究竟得至一切智智。是为第十印。佛子。是为菩萨摩诃萨十种印。菩萨以此。速成阿耨多罗三藐三菩提。具足如来一切法无上智印。佛子。菩萨摩诃萨。有十种智光照。何等为十。所谓知定当成阿耨多罗三藐三菩提智光照。见一切佛智光照。见一切众生。死此生彼智光照。解一切修多罗法门智光照。依善知识。发菩提心。集诸善根智光照。示现一切诸佛智光照。教化一切众生。悉令安住如来地智光照。演说不可思议。广大法门智光照。善巧了知一切诸佛。神通威力智光照。满足一切诸波罗蜜智光照。是为十。若诸菩萨。安住此法。则得一切诸佛无上智光照。佛子。菩萨摩诃萨。有十种无等住。一切众生。声闻独觉。悉无与等。何等为十。所谓菩萨摩诃萨。虽观实际。而不取证。以一切愿。未成满故。是为第一无等住。菩萨摩诃萨。种等法界一切善根。而不于中有少执着。是为第二无等住。菩萨摩诃萨。修菩萨行。知其如化。以一切法。悉寂灭故。而于佛法。不生疑惑。是为第三无等住。菩萨摩诃萨。虽离世间所有妄想。然能作意。于不可说劫。行菩萨行。满足大愿。终不中起疲厌之心。是为第四无等住。菩萨摩诃萨。于一切法。无所取着。以一切法性寂灭故。而不证涅槃。何以故。一切智道。未成满故。是为第五无等住。菩萨摩诃萨。知一切劫皆即非劫。而真实说一切劫数。是为第六无等住。菩萨摩诃萨。知一切法悉无所作。而不舍作道。求诸佛法。是为第七无等住。菩萨摩诃萨。知三界唯心。三世唯心。而了知其心无量无边。是为第八无等住。菩萨摩诃萨。为一众生。于不可说劫行菩萨行。欲令安住一切智地。如为一众生。为一切众生。悉亦如是而不生疲厌。是为第九无等住。菩萨摩诃萨。虽修行圆满。而不证菩提。何以故。菩萨作如是念。我之所作。本为众生。是故我应久处生死。方便利益。皆令安住无上佛道。是为第十无等住。佛子。是为菩萨摩诃萨。十种无等住。若诸菩萨。安住其中。则得无上大智。一切佛法。无等住

大方广佛华严经卷第五十四大方广佛华严经卷第五十五

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之三

佛子。菩萨摩诃萨。发十种无下劣心。何等为十。佛子。菩萨摩诃萨。作如是念。我当降伏一切天魔。及其眷属。是为第一无下劣心。又作是念。我当悉破一切外道。及其邪法。是为第二无下劣心。又作是念。我当于一切众生。善言开谕。皆令欢喜。是为第三无下劣心。又作是念。我当成满遍法界一切波罗蜜行。是为第四无下劣心。又作是念。我当积集一切福德藏。是为第五无下劣心。又作是念。无上菩提广大难成。我当修行。悉令圆满。是为第六无下劣心。又作是念。我当以无上教化。无上调伏。教化调伏一切众生。是为第七无下劣心。又作是念。一切世界。种种不同。我当以无量身。成等正觉。是为第八无下劣心。又作是念。我修菩萨行时。若有众生。来从我乞手足耳鼻。血肉骨髓。妻子象马。乃至王位。如是一切悉皆能舍。不生一念忧悔之心。但为利益一切众生。不求果报。以大悲为首。大慈究竟。是为第九无下劣心。又作是念。三世所有。一切诸佛。一切佛法。一切众生。一切国土。一切世间。一切三世。一切虚空界。一切法界。一切语言施设界。一切寂灭涅槃界。如是一切种种诸法。我当以一念相应慧。悉知悉觉。悉见悉证。悉修悉断。然于其中。无分别离分别。无种种差别。无功德无境界。非有非无。非一非二。以不二智。知一切二。以无相智。知一切相。以无分别智。知一切分别。以无异智。知一切异。以无差别智。知一切差别。以无世间智。知一切世间。以无世智。知一切世。以无众生智。知一切众生。以无执着智。知一切执着。以无住处智。知一切住处。以无杂染智。知一切杂染。以无尽智。知一切尽。以究竟法界智。于一切世界。示现身。以离言音智。示不可说言音。以一自性智。入于无自性。以一境界智。现种种境界。知一切法不可说。而现大自在言说。证一切智地。为教化调伏一切众生故。于一切世间。示现大神通变化。是为第十无下劣心。佛子。是为菩萨摩诃萨。发十种无下劣心。若诸菩萨。安住此心。则得一切最上无下劣佛法。佛子。菩萨摩诃萨。于阿耨多罗三藐三菩提。有十种如山增上心。何等为十。佛子。菩萨摩诃萨。常作意勤修一切智法。是为第一如山增上心。恒观一切法本性空无所得。是为第二如山增上心。愿于无量劫。行菩萨行。修一切白净法。以住一切白净法故。知见如来无量智慧。是为第三如山增上心。为求一切佛法故。等心敬奉诸善知识。无异希求。无盗法心。唯生尊重。未曾有意。一切所有。悉皆能舍。是为第四如山增上心。若有众生。骂辱毁谤。打棒屠割。苦其形体。乃至断命。如是等事。悉皆能受。终不因此生动乱心。生嗔害心。亦不退舍大悲弘誓。更令增长。无有休息。何以故。菩萨于一切法。如实出离。舍成就故。证得一切诸如来法。忍辱柔和。已自在故。是为第五如山增上心。菩萨摩诃萨。成就增上大功德。所谓天增上功德。人增上功德。色增上功德。力增上功德。眷属增上功德。欲增上功德。王位增上功德。自在增上功德。福德增上功德。智慧增上功德。虽复成就如是功德。终不于此。而生染着。所谓不着味。不着欲。不着财富。不着眷属。但深乐法。随法去。随法住。随法趣向。随法究竟。以法为依。以法为救。以法为归。以法为舍。守护法。爱乐法。希求法。思惟法。佛子。菩萨摩诃萨。虽复具受种种法乐。而常远离众魔境界。何以故。菩萨摩诃萨。于过去世。发如是心。我当令一切众生。皆悉永离众魔境界。住佛境界故。是为第六如山增上心。菩萨摩诃萨。为求阿耨多罗三藐三菩提。已于无量阿僧祇劫。行菩萨道。精勤匪懈。犹谓我今始发阿耨多罗三藐三菩提心。行菩萨行。亦不惊亦不怖。亦不畏。虽能一念即成阿耨多罗三藐三菩提。然为众生故。于无量劫。行菩萨行。无有休息。是为第七如山增上心。菩萨摩诃萨。知一切众生。性不和善。难调难度。不能知恩。不能报恩。是故为其。发大誓愿。欲令皆得心意自在。所行无碍。舍离恶念。不于他所。生诸烦恼。是为第八如山增上心。菩萨摩诃萨。复作是念。非他令我发菩提心。亦不待人助我修行。我自发心。集诸佛法。誓期自勉。尽未来劫。行菩萨道。成阿耨多罗三藐三菩提。是故我今修菩萨行。当净自心。亦净他心。当知自境界。亦知他境界。我当悉与三世诸佛。境界平等。是为第九如山增上心。菩萨摩诃萨。作如是观。无有一法修菩萨行。无有一法满菩萨行。无有一法教化调伏一切众生。无有一法供养恭敬一切诸佛。无有一法于阿耨多罗三藐三菩提。已成今成当成。无有一法已说今说当说。说者及法。俱不可得。而亦不舍阿耨多罗三藐三菩提愿。何以故。菩萨求一切法。皆无所得。如是出生阿耨多罗三藐三菩提。是故于法。虽无所得。而勤修习增上善业。清净对治。智慧圆满。念念增长。一切具足。其心于此。不惊不怖。不作是念。若一切法。皆悉寂灭。我有何义。求于无上菩提之道。是为第十如山增上心。佛子。是为菩萨摩诃萨。于阿耨多罗三藐三菩提。十种如山增上心。若诸菩萨。安住其中。则得如来无上大智山王增上心。佛子。菩萨摩诃萨。有十种入阿耨多罗三藐三菩提如海智。何等为十。所谓入一切无量众生界。是为第一如海智。入一切世界。而不起分别。是为第二如海智。知一切虚空界无量无碍。普入十方一切差别世界网。是为第三如海智。菩萨摩诃萨。善入法界。所谓无碍入。不断入。不常入。无量入。不生入。不灭入。一切入。悉了知故。是为第四如海智。菩萨摩诃萨。于过去未来现在诸佛。菩萨法师。声闻独觉。及一切凡夫。所集善根。已集现集当集。三世诸佛。于阿耨多罗三藐三菩提。已成今成当成。所有善根。三世诸佛。说法调伏一切众生。已说今说当说。所有善根。于彼一切皆悉了知。深信随喜。愿乐修习。无有厌足。是为第五如海智。菩萨摩诃萨。于念念中。入过去世不可说劫。于一劫中。或百亿佛出世。或千亿佛出世。或百千亿佛出世。或无数或无量。或无边或无等。或不可数。或不可称。或不可思。或不可量。或不可说。或不可说不可说。超过算数。诸佛世尊。出兴于世。及彼诸佛。道场众会。声闻菩萨。说法调伏。一切众生寿命延促。法住久近。如是一切。悉皆明见。如一劫。一切诸劫。皆亦如是。其无佛劫。所有众生。有于阿耨多罗三藐三菩提。种诸善根亦悉了知。若有众生。善根熟已。于未来世。当得见佛。亦悉了知。如是观察过去世不可说不可说劫。心无厌足。是为第六如海智。菩萨摩诃萨。入未来世。观察分别一切诸劫无量无边。知何劫有佛。何劫无佛。何劫有几如来出世。一一如来。名号何等。住何世界。世界名何。度几众生。寿命几时。如是观察。尽未来际。皆悉了知。不可穷尽。而无厌足。是为第七如海智。菩萨摩诃萨。入现在世。观察思惟。于念念中。普见十方无边品类不可说世界。皆有诸佛于无上菩提。已成今成当成。往诣道场。菩提树下。坐吉祥草。降伏魔军。成阿耨多罗三藐三菩提。从此起已。入于城邑。升天宫殿。说微妙法。转大法轮。示现神通。调伏众生。乃至付嘱阿耨多罗三藐三菩提法。舍于寿命。入般涅槃。入涅槃已。结集法藏。令久住世。庄严佛塔。种种供养。亦见彼世界所有众生。值佛闻法。受持讽诵。忆念思惟。增长慧解。如是观察。普遍十方。而于佛法。无有错谬。何以故。菩萨摩诃萨。了知诸佛。皆悉如梦。而能往诣一切佛所。恭敬供养。菩萨尔时。不着自身。不着诸佛。不着世界。不着众会。不着说法。不着劫数。然见佛闻法。观察世界。入诸劫数。无有厌足。是为第八如海智。菩萨摩诃萨。于不可说不可说劫一一劫中。供养恭敬不可说不可说无量诸佛。示现自身。殁此生彼。以出过三界一切供具。而为供养。并及供养菩萨声闻。一切大众。一一如来。般涅槃后。皆以无上供具。供养舍利。及广行惠施。满足众生。佛子。菩萨摩诃萨。以不可思议心。不求报心。究竟心。饶益心。于不可说不可说劫。为阿耨多罗三藐三菩提故。供养诸佛。饶益众生。护持正法。开示演说。是为第九如海智。菩萨摩诃萨。于一切佛所。一切菩萨所。一切法师所。一向专求菩萨所说法。菩萨所学法。菩萨所教法。菩萨修行法。菩萨清净法。菩萨成熟法。菩萨调伏法。菩萨平等法。菩萨出离法。菩萨总持法。得此法已。受持读诵。分别解说。无有厌足。令无量众生。于佛法中。发一切智相应心。入真实相。于阿耨多罗三藐三菩提。得不退转。菩萨如是。于不可说不可说劫。无有厌足。是为第十如海智。佛子。是为菩萨摩诃萨。十种入阿耨多罗三藐三菩提如海智。若诸菩萨。安住此法。则得一切诸佛无上大智慧海。佛子。菩萨摩诃萨。于阿耨多罗三藐三菩提。有十种如宝住。何等为十。佛子。菩萨摩诃萨。悉能往诣无数世界。诸如来所。瞻觐顶礼。承事供养。是为第一如宝住。于不思议诸如来所。听闻正法。受持忆念。不令忘失。分别思惟。觉慧增长。如是所作。充满十方。是为第二如宝住。于此刹殁。余处现生。而于佛法。无所迷惑。是为第三如宝住。知从一法。出一切法。而能各各分别演说。以一切法种种义。究竟皆是一义故。是为第四如宝住。知厌离烦恼。知止息烦恼。知防护烦恼。知除断烦恼。修菩萨行。不证实际。究竟到于实际彼岸。方便善巧。善学所学。令往昔愿行。皆得成满。身不疲倦。是为第五如宝住。知一切众生。心所分别。皆无处所。而亦说有种种方处。虽无分别。无所造作。为欲调伏一切众生。而有修行。而有所作。是为第六如宝住。知一切法。皆同一性。所谓无性。无种种性。无无量性。无可算数性。无可称量性。无色无相。若一若多。皆不可得。而决定了知。此是诸佛法。此是菩萨法。此是独觉法。此是声闻法。此是凡夫法。此是善法。此是不善法。此是世间法。此是出世间法。此是过失法。此是无过失法。此是有漏法。此是无漏法。乃至此是有为法。此是无为法。是为第七如宝住。菩萨摩诃萨。求佛不可得。求菩萨不可得。求法不可得。求众生不可得。而亦不舍调伏众生。令于诸法。成正觉愿。何以故。菩萨摩诃萨。善巧观察。知一切众生分别。知一切众生境界。方便化导。令得涅槃。为欲满足化众生愿。炽然修行菩萨行故。是为第八如宝住。菩萨摩诃萨。知善巧说法。示现涅槃。为度众生。所有方便。一切皆是心想建立。非是颠倒。亦非虚诳。何以故。菩萨了知一切诸法三世平等。如如不动。实际无住。不见有一众生。已受化今受化当受化。亦自了知。无所修行。无有少法。若生若灭。而可得者。而依于一切法。令所愿不空。是为第九如宝住。菩萨摩诃萨。于不思议无量诸佛。一一佛所。闻不可说不可说授记法名号各异。劫数不同。从于一劫。乃至不可说不可说劫。常如是闻。闻已修行。不惊不怖。不迷不惑。知如来智不思议故。如来授记。言无二故。自身行愿。殊胜力故。随应受化。令成阿耨多罗三藐三菩提。满等法界一切愿故。是为第十如宝住。佛子。是为菩萨摩诃萨。于阿耨多罗三藐三菩提。十种如宝住。若诸菩萨。安住此法。则得诸佛无上大智慧宝。佛子。菩萨摩诃萨。发十种如金刚大乘誓愿心。何等为十。佛子。菩萨摩诃萨。作如是念。一切诸法。无有边际。不可穷尽。我当以尽三世智。普皆觉了。无有遗余。是为第一如金刚大乘誓愿心。菩萨摩诃萨。又作是念。于一毛端处。有无量无边众生。何况一切法界。我当皆以无上涅槃。而灭度之。是为第二如金刚大乘誓愿心。菩萨摩诃萨。又作是念。十方世界无量无边。无有齐限。不可穷尽。我当以诸佛国土最上庄严。庄严如是一切世界。所有庄严。皆悉真实。是为第三如金刚大乘誓愿心。菩萨摩诃萨。又作是念。一切众生。无量无边。无有齐限。不可穷尽。我当以一切善根。回向于彼无上智光。照曜于彼。是为第四如金刚大乘誓愿心。菩萨摩诃萨。又作是念。一切诸佛无量无边。无有齐限。不可穷尽。我当以所种善根。回向供养。悉令周遍。无所阙少。然后我当成阿耨多罗三藐三菩提。是为第五如金刚大乘誓愿心。佛子。菩萨摩诃萨。见一切佛。闻所说法。生大欢喜。不着自身。不着佛身。解如来身。非实非虚。非有非无。非性非无性。非色非无色。非相非无相。非生非灭。实无所有。亦不坏有。何以故。不可以一切性相。而取着故。是为第六如金刚大乘誓愿心。佛子。菩萨摩诃萨。或有众生。诃骂毁呰。挝打楚挞。或截手足。或割耳鼻。或挑其目。或级其头。如是一切皆能忍受。终不因此生恚害心。于不可说不可说无央数劫。修菩萨行。摄受众生。恒无废舍。何以故。菩萨摩诃萨。已善观察一切诸法。无有二相。心不动乱。能舍自身。忍其苦故。是为第七如金刚大乘誓愿心。佛子。菩萨摩诃萨。又作是念。未来世劫无量无边。无有齐限。不可穷尽。我当尽彼劫。于一世界。行菩萨道。教化众生。如一世界。尽法界虚空界一切世界。悉亦如是。而心不惊。不怖不畏。何以故。为菩萨道。法应如是。为一切众生。而修行故。是为第八如金刚大乘誓愿心。佛子。菩萨摩诃萨。又作是念。阿耨多罗三藐三菩提。以心为本。心若清净。则能圆满一切善根。于佛菩提。必得自在。欲成阿耨多罗三藐三菩提。随意即成。若欲除断一切取缘。住一向道。我亦能得。而我不断。为欲究竟佛菩提故。亦不即证无上菩提。何以故。为满本愿尽一切世界。行菩萨行。化众生故。是为第九如金刚大乘誓愿心。佛子。菩萨摩诃萨。知佛不可得。菩提不可得。菩萨不可得。一切法不可得。众生不可得。心不可得。行不可得。过去不可得。未来不可得。现在不可得。一切世间不可得。有为无为不可得。菩萨如是。寂静住。甚深住。寂灭住。无诤住。无言住。无二住。无等住。自性住。如理住。解脱住。涅槃住。实际住。而亦不舍一切大愿。不舍萨婆若心。不舍菩萨行。不舍教化众生。不舍诸波罗蜜。不舍调伏众生。不舍承事诸佛。不舍演说诸法。不舍庄严世界。何以故。菩萨摩诃萨。发大愿故。虽复了达一切法相。大慈悲心。转更增长。无量功德。皆具修行。于诸众生。心不舍离。何以故。一切诸法。皆无所有。凡夫愚迷。不知不觉。我当令彼悉得开悟。于诸法性。分明照了。何以故。一切诸佛。安住寂灭。而以大悲心。于诸世间。说法教化。曾无休息。我今云何。而舍大悲。又我先发广大誓愿心。发决定利益一切众生心。发积集一切善根心。发安住善巧回向心。发出生甚深智慧心。发含受一切众生心。发于一切众生平等心。作真实语。不虚诳语。愿与一切众生。无上大法。愿不断一切诸佛种性。令一切众生。未得解脱。未成正觉。未具佛法。大愿未满。云何而欲舍离大悲。是为第十如金刚大乘誓愿心。佛子。是为菩萨摩诃萨发十种如金刚大乘誓愿心。若诸菩萨。安住此法。则得如来金刚性无上大神通智。佛子。菩萨摩诃萨。有十种大发起。何等为十。佛子。菩萨摩诃萨。作如是念。我当供养恭敬一切诸佛。是为第一大发起。又作是念。我当长养一切菩萨所有善根。是为第二大发起。又作是念。我当于一切如来般涅槃后。庄严佛塔。以一切华。一切鬘。一切香。一切涂香。一切末香。一切衣一切盖。一切幢一切幡。而供养之。受持守护彼佛正法。是为第三大发起。又作是念。我当教化调伏一切众生。令得阿耨多罗三藐三菩提。是为第四大发起。又作是念。我当以诸佛国土无上庄严。而以庄严一切世界。是为第五大发起。又作是念。我当发大悲心。为一众生。于一切世界。一一各尽未来际劫。行菩萨行。如为一众生。为一切众生。悉亦如是。皆令得佛无上菩提。乃至不生一念疲懈。是为第六大发起。又作是念。彼诸如来。无量无边。我当于一如来所。经不思议劫。恭敬供养。如于一如来。于一切如来。悉亦如是。是为第七大发起。菩萨摩诃萨。又作是念。彼诸如来。灭度之后。我当为一一如来。所有舍利。各起宝塔。其量高广。与不可说。诸世界等。造佛形像。亦复如是。于不可思议劫。以一切宝幢幡盖。香华衣服。而为供养。不生一念。厌倦之心。为成就佛法故。为供养诸佛故。为教化众生故。为护持正法。开示演说故。是为第八大发起。菩萨摩诃萨。又作是念。我当以此善根。成无上菩提。得入一切诸如来地。与一切如来体性平等。是为第九大发起。菩萨摩诃萨。复作是念。我当成正觉已。于一切世界不可说劫。演说正法示现不可思议自在神通。身语及意。不生疲倦。不离正法。以佛力所持故。为一切众生。勤行大愿故。大慈为首故。大悲究竟故。达无相法故。住真实语故。证一切法皆寂灭故。知一切众生。悉不可得。而亦不违诸业所作故。与三世佛。同一体故。周遍法界。虚空界故。通达诸法无相故。成就不生不灭故。具足一切佛法故。以大愿力。调伏众生。作大佛事。无有休息。是为第十大发起。佛子。是为菩萨摩诃萨十种大发起。若诸菩萨。安住此法。则不断菩萨行。具足如来无上大智。佛子。菩萨摩诃萨。有十种究竟大事。何等为十。所谓恭敬供养一切如来究竟大事。随所念众生。悉能救护究竟大事。专求一切佛法究竟大事。积集一切善根究竟大事。思惟一切佛法究竟大事。满足一切誓愿究竟大事。成就一切菩萨行究竟大事。奉事一切善知识究竟大事。往诣一切世界。诸如来所究竟大事。闻持一切诸佛正法究竟大事。是为十。若诸菩萨。安住此法。则得阿耨多罗三藐三菩提大智慧究竟事。佛子。菩萨摩诃萨。有十种不坏信。何等为十。所谓于一切佛不坏信。于一切佛法不坏信。于一切圣僧不坏信。于一切菩萨不坏信。于一切善知识不坏信。于一切众生不坏信。于一切菩萨大愿不坏信。于一切菩萨行不坏信。于恭敬供养一切诸佛不坏信。于菩萨巧密方便。教化调伏一切众生不坏信。是为十。若诸菩萨。安住此法。则得诸佛无上大智慧不坏信。佛子。菩萨摩诃萨。有十种得授记。何等为十。所谓内有甚深解得授记。能随顺起菩萨诸善根得授记。修广大行得授记。现前得授记。不现前得授记。因自心证菩提得授记。成就忍得授记。教化调伏众生得授记。究竟一切劫数得授记。一切菩萨行自在得授记。是为十。若诸菩萨。安住此法。则于一切诸佛所。而得授记。佛子。菩萨摩诃萨。有十种善根回向。菩萨由此。能以一切善根。悉皆回向。何等为十。所谓以我善根。同善知识愿。如是成就。莫别成就。以我善根。同善知识心。如是成就。莫别成就。以我善根。同善知识行。如是成就。莫别成就。以我善根。同善知识善根。如是成就。莫别成就。以我善根。同善知识平等。如是成就。莫别成就。以我善根。同善知识念。如是成就。莫别成就。以我善根。同善知识清净。如是成就。莫别成就。以我善根。同善知识所住。如是成就。莫别成就。以我善根。同善知识成满。如是成就。莫别成就。以我善根。同善知识不坏。如是成就。莫别成就。是为十。若诸菩萨。安住此法。则得无上善根回向。佛子。菩萨摩诃萨。有十种得智慧。何等为十。所谓于施自在得智慧。深解一切佛法得智慧。入如来无边智得智慧。于一切问答中。能断疑得智慧。入于智者义得智慧。深解一切如来。于一切佛法中。言音善巧得智慧。深解于诸佛所。种少善根。必能满足一切白净法。获如来无量智得智慧。成就菩萨。不思议住得智慧。于一念中。悉能往诣不可说佛刹得智慧。觉一切佛菩提。入一切法界。闻持一切佛所说法。深入一切如来种种庄严言音得智慧。是为十。若诸菩萨。安住此法。则得一切诸佛无上现证智。佛子。菩萨摩诃萨。有十种发无量无边广大心。何等为十。所谓于一切诸佛所。发无量无边广大心。观一切众生界。发无量无边广大心。观一切刹一切世一切法界。发无量无边广大心。观察一切法。皆如虚空。发无量无边广大心。观察一切菩萨广大行。发无量无边广大心。正念三世一切诸佛。发无量无边广大心。观不思议诸业果报。发无量无边广大心。严净一切佛刹。发无量无边广大心。遍入一切诸佛大会。发无量无边广大心。观察一切如来妙音。发无量无边广大心。是为十。若诸菩萨。安住此心。则得一切佛法。无量无边广大智慧海。佛子。菩萨摩诃萨。有十种伏藏。何等为十。所谓知一切法。是起功德行藏。知一切法。是正思惟藏。知一切法。是陀罗尼照明藏。知一切法。是辩才开演藏。知一切法。是不可说善觉真实藏。知一切佛自在神通。是观察示现藏。知一切法。是善巧出生平等藏。知一切法。是常见一切诸佛藏。知一切不思议劫。是善了皆如幻住藏。知一切诸佛菩萨。是发生欢喜净信藏。是为十。若诸菩萨。安住此法。则得一切诸佛无上智慧法藏。悉能调伏一切众生。佛子。菩萨摩诃萨。有十种律仪。何等为十。所谓于一切佛法。不生诽谤律仪。于一切佛所。信乐心不可坏律仪。于一切菩萨所。起尊重恭敬律仪。于一切善知识所。终不舍爱乐心律仪。于一切声闻独觉。不生忆念心律仪。远离一切退菩萨道律仪。不起一切损害众生心律仪。修一切善根。皆令究竟律仪。于一切魔。悉能降伏律仪。于一切波罗蜜。皆令满足律仪。是为十。若诸菩萨。安住此法。则得无上大智律仪。佛子。菩萨摩诃萨。有十种自在。何等为十。所谓命自在。于不可说劫。住寿命故。心自在。智慧能入阿僧祇诸三昧故。资具自在。能以无量庄严。庄严一切世界故。业自在。随时受报故。受生自在。于一切世界。示现受生故。解自在。于一切世界。见佛充满故。愿自在。随欲随时。于诸刹中。成正觉故。神力自在。示现一切大神变故。法自在。示现无边诸法门故。智自在。于念念中。示现如来十力无畏。成正觉故。是为十。若诸菩萨。安住此法。则得圆满一切诸佛。诸波罗蜜。智慧神力。菩提自在

大方广佛华严经卷第五十五大方广佛华严经卷第五十六

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之四

佛子。菩萨摩诃萨。有十种无碍用。何等为十。所谓众生无碍用。国土无碍用。法无碍用。身无碍用。愿无碍用。境界无碍用。智无碍用。神通无碍用。神力无碍用。力无碍用。佛子。云何为菩萨摩诃萨。众生等无碍用。佛子。菩萨摩诃萨。有十种众生无碍用。何者为十。所谓知一切众生。无众生无碍用。知一切众生。但想所持无碍用。为一切众生。说法未曾失时无碍用。普化现一切众生界无碍用。置一切众生。于一毛孔中。而不迫隘无碍用。为一切众生。示现他方一切世界。令其悉见无碍用。为一切众生。示现释梵护世诸天身无碍用。为一切众生。示现声闻辟支佛。寂静威仪无碍用。为一切众生。示现菩萨行无碍用。为一切众生。示现诸佛。色身相好。一切智力。成等正觉无碍用。是为十。佛子。菩萨摩诃萨。有十种国土无碍用。何等为十。所谓一切刹作一刹无碍用。一切刹入一毛孔无碍用。知一切刹无有尽无碍用。一身结跏坐。充满一切刹无碍用。一身中现一切刹无碍用。震动一切刹。不令众生恐怖无碍用。以一切刹庄严具。庄严一刹无碍用。以一刹庄严具。庄严一切刹无碍用。以一如来一众会。遍一切佛刹。示现众生无碍用。一切小刹中刹大刹。广刹深刹。仰刹覆刹。侧刹正刹。遍诸方网。无量差别。以此普示一切众生无碍用。是为十。佛子。菩萨摩诃萨。有十种法无碍用。何等为十。所谓知一切法入一法。一法入一切法。而亦不违众生心解无碍用。从般若波罗蜜。出生一切法。为他解说。悉令开悟无碍用。知一切法离文字。而令众生。皆得悟入无碍用。知一切法入一相。而能演说无量法相无碍用。知一切法离言说。能为他说无边法门无碍用。于一切法。善转普门字轮无碍用。以一切法。入一法门。而不相违。于不可说劫。说不穷尽无碍用。以一切法。悉入佛法。令诸众生。皆得悟解无碍用。知一切法。无有边际无碍用。知一切法。无障碍际。犹如幻网。无量差别。于无量劫。为众生说。不可穷尽无碍用。是为十。佛子。菩萨摩诃萨。有十种身无碍用。何等为十。所谓以一切众生身。入己身无碍用。以己身。入一切众生身无碍用。一切佛身。入一佛身无碍用。一佛身。入一切佛身无碍用。一切刹入己身无碍用。以一身。充遍一切三世法。示现众生无碍用。于一身。示现无边身。入三昧无碍用。于一身。示现众生数等身。成正觉无碍用。于一切众生身。现一众生身。于一众生身。现一切众生身无碍用。于一切众生身。示现法身。于法身。示现一切众生身无碍用。是为十。佛子。菩萨摩诃萨。有十种愿无碍用。何等为十。所谓以一切菩萨愿。作自愿无碍用。以一切佛成菩提愿力。示现自成正觉无碍用。随所化众生。自成阿耨多罗三藐三菩提无碍用。于一切无边际劫。大愿不断无碍用。远离识身。不着智身。以自在愿现一切身。无碍用。舍弃自身。成满他愿无碍用。普教化一切众生。而不舍大愿无碍用。于一切劫。行菩萨行。而大愿不断无碍用。于一毛孔。现成正觉。以愿力故。充遍一切诸佛国土。于不可说不可说世界。为一一众生。如是示现无碍用。说一句法。遍一切法界。兴大正法云。耀解脱电光。震实法雷音。雨甘露味雨。以大愿力。充洽一切诸众生界无碍用。是为十。佛子。菩萨摩诃萨。有十种境界无碍用。何等为十。所谓在法界境界。而不舍众生境界无碍用。在佛境界。而不舍魔境界无碍用。在涅槃境界。而不舍生死境界无碍用。入一切智境界。而不断菩萨种性境界无碍用。住寂静境界。而不舍散乱境界无碍用。住无去无来。无戏论无相状。无体性无言说。如虚空境界。而不舍一切众生戏论境界无碍用。住诸力解脱境界。而不舍一切诸方所境界无碍用。入无众生际境界。而不舍教化一切众生无碍用。住禅定解脱。神通明智。寂静境界。而于一切世界。示现受生无碍用。住如来一切行。庄严成正觉境界。而现一切声闻辟支佛。寂静威仪无碍用。是为十。佛子。菩萨摩诃萨。有十种智无碍用。何等为十。所谓无尽辩才无碍用。一切总持。无有忘失无碍用。能决定知决定说。一切众生诸根无碍用。于一念中。以无碍智。知一切众生心之所行无碍用。知一切众生。欲乐随眠。习气烦恼病。随应授药无碍用。一念能入如来十力无碍用。以无碍智。知三世一切劫。及其中众生无碍用。于念念中。现成正觉。示现众生。无有断绝无碍用。于一众生想。知一切众生业无碍用。于一众生音。解一切众生语无碍用。是为十。佛子。菩萨摩诃萨。有十种神通无碍用。何等为十。所谓于一身。示现一切世界身无碍用。于一佛众会。听受一切佛众会中。所说法无碍用。于一众生心念中。成就不可说无上菩提。开悟一切众生心无碍用。以一音。现一切世界差别言音。令诸众生。各得解了无碍用。一念中。现尽前际一切劫。所有业果。种种差别。令诸众生。悉得知见无碍用。令一切世界。具足庄严无碍用。普入一切三世无碍用。放大法光明。现一切诸佛菩提。众生行愿无碍用。善守护一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世。声闻独觉。菩萨所有。如来十力。菩萨善根。无碍用是为十。若诸菩萨。得此无碍用。则能普入一切佛法。佛子。菩萨摩诃萨。有十种神力无碍用。何等为十。所谓以不可说世界。置一尘中无碍用。于一尘中。现等法界一切佛刹无碍用。以一切大海水。置一毛孔。周旋往返十方世界。而于众生。无所触娆无碍用。以不可说世界内自身中。示现一切神通所作无碍用。以一毛。系不可数金刚围山。持以游行一切世界。不令众生。生恐怖心无碍用。以不可说劫。作一劫。一劫。作不可说劫。于中示现成坏差别。不令众生。心有恐怖无碍用。于一切世界。现水火风灾。种种变坏。而不恼众生无碍用。一切世界。三灾坏时。悉能护持一切众生资生之具。不令损缺无碍用。以一手。持不思议世界。掷不可说世界之外。不令众生。有惊怖想无碍用。说一切刹。同于虚空。令诸众生。悉得悟解无碍用。是为十。佛子。菩萨摩诃萨。有十种力无碍用。何等为十。所谓众生力无碍用。教化调伏。不舍离故。刹力无碍用。示现不可说庄严。而庄严故。法力无碍用。令一切身。入无身故。劫力无碍用。修行不断故。佛力无碍用。觉悟睡眠故。行力无碍用。摄取一切菩萨行故。如来力无碍用。度脱一切众生故。无师力无碍用。自觉一切诸法故。一切智力无碍用。以一切智。成正觉故。大悲力无碍用。不舍一切众生故。是为十。佛子。如是名为菩萨摩诃萨。十种无碍用。若有得此十无碍用者。于阿耨多罗三藐三菩提。欲成不成。随意无违。虽成正觉。而亦不断行菩萨行。何以故。菩萨摩诃萨。发大誓愿。入无边无碍用门。善巧示现故。佛子。菩萨摩诃萨。有十种游戏。何等为十。所谓以众生身。作刹身。而亦不坏众生身。是菩萨游戏。以刹身。作众生身。而亦不坏于刹身。是菩萨游戏。于佛身。示现声闻独觉身。而不损减如来身。是菩萨游戏。于声闻独觉身。示现如来身。而不增长声闻独觉身。是菩萨游戏。于菩萨行身。示现成正觉身。而亦不断菩萨行身。是菩萨游戏。于成正觉身。示现修菩萨行身。而亦不减成菩提身。是菩萨游戏。于涅槃界。示现生死身。而不着生死。是菩萨游戏。于生死界。示现涅槃。亦不究竟。入于涅槃。是菩萨游戏。入于三昧。而示现行住坐卧一切业。亦不舍三昧正受。是菩萨游戏。在一佛所。闻法受持。其身不动。而以三昧力。于不可说诸佛会中。各各现身。亦不分身。亦不起定。而闻法受持。相续不断。如是念念。于一一三昧身。各出生不可说不可说三昧身。如是次第一切诸劫。犹可穷尽。而菩萨三昧身。不可穷尽。是菩萨游戏。是为十。若诸菩萨安住此法。则得如来无上大智游戏。佛子。菩萨摩诃萨。有十种境界。何等为十。所谓示现无边法界门。令众生得入。是菩萨境界。示现一切世界无量妙庄严。令众生得入。是菩萨境界。化往一切众生界。悉方便开悟。是菩萨境界。于如来身。出菩萨身。于菩萨身。出如来身。是菩萨境界。于虚空界。现世界。于世界。现虚空界。是菩萨境界。于生死界。现涅槃界。于涅槃界。现生死界。是菩萨境界。于一众生语言中。出生一切佛法语言。是菩萨境界。以无边身。现作一身。一身。作一切差别身。是菩萨境界。以一身。充满一切法界。是菩萨境界。于一念中。令一切众生。发菩提心。各现无量身。成等正觉。是菩萨境界。是为十。若诸菩萨。安住此法。则得如来无上大智慧境界。佛子。菩萨摩诃萨。有十种力。何等为十。所谓深心力。不杂一切世情故。增上深心力。不舍一切佛法故。方便力。诸有所作究竟故。智力。了知一切心行故。愿力。一切所求令满故。行力。尽未来际不断故。乘力。能出生一切乘。而不舍大乘故。神变力。于一一毛孔中。各各示现一切清净世界。一切如来。出兴世故。菩提力。令一切众生。发心成佛。无断绝故。转法轮力。说一句法。悉称一切众生诸根性欲故。是为十。若诸菩萨。安住此法。则得诸佛无上一切智十力

佛子。菩萨摩诃萨。有十种无畏。何等为十。佛子。菩萨摩诃萨。悉能闻持一切言说。作如是念。设有众生无量无边。从十方来。以百千大法。而问于我。我于彼问。不见微少。难可答相。以不见故。心得无畏。究竟到彼大无畏岸。随其所问。悉能酬对。断其疑惑。无有怯弱。是为菩萨第一无畏。佛子。菩萨摩诃萨。得如来灌顶。无碍辩才。到于一切文字言音。开示秘密究竟彼岸。作如是念。设有众生无量无边。从十方来。以无量法。而问于我。我于彼问。不见微少。难可答相。以不见故。心得无畏。究竟到彼大无畏岸。随其所问。悉能酬对。断其疑惑。无有恐惧。是为菩萨第二无畏。佛子。菩萨摩诃萨。知一切法空。离我离我所。无作无作者。无知者。无命者。无养育者。无补伽罗。离蕴界处。永出诸见。心如虚空。作如是念。不见众生。有微少相。能损恼我。身语意业。何以故。菩萨远离我我所故。不见诸法。有少性相。以不见故。心得无畏。究竟到彼大无畏岸。坚固勇猛。不可沮坏。是为菩萨第三无畏。佛子。菩萨摩诃萨。佛力所护。佛力所持。住佛威仪。所行真实。无有变易。作如是念。我不见有少分威仪。令诸众生。生诃责相。以不见故。心得无畏。于大众中。安隐说法。是为菩萨第四无畏。佛子。菩萨摩诃萨。身语意业。皆悉清净。鲜白柔和。远离众恶。作如是念。我不自见身语意业。而有少分。可诃责相。以不见故。心得无畏。能令众生。住于佛法。是为菩萨第五无畏。佛子。菩萨摩诃萨。金刚力士。天龙夜叉乾闼婆阿修罗。帝释梵王。四天王等。常随侍卫。一切如来。护念不舍。菩萨摩诃萨。作如是念。我不见有众魔外道。有见众生。能来障我。行菩萨道少分之相。以不见故。心得无畏。究竟到彼大无畏岸。发欢喜心。行菩萨行。是为菩萨第六无畏。佛子。菩萨摩诃萨。已得成就第一念根。心无忘失。佛所悦可。作如是念。如来所说。成菩提道。文字句法。我不于中。见有少分忘失之相。以不见故。心得无畏。受持一切如来正法。行菩萨行。是为菩萨第七无畏。佛子。菩萨摩诃萨。智慧方便。悉已通达。菩萨诸力。皆得究竟。常勤教化一切众生。恒以愿心。系佛菩提。而为悲愍众生故。成就众生故。于烦恼浊世。示现受生。种族尊贵。眷属圆满。所欲从心。欢娱快乐。而作是念。我虽与此眷属聚会。不见少相而可贪着。废我修行。禅定解脱。及诸三昧。总持辩才。菩萨道法。何以故。菩萨摩诃萨。于一切法。已得自在。到于彼岸。修菩萨行。誓不断绝。不见世间。有一境界。而能惑乱菩萨道者。以不见故。心得无畏。究竟到彼大无畏岸。以大愿力。于一切世界。示现受生。是为菩萨第八无畏。佛子。菩萨摩诃萨。恒不忘失萨婆若心。乘于大乘。行菩萨行。以一切智。大心势力。示现一切声闻独觉。寂静威仪。作是念言。我不自见。当于二乘。而取出离。少分之相。以不见故。心得无畏。到彼无上大无畏岸。普能示现一切乘道。究竟满足平等大乘。是为菩萨第九无畏。佛子。菩萨摩诃萨。成就一切诸白净法。具足善根。圆满神通。究竟住于诸佛菩提。满足一切诸菩萨行。于诸佛所。受一切智灌顶之记。而常化众生。行菩萨道。作如是念。我不自见有一众生。应可成熟。而不能现诸佛自在。而成熟相。以不见故。心得无畏。究竟到彼大无畏岸。不断菩萨行。不舍菩萨愿。随所应化一切众生。现佛境界。而化度之。是为菩萨第十无畏。佛子。是为菩萨摩诃萨。十种无畏。若诸菩萨。安住此法。则得诸佛无上大无畏。而亦不舍菩萨无畏。佛子。菩萨摩诃萨。有十种不共法。何等为十。佛子。菩萨摩诃萨。不由他教。自然修行六波罗蜜。常乐大施。不生悭吝。恒持净戒。无所毁犯。具足忍辱。心不动摇。有大精进。未曾退转。善入诸禅。永无散乱。巧修智慧。悉除恶见。是为第一不由他教随顺波罗蜜道修六度不共法。佛子。菩萨摩诃萨。普能摄受一切众生。所谓以财及法。而行惠施。正念现前。和颜爱语。其心欢喜。示如实义。令得悟解诸佛菩提。无有憎嫌。平等利益。是为第二不由他教顺四摄道勤摄众生不共法。佛子。菩萨摩诃萨。善巧回向。所谓不求果报回向。顺佛菩提回向。不着一切世间禅定三昧回向。为利益一切众生回向。为不断如来智慧回向。是为第三不由他教为诸众生发起善根求佛智慧不共法。佛子。菩萨摩诃萨。到善巧方便。究竟彼岸。心恒顾复一切众生。不厌世俗凡愚境界。不乐二乘出离之道。不着己乐。唯勤化度。善能入出禅定解脱。于诸三昧。悉得自在。往来生死。如游园观。未曾暂起疲厌之心。或住魔宫。或为释天。梵王世主。一切生处。靡不于中。而现其身。或于外道众中出家。而恒远离一切邪见。一切世间。文词咒术。字印算数。乃至游戏歌舞之法。悉皆示现。无不精巧。或时示作端正妇人。智慧才能。世中第一。于诸世间出世间法。能问能说。问答断疑。皆得究竟。一切世间出世间事。亦悉通达。到于彼岸。一切众生。恒来瞻仰。虽现声闻辟支佛威仪。而不失大乘心。虽念念中。示成正觉而不断菩萨行。是为第四不由他教方便善巧究竟彼岸不共法。佛子。菩萨摩诃萨。善知权实双行道。智慧自在。到于究竟。所谓住于涅槃。而示现生死。知无众生。而勤行教化。究竟寂灭。而现起烦恼。住一坚密智慧法身。而普现无量诸众生身。常入深禅定。而示受欲乐。常远离三界。而不舍众生。常乐法乐。而现有采女。歌咏嬉戏。虽以众相好。庄严其身。而示受丑陋贫贱之形。常积集众善。无诸过恶。而现生地狱畜生饿鬼。虽已到于佛智彼岸。而亦不舍菩萨智身。菩萨摩诃萨。成就如是无量智慧。声闻独觉。尚不能知。何况一切童蒙众生。是为第五不由他教权实双行不共法。佛子。菩萨摩诃萨。身口意业。随智慧行。皆悉清净。所谓具足大慈。永离杀心。乃至具足正解。无有邪见。是为第六不由他教身口意业随智慧行不共法。佛子。菩萨摩诃萨。具足大悲。不舍众生。代一切众生。而受诸苦。所谓地狱苦。畜生苦。饿鬼苦。为利益故。不生劳倦。唯专度脱一切众生。未曾耽染五欲境界。常为精勤。灭除众苦。是为第七不由他教常起大悲不共法。佛子。菩萨摩诃萨。常为众生之所乐见。梵王帝释。四天王等。一切众生。见无厌足。何以故。菩萨摩诃萨。久远世来。行业清净。无有过失。是故众生。见者无厌。是为第八不由他教一切众生皆悉乐见不共法。佛子。菩萨摩诃萨。于萨婆若。大誓庄严。志乐坚固。虽处凡夫声闻独觉。险难之处。终不退失一切智心明净妙宝。佛子。如有宝珠。名净庄严。置泥涝中。光色不改。能令浊水。悉皆澄净。菩萨摩诃萨。亦复如是。虽在凡愚杂浊等处。终不失坏求一切智清净宝心。而能令彼诸恶众生。远离妄见。烦恼秽浊。得求一切智清净心宝。是为第九不由他教在众难处不失一切智心宝不共法。佛子。菩萨摩诃萨。成就自觉境界智。无师自悟。究竟自在。到于彼岸。离垢法缯。以冠其首。而于善友。不舍亲近。于诸如来。常乐尊重。是为第十不由他教得最上法不离善知识不舍尊重佛不共法。佛子。是为菩萨摩诃萨。十种不共法。若诸菩萨。安住其中。则得如来无上广大不共法。佛子。菩萨摩诃萨。有十种业。何等为十。所谓一切世界业。悉能严净故。一切诸佛业。悉能供养故。一切菩萨业。同种善根故。一切众生业。悉能教化故。一切未来业。尽未来际摄取故。一切神力业。不离一世界遍至一切世界故。一切光明业。放无边色光明。一一光中。有莲华座。各有菩萨。结跏趺坐。而显现故。一切三宝种不断业。诸佛灭后。守护住持诸佛法故。一切变化业。于一切世界。说法教化诸众生故。一切加持业。于一念中。随诸众生心之所欲。皆为示现。令一切愿。悉成满故。是为十。若诸菩萨。安住此法。则得如来无上广大业。佛子。菩萨摩诃萨。有十种身。何等为十。所谓不来身。于一切世间。不受生故。不去身。于一切世间。求不得故。不实身。一切世间。如实得故。不虚身。以如实理。示世间故。不尽身。尽未来际。无断绝故。坚固身。一切众魔。不能坏故。不动身。众魔外道。不能动故。具相身。示现清净百福相故。无相身。法相究竟。悉无相故。普至身。与三世佛。同一身故。是为十。若诸菩萨。安住此法。则得如来无上无尽之身

佛子。菩萨摩诃萨。有十种身业。何等为十。所谓一身充满一切世界身业。于一切众生前。悉能示现身业。于一切趣。悉能受生身业。游行一切世界身业。往诣一切诸佛。众会身业。能以一手。普覆一切世界身业。能以一手。磨一切世界金刚围山。碎如微尘身业。于自身中。现一切佛刹成坏。示于众生身业。以一身。容受一切众生界身业。于自身中。普现一切清净佛刹。一切众生。于中成道身业。是为十。若诸菩萨。安住此法。则得如来无上佛业。悉能觉悟一切众生。佛子。菩萨摩诃萨。复有十种身。何等为十。所谓诸波罗蜜身。悉正修行故。四摄身。不舍一切众生故。大悲身。代一切众生。受无量苦。无疲厌故。大慈身。救护一切众生故。福德身。饶益一切众生故。智慧身。与一切佛身。同一性故。法身。永离诸趣受生故。方便身。于一切处现前故。神力身。示现一切神变故。菩提身。随乐随时。成正觉故。是为十。若诸菩萨。安住此法。则得如来无上大智慧身。佛子。菩萨摩诃萨。有十种语。何等为十。所谓柔软语。使一切众生。皆安隐故。甘露语。令一切众生。悉清凉故。不诳语。所有言说。皆如实故。真实语。乃至梦中。无妄语故。广大语。一切释梵。四天王等。皆尊敬故。甚深语。显示法性故。坚固语。说法无尽故。正直语。发言易了故。种种语。随时示现故。开悟一切众生语。随其欲乐。令解了故。是为十。若诸菩萨。安住此法。则得如来无上微妙语。佛子。菩萨摩诃萨。有十种净修语业。何等为十。所谓乐听闻如来音声。净修语业。乐闻说菩萨功德。净修语业。不说一切众生不乐闻语。净修语业。真实远离语四过失。净修语业。欢喜踊跃赞叹如来。净修语业。如来塔所高声赞佛。如实功德净修语业。以深净心。施众生法。净修语业。音乐歌颂。赞叹如来。净修语业。于诸佛所。听闻正法。不惜身命。净修语业。舍身承事一切菩萨。及诸法师。而受妙法。净修语业。是为十。佛子。若菩萨摩诃萨。以此十事净修语业。则得十种守护。何等为十。所谓天王为首。一切天众。而为守护。龙王为首。一切龙众。而为守护。夜叉王为首。乾闼婆王为首。阿修罗王为首。迦楼罗王为首。紧那罗王为首。摩睺罗伽王为首。梵王为首。一一皆与自己徒众而为守护。如来法王为首。一切法师。皆悉守护。是为十。佛子。菩萨摩诃萨。得此守护已。则能成辨十种大事。何等为十。所谓一切众生皆令欢喜。一切世界悉能往诣。一切诸根皆能了知。一切胜解悉令清净。一切烦恼皆令除断。一切习气皆令舍离。一切欲乐皆令明洁。一切深心悉使增长。一切法界悉令周遍。一切涅槃普令明见。是为十。佛子。菩萨摩诃萨。有十种心。何等为十。所谓如大地心。能持能长一切众生诸善根故。如大海心。一切诸佛。无量无边。大智法水。悉流入故。如须弥山王心。置一切众生于出世间最上善根处故。如摩尼宝王心。乐欲清净无杂染故。如金刚心。决定深入一切法故。如金刚围山心。诸魔外道。不能动故。如莲华心。一切世法。不能染故。如优昙钵华心。一切劫中。难值遇故。如净日心。破闇障故。如虚空心。不可量故。是为十。若诸菩萨。安住其中。则得如来无上大清净心。佛子。菩萨摩诃萨。有十种发心。何等为十。所谓发我当度脱一切众生心。发我当令一切众生除断烦恼心。发我当令一切众生消灭习气心。发我当断除一切疑惑心。发我当除灭一切众生苦恼心。发我当除灭一切恶道。诸难心。发我当敬顺一切如来心。发我当善学一切菩萨所学心。发我当于一切世间一一毛端处。现一切佛成正觉心。发我当于一切世界。击无上法鼓。令诸众生。随其根欲。悉得悟解心。是为十。若诸菩萨。安住其中。则得如来无上大发起能事心。佛子。菩萨摩诃萨。有十种周遍心。何等为十。所谓周遍一切虚空心。发意广大故。周遍一切法界心。深入无边故。周遍一切三世心。一念悉知故。周遍一切佛出现心。于入胎诞生。出家成道。转法轮。般涅槃。悉明了故。周遍一切众生心。悉知根欲习气故。周遍一切智慧心。随顺了知法界故。周遍一切无边心。知诸幻网差别故。周遍一切无生心。不得诸法自性故。周遍一切无碍心。不住自心他心故。周遍一切自在心。一念普现成佛故。是为十。若诸菩萨。安住其中。则得无量无上佛法周遍庄严。佛子。菩萨摩诃萨。有十种根。何等为十。所谓欢喜根。见一切佛。信不坏故。希望根。所闻佛法。皆悟解故。不退根。一切作事。皆究竟故。安住根。不断一切菩萨行故。微细根。入般若波罗蜜。微妙理故。不休息根。究竟一切众生事故。如金刚根。证知一切诸法性故。金刚光焰根。普照一切佛境界故。无差别根。一切如来。同一身故。无碍际根。深入如来十种力故。是为十。若诸菩萨。安住其中。则得如来无上大智圆满根。佛子。菩萨摩诃萨。有十种深心。何等为十。所谓不染一切世间法深心。不杂一切二乘道深心。了达一切佛菩提深心。随顺一切智智道深心。不为一切众魔外道所动深心。净修一切如来圆满智深心。受持一切所闻法深心。不着一切受生处深心。具足一切微细智深心。修一切诸佛法深心。是为十。若诸菩萨。安住其中。则得一切智无上清净深心。佛子。菩萨摩诃萨。有十种增上深心。何等为十。所谓不退转增上深心。积集一切善根故。离疑惑增上深心。解一切如来密语故。正持增上深心。大愿大行所流故。最胜增上深心。深入一切佛法故。为主增上深心。一切佛法自在故。广大增上深心。普入种种法门故。上首增上深心。一切所作成办故。自在增上深心。一切三昧。神通变化。庄严故。安住增上深心。摄受本愿故。无休息增上深心。成熟一切众生故。是为十。若诸菩萨。安住此法。则得一切诸佛无上清净增上深心。佛子。菩萨摩诃萨。有十种勤修。何等为十。所谓布施勤修。悉舍一切。不求报故。持戒勤修。头陀苦行。少欲知足。无所欺故。忍辱勤修。离自他想。忍一切恶。毕竟不生。恚害心故。精进勤修。身语意业。未曾散乱。一切所作。皆不退转。至究竟故。禅定勤修。解脱三昧。出现神通。离一切欲烦恼斗诤。诸眷属故。智慧勤修。修习积聚一切功德。无厌倦故。大慈勤修。知诸众生。无自性故。大悲勤修。知诸法空。普代一切众生受苦。无疲厌故。觉悟如来十力勤修。了达无碍。示众生故。不退法轮勤修。转至一切众生心故。是为十。若诸菩萨。安住此法。则得如来无上大智慧勤修。佛子。菩萨摩诃萨。有十种决定解。何等为十。所谓最上决定解。种植尊重善根故。庄严决定解。出生种种庄严故。广大决定解。其心未曾狭劣故。寂灭决定解。能入甚深法性故。普遍决定解。发心无所不及故。堪任决定解。能受佛力加持故。坚固决定解。摧破一切魔业故。明断决定解。了知一切业报故。现前决定解。随意能现神通故。绍隆决定解。一切佛所得记故。自在决定解。随意随时成佛故。是为十。若诸菩萨。安住此法。则得如来无上决定解。佛子。菩萨摩诃萨。有十种决定解知诸世界。何等为十。所谓知一切世界入一世界。知一世界入一切世界。知一切世界。一如来身。一莲华座。皆悉周遍。知一切世界皆如虚空。知一切世界具佛庄严。知一切世界菩萨充满。知一切世界入一毛孔。知一切世界入一众生身。知一切世界一佛菩提树。一佛道场。皆悉周遍。知一切世界。一音普遍。令诸众生。各别了知。心生欢喜。是为十。若诸菩萨。安住此法。则得如来无上佛刹广大决定解。佛子。菩萨摩诃萨。有十种决定解知众生界。何等为十。所谓知一切众生界。本性无实。知一切众生界。悉入一众生身。知一切众生界。悉入菩萨身。知一切众生界。悉入如来藏。知一众生身。普入一切众生界。知一切众生界。悉堪为诸佛法器。知一切众生界。随其所欲。为现释梵护世身。知一切众生界。随其所欲。为现声闻独觉寂静威仪。知一切众生界。为现菩萨功德庄严身。知一切众生界。为现如来相好。寂静威仪。开悟众生。是为十。若诸菩萨。安住此法。则得如来无上大威力决定解

大方广佛华严经卷第五十六大方广佛华严经卷第五十七

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之五

佛子。菩萨摩诃萨。有十种习气。何等为十。所谓菩提心习气。善根习气。教化众生习气。见佛习气。于清净世界受生习气。行习气。愿习气。波罗蜜习气。思惟平等法习气。种种境界差别习气。是为十。若诸菩萨。安住此法。则永离一切烦恼习气。得如来大智习气。非习气智。佛子。菩萨摩诃萨。有十种取。以此不断诸菩萨行。何等为十。所谓取一切众生界。究竟教化故。取一切世界。究竟严净故。取如来。修菩萨行为供养故。取善根。积集诸佛相好功德故。取大悲。灭一切众生苦故。取大慈。与一切众生一切智乐故。取波罗蜜。积集菩萨诸庄严故。取善巧方便。于一切处。皆示现故。取菩提。得无碍智故。略说菩萨。取一切法。于一切处。悉以明智。而现了故。是为十。若诸菩萨。安住此取。则能不断诸菩萨行。得一切如来无上无所取法。佛子。菩萨摩诃萨。有十种修。何等为十。所谓修诸波罗蜜。修学。修慧。修义。修法。修出离。修示现。修勤行匪懈。修成等正觉。修转正法轮。是为十。若诸菩萨。安住其中。则得无上修。修一切法。佛子。菩萨摩诃萨。有十种成就佛法。何等为十。所谓不离善知识。成就佛法。深信佛语。成就佛法。不谤正法。成就佛法。以无量无尽善根回向。成就佛法。信解如来境界无边际。成就佛法。知一切世界境界。成就佛法。不舍法界境界。成就佛法。远离诸魔境界。成就佛法。正念一切诸佛境界。成就佛法。乐求如来十力境界。成就佛法。是为十。若诸菩萨。安住此法。则得成就如来无上大智慧。佛子。菩萨摩诃萨。有十种退失佛法。应当远离。何等为十。所谓轻慢善知识。退失佛法。畏生死苦。退失佛法。厌修菩萨行。退失佛法。不乐住世间。退失佛法。耽着三昧。退失佛法。执取善根。退失佛法。诽谤正法。退失佛法。断菩萨行。退失佛法。乐二乘道。退失佛法。嫌恨诸菩萨。退失佛法。是为十。若诸菩萨。远离此法。则入菩萨离生道。佛子。菩萨摩诃萨。有十种离生道。何等为十。所谓出生般若波罗蜜。而恒观察一切众生是为一。远离诸见。而度脱一切见缚众生是为二。不念一切相。而不舍一切着相众生是为三。超过三界。而常在一切世界是为四。永离烦恼。而与一切众生共居是为五。得离欲法。而常以大悲。哀愍一切着欲众生是为六。常乐寂静。而恒示现一切眷属是为七。离世间生。而死此生彼。起菩萨行是为八。不染一切世间法。而不断一切世间所作是为九。诸佛菩提。已现其前。而不舍菩萨。一切愿行是为十。佛子。是为菩萨摩诃萨。十种离生道。出离世间。不与世共。而亦不杂二乘之行。若诸菩萨。安住此法。则得菩萨决定法。佛子。菩萨摩诃萨。有十种决定法。何等为十。所谓决定于如来种族中生。决定于诸佛境界中住。决定了知菩萨所作事。决定安住诸波罗蜜。决定得预如来众会。决定能显如来种性。决定安住如来力。决定深入佛菩提。决定与一切如来。同一身。决定与一切如来。所住无有二。是为十。佛子。菩萨摩诃萨。有十种出生佛法道。何等为十。所谓随顺善友。是出生佛法道。同种善根故。深心信解。是出生佛法道。知佛自在故。发大誓愿。是出生佛法道。其心宽广故。忍自善根。是出生佛法道。知业不失故。一切劫修行无厌足。是出生佛法道。尽未来际故。阿僧祇世界皆示现。是出生佛法道。成熟众生故。不断菩萨行。是出生佛法道。增长大悲故。无量心。是出生佛法道。一念遍一切虚空界故。殊胜行。是出生佛法道。本所修行。无失坏故。如来种。是出生佛法道。令一切众生。乐发菩提心。以一切善法资持故。是为十。若诸菩萨。安住此法。则得大丈夫名号。佛子。菩萨摩诃萨。有十种大丈夫名号。何等为十。所谓名为菩提萨埵。菩提智所生故。名为摩诃萨埵。安住大乘故。名为第一萨埵。证第一法故。名为胜萨埵。觉悟胜法故。名为最胜萨埵。智慧最胜故。名为上萨埵。起上精进故。名为无上萨埵。开示无上法故。名为力萨埵。广知十力故。名为无等萨埵。世间无比故。名为不思议萨埵。一念成佛故。是为十。若诸菩萨。得此名号。则成就菩萨道。佛子。菩萨摩诃萨。有十种道。何等为十。所谓一道是菩萨道。不舍独一菩提心故。二道是菩萨道。出生智慧及方便故。三道是菩萨道。行空无相无愿。不着三界故。四行是菩萨道。忏除罪障。随喜福德。恭敬尊重。劝请如来。善巧回向。无休息故。五根是菩萨道。安住净信。坚固不动。起大精进。所作究竟。一向正念。无异攀缘。巧知三昧入出方便。善能分别智慧境界故。六通是菩萨道。所谓天眼悉见一切世界所有众色。知诸众生死此生彼故。天耳悉闻诸佛说法。受持忆念。广为众生。随根演畅故。他心智。能知他心。自在无碍故。宿命念。忆知过去一切劫数。增长善根故。神足通。随所应化一切众生。种种为现。令乐法故。漏尽智。现证实际。起菩萨行。不断绝故。七念是菩萨道。所谓念佛。于一毛孔。见无量佛。开悟一切众生心故。念法。不离一如来众会。于一切如来众会中。亲承妙法。随诸众生。根性欲乐。而为演说。令悟入故。念僧。恒相续见。无有休息。于一切世间。见菩萨故。念舍。了知一切菩萨舍行。增长广大布施心故。念戒。不舍菩提心。以一切善根。回向众生故。念天。常忆念兜率陀天宫一生补处菩萨故。念众生。智慧方便。教化调伏。普及一切。无间断故。随顺菩提。八圣道是菩萨道。所谓行正见道。远离一切诸邪见故。起正思惟。舍妄分别。心常随顺一切智故。常行正语。离语四过。顺圣言故。恒修正业。教化众生。令调伏故。安住正命。头陀知足。威仪审正。随顺菩提。行四圣种。一切过失。皆永离故。起正精进。勤修一切菩萨苦行。入佛十力无挂碍故。心常正念。悉能忆持一切言音。除灭世间散动心故。心常正定。善入菩萨不思议解脱门。于一三昧中。出生一切诸三昧故。入九次第定。是菩萨道。所谓离欲恚害。而以一切语业。说法无碍。灭除觉观。而以一切智觉观。教化众生。舍离喜爱。而见一切佛。心大欢喜。离世间乐。而随顺出世菩萨道乐。从此不动。入无色定。而亦不舍欲色受生。虽住灭一切想受定。而亦不息菩萨行故。学佛十力。是菩萨道。所谓善知是处非处智。善知一切众生去来现在业报因果智。善知一切众生上中下根不同随宜说法智。善知一切众生种种无量性智。善知一切众生软中上解差别令入法方便智。遍一切世间一切刹一切三世一切劫普现如来形相威仪而亦不舍菩萨所行智。善知一切诸禅解脱及诸三昧若垢若净时与非时方便出生诸菩萨解脱门智。知一切众生于诸趣中死此生彼差别智。于一念中悉知三世一切劫数智。善知一切众生乐欲诸使惑习灭尽智。而不舍离诸菩萨行。是为十。若诸菩萨。安住此法。则得一切如来。无上巧方便道

佛子。菩萨摩诃萨。有无量道。无量助道。无量修道。无量庄严道。佛子。菩萨摩诃萨。有十种无量道。何等为十。所谓虚空无量故。菩萨道亦无量。法界无边故。菩萨道亦无量。众生界无尽故。菩萨道亦无量。世界无际故。菩萨道亦无量。劫数不可尽故。菩萨道亦无量。一切众生语言法无量故。菩萨道亦无量。如来身无量故。菩萨道亦无量。佛音声无量故。菩萨道亦无量。如来力无量故。菩萨道亦无量。一切智智无量故。菩萨道亦无量。是为十。佛子。菩萨摩诃萨。有十种无量助道。所谓如虚空界无量。菩萨集助道亦无量。如法界无边。菩萨集助道亦无边。如众生界无尽。菩萨集助道亦无尽。如世界无际。菩萨集助道亦无际。如劫数说不可尽。菩萨集助道亦一切世间。说不能尽。如众生语言法无量。菩萨集助道。出生智慧。知语言法亦无量。如如来身无量。菩萨集助道。遍一切众生。一切刹。一切世。一切劫亦无量。如佛音声无量。菩萨出一言音。周遍法界。一切众生。无不闻知故。所集助道亦无量。如佛力无量。菩萨承如来力。积集助道亦无量。如一切智智无量。菩萨积集助道亦如是无有量。是为十。若诸菩萨。安住此法。则得如来无量智慧。佛子。菩萨摩诃萨。有十种无量修道。何等为十。所谓不来不去修。身语意业。无动作故。不增不减修。如本性故非有非无修。无自性故。如幻如梦。如影如响。如镜中像。如热时焰。如水中月修。离一切执着故。空无相无愿无作修。明见三界。而集福德。不休息故。不可说无言说离言说修。远离施设。安立法故。不坏法界修。智慧现知一切法故。不坏真如实际修。普入真如实际虚空际故。广大智慧修。诸有所作力无尽故。住如来十力四无所畏一切智智平等修。现见一切法无疑惑故。是为十。若诸菩萨。安住此法。则得如来一切智无上善巧修。佛子。菩萨摩诃萨。有十种庄严道。何等为十。佛子。菩萨摩诃萨。不离欲界。入色界无色界禅定解脱。及诸三昧。亦不因此。而受彼生。是为第一庄严道。智慧现前。入声闻道。不以此道。而取出离。是为第二庄严道。智慧现前。入辟支佛道。而起大悲。无有休息。是为第三庄严道。虽有人天。眷属围绕。百千采女。歌舞侍从。未曾暂舍禅定解脱及诸三昧。是为第四庄严道。与一切众生。受诸欲乐。共相娱乐。乃至未曾于一念间。舍离菩萨平等三昧。是为第五庄严道。已到一切世间彼岸。于诸世法。悉无所著。而亦不舍度众生行。是为第六庄严道。安住正道正智正见。而能示入一切邪道。不取为实。不执为净。令彼众生。远离邪法。是为第七庄严道。常善护持如来净戒。身语意业。无诸过失。为欲教化犯戒众生。示行一切凡愚之行。虽已具足清净福德。住菩萨趣。而示生于一切地狱畜生饿鬼。及诸险难。贫穷等处。令彼众生。皆得解脱。而实菩萨。不生彼趣。是为第八庄严道。不由他教。得无碍辩。智慧光明。普能照了一切佛法。为一切如来神力所持。与一切诸佛。同一法身。成就一切坚固大人明净密法。安住一切平等诸乘。诸佛境界。皆现其前。具足一切世智光明。照见一切诸众生界。能为众生。作知法师。而示求正法。未曾休息。虽实与众生。作无上师。而示行尊敬阇梨和尚。何以故。菩萨摩诃萨。善巧方便。住菩萨道。随其所应。皆为示现。是为第九庄严道。善根具足。诸行究竟。一切如来。所共灌顶。到一切法自在彼岸。无碍法缯。以冠其首。其身遍至一切世界。普现如来无碍之身。于法自在。最上究竟。转于无碍清净法轮。一切菩萨自在之法。皆已成就。而为众生故。于一切国土。示现受生。与三世诸佛。同一境界。而不废菩萨行。不舍菩萨法。不懈菩萨业。不离菩萨道。不弛菩萨仪。不断菩萨取。不息菩萨巧方便。不绝菩萨所作事。不厌菩萨生成用。不止菩萨住持力。何以故。菩萨欲疾证阿耨多罗三藐三菩提。观一切智门。修菩萨行。无休息故。是为第十庄严道。若诸菩萨。安住此法。则得如来无上大庄严道。亦不舍菩萨道。佛子。菩萨摩诃萨。有十种足。何等为十。所谓持戒足。殊胜大愿。悉成满故。精进足。集一切菩提分法。不退转故。神通足。随众生欲。令欢喜故。神力足。不离一佛刹。往一切佛刹故。深心足。愿求一切殊胜法故。坚誓足。一切所作。咸究竟故。随顺足。不违一切尊者教故。乐法足。闻持一切佛所说法。不疲懈故。法雨足。为众演说。无怯弱故。修行足。一切诸恶。悉远离故。是为十。若诸菩萨。安住此法。则得如来无上最胜足。若一举步。悉能遍至一切世界。佛子。菩萨摩诃萨。有十种手。何等为十。所谓深信手。于佛所说。一向忍可。究竟受持故。布施手。有来求者。随其所欲。皆令充满故。先意问讯手。舒展右掌。相迎引故。供养诸佛手。集众福德。无疲厌故。多闻善巧手。悉断一切众生疑故。令超三界手。授与众生。拔出欲泥故。置于彼岸手。四暴流中。救溺众生故。不吝正法手。所有妙法。悉以开示故。善用众论手。以智慧乐。灭身心病故。恒持智宝手。开法光明。破烦恼闇故。是为十。若诸菩萨。安住此法。则得如来无上手。普覆十方一切世界。佛子。菩萨摩诃萨。有十种腹。何等为十。所谓离谄曲腹。心清净故。离幻伪腹。性质直故。不虚假腹。无险诐故。无欺夺腹。于一切物。无所贪故。断烦恼腹。具智慧故。清净心腹。离诸恶故。观察饮食腹。念如实法故。观察无作腹。觉悟缘起故。觉悟一切出离道腹。善成熟深心故。远离一切边见垢腹。令一切众生。得入佛腹故。是为十。若诸菩萨。安住此法。则得如来无上广大腹。悉能容受一切众生。佛子。菩萨摩诃萨。有十种藏。何等为十。所谓不断佛种。是菩萨藏。开示佛法无量威德故。增长法种。是菩萨藏。出生智慧广大光明故。住持僧种。是菩萨藏。令其得入不退法轮故。觉悟正定众生。是菩萨藏。善随其时。不逾一念故。究竟成熟不定众生。是菩萨藏。令因相续。无有间断故。为邪定众生。发起大悲。是菩萨藏。令未来因。悉得成就故。满佛十力不可坏因。是菩萨藏。具降伏魔军。无对善根故。最胜无畏大师子吼。是菩萨藏。令一切众生。皆欢喜故。得佛十八不共法。是菩萨藏。智慧普入一切处故。普了知一切众生。一切刹。一切法。一切佛。是菩萨藏。于一念中。悉明见故。是为十。若诸菩萨。安住此法。则得如来无上善根不可坏大智慧藏。佛子。菩萨摩诃萨。有十种心。何等为十。所谓精勤心。一切所作。悉究竟故。不懈心。积集相好。福德行故。大勇健心。摧破一切诸魔军故。如理行心。除灭一切诸烦恼故。不退转心。乃至菩提。终不息故。性清净心。知心不动。无所著故。知众生心。随其解欲。令出离故。令入佛法。大梵住心。知诸众生。种种解欲。不以别乘。而救护故。空无相无愿无作心。见三界相。不取着故。卍字相金刚坚固胜藏庄严心。一切众生数等魔来。乃至不能动一毛故。是为十。若诸菩萨。安住此法。则得如来无上大智光明藏心。佛子。菩萨摩诃萨。有十种被甲。何等为十。所谓被大慈甲。救护一切众生故。被大悲甲。堪忍一切诸苦故。被大愿甲。一切所作究竟故。被回向甲。建立一切佛庄严故。被福德甲。饶益一切诸众生故。被波罗蜜甲。度脱一切诸含识故。被智慧甲。灭一切众生。烦恼闇故。被善巧方便甲。生普门善根故。被一切智心坚固不散乱甲。不乐余乘故。被一心决定甲。于一切法。离疑惑故。是为十。若诸菩萨。安住此法。则被如来无上甲胄。悉能摧伏一切魔军。佛子。菩萨摩诃萨。有十种器仗。何等为十。所谓布施是菩萨器仗。摧破一切悭吝故。持戒是菩萨器仗。弃舍一切毁犯故。平等是菩萨器仗。断除一切分别故。智慧是菩萨器仗。消灭一切烦恼故。正命是菩萨器仗。远离一切邪命故。善巧方便是菩萨器仗。于一切处示现故。略说贪嗔痴等一切烦恼是菩萨器仗。以烦恼门。度众生故。生死是菩萨器仗。不断菩萨行。教化众生故。说如实法。是菩萨器仗。能破一切执着故。一切智是菩萨器仗。不舍菩萨行门故。是为十。若诸菩萨。安住此法。则能除灭一切众生。长夜所集。烦恼结使

佛子。菩萨摩诃萨。有十种首。何等为十。所谓涅槃首。无能见顶故。尊敬首。一切人天。所敬礼故。广大胜解首。三千界中。最为胜故。第一善根首。三界众生。咸供养故。荷戴众生首。成就顶上肉髻相故。不轻贱他首。于一切处。常尊胜故。般若波罗蜜首。长养一切功德法故。方便智相应首。普现一切同类身故。教化一切众生首。以一切众生。为弟子故。守护诸佛法眼首。能令三宝种。不断绝故。是为十。若诸菩萨。安住此法。则得如来无上大智慧首。佛子。菩萨摩诃萨。有十种眼。所谓肉眼。见一切色故。天眼。见一切众生心故。慧眼。见一切众生。诸根境界故。法眼。见一切法。如实相故。佛眼。见如来十力故。智眼。知见诸法故。光明眼。见佛光明故。出生死眼。见涅槃故。无碍眼。所见无障故。一切智眼。见普门法界故。是为十。若诸菩萨。安住此法。则得如来无上大智慧眼。佛子。菩萨摩诃萨。有十种耳。何等为十。所谓闻赞叹声。断除贪爱。闻毁呰声。断除嗔恚。闻说二乘。不着不求。闻菩萨道。欢喜踊跃。闻地狱等诸苦难处。起大悲心。发弘誓愿。闻说人天胜妙之事。知彼皆是无常之法。闻有赞叹诸佛功德。勤加精进。令速圆满。闻说六度四摄等法。发心修行。愿到彼岸。闻十方世界一切音声。悉知如响。入不可说甚深妙义。菩萨摩诃萨。从初发心。乃至道场。常闻正法。未曾暂息。而恒不舍化众生事。是为十。若诸菩萨。成就此法。则得如来无上大智慧耳。佛子。菩萨摩诃萨。有十种鼻。何等为十。所谓闻诸臭物。不以为臭。闻诸香气。不以为香。香臭俱闻。其心平等。非香非臭。安住于舍。若闻众生。衣服卧具。及其肢体。所有香臭。则能知彼贪恚愚痴。等分之行。若闻诸伏藏。草木等香。皆如对目前。分明辨了。若闻下至阿鼻地狱。上至有顶众生之香。皆知彼过去所行之行。若闻诸声闻。布施持戒。多闻慧香。住一切智心。不令散动。若闻一切菩萨行香以平等慧。入如来地。闻一切佛智境界香。亦不废舍诸菩萨行。是为十。若诸菩萨。成就此法。则得如来无量无边清净鼻。佛子。菩萨摩诃萨。有十种舌。何等为十。所谓开示演说无尽众生行舌。开示演说无尽法门舌。赞叹诸佛无尽功德舌。演畅辞辩无尽舌。开阐大乘助道舌。遍覆十方虚空舌。普照一切佛刹舌。普使众生悟解舌。悉令诸佛叹喜舌。降伏一切诸魔外道。除灭一切生死烦恼。令至涅槃舌。是为十。若诸菩萨。成就此法。则得如来遍覆一切诸佛国土无上舌。佛子。菩萨摩诃萨。有十种身。何等为十。所谓人身。为教化一切诸人故。非人身。为教化地狱畜生饿鬼故。天身。为教化欲界色界无色界众生故。学身。示现学地故。无学身。示现阿罗汉地故。独觉身。教化令入辟支佛地故。菩萨身。令成就大乘故。如来身。智水灌顶故。意生身。善巧出生故。无漏法身。以无功用示现一切众生身故。是为十。若诸菩萨。成就此法。则得如来无上之身。佛子。菩萨摩诃萨。有十种意。何等为十。所谓上首意。发起一切善根故。安住意。深信坚固不动故。深入意。随顺佛法而解故。内了意。知诸众生心乐故。无乱意。一切烦恼不杂故。明净意。客尘不能染着故。善观众生意。无有一念失时故。善择所作意。未曾一处生过故。密护诸根意。调伏不令驰散故。善入三昧意。深入佛三昧无我我所故。是为十。若诸菩萨。安住此法。则得一切佛无上意。佛子。菩萨摩诃萨。有十种行。何等为十。所谓闻法行。爱乐于法故。说法行。利益众生故。离贪恚痴怖畏行。调伏自心故。欲界行。教化欲界众生故。色无色界三昧行。令速转还故。趣向法义行。速得智慧故。一切生处行。自在教化众生故。一切佛刹行。礼拜供养诸佛故。涅槃行。不断生死相续故。成满一切佛法行。不舍菩萨法行故。是为十。若诸菩萨。安住此法。则得如来无来无去行。佛子。菩萨摩诃萨。有十种住。何等为十。所谓菩提心住。曾不忘失故。波罗蜜住。不厌助道故。说法住。增长智慧故。阿兰若住。证大禅定故。随顺一切智头陀知足四圣种住。少欲少事故。深信住。荷负正法故。亲近如来住。学佛威仪故。出生神通住。圆满大智故。得忍住。满足授记故。道场住。具足力无畏一切佛法故。是为十。若诸菩萨。安住此法。则得一切智无上住。佛子。菩萨摩诃萨。有十种坐。何等为十。所谓转轮王坐。兴十善道故。四天王坐。于一切世间。自在安立佛法故。帝释坐。与一切众生。为胜主故。梵天坐。于自他心。得自在故。师子坐。能说法故。正法坐。以总持辩才力。而开示故。坚固坐。誓愿究竟故。大慈坐。令恶众生。悉欢喜故。大悲坐。忍一切苦。不疲厌故。金刚坐。降伏众魔及外道故。是为十。若诸菩萨。安住此法。则得如来无上正觉坐。佛子。菩萨摩诃萨。有十种卧。何等为十。所谓寂静卧。身心憺怕故。禅定卧。如理修行故。三昧卧。身心柔软故。梵天卧。不恼自他故。善业卧。于后不悔故。正信卧。不可倾动故。正道卧。善友开觉故。妙愿卧。善巧回向故。一切事毕卧。所作成辨故。舍诸功用卧。一切惯习故。是为十。若诸菩萨。安住此法。则得如来无上大法卧。悉能开悟一切众生。佛子。菩萨摩诃萨。有十种所住处。何等为十。所谓以大慈为所住处。于一切众生。心平等故。以大悲为所住处。不轻未学故。以大喜为所住处。离一切忧恼故。以大舍为所住处。于有为无为平等故。以一切波罗蜜。为所住处。菩提心为首故。以一切空。为所住处。善巧观察故。以无相为所住处。不出正位故。以无愿为所住处。观察受生故。以念慧为所住处。忍法成满故。以一切法平等。为所住处。得授记别故。是为十。若诸菩萨。安住此法。则得如来无上无碍所住处。佛子。菩萨摩诃萨。有十种所行处。何等为十。所谓以正念为所行处。满足念处故。以诸趣为所行处。正觉法趣故。以智慧为所行处。得佛欢喜故。以波罗蜜。为所行处。满足一切智智故。以四摄为所行处。教化众生故。以生死为所行处。积集善根故。以与一切众生杂谈戏。为所行处。随应教化。令永离故。以神通为所行处。知一切众生。诸根境界故。以善巧方便。为所行处。般若波罗蜜相应故。以道场为所行处。成一切智。而不断菩萨行故。是为十。若诸菩萨。安住此法。则得如来无上大智慧所行处。佛子。菩萨摩诃萨。有十种观察。何等为十。所谓知诸业观察。微细悉见故。知诸趣观察。不取众生故。知诸根观察。了达无根故。知诸法观察。不坏法界故。见佛法观察。勤修佛眼故。得智慧观察。如理说法故。无生忍观察。决了佛法故。不退地观察。灭一切烦恼。超出三界二乘地故。灌顶地观察。于一切佛法。自在不动故。善觉智三昧观察。于一切十方。施作佛事故。是为十。若诸菩萨。安住此法。则得如来无上大观察智。佛子。菩萨摩诃萨。有十种普观察。何等为十。所谓。普观一切诸来求者。以无违心。满其意故。普观一切犯戒众生。安置如来净戒中故。普观一切害心众生。安置如来忍力中故。普观一切懈怠众生。劝令精勤。不舍荷负大乘担故。普观一切乱心众生。令住如来一切智地。无散动故。普观一切恶慧众生。令除疑惑。破有见故。普观一切平等善友。顺其教命。住佛法故。普观一切所闻之法。疾得证见最上义故。普观一切无边众生。常不舍离大悲力故。普观一切诸佛之法。速得成就一切智故。是为十。若诸菩萨。安住此法。则得如来无上大智慧普观察。佛子。菩萨摩诃萨。有十种奋迅。何等为十。所谓牛王奋迅。映蔽一切天龙夜叉乾闼婆等。诸大众故。象王奋迅。心善调柔。荷负一切诸众生故。龙王奋迅。兴大法密云。耀解脱电光。震如实义雷。降诸根力觉分禅定解脱三昧甘露雨故。大金翅鸟王奋迅。竭贪爱水。破愚痴[穀-禾+卵]。搏撮烦恼诸恶毒龙。令出生死大苦海故。大师子王奋迅。安住无畏平等大智。以为器仗。摧伏众魔及外道故。勇健奋迅。能于生死大战阵中。摧灭一切烦恼怨故。大智奋迅。知蕴界处。及诸缘起。自在开示一切法故。陀罗尼奋迅。以念慧力。持法不忘。随众生根。为宣说故。辩才奋迅。无碍迅疾。分别一切咸令受益。心欢喜故。如来奋迅。一切智智助道之法。皆悉成满。以一念相应慧。所应得者。一切皆得。所应悟者。一切皆悟。坐师子座。降魔怨敌。成阿耨多罗三藐三菩提故。是为十。若诸菩萨。安住此法。则得诸佛于一切法无上自在奋迅。佛子。菩萨摩诃萨。有十种师子吼。何等为十。所谓唱言我当必定成正等觉。是菩提心大师子吼。我当令一切众生。未度者度。未脱者脱。未安者安。未涅槃者。令得涅槃。是大悲大师子吼。我当令佛法僧种。无有断绝。是报如来恩大师子吼。我当严净一切佛刹。是究竟坚誓大师子吼。我当除灭一切恶道。及诸难处。是自持净戒大师子吼。我当满足一切诸佛身语及意。相好庄严。是求福无厌大师子吼。我当成满一切诸佛。所有智慧。是求智无厌大师子吼。我当除灭一切众魔。及诸魔业。是修正行断诸烦恼大师子吼。我当了知一切诸法。无我无众生。无寿命。无补伽罗。空无相无愿。净如虚空。是无生法忍大师子吼。最后生菩萨。震动一切诸佛国土。悉令严净。是时一切释梵四王。咸来赞请。唯愿菩萨。以无生法。而现受生。菩萨则以无碍慧眼。普观世间一切众生。无如我者。即于王宫。示现诞生。自行七步大师子吼。我于世间。最胜第一。我当永尽生死边际。是如说而作大师子吼。是为十。若诸菩萨。安住此法。则得如来无上大师子吼

大方广佛华严经卷第五十七大方广佛华严经卷第五十八

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之六

佛子。菩萨摩诃萨。有十种清净施。何等为十。所谓平等施。不拣众生故。随意施。满其所愿故。不乱施。令得利益故。随宜施。知上中下故。不住施。不求果报故。开舍施。心不恋着故。一切施。究竟清净故。回向菩提施。远离有为无为故。教化众生施。乃至道场不舍故。三轮清净施。于施者受者。及以施物。正念观察。如虚空故。是为十。若诸菩萨。安住此法。则得如来无上清净广大施。佛子。菩萨摩诃萨。有十种清净戒。何等为十。所谓身清净戒。护身三恶故。语清净戒。离语四过故。心清净戒。永离贪嗔邪见故。不破一切学处清净戒。于一切人天中。作尊主故。守护菩提心清净戒。不乐小乘故。守护如来所制清净戒。乃至微细罪。生大怖畏故。隐密护持清净戒。善拔犯戒众生故。不作一切恶清净戒。誓修一切善法故。远离一切有见清净戒。于戒无著故。守护一切众生清净戒。发起大悲故。是为十。若诸菩萨。安住此法。则得如来无上无过失清净戒。佛子。菩萨摩诃萨。有十种清净忍。何等为十。所谓安受呰辱清净忍。护诸众生故。安受刀杖清净忍。善护自他故。不生恚害清净忍。其心不动故。不责卑贱清净忍。为上能宽故。有归咸救清净忍。舍自身命故。远离我慢清净忍。不轻未学故。残毁不嗔清净忍。观察如幻故。有犯无报清净忍。不见自他故。不随烦恼清净忍。离诸境界故。随顺菩萨真实智知一切法无生清净忍。不由他教。入一切智境界故。是为十。若诸菩萨。安住其中。则得一切诸佛。不由他悟无上法忍。佛子。菩萨摩诃萨。有十种清净精进。何等为十。所谓身清净精进。承事供养诸佛菩萨。及诸师长。尊重福田。不退转故。语清净精进。随所闻法。广为他说。赞佛功德。无疲倦故。意清净精进。善能入出慈悲喜舍禅定解脱及诸三昧。无休息故。正直心清净精进。无诳无谄。无曲无伪。一切勤修。无退转故。增胜心清净精进。志常趣求上上智慧。愿具一切白净法故。不唐捐清净精进。摄取布施戒忍多闻。及不放逸。乃至菩提。无中息故。摧伏一切魔清净精进。悉能除灭贪欲嗔恚愚痴邪见。一切烦恼。诸缠盖故。成满智慧光清净精进。有所施为。悉善观察。咸使究竟。不令后悔。得一切佛不共法故。无来无去清净精进。得如实智。入法界门。身语及心。皆悉平等。了相非相。无所著故。成就法光清净精进。超过诸地。得佛灌顶。以无漏身。而示殁生。出家成道。说法灭度。具足如是普贤事故。是为十。若诸菩萨。安住此法。则得如来无上大清净精进。佛子。菩萨摩诃萨。有十种清净禅。何等为十。所谓常乐出家清净禅。舍一切所有故。得真善友清净禅。示教正道故。住阿兰若忍风雨等清净禅。离我我所故。离愦闹众生清净禅。常乐寂静故。心业调柔清净禅。守护诸根故。心智寂灭清净禅。一切音声。诸禅定刺。不能乱故。觉道方便清净禅。观察一切皆现证故。离于味着清净禅。不舍欲界故。发起通明清净禅。知一切众生根性故。自在游戏清净禅。入佛三昧。知无我故。是为十。若诸菩萨。安住其中。则得如来无上大清净禅。佛子。菩萨摩诃萨。有十种清净慧。何等为十。所谓知一切因清净慧。不坏果报故。知一切缘清净慧。不违和合故。知不断不常清净慧。了达缘起。皆如实故。拔一切见清净慧。于众生相。无取舍故。观一切众生心行清净慧。了知如幻故。广大辩才清净慧。分别诸法。问答无碍故。一切诸魔外道声闻独觉所不能知清净慧。深入一切如来智故。见一切佛微妙法身见一切众生本性清净见一切法皆悉寂灭见一切刹同于虚空清净慧。知一切相。皆无碍故。一切总持辩才方便波罗蜜清净慧。令得一切最胜智故。一念相应金刚智了一切法平等清净慧。得一切法。最尊智故。是为十。若诸菩萨。安住其中。则得如来无障碍大智慧。佛子。菩萨摩诃萨。有十种清净慈。何等为十。所谓等心清净慈。普摄众生。无所拣择故。饶益清净慈。随有所作。皆令欢喜故。摄物同己清净慈。究竟皆令出生死故。不舍世间清净慈。心常缘念集善根故。能至解脱清净慈。普使众生。除灭一切诸烦恼故。出生菩提清净慈。普使众生。发求一切智心故。世间无碍清净慈。放大光明。平等普照故。充满虚空清净慈。救护众生。无处不至故。法缘清净慈。证于如如真实法故。无缘清净慈。入于菩萨离生性故。是为十。若诸菩萨。安住此法。则得如来无上广大清净慈。佛子。菩萨摩诃萨。有十种清净悲。何等为十。所谓无俦伴清净悲。独发其心故。无疲厌清净悲。代一切众生受苦。不以为劳故。难处受生清净悲。为度众生故。善趣受生清净悲。示现无常故。为邪定众生清净悲。历劫不舍弘誓故。不着己乐清净悲。普与众生快乐故。不求恩报清净悲。修洁其心故。能除颠倒清净悲。说如实法故。菩萨摩诃萨。知一切法本性清净。无染着。无热恼。以客尘烦恼故。而受众苦。如是知已。于诸众生。而起大悲。名本性清净。为说无垢清净光明法故。菩萨摩诃萨。知一切法。如空中鸟迹。众生痴翳。不能照了。观察于彼。起大悲心。名真实智。为其开示涅槃法故。是为十。若诸菩萨。安住此法。则得如来无上广大清净悲。佛子。菩萨摩诃萨。有十种清净喜。何等为十。所谓发菩提心清净喜。悉舍所有清净喜。不嫌弃破戒众生而教化成就清净喜。能忍受造恶众生誓愿救度清净喜。舍身求法不生悔心清净喜。自舍欲乐常乐法乐清净喜。令一切众生舍资生乐常乐法乐清净喜。见一切佛恭敬供养无有厌足法界平等清净喜。令一切众生爱乐禅定解脱三昧游戏入出清净喜。心乐具行顺菩萨道一切苦行证得牟尼寂静不动无上定慧清净喜。是为十。若诸菩萨。安住此法。则得如来无上广大清净喜。佛子。菩萨摩诃萨。有十种清净舍。何等为十。所谓一切众生恭敬供养不生爱着清净舍。一切众生轻慢毁辱不生嗔恚清净舍。常行世间不为世间八法所染清净舍。于法器众生待时而化于无法器亦不生嫌清净舍。不求二乘学无学法清净舍。心常远离一切欲乐顺烦恼法清净舍。不叹二乘厌离生死清净舍。远离一切世间语非涅槃语非离欲语不顺理语恼乱他语声闻独觉语略说乃至一切障菩萨道语皆悉远离清净舍。或有众生根已成熟发生念慧而未能知最上之法待时方化清净舍。或有众生菩萨往昔已曾教化至于佛地方可调伏彼亦待时清净舍。菩萨摩诃萨于彼二人无高无下无取无舍远离一切种种分别恒住正定入如实法心得堪忍清净舍。是为十。若诸菩萨。安住其中。则得如来无上广大清净舍

佛子。菩萨摩诃萨。有十种义。何等为十。所谓多闻义。坚固修行故。法义。善巧思择故。空义。第一义空故。寂静义。离诸众生諠愦故。不可说义。不着一切语言故。如实义。了达三世平等故。法界义。一切诸法一味故。真如义。一切如来顺入故。实际义。了知究竟如实故。大般涅槃义。灭一切苦。而修菩萨诸行故。是为十。若诸菩萨。安住此法。则得一切智无上义。佛子。菩萨摩诃萨。有十种法。何等为十。所谓真实法。如说修行故。离取法。能取所取悉离故。无诤法。无有一切惑诤故。寂灭法。灭除一切热恼故。离欲法。一切贪欲皆断故。无分别法。攀缘分别永息故。无生法。犹如虚空不动故。无为法。离生住灭诸相故。本性法。自性无染清净故。舍一切乌波提涅槃法。能生一切菩萨行。修习不断故。是为十。若诸菩萨。安住其中。则得如来无上广大法。佛子。菩萨摩诃萨。有十种福德助道具。何等为十。所谓劝众生起菩提心。是菩萨福德助道具。不断三宝种故。随顺十种回向。是菩萨福德助道具。断一切不善法。集一切善法故。智慧诱诲。是菩萨福德助道具。超过三界福德故。心无疲倦。是菩萨福德助道具。究竟度脱一切众生故。悉舍内外一切所有。是菩萨福德助道具。于一切物。无所著故。为满足相好。精进不退。是菩萨福德助道具。开门大施。无所限故。上中下三品善根。悉以回向无上菩提心无所轻。是菩萨福德助道具。善巧方便相应故。于邪定下劣。不善众生。皆生大悲。不怀轻贱。是菩萨福德助道具。常起大人。弘誓心故。恭敬供养一切如来。于一切菩萨。起如来想。令一切众生。皆生欢喜。是菩萨福德助道具。守本志愿。极坚牢故。菩萨摩诃萨。于阿僧祇劫。积集善根。自欲取证无上菩提。如在掌中。然悉舍与一切众生。心无忧恼。亦无悔恨。其心广大。等虚空界。此是菩萨福德助道具。起大智慧。证大法故。是为十。若诸菩萨。安住其中。则具足如来无上广大福德聚。佛子。菩萨摩诃萨。有十种智慧助道具。何等为十。所谓亲近多闻。真善知识。恭敬供养。尊重礼拜。种种随顺。不违其教。是为一。一切正直。无虚矫故。永离憍慢。常行谦敬。身语意业。无有粗犷。柔和善顺。不伪不曲。是为二。其身堪作佛法器故。念慧随觉。未曾散乱。惭愧柔和。心安不动。常忆六念。常行六敬。常随顺住六坚固法是为三。与十种智。为方便故。乐法乐义。以法为乐。常乐听闻。无有厌足。舍离世论及世言说。专心听受。出世间语。远离小乘。入大乘慧。是为四。一心忆念。无散动故。六波罗蜜。心专荷负。四种梵住。行已成熟。随顺明法。悉善修行。聪敏智人。皆勤请问。远离恶趣。归向善道。心常爱乐。正念观察。调伏己情。守护他意。是为五。坚固修行真实行故。常乐出离。不着三有。恒觉自心。曾无恶念。三觉已绝。三业皆善。决定了知心之自性。是为六。能令自他心清净故。观察五蕴皆如幻事。界如毒蛇。处如空聚。一切诸法。如幻如焰。如水中月。如梦如影。如响如像。如空中画。如旋火轮。如虹霓色。如日月光。无相无形。非常非断。不来不去。亦无所住。如是观察。知一切法。无生无灭。是为七。知一切法性空寂故。菩萨摩诃萨。闻一切法无我无众生。无寿者无补伽罗。无心无境。无贪嗔痴。无身无物。无主无待。无著无行。如是一切。皆无所有。悉归寂灭。闻已深信。不疑不谤。是为八。以能成就圆满解故。菩萨摩诃萨。善调诸根。如理修行。恒住止观。心意寂静。一切动念。皆悉不生。无我无人。无作无行。无计我想。无计我业。无有疮疣。无有瘢痕。亦无于此所得之忍。身语意业。无来无去。无有精进。亦无勇猛。观一切众生。一切诸法。心皆平等。而无所住。非此岸非彼岸。此彼性离。无所从来。无所至去。常以智慧。如是思惟。是为九。到分别相。彼岸处故。菩萨摩诃萨。见缘起法故。见法清净。见法清净故。见国土清净。见国土清净故。见虚空清净。见虚空清净故。见法界清净。见法界清净故。见智慧清净。是为十。修行积集一切智故。佛子。是为菩萨摩诃萨十种智慧助道具。若诸菩萨。安住此法。则得如来一切法。无障碍清净。微妙智慧聚。佛子。菩萨摩诃萨。有十种明足。何等为十。所谓善分别诸法明足。不取着诸法明足。离颠倒见明足。智慧光照诸根明足。巧发起正精进明足。能深入真谛智明足。灭烦恼业。成就尽智无生智明足。大眼智普。观察明足。宿住念知前际清净明足。漏尽神通智断众生诸漏明足。是为十。若诸菩萨。安住此法。则得如来于一切佛法无上大光明。佛子。菩萨摩诃萨。有十种求法。何等为十。所谓直心求法。无有谄诳故。精进求法。远离懈慢故。一向求法。不惜身命故。为断一切众生烦恼求法。不为名利恭敬故。为饶益自他一切众生求法。不但自利故。为入智慧求法不乐文字故。为出生死求法。不贪世乐故。为度众生求法。发菩提心故。为断一切众生疑求法。令无犹豫故。为满足佛法求法。不乐余乘故。是为十。若诸菩萨。安住此法。则得不由他教一切佛法大智慧。佛子。菩萨摩诃萨。有十种明了法。何等为十。所谓随顺世俗生长善根是童蒙凡夫明了法。得无碍不坏信觉法自性是随信行人明了法。勤修习法随顺法住是随法行人明了法。远离八邪向八正道是第八人明了法。除灭众结断生死漏见真实谛是须陀洹人明了法。观味是患知无往来是斯陀含人明了法。不乐三界求尽有漏于受生法乃至一念不生爱着是阿那含人明了法。获六神通得八解脱九定四辩悉皆成就是阿罗汉人明了法。性乐观察一味缘起心常寂静知足少事解因自得悟不由他成就种种神通智慧是辟支佛人明了法。智慧广大诸根明利常乐度脱一切众生勤修福智助道之法如来所有十力无畏一切功德具足圆满是菩萨人明了法。是为十。若诸菩萨。安住此法。则得如来无上大智明了法。佛子。菩萨摩诃萨。有十种修行法。何等为十。所谓恭敬尊重诸善知识修行法。常为诸天之所觉悟修行法。于诸佛所常怀惭愧修行法。哀愍众生不舍生死修行法。事必究竟心无变动修行法。专念随逐发大乘心诸菩萨众精勤修学修行法。远离邪见勤求正道修行法。摧破众魔及烦恼业修行法。知诸众生根性胜劣。而为说法令住佛地修行法。安住无边广大法界除灭烦恼令身清净修行法。是为十。若诸菩萨。安住其中。则得如来无上修行法。佛子。菩萨摩诃萨。有十种魔。何等为十。所谓蕴魔。生诸取故。烦恼魔。恒杂染故。业魔。能障碍故。心魔。起高慢故。死魔。舍生处故。天魔。自憍纵故。善根魔。恒执取故。三昧魔。久耽味故。善知识魔。起着心故。菩提法智魔。不愿舍离故。是为十。菩萨摩诃萨。应作方便。速求远离。佛子。菩萨摩诃萨。有十种魔业。何等为十。所谓忘失菩提心。修诸善根是为魔业。恶心布施。嗔心持戒。舍恶性人。远懈怠者。轻慢乱意。讥嫌恶慧。是为魔业。于甚深法。心生悭吝。有堪化者。而不为说。若得财利。恭敬供养。虽非法器。而强为说。是为魔业。不乐听闻诸波罗蜜。假使闻说。而不修行。虽亦修行。多生懈怠。以懈怠故。志意狭劣。不求无上大菩提法。是为魔业。远善知识。近恶知识。乐求二乘。不乐受生。志尚涅槃离欲寂静。是为魔业。于菩萨所。起嗔恚心。恶眼视之。求其罪衅。说其过恶。断彼所有。财利供养。是为魔业。诽谤正法。不乐听闻。假使得闻。便生毁呰。见人说法。不生尊重。言自说是。余说悉非。是为魔业。乐学世论。巧术文词。开阐二乘。隐覆深法。或以妙义。授非其人。远离菩提。住于邪道。是为魔业。已得解脱。已安隐者。常乐亲近。而供养之。未得解脱。未安隐者。不肯亲近。亦不教化。是为魔业。增长我慢。无有恭敬。于诸众生。多行恼害。不求正法真实智慧。其心弊恶。难可开悟。是为魔业。是为十。菩萨摩诃萨。应速远离。勤求佛业。佛子。菩萨摩诃萨。有十种舍离魔业。何等为十。所谓近善知识。恭敬供养。舍离魔业。不自尊举。不自赞叹。舍离魔业。于佛深法。信解不谤。舍离魔业。未曾忘失一切智心。舍离魔业。勤修妙行。恒不放逸。舍离魔业。常求一切菩萨藏法。舍离魔业。恒演说法。心无疲倦。舍离魔业。归依十方一切诸佛。起救护想。舍离魔业。信受忆念。一切诸佛。神力加持。舍离魔业。与一切菩萨。同种善根。平等无二。舍离魔业。是为十。若诸菩萨。安住此法。则能出离一切魔道

佛子。菩萨摩诃萨。有十种见佛。何等为十。所谓于安住世间成正觉佛无著见。愿佛出生见。业报佛深信见。住持佛随顺见。涅槃佛深入见。法界佛普至见。心佛安住见。三昧佛无量无依见。本性佛明了见。随乐佛普受见。是为十。若诸菩萨。安住此法。则常得见无上如来。佛子。菩萨摩诃萨。有十种佛业。何等为十。所谓随时开导是佛业。令正修行故。梦中令见是佛业。觉昔善根故。为他演说所未闻经是佛业。令生智断疑故。为悔缠所缠者。说出离法是佛业。令离疑心故。若有众生。起悭吝心。乃至恶慧心。二乘心。损害心。疑惑心。散动心。憍慢心。为现如来众相庄严身是佛业。生长过去善根故。于正法难遇时。广为说法。令其闻已。得陀罗尼智。神通智。普能利益无量众生是佛业。胜解清净故。若有魔事起。能以方便。现虚空界等声。说不损恼他法。以为对治。令其开悟。众魔闻已。威光歇灭是佛业。志乐殊胜。威德大故。其心无间。常自守护。不令证入二乘正位。若有众生。根性未熟。终不为说解脱境界是佛业。本愿所作故。生死结漏。一切皆离。修菩萨行。相续不断。以大悲心。摄取众生。令其起行。究竟解脱是佛业。不断修行菩萨行故。菩萨摩诃萨。了达自身及以众生。本来寂灭。不惊不怖。而勤修福智。无有厌足。虽知一切法无有造作。而亦不舍诸法自相。虽于诸境界。永离贪欲。而常乐瞻奉诸佛色身。虽知不由他悟入于法。而种种方便。求一切智。虽知诸国土皆如虚空。而常乐庄严一切佛刹。虽恒观察无人无我。而教化众生。无有疲厌。虽于法界本来不动。而以神通智力。现众变化。虽已成就一切智智。而修菩萨行。无有休息。虽知诸法不可言说。而转净法轮。令众心喜。虽能示现诸佛神力。而不厌舍菩萨之身。虽现入于大般涅槃。而一切处。示现受生。能作如是权实双行法是佛业。是为十。若诸菩萨。安住其中。则得不由他教无上无师广大业。佛子。菩萨摩诃萨。有十种慢业。何等为十。所谓于师僧父母。沙门婆罗门。住于正道。向正道者。尊重福田所。而不恭敬。是慢业。或有法师。获最胜法。乘于大乘。知出要道。得陀罗尼。演说契经广大之法。无有休息。而于其所。起高慢心。及于所说法。不生恭敬。是慢业。于众会中。闻说妙法。不肯叹美。令人信受。是慢业。好起过慢。自高陵物。不见己失。不知自短。是慢业。好起过过慢。见有德人。应赞不赞。见他赞叹。不生欢喜。是慢业。见有法师为人说法。知是法是律。是真实是佛语。为嫌其人。亦嫌其法。自起诽谤。亦令他谤。是慢业。自求高座。自称法师。应受供给。不应执事。见有耆旧久修行人。不起逢迎。不肯承事。是慢业。见有德人。颦蹙不喜。言辞粗犷。伺其过失。是慢业。见有聪慧知法之人。不肯亲近恭敬供养。不肯咨问。何等为善。何等不善。何等应作。何等不应作。作何等业。于长夜中。而得种种利益安乐。愚痴顽很。我慢所吞。终不能见出要之道。是慢业。复有众生。慢心所覆。诸佛出世不能亲近恭敬供养。新善不起。旧善消灭。不应说而说。不应诤而诤。未来必堕险难深坑。于百千劫。尚不值佛。何况闻法。但以曾发菩提心故。终自醒悟。是慢业。是为十。若诸菩萨。离此慢业。则得十种智业。何等为十。所谓信解业报。不坏因果。是智业。不舍菩提心。常念诸佛。是智业。近善知识。恭敬供养。其心尊重。终无厌怠。是智业。乐法乐义。无有厌足。远离邪念。勤修正念。是智业。于一切众生。离于我慢。于诸菩萨。起如来想。爱重正法。如惜己身。尊奉如来。如护己命。于修行者。生诸佛想。是智业。身语意业。无诸不善。赞美贤圣。随顺菩提。是智业。不坏缘起。离诸邪见。破闇得明。照一切法。是智业。十种回向。随顺修行。于诸波罗蜜。起慈母想。于善巧方便。起慈父想。以深净心。入菩提舍。是智业。施戒多闻。止观福慧。如是一切助道之法。常勤积集。无有厌倦。是智业。若有一业。为佛所赞。能破众魔烦恼斗诤。能离一切障盖缠缚。能教化调伏一切众生。能随顺智慧。摄取正法。能严净佛刹。能发起通明。皆勤修习。无有懈退。是智业。是为十。若诸菩萨。安住其中。则得如来一切善巧方便无上大智业。佛子。菩萨摩诃萨。有十种魔所摄持。何等为十。所谓懈怠心。魔所摄持。志乐狭劣。魔所摄持。于少行生足。魔所摄持。受一非余。魔所摄持。不发大愿。魔所摄持。乐处寂灭。断除烦恼。魔所摄持。永断生死。魔所摄持。舍菩萨行。魔所摄持。不化众生。魔所摄持。疑谤正法。魔所摄持。是为十。若诸菩萨。能弃舍此魔所摄持。则得十种佛所摄持。何等为十。所谓初始能发菩提之心。佛所摄持。于生生中。持菩提心。不令忘失。佛所摄持。觉诸魔事。悉能远离。佛所摄持。闻诸波罗蜜。如说修行。佛所摄持。知生死苦。而不厌恶。佛所摄持。观甚深法。得无量果。佛所摄持。为诸众生。说二乘法。而不证取彼乘解脱。佛所摄持。乐观无为法。而不住其中。于有为无为。不生二想。佛所摄持。至无生处。而现受生。佛所摄持。虽证得一切智。而起菩萨行。不断菩萨种。佛所摄持。是为十。若诸菩萨。安住其中。则得诸佛无上摄持力。佛子。菩萨摩诃萨。有十种法所摄持。何等为十。所谓知一切行无常。法所摄持。知一切行苦。法所摄持。知一切行无我。法所摄持。知一切法。寂灭涅槃。法所摄持。知诸法从缘起。无缘则不起。法所摄持。知不正思惟故。起于无明。无明起故。乃至老死起。不正思惟灭故。无明灭。无明灭故。乃至老死灭。法所摄持。知三解脱门出生声闻乘。证无诤法出生独觉乘。法所摄持。知六波罗蜜。四摄法。出生大乘。法所摄持。知一切刹。一切法。一切众生。一切世。是佛智境界。法所摄持。知断一切念。舍一切取。离前后际。随顺涅槃。法所摄持。是为十。若诸菩萨。安住其中。则得一切诸佛无上。法所摄持

佛子。菩萨摩诃萨。住兜率天。有十种所作业。何等为十。所谓为欲界诸天子。说厌离法言。一切自在。皆是无常。一切快乐。悉当衰谢。劝彼诸天。发菩提心。是为第一所作业。为色界诸天。说入出诸禅。解脱三昧。若于其中。而生爱着。因爱复起身见邪见无明等者。则为其说如实智慧。若于一切色非色法。起颠倒想。以为清净。为说不净皆是无常。劝其令发菩提之心。是为第二所作业。菩萨摩诃萨。住兜率天。入三昧。名光明庄严。身放光明。遍照三千大千世界。随众生心。以种种音。而为说法。众生闻已。信心清净。命终生于兜率天中。劝其令发菩提之心。是为第三所作业。菩萨摩诃萨。在兜率天。以无障碍眼。普见十方兜率天中。一切菩萨。彼诸菩萨。皆亦见此。互相见已。论说妙法。谓降神母胎。初生出家。往诣道场。具大庄严。而复示现往昔已来。所行之行。以彼行故。成此大智。所有功德。不离本处。而能示现如是等事。是为第四所作业。菩萨摩诃萨。住兜率天。十方一切兜率天宫。诸菩萨众。皆悉来集。恭敬围绕。尔时菩萨摩诃萨。欲令彼诸菩萨皆满其愿。生欢喜故。随彼菩萨。所应住地。所行所断。所修所证。演说法门。彼诸菩萨。闻说法已。皆大欢喜。得未曾有。各还本土所住宫殿。是为第五所作业。菩萨摩诃萨。住兜率天时。欲界主。天魔波旬。为欲坏乱菩萨业故。眷属围绕。诣菩萨所。尔时菩萨。为摧伏魔军故。住金刚道所摄般若波罗蜜方便善巧智慧门。以柔软粗犷二种语。而为说法。令魔波旬。不得其便。魔见菩萨自在威力。皆发阿耨多罗三藐三菩提心。是为第六所作业。菩萨摩诃萨。住兜率天。知欲界诸天子。不乐闻法。尔时菩萨。出大音声。遍告之言。今日菩萨。当于宫中。现希有事。若欲见者。宜速往诣。时诸天子。闻是语已。无量百千亿那由他。皆来集会。尔时菩萨。见诸天众皆来集已。为现宫中诸希有事。彼诸天子。曾未见闻。既得见已。皆大欢喜。其心醉没。又于乐中。出声告言。诸仁者。一切诸行。皆悉无常。一切诸行。皆悉是苦。一切诸法。皆悉无我。涅槃寂灭。又复告言。汝等皆应修菩萨行。皆当圆满一切智智。彼诸天子。闻此法音。忧叹咨嗟。而生厌离。靡不皆发菩提之心。是为第七所作业。菩萨摩诃萨。住兜率宫。不舍本处。悉能往诣十方无量一切佛所。见诸如来。亲近礼拜。恭敬听法。尔时诸佛。欲令菩萨。获得最上灌顶法故。为说菩萨地。名一切神通。以一念相应慧。具足一切最胜功德。入一切智智位。是为第八所作业。菩萨摩诃萨。住兜率宫。为欲供养诸如来故。以大神力。兴起种种诸供养具。名殊胜可乐。遍法界虚空界。一切世界。供养诸佛。彼世界中。无量众生。见此供养。皆发阿耨多罗三藐三菩提心。是为第九所作业。菩萨摩诃萨。住兜率天。出无量无边如幻如影法门。周遍十方一切世界。示现种种色。种种相。种种形体。种种威仪。种种事业。种种方便。种种譬谕。种种言说。随众生心。皆令欢喜。是为第十所作业。佛子。是为菩萨摩诃萨。住兜率天。十种所作业。若诸菩萨。成就此法。则能于后。下生人间。佛子。菩萨摩诃萨。于兜率天。将下生时。现十种事。何等为十。佛子。菩萨摩诃萨。于兜率天。下生之时。从于足下。放大光明。名安乐庄严。普照三千大千世界一切恶趣。诸难众生。触斯光者。莫不皆得离苦安乐。得安乐已。悉知将有奇特大人。出兴于世。是为第一所示现事。佛子。菩萨摩诃萨。于兜率天。下生之时。从于眉间白毫相中。放大光明。名曰觉悟。普照三千大千世界。照彼宿世一切同行。诸菩萨身。彼诸菩萨。蒙光照已。咸知菩萨将欲下生。各各出兴。无量供具。诣菩萨所。而为供养。是为第二所示现事。佛子。菩萨摩诃萨。于兜率天。将下生时。于右掌中。放大光明。名清净境界。悉能严净一切三千大千世界。其中若有已得无漏诸辟支佛。觉斯光者。即舍寿命。若不觉者。光明力故。徙置他方。余世界中。一切诸魔。及诸外道。有见众生。皆亦徙置他方世界。唯除诸佛神力所持应化众生。是为第三所示现事。佛子。菩萨摩诃萨。于兜率天。将下生时。从其两膝。放大光明。名清净庄严。普照一切诸天宫殿。下从护世。上至净居。靡不周遍。彼诸天等。咸知菩萨于兜率天。将欲下生。俱怀恋慕。悲叹忧恼。各持种种华鬘衣服。涂香末香。幡盖妓乐。诣菩萨所。恭敬供养。随逐下生。乃至涅槃。是为第四所示现事。佛子。菩萨摩诃萨。在兜率天。将下生时。于卍字金刚庄严心藏中。放大光明。名无能胜幢。普照十方一切世界金刚力士。时有百亿金刚力士。皆悉来集。随逐侍卫。始于下生。乃至涅槃。是为第五所示现事。佛子。菩萨摩诃萨。于兜率天。将下生时。从其身上。一切毛孔。放大光明。名分别众生。普照一切大千世界。遍触一切诸菩萨身。复触一切诸天世人。诸菩萨等。咸作是念。我应住此。供养如来。教化众生。是为第六所示现事。佛子。菩萨摩诃萨。于兜率天。将下生时。从大摩尼宝藏殿中。放大光明。名善住观察。照此菩萨当生之处。所托王宫。其光照已。诸余菩萨。皆共随逐。下阎浮提。若于其家。若其聚落。若其城邑。而现受生。为欲教化诸众生故。是为第七所示现事。佛子。菩萨摩诃萨。于兜率天。临下生时。从天宫殿。及大楼阁诸庄严中。放大光明。名一切宫殿清净庄严。照所生母腹。光明照已。令菩萨母。安隐快乐。具足成就一切功德。其母腹中。自然而有广大楼阁。大摩尼宝。而为庄严。为欲安处菩萨身故。是为第八所示现事。佛子。菩萨摩诃萨。于兜率天。临下生时。从两足下。放大光明。名为善住。若诸天子。及诸梵天。其命将终。蒙光照触。皆得住寿。供养菩萨。从初下生。乃至涅槃。是为第九所示现事。佛子。菩萨摩诃萨。于兜率天。临下生时。从随好中。放大光明。名曰眼庄严。示现菩萨种种诸业。时诸人天。或见菩萨。住兜率天。或见入胎。或见初生。或见出家。或见成道。或见降魔。或见转法轮。或见入涅槃。是为第十所示现事。佛子。菩萨摩诃萨。于身于座。于宫殿。于楼阁中。放如是等百万阿僧祇光明。悉现种种诸菩萨业。现是业已。具足一切功德法故。从兜率天。下生人间

大方广佛华严经卷第五十八大方广佛华严经卷第五十九

        于阗国三藏实叉难陀奉　制译

    离世间品第三十八之七

佛子。菩萨摩诃萨。示现处胎。有十种事。何等为十。佛子。菩萨摩诃萨。为欲成就小心劣解诸众生故。不欲令彼起如是念。今此菩萨。自然化生。智慧善根。不从修得。是故菩萨。示现处胎。是为第一事。菩萨摩诃萨。为成熟父母。及诸眷属。宿世同行。众生善根。示现处胎。何以故。彼皆应以见于处胎。成熟所有诸善根故。是为第二事。菩萨摩诃萨。入母胎时。正念正知。无有迷惑。住母胎已。心恒正念。亦无错乱。是为第三事。菩萨摩诃萨。在母胎中。常演说法。十方世界。诸大菩萨。释梵四王。皆来集会。悉令获得无量神力。无边智慧。菩萨处胎。成就如是。辩才胜用。是为第四事。菩萨摩诃萨。在母胎中。集大众会。以本愿力。教化一切诸菩萨众。是为第五事。菩萨摩诃萨。于人中成佛。应具人间最胜受生。以此示现处于母胎。是为第六事。菩萨摩诃萨。在母胎中。三千大千世界众生。悉见菩萨。如明镜中。见其面像。尔时大心。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆诣菩萨。恭敬供养。是为第七事。菩萨摩诃萨。在母胎中。他方世界。一切最后生菩萨。在母胎者。皆来共会。说大集法门。名广大智慧藏。是为第八事。菩萨摩诃萨。在母胎时。入离垢藏三昧。以三昧力。于母胎中。现大宫殿。种种严饰。悉皆妙好。兜率天宫。不可为比。而令母身。安隐无患。是为第九事。菩萨摩诃萨。住母胎时。以大威力。兴供养具。名开大福德离垢藏。普遍十方一切世界。供养一切诸佛如来。彼诸如来。咸为演说无边菩萨。住处法界藏。是为第十事。佛子。是为菩萨摩诃萨。示现处胎十种事。若诸菩萨了达此法则能示现甚微细趣。佛子。菩萨摩诃萨。有十种甚微细趣。何等为十。所谓在母胎中。示现初发菩提心。乃至灌顶地。在母胎中。示现住兜率天。在母胎中。示现初生。在母胎中。示现童子地。在母胎中。示现处王宫。在母胎中。示现出家。在母胎中。示现苦行。往诣道场。成等正觉。在母胎中。示现转法轮。在母胎中。示现般涅槃。在母胎中。示现大微细。谓一切菩萨行。一切如来。自在神力。无量差别门。佛子。是为菩萨摩诃萨。在母胎中。十种微细趣。若诸菩萨。安住此法。则得如来无上大智慧微细趣。佛子。菩萨摩诃萨。有十种生。何等为十。所谓远离愚痴正念正知生。放大光明网普照三千大千世界生。住最后有更不受后身生。不生不起生。知三界如幻生。于十方世界普现身生。证一切智智身生。放一切佛光明普觉悟一切众生身生。入大智观察三昧身生。佛子。菩萨生时。震动一切佛刹。解脱一切众生。除灭一切恶道。映蔽一切诸魔。无量菩萨。皆来集会。佛子。是为菩萨摩诃萨十种生。为调伏众生故。如是示现。佛子。菩萨摩诃萨。以十事故。示现微笑心自誓。何等为十。所谓菩萨摩诃萨念言。一切世间。殁在欲泥。除我一人。无能免济。如是知已。熙怡微笑心自誓。复念言。一切世间。烦恼所盲。唯我今者。具足智慧。如是知已。熙怡微笑心自誓。又念言。我今因此假名身故。当得如来充满三世无上法身。如是知已。熙怡微笑心自誓。菩萨尔时。以无障碍眼。遍观十方所有梵天。乃至一切大自在天。作是念言。此等众生。皆自谓为有大智力。如是知已。熙怡微笑心自誓。菩萨尔时。观诸众生。久种善根。今皆退没。如是知已。熙怡微笑心自誓。菩萨观见世间种子。所种虽少。获果甚多。如是知已。熙怡微笑心自誓。菩萨观见一切众生。蒙佛所教。必得利益。如是知已。熙怡微笑心自誓。菩萨观见过去世中。同行菩萨。染着余事。不得佛法广大功德。如是知已。熙怡微笑心自誓。菩萨观见过去世中。同共集会。诸天人等。至今犹在凡夫之地。不能舍离。亦不疲厌。如是知已。熙怡微笑心自誓。菩萨尔时。为一切如来光明所触。倍加欣慰。熙怡微笑心自誓。是为十。佛子。菩萨为调伏众生故。如是示现。佛子。菩萨摩诃萨。以十事故。示行七步。何等为十。所谓现菩萨力故。示行七步。现施七财故。示行七步。满地神愿故。示行七步。现超三界相故。示行七步。现菩萨最胜行。超过象王牛王。师子王行故。示行七步。现金刚地相故。示行七步。现欲与众生勇猛力故。示行七步。现修行七觉宝故。示行七步。现所得法。不由他教故。示行七步。现于世间。最胜无比故。示行七步。是为十。佛子。菩萨为调伏众生故。如是示现。佛子。菩萨摩诃萨。以十事故。现处童子地。何等为十。所谓为现通达一切世间文字算计图书印玺种种业故。处童子地。为现通达一切世间象马车乘弧矢剑戟种种业故。处童子地。为现通达一切世间文笔谈论博弈嬉戏种种事故。处童子地。为现远离身语意业诸过失故。处童子地。为现入定住涅槃门周遍十方无量世界故。处童子地。为现其力超过一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世人非人等故。处童子地。为现菩萨色相威光超过一切释梵护世故。处童子地。为令耽着欲乐众生欢喜乐法故。处童子地。为尊重正法勤供养佛周遍十方一切世界故。处童子地。为现得佛加被蒙法光明故。处童子地。是为十。佛子。菩萨摩诃萨。现童子地已。以十事故。现处王宫。何等为十。所谓为令宿世同行众生。善根成熟故。现处王宫。为显示菩萨善根力故。现处王宫。为诸人天耽着乐具。示现菩萨大威德乐具故。现处王宫。顺五浊世众生心故。现处王宫。为现菩萨大威德力。能于深宫入三昧故。现处王宫。为令宿世同愿众生满其意故。现处王宫。欲令父母亲戚眷属满所愿故。现处王宫。欲以妓乐出妙法音供养一切诸如来故。现处王宫。欲于宫内住微妙三昧始从成佛乃至涅槃皆示现故。现处王宫。为随顺守护诸佛法故。现处王宫。是为十。最后身菩萨。如是示现处王宫已。然后出家。佛子。菩萨摩诃萨。以十事故。示现出家。何等为十。所谓为厌居家故。示现出家。为着家众生令舍离故。示现出家。为随顺信乐圣人道故。示现出家。为宣扬赞叹出家功德故。示现出家。为显永离二边见故。示现出家。为令众生。离欲乐我乐故。示现出家。为先现出三界相故。示现出家。为现自在不属他故。示现出家。为显当得如来十力无畏法故。示现出家。最后菩萨。法应尔故。示现出家。是为十。菩萨以此调伏众生。佛子。菩萨摩诃萨。为十种事故。示行苦行。何等为十。所谓为成就劣解众生故。示行苦行。为拔邪见众生故。示行苦行。为不信业报众生。令见业报故。示行苦行。为随顺杂染世界法应尔故。示行苦行。示能忍劬劳。勤修道故。示行苦行。为令众生。乐求法故。示行苦行。为着欲乐我乐众生故。示行苦行。为显菩萨起行殊胜。乃至最后生。犹不舍勤精进故。示行苦行。为诸天世人。诸根未熟。待时成熟故。示行苦行。是为十。菩萨以此方便。调伏一切众生。佛子。菩萨摩诃萨。往诣道场。有十种事。何等为十。所谓诣道场时。照耀一切世界。诣道场时。震动一切世界。诣道场时。于一切世界。普现其身。诣道场时。觉悟一切菩萨。及一切宿世。同行众生。诣道场时。示现道场一切庄严。诣道场时。随诸众生心之所欲。而为现身。种种威仪。及菩提树一切庄严。诣道场时。现见十方一切如来。诣道场时。举足下足。常入三昧。念念成佛。无有超隔。诣道场时。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世一切诸王各不相知。而兴种种。上妙供养。诣道场时以无碍智。普观一切诸佛如来。于一切世界修菩萨行。而成正觉。是为十。菩萨以此。教化众生。佛子。菩萨摩诃萨。坐道场。有十种事。何等为十。所谓坐道场时。种种震动一切世界。坐道场时。平等照耀一切世界。坐道场时。除灭一切诸恶趣苦。坐道场时。令一切世界金刚所成。坐道场时。普观一切诸佛如来。师子之座。坐道场时。心如虚空。无所分别。坐道场时。随其所应。现身威仪。坐道场时。随顺安住金刚三昧。坐道场时。受一切如来神力所持。清净妙处。坐道场时。自善根力。悉能加被一切众生。是为十。佛子。菩萨摩诃萨。坐道场时。有十种奇特未曾有事。何等为十。佛子。菩萨摩诃萨。坐道场时。十方世界。一切如来。皆现其前。咸举右手。而称赞言。善哉善哉。无上导师。是为第一未曾有事。菩萨摩诃萨。坐道场时。一切如来。皆悉护念。与其威力。是为第二未曾有事。菩萨摩诃萨。坐道场时。宿世同行。诸菩萨众。悉来围绕。以种种庄严具。恭敬供养。是为第三未曾有事。菩萨摩诃萨。坐道场时。一切世界。草木丛林。诸无情物。皆曲身低影。归向道场。是为第四未曾有事。菩萨摩诃萨。坐道场时。入三昧。名观察法界。此三昧力。能令菩萨一切诸行。悉得圆满。是为第五未曾有事。菩萨摩诃萨。坐道场时。得陀罗尼。名最上离垢妙光海藏。能受一切诸佛如来大云法雨。是为第六未曾有事。菩萨摩诃萨。坐道场时。以威德力。兴上妙供具。遍一切世界。供养诸佛。是为第七未曾有事。菩萨摩诃萨。坐道场时。住最胜智。悉现了知一切众生。诸根意行。是为第八未曾有事。菩萨摩诃萨。坐道场时。入三昧。名善觉。此三昧力。能令其身。充满三世尽虚空界一切世界。是为第九未曾有事。菩萨摩诃萨。坐道场时。得离垢光明无碍大智。令其身业。普入三世。是为第十未曾有事。佛子。是为菩萨摩诃萨。坐道场时。十种奇特未曾有事。佛子。菩萨摩诃萨。坐道场时。观十种义故。示现降魔。何等为十。所谓为浊世众生。乐于斗战。欲显菩萨威德力故。示现降魔。为诸天世人。有怀疑者。断彼疑故。示现降魔。为教化调伏诸魔军故。示现降魔。为欲令诸天世人。乐军阵者。咸来聚观。心调伏故。示现降魔。为显示菩萨所有威力。世无能敌故。示现降魔。为欲发起一切众生勇猛力故。示现降魔。为哀愍末世诸众生故。示现降魔。为欲显示乃至道场。犹有魔军。而来触恼。此后乃得超魔境界故。示现降魔。为显烦恼业用羸劣。大慈善根势力强盛故。示现降魔。为欲随顺浊恶世界所行法故。示现降魔。是为十。佛子。菩萨摩诃萨。有十种成如来力。何等为十。所谓超过一切众魔烦恼业故。成如来力。具足一切菩萨行。游戏一切菩萨三昧门故。成如来力。具足一切菩萨广大禅定故。成如来力。圆满一切白净助道法故。成如来力。得一切法智慧光明。善思惟分别故。成如来力。其身周遍一切世界故。成如来力。所出言音。悉与一切众生心等故。成如来力。能以神力加持一切故。成如来力。与三世诸佛身语意业。等无有异。于一念中。了三世法故。成如来力。得善觉智三昧。具如来十力。所谓是处非处智力。乃至漏尽智力故。成如来力。是为十。若诸菩萨。具此十力。则名如来应正等觉。佛子。如来应正等觉。转大法轮。有十种事。何等为十。一者具足清净四无畏智。二者出生四辩随顺音声。三者善能开阐四真谛相。四者随顺诸佛无碍解脱。五者能令众生心皆净信。六者所有言说皆不唐捐。能拔众生诸苦毒箭。七者大悲愿力之所加持。八者随出音声普遍。十方一切世界。九者于阿僧祇劫。说法不断。十者随所说法。皆能生起根力觉道禅定解脱三昧等法。佛子。诸佛如来。转于法轮。有如是等无量种事。佛子。如来应正等觉。转法轮时。以十事故。于众生心中。种白净法。无空过者。何等为十。所谓过去愿力故。大悲所持故。不舍众生故。智慧自在随其所乐为说法故。必应其时未曾失故。随其所宜无妄说故。知三世智善了知故。其身最胜无与等故。言辞自在无能测故。智慧自在随所发言悉开悟故。是为十。佛子。如来应正等觉。作佛事已。观十种义故。示般涅槃。何等为十。所谓示一切行实无常故。示一切有为非安隐故。示大涅槃是安隐处无怖畏故。以诸人天。乐着色身。为现色身。是无常法。令其愿住净法身故。示无常力不可转故。示一切有为。不随心住。不自在故。示一切三有。皆如幻化。不坚牢故。示涅槃性。究竟坚牢。不可坏故。示一切法。无生无起。而有聚集散坏相故。佛子。诸佛世尊。作佛事已。所愿满已。转法轮已。应化度者。皆化度已。有诸菩萨。应受尊号。成记别已。法应如是入于不变大般涅槃。佛子。是为如来应正等觉。观十义故。示般涅槃

佛子。此法门名菩萨广大清净行。无量诸佛。所共宣说。能令智者。了无量义。皆生欢喜。令一切菩萨。大愿大行。皆得相续。佛子。若有众生。得闻此法。闻已信解。解已修行。必得疾成阿耨多罗三藐三菩提。何以故。以如说修行故。佛子。若诸菩萨。不如说行。当知是人。于佛菩提。则为永离。是故菩萨。应如说行。佛子。此一切菩萨功德行处决定义华普入一切法。普生一切智。超诸世间。离二乘道。不与一切诸众生共。悉能照了一切法门。增长众生出世善根。离世间法门品。应尊重。应听受。应诵持。应思惟。应愿乐。应修行。若能如是。当知是人。疾得阿耨多罗三藐三菩提。说此品时。佛神力故。及此法门。法如是故。十方无量无边阿僧祇世界。皆大震动。大光普照。尔时十方诸佛。皆现普贤菩萨前。赞言。善哉善哉。佛子。乃能说此诸菩萨摩诃萨。功德行处决定义华普入一切佛法出世间法门品。佛子。汝已善学此法。善说此法。汝以威力。护持此法。我等诸佛。悉皆随喜。如我等诸佛随喜于汝。一切诸佛。悉亦如是。佛子。我等诸佛。悉共同心。护持此经。令现在未来诸菩萨众。未曾闻者。皆当得闻。尔时普贤菩萨摩诃萨。承佛神力。观察十方一切大众。洎于法界。而说颂言

  于无量劫修苦行　　从无量佛正法生
  令无量众住菩提　　彼无等行听我说
  供无量佛而舍着　　广度群生不作想
  求佛功德心无依　　彼胜妙行我今说
  离三界魔烦恼业　　具圣功德最胜行
  灭诸痴惑心寂然　　我今说彼所行道
  永离世间诸诳幻　　种种变化示众生
  心生住灭现众事　　说彼所能令众喜
  见诸众生生老死　　烦恼忧横所缠迫
  欲令解脱教发心　　彼功德行应听受
  施戒忍进禅智慧　　方便慈悲喜舍等
  百千万劫常修行　　彼人功德仁应听
  千万亿劫求菩提　　所有身命皆无吝
  愿益群生不为己　　彼慈愍行我今说
  无量亿劫演其德　　如海一滴未为少
  功德无比不可谕　　以佛威神今略说
  其心无高下　　求道无厌倦
  普使诸众生　　住善增净法
  智慧普饶益　　如树如河泉
  亦如于大地　　一切所依处
  菩萨如莲华　　慈根安隐茎
  智慧为众蕊　　戒品为香洁
  佛放法光明　　令彼得开敷
  不著有为水　　见者皆欣乐
  菩萨妙法树　　生于直心地
  信种慈悲根　　智慧以为身
  方便为枝干　　五度为繁密
  定叶神通华　　一切智为果
  最上力为鸟　　垂阴覆三界
  菩萨师子王　　白净法为身
  四谛为其足　　正念以为颈
  慈眼智慧首　　顶系解脱缯
  胜义空谷中　　吼法怖众魔
  菩萨为商主　　普见诸群生
  在生死旷野　　烦恼险恶处
  魔贼之所摄　　痴盲失正道
  示其正直路　　令入无畏城
  菩萨见众生　　三毒烦恼病
  种种诸苦恼　　长夜所煎迫
  为发大悲心　　广说对治门
  八万四千种　　灭除众苦患
  菩萨为法王　　正道化众生
  令远恶修善　　专求佛功德
  一切诸佛所　　灌顶授尊记
  广施众圣财　　菩提分珍宝
  菩萨转法轮　　如佛之所转
  戒毂三昧辋　　智庄慧为剑
  既破烦恼贼　　亦殄众魔怨
  一切诸外道　　见之无不散
  菩萨智慧海　　深广无涯际
  正法味盈洽　　觉分宝充满
  大心无边岸　　一切智为潮
  众生莫能测　　说之不可尽
  菩萨须弥山　　超出于世间
  神通三昧峰　　大心安不动
  若有亲近者　　同其智慧色
  迥绝众境界　　一切无不睹
  菩萨如金刚　　志求一切智
  信心及苦行　　坚固不可动
  其心无所畏　　饶益诸群生
  众魔与烦恼　　一切悉摧灭
  菩萨大慈悲　　譬如重密云
  三明发电光　　神足震雷音
  普以四辩才　　雨八功德水
  润洽于一切　　令除烦恼热
  菩萨正法城　　般若以为墙
  惭愧为深堑　　智慧为却敌
  广开解脱门　　正念恒防守
  四谛坦王道　　六通集兵仗
  复建大法幢　　周回遍其下
  三有诸魔众　　一切无能入
  菩萨迦楼罗　　如意为坚足
  方便勇猛翅　　慈悲明净眼
  住一切智树　　观三有大海
  搏撮天人龙　　安置涅槃岸
  菩萨正法日　　出现于世间
  戒品圆满轮　　神足速疾行
  照以智慧光　　长诸根力药
  灭除烦恼闇　　消竭爱欲海
  菩萨智光月　　法界以为轮
  游于毕竟空　　世间无不见
  三界识心内　　随时有增减
  二乘星宿中　　一切无俦匹
  菩萨大法王　　功德庄严身
  相好皆具足　　人天悉瞻仰
  方便清净目　　智慧金刚杵
  于法得自在　　以道化群生
  菩萨大梵王　　自在超三有
  业惑悉皆断　　慈舍靡不具
  处处示现身　　开悟以法音
  于彼三界中　　拔诸邪见根
  菩萨自在天　　超过生死地
  境界常清净　　智慧无退转
  绝彼下乘道　　受诸灌顶法
  功德智慧具　　名称靡不闻
  菩萨智慧心　　清净如虚空
  无性无依处　　一切不可得
  有大自在力　　能成世间事
  自具清净行　　令众生亦然
  菩萨方便地　　饶益诸众生
  菩萨慈悲水　　浣涤诸烦恼
  菩萨智慧火　　烧诸惑习薪
  菩萨无住风　　游行三有空
  菩萨如珍宝　　能济贫穷厄
  菩萨如金刚　　能摧颠倒见
  菩萨如璎珞　　庄严三有身
  菩萨如摩尼　　增长一切行
  菩萨德如华　　常发菩提分
  菩萨愿如鬘　　恒系众生首
  菩萨净戒香　　坚持无缺犯
  菩萨智涂香　　普熏于三界
  菩萨力如帐　　能遮烦恼尘
  菩萨智如幢　　能摧我慢敌
  妙行为缯彩　　庄严于智慧
  惭愧作衣服　　普覆诸群生
  菩萨无碍乘　　巾之出三界
  菩萨大力象　　其心善调伏
  菩萨神足马　　腾步超诸有
  菩萨说法龙　　普雨众生心
  菩萨优昙华　　世间难值遇
  菩萨大勇将　　众魔悉降伏
  菩萨转法轮　　如佛之所转
  菩萨灯破闇　　众生见正道
  菩萨功德河　　恒顺正道流
  菩萨精进桥　　广度诸群品
  大智与弘誓　　共作坚牢船
  引接诸众生　　安置菩提岸
  菩萨游戏园　　真实乐众生
  菩萨解脱华　　庄严智宫殿
  菩萨如妙药　　灭除烦恼病
  菩萨如雪山　　出生智慧药
  菩萨等于佛　　觉悟诸群生
  佛心岂有他　　正觉觉世间
  如佛之所来　　菩萨如是来
  亦如一切智　　以智入普门
  菩萨善开导　　一切诸群生
  菩萨自然觉　　一切智境界
  菩萨无量力　　世间莫能坏
  菩萨无畏智　　知众生及法
  一切诸世间　　色相各差别
  音声及名字　　悉能分别知
  虽离于名色　　而现种种相
  一切诸众生　　莫能测其道
  如是等功德　　菩萨悉成就
  了性皆无性　　有无无所著
  如是一切智　　无尽无所依
  我今当演说　　令众生欢喜
  虽知诸法相　　如幻悉空寂
  而以悲愿心　　及佛威神力
  现神通变化　　种种无量事
  如是诸功德　　汝等应听受
  一身能示现　　无量差别身
  无心无境界　　普应一切众
  一音中具演　　一切诸言音
  众生语言法　　随类皆能作
  永离烦恼身　　而现自在身
  知法不可说　　而作种种说
  其心常寂灭　　清净如虚空
  而普庄严刹　　示现一切众
  于身无所著　　而能示现身
  一切世间中　　随应而受生
  虽生一切处　　亦不住受生
  知身如虚空　　种种随心现
  菩萨身无边　　普现一切处
  常恭敬供养　　最胜两足尊
  香华众妓乐　　幢幡及宝盖
  恒以深净心　　供养于诸佛
  不离一佛会　　普在诸佛所
  于彼大众中　　问难听受法
  闻法入三昧　　一一无量门
  起定亦复然　　示现无穷尽
  智慧巧方便　　了世皆如幻
  而能现世间　　无边诸幻法
  示现种种色　　亦现心及语
  入诸想网中　　而恒无所著
  或现初发心　　利益于世间
  或现久修行　　广大无边际
  施戒忍精进　　禅定及智慧
  四梵四摄等　　一切最胜法
  或现行成满　　得忍无分别
  或现一生系　　诸佛与灌顶
  或现声闻相　　或复现缘觉
  处处般涅槃　　不舍菩提行
  或现为帝释　　或现为梵王
  或天女围绕　　或时独宴默
  或现为比丘　　寂静调其心
  或现自在王　　统理世间法
  或现巧术女　　或现修苦行
  或现受五欲　　或现入诸禅
  或现初始生　　或少或老死
  若有思议者　　心疑发狂乱
  或现在天宫　　或现始降神
  或入或住胎　　或佛转法轮
  或生或涅槃　　或现入学堂
  或在采女中　　或离俗修禅
  或坐菩提树　　自然成正觉
  或现转法轮　　或现始求道
  或现为佛身　　宴坐无量刹
  或修不退道　　积集菩提具
  深入无数劫　　皆悉到彼岸
  无量劫一念　　一念无量劫
  一切劫非劫　　为世示现劫
  无来无积集　　成就诸劫事
  于一微尘中　　普见一切佛
  十方一切处　　无处而不有
  国土众生法　　次第悉皆见
  经无量劫数　　究竟不可尽
  菩萨知众生　　广大无有边
  彼一众生身　　无量因缘起
  如知一无量　　一切悉亦然
  随其所通达　　教诸未学者
  悉知众生根　　上中下不同
  亦知根转移　　应化不应化
  一根一切根　　展转因缘力
  微细各差别　　次第无错乱
  又知其欲解　　一切烦恼习
  亦知去来今　　所有诸心行
  了达一切行　　无来亦无去
  既知其行已　　为说无上法
  杂染清净行　　种种悉了知
  一念得菩提　　成就一切智
  住佛不思议　　究竟智慧心
  一念悉能知　　一切众生行
  菩萨神通智　　功力已自在
  能于一念中　　往诣无边刹
  如是速疾往　　尽于无数劫
  无处而不周　　莫动毫端分
  譬如工幻师　　示现种种色
  于彼幻中求　　无色无非色
  菩萨亦如是　　以方便智幻
  种种皆示现　　充满于世间
  譬如净日月　　皎镜在虚空
  影现于众水　　不为水所杂
  菩萨净法轮　　当知亦如是
  现世间心水　　不为世所杂
  如人睡梦中　　造作种种事
  虽经亿千岁　　一夜未终尽
  菩萨住法性　　示现一切事
  无量劫可极　　一念智无尽
  譬如山谷中　　及以宫殿间
  种种皆响应　　而实无分别
  菩萨住法性　　能以自在智
  广出随类音　　亦复无分别
  如有见阳焰　　想之以为水
  驰逐不得饮　　展转更增渴
  众生烦恼心　　应知亦如是
  菩萨起慈愍　　救之令出离
  观色如聚沫　　受如水上泡
  想如热时焰　　诸行如芭蕉
  心识犹如幻　　示现种种事
  如是知诸蕴　　智者无所著
  诸处悉空寂　　如机关动转
  诸界性永离　　妄现于世间
  菩萨住真实　　寂灭第一义
  种种广宣畅　　而心无所依
  无来亦无去　　亦复无有住
  烦恼业苦因　　三种恒流转
  缘起非有无　　非实亦非虚
  如是入中道　　说之无所著
  能于一念中　　普现三世心
  欲色无色界　　一切种种事
  随顺三律仪　　演说三解脱
  建立三乘道　　成就一切智
  了达处非处　　诸业及诸根
  界解与禅定　　一切至处道
  宿命念天眼　　灭除一切惑
  知佛十种力　　而未能成就
  了达诸法空　　而常求妙法
  不与烦恼合　　而亦不尽漏
  广知出离道　　而以度众生
  于此得无畏　　不舍修诸行
  无谬无违道　　亦不失正念
  精进欲三昧　　观慧无损减
  三聚皆清净　　三世悉明达
  大慈愍众生　　一切无障碍
  由入此法门　　得成如是行
  我说其少分　　功德庄严义
  穷于无数劫　　说彼行无尽
  我今说少分　　如大地一尘
  依于佛智住　　起于奇特想
  修行最胜行　　具足大慈悲
  精勤自安隐　　教化诸含识
  安住净戒中　　具诸授记行
  能入佛功德　　众生行及刹
  劫世悉亦知　　无有疲厌想
  差别智总持　　通达真实义
  思惟说无比　　寂静等正觉
  发于普贤心　　及修其行愿
  慈悲因缘力　　趣道意清净
  修行波罗蜜　　究竟随觉智
  证知力自在　　成无上菩提
  成就平等智　　演说最胜法
  能持具妙辩　　逮得法王处
  远离于诸着　　演说心平等
  出生于智慧　　变化得菩提
  住持一切劫　　智者大欣慰
  深入及依止　　无畏无疑惑
  了达不思议　　巧密善分别
  善入诸三昧　　普见智境界
  究竟诸解脱　　游戏诸通明
  缠缚悉永离　　园林恣游处
  白法为宫殿　　诸行可欣乐
  现无量庄严　　于世心无动
  深心善观察　　妙辩能开演
  清净菩提印　　智光照一切
  所住无等比　　其心不下劣
  立志如大山　　种德若深海
  如宝安住法　　被甲誓愿心
  发起于大事　　究竟无能坏
  得授菩提记　　安住广大心
  秘藏无穷尽　　觉悟一切法
  世智皆自在　　妙用无障碍
  众生一切刹　　及以种种法
  身愿与境界　　智慧神通等
  示现于世间　　无量百千亿
  游戏及境界　　自在无能制
  力无畏不共　　一切业庄严
  诸身及身业　　语及净修语
  以得守护故　　成辨十种事
  菩萨心初发　　及以心周遍
  诸根无散动　　获得最胜根
  深心增胜心　　远离于谄诳
  种种决定解　　普入于世间
  舍彼烦恼习　　取兹最胜道
  巧修使圆满　　逮成一切智
  离退入正位　　决定证寂灭
  出生佛法道　　成就功德号
  道及无量道　　乃至庄严道
  次第善安住　　悉皆无所著
  手足及腹藏　　金刚以为心
  被以慈哀甲　　具足众器仗
  智首明达眼　　菩提行为耳
  清净戒为鼻　　灭闇无障碍
  辩才以为舌　　无处不至身
  最胜智为心　　行住修诸业
  道场师子坐　　梵卧空为住
  所行及观察　　普照如来境
  遍观众生行　　奋迅及哮吼
  离贪行净施　　舍慢持净戒
  不嗔常忍辱　　不懈恒精进
  禅定得自在　　智慧无所行
  慈济悲无倦　　喜法舍烦恼
  于诸境界中　　知义亦知法
  福德悉成满　　智慧如利剑
  普照乐多闻　　明了趣向法
  知魔及魔道　　誓愿咸舍离
  见佛与佛业　　发心皆摄取
  离慢修智慧　　不为魔力持
  为佛所摄持　　亦为法所持
  现住兜率天　　又现彼命终
  示现住母胎　　亦现微细趣
  现生及微笑　　亦现行七步
  示修众技术　　亦示处深宫
  出家修苦行　　往诣于道场
  端坐放光明　　觉悟诸群生
  降魔成正觉　　转无上法轮
  所现悉已终　　入于大涅槃
  彼诸菩萨行　　无量劫修习
  广大无有边　　我今说少分
  虽令无量众　　安住佛功德
  众生及法中　　毕竟无所取
  具足如是行　　游戏诸神通
  毛端置众刹　　经于亿千劫
  掌持无量刹　　遍往身无倦
  还来置本处　　众生不知觉
  菩萨以一切　　种种庄严刹
  置于一毛孔　　真实悉令见
  复以一毛孔　　普纳一切海
  大海无增减　　众生不娆害
  无量铁围山　　手执碎为尘
  一尘下一刹　　尽此诸尘数
  以此诸尘刹　　复更末为尘
  如是尘可知　　菩萨智难量
  于一毛孔中　　放无量光明
  日月星宿光　　摩尼珠火光
  及以诸天光　　一切皆映蔽
  灭诸恶道苦　　为说无上法
  一切诸世间　　种种差别音
  菩萨以一音　　一切皆能演
  决定分别说　　一切诸佛法
  普使诸群生　　闻之大欢喜
  过去一切劫　　安置未来今
  未来现在劫　　迥置过去世
  示现无量刹　　烧然及成住
  一切诸世间　　悉在一毛孔
  未来及现在　　一切十方佛
  靡不于身中　　分明而显现
  深知变化法　　善应众生心
  示现种种身　　而皆无所著
  或现于六趣　　一切众生身
  梵释护世身　　诸天人众身
  声闻缘觉身　　诸佛如来身
  或现菩萨身　　修行一切智
  善入软中上　　众生诸想网
  示现成菩提　　及以诸佛刹
  了知诸想网　　于想得自在
  示修菩萨行　　一切方便事
  示现如是等　　广大诸神变
  如是诸境界　　举世莫能知
  虽现无所现　　究竟转增上
  随顺众生心　　令行真实道
  身语及与心　　平等如虚空
  净戒为涂香　　众行为衣服
  法缯严净髻　　一切智摩尼
  功德靡不周　　灌顶升王位
  波罗蜜为轮　　诸通以为象
  神足以为马　　智慧为明珠
  妙行为采女　　四摄主藏臣
  方便为主兵　　菩萨转轮王
  三昧为城廓　　空寂为宫殿
  慈甲智慧剑　　念弓明利箭
  高张神力盖　　迥建智慧幢
  忍力不动摇　　直破魔王军
  总持为平地　　众行为河水
  净智为涌泉　　妙慧作树林
  空为澄净池　　觉分菡萏华
  神力自庄严　　三昧常娱乐
  思惟为采女　　甘露为美食
  解脱味为浆　　游戏于三乘
  此诸菩萨行　　微妙转增上
  无量劫修行　　其心不厌足
  供养一切佛　　严净一切刹
  普令一切众　　安住一切智
  一切刹微尘　　悉可知其数
  一切虚空界　　一沙可度量
  一切众生心　　念念可数知
  佛子诸功德　　说之不可尽
  欲具此功德　　及诸上妙法
  欲使诸众生　　离苦常安乐
  欲令身语意　　悉与诸佛等
  应发金刚心　　学此功德行

大方广佛华严经卷第五十九大方广佛华严经卷第六十

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之一

尔时世尊。在室罗筏国逝多林给孤独园大庄严重阁。与菩萨摩诃萨。五百人俱。普贤菩萨。文殊师利菩萨。而为上首。其名曰光焰幢菩萨。须弥幢菩萨。宝幢菩萨。无碍幢菩萨。华幢菩萨。离垢幢菩萨。日幢菩萨。妙幢菩萨。离尘幢菩萨。普光幢菩萨。地威力菩萨。宝威力菩萨。大威力菩萨。金刚智威力菩萨。离尘垢威力菩萨。正法日威力菩萨。功德山威力菩萨。智光影威力菩萨。普吉祥威力菩萨。地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。净德藏菩萨。法印藏菩萨。光明藏菩萨。脐藏菩萨。莲华德藏菩萨。善眼菩萨。净眼菩萨。离垢眼菩萨。无碍眼菩萨。普见眼菩萨。善观眼菩萨。青莲华眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。喜眼菩萨。普眼菩萨。天冠菩萨。普照法界智慧冠菩萨。道场冠菩萨。普照十方冠菩萨。一切佛藏冠菩萨。超出一切世间冠菩萨。普照冠菩萨。不可坏冠菩萨。持一切如来师子座冠菩萨。普照法界虚空冠菩萨。梵王髻菩萨。龙王髻菩萨。一切化佛光明髻菩萨。一切道场髻菩萨。一切愿海音宝王髻菩萨。一切佛光明摩尼髻菩萨。示现一切虚空平等相摩尼王庄严髻菩萨。示现一切如来神变摩尼王幢网垂覆髻菩萨。出一切佛转法轮音髻菩萨。说三世一切名字音髻菩萨。大光菩萨。离垢光菩萨。宝光菩萨。离尘光菩萨。焰光菩萨。法光菩萨。寂静光菩萨。日光菩萨。自在光菩萨。天光菩萨。福德幢菩萨。智慧幢菩萨。法幢菩萨。神通幢菩萨。光幢菩萨。华幢菩萨。摩尼幢菩萨。菩提幢菩萨。梵幢菩萨。普光幢菩萨。梵音菩萨。海音菩萨。大地音菩萨。世主音菩萨。山相击音菩萨。遍一切法界音菩萨。震一切法海雷音菩萨。降魔音菩萨。大慈方便云雷音菩萨。息一切世间苦安慰音菩萨。法上菩萨。胜上菩萨。智上菩萨。福德须弥上菩萨。功德珊瑚上菩萨。名称上菩萨。普光上菩萨。大慈上菩萨。智海上菩萨。佛种上菩萨。光胜菩萨。德胜菩萨。上胜菩萨。普明胜菩萨。法胜菩萨。月胜菩萨。虚空胜菩萨。宝胜菩萨。幢胜菩萨。智胜菩萨。娑罗自在王菩萨。法自在王菩萨。象自在王菩萨。梵自在王菩萨。山自在王菩萨。众自在王菩萨。速疾自在王菩萨。寂静自在王菩萨。不动自在王菩萨。势力自在王菩萨。最胜自在王菩萨。寂静音菩萨。无碍音菩萨。地震音菩萨。海震音菩萨。云音菩萨。法光音菩萨。虚空音菩萨。说一切众生善根音菩萨。示一切大愿音菩萨。道场音菩萨。须弥光觉菩萨。虚空觉菩萨。离染觉菩萨。无碍觉菩萨。善觉菩萨。普照三世觉菩萨。广大觉菩萨。普明觉菩萨。法界光明觉菩萨。如是等菩萨摩诃萨五百人俱。此诸菩萨。皆悉成就普贤行愿。境界无碍。普遍一切诸佛刹故。现身无量。亲近一切诸如来故。净眼无障。见一切佛神变事故。至处无限。一切如来成正觉所。恒普诣故。光明无际。以智慧光。普照一切实法海故。说法无尽。清净辩才。无边际劫。无穷尽故。等虚空界。智慧所行。悉清净故。无所依止。随众生心。现色身故。除灭痴翳。了众生界。无众生故。等虚空智。以大光网。照法界故。及与五百声闻众俱。悉觉真谛。皆证实际。深入法性。永出有海。依佛功德。离结使缚。住无碍处。其心寂静。犹如虚空。于诸佛所。永断疑惑。于佛智海。深信趣入。及与无量诸世主俱。悉曾供养无量诸佛。常能利益一切众生。为不请友。恒勤守护。誓愿不舍。入于世间殊胜智门。从佛教生。护佛正法。起于大愿。不断佛种。生如来家。求一切智

时诸菩萨大德声闻。世间诸王。并其眷属。咸作是念。如来境界。如来智行。如来加持。如来力。如来无畏。如来三昧。如来所住。如来自在。如来身。如来智。一切世间。诸天及人。无能通达。无能趣入。无能信解。无能了知。无能忍受。无能观察。无能拣择。无能开示。无能宣明。无有能令众生解了。唯除诸佛加被之力。佛神通力。佛威德力。佛本愿力。及其宿世善根之力。诸善知识。摄受之力。深净信力。大明解力。趣向菩提。清净心力。求一切智。广大愿力。唯愿世尊。随顺我等及诸众生。种种欲。种种解。种种智。种种语。种种自在。种种住地。种种根清净。种种意方便。种种心境界。种种依止如来功德。种种听受诸所说法。显示如来往昔趣求一切智心。往昔所起菩萨大愿往昔所净诸波罗蜜。往昔所入菩萨诸地。往昔圆满诸菩萨行。往昔成就方便。往昔修行诸道。往昔所得出离法。往昔所作神通事。往昔所有。本事因缘。及成等正觉。转妙法轮。净佛国土。调伏众生。开一切智法城。示一切众生道。入一切众生所住。受一切众生所施。为一切众生。说布施功德。为一切众生。现诸佛影像。如是等法。愿皆为说

尔时世尊。知诸菩萨心之所念。大悲为身。大悲为门。大悲为首。以大悲法。而为方便。充遍虚空。入师子频申三昧。入此三昧已。一切世间。普皆严净。于时此大庄严楼阁。忽然广博。无有边际。金刚为地。宝王覆上。无量宝华。及诸摩尼。普散其中。处处盈满。琉璃为柱。众宝合成。大光摩尼之所庄严。阎浮檀金如意宝王。周置其上。以为严饰。危楼迥带。阁道傍出。栋宇相承窗闼交映。阶墀轩槛。种种备足。一切皆以妙宝庄严。其宝悉作人天形像。坚固妙好。世中第一。摩尼宝网。弥覆其上。于诸门侧。悉建幢幡。咸放光明。普周法界道场之外。阶蹬栏楯。其数无量不可称说。靡不咸以摩尼所成。尔时复以佛神力故。其逝多林。忽然广博。与不可说佛刹微尘数诸佛国土。其量正等。一切妙宝。间错庄严。不可说宝。遍布其地。阿僧祇宝。以为垣墙。宝多罗树。庄严道侧。其间复有无量香河。香水盈满。湍激洄澓。一切宝华。随流右转。自然演出佛法音声。不思议宝。芬陀利华。菡萏芬敷。弥布水上。众宝华树。列植其岸。种种台榭。不可思议。皆于岸上。次第行列。摩尼宝网之所弥覆。阿僧祇宝。放大光明。阿僧祇宝。庄严其地。烧众妙香。香气氛氲。复建无量种种宝幢。所谓宝香幢。宝衣幢。宝幡幢。宝缯幢。宝华幢。宝璎珞幢。宝鬘幢。宝铃幢。摩尼宝盖幢。大摩尼宝幢。光明遍照摩尼宝幢。出一切如来名号音声摩尼王幢。师子摩尼王幢。说一切如来本事海摩尼王幢。现一切法界影像摩尼王幢。周遍十方。行列庄严。时逝多林上虚空之中。有不思议天宫殿云。无数香树云。不可说须弥山云。不可说妓乐云。出美妙音歌赞如来不可说宝莲华云。不可说宝座云。敷以天衣菩萨坐上叹佛功德不可说诸天王形像摩尼宝云。不可说白真珠云。不可说赤珠楼阁庄严具云。不可说雨金刚坚固珠云。皆住虚空。周匝遍满。以为严饰。何以故。如来善根。不思议故。如来白法不思议故。如来威力不思议故。如来能以一身。自在变化。遍一切世界。不思议故。如来能以神力。令一切佛及佛国庄严。皆入其身。不思议故。如来能于一微尘内。普现一切法界影像。不思议故。如来能于一毛孔中。示现过去一切诸佛。不思议故。如来随放一一光明。悉能遍照一切世界。不思议故。如来能于一毛孔中。出一切佛刹微尘数变化云。充满一切诸佛国土。不思议故。如来能于一毛孔中。普现一切十方世界。成住坏劫。不思议故。如于此逝多林给孤独园。见佛国土。清净庄严。十方一切。尽法界虚空界。一切世界。亦如是见。所谓见如来身。住逝多林。菩萨众会。皆悉遍满。见普雨一切庄严云。见普雨一切宝光明照曜云。见普雨一切摩尼宝云。见普雨一切庄严盖弥覆佛刹云。见普雨一切天身云。见普雨一切华树云。见普雨一切衣树云。见普雨一切宝鬘璎珞相续不绝周遍一切大地云。见普雨一切庄严具云。见普雨一切如众生形种种香云。见普雨一切微妙宝华网相续不断云。见普雨一切诸天女持宝幢幡于虚空中周旋来去云。见普雨一切众宝莲华于华叶间自然而出种种乐音云。见普雨一切师子座宝网璎珞而为庄严云

尔时东方。过不可说佛刹微尘数世界海外。有世界。名金灯云幢。佛号毗卢遮那胜德王。彼佛众中。有菩萨。名毗卢遮那愿光明。与不可说佛刹微尘数菩萨俱。来向佛所。悉以神力。兴种种云。所谓天华云。天香云。天末香云。天鬘云。天宝云。天庄严具云。天宝盖云。天微妙衣云。天宝幢幡云。天一切妙宝。诸庄严云。充满虚空。至佛所已。顶礼佛足。即于东方。化作宝庄严楼阁。及普照十方宝莲华藏师子之座。如意宝网。罗覆其身。与其眷属。结跏趺坐。南方过不可说佛刹微尘数世界海外。有世界。名金刚藏。佛号普光明无胜藏王。彼佛众中。有菩萨。名不可坏精进王。与不可说佛刹微尘数菩萨俱。来向佛所。持一切宝香网。持一切宝璎珞。持一切宝华带。持一切宝鬘带。持一切金刚璎珞。持一切摩尼宝网。持一切宝衣带。持一切宝璎珞带。持一切最胜光明摩尼带。持一切师子。摩尼宝璎珞。悉以神力。充遍一切诸世界海。到佛所已。顶礼佛足。即于南方。化作遍照世间摩尼宝庄严楼阁。及普照十方宝莲华藏师子之座。以一切宝华网。罗覆其身。与其眷属。结跏趺坐。西方过不可说佛刹微尘数世界海外。有世界。名摩尼宝灯须弥山幢。佛号法界智灯。彼佛众中。有菩萨。名普胜无上威德王。与世界海微尘数菩萨俱。来向佛所。悉以神力。兴不可说佛刹微尘数种种涂香烧香须弥山云。不可说佛刹微尘数种种色香水须弥山云。不可说佛刹微尘数一切大地微尘等光明摩尼宝王须弥山云。不可说佛刹微尘数种种光焰轮庄严幢须弥山云。不可说佛刹微尘数种种色金刚藏摩尼王庄严须弥山云。不可说佛刹微尘数普照一切世界阎浮檀摩尼宝幢须弥山云。不可说佛刹微尘数现一切法界摩尼宝须弥山云。不可说佛刹微尘数现一切诸佛相好摩尼宝王须弥山云。不可说佛刹微尘数现一切如来本事因缘说诸菩萨所行之行摩尼宝王须弥山云。不可说佛刹微尘数现一切佛坐菩提场摩尼宝王须弥山云。充满法界至佛所已。顶礼佛足。即于西方。化作一切香王楼阁。真珠宝网。弥覆其上。及化作帝释影幢宝莲华藏师子之座。以妙色摩尼网。罗覆其身。心王宝冠。以严其首。与其眷属。结跏趺坐。北方过不可说佛刹微尘数世界海外。有世界。名宝衣光明幢。佛号照虚空法界大光明。彼佛众中。有菩萨。名无碍胜藏王。与世界海微尘数菩萨俱。来向佛所。悉以神力。兴一切宝衣云。所谓黄色宝光明衣云。种种香所熏衣云。日幢摩尼王衣云。金色炽然摩尼衣云。一切宝光焰衣云。一切星辰像上妙摩尼衣云。白玉光摩尼衣云。光明遍照殊胜赫奕摩尼衣云。光明遍照威势炽盛摩尼衣云。庄严海摩尼衣云。充遍虚空。至佛所已。顶礼佛足。即于北方。化作摩尼宝海庄严楼阁。及毗琉璃宝莲华藏师子之座。以师子威德摩尼王网。罗覆其身。清净宝王。为髻明珠。与其眷属。结跏趺坐。东北方过不可说佛刹微尘数世界海外。有世界。名一切欢喜清净光明网。佛号无碍眼。彼佛众中。有菩萨。名化现法界愿月王。与世界海微尘数菩萨俱。来向佛所。悉以神力。兴宝楼阁云。香楼阁云。烧香楼阁云。华楼阁云。栴檀楼阁云。金刚楼阁云。摩尼楼阁云。金楼阁云。衣楼阁云。莲华楼阁云。弥覆十方一切世界。至佛所已。顶礼佛足。即于东北方。化作一切法界门大摩尼楼阁。及无等香王莲华藏师子之座。摩尼华网。罗覆其身。着妙宝藏摩尼王冠。与其眷属。结跏趺坐。东南方。过不可说佛刹微尘数世界海外。有世界。名香云庄严幢。佛号龙自在王。彼佛众中。有菩萨。名法慧光焰王。与世界海微尘数菩萨俱。来向佛所。悉以神力。兴金色圆满光明云。无量宝色圆满光明云。如来毫相圆满光明云。种种宝色圆满光明云。莲华藏圆满光明云。众宝树枝圆满光明云。如来顶髻圆满光明云。阎浮檀金色圆满光明云。日色圆满光明云。星月色圆满光明云。悉遍虚空。到佛所已。顶礼佛足。即于东南方。化作毗卢遮那最上宝光明楼阁金刚摩尼莲华藏师子之座。众宝光焰摩尼王网。罗覆其身。与其眷属。结跏趺坐。西南方。过不可说佛刹微尘数世界海外有世界。名日光摩尼藏。佛号普照诸法智月王。彼佛众中。有菩萨。名摧破一切魔军智幢王。与世界海微尘数菩萨俱。来向佛所。于一切毛孔中。出等虚空界华焰云。香焰云。宝焰云。金刚焰云。烧香焰云。电光焰云。毗卢遮那摩尼宝焰云。一切金光焰云。胜藏摩尼王光焰云。等三世如来海光焰云。一一皆从毛孔中出。遍虚空界。到佛所已。顶礼佛足。即于西南方。化作普现十方法界光明网大摩尼宝楼阁及香灯焰宝莲华藏师子之座。以离垢藏摩尼网。罗覆其身。着出一切众生发趣音摩尼王严饰冠。与其眷属。结跏趺坐。西北方。过不可说佛刹微尘数世界海外。有世界。名毗卢遮那愿摩尼王藏。佛号普光明最胜须弥王。彼佛众中。有菩萨。名愿智光明幢。与世界海微尘数菩萨俱。来向佛所。于念念中。一切相好。一切毛孔。一切身分。皆出三世一切如来形像云。一切菩萨形像云。一切如来众会形像云。一切如来变化身形像云。一切如来本生身形像云。一切声闻辟支佛形像云。一切如来菩提场形像云。一切如来神变形像云。一切世间主形像云。一切清净国土形像云。充满虚空。至佛所已。顶礼佛足。即于西北方。化作普照十方摩尼宝庄严楼阁及普照世间宝莲华藏师子之座。以无能胜光明真珠网。罗覆其身。着普光明摩尼宝冠。与其眷属。结跏趺坐。下方。过不可说佛刹微尘数世界海外。有世界。名一切如来圆满光普照。佛号虚空无碍相智幢王。彼佛众中。有菩萨。名破一切障勇猛智王。与世界海微尘数菩萨俱。来向佛所。于一切毛孔中。出说一切众生语言海音声云。出说一切三世菩萨修行方便海音声云。出说一切菩萨所起愿方便海音声云。出说一切菩萨成满清净波罗蜜方便海音声云。出说一切菩萨圆满行遍一切刹音声云。出说一切菩萨成就自在用音声云。出说一切如来往诣道场破魔军众成等正觉自在用音声云。出说一切如来转法轮契经门名号海音声云。出说一切随应教化调伏众生法方便海音声云。出说一切随时随善根随愿力普令众生证得智慧方便海音声云。到佛所已。顶礼佛足。即于下方。化作现一切如来宫殿形像众宝庄严楼阁及一切宝莲华藏师子之座。着普现道场影摩尼宝冠。与其眷属。结跏趺坐。上方。过不可说佛刹微尘数世界海外。有世界。名说佛种性无有尽。佛号普智轮光明音。彼佛众中。有菩萨。名法界差别愿。与世界海。微尘数菩萨俱。发彼道场来。向此娑婆世界释迦牟尼佛所。于一切相好。一切毛孔。一切身分。一切肢节。一切庄严具。一切衣服中。现毗卢遮那等。过去一切诸佛。未来一切诸佛。已得授记。未授记者。现在十方一切国土。一切诸佛。并其众会。亦现过去行檀那波罗蜜。及其一切受布施者。诸本事海。亦现过去行尸罗波罗蜜。诸本事海。亦现过去行羼提波罗蜜。割截肢体。心无动乱。诸本事海。亦现过去行精进波罗蜜。勇猛不退。诸本事海。亦现过去求一切如来。禅波罗蜜海。而得成就。诸本事海。亦现过去求一切佛所转法轮。所成就法。发勇猛心。一切皆舍。诸本事海。亦现过去乐见一切佛。乐行一切菩萨道。乐化一切众生界。诸本事海。亦现过去所发一切菩萨大愿。清净庄严。诸本事海。亦现过去菩萨所成。力波罗蜜。勇猛清净。诸本事海。亦现过去一切菩萨。所修圆满。智波罗蜜。诸本事海。如是一切本事海。悉皆遍满广大法界。至佛所已。顶礼佛足。即于上方。化作一切金刚藏庄严楼阁及帝青金刚王莲华藏师子之座。以一切宝光明摩尼王网。罗覆其身。以演说三世如来名摩尼宝王。为髻明珠。与其眷属。结跏趺坐。如是十方一切菩萨。并其眷属。皆从普贤菩萨行愿中生。以净智眼。见三世佛。普闻一切诸佛如来。所转法轮。修多罗海。已得至于一切菩萨自在彼岸。于念念中。现大神变。亲近一切诸佛如来。一身充满一切世界一切如来众会道场。于一尘中。普现一切世间境界。教化成熟一切众生。未曾失时。一毛孔中。出一切如来说法音声。知一切众生悉皆如幻。知一切佛悉皆如影。知一切诸趣受生悉皆如梦。知一切业报如镜中像。知一切诸有生起如热时焰。知一切世界皆如变化。成就如来十力无畏。勇猛自在。能师子吼。深入无尽。辩才大海。得一切众生言辞海诸法智。于虚空法界。所行无碍。知一切法。无有障碍。一切菩萨。神通境界。悉已清净。勇猛精进。摧伏魔军。恒以智慧。了达三世。知一切法犹如虚空。无有违诤。亦无取着。虽勤精进。而知一切智终无所来。虽观境界。而知一切有悉不可得。以方便智。入一切法界。以平等智。入一切国土。以自在力。令一切世界。展转相入于一切世界。处处受生。见一切世界种种形相。于微细境。现广大刹。于广大境。现微细刹。于一佛所一念之顷。得一切佛。威神所加。普见十方。无所迷惑。于刹那顷。悉能往诣。如是等一切菩萨。满逝多林。皆是如来威神之力。于时上首诸大声闻。舍利弗。大目揵连。摩诃迦叶。离婆多。须菩提。阿[少/兔]楼驮。难陀。劫宾那。迦旃延。富楼那等。诸大声闻。在逝多林。皆悉不见如来神力。如来严好。如来境界。如来游戏。如来神变。如来尊胜。如来妙行。如来威德。如来住持。如来净刹。亦复不见不可思议菩萨境界。菩萨大会。菩萨普入。菩萨普至。菩萨普诣。菩萨神变。菩萨游戏。菩萨眷属。菩萨方所。菩萨庄严师子座。菩萨宫殿。菩萨住处。菩萨所入三昧自在。菩萨观察。菩萨频申。菩萨勇猛。菩萨供养。菩萨受记。菩萨成熟。菩萨勇健。菩萨法身清净。菩萨智身圆满。菩萨愿身示现。菩萨色身成就。菩萨诸相具足清净。菩萨常光众色庄严。菩萨放大光网。菩萨起变化云。菩萨身遍十方。菩萨诸行圆满。如是等事。一切声闻。诸大弟子。皆悉不见。何以故。以善根不同故。本不修习见佛自在善根故。本不赞说十方世界一切佛刹清净功德故。本不称叹诸佛世尊种种神变故。本不于生死流转之中。发阿耨多罗三藐三菩提心故。本不令他住菩提心故。本不能令如来种性不断绝故。本不摄受诸众生故。本不劝他修习菩萨波罗蜜故。本在生死流转之时。不劝众生求于最胜大智眼故。本不修习生一切智诸善根故。本不成就如来出世诸善根故。本不得严净佛刹神通智故。本不得诸菩萨眼所知境故。本不求超出世间不共菩提诸善根故。本不发一切菩萨诸大愿故。本不从如来加被之所生故。本不知诸法如幻菩萨如梦故。本不得诸大菩萨广大欢喜故。如是皆是普贤菩萨。智眼境界。不与一切二乘所共。以是因缘。诸大声闻。不能见不能知。不能闻不能入。不能得不能念。不能观察。不能筹量。不能思惟。不能分别。是故。虽在逝多林中。不见如来诸大神变。复次诸大声闻。无如是善根故。无如是智眼故。无如是三昧故。无如是解脱故。无如是神通故。无如是威德故。无如是势力故。无如是自在故。无如是住处故。无如是境界故。是故于此。不能知不能见。不能入不能证。不能住不能解。不能观察。不能忍受。不能趣向。不能游履。又亦不能广为他人开阐解说。称扬示现。引导劝进。令其趣向。令其修习。令其安住。令其证入。何以故。诸大弟子。依声闻乘。而出离故。成就声闻道。满足声闻行。安住声闻果。于无有谛。得决定智。常住实际。究竟寂静。远离大悲。舍于众生。住于自事。于彼智慧。不能积集。不能修行。不能安住。不能愿求。不能成就。不能清净。不能趣入。不能通达。不能知见。不能证得。是故。虽在逝多林中对于如来。不见如是广大神变。佛子。如恒河岸。有百千亿无量饿鬼。裸形饥渴。举体焦然。乌鹫豺狼。竞来搏撮。为渴所逼。欲求水饮。虽住河边。而不见河。设有见者。见其枯竭。何以故。深厚业障之所覆故。彼大声闻。亦复如是。虽复住在逝多林中。不见如来广大神力。舍一切智。无明翳瞙。覆其眼故。不曾种植萨婆若地诸善根故。譬如有人。于大会中。昏睡安寝。忽然梦见须弥山顶帝释所住善见大城。宫殿园林。种种严好。天子天女。百千万亿。普散天华。遍满其地。种种衣树。出妙衣服。种种华树。开敷妙华。诸音乐树。奏天音乐。天诸采女。歌咏美音。无量诸天。于中戏乐。其人自见着天衣服。普于其处。住止周旋。其大会中。一切诸人。虽同一处。不知不见。何以故。梦中所见。非彼大众所能见故。一切菩萨。世间诸王。亦复如是。以久积集善根力故。发一切智广大愿故。学习一切佛功德故。修行菩萨庄严道故。圆满一切智智法故。满足普贤诸行愿故。趣入一切菩萨智地故。游戏一切菩萨所住诸三昧故。已能观察一切菩萨智慧境界无障碍故。是故悉见如来世尊不可思议自在神变。一切声闻。诸大弟子。皆不能见。皆不能知。以无菩萨清净眼故。譬如雪山具众药草。良医诣彼。悉能分别。其诸捕猎放牧之人。恒住彼山。不见其药。此亦如是。以诸菩萨入智境界。具自在力。能见如来广大神变。诸大弟子。唯求自利。不欲利他。唯求自安。不欲安他。虽在林中。不知不见。譬如地中有诸宝藏。种种珍异。悉皆充满。有一丈夫。聪慧明达。善能分别一切伏藏。其人复有大福德力。能随所欲。自在而取。奉养父母。赈恤亲属。老病穷乏。靡不均赡。其无智慧。无福德人虽亦至于宝藏之处。不知不见。不得其益。此亦如是。诸大菩萨。有净智眼。能入如来不可思议甚深境界。能见佛神力。能入诸法门。能游三昧海。能供养诸佛。能以正法开悟众生。能以四摄摄受众生。诸大声闻。不能得见如来神力。亦不能见诸菩萨众。譬如盲人至大宝洲。若行若住。若坐若卧。不能得见。一切众宝。以不见故。不能采取。不得受用。此亦如是。诸大弟子。虽在林中亲近世尊。不见如来自在神力。亦不得见菩萨大会。何以故。无有菩萨无碍净眼。不能次第悟入法界。见于如来自在力故。譬如有人。得清净眼。名离垢光明。一切暗色。不能为障。尔时彼人。于夜暗中。处在无量百千万亿人众之内。或行或住。或坐或卧。彼诸人众。形相威仪。此明眼人。莫不具见。其明眼者。威仪进退。彼诸人众。悉不能睹。佛亦如是。成就智眼。清净无碍。悉能明见一切世间。其所示现。神通变化。大菩萨众。所共围绕。诸大弟子。悉不能见。譬如比丘在大众中。入遍处定。所谓地遍处定。水遍处定。火遍处定。风遍处定。青遍处定。黄遍处定。赤遍处定。白遍处定。天遍处定。种种众生身遍处定。一切语言音声遍处定。一切所缘遍处定。入此定者。见其所缘。其余大众。悉不能见。唯除有住此三昧者。如来所现。不可思议。诸佛境界。亦复如是。菩萨具见。声闻莫睹。譬如有人。以翳形药。自涂其眼。在于众会。去来坐立。无能见者。而能悉睹众会中事。应知如来。亦复如是。超过于世。普见世间。非诸声闻所能得见。唯除趣向一切智境。诸大菩萨。如人生已。则有二天。恒相随逐。一曰同生。二曰同名。天常见人。人不见天。应知如来。亦复如是。在诸菩萨大集会中。现大神通。诸大声闻。悉不能见。譬如比丘得心自在。入灭尽定。六根作业。皆悉不行。一切语言。不知不觉。定力持故。不般涅槃。一切声闻。亦复如是。虽复住在逝多林中。具足六根。而不知不见。不解不入。如来自在。菩萨众会。诸所作事。何以故。如来境界。甚深广大。难见难知。难测难量。超诸世间。不可思议。无能坏者。非是一切二乘境界。是故如来。自在神力。菩萨众会。及逝多林。普遍一切清净世界。如是等事。诸大声闻。悉不知见。非其器故。尔时毗卢遮那愿光明菩萨。承佛神力。观察十方。而说颂言

  汝等应观察　　佛道不思议
  于此逝多林　　示现神通力
  善逝威神力　　所现无央数
  一切诸世间　　迷惑不能了
  法王深妙法　　无量难思议
  所现诸神通　　举世莫能测
  以了法无相　　是故名为佛
  而具相庄严　　称扬不可尽
  今于此林内　　示现大神力
  甚深无有边　　言辞莫能辩
  汝观大威德　　无量菩萨众
  十方诸国土　　而来见世尊
  所愿皆具足　　所行无障碍
  一切诸世间　　无能测量者
  一切诸缘觉　　及彼大声闻
  皆悉不能知　　菩萨行境界
  菩萨大智慧　　诸地悉究竟
  高建勇猛幢　　难摧难可动
  诸大名称士　　无量三昧力
  所现诸神变　　法界悉充满

尔时不可坏精进王菩萨。承佛神力。观察十方。而说颂言

  汝观诸佛子　　智慧功德藏
  究竟菩提行　　安隐诸世间
  其心本明达　　善入诸三昧
  智慧无边际　　境界不可量
  今此逝多林　　种种皆严饰
  菩萨众云集　　亲近如来住
  汝观无所著　　无量大众海
  十方来诣此　　坐宝莲华座
  无来亦无住　　无依无戏论
  离垢心无碍　　究竟于法界
  建立智慧幢　　坚固不动摇
  知无变化法　　而现变化事
  十方无量刹　　一切诸佛所
  同时悉往诣　　而亦不分身
  汝观释师子　　自在神通力
  能令菩萨众　　一切俱来集
  一切诸佛法　　法界悉平等
  言说故不同　　此众咸通达
  诸佛常安住　　法界平等际
  演说差别法　　言辞无有尽

尔时普胜无上威德王菩萨。承佛神力。观察十方。而说颂言

  汝观无上士　　广大智圆满
  善达时非时　　为众演说法
  摧伏众外道　　一切诸异论
  普随众生心　　为现神通力
  正觉非有量　　亦复非无量
  若量若无量　　牟尼悉超越
  如日在虚空　　照临一切处
  佛智亦如是　　了达三世法
  譬如十五夜　　月轮无减缺
  如来亦复然　　白法悉圆满
  譬如空中日　　运行无暂已
  如来亦如是　　神变恒相续
  譬如十方刹　　于空无所碍
  世灯现变化　　于世亦复然
  譬如世间地　　群生之所依
  照世灯法轮　　为依亦如是
  譬如猛疾风　　所行无障碍
  佛法亦如是　　速遍于世间
  譬如大水轮　　世界所依住
  智慧轮亦尔　　三世佛所依

尔时无碍胜藏王菩萨。承佛神力。观察十方。而说颂言

  譬如大宝山　　饶益诸含识
  佛山亦如是　　普益于世间
  譬如大海水　　澄净无垢浊
  见佛亦如是　　能除诸渴爱
  譬如须弥山　　出于大海中
  世间灯亦尔　　从于法海出
  如海具众宝　　求者皆满足
  无师智亦然　　见者悉开悟
  如来甚深智　　无量无有数
  是故神通力　　示现难思议
  譬如工幻师　　示现种种事
  佛智亦如是　　现诸自在力
  譬如如意宝　　能满一切欲
  最胜亦复然　　满诸清净愿
  譬如明净宝　　普照一切物
  佛智亦如是　　普照群生心
  譬如八面宝　　等鉴于诸方
  无碍灯亦然　　普照于法界
  譬如水清珠　　能清诸浊水
  见佛亦如是　　诸根悉清净

尔时化现法界愿月王菩萨。承佛神力。观察十方。而说颂言

  譬如帝青宝　　能青一切色
  见佛者亦然　　悉发菩提行
  一一微尘内　　佛现神通力
  令无量无边　　菩萨皆清净
  甚深微妙力　　无边不可知
  菩萨之境界　　世间莫能测
  如来所现身　　清净相庄严
  普入于法界　　成就诸菩萨
  难思佛国土　　于中成正觉
  一切诸菩萨　　世主皆充满
  释迦无上尊　　于法悉自在
  示现神通力　　无边不可量
  菩萨种种行　　无量无有尽
  如来自在力　　为之悉示现
  佛子善修学　　甚深诸法界
  成就无碍智　　明了一切法
  善逝威神力　　为众转法轮
  神变普充满　　令世皆清净
  如来智圆满　　境界亦清净
  譬如大龙王　　普济诸群生

尔时法慧光焰王菩萨。承佛神力。观察十方。而说颂言

  三世诸如来　　声闻大弟子
  悉不能知佛　　举足下足事
  去来现在世　　一切诸缘觉
  亦不知如来　　举足下足事
  况复诸凡夫　　结使所缠缚
  无明覆心识　　而能知导师
  正觉无碍智　　超过语言道
  其量不可测　　孰有能知见
  譬如明月光　　无能测边际
  佛神通亦尔　　莫见其终尽
  一一诸方便　　念念所变化
  尽于无量劫　　思惟不能了
  思惟一切智　　不可思议法
  一一方便门　　边际不可得
  若有于此法　　而兴广大愿
  彼于此境界　　知见不为难
  勇猛勤修习　　难思大法海
  其心无障碍　　入此方便门
  心意已调伏　　志愿亦宽广
  当获大菩提　　最胜之境界

尔时破一切魔军智幢王菩萨。承佛神力。观察十方。而说颂言

  智身非是身　　无碍难思议
  设有思议者　　一切无能及
  从不思议业　　起此清净身
  殊特妙庄严　　不着于三界
  光明照一切　　法界悉清净
  开佛菩提门　　出生众智慧
  譬如世间日　　普放慧光明
  远离诸尘垢　　灭除一切障
  普净三有处　　永绝生死流
  成就菩萨道　　出生无上觉
  示现无边色　　此色无依处
  所现虽无量　　一切不思议
  菩提一念顷　　能觉一切法
  云何欲测量　　如来智边际
  一念悉明达　　一切三世法
  故说佛智慧　　无尽无能坏
  智者应如是　　专思佛菩提
  此思难思议　　思之不可得
  菩提不可说　　超过语言路
  诸佛从此生　　是法难思议

尔时愿智光明幢王菩萨。承佛神力。观察十方。而说颂言

  若能善观察　　菩提无尽海
  则得离痴念　　决定受持法
  若得决定心　　则能修妙行
  禅寂自思虑　　永断诸疑惑
  其心不疲倦　　亦复无懈怠
  展转增进修　　究竟诸佛法
  信智已成就　　念念令增长
  常乐常观察　　无得无依法
  无量亿千劫　　所修功德行
  一切悉回向　　诸佛所求道
  虽在于生死　　而心无染着
  安住诸佛法　　常乐如来行
  世间之所有　　蕴界等诸法
  一切皆舍离　　专求佛功德
  凡夫婴妄惑　　于世常流转
  菩萨心无碍　　救之令解脱
  菩萨行难称　　举世莫能思
  遍除一切苦　　普与群生乐
  已获菩提智　　复愍诸群生
  光明照世间　　度脱一切众

尔时破一切障勇猛智王菩萨。承佛神力。观察十方。而说颂言

  无量亿千劫　　佛名难可闻
  况复得亲近　　永断诸疑惑
  如来世间灯　　通达一切法
  普生三世福　　令众悉清净
  如来妙色身　　一切所钦叹
  亿劫常瞻仰　　其心无厌足
  若有诸佛子　　观佛妙色身
  必舍诸有着　　回向菩提道
  如来妙色身　　恒演广大音
  辩才无障碍　　开佛菩提门
  晓悟诸众生　　无量不思议
  令入智慧门　　授以菩提记
  如来出世间　　为世大福田
  普导诸含识　　令其集福行
  若有供养佛　　永除恶道畏
  消灭一切苦　　成就智慧身
  若见两足尊　　能发广大心
  是人恒值佛　　增长智慧力
  若见人中胜　　决意向菩提
  是人能自知　　必当成正觉

尔时法界差别愿智神通王菩萨。承佛神力。观察十方。而说颂言

  释迦无上尊　　具一切功德
  见者心清净　　回向大智慧
  如来大慈悲　　出现于世间
  普为诸群生　　转无上法轮
  如来无数劫　　勤苦为众生
  云何诸世间　　能报大师恩
  宁于无量劫　　受诸恶道苦
  终不舍如来　　而求于出离
  宁代诸众生　　备受一切苦
  终不舍于佛　　而求得安乐
  宁在诸恶趣　　恒得闻佛名
  不愿生善道　　暂时不闻佛
  宁生诸地狱　　一一无数劫
  终不远离佛　　而求出恶趣
  何故愿久住　　一切诸恶道
  以得见如来　　增长智慧故
  若得见于佛　　除灭一切苦
  能入诸如来　　大智之境界
  若得见于佛　　舍离一切障
  长养无尽福　　成就菩提道
  如来能永断　　一切众生疑
  随其心所乐　　普皆令满足

大方广佛华严经卷第六十大方广佛华严经卷第六十一

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之二

尔时普贤菩萨摩诃萨。普观一切菩萨众会。以等法界方便。等虚空界方便。等众生界方便。等三世。等一切劫。等一切众生业。等一切众生欲。等一切众生解。等一切众生根。等一切众生成熟时。等一切法光影方便。为诸菩萨以十种法句。开发显示照明演说此师子频申三昧。何等为十。所谓演说能示现等法界。一切佛刹微尘中。诸佛出兴次第。诸刹成坏。次第法句。演说能示现等虚空界。一切佛刹中。尽未来劫。赞叹如来功德音声法句。演说能示现等虚空界。一切佛刹中。如来出世。无量无边。成正觉门法句。演说能示现等虚空界。一切佛刹中。佛坐道场。菩萨众会法句。演说于一切毛孔。念念出现等三世一切佛变化身。充满法界法句。演说能令一身充满十方一切刹海。平等显现法句。演说能令一切诸境界中。普现三世诸佛神变法句。演说能令一切佛刹微尘中。普现三世一切佛刹微尘数佛。种种神变。经无量劫法句。演说能令一切毛孔。出生三世一切诸佛。大愿海音。尽未来劫。开发化导一切菩萨法句。演说能令佛师子座。量同法界。菩萨众会。道场庄严。等无差别。尽未来劫。转于种种微妙法轮法句。佛子。此十为首。有不可说佛刹微尘数法句。皆是如来。智慧境界。尔时普贤菩萨。欲重宣此义。承佛神力。观察如来。观察众会。观察诸佛难思境界。观察诸佛无边三昧。观察不可思议诸世界海。观察不可思议如幻法智。观察不可思议三世诸佛悉皆平等。观察一切无量无边诸言辞法。而说颂言

  一一毛孔中　　微尘数刹海
  悉有如来坐　　皆具菩萨众
  一一毛孔中　　无量诸刹海
  佛处菩提座　　如是遍法界
  一一毛孔中　　一切刹尘佛
  菩萨众围绕　　为说普贤行
  佛坐一国土　　充满十方界
  无量菩萨云　　咸来集其所
  亿刹微尘数　　菩萨功德海
  俱从会中起　　遍满十方界
  悉住普贤行　　皆游法界海
  普现一切刹　　等入诸佛会
  安坐一切刹　　听闻一切法
  一一国土中　　亿劫修诸行
  菩萨所修行　　普明法海行
  入于大愿海　　住佛境界地
  了达普贤行　　出生诸佛法
  具佛功德海　　广现神通事
  身云等尘数　　充遍一切刹
  普雨甘露法　　令众住佛道

尔时世尊。欲令诸菩萨。安住如来师子频申广大三昧故。从眉间白毫相。放大光明。其光名普照三世法界门。以不可说佛刹微尘数光明。而为眷属。普照十方一切世界海诸佛国土。时逝多林菩萨大众。悉见一切尽法界虚空界一切佛刹。一一微尘中。各有一切佛刹微尘数诸佛国土。种种名。种种色。种种清净。种种住处。种种形相。如是一切诸国土中。皆有大菩萨。坐于道场师子座上。成等正觉。菩萨大众。前后围绕。诸世间主。而为供养。或见于不可说佛刹量。大众会中。出妙音声。充满法界。转正法轮。或见在天宫殿。龙宫殿夜叉宫殿。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等诸宫殿中。或在人间村邑聚落。王都大处。现种种姓。种种名。种种身。种种相。种种光明。住种种威仪。入种种三昧。现种种神变。或时自以种种言音。或令种种诸菩萨等。在于种种大众会中。种种言辞。说种种法。如此会中。菩萨大众。见于如是诸佛如来甚深三昧大神通力。如是尽法界虚空界。东西南北。四维上下。一切方海中。依于众生心想而住。始从前际至今现在。一切国土身。一切众生身。一切虚空道。其中一一毛端量处。一一各有微尘数刹。种种业起。次第而住。悉有道场菩萨众会。皆亦如是。见佛神力。不坏三世。不坏世间。于一切众生心中。现其影像。随一切众生心乐。出妙言音。普入一切众会中。普现一切众生前。色相有别。智慧无异。随其所应。开示佛法。教化调伏一切众生。未曾休息。其有见此佛神力者。皆是毗卢遮那如来。于往昔时。善根摄受。或昔曾以四摄所摄。或是见闻忆念亲近之所成熟。或是往昔教其令发阿耨多罗三藐三菩提心。或是往昔于诸佛所。同种善根。或是过去以一切智。善巧方便。教化成熟。是故皆得入于如来不可思议甚深三昧。尽法界虚空界大神通力。或入法身。或入色身。或入往昔所成就行。或入圆满诸波罗蜜。或入庄严清净行轮。或入菩萨诸地。或入成正觉力。或入佛所住三昧无差别大神变。或入如来力无畏智。或入佛无碍辩才海。彼诸菩萨。以种种解。种种道。种种门。种种入。种种理趣。种种随顺。种种智慧。种种助道。种种方便。种种三昧。入如是等十不可说佛刹微尘数佛神变海方便门。云何种种三昧。所谓普庄严法界三昧。普照一切三世无碍境界三昧。法界无差别智光明三昧。入如来境界不动转三昧。普照无边虚空三昧。入如来力三昧。佛无畏勇猛奋迅庄严三昧。一切法界旋转藏三昧。如月普现一切法界以无碍音大开演三昧。普清净法光明三昧。无碍缯法王幢三昧。一一境界中悉见一切诸佛海三昧。于一切世间悉现身三昧。入如来无差别身境界三昧。随一切世间转大悲藏三昧。知一切法无有迹三昧。知一切法究竟寂灭三昧。虽无所得而能变化普现世间三昧。普入一切刹三昧。庄严一切佛刹成正觉三昧。观一切世间主色相差别三昧。观一切众生境界无障碍三昧。能出生一切如来母三昧。能修行入一切佛海功德道三昧。一一境界中出现神变尽未来际三昧。入一切如来本事海三昧。尽未来际护持一切如来种性三昧。以决定解力令现在十方一切佛刹海皆清净三昧。一念中普照一切佛所住三昧。入一切境界无碍际三昧。令一切世界为一佛刹三昧。出一切佛变化身三昧。以金刚王智知一切诸根海三昧。知一切如来同一身三昧。知一切法界所安立悉住心念际三昧。于一切法界广大国土中示现涅槃三昧。令住最上处三昧。于一切佛刹现种种众生差别身三昧。普入一切佛智慧三昧。知一切法性相三昧。一念普知三世法三昧。念念中普现法界身三昧。以师子勇猛智知一切如来出兴次第三昧。于一切法界境界慧眼圆满三昧。勇猛趣向十力三昧。放一切功德圆满光明普照世间三昧。不动藏三昧。说一法普入一切法三昧。于一法以一切言音差别训释三昧。演说一切佛无二法三昧。知三世无碍际三昧。知一切劫无差别三昧。入十力微细方便三昧。于一切劫成就一切菩萨行不断绝三昧。十方普现身三昧。于法界自在成正觉三昧。生一切安隐受三昧。出一切庄严具庄严虚空界三昧。念念中出等众生数变化身云三昧。如来净空月光明三昧。常见一切如来住虚空三昧。开示一切佛庄严三昧。照明一切法义灯三昧。照十力境界三昧。三世一切佛幢想三昧。一切佛一密藏三昧。念念中所作皆究竟三昧。无尽福德藏三昧。见无边佛境界三昧。坚住一切法三昧。现一切如来变化悉令知见三昧。念念中佛日常出现三昧。一日中悉知三世所有法三昧。普音演说一切法性寂灭三昧。见一切佛自在力三昧。法界开敷莲华三昧。观诸法如虚空无住处三昧。十方海普入一方三昧。入一切法界无源底三昧。一切法海三昧。以寂静身放一切光明三昧。一念中现一切神通大愿三昧。一切时一切处成正觉三昧。以一庄严入一切法界三昧。普现一切诸佛身三昧。知一切众生广大殊胜神通智三昧。一念中其身遍法界三昧。现一乘净法界三昧。入普门法界示现大庄严三昧。住持一切佛法轮三昧。以一切法门庄严一法门三昧。以因陀罗网愿行摄一切众生界三昧。分别一切世界门三昧。乘莲华自在游步三昧。知一切众生种种差别神通智三昧。令其身恒现一切众生前三昧。知一切众生差别音声言辞海三昧。知一切众生差别智神通三昧。大悲平等藏三昧。一切佛入如来际三昧。观察一切如来解脱处师子频申三昧。菩萨以如是等不可说佛刹微尘数三昧。入毗卢遮那如来念念充满一切法界三昧神变海。其诸菩萨。皆悉具足大智神通。明利自在。住于诸地。以广大智。普观一切。从诸智慧种性而生。一切智智。常现在前。得离痴翳清净智眼。为诸众生。作调御师。住佛平等。于一切法。无有分别。了达境界。知诸世间。性皆寂灭。无有依处。普诣一切诸佛国土而无所著。悉能观察一切诸法。而无所住。遍入一切妙法宫殿。而无所来。教化调伏一切世间。普为众生。现安隐处。智慧解脱。为其所行。恒以智身。住离贪际。超诸有海。示真实际。智光圆满。普见诸法。住于三昧。坚固不动。于诸众生。恒起大悲。知诸法门悉皆如幻。一切众生悉皆如梦。一切如来悉皆如影。一切言音悉皆如响。一切诸法悉皆如化。善能积集殊胜行愿。智慧圆满。清净善巧。心极寂静。善入一切总持境界。具三昧力。勇猛无怯。获明智眼。住法界际。到一切法无所得处。修习无涯智慧大海。到智波罗蜜究竟彼岸。为般若波罗蜜之所摄持。以神通波罗蜜。普入世间。依三昧波罗蜜。得心自在。以不颠倒智。知一切义。以巧分别智。开示法藏。以现了智。训释文辞。以大愿力。说法无尽。以无所畏大师子吼。常乐观察无依处法。以净法眼。普观一切。以净智月。照世成坏。以智慧光。照真实谛。福德智慧如金刚山。一切譬谕所不能及。善观诸法。慧根增长。勇猛精进。摧伏众魔。无量智慧。威光炽盛。其身超出一切世间。得一切法无碍智慧。善能悟解尽无尽际。住于普际。入真实际。无相观智。常现在前。善巧成就诸菩萨行。以无二智。知诸境界。普见一切世间诸趣。遍往一切诸佛国土。智灯圆满。于一切法。无诸暗障。放净法光。照十方界。为诸世间真实福田。若见若闻。所愿皆满。福德高大。超诸世间。勇猛无畏。摧诸外道。演微妙音。遍一切刹。普见诸佛。心无厌足。于佛法身。已得自在。随所应化。而为现身。一身充满一切佛刹。已得自在清净神通。乘大智舟。所往无碍。智慧圆满。周遍法界。譬如日出普照世间。随众生心。现其色像。知诸众生根性欲乐。入一切法无诤境界。知诸法性无生无起。能令小大。自在相入。决了佛地甚深之趣。以无尽句。说甚深义。于一句中。演说一切修多罗海。获大智慧陀罗尼身。凡所受持。永无忘失。一念能忆无量劫事。一念悉知三世一切诸众生智。恒以一切陀罗尼门。演说无边诸佛法海。常转不退清净法轮。令诸众生皆生智慧。得佛境界。智慧光明。入于善见甚深三昧。入一切法无障碍际。于一切法。胜智自在。一切境界。清净庄严。普入十方一切法界。随其方所。靡不咸至。一一尘中。现成正觉。于无色性。现一切色。以一切方。普入一方。其诸菩萨。具如是等无边福智功德之藏。常为诸佛之所称叹。种种言辞。说其功德。不能令尽。靡不咸在逝多林中。深入如来功德大海。悉见于佛光明所照。尔时诸菩萨。得不思议正法光明。心大欢喜。各于其身及以楼阁。诸庄严具。并其所坐。师子之座。遍逝多林一切物中。化现种种大庄严云。充满一切十方法界。所谓于念念中。放大光明云。充满十方。悉能开悟一切众生。出一切摩尼宝铃云。充满十方。出微妙音称扬赞叹三世诸佛一切功德。出一切音乐云。充满十方。音中演说一切众生诸业果报。出一切菩萨种种愿行色相云。充满十方。说诸菩萨所有大愿。出一切如来自在变化云。充满十方。演出一切诸佛如来语言音声。出一切菩萨相好庄严身云。充满十方。说诸如来。于一切国土。出兴次第。出三世如来道场云。充满十方。现一切如来成等正觉。功德庄严。出一切龙王云。充满十方。雨一切诸香。出一切世主身云。充满十方。演说普贤菩萨之行。出一切宝庄严清净佛刹云。充满十方。现一切如来转正法轮。是诸菩萨。以得不思议法光明故。法应如是。出兴此等不可说佛刹微尘数大神变庄严云。尔时文殊师利菩萨。承佛神力。欲重宣此逝多林中。诸神变事。观察十方。而说颂言

  汝应观此逝多林　　以佛威神广无际
  一切庄严皆示现　　十方法界悉充满
  十方一切诸国土　　无边品类大庄严
  于其座等境界中　　色像分明皆显现
  从诸佛子毛孔出　　种种庄严宝焰云
  及发如来微妙音　　遍满十方一切刹
  宝树华中现妙身　　其身色相等梵王
  从禅定起而游步　　进止威仪恒寂静
  如来一一毛孔内　　常现难思变化身
  皆如普贤大菩萨　　种种诸相为严好
  逝多林上虚空中　　所有庄严发妙音
  普说三世诸菩萨　　成就一切功德海
  逝多林中诸宝树　　亦出无量妙音声
  演说一切诸群生　　种种业海各差别
  林中所有众境界　　悉现三世诸如来
  一一皆起大神通　　十方刹海微尘数
  十方所有诸国土　　一切刹海微尘数
  悉入如来毛孔中　　次第庄严皆现睹
  所有庄严皆现佛　　数等众生遍世间
  一一咸放大光明　　种种随宜化群品
  香焰众华及宝藏　　一切庄严殊妙云
  靡不广大等虚空　　遍满十方诸国土
  十方三世一切佛　　所有庄严妙道场
  于此园林境界中　　一一色像皆明现
  一切普贤诸佛子　　百千劫海庄严刹
  其数无量等众生　　莫不于此林中见

尔时彼诸菩萨。以佛三昧光明照故。即时得入如是三昧。一一皆得不可说佛刹微尘数大悲门。利益安乐一切众生。于其身上一一毛孔。皆出不可说佛刹微尘数光明。一一光明。皆化现不可说佛刹微尘数菩萨。其身形相。如世诸主。普现一切众生之前。周匝遍满十方法界。种种方便。教化调伏。或现不可说佛刹微尘数诸天宫殿无常门。或现不可说佛刹微尘数一切众生受生门。或现不可说佛刹微尘数一切菩萨修行门。或现不可说佛刹微尘数梦境门。或现不可说佛刹微尘数菩萨大愿门。或现不可说佛刹微尘数震动世界门。或现不可说佛刹微尘数分别世界门。或现不可说佛刹微尘数现生世界门。或现不可说佛刹微尘数檀波罗蜜门。或现不可说佛刹微尘数一切如来修诸功德种种苦行尸波罗蜜门。或现不可说佛刹微尘数割截肢体羼提波罗蜜门。或现不可说佛刹微尘数勤修毗梨耶波罗蜜门。或现不可说佛刹微尘数一切菩萨修诸三昧禅定解脱门。或现不可说佛刹微尘数佛道圆满智光明门。或现不可说佛刹微尘数勤求佛法为一文一句故舍无数身命门。或现不可说佛刹微尘数亲近一切佛咨问一切法心无疲厌门。或现不可说佛刹微尘数随诸众生时节欲乐往诣其所方便成熟令住一切智海光明门。或现不可说佛刹微尘数降伏众魔制诸外道显现菩萨福智力门。或现不可说佛刹微尘数知一切工巧明智门。或现不可说佛刹微尘数知一切众生差别明智门。或现不可说佛刹微尘数知一切法差别明智门。或现不可说佛刹微尘数知一切众生心乐差别明智门。或现不可说佛刹微尘数知一切众生根行烦恼习气明智门。或现不可说佛刹微尘数知一切众生种种业明智门。或现不可说佛刹微尘数开悟一切众生门。以如是等不可说佛刹微尘数方便门。往诣一切众生住处。而成熟之。所谓或往天宫。或往龙宫。或往夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽宫。或往梵王宫。或往人王宫。或往阎罗王宫。或往畜生饿鬼地狱之所住处。以平等大悲。平等大愿。平等智慧。平等方便。摄诸众生。或有见已而调伏者。或有闻已而调伏者。或有忆念而调伏者。或闻音声而调伏者。或闻名号而调伏者。或见圆光而调伏者。或见光网而调伏者。随诸众生心之所乐。皆诣其所。令其获益。佛子。此逝多林。一切菩萨。为欲成熟诸众生故。或时现处种种严饰诸宫殿中。或时示现住自楼阁宝师子座。道场众会所共围绕。周遍十方皆令得见。然亦不离此逝多林如来之所。佛子。此诸菩萨。或时示现无量化身云。或现其身。独一无侣。所谓或现沙门身。或现婆罗门身。或现苦行身。或现充盛身。或现医王身。或现商主身。或现净命身。或现妓乐身。或现奉事诸天身。或现工巧技术身。往诣一切村营城邑。王都聚落。诸众生所。随其所应。以种种形相。种种威仪。种种音声。种种言论。种种住处。于一切世间。犹如帝网。行菩萨行。或说一切世间工巧事业。或说一切智慧照世明灯。或说一切众生业力所庄严。或说十方国土建立诸乘位。或说智灯所照一切法境界。教化成就一切众生。而亦不离此逝多林如来之所

尔时文殊师利童子。从善住楼阁出。与无量同行菩萨。及常随侍卫诸金刚神。普为众生。供养诸佛诸身众神。久发坚誓愿常随从诸足行神。乐闻妙法主地神。常修大悲主水神。智光照耀主火神。摩尼为冠主风神。明练十方一切仪式主方神。专勤除灭无明黑暗主夜神。一心匪懈阐明佛日主昼神。庄严法界一切虚空主空神。普度众生超诸有海主海神。常勤积集趣一切智助道善根高大如山主山神。常勤守护一切众生菩提心城主城神。常勤守护一切智智无上法城诸大龙王。常勤守护一切众生诸夜叉王。常令众生增长欢喜乾闼婆王。常勤除灭诸饿鬼趣鸠槃荼王。恒愿拔济一切众生出诸有海迦楼罗王。愿得成就诸如来身高出世间阿修罗王。见佛欢喜曲躬恭敬摩睺罗伽王。常厌生死恒乐见佛诸大天王。尊重于佛赞叹供养诸大梵王。文殊师利。与如是等功德庄严诸菩萨众。出自住处。来诣佛所。右绕世尊。经无量匝。以诸供具种种供养。供养毕已。辞退南行。往于人间

尔时尊者舍利弗。承佛神力。见文殊师利菩萨。与诸菩萨众会庄严。出逝多林。往于南方。游行人间。作如是念。我今当与文殊师利。俱往南方。时尊者舍利弗。与六千比丘。前后围绕。出自住处。来诣佛所。顶礼佛足。具白世尊。世尊听许。右绕三匝。辞退而去。往文殊师利所。此六千比丘。是舍利弗自所同住。出家未久。所谓海觉比丘。善生比丘。福光比丘。大童子比丘。电生比丘。净行比丘。天德比丘君慧比丘。梵胜比丘。寂慧比丘。如是等其数六千。悉曾供养无量诸佛。深植善根。解力广大。信眼明彻。其心宽博。观佛境界。了法本性。饶益众生。常乐勤求诸佛功德。皆是文殊师利说法教化之所成就。尔时尊者舍利弗。在行道中。观诸比丘。告海觉言。海觉。汝可观察文殊师利菩萨清净之身相好庄严。一切天人莫能思议。汝可观察文殊师利圆光映彻。令无量众生。发欢喜心。汝可观察文殊师利光网庄严。除灭众生无量苦恼。汝可观察文殊师利众会具足。皆是菩萨往昔善根之所摄受。汝可观察文殊师利所行之路。左右八步。平坦庄严。汝可观察文殊师利所住之处。周回十方。常有道场。随逐而转。汝可观察文殊师利所行之路。具足无量福德庄严。左右两边。有大伏藏。种种珍宝。自然而出。汝可观察文殊师利曾供养佛。善根所流。一切树间。出庄严藏。汝可观察文殊师利。诸世间主雨供具云。顶礼恭敬。以为供养。汝可观察文殊师利。十方一切诸佛如来。将说法时。悉放眉间白毫相光。来照其身。从顶上入。尔时尊者舍利弗。为诸比丘。称扬赞叹。开示演说文殊师利童子。有如是等。无量功德具足庄严。彼诸比丘。闻是说已。心意清净。信解坚固。喜不自持。举身踊跃。形体柔软。诸根悦豫。忧苦悉除。垢障咸尽。常见诸佛。深求正法。具菩萨根。得菩萨力。大悲大愿。皆自出生。入于诸度甚深境界。十方佛海。常现在前。于一切智。深生信乐。即白尊者舍利弗言。唯愿大师。将引我等。往诣于彼胜人之所。时舍利弗。即与俱行。至其所已。白言仁者。此诸比丘。愿得奉觐。尔时文殊师利童子。无量自在菩萨围绕。并其大众。如象王回。观诸比丘。时诸比丘。顶礼其足。合掌恭敬。作如是言。我今奉见。恭敬礼拜。及余所有一切善根。唯愿仁者文殊师利。和尚舍利弗。世尊释迦牟尼。皆悉证知。如仁所有。如是色身。如是音声。如是相好。如是自在。愿我一切悉当具得。尔时文殊师利菩萨。告诸比丘言。比丘。若善男子善女人。成就十种趣大乘法。则能速入如来之地。况菩萨地。何者为十。所谓积集一切善根心无疲厌。见一切佛承事供养心无疲厌。求一切佛法心无疲厌。行一切波罗蜜心无疲厌。成就一切菩萨三昧心无疲厌。次第入一切三世心无疲厌。普严净十方佛刹心无疲厌。教化调伏一切众生心无疲厌。于一切刹一切劫中成就菩萨行心无疲厌。为成熟一众生故修行一切佛刹微尘数波罗蜜成就如来一力如是次第为成熟一切众生界成就如来一切力心无疲厌。比丘若善男子善女人。成就深信。发此十种无疲厌心。则能长养一切善根。舍离一切诸生死趣。超过一切世间种姓。不堕声闻辟支佛地。生一切如来家。具一切菩萨愿。学习一切如来功德。修行一切菩萨诸行。得如来力。摧伏众魔及诸外道。亦能除灭一切烦恼。入菩萨地。近如来地。时诸比丘。闻此法已。则得三昧。名无碍眼见一切佛境界。得此三昧故。悉见十方无量无边一切世界诸佛如来。及其所有道场众会。亦悉见彼十方世界一切诸趣所有众生。亦悉见彼一切世界种种差别。亦悉见彼一切世界所有微尘。亦悉见彼诸世界中一切众生所住宫殿。以种种宝而为庄严。及亦闻彼诸佛如来种种言音演说诸法文辞训释。悉皆解了。亦能观察彼世界中一切众生诸根心欲。亦能忆念彼世界中一切众生前后十生。亦能忆念彼世界中过去未来各十劫事。亦能忆念彼诸如来十本生事。十成正觉。十转法轮。十种神通。十种说法。十种教诫。十种辩才。又即成就十千菩提心。十千三昧。十千波罗蜜。悉皆清净。得大智慧圆满光明。得菩萨十神通。柔软微妙。住菩萨心。坚固不动。尔时文殊师利菩萨。劝诸比丘。住普贤行。住普贤行已入大愿海。入大愿海已成就大愿海。以成就大愿海故心清净。心清净故身清净。身清净故身轻利。身清净轻利故得大神通无有退转。得此神通故不离文殊师利足下。普于十方一切佛所。悉现其身。具足成就一切佛法

大方广佛华严经卷第六十一大方广佛华严经卷第六十二

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之三

尔时文殊师利菩萨。劝诸比丘。发阿耨多罗三藐三菩提心已。渐次南行。经历人间。至福城东。住庄严幢娑罗林中。往昔诸佛曾所止住。教化众生。大塔庙处。亦是世尊。于往昔时。修菩萨行。能舍无量难舍之处。是故此林。名称普闻无量佛刹。此处常为天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人之所供养。时文殊师利。与其眷属。到此处已。即于其处。说普照法界修多罗。百万亿那由他修多罗。以为眷属。说此经时。于大海中。有无量百千亿诸龙。而来其所。闻此法已。深厌龙趣。正求佛道。咸舍龙身。生天人中。一万诸龙。于阿耨多罗三藐三菩提。得不退转。复有无量无数众生。于三乘中。各得调伏。时福城人。闻文殊师利童子。在庄严幢娑罗林中大塔庙处。无量大众。从其城出。来诣其所。时有优婆塞。名曰大智。与五百优婆塞眷属俱。所谓须达多优婆塞。婆须达多优婆塞。福德光优婆塞。有名称优婆塞。施名称优婆塞。月德优婆塞。善慧优婆塞。大慧优婆塞。贤护优婆塞。贤胜优婆塞。如是等五百优婆塞俱。来诣文殊师利童子所。顶礼其足。右绕三匝。退坐一面。复有五百优婆夷。所谓大慧优婆夷。善光优婆夷。妙身优婆夷。可乐身优婆夷。贤优婆夷。贤德优婆夷。贤光优婆夷。幢光优婆夷。德光优婆夷。善目优婆夷。如是等五百优婆夷。来诣文殊师利童子所。顶礼其足。右绕三匝。退坐一面。复有五百童子。所谓善财童子。善行童子。善戒童子。善威仪童子。善勇猛童子。善思童子。善慧童子。善觉童子。善眼童子。善臂童子。善光童子。如是等五百童子。来诣文殊师利童子所。顶礼其足。右绕三匝。退坐一面。复有五百童女。所谓善贤童女。大智居士女童女。贤称童女。美颜童女。坚慧童女。贤德童女。有德童女。梵授童女。德光童女。善光童女。如是等五百童女。来诣文殊师利童子所。顶礼其足。右绕三匝。退坐一面

尔时文殊师利童子。知福城人。悉已来集。随其心乐。现自在身威光赫奕。蔽诸大众。以自在大慈。令彼清凉。以自在大悲。起说法心。以自在智慧。知其心乐。以广大辩才。将为说法。复于是时。观察善财。以何因缘。而有其名。知此童子初入胎时。于其宅内。自然而出七宝楼阁。其楼阁下。有七伏藏。于其藏上。地自开裂。生七宝芽。所谓金银琉璃。玻璃真珠砗磲码瑙。善财童子。处胎十月。然后诞生。形体肢分。端正具足。其七大藏。纵广高下。各满七肘。从地涌出。光明照耀。复于宅中。自然而有五百宝器。种种诸物。自然盈满。所谓金刚器中盛一切香。于香器中盛种种衣。美玉器中盛满种种上味饮食。摩尼器中盛满种种殊异珍宝。金器盛银。银器盛金。金银器中盛满琉璃及摩尼宝。玻璃器中盛满砗磲。砗磲器中盛满玻璃。码瑙器中盛满真珠。真珠器中盛满码瑙。火摩尼器中盛满水摩尼。水摩尼器中盛满火摩尼。如是等五百宝器。自然出现。又雨众宝及诸财物。一切库藏。悉令充满。以此事故。父母亲属。及善相师。共呼此儿。名曰善财。又知此童子。已曾供养过去诸佛。深种善根。信解广大常乐亲近诸善知识。身语意业。皆无过失。净菩萨道。求一切智。成佛法器。其心清净。犹如虚空。回向菩提。无所障碍。尔时文殊师利菩萨。如是观察善财童子已。安慰开谕。而为演说一切佛法。所谓说一切佛积集法。说一切佛相续法。说一切佛次第法。说一切佛众会清净法。说一切佛法轮化导法。说一切佛色身相好法。说一切佛法身成就法。说一切佛言辞辩才法。说一切佛光明照耀法。说一切佛平等无二法。尔时文殊师利童子。为善财童子及诸大众。说此法已。殷勤劝谕。增长势力。令其欢喜。发阿耨多罗三藐三菩提心。又令忆念过去善根。作是事已。即于其处。复为众生。随宜说法。然后而去。尔时善财童子。从文殊师利所。闻佛如是种种功德。一心勤求阿耨多罗三藐三菩提。随文殊师利。而说颂曰

  三有为城廓　　憍慢为垣墙
  诸趣为门户　　爱水为池堑
  愚痴闇所覆　　贪恚火炽然
  魔王作君主　　童蒙依止住
  贪爱为徽缠　　谄诳为辔勒
  疑惑蔽其眼　　趣入诸邪道
  悭嫉憍盈故　　入于三恶处
  或堕诸趣中　　生老病死苦
  妙智清净日　　大悲圆满轮
  能竭烦恼海　　愿赐少观察
  妙智清净月　　大慈无垢轮
  一切悉施安　　愿垂照察我
  一切法界王　　法宝为先导
  游空无所碍　　愿垂教敕我
  福智大商主　　勇猛求菩提
  普利诸群生　　愿垂守护我
  身被忍辱甲　　手提智慧剑
  自在降魔军　　愿垂拔济我
  住法须弥顶　　定女常恭侍
  灭惑阿修罗　　帝释愿观我
  三有凡愚宅　　惑业地趣因
  仁者悉调伏　　如灯示我道
  舍离诸恶趣　　清净诸善道
  超诸世间者　　示我解脱门
  世间颠倒执　　常乐我净想
  智眼悉能离　　开我解脱门
  善知邪正道　　分别心无怯
  一切决了人　　示我菩提路
  住佛正见地　　长佛功德树
  雨佛妙法华　　示我菩提道
  去来现在佛　　处处悉周遍
  如日出世间　　为我说其道
  善知一切业　　深达诸乘行
  智慧决定人　　示我摩诃衍
  愿轮大悲毂　　信轴坚忍辖
  功德宝庄校　　令我载此乘
  总持广大箱　　慈愍庄严盖
  辩才铃震响　　使我载此乘
  梵行为茵蓐　　三昧为采女
  法鼓震妙音　　愿与我此乘
  四摄无尽藏　　功德庄严宝
  惭愧为羁鞅　　愿与我此乘
  常转布施轮　　恒涂净戒香
  忍辱牢庄严　　令我载此乘
  禅定三昧箱　　智慧方便轭
  调伏不退转　　令我载此乘
  大愿清净轮　　总持坚固力
  智慧所成就　　令我载此乘
  普行为周校　　悲心作徐转
  所向皆无怯　　令我载此乘
  坚固如金刚　　善巧如幻化
  一切无障碍　　令我载此乘
  广大极清净　　普与众生乐
  虚空法界等　　令我载此乘
  净诸业惑轮　　断诸流转苦
  摧魔及外道　　令我载此乘
  智慧满十方　　庄严遍法界
  普洽众生类　　令我载此乘
  清净如虚空　　爱见悉除灭
  利益一切众　　令我载此乘
  愿力速疾行　　定心安隐住
  普运诸含识　　令我载此乘
  如地不倾动　　如水普饶益
  如是运众生　　令我载此乘
  四摄圆满轮　　总持清净光
  如是智慧日　　愿示我令见
  已入法王城　　已着智王冠
  已系妙法缯　　愿能慈顾我

尔时文殊师利菩萨。如象王回。观善财童子。作如是言。善哉善哉。善男子。汝已发阿耨多罗三藐三菩提心。复欲亲近诸善知识。问菩萨行。修菩萨道。善男子。亲近供养诸善知识。是具一切智。最初因缘。是故于此。勿生疲厌。善财白言。唯愿圣者。广为我说。菩萨应云何学菩萨行。应云何修菩萨行。应云何趣菩萨行。应云何行菩萨行。应云何净菩萨行。应云何入菩萨行。应云何成就菩萨行。应云何随顺菩萨行。应云何忆念菩萨行。应云何增广菩萨行。应云何令普贤行速得圆满。尔时文殊师利菩萨。为善财童子。而说颂言

  善哉功德藏　　能来至我所
  发起大悲心　　勤求无上觉
  已发广大愿　　除灭众生苦
  普为诸世间　　修行菩萨行
  若有诸菩萨　　不厌生死苦
  则具普贤道　　一切无能坏
  福光福威力　　福处福净海
  汝为诸众生　　愿修普贤行
  汝见无边际　　十方一切佛
  皆悉听闻法　　受持不忘失
  汝于十方界　　普见无量佛
  成就诸愿海　　具足菩萨行
  若入方便海　　安住佛菩提
  能随导师学　　当成一切智
  汝遍一切刹　　微尘等诸劫
  修行普贤行　　成就菩提道
  汝于无量刹　　无边诸劫海
  修行普贤行　　成满诸大愿
  此无量众生　　闻汝愿欢喜
  皆发菩提意　　愿学普贤乘

尔时文殊师利菩萨。说此颂已。告善财童子言。善哉善哉。善男子。汝已发阿耨多罗三藐三菩提心。求菩萨行。善男子。若有众生。能发阿耨多罗三藐三菩提心。是事为难。能发心已。求菩萨行。倍更为难。善男子。若欲成就一切智智。应决定求真善知识。善男子。求善知识勿生疲懈。见善知识勿生厌足。于善知识所有教诲皆应随顺。于善知识善巧方便勿见过失。善男子。于此南方。有一国土。名为胜乐。其国有山。名曰妙峰。于彼山中。有一比丘。名曰德云。汝可往问。菩萨云何学菩萨行。菩萨云何修菩萨行。乃至菩萨云何于普贤行。疾得圆满。德云比丘。当为汝说。尔时善财童子。闻是语已。欢喜踊跃。头顶礼足。绕无数匝。殷勤瞻仰。悲泣流泪。辞退南行。向胜乐国。登妙峰山。于其山上。东西南北。四维上下。观察求觅。渴仰欲见德云比丘。经于七日。见彼比丘在别山上徐步经行。见已往诣。顶礼其足。右绕三匝。于前而住。作如是言。圣者我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨行。乃至应云何于普贤行疾得圆满。我闻圣者。善能诱诲。唯愿垂慈。为我宣说。云何菩萨。而得成就阿耨多罗三藐三菩提。时德云比丘。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。复能请问诸菩萨行。如是之事。难中之难。所谓求菩萨行。求菩萨境界。求菩萨出离道。求菩萨清净道。求菩萨清净广大心。求菩萨成就神通。求菩萨示现解脱门。求菩萨示现世间所作业。求菩萨随顺众生心。求菩萨生死涅槃门。求菩萨观察有为无为心无所著。善男子。我得自在决定解力。信眼清净。智光照曜。普观境界。离一切障。善巧观察。普眼明彻。具清净行。往诣十方一切国土。恭敬供养一切诸佛。常念一切诸佛如来。总持一切诸佛正法。常见一切十方诸佛。所谓见于东方一佛二佛十佛百佛。千佛百千佛。亿佛百亿佛。千亿佛百千亿佛。那由他亿佛。百那由他亿佛。千那由他亿佛。百千那由他亿佛。乃至见无数无量无边无等。不可数不可称。不可思不可量。不可说。不可说不可说佛。乃至见阎浮提微尘数佛。四天下微尘数佛。千世界微尘数佛。二千世界微尘数佛。三千世界微尘数佛。佛刹微尘数佛。乃至不可说不可说佛刹微尘数佛。如东方。南西北方。四维上下。亦复如是。一一方中。所有诸佛。种种色相。种种形貌。种种神通。种种游戏。种种众会庄严道场。种种光明无边照耀。种种国土。种种寿命随诸众生。种种心乐示现种种成正觉门。于大众中。而师子吼。善男子我唯得此忆念一切诸佛境界智慧光明普见法门。岂能了知诸大菩萨无边智慧清净行门。所谓智光普照念佛门。常见一切诸佛国土种种宫殿。悉严净故。令一切众生念佛门。随诸众生心之所乐。皆令见佛。得清净故。令安住力念佛门。令入如来十力中故。令安住法念佛门。见无量佛。听闻法故。照耀诸方念佛门。悉见一切诸世界中。等无差别诸佛海故。入不可见处念佛门。悉见一切微细境中。诸佛自在。神通事故。住于诸劫念佛门。一切劫中。常见如来诸所施为。无暂舍故。住一切时念佛门。于一切时。常见如来。亲近同住。不舍离故。住一切刹念佛门。一切国土。咸见佛身。超过一切无与等故。住一切世念佛门。随于自心之所欲乐。普见三世诸如来故。住一切境念佛门。普于一切诸境界中。见诸如来次第现故。住寂灭念佛门。于一念中。见一切刹。一切诸佛。示涅槃故。住远离念佛门。于一日中。见一切佛。从其所住。而出去故。住广大念佛门。心常观察一一佛身。充遍一切诸法界故。住微细念佛门。于一毛端。有不可说如来出现。悉至其所。而承事故。住庄严念佛门。于一念中。见一切刹。皆有诸佛成等正觉。现神变故。住能事念佛门。见一切佛出现世间。放智慧光。转法轮故。住自在心念佛门。知随自心所有欲乐。一切诸佛。现其像故。住自业念佛门。知随众生所积集业。现其影像。令觉悟故。住神变念佛门。见佛所坐广大莲华。周遍法界。而开敷故。住虚空念佛门。观察如来所有身云。庄严法界虚空界故。而我云何能知能说彼功德行。善男子。南方有国。名曰海门。彼有比丘。名为海云。汝往彼问。菩萨云何学菩萨行。修菩萨道。海云比丘。能分别说发起广大善根因缘。善男子。海云比丘。当令汝入广大助道位。当令汝生广大善根力。当为汝说发菩提心因。当令汝生广大乘光明。当令汝修广大波罗蜜。当令汝入广大诸行海。当令汝满广大誓愿轮。当令汝净广大庄严门。当令汝生广大慈悲力。时善财童子。礼德云比丘足。右绕观察。辞退而去

尔时善财童子。一心思惟善知识教。正念观察智慧光明门。正念观察菩萨解脱门。正念观察菩萨三昧门。正念观察菩萨大海门。正念观察诸佛现前门。正念观察诸佛方所门。正念观察诸佛轨则门。正念观察诸佛等虚空界门。正念观察诸佛出现次第门。正念观察诸佛所入方便门。渐次南行。至海门国。向海云比丘所。顶礼其足。右绕毕已。于前合掌。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。欲入一切无上智海。而未知菩萨云何能舍世俗家生如来家。云何能度生死海入佛智海。云何能离凡夫地入如来地。云何能断生死流入菩萨行流。云何能破生死轮成菩萨愿轮。云何能灭魔境界显佛境界。云何能竭爱欲海长大悲海。云何能闭众难恶趣门开诸天涅槃门。云何能出三界城入一切智城。云何能弃舍一切玩好之物悉以饶益一切众生。时海云比丘。告善财言。善男子。汝已发阿耨多罗三藐三菩提心耶。善财言唯。我已先发阿耨多罗三藐三菩提心。海云言。善男子。若诸众生。不种善根。则不能发阿耨多罗三藐三菩提心。要得普门善根光明。具真实道三昧智光。出生种种广大福海。长白净法无有懈息。事善知识不生疲厌。不顾身命无所藏积。等心如地无有高下。性常慈愍一切众生。于诸有趣。专念不舍。恒乐观察如来境界。如是乃能发菩提心。发菩提心者。所谓发大悲心。普救一切众生故。发大慈心。等祐一切世间故。发安乐心。令一切众生灭诸苦故。发饶益心。令一切众生离恶法故。发哀愍心。有怖畏者。咸守护故。发无碍心。舍离一切。诸障碍故。发广大心。一切法界。咸遍满故。发无边心。等虚空界。无不往故。发宽博心。悉见一切诸如来故。发清净心。于三世法。智无违故。发智慧心。普入一切智慧海故。善男子。我住此海门国。十有二年。常以大海。为其境界。所谓思惟大海广大无量。思惟大海甚深难测。思惟大海渐次深广。思惟大海无量众宝奇妙庄严。思惟大海积无量水。思惟大海水色不同不可思议。思惟大海无量众生之所住处。思惟大海容受种种大身众生。思惟大海能受大云所雨之雨。思惟大海无增无减。善男子。我思惟时。复作是念。世间之中。颇有广博过此海不。颇有无量过此海不。颇有甚深过此海不。颇有殊特过此海不。善男子。我作是念时。此海之下。有大莲华。忽然出现。以无能胜因陀罗尼罗宝为茎。吠琉璃宝为藏。阎浮檀金为叶。沉水为台。码瑙为须。芬敷布濩。弥覆大海。百万阿修罗王执持其茎。百万摩尼宝庄严网弥覆其上。百万龙王雨以香水。百万迦楼罗王衔诸璎珞及宝缯带周匝垂下。百万罗刹王慈心观察。百万夜叉王恭敬礼拜。百万乾闼婆王种种音乐赞叹供养。百万天王雨诸天华。天鬘天香。天烧香。天涂香。天末香。天妙衣服。天幢幡盖。百万梵王头顶礼敬。百万净居天合掌作礼。百万转轮王各以七宝庄严供养。百万海神俱时出现恭敬顶礼。百万味光摩尼宝光明普照。百万净福摩尼宝以为庄严。百万普光摩尼宝为清净藏。百万殊胜摩尼宝其光赫奕。百万妙藏摩尼宝光照无边。百万阎浮幢摩尼宝次第行列。百万金刚师子摩尼宝不可破坏清净庄严。百万日藏摩尼宝广大清净。百万可乐摩尼宝具种种色。百万如意摩尼宝庄严无尽。光明照耀此大莲华。如来出世。善根所起。一切菩萨。皆生信乐。十方世界。无不现前。从如幻法生。如梦法生。清净业生。无诤法门之所庄严。入无为印。住无碍门。充满十方一切国土。随顺诸佛甚深境界。于无数百千劫。叹其功德。不可得尽。我时见彼莲华之上。有一如来。结跏趺坐。其身从此上至有顶宝莲华座不可思议道场众会不可思议。诸相成就不可思议。随好圆满不可思议。神通变化不可思议。色相清净不可思议。无见顶相不可思议。广长舌相不可思议。善巧言说不可思议。圆满音声不可思议。无边际力不可思议。清净无畏不可思议。广大辩才不可思议。又念彼佛往修诸行不可思议。自在成道不可思议。妙音演法不可思议。普门示现种种庄严不可思议。随其左右见各差别不可思议。一切利益皆令圆满不可思议。时此如来。即伸右手。而摩我顶。为我演说普眼法门。开示一切如来境界。显发一切菩萨诸行。阐明一切诸佛妙法。一切法轮。悉入其中。能净一切诸佛国土。能摧一切异道邪论。能灭一切诸魔军众。能令众生。皆生欢喜。能照一切众生心行。能了一切众生诸根。随众生心。悉令开悟。我从于彼如来之所闻此法门。受持读诵。忆念观察。假使有人。以大海量墨。须弥聚笔。书写于此普眼法门。一品中一门。一门中一法。一法中一义。一义中一句。不得少分。何况能尽。善男子。我于彼佛所。千二百岁。受持如是普眼法门。于日日中。以闻持陀罗尼光明。领受无数品。以寂静门陀罗尼光明。趣入无数品。以无边旋陀罗尼光明。普入无数品。以随地观察陀罗尼光明。分别无数品。以威力陀罗尼光明。普摄无数品。以莲华庄严陀罗尼光明。引发无数品。以清净言音陀罗尼光明。开演无数品。以虚空藏陀罗尼光明。显示无数品。以光聚陀罗尼光明。增广无数品。以海藏陀罗尼光明。辨析无数品。若有众生。从十方来。若天若天王。若龙若龙王。若夜叉若夜叉王。若乾闼婆若乾闼婆王。若阿修罗若阿修罗王。若迦楼罗若迦楼罗王。若紧那罗若紧那罗王。若摩睺罗伽若摩睺罗伽王。若人若人王。若梵若梵王。如是一切。来至我所。我悉为其。开示解释。称扬赞叹。咸令爱乐。趣入安住此诸佛菩萨行光明普眼法门。善男子。我唯知此普眼法门。如诸菩萨摩诃萨。深入一切菩萨行海。随其愿力。而修行故。入大愿海。于无量劫住世间故。入一切众生海。随其心乐广利益故。入一切众生心海。出生十力无碍智光故。入一切众生根海。应时教化悉令调伏故。入一切刹海。成满本愿严净佛刹故。入一切佛海。愿常供养诸如来故。入一切法海。能以智慧咸悟入故。入一切功德海。一一修行令具足故。入一切众生言辞海。于一切刹转正法轮故。而我云何。能知能说彼功德行。善男子。从此南行。六十由旬。楞伽道边。有一聚落。名为海岸。彼有比丘。名曰善住。汝诣彼问。菩萨云何净菩萨行。时善财童子。礼海云足。右绕瞻仰。辞退而去

尔时善财童子。专念善知识教。专念普眼法门。专念佛神力。专持法句云。专入法海门。专思法差别。深入法漩澓。普入法虚空。净治法翳障。观察法宝处。渐次南行。至楞伽道海岸聚落。观察十方。求觅善住。见此比丘于虚空中来往经行。无数诸天。恭敬围绕。散诸天华。作天妓乐。幡幢缯绮。悉各无数。遍满虚空。以为供养。诸大龙王。于虚空中。兴不思议。沉水香云。震雷激电。以为供养。紧那罗王。奏众乐音。如法赞美。以为供养。摩睺罗伽王。以不思议极微细衣。于虚空中。周回布设。心生欢喜。以为供养。阿修罗王。兴不思议摩尼宝云。无量光明。种种庄严。遍满虚空。以为供养。迦楼罗王。作童子形无量采女之所围绕。究竟成就无杀害心。于虚空中。合掌供养。不思议数诸罗刹王。无量罗刹之所围绕。其形长大甚可怖畏。见善住比丘。慈心自在。曲躬合掌。瞻仰供养。不思议数诸夜叉王。各各悉有自众围绕。四面周匝。恭敬守护。不思议数诸梵天王。于虚空中。曲躬合掌。以人间法。称扬赞叹。不思议数诸净居天。于虚空中。与宫殿俱。恭敬合掌。发弘誓愿。时善财童子。见是事已。心生欢喜。合掌敬礼。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何修行佛法。云何积集佛法。云何备具佛法。云何熏习佛法。云何增长佛法。云何总摄佛法。云何究竟佛法。云何净治佛法。云何深净佛法。云何通达佛法。我闻圣者。善能诱诲。唯愿慈哀。为我宣说。菩萨云何不舍见佛。常于其所。精勤修习。菩萨云何不舍菩萨。与诸菩萨。同一善根。菩萨云何不舍佛法。悉以智慧。而得明证。菩萨云何不舍大愿。能普利益一切众生。菩萨云何不舍众行。住一切劫。心无疲厌。菩萨云何不舍佛刹。普能严净一切世界。菩萨云何不舍佛力。悉能知见如来自在。菩萨云何不舍有为。亦复不住。普于一切诸有趣中。犹如变化。示受生死。修菩萨行。菩萨云何不舍闻法。悉能领受诸佛正教。菩萨云何不舍智光。普入三世智所行处。时善住比丘。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。今复发心。求问佛法一切智法自然者法。善男子。我已成就菩萨无碍解脱门。若来若去。若行若止。随顺思惟。修习观察。即时获得智慧光明。名究竟无碍。得此智慧光明故。知一切众生心行。无所障碍。知一切众生没生。无所障碍。知一切众生宿命。无所障碍。知一切众生未来劫事。无所障碍。知一切众生现在世事。无所障碍。知一切众生言语音声种种差别。无所障碍。决一切众生所有疑问。无所障碍。知一切众生诸根。无所障碍。随一切众生应受化时。悉能往赴。无所障碍。知一切刹那罗婆。牟呼栗多日夜时分。无所障碍。知三世海流转次第。无所障碍。能以其身遍往十方一切佛刹。无所障碍。何以故。得无住无作神通力故。善男子。我以得此神通力故。于虚空中。或行或住。或坐或卧。或隐或显。或现一身。或现多身。穿度墙壁。犹如虚空。于虚空中。结跏趺坐。往来自在。犹如飞鸟。入地如水。履水如地。遍身上下。普出烟焰。如大火聚。或时震动一切大地。或时以手摩触日月。或现其身。高至梵宫。或现烧香云。或现宝焰云。或现变化云。或现光网云。皆悉广大。弥覆十方。或一念中。过于东方一世界二世界。百世界千世界。百千世界。乃至无量世界。乃至不可说不可说世界。或过阎浮提微尘数世界。或过不可说不可说佛刹微尘数世界。于彼一切诸佛国土佛世尊前。听闻说法。一一佛所。现无量佛刹微尘数差别身。一一身。雨无量佛刹微尘数供养云。所谓一切华云。一切香云。一切鬘云。一切末香云。一切涂香云。一切盖云。一切衣云。一切幢云。一切幡云。一切帐云。以一切身云。而为供养。一一如来。所有宣说。我皆受持。一一国土。所有庄严。我皆忆念。如东方。南西北方。四维上下。亦复如是。如是一切诸世界中。所有众生。若见我形。皆决定得阿耨多罗三藐三菩提。彼诸世界。一切众生。我皆明见。随其大小胜劣苦乐。示同其形。教化成就。若有众生。亲近我者。悉令安住如是法门。善男子。我唯知此普速疾供养诸佛成就众生无碍解脱门。如诸菩萨。持大悲戒。波罗蜜戒。大乘戒。菩萨道相应戒。无障碍戒。不退堕戒。不舍菩提心戒。常以佛法为所缘戒。于一切智常作意戒。如虚空戒。一切世间无所依戒。无失戒。无损戒。无缺戒。无杂戒。无浊戒。无悔戒。清净戒。离尘戒。离垢戒。如是功德。而我云何能知能说。善男子。从此南方有国。名达里鼻荼。城名自在。其中有人。名曰弥伽。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。右绕瞻仰。辞退而行

大方广佛华严经卷第六十二大方广佛华严经卷第六十三

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之四

尔时善财童子。一心正念法光明法门。深信趣入。专念于佛。不断三宝。叹离欲性。念善知识。普照三世。忆诸大愿。普救众生。不著有为。究竟思惟诸法自性。悉能严净一切世界。于一切佛众会道场。心无所著。渐次南行。至自在城。求觅弥伽。乃见其人。于市肆中。坐于说法师子之座。十千人众。所共围绕。说轮字庄严法门。时善财童子。顶礼其足。绕无量匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而我未知菩萨云何学菩萨行。云何修菩萨道。云何流转于诸有趣常不忘失菩提之心。云何得平等意坚固不动。云何获清净心无能沮坏。云何生大悲力恒不劳疲。云何入陀罗尼普得清净。云何发生智慧广大光明。于一切法离诸暗障。云何具无碍解辩才之力。决了一切甚深义藏。云何得正念力。忆持一切差别法轮。云何得净趣力。于一切趣普演诸法。云何得智慧力。于一切法悉能决定分别其义。尔时弥伽。告善财言。善男子。汝已发阿耨多罗三藐三菩提心耶。善财言唯。我已先发阿耨多罗三藐三菩提心。弥伽遽即下师子座。于善财所。五体投地。散金银华无价宝珠。及以上妙碎末栴檀无量种衣。以覆其上。复散无量种种香华。种种供具。以为供养。然后起立。而称叹言。善哉善哉。善男子。乃能发阿耨多罗三藐三菩提心。善男子。若有能发阿耨多罗三藐三菩提心。则为不断一切佛种。则为严净一切佛刹。则为成熟一切众生。则为了达一切法性。则为悟解一切业种。则为圆满一切诸行。则为不断一切大愿。则如实解离贪种性。则能明见三世差别。则令信解永得坚固。则为一切如来所持。则为一切诸佛忆念。则与一切菩萨平等。则为一切贤圣赞喜。则为一切梵王礼觐。则为一切天主供养。则为一切夜叉守护。则为一切罗刹侍卫。则为一切龙王迎接。则为一切紧那罗王歌咏赞叹。则为一切诸世间主称扬庆悦。则令一切诸众生界悉得安隐。所谓令舍恶趣故。令出难处故。断一切贫穷根本故。生一切天人快乐故。遇善知识亲近故。闻广大法受持故。生菩提心故。净菩提心故。照菩萨道故。入菩萨智故。住菩萨地故。善男子。应知菩萨。所作甚难。难出难值。见菩萨者。倍更难有。菩萨为一切众生恃怙。生长成就故。为一切众生拯济。拔诸苦难故。为一切众生依处。守护世间故。为一切众生救护。令免怖畏故。菩萨如风轮。持诸世间。不令堕落恶趣故。如大地。增长众生善根故。如大海。福德充满无尽故。如净日。智慧光明普照故。如须弥。善根高出故。如明月。智光出现故。如猛将。摧伏魔军故。如君主。佛法城中得自在故。如猛火。烧尽众生我爱心故。如大云。降霔无量妙法雨故。如时雨。增长一切信根芽故。如船师。示导法海津济处故。如桥梁。令其得度生死海故。弥伽如是。赞叹善财。令诸菩萨。皆欢喜已。从其面门。出种种光。普照三千大千世界。其中众生。遇斯光已。诸龙神等。乃至梵天。悉皆来至弥伽之所。弥伽大士。即以方便。为开示演说分别解释轮字品庄严法门。彼诸众生。闻此法已。皆于阿耨多罗三藐三菩提。得不退转。弥伽于是。还升本座。告善财言。善男子。我已获得妙音陀罗尼。能分别知三千大千世界中。诸天语言。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。及诸梵天。所有语言。如此三千大千世界十方无数。乃至不可说不可说世界。悉亦如是。善男子。我唯知此菩萨妙音陀罗尼光明法门。如诸菩萨摩诃萨。能普入一切众生种种想海。种种施设海。种种名号海。种种语言海。能普入说一切深密法句海。说一切究竟法句海。说一所缘中有一切三世所缘法句海。说上法句海。说上上法句海。说差别法句海。说一切差别法句海。能普入一切世间咒术海。一切音声庄严轮一切差别字轮际。如是功德。我今云何能知能说。善男子。从此南行。有一聚落。名曰住林。彼有长者。名曰解脱。汝诣彼问。菩萨云何修菩萨行。菩萨云何成菩萨行。菩萨云何集菩萨行。菩萨云何思菩萨行。尔时善财童子。以善知识故。于一切智法。深生尊重。深植净信。深自增益。礼弥伽足。涕泗悲泣。绕无量匝。恋慕瞻仰。辞退而行

尔时善财童子。思惟诸菩萨无碍解陀罗尼光明庄严门。深入诸菩萨语言海门。忆念诸菩萨知一切众生微细方便门。观察诸菩萨清净心门。成就诸菩萨善根光明门。净治诸菩萨教化众生门。明利诸菩萨摄众生智门。坚固诸菩萨广大志乐门。住持诸菩萨殊胜志乐门。净治诸菩萨种种信解门。思惟诸菩萨无量善心门。誓愿坚固。心无疲厌。以诸甲胄。而自庄严。精进深心。不可退转。具不坏信。其心坚固。犹如金刚及那罗延。无能坏者。守持一切善知识教。于诸境界。得不坏智。普门清净。所行无碍。智光圆满。普照一切。具足诸地。总持光明。了知法界种种差别。无依无住。平等无二。自性清净。而普庄严。于诸所行。皆得究竟。智慧清净。离诸执着。知十方差别法。智无障碍。往十方差别处。身不疲懈。于十方差别业。皆得明了。于十方差别佛。无不现见。于十方差别时。悉得深入。清净妙法。充满其心。普智三昧。明照其心。心恒普入平等境界。如来智慧之所照触。一切智流。相续不断。若身若心。不离佛法。一切诸佛。神力所加。一切如来。光明所照。成就大愿。愿身周遍一切刹网。一切法界普入其身。渐次游行。十有二年。至住林城。周遍推求解脱长者。既得见已。五体投地。起立合掌。白言圣者。我今得与善知识会。是我获得广大善利。何以故。善知识者。难可得见。难可得闻。难可出现。难得奉事。难得亲近。难得承接。难可逢值。难得共居。难令喜悦。难得随逐。我今会遇为得善利。圣者。我已先发阿耨多罗三藐三菩提心。为欲事一切佛故。为欲值一切佛故。为欲见一切佛故。为欲观一切佛故。为欲知一切佛故。为欲证一切佛平等故。为欲发一切佛大愿故。为欲满一切佛大愿故。为欲具一切佛智光故。为欲成一切佛众行故。为欲得一切佛神通故。为欲具一切佛诸力故。为欲获一切佛无畏故。为欲闻一切佛法故。为欲受一切佛法故。为欲持一切佛法故。为欲解一切佛法故。为欲护一切佛法故。为欲与一切诸菩萨众同一体故。为欲与一切菩萨善根等无异故。为欲圆满一切菩萨波罗蜜故。为欲成就一切菩萨所修行故。为欲出生一切菩萨清净愿故。为欲得一切诸佛菩萨威神藏故。为欲得一切菩萨法藏无尽智慧大光明故。为欲得一切菩萨三昧广大藏故。为欲成就一切菩萨无量无数神通藏故。为欲以大悲藏教化调伏一切众生。皆令究竟到边际故。为欲显现神变藏故。为于一切自在藏中悉以自心得自在故。为欲入于清净藏中以一切相而庄严故。圣者我今。以如是心。如是意。如是乐。如是欲。如是希求。如是思惟。如是尊重。如是方便。如是究竟。如是谦下。至圣者所。我闻圣者。善能诱诲诸菩萨众。能以方便。阐明所得。示其道路。与其津梁。授其法门。令除迷倒障。拔犹豫箭。截疑惑网。照心稠林。浣心垢浊。令心洁白。使心清凉。正心谄曲。绝心生死。止心不善。解心执着。于执着处。令心解脱。于染爱处。使心动转。令其速入一切智境。使其疾到无上法城。令住大悲。令住大慈。令入菩萨行。令修三昧门。令入证位。令观法性。令增长力。令修习行。普于一切。其心平等。唯愿圣者。为我宣说。菩萨云何学菩萨行。修菩萨道。随所修习。疾得清净。疾得明了。时解脱长者。以过去善根力佛威神力。文殊师利童子忆念力故。即入菩萨三昧门。名普摄一切佛刹无边旋陀罗尼。入此三昧已。得清净身。于其身中。显现十方各十佛刹微尘数佛。及佛国土。众会道场。种种光明。诸庄严事。亦现彼佛往昔所行。神通变化。一切大愿。助道之法。诸出离行。清净庄严。亦见诸佛成等正觉。转妙法轮。教化众生。如是一切。于其身中。悉皆显现。无所障碍。种种形相。种种次第。如本而住。不相杂乱。所谓种种国土。种种众会。种种道场。种种严饰。其中诸佛。现种种神力。立种种乘道。示种种愿门。或于一世界处兜率宫。而作佛事。或于一世界没兜率宫。而作佛事。如是或有住胎。或复诞生。或处宫中。或复出家。或诣道场。或破魔军。或诸天龙。恭敬围绕。或诸世主。劝请说法。或转法轮。或般涅槃。或分舍利。或起塔庙。彼诸如来。于种种众会。种种世间。种种趣生。种种家族。种种欲乐。种种业行。种种语言。种种根性。种种烦恼。随眠习气。诸众生中。或处微细道场。或处广大道场。或处一由旬量道场。或处十由旬量道场。或处不可说不可说佛刹微尘数由旬量道场。以种种神通。种种言辞。种种音声。种种法门。种种总持门。种种辩才门。以种种圣谛海。种种无畏。大师子吼。说诸众生种种善根。种种忆念。授种种菩萨记。说种种诸佛法。彼诸如来。所有言说。善财童子。悉能听受。亦见诸佛及诸菩萨。不可思议。三昧神变。尔时解脱长者。从三昧起。告善财童子言。善男子。我已入出如来无碍庄严解脱门。善男子。我入出此解脱门时。即见东方阎浮檀金光明世界。龙自在王如来应正等觉。道场众会之所围绕。毗卢遮那藏菩萨。而为上首。又见南方速疾力世界。普香如来应正等觉。道场众会之所围绕。心王菩萨。而为上首。又见西方香光世界。须弥灯王如来应正等觉。道场众会之所围绕。无碍心菩萨。而为上首。又见北方袈裟幢世界。不可坏金刚如来应正等觉。道场众会之所围绕。金刚步勇猛菩萨。而为上首。又见东北方一切上妙宝世界。无所得境界眼如来应正等觉。道场众会之所围绕。无所得善变化菩萨。而为上首。又见东南方。香焰光音世界。香灯如来应正等觉。道场众会之所围绕。金刚焰慧菩萨。而为上首。又见西南方智慧日普光明世界。法界轮幢如来应正等觉。道场众会之所围绕。现一切变化幢菩萨。而为上首。又见西北方普清净世界。一切佛宝高胜幢如来应正等觉。道场众会之所围绕。法幢王菩萨。而为上首。又见上方佛次第出现无尽世界。无边智慧光圆满幢如来应正等觉。道场众会之所围绕。法界门幢王菩萨。而为上首。又见下方佛光明世界。无碍智幢如来应正等觉。道场众会之所围绕。一切世间刹幢王菩萨。而为上首。善男子。我见如是等十方各十佛刹微尘数如来。彼诸如来。不来至此。我不往彼。我若欲见安乐世界阿弥陀如来。随意即见。我若欲见栴檀世界金刚光明如来。妙香世界宝光明如来。莲华世界宝莲华光明如来。妙金世界寂静光如来。妙喜世界不动如来。善住世界师子如来。镜光明世界月觉如来。宝师子庄严世界毗卢遮那如来。如是一切。悉皆即见。然彼如来。不来至此。我身亦不往诣于彼。知一切佛及与我心。悉皆如梦。知一切佛犹如影像。自心如水。知一切佛所有色相。及以自心。悉皆如幻。知一切佛及以己心。悉皆如响。我如是知。如是忆念。所见诸佛。皆由自心。善男子。当知菩萨修诸佛法。净诸佛刹。积集妙行。调伏众生。发大誓愿。入一切智自在游戏不可思议解脱之门。得佛菩提。现大神通。遍往一切十方法界。以微细智。普入诸劫如是一切。悉由自心。是故。善男子。应以善法。扶助自心。应以法水。润泽自心。应于境界。净治自心。应以精进。坚固自心。应以忍辱。坦荡自心。应以智证。洁白自心。应以智慧。明利自心。应以佛自在。开发自心。应以佛平等。广大自心。应以佛十力。照察自心。善男子。我唯于此如来无碍庄严解脱门。而得入出。如诸菩萨摩诃萨。得无碍智。住无碍行。得常见一切佛三昧。得不住涅槃际三昧。了达三昧。普门境界。于三世法。悉皆平等。能善分身。遍一切刹。住于诸佛平等境界。十方境界。皆悉现前。智慧观察。无不明了。于其身中。悉现一切世界成坏。而于己身及诸世界。不生二想。如是妙行。而我云何。能知能说。善男子。从此南行。至阎浮提畔。有一国土。名摩利伽罗。彼有比丘。名曰海幢。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼解脱长者足。右绕观察。称扬赞叹。思惟恋仰。悲泣流泪。一心忆念。依善知识。事善知识。敬善知识。由善知识。见一切智。于善知识。不生违逆。于善知识。心无谄诳。于善知识。心常随顺。于善知识。起慈母想。舍离一切无益法故。于善知识。起慈父想。出生一切诸善法故。辞退而去

尔时善财童子。一心正念彼长者教。观察彼长者教。忆念彼不思议菩萨解脱门。思惟彼不思议菩萨智光明。深入彼不思议法界门。趣向彼不思议菩萨普入门。明见彼不思议如来神变。解了彼不思议普入佛刹。分别彼不思议佛力庄严。思惟彼不思议菩萨三昧解脱境界分位。了达彼不思议差别世界究竟无碍。修行彼不思议菩萨坚固深心。发起彼不思议菩萨大愿净业。渐次南行。至阎浮提畔。摩利聚落。周遍求觅海幢比丘。乃见其在经行地侧。结跏趺坐。入于三昧。离出入息。无别思觉。身安不动。从其足下。出无数百千亿长者居士。婆罗门众。皆以种种诸庄严具。庄严其身。悉着宝冠。顶系明珠。普往十方一切世界。雨一切宝。一切璎珞。一切衣服。一切饮食。如法上味。一切华一切鬘。一切香一切涂香。一切欲乐。资生之具。于一切处。救摄一切贫穷众生。安慰一切苦恼众生。皆令欢喜。心意清净。成就无上菩提之道。从其两膝。出无数百千亿刹帝利。婆罗门众。皆悉聪慧。种种色相。种种形貌。种种衣服。上妙庄严。普遍十方一切世界。爱语同事。摄诸众生。所谓贫者令足。病者令愈。危者令安。怖者令止。有忧苦者。咸使快乐。复以方便。而劝导之。皆令舍恶。安住善法。从其腰间。出等众生数无量仙人。或服草衣。或树皮衣。皆执澡瓶。威仪寂静。周旋往返十方世界。于虚空中。以佛妙音。称赞如来。演说诸法。或说清净梵行之道。令其修习。调伏诸根。或说诸法皆无自性。使其观察。发生智慧。或说世间言论轨则。或复开示一切智智出要方便。令随次第各修其业。从其两胁。出不思议龙。不思议龙女。示现不思议诸龙神变。所谓雨不思议香云。不思议华云。不思议鬘云。不思议宝盖云。不思议宝幡云。不思议妙宝庄严具云。不思议大摩尼宝云。不思议宝璎珞云。不思议宝座云。不思议宝宫殿云。不思议宝莲华云。不思议宝冠云。不思议天身云。不思议采女云。悉遍虚空。而为庄严。充满一切十方世界。诸佛道场。而为供养。令诸众生。皆生欢喜。从胸前卍字中。出无数百千亿阿修罗王。皆悉示现不可思议自在幻力。令百世界。皆大震动。一切海水。自然涌沸。一切山王。互相冲击。诸天宫殿。无不动摇。诸魔光明。无不隐蔽。诸魔兵众。无不摧伏。普令众生舍憍慢心。除怒害心。破烦恼山。息众恶法。长无斗诤。永共和善。复以幻力。开悟众生。令灭罪恶。令怖生死。令出诸趣。令离染着。令住无上菩提之心。令修一切诸菩萨行。令住一切诸波罗蜜。令入一切诸菩萨地。令观一切微妙法门。令知一切诸佛方便。如是所作。周遍法界。从其背上。为应以二乘而得度者。出无数百千亿声闻独觉。为着我者。说无有我。为执常者。说一切行皆悉无常。为贪行者。说不净观。为嗔行者。说慈心观。为痴行者。说缘起观。为等分行者。说与智慧相应境界法。为乐着境界者。说无所有法。为乐着寂静处者。说发大誓愿普饶益一切众生法。如是所作。周遍法界。从其两肩。出无数百千亿诸夜叉罗刹王。种种形貌。种种色相。或长或短。皆可怖畏。无量眷属。而自围绕。守护一切行善众生。并诸贤圣。菩萨众会。若向正住。及正住者。或时现作执金刚神。守护诸佛及佛住处。或遍守护一切世间。有怖畏者。令得安隐。有疾病者。令得除差。有苦恼者。令得免离。有过恶者。令其厌悔。有灾横者。令其息灭。如是利益一切众生。皆悉令其舍生死轮转正法轮。从其腹出无数百千亿紧那罗王。各有无数紧那罗女。前后围绕。又出无数百千亿乾闼婆王。各有无数乾闼婆女。前后围绕。各奏无数百千天乐。歌咏赞叹诸法实性。歌咏赞叹一切诸佛。歌咏赞叹发菩提心。歌咏赞叹修菩萨行。歌咏赞叹一切诸佛成正觉门。歌咏赞叹一切诸佛转法轮门。歌咏赞叹一切诸佛现神变门。开示演说一切诸佛般涅槃门。开示演说守护一切诸佛教门。开示演说令一切众生皆欢喜门。开示演说严净一切诸佛刹门。开示演说显示一切微妙法门。开示演说舍离一切诸障碍门。开示演说发生一切诸善根门。如是周遍十方法界。从其面门。出无数百千亿转轮圣王。七宝具足。四兵围绕。放大舍光。雨无量宝。诸贫乏者。悉使充足。令其永断不与取行。端正采女无数百千。悉以舍施心无所著。令其永断邪淫之行。令生慈心。不断生命。令其究竟常真实语。不作虚诳无益谈说。令摄他语。不行离间。令柔软语。无有粗恶。令常演说甚深决定明了之义。不作无义绮饰言辞。为说少欲。令除贪爱。心无瑕垢。为说大悲。令除忿怒意得清净。为说实义。令其观察一切诸法。深入因缘。善明谛理。拔邪见刺。破疑惑山。一切障碍。悉皆除灭。如是所作。充满法界。从其两目。出无数百千亿日轮。普照一切诸大地狱及诸恶趣。皆令离苦。又照一切世界中间。令除黑暗。又照一切十方众生。皆令舍离愚痴翳障。于垢浊国土放清净光。白银国土。放黄金色光。黄金国土。放白银色光。琉璃国土。放玻璃色光。玻璃国土。放琉璃色光。砗磲国土。放码瑙色光。码瑙国土。放砗磲色光。帝青国土。放日藏摩尼王色光。日藏摩尼王国土。放帝青色光。赤真珠国土。放月光网藏摩尼王色光。月光网藏摩尼王国土。放赤真珠色光。一宝所成国土。放种种宝色光。种种宝所成国土。放一宝色光。照诸众生心之稠林。辨诸众生无量事业。严饰一切世间境界。令诸众生。心得清凉。生大欢喜。如是所作。充满法界。从其眉间白毫相中。出无数百千亿帝释。皆于境界。而得自在。摩尼宝珠。系其顶上。光照一切诸天宫殿。震动一切须弥山王。觉悟一切诸天大众。叹福德力。说智慧力。生其乐力。持其志力。净其念力。坚其所发菩提心力。赞乐见佛。令除世欲。赞乐闻法。令厌世境。赞乐观智。令绝世染。止修罗战。断烦恼诤。灭怖死心。发降魔愿。兴立正法须弥山王。成辨众生一切事业。如是所作。周遍法界。从其额上。出无数百千亿梵天。色相端严。世间无比。威仪寂静。言音美妙。劝佛说法。叹佛功德。令诸菩萨。悉皆欢喜。能辨众生无量事业。普遍一切十方世界。从其头上。出无量佛刹微尘数诸菩萨众。悉以相好。庄严其身。放无边光。说种种行。所谓赞叹布施。令舍悭贪。得众妙宝。庄严世界。称扬赞叹持戒功德。令诸众生。永断诸恶。住于菩萨大慈悲戒。说一切有悉皆如梦。说诸欲乐无有滋味。令诸众生。离烦恼缚。说忍辱力。令于诸法。心得自在。赞金色身。令诸众生。离嗔恚垢。起对治行。绝畜生道。叹精进行。令其远离世间放逸。皆悉勤修无量妙法。又为赞叹禅波罗蜜。令其一切心得自在。又为演说般若波罗蜜。开示正见。令诸众生。乐自在智。拔诸见毒。又为演说随顺世间种种所作。令诸众生。虽离生死。而于诸趣。自在受生。又为示现神通变化。说寿命自在。令诸众生。发大誓愿。又为演说成就总持力。出生大愿力。净治三昧力。自在受生力。又为演说种种诸智。所谓普知众生诸根智。普知一切心行智。普知如来十力智。普知诸佛自在智。如是所作。周遍法界。从其顶上。出无数百千亿如来身。其身无等。诸相随好。清净庄严。威光赫奕。如真金山。无量光明。普照十方。出妙音声。充满法界。示现无量大神通力。为一切世间。普雨法雨。所谓为坐菩提道场诸菩萨雨普知平等法雨。为灌顶位诸菩萨雨入普门法雨。为法王子位诸菩萨雨普庄严法雨。为童子位诸菩萨雨坚固山法雨。为不退位诸菩萨雨海藏法雨。为成就正心位诸菩萨雨普境界法雨。为方便具足位诸菩萨雨自性门法雨。为生贵位诸菩萨雨随顺世间法雨。为修行位诸菩萨雨普悲愍法雨。为新学诸菩萨雨积集藏法雨。为初发心诸菩萨雨摄众生法雨。为信解诸菩萨雨无尽境界普现前法雨。为色界诸众生雨普门法雨。为诸梵天雨普藏法雨。为诸自在天雨生力法雨。为诸魔众雨心幢法雨。为诸化乐天雨净念法雨。为诸兜率天雨生意法雨。为诸夜摩天雨欢喜法雨。为诸忉利天雨疾庄严虚空界法雨。为诸夜叉王雨欢喜法雨。为诸乾闼婆王雨金刚轮法雨。为诸阿修罗王雨大境界法雨。为诸迦楼罗王雨无边光明法雨。为诸紧那罗王雨一切世间殊胜智法雨。为诸人王雨无乐着法雨。为诸龙王雨欢喜幢法雨。为诸摩睺罗伽王雨大休息法雨。为诸地狱众生雨正念庄严法雨。为诸畜生雨智慧藏法雨。为阎罗王界众生雨无畏法雨。为诸厄难处众生雨普安慰法雨。悉令得入贤圣众会。如是所作。充满法界。海幢比丘。又于其身一切毛孔。一一皆出阿僧祇佛刹微尘数光明网。一一光明网。具阿僧祇色相。阿僧祇庄严。阿僧祇境界。阿僧祇事业。充满十方一切法界。尔时善财童子。一心观察海幢比丘。深生渴仰。忆念彼三昧解脱。思惟彼不思议菩萨三昧。思惟彼不思议利益众生方便海。思惟彼不思议无作用普庄严门。思惟彼庄严法界清净智。思惟彼受佛加持智。思惟彼出生菩萨自在力。思惟彼坚固菩萨大愿力。思惟彼增广菩萨诸行力。如是住立。思惟观察。经一日一夜。乃至经于七日七夜。半月一月。乃至六月。复经六日。过此已后。海幢比丘。从三昧出。善财童子。赞言圣者。希有奇特。如此三昧最为甚深。如此三昧最为广大。如此三昧境界无量。如此三昧神力难思。如此三昧光明无等。如此三昧庄严无数。如此三昧威力难制。如此三昧境界平等。如此三昧普照十方。如此三昧利益无限。以能除灭一切众生无量苦故。所谓能令一切众生。离贫苦故。出地狱故。免畜生故。闭诸难门故。开人天道故。令人天众生喜乐故。令其爱乐禅境界故。能令增长有为乐故。能为显示出有乐故。能为引发菩提心故。能使增长福智行故。能令增长大悲心故。能令生起大愿力故。能令明了菩萨道故。能使庄严究竟智故。能令趣入大乘境故。能令照了普贤行故。能令证得诸菩萨地智光明故。能令成就一切菩萨诸愿行故。能令安住一切智智境界中故。圣者。此三昧者。名为何等。海幢比丘言。善男子。此三昧。名普眼舍得。又名般若波罗蜜境界清净光明。又名普庄严清净门。善男子。我以修习般若波罗蜜故。得此普庄严清净三昧等百万阿僧祇三昧。善财童子言。圣者。此三昧境界。究竟唯如是耶。海幢言。善男子。入此三昧时。了知一切世界。无所障碍。往诣一切世界。无所障碍。超过一切世界。无所障碍。庄严一切世界。无所障碍。修治一切世界。无所障碍。严净一切世界。无所障碍。见一切佛。无所障碍。观一切佛广大威德。无所障碍。知一切佛自在神力。无所障碍。证一切佛诸广大力。无所障碍。入一切佛诸功德海。无所障碍。受一切佛无量妙法。无所障碍。入一切佛法中修习妙行。无所障碍。证一切佛转法轮平等智。无所障碍。入一切诸佛众会道场海。无所障碍。观十方佛法。无所障碍。大悲摄受十方众生。无所障碍。常起大慈充满十方。无所障碍。见十方佛心无厌足。无所障碍。入一切众生海。无所障碍。知一切众生根海。无所障碍。知一切众生诸根差别智。无所障碍。善男子。我唯知此一般若波罗蜜三昧光明。如诸菩萨。入智慧海。净法界境。达一切趣。遍无量刹。总持自在。三昧清净。神通广大。辩才无尽。善说诸地。为众生依。而我何能知其妙行。辨其功德。了其所行。明其境界。究其愿力。入其要门。达其所证。说其道分。住其三昧。见其心境。得其所有。平等智慧。善男子。从此南行。有一住处。名曰海潮。彼有园林。名普庄严。于其园中。有优婆夷。名曰休舍。汝往彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。于海幢比丘所。得坚固身。获妙法财。入深境界。智慧明彻。三昧照耀。住清净解。见甚深法。其心安住诸清净门。智慧光明。充满十方。心生欢喜。踊跃无量。五体投地。顶礼其足。绕无量匝。恭敬瞻仰。思惟观察。咨嗟恋慕。持其名号。想其容止。念其音声。思其三昧及彼大愿所行境界。受其智慧清净光明。辞退而行

大方广佛华严经卷第六十三大方广佛华严经卷第六十四

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之五

尔时善财童子。蒙善知识力。依善知识教。念善知识语。于善知识。深心爱乐。作是念言。因善知识。令我见佛。因善知识。令我闻法。善知识者。是我师傅。示导于我诸佛法故。善知识者。是我眼目。令我见佛如虚空故。善知识者。是我津济。令我得入诸佛如来莲华池故。渐渐南行。至海潮处。见普庄严园。众宝垣墙。周匝围绕。一切宝树。行列庄严。一切宝华树。雨众妙华。布散其地。一切宝香树。香气氛氲。普熏十方。一切宝鬘树。雨大宝鬘。处处垂下。一切摩尼宝王树。雨大摩尼宝。遍布充满。一切宝衣树。雨种种色衣。随其所应。周匝敷布。一切音乐树。风动成音。其音美妙。过于天乐。一切庄严具树。各雨珍玩奇妙之物。处处分布。以为严饰。其地清净。无有高下。于中具有百万殿堂。大摩尼宝之所合成。百万楼阁。阎浮檀金。以覆其上。百万宫殿。毗卢遮那摩尼宝。间错庄严。一万浴池。众宝合成。七宝栏楯。周匝围绕。七宝阶道。四面分布。八功德水。湛然盈满。其水香气。如天栴檀。金沙布底。水清宝珠。周遍间错。凫雁孔雀。俱枳罗鸟。游戏其中。出和雅音。宝多罗树。周匝行列。覆以宝网。垂诸金铃。微风徐摇。恒出美音。施大宝帐。宝树围绕。建立无数摩尼宝幢。光明普照百千由旬。其中复有百万陂池。黑栴檀泥。凝积其底。一切妙宝。以为莲华。敷布水上。大摩尼华光色。照耀园中。复有广大宫殿。名庄严幢。海藏妙宝。以为其地。毗琉璃宝。以为其柱。阎浮檀金。以覆其上。光藏摩尼。以为庄严。无数宝王。光焰炽然。重楼挟阁。种种庄饰。阿卢那香王。觉悟香王。皆出妙香。普熏一切。其宫殿中。复有无量宝莲华座。周回布列。所谓照耀十方摩尼宝莲华座。毗卢遮那摩尼宝莲华座。照耀世间摩尼宝莲华座。妙藏摩尼宝莲华座。师子藏摩尼宝莲华座。离垢藏摩尼宝莲华座。普门摩尼宝莲华座。光严摩尼宝莲华座。安住大海藏清净摩尼王宝莲华座。金刚师子摩尼宝莲华座。园中复有百万种帐。所谓衣帐鬘帐。香帐华帐。枝帐摩尼帐。真金帐。庄严具帐。音乐帐。象王神变帐。马王神变帐。帝释所著摩尼宝帐。如是等其数百万。有百万大宝网。弥覆其上。所谓宝铃网。宝盖网。宝身网。海藏真珠网。绀琉璃摩尼宝网。师子摩尼网。月光摩尼网。种种形像众香网。宝冠网。宝璎珞网。如是等其数百万。有百万大光明之所照耀。所谓焰光摩尼宝光明。日藏摩尼宝光明。月幢摩尼宝光明。香焰摩尼宝光明。胜藏摩尼宝光明。莲华藏摩尼宝光明。焰幢摩尼宝光明。大灯摩尼宝光明。普照十方摩尼宝光明。香光摩尼宝光明。如是等其数百万。常雨百万庄严具。百万黑栴檀香出妙音声。百万出过诸天曼陀罗华而以散之。百万出过诸天璎珞。以为庄严。百万出过诸天妙宝鬘带。处处垂下。百万出过诸天众色妙衣。百万杂色摩尼宝。妙光普照。百万天子。欣乐瞻仰。头面作礼。百万采女。于虚空中。投身而下。百万菩萨。恭敬亲近。常乐闻法。时休舍优婆夷。坐真金座。戴海藏真珠网。冠挂出过诸天真金宝钏。垂绀青发。大摩尼网。庄严其首。师子口摩尼宝。以为耳珰。如意摩尼宝王。以为璎珞。一切宝网。垂覆其身。百千亿那由他众生。曲躬恭敬。东方有无量众生。来诣其所。所谓梵天梵众天。大梵天梵辅天。自在天。乃至一切人及非人。南西北方。四维上下。皆亦如是。其有见此优婆夷者。一切病苦。悉得除灭。离烦恼垢。拔诸见刺。摧障碍山。入于无碍清净境界。增明一切所有善根。长养诸根。入一切智慧门。入一切总持门。一切三昧门。一切大愿门。一切妙行门。一切功德门。皆得现前。其心广大。具足神通。身无障碍。至一切处。尔时善财童子。入普庄严园。周遍观察。见休舍优婆夷。坐于妙座。往诣其所。顶礼其足。绕无数匝。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。休舍告言。善男子。我唯得菩萨一解脱门。若有见闻忆念于我。与我同住。供给我者。悉不唐捐。善男子。若有众生。不种善根。不为善友之所摄受。不为诸佛之所护念。是人终不得见于我。善男子。其有众生。得见我者。皆于阿耨多罗三藐三菩提。获不退转。善男子。东方诸佛。常来至此。处于宝座。为我说法。南西北方。四维上下。一切诸佛。悉来至此。处于宝座。为我说法。善男子。我常不离见佛闻法。与诸菩萨。而共同住。善男子。我此大众。有八万四千亿那由他。皆在此园。与我同行。悉于阿耨多罗三藐三菩提。得不退转。其余众生。住此园者。亦皆普入不退转位。善财白言。圣者。发阿耨多罗三藐三菩提心。为久近耶。答言。善男子。我忆过去。于然灯佛所。修行梵行。恭敬供养。闻法受持。次前于离垢佛所。出家学道。受持正法。次前于妙幢佛所。次前于胜须弥佛所。次前于莲华德藏佛所。次前于毗卢遮那佛所。次前于普眼佛所。次前于梵寿佛所。次前于金刚脐佛所。次前于婆楼那天佛所。善男子。我忆过去。于无量劫无量生中。如是次第三十六恒河沙佛所。皆悉承事。恭敬供养。闻法受持。净修梵行。于此已往。佛智所知。非我能测。善男子。菩萨初发心无有量。充满一切法界故。菩萨大悲门无有量。普入一切世间故。菩萨大愿门无有量。究竟十方法界故。菩萨大慈门无有量。普覆一切众生故。菩萨所修行无有量。于一切刹一切劫中修习故。菩萨三昧力无有量。令菩萨道不退故。菩萨总持力无有量。能持一切世间故。菩萨智光力无有量。普能证入三世故。菩萨神通力无有量。普现一切刹网故。菩萨辩才力无有量。一音一切悉解故。菩萨清净身无有量。悉遍一切佛刹故。善财童子言。圣者。久如当得阿耨多罗三藐三菩提。答言。善男子。菩萨不为教化调伏一众生故发菩提心。不为教化调伏百众生故发菩提心。乃至不为教化调伏不可说不可说转众生故发菩提心。不为教化一世界众生故发菩提心。乃至不为教化不可说不可说转世界众生故发菩提心。不为教化阎浮提微尘数世界众生故发菩提心。不为教化三千大千世界微尘数世界众生故发菩提心。乃至不为教化不可说不可说转三千大千世界微尘数世界众生故发菩提心。不为供养一如来故发菩提心。乃至不为供养不可说不可说转如来故发菩提心。不为供养一世界中次第兴世诸如来故发菩提心。乃至不为供养不可说不可说转世界中次第兴世诸如来故发菩提心。不为供养一三千大千世界微尘数世界中次第兴世诸如来故发菩提心。乃至不为供养不可说不可说转佛刹微尘数世界中次第兴世诸如来故发菩提心。不为严净一世界故发菩提心。乃至不为严净不可说不可说转世界故发菩提心。不为严净一三千大千世界微尘数世界故发菩提心。乃至不为严净不可说不可说转三千大千世界微尘数世界故发菩提心。不为住持一如来遗法故发菩提心。乃至不为住持不可说不可说转如来遗法故发菩提心。不为住持一世界如来遗法故发菩提心。乃至不为住持不可说不可说转世界如来遗法故发菩提心。不为住持一阎浮提微尘数世界如来遗法故发菩提心。乃至不为住持不可说不可说转佛刹微尘数世界如来遗法故发菩提心。如是略说。不为满一佛誓愿故。不为往一佛国土故。不为入一佛众会故。不为持一佛法眼故。不为转一佛法轮故。不为知一世界中诸劫次第故。不为知一众生心海故。不为知一众生根海故。不为知一众生业海故。不为知一众生行海故。不为知一众生烦恼海故。不为知一众生烦恼习海故。乃至不为知不可说不可说转佛刹微尘数众生烦恼习海故发菩提心。欲教化调伏一切众生。悉无余故。发菩提心。欲承事供养一切诸佛。悉无余故。发菩提心。欲严净一切诸佛国土。悉无余故。发菩提心。欲护持一切诸佛正教。悉无余故。发菩提心。欲成满一切如来誓愿。悉无余故。发菩提心。欲往一切诸佛国土。悉无余故。发菩提心。欲入一切诸佛众会。悉无余故。发菩提心。欲知一切世界中。诸劫次第。悉无余故。发菩提心。欲知一切众生心海。悉无余故。发菩提心。欲知一切众生根海。悉无余故。发菩提心。欲知一切众生业海。悉无余故。发菩提心。欲知一切众生行海。悉无余故。发菩提心。欲灭一切众生。诸烦恼海。悉无余故。发菩提心。欲拔一切众生。烦恼习海。悉无余故。发菩提心。善男子。取要言之。菩萨以如是等百万阿僧祇方便行故。发菩提心。善男子。菩萨行。普入一切法。皆证得故。普入一切刹。悉严净故。是故善男子。严净一切世界尽。我愿乃尽。拔一切众生。烦恼习气尽。我愿乃满。善财童子言。圣者。此解脱名为何等。答言。善男子。此解脱。名离忧安隐幢。善男子。我唯知此一解脱门。如诸菩萨摩诃萨。其心如海。悉能容受一切佛法。如须弥山。志意坚固。不可动摇。如善见药。能除众生烦恼重病。如明净日。能破众生无明闇障。犹如大地能作一切众生依处。犹如好风能作一切众生义利。犹如明灯能为众生。生智慧光。犹如大云能为众生。雨寂灭法。犹如净月能为众生。放福德光。犹如帝释悉能守护一切众生。而我云何能知能说彼功德行。善男子。于此南方海潮之处。有一国土。名那罗素。中有仙人。名毗目瞿沙。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。悲泣流泪。作是思惟。得菩提难。近善知识难。遇善知识难。得菩萨诸根难。净菩萨诸根难。值同行善知识难。如理观察难。依教修行难。值遇出生善心方便难。值遇增长一切智法光明难。作是念已。辞退而行

尔时善财童子。随顺思惟菩萨正教。随顺思惟菩萨净行。生增长菩萨福力心。生明见一切诸佛心。生出生一切诸佛心。生增长一切大愿心。生普见十方诸法心。生明照诸法实性心。生普散一切障碍心。生观察法界无闇心。生清净意宝庄严心。生摧伏一切众魔心。渐渐游行。至那罗素国。周遍推求毗目瞿沙。见一大林。阿僧祇树。以为庄严。所谓种种叶树扶疏布濩。种种华树开敷鲜荣。种种果树相续成熟。种种宝树雨摩尼果。大栴檀树处处行列。诸沉水树常出好香。悦意香树妙香庄严。波吒罗树四面围绕。尼拘律树其身耸擢。阎浮檀树常雨甘果。优钵罗华波头摩华以严池沼。时善财童子。见彼仙人在栴檀树下。敷草而坐。领徒一万。或着鹿皮。或着树皮。或复编草。以为衣服。髻环垂鬓。前后围绕。善财见已。往诣其所。五体投地。作如是言。我今得遇真善知识。善知识者。则是趣向一切智门。令我得入真实道故。善知识者。则是趣向一切智乘。令我得至如来地故。善知识者。则是趣向一切智船。令我得至智宝洲故。善知识者。则是趣向一切智炬。令我得生十力光故。善知识者。则是趣向一切智道。令我得入涅槃城故。善知识者。则是趣向一切智灯。令我得见夷险道故。善知识者。则是趣向一切智桥。令我得度险恶处故。善知识者。则是趣向一切智盖。令我得生大慈凉故。善知识者。则是趣向一切智眼。令我得见法性门故。善知识者。则是趣向一切智潮。令我满足大悲水故。作是语已。从地而起。绕无量匝。合掌前住。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时毗目瞿沙。顾其徒众。而作是言。善男子。此童子已发阿耨多罗三藐三菩提心。善男子。此童子普施一切众生无畏。此童子普兴一切众生利益。此童子常观一切诸佛智海。此童子欲饮一切甘露法雨。此童子欲测一切广大法海。此童子欲令众生住智海中。此童子欲普发起广大悲云。此童子欲普雨于广大法雨。此童子欲以智月普照世间。此童子欲灭世间烦恼毒热。此童子欲长含识一切善根。时诸仙众。闻是语已。各以种种上妙香华。散善财上。投身作礼。围绕恭敬。作如是言。今此童子。必当救护一切众生。必当除灭诸地狱苦。必当永断诸畜生道。必当转去阎罗王界。必当关闭诸难处门。必当干竭诸爱欲海。必令众生永灭苦蕴。必当永破无明黑闇。必当永断贪爱系缚。必以福德大轮围山围绕世间。必以智慧大宝须弥显示世间。必当出现清净智日。必当开示善根法藏。必使世间明识险易。时毗目瞿沙。告群仙言。善男子。若有能发阿耨多罗三藐三菩提心。必当成就一切智道。此善男子已发阿耨多罗三藐三菩提心。当净一切佛功德地。时毗目瞿沙。告善财童子言。善男子。我得菩萨无胜幢解脱。善财白言。圣者。无胜幢解脱境界云何。时毗目仙人。即申右手。摩善财顶。执善财手。即时善财。自见其身。往十方十佛刹微尘数世界中。到十佛刹微尘数诸佛所。见彼佛刹及其众会。诸佛相好。种种庄严。亦闻彼佛随诸众生心之所乐。而演说法。一文一句。皆悉通达。各别受持。无有杂乱。亦知彼佛以种种解。净治诸愿。亦知彼佛以清净愿。成就诸力。亦见彼佛随众生心。所现色相。亦见彼佛大光明网。种种诸色。清净圆满。亦知彼佛无碍智慧。大光明力。又自见身。于诸佛所。经一日夜。或七日夜。半月一月。一年十年。百年千年。或经亿年。或阿庾多亿年。或那由他亿年。或经半劫。或经一劫百劫千劫。或百千亿。乃至不可说不可说佛刹微尘数劫。尔时善财童子。为菩萨无胜幢解脱智光明照故。得毗卢遮那藏三昧光明。为无尽智解脱三昧光明照故。得普摄诸方陀罗尼光明。为金刚轮陀罗尼门光明照故。得极清净智慧心三昧光明。为普门庄严藏般若波罗蜜光明照故。得佛虚空藏轮三昧光明。为一切佛法轮三昧光明照故。得三世无尽智三昧光明。时彼仙人。放善财手。善财童子。即自见身。还在本处。时彼仙人。告善财言。善男子。汝忆念耶。善财言唯。此是圣者。善知识力。仙人言。善男子。我唯知此菩萨无胜幢解脱。如诸菩萨摩诃萨。成就一切殊胜三昧。于一切时。而得自在。于一念顷。出生诸佛无量智慧。以佛智灯。而为庄严。普照世间。一念普入三世境界。分形遍往十方国土。智身普入一切法界。随众生心。普现其前。观其根行。而为利益。放净光明。甚可爱乐。而我云何能知能说彼功德行。彼殊胜愿。彼庄严刹。彼智境界。彼三昧所行。彼神通变化。彼解脱游戏。彼身相差别。彼音声清净。彼智慧光明。善男子。于此南方。有一聚落。名伊沙那。有婆罗门。名曰胜热。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。欢喜踊跃。顶礼其足。绕无数匝。殷勤瞻仰。辞退南行

尔时善财童子。为菩萨无胜幢解脱所照故。住诸佛不思议神力。证菩萨不思议解脱神通智。得菩萨不思议三昧智光明。得一切时熏修三昧智光明。得了知一切境界皆依想所住三昧智光明。得一切世间殊胜智光明。于一切处。悉现其身。以究竟智。说无二无分别平等法。以明净智。普照境界。凡所闻法。皆能忍受。清净信解。于法自性。决定明了。心恒不舍菩萨妙行。求一切智。永无退转。获得十力智慧光明。勤求妙法。常无厌足。以正修行。入佛境界。出生菩萨无量庄严。无边大愿。悉已清净。以无穷尽智。知无边世界网。以无怯弱心。度无量众生海。了无边菩萨诸行境界。见无边世界种种差别。见无边世界种种庄严。入无边世界微细境界。知无边世界种种名号。知无边世界种种言说。知无边众生种种解。见无边众生种种行。见无边众生成熟行。见无边众生差别想。念善知识渐次游行。至伊沙那聚落。见彼胜热修诸苦行。求一切智。四面火聚。犹如大山。中有刀山。高峻无极。登彼山上。投身入火。时善财童子。顶礼其足。合掌而立。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。婆罗门言。善男子。汝今若能上此刀山。投身火聚。诸菩萨行。悉得清净。时善财童子。作如是念。得人身难。离诸难难。得无难难。得净法难。得值佛难。具诸根难。闻佛法难。遇善人难。逢真善知识难。受如理正教难。得正命难。随法行难。此将非魔。魔所使耶。将非是魔险恶徒党。诈现菩萨善知识相。而欲为我作善根难。作寿命难。障我修行一切智道。牵我令入诸恶道中。欲障我法门。障我佛法。作是念时。十千梵天。在虚空中。作如是言善男子。莫作是念。莫作是念。今此圣者。得金刚焰三昧光明。发大精进。度诸众生。心无退转。欲竭一切贪爱海。欲截一切邪见网。欲烧一切烦恼薪。欲照一切惑稠林。欲断一切老死怖。欲坏一切三世障。欲放一切法光明。善男子。我诸梵天。多着邪见。皆悉自谓是自在者。是能作者。于世间中。我是最胜。见婆罗门。五热炙身。于自宫殿。心不乐着。于诸禅定。不得滋味。皆共来诣婆罗门所。时婆罗门。以神通力。示大苦行。为我说法。能令我等灭一切见。除一切慢。住于大慈。行于大悲。起广大心。发菩提意。常见诸佛。恒闻妙法。于一切处。心无所碍。复有十千诸魔在虚空中。以天摩尼宝。散婆罗门上。告善财言。善男子。此婆罗门。五热炙身时。其火光明。映夺于我所有宫殿诸庄严具。皆如聚墨。令我于中不生乐着。我与眷属。来诣其所。此婆罗门。为我说法。令我及余无量天子诸天女等。皆于阿耨多罗三藐三菩提。得不退转。复有十千自在天王。于虚空中。各散天华。作如是言。善男子。此婆罗门。五热炙身时。其火光明。映夺我等所有宫殿诸庄严具。皆如聚墨。令我于中不生爱着。即与眷属。来诣其所。此婆罗门。为我说法。令我于心而得自在。于烦恼中而得自在。于受生中而得自在。于诸业障而得自在。于诸三昧而得自在。于庄严具而得自在。于寿命中而得自在。乃至能于一切佛法而得自在。复有十千化乐天王。于虚空中。作天音乐。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。其火光明。照我宫殿诸庄严具及诸采女。能令我等不受欲乐。不求欲乐。身心柔软。即与众俱。来诣其所。时婆罗门。为我说法。能令我等心得清净。心得明洁。心得纯善。心得柔软。心生欢喜。乃至令得清净十力清净之身。生无量身。乃至令得佛身佛语佛声佛心。具足成就一切智智。复有十千兜率天王天子天女。无量眷属。于虚空中。雨众妙香。恭敬顶礼。作如是言。善男子。此婆罗门。五热炙身时。令我等诸天。及其眷属。于自宫殿。无有乐着。共诣其所。闻其说法。能令我等不贪境界。少欲知足。心生欢喜。心得充满。生诸善根。发菩提心。乃至圆满一切佛法。复有十千三十三天。并其眷属天子天女。前后围绕。于虚空中。雨天曼陀罗华。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。令我等诸天。于天音乐。不生乐着。共诣其所。时婆罗门。为我等说一切诸法无常败坏。令我舍离一切欲乐。令我断除憍慢放逸。令我爱乐无上菩提。又善男子。我当见此婆罗门时。须弥山顶。六种震动。我等恐怖。皆发菩提心。坚固不动。复有十千龙王。所谓伊那跋罗龙王。难陀优波难陀龙王等。于虚空中。雨黑栴檀。无量龙女。奏天音乐。雨天妙华及天香水。恭敬供养。作如是言。善男子。此婆罗门。五热炙身时。其火光明。普照一切诸龙宫殿。令诸龙众。离热沙怖。金翅鸟怖。灭除嗔恚。身得清凉。心无垢浊。闻法信解。厌恶龙趣。以至诚心。悔除业障。乃至发阿耨多罗三藐三菩提意。住一切智。复有十千夜叉王。于虚空中。以种种供具。恭敬供养此婆罗门及以善财。作如是言。善男子。此婆罗门。五热炙身时。我及眷属。悉于众生。发慈愍心。一切罗刹。鸠槃茶等。亦生慈心。以慈心故。于诸众生。无所恼害。而来见我。我及彼等。于自宫殿。不生乐着。即与共俱。来诣其所。时婆罗门。即为我等。如应说法。一切皆得身心安乐。又令无量夜叉罗刹鸠槃茶等。发于无上菩提之心。复有十千乾闼婆王。于虚空中。作如是言。善男子。此婆罗门。五热炙身时。其火光明。照我宫殿。悉令我等受不思议无量快乐。是故我等。来诣其所。此婆罗门。为我说法。能令我等于阿耨多罗三藐三菩提。得不退转。复有十千阿修罗王。从大海出。住在虚空。舒右膝轮。合掌前礼。作如是言。善男子。此婆罗门。五热炙身时。我阿修罗所有宫殿大海大地。悉皆震动。令我等舍憍慢放逸。是故我等来诣其所。从其闻法。舍离谄诳。安住忍地。坚固不动。圆满十力。复有十千迦楼罗王。勇力持王。而为上首。化作外道童子之形。于虚空中。唱如是言。善男子。此婆罗门。五热炙身时。其火光明。照我宫殿。一切震动。皆悉恐怖。是故我等。来诣其所。时婆罗门。即为我等。如应说法。令修习大慈。称赞大悲。度生死海。于欲泥中。拔济众生。叹菩提心。起方便智。随其所宜。调伏众生。复有十千紧那罗王。于虚空中。唱如是言。善男子。此婆罗门。五热炙身时。我等所住宫殿。诸多罗树。诸宝铃网。诸宝缯带。诸音乐树。诸妙宝树。及诸乐器。自然而出佛声法声。及不退转菩萨僧声。愿求无上菩提之声。云某方某国。有某菩萨。发菩提心。某方某国。有某菩萨。修行苦行。难舍能舍。乃至清净一切智行。某方某国。有某菩萨。往诣道场。乃至某方某国。有某如来。作佛事已。而般涅槃。善男子。假使有人。以阎浮提。一切草木。末为微尘。此微尘数。可知边际。我宫殿中宝多罗树。乃至乐器。所说菩萨名。如来名。所发大愿。所修行等。无有能得知其边际。善男子。我等以闻佛声法声。菩萨僧声。生大欢喜。来诣其所。时婆罗门。即为我等。如应说法。令我及余无量众生。于阿耨多罗三藐三菩提。得不退转。复有无量欲界诸天。于虚空中。以妙供具。恭敬供养。唱如是言。善男子。此婆罗门。五热炙身时。其火光明。照阿鼻等。一切地狱。诸所受苦。悉令休息。我等见此火光明故。心生净信。以信心故。从彼命终。生于天中。为知恩故。而来其所。恭敬瞻仰。无有厌足。时婆罗门。为我说法。令无量众生。发菩提心。尔时善财童子。闻如是法。心大欢喜。于婆罗门所。发起真实善知识心。头顶礼敬。唱如是言。我于大圣善知识所。生不善心。唯愿圣者。容我悔过。时婆罗门。即为善财。而说颂言

  若有诸菩萨　　顺善知识教
  一切无疑惧　　安住心不动
  当知如是人　　必获广大利
  坐菩提树下　　成于无上觉

尔时善财童子。即登刀山。自投火聚。未至中间。即得菩萨善住三昧。才触火焰。又得菩萨寂静乐神通三昧。善财白言。甚奇圣者。如是刀山。及大火聚。我身触时。安隐快乐。时婆罗门。告善财言。善男子。我唯得此菩萨无尽轮解脱。如诸菩萨摩诃萨。大功德焰。能烧一切。众生见惑。令无有余。必不退转。无穷尽心。无懈怠心。无怯弱心。发如金刚藏那罗延心。疾修诸行。无迟缓心。愿如风轮。普持一切精进大誓。皆无退转。而我云何能知能说彼功德行。善男子。于此南方。有城名师子奋迅。中有童女。名曰慈行。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。辞退而去

大方广佛华严经卷第六十四大方广佛华严经卷第六十五

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之六

尔时善财童子。于善知识所。起最极尊重心。生广大清净解。常念大乘。专求佛智。愿见诸佛。观法境界无障碍智。常现在前。决定了知诸法实际常住际。一切三世诸刹那际。如虚空际。无二际。一切法无分别际。一切义无障碍际。一切劫无失坏际。一切如来无际之际。于一切佛。心无分别。破众想网。离诸执着。不取诸佛众会道场。亦不取佛清净国土。知诸众生皆无有我。知一切声悉皆如响。知一切色悉皆如影。渐次南行。至师子奋迅城。周遍推求慈行童女。闻此童女是师子幢王女。五百童女。以为侍从。住毗卢遮那藏殿。于龙胜栴檀足金线网天衣座上。而说妙法。善财闻已。诣王宫门。求见彼女。见无量众。来入宫中。善财问言。诸人今者何所往诣。咸报之言。我等欲诣慈行童女听受妙法。善财童子。即作是念。此王宫门。既无限碍。我亦应入。善财入已。见毗卢遮那藏殿。玻璃为地。琉璃为柱。金刚为壁。阎浮檀金。以为垣墙。百千光明。而为窗牖。阿僧祇摩尼宝。而庄校之。宝藏摩尼镜。周匝庄严。以世间最上摩尼宝。而为庄饰。无数宝网罗覆其上。百千金铃。出妙音声。有如是等不可思议众宝严饰。其慈行童女。皮肤金色。眼绀紫色。发绀青色。以梵音声。而演说法。善财见已。顶礼其足。绕无数匝。合掌前住。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨。云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时慈行童女。告善财言。善男子。汝应观我宫殿庄严。善财顶礼。周遍观察。见一一壁中。一一柱中。一一镜中。一一相中。一一形中。一一摩尼宝中。一一庄严具中。一一金铃中。一一宝树中。一一宝形像中。一一宝璎珞中。悉见法界一切如来。从初发心。修菩萨行。成满大愿。具足功德。成等正觉转妙法轮。乃至示现入于涅槃。如是影像。靡不皆现。如净水中普见虚空日月星宿所有众像。如此皆是慈行童女。过去世中善根之力。尔时善财童子。忆念所见诸佛之相。合掌瞻仰慈行童女。尔时童女。告善财言。善男子。此是般若波罗蜜普庄严门。我于三十六恒河沙佛所。求得此法。彼诸如来。各以异门。令我入此般若波罗蜜普庄严门。一佛所演。余不重说。善财白言。圣者。此般若波罗蜜普庄严门。境界云何。童女答言。善男子。我入此般若波罗蜜普庄严门。随顺趣向。思惟观察。忆持分别。时得普门陀罗尼。百万阿僧祇陀罗尼门。皆悉现前。所谓佛刹陀罗尼门。佛陀罗尼门。法陀罗尼门。众生陀罗尼门。过去陀罗尼门。未来陀罗尼门。现在陀罗尼门。常住际陀罗尼门。福德陀罗尼门。福德助道具陀罗尼门。智慧陀罗尼门。智慧助道具陀罗尼门。诸愿陀罗尼门。分别诸愿陀罗尼门。集诸行陀罗尼门。清净行陀罗尼门。圆满行陀罗尼门。业陀罗尼门。业不失坏陀罗尼门。业流注陀罗尼门。业所作陀罗尼门。舍离恶业陀罗尼门。修习正业陀罗尼门。业自在陀罗尼门。善行陀罗尼门。持善行陀罗尼门。三昧陀罗尼门。随顺三昧陀罗尼门。观察三昧陀罗尼门。三昧境界陀罗尼门。从三昧起陀罗尼门。神通陀罗尼门。心海陀罗尼门。种种心陀罗尼门。直心陀罗尼门。照心稠林陀罗尼门。调心清净陀罗尼门。知众生所从生陀罗尼门。知众生烦恼行陀罗尼门。知烦恼习气陀罗尼门。知烦恼方便陀罗尼门。知众生解陀罗尼门。知众生行陀罗尼门。知众生行不同陀罗尼门。知众生性陀罗尼门。知众生欲陀罗尼门。知众生想陀罗尼门。普见十方陀罗尼门。说法陀罗尼门。大悲陀罗尼门。大慈陀罗尼门。寂静陀罗尼门。言语道陀罗尼门。方便非方便陀罗尼门。随顺陀罗尼门。差别陀罗尼门。普入陀罗尼门。无碍际陀罗尼门。普遍陀罗尼门。佛法陀罗尼门。菩萨法陀罗尼门。声闻法陀罗尼门。独觉法陀罗尼门。世间法陀罗尼门。世界成陀罗尼门。世界坏陀罗尼门。世界住陀罗尼门。净世界陀罗尼门。垢世界陀罗尼门。于垢世界现净陀罗尼门。于净世界现垢陀罗尼门。纯垢世界陀罗尼门。纯净世界陀罗尼门。平坦世界陀罗尼门。不平坦世界陀罗尼门。覆世界陀罗尼门。因陀罗网世界陀罗尼门。世界转陀罗尼门。知依想住陀罗尼门。细入粗陀罗尼门。粗入细陀罗尼门。见诸佛陀罗尼门。分别佛身陀罗尼门。佛光明庄严网陀罗尼门。佛圆满音陀罗尼门。佛法轮陀罗尼门。成就佛法轮陀罗尼门。差别佛法轮陀罗尼门。无差别佛法轮陀罗尼门。解释佛法轮陀罗尼门。转佛法轮陀罗尼门。能作佛事陀罗尼门。分别佛众会陀罗尼门。入佛众会海陀罗尼门。普照佛力陀罗尼门。诸佛三昧陀罗尼门。诸佛三昧自在用陀罗尼门。诸佛所住陀罗尼门。诸佛所持陀罗尼门。诸佛变化陀罗尼门。佛知众生心行陀罗尼门。诸佛神通变现陀罗尼门。住兜率天宫乃至示现入于涅槃陀罗尼门。利益无量众生陀罗尼门。入甚深法陀罗尼门。入微妙法陀罗尼门。菩提心陀罗尼门。起菩提心陀罗尼门。助菩提心陀罗尼门。诸愿陀罗尼门。诸行陀罗尼门。神通陀罗尼门。出离陀罗尼门。总持清净陀罗尼门。智轮清净陀罗尼门。智慧清净陀罗尼门。菩提无量陀罗尼门。自心清净陀罗尼门。善男子。我唯知此般若波罗蜜普庄严门。如诸菩萨摩诃萨。其心广大。等虚空界。入于法界。福德成满。住出世法。远世间行。智眼无翳。普观法界。慧心广大。犹如虚空。一切境界。悉皆明见。获无碍地大光明藏。善能分别一切法义。行于世行。不染世法。能益于世非世所坏。普作一切世间依止。普知一切众生心行。随其所应。而为说法。于一切时。恒得自在。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名为三眼。彼有比丘。名曰善见。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。恋慕瞻仰。辞退而行

尔时善财童子。思惟菩萨所住行甚深。思惟菩萨所证法甚深。思惟菩萨所入处甚深。思惟众生微细智甚深。思惟世间依想住甚深。思惟众生所作行甚深。思惟众生心流注甚深。思惟众生如光影甚深。思惟众生名号甚深。思惟众生言说甚深。思惟庄严法界甚深。思惟种植业行甚深。思惟业庄饰世间甚深。渐次游行。至三眼国。于城邑聚落村邻市肆。川原山谷一切诸处。周遍求觅善见比丘。见在林中。经行往返。壮年美貌。端正可喜。其发绀青。右旋不乱。顶有肉髻。皮肤金色。颈文三道。额广平正。眼目修广。如青莲华。唇口丹洁如频婆果。胸摽卍字。七处平满。其臂纤长。其指网缦。手足掌中。有金刚轮。其身殊妙。如净居天。上下端直。如尼拘陀树。诸相随好。悉皆圆满。如雪山王。种种严饰。目视不瞬。圆光一寻。智慧广博。犹如大海。于诸境界。心无所动。若沈若举。若智非智。动转戏论。一切皆息。得佛所行平等境界。大悲教化一切众生。心无暂舍。为欲利乐一切众生。为欲开示如来法眼。为践如来所行之道。不迟不速。审谛经行。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世人与非人。前后围绕。主方之神随方回转引导其前。足行诸神持宝莲华以承其足。无尽光神舒光破闇。阎浮幢林神雨众杂华。不动藏地神现诸宝藏。普光明虚空神庄严虚空。成就德海神雨摩尼宝。无垢藏须弥山神头顶礼敬曲躬合掌。无碍力风神雨妙香华。春和主夜神庄严其身举体投地。常觉主昼神执普照诸方摩尼幢住在虚空。放大光明。时善财童子。诣比丘所。顶礼其足。曲躬合掌。白言。圣者。我已先发阿耨多罗三藐三菩提心。求菩萨行。我闻圣者。善能开示诸菩萨道。愿为我说。菩萨云何学菩萨行。云何修菩萨道。善见答言。善男子。我年既少。出家又近。我此生中。于三十八恒河沙佛所。净修梵行。或有佛所一日一夜。净修梵行。或有佛所七日七夜。净修梵行。或有佛所半月一月。一岁百岁。万岁亿岁。那由他岁。乃至不可说不可说岁。或一小劫。或半大劫。或一大劫。或百大劫。乃至不可说不可说大劫。听闻妙法。受行其教。庄严诸愿。入所证处。净修诸行。满足六种波罗蜜海。亦见彼佛成道说法。各各差别。无有杂乱。住持遗教。乃至灭尽。亦知彼佛本所兴愿。以三昧愿力。严净一切。诸佛国土。以入一切行三昧力。净修一切诸菩萨行。以普贤乘出离力。清净一切佛波罗蜜。又善男子。我经行时。一念中。一切十方皆悉现前。智慧清净故。一念中。一切世界皆悉现前。经过不可说不可说世界故。一念中。不可说不可说佛刹皆悉严净。成就大愿力故。一念中。不可说不可说众生差别。行皆悉现前。满足十力智故。一念中。不可说不可说诸佛清净身皆悉现前。成就普贤行愿力故。一念中。恭敬供养不可说不可说佛刹微尘数如来。成就柔软心。供养如来愿力故。一念中。领受不可说不可说如来法。得证阿僧祇差别法。住持法轮陀罗尼力故。一念中。不可说不可说菩萨行海。皆悉现前。得能净一切行。如因陀罗网愿力故。一念中。不可说不可说诸三昧海。皆悉现前。得于一三昧门。入一切三昧门。皆令清净愿力故。一念中。不可说不可说诸根海。皆悉现前。得了知诸根际。于一根中。见一切根愿力故。一念中。不可说不可说佛刹微尘数时。皆悉现前。得于一切时。转法轮。众生界尽。法轮无尽愿力故。一念中。不可说不可说一切三世海。皆悉现前。得了知一切世界中一切三世分位。智光明愿力故。善男子。我唯知此菩萨随顺灯解脱门。如诸菩萨摩诃萨。如金刚灯。于如来家。真正受生。具足成就。不死命根常然智灯。无有尽灭。其身坚固。不可沮坏。现于如幻色相之身。如缘起法无量差别。随众生心。各各示现。形貌色相。世无伦匹。毒刃火灾。所不能害。如金刚山无能坏者。降伏一切诸魔外道。其身妙好。如真金山。于天人中。最为殊特。名称广大。靡不闻知。观诸世间。咸对目前。演深法藏。如海无尽。放大光明。普照十方。若有见者。必破一切障碍大山。必拔一切不善根本。必令种植广大善根。如是之人。难可得见。难可出世。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名曰名闻。于河渚中。有一童子。名自在主。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。为欲究竟菩萨勇猛清净之行。欲得菩萨大力光明。欲修菩萨无胜无尽诸功德行欲满菩萨坚固大愿。欲成菩萨广大深心。欲持菩萨无量胜行。于菩萨法心无厌足。愿入一切菩萨功德。欲常摄御一切众生。欲超生死稠林旷野。于善知识。常乐见闻。承事供养。无有厌倦。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。受善见比丘教已。忆念诵持。思惟修习。明了决定。于彼法门。而得悟入。天龙夜叉乾闼婆众。前后围绕。向名闻国。周遍求觅自在主童子。时有天龙乾闼婆等。于虚空中。告善财言。善男子。今此童子。在河渚上。尔时善财。即诣其所。见此童子。十千童子。所共围绕。聚沙为戏。善财见已。顶礼其足。绕无量匝。合掌恭敬。却住一面。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。愿为解说。自在主言。善男子。我昔曾于文殊师利童子所。修学书数算印等法。即得悟入一切工巧神通智法门。善男子。我因此法门故。得知世间书数算印界处等法。亦能疗治风痫消瘦鬼魅所著。如是所有一切诸病。亦能造立城邑聚落园林台观。宫殿屋宅种种诸处。亦善调炼种种仙药。亦善营理田农商估一切诸业。取舍进退咸得其所。又善别知众生身相。作善作恶。当生善趣。当生恶趣。此人应得声闻乘道。此人应得缘觉乘道。此人应入一切智地。如是等事。皆悉能知。亦令众生学习此法。增长决定。究竟清净。善男子。我亦能知菩萨算法。所谓一百洛叉为一俱胝。俱胝俱胝为一阿庾多。阿庾多阿庾多为一那由他。那由他那由他为一频婆罗。频婆罗频婆罗为一矜羯罗。广说。乃至优钵罗优钵罗为一波头摩。波头摩波头摩。为一僧祇。僧祇僧祇为一趣。趣趣为一谕。谕谕为一无数。无数无数。为一无数转。无数转无数转为一无量。无量无量为一无量转。无量转无量转为一无边。无边无边为一无边转。无边转无边转为一无等。无等无等为一无等转。无等转无等转为一不可数。不可数不可数为一不可数转。不可数转不可数转为一不可称。不可称不可称为一不可称转。不可称转不可称转为一不可思。不可思不可思为一不可思转。不可思转不可思转为一不可量。不可量不可量为一不可量转。不可量转不可量转为一不可说。不可说不可说为一不可说转。不可说转不可说转为一不可说不可说。此又不可说不可说为一不可说不可说转。善男子。我以此菩萨算法。算无量由旬广大沙聚。悉知其内颗粒多少。亦能算知东方所有一切世界种种差别。次第安住。南西北方。四维上下。亦复如是。亦能算知十方所有一切世界广狭大小。及以名字。其中所有一切劫名。一切佛名。一切法名。一切众生名。一切业名。一切菩萨名。一切谛名。皆悉了知。善男子。我唯知此一切工巧大神通智光明法门。如诸菩萨摩诃萨。能知一切诸众生数。能知一切诸法品类数。能知一切诸法差别数。能知一切三世数。能知一切众生名数。能知一切诸法名数。能知一切诸如来数。能知一切诸佛名数。能知一切诸菩萨数。能知一切菩萨名数。而我何能说其功德。示其所行。显其境界。赞其胜力。辨其乐欲。宣其助道。彰其大愿。叹其妙行。阐其诸度。演其清净。发其殊胜。智慧光明。善男子。于此南方。有一大城。名曰海住。有优婆夷。名为具足。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。闻是语已。举身毛竖。欢喜踊跃。获得希有信乐宝心。成就广大利众生心。悉能明见一切诸佛出兴次第。悉能通达甚深智慧清净法轮。于一切趣。皆随现身。了知三世平等境界。出生无尽功德大海。放大智慧自在光明。开三有城。所有关钥。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。观察思惟善知识教。犹如巨海受大云雨。无有厌足。作是念言。善知识教。犹如春日生长一切善法根苗。善知识教。犹如满月。凡所照及。皆使清凉。善知识教。如夏雪山。能除一切诸兽热渴。善知识教。如芳池日。能开一切善心莲华。善知识教。如大宝洲。种种法宝。充满其心。善知识教。如阎浮树。积集一切福智华果。善知识教。如大龙王。于虚空中。游戏自在。善知识教。如须弥山。无量善法。三十三天。于中止住。善知识教。犹如帝释。众会围绕。无能映蔽。能伏异道修罗军众。如是思惟。渐次游行。至海住城。处处寻觅此优婆夷。时彼众人。咸告之言。善男子。此优婆夷。在此城中所住宅内。善财闻已。即诣其门。合掌而立。其宅广博。种种庄严。众宝垣墙。周匝围绕。四面皆有宝庄严门。善财入已。见优婆夷。处于宝座。盛年好色。端正可喜。素服垂发。身无璎珞。其身色相。威德光明。除佛菩萨。余无能及。于其宅内。敷十亿座。超出人天一切所有。皆是菩萨业力成就。宅中无有衣服饮食及余一切资生之物。但于其前。置一小器。复有一万童女围绕。威仪色相。如天采女。妙宝严具。庄饰其身。言音美妙。闻者喜悦。常在左右。亲近瞻仰。思惟观察。曲躬低首。应其教命。彼诸童女。身出妙香。普熏一切。若有众生。遇斯香者。皆不退转。无怒害心。无怨结心。无悭嫉心。无谄诳心。无险曲心。无憎爱心。无嗔恚心。无下劣心。无高慢心。生平等心。起大慈心。发利益心。住律仪心。离贪求心。闻其音者。欢喜踊跃。见其身者。悉离贪染。尔时善财。既见具足优婆夷已。顶礼其足。恭敬围绕。合掌而立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。彼即告言。善男子。我得菩萨无尽福德藏解脱门。能于如是一小器中。随诸众生种种欲乐。出生种种美味饮食。悉令充满。假使百众生。千众生。百千众生。亿众生。百亿众生。千亿众生。百千亿那由他众生。乃至不可说不可说众生。假使阎浮提微尘数众生。一四天下微尘数众生。小千世界中千世界大千世界。乃至不可说不可说佛刹微尘数众生。假使十方世界一切众生。随其欲乐悉令充满。而其饮食无有穷尽。亦不减少。如饮食。如是种种上味。种种床座。种种衣服。种种卧具。种种车乘。种种华。种种鬘。种种香。种种涂香。种种烧香。种种末香。种种珍宝。种种璎珞。种种幢。种种幡。种种盖。种种上妙资生之具。随意所乐悉令充足。又善男子。假使东方一世界中。声闻独觉。食我食已。皆证声闻辟支佛果。住最后身。如一世界中。如是百世界。千世界。百千世界。亿世界。百亿世界。千亿世界。百千亿世界。百千亿那由他世界。阎浮提微尘数世界。一四天下微尘数世界。小千国土微尘数世界。中千国土微尘数世界。三千大千国土微尘数世界。乃至不可说不可说佛刹微尘数世界中。所有一切声闻独觉。食我食已。皆证声闻辟支佛果。住最后身。如于东方。南西北方。四维上下。亦复如是。又善男子。东方一世界。乃至不可说不可说佛刹微尘数世界中。所有一生所系菩萨。食我食已。皆菩提树下。坐于道场。降伏魔军。成阿耨多罗三藐三菩提。如东方。南西北方。四维上下。亦复如是。善男子。汝见我此十千童女眷属以不。答言已见。优婆夷言。善男子。此十千童女。而为上首。如是眷属百万阿僧祇。皆悉与我同行同愿。同善根。同出离道。同清净解。同清净念。同清净趣。同无量觉。同得诸根。同广大心。同所行境。同理同义。同明了法。同净色相。同无量力。同最精进。同正法音。同随类音。同清净第一音。同赞无量清净功德。同清净业。同清净报。同大慈周普救护一切。同大悲周普成熟众生。同清净身业随缘集起令见者欣悦。同清净口业随世语言宣布法化。同往诣一切诸佛众会道场。同往诣一切佛刹供养诸佛。同能现见一切法门。同住菩萨清净行地。善男子。是十千童女。能于此器。取上饮食。一刹那顷。遍至十方。供养一切后身菩萨声闻独觉。乃至遍及诸饿鬼趣。皆令充足。善男子。此十千女。以我此器。能于天中充足天食。乃至人中充足人食。善男子。且待须臾。汝当自见。说是语时。善财则见无量众生。从四门入。皆优婆夷。本愿所请。既来集已。敷座令坐。随其所须。给施饮食。悉使充足。告善财言。善男子。我唯知此无尽福德藏解脱门。如诸菩萨摩诃萨一切功德。犹如大海甚深无尽。犹如虚空广大无际。如如意珠满众生愿。如大聚落所求皆得。如须弥山普集众宝。犹如奥藏常贮法财。犹如明灯破诸黑闇。犹如高盖普荫群生。而我云何能知能说彼功德行。善男子。南方有城。名曰大兴。彼有居士。名曰明智。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。瞻仰无厌。辞退而去。尔时善财童子。得无尽庄严福德藏解脱光明已。思惟彼福德大海。观察彼福德虚空。趣彼福德聚。登彼福德山。摄彼福德藏。入彼福德渊。游彼福德池。净彼福德轮。见彼福德藏。入彼福德门。行彼福德道。修彼福德种。渐次而行。至大兴城。周遍推求明智长者。于善知识。心生渴仰。以善知识。熏习其心。于善知识。志欲坚固。方便求见诸善知识。心不退转。愿得承事诸善知识。心无懈倦。知由依止善知识故。能满众善。知由依止善知识故。能生众福。知由依止善知识故。能长众行。知由依止善知识故。不由他教。自能承事一切善友。如是思惟时。长其善根。净其深心。增其根性。益其德本。加其大愿。广其大悲。近一切智。具普贤道。照明一切诸佛正法。增长如来十力光明。尔时善财。见彼居士在其城内市四衢道七宝台上。处无数宝庄严之座。其座妙好。清净摩尼。以为其身。金刚帝青。以为其足。宝绳交络。五百妙宝。而为校饰。敷天宝衣。建天幢幡。张大宝网。施大宝帐。阎浮檀金。以为其盖。毗琉璃宝。以为其竿。令人执持。以覆其上。鹅王羽翮。清净严洁。以为其扇。熏众妙香。雨众天华。左右常奏五百乐音。其音美妙。过于天乐。众生闻者。无不悦豫。十千眷属。前后围绕。色相端严。人所喜见。天庄严具。以为严饰。于天人中。最胜无比。悉已成就菩萨志欲。皆与居士。同昔善根。侍立瞻对。承其教命。尔时善财。顶礼其足。绕无量匝。合掌而立。白言。圣者。我为利益一切众生故。为令一切众生出诸苦难故。为令一切众生究竟安乐故。为令一切众生出生死海故。为令一切众生住法宝洲故。为令一切众生枯竭爱河故。为令一切众生起大慈悲故。为令一切众生舍离欲爱故。为令一切众生渴仰佛智故。为令一切众生出生死旷野故。为令一切众生乐诸佛功德故。为令一切众生出三界城故。为令一切众生入一切智城故。发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。能为一切众生。作依止处。长者告言。善哉善哉。善男子。汝乃能发阿耨多罗三藐三菩提心。善男子。发阿耨多罗三藐三菩提心。是人难得。若能发心。是人则能求菩萨行。值遇善知识恒无厌足。亲近善知识恒无劳倦。供养善知识恒不疲懈。给侍善知识不生忧戚。求觅善知识终不退转。爱念善知识终不放舍。承事善知识无暂休息。瞻仰善知识无时憩止。行善知识教未曾怠惰。禀善知识心无有误失。善男子。汝见我此众会人不。善财答言。唯然已见。居士言。善男子。我已令其发阿耨多罗三藐三菩提心。生如来家。增长白法。安住无量诸波罗蜜。学佛十力。离世间种。住如来种。弃生死轮。转正法轮。灭三恶趣。住正法趣。如诸菩萨悉能救护一切众生。善男子。我得随意出生福德藏解脱门。凡有所须。悉满其愿。所谓衣服璎珞。象马车乘。华香幢盖。饮食汤药。房舍屋宅。床座灯炬。奴婢牛羊。及诸侍使。如是一切资生之物。诸有所须。悉令充满。乃至为说真实妙法。善男子。且待须臾。汝当自见。说是语时。无量众生。从种种方所。种种世界。种种国土。种种城邑。形类各别。爱欲不同。皆以菩萨。往昔愿力。其数无边。俱来集会。各随所欲。而有求请。尔时居士。知众普集。须臾系念。仰视虚空。如其所须。悉从空下。一切众会。普皆满足。然后复为说种种法。所谓为得美食而充足者。与说种种集福德行。离贫穷行。知诸法行。成就法喜禅悦食行。修习具足诸相好行。增长成就难屈伏行。善能了达无上食行。成就无尽大威德力降魔怨行。为得好饮而充足者。与其说法。令于生死。舍离爱着。入佛法味。为得种种诸上味者。与其说法。皆令获得诸佛如来上味之相。为得车乘而充足者。与其宣说种种法门。皆令得载摩诃衍乘。为得衣服而充足者。与其说法。令得清净惭愧之衣。乃至如来清净妙色。如是一切。靡不周赡。然后悉为如应说法。既闻法已还归本处。尔时居士。为善财童子。示现菩萨不可思议解脱境界已。告言。善男子。我唯知此随意出生福德藏解脱门。如诸菩萨摩诃萨。成就宝手。遍覆一切十方国土。以自在力。普雨一切资生之具。所谓雨种种色宝。种种色璎珞。种种色宝冠。种种色衣服。种种色音乐。种种色华。种种色香。种种色末香。种种色烧香。种种色宝盖。种种色幢幡。遍满一切众生住处。及诸如来众会道场。或以成熟一切众生。或以供养一切诸佛。而我云何能知能说彼诸功德自在神力。善男子。于此南方。有一大城。名师子宫。彼有长者。名法宝髻。汝可往问。菩萨云何学菩萨行。修菩萨道。时善财童子。欢喜踊跃。恭敬尊重。如弟子礼。作如是念。由此居士护念于我。令我得见一切智道。不断爱念善知识见。不坏尊重善知识心。常能随顺善知识教。决定深信善知识语。恒发深心。事善知识。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第六十五大方广佛华严经卷第六十六

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之七

尔时善财童子。于明智居士所。闻此解脱已。游彼福德海。治彼福德田。仰彼福德山。趣彼福德津。开彼福德藏。观彼福德法。净彼福德轮。味彼福德聚。生彼福德力。增彼福德势。渐次而行。向师子城。周遍推求宝髻长者。见此长者在于市中。遽即往诣。顶礼其足。绕无数匝。合掌而立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨。云何学菩萨行。云何修菩萨道。善哉圣者。愿为我说诸菩萨道。我乘此道。趣一切智。尔时长者。执善财手。将诣所居示其舍宅。作如是言。善男子。且观我家。尔时善财。见其舍宅。清净光明。真金所成。白银为墙。玻璃为殿。绀琉璃宝。以为楼阁。砗磲妙宝。而作其柱。百千种宝。周遍庄严。赤珠摩尼。为师子座。摩尼为帐。真珠为网。弥覆其上。码瑙宝池。香水盈满。无量宝树。周遍行列。其宅广博。十层八门。善财入已。次第观察。见最下层。施诸饮食。见第二层。施诸宝衣。见第三层。布施一切宝庄严具。见第四层。施诸采女并及一切上妙珍宝。见第五层。乃至五地菩萨云集。演说诸法。利益世间。成就一切陀罗尼门。诸三昧印。诸三昧行。智慧光明。见第六层。有诸菩萨。皆已成就甚深智慧。于诸法性。明了通达。成就广大总持三昧。无障碍门。所行无碍。不住二法。在不可说妙庄严道场中。而共集会。分别显示般若波罗蜜门。所谓寂静藏般若波罗蜜门。善分别诸众生智般若波罗蜜门。不可动转般若波罗蜜门。离欲光明般若波罗蜜门。不可降伏藏般若波罗蜜门。照众生轮般若波罗蜜门。海藏般若波罗蜜门。普眼舍得般若波罗蜜门。入无尽藏般若波罗蜜门。一切方便海般若波罗蜜门。入一切世间海般若波罗蜜门。无碍辩才般若波罗蜜门。随顺众生般若波罗蜜门。无碍光明般若波罗蜜门。常观宿缘而布法云般若波罗蜜门。说如是等百万阿僧祇般若波罗蜜门。见第七层。有诸菩萨。得如响忍。以方便智。分别观察。而得出离。悉能闻持诸佛正法。见第八层。无量菩萨。共集其中。皆得神通。无有退堕。能以一音。遍十方刹。其身普现一切道场。尽于法界。靡不周遍。普入佛境。普见佛身。普于一切佛众会中。而为上首。演说于法。见第九层。一生所系诸菩萨众。于中集会。见第十层。一切如来。充满其中。从初发心。修菩萨行。超出生死。成满大愿及神通力。净佛国土道场众会。转正法轮。调伏众生。如是一切。悉使明见。尔时善财。见是事已。白言。圣者。何缘致此清净众会。种何善根。获如是报。长者告言。善男子。我念过去。过佛刹微尘数劫。有世界。名圆满庄严。佛号无边光明法界普庄严王如来应正等觉。十号圆满。彼佛入城。我奏乐音。并烧一丸香。而以供养。以此功德。回向三处。谓永离一切贫穷困苦。常见诸佛及善知识。恒闻正法故获斯报。善男子。我唯知此菩萨无量福德宝藏解脱门。如诸菩萨摩诃萨。得不思议功德宝藏。入无分别如来身海。受无分别无上法云。修无分别功德道具。起无分别普贤行网。入无分别三昧境界。等无分别菩萨善根。住无分别如来所住。证无分别三世平等。住无分别普眼境界。住一切劫。无有疲厌。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名曰藤根。其土有城。名曰普门。中有长者。名为普眼。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。于宝髻长者所。闻此解脱已。深入诸佛无量知见。安住菩萨无量胜行。了达菩萨无量方便。希求菩萨无量法门。清净菩萨无量信解。明利菩萨无量诸根。成就菩萨无量欲乐。通达菩萨无量行门。增长菩萨无量愿力。建立菩萨无能胜幢。起菩萨智照菩萨法。渐次而行。至藤根国。推问求觅彼城所在。虽历艰难不惮劳苦。但唯正念善知识教。愿常亲近承事供养。遍策诸根。离众放逸。然后乃得见普门城。百千聚落。周匝围绕。雉堞崇[山/陵]。衢路宽平。见彼长者。往诣其所。于前顶礼。合掌而立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。长者告言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我知一切众生诸病。风黄痰热。鬼魅蛊毒。乃至水火之所伤害。如是一切所生诸疾。我悉能以方便救疗。善男子。十方众生。诸有病者。咸来我所。我皆疗治。令其得差。复以香汤。沐浴其身。香华璎珞。名衣上服。种种庄严。施诸饮食及以财宝。悉令充足。无所乏短。然后各为如应说法。为贪欲多者教不净观。嗔恚多者教慈悲观。愚痴多者教其分别种种法相。等分行者为其显示殊胜法门。为欲令其发菩提心。称扬一切诸佛功德。为欲令其起大悲意。显示生死无量苦恼。为欲令其增长功德。赞叹修集无量福智。为欲令其发大誓愿。称赞调伏一切众生。为欲令其修普贤行。说诸菩萨于一切刹。一切劫住。修诸行网。为欲令其具佛相好。称扬赞叹檀波罗蜜。为欲令其得佛净身悉能遍至一切处故。称扬赞叹尸波罗蜜。为欲令其得佛清净不思议身。称扬赞叹忍波罗蜜。为欲令其获于如来无能胜身。称扬赞叹精进波罗蜜。为欲令其得于清净无与等身。称扬赞叹禅波罗蜜。为欲令其显现如来清净法身。称扬赞叹般若波罗蜜。为欲令其现佛世尊清净色身。称扬赞叹方便波罗蜜。为欲令其为诸众生住一切劫。称扬赞叹愿波罗蜜。为欲令其现清净身。悉过一切诸佛刹土。称扬赞叹力波罗蜜。为欲令其现清净身随众生心悉使欢喜。称扬赞叹智波罗蜜。为欲令其获于究竟净妙之身。称扬赞叹永离一切诸不善法。如是施已。各令还去。善男子。我又善知和合一切诸香要法。所谓无等香。辛头波罗香。无胜香。觉悟香。阿卢那跋底香。坚黑栴檀香。乌洛迦栴檀香。沉水香。不动诸根香。如是等香。悉知调理和合之法。又善男子。我持此香。以为供养。普见诸佛。所愿皆满。所谓救护一切众生愿。严净一切佛刹愿。供养一切如来愿。又善男子。然此香时。一一香中。出无量香。遍至十方一切法界。一切诸佛众会道场。或为香宫。或为香殿。如是香栏槛。香垣墙。香却敌。香户牖。香重阁。香半月。香盖香幢。香幡香帐。香罗网。香形像。香庄严具。香光明。香云雨。处处充满。以为庄严。善男子。我唯知此令一切众生普见诸佛欢喜法门。如诸菩萨摩诃萨。如大药王。若见若闻。若忆念若同住。若随行往。若称名号。皆获利益。无空过者。若有众生。暂得值遇。必令销灭一切烦恼。入于佛法。离诸苦蕴。永息一切生死怖畏。到无所畏一切智处。摧坏一切老死大山。安住平等寂灭之乐。而我云何能知能说彼功德行。善男子。于此南方。有一大城。名多罗幢。彼中有王。名无厌足。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。时善财童子。礼普眼足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。忆念思惟善知识教。念善知识。能摄受我。能守护我。令我于阿耨多罗三藐三菩提。无有退转。如是思惟。生欢喜心。净信心。广大心。怡畅心。踊跃心。欣庆心。胜妙心。寂静心。庄严心。无著心。无碍心。平等心。自在心。住法心。遍往佛刹心。见佛庄严心。不舍十力心。渐次游行。经历国土村邑聚落。至多罗幢城。问无厌足王所在之处。诸人答言。此王今者在于正殿。坐师子座。宣布法化。调御众生。可治者治。可摄者摄。罚其罪恶。决其诤讼。抚其孤弱。皆令永断杀盗邪淫。亦令禁止妄言两舌恶口绮语。又使远离贪嗔邪见。时善财童子。依众人语。寻即往诣遥见彼王坐那罗延金刚之座。阿僧祇宝。以为其足。无量宝像。以为庄严。金绳为网弥覆其上。如意摩尼以为宝冠。庄严其首。阎浮檀金以为半月。庄严其额。帝青摩尼以为耳珰。相对垂下。无价摩尼以为璎珞。庄严其颈。天妙摩尼以为印钏。庄严其臂。阎浮檀金以为其盖。众宝间错以为轮辐。大琉璃宝以为其竿。光味摩尼以为其脐。杂宝为铃。恒出妙音。放大光明。周遍十方。如是宝盖。而覆其上。阿那罗王。有大力势。能伏他众。无能与敌。以离垢缯。而系其顶。十千大臣。前后围绕。共理王事。其前复有十万猛卒。形貌丑恶。衣服褊陋。执持器仗。攘臂嗔目。众生见者。无不恐怖。无量众生。犯王教敕。或盗他物。或害他命。或侵他妻。或生邪见。或起嗔恨。或怀贪嫉。作如是等种种恶业。身被五缚。将诣王所。随其所犯。而治罚之。或断手足。或截耳鼻。或挑其目。或斩其首。或剥其皮。或解其体。或以汤煮。或以火焚。或驱上高山推令堕落。有如是等无量楚毒。发声号叫。譬如众合大地狱中。善财见已。作如是念。我为利益一切众生。求菩萨行。修菩萨道。今者此王灭诸善法。作大罪业。逼恼众生。乃至断命。曾不顾惧未来恶道。云何于此而欲求法。发大悲心。救护众生。作是念时。空中有天。而告之言。善男子。汝当忆念普眼长者善知识教。善财仰视。而白之曰。我常忆念。初不敢忘。天曰。善男子。汝莫厌离善知识语。善知识者。能引导汝。至无险难安隐之处。善男子。菩萨善巧方便智不可思议。摄受众生智不可思议。护念众生智不可思议。成熟众生智不可思议。守护众生智不可思议。度脱众生智不可思议。调伏众生智不可思议。时善财童子。闻此语已。即诣王所。顶礼其足。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。时阿那罗王。理王事已。执善财手。将入宫中。命之同坐。告言。善男子。汝应观我所住宫殿。善财如语。即遍观察。见其宫殿。广大无比。皆以妙宝之所合成。七宝为墙。周匝围绕。百千众宝。以为楼阁。种种庄严。悉皆妙好。不思议摩尼宝网。罗覆其上。十亿侍女。端正殊绝。威仪进止。皆悉可观。凡所施为无非巧妙。先起后卧。软意承旨。时阿那罗王。告善财言。善男子。于意云何。我若实作如是恶业。云何而得如是果报。如是色身。如是眷属。如是富赡。如是自在。善男子。我得菩萨如幻解脱。善男子。我此国土。所有众生。多行杀盗乃至邪见。作余方便。不能令其舍离恶业。善男子。我为调伏彼众生故。化作恶人。造诸罪业。受种种苦。令其一切作恶众生。见是事已。心生惶怖。心生厌离。心生怯弱。断其所作一切恶业。发阿耨多罗三藐三菩提意。善男子。我以如是巧方便故。令诸众生。舍十恶业。住十善道。究竟快乐。究竟安隐。究竟住于一切智地。善男子。我身语意。未曾恼害于一众生。善男子。如我心者。宁于未来。受无间苦。终不发生一念之意。与一蚊一蚁。而作苦事。况复人耶。人是福田。能生一切诸善法故。善男子。我唯得此如幻解脱。如诸菩萨摩诃萨。得无生忍。知诸有趣悉皆如幻。菩萨诸行悉皆如化。一切世间悉皆如影。一切诸法悉皆如梦。入真实相无碍法门。修行帝网。一切诸行。以无碍智。行于境界。普入一切平等三昧。于陀罗尼。已得自在。而我云何能知能说彼功德行。善男子。于此南方。有城。名妙光。王名大光。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼王足。绕无数匝。辞退而去

尔时善财童子。一心正念彼王所得幻智法门。思惟彼王如幻解脱。观察彼王如幻法性。发如幻愿。净如幻法。普于一切如幻三世。起于种种如幻变化。如是思惟。渐次游行。或至人间城邑聚落。或经旷野岩谷险难。无有疲懈。未曾休息。然后乃至妙光大城。而问人言。妙光大城。在于何所。人咸报言。妙光城者。今此城是。是大光王之所住处。时善财童子。欢喜踊跃。作如是念。我善知识。在此城中。我今必当亲得奉见。闻诸菩萨所行之行。闻诸菩萨出要之门。闻诸菩萨所证之法。闻诸菩萨不思议功德。闻诸菩萨不思议自在。闻诸菩萨不思议平等。闻诸菩萨不思议勇猛。闻诸菩萨不思议境界广大清净。作是念已。入妙光城。见此大城。以金银琉璃玻璃真珠砗磲码瑙七宝所成。七宝深堑。七重围绕。八功德水。盈满其中。底布金沙。优钵罗华。波头摩华。拘物头华。芬陀利华。遍布其上。宝多罗树。七重行列。七种金刚。以为其垣。各各围绕。所谓师子光明金刚垣。无能超胜金刚垣。不可沮坏金刚垣。不可毁缺金刚垣。坚固无碍金刚垣。胜妙网藏金刚垣。离尘清净金刚垣。悉以无数摩尼妙宝。间错庄严。种种众宝而为埤堄。其城纵广。一十由旬。周回八方。面开八门。皆以七宝。周遍严饰。毗琉璃宝。以为其地。种种庄严。甚可爱乐。其城之内。十亿衢道。一一道间。皆有无量万亿众生。于中止住。有无数阎浮檀金楼阁。毗琉璃摩尼网。罗覆其上。无数银楼阁。赤真珠摩尼网。罗覆其上。无数毗琉璃楼阁。妙藏摩尼网。罗覆其上。无数玻璃楼阁。无垢藏摩尼王网。罗覆其上。无数光照世间。摩尼宝楼阁。日藏摩尼王网。罗覆其上。无数帝青摩尼宝楼阁。妙光摩尼王网。罗覆其上。无数众生海摩尼王楼阁。焰光明摩尼王网。罗覆其上。无数金刚宝楼阁。无能胜幢摩尼王网。罗覆其上。无数黑栴檀楼阁。天曼陀罗华网。罗覆其上。无数无等香王楼阁。种种华网。罗覆其上。其城复有无数摩尼网。无数宝铃网。无数天香网。无数天华网。无数宝形像网。无数宝衣帐。无数宝盖帐。无数宝楼阁帐。无数宝华鬘帐之所弥覆。处处建立宝盖幢幡。当此城中。有一楼阁。名正法藏。阿僧祇宝。以为庄严。光明赫奕。最胜无比。众生见者。心无厌足。彼大光王。常处其中。尔时善财童子。于此一切珍宝妙物。乃至男女。六尘境界。皆无爱着。但正思惟究竟之法。一心愿乐见善知识。渐次游行。见大光王。去于所住楼阁。不远四衢道中。坐如意摩尼宝莲华藏广大庄严师子之座。绀琉璃宝。以为其足。金缯为帐。众宝为网。上妙天衣。以为茵蓐。其王于上。结跏趺坐。二十八种大人之相。八十随好。而以严身。如真金山光色炽盛。如净空日威光赫奕。如盛满月见者清凉。如梵天王处于梵众。亦如大海功德法宝。无有边际。亦如雪山相好树林。以为严饰。亦如大云能震法雷。启悟群品。亦如虚空显现种种法门星象。如须弥山四色普现众生心海。亦如宝洲种种智宝。充满其中。于王座前。有金银琉璃摩尼真珠珊瑚琥珀珂贝璧玉。诸珍宝聚。衣服璎珞。及诸饮食。无量无边。种种充满。复见无量百千万亿上妙宝车。百千万亿诸天妓乐。百千万亿天诸妙香。百千万亿病缘汤药。资生之具。如是一切悉皆珍好。无量乳牛。蹄角金色。无量千亿端正女人上妙栴檀。以涂其体。天衣璎珞。种种庄严。六十四能。靡不该练。世情礼则。悉皆善解。随众生心。而以给施。城邑聚落。四衢道侧。悉置一切资生之具。一一道傍。皆有二十亿菩萨。以此诸物。给施众生。为欲普摄众生故。为令众生欢喜故。为令众生踊跃故。为令众生心净故。为令众生清凉故。为灭众生烦恼故。为令众生知一切义理故。为令众生入一切智道故。为令众生舍怨敌心故。为令众生离身语恶故。为令众生拔诸邪见故。为令众生净诸业道故。时善财童子。五体投地。顶礼其足。恭敬右绕。经无量匝。合掌而住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时王告言。善男子。我净修菩萨大慈幢行。我满足菩萨大慈幢行。善男子。我于无量百千万亿。乃至不可说不可说佛所。问难此法。思惟观察。修习庄严。善男子。我以此法为王。以此法教敕。以此法摄受。以此法随逐世间。以此法引导众生。以此法令众生修行。以此法令众生趣入。以此法与众生方便。以此法令众生熏习。以此法令众生起行。以此法令众生安住思惟诸法自性。以此法令众生安住慈心。以慈为主。具足慈力。如是令住利益心。安乐心。哀愍心。摄受心。守护众生不舍离心。拔众生苦无休息心。我以此法。令一切众生。毕竟快乐。恒自悦豫。身无诸苦。心得清凉。断生死爱。乐正法乐。涤烦恼垢。破恶业障。绝生死流。入真法海。断诸有趣。求一切智。净诸心海。生不坏信。善男子。我已住此大慈幢行。能以正法。教化世间。善男子。我国土中。一切众生。皆于我所。无有恐怖。善男子。若有众生。贫穷困乏。来至我所。而有求索。我开库藏。恣其所取。而语之言。莫造诸恶。莫害众生。莫起诸见。莫生执着。汝等贫乏。若有所须。当来我所。及四衢道。一切诸物。种种具足。随意而取。勿生疑难。善男子。此妙光城。所住众生。皆是菩萨发大乘意。随心所欲。所见不同。或见此城其量狭小。或见此城其量广大。或见土沙以为其地。或见众宝而以庄严。或见聚土以为垣墙。或见宝墙周匝围绕。或见其地多诸瓦石。高下不平。或见无量大摩尼宝。间错庄严。平坦如掌。或见屋宅土木所成。或见殿堂及诸楼阁。阶墀窗闼。轩槛户牖。如是一切无非妙宝。善男子。若有众生。其心清净。曾种善根。供养诸佛。发心趣向一切智道。以一切智。为究竟处。及我昔时。修菩萨行。曾所摄受。则见此城众宝严净。余皆见秽。善男子。此国土中一切众生。五浊世时。乐作诸恶。我心哀愍。而欲救护。入于菩萨大慈为首随顺世间三昧之门。入此三昧时。彼诸众生。所有怖畏心。恼害心。怨敌心。诤论心。如是诸心。悉自消灭。何以故。入于菩萨大慈为首顺世三昧。法如是故。善男子。且待须臾。自当现见。时大光王。即入此定。其城内外。六种震动。诸宝地宝墙。宝堂宝殿。台观楼阁。阶砌户牖。如是一切咸出妙音。悉向于王。曲躬敬礼。妙光城内。所有居人。靡不同时。欢喜踊跃。俱向王所。举身投地。村营城邑。一切人众。咸来见王。欢喜敬礼。近王所住。鸟兽之属。互相瞻视。起慈悲心。咸向王前。恭敬礼拜。一切山原。及诸草树。莫不回转向王敬礼。陂池泉井。及以河海。悉皆腾溢。流注王前。十千龙王。起大香云。激电震雷。注微细雨。有十千天王。所谓忉利天王。夜摩天王。兜率陀天王。善变化天王。他化自在天王。如是等而为上首。于虚空中。作众妓乐。无数天女。歌咏赞叹。雨无数华云。无数香云。无数宝鬘云。无数宝衣云。无数宝盖云。无数宝幢云。无数宝幡云。于虚空中。而为庄严。供养其王。伊罗婆拏大象王。以自在力。于虚空中。敷布无数大宝莲华。垂无数宝璎珞。无数宝缯带。无数宝鬘。无数宝严具。无数宝华。无数宝香。种种奇妙。以为严饰。无数采女。种种歌赞。阎浮提内。复有无量百千万亿诸罗刹王。诸夜叉王鸠槃荼王。毗舍阇王。或住大海。或居陆地。饮血啖肉。残害众生。皆起慈心。愿行利益。明识后世。不造诸恶。恭敬合掌。顶礼于王。如阎浮提。余三天下。乃至三千大千世界。乃至十方百千万亿那由他世界中。所有一切毒恶众生。悉亦如是。时大光王。从三昧起。告善财言。善男子。我唯知此菩萨大慈为首随顺世间三昧门。如诸菩萨摩诃萨。为高盖。慈心普荫诸众生故。为修行。下中上行悉等行故。为大地。能以慈心任持一切诸众生故。为满月。福德光明于世间中平等现故。为净日。以智光明照耀一切所知境故。为明灯。能破一切众生心中诸黑闇故。为水清珠。能清一切众生心中谄诳浊故。为如意宝。悉能满足一切众生心所愿故。为大风。速令众生修习三昧入一切智大城中故。而我云何能知其行能说其德。能称量彼福德大山。能瞻仰彼功德众星。能观察彼大愿风轮。能趣入彼甚深法门。能显示彼庄严大海。能阐明彼普贤行门。能开示彼诸三昧窟。能赞叹彼大慈悲云。善男子。于此南方。有一王都。名曰安住。有优婆夷。名曰不动。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼王足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。出妙光城。游行道路。正念思惟。大光王教。忆念菩萨大慈幢行门。思惟菩萨随顺世间三昧光明门。增长彼不思议愿福德自在力。坚固彼不思议成熟众生智。观察彼不思议不共受用大威德。忆念彼不思议差别相。思惟彼不思议清净眷属。思惟彼不思议所作业。生欢喜心。生净信心。生猛利心。生欣悦心。生踊跃心。生庆幸心。生无浊心。生清净心。生坚固心。生广大心。生无尽心。如是思惟。悲泣流泪。念善知识。实为希有。出生一切诸功德处。出生一切诸菩萨行。出生一切菩萨净念。出生一切陀罗尼轮。出生一切三昧光明。出生一切诸佛知见。普雨一切诸佛法雨。显示一切菩萨愿门。出生难思智慧光明。增长一切菩萨根芽。又作是念。善知识者。能普救护一切恶道。能普演说诸平等法。能普显示诸夷险道。能普开阐大乘奥义。能普劝发普贤诸行。能普引到一切智城。能普令入法界大海。能普令见三世法海。能普授与众圣道场。能普增长一切白法。善财童子。如是悲哀。思念之时。彼常随逐。觉悟菩萨。如来使天。于虚空中。而告之言。善男子。其有修行善知识教。诸佛世尊。悉皆欢喜。其有随顺善知识语。则得近于一切智地。其有能于善知识语无疑惑者。则常值遇一切善友。其有发心愿常不离善知识者。则得具足一切义利。善男子。汝可往诣安住王都。即当得见不动优婆夷大善知识。时善财童子。从彼三昧智光明起。渐次游行。至安住城。周遍推求不动优婆夷。今在何所。无量人众。咸告之言。善男子。不动优婆夷。身是童女在其家内。父母守护。与自亲属无量人众。演说妙法。善财童子。闻是语已。其心欢喜。如见父母。即诣不动优婆夷舍。入其宅内。见彼堂宇。金色光明。普皆照耀遇斯光者。身意清凉。善财童子。光明触身。即时获得五百三昧门。所谓了一切希有相三昧门。入寂静三昧门。远离一切世间三昧门。普眼舍得三昧门。如来藏三昧门。得如是等五百三昧门。以此三昧门故。身心柔软。如七日胎。又闻妙香。非诸天龙乾闼婆等。人与非人之所能有。善财童子。前诣其所。恭敬合掌。一心观察。见其形色。端正殊妙。十方世界一切女人。无有能及。况其过者。唯除如来及以一切灌顶菩萨。口出妙香。宫殿庄严。并其眷属。悉无与等。况复过者。十方世界。一切众生。无有于此优婆夷所。起染着心。若得暂见。所有烦恼。悉自消灭。譬如百万大梵天王。决定不生欲界烦恼。其有见此优婆夷者。所有烦恼应知亦然。十方众生。观此女人。皆无厌足。唯除具足大智慧者。尔时善财童子。曲躬合掌。正念观察。见此女人。其身自在。不可思议。色相颜容。世无与等。光明洞彻。物无能障。普为众生。而作利益。其身毛孔。恒出妙香。眷属无边。宫殿第一。功德深广。莫知涯际。心生欢喜。以颂赞曰

  守护清净戒　　修行广大忍
  精进不退转　　光明照世间

尔时善财童子。说此颂已。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时不动优婆夷。以菩萨柔软语悦意语。慰谕善财。而告之言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我得菩萨难摧伏智慧藏解脱门。我得菩萨坚固受持行门。我得菩萨一切法平等地总持门。我得菩萨照明一切法辩才门。我得菩萨求一切法无疲厌三昧门。善财童子言。圣者。菩萨难摧伏智慧藏解脱门。乃至求一切法无疲厌三昧门。境界云何。童女言。善男子。此处难知。善财白言。唯愿圣者。承佛神力。为我宣说。我当因善知识。能信能受。能知能了。趣入观察。修习随顺。离诸分别。究竟平等。优婆夷言。善男子。过去世中有劫。名离垢。佛号修臂。时有国王。名曰电授。唯有一女。即我身是。我于夜分。废音乐时。父母兄弟。悉已眠寝。五百童女。亦皆昏寐。我于楼上。仰观星宿。于虚空中。见彼如来如宝山王。无量无边。天龙八部。诸菩萨众。所共围绕。佛身普放大光明网。周遍十方。无所障碍。佛身毛孔。皆出妙香。我闻是香。身体柔软。心生欢喜。便从楼下。至于地上。合十指爪。顶礼于佛。又观彼佛。不见顶相。观身左右。莫知边际。思惟彼佛诸相随好。无有厌足。窃自念言。此佛世尊。作何等业。获于如是上妙之身。相好圆满。光明具足。眷属成就。宫殿严好。福德智慧。悉皆清净。总持三昧。不可思议神通自在。辩才无碍。善男子。尔时如来。知我心念。即告我言。汝应发不可坏心灭诸烦恼。应发无能胜心破诸取着。应发无退怯心入深法门。应发能堪耐心救恶众生。应发无迷惑心普于一切诸趣受生。应发无厌足心。求见诸佛无有休息。应发无知足心。悉受一切如来法雨。应发正思惟心。普生一切佛法光明。应发大住持心。普转一切诸佛法轮。应发广流通心。随众生欲施其法宝。善男子。我于彼佛所。闻如是法。求一切智。求佛十力。求佛辩才。求佛光明。求佛色身。求佛相好。求佛众会。求佛国土。求佛威仪。求佛寿命。发是心已。其心坚固。犹如金刚。一切烦恼。及以二乘。悉不能坏。善男子。我发是心已来。经阎浮提微尘数劫。尚不生于念欲之心。况行其事。尔所劫中。于自亲属。不起嗔心。况他众生。尔所劫中。于其自身。不生我见。况于众具。而计我所。尔所劫中。死时生时。及住胎藏。未曾迷惑。起众生想。及无记心。况于余时。尔所劫中。乃至梦中。随见一佛。未曾忘失。何况菩萨十眼所见。尔所劫中。受持一切如来正法。未曾忘失一文一句。乃至世俗所有言辞。尚不忘失。何况如来金口所说。尔所劫中。受持一切如来法海。一文一句。无不思惟。无不观察。乃至一切世俗之法。亦复如是。尔所劫中。受持如是一切法海。未曾于一法中。不得三昧。乃至世间技术之法。一一法中。悉亦如是。尔所劫中。住持一切如来法轮。随所住持。未曾废舍一文一句。乃至不曾生于世智。唯除为欲调众生故。尔所劫中。见诸佛海。未曾于一佛所。不得成就清净大愿。乃至于诸化佛之所。悉亦如是。尔所劫中。见诸菩萨修行妙行。无有一行我不成就。尔所劫中。所见众生。无一众生我不劝发阿耨多罗三藐三菩提心。未曾劝一众生发于声闻辟支佛意。尔所劫中。于一切佛法乃至一文一句。不生疑惑。不生二想。不生分别想。不生种种想。不生执着想。不生胜劣想。不生爱憎想。善男子。我从是来。常见诸佛。常见菩萨。常见真实善知识。常闻诸佛愿。常闻菩萨行。常闻菩萨波罗蜜门。常闻菩萨地智光明门。常闻菩萨无尽藏门。常闻入无边世界网门。常闻出生无边众生界因门。常以清净智慧光明。除灭一切众生烦恼。常以智慧。生长一切众生善根。常随一切众生所乐。示现其身。常以清净上妙言音。开悟法界一切众生。善男子。我得菩萨求一切法无厌足庄严门。我得一切法平等地总持门。现不思议自在神变。汝欲见不。善财言唯。我心愿见。尔时不动优婆夷。坐于龙藏师子之座。入求一切法无厌足庄严三昧门。不空轮庄严三昧门。十力智轮现前三昧门。佛种无尽藏三昧门。入如是等一万三昧门。入此三昧门时。十方各有不可说佛刹微尘数世界。六种震动。皆悉清净琉璃所成。一一世界中。有百亿四天下。百亿如来。或住兜率天。乃至般涅槃。一一如来。放光明网。周遍法界道场众会。清净围绕。转妙法轮。开悟群生。时不动优婆夷。从三昧起。告善财言。善男子。汝见此不。善财言唯。我皆已见。优婆夷言。善男子。我唯得此求一切法无厌足三昧光明。为一切众生。说微妙法。皆令欢喜。如诸菩萨摩诃萨如金翅鸟。游行虚空。无所障碍。能入一切众生大海。见有善根已成熟者。便即执取置菩提岸。又如商客入大宝洲。采求如来十力智宝。又如渔师持正法网。入生死海。于爱水中。漉诸众生。如阿修罗王能遍挠动三有大城诸烦恼海。又如日轮出现虚空。照爱水泥。令其干竭。又如满月出现虚空。令可化者。心华开敷。又如大地普皆平等。无量众生。于中止住。增长一切善法根芽。又如大风所向无碍。能拔一切诸见大树。如转轮王游行世间。以四摄事。摄诸众生。而我云何能知能说彼功德行。善男子。于此南方。有一大城。名无量都萨罗。其中有一出家外道。名曰遍行。汝往彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第六十六大方广佛华严经卷第六十七

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之八

尔时善财童子。于不动优婆夷所。得闻法已。专心忆念所有教诲。皆悉信受。思惟观察。渐渐游行。经历国邑。至都萨罗城。于日没时。入彼城中。廛店邻里。四衢道侧。处处寻觅遍行外道。城东有山。名曰善德。善财童子。于中夜时。见此山顶。草树岩巘。光明照耀。如日初出。见此事已。生大欢喜。作是念言。我必于此。见善知识。便从城出。而登彼山。见此外道于其山上平坦之处。徐步经行。色相圆满。威光照耀。大梵天王。所不能及。十千梵众之所围绕。往诣其所。头顶礼足。绕无量匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而我未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。遍行答言。善哉善哉。善男子。我已安住至一切处菩萨行。已成就普观世间三昧门。已成就无依无作神通力。已成就普门般若波罗蜜。善男子。我普于世间种种方所。种种形貌。种种行解。种种没生。一切诸趣。所谓天趣龙趣。夜叉趣。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。地狱畜生。阎罗王界。人非人等。一切诸趣。或住诸见。或信二乘。或复信乐大乘之道。如是一切诸众生中。我以种种方便。种种智门。而为利益。所谓或为演说一切世间种种技艺。令得具足一切巧术陀罗尼智。或为演说四摄方便。令得具足一切智道。或为演说诸波罗蜜。令其回向一切智位。或为称赞大菩提心。令其不失无上道意。或为称赞诸菩萨行。令其满足净佛国土度众生愿。或为演说造诸恶行。受地狱等种种苦报。令于恶业。深生厌离。或为演说供养诸佛。种诸善根。决定获得一切智果。令其发起欢喜之心。或为赞说一切如来应正等觉。所有功德。令乐佛身。求一切智。或为赞说诸佛威德。令其愿乐佛不坏身。或为赞说佛自在身。令求如来无能映蔽大威德体。又善男子。此都萨罗城中。一切方所。一切族类。若男若女。诸人众中。我皆以方便。示同其形。随其所应。而为说法。诸众生等。悉不能知。我是何人。从何而至。唯令闻者。如实修行。善男子。如于此城利益众生。于阎浮提城邑聚落。所有人众。住止之处。悉亦如是。而为利益。善男子。阎浮提内九十六众。各起异见。而生执着。我悉于中。方便调伏。令其舍离所有诸见。如阎浮提。余四天下。亦复如是。如四天下。三千大千世界。亦复如是。如三千大千世界。如是十方无量世界。诸众生海。我悉于中。随诸众生心之所乐。以种种方便。种种法门。现种种色身。以种种言音。而为说法。令得利益。善男子。我唯知此至一切处菩萨行。如诸菩萨摩诃萨。身与一切众生数等。得与众生无差别身。以变化身。普入诸趣。于一切处。皆现受生。普现一切众生之前。清净光明。遍照世间。以无碍愿住一切劫。得如帝网诸无等行。常勤利益一切众生。恒与共居。而无所著。普于三世。悉皆平等。以无我智。周遍照耀。以大悲藏。一切观察。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名为广大。有鬻香长者。名优钵罗华。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。因善知识教。不顾身命。不着财宝。不乐人众。不耽五欲。不恋眷属。不重王位。唯愿化度一切众生。唯愿严净诸佛国土。唯愿供养一切诸佛。唯愿证知诸法实性。唯愿修集一切菩萨大功德海。唯愿修行一切功德终无退转。唯愿恒于一切劫中以大愿力修菩萨行。唯愿普入一切诸佛众会道场。唯愿入一三昧门普现一切三昧门自在神力。唯愿于佛一毛孔中见一切佛心无厌足。唯愿得一切法智慧光明。能持一切诸佛法藏。专求此等一切诸佛菩萨功德。渐次游行。至广大国。诣长者所。顶礼其足。绕无量匝。合掌而立。白言。圣者。我已先发阿耨多罗三藐三菩提心。欲求一切佛平等智慧。欲满一切佛无量大愿。欲净一切佛最上色身。欲见一切佛清净法身。欲知一切佛广大智身。欲净治一切菩萨诸行。欲照明一切菩萨三昧。欲安住一切菩萨总持。欲除灭一切所有障碍。欲游行一切十方世界。而未知菩萨云何学菩萨行。云何修菩萨道。而能出生一切智智。长者告言。善哉善哉。善男子。汝乃能发阿耨多罗三藐三菩提心。善男子。我善别知一切诸香。亦知调合一切香法。所谓一切香。一切烧香。一切涂香。一切末香。亦知如是一切香王所出之处。又善了知天香。龙香。夜叉香。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。所有诸香。又善别知治诸病香。断诸恶香。生欢喜香。增烦恼香。灭烦恼香。令于有为生乐着香。令于有为生厌离香。舍诸憍逸香。发心念佛香。证解法门香。圣所受用香。一切菩萨差别香。一切菩萨地位香。如是等香。形相生起。出现成就。清净安隐。方便境界。威德业用。及以根本。如是一切我皆了达。善男子。人间有香。名曰象藏。因龙斗生。若烧一丸。即起大香云。弥覆王都。于七日中。雨细香雨。若着身者。身则金色。若着衣服。宫殿楼阁。亦皆金色。若因风吹。入宫殿中。众生嗅者。七日七夜。欢喜充满。身心快乐。无有诸病。不相侵害。离诸忧苦。不惊不怖。不乱不恚。慈心相向。志意清净。我知是已。而为说法。令其决定发阿耨多罗三藐三菩提心。善男子。摩罗耶山。出栴檀香。名曰牛头。若以涂身。设入火坑。火不能烧。善男子。海中有香。名无能胜。若以涂鼓及诸螺贝。其声发时。一切敌军。皆自退散。善男子。阿那婆达多池边。出沉水香。名莲华藏。其香一丸。如麻子大。若以烧之。香气普熏阎浮提界。众生闻者。离一切罪。戒品清净。善男子。雪山有香。名阿卢那。若有众生。嗅此香者。其心决定。离诸染着。我为说法。莫不皆得离垢三昧。善男子。罗刹界中有香。名海藏。其香但为转轮王用。若烧一丸。而以熏之。王及四军。皆腾虚空。善男子。善法天中有香。名净庄严。若烧一丸。而以熏之。普使诸天。心念于佛。善男子。须夜摩天有香。名净藏。若烧一丸。而以熏之。夜摩天众。莫不云集彼天王所。而共听法。善男子。兜率天中有香。名先陀婆。于一生所系菩萨座前。烧其一丸。兴大香云。遍覆法界。普雨一切诸供养具。供养一切诸佛菩萨。善男子。善变化天有香。名曰夺意。若烧一丸。于七日中。普雨一切诸庄严具。善男子。我唯知此调和香法。如诸菩萨摩诃萨。远离一切诸恶习气。不染世欲。永断烦恼众魔罥索。超诸有趣。以智慧香。而自庄严。于诸世间。皆无染着。具足成就无所著戒。净无著智。行无著境。于一切处。悉无有着。其心平等。无著无依。而我何能知其妙行。说其功德。显其所有清净戒门。示其所作无过失业。辨其离染身语意行。善男子。于此南方。有一大城。名曰楼阁。中有船师。名婆施罗。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。向楼阁城。观察道路。所谓观道高卑。观道夷险。观道净秽。观道曲直。渐次游行。作是思惟。我当亲近彼善知识。善知识者。是成就修行诸菩萨道因。是成就修行波罗蜜道因。是成就修行摄众生道因。是成就修行普入法界。无障碍道因。是成就修行令一切众生除恶慧道因。是成就修行令一切众生离憍慢道因。是成就修行令一切众生灭烦恼道因。是成就修行令一切众生舍诸见道因。是成就修行令一切众生拔一切恶刺道因。是成就修行令一切众生至一切智城道因。何以故。于善知识处。得一切善法故。依善知识力。得一切智道故。善知识者。难见难遇。如是思惟。渐次游行。既至彼城。见其船师。在城门外海岸上住。百千商人。及余无量大众围绕。说大海法。方便开示佛功德海。善财见已。往诣其所。顶礼其足。绕无量匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。船师告言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。今复能问生大智因。断除一切生死苦因。往一切智大宝洲因。成就不坏摩诃衍因。远离二乘怖畏生死住诸寂静三昧旋因。乘大愿车。遍一切处行菩萨行无有障碍清净道因。以菩萨行庄严一切无能坏智清净道因。普观一切十方诸法。皆无障碍清净道因。速能趣入一切智海清净道因。善男子。我在此城海岸路中。净修菩萨大悲幢行。善男子。我观阎浮提内。贫穷众生。为饶益故。修诸苦行。随其所愿。悉令满足。先以世物。充满其意。复施法财。令其欢喜。令修福行。令生智道。令增善根力。令起菩提心。令净菩提愿。令坚大悲力。令修能灭生死道。令生不厌生死行。令摄一切众生海。令修一切功德海。令照一切诸法海。令见一切诸佛海。令入一切智智海。善男子。我住于此如是思惟。如是作意。如是利益一切众生。善男子。我知海中一切宝洲。一切宝处。一切宝类。一切宝种。我知净一切宝。钻一切宝。出一切宝。作一切宝。我知一切宝器。一切宝用。一切宝境界。一切宝光明。我知一切龙宫处。一切夜叉宫处。一切部多宫处。皆善回避。免其诸难。亦善别知漩澓浅深。波涛远近。水色好恶。种种不同。亦善别知日月星宿。运行度数。昼夜晨晡。晷漏延促。亦知其船铁木坚脆。机关涩滑。水之大小。风之逆顺。如是一切安危之相。无不明了。可行则行。可止则止。善男子。我以成就如是智慧。常能利益一切众生。善男子。我以好船。运诸商众。行安隐道。复为说法。令其欢喜。引至宝州。与诸珍宝。咸使充足。然后将领。还阎浮提。善男子。我将大船。如是往来。未始令其一有损坏。若有众生。得见我身。闻我法者。令其永不怖生死海。必得入于一切智海。必能消竭诸爱欲海。能以智光。照三世海。能尽一切众生苦海。能净一切众生心海。速能严净一切刹海。普能往诣十方大海。普知一切众生根海。普了一切众生行海。普顺一切众生心海。善男子。我唯得此大悲幢行。若有见我。及以闻我。与我同住。忆念我者。皆悉不空。如诸菩萨摩诃萨。善能游涉生死大海。不染一切诸烦恼海。能舍一切诸妄见海。能观一切诸法性海。能以四摄。摄众生海。已善安住一切智海。能灭一切众生着海。能平等住一切时海。能以神通。度众生海。能以其时。调众生海。而我云何能知能说彼功德行。善男子。于此南方。有城名可乐。中有长者。名无上胜。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。悲泣流泪。求善知识。心无厌足。辞退而去

尔时善财童子。起大慈周遍心。大悲润泽心。相续不断。福德智慧二种庄严。舍离一切烦恼尘垢。证法平等。心无高下。拔不善刺。灭一切障。坚固精进以为墙堑。甚深三昧而作园苑。以慧日光破无明暗。以方便风开智慧华。以无碍愿充满法界。心常现入一切智城。如是而求菩萨之道。渐次经历。到彼城内。见无上胜在其城东大庄严幢无忧林中。无量商人。百千居士之所围绕。理断人间种种事务。因为说法。令其永拔一切我慢。离我我所。舍所积聚。灭悭嫉垢。心得清净。无诸秽浊。获净信力。常乐见佛。受持佛法。生菩萨力。起菩萨行。入菩萨三昧。得菩萨智慧。住菩萨正念。增菩萨乐欲。尔时善财童子。观彼长者为众说法已。以身投地。顶礼其足。良久乃起。白言。圣者。我是善财。我是善财。我专寻求菩萨之行。菩萨云何学菩萨行。菩萨云何修菩萨道。随修学时。常能化度一切众生。常能现见一切诸佛。常得听闻一切佛法。常能住持一切佛法。常能趣入一切法门。入一切刹。学菩萨行。住一切劫。修菩萨道。能知一切如来神力。能受一切如来护念。能得一切如来智慧。时彼长者。告善财言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我成就至一切处菩萨行门无依无作神通之力。善男子。云何为至一切处菩萨行门。善男子。我于此三千大千世界。欲界一切诸众生中。所谓一切三十三天。一切须夜摩天。一切兜率陀天。一切善变化天。一切他化自在天。一切魔天。及余一切天龙夜叉罗刹娑鸠槃茶乾闼婆。阿修罗迦楼罗紧那罗摩睺罗伽人与非人。村营城邑。一切住处。诸众生中。而为说法。令舍非法。令息诤论。令除斗战。令止忿竞。令破怨结。令解系缚。令出牢狱。令免怖畏。令断杀生。乃至邪见一切恶业。不可作事。皆令禁止。令其顺行一切善法。令其修学一切技艺。于诸世间而作利益。为其分别种种诸论。令生欢喜。令渐成熟。随顺外道。为说胜智。令断诸见。令入佛法。乃至色界一切梵天。我亦为其说超胜法。如于此三千大千世界。乃至十方十不可说百千亿那由他佛刹微尘数世界中。我皆为说佛法。菩萨法。声闻法。独觉法。说地狱。说地狱众生。说向地狱道。说畜生。说畜生差别。说畜生受苦。说向畜生道。说阎罗王世间。说阎罗王世间苦。说向阎罗王世间道。说天世间。说天世间乐。说向天世间道。说人世间。说人世间苦乐。说向人世间道。为欲开显菩萨功德。为令舍离生死过患。为令知见一切智人诸妙功德。为欲令知诸有趣中迷惑受苦。为令知见无障碍法。为欲显示一切世间生起所因。为欲显示一切世间寂灭为乐。为令众生舍诸想着。为令证得佛无依法。为令永灭诸烦恼轮。为令能转如来法轮。我为众生。说如是法。善男子。我唯知此至一切处修菩萨行清净法门。无依无作神通之力。如诸菩萨摩诃萨。具足一切自在神通。悉能遍往一切佛刹。得普眼地。悉闻一切音声言说。普入诸法智慧自在。无有乖诤。勇健无比。以广长舌。出平等音。其身妙好。同诸菩萨。与诸如来究竟无二。无有差别。智身广大普入三世。境界无际同于虚空。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名曰输那。其国有城。名迦陵迦林。有比丘尼。名师子频申。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。渐次游行。至彼国城。周遍推求此比丘尼。有无量人。咸告之言。善男子。此比丘尼。在胜光王之所舍施日光园中。说法利益无量众生。时善财童子。即诣彼园。周遍观察。见其园中。有一大树。名为满月。形如楼阁。放大光明。照一由旬。见一叶树。名为普覆。其形如盖。放毗琉璃绀青光明。见一华树。名曰华藏。其形高大。如雪山王。雨众妙华。无有穷尽。如忉利天中波利质多罗树。复见有一甘露果树。形如金山。常放光明。种种众果。悉皆具足。复见有一摩尼宝树。名毗卢遮那藏。其形无比。心王摩尼宝。最在其上阿僧祇色相摩尼宝。周遍庄严。复有衣树。名为清净种种色衣。垂布严饰。复有音乐树。名为欢喜。其音美妙。过诸天乐。复有香树。名普庄严。恒出妙香。普熏十方。无所障碍。园中复有泉流陂池。一切皆以七宝庄严。黑栴檀泥。凝积其中。上妙金沙。弥布其底。八功德水。具足盈满。优钵罗华。波头摩华。拘物头华。芬陀利华。遍覆其上。无量宝树。周遍行列。诸宝树下。敷师子座。种种妙宝。以为庄严。布以天衣。熏诸妙香。垂诸宝缯。施诸宝帐。阎浮金网。弥覆其上。宝铎徐摇。出妙音声。或有树下敷莲华藏师子之座。或有树下敷香王摩尼藏师子之座。或有树下敷龙庄严摩尼王藏师子之座。或有树下敷宝师子聚摩尼王藏师子之座。或有树下敷毗卢遮那摩尼王藏师子之座。或有树下敷十方毗卢遮那摩尼王藏师子之座。其一一座。各有十万宝师子座。周匝围绕。一一皆具无量庄严。此大园中。众宝遍满。犹如大海宝洲之上。迦邻陀衣。以布其地。柔软妙好。能生乐触。蹈则没足。举则还复。无量诸鸟。出和雅音。宝栴檀林。上妙庄严。种种妙华。常雨无尽。犹如帝释杂华之园。无比香王普熏一切。犹如帝释善法之堂。诸音乐树宝多罗树众宝铃网出妙音声。如自在天善口天女所出歌音。诸如意树种种妙衣垂布庄严。犹如大海有无量色百千楼阁。众宝庄严。如忉利天宫善见大城。宝盖遐张如须弥峰。光明普照如梵王宫。尔时善财童子。见此大园无量功德。种种庄严。皆是菩萨业报成就。出世善根之所生起。供养诸佛功德所流。一切世间无与等者。如是皆从师子频申比丘尼了法如幻集。广大清净福德善业之所成就。三千大千世界。天龙八部。无量众生。皆入此园。而不迫窄。何以故。此比丘尼。不可思议威神力故。尔时善财。见师子频申比丘尼。遍坐一切诸宝树下大师子座。身相端严。威仪寂静。诸根调顺如大象王。心无垢浊如清净池。普济所求如如意宝。不染世法犹如莲华。心无所畏如师子王。护持净戒不可倾动如须弥山。能令见者心得清凉如妙香王。能除众生诸烦恼热如雪山中妙栴檀香。众生见者诸苦消灭如善见药王。见者不空如婆楼那天。能长一切众善根芽如良沃田。在一一座。众会不同。所说法门。亦各差别。或见处座净居天众所共围绕。大自在天子而为上首。此比丘尼为说法门。名无尽解脱。或见处座诸梵天众所共围绕。爱乐梵王而为上首。此比丘尼为说法门。名普门差别清净言音轮。或见处座他化自在天天子天女所共围绕。自在天王而为上首。此比丘尼为说法门。名菩萨清净心。或见处座善变化天天子天女所共围绕。善化天王而为上首。此比丘尼为说法门。名一切法善庄严。或见处座兜率陀天天子天女所共围绕。兜率天王而为上首。此比丘尼为说法门。名心藏旋。或见处座须夜摩天天子天女所共围绕夜摩天王而为上首。此比丘尼为说法门。名无边庄严。或见处座三十三天天子天女所共围绕。释提桓因而为上首。此比丘尼为说法门。名厌离门。或见处座百光明龙王难陀龙王优波难陀龙王摩那斯龙王伊罗跋难陀龙王阿那婆达多龙王等龙子龙女所共围绕。娑伽罗龙王而为上首。此比丘尼为说法门。名佛神通境界光明庄严。或见处座诸夜叉众所共围绕。毗沙门天王而为上首。此比丘尼为说法门。名救护众生藏。或见处座。乾闼婆众所共围绕。持国乾闼婆王而为上首。此比丘尼为说法门。名无尽喜。或见处座阿修罗众所共围绕。罗睺阿修罗王而为上首。此比丘尼为说法门。名速疾庄严法界智门。或见处座迦楼罗众所共围绕。捷持迦楼罗王而为上首。此比丘尼为说法门。名怖动诸有海。或见处座紧那罗众所共围绕。大树紧那罗王而为上首。此比丘尼为说法门。名佛行光明。或见处座摩睺罗伽众所共围绕。庵罗林摩睺罗伽王而为上首。此比丘尼为说法门。名生佛欢喜心。或见处座无量百千男子女人所共围绕。此比丘尼为说法门。名殊胜行。或见处座诸罗刹众所共围绕。常夺精气大树罗刹王而为上首。此比丘尼为说法门。名发生悲愍心。或见处座信乐声闻。乘众生所共围绕。此比丘尼为说法门。名胜智光明。或见处座信乐缘觉乘众生所共围绕。此比丘尼为说法门。名佛功德广大光明。或见处座信乐大乘众生所共围绕。此比丘尼为说法门。名普门三昧智光明门。或见处座初发心诸菩萨所共围绕。此比丘尼为说法门。名一切佛愿聚。或见处座第二地诸菩萨所共围绕。此比丘尼为说法门。名离垢轮。或见处座第三地诸菩萨所共围绕。此比丘尼为说法门。名寂静庄严。或见处座第四地诸菩萨所共围绕。此比丘尼为说法门。名生一切智境界。或见处座第五地诸菩萨所共围绕。此比丘尼为说法门。名妙华藏。或见处座第六地诸菩萨所共围绕。此比丘尼为说法门。名毗卢遮那藏。或见处座第七地诸菩萨所共围绕。此比丘尼为说法门。名普庄严地。或见处座第八地诸菩萨所共围绕。此比丘尼为说法门。名遍法界境界身。或见处座第九地诸菩萨所共围绕。此比丘尼为说法门。名无所得力庄严。或见处座第十地诸菩萨所共围绕。此比丘尼为说法门。名无碍轮。或见处座执金刚神所共围绕。此比丘尼为说法门。名金刚智那罗延庄严。善财童子。见如是等一切诸趣所有众生。已成熟者。已调伏者。堪为法器。皆入此园。各于座下。围绕而坐。师子频申比丘尼。随其欲解胜劣差别。而为说法。令于阿耨多罗三藐三菩提。得不退转。何以故。此比丘尼。入普眼舍得般若波罗蜜门。说一切佛法般若波罗蜜门。法界差别般若波罗蜜门。散坏一切障碍轮般若波罗蜜门。生一切众生善心般若波罗蜜门。殊胜庄严般若波罗蜜门。无碍真实藏般若波罗蜜门。法界圆满般若波罗蜜门。心藏般若波罗蜜门。普出生藏般若波罗蜜门。此十般若波罗蜜门为首。入如是等无数百万般若波罗蜜门。此日光园中。所有菩萨。及诸众生。皆是师子频申比丘尼。初劝发心。受持正法。思惟修习。于阿耨多罗三藐三菩提。得不退转。时善财童子。见师子频申比丘尼。如是园林。如是床座。如是经行。如是众会。如是神力。如是辩才。复闻不可思议法门。广大法云。润泽其心。便生是念。我当右绕无量百千匝。时比丘尼。放大光明。普照其园众会庄严。善财童子。即自见身及园林中。所有众树。皆悉右绕此比丘尼。经于无量百千万匝。围绕毕已。善财童子。合掌而住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。比丘尼言。善男子。我得解脱。名成就一切智。善财言。圣者何故。名为成就一切智。比丘尼言。善男子。此智光明。于一念中。普照三世一切诸法。善财白言。圣者。此智光明境界云何。比丘尼言。善男子。我入此智光明门。得出生一切法三昧王。以此三昧故。得意生身。往十方一切世界兜率天宫一生所系菩萨所。一一菩萨前。现不可说佛刹微尘数身。一一身。作不可说佛刹微尘数供养。所谓现天王身。乃至人王身。执持华云。执持鬘云。烧香涂香。及以末香。衣服璎珞。幢幡缯盖。宝网宝帐。宝藏宝灯。如是一切诸庄严具。我皆执持。而以供养。如于住兜率宫菩萨所。如是于住胎出胎。在家出家。往诣道场。成等正觉。转正法轮。入于涅槃。如是中间。或住天宫。或住龙宫。乃至或复住于人宫。于彼一一诸如来所。我皆如是而为供养。若有众生。知我如是供养佛者。皆于阿耨多罗三藐三菩提。得不退转。若有众生来至我所。我即为说般若波罗蜜。善男子。我见一切众生。不分别众生相。智眼明见故。听一切语言。不分别语言相。心无所著故。见一切如来。不分别如来相。了达法身故。住持一切法轮。不分别法轮相。悟法自性故。一念遍知一切法。不分别诸法相。知法如幻故。善男子。我唯知此成就一切智解脱。如诸菩萨摩诃萨。心无分别。普知诸法。一身端坐。充满法界。于自身中现一切刹。一念悉诣一切佛所。于自身内。普现一切诸佛神力。一毛遍举不可言说诸佛世界。于其自身一毛孔中。现不可说世界成坏。于一念中。与不可说不可说众生同住。于一念中。入不可说不可说一切诸劫。而我云何能知能说彼功德行。善男子。于此南方。有一国土。名曰险难。此国有城。名宝庄严。中有女人。名婆须蜜多。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第六十七大方广佛华严经卷第六十八

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之九

尔时善财童子。大智光明。照启其心。思惟观察。见诸法性。得了知一切言音陀罗尼门。得受持一切法轮陀罗尼门。得与一切众生作所归依大悲力。得观察一切法义理光明门。得充满法界清净愿。得普照十方一切法智光明。得遍庄严一切世界自在力。得普发起一切菩萨业圆满愿。渐次游行。至险难国宝庄严城。处处寻觅婆须蜜多女。城中有人。不知此女功德智慧。作如是念。今此童子。诸根寂静。智慧明了。不迷不乱。谛视一寻。无有疲懈。无所取着。目视不瞬。心无所动。甚深宽广。犹如大海。不应于此婆须蜜女。有贪爱心。有颠倒心。生于净想。生于欲想。不应为此女色所摄。此童子者。不行魔行。不入魔境。不没欲泥。不被魔缚。不应作处。已能不作。有何等意。而求此女。其中有人。先知此女有智慧者。告善财言。善哉善哉。善男子。汝今乃能推求寻觅婆须蜜女。汝已获得广大善利。善男子。汝应决定求佛果位。决定欲为一切众生作所依怙。决定欲拔一切众生贪爱毒箭。决定欲破一切众生于女色中所有净想。善男子。婆须蜜女。于此城内市廛之北。自宅中住。时善财童子。闻是语已。欢喜踊跃。往诣其门。见其住宅。广博严丽。宝墙宝树。及以宝堑。一一皆有十重围绕。其宝堑中。香水盈满。金沙布地。诸天宝华。优钵罗华。波头摩华。拘物头华。芬陀利华。遍覆水上。宫殿楼阁。处处分布。门闼窗牖。相望间列。咸施网铎。悉置幡幢。无量珍奇。以为严饰。琉璃为地。众宝间错。烧诸沉水。涂以栴檀。悬众宝铃。风动成音。散诸天华。遍布其地。种种严丽。不可称说。诸珍宝藏。其数百千。十大园林。以为庄严。尔时善财。见此女人。颜貌端严。色相圆满。皮肤金色。目发绀青。不长不短。不粗不细。欲界人天。无能与比。音声美妙。超诸梵世。一切众生。差别言音。悉皆具足。无不解了。深达字义。善巧谈说。得如幻智。入方便门。众宝璎珞。及诸严具。庄严其身。如意摩尼以为宝冠而冠其首。复有无量眷属围绕。皆共善根同一行愿。福德大藏。具足无尽。时婆须蜜多女。从其身出广大光明。普照宅中一切宫殿。遇斯光者。身得清凉。尔时善财。前诣其所。顶礼其足。合掌而住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。彼即告言。善男子。我得菩萨解脱。名离贪欲际。随其欲乐。而为现身。若天见我。我为天女。形貌光明。殊胜无比。如是乃至人非人等。而见我者。我即为现人非人女。随其乐欲。皆令得见。若有众生。欲意所缠。来诣我所。我为说法。彼闻法已。则离贪欲。得菩萨无著境界三昧。若有众生。暂见于我。则离贪欲。得菩萨欢喜三昧。若有众生。暂与我语。则离贪欲。得菩萨无碍音声三昧。若有众生。暂执我手。则离贪欲。得菩萨遍往一切佛刹三昧。若有众生。暂升我座。则离贪欲。得菩萨解脱光明三昧。若有众生。暂观于我。则离贪欲。得菩萨寂静庄严三昧。若有众生。见我频申。则离贪欲。得菩萨摧伏外道三昧。若有众生。见我目瞬。则离贪欲。得菩萨佛境界光明三昧。若有众生。抱持于我。则离贪欲。得菩萨摄一切众生恒不舍离三昧。若有众生。唼我唇吻。则离贪欲。得菩萨增长一切众生福德藏三昧。凡有众生。亲近于我。一切皆得住离贪际。入菩萨一切智地现前无碍解脱。善财白言。圣者。种何善根。修何福业。而得成就如是自在。答言。善男子。我念过去。有佛出世。名为高行。其王都城。名曰妙门。善男子。彼高行如来。哀愍众生。入于王城。蹈彼门阃。其城一切悉皆震动。忽然广博。众宝庄严。无量光明。递相映彻。种种宝华散布其地。诸天音乐同时俱奏。一切诸天充满虚空。善男子。我于彼时。为长者妻。名曰善慧。见佛神力。心生觉悟。则与其夫。往诣佛所。以一宝钱。而为供养。是时文殊师利童子。为佛侍者。为我说法。令发阿耨多罗三藐三菩提心。善男子。我唯知此菩萨离贪际解脱。如诸菩萨摩诃萨。成就无边巧方便智。其藏广大。境界无比。而我云何能知能说彼功德行。善男子。于此南方有城。名善度。中有居士。名鞞瑟胝罗。彼常供养栴檀座佛塔。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。渐次游行。至善度城。诣居士宅。顶礼其足。合掌而立。白言圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。居士告言。善男子。我得菩萨解脱。名不般涅槃际。善男子。我不生心言如是如来已般涅槃。如是如来现般涅槃。如是如来当般涅槃。我知十方一切世界诸佛如来。毕竟无有般涅槃者。唯除为欲调伏众生而示现耳。善男子。我开栴檀座如来塔门时。得三昧。名佛种无尽。善男子。我念念中。入此三昧。念念得知一切无量殊胜之事。善财白言。此三昧者。境界云何。居士答言。善男子。我入此三昧。随其次第。见此世界一切诸佛。所谓迦叶佛。拘那含牟尼佛。拘留孙佛。尸弃佛。毗婆尸佛。提舍佛。弗沙佛。无上胜佛。无上莲华佛。如是等而为上首。于一念顷。得见百佛。得见千佛。得见百千佛。得见亿佛。千亿佛。百千亿佛。阿庾多亿佛。那由他亿佛。乃至不可说不可说世界微尘数佛。如是一切次第皆见。亦见彼佛初始发心。种诸善根。获胜神通。成就大愿。修行妙行。具波罗蜜。入菩萨地。得清净忍。摧伏魔军。成正等觉。国土清净。众会围绕。放大光明。转妙法轮。神通变现。种种差别。我悉能持。我悉能忆。悉能观察。分别显示。未来弥勒佛等一切诸佛。现在毗卢遮那佛等一切诸佛。悉亦如是。如此世界。十方世界。所有三世。一切诸佛。声闻独觉。诸菩萨众。悉亦如是。善男子。我唯得此菩萨所得不般涅槃际解脱。如诸菩萨摩诃萨。以一念智普知三世。一念遍入一切三昧。如来智日恒照其心。于一切法无有分别。了一切佛悉皆平等。如来及我一切众生。等无有二。知一切法自性清净。无有思虑。无有动转。而能普入一切世间。离诸分别。住佛法印。悉能开悟法界众生。而我云何能知能说彼功德行。善男子。于此南方。有山。名补怛洛迦。彼有菩萨。名观自在。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。即说颂曰

  海上有山多圣贤　　众宝所成极清净
  华果树林皆遍满　　泉流池沼悉具足
  勇猛丈夫观自在　　为利众生住此山
  汝应往问诸功德　　彼当示汝大方便

时善财童子。顶礼其足。绕无量匝已。殷勤瞻仰。辞退而去

尔时善财童子。一心思惟彼居士教。入彼菩萨解脱之藏。得彼菩萨能随念力。忆彼诸佛出现次第。念彼诸佛相续次第。持彼诸佛名号次第。观彼诸佛所说妙法。知彼诸佛具足庄严。见彼诸佛成正等觉。了彼诸佛不思议业。渐次游行。至于彼山。处处求觅此大菩萨。见其西面岩谷之中。泉流萦映。树林蓊郁。香草柔软。右旋布地。观自在菩萨。于金刚宝石上。结跏趺坐。无量菩萨。皆坐宝石。恭敬围绕。而为宣说大慈悲法。令其摄受一切众生。善财见已。欢喜踊跃。合掌谛观。目不暂瞬。作如是念。善知识者则是如来。善知识者一切法云。善知识者诸功德藏。善知识者难可值遇。善知识者十力宝因。善知识者无尽智炬。善知识者福德根芽。善知识者一切智门。善知识者智海导师。善知识者至一切智助道之具。便即往诣大菩萨所。尔时观自在菩萨。遥见善财。告言善来。汝发大乘意普摄众生。起正直心专求佛法。大悲深重救护一切。普贤妙行相续现前。大愿深心圆满清净。勤求佛法悉能领受。积集善根恒无厌足。顺善知识不违其教。从文殊师利功德智慧大海所生。其心成熟。得佛势力。已获广大三昧光明。专意希求甚深妙法。常见诸佛。生大欢喜。智慧清净。犹如虚空。既自明了。复为他说。安住如来智慧光明。尔时善财童子。顶礼观自在菩萨足。绕无数匝。合掌而住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。菩萨告言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。善男子。我已成就菩萨大悲行解脱门。善男子。我以此菩萨大悲行门。平等教化一切众生。相续不断。善男子。我住此大悲行门。常在一切诸如来所。普现一切众生之前。或以布施摄取众生。或以爱语。或以利行。或以同事摄取众生。或现色身。摄取众生。或现种种不思议色净光明网。摄取众生。或以音声。或以威仪。或为说法。或现神变。令其心悟。而得成熟。或为化现同类之形。与其共居。而成熟之。善男子。我修行此大悲行门。愿常救护一切众生。愿一切众生。离险道怖。离热恼怖。离迷惑怖。离系缚怖。离杀害怖。离贫穷怖。离不活怖。离恶名怖。离于死怖。离大众怖。离恶趣怖。离黑闇怖。离迁移怖。离爱别怖。离怨会怖。离逼迫身怖。离逼迫心怖。离忧悲怖。复作是愿。愿诸众生若念于我。若称我名。若见我身。皆得免离一切怖畏。善男子。我以此方便。令诸众生。离怖畏已。复教令发阿耨多罗三藐三菩提心。永不退转。善男子。我唯得此菩萨大悲行门。如诸菩萨摩诃萨。已净普贤一切愿。已住普贤一切行。常行一切诸善法。常入一切诸三昧。常住一切无边劫。常知一切三世法。常诣一切无边刹。常息一切众生恶。常长一切众生善。常绝众生生死流。而我云何能知能说彼功德行。尔时东方有一菩萨。名曰正趣。从空中来。至娑婆世界轮围山顶。以足按地。其娑婆世界。六种震动。一切皆以众宝庄严。正趣菩萨。放身光明。映蔽一切日月星电。天龙八部。释梵护世。所有光明。皆如聚墨。其光普照一切地狱畜生饿鬼阎罗王处。令诸恶趣。众苦皆灭。烦恼不起。忧悲悉离。又于一切诸佛国土。普雨一切华香璎珞。衣服幢盖。如是所有诸庄严具。供养于佛。复随众生心之所乐。普于一切诸宫殿中。而现其身。令其见者。皆悉欢喜。然后来诣观自在所。时观自在菩萨。告善财言。善男子。汝见正趣菩萨。来此会不。白言已见。告言善男子。汝可往问。菩萨云何学菩萨行。修菩萨道

尔时善财童子。敬承其教遽。即往诣彼菩萨所。顶礼其足。合掌而立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。正趣菩萨言。善男子。我得菩萨解脱。名普门速疾行。善财言。圣者。于何佛所。得此法门。所从来刹。去此几何。发来久如。告言。善男子。此事难知。一切世间。天人阿修罗。沙门婆罗门等。所不能了。唯勇猛精进无退无怯。诸菩萨众。已为一切善友所摄。诸佛所念。善根具足。志乐清净。得菩萨根。有智慧眼。能闻能持。能解能说。善财言。圣者。我承佛神力善知识力。能信能受愿为我说。正趣菩萨言。善男子。我从东方妙藏世界。普胜生佛所。而来此土。于彼佛所。得此法门。从彼发来。已经不可说不可说佛刹微尘数劫。一一念中。举不可说不可说佛刹微尘数步。一一步。过不可说不可说世界微尘数佛刹。一一佛刹。我皆遍入。至其佛所。以妙供具而为供养。此诸供具。皆是无上心所成。无作法所印。诸如来所忍。诸菩萨所叹。善男子。我又普见彼世界中。一切众生。悉知其心。悉知其根。随其欲解。现身说法。或放光明。或施财宝。种种方便。教化调伏。无有休息。如从东方。南西北方。四维上下。亦复如是。善男子。我唯得此菩萨普疾行解脱能疾周遍到一切处。如诸菩萨摩诃萨。普于十方。无所不至。智慧境界。等无差别。善布其身。悉遍法界。至一切道。入一切刹。知一切法。到一切世。平等演说一切法门。同时照耀一切众生。于诸佛所。不生分别。于一切处。无有障碍。而我云何能知能说彼功德行。善男子。于此南方有城。名堕罗钵底。其中有神。名曰大天。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝殷勤瞻仰。辞退而去

尔时善财童子。入菩萨广大行。求菩萨智慧境。见菩萨神通事。念菩萨胜功德。生菩萨大欢喜。起菩萨坚精进。入菩萨不思议自在解脱。行菩萨功德地。观菩萨三昧地。住菩萨总持地。入菩萨大愿地。得菩萨辩才地。成菩萨诸力地。渐次游行。至于彼城。推问大天今在何所。人咸告言。在此城内。现广大身。为众说法。尔时善财。至大天所。顶礼其足。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能教诲。愿为我说。尔时大天。长舒四手。取四大海水。自洗其面。持诸金华。以散善财。而告之言。善男子。一切菩萨。难可得见。难可得闻。希出世间。于众生中。最为第一。是诸人中芬陀利华。为众生归。为众生救。为诸世间作安隐处。为诸世间作大光明。示迷惑者安隐正道。为大导师。引诸众生入佛法门。为大法将。善能守护一切智城。菩萨如是难可值遇。唯身语意无过失者。然后乃得见其形像。闻其辩才。于一切时。常现在前。善男子。我已成就菩萨解脱。名为云网。善财言。圣者。云网解脱。境界云何。尔时大天。于善财前。示现金聚银聚。琉璃聚玻璃聚。砗磲聚码瑙聚。大焰宝聚。离垢藏宝聚。大光明宝聚。普现十方宝聚。宝冠聚宝印聚。宝璎珞聚。宝珰聚宝钏聚。宝锁聚珠网聚。种种摩尼宝聚。一切庄严具聚。如意摩尼聚。皆如大山。又复示现一切华。一切鬘。一切香。一切烧香。一切涂香。一切衣服。一切幢幡一切音乐。一切五欲娱乐之具。皆如山积。及现无数百千万亿诸童女众。而彼大天。告善财言。善男子。可取此物供养如来。修诸福德。并施一切。摄取众生。令其修学檀波罗蜜能舍难舍。善男子。如我为汝示现此物。教汝行施。为一切众生。悉亦如是。皆令以此善根熏习。于三宝所。善知识所。恭敬供养。增长善法。发于无上菩提之意。善男子。若有众生。贪着五欲。自放逸者。为其示现不净境界。若有众生。嗔恚憍慢。多诤竞者。为其示现极可怖形如罗刹等。饮血啖肉。令其见已。惊恐惶惧。心意调柔。舍离怨结。若有众生。惛沈懒惰。为其示现王贼水火。及诸重疾。令其见已。心生惶怖。知有忧苦。而自勉策。以如是等种种方便。令舍一切诸不善行。修行善法令除一切。波罗蜜障。具波罗蜜。令超一切障碍险道。到无障处。善男子。我唯知此云网解脱。如诸菩萨摩诃萨犹如帝释已能摧伏一切烦恼阿修罗军。犹如大水普能消灭一切众生诸烦恼火。犹如猛火普能干竭一切众生。诸爱欲水。犹如大风普能吹倒一切众生诸见取幢。犹如金刚悉能摧破一切众生诸我见山。而我云何能知能说彼功德行。善男子。此阎浮提摩竭提国菩提场中。有主地神。其名安住。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼大天足。绕无数匝。辞退而去

尔时善财童子。渐次游行。趣摩竭提国菩萨场内安住神所。百万地神。同在其中。更相谓言。此来童子。即是佛藏。必当普为一切众生作所依处。必当普坏一切众生无明[穀-禾+卵]藏。此人已生法王种中。当以离垢无碍法缯。而冠其首。当开智慧大珍宝藏。摧伏一切邪论异道。时安住等百万地神。放大光明。遍照三千大千世界。普令大地同时震吼。种种宝物。处处庄严。影洁光流。递相鉴彻。一切叶树俱时生长。一切华树咸共开敷。一切果树靡不成熟。一切河流递相灌注。一切池沼悉皆盈满。雨细香雨遍洒其地。风来吹华普散其上。无数音乐一时俱奏。天庄严具咸出美音。牛王象王。师子王等。皆生欢喜。踊跃哮吼犹如大山。相击出声。百千伏藏。自然踊现。时安住地神。告善财言善来童子。汝于此地。曾种善根。我为汝现。汝欲见不。尔时善财。礼地神足。绕无数匝。合掌而立。白言。圣者。唯然欲见。时安住地神。以足按地。百千亿阿僧祇宝藏。自然踊出。告言。善男子。今此宝藏。随逐于汝。是汝往昔善根果报。是汝福力之所摄受。汝应随意自在受用。善男子。我得菩萨解脱。名不可坏智慧藏。常以此法。成就众生。善男子。我忆自从然灯佛来。常随菩萨。恭敬守护。观察菩萨所有心行智慧境界。一切誓愿。诸清净行。一切三昧。广大神通。大自在力。无能坏法。遍往一切诸佛国土。普授一切诸如来记。转于一切诸佛法轮。广说一切修多罗门。大法光明普皆照耀。教化调伏一切众生。示现一切诸佛神变。我皆能领受。皆能忆持。善男子。乃往古世。过须弥山微尘数劫。有劫名庄严。世界名月幢。佛号妙眼。于彼佛所。得此法门。善男子。我于此法门。若入若出。修习增长。常见诸佛。未曾舍离。始从初得。乃至贤劫。于其中间。值遇不可说不可说佛刹微尘数如来应正等觉。悉皆承事。恭敬供养。亦见彼佛诣菩提座。现大神力。亦见彼佛所有一切功德善根。善男子。我唯知此不可坏智慧藏法门。如诸菩萨摩诃萨。常随诸佛。能持一切诸佛所说。入一切佛甚深智慧。念念充遍一切法界。等如来身。生诸佛心。具诸佛法。作诸佛事。而我云何能知能说彼功德行。善男子。此阎浮提摩竭提国迦毗罗城。有主夜神。名婆珊婆演底。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼地神足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。一心思惟安住神教。忆持菩萨不可沮坏智藏解脱。修其三昧。学其轨则。观其游戏。入其微妙。得其智慧。达其平等。知其无边。测其甚深。渐次游行。至于彼城。从东门入。伫立未久。便见日没。心念随顺诸菩萨教。渴仰欲见彼主夜神。于善知识。生如来想。复作是念。由善知识。得周遍眼。普能明见十方境界。由善知识。得广大解。普能了达一切所缘。由善知识。得三昧眼。普能观察一切法门。由善知识。得智慧眼。普能明照十方刹海。作是念时。见彼夜神于虚空中。处宝楼阁香莲华藏师子之座。身真金色。目发绀青。形貌端严。见者欢喜。众宝璎珞。以为严饰。身服朱衣。首戴梵冠。一切星宿。炳然在体。于其身上一一毛孔。皆现化度无量无数恶道众生。令其免离险难之像。是诸众生。或生人中。或生天上。或有趣向二乘菩提。或有修行一切智道。又彼一一诸毛孔中。示现种种教化方便。或为现身。或为说法。或为示现声闻乘道。或为示现独觉乘道。或为示现诸菩萨行。菩萨勇猛。菩萨三昧。菩萨自在。菩萨住处。菩萨观察。菩萨师子频申。菩萨解脱游戏。如是种种成熟众生。善财童子。见闻此已。心大欢喜。以身投地。礼夜神足。绕无数匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。我心冀望。依善知识。获诸如来功德法藏。唯愿示我一切智道。我行于中。至十力地。时彼夜神。告善财言。善哉善哉。善男子。汝能深心敬善知识。乐闻其语。修行其教。以修行故。决定当得阿耨多罗三藐三菩提。善男子。我得菩萨破一切众生痴暗法光明解脱。善男子。我于恶慧众生。起大慈心。于不善业众生。起大悲心。于作善业众生。起于喜心。于善恶二行众生。起不二心。于杂染众生。起令生清净心。于邪道众生。起令生正行心。于劣解众生。起令兴大解心。于乐生死众生。起令舍轮转心。于住二乘道众生。起令住一切智心。善男子。我以得此解脱故。常与如是心共相应。善男子。我于夜闇人静。鬼神盗贼。诸恶众生。所游行时。密云重雾。恶风暴雨。日月星宿。并皆昏蔽。不见色时。见诸众生。若入于海。若行于陆。山林旷野。诸险难处。或遭盗贼。或乏资粮。或迷惑方隅。或忘失道路。慞惶忧怖。不能自出。我时即以种种方便。而救济之。为海难者。示作船师。鱼王马王。龟王象王。阿修罗王。及以海神。为彼众生。止恶风雨。息大波浪。引其道路。示其洲岸。令免怖畏。悉得安隐。复作是念。以此善根。回施众生。愿令舍离一切诸苦。为在陆地一切众生。于夜暗中。遭恐怖者。现作日月及诸星宿。晨霞夕电。种种光明。或作屋宅。或为人众。令其得免恐怖之厄。复作是念。以此善根。回施众生。悉令除灭诸烦恼暗。一切众生。有惜寿命。有爱名闻。有贪财宝。有重官位。有着男女。有恋妻妾。未称所求。多生忧怖。我皆救济。令其离苦。为行山险而留难者。为作善神。现形亲近。为作好鸟发音慰悦。为作灵药舒光照耀。示其果树。示其泉井。示正直道。示平坦地。令其免离一切忧厄。为行旷野稠林险道。藤萝所罥。云雾所暗。而恐怖者。示其正道。令得出离。作是念言。愿一切众生。伐见稠林。截爱罗网。出生死野。灭烦恼暗。入一切智平坦正道。到无畏处。毕竟安乐。善男子。若有众生。乐着国土。而忧苦者。我以方便。令生厌离。作是念言。愿一切众生。不着诸蕴。住一切佛萨婆若境。善男子。若有众生。乐着聚落贪爱宅舍。常处黑暗。受诸苦者。我为说法。令生厌离。令法满足。令依法住。作是念言。愿一切众生。悉不贪乐六处聚落。速得出离生死境界。究竟安住一切智城。善男子。若有众生。行暗夜中。迷惑十方。于平坦路生险难想。于险难道起平坦想。以高为下。以下为高。其心迷惑。生大苦恼。我以方便。舒光照及。若欲出者示其门户。若欲行者示其道路。欲度沟洫示其桥梁。欲涉河海与其船筏。乐观方者示其险易安危之处。欲休息者示其城邑水树之所。作是念言。如我于此照除夜暗。令诸世事悉得宣叙。愿我普于一切众生生死长夜。无明暗处。以智慧光。普皆照了。是诸众生。无有智眼。想心见倒之所覆翳。无常常想。无乐乐想。无我我想。不净净想。坚固执着。我人众生。蕴界处法。迷惑因果。不识善恶。杀害众生。乃至邪见。不孝父母。不敬沙门及婆罗门。不知恶人。不识善人。贪着恶事。安住邪法。毁谤如来。坏正法轮。于诸菩萨。呰辱伤害。轻大乘道。断菩提心。于有恩人反加杀害。于无恩处常怀怨结。毁谤贤圣。亲近恶伴。盗塔寺物。作五逆罪。不久当堕三恶道处。愿我速以大智光明。破彼众生无明黑暗。令其疾发阿耨多罗三藐三菩提心。既发心已。示普贤乘。开十力道。亦示如来法王境界。亦示诸佛一切智城。诸佛所行。诸佛自在。诸佛成就。诸佛总持。一切诸佛。共同一身。一切诸佛平等之处。令其安住。善男子。一切众生。或病所缠。或老所侵。或苦贫穷。或遭祸难。或犯王法。临当受刑。无所依怙。生大怖畏。我皆救济。使得安隐。复作是念。愿我以法。普摄众生。令其解脱一切烦恼。生老病死。忧悲苦患。近善知识。常行法施。勤行善业。速得如来。清净法身。住于究竟无变易处。善男子。一切众生。入见稠林。住于邪道。于诸境界。起邪分别。常行不善。身语意业。妄作种种诸邪苦行。于非正觉生正觉想。于正觉所非正觉想。为恶知识之所摄受。以起恶见。将堕恶道。我以种种诸方便门。而为救护。令住正见。生人天中。复作是念。如我救此将坠恶道诸众生等。愿我普救一切众生。悉令解脱一切诸苦。住波罗蜜。出世圣道。于一切智。得不退转。具普贤愿。近一切智。而不舍离诸菩萨行。常勤教化一切众生。尔时婆珊婆演底主夜神。欲重宣此解脱义。承佛神力。观察十方。为善财童子。而说颂曰

  我此解脱门　　生净法光明
  能破愚痴暗　　待时而演说
  我昔无边劫　　勤行广大慈
  普覆诸世间　　佛子应修学
  寂静大悲海　　出生三世佛
  能灭众生苦　　汝应入此门
  能生世间乐　　亦生出世乐
  令我心欢喜　　汝应入此门
  既舍有为患　　亦远声闻果
  净修诸佛力　　汝应入此门
  我目甚清净　　普见十方刹
  亦见其中佛　　菩提树下坐
  相好庄严身　　无量众围绕
  一一毛孔内　　种种光明出
  见诸群生类　　死此而生彼
  轮回五趣中　　常受无量苦
  我耳甚清净　　听之无不及
  一切语言海　　悉闻能忆持
  诸佛转法轮　　其声妙无比
  所有诸文字　　悉皆能忆持
  我鼻甚清净　　于法无所碍
  一切皆自在　　汝应入此门
  我舌甚广大　　净好能言说
  随应演妙法　　汝应入此门
  我身甚清净　　三世等如如
  随诸众生心　　一切悉皆现
  我心净无碍　　如空含万像
  普念诸如来　　而亦不分别
  了知无量刹　　一切诸心海
  诸根及欲乐　　而亦不分别
  我以大神通　　震动无量刹
  其身悉遍往　　调彼难调众
  我福甚广大　　如空无有尽
  供养诸如来　　饶益一切众
  我智广清净　　了知诸法海
  除灭众生惑　　汝应入此门
  我知三世佛　　及以一切法
  亦了彼方便　　此门遍无等
  一一尘中见　　三世一切刹
  亦见彼诸佛　　此是普门力
  十方刹尘内　　悉见卢舍那
  菩提树下坐　　成道演妙法

尔时善财童子。白夜神言。汝发阿耨多罗三藐三菩提心。为几时耶。得此解脱。其已久如。乃能如是饶益众生。其神答言。善男子。乃往古世。过如须弥山微尘数劫。有劫名寂静光。世界名出生妙宝。有五亿佛于中出现。彼世界中有四天下。名宝月灯光。有城名莲华光。王名善法度。以法施化。成就七宝。王四天下。王有夫人名法慧月。夜久眠寐。时彼城东有一大林。名为寂住。林中有一大菩提树。名一切光摩尼王庄严身出生一切佛神力光明

尔时有佛。名一切法雷音王。于此树下。成等正觉。放无量色广大光明。遍照出生妙宝世界。莲华光城内。有主夜神。名为净月。诣王夫人法慧月所。动身璎珞。以觉夫人。而告之言。夫人当知一切法雷音王如来。于寂住林。成无上觉。及广为说诸佛功德自在神力。普贤菩萨所有行愿。令王夫人。发阿耨多罗三藐三菩提意。供养彼佛及诸菩萨声闻僧众。善男子。时王夫人。法慧月者。岂异人乎。我身是也。我于彼佛所。发菩提心。种善根故。于须弥山微尘数劫。不生地狱饿鬼畜生。诸恶趣中。亦不生于下贱之家。诸根具足。无有众苦。于天人中。福德殊胜。不生恶世。恒不离佛及诸菩萨。大善知识。常于其所。种植善根。经八十须弥山微尘数劫。常受安乐。而未满足菩萨诸根。过此劫已。复过万劫。于贤劫前。有劫名无忧遍照。世界名离垢妙光。其世界中。净秽相杂。有五百佛于中出现。其第一佛。名须弥幢寂静妙眼如来应正等觉。我为名称长者。女名妙慧光明。端正殊妙。彼净月夜神。以愿力故。于离垢世界一四天下妙幢王城中生。作主夜神。名清净眼。我于一时。在父母边。夜久眠息。彼清净眼。来诣我所。震动我宅。放大光明。出现其身。赞佛功德言。妙眼如来。坐菩提座。始成正觉。劝谕于我及以父母。并诸眷属。令速见佛。自为前导。引至佛所。广兴供养。我才见佛。即得三昧。名出生见佛调伏众生三世智光明轮。获此三昧故。能忆念须弥山微尘数劫。亦见其中诸佛出现。于彼佛所。听闻妙法。以闻法故。即得此破一切众生暗法光明解脱。得此解脱已。即见其身。遍往佛刹微尘数世界。亦见彼世界所有诸佛。又见自身在其佛所。亦见彼世界一切众生。解其言音。识其根性。知其往昔曾为善友之所摄受。随其所乐。而为现身。令生欢喜。我时于彼所。得解脱。念念增长。此心无间。又见自身。遍往百佛刹微尘数世界。此心无间。又见自身。遍往千佛刹微尘数世界。此心无间。又见自身。遍往百千佛刹微尘数世界。如是念念。乃至不可说不可说佛刹微尘数世界。亦见彼世界中一切如来。亦自见身。在彼佛所。听闻妙法。受持忆念。观察决了。亦知彼佛诸本事海。诸大愿海。彼诸如来严净佛刹。我亦严净。亦见彼世界一切众生。随其所应。而为现身。教化调伏。此解脱门。念念增长。如是乃至充满法界。善男子。我唯知此菩萨破一切众生暗法光明解脱。如诸菩萨摩诃萨。成就普贤无边行愿。普入一切诸法界海。得诸菩萨金刚智幢自在三昧。出生大愿。住持佛种。于念念中。成满一切大功德海。严净一切广大世界。以自在智。教化成熟一切众生。以智慧日。灭除一切世间暗障。以勇猛智。觉悟一切众生惛睡。以智慧月。决了一切众生疑惑。以清净音。断除一切诸有执着。于一切法界一一尘中。示现一切自在神力。智眼明净。等见三世。而我何能知其妙行。说其功德。入其境界。示其自在。善男子。此阎浮提摩竭提国菩提场内。有主夜神。名普德净光。我本从其。发阿耨多罗三藐三菩提心。常以妙法。开悟于我。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时善财童子。向婆珊婆演底神。而说颂曰

  见汝清净身　　相好超世间
  如文殊师利　　亦如宝山王
  汝法身清净　　三世悉平等
  世界悉入中　　成坏无所碍
  我观一切趣　　悉见汝形像
  一一毛孔中　　星月各分布
  汝心极广大　　如空遍十方
  诸佛悉入中　　清净无分别
  一一毛孔内　　悉放无数光
  十方诸佛所　　普雨庄严具
  一一毛孔内　　各现无数身
  十方诸国土　　方便度众生
  一一毛孔内　　示现无量刹
  随诸众生欲　　种种令清净
  若有诸众生　　闻名及见身
  悉获功德利　　成就菩提道
  多劫在恶趣　　始得见闻汝
  亦应欢喜受　　以灭烦恼故
  千刹微尘劫　　叹汝一毛德
  劫数犹可穷　　功德终无尽

时善财童子。说此颂已。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第六十八大方广佛华严经卷第六十九

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十

尔时善财童子。了知彼婆珊婆演底夜神。初发菩提心。所生菩萨藏。所发菩萨愿。所净菩萨度。所入菩萨地。所修菩萨行。所行出离道一切智光海。普救众生心。普遍大悲云。于一切佛刹。尽未来际。常能出生普贤行愿。渐次游行。至普德净光夜神所。顶礼其足。绕无数匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而我未知菩萨云何修行菩萨地。云何出生菩萨地。云何成就菩萨地。夜神答言。善哉善哉。善男子。汝已能发阿耨多罗三藐三菩提心。今复问于菩萨地修行出生。及以成就。善男子。菩萨成就十法。能圆满菩萨行。何者为十。一者得清净三昧。常见一切佛。二者得清净眼。常观一切佛。相好庄严。三者知一切如来无量无边。功德大海。四者知等法界无量诸佛。法光明海。五者知一切如来。一一毛孔。放等众生数大光明海。利益无量一切众生。六者见一切如来。一一毛孔。出一切宝色光明焰海。七者于念念中。出现一切佛变化海。充满法界。究竟一切诸佛境界。调伏众生。八者得佛音声同一切众生言音海转三世一切佛法轮。九者知一切佛无边名号海。十者知一切佛调伏众生不思议自在力。善男子。菩萨成就此十种法。则能圆满菩萨诸行。善男子。我得菩萨解脱。名寂静禅定乐普游步。普见三世一切诸佛。亦见彼佛清净国土道场众会。神通名号。说法寿命。言音身相。种种不同。悉皆明睹。而无取着。何以故。知诸如来。非去。世趣永灭故。非来。体性无生故。非生。法身平等故。非灭。无有生相故。非实。住如幻法故。非妄。利益众生故。非迁。超过生死故。非坏。性常不变故一相。言语悉离故。无相。性相本空故。善男子。我如是了知一切如来时。于菩萨寂静禅定乐普游步解脱门。分明了达。成就增长。思惟观察。坚固庄严。不起一切妄想分别。大悲救护一切众生。一心不动。修习初禅。息一切意业。摄一切众生。智力勇猛。喜心悦豫。修第二禅。思惟一切众生自性。厌离生死。修第三禅。悉能息灭一切众生众苦热恼。修第四禅。增长圆满一切智愿。出生一切诸三昧海。入诸菩萨解脱海门。游戏一切神通。成就一切变化。以清净智普入法界。善男子。我修此解脱时。以种种方便。成就众生。所谓于在家放逸众生。令生不净想。可厌想。疲劳想。逼迫想。系缚想。罗刹想。无常想。苦想。无我想。空想。无生想。不自在想。老病死想。自于五欲。不生乐着。亦劝众生。不着欲乐。唯住法乐。出离于家。入于非家。若有众生。住于空闲。我为止息诸恶音声。于静夜时。为说深法。与顺行缘。开出家门。示正道路。为作光明。除其闇障。灭其怖畏。赞出家业。叹佛法僧及善知识。具诸功德。亦叹亲近善知识行。复次善男子。我修解脱时。令诸众生。不生非法贪。不起邪分别不作诸罪业。若已作者皆令止息。若未生善法。未修波罗蜜行。未求一切智。未起大慈悲。未造人天业。皆令其生。若已生者令其增长。我与如是顺道因缘。乃至令成一切智智。善男子。我唯得此菩萨寂静禅定乐普游步解脱门。如诸菩萨摩诃萨。具足普贤所有行愿。了达一切无边法界。常能增长一切善根。照见一切如来十力。住于一切如来境界。恒处生死。心无障碍。疾能满足一切智愿。普能往诣一切世界。悉能观见一切诸佛。遍能听受一切佛法。能破一切众生痴闇。能于生死大夜之中。出生一切智慧光明。而我云何能知能说彼功德行。善男子。去此不远。于菩提场右边。有一夜神。名喜目观察众生。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时普德净光夜神。欲重宣此解脱义。为善财童子。而说颂曰

  若有信解心　　尽见三世佛
  彼人眼清净　　能入诸佛海
  汝观诸佛身　　清净相庄严
  一念神通力　　法界悉充满
  卢舍那如来　　道场成正觉
  一切法界中　　转于净法轮
  如来知法性　　寂灭无有二
  清净相严身　　遍示诸世间
  佛身不思议　　法界悉充满
  普现一切刹　　一切无不见
  佛身常光明　　一切刹尘等
  种种清净色　　念念遍法界
  如来一毛孔　　放不思议光
  普照诸群生　　令其烦恼灭
  如来一毛孔　　出生无尽化
  充遍于法界　　除灭众生苦
  佛演一妙音　　随类皆令解
  普雨广大法　　使发菩提意
  佛昔修诸行　　已曾摄受我
  故得见如来　　普现一切刹
  诸佛出世间　　量等众生数
  种种解脱境　　非我所能知
  一切诸菩萨　　入佛一毛孔
  如是妙解脱　　非我所能知
  此近有夜神　　名喜目观察
  汝应往诣彼　　问修菩萨行

时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

尔时善财童子。敬善知识教。行善知识语。作如是念。善知识者难见难遇。见善知识令心不散乱。见善知识破障碍山。见善知识入大悲海。救护众生。见善知识得智慧光。普照法界。见善知识悉能修行一切智道。见善知识普能睹见十方佛海。见善知识得见诸佛。转于法轮。忆持不忘。作是念已。发意欲诣喜目观察众生夜神所。时喜目神。加善财童子。令知亲近善知识。能生诸善根。增长成熟。所谓令知亲近善知识能修助道具。令知亲近善知识能起勇猛心。令知亲近善知识能作难坏业。令知亲近善知识能得难伏力。令知亲近善知识能入无边方。令知亲近善知识能久远修行。令知亲近善知识能辨无边业。令知亲近善知识能行无量道。令知亲近善知识能得速疾力普诣诸刹。令知亲近善知识能不离本处遍至十方。时善财童子。遽发是念。由亲近善知识能勇猛勤修一切智道。由亲近善知识能速疾出生诸大愿海。由亲近善知识。能为一切众生。尽未来劫。受无边苦。由亲近善知识。能被大精进甲。于一微尘中。说法声遍法界。由亲近善知识。能速往诣一切方海。由亲近善知识。于一毛道。尽未来劫。修菩萨行。由亲近善知识。于念念中。行菩萨行。究竟安住一切智地。由亲近善知识。能入三世一切如来。自在神力诸庄严道。由亲近善知识。能常遍入诸法界门。由亲近善知识。常缘法界未曾动出。而能遍往十方国土

尔时善财童子。发是念已。即诣喜目观察众生夜神所。见彼夜神。在于如来众会道场。坐莲华藏师子之座。入大势力普喜幢解脱。于其身上一一毛孔。出无量种变化身云。随其所应。以妙言音。而为说法。普摄无量一切众生。皆令欢喜而得利益。所谓出无量化身云。充满十方一切世界。说诸菩萨行檀波罗蜜。于一切事。皆无恋着。于一切众生。普皆施与。其心平等。无有轻慢。内外悉施。难舍能舍。又出等众生数无量化身云。充满法界。普现一切众生之前。说持净戒无有缺犯。修诸苦行。皆悉具足。于诸世间无有所依。于诸境界无所爱着说在生死。轮回往返。说诸人天盛衰苦乐。说诸境界皆是不净。说一切法皆是无常。说一切行悉苦无味。令诸世间舍离颠倒。住诸佛境。持如来戒。如是演说种种戒行戒香普熏。令诸众生。悉得成熟。又出等众生数种种身云。说能忍受一切众苦。所谓割截捶楚。诃骂欺辱。其心泰然不动不乱。于一切行不卑不高。于诸众生不起我慢。于诸法性安住忍受。说菩提心。无有穷尽。心无尽故。智亦无尽。普断一切众生烦恼。说诸众生卑贱丑陋。不具足身。令生厌离。赞诸如来清净妙色无上之身。令生欣乐。如是方便。成熟众生。又出等众生界种种身云。随诸众生心之所乐。说勇猛精进。修一切智助道之法。勇猛精进。降伏魔怨。勇猛精进。发菩提心。不动不退。勇猛精进。度一切众生。出生死海。勇猛精进。除灭一切恶道诸难。勇猛精进。坏无智山。勇猛精进供养一切诸佛如来。不生疲厌。勇猛精进。受持一切诸佛法轮。勇猛精进。坏散一切诸障碍山。勇猛精进。教化成熟一切众生。勇猛精进。严净一切诸佛国土。如是方便成熟众生。又出种种无量身云。以种种方便。令诸众生。心生欢喜。舍离恶意。厌一切欲。为说惭愧。令诸众生。藏护诸根。为说无上清净梵行。为说欲界是魔境界令生恐怖。为现不乐世间欲乐。住于法乐。随其次第。入诸禅定诸三昧乐。令思惟观察。除灭一切所有烦恼。又为演说一切菩萨诸三昧海。神力变现。自在游戏。令诸众生欢喜适悦。离诸忧怖。其心清净。诸根猛利。爱重于法。修习增长。又出等众生界种种身云。为说往诣十方国土。供养诸佛及以师长真善知识。受持一切诸佛法轮。精勤不懈。又为演说称赞一切诸如来海。观察一切诸法门海。显示一切诸法性相。开阐一切诸三昧门。开智慧境界。竭一切众生疑海。示智慧金刚坏一切众生见山。升智慧日轮破一切众生痴闇。皆令欢喜成一切智。又出等众生界种种身云。普诣一切众生之前。随其所应。以种种言辞。而为说法。或说世间神通福力。或说三界皆是可怖。令其不作世间业行。离三界处。出见稠林。或为称赞一切智道。令其超越二乘之地。或为演说不住生死不住涅槃。令其不著有为无为。或为演说住于天宫乃至道场。令其欣乐发菩提意。如是方便。教化众生。皆令究竟得一切智。又出一切世界微尘数身云。普诣一切众生之前。念念中。示普贤菩萨一切行愿。念念中。示清净大愿充满法界。念念中。示严净一切世界海。念念中。示供养一切如来海。念念中。示入一切法门海。念念中。示入一切世界海微尘数世界海。念念中。示于一切刹尽未来劫清净修行一切智道。念念中。示入如来力。念念中。示入一切三世方便海。念念中。示往一切刹现种种神通变化。念念中。示诸菩萨一切行愿。令一切众生住一切智。如是所作恒无休息。又出等一切众生心数身云。普诣一切众生之前。说诸菩萨集一切智助道之法无边际力。求一切智不破坏力。无穷尽力。修无上行不退转力。无间断力。于生死法无染着力。能破一切诸魔众力。远离一切烦恼垢力。能破一切业障山力。住一切劫修大悲行无疲倦力。震动一切诸佛国土令一切众生生欢喜力。能破一切诸外道力。普于世间转法轮力。以如是等方便成熟。令诸众生至一切智。又出等一切众生心数无量变化色身云。普诣十方无量世界。随众生心。演说一切菩萨智行。所谓说入一切众生界海智。说入一切众生心海智。说入一切众生根海智。说入一切众生行海智。说度一切众生未曾失时智。说出一切法界音声智。说念念遍一切法界海智。说念念知一切世界海坏智。说念念知一切世界海成住庄严差别智。说念念自在亲近供养一切如来听受法轮智。示现如是智波罗蜜。令诸众生。皆大欢喜。调畅适悦。其心清净。生决定解。求一切智。无有退转。如说菩萨诸波罗蜜成熟众生。如是宣说一切菩萨种种行法。而为利益。复于一一诸毛孔中。出无量种众生身云。所谓出与色究竟天善现天善见天无热天无烦天相似身云。出少广广果福生无云天相似身云。出遍净无量净少净天相似身云。出光音无量光少光天相似身云。出大梵梵辅梵众天相似身云。出自在天化乐天兜率陀天须夜摩天忉利天及其采女诸天子众相似身云。出提头赖吒乾闼婆王乾闼婆子乾闼婆女相似身云。出毗楼勒叉鸠槃茶王鸠槃茶子鸠槃茶女相似身云。出毗楼博叉龙王龙子龙女相似身云。出毗沙门夜叉王夜叉子夜叉女相似身云。出大树紧那罗王善慧摩睺罗伽王大速疾力迦楼罗王罗睺阿修罗王阎罗法王及其子其女相似身云。出诸人主及其子其女相似身云。出声闻独觉及诸佛众相似身云。出地神水神火神风神河神海神山神树神乃至昼夜主方神等相似身云。周遍十方。充满法界。于彼一切众生之前。现种种声。所谓风轮声水轮声。火焰声海潮声。地震声。大山相击声。天城震动声。摩尼相击声。天王声。龙王声。夜叉王声。乾闼婆王声。阿修罗王声。迦楼罗王声。紧那罗王声。摩睺罗伽王声。人王声。梵王声。天女歌咏声。诸天音乐声。摩尼宝王声。以如是等种种音声。说喜目观察众生夜神。从初发心。所集功德。所谓承事一切诸善知识。亲近诸佛。修行善法。行檀波罗蜜。难舍能舍。行尸波罗蜜。弃舍王位宫殿眷属。出家学道。行羼提波罗蜜。能忍世间一切苦事。及以菩萨所修苦行。所持正法。皆悉坚固。其心不动。亦能忍受一切众生。于己身心。恶作恶说。忍一切业。皆不失坏。忍一切法。生决定解。忍诸法性。能谛思惟。行精进波罗蜜。起一切智行。成一切佛法。行禅波罗蜜。其禅波罗蜜。所有资具所有修习。所有成就。所有清净。所有起三昧神通。所有入三昧海门。皆悉显示。行般若波罗蜜。其般若波罗蜜。所有资具。所有清净。大智慧日。大智慧云。大智慧藏。大智慧门。皆悉显示。行方便波罗蜜。其方便波罗蜜。所有资具。所有修行。所有体性。所有理趣。所有清净。所有相应事。皆悉显示。行愿波罗蜜。其愿波罗蜜。所有体性。所有成就。所有修习。所有相应事。皆悉显示。行力波罗蜜。其力波罗蜜。所有资具。所有因缘。所有理趣。所有演说。所有相应事。皆悉显示。行智波罗蜜。其智波罗蜜。所有资具。所有体性。所有成就。所有清净。所有处所。所有增长。所有深入。所有光明。所有显示。所有理趣。所有相应事。所有拣择。所有行相。所有相应法。所有所摄法。所知法。所知业。所知刹。所知劫。所知世。所知佛出现。所知佛。所知菩萨。所知菩萨心。菩萨位。菩萨资具。菩萨发趣。菩萨回向。菩萨大愿。菩萨法轮。菩萨拣择法。菩萨法海。菩萨法门海。菩萨法旋流。菩萨法理趣。如是等智波罗蜜。相应境界。皆悉显示。成熟众生。又说此神从初发心所集功德。相续次第。所习善根。相续次第。所修无量诸波罗蜜相续次第。死此生彼。及其名号相续次第。亲近善友。承事诸佛。受持正法。修菩萨行。入诸三昧。以三昧力。普见诸佛。普见诸刹。普知诸劫。深入法界。观察众生。入法界海。知诸众生死此生彼。得净天耳闻一切声。得净天眼见一切色。得他心智知众生心。得宿住智知前际事。得无依无作神足智通。自在游行遍十方刹。如是所有相续次第。得菩萨解脱。入菩萨解脱海。得菩萨自在。得菩萨勇猛。得菩萨游步。住菩萨想。入菩萨道。如是一切所有功德。相续次第。皆悉演说。分别显示。成熟众生。如是说时。于念念中。十方各严净不可说不可说诸佛国土。度脱无量恶趣众生。令无量众生。生天人中。富贵自在。令无量众生。出生死海。令无量众生。安住声闻辟支佛地。令无量众生。住如来地。尔时善财童子。见闻如上所现一切诸希有事。念念观察思惟解了。深入安住。承佛威力及解脱力。则得菩萨不思议大势力。普喜幢自在力解脱。何以故。与喜目夜神。于往昔时。同修行故。如来神力所加持故。不思议善根所祐助故。得菩萨诸根故。生如来种中故。得善友力所摄受故。受诸如来所护念故。毗卢遮那如来曾所化故。彼分善根已成熟故。堪修普贤菩萨行故。尔时善财童子。得此解脱已。心生欢喜。合掌向喜目观察众生夜神。以偈赞曰

  无量无数劫　　学佛甚深法
  随其所应化　　显现妙色身
  了知诸众生　　沉迷婴妄想
  种种身皆现　　随应悉调伏
  法身恒寂静　　清净无二相
  为化众生故　　示现种种形
  于诸蕴界处　　未曾有所著
  示行及色身　　调伏一切众
  不着内外法　　已度生死海
  而现种种身　　住于诸有界
  远离诸分别　　戏论所不动
  为着妄想者　　弘宣十力法
  一心住三昧　　无量劫不动
  毛孔出化云　　供养十方佛
  得佛方便力　　念念无边际
  示现种种身　　普摄诸群生
  了知诸有海　　种种业庄严
  为说无碍法　　令其悉清净
  色身妙无比　　清净如普贤
  随诸众生心　　示现世间相

尔时善财童子。说此颂已。白言。天神。汝发阿耨多罗三藐三菩提心。为几时耶。得此解脱。身已久如。尔时喜目观察众生主夜神。以颂答曰

  我念过去世　　过于刹尘劫
  刹号摩尼光　　劫名寂静音
  百万那由他　　俱胝四天下
  其王数亦尔　　各各自临驭
  中有一王都　　号曰香幢宝
  庄严最殊妙　　见者皆欣悦
  中有转轮王　　其身甚微妙
  三十二种相　　随好以庄严
  莲华中化生　　金色光明身
  腾空照远近　　普及阎浮界
  其王有千子　　勇猛身端正
  臣佐满一亿　　智慧善方便
  嫔御有十亿　　颜容状天女
  利益调柔意　　慈心给侍王
  其王以法化　　普及四天下
  轮围大地中　　一切皆丰盛
  我时为宝女　　具足梵音声
  身出金色光　　照及千由旬
  日光既已没　　音乐咸寂然
  大王及侍御　　一切皆安寝
  彼时德海佛　　出兴于世间
  显现神通力　　充满十方界
  放大光明海　　一切刹尘数
  种种自在身　　遍满于十方
  地震出妙音　　普告佛兴世
  天人龙神众　　一切皆欢喜
  一一毛孔中　　出佛化身海
  十方皆遍满　　随应说妙法
  我时于梦中　　见佛诸神变
  亦闻深妙法　　心生大欢喜
  一万主夜神　　共在空中住
  赞叹佛兴世　　同时觉悟我
  贤慧汝应起　　佛已现汝国
  劫海难值遇　　见者得清净
  我时便寐寤　　即睹清净光
  观此从何来　　见佛树王下
  诸相庄严体　　犹如宝山王
  一切毛孔中　　放大光明海
  见已心欢喜　　便生此念言
  愿我得如佛　　广大神通力
  我时寻觉寤　　大王并眷属
  令见佛光明　　一切皆欣庆
  我时与大王　　骑从千万亿
  众生亦无量　　俱行诣佛所
  我于二万岁　　供养彼如来
  七宝四天下　　一切皆奉施
  时彼如来说　　功德普云经
  普应群生心　　庄严诸愿海
  夜神觉悟我　　令我得利益
  我愿作是身　　觉诸放逸者
  我从此初发　　最上菩提愿
  往来诸有中　　其心无忘失
  从此后供养　　十亿那由佛
  恒受人天乐　　饶益诸群生
  初佛功德海　　第二功德灯
  第三妙宝幢　　第四虚空智
  第五莲华藏　　第六无碍慧
  第七法月王　　第八智灯轮
  第九两足尊　　宝焰山灯王
  第十调御师　　三世华光音
  如是等诸佛　　我悉曾供养
  然未得慧眼　　入于解脱海
  从此次第有　　一切宝光刹
  其劫名天胜　　五百佛兴世
  最初月光轮　　第二名日灯
  第三名光幢　　第四宝须弥
  第五名华焰　　第六号灯海
  第七炽然佛　　第八天藏佛
  九光明王幢　　十普智光王
  如是等诸佛　　我悉曾供养
  尚于诸法中　　无而计为有
  从此复有劫　　名曰梵光明
  世界莲华灯　　庄严极殊妙
  彼有无量佛　　一一无量众
  我悉曾供养　　尊重听闻法
  初宝须弥佛　　二功德海佛
  三法界音佛　　四法震雷佛
  五名法幢佛　　六名地光佛
  七名法力光　　八名虚空觉
  第九须弥光　　第十功德云
  如是等如来　　我悉曾供养
  未能明了法　　而入诸佛海
  次后复有劫　　名为功德月
  尔时有世界　　其名功德幢
  彼中有诸佛　　八十那由他
  我皆以妙供　　深心而敬奉
  初乾闼婆王　　二名大树王
  三功德须弥　　第四宝眼佛
  第五卢舍那　　第六光庄严
  第七法海佛　　第八光胜佛
  九名贤胜佛　　第十法王佛
  如是等诸佛　　我悉曾供养
  然未得深智　　入于诸法海
  此后复有劫　　名为寂静慧
  刹号金刚宝　　庄严悉殊妙
  于中有千佛　　次第而出兴
  众生少烦恼　　众会悉清净
  初金刚脐佛　　二无碍力佛
  三名法界影　　四号十方灯
  第五名悲光　　第六名戒海
  第七忍灯轮　　第八法轮光
  九名光庄严　　十名寂静光
  如是等诸佛　　我悉曾供养
  犹未能深悟　　如空清净法
  游行一切刹　　于彼修诸行
  次第复有劫　　名为善出现
  刹号香灯云　　净秽所共成
  亿佛于中现　　庄严刹及劫
  所说种种法　　我皆能忆持
  初名广称佛　　次名法海佛
  三名自在王　　四名功德云
  第五法胜佛　　第六天冠佛
  第七智焰佛　　第八虚空音
  第九两足尊　　名普生殊胜
  第十无上士　　眉间胜光明
  如是一切佛　　我悉曾供养
  然犹未能净　　离诸障碍道
  次第复有劫　　名集坚固王
  刹号宝幢王　　一切善分布
  有五百诸佛　　于中而出现
  我恭敬供养　　求无碍解脱
  最初功德轮　　其次寂静音
  次名功德海　　次名日光王
  第五功德王　　第六须弥相
  次名法自在　　次佛功德王
  第九福须弥　　第十光明王
  如是等诸佛　　我悉曾供养
  所有清净道　　普入尽无余
  然于所入门　　未能成就忍
  次第复有劫　　名为妙胜主
  刹号寂静音　　众生烦恼薄
  于中有佛现　　八十那由他
  我悉曾供养　　修行最胜道
  初佛名华聚　　次佛名海藏
  次名功德生　　次号天王髻
  第五摩尼藏　　第六真金山
  第七宝聚尊　　第八法幢佛
  第九名胜财　　第十名智慧
  此十为上首　　供养无不尽
  次第复有劫　　名曰千功德
  尔时有世界　　号善化幢灯
  六十亿那由　　诸佛兴于世
  最初寂静幢　　其次奢摩他
  第三百灯王　　第四寂静光
  第五云密阴　　第六日大明
  七号法灯光　　八名殊胜焰
  九名天胜藏　　十名大吼音
  如是等诸佛　　我悉常供养
  未得清净忍　　深入诸法海
  次第复有劫　　名无著庄严
  尔时有世界　　名曰无边光
  中有三十六　　那由他佛现
  初功德须弥　　第二虚空心
  第三具庄严　　第四法雷音
  第五法界声　　第六妙音云
  第七照十方　　第八法海音
  第九功德海　　第十功德幢
  如是等诸佛　　我悉曾供养
  次有佛出现　　名为功德幢
  我为月面天　　供养人中主
  时佛为我说　　无依妙法门
  我闻专念持　　出生诸愿海
  我得清净眼　　寂灭定总持
  能于念念中　　悉见诸佛海
  我得大悲藏　　普明方便眼
  增长菩提心　　成就如来力
  见众生颠倒　　执常乐我净
  愚痴暗所覆　　妄想起烦恼
  行止见稠林　　往来贪欲海
  集于诸恶趣　　无量种种业
  一切诸趣中　　随业而受身
  生老死众患　　无量苦逼迫
  为彼众生故　　我发无上心
  愿得如十方　　一切十力尊
  缘佛及众生　　起于大愿云
  从是修功德　　趣入方便道
  愿云悉弥覆　　普入一切道
  具足波罗蜜　　充满于法界
  速入于诸地　　三世方便海
  一念修诸佛　　一切无碍行
  佛子我尔时　　得入普贤道
  了知十法界　　一切差别门

善男子。于汝意云何。彼时转轮圣王。名十方主。能绍隆佛种者。岂异人乎。文殊师利童子是也。尔时夜神。觉悟我者。普贤菩萨之所化耳。我于尔时。为王宝女。蒙彼夜神觉悟于我。令我见佛。发阿耨多罗三藐三菩提心。自从是来。经佛刹微尘数劫。不堕恶趣。常生人天。于一切处。常见诸佛。乃至于妙灯功德幢佛所。得此大势力普喜幢菩萨解脱。以此解脱。如是利益一切众生。善男子。我唯得此大势力普喜幢解脱门。如诸菩萨摩诃萨。于念念中。普诣一切诸如来所。疾能趣入一切智海。于念念中。以发趣门。入于一切诸大愿海。于念念中。以愿海门。尽未来劫。念念出生一切诸行。一一行中。出生一切刹微尘数身。一一身。普入一切法界门。一一法界门。一切佛刹中。随众生心说诸妙行。一切刹一一尘中。悉见无边诸如来海。一一如来所。悉见遍法界诸佛神通。一一如来所。悉见往劫修菩萨行。一一如来所。受持守护所有法轮。一一如来所。悉见三世一切如来诸神变海。而我云何能知能说彼功德行。善男子。此众会中。有一夜神。名普救众生妙德。汝诣彼问。菩萨云何入菩萨行。净菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第六十九大方广佛华严经卷第七十

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十一

尔时善财童子。于喜目观察众生夜神所。闻普喜幢解脱门。信解趣入。了知随顺。思惟修习。念善知识所有教诲。心无暂舍。诸根不散。一心愿得见善知识。普于十方。勤求匪懈。愿常亲近。生诸功德。与善知识同一善根。得善知识巧方便行。依善知识。入精进海。于无量劫。常不远离。作是愿已。往诣普救众生妙德夜神所。时彼夜神。为善财童子。示现菩萨。调伏众生解脱神力。以诸相好。庄严其身。于两眉间放大光明。名智灯普照清净幢。无量光明以为眷属。其光普照一切世间。照世间已。入善财顶。充满其身。善财尔时。即得究竟清净轮三昧。得此三昧已。悉见二神两处中间。所有一切地尘水尘。及以火尘。金刚摩尼。众宝微尘。华香璎珞。诸庄严具。如是一切所有微尘。一一尘中。各见佛刹微尘数世界成坏。及见一切地水火风诸大积聚。亦见一切世界接连。皆以地轮。任持而住。种种山海。种种河池。种种树林。种种宫殿。所谓天宫殿。龙宫殿。夜叉宫殿。乃至摩睺罗伽。人非人等。宫殿屋宅。地狱畜生。阎罗王界。一切住处。诸趣轮转。生死往来。随业受报。各各差别。靡不悉见。又见一切世界差别。所谓或有世界杂秽。或有世界清净。或有世界趣杂秽。或有世界趣清净。或有世界杂秽清净。或有世界清净杂秽。或有世界一向清净。或有世界其形平正。或有覆住。或有侧住。如是等一切世界。一切趣中。悉见此普救众生夜神。于一切时一切处。随诸众生形貌言辞行解差别。以方便力。普现其前。随宜化度。令地狱众生免诸苦毒。令畜生众生不相食啖。令饿鬼众生无有饥渴。令诸龙等离一切怖。令欲界众生离欲界苦。令人趣众生离暗夜怖。毁呰怖。恶名怖。大众怖。不活怖。死怖。恶道怖。断善根怖。退菩提心怖。遇恶知识怖。离善知识怖。堕二乘地怖。种种生死怖。异类众生同住怖。恶时受生怖。恶种族中受生怖。造恶业怖。业烦恼障怖。执着诸想系缚怖。如是等怖。悉令舍离。又见一切众生。卵生胎生。湿生化生。有色无色。有想无想。非有想非无想。普现其前。常勤救护。为成就菩萨大愿力故。深入菩萨三昧力故。坚固菩萨神通力故。出生普贤行愿力故。增广菩萨大悲海故。得普覆众生无碍大慈故。得普与众生无量喜乐故。得普摄一切众生智慧方便故。得菩萨广大解脱自在神通故。严净一切佛刹故。觉了一切诸法故。供养一切诸佛故。受持一切佛教故。积集一切善根修一切妙行故。入一切众生心海而无障碍故。知一切众生诸根教化成熟故。净一切众生信解除其恶障故。破一切众生无知黑闇故。令得一切智清净光明故。时善财童子。见此夜神如是神力不可思议甚深境界。普现调伏一切众生菩萨解脱已。欢喜无量。头面作礼。一心瞻仰。时彼夜神即舍菩萨庄严之相。还复本形。而不舍其自在神力。尔时善财童子。恭敬合掌。却住一面以偈赞曰

  我善财得见　　如是大神力
  其心生欢喜　　说偈而赞叹
  我见尊妙身　　众相以庄严
  譬如空中星　　一切悉严净
  所放殊胜光　　无量刹尘数
  种种微妙色　　普照于十方
  一一毛孔放　　众生心数光
  一一光明端　　皆出宝莲华
  华中出化身　　能灭众生苦
  光中出妙香　　普熏于众生
  复雨种种华　　供养一切佛
  两眉放妙光　　量与须弥等
  普触诸含识　　令灭愚痴闇
  口放清净光　　譬如无量日
  普照于广大　　毗卢舍那境
  眼放清净光　　譬如无量月
  普照十方刹　　悉灭世痴翳
  现化种种身　　相状等众生
  充满十方界　　度脱三有海
  妙身遍十方　　普现众生前
  灭除水火贼　　王等一切怖
  我承喜目教　　今得诣尊所
  见尊眉间相　　放大清净光
  普照十方海　　悉灭一切闇
  显现神通力　　而来入我身
  我遇圆满光　　心生大欢喜
  得总持三昧　　普见十方佛
  我于所经处　　悉见诸微尘
  一一微尘中　　各见尘数刹
  或有无量刹　　一切咸浊秽
  众生受诸苦　　常悲叹号泣
  或有染净刹　　少乐多忧苦
  示现三乘像　　往彼而救度
  或有净染刹　　众生所乐见
  菩萨常充满　　住持诸佛法
  一一微尘中　　无量净刹海
  毗卢遮那佛　　往劫所严净
  佛于一切刹　　悉坐菩提树
  成道转法轮　　度脱诸群生
  我见普救天　　于彼无量刹
  一切诸佛所　　普皆往供养

尔时善财童子。说此颂已。白普救众生妙德夜神言。天神。今此解脱甚深希有。其名何等。得此解脱。其已久如。修何等行而得清净。夜神言。善男子。是处难知。诸天及人一切二乘。所不能测。何以故。此是住普贤菩萨行者境界故。住大悲藏者境界故。救护一切众生者境界故。能净一切三恶八难者境界故。能于一切佛刹中绍隆佛种不断者境界故。能住持一切佛法者境界故。能于一切劫修菩萨行成满大愿海者境界故。能于一切法界海以清净智光灭无明闇障者境界故。能以一念智慧光明普照一切三世方便海者境界故。我承佛力。今为汝说。善男子。乃往古世。过佛刹微尘数劫。尔时有劫。名圆满清净。世界名毗卢遮那大威德。有须弥山微尘数如来。于中出现。其佛世界。以一切香王摩尼宝为体。众宝庄严。住无垢光明摩尼王海上。其形正圆。净秽合成。一切严具帐云。而覆其上。一切庄严摩尼轮山。千匝围绕。有十万亿那由他四天下。皆妙庄严。或有四天下恶业众生。于中止住。或有四天下杂业众生。于中止住。或有四天下善根众生。于中止住。或有四天下一向清净诸大菩萨之所止住。此界东际轮围山侧。有四天下。名宝灯华幢。国界清净。饮食丰足。不藉耕耘而生稻粱。宫殿楼阁。悉皆奇妙。诸如意树。处处行列。种种香树恒出香云。种种鬘树恒出鬘云。种种华树常雨妙华。种种宝树出诸奇宝。无量色光周匝照耀。诸音乐树出诸音乐。随风吹动演妙音声。日月光明摩尼宝王。普照一切。昼夜受乐。无时间断。此四天下。有百万亿那由他诸王国土。一一国土。有千大河周匝围绕。一一皆以妙华覆上。随流漂动。出天乐音。一切宝树列植其岸。种种珍奇以为严饰。舟船来往。称情戏乐。一一河间有百万亿城。一一城有百万亿那由他聚落。如是一切城邑聚落。各有无量百千亿那由他宫殿园林。周匝围绕。此四天下阎浮提内。有一国土。名宝华灯。安隐丰乐。人民炽盛。其中众生。具行十善。有转轮王。于中出现。名毗卢遮那妙宝莲华髻。于莲华中。忽然化生。三十二相以为严好。七宝具足王四天下。恒以正法教导群生。王有千子。端正勇健。能伏怨敌。百万亿那由他宫人采女。皆悉与王同种善根。同修诸行。同时诞生。端正姝妙。犹如天女。身真金色。常放光明。诸毛孔中。恒出妙香。良臣猛将。具足十亿。王有正妃。名圆满面。是王女宝。端正殊特。皮肤金色。目发绀青。言同梵音。身有天香。常放光明。照千由旬。其有一女。名普智焰妙德眼。形体端严。色相殊美。众生见者。情无厌足。尔时众生。寿命无量。或有不定而中夭者。种种形色。种种音声。种种名字。种种族姓。愚智勇怯。贫富苦乐。无量品类。皆悉不同。时或有人。语余人言。我身端正。汝形鄙陋。作是语已。递相毁辱。集不善业。以是业故。寿命色力。一切乐事。悉皆损减。时彼城北有菩提树。名普光法云音幢。以念念出现一切如来道场庄严坚固摩尼王。而为其根。一切摩尼。以为其干。众杂妙宝。以为其叶。次第分布。并相称可。四方上下。圆满庄严。放宝光明。出妙音声。说一切如来甚深境界。于彼树前。有一香池。名宝华光明。演法雷音。妙宝为岸。百万亿那由他宝树围绕。一一树形。如菩提树。众宝璎珞。周匝垂下。无量楼阁。皆宝所成。周遍道场。以为严饰。彼香池内出大莲华。名普现三世一切如来庄严境界云。须弥山微尘数佛。于中出现。其第一佛。名普智宝焰妙德幢。于此华上。最初得阿耨多罗三藐三菩提。无量千岁。演说正法。成熟众生。其彼如来。未成佛时。十千年前。此大莲华。放净光明。名现诸神通成熟众生。若有众生。遇斯光者。心自开悟。无所不了。知十千年后。佛当出现。九千年前。放净光明。名一切众生离垢灯。若有众生。遇斯光者。得清净眼。见一切色。知九千年后。佛当出现。八千年前。放大光明。名一切众生业果音。若有众生。遇斯光者。悉得自知诸业果报。知八千年后。佛当出现。七千年前。放大光明。名生一切善根音。若有众生遇斯光者。一切诸根。悉得圆满。知七千年后。佛当出现。六千年前。放大光明。名佛不思议境界音。若有众生。遇斯光者。其心广大。普得自在。知六千年后。佛当出现。五千年前。放大光明。名严净一切佛刹音。若有众生。遇斯光者。悉见一切清净佛土。知五千年后。佛当出现。四千年前。放大光明。名一切如来境界无差别灯。若有众生。遇斯光者。悉能往觐一切诸佛。知四千年后。佛当出现。三千年前。放大光明。名三世明灯。若有众生。遇斯光者。悉能现见一切如来诸本事海。知三千年后。佛当出现。二千年前。放大光明。名如来离翳智慧灯。若有众生。遇斯光者。则得普眼见一切如来神变。一切诸佛国土。一切世界众生。知二千年后。佛当出现。一千年前。放大光明。名令一切众生见佛集诸善根。若有众生。遇斯光者。则得成就见佛三昧。知一千年后。佛当出现。次七日前。放大光明。名一切众生欢喜音。若有众生。遇斯光者。得普见诸佛生大欢喜。知七日后。佛当出现。满七日已。一切世界。悉皆震动。纯净无染。念念普现十方一切清净佛刹。亦现彼刹种种庄严。若有众生。根性淳熟。应见佛者。咸诣道场。尔时彼世界中。一切轮围。一切须弥。一切诸山。一切大海。一切地。一切城。一切垣墙。一切宫殿。一切音乐。一切语言。皆出音声。赞说一切诸佛如来神力境界。又出一切香云。一切烧香云。一切末香云。一切香摩尼形像云。一切宝焰云。一切焰藏云。一切摩尼衣云。一切璎珞云。一切妙华云。一切如来光明云。一切如来圆光云。一切音乐云。一切如来愿声云。一切如来言音海云。一切如来相好云。显示如来出现世间不思议相。善男子。此普照三世一切如来庄严境界大宝莲华王。有十佛刹微尘数莲华周匝围绕。诸莲华内。悉有摩尼宝藏师子之座。一一座上。皆有菩萨。结跏趺坐。善男子。彼普智宝焰妙德幢王如来。于此。成阿耨多罗三藐三菩提时。即于十方一切世界中。成阿耨多罗三藐三菩提。随众生心。悉现其前。为转法轮。于一一世界。令无量众生。离恶道苦。令无量众生。得生天中。令无量众生。住于声闻辟支佛地。令无量众生。成就出离菩提之行。令无量众生。成就勇猛幢菩提之行。令无量众生。成就法光明菩提之行。令无量众生。成就清净根菩提之行。令无量众生。成就平等力菩提之行。令无量众生。成就入法城菩提之行。令无量众生。成就遍至一切处不可坏神通力菩提之行。令无量众生。入普门方便道菩提之行。令无量众生。安住三昧门菩提之行。令无量众生。成就缘一切清净境界菩提之行。令无量众生。发菩提心。令无量众生。住菩萨道。令无量众生。安住清净波罗蜜道。令无量众生。住菩萨初地。令无量众生。住菩萨二地乃至十地。令无量众生。入于菩萨殊胜行愿。令无量众生。安住普贤清净行愿。善男子。彼普智宝焰妙德幢如来。现如是不思议自在神力。转法轮时。于彼一一诸世界中。随其所应。念念调伏无量众生。时普贤菩萨。知宝华灯王城中众生。自恃色貌及诸境界。而生憍慢。陵蔑他人。化现妙身。端正殊特。往诣彼城。放大光明。普照一切。令彼圣王及诸妙宝。日月星宿。众生身等。一切光明。悉皆不现。譬如日出众景夺曜。亦如聚墨对阎浮金。时诸众生。咸作是言。此为是谁。为天为梵。今放此光。令我等身所有光色。皆不显现。种种思惟无能解了。尔时普贤菩萨。在彼轮王宝宫殿上虚空中住。而告之言。大王当知今汝国中。有佛兴世。在普光明法云音幢菩提树下。时圣王女。莲华妙眼。见普贤菩萨所现色身光明自在。及闻身上诸庄严具所出妙音。心生欢喜。作如是念。愿我所有一切善根。得如是身。如是庄严。如是相好。如是威仪。如是自在。今此大圣。能于众生生死长夜黑闇之中。放大光明。开示如来出兴于世。愿令于我亦得如是。为诸众生作智光明。破彼所有无知黑闇。愿我所在受生之处。常得不离此善知识。善男子。时转轮王。与其宝女千子眷属。大臣辅佐。四种兵众。及其城内。无量人民。前后围绕。以王神力。俱升虚空。高一由旬。放大光明。照四天下。普使一切。咸得瞻仰。欲令众生俱往见佛。以偈赞曰

  如来出世间　　普救诸群生
  汝等应速起　　往诣导师所
  无量无数劫　　乃有佛兴世
  演说深妙法　　饶益一切众
  佛观诸世间　　颠倒常痴惑
  轮回生死苦　　而起大悲心
  无数亿千劫　　修习菩提行
  为欲度众生　　斯由大悲力
  头目手足等　　一切悉能舍
  为求菩提故　　如是无量劫
  无量亿千劫　　导师难可遇
  见闻若承事　　一切无空过
  今当共汝等　　往观调御尊
  坐于如来座　　降魔成正觉
  瞻仰如来身　　放演无量光
  种种微妙色　　除灭一切暗
  一一毛孔中　　放光不思议
  普照诸群生　　咸令大欢喜
  汝等咸应发　　广大精进心
  诣彼如来所　　恭敬而供养

尔时转轮圣王。说偈赞佛。开悟一切众生已。从轮王善根。出十千种大供养云。往诣道场。向如来所。所谓一切宝盖云。一切华帐云。一切宝衣云。一切宝铃网云。一切香海云。一切宝座云。一切宝幢云。一切宫殿云。一切妙华云。一切诸庄严具云。于虚空中。周遍严饰。到已顶礼普智宝焰妙德幢王如来足。绕无量百千匝。即于佛前坐普照十方宝莲华座。时转轮王女。普智焰妙德眼。即解身上诸庄严具。持以散佛。时庄严具。于虚空中。变成宝盖。宝网垂下。龙王执持。一切宫殿。于中间列。十种宝盖。周匝围绕。形如楼阁。内外清净。诸璎珞云。及诸宝树。香海摩尼。以为庄严。于此盖中。有菩提树。枝叶荣茂。普覆法界。念念示现无量庄严。毗卢遮那如来。坐此树下。有不可说佛刹微尘数菩萨。前后围绕。皆从普贤行愿出生。住诸菩萨无差别住。亦见有一切诸世间主。亦见如来自在神力。又见一切诸劫次第世界成坏。又亦见彼一切世界。一切诸佛。出兴次第。又亦见彼一切世界一一皆有普贤菩萨。供养于佛。调伏众生。又亦见彼一切菩萨。莫不皆在普贤身中。亦见自身在其身内。亦见其身在一切如来前。一切普贤前。一切菩萨前。一切众生前。又亦见彼一切世界。一一各有佛刹微尘数世界。种种际畔。种种任持。种种形状。种种体性。种种安布。种种庄严。种种清净。种种庄严云。而覆其上。种种劫名。种种佛兴。种种三世。种种方处。种种住法界。种种入法界。种种住虚空。种种如来菩提场。种种如来神通力。种种如来师子座。种种如来大众海。种种如来众差别。种种如来巧方便。种种如来转法轮。种种如来妙音声。种种如来言说海。种种如来契经云。既见是已。其心清净。生大欢喜。普智宝焰妙德幢王如来。为说修多罗。名一切如来转法轮。十佛刹微尘数修多罗。而为眷属。时彼女人。闻此经已。则得成就十千三昧门。其心柔软。无有粗强。如初受胎。如始诞生。如娑罗树初始生芽。彼三昧心。亦复如是。所谓现见一切佛三昧。普照一切刹三昧。入一切三世门三昧。说一切佛法轮三昧。知一切佛愿海三昧。开悟一切众生令出生死苦三昧。常愿破一切众生闇三昧。常愿灭一切众生苦三昧。常愿生一切众生乐三昧。教化一切众生不生疲厌三昧。一切菩萨无障碍幢三昧。普诣一切清净佛刹三昧。得如是等十千三昧已。复得妙定心。不动心。欢喜心。安慰心。广大心。顺善知识心。缘甚深一切智心。住广大方便海心。舍离一切执着心。不住一切世间境界心。入如来境界心。普照一切色海心。无恼害心。无高倨心。无疲倦心。无退转心。无懈怠心。思惟诸法自性心。安住一切法门海心。观察一切法门海心。了知一切众生海心。救护一切众生海心。普照一切世界海心。普生一切佛愿海心。悉破一切障山心。积集福德助道心。现见诸佛十力心。普照菩萨境界心。增长菩萨助道心。遍缘一切方海心。一心思惟普贤大愿。发一切如来十佛刹微尘数愿海。愿严净一切佛国。愿调伏一切众生。愿遍知一切法界。愿普入一切法界海。愿于一切佛刹。尽未来际劫。修菩萨行。愿尽未来际劫。不舍一切菩萨行。愿得亲近一切如来。愿得承事一切善友。愿得供养一切诸佛。愿于念念中。修菩萨行。增一切智。无有间断。发如是等十佛刹微尘数愿海。成就普贤所有大愿。时彼如来。复为其女。开示演说发心已来所集善根。所修妙行。所得大果。令其开悟成就如来所有愿海。一心趣向一切智位。善男子。复于此前。过十大劫。有世界。名日轮光摩尼。佛号因陀罗幢妙相。此妙眼女。于彼如来遗法之中。普贤菩萨。劝其修补莲华座上。故坏佛像。既修补已。而复彩画。既彩画已。复宝庄严。发阿耨多罗三藐三菩提心。善男子。我念过去。由普贤菩萨善知识故。种此善根。从是已来。不堕恶趣。常于一切天王人王种族中生。端正可喜。众相圆满。令人乐见。常见于佛。常得亲近普贤菩萨。乃至于今。示导开悟。成熟于我。令生欢喜。善男子。于意云何。尔时毗卢遮那藏妙宝莲华髻转轮圣王者。岂异人乎。今弥勒菩萨是。时王妃圆满面者。寂静音海夜神是。今所住处。去此不远。时妙德眼童女者。即我身是我于彼时身为童女。普贤菩萨。劝我修补莲华座像。以为无上菩提因缘。令我发于阿耨多罗三藐三菩提心。我于彼时。初始发心。次复引导。令我得见妙德幢佛。解身璎珞。散佛供养。见佛神力。闻佛说法。即得菩萨普现一切世间调伏众生解脱门。于念念中。见须弥山微尘数佛。亦见彼佛道场众会清净国土。我皆尊重。恭敬供养。听闻说法。依教修行。善男子。过彼毗卢遮那大威德世界圆满清净劫已。次有世界。名宝轮妙庄严。劫名大光。有五百佛。于中出现。我皆承事恭敬供养。其最初佛。名大悲幢。初出家时。我为夜神。恭敬供养。次有佛出。名金刚那罗延幢。我为转轮王。恭敬供养。其佛为我。说修多罗。名一切佛出现。十佛刹微尘数修多罗。以为眷属。次有佛出。名金刚无碍德。我于彼时。为转轮王。恭敬供养。其佛为我。说修多罗。名普照一切众生根。须弥山微尘数修多罗。而为眷属。我皆受持。次有佛出。名火焰山妙庄严。我于彼时。为长者女。其佛为我。说修多罗。名普照三世藏。阎浮提微尘数修多罗。而为眷属。我皆听闻。如法受持。次有佛出。名一切法海高胜王。我为阿修罗王。恭敬供养。其佛为我。说修多罗。名分别一切法界。五百修多罗。而为眷属。我皆听闻。如法受持。次有佛出。名海岳法光明。我为龙王女。雨如意摩尼宝云。而为供养。其佛为我。说修多罗。名增长欢喜海。百万亿修多罗。而为眷属。我皆听闻。如法受持。次有佛出。名宝焰山灯。我为海神。雨宝莲华云。恭敬供养。其佛为我。说修多罗。名法界方便海光明佛刹微尘数修多罗。而为眷属。我皆听闻。如法受持次有佛出。名功德海光明轮。我于彼时为五通仙。现大神通六万诸仙。前后围绕。雨香华云而为供养。其佛为我。说修多罗。名无著法灯。六万修多罗。而为眷属。我皆听闻。如法受持。次有佛出。名毗卢遮那功德藏。我于彼时。为主地神。名出生平等义。与无量地神俱。雨一切宝树。一切摩尼藏。一切宝璎珞云。而为供养。其佛为我。说修多罗。名出生一切如来智藏。无量修多罗。而为眷属。我皆听闻。受持不忘。善男子。如是次第。其最后佛。名充满虚空法界妙德灯。我为妓女。名曰美颜。见佛入城。歌舞供养。承佛神力。踊在空中。以千偈颂。赞叹于佛。佛为于我。放眉间光。名庄严法界大光明。遍触我身。我蒙光已。即得解脱门。名法界方便不退藏。善男子。此世界中。有如是等佛刹微尘数劫。一切如来。于中出现。我皆承事。恭敬供养。彼诸如来。所说正法。我皆忆念。乃至不忘一文一句。于彼一一诸如来所。称扬赞叹一切佛法。为无量众生。广作利益。于彼一一诸如来所。得一切智光明。现三世法界海。入一切普贤行。善男子。我依一切智光明故于念念中。见无量佛。既见佛已。先所未得。先所未见。普贤诸行。悉得成满。何以故。以得一切智光明故。尔时普救众生夜神欲重明此解脱义。承佛神力。为善财童子。而说颂言

  善财听我说　　甚深难见法
  普照于三世　　一切差别门
  如我初发心　　专求佛功德
  所入诸解脱　　汝今应谛听
  我念过去世　　过刹微尘劫
  次前有一劫　　名圆满清净
  是时有世界　　名为遍照灯
  须弥尘数佛　　于中出兴世
  初佛名智焰　　次佛名法幢
  第三法须弥　　第四德师子
  第五寂静王　　第六灭诸见
  第七高名称　　第八大功德
  第九名胜日　　第十名月面
  于此十佛所　　最初悟法门
  从此后次第　　复有十佛出
  初名虚空处　　第二名普光
  三名住诸方　　四名正念海
  五名高胜光　　六名须弥云
  七名法焰佛　　八名山胜佛
  九名大悲华　　十名法界华
  此十出现时　　第二悟法门
  从此后次第　　复有十佛出
  第一光幢佛　　第二智慧佛
  第三心义佛　　第四德主佛
  第五天慧佛　　第六慧王佛
  第七胜智佛　　第八光王佛
  第九勇猛佛　　第十莲华佛
  于此十佛所　　第三悟法门
  从此后次第　　复有十佛出
  第一宝焰山　　第二功德海
  第三法光明　　第四莲华藏
  第五众生眼　　第六香光宝
  七须弥功德　　八乾闼婆王
  第九摩尼藏　　第十寂静色
  从此后次第　　复有十佛出
  初佛广大智　　次佛宝光明
  第三虚空云　　第四殊胜相
  第五圆满戒　　第六那罗延
  第七须弥德　　第八功德轮
  第九无胜幢　　第十大树山
  从此后次第　　复有十佛出
  第一娑罗藏　　第二世主身
  第三高显光　　第四金刚照
  第五地威力　　第六甚深法
  第七法慧音　　第八须弥幢
  第九胜光明　　第十妙宝光
  从此后次第　　复有十佛出
  第一梵光明　　第二虚空音
  第三法界身　　第四光明轮
  第五智慧幢　　第六虚空灯
  第七微妙德　　第八遍照光
  第九胜福光　　第十大悲云
  从此后次第　　复有十佛出
  第一力光慧　　第二普现前
  第三高显光　　第四光明身
  第五法起佛　　第六宝相佛
  第七速疾风　　第八勇猛幢
  第九妙宝盖　　第十照三世
  从此后次第　　复有十佛出
  第一愿海光　　第二金刚身
  第三须弥德　　第四念幢王
  第五功德慧　　第六智慧灯
  第七光明幢　　第八广大智
  第九法界智　　第十法海智
  从此后次第　　复有十佛出
  初名布施法　　次名功德轮
  三名胜妙云　　四名忍智灯
  五名寂静音　　六名寂静幢
  七名世间灯　　八名深大愿
  九名无胜幢　　十名智焰海
  从此后次第　　复有十佛出
  初佛法自在　　二佛无碍慧
  三名意海慧　　四名众妙音
  五名自在施　　六名普现前
  七名随乐身　　八名住胜德
  第九本性佛　　第十贤德佛
  须弥尘数劫　　此中所有佛
  普作世间灯　　我悉曾供养
  佛刹微尘劫　　所有佛出现
  我皆曾供养　　入此解脱门
  我于无量劫　　修行得此道
  汝若能修行　　不久亦当得

善男子。我唯知此菩萨普现一切世间调伏众生解脱。如诸菩萨摩诃萨。集无边行。生种种解。现种种身。具种种根。满种种愿。入种种三昧。起种种神变。能种种观察法。入种种智慧门。得种种法光明。而我云何能知能说彼功德行。善男子。去此不远。有主夜神。名寂静音海。坐摩尼光幢庄严莲华座。百万阿僧祇主夜神。前后围绕。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第七十大方广佛华严经卷第七十一

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十二

尔时善财童子。于普救众生妙德夜神所。闻菩萨普现一切世间调伏众生解脱门。了知信解。自在安住。而往寂静音海夜神所。顶礼其足。绕无数匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。我欲依善知识。学菩萨行。入菩萨行。修菩萨行。住菩萨行。唯愿慈哀。为我宣说。菩萨云何学菩萨行。云何修菩萨道。时彼夜神。告善财言。善哉善哉。善男子。汝能依善知识。求菩萨行。善男子。我得菩萨念念出生广大喜庄严解脱门。善财言。大圣。此解脱门。为何事业。行何境界。起何方便。作何观察。夜神言。善男子。我发起清净平等乐欲心。我发起离一切世间尘垢清净坚固庄严不可坏乐欲心。我发起攀缘不退转位永不退转心。我发起庄严功德宝山不动心。我发起无住处心。我发起普现一切众生前救护心。我发起见一切佛海无厌足心。我发起求一切菩萨清净愿力心。我发起住大智光明海心。我发起令一切众生超过忧恼旷野心。我发起令一切众生舍离愁忧苦恼心。我发起令一切众生舍离不可意色声香味触法心。我发起令一切众生舍离爱别离苦怨憎会苦心。我发起令一切众生舍离恶缘愚痴等苦心。我发起与一切险难众生作依怙心。我发起令一切众生出生死苦处心。我发起令一切众生舍离生老病死等苦心。我发起令一切众生成就如来无上法乐心。我发起令一切众生皆受喜乐心。发是心已。复为说法。令其渐至一切智地。所谓若见众生。乐着所住宫殿屋宅。我为说法。令其了达诸法自性。离诸执着。若见众生恋着父母兄弟姊妹。我为说法。令其得预诸佛菩萨清净众会。若见众生恋着妻子。我为说法。令其舍离生死爱染。起大悲心。于一切众生。平等无二。若见众生住于王宫。采女侍奉。我为说法。令其得与众圣集会。入如来教。若见众生染着境界。我为说法。令其得入如来境界。若见众生多嗔恚者。我为说法。令住如来忍波罗蜜。若见众生其心懈怠。我为说法。令得清净精进波罗蜜。若见众生其心散乱。我为说法。令得如来禅波罗蜜。若见众生入见稠林无明暗障。我为说法。令得出离稠林黑暗。若见众生无智慧者。我为说法。令得般若波罗蜜。若见众生染着三界。我为说法。令出生死。若见众生志意下劣。我为说法。令其圆满佛菩提愿。若见众生住自利行。我为说法。令其发起利益一切诸众生愿。若见众生志力微弱。我为说法。令得菩萨力波罗蜜。若见众生愚痴闇心。我为说法。令得菩萨智波罗蜜。若见众生色相不具。我为说法。令得如来清净色身。若见众生形容丑陋。我为说法。令得无上清净法身。若见众生色相粗恶。我为说法令得如来微妙色身。若见众生情多忧恼。我为说法。令得如来毕竟安乐。若见众生贫穷所苦。我为说法。令得菩萨功德宝藏。若见众生住止园林。我为说法。令彼勤求佛法因缘。若见众生行于道路。我为说法。令其趣向一切智道。若见众生在聚落中。我为说法。令出三界。若见众生住止人间。我为说法。令其超越二乘之道。住如来地。若见众生居住城廓。我为说法。令其得住法王城中若见众生住于四隅。我为说法。令得三世平等智慧。若见众生住于诸方。我为说法。令得智慧见一切法。若见众生贪行多者。我为彼说不净观门。令其舍离生死爱染。若见众生嗔行多者。我为彼说大慈观门。令其得入勤加修习。若见众生痴行多者。我为说法。令得明智观诸法海。若见众生等分行者。我为说法。令其得入诸乘愿海。若见众生乐生死乐。我为说法。令其厌离。若见众生厌生死苦。应为如来所化度者。我为说法。令能方便示现受生。若见众生爱着五蕴。我为说法。令其得住无依境界。若见众生其心下劣。我为显示胜庄严道。若见众生心生憍慢。我为其说平等法忍。若见众生其心谄曲。我为其说菩萨直心。善男子。我以此等无量法施。摄诸众生。种种方便。教化调伏。令离恶道受人天乐。脱三界缚住一切智。我时便得广大欢喜法光明海。其心怡畅。安隐适悦。复次善男子。我常观察一切菩萨道场众会。修种种愿行。现种种净身。有种种常光。放种种光明。以种种方便。入一切智门。入种种三昧。现种种神变。出种种音声海。具种种庄严身。入种种如来门。诣种种国土海。见种种诸佛海。得种种辩才海。照种种解脱境。得种种智光海。入种种三昧海。游戏种种诸解脱门。以种种门趣一切智。种种庄严。虚空法界。以种种庄严云遍覆虚空。观察种种道场众会。集种种世界。入种种佛刹。诣种种方海。受种种如来命。从种种如来所。与种种菩萨俱。雨种种庄严云。入如来种种方便。观如来种种法海。入种种智慧海。坐种种庄严座。善男子。我观察此道场众会。知佛神力无量无边。生大欢喜。善男子。我观毗卢遮那如来念念出现不可思议清净色身。既见是已。生大欢喜。又观如来于念念中放大光明充满法界。既见是已。生大欢喜。又见如来一一毛孔。念念出现无量佛刹微尘数光明海。一一光明。以无量佛刹微尘数光明。而为眷属。一一周遍一切法界。消灭一切诸众生苦。既见是已。生大欢喜。又善男子。我观如来顶及两肩。念念出现一切佛刹微尘数宝焰山云。充满十方一切法界。既见是已。生大欢喜。又善男子。我观如来一一毛孔。于念念中。出一切佛刹微尘数香光明云。充满十方一切佛刹。既见是已。生大欢喜。又善男子。我观如来一一相。念念出一切佛刹微尘数诸相庄严如来身云。遍往十方一切世界。既见是已。生大欢喜。又善男子。我观如来一一毛孔。于念念中出不可说佛刹微尘数佛变化云。示现如来从初发心修波罗蜜具庄严道入菩萨地。既见是已。生大欢喜。又善男子。我观如来一一毛孔。念念出现不可说不可说佛刹微尘数天王身云。及以天王自在神变。充遍一切十方法界。应以天王身而得度者。即现其前。而为说法。既见是已。生大欢喜。如天王身云。其龙王夜叉王。乾闼婆王。阿修罗王。迦楼罗王。紧那罗王。摩睺罗伽王。人王梵王身云。莫不皆于一一毛孔如是出现如是说法。我见是已。于念念中。生大欢喜。生大信乐。量与法界萨婆若等。昔所未得而今始得。昔所未证而今始证。昔所未入而今始入。昔所未满而今始满。昔所未见而今始见。昔所未闻而今始闻。何以故。以能了知法界相故。知一切法唯一相故。能平等入三世道故。能说一切无边法故。善男子。我入此菩萨念念出生广大喜庄严解脱光明海。又善男子。此解脱无边。普入一切法界门故。此解脱无尽。等发一切智性心故。此解脱无际。入无际畔一切众生心想中故。此解脱甚深。寂静智慧所知境故。此解脱广大周遍一切如来境故。此解脱无坏。菩萨智眼之所知故。此解脱无底。尽于法界之源底故。此解脱者即是普门。于一事中。普见一切诸神变故。此解脱者终不可取。一切法身等无二故。此解脱者终无有生。以能了知如幻法故。此解脱者犹如影像。一切智愿光所生故。此解脱者犹如变化。化生菩萨诸胜行故。此解脱者犹如大地。为一切众生。所依处故。此解脱者犹如大水。能以大悲润一切故。此解脱者犹如大火。干竭众生贪爱水故。此解脱者犹如大风。令诸众生速疾趣于一切智故。此解脱者犹如大海。种种功德庄严一切诸众生故。此解脱者如须弥山。出一切智法宝海故。此解脱者如大城廓。一切妙法所庄严故。此解脱者犹如虚空。普容三世佛神力故。此解脱者犹如大云。普为众生雨法雨故。此解脱者犹如净日。能破众生无知暗故。此解脱者犹如满月。满足广大福德海故。此解脱者犹如真如。悉能周遍一切处故。此解脱者犹如自影。从自善业所化出故。此解脱者犹如呼响。随其所应为说法故。此解脱者犹如影像。随众生心而照现故。此解脱者如大树王。开敷一切神通华故。此解脱者犹如金刚。从本已来不可坏故。此解脱者如如意珠。出生无量自在力故。此解脱者如离垢藏。摩尼宝王示现一切三世如来诸神力故。此解脱者如喜幢摩尼宝。能平等出一切诸佛法轮声故。善男子。我今为汝。说此譬谕。汝应思惟。随顺悟入。尔时善财童子。白寂静音海夜神言。大圣。云何修行。得此解脱。夜神言。善男子。菩萨修行十大法藏。得此解脱。何等为十。一修布施广大法藏。随众生心悉令满足。二修净戒广大法藏。普入一切佛功德海。三修堪忍广大法藏。能遍思惟一切法性。四修精进广大法藏。趣一切智恒不退转。五修禅定广大法藏。能灭一切众生热恼。六修般若广大法藏。能遍了知一切法海。七修方便广大法藏。能遍成熟诸众生海。八修诸愿广大法藏。遍一切佛刹一切诸众生海尽未来劫修菩萨行。九修诸力广大法藏。念念现于一切法界海一切佛国土成等正觉常不休息。十修净智广大法藏。得如来智遍知三世一切诸法无有障碍。善男子。若诸菩萨。安住如是十大法藏。则能获得如是解脱。清净增长积集坚固。安住圆满。善财童子言。圣者。汝发阿耨多罗三藐三菩提心。其已久如。夜神言。善男子。此华藏庄严世界海东。过十世界海。有世界海。名一切净光宝。此世界海中。有世界种。名一切如来愿光明音。中有世界。名清净光金庄严。一切香金刚摩尼王为体。形如楼阁。众妙宝云。以为其际。住于一切宝璎珞海。妙宫殿云。而覆其上。净秽相杂。此世界中。乃往古世。有劫名普光幢。国名普满妙藏。道场名一切宝藏妙月光明。有佛名不退转法界音。于此成阿耨多罗三藐三菩提。我于尔时。作菩提树神。名具足福德灯光明幢。守护道场。我见彼佛成等正觉。示现神力。发阿耨多罗三藐三菩提心。即于此时。获得三昧。名普照如来功德海。此道场中。次有如来。出兴于世。名法树威德山。我时命终。还生此中。为道场主夜神。名殊妙福智光。见彼如来转正法轮。现大神通。即得三昧。名普照一切离贪境界。次有如来。出兴于世。名一切法海音声王。我于彼时。身为夜神。因得见佛承事供养。即获三昧。名生长一切善法地。次有如来。出兴于世。名宝光明灯幢王。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名普现神通光明云。次有如来。出兴于世。名功德须弥光。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名普照诸佛海。次有如来。出兴于世。名法云音声王。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名一切法海灯。次有如来。出兴于世。名智灯照耀王。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名灭一切众生苦清净光明灯。次有如来。出兴于世。名法勇妙德幢。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名三世如来光明藏。次有如来。出兴于世。名师子勇猛法智灯。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名一切世间无障碍智慧轮。次有如来。出兴于世。名智力山王。我于彼时。身为夜神。因得见佛。承事供养。即获三昧。名普照三世众生诸根行。善男子。清净光金庄严世界。普光明幢劫中。有如是等佛刹微尘数如来。出兴于世。我于彼时。或为天王。或为龙王。或为夜叉王。或为乾闼婆王。或为阿修罗王。或为迦楼罗王。或为紧那罗王。或为摩睺罗伽王。或为人王。或为梵王。或为天身。或为人身。或为男子身。或为女人身。或为童男身。或为童女身。悉以种种诸供养具。供养于彼一切如来。亦闻其佛所说诸法。从此命终。还即于此世界中生。经佛刹微尘数劫。修菩萨行。然后命终。生此华藏庄严世界海娑婆世界。值迦罗鸠孙驮如来。承事供养。得三昧。名离一切尘垢光明。次值拘那含牟尼如来。承事供养。得三昧。名普现一切诸刹海。次值迦叶如来。承事供养。得三昧。名演一切众生言音海。次值毗卢遮那如来于此道场。成正等觉。念念示现大神通力。我时得见。即获此念念出生广大喜庄严解脱。得此解脱已。能入十不可说不可说佛刹微尘数法界安立海。见彼一切法界安立海一切佛刹所有微尘。一一尘中。有十不可说不可说佛刹微尘数佛国土。一一佛土。皆有毗卢遮那如来。坐于道场。于念念中。成正等觉。现诸神变。所现神变。一一皆遍一切法界海。亦见自身在彼一切诸如来所。又亦闻其所说妙法。又亦见彼一切诸佛一一毛孔。出变化海。现神通力。于一切法界海。一切世界海。一切世界种。一切世界中。随众生心。转正法轮。我得速疾陀罗尼力。受持思惟一切文义。以明了智。普入一切清净法藏。以自在智。普游一切甚深法海。以周遍智。普知三世诸广大义。以平等智。普达诸佛无差别法。如是悟解一切法门。一一法门中。悟解一切修多罗云。一一修多罗云中。悟解一切法海。一一法海中。悟解一切法品。一一法品中。悟解一切法云。一一法云中。悟解一切法流。一一法流中。出生一切大喜海。一一大喜海。出生一切地。一一地。出生一切三昧海。一一三昧海。得一切见佛海。一一见佛海。得一切智光海。一一智光海。普照三世。遍入十方。知无量如来往昔诸行海。知无量如来所有本事海。知无量如来难舍能施海。知无量如来清净戒轮海。知无量如来清净堪忍海。知无量如来广大精进海。知无量如来甚深禅定海。知无量如来般若波罗蜜海。知无量如来方便波罗蜜海。知无量如来愿波罗蜜海。知无量如来力波罗蜜海。知无量如来智波罗蜜海。知无量如来往昔超菩萨地。知无量如来往昔住菩萨地无量劫海现神通力。知无量如来往昔入菩萨地。知无量如来往昔修菩萨地。知无量如来往昔治菩萨地。知无量如来往昔观菩萨地。知无量如来昔为菩萨时常见诸佛。知无量如来昔为菩萨时。尽见佛海劫海同住。知无量如来昔为菩萨时。以无量身遍生刹海。知无量如来昔为菩萨时。周遍法界修广大行。知无量如来昔为菩萨时。示现种种诸方便门调伏成熟一切众生知无量如来放大光明。普照十方一切刹海。知无量如来现大神力。普现一切诸众生前。知无量如来广大智地。知无量如来转正法轮。知无量如来示现相海。知无量如来示现身海。知无量如来广大力海。彼诸如来。从初发心。乃至法灭。我于念念。悉得知见。善男子。汝问我言。汝发心来。其已久如。善男子。我于往昔过二佛刹微尘数劫。如上所说。于清净光金庄严世界中。为菩提树神。闻不退转法界音如来说法。发阿耨多罗三藐三菩提心。于二佛刹微尘数劫中。修菩萨行。然后乃生此娑婆世界贤劫之中。从迦罗鸠孙驮佛。至释迦牟尼佛。及此劫中。未来所有一切诸佛。我皆如是。亲近供养。如于此世界贤劫之中供养未来一切诸佛。一切世界。一切劫中。所有未来一切诸佛。悉亦如是。亲近供养。善男子。彼清净光金庄严世界。今犹现在。诸佛出现。相续不断。汝当一心修此菩萨大勇猛门。尔时寂静音海主夜神。欲重宣此解脱义。为善财童子。而说颂言

  善财听我说　　清净解脱门
  闻已生欢喜　　勤修令究竟
  我昔于劫海　　生大信乐心
  清净如虚空　　常观一切智
  我于三世佛　　皆生信乐心
  并及其众会　　悉愿常亲近
  我昔曾见佛　　为众生供养
  得闻清净法　　其心大欢喜
  常尊重父母　　恭敬而供养
  如是无休懈　　入此解脱门
  老病贫穷人　　诸根不具足
  一切皆愍济　　令其得安隐
  水火及王贼　　海中诸恐怖
  我昔修诸行　　为救彼众生
  烦恼恒炽然　　业障所缠覆
  堕于诸险道　　我救彼众生
  一切诸恶趣　　无量楚毒苦
  生老病死等　　我当悉除灭
  愿尽未来劫　　普为诸群生
  灭除生死苦　　得佛究竟乐

善男子。我唯知此念念生广大喜庄严解脱。如诸菩萨摩诃萨。深入一切法界海。悉知一切诸劫数。普见一切刹成坏。而我云何能知能说彼功德行。善男子。此菩提场如来会中。有主夜神。名守护一切城增长威力。汝诣彼问。菩萨云何学菩萨行。修菩萨道。尔时善财童子。一心观察寂静音海主夜神身。而说颂言

  我因善友教　　来诣天神所
  见神处宝座　　身量无有边
  非是着色相　　计有于诸法
  劣智浅识人　　能知尊境界
  世间天及人　　无量劫观察
  亦不能测度　　色相无边故
  远离于五蕴　　亦不住于处
  永断世间疑　　显现自在力
  不取内外法　　无动无所碍
  清净智慧眼　　见佛神通力
  身为正法藏　　心是无碍智
  既得智光照　　复照诸群生
  心集无边业　　庄严诸世间
  了世皆是心　　现身等众生
  知世悉如梦　　一切佛如影
  诸法皆如响　　令众无所著
  为三世众生　　念念示现身
  而心无所住　　十方遍说法
  无边诸刹海　　佛海众生海
  悉在一尘中　　此尊解脱力

时善财童子。说此偈已。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。随顺寂静音海夜神教。思惟观察所说法门。一一文句。皆无忘失。于无量深心。无量法性。一切方便。神通智慧。忆念思择。相续不断。其心广大。证入安住。行诣守护一切城夜神所。见彼夜神。坐一切宝光明摩尼王师子之座。无数夜神所共围绕。现一切众生色相身。现普对一切众生身。现不染一切世间身。现一切众生身数身。现超过一切世间身。现成熟一切众生身。现速往一切十方身。现遍摄一切十方身。现究竟如来体性身。现究竟调伏众生身。善财见已。欢喜踊跃。顶礼其足。绕无量匝。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨。修菩萨行时。云何饶益众生。云何以无上摄而摄众生。云何顺诸佛教。云何近法王位。唯愿慈哀。为我宣说。时彼夜神。告善财言。善男子。汝为救护一切众生故。汝为严净一切佛刹故。汝为供养一切如来故。汝欲住一切劫救众生故。汝欲守护一切佛种性故。汝欲普入十方修诸行故。汝欲普入一切法门海故。汝欲以平等心遍一切故。汝欲普受一切佛法轮故。汝欲普随一切众生心之所乐雨法雨故。问诸菩萨所修行门。善男子。我得菩萨甚深自在妙音解脱。为大法师。无所挂碍。善能开示诸佛法藏故。具大誓愿。大慈悲力。令一切众生。住菩提心故。能作一切利众生事。积集善根。无有休息故。为一切众生调御之师。令一切众生。住萨婆若道故。为一切世间清净法日。普照世间。令生善根故。于一切世间其心平等。普令众生。增长善法故。于诸境界其心清净。除灭一切诸不善业故。誓愿利益一切众生。身恒普现一切国土故。示现一切本事因缘。令诸众生。安住善行故。恒事一切诸善知识。为令众生安住佛教故。佛子。我以此等法施众生。令生白法。求一切智。其心坚固。犹如金刚那罗延藏。善能观察佛力魔力。常得亲近诸善知识。摧破一切业惑障山。集一切智助道之法。心恒不舍一切智地。善男子。我以如是净法光明。饶益一切众生。集善根助道法时。作十种观察法界。何者为十。所谓我知法界无量。获得广大智光明故。我知法界无边。见一切佛所知见故。我知法界无限。普入一切诸佛国土恭敬供养诸如来故。我知法界无畔。普于一切法界海中示现修行菩萨行故。我知法界无断。入于如来不断智故。我知法界一性。如来一音一切众生无不了故。我知法界性净。了如来愿普度一切诸众生故。我知法界遍众生。普贤妙行悉周遍故。我知法界一庄严。普贤妙行善庄严故。我知法界不可坏。一切智善根充满法界不可坏故。善男子。我作此十种观察法界。集诸善根办助道法。了知诸佛广大威德。深入如来难思境界。又善男子。我如是正念思惟。得如来十种大威德陀罗尼轮。何者为十。所谓普入一切法陀罗尼轮。普持一切法陀罗尼轮。普说一切法陀罗尼轮。普念十方一切佛陀罗尼轮。普说一切佛名号陀罗尼轮。普入三世诸佛愿海陀罗尼轮。普入一切诸乘海陀罗尼轮。普入一切众生业海陀罗尼轮。疾转一切业陀罗尼轮。疾生一切智陀罗尼轮。善男子。此十陀罗尼轮。以十千陀罗尼轮。而为眷属。恒为众生。演说妙法。善男子。我或为众生说闻慧法。或为众生说思慧法。或为众生说修慧法。或为众生说一有法。或为众生说一切有法。或为说一如来名海法。或为说一切如来名海法。或为说一世界海法。或为说一切世界海法。或为说一佛授记海法。或为说一切佛授记海法。或为说一如来众会道场海法。或为说一切如来众会道场海法。或为说一如来法轮海法。或为说一切如来法轮海法。或为说一如来修多罗法。或为说一切如来修多罗法。或为说一如来集会法。或为说一切如来集会法。或为说一萨婆若心海法。或为说一切萨婆若心海法。或为说一乘出离法。或为说一切乘出离法。善男子。我以如是等不可说法门。为众生说。善男子。我入如来无差别法界门海。说无上法。普摄众生。尽未来劫。住普贤行。善男子。我成就此甚深自在妙音解脱。于念念中。增长一切诸解脱门。念念充满一切法界。时善财童子。白夜神言。奇哉天神。此解脱门。如是希有。圣者证得。其已久如。夜神言。善男子。乃往古世。过世界转微尘数劫。有劫名离垢光明。有世界名法界功德云。以现一切众生业摩尼王海为体。形如莲华。住四天下微尘数香摩尼须弥山网中。以出一切如来本愿音莲华。而为庄严。须弥山微尘数莲华。而为眷属。须弥山微尘数香摩尼。以为间错。有须弥山微尘数四天下。一一四天下。有百千亿那由他不可说不可说城。善男子。彼世界中有四天下。名为妙幢。中有王都。名普宝华光。去此不远。有菩提场。名普显现法王宫殿。须弥山微尘数如来。于中出现。其最初佛。名法海雷音光明王。彼佛出时。有转轮王。名清净日光明面。于其佛所。受持一切法海旋修多罗。佛涅槃后。其王出家。护持正法。法欲灭时。有千部异千种说法。近于末劫。业惑障重。诸恶比丘。多有斗诤。乐着境界。不求功德。乐说王论贼论女论。国论海论。及以一切世间之论。时王比丘。而语之言。奇哉苦哉。佛于无量诸大劫海。集此法炬。云何汝等。而共毁灭。作是说已。上升虚空。高七多罗树。身出无量诸色焰云。放种种色大光明网。令无量众生。除烦恼热。令无量众生。发菩提心。以是因缘。彼如来教。复于六万五千岁中。而得兴盛。时有比丘尼。名法轮化光。是此王女。百千比丘尼。而为眷属。闻父王语。及见神力。发菩提心。永不退转。得三昧。名一切佛教灯。又得此甚深自在妙音解脱。得已。身心柔软。即得现见法海雷音光明王如来一切神力。善男子。于汝意云何。彼时转轮圣王。随于如来。转正法轮。佛涅槃后。兴隆末法者。岂异人乎。今普贤菩萨是。其法轮化光比丘尼。即我身是。我于彼时。守护佛法。令十万比丘尼。于阿耨多罗三藐三菩提。得不退转。又令得现见一切佛三昧。又令得一切佛法轮金刚光明陀罗尼。又令得普入一切法门海般若波罗蜜。次有佛兴。名离垢法光明。次有佛兴。名法轮光明髻。次有佛兴。名法日功德云。次有佛兴。名法海妙音王。次有佛兴。名法日智慧灯。次有佛兴。名法华幢云。次有佛兴。名法焰山幢王。次有佛兴。名甚深法功德月。次有佛兴。名法智普光藏。次有佛兴。名开示普智藏。次有佛兴。名功德藏山王。次有佛兴。名普门须弥贤。次有佛兴。名一切法精进幢。次有佛兴。名法宝华功德云。次有佛兴。名寂静光明髻。次有佛兴。名法光明慈悲月。次有佛兴。名功德焰海。次有佛兴。名智日普光明。次有佛兴。名普贤圆满智。次有佛兴。名神通智光王。次有佛兴。名福德华光灯。次有佛兴。名智师子幢王。次有佛兴。名日光普照王。次有佛兴。名须弥宝庄严相。次有佛兴。名日光普照。次有佛兴。名法王功德月。次有佛兴。名开敷莲华妙音云。次有佛兴。名日光明相。次有佛兴。名普光明妙法音。次有佛兴。名师子金刚那罗延无畏。次有佛兴。名普智勇猛幢。次有佛兴。名普开法莲华身。次有佛兴。名功德妙华海。次有佛兴。名道场功德月。次有佛兴。名法炬炽然月。次有佛兴。名普光明髻。次有佛兴。名法幢灯。次有佛兴。名金刚海幢云。次有佛兴。名名称山功德云。次有佛兴。名栴檀妙月。次有佛兴。名普妙光明华。次有佛兴。名照一切众生光明王。次有佛兴。名功德莲华藏。次有佛兴。名香焰光明王。次有佛兴。名波头摩华因。次有佛兴。名众相山普光明。次有佛兴。名普名称幢。次有佛兴。名须弥普门光。次有佛兴。名功德法城光。次有佛兴。名大树山光明。次有佛兴。名普德光明幢。次有佛兴。名功德吉祥相。次有佛兴。名勇猛法力幢。次有佛兴。名法轮光明音。次有佛兴。名功德山智慧光。次有佛兴。名无上妙法月。次有佛兴。名法莲华净光幢。次有佛兴。名宝莲华光明藏。次有佛兴。名光焰云山灯。次有佛兴。名普觉华。次有佛兴。名种种功德焰须弥藏。次有佛兴。名圆满光山王。次有佛兴。名福德云庄严。次有佛兴。名法山云幢。次有佛兴。名功德山光明。次有佛兴。名法日云灯王。次有佛兴。名法云名称王。次有佛兴。名法轮云。次有佛兴。名开悟菩提智光幢。次有佛兴。名普照法轮月。次有佛兴。名宝山威德贤。次有佛兴。名贤德广大光。次有佛兴。名普智云。次有佛兴。名法力功德山。次有佛兴。名功德香焰王。次有佛兴。名金色摩尼山妙音声。次有佛兴。名顶髻出一切法光明云。次有佛兴。名法轮炽盛光。次有佛兴。名无上功德山。次有佛兴。名精进炬光明云。次有佛兴。名三昧印广大光明冠。次有佛兴。名宝光明功德王。次有佛兴。名法炬宝盖音。次有佛兴。名普照虚空界无畏法光明。次有佛兴。名月相庄严幢。次有佛兴。名光明焰山云。次有佛兴。名照无障碍法虚空。次有佛兴。名开显智光身。次有佛兴。名世主德光明音。次有佛兴。名一切法三昧光明音。次有佛兴。名法音功德藏。次有佛兴。名炽然焰法海云。次有佛兴。名普照三世相大光明。次有佛兴。名普照法轮山。次有佛兴。名法界师子光。次有佛兴。名须弥华光明。次有佛兴。名一切三昧海师子焰。次有佛兴。名普智光明灯。善男子。如是等须弥山微尘数如来。其最后佛。名法界城智慧灯。并于离垢光明劫中。出兴于世。我皆尊重。亲近供养。听闻受持所说妙法。亦于彼一切诸如来所。出家学道护持法教。入此菩萨甚深自在妙音解脱。种种方便。教化成熟无量众生。从是已来。于佛刹微尘数劫。所有诸佛。出兴于世。我皆供养。修行其法。善男子。我从是来。于生死夜无明昏寐诸众生中。而独觉悟。令诸众生。守护心城。舍三界城。住一切智无上法城。善男子。我唯知此甚深自在妙音解脱。令诸世间。离戏论语。不作二语。常真实语。恒清净语。如诸菩萨摩诃萨。能知一切语言自性。于念念中。自在开悟一切众生。入一切众生言音海。于一切言辞。悉皆辨了。明见一切诸法门海。于普摄一切法陀罗尼。已得自在。随诸众生心之所疑。而为说法。究竟调伏一切众生。能普摄受一切众生。巧修菩萨诸无上业。深入菩萨诸微细智。能善观察诸菩萨藏。能自在说诸菩萨法。何以故。已得成就一切法轮陀罗尼故。而我云何能知能说彼功德行。善男子。此佛会中。有主夜神。名开敷一切树华。汝诣彼问。菩萨云何学一切智。云何安立一切众生。住一切智。尔时守护一切城主夜神。欲重宣此解脱义。为善财童子。而说颂言

  菩萨解脱深难见　　虚空如如平等相
  普见无边法界内　　一切三世诸如来
  出生无量胜功德　　证入难思真法性
  增长一切自在智　　开通三世解脱道
  过于刹转微尘劫　　尔时有劫名净光
  世界名为法焰云　　其城号曰宝华光
  其中诸佛兴于世　　量与须弥尘数等
  有佛名为法海音　　于此劫中先出现
  乃至其中最后佛　　名为法界焰灯王
  如是一切诸如来　　我皆供养听受法
  我见法海雷音佛　　其身普作真金色
  诸相庄严如宝山　　发心愿得成如来
  我暂见彼如来身　　即发菩提广大心
  誓愿勤求一切智　　性与法界虚空等
  由斯普见三世佛　　及以一切菩萨众
  亦见国王众生海　　而普攀缘起大悲
  随诸众生心所乐　　示现种种无量身
  普遍十方诸国土　　动地舒光悟含识
  见第二佛而亲近　　亦见十方刹海佛
  乃至最后佛出兴　　如是须弥尘数等
  于诸刹转微尘劫　　所有如来照世灯
  我皆亲近而瞻奉　　令此解脱得清净

尔时善财童子。得入此菩萨甚深自在妙音解脱故。入无边三昧海。入广大总持海。得菩萨大神通。获菩萨大辩才。心大欢喜。观察守护一切城主夜神。以偈赞曰

  已行广大妙慧海　　已度无边诸有海
  长寿无患智藏身　　威德光明住此众
  了达法性如虚空　　普入三世皆无碍
  念念攀缘一切境　　心心永断诸分别
  了达众生无有性　　而于众生起大悲
  深入如来解脱门　　广度群迷无量众
  观察思惟一切法　　了知证入诸法性
  如是修行佛智慧　　普化众生令解脱
  天是众生调御师　　开示如来智慧道
  普为法界诸含识　　说离世间众怖行
  已住如来诸愿道　　已受菩提广大教
  已修一切遍行力　　已见十方佛自在
  天神心净如虚空　　普离一切诸烦恼
  了知三世无量刹　　诸佛菩萨及众生
  天神一念悉了知　　昼夜日月年劫海
  亦知一切众生类　　种种名相各差别
  十方众生生死处　　有色无色想无想
  随顺世俗悉了知　　引导使入菩提路
  已生如来誓愿家　　已入诸佛功德海
  法身清净心无碍　　随众生乐现众色

时善财童子。说此颂已。礼夜神足。绕无量匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第七十一大方广佛华严经卷第七十二

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十三

尔时善财童子。入菩萨甚深自在妙音解脱门修行增进。往诣开敷一切树华夜神所。见其身在众宝香树楼阁之内妙宝所成师子座上。百万夜神。所共围绕。时善财童子。顶礼其足。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何得一切智。唯愿垂慈。为我宣说。夜神言。善男子。我于此娑婆世界。日光已没。莲华覆合。诸人众等。罢游观时。见其一切若山若水。若城若野。如是等处。种种众生。咸悉发心。欲还所住。我皆密护。令得正道。达其处所。宿夜安乐。善男子。若有众生。盛年好色。憍慢放逸。五欲自恣。我为示现老病死相。令生恐怖。舍离诸恶。复为称叹种种善根。使其修习。为悭吝者赞叹布施。为破戒者称扬净戒。有嗔恚者教住大慈。怀恼害者令行忍辱。若懈怠者令起精进。若散乱者令修禅定。住恶慧者令学般若。乐小乘者令住大乘。乐着三界诸趣中者。令住菩萨愿波罗蜜。若有众生。福智微劣。为诸结业之所逼迫多留碍者。令住菩萨力波罗蜜。若有众生。其心闇昧。无有智慧。令住菩萨智波罗蜜。善男子。我已成就菩萨出生广大喜光明解脱门。善财言。大圣。此解脱门境界云何。夜神言。善男子。入此解脱。能知如来普摄众生巧方便智。云何普摄。善男子。一切众生。所受诸乐。皆是如来威德力故。顺如来教故。行如来语故。学如来行故。得如来所护力故。修如来所印道故。种如来所行善故。依如来所说法故。如来智慧日光之所照故。如来性净业力之所摄故。云何知然善男子。我入此出生广大喜光明解脱。忆念毗卢遮那如来应正等觉往昔所修菩萨行海。悉皆明见善男子。世尊往昔。为菩萨时。见一切众生。着我我所。住无明闇室。入诸见稠林。为贪爱所缚。忿怒所坏。愚痴所乱。悭嫉所缠。生死轮回。贫穷困苦。不得值遇诸佛菩萨。见如是已。起大悲心。利益众生。所谓起愿得一切妙宝资具。摄众生心。愿一切众生。皆悉具足资生之物无所乏心。于一切众事离执着心。于一切境界无贪染心。于一切所有无悭吝心。于一切果报无希望心。于一切荣好无羡慕心。于一切因缘无迷惑心。起观察真实法性心。起救护一切众生心。起深入一切法漩澓心。起于一切众生住平等大慈心。起于一切众生行方便大悲心。起为大法盖普覆众生心。起以大智金刚杵破一切众生烦恼障山心。起令一切众生。增长喜乐心。起愿一切众生究竟安乐心。起随众生所欲雨一切财宝心。起以平等方便成熟一切众生心。起令一切众生满足圣财心。起愿一切众生究竟皆得十力智果心。起如是心已。得菩萨力。现大神变。遍法界虚空界。于一切众生前。普雨一切资生之物。随其所欲。悉满其意。皆令欢喜。不悔不吝。无间无断。以是方便。普摄众生。教化成熟。皆令得出生死苦难。不求其报。净治一切众生心宝。令其生起一切诸佛同一善根。增一切智福德大海。菩萨如是。念念成熟一切众生。念念严净一切佛刹。念念普入一切法界。念念悉皆遍虚空界。念念普入一切三世。念念成就调伏一切诸众生智。念念恒转一切法轮。念念恒以一切智道利益众生。念念普于一切世界种种差别诸众生前。尽未来劫。现一切佛成等正觉。念念普于一切世界一切诸劫。修菩萨行。不生二想。所谓普入一切广大世界海一切世界种中。种种际畔诸世界。种种庄严诸世界。种种体性诸世界。种种形状诸世界。种种分布诸世界。或有世界秽而兼净。或有世界净而兼秽。或有世界一向杂秽。或有世界一向清净。或小或大。或粗或细。或正或侧。或覆或仰。如是一切诸世界中念念修行诸菩萨行。入菩萨位。现菩萨力。亦现三世一切佛身。随众生心。普使知见。善男子。毗卢遮那如来。于过去世。如是修行菩萨行时。见诸众生。不修功德。无有智慧。着我我所无明翳障。不正思惟。入诸邪见。不识因果。顺烦恼业。堕于生死险难深坑。具受种种无量诸苦。起大悲心。具修一切波罗蜜行。为诸众生。称扬赞叹坚固善根。令其安住远离生死贫穷之苦。勤修福智助道之法。为说种种诸因果门。为说业报不相违反。为说于法证入之处。为说一切众生欲解。及说一切受生国土。令其不断一切佛种。令其守护一切佛教。令其舍离一切诸恶。又为称赞趣一切智助道之法。令诸众生。心生欢喜。令行法施。普摄一切。令其发起一切智行。令其修学诸大菩萨波罗蜜道。令其增长成一切智诸善根海。令其满足一切圣财。令其得入佛自在门。令其摄取无量方便。令其观见如来威德。令其安住菩萨智慧。善财童子言。圣者。发阿耨多罗三藐三菩提心。其已久如。夜神言。善男子。此处难信。难知难解。难入难说。一切世间。及以二乘。皆不能知。唯除诸佛神力所护。善友所摄。集胜功德。欲乐清净。无下劣心。无杂染心。无谄曲心。得普照耀智光明心。发普饶益诸众生心。一切烦恼。及以众魔。无能坏心。起必成就一切智心。不乐一切生死乐心。能求一切诸佛妙乐。能灭一切众生苦恼。能修一切佛功德海。能观一切诸法实性。能具一切清净信解。能超一切生死暴流。能入一切如来智海。能决定到无上法城。能勇猛入如来境界。能速疾趣诸佛地位。能即成就一切智力。能于十力。已得究竟。如是之人。于此能持。能入能了。何以故。此是如来智慧境界。一切菩萨。尚不能知。况余众生。然我今者。以佛威力。欲令调顺可化众生意速清净。欲令修习善根众生。心得自在。随汝所问。为汝宣说。尔时开敷一切树华夜神。欲重明其义。观察三世如来境界。而说颂言

  佛子汝所问　　甚深佛境界
  难思刹尘劫　　说之不可尽
  非是贪恚痴　　憍慢惑所覆
  如是众生等　　能知佛妙法
  非是住悭嫉　　谄诳诸浊意
  烦恼业所覆　　能知佛境界
  非着蕴界处　　及计于有身
  见倒想倒人　　能知佛所觉
  佛境界寂静　　性净离分别
  非着诸有者　　能知此法性
  生于诸佛家　　为佛所守护
  持佛法藏者　　智眼之境界
  亲近善知识　　爱乐白净法
  勤求诸佛力　　闻此法欢喜
  心净无分别　　犹如大虚空
  慧灯破诸闇　　是彼之境界
  以大慈悲意　　普覆诸世间
  一切皆平等　　是彼之境界
  欢喜心无著　　一切皆能舍
  平等施众生　　是彼之境界
  心净离诸恶　　究竟无所悔
  顺行诸佛教　　是彼之境界
  了知法自性　　及以诸业种
  其心无动乱　　是彼之境界
  勇猛勤精进　　安住心不退
  勤修一切智　　是彼之境界
  其心寂静住三昧　　究竟清凉无热恼
  已修一切智海因　　此证悟者之解脱
  善知一切真实相　　深入无边法界门
  普度群生靡有余　　此慧灯者之解脱
  了达众生真实性　　不着一切诸有海
  如影普现心水中　　此正道者之解脱
  从于一切三世佛　　方便愿种而出生
  尽诸劫刹勤修行　　此普贤者之解脱
  普入一切法界门　　悉见十方诸刹海
  亦见其中劫成坏　　而心毕竟无分别
  法界所有微尘中　　悉见如来坐道树
  成就菩提化群品　　此无碍眼之解脱
  汝于无量大劫海　　亲近供养善知识
  为利群生求正法　　闻已忆念无遗忘
  毗卢遮那广大境　　无量无边不可思
  我承佛力为汝说　　令汝深心转清净

善男子。乃往古世。过世界海微尘数劫。有世界海。名普光明真金摩尼山。其世界海中。有佛出现。名普照法界智慧山寂静威德王。善男子。其佛往修菩萨行时。净彼世界海。其世界海中。有世界微尘数世界种。一一世界种。有世界微尘数世界。一一世界。皆有如来出兴于世。一一如来。说世界海微尘数修多罗。一一修多罗。授佛刹微尘数诸菩萨记。现种种神力。说种种法门。度无量众生。善男子。彼普光明真金摩尼山世界海中。有世界种。名普庄严幢。此世界种中。有世界名一切宝色普光明。以现一切化佛影摩尼王为体。形如天城。以现一切如来道场影像摩尼王。为其下际。住一切宝华海上。净秽相杂。此世界中。有须弥山微尘数四天下。有一四天下。最处其中。名一切宝山幢。其四天下。一一纵广十万由旬。一一各有一万大城。其阎浮提中。有一王都。名坚固妙宝庄严云灯。一万大城。周匝围绕。阎浮提人寿万岁时。其中有王。名一切法音圆满盖。有五百大臣。六万采女。七百王子。其诸王子。皆端正勇健。有大威力。尔时彼王。威德普被阎浮提内。无有怨敌。时彼世界。劫欲尽时。有五浊起。一切人众。寿命短促。资财乏少。形色鄙陋。多苦少乐。不修十善。专作恶业。更相忿诤。互相毁辱。离他眷属。妒他荣好。任情起见。非法贪求。以是因缘。风雨不时。苗稼不登。园林草树。一切枯槁。人民匮乏。多诸疫病。驰走四方。靡所依怙。咸来共绕王都大城。无量无边百千万亿。四面周匝。高声大呼。或举其手。或合其掌。或以头扣地。或以手捶胸。或屈膝长号。或踊身大叫。头发蓬乱。衣裳弊恶。皮肤皴裂。面目无光。而向王言。大王大王。我等今者。贫穷孤露。饥渴寒冻。疾病衰羸。众苦所逼。命将不久。无依无救。无所控告。我等今者。来归大王。我观大王。仁慈智慧。于大王所。生得安乐想。得所爱想。得活命想。得摄受想。得宝藏想。遇津梁想。逢道路想。值船筏想。见宝洲想。获财利想。升天宫想。尔时大王。闻此语已。得百万阿僧祇大悲门。一心思惟。发十种大悲语。其十者何。所谓哀哉众生。堕于无底生死大坑。我当云何而速勉济。令其得住一切智地。哀哉众生。为诸烦恼之所逼迫。我当云何而作救护。令其安住一切善业。哀哉众生。生老病死之所恐怖。我当云何为作归依。令其永得身心安隐。哀哉众生。常为世间众怖所逼。我当云何而为祐助。令其得住一切智道。哀哉众生。无有智眼。常为身见疑惑所覆。我当云何为作方便。令其得决。疑见翳膜。哀哉众生。常为痴闇之所迷惑。我当云何为作明炬。令其照见一切智城。哀哉众生。常为悭嫉谄诳所浊。我当云何而为开晓。令其证得清净法身。哀哉众生。长时漂没生死大海。我当云何而普运度。令其得上菩提彼岸。哀哉众生。诸根刚强。难可调伏。我当云何而为调御。令其具足诸佛神力。哀哉众生。犹如盲瞽不见道路。我当云何而为引导。令其得入一切智门。作是语已。击鼓宣令。我今普施一切众生。随有所须悉令充足。即时颁下阎浮提内大小诸城。及诸聚落。悉开库藏。出种种物。置四衢道。所谓金银琉璃。摩尼等宝。衣服饮食。华香璎珞。宫殿屋宅。床榻敷具。建大光明。摩尼宝幢。其光触身。悉使安隐。亦施一切病缘汤药。种种宝器。盛众杂宝。金刚器中。盛种种香。宝香器中。盛种种衣。辇舆车乘。幢幡缯盖。如是一切资生之物。悉开库藏。而以给施。亦施一切村营城邑。山泽林薮。妻子眷属。及以王位。头目耳鼻。唇舌牙齿。手足皮肉。心肾肝肺。内外所有。悉皆能舍。其坚固妙宝。庄严云灯城。东面有门。名摩尼山光明。于其门外。有施会处。其地广博。清净平坦。无诸坑坎。荆棘沙砾。一切皆以妙宝所成。散众宝华。熏诸妙香。然诸宝灯。一切香云。充满虚空。无量宝树。次第行列。无量华网。无量香网。弥覆其上。无量百千亿那由他诸音乐器。恒出妙音。如是一切。皆以妙宝而为庄严。悉是菩萨净业果报。于彼会中。置师子座。十宝为地。十宝栏楯。十种宝树。周匝围绕。金刚宝轮。以承其下。以一切宝。为龙神像。而共捧持。种种宝物。以为严饰。幢幡间列。众网覆上。无量宝香常出香云。种种宝衣处处分布。百千种乐恒奏美音。复于其上张施宝盖。常放无量宝焰光明。如阎浮金炽然清净。覆以宝网。垂诸璎珞摩尼宝带。周回间列。种种宝铃。恒出妙音。劝诸众生。修行善业。时彼大王。处师子座。形容端正。人相具足。光明妙宝。以为其冠。那罗延身。不可沮坏。一一肢分。悉皆圆满。性普贤善。王种中生。于财及法。悉得自在。辩才无碍。智慧明达。以政治国。无违命者。尔时阎浮提无量无数百千万亿那由他众生。种种国土。种种族类。种种形貌。种种衣服。种种言辞。种种欲乐。俱来此会。观察彼王。咸言此王是大智人。是福须弥。是功德月。住菩萨愿。行广大施。时王见彼诸来乞者。生悲愍心。生欢喜心。生尊重心。生善友心。生广大心。生相续心。生精进心。生不退心。生舍施心。生周遍心。善男子尔时彼王。见诸乞者。心大欢喜。经须臾顷。假使忉利天王。夜摩天王。兜率陀天王。尽百千亿那由他劫。所受快乐亦不能及。善化天王。于无数劫。所受快乐。自在天王。于无量劫。所受快乐。大梵天王。于无边劫。所受梵乐。光音天王。于难思劫。所受天乐。遍净天王。于无尽劫。所受天乐。净居天王。不可说劫。住寂静乐。悉不能及。善男子。譬如有人仁慈孝友。遭逢世难。父母妻息。兄弟姊妹。并皆散失。忽于旷野道路之间。而相值遇。瞻奉抚对。情无厌足。时彼大王。见来求者。心生欢喜。亦复如是。善男子。其王尔时。因善知识。于佛菩提。解欲增长。诸根成就。信心清净。欢喜圆满。何以故。此菩萨勤修诸行。求一切智。愿得利益一切众生。愿获菩提无量妙乐。舍离一切诸不善心。常乐积集一切善根。常愿救护一切众生。常乐观察萨婆若道。常乐修行一切智法。满足一切众生所愿。入一切佛功德大海。破一切魔业惑障山。随顺一切如来教行。行一切智无障碍道。已能深入一切智流。一切法流。常现在前。大愿无尽。为大丈夫。住大人法。积集一切普门善藏。离一切着。不染一切世间境界。知诸法性。犹如虚空。于来乞者。生一子想。生父母想。生福田想。生难得想。生恩益想。生坚固想。师想佛想。不拣方处。不择族类。不选形貌。随有来至。如其所欲。以大慈心。平等无碍一切普施皆令满足。求饮食者。施与饮食。求衣服者施与衣服。求香华者施与香华。求鬘盖者施与鬘盖。幢幡璎珞。宫殿园苑。象马车乘。床座被褥。金银摩尼。诸珍宝物。一切库藏。及诸眷属。城邑聚落。皆悉如是。普施众生。时此会中。有长者女。名宝光明。与六十童女俱端正姝妙。人所喜见。皮肤金色。目发绀青。身出妙香口演梵音。上妙宝衣以为庄严。常怀惭愧正念不乱。具足威仪恭敬师长。常念顺行甚深妙行。所闻之法忆持不忘。宿世善根流润其心。清净广大犹如虚空等安众生。常见诸佛求一切智。时宝光明女。去王不远。合掌顶礼。作如是念。我获善利我获善利。我今得见大善知识。于彼王所。生大师想。善知识想。具慈悲想。能摄受想。其心正直。生大欢喜。脱身璎珞。持奉彼王。作是愿言。今此大王。为无量无边无明众生。作所依处。愿我未来亦复如是。如彼大王所知之法。所载之乘。所修之道。所具色相。所有财产。所摄众会。无边无尽。难胜难坏。愿我未来悉得如是。随所生处。皆随往生。尔时大王。知此童女。发如是心。而告之言。童女随汝所欲。我皆与汝。我今所有。一切皆舍。令诸众生。普得满足。时宝光明女。信心清净。生大欢喜。即以偈颂。而赞王言

  往昔此城邑　　大王未出时
  一切不可乐　　犹如饿鬼处
  众生相杀害　　窃盗纵淫佚
  两舌不实语　　无义粗恶言
  贪爱他财物　　嗔恚怀毒心
  邪见不善行　　命终堕恶道
  以是等众生　　愚痴所覆蔽
  住于颠倒见　　天旱不降泽
  以无时雨故　　百谷悉不生
  草本皆枯槁　　泉流亦干竭
  大王未兴世　　津池悉枯涸
  园苑多骸骨　　望之如旷野
  大王升宝位　　广济诸群生
  油云被八方　　普雨皆充洽
  大王临庶品　　普断诸暴虐
  刑狱皆止措　　茕独悉安隐
  往昔诸众生　　各各相残害
  饮血而啖肉　　今悉起慈心
  往昔诸众生　　贫穷少衣服
  以草自遮蔽　　饥羸如饿鬼
  大王既兴世　　粳米自然生
  树中出妙衣　　男女皆严饰
  昔日竞微利　　非法相陵夺
  今时并丰足　　如游帝释园
  昔时人作恶　　非分生贪染
  他妻及童女　　种种相侵逼
  今见他妇人　　端正妙严饰
  而心无染着　　犹如知足天
  昔日诸众生　　妄言不真实
  非法无利益　　谄曲取人意
  今日群生类　　悉离诸恶言
  其心既柔软　　发语亦调顺
  昔日诸众生　　种种行邪法
  合掌恭敬礼　　牛羊犬豚类
  今闻王正法　　悟解除邪见
  了知苦乐报　　悉从因缘起
  大王演妙音　　闻者皆欣乐
  梵释音声等　　一切无能及
  大王众宝盖　　迥处虚空中
  擎以琉璃干　　覆以摩尼网
  金铃自然出　　如来和雅音
  宣扬微妙法　　除灭众生惑
  次复广演说　　十方诸佛刹
  一切诸劫中　　如来并眷属
  又复次第说　　过去十方刹
  及彼国土中　　一切诸如来
  又出微妙音　　普遍阎浮界
  广说人天等　　种种业差别
  众生听闻已　　自知诸业藏
  离恶勤修行　　回向佛菩提
  王父净光明　　王母莲华光
  五浊出现时　　处位治天下
  时有广大园　　园有五百池
  一一千树绕　　各各华弥覆
  于其池岸上　　建立千柱堂
  栏楯等庄严　　一切无不备
  末世恶法起　　积年不降雨
  池流悉干竭　　草树皆枯槁
  王生七日前　　先现灵瑞相
  见者咸心念　　救世今当出
  尔时于中夜　　大地六种动
  有一宝华池　　光明犹日现
  五百诸池内　　功德水充满
  枯树悉生枝　　华叶皆荣茂
  池水既盈满　　流演一切处
  普及阎浮地　　靡不皆沾洽
  药草及诸树　　百谷苗稼等
  枝叶华果实　　一切皆繁盛
  沟坑及堆阜　　种种高下处
  如是一切地　　莫不皆平坦
  荆棘沙砾等　　所有诸杂秽
  皆于一念中　　变成众宝玉
  众生见是已　　欢喜而赞叹
  咸言得善利　　如渴饮美水
  时彼光明王　　眷属无量众
  佥然备法驾　　游观诸园苑
  五百诸池内　　有池名庆喜
  池上有法堂　　父王于此住
  先王语夫人　　我念七夜前
  中宵地震动　　此中有光现
  时彼华池内　　千叶莲华出
  光如千日照　　上彻须弥顶
  金刚以为茎　　阎浮金为台
  众宝为华叶　　妙香作须蕊
  王生彼华上　　端身结跏坐
  相好以庄严　　天神所恭敬
  先王大欢喜　　入池自抚掬
  持以授夫人　　汝子应欣庆
  宝藏皆涌出　　宝树生妙衣
  天乐奏美声　　充满虚空中
  一切诸众生　　皆生大欢喜
  合掌称希有　　善哉救护世
  王时放身光　　普照于一切
  能令四天下　　闇尽病除灭
  夜叉毗舍阇　　毒虫诸恶兽
  所欲害人者　　一切自藏匿
  恶名失善利　　横事病所持
  如是众苦灭　　一切皆欢喜
  凡是众生类　　相视如父母
  离恶起慈心　　专求一切智
  关闭诸恶趣　　开示人天路
  宣扬萨婆若　　度脱诸群生
  我等见大王　　普获于善利
  无归无导者　　一切悉安乐

尔时宝光明童女。以偈赞叹一切法音圆满盖王已。绕无量匝。合掌顶礼。曲躬恭敬。却住一面。时彼大王。告童女言。善哉童女。汝能信知他人功德。是为希有。童女。一切众生。不能信知他人功德。童女。一切众生。不知报恩。无有智慧。其心浊乱。性不明了。本无志力。又退修行。如是之人。不信不知菩萨如来所有功德神通智慧。童女。汝今决定求趣菩提。能知菩萨如是功德。汝今生此阎浮提中。发勇猛心。普摄众生。功不唐捐。亦当成就如是功德。王赞女已。以无价宝衣。手自授与宝光童女并其眷属一一告言。汝着此衣。时诸童女。双膝着地。两手承捧。置于顶上。然后而着。既着衣已。右绕于王。诸宝衣中。普出一切星宿光明。众人见之。咸作是言。此诸女等皆悉端正。如净夜天星宿庄严。善男子。尔时一切法音圆满盖王者。岂异人乎。今毗卢遮那如来应正等觉是也。光明王者。净饭王是。莲华光夫人者。摩耶夫人是。宝光童女者。即我身是。其王尔时。以四摄法。所摄众生。即此会中一切菩萨是。皆于阿耨多罗三藐三菩提。得不退转。或住初地乃至十地。具种种大愿。集种种助道。修种种妙行。备种种庄严。得种种神通。住种种解脱。于此会中。处于种种妙法宫殿。尔时开敷一切树华主夜神。为善财童子。欲重宣此解脱义。而说颂言

  我有广大眼　　普见于十方
  一切刹海中　　五趣轮回者
  亦见彼诸佛　　菩提树下坐
  神通遍十方　　说法度众生
  我有清净耳　　普闻一切声
  亦闻佛说法　　欢喜而信受
  我有他心智　　无二无所碍
  能于一念中　　悉了诸心海
  我得宿命智　　能知一切劫
  自身及他人　　分别悉明了
  我于一念知　　刹海微尘劫
  诸佛及菩萨　　五道众生类
  忆知彼诸佛　　始发菩提愿
  乃至修诸行　　一一悉圆满
  亦知彼诸佛　　成就菩提道
  以种种方便　　为众转法轮
  亦知彼诸佛　　所有诸乘海
  正法住久近　　众生度多少
  我于无量劫　　修习此法门
  我今为汝说　　佛子汝应学

善男子。我唯知此菩萨出生广大喜光明解脱门。如诸菩萨摩诃萨。亲近供养一切诸佛。入一切智大愿海。满一切佛诸愿海。得勇猛智。于一菩萨地。普入一切菩萨地海。得清净愿。于一菩萨行。普入一切菩萨行海。得自在力。于一菩萨解脱门。普入一切菩萨解脱门海。而我云何能知能说彼功德行。善男子。此道场中。有一夜神。名大愿精进力救护一切众生。汝诣彼问。菩萨云何教化众生。令趣阿耨多罗三藐三菩提。云何严净一切佛刹。云何承事一切如来。云何修行一切佛法。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第七十二大方广佛华严经卷第七十三

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十四

尔时善财童子。往大愿精进力救护一切众生夜神所。见彼夜神在大众中。坐普现一切宫殿摩尼王藏师子之座。普现法界国土摩尼宝网。弥覆其上。现日月星宿影像身。现随众生心普令得见身。现等一切众生形相身。现无边广大色相海身。现普现一切威仪身。现普于十方示现身。现普调一切众生身。现广运速疾神通身。现利益众生不绝身。现常游虚空利益身。现一切佛所顶礼身。现修习一切善根身。现受持佛法不忘身。现成满菩萨大愿身。现光明充满十方身。现法灯普灭世暗身。现了法如幻净智身。现远离尘暗法性身。现普智照法明了身。现究竟无患无热身。现不可沮坏坚固身。现无所住佛力身。现无分别离染身。现本清净法性身。时善财童子。见如是等佛刹微尘数差别身。一心顶礼。举体投地。良久乃起。合掌瞻仰。于善知识。生十种心。何等为十。所谓于善知识生同己心。令我精勤办一切智助道法故。于善知识生清净自业果心。亲近供养生善根故。于善知识生庄严菩萨行心。令我速能庄严一切菩萨行故。于善知识生成就一切佛法心。诱诲于我令修道故。于善知识生能生心。能生于我无上法故。于善知识生出离心。令我修行普贤菩萨所有行愿而出离故。于善知识生具一切福智海心。令我积集诸白法故。于善知识生增长心。令我增长一切智故。于善知识生具一切善根心。令我志愿得圆满故。于善知识生能成办大利益心。令我自在安住一切菩萨法故。成一切智道故。得一切佛法故。是为十。发是心已。得彼夜神与诸菩萨佛刹微尘数同行。所谓同念。心常忆念十方三世一切佛故。同慧。分别决了一切法海差别门故。同趣。能转一切诸佛如来妙法轮故。同觉。以等空智普入一切三世间故。同根。成就菩萨清净光明智慧根故。同心。善能修习无碍功德。庄严一切菩萨道故。同境。普照诸佛所行境故。同证。得一切智照实相海净光明故。同义。能以智慧了一切法真实性故。同勇猛。能坏一切障碍山故。同色身。随众生心示现身故。同力。求一切智不退转故。同无畏。其心清净如虚空故。同精进。于无量劫行菩萨行无懈倦故。同辩才。得法无碍智光明故。同无等。身相清净超世间故。同爱语。令一切众生皆欢喜故。同妙音。普演一切法门海故。同满音。一切众生随类解故。同净德。修习如来净功德故。同智地。一切佛所受法轮故。同梵行。安住一切佛境界故。同大慈。念念普覆一切国土众生海故。同大悲。普雨法雨润泽一切诸众生故。同身业。以方便行教化一切诸众生故。同语业。以随类音演说一切诸法门故。同意业。普摄众生置一切智境界中故。同庄严。严净一切诸佛刹故。同亲近。有佛出世皆亲近故。同劝请。请一切佛转法轮故。同供养。常乐供养一切佛故。同教化。调伏一切诸众生故。同光明。照了一切诸法门故。同三昧。普知一切众生心故。同充遍。以自在力充满一切诸佛刹海修诸行故。同住处。住诸菩萨大神通故。同眷属。一切菩萨共止住故。同入处。普入世界微细处故。同心虑。普知一切诸佛刹故。同往诣。普入一切佛刹海故。同方便。悉现一切诸佛刹故。同超胜。于诸佛刹皆无比故。同不退。普入十方无障碍故。同破闇。得一切佛成菩提智大光明故。同无生忍。入一切佛众会海故。同遍一切诸佛刹网。恭敬供养不可说刹诸如来故。同智证。了知彼彼法门海故。同修行。顺行一切诸法门故。同希求。于清净法深乐欲故。同清净。集佛功德而以庄严身口意故。同妙意。于一切法智明了故。同精进。普集一切诸善根故。同净行。成满一切菩萨行故。同无碍。了一切法皆无相故。同善巧。于诸法中智自在故。同随乐。随众生心现境界故。同方便。善习一切所应习故。同护念。得一切佛所护念故。同入地。得入一切菩萨地故。同所住。安住一切菩萨位故。同记别。一切诸佛授其记故。同三昧。一刹那中普入一切三昧门故。同建立。示现种种诸佛事故。同正念。正念一切境界门故。同修行。尽未来劫修行一切菩萨行故。同净信。于诸如来无量智慧极欣乐故。同舍离。灭除一切诸障碍故。同不退智。与诸如来智慧等故。同受生。应现成熟诸众生故。同所住。住一切智方便门故。同境界。于法界境得自在故。同无依。永断一切所依心故。同说法。已入诸法平等智故。同勤修。常蒙诸佛所护念故。同神通。开悟众生令修一切菩萨行故。同神力。能入十方世界海故。同陀罗尼。普照一切总持海故。同秘密法。了知一切修多罗中妙法门故。同甚深法。解一切法如虚空故。同光明。普照一切诸世界故。同欣乐。随众生心而为开示令欢喜故。同震动。为诸众生现神通力普动十方一切刹故。同不虚。见闻忆念皆悉令其心调伏故。同出离。满足一切诸大愿海。成就如来十力智故。时善财童子。观察大愿精进力救护一切众生夜神。起十种清净心。获如是等佛刹微尘数同菩萨行。既获此已。心转清净。偏袒右肩。顶礼其足。一心合掌。以偈赞曰

  我发坚固意　　志求无上觉
  今于善知识　　而起自己心
  以见善知识　　集无尽白法
  灭除众罪垢　　成就菩提果
  我见善知识　　功德庄严心
  尽未来刹劫　　勤修所行道
  我念善知识　　摄受饶益我
  为我悉示现　　正教真实法
  关闭诸恶趣　　显示人天路
  亦示诸如来　　成一切智道
  我念善知识　　是佛功德藏
  念念能出生　　虚空功德海
  与我波罗蜜　　增我难思福
  长我净功德　　令我冠佛缯
  我念善知识　　能满佛智道
  誓愿常依止　　圆满白净法
  我以此等故　　功德悉具足
  普为诸众生　　说一切智道
  圣者为我师　　与我无上法
  无量无数劫　　不能报其恩

尔时善财。说此偈已。白言大圣。愿为我说此解脱门。名为何等。发心已来。为几时耶。久如当得阿耨多罗三藐三菩提。夜神告言。善男子。此解脱门。名教化众生令生善根。我以成就此解脱故。悟一切法自性平等。入于诸法真实之性。证无依法。舍离世间。悉知诸法色相差别。亦能了达青黄赤白性皆不实。无有差别。而恒示现无量色身。所谓种种色身。非一色身。无边色身。清净色身。一切庄严色身。普见色身。等一切众生色身。普现一切众生前色身。光明普照色身。见无厌足色身。相好清净色身。离众恶光明色身。示现大勇猛色身。甚难得色身。一切世间无能映蔽色身。一切世间共称叹无尽色身。念念常观察色身。示现种种云色身。种种形显色色身。现无量自在力色身。妙光明色身。一切净妙庄严色身。随顺成熟一切众生色身。随其心乐现前调伏色身。无障碍普光明色身。清净无浊秽色身。具足庄严不可坏色身。不思议法方便光明色身。无能夺。夺一切色身。无诸闇破一切闇色身。集一切白净法色身。大势力功德海色身。从过去恭敬因所生色身。如虚空清净心所生色身。最胜广大色身。无断无尽色身。光明海色身。于一切世间无所依平等色身。遍十方无所碍色身。念念现种种色相海色身。增长一切众生欢喜心色身。摄取一切众生海色身。一一毛孔中说一切佛功德海色身。净一切众生欲解海色身。决了一切法义色身。无障碍普照耀色身。等虚空净光明色身。放广大净光明色身。照现无垢法色身。无比色身。差别庄严色身。普照十方色身。随时示现应众生色身。寂静色身。灭一切烦恼色身。一切众生福田色身。一切众生见不虚色身。大智慧勇猛力色身。无障碍普周遍色身。妙身云普现世间皆蒙益色身。具足大慈海色身。大福德宝山王色身。放光明普照世间一切趣色身。大智慧清净色身。生众生正念心色身。一切宝光明色身。普光藏色身。现世间种种清净相色身。求一切智处色身。现微笑令众生生净信色身。一切宝庄严光明色身。不取不舍一切众生色身。无决定无究竟色身。现自在加持力色身。现一切神通变化色身。生如来家色身。远离众恶遍法界海色身。普现一切如来道场众会色身。具种种众色海色身。从善行所流色身。随所应化示现色身。一切世间见无厌足色身。种种净光明色身。现一切三世海色身。放一切光明海色身。现无量差别光明海色身。超诸世间一切香光明色身。现不可说日轮云色身。现广大月轮云色身。放无量须弥山妙华云色身。出种种鬘云色身。现一切宝莲华云色身。兴一切烧香云遍法界色身。散一切末香藏云色身。现一切如来大愿身色身。现一切语言音声演法海色身。现普贤菩萨像色身。念念中现如是等色相身。充满十方。令诸众生。或见或念。或闻说法。或因亲近。或得开悟。或见神通。或睹变化。悉随心乐。应时调伏。舍不善业。住于善行。善男子。当知此由大愿力故。一切智力故。菩萨解脱力故。大悲力故。大慈力故。作如是事。善男子。我入此解脱。了知法性。无有差别。而能示现无量色身。一一身。现无量色相海。一一相。放无量光明云。一一光。现无量佛国土。一一土。现无量佛兴世。一一佛。现无量神通力。开发众生宿世善根。未种者令种。已种者令增长。已增长者令成熟。念念中。令无量众生。于阿耨多罗三藐三菩提。得不退转。善男子。如汝所问。从几时来。发菩提心。修菩萨行。如是之义。承佛神力。当为汝说。善男子。菩萨智轮。远离一切分别境界。不可以生死中。长短染净。广狭多少。如是诸劫。分别显示。何以故。菩萨智轮。本性清净。离一切分别网。超一切障碍山。随所应化而普照故。善男子。譬如日轮无有昼夜。但出时名昼没时名夜。菩萨智轮亦复如是。无有分别。亦无三世。但随心现。教化众生。言其止住前劫后劫。善男子。譬如日轮住阎浮空。其影悉现一切宝物及以河海诸净水中。一切众生。莫不目见。而彼净日。不来至此。菩萨智轮。亦复如是。出诸有海。住佛实法寂静空中。无有所依。为欲化度诸众生故。而于诸趣随类受生。实不生死。无所染着。无长短劫诸想分别。何以故。菩萨究竟。离心想见一切颠倒。得真实见。见法实性。知一切世间。如梦如幻。无有众生。但以大悲大愿力故。现众生前。教化调伏。佛子。譬如船师常以大船。于河流中。不依此岸。不着彼岸。不住中流。而度众生。无有休息。菩萨摩诃萨。亦复如是。以波罗蜜船。于生死流中。不依此岸。不着彼岸。不住中流。而度众生。无有休息。虽无量劫修菩萨行。未曾分别劫数长短。佛子。如大虚空。一切世界于中成坏。而无分别。本性清净。无染无乱。无碍无厌。非长非短。尽未来劫。持一切刹。菩萨摩诃萨。亦复如是。以等虚空界。广大深心。起大愿风轮。摄诸众生。令离恶道。生诸善趣。悉令安住一切智地。灭诸烦恼生死苦缚。而无忧喜疲厌之心。善男子。如幻化人。肢体虽具。而无入息及以出息。寒热饥渴忧喜生死十种之事。菩萨摩诃萨。亦复如是。以如幻智平等法身。现众色相。于诸有趣。住无量劫。教化众生。于生死中一切境界。无欣无厌。无爱无恚。无苦无乐。无取无舍。无安无怖。佛子。菩萨智慧。虽复如是甚深难测。我当承佛威神之力。为汝解说。令未来世诸菩萨等。满足大愿。成就诸力。佛子。乃往古世。过世界海微尘数劫。有劫名善光。世界名宝光。于其劫中。有一万佛。出兴于世。其最初佛。号法轮音虚空灯王如来应正等觉。十号圆满。彼阎浮提。有一王都名宝庄严。其东不远。有一大林名曰妙光。中有道场名为宝华。彼道场中。有普光明摩尼莲华藏师子之座。时彼如来于此座上。成阿耨多罗三藐三菩提。满一百年坐于道场。为诸菩萨诸天世人。及阎浮提宿植善根已成熟者。演说正法。是时国王名曰胜光。时世人民寿一万岁。其中多有杀盗淫佚。妄语绮语。两舌恶口。贪嗔邪见。不孝父母。不敬沙门。婆罗门等。时王为欲调伏彼故。造立囹圄。枷锁禁闭。无量众生于中受苦。王有太子名为善伏。端正殊特。人所喜见。具二十八大人之相。在宫殿中。遥闻狱囚楚毒音声。心怀伤愍。从宫殿出入牢狱中。见诸罪人杻械枷锁。递相连系。置幽闇处。或以火炙。或以烟熏。或被榜笞。或遭膑割。裸形乱发。饥渴羸瘦。筋断骨现。号叫苦剧。太子见已心生悲愍。以无畏声。安慰之言。汝莫忧恼。汝勿愁怖。我当令汝悉得解脱。便诣王所而白王言。狱中罪人苦毒难处。愿垂宽宥施以无畏。时王即集五百大臣而问之言。是事云何。诸臣答言。彼罪人者私窃官物。谋夺王位。盗入宫闱。罪应刑戮。有哀救者罪亦至死。时彼太子。悲心转切。语大臣言。如汝所说但放此人。随其所应可以治我。我为彼故。一切苦事悉皆能受。粉身没命。无所顾惜。要令罪人皆得免苦。何以故。我若不救此众生者。云何能救三界牢狱诸苦众生。一切众生在三界中。贪爱所缚。愚痴所蔽。贫无功德。堕诸恶趣。身形鄙陋诸根放逸。其心迷惑不求出道。失智慧光乐着三有。断诸福德灭诸智慧。种种烦恼浊乱其心。住苦牢狱入魔罥网。生老病死忧悲恼害。如是诸苦常所逼迫。我当云何。令彼解脱。应舍身命而拔济之。时诸大臣共诣王所。悉举其手高声唱言。大王当知。如太子意。毁坏王法祸及万人。若王爱念不责治者。王之宝祚亦不久立。王闻此言赫然大怒。令诛太子及诸罪人。王后闻之。愁忧号哭。毁形降服。与千采女驰诣王所。举身投地顶礼王足。俱作是言。唯愿大王。赦太子命。王即回顾。语太子言。莫救罪人。若救罪人必当杀汝。尔时太子。为欲专求一切智故。为欲利益诸众生故。为以大悲普救摄故。其心坚固。无有退怯。复白王言。愿恕彼罪身当受戮。王言随意。尔时王后白言。大王。愿听太子。半月行施。恣意修福。然后治罪。王即听许。时都城北有一大园名曰日光。是昔施场。太子往彼。设大施会。饮食衣服。华鬘璎珞。涂香末香。幢幡宝盖。诸庄严具。随有所求靡不周给。经半月已。于最后日。国王大臣。长者居士。城邑人民。及诸外道。悉来集会。时法轮音虚空灯王如来。知诸众生调伏时至。与大众俱。天王围绕。龙王供养。夜叉王守护。乾闼婆王赞叹。阿修罗王曲躬顶礼。迦楼罗王以清净心散诸宝华。紧那罗王欢喜劝请。摩睺罗伽王一心瞻仰。来入彼会。尔时太子及诸大众。遥见佛来。端严殊特诸根寂定。如调顺象。心无垢浊。如清净池。现大神通。示大自在。显大威德。种种相好。庄严其身。放大光明。普照世界。一切毛孔出香焰云。震动十方无量佛刹。随所至处。普雨一切诸庄严具。以佛威仪。以佛功德。众生见者。心净欢喜烦恼销灭。尔时太子及诸大众。五体投地顶礼其足。安施床座。合掌白言。善来世尊。善来善逝。唯愿哀愍。摄受于我。处于此座。以佛神力。净居诸天。即变此座。为香摩尼莲华之座。佛坐其上。诸菩萨众。亦皆就座。周匝围绕。时彼会中。一切众生。因见如来。苦灭障除。堪受圣法。尔时如来。知其可化。以圆满音。说修多罗。名普照因轮。令诸众生。随类各解。时彼会中。有八十那由他众生。远尘离垢。得法眼净。无量那由他众生。得无学地。十千众生。住大乘道。入普贤行。成满大愿。当尔之时。十方各百佛刹微尘数众生。于大乘中。心得调伏。无量世界一切众生。免离恶趣生于天上。善伏太子。即于此时。得菩萨教化众生令生善根解脱门。善男子。尔时太子。岂异人乎。我身是也。我因往昔起大悲心。舍身命财。救苦众生。开门大施。供养于佛。得此解脱。佛子当知。我于尔时。但为利益一切众生。不着三界。不求果报。不贪名称。不欲自赞轻毁于他。于诸境界。无所贪染。无所怖畏。但庄严大乘出要之道。常乐观察一切智门。修行苦行。得此解脱。佛子。于汝意云何。彼时五百大臣。欲害我者。岂异人乎。今提婆达多等五百徒党是也。是诸人等。蒙佛教化。皆当得阿耨多罗三藐三菩提。于未来世。过须弥山微尘数劫。尔时有劫。名善光。世界名宝光。于中成佛。其五百佛次第兴世。最初如来名曰大悲。第二名饶益世间。第三名大悲师子。第四名救护众生。乃至最后名曰医王。虽彼诸佛大悲平等。然其国土。种族父母。受生诞生。出家学道。往诣道场。转正法轮。说修多罗。语言音声。光明众会。寿命法住。及其名号。各各差别。佛子。彼诸罪人。我所救者。即拘留孙等贤劫千佛。及百万阿僧祇诸大菩萨。于无量精进力名称功德慧如来所。发阿耨多罗三藐三菩提心。今于十方国土。行菩萨道。修习增长。此菩萨。教化众生。令生善根解脱者是。时胜光王。今萨遮尼干子大论师是。时王宫人及诸眷属。即彼尼干六万弟子。与师俱来。建大论幢。共佛论议。悉降伏之。授阿耨多罗三藐三菩提记者是。此诸人等。皆当作佛。国土庄严。劫数名号。各各有异。佛子。我于尔时。救罪人已。父母听我。舍离国土。妻子财宝。于法轮音虚空灯王佛所。出家学道。五百岁中。净修梵行。即得成就百万陀罗尼。百万神通。百万法藏。百万求一切智勇猛精进。净治百万堪忍门。增长百万思惟心。成就百万菩萨力。入百万菩萨智门。得百万般若波罗蜜门。见十方百万诸佛。生百万菩萨大愿。念念中十方各照百万佛刹。念念中忆念十方世界前后际劫百万诸佛。念念中知十方世界百万诸佛变化海。念念中见十方百万世界所有众生种种诸趣。随业所受。生时死时。善趣恶趣。好色恶色。其诸众生。种种心行。种种欲乐。种种根性。种种业习。种种成就。皆悉明了。佛子。我于尔时。命终之后。还复于彼王家受生。作转轮王。彼法轮音虚空灯王如来灭后。次即于此。值法空王如来。承事供养。次为帝释。即此道场值天王藏如来。亲近供养。次为夜摩天王。即于此世界值大地威力山如来。亲近供养。次为兜率天王。即于此世界值法轮光音声王如来。亲近供养。次为化乐天王。即于此世界值虚空智王如来。亲近供养。次为他化自在天王。即于此世界值无能坏幢如来。亲近供养。次为阿修罗王。即于此世界值一切法雷音王如来。亲近供养。次为梵王。即于此世界值普现化演法音如来。亲近供养。佛子。此宝光世界善光劫中。有一万佛。出兴于世。我皆亲近承事供养。次复有劫名曰日光。有六十亿佛。出兴于世。最初如来名妙相山。我时为王名曰大慧。于彼佛所承事供养。次有佛出名圆满肩。我为居士。亲近供养。次有佛出名离垢童子。我为大臣。亲近供养。次有佛出名勇猛持。我为阿修罗王。亲近供养。次有佛出名须弥相。我为树神。亲近供养。次有佛出。名离垢臂。我为商主。亲近供养。次有佛出名师子游步。我为城神。亲近供养。次有佛出名为宝髻。我为毗沙门天王。亲近供养。次有佛出名最上法称。我为乾闼婆王。亲近供养。次有佛出名光明冠。我为鸠槃荼王。亲近供养。于彼劫中。如是次第。有六十亿如来。出兴于世。我常于此。受种种身。一一佛所。亲近供养。教化成就无量众生。于一一佛所。得种种三昧门。种种陀罗尼门。种种神通门。种种辩才门。种种一切智门。种种法明门。种种智慧门。照种种十方海。入种种佛刹海。见种种诸佛海。清净成就增长广大。如于此劫中亲近供养。尔所诸佛。于一切处一切世界海微尘数劫。所有诸佛出兴于世。亲近供养。听闻说法。信受护持。亦复如是。如是一切诸如来所。皆悉修习此解脱门。复得无量解脱方便。尔时救护一切众生主夜神。欲重宣此解脱义。即为善财。而说颂言

  汝以欢喜信乐心　　问此难思解脱法
  我承如来护念力　　为汝宣说应听受
  过去无边广大劫　　过于刹海微尘数
  时有世界名宝光　　其中有劫号善光
  于此善光大劫中　　一万如来出兴世
  我皆亲近而供养　　从其修学此解脱
  时有王都名喜严　　纵广宽平极殊丽
  杂业众生所居住　　或心清净或作恶
  尔时有王名胜光　　恒以正法御群生
  其王太子名善伏　　形体端正备众相
  时有无量诸罪人　　系身牢狱当受戮
  太子见已生悲愍　　上启于王请宽宥
  尔时诸臣共白王　　今此太子危王国
  如是罪人应受戮　　如何悉救令除免
  时胜光王语太子　　汝救彼罪自当受
  太子哀念情转深　　誓救众生无退怯
  时王夫人采女等　　俱来王所白王言
  愿放太子半月中　　布施众生作功德
  时王闻已即听许　　设大施会济贫乏
  一切众生靡不臻　　随有所求咸给与
  如是半月日云满　　太子就戮时将至
  大众百千万亿人　　同时瞻仰俱号泣
  彼佛知众根将熟　　而来此会化群生
  显现神变大庄严　　靡不亲近而恭敬
  佛以一音方便说　　法灯普照修多罗
  无量众生意柔软　　悉蒙与授菩提记
  善伏太子生欢喜　　发兴无上正觉心
  誓愿承事于如来　　普为众生作依处
  便即出家依佛住　　修行一切种智道
  尔时便得此解脱　　大悲广济诸群生
  于中止住经劫海　　谛观诸法真实性
  常于苦海救众生　　如是修习菩提道
  劫中所有诸佛现　　悉皆承事无有余
  咸以清净信解心　　听闻持护所说法
  次于佛刹微尘数　　无量无边诸劫海
  所有诸佛现世间　　一一供养皆如是
  我念往昔为太子　　见诸众生在牢狱
  誓愿舍身而救护　　因其证此解脱门
  经于佛刹微尘数　　广大劫海常修习
  念念令其得增长　　复获无边巧方便
  彼中所有诸如来　　我悉得见蒙开悟
  令我增明此解脱　　及以种种方便力
  我于无量千亿劫　　学此难思解脱门
  诸佛法海无有边　　我悉一时能普饮
  十方所有一切刹　　其身普入无所碍
  三世种种国土名　　念念了知皆悉尽
  三世所有诸佛海　　一一明见尽无余
  亦能示现其身相　　普诣于彼如来所
  又于十方一切刹　　一切诸佛导师前
  普雨一切庄严云　　供养一切无上觉
  又以无边大问海　　启请一切诸世尊
  彼佛所雨妙法云　　皆悉受持无忘失
  又于十方无量刹　　一切如来众会前
  坐于众妙庄严座　　示现种种神通力
  又于十方无量刹　　示现种种诸神变
  一身示现无量身　　无量身中现一身
  又于一一毛孔中　　悉放无数大光明
  各以种种巧方便　　除灭众生烦恼火
  又于一一毛孔中　　出现无量化身云
  充满十方诸世界　　普雨法雨济群品
  十方一切诸佛子　　入此难思解脱门
  悉尽未来无量劫　　安住修行菩萨行
  随其心乐为说法　　令彼皆除邪见网
  示以天道及二乘　　乃至如来一切智
  一切众生受生处　　示现无边种种身
  悉同其类现众像　　普应其心而说法
  若有得此解脱门　　则住无边功德海
  譬如刹海微尘数　　不可思议无有量

善男子。我唯知此教化众生令生善根解脱门。如诸菩萨摩诃萨。超诸世间。现诸趣身。不住攀缘。无有障碍。了达一切诸法自性。善能观察一切诸法。得无我智。证无我法。教化调伏一切众生。恒无休息。心常安住无二法门。普入一切诸言辞海。我今云何能知能说彼功德海。彼勇猛智。彼心行处。彼三昧境。彼解脱力。善男子。此阎浮提。有一园林名岚毗尼。彼园有神名妙德圆满。汝诣彼问。菩萨云何修菩萨行。生如来家。为世光明。尽未来劫。而无厌倦。时善财童子。顶礼其足。绕无量匝。合掌瞻仰。辞退而去

大方广佛华严经卷第七十三大方广佛华严经卷第七十四

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十五

尔时善财童子。于大愿精进力救护一切众生夜神所。得菩萨解脱已。忆念修习。了达增长。渐次游行。至岚毗尼林。周遍寻觅彼妙德神。见在一切宝树庄严楼阁中。坐宝莲华师子之座。二十亿那由他诸天。恭敬围绕。为说菩萨受生海经。令其皆得生如来家。增长菩萨大功德海。善财见已。顶礼其足。合掌前立。白言大圣。我已先发阿耨多罗三藐三菩提心。而未能知菩萨云何修菩萨行。生如来家为世大明。彼神答言。善男子。菩萨有十种受生藏。若菩萨。成就此法。则生如来家。念念增长菩萨善根。不疲不懈不厌不退。无断无失。离诸迷惑。不生怯劣恼悔之心。趣一切智。入法界门。发广大心。增长诸度。成就诸佛无上菩提。舍世间趣。入如来地。获胜神通。诸佛之法常现在前。顺一切智真实义境。何等为十。一者愿常供养一切诸佛受生藏。二者发菩提心受生藏。三者观诸法门勤修行受生藏。四者以深净心普照三世受生藏。五者平等光明受生藏。六者生如来家受生藏。七者佛力光明受生藏。八者观普智门受生藏。九者普现庄严受生藏。十者入如来地受生藏。善男子。云何名愿常供养一切佛受生藏。善男子。菩萨初发心时。作如是愿。我当尊重恭敬供养一切诸佛。见佛无厌。于诸佛所。常生爱乐。常起深信修诸功德。恒无休息。是为菩萨为一切智始集善根受生藏。云何名发菩提心受生藏。善男子。此菩萨。发阿耨多罗三藐三菩提心。所谓起大悲心。救护一切众生故。起供养佛心。究竟承事故。起普求正法心。一切无吝故。起广大趣向心。求一切智故。起慈无量心。普摄众生故。起不舍一切众生心。被求一切智坚誓甲故。起无谄诳心。得如实智故。起如说行心。修菩萨道故。起不诳诸佛心。守护一切佛大誓愿故。起一切智愿心。尽未来化众生不休息故。菩萨以如是等佛刹微尘数菩提心功德故。得生如来家。是为菩萨第二受生藏。云何名观诸法门勤修行受生藏。善男子。此菩萨摩诃萨。起观一切法门海心。起回向一切智圆满道心。起正念无过失业心。起一切菩萨三昧海清净心。起修成一切菩萨功德心。起庄严一切菩萨道心。起求一切智大精进行修诸功德如劫火炽然无休息心。起修普贤行教化一切众生心。起善学一切威仪修菩萨功德舍离一切所有住无所有真实心。是为菩萨第三受生藏。云何名以深净心普照三世受生藏。善男子。此菩萨。具清净增上心。得如来菩提光。入菩萨方便海。其心坚固。犹若金刚背舍一切诸有趣生。成就一切佛自在力。修殊胜行。具菩萨根。其心明洁。愿力不动。常为诸佛之所护念。破坏一切诸障碍山。普为众生作所依处。是为菩萨第四受生藏。云何名平等光明受生藏。善男子。此菩萨。具足众行。普化众生。一切所有。悉皆能舍。住佛究竟净戒境界。具足忍法。成就诸佛法忍光明。以大精进。趣一切智。到于彼岸。修习诸禅得普门定。净智圆满。以智慧日明照诸法。得无碍眼。见诸佛海。悟入一切真实法性。一切世间。见者欢喜。善能修习如实法门。是为菩萨第五受生藏。云何名生如来家受生藏。善男子。此菩萨。生如来家。随诸佛住。成就一切甚深法门。具三世佛清净大愿。得一切佛同一善根。与诸如来。共一体性。具出世行白净善法。安住广大功德法门。入诸三昧。见佛神力。随所应化。净诸众生。如问而对。辩才无尽。是为菩萨第六受生藏。云何名佛力光明受生藏。善男子。此菩萨。深入佛力。游诸佛刹。心无退转。供养承事菩萨众会。无有疲厌。了一切法皆如幻起。知诸世间如梦所见。一切色相犹如光影。神通所作皆如变化。一切受生悉皆如影。诸佛说法皆如谷响。开示法界咸令究竟。是为菩萨第七受生藏。云何名观普智门受生藏。善男子。此菩萨。住童真位。观一切智。一一智门。尽无量劫。开演一切菩萨所行。于诸菩萨甚深三昧。心得自在。念念生于十方世界诸如来所。于有差别境入无差别定。于无差别法现有差别智。于无量境知无境界。于少境界入无量境。通达法性广大无际。知诸世间悉假施设。一切皆是识心所起。是为菩萨第八受生藏。云何名普现庄严受生藏。善男子。此菩萨。能种种庄严无量佛刹。普能化现一切众生。及诸佛身。得无所畏。演清净法。周流法界。无所障碍。随其心乐普使知见。示现种种成菩提行。令生无碍一切智道。如是所作不失其时。而常在三昧毗卢遮那智慧之藏。是为菩萨第九受生藏。云何名入如来地受生藏。善男子。此菩萨。悉于三世诸如来所。受灌顶法。普知一切境界次第。所谓知一切众生。前际后际没生次第。一切菩萨修行次第。一切众生心念次第。三世如来成佛次第。善巧方便说法次第。亦知一切初中后际。所有诸劫。若成若坏。名号次第。随诸众生所应化度。为现成道功德庄严。神通说法方便调伏。是为菩萨第十受生藏。佛子。若菩萨摩诃萨。于此十法。修习增长圆满成就。则能于一庄严中。现种种庄严。如是庄严一切国土。开导示悟一切众生。尽未来劫无有休息。演说一切诸佛法海。种种境界。种种成熟。展转传来。无量诸法。现不思议佛自在力。充满一切虚空法界。于诸众生心行海中。而转法轮。于一切世界。示现成佛。恒无间断。以不可说清净言音。说一切法。住无量处。通达无碍。以一切法庄严道场。随诸众生欲解差别。而现成佛。开示无量。甚深法藏。教化成就一切世间。尔时岚毗尼林神。欲重明其义。以佛神力。普观十方。而说颂言

  最上离垢清净心　　见一切佛无厌足
  愿尽未来常供养　　此明慧者受生藏
  一切三世国土中　　所有众生及诸佛
  悉愿度脱恒瞻奉　　此难思者受生藏
  闻法无厌乐观察　　普于三世无所碍
  身心清净如虚空　　此名称者受生藏
  其心恒住大悲海　　坚如金刚及宝山
  了达一切种智门　　此最胜者受生藏
  大慈普覆于一切　　妙行常增诸度海
  以法光明照群品　　此雄猛者受生藏
  了达法性心无碍　　生于三世诸佛家
  普入十方法界海　　此明智者受生藏
  法身清净心无碍　　普诣十方诸国土
  一切佛力靡不成　　此不思议受生藏
  入深智慧已自在　　于诸三昧亦究竟
  观一切智如实门　　此真身者受生藏
  净治一切诸佛土　　勤修普化众生法
  显现如来自在力　　此大名者受生藏
  久已修行萨婆若　　疾能趣入如来位
  了知法界皆无碍　　此诸佛子受生藏

善男子。菩萨具此十法。生如来家。为一切世间清净光明。善男子。我从无量劫来。得是自在受生解脱门。善财白言。圣者。此解脱门。境界云何。答言。善男子。我先发愿。愿一切菩萨示受生时。皆得亲近。愿入毗卢遮那如来无量受生海。以昔愿力。生此世界阎浮提中岚毗尼园。专念菩萨。何时下生。经于百年。世尊果从兜率陀天而来生此。时此林中。现十种相。何等为十。一者此园中地。忽自平坦。坑坎堆阜。悉皆不现。二者金刚为地。众宝庄严。无有瓦砾。荆棘株杌。三者宝多罗树。周匝行列。其根深植。至于水际。四者生众香芽。现众香藏。宝香为树。扶疏荫映。其诸香气。皆逾天香。五者诸妙华鬘。宝庄严具。行列分布。处处充满。六者园中所有一切诸树。皆自然开摩尼宝华。七者诸池沼中。皆自生华。从地涌出。周布水上。八者时此林中。娑婆世界。欲色所住。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽一切诸王。莫不来集。合掌而住。九者此世界中。所有天女。乃至摩睺罗伽女。皆生欢喜。各各捧持诸供养具。向毕洛叉树前。恭敬而立。十者十方一切诸佛脐中。皆放光明。名菩萨受生自在灯。普照此林。一一光中。悉现诸佛受生诞生。所有神变。及一切菩萨受生功德。又出诸佛种种言音。是为林中十种瑞相。此相现时。诸天王等。即知当有菩萨下生。我见此瑞。欢喜无量。善男子。摩耶夫人。出迦毗罗城。入此林时。复现十种光明瑞相。令诸众生得法光明。何等为十。所谓一切宝华藏光。宝香藏光。宝莲华开演出真实妙音声光。十方菩萨初发心光。一切菩萨得入诸地现神变光。一切菩萨修波罗蜜圆满智光。一切菩萨大愿智光。一切菩萨教化众生方便智光。一切菩萨证于法界真实智光。一切菩萨得佛自在受生出家成正觉光。此十光明。普照无量诸众生心。善男子。摩耶夫人。于毕洛叉树下坐时。复现菩萨将欲诞生。十种神变。何等为十。善男子。菩萨将欲诞生之时。欲界诸天天子天女。及以色界一切诸天诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽并其眷属。为供养故。悉皆云集。摩耶夫人。威德殊胜。身诸毛孔。咸放光明。普照三千大千世界。无所障碍。一切光明悉皆不现。除灭一切众生烦恼。及恶道苦。是为菩萨将欲诞生第一神变。又善男子。当尔之时。摩耶夫人。腹中悉现三千世界一切形像。其百亿阎浮提内。各有都邑。各有园林。名号不同。皆有摩耶夫人。于中止住。天众围绕。悉为显现菩萨将生不可思议神变之相。是为菩萨将欲诞生第二神变。又善男子。摩耶夫人一切毛孔。皆现如来往昔修行菩萨道时。恭敬供养一切诸佛。及闻诸佛说法音声。譬如明镜及以水中。能现虚空日月星宿。云雷等像。摩耶夫人身诸毛孔。亦复如是。能现如来往昔因缘。是为菩萨将欲诞生第三神变。又善男子。摩耶夫人。身诸毛孔。一一皆现如来往修菩萨行时。所住世界。城邑聚落。山林河海。众生劫数。值佛出世。入净国土。随所受生。寿命长短。依善知识。修行善法。于一切刹。在在生处。摩耶夫人。常为其母。如是一切。于毛孔中。靡不皆现。是为菩萨将欲诞生第四神变。又善男子。摩耶夫人一一毛孔。显现如来往昔修行菩萨行时。随所生处。色相形貌。衣服饮食。苦乐等事。一一普现。分明辩了。是为菩萨将欲诞生第五神变。又善男子。摩耶夫人。身诸毛孔。一一皆现世尊往昔修施行时。舍所难舍。头目耳鼻。唇舌牙齿。身体手足。血肉筋骨。男女妻妾。城邑宫殿。衣服璎珞。金银宝货。如是一切内外诸物。亦见受者形貌音声。及其处所。是为菩萨将欲诞生第六神变。又善男子。摩耶夫人。入此园时。其林普现过去所有一切诸佛。入母胎时。国土园林。衣服华鬘。涂香末香。幡缯幢盖。一切众宝庄严之事。妓乐歌咏。上妙音声。令诸众生普得见闻。是为菩萨将诞生时第七神变。又善男子。摩耶夫人。入此园时。从其身出菩萨所住摩尼宝王宫殿楼阁。超过一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。及诸人王之所住者。宝网覆上。妙香普熏。众宝庄严。内外清净。各各差别。不相杂乱。周匝遍满岚毗尼园。是为菩萨将诞生时第八神变。又善男子。摩耶夫人。入此园时。从其身出十不可说百千亿那由他佛刹微尘数菩萨。其诸菩萨。身形容貌。相好光明。进止威仪。神通眷属。皆与毗卢遮那菩萨。等无有异。悉共同时。赞叹如来。是为菩萨将诞生时第九神变。又善男子。摩耶夫人。将欲诞生菩萨之时。忽于其前。从金刚际。出大莲华。名为一切宝庄严藏。金刚为茎。众宝为须。如意宝王以为其台。有十佛刹微尘数叶。一切皆以摩尼所成宝网宝盖。以覆其上。一切天王。所共执持。一切龙王降注香雨。一切夜叉王恭敬围绕。散诸天华。一切乾闼婆王出微妙音。歌赞菩萨往昔供养诸佛功德。一切阿修罗王舍憍慢心。稽首敬礼。一切迦楼罗王垂宝缯幡。遍满虚空。一切紧那罗王欢喜瞻仰。歌咏赞叹菩萨功德。一切摩睺罗伽王皆生欢喜。歌咏赞叹。普雨一切宝庄严云。是为菩萨将诞生时第十神变。善男子。岚毗尼园。示现如是十种相已。然后菩萨。其身诞生。如虚空中现净日轮。如高山顶出于庆云。如密云中而耀电光。如夜闇中而然大炬。尔时菩萨。从母胁生。身相光明。亦复如是。善男子。菩萨尔时。虽现初生。悉已了达一切诸法如梦如幻。如影如像。无来无去。不生不灭。善男子。当我见佛。于此四天下阎浮提内岚毗尼园。示现初生种种神变时。亦见如来于三千大千世界百亿四天下阎浮提内岚毗尼园中。示现初生种种神变。亦见三千大千世界一一尘中无量佛刹。亦见百佛世界。千佛世界。乃至十方一切世界。一一尘中。无量佛刹。如是一切诸佛刹中。皆有如来。示现受生种种神变。如是念念。常无间断。时善财童子。白彼神言。大天得此解脱。其已久如。答言。善男子。乃往古世。过亿佛刹微尘数劫。复过是数。时有世界名为普宝。劫名悦乐。八十那由他佛。于中出现。其第一佛。名自在功德幢。十号具足。彼世界中。有四天下。名妙光庄严。其四天下阎浮提中。有一王都。名须弥庄严幢。其中有王名宝焰眼。其王夫人名曰喜光。善男子。如此世界摩耶夫人。为毗卢遮那如来之母。彼世界中喜光夫人。为初佛母。亦复如是。善男子。其喜光夫人。将欲诞生菩萨之时。与二十亿那由他采女。诣金华园。园中有楼。名妙宝峰。其边有树。名一切施。喜光夫人。攀彼树枝。而生菩萨。诸天王众。各持香水。共以洗沐。时有乳母。名为净光。侍立其侧。既洗沐已。诸天王众授与乳母。乳母敬受生大欢喜。即得菩萨普眼三昧。得此三昧已。普见十方无量诸佛。复得菩萨于一切处示现受生自在解脱。如初受胎识。速疾无碍。得此解脱故。见一切佛乘本愿力。受生自在。亦复如是。善男子。于汝意云何。彼乳母者。岂异人乎。我身是也。我从是来。念念常见毗卢遮那佛示现菩萨受生海调伏众生自在神力。如见毗卢遮那佛。乘本愿力。念念于此三千大千。乃至十方。一切世界微尘之内。皆现菩萨受生神变。见一切佛。悉亦如是。我皆恭敬承事供养。听所说法如说修行。时岚毗尼林神。欲重宣此解脱义。承佛神力。普观十方而说颂言

  佛子汝所问　　诸佛甚深境
  汝今应听受　　我说其因缘
  过亿刹尘劫　　有劫名悦乐
  八十那由他　　如来出兴世
  最初如来号　　自在功德幢
  我在金华园　　见彼初生日
  我时为乳母　　智慧极聪利
  诸天授与我　　菩萨金色身
  我时疾捧持　　谛观不见顶
  身相皆圆满　　一一无边际
  离垢清净身　　相好以庄严
  譬如妙宝像　　见已自欣庆
  思惟彼功德　　疾增众福海
  见此神通事　　发大菩提心
  专求佛功德　　增广诸大愿
  严净一切刹　　灭除三恶道
  普于十方土　　供养无数佛
  修行本誓愿　　救脱众生苦
  我于彼佛所　　闻法得解脱
  亿刹微尘数　　无量劫修行
  劫中所有佛　　我悉曾供养
  护持其正法　　净此解脱海
  亿刹微尘数　　过去十力尊
  尽持其法轮　　增明此解脱
  我于一念顷　　见此刹尘中
  一一有如来　　所净诸刹海
  刹内悉有佛　　园中示诞生
  各现不思议　　广大神通力
  或见不思议　　亿刹诸菩萨
  住于天宫上　　将证佛菩提
  无量刹海中　　诸佛现受生
  说法众围绕　　于此我皆见
  一念见亿刹　　微尘数菩萨
  出家趣道场　　示现佛境界
  我见刹尘内　　无量佛成道
  各现诸方便　　度脱苦众生
  一一微尘中　　诸佛转法轮
  悉以无尽音　　普雨甘露法
  亿刹微尘数　　一一刹尘内
  悉见于如来　　示现般涅槃
  如是无量刹　　如来示诞生
  而我悉分身　　现前兴供养
  不思议刹海　　无量趣差别
  我悉现其前　　雨于大法雨
  佛子我知此　　难思解脱门
  无量亿劫中　　称扬不可尽

善男子。我唯知此菩萨于无量劫遍一切处示现受生自在解脱。如诸菩萨摩诃萨。能以一念为诸劫藏。观一切法。以善方便而现受生。周遍供养一切诸佛。究竟通达一切佛法。于一切趣皆现受生。一切佛前坐莲华座。知诸众生应可度时。为现受生方便调伏。于一切刹现诸神变。犹如影像悉现其前。我当云何能知能说彼功德行。善男子。此迦毗罗城。有释种女。名曰瞿波。汝诣彼问。菩萨云何于生死中。教化众生。时善财童子。顶礼其足。绕无数匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第七十四大方广佛华严经卷第七十五

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十六

尔时善财童子。向迦毗罗城。思惟修习受生解脱。增长广大。忆念不舍。渐次游行。至菩萨集会普现法界光明讲堂。其中有神。号无忧德。与一万主宫殿神俱。来迎善财。作如是言。善来丈夫有大智慧。有大勇猛。能修菩萨不可思议自在解脱。心恒不舍广大誓愿。善能观察诸法境界。安住法城。入于无量诸方便门。成就如来功德大海。得妙辩才。善调众生。获圣智身。恒顺修行。知诸众生心行差别。令其欢喜趣向佛道。我观仁者修诸妙行。心无暂懈。威仪所行。悉皆清净。汝当不久。得诸如来清净庄严无上三业。以诸相好庄严其身。以十力智莹饰其心。游诸世间。我观仁者勇猛精进而无有比。不久当得普见三世一切诸佛。听受其法。不久当得一切菩萨禅定解脱诸三昧乐。不久当入诸佛如来甚深解脱。何以故。见善知识。亲近供养。听受其教。忆念修行。不懈不退。无忧无悔。无有障碍。魔及魔民。不能为难。不久当成无上果故。善财童子言。圣者。如向所说。愿我皆得。圣者。我愿一切众生息诸热恼。离诸恶业。生诸安乐。修诸净行。圣者。一切众生起诸烦恼。造诸恶业。堕诸恶趣。若身若心恒受楚毒。菩萨见已心生忧恼。圣者。譬如有人唯有一子。爱念情至。忽见被人割截肢体。其心痛切不能自安。菩萨摩诃萨。亦复如是。见诸众生以烦恼业。堕三恶趣受种种苦。心大忧恼。若见众生起身语意三种善业。生天人趣。受身心乐。菩萨尔时。生大欢喜。何以故。菩萨不自为故求一切智。不贪生死诸欲快乐。不随想倒见倒心倒诸结随眠爱见力转。不起众生种种乐想。亦不味着诸禅定乐。非有障碍。疲厌退转住于生死。但见众生。于诸有中。具受无量种种诸苦。起大悲心。以大愿力而普摄取。悲愿力故。修菩萨行。为断一切众生烦恼。为求如来一切智智。为供养一切诸佛如来。为严净一切广大国土。为净治一切众生乐欲。及其所有身心诸行。于生死中无有疲厌。圣者菩萨摩诃萨。于诸众生为庄严。令生人天富贵乐故。为父母。为其安立菩提心故。为养育令其成就菩萨道故。为卫护。令其远离三恶道故。为船师。令其得度生死海故。为归依。令舍诸魔烦恼怖故。为究竟。令其永得清凉乐故。为津济。令入一切诸佛海故。为导师。令至一切法宝洲故。为妙华。开敷诸佛功德心故。为严具。常放福德智慧光故。为可乐。凡有所作悉端严故。为可尊。远离一切诸恶业故。为普贤。具足一切端严身故。为大明。常放智慧净光明故。为大云。常雨一切甘露法故。圣者。菩萨如是修诸行时。令一切众生。皆生爱乐具足法乐。尔时善财童子。将升法堂。其无忧德及诸神众。以出过诸天上妙华鬘。涂香末香。及以种种宝庄严具。散善财上。而说颂言

  汝今出世间　　为世大明灯
  普为诸众生　　勤求无上觉
  无量亿千劫　　难可得见汝
  功德日今出　　灭除诸世闇
  汝见诸众生　　颠倒惑所覆
  而兴大悲意　　求证无师道
  汝以清净心　　寻求佛菩提
  承事善知识　　不自惜身命
  汝于诸世间　　无依无所著
  其心普无碍　　清净如虚空
  汝修菩提行　　功德悉圆满
  放大智慧光　　普照一切世
  汝不离世间　　亦不着于世
  行世无障碍　　如风游虚空
  譬如火灾起　　一切无能灭
  汝修菩提行　　精进火亦然
  勇猛大精进　　坚固不可动
  金刚慧师子　　游行无所畏
  一切法界中　　所有诸刹海
  汝悉能往诣　　亲近善知识

尔时无忧德神。说此颂已。为爱乐法故。随逐善财。恒不舍离。尔时善财童子。入普现法界光明讲堂。周遍推求彼释氏女。见在堂内。坐宝莲华师子之座。八万四千采女所共围绕。是诸采女。靡不皆从王种中生。悉于过去。修菩萨行同种善根。布施爱语普摄众生。已能明见一切智境。已共修集佛菩提行。恒住正定。常游大悲。普摄众生犹如一子。慈心具足眷属清净。已于过去。成就菩萨不可思议善巧方便。皆于阿耨多罗三藐三菩提。得不退转。具足菩萨诸波罗蜜。离诸取着。不乐生死。虽行诸有心常清净。恒勤观察一切智道。离障盖网。超诸着处。从于法身而示化形。生普贤行。长菩萨力。智日慧灯悉已圆满。尔时善财童子。诣彼释女瞿波之所。顶礼其足合掌而住。作如是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何于生死中。而不为生死过患所染。了法自性。而不住声闻辟支佛地。具足佛法。而修菩萨行。住菩萨地。而入佛境界。超过世间。而于世受生。成就法身。而示现无边种种色身。证无相法。而为众生示现诸相。知法无说。而广为众生演说诸法。知众生空。而恒不舍化众生事。虽知诸佛不生不灭。而勤供养。无有退转。虽知诸法无业无报。而修诸善行恒不止息。时瞿波女。告善财言。善哉善哉。善男子。汝今能问菩萨摩诃萨。如是行法。修习普贤诸行愿者。能如是问。谛听谛听。善思念之。我当承佛神力。为汝宣说。善男子。若诸菩萨。成就十法。则能圆满因陀罗网普智光明菩萨之行。何等为十。所谓依善知识故。得广大胜解故。得清净欲乐故。集一切福智故。于诸佛所听闻法故。心恒不舍三世佛故。同于一切菩萨行故。一切如来所护念故。大悲妙愿皆清净故。能以智力普断一切诸生死故。是为十。若诸菩萨。成就此法。则能圆满因陀罗网普智光明菩萨之行。佛子。若菩萨亲近善知识。则能精进不退修习出生无尽佛法。佛子。菩萨以十种法。承事善知识。何等为十。所谓于自身命无所顾惜。于世乐具心不贪求。知一切法性皆平等。永不退舍一切智愿。观察一切法界实相。心恒舍离一切有海。知法如空心无所依。成就一切菩萨大愿。常能示现一切刹海。净修菩萨无碍智轮。佛子。应以此法。承事一切诸善知识。无所违逆。尔时释迦瞿波女。欲重明此义。承佛神力。观察十方。而说颂言

  菩萨为利诸群生　　正念亲承善知识
  敬之如佛心无怠　　此行于世帝网行
  胜解广大如虚空　　一切三世悉入中
  国土众生佛皆尔　　此是普智光明行
  志乐如空无有际　　永断烦恼离诸垢
  一切佛所修功德　　此行于世身云行
  菩萨修习一切智　　不可思议功德海
  净诸福德智慧身　　此行于世不染行
  一切诸佛如来所　　听受其法无厌足
  能生实相智慧灯　　此行于世普照行
  十方诸佛无有量　　一念一切悉能入
  心恒不舍诸如来　　此向菩提大愿行
  能入诸佛大众会　　一切菩萨三昧海
  愿海及以方便海　　此行于世帝网行
  一切诸佛所加持　　尽未来际无边劫
  处处修行普贤道　　此是菩萨分身行
  见诸众生受大苦　　起大慈悲现世间
  演法光明除闇冥　　此是菩萨智日行
  见诸众生在诸趣　　为集无边妙法轮
  令其永断生死流　　此是修行普贤行
  菩萨修行此方便　　随众生心而现身
  普于一切诸趣中　　化度无量诸含识
  以大慈悲方便力　　普遍世间而现身
  随其解欲为说法　　皆令趣向菩提道

时释迦瞿波。说此颂已。告善财童子言。善男子。我已成就观察一切菩萨三昧海解脱门。善财言。大圣。此解脱门境界云何。答言。善男子。我入此解脱。知此娑婆世界佛刹微尘数劫。所有众生于诸趣中。死此生彼。作善作恶。受诸果报。有求出离。不求出离。正定邪定。及以不定。有烦恼善根。无烦恼善根。具足善根。不具足善根。不善根所摄善根。善根所摄不善根。如是所集。善不善法。我皆知见。又彼劫中所有诸佛。名号次第。我悉了知。彼佛世尊。从初发心。及以方便。求一切智。出生一切诸大愿海。供养诸佛。修菩萨行。成等正觉。转妙法轮。现大神通。化度众生。我悉了知。亦知彼佛众会差别。其众会中。有诸众生依声闻乘。而得出离。其声闻众。过去修习一切善根。及其所得种种智慧。我悉了知。有诸众生依独觉乘。而得出离。其诸独觉。所有善根。所得菩提。寂灭解脱。神通变化。成熟众生。入于涅槃。我悉了知。亦知彼佛诸菩萨众。其诸菩萨。从初发心。修习善根。出生无量诸大愿行。成就满足诸波罗蜜种种庄严菩萨之道。以自在力。入菩萨地。住菩萨地。观菩萨地。净菩萨地。菩萨地相。菩萨地智。菩萨摄智。菩萨教化众生智。菩萨建立智。菩萨广大行境界菩萨神通行。菩萨三昧海。菩萨方便。菩萨于念念中所入三昧海。所得一切智光明。所获一切智电光云。所得实相忍。所通达一切智。所住刹海。所入法海。所知众生海。所住方便。所发誓愿。所现神通。我悉了知。善男子。此娑婆世界尽未来际所有劫海。展转不断。我皆了知。如知娑婆世界。亦知娑婆世界内微尘数世界。亦知娑婆世界内一切世界。亦知娑婆世界微尘内所有世界。亦知娑婆世界外十方无间所住世界。亦知娑婆世界世界种所摄世界。亦知毗卢遮那世尊此华藏世界海中十方无量诸世界种所摄世界。所谓世界广博。世界安立。世界轮。世界场。世界差别。世界转。世界莲华。世界须弥。世界名号。尽此世界海。一切世界。由毗卢遮那世尊本愿力故。我悉能知。亦能忆念。亦念如来往昔所有诸因缘海。所谓修集一切诸乘方便。无量劫中住菩萨行。净佛国土。教化众生。承事诸佛。造立住处。听受说法。获诸三昧。得诸自在。修檀波罗蜜。入佛功德海。持戒苦行。具足诸忍。勇猛精进。成就诸禅。圆满净慧。于一切处。示现受生。普贤行愿悉皆清净。普入诸刹。普净佛土。普入一切如来智海。普摄一切诸佛菩提。得于如来大智光明。证于诸佛一切智性。成等正觉。转妙法轮。及其所有道场众会。其众会中一切众生。往世已来。所种善根。从初发心。成熟众生。修行方便。念念增长。获诸三昧神通解脱。如是一切。我悉了知。何以故。我此解脱。能知一切众生心行。一切众生修行善根。一切众生杂染清净。一切众生种种差别。一切声闻诸三昧门。一切缘觉寂静三昧神通解脱。一切菩萨一切如来解脱光明。皆了知故。尔时善财童子。白瞿波言。圣者。得此解脱。其已久如。答言。善男子。我于往世过佛刹微尘数劫。有劫名胜行。世界名无畏。彼世界中。有四天下。名为安隐。其四天下阎浮提中。有一王城名高胜树。于八十王城中最为上首。彼时有王名曰财主。其王具有六万采女五百大臣五百王子。其诸王子。皆悉勇健。能伏怨敌。其王太子名威德主。端正殊特。人所乐见。足下平满。轮相备具。足趺隆起。手足指间皆有网缦。足跟齐正。手足柔软。伊尼耶鹿王腨。七处圆满阴藏隐密。其身上分如师子王。两肩平满。双臂佣长。身相端直。颈文三道。颊如师子。具四十齿。悉皆齐密。四牙鲜白。其舌长广。出梵音声。眼目绀青。睫如牛王。眉间毫相。顶上肉髻。皮肤细软。如真金色。身毛上靡。发帝青色。其身洪满。如尼拘陀树。尔时太子受父王教。与十千采女。诣香芽园。游观戏乐。太子是时。乘妙宝车。其车具有种种严饰。置大摩尼师子之座。而坐其上。五百采女。各执宝绳牵驭而行。进止有度。不迟不速。百千万人持诸宝盖。百千万人持诸宝幢。百千万人持诸宝幡。百千万人作诸妓乐。百千万人烧诸名香。百千万人散诸妙华。前后围绕。而为翊从。道路平正。无有高下。众宝杂华散布其上。宝树行列。宝网弥覆。种种楼阁延袤其间。其楼阁中。或有积聚种种珍宝。或有陈列诸庄严具。或有供设种种饮食。或有悬布种种衣服。或有备拟诸资生物。或复安置端正女人。及以无量僮仆侍从。随有所须悉皆施与。时有母人名为善现。将一童女名具足妙德。颜容端正。色相严洁。洪纤得所。修短合度。目发绀青。声如梵音。善达工巧。精通辩论。恭勤匪懈。慈愍不害。具足惭愧。柔和质直。离痴寡欲。无诸谄诳。乘妙宝车。采女围绕。及与其母从王城出。先太子行。见其太子言辞讽咏。心生爱染而白母言。我心愿得敬事此人。若不遂情当自殒灭。母告女言。莫生此念。何以故。此甚难得。此人具足轮王诸相。后当嗣位作转轮王。有宝女出。腾空自在。我等卑贱非其匹偶。此处难得勿生是念。彼香芽园侧。有一道场。名法云光明。时有如来。名胜日身。十号具足。于中出现已经七日。时彼童女。暂时假寐。梦见其佛。从梦觉已。空中有天。而告之言。胜日身如来。于法云光明道场。成等正觉。已经七日。诸菩萨众。前后围绕。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。梵天乃至。色究竟天。诸地神风神。火神水神。河神海神。山神树神。园神药神。主城神等。为见佛故。皆来集会。时妙德童女。梦睹如来故。闻佛功德故。其心安隐。无有怖畏。于太子前。而说颂言

  我身最端正　　名闻遍十方
  智慧无等伦　　善达诸工巧
  无量百千众　　见我皆贪染
  我心不于彼　　而生少爱欲
  无嗔亦无恨　　无嫌亦无喜
  但发广大心　　利益诸众生
  我今见太子　　具诸功德相
  其心大欣庆　　诸根咸悦乐
  色如光明宝　　发美而右旋
  额广眉纤曲　　我心愿事汝
  我观太子身　　譬若真金像
  亦如大宝山　　相好有光明
  目广绀青色　　月面师子颊
  喜颜美妙音　　愿垂哀纳我
  舌相广长妙　　犹如赤铜色
  梵音紧那声　　闻者皆欢喜
  口方不褰缩　　齿白悉齐密
  发言现笑时　　见者心欢喜
  离垢清净身　　具相三十二
  必当于此界　　而作转轮位

尔时太子。告彼女言。汝是谁女。为谁守护。若先属人。我则不应起爱染心。尔时太子。以颂问言

  汝身极清净　　功德相具足
  我今问于汝　　汝于谁所住
  谁为汝父母　　汝今系属谁
  若已属于人　　彼人摄受汝
  汝不盗他物　　汝不有害心
  汝不作邪淫　　汝依何语住
  不说他人恶　　不坏他所亲
  不侵他境界　　不于他恚怒
  不生邪险见　　不作相违业
  不以谄曲力　　方便诳世间
  尊重父母不　　敬善知识不
  见诸贫穷人　　能生摄心不
  若有善知识　　诲示于汝法
  能生坚固心　　究竟尊重不
  爱乐于佛不　　了知菩萨不
  众僧功德海　　汝能恭敬不
  汝能知法不　　能净众生不
  为住于法中　　为住于非法
  见诸孤独者　　能起慈心不
  见恶道众生　　能生大悲不
  见他得荣乐　　能生欢喜不
  他来逼迫汝　　汝无嗔恼不
  汝发菩提意　　开悟众生不
  无边劫修行　　能无疲倦不

尔时女母。为其太子。而说颂言

  太子汝应听　　我今说此女
  初生及成长　　一切诸因缘
  太子始生日　　即从莲华生
  其目净修广　　肢节悉具足
  我曾于春月　　游观娑罗园
  普见诸药草　　种种皆荣茂
  奇树发妙华　　望之如庆云
  好鸟相和鸣　　林间共欢乐
  同游八百女　　端正夺人心
  被服皆严丽　　歌咏悉殊美
  彼园有浴池　　名曰莲华幢
  我于池岸坐　　采女众围绕
  于彼莲池内　　忽生千叶华
  宝叶琉璃茎　　阎浮金为台
  尔时夜分尽　　日光初出现
  其莲正开剖　　放大清净光
  其光极炽盛　　譬如日初出
  普照阎浮提　　众叹未曾有
  时见此玉女　　从彼莲华生
  其身甚清净　　肢分皆圆满
  此是人间宝　　从于净业生
  宿因无失坏　　今受此果报
  绀发青莲眼　　梵声金色光
  华鬘众宝髻　　清净无诸垢
  肢节悉具足　　其身无缺减
  譬如真金像　　安处宝华中
  毛孔栴檀香　　普熏于一切
  口出青莲香　　常演梵音声
  此女所住处　　常有天音乐
  不应下劣人　　而当如是偶
  世间无有人　　堪与此为夫
  唯汝相严身　　愿垂见纳受
  非长亦非短　　非粗亦非细
  种种悉端严　　愿垂见纳受
  文字算数法　　工巧诸技艺
  一切皆通达　　愿垂见纳受
  善了诸兵法　　巧断众诤讼
  能调难可调　　愿垂见纳受
  其身甚清净　　见者无厌足
  功德自庄严　　汝应垂纳受
  众生所有患　　善达彼缘起
  应病而与药　　一切能消灭
  阎浮语言法　　差别无量种
  乃至妓乐音　　靡不皆通达
  妇人之所能　　此女一切知
  而无女人过　　愿垂速纳受
  不嫉亦不悭　　无贪亦无恚
  质直性柔软　　离诸粗犷恶
  恭敬于尊者　　奉事无违逆
  乐修诸善行　　此能随顺汝
  若见于老病　　贫穷在苦难
  无救无所依　　常生大慈愍
  常观第一义　　不求自利乐
  但愿益众生　　以此庄严心
  行住与坐卧　　一切无放逸
  言说及默然　　见者咸欣乐
  虽于一切处　　皆无染着心
  见有功德人　　乐观无厌足
  尊重善知识　　乐见离恶人
  其心不躁动　　先思后作业
  福智所庄严　　一切无怨恨
  女人中最上　　宜应事太子

尔时太子。入香芽园已。告其妙德及善现言。善女。我趣求阿耨多罗三藐三菩提。当于尽未来际无量劫。集一切智助道之法。修无边菩萨行。净一切波罗蜜。供养一切诸如来。护持一切诸佛教。严净一切佛国土。当令一切如来种性不断。当随一切众生种性而普成熟。当灭一切众生生死苦置于究竟安乐处。当净治一切众生智慧眼。当修习一切菩萨所修行。当安住一切菩萨平等心。当成就一切菩萨所行地。当令一切众生普欢喜。当舍一切物尽未来际行。檀波罗蜜。令一切众生普得满足衣服饮食。妻妾男女。头目手足。如是一切内外所有。悉当舍施无所吝惜。当于尔时。汝或于我而作障难。施财物时汝心吝惜。施男女时汝心痛恼。割肢体时汝心忧闷。舍汝出家汝心悔恨。尔时太子。即为妙德。而说颂言

  哀愍众生故　　我发菩提心
  当于无量劫　　习行一切智
  无量大劫中　　净修诸愿海
  入地及治障　　悉经无量劫
  三世诸佛所　　学六波罗蜜
  具足方便行　　成就菩提道
  十方垢秽刹　　我当悉严净
  一切恶道难　　我当令永出
  我当以方便　　广度诸群生
  令灭愚痴暗　　住于佛智道
  当供一切佛　　当净一切地
  起大慈悲心　　悉舍内外物
  汝见来乞者　　或生悭吝心
  我心常乐施　　汝勿违于我
  若见我施头　　慎勿生忧恼
  我今先语汝　　令汝心坚固
  乃至截手足　　汝勿嫌乞者
  汝今闻我语　　应可谛思惟
  男女所爱物　　一切我皆舍
  汝能顺我心　　我当成汝意

尔时童女。白太子言。敬奉来教。即说颂言

  无量劫海中　　地狱火焚身
  若能眷纳我　　甘心受此苦
  无量受生处　　碎身如微尘
  若能眷纳我　　甘心受此苦
  无量劫顶戴　　广大金刚山
  若能眷纳我　　甘心受此苦
  无量生死海　　以我身肉施
  汝得法王处　　愿令我亦然
  若能眷纳我　　与我为主者
  生生行施处　　愿常以我施
  为愍众生苦　　而发菩提心
  既已摄众生　　亦当摄受我
  我不求豪富　　不贪五欲乐
  但为共行法　　愿以仁为主
  绀青修广眼　　慈愍观世间
  不起染着心　　必成菩萨道
  太子所行处　　地出众宝华
  必作转轮王　　愿能眷纳我
  我曾梦见此　　妙法菩提场
  如来树下坐　　无量众围绕
  我梦彼如来　　身如真金山
  以手摩我顶　　寤已心欢喜
  往昔眷属天　　名曰喜光明
  彼天为我说　　道场佛兴世
  我曾生是念　　愿见太子身
  彼天报我言　　汝今当得见
  我昔所志愿　　于今悉成满
  唯愿俱往诣　　供养彼如来

尔时太子。闻胜日身如来名。生大欢喜。愿见彼佛。以五百摩尼宝。散其女上。冠以妙藏光明宝冠。被以火焰摩尼宝衣。其女尔时。心不动摇。亦无喜相。但合掌恭敬。瞻仰太子。目不暂舍。其母善现。于太子前。而说颂言

  此女极端正　　功德庄严身
  昔愿奉太子　　今意已满足
  持戒有智慧　　具足诸功德
  普于一切世　　最胜无伦匹
  此女莲华生　　种姓无讥丑
  太子同行业　　远离一切过
  此女身柔软　　犹如天缯纩
  其手所触摩　　众患悉除灭
  毛孔出妙香　　芬馨最无比
  众生若闻者　　悉住于净戒
  身色如真金　　端坐华台上
  众生若见者　　离害具慈心
  言音极柔软　　听之无不喜
  众生若得闻　　悉离诸恶业
  心净无瑕垢　　远离诸谄曲
  称心而发言　　闻者皆欢喜
  调柔具惭愧　　恭敬于尊宿
  无贪亦无诳　　怜愍诸众生
  此女心不恃　　色相及眷属
  但以清净心　　恭敬一切佛

尔时太子。与妙德女及十千采女并其眷属。出香芽园。诣法云光明道场。至已下车。步进诣如来所。见佛身相端严寂静。诸根调顺。内外清净。如大龙池。无诸垢浊。皆生净信。踊跃欢喜。顶礼佛足。绕无数匝。于时太子及妙德女。各持五百妙宝莲华。供散彼佛。太子为佛。造五百精舍。一一皆以香木所成。众宝庄严。五百摩尼以为间错。时佛为说普眼灯门修多罗。闻是经已。于一切法中得三昧海。所谓得普照一切佛愿海三昧。普照三世藏三昧。现见一切佛道场三昧。普照一切众生三昧。普照一切世间智灯三昧。普照一切众生根智灯三昧。救护一切众生光明云三昧。普照一切众生大明灯三昧。演一切佛法轮三昧。具足普贤清净行三昧。时妙德女。得三昧。名难胜海藏。于阿耨多罗三藐三菩提。永不退转。时彼太子。与妙德女并其眷属。顶礼佛足。绕无数匝。辞退还宫。诣父王所。拜跪毕已。奉白王言。大王当知。胜日身如来出兴于世。于此国内法云光明菩提场中。成等正觉。于今未久。尔时大王语太子言。是谁为汝说如是事。天耶人耶。太子白言。是此具足妙德女说。时王闻已。欢喜无量。譬如贫人得大伏藏。作如是念。佛无上宝难可值遇。若得见佛永断一切恶道怖畏。佛如医王能治一切诸烦恼病。能救一切生死大苦。佛如导师。能令众生至于究竟安隐住处。作是念已。集诸小王群臣眷属及以刹利婆罗门等一切大众。便舍王位。授与太子。灌顶讫已。与万人俱。往诣佛所。到已礼足。绕无数匝。并其眷属。悉皆退坐。尔时如来。观察彼王及诸大众。白毫相中放大光明。名一切世间心灯。普照十方无量世界。住于一切世主之前。示现如来不可思议大神通力。普令一切应受化者。心得清净。尔时如来。以不思议自在神力。现身超出一切世间。以圆满音。普为大众。说陀罗尼。名一切法义离闇灯。佛刹微尘数陀罗尼。而为眷属。彼王闻已。即时获得大智光明。其众会中。有阎浮提微尘数菩萨。俱时证得此陀罗尼。六十万那由他人。尽诸有漏心得解脱。十千众生远尘离垢。得法眼净。无量众生发菩提心。时佛又以不思议力。广现神变。普于十方无量世界。演三乘法。化度众生。时彼父王作如是念。我若在家。不能证得如是妙法。若于佛所。出家学道。即当成就。作是念已。前白佛言。愿得从佛出家修学。佛言随意。宜自知时。时财主王。与十千人。皆于佛所同时出家。未久之间。悉得成就一切法义离闇灯陀罗尼。亦得如上诸三昧门。又得菩萨十神通门。又得菩萨无边辩才。又得菩萨无碍净身。往诣十方诸如来所。听受其法。为大法师演说妙法。复以神力遍十方刹。随众生心而为现身。赞佛出现。说佛本行。示佛本缘。称扬如来自在神力。护持于佛所说教法。尔时太子。于十五日。在正殿上。采女围绕。七宝自至。一者轮宝名无碍行。二者象宝名金刚身。三者马宝名迅疾风。四者珠宝名日光藏。五者女宝名具妙德。六藏臣宝名为大财。七主兵宝名离垢眼。七宝具足为转轮王。王阎浮提。正法治世。人民快乐。王有千子端正勇健。能伏怨敌。其阎浮提中。有八十王城。一一城中有五百僧坊。一一僧坊立佛支提。皆悉高广。以众妙宝而为校饰。一一王城。皆请如来。以不思议众妙供具。而为供养。佛入城时。现大神力。令无量众生种诸善根。无量众生心得清净。见佛欢喜。发菩提意。起大悲心。利益众生。勤修佛法。入真实义。住于法性。了法平等。获三世智。等观三世。知一切佛出兴次第。说种种法。摄取众生。发菩萨愿。入菩萨道。知如来法。成就法海。能普现身。遍一切刹。知众生根及其性欲。令其发起一切智愿。佛子。于汝意云何。彼时太子得轮王位。供养佛者。岂异人乎。今释迦牟尼佛是也。财主王者宝华佛是。其宝华佛。现在东方过世界海微尘数佛刹。有世界海。名现法界虚空影像云。中有世界种。名普现三世影摩尼王。彼世界种中。有世界名圆满光。中有道场名现一切世主身。宝华如来。于此成阿耨多罗三藐三菩提。不可说佛刹微尘数诸菩萨众。前后围绕。而为说法。宝华如来。往昔修行菩萨道时。净此世界海。其世界海中去来今佛。出兴世者。皆是宝华如来为菩萨时。教化令发阿耨多罗三藐三菩提心。彼时女母善现者。今我母善目是。其王眷属。今如来所众会是也。皆具修行普贤诸行。成满大愿。虽恒在此众会道场。而能普现一切世间。住诸菩萨平等三昧。常得现见一切诸佛。一切如来。以等虚空妙音声云。演正法轮。悉能听受。于一切法悉得自在。名称普闻诸佛国土。普诣一切道场之所。普现一切众生之前。随其所应。教化调伏。尽未来劫。修菩萨道。恒无间断。成满普贤广大誓愿。佛子。其妙德女。与威德主转轮圣王。以四事供养胜日身如来者。我身是也。彼佛灭后。其世界中。六十亿百千那由他佛。出兴于世。我皆与王。承事供养。其第一佛名清净身。次名一切智月光明身。次名阎浮檀金光明王。次名诸相庄严身。次名妙月光。次名智观幢。次名大智光。次名金刚那罗延精进。次名智力无能胜。次名普安详智。次名离垢胜智云。次名师子智光明。次名光明髻。次名功德光明幢。次名智日幢。次名宝莲华开敷身。次名福德严净光。次名智焰云。次名普照月。次名庄严盖妙音声。次名师子勇猛智光明。次名法界月。次名现虚空影像开悟众生心。次名恒嗅寂灭香。次名普震寂静音。次名甘露山。次名法海音。次名坚固网。次名佛影髻。次名月光毫。次名辩才口。次名觉华智。次名宝焰山。次名功德星。次名宝月幢。次名三昧身。次名宝光王。次名普智行。次名焰海灯。次名离垢法音王。次名无比德名称幢。次名修臂。次名本愿清净月。次名照义灯。次名深远音。次名毗卢遮那胜藏王。次名诸乘幢。次名法海妙莲华。佛子。彼劫中。有如是等六十亿百千那由他佛。出兴于世。我皆亲近。承事供养。其最后佛。名广大解。于彼佛所。得净智眼。尔时彼佛。入城教化。我为王妃。与王礼觐。以众妙物而为供养。于其佛所。闻说出生一切如来灯法门。即时获得观察一切菩萨三昧海境界解脱。佛子。我得此解脱已。与菩萨于佛刹微尘数劫。勤加修习。于佛刹微尘数劫中。承事供养无量诸佛。或于一劫。承事一佛。或二或三。或不可说。或值佛刹微尘数佛。悉皆亲近承事供养。而未能知菩萨之身形量色貌。及其身业心行智慧三昧境界。佛子。若有众生。得见菩萨修菩提行。若疑若信。菩萨皆以世出世间种种方便。而摄取之。以为眷属。令于阿耨多罗三藐三菩提得不退转。佛子。我见彼佛。得此解脱已。与菩萨于百佛刹微尘数劫。而共修习。于其劫中。所有诸佛出兴于世。我皆亲近承事供养。听所说法读诵受持。于彼一切诸如来所。得此解脱种种法门。知种种三世。入种种刹海。见种种成正觉。入种种佛众会。发菩萨种种大愿。修菩萨种种妙行。得菩萨种种解脱。然未能知菩萨所得普贤解脱门。何以故。菩萨普贤解脱门。如太虚空。如众生名。如三世海。如十方海。如法界海。无量无边。佛子。菩萨普贤解脱门。与如来境界等。佛子。我于佛刹微尘数劫。观菩萨身。无有厌足。如多欲人男女集会。递相爱染。起于无量妄想思觉。我亦如是观菩萨身一一毛孔。念念见无量无边广大世界。种种安住。种种庄严。种种形状。有种种山。种种地。种种云。种种名。种种佛兴。种种道场。种种众会。演种种修多罗。说种种灌顶。种种诸乘。种种方便。种种清净。又于菩萨一一毛孔。念念常见无边佛海。坐种种道场。现种种神变。转种种法轮。说种种修多罗。恒不断绝。又于菩萨一一毛孔。见无边众生海。种种住处。种种形貌。种种作业。种种诸根。又于菩萨一一毛孔。见三世诸菩萨无边行门。所谓无边广大愿。无边差别地。无边波罗蜜。无边往昔事。无边大慈门。无边大悲云。无边大喜心。无边摄取众生方便。佛子。我于佛刹微尘数劫。念念如是观于菩萨一一毛孔。已所至处而不重至。已所见处而不重见。求其边际竟不可得。乃至见彼悉达太子。住于宫中。采女围绕。我以解脱力。观于菩萨一一毛孔。悉见三世法界中事。佛子。我唯得此观察菩萨三昧海解脱。如诸菩萨摩诃萨。究竟无量诸方便海。为一切众生现随类身。为一切众生说随乐行。于一一毛孔现无边色相海。知诸法性无性为性。知众生性同虚空相无有分别。知佛神力同于如如。遍一切处示现无边解脱境界。于一念中。能自在入广大法界。游戏一切诸地法门。而我云何能知能说彼功德行。善男子。此世界中。有佛母摩耶。汝诣彼问。菩萨云何修菩萨行。于诸世间无所染着。供养诸佛恒无休息。作菩萨业永不退转。离一切障碍。入菩萨解脱不由于他。住一切菩萨道。诣一切如来所。摄一切众生界。尽未来劫。修菩萨行。发大乘愿。增长一切众生善根。常无休息。尔时释迦瞿波女。欲重明此解脱义。承佛神力。即说颂言

  若有见菩萨　　修行种种行
  起善不善心　　菩萨皆摄取
  乃往久远世　　过百刹尘劫
  有劫名清净　　世界名光明
  此劫佛兴世　　六十千万亿
  最后天人主　　号曰法幢灯
  彼佛涅槃后　　有王名智山
  统领阎浮提　　一切无怨敌
  王有五百子　　端正能勇健
  其身悉清净　　见者皆欢喜
  彼王及王子　　信心供养佛
  护持其法藏　　亦乐勤修法
  太子名善光　　离垢多方便
  诸相皆圆满　　见者无厌足
  五百亿人俱　　出家行学道
  勇猛坚精进　　护持其佛法
  王都名智树　　千亿城围绕
  有林名静德　　众宝所庄严
  善光住彼林　　广宣佛正法
  辩才智慧力　　令众悉清净
  有时因乞食　　入彼王都城
  行止极安详　　正知心不乱
  城中有居士　　号曰善名称
  我时为彼女　　名为净日光
  时我于城中　　遇见善光明
  诸相极端严　　其心生染着
  次乞至我门　　我心增爱染
  即解身璎珞　　并珠置钵中
  虽以爱染心　　供养彼佛子
  二百五十劫　　不堕三恶趣
  或生天王家　　或作人王女
  恒见善光明　　妙相庄严身
  此后所经劫　　二百有五十
  生于善现家　　名为具妙德
  时我见太子　　而生尊重心
  愿得备瞻侍　　幸蒙哀纳受
  我时与太子　　觐佛胜日身
  恭敬供养毕　　即发菩提意
  于彼一劫中　　六十亿如来
  最后佛世尊　　名为广大解
  于彼得净眼　　了知诸法相
  普见受生处　　永除颠倒心
  我得观菩萨　　三昧境解脱
  一念入十方　　不思议刹海
  我见诸世界　　净秽种种别
  于净不贪乐　　于秽不憎恶
  普见诸世界　　如来坐道场
  皆于一念中　　悉放无量光
  一念能普入　　不可说众会
  亦知彼一切　　所得三昧门
  一念能悉知　　彼诸广大行
  无量地方便　　及以诸愿海
  我观菩萨身　　无边劫修行
  一一毛孔量　　求之不可得
  一一毛孔刹　　无数不可说
  地水火风轮　　靡不在其中
  种种诸建立　　种种诸形状
  种种体名号　　无边种庄严
  我见诸刹海　　不可说世界
  及见其中佛　　说法化众生
  不了菩萨身　　及彼身诸业
  亦不知心智　　诸劫所行道

尔时善财童子。顶礼其足。绕无数匝。辞退而去

大方广佛华严经卷第七十五大方广佛华严经卷第七十六

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十七

尔时善财童子。一心欲诣摩耶夫人所。即时获得观佛境界智。作如是念。是善知识。远离世间。住无所住。超过六处。离一切着。知无碍道。具净法身。以如幻业而现化身。以如幻智而观世间。以如幻愿而持佛身。随意生身。无生灭身。无来去身。非虚实身。不变坏身。无起尽身。所有诸相皆一相身。离二边身。无依处身。无穷尽身。离诸分别如影现身。知如梦身。了如像身。如净日身。普于十方而化现身。住于三世无变异身。非身心身。犹如虚空所行无碍。超诸世眼。唯是普贤净目所见。如是之人。我今云何而得亲近承事供养。与其同住。观其状貌。听其音声。思其语言。受其教诲。作是念已。有主城神。名曰宝眼。眷属围绕。于虚空中。而现其身。种种妙物以为严饰。手持无量众色宝华。以散善财。作如是言。善男子。应守护心城。谓不贪一切生死境界。应庄严心城。谓专意趣求如来十力。应净治心城。谓毕究断除悭嫉谄诳。应清凉心城。谓思惟一切诸法实性。应增长心城。谓成办一切助道之法。应严饰心城。谓造立诸禅解脱宫殿。应照耀心城。谓普入一切诸佛道场听受般若波罗蜜法。应增益心城。谓普摄一切佛方便道。应坚固心城。谓恒勤修习普贤行愿。应防护心城。谓常专御捍恶友魔军。应廓彻心城。谓开引一切佛智光明。应善补心城。谓听受一切佛所说法。应扶助心城。谓深信一切佛功德海。应广大心城。谓大慈普及一切世间。应善覆心城。谓集众善法。以覆其上应宽广心城。谓大悲哀愍一切众生。应开心城门。谓悉舍所有随应给施。应密护心城。谓防诸恶欲不令得入。应严肃心城。谓逐诸恶法不令其住。应决定心城。谓集一切智助道之法恒无退转。应安立心城。谓正念三世一切如来所有境界。应莹彻心城。谓明达一切佛正法轮修多罗中所有法门种种缘起。应部分心城。谓普晓示一切众生皆令得见萨婆若道。应住持心城。谓发一切三世如来诸大愿海。应富实心城。谓集一切周遍法界大福德聚。应令心城明了。谓普知众生根欲等法。应令心城自在。谓普摄一切十方法界。应令心城清净。谓正念一切诸佛如来。应知心城自性。谓知一切法皆无有性。应知心城如幻。谓以一切智了诸法性。佛子。菩萨摩诃萨。若能如是净修心城。则能积集一切善法。何以故。蠲除一切诸障难故。所谓见佛障。闻法障。供养如来障。摄诸众生障。净佛国土障。善男子。菩萨摩诃萨。以离如是诸障难故。若发希求善知识心。不用功力。则便得见。乃至究竟必当成佛。尔时有身众神。名莲华法德。及妙华光明无量诸神。前后围绕。从道场出住虚空中。于善财前。以妙音声。种种称叹摩耶夫人。从其耳珰放无量色相光明网。普照无边诸佛世界。令善财见十方国土一切诸佛。其光明网。右绕世间。经一匝已。然后还来。入善财顶。乃至遍入身诸毛孔。善财即得净光明眼。永离一切愚痴闇故。得离翳眼。能了一切众生性故。得离垢眼。能观一切法性门故。得净慧眼。能观一切佛国性故。得毗卢遮那眼。见佛法身故。得普光明眼。见佛平等不思议身故。得无碍光眼。观察一切刹海成坏故。得普照眼。见十方佛起大方便转正法轮故。得普境界眼。见无量佛以自在力调伏众生故。得普见眼。睹一切刹诸佛出兴故。时有守护菩萨法堂罗刹鬼王。名曰善眼。与其眷属万罗刹俱。于虚空中。以众妙华。散善财上。作如是言。善男子。菩萨。成就十法。则得亲近诸善知识。何等为十。所谓其心清净离诸谄诳。大悲平等普摄众生。知诸众生无有真实趣一切智心不退转。以信解力普入一切诸佛道场。得净慧眼了诸法性。大慈平等普覆众生。以智光明廓诸妄境。以甘露雨涤生死热。以广大眼彻鉴诸法。心常随顺诸善知识。是为十。复次佛子。菩萨。成就十种三昧门。则常现见诸善知识。何等为十。所谓法空清净轮三昧。观察十方海三昧。于一切境界不舍离不缺减三昧。普见一切佛出兴三昧。集一切功德藏三昧。心恒不舍善知识三昧。常见一切善知识生诸佛功德三昧。常不离一切善知识三昧。常供养一切善知识三昧。常于一切善知识所无过失三昧。佛子。菩萨。成就此十三昧门。常得亲近诸善知识。又得善知识转一切佛法轮三昧。得此三昧已。悉知诸佛体性平等。处处值遇诸善知识。说是语时。善财童子。仰视空中而答之言。善哉善哉。汝为哀愍摄受我故。方便教我。见善知识。愿为我说。云何往诣善知识所。于何方处城邑聚落。求善知识。罗刹答言。善男子。汝应普礼十方求善知识。正念思惟一切境界。求善知识。勇猛自在遍游十方。求善知识。观身观心如梦如影。求善知识。尔时善财。受行其教。即时睹见。大宝莲华从地涌出。金刚为茎。妙宝为藏。摩尼为叶。光明宝王以为其台。众宝色香以为其须。无数宝网弥覆其上。于其台上有一楼观。名普纳十方法界藏。奇妙严饰。金刚为地。千柱行列。一切皆以摩尼宝成。阎浮檀金以为其壁。众宝璎珞四面垂下。阶陛栏楯。周匝庄严。其楼观中。有如意宝莲华之座。种种众宝以为严饰。妙宝栏楯。宝衣间列。宝帐宝网。以覆其上。众宝缯幡。周匝垂下。微风徐动。光流响发。宝华幢中雨众妙华。宝铃铎中出美音声。宝户牖间垂诸璎珞。摩尼身中流出香水。宝象口中出莲华网。宝师子口吐妙香云。梵形宝轮出随乐音。金刚宝铃出诸菩萨大愿之音。宝月幢中出佛化形。净藏宝王现三世佛受生次第。日藏摩尼放大光明遍照十方一切佛刹。摩尼宝王。放一切佛圆满光明。毗卢遮那摩尼宝王。兴供养云供养一切诸佛如来。如意珠王。念念示现普贤神变充满法界。须弥宝王。出天宫殿天诸采女。种种妙音。歌赞如来不可思议。微妙功德。尔时善财。见如是座。复有无量众座围绕。摩耶夫人。在彼座上于一切众生前。现净色身。所谓超三界色身已出一切诸有趣故。随心乐色。身于一切世间无所著故。普周遍色身等于一切众生数故。无等比色身令一切众生灭倒见故。无量种色身随众生心种种现故。无边相色身普现种种诸形相故。普对现色身以大自在而示现故。化一切色身随其所应而现前故。恒示现色身尽众生界而无尽故。无去色身于一切趣无所灭故。无来色身于诸世间无所出故。不生色身无生起故。不灭色身离语言故。非实色身得如实故。非虚色身随世现故。无动色身生灭永离故。不坏色身法性不坏故。无相色身言语道断故。一相色身无相为相故。如像色身随心应现故。如幻色身幻智所生故。如焰色身但想所持故。如影色身随愿现生故。如梦色身随心而现故。法界色身性净如空故。大悲色身常护众生故。无碍色身念念周遍法界故。无边色身普净一切众生故。无量色身超出一切语言故。无住色身愿度一切世间故。无处色身恒化众生不断故。无生色身幻愿所成故。无胜色身超诸世间故。如实色身定心所现故。不生色身随众生业而出现故。如意珠色身普满一切众生愿故。无分别色身。但随众生分别起故。离分别色身一切众生不能知故。无尽色身尽诸众生生死际故。清净色身同于如来无分别故。如是身者。非色所有。色相如影像故。非受。世间苦受究竟灭故。非想。但随众生想所现故。非行。依如幻业而成就故。离识。菩萨愿智空无性故。一切众生语言断故。已得成就寂灭身故。尔时善财童子。又见摩耶夫人。随诸众生心之所乐。现超过一切世间色身。所谓或现超过他化自在天女身。乃至超过四大天王天女身。或现超过龙女身。乃至超过人女身。现如是等无量色身。饶益众生。集一切智助道之法。行于平等檀波罗蜜。大悲普覆一切世间。出生如来无量功德。修习增长一切智心。观察思惟诸法实性。获深忍海。具众定门。住于平等三昧境界。得如来定圆满光明。销竭众生烦恼巨海。心常正定未尝动乱。恒转清净不退法轮。善能了知一切佛法。恒以智慧观法实相。见诸如来心无厌足。知三世佛出兴次第。见佛三昧常现在前。了达如来出现于世。无量无数诸清净道。行于诸佛虚空境界。普摄众生各随其心。教化成就。入佛无量清净法身。成就大愿。净诸佛刹。究竟调伏一切众生。心恒遍入诸佛境界。出生菩萨自在神力。已得法身清净无染。而恒示现无量色身。摧一切魔力。成大善根力。出生正法力。具足诸佛力。得诸菩萨自在之力。速疾增长一切智力。得佛智光。普照一切。悉知无量众生心海。根性欲解种种差别。其身普遍十方刹海。悉知诸刹成坏之相。以广大眼见十方海。以周遍智知三世海。身普承事一切佛海。心恒纳受一切法海。修习一切如来功德。出生一切菩萨智慧。常乐观察一切菩萨。从初发心。乃至成就所行之道。常勤守护一切众生。常乐称扬诸佛功德。愿为一切菩萨之母。尔时善财童子。见摩耶夫人现如是等阎浮提微尘数诸方便门。既见是已。如摩耶夫人所现身数。善财亦现作尔许身。于一切处摩耶之前。恭敬礼拜。即时证得无量无数诸三昧门。分别观察。修行证入。从三昧起。右绕摩耶并其眷属。合掌而立。白言大圣。文殊师利菩萨。教我发阿耨多罗三藐三菩提心。求善知识。亲近供养。我于一一善知识所。皆往承事。无空过者。渐来至此。愿为我说。菩萨云何学菩萨行。而得成就。答言。佛子。我已成就菩萨大愿智幻解脱门。是故。常为诸菩萨母。佛子。如我于此阎浮提中迦毗罗城净饭王家。右胁而生悉达太子。现不思议自在神变。如是乃至尽此世界海。所有一切毗卢遮那如来。皆入我身。示现诞生自在神变。又善男子。我于净饭王宫。菩萨将欲下生之时。见菩萨身。一一毛孔咸放光明。名一切如来受生功德轮。一一毛孔。皆现不可说不可说佛刹微尘数菩萨受生庄严。彼诸光明。皆悉普照一切世界。照世界已。来入我顶乃至一切诸毛孔中。又彼光中。普现一切菩萨名号。受生神变。宫殿眷属。五欲自娱。又见出家。往诣道场。成等正觉。坐师子座。菩萨围绕。诸王供养。为诸大众。转正法轮。又见如来往昔修行菩萨道时。于诸佛所。恭敬供养。发菩提心。净佛国土。念念示现无量化身。充遍十方一切世界。乃至最后入般涅槃。如是等事靡不皆见。又善男子。彼妙光明入我身时。我身形量虽不逾本。然其实已超诸世间。所以者何。我身尔时。量同虚空。悉能容受十方菩萨受生庄严诸宫殿故。尔时菩萨。从兜率天。将降神时。有十佛刹微尘数诸菩萨。皆与菩萨。同愿同行。同善根同庄严。同解脱同智慧。诸地诸力。法身色身。乃至普贤神通行愿。悉皆同等。如是菩萨。前后围绕。又有八万诸龙王等。一切世主乘其宫殿。俱来供养。菩萨尔时。以神通力。与诸菩萨。普现一切兜率天宫。一一宫中。悉现十方一切世界。阎浮提内受生影像。方便教化无量众生。令诸菩萨。离诸懈怠。无所执着。又以神力。放大光明。普照世间。破诸黑闇。灭诸苦恼。令诸众生。皆识宿世所有业行。永出恶道。又为救护一切众生。普现其前。作诸神变。现如是等诸奇特事。与眷属俱。来入我身。彼诸菩萨。于我腹中。游行自在。或以三千大千世界。而为一步。或以不可说不可说佛刹微尘数世界。而为一步。又念念中。十方不可说不可说一切世界。诸如来所。菩萨众会。及四天王天。三十三天。乃至色界诸梵天王。欲见菩萨处胎神变。恭敬供养。听受正法。皆入我身。虽我腹中。悉能容受如是众会。而身不广大亦不迫窄。其诸菩萨。各见自处众会道场。清净严饰。善男子。如此四天下阎浮提中。菩萨受生我为其母。三千大千世界百亿四天下阎浮提中。悉亦如是。然我此身本来无二。非一处住。非多处住。何以故。以修菩萨大愿智幻庄严解脱门故。善男子。如今世尊我为其母。往昔所有无量诸佛悉亦如是而为其母。善男子。我昔曾作莲华池神。时有菩萨。于莲华藏。忽然化生。我即捧持。瞻侍养育。一切世间。皆共号我。为菩萨母。又我昔为菩提场神。时有菩萨。于我怀中。忽然化生。世亦号我。为菩萨母。善男子。有无量最后身菩萨。于此世界种种方便示现受生。我皆为母。善男子。如此世界贤劫之中。过去世时。拘留孙佛。拘那含牟尼佛。迦叶佛。及今世尊释迦牟尼佛。现受生时。我为其母。未来世中弥勒菩萨。从兜率天将降神时。放大光明。普照法界。示现一切诸菩萨众。受生神变。乃于人间。生大族家。调伏众生。我于彼时亦为其母。如是次第。有师子佛。法幢佛。善眼佛。净华佛。华德佛。提舍佛。弗沙佛。善意佛。金刚佛。离垢佛。月光佛。持炬佛。名称佛。金刚楯佛。清净义佛。绀身佛。到彼岸佛。宝焰山佛。持炬佛。莲华德佛。名称佛。无量功德佛。最胜灯佛。庄严身佛。善威仪佛。慈德佛。无住佛。大威光佛。无边音佛。胜怨敌佛。离疑惑佛。清净佛。大光佛。净心佛。云德佛。庄严顶髻佛。树王佛。宝珰佛。海慧佛。妙宝佛。华冠佛。满愿佛。大自在佛。妙德王佛。最尊胜佛。栴檀云佛。绀眼佛。胜慧佛。观察慧佛。炽盛王佛。坚固慧佛。自在名佛。师子王佛。自在佛。最胜顶佛。金刚智山佛。妙德藏佛。宝网严身佛。善慧佛。自在天佛。大天王佛。无依德佛。善施佛。焰慧佛。水天佛。得上味佛。出生无上功德佛。仙人侍卫佛。随世语言佛。功德自在幢佛。光幢佛。观身佛。妙身佛。香焰佛。金刚宝严佛。喜眼佛。离欲佛。高大身佛。财天佛。无上天佛。顺寂灭佛。智觉佛。灭贪佛。大焰王佛。寂诸有佛。毗舍佉天佛。金刚山佛。智焰德佛。安隐佛。师子出现佛。圆满清净佛。清净贤佛。第一义佛。百光明佛。最增上佛。深自在佛。大地王佛。庄严王佛。解脱佛。妙音佛。殊胜佛。自在佛。无上医王佛。功德月佛。无碍光佛。功德聚佛。月现佛。日天佛。出诸有佛。勇猛名称佛。光明门佛。娑罗王佛。最胜佛。药王佛。宝胜佛。金刚慧佛。无能胜佛。无能映蔽佛。众会王佛。大名称佛。敏持佛。无量光佛。大愿光佛。法自在不虚佛。不退地佛。净天佛。善天佛。坚固苦行佛。一切善友佛。解脱音佛。游戏王佛。灭邪曲佛。薝卜净光佛。具众德佛。最胜月佛。执明炬佛。殊妙身佛。不可说佛。最清净佛。友安众生佛。无量光佛。无畏音佛。水天德佛。不动慧光佛。华胜佛。月焰佛。不退慧佛。离爱佛。无著慧佛。集功德蕴佛。灭恶趣佛。普散华佛。师子吼佛。第一义佛。无碍见佛。破他军佛。不着相佛。离分别海佛。端严海佛。须弥山佛。无著智佛。无边座佛。清净住佛。随师行佛。最上施佛。常月佛。饶益王佛。不动聚佛。普摄受佛。饶益慧佛。持寿佛。无灭佛。具足名称佛。大威力佛。种种色相佛。无相慧佛。不动天佛。妙德难思佛。满月佛。解脱月佛。无上王佛。希有身佛。梵供养佛。不瞬佛。顺先古佛。最上业佛。顺法智佛。无胜天佛。不思议功德光佛。随法行佛。无量贤佛。普随顺自在佛。最尊天佛。如是乃至楼至如来。在贤劫中。于此三千大千世界。当成佛者。悉为其母。如于此三千大千世界。如是于此世界海十方无量诸世界一切劫中。诸有修行普贤行愿。为化一切诸众生者。我自见身悉为其母。尔时善财童子。白摩耶夫人言。大圣。得此解脱。经今几时。答言。善男子。乃往古世。过不可思议。非最后身菩萨。神通道眼所知劫数。尔时有劫名净光。世界名须弥德。虽有诸山五趣杂居。然其国土众宝所成。清净庄严无诸秽恶。有千亿四天下。有一四天下。名师子幢。于中有八十亿王城。有一王城。名自在幢。有转轮王。名大威德。彼王城北。有一道场。名满月光明。其道场神。名曰慈德。时有菩萨。名离垢幢。坐于道场。将成正觉。有一恶魔。名金色光。与其眷属无量众俱。至菩萨所。彼大威德转轮圣王。已得菩萨神通自在。化作兵众。其数倍多。围绕道场。诸魔惶怖。悉自奔散。故彼菩萨。得成阿耨多罗三藐三菩提。时道场神。见是事已。欢喜无量。便于彼王而生子想。顶礼佛足。作是愿言。此转轮王。在在生处乃至成佛。愿我常得与其为母。作是愿已。于此道场。复曾供养十那由他佛。善男子。于汝意云何。彼道场神。岂异人乎。我身是也。转轮王者。今世尊毗卢遮那是。我从于彼发愿已来。此佛世尊。于十方刹一切诸趣。处处受生。种诸善根。修菩萨行。教化成就一切众生。乃至示现住最后身。念念普于一切世界。示现菩萨受生神变。常为我子我常为母。善男子。过去现在十方世界无量诸佛。将成佛时。皆于脐中。放大光明。来照我身及我所住宫殿屋宅。彼最后生。我悉为母。善男子。我唯知此菩萨大愿智幻解脱门。如诸菩萨摩诃萨。具大悲藏。教化众生常无厌足。以自在力。一一毛孔。示现无量诸佛神变。我今云何能知能说彼功德行。善男子。于此世界三十三天。有王名正念。其王有女。名天主光。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。敬受其教。头面作礼。绕无数匝。恋慕瞻仰。却行而退

遂往天宫。见彼天女。礼足围绕。合掌前住。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。天女答言。善男子。我得菩萨解脱。名无碍念清净庄严。善男子。我以此解脱力。忆念过去。有最胜劫。名青莲华。我于彼劫中。供养恒河沙数诸佛如来。彼诸如来。从初出家。我皆瞻奉。守护供养。造僧伽蓝。营辨什物。又彼诸佛。从为菩萨住母胎时。诞生之时。行七步时。大师子吼时。住童子位在宫中时。向菩提树成正觉时。转正法轮现佛神变。教化调伏众生之时。如是一切诸所作事。从初发心。乃至法尽。我皆明忆。无有遗余。常现在前。念持不忘。又忆过去劫名善地。我于彼供养十恒河沙数诸佛如来。又过去劫。名为妙德。我于彼供养一佛世界微尘数诸佛如来。又劫名无所得。我于彼供养八十四亿百千那由他诸佛如来。又劫名善光。我于彼供养阎浮提微尘数诸佛如来。又劫名无量光。我于彼供养二十恒河沙数诸佛如来。又劫名最胜德。我于彼供养一恒河沙数诸佛如来。又劫名善悲。我于彼供养八十恒河沙数诸佛如来。又劫名胜游。我于彼供养六十恒河沙数诸佛如来。又劫名妙月。我于彼供养七十恒河沙数诸佛如来。善男子。如是忆念恒河沙劫。我常不舍诸佛如来应正等觉。从彼一切诸如来所。闻此无碍念清净庄严菩萨解脱。受持修行恒不忘失。如是先劫所有如来。从初菩萨。乃至法尽。一切所作。我以净严解脱之力。皆随忆念。明了现前。持而顺行曾无懈废。善男子。我唯知此无碍念清净解脱。如诸菩萨摩诃萨。出生死夜朗然明彻。永离痴冥未尝惛寐。心无诸盖身行轻安。于诸法性清净觉了。成就十力。开悟群生。而我云何能知能说彼功德行。善男子。迦毗罗城。有童子师。名曰遍友。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。以闻法故。欢喜踊跃。不思议善根。自然增广。顶礼其足。绕无数匝。辞退而去。从天宫下。渐向彼城。至遍友所。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。遍友答言。善男子。此有童子。名善知众艺。学菩萨字智。汝可问之。当为汝说。尔时善财。即至其所。头顶礼敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。时彼童子。告善财言。善男子。我得菩萨解脱。名善知众艺。我恒唱持此之字母。唱阿字时。入般若波罗蜜门。名以菩萨威力入无差别境界。唱多字时。入般若波罗蜜门。名无边差别门。唱波字时。入般若波罗蜜门。名普照法界。唱者字时。入般若波罗蜜门。名普轮断差别。唱那字时。入般若波罗蜜门。名得无依无上。唱逻字时。入般若波罗蜜门。名离依止无垢。唱柂(轻呼)字时。入般若波罗蜜门。名不退转方便。唱婆(蒲我切)字时。入般若波罗蜜门。名金刚场。唱荼(徒解切)字时。入般若波罗蜜门。名曰普轮。唱沙(史我切)字时。入般若波罗蜜门。名为海藏。唱缚(房可切)字时。入般若波罗蜜门。名普生安住。唱哆(都我切)字时。入般若波罗蜜门。名圆满光。唱也(以可切)字时。入般若波罗蜜门。名差别积聚。唱瑟吒字时。入般若波罗蜜门。名普光明息烦恼。唱迦字时。入般若波罗蜜门。名无差别云。唱娑(苏我切)字时。入般若波罗蜜门。名降霪大雨。唱么字时。入般若波罗蜜门。名大流湍激众峰齐峙。唱伽(上声轻呼)字时。入般若波罗蜜门。名普安立。唱他(他可切)字时。入般若波罗蜜门。名真如平等藏。唱社字时。入般若波罗蜜门。名入世间海清净。唱锁字时。入般若波罗蜜门。名念一切佛庄严。唱柂字时。入般若波罗蜜门。名观察拣择一切法聚。唱奢(尸苛切)字时。入般若波罗蜜门。名随顺一切佛教轮光明。唱佉字时。入般若波罗蜜门。名修因地智慧藏。唱叉(楚我切)字时。入般若波罗蜜门。名息诸业海藏。唱娑(苏纥切)多(上声呼)字时。入般若波罗蜜门。名蠲诸惑障开净光明。唱壤字时。入般若波罗蜜门。名作世间智慧门。唱曷攞多(上声)字时。入般若波罗蜜门。名生死境界智慧轮。唱婆(蒲饿切)字时。入般若波罗蜜门。名一切智宫殿圆满庄严。唱车(上声呼)字时。入般若波罗蜜门。名修行方便藏各别圆满。唱娑(苏纥切)么字时。入般若波罗蜜门。名随十方现见诸佛。唱诃婆(二字皆上声呼)字时。入般若波罗蜜门。名观察一切无缘众生方便摄受令出生无碍力。唱縒(七可切)字时。入般若波罗蜜门。名修行趣入一切功德海。唱伽(上声呼)字时。入般若波罗蜜门。名持一切法云坚固海藏。唱吒字时。入般若波罗蜜门。名随愿普见十方诸佛。唱拏(奶可切)字时。入般若波罗蜜门。名观察字轮有无尽诸亿字。唱娑(苏纥切)颇字时。入般若波罗蜜门。名化众生究竟处。唱娑(同前音)迦字时。入般若波罗蜜门。名广大藏无碍辩光明轮遍照。唱也(夷舸切)娑(苏舸切)字时。入般若波罗蜜门。名宣说一切佛法境界。唱室者字时。入般若波罗蜜门。名于一切众生界法雷遍吼。唱侘(耻加切)字时。入般若波罗蜜门。名以无我法开晓众生。唱陀字时。入般若波罗蜜门。名一切法轮差别藏。善男子。我唱如是字母时。此四十二般若波罗蜜门为首。入无量无数般若波罗蜜门。善男子。我唯知此善知众艺菩萨解脱。如诸菩萨摩诃萨。能于一切世出世间善巧之法。以智通达。到于彼岸。殊方异艺。咸综无遗。文字算数。蕴其深解。医方咒术。善疗众病。有诸众生。鬼魅所持。怨憎咒诅。恶星变怪。死尸奔逐。癫痫羸瘦。种种诸疾。咸能救之。使得痊愈。又善别知金玉珠贝。珊瑚琉璃。摩尼砗磲。鸡萨罗等。一切宝藏出生之处。品类不同。价直多少。村营乡邑。大小都城。宫殿苑园。岩泉薮泽。凡是一切人众所居。菩萨咸能随方摄护。又善观察天文地理。人相吉凶。鸟兽音声。云霞气候。年谷丰俭。国土安危。如是世间。所有技艺。莫不该练。尽其源本。又能分别出世之法。正名辨义。观察体相。随顺修行。智入其中。无疑无碍。无愚暗。无顽钝。无忧恼。无沉没。无不现证。而我云何能知能说彼功德行。善男子。此摩竭提国有一聚落。彼中有城。名婆咀那。有优婆夷号曰贤胜。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。头面敬礼知艺之足。绕无数匝。恋仰辞去

向聚落城。至贤胜所。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。贤胜答言。善男子。我得菩萨解脱。名无依处道场。既自开解。复为人说。又得无尽三昧。非彼三昧法。有尽无尽。以能出生一切智性眼无尽故。又能出生一切智性耳无尽故。又能出生一切智性鼻无尽故。又能出生一切智性舌无尽故。又能出生一切智性身无尽故。又能出生一切智性意无尽故。又能出生一切智性功德波涛无尽故。又能出生一切智性智慧光明无尽故。又能出生一切智性速疾神通无尽故。善男子。我唯知此无依处道场解脱。如诸菩萨摩诃萨。一切无著功德行。而我云何尽能知说。善男子。南方有城。名为沃田。彼有长者。名坚固解脱。汝可往问。菩萨云何学菩萨行。修菩萨道。尔时善财。礼贤胜足。绕无数匝。恋慕瞻仰。辞退南行

到于彼城。诣长者所。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无著念清净庄严。我自得是解脱已来。于十方佛所。勤求正法。无有休息。善男子。我唯知此无著念净庄严解脱。如诸菩萨摩诃萨。获无所畏大师子吼安住广大福智之聚。而我云何能知能说彼功德行。善男子。即此城中。有一长者。名为妙月。其长者宅。常有光明。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼坚固足。绕无数匝。辞退而行

向妙月所。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。妙月答言。善男子。我得菩萨解脱。名净智光明。善男子。我唯知此智光解脱。如诸菩萨摩诃萨。证得无量解脱法门。而我云何能知能说彼功德行。善男子。于此南方。有城名出生。彼有长者。名无胜军。汝诣彼问。菩萨云何学菩萨行。修菩萨道。是时善财礼妙月足。绕无数匝。恋仰辞去

渐向彼城。至长者所。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。长者答言。善男子。我得菩萨解脱。名无尽相。我以证此菩萨解脱。见无量佛得无尽藏。善男子。我唯知此无尽相解脱。如诸菩萨摩诃萨。得无限智无碍辩才。而我云何能知能说彼功德行。善男子。于此城南。有一聚落。名之为法。彼聚落中。有婆罗门。名最寂静。汝诣彼问。菩萨云何学菩萨行。修菩萨道。时善财童子。礼无胜军足。绕无数匝。恋仰辞去渐次南行。诣彼聚落。见最寂静。礼足围绕。合掌恭敬。于一面立。白言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。我闻圣者。善能诱诲。愿为我说。婆罗门答言。善男子。我得菩萨解脱。名诚愿语。过去现在。未来菩萨。以是语故。乃至于阿耨多罗三藐三菩提。无有退转。无已退。无现退。无当退。善男子。我以住于诚愿语故。随意所作。莫不成满。善男子。我唯知此诚语解脱。如诸菩萨摩诃萨。与诚愿语。行止无违。言必以诚。未曾虚妄。无量功德。因之出生。而我云何。能知能说。善男子。于此南方。有城名妙意华门。彼有童子。名曰德生。复有童女。名为有德。汝诣彼问。菩萨云何。学菩萨行。修菩萨道。时善财童子。于法尊重。礼婆罗门足。绕无数匝。恋仰而去

大方广佛华严经卷第七十六大方广佛华严经卷第七十七

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十八

尔时善财童子。渐次南行。至妙意华门城。见德生童子有德童女。顶礼其足。右绕毕已。于前合掌。而作是言。圣者。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。云何修菩萨道。唯愿慈哀。为我宣说。时童子童女。告善财言。善男子。我等证得菩萨解脱。名为幻住。得此解脱故。见一切世界皆幻住。因缘所生故。一切众生皆幻住。业烦恼所起故。一切世间皆幻住。无明有爱等展转缘生故。一切法皆幻住。我见等种种幻缘所生故。一切三世皆幻住。我见等颠倒智所生故。一切众生生灭生老病死忧悲苦恼皆幻住。虚妄分别所生故。一切国土皆幻住。想倒心倒见倒无明所现故。一切声闻辟支佛皆幻住。智断分别所成故。一切菩萨皆幻住。能自调伏教化众生诸行愿法之所成故。一切菩萨众会变化调伏诸所施为皆幻住。愿智幻所成故。善男子。幻境自性不可思议。善男子。我等二人。但能知此幻住解脱。如诸菩萨摩诃萨。善入无边诸事幻网。彼功德行。我等云何能知能说。时童子童女。说自解脱已。以不思议诸善根力。令善财身柔软光泽。而告之言。善男子。于此南方。有国名海岸。有园名大庄严。其中有一广大楼阁。名毗卢遮那庄严藏。从菩萨善根果报生。从菩萨念力愿力自在力神通力生。从菩萨善巧方便生。从菩萨福德智慧生。善男子。住不思议解脱菩萨。以大悲心。为诸众生。现如是境界。集如是庄严。弥勒菩萨摩诃萨。安处其中。为欲摄受本所生处父母眷属及诸人民。令成熟故。又欲令彼同受生同修行众生。于大乘中。得坚固故。又欲令彼一切众生。随住地随善根皆成就故。又欲为汝显示菩萨解脱门故。显示菩萨遍一切处受生自在故。显示菩萨以种种身普现一切众生之前常教化故。显示菩萨以大悲力普摄一切世间资财。而不厌故。显示菩萨具修诸行。知一切行。离诸相故。显示菩萨处处受生。了一切生皆无相故。汝诣彼问。菩萨云何行菩萨行。云何修菩萨道。云何学菩萨戒。云何净菩萨心。云何发菩萨愿。云何集菩萨助道具。云何入菩萨所住地。云何满菩萨波罗蜜。云何获菩萨无生忍。云何具菩萨功德法。云何事菩萨善知识。何以故。善男子。彼菩萨摩诃萨。通达一切菩萨行。了知一切众生心。常现其前。教化调伏。彼菩萨。已满一切波罗蜜。已住一切菩萨地。已证一切菩萨忍。已入一切菩萨位。已蒙授与具足记。已游一切菩萨境。已得一切佛神力。已蒙一切如来以一切智。甘露法水。而灌其顶。善男子。彼善知识。能润泽汝诸善根。能增长汝菩提心。能坚汝志。能益汝善。能长汝菩萨根。能示汝无碍法。能令汝入普贤地。能为汝说菩萨愿。能为汝说普贤行。能为汝说一切菩萨行愿所成功德。善男子。汝不应修一善。照一法。行一行。发一愿。得一记。住一忍。生究竟想。不应以限量心。行于六度。住于十地。净佛国土。事善知识。何以故。善男子。菩萨摩诃萨。应种无量诸善根。应集无量菩提具。应修无量菩提因。应学无量巧回向。应化无量众生界。应知无量众生心。应知无量众生根。应识无量众生解。应观无量众生行。应调伏无量众生。应断无量烦恼。应净无量业习。应灭无量邪见。应除无量杂染心。应发无量清净心。应拔无量苦毒箭。应涸无量爱欲海。应破无量无明暗。应摧无量我慢山。应断无量生死缚。应度无量诸有流。应竭无量受生海。应令无量众生出五欲淤泥。应使无量众生。离三界牢狱。应置无量众生于圣道中。应消灭无量贪欲行。应净治无量嗔恚行。应摧破无量愚痴行。应超无量魔网。应离无量魔业。应净治菩萨无量欲乐。应增长菩萨无量方便。应出生菩萨无量增上根。应明洁菩萨无量决定解。应趣入菩萨无量平等。应清净菩萨无量功德。应修治菩萨无量诸行。应示现菩萨无量随顺世间行。应生无量净信力。应住无量精进力。应净无量正念力。应满无量三昧力。应起无量净慧力。应坚无量胜解力。应集无量福德力。应长无量智慧力。应发起无量菩萨力。应圆满无量如来力。应分别无量法门。应了知无量法门。应清净无量法门。应生无量法光明。应作无量法照耀。应照无量品类根。应知无量烦恼病。应集无量妙法药。应疗无量众生疾。应严辨无量甘露供。应往诣无量佛国土。应供养无量诸如来。应入无量菩萨会。应受无量诸佛教。应忍无量众生罪。应灭无量恶道难。应令无量众生生善道。应以四摄摄无量众生。应修无量总持门。应生无量大愿门。应修无量大慈大愿力。应勤求无量法常无休息。应起无量思惟力。应起无量神通事。应净无量智光明。应往无量众生趣。应受无量诸有生。应现无量差别身。应知无量言辞法。应入无量差别心。应知菩萨大境界。应住菩萨大宫殿。应观菩萨甚深妙法。应知菩萨难知境界。应行菩萨难行诸行。应具菩萨尊重威德。应践菩萨难入正位。应知菩萨种种诸行。应现菩萨普遍神力。应受菩萨平等法云。应广菩萨无边行网。应满菩萨无边诸度。应受菩萨无量记别。应入菩萨无量忍门。应治菩萨无量诸地。应净菩萨无量法门。应同诸菩萨安住无边劫。供养无量佛。严净不可说佛国土。出生不可说菩萨愿。善男子。举要言之。应普修一切菩萨行。应普化一切众生界。应普入一切劫。应普生一切处。应普知一切世。应普行一切法。应普净一切刹。应普满一切愿。应普供一切佛。应普同一切菩萨愿。应普事一切善知识。善男子。汝求善知识。不应疲倦。见善知识。勿生厌足。请问善知识。勿惮劳苦。亲近善知识。勿怀退转。供养善知识。不应休息。受善知识教不应倒错。学善知识行不应疑惑。闻善知识演说出离门不应犹豫。见善知识随顺烦恼行勿生嫌怪。于善知识所生深信尊敬心不应变改。何以故。善男子。菩萨因善知识。听闻一切菩萨诸行。成就一切菩萨功德。出生一切菩萨大愿。引发一切菩萨善根。积集一切菩萨助道。开发一切菩萨法光明。显示一切菩萨出离门。修学一切菩萨清净戒。安住一切菩萨功德法。清净一切菩萨广大志。增长一切菩萨坚固心。具足一切菩萨陀罗尼辩才门。得一切菩萨清净藏。生一切菩萨定光明。得一切菩萨殊胜愿。与一切菩萨同一愿。闻一切菩萨殊胜法。得一切菩萨秘密处。至一切菩萨法宝洲。增一切菩萨善根芽。长一切菩萨智慧身。护一切菩萨深密藏。持一切菩萨福德聚。净一切菩萨受生道。受一切菩萨正法云。入一切菩萨大愿路。趣一切如来菩提果。摄取一切菩萨妙行。开示一切菩萨功德。往一切方听受妙法。赞一切菩萨广大威德。生一切菩萨大慈悲力。摄一切菩萨胜自在力。生一切菩萨菩提分。作一切菩萨利益事。善男子。菩萨由善知识任持不堕恶趣。由善知识摄受不退大乘。由善知识护念不毁犯菩萨戒。由善知识守护不随逐恶知识。由善知识养育不缺减菩萨法。由善知识摄取超越凡夫地。由善知识教诲超越二乘地。由善知识示导得出离世间。由善知识长养能不染世法。由承事善知识修一切菩萨行。由供养善知识具一切助道法。由亲近善知识不为业惑之所摧伏。由恃怙善知识势力坚固不怖诸魔。由依止善知识增长一切菩提分法。何以故。善男子。善知识者。能净诸障。能灭诸罪。能除诸难。能止诸恶。能破无明长夜黑暗。能坏诸见坚固牢狱。能出生死城。能舍世俗家。能截诸魔网。能拔众苦箭。能离无智险难处。能出邪见大旷野。能度诸有流。能离诸邪道。能示菩提路。能教菩萨法。能令安住菩萨行。能令趣向一切智。能净智慧眼。能长菩提心。能生大悲。能演妙行。能说波罗蜜。能摈恶知识。能令住诸地。能令获诸忍。能令修习一切善根。能令成办一切道具。能施与一切大功德。能令到一切种智位。能令欢喜集功德。能令踊跃修诸行。能令趣入甚深义。能令开示出离门。能令杜绝诸恶道。能令以法光照耀。能令以法雨润泽。能令消灭一切惑。能令舍离一切见。能令增长一切佛智慧。能令安住一切佛法门。善男子。善知识者如慈母。出生佛种故。如慈父。广大利益故。如乳母。守护不令作恶故。如教师。示其菩萨所学故。如善导。能示波罗蜜道故。如良医。能治烦恼诸病故。如雪山。增长一切智药故。如勇将。殄除一切怖畏故。如济客。令出生死暴流故。如船师。令到智慧宝洲故。善男子。常当如是正念思惟诸善知识。复次善男子。汝承事一切善知识。应发如大地心。荷负重任。无疲倦故。应发如金刚心。志愿坚固不可坏故。应发如铁围山心。一切诸苦无能动故。应发如给侍心。所有教令。皆随顺故。应发如弟子心。所有训诲。无违逆故。应发如僮仆心。不厌一切诸作务故。应发如养母心。受诸勤苦不告劳故。应发如佣作心。随所受教无违逆故。应发如除粪人心。离憍慢故。应发如已熟稼心。能低下故。应发如良马心。离恶性故。应发如大车心。能运重故。应发如调顺象心。恒伏从故。应发如须弥山心。不倾动故。应发如良犬心。不害主故。应发如旃荼罗心。离憍慢故。应发如犗牛心。无威怒故。应发如舟船心。往来不倦故。应发如桥梁心。济渡忘疲故。应发如孝子心。承顺颜色故。应发如王子心。遵行教命故。复次善男子。汝应于自身生病苦想。于善知识生医王想。于所说法生良药想。于所修行生除病想。又应于自身生远行想。于善知识生导师想。于所说法生正道想。于所修行生远达想。又应于自身生求度想。于善知识生船师想。于所说法生舟楫想。于所修行生到岸想。又应于自身生苗稼想。于善知识生龙王想。于所说法生时雨想。于所修行生成熟想。又应于自身生贫穷想。于善知识生毗沙门王想。于所说法生财宝想。于所修行生富饶想。又应于自身生弟子想。于善知识生良工想。于所说法生技艺想。于所修行生了知想。又应于自身生恐怖想。于善知识生勇健想。于所说法生器仗想。于所修行生破怨想。又应于自身生商人想。于善知识生导师想。于所说法生珍宝想。于所修行生捃拾想。又应于自身生儿子想。于善知识生父母想。于所说法生家业想。于所修行生绍继想。又应于自身生王子想。于善知识生大臣想。于所说法生王教想。于所修行生冠王冠想。服王服想。系王缯想。坐王殿想。善男子。汝应发如是心作如是意近善知识。何以故。以如是心近善知识。令其志愿永得清净。复次善男子。善知识者长诸善根。譬如雪山长诸药草。善知识者是佛法器。譬如大海吞纳众流。善知识者是功德处。譬如大海出生众宝。善知识者净菩提心。譬如猛火能炼真金。善知识者出过世法。如须弥山出于大海。善知识者不染世法。譬如莲华不着于水。善知识者不受诸恶。譬如大海不宿死尸。善知识者增长白法。譬如白月光色圆满。善知识者照明法界。譬如盛日照四天下。善知识者长菩萨身。譬如父母养育儿子。善男子。以要言之。菩萨摩诃萨。若能随顺善知识教。得十不可说百千亿那由他功德。净十不可说百千亿那由他深心。长十不可说百千亿那由他菩萨根。净十不可说百千亿那由他菩萨力。断十不可说百千亿阿僧祇障。超十不可说百千亿阿僧祇魔境。入十不可说百千亿阿僧祇法门。满十不可说百千亿阿僧祇助道。修十不可说百千亿阿僧祇妙行。发十不可说百千亿阿僧祇大愿。善男子。我复略说一切菩萨行。一切菩萨波罗蜜。一切菩萨地。一切菩萨忍。一切菩萨总持门。一切菩萨三昧门。一切菩萨神通智。一切菩萨回向。一切菩萨愿。一切菩萨成就佛法。皆由善知识力。以善知识而为根本。依善知识生。依善知识出。依善知识长。依善知识住。善知识为因缘。善知识能发起。时善财童子。闻善知识如是功德。能开示无量菩萨妙行。能成就无量广大佛法。踊跃欢喜。顶礼德生及有德足。绕无量匝。殷勤瞻仰。辞退而去

尔时善财童子。善知识教。润泽其心。正念思惟诸菩萨行。向海岸国。自忆往世不修礼敬。即时发意勤力而行。复忆往世身心不净。即时发意专自治洁。复忆往世作诸恶业。即时发意专自防断。复忆往世起诸妄想。即时发意恒正思惟。复忆往世所修诸行但为自身。即时发意令心广大普及含识。复忆往世追求欲境常自损耗无有滋味。即时发意修行佛法长养诸根以自安隐。复忆往世起邪思念颠倒相应。即时发意生正见心起菩萨愿。复忆往世日夜劬劳作诸恶事。即时发意起大精进成就佛法。复忆往世受五趣生于自他身皆无利益。即时发意愿以其身饶益众生成就佛法承事一切诸善知识。如是思惟生大欢喜。复观此身。是生老病死众苦之宅。愿尽未来劫。修菩萨道。教化众生。见诸如来成就佛法。游行一切佛刹。承事一切法师。住持一切佛教。寻求一切法侣。见一切善知识。集一切诸佛法。与一切菩萨愿智身。而作因缘。作是念时。长不思议无量善根。即于一切菩萨。深信尊重。生希有想。生大师想。诸根清净善法增益。起一切菩萨恭敬供养。作一切菩萨曲躬合掌。生一切菩萨普见世间眼。起一切菩萨普念众生想。现一切菩萨无量愿化身。出一切菩萨清净赞说音。想见过现一切诸佛及诸菩萨。于一切处。示现成道。神通变化。乃至无有一毛端处而不周遍。又得清净智光明眼。见一切菩萨所行境界。其心普入十方刹网。其愿普遍虚空法界。三世平等无有休息。如是一切皆以信受善知识教之所致耳。善财童子。以如是尊重。如是供养。如是称赞。如是观察。如是愿力。如是想念。如是无量智慧境界。于毗卢遮那庄严藏大楼阁前。五体投地。暂时敛念。思惟观察。以深信解。大愿力故。入遍一切处智慧身平等门。普现其身。在于一切如来前。一切菩萨前。一切善知识前。一切如来塔庙前。一切如来形像前。一切诸佛诸菩萨住处前。一切法宝前。一切声闻辟支佛及其塔庙前。一切圣众福田前。一切父母尊者前。一切十方众生前。皆如上说。尊重礼赞。尽未来际无有休息。等虚空无边量故。等法界无障碍故。等实际遍一切故。等如来无分别故。犹如影。随智现故。犹如梦。从思起故。犹如像。示一切故。犹如响。缘所发故。无有生。递兴谢故。无有性。随缘转故。又决定知一切诸报皆从业起。一切诸果皆从因起。一切诸业皆从习起。一切佛兴皆从信起。一切化现诸供养事。皆悉从于决定解起。一切化佛从敬心起。一切佛法从善根起。一切化身从方便起。一切佛事从大愿起。一切菩萨所修诸行。从回向起。一切法界广大庄严。从一切智境界而起。离于断见知回向故。离于常见知无生故。离无因见知正因故。离颠倒见知如实理故。离自在见知不由他故。离自他见知从缘起故。离边执见知法界无边故。离往来见知如影像故。离有无见知不生灭故。离一切法见知空无生故。知不自在故。知愿力出生故。离一切相见入无相际故。知一切法如种生芽故。如印生文故。知质如像故。知声如响故。知境如梦故。知业如幻故。了世心现故。了果因起故。了报业集故。了知一切诸功德法。皆从菩萨善巧方便所流出故。善财童子。入如是智。端心洁念。于楼观前。举体投地。殷勤顶礼。不思议善根。流注身心。清凉悦泽。从地而起。一心瞻仰。目不暂舍。合掌围绕。经无量匝。作是念言。此大楼阁。是解空无相无愿者之所住处。是于一切法无分别者之所住处。是了法界无差别者之所住处。是知一切众生不可得者之所住处。是知一切法无生者之所住处。是不着一切世间者之所住处。是不着一切窟宅者之所住处。是不乐一切聚落者之所住处。是不依一切境界者之所住处。是离一切想者之所住处。是知一切法无自性者之所住处。是断一切分别业者之所住处。是离一切想心意识者之所住处。是不入不出一切道者之所住处。是入一切甚深般若波罗蜜者之所住处。是能以方便住普门法界者之所住处。是息灭一切烦恼火者之所住处。是以增上慧除断一切见爱慢者之所住处。是出生一切诸禅解脱三昧通明而游戏者之所住处。是观察一切菩萨三昧境界者之所住处。是安住一切如来所者之所住处。是以一劫入一切劫。以一切劫入一劫。而不坏其相者之所住处。是以一刹入一切刹。以一切刹入一刹。而不坏其相者之所住处。是以一法入一切法。以一切法入一法。而不坏其相者之所住处。是以一众生入一切众生。以一切众生入一众生。而不坏其相者之所住处。是以一佛入一切佛。以一切佛入一佛。而不坏其相者之所住处。是于一念中而知一切三世者之所住处。是于一念中往诣一切国土者之所住处。是于一切众生前悉现其身者之所住处。是心常利益一切世间者之所住处。是能遍至一切处者之所住处。是虽已出一切世间。为化众生故而恒于中现身者之所住处。是不着一切刹为供养诸佛故而游一切刹者之所住处。是不动本处能普诣一切佛刹而庄严者之所住处。是亲近一切佛而不起佛想者之所住处。是依止一切善知识而不起善知识想者之所住处。是住一切魔宫而不耽着欲境界者之所住处。是永离一切心想者之所住处。是虽于一切众生中而现其身。然于自他不生二想者之所住处。是能普入一切世界。而于法界无差别想者之所住处。是愿住未来一切劫。而于诸劫无长短想者之所住处。是不离一毛端处而普现身一切世界者之所住处。是能演说难遭遇法者之所住处。是能住难知法甚深法无二法无相法无对治法无所得法无戏论法者之所住处。是住大慈大悲者之所住处。是已度一切二乘智。已超一切魔境界。已于世法无所染。已到菩萨所到岸。已住如来所住处者之所住处。是虽离一切诸相而亦不入声闻正位。虽了一切法无生而亦不住无生法性者之所住处。是虽观不净而不证离贪法亦不与贪欲俱。虽修于慈而不证离嗔法亦不与嗔垢俱。虽观缘起而不证离痴法亦不与痴惑俱者之所住处。是虽住四禅而不随禅生。虽行四无量。为化众生故而不生色界。虽修四无色定以大悲故而不住无色界者之所住处。是虽勤修止观为化众生故而不证明脱。虽行于舍而不舍化众生事者之所住处。是虽观于空而不起空见。虽行无相而常化着相众生。虽行无愿而不舍菩提行愿者之所住处。是虽于一切业烦恼中而得自在。为化众生故而现随顺诸业烦恼。虽无生死为化众生故示受生死虽已离一切趣为化众生故示入诸趣者之所住处。是虽行于慈而于诸众生无所爱恋。虽行于悲而于诸众生无所取着。虽行于喜而观苦众生心常哀愍。虽行于舍而不废舍利益他事者之所住处。是虽行九次第定而不厌离欲界受生。虽知一切法无生无灭而不于实际作证。虽入三解脱门而不取声闻解脱。虽观四圣谛而不住小乘圣果。虽观甚深缘起而不住究竟寂灭。虽修八圣道而不求永出世间。虽超凡夫地而不堕声闻辟支佛地。虽观五取蕴而不永灭诸蕴。虽超出四魔而不分别诸魔。虽不着六处而不永灭六处。虽安住真如而不堕实际。虽说一切乘而不舍大乘。此大楼阁是住如是等一切诸功德者之所住处。尔时善财童子。而说颂言

  此是大悲清净智　　利益世间慈氏尊
  灌顶地中佛长子　　入如来境之住处
  一切名闻诸佛子　　已入大乘解脱门
  游行法界心无著　　此无等者之住处
  施戒忍进禅智慧　　方便愿力及神通
  如是大乘诸度法　　悉具足者之住处
  智慧广大如虚空　　普知三世一切法
  无碍无依无所取　　了诸有者之住处
  善能解了一切法　　无性无生无所依
  如鸟飞空得自在　　此大智者之住处
  了知三毒真实性　　分别因缘虚妄起
  亦不厌彼而求出　　此寂静人之住处
  三解脱门八圣道　　诸蕴处界及缘起
  悉能观察不趣寂　　此善巧人之住处
  十方国土及众生　　以无碍智咸观察
  了性皆空不分别　　此寂灭人之住处
  普行法界悉无碍　　而求行性不可得
  如风行空无所行　　此无依者之住处
  普见恶道群生类　　受诸楚毒无所归
  放大慈光悉除灭　　此哀愍者之住处
  见诸众生失正道　　譬如生盲践畏途
  引其令入解脱城　　此大导师之住处
  见诸众生入魔网　　生老病死常逼迫
  令其解脱得慰安　　此勇健人之住处
  见诸众生婴惑病　　而兴广大悲愍心
  以智慧药悉除灭　　此大医王之住处
  见诸群生没有海　　沉沦忧迫受众苦
  悉以法船而救之　　此善度者之住处
  见诸众生在惑海　　能发菩提妙宝心
  悉入其中而济拔　　此善渔人之住处
  恒以大愿慈悲眼　　普观一切诸众生
  从诸有海而拔出　　此金翅王之住处
  譬如日月在虚空　　一切世间靡不烛
  智慧光明亦如是　　此照世者之住处
  菩萨为化一众生　　普尽未来无量劫
  如为一人一切尔　　此救世者之住处
  于一国土化众生　　尽未来劫无休息
  一一国土咸如是　　此坚固意之住处
  十方诸佛所说法　　一座普受咸令尽
  尽未来劫恒悉然　　此智海人之住处
  遍游一切世界海　　普入一切道场海
  供养一切如来海　　此修行者之住处
  修行一切妙行海　　发起无边大愿海
  如是经于众劫海　　此功德者之住处
  一毛端处无量刹　　佛众生劫不可说
  如是明见靡不周　　此无碍眼之住处
  一念普摄无边劫　　国土诸佛及众生
  智慧无碍悉正知　　此具德人之住处
  十方国土碎为尘　　一切大海以毛滴
  菩萨发愿数如是　　此无碍者之住处
  成就总持三昧门　　大愿诸禅及解脱
  一一皆住无边劫　　此真佛子之住处
  无量无边诸佛子　　种种说法度众生
  亦说世间众技术　　此修行者之住处
  成就神通方便智　　修行如幻妙法门
  十方五趣悉现生　　此无碍者之住处
  菩萨始从初发心　　具足修行一切行
  化身无量遍法界　　此神力者之住处
  一念成就菩提道　　普作无边智慧业
  世情思虑悉发狂　　此难量者之住处
  成就神通无障碍　　游行法界靡不周
  其心未尝有所得　　此净慧者之住处
  菩萨修行无碍慧　　入诸国土无所著
  以无二智普照明　　此无我者之住处
  了知诸法无依止　　本性寂灭同虚空
  常行如是境界中　　此离垢人之住处
  普见群生受诸苦　　发大仁慈智慧心
  愿常利益诸世间　　此悲愍者之住处
  佛子住于此　　普现众生前
  犹如日月轮　　遍除生死暗
  佛子住于此　　普顺众生心
  变现无量身　　充满十方刹
  佛子住于此　　遍游诸世界
  一切如来所　　无量无数劫
  佛子住于此　　思量诸佛法
  无量无数劫　　其心无厌倦
  佛子住于此　　念念入三昧
  一一三昧门　　阐明诸佛境
  佛子住于此　　悉知一切刹
  无量无数劫　　众生佛名号
  佛子住于此　　一念摄诸劫
  但随众生心　　而无分别想
  佛子住于此　　修习诸三昧
  一一心念中　　了知三世法
  佛子住于此　　结跏身不动
  普现一切刹　　一切诸趣中
  佛子住于此　　饮诸佛法海
  深入智慧海　　具足功德海
  佛子住于此　　悉知诸刹数
  世数众生数　　佛名数亦然
  佛子住于此　　一念悉能了
  一切三世中　　国土之成坏
  佛子住于此　　普知佛行愿
  菩萨所修行　　众生根性欲
  佛子住于此　　见一微尘中
  无量刹道场　　众生及诸劫
  如一微尘内　　一切尘亦然
  种种咸具足　　处处皆无碍
  佛子住于此　　普观一切法
  众生刹及世　　无起无所有
  观察众生等　　法等如来等
  刹等诸愿等　　三世悉平等
  佛子住于此　　教化诸群生
  供养诸如来　　思惟诸法性
  无量千万劫　　所修愿智行
  广大不可量　　称扬莫能尽
  彼诸大勇猛　　所行无障碍
  安住于此中　　我合掌敬礼
  诸佛之长子　　圣德慈氏尊
  我今恭敬礼　　愿垂顾念我

尔时善财童子。以如是等一切菩萨无量称扬赞叹法。而赞毗卢遮那庄严藏大楼阁中诸菩萨已。曲躬合掌恭敬顶礼。一心愿见弥勒菩萨亲近供养。乃见弥勒菩萨摩诃萨。从别处来。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽王。释梵护世。及本生处。无量眷属。婆罗门众。及余无数。百千众生。前后围绕。而共来向庄严藏大楼观所。善财见已。欢喜踊跃。五体投地。时弥勒菩萨。观察善财。指示大众。叹其功德。而说颂曰

  汝等观善财　　智慧心清净
  为求菩提行　　而来至我所
  善来圆满慈　　善来清净悲
  善来寂灭眼　　修行无懈倦
  善来清净意　　善来广大心
  善来不退根　　修行无懈倦
  善来不动行　　常求善知识
  了达一切法　　调伏诸群生
  善来行妙道　　善来住功德
  善来趣佛果　　未曾有疲倦
  善来德为体　　善来法所滋
  善来无边行　　世间难可见
  善来离迷惑　　世法不能染
  利衰毁誉等　　一切无分别
  善来施安乐　　调柔堪受化
  谄诳嗔慢心　　一切悉除灭
  善来真佛子　　普诣于十方
  增长诸功德　　调柔无懈惓
  善来三世智　　遍知一切法
  普生功德藏　　修行不疲厌
  文殊德云等　　一切诸佛子
  令汝至我所　　示汝无碍处
  具修菩萨行　　普摄诸群生
  如是广大人　　今来至我所
  为求诸如来　　清净之境界
  问诸广大愿　　而来至我所
  去来现在佛　　所成诸行业
  汝欲皆修学　　而来至我所
  汝于善知识　　欲求微妙法
  欲受菩萨行　　而来至我所
  汝念善知识　　诸佛所称叹
  令汝成菩提　　而来至我所
  汝念善知识　　生我如父母
  养我如乳母　　增我菩提分
  如医疗众疾　　如天洒甘露
  如日示正道　　如月转净轮
  如山不动摇　　如海无增减
  如船师济渡　　而来至我所
  汝观善知识　　犹如大猛将
  亦如大商主　　又如大导师
  能建正法幢　　能示佛功德
  能灭诸恶道　　能开善趣门
  能显诸佛身　　能守诸佛藏
  能持诸佛法　　是故愿瞻奉
  欲满清净智　　欲具端正身
  欲生尊贵家　　而来至我所
  汝等观此人　　亲近善知识
  随其所修学　　一切应顺行
  以昔福因缘　　文殊令发心
  随顺无违逆　　修行不懈倦
  父母与亲属　　宫殿及财产
  一切皆舍离　　谦下求知识
  净治如是意　　永离世间身
  当生佛国土　　受诸胜果报
  善财见众生　　生老病死苦
  为发大悲意　　勤修无上道
  善财见众生　　五趣常流转
  为求金刚智　　破彼诸苦轮
  善财见众生　　心田甚荒秽
  为除三毒刺　　专求利智犁
  众生处痴暗　　盲冥失正道
  善财为导师　　示其安隐处
  忍铠解脱乘　　智慧为利剑
  能于三有内　　破诸烦恼贼
  善财法船师　　普济诸含识
  令过尔焰海　　疾至净宝洲
  善财正觉日　　智光大愿轮
  周行法界空　　普照群迷宅
  善财正觉月　　白法悉圆满
  慈定清凉光　　等照众生心
  善财胜智海　　依于直心住
  菩提行渐深　　出生众法宝
  善财大心龙　　升于法界空
  兴云霔甘泽　　生成一切果
  善财然法灯　　信炷慈悲油
  念器功德光　　灭除三毒暗
  觉心迦罗逻　　悲胞慈为肉
  菩提分肢节　　长于如来藏
  增长福德藏　　清净智慧藏
  开显方便藏　　出生大愿藏
  如是大庄严　　救护诸群生
  一切天人中　　难闻难可见
  如是智慧树　　根深不可动
  众行渐增长　　普荫诸群生
  欲生一切德　　欲问一切法
  欲断一切疑　　专求善知识
  欲破诸惑魔　　欲除诸见垢
  欲解众生缚　　专求善知识
  当灭诸恶道　　当示人天路
  令修功德行　　疾入涅槃城
  当度诸见难　　当截诸见网
  当枯爱欲水　　当示三有道
  当为世依怙　　当作世光明
  当成三界师　　示其解脱处
  亦当令世间　　普离诸想着
  普觉烦恼睡　　普出爱欲泥
  当了种种法　　当净种种刹
  一切咸究竟　　其心大欢喜
  汝行极调柔　　汝心甚清净
  所欲修功德　　一切当圆满
  不久见诸佛　　了达一切法
  严净众刹海　　成就大菩提
  当满诸行海　　当知诸法海
  当度众生海　　如是修诸行
  当到功德岸　　当生诸善品
  当与佛子等　　如是心决定
  当断一切惑　　当净一切业
  当伏一切魔　　满足如是愿
  当生妙智道　　当开正法道
  不久当舍离　　惑业诸苦道
  一切众生轮　　沉迷诸有轮
  汝当转法轮　　令其断苦轮
  汝当持佛种　　汝当净法种
  汝当集僧种　　三世悉周遍
  当断众爱网　　当裂众见网
  当救众苦网　　当成此愿网
  当度众生界　　当净国土界
  当集智慧界　　当成此心界
  当令众生喜　　当令菩萨喜
  当令诸佛喜　　当成此欢喜
  当见一切趣　　当见一切刹
  当见一切法　　当成此佛见
  当放破暗光　　当放息热光
  当放灭恶光　　涤除三有苦
  当开天趣门　　当开佛道门
  当示解脱门　　普使众生入
  当示于正道　　当绝于邪道
  如是勤修行　　成就菩提道
  当修功德海　　当度三有海
  普使群生海　　出于众苦海
  当于众生海　　消竭烦恼海
  令修诸行海　　疾入大智海
  汝当增智海　　汝当修行海
  诸佛大愿海　　汝当咸满足
  汝当入刹海　　汝当观众海
  汝当以智力　　普饮诸法海
  当觐诸佛云　　当起供养云
  当听妙法云　　当兴此愿云
  普游三有室　　普坏众惑室
  普入如来室　　当行如是道
  普入三昧门　　普游解脱门
  普住神通门　　周行于法界
  普现众生前　　普对诸佛前
  譬如日月光　　当成如是力
  所行无动乱　　所行无染着
  如鸟行虚空　　当成此妙用
  譬如因陀网　　刹网如是住
  汝当悉往诣　　如风无所碍
  汝当入法界　　遍往诸世界
  普见三世佛　　心生大欢喜
  汝于诸法门　　已得及当得
  应生大喜跃　　无贪亦无厌
  汝是功德器　　能随诸佛教
  能修菩萨行　　得见此奇特
  如是诸佛子　　亿劫难可遇
  况见其功德　　所修诸妙道
  汝生于人中　　大获诸善利
  得见文殊等　　无量诸功德
  已离诸恶道　　已出诸难处
  已超众苦患　　善哉勿懈怠
  已离凡夫地　　已住菩萨地
  当满智慧地　　速入如来地
  菩萨行如海　　佛智同虚空
  汝愿亦复然　　应生大欣庆
  诸根不懈倦　　志愿恒决定
  亲近善知识　　不久悉成满
  菩萨种种行　　皆为调众生
  普行诸法门　　慎勿生疑惑
  汝具难思福　　及以真实信
  是故于今日　　得见诸佛子
  汝见诸佛子　　悉获广大利
  一一诸大愿　　一切咸信受
  汝于三有中　　能修菩萨行
  是故诸佛子　　示汝解脱门
  非是法器人　　与佛子同住
  设经无量劫　　莫知其境界
  汝见诸菩萨　　得闻如是法
  世间甚难有　　应生大喜庆
  诸佛护念汝　　菩萨摄受汝
  能顺其教行　　善哉住寿命
  已生菩萨家　　已具菩萨德
  已长如来种　　当升灌顶位
  不久汝当得　　与诸佛子等
  见苦恼众生　　悉置安隐处
  如下如是种　　必获如是果
  我今庆慰汝　　汝应大欣悦
  无量诸菩萨　　无量劫行道
  未能成此行　　今汝皆获得
  信乐坚进力　　善财成此行
  若有敬慕心　　亦当如是学
  一切功德行　　皆从愿欲生
  善财已了知　　常乐勤修习
  如龙布密云　　必当霔大雨
  菩萨起愿智　　决定修诸行
  若有善知识　　示汝普贤行
  汝当好承事　　慎勿生疑惑
  汝于无量劫　　为欲妄舍身
  今为求菩提　　此舍方为善
  汝于无量劫　　具受生死苦
  不曾事诸佛　　未闻如是行
  汝今得人身　　值佛善知识
  听受菩提行　　云何不欢喜
  虽遇佛兴世　　亦值善知识
  其心不清净　　不闻如是法
  若于善知识　　信乐心尊重
  离疑不疲厌　　乃闻如是法
  若有闻此法　　而兴誓愿心
  当知如是人　　已获广大利
  如是心清净　　常得近诸佛
  亦近诸菩萨　　决定成菩提
  若入此法门　　则具诸功德
  永离众恶趣　　不受一切苦
  不久舍此身　　往生佛国土
  常见十方佛　　及以诸菩萨
  往因今净解　　及事善友力
  增长诸功德　　如水生莲华
  乐事善知识　　勤供一切佛
  专心听闻法　　常行勿懈倦
  汝是真法器　　当具一切法
  当修一切道　　当满一切愿
  汝以信解心　　而来礼敬我
  不久当普入　　一切诸佛会
  善哉真佛子　　恭敬一切佛
  不久具诸行　　到佛功德岸
  汝当往大智　　文殊师利所
  彼当令汝得　　普贤深妙行

尔时弥勒菩萨摩诃萨。在众会前。称赞善财大功德藏。善财闻已欢喜踊跃。身毛皆竖悲泣哽噎。起立合掌恭敬瞻仰。绕无量匝。以文殊师利心念力故。众华璎珞种种妙宝。不觉忽然自盈其手。善财欢喜。即以奉散弥勒菩萨摩诃萨上。时弥勒菩萨。摩善财顶。为说颂言

  善哉善哉真佛子　　普策诸根无懈倦
  不久当具诸功德　　犹如文殊及与我

时善财童子。以颂答曰

  我念善知识　　亿劫难值遇
  今得咸亲近　　而来诣尊所
  我以文殊故　　见诸难见者
  彼大功德尊　　愿速还瞻觐

大方广佛华严经卷第七十七大方广佛华严经卷第七十八

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之十九

尔时善财童子。合掌恭敬。重白弥勒菩萨摩诃萨言。大圣。我已先发阿耨多罗三藐三菩提心。而我未知菩萨云何学菩萨行。云何修菩萨道。大圣。一切如来授尊者记。一生当得阿耨多罗三藐三菩提。若一生当得无上菩提。则已超越一切菩萨所住处。则已出过一切菩萨离生位。则已圆满一切波罗蜜。则已深入一切诸忍门。则已具足一切菩萨地。则已游戏一切解脱门。则已成就一切三昧法。则已通达一切菩萨行。则已证得一切陀罗尼辩才。则已于一切菩萨自在中而得自在则已积集一切菩萨助道法。则已游戏智慧方便。则已出生大神通智。则已成就一切学处。则已圆满一切妙行。则已满足一切大愿。则已领受一切佛所记。则已了知一切诸乘门。则已堪受一切如来所护念。则已能摄一切佛菩提。则已能持一切佛法藏。则已能持一切诸佛菩萨秘密藏。则已能于一切菩萨众中为上首。则已能为破烦恼魔军大勇将。则已能作出生死旷野大导师。则已能作治诸惑重病大医王。则已能于一切众生中为最胜。则已能于一切世主中得自在。则已能于一切圣人中最第一。则已能于一切声闻独觉中最增上。则已能于生死海中为船师。则已能布调伏一切众生网。则已能观一切众生根。则已能摄一切众生界。则已能守护一切菩萨众。则已能谈议一切菩萨事。则已能往诣一切如来所。则已能住止一切如来会。则已能现身一切众生前。则已能于一切世法无所染。则已能超越一切魔境界。则已能安住一切佛境界。则已能到一切菩萨无碍境。则已能精勤供养一切佛。则已与一切诸佛法同体性。已系妙法缯。已受佛灌顶。已住一切智。已能普生一切佛法。已能速践一切智位。大圣。菩萨云何学菩萨行。云何修菩萨道。随所修学。疾得具足一切佛法。悉能度脱所念众生。普能成满所发大愿。普能究竟所起诸行。普能安慰一切天人。不负自身。不断三宝。不虚一切佛菩萨种。能持一切诸佛法眼。如是等事愿皆为说

尔时。弥勒菩萨摩诃萨。观察一切道场众会。指示善财而作是言。诸仁者。汝等见此长者子今于我所问菩萨行诸功德不。诸仁者。此长者子勇猛精进志愿无杂。深心坚固恒不退转。具胜希望。如救头然。无有厌足。乐善知识亲近供养。处处寻求承事请法。诸仁者。此长者子。曩于福城受文殊教。展转南行求善知识。经由一百一十善知识已。然后而来至于我所。未曾暂起一念疲懈。诸仁者。此长者子。甚为难有。趣向大乘。乘于大慧。发大勇猛。擐大悲甲。以大慈心救护众生。起大精进波罗蜜行。作大商主护诸众生。为大法船度诸有海。住于大道。集大法宝。修诸广大助道之法。如是之人。难可得闻。难可得见。难得亲近同居共行。何以故。此长者子。发心救护一切众生。令一切众生解脱诸苦。超诸恶趣。离诸险难。破无明闇。出生死野。息诸趣轮。度魔境界。不着世法。出欲淤泥。断贪鞅解见缚。坏想宅绝迷道。摧慢幢拔惑箭。撤睡盖裂爱网。灭无明度有流。离谄幻净心垢。断痴惑出生死。诸仁者。此长者子。为被四流漂泊者造大法船。为被见泥没溺者立大法桥。为被痴暗昏迷者然大智灯。为行生死旷野者开示圣道。为婴烦恼重病者调和法药。为遭生老死苦者饮以甘露令其安隐。为入贪恚痴火者沃以定水使得清凉。多忧恼者慰谕使安。系有狱者晓诲令出。入见网者开以智剑。住界城者示诸脱门。在险难者导安隐处。惧结贼者与无畏法。堕恶趣者授慈悲手。拘害蕴者示涅槃城。界蛇所缠解以圣道。着于六处空聚落者以智慧光引之令出。住邪济者令入正济。近恶友者示其善友。乐凡法者诲以圣法。着生死者令其趣入一切智城。诸仁者。此长者子。恒以此行。救护众生。发菩提心未尝休息。求大乘道曾无懈倦。饮诸法水不生厌足。恒勤积集助道之行。常乐清净一切法门。修菩萨行不舍精进。成满诸愿善行方便。见善知识情无厌足。事善知识身不疲懈。闻善知识所有教诲。常乐顺行未曾违逆。诸仁者。若有众生。能发阿耨多罗三藐三菩提心。是为希有。若发心已。又能如是。精进方便。集诸佛法。倍为希有。又能如是求菩萨道。又能如是净菩萨行。又能如是事善知识。又能如是如救头然。又能如是顺知识教。又能如是坚固修行。又能如是集菩提分。又能如是不求一切名闻利养。又能如是不舍菩萨纯一之心。又能如是不乐家宅。不着欲乐。不恋父母亲戚知识。但乐追求菩萨伴侣。又能如是不顾身命。唯愿勤修一切智道。应知展转倍更难得。诸仁者。余诸菩萨。经于无量百千万亿那由他劫。乃能满足菩萨愿行。乃能亲近诸佛菩提。此长者子。于一生内。则能净佛刹。则能化众生。则能以智慧深入法界。则能成就诸波罗蜜。则能增广一切诸行。则能圆满一切大愿。则能超出一切魔业。则能承事一切善友。则能清净诸菩萨道。则能具足普贤诸行。尔时弥勒菩萨摩诃萨。如是称叹善财童子种种功德。令无量百千众生。发菩提心已。告善财言。善哉善哉。善男子。汝为饶益一切世间。汝为救护一切众生。汝为勤求一切佛法故。发阿耨多罗三藐三菩提心。善男子。汝获善利。汝善得人身。汝善住寿命。汝善值如来出现。汝善见文殊师利大善知识。汝身是善器。为诸善根之所润泽。汝为白法之所资持。所有解欲。悉已清净。已为诸佛共所护念。已为善友共所摄受。何以故。善男子。菩提心者犹如种子。能生一切诸佛法故。菩提心者犹如良田。能长众生白净法故。菩提心者犹如大地。能持一切诸世间故。菩提心者犹如净水。能洗一切烦恼垢故。菩提心者犹如大风。普于世间无所碍故。菩提心者犹如盛火。能烧一切诸见薪故。菩提心者犹如净日。普照一切诸世间故。菩提心者犹如盛月。诸白净法悉圆满故。菩提心者犹如明灯。能放种种法光明故。菩提心者犹如净目。普见一切安危处故。菩提心者犹如大道。普令得入大智城故。菩提心者犹如正济。令其得离诸邪法故。菩提心者犹如大车。普能运载诸菩萨故。菩提心者犹如门户。开示一切菩萨行故。菩提心者犹如宫殿。安住修习三昧法故。菩提心者犹如园苑。于中游戏受法乐故。菩提心者犹如舍宅。安隐一切诸众生故。菩提心者则为所归。利益一切诸世间故。菩提心者则为所依。诸菩萨行所依处故。菩提心者犹如慈父。训导一切诸菩萨故。菩提心者犹如慈母。生长一切诸菩萨故。菩提心者犹如乳母。养育一切诸菩萨故。菩提心者犹如善友。成益一切诸菩萨故。菩提心者犹如君主。胜出一切二乘人故。菩提心者犹如帝王。一切愿中得自在故。菩提心者犹如大海。一切功德悉入中故。菩提心者如须弥山。于诸众生心平等故。菩提心者如铁围山。摄持一切诸世间故。菩提心者犹如雪山。长养一切智慧药故。菩提心者犹如香山。出生一切功德香故。菩提心者犹如虚空。诸妙功德广无边故。菩提心者犹如莲华。不染一切世间法故。菩提心者如调慧象。其心善顺不犷戾故。菩提心者如良善马。远离一切诸恶性故。菩提心者如调御师。守护大乘一切法故。菩提心者犹如良药。能治一切烦恼病故。菩提心者犹如坑阱。陷没一切诸恶法故。菩提心者犹如金刚。悉能穿彻一切法故。菩提心者犹如香箧。能贮一切功德香故。菩提心者犹如妙华。一切世间所乐见故。菩提心者如白栴檀。除众欲热使清凉故。菩提心者如黑沉香。能熏法界悉周遍故。菩提心者如善见药王。能破一切烦恼病故。菩提心者如毗笈摩药。能拔一切诸惑箭故。菩提心者犹如帝释。一切主中最为尊故。菩提心者如毗沙门。能断一切贫穷苦故。菩提心者如功德天。一切功德所庄严故。菩提心者如庄严具。庄严一切诸菩萨故。菩提心者如劫烧火。能烧一切诸有为故。菩提心者如无生根药。长养一切诸佛法故。菩提心者犹如龙珠。能消一切烦恼毒故。菩提心者如水清珠。能清一切烦恼浊故。菩提心者如如意珠。周给一切诸贫乏故。菩提心者如功德瓶。满足一切众生心故。菩提心者如如意树。能雨一切庄严具故。菩提心者如鹅羽衣。不受一切生死垢故。菩提心者如白[疊*毛]线。从本已来性清净故。菩提心者如快利犁。能治一切众生田故。菩提心者如那罗延。能摧一切我见敌故。菩提心者犹如快箭。能破一切诸苦的故。菩提心者犹如利矛。能穿一切烦恼甲故。菩提心者犹如坚甲。能护一切如理心故。菩提心者犹如利刀。能斩一切烦恼首故。菩提心者犹如利剑。能断一切憍慢铠故。菩提心者如勇将幢。能伏一切诸魔军故。菩提心者犹如利锯。能截一切无明树故。菩提心者犹如利斧。能伐一切诸苦树故。菩提心者犹如兵仗。能防一切诸苦难故。菩提心者犹如善手。防护一切诸度身故。菩提心者犹如好足。安立一切诸功德故。菩提心者犹如眼药。灭除一切无明翳故。菩提心者犹如钳镊。能拔一切身见刺故。菩提心者犹如卧具。息除生死诸劳苦故。菩提心者如善知识。能解一切生死缚故。菩提心者如好珍财。能除一切贫穷事故。菩提心者如大导师。善知菩萨出要道故。菩提心者犹如伏藏。出功德财无匮乏故。菩提心者犹如涌泉。生智慧水无穷尽故。菩提心者犹如明镜。普现一切法门像故。菩提心者犹如莲华。不染一切诸罪垢故。菩提心者犹如大河。流引一切度摄法故。菩提心者如大龙王。能雨一切妙法雨故。菩提心者犹如命根。任持菩萨大悲身故。菩提心者犹如甘露。能令安住不死界故。菩提心者犹如大网。普摄一切诸众生故。菩提心者犹如罥索。摄取一切所应化故。菩提心者犹如钩饵。出有渊中所居者故。菩提心者如阿伽陀药。能令无病永安隐故。菩提心者如除毒药。悉能消歇贪爱毒故。菩提心者如善持咒。能除一切颠倒毒故。菩提心者犹如疾风。能卷一切诸障雾故。菩提心者如大宝洲。出生一切觉分宝故。菩提心者如好种性。出生一切白净法故。菩提心者犹如住宅。诸功德法所依处故。菩提心者犹如市肆。菩萨商人贸易处故。菩提心者如炼金药。能治一切烦恼垢故。菩提心者犹如好蜜。圆满一切功德味故。菩提心者犹如正道。令诸菩萨入智城故。菩提心者犹如好器。能持一切白净法故。菩提心者犹如时雨。能灭一切烦恼尘故。菩提心者则为住处。一切菩萨所住处故。菩提心者则为寿行。不取声闻解脱果故。菩提心者如净琉璃。自性明洁无诸垢故。菩提心者如帝青宝。出过世间二乘智故。菩提心者如更漏鼓。觉诸众生烦恼睡故。菩提心者如清净水。性本澄洁无垢浊故。菩提心者如阎浮金。映夺一切有为善故。菩提心者如大山王。超出一切诸世间故。菩提心者则为所归。不拒一切诸来者故。菩提心者则为义利。能除一切衰恼事故。菩提心者则为妙宝。能令一切心欢喜故。菩提心者如大施会。充满一切众生心故。菩提心者则为尊胜。诸众生心无与等故。菩提心者犹如伏藏。能摄一切诸佛法故。菩提心者如因陀罗网。能伏烦恼阿修罗故。菩提心者如婆楼那风。能动一切所应化故。菩提心者如因陀罗火。能烧一切诸惑习故。菩提心者如佛支提。一切世间应供养故。善男子。菩提心者。成就如是无量功德。举要言之。应知悉与一切佛法诸功德等。何以故。因菩提心。出生一切诸菩萨行。三世如来。从菩提心而出生故。是故善男子。若有发阿耨多罗三藐三菩提心者。则已出生无量功德。普能摄取一切智道。善男子。譬如有人得无畏药离五恐怖。何等为五。所谓火不能烧。毒不能中。刀不能伤。水不能漂。烟不能熏。菩萨摩诃萨亦复如是。得一切智菩提心药。贪火不烧。嗔毒不中。惑刀不伤。有流不漂。诸觉观烟不能熏害。善男子。譬如有人得解脱药终无横难。菩萨摩诃萨亦复如是。得菩提心解脱智药。永离一切生死横难。善男子。譬如有人。持摩诃应伽药。毒蛇闻气即皆远去。菩萨摩诃萨亦复如是。持菩提心大应伽药。一切烦恼诸恶毒蛇。闻其气者悉皆散灭。善男子。譬如有人。持无胜药。一切怨敌无能胜者。菩萨摩诃萨亦复如是。持菩提心无能胜药。悉能降伏一切魔军。善男子。譬如有人。持毗笈摩药。能令毒箭自然堕落。菩萨摩诃萨亦复如是。持菩提心毗笈摩药。令贪恚痴诸邪见箭。自然堕落。善男子。譬如有人。持善见药。能除一切所有诸病。菩萨摩诃萨亦复如是。持菩提心善见药王。悉除一切诸烦恼病。善男子。如有药树名珊陀那。有取其皮以涂疮者。疮即除愈。然其树皮。随取随生终不可尽。菩萨摩诃萨。从菩提心。生一切智树。亦复如是。若有得见而生信者。烦恼业疮悉得消灭。一切智树初无所损。善男子。如有药树名无生根。以其力故。增长一切阎浮提树。菩萨摩诃萨菩提心树。亦复如是。以其力故。增长一切学与无学。及诸菩萨所有善法。善男子。譬如有药名阿蓝婆。若用涂身。身之与心咸有堪能。菩萨摩诃萨。得菩提心阿蓝婆药。亦复如是。令其身心增长善法。善男子。譬如有人得念力药。凡所闻事忆持不忘。菩萨摩诃萨。得菩提心念力妙药。悉能闻持一切佛法。皆无忘失。善男子。譬如有药名大莲华。其有服者住寿一劫。菩萨摩诃萨。服菩提心大莲华药。亦复如是。于无数劫寿命自在。善男子。譬如有人执翳形药。人与非人悉不能见。菩萨摩诃萨。执菩提心翳形妙药。一切诸魔不能得见。善男子。如海有珠名普集众宝。此珠若在。假使劫火焚烧世间。能令此海减于一滴。无有是处。菩萨摩诃萨菩提心珠。亦复如是。住于菩萨大愿海中。若常忆持不令退失。能坏菩萨一善根者。终无是处。若退其心。一切善法即皆散灭。善男子。如有摩尼名大光明。有以此珠璎珞身者。映蔽一切宝庄严具。所有光明悉皆不现。菩萨摩诃萨菩提心宝。亦复如是。璎珞其身。映蔽一切二乘心宝。诸庄严具悉无光彩。善男子。如水清珠能清浊水。菩萨摩诃萨菩提心珠。亦复如是。能清一切烦恼垢浊。善男子。譬如有人得住水宝。系其身上入大海中不为水害。菩萨摩诃萨亦复如是。得菩提心住水妙宝。入于一切生死海中。终不沉没。善男子。譬如有人得龙宝珠持入龙宫。一切龙蛇不能为害。菩萨摩诃萨亦复如是。得菩提心大龙宝珠。入欲界中。烦恼龙蛇不能为害。善男子。譬如帝释着摩尼冠。映蔽一切诸余天众。菩萨摩诃萨亦复如是。着菩提心大愿宝冠。超过一切三界众生。善男子。譬如有人得如意珠。除灭一切贫穷之苦。菩萨摩诃萨亦复如是。得菩提心如意宝珠。远离一切邪命怖畏。善男子。譬如有人得日精珠。持向日光而生于火。菩萨摩诃萨亦复如是。得菩提心智日宝珠。持向智光而生智火。善男子。譬如有人得月精珠。持向月光而生于水。菩萨摩诃萨亦复如是。得菩提心月精宝珠。持此心珠。鉴回向光。而生一切善根愿水。善男子。譬如龙王首戴如意摩尼宝冠。远离一切怨敌怖畏。菩萨摩诃萨亦复如是。着菩提心大悲宝冠。远离一切恶道诸难。善男子。如有宝珠名一切世间庄严藏。若有得者。令其所欲悉得充满。而此宝珠无所损减。菩提心宝亦复如是。若有得者。令其所愿悉得满足。而菩提心无有损减。善男子。如转轮王有摩尼宝。置于宫中。放大光明破一切暗。菩萨摩诃萨亦复如是。以菩提心大摩尼宝。住于欲界。放大智光。悉破诸趣无明黑暗。善男子。譬如帝青大摩尼宝。若有为此光明所触即同其色。菩萨摩诃萨菩提心宝。亦复如是。观察诸法回向善根。靡不即同菩提心色。善男子。如琉璃宝于百千岁。处不净中。不为臭秽之所染着。性本净故。菩萨摩诃萨菩提心宝。亦复如是。于百千劫住欲界中。不为欲界过患所染。犹如法界性清净故。善男子。譬如有宝名净光明。悉能映蔽一切宝色。菩萨摩诃萨菩提心宝。亦复如是。悉能映蔽一切凡夫二乘功德。善男子。譬如有宝名为火焰。悉能除灭一切暗冥。菩萨摩诃萨菩提心宝。亦复如是。能灭一切无知暗冥。善男子。譬如海中有无价宝。商人采得船载入城。诸余摩尼百千万种。光色价直无与等者。菩提心宝亦复如是。住于生死大海之中。菩萨摩诃萨。乘大愿船。深心相续。载之来入解脱城中。二乘功德无能及者。善男子。如有宝珠名自在王。处阎浮洲。去日月轮四万由旬。日月宫中所有庄严。其珠影现悉皆具足。菩萨摩诃萨发菩提心净功德宝。亦复如是。住生死中照法界空。佛智日月。一切功德悉于中现。善男子。如有宝珠名自在王。日月光明所照之处。一切财宝衣服等物。所有价直悉不能及。菩萨摩诃萨发菩提心自在王宝。亦复如是。一切智光所照之处。三世所有天人二乘。漏无漏善一切功德。皆不能及。善男子。海中有宝名曰海藏。普现海中诸庄严事。菩萨摩诃萨菩提心宝。亦复如是。普能显现一切智海诸庄严事。善男子。譬如天上阎浮檀金。唯除心王大摩尼宝。余无及者。菩萨摩诃萨发菩提心阎浮檀金。亦复如是。除一切智心王大宝。余无及者。善男子。譬如有人善调龙法。于诸龙中而得自在。菩萨摩诃萨亦复如是。得菩提心善调龙法。于诸一切烦恼龙中。而得自在。善男子。譬如勇士被执铠仗。一切怨敌无能降伏。菩萨摩诃萨亦复如是。被执菩提大心铠仗。一切业惑诸恶怨敌。无能屈伏。善男子。譬如天上黑栴檀香。若烧一铢。其香普熏小千世界。三千世界满中珍宝。所有价直皆不能及。菩萨摩诃萨菩提心香。亦复如是。一念功德普熏法界。声闻缘觉一切功德。皆所不及。善男子。如白栴檀若以涂身。悉能除灭一切热恼。令其身心普得清凉。菩萨摩诃萨菩提心香。亦复如是。能除一切虚妄分别贪恚痴等诸惑热恼。令其具足智慧清凉。善男子。如须弥山。若有近者即同其色。菩萨摩诃萨菩提心山。亦复如是。若有近者。悉得同其一切智色。善男子。譬如波利质多罗树。其皮香气。阎浮提中。若婆师迦。若薝卜迦。若苏摩那。如是等华所有香气皆不能及。菩萨摩诃萨菩提心树。亦复如是。所发大愿功德之香。一切二乘无漏戒定。智慧解脱。解脱知见诸功德香悉不能及。善男子。譬如波利质多罗树。虽未开华。应知即是无量诸华出生之处。菩萨摩诃萨菩提心树。亦复如是。虽未开发一切智华。应知即是无数天人众菩提华所生之处。善男子。譬如波利质多罗华。一日熏衣。薝卜迦华。婆利师华。苏摩那华。虽千岁熏亦不能及。菩萨摩诃萨菩提心华。亦复如是。一生所熏诸功德香。普彻十方一切佛所。一切二乘无漏功德。百千劫熏所不能及。善男子。如海岛中生椰子树。根茎枝叶及以华果。一切众生。恒取受用无时暂歇。菩萨摩诃萨菩提心树。亦复如是。始从发起悲愿之心。乃至成佛。正法住世。常时利益一切世间。无有间歇。善男子。如有药汁名诃宅迦。人或得之。以其一两变千两铜。悉成真金。非千两铜能变此药。菩萨摩诃萨亦复如是。以菩提心回向智药。普变一切业惑等法。悉使成于一切智相非业惑等。能变其心。善男子。譬如小火随所焚烧其焰转炽。菩萨摩诃萨菩提心火。亦复如是。随所攀缘智焰增长。善男子。譬如一灯然百千灯。其本一灯无减无尽。菩萨摩诃萨菩提心灯。亦复如是。普然三世诸佛智灯。而其心灯无减无尽。善男子。譬如一灯入于闇室。百千年闇悉能破尽。菩萨摩诃萨菩提心灯。亦复如是。入于众生心室之内。百千万亿不可说劫。诸业烦恼种种闇障。悉能除尽。善男子。譬如灯炷随其大小而发光明。若益膏油明终不绝。菩萨摩诃萨菩提心灯。亦复如是。大愿为炷。光照法界。益大悲油。教化众生。庄严国土。施作佛事无有休息。善男子。譬如他化自在天王冠阎浮檀真金天冠。欲界天子。诸庄严具皆不能及。菩萨摩诃萨亦复如是。冠菩提心大愿天冠。一切凡夫二乘功德。皆不能及。善男子。如师子王哮吼之时。师子儿闻皆增勇健。余兽闻之即皆窜伏。佛师子王菩提心吼。应知亦尔。诸菩萨闻增长功德。有所得者闻皆退散。善男子。譬如有人以师子筋。而为乐弦。其音既奏余弦悉绝。菩萨摩诃萨亦复如是。以如来师子波罗蜜身菩提心筋。为法乐弦。其音既奏。一切五欲及以二乘诸功德弦。悉皆断灭。善男子。譬如有人以牛羊等种种诸乳。假使积集盈于大海。以师子乳一滴投中。悉令变坏直过无碍。菩萨摩诃萨亦复如是。以如来师子菩提心乳。着无量劫业烦恼乳大海之中。悉令坏灭直过无碍。终不住于二乘解脱。善男子。譬如迦陵频伽鸟。在卵[穀-禾+卵]中有大势力。一切诸鸟所不能及。菩萨摩诃萨亦复如是。于生死[穀-禾+卵]。发菩提心所有大悲功德势力。声闻缘觉无能及者。善男子。如金翅鸟王子初始生时。目则明利飞则劲捷。一切诸鸟。虽久成长无能及者。菩萨摩诃萨亦复如是。发菩提心为佛王子。智慧清净。大悲勇猛。一切二乘。虽百千劫。久修道行所不能及。善男子。如有壮夫手执利矛刺坚密甲。直过无碍。菩萨摩诃萨亦复如是。执菩提心铦利快矛。刺诸邪见随眠密甲。悉能穿彻无有障碍。善男子。譬如摩诃那伽大力勇士。若奋威怒。于其额上必生疮疱。疮若未合。阎浮提中一切人民。无能制伏。菩萨摩诃萨亦复如是。若起大悲。必定发于菩提之心。心未舍来。一切世间魔及魔民不能为害。善男子。譬如射师有诸弟子。虽未惯习其师技艺。然其智慧方便善巧。余一切人所不能及。菩萨摩诃萨初始发心。亦复如是。虽未惯习一切智行。然其所有愿智解欲。一切世间凡夫二乘。悉不能及。善男子。如人学射先安其足后习其法。菩萨摩诃萨亦复如是。欲学如来一切智道。先当安住菩提之心。然后修行一切佛法。善男子。譬如幻师将作幻事。先当起意忆持幻法。然后所作悉得成就。菩萨摩诃萨亦复如是。将起一切诸佛菩萨神通幻事。先当起意发菩提心。然后一切悉得成就。善男子。譬如幻术无色现色。菩萨摩诃萨菩提心相。亦复如是。虽无有色不可睹见。然能普于十方法界。示现种种功德庄严。善男子。譬如猫狸才见于鼠。鼠即入穴不敢复出。菩萨摩诃萨发菩提心。亦复如是。暂以慧眼观诸惑业。皆即窜匿不复出生。善男子。譬如有人着阎浮金庄严之具。映蔽一切皆如聚墨。菩萨摩诃萨亦复如是。着菩提心庄严之具。映蔽一切凡夫二乘功德庄严。悉无光色。善男子。如好磁石少分之力。即能吸坏诸铁钩锁。菩萨摩诃萨发菩提心。亦复如是。若起一念。悉能坏灭一切见欲无明钩锁。善男子。如有磁石。铁若见之。即皆散去无留住者。菩萨摩诃萨发菩提心。亦复如是。诸业烦恼二乘解脱。若暂见之即皆散灭。亦无住者。善男子。譬如有人善入大海。一切水族无能为害。假使入于摩竭鱼口。亦不为彼之所吞噬。菩萨摩诃萨亦复如是。发菩提心入生死海。诸业烦恼不能为害。假使入于声闻缘觉实际法中。亦不为其之所留难。善男子。譬如有人饮甘露浆。一切诸物不能为害。菩萨摩诃萨亦复如是。饮菩提心甘露法浆。不堕声闻辟支佛地。以具广大悲愿力故。善男子。譬如有人得安缮那药以涂其目。虽行人间人所不见。菩萨摩诃萨亦复如是。得菩提心安缮那药。能以方便入魔境界。一切众魔所不能见。善男子。譬如有人依附于王。不畏余人。菩萨摩诃萨亦复如是。依菩提心大势力王。不畏障盖恶道之难。善男子。譬如有人住于水中。不畏火焚。菩萨摩诃萨亦复如是。住菩提心善根水中。不畏二乘解脱智火。善男子。譬如有人依倚猛将。即不怖畏一切怨敌。菩萨摩诃萨亦复如是。依菩提心勇猛大将。不畏一切恶行怨敌。善男子。如释天王执金刚杵。摧伏一切阿修罗众。菩萨摩诃萨亦复如是。持菩提心金刚之杵。摧伏一切诸魔外道。善男子。譬如有人服延龄药。长得充健不老不瘦。菩萨摩诃萨亦复如是。服菩提心延龄之药。于无数劫修菩萨行。心无疲厌亦无染着。善男子。譬如有人调和药汁。必当先取好清净水。菩萨摩诃萨亦复如是。欲修菩萨一切行愿。先当发起菩提之心。善男子。如人护身先护命根。菩萨摩诃萨亦复如是。护持佛法亦当先护菩提之心。善男子。譬如有人命根若断。不能利益父母宗亲。菩萨摩诃萨亦复如是。舍菩提心。不能利益一切众生。不能成就诸佛功德。善男子。譬如大海无能坏者。菩提心海亦复如是。诸业烦恼二乘之心。所不能坏。善男子。譬如日光。星宿光明不能映蔽。菩提心日亦复如是。一切二乘无漏智光。所不能蔽。善男子。如王子初生即为大臣之所尊重。以种性自在故。菩萨摩诃萨亦复如是。于佛法中。发菩提心。即为耆宿久修梵行。声闻缘觉所共尊重。以大悲自在故。善男子。譬如王子年虽幼稚。一切大臣皆悉敬礼。菩萨摩诃萨亦复如是。虽初发心修菩萨行。二乘耆旧皆应敬礼。善男子。譬如王子虽于一切臣佐之中未得自在。已具王相。不与一切诸臣佐等。以生处尊胜故。菩萨摩诃萨亦复如是。虽于一切业烦恼中未得自在。然已具足菩提之相。不与一切二乘齐等。以种性第一故。善男子。譬如清净摩尼妙宝。眼有翳故见为不净。菩萨摩诃萨菩提心宝。亦复如是。无智不信谓为不净。善男子。譬如有药为咒所持。若有众生见闻同住。一切诸病皆得消灭。菩萨摩诃萨菩提心药。亦复如是。一切善根。智慧方便。菩萨愿智。共所摄持。若有众生。见闻同住忆念之者。诸烦恼病悉得除灭。善男子。譬如有人常持甘露。其身毕竟不变不坏。菩萨摩诃萨亦复如是。若常忆持菩提心露。令愿智身毕竟不坏。善男子。如机关木人若无有楔。身即离散不能运动。菩萨摩诃萨亦复如是。无菩提心行即分散。不能成就一切佛法。善男子。如转轮王有沉香宝。名曰象藏。若烧此香。王四种兵悉腾虚空。菩萨摩诃萨菩提心香。亦复如是。若发此意。即令菩萨一切善根。永出三界行如来智无为空中。善男子。譬如金刚唯从金刚处及金处生。非余宝处生。菩萨摩诃萨菩提心金刚。亦复如是。唯从大悲救护众生金刚处。一切智智殊胜境界金处而生。非余众生善根处生。善男子。譬如有树名曰无根。不从根生。而枝叶华果悉皆繁茂。菩萨摩诃萨菩提心树。亦复如是无根可得。而能长养一切智智神通大愿。枝叶华果。扶疏荫映。普覆世间。善男子。譬如金刚。非劣恶器及以破器所能容持。唯除全具上妙之器。菩提心金刚亦复如是。非下劣众生悭嫉破戒。懈怠妄念无智器中所能容持。亦非退失殊胜志愿散乱恶觉众生器中所能容持。唯除菩萨深心宝器。善男子。譬如金刚能穿众宝。菩提心金刚亦复如是。悉能穿彻一切法宝。善男子。譬如金刚能坏众山。菩提心金刚亦复如是。悉能摧坏诸邪见山。善男子。譬如金刚虽破不全。一切众宝犹不能及。菩提心金刚亦复如是。虽复志劣少有亏损。犹胜一切二乘功德。善男子。譬如金刚虽有损缺。犹能除灭一切贫穷。菩提心金刚亦复如是。虽有损缺不进诸行。犹能舍离一切生死。善男子。如小金刚悉能破坏一切诸物。菩提心金刚亦复如是。入少境界即破一切无知诸惑。善男子。譬如金刚非凡人所得。菩提心金刚亦复如是。非劣意众生之所能得。善男子。譬如金刚不识宝人。不知其能不得。其用。菩提心金刚亦复如是。不知法人。不了其能不得其用。善男子。譬如金刚无能销灭。菩提心金刚亦复如是。一切诸法无能销灭。善男子。如金刚杵。诸大力人皆不能持。唯除有大那罗延力。菩提之心亦复如是。一切二乘皆不能持。唯除菩萨广大因缘坚固善力。善男子。譬如金刚一切诸物无能坏者。而能普坏一切诸物。然其体性无所损减。菩提之心亦复如是。普于三世无数劫中。教化众生。修行苦行。声闻缘觉所不能者。咸能作之。然其毕竟。无有疲厌亦无损坏。善男子。譬如金刚余不能持。唯金刚地之所能持。菩提之心亦复如是。声闻缘觉皆不能持。唯除趣向萨婆若者。善男子。如金刚器无有瑕缺用盛于水。永不渗漏而入于地。菩提心金刚器亦复如是。盛善根水。永不渗漏。令入诸趣。善男子。如金刚际能持大地不令坠没。菩提之心亦复如是。能持菩萨一切行愿。不令坠没入于三界。善男子。譬如金刚久处水中不烂不湿。菩提之心亦复如是。于一切劫处在生死业惑水中。无坏无变。善男子。譬如金刚一切诸火不能烧然不能令热。菩提之心亦复如是。一切生死诸烦恼火。不能烧然不能令热。善男子。譬如三千世界之中金刚座上能持诸佛。坐于道场。降伏诸魔。成等正觉。非是余座之所能持。菩提心座亦复如是。能持菩萨一切愿行诸波罗蜜。诸忍诸地。回向受记。修集菩提助道之法。供养诸佛。闻法受行。一切余心所不能持。善男子。菩提心者。成就如是无量无边乃至不可说不可说殊胜功德。若有众生发阿耨多罗三藐三菩提心。则获如是胜功德法。是故善男子。汝获善利。汝发阿耨多罗三藐三菩提心。求菩萨行。已得如是大功德故。善男子。如汝所问。菩萨云何学菩萨行。修菩萨道。善男子。汝可入此毗卢遮那庄严藏大楼阁中。周遍观察。则能了知学菩萨行。学已成就无量功德

大方广佛华严经卷第七十八大方广佛华严经卷第七十九

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之二十

尔时善财童子。恭敬右绕弥勒菩萨摩诃萨已。而白之言。唯愿大圣。开楼阁门令我得入。时弥勒菩萨。前诣楼阁。弹指出声。其门即开。命善财入。善财心喜。入已还闭。见其楼阁。广博无量。同于虚空。阿僧祇宝以为其地。阿僧祇宫殿。阿僧祇门闼。阿僧祇窗牖。阿僧祇阶陛。阿僧祇栏楯。阿僧祇道路。皆七宝成。阿僧祇幡。阿僧祇幢。阿僧祇盖。周回间列。阿僧祇众宝璎珞。阿僧祇真珠璎珞。阿僧祇赤真珠璎珞。阿僧祇师子珠璎珞。处处垂下。阿僧祇半月。阿僧祇缯带。阿僧祇宝网以为严饰。阿僧祇宝铎风动成音。散阿僧祇天诸杂华。悬阿僧祇天宝鬘带。严阿僧祇众宝香炉。雨阿僧祇细末金屑。悬阿僧祇宝镜。然阿僧祇宝灯。布阿僧祇宝衣。列阿僧祇宝帐。设阿僧祇宝坐。阿僧祇宝缯以敷座上。阿僧祇阎浮檀金童女像。阿僧祇杂宝诸形像。阿僧祇妙宝菩萨像。处处充遍。阿僧祇众鸟出和雅音。阿僧祇宝优钵罗华。阿僧祇宝波头摩华。阿僧祇宝拘物头华。阿僧祇宝芬陀利华。以为庄严。阿僧祇宝树次第行列。阿僧祇摩尼宝放大光明。如是等无量阿僧祇诸庄严具。以为庄严。又见其中。有无量百千诸妙楼阁。一一严饰悉如上说。广博严丽。皆同虚空。不相障碍亦无杂乱。善财童子。于一处中见一切处。一切诸处悉如是见。尔时善财童子。见毗卢遮那庄严藏楼阁如是种种不可思议自在境界。生大欢喜。踊跃无量。身心柔软。离一切想。除一切障。灭一切惑。所见不忘。所闻能忆。所思不乱。入于无碍解脱之门。普运其心。普见一切。普申敬礼。才始稽首。以弥勒菩萨威神之力。自见其身。遍在一切诸楼阁中。具见种种不可思议自在境界。所谓或见弥勒菩萨。初发无上菩提心时。如是名字。如是种族。如是善友之所开悟。令其种植如是善根。住如是寿。在如是劫。值如是佛。处于如是庄严刹土。修如是行。发如是愿。彼诸如来如是众会。如是寿命。经尔许时。亲近供养。悉皆明见。或见弥勒最初证得慈心三昧。从是已来。号为慈氏。或见弥勒修诸妙行。成满一切诸波罗蜜。或见得忍。或见住地。或见成就清净国土。或见护持如来正教。为大法师。得无生忍。某时某处。某如来所。受于无上菩提之记。或见弥勒为转轮王劝诸众生。住十善道。或为护世饶益众生。或为释天呵责五欲。或为焰摩天王赞不放逸。或为兜率天王称叹一生菩萨功德。或为化乐天王。为诸天众。现诸菩萨。变化庄严。或为他化自在天王。为诸天众演说一切诸佛之法。或作魔王说一切法皆悉无常。或为梵王说诸禅定无量喜乐。或为阿修罗王入大智海。了法如幻。为其众会常演说法。断除一切憍慢醉傲。或复见其处阎罗界放大光明救地狱苦。或见在于饿鬼之处。施诸饮食济彼饥渴。或见在于畜生之道。种种方便调伏众生。或复见为护世天王众会说法。或复见为忉利天王众会说法。或复见为焰摩天王众会说法。或复见为兜率天王众会说法。或复见为化乐天王众会说法。或复见为他化自在天王众会说法。或复见为大梵王众会说法。或复见为龙王众会说法。或复见为夜叉罗刹王众会说法。或复见为乾闼婆紧那罗王众会说法。或复见为阿修罗陀那婆王众会说法。或复见为迦楼罗摩睺罗伽王众会说法。或复见为其余一切人非人等众会说法。或复见为声闻众会说法。或复见为缘觉众会说法。或复见为初发心乃至一生所系已灌顶者诸菩萨众。而演说法。或见赞说初地乃至十地所有功德。或见赞说满足一切诸波罗蜜。或见赞说入诸忍门。或见赞说诸大三昧门。或见赞说甚深解脱门。或见赞说诸禅三昧神通境界。或见赞说诸菩萨行。或见赞说诸大誓愿。或见与诸同行菩萨。赞说世间资生工巧种种方便利众生事。或见与诸一生菩萨。赞说一切佛灌顶门。或见弥勒于百千年。经行读诵书写经卷。勤求观察为众说法。或入诸禅四无量心。或入遍处及诸解脱。或入三昧以方便力现诸神变。或见诸菩萨入变化三昧。各于其身一一毛孔。出于一切变化身云。或见出天众身云。或见出龙众身云。或见出夜叉乾闼婆紧那罗阿修罗迦楼罗摩睺罗伽。释梵护世转轮圣王小王王子大臣官属长者居士身云。或见出声闻缘觉及诸菩萨如来身云。或见出一切众生身云。或见出妙音赞诸菩萨种种法门。所谓赞说菩提心功德门。赞说檀波罗蜜乃至智波罗蜜功德门。赞说诸摄诸禅。诸无量心。及诸三昧。三摩钵底。诸通诸明。总持辩才。诸谛诸智。止观解脱。诸缘诸依。诸说法门。赞说念处正勤。神足根力。七菩提分。八圣道分。诸声闻乘。诸独觉乘。诸菩萨乘。诸地诸忍。诸行诸愿。如是等一切诸功德门。或复于中。见诸如来大众围绕。亦见其佛生处种姓身形寿命。刹劫名号。说法利益。教住久近。乃至所有道场众会。种种不同。悉皆明见。又复于彼庄严藏内诸楼阁中。见一楼阁高广严饰最上无比。于中悉见三千世界百亿四天下百亿兜率陀天。一一皆有弥勒菩萨。降神诞生。释梵天王。捧持顶戴。游行七步。观察十方。大师子吼。现为童子。居处宫殿。游戏园苑。为一切智。出家苦行。示受乳糜。往诣道场。降伏诸魔。成等正觉。观菩提树。梵王劝请。转正法轮。升天宫殿。而演说法。劫数寿量。众会庄严。所净国土。所修行愿。教化成熟众生方便。分布舍利。住持教法。皆悉不同

尔时善财。自见其身。在彼一切诸如来所。亦见于彼一切众会一切佛事。忆持不忘。通达无碍。复闻一切诸楼阁内。宝网铃铎及诸乐器。皆悉演畅不可思议微妙法音。说种种法。所谓或说菩萨发菩提心。或说修行波罗蜜行。或说诸愿。或说诸地。或说恭敬供养如来。或说庄严诸佛国土。或说诸佛说法差别。如上所说一切佛法。悉闻其音敷畅辩了。又闻某处。有某菩萨。闻某法门。某善知识之所劝导发菩提心。于某劫某刹。某如来所。某大众中。闻于某佛如是功德。发如是心。起如是愿。种于如是广大善根。经若干劫。修菩萨行。于尔许时。当成正觉。如是名号。如是寿量。如是国土。具足庄严。满如是愿。化如是众。如是声闻菩萨众会。般涅槃后。正法住世。经尔许劫。利益如是无量众生。或闻某处。有某菩萨。布施持戒。忍辱精进。禅定智慧。修习如是诸波罗蜜。或闻某处。有某菩萨。为求法故。弃舍王位及诸珍宝。妻子眷属手足头目。一切身分皆无所吝。或闻某处。有某菩萨。守护如来所说正法。为大法师。广行法施。建法幢。吹法螺。击法鼓。雨法雨。造佛塔庙。作佛形像。施诸众生一切乐具。或闻某处。有某如来。于某劫中。成等正觉。如是国土。如是众会。如是寿命。说如是法。满如是愿。教化如是无量众生。善财童子。闻如是等不可思议微妙法音。身心欢喜。柔软悦泽。即得无量诸总持门。诸辩才门。诸禅诸忍。诸愿诸度。诸通诸明。及诸解脱。诸三昧门。又见一切诸宝镜中种种形像。所谓或见诸佛众会道场。或见菩萨众会道场。或见声闻众会道场。或见缘觉众会道场。或见净世界。或见不净世界。或见净不净世界。或见不净净世界。或见有佛世界。或见无佛世界。或见小世界。或见中世界。或见大世界。或见因陀罗网世界。或见覆世界。或见仰世界。或见平坦世界。或见地狱畜生饿鬼所住世界。或见天人充满世界。于如是等诸世界中。见有无数大菩萨众。或行或坐。作诸事业。或起大悲怜愍众生。或造诸论利益世间。或受或持。或书或诵。或问或答。三时忏悔。回向发愿。又见一切诸宝柱中。放摩尼王大光明网。或青或黄。或赤或白。或玻璃色。或水精色。或帝青色。或虹霓色。或阎浮檀金色。或作一切诸光明色。又见彼阎浮檀金童女。及众宝像。或以其手而执华云。或执衣云。或执幢幡。或执鬘盖。或持种种涂香末香。或持上妙摩尼宝网。或垂金锁。或挂璎珞。或举其臂捧庄严具。或低其首垂摩尼冠。曲躬瞻仰目不暂舍。又见彼真珠璎珞。常出香水。具八功德。琉璃璎珞百千光明。同时照耀。幢幡网盖如是等物。一切皆以众宝庄严。又复见彼优钵罗华。波头摩华。拘物头华。芬陀利华。各各生于无量诸华。或大一手。或长一肘。或复纵广犹如车轮。一一华中。皆悉示现种种色像。以为严饰。所谓男色像女色像。童男色像。童女色像。释梵护世。天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。声闻缘觉。及诸菩萨。如是一切众生色像。皆悉合掌曲躬礼敬。亦见如来结跏趺坐。三十二相庄严其身。又复见彼净琉璃地一一步间。现不思议种种色像。所谓世界色像。菩萨色像。如来色像。及诸楼阁庄严色像。又于宝树枝叶华果。一一事中。悉见种种半身色像。所谓佛半身色像。菩萨半身色像。天龙夜叉。乃至护世。转轮圣王。小王王子。大臣官长。及以四众半身色像。其诸色像。或执华鬘。或执璎珞。或持一切诸庄严具。或有曲躬合掌礼敬。一心瞻仰目不暂舍。或有赞叹。或入三昧。其身悉以相好庄严。普放种种诸色光明。所谓金色光明。银色光明。珊瑚色光明。兜沙罗色光明。帝青色光明。毗卢遮那宝色光明。一切众宝色光明。瞻波迦华色光明。又见诸楼阁半月像中。出阿僧祇日月星宿种种光明。普照十方。又见诸楼阁周回四壁。一一步内。一切众宝以为庄严。一一宝中皆现弥勒曩劫修行。菩萨道时。或施头目。或施手足。唇舌牙齿。耳鼻血肉。皮肤骨髓。乃至爪发。如是一切悉皆能舍。妻妾男女。城邑聚落。国土王位。随其所须尽皆施与。处牢狱者令得出离。被系缚者使其解脱。有疾病者为其救疗。入邪径者示其正道。或为船师令度大海。或为马王救护恶难。或为大仙善说诸论。或为轮王劝修十善。或为医王善疗众病。或孝顺父母。或亲近善友。或作声闻。或作缘觉。或作菩萨。或作如来。教化调伏一切众生。或为法师奉行佛教。受持读诵。如理思惟。立佛支提。作佛形像。若自供养。若劝于他。涂香散华。恭敬礼拜。如是等事相续不绝。或见坐于师子之座。广演说法。劝诸众生。安住十善。一心归向佛法僧宝。受持五戒及八斋戒。出家听法。受持读诵。如理修行。乃至见于弥勒菩萨。百千亿那由他阿僧祇劫。修行诸度一切色像。又见弥勒曾所承事诸善知识。悉以一切功德庄严。亦见弥勒在彼一一善知识所。亲近供养受行其教。乃至住于灌顶之地。时诸知识。告善财言。善来童子。汝观此菩萨不思议事。莫生疲厌

尔时善财童子。得不忘失忆念力故。得见十方清净眼故。得善观察无碍智故。得诸菩萨自在智故。得诸菩萨已。入智地广大解故。于一切楼阁一一物中。悉见如是及余无量不可思议自在境界诸庄严事。譬如有人。于睡梦中。见种种物。所谓城邑聚落。宫殿园苑。山林河池。衣服饮食。乃至一切资生之具。或见自身父母兄弟。内外亲属。或见大海须弥山王。乃至一切诸天宫殿。阎浮提等四天下事。或见其身形量广大百千由旬。房舍衣服悉皆相称。谓于昼日经无量时不眠不寝受诸安乐。从睡觉已乃知是梦。而能明记所见之事。善财童子亦复如是。以弥勒菩萨力所持故。知三界法皆如梦故。灭诸众生狭劣想故。得无障碍广大解故。住诸菩萨胜境界故。入不思议方便智故。能见如是自在境界。譬如有人将欲命终。见随其业。所受报相。行恶业者。见于地狱畜生饿鬼。所有一切众苦境界。或见狱卒手持兵仗。或嗔或骂。囚执将去。亦闻号叫悲叹之声。或见灰河。或见镬汤。或见刀山。或见剑树。种种逼迫受诸苦恼。作善业者。即见一切诸天宫殿。无量天众天诸采女。种种衣服。具足庄严。宫殿园林。尽皆妙好。身虽未死。而由业力见如是事。善财童子亦复如是。以菩萨业不思议力。得见一切庄严境界。譬如有人为鬼所持。见种种事。随其所问。悉皆能答。善财童子亦复如是。菩萨智慧之所持故。见彼一切诸庄严事。若有问者。靡不能答。譬如有人为龙所持。自谓是龙。入于龙宫。于少时间。自谓已经日月年载。善财童子亦复如是。以住菩萨智慧想故。弥勒菩萨所加持故。于少时间谓无量劫。譬如梵宫名庄严藏。于中悉见三千世界一切诸物。不相杂乱。善财童子亦复如是。于楼观中。普见一切庄严境界。种种差别不相杂乱。譬如比丘入遍处定。若行若住若坐若卧。随所入定境界现前。善财童子亦复如是。入于楼观。一切境界悉皆明了。譬如有人。于虚空中。见乾闼婆城具足庄严。悉分别知无有障碍。譬如夜叉宫殿与人宫殿。同在一处而不相杂。各随其业所见不同。譬如大海于中悉见三千世界一切色像。譬如幻师以幻力故。现诸幻事种种作业。善财童子亦复如是。以弥勒菩萨威神力故。及不思议幻智力故。能以幻智知诸法故。得诸菩萨自在力故。见楼阁中一切庄严。自在境界

尔时弥勒菩萨摩诃萨。即摄神力。入楼阁中。弹指作声。告善财言。善男子起。法性如是。此是菩萨知诸法智因缘聚集所现之相。如是自性。如幻如梦。如影如像。悉不成就。尔时善财。闻弹指声。从三昧起。弥勒告言。善男子。汝住菩萨不可思议自在解脱。受诸菩萨三昧喜乐。能见菩萨神力所持。助道所流。愿智所现。种种上妙庄严宫殿。见菩萨行。闻菩萨法。知菩萨德。了如来愿。善财白言。唯然圣者。是善知识。加被忆念威神之力。圣者。此解脱门。其名何等。弥勒告言。善男子。此解脱门。名入三世一切境界不忘念智庄严藏。善男子。此解脱门中。有不可说不可说解脱门。一生菩萨之所能得。善财问言。此庄严事。何处去耶。弥勒答言。于来处去。曰从何处来。曰从菩萨智慧神力中来。依菩萨智慧神力而住。无有去处。亦无住处。非集非常。远离一切。善男子。如龙王降雨。不从身出不从心出。无有积集。而非不见。但以龙王心念力故。霈然洪霔。周遍天下。如是境界不可思议。善男子。彼庄严事亦复如是。不住于内。亦不住外。而非不见。但由菩萨威神之力。汝善根力。见如是事。善男子。譬如幻师作诸幻事。无所从来无所至去。虽无来去。以幻力故分明可见。彼庄严事亦复如是。无所从来亦无所去。虽无来去。然以惯习不可思议幻智力故。及由往昔大愿力故。如是显现。善财童子言。大圣。从何处来。弥勒言。善男子。诸菩萨。无来无去。如是而来。无行无住。如是而来。无处无著。不没不生。不住不迁。不动不起。无恋无著。无业无报。无起无灭。不断不常。如是而来。善男子。菩萨。从大悲处来。为欲调伏诸众生故。从大慈处来。为欲救护诸众生故。从净戒处来。随其所乐而受生故。从大愿处来。往昔愿力之所持故。从神通处来。于一切处随乐现故。从无动摇处来。恒不舍离一切佛故。从无取舍处来。不役身心使往来故。从智慧方便处来。随顺一切诸众生故。从示现变化处来。犹如影像而化现故。然善男子。汝问于我从何处来者。善男子。我从生处摩罗提国。而来于此。善男子。彼有聚落名为房舍。有长者子名瞿波罗。为化其人令入佛法。而住于彼。又为生处。一切人民。随所应化。而为说法。亦为父母及诸眷属婆罗门等。演说大乘。令其趣入故。住于彼。而从彼来。善财童子言。圣者。何者是菩萨生处。答言。善男子。菩萨有十种生处。何者为十。善男子。菩提心。是菩萨生处。生菩萨家故。深心。是菩萨生处。生善知识家故。诸地。是菩萨生处。生波罗蜜家故。大愿。是菩萨生处。生妙行家故。大悲。是菩萨生处。生四摄家故。如理观察。是菩萨生处。生般若波罗蜜家故。大乘。是菩萨生处。生方便善巧家故。教化众生。是菩萨生处。生佛家故。智慧方便。是菩萨生处。生无生法忍家故。修行一切法。是菩萨生处。生过现未来一切如来家故。善男子。菩萨摩诃萨。以般若波罗蜜为母。方便善巧为父。檀波罗蜜为乳母。尸波罗蜜为养母。忍波罗蜜为庄严具。勤波罗蜜为养育者。禅波罗蜜为浣濯人。善知识为教授师。一切菩提分为伴侣。一切善法为眷属。一切菩萨为兄弟。菩提心为家。如理修行为家法。诸地为家处。诸忍为家族。大愿为家教。满足诸行为顺家法。劝发大乘为绍家业。法水灌顶一生所系菩萨为王太子。成就菩提为能净家族。善男子。菩萨如是超凡夫地。入菩萨位。生如来家。住佛种性。能修诸行。不断三宝。善能守护菩萨种族。净菩萨种。生处尊胜。无诸过恶。一切世间。天人魔梵。沙门婆罗门。恭敬赞叹。善男子。菩萨摩诃萨。生于如是尊胜家已。知一切法如影像故。于诸世间无所恶贱。知一切法如变化故。于诸有趣无所染着。知一切法无有我故。教化众生心无疲厌。以大慈悲为体性故。摄受众生不觉劳苦。了达生死犹如梦故。经一切劫而无怖畏。了知诸蕴皆如幻故。示现受生而无忧厌。知诸界处同法界故。于诸境界无所坏灭。知一切想如阳焰故。入于诸趣不生倒惑。达一切法皆如幻故。入魔境界不起染着。知法身故。一切烦恼不能欺诳。得自在故。于一切趣通达无碍。善男子。我身普生一切法界。等一切众生差别色相。等一切众生殊异言音。等一切众生种种名号。等一切众生所乐威仪随顺世间教化调伏。等一切清净众生示现受生。等一切凡夫众生所作事业。等一切众生想。等一切菩萨愿。而现其身充满法界。善男子。我为化度与我往昔同修诸行。今时退失菩提心者。亦为教化父母亲属。亦为教化诸婆罗门。令其离于种族憍慢。得生如来种性之中。而生于此阎浮提界摩罗提国拘吒聚落婆罗门家。善男子。我住于此大楼阁中。随诸众生心之所乐。种种方便。教化调伏。善男子。我为随顺众生心故。我为成熟兜率天中同行天故。我为示现菩萨福智。变化庄严。超过一切诸欲界故。令其舍离诸欲乐故。令知有为皆无常故。令知诸天盛必衰故。为欲示现将降生时大智法门。与一生菩萨共谈论故。为欲摄化诸同行故。为欲教化释迦如来所遣来者。令如莲华悉开悟故。于此命终。生兜率天。善男子。我愿满足。成一切智。得菩提时。汝及文殊。俱得见我。善男子。汝当往诣文殊师利善知识所。而问之言。菩萨云何学菩萨行。云何而入普贤行门。云何成就。云何广大。云何随顺。云何清净。云何圆满。善男子。彼当为汝分别演说。何以故。文殊师利。所有大愿。非余无量百千亿那由他菩萨之所能有。善男子。文殊师利童子。其行广大。其愿无边。出生一切菩萨功德。无有休息。善男子。文殊师利。常为无量百千亿那由他诸佛母。常为无量百千亿那由他菩萨师。教化成熟一切众生。名称普闻十方世界。常于一切诸佛众中。为说法师。一切如来之所赞叹。住甚深智。能如实见一切诸法。通达一切解脱境界。究竟普贤所行诸行。善男子。文殊师利童子。是汝善知识。令汝得生如来家。长养一切诸善根。发起一切助道法。值遇真实善知识。令汝修一切功德。入一切愿网。住一切大愿。为汝说一切菩萨秘密法。现一切菩萨难思行。与汝往昔。同生同行。是故。善男子。汝应往诣文殊之所莫生疲厌。文殊师利。当为汝说一切功德。何以故。汝先所见诸善知识。闻菩萨行。入解脱门。满足大愿。皆是文殊威神之力。文殊师利。于一切处。咸得究竟。时善财童子。顶礼其足。绕无量匝。殷勤瞻仰。辞退而去

大方广佛华严经卷第七十九大方广佛华严经卷第八十

        于阗国三藏实叉难陀奉　制译

    入法界品第三十九之二十一

尔时善财童子。依弥勒菩萨摩诃萨教。渐次而行。经由一百一十余城已。到普门国苏摩那城。住其门所。思惟文殊师利。随顺观察。周旋求觅。希欲奉觐。是时文殊师利。遥伸右手。过一百一十由旬。按善财顶。作如是言。善哉善哉。善男子。若离信根。心劣忧悔。功行不具。退失精勤。于一善根。心生住着。于少功德。便以为足。不能善巧发起行愿。不为善知识之所摄护。不为如来之所忆念。不能了知如是法性。如是理趣。如是法门。如是所行。如是境界。若周遍知。若种种知。若尽源底。若解了。若趣入。若解说。若分别。若证知。若获得。皆悉不能。是时文殊师利。宣说此法。示教利喜。令善财童子。成就阿僧祇法门。具足无量大智光明。令得菩萨无边际陀罗尼。无边际愿。无边际三昧。无边际神通。无边际智。令入普贤行道场。及置善财自所住处。文殊师利。还摄不现。于是善财。思惟观察。一心愿见文殊师利。及见三千大千世界微尘数诸善知识。悉皆亲近。恭敬承事。受行其教。无有违逆。增长趣求一切智慧。广大悲海。益大慈云。普观众生。生大欢喜。安住菩萨寂静法门。普缘一切广大境界。学一切佛广大功德。入一切佛决定知见。增一切智助道之法。善修一切菩萨深心。知三世佛出兴次第。入一切法海。转一切法轮。生一切世间。入于一切菩萨愿海。住一切劫。修菩萨行。照明一切如来境界。长养一切菩萨诸根。获一切智清净光明。普照十方。除诸暗障。智周法界于一切佛刹。一切诸有。普现其身。靡不周遍。摧一切障。入无碍法。住于法界平等之地。观察普贤解脱境界。即闻普贤菩萨摩诃萨名字行愿。助道正道。诸地地。方便地。入地。胜进地。住地。修习地。境界地。威力地。同住渴仰。欲见普贤菩萨。即于此金刚藏菩提场。毗卢遮那如来师子座前一切宝莲华藏座上。起等虚空界广大心。舍一切刹离一切着无碍心。普行一切无碍法无碍心。遍入一切十方海无碍心。普入一切智境界清净心。观道场庄严明了心。入一切佛法海广大心。化一切众生界周遍心。净一切国土无量心。住一切劫无尽心。趣如来十力究竟心。善财童子。起如是心时。由自善根力。一切如来所加被力。普贤菩萨同善根力故。见十种瑞相。何等为十。所谓见一切佛刹清净。一切如来成正等觉。见一切佛刹清净。无诸恶道。见一切佛刹清净。众妙莲华。以为严饰。见一切佛刹清净。一切众生。身心清净。见一切佛刹清净。种种众宝之所庄严。见一切佛刹清净。一切众生诸相严身。见一切佛刹清净。诸庄严云以覆其上。见一切佛刹清净。一切众生互起慈心递相利益不为恼害。见一切佛刹清净。道场庄严。见一切佛刹清净。一切众生心常念佛。是为十。又见十种光明相。何等为十。所谓见一切世界所有微尘。一一尘中出一切世界微尘数佛光明网云周遍照耀。一一尘中出一切世界微尘数佛光明轮云。种种色相周遍法界。一一尘中出一切世界微尘数佛色像宝云。周遍法界。一一尘中出一切世界微尘数佛光焰轮云。周遍法界。一一尘中出一切世界微尘数众妙香云。周遍十方。称赞普贤一切行愿大功德海。一一尘中出一切世界微尘数日月星宿云。皆放普贤菩萨光明遍照法界。一一尘中出一切世界微尘数一切众生身色像云。放佛光明遍照法界。一一尘中出一切世界微尘数一切佛色像摩尼云周遍法界。一一尘中出一切世界微尘数菩萨身色像云。充满法界令一切众生皆得出离所愿满足。一一尘中出一切世界微尘数如来身色像云。说一切佛广大誓愿。周遍法界。是为十。时善财童子。见此十种光明相已。即作是念。我今必见普贤菩萨。增益善根。见一切佛。于诸菩萨广大境界。生决定解得一切智。于时善财。普摄诸根。一心求见普贤菩萨起大精进心无退转。即以普眼。观察十方一切诸佛诸菩萨众所见境界。皆作得见普贤之想。以智慧眼观普贤道。其心广大犹如虚空。大悲坚固犹如金刚。愿尽未来。常得随逐普贤菩萨。念念随顺。修普贤行。成就智慧。入如来境住普贤地。时善财童子。即见普贤菩萨。在如来前众会之中。坐宝莲华师子之座。诸菩萨众。所共围绕。最为殊特。世无与等。智慧境界无量无边。难测难思。等三世佛。一切菩萨。无能观察。见普贤身一一毛孔。出一切世界微尘数光明云。遍法界虚空界一切世界。除灭一切众生苦患。令诸菩萨生大欢喜。见一一毛孔。出一切佛刹微尘数种种色香焰云。遍法界虚空界一切诸佛众会道场。而以普熏。见一一毛孔。出一切佛刹微尘数杂华云。遍法界虚空界一切诸佛众会道场。雨众妙华。见一一毛孔出一切佛刹微尘数香树云。遍法界虚空界一切诸佛众会道场。雨众妙香。见一一毛孔。出一切佛刹微尘数妙衣云。遍法界虚空界一切诸佛众会道场。雨众妙衣。见一一毛孔。出一切佛刹微尘数宝树云。遍法界虚空界一切诸佛众会道场。雨摩尼宝。见一一毛孔。出一切佛刹微尘数色界天身云。充满法界叹菩提心。见一一毛孔。出一切佛刹微尘数梵天身云。劝诸如来转妙法轮见一一毛孔。出一切佛刹微尘数欲界天主身云。护持一切如来法轮见。一一毛孔。念念中出一切佛刹微尘数三世佛刹云。遍法界虚空界。为诸众生无归趣者为作归趣。无覆护者为作覆护。无依止者为作依止。见一一毛孔。念念中出一切佛刹微尘数清净佛刹云。遍法界虚空界一切诸佛。于中出世菩萨众会。悉皆充满。见一一毛孔。念念中出一切佛刹微尘数净不净佛刹云。遍法界虚空界。令杂染众生皆得清净。见一一毛孔。念念中出一切佛刹微尘数不净净佛刹云。遍法界虚空界。令杂染众生皆得清净。见一一毛孔。念念中出一切佛刹微尘数不净佛刹云。遍法界虚空界。令纯染众生皆得清净。见一一毛孔。念念中。出一切佛刹微尘数众生身云。遍法界虚空界。随其所应教化众生。皆令发阿耨多罗三藐三菩提心。见一一毛孔。念念中出一切佛刹微尘数菩萨身云。遍法界虚空界。称扬种种诸佛名号。令诸众生增长善根。见一一毛孔。念念中出一切佛刹微尘数菩萨身云。遍法界虚空界一切佛刹。宣扬一切诸佛菩萨从初发意所生善根。见一一毛孔。念念中出一切佛刹微尘数菩萨身云。遍法界虚空界。于一切佛刹。一一刹中。宣扬一切菩萨愿海。及普贤菩萨清净妙行。见一一毛孔。念念中出普贤菩萨行云。令一切众生心得满足。具足修集一切智道。见一一毛孔。出一切佛刹微尘数正觉身云。于一切佛刹。现成正觉。令诸菩萨增长大法成一切智。尔时善财童子。见普贤菩萨如是自在神通境界。身心遍喜。踊跃无量。重观普贤一一身分。一一毛孔。悉有三千大千世界。风轮水轮。地轮火轮。大海江河。及诸宝山。须弥铁围。村营城邑。宫殿园苑。一切地狱饿鬼畜生。阎罗王界。天龙八部。人与非人。欲界色界。无色界处。日月星宿。风云雷电。昼夜月时。及以年劫。诸佛出世。菩萨众会。道场庄严。如是等事悉皆明见。如见此世界。十方所有一切世界。悉如是见。如见现在十方世界。前际后际一切世界。亦如是见。各各差别不相杂乱。如于此毗卢遮那如来所。示现如是神通之力。于东方莲华德世界贤首佛所。现神通力。亦复如是。如贤首佛所。如是东方一切世界。如东方。南西北方。四维上下。一切世界诸如来所。现神通力。当知悉尔。如十方一切世界。如是十方一切佛刹。一一尘中。皆有法界诸佛众会。一一佛所。普贤菩萨。坐宝莲华师子座上。现神通力。悉亦如是。彼一一普贤身中。皆现三世一切境界。一切佛刹。一切众生。一切佛出现。一切菩萨众。及闻一切众生言音。一切佛言音。一切如来所转法轮。一切菩萨所成诸行。一切如来游戏神通。善财童子。见普贤菩萨如是无量不可思议大神通力。即得十种智波罗蜜。何等为十。所谓于念念中。悉能周遍一切佛刹智波罗蜜。于念念中。悉能往诣一切佛所智波罗蜜。于念念中。悉能供养一切如来智波罗蜜。于念念中。普于一切诸如来所。闻法受持智波罗蜜。于念念中。思惟一切如来法轮智波罗蜜。于念念中。知一切佛不可思议。太神通事智波罗蜜。于念念中。说一句法尽未来际。辩才无尽智波罗蜜。于念念中。以深般若观一切法智波罗蜜。于念念中。入一切法界实相海智波罗蜜。于念念中。知一切众生心智波罗蜜。于念念中。普贤慧行。皆现在前智波罗蜜。善财童子。既得是已。普贤菩萨。即伸右手。摩触其顶。既摩顶已。善财即得一切佛刹微尘数三昧门。各以一切佛刹微尘数三昧。而为眷属。一一三昧。悉见昔所未见一切佛刹微尘数佛大海。集一切佛刹微尘数一切智助道具。生一切佛刹微尘数一切智上妙法。发一切佛刹微尘数一切智大誓愿。入一切佛刹微尘数大愿海。住一切佛刹微尘数一切智出要道。修一切佛刹微尘数诸菩萨所修行。起一切佛刹微尘数一切智大精进。得一切佛刹微尘数一切智净光明。如此娑婆世界毗卢遮那佛所。普贤菩萨。摩善财顶。如是十方所有世界。及彼世界一一尘中。一切世界一切佛所。普贤菩萨。悉亦如是摩善财顶。所得法门亦皆同等。尔时普贤菩萨摩诃萨。告善财言。善男子汝见我此神通力不。唯然已见。大圣。此不思议大神通事。唯是如来之所能知。普贤告言。善男子。我于过去不可说不可说佛刹微尘数劫。行菩萨行。求一切智。一一劫中。为欲清净菩提心故。承事不可说不可说佛刹微尘数佛。一一劫中。为集一切智福德具故。设不可说不可说佛刹微尘数广大施会。一切世间。咸使闻知。凡有所求悉令满足。一一劫中。为求一切智法故。以不可说不可说佛刹微尘数财物布施。一一劫中。为求佛智故。以不可说不可说佛刹微尘数城邑聚落。国土王位。妻子眷属。眼耳鼻舌。身肉手足乃至身命。而为布施。一一劫中。为求一切智首故。以不可说不可说佛刹微尘数头。而为布施。一一劫中。为求一切智故。于不可说不可说佛刹微尘数诸如来所。恭敬尊重承事供养。衣服卧具饮食汤药。一切所须悉皆奉施。于其法中出家学道。修行佛法护持正教。善男子。我于尔所劫海中。自忆未曾于一念间不顺佛教。于一念间。生嗔害心我我所心。自他差别心。远离菩提心。于生死中起疲厌心。懒惰心。障碍心。迷惑心。唯住无上不可沮坏集一切智助道之法大菩提心。善男子。我庄严佛土。以大悲心。救护众生。教化成就。供养诸佛。事善知识。为求正法。弘宣护持。一切内外。悉皆能舍。乃至身命亦无所吝。一切劫海说其因缘。劫海可尽此无有尽。善男子。我法海中。无有一文。无有一句。非是舍施转轮王位而求得者。非是舍施一切所有而求得者。善男子。我所求法。皆为救护一切众生。一心思惟。愿诸众生得闻是法。愿以智光普照世间。愿为开示出世间智。愿令众生悉得安乐。愿普称赞一切诸佛所有功德。我如是等往昔因缘。于不可说不可说佛刹微尘数劫海。说不可尽。是故善男子。我以如是助道法力。诸善根力。大志乐力。修功德力。如实思惟一切法力。智慧眼力。佛威神力。大慈悲力。净神通力。善知识力故。得此究竟三世平等清净法身。复得清净无上色身。超诸世间。随诸众生心之所乐。而为现形。入一切刹。遍一切处。于诸世界。广现神通。令其见者靡不欣乐。善男子。汝且观我如是色身。我此色身。无边劫海之所成就。无量千亿那由他劫。难见难闻。善男子。若有众生。未种善根。及种少善根声闻菩萨。犹尚不得闻我名字。况见我身。善男子。若有众生。得闻我名。于阿耨多罗三藐三菩提。不复退转。若见若触。若迎若送。若暂随逐。乃至梦中。见闻我者。皆亦如是。或有众生。一日一夜。忆念于我。即得成熟。或七日七夜。半月一月。半年一年。百年千年。一劫百劫。乃至不可说不可说佛刹微尘数劫。忆念于我而成熟者。或一生或百生。乃至不可说不可说佛刹微尘数生。忆念于我而成熟者。或见我放大光明。或见我震动佛刹。或生怖畏。或生欢喜。皆得成熟。善男子。我以如是等佛刹微尘数方便门。令诸众生。于阿耨多罗三藐三菩提。得不退转。善男子。若有众生。见闻于我清净刹者。必得生此清净刹中。若有众生。见闻于我清净身者。必得生我清净身中。善男子。汝应观我此清净身。尔时善财童子。观普贤菩萨身。相好肢节。一一毛孔中。皆有不可说不可说佛刹海。一一刹海。皆有诸佛。出兴于世。大菩萨众。所共围绕。又复见彼一切刹海。种种建立。种种形状。种种庄严。种种大山。周匝围绕。种种色云弥覆虚空。种种佛兴。演种种法。如是等事。各各不同。又见普贤于一一世界海中。出一切佛刹微尘数佛化身云。周遍十方一切世界。教化众生。令向阿耨多罗三藐三菩提。时善财童子。又见自身。在普贤身内。十方一切诸世界中。教化众生。又善财童子。亲近佛刹微尘数诸善知识。所得善根。智慧光明。比见普贤菩萨所得善根。百分不及一。千分不及一。百千分不及一。百千亿分。乃至算数譬谕。亦不能及是。善财童子。从初发心。乃至得见普贤菩萨。于其中间。所入一切诸佛刹海。今于普贤一毛孔中。一念所入诸佛刹海。过前不可说不可说佛刹微尘数倍。如一毛孔。一切毛孔。悉亦如是。善财童子。于普贤菩萨毛孔刹中。行一步。过不可说不可说佛刹微尘数世界。如是而行。尽未来劫。犹不能知一毛孔中刹海次第。刹海藏。刹海差别。刹海普入。刹海成。刹海坏。刹海庄严。所有边际。亦不能知佛海次第。佛海藏。佛海差别。佛海普入。佛海生。佛海灭。所有边际。亦不能知菩萨众海次第。菩萨众海藏。菩萨众海差别。菩萨众海普入。菩萨众海集。菩萨众海散。所有边际。亦不能知入众生界。知众生根。教化调伏诸众生智。菩萨所住甚深自在。菩萨所入诸地诸道。如是等海所有边际。善财童子。于普贤菩萨毛孔刹中。或于一刹经于一劫。如是而行。乃至或有经不可说不可说佛刹微尘数劫。如是而行。亦不于此刹没。于彼刹现。念念周遍无边刹海。教化众生。令向阿耨多罗三藐三菩提。当是之时。善财童子。则次第得普贤菩萨诸行愿海。与普贤等。与诸佛等。一身充满一切世界。刹等行等正觉等神通等。法轮等辩才等。言辞等音声等。力无畏等。佛所住等。大慈悲等。不可思议。解脱自在。悉皆同等。尔时普贤菩萨摩诃萨。即说颂言

  汝等应除诸惑垢　　一心不乱而谛听
  我说如来具诸度　　一切解脱真实道
  出世调柔胜丈夫　　其心清净如虚空
  恒放智日大光明　　普使群生灭痴暗
  如来难可得见闻　　无量亿劫今乃值
  如优昙华时一现　　是故应听佛功德
  随顺世间诸所作　　譬如幻士现众业
  但为悦可众生心　　未曾分别起想念

尔时诸菩萨。闻此说已。一心渴仰。唯愿得闻如来世尊真实功德。咸作是念。普贤菩萨。具修诸行。体性清净。所有言说。皆悉不虚。一切如来。共所称叹。作是念已。深生渴仰。尔时普贤菩萨。功德智慧。具足庄严。犹如莲华。不着三界一切尘垢。告诸菩萨言。汝等谛听。我今欲说佛功德海一滴之相。即说颂言

  佛智广大同虚空　　普遍一切众生心
  悉了世间诸妄想　　不起种种异分别
  一念悉知三世法　　亦了一切众生根
  譬如善巧大幻师　　念念示现无边事
  随众生心种种行　　往昔诸业誓愿力
  令其所见各不同　　而佛本来无动念
  或有处处见佛坐　　充满十方诸世界
  或有其心不清净　　无量劫中不见佛
  或有信解离憍慢　　发意即得见如来
  或有谄诳不净心　　亿劫寻求莫值遇
  或一切处闻佛音　　其音美妙令心悦
  或有百千万亿劫　　心不净故不闻者
  或见清净大菩萨　　充满三千大千界
  皆已具足普贤行　　如来于中俨然坐
  或见此界妙无比　　佛无量劫所严净
  毗卢遮那最胜尊　　于中觉悟成菩提
  或见莲华胜妙刹　　贤首如来住在中
  无量菩萨众围绕　　皆悉勤修普贤行
  或有见佛无量寿　　观自在等所围绕
  悉已住于灌顶地　　充满十方诸世界
  或有见此三千界　　种种庄严如妙喜
  阿閦如来住在中　　及如香象诸菩萨
  或见月觉大名称　　与金刚幢菩萨等
  住如圆镜妙庄严　　普遍十方清净刹
  或见日藏世所尊　　住善光明清净土
  及与灌顶诸菩萨　　充遍十方而说法
  或见金刚大焰佛　　而与智幢菩萨俱
  周行一切广大刹　　说法除灭众生翳
  一一毛端不可说　　诸佛具相三十二
  菩萨眷属共围绕　　种种说法度众生
  或有观见一毛孔　　具足庄严广大刹
  无量如来悉在中　　清净佛子皆充满
  或有见一微尘内　　具有恒沙佛国土
  无量菩萨悉充满　　不可说劫修诸行
  或有见一毛端处　　无量尘沙诸刹海
  种种业起各差别　　毗卢遮那转法轮
  或见世界不清净　　或见清净宝所成
  如来住寿无量时　　乃至涅槃诸所现
  普遍十方诸世界　　种种示现不思议
  随诸众生心智业　　靡不化度令清净
  如是无上大导师　　充满十方诸国土
  示现种种神通力　　我说少分汝当听
  或见释迦成佛道　　已经不可思议劫
  或见今始为菩萨　　十方利益诸众生
  或有见此释师子　　供养诸佛修行道
  或见人中最胜尊　　现种种力神通事
  或见布施或持戒　　或忍或进或诸禅
  般若方便愿力智　　随众生心皆示现
  或见究竟波罗蜜　　或见安住于诸地
  总持三昧神通智　　如是悉现无不尽
  或现修行无量劫　　住于菩萨堪忍位
  或现住于不退地　　或现法水灌其顶
  或现梵释护世身　　或现刹利婆罗门
  种种色相所庄严　　犹如幻师现众像
  或现兜率始降神　　或见宫中受嫔御
  或见弃舍诸荣乐　　出家离俗行学道
  或见始生或见灭　　或见出家学异行
  或见坐于菩提树　　降伏魔军成正觉
  或有见佛始涅槃　　或见起塔遍世间
  或见塔中立佛像　　以知时故如是现
  或见如来无量寿　　与诸菩萨授尊记
  而成无上大导师　　次补住于安乐刹
  或见无量亿千劫　　作佛事已入涅槃
  或见今始成菩提　　或见正修诸妙行
  或见如来清净月　　在于梵世及魔宫
  自在天宫化乐宫　　示现种种诸神变
  或见在于兜率宫　　无量诸天共围绕
  为彼说法令欢喜　　悉共发心供养佛
  或见住在夜摩天　　忉利护世龙神处
  如是一切诸宫殿　　莫不于中现其像
  于彼然灯世尊所　　散华布发为供养
  从是了知深妙法　　恒以此道化群生
  或有见佛久涅槃　　或见初始成菩提
  或有住于无量劫　　或见须臾即灭度
  身相光明与寿命　　智慧菩提及涅槃
  众会所化威仪声　　如是一一皆无数
  或现其身极广大　　譬如须弥大宝山
  或见跏趺不动摇　　充满无边诸世界
  或见圆光一寻量　　或见千万亿由旬
  或见照于无量土　　或见充满一切刹
  或见佛寿八十年　　或寿百千万亿岁
  或住不可思议劫　　如是展转倍过此
  佛智通达净无碍　　一念普知三世法
  皆从心识因缘起　　生灭无常无自性
  于一刹中成正觉　　一切刹处悉亦成
  一切入一一亦尔　　随众生心皆示现
  如来住于无上道　　成就十力四无畏
  具足智慧无所碍　　转于十二行法轮
  了知苦集及灭道　　分别十二因缘法
  法义乐说辞无碍　　以是四辩广开演
  诸法无我无有相　　业性不起亦无失
  一切远离如虚空　　佛以方便而分别
  如来如是转法轮　　普震十方诸国土
  宫殿山河悉摇动　　不使众生有惊怖
  如来普演广大音　　随其根欲皆令解
  悉使发心除惑垢　　而佛未始生心念
  或闻施戒忍精进　　禅定般若方便智
  或闻慈悲及喜舍　　种种音辞各差别
  或闻四念四正勤　　神足根力及觉道
  诸念神通止观等　　无量方便诸法门
  龙神八部人非人　　梵释护世诸天众
  佛以一音为说法　　随其品类皆令解
  若有贪欲嗔恚痴　　忿覆悭嫉及憍谄
  八万四千烦恼异　　皆令闻说彼治法
  若未具修白净法　　令其闻说十戒行
  已能布施调伏人　　令闻寂灭涅槃音
  若人志劣无慈愍　　厌恶生死自求离
  令其闻说三脱门　　使得出苦涅槃乐
  若有自性少诸欲　　厌背三有求寂静
  令其闻说诸缘起　　依独觉乘而出离
  若有清净广大心　　具足施戒诸功德
  亲近如来具慈愍　　令其闻说大乘音
  或有国土闻一乘　　或二或三或四五
  如是乃至无有量　　悉是如来方便力
  涅槃寂静未曾异　　智行胜劣有差别
  譬如虚空体性一　　鸟飞远近各不同
  佛体音声亦如是　　普遍一切虚空界
  随诸众生心智殊　　所闻所见各差别
  佛以过去修诸行　　能随所乐演妙音
  无心计念此与彼　　我为谁说谁不说
  如来面门放大光　　具足八万四千数
  所说法门亦如是　　普照世界除烦恼
  具足清净功德智　　而常随顺三世间
  譬如虚空无染着　　为众生故而出现
  示有生老病死苦　　亦示住寿处于世
  虽顺世间如是现　　体性清净同虚空
  一切国土无有边　　众生根欲亦无量
  如来智眼皆明见　　随所应化示佛道
  究竟虚空十方界　　所有人天大众中
  随其形相各不同　　佛现其身亦如是
  若在沙门大众会　　剃除须发服袈裟
  执持衣钵护诸根　　令其欢喜息烦恼
  若时亲近婆罗门　　即为示现羸瘦身
  执杖持瓶恒洁净　　具足智慧巧谈说
  吐故纳新自充饱　　吸风饮露无异食
  若坐若立不动摇　　现斯苦行摧异道
  或持彼戒为世师　　善达医方等诸论
  书数天文地众相　　及身休咎无不了
  深入诸禅及解脱　　三昧神通智慧行
  言谈讽咏共嬉戏　　方便皆令住佛道
  或现上服以严身　　首戴华冠荫高盖
  四兵前后共围绕　　誓众宣威伏小王
  或为听讼断狱官　　善解世间诸法务
  所有与夺皆明审　　令其一切悉欣伏
  或作大臣事弼辅　　善用诸王治政法
  十方利益皆周遍　　一切众生莫了知
  或为粟散诸小王　　或作飞行转轮帝
  令诸王子采女众　　悉皆授化无能测
  或作护世四天王　　统领诸龙夜叉等
  为其众会而说法　　一切皆令大欣庆
  或为忉利大天王　　住善法堂欢喜园
  首戴华冠说妙法　　诸天觐仰莫能测
  或住夜摩兜率天　　化乐自在魔王所
  居处摩尼宝宫殿　　说真实行令调伏
  或至梵天众会中　　说四无量诸禅道
  普令欢喜便舍去　　而莫知其往来相
  或至阿迦尼吒天　　为说觉分诸宝华
  及余无量圣功德　　然后舍去无知者
  如来无碍智所见　　其中一切诸众生
  悉以无边方便门　　种种教化令成熟
  譬如幻师善幻术　　现作种种诸幻事
  佛化众生亦如是　　为其示现种种身
  譬如净月在虚空　　令世众生见增减
  一切河池现影像　　所有星宿夺光色
  如来智月出世间　　亦以方便示增减
  菩萨心水现其影　　声闻星宿无光色
  譬如大海宝充满　　清净无浊无有量
  四洲所有诸众生　　一切于中现其像
  佛身功德海亦尔　　无垢无浊无边际
  乃至法界诸众生　　靡不于中现其影
  譬如净日放千光　　不动本处照十方
  佛日光明亦如是　　无去无来除世暗
  譬如龙王降大雨　　不从身出及心出
  而能沾洽悉周遍　　涤除炎热使清凉
  如来法雨亦复然　　不从于佛身心出
  而能开悟一切众　　普使灭除三毒火
  如来清净妙法身　　一切三界无伦匹
  以出世间言语道　　其性非有非无故
  虽无所依无不住　　虽无不至而不去
  如空中画梦所见　　当于佛体如是观
  三界有无一切法　　不能与佛为譬谕
  譬如山林鸟兽等　　无有依空而住者
  大海摩尼无量色　　佛身差别亦复然
  如来非色非非色　　随应而现无所住
  虚空真如及实际　　涅槃法性寂灭等
  唯有如是真实法　　可以显示于如来
  刹尘心念可数知　　大海中水可饮尽
  虚空可量风可系　　无能尽说佛功德
  若有闻斯功德海　　而生欢喜信解心
  如所称扬悉当获　　慎勿于此怀疑念

大方广佛华严经卷第八十


等目菩萨所问三昧经卷上

    No. 288 [No. 279(27)]

等目菩萨所问三昧经卷上　　　　　　　　　　(一名普贤菩萨定意)

        西晋月氏国三藏竺法护译

    大感动品第一

闻如是。一时世尊。游于摩竭境界法静道场。初始得佛。光炜明曜。宣真谛藏。演如来慧。畅三世要。布无挂碍道宝之定。佛时以此普智无极[火*霍]然正受。其定惔怕。忽无形像。亦无中外。静无见闻。所居正受。乃大旷荡。汪洋无极。难遇难闻。亿世之遇。时逮此定。佛定无量。无不昉彻。以悉通慧。得普智力。无限清净。斑赞如来。以无巢窟。陶现佛身。得大空寂微妙之句。乃弘无极佛诸感动。等无所住。而转慧行。名称普世光扬如来。应时之兴。为现佛土。以其一相。了达无相。无相无行。亦复无相。威炎亘然。照于十方。无上佛定。震曜如斯。尽极诸土。同时现变。都世一切。莫不雅奇

尔时会场。有一菩萨。名曰普贤。承佛圣旨。而自念曰。今日如来。所现感变。从往古来。所未闻睹。如是瑞应。必有殊特无尽之要。当使他方诸大菩萨咸共受持。即如其像。而为正受。放大金光。照十方土。于光明中。散天华香。而作天乐。其乐柔和。同一洪音。普贤菩萨。告诸族姓子。释迦文佛。今日当演未曾有法。族姓子等。所欲者成。寻顷之时。菩萨大士。如尘之数。普悉来会

是时世尊。以大正受。靡不贯焉睹于诸众。无不明尽生者终者。及其成灭。以所正受。悉无不达。旷定普至。无窈不彻。察众来会。纯悉菩萨。皆大童真。为摩诃萨。如十方土尘埃之数。志悉高妙。独步殊特。悉在最署。封拜无上法身无量。而皆具足。名流显称。普至十方。各住要行。所住如佛。势力无敌。猛喻师子。得金刚志。慧无挂碍。智德纯厚。重过须弥。心喻虚空。而不可量。揽总持慧。而自娱乐。晓了诸法本无之界。尽得诸佛相好庄严。皆能分身。十方现化。悉于极世。如佛感动。游步无侣。威神独尊。能于十方。大师子吼。以金刚志。陷碎魔怨。伏之以慈。降顺唯德。却众外道。进退自由。道德正想。祐济一切。皆雷法鼓。已举法幡。震鸣法珂。列竖法幢。其所游居。莫不信解。尔时于是来会菩萨。各随行立字。其名曰刚意菩萨。过意菩萨。说意菩萨。上意菩萨。施意菩萨。龙意菩萨。果意菩萨。调意菩萨。力意菩萨。旷意菩萨。无限意菩萨。解意菩萨。最意菩萨。天意菩萨。祠意菩萨。处意菩萨。事意菩萨。尊意菩萨。法意菩萨。寂意菩萨。德意菩萨。一意菩萨。一相菩萨。善意菩萨。幻意菩萨。大意菩萨。势意菩萨。人意菩萨。佛意菩萨。达意菩萨。长意菩萨。无思菩萨。无边菩萨。严志菩萨。无际菩萨。严本菩萨。深界菩萨。普便菩萨。龙明菩萨。持曜菩萨。佛土菩萨。心王菩萨。一行菩萨。升通菩萨。达慧菩萨。福行菩萨。法炽菩萨。明世菩萨。持世菩萨。兴安菩萨。最上菩萨。无上菩萨。无比菩萨。无等菩萨。明光菩萨。光曜菩萨。美光菩萨。一王菩萨。势业菩萨。法雨菩萨。持妙菩萨。普严菩萨。慧眼菩萨。法首菩萨。慧云菩萨。持地菩萨。法王菩萨。善建菩萨。最愿菩萨。行妙菩萨。慧藏菩萨。意王菩萨。修内意菩萨。普智菩萨。持过地力菩萨。土力势菩萨。善月菩萨。大山顶首菩萨。宝山顶菩萨。放光菩萨。上场王菩萨。无当势场菩萨。无胜威菩萨。大龙首菩萨。道首菩萨。普调菩萨。无退进菩萨。持佛英轮菩萨。无惑菩萨。威行菩萨。无思意菩萨。无量意菩萨。佛变菩萨。无尽藏菩萨。慧首菩萨。法耀菩萨。慧茂藏菩萨。雨觉雨菩萨。边现菩萨。无愚现菩萨。刚通菩萨。慧刚菩萨。金刚耀菩萨。慧刚意菩萨普目菩萨。广目菩萨。吉首菩萨。如佛威菩萨。持佛金刚菩萨。严普智菩萨。慧庄菩萨。普贤慧藏菩萨。如是等十方佛土。如虚空等尘菩萨摩诃萨。一切悉与堕楼近菩萨。(丹本随楼延菩萨)宿共等行。修菩萨德。德皆具足

尔时等目菩萨。承佛威神。忽从坐起。偏袒右肩。右膝着地。向佛叉手。白世尊曰。欲问如来平等正觉。若当听许乃敢自陈。佛告等目。随若所问。恣问如来。佛从汝意。当为发遣。令汝欢喜。于时等目。寻白佛言。云何世尊。菩萨。为以几无思议之定。得应普贤菩萨之行。而致与等勇世誓愿。及其所修。庄严定行。于定自在。而以娱乐。以其定力。感动诸定。唯愿如来解说议归。于是世尊。告等目曰。善哉善哉。等目菩萨。乃为去来现在诸佛菩萨。广其道场。宣畅要议而质是问耳。若是等目。普贤菩萨。今在此会。得无思议菩萨感动。为修无量菩萨之行。得无思议菩萨变化。已净菩萨难值之愿。致无退还。菩萨生行。修诸无量。广德净行。等越无量。辩才无碍。以大悲于诸无厌。以诸愿于际无扰。咸当共请此彼。当说诸定正受卓变之行。于时众会。闻彼正士所入名称。皆与恭敬。普有瞻望。欲见普贤菩萨而不睹之。不闻言音及坐处所。所以者何。如来威神。普贤菩萨力之所致

尔时等目菩萨。前白佛言。普贤菩萨。今所游在佛告之曰。普贤菩萨。在斯会场吾膝左右。游居不动。时等目菩萨及与大众。以其神力悉观察之。不知所在。重白佛言。吾等不睹普贤菩萨及其坐处。世尊告曰。如是族姓子。汝等不见普贤菩萨身及坐处。所以者何。其普贤菩萨。处深行故。不可得以。其慧行住无碍。得如师子强猛之故。得佛无上感变。寂无碍际。住佛十力法界首藏。致佛威神。严无毁慧。于三世等。诸佛法身。普贤菩萨。净一心界时。等目菩萨。于如来所。闻普贤菩萨德行。修菩萨十定。皆愿见普贤菩萨。思侥推求。等目菩萨。及一切众。都不见普贤菩萨。时等目菩萨。从定寤起。而白佛言。吾以十无数千三昧。而正受。亦不见普贤菩萨身口意行及其处所。亦复不睹所住游行之地

佛告等目。如是如是。汝等不见普贤菩萨。所以者何。已学菩萨行无尽地。又是等目。其于明慧幻化字说。宁可分别慧幻色不。曰不可。世尊。其幻化不可处别。况其普贤菩萨。身口意行。见可入处。所以者何。以其深邃无思议德备之故。亦以无量敷演无尽故。解达金刚之慧。取要言之。晓了无量诸法性界。于诸刹土。而无所著。于一切身。解无体行。无所入。无所有法等吾我神足境界。而无毁坏诸住际者。而无著财。以神通解本无。诸族姓子。欲见普贤菩萨者。彼无蔽碍。闻亦无碍。礼敬无碍。心敬无碍。意念无碍。趣向无碍。睹见无碍。修入无碍。求索无碍。普贤菩萨志愿。彼无缚碍。时等目菩萨。及诸菩萨众。咸悕乐欲见普贤菩萨。并共叉手向顶。作是言曰。自归诸佛。自归普贤。三称如是。于是世尊。告等目曰。当察此菩萨大会。吾告敕汝。汝当请普贤菩萨。都向诸方。以其明目。正在身中。以求索普贤。以诸法本而定正受。解法无欲。当以一心。向普贤菩萨。当解本无之际。身之吾我使立诸土。当分别诸根。普使所至。永致普贤。作是行者。乃见普贤。时等目菩萨及会大众。从世尊闻即以头面为礼。咸请普贤。其请之顷。普贤菩萨。兴为感动。使其大众咸见普贤。于世尊足左右。坐大莲华上。其此众会。一切菩萨。出现其身中。于诸国土。莫不见者。其去来普土诸佛。展转相见。诸佛之音。畅三世慧

尔时等目及菩萨众。见是变化。咸悦欢喜。率礼普贤。尔时以佛威神亦普贤菩萨宿德所致。天雨众华。纷纷而降。诸天璎珞。箜篌乐器。相和而鸣。天雨泽香。遍诸佛界于虚空中。有天鸾音。诸三恶趣。一时休息。无量大脱菩萨之众。登时悉解普贤菩萨诸德之行。尔时等目。而白佛言。此普贤菩萨之德。为无有量。不可限行。为无称限之行。为无断行。为无转行。普流之行。为无所不周至。为无回还之行。分别诸法行明。无分别随一切方便之行。等过口行。世尊告曰。如是。等目。如尔之言。普贤菩萨。以净无数众生。无极清净。无量功德。兴无数福。修无数相。德备无限。行无等伦。名流无外。无得之行。普益三世。有佛名誉。普而流着。普贤菩萨。行绩若斯

    等目菩萨说行定品第二

尔时佛告普贤菩萨。当为发遣等目菩萨所欲。并诸菩萨畅诸菩萨场。当说菩萨摩诃萨十定方便。普贤菩萨本行功德。咸修当行。何等十。一曰。得初始大德之明。菩萨摩诃萨方便之善。二名悦向大定之行。得菩萨摩诃萨方便之行。三名明度诸刹之清净。四名修内性之清净。五名过去藏之清净。六名照明慧藏。七名诸佛慧音清净之声彻诸佛土。八名分别一切众生身行法界而得自在。九名得无著旷荡之行。十名得致菩萨摩诃萨大行方便。此为菩萨摩诃萨十大定。此为去来现在诸佛所说。已说今说当说。其诸菩萨。能行十定心。入是者。此名为觉。此名为正觉。此谓如来为持十力。此名为导师。名为大师。名为普智。名为显现。名无尽行。名无限行。名最法导。其得是三昧。为普现诸佛国。于诸国土。游乐自在。彼则督住众生之界。为达众生所入。为致无疑之藏。为入法界要行。为觉明无量法界。为达去来现在诸如来行。为见诸如来法。为述解达诸言说利偶。为得音声字句之行。为具足菩萨清净之行。为得住菩萨诸愿之行。彼于三世。明一时行。了一切无二之行。能说诸佛法。以方便行。转诸法轮。而不回还。悉觉去来现在诸佛之要行。以一佛之觉寤。说诸佛之要。此则诸菩萨法要。彼觉此慧。明了普智。无胜踰者。为具足普贤之行。为明利菩萨诸定慧行。得诸总持。分别三世。得睹去来现在诸佛。成立一切于普智之慧。此则菩萨诸土清净。此则得睹诸佛行处。菩萨得是法要者。于菩萨法界。而有强力。以此十定。畅无边德。德如虚空。为无限之边际。明照无量。为世法王。普于众生。得无量慧。广分十力。明畅闲居。修静之心。普入于寂静之行。以大慈如师子。为慧丈夫。为显法炬。诸德之名。而无断尽。普世声闻缘觉。而无思议。通达法界。已住法积。晓种种说权方便行。明达一切诸音声说。得持无像。解像方便。得净所生。则净佛种分别法等。则与慧等晓解法施。入常方便畅有顺实。普化慧道。明净内性。能普受众行。兴诸道场。慧寤觉道。于菩萨处。而无限尽。普能示现诸大变化。明普智行。觉寤方便。此谓普贤之说。是为菩萨十定广普之行分别之说。此谓菩萨之要行

于是等目菩萨。从佛闻知。当应请其彼菩萨。咸乐等目菩萨。所与告诸菩萨众。是族姓子等。有十正受。为应菩萨无余之法。何谓十。兴于佛法以顺慧行。化度众生顺入慧行。明诸国土了声慧行。惟法界慧。受菩萨方便慧行。入不退转菩萨之慧。为诸众生观法慧便。制持心力方便之慧。广入菩萨心行之慧。诸佛普智法兴愿之慧。是族姓子。此谓菩萨摩诃萨十无余荡尽之法

又族姓子。复有菩萨摩诃萨十法兴无量心慧。何谓十。谓为明解众生境界。度诸兴起。自了心起。谓过诸佛。兴无数心。奉诸佛德。兴心众养。谓睹佛而有无量。目所见者。兴无量心。谓遇诸佛所入音声。而受度之显无数心。谓诸佛之限。分别遇其方便之慧。是谓贤圣兴无数心。谓如来道入无著之力为兴无数心。谓普智力。当行微妙。兴致佛法。以善分布兴无量心旷荡之行。谓佛境界。而无有量普入之行。为兴无数明心之行。谓佛辩才。内性所愿。皆获而致。求诸佛法兴无数心。谓如来会场。普而入现诸身处兴无数心。是族姓子。菩萨大士。兴十无数心

又族姓子。菩萨大士。复有十德入定意慧。何谓为十。一者在东正受。忽南起寤。二者处南正受。在东觉寤。三者东北正受。西南而寤。四者西南正定。东北为寤。五者在南慧定。忽北现寤。六者于北现定。出南而觉。七者西北入定。东南现寤。八者东南而定。西北兴寤。九者居下正受。忽上方寤。十者上方正受。下方亘寤。是族姓子。菩萨大士入十定意分别之慧。又族姓子。菩萨大士。有十大定方便之慧。何谓为十。是族姓子。菩萨大士。现三千大千之土在一莲华之上。自见己身。在其华上。结加趺坐。于三千大千。而现其身。于三千大千。而现其明。于一一方。而立其身。以一一之身。入三千大千之土。于诸刹土。一一四天下。现亿百千菩萨。于一一菩萨行。现亿亿顺度之化。于一一所化。复现亿亿分别。具满诸根。于一一分别诸根。而得具满亿千菩萨。皆是不退转法者。不为一身。亦不多身。亦不入正受。亦不觉寤。譬如族姓子。阿须轮王。其本身长七百由延。神力现身。六十八百千由延。立于大海。出现半身头与须弥山为齐。所现化身。六十八百千由延。于其本体。不有毁减。如本王体。四大之身。亦无疑惑。又于大体。想若他身。于本身者。不想终没。以所王身。憎然一常。以化为乐。化为旷力。以尊能化。所现不疑。亦复无惑。彼阿须伦。怀有贪淫嗔恚愚痴垢毒诸秽。兴邪贡高。处于大海。止有宫殿。由能兴立化身如是。况其菩萨。大士之等。晓了幻化诸法要者。明解睹世。皆如梦耳。知诸佛兴。明达普世。悉了了之。亦如化矣。解诸音声。皆如响耳。观于诸法。而顺度之。又如法身。本之清净。晓入诸法。亦复如是。明了身心。旷无所有。解无数身所入之处。皆发为佛。行道清净。其得住于斯大定者。岂应有疑。况当惑哉。何得闻耶。其行如是。致大定场。睹世现身。身入普世。如彼水神。立于本位。因所受体。变化大身。譬如族姓子。比丘观身。内外不净。亦观色识悉皆如之。精勤修行。菩萨大士。亦复如是。以观法身。而建显行。其所入者。彼悉睹世。亦见世法。于其世法。净无所著。此则菩萨。感动境界。由斯大士。得正定故。是族姓子。菩萨大士。入于普世。世所不动也

    等目菩萨神变品第三

又族姓子。菩萨大士现三千大千土其数如尘。一一尘土。入而现身。于一一身。现明普照。于一一明。现众色像。复一一相。现有宣畅。一一宣畅。现化众生。而于彼此。菩萨悉知诸土所有。解土欲着。明土清净。晓入诸土。知土所处。了土住止。明晓诸土。知诸土行。如其菩萨。入土如之。如其土菩萨入如之。不以想土。而现所生。不以法本。有所毁土

譬如族姓子。日欲出时。日光先照于七宝山。其七宝山。绕须弥山者。明复次彻七山之间。日炎转[火*霍]。山之金精。其明展转。相晃昱昱。夫日行照。从次悉明。日之宫殿。普遍明昺。又日宫殿。弗有其限。亦无所碍。不念所照。亦无所照。又其日光不着于山。亦不离山。其日明者。不在虚空。不离虚空。如是族姓子。菩萨大士。以此之明。人普等住于大定者。斯须一时。一日一夜。半月一月。一岁百岁。及劫兴衰。有着无著。广狭粗细。喜有佛世。及菩萨众。有遇佛时。一切所止。佛土清净。诸所住处。种种类行。普无数众。生死无量。不可思议。有去来见。无去来见。及种种宝。至无量宝。种罪种罪复报。应清净人彼国土处。普念诸土。诸所有土。极于众刹人是菩萨。尽悉现之。都入了现。游之教之。如是族姓子。菩萨大士。以住此定。于诸土不想所止。于诸法不离法本。亦不入土。亦无所想人彼菩萨不想刹外。不想有土。不想无土。不坏土想。亦无所毁。又彼菩萨。于诸法。不一想。不非想。亦不求法。亦不毁法。法界本无皆悉了之

    等目菩萨幻事品第四

譬如族姓子。幻名帝父。帝界所行。其有善学行此幻者。明晓术已。于四幻道。现此帝父大幻之事。普众咸住。共观视之。诸天都聚。在于一处。现一日七日。半月一月。一岁百岁。复现城墎。县邑聚落。复现江湖渊海。河流诸水。现云兴雨。作此大变。现严诸土。不以所现与岁月诤毁。所现幻化。兴天欢乐。而于幻体。亦无所损。诸天见之。亦无疑怪。是菩萨大士之等。以此大定而为正受。于一刹土。现无数土。有其诸大地水火风。如海宝山。及须弥山。铁围山大铁围山。尽人境界。城墎县邑。及诸聚落。像天宫殿。诸龙宫室。众神所处。香神所居。水神所游。瘿神所之。伎神所乐。恬神所安。又像极世诸所宫殿。及欲色界。至无色界。又小千土中千土。三千大千土。有罪无福。一切众类。转身生死。明达尽之。于彼等念。入以明慧。审见无见。于诸刹土。不有疲劳。弃此刹劳。不有斯劳。弃诸土行。无土无行。所以者何。伏入法故。又彼菩萨。于诸法入无著法。于诸法界。不想有念。空无所行。于诸刹土。不想空行。于诸受身。亦无寿行。因缘诸法。如审谛见。亦无命行。于诸起灭。化转以法。于化无化。菩萨以法。具愿入故。菩萨行寂诸法静故。菩萨行化不想化故。普度众生等如来法之清净故。菩萨法界。行无思议法无取故。菩萨行悲。普悉善权化众生故。菩萨如是。处于一刹。明无数刹所住行处。了无数类众生身行。现于无数菩萨修立。念于无数佛之兴显。受诸如来平等正觉。法要之说。于彼自修菩萨行。于此寂没。而彼等现。于彼寂没。忽此等现。行不毁吾。入于法界。明入寂静。忆念于慧。以益于冥。如彼幻师住于此地。而现幻化。不以现幻。有损于地。所现幻事。依因于地。幻不念昼夜。不坏时节。菩萨如是。以无刹界而入于土。以无国土明了于国。又以国土而晓无国。以无色处现住于色。不以一而毁于二。亦不以二而毁于一。譬如幻名解普土法。入于法幻。明入慧幻。已入慧幻。晓入行幻。已入行幻。而兴慧幻。而以慧幻。了别诸行。如彼幻士。不于地外。而现其幻。亦不在众观人之外。菩萨如是不以虚空入诸国土。不以土外而入虚空所以者何。土入虚空而无毁故。能入国土则入虚空。是彼菩萨。普严庄校。以土境界。入文诸行。等见无见。致以无怀。修明解了。行而观之。一弹指顷。遍无数土。悉了诸所。生于劫过。劫所可行者。以一时间。于无量劫。复过是数。过所兴积。不有惟想此之过劫。一弹指顷。广所现作。不以意念。乐慧幻故。是菩萨学明度无极。以过慧幻。达入世幻。明越法幻。与世幻无诤。普遍慧行。幻极三世。而过无数。幻过通慧。入于心幻。过亿无限。过诸佛幻。普度无极。菩萨如是。解入诸土。都土都悉晓了。永无所著。都亦无念。如彼幻士因帝网幻。普现诸幻。不处于幻。亦无所惑。菩萨如是。得入诸法度无极者。不念入法。入法不惑。是菩萨名广普大定

    等目菩萨经菩萨乐定品第五

又复诸族姓子。等目菩萨摩诃萨。东方去此。过无数佛刹。于彼有土。名最上度无极。于彼有定正受。号无上度无极。如其所过本土。乃得最上之土。其土或有土而正受。或早时。或中时。或复晡时。或西时。或晚时。或念之顷。或斯须之顷。或时节之顷。或五夜间。或十五日间。或一月间。或复一岁间。或百岁间。或千岁间。或千万岁时。或亿万岁时。或亿百千万岁时。或亿那术百千万岁时。或一劫时。或百劫时。或千劫时。或百千劫。或亿千那术劫时。或无数劫时。或无量劫时。或无边幅劫。或复无限劫。或无尽劫时。或无思议劫时。或无限如虚空劫时。或有无限念劫时。或有无限量而过量劫时。而彼菩萨。不以法之时故有住而有欲想。亦不以时节之住而有欲想。又彼菩萨。不以种种之时而起疲劳想。亦不于中而起想。亦无二行。亦无吾作。亦不有念。亦不无念。亦无想念。亦不念坐定。亦不有起想。以一切诸法无限量故。譬如日天子。与诸天而有所照道。日者行之。诸天亦无行止。日亦不夜出。亦不念昼。日日已没。乃知耳。亦非彼天所知也。亦不坏败于夜。菩萨摩诃萨。亦如是。以通此定。于无数国土。而定正受。亦无时节之念。亦无其念想。是谓族姓子。菩萨摩诃萨。所名土最上度无极之定。为无上无比权慧之行也

    等目菩萨大权慧定品第六

又族姓子。菩萨摩诃萨。于一切众生之身佛身。而等解之。彼以此。多观如来。于无数国土。如尘数。于诸如来一切。而供养。一切众花。一切极世众宝。以供养。一切众宝供养。散其上。一切众饰供养。种种经行之处供养。以无央数一切摩尼宝。起塔精舍。而供养所可供养。过天之所作所为供养。皆佛之威神。一切佛土清净。种种供养。皆佛所念佐接。而以此供养佛。亦以供养诸佛礼足。彼诸如来。以尽身之化。而[打-丁+(目*夬)]以其恭肃。而问诸佛法。愿说诸佛平等法。敷演诸佛大法。入诸佛要行。行于大悲。入于无限顺行等力。思诸佛入诸众生要。明入本积。亦不知佛之兴。亦不觉诸如来灭。譬心之兴念。亦不知所由起。亦不知其所归。菩萨亦不觉如来起。亦不觉如来灭。譬如于昼日时。野马之河。亦不由阴有。亦不出于彼泉。亦不处于地。亦不从东嵎来。亦不有。亦不无。亦不善。亦不不善。亦不清亦不浊。亦不可饮。亦不可污。亦不有。亦不无。亦不味。亦不可味。有形如水之像。缘此而兴念。如野马之河。便有河想之念此去想念。而远于近。而无所毁。野马之河。亦不可处。菩萨亦如是。于诸如来不兴。亦不识如来兴。亦不识如来灭。以相想诸佛有耳。以无相而无想。是诸族姓子。诸菩萨大士。名曰清净之定。以此定正受。而觉寤。而不失其定。譬如明了人寝寐。于梦中所行。知皆无因缘。悟以皆识知之。菩萨大士。亦如是见诸佛而忘其识。持诸佛法。知诸如来众坐之场。胜致诸佛土清净。解了谊理。明了分别诸法之要。广显诸法之因缘。显益佛种行净诸佛威神。广演诸佛辩才。是族姓子。诸菩萨大士大定之权慧也

    等目菩萨无量如品第七

又族姓子。菩萨大士行。念过去诸佛如来。兴度无极。至劫过劫。过诸土尽无极。明知诸土尽劫过劫。当明知诸佛之兴。尽劫过劫。明了诸佛。兴敷说经。度无极法。从劫过劫。说法度无极。明知意行度无极。明诸情度无极。于情度无极。知行种种。乃明了种种如来寿命。彼此皆知。于诸寿命。过岁亿那术。彼此皆知。彼以此慧而行。知无量如来贤行。本无无量贤。明知过去诸土。本无无量。明知过去诸劫。本无无量。如过去明知如法本无无量如。知过去心本无无量如。知过去脱本无无量如。知过去众生行本无无量如。知过去所说本无无量如。知过去起本无无量如。以其定正受。名曰过庄严藏。以发一心。能过百千劫本无无量。以其心。过亿百千那术劫。复过无数劫。复无思议劫。复过无称限劫。复无边劫。复无量劫。复过阿僧祇劫。复过不可思议劫复过无望劫无望。复过无望劫。其因缘。而无有灭。过去无所因定正受。而立其十法。为彼定。复有悟。亦立其十法。于诸如来。得入不思议。亦清净而起。亦无住修立。得之督致之。受满奉持。求平等入三场。何谓十。一者解了本痴之行。二者辩解无尽法。三者分别无毁无诤。四者分别无住。五者辩才无动。六者已所说而至诚。七者为一切依住。八者悦向三界。九者为诸德本之上。十者于诸法而无轻慢。此族姓子。是为十无限定之行。其是十定而悟。譬如族姓子。身在胞胎。当应生者。神识已入。其此时间。菩萨亦如是从定悟。以此十。而流注于法。其时得是族姓子。菩萨大士。得过去清净也

等目菩萨经卷上佛说等目菩萨经卷中

        西晋月氏国三藏竺法护译

    权慧清净品第八

又复族姓子。菩萨大士。以一一国净故。便入一一土。乃已修一一土。而现于一一土。顺持一一土。则住一一佛国土便明一一佛国土已。晓了一一土。便游转一一土。则了知一一土清净。于彼诸土。于诸当来。为人之上。于诸土。在诸劫数。而有所说。于诸劫。明了诸像。于诸劫而悉分别之。于诸劫。而顺导之。于诸劫。而念平等。于诸劫。莫不兴发。于诸劫。而行无量。于诸劫。香有普美。于诸劫。而有伤愍。于诸劫。无有过去诸佛世尊。当来所说。或无所说。有所授决。无所授决。众异名号。无数名号。无量名号。无限名号。无边名号。阿僧祇名号。无思议名号。无际名号。无望名号。其当兴起。愍度众生。现为法王。修行为导故。而当普说三十七品。广叹诸功德行。当广演说明显之行。又当清净其意。性行修立。当成众德之行。当广宣布。要上之行。又当建立普智之议。亦当过度诸如来行。亦当修成具足诸愿。又亦行过具足之慧。晓了明尽成德之善。又过于最上庄严。明晓之行。立上眷属。亦复晓了。具足于法。又复修晓罪福之应。又复修观成相具足。晓了解知具足之善。晓了解达平等之德。亦晓了诸佛世尊意。亦知其种姓。解其权行。亦知方便。知其变化及所趣向。亦知成佛。知度人物。知度无数众生。知诸如来般泥洹。知诸佛时节。而其发心顷。明了劫事。复过百劫千劫。百千劫亿劫。又过阎浮提如尘数劫。复过四天下如尘数劫。过千天下如尘数劫。过大千如尘数劫。过三千大千刹土如尘数劫。过如诸佛国尘数之劫。复过如千佛国如尘数劫。复过如百千佛国尘数之劫。复过亿那术佛国如尘数之劫。复过无数佛国如尘数之劫。复过不可计劫。复过无量如尘数之劫。复过无边际如尘数之劫。复过无称限尘数之劫。复过阿僧祇尘数之劫。复过无思议尘数之劫。复过无我限尘数之劫。复过无限乐尘数之劫。复过乐无乐尘数之劫。菩萨以住慧明藏三昧。受持一一国土之说。如是亦入一一国土种姓如一一国土。于无限乐尘数之国。亦尔。明知当来无限国土。菩萨以慧定。而普入意所向念。有十依住处。何谓十。一者谓思乐佛土。如尘数如来所建立。其菩萨。为佛威神所立。二者菩萨为法所住立。于世明达十总持。已得十总持。究竟无尽辩才。三者菩萨依行。为行所立。究竟最愿。而行具足。四者菩萨依德力而得立。而无能过胜者。五者菩萨依慧而立。于佛法行无碍故。六者菩萨依大悲立。转于法轮。以无回还故。七者依彼众行而立。于众文字诸法之行。善修立故。八者菩萨依诸所生最上法立。开甘露门。闭诸恶之门故。九者菩萨依慧力立。行菩萨行。而无断故。十者其菩萨依等力立。具足于施力。度无数众。使行清净菩萨所依无数力故。明了无限数劫。菩萨得依法力。以诸法本清净故。诸所生无数故。此谓菩萨摩诃萨第六最大慧定之行

其菩萨住是得致晓了无限数劫行。明了分别无限数劫权便之行。晓了无限数众生所行权行之相。于无限数罪福之行。分别已达。而得权行。复于无限数所行精进。现入众生于行无行之权。便于行无行。于善恶有无限数之权行。于行无行诸法。解达权行。于行无行。于诸时佛兴。如其像。如其说。如其起尽诸佛行解了诸佛种姓权行。于行无行。解说无量慧门。回转权行。于行无行。普智感动。无数变化。如时示现之权行。譬如族姓子。日天出时。有目之人。展转见诸郡国县邑聚落。亦知高下山川崄峪。知诸树木种稷。知诸好丑。亦知净不净。世之所有。亦知之。明目解达。有了意当观。族姓子。日光之无异。而其明照。现有目者。因其光普见众色。如是族姓子。其菩萨已达无异之定。明了一切有行无行。亿百千那术。知其种稷。明之识之。以其明了。以十无惑。充满十方一切众生。何谓十。一者现于众生。不惑德本。二者无惑化度于众生。三者无惑处度众生。四者无惑于众生所兴行如应如言。究竟诸议。五者所行无惑。于诸国土而清净。六者诸所入无惑。于诸佛土。所行无行。于行无行。决众生狐疑。七者无惑所誓愿。如所请众生济度于行而具足诸愿。八者无惑权行之法无限碍清净慧门。九者无惑法说。能普法雨。罔制诸情。于行无行。于普智行。使立佛道。十者无惑慧之重任。无限清净慧门之行。无惑出现无冥。而明照普世菩萨已住十无惑行法已。住是定。其菩萨。寻从定起。为诸天帝所礼为诸龙帝所敬。而雨美香。为诸神帝所见礼。奉为诸谅帝所见宗敬。为诸凤凰帝神所见归向。为诸梵帝稽请。为诸乐神帝所见叹美。为恬神帝所见赞叹。为诸香神帝所见追寻。为诸人帝所见供养。是族姓子。诸菩萨。以慧明藏定。名为第六兴显大慧方便行也

    等目菩萨兴显品第九

又复族姓子。菩萨大士有定。名诸佛明显国土清净。云何族姓子。诸菩萨诸佛明显国土清净定而正受乎。于是菩萨。入于东方世界。从一国土。至一国土。于西南北方及四隅上下方。亦从一国土至一国土。于彼诸土。普现兴佛事。于诸如来前。现佛感动。现佛娱乐。现佛显尊现佛境界。现佛自在。现佛师子吼。现佛诸行。现佛庄严。现佛神足。现诸佛众会。现众会清净。现众平等。现众如一。现众众大。现众所依。现众止处。现众教化。现众如应。现众雄大。现阎浮提众等会。四域。亦如是。千国土亦如是。于二千国土亦如是于三千大千国土亦如是。具于亿那术百千国土。具现众会之场于无央数国土。现具众会之场。如百千佛土尘数之国。现众会场。举要言之。乃至无数无量佛土尘数诸国。普现众会之场。于彼众会之场。现诸佛种种所见。现诸佛种种身相。现诸佛种种之时。现诸佛种种之处。现诸佛种种变化。现诸佛种种之感动。现诸佛种种庄严。现诸佛种种威仪。现诸佛种种色像。现诸佛种种事。菩萨于彼。在在众会。自见而普同现。亦自见于彼。而普说经。亦自见普持诸法。亦自知有诸法之权。亦自知解。诸义理。亦自知解达虚空。亦自知明了法身。亦自知而无恐怯。亦自知不处于有常。亦自知不处有想念。亦自知而无劳想。亦自知晓了诸慧。亦自知晓诸义。亦自知念诸行地。亦自知等念偶义。亦自知复无所念。亦自知专念诸佛。亦自知等念诸力。亦自知等念诸情。亦自知等念空行。亦自知等了闲静。以知如是。不念于土。不念有人。亦不念佛义。亦不造法。亦不坏身。亦不坏身行。亦不意念。亦不入心行。亦不念寿命。亦不念我人处所。譬如以法知法。亦不兴有无菩萨行。亦无念。亦不念游诸土。彼能现佛无数色像。具满诸行。能行等清净。得致其处。能具畅现佛之色相。亦现佛所有光明。所现平等。而过清净。以升致之。而畅现之。能具现如佛像色。具现如佛光明。亦现如佛意像。亦现佛身无极相好。亦现佛最威神之明。亦现佛最身相之好。亦现佛身金刚之色。亦现佛身清净色像。亦现佛身无量色像。亦现佛身大清摩尼宝色像。亦现如来身如七刃。亦现如来身如八刃亦现如来身如九刃。亦现如来身如十刃。亦现如来身如二十刃。亦现如来身如三十刃。亦现如来身如四十刃。亦现如来身如五十刃。亦现如来身如六十刃。亦现如来身如七十刃。亦现如来身如八十刃。亦现如来身如九十刃。亦现如来身如百刃。亦现如来身如十里。亦现如来身如半喻旬。亦现如来身如一喻旬。亦现如来身如十喻旬。亦现如来身如百喻旬。亦现如来身如千喻旬。亦现如来身如一阎浮利。亦现如来身如四天下。亦现如来身如千天下。亦现如来身如三千大千天下。或复现如来身如百佛刹。或复现如来身如千佛刹。或复现如来身如百千佛刹。或复现如来身如亿那术佛刹。或复现如来身如无量佛刹。或复现如来身如无限佛刹。或复现如来身如阿僧祇佛刹。或复现如来身如无边佛刹。或复现如来身如无际佛刹。或复现如来身如无思议佛刹。或复现如来身如无称佛刹。或复现如来身如过意思佛刹。或复现如来身如无处所佛刹。或复现如来身如无可思议佛刹。或复现如来身如无望过望佛刹。如是菩萨。现彼如来身。如此无数色。无数相。现美无数。现无数光。无数网。明现无数法本无。现无数法。本无吾我。现诸法本慧。所从起。现无尽之身。现无行之清净。如是菩萨。现彼诸如来。于诸如来身。亦无增亦无减

譬如虚空。而无疲厌亦无大小。于无数土。诸土窈冥处。不以冥大。其如来身。亦如是。以其弘大示无小大。譬如月像。照于阎浮提。亦无大小。其月像住明无往来。其菩萨。亦如是。得致现如佛住是定。亦不妄坏。如来色像。所现诸佛。亦如梦耳。于此无所见。而有见。而现诸佛如来音声。所现诸佛如来音声。于法空。无所有耳。而皆受法。宣传此。悉在无惑之法。譬如众生。死所归向。而心由走。菩萨亦如是。于是三昧而住。庄严诸土。以佛慧。度脱。而清净。菩萨以十速疾而应普等。何谓十。疾满具足诸愿行故。疾明诸土照以佛法。疾度众生法轮权慧故。疾净诸土随一切行应故。疾成于慧十力等故。疾成平等以诸如来故。疾欲降魔以大慈力故。疾欲悦众生当断狐疑故。疾现感动随应所度故。疾向法门种种音声。净诸土故

菩萨有十印。以诸法而印彼菩萨。何谓十。彼菩萨。与过去当来今现在诸佛。而行一德本。彼菩萨合为一身。以法身无踰者。彼菩萨以一行。如来无二故。彼菩萨为无数场。从无二生故。彼菩萨为无限行。与法身等故。彼菩萨为无挂碍。于世得十力故。彼菩萨行空净法。无二行故。彼菩萨无漏。为世极度故。彼菩萨意无内。普智权慧故。彼菩萨为有护。以诸佛故。是族姓子。菩萨大士。有大慧定。名曰诸佛音声普照国土。彼菩萨。行此定正受。无能为师者。入诸佛法。为无疑惑故。为极世慧丈夫。为清净故。心本净明。为最尊大故。为极世唱导以自敬重故。兴最猛健立。当来诸佛。普智本种故。修慧成信。言无二故。过去慧无挂碍。成法藏故。以诸佛法。为兴法雨。如应众生行故

譬如族姓子。释提桓因。摩尼释天王所处最尊。其摩尼威明天帝释。以此为威神。其有得此摩尼宝。威尊最大释天王。以十事。于忉利。而致尊。何谓十。以天最色。而喻于诸天子。以天最像。以天相现天最眷属。以天极欲。以天最乐。以天服信。以天最自在。以天上意。以天大智慧其摩尼宝德。这得之者。而致天之上尊。菩萨亦如是。这得定正受。便得广大无极十慧。何谓十。谓于佛刹得无挂碍慧。谓于诸众生本得起慧行。谓依三世得如应慧。谓于诸佛身得所依慧。谓诸佛法而得慧行。谓一切法而得一法慧行。谓一切极世得入法身慧。谓一切法本得平等慧行。谓一切自在得所依慧。谓一切法得致悦慧方。得此定。以诸佛音声。于世界而清净

菩萨复有十事。而得身威清净。何谓十。谓以无得之得。无限之行。不处于土。谓以无望之望。以种色像于诸国土。而住清净。谓以无悕之悕。而放光场。为住度众生。谓以无想之想。而住其身。以行兴诸佛。谓以无求之求。而雨无数华香。以供养诸佛。谓以无念之念。而设种种音乐之供养诸佛。以度众生。谓以无著之着。清净众事。众饰无数以供养诸佛应如所度。而度众生。谓以无行之行。而现种种色相。得身清净。现以无惑。使众生知之。谓以无所有之有。而放种种清妙音声。使众明知种种异语。菩萨亦如是。得是十分清净。彼菩萨亦具满处。何谓十处众生导见佛事。谓住众生得信向诸佛。谓安众生以佛法音声。谓度众生得生于有佛土。谓安济众生使信诸佛。谓导利众生闻诸佛法音。谓度济众生现佛感动。谓宁众生念如其行应。而具满一心。谓安顺众生庄严诸佛。谓利安众生以发菩萨心故。谓永安众生具满佛慧故。以此族姓子。彼菩萨以此十事。具安利众生

其菩萨。如是以满十度。安众生已。普为众生行佛十事。何谓十。一者谓彼菩萨。以音声为众。而作佛事。以度诸会故。二者谓见彼菩萨。而兴佛事。以顺导众生故。三者谓彼菩萨。方动之顷。行佛事。用心清净故。四者谓彼菩萨。振动诸土。而行佛事。齐转三恶道故。五者谓彼菩萨。方所现生。而行佛事。正悦众生意故。六者谓彼菩萨诸所行宜。而作佛事。导利众生。使意无惑故。七者谓彼菩萨。方升光明。而行佛事。秉持度无数众生故。八者谓彼菩萨。现修众德。而行佛事。劝立众生无数诸德故。九者谓彼菩萨。至成平等觉。而行佛事。使诸众生解一切法如幻故。十者谓彼菩萨。转其法轮。而行佛事。为普世说法。兴贤圣宝久住故。是族姓子。彼菩萨大士。行佛十事。以度无数人。济无数众生。成满无量愿。安立一切众意行。永立佛事也

    等目菩萨经外身现化品第十

又复族姓子。菩萨大士。有定正受。名身无毁。使其菩萨。得住此意。而身无毁。得满十无望。何谓十。一者谓于诸土。而无望。二者普于诸方。而无望。三者于诸想念。而无望。四者于诸众生而无望五者于诸法。而无望。六者于诸菩萨行。亦无望。七者于诸菩萨所愿。亦无望。八者于诸定。而无望。九者于诸像。而无望。十者于诸行地。而亦无望。是为十。菩萨得致十无望。便得住一切身无毁行之定。云何菩萨。得致众生身无毁定。是族姓子。菩萨于内身而正受于外身而觉悟。于外身而正受于内身而觉悟。以一身而正受以多身而觉悟。以多身而正受以一身而觉悟。以人身而正受以鬼神身而觉悟。以鬼神身而正受以龙身而觉悟。以龙身而正受以质谅神身而觉悟。以质谅神身而正受以天身而觉悟。或以天身而正受以梵身而觉悟。或以梵身而正受于欲界而觉悟。或于欲界而正受于色界而觉悟。或于色界而正受于无色界而觉悟。或于无色界而正受现于地狱而觉悟。或于地狱而正受现于饿鬼而觉悟。或于饿鬼而正受现畜生而觉悟。或于静而正受于众普而觉悟。或于千身而正受于无身而觉悟。或于有身而正受于无数身而觉悟。或于无数亿那术身而正受现于空身而觉悟。或于阎浮利而正受于瞿耶匿而觉悟。或于瞿耶匿而正受于郁单越而觉悟。或于郁单越而正受于弗于逮而觉悟。或于弗于逮而正受于三天下而觉悟。或于三天下而正受普于四天下而觉悟。或于四天下而正受普于三处众生而觉悟。普于海之境界而正受亦尽于海之境界。与众生而觉悟。或于须弥山上而正受亦复于山下而觉悟。或于须弥山下而正受亦复于山上而觉悟。或于七宝山间而正受亦复于山上而觉悟。或于种种类而正受亦复于种种杂类而觉悟。或于清净种种华香众宝庄严之间而正受亦复现于清净种种香华众宝之间而觉悟。尽于四天下之境界。与诸众生。随其心意而正受复现于四天下之境界。与诸众生随其心意而觉悟。于千国土。尽其境界而正受亦复现于千国土而觉悟。于三千大千国土尽其境界而正受亦复现于三千大千国土而觉悟。于亿那术百千刹土中而正受亦复现于亿那术百千刹土而觉悟。于无数刹土而正受亦复现于无数刹土而觉悟。于阿僧祇刹土而正受亦复现于阿僧祇刹土而觉悟。于无量之量无限之佛刹土而正受。取要言之。如是等刹土普于其中。而现觉悟。从一天下如尘数。至四天下。复千天下。复至三千大千天下。复至亿那术刹土。复至阿僧祇刹土。乃至无限无数。复过无限无数之刹土。如是之数。普于其中而正受。亦于其中而觉悟。于一尘中而正受复现于如此上刹土尘中而觉悟。从如此上刹土尘而正受。复现一尘而觉悟。于一声闻中而正受。复现无数声闻而觉悟。于一辟支佛中而正受。复现无数辟支佛而觉悟。于己身中而正受。复现于无数佛身中而觉悟。于无数佛身中而正受。复现于己身中而觉悟。于一心念之顷而正受。现于亿劫而觉悟。于亿劫之中而正受。现如心起念顷而觉悟。或时觉悟或时正受。或同时正受而觉悟。或于本积而正受。现于末积而觉悟。或于末积而正受。现于本积而觉悟。或于现积而正受。复于现积而觉悟。于本积而正受。于三世而觉悟。于时积而觉悟。于时积而正受。于三世而正受。于本无而觉悟。或于本无见正受。复于本无而忽觉。譬如族姓子。有人为鬼神所见娆时。已为鬼神所得。自在取参动。亦不得自在。唯从其鬼神耳。便为随之于他身也。己身不复得自在。菩萨亦如是。以得是定。或内正受。外而觉悟。于外正受。内而觉悟。譬如死人。其尸为他神所役。而其事为他所追逐。其所回转皆化耳。其役之者。是他神力。如是族姓子。以得此定。而是菩萨。而兴正受。以分别而正受。复以分别而悟。以平等分别而正受。以平等分别而悟。譬如心自在。魔变化自由。或化为一。或复为多。或化为多。或复为一。不以一身而终亡而现其多。亦不以多身而终亡而化现一身。于时其一身。亦不有一身。不以知一而现多。不以现多而知一。若一若多。从一而兴耳。菩萨亦如是。于一身而正受。多身而觉悟。或多身而正受。以一身而觉悟。譬如一类之地。地而一味。于其一地。而诸聚落县邑。所种各异。味味不同。地亦不想。是味亦无种种识。菩萨亦如是。得此定意。以一而正受。而多觉悟。于多正受。而一觉悟。是族姓子。菩萨大士。名曰分别一切诸身第八菩萨之定。其菩萨。得所住宅处。致十名誉法名誉常流。何谓十。一者为如来所称叹。二者得如来平等威。三者谓为佛明晓诸法。而无挂碍。四者谓为最尊用。诸极世所供养故。五者谓为普知用。明晓一切诸法故。六者谓为导师用。一切极世。所依凭故。七者谓为唱导用。晓了明入诸法故。八者谓无上师。众生法本。普智无故。九者谓为兴明用顺慧一切极世施大明故。十者谓为十力。得致最吉。诸所作行故。分别诸法。以其慧达念。具足无著之行。谓为普现于正法轮。得自在。以此十名誉之法。菩萨以此。有最名闻。菩萨复有十明显。而甚威曜。何谓十。一者谓诸佛而等其明。二者谓于其极世。以法本明说兴造慧曜。显振诸法。三者于诸众生。以明照曜。种种明说。四者以无数明。进导以法场之明。五者以法界之明。兴显振说。六者以感动诸法。而不坏其明。七者诸法无欲等。以其无所作。而不坏明故。八者众生无欲等。念世一切感动无挂碍故。九者诸佛所立而无断绝。善明照故。十者诸佛之境界。而度无极。诸法本无。明极世一切无所坏故。菩萨以此十明。而得光曜也。菩萨复有十事。于无所著句说觉而明了。何谓十。一者善修调柔于身行。二者无粗口行。三者柔软心性。四者处无所住。五者谓情无作。六者谓行无所作。七者于法无所毁。八者慧无所起九者于法无觉。十者顺彼以慧。是谓菩萨大士降魔之定。以众行伏之。以一为多。正受而悟。无行行。而于行而行。于己尊大。与佛等大。以小而广泰。以旷荡而狭小。所趣亦无所至。所至亦无所趣。以无身为身。于有身而无身。以觉悟而正受。以正受而觉悟。于见无见。于无见而有见。是谓十也。复有十事。而为变化。何谓十。一者谓。一切变化境界。是皆定意。譬如大神咒言行之通告。现种种诸色。明建无过者所现喻绝于咒之言。而随足于幻。而猛建慧了时节。于幻名显。行学知术。慧而通达。菩萨亦如是。以平等正受。现以无等而觉悟。以无等而正受。以平等而觉悟。譬如天与阿须伦共斗。天而得胜阿须伦而不如。质谅帝以七百喻旬之身。与四种之兵。而自围绕。阿须伦乃更自化身。为百千喻旬。忉利诸天皆共见之。其众严整。又阿须伦。学玄明了菩萨大士。亦如是。悉明于慧幻行。而慧无尽。彼菩萨者。乃为菩萨耳。彼慧幻菩萨。以无毁断而正受。于毁而悟。譬如有大咒。名曰妖惑。以此咒言。取诸种物。散种于地。便随得茎枝叶华果实而食之。菩萨亦如是。得致专一之定。能现种种而觉悟。譬如男女之会同久久。毕致怀妊。以成就胞胎。而满十月。便生完具。菩萨亦如是。长养普智之胞胎。具足成满诸愿。以广大内性。得致慧明。而处无毁定。普悟于诸趣。在诸趣而正受。于无毁定而觉悟。譬如龙宫殿。依因于地。亦现于虚空。亦不动虚空。亦不惊诸龙。虚空亦有乾陀罗。亦有诸龙。其虚空。而无增减。或欲晴荫。于虚空而无动。而其宫殿。续依于地。或依虚空。菩萨亦如是。以得是如幻定。于有相而正受。于无相而觉悟。于无相而正受。于无相而觉悟。譬如梵天之宫号持世清净藏。最上梵所处之宫。或现千天下。或现十千天下。或现百千天下。或现三千大千天下。或现于天龙神。乾陀罗。阿须伦。迦留罗。真陀罗。摩休勒。诸人。鬼神宫及世人间。或现须弥。及七宝山间。铁围山宝黑山雪山。及四天下。郡国县邑聚落。君王人间。梵所之至。无所不遍。譬如明镜。见其面像。菩萨如是。处于此定。于诸一切慧。无不明彻也。靡所不入而悉平等。一切普往。慧照明彻。彼菩萨亦如是。以此分别一切身定国土自在之明悉见佛种而化一切诸种。而过法种。具满解脱行种。亦以定种。而感动起悟之种。而普现以得慧种。以住智种菩萨于十感动。而致度无极。何谓十。一者谓成佛感动。若如虚空。二者尽于法际。三者以菩萨感动。至于无毁。于毁自在。而度无极。四者菩萨之行。大愿感动。五者行入如来行。佛事度无极。六者于诸土感动。现一切种种闲居之行。七者动摇一切诸土。依于明显。八者感动一切众生。以无思议行。悉了玄事。感动以慧。九者感动分别诸定。十者以金刚定。以玄化正受。觉悟以慧。菩萨以此十定之行。具满诸种也

又复族姓子。菩萨能化为佛。能住如佛。能化法轮。建立应化。普现如来之光明。度志大乘。于彼而降化。于心尊大。神足感动。而度无极。于菩萨中。而尊大。明了菩萨无著慧定。以无得之得。亿百千以诸法门感动。而转法轮。菩萨无挂碍。明知一切行。皆晓知无想念。以其明慧。一时悉能晓了。现感动三世。亦无挂碍。以此十事。而大感动。诸佛菩萨所行。而致度无极。是族姓子。菩萨大士。分别身行。所可依住。而致。大德权定之慧达也

等目菩萨经卷中等目菩萨经卷下

        西晋月支三藏竺法护译

    分别身行大慧空品第十一

又复族姓子。菩萨大士。于己身尽其身。等如幻。眼之所见。随于法界。菩萨之定兴。亦等于身诸毛孔。一一之毛。现诸法界。而菩萨居之正受。彼亦住于幻法耳。及所知诸国土。亦如彼法俗。以知诸法。便知亿那术。无数国土。复知无得之得。佛刹尘数之国土。于彼诸国土。等现有佛菩萨围绕。而皆具足。净复清净。皆悉勇猛。贤行辩才。而大庄严。无量觉饰。如日明曜。众宝严好。于彼若十劫。若百若千。若百千若亿。若亿千那术。若无数无限。无边无际。极尽无尽之数。至如佛刹尘劫之数。行菩萨诸行。所依住者。而不可尽极。菩萨于彼。作是定正受。而复觉悟。于此而正受。于彼定而觉悟。彼普入诸国土。于彼而化众。化众生界。皆使悉入法界。而晓了过去诸慧。而复现处说于经法。明晓无具。无挂碍眼所分别。于法而自在。卓然而过。耳所分别。致度无极。鼻所分别。亦复以权。口所分别。悉之明了。身所分别。亦具晓解。心所分别。慧念满具。彼以此慧。作是明了。便得十亿千总持。何谓十。以法普顺诸土。得成十亿千清净之行。解了十亿千神诸顺。入普智行。得具满十亿千神通。得入十亿千定意行。得十亿千神足。而致具满。得致增益十亿千力。得具满十亿千诚性。得显现十亿千所依住处。得致十亿千感动。是为十。菩萨复有十体。以致成就亿千。菩萨有十行处。具满亿千。菩萨有十藏。以过平等亿千。菩萨有十行。于亿千而显光曜。菩萨有十住。以宣亿千之教说。菩萨有十愿。而过亿千德善之行。菩萨有十悔过诚。立亿千修德之行。菩萨有十明显。得致亿千清净之行。菩萨有十向胜。致亿千以自明显。菩萨有十说。以得亿千照明之德。菩萨有十清净果。达亿千而致清净。是谓菩萨大士行具无数身。成就无数德。满无吾我德。成致无数行。修无思议德。行无称限德。满无我我行。致无德之获。无尽念无我德行。菩萨以此行。而具足诸德。得致平等行。而自庄严。得致显豫调和柔弱。得致奉持得致供养。而为殊增。得无喻者。得为勇捍。菩萨于是法。得自在。菩萨依是定。于东方乃十佛刹无数千尘数如来所。建立以一一名字。一一名字。彼十佛刹如尘之等。无能念限者。从彼一尘。分为佛刹无数千如尘数。以遍其中。亦无觉知。而无增减。如一之不觉。而无增减。普于诸刹如尘数。亦如是。如东之所为。南西北隅上下。亦如是。其一尘分破之所可着处。其数亦如上。其菩萨。能建立之。普能现其身。是彼菩萨。于诸佛刹。普能清净所建置也。以如来身无限故。又于光明。而得自在。复以无思议故。得有感动。使普现耳。如来耳之所宣。亦复无量。如来鼻之分别。亦无限量。如来口所分别。而现平等。如来身于细滑。而顺行之。如来心所现。而不可限。如来正觉所知念。亦无限量。宣如来音声清净。普显现如来法轮。而无回还。使一切普知如来圣众而无限数。如来法觉。而亦无限。而普顺导。普现兴显如来功德之本。现入如来之定。如来之德。于三世修行。而无数如来现兴显诸法。如来所建立宣音声说。是为十。现建立如来之土。以佛音声。而普雨诸法。使其音声。普闻诸土。广宣传佛之正受。亦复普宣诸佛世尊。贤圣之众。建立诸佛无思议法。所宣诸法。悉如幻化。宣演诸法。而无所著。悉明显一切法场。普悉畅现如来众德之行。是为十。一切诸定。顺导如幻。建立心如幻。解无挂碍。菩萨于此法界。而悉自在。乃为建立菩萨耳。彼诸佛世尊。于诸种种心意。以一一名字。而现无数佛土。无数千如尘数诸如来。以一一名字。如尘之数。以一一之尘。立置如十佛刹。至九数如尘数佛刹。亦无增减。无能知所取着之者。是菩萨所建立也。修应无遍数行。亦心所建立。以无著行意所建立。于诸法而无惑故。念所建立。于诸法慧分别故。行所建立。诸法所受处故。行所建立。顺奉诸法故。亦觉道所建立。修行普宣传法故。亦建立无数诸情。以建神通分别于法用权慧故为无起行。所建立明了。法界无所著故。亦住修入慧行。无限慧清净故。亦住于等正觉。普于诸国土。而现感动故。菩萨以此。而住诸定故。得充十海之门。何谓为十。一者谓现充佛海。顺导诸海故。二者以过法海。行了慧海故。三者住诸明曜。于情无所著故。四者以慧感动。用敷音声故。五者念诸情之海。顺以权慧故。六者晓了心海。一切无种种之观。而知无数心故。七者满于行海。具足愿故。八者具满一切行愿海故。(少第九一法)十者成致一切于觉道故。是为十。菩萨成满一切道德之海也。菩萨有十事。得致上尊。何谓十。一者以上尊。顺导一切。二者求于最上。化导众生。三者求向上尊。则达诸梵行。四者致最上力。求具得之。五者求无伦侣。于一切极世。六者求无过踰。胜魔故。七者求以明畅。度一切恶道故。八者求无所依。于诸所生。九者为尊于诸佛法。十者求为自在。于诸众生。将有勇健。是为菩萨最上十尊法也

菩萨复有十事。兴起于众生之界。何谓为十。一者常志出家。欲度众生故。二者无其回转进最猛力故。三者求依诸佛。受行行故。四者有无限力。进诸法故。五者寂定之力。于诸法自在故。六者心无回还。顺导力故。七者于义自在。本无法力故。八者为大智慧。宣法无挂碍力故。九者勇猛力。法所建立故。十者分别力。宣布无量慧故。是谓十种之力。而复致十大勇力。何谓十。一者最健之力。二者无过踰之力。三者无量之力。四者善修之力。五者无动之力。六者无起之力。七者无怒之力。八者慧常之力。九者勤建之力。十者弘慈之力。是为十力。复有十力。何谓十。一者修调行力。二者慧清净力。三者过清净法力。四者法身之力。五者诸法土力。六者法明曜力。七者法情之力。八者无所坏力。九者善行修力。十者修勤入力。是为十大力。复有十力。何谓十。一者大丈夫力。二者正雄勇力。三者等正觉所建力。四者前世所修德本之力。五者无量德本如应之力。六者如来之力。七者普应入力。八者于三世等力。九者得菩萨如地行力。十者得菩萨信向清净行力。是为十力。复有十力。何谓十力。一者菩萨离转力。二者菩萨顺缘之力。三者菩萨于性得自在力。四者菩萨修于内性清净力。五者菩萨修诸德本从诸行力。六者菩萨行法最力。七者身无著力。八者菩萨以是致成之力。九者菩萨入权慧力。十者菩萨诸法本清净信向之力。是为十。复有十力。何谓十。一者住于普世。清闲无处力故。二者于诸众。无双力故。三者普于一切。无等力故。四者以诸德行。化众生力故。五者在于生死。无倾动力故。六者度诸生死。清净如莲华力故。七者普现诸导。降诸魔力故。八者将顺魔党。成大乘力故。九者化于三界。无所处力故。十者普劝进十方。无挂碍力故。是为十。菩萨以此无数之法。成其德化也又菩萨兴起满众愿行。明曜之。显照之。而普应现。皆成就之。以致弘大增进慧。益之而广清净。是为十顺清净定。彼众德而无边际。其慧亦无挂碍。其菩萨行。亦无限量。彼菩萨德乘。过量难称。又其菩萨行处。难可断量。其菩萨所入。而不可测度。彼菩萨所兴化。亦无边际。是菩萨之清净。亦难思议。其菩萨所修。亦难可尽。又其菩萨贤圣法。亦无能极。以无可得。亦无念限。其菩萨所可得者。其菩萨所可因起。其诸菩萨。所应现行。其诸菩萨。所当得。又其菩萨。明彻所至处。又其菩萨。所可彻见。又彼菩萨慧明所过。又是菩萨法行所可知见。又其菩萨行。应所当得。又其菩萨一切法行慧处。皆达之。是为十。其住于此大定者。无数无限。无量无边际。无尽无称限。无思议无我得之得。是为十。菩萨以此定正受。入于一一诸行。或定或悟。而悉晓知诸定行。明达无数诸定。亦了具满诸定。亦晓定之增损又了定诸幻化。晓了定所见行。亦知定之由行。亦知定之际处。亦明晓定之闲静。亦知定寂寞。亦知定念行。譬如无热龙王池之宫殿。有四大河而流出。盈溢清澄。无垢无浊无秽。清净无瑕。甘美香洁。周回四出。有四目口。所从流出。一目名和。二目名拔叉。三目名蛇未。四目名恒。其和北流。拔叉南流。其蛇东流。恒水西流。一一而回旋。四周亦如是。而充大而以满之。又彼大河。绕之七匝。此河之间。有青莲华红莲华。白莲华黄莲华。以天众宝之光色。精明妙净。展转而照曜。现而鲜洁。永无污秽。其间了了。曜而明彻。叶叶分异。现而明显。画者所不图像。软动之色。既照曜。音声彻妙。慧善之色。图之难极色力。无数天句文。普行乐。诸叶交错。色发姝妙。香美异丽色照曜。以无数种种诸宝所挍饰。众色无数。如日天出于宫殿。光而彻照。彼诸华之郁曜。相照焜煌。能夺日之精光。彼诸杂花。在河之流。有诸天。应在河回转浮没。乃游于种种诸华间。而此诸华。上下低仰。妙色炜炜。照曜宝色的的。日光曲照。玄黄乃遏。日光精如彼众华之动。流河音声。乃踰天伎乐。菩萨大士。亦如是。有四辩才而流出。以充满普智之海。如香大河。有银妙色。从马口而出。其底皆有银沙。菩萨亦如是。清净之智。顺随众行。而从口出依顺之义。一切诸如来行。一切诸义行。善施之法。诸法慧明。分别了竟无挂碍慧。而归智海。如和之大河。金刚之色。从师子口而流出。底沙亦金刚色。菩萨亦如是。出法之光曜。有佛金刚之色。而自娱乐。用照曜于普世。以金刚之慧。而自娱乐。而充无尽之海。如彼二大河。紫磨金色。明而光曜。亦紫磨金色之沙。菩萨亦如是。以发遣之辩。而从口出。一切众生。攀慕慧身。而悦一切普世。以金刚之慧。而有所照曜。普度一切。常慕顺导因缘。使归于智海。又若拔叉之大河。青而琉璃色从牛口而出。精明流之洁色。菩萨亦如是。以无尽明曜辩才。而流出。以无碍之法。亿那术百千威猛。从念而雨。流进至于法河。转充于普智之海。成致诸佛法藏之海。如彼河之目。而四面回旋围绕。归充大海。菩萨亦如是。顺回身行。顺回意行。身口意回。皆以备具。亦如彼四川之流而归于海。菩萨亦如是。以四庄严。归普智海。何谓四。一者见诸佛而为庄严。二者见佛分别慧。三者以诸佛法之光曜而为庄严。四者揽诸总持而无疑惑。是为四。复有四。一者以诸度无极而为庄严。二者以诸菩萨而为庄严行。三者以大悲行而为庄严。四者于诸众生满以法轮之行而为庄严。是为四。如彼大河。回旋七匝。以其四华。青红黄白而为庄严。菩萨亦如是。以大乘心。于其间。诸未度者。而为说法。以兴起之。其诸定正受。亿那术百千。而分布之。普见佛德。以于三世。于诸佛刹。清净行无垢秽。如彼无起而静定。以众宝树而围绕。菩萨亦如是。以诸刹庄严。而为围绕。得致正觉。而现悦乐。如彼水潭定。而无动静。然清澄清彻。其菩萨亦如是。彼菩萨以道德御心。静然清澄清彻。具满无数诸德之本。如彼无热池。以众宝为岸。内外而照彻。清净无垢。菩萨亦如是。其菩萨心。以十宝慧。至亿那术百千行。致最愿慧。而普得之。晓了清净诸德之本。如彼之无回。内外清彻。底有紫磨金沙。以众宝而挍饰。菩萨亦如是。得致彻慧。以意无念。明菩萨境界。以诸菩萨德行。而自庄严。于诸法而无挂碍。一切诸佛行无处所。知一切行明了时节。如彼居有诸龙。菩萨亦如是。顺导一切恐怖之世。亦悉显明。普悉诸等护极世。如彼流水从四目出而进流。归诸佛德。渐舟津流。归至于海。菩萨亦如是。以四大慧河流。为诸天梵魔界。尽世沙门梵志。极世人类。而普津润之。渐舟归至佛无上慧海。以四种力。而自庄严。何谓为四。一者谓本愿之慧。普悉救济一切极世。二者向无断慧。化度一切极世。三者具满诸度无极之慧。使依菩萨之行。而顺清净。四者明持一切众生之本。明达诸念。使归无断之流。得至三世海慧。是为四。蠲除止处。谓以菩萨定慧之行也。以无央数诸定。为众宝之庄严挍。觐睹诸佛。以无见之慧。流归诸佛之海。以大悲之慧行。其行亦有大慈。顺导一切。而无回还。兴起极也。以无数权慧。而归十力之海。如彼四河。从无热之渊出。而归无极之大海。菩萨亦如是。行上头之大愿。具菩萨诸行。成得一切无尽大慧众行亦无尽。常见诸佛。以为娱乐。如彼四大河。而无回还。归至于大海。而无毁断。菩萨亦如是。菩萨之愿。而无挂碍。得修具足普贤菩萨行愿之光曜。得入普智之行诸法觉道行。以无念。以无著。修如来行。如彼四大河。无懈无止处之劫数。流归于海。菩萨亦如是。修入普贤菩萨之行。于无数劫。修菩萨行。而无懈惓。以成归诸如来海。归于无想行。如彼无回还之大河。以众宝为明。以紫金沙为照。以银沙为晃煜。以金沙为曜灼。以琉璃沙为遏灼灼。日光住照。而悉夺日之明曜。明曜至时。焰彻过日。诸所造住。无所烦娆。彼之光曜。度之无喻。合会众宝。用所成为其菩萨亦如是。于法身得自由。建立于定。于其身一一毛孔。以无限量。普出诸佛光明。而见诸国土。晓入众会之场。而闻法能悉奉持。晓了如来无数身行。明达彼诸佛国土。见如来会场。闻其法说。以无得之得。消除亿那术劫有长想。又无短念。于其身毛。数亦无减。及诸土如来众会场。于种种人界。不处分别。所以者何。以入法界故。用解无我微妙故。亦不入于毁。行无数定。修无数行。普现于诸佛所。为无数诸佛所建为无数诸佛感动。普远所归普贤菩萨所行愿。以清净菩萨所行。如来十力。而无挂碍。修普贤菩萨之行。建立具满。晓达诸感动。而无限碍。菩萨如是。以一时心正受。而觉悟现己极长。不堕所入行。不着一切诸行以离于有无之间。为一切故。现佛土所兴耳。于法界不见有土处所。亦不住限齐。亦不住于两际之间。而修入普智之慧。乐慕于慧住。无自大。晓入诸众生类。于诸土而清净。皆以具满诸土之行。种种所想。皆悉达知。不止生诸想之处。而皆悉过于种种色像。悉了而无染污。菩萨权慧。所具满。至永清净。悉无想念。普建诸行地。譬如至虚空。以离诸趣。于诸趣。永无所趣。菩萨于国土行。亦如是。了达诸国土修行。度众生。永离一切众生想。晓了一切法界。以除一切法想。见诸佛而无厌依仰欲睹诸佛。解达诸定。分别权行。一切诸法本清净。而无所著。无尽法句。慧无量辩才。晓了无句无字。得诸音声行。了音声之清净。逮无得法际。现种种色。彼顺导境界。一切法本清净。而究竟以大慈矜。济度一切众生之界。无因无所因。一切界本清净。了所住法界而无所起。了诸趣而无所住三场而清净。晓达如来行。于种种法。而无念权行种种辩说。清净宣法。得致法行。是族姓子。菩萨大士。于法界得庄而尊大

    等目菩萨大权慧品第十二

何谓族姓子。诸菩萨大士。第十最德大定权慧行。是族姓子。诸菩萨有大定。名无尽场。其以此定正受者。得住身口意行无尽。等住诸佛刹亦无尽。致度众生行亦无尽。住导众生之慧。而亦无尽。放于光明而亦无尽。放于明网亦无尽。现出诸化亦无尽得过转法轮而亦无尽。其身能现菩萨现佛。于诸国土而亦无尽。其身悉达诸佛之力。其身志愿诸佛之慧。显如佛之兴行。于诸刹以佛感动佛声。以普彻。以行佛圣。以过佛行。其身以过佛之限量。修治佛事。佛行自在。是为十最德之定也。又其菩萨。住是定者。观于普智。明了普智。晓解普智。以达普智。分别普智。现于普智。以辨普智。睹于普智。以入普智广显普智。是为十。又其菩萨。亦不愿普贤菩萨之行。及其大菩萨心。及大菩萨行。及其所现行。及所入所现大世。及其所趣并所建立。其大菩萨所润泽。其大菩萨亦无断。是为十。复有十行。一曰无回还。亦无长养。亦无还反。亦无疲劳。亦不念不念我。亦不放舍。亦无动摇。亦不断绝。不以音声为菩萨。是为十。何则然者如彼菩萨。于诸法致大愿。而具足于诸行。所兴大道。悉善修学佛法大海最大等愿菩萨之行。显学权慧方便之明。以善学菩萨幻化。善明达一切音声。而得建立。以善建立去来现在及诸佛一切之世。以得大悲之行。以诸行而成佛法之业兴佛法。而无挂碍。是为十。何则然者。譬如有人。得如意宝。所念无不建立。如其像而光明。其摩尼宝。与本无异也。菩萨亦如是。得建立如意宝。于慧无厌。反复明晓普智之慧。于普贤菩萨之行。而无懈。如其摩尼。尽自现其色像。不毁摩尼本体。菩萨亦如是。致成普智之像。然不毁本行之体。所以者何。以其菩萨发义。为一切故。欲度一切故。而发愿修诸佛行。而无回还。欲净诸佛无懈惓许。任一切故。而无懈退。于一切无数法。无我想念。无却无懈。普现一切感动。于众生得清净。而无厌倦。利养普世。亦无懈退。普照明于世。己无劳退。入无数诸法幻间。而无回还。心永无却退。是谓十。譬如红黄。在所虚空。无所住止处。而所持者。不起劳疲。亦无损弱。亦不得一切意。亦无所处。亦无系缚。亦无所见。亦不处中。亦不外。观内无所处。不坏本净。所以者何。其虚空法。本清净故。菩萨亦如是。修行广大无极之愿故。不起劳疲。为以兴发。普度众生故。譬如有灭度者。此为何人而当灭度。于三世而无尽限。亦无疲劳。亦不恐惧。亦无回还。所以者何。诸法无二故。而归灭度者。何则而劳耶也。菩萨亦如是。为普世众生。而兴于世耳。当何以而回还。用度众生故。譬如为普智故也。菩萨行亦如是。道无有疲。亦无劳故。过去无住。其现在者。住佛种种当趣(有本作起)所以者何。彼无二法故。何缘而有劳。于诸法如幻。而无所入故。其无殆。菩萨如是。故有其身修入普智。彼何由而有懈。其彼菩萨以是其光明。普遍至于诸方明曜。至诸国土。而无挂碍。诸色无数。种种之藏。难得之叶。无极之宝。无得之香。无量清净。振动庄严。大音雷震。而普遍以交露而严饰。其色甚殊好。以琦妙众宝。以为挍藏。以众宝现严净。又各处立绮栏楯。其间而有众色。如来清净而为光饰。以诸德本。外致光曜。如来吉祥所接。逮诸如来所现建立。是为十。等住一莲华。无得无限。极于十方。十德无厌千之清净。菩萨所行。由生普智之明。所可由生。持诸佛法之明。除灭普世之火。为世所礼敬。明达普现幻法。于极世行有喻无喻。是谓十

又菩萨所坐处。足其结加趺。满其中莲花。而无空缺。悉遍菩萨所坐之处。是其威神所致。为诸佛而建于十无得。佛刹亿那术百千如尘之数。于一一之毛。放诸光明。如一一之毛孔。目亦普然。于一一之光明之目。现十无得佛刹亿那术百千如尘之数。有摩尼宝。名曰明显藏。无数异色。种种庄严。无数德所合。宝网所覆。众华交庄。而为光显。以住最尊之地。但以是定。而为其行。无余之行。行无厌足。心无放散。以一心念。作是而行。作是无懈退。作是无恚。作是修立。作是之行。作是究竟行。所以者何。菩萨终无异行。菩萨亦无他行。菩萨言行相应。所以者何。譬如金刚。叹其无能坏。其金刚体无坏。终不失本性菩萨亦如是。以此诸法。而为光显。不越断是法之所住。譬如紫磨金。叹其焰光。而不毁其体之精明。菩萨亦如是。以精明之法。而自明显。不毁修善之行。譬如日天子。显以明场。不毁光曜。菩萨亦如是。普明极世。不毁菩萨曜德。譬如须弥山王。以四宝之积美。其最高从海而现出。菩萨亦如是。美其普显于世。其菩萨德本。以显于世。而不远离。譬如大地美。能普持于世。不毁所持之本。菩萨亦如是。显以度众生。不离大悲。譬如大海美有众宝。不毁海水。菩萨亦如是。美其诸德之本。不离为众之重任而度一切。譬如便习兵师。知刀高下。举刀之轻重。便习悉了。如其形习所入战。而无难于所习。亦无误失。用晓了战慧故。菩萨亦如是。于诸如此像。修诸定门之处。而兴显之。以普智慧。而为光曜。譬如遮迦越王。至于尽寿命。其诸人类。而致究竟。菩萨亦如是。至于修菩萨之行。以是像大定正受。至致众生之界。而得究竟之清洁。譬如五通。自见宿命。并见他人。菩萨亦如是。至于兴修普贤菩萨之行。而致众生之界亦清净。以其德本。譬如大云降雨。慧泽而以时节。普益于众生。菩萨亦如是。至于兴法云雨。普润以菩萨之德行。以此像大定正受至于一切众生。究竟清净。然致众敬。而永安快。而永度无极。永然度于普世。永然悦于普世。永然能断一切狐疑。永然施行福田。常求来受明显受圣。永然与菩萨。普智和同等分数。而建立不退之轮。永然致慧言。莫不受。普为三世众生。而作依凭。永然为法。而致固义普智兴众生无诤。所以者何。菩萨修具此诸法。为佛所建。开法门界。无思无量。菩萨诸所言行。修慧之善为普智故。为众生修善度一切故。修土之善以誓愿故。修法之善建立之故。修其无畏无恐怯故。修其辩才宣布之故。以修于法广演说故。修其总持于法自在故。修诸佛座顺诸佛故。菩萨如是。住于此大定。于此诸德及余众多。无得复无得。众德亿那术百千。而得清净。以此大定之场。而显威曜。承诸威神。己之德本。兴显以力。其慧之地。顺入以力。于诸善友。兴显以力。一切魔事。转之以力。于诸等行诸德之本。以其一力。于诸誓愿。固以被铠力。如其种德本兴起之力。过无尽世。以众福以无降身之力。彼以此定正受。而行有十等像。去来现在一切诸佛而等像也

何谓十。一者谓色相众好。以庄严身。彼菩萨而得等像。二者又彼菩萨光明幔网清净。而得等像。三者其彼菩萨神足感动。诸所化应。随顺众生所应度。而示现等像。四者是菩萨无称限身。无量色像。一切音声。行应清净。皆而等像。五者是彼菩萨建立诸佛土之清净德。随彼众生罪福之行。顺之普现等像。六者此彼菩萨随一切众生。诸所作行。以德力摄持。以无惑意。被服德铠。而现等像七者又彼菩萨以无尽辩才。随诸众生语言音声。所知色行。顺转法轮。而现等像。八者又彼菩萨无断无畏。极师子吼。为一切众生。说法以梵音声。普悉等像。九者又彼菩萨所入句说。于三世之积。明了神通。而亦等像。十者又彼菩萨以佛清净力如来之境界。为众生而示现等像诸如来。是谓十也

尔时等目菩萨。而谓普贤菩萨。若此族姓子其菩萨。以此像法。而得与俱者而致等像。于诸如来。岂非为佛。岂非为十力。岂非为普智。岂非于诸法觉而等觉。岂非普眼。岂非于诸法本际而过慧。岂谁不信普贤菩萨誓愿之行。岂非法界尽其所处。菩萨所兴。而审谛。时普贤菩萨谓等目曰。善哉善哉。是族姓子。若此。如卿所言。其菩萨而现等像诸如来。岂非佛之谓也。如其族姓子。一切菩萨之场。去来现在而为誓愿为有异发起耶。其慧处所。而不可得。于彼而有起佛耶。菩萨所修行。而无断于诸如来。彼菩萨而有起耶。其力为入诸如来不。其十力为彼此耶。又其力。为念想诸如来不。亦无止住普贤菩萨之行。彼此而兴菩萨如彼诸法界所演说。而为入边际而云普智。如彼诸法之说。种种所入。为从外权行耳。亦无回还。又彼菩萨之谓。如其菩萨诸法之印。而知等行。若诸法为有觉之觉。如彼菩萨于二无二行。了诸法之权慧。入诸法度无极权慧。而无回还。是乃谓菩萨。如彼菩萨。为普眼之境界。晓普门之慧。为从色生耶。而谓普眼之言耶。如彼菩萨普眼境界。而晓慧门。为从色生耶。而谓普眼。如彼菩萨为普眼境界之行。意无所行。如心起起而增益。而无远离。是乃谓菩萨如彼菩萨。诸法以光曜而明显。若以等地为现。以无碍慧而念。念诸佛而谓菩萨。如彼菩萨。得致诸如来慧眼。可谓诸法致于正觉。如其菩萨。致如来正觉慧眼。而思观之。而不限量。是谓菩萨。如其菩萨。行如来行。用一切如来。为无二故。为过去当来现在诸佛。亦无二之谓。如其菩萨。修如来神通。己自所建行。而无所行。是乃谓菩萨。如其菩萨。得住极世。至于有积。乃谓慧之积。如其菩萨。住于本积。除而分别。亦不求其本积。亦不妄有妄想。于诸法分别而行。此谓菩萨。如其菩萨。无动不动。无念不念。此乃谓兴致德本。如彼菩萨。而具满之兴造广大。而致清净。亦无回还。于是而无断绝。是乃普贤菩萨誓愿之谓。如彼菩萨。于法界。解了无量以法本无。用一相行。以诸法无相。又彼菩萨。于法界住止之谓。其妄想菩萨在于流转。如彼菩萨。于法界明了。无量晓达。入于法界。诸法各各。异相明晓。以无相。不起疲厌。至无数亿劫。亦不懈退。以大悲心。悉济普世。顺化众生。又是菩萨大士。为普贤菩萨之谓也

    等目菩萨悦乐龙王品第十三

譬如族姓子。悦乐龙王。处于金山之面七宝之藏。以七宝而造作。周匝亦以七宝。以雪而覆之。其悦乐龙王悉白而皎洁。如雪之色。金色明曜。金色若画色。庄饰白妙以覆之。垂以交露。以众宝清净网。而覆之。垂众宝为旒苏。以七体而止立。是谓柔之所乐。是无秽之色像。睹者无厌。清净无瑕。调柔性之谓也

彼则天帝释。于忉利自在者。方这有念。金色面山众宝之藏。于彼忽不现。而住忉利帝释天王之前。尔时天帝。即乘悦乐龙王。天帝释寻随上此龙王。尔时悦乐龙王。于其时。为若干变。而种种行现有三十三头。于一一头。各各有七牙。于一一之牙。而有七浴池。于一一浴池而现七百莲华。于一一莲华。现有七百玉女。如其一玉女。而悉叹歌。如天礼仪。雅同一商。而作音乐。帝释天王。于其天堂。乘此一象。而至妙树园。悦乐尽欢。在意驰游。尔时帝释天王。于一象上。在园观而戏。从悦乐龙而下。至众宝庄珓之堂。与诸玉女。和歌作乐。极意欢喜。快相娱乐。尔时悦乐龙王。现其威神。在忉利天。尽彼园观。为一象身耳。与诸玉女。而相围绕。娱乐欢喜

尔时悦乐龙王。娱乐已极。与诸天人。皆共交错。皆与悦乐。龙威神被服而无异。及众身相色像神炜。以无异。及其珓饰。所衣服。诸所一切。屈伸坐起。悦乐龙王。众诸所有亦同无异。彼诸天人。与悦乐龙王。众诸所有。亦同无异。如悦乐龙王所有。诸天人亦悉如之。如诸天所有。悦乐龙王亦悉如之。如忉利天人所食器。悦乐龙王复悉如之悦乐龙王亦不现化。而有紫金之像色。在于七宝之藏。天所化致此众所有。至忉利天。而来为帝释天王。供养之故。悦豫而供养之。天乐而自有。以忉利众所有悉有之。以众化德。而无异。如是族姓子。菩萨大士。以普贤菩萨之行。修立誓愿菩萨之定。众宝珓庄。以菩萨七体之藏。而以趾立。从身放诸焰网明。击法铃以显法幡。普悉化现那罗延身。致最无上誓愿。为师子步。以转诸慧。整以法彩。而住诸藏。于诸菩萨。为最上行。具满诸行。而致誓愿。以趣佛树。修行誓愿。而无断绝。为欲致普智之慧故。致普贤菩萨行愿。修增广大。以觉觉之故。于菩萨愿行。而无回还。亦无懈止。又无断息。亦无退转。增益无量之大悲。以大乘愿行。于一切无身。以上普贤之乘。行不舍精进。为度当来一切众生故。不断普贤菩萨之德行。亦不见致道之时。道为无得不得之门。无得之得。转法之门。无得之得。种种行性之门。无得之得。种种众生。至诸土处所。感动之门。又彼以无得之得。普入于诸土。现其生。亦悉现普贤之行。以无得之得。于如来道树。而致正觉。以无得之得。为诸菩萨众。围绕而行。以无得之得。至诸种种处所。于诸十方佛土现种种身像。寻时致正觉斯须致正觉。时间致正觉。以日致正觉。旬月致正觉。岁数无限。至于一劫。于其时。无得之得。于此诸数。而致正觉。觐诣诸如来足下。如是比诸土如来。而皆稽首。敬而礼之。供养承事。问诸佛事。于诸幻场。而有增益。以清净修诸菩萨无量清净行。以无得之得。修菩萨慧行。以菩萨种种感动。种种菩萨处所。菩萨种种慧方等。菩萨种种之微妙。菩萨种种神足无量之意。菩萨种种至诸处所。菩萨种种游乐感动。菩萨种种法修其明显。菩萨种种顺导之化。彼普而示现菩萨之愿行。亦不毁其本际。其普贤菩萨化一切众生。诸情所有。以无得之得。修行清净。以断生死之轮。以声听闻语而清净。以如来之耳。闻诸佛兴佛法之音。受而行之。而皆过于三世而无二。诸佛之种。皆而念之。普智之音声佛法。而以分别。于诸处而无处。彼以法身。而以念之。一切菩萨诸行。以音声受之。具满其行。普贤之音声。以等觉普智慧处。是族姓子。当观普贤之行。以无懈断菩萨之行。而无断。以智之慧。而见诸佛。普贤菩萨之行。而无休息。而致普智之境界。如彼悦乐龙王。莫能动者。升于忉利。于彼兴起。行至负乘。而甚娱乐。食天之快乐。不失众诸极快之养。与诸婇女。而娱乐。悉现众变。与忉利诸天。悉等一类。如是族姓子。菩萨以普贤之行。无毁大乘之场。不舍誓愿。受诸佛境界。以普智而自乐。明了诸佛之行。晓解于无数无数无得。而悉清净于诸土。而无住于佛法。而无我。亦无想念。等诸佛法。不起兴二。明诸佛土。菩萨如是。现与诸佛等其去来现在菩萨之行。音声无断。其悦乐龙。为若此处龙境界。复现天上。受彼极乐。如是族姓子。是像大德之法。立志以普贤大士行。菩萨无上誓愿。当奉勤修。净其内性。是谓族姓子。第十大定场广博明显无量菩萨之行。得其净性。广其大乘。此族姓子。普贤菩萨十定之场也

佛说是普贤菩萨十德大道之定十无上要慧。普于十方诸佛国土。皆悉旷明。自然感动诸土。都悉率自庄严诸土菩萨及诸天人。悉作天上。无量倡乐。咸悉歌叹普贤菩萨无量之德。明照诸土。众冥莫不开避。十方诸地狱诸苦痛。登尔之时。莫不懈息。十方诸土如尘之数。诸众生之类。咸悉各各所在。皆发无上正真道意。那术百千之众。皆得无所从生法乐之忍。佛说是已。普贤大士等目菩萨。一切菩萨。及一切众会。天龙鬼神。阿须伦。人与非人。闻佛所说。莫不欢喜。为佛作礼而退

等目菩萨经卷下


度世品经卷第一

    No. 292 [Nos. 278(33), 279(38)]

度世品经卷第一

        西晋月氏三藏竺法护译

闻如是。一时佛游摩竭国法闲道场普光讲堂莲华藏师子座。觉了真谛。无有二行。度无想法。如佛游居。以致平等。一切诸佛。进退游行。无所挂碍。亦无荫蔽。法无退还。行无等伦。所见奉敬。不可思议。现等三世。其身所显。普周世界。分别诸法。慧无犹豫。具足诸法。坐佛树下。究畅经典。不疑正觉。不想计身。一切菩萨。志愿道慧。佛行无二。所济第一。度于彼岸。不坏如来建立脱门。诸佛土地。不可限量。所游平等。所修法境。旷若虚空。十方国土。不可计会。亿百那术一切尘限诸菩萨数其亦如此。菩萨大士。皆生补处。当成无上正真之道。各各他异。十方佛国。来会此土。皆成开士。皆发慧目。德门无极。开化一切众生诸界。顺律唱道。权方便门。晓了随时。住菩萨法一切世界讲堂楼阁。越升慧定。而以观察灭度之地。尊敬道慧。蠲除一切言辞行阴所可释去。明识因宜。摄取众生。入于无量道。游其中一切众生所作祸福。皆有报应。终不腐朽。分别应时。所试观察。永无所获。解知众生诸界志性。达了诸根。省应可度。从其缘便。应病授药。去来今佛。所可颁宣。章句议理。辄受奉持。已受其决。执怀平等。解发正藏。所当归者。入于现世。度世无量法。自所入真正悉已畅解。有为无为。观之无二。去来今佛。一切如来。所入道场。一时道御。建平解。成平等觉。悉能示现。心闲心懅。已了佛道。不离一切众生发心。入一人心。则能普入一切众生。所知所乐。自于其慧。而不动转。诸菩萨身。逮得普智诸通慧心。住于其地。而不退转。菩萨所行。力无休懈。周旋往来。慧无所行。一切人故。于无数劫。在于生死。晓了建立。不可计劫。难可值见。诸菩萨宝。真正难遇。常转法轮。未曾劳废。开化众生。令入律品。过去当来。现在如来严净斯处。逮成众生。具足本行。所誓已具。功行殊特。如是菩萨。及余学士。十方诸佛。所可咨嗟。劫数无际。所叹无限。其无元底。与众超异其名曰普贤菩萨。普因(一作目)菩萨。普化菩萨。普智菩萨。普眼菩萨。普光菩萨。普观菩萨。普明菩萨。普英菩萨。普觉菩萨。如是之等不可称计亿百那术十方诸佛国土尘数。如是普贤。成就所愿。其所誓志。志愿超殊。若诸佛兴。普往求请。晓了随时。皆持诸佛所化法目。不断一切如来之教。诸佛兴世。速疾受决。成最正觉。名号国土。已净毕了。所住法轮。见无佛国。示现为佛。严治一切凶弊秽浊难化世界。休息灭除诸菩萨众挂碍祸福。入无阴盖正谛法界。于是普贤菩萨。即以佛藏三昧正受。这三昧已。应时遍入十方诸佛之所游居。靡不周畅。皆以通达。无有余土而不彻者讲堂法境。其虚空界。悉至无际。十方刹土。六反震动。其大光明。靡所不照。謦扬洪音。莫不闻声。普贤菩萨。从三昧兴。见诸菩萨。咸来俱会。欣然大悦。普智菩萨。睹诸菩萨皆来云集。亦复踊跃。前问普贤菩萨大士。善哉佛子。今诸菩萨。十方来会。渴仰经典。瞻戴仁者。如冥思明。唯为解说诸菩萨行。从始至终。令无疑。结者亘然。如病得愈。盲者得目。何谓菩萨有所依怙。而无所著。何谓菩萨未曾有想。何谓为行。何谓善友。何谓精进。何谓劝信。何谓化众生。何谓禁戒。何谓受决。何谓菩萨不相求短。何谓入如来。何谓得入众生性行。何谓逮入于诸世界。何谓晓入诸念劫数靡所不达。何谓畅说于三世事。何谓得入三处。何谓无厌。其所发心。无所缺漏。何谓菩萨分别诸辩。何谓菩萨逮得总持。何谓菩萨颁宣佛道

普贤菩萨。缘普智问。欲令来者皆得开解。赞言善哉。诸会菩萨。皆共咸听菩萨有十事法有所依怙。而无所著。何谓为十。依菩萨心令不违失。依于善友常修专精。倚于德本而植福庆。顺度无极能奉行故。恃一切法无所归故。怙誓诸愿使亲道故。专于诸行习具足故。附诸菩萨一生补故。归奉诸佛心欢然故。奉诸如来叹如父故。是为菩萨十事法有所依怙为无所著。菩萨住此。疾逮无上如来大慧。至无极依。于是颂曰

  依者无所依　　自归于诸佛
  解法无所望　　乃至于大愿
  见诸佛欢然　　依之而奉敬
  恃怙诸如来　　因具足道行

菩萨有十事未曾有想。何谓为十。念诸德本如己无异。身积众善以施众生。一切功训以为道想。解达众生为道器想。愿济一切如己愿想。皆以诸法施不及想。察一切法念如佛法。为一切行如奉身想。一切言辞于诸所行无所妄想。睹见诸佛为父母想。于众如来为无二想。是族姓子。诸菩萨众未曾有想。菩萨住此。疾成无上。逮众德本。于是颂曰

  为一切积德　　念之如己身
  观察于众生　　亦如道法器
  诸众生造愿　　与身等无异
  归命于道法　　令致无从生

菩萨有十事为行。何谓为十。讲说分别众生所行。而求一切诸法所行。普学禁戒寻即奉行。积累诸行众德之本。一心专精奉修三昧。晓了圣慧所当归趣。殷勤谨敕无所违失。游于刹土欲庄严故。修善知识不离恭恪。奉如来行敬如师子。是为十事。于时颂曰

  一切有所行　　当开化众生
  勤求于诸法　　而奉行禁戒
  积累众德本　　一心归定意
  晓了圣明慧　　所游净刹土

菩萨有十事为善友。何谓为十。建立道意。能修德本。入度无极。颁宣道法。开化众生。分别辩才。称举群萌。除众妄想。住无患厌。立普贤行入诸佛慧。则为善友。是为十事。于是颂曰

  心建立于道　　精勤修德本
  入诸度无极　　颁宣诸经典
  开化度众生　　辩才决众疑
  称誉于黎庶　　除去众想念

菩萨有十事为精进。何谓为十。讲说一切众生之界。识念经典之所归趣。严净一切诸佛世界。又当奉行诸菩萨戒。常忍一切众难之患。为断地狱饿鬼畜生烧煮之痛。降伏一切众魔官属。不令众生怀嗔恨心。当奉十方诸佛世尊。常遇诸佛归命咨受。是族姓子。应行菩萨十事精进。于时颂曰

  归命于诸佛　　严净众佛土
  奉修菩萨行　　忍一切苦恼
  断三涂之难　　降伏魔官属
  能悦于众生　　常见诸如来

菩萨有十事为劝信。何谓为十。常建立意亦劝他人使发道心。仁和第一无所诤讼。亦化他人立于欣悦蠲除愚法。亦化他人令弃邪典使住佛道。务求德本亦劝他人使志善原。归度无极亦劝他人求波罗蜜。己生佛种亦诱他人令务佛性。身已得入无所有法开进他人使立空法。赞诸佛慧无所讥谤示宣他人不毁正觉。具足普智诸愿纯备亦导他人成诸通慧。究竟道誓以得严净如来至真无尽之慧。亦当建立一切众人入如来道。是为十事。于时颂曰

  已建立在道　　亦化于他人
  心不怀诤讼　　和悦忿恚者
  弃捐众愚冥　　开化痴邪径
  常求众德本　　诱之住道义

菩萨有十事开化众生。何谓为十。菩萨布施诱进众生。和颜悦色而劝进之。班宣经道令其亘然。诱进分别己身无异。所施无量发起人界。显佛菩萨行诱众生种。示诸世间如火然炽。训教众生无上道法。神足变化若干感动。晓了若干善权方便。随其习俗度脱众生。是为十事。于时颂曰

  菩萨行布施　　已用化众生
  常和颜悦色　　诱进诸不及
  睹世如然炽　　显示佛大道
  神足现变化　　若干权方便

菩萨禁戒有十事。何谓为十。不舍道心。捐声闻缘觉意。观察一切众生愍行。开化群萌令住佛法。奉修菩萨所应学者。解一切法悉不可得。所造德本劝助至道。未曾猗着于诸佛身。能忍诸法亦无所倚。济护诸根以为禁戒。是为十事。于时颂曰

  常和于道心　　舍声闻缘觉
  愍伤于众生　　劝使立佛法
  学诸菩萨行　　解法无所有
  一切所行德　　劝助于佛道

菩萨有十事受决所见受决能自知之。何谓为十。发仁和心。自然道意。不厌菩萨行。弃捐一切。诸所妄想。而能奉修诸佛之法皆能笃信诸如来身所可宣说。亦以究畅成就德本。化于一切使住佛道。等敬亲友而无二心。视诸善友如见诸佛。古昔所愿将护佛道。是为十事受决。于时颂曰

  等心敬善友　　利义皆由之
  将护古昔愿　　清和发道意
  不厌菩萨行　　弃捐众妄想
  使住诸佛法　　笃信如来教

菩萨有十事不相求短。何谓为十。入于宿世本所誓愿。随时入行导习其便。不失正义皆得通入。诸度无极具足成就。随其宜便。所可入者顺从所愿。随其所乐以开化之。庄严刹土劝使入道。神足变化使从其教。普为示现所生之处。是为十事不相求短。于时颂曰

  入于宿世愿　　世行随宜便
  遵习不失节　　顺诸度无极
  因得大成就　　从若干信乐
  为庄严佛土　　以神足变化

菩萨有十事入于如来去来现在一切诸佛所可由成。何谓为十。入于无量平等道教。而转无限经法之轮。宣传无量慧义之要。顺从无际音声通畅。开化无底众生之类。显畅无数神足变化。随时遍至若干种形。入于无喻诸三昧定。照耀开悟不可计量。示力无畏显现无限使入灭度。是为十事如来所入。于是颂曰

  过去来现在　　一切诸如来
  入无量道教　　转无限法轮
  顺无际道法　　宣无底慧场
  开化无数人　　神足不可计

菩萨有十事入众生性行。何谓为十。入于本行众生所解。随时开度当来受身。一切人民遍于群萌。现在所作入于众生。善行本末随时救济。诸非法行当宣道众生。心性所入晓了一切。根原所趣分别若干。随所爱乐发起诸碍。尘劳爱欲数数说法以度脱之。是为十事入众生性。于时颂曰

  晓了过世行　　亦复知当来
  分别现在事　　众生所可行
  入于众德行　　亦游于无德
  其心靡不周　　使诸根成就

菩萨有十事入于世界。何谓为十。常知止足在于世间。而修清净无所沾污。处于俗间心存少求。演无极香薰诸迷惑。所入方俗如一土尘。周于无量微妙之义。亦遍旷然无量世界度脱有身四大之患。恭敬自归于诸佛道。亦复游人无道天下。是为十事游入世界。于时颂曰

  在世知止足　　所行常清净
  所入而少求　　周遍无极业
  犹如尘世界　　解微妙之行
  小大无不达　　入于诸所有

菩萨有十事晓入诸念劫数。靡所不达。何谓为十。知过去劫。晓当来对。知现在事。知有限世。识无限碍。入于有限无限之事。了诸有数无数劫事。于诸有数使入无为。令诸无念畅入有念。畅诸有念使入无念。是为十事。晓了诸劫。靡所不达。于时颂曰

  入于过去念　　当来亦如是
  游步在现世　　而皆悉念之
  周流无量劫　　有数若无数
  无念入有念　　一切想无想

菩萨有十事畅说三世而无二言。何谓为十事。以过去而宣说之。往古以没豫说当来。灭来久远演现在处。尚未当来豫说过去。尚未欲至辄宣现在。亦复班宣未来生者。传于现在忽以过去。解于现在谓之未来。目所睹者宣之平等。现了三世一时悉达。是为十事畅说三世。于时颂曰

  能说过去事　　演古如是来
  说过为现在　　亦畅当来事
  过去今现在　　未至豫演生
  解生现以过　　目见今当来

菩萨有十事入于三处。何谓为十。入诸有数。至无所念到有所获。趣诸有教。游众想处。归众方俗。畅众言辞。达不可尽。咨嗟寂然。畅众憺怕。是为十事入于三处。于时颂曰

  入众有所念　　有所得教授
  在想众方俗　　所念不可尽
  宣传寂然事　　亦入于憺怕
  灭除诸恶事　　如是成道意

菩萨有十事无厌其所发心无所缺漏。何谓为十。供养诸佛住在众色而不懈惓。敬顺一切诸善亲友。求诸经典不以为难。博闻众经启受不逮。发意之顷颁宣经道。开化众生示以法律。发起一切使至佛道。于无数劫住一世界修菩萨行普游诸国靡不周遍。未曾怀疑佛诸经典问则发遣。是为十事。发心无厌。无所缺漏。于时颂曰

  供养诸佛身　　不以为厌足
  亦顺众善友　　务求诸经典
  所求不懈倦　　见诸发心者
  为说道训教　　开化诸菩萨

菩萨有十事分别诸辩。何谓为十。分别众生所入辩慧。晓了诸根当可归趣。了诸罪福诸所报应。睹其所生在于何处。皆知世间诸所有无。睹见诸佛之所游居。晓了经法义理深浅。畅解法界之所存没。达于三世去来现事。亦能分别不可计数所行言慈。是为十事菩萨诸辩。于时颂曰

  晓众生所知　　诸根之所趣
  随所立罪福　　见之当所生
  分别诸世界　　亦晓了法品
  究畅佛道慧　　三世之本末

菩萨有十事逮得总持。何谓为十。博有所闻辄则奉持。怀抱经典悉不忘失。执法锭燎有所宣化。皆从方便解诸经典。晓法自然逮法光明。致诸佛道不可思议。执诸定意现在闻佛。面前启受寻奉行法。入道场音能随方俗。演出言辞不可思议。念三世事去来今佛不可计法。随时宣传。怀若干辩一切诸佛经典之要。耳所闻谊。不可称限。所兴圣慧。能畅诸听持诸佛法。建立如来十力无畏。是为十事。菩萨总持。于时颂曰

  博闻辄执持　　不忘一切法
  晓了随时说　　解诸法自然
  以法大光明　　不可思议慧
  现在得三昧　　目前闻经典

菩萨有十事为颁宣佛道。何谓为十。晓了道议。志誓大愿。分别罪福之所归趣。常住正觉。不怀自大。畅达法界。识知定意。明解心本。晓了本净。随本而觉。使成佛道。是为十事菩萨班宣佛道。于时颂曰

  晓了于佛道　　解愿知罪福
  为诸佛所立　　解法无自大
  分别心本净　　定意之所归
  本净亦自然　　随本而觉悟

佛说是时。三千世界。为大震动。其大光明。普照十方。诸天龙神。皆来散华。以诸音乐。来娱乐佛。欢喜悦豫。皆共欣庆。幸哉吾等宿世其德纯厚。得豫此会。服深妙议。无极道慧。何其禄厚。世尊能仁。十方慈恩。开示法藏。疗治盲冥。消化五阴六衰。三毒五盖。十二因缘。六十二见。示以五事。戒定慧解度知见品五眼六通。六度无极。布施持戒。忍辱精进。一心智慧。以成佛道。班宣开示十二部经。开化邪见六十二疑。使发道意。诸佛遥赞。菩萨悦豫。普智菩萨。复问普贤。何谓发菩萨心。何谓行法。何谓大哀。何谓缘发道心以其所缘而兴其意。何谓见善友发恭恪心。何谓菩萨逮得清净。何谓度无极。何谓佛慧。何谓所历。何谓菩萨力。何谓平等。何谓生觉圣。何谓说法。何谓而行奉持。何谓辩才。何谓无数。何谓为行等心。何谓行慧。何谓菩萨而不自大普贤菩萨答曰。善哉。佛子所问。甚为深妙。何其快哉。谛听谛听。今为仁说。普智菩萨。与诸大众。受教而听。普贤菩萨言。有十事发菩萨心。何谓为十。发心之时。常怀大慈护持一切众生之类。所行怜愍。察于人民勤苦之恼。如身自更。一切所有皆能惠施。念一切智。心则为原首。念一切智。故能发意。不毁圣谊。兴从严心学诸菩萨禁戒之要。其心坚固。亦如金刚。蠲除一切诸恶垢浊。其所生意。若如江海。导御一切诸清白法。其志强固。如须弥山则能堪忍众庶言辞善恶音声。其所发心。造立永安。施于众生。大诚信业。而心独步。智度无极。晓了诸法。随便将护。是为十事发菩萨心。于时颂曰

  而发大哀心　　将护于众生
  见之在苦恼　　愍之如己身
  思惟一切智　　得志所庄严
  其心如金刚　　智慧如江海

菩萨有十事行普贤法。何谓为十。于当来劫与一切俱。普愿行仁奉敬未至。如来至真等处色法。开化众生立菩萨行。积众德本而誓普贤。皆能游入诸度无极。所愿和雅具菩萨行。遵修诸法皆欲庄严。诸佛世界平等诸议。受生一切十方佛国。晓了方便求众经典。悉乐现生于诸佛土。逮成无上正真之道。是为十事菩萨行法。于时颂曰

  悉知当来劫　　奉敬诸如来
  菩萨等众生　　所誓普贤行
  积累众德本　　入诸度无极
  庄严诸佛土　　疾成无上觉

菩萨有十事常行大哀。何谓为十。观于众生孤独无种为兴大哀。察之无道化以大悲。见贫厄众令殖德本。将久眠寐使得觉悟。见众生界无有方便。化之随时。为诸贪欲所系缚者而劝护之。瞻于群萌所遭厄难愍之令济。睹久疾病疗之以慈哀。离善法者显示道议。若见众生失于佛法愍哀悦豫。是为十事菩萨大哀。于时颂曰

  在世行大哀　　观察于众生
  久远遭疾厄　　由断德本故
  为兴无盖哀　　建立于佛道
  菩萨行大慈　　以开化众生

菩萨有十事缘发道心。何谓为十。教诲众生。令顺谊律而发道心。欲除一切众苦恼患。建立人民使意永安。见于群萌在无明地使发道意。好劝众生使入佛慧。顺随正觉奉敬一切诸佛最圣。皆欲得见如来至真。亦复乐睹诸佛色像相好威容。亦复爱喜入诸佛道故发大意。亦复敬爱十力无畏。是为十事缘发道心。于时颂曰

  见众生所灭　　为恼患所缚
  欲令至永安　　故发菩萨心
  人民在无智　　劝示以佛慧
  令奉三界将　　常睹诸如来

菩萨见善友发恭恪心。菩萨初发正真道意。与善友俱。谦下恭顺。欲得务成佛一切智。故习善友。为之屈意。见善友发意有十事。何谓为十。奉敬自归。心无爱欲。如所闻音。则能奉行。心爱乐之。志不瑕秽。常一其心。以诸德本。合为一业。怀抱一愿。发世尊意。其志平等。所行具足。是为十见善亲友发恭恪心。于时颂曰

  心常怀恭恪　　如所闻奉行
  如喜无瑕秽　　其意常专一
  合集众德本　　自归于世尊
  常尊平等行　　道心乃具成

菩萨清净有十事。何谓为十。净如虚空。究竟无失。于诸色净。随众生本。而开化之。诸音清净。演不可谊。言辞众响。其辩才净。分别无量佛所说法。其慧清净皆弃无智。所生亦净。得诸菩萨。自在由己。眷属微妙。晓了众生宿世所行。而开化之。报应亦净。除去一切挂碍阴盖。所愿解明。解诸菩萨。所生一品。其行皦然出普贤乘。是为十事得清净。于时颂曰(丹本注云诸本阙颂)

菩萨有十事逮度无极。何谓为十。行度无极。一切所有皆能布施。戒度无极。具足佛禁忍度无极。能行仁和逮佛净力。进度无极。所行勤修而不退转。寂度无极。使意一定。智度无极观一切法。本自然谛。慧度无极。入佛十力。愿度无极。具足普贤。神足度无极。多所变化无所不现。法度无极。等御一切诸法本末。是为菩萨十度无极。菩萨住此。得归无上如来正真无极大慧。具足六度。于时颂曰

  布施度无极　　皆能施所有
  持戒度无极　　清净佛诸行
  忍辱度无极　　仁和不怀恚
  精进度无极　　勤修不退还
  一心度无极　　志定无愦乱
  智慧度无极　　观诸法自然
  神通度无极　　普入佛道力
  所愿行平等　　神足道诸法

菩萨有十事慧。何谓为十。晓解一切十方世界。其众生种。不可思议。识别诸宗。晓了诸法。不失时节。若干种形。若以一品。皆令觉知。达诸法界。能班宣慧。晓了一切虚空本末。通使无余。第一佛慧。十方世界。诸过去事。皆能知之。十方佛土。诸当来事。悉能见之。十方佛国。今现在事。普入教化。晓愿如来一切诸行。具入一切慧。解知去来今现在佛。皆同一行。是为菩萨十慧义。菩萨住此。其大光明。自在照耀。具足所愿。信诸佛法。则以一慧。解诸佛法。于时颂曰

  能知十方界　　众生不可计
  普令入道慧　　使无若干念
  能分别诸法　　平等如虚空
  佛慧为第一　　能达三世事

菩萨有十事而有所历。何谓为十。悉解诸法为一品义。一切经典而有节限。晓了诸慧则为一相。分别众生心念行慧无为无数见诸群黎皆以一等明识众生所行尘劳。人民志性系缚在行。明识众生所行善恶一切菩萨所行志愿。乐不自大如来十力。建立无余而上正觉。是为十事菩萨经历。于时颂曰

  知诸法为一　　解了际限故
  众慧合一相　　众生心无数
  解见诸人民　　尘劳行所迷
  众结所缚束　　不得普智心

菩萨有十事力。何谓为十。一切诸法皆入自然。诸有经典悉如所化。众义若幻计诸法数皆为佛法。诸所经典悉无所倚。一切所有归三脱门。见众善友重事奉敬。心习势力以众德本。入无上慧道王之堂。未曾诽谤深微之慧。信乐诸佛一切智心。终不退转善权力故。是为十事菩萨之力。于时颂曰

  一切法自然　　皆如幻化力
  诸法悉佛法　　义归三脱门
  奉敬众善友　　常积众德本
  入无上慧堂　　笃信佛深法

菩萨平等有十事。何谓为十。等心众生。亦等诸法。普观佛土。性行无二。因诸德本。等诸菩萨。所愿无异。诸度无极。亦无差别。一切诸行。皆归同像。十方诸佛。悉为一佛。是为十平等。于时颂曰

  等心念众生　　普观众经典
  亦等诸刹土　　性行不怀二
  皆合诸德本　　菩萨常行慈
  所愿无若干　　具诸度无极

菩萨有十事发觉圣。何谓为十。一切诸法但有音耳。皆归寂然诸法如幻。经义若影。目所见者悉因缘合。诸义业净。一切诸法悉假文字。诸事之业因其本净。道慧无想究尽本原。诸有形者皆由法界。是为十生觉圣。于时颂曰

  诸法悉寂然　　譬之如幻化
  假喻若影响　　皆由因缘生
  诸法本末净　　一切无所生
  悉因其本际　　无想为真谛

菩萨说法有十事。何谓为十。演深妙法。所说义者。随时得入。讲若干事。当多宣畅诸通慧事。亦能分别诸度无极。宣示如来十种力事。解三世义。常说菩萨不退转法。咨嗟诸佛功训之德。班宣菩萨。诸佛如来。平等出家。是为十事菩萨说法。于时颂曰

  讲说深妙法　　悉使入道义
  演若干之慧　　多宣一切智
  演诸度无极　　显示十种力
  三世无挂碍　　菩萨不退转

菩萨有十事而行奉行。何谓为十。积累一切诸善德本。闻诸如来讲说经典。辄能受持。执一切现。举喻说之。御导一切奉行法门。怀抱总持道义慧门。皆能断除狐疑诸着。悉以具足诸菩萨行。一切如来辩才平等。开化说法。演其光辉。言皆受诸佛。所娱乐业。而建立之。使得至于无上正真。是为十事说平等门而奉行之。于时颂曰

  积累众德本　　咨嗟如来法
  观诸法平等　　奉宣道慧门
  弃捐诸疑着　　具足菩萨行
  诸法为世门　　皆令入道室

菩萨有十事分别辩才。何谓为十。所演诸法永无想念。分别诸经悉无所行。诸义辩才亦无所著。解诸法空班宣无量一切诸法。悉佛所立。一切所有悉无所依。皆能分别诸法章句。宣畅经典真谛之义。常以等心愍于众生。应意说法。令得悦豫。是为十辩才。于时颂曰

  讲经无想念　　一切无想行
  不着于诸法　　解之悉为空
  辩才无限量　　诸法佛所立
  一切无所猗　　解之悉本无

菩萨有十事得自在。何谓为十。开化众生。照耀诸法。修诸德本。行无极慧。不着禁戒。所造善本。劝助佛道。所行精进。而不退还。降伏众魔。其所爱喜。解了道心。一切佛道。在于邪见。而成正觉。是为十得自在。于时颂曰

  晓开教众生　　得照耀诸法
  奉行众德本　　自在无极慧
  心皆无所著　　精进不懈惓
  降伏于众魔　　道心得由己

菩萨有十事所施无数。何谓为十。开化一切诸世间难。众生本末亦不可计。经典之事亦不可量。一切所作亦无崖底。有计诸法崖际难尽。众德之本亦无俦匹。一切诸恶悉无能宣。诸所志愿亦无边际。众行所趣无能为喻。一切菩萨独步无侣。诸佛正觉独尊无双。是为十事。所施无数。于时颂曰

  世计不可计　　众生无有数
  诸法无边际　　所造亦无限
  德本无俦匹　　诸恶无处所
  菩萨无等侣　　诸佛无俦匹

菩萨有十事为行等心。何谓为十。等心积德。志愿同等。众生身意。亦无有二。入于人民。罪福所趣。普游诸法。视诸佛土净秽同一。劝化众生。使入笃信。等心诸行。及众妄想。皆入诸佛十力无畏。悉由如来平等之慧。是为十等心。于时颂曰

  等心积德本　　兴显一切愿
  平等众生心　　罪福无殊异
  普入诸经典　　等观诸佛土
  愍念诸众生　　使入无异行

菩萨有十事行慧。何谓为十。晓了众生当归解慧。遍入诸国若干刹土。未入者入之。游诸贪网。除去臭秽所游诸界。知其增减。晓了诸法。各各有异。或复一品。普能周旋。众界音声。解世间众想。所住颠倒。所念各异。以一言辞。普入一切诸法言教。如来威变。建立法界。一切众生。处在三世。诸佛入中。训诲无废。皆令入道。是为十事菩萨行慧。于时颂曰

  信解众生界　　普入诸佛土
  悉至于十方　　等观诸世界
  诸法无若干　　入不可计身
  如来所变化　　开度于三界

菩萨有十事而不自大。何谓为十。不轻慢人。蚊行喘息。身心谦下。不轻易人。不以刹土而自贡高。若得奉敬不怀自大。不以好音。而自叹誉。行愿备悉。不以绮饰。开化众生。离于懈怠。成至正觉。常怀哀愍。讲说经典。不咨嗟身。有所建立而不自大。是为十事不自大。于时颂曰

  不轻慢众生　　得刹土不悦
  而奉敬不欢　　离于好音声
  无贪诸所愿　　开化于众生
  得成最正觉　　颁宣大道慧

说是法时。天龙鬼神世间人民阿须伦迦留罗甄陀罗摩睺勒。莫不欢喜。咸发道意。师子虎狼。熊罴鹿党。鱼鳖鼋鼍。诸小小虫。皆有慈心。无相害意。闻所说法。各各欢喜。而发道意。诸天散华。其落如雨。烧众名香。郁如云兴。箜篌乐器。不鼓自鸣。当尔之时。莫不喜敬

度世品经卷第一度世品经卷第二

        西晋月氏三藏竺法护译

普智菩萨。复问普贤。何谓建立。何谓乐信。何谓深入。何谓依怙。何谓意勇。何谓断诸疑。何谓无思议。何谓解说真谛。何谓了报应。何谓定意。何谓何所有。何谓脱门。何谓神通。何谓通达。何谓解脱。何谓园囿。何谓宫殿。何谓游观。何谓庄严。何谓心不动。何谓性无所舍。何谓观慧。何谓讲法。何谓净愿。何谓为印。何谓慧光。何谓行无色。何谓无法心。何谓心如山。何谓如海。普贤曰。善哉问。菩萨建立。有十事何谓为十。常志于佛。恒思经法。劝化众生。使住佛道。劝安事业。修立正行。顺乐誓愿。常念威仪。所游随时。班宣善本。建立慧义。是为十事。建立其心。于时颂曰

  一心常念佛　　专精思经典
  劝众生入道　　示以所造业
  赞助修正行　　恒使不失愿
  威仪礼节备　　善本成圣慧

菩萨乐信有十事。何谓为十。菩萨。心自发念。其有当来如来正真。出现于世。我当悉见。见诸佛已。供养奉事。志于无上。稽首自归此诸正觉。当训诲我。以是训诲。归菩萨地。如诸菩萨。奉教敬心。心怀恭恪。如所闻者。辄当修行。于是菩萨。复自念言。使吾不离诸佛世尊及诸开士。蠲除生死驰逸之难。无央数劫。修菩萨行。又心念言。昔未发无上道意之时。未为法器。畏甚深义。亦畏世间诽谤恶名。又惧畏生死恶道众会。我以离此。永不与合。以远在事。所生之处。不离道心。不恐不畏。亦不怀懅。永无诸难。常远尘垢。永灭秽浊。出入独步。降伏众魔。消诸外道。又心念言。吾当劝化。诸众生界。使随律教。志在无上正真道意。修菩萨行。得成佛时。则随尊圣微妙道教。吾当稽首。奉敬自归。欣悦无量。尽其寿命。佛灭度后。当为兴立无数庙寺。供事舍利。奉宣佛教。分布经典。使无上义永得长存。又心念言。我当庄严无极世界。皆令佛土清和柔软。种种别异。平等清净。吾当感动无数佛土。悉使发意。演大光明照于十方。神足变化。靡不周遍。又心念言。吾成佛已。当决众生一切狐疑。化其志性。令常清和。寂静其志。消灭尘欲。塞诸恶户。阐永安门。除去幽冥。奋巨光耀。弃捐魔业。逮无上吉。以是功勋。普示众生。又心念言。吾所在处。常见诸佛。在危厄时。思欲奉觐。必当如愿。得见正觉。莫使违远。面见如来所说法时。如来难值。无央数劫时一出耳。犹灵瑞华。久久希有。发清净心。弃捐一切不宜之计。其意质直。而无谀谄。又心念言。吾成无上正真之道。为最正觉。遍诸佛土。施作佛事。为诸众生。各现佛身。击大法鼓。雨法甘露。施无极法。清净无畏。为师子吼。立无底愿。住于法界班宣经道。一劫不休。身不疲懈。言辞无极。心亦不惓。是为十事心所建立。于时颂曰

  严净诸佛土　　劝道于众生
  示以深妙法　　令发无上道
  常愿见诸佛　　奉事自归命
  听受所说法　　一心受奉行
  为断三恶趣　　开阐安乐门
  为于众幽冥　　显示大光明
  流布经法施　　消灭诸垢尘
  为大师子吼　　而雨大甘露

菩萨有十事法深入。何谓为十。皆入世界诸过去事。游于志性深奥佛法。归诸佛土当来之事。在在佛国。而在诸数。正觉无二。虽在诸国现在寂然。世间方俗。所言所说。严净境土。悉能知之。是入深法。所在天下。有若干教。又能解识一切众生罪福不同。计诸菩萨所行各异。又菩萨解。悉知过去诸如来处。菩萨悉知诸佛世尊所教迟疾。菩萨复知现在国土诸佛正觉眷属圣众。所可说法。开化众生。法界虚空。无有边际。十方如来。又分别知世俗之法。声闻之法。及缘觉乘。菩萨如来。入于此法。无所希求。讲说若干所入法界。亦无所入。亦不想法。随诸法教。而以开化。是为十事深入佛法。于时颂曰

  知于过去世　　当来及现在
  随方俗示现　　清净佛世界
  分别人罪福　　诸菩萨所行
  现在诸佛土　　诸菩萨集会
  知众生之数　　说法虚空限
  悉达诸声闻　　缘觉众菩萨

菩萨依怙有十事。以是依怙。修菩萨行。何谓为十。常奉敬佛。日有归命。开化众生。见诸善友。而依附之。常喜积聚众德之本。亦皆严净诸佛刹土。常愍一切不舍众生。普以游入诸度无极。悉欲具足诸菩萨愿。所修无量。来归道心。明解诸佛。成至正觉。是为十事菩萨所依怙以成道行。于时颂曰

  奉敬于诸佛　　依附菩萨行
  开化众生类　　恭顺诸善友
  积累众德本　　严净诸佛土
  入诸度无极　　具足菩萨愿

菩萨意勇有十事。何谓为十。消除一切诸阴盖罪。诸佛世尊。虽以灭度。奉垂训教。以勇猛心。降伏众魔。解知无常。不惜身命。以正法缘。消化外道。以柔和心。悦可众生。怀踊跃意。众会见之。莫不欣然。调化一切天龙鬼神揵沓和阿须伦迦留罗甄陀罗摩睺勒。皆受其缘。奉修柔顺。依法深奥。常舍声闻缘觉之地。于无数劫。行菩萨事。而不懈惓。是为十事菩萨心勇。于是颂曰

  弃捐诸阴盖　　佛逝奉乘教
  降伏于众魔　　不自惜身命
  降化众外道　　欢悦于众生
  鬼神咸受教　　常奉菩萨行

菩萨有十事断诸狐疑令无沉吟。何谓为十。菩萨发意。心自念言。吾当以施戒忍辱精进一心智慧。救摄众生。慈悲喜护。而开导之。虽行于此。无有犹豫。欲令进退。未之有也。又心念言。吾当普见十方正觉。当来诸佛。值无上慧。供养诸佛。心不沉吟。若于毛牦。又菩萨念。以若干光。具足照耀。于诸佛土。闻诸菩萨。当来所行。无央数劫。心不厌惓。开化无量众生之类。不以为难。计于法界不可限量。无有崖际。犹如虚空。所度众生。其数亦然。不以厌退。又心念言。修菩萨行。备悉诸愿。成一切智诸通之慧。又复念言。行菩萨时。令我皆逮道法之光佛无极明。常当计乐一切诸法。悉为佛法。普知众生意之所念。晓了无数诸无尽数。诸无为法。及诸有为。成平等觉。明达诸法。皆诸度世。除倒见想。虽有秽浊。本悉清净。菩萨晓了一切佛法。成最正觉。无有众想倒见之谬。一毛所著。漏虽有为。达于无为。弃诸利养。则能游入无央数际。是为十事菩萨断诸狐疑。于时颂曰

  念施戒忍进　　一心修智慧
  行慈悲喜护　　见诸佛奉敬
  光具足照耀　　无量当来劫
  心不以懈惓　　成佛一切智
  诸法悉佛法　　皆亦度世法
  弃秽浊倒见　　得佛最正觉

菩萨无思议有十事。何谓为十。所修德本不可思议。一切所愿不可计量。观察诸法悉如幻化。因发道心。依诸善业。无所违失。修菩萨行。永无妄想。修深要义。普入诸法。不取灭度。道慧不备终不舍去。菩萨行道。入胎出生。积勤苦行。诣佛树下。降伏众魔。逮最正觉。而转法轮。现取灭度。显诸佛事。建立所现。不舍大哀护诸众生。不违本愿。又其菩萨。建立示现如来十力。从初发意。在于法界。开化众生。未曾休废。又其菩萨。皆以无想入于众想。又以有想入于无想。无所思念说诸念事。又以诸念说无念事。以无所有入于所有。又诸所有入无所有。化无所作入有所作。化有所作入无所作。于无所得说有所得。于有所得说无所得。解知诸法悉无所有。又其菩萨。等心于道道以平等。解知众生道心无异。心不倒见所念无失。不随邪疑所睹平等。又其菩萨。发意之顷。其心寂然定意正受。在于本际而不造证。以无有漏而不永灭。布诸德本晓了诸法。一切无漏而为人说。诸漏已尽亦为人宣。当除诸漏。则以佛法入于俗法。虽在其中无俗思想。无道俗念。观一切法。皆入法身亦无所入。晓了诸法而无有二。亦无所行。是为菩萨十无思议。菩萨住此。疾逮无上正真之道

菩萨有十事。解说真谛。何谓为十。演一切佛法。随时真诚。弃捐恶法不失其节。以诸菩萨。神足变化。宣正觉教。能以随便。入于众生罪福之业。宣畅众生。除去一切尘劳罪事。皆以能达众生之义。无为法门。消诸挂碍。修闲静业。又其菩萨。悉无所住。犹如虚空。一一所入。不得禁戒。天地成败无有犹豫。在诸世界而不沉吟。而于诸法境。无所蔽碍。所由方面。益以微妙。达如来至真。至生出家。竟于灭度。又入法界菩萨诸佛。普见诸佛。举动进止。菩萨悉见众生之类处于泥洹。无所造故。愿不堕落。会当备悉。诸通慧智。又有菩萨。见一切法。无所依怙。不远善友。所当近者。亦不附着。如来精进。不懈休法。礼仪一等。亲友怨恶。积累德本。劝助令集。皆使同一。赞扬成就。令无有二。是为菩萨十事说常随时菩萨分别慧便有十事。何谓为十。晓了一切诸佛之国。解入众生本原衰盛。识别群黎心行所存。宣畅黎庶诸根兴耗。又知一切报应行果。普入声闻别随时义。皆亦复下众缘觉行。悉以方便。修诸菩萨。分别咸从世俗之法。一切悉顺入诸佛法。晓了慧宜。是为菩萨十分别慧。菩萨住此。速逮无上正真之道菩萨三昧有十事。何谓十事。定意之时。皆知十方世界所有。能以意定。寂众生身定诸法三昧。其三昧定。见十方佛。则能建立一切诸念。随时定意。其三昧有则能动转。无央数身。亦复能使从三昧起。普入诸佛如来正觉。三昧正受。开悟众生。其慧普大。晓了随时诸菩萨三昧。一发意顷入一心慧。以无为心开静之慧。悉能普修诸菩萨慧。不废笃信。以愿大慧。晓了三昧。是为菩萨十事三昧

菩萨何所有有十事。何谓为十。众生何所有。国土亦然。观所众生。亦解本无。劫烧之时。天地为败。或水灾变。天地败已。复还合成。计佛正觉。亦无所有。若干种行。亦无处所。如来身者。功勋无量。一切诸法。所说本末。其义各异。若能供养诸佛正觉。所归亦无。是为菩萨十事何所有于是颂曰

  众生何所有　　国土无处所
  以察诸相好　　劫烧天地坏
  还合亦如是　　佛身若干品
  如来不可量　　宣法若干品

菩萨脱门有十事。何谓为十。其身普遍一切世界。现于十方若干品形无数色像。以诸法界入一佛土。建立一切众生之众。以佛庄严。形周十方若干佛土。自然觉知。至一切界。一发心顷。遍诸佛土。皆现诸佛。在一刹土。使诸佛界度入一身。悉使诸佛。感动神足。而以娱乐。显入一心。是为菩萨十事脱门。于是颂曰

  其身遍佛土　　显若干形像
  诸法入一土　　建立诸世界
  遍世现佛身　　自知靡不周
  诸法入一体　　开心一切人

菩萨神通有十事。何谓为十。识于过去所经历处。晓了方便。出入进退。天耳识别。无所挂碍。悉闻言辞。众所归趣。能知他人众生之类心所念行。无央数事。种种别异。则以天眼无为之业。观察一切所经周旋。以大神足感动变化。建无思议众生之类。从其本性。而示现之。使得入律。见于无限诸佛世界。遍示诸身。发心之顷。能周无量十方佛土。亦能庄严。建立无数境界处所。亦复显示具足身形。不怀自大。晓了通慧。于无底国。逮得无上正真之道。为最正觉。心无思议。因其众生志性本末。而示现教。是为菩萨十事通义也。菩萨住此。获致如来。无上正真神通归趣。方便随向。诸佛所变。现于十方。众生训诲。转成其行。众义备悉

菩萨通达有十事。何谓为十。则能随时。教化众生。分别罪福。群生之类所经历事。若干不同。使其出家。令心寂然。入诸蔽碍。一一众生。所行颠倒。若干不同。而使消除。达如金刚。圣慧具足。所可建立。其音周遍。不可思议。教诸佛土。晓了方便。一切猗着。习四等心。悉普游入。解所生处。亦复识了。无所从生。皆已除去诸想痛痒境界处所。又其菩萨。不观诸法。亦非不观。诸法无想。以为一净。亦无有净。明若干种。晓知精勤。于无数劫。班宣经道。而以等归。趣于无上正真之道。常住法界。又其菩萨。晓了众生。本悉灭度。不用家业。亦无所造。知有生者。为随颠倒。达其因缘报应之义。识可奉敬。以何缘便。所行本末。起灭处所。分别开化群萌之类。开明闭塞脱门之理。解其颠倒无谬之事。亦知尘欲嗔诤之原。亦别生死无为之业。复了反逆无逆之事。知可依怙不可怙者。亦明究畅别所至处。知其退转还复处者。知其至决及所归趣。亦识坏败当还成者。亦了开化知众生根。所当开化使得入律。若干方便教授黎庶而不迷惑失菩萨行。所以者何。佛子。欲知菩萨。所以发无上正真道心者。何以故。开化众生之故。既化众生。令从律教。身不劳惓。是为菩萨。为一切故所由无诤。晓了分别十二缘起。又其菩萨。未曾猗佛。亦不发心依怙佛也。亦不着法。复不兴心贪于法也。不着佛土。亦不生心依佛土也。亦不着人。复不起心慕乐众生也。不见人民。亦不发心观于群黎。兴显众行。具足所愿。修无极哀。不想见佛。识念如来。所班宣法。得如来座。殖众德本。亦不悁悒。心好正觉。不以劳懈。亦以法则。供养如来。心日加精。感动立威。不可思议诸佛世界。建立思惟第一法界。剖判若干经法之教。知于众生有为之会。亦识众生限节多少。了苦本末所可从起。亦知尽灭一切万物皆为苦本。若有菩萨。以能见此。其所修行。亦如影响。弃捐众恶。断其根本即自发心。救济众生。其所行者。悉无所行。曰菩萨行。学诸佛言。其心坚固。如须弥山。觉除一切众想颠倒。建立普智诸通慧门。逮成正觉。入于无极无限慧堂。所言慧堂。无上正真道。开度众生。三处漂流。反尽其原。是为菩萨十所通达。菩萨住此。逮成如来无上大慧

菩萨解脱。有十事。何谓为十。度诸尘劳爱欲之原。脱于邪见不正之路。而济五阴覆盖之患。又捄形体四大诸入。越于声闻缘觉之乘。因此逮得无所从生法忍。发起一切众生国土诸所宜法。便得超出诸菩萨行不可称限。称举一切诸菩萨行。以无妄想入如来地以一圣慧普知三世。平等神通靡不救济。是为菩萨十事解脱。菩萨住此。开化众生。使之无上。于时颂曰

  以度欲尘劳　　邪见诸五阴
  四大诸种类　　贪身之患难
  越声闻缘觉　　逮无从生忍
  称举众生土　　菩萨无量行
  开士之所修　　入如来之地
  超出众妄想　　神达解三界

菩萨苑囿有十事。何谓为十。乐于生死。未曾恶厌。好化众生。性无所著。处于一切众想之地。启受大行。常喜严净诸佛世界。住己处所。志在诸魔。婇女宫殿。悉能降化。宫台阁故。敬所说法。如所闻法。思惟知义。观察归趣。六通无极。四恩摄行。三十七品道慧之法。为菩萨园。是己严父。所可游居。如来十力。四无所畏。十八不共。取要言之。一切佛法。为菩萨园。未曾复思他奇异法。一切菩萨。所现变化。建立娱乐。为菩萨园。转于法轮。无自大律。而谨慎行。无所违失。一切发心。不离正觉。普现群黎为菩萨园。然其法身。皆遍十方。诸佛世界。菩萨所行。犹如虚空。是为菩萨十苑囿也

菩萨宫殿有十事。何谓为十。乐菩萨宫心不迷惑。十善章句。功德慧业。好积累。是乃为菩萨宫。开化欲界众生之类。修四梵行。慈悲喜护。菩萨由此。训诲色界群黎之品。往生净居诸天宫殿。菩萨由此。消灭一切尘劳诸秽。到无欲色天。至其宫殿。训诲大难。不闲群黎令其退还。或时生于杂秽境界。菩萨以是。乐受其处。拔济一切贪欲众生。菩萨有乐。现于后宫。婇女男女。宿世曾兴福行同故。由是教化四方四域。诸帝梵释四天王。菩萨由此。劝化凶危。计有常人。使舍乱意。处于一切诸菩萨业。念化长故。自恣驰骋。游戏神通。菩萨常皆一心脱门三昧正受。以慧开化。而娱乐之。以一切智无上正真诸佛之典断众挂碍。施一切法。而得自在。得为国主。尊豪由己。菩萨乐此。如来十力。以为游居。是为菩萨十宫殿也

菩萨有十游观。何谓为十。意自好喜。观诸章句。所履迹行。志意观察。善权方便。其所住处。辄得在诸佛足下。闻法启受。意乐十方。心普周遍。敬诸菩萨。神足变化。现无限门。化于众生。身意所惑。而奉定意一三昧门。则得普入诸定意门。处诸总持。一切所闻。便能受持。未曾忽忘。以此总要。为众生演。使令欢然。乐于辩才。以一章句。无央数劫。咨嗟美辞。谈言说事。无能断辞。志最正觉。而为众生。示现若干身形。无量品门。慕转法轮。化诸异学。令咨受法。是为菩萨十游观也

菩萨有十严净。何谓为十。其力鲜明。故能独步。无畏清净。无能过者。其义皎然。所演辞意。无央数劫谈言之事。无能妨废其法清净。能演八万四千法藏。经言清和。不忘一义。所愿微妙。一切菩萨。不舍所誓。其行鲜洁。班宣圣贤。诸正雅训。庄严刹土。以一音声。普告十方。如一刹土。己场清净。遍诸佛土。兴以道云。雨法甘露。建立正教。蠲除一切。有为妄想。驰逸之行。无慢清净。以一体而现众生身。教训一切。精勤不惓。夙夜务求诸通敏慧。示无数诸力无畏像。是为菩萨十清净也。菩萨住此。普得一切诸佛严净

菩萨有十事心不动。何谓为十。一切所有。施无所爱。其所施者。悉以清净。而心不动。思惟明察诸佛深法。奉敬诸佛。承事自归。专精无量。慈念众生。未曾嗔恨。不舍一切。蚊行喘息人物之类求诸佛法。未曾懈废。一切众生。不可称计。行菩萨业。无央数劫。不近不远。为菩萨行。未曾退转。无塞无阐。又其菩萨。本生信心。有所修行。无量清净。其清净者。离垢解明。殷勤修行。奉敬诸佛。弃所贪身。无所慕乐。而为俦匹。逮大踊跃无极之欢。笃信为导。归一切智。应其章句。究竟成就诸菩萨教。修行训诲。其所闻信。无所谤毁。烦惋变业。其心不动。是为十事菩萨心不动。而能住此。便即逮知诸通敏慧

菩萨有十事心无所舍。何谓为十。逮成诸佛最正觉道。故曰不舍。教化众生使从法律。无所遗弃随诸佛教。不废训诲。从诸善友。依附自归。而不违远。普诣佛国。稽首跪拜如来至真。不舍礼节。常求一切功勋之法。不舍大乘。敢值佛世。净修梵行。奉护禁戒。终不毁犯。随诸菩萨。勤修道业。不以懈废。慕求如来训诲之义。随时执持。咨受不忘。习诸菩萨本所行愿。皆念思惟。通诸佛教。是为十事。菩萨心无所舍

菩萨观慧有十事。何谓为十。观一切法分别章句。随时演说。察于三世众德之本。而为说法。视诸菩萨所行本际。而开化之。瞻诸法门。达其根原。亦睹诸佛所建立业。观众总持。以惠法门。而用归之。亦以明智。普察世间。视诸法界。顺慧而入。瞻知十方。慧无思议。睹诸佛慧。处了世界。圣明无量。是为菩萨观于十慧

菩萨讲法有十事。何谓为十。宣说诸法。皆从缘起。名一切义。悉令归趣。以积志行。演诸所有。亦如幻化。又宣诸法。皆亦本空。论议诸经。中间旷绝。而无崖底。诸所有业。悉无所著。又说诸法强如金刚。一切诸义。如来所畅。又说众业。寂寞憺怕。又演诸法。悉无所生。讲一切法。等一本净。说无合成。是为菩萨。讲法十事

菩萨清净有十事。何谓为十。其性本净。而无沾污。除去狐疑犹豫之结。令其鲜明。弃诸沉吟六十二见。所行威仪。而修礼节。好乐普智。诸通敏慧。所分别辩。巍巍清净。勇猛皦然。四无所畏。修菩萨行。一切游居。悉无瑕疵。劝诸菩萨。愿愿修习。行无秽浊。百功勋相。三十有二大士之业。求于无上正真之道。归清白法。严净一切众德之本净。是为菩萨十清净也。菩萨住此。得成诸佛无上清净菩萨印有十事。菩萨大士。由是所印。具菩萨慧。疾成无上正真之道。为最正觉。何谓为十。菩萨悉知万物皆苦。苦复苦。恼复恼。爱别离苦。怨会之苦。虽遭此难。勤求佛法。心不动摇。亦不违舍。菩萨之行。不恐不畏。亦不怀懅。不舍本愿。不废大智。一切敏达。心不违佛道业之要。愚痴凡夫。自己尘劳。恩爱之恋。修不善本。骂詈菩萨。毁辱轻易。演粗犷辞。瓦石打掷。加以刀杖。菩萨遭此。故求佛法。未曾厌废菩萨之行。常行忍辱。多怀仁和。随经典教。亦勤忍辱。具足正行。又其菩萨。班宣诸佛深妙之法。处一切智。使入己慧。悉具所生。化令众人。欢喜爱法。又其菩萨。观其体慧。致仁和性。兴普智心。吾当成佛无上正真之道。为最正觉。观察众生。驰骋周旋五趣之难。忧恼悁悒。使发道心。欢喜悦豫。加大笃信。忻然如是。坚固精进。又其菩萨。入于如来无边际慧。不越境界。如来圣明不可称限。闻诸佛世尊。班宣经道。亦无崖底。不限佛智。于诸文字。不生增减。分别诸义。不犯佛教。又其菩萨。爱乐无上正真之道。好喜深义。至于微妙无极之慧。以与若干。崇于无上。殷勤恋怅。未曾违远一切魔众。及与官属。其诸异学。诸外仇敌。无敢当前。未曾废舍一切智心。菩萨所行。饶益如是。终不回还。又其菩萨。行道之时。无所恐畏。不惜身命。发通慧心。修一切智。以为元首。皆得诸佛光明照耀。不舍道义。不远善友。又其菩萨。见族姓子若族姓女。志学大乘。使勤修行。慕诸佛法。劝立德本。受一切智。未曾休废。又其菩萨。其所游居。等心众生。亦复平正智慧。为诸群萌。班宣经典。普至无上正真之道。趣不退转。兴大慈悲。又其菩萨。计诸过去当来现在佛。思惟为一。以诸德本。奉启诸佛。未曾断绝。观诸敏慧。是为菩萨十印。以是印故。疾成正觉。印无上法菩萨慧光有十事。何谓为十。菩萨大士。必当逮成无上正真之道。以佛道照于一切。常见诸佛平等正觉。了知众生。终没所生。明识一切经典法品。发菩萨心。常习善友。分别所积众德之本。解智所印。常见诸佛。晓了开化众生之类。立如来地。宣无思议法门道堂。识解诸佛。随时建立。普能备具诸度无极。是为菩萨十慧光明

菩萨有十事行无量。一切众生声闻缘觉何谓为十。于是菩萨。修本际行。不备诸愿。终不取证。又其菩萨。殖众德本。发心劝助一切法界。不着诸法。又其菩萨。行道之时。察诸所行。犹如幻化。诸法寂然。而不迷惑。诸佛亦然。又其菩萨。去诸众生妄想之着。于无数劫。修菩萨行。具足大愿。不起疲懈。又其菩萨奉行诸法。悉无所著。诸法自然。悉亦寂静。亦不灭度。要当备悉一切智教。又其菩萨。知诸妄想及无想愿。宣无数劫所从本末真谛之行。又其菩萨。解一切法悉无所有。虽解空无不废道行。求诸佛法。又其菩萨。发意之顷。普入三界。亦悉普解三世之义。其心所达。中间迥绝。靡所不通。又其菩萨。用一人故。在生死难。无央数劫。行菩萨法。而建立志。于一切智。如为一人。忍诸劳惓。为诸众生。亦复俱然。终立之大道不懈废。以为劳厌当来之苦。又其菩萨。备菩萨行。不肯速取无上正真之道。为一切故。周旋尘劳。开化饶益无数众生。使立佛道。是为菩萨十无量行。菩萨住此。疾成正觉

菩萨有十事心不怯弱发其道心。何谓为十。菩萨自念。一切诸魔及众魔天。当见降伏。心不怯弱。当以正法。诸外异道。为我降伏。身当欢悦诸众生界。心不弱劣。具足一切诸度无极。备悉法界。为众生故。积累合集。具功德品。其无上正真道者。为大精进。虽为难办。亦为大业。意菩萨行。不以怯弱。开化一切众生境界。顺使随律。为尊劝诲。十方世界。形貌各异。其被服者。无央数种。菩萨入中。从其所乐。在于其中。成最正觉。又其菩萨。心自发念。吾所曾学。修菩萨行。皆从己出。若来求索手脚耳鼻。肌肉骨髓。妻子男女。象马车乘。国邑城郭。眷属走使。悉能施与。不逆人意。以见众人。来有所求索。发心之顷。恣其所乐。不起患厌。其身欲安一切众生。而怀愍哀。既有所施。无所希望。大哀为首。归无极慈。不以为怯。又其菩萨。遵修其行。诸在三界。诸佛法者。众生佛土。群萌诸世。虚空境界。诸法音声。悉为寂然。归趣灭度。诸法渐渐。一念之顷。了平等应。分别解之。成最正觉悉趣譬喻。劝助神通。修行造证。无念不念。不令别异。无若干行。而节度之。使无财业。无造因缘。不为分异。亦无不分。为无数法。所作不过。以无二慧。晓了诸二。以无想慧。解诸有想。以无念慧。识知诸念。无若干慧。晓了若干。以无限智。晓诸少明。以度世智。明晓世俗一切所行。以世圣光。开化方俗。闇冥诸塞。无过去智。悉能分别诸过去世。归无人地。明识一切众生境界。出诸倚着。游行所作。合集众行。明识一切诸究竟慧。解诸究畅。解诸不畅。以纯淑慧。开解尘劳。而分别知无尽本际。开化诸尽。晓了法界。为第一智。其身普现十方世界。入于无数音声言教。从其无限。而宣训诲。一自然慧。入无自然。一圣明行。伸叙所修。现若干行。一切诸法。悉不可得。解此义者。以致无极。示现变化。示现变化。成最正觉。至于大慧。显大神足。则以普智。感动兴行。化诸群黎。是无怯弱。是为菩萨十无怯弱

菩萨有十事心如大山。何谓为十。于是菩萨。常修精进。专志思惟。诸通敏慧。又其菩萨。观一切法。本净如空。而解诸法悉从颠倒。无央数劫。修菩萨行。兴发其心。丰盛一切清白之法。解知如来无量慧义。以能奉行诸清白法。菩萨兴发诸佛经道。平等清和。顺善亲友。所因发心。不怀疑结。尊敬经典。不当念异。法于余业。唯当恭恪。谦下卑顺。一切所有。施无所吝。渐近道法。菩萨愍哀一切众生。忍诸忧患众苦之恼。假使遭遇危身之患失命之难。骂詈毁辱。刀杖加形。皆能忍之。不怀戚悒。定心不乱。不起嗔恨。怀无极慈。愍念群黎。被大德铠。而不退还。不废道意。益加殷勤。兴无极哀。其哀益广。所以者何。佛子当知。菩萨所行一切诸法。皆因由生。具足护行如来正真。晓了诸法。忍辱仁和。以为豪位。菩萨大士。修大功德。威神巍巍。若在天上。诸天中尊。若在世间。人中位高。面像端政。势力第一。眷属强盛。所欲自由。若为帝主。无极贵姓。功勋无限。智慧广远。不好爱欲。不以财贿。眷属自在。用为安隐。唯爱道法。喜法乐法。慕法求法。以法为室。因法得护。自归于法。因法得度。常求法义。以法为乐。思惟经典。以是比像。而得安居。不随魔教。所以者何。若有菩萨。发意之顷。蠲除众生吾我魔界。使住佛境。又其菩萨。精进如是。无央数劫。修菩萨行。自知如此。吾于今日。逮学无上正真之道。不恐不畏。亦不怀懅。修菩萨行。有斯行已。吾今当成最正觉道。然于来世无央数劫。修菩萨行。自知见之。又睹异学。难化难疗。无反复心。不识报恩。欲教此众。故被德铠。游在众生。而得自在。见凶恶众。不以为厌。不憎恶人尘欲之故而退还也。又其菩萨。不信仰人。发大道意。吾以是行。合集菩萨身独当办。不须他人。于当来劫。奉开士法。以己志行。具诸佛法。兴心存在无上大道。以唯愿乐。开化众生。乐化众生。信菩萨行。自净志性。亦能复净他人性行。解深境界。亦复分别他人土地。去来今佛。合一境土。又其菩萨。不见诸法。亦复不睹诸菩萨行。不观备悉诸开士义。亦复不见教众生义。亦复不察奉诸佛法。亦复不见当逮无上正真道法已成今成方当成者。亦复不见班宣经道不得说者。亦无讲者。菩萨大士。不从大道而退还耶。所以者何。佛子当知。是生菩萨。因求诸法。成最正觉。行一切法。不随倒见。益加精勤。遵习德本。所行清净。具足智慧。一发心顷。功勋名德。日新增益。不恐不畏。亦不怀懅。因疾成无上正真之道。是为十事心如大山

菩萨有十事慧如江海入无上道。何谓为十。入于众生无量境界。又其佛子。菩萨普游十方诸佛境界。以大宫殿。入于圣室。习无思想。又其菩萨。修治无量一切空界。游于虚空而无挂碍。十方寂然。如水如网。以普平等。又其菩萨。善入法界。而游无为。所入无断。不计有常。所入无际。无造无灭。晓了所入靡不周至。又其积众德本。自归过去当来现在诸佛世尊。菩萨法师。声闻缘觉。诸凡夫士。亦于其所。而造德本。复劝众人。以是德本。去来今佛。成正觉时。已成今成方当成者。去来今佛。班宣经道。以说今说。方当说者。彼众生类。诸启受法已成至道。意欲向道。方得道者。教化众生。此诸德本。合斯众善。劝助一切。不求望报。于今现世。不发疲厌。又其菩萨。一一发意。入过去世。游无数劫。于一一劫。见百亿佛。若干无数不可计会不可思议百千亿劫。其所彻睹。不可譬喻。入兴佛世。超过诸喻。亦观诸佛众会道场。为诸菩萨声闻说法。开化众生。寿命短长。所建立者。而无所住。如于一劫所开度人。一切诸劫。不可称限。若于其劫。世无佛时。菩萨知之。于其劫中。应当修立大道德本。无能为劝开道教者。然为讲说。见去来佛纯淑德本。入无量劫。观察其义。而无厌足。入过去劫。又其菩萨。入于当来。思惟观察。游诸当来。无量劫数。于何劫中。当有正觉。何时无佛。当于何劫。佛出于世。如来至真。多少之数。其号云何。出何佛土。其界名号。开化度脱。乐何众生。寿命长短。豫睹无量不可计劫。不以劳倦。又其菩萨。入于现在。观十方界。班宣无际。诸佛国土。分别方面。遐迩分数。诸佛思惟。察其本末。得成无上正真之道。诣佛树下。求取刍草。布地坐树。降魔官属。起入城邑。上于天上。广说经义。而转法轮。教诲众生。现作佛事。成最正觉。释梵劝助。舍其寿命。至于无余。至泥洹界。而取灭度。流布经道。将护教训。兴隆法化。庄严庙寺。供养图像。修法塔庙。念诸佛土。一一发心。入于十方无数佛国。普察众生。皆见诸佛。听所说法。受讽诵学。抱在心怀。选择志行。进退有益。遍于十方。悉归诸佛。不忘佛法。所以者何。达见诸法。悉如梦耳。以是之故。供养如来一切所在。在在所生。常在佛边。自见其身。奉敬如来。不贪己身。不着如来。不怙世界众会道场。亦不希望听闻经典。见在诸佛。不以厌足。游其佛土。见十方佛。亦复如是。无所希望。又其菩萨。无央数劫。供养奉事。诸佛世尊。于一一劫。奉事归命。无限如来。从始现生。皆由三世。供养不废。声闻菩萨。眷属群党。供养如来。乃至灭度。灭度已后。奉敬舍利。至于无极。布施所有。饱满一切众生境界。舍心所与。不可思议。亦不想报。不见受者。而有所取。愍哀之故。故供给耳。奉敬诸佛。施诸群黎。不用懈惓。如是比像。归命诸佛。不可计劫。开化众生。奉持法教。班宣经道。诱进群黎。使发无上。正真道心

复次佛子。当知菩萨菩萨展转相成。戒禁训诲。而奉道行清净之法。开化随律。菩萨平等。从其所生。志慕菩萨诸总持门。常觐诸佛无极大圣。求诸法师。恭敬稽首。咨受讽诵。未尝懈废。摄护众生。所学究竟。为诸群黎。颁宣经道。化无限众。发于无上正真之道。立不退转。净诸佛法。心念普智诸通慧义。修诸佛法。于无数劫。众行备悉。是为菩萨十事如海成最正觉

度世品经卷第二度世品经卷第三

        西晋月氏三藏竺法护译

普智菩萨。复问普贤。菩萨所行所作。如夜显明。何谓其心犹若金刚志大乘铠。何谓大乘。何谓能畅于大勤修。何谓信不可坏。何谓受决。何谓劝德本。何谓入圣。何谓发其心内广大无量。何谓菩萨藏。何谓将护。何谓自在。何谓感动。何谓众变。何谓严净国土。何谓经法随时。何谓身变。何谓愿变。何谓化变。何谓慧变化。何谓神通变动。何谓神足变动。何谓诸力变动。何谓娱乐。何谓境界。何谓十力。何谓无畏。何谓诸佛不共法者。何谓为业。何谓菩萨身

普贤答曰。善哉善哉。快问此事。开化一切。为将来施。今所问者。如日宫殿照于天下。如夜月出。如入大海采诸明珠。如医合药。如饥求食。如渴欲饮。诸来会者。谛听谛听。咸言受教。普贤告曰。菩萨有十事如夜显明。何谓为十。其意普周无数佛界心犹虚空。见诸如来。稽首归命。菩萨尔时。其所游步。亦如初夜。当成正觉。又其菩萨。从无量佛。得闻经典。受持讽诵专心思惟。所解旷然。转更增加。其意普遍十方无际。又其菩萨。于此佛土。未曾终没。生于他方。而现其身。常识佛法。未曾忽忘。又其菩萨以一法行。解一切法。渐为众人。班宣经道。以一切义。入于一义。又其菩萨。除众尘劳。亦复能解。灭众爱欲。亦复能知欲盛欲除。所作坚固。修菩萨行。不于本际而造邪证。诸度无极。为最第一。在于本际。晓了谛学善权方便。具足本愿。所行究竟。身不疲劳。又其菩萨。心入诸想。无处非处而复讲说处非处事。亦无所作。其所行者。亦无所念。开化众生。又其菩萨。以一自然。解一切法。无有自然。亦无若干。亦复不少。不称不量。无色无相。尚不得一。何况多乎。菩萨晓了此诸佛法。菩萨缘觉法。声闻法。凡夫法。善恶法。为世法。度世法。罪法无罪法。有漏无漏。有为无为。又其菩萨。又诸佛世尊。得道不得道。无法众生。不废所愿。开化众生。晓了诸法。所以者何。悉知他人黎庶心。念所作因缘。亦复明识。教授训诲。使诸人民。悉至灭度。所愿具足。又其菩萨。晓了能睹众生心念。解所归趣。善权方便。随时而现。说法示律。不离真正。不从颠倒。菩萨晓知。诸法悉住。等于三世。本无不动。立在本际。不见众生。所可开化。无化不化。不从律教。亦无行者。分别归趣。法不可得。生者灭者。其所誓愿。终不虚妄。于一切法。永无所著。又其菩萨。见无央数诸佛世尊。一一如来。所说经典。闻辄受持。所行若干。其名各异。所念不同。于彼诸劫。一一分别。诸劫本末。至无数劫。闻悉识念。而不忽忘。亦不迷谬。诸如来等。不可思议。闻悉受持。而无有二。己身所行。力愿超异。开化众生。令悉具成无上正真最正觉道。得成所愿。晓了法界。是名曰十菩萨遵修游行如夜显明

菩萨有十事心如金刚志大乘铠。何谓为十。不住于此。亦无边际。菩萨发心。解一切法。于三世事。靡不通达。是为心如金刚被大德铠。不可称计一一毛孔。普能庄严。况复众生一切法界菩萨德铠。口自发言。吾当灭度。一切众生。至于无上正真之道。又佛世界。无底无边。不可称限。诸菩萨等。发如此愿。吾当净治无上正真。于诸佛界。以是之故。净诸佛土。又诸众生。无底无际。无齐无限。若有菩萨。劝诸德本。广大如斯。照诸众生无上大乘。诸佛世尊。无有齐限。诸菩萨等。所殖德本。亦复如是。劝施众生。常见诸佛。而复能逮无上正真之道。为最正觉。若有菩萨。见诸佛闻说经心欢悦。不倚吾我。不着如来。不近如来身亦复不远。不有不无。不计所有。亦无所有。不计有身。无色相种好。解如来体。亦不令起。亦不无起。不相非不相。不有处所。亦不无处。不起如来身。亦无所坏。以如来身。入无所有。于所行而无所行。所以者何。皆受一切自然之数。又诸菩萨。常加愍哀。众生之类。斫头断其手脚。割其耳鼻。挑其两眼。骂詈毁辱。瓦石打掷。叉蹋棕搣。唾溅调戏。皆能忍之。不起嗔恚。亦不怀恨。颜色不变。无央数劫。修菩萨行。未曾发心。违舍一切。又如菩萨。于一切法。学无二事。以学于此。无余嗔恨。勤护群黎。忍一切苦众恼之患。身遭毒痛。悉亦忍之。当来诸物。无有边际。亦无蔽碍。住于信乐。以如是比。发菩萨意。当来至今究竟法界。住虚空界。皆于一一诸佛世界。行菩萨道。开化众生。如一世界所可造行。十方佛土。亦复如是。度于法界。尽虚空界。空无所有。不恐不畏。亦不怀懅。发于三世。造行如此。所以者何。菩萨大士。所可游居。用一切故。奉菩萨行。依菩萨心。信于无上正真之道。志性清净。积众德本。具足誓愿。而于佛道。而得自在。亦得由己。从其所愿。欲成正觉。辄如意得。所行无量。而得究竟。断除一切五阴诸受。悉尽无余。其所行处。依于诸佛。不成正觉。所以者何。具足所愿。备菩萨行。开化众生。护诸佛土。又其菩萨。不得诸佛。不得道处。亦复不得诸菩萨处及一切众生处所。亦复不得心意诸行。亦复不得于去来今一切众生有为无为。菩萨所行。澹泊如是。深妙巍巍。寂定闲静。悉无所得。其行无二。无所诤讼。自然若兹。清净解脱。灭度若此。修如本际。心实无虚。所立誓愿。而不懈废。一切智心。诸菩萨行。开化众生。诸度无极。训民随律。奉敬诸佛。说法讲义。庄严世界。于是精进。无曾懈惓。所以者何。大愿所致。如是比类。知一切法。如是法相。长无极哀。功勋无量。晓了慧义。愍哀众生。常解一切诸法号字。如此愚痴凡夫。不晓了是。不能解知诸法自然。吾当开悟使达知之。所以者何。一切众生。无寂然行。由是诸佛。为说经典。开化众生。兴无极哀。不舍大慈。吾等何故。厌大哀乎。而舍众生。设不得佛。不备经典。不成大愿。施于众生。无上法施。本初发心。净诸群黎。立真诚誓。设不能学大愿正要发心道门。则为欺诈一切诸佛。为一切故。而发道心。植众德本。而劝助之。入深奥慧。普得周遍。众生形处。而等其心。以是之故。具足大愿。是为十事心如金刚被大乘铠菩萨住此疾。成如来无极神通。强如金刚

菩萨大勤。有十事。何谓为十。吾当奉敬诸佛。供养自归。积累合集。修诸菩萨众德之本。为诸如来。般泥洹后。庄严神寺。供养众华。名香捣香。杂香涂香。衣服幢盖。执持正法。将护训诲。开化一切诸众生界。劝发无上正真之道。不违雅律。严净一切诸佛国土。安无上界。又复菩萨。心自念言。诸当来劫。一一世界。中有一人未得度者及一切人。故无所遗忘。为斯等故。修菩萨行。亦复如是。兴大悲哀。立诸众生。于佛正道。历若干难。未曾须臾发疲懈心。常修佛法。是诸佛世尊。无央数劫来现。其人一一供养如来。如供一佛。奉诸如来。等无殊特。是诸如来灭度之后。无央数劫。供养舍利。一切宝盖。诸铃幢幡。为一一佛。无数国土。兴诸大庙。图画形像。所可立像。周遍无量无思议国。夙夜精勤。念顷不废。为佛法藏。奉诸佛已。开化众生。奉宣法教。修正法已。渐近大道。以是德本。得成无上正真之道。为最正觉。遵一平等一切如来。归诸佛土。成正觉已。无央数劫。班宣经道。遍诸佛界。诸佛变化。显示神足不可思议。不以懈惓。其身口心。亦不计劳。发其心时。正向法门随时奉佛。修大志愿。诱化众生。大慈为首。归于大哀。礼无相法。住诚信教。具足诸法。以为造证。一切无逆。所作事业。无所诤讼。去来今佛。入于一义。趣于法界。与空通同。越无相法。无成不成。使至究竟。未曾患厌诸佛之法。致无极愿。作佛本事。诱劝群黎。是为菩萨十事于大殷勤。菩萨住此。成于如来无上大慧

菩萨有十事能畅大精进。何谓为十。奉敬一切如来至真。而自归命。请诸群黎。随时将护。求护佛法。务大殷勤。积众德本不以劳倦。兴隆圣典。普使流布。具足一切无极道愿。殷勤志慕诸菩萨行。常遇善友。而从启受。普诣十方。见诸如来。听所说经。入佛道场。是为十事畅大精进

菩萨有十事信不可坏。何谓为十。信十方佛无有异心。喜诸佛法未曾违舍。爱乐圣众不生异心。好喜菩萨不怀疑结。与诸善友常同俱合。愍念众生不舍群黎。一切奉行诸菩萨愿。奉行开士众行备足。奉敬诸佛稽首归命。开化众生皆度脱之。修于菩萨善权方便不毁笃信。是为十事菩萨信不坏

菩萨有十事受决。何谓为十。好喜笃信行。受己性行决。修习道心。怀来德本。其行广远。受方等决。目前受决。或密受决。心得自在。至平等觉决逮得法忍。然后受决。开化众生。本末受决。皆除一切妄想永尽。能显示现一切菩萨所行功勋。尔乃受决。是为菩萨十事受决

菩萨有十事劝助德本。何谓为十。以此德本。同一志愿。其所生处。与善友俱。常使如是。莫令变异。以此德本。与诸善友。所生同心。莫令别异。所生之处。具足等愿。与善师俱。以是善本。所生之处。与诸菩萨。道合志同。因斯福行。世世所在。明智者俱。所在之处。专惟一心。不离圣达。所在游居。常等清净。智者同心。世世所生。与诸善友。德行合附。于将来世。入一平等。与明师会。以此德原。与善师俱。兴义无坏。是为十事劝助德本

菩萨入圣心。复有十事。何谓为十。广行布施。得入于慧。好喜一切诸佛道法。游诸如来入于无量中间之义。皆以问慧。决众疑结。晓了义理。能入圣慧。分别一切如来至真口所宣教。笃信佛法。现众所有。其力薄鲜。佛以兴出。德本无量。好喜如来。皆具经典清白之义。具足一切诸菩萨行慧不可议。发心之顷。所入无限诸佛国土。无能蔽碍。解一念慧。明解一切诸佛道事。入众法界。闻佛说法。皆能奉持。入诸如来若干音声。是为十事。菩萨入慧

菩萨有十事发其心时内广无量。何谓为十。发其心时。广其内志。念无量佛。入于众生。发心无限。游群黎刹。入于法界。解知无二。观察诸法。等如虚空。而普瞻于诸菩萨行。思惟三世一切诸佛入不可议罪福报应。观诸佛土。皆悉清净。普入一切诸佛道场。亦皆观察。入诸如来音响文辞。是为十事菩萨普入中间内广无量

菩萨复有十事藏。何谓为十。数一切法修精进藏。解知诸法悉无所生。照明奉持诸佛经要。班宣辩才诸法本末。晓了随时。众义无量。悉不可获。普令目见诸佛神足所兴变化。而以方便。等御诸法。常见诸佛。未曾违远。识别义权不可思议诸幻成想。若见诸佛众菩萨等。欣然大悦。逮致法藏。是为菩萨十事藏也

菩萨将护有十事。何谓为十。终不诽谤诸佛道法。将护其意。信大圣教。未曾变悔。入诸菩萨常怀恭恪。见诸善友。悉和其性。而同其志。不复习念一切声闻缘觉之行。将护菩萨章句履行。未曾退转。慈愍众生。而不怀害。究畅一切众德之本。降伏众魔。却诸外敌。具足一切。诸度无极。是为十事菩萨将护

菩萨自在有十事命得自在。何谓为十。计其所寿。无央数劫。而无穷极。其心自游所兴定意。入于圣慧。不可计会。其业自在。游诸佛界。所严无量。欲显建立道场之义。其业自恣。示现随时。世间报应。所生自游。现于十方诸佛世界。意乐自在。普见一切诸佛世界。睹诸如来。所愿自恣。所欲自在。于何佛土。成最正觉。神足自游。皆能示现。威神变化。于法自纵。普能兴显。示无央数。诸内法门。于慧自在。如来十力。四无所畏。而数普现诸佛道场。是为十事菩萨自在。菩萨住此悉能具足诸度无极

菩萨感动有十事。何谓为十。众生变化随罪福往。严治国土各各不同。经法变异随时教化。其身所在在所显现。所愿自在造立道义所行自游所入普遍。造业圣慧以示一切神通变化靡不度脱。神足变化无所不感。修习威势至十种力。是为菩萨十事变化菩萨变化众生有十事。何谓为十。演说众生。悉无所有。一切群黎。因想而立。为诸群萌。随时说法。化众黎庶。令弃自大。一切人界。护一履迹。使得安隐。无有娆害。普能示现一切世界。建立众生。诸众生界。显现释梵。及四天王。游于黎庶。随时现身。声闻缘觉。形像色貌。亦复现形。显菩萨行。解诸众生。境界所在。靡不周达。觉成普知一切道力。色身相好。若干庄严。是为菩萨变化众生

菩萨有十事国土严净。何谓为十。一切佛土。为一佛土。造立建业。使诸佛国。入一毛孔。一切佛界。所入无尽。一切佛境。开通一义。显己一行。自见己身。普入佛土。一切佛国。众生之类。无能动者。亦不恐怖。又诸佛土。一切庄严。现一佛国。一国严净。遍诸佛土。一切佛国。则一如来。众会道场。一如来身。遍诸众生。使诸众生。入于微妙。无极巍巍。广普深奥倾邪。平正等他。等御方面。罗网报应。悉遍无余。皆能示现。是为十事也

菩萨有十事经法随时。何谓为十。御一切法。使入一法。则以一法。化一切法。化众生性。使不诤讼。一切诸法。皆令顺入般若波罗蜜。教度彼岸。一切诸法。入于众生。舍诸法想。使一切法。入于一义。演无数劫不可尽教。以一切法。入无央数百千法门。见众生心。悉说本末。又一切法。普门轮字。晓了随时。一切诸法。入一法门。无所诤讼。宣无数劫义不可尽。一切诸法。入诸佛道。以化众生。一切佛法。现无央数。诸内正教。一切诸法。悉入本际。无量网内。现无数劫。众生尽耗。是为十事随时也菩萨有十事其身变化。何谓为十。建立众生入于己身而得解脱。亦以己身想众生身而建立之。一切佛身入一佛身。以一佛身入诸佛身而示现之。一切佛土建立己身。而为众生示现变化。普取三世遍一法身。一身定意而修正受。现若干身。则以一身。解正觉道。现无央数诸菩萨身。以众生身合为一身。以一人身普现众身。以众生身显入法身。亦以法身现众生身。是为十事其身变化

菩萨有十事变立所愿。何谓为十。取诸菩萨愿。立己所誓。诸佛正觉。己愿道力。显诸菩萨。随众生根。纯淑所在。使成无上正真之道。为最正觉。除无际劫。意所贪愿。出于识身。建立慧身。自在所愿。而现诸身。而去己形。具足显示彼具足身。开化众生。劝进诸愿。以菩萨身。遍一切念。诸行劫数。而不断绝。履一力迹。成最正觉。因所力愿。周遍一切无数佛土。皆现其身。于一切形。演一法句。普周无余一切法界。兴大法云。雨甘露味。照以慧解。畅真谛法。以为雷震。饱满众生。成无极愿。法乐具足。是为菩萨变立所愿

菩萨化变。复有十事。何谓为十。遵修法界。则以示现。在众生界。乐行佛事。而复普现。在诸魔部。菩萨行无为界。而拔出生死行。行一切智。不舍菩萨之所游业。又存寂寞。澹泊之业。示在众生。匆匆勤学。不俱为乱。无进无怠。无双无只。无言无想。无所有无所启。行如空等。菩萨如是。而复皆现。在于众生诸想颠倒。发诸所行。不与同尘。净修力行。亦悉示现。诸所行处。晓知众事。了本无人。现在众生。而开化之。修禅脱门神通三达之智。现在十方诸佛土生。成如来行。备佛严净。现诸声闻缘觉之乘。威仪礼节无念之行。是为菩萨十事化变

菩萨有十事以慧变化。何谓为十。辩才无尽。班宣道慧。逮诸总持。演无量明。辩才善解。多所讲说。摄众生根。圣慧变化。而度脱之。以无为心。睹他人意。则以一心。知众生志。心念所行。晓众生界。志性结缚。诸尘劳疾。应病与药。令得瘳除。明解一时。普能周达如来十力。能入众生三世之行。有劫数无劫数。悉而显示。而开化之。其心闲静。永无蔽碍。成最正觉。遍度黎庶。以一人慧。而得自在。观察众生。知所造业。善恶祸福。以一种声。遍畅一切群黎音响。是为十事也

菩萨神通变有十事。何谓为十。则以一身。遍现一切诸佛国土。一如来会。皆能同畅。宣讲菩萨诸佛道场。以一心行。开化一切诸修道行。以一音声。普告十方诸佛世界。众生心念。令得其所。以一定心。皆见群黎无央数劫前世所行善恶祸福。而度脱之。则以神通。庄严一切诸佛国土。亦以神通。皆见三世。等无差特。而知一切诸佛菩萨所建立行。演法光明而照耀之。亦以神通。见知一切诸天龙神。犍沓和。阿须轮。迦留罗。甄陀罗。摩休勒。释梵四天王。声闻缘觉。诸菩萨行。如来十力。菩萨德本。无所不护。菩萨平等。寂诸音响。则以平夷。等御众生。是为菩萨十神通变

菩萨神足变化有十事。何谓为十。无数世界入于一尘。是神足变。复以一尘遍诸法界。现一佛土。使诸海水入一毛孔。旷诸法界入众佛土。令诸众生无所娆害。无量世界入于己身。以神通慧普现所为。不可思议诸铁围山及大铁围。入一毛孔。游诸佛土。令诸群生不怀恐怖。以无数劫。示为一劫。或现一日。或以一劫现无数劫。进退合成。显化众生无所娆损。现诸世界。为外所灾。或复遭值水火灾变。欲使众生察知非常。神足所现而无娆害。一切世界。水火风空。所合灾变。化为一切财产诸业。宫殿屋宅具足充满。则以神足。现化众生不可思议诸佛刹土。举着右掌移着无量诸佛世界。无所损耗。现诸佛土。自然虚空。以诲众生。是为菩萨十神足变

菩萨诸力变动。亦有十事。何谓为十。力感众生。而开化之。未曾违废。悉感诸国。以无央数庄严众事。而示现之。法力变化。一切诸身。入于无身。所化势力。劫数不断。佛力所变。悟诸睡寐。行力所感。摄取一切诸菩萨行。如来力教。则能救济众生境界。自在力教。一切诸法。达之自然。成最正觉一切智力。则以无余诸通圣慧。逮平等道。大哀力变。不舍众生。是为菩萨十力变也。兴化众生。菩萨若逮此十力变。则无挂碍。速成无上正真之道。为最正觉。发意之顷。以得佛道。不断所行。所以者何。宣大誓愿。菩萨则成无量法门。普现德本

菩萨娱乐。有十事法。何谓为十。于斯菩萨。以众生身。建立国体。分别黎庶形之所趣。是第一乐。又复菩萨。以土身像。建立众生。不令国身而有损耗。是第二乐。又其菩萨。随时变现佛正觉身。现诸声闻身缘觉之身。非常示现如来之业。是第三乐。又其菩萨。示现声闻缘觉佛身。巍巍微妙。不着三品法训。是第四乐。又其菩萨。示现行身。最正觉身。不着身行。亦无所断。是第五乐也。又其菩萨。现正觉道身之所行。不猗正觉。是第六乐也。又其菩萨。现泥洹界。猗于生死。不着泥洹。是第七乐又其菩萨。现习生死。又现取灭度。不于泥洹而永灭度。是第八乐。又其菩萨。以常永定。普示众行。往反周旋。住立经行。不舍三昧。是第九乐。又其菩萨。从一如来。闻说正法。不见没身。护三昧定。如来道场无央数事各各分别。恕当诸身。其所住处。身无所坏。不乱三昧。从诸如来。听所说法。这闻法已。则受奉行。三昧正受。不断启觐经典之要。与如来俱。不见灭身。一一三昧。御诸行门。入无数定。以是比像。皆尽坏劫。菩萨三昧。未曾穷极定意身门。是为第十娱乐。菩萨住此。逮成如来无上慧乐

菩萨境界有十事。何谓为十。为诸众生。而以显示。入无量门。一切世界。有无央数。若干庄严。开导黎庶。以众生界。御不自大。说诲所部。如来至真。入菩萨身。以菩萨身。入如来身。以虚空界。导诸佛土。以诸佛土。导虚空界。以生死本。现泥洹原。以泥洹原。现生死本。以一人音。宣诸佛法。各入境界。以无量门。显于一身。则以一身。建无数身。复以一身。遍诸法界。众生发心。而以一智。御无量门。成最正觉。是为十事。菩萨住此。入于如来无上大慧

菩萨有十力。何谓为十。奉志性力不与诸世而俱同尘。修清和力不着佛法。应时之力普现菩萨方便处所。以圣慧力知诸群黎心念所行。所誓愿力皆能备通具足本愿所行之力。不断本际所修乘力。显一切乘不舍大乘。诸变化力一切佛兴净十方界一一显示所护履迹。道义之力发众生心不离正觉。转法轮力宣显一法。音无余不余皆令无余。将御一切众生根心。是为十力。菩萨住此。逮成无上普智十力

菩萨无畏有十事。何谓为十。皆受一切得持诸音。何况菩萨。不作是念。吾于东方南西北方。来至于斯。咨问百千无极要集。傥不堪任受答是大法。菩萨悉知。不见不及。以大无畏。所度无极一切众生。诸来难问。恣意听之。所欲启问。勇猛意说。而无懈废。是一无畏。于诸文字。所演音辞。次第如流。承如来威。无碍辩才。所度无极。其菩萨不作是念。东西南北。傥来难问。不任发遣。未曾有是。不见不及。勇猛无畏。一切众生。恣意难问。勇猛自在。衣毛不竖。是二无畏。独游空法。菩萨未曾心怀疑网。计于吾我所作所更。计寿命人。以离五阴诸入邪见六十二疑。其心普平。等如虚空。故无此念。将无见试娆身口意。菩萨无此不及之见。所以者何。斯诸正士。离吾我人。不现诸想。游步大勇坚固方便。是三无畏。又其菩萨。佛所建立。住于佛力。而处如来。威仪礼节。亦无妄想。不作是念。众人将无求吾长短。威仪不备。未曾有此。不见不及。而猛勇步。处于大众。班宣经道是四无畏。身口意净。又其菩萨。岂当复念蠲除恶行。修学清净。仁和义乎。亦无此念。傥有求吾身口意缺。以大勇猛。为诸众生。讲说经道。是五无畏。以得大护。其金刚神。常执金刚。在菩萨后。天龙鬼神。及阿须轮。所见归命。释梵四王。咸共奉事。诸佛所念。故无此意。畏于诸魔及诸魔天。诸外异学。迷惑众邪。无能娆乱永不见人。当菩萨者。以大勇猛。所度无极。劝意生焉。皆能具足诸菩萨业。是六无畏。又其菩萨。得佛慧念。未曾忽忘。诸根常定。为众说法。敷演圣句。识佛道义。其所宣法。如佛口出。无中蔽碍。无能障翳。不能发意。见其短者。奉如来教。是七无畏。菩萨明解。智慧善权。力度无极。进退独步。训诲众生。无能拘制。以佛道愿。无极圣性。发无盖哀。愍于群黎。假使生在凶暴尘劳。秽浊世界。摄取大欲。所可娱乐。眷属大业。教授众生。不兴此念。将无众人。毁谤清白。佛道净行断绝定意。脱门正受。总持辩才。不见有是。所以者何。菩萨大士。于一切法。而得自在。无能制止。所修道行。其于十方。无能犯者。遵大勇猛。处诸佛土。弃捐众恶。而摄正愿。是八无畏。菩萨不舍一切智心。善住道义。钦乐大乘。以诸通慧所建之力。为诸声闻及缘觉乘。现不可及威仪礼节。不兴此念。将无误堕声闻缘觉。以大勇猛现一切乘。所度无极。唯乐大乘。所行具足。是九无畏。菩萨善集诸清白法。合众德本。普备神通。所觉不废。以佛道度。周菩萨行。而究一切诸佛普智。以化众生。不失正行。不坏章句。心不念言。众生将无诸根纯淑。吾明不及。现佛境界。未有此应。以大勇猛。观众生根。为显佛地。虽化众生。菩萨所行。无极大愿。无有缺漏。是十无畏。菩萨住此。悉逮如来四无所畏

菩萨有十事诸佛法不共。何谓为十。菩萨精勤。无所从生。度于彼岸。除悭喜施。戒禁清净。不犯众恶。成具忍辱。去众怀恨。修大精进。所修正业。未曾退还。禅定坚固。弃众乱意。从智慧生。远恶邪见。终无有言。何谓无所从生。常勤奉行六度无极。是为菩萨第一无言。菩萨之法。晓度彼岸。摄护众生境界。施以俗施。及宣法施。颜色和悦。所说可度。言辞清和。众人闻之。心莫不悦。义理应时。明识佛道。心无偏党。等念群黎。菩萨所修。无所从生。以无言辞。救济群萌。所修境界。是为菩萨第二法施。菩萨所修。晓了劝助。不望想报。导入佛道。不乐世俗。所修定行。不舍如来至真圣慧用众生故。而劝助之。无所说者。则是菩萨。无有言辞。修诸德本。求慕佛慧。为众生施。是三无言。菩萨之业。有权方便。第一之行随众生乐。而不秽厌世俗俱游。在诸不贤自恣行门。一切声闻缘觉所生。一切黎庶。皆开化之。不求安己。禅定三昧。脱门正受。晓了进退。逮自在定。以不懈惓。察于生死。犹如大游观。毁魔宫殿。普现释梵四天处所所生之处。常有明曜。见诸异学。而悉达知一切世俗。经书典籍。文辞之赞计校算术。己身六事。王者典籍。雕文刻镂。所假印绶。工言巧辞。娱乐音声。樗蒱六博。敢可天下。目所睹者。亦复晓了。女人进止。男子举动。豫说瑞应。天文地理。日月星辰。所现灾变。度世之法。声闻缘觉。来问事者。无不明了。诸度世事。独步无侣一切天下。咸共瞻仰。显诸声闻缘觉之乘。所不能逮。威仪礼节。不舍大乘。发意之顷。知诸如来所示现行。不断经典。菩萨所遵。善权方便。亦复无断。奉修寂然菩萨德本。以慧娱乐。犹得自在。在于无为。现生死门。至无人际。教化众生。未曾违废。处永澹泊。在于众生。现大尘劳。则以一品。法慧之身。现于众生无数之身。无限之门。犹如虚空。以大智慧。乐一切欲。因化众生。乐一品乐。现于三界。开化众生。不离妄想。在诸玉女百千人中。常以法乐。而自娱乐。以妙相好。百千众德。而自庄严。所生之处。常无罪殃。修清净行。现生地狱饿鬼畜生。于佛道慧。所度无极。而不动舍。菩萨慧身。其慧如是。无有边际。以是比故。悉解声闻缘觉。何况愚冥凡夫。是五无言。身口意行。以慧为首。菩萨所修。行业甚净。具足慈心。愍念众生。离于杀生盗窃淫劮。妄言两舌。恶口绮语。嫉妒恚痴。邪见之事。修正行见。悉亦无言。菩萨所行。身口意业。慧傥随时。是为第六不舍众生。乃为菩萨奉无盖哀。睹众生恼。身阴遭患。口自更历。兴显德本。在于地狱饿鬼畜生。为众生故。而被毒痛。不用懈厌。化众生界。令怀欣然。于一切欲。所娱乐业。不以经心。常加精进。欲度众生。毒苦诸痛。亦不以诸菩萨所习。唯志大哀。遵习道力。是为第七一切黎庶奉敬悦乐。乃为菩萨释梵四王皆共念之。一切人民。睹悉欣喜。群萌思德。不离心怀。所以者何。其菩萨者。往昔宿命。奉清净行。无有罪业。是故众人。其来见者。不知饱满。亦以无言。是为第八其心坚固在诸通慧善被德铠。乃为菩萨。所由甚难。勤力习行。入诸声闻缘觉之中。一切智心。宝净明耀。无所忘失犹大明珠。名净复净。清诸浊水。正使浴池。极秽瑕疵。以净明珠。这着其中。浊水则清。不复同合。菩萨如是。正使与愚騃俱。痴冥人共周旋。未曾违失一切智心宝净明耀。无极智慧。蠲除众生邪见尘劳秽浊爱欲。住一切智宝净明心。亦以无言。虽在恶人声闻缘觉。不废大道。是为第九己部界慧在法势尊度于彼岸。乃为菩萨慧得自在。具足无余。为阿惟颜。以被离垢。着法冠帻。带道印绶。不离善友之所教训。奉敬如来。未曾轻慢。亦以无言。菩萨师者。修未曾有。开化众生。不舍圣师。常顺如来。谦恭自归。是为第十无言之教。菩萨住此。逮成世尊无上无言

菩萨有十业。何谓为十。普净世界。庄严佛地。兴立一切诸佛道业。以诸菩萨伴侣为首。同共德本。开导教诲众生境界。诸当来业。摄末至本。则以神足。遍至十方诸佛境界。虽遍十方。不移本土。以光明业。演无量曜。一一光明。有诸莲华。现诸菩萨。各坐其上。不断三宝。佛灭度后。奉宣训诲。无自大业。游十方界。开化众生。以为说法。使随律教。修八道业。心在邪业。则为彼等。示现诸愿。普使备足。是为十业。菩萨住此。逮成如来无上道业

菩萨身有十事。何谓为十。菩萨当来。解一切身。悉无所成。亦无所有。菩萨身来。知众人民。身不可得。菩萨身者。无有真谛。随其习俗。示有所在。菩萨身者。无有能侵。随其世俗。显示真谛。菩萨身者。亦不可尽。于当世际。无所断除。其身坚固。一切诸魔。无能毁坏。其身强要。一切邪学。众外异术无能动者。其身无相。而复示现。诸相清净。百福功德。其身无好。因以法相。而为众好。稽首为礼。其菩萨身。普无不入。诸去来今如来至真。同合一身。是为十身。菩萨住此。逮成如来不可尽业无极法身。说是语时。三千世界。为大震动。其大光明。遍照十方。天雨众华。箜篌乐器。不鼓自鸣。诸来会者。各自欣庆幸值供业无极道明欲值此法。当何所行。菩萨报曰。奉敬诸法。一心听经。供养圣众。谦尊法师。视之如佛。慈愍众生。如己骨髓。处在三界。如水莲华。如日明耀。如月照冥。如是行者。疾得正法。说此语时。无央数人。皆发道意

度世品经卷第三度世品经卷第四

        西晋月氏三藏竺法护译

普智菩萨。复问普贤。何谓身业。何谓为体。何谓言辞。何谓口净。何谓善清净。何谓所护而善摄。何谓菩萨所修章训常劝乐众生界。何谓菩萨等心。何谓发意。何谓心遍。何谓诸根。何谓志性。何谓性和。何谓应时。何谓应信。何谓信入世界。何谓信入众生界。何谓居止。何谓兴发。何谓奉行。何谓成就。何谓失佛道法。何谓寂然。何谓究竟法。何谓生佛法。何谓正士。何谓为路。何谓路无量。何谓道业。何谓行道。何谓进道。何谓为行。何谓为手。何谓为腹。何谓为藏。何谓为心业。何谓德铠。何谓为杖。何谓为头。何谓为眼。何谓为耳。何谓为鼻。何谓为舌。何谓为躯。何谓喜行。何谓行步。何谓为处。何谓为坐。何谓卧寐。何谓为室。何谓为游居

普贤菩萨报曰。善哉问也。谛听谛受。报曰唯然。普贤曰。菩萨身业有十事。何谓为十。能以一身。普遍佛界。故曰身业。示现一切众生界门。与诸所生。而俱宿止。而独游步十方世界。亦皆往至诸佛道场会说法处。能以一手。覆盖一切三千世界。一掌捉持诸大铁围。金刚众山。显示众生。一切佛土。合在身中。复令散没。以众生界。受在一身。匿覆独处。又复示现一切众生。觉在己身。以用成就。严净佛土。是为十身业。菩萨住此。由是得致无上佛业。训诲群黎悉得至道

菩萨体有十事。何谓为十。体能奉修。六度无极。能行四恩。不舍众生。修无盖哀。代诸群萌。身自受之。五阴苦担。不以劳惓。无极慈身。普护一切。而令得济。以功德形。使诸人民。皆得戴仰。而逮安脱。以圣慧事。一切诸佛。同合体故。以得成就。弃捐一切诸凶危法。是谓法身善权方便。一切现门神足变化。皆能显示。所为感动。菩萨体者。于道自在。便成正觉。是为十体。菩萨住此。便能得入如来至真无上大慧

菩萨言辞。有十事。何谓为十。言辞而谛。则以此教。安隐众生。以清和语。悦可一切。人民意念。以不妄语。所说如言。演至诚辞。菩萨如是。假在梦中。无有异言。所说随顺。不欺释梵及四天王。深妙无害。能为显示。自然之教所说坚固。班宣诸法。无有边际。所演发路。从一切言。而开化之。随人所作。说其报应。示其本末。观众生意。随其所应而教诲之。是为菩萨畅十言辞

菩萨有十事。为善清净。何谓为十。好喜欲闻如来音声。是则为净。思省菩萨曾所听音。去于众生所不喜听。弃捐恶语。不施于人。本昔所说。四事口过。常远离之。本欢悦心。咨嗟如来磬扬大音。在佛神寺。歌叹佛德。以清和性。为诸众生。宣传法施。在尊神寺。作诸妓乐琴筝吹笛。乐佛塔庙。亲自面从。诸佛世尊。听闻经典。顺在天福。从诸菩萨。若因法师。得闻经典。身自奉事。心舍天上。是为十事菩萨演教为善清净

菩萨有十事所护善摄。何谓为十。诸天王现。悉共护之。龙王鬼神王。皆出宿卫。揵沓和。阿须轮。咸来奉敬。迦留罗。金翅鸟王。佥来安之。甄陀罗。摩睺勒。悉归仰之。又天帝释。侍从诸天。俱来护之。其梵天王。将诸梵天。在边自归。诸菩萨等。皆共敬念。诸不退转。一生补处。佥来亲之。诸如来等。现在十方。威神护之。是为菩萨十事拥护善摄

菩萨有十事所修章训。何谓为十。而常劝乐众生之界。亦复教化三千大千诸佛国土。又悉能入一切诸根。通利中间及弱劣者。随其境土。而严净之。消除一切爱欲尘劳。远离诸秽。弃捐境界。而悉睹见志性所在。渐稍长益。清和之性。而悉普达。遍诸法界。因是之故。速近无为。是为十事

菩萨等心。有十事。何谓为十。等心总持。执诸众生。摄众德本。令不遗漏。心如江海。不可限量。顺诸佛法。无极道慧。心如须弥。其德超踰。建立众生。一切善本。心如明珠。去诸垢秽。意念清净。心如金刚。毁坏一切诸瑕疵法。其心坚固。如铁围山。不可破坏。一切众魔。诸外异学。无能动者。其菩萨心。犹如莲华。游于三界。永无所著。其菩萨心。如灵瑞华。于无数劫难可见闻。心如日明。游行虚空。消灭一切闇蔽挂碍愚痴之冥。其心如空。愍伤一切群萌之类。是为菩萨十心

菩萨发意。复有十事。何谓为十。发意念言。吾当悦豫一切群萌。皆当消除诸众生等尘劳爱欲。永使无余。自兴念言。断截诸蔽挂碍之难。悉于诸法。不以犹豫。得至寂然。吾当澹泊一切众生勤苦五阴。当断消灭恶趣八难。常当普见一切如来。不离其边。常当精进学菩萨戒。成诸佛道。普见众生。成就一切。使入道迹。以故发意。当知无极法鼓普。遍十方诸佛国土。总摄人民。志性诸根。使无有余。是为十事菩萨发意

菩萨意遍。复有十事。何谓为十。其意普遍。旷若虚空。入于无量一切法界。一时之间皆遍三世。诸佛所兴。辄能具足。入胎出生。弃国捐王。成最正觉。现大灭度。悉由圣慧。入众生界。志其意性。觉知诸根。以圣光明。遍至一切诸法境土。周无边际。诸幻罗网。无所从生。至于自然。无有颠倒。不可计会。己心无碍。使他无蔽。光明智慧。而得自在。诸佛兴时。所在发意。现最正觉。是为菩萨十事意遍

菩萨诸根有十事。何谓为十。诸菩萨等。若见诸佛。诸根欢悦。欣然不还。好乐诸佛。奉敬经典。靡所不达。菩萨不回一切诸根。无所障塞。心常坚住。其所修行。莫能废者。诸根微妙。晓了分别。智度无极。诸菩萨意。无有进退。劝诲众生。志如金刚。消化诸法。破坏众恶。其明坚强。靡所不照。见诸如来。光耀所在。诸根无怪。开士之心。了如来身。合为一体。其菩萨意。至无限际。入于如来十种之力。是为菩萨十事诸根

菩萨志性有十事。何谓为十。有菩萨心。常无所著。不贪世俗。其心清彻。而不杂碎。不思声闻缘觉之事。又计菩萨志性柔顺。恒志佛道。其意清和。因一切智。而出生矣。有所念者。无有俦匹。消伏众魔诸外异学。志无瑕疵。严净一切如来慧场。恒善救摄。其意本末。如所闻法。未曾忽忘。其意自然。而无所倚着。所生之处。无所适莫。其志深妙。普能得入微妙之慧。念已信解。解诸佛法。是为菩萨十事性也

菩萨性和有十事。何谓为十。菩萨性和。意在尊豪。而不退转。积累一切众德善法。不疑诸佛。咨嗟如来本末性行。处于总摄。为大师行。闻所愿俱。念在顶相。普能周入。于诸佛法。性自然净。于诸佛法。而得由己。其意微妙。能入若干诸法道门。菩萨元首。超越一切。所在因缘。于道自恣。于诸三昧定意正受。严净变化。其意坚住。摄取前世之所誓愿。教化众生未曾休息。是为菩萨十性净和

菩萨应时有十事。何谓为十。菩萨布施。则为应时。施诸所有。无所希望。一切奉戒。其禁德限。闲净精修。奉行应时。不蔑他人。为众生故。忍诸嗔恚。患厌怀恨。除去吾我及他人想。普修精进。随时无转。将护身口。心无所忘。废众事业。禅定三昧。遵诸解门。神通之正。不舍爱欲尘劳眷属。若能奉行诸度无极。积累众德。未曾懈废。修行大慈。解无众生。身负众苦。五品应身。不舍大哀。解知诸法。自然寂静。如来十力。觉了随时。以无限宜。显示黎庶。而转法轮。未曾怀还。见他志性。而教诲之。是为菩萨十事应时。菩萨住此。逮佛无上无极大慧。便能随时

菩萨信解。复有十事。何谓为十。信于微妙。而常随宜。难及德本。笃无央数若干净行。其好广普。见于众生。无央数心。造信寂然。入于深奥无极法门。乐于清净。兴广远心。爱敬所望。诸佛建立。十种力故。谦恭无双。降伏众魔。及与官属。究竟好业。等于报应。笃于近门。随其所喜。而示现之。受于所受。谓欲逮得。诸佛授决。神足自在。恣意所乐。欲得佛道。便成正觉。是为菩萨十事信解也

菩萨信入世界。亦有十事。何谓为十。信诸佛土。入一世界。以一世界。入诸佛土。信一莲华。如大千界。一如来身。遍坐其上。十方佛土。解信一切。自然如空。一切世界。普悉庄严。信遍入中十方世界。其菩萨身。能周其中。信十方国。建着一迹。一切世界。入一人身。而自申畅。诸佛境土。至如来树。周一道场。以一音声。告十方界。一切众生。闻之心悦。是为十事菩萨信入世界。能住于此遍入如来无量境土

菩萨有十事入众生境界。何谓为十。一切身形。自然无身诸群生界。则为一身。自恣讲堂。信所入处。诸群萌品。则以得入一菩萨腹。众黎庶界。受诸释梵。及四天王形体像貌。信众生界入如来身。十方人民。蚑行喘息。人物之土入一人身。一切众生。能得处在。一佛法品。显群萌界。现为声闻。缘觉形貌像类。永无想念。十方世界。悉现菩萨庄严功勋。诸众生界。示现如来色像相好若干种身威仪礼节。训诲众人。是为菩萨十事入众生界菩萨居止有十事。何谓为十。发菩萨意。则是其处。修诸德本。众恶休息。开化众生。随时导示。常见诸佛。不离众圣。其所欲生。辄得处在。清净之界。奉修道行。不违正真。恒怀正愿。不随邪誓。佥能遵奉六度无极。专精思惟。平等道法。所可游居。与诸佛会。是为菩萨十宿止处也。菩萨住此。弃诸尘劳。无有遗余。逮成如来无量慧处是为居止

菩萨兴发有十事。菩萨以此。断诸起行。何谓为十。众生界起。开化度之。令之究竟。世界若起。灭除其秽。常使严净如来。兴现逮菩萨行起众。德本积累。相好习佛。功勋兴于大哀。消除众生苦恼五阴炽盛之衰。发于大哀。劝立众生。安一切智。诸度无极。合集菩萨严净之行。起权方便。普为一切。现道德之门。兴于道意。其心坦然。不可称限取要言之。一切诸法。菩萨所兴。在所现化。神通解达。是为菩萨十兴起也

菩萨有十事奉行何谓为十。恒自思念诸度无极。奉修禁戒而无缺漏。遵承圣慧不随邪见。顺从礼义未曾失节。遵崇道法。不随邪见。随时品第不违高节。应时示现不犯道教。亲近行义不厌训诲。奉修正觉不随小乘。遵承圣行而转法轮。是为菩萨十事奉行也菩萨成就有十事。何谓为十。常怀笃信。奉敬善友。逮成佛法。殷勤爱乐。如来所说。未曾谤毁。正典训教。其心无量。在于无际。劝助德本。逮如来境。而无齐限。信乐不疑。普能游入十方世界。成为佛法。又于法界。不可动摇。心如泰山。动魔境界。不得自在。自然降伏。恒悉识念诸佛境界。训诲众生。当自怀念。如来至真。十种慧力。是为菩萨。十事成就菩萨有十事失佛道法常当远之。何谓为十。其自憍慢。轻善亲友。失佛道法。畏惧生死穷苦之恼。患厌众行。违菩萨心。劳惓天下。周旋止顿。行必固性。违于正定。便失等迹。所作德本。名是我所作。嫉妒诽谤正法。翳匿覆盖诸菩萨行。爱乐声闻缘觉之法。憎于弘履。不喜宣畅菩萨大法。是为菩萨十失道法。常当远之。乃入菩萨无上圣贤

菩萨寂然有十事。何谓为十。能常勤修智度无极。瞻察众生除诸颠倒。度脱一切诸邪见缚。未曾发意。求诸妄想。开化众着。贪妄想者。行过三界。周旋一切十方世界。游居其中。改变众生。贪诸尘劳习放逸者。离爱欲法。兴大悲哀。愍诸群黎。除诸所有。而复示现一切眷属。动诸世界。现有终始。为显修行。游世俗法。而无所著。而复随时。入其中教。具见佛道。不断大行。不畏本愿。是为菩萨十事寂然。贤圣度世。摄护黎庶。过诸声闻缘觉之业

菩萨有十事得究竟法。何谓为十。这生堕地。自在如来。以致究畅诸佛境界。以获成就诸菩萨业。具足一切诸度无极。兴盛充满诸佛种姓。而逮超越如来俦类。常得建立诸佛十力。永得究畅如来大道。解知诸佛皆一法身。如来至真行无有二。是为菩萨十究竟法

菩萨有十事生诸佛法。何谓为十。一心自归。奉善亲友。兴诸佛法。至一德本。信乐佛法。则生道迹。发意之顷。皆能变现诸如来行。以得怀来无极大愿。生广大心。乐己德本。如所造立。终不忘失。未曾患厌。无央数劫。所可积行。悉摄当来一切无际。游居生在无量佛土。开化众生。常随时节。兴菩萨行。不断所履。常发大哀。显无量心。发一意时。普见虚空。以得超入殊妙大行。生至真愿。不失本意奉持一切如来训诲。照耀众生以发道心。具众德法。是为菩萨兴十道法

菩萨有十事号为正士。何谓为十。菩萨解了佛慧。为一法身。故曰开士。坚住大乘。号曰大士。奉行豪法。故曰尊人。觉成妙法。故曰圣士。入殊胜慧。故曰超士。劝人精进。故曰上人。宣豪胜法。故曰无上。具足解了十种力慧。故曰力士。除诸一切闇冥覆蔽。故曰无双。无俦匹士。心得由己辄成佛道。号无思议。是为菩萨号十正士也

菩萨行路有十事。何谓为十。诸菩萨众。与一乘路。一无等伦。不舍一心。菩萨有行。智慧善权。为二性路。复有三路奉修空行无相之本。则无元际。不猗无愿。游于三界。无所沾污。复有四路。修开士行。讲无尽业。皆能劝助一切功德。稽颡如来。奉敬无懈。劝助圣慧。善宣道教。增五根路。谛建立于信根大精进于诸行不退转住。一心而不乱。善觉了随定意。常晓了智慧行。修六通事。以为道路。其天眼者。见诸色像。睹诸世界众生之类。若有生者。及于死者。则以天耳。闻诸佛所说经典。则受持之。见他众生。为能分别。自见己心。亦睹他意。本末众念。不可称限。而得由己。念往古世无央数劫。所造德本。进益之宜。悉识知之。得大神足。随众生本。所应化者。现若干变则以正法。训诲众生。慧尽诸漏。自睹本际。不断菩萨所兴立行。行七思念。为菩萨路。常念于佛。导众生者。无有边际以一切句。见辄受持。劝化他人。使自归佛。思念经法。如来至真。于一道场。未曾动移。普在一切诸佛众会。现己说法。音畅十方。知诸群黎心根所在。而开化之。其意思念。僧在无数诸菩萨不退转睹不离数。皆见众生。诸菩萨身。常念施与。施诸菩萨。等御其心。思于大施。使德增长。常念禁戒。不舍菩萨心。以诸德本。施诸众生。常念诸天。菩萨生在于兜术天。当一补处。饥虚思德。常念众生。以大权慧。开化众生。无能废辩。其八正路。奉于正见。弃诸邪见。弃诸妄想众贪之求。皆念一切诸通之慧。道德种姓。舍口四过。修贤圣种。宣传正语。身诸所行为众生施。训诲众人。无有休懈。不舍正律。其正业者。坚住自在。闲静知足。修其道德。住于礼节威仪。住于正法。皆不误失。其正方便。以诸菩萨。同产兄弟。所见眷属。无有损耗。遵修如来十种力行。其正意者。所闻音声。悉能执持。普见十方诸佛世界。定意愦乱。其正定者。诸菩萨等。不可思议。以为脱门。聪明之故。以一定意。遍无数定。本定正受。定未曾舍。为菩萨路。离于欲界危害之迹。所讲说法。口所宣讲。一切无碍。说所思念。众想之着。开化众生。入一切智。舍于希望。舍众贪爱。常欲思见一切如来。以欢悦心。未曾懈废。舍于世俗苦乐之业。显示菩萨贤圣度世。永安道慧。修解无常。无色定意。生于欲界及在色界。初不动移。以度一切诸想所遭。音声正受。其菩萨行。不以为劳。若能思惟如来十力。佛子发遣。为菩萨路。常能晓了有处无处。限与无限。见诸众生过去当来现在报应罪福所趣。知于一切神识诸根。了了分别。察其心本。而为说法。别若干种不可计数身体各异。如是上愿。志在中间。又或下志。识其无际。为班宣法。一切刹土。诸有众生。三世所在。无央数劫。诸菩萨身。悉遍其中。如来至真。现无想念。而不违舍诸菩萨行。诸禅定意。一心正受。尘劳嗔恚。观察进退。知所因生。住菩萨门。睹诸黎庶。死生所趣。为说本末。知于三世众想诸念。入于一世。了诸群萌。尘劳挂碍。志性结解。悉令尽索。不舍菩萨所兴显行。是为十路。菩萨住此。悉逮无上如来权道菩萨行路无量。道至无限。行道无数净不可计。所以者何。菩萨行道无量有十事。何谓为十。察于虚空不可计矣。法界中间。向玄之有玄。悉无量矣。众生之种甚多故不可尽。世界无际故曰无限。诸恶思想亦复无底。一切民庶言辞亦无底元。如来之身无能计校。诸佛所演音声言教亦莫能尽。如来道力无能穷者。一切智明慧达圣元亦无能极。是为菩萨路十无量。所以者何。如虚空无量。修道无量。亦当如之。如法界玄之有玄。奉合道义无量亦如。如众生界甚多无尽。菩萨奉道无尽亦如。若其世界无有边际。进道亦如。若众恶思想不可计说。顺道化人。亦若兹矣。如民庶辞无有崖际。其合道如。若如来行无能计校。一切群黎无有二国。所念悉周。道行亦如。若佛音声言教莫能尽者。修道亦如。以一言训。普告一切。法界人种。若如来力。无能穷者。进如来力。修道亦然。如一切智不可计者。菩萨积德修道亦然。是为菩萨行路无量也菩萨行路有十事。何谓为十。无行不行。应与不应。其身口心。无所至凑。无举无下。其慧本净。故使其然。无奉不奉。修与不修。入于自然犹如幻梦。影响芭蕉电现野马。水中之月。皆解此已无一倚求。达知三界空无相愿。悉无处所。因其想见。而有三处。积斯功德。不荒其行。心无所有。而不可见。无言无教。离于诸法。众所游居。奉修法界。无所破坏。能知观察入一切法。不失如来真谛本际。斯真谛者。则以普周虚空之际。入菩萨慧诸行力业。未曾懈惓如来十力。四无所畏。一切智藏。察诸平等。观一切法。不怀沉吟。是为十事菩萨行道

菩萨有十行道严净何谓为十。佛子。菩萨在于欲界。而不动移。忽在色界。在其像行。一心脱门。定意正受。其所生处。无有放逸。是一净路。又复佛子菩萨目见声闻之乘。以慧度之。不堕彼路。是二净路。又复佛子。菩萨观知缘觉之乘。晓了随时。兴大悲哀。逮诸力愿。而不懈废。是三净路。又复佛子。菩萨大士。与大群从。眷属围绕。诸天人民。清净端政。鼓百千乐。诸玉女琴瑟。亦不可计。其音清和。参驾大车。菩萨在中。禅定脱门。三昧正受。如道无违。是四净路。又复佛子。菩萨在于一切众生。歌舞调戏。随众所为。示与俱同。常如一心。菩萨定意。初未曾乱是五净路。又复佛子。菩萨已度于世俗法。而于诸业。悉无所著。不舍度道。救摄众生。是六净路。又复佛子。菩萨住道。为显圣慧。以入正道。越诸邪见。在于邪径。训诲众生。使得勉济。不与邪径而俱同尘。是七净路。又复佛子。菩萨大士。其身口意。无有缺漏。亦不护戒。将养如来清净之禁。为诸凡夫愚騃之党。显清净行。教恶戒者。使普具足一切净福。菩萨所由。皆除地狱。饿鬼畜生。致三善路。现在不闲。生于众难贫匮之处。而到所在。勉济众生。虽游其中。不与合同。是八净路。又复佛子。菩萨所为。不倾仰人。而于佛法。逮无碍辩。普观诸佛逮法慧光。诸如来等。下无形种。一切诸佛。皆一法身。诸佛导利。为一切故。遍照法门。等住诸乘。诸佛游居。悉在目前。一切黎庶。佥无堪任。众生面手。悉见形呰。至未曾有悉为普等。其所求法。未曾忘失。其所现师。为从何受。悉恭敬之。咸起迎逆。因怪而生。缘其受之。彼修行法。在于众生。所以者何。善权方便。菩萨所行。开士真谛。住于道业。辄以方便。趣使众生。得随律教。显现权道。各使得所。是九净路。又复佛子。菩萨合集众德之本。逮得菩萨最上妙法。普具如来阿惟颜行。一切法尊所度无极系着无量离垢法冠。正缯为带。十方世界。现无央数诸如来身。转无耗损。建立法轮。其身尽遍一切佛土。游于诸法。独步三界。度于彼岸。逮诸菩萨。皆得自在。生十方国。过去当来现在诸佛。所可示现。教化众生。皆一佛界。亦不违失诸菩萨行。不迷道慧。不违开士德原之本而退还也。履菩萨迹而不回还。在大士行而不懈废。亦复不断正士启受。亦复不舍善权方便。不废圣业。不违菩萨所行势力。不以危害加于他余。不远圣士所建正行。所以者何。若斯菩萨。速得无上正真之道。如是菩萨。行无所著。观一切智。明如来体像而无形貌。是为十净路。菩萨住此。疾成如来无上大道

佛子菩萨。有十奉行。何谓为十。修于禁戒大愿殊特。渐备具足。为精进行。怀来一切诸道品义。而不回还。遵神通行。从众人志。各令欢悦。修神足行。普入十方诸佛国土。合为一刹。而无动者。志奉清和。得入殊妙。誓愿坚固。一切所作靡不成办。若受伏胜。不越一切众尊师命。求闻经典。行无厌倦。奉修诸佛所班宣法。不以为劳。崇法圣性。游于一切众会道场。勇无怯弱。就于无极大行清净。解知一切。咸无所生。是为十行。菩萨住斯。普游十方一切佛土。无所挂碍

菩萨有十事手。何谓为十。谓笃信手信如来教一志信乐不可穷极。以手供养诸佛正觉。积累大德增益无倦。为放舍手一切诸求皆令得悦充满所愿叹善哉言。先问讯手。伸其右掌。博闻善手断除一切犹豫结网三界寂然。大游出手爱欲无常。当以大手化众生界授所施与。住安地手。觉了四流度无极臂总摄内藏奉平等行为无师法。悉化众生无起害心。讲说经典明知世俗及度世法手。能除身心诸有灾疾。智慧宝手消灭尘劳现无量法光明之耀。是为菩萨十事手也。以此道手弘覆一切

菩萨腹有十事。何谓为十。谓志性腹。所念清和。质直之藏。而无谀谄。不思伪饰。悉无所受。无因缘界。不乐一切诸所有业。去诸尘劳。以慧为胎。其心清净。而无瑕秽。观断诸食。思真谛法。察万物无。晓了十二因缘之故。分别一切诸生死业。志性柔软。纯淑之故。除于一切边际邪见。为菩萨腹。普使众生。入佛道藏。是为菩萨十事腹也

菩萨复有十藏。何谓为十。不断佛教。住菩萨行。奉诸佛教。以无放逸。而得由生。显炽法训。为菩萨胎。住无极慧。现出世间。遵承圣众。为菩萨胎。住不退转。而转法轮。必从众生。善法残来。为菩萨胎。所住随时。不失道节。众生在于不决了处。究竟开化。为菩萨胎。立之报应。各各使度。令无断绝。众生处在。处邪见地。兴大悲哀。为菩萨胎。兴炽当来无极光明。如来十力。奉修报应。令其具足。为菩萨胎。降伏众魔。德本无双。大无所畏。为师子吼。则菩萨胎。一住立处。欢悦众生。令无余疑。逮得十八诸佛之法。为菩萨胎。皆以圣慧。道利一切。一切众生十方国土。有诸佛法。劝助佛道。为菩萨胎。生无差特。入于一慧。是为菩萨之十胎矣

菩萨心业有十事。何谓为十。所可念业。一切所作。辄得成就。心不怀怯。积累功德。习具相好。愍大行步。降伏一切诸魔官属。随时行愍。消除一切尘劳爱欲。修不退转。亦不回还弘愍之行。至佛道场。本净显耀。心无所至。了无所倚。愍入众生。随其所好。而开化之。修大梵行。入诸佛法。不乐余道。救济众生。空无相愿。达无所有。去诸邪见。不舍三界。举诸庄严。为金刚界坚固无坏。正使一切皆成为魔。不能动摇。菩萨一毛。所兴德行。是为十愍菩萨有十事被德铠。何谓为十。被大慈铠。将护民庶。修无极哀。皆忍众苦。志誓愿铠。悉能究畅一切方便。劝助德铠。亲奉诸佛清净之行。兴功德铠。使诸众生。皆蒙其恩。诸度无极。皆度群黎。圣慧之铠。消除一切尘劳爱欲。善权方便。殖众德本。导利普门。一切智心。安不愦闹。其意无变。一志德铠。心怀法念。而不忽忘是为菩萨十德之铠降伏众魔菩萨杖有十事。何谓为十。以布施杖害诸悭贪。修禁戒业坏除一切犯众恶事。等劝法杖消去妄想。则以智慧。断截众生尘劳爱欲。以正业杖远离一切不晓活业。以善权杖普自现身淫怒痴乱。菩萨皆以法杖消化众生一切爱欲众瑕秽门。其在生死则以慧力断为秽行而开化之。讲一法杖破坏一切诸所依倚一切智门。能为消去诸反逆户。是为菩萨所执十杖

菩萨头有十事。何谓为十。无慢为首。天上世间莫能见顶。稽首师长孝顺二亲。天上世间皆为跪拜。好上妙首三千大千世界靡不戴仰。众德之本而为元首。三界众生咸来归命。代诸众生负于重担。为枕之首常得举头周观十方。不轻他首。所作游步与众超异。智度无极首顶有法王。权方便首普现众生平等之行。化人民首诱进众生悉使普安。修诸如来法教之首。常奉三宝令不断绝。是为菩萨所有十头

菩萨眼有十事。何谓为十。则以肉眼皆见诸色。又以天眼普见众生心意所念。以智慧眼观黎庶根。复以法眼皆见诸法之所归趣。佛正觉眼悉见如来诸十种力。以圣慧眼见除一切诸非法事。以光明眼演佛威耀普有所照。以导利眼捐弃一切贡高自大。以无为眼所睹无碍。一切智眼。普见十方一切法门。是为菩萨十事眼也

菩萨耳有十事。何谓为十。闻嗟叹德断诸结着。若闻谤毁除诸所受。若闻声闻缘觉之事。不以喜悦亦不志求。若闻嗟叹菩萨之行欢悦无量。闭塞地狱饿鬼畜生假使生贫八难厄者。为兴大哀。闻生天上人中安处。知皆无常志慕大道。若闻咨嗟诸佛功勋。益加精进具足此业。若复得闻诸度无极及与四恩菩萨法藏一切精修。皆能通达备悉是事。佛子。当知诸菩萨众。十方世界诸佛所宣义理之业。诸开士等。皆悉闻之。诸所可听。解无所有。又其菩萨。耳所闻法。悉等一定。从初发意。至于道场。坐佛树下。得成为佛。开化众生。未曾懈废。是为菩萨十事耳也

菩萨鼻有十事。何谓为十。若遇美香不以识乐。若遭臭秽不以患厌。等察香臭不以殊特。观诸香臭悉无所有。衣服卧具。礼节香臭。淫怒痴事。皆以等心。入此众生。其诸大藏。树木众香。咸悉观之。知无有香。下无择狱。尽于上界三十三天。其中所有一切名香。佥无所著。悉说本末。得听声闻戒禁博闻。布施智慧道法之香。慕一切智。心未曾变。假使得蒙诸菩萨行。则以修智如来等地。若具如来境界慧香。不断菩萨上妙道行。是为菩萨十清净香菩萨舌有十事。何谓为十。口演无尽众生之行。班宣无量诸经典教。咨嗟无限诸佛功勋。歌叹无穷灭度辩才。颂说无际大乘之业。其口言辞。遍十方空。其大光明。照诸佛土。口所说言皆使众生。各各得解。其辞与同口所宣者。十方诸佛。咸共叹之。一切众魔。及外仇敌。尘劳生死。悉自然除。至寂无为。是为菩萨。所说口舌

菩萨躯有十事。何谓为十。谓受人身。则以人言而开化之。亦复训导诸非人形。地狱饿鬼畜生。令随律教。生在天身。又复教授诸天人像欲行天人及无色天。有在学者则以学地。而诱进之。向无学身。为现罗汉无所著事。在缘觉躯为导缘觉所当奉律。在菩萨形则为显示大乘之业。如来至真。其慧无限。随时说现。见诸自大。以权方便。而发起之。法身无漏。悉无所有。普现诸身。是为菩萨十身菩萨有十意行。何谓为十。念于本宿命一切所行。众德之本。建立其意。常奉要义。心所入者常志佛道。极至原际。愍众生身。念无烦扰断众尘劳其意显曜。不与客尘而俱合同。念择善行。察之随时。而无所犯。谛观罪福。不造殃衅。思诸德根。诸根寂定。制不放逸。其志澹泊。求佛定意。是为菩萨十意之行菩萨行步有十事。何谓为十。好诣法会。听受经义所诣无声。亦无阴蔽。不怀淫怒愚痴恐惧。心常专惟。有讲法者。皆为众生。至于欲界。开化黎庶。若至色界及无色界。以像定意。寻便回还。普现五道。训诲群黎。以神通慧。遍诸佛土。见诸如来。稽首问讯。所可游步。悉为法施。由是之故。得大智慧。现入泥洹。不断生死。周旋所度。具诸佛法。未曾休废诸菩萨行。是为菩萨十事游行。菩萨住此。无游不游。因斯普至诸如来行。独出十方

菩萨有十处。何谓为十。处菩萨心。未曾忘之。住度无极所可修业。不以饱满。聚集法众。通达智慧。止于闲居。致大禅定。顺一切智。德知止足。贤圣寂静。住无众想。亦无希望。奉行法处。不远正义。礼归如来。则能具足。诸佛正觉。威仪礼节。出神通处。备悉大慧。逮法忍者。满所授慧。坐道场处。至力无畏。充满一切诸佛之法。是为菩萨十处

菩萨有十坐。何谓为十。其福得至转轮王座修于十德。不失天上。世间人处得四天王。以佛尊法。授诸天下。逮为天帝。超越众庶。梵天自在。欲摄他心。亦得由己。致师子座。兴显法众。得正法座。逮成总持力。普照一切。其志坚强。所建正愿。靡不周遍。通达十方。以大慈座。嗔恚怀结。令得悦颜。以大哀座。忍诸苦恼。不以为患。坐金刚座。降伏众魔诸外怨敌。是为十座

菩萨卧寐有十事。何谓为十。谓止寂然。身心澹泊。宿于独处。思惟顺义。不失其时。顿于正定。身心静默。处于梵天。能悦己彼。善修其业。然于后世。不怀恼热。志平等行。不怀嗔恚。住于道行。解达善友。善微妙居。劝助德本。皆得一切义理之源。悉能究竟。成就道教。不利财业。乃是往宿。所修德行。是为菩萨十事卧寐

菩萨室有十事。何谓为十。无极慈室。等心众生。以大哀行不轻未学。以大喜行除诸不欢。和颜悦色。行大护处。等于有为。及无所有。诸度无极。道心为首。具足空行。晓了随时。为无相行。不住寂灭。为无愿行。所生至诚。意安详行。备悉忍辱。等诸法行。逮得受决。是为菩萨十事室也

菩萨游居有十事。何谓为十。其意游居。具四意止。所行游居。了法所趣。其意所在。唯乐诸佛。诸度无极。备一切智。修四恩行。开化众生。游在生死。兴于德本。集众黎庶。不习诸闹。随其所乐。而度脱之。显神通行。开悟众生。解殊特根。善权方便。智度无极。为众说法。游至道场。达诸通慧。备菩萨行。行不断绝。是为菩萨十事游居

说是语时。三千大千世界。为大震动。十方菩萨。皆来赞咏。戴诸天华。如须弥山皆散佛上。莫不欢然。诸天龙神。悉来奉敬。箜篌乐器。不鼓自鸣。妇女珠环。皆自作声。飞鸟禽兽。皆共[革*鳥][革*鳥]。盲者得视。聋者得听。跛者行走瘘者得平。屈者申舒。狂者得正。尪者强健。疾者瘳除。众会咸踊。深自欣庆宿命禄厚致此光明。无央数人得无从生发大道意。功德皆成

度世品经卷第四度世品经卷第五

        西晋月氏三藏竺法护译

普智菩萨。复问普贤。何谓为观。何谓为顾视。何谓为嚬申。何谓师子吼。何谓施净。何谓戒净。何谓忍净。何谓进净。何谓禅净。何谓智净。何谓慈净。何谓哀净。何谓喜净。何谓护净。何谓为义。何谓为法。何谓积德。何谓慧业。何谓明达。何谓法典。何谓行法。何谓奉法。何谓为魔。何谓为魔业。何谓弃魔业。何谓见佛。何谓佛事。何谓自大。何谓圣业。何谓菩萨为魔所固。何谓佛建立。何谓建立法。何谓处兜术天。何谓现殁兜术天。何谓住胎。何谓现其安详。何谓修生。何谓因欣笑。何谓行七步。何谓现幼童。何谓在中宫。何谓弃国捐王。何谓勤苦行。何谓诣道场。何谓坐树下。何谓在树下致未曾有法。何谓降魔宫。何谓成佛道。何谓转法轮。何谓转清白法。何谓如来至真取大灭度

普贤菩萨。报普智曰。善哉问也。乃为一切。重启斯义。何一快乎。谛听谛听。善思念之。与诸大众。受教而听。普贤曰。菩萨观有十事。何谓为十。观其真谛。造立善业。见微妙色悉达其原。察如寿终。及见生者。亦不贪猗。愦闹众会。见一切根。而分别之。化诸败根。观察诸法。不坏法界。面见诸法。逮得佛眼。逮智慧圣。随应说法。无所从生法忍究竟。逮成诸佛之法不退转地。除诸尘劳三界众难。声闻缘觉。一切径路。观阿惟颜。于诸佛法。而得自在。现欢悦法。善解道意。而能普现十方所有。是为菩萨十事观也

菩萨顾视有十事。何谓为十。见诸乞求。不怀害心。从其所愿。而令欢悦。睹犯禁者。皆建立于一切智戒。见诸众生。怀嗔恚意。解忍辱意。以此佛仁。而诱进之。见懈怠者。已不离行。而劝助之。使学大乘。睹心乱者。化建立之。不愦觉地。诸通敏慧。察恶智者。为未曾怀诸邪见。使无有余已。以真察其善友如来所学。建立佛法。如所闻经。观其本原。修无上义。眄于众生。悉怀憔悴。显示大哀。顾诸佛法。逮成正觉诸通敏慧。是为菩萨十顾视也

菩萨频申有十事。何谓为十。如象频申。诸天龙神。阿须伦。迦留罗。甄陀罗。摩睺勒。一切众会。无能及者。如龙象长所乘造心欲。为代众生。而负重担。为如蛟龙。兴云澍雨。演电光[火*僉]。出正雷音。根力觉意。禅脱三昧。畅甘露水。流布法雨大凤凰王频申。拔诸无明愚痴众冥。深入根株。消息爱泉。济其根原挂碍之门。免出欲心毒害尘劳瑕疵诸秽。师子频申。以离恐惧。大慧等剑。在于大众。消伏外学。勇猛频申。除诸怨敌。爱欲瑕疵。垢浊众冥。消伏难化。如大将师。降伏严敌。圣慧频申。弃去五阴。四大诸入。十二因缘。令不增长。而慧显现。极尊势法。总持频申。意游甚强。一切所闻。辄能受持。未曾遗忘。己能受持。为他人说。辩才频申。应机卒答。所演章句。不可称计。分别班宣。无能障翳。可悦众生。无所侵欺。究竟本末。如佛频申。处于师子。殊胜之座。降魔官属。具足普智。诸通敏慧。一心念顷。应时平等。逮成智慧。为最正觉。悉能明达。护辄成如志。致无上正真之道。是为菩萨十事频申

菩萨师子吼有十事。何谓为十。吾当成佛。怀逮圣道。大师子吼。度未度者。济未脱者。安不安者。其无为者。令取泥曰愍伤众生。佛教法诲。圣众之训。顺不违之。于如来所。而有反复。以坚固愿。净诸佛土。悉能勇达。谨慎禁戒。除诸恶趣。使佥消歇。为师子吼。身当备悉。佛身口心。庄严相好。求诸功勋。而无饱足。具满佛慧。慕圣明宜。不以懈惓。降伏众魔。使无害事。奉正真行。去尘劳业。解见诸法。无我无人。无寿无命。空无相愿。心如虚空。清净无垢。寻即解诸典。能逮得无所从生法忍。为师子吼。最后究竟。菩萨清净。离垢解明。显耀感动。诸佛国土。告众释梵四天王。所见咨嗟生未生者。以无限碍。无极大慧。谛观觉意。已成无上正真之道。悉无所受。而大欢悦。又行七步。吾于世尊。极豪无双。当除众生生老病死。言如所行。为师子吼。是为菩萨十师子吼

菩萨施净有十事。何谓为十。等施众生。心无偏党。随所喜乐。而布施之。具足诸愿。不乱布施。不断哀业。应时布施。解于众人诸根原故。不必故施。悉离众沉吟。善施布施。悉舍心所爱。不惜内外。所有爱施。究竟净于所与之故。所施与者。劝助佛道。弃于有为及与无为。开化是等。所施与人。至令究畅。成道场故。施净三场。施受者处。念于诸法。等如空故。是为菩萨十事施净。若住于此。逮于如来无上大施

菩萨戒净有十事。何谓为十。身行清净护其三事。口言清净弃口四过。舍心三秽无嗔恚痴。将养禁戒一切无犯。见有过者随时安之。消贪欲业去恚愚冥。其德照明天上世间。守于道心思乐大乘。奉诸如来而学正教。而无为戒默随律禁。除诸众生殃衅众罪。远离众恶。顺从一切众德之本。断众邪见。不以禁戒而怀自大。抚育群黎。遵大哀力。是为菩萨十戒清净

菩萨忍净复有十事。何谓为十。若人骂詈。加以恶声。默而不应。则忍清净。亦护众生。加以瓦石。而打掷之。刀杖加身。受而不挍。护彼我故。设有嗔恚。怒恨向之。而慈愍之。本性无害。若轻蔑者。不怀恶念。明耀堪任。若来归念。能将顺之。宁失身命。忍不违之。捐舍自大。不轻未学。不自贪身。视如虚空。忍观若幻。诸有恶向。心不怀害。无彼我想。任顺尘劳。消除众毒。诸菩萨慧。柔和之忍。兴显灭尽。一切诸法。诸通慧界。人无所仰。是为菩萨十净忍也

菩萨精进净有十事。何谓为十。身行进净。恭敬自归于诸菩萨。则为贤圣。寂定众祐。口言勤力。闻诸如来。所可宣畅。悉识念持。叹诸佛德。如所闻法。为众生说。不以劳惓。心念鲜洁。慈悲喜护。禅思脱门。定意正受。不废善权。志不怯劣。常修精进。不怀谀谄。进清白行。而怀质直。诸所应行。不为杂碎。志性勤和。所游至处。常有超异。其慧转增。众清白法。遂以炽盛。其明光光。无戒无虚。布施调意。明识仁和。戒闻施与。永无放逸。启受不废。当诣佛树。降伏魔怨。为净精进。断淫怒痴爱欲尘劳诸着邪见阴盖挂碍。成慧光明。常谛思惟。逮善明心。不怀恼热。毕所造业。亦能致得。诸佛之法无应不应。为常勤修。心所启受。永以欢悦。其身口心。等视无视。而谛晓了普门之界。随其所知。而顺从之。成就法明。势以强和。越诸住地。乐诸佛说。解诸佛身。无有诸漏。现来入胎。出生在俗。弃国捐王。成最正觉。而转法轮。示大灭度。而咸悉备普贤之行。是十进净

菩萨禅净有十事。何谓为十。常欲出家。志存一心。则为清净。弃一切贪。得善亲友。应时致寂。等解道故。习在闲居。修鲜洁行。不计吾我。亦无所慕。除诸睡眠。而去众闹。乐于寂静。其心勤修。寂诸根门。己慧一心。不为一切枷锁危谄凶人之所蔽碍。道路觉意。应时寂然。一切所修。以慧观察。思于一心。以善权故。更复还反。来入欲界。有所发起。履神通迹。分别一切众生诸根。使入寂静。乐无所有。澹泊之门。致佛定意。是十禅净

菩萨智净复有十事。何谓为十。以净智慧。解其报应。不望果实。度于一切。目所见者。常怀安和。而不诤讼。了知断绝。亦不计常。入于因缘。随真谛慧。弃诸邪见。摄于众生。未曾休废。睹诸群黎心念所行。瞻之自然。犹若幻化。大辩才慧。入于圣明。为清净智。分别章句。所宣无碍。远一切魔。众外异学。声闻缘觉。入诸如来善权之慧。见诸佛净。众生其净。睹诸法寂。观诸刹土。自然如空。普智慧净。游于此中。至无为相。逮得总持。宣畅辩才。住权方便。诸度无极。所可游步。与众超异。一心念顷。解诸法等。慧如金刚。不怀恚恨。无恐惧想。为清净智。皆逮诸法圣顶之慧。是十智净

菩萨慈净有十事。何谓为十。等慈众生。净心无若干。常行愍哀。荷为众人。而抚育故。将护身慈。勉济群黎。生老死难。不舍群萌。兴众德本。行解脱仁。皆能断除众生尘欲。不忘道意。训诲众生。入通慧心。无害人民。普演等曜。遍慈如空。将护一切。遵修法愍。化如真谛无漏之慈。因得来入菩萨寂然。是为菩萨十慈净也

菩萨有十大哀净。何谓为十。无双大哀。为己身故。不厌大哀。为众生故。遭众苦恼。不以悒结。愍哀恶趣诸在八难。假使生彼。而勉济之。生天人间。兴大净悲。宣讲非常。愍于一切诸堕邪见。无央数劫。因被德铠。不舍未度。安己无退。哀劝众生。使获大安。造一切业。无所希望。己心愍净。怜念诸倒。住世无智。使远依倚。应时说法。一切诸法。本净自然。悉虚无实。为诸客尘之所沾污。菩萨知是。故于众生。兴大悲哀。令不净者永得净处。无垢显耀。而为说法。分别诸法。譬如空中飞行鸟迹。群萌于此一切经义。冥不解了。菩萨以故。兴大悲哀。为现大慧。取灭度矣。真谛履迹。是为菩萨十大哀净

菩萨喜净有十事。何谓为十。欣然发大心。以喜悦为净。一切所有。施而不吝。无所逼恼。不怀怯弱。教毁戒者。众生有恶。皆能忍之。通诸愿故。用经义故。不惜身命。不以恼热。为欢悦净。不念恼热。乐以法乐。弃捐一切贪欲之乐。显示众生经典之要。令舍诸贪利养之恩。见佛无厌。奉敬自归。法无所坏。喜悦为净。皆以禅一心。至于脱门。定意正受。而自娱乐。复以此法。开化他人。寂然能仁。禅无嗔恨。以慧为上。弃诸邪见。具菩萨行。则为喜净。是为十喜净

菩萨护净有十事。何谓为十。一切人民。贪乐有为。化于众生。使至无为。则为净护。本性在于无俗之法。反游世间。见不应器。不怀危害。睹应法者。显以方便。志清净法。不慕声闻缘觉之业。学不学事。不贪一切爱欲之乐。在业尘劳。心常专精。在于经典。厌于声闻。缘觉生死。不住处所。不喜世俗之所言谈。危他人辞。离不随时。声闻缘觉。以此言说。乱失菩萨。不与同尘。所化众生。如己解力。拔济四大寂灭诸入。不知法者。以时观看。其有菩萨。本曾现化。在如来地。菩萨所观。以离二事。无卒无暴不举不下。离于多念妄想之患。而常寂定。处真谛法。逮得法忍。是十护净

菩萨义理。有十事。何谓为十。若闻法者。以何为要晓了法义。解达空者。知本无事。分别诸法。修寂静义。恬泊之故。解无所有。不着诸音。为如真谛。等于三世。入于法界平和味故本无义者。如来所归。真谛本际。解之如审。大灭度义。断勤苦患。修菩萨行。除诸所受。是为十义

菩萨有十法。何谓为十。修至诚法。言行相应。无诤讼法。弃捐一切诸所贪求。无所讼事。消除尘劳[火*僉]炽之欲。为寂然业。离诸恼热。舍于贪欲。消众恩爱。众垢之患无所想念。休息因缘诸所作为。无所生法。等如虚空。习无为法。释诸所生起运之事。已达本净。解于自然。无所染污。断一切病。径至灭度法。兴菩萨行。犹执持故。是菩萨十法

菩萨积德。复有十事。何谓为十。若能劝人。发菩萨心为积功德。不断三宝。劝于十事。而顺福行。弃捐一切诸不善法。修正经典。兴智慧业。为菩萨福。其在三界。无能及者。修德无厌。欲济一切众生之界。内外所有。皆能惠施。为舍一切贪求之业。具足相好。修大精进。而不回还。剪心刺棘。缠绵之患。永不思念诸上中下众德之本。劝助佛道。以权方便。受清净教。弃众邪见。修众德本。及兴大哀。现正士行。而独游步。奉敬归命诸如来尊。见诸菩萨。敬之如佛。安诸群黎。坚固护意。无央数劫。积功累德。含此德本。道在己身。如观手掌。施一人已。寻开化之。不怀愁戚。亦不后悔。一切众生。亦复如是。先施与之。然后开化。集众德本。折伏其心。见道如掌。不怀愁悔。是为菩萨广大其志犹若虚空。积于十德。入于无极广大之智

菩萨有十慧业。何谓为十。以博闻。为善亲友。与其俱同。影在其后。启受奉敬。趍走给使。给所当得。奉其教命。无细碎意。弃捐自大。谦下恭顺。卑身逊辞。伏心下意。性不刚[革*卬]。不为卒暴。性不粗犷。禁戒平正。意志柔和。颜貌熙怡。离于虚伪。先人问讯。性行质直。不妄倿愦。不怀谀谄。以慧为业。为己应器。意性和雅。晓了所趣。其心不乱。住于羞耻。奉六思念。显示六字施戒忍进寂智之本。顺六坚法。而不回还。入十解慧。常求法义。好法乐法。慕索正法。所闻无厌。舍世谈话。不与同尘。离方俗言。讲道度世。而远小乘。志在微妙大乘之业。其心所念。无有异业。求六度无极。其所求者。未曾远离修四梵行。习于明曜柔顺之法。作性黠慧。晓知问事。离诸邪径。导利正路。心所思念。以用班宣。调和己心。护他人心。所谓慧业。奉修要行。常欲舍家。虽游三界。乐于寂静。自察己心。不随恶念。消去三恶。身口意事。心观究竟自然之事。净己彼心。观于五阴。犹如幻化。察于四种。如毒蛇虺。视诸衰入。亦如空聚幻化野马水月梦影山中之响。如镜中像。如画虚空。如无形轮。其譬如是。说其本末一切诸法。无可捉持。无有比类。如日之影。无常无断。无来无去。一切诸法。无有住处。以观诸法。所入如是微妙之业。然后乃信。是为菩萨解名万物适起寻灭第七慧业。入一切法。闻一切法。无我无人。无寿无命。无心思议。无淫怒痴。身无所有。亦无观业。无垢无生。无有色习。无有衣食。习至无为。已闻如此。忻然信之。不怀狐疑。是为第八慧业。信解具足。精进随时。诸根寂定。观澹泊事。静然澹默。于一切念。无造无知。戒无形像。无我无人。亦无所行。不住贪身。究竟文字。无有疮疣。无所得忍。无进无怠。无双无只。其身口心。无所修行精进之要。于一切法。及与众生。皆以等心。悉无所住。不此际。不度岸。离于彼此。无行不行。所遵为慧。作是思惟。第九慧业。度诸希望众想之患。见诸因缘。睹见诸法。为清净业。见诸正觉。观诸澹泊。见诸法界诸法。为清净业。见诸正觉。观于众生。察诸刹土。为甚清净。见诸刹土。如空清净。观诸澹泊。见诸法界。则慧清净。睹诸圣慧。法甚清净。是十慧业

菩萨兴通达有十事。何谓为十。善持佛法。为兴通达。究竟精进。以为道义。离诸邪见。则为显明。智慧为明。诸根显达。修等精进。以为正解。劝助圣慧。入于顺业。兴于尽慧。除罪尘劳。选择智慧。发天眼明。本宿清净。识于往古。所可游居。修诸神通。观众生原。尽一切漏。发起正慧。是为菩萨兴神通句

菩萨法典有十事。何谓为十。虽求诸法。为无所慕。舍诸谀谄。则以精进。而求诸法。志远世俗。以无著意。而乐诸法。不贪身命。消除一切尘劳之难。而好道法。不惑利养汲汲之念。为己他人。愍众群黎。而慕经典。不独为己。所以求法。欲入慧故。不贪住法。道利行故。而爱敬法。不以轻戏而易弄之。愍伤众生。故求法义。不舍道心。欲断群萌狐疑之结。故求经义。消众犹豫。求佛道业。欲使备悉。故求经典。不乐异乘。是为菩萨十事求法也

菩萨行法有十事。何谓为十。化诸愚戆。至心殷勤。入众德本。信无所怀。度诸挂碍。解法自然。笃行要义。住于经典。奉道慧已。而不离义。遵奉道慧。以法为念。越八邪地。入八正路。顺从八等。断诸结网截生死流。现真谛义。逆水而度。谓须陀洹。不自放逸。等于他人。不行谄饰。所游居处常修道德。周游往来。不乐三界。寻时所生。不怀沉吟。奉诸漏尽。为不复还。造六神通。乐八解门。因本三昧。而修正受。以为身船。宣四辩才。为无所著。以乐一品。入缘起事。乐一味业。好寂为本。无思无想。入于己地。自闻其慧。唯修神通。则为缘觉。心志微妙。乐入明根。其心常念。欲度众生。积功福业十力无畏。具足一切诸佛道业。是为菩萨十修光业

菩萨奉法有十事。何谓为十。奉敬善友。则为行法。诸天劝助。则为行法常听诸佛及世尊教。则行十法。愍伤众生。不断生死。则为行法。悉能究竟。勤修道业。不怀结恨。则为行法以诸同学。修大乘者。勤行精进诸菩萨业。则为行法。遵修随义。弃诸邪业。则为行法。降伏一切。诸魔尘欲。则为行法。住于圣觉。见众生根。而为说经。则为行法。修治广大无量道业。不舍道意。则为行法。是为菩萨奉行十法

菩萨有十魔。何谓为十。猗于身魔而着五阴。为尘欲魔之所得便。亦为罪魔之所覆盖。自兴起意是为心魔。其死魔者弃所生处。其天魔者多念诸想为放逸行。废德本魔随人着冥。乱定意魔多所慕乐。似善友魔外像如真。令不奉修道慧之本魔使离正愿。是为十魔

菩萨魔业。复有十事。何谓为十。违菩萨心。舍众德本。偏心布施。见犯戒者。而怀嗔恚。远诸怀恨。舍众懈怠。避于乱心。得诸邪智。舍法师行。不劝法器。若宣经典。唯叹衣食。劝破坏器。而复劳厌。诸度无极。若复戒敕。所闻正法。不能奉行。释雅训诲懈怠心怯。不顺道教。心怀众想。习诸恶友。远善亲友。乐声闻缘觉。得所生处。乐离爱欲。寂灭其心。志厌菩萨。而诽谤之。求人长短。欲断利养。恶眼视师。诽谤正法。所未闻经。闻之呰毁。闻余法师。有所讲说。不肯善听。轻慢调戏。叹己恶彼。慕世谈话杂句之辞严饰之言。乐诸合偶句诔之业。好闻声闻缘觉之业。所讲言教。蔽深妙义。阐杂句饰。为不应器。若说深法。而不肯受。不求佛道。反住邪径。越于度脱。习不吉祥。舍永安业。而敬乐此。归命邪伪。未解未度。不修吉祥。不从真谛。恭恪启受。亦不诵读。心怀自大。不能谦下。有所言说。辄自高畜。念害众生。不求道慧。不志寂然。常怀杂碎。所修正律。则为魔业。是为菩萨十魔业也。弃捐魔事。求佛道业

菩萨有十事弃捐魔事。何谓为十。与善亲友。而俱相随。舍诸自大。为弃众害。自伤己身。无毁损事。信佛深法。未曾诽谤。心不舍远正教之志。一切普智。精勤深要。达无放逸。修行菩萨。住于法藏之业。求一切典。不得博闻。如大江海不厌众流。念诸如来在十方界者。以用护己。普思达意。信乐发善。在于众德。菩萨为党。无有二行。是为十事弃捐魔业菩萨有十事见诸佛道。何谓为十。佛住于世。无所依倚。成最正觉。建立诸圣。导利正业信喜诸佛。所演报应。归趣所化。威神之德。入于诸佛。不自大本。等进一切诸佛法界。心常志念。奉敬众圣。以佛定意。无有放逸。亦无所著。佛所解达。则为本净。如心所觉。广大其心。是为菩萨十事见诸佛也

菩萨有十为佛事。何谓为十。以时劝人为佛事。修平等事而得由生。于卧梦中得见正觉。为宿德本之所诱进。所未闻经而念思惟。不疑佛事。弃悭贪心。而消声闻缘觉之心。亦复除去犯戒嗔恚乱意恶智诸所著心踌躇沉吟戏故之心自大心。庄严相好如来形像。前世功德之所牵引。净除众疑及诸蔽碍众想之法。于佛道业。不怀犹豫。饥乏之时。闻说经典。修所讲法。所闻能持。逮致圣慧。兴显神通。劝化无量。利益众生。是为第六诸佛道业。为甚清净。设魔事兴。以权方便。修若干行。因虚空中。各演异音。若轻他人。若忧魔事。其音演法。而开化之。便解道法。假使闻者。加精进行。是七佛事。广大意故。又护逆心。亦护不随声闻缘觉灭尽之业。抑制诸根未纯淑者。不与解脱。宿本所造。诸佛道愿。而奉行之。随生死者。为断诸漏。若在众行。合集执持。为显大哀。而成其行。使合无为。是八佛事。不随断行。佛子。欲知此离灭度。达己众生。解知无人。而不恐畏。求智德本。初发心者。于慧无厌。有所兴发。己身万物。一切诸相。常不离此。见佛色相诸行已离贪着。不猗诸法。志求无为一切愍慧。于一切法。不戴仰人。净其佛土。解了诸相。如虚空刹。开化众生。不以为劳。亦不弃捐无我之相。变神通慧在于法界。而不动移。亦复不舍菩萨兴业。诸通慧光。而照曜之。而转法轮。悦众生心。亦复不越无所有法。示现如来所建变化。不离菩萨现大灭度。弃捐众恶。普现五趣所生之处。如是佛子。以此比类寂然之行。奉修诸法。是为十业兴诸佛事

菩萨自大有十事。何谓为十。轻慢众祐耆年尊长贤圣之党。不孝父母。沙门梵志。修平等行。正真之训。不行恭恪。心所念业。不顺法师。奉尊法者。宣妙法等。承大乘教。履慧道迹。执持谦典。不肯谦下。稽首礼敬。憍慢自恣。不奉师教。不谛听受。亦不思惟。在于众中诸讲法者。坐显妙法。不赞法师。言曰善哉将无众人。钦敬彼人。心起自大。自显其功。蔽他人德。计独有我。心自生念。多所轻蔑。既怀自大。我知我解。谤讪有德。净修行者。说其瑕秽。未曾咨嗟功勋之义。若见叹者。心怀惨戚。既知法义。律教若兹。佛言至诚。可尊敬者。乃不喜之。憎恶学士。并毁经典。谤讪正籍。更受余义。求处高座。求经法短。欲得慕求他人奉敬。见诸尊长英雄之党又修梵行。不起迎逆稽首礼节。若见明者。面色惨戚。颜貌不悦。不演好辞。常怀恶心。观取长短。少少之失。随于自大。不肯往诣。至明智所。不肯逐后。谦下恭顺。不肯问讯。咨受经义。不知何善何者不善。当修何义。长夜获安。不遭众难。与愚党俱。日向闇冥。痴蔽益甚。以騃之故。显不恭顺。以騃自害。而怀自大。以贡高故。离于佛教。耗尽宿世众德之本。不兴新福。强起幼少。欲令下屈。说不当说。举动凶竖。多喜诤讼。毁于博智。驱出精舍。而自放恣。堕大崄峪。又于道心。势力之正。憍豪自恣。谓得尊位。于百千劫。不值佛世。况当复遭遇闻经法。是为菩萨自大十事。菩萨弃是。便逮十慧

菩萨慧业。复有十事。何谓为十。所造事业。执圣之义。解知福果。终不朽腐。心习道念。常知念佛。习善知友。谦恪随顺。于彼奉敬。启受尊长。精进修慧。志法乐法。元元求法。慕于博闻。而无厌足。思惟随顺。应当念者。勤勤行之。不应念者。辄弃捐之。见诸众生。不怀轻慢。见众菩萨。视之如佛。爱法如己。奉念如来如爱身命。勤归诸佛。其身口意。谨慎无犯。舌根所宣。初无口过。归命圣明。不远佛道。精修慧业。未曾诤乱。十二缘起。弃诸邪见。拔冥树根。消灭闇昧。逮得诸法。智慧光明。劝顺十事诱进之业。智度无极。念之如母。以权方便。计之如父。入佛道业。志性慧解。施戒博闻。慕求寂灭。志积慧德。不以为劳。佛所宣业。除去诸魔众罪尘劳。消去阴盖一切挂碍。开化众生。顺从佛教。精勤奉法。净诸佛土。神通三达。现在目前。是为十慧

菩萨有十事魔所必固。何谓为十。心怀怯弱。魔得其便。其心多念。愦愦匆匆。性不安和。多求无厌。为魔所乱专持一法。自以为是。为魔所困。不能殷勤。兴显正愿。为欲所迷。尘劳所缚。志不寂静。厌于周旋。欲断生死。为魔所回。不能精进勤修道法。而反退还。不肯开化一切众生。唯自护己。不念苦人。狐疑经典。诽谤正法。不肯顺从。是为十事魔所建立

菩萨有十事佛所以立。何谓为十。从初发心。为佛所护。世世所生。不忘道意。觉知魔事。能降伏之。使其退还。假使得闻诸度无极。明彻在心。听便奉行。知生死苦。虽知为苦。不以为劳。观深妙法。不得果证。为诸声闻缘一觉种。而说经法。不随彼学之所好说。观于自然。无所有义。不住无为。于有为无为。不想有二。佛所护者。不以远故。而怀悒戚。入一切智诸通之慧。在菩萨行。显于自在。亦无所断。是为菩萨十事佛所建立

菩萨复有十事法建立法。何谓为十。乐知一切万物无常。为建立法。一切诸法。皆是苦恼。又计诸法。悉无吾我泥洹寂灭。永无处所。计于诸法。悉从缘转。因虚伪退。从习不顺。合于无明十二缘起。至老病死。除不顺念。无明则除。无明已除。生老病死。永悉除矣。其三脱门。成诸声闻。倚于空闲。生缘觉法。六度无极。四等四恩。兴发大乘。解十方土。分别诸法。了于众生。游诸慧明。无所不通。为佛境界。蠲除诸念。断去诸受。入于自然。过去当来。至灭度义。是菩萨法。所建立

菩萨处兜术天。复有十事。何谓为十。处于欲界。为诸天子。说欲恍惚。豪自恣者。示无常事。诸有成就。共同会者。说别离法。劝发道心。在兜术天。是初始教。在于色界。为诸天子。讲善解脱三昧正受。无所兴起。彼于禅定。若有挂碍生恩爱故为贪身故。而现迷惑。分别尘劳。解如真谛。然后乃消一切诸色皆住颠倒。其不解者。思念计净。谓为常存。悉不可贪。当归无常别离之业。劝发道心。是为二事。又族姓子。菩萨处在兜术天时。净光三昧。而自正受。演身光耀。普遍三千大千世界。随众生本。应当度者。演若干品百种异音。众人得闻此经法音。其心坦然。而得开解悉得迁生兜术天上。适得生天。菩萨寻时。劝发道心。是为三事。菩萨处在兜术天时。以无挂碍。菩萨道眼。见于十方诸佛国土诸菩萨等。各在兜术。适见此已。集大法会。显无极变。现来入胎。而复示生。弃国捐王。诣佛树下。庄严道场。讲说前世所造立行。因宿本行。令其得入无极大慧不移所在。而复普现若干形变。开化群萌。是为四事。菩萨处在兜术天时。十方兜术诸菩萨等。悉来见之。谦下恭顺。于时菩萨。咸令欢悦。使其所愿。皆得备悉。口演大法。随诸菩萨。所立住行。应当除者。宜当奉行。当可证明。而为说法。闻其所讲。欢喜踊跃。各还本土。归兜术天。是为五事。菩萨在于兜术天时。见魔波旬。豪贵贪欲。与大营从。相围绕来。欲乱菩萨。即住降制诸魔。金刚履迹之场。智度无极。执权方便。道慧面首。而怀仁和。寂静禁戒。以斯威神。而建立之。如应说法。令魔波旬。不得其便。见于菩萨。所显感动。悉发无上正真道意。是为六事。菩萨在兜术天时。知诸天人。厌于欲界。志乐法会。令欲界中诸有宫殿。自然演声而出音言。今日菩萨。当现宫人。若有睹者。欲意自生。咸共请会。适闻此音。无央数亿百千垓天。悉来集彼。应时菩萨。现诸宫人。其诸天子。古昔以来。所未见闻。端正殊妙。世之希有。见之大悦。视无厌足。悉作伎乐。因从伎乐。演法音声。一切万物。皆归无常。目之所睹。悉为苦本。诸法无我。无身寿命。悉当归空。无为寂安。奉菩萨行。当得至佛。具诸通慧。来会诸天。闻此法音。心怀戚然。不乐贪欲。咸发道心。是为七事。菩萨若在兜术天时。不殁其形。普现十方不可称限无数佛土。诣诸如来。稽首作礼。听所说法。视诸佛尊。辄为班宣阿惟颜事。因本际来。诣通慧地菩萨道住。使人一切道义具足无极普智。发心之顷。悉令解了。是为八事。菩萨若在兜术天时。以其威神。有奉佛法。名好殊特。普遍十方诸佛国土。供养如来。无量清净。宣不可计。现诸法界。归虚空界。诸天人民见此供养。不可计人。皆发无上正真道意。是为九事。菩萨若在兜术天时。入于无量诸法道柔。演慧光明。现于十方不可称限诸佛世界若干色像。不可计限威仪礼节。各各则异。所作随时。为分别说。若干种法。剖判训诲。随众生心。本行志愿。各令解达。是为十事。是为菩萨在兜术天所现十事。然后乃生。现于人间

菩萨现没兜术天有十事。何谓为十。于时菩萨。在兜术天。有光名曰安隐清净。演此明曜。从足底出。照于三千大千世界。皆为大明。其在恶趣三涂之难。地狱饿鬼畜生之厄。周旋往返。适蒙此光皆获大安。息众苦患。适遇安已。心自念言。诸贤者等。更有异人。来生此界。于冥睹明。相见喜惊。斯为菩萨现舍兜术天。是为一事。复次在兜术天。光名劝助。从其眉间。演是明时。遍照三千大千世界。耀诸宿世所行菩萨。适演此明。耀大千国。请诸菩萨已。于时菩萨。德行已备。舍兜术天。诸天龙神。一切皆来。供养菩萨。其心欣然。悉发道意。是为二事。菩萨若在兜术天时。光名净界。从其右掌。复演此光。普照三千大千世界。则成严净。彼诸缘觉。无诸漏者。即时其光。徙着异国。其不徙者。便舍寿命。而般泥洹。诸外异学。裸形露精。迷惑倒见。众生之类。亦复见徒。着于他方。所见徙者。如来圣旨。亦是黎庶。缘此因缘。而见开化。是为三事。在兜术天时。有光名曰离垢显耀。从菩萨身。演此明耀。照下诸天。乃上至阿迦腻吒二十四天。处兜术宫。诸天子等。各各心念言。今日菩萨。舍兜术天。各怀愁戚。各各执取华香。杂香捣香。缯盖幢幡。鼓诸琴筝。歌颂其德。而作伎乐。诣菩萨所。而供养之。稽首礼敬。奉事不休。至成佛道。现大灭度。是为四事。又族姓子。菩萨若在兜术天时。有光名曰莫能胜幢。因头冠帻体璎珞。于其心藏。演此明耀。其中畅出。普照十方诸金刚神。应时百亿金刚诸神。皆来集会。侍菩萨后。成佛已去。至大灭度。是为五事。复次有光。名解众生。应时菩萨。从身诸毛。演此明耀。悉照三千大千世界。辉菩萨体照诸天人一切宫殿。应时各念。吾等开士。当化众生。奉敬如来。是为六事。复次有光。名积善住。因从菩萨大宝珠藏。演无极明。此光明珠。化出大殿。往至菩萨生处家国。于其家中。光照十方郡国县邑州域大邦诸有家居。其应化者。咸来就之。生其土界。是为七事。复次有光。名普严宫。演此明耀。菩萨寻时。出普严净大宝阁殿与大宝殿。住于母胎。近其右胁。光明这照。应时其母。普得安隐。住于一切德功勋之护菩萨母胎。菩萨处此大宝宫殿游居。是为八事。复次有光。名曰停住。而出菩萨于足底下。其诸天子。处在欲界及诸梵天。常怀恭恪。奉敬菩萨。因其命尽欲终之时。故谓菩萨。续在故处。光明来照。虽在天上。堪奉如来。光明遍照。诸天子等。即更安住。不复寿终。供养菩萨。乃至成佛。现大灭度。是为九事。复次有光。名若干目。因从菩萨诸好中出。演此明时。现众菩萨各各异变无量功德。彼诸天人。遥见菩萨住兜术天。或现来下。入母胎中。或见甫生。或见出家。或见成佛。或见转法轮。或见灭度。是为十事。在兜术天现没来生。计是菩萨十品光明。而显具足无央数亿百千明曜。出菩萨身。不计床座楼阁宫殿。所出光曜。现若干种菩萨事业所可兴为。巍巍如此。普备道法

度世品经卷第五度世品经第六

        西晋元康元年月氏沙门竺法护译

菩萨住胎有十事。何谓为十。欲得开化志住小乘。怀怯羸劣众生之等。菩萨悉见此辈心念。故现入胎。或恐此等。心发念言。菩萨化生。德本自然。不可学得。故现入胎。是为一事。菩萨悉为父母亲属往古宿世同学徒类及余黎庶。俱殖德本。欲度此党。故现入胎。或复有人。宿世积德。因其胎中。应受开化。是为二事。菩萨大士。心未曾妄安隐庠序。而意常定。是为三事。菩萨若现在母胎时。讲法圣众。未曾断绝。十方世界诸菩萨释梵四天王俱来聚会。示现无数不可称计无际圣慧。在于胎中。显其辩才。而有殊持。就度脱之。是为四事。菩萨若在母胎中时。合大众会及诸开士。悉欲来集。因本所誓。欲度脱之。故为说法。皆使得济。是为五事。又欲开化世间人民成最正觉。皆备众德。庄严道场故。以示现生于人间。是为六事。菩萨虽处在母胎中。普身示在三千大千世界。犹如明镜见其面像。其志微妙。大乘学士。诸天龙神。揵沓和。阿须伦。迦留罗。甄陀罗。摩睺勒。诸人及与非人。各心念言。我往稽首归命供养菩萨。是为七事。菩萨在于母胎中时。有大法门。名曰大慧藏。游到他方异佛国土。最后究竟。在胎菩萨。俱共论讲。由是之故。使其菩萨。现入母胎。是为八事。菩萨现入母胎中时。有三昧名离垢藏。承定意成。不近母胎。在兜术天。入于清净。住母胎中。亦无所入。是为九事。又如来至真。有大功德。名离垢藏华。而见奉敬供养如来之业。是诸觉佛。在母胎时。菩萨圣旨。皆遍十方。以真大圣。诸菩萨众有行。名曰法界藏。为讲此教。入无极慧。菩萨因是。现十善微妙游居。而立大安

菩萨有十事。现其安详。何谓为十。于是菩萨。入母胎时。从初发意。乃至现于阿惟颜法。成具佛业。若入母胎。续复自示在兜术天。或复来下。现入母胎。已复出生。故在母胎。或示幼僮。不舍母胎。示现在于宫采女中。显母胎中。复示出生。固在母胎。示于精进勤苦之行。现诣道场。坐于树下。得佛正觉。复现在胎。而转法轮。在于胎中。现取灭度。游母胎中。庠序劝进。入乎大道。在彼胎止。而普示现诸菩萨行。建立如来无极大道怀来道门。是为菩萨现于十事庠序之行

菩萨修生有十事。何谓为十。菩萨悉明。其意安然。现生清和。演大光明。周遍三千大千世界。最后究竟。不复更生。而现所生。无起不灭。故曰为生。思惟三界。所生受者。犹如幻化。现身出生十方世界。其身显示。致一切智如来至真。皆演威耀。告敕一切诸有身者。积累大慧三昧正受。然后乃生。菩萨适生。动诸佛国。令众生类心怀欢然。消诸恶趣。蔽众魔事。各各惊言。今者菩萨。从某处来。是为菩萨十修所生

菩萨忻笑有十事。何谓为十。察其世俗。缚在贪欲。而自缠绵。无能拔者。独吾身力。乃能堪任。溃于斯党。是故而发笑耳。俗人多为尘劳之所迷惑。自谓智慧无能逮者。是故菩萨。而发忻笑。自大游逸。我身名号。如此无上。如来。便以法身。显示大要。遍于三世。令各生意。求欲致是。诸菩萨眼。无所挂碍。从十方土。至梵天宫。乃复至于大神妙天。皆观本末。便自念言。是众生党。乃尔瑕秽。菩萨智力。悉睹见之。又见人民。宿积德本。还复堕落。见殖少福。望无量报。睹平等觉正真之道。无有侵欺。观古亲友。本时同学。志菩萨道。各各修净。未具佛法。己己为达。察本所居诸天人民。及在愚地。不解正法。心不动摇。不以为劳。如来至真。有演光明。名大摇安。放此大耀。是为菩萨十事忻笑

菩萨行七步有十事。何谓为十。菩萨尔时。自现幼僮。举足七步。示有七财。显有殊异。欲使地神所愿具足。自示其德超于三界独步无侣。游如龙王。住若象王。举动进止。如师子步。诸有往反所至到处。菩萨行步。周旋举动。皆越一切。当时天地。变为金刚。其余凡地。不动堪任。载持菩萨。抚育一切诸地众生。是故菩萨。举足七步。又一切人。不解道义。故复菩萨。举足七步。应七觉意。觉诸不觉。以逮正法。无所依仰。吾于世尊。豪无有上。口自发言。天上天下。吾当度之。是为菩萨十事行步

菩萨现幼僮地复有十事。何谓为十。悉知书疏算术计校。所当应宜。答报言辞。无所不通。故以是事。显示众人。又复示现上马骗象。乘车往反。神仙咒术。与众超异。摴蒱博掩。伎乐歌戏。超群越众。其身口意。示有罪福。而无殃衅。以无憍慢。三昧正受。遍于无量诸佛世界。现在众生。而开化之。菩萨显德。其慧过于天龙鬼神。阿须轮。迦留罗。甄陀罗。摩睺勒。释梵四天王。咸来归命。又复自示释梵四王。色貌形像。复以菩萨。容貌自示。显其道业。菩萨现于人民各异。若有贪乐。爱欲调戏。或复愁忧愦乱众生。为现欢悦。令爱乐法。常以法会。有所长益。奉敬如来。遍见十方。以法光明如来威神。现其安详。清和默然。因化众生。是菩萨。现其幼僮。在于后宫。多所救济。菩萨现在中宫处采女中

复有十事。何谓为十。与其宿世。俱共同学。菩萨因欲化此众生。显示德本。故在后宫。菩萨又以殖德本者。应当勉济。故现后宫。诸天人民。憍豪自恣。富贵自绮。因此菩萨。现大豪贵尊。因而降化。在五浊世。随时诱进。化度佛土。虽在中宫。不废三昧。势力无双。往古众生。兴立誓愿。菩萨欲使如意悉得。故现后宫。欲令父母家室亲属。本愿备悉。以大法音伎乐歌颂。箜篌乐器。奉敬供养如来至真。佥令效之。于时菩萨。在于后宫。了成佛道。定意不动。从初至终。成最正觉。而转法轮。至大灭度。所以示现。以法护之。救济危厄。使入大道。是为菩萨现在后宫。最末究竟。弃国捐王。入山得道

菩萨舍国复有十事。何谓为十。示厌尘欲。故现出家。见于世俗多所染着。欲使众人不猗瑕疵。显现贤圣正真履迹柔顺之义。菩萨居业。欲畅道化。叹出家德。以权方便。现于二际。堕在诸疑六十二见。拔之令出。众生贪欲。勤勤为安。为显众难。使弃所猗安乐之想。为着三界。驰逸众类。示现先应。故出家耳。其意兴盛。无所依仰。猗不可计。故现出家。又示逮得如来十力。四无所畏。随时而教。最后究竟。临当成佛。法应当然。是为菩萨十事弃国捐王

菩萨现勤苦行复有十事。何谓为十。欲得开化小学之士。故现六年进一麻米。又欲勖勉猗着诸邪六十二见。为诸失德众生之党。指示其业罪福之报。亦为杂秽迷惑世界。随时劝导。现己劳患。能伏情欲。示二等业。缘是之故。受真谛法。诸贪受欲。重自安己。驰逸众生。令净其心。又复示现菩萨精进。勤苦志道。最于后世。临欲成佛。示不更生。用精进故。诸天人民。根不纯淑。及外异学。使从训诲。是为菩萨示十苦行

菩萨诣道场复有十事。何谓为十。演大光明。照于十方。使众知之。故诣树下。亦欲感动诸佛国土。显示己身。使普佛土。皆共见之。又复畅示诸菩萨等及诸众生前世所行。悉来从斯。稽首受学。现其道场。所坐树下。庄严清净。随众人本。应时现身。威仪礼节。佛树静然。使诸世界如来至真。各自现身。诸可经行。举足下足。常修三昧。不离定意。觉了圣道。不犯须臾。诸天龙王。揵沓和。阿须伦。迦留罗。甄陀罗。摩睺勒。释梵四王。现来奉敬。众人见之。莫不发意。大慧无碍。菩萨所行。普观十方。念诸如来。晓了方面。在诸国土。现成正觉。是为菩萨现诣佛树

菩萨坐佛树下复有十事。何谓为十。以无数事。动诸佛国。故坐树下。皆欲照耀十方世界。而悉消除一切恶趣。亦复建立一切境土。咸为金刚。观诸如来处师子床。心所思念。等如虚空。现身威仪。咸以随时。归趣金刚道场三昧。其诸如来所止之处。受于清净。自承势力。以趣德本。劝立一切群生之类。是为十事坐佛树下

菩萨坐尊树下有十致未曾有。何谓为十。坐佛树时。致未曾有自然之法。十方世界诸如来至真等正觉。各现面像。伸其右掌。各自赞叹。当使导师得胜。得胜则是第一未曾有法。菩萨若复坐佛树时。一切诸佛。皆共念之。遣威神往。是为二事。坐佛树时。古昔同学。诸菩萨等。佥俱来至。周匝宿卫。住定意门。以若干物。而供养之。是为三事。在树下时。十方世界。草木华实。及诸药树。虽无神识。自然屈形。悉共曲躬。向于佛树。而稽首礼。是为四事。有大定意。号积法界。超越一切诸菩萨行。假使逮得此定意时。其功德明。越众开士。是为五事。于时菩萨。立身海藏离垢光曜总持之场。使诸如来。阐大法雨。是为六事。则以柔软顶之度去。供养如来。菩萨坐于树下。普游诸国。无所不遍。是为七事。菩萨若坐佛树下时。其行亦如慧上开士。普见一切众生根本心念所奏。是为八事。坐佛树时。自然善致佛圣觉定。适得斯定。普周无量三世之事。犹如虚空。是为九事。坐佛树时。则以己身。明识三世。其大圣慧。而无等伦。演离垢光。是为十事未曾有法

菩萨何谓降魔官。有十事降魔官属。何谓为十。众生同尘。着于世俗生死之患。不乐战斗。是故菩萨。现大势力降魔官属。诸天人民。贡高求名。欲为除断自大之难。佛欲开化魔及兵众。诸天人民。佥共娱乐。俱来聚会。因是化之。菩萨力势。无有双比。亦复显现。欲使人知。亦欲劝悦一切众生。显其利议。亦欲愍伤将来世人。在佛树下。降魔官时。悉已越度诸魔境界。无有尘欲无力不力。见诸薄力。而现德本。示慈心力。降魔官属。随时劝悦。爱欲尘劳贪欲之世。化以道法。观此十义。是故菩萨。降魔官属

菩萨成最正觉示如来力亦有十事。何谓为十。能伏诸魔业尘劳之秽。具菩萨行。乐诸菩萨一切定意。而以自娱上众开士圣慧之堂。究竟成就诸清白法。一切行义。为诸世间。善思惟行。其身普遍十方世界。演其音向。等心众生。皆畅威神。而建立之。过去当来今现在佛。如来至真。身口心等。无所望想。一时之间。普达三世。有三昧名善觉觉意。得是定时。入佛十力。以能兴此。处处有力。至漏尽慧。是为菩萨如来十力成最正觉。住是力时。诸佛普至。故曰如来已成正觉

如来至真。则以十品而转法轮。何谓为十。致四无畏。入清净慧。而畅慧音四分别辩。又善晓了。越于四谛游居无碍正觉脱门。旷意愍念一切群生。消除不顺侵枉苦恼悒戚之患不闲之难。不违往昔无盖之哀。清净和辞。周十方界。无央数劫。颁宣经法。不以劳懈。善分别解根力觉意一心悦门禅定正受。是为十品成正觉时。以无量义而转法轮。已成如来至真等正觉转于法轮。十清白法。观众生心。愦愦无闲。欢悦其志。令得亘然。何谓为十。前世宿命。所愿力势之所致也。不违本誓。威神建立无极大哀不舍众生而救济之。兴显圣慧而为说法。随时建立而宣传之。应时令解使无缺漏。明识解了三世之慧。其身所行永无所造。其意所宣无有形想。所畅慧者随音辄解。是为十事。清白之法而转法轮

如来至真以作佛事。观见十义现大灭度。何谓为十。常为示现。审谛非常。一切有为。显如呼噏。普诣安处无为之真。除诸恐惧。诸天人民。着于色身。故现色身如是无常。法身常存。而为分别。合有别离。诸所有为。弹指已过豪无坚强。一切三界犹如幻化。众想危脆无为最坚。为现道法。无有毁坏。诸习离别。悉无所成。为示碎散。法自应然。诸佛世尊。所作佛事。皆已具足。善转法轮。决狐疑。令随律教。授菩萨决。无有进退。修大灭度。是十观义如来至真取灭度矣。无有没化

普贤复白。是为佛子名菩萨行净大法道门。吾今所演法门之要。粗举都较。如来至真。所颁宣义。不可限量。悦众明智诸菩萨行。皆承大愿。未曾断绝。假使人闻。欢喜信者。心以怀信。则习奉行。成就此义。皆当疾成无上正真之道为最正觉。所以者何。计菩萨道。以行为要。未曾离行。是故菩萨大士。当住于行。以能行此菩萨功勋。入分别义。好如莲华。辄能得入一切法门无极圣室。度世径路。离于声闻一切缘觉之径路也。化诸众生。无所怀侠。咸照一切法经法门。劝诸群黎。使得长益。度世法门。当至心听度世法品。受持讽诵。一心思惟。修道目门。奉遵所愿。行如是已。菩萨所求。终不难得。疾成无上正真之道。说是经时。宣说法门。演度世法品。十方无量不可计会诸佛世界。为大震动。皆佛威神之所兴化。宣致此法。得是经典。一切佛土。自然动者。而大光明。靡所不耀。十方诸佛。皆各现身。而遥赞叹普贤菩萨。善哉善哉。最胜之子。随时讲说菩萨大士功勋之德。分别正义。一何快乎。开阐班宣度世法品。如汝佛子。本学真谛。解达斯法。今者善说承经威德光明清净经典之要。我等悉解。诸佛亦然。吾等亦共称誉此经。于今现在十方诸佛。为诸当来诸菩萨。学未闻者。施慈恩广大。乃如是乎

于是普贤菩萨大士。承佛圣旨。十方众圣之所接护。观于十方。察诸众会。普瞻法界。而说颂曰

  修千亿兆劫　　勤奉难限量
  归千载垓佛　　因生诸法子
  开化于众生　　立道无崖底
  咸共一心听　　叹佛无等伦
  供佛不可限　　已不着佛道
  解群黎庶欲　　不想计有人
  见佛之功德　　不依其名勋
  嗟叹彼尊行　　欢悦世巍巍
  已除罪尘魔　　普现于三世
  其德超众圣　　显殊异力行
  烧尽痴爱行　　志性在寂寞
  现行众齐限　　今当叹功勋
  最圣所过度　　众生趣如幻
  为示若干变　　令人除自大
  适发心之顷　　普能悉晓了
  今叹彼功勋　　众生所奉敬
  睹苦恼众生　　五径生老患
  终亡忧戚危　　爱欲所伤害
  愍欲度此等　　故建广尊慧
  当叹此功勋　　且共一心听
  施戒忍精进　　一心以自娱
  权慧度无极　　施以无极慈
  悲喜乐于法　　百千劫护行
  今当叹此行　　听所说功德
  以求佛道故　　消千亿垓身
  不贪惜躯命　　是为殊道真
  精勤为众生　　常覆欲安己
  叹能仁超行　　志怀愍哀慈
  无数千亿载　　劫数叹名称
  以一毛取水　　尚可尽大海
  所行精进德　　过是不可喻
  且听佛境界　　所现愍群庶
  为众生之故　　长清白德本
  志性不卒暴　　不厌道法乐
  建立众生处　　慧江渊智树
  世尊如天地　　群黎常戴仰
  慈濡愍为根　　护禁仁为茎
  尊勋慧华叶　　戒香甚清净
  悟诸不觉意　　众生爱敬行
  无著等莲华　　众生见归命
  解脱为种稷　　身本性怀慈
  智慧善权术　　五枝度彼岸
  禅叶神通华　　一切智慧实
  神足尊法树　　弘覆于三界
  本修清净迹　　长育广慧义
  师子颈颐念　　智慧净缯首
  空慧义第一　　慈愍度世明
  无我如师子　　能吼降众魔
  得越生死旷　　众民邪尘欲
  度所有家业　　奉要行除愚
  迷惑示正路　　显佛无上道
  立志无恐畏　　为殊胜导师
  众生淫怒痴　　冥尘若干弊
  长夜随有为　　苦父母所恼
  见群黎出生　　以哀疗爱欲
  讲八万四千　　用治弃众病
  此降伏魔尘　　以法训众生
  弃恶无所习　　求严净佛德
  解法两足帝　　一切智慧尊
  以贤圣之财　　实广觉冥众
  戒三昧自娱　　以圣净智慧
  用明达刀刃　　度尘无恐惧
  作变于法幻　　因转最法轮
  亦不退回还　　一切异学意
  晓了深尽慧　　普生其法味
  觉意宝神足　　开难化民庶
  住千通慧力　　严净三为君
  斯为大慧海　　无双说无尽
  以越度世俗　　不着三处众
  以成禅神通　　慧如山不动
  其有比清净　　无及智慧明
  德圣超须弥　　愍住众生仰
  性强若金刚　　所修皆要固
  其心不可毁　　重法奉普智
  游众魔尘欲　　在世住无畏
  消恩爱然炽　　总摄俗群黎
  普布于慈雨　　演愍哀光[火*僉]
  四神足雷鸣　　能仁寂畅音
  雨四分别辨　　清和八品道
  以此大阴雨　　清灭众尘劳
  智垣墙耻堑　　[立*寺]法幢为幡
  圣如墙解门　　意念守门者
  四谛成径路　　净神足严迹
  法幻为城郭　　主三界降魔
  树心一切智　　坚住足飞行
  如鸟独游行　　慈愍为明曜
  教化如凤凰　　众生无能逮
  拔度生死海　　立志上泥洹
  以戒定道场　　兴慧华鬘净
  以明消尘劳　　枯竭恩爱流
  增长药根力　　净众佛上道
  则奋法日光　　以照众生界
  法境场等净　　不舍等众生
  一切照诸学　　声闻缘觉乘
  心普见三世　　消念所增损
  意圣慧超异　　畅众生如空
  于法得自在　　在众严德像
  兴明执金刚　　常立在法地
  身相若干好　　清净超诸世
  为众积经典　　群黎最尊法
  以越于三世　　爱网众尘劳
  慈愍诸世俗　　乐法作慈护
  现身于三界　　法音告一切
  清净犹如梵　　济邪见无乐
  清净度生死　　境界法豪尊
  不复重退还　　大意摄蠕动
  法尊超于世　　以慧怀来众
  一切功勋最　　大称普流世
  自然如虚空　　除一切颠倒
  在众造超异　　永不着诸界
  普入清净行　　亦建立众生
  其智极玄妙　　斯慧净复净
  权便旷如地　　普遍五众生
  其慈犹如水　　洗除众尘欲
  以慧消爱欲　　拔济众穿漏
  世尊无崖底　　游三界如风
  斯党犹如宝　　济诸贫乏道
  如金刚无侣　　弃三处诸见
  其音若干品　　普德严三界
  尊如夜明珠　　其行立首顶
  功勋如众华　　觉意以自娱
  斯等如华鬘　　超世誓正愿
  其戒香清净　　完具无缺漏
  以净涂法香　　慧布于三处
  其行如高盖　　覆去尘劳欲
  以跱立慧幢　　执意无二迹
  以行杂幡彩　　修慧而悬智
  谛羞耻衣服　　以德覆众生
  无量界居乘　　驰游于三世
  调定如龙象　　其心常坚住
  神足游三世　　越度大重担
  亦如大龙王　　所布云法水
  亦如灵瑞华　　众人所难遇
  斯等如勇好　　降魔拔尘劳
  亦如无转轮　　导师所颁宣
  现群黎终始　　如冥中火炬
  其德如江河　　顺路如流水
  斯等如桥梁　　常执载一切
  如严净舟船　　以慧愿度渊
  亦复如船师　　住众明地最
  游观夜娱乐　　为众显真乐
  以慧法脱门　　严慧净宫殿
  亦复如众药　　消除尘劳病
  如雪山杂药　　妙慧为屋宅
  其行如正觉　　慧寤诸睡寐
  其道平等觉　　等心了众生
  斯所从来处　　如胜行诚信
  犹若一切智　　入普门慧室
  斯等多所化　　济若干众生
  以自在佛慧　　游一切智界
  其力不可量　　一切莫能当
  其慧无所畏　　解慧晓众生
  一切民庶像　　颜貌名无济
  诸色皆平等　　字类诸音声
  悉度众色像　　离名音能现
  一切众生类　　不任宣德耀
  其修此功勋　　舍非建立法
  现在为慧父　　以远有无际
  则为一切智　　于慧第一明
  嗟入无著行　　遵敬欢悦世
  解了诸法门　　如幻常空寂
  往古愿行哀　　亦承佛圣旨
  离慢显惠门　　而现若干变
  皆共一心听　　菩萨之功勋
  则以一身形　　广现无数德
  无心意境界　　众生不见心
  演出一音声　　越诸辞境界
  随一切群黎　　言语而班宣
  以舍众生身　　欲报所行体
  解音无所有　　而畅众声教
  心寂寞显耀　　觉谛如虚空
  黎庶世各异　　亦为示若干
  究竟无有身　　尚复现有形
  随众之所生　　得立报应果
  皆入诸所生　　不着于所生
  己身如虚空　　不想若干人
  其身不可量　　明智悉能现
  奉敬天人尊　　归世一切智
  华香杂捣香　　妓乐缯幡盖
  身命自投地　　供养上圣尊
  住一最胜下　　皆立诸佛前
  睹见诸众舍　　常问无等伦
  闻法逮三昧　　一台无量门
  从本所学住　　意勇现无量
  善权智慧业　　以度于彼岸
  晓众生如幻　　自致得佛道
  遍见别异心　　无量色音声
  入于求望想　　无著普现众
  或复现第一　　为众生显心
  或有行道者　　见无量黎庶
  布施戒忍辱　　精进禅智惠
  或受梵迹行　　或现上妙行
  或有行成满　　得忍示嗔恚
  一及生究竟　　或阿惟颜佛
  或显声闻像　　或复为缘觉
  亿载国现灭　　亦复不灭度
  或斯刀利释　　须伦梵天王
  玉女诸眷属　　或复独游步
  比丘心寂寞　　或复为国主
  入法网慧界　　或显妙色像
  从天而没来　　或现女人像
  所度于无极　　或现在露精
  或在广欲禅　　若积忍辱业
  晓逮真谛地　　现目见心行
  或示入胞胎　　于胎成正觉
  而复转法轮　　或生显灭度
  或复学技术　　女人中三昧
  众业已备悉　　现弃国捐王
  或复佛树下　　逮成最正觉
  或现转法轮　　显现若干品
  或佛化众生　　遍亿千国土
  示现不退行　　佛亦无寂业
  入想度无极　　游于亿千劫
  一心所显现　　境界百千劫
  诸想无有想　　为众现劫数
  无疑无所说　　而现有周旋
  见有作寂业　　普降于众生
  皆由降伏胜　　彼处为澹泊
  佛国众生界　　入诸法报应
  究竟百亿劫　　所宣不可穷
  入众生如是　　广智晓黎庶
  则以一人身　　报无量变形
  亦以一幻术　　常悉周一切
  此说度无极　　教诸不学者
  解诸根通利　　中间调定本
  诸根得自在　　众生无有业
  一根入诸根　　各各怀贪猗
  禅灭甚微妙　　所住诸入根
  是脱信施性　　不止尘欲行
  过去当来心　　现在亦如是
  众生度彼岸　　无去亦无来
  尽晓真谛行　　为众演上法
  心如此若干　　心行尘无漏
  一心入正道　　甚解一切智
  心在佛无心　　住第一上慧
  一发心之顷　　解别自然慧
  神足度无极　　识别一切圣
  神通发念顷　　至无量载国
  普游亦如是　　亿百那术劫
  宣智不可量　　不动普彻力
  幻师求财业　　众中见诸像
  无色见诸色　　幻者无所有
  权慧亦如是　　入于广法幻
  现若干种变　　普遍于世间
  如日在虚空　　清净无微翳
  犹如清净水　　见底之所有
  法界场净然　　慧明为远照
  见人界清净　　心不住邪见
  如梦种种思　　觉则无所有
  无数亿载岁　　长夜不可尽
  自然法等然　　普现一切义
  竟住百千劫　　一时须尽慧
  处世间方俗　　如山顶门阃
  一切所畅音　　不想己说慧
  菩萨晓了此　　诸法自然尔
  随众生言向　　现法音无想
  譬如春夏日　　野马人起想
  驰走谓有水　　虚渴益更甚
  众生欲兴如　　志求立解脱
  得慧无人想　　慈愍益更兴
  佛说色如沫　　痛痒如水泡
  想悉如野马　　行者譬芭蕉
  其心犹如幻　　识现若干变
  演五阴如此　　达者无所著
  诸入空自然　　随己有所作
  以等于法界　　现离众生土
  六事寂真谛　　说若干不定
  是为分别解　　诸法所猗着
  无来无去处　　亦无常住处
  恩爱之报应　　罪福转三世
  分别因缘生　　无住而拔者
  至成求本末　　依猗无所有
  了三世一等　　一时现若干
  在欲无色界　　普能显境土
  从行致三护　　济脱于三处
  咨嗟宣三乘　　归一一切智
  剖判法处处　　令度诸根原
  已解尘劳界　　自在普游居
  识念过去事　　明眼灭尘劳
  旷慧佛十力　　亦不得诸力
  觉一切空意　　现观众生法
  无爱欲穿漏　　亦不得尽傥
  入于诸所生　　慧广不失众
  胜子勇住此　　善施撰释行
  不缺不动道　　其意不忽忘
  好精进定意　　智慧消诸秽
  悉造慧法护　　今现于三世
  慈法众生侣　　无为无所得
  其行此法门　　逮致宣扬德
  粗举其功勋　　庄严诸至义
  嗟叹其所行　　亿载劫无尽
  粗举其要惠　　如取地一尘
  依猗佛圣慧　　住未曾想念
  精进坚慈心　　超遵一切业
  劝众而教化　　禅戒不可动
  逮得正决行　　皆号为佛子
  通入佛功勋　　念国众生行
  入于无二想　　惠超无厌难
  得辨力总持　　度以真谛义
  赞无等伦心　　逮成最正觉
  普思贤功称　　誓愿尊妙行
  愍哀缘修慈　　近尊净妙道
  解净度无极　　究竟权灭度
  识别得势力　　逮成最上道
  解致普等惠　　颁宣最上法
  超德执圣铠　　在道遵法位
  究竟住圣旨　　等心除雷音
  御慧化慢迹　　得致和佛道
  智建立无想　　致抚育之堂
  住深猗勇猛　　蠲除众生疑
  思慧次第法　　善报度无极
  下入平等迹　　慧部觉普智
  以度杂碎智　　神通自娱乐
  明照脱尘劳　　为众生苑囿
  清净行宫殿　　现若干妙行
  示众无所净　　其心不动摇
  究畅志性明　　善说度无极
  严净道见中　　奋慧光明曜
  无双无怯弱　　其意如太山
  德行至无极　　智如海无尽
  若宝室金刚　　坚住大德铠
  所设极广大　　善解莫能坏
  授决当至道　　由住广大心
  得佛无尽藏　　觉成一切智
  常护慧自在　　晓了现变化
  众生国法界　　住慧显权变
  身愿建游行　　慧变亦如是
  现亿载无量　　以悦乐黎庶
  显力神通飞　　究畅娱乐力
  逮致觉境界　　难化众生类
  勇猛无所畏　　严智无言辞
  一切为佛子　　其身大清净
  体业甚广长　　口言亦清净
  乐建慧至成　　最胜造十业
  心心发其心　　显遍最为上
  定意教诸根　　胜诸原坚住
  清净除谀谄　　性行常质直
  以致入解脱　　现众若干变
  弃捐所止处　　执怀上品业
  成其所当善　　解达一切智
  不舍住寂然　　住于上澹泊
  出生号功勋　　善学于大道
  求心无量业　　奉行无所著
  现道庶流渊　　坚立入众生
  所行以为手　　腹强慧最上
  其意如金刚　　愍铠圣净状
  智慧首观法　　识道行博闻
  戒香为清净　　动静为最上
  身心游言辨　　心慧为最胜
  所行至佛道　　坐于师子床
  梵行迹卧寐　　最空行无为
  明为往安界　　光所照若斯
  观察知众生　　行若干频伸
  布施离悭贪　　不轻慢禁戒
  忍辱舍嗔恚　　精进最第一
  禅智得自在　　慈心等众生
  愍哀无厌法　　清净尽尘劳
  义寂顺道法　　以福施众生
  圣慧利如犀　　明智照广远
  博闻无厌足　　无畏拔妄想
  制己立在行　　得脱魔径路
  所修佛慧业　　志性稽首奉
  弃捐于贡高　　常遵为道义
  勖勉魔所困　　从佛之威神
  大意随法教　　总义至无上
  所作后追身　　趣严度无极
  所生现豪尊　　初生行七步
  普显诸伎术　　示现处后宫
  弃家无所慕　　修道至止本
  近空光明耀　　习广至诚业
  降魔逮上道　　转法轮之迹
  示在佛道地　　大师无等伦
  此行无崖底　　粗现或广远
  积行亿载劫　　以是为娱乐
  亿百千众生　　精修住佛德
  法者无有人　　及着一切行
  此行合慧义　　神通以自娱
  亿千诸国土　　万百千载劫
  手掌擎周行　　亿载国不劳
  寻能还复处　　不逼恼众生
  诸佛国严净　　现之如有限
  皆令众生类　　入于一毛孔
  使其四大海　　在于一毛孔
  不增亦不减　　益众无迫恼
  掌捉大铁围　　亿垓如一尘
  移亿江沙土　　还复着故处
  取国并其土　　或有破坏者
  以无心降伏　　所入不可尽
  假令百千日　　一切月照众
  明珠大炎光　　及诸天须伦
  演一毛之光　　其耀超亿载
  演无上法已　　皆消世恶趣
  若干种言音　　众生无余辞
  畅一音教已　　皆周入诸训
  得闻柔软音　　巨亿众忻然
  佛所讲法音　　咸共悉听之
  计其过去劫　　而睹当来事
  若当来现在　　为显过去行
  示限诸佛土　　危坏复还复
  以诸众生亿　　悉具入一毛
  十方佛威神　　建立得越度
  皆己身真现　　感动现变化
  明者住无慢　　晓了众生心
  随其身示现　　离垢不贪己
  一切诸人身　　口言所归趣
  释梵四天王　　诸天及世人
  声闻缘觉乘　　皆从佛身出
  示奉行佛道　　至于一切智
  皆入思想罔　　清净中瑕秽
  建立于普智　　常现佛道国
  念分别思想　　总世自在智
  从其本行道　　国为现所修
  所感动如此　　善广极现上
  世俗所不及　　为现如斯教
  所现无所现　　复能有过者
  因黎庶性行　　为显真谛业
  其身等如空　　其名闻三世
  戒香衣自勋　　寂然德庄严
  被法离垢缯　　普智如意珠
  明智已备悉　　功勋住普智
  逮度无极轮　　常施最神通
  慧神足无碍　　至智上明珠
  其行净妙女　　殊胜摄四恩
  唱导以善权　　德善本法轮
  居空定意尊　　慈愍铠为城
  弓弩智惠意　　诸根明为箭
  建立为世盖　　圣慧[立*寺]幢幡
  因降诸魔势　　伏以忍辱力
  土地摄总持　　行慧渊智树
  觉意华三昧　　神足严娱乐
  解空为浴池　　脱门要净妻
  晓法甘露食　　乐戏以三乘
  是行为最尊　　殊妙不过此
  亿垓百千劫　　未曾兴懈惓
  恭敬圣净土　　晓众乐无住
  立慧诸妙乐　　具足一切智
  勇猛计诸国　　天雨消诸秽
  众妙尚可尽　　虚空亦可度
  须臾一时间　　可晓众心念
  嗟叹诸佛子　　百千劫无尽
  欲致净功勋　　慧无能过者
  济度众苦患　　令立于永安
  至无尽平等　　安住身口意
  当坚固其心　　造行如金刚

普贤菩萨。说是语时。三千大千世界。六反震动。其大光明。普照十方。箜篌乐器。不鼓自鸣。诸天人民。莫不欣庆。声闻弟子。皆来归命。诸菩萨等。皆言其诚。一切众会。皆共欢然。悉发无上正真道意

普智菩萨。复白佛言。道从有言。无言致乎。佛言。亦从有言。亦从无言。堕在五趣生死之难。五阴六衰。所见羁绊。十二因缘六十二见。扰扰不安。或十二海。不度彼岸。此诸事业。百千种病。故佛设教。施以法药。戒定慧解。度知见品四等四恩。三十七品。六度无极。十二部经。空无想愿。四谛三脱。及以三宝。以用疗治此诸秽病。药为病施。无病无药。三毒众秽。皆为重病。至正真慧。而曰不病。因缘所缚。不解道者。故佛为畅。晓喻文说聚沫水泡。芭蕉野马。影向幻化。梦月荒忽。以解其意。此事皆虚。因或而生。不贪世俗。习道法药。六度四等。四恩众事。奉行此业。得至于道。解诸言教。本皆无言。或有佛土。无有五阴六衰三毒因缘之缚。故无文说。无身无言。虚静寂寞。解无三界。不住有为。不处无为。不处中间。是为名曰从无言致

普智复问。今者众会。来集于此。或有深解。诸根明彻。或有中人。可进可退。或有下士。不智所趣。达者无疑。中间下士。皆怀犹豫。所以者何。闻吾向者问二百事。普贤菩萨。答以二千。各心念言。事物烦闹。不知何事。可奉可舍。愿佛分别。开解其意。以何等故。事有二百。答以二千。佛言。善哉善哉。所问一何快乎。决将来疑。令诸学者不挟经罔。佛言谛听。善思念之。当为汝说是义所趣。答言受教。佛言用有二故。故问二百。何谓为二。有神贪身计。有吾我。有内有外。在有在无。故问二百又复问曰。用有此计。故有生死。何故复郑重。问二百事。世尊告曰。其二百事。所咨问。皆除吾我内外有无。则以权慧。开化无际。不得内外。乃得至道。开化一切

普智复问。普贤菩萨。何故复重二千事答。世尊告曰。十方一切皆来集会。其心各异意行不同。达者闻要。则以至道。不能达者。为演多辞。晓喻文说。牵攀义旨。目所睹形。以喻其意乃得解慧。如衣多垢以淳灰浣。若干反数。乃得净耳。然后染之。其色乃鲜。譬如有人欲。起屋宅。其地高下。不能平正。多有溷厕蛇虺毒虫。高下平之。徙去不净。摈弃蛇虺。筑墙园基。乃起屋宅。菩萨如是。除去五阴六衰十二因缘吾我诸盖。行大慈哀智慧善权。为众法舍。为世间护。为世间台。普智复问。何谓法舍。世尊告曰。教化一切。皆入空慧。无增无爱。心无妄想。度脱众生。是为法舍。普智复问。何谓为台。世尊告曰。以六神通。彻视睹见十方心念。彻听有形。亦察无形。身遍十方。无有去来。道心睹见一切根原。本无处所。见已本际。不处有无。不处生死。不住灭度开心一切。皆至大道。是曰为台。何谓为护。世尊告曰。随时开化。入于五道。而净五眼。何谓为五。一曰肉眼。处于世间。现四大身。因此开化。度脱众生。何谓天眼。诸在天上。及在世间。未识至道。示以三乘各令得所。何谓慧眼。其不能解智度无极。皆开化之。使入大慧。何谓法眼。其在褊局。不能恢泰。悉开化之。解法身一无去来今平等三世。何谓佛眼。其迷或者。不识正真。阴盖所覆。譬如睡眠。示以四等四恩之行。布施持戒。忍辱精进。一心智慧。善权方便。随时而化。进退随宜不失一切。各令得所。皆发无上正真道意

普智复问。何谓此经。名度世品。佛言。一切众生。闭在世间。何谓为闭。五阴六衰。之所覆盖。缠绵生死。不能自拔。以权方便智度无极。消去五阴。捐弃六衰。不计吾我。不在生死。不住灭度。譬如日月昼夜演光。权慧如是。忽然无迹。德如虚空。无有譬喻。是故号曰度世品

佛说如是。普智菩萨。普贤菩萨。诸来会者。天龙鬼神。阿须轮。闻佛所说。莫不欢喜。为佛作礼

度世品第六


度诸佛境界智光严经

    No. 302 [Nos. 303, 304]

    度诸佛境界智光严经

        失译人名附秦录

如是我闻。一时佛住摩伽陀国法林菩提光明宫殿。大功德所造能令见者生大欢喜无量功德莲华之像师子高座。佛在其上。正遍知意清净。无等正行。到诸佛等法心无障碍。到不退法。不舍无边佛事。安住不可思议。向无相法。三世平等。身满世界知法无疑一切智身智慧无量。诸大菩萨之所受持。已到诸佛无等禅那。究竟满足。得解脱智。大慈大悲转于法轮。究竟无边有色身。及余比丘众六万二千。其名曰舍利弗。摩诃目揵连。摩诃迦叶。阿[少/(兔-、)]楼驮。须菩提。迦旃延。摩诃劫宾那。离婆多。难陀。那提迦叶。伽耶迦叶。分那弥多罗尼子。伽梵钵底。周利般特。蹋腊骠末利至。迦提罗尼伽。准陀。摩诃俱絺罗。罗睺罗。阿难陀。如是等六万二千众。一切定一切行。等入诸法性。无住无依。度诸烦恼。入佛法界。随从一法。向一切智。不舍一切智道。乐一切智不退。已到毗婆舍那第一波罗蜜已生诸方便境界行处及与万比丘尼摩诃波阇波提比丘尼。耶输陀罗比丘尼。等入一切善神清白之法。近一切智入一切智明。善达诸法无性。入诸法无性。入诸法无相。得诸法实际。知诸法不生。一切安立不思议解脱之定。教化众生。不作意不思惟。而能现身四种威仪。复有十佛世界不可说亿万那由他微尘数等菩萨摩诃萨。其名曰普贤菩萨摩诃萨。普眼菩萨。普化菩萨。普慧菩萨。普焰菩萨。普光菩萨。普明菩萨。普光明菩萨。普幢菩萨。普意菩萨。大勇猛菩萨。大持勇猛菩萨。大神通菩萨。大神通王菩萨。大勇猛菩萨。大勇猛力菩萨。大嚬申菩萨。大嚬申力菩萨。大香象菩萨。大月菩萨。善月菩萨。普光明月菩萨。法无垢月菩萨。光炎月菩萨。明月菩萨。放光月菩萨。满月菩萨。梵大自在菩萨。梵帝释震声菩萨。地鸣声菩萨。法界响声菩萨。除一切魔界声菩萨。法鼓响声菩萨。普语言声菩萨。无思惟声菩萨。地上响声菩萨。一切声性宫殿声菩萨。普上菩萨。普无垢上菩萨。功德藏菩萨。光曜菩萨。地藏菩萨。宝藏菩萨。月藏菩萨。日藏菩萨。热光藏菩萨。莲华吉藏菩萨。意菩萨。大意菩萨。胜意菩萨。震意菩萨。广意菩萨。上意菩萨。增长意菩萨。无边菩萨。严意菩萨。觉意菩萨。无尽意菩萨。海意菩萨。弥楼灯菩萨。大灯菩萨。法炬灯菩萨。一切光耀灯菩萨。普灯菩萨。除一切闇灯菩萨。照一切趣灯菩萨。专一光明灯菩萨。月灯菩萨。日灯菩萨。文殊师利童子菩萨。观世音菩萨。得大精进菩萨。金刚藏菩萨。密室菩萨。舍恶趣菩萨。药王菩萨。药上菩萨。慈不声菩萨。莲华手菩萨。日光菩萨。无微尘勇猛菩萨。金刚意菩萨。伏一切界菩萨。魔不胜菩萨。宝顶菩萨。百光所照明菩萨。大魔不胜菩萨。不可生菩萨。不可胜菩萨。不可入菩萨。不可近意菩萨。扫恶趣菩萨。弥勒菩萨。如是等诸菩萨。十佛世界不可说万亿那由他微尘等菩萨摩诃萨。一生相续余世界集。晓了众生。成熟众生。安住菩萨智慧方便。入世间法。了泥洹处。观了一切挍计习已。断行取于晓了不断摄受众生。善入一切无边无中。晓了一切众生业果而不失。于无所得智。观众生结使。具方便智慧。了去来今。诸佛义句。善能受持。智慧分别。入世出世。无边无中。能观有为及无为法。向去来今。诸如来智。了心刹那刹那生灭。初生出家方便苦行坐菩提树降魔得佛转于法轮及般涅槃。不离众生起菩提业。此诸菩萨。以一众生心缘。入一切众生心缘。方便生智慧地。不退菩萨身。得一切智地。行不退转。不断菩萨所行。入无功用智慧。为一众生事。行无边事无行。转法轮教化世间。晓了能持诸佛法本。绍如来种。使不断绝。于无佛世能现作佛。秽恶世界能令清净。能除一切菩萨业障。令得入于无障碍法相应。虚空等一切世界相应。无障碍等实际相应。与法界等知一切业所造果报。如彼因缘所造果报相应。印彼印造诸法等智相应。像现一切等智相应。于响声知诸假名等。此诸菩萨。安住不可思议解脱定。游戏首楞严三昧。安住无边佛身。具众陀罗尼。于一毛孔现诸世界成就去来现在诸佛清净住处。受持殊胜行愿。成就普贤行愿。了知诸佛初生灭度劝请说法利安众生。一毛孔中。现于十方初生出家方便苦行。坐菩提树降魔成佛。转于法轮及般涅槃。此诸菩萨。以智慧相应于一坐处。能动十方一切世界。于一佛土。遍能庄严诸佛世界。晓了庄严一佛世界。能现一切诸佛世界。于十方世界诸如来众。能现一如来众。于一如来众。能现十方诸如来众。晓了说法无中无边。能于自身。现一切众生。于一佛身。能现多佛。于多佛身。能现一佛。能令自身现十方世界。晓了三世能现一众生身。于过去世现未来世。于未来世现过去世。于过去世现现在世。于现在世现过去世。于未来世现现在世。于现在世现未来世。能以一身出入无量无数禅定三摩钵提。以无量无数身。出入一定三摩钵提。能现菩提。于一切身。能于一众生身。现一切众生。于一切众生身。现一众生。能于一佛身。现一切众生。于一切众生身。能现于一佛。能现一切身法身众生身。于一切世界。能现一世界。分布一世界能现多世界。能令十方世界入一毛孔。能现诸众生一切诸佛得菩提愿力处。能现十方世界成熟众生得阿耨多罗三藐三菩提。能现无数劫一世界中修菩萨行。能现一心生于十方一切世界。于一切世界一切众生胎生卵生湿生化生。有色无色有想无想。二足四足无足多足。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释梵四天王人及非人。如所成熟。教化众生心无功用。不以思惟起威仪事。于一微尘。能现无量无数不可说世界一切众生。亦无迫迮。无量无数不可说劫威仪果报事。能于一念中。现于一念威仪果报事。于无量无数不可说劫中。现如是所作。心无功用。不作思惟。现身威仪及诸转变。复有余菩萨。具足不可称量功德亿万那由他。复有不可说诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释梵四天王人非人等。从诸佛世界来集于此。从此世界百千万亿四天王。一四天王。有一大天及诸眷属。来至佛所。礼拜供养听受正法。复有无量百千万亿天帝释。复有无量百千万亿夜摩天王。复有无量百千万亿兜率陀天王。复有无量百千万亿化乐天王。复有无量百千万亿他化自在天王。来至佛所。礼拜供养听受正法。复有诸天魔眷属。亦来佛所。礼拜供养听受正法。复有无量百千万亿梵天王。复有无量百千万亿大梵天王。复有无量百千万亿少光天。复有无量百千万亿无量光天。复有无量百千万亿光耀天。复有无量百千万亿少净天。复有无量百千万亿无量净天。复有无量百千万亿遍净天。乃至阿迦尼吒诸天。一一天众共来佛所。礼拜供养听受正法。复有无量百千万亿净居诸天。及大自在天子。来至佛所。礼拜供养听受正法。复有无量百千万亿龙王。复有无量百千万亿夜叉王。复有无量百千万亿乾闼婆王。复有无量百千万亿紧那罗王。复有无量百千万亿摩睺罗伽王等。来至佛所。礼拜供养听受正法。复有无量阿僧祇人非人等。来至佛所。礼拜供养听受正法。复有无量百千万亿优婆塞优婆夷。来至佛所。礼拜供养听受正法。复有山神。树神。草木等神。及弥楼。摩诃弥楼。目真邻陀。摩诃目真邻陀。雪山。铁围等诸山神。来至佛所礼拜供养听受正法。复有小海大海小江大江湖池等神。来至佛所。礼拜供养听受正法。复有村邑国城诸神。来至佛所。礼拜供养听受正法。复有龙神夜叉乾闼婆紧那罗摩睺罗伽住处诸神。来至佛所。礼拜供养听受正法。以佛神力悉无迫迮。复有百千万亿月天子。复有百千万亿日天子。一一天子。各将大眷属。来至佛所。礼拜供养听受正法。复有阿[少/(兔-、)]达多大龙王。来至佛所。礼拜供养听受正法

尔时世尊。光明照耀过诸大众。如月十五日。圆满明净无诸云翳。光明照耀过于众星。如是世尊光明照耀。过于一切释梵诸天。佛身不动如须弥山王。尔时文殊师利童子菩萨。谓伏一切诸盖菩萨摩诃萨言。佛子。此如来身安住不动。如是语已。伏一切诸盖菩萨摩诃萨。复语文殊师利言。于此众中。有人见佛欲出家踰城。或有见佛已出家。或有见佛已修苦行。或有见佛向菩提树。或有见佛已坐道树。或有见佛为无量无数魔所围绕。或有见佛已破魔军。或有见无量无数诸天龙王。夜叉乾闼婆紧那罗摩睺罗伽人非人释梵诸天。说如是言愿如来胜。或有见佛为帝释所请。或有见佛为梵王所请。或有见佛为四天王所请。或复有人。于此众中。见佛为我说布施法。有见为我说持戒法。有见为我说忍辱法。有见为我说精进法。有见为我说禅定法。有见为我说智慧法。有见为我说方便法。有见为我说于愿法。有见为我说声闻法。有见为我说缘觉法。有见为我说菩萨法。有见为我说地狱生法。有见为我说饿鬼生法。有见为我说畜生生法。有见为我说人生法。有见为我说四天王生法。有见为我说三十三天生法。有见为我说焰摩天生法。有见为我说兜率陀天生法。有见为我说化乐天生法。有见为我说他化自在天生法。有见为我说梵天生法。有见为我说转轮王生法。或复有人。于此众中。见于如来身长二寻。或见佛身长一句卢舍。或见佛身长二句卢舍。或见佛身长一由旬。或见佛身长十由旬。或见佛身长千由旬。或见佛身长十。二十三十。四十五十。千由旬。或见佛身长百千由旬。或见佛身长十。二十三十。四十五十。百千由旬。或见佛身长八万四千由旬。或见佛身过于数量百千由旬。或见佛身紫金之色。或见佛身宝琉璃色。或见佛身因陀罗青摩尼宝珠色。或见佛身大青摩尼珠色。或见佛身火光摩尼宝珠色。或见佛身摩尼宝莲华色。或见佛身过帝释摩尼宝珠色。或见佛身金刚光明宝摩尼色。或见佛身一切天宝光摩尼色。或见佛身日月光明摩尼宝色。或见佛身水精摩尼宝色。或见佛身自在天王宝摩尼色。或见佛身一切光明聚宝摩尼色。或见佛身师子鬣毛宝摩尼色。或见佛身师子幢宝摩尼色。或见佛身海住清净庄严遍光明宝摩尼色。或见佛身如意宝摩尼色。文殊师利。是诸众生。见如来身。闻所说法。入如来行。至佛境界。彼诸众生。各见如来。同其所行

文殊师利。于东方不可数量不可思议不可称说世界布满。诸天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽。释梵四天王人非人等。如东方。南西北方四维上下亦如是。不可数量不可思议。不可称说布满。诸天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽。释梵四天王人非人等。大众充满。如竹林园。如甘蔗园。如稻麻园。文殊师利。若诸众生得见如来。则可教化。彼诸众生。在如来前。去一寻住。瞻仰如来。是时众生随见如来。现四威仪各住其前。文殊师利。若以说法成熟众生。彼诸众生皆闻说法。文殊师利。若以行成熟众生。彼诸众生唯见佛行。文殊师利。如来所现。无异功用。无异思惟。随众生性。自见不同。文殊师利。如十五日夜。阎浮提人。各见月现。在其上。月不作意我现其上。亦不作意令其得见。何以故。不共法故。文殊师利。如来应正遍知。于大众中。众生皆见各在其前。佛不作意我现其前。亦不作意令彼见我。应受化者随其自见。何以故。不共法故。文殊师利。如最胜水精摩尼宝珠。随种种衣成种种色。若珠置在黄衣之上。珠成黄色。置赤衣上。珠成赤色。置青衣上。珠成青色。此摩尼珠。亦不作意亦不思惟令成异色。如来应正遍知。亦复如是由众生故现种种色。若诸众生应见金色而受化者。即见如来身黄金色。若应见水精摩尼珠色而受化者。即见如来水精摩尼珠色。应见真珠色而受化者。即见如来真珠之色。应见因陀罗摩尼珠色而受化者。即见如来因陀罗摩尼珠色。应见大青摩尼珠色而受化者。即见如来大青摩尼珠色。应见一切光明聚摩尼珠色而受化者。即见如来一切光明聚摩尼珠色。应见师子鬣摩尼珠色而受化者。即见如来师子鬣摩尼珠色。应见师子幢上摩尼珠色而受化者。即见如来师子幢上摩尼珠色。应见海住清净庄严普光明摩尼珠色而受化者。即见如来海住清净庄严普光明摩尼珠色。应见以电灯摩尼珠色而受化者。即见如来电灯摩尼珠色。应见水清净摩尼珠色而受化者。即见如来水清净摩尼色。文殊师利。若有众生。应见如来。以帝释梵天四天王色而受化者。即见如来。帝释梵天四天王色。如是地狱畜生饿鬼阎罗王。至无色界。胎卵湿化。有色无色。有想无想。随以身相而受化者。彼诸众生皆见如来有种种相。如来亦不作意分别。此众生愿见我金色者。莫令见我水精摩尼珠色。此众生愿见我水精摩尼珠色者。莫令见我金色。此众生愿见我水精摩尼珠色者。莫令见我真珠色。此众生愿见我真珠色者。莫令见我水精摩尼珠色。此众生愿见我因陀罗摩尼珠色。莫令见我大青摩尼珠色。此众生愿见我大青摩尼珠色者。莫令见我因陀罗摩尼珠色。此众生愿见我一切光明聚摩尼珠色者。莫令见我师子鬣摩尼珠色。此众生愿见我师子鬣摩尼珠色者。莫令见我一切光明聚摩尼珠色。此众生愿见我师子幢上摩尼珠色者。莫令见我海住清净庄严普光明摩尼珠色。此众生愿见我海住清净庄严普光明摩尼珠色者。莫令见我师子幢上摩尼珠色。此众生愿见我电灯摩尼珠色者。莫令见我水清净摩尼珠色。此众生愿见我水清净摩尼珠色者。莫令见我电焰摩尼珠色。此众生愿见我帝释梵天四天王色者。莫令见我地狱畜生饿鬼阎罗等色。此众生愿见我地狱畜生饿鬼阎罗等色者。莫令见我帝释梵天四天王色。如来不作意思惟以无功用。亦不分别以成其事。文殊师利。如自在王摩尼宝生处。是处不生铁。及诸众具亦不得生。自在王摩尼宝。亦不作意。是处我生铁及众具不应得生。文殊师利。是处自在王摩尼宝自生。是处终不生铁。及诸众具亦不得生。文殊师利。如是佛境界处。如来生处。尼干外道亦不得生。诸邪见等亦不得生。一切诸乱亦不生。五逆亦不生。十不善道亦不生。制法亦不生。日月光明亦不生。帝释梵天四天王等诸天光明亦不生。诸宝摩尼光明亦不生。火光明亦不生。电光明亦不生。一念半念。一月半月。一年半年数亦不生。文殊师利。如来虽复成就众生。不作思惟。心无功用一切成就。文殊师利。如人为大青摩尼宝珠光明所触。彼人即成大青摩尼宝珠色。大青摩尼宝珠不作意思惟。若人为如来智慧光明所触。彼人即成一切智色。如来亦不作意思惟心无功用。文殊师利。如水精摩尼珠。善磨莹之。随所安处。以为庄严或庄严足。或庄严手或庄严头。或庄严颈。随庄严处。皆大光明。诸庄严具悉随光明。文殊师利如来应正遍知。行四威仪随所住处。如来光明。彼亦光明如来不作思惟心无功用。文殊师利。如地安住一切诸种种草木药树。悉得增长。地不作意思惟分别。文殊师利。如来安住一切众生。善根增长。如来亦不作意思惟心无功用。文殊师利。犹如大云普覆大地。于一切种。降一味雨。令诸草木成种种味。成种种色。云不作意思惟分别。文殊师利。如来应正遍知。于十方世界。以佛身云普覆众生种种善根。种种诸愿。种种心解脱。种种住解脱。降大法雨。令种种善根。种种诸愿。种种心解脱。悉得增长。如来亦不作意思惟。我令增长此众生声闻善根。我令增长此众生缘觉善根。我令增长此众生佛智慧善根。我令增长此众生四天王生善根。我令增长此众生三十三天生善根。我令增长此众生焰摩天生善根。我令增长此众生兜率陀天生善根。我令增长此众生化乐天生善根。我令增长此众生他化自在天生善根。我令增长此众生乃至五净居天生善根。文殊师利。如来不作意分别。我令增长此众生种种王生善根。我令增长此众生人生善根。我令增长此众生富贵生善根。文殊师利。如来虽不作意分别。利益事成。如其愿。如其意。如其乐。善根成就。于一切处恒行舍心。无有思惟无有分别。文殊师利。如日初出。放无量百千万亿那由他光。除阎浮提一切诸闇。光不作意我令闇灭。虽无思惟日用得成。文殊师利。佛日初出。放无量百千万亿那由他智慧光明。灭邪见闇。除如来应现为成熟众生。文殊师利。如来亦不作意分别。我灭众生邪见烦恼。不以功用如来事成。文殊师利。又如幻师现种种事。不以功用不以思惟。所作幻事自然而成。所为幻事不可言说不生不灭。无字无声无性无相。不可思议不去不来无等无对。文殊师利。如来应正遍知为诸众生。行四威仪一切处现。而此如来不可言说。不生不灭无字无声无性无相不可思议。不去不来无等无对与法界等。文殊师利。如日于须弥四洲。众生各各异见。有见日出。有见日入。有见正中。有见中夜。日不作意思惟分别。因须弥故。四洲世界现种种事为见不同。文殊师利。如来应正遍知于一众处。令诸众生各各异见。有见如来当得作佛。有见如来当入涅槃。有见如来已得成佛。有见如来已般涅槃。有见如来正法兴隆。有见如来正法衰灭。有见如来或十二十至四十年说法。有见如来或十二十三十四十亿百千不可说劫已入涅槃。文殊师利。如来亦不作意分别。由众生故自见不同。文殊师利。如阎浮提大风吹动。东方草木一时皆伏。西方草木一时皆起。如是随方起伏种种不同。而此草木亦不作意思惟。由风吹故令现种种。文殊师利。如来应正遍知。由诸众生于无数劫现四威仪。若诸众生缘于如来。生诸行者。断无数劫地狱饿鬼畜生阎魔王生。若有众生一念作意缘如来者。所得功德无有限极。不可称量百千万亿那由他。诸大菩萨。悉得不可思议解脱定。不能计挍得其边际。文殊师利。如日从大海出。放无数无量百千万亿那由他光。现城邑聚落。灭诸闇干湿泥。生草木成众事。然后行动。日不作意思惟分别。文殊师利。如来应正遍知。从生死海出。住于数量。放无数量百千万亿那由他智慧光明。现于十方一切世界。除无明闇。干烦恼泥。令生善根。成就一切于本处不动。如来亦不思惟分别。而一切皆成。文殊师利。若有善男子善女人。于十方世界微尘等诸佛及声闻众。施百味饮食及微妙天衣。日日不废。满恒河沙劫彼诸如来悉入涅槃。为一一佛。于十方世界一一世界。起尘数塔阎浮檀金为塔。电光摩尼宝珠以布其地。一切光明聚摩尼宝珠为基。真摩尼宝珠为幡。自在摩尼宝珠为网。覆其上造如是塔。宝伞遍覆大千世界。一一幢衣。一一幡华。一一诸香王自在。一一摩尼宝珠。一一如意摩尼宝珠。其数如云。散以供养。一日三时日日不废满恒沙劫。复教无数无量众生。设诸供养。如上所说

文殊师利。若有一善男子一善女人。信此如来功德智慧不可思议境界。度脱众语言法。所得功德胜彼无量。文殊师利。若有菩萨信此言说能令满足不可称量百千亿那由他波罗蜜。能知无数百千万亿那由他佛游戏处。能破无数憍慢之山。能倒无数嫉妒之幢。能干无数渴爱之河。能度无数生死之海。能断无数魔王之绳。能胜诸日月帝释梵天王等光明。能从佛境界至诸佛境界。能度地狱畜生饿鬼阎罗王生。令得值佛。与菩萨俱亦能得海印三昧。现一切界无过三昧。一切诸法自在三昧。一切法入三昧。无行庄严三昧。宝生三昧。作游戏三昧。莲华庄严三昧。破虚空三昧。随行一切世间三昧。法华三昧。境界自在三昧。大嚬申三昧。心行自在三昧。师子嚬申三昧。日等三昧。无边转三昧。随流行三昧。金刚缘三昧。金刚幢三昧。金刚喻三昧。金刚三昧。持地三昧。山等三昧。弥楼幢三昧。宝藏三昧。心自在三昧。一切众生心自在三昧。一切诸行境界行三昧。深密方便三昧。种种乐说三昧。无观三昧。观一切诸法三昧。游戏三昧。一切通行三昧。胜魔境界三昧。现一切色三昧。修身三昧。随一切法则三昧。智慧灯三昧。作证菩提光明三昧。说四无碍三昧。入一切行功德三昧。一切分别说三昧。寂静分别神通三昧。首楞严三昧。大深不量海水岸三昧。得如是等无数百千亿那由他三昧。复得无边佛身色众具陀罗尼。智慧陀罗尼。清净音声陀罗尼。无尽藏陀罗尼。无边转陀罗尼。海印陀罗尼。莲华庄严陀罗尼。不着入门陀罗尼。度分别辩陀罗尼。佛庄严受持陀罗尼。得如是等阿僧祇百千万亿那由他陀罗尼。到一切胜行。到一切诸法不由他知。到一切诸法无疑。复得阿僧祇百千佛游戏。复得诸胜行方便。文殊师利。如须弥山。于一切山。光明殊特。如是若菩萨信此言者。于一切善根光明。最为殊胜。是时文殊师利童子。语伏一切诸盖菩萨言。佛子。更有余胜法。是菩萨信乐处。若菩萨能信者。得无量胜功德不。伏一切诸盖菩萨言。有五法。是菩萨信乐处。得无量胜功德。云何五法。一者信一切诸法无对不生不灭不可说。二者信过阎浮提微尘诸行威仪事。如来不以功德不以思惟。念念自生。三者信常成熟众生。于恒沙劫久已成佛。四者信从然灯佛来乃至得佛中间所作是佛境界。无边劫来久已得佛现行此事。五者信灭释种示现此事。成熟众生是佛境界。文殊师利。此谓五法。是菩萨所信。得无边胜功德。文殊师利。若有善男子善女人。于日日中以百味食及微妙衣。施得六通及八解脱诸阿罗汉满恒沙劫。复有善男子善女人。一日之中。施一缘觉。如上供养。胜于前人所得功德。文殊师利。若有善男子善女人。于十方世界。起于塔寺如微尘数。于一一世界。真阎浮檀金。电灯摩尼宝布地。一切光明聚摩尼宝为基。真珠摩尼宝为幡盖。牛头栴檀以涂其地。自在王摩尼宝为网覆上安置。海清净普光明庄严摩尼宝为柱。师子鬣摩尼珠为板覆上。师子幢上摩尼宝为窗牖。悬诸幡盖。无量百千缘觉所住。日日施与百味饮食及上妙衣。经恒沙劫。文殊师利。若有一善男子善女人。闻佛者。闻世尊者。闻如来者。闻一切智者。此善男子善女人。所得功德胜彼无量不可计数。文殊师利。若复有善男子善女人。为佛造像。或以彩画。或用泥木。其人所得功德。复胜于彼无数不可计量。何况复以香华旛盖种种供养。所得功德无量无边不可称计。若复有善男子善女人。归依如来。一日守护如来禁戒。是人所得功德。复胜于彼无量无数不可称计。文殊师利。若复有善男子善女人。以百味食百种妙衣。施于十方一切诸佛。及诸菩萨声闻大众。经恒沙劫。彼诸如来入于涅槃。为一一如来。于十方界微尘数等。起诸宝塔。一一宝塔纵广如四天下。庄挍具足。以真阎浮檀金灯摩尼宝布地。一切光明聚摩尼宝为基。真珠摩尼宝为幡盖。牛头栴檀以涂其地。自在王摩尼宝为网覆上。又以宝盖遍覆三千大千世界。复以诸幡华其数如云。复以种种上妙妓乐。供养于塔。文殊师利。若复有善男子善女人。能信此经如来功德智慧不可思议。乃至以一揣食。施于畜生。是人所得功德。复胜于彼不可数量。文殊师利。若有菩萨。信于修多罗。如前所说。而为供养。若有菩萨信此经法。复见余人信此法者。生大欢喜发踊跃心。起恭敬意。奉迎合掌礼拜问讯。随所能办以为供养。此人功德。复胜于彼无量无边不可称计。何以故。以此功德能生佛智。世尊所印。文殊师利闻此言已。皆大欢喜。及诸菩萨声闻大众。天人阿修罗迦楼罗等。皆悉随喜顶礼而退度诸佛境界智光严经


佛华严入如来德智不思议境界经卷上

    No. 303 [Nos. 302, 304]

佛华严入如来德智不思议境界经卷上

        隋天竺三藏阇那崛多译

如是我闻。一时婆伽婆。游摩伽陀国法阿兰拏处菩提场上普光堂中。大福聚集。妙喜所生。普无毁处。功德无量。莲华藏师子座中坐。平等证觉(一)善净觉者(二)无有二行(三)游佛所游(四)得至诸佛平等(五)到无障处(六)不退转法(七)无遮行处(八)不舍无边诸佛所作(九)住不思处(十)向无相法(十一)三世平等所生(十二)其身遍诸世界(十三)诸法智中无有疑惑(十四)于诸所行具足觉慧(十五)诸法智中不为虑难(十六)无分别身(十七)受诸菩萨智(十八)得至无二佛行最胜彼岸(十九)尽到无差别如来解脱智(二十)顺到无边无中佛地平等(二十一)法界最极(二十二)虚空界究竟(二十三)无后际尽(二十四)于诸劫数常转法轮身不休息(二十五)共六十二百千比丘彼谓奢利弗多啰(隋云鸲鹆子旧名舍利弗者一)摩诃毛伽利耶夜那(旧名大目揵连者二)摩诃迦叶簸(三)阿泥留驮(四)修浮帝(隋云善实旧名须菩提者五)迦底耶夜那(旧名迦旃延者六)摩诃劫譬那(旧名劫宾那者七)黎婆多(八)难陀(九)那提迦叶簸(十)伽耶迦叶簸(十一)富啰拏迷低黎夜尼弗多啰(隋云满慈子旧名富楼那者十二)伽傍簸帝(隋云牛主旧名憍梵波提者十三)周稚般他迦(隋云髻道旧名周利槃陀者十四)达啰弊夜摩罗弗多啰(隋云物力士子旧名沓婆摩罗子者十五)佉驮啰婆那迦(十六)专陀(十七)摩诃俱絺罗(十八)啰侯罗(十九)阿难陀(二十)如是为首。有六十二百千比丘。皆游一法。等入境界。皆入诸法自性行。皆无所住虚空境界。皆游无所依处。皆已离诸烦恼障盖所起。皆已入诸如来法界光明行。皆平等入一法。皆向普智。皆于普智道无有休息。皆说普智智无有退意。皆已得至别智智观最胜彼岸。皆从方便境界行处所生。复共六十百千比丘尼。摩诃钵啰阇簸帝比丘尼。耶输陀啰比丘尼为首。皆善集白法。皆近普智智。皆入普智光明行。皆于明法。如是善通诸法无相。如是下入诸法实际。如是顺到诸法不生不灭无有助对。如是信解。皆安住不思解脱三摩地。皆随化度众生。如无功用无分别色身形类威仪示现

复与大菩萨众。有十佛土不可说俱致那由多百千微尘等菩萨摩诃萨。彼谓普贤菩萨摩诃萨。普日菩萨。普化菩萨。普智菩萨。普眼菩萨。普光菩萨。普明菩萨。普照菩萨。普幢菩萨。普意菩萨摩诃萨。大速行菩萨。大速持菩萨。大游戏菩萨。大游戏王菩萨。大精进勇步菩萨。大勇步健菩萨。大频申菩萨。大频申力菩萨。大众主菩萨。平等光明月菩萨。法无垢月菩萨。显赫月菩萨。震声月菩萨。放光月菩萨摩诃萨。梵音菩萨。梵主雷音菩萨。地鸣音菩萨。诸音分胜音菩萨摩诃萨。普孕菩萨。普无垢孕菩萨。功德孕菩萨。显赫孕菩萨。宝孕菩萨。月孕菩萨。日孕菩萨。炽然孕菩萨。莲华孕菩萨摩诃萨。意菩萨。大意菩萨。胜意菩萨。震声意菩萨。上意菩萨。妙意菩萨。增长意菩萨。无边意菩萨。广意菩萨。觉意菩萨。无尽意菩萨。海意菩萨摩诃萨。迷留灯菩萨。法炬灯菩萨。诸方遍灯菩萨。普灯菩萨。灭诸闇灯菩萨。诸趣明灯菩萨。一向照灯菩萨。月灯菩萨。日灯菩萨摩诃萨。曼殊尸利童子菩萨。观世音菩萨。大势至菩萨。金刚孕菩萨。功德孕菩萨。舍恶道菩萨。药王菩萨。药上菩萨。支帝神庙雷音菩萨。莲华手菩萨。日光菩萨。离尘勇步菩萨。金刚意菩萨。闭塞诸盖菩萨。降伏摩啰菩萨。宝髻菩萨。十百光明火炽然菩萨。大降伏摩啰菩萨。难出现菩萨。难降伏菩萨。入度菩萨。难称事意菩萨。干竭恶趣菩萨。慈者菩萨摩诃萨。如是为首。十佛土不可说俱致那由多百千微尘等菩萨摩诃萨。皆是一生补处。各异世界来集。善安立菩萨。欲令成熟思惟方便行。化度诸众生界。欲令成熟(一)皆遍诸世界思惟行智遍入(二)皆思惟善观察涅槃地境界智(三)善摄众生界断诸戏论及断行取(四)皆善住入无边中法行(五)皆思惟善观察众生业报不失不得(六)皆思惟善观察众生界信根发起方便最胜(七)皆善平等持过去未来现在诸如来所说义句味受持智(八)皆善住入世间出世间无边中法行(九)皆善观察有为无为三世过量法行(十)皆次第无间得游过去未来现在诸如来智场相(十一)皆于心刹那心刹那间善示现堕没出生出家苦行方便诣菩提场降伏摩啰证觉菩提转法轮大涅槃(十二)皆不离诸众生令其发心证觉菩提(十三)皆入一众生心攀缘善顺到无余诸众生心攀缘(十四)皆于自然地不动菩萨身(十五)皆得普智地不退转行(十六)皆入菩萨所作力不休息无作智行(十七)皆善住持一众生所作无边劫行(十八)皆善入不错谬转法轮安住诸世间化度界(十九)皆具足过去未来现在诸如来净处受行力胜愿(二十)皆具足普贤行愿殊胜净信(二十一)皆诣诸佛出处善能劝请(二十二)皆善持诸如来法教(二十三)皆作不断诸佛种姓(二十四)皆于无佛世界示现佛出(二十五)皆能清净浊染世界(二十六)皆灭诸菩萨业障(二十七)皆已入无碍法界(二十八)皆具足虚空界量法(二十九)皆具足法界无碍平等(三十)皆具足实际法界平等(三十一)皆信解威仪业所起报(三十二)皆信解如因所起果(三十三)皆具足印别印起诸法平等智(三十四)皆具足影像水月法平等(三十五)皆具足觉诸法响等音鸣(三十六)皆安住不思解脱三摩地(三十七)游戏首楞伽摩三摩地(三十八)皆安住无边佛身色成就出生陀罗尼(三十九)皆善于一毛道现诸世界(四十依梵本此间有三句与前二十二十一二十二等三句次第相似故不重出)皆于一毛道中十方善能示现堕没出生出家苦行方便诣菩提场示现降伏摩啰证觉菩提转法轮大涅槃(四十一)皆具足以一加趺十方诸世界遍满智(四十二)皆善示现诸土璎珞具于一土中(四十三)皆善示现一土璎珞具于诸土中(四十四)皆善示现满十方世界诸如来众于一如来众中(四十五)善示现一如来众于十方诸世界诸如来众中(四十六)善示现诸众生身(四十七)善示现诸佛身入一佛身(四十八)善示现一佛身入诸佛身(四十九)善示现诸方诸世界入自身中(五十)善示现诸三世众生身于一众生(五十一)皆善示现过去世入未来世未来世入过去世过去世入现在世现在世入过去世过去世入未来世(五十二)皆善以一身入三摩地于无量无数身起(五十三)善以无量无数身入三摩地于一身起(五十四)皆善示现诸身譬喻证觉菩提(五十五)皆善示现诸众生身于一众生身中(五十六)善示现一众生身于诸众生身中(五十七)善示现诸佛身于一佛身中(五十八)善示现一佛身于诸佛身中(五十九)善示现诸众生身即是法身(六十)皆善示现诸土庄严具于一土中(六十一)善示现一土庄严具于诸土中(六十二)善纳十方诸世界于一毛孔中(六十三)皆善示现诸佛证觉菩提愿力智令诸众生证觉(六十四)皆遍十方世界随所成就众生随所化度如无上正觉善能示现(六十五)皆善示现于诸劫数一一世界中菩萨行行身不休息(六十六)皆于一心生时。遍十方诸世界一一世界中。诸众生若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若二足若四足若多足。若天龙夜叉。揵闼婆。阿修啰。伽留荼。紧那啰。摩睺啰伽。舍迦啰。婆啰诃摩。卢迦波罗。人非人等。随所成熟化度。如是无功用无分别作威仪行入其住处善能示现(六十七)皆于一微尘中善纳无量无数不可称不可量不可说世界而心不逼恼(六十八)皆善以无量无数不可思不可称不可量不可说不可说劫。于一牟侯利位时住持(六十九)善以一牟侯利位时。于无量无数不可思不可称不可量不可说不可说劫住持(七十)皆随众生所成熟行。如是无功用无分别色身形类威仪善能示现。如是及余无量无数俱致那由多百千功德具足。菩萨摩诃萨

复有无量无数不可思不可称不可量不可说天龙夜叉。揵达婆阿修啰。伽留荼紧那啰。摩睺啰伽。舍迦啰。婆啰诃摩。护世等。各从种种佛土。来集此世界中。百俱致四大王身天。一一大多眷属围绕。诣向佛所。为欲礼觐供养亲事听法

复有百俱致舍迦啰。百俱致修夜摩天王。百俱致兜率多天王。百俱致善化天王。百俱致他化自在天王。一一天王大多眷属围绕。诣向佛所。为欲礼觐供养亲事听法

复有俱致摩啰身天。商主前行诣向佛所。为欲礼觐供养亲事听法

复有百俱致婆啰诃摩。百俱致大婆啰诃摩。百俱致少光。百俱致无量光。百俱致光音。百俱致少净。百俱致无量净。百俱致遍净。百俱致广果。百俱致善现。百俱致大广。百俱致大炽。百俱致究竟诸天。一一婆啰诃摩。大多眷属围绕。诣向佛所。为欲礼觐供养亲事听法

百俱致净居身天。大自在天子前行诣向佛所。为欲礼觐供养亲事听法。百俱致龙主。百俱致夜叉主。百俱致揵闼婆主。百俱致阿修啰主。百俱致伽留荼主。百俱致紧那啰主。百俱致摩睺啰伽主。一一大多眷属围绕。诣向佛所。为欲礼觐供养亲事听法

复有无量无数人非人等。诣向佛所。为欲礼觐供养亲事听法

复有多俱致那由多百千优波娑迦优波斯迦。诣向佛所。为欲礼觐供养亲事听法

复有诸药草树林天等。迷留大迷留。目真邻陀大目真邻陀。雪山轮山等。诸山天。诣向佛所。为欲礼觐供养亲事听法

复有海大海。河池陂天等。诣向佛所。为欲礼觐供养亲事听法

复有村城国王所治处天等。诣向佛所。为欲礼觐供养亲事听法

复有龙夜叉。揵闼婆阿修啰。伽留荼紧那啰。摩睺啰伽宫中所有天等。诣向佛所。为欲礼觐供养亲事听法。以佛神力故。众生无有逼恼

复有百俱致月。百俱致日。百俱致海。一一大多眷属围绕诣向佛所。为欲礼觐供养亲事听法

复有龙王。名阿那婆怛簸多。大眷属围绕。诣向佛所。为欲礼觐供养亲事听法

尔时世尊。光明显炽。映蔽诸众。如彼白助月轮。于十五日。云网放脱。光明显炽。映蔽诸星宿轮。如是如是。世尊亦然。映蔽诸舍迦啰。婆啰诃摩。护世等光明显炽。如修迷留山王光明显炽。功德显炽住不动身不战不喘

尔时曼殊尸利童真。告遮塞诸盖菩萨言。佛子。此如来。住不动身不战不喘。如是语已。遮塞诸盖菩萨摩诃萨。告曼殊尸利童真言。曼殊尸利。此如来于此众中。或有天人。知其从家而出欲向出家。或有知其住苦行处。于此众中。或有知其诣菩提场。或有坐菩提场于此众中。或有无量无数摩啰众围绕。或有知其破坏摩啰。无量无数天龙夜叉。揵闼婆阿修啰。伽留荼。紧那啰。摩睺啰伽。舍迦啰。婆啰诃摩。卢迦波啰等。欲助与力。胜胜大商主。或有知其证觉已舍迦啰劝请。或有婆啰诃摩。或有知此众中卢迦波罗劝请世尊。或有知世尊为我等说陀那。此众中。或有知世尊为我等说尸罗。或有说忍。或有说精进。或有说思惟定。或有知世尊为我等说钵啰阇若波啰蜜。或有说方便。或有知世尊为我等说愿。或有说力。或有说阇若那。或有知世尊为我等说声闻乘。或有说独觉乘。或有说大乘。或有知世尊为我等说生畜生法。或有生饿鬼。或有知世尊为我等说生阎摩世法。或有知世尊为我等说生四大王天宫法。或有生三十三天。或有知世尊为我等说生夜摩天宫法。或有知世尊为我等说生兜率天宫法。或有生化天宫。或有生他化自在天宫。或有生摩啰天宫。或有知世尊为我等说生婆啰诃摩天宫法。或有生人。或有此众中知世尊为我等说当得转轮王。曼殊尸利。或有此众中知如来高二寻。或有高一俱嚧舍。或有高二俱嚧舍。或有高半踰阇那。或有知如来身高二踰阇那。或有知如来身十踰阇那。或有此众中知如来身千踰阇那。或有知如来身十二十三十四十五十百千踰阇那。或有知如来身八十四百千踰阇那。或有此众中知如来身过百千数踰阇那。或有见金色。或有鞞琉璃夜摩尼宝色。或有因陀啰青摩尼宝色。或有大青摩尼宝色。或有火光摩尼宝色。或有波头摩染摩尼宝色。或有知如来身舍迦啰毗楞伽那摩尼宝色。或有金刚光摩尼宝色。或有诸天光摩尼宝色。或有日月光摩尼宝色。或有水光摩尼宝色。或有知如来颇致迦摩尼宝色。或有自在王摩尼宝色。或有诸光最上摩尼宝色。或有师子须摩尼宝色。或有师子幢上摩尼宝色。或有海住持净庄严普炎光摩尼宝色。曼殊尸利。或有此众中知如来如意摩尼宝色。曼殊尸利。所有如是色威仪住。得化度众生。曼殊尸利。彼众生见如来彼彼如是色威仪住。曼殊尸利。所有说法得成熟众生。彼等众生。知如来如是说法。曼殊尸利。所有修行。令诸众生入如来教得受化度。彼众生知如来住彼彼行

曼殊尸利。若于东方无量无数不可思不可称不可量不可说诸世界悉满。天龙夜叉揵闼婆阿修啰。伽留荼。紧那啰。摩睺啰伽。舍伽啰。婆啰诃摩。护世。人非人等。如东方。如是南方西方北方。东南方西南方西北方。如是东北方。上方下方。无量无数不可思不可称不可量不可说诸世界悉满。天龙夜叉。揵闼婆。阿修啰。伽留荼。紧那啰。摩睺啰伽。舍迦啰。婆啰诃摩。护世。人非人等。譬如竹林甘蔗林。胡麻林。曼殊尸利。若诸众生。见如来已得化度者。彼诸众生。在如来前一寻量住。而见如来所有所有色威仪住。彼等众生得化度者。众生见如来在前彼彼色威仪住。曼殊尸利。所有说法已令彼众生当得成熟。彼彼当闻如是说法。曼殊尸利。所有修行。令彼众生入如来教。当得成熟彼彼修行。如来当住如来诸所作事无功用无分别。而自回转。曼殊尸利。譬如白助月轮于半夜时。阎浮地鞞波诸众生各各知月轮在前。而月轮亦无分别无异分别。如是我于众生前住。欲令众生知我月轮。曼殊尸利。然月轮无功用无分别。故此如是色事转。以不共法故。如是如是

佛华严入如来德智不思议境界经卷上佛华严入如来德智不思议境界经卷下

        隋天竺三藏阇那崛多译

曼殊尸利。如来应正遍知。在于众中。彼诸众生。皆见如来在其前住。如来亦无分别无异分别。如是我于众生前住。欲令众生知我如来在其前住。然随所化度众生。彼知如来在其前住。何以故。不共法相应故。曼殊尸利。譬如诸众生随下中上业熟力。还有下中上诸行。为众生出生。而诸行亦无分别无异分别。然复无功用无分别故。诸行下中上事。自然回转如是如是。曼殊尸利。如来应正遍知。随众生下中上业熟力。还有下中上。如来为众生见。曼殊尸利。如来亦无分别无异分别。然无功用无分别故。如来如是事转。曼殊尸利。譬如真颇致迦摩尼宝随衣种种故有种种色。曼殊尸利。若颇致迦摩尼宝。置黄衣上。颇致迦摩尼宝即作黄色。若置赤衣上。颇致迦摩尼宝即作赤色。若置青衣上。颇致迦摩尼宝即作青色。如是置何似何似色上。还作如是色。曼殊尸利。颇致迦摩尼宝。亦无分别无异分别。如是如是。曼殊尸利。如来随众生色。作种种色。曼殊尸利。若众生以金色如来身现。而得化度者。彼等当见金色如来身。若众生以鞞琉璃夜摩尼宝色。得化度者。彼等当见鞞琉璃夜摩尼宝色。若众生以真珠色。得化度者。彼等当见如来真珠色。若众生以天帝青摩尼宝色。得化度者。彼等当见如来天帝青摩尼宝色。曼殊尸利。若众生以大青摩尼宝色。得化度者。彼等当见如来大青摩尼宝色。若众生以诸光选择上摩尼宝色。得化度者。彼等当见如来诸光选择摩尼宝色。若众生以海住持净庄严普炎光摩尼宝色。得化度者。彼等当见如来海住持净庄严普炎光摩尼宝色。若众生以师子须摩尼宝色。得化度者。彼等当见如来师子须摩尼宝色。若众生以师子幢上摩尼宝色。得化度者。彼等当见如来师子幢上摩尼宝色。曼殊尸利。若众生以电灯摩尼宝色。得化度者。彼等当见如来电灯摩尼宝色。若众生以水净摩尼宝色。得化度者。彼等当见如来水净摩尼宝色。曼殊尸利。如是若以婆啰诃摩舍迦啰护世等色。得化度者。彼等当见如来婆啰诃摩舍迦啰护世等色。乃至那啰迦畜生饿鬼阎魔世所生中。若彼色类所生众生。随以何等色身色威仪。得化度者。彼等当见如来如是色身色威仪。如是卵生胎生湿生化生。色无色想无想。非想非非想。随以何等色身色威仪。得化度者。彼等当见如来如是色身色威仪。而如来亦无分别无异分别。欲令此等众生见我金色。莫见鞞琉璃夜色。此等众生见我鞞琉璃夜色。莫见天帝青摩尼宝色。此等众生见我天帝青摩尼宝色。莫见大青摩尼宝色。此等众生见我大青摩尼宝色。莫见诸光选择摩尼宝色。此等众生见我诸光选择摩尼宝色。莫见自在王摩尼宝色。此等众生见我自在王摩尼宝色。莫见海住持净庄严普炎光摩尼宝色。此等众生见我海住持净庄严普炎光摩尼宝色。莫见师子须摩尼宝色。此等众生见我师子须摩尼宝色。莫见师子幢上摩尼宝色。如是诸处如来亦无分别无异分别。然无功用无分别故。如是等色所作事转。曼殊尸利。譬如自在王摩尼宝所生处。彼处不生铁若铁作具。曼殊尸利。其自在王。无分别念彼亦不如是念。我所生处。彼处莫生铁若铁作具。曼殊尸利。而自在王摩尼宝所生处。彼处不生铁若铁作具。如是如是。曼殊尸利。所有佛土。如来出生彼处不生柘啰迦波利婆啰阇迦泥揵连。他等诸外道。彼处不生诸恶作等。彼处不生诸乱。彼处不生诸无间。彼处不生十不善业道。彼处不生王教违背法者。彼处不生日月光明。彼处不生婆啰诃摩舍迦啰护世等诸天光明。彼处不生摩尼光明若火光明。彼处不生牟侯利多。半牟侯利多。月半月岁算数等。曼殊尸利。唯除如来住持为成熟众生。曼殊尸利。如来亦无分别无异分别。然随众生。以无功用无分别故此等事转。曼殊尸利。譬如大青摩尼宝光明所触者。彼等皆作大青摩尼宝色。而大青摩尼宝无分别念。如是如是。曼殊尸利。其为如来攀缘意光所触者。彼等皆作遍智色。如来亦无分别无异分别。曼殊尸利。然如来以无功用无分别故。此等事转。曼殊尸利。譬如善作成就大鞞琉璃摩尼宝。随所有边。安置诸庄严具中若足庄严具中若头庄严具中。彼彼庄严具中。最极光照。及彼等庄严具。亦最极光照。是彼鞞琉璃摩尼宝威力故。如是如是。曼殊尸利。如来应等正觉。随所有行威仪住处。随所有行中住。彼彼行中最极光照。及彼行亦最极光照。是彼如来威力故。曼殊尸利。如来亦无分别无异分别。然如来。以无功用无分别故。此等事转。曼殊尸利。譬如地依止故地住持故。诸草木药林。种子增长广成。曼殊尸利。其地无分别念。然以无功用无分别故。此等事转。如是如是。曼殊尸利。如来依止故如来住持故。诸众生诸善根增长广成。如来亦无分别无异分别。然如来以无功用无分别故。此等事转。曼殊尸利。譬如云气覆诸地已。于种种草木药林处所。遍雨大雨。彼水一味。而令种种草木药林增长种种处所种种味种种色彼水住。曼殊尸利。其云无分别念。然以无功用无分别故。此等事转。如是如是。曼殊尸利。如来应等正觉以佛身云。遍布满十方世界已。于诸众生种种积集善根。种种作愿。种种内心信解。种种解脱住处。遍雨种种法雨。所有种种积集善根。众生作愿。内心信解。各各善根作愿。内信解脱住处。以种种法雨故。随能随力。令其善根增长。曼殊尸利。如来亦无分别无异分别。我为此等众生增长善根。令其得声闻智。我为此等众生增长善根。令其得独觉智。我为此等众生增长善根。令其得佛陀智。我为此等众生增长善根。令其生四天大王宫。我为此等增长善根。令其生三十三天宫。如是略说。乃至夜摩。兜率多。化乐他化自在。如是婆啰诃摩众。婆啰诃摩师。少光无量光光音。少净无量净遍净。大果福生净居。阿迦尼沙诧。曼殊尸利。如来不如是分别。令此等众生增长善根。当生种种王处。令此等众生增长善根当生种种人处。令此等众生增长善根。当生种种自在处。曼殊尸利。如来亦无分别无异分别。曼殊尸利。然如来以无功用无分别故。随诸众生作愿。内心信解。积集善根。此如是等色类事转。如来于诸处舍。无有分别。曼殊尸利。譬如日轮出时。其间次第。放无数俱致那由多百千光炎。除去阎浮洲中所有诸闇。其日轮亦无分别无异分别。然以无功用无分别故。此等事转。如是如是。曼殊尸利。如来日轮出时。其间次第。放无数俱致那由多百千智炎。除去诸见作闇。唯除佛住持成熟众生故。曼殊尸利。如来亦无分别。我为众生今破散见事。当破散见事。曼殊尸利。然如来以无功用无分别故。此如是等色类事转。曼殊尸利。如来于诸处舍。无有分别。曼殊尸利。譬如为幻所化。由幻师故。现种种事。以无功用无分别故。分种种身。曼殊尸利。彼幻所化。不可说不生不灭。无字无声。无方处无有物。无想无思。无二无行。无等无对。曼殊尸利。然彼为幻所化。由幻师故。现种种事。以无功用无分别故。如是如是。曼殊尸利。如来应等正觉。随众生故。种种所行。威仪事入处示现。曼殊尸利。彼如来不可说不生不灭。无字无声。无方处无有物。无想无思。无二无行。与法界等无对。曼殊尸利。譬如日由循迷留山王故。四大洲中众生。或有见出时。或有见下时。或有见日高来时。或有知下入时。或有知半夜时。或有中时。或有知日出来初打鼓时。(彼国一日分为四分若尽一分则打鼓为节此谓四分中初打鼓时)或有下入初打鼓时。或有残日打鼓时。或有残夜打鼓时。如是日轮。四大洲中众生。各各异见。其日轮亦无分别无异分别。然由循迷留故。四洲世界中。现种种事。以无功用无分别故。如是如是。曼殊尸利。如来应等正觉。于此一众中。或有众生。知如来欲证觉。或有知欲涅槃。或有知世尊已证觉。或有此众中知世尊已涅槃。或有世尊证觉已十年。或有知世尊涅槃已十千年。或有知世尊法教纯至时。或有知世尊法教隐没时。或有知世尊说法已十二十三十四十年。或有知世尊涅槃已十二十三十四十俱致那由多百千劫。曼殊尸利。或有天人知奢迦夜牟尼世尊证觉已不可说不可说劫。曼殊尸利。如来亦无分别无异分别。曼殊尸利。然如来以无功用无分别故。随众生有如是色类。所作事转。曼殊尸利。譬如阎浮洲中。大风轮吹时。其诸草木药林叶动。振已复振。乱已复乱。或有叶东方低西方举。或有叶西方低东方举。或有叶边举中低。或有北方举南方低。其草木药林叶亦无分别。然随风轮故。种种所作事转如是如是。曼殊尸利。如来应等正觉。亦无分别无异分别。然随众生故。于叉拏叉拏间。常有如是不可数行。威仪所作。事入处转。曼殊尸利。众生所有攀缘如来作意念。转还尔许劫。所有那啰迦畜生饿鬼阎摩世等生处。当断当回。曼殊尸利。如来如是。无量具足。曼殊尸利。能一攀缘如来作意念事。于无量无数俱致那由多百千劫中。住不可思解脱三摩地。菩萨摩诃萨。不能至其功德边际。曼殊尸利。譬如日从大海起。出住虚空境界。放无数俱致那由多百千炎。诸村城邑国土王都中示现。而与破散黑闇。干诸浊泥。生长诸草木药林。成熟诸药。发起诸所作业。于诸河池泊中。一时影到而住处不动。曼殊尸利。日轮亦无分别无异分别。然以无功用无分别故。此等如是色类事转如是如是。曼殊尸利。如来应等正觉。从有海起。出住虚空境界。放无数俱致那由多百千智炎。十方诸世界中。遍布示现。与诸众生。破散无明黑闇翳膜。[車*乞]诸烦恼浊泥。生长诸善根。成熟诸善根聚。发起诸善门。并于一时诸所作转。而住处不动。曼殊尸利。如来亦无分别无异分别。然以无功用无分别故。此等如是色类事转。曼殊尸利。若有善家子善家女。十方诸世界中所有微尘等。诸佛及声闻众。施天百味食。日日施天衣。如是施时。于[口*恒]伽河沙等劫施。彼等灭度已。为一一如来。遍十方世界。于一一世界中。作十方诸世界微尘等娑偷波。阎浮那陀金为体。电灯摩尼宝为间错。诸光选摩尼宝栏楯围绕。摩尼珠悬以庄严。立幢幡盖。铃网覆上。涂以大蛇牢固栴檀那香以摩尼网覆上。彼等娑偷波。以三千大千世界量等天盖云。幢云香云。自在王摩尼宝云如意摩尼宝云。散以复散。日日三时。如是供养。于[口*恒]伽河沙等劫供养。复有别异无量无数众生。亦教住如是供养。曼殊尸利。若有别异善家子。善家女。此说入如来功德不思境界法本。乃至信解。此过彼无数分福德生。曼殊尸利。信解此法本菩萨。当满足无量无数俱致那由多百千波啰蜜。当超越无量无数俱致那由多百千地。当后面背无量无数俱致那由多百千劫当知无量无数俱致那由多百千佛游戏。当破散无量无数憍慢山。当倒无量无数悭妒幢。当干竭无量无数渴爱河。当度无量无数生死海。当断无量无数摩啰罥索。当遮障日月。舍迦啰。婆啰诃摩。护世尊威力。从佛土至佛土。当救护那啰迦低利夜卑黎多夜摩世等所生众生。当得逢会诸佛菩萨。当得海印三摩地。当得名诸法平等入三摩地。当得名诸法自在转三摩地。当得名诸相庄严三摩地。当得名宝所生三摩地。当得名作喜三摩地。当得名莲华庄严三摩地。当得名虚空库藏三摩地。当得名诸世顺行三摩地。当得名正法白华三摩地。当得名境界自在转三摩地。当得名大频申三摩地。当得名虚空心自在转三摩地。当得名师子频申三摩地。当得名日灯三摩地。当得名无边旋流三摩地。当得名悬峻顺行三摩地。当得名金刚轮三摩地。当得名金刚幢三摩地。当得名如金刚三摩地。当得名金刚齐三摩地。当得名持地三摩地。当得名迷留灯三摩地。当得名诸众生心自在转三摩地。当得名诸众生行境界出三摩地。当得名迷留幢三摩地。当得名宝藏三摩地。当得名心自在转三摩地。当得名深密方便三摩地。当得名杂色光辩三摩地。当得名观视三摩地。当得名观察诸法三摩地。当得名游戏三摩地。当得名不喜乐诸胜智通三摩地。当得名破散摩啰轮三摩地。当得名示现诸色三摩地。当得名胜益诸色三摩地。当得名观身三摩地。当得名信行主三摩地。当得名智慧灯三摩地。当得名现觉灯三摩地。当得名说别缺三摩地。当得名入诸相功德三摩地。当得名决定诸法行三摩地。当得名寂静决定神通三摩地。当得名健行三摩地。当得名深无畏水海波三摩地。当得如是等为首。俱致那由多百千不可数三摩地。当得无边佛身色成就出陀啰尼。当得名智主陀啰尼。当得名清净音鸣陀啰尼。当得名无尽箧陀啰尼。当得名无边渊陀啰尼。当得名海印陀啰尼。当得名莲华庄严陀啰尼。当得名入无著门陀啰尼。当得名正决定陀啰尼。当得名佛璎珞住持陀啰尼。当得如是等为首。俱致那由多百千不可数陀啰尼。当顺得诸行胜。当顺得诸法中不由他智。当顺得诸疑断。当得佛百千不可数游戏。当得善巧胜诸众生行。曼殊尸利。譬如循迷留山王。映蔽诸山光炽照曜。如是如是。曼殊尸利。此法本中。信解菩萨。映蔽众生。诸善根光炽照曜。尔时曼殊尸利童子。告闭塞诸盖菩萨摩诃萨言。佛子。更有别胜法中信解菩萨。当得如是别胜功德。如是语已。闭塞诸盖菩萨摩诃萨。告曼殊尸利童子言。曼殊尸利。有五法信解菩萨。当得如是别胜功德。何者为五。诸法无对无生无灭不可说。当如是信解。过阎浮洲最微尘。如来所行威仪。所作入处。无功用无分别。于念念中常转。当如是信解。于常会中所作。成熟众生。彼世尊奢迦牟尼。于[口*恒]伽河沙等劫中已证觉。当如是信解。从然灯佛。受记已来。乃至证觉。于此中间。所有菩萨行。彼世尊奢迦牟尼。尽佛境界等劫。已证觉示现当如是信解。诛杀奢迦。示现所作。成熟众生。彼世尊奢迦牟尼。尽佛境界等劫。已证觉示现。当如是信解。曼殊尸利。如是五种信解菩萨。当得如是别胜功德。曼殊尸利。若有善家子善家女。施诸世界微尘等八解脱定阿罗汉。天百味食。日日以天衣施。如是施与。于[口*恒]伽河沙等劫施。曼殊尸利。若有善家子善家女。一日施一独觉食。此于彼福胜过无数分生。曼殊尸利。若有善家子善家女。作十方诸世界微尘等游行处。(旧译云寺)一一世界中。阎浮那陀金为体。电灯摩尼宝。以为间错。诸光选择摩尼宝栏楯围绕。摩尼珠宝贯束所作。庄严建立诸盖幢幡。铃网为帐。蛇行牢固栴檀那以为泥涂。自在王摩尼宝。以覆其上。海住持清净普光摩尼宝为柱。以网连系师子须摩尼宝版。以覆其上。师子幢胜摩尼宝。以为却敌。女墙寮窗。悬缯帛束。为彼独觉。作千不可数。为彼独觉。日日施以天百味食。亦施天衣。如是施与。于[口*恒]伽河沙等劫施。曼殊尸利。若善家子善家女。闻佛世尊如来声。此于彼福。胜过无数分生。何况若于作画处若作泥塑处见如来。此于彼福。胜过无数分生。何况施灯烧香。涂香华等。若更别有种种供具。此于彼福。胜过无数分生。何况为如来故。一日护持一戒。此于彼福胜过无数分生。曼殊尸利。若善家子善家女。十方世界微尘等。诸如来及诸菩萨。并声闻众。日日施以天百味食。及施天衣。如是施与。于[口*恒]伽河沙等劫施。彼等世尊灭度后。为一一如来十方世界微尘等。造娑偷波。一一娑偷波。量与四洲等。诸种相具足。诸功德成就。阎浮那陀金为体。电灯摩尼宝为间错。诸光选择摩尼宝栏楯围绕。摩尼珠宝贯束庄严。建立诸盖幢幡。铃网为帐。蛇行牢固栴檀那以为泥涂。自在王摩尼宝以覆其上。彼等娑偷波。日日以三千大千量等盖云幡云。宝云音乐云。璎珞云。师子幢胜月云。天作鼓乐歌音云。以散其上。散已复散。而不信解此法本。曼殊尸利。若有善家子善家女。此入如来功德智不思境界。名法本信解者。乃至畜生趣众生。施一搏食。此于彼福。胜过无数分生。曼殊尸利。若有信解此修多啰菩萨。如此修多啰中所说。供养如来。若复有菩萨。见此修多啰中信解菩萨。见已。作如是意。此信解。此修多啰。以如是意。得大欢喜净信心已。从座而起。合掌顶礼。随堪随力。摄取供养。此于彼福。胜过无数分生。当得佛智故。佛说此时。彼诸比丘。及诸菩萨。天人阿修罗。揵闼婆等世。于佛所说。欢喜奉行

入如来德智不思议境界经卷下


佛说大方广菩萨十地经

    No. 308

佛说大方广菩萨十地经

        元魏西域三藏吉迦夜译

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众千二百五十人俱。菩萨万人。其名曰智幢菩萨。法幢菩萨。月幢菩萨。日幢菩萨。无量幢菩萨。跋陀波罗等。十六正士。文殊师利等。六十同意。弥勒菩萨等。贤劫一切菩提萨埵。尔时无尽智菩提萨埵。从座起整衣服偏袒右肩右膝着地。以种种宝华散于佛上。白佛言。世尊。欲有所问唯愿世尊。开示解说

尔时世尊告无尽智菩萨。善哉善哉。善男子。若有疑难恣汝所问。如来当为随问解说令汝欢喜。尔时无尽智菩提萨埵白佛言。世尊。菩提心。世尊。谓菩提心云何当知。菩提萨埵成就菩提心。何等为菩提心。亦无菩提心。萨埵亦不可得。亦不离菩提名曰菩提心。菩提者。亦不可说不可见无有对。萨埵亦不可得。云何于此诸法当得开解。世尊告曰。善男子。菩提者。是皆言说俗数施设。善男子。菩提者非言说非俗数非施设。善男子。如菩提非言说。萨埵及心至一切法。亦复如是。当作是知。若如是心是名菩提心。菩提亦不过去当来今现在。所谓萨埵及心亦不过去当来今现在。若如是知者。菩提萨埵不可得。彼处都无所得。于一切法得无所得。是名得菩提心。如阿罗汉阿罗汉果亦不可得。彼都无所得。但是俗数言说有耳。于一切法无所得。是名得菩提心。亦非初业菩提萨埵度义。义名为菩提萨埵。亦非彼心非施设心。非众生非施设众生非声闻非施设声闻。非辟支佛非施设辟支佛。非菩提萨埵非施设菩提萨埵。非有为非施设有为法。非无为非施设无为法。可得已得当得。但如说法随顺故。说一切善根等起。当知初发心。彼因檀波罗蜜。犹如大地所持。当知第二心起。彼因尸波罗蜜。犹如师子兽王勇猛。当知第三心起。彼因羼提波罗蜜。犹如那罗延勇猛大力便。当知第四心起。摧伏一切诸结怨敌。彼因毗梨耶波罗蜜。种种善根功德华开。当知第五心起譬如天帝释大会拘毗陀罗树。彼因禅那波罗蜜。犹如日轮无量光曜。当知第六心起。悉能除灭一切闇冥。彼因般若波罗蜜。本愿功德普现庄严。当知第七心起。如商人主将诸商人能度旷野。彼因方便波罗蜜。净除一切过恶所欲如意。当知第八心起。满足明净犹如秋月周满所愿。当知第九心起。一切所作皆悉休息。譬如贫人得无尽宝藏。犹如虚空离垢明净。当知第十心起。究竟一切功德彼岸。智慧辩才无尽一切法主犹转轮王。如是善男子。其成就此十种心者。是名为菩提萨埵。摩诃萨埵。第一萨埵。最上萨埵。离罪萨埵。最尊萨埵。然善男子。菩提萨埵及心。于第一义都不可得又善男子。菩提萨埵初心起。有法宝等起三摩提摄取心而生。菩提萨埵第二心起。有不动三摩提摄取心而生。彼第三心起。名善住三摩提摄取心而生。彼第四心起。名不退转三摩提摄取心而生。彼第五心起。名集华三摩提摄取心而生。彼第六心起。名日光三摩提摄取心而生。彼第七心起。名义满足三摩提摄取心而生。彼第八心起。名慧炬三摩提摄取心而生。彼第九心起。名佛见在前三摩提摄取心而生。彼第十心起。名首楞严三摩提摄取心而生。又善男子。初地菩提萨埵先睹嘉瑞。三千大千佛土亿百千珍奇宝藏。悉现境界。第二地先睹嘉瑞。三千大千佛土平如水掌。悉现境界。第三地先睹嘉瑞。勇健坚强手执兵仗。悉现境界。第四地先睹嘉瑞。曼陀罗风从四方来。吹种种华普散大地。悉现境界。第五地先睹嘉瑞。一切女人严具庄饰。瞻匐华鬘。解脱华鬘。忧钵罗华鬘。婆利师华鬘。庄严其首。悉现境界。第六地先睹嘉瑞。众宝浴池八功德水充满其中。有四阶道底布金沙。澄靖清彻自见己身游戏其中。悉现境界。第七地先睹嘉瑞。见左右面有大地狱楚毒峻崄。自见己身超出此难。悉现境界。第八地先睹嘉瑞。自见两肩有师子兽王。首冠缯帛其身雄壮。一切毒害诸恶兽等无不摧伏。悉现境界。第九地先睹嘉瑞。转轮圣王大臣刹利百千眷属。以法化导一切众生。手执缯盖众宝百千庄严其首。悉现境界。第十地先睹嘉瑞。自见作佛身黄金色圆光一寻。亿百千梵围绕说法。善男子。是为菩提萨埵十地前相。当作是知。悉从十地三摩提之所出生

又善男子。菩提萨埵初发意地得最胜处陀罗尼。第二地得难伏陀罗尼。第三地得善住陀罗尼。第四地得难当陀罗尼。第五地得功德华普集庄严陀罗尼。第六地得智光明陀罗尼。第七地得胜趣陀罗尼。第八地得八万四千陀罗尼。澄靖司陀罗尼为首。第九地得六十那由他陀罗尼。无尽陀罗尼为首。第十地得恒河沙陀罗尼。出生无量陀罗尼为首。是为菩提萨埵十地陀罗尼。当作是知又善男子。菩提萨埵初发意地具足檀波罗蜜。第二地具足尸波罗蜜。第三地具足羼提波罗蜜。第四地具足毗梨耶波罗蜜。第五地具足禅那波罗蜜。第六地具足般若波罗蜜。第七地具足方便波罗蜜。第八地具足愿波罗蜜。第九地具足力波罗蜜。第十地具足智波罗蜜。如是诸波罗蜜。于诸地中皆悉成就。又善男子。有十种檀波罗蜜。何等为十。信根为首檀波罗蜜。三摩提为首檀波罗蜜。大慈为首檀波罗蜜。大悲为首檀波罗蜜。深心希望为首檀波罗蜜。一切智为首檀波罗蜜。安立众生为首檀波罗蜜。四摄为首檀波罗蜜。护持正法为首檀波罗蜜。乐求佛法为首檀波罗蜜。复有十种尸罗波罗蜜。何等为十种。离八难为首尸罗波罗蜜。建立佛法为首尸罗波罗蜜。超越声闻辟支佛地为首尸罗波罗蜜。净身业为首尸罗波罗蜜。净口业为首尸罗波罗蜜。净意业为首尸波罗蜜。庄严心为首尸波罗蜜。人世界清净为首尸波罗蜜。一切愿求满足为首尸波罗蜜。不害为首尸波罗蜜。复有十种羼提波罗蜜。何等为十。忍力为首羼提波罗蜜。成熟众生为首羼提波罗蜜。意解为首羼提波罗蜜。深法忍为首羼提波罗蜜。断烦恼为首羼提波罗蜜。离嗔恚为首羼提波罗蜜。不计身为首羼提波罗蜜。不计命为首羼提波罗蜜。断诸无智为首羼提波罗蜜。观诸法平等为首羼提波罗蜜

复有十种毗梨耶波罗蜜。何等为十。精进根为首毗梨耶波罗蜜。精进力为首毗梨耶波罗蜜。等方便为首毗梨耶波罗蜜。念处为首毗梨耶波罗蜜。代一切众生身所作为首毗梨耶波罗蜜。随顺一切众生口意转为首毗梨耶波罗蜜。不退还为首毗梨耶波罗蜜。极精勤为首毗梨耶波罗蜜。伏一切烦恼怨家为首毗梨耶波罗蜜。一切智智为首毗梨耶波罗蜜

复有十种禅波罗蜜。何等为十。定根为首禅波罗蜜。定力为首禅波罗蜜。等定为首禅波罗蜜。诸禅解脱为首禅波罗蜜。善法为首禅波罗蜜。是处为首禅波罗蜜。不乱为首禅波罗蜜。非处为首禅波罗蜜。害一切结使为首禅波罗蜜。定身满足为首禅波罗蜜

复有十种般若波罗蜜。何等为十。慧根为首般若波罗蜜。慧力为首般若波罗蜜。正见为首般若波罗蜜正念为首般若波罗蜜。阴巧便为首般若波罗蜜。观界入为首般若波罗蜜。圣谛为首般若波罗蜜。无障碍为首般若波罗蜜。除一切妄见为首般若波罗蜜。无生法忍为首般若波罗蜜

复有十种方便智波罗蜜。何等为十。众生希望方便行为首方便波罗蜜。安立众生为首方便波罗蜜。大悲为首方便波罗蜜。化众生不劳惓为首方便波罗蜜。超越声闻辟支佛地为首方便波罗蜜。入诸波罗蜜为首方便波罗蜜。如实观诸法为首方便波罗蜜。不思议力为首方便波罗蜜。不退转为首方便波罗蜜。降伏众魔为首方便波罗蜜。何等为波罗蜜义。行增进满足义。是谓波罗蜜义。胜妙智满足。是波罗蜜义。不著有为无为法义。是波罗蜜义。觉生死过义。是波罗蜜义。觉悟不觉悟者义。是波罗蜜义。开示一切无尽法藏义。是波罗蜜义。无间碍解脱具足义。是波罗蜜义。觉知布施平等义。是波罗蜜义。觉知戒忍精进一心智慧平等义。是波罗蜜义。决定巧便义。是波罗蜜义。知一切众生法性义。是波罗蜜义。无生法忍满足义。是波罗蜜义。不退地满足义。是波罗蜜义。严净佛土义。是波罗蜜义。成熟众生义。是波罗蜜义。觉场具足义。是波罗蜜义。降伏众魔义。是波罗蜜义。一切佛法满足义。是波罗蜜义。十力四无所畏十八不共法满足义。是波罗蜜义。摄取一切化生义。是波罗蜜义。三转十二行法轮义。是波罗蜜义

尔时会中有天名师子幢无碍光耀。白佛言。世尊。甚奇甚特。是名一切具足。是名究竟一切佛法功德。世尊答曰。如是如是诸天。其有善男子善女人闻是法正忆念者。当知是阿惟越致菩提萨埵。何以故。天子。是善男子善女人善根成熟故。令耳根得闻是经。一切善根成熟故。得闻此经已。终不离真实观。不离诸佛世尊。不离诸佛法。不离转法轮。不离海印陀罗尼。不离无尽陀罗尼。不离遍入众生行陀罗尼。不离无尽光日幢陀罗尼。不离月无垢相陀罗尼。不离无垢等起相陀罗尼。若菩萨得是陀罗尼者。悉能一时变身为佛。周满十方教化众生。然于诸法亦不死亦不去。而度脱众生。众生亦不可得。说法教化诸文字等亦不可得。示现死生亦不生。知诸法平等无去无来。亦不作非不作故。说是法时。三千菩提萨埵得无生法忍。复次天子。若有读诵持是法者。终不离息一切缠陀罗尼。不离金刚坚强破散一切烦恼山陀罗尼。终不离说无言普入诸波罗蜜陀罗尼。终不离能说异名句诸语陀罗尼。不离虚空离垢出生无尽印陀罗尼。不离成就无量佛身一切生尽陀罗尼。说是法时。无量众生皆得法忍。无量众生发阿耨多罗三藐三菩提心。佛说是时。无尽智菩萨。师子幢无碍光耀天子。及诸大声闻天人阿修罗。为佛作礼皆大欢喜佛说大方广菩萨十地经


佛说兜沙经一卷

    No. 280 [Nos. 278(3, 5), 279(7, 9)]

    佛说兜沙经一卷

        后汉月氏三藏支娄迦谶译

一切诸佛威神恩。诸过去当来今现在亦尔。佛在摩竭提国时。法清净处。其处号曰在所问清净。始作佛时。光景甚明。自然金刚莲华。周匝甚大。自然师子座。诸佛过去时。亦悉于上坐。仪法等无有异。极相法中。出生极过度已。诸佛身体行。悉等具足。明无所复挂碍。不可计佛处。不可计法处。不可计诸大十方人民处。不可计佛刹处。过去当来今现在佛等所出生也。诸菩萨等。各各从异国土来都大会。其数如十佛刹尘。一尘为一菩萨。如是为限。诸菩萨赐一生补处。皆入十方人民典安隐。皆入法处。皆入十方诸刹土。皆入十方泥洹慧。皆入十方所作世间人宿命。皆入稍稍增深菩萨。皆入诸慧法中。皆入内外法中。皆入不动不摇法中。皆入过去当来今现在法中。诸菩萨辈。议如是。佛爱我曹等辈。诸菩萨等所念。示现我等。诸佛刹。如佛所行。居处阿。彼闻所有。现我等诸佛刹清净。现我等如佛法清净。佛所说法。悉皆使我曹见矣。现我等佛刹成败时。使我曹悉见矣。现我曹等诸佛起出时。现我等佛刹所有善恶。佛所有悉示我。示现我曹十方诸有刹土。现我等诸不可计佛所说。现我等菩萨十法住。现我等菩萨十法所行。现我等菩萨十法悔。过经。现我等菩萨十道地。现我等菩萨十镇。现我等菩萨十居处所愿。现我菩萨十黠。现我菩萨十三昧。现我菩萨十飞法。现我菩萨十印。现我菩萨悉飞来时。现我佛名无有尽。时佛使我皆护世间人民。十方佛诸有刹土。悉清净无瑕秽。现我佛诸所知有无有也。现我诸恶根本。悉使清净。诸法悉为我说。诸所疑难。皆为解之。悉为解狐疑。皆过度矣。诸所有欲断之。现我佛所止处。现我佛诸法所部界。现我佛威神。现我佛所行。现我佛筋力。现我佛四事不护。现我佛三昧所入处。现我佛所变化在所为。现我佛无有过胜者。现我佛所有尊号。无有能及逮者。现我佛所根。现我佛飞。现我佛光明。现我佛智慧。现我佛四事无所畏。佛悉知诸菩萨心所念。佛悉现光明威神

东方极远不可计佛刹有佛。佛名阿逝堕。其刹名讫连桓。文殊师利菩萨。从是刹来。与诸菩萨俱。数如十方刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐

南方极远不可计佛刹有佛。佛名阿泥罗堕罗。其刹名楼耆洹。佛陀师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐西方极远不可计佛刹有佛。佛名阿斯堕陀。其刹名波头洹。罗邻师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐北方极远。不可计佛刹有佛。佛名阿阇堕。其刹名占倍洹。檀那师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐

东北方极远。不可计佛刹有佛。佛名阿输那堕国陀。其刹名优彼洹。群那师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐东南方极远。不可计佛刹有佛。佛名阿旃陀堕陀。其刹名犍阇洹。那涅罗师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐西南方极远。不可计佛刹有佛。佛名郁沈堕大。其刹名罗怜洹。惟闇师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐西北方极远。不可计佛刹有佛。佛名阿波罗堕。其刹名活逸洹。昙摩师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐下方极远。不可计佛刹有佛。佛名枫摩堕罗。其刹名潘利洹。惹那师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐

上方极远。不可计佛刹有佛。佛名堕色。其刹名儨提拾洹。那軷陀师利菩萨。从是刹来。与诸菩萨俱。其数如十佛刹尘。皆前为佛作礼。各各于自然师子座交路帐中坐文殊师利菩萨。持佛威神。悉遍视诸菩萨。皆遍以便举慧言。诸菩萨大众会。何甚快耶。不可复计诸佛刹。佛所居处。诸所处。诸所被服佛法。佛说法。佛刹威神。佛所行。佛筋力。佛刹善恶。不可计佛法。何因耶。十方诸佛刹土。所说道。所度脱十方人诸法甚深无极。如虚空。了无所挂碍。何因耶。是蔡呵只刹土四面种种人。各各异身体。各各异名。各各异色。各各有长短。各各有寿命。各各有形类。各各有思想。各各有念。各各异有声。各各有闻佛声。何因是国土。名波迦私提。四面中有呼佛名曰胜达。中有呼世世慢陀。中有呼夷阿那坭提。中有呼释迦文尼。中有呼鼓师萨沈。中有呼堕楼延。中有呼俱[言*賈]滑提。中有呼摩呵沙门。中有呼晨那愁楼提。中有呼质多愁楼提等。为四面如是辈。各各呼释迦文佛名。合为万字。如是十方极过去不可复计诸佛刹。都人民种种各异语。共呼释迦文佛。名佛字。一一佛刹。凡各十亿万字。释迦文佛。从本未造学道已来。诸所教授弟子等辈时人。如是。佛放光明。先从足下出。照一佛界中。极明现十亿阎浮利天南。十亿大海。十亿须弥山。十亿遮加和山。十亿弗于逮天东。十亿俱耶匿天西。十亿郁单曰天北。十亿照头摩罗天。十亿忉利天。十亿盐天。十亿兜术天。十亿泥摩罗提罗邻优天。十亿波罗蜜和耶拔致天。十亿梵天。十亿梵迦夷天。十亿梵弗还天。十亿梵迦产天。十亿摩诃梵天。十亿廅天。十亿波梨陀天。十亿廅波摩那天。十亿阿会亘羞天。十亿波栗羞诃天。十亿阿波摩羞天。十亿羞讫天。十亿权呵天。十亿波栗推呵天。十亿阿波堕诃天。十亿惟于潘天。十亿阿惟潘天。十亿阿陀波天。十亿须[無/足](音武)天。十亿呵迦腻吒天。十亿阿惟先惟先尼[卄/呵]

如是等。各各照见诸天上人所止处。敢是佛界中。悉皆照明。释迦文佛。都所典主。十方国一一方。各有一亿小国土。皆有一大海一须弥山。上至三十三天。一小国土。如是所部。凡有十亿小国土。合为一佛刹名为蔡呵只。佛分身。悉遍至十亿小国土。一一小国土。皆有一佛。凡有十亿佛。皆与诸菩萨。共坐十亿小国土。诸天人民。皆悉见佛。诸菩萨诸天人民。皆持佛威神。相视如迎。相见

  文殊师利菩萨　　复有文殊师利菩萨
  罗邻师利菩萨　　檀那师利菩萨
  群那师利菩萨　　佛陀师利菩萨
  涅罗师利菩萨　　惟阇师利菩萨
  惹那师利菩萨　　軷陀师利菩萨
  昙摩师利菩萨

如是等菩萨。其所止佛刹。刹极快好。其刹皆各各自有名

  阿栴堕还佛　　阿泥罗堕还佛
  阿阇陀堕还佛　　阿楼那堕还佛
  阿栴陀堕还佛　　郁沈堕还佛
  伊豆罗堕还佛　　梵摩堕还佛
  惟夷罗还佛　佛说兜沙经


佛说较量一切佛刹功德经

    No. 290 [Nos. 278(26), 279(31), 289]

    佛说较量一切佛刹功德经

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

如是我闻。一时。佛在王舍城法野菩提道场。坐金刚摩尼宝师子之座。有菩萨摩诃萨众。周匝围绕。复有十佛刹百千俱胝那由他众。听佛说法。尔时会中有一菩萨摩诃萨。名不思议光王。即从座起。瞻视大会诸菩萨已。而白众言。汝诸佛子。今当谛听。此娑婆世界。满一大劫较量时分。是彼西方极乐世界。无量寿佛刹一昼夜。佛子。彼极乐世界。一大劫较量时分。是阿儞弭沙世界。缚日啰(二合)娑誐啰钵啰摩哩那曩如来佛刹一昼夜。佛子。彼阿儞弭沙世界。一大劫较量时分。是不退轮光明世界。敷莲花身如来佛刹中一昼夜。佛子。彼不退轮光明世界。一大劫较量时分。是无尘世界。法王如来佛刹中一昼夜。佛子。彼无尘世界。一大劫较量时分。是灯光世界。师子如来佛刹中一昼夜。佛子。彼灯光世界。一大劫较量时分。是善光世界。毗卢遮那如来佛刹中一昼夜。佛子。彼善光世界。一大劫较量时分。是难胜世界。法敷身如来佛刹中一昼夜。佛子。彼难胜世界。一大劫较量时分。是谟贺世界。一切通意王如来佛刹中一昼夜。佛子。彼谟贺世界。一大劫较量时分。是现圆光世界。赞叹如来佛刹中一昼夜。佛子。如是一切世界。依劫算数过十佛刹百千俱胝那由他微尘数劫已。有世界名莲花吉祥。彼佛世尊名贤吉祥。是彼佛刹中一昼夜。佛子。彼有菩萨地名普行地行。如是无量菩萨行。佛子。若复有人于此较量一切佛刹功德经。受持读诵。为他解说。彼人命终。十方佛刹恒河沙数。诸佛如来。悉皆现前。满彼有情一切所愿。佛说此经已。不思议光王菩萨及诸大众。闻佛所说。皆大欢喜信受奉行佛说较量一切佛刹功德经


佛说罗摩伽经卷上

    No. 294 [Part of No. 278(34), 279(39), 293]

佛说罗摩伽经卷上

        西秦沙门圣坚译

如是我闻。一时佛在舍卫国祇树给孤独园。庄严重阁善胜讲堂。与菩萨摩诃萨。普贤菩萨。文殊师利菩萨等。其名曰光明幢菩萨。须弥山幢菩萨。宝幢菩萨。无碍幢菩萨。花幢菩萨。净幢菩萨。日光幢菩萨。静正幢菩萨。离尘幢菩萨。世静幢菩萨。地威德幢菩萨。宝威德菩萨。大威德菩萨。金刚智威德菩萨。净威德菩萨。法日威德菩萨。功德山威德菩萨。智炎威德菩萨。普现胜威德菩萨。持地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。功德净藏菩萨。法印藏菩萨。世净藏菩萨。不憍慢菩萨。莲华胜藏菩萨。善净眼菩萨。清净眼菩萨。净眼藏菩萨。无著眼菩萨。普集眼菩萨。善观眼菩萨。优钵罗华眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。善眼菩萨。普眼菩萨。天冠菩萨。法界炎智天冠菩萨。道场天冠菩萨。栴檀光天冠菩萨。佛藏天冠菩萨。山勇天冠菩萨。世净天冠菩萨。威仪天冠菩萨。无能胜菩萨。诸佛师子座覆观菩萨。普法界虚空光观菩萨。梵胜髻菩萨。龙胜髻菩萨。佛变化炎髻菩萨。一切愿海摩尼髻菩萨。如来圆光殊髻菩萨。虚空掌珠报髻菩萨。如来游戏珠王网髻菩萨。如来法轮香髻菩萨。一切三世香髻菩萨。大光菩萨。离垢光菩萨。宝光菩萨。离尘光菩萨。炎光菩萨。法光菩萨。寂光菩萨。日光菩萨。游戏光菩萨。天光菩萨。功德相光菩萨。智相炎菩萨。法相炎菩萨。神通炎相菩萨。光炎相菩萨。华相炎菩萨。珠相炎菩萨。菩提炎相菩萨。梵相炎菩萨。普光炎相菩萨。梵音菩萨。海音菩萨。辩才音菩萨。世王音菩萨。山相击音菩萨。一切法界普音菩萨。一切法海雷音菩萨。调伏魔界音菩萨。大悲云雷音菩萨。一切世间寂音菩萨。法勇慧菩萨。智勇菩萨。功德须弥勇菩萨。功德牙勇菩萨。称勇菩萨。普炎勇菩萨。大慈勇菩萨。智海勇菩萨。如来种性勇菩萨。光胜菩萨。妙胜菩萨。勇胜菩萨。世净胜菩萨。法胜菩萨。月胜菩萨。虚空胜菩萨。宝胜菩萨。星胜菩萨。智胜菩萨。树王印胜菩萨。法王印菩萨。世王印菩萨。梵王印菩萨。山王印菩萨。珠王印菩萨。龙王印菩萨。寂王印菩萨。不动王印菩萨。仙人贤力王印菩萨。胜王印菩萨。寂香菩萨。无极香菩萨。地香音菩萨。海雷香音菩萨。法艳香音菩萨。虚空香音菩萨。众生功德香音菩萨。众生善根香音菩萨。魔界香音菩萨。智山光菩萨。虚空意菩萨。净意菩萨。无著意菩萨。觉悟意菩萨。三世炎意菩萨。光意菩萨。普明意菩萨。法界炎意菩萨。如是等菩萨摩诃萨。五百人俱。行同普贤。悉皆具足无著境界。普现十方无量佛土。身量无极。遍诸佛前。又修无碍净眼境所。心无休息。普集一切诸佛功德。决定明了于菩提道。普集无量光明。深入一切法智海。常行无著无所受。心得大慧。身满足无量无数劫。四辩无穷尽。智慧如虚空。无依无所著。随众生所乐。如意现色身。净眼无垢障。如日处空中。于一切法界。光明悉充满。复有五百声闻。久已通达四谛。明了本际。深入法性离生死海。随顺如来圣弟子众。于诸有结心得解脱。于佛法海无有疑惑。复与无数诸天王俱。又于先佛植众德本。普为众生作不请之友。又受心戒具诸功德。普胜天人而无高心。不舍烦恼皆已尽。心智解脱如虚空。于佛法中无有疑。深入诸佛智慧海。随顺如来诸圣威仪。承佛教诫成就众生。护佛法种使不断绝。缘此善根常生佛家。深乐种智真实法门

尔时诸菩萨。声闻大众。诸天魔梵。及诸神仙。各与眷属。恭敬围绕。咸作是念。念如来行。念佛境界。念佛自在神通变化。念如来持念如来力。念如来无畏。念如来住。念如来三昧。念于如来胜妙功德。念如来身。念如来智无有崖底。一切天人不能测量。无能分别无能开现。无能知见无能宣明。亦无有能如实解说。除佛持力。佛自在力。佛智慧力。佛辩才力。佛威神力。佛三昧力。佛神通力。佛本愿力。过去善根力。亲近善知识力。清净信心力。住方便力。乐求清净胜妙善根力。正直菩提深心力。一切智愿力。是故世尊。知识众生种种欲。种种信。种种解。而心无二。以无著声。觉寤一切知道者。说道者。善说诸地种种行。种种根。种种人。种种信。种种解。种种思。及知一切智人境界。各各思惟如来功德。咸愿宣说。如来昔为菩萨时。行愿善业。先所修习。一切智愿胜波罗蜜。示现菩萨诸地神通。庄严方便。众妙音响。庄严菩萨行。出生满足海庄严菩萨菩提门。示现菩萨自在道。出生菩萨庄严海。庄严如来游戏神通。庄严如来自在法轮。庄严如来刹海。庄严如来普现十方调伏众生。而不现身心。住诸如来正法之城。超胜功德。普广示现一切诸道如来法王。为一切众生示现诸趣。明净普照神通自在力。如来为一切众生最上福田。如来为一切众生。说功德哒嚫三轮。化度一切群生。唯愿如来。悲愍一切。具足显现

尔时世尊。知诸菩萨心之所念。以大悲身大悲门大悲心大悲本愿力随顺大悲。广大如法性。究竟如虚空。入师子王奋迅三昧。为令一切众生。乐清净法。入三昧已。时只陀林重阁讲堂。忽然光丽广博严净。梵天金刚。庄严其地。珍奇间错。众宝严饰。雨如意珠及诸名华。时彼林中表里映彻。有琉璃树。枝条华果皆众宝成。杂色光明回旋其间。乐见珠王以为罗网。阎浮檀金及众挍饰。间无空缺弥覆其上。又以名珍庄严楼阁。普光摩尼为明珠柱。修直光色照彻园林。金户珠帘。宝钿栏楯。四出蹬道。众宝所成。摩尼宝王化珍妙华。于其鬘端放真珠光。列植阶檐。罗荫轩陛。幢幡缯盖满虚空界。于窗牖前宝树化生。犹娑罗林自然行列。果如宝铃发众妙音。于树根下出琉璃水。香净柔软流遍祇洹。佛神力故。本愿力故。十方世界。微尘数不可思议阿僧祇清净佛刹。无量无数诸供养具。皆悉普现于只陀林。复有功德香河。回沿净国。无量宝华随流化生。不可穷尽。华水有声。皆说菩萨报应之行。华树敷荣。出香云盖。诸香盖中。有不可思议诸楼阁云。有阿僧祇不可思议华鬘璎珞。皆悉垂下阿僧祇宝摩尼珠王。自然涌出柔软衣服及诸宝幢。香烟幡盖皆悉充满。复有无数诸宝华云。旋转空中。一切幢幡及诸华盖。众宝铃幢。出妙音声。演说一切诸佛名号。显现清净法轮之相。复有师子如意珠王。以音声海。普演诸佛本愿海门。一切法界宝王摩尼法相光明。以为庄严。时只陀林上虚空之中。有不可思议阿僧祇等诸香树云。如是种种诸供养具。及诸佛刹。诸庄严事。无量无边不可具说

尔时善财童子。从东方界。求善知识。渐渐游行。至南方界。转至西方。遥见善胜长者在窟头摩城。发意欲向渐涉道路。思惟正受系念在前。无分散意住正定聚。虽在道路爱乐正法。无悔恨心不退境界。勇猛精进不畏崄路。念善知识修正觉道。为得安隐道故身心无尽。在于中道作如是念。我当云何得胜境界。我今云何当速诣善知识。问菩萨道修菩萨行。于善知识。作佛道因缘。得诸波罗蜜。普摄一切。离诸障碍。入无著法界。普为一切众生。断众恶道业。为除我人众生寿命之心。灭除一切烦恼诸尘。破灭一切诸见罗网。成就善箭。以慈悲弓。射护法处。成就因果。何以故。若得值见善知识者。必得成就诸善功德。善知识者。能为一切智。作大根本。身心正受。颜色不变。求善知识。威仪庠序。无卒暴相。渐渐往至窟头摩城。见善胜长者在于彼城重阁讲堂。即前诣已。如人游海水中不见边际。百千万亿诸大长者。以为围绕。皆悉欢喜。在于善胜长者左右。各欲乐闻种种诸法。如海导师为诸商人说海宝处。善胜长者。善能分别佛法海宝。为一切众。说无所著无所分别

尔时善财童子。头面敬礼。白言大圣。我已久发阿耨多罗三藐三菩提心。但不知云何行菩萨道。修菩萨行。善胜长者。告善财言。善哉善哉。善男子。汝已能发菩提之心。善能问于大智慧宝。为得如是甚深法义。为断一切疑惑苦恼种子。汝今问我。为到一切智岸。以不破坏心。正向大乘。令离一切声闻辟支佛地怖畏。正趣佛道。修诸三昧寂静法门。善修一切诸菩萨行。愿游戏神通转不退轮净诸业道。速疾回向一切智心。于菩萨行。如实修行。为菩萨道故来问我。行此行者。普见十方。无有障碍。善知一切智海对治门。庄严一切菩萨行故来问我。善男子。我在此海岸屈头摩城重阁讲堂。昼夜常说大慈大悲菩萨净行法门。善男子。我于此阎浮提。见诸贫苦众生。必欲饶益然后为说甚深空义。随彼所愿。令得满足。或以饮食而摄取之。或以法财而摄取之。或以功德业而摄取之。或以智慧而摄取之。或以善根正直业而摄取之。应以菩萨根而摄取者。即以菩萨根而摄取之。应发菩萨心摄取者。即以菩萨心而摄取之。若应以除去疑惑发菩提心者。即以除疑惑法而摄取之。若应以喜悦发菩萨心者。即以喜悦法而摄取之。若应以大悲发菩萨心者。即以大悲而摄取之。若有应以除生老病死忧悲苦恼无常定法发菩萨心者。即以苦空无常法而摄取之。若有众生。应以住生死海心无疲惓。即同住生死海而摄取之。若有应以四摄法发菩萨心者。即以四摄法而摄取之。若应以一切智慧功德海发菩萨心者。即以功德智慧海随顺法而摄取之。若有应以一切三世诸佛正法海对治门发菩萨心者。即以三世诸佛正法海而摄取之。善男子。我以如是等诸摄取法。为饶益众生故。令一切众生得法利乐故。在海此岸。善男子。我住于此岸。普知一切海中珍宝及所出处。根原种性及价贵贱清明之相。识宝光明。善能分别。善知一切工巧伎术。善知一切诸龙龙王龙子宫殿差别。亦能善除诸龙斗诤怖畏恶相。又复善知一切诸罗刹王宫殿村落。亦能善除罗刹斗讼。及与怖畏。又复善知一切魑魅魍魉诸恶鬼神所住之处。亦能除灭一切海水洄波诸难。并知水色泉源众流。善能瞻知日月星辰一切灾异变怪之事。昼夜瞻相。无一念顷失于常度。了了分明无分毫差。善知一切书疏算数。射驭。随时能用。善知一切众相。于刹那顷变怪不停。或合或离。善知筹量世间众事。善男子。汝今当知。我以知此一切众生十明法门。安止清净住无畏岸。令彼彼众生皆得安隐。恒以正法而抚慰之。若阎浮提。有诸商估贾客。欲往大海求珍宝者。称我名故大获珍宝。安隐吉还。若有众生得闻我名者。身心诸垢及以衣垢。永得消除。何况烦恼。若有众生眼视我者。常得清净无上法喜。闻法无厌。身心悦乐。以此法乐。普为一切阎浮提内诸苦众生。雨大法雨令得悦乐。若有众生闻我说法。必得安隐度生死海。免诸怖畏。必得安立一切智海。永离渴爱无复忧患。恒住三世明解脱海。善男子。汝今当知。我能当入一切众生心心数行海中。令彼众生修净土业。普知一切十方净国海。随意往生得无碍业。复能庄严一切净业根海。普能清净一切诸众生行海。令住安乐寂静大安眠海。善男子。我以知此大慈悲喜舍对治灭相击音声菩萨喜幢法门。诸大菩萨。成就无量诸功德智慧海。善能分别一切世界行海。断除一切烦恼业海。成就一切诸法界海。普摄一切诸众生及世界海。普入一切胜智慧海。终不舍一切众生海。其心如地。善能随顺一切众生海。普能教化一切众生海。善随一切众生威仪海。诸大菩萨深行如是。我当云何能知能说彼功德行

时善财童子。头面作礼。绕百千匝。辞退西行。善胜赞言。善哉善哉。善男子。汝今应当正念思惟三昧正受。汝从此去。渐渐西行。向名闻城。去彼城已。有国名难忍。城名迦陵提。去此不远。有功德林。于其林中。有比丘尼。名师子奋迅。身紫金色。端严第一。汝可诣彼问菩萨行。问菩萨戒。问诸法门。尔时善财童子。逡巡辞退。渐渐游行。至功德林日光泉侧。见彼比丘尼端坐正受。有五百童女。形貌端正。以为侍者。复有五百童子卫护众女。百千天女卫立左右

尔时日光泉侧有一园林。名曰王园。入彼园中。见一大树。名日月光。普放光明。照百由旬庄严园林。化成重阁。七宝严饰。上有光明。复见大树。名普光明。枝叶扶疏。遍覆三千大千世界。其形如盖。流出众水。有清净光。复见宝林。名曰花藏。高显无极。其华开敷。如天树王。有妙光明。如天宫殿。其色鲜白。犹如雪山。复见大树。名曰美味。金花金果。柔软香美。甚适众心。复见一树。名世净光。其色光明。无量无边。栴檀摩尼。以为树果。有阿僧祇诸杂珠网。罗覆树上。像天宫殿。复见一树。名曰天衣。常出无量阿僧祇数众宝色衣。复见诸树名曰音乐。互相掁触。声踰梵音。复见众林。名普香庄严。其香普熏。无有障碍。于园林中。复见泉池。七宝光网。弥覆其上。其池四方。有四渠流。分为八支。更相灌注。八功德水。湛然盈满。牛头栴檀。末为底泥。众宝庄严。黄金为沙。激此香水。声如天乐。悦可众心。又以众宝而为栏楯。于池岸上。布以金沙。常放种种杂色光明。优钵罗花。钵昙摩花。拘勿头花。分陀利花。敷荣水上。有众宝树。行列严饰。围绕池侧。一一树下。各敷无量宝师子座。无量天衣。众妙珍奇。以为严饰。烧无价香。熏师子座。众香缯帐。白净鲜明。宝网覆上。垂众金铃。出和妙音。复有无量众宝床帐。围绕高座。一一树下。亦复如是。于诸树间。复有无量莲花宝藏师子座。又于树间。有众香藏座。又于树间。有种种香云藏座。又于树间。有师子宝聚藏座。又于树间。有一切世间普光摩尼清净藏座。又于树间。有乐见师子宝藏之座。无量妙香。以为敷具。此诸宝座。一一皆有无量百千诸小床座。以为围绕。一一小座。以无量宝。而为庄严。一一座上。有无量宝珠。充满一切。如大宝洲。一一座上。有胜光明。普照王园及日光林。于光明中。雨天宝衣及杂宝珠。柔软可爱。以布其地。譬如大海悉具众宝。此日光泉。栴檀香水。蹑则没踝。随足旋转。举足还复本相如故。于其池中。有众色鸟。凫雁鸳鸯。[非/鳥]翠孔雀。各自顾影。雅音相和。飞翔空中。集栴檀林。此王园林。日光泉水。出生无尽清净杂花。有无价香。散众花间。超过帝释喜见林池。宝树宝铃。枝叶花果。不鼓自鸣。出妙音声。有诸天女。端正殊妙。如自在天后。此王园林。倍更明显。胜诸天宫。此诸天女。鼓乐弦歌。声遍王园。充悦一切天劫流毓衣被树枝间。于林四边。有四天王。一切皆是。大权菩萨。领四种兵。以为备卫。种种楼阁。天缯华盖。及诸殿堂。亦有兵众。而卫护之。此园庄严。犹如帝释照明宝林欢喜之园。普皆严净。视之无厌。出过三界人天果报大梵善净庄严讲堂。不得为比。无量梵王清净报明眼所不能见。此功德林及日光泉。假使和合百千梵宫。所不能及。珍妙庄严。不可具说

尔时善财童子。见此园林种种光明微妙严饰。悉是菩萨本业净行。如实功德善根愿力之所成就。超绝世间三界果报。于不可思议阿僧祇劫诸如来所植众德本。不着世间。远离揣食。犹如幻师。见众色像。广修净业。无著胜行。不可破坏。所谓师子奋迅比丘尼。晓了诸法性相如幻本修功德。长养善根。成熟五力。而无所著。此王园林广博严净。普容一切三千大千世界。天龙夜叉。乾闼婆阿修罗。紧那罗迦楼罗。摩睺罗伽。人非人等。一切悉集。入此王园。而不迫迮。何以故。皆是师子奋迅比丘尼。威神力故。不可思议神通变化。皆从菩萨本愿海生

尔时善财童子。普见一切诸宝树下师子之座。一一座上有比丘尼。名师子奋迅。端严胜妙威仪庠序。其心善寂。调伏诸根如大龙象。如如意珠普适众愿。心无所著犹如莲花。如师子王威伏众兽。安住不动。无相戒故。其心清净消除烦恼。犹如香王灭除臭秽。如大药王诸药庄严。灭除众病如良药王。善心见者能除众病。不善见者反成毒害。菩萨摩诃萨。亦复如是为有缘无缘者。说微妙法。有缘者。见我形闻我声。即得无碍陀罗尼。无缘众生更增恶行。无记众生即得善心。如波楼那天庄严微妙。普施世间。一切清净。长养善根如良福田。又见此座种种大众。或见净居天眷属围绕。又见摩醯首罗天眷属围绕。是诸天众。一心谛观彼比丘尼。目不暂舍。时比丘尼。即为净居天众及摩醯首罗天等。说无尽法门无受法行。又见此座欲乐天子眷属围绕。一心瞻仰。观比丘尼。目不暂舍。时比丘尼。为欲天众说普明音声名问清净法门。又见此座自在天王天子天女眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为自在天众。说菩萨名字自在清净法门。又见此座化乐天王天子天女眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为夜摩天众。说一切法清净庄严法门。又见此座兜率天王天子天女眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为兜率天众。说安乐心藏旋复自在无碍陀罗尼法门。又见此座夜摩天王。眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为夜摩天众。说出生无量清净胜妙庄严法门。又见此座释提桓因眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为释天众。说不净忍厌离无常苦空无我法门。又见此座解空娑伽罗龙王与十光明龙王等眷属围绕。难陀龙王跋难陀龙王等眷属围绕。摩那斯龙王伊那槃那龙王阿[少/兔]婆达多龙王等各与龙子龙女眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为诸龙王。说一切救护善巧方便法门。又见此座提头赖吒天王。领乾闼婆等男女大小眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说欢喜无尽法门。又见此座摩睺罗伽阿修罗王眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说法界庄严明慧速疾法门。又见此座大天势力迦楼罗王男女大小眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说度生死海无所畏法门。又见此座善音紧那罗王男女大小眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说佛本行清净无著法门。又见此座金角云结摩睺罗伽王男女大小眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说诸佛欢喜普集法门。又见此座无量男女童男童女眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说无胜法门。又见此座。常食众生精气罗刹王等眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说普慈悲观法门。又见此座出家声闻一切皆集。俱来会坐。时比丘尼。为说智慧光明胜法门。又见此座出家乐缘觉者。俱来会坐。时比丘尼。为说净明佛功德法门。又见出家乐大乘者眷属围绕。俱来会坐。时比丘尼。为说普门智慧光明三昧法门。又见此座初发心菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说一切诸佛大愿聚法门。又见此座二地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说虚空明净罗摩伽三昧法门。又见此座三地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说庄严寂静法门。又见此座四地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说一切种智势力境界法门。又见此座五地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说普集净花藏法门。又见此座六地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说出世清净藏法门。又见此座七地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说普依止清净地藏法门。又见此座八地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说法界毗罗摩伽普遍法身化现一切虚空境界法门。又见此座九地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说无碍无著清净力庄严法门。又见此座十地菩萨眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说圆满无障碍净名三昧法门。又见此座金刚力士眷属围绕。一心谛观彼比丘尼。目不暂舍。时比丘尼。为说智慧庄严那罗延金刚相三昧法门。如是等一切大众。一切众生。一切诸趣。所应受化者。一切眷属。种善根者。随诸众生种种欲。种种行。种种道。乐闻多法者。为长养善根故。为增长善根故。庄严善根故。随其所应。开示显说阿耨多罗三藐三菩提。转不退转法轮。令诸众生。得不退轮。何以故。此皆是师子奋迅比丘尼。成就普眼智慧光明舍离法门。成就一切诸佛法界无相清净法界通达无碍法门。此比丘尼。成就无著无碍清净秘藏法门。成就圆满不可思议净藏法门。成就清净普喜见藏法门。成就十万亿不可数般若波罗蜜。成就普眼般若波罗蜜。成就一切佛法法界不可坏般若波罗蜜。此王园林日光泉侧。一切大众菩萨摩诃萨等。一切皆悉久植善根。缘此比丘尼说法教化。乃至阿耨多罗三藐三菩提。其心善寂。得不退转

尔时善财童子。见师子奋迅比丘尼久已成就如是等普门法门普现色身。而自庄严。令王园林日光泉水。及诸宝树众师子座。皆现希有奇特之事。所有园林。经行禅窟。及诸所须宝物床帐。见诸大众一切眷属。悉坐其中。功德神力。皆悉具足。八种音声。说众妙法

尔时善财童子。见此不可思议诸奇特事。及闻微妙八种音声。复闻不可思议清净妙音。宣扬赞叹无量法空法门。以此法门。润泽身心。皆令柔软。此名正法对治无比法门。得此法门已。身心欢喜。豁然大悟。成就一切诸大法门。恭敬合掌。绕百千匝。即前作礼。未举头顷。见比丘尼。遍处一切师子宝座。放大光明。金色赫奕。照王园林及诸树木。犹如光云。此光明力。令诸树木。皆悉右旋绕无数匝。此诸树木。行行相次。皆放光明。照比丘尼

尔时善财童子。睹此相已。合掌而立。恭敬却行。住于一面。白言大圣。我已先发阿耨多罗三藐三菩提心。唯愿大圣。慈悲怜愍。为我宣说。我今不知。云何学菩萨行。修菩萨道。唯愿大圣。为我解说。时比丘尼。答善财言。善哉善哉。善男子。我今知此一切种智普能开现无底法门。善财童子。白言。大圣。一切种智无底法门。体性云何。时比丘尼。答善财言。善男子。此是三世大圣智慧光明庄严法门。善财童子。白言。大圣。三世诸佛智慧光明庄严法门。境界云何。答言善男子。入此法门者。得深入现前分别正受一切诸法不生不灭平等法林庄严三昧。住此三昧者。即得如意自在神通。此阎浮提。示现处兜率天。十方无量微尘世界。处兜率天。亦复如是。于彼彼处一一佛所。示现无量无数之身。从于自身。出无量无数微尘等佛刹海摩[少/兔]摩身。恭敬礼拜。修诸福业。又赍无量无数不可说不可说微尘数杂色花云。不可说不可说杂色璎珞云。不可说不可说杂色宝鬘云。不可说不可说杂色涂香末香云。不可说不可说杂色缯盖幢幡云。不可说不可说杂色宝网宝帐云。不可说不可说杂色宝座云。一一座前。有不可说不可说灯光炎庄严云。一一灯光。有众宝珠。而庄严之。乃至不可说不可说一切杂色庄严具云。供养如来。又赍不可说不可说杂色香水云。从香水云中。出不可说不可说杂宝莲花云。从杂宝莲花云。出不可说不可说天璎珞庄严云诸宝光明庄严具。乃至阿迦腻吒一切诸天供养具云。又从香水。出不可说不可说转轮圣王及诸小王一切世间诸供养具云。又从香水。出不可说不可说龙神八部乃至一切不可说不可说供养具云。供养如来。遍一切处。一切诸菩萨。处兜率天。化乘白象。降神母胎。初生王宫。舍家学道。诣菩提树。成等正觉。转净法轮。升忉利天。为母说法。天上人中。变现自在。乃至涅槃。于诸佛所。植众德本。以此本愿因缘力故。示现摩[少/兔]摩色身。遍一切处。供养诸佛。诸供养具。亦复如是。如是种种诸供养具。皆缘久修大愿庄严法界力生。若有众生。知我所修如是供养者。皆于阿耨多罗三藐三菩提。得不退转。若有众生。来至我所。我即为说摩诃般若波罗蜜。示教利喜。善男子。汝今当知。我常不起众生相。不着众生相。众生无相故。知一切语言音声。而不着音声。音声无性相故。见一切佛光明相好。而不着相好。何以故。深知法身无色相故。受持一切诸佛法轮。而亦不着法轮之相。深心解了诸法真如实际法性相故。于念念中。充满普遍虚空法界。而亦不着法界相。善能了知一切诸法如幻化相故。善男子。我唯知此一切种智普能开现无底菩萨法门。善男子。汝今当知。诸大菩萨。究竟法界一切菩萨境界无著。能以一身。结加趺坐。充满十方一切世界。于自身内。悉能示现一切十方诸佛刹土妙庄严事。于刹那刹那顷。周遍十方。礼事诸佛。于自身内。普能示现一切诸佛神通变化愿力。能以一毛。遍缚十方诸须弥山。举置他方无量世界。于一一毛孔。普现十方一切世界劫成坏相。于一刹那顷。普于十方不可说不可说劫。摄受众生。终不舍离诸大菩萨摩诃萨具足一切深智海行。我当云何能知能说彼功德愿。善男子。汝从此南行。有国。名崄难。城名宝庄严。于彼城中。有一女人。名婆须蜜多。汝诣彼问。云何菩萨学菩萨行。修菩萨道

尔时善财童子。头面敬礼师子奋迅比丘尼足。瞻仰谛观。辞退南行。善财童子。得大慧光。以照其心。具足长养一切善根。欲以教化诸众生故。一心思惟诸法实相。建立一切清净法水语言陀罗尼藏。广修受持一切法轮陀罗尼成就思惟力。为众生归依大悲一切世间之力。方便观察一切种智充满法界速疾思惟一切净法愿普观察光明法门。庄严十方诸通明力。皆悉充满一切法界。究竟成满诸菩萨行诸菩萨业。满足愿力。具诸神通渐渐游行。至崄难国宝庄严城。推问尊者婆须蜜多女。今在何所。其城中人。作如是念。我不闻此女有深智慧善摄诸根身心寂静。今此童子。威仪庠序。其心恬泊。调伏诸根。远离放逸颠倒惑乱。念慧现前。视瞻详审。言音和雅。不着形色。正念思惟甚深法相。远离懈惓。心如大海。此非染欲颠倒之人。无情欲想。不没欲泥。不随诸根。超出魔界。不为一切诸魔所缚。如此童子。具诸功德。何故为色。问此女为。今此城中。多有诸人。乃至不闻此女人名。何况识者。有一人言。善哉善哉。善男子。汝于今者。必获大利。乃能问此尊者婆须蜜多。如汝问意。必已先发阿耨多罗三藐三菩提心。决定为于一切众生。必能永离淫怒痴箭。不坏净想。不着不净。普解一切诸缚著者。善男子。今此尊者婆须蜜多。在此城北欢喜园中庄严楼阁。止于其中

尔时善财童子。闻此语已。欢喜踊跃。往诣其所。住于门侧。叉手合掌。瞻察园内。见彼宫宅。广博严净。十种宝墙周匝围绕。列殖十行宝多罗树。十种宝堑其水清深。具八功德盈满其中。优钵罗花。钵头摩花。拘勿头花。分陀利花。开敷鲜荣弥覆水上。底布金沙宝岸严丽。杂色光明充遍园林。宝殿楼阁清净庄严。绮窗香风怡悦众心。连钱半月校饰罗网。金刚力士嗔目奋杵。众宝师子震尾哮吼。壮士兽王列侍门侧。宫城四角有明珠柱。众宝观阙放种种光。雨宝珠花积至于膝。净琉璃地如悬虚空。有如意珠王映于地下。紫磨金渠流香色水。黄金莲花敷荣其上。从莲花台涌妙声水。演散法音流闻十方。金色芭蕉放大光明。处处积宝犹如山岗。沉水香云回旋宛转。涂香末香遍熏宫城。异类众鸟出和雅音。张大宝帐垂众金花。摩尼宝铃众宝厕填。阎浮檀金以为罗网弥覆宫墙。烧百千万亿无价宝香。香烟芬馥充满虚空。无量诸天列侍供养。诸天妓乐不鼓自鸣。众吉祥瓶盛如意珠从地踊出。又雨无量天宝花云。无量天宝香云。无量幢幡宝盖云。无量天衣璎珞云。无量妓乐天音声云。如是种种供养具云。一一皆放无量色光。弥覆虚空。照十方界。无量万亿金刚宝藏。盈满宫中。一一宝园。雕文刻镂。光光相照映彻无碍。复有无量十种宝园以为围绕。珍妙庄严。清净无极。尊者婆须蜜多。端正微妙。色如花敷。相好具足。身真金色。不长不短。不肥不瘦。目睫绀色。如青莲花。鬓发柔润。其色绀艳。威仪齐整。进止庠序。手足鲜泽。千辐轮相。六欲天后。不得为比。声踰梵音。悉解众语。善知世间工巧技艺。深达一切诸论根本。及论议相皆悉究尽。善知字义。善辩正智善巧方便如幻境界。善知菩萨方便法门。善知菩萨方便法界。具诸相好。璎珞严身。摩尼宝冠。放大光明。心王明珠以为花鬘。本愿眷属皆悉围绕。功德成满不可沮坏。具足无尽功德宝藏。身出光明普照一切。饶益光柔软光。悦乐光开心光。庄严菩萨心道之光。以此光明。严饰一切众生之心遇斯光者。得离五欲。拔众苦根

尔时善财童子。诣尊者婆须蜜多所。叉手合掌。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知云何学菩萨行。修菩萨道。答言善男子。我唯知此一亿离欲无垢具足庄严菩萨法门。善男子。若天见我遍一切处。天光璎珞。以自严饰。为天女形。若人见我。我以上妙色清净慈心。而自庄严。为童女形。非人见我。我现非人女形。端正殊妙。遍非人处。若有众生。来至我所。起淫怒痴。无有是处。唯得菩萨无受正法。恒为众生说清净解脱离苦法门。闻我名者。得厌离观。速得成就功德三昧。身心寂静。无有障碍。见我形者。即得欢喜三昧。闻我声者。即得无量声藏三昧。闻我名者。即得归依佛法僧宝。即得诸佛刹普现色三昧。若有众生。与我同止者。即得解脱光三昧。若有众生。谛观我者。即得寂静庄严三昧。若有见我频申欠呿者。得坏散外道三昧。若有众生。观察我者。得一切诸佛境界光明三昧。若有众生。与我言者。即得守护摄受一切众生藏三昧。若有众生。为我搔痒者。即得一切德集花藏三昧。若有众生亲近我者。即得一亿无染离欲庄严菩萨无著无极明净一切智境界法门。善财童子。白言大圣。昔于何所。修何功德。种何善根。有何等业。得此法门。答言善男子。过去有佛。号无染着行如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时无染着行如来。出兴于世。为哀愍饶益一切众生故。向普贤城。始至界上。当举足时。国土城邑六种震动。下足之时。丘墟坑坎。皆自夷平。空中清明。自然严净。尔时世尊。足蹈门阃。即时大地复更震动。瓦砾墙壁化成七宝。散杂宝花列住空中。罗覆宫城。百千万亿诸天乐器。众宝校饰。悬在虚空。不鼓自鸣。无量诸天。各与宫殿。列侍空中。顶礼佛足。雨诸天花。以供养佛。佛入城时。放金色光。犹如金山。我于尔时。生彼城中。为长者妻。亦名婆须蜜多。见佛色身相好光明神通具足。即开发我宿世善根。我于尔时。与夫长者。疾诣佛所。即脱所著无价宝珠。以散佛上。所散宝珠。悉住虚空。接足作礼

尔时文殊师利童子。为佛侍者。时文殊师利。即告我言。善女人。汝可速发无上道心。我于尔时。始发菩萨无上道心。婆须蜜多。告善财言。我唯得此一亿无染离欲庄严无著法门。诸大菩萨智慧方便化度众生大海深广三昧法门。大智慧力不可坏伏境界。我当云何能知能说彼功德行。善男子。汝从此南行。彼有大城。名曰善寂。城中长者。名曰不憍高贵德王。彼大长者。昼夜六时。恒常供养栴檀宝塔。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼彼女人足。辞退南行。渐渐游步。至彼大城。到长者所。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知云何学菩萨行。修菩萨道。长者答言。我唯成就不灭度实际菩萨法门。住此法门。我今审知诸佛如来。不般涅槃。不入灭度。三世如来。永不涅槃。无涅槃相。除佛方便为度虚伪众生故示现涅槃。欲令舍利广流布故。普令一切得入律行。善男子。若人能知如来毕竟不般涅槃者。是人能开栴檀宝塔。善男子。汝今可往礼拜供养。善财童子。即至塔所。头面敬礼。开栴檀塔。开塔户时。念念相续。得无尽佛性圆光明净无尽三昧法门。善男子。我心于刹那刹那顷。常入正受。于正受中。得无量无数圆光明净三昧。于念念顷。入胜进地。善财童子。白言大圣。此法门者。境界云何。答言。善男子。我入此三昧时。普入一切三昧道门。三昧力故。得见十方无量诸佛迦叶如来应供正遍知。十方无量各恒河沙微尘数世界海。同名迦叶如来等。拘那含牟尼佛及十方无量恒河沙微尘数世界海。同名拘那含牟尼佛等。尸弃如来及十方无量恒河沙微尘数世界海。同名尸弃如来等。毗婆尸如来及十方无量恒河沙微尘数世界海。同名毗婆尸如来等。提舍如来及十方无量恒河沙微尘数世界海。同名提舍如来等。弗沙如来及十方无量恒河沙微尘数世界海。同名弗沙如来等。无上胜佛及十方无量恒河沙微尘数世界海。同名无上胜佛等。无上莲花佛及十方无量恒河沙微尘数世界海。同名无上莲花佛等。如是无量诸佛。行行相次。不相障碍。一如来面白毫相中。映现一切十方无量一切诸佛。十方一切无量诸佛白毫相中。映现一佛。一切诸佛毛孔光明。更相映现。亦复如是。坐栴檀塔。我于刹那顷。皆悉睹见诸佛世尊。心心相续。间无空缺。亦于刹那顷。得见阎浮提微尘数。复见百千万亿阎浮提微尘数。乃至十方恒河沙不可说不可说世界微尘数诸佛。复过是数。得见无量无边微尘数诸佛。乃至得见不可说微尘数世界海诸佛。又见诸佛从初发心。游戏神通无碍自在。亦见一切大愿清净妙行成就分别功德不二法门。亦见满愿波罗蜜清净波罗蜜成就次第一切菩萨诸地。得普忍清净游戏神通。长养善根。降伏四魔。成就众生。严净佛土。成菩提道。转妙法轮。放大光明。是诸大众。悉睹此相心心相续。间无空缺。时高贵德王菩萨。告善财童子。善男子。汝今见此栴檀塔中无量净明圆光明净神通庄严诸如来不。悉皆同入毗罗摩伽三昧神通法轮不二法门不。诸佛如来。以此明净不二法门神通力故。遍一切处。转妙法轮以明净镜身充满法界。尔时善财童子。白言大圣。我今已见一切诸佛神通游戏清净境界。亦闻诸佛说法音声。了了分明。不坏耳根。受持不忘。正念思惟。不失句义。次第分别。为人演说。示教利喜。以智慧力。分别诸佛法教。教授众生。见弥勒等未来百佛千佛。百千佛亿万佛。阿閦婆。频婆罗。阿僧祇佛。于念念中。刹那顷。心念明净。亦见未来恒河沙不可说不可说世界微尘数等众生。发菩萨心。修菩萨道。行三十七品。具六波罗蜜。游戏神通。教化众生。净佛国土。取吉祥草。坐菩提树。降伏四魔。成等正觉。转妙法轮放大光明。示现涅槃。乃至正法像法。劫数成坏。心心相续。皆悉明了。如见此境未来国土十方世界。亦复如是。亦见现在毗卢遮那多陀阿伽度阿罗诃三藐三佛陀等。无量无数一切诸佛。从初发心。坐于道场。转妙法轮。示现涅槃。正法像法。劫数成坏。住世久近。如此世界。十方亦然。十方三世一切佛刹。火劫起时。于栴檀塔。倍更明显。亦闻十方三世诸佛已说今说当说。以智慧力。悉能受持。一切世间。声闻缘觉。及小菩萨所不能及。善男子。我唯知此不生不灭实际庄严平等菩萨法门。诸大菩萨于一念顷。悉知三世佛法本际平等。于刹那顷。庄严无量三昧境界海门。住如实际。无彼我相。亦无二意。住佛所住。于一切而无怯想。住欢喜法界。清净庄严。三乘贤圣。如实智慧。平等无二。不着世间及世间果。一切三世如来印绶及受决法。悉充法界。常住不灭。一切如来。音声充满。法界不可思议。无量无边。不可具说。我当云何能知能说彼功德行。善男子。于此南方。有孤绝山。名金刚轮庄严高显。彼有菩萨名观世音。住其山顶。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼高贵德王菩萨足已。绕百千匝。眷仰瞻察。辞退南行

尔时善财童子。正念思惟彼长者教。随顺菩萨解脱之藏。正念菩萨诸忆念力。承佛威神佛本愿力。以三昧正受。于念念中。间无空缺。常念栴檀宝塔无量诸佛。悲泣雨泪。寻路而行。次第分别一切诸佛及诸佛法。于一心中。庄严诸佛神通念定慧力。为欲长养菩提善根。思惟正念一切诸佛不思议业。渐渐游行。到彼孤山。步步登陟。念观世音。正念不舍。遥见经行在岩西阿。处处皆有流泉花树。林池清渌。金花香草。柔软鲜洁。皆从菩萨功德所生。至其山顶。见观世音坐于金刚八楞之座。座出光明。严饰无比。与无量菩萨。眷属围绕。而为说法。时观世音。身真金色。手执大悲白宝莲华。说大慈悲经。劝发摄取一切众生。入于普门示现法门

尔时善财童子。既得见已。欢喜踊跃。不自胜持。生希有心。合掌谛观。目不暂舍。作如是念。善知识者即是如来。善知识者是佛道正因。善知识者是法宝云。善知识者是功德行藏。善知识者十力妙宝。善知识者难见难值最胜无比难可测量。善知识者是十二头陀正因之行。善知识者是无尽智藏。善知识者生功德牙茎。善知识者能开发示道一切智门。善知识者能令一切众生得入萨婆若海。究竟清净无上佛性菩提境界。如是赞叹善知识已。渐渐亲近。时观世音。遥见善财。赞言。善哉善哉。善来童子。专求大乘。摄取众生。救护一切众生。生柔软心。正直心。深心。求佛法心。起大悲心。向普贤行。发一切大愿清净之行。成就一切大愿庄严。常乐受持一切佛法宝云。心不亏减。增长善根。修诸功德。无有厌足。顺善知识。不违其教。从文殊师利智慧大海。成熟心行。得佛势力光明三昧。身心严净。无有垢秽。永离懈怠。终不退转。常见诸佛心生欢喜。远绝众恶。修诸善行。成就智慧。心无障碍。净如虚空。速得对治离苦法门。住诸如来境界光明守护法城。广宣法教

尔时善财童子。至观世音菩萨所。头面礼足。绕百千匝。合掌恭敬。却住一面。白言大圣。我已先发阿耨多罗三藐三菩提心。而未能知云何菩萨学菩萨行。修菩萨道。答言。善哉善哉。善男子。汝今已能发阿耨多罗三藐三菩提心。善男子。我已成就毗罗摩伽三昧大悲法门。善男子。此毗罗摩伽三昧大悲法门。是菩萨行。一切菩萨功德智慧。悉入其中。三昧力故。不移此座。普现一切清净色身。以普现法门清净光明之行。于十方世界。教化成熟六趣众生。常于一切诸佛所。随所应化。普现其前。或以布施摄诸悭贪。或以持戒摄诸毁禁。或以忍辱摄诸恚恼。或以精进摄诸懈怠。或以禅定摄诸乱心。或以智慧摄诸愚痴。以六和敬善顺众生。以四摄法摄取众生。放大光明网除灭众生烦恼热痛。以方便波罗蜜行布施爱语利益同事。摄取众生。以一切光明网微妙音声。普为十方一切众生。演说一切圣解脱法。成就一切诸波罗蜜。随诸众生。应以诸佛菩萨声闻缘觉形色威仪。而得度者。皆为现身。坐金刚座。手执白花。为说毗罗摩伽菩萨本行大悲法门圣解脱法。若有众生。应以六趣形色威仪。而得度者。现六趣身坐金刚座。手执白花。为说毗罗摩伽大悲法门圣解脱法。令彼众生皆得悦乐。以妙色身。变现自在。示同类身。普度一切。随其威仪。乃至同心。摄取众生。善男子。我常行此大悲法门毗罗摩伽菩萨圆满智慧光明三昧。我于往昔。发清净誓。满足愿故。以此净愿果力。住此法门。是故此三昧门。名为大悲具菩萨行毗罗摩伽三昧法门。教化一切众生。为诸众生而作屋宅归依覆护依止之处。为诸众生作大桥梁。作大洲渚。为诸众生。作大炬烛。作大导师。乃至究竟处。为化众生故。发弘誓愿。见闻我者。皆得欢喜。欲令一切五道众生。远离崄难恶道恐怖。热恼恐怖。愚痴恐怖。系缚恐怖。杀害恐怖。贫穷恐怖。不活恐怖。诤讼恐怖。大众恐怖。死恐怖。堕四恶道恐怖。诸趣恐怖。不同意恐怖。爱不爱恐怖。一切恶恐怖。逼迫身恐怖。逼迫心恐怖。愁忧恐怖。懈怠恐怖。邪淫贪色恐怖。生老病死忧悲苦恼。所求不得。爱别离苦。怨憎会苦。为脱一切众生苦畏海故。发大誓愿。住此净慧光明法门。复次善男子。出生现在正念救护三世一切众生怖畏正念法名字法轮法门。为脱轮转三界众生故。入论议法门。住此法门故。示现一切众生等身种种方便。随其所应。以是方便。除其恐怖。皆令发阿耨多罗三藐三菩提心得不退转。供养诸佛。受持正法。善男子。我唯知此大悲清净毗罗摩伽菩萨光明法门。诸大菩萨。一切皆具普贤菩萨清净大愿。成满究竟普贤之行。不断一切诸善根流。不灭一切诸三昧流。常修阿毗跋致行。未曾断绝。善知世界成坏之相。灭诸众生不善根牙。生出一切诸善根流。灭诸众生生死心流。出生众生善根心流。我当云何能知能说彼功德行

罗摩伽经卷上佛说罗摩伽经卷中

        西秦沙门圣坚译

尔时东方有一菩萨。名无异行。宝花承足。步虚而来。诣娑婆世界金刚轮山。足蹈山时。娑婆世界。六种震动变成众宝。以为庄严。举身毛孔。普放光明。皆悉映蔽日月星辰。梵释四王。及一切天龙神夜叉。揵闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。人非人等。火珠光明。摩尼珠光。皆如聚墨。又此光明。普照地狱。饿鬼畜生。阎罗王处。及诸幽闇。消灭众苦。断除烦恼病苦怖畏。皆得安隐。普雨宝雨。充满佛刹。及雨一切供养之具。以是等种种供养。供养如来。随诸众生所应见身。为其示现。遍六趣已。到金刚轮山。至观世音所。尔时观世音菩萨。告善财言。善男子。汝见此座无异行菩萨不。答言。大圣。唯然已见。时观世音。告善财言。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼观世音足。绕无数匝。观察无厌。正念圣教。深入智海。却行辞退。至无异行所。头面敬礼。右绕七匝。毕已合掌而立。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。答言善男子。我已成就普现速行法门。善财童子。白言大圣。于何佛所。得此法门。所从来刹。去此几何。发来久如。答言善男子。此处难知。一切天人。及阿修罗。人非人等。所不能测。唯勤精进不退转行。亲近善知识佛所护念。乃能得知。若非具足宿善根力清净直心。具菩萨根开智慧眼。多闻多知。尚不得闻。不能深入贤圣智慧。何况信解菩萨行处。善财童子。白言大圣。唯愿为我。说彼国土如来名号。我当承佛神力及善知识力。信五根力。成就神通力。而得信解。尔时无异行菩萨。答善财言。我所来刹。名妙首法藏。佛号普贤首。于彼佛所。得此普现速行法门。从彼发来。已经不可说佛刹微尘等劫。于一念中行不可说佛刹微尘等步。一一步过不可说佛刹微尘等世界。所经诸国。佛皆现在。以一切菩萨无尽供具。供养诸佛摩[少/兔]摩身。所以者何。以我得此无著清净法性生身如实相印三昧法门。以是功德。能供养如来无著法身。以一切诸菩萨所希见事。供养诸佛。随诸众生宿世善根。为现色身。而为说法。放大光明。普照十方。应适众心。随其所须。如意皆得。成就法藏。出微妙声。演说正法。饶益众生。以妙法身。度脱众生。乃至十方。亦复如是。善男子。我唯知此菩萨普现速行法门。诸大菩萨。普于十方。无所不至。境界无量。无能坏者。清净法身。充满法界。分别了知诸众生道。满一切刹。顺一切法。等观三世。说平等法。随顺世间。不着佛道。普至无著无碍。善说一切诸法实相本性空寂。我当云何能知能说彼功德行。善男子。于此南方。有城名婆罗波提。彼有一天。名曰大天。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面礼敬无异行菩萨足。绕无数匝。瞻仰观察。辞退南行

尔时善财童子。正念思惟菩萨毗罗摩伽无障碍行。一向专求无异行菩萨智慧境界所出光明智慧神通色身境界。一切功德庄严境界。勇猛精进。坚固欢喜。出生无量不可思议持行法门。游戏神通。得决定智。深心悦乐。遍体欢喜。具诸功德诸三昧地。陀罗尼地。诸大愿地。诸辩才地。具诸力地。渐渐游行。至彼城门。推问大天今在何所。时有人言。善男子。今在城内重阁堂上。成就微妙清净色身。大众围绕。化现说法

尔时善财童子。诣大天所。头面敬礼。白言大圣。我已先发阿耨多罗三藐三菩提心。而未知菩萨云何学菩萨行。修菩萨道。是时大天。即申四臂。取四海水。安置四掌。不令漏落。自为善财童子。澡面漱口。取金莲华。以散善财。而作是言。希有善男子。甚奇甚特。乃能远来。求善知识。善男子。诸菩萨行。难闻难见。甚深微妙。不可思议。勇猛精进。形容微妙。人中分陀利。为众生归依。覆护一切。饶益众生。摄取不舍。安隐一切。普照一切十方刹海。显现正道。远离愚痴。为大导师。护持正法。将引众生。安隐无患。到于彼岸。必定当至一切智城。甚为希有。菩萨三业。具足成就难净能净。永离众恶。于众生类。常以爱语。随其所应。悉现其前。未尝失机。善男子。我唯成就菩萨云网光明法门。善财童子。白言大圣。此云网光明法门。境界云何。尔时大天。于善财前。积天金聚。犹如山王。积白银聚。积琉璃聚。积颇梨聚。积车磲聚。积马瑙聚。积夜光聚。积水精聚。积金精聚。积开导众生摩尼聚。积绀发摩尼聚。积周罗摩尼聚。积水光摩尼聚。积玫瑰聚。积紫玫瑰聚。积日精珠聚。积弥罗佉宝聚。积杂色宝聚。积毗富罗宝聚。积赤真珠罗网聚。积栴檀摩尼聚。及积庄严支节一切身分诸璎珞聚。犹如须弥。一切花一切香。一切涂香。一切末香。一切花鬘。一切天衣。一切宝盖。一切幢幡。一切乐器。一切床帐。诸供养具。五欲境界。如是众宝。积如须弥。又复显现阿僧祇百千万亿诸童女众。语善财言。善男子。汝可取此一切众宝。供养如来。惠施一切。摄取众生。悉令众生。修檀波罗蜜。学檀波罗蜜。一切舍故。以此舍心。教授一切。普得修行。令诸众生。能舍难舍。善男子。我以此物。教汝布施。普教一切。亦复如是。悉令众生。以无贪善根。熏修身心。普使众生。修佛菩萨行。亲近善知识。供养恭敬。尊重赞叹。出生善根。长养善根。成就具足一切善根。发阿耨多罗三藐三菩提心

复次善男子。若有众生。贪五欲者。为彼示现不净境界。贪国土者。为说无常。为嗔恚怖畏。憍慢放逸。诤讼结恨如罗刹鬼。杀生无度。饮血啖肉。如是等种种众生。悉为示现。教彼众生。修大慈悲。皆令永离嗔恚放逸。若懈怠者。为现水火盗贼恶王怨敌等难。化以无常。起诸善根。善男子。如是种种恶类众生。以方便慧。灭除诸恶一切障碍智慧怨敌。成就一切诸波罗蜜。善男子。我唯知此菩萨云网光明法门。诸大菩萨。灭除烦恼。如忉利天王。灭阿修罗难。诸菩萨如水。能灭众生烦恼炽火。诸菩萨如火。能烧众生烦恼积薪。诸菩萨如风。吹散众生贪爱诸着。坏灭一切染爱痴心。诸菩萨如金刚。摧灭一切彼我有爱。诸大菩萨。成就如是诸大功德。我当云何能知能说彼菩萨行。善男子。此阎浮提南方有国。名摩伽陀。寂灭道场菩提树下。有神名安住。汝诣彼问。云何菩萨学菩萨行。修菩萨道。时善财童子。头面敬礼彼大天足。尔乃辞退。趣摩伽蛇国诣寂灭道场安住神所

尔时十千地神。各作是言。此童子来能救护一切众生。即是如来藏。能破众生无明[穀-禾+卵]膜。常生胜妙法王之家。离垢无障。以无量天缯宝冠。以冠其首。有大智慧宝藏。摧伏外道异学诸论议师。法轮王法。教化众生。尔时安住地天一万神等。震动大地。雨以香水。扫以香风。一万地天。异口同音。出微妙声。遍满三千大千世界。放大光明。普照三千大千世界。复有众宝宫殿。以为庄严。一切花树。开敷鲜茂。曲枝垂下。一切果树。悉成果实。亦皆垂下。一切香水。泉源河池。回渊旋流。更相灌注。演出种种娱乐音声。诸天众宝庄严楼阁。骐驎师子。香象白鹿。凤凰孔雀。异类禽兽。各与眷属。赍持供具。皆悉欢喜。出哀和音。无量宝藏。自然涌出。四方风起。犹如金轮。吹众杂花。散道场地。天龙夜叉。揵闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。人非人等。充满林间

尔时安住地神。告善财言。善来善男子。汝欲自见往昔曾于此处所种善根福报果不。是时善财童子。头面敬礼安住天足。绕无数匝。却住一面。白言大圣。唯然欲见。尔时安住地神。即以足指。案此大地。无量阿僧祇那由他摩尼宝藏。开发显现。众吉祥瓶。自然涌出。善男子。汝昔布施果报。致此宝藏。恣随汝意。以用布施。善男子。我已成就菩萨不可坏智慧藏法门。我从然灯佛来。获大善根。常住此地。次第护诸菩萨。令得深入智慧境界尽其源底。大愿成满。净菩萨行。出生一切三昧。修一切神通。具足一切菩萨大方广功德力。具足诸菩萨大威德力。成就菩萨不可测智慧。其心坚固不可破坏。放光明网。游诸佛刹。闻诸如来受记法轮。一切如来所转法轮一切修多罗云。以大法光明。普化众生。受持诸佛自在神力。守护诸佛大法明力。示教利喜。我唯知此菩萨不可破坏智慧法门。善男子。乃往古世过须弥山微尘数劫。有劫名光明净。世界名月幢。如来号善眼。善男子。我于光明净劫善眼佛所。思惟得此法门。修习长养净此法门。增进高广普演法门。于其中间。常得见佛。从光明劫。乃至贤劫。于其中间过不可说不可说佛刹微尘等劫。劫中诸佛。我悉亲近。具足供养如是诸佛。往诣道场菩提树下。诸庄严具。我悉得见。于一一佛所听受修习。得此法门。于诸佛所。修习善根。以此善根。闻法因缘。得不可坏藏智慧法门。善男子。我唯知此菩萨不可坏藏智慧法门。诸大菩萨。于一切佛所。亲近供养。诸佛说法悉闻受持。随佛音声。为他演说。念念相续。得入佛心。住佛秘密。得净法身。超出菩萨无明习[穀-禾+卵]。出生一切诸佛影藏。善说句义。忆持不忘。普现诸色身。于身不二相。诸菩萨行。无量无边。我当云何能知能说。善男子。此阎浮提。有国名无恼。城名胜忍。于彼城中。有一夜天。名婆娑婆陀。汝诣彼问。云何菩萨。学菩萨行。修菩萨道。时善财童子。头面敬礼安住神足。绕无数匝。眷仰辞退。渐渐游行。诣夜天所

尔时善财童子。正念思惟彼地天教菩萨不可坏智慧法门。修菩萨三昧明趣入随意。观察菩萨律仪法式。其心明了诸菩萨自在游戏神通。观察一切清净法性。深入菩萨甚深智慧究竟境界。深入菩萨智海法门。随顺菩萨观察无坏智海法门。观察菩萨深极无边清净不坏法门。观察菩萨法云法海荫覆法门。渐渐游行。至彼大城绕无数匝。从东门入。中城而住。尔时善财。日没未久。思慕大师。如渴欲饮。随顺一切诸菩萨教。一心合掌。欲见大师婆娑婆陀夜天。于善知识所。起于如来应供正遍知想。普眼境界。显现十方一切色身及智慧力。遍至一切。乐见善知识住净境界。普见一切诸善知识慈心境界妙藏法门。得一切法正智慧眼。观察十方三昧智海普眼境界。不出不入同一如性一切光明法界智海。大智慧眼。深广无边。见彼夜天。于其城上虚空中住。处宝楼阁香莲华藏庄严世界。坐宝莲华。身真金色。顶髻蠡文。妙金精色。目睫绀青。分齐分明。色相端严。殊妙第一。众宝严身。希有无比。见者欢喜。视之无厌身服朱衣妙宝严饰。顶上髻发。犹如梵王。尔时夜天。即为善财童子。说蠡髻梵王顶法身印陀罗尼。即说咒曰

勒耽　婆罗婆娑那　陀罗尼　眤遮梵摩阇咤震那　舍利啰　摩鸠吒　陀罗尼　眤遮　斫迦罗陀罗尼哆莎呵蛇莎呵

善男子。若有得此陀罗尼者。于其身上诸毛孔中。普现一切日月五星二十八宿。亦现一切辰曜光明。以此光明。普照无量世界一切众生。于刹那顷。能见众生在三恶道受八难苦。于一毛孔。皆悉睹见所化众生。或见众生乐生天者。或有乐得声闻乘者。或有乐得缘觉乘者。或有乐得一切种智者。于一毛孔。皆悉显现。或有乐见种种方便形色威仪音声说法及诸语言。亦于一念。皆悉睹见。如是微妙。法音清彻。随所乐闻。经无数劫。亦于毛孔。皆悉见闻及诸菩萨一切行等。或见菩萨勇猛精进修诸三昧神通力门。菩萨自在神力境界。菩萨所住。菩萨光明。菩萨神通奋迅法门。如是种种。随所化众生。皆于毛孔。悉得见闻。皆是菩萨本行所得

尔时善财童子。见闻是已。心大欢喜。头面敬礼彼夜天足。绕无数匝。恭敬合掌。于一面立。白言天神。我已先发阿耨多罗三藐三菩提心。心生信解。因善知识。得见诸佛。闻法功德。唯愿天神。今当为我开示显现诸菩萨所行萨婆若道。若有菩萨。向此道者。当得菩萨十地十力。尔时夜天。告善财言。善哉善哉。善男子。汝能敬善知识。随顺其教。若有菩萨。敬善知识。随顺其教。疾疾当得阿耨多罗三藐三菩提。善男子。唯我成就菩萨光明普照诸法坏散众生愚痴破魔法门。善男子。我于邪见恶众生中。发大慈心。于不善业逆众生中。发大悲心。于修善众生。发欢喜心。于善恶等众生。起无二心。于染污众生。发清净心。于邪见着我众生。起平等心。于下贱不净众生。发欢喜心。于着乐众生。生清净心。于乐生死轮转众生。发善随顺解生死轮。于乐声闻缘觉众生发起安立住一切智菩提道心。善男子。我常如是思惟。教化一切众生。成就菩萨光明普照坏散众生愚痴破魔法门。于夜后分人靖无声时。一切鬼神交横驰走时。盗贼游行时。比丘离威仪时。烟云尘雾昏蔽日月不见色时。我于彼处。为作明眼。引导令过。若有众生。在于城邑村营聚落。山岩旷野。八方大海中。乃至一切水陆丛林。崄路迷道怖畏。云雷霹雳难。愚人恐怖禽兽难。旷野盗贼难。国土饥馑疾疫难。斗战破坏难。以陀罗尼力。灭其恐怖。若有众生。遭于海难黑风扬波。大浪回覆。商人迷惑。不见边涯。如是种种水陆诸难。我于彼处。为作归依。或作洲渚。或作船形。济诸溺人。或作萨薄。或作鲛人。或作象王形马王形。或作小象形鼋鼍鳖形。阿修罗王形。海神龙王形。或作狗王蚊虻形。现如是等种种类形。为作归趣。方便度脱一切苦难。愿诸众生。离五阴苦。得解脱道。一切人间。于夜闇时。瓦砾荆棘。丘陵堆阜。毒蛇师子。虎狼虺蝮。一切毒害。寒热风难。我于尔时。作日月形。明星形。流星形。彗星形。或作雷电霹雳之声。或作宝光明形。或作荧惑太白诸灾异星变怪之形。或作诸天宫殿。或作天王形。或作诸天龙神八部之形。或作转轮王形。诸小王形种种人形。或作菩萨形。或作如来形。以陀罗尼力种种方便。覆护众生。愿诸众生。常得安隐。大悲覆护。住佛所住。或作山岩石窟形。或作溪涧泉池林木药草花果树形。或作百种甘膳香美饮食。或作冰雪。或作影响荫凉之形。或作平地道路巷陌。或作迦陵频伽孔雀王等众鸟之形。或作药树王放光明形。或作山神地神形。或作炬烛电光之形。若有众生。在山崄平泽诸怖畏处。以陀罗尼力。为作救护。我以如是种种方便。令诸众生。得免忧苦离生死海。发如是念。令诸众生。越我慢山。又愿众生。超生死流。慧炬炎炽。破无明闇。烧五阴村。度死生泽。善男子。我于生死崄难愚痴众生。以陀罗尼力。决生死网恐怖系缚。恶骂咒咀。两舌恶口。诽谤谗构。我于尔时。作迦陵频伽鸟微妙之声。说陀罗尼。令彼悦乐。解脱忧苦。若婴儿童子。壮年耆老。聋盲喑哑。癃残拘躄。疥癞痈疽。乃至四百四病。以陀罗尼力。作大医王。现病人前为说种种诸治病法。各得除愈。善男子。我复作是念。见诸众生。乐着五欲棘刺林者。乐着邪见颠倒说者。乐着国土生憍慢者。如是种种爱着苦难。逼切其身不觉不知。随彼众生在在处处。念何事思何事。以陀罗尼力。即为现身。示导正路。令得安乐。蒙我恩力。离众苦难。得安隐处。我为彼人。复发誓愿。令诸众生远离三涂。永得解脱一切众苦。专求智慧。向菩提道。无众忧患。常得安隐。离五阴缚。若有边方诸小国土国王王子善男子善女人。忧国土诤讼事。忧生业田宅事。忧名称。荣位自在事。如是种种危厄怖难。我于彼处。以陀罗尼方便之力。令彼和同。皆得安隐。复发是愿。令诸众生。除五阴十二入十八界等一切诸着。越生死河。安住彼岸。又愿众生。住佛一切种智境界。永离见着。出生安乐一切佛行。若有众生。着聚落业无明系缚。六十二见。种种见着。受诸苦恼。甚可愍伤。我以陀罗尼方便为其说法。令得厌离。以法摄之。复作是念。令诸众生。安住无上正法道地。复作是念。愿诸众生。悉皆远离六入空聚。超出生死究竟境界。安处萨婆若城寂灭乐处。复次善男子。如迷方人。以东为西。以西为东。以南为北。以北为南。四维上下。亦复如是。一切世间。迷法之人。不知正道。亦复如是。善男子。世有三人。一狂。二痴。三者风病。如此三人。横兴毒害。手执利剑。欲斫东方反斫西方欲斫西方反斫东方。欲斫南方反斫北方。欲斫北方反斫南方。四维上下亦复如是。谤法之人亦复如是。心颠倒故。于正法中而生邪相。于邪法中生正法想。于常法中生无常想。于无常法中生于常想。于乐法中生于苦想。于苦法中生于乐想。于不净中生于净想。于无我法中横生我想。于平地中生崄岨想。于崄岨中生平地想。丰乐之世生饥馑想。饥馑之世生丰乐想。民炽盛世生空荒想。空荒之世生炽盛想。如此愚痴。失道众生。迷惑众生。失性众生。我以种种方便陀罗尼力。放大光明。于黑闇处。欲出道者。开其门户。为愚痴者放大光明。开智慧眼。为失道众生。开示正路。而引道之。若有众生。欲度流者。为作桥船津济洲渚。令到彼岸。不知方域示以乐土。丘墟坑坎化为平地。生柔软草。或复现作城邑聚落及诸妙色。以施众生。令得快乐。又复现作江河流泉。园林浴池。人民炽盛。安隐丰乐。令诸众生。慈心相向。犹如父子兄弟姊妹。复发此愿。我今已施一切众生一切安乐智慧光明。令彼众生永离闇冥。无复痴爱长夜迷昏无明闇蔽。无眼众生得智慧眼。普令明净。若有众生着于我人众生相者。令离我人众生等想。若有众生。无常常想。无我我想。苦有乐想。不净净想。非阴阴想。非命命想。于非中阴。作中阴想。非阴界入。作阴界入想。草木非寿命。作寿命想。众生非草木。作草木想。于非因果。作因果想。非善行道。作善行道想。杀生祠天。求常乐想。乃至十恶邪见等业。普愿众生。离此诸想。不孝父母。不敬沙门及婆罗门。无有反复。不识恩养。远离正道。行不善业。具足十六诸恶律仪。诽谤正道。毁坏正论。深着邪见。谤佛法僧。断正法轮。坏菩萨众增恶大乘。杀害菩萨。不赞菩萨僧。如是种种诸不善业。杂类众生。众苦逼身。心怀愁恼。失本智心。不知法利。狂惑愚痴。不识正路。于无量劫。常被诽谤。邪见迷惑。不识诸方者。为如是等非法非律。深生慈悲。令得覆护

尔时夜天婆娑婆陀。即为诸狂乱谤法众生。说净调伏除无量阿僧祇劫罪业障。陀罗尼即说咒曰

羝(音都奚反)钐(音疏监反)跛啰(音卢可反)蒲陀那夜(音余架反)三摩末祗　他波耶(音余加反)[宋-木+悟]　毗摩隶输檀奈　毗摩罗输檀祢翅(音尸鼓反)输檀尼移莎呵摩诃输檀那摩羝移莎呵

若有众生。诽谤正法。毁菩萨僧。破和合僧。断绝大乘圣智慧教。增疾修行菩萨行者。无有反复。如此人等。不名丈夫具男子身。不孝父母。杀逆父母。于善知识所。诤讼欺诈。杀害八人及阿罗汉。不仁不义。偷盗佛物。塔物法物。招提僧物。现前僧物。犯四重禁。十三僧残。十不善道。五无间罪。速疾正向趣恶道者。无明闇蔽。没在苦海。我以大智慧光明愿力。为除无明无间重罪闇障痴惑。令彼速发阿耨多罗三藐三菩提心。即以大乘。而自庄严。具普贤行。为说如来法王境界如来十力四无所畏十八不共法神通等事。成就一切大智慧地。我今示现如来十力四无畏等陀罗尼力。安住一切诸佛正道。以此陀罗尼力。能令十方一切诸佛。同一法身。复次善男子。我今为于长夜病苦苦恼众生。多病消瘦。疾疫老朽。悭贪贫穷。危厄因悴。亡国破家。流离失土。贫穷孤迸。伶俜失势。无救护者。皆由前世无慈悲心。恶业果报。系属于他。八苦衰恼。以为衣服。为如是等无归依者。以大悲方便而救护之。诸贫苦者。以陀罗尼力。令其库藏。自然盈溢。若有悭贪。至死不舍。作守财鬼。为如是等。种种贪着。以诸方便而化导之。令彼众生。皆得解脱。复发是愿。我当为彼诸众生等。作大救护。施以法药。服此药者。能消一切诸烦恼病。离生老死八苦之畏。无明老死十二轮转。一切众苦。皆得永离。离恶知识。亲近善友。以普胜法。摄取一切。令得安止三清净业。敬信如来真妙法身。当得永离生老病死。毕竟常住清净境界。复次善男子。我见邪见诸众生等及其眷属作恶律仪。见诸众生远离正道趣于邪迳。着诸倒见虚妄迷惑。身口意业其行不善种种放逸依止邪法。于非正觉生正觉想。于正觉所生非正觉想。亲近恶友受行苦法。投渊赴火自坠高岩。常翘一脚。五热炙身。灰土涂污。卧棘刺上。自饿而死。盛冬潜渊。伏藏冰下。受持鸡狗牛鹿等戒。如是种种邪见苦行。欲求解脱。我以种种方便。除其邪见。令得安住于正见中。令诸人天得最上乐。复发是愿。愿诸众生。出离世间。不着邪见。安处无上正真之道。得不退转成一切智。究竟满足普贤菩萨大愿之行。向一切智。不离菩萨一切诸地。不怀一切众生苦性。而得解脱。尔时夜天婆娑婆陀。欲重宣菩萨光明普照诸法坏散众生愚痴法门。承佛威神。观察十方。即为善财童子。以偈颂曰

  我所成妙法　　知时诸门地
  照除愚痴闇　　普观一切法
  我法门寂静　　久修慈心得
  无量无数劫　　大悲覆群生
  成就大悲海　　出生三世佛
  除灭一切苦　　善财速究竟
  佛子心欢喜　　永离世间恶
  超出三界苦　　受诸贤圣乐
  远离有为恶　　声闻智解脱
  满足诸佛智　　佛子应究竟
  我以遍净眼　　普观十方刹
  于彼世界中　　诸佛坐道场
  相好庄严身　　无量众围绕
  放大光明海　　普化诸群生
  睹诸众生类　　死此而生彼
  回流六趣中　　备受诸苦毒
  我以净耳海　　普闻十方音
  一切语言海　　皆悉能受持
  我以净鼻根　　法海中无碍
  能入诸法门　　善财应究竟
  我成大人相　　清净广长舌
  随应演说法　　佛子应究竟
  清净妙法身　　三世如如等
  随其所应化　　一切无不现
  我心无所著　　澄清如虚空
  普摄佛境界　　而亦无二相
  悉知无量刹　　众生诸心海
  分别诸根意　　远离虚妄法
  我以神通力　　遍游无量刹
  普覆一切众　　调伏诸众生
  智慧净如空　　无比无尽藏
  供养一切佛　　饶益诸众生
  广大净智慧　　了知诸法海
  除灭众痴惑　　佛子应究竟
  我入佛法海　　通达三世法
  明了一切智　　无能测量者
  一一微尘中　　悉见佛刹海
  或睹三世佛　　真实智慧力
  见卢舍那佛　　道场成正觉
  十方微尘刹　　悉转正法轮

尔时善财童子。白天神言。发阿耨多罗三藐三菩提心。为已几时。得此法门。其已久如。乃能如是饶益众生。答言。佛子。乃往古世。过须弥山微尘数等劫。复过是数无量无边。彼有世界。名七宝功德集。劫名光明寂静。国名宝月光明。城名莲花光处。阎浮提中。于此劫中。有五百亿佛出兴于世。时彼城中。有转轮圣王。名善法度。以圣王法正法治世。七宝自至。王四天下。寿命一劫。威力自在。不加兵仗自然太平。彼王所重第一夫人。名日月意。其王夫人伎乐自娱。至于中夜淳昏而眠。梦此城中有一夜天。名最正觉寂静光明。来至其前。合掌而立。而作是言。咄。善女人。汝今知不。于莲花光大城之东。有林名寂静光微妙德。于此林中有菩提树。名一切佛自在光。有佛世尊。号一切法雷音王。坐此树下成等正觉。十号具足。放大光明。名摩尼王普照一切。彼雷音王佛。出兴于世。于菩提树下。始成正觉。已经七日。时彼夜天。称扬赞叹。显说如来无量功德自在神通。令彼夫人发无上道心。赞叹普贤菩萨一切愿行。时王夫人。即于梦中敬礼彼佛。发阿耨多罗三藐三菩提心供养佛。时世尊。放金色光触夫人。心。遍照宫城皆同金色。时彼夫人。即从眠觉。尔时彼佛。侍从声闻菩萨一切大众。现夫人前。是时夫人。头面敬礼佛及大众。供养恭敬尊重赞叹。即发誓愿。愿此功德。于将来世。天人之中最尊最胜。善男子。汝今当知。时王夫人月意者。岂异人乎。我身是也。我于彼佛所。初发道心。庄严功德。种大善根。超越须弥微尘等劫。不堕地狱饿鬼畜生阎罗王处下贱之家。具足诸根灭除众苦。常于人天中。得最胜果报。常得不离亲近善友。常生诸佛菩萨之家。不生五浊劫。善男子。我获善利。于彼佛所。深种善根。长养善根。于八十亿须弥山微尘等劫。常受快乐。而未满足菩萨善根。亦未获得三昧神通。得过八十亿须弥山微尘等劫。过此劫已。复过一万劫。有劫名清净无忧。世界名清净威德胜。彼世界中。有五百亿佛。出兴于世。成等正觉。十号具足。彼佛国土或净或秽。我时次第。供养彼佛。彼佛世界。有一四天下。名离垢幢。城名庄严。我于尔时。为明胜长者女。名胜慧光。端正殊妙。于彼世中。值最初佛。名须弥山善寂幢。时有一天。名净觉月。以本愿力。生彼城中。复有夜天。名清净眼。于睡眠中。入于王宫。即至我所。显现妙身。赞叹如来。劝我发心。令往佛所。作如是言。须弥山善寂幢佛。始成正觉。放大光明。已经七日。尔时夜天。引导于我。我即惊觉。见大光明遍满宫室。父母惊喜。即告我言。此何光明。金色显赫。明照吾室。我于尔时。即白父母。我于梦中。见一夜天。赞叹如来胜妙功德。有佛世尊。名须弥山善寂幢。出现于世。已经七日。唯愿父母。与诸眷属。往诣佛所供养恭敬。听佛说法。父母欢喜。即便许可。是时夜天。在前引导。我与父母。及亲眷属。俱诣佛所。头面礼足。退坐一面。见佛色身微妙光明。即得菩萨清净三世普智慧光明三昧。得此三昧已。忆念过去如须弥山微尘等劫所见诸佛。所说经法。受持不忘。即得光明普照诸法坏散众生愚痴破魔法门。得此法门已。复忆过去十世界微尘数劫世界时事。又见彼诸一切众生。及其业报。好丑。诸根利钝。性欲不同。语言音声。久修善业。亲近善知识。随其所应。示现色身。为作利益。见如此事。如今现在。我以此三昧力。于念念中。增长法门。心心相续。能以一身。充满十方微尘等世界。乃至充满一切世界微尘等海。又复过彼一切世界微尘数不可说不可说世界。如是世界中。悉见一切诸佛。闻佛说法。悉能忆念。受持分别。了知彼佛本净愿海。又知诸佛发清净愿。庄严佛土。我今亦欲严净一切世界海众生。令得净土。如今现前。随彼众生。所应见身。即为示现。调伏其心。而化度之。我从昔来。乃至今日。刹那相续。长养增进。修此法门。如此法门。究竟广大。如法界等。善男子。我唯知此菩萨光明普照一切诸法坏散众生破魔法门。诸大菩萨。究竟无量无边普贤菩萨所行愿海。深入一切诸法界海。建立一切诸菩萨智慧幢三昧游戏神通大愿成满守护受持诸佛如来大功德海。于念念中。庄严教化一切众生。成就满足智慧性海。除灭无明迷惑颠倒。普施净慧。犹如秋月。菩萨住世。遍照三界。不着众相。消除热恼。示现三世。自在神通。运载众生。开示正道。出生三世圆满清净一切音声。充溢十方一切法界。从初发心。乃至十地。于其中间。皆悉具足无量功德不可思议诸神通力智慧光明。我当云何能知能说彼菩萨行。善男子。此阎浮提摩伽提国。有一夜天。名妙功德离垢光明。彼夜天者。是我大师。先已劝我发阿耨多罗三藐三菩提心。示教利喜。汝诣彼问。云何菩萨。学菩萨行。修菩萨道。尔时善财童子。即以偈赞婆娑婆陀。而说颂曰

  我见尊净身　　相好自庄严
  超出于世间　　犹如须弥山
  法身湛然净　　三世悉平等
  普摄诸众生　　其人无所著
  开演净光明　　普照一切趣
  于一毛孔中　　悉见诸星宿
  心净无所依　　如日在空中
  摄取法王法　　明净深智慧
  一一毛孔光　　遍照十方刹
  于一切佛所　　弥布法云雨
  一切毛孔中　　示现变化身
  充满十方刹　　方便度众生
  初行菩萨时　　净业不思议
  一一毛孔中　　显现十方刹
  识知见闻者　　悉得功德利
  专求菩提道　　必成佛无疑
  不思议等劫　　常求善知识
  宁堕三恶道　　不舍菩提心
  百千微尘劫　　赞叹一切德
  众劫犹可尽　　功德无穷已

尔时善财童子。头面敬礼彼夜天足。绕无数匝。眷仰观察。心无厌足。辞退南行。向摩伽陀国

佛说罗摩伽经卷中佛说罗摩伽经卷下

        西晋沙门圣坚译

尔时善财童子。一心思惟彼夜天教。初发道心。圆满清净。思惟是已。即得深入诸菩萨藏出生菩萨大愿法海。净诸菩萨波罗蜜道。穷尽菩萨圆满胜净行业。发起成就深入智海。以一切智。救护十方一切众生。长养增广大慈悲云。于诸佛刹。出生普贤诸大愿行。渐渐游行。至普甚深微妙功德离垢光明夜天所。头面敬礼。绕无数匝。却住一面。恭敬合掌。白言天神。我已先发阿耨多罗三藐三菩提心。而未知云何修菩萨行。具足诸地。答言。善哉善哉。童子。乃能发阿耨多罗三藐三菩提心。问菩萨行。具足诸地。善男子。菩萨成就十法。则能具足菩萨所行。何等为十。一者悉得诸佛现前三昧。见一切佛色身了了分明。二者得净眼三昧。见一切佛三十二相八十种好庄严其身。三者得无量无边功德净眼。见一切佛深妙功德智慧大海。四者见无量无边佛光明海。悉能普照一切法界。五者无量不可思议佛法光明。于一毛孔放大光明。普照一切众生数等。令种种众生皆发阿耨多罗三藐三菩提心成光明海诸佛如来普慈等心。于念念顷。十方世界。施作佛事。于诸众生。随其所应。而度脱之。令无量众生皆得解脱。六者于一一毛孔中。悉见一切宝珠光明摩尼炎海。七者于念念中。出一切诸佛变化大海。充满法界。究竟一切诸佛境界。教化众生而无障碍。八者出一切佛无住微妙音声大海。转三世佛清净法轮。演说一切修多罗海及法云海。其义深远。无能穷尽。九者究竟诸佛音声海。深入一切如来海。究竟一切如来海。十者深入示现不思议佛自在神力化度众生住无量无边诸佛名称海。善男子。此名菩萨十法。若有菩萨。具此十法。则能满足菩萨诸行。亦能悉备普贤行愿。善男子。我已成就菩萨寂灭定乐精进法门。以此定力。悉见三世严净佛刹一切诸佛及眷属海。悉见无量无边诸佛如来神通力海。分别了知诸佛名号诸佛如来转法轮海。知彼诸佛寿命短促。及以无量。知彼诸佛无量微妙净音声海。彼诸如来。清净法身。无量无边。充满法界。亦不着如来一切诸相。而无相好想。何以故。诸佛如来。无来去相。已灭一切来去相故。不住三世如如际故。亦非过去。不住现在灭于一切世间相相故。不取一切来去相故。故名如来不来不去。诸佛如来。不生不起。不退不没。不灭不现。故名法身。诸佛如来。不起语性。不灭语性。过一切语言。语言断故。非实灭身。示现灭度。犹如幻法性不坏故。诸佛如来。非实非虚。欲为饶益诸众生故。一切如来。以如来道无来无去。出兴于世。诸佛如来。不生不没。不灭不住。不至此。不往彼。法性清净。不可坏故。诸佛如来。无性无相。离于一切语言道故。诸佛如来。以一如相。同入法性。无边际故。究竟一切法界性故。善男子。我如是了知于一切如来。唯得此寂灭定乐精进法门。照明增长广大善根。深入随顺如寂甚深普现境界。分别了知虚妄平等相。演说甚深平等大法。以大悲心。普摄一切。未曾舍离。一心善寂。无起灭想。增长正受。入寂灭定。起于初禅。除灭意业。得寂智力。摄取众生。欢喜悦乐。入第二禅。舍离生死寂灭涅槃。观众生性。修第三禅。为灭众生诸烦恼苦。而不见众生相。修第四禅。增长一切智菩提心愿。出生一切菩萨定海巧妙方便。深入一切诸法门海。成就菩萨游戏神通。出生菩萨自在神力明净智慧。深入普门法界。复次善男子。我唯如是修习菩萨寂灭定乐精进法门。以种种方便。度脱众生。夜半静时。为诸在家。贪着五欲者。说不净相。为计乐者说苦恼想逼迫系缚想。食不净想。心狂痴想。罗刹鬼想。为计常者说无常想。八苦集身想。无我我想。不自在想。空想。如是等常无常。苦无苦想。观此想已。教彼众生。令厌离五欲。呵责身心想。信家非家出家学道想。于空闲处。思惟坐禅。除一切障碍。诸恶乱道声想。于夜寂静。为诸众生。心安隐故。示现如是。以鬼神力。除其恐怖。令发道心。若有乐欲求出家者。我当为开正法心门。光明照路。除其闇冥。令不怖畏。即为彼人。赞佛法僧。令发道意。又复赞叹亲近善知识。修功德行。善男子。我今以此法门力故。令诸众生未生恶法。方便令不生。已生恶法方便令灭。未生善法方便令生。已生善法方便令增长。广行菩萨行。修诸波罗蜜。满足大愿。出生一切智慧慈悲。欲令众生得人天乐。除去妄想。增长善法。随顺助成无尽无边无受法行。善男子。我唯知此菩萨寂灭定乐精进法门。诸大菩萨。满普贤愿。具足普贤所行之行。究竟得离除闇境界。而得成就诸善根力。如来功德智慧光明佛境界力。一切佛心。无所障碍。出生死闇。无所染污。悉具一切萨婆若愿。深入一切诸佛刹海。摄取一切诸佛法海。成就一切妙法云海。如来智慧普能饶益一切众生没生死闇者。以智慧光。照生死夜。我当云何能知能说彼功德行。善男子。去此不远。向如来右面。有一夜天。名曰喜目观察众生。汝诣彼问。云何菩萨。学菩萨行。修菩萨道。尔时普甚深微妙功德离垢光明夜天。欲重宣此法门义。以偈颂曰

  深入现前定　　普见三世佛
  净眼无垢称　　分别诸佛海
  观察净妙身　　深入佛相好
  一念无量力　　普知法界性
  净身坐道场　　卢舍那正觉
  十方法界中　　转净妙法轮
  佛觉智最胜　　灭尽相无二
  众妙好庄严　　显示一切众
  佛身难思议　　同一虚空身
  普现十方刹　　一时悉教化
  放圆净光明　　摄诸佛刹等
  不思议净色　　普照诸法界
  于一一毛孔　　现无量佛刹
  无量微妙色　　普照诸世界
  不思议光明　　从于毛孔现
  普照众生类　　除灭众烦恼
  化佛出妙音　　充满十方界
  普见诸佛刹　　皆悉如雷电
  如来妙音声　　充满十方界
  普雨甘露法　　令发菩提心
  无数劫修行　　摄受诸众生
  普见卢舍那　　一切诸佛刹
  一切世音响　　如来悉出离
  普现群萌类　　令众住境界
  一切诸菩萨　　所行不思议
  于佛一毛孔　　一念悉能知
  不远有夜天　　名喜目观察
  汝可诣彼问　　云何菩萨行

尔时善财童子。头面敬礼彼夜天足。绕无数匝。眷仰辞退。向喜目观察众生夜天所。尔时善财童子。专求善知识。正念善知识教。因善知识。生诸功德。发菩提心。善知识者。难见难遇。见善知识生欢喜心。灭诸乱想。善知识者灭除疑惑。能坏障碍。见善知识。当知即得近一切智。见善知识。即得深入诸佛法海。见善知识。起一切十方诸如来想。闻善知识有所宣说。当知即得正念法云陀罗尼想。受持一切清净佛法见一切佛转法轮想。见善知识。即具一切大慈悲海。救护众生。见善知识。当生欢喜。智慧明净。悉能普照一切佛法界海。尔时喜目观察众生夜天。以威神力。加善财童子。赞善财言。善哉善哉。善男子。乃能如是求善知识。诣善知识。亲近供养。善知识者即是菩提。求善知识是大精进。善男子善知识者难见难遇。善知识力不可破坏。善知识者普游十方。除灭生死。悉断烦恼。能成辩才。善知识者。深入一切无量大事。庄严正顺道。善知识者。悉是普现法门。能令一切得无障碍。不离本处。遍至十方一切佛所。求善知识。当起是想。不来不去。不动不摇。无来去相。为一切智。救护众生。应求善友。尔时善财童子。见善知识。即得了知无量无边诸大愿海。得一切智。饶益众生。亲近善友。为诸众生无量无数恒沙微尘世界海。尽此世界海。尽此世界边际。复过是数无量无边不可说不可说处大地狱。为彼众生。起于慈悲。正向菩提。除灭众生无量劫苦。以一音声。普遍十方一切世界。讲宣妙法。若有闻者。灭无量劫生死罪障。以大慧愿。而自庄严。修菩萨行。于念念中。得一切智相。具神通力。于一切处。常见一切诸佛如来。亲近供养。为善知识。以佛庄严。而自庄严。普净三世诸佛法界。不入生流。不住死流。具佛神通。不住法界。不离法界。而能往诣十方世界。充满法界善知识所。不着语言。刹那刹那顷。修菩萨行。满足性境界。成就萨婆若。具一切佛神通游戏。庄严佛道。以平等法。身心不动。普摄众生。善知识力。显现三世

尔时善财童子。即诣喜目观察众生夜天所。时彼夜天。于大众中。处宝莲华师子之座。正受菩萨普现光幢喜净法门。一切毛孔。出妙色云。其有见者。喜悦无厌。一一毛孔。现众宝云。所谓。智慧行报。饶益众生。离于诤讼。以平等心。不着诸法。以上妙智。摄诸众生。显现三世。修菩萨行。心无悭吝。能舍难舍。普施一切。身心平等。不可思议。以布施福。普摄众生。于诸众生。不起染着。不见众相。不舍众生。悉具三世菩萨苦行。十方世界一切众生。无明系缚。住痴有结。菩萨即以大悲神通。解其系缚。又于一切毛孔。出生一切众生数等菩萨自在随应变化身云。以此身云充满一切。虚空法界。于众生前。示现色身。正受不动。于众生前。三昧神通。觉悟众生。不乐世间。远离三界。灭除生死。如避火坑。而于一切。示现生死。现天人中种种快乐及成败相。为诸众生。说不净观。令诸众生。皆悉修行。除颠倒想。为诸众生。说于变易苦恼之法一切受身有为之法皆悉无常。愿诸众生。深入佛境界。永离无常。住不可思议尸波罗蜜。恒受诸佛清净禁戒。终不毁犯。心无疑惑。示诸众生具足禁戒。以戒香熏一切众生。又于毛孔。出生一切妙色身云。割截手足及诸支体。捶打逼切。呵责恶骂。妄言诽谤。皆悉忍受。于彼众生。不生嗔心。不起害意。赞叹恶人。终不毁犯。身心恭敬。深生恩爱。犹如父母慈念一子。虽作此行。不生憍慢贡高之心。显现诸法真如法忍。善能和合一切世界诸恶众生。深知尽无尽性虚空智慧。行菩萨忍。以佛心智。断一切烦恼。灭一切结习。悉能荷负一切世间丑恶众生。如护眼目。愿一切众生。成就诸佛金刚忍德。净无瑕秽。又于一一毛孔。显现如来清净色身。随所应度众生。皆令得见。又于一一毛孔。出生一切诸趣种种色身。示现勇猛精进令众生修行。如救头然。降伏诸魔怨。得胜不退转。救护于一切。拔出生死海。永离诸忧患及无明怖畏。越度生死山。永离诸欲流。供养恭敬一切诸佛。心无疲厌。受持守护诸佛法轮。勇猛精进。灭除障碍。普摄一切众生。皆令调伏。入于律行。心无懈怠。普示一切净佛国土。教化众生。庄严阿耨多罗三藐三菩提心。如是功德。皆从精进波罗蜜本事果报生。一一毛孔。出现一切种种形色。以诸方便。除灭众生诸忧恼苦。皆令欢喜。呵责厌患一切五欲。深生惭愧。调伏诸根。修行无上最胜梵行。净身口意业显现世间一切所欲皆不可乐。示现如是种种形色。皆令快乐。常乐受持。出生正法。心不散乱。安住深入九次第定。除灭众生一切烦恼。令得安乐。显现菩萨诸三昧海通明自在神力境界。令诸众生身心欢喜。灭烦恼热。得清凉乐。增进善法。身口意业。常得善寂。诸根悦豫。得法喜乐。又于一一毛孔。示现一切五道生处。令十方五道。皆见其身。诣诸佛所。尽一切佛刹。诸佛师长。及善知识。恭敬供养。心不懈惓。一切如来所转法轮。悉能受持。终不疲厌。不生退转。究竟一切诸佛刹海。化度众生。示现一切法海。护持正法。不见法相。于一实相。示现一切诸三昧门。身心清净。能断一切众生疑惑。以智慧力。分别一切众生心海。以金刚慧。破坏众生诸邪见山。心生圆满明净慧日。于一念中。能除众生痴冥闇蔽。令诸众生远离声闻辟支佛地疑惑颠倒有无二边。皆悉欢喜。得智慧乐。悉教一切回向佛道。又于一切毛孔。出生一切众生尘数等身。示现种种色身不思议身。随所应度。悉现其前。于一音中说无量音。无量音中演说一音。随诸一切众生类语。说一切诸佛功德之藏。示行世间有作无作。有记无记。悉了三世业行果报。不乐三界。赞叹出世离三界法。一切颠倒。邪见饥馑。皆令出离。向甘露道。趣一切智。超出诸地二乘怖畏。于有为无为。心无所著。背舍生死。正向涅槃。不舍众行。不离诸趣。往来五道。无有疲厌。发胜进心。成于平等。以正觉法。教化众生。得一切智。一一毛孔。出生示现一切佛刹微尘数等变化身云。遍现一切诸众生前。修普贤行。满一切愿。不可穷尽。劝进众生。向萨婆若。于一念顷。示现修习一切净行。供养恭敬一切如来。心无厌足。建法幢摧外道。守护一切诸菩萨行。心心相续。具足一切诸波罗蜜。一一微尘海。出生一切诸法性海。演说一切法音声海。遍满十方微尘刹海。以此音声。复尽微尘世界海劫。长养一切众生善根。住寿一切无量无边阿僧祇微尘数佛刹海。阿僧祇等微尘数不可说不可说劫。为诸众生。令得增进。复过是数。住寿不灭。于劫坏时。承佛神力。令得不灭三世一切微尘佛刹诸佛出世。悉令往诣。恭敬供养。守护受持佛正法轮。游戏神通。净佛国土。教化众生。至彼彼处。令诸众生皆大欢喜熙怡快乐。于一一毛孔。出一切化身。应一切众生众生业报现一毛孔。又于一一毛孔。雨一切供养具。供养诸佛。给施众生。法王心力故。无坏境界。不可穷尽。坚住如相。不退不没。心行平等。无住无著。出生欢喜无极清净之行。以慈心力。除灭一切众生罪恶。菩萨本誓善愿之力。摧坏四魔。灭除一切烦恼业山。尽诸世法。修大慈悲。于菩萨行。得不退转。普摄一切十方世界有缘众生。令得修行诸波罗蜜。示现菩萨无尽功德。逮得菩萨转法轮幢胜妙菩提诸陀罗尼。以此胜慧。降伏外道。具菩萨行力波罗蜜。为诸众生。趣向萨婆若故。一一毛孔。示现一切众生平等身相。令众乐见。又于一一毛孔。显现一切众生类海。又复显现无量无数微尘数等不可说十方世界海微尘数等诸妙色身。皆悉显现随应众生菩萨智慧行力。显现不可说不可说智慧大海。善知一切众生心海。善知一切众生根海。知诸众生心心数海。深入究竟智慧法界。于念念顷。普能充满一切法界。解脱于世间。赞叹出世间。庄严净佛国土。赞叹净国众生。习学诸佛游戏神通。赞叹诸佛神通愿力。诣诸佛所。供养恭敬守护受持正法轮云。显现智慧十波罗蜜。令诸众生皆大欢喜。灭除热恼。远离忧戚。及世八法。悉舍众恶。调伏诸根。于一切智。得不退转。如是诸波罗蜜。欢悦安乐。化度众生。诸大菩萨。以此胜法。震大法雷。觉寤一切睡眠众生。以胜慧法智力光明。普能正彼狂乱恶行。亦见诸佛本性净行。于一毛孔。皆悉显现。而不障碍。喜目观察众生夜天所修功德。求善知识。诣诸佛所亲近供养。修习诸善。行檀波罗蜜。难舍能舍。悉舍王位。国土城邑。宫殿臣妾。人民眷属。出家学道。是名行檀波罗蜜。行尸波罗蜜。修持净戒。如护一目。虽受一切世间众苦。于所持戒。而不毁犯。一切众生。所不能为。菩萨行之。是名行尸波罗蜜。行羼提波罗蜜。一切众生。嗔恚恶骂。捶打毁谤。逼切其身。皆悉堪忍。无嗔恚色。一切众生。夺其利乐。害及亲爱。如是苦事。亦悉能忍。设以三火焚烧其身。受一切苦。心大欢喜。譬如比丘入第三禅。身心悦乐。深信诸法。堪受诸法。不生不灭。是名行羼提波罗蜜。行毗梨耶波罗蜜。为一切智故。悉受众苦。节节火烧。终不恐怖。为一切智故。起大勇猛。如救头然。专求菩提身心坚固。不可毁坏。无疲极念。终不退转。是名行毗梨耶波罗蜜。行禅波罗蜜。身心不乱。而遍诸方。满足清净禅波罗蜜。勇猛精进。不舍三昧。名禅波罗蜜。而得清净。究竟一切诸清净行。入胜三昧。神通游戏。度大智海。念念相续。皆悉次第。入清净定。是名禅波罗蜜。满足诸方便。身心常净。是名禅波罗蜜。一切禅定海。究竟诸三昧海。次第相续。未曾断绝。是名禅波罗蜜。行般若波罗蜜。不着彼不着此。于空法中。得大解脱。是大菩萨。清净圆满般若波罗蜜。自然智慧出生清净慧日身心不着入智慧藏究竟观察大智慧海般若波罗蜜。不着法相行胜清净智境界吉祥般若波罗蜜。出生妙义智慧海般若波罗蜜。行方便者。出生一切诸方便身普知一切智明净法界胜进力。是名方便波罗蜜。净慧方便。生法性生身。出入息顷。得净方便无二本行。是名方便波罗蜜。诸菩萨等。本弘誓愿。出清净身。现生具足。摄受众生。于一切众生及诸善行。心净无著。是名行方便波罗蜜。行愿波罗蜜。出生一切愿海身。深入一切智慧诸三昧海。超过一切声闻辟支佛地。示现出生本净愿。行波罗蜜。不舍不得。随所愿求。智慧本行。净诸愿身。是名行净愿波罗蜜。行力波罗蜜。备诸功德。如意自在修助道法。是名力波罗蜜。因助道法。饶益众生。修诸功德。不着功德。不见功德相。是名力波罗蜜。因力果力。皆悉具足。犹如大海。是名力波罗蜜。显示种种法序说诸智力。是名力波罗蜜。杂因果力。演说智力。智杂业力。是名行力波罗蜜。行智波罗蜜身。智波罗蜜名字清净。智波罗蜜智慧境界。智波罗蜜正疾行。智波罗蜜普现光明犹如妙香。异物同熏。如呼声响。一切皆应。是名智波罗蜜。智炎光明。胜妙音声。演说义味。无有穷尽。普摄一切。是名智波罗蜜。智波罗蜜。出生成满本行果报性相清净。是名智波罗蜜。智波罗蜜。无著无护。一切智。集诸无著。助菩提分。智慧明了。具胜进地。深入甚深智行境界。是名智波罗蜜。智波罗蜜。深入微妙。知法性法智。摄受诸法。随顺智慧。善知福田及非福田如实之相。是名智波罗蜜。诸如来智。超出三界。了达三世。善知菩萨一切行业。普集众智。无所挂碍。亦知菩萨正智住处应修正行。又复善知从初发心。趣向上地。以方便心。善知回向。善知诸法如。业如。报如。善知法轮如。知法轮如相。是名智波罗蜜。胜妙无著。摄受正法。摄受正法者。总知一切法。总知一切法者。知法如来。知法如去。善知业业境界。善知刹刹境界。善知诸劫。善知三世智。出生诸佛智。知佛智等正智。知菩萨智。知菩萨智智。知菩萨住智。知菩萨功德智慧智。知菩萨净心回向智。知诸大愿智。转法轮智。知分别法智。入法海智。知方便海智。知法旋流陀罗尼智。知诸法至趣智。知如是等一切智波罗蜜。深远无底。广大无边。究竟无际。如是胜智十波罗蜜。于一毛孔。皆悉显现。一切毛孔。皆悉显现诸变化身。化度众生。又于一切毛孔。出生无量身云。所谓。阿迦腻吒天身云。净居天身云。善现天身云。不热天身云。果实天身云。遍净天身云。无量净天身云。少净天身云。净果天身云。广果天身云。无量净果天身云。少净果天身云。光音天身云。无量光音天身云。少光音天身云。大梵天身云。梵辅天身云。梵富楼那天身云。梵富楼吉那天身云。梵印天身云。梵自在天王身云。他化自在天王。及其天子天女身云。化乐天王。化乐天子天女身云。兜率陀天王。兜率陀天子天女身云。炎摩天王。及其天子天女身云。释提桓因天王。及三十二辅臣天子天女身云。提头赖吒天王。及天子天女眷属。一切乾闼婆男女身云。毗楼勒叉天王。及其眷属天子天女一切鸠槃茶男女身云。毗楼博叉天王。及其眷属天子天女一切龙男女身云。毗沙门天王。及其眷属天子天女一切夜叉男女身云。紧那罗王。及一切紧那罗男女身云。摩睺罗伽王。及一切摩睺罗伽男女身云。迦楼罗王。及一切迦楼罗男女身云。阿修罗王。及一切阿修罗男女身云。阎罗王。及一切阎罗王男女身云。并及地狱恶趣身云。人王身云。男女身云。童男童女身云。出如是等一切诸趣身云。声闻辟支佛仙人身云。地神水神火神风神海神河神。山林树神。谷神味神。药草神园观神。泉海神城郭神。道场神。夜神昼神。虚空神。方神道神。身形神日精神。诸魑魅神。金刚力士神。步行神。如是等一切神身云。普遍十方一切世界。为法界等一切众生现喜见身。尔时喜目观察众生夜天。从初发心。所行功德。积集无量诸波罗蜜。次第受生。死此生彼。轮转五道。及其名号。亲近善知识。值遇诸佛。亲近供养。闻持正法。行菩萨行。心无挂碍得诸三昧。次第观见一切诸佛。色身相好。见诸佛刹。及见诸劫次第成坏。得净智慧。深入法界。观察众生。知众生海。死此生彼。得净天耳。次第悉闻一切音声。以闻声故。得知他心智。悉知众生心心所念。无碍神足。次第自在。不着世间。不受后有。尽虚空界。净法性身。修得神通。净妙报果。充满十方。得诸菩萨次第法门。究竟菩萨诸法门海。菩萨自在。勇猛精进。菩萨游步。犹无所畏。至于正趣。离生死相。胜妙清净。集诸功德如意法门。等一切法界。等示彼一切功德身云。示一切智慧身云。演说法音。开现教化。令得归依。遍一切处。示现大道。于风轮中。扇动出声。示现说法。令彼受持示教利喜。思惟不着。地动水流海波火炎山相击声。诸天宫城震动之声。摩尼宝殿震吼之声。天王形色鼓舞之声。龙王起云雷震之声。夜叉乾闼婆阿修罗迦楼罗。紧那罗摩睺罗伽等。一切神王。于十宝山种种音声。转轮圣王。及诸小王。一切人众男女音声梵王音声。一切诸天歌颂音声。天乐音声。摩尼宝王神珠音声。天音声。声闻缘觉菩萨音声。如来音声。如来化身所出音声。如是等种种音声。为诸众生。分别演说。喜目观察众生夜天。从初发心。功德境界。难得能得。一切苦行。难行能行。如是等行。皆承佛力。而得通达一切功德变化身云。于一一身云。说此清净无著法云。间无断绝。于念念中。游十方世界。修于净土。复令过是无量无边世界。应受恶道苦无量无边诸众生等。成就天人乐。无量无边众生度生死海。无量无边众生安住声闻辟支佛地。无量无边众生离声闻辟支佛地。得诸菩萨不退转行不可思议广博喜幢自在法门。于念念中。令无量无边众生住如来地

尔时善财童子。皆得见闻。善知解了诸奇特事。正念思惟。观察分别。深入禅定智慧安住平等。何以故。与彼夜天。光身同行故。佛所护念故。成就不可思议如幻诸善根故。具足菩萨不思议根故。成就菩萨诸善根故。得生如来种姓家故。得善知识恩力故。一切如来无著神力之所持故。毗卢遮那佛本愿力故。成就善根堪受普贤菩萨诸愿行故

尔时善财童子。得菩萨欢喜净光明大海幢法。得十方一切诸如来力。得彼夜天毗罗摩伽菩萨幢法门。得彼法门已。深入观察普照十方光明法海三昧

尔时善财童子。即起恭敬合掌。以偈赞叹彼夜天曰

  无量无数劫　　深入最胜法
  显现妙法身　　随众所应见
  了知群生心　　无明颠倒惑
  以种种方便　　度脱众生类
  常净妙法身　　久除诸热恼
  非二示有二　　度脱众生故
  阴入及与界　　悉皆无所著
  众行及色身　　解脱一切有
  不着内外法　　越度生死海
  净明智慧光　　普照生死闇
  喜目根无著　　除灭诸疑惑
  一切乐世乐　　为现佛十方
  无碍三昧力　　于一一毛孔
  出诸化身云　　心念生三昧
  心念三昧力　　供养十方佛
  摄取诸众生　　究竟一切法
  观察诸有海　　业行自庄严
  演说无碍道　　令众清净故
  相好备严饰　　犹如普贤像
  随应受化者　　显现无碍身

尔时善财童子。偈赞叹已。白言天神。发阿耨多罗三藐三菩提心。为已几时。得此法门。其已久如。尔时夜天。以偈答言

  我念过去世　　无量刹尘劫
  尔时有一劫　　名曰寂静音
  城有转轮王　　清净妙色身
  具三十二相　　八十好庄严
  妙身圆满幢　　阎浮檀金色
  光明照一切　　安详游虚空
  转轮王千子　　勇猛身端正
  大臣有一亿　　智慧悉贤明
  有十亿婇女　　端严如天后
  大慈悲柔软　　奉给侍大王
  时彼转轮王　　常以正法治
  总领诸山地　　一切四天下
  弃国舍世荣　　出家求佛道
  我为圣王后　　具足梵音声
  身出金色光　　周照四万里
  日光既已没　　中夜闲寂然
  我当于尔时　　神瑞降善梦
  闻佛出世间　　号曰功德海
  显现自在力　　充满十方界
  放光明网海　　照一切刹土
  无量自在身　　充满十方界
  种种变化身　　光明果报力
  充满恒河沙　　遍照一切趣
  大地六种动　　自然出妙音
  如来出兴世　　众生皆欢喜
  一切毛孔中　　出佛化身海
  充满十方界　　随应演说法
  我梦见如是　　如来自在力
  闻说微妙法　　身心大欢喜
  十千夜天身　　充满虚空中
  赞叹彼如来　　开发觉悟我
  彼天告我言　　贤慧汝今起
  佛已兴汝国　　劫海难值遇
  闻此音欢喜　　即见明净光
  观察从何来　　道场树王所
  我见如来身　　如须弥山王
  一切毛孔中　　放大光明海
  见佛自在力　　心生大欢喜
  即发弘誓愿　　愿我如世尊
  夫人觉语王　　眷属及婇女
  我梦见佛光　　喜乐充满身
  即时与大王　　无量那由他
  眷属四兵众　　往诣如来所
  我于二万岁　　常供养如来
  七宝四天下　　一切悉奉施
  彼佛为我说　　功德普云经
  大愿海庄严　　随闻度众生
  我发大誓愿　　未来作夜天
  诸有放逸者　　悉令远众恶
  尔时我初发　　无上菩提心
  生死有为中　　未曾有忘失
  从是后供养　　十亿那由他
  生死海受乐　　饶益诸众生
  初佛功德海　　第二功德灯
  第三宝炎佛　　第四丰慧智
  第五天花藏　　六无碍月音
  第七法月王　　八圆满智王
  第九宝炎佛　　无上天人尊
  第十日音声　　我已悉供养
  如是等诸佛　　十亿那由他
  犹未得慧眼　　究竟生死海
  次第复有劫　　名曰天妙胜
  世界名宝光　　五百佛兴世
  初佛圆满月　　第二明净日
  第三光幢佛　　四须弥山王
  第五花炎海　　六智慧海幢
  第七然灯佛　　第八天德藏
  第九光明幢　　第十普智王
  如是等诸佛　　我已悉供养
  未离五阴苦　　非乐生乐想
  于法不生疑　　亦不疑正法
  次第复有劫　　名庄严梵音
  尔时有世界　　名莲华灯云
  彼有无量佛　　及诸佛眷属
  我已悉供养　　闻受持正法
  初佛名宝山　　第二功德海
  法界须弥幢　　第四法须弥
  第五法幢佛　　第六地威神
  第七法力佛　　第八虚空慧
  第九法炎山　　第十照明山
  如是等诸佛　　我已悉供养
  犹未了真实　　究竟尽法海
  次第复有劫　　名曰欢喜德
  尔时有世界　　名曰光功德
  彼劫有八十　　那由他诸佛
  我已悉供养　　礼敬最胜尊
  初乾闼婆王　　二寿命树王
  三须弥功德　　第四宝眼佛
  五毗卢遮那　　六贤圣庄严
  第七法胜王　　第八明净德
  第九世间王　　十一切法王
  如是等诸佛　　我皆已供养
  犹未得妙智　　深入诸法门
  次第复有劫　　名曰净不坏
  尔时有世界　　名普光庄严
  十佛兴世间　　除无量烦恼
  功德已庄严　　严净诸众生
  有千佛兴世　　无量德庄严
  除灭烦恼垢　　令众悉清净
  初佛名无诤　　第二无碍力
  第三法界光　　第四梵髻王
  五波楼那天　　第六众生归
  七圆满忍灯　　八具足法灯
  九光明严海　　第十威神王
  如是等诸佛　　我皆已供养
  犹未解真法　　游行一切刹
  次第复有劫　　名曰香灯刹
  尔时有世界　　名曰清净起
  一亿佛兴世　　严净一切劫
  彼佛所说法　　我闻悉受持
  初名法称王　　二名法身海
  三名勇猛顶　　四功德法王
  第五胜法云　　六名天首冠
  第七智炎佛　　八名虚空力
  九名普胜起　　十名妙德首
  供养彼佛已　　成就八正道
  次第复有劫　　名明净金刚
  尔时有世界　　名曰宝幢主
  五百佛兴世　　彼诸如来等
  我皆已供养　　求无碍法门
  初名圆满德　　第二寂然音
  第三功德海　　四曰威神王
  第五法最王　　六名须弥相
  第七名法王　　第八功德王
  第九功德山　　第十光明王
  如是等诸佛　　我已悉供养
  我皆悉严净　　一切最胜道
  犹未得具足　　究竟深法忍
  次第复有劫　　名曰胜称音
  尔时有世界　　名曰寂静音
  八十那由他　　诸佛兴出世
  我已悉供养　　于彼修正道
  初佛号华聚　　第二海藏佛
  第三功德起　　第四天周罗
  第五摩尼藏　　六号金山王
  第七宝聚佛　　第八寂静幢
  第九法幢佛　　第十号财首
  如是等诸佛　　我已悉供养
  次第复有劫　　名千首功德
  尔时有世界　　名曰善花灯
  六亿那由他　　诸佛兴出世
  我已曾供养　　彼一切诸佛
  初佛寂静幢　　第二智印王
  第三号百灯　　四功德云王
  寂静光明王　　第六明净日
  第七法灯王　　八功德首王
  九天功德藏　　十智慧云雷
  如是等诸佛　　我皆已供养
  未得无生忍　　究竟诸法门
  次第复有劫　　名无著光炎
  尔时有世界　　名无量胜光
  有三十六亿　　那由他佛出
  如是等诸佛　　我皆已供养
  初号普山王　　第二虚空心
  第三号集智　　第四庄严藏
  第五法海音　　第六持音声
  第七化音声　　第八化云海
  九功德音海　　第十妙音幢
  十一普威德　　第十二法海
  十三集音声　　十四功德海
  十五灯明首　　十六宝炎首
  十七灯明佛　　十八功德炎
  十九月天佛　　二十功德胜
  彼诸如来等　　我皆得值遇
  彼两足世尊　　出兴于世时
  我为功德天　　供养彼最胜
  时佛为我说　　庄严大海愿
  陀罗尼念力　　皆悉能受持
  我得明净眼　　三昧陀罗尼
  于一一念中　　悉见无数刹
  出生大悲藏　　深入方便云
  心净如虚空　　皆从梦中生
  始发菩提心　　广大如虚空
  究竟无边际　　为度众生故
  尽未来际劫　　愿求诸佛力
  观察诸众生　　常乐我净倒
  愚痴闇所覆　　烦恼起虚妄
  邪见贪欲等　　无量诸恶业
  一切诸趣中　　具受不善报
  一切诸趣中　　种种业受身
  生老病死患　　无量苦逼迫
  我发无上心　　安乐诸众生
  令至诸佛所　　成满如来力
  满足大愿云　　常见一切佛
  修习于正道　　具足诸功德
  一向广专求　　无量功德云
  罗摩伽三昧　　充满诸法界
  广大波罗蜜　　声闻十方刹
  一切诸佛所　　闻此罗摩伽
  即具普贤行　　入净深法界
  摄持一切法　　成满一切地
  三世方便海　　修习无量行
  一心具佛智　　智慧悉通达

尔时夜天。说此偈已。头面敬礼一切诸佛。未举头顷。见一切如来足下千辐相轮。逆观如来一切相好。于佛相好中。身心明了。不着相好。以广大心。速疾闻佛五分法身香。究竟一切诸波罗蜜。住菩萨地。尽佛法海。远离一切三世色声香味触法。住普贤菩萨广行究竟地。圆满清净大境界地。于一念顷。普现十方无量佛刹。具十法门。一一法门。具足无量无边不可思议阿僧祇等诸法界海。尽一切苦际。皆悉深信。佛子。如是等种种功德。我已久修。信解受持。具普贤行。善男子。尔时智慧转轮圣王。劫劫相续。常绍王位。受佛种性。生释种家。不断如来善寂种性者。岂异人乎。今文殊师利童子是也。尔时转轮圣王夫人贤慧玉女者。今我喜目观察众生夜天是。时觉寤我夜天者。今普贤菩萨所变化身是。善男子。我于尔时。夜梦觉已。见佛光明。初发阿耨多罗三藐三菩提心。发是心已。于无量佛刹微尘数劫。不堕恶道。常生天上。下在人中。受诸快乐值见诸佛。于其中间。经无量劫。乃至报应首功德幢如来应供正遍知所。得此普光喜幢法门。得此法门已。示现种种身。调伏众生。随顺开发。皆令亲近善知识。若天若人。及余一切。于未来世。闻向佛名。及闻普光喜幢法门毗罗摩伽三昧名号。受持读诵。解说书写。亦得超越无量佛刹微尘劫海生死之罪。不堕恶道。常生天上人中。受诸快乐。常见诸佛。闻法受持。终不忘失。善男子。我于宝光功德炎佛所。得此普光喜幢速疾法门。得此法门已。一向专求诸善知识。身心诸根。欢喜悦乐。游诸方面。调伏众生。令入律行。善男子。我唯知此普光喜幢法门毗罗摩伽三昧。圆满清净胜光境界。诸大菩萨。于念念顷。不离善知识。深入方便智慧大海。因善知识。出生长养速疾法门。发一切大愿海。于一切劫。不离善根。念念相续。近善知识。求妙功德。救护众生。悉具一切普贤菩萨所行之道。尔时喜目观察众生夜天。为善财童子。显现菩萨教化一切世间法门境界相好庄严身相。眉间白毫相中。放大光明。名普慧炎灯清净幢。无量光明。照一切世界已。入善财顶。充满其身。尔时善财童子。即得毗罗摩伽圆满三昧。得此三昧已。于一一身。充满法界。于一切地水火风微尘。众宝微尘。香微尘。金刚微尘。摩尼珠微尘。碎末微尘。一切庄严微尘。如是等一一微尘海中。悉见佛刹微尘等世界成坏。四大成败相。风轮水轮。金刚轮地轮。种种庄严众山围绕无量大海诸天宫殿。诸杂宝树种种庄严诸龙宫殿。夜叉乾闼婆。阿修罗迦楼罗。紧那罗。人非人等城郭宫殿。地狱饿鬼阎罗王处。死此生彼。皆悉了知诸法因果。一一身中。普现一切法界等身。悉见一切诸佛刹土。随所应化。度脱众生业报好丑。以微妙音。普为说法。令此法音从毛孔入。令诸众生皆得法行。见一一刹。及见一切世界微尘数刹。见无量无边一切诸佛如来海。深入善根。于诸佛所。住一切法界。于无量佛所。得无量法门。越度生死。游戏神通。于一一佛所。自念从初发心。修菩萨本行普集善根一切境界果报。于一一佛所。得闻诸佛所转法轮。受持不忘。守护正法。以本愿善根力。悉见三世一切佛海。越生死流。善男子。诸大菩萨。成就如是无量无边诸大功德。我当云何能知能说彼功德行。尔时喜目观察众生夜天。告善财童子言。我以此普光喜幢法门力故。常见诸佛。间无空缺。以此义故。遍一切处守护佛法。尽虚空界。心不疲厌。云何能为守护一切诸佛正法。以毗卢遮那佛本愿力故。及观世音菩萨摩诃萨威神力故。持白宝莲华陀罗尼咒。拥护受持读诵行正法者。尔时喜目观察众生夜天。承佛神力。即说白宝莲华陀罗尼咒

多耋他　摸利翅　波阇罗摸利翅赊摩他移　毗赊摩他移　波腊波檀尼翅郁他婆尼翅莎呵　禅头(音头掬反)翅　曼头翅莎呵　赊俾多钵头摩　无至翅莎呵　因陀罗波尼翅莎呵　曼檀祢莎呵　踰阇祢莎呵

若有受持此咒者。不堕地狱饿鬼畜生。于现身上。终不横死。不遭县官牢狱系缚。常受一切清净快乐。若有得此陀罗尼者。当知此人。常得不离值见诸佛。亦不离闻佛说法转正法轮。又复常得无尽清净法音声海辩才印陀罗尼。若有得闻此陀罗尼者。具足一切菩萨净行。必度生死海。当到彼岸

尔时善财童子。闻此陀罗尼已。恭敬顶礼喜目观察众生夜天足。绕无数匝。专心思惟正念菩萨圆满净幢菩萨法门。思惟分别。观察正受。念善知识教。深入随顺善知识教。时彼夜天。告善财言。善男子。此佛众中有一夜天。名普覆众生威德。汝诣彼问。云何菩萨学菩萨行。具菩萨行。修菩萨道。时善财童子。头面敬礼。喜目观察。众生夜天足。辞退而行。诣普覆众生威德夜天所。求善知识。心无厌足。即得发起宿世善根一切境界。此境界力。普见十方诸佛菩萨诸善知识。威仪庠序。舍离憍慢。深生恭敬。所见菩萨及善知识。念念相续。无有异心。皆悉归依诸善知识。彼诸菩萨。从初发心。堪为法器。乃至十地。求善知识。如我无异。常为善知识之所覆护。闻善知识所说密语。忆持在心。终不忘失。为成菩提故。修一切善根庄严功德。具诸方便。皆由先世亲近善知识故。尔时普覆众生威德夜天。普放光明。此光明名调伏一切众生律仪示现庄严法门。得此法门故。具足相好。以庄严身。以此相好身。示一切众生。令得欢喜。一一相好。示现一切众相光明。现光明已。于白毫相。放一切光。以此光明。普照一切。以一切光。以为眷属。此光名普智炎毗罗摩伽圆满明净三昧境界。又此光明。无量无边无有涯际。普照十方一切世间已。入善财童子顶。充遍其身。于其身内。悉见众生死此生彼。善恶业报。皆悉现于善财身中。尔时善财童子。即得极妙清净毗罗摩伽三昧。得此三昧时。无量无边诸众生等。发阿耨多罗三藐三菩提心。一切大众。皆大欢喜。礼佛而退

佛说罗摩伽经卷下


佛说菩萨本业经

    No. 281 [Nos. 278(7, 11), 279(11, 15), 282]

    佛说菩萨本业经

一卷

        吴月氏优婆塞支谦译

闻如是。一时佛。游于摩竭道场。初始得佛。光景甚明。自然莲华宝师子座。古昔诸佛所坐皆尔。道德威仪相好如一。身意清净。福行普具。明所彻照人刹法处。去来现在无复挂碍。成兴于世。一切悉等。时会菩萨。尽一生补处。神通妙达。周遍十方。导利众生。开佛法藏。示泥洹要。都入人根。宿命智德。善权方便。训化以渐。解内外法。终始不摇。等诸佛土。无所分别。赞扬佛名。不可称极。三涂之事。靡不贯达。至皆叹曰。佛念吾等。建立大志。能悉现我诸佛世界所有好恶。殊胜之国。佛所游居。兴隆道化。光明神足。教训天人。启示法意。佛之本业。十地十智。十行十投。十藏十愿。十明十定。十现十印。断我瑕疵及诸疑妄。悉为我现佛行佛智。佛神佛力佛定。无量变化随时。四时不护。四无所畏。十八不绝。一切敏慧。无上道德。众事敷露

  东去无极　　有香林刹
  佛名入精进　　菩萨字敬首
  南去无极　　有乐林刹
  佛名不舍乐　　菩萨字觉首
  西去无极　　有华林刹
  佛名习精进　　菩萨字宝首
  北去无极　　有道林刹
  佛名行精进　　菩萨字慧首
  东北无极　　有青莲刹
  佛名悲精进　　菩萨字德首
  东南无极　　有金林刹
  佛名尽精进　　菩萨字目首
  西南无极　　有宝林刹
  佛名上精进　　菩萨字明首
  西北无极　　有金刚刹
  佛名一乘度　　菩萨字法首
  下方无极　　有水精刹
  佛名梵精进　　菩萨字智首
  上方无极　　有欲林刹
  佛名至精进　　菩萨字贤首

是贤首等。皆彼第一。各与无数上人俱来。稽首佛足。坐一面莲华上。彼时敬首菩萨。承佛圣旨。叹曰快哉。今上人会。为未曾有。观其所止。佛国清净。至于被服如来德戒。修行微妙成觉根力。演说经法。得佛威神。随刹清浊。度人无极。分流道化。靡不周匝。于此佛土。国殊别者亿百千垓。贤愚好丑。长短寿夭。种种言异。皆闻佛德。各自名之。或有名佛为大圣人。或有名佛为大沙门。或号众祐。或号神人。或称勇智。或称世尊。或谓能儒。或谓升仙。或呼天师。或呼最胜。如是十方诸天人民。所称名佛亿万无数。此皆佛本发意以来。班宣道化。所诲之徒也

是时。佛放足下相轮光明。悉照佛界诸小国土。一小国土者。一须弥山日月运绕照四天下。东弗于逮。南阎浮提。西拘耶尼。北郁单越。四周大海。铁垣围表。上有二十八天。如此者为一小国土。周匝十方合有百亿。是时悉现百亿须弥山百亿日月。及四天王天。忉利天。炎天。兜术天。不憍乐天。化应声天。梵天。梵众天。梵辅天。大梵天。清明天。水行天。水微天。水无量天。水音天。约净天。遍净天。净明天。守妙天。微妙天。广妙天。极妙天。福爱天。爱胜天。近际天善观天。快见天。无结爱天。识慧天。无所念慧天。至二十八无色天。各有百亿。此为一佛刹。号曰忍世界。释迦文佛。分身百亿。悉遍其中。于时天人。睹众小国。诸佛菩萨。若近相见

    愿行品第二

智首菩萨。问敬首曰。本何修行。成佛圣道。身口意净。不念人恶。亦使天下不得其短。仁慈至大。内性明了。殊过弟子别觉之上。一切众邪莫能回动。出生端正。色相无比。族姓尊贵。知重佛法。自守志强。常行四等。高才敏达。精进勇健。习众德本。诸度无极。所为无量。恒生福地。言见信用。降心正意。摄念入禅。晓空无想不愿之法。出入四大。五阴六入。十二缘起。七觉不阂。通十力智。博入诸道。济危解厄。为释梵所敬。除闇冥如烛火。明天下如日月。度众人如船师。贤过三界而为上首。欲成斯道。当何修行

敬首答曰。善哉佛子。志仰高远。极大慈哀。愍伤十方。若族姓子族姓女。欲成佛道者。当先正身。言念相应。口习经典。心思可行。改往修来。不释道意。积德累善。施恩不惓。然则所问悉可得也。为菩萨者。必谛受学。如佛法教。无得增减。以誓自要。念安世间。奉戒行愿。以立德本

  居家奉戒　　当愿众生　　贪欲意解
  入空法中　　孝事父母　　当愿众生
  一切护视　　使得佛道　　顺教妻子
  当愿众生　　令出爱狱　　无恋慕心
  若得五欲　　当愿众生　　皆入清净
  心无所著　　若在伎乐　　当愿众生
  悉得法乐　　欢喜之忍　　着宝璎珞
  当愿众生　　解去重担　　诸绮可意
  见诸婇女　　当愿众生　　弃捐色爱
  无淫劮态　　若上楼阁　　当愿众生
  皆升法堂　　受佛诸经　　身在房室
  当愿众生　　觉知恶露　　无有更乐
  布施所有　　当愿众生　　兴福救之
  莫堕悭贪　　若患厌家　　当愿众生
  疾得解脱　　无所拘缀　　若弃家出
  当愿众生　　离苦恼罪　　从正得安
  入佛宗庙　　当愿众生　　近佛行法
  无复挂碍　　诣师友所　　当愿众生
  开达入正　　悉得如愿　　请求舍罪
  当愿众生　　得成就志　　学不中悔
  脱去白衣　　当愿众生　　解道修德
  无有懈怠　　受着袈裟　　当愿众生
  被法服行　　心无沾污　　除剔须发
  当愿众生　　除捐饰好　　无有众劳
  已作沙门　　当愿众生　　受行佛意
  开导天下　　受成就戒　　当愿众生
  得道方便　　慧度无极　　守护道禁
  当愿众生　　皆奉法律　　不犯法教
  始受和上　　当愿众生　　令如禅意
  思惟解脱　　受大小师　　当愿众生
  承佛圣教　　所受不忘　　自归于佛
  当愿众生　　体解大道　　发无上意
  自归于法　　当愿众生　　深入经藏
  智慧如海　　自归于僧　　当愿众生
  依附圣众　　从正得度　　凡开门户
  当愿众生　　开现道法　　至于泥洹
  关闭门户　　当愿众生　　闭塞恶道
  罪得除尽　　入室当愿　　一切众生
  安隐寂寞　　得止观意　　敷床当愿
  一切众生　　入大乘道　　济安天下
  宴坐当愿　　一切众生　　坐佛道树
  心无所猗　　入众当愿　　一切众生
  成戒定慧　　解度知见　　数息当愿
  一切众生　　得舍家中　　无世间念
  守意当愿　　一切众生　　心不放逸
  无有杂念　　早起当愿　　一切众生
  觉识非常　　兴精进意　　下床当愿
  一切众生　　履践佛迹　　心不动摇
  着裳当愿　　一切众生　　常知惭愧
  摄意守道　　结带当愿　　一切众生
  束带修善　　志无解已　　次着中衣
  当愿众生　　恭敬畏慎　　无有慢堕
  被上法服　　当愿众生　　服圣表式
  敏于道行　　左右便利　　当愿众生
  蠲除污秽　　无淫怒痴　　已而就水
  当愿众生　　柔和软弱　　清净谨饰
  用水既净　　当愿众生　　以法自洗
  无复恶态　　手执杨枝　　当愿众生
  学以法句　　擿去诸垢　　澡漱口齿
  当愿众生　　荡涤情性　　如清净住
  盥手当愿　　一切众生　　得柔净掌
  执受经道　　澡面当愿　　一切众生
  常向清净　　心无瑕疵　　出门当愿
  一切众生　　如佛所欲　　出度三界
  向道当愿　　一切众生　　向无上道
  志不退转　　行道当愿　　一切众生
  游于无际　　不中休息　　上阪当愿
  一切众生　　乐升上道　　无所疑难
  下阪当愿　　一切众生　　深入广博
  微妙法中　　行于曲路　　当愿众生
  弃邪曲意　　行不忮忮　　行于直路
  当愿众生　　得中正意　　言无谀谄
  见风扬尘　　当愿众生　　经明行修
  心不纷乱　　见雨淹尘　　当愿众生
  大慈伏意　　不起诸想　　凉息树下
  当愿众生　　伏心在道　　经意不疲
  入林泽中　　当愿众生　　学为儒林
  养徒以德　　行见高山　　当愿众生
  志仰高大　　积德无厌　　行见刺棘
  当愿众生　　三毒消灭　　无贼害心
  得好叶树　　当愿众生　　以道自荫
  入禅三昧　　树华繁炽　　当愿众生
  三十二相　　诸好满具　　果蓏盛好
  当愿众生　　起道树行　　成无上果
  睹诸流水　　当愿众生　　得正沟流
  入佛海智　　睹诸陂池　　当愿众生
  一切功德　　慧行充满　　若见泉水
  当愿众生　　入佛渊智　　所问无穷
  遥望江海　　当愿众生　　入深佛藏
  无尽之法　　见人汲井　　当愿众生
  开心受法　　得一味道　　过度桥梁
  当愿众生　　兴造法桥　　度人不休
  见修园圃　　当愿众生　　耘除秽恶
  不生欲根　　见田稻谷　　当愿众生
  广殖福德　　不为灾患　　见好园圃
  当愿众生　　得周满持　　道法备具
  见丘聚舍　　当愿众生　　常处仁智
  道无危殆　　见精学堂　　当愿众生
  讲诵经道　　日进不衰　　见人众聚
  当愿众生　　功满得佛　　成弟子众
  见人闲居　　当愿众生　　恬惔无为
  游志典籍　　得见沙门　　当愿众生
  多闻戒具　　诲人不惓　　见异道人
  当愿众生　　远去邪见　　入八正道
  得见仙人　　当愿众生　　意行具足
  所欲者成　　行到城郭　　当愿众生
  持戒完具　　心无亏缺　　望见宫阙
  当愿众生　　聪明远照　　诸善普立
  若见帝王　　当愿众生　　得奉圣化
  如正道教　　见帝王子　　当愿众生
  履佛子行　　化生法中　　若见公卿
  当愿众生　　明于道理　　助利天下
  见诸臣吏　　当愿众生　　忠正顺善
  无固贼心　　见被铠甲　　当愿众生
  誓被法铠　　不违本愿　　见鲁钝人
  当愿众生　　勇于道义　　成四无畏
  见忧愁人　　当愿众生　　离诸恐怖
  无复忧戚　　见喜笑人　　当愿众生
  舍非常乐　　五欲自娱　　见勤苦人
  当愿众生　　得泥洹道　　免度诸厄
  见安乐人　　当愿众生　　安快如佛
  惔怕无患　　见疾病人　　当愿众生
  知空非身　　无苦痛意　　见强健人
  当愿众生　　得金刚形　　无有衰耗
  见丑陋人　　当愿众生　　去丑恶行
  以善自严　　见端正人　　当愿众生
  意行质直　　爱好道法　　见报恩人
  当愿众生　　念佛恩德　　行菩萨行
  见背恩人　　当愿众生　　降心伏意
  弃捐诸恶　　见贪欲人　　当愿众生
  法施天下　　无悭贪意　　行持锡杖
  当愿众生　　依仗于法　　分流德化
  挟持应器　　当愿众生　　受而知施
  修六重法　　入里分卫　　当愿众生
  如戒法求　　无得疑妄　　到人门户
  当愿众生　　入总持门　　悉见诸法
  入人堂室　　当愿众生　　升佛圣堂
  深行微妙　　人不与食　　当愿众生
  得般若意　　无望无惜　　主人未办
  当愿众生　　离三恶道　　无饥渴想
  授空应器　　当愿众生　　皆得至空
  无欲之性　　受满应器　　当愿众生
  一切成满　　道品之法　　擎持钵饭
  当愿众生　　为法供养　　志在大道
  与廉人坐　　当愿众生　　廉洁知耻
  所作不妄　　坐有贪人　　当愿众生
  无有强颜　　贪鄙之心　　得香美食
  当愿众生　　知节少欲　　情无所著
  得不美食　　当愿众生　　知身幻法
  好恶无异　　举饭向口　　当愿众生
  悉得诸经　　诸佛法味　　所啖杂味
  当愿众生　　味味如佛　　化成甘露
  饭食已讫　　当愿众生　　德行充盈
  成十种力　　讲经说法　　当愿众生
  志意开达　　闻法即寤　　咒愿达嚫
  当愿众生　　悉令通佛　　十二部经
  罢坐退去　　当愿众生　　一切究竟
  得三甘露　　若欲入水　　当愿众生
  身口意净　　等于三涂　　澡浴身体
  当愿众生　　荡除心垢　　见生死际
  盛暑热极　　当愿众生　　得清凉定
  灭一切苦　　冰冻寒甚　　当愿众生
  心冷爱除　　无复情欲　　诵读经偈
  当愿众生　　博解诸法　　无复漏忘
  若得见佛　　当愿众生　　常与佛会
  行七觉意　　见佛图像　　当愿众生
  悉睹十方　　眼无障蔽　　拜谒佛时
  当愿众生　　得道如佛　　莫能见顶
  稽首而起　　当愿众生　　皆如佛意
  尊贵无上　　始欲旋塔　　当愿众生
  施行福祐　　究畅道意　　绕塔三匝
  当愿众生　　得一向意　　不断四喜
  行咏歌经　　当愿众生　　念佛恩德
  行法供养　　毕住赞佛　　当愿众生
  光明神德　　如佛法身　　暮将洗足
  当愿众生　　得四神足　　周遍十方
  昏夜寝息　　当愿众生　　离于闇冥
  无复五盖　　卧觉当愿　　都使众生
  得佛十八　　不绝之法　　是为菩萨
  诫愿俱行　　兼爱博施　　不舍十方

    十地品第三

于是忍世界。百亿天帝释。皆于忉利紫绀殿上。化作七宝师子之座。施交露帐。席以彩絷已。各稽首请佛。佛意悉知。即为分身。遍诸释殿。一一佛者。从众菩萨。一切天帝。莫不悦豫。其下百亿小国。续自见佛。如故不减。时十方刹。复来云集。法意菩萨。首意菩萨。贤意菩萨。勤意菩萨。思意。知意审意。专意重意。尽意菩萨等。各从十方。与无数上人俱来。稽首佛足坐一面。莲华上法意菩萨。即如其像。正坐定意。入于无量会见三昧。悉见十方。无数诸佛。各伸右手摩其头。俱言。善哉。法意。菩萨勇健。乃得是定。十方如来。及释迦牟尼佛。已皆拜汝成立功德。修微妙辩。知空无著行。究畅法要。通诸佛语。知众生意。汝行已备。得佛不久。今使汝说菩萨。十住。令诸学者普知所行。于是法意菩萨。得佛辩辞。明哲至真。不忘不难。从定意觉而言曰。诸族姓子。欲求佛者。有十地住。往古来今。皆由此成。众祐所叹。是合无量。具陈演说。如佛所言。何等为十。第一发意。第二治地。第三应行。第四生贵。第五修成。第六行登。第七不退。第八童真。第九了生。第十补处何谓发意。菩萨法住。有十事。谓初见佛。十功德起。一见佛端正。二身色相具。三神足现化。四道德深奥。五仪法无比。六谓知人意。七出经教明。八所言谛解。九见生死苦。十体乐佛法。稍稍开解。便发道意。欲晓了佛十力之智。其学有十。当知礼事诸佛。当晓说菩萨德。当谛了生死本。当愿修贵治福。当令行胜三界。当学诸佛功德业。当求更见诸佛。当习行诸深三昧。当悲念诸罪苦人。当从生死轮还。是为上头初发意之地何谓治地。菩萨法住。有十事。以次学。一念人善。二净洁心。三柔软意。四安静志。五常布施。六行慈爱。七利天下。八助平均。九视彼如己。十敬人如师。复有十学。当多讽经。当远乡土。当近明师。当学善言。当知时。当精进。当入要。当晓行。当不忘。当安志。是为次第治地之行

何谓应行。菩萨法住。有十事入如经。一见无常。二见生苦。三见行空。四见非身。五见无主。六无所贪。七无所著。八无为。九无欲。十无求。复有十学。当念人。当念刹。当念法。当念地种。当念水种。当念火种。当念风种。当念欲界。当念色界。当念无色界。心无恋慕。是为分别应行之地

何谓生贵。菩萨法住。有十事随佛行。一不还邪道。二专心向佛。三思惟法意。四观功德行。五见人如化。六见刹如梦。七见殃福空。八见诸法如幻。九苦乐无异。十解泥洹净。复有十学。当知思念。去佛意空。来佛意空。今佛意空。去佛法净。来佛法净。今佛法净。去佛自然。来佛自然。今佛自然。诸佛兴等。皆无所异。是为平等生贵之地

何谓修成。菩萨法住。有十事行济人。一为人方便。二令人安隐。三赈救天下人。四慈念一切。五悲伤众生。六令人欢喜。七护视人物。八劝令随道。九为现清净。十令得泥洹。复有十学。当知众生。无有要。无有种。无有数。无有造。无有正。不可思。不可称。不可度。不可具说。为一切空。是为圣行修成之地。何谓行登。菩萨法住。有十事度辄成。一闻称佛讥佛心无异。二闻誉法毁法心无异。三闻菩萨善菩萨恶心无异。四闻人相评论心无异。五闻人众人寡心无异。六闻经多经少心无异。七闻生苦生乐心无异。八闻人难度人易度心无异。九闻法兴法衰心无异。十遭有道遭无道心无异。复有十学。心无想不受想。不计身。无我所。无有见。无有主。无有受。为如化。为不成。无所有。是为尽信行登之地何谓不退转。菩萨法住。有十事志牢强。一言有佛无佛不退转。二言有法无法不退转。三言有菩萨无菩萨不退转。四六言有求佛无求佛不退转。五有得佛无得佛不退转。六曰古有圣道无圣道不退转。七今有圣道无圣道不退转。八后有圣道无圣道不退转。九言三涂同三涂异不退转。十言佛智有尽佛智无尽不退转。复有十学。开微慧入大智。开大智入微慧。现一法入众经。现众经入一法。解众生入空要。解空要入众生。释有想入寂定。释寂定入有想。说少净入多想。说多想入少净。是为转进不退之地

何谓童真。菩萨法住。有十事随所入。一身口意不犯。二一切无瑕疵。三志壹在所生。四见人知内慈。五知人心所信。六知人意所解。七不受彼杂想。八知诸刹成败。九神足疾遍到十方。十周满持诸法。复有十事。学知佛世界。学如佛智能。学现佛神足行。学庄严诸佛刹。学遍游诸国土。学法答众问。学化无不现。学佛声出诸法。学转顷匝十方。学作一念见无数佛。是为清净童真之地何谓了生。菩萨法住。有十事受慧见。一知一切生何道。二知众生所习缚。三知人本所更来。四知人所行殃福之报。五知人受行何法。六知人心所入好恶。七知人意念若干变。八知十方国清浊。九知三涂无量慧。十知谛要说如应。复有十事。学法王正行。学法王礼仪。学法王兴立。学法王出入。学法王周旋。学法王威严学法王坐起。学法王教令。学法王拜人。学法王巡行刹土。是为受决了生之地何谓补处。菩萨法住。有十事智难及一当念感动无数国。二当为无数国现明。三当为无数国立法。四当为开度无数国。五当利安无数国。六当声晓无数人。七当观察知众生意。八当知众生无极念。九当令无数人入法。十以次第现人慧了。生所不能及补处者十。不能知其身事志行。神足定念。达古知今。见后明处。及修刹法。圣意之事。补处所欲。又有十事。学佛三涂无际之慧。学具足诸佛法。学法法无所著。学诸佛无底藏。学神智成其刹。学光明照十方。学佛定感动诸国。学权道随意化。学遍教令成就。学合会转法轮。所以学者。欲一切知。已一切敏。无所复学。是名为补处。从十十法成。现世得绍代无上正真之道。为最正觉。度脱天下。佛言。善哉善哉。法意菩萨。可谓佛子。一切十方去来现在佛。皆由此兴。是法无际。所照无量。度人无极。智心无尽。佛说是已。皆大欢喜。为佛作礼佛说菩萨本业经


佛说菩萨十住经一卷

    No. 284 [Nos. 278(11), 279(15), 281(2), 283]

    佛说菩萨十住经一卷

        东晋三藏只多蜜译

佛说菩萨戒。十二时竟。文殊师利。白佛言。菩萨用何功德。得是十住。唯愿天中天。分别说之。佛言。善哉善哉。文殊师利菩萨摩诃萨。多所忧念。多所安隐。吾当为汝具说其要。谛听谛受。文殊师利言受教。佛言。有十住菩萨功德。各有高下。自有次第。文殊师利言。何等为十

一住波蓝质兜波菩萨法住。佛言。上头见佛端正无比。视面色无有厌。无有逮者。尊贵无有能过者。所教授无有能踰者。见佛威神仪法如是。便稍稍入佛道中。转开导之。皆随其意教度脱之。见勤苦皆愍伤之。稍稍解晓佛语。信向之。新发起意。学佛道。悉欲得了知佛智十难处。悉欲逮得之。何等为十难处。佛十种力是也。一者当供养佛。二者当随其所乐当教语之。三者所生处皆尊贵。四者天上天下无有能及者。五者佛智慧悉逮得。六者世世所生处。得见无央数佛。七者佛经悉逮得。八者悉过度诸生死九者今脱去不久。十者悉度脱十方人

二住何等为阿阇浮菩萨法住。佛言。有十意念十方人。何等为十意。一者悉念世间善。二者洁净心。三者皆安隐心。四者柔软心。五者悉爱等。六者心念但欲布施与人。七者心悉常等护。八者念人与我身无异。九者心念十方人。视如视师。十者心念十方人。视如视佛。阿阇浮菩萨法。当多学经。多学经已。当独处止。独处止已。常当与善师从事。当在善师边易使。当随时。随时所作为勇。所作为既勇。当学人慧。中以所受法当悉持。当不忘也。既不忘者。当安隐处止。所以者何。益于十方人故

三住何等为喻阿阇菩萨法住者。佛言。入于诸法中。用十事。何等为十事。一者谓所有皆无常。二者谓所有皆勤苦。三者谓所有皆虚空。四者谓所有皆非我所。五者谓所有皆无所住。六者谓所有皆无所利。七者谓所有皆无所止。八者谓所有皆无有处。九者谓所有皆无所著。十者一切无所有。诸法悉入一法中。一法悉入诸法中。是为喻阿阇菩萨教法

四住何等为阇摩期菩萨法住者。佛言。常愿于佛处生有十事。一者不复还。二者多深思于佛。三者深思于法。四者意念比丘僧。视十方人慈心。五者思惟万物皆无所有。六者十方佛刹皆虚空。七者宿命所作了无所有。八者诸所有如幻皆虚空。九者诸所勤苦无所有。十者泥洹虚空亦无所有。用是故。生于佛法中。是为阇摩期菩萨教法

五住何等为波俞三般菩萨法住者。佛言。所作功德悉度十方人。有十事。一者悉护十方人。二者悉念十方人善。三者悉念十方人令安隐。四者悉爱十方人。五者悉哀念十方人。六者悉念十方人。莫使作恶。七者悉引十方人。着菩萨道中。八者悉清净于十方人。九者悉度脱十方人。十者悉使十方人般泥洹。是为波俞三般菩萨法教

六住何等为阿耆三般菩萨法住者。佛言。有十法深哀慈心。一者有人说佛善恶。心无有异。二者说法善恶。心无有异。三者说菩萨善恶。心无有异。四者求菩萨道人共相导善恶。心无有异。五者有人言。十方人有多少。心无有异。六者睹十方人。展转相导善恶。心无有异。七者中有人说言。十方人易脱难脱。心无有异。八者若有人说法多少。心无有异。九者有人说法坏不坏。心无有异。十者有法处无法处。心无有异。是为阿耆三般菩萨教法

七住何等为阿惟越致菩萨法住者。佛言。菩萨有十事坚住不动。一者言有佛无有佛。心不动还。二者有法无法不动还。三者有菩萨无菩萨不动还。四者有求索菩萨道。无求索菩萨道者不动还。五者持是法得。持是法不得。不动还。六者有诸过去佛无过去佛不动还。七者有诸当来佛。无当来佛不动还。八者有现在佛。无现在佛不动还。九者佛智慧尽不尽不动还。十者当来过去现在世事。乎若干种。若一种不动还。是为阿惟越致菩萨教法

八住何等为鸠摩罗浮童男菩萨法住者。佛言。菩萨于十事中住。一者身所行口所言心所念。悉净洁。二者无有能得长短者。三者一反念在所欲生何所。四者十方人。知谁慈心者。五者十方所信用悉知。六者十方人若干种悉知。七者十方人所作为悉知。八者十方诸佛刹土成败悉知。九者得神足念飞在所至到。十者诸法悉净洁。是为鸠摩罗浮童男菩萨教法。九住何等为俞罗阇菩萨法住者。佛言。用十事得。一者十方人所出生悉知。二者十方人所系恩爱悉知。三者十方人所念本末。所从来悉知。四者十方人所作宿命。所趣向悉知。五者十方人若干种诸法悉知。六者十方人所念若干种变化悉知。七者诸佛刹善恶坏败悉知。八者过去当来现在。无央数世事悉知。九者十方人等不等悉知。十者教授十方人。说虚空法悉知。是为俞罗阇菩萨教法

十住何等为阿惟颜菩萨法住者。佛言。菩萨入于十智中。能分别知。有十事。一者何因当感动十方诸佛刹。二者当明无央数佛刹中。事三者我日日当署置无央数佛刹中菩萨。四者我日日当度脱无央数佛刹中人民。五者我当安隐无央数佛刹中众生。六者十方人。莫不闻我声欢喜得度脱者。七者悉令十方人民。使得佛道。皆舍家作沙门。八者十方人所思想善恶。我悉知之。九者十方人我悉当内着佛道中。悉使发菩萨意。十者十方人我悉当度脱之。是阿俞罗阇菩萨。了不能及知阿惟颜身所行口所言心所念所作为。了不能及知阿惟颜菩萨事。亦不能知神足念。不能知飞行。亦不能逮知阿惟颜菩萨当来过去今现在事。是为阿惟颜菩萨教法

佛说是时。和轮调菩萨等。七万二千人。皆大踊跃欢喜。各现光明。展转相照。各各起正衣服。前以头脑着地。为佛作礼而去佛说菩萨十住经


佛说如来兴显经卷第一

    No. 291 [Nos. 278(32), 279(37)]

佛说如来兴显经卷第一

        西晋月氏三藏竺法护译

闻如是。一时佛游如来建立之土。号叹法身深奥悦豫普见棚阁。为大严净显曜威宫琉璃之藏如来所行。佛时兴出无量之路。为法界宫。观菩萨身。光明清净。师子之座。咸受一切菩萨之体。为大法座。咨嗟法界。如来圣旨。缘虚空界。行无挂碍。晓了本际圣慧之界。普解佛慧。分别圣道。去来今佛。一切悉等。为一法身。一切诸佛行。皆平等神通之行。无所挂碍。法身慧体。究竟无相。法度无极。游于法界。无有二行。玄旷无限。为最正觉。其等如称。则超度行。无有阴盖解脱之门。其法界者。普同虚空。常游十方。诸佛国土无限之故。靡所不睹。亿百千垓诸菩萨等。犹如尘数。一切悉已一生补处。各各在于异佛世界。志愿无极。奉诸慧行。各各入于无所破坏平等法界。空界无限。无所获致。无中间行。无有自然。亦无所生。晓了证明一切诸法。亦复如是。众菩萨身。无所动舍。逮诸通慧。遍诸佛土。而无所念遵如来慧。而于佛道。现在得致显明之曜。游大圣行。无所震动。慧以一身。示于无量所行之体。周于无限法界之里分别善人众生之界。至不退转。等获本际。无本法界。除去自大。身常卑顺。则无所畏。如来照明。一切德本。以为徒类

其名曰普贤菩萨。普称尊菩萨。如来族姓成首菩萨。金刚幢英菩萨。无盖月净菩萨。日光离垢藏菩萨。大神通变动菩萨。离垢光首十方精进王大师子娱乐神通菩萨。如是等类。犹如十方不可计数亿百千垓诸佛之土满中众尘。众会菩萨。其数如斯

于是有光。号如来圣旨。世尊眉间。演出斯耀。无央数垓亿百千明。照于无量无有边际。无余世界十方佛土。示现如来威神之变。告无央数亿百千垓诸菩萨众。威神。则令诸佛世界一切恶趣。悉为销灭。覆蔽一切诸魔宫殿。又诸如来。成最正觉。寤诸未觉。示现诸佛众会道场。所出光明严净之座。显曜法界第一空界在所周遍。达诸佛界。寻复来还。皆绕一切菩萨坐场。入如来族姓成首菩萨顶上不现。如是众会。一切菩萨。怪未曾有。身心踊跃。今日当有无极之变。讲说大法。如此光明。自然来现。光明适没。如来族姓成首菩萨。即从坐起。于莲花上。而下右膝。长跪叉手。思如来德。以偈颂曰

  寤诸不觉者　　超踰诸德王
  其行无挂碍　　所起度无极
  其大圣安住　　平等于三世
  恭敬今稽首　　明哲之慧上
  所行无形相　　则度于彼岸
  又复而示现　　善庄严身相
  光明离众垢　　演显百千曜
  降伏诸魔事　　以顶归命礼
  震动诸国土　　宫殿之元首
  乃至于十方　　诸所有土地
  终不令一人　　而使获恐惧
  佛道之威神　　所兴如是比
  而平等建立　　于虚空之界
  其法界如是　　获逮诸境土
  严净于黎庶　　亿垓之尘数
  蠲除诸众生　　一切之罪衅
  志愿甚坚强　　行于亿千劫
  玩习积累德　　殊胜之佛道
  逮得于一行　　圣慧无挂碍
  以一之自然　　皆行诸佛道
  所演放光明　　导师为若兹
  普见于忍界　　一切靡不周
  普示现一切　　威神之变化
  吾身已得入　　于一自然行
  今以是之故　　兴发如此念
  今为正应时　　稽首于法王
  无央数菩萨　　悉来集会斯
  而欲得听省　　所分别法事
  今日诸会者　　清净复清净
  而于诸世界　　亲近遵修行
  圣慧无限量　　境界无挂碍
  逮得于勇猛　　无极之威神
  斯等游世谊　　所行逮神仙
  智慧不可计　　超越精进力
  而造奋光明　　悉照诸菩萨
  今鄙如应问　　殊胜最上法
  所堪任境界　　为之大圣通
  自恣其威曜　　而普悉示现
  导师最上尊　　颁宣诸佛土
  孰为人中圣　　至上之真子

说此颂赞已。应时世尊从口演光。名不可计亿数照明。照于一切无有边际诸佛世界。绕诸佛土。具足十匝。示现如来圣旨威变。请无央数诸菩萨亿百千垓。悉见告敕。动诸佛土。至诸恶趣。悉灭灾患。覆蔽一切诸魔宫殿。十方如来平等正觉。觉诸不觉。示现诸佛众会道场。光明之耀度于法界。一切周遍虚空之界。达诸佛土。寻即复还。绕诸菩萨。入于普贤菩萨面门。普贤菩萨。适遇斯光。寻时如应。功德威颜。师子之座。倍加于前。超越佛身及师子座。又复绝踰诸菩萨体师子之座。普贤菩萨仪观美德。师子之座。高广殊妙。而现特为显丽。尔时如来族姓成首菩萨。问普贤曰。唯佛之子。仁之功德不可思议。一切世界悉遍知之。兴大变化悦诸菩萨无极感动。今斯佛子。如来所现。变本瑞应。普贤菩萨。谓如来族姓成首菩萨。如吾所忆。又如往古诸平等觉之所睹现。如斯变化无极感动。当讲如来兴显经典。今者大圣。欲演此义。故复示现如是变应。如来族姓成首菩萨。适闻于斯兴显典名。寻时即以佛之威神。地则大动。于是如来族姓成首菩萨。谓普贤曰。善哉佛子。堪任能乐为诸菩萨大士之等。赞扬如来至真等正觉。兴显成乎。今者十方悉皆严净。无央数亿百千垓众。而来集会。往古善修清净之行。心有所归。怀抱道德。显发觉意。演大言辞。超度彼岸。建立一切诸如来行。威仪礼节。心念诸佛。未曾忘舍。兴设大哀。普观众生。诸大菩萨。决了神通。分别一切如来精进。己身惔怕。闻一切佛所赞道音尊妙之法。如是俦伦。功德名称。平等蠲除一切憎爱。而无适莫。今斯菩萨。皆来集会。仁为佛子。曾已供养无央数亿百千垓佛。稽首咨受。悉已遵修诸菩萨行。获大神足诸三昧门。娱乐神通。皆入如来秘密之藏。销诸狐疑。入于如来无畏精进。探睹众生一切诸根。皆以信于真谛解脱。而说经典。达如来动。圣性所归。颁宣一切诸佛之法。最为第一得度无极。如是比类。不可称计。众德奇特。善哉佛子。愿说如来兴显现身。畅演弘音。所可讲说。诸心念行境界之处。所叹行者。成最正觉。转于法轮。宣传佛教。现大灭度。示于如来一切德本。诸所造行。尔时。如来族姓成首菩萨。重欲解义分别所归。则为普贤菩萨。而说颂曰

  善归无合会　　谛晓了悉觉
  其慧则无上　　平等离欲尘
  称叹于最胜　　所行无限量
  其闻于音响　　一切悉踊跃
  菩萨之殊特　　云何兴出胜
  所以得归趣　　何因致真实
  如来之音响　　何谓为身心
  其行之境界　　斯大称云何
  何谓为诸佛　　而因言如来
  何故为最胜　　而转于法轮
  愿讲众安住　　灭度之道地
  当悦可斯等　　无量诸佛子
  其在于十方　　安住大法王
  一切诸众生　　功德之所归
  斯等之福庆　　大圣愿为说
  何缘见道意　　云何至安住
  云何得听闻　　如来之名号
  未曾得睹见　　灭度诸大圣
  假使发踊跃　　恭敬于尊圣
  唯悦豫说之　　何因成大意
  今以问于此　　清净之大人
  为说所奉行　　大德之巨海
  察斯诸菩萨　　一切悉叉手
  问佛并仁者　　及咨于鄙身
  当为斯等故　　宣说净尊法
  为断众狐疑　　获无量大慧
  因为引譬喻　　示现佛种姓
  设众生闻者　　发清净道心
  悉令诸佛土　　周遍胜无余
  诸佛普示现　　若干种身形
  知法清净者　　则演随应时
  因其族譬喻　　而为示现说
  往至垓佛土　　于十方百千
  亿百那术数　　无量不可计
  难可得值见　　如是等菩萨
  如今日聚会　　若兹自在胜
  是故愿说之　　安住行清净
  由斯广宣阐　　如来之族姓
  斯等诸菩萨　　一切叉手立
  普悉志求法　　渴仰于经典

普贤菩萨。缘如来族姓成首所问。普告一切诸菩萨众。唯最胜子。诸如来处不可思议。至真等正觉。若兴出者。演不可量。叙法次第。无能称计。如来熙隆。巍巍如是。虽以一事。不以一事。而归于道。所以者何。唯佛之号。又有十事。为无量法归。不可计百千功德。修习所行。得至如来。何谓为十。道心无量。普护群黎一切之意。往宿积累善行之念。志性无限从本清净。合集无极。大慈大哀。而以习趣。救济众生。愿行无底。不断遵修。福慧无极。习行无厌。而习归趣。教化众生。无边佛藏。亦以习趣。善谛清净。无量善权。智慧之路。奉无量德。无限之道。所习圣智。合集怀来无际法义经典之藏。是故佛子。十法之行。为法面首。已具足十不可计会。无量百千眷属枝党。得归如来。譬如佛子其千世界。所因得号。不以一事。而合成也。以无数合会成。譬如大阴。不失时节。而以澍雨。有四因缘。诸风习习。飘飖流布。风名执御。其大风场。多有众水。主导御雨。有枯竭风。其风烧水。有风名曰住立。住立一切所有宫殿。风名庄严。为诸三千受体众生。罪福俱游。计诸菩萨所成功德。亦复如是。无有限量。不可计会。亦如若干立三千界。乃得诸法。无有能为分别计数。称量本末。无能睹见尽其原者。如是佛子。如来至真等正觉。不以一事不以一义。而兴出也。又从往古诸如来所。先兴弘阴法雨。其心奉教。而无厌惓。志性坚强。执持不忘。不有愦乱。观察寂然。以慧道场。枯竭一切尘劳之欲。诱劝修殖。众德之本。而善建进。锁却憍慢。分别决了清净之行。讲畅言教。德净群生。如来功祚。道原无漏。怀来如是。至真正觉。获致诸法。于彼无有兴出之者。是为入于第一之门。菩萨所行。至于如来之所兴显。复次佛子。譬如喻于三千世界。自然兴盛。起大阴云。名不可坏。应时而雨。其余地者。不能堪任。受于此水。唯有三千世界遭水变时。如是仁者。佛之法界。有弘法泽。名曰无坏。合集如来不断佛种。及诸圣士。一切声闻。及与缘觉。所不堪任受持奉行。唯有菩萨。承大势力。心无恐惧。誓被德铠。是为二事。于是颂曰

  明听诸十方　　一切世间上
  求比无等伦　　譬之若虚空
  导师之所行　　无量无边际
  则为无俦匹　　其德皆周遍
  假使思惟佛　　心念之所由
  斯诸十方者　　功德无限量
  众人之口辞　　亿百千劫叹
  雄师子无极　　世俗无有双
  一切诸十方　　诸所有佛土
  皆破碎如尘　　如是尘数劫
  复如亿百千　　咨嗟诸十方
  一毛之功德　　而不能尽极
  假令有丈夫　　欲称量虚空
  第二人计然　　疾算诸受相
  不可计无量　　不能尽虚空
  当知诸十方　　如是行无限
  假令三世人　　诸在三界者
  设计此众生　　心之所行念
  心一时须臾　　悉可知分数
  群萌诸思想　　神识之所念
  犹譬如法界　　悉无有边际
  而不见一切　　法界之所趣
  十力亦如是　　所行无限量
  一切无一切　　法界为自然
  犹如大雨时　　名曰不可坏
  无能任受者　　水灾乃能苞
  佛演无极泽　　小乘不堪受
  唯菩萨能奉　　遍布于一切
  无本如无本　　寂寞无二想
  永无有生者　　是曰为普等
  一切世间上　　境界亦如兹
  无本等自然　　已脱于增损
  犹如斯本际　　真本际无际
  三世为平等　　普解脱一切
  愍哀等如斯　　导师之所行
  咸周于三世　　一切无挂碍
  本际无所造　　无造能自然
  本净如虚空　　无垢无尘劳
  最胜显如是　　一切悉严净
  已舍造无造　　弃于有无事
  释放言声辞　　及一切音响
  蠲除于去来　　灭度无所有
  诸十方如斯　　于法而自然
  一切言无声　　亦不可受持
  如是净寂然　　晓了一切法
  如空中鸟迹　　若石处虚空
  缘本所誓愿　　而示现色身
  自观诸十方　　最胜所变化
  假使欲入斯　　如是最胜界
  当志念遵道　　自净其志性
  制捐诸思想　　于念亦无念
  犹空中鸟迹　　心所入如是
  是故安住子　　省诸导师行
  听我之所说　　精举诸譬喻
  计于诸十方　　名德不可极
  况复说其义　　咨嗟讲圣尊
  如彼群萌类　　自然行致身
  不能思念计　　诸导师所行
  十方境界果　　佛道自在伦
  成就诸德本　　听说一切德
  今现是世人　　思行令无余
  未曾念堪任　　合聚依因缘
  百亿土有辞　　音合亿百千
  所以曰言世　　因立三千界
  人中上如是　　斯等自然悉
  不能计演德　　如其等所周
  常可数宣畅　　一切众生念
  不可知人尊　　所行之自然

复次佛子。犹如此雨无所从来。无所从去。而致斯润。是群萌类。因罪福生。如是佛子。斯诸如来。兴隆道化。无所从来无所从去。而致法雨。悉是菩萨。众德本力。是为三事。于是颂曰

  如雨无从来　　去亦无所至
  佛化一切然　　无来亦无去

复次佛子。譬如大雨三千世界。受体众人无能计会。知其渧数。设一佛土。所兴众生。思念弘泽。心眼为惑。唯有主知。三千世界。雨尊天子。悉知诸数。不失一渧。悉是宿本德之所致。如是仁者。一切众生。声闻缘觉。不能晓了。思惟观察。如来法泽。不能及念。怀来大心。假使闻之。斯大心者。则当迷惑。唯众生尊菩萨大人。于过去佛。善修道业。得无上力。能知之耳。是为第四。于是颂曰

  犹如有大雨　　遍三千佛土
  唯尊天子知　　其余无能别
  计一切声闻　　及缘觉之乘
  不解佛法雨　　唯菩萨能知

复次佛子。兴大云时。又有阴雨。名曰灭除。灭尽于火。有大雨。名曰愦乱。坏于水灾。又有大雨。名曰断绝。断除于风。又有大雨。名曰坏败。毁坏大宝。又有大雨。名曰消烂。则以糜烂三千世界。如来如是。兴显于世。有大法雨。名曰灭除。而演法泽。消除一切尘劳之欲。又名积业。而演法泽。积累一切。众德之本。又名蠲释。而演法泽。断除一切六十二见。又名坏败。而演法泽。令成一切诸法之慧。又名消化。而演法泽。化灭一切心志所行。是为第五。于是颂曰

  如雨灭除火　　有雨坏水灾
  有雨断绝风　　毁落大宝山
  如来兴显世　　灭一切贪欲
  积累众德本　　除六十二见
  法雨于十方　　成就一切慧
  化众生志性　　使顺从正道
  令不吝四大　　三界无根原
  自然无极慈　　三达无挂碍

复次佛子。如雨一味。若滋无限。润悉周遍。如来若斯。以一大哀。咸雨一切。令至无边。法泽周普。怀致大圣。故曰如来分别显现无量之法是为六事。于是颂曰

  譬如雨一味　　而悉遍蒙润
  如来亦如是　　行等无偏邪
  则以一大哀　　咸雨一切人
  法泽至无边　　普怀来大道

复次佛子。犹如三千世界还复之时。先成色界诸天子身所有宫殿。次成欲界世人所居。然后成就众生之类。如来若斯。兴显现世。先成就于诸菩萨慧。然后次演缘觉慧行。次乃显示声闻德本所行之慧。然后示于余众生合集善本所当行慧。道法一味。随众生乐。所为德本。所居屋宅。宫殿之处。如现一类。或不用者。如来法味。亦复如是。从黎庶器。所殖德本。而显慧行。自然为现。是为七事。于是颂曰

  犹始立天宫　　色界无色界
  然后乃兴盛　　欲界之宫殿
  已后乃成地　　人民之处所
  一切诸萌类　　诸龙揵沓和
  十力亦如是　　本已应自然
  修行无边际　　菩萨之风仪
  然后寂然宝　　因缘而得立
  次于得自在　　分乃及众生
  雨诸渧堕已　　无青亦无黄
  水则入于地　　缘是生若干
  因其地欲就　　生树山丛林
  其水不若干　　生地种之名
  诸导师住谛　　智慧悉圣达
  哀慧如虚空　　执持于善权
  如最胜之法　　则入斯供养
  智慧离众垢　　其身无所住

复次佛子。犹如水灾兴起之时。等在虚空。斯三千界。现有莲华。名成德宝。为若干种。而自然生。皆悉覆蔽于水灾变。普照世间。假使莲华。自然出时。大尊天子。及净居天。得见斯华。则便知之。于此劫中。当有若干平等觉兴。彼有自然风。名显曜。而起游行。则已成就色界天子宫殿屋宅。又复有风。名净显明。安隐净洁。而以成立欲行天子宫殿屋宅。又复有风。名曰一类。无所破坏。而成立于大铁围山金刚之山。又复有风。名曰特尊。而吹成立须弥山王。又复有风。名曰长立。而吹成就七大宝山王。一曰阴涂利。二曰懿此山其利。三曰除害[土*屋]。四曰除优陀罗。五曰脱化民随罗。六曰目邻大目邻。七曰香山冰山。又复有风。名曰善住。成立大地。又复有风。名曰严净。成立游地诸天。天龙揵沓和宫殿屋宅。又复有风。名无尽意。成立三千通流一切海之渊。又复有风。名照明藏。成立普世如意宝珠。又复有风。名坚固根。吹令成就衣服之树。如是仁者。其大阴雨。则为一味。又其水者。无有想念。获致诸法自然之数。而使众生别知德本。如斯诸风。则以诸风。分别了知三千世界如来至真等正觉者。所以怀来一切德本。成就诸法积累无上无极之慧。为世面首。而不断绝。如来种性。显耀无极威神光明。普晖世间。靡不周遍。其见光明。皆以至心。向于如来。又是大圣。无所挂碍。及诸菩萨。各自念言。今者如来。所以兴显化诸菩萨。是故现身于斯世矣。分别演说诸佛种性清净离垢平等之慧。奋此光明。如来所可咏怀合集无漏之慧道光明。名曰普照。令致如来不可思议法界之慧正觉种性。又有光明。名曰总持以。故如来。力不可动。怀来兴显。无能胜者。有道光明。名曰超越。故诸如来。慧无所畏。怀来兴显。莫能及者。有道光明。名一切通。故诸如来。怀来合集。诸通之慧。靡不从教。有道光明。名坏憍慢。故诸如来。令众声闻。见功德本。不为虚妄。无所缺减。致无所著。有慧光明。名曰普德。一切众生。若见佛者。悉令归趣。无尽福慧身亦如是。有慧光明。名远中间。如来以斯深妙之智。归趣合集。至道三宝。而不断绝。有慧光明。名若干种庄校严净。如来以斯具三十二相。八十种好。怀来合集。一切普备。悦可众人。有慧光明。名无等伦。如来以斯。度于法典。咸同空界。于佛之土。寿命无量。致无穷极。如是仁者。如来法雨。则为一味。如来慧场。无所想念。显示菩萨。成致道法。见众生根。而为说经。如来之慧。悉为一等。圣道光明。等无差特。以故如来。兴出现耳。佛子。观此如来致于一解脱味。分别显现。无有限量不可思议清净之德。令众生类。悉睹知之。皆是大圣之所建立。又复欲令如来无所建立。而显现法未之有也。若使劝立化于一人。至于无上。则为如来。俱显德本。若能晓了如来之德。想念智慧。而逮及者未之有也。如来圣旨。超殊诸法。故为众生。分别显现。令入此义。使了亮法。不以厌足。如来无想。亦无所念。无所成就。亦不怀来。无所造作。亦无不作。彼无作者。无所从来。乃为兴显。是为八事。于是颂曰

  如莲华出生　　觉佛兴如斯
  诸天欢喜者　　曾见过去佛
  睹水之所在　　宫殿则清明
  今世不复久　　各当有国土
  佛真善光明　　斯为本瑞应
  菩萨之所念　　觉了靡不达
  其慧识清净　　身鲜洁无垢
  十力济蠕动　　念行诸佛法
  晓了世所有　　无量所造业
  犹在因地上　　地在于水表
  悉处于虚空　　此谓大宫殿
  两足及四足　　众生皆依仰
  人中尊如是　　已达为法王
  为一切无余　　众生皆戴赖
  睹见若闻者　　悉宗共侍之
  破坏爱欲尘　　群生所依业
  上至于梵天　　然及无边际
  孰为众生故　　而欲安黎庶
  不应光为迷　　而求于智慧
  无喻而为喻　　最胜以故见

复次佛子。譬如空中而立四风。执持水种。何谓为四。住风起风御风坚周风。是为四。持虚空水。地在水上。不动不摇。是则名曰为地力矣。水在风上。风立于空。空无所住。以是之故。三千世界。而有处所。如是仁者。假使怀集。如来兴显。建立于世。无所挂碍。智慧之明。便有四部。无极慧场。执持一切众生德本。何谓为四。一时顺欢悦群黎慧场。二建立诸法因缘慧场。三护众德本所御慧场具足诸业。四住无漏界而睹慧场。是为四慧场。以此将育一切黎庶。其大慈者。度脱群萌。其大哀者。执师子吼。以能立此大慈大哀。分别众生诸所念趣。住权方便。建立慈行。是为绥怀如来兴显。又如来者。无所挂碍。圣达之明。悉无所住。是为九法。于是颂曰

  犹如虚空界　　而无有齐限
  受有色无色　　所苞无有量
  八维及上下　　佛土诸有身
  三界无有余　　是为虚空界
  诸胜身如是　　则普而示现
  观察诸法界　　有无之所处
  大圣之尊体　　一切无见者
  若睹诸导师　　随律蒙开化

复次佛子。犹如三千世界。弥广无限。众生之类。有若干行。若有方便。不离虚空。或在水中。或在地上。或分陀利。不可计量。各行权便。或在诸天宫殿之中。自在天宫。或在虚空。因空自恣。如是仁者。假使如来。绥集显现。一切众生。见皆戴仰。若有觐者。欢喜踊跃随时自恣。则住觉力。继习禁戒。娱乐弘业。度世贤圣。自由神通。智慧无身。说无挂碍。圣达之门。修行此业。演说显耀。而自恣成。不失报应。讲务光辉。导利诸法。依由大化。无所忘失。是者名曰。绥集如来显现。一切众生而悉戴仰。是为十力法。斯为佛子。如来至真等正觉为诸菩萨兴显示现怀来讲法。有所归趣。不可限量。无有放逸。亦不调戏。其心意识。有所兴发。归于无身。自然如空。了解众生。则为自然。不计吾我。非有崖底。一切佛土。则无有土。诸土尽空。归无退还而不断绝。当来之际至无欢豫如来圣慧无有[番*去]党。归于无二。有形无形。有为无为。诸法平等。假使通达一切众生遵修大猷自恣之业。乃是往古之所劝助。则能具足斯奇雅矣。是为佛子。无限言辞之徒类也。所言徒类。怀集如来兴显大道。于是颂曰

  一切诸众生　　依怙于佛土
  悉因虚空界　　则顺随法教
  或水中平地　　若于诸天宫
  鬼神及龙王　　皆为依仰之
  空无有斯念　　今吾何所造
  已为何所失　　为谁现造义
  人中上如是　　身显诸缘便
  随一切十方　　而造若干行
  戒禁自娱乐　　弘业度世圣
  以神通慧明　　为益谁利义
  顺示清白法　　了无有诸身
  未曾兴想念　　为益谁利义

佛说如来兴显经卷第一佛说如来兴显经卷第二

        西晋月氏三藏竺法护译

何谓佛子。诸菩萨众。觐见如来。至无限量。菩萨设若亲近如来。则为归道。所以者何。无所见者。为见如来。见如来者。则为一法身。以一法身。若一慈心向于一人。则为普及一切群萌。多所将养。如虚空界。无所不苞。无所不入。或至一切有色无色。有形无形。有处无处。亦无所至。亦无有来。则无有身。以无身故。无所不周。佛身如是。普入一切。群萌之类。悉于诸法。一切佛土。靡所不遍。亦无所去。亦无所从来。所以者何。用无身故。如来身者。欲以开化众生之故。因现身耳。是为佛子。菩萨入于第一之门归趣兴显。则谓如来

复次佛子。譬如虚空无色无见。无有形类。而不可睹。因分别知。众生之类其所苞[果/衣]。广普弥远不以逼迫。空亦无想念。如是若见如来之身。普照世间。及度世事。因别罪福。如来不来。亦无所去。无所挂碍。亦不可得。所以者何。大圣光明。蠲除一切八十颠倒。是为第二所入之门。于是颂曰

  因发起驰逸　　则尽威光焰
  悉见于众生　　增损诸因缘
  如空无形色　　如来亦如是
  以一等法身　　救脱众生类
  最胜适出现　　化一切冥者
  渐渐观察谊　　兴盛遇佛道
  道德甚弘广　　照曜三千界
  度脱生死难　　心悉无想念
  人尊无等伦　　示现于增损
  若有训己者　　逮得于缘觉
  一切众生知　　亲近人中圣
  譬如大梵志　　自处清明宫

复次佛子。日之光明。照阎浮提。众生之类。蒙恩无限。而仰得活。辉耀无量。犹如流水出于山川。生长百谷。衣服之具。其有窈冥不明之处。亦复赖之。蜎蜚蠕动。牛马骡驴。亦复由之。所欲读说。溪谷树木。及诸药草。悉亦因之。诤讼虚无。悉得决了。空中游行众生之类。悉复怙之。江河浴池。泉源流水。亦复恃之。莲华开披。郡国县邑。州域大邦。悉得其明。展转睹见若干形色。游于田野草苗之中。陆地之人。水中品类。悉复仰之。各各修治生活之业。有所兴造。便能究竟。所以者何。日之光明。宫殿所照不可限量。饶益众生。道德如日。群萌若觐如来身。闻其音声。致无央数不可称限方便之缘。而依得安。回恶就善功德之法。蠲除愚戆。灭众冥事。兴隆道慧。巍巍晖曜。其大慈者。普护众生。其大哀者。救脱黎庶。归趣诸法。长育成就三十七品道之力也。殖种信净。犹如浊水。而致清澄。所睹不虚。不失报应有色无色生没之事。悉见睹之无所伤害。道慧光明。令诸众生。不失德本。为众之首。菩萨大士。犹如莲华。劝化布施一切诸行因缘之便。而为最上。所以者何。圣之道场而无涯底。如来奋震。无量慧光。无限圣场。亦复若斯。是为第三所入之门。于是颂曰

  譬如日宫殿　　悉照阎浮提
  于空而垂光　　除闇无蔽碍
  本无无处所　　因地生莲华
  众人而依怙　　若干之土地
  胜日亦如是　　众生悉恃仰
  诸天世人民　　善修于德本
  降伏于无极　　逮致法光明
  得见人中圣　　因成于三乘

复次佛子。譬如彼一日之宫殿。照大石帝须弥山王。次复照于诸余大山。次照黑山。后乃照陵阜丘垤。及地处所。此阎浮提人所游居。光明随地。其日宫光。无有想念。言当先照于宝山王。又日演晖。等无差别。是其土地。处所高卑。非日光明而有殊特。不念先后。如来若此。等游无量忠正法界巍巍道场。则演出于无损光晖。以斯慧明。普有所照。其前云大。帝石山须弥王者。而先遇光。则谓趣于诸大正士。以法光明而为示现。开化度之。然次乃示声闻缘觉之所慕慧。众生发志。建立德本。然后化于不善之党。稍渐教于一切黎庶。长处邪见。悉皆遭蒙如来之光。已蒙光明。便得受决于当来世。得值如来日之慧晖。令无思想。成诸德本。如其志愿。逮智慧耀。是为第四所入之门。于是颂曰

  如斯日之曜　　不离诸有形
  又及诸天众　　亦皆得依倚
  犹如诸江河　　饶益于众人
  安住光如是　　众生悉戴仰
  其离笃信者　　不见佛日光
  何所佛差特　　斯等亦蒙赖
  若有闻名者　　遭遇胜光明
  缘是渐获进　　至于成佛道

复次佛子。如日宫殿。其生盲者。不见威光。虽无眼目不知昼夜。续因其明。得生活业饮食之具。如是众生。亡失本净。见佛不信无极道光。则谓生盲。虽不睹见。如来慧光。纵使如此。续当蒙于大圣日照。如是比类。微妙弘明。晖曜神通。照其身形。为设瑞应。于当来蠲除爱欲尘劳之行。是为第五所入之门。于是颂曰

  如日照天下　　生盲不能见
  虽不别昼夜　　续蒙其晖曜
  众生失本净　　不信如来慧
  佛恩慈广大　　续当蒙得度

复次佛子。譬如月殿造立现四未曾有法。何谓四。照诸窈冥。在于众星。而常弘明。其亡道者。指示处所。普游天下。有所容受。已见月光。众生戴仰。立随方面。有所游出。不怀狐疑。是为四。如是如来之身。有四难及。自昔未有。示现叵逮。非人所见。何等四。普现一切学与不学。缘觉之乘。所誓愿者。从其信乐。如示现之。限碍之事。寿命之节。其损耗者。为示长益。如来道场。不增不减。咸见一切诸佛世界。众生之类。所可造念。随力信乐。应为道器。因何光明。则为一切群萌品类。而见瞻戴。观于佛身。皆蒙曜晖。又如来身。无有想念。便能逮得无所著心。是为第六所入之门。于是颂曰

  其月光明照　　神围须弥山
  光乃至诸山　　然后至丘岸
  次照于高土　　乃至于平地
  渐曜诸卑下　　所有诸土地
  安住光先照　　诸菩萨身形
  然后奋晖曜　　缘觉之所行
  尔乃照自在　　次照学不学
  乃照众无余　　佛道无想念

复次佛子。如大梵天。名曰三千。悉现身三千世界。靡不周遍。亦不分身。群生品类。敢有形者。随其色貌。皆现其前无不见像。如来至真。亦复如是。未曾分身。无若干体。普诸世界。随诸黎庶。志性形体。所可信乐。而示现之。大圣身心。亦无想念。是为第七所入之门。于是颂曰

  梵天名三千　　悉遍自现形
  于众势各尊　　自在无不睹
  又斯梵天者　　而不分其体
  诸法之导师　　自在亦如是
  佛身普示现　　在十方世界
  其像无限量　　亦不分别体
  一切人各念　　今现在我前
  悉睹佛面像　　闻所讲说法

复次佛子。如大医王。皆知诸药。分别好丑所入分部。晓练群籍经典术咒。其阎浮提一切众药。人不识知。谓不中用。医药本德及医咒力。表示群黎。适见此医。病皆除愈悉得安隐。又是其医。非力所造。现在得立。心自念言。此诸民人。将失救护。若没之后。得无孤茕。鄙宁可设权善方便。而为示现。采集众药。以自涂体。承己术力。已合诸药。示如寿终。其身不坏。亦不枯朽。亦不毁碎。往来周旋。坐起经行。皆为变现。医药所当。而疗除众生之病。闻见其音。亦得安隐。终始无异。如来亦然。则为无上医王。晓了疗治一切众生尘劳之病。亿百千垓诸劫之数。造设医药。普归一切智度无极。方便善学道术法药。皆是往古为菩萨时。所建奉行。智慧善权术咒食药。威势之力。住当来际如是无限。处于众生。为兴救护。疗治群萌诸疹疾也。斯则无身。无有事业。其身清净。一切众生。适睹见之。爱欲劳病悉为除愈。虽不信者续而得安。一切佛事未曾断绝。是为第八所入之门。于是颂曰

  犹如假有医　　皆学诸方术
  其见此师者　　众病悉消除
  如人病困厄　　赍药欲往疗
  则已涂己体　　现一切威仪
  人中尊如是　　医王无限量
  显扬于圣智　　善学慧医术
  往本宿所行　　故现尊圣身
  众人得睹见　　除欲病无余

复次佛子。如巨海中。有大宝珠琉璃之藏。名曰等演诸光。其有见此大宝珠曜。若遭斯珠。形像颜貌。皆变如琉璃藏。设人睹见大宝珠色。眼即清净。普获安隐。乃至大珠光明威神。宫殿咸照。群萌蒙光。而永无患。如大宝珠。名曰安众。所处年岁。若放雨时。众生即悉而得安隐。休息诸[病-丙+(止/(止*止))]。如来影曜亦复如是。为大珍宝一切福会无极慧藏。假使众生。遭遇如来圣慧光明。皆获一类。升于正真道宝形像。若觐如来。则逮五眼。值大圣光。一切贫匮。则获法珍。便得丰饶无极之财。乃至道安如来之安。佛子且观正觉威容。无所演说。而普化益。开导群黎。是为第九所入之门。于是颂曰

  譬如无琦珍　　诣海深求宝
  致一切明珠　　其光照周普
  若人遭斯珠　　便得致自然
  其有目睹者　　寻获清净眼
  胜宝亦如是　　演出慧光明
  若人遭此晖　　则致佛容貌
  若观察最胜　　即获成五眼
  蠲去诸尘冥　　便住佛道地

复次佛子。有大宝珠。名一切净念藏王。其大宝珠。功德威神。非十非千。而合集致。又彼大珠。所可着处。斯处众生。普无诸病。亦无众患。设令群黎。从摩尼宝。所念誓愿。悉令具足。如意皆获。又彼宝珠。则不照及。无德本者。一切净念藏王珠者。则谓如来。悦可一切众生品类。至真正觉。所示现身。三昧定者。嗟叹称誉。诸声闻众。一切众生。在彼生死。于五苦中。得越殊特。而度终始。又彼佛子。如来之身。无前无后。一切世界。受形众生。宿有福者。悉为一心。而无乱志。遵修正念。纯淑诸行。精进至向。于如来尊。悉获法愿。而皆具足。其罪重者。无有德本。不能睹见如来光明。则建立之。使蒙劝化。示其德本。是为第十所入之门。为菩萨行。至真正觉。入近如来。而至无量心之所念。其罔普周一切十方。行无挂碍。又法界者。观于诸界。不住本际。又如来者。无起无灭。咸等三世。于一切想而无所想。导利群萌。当来心际。入于此道。令无有余。周满一切诸佛世界。具足法身一切如来。悉为一净。于是颂曰

  譬若如意珠　　能与一切愿
  设有所求者　　则获如所志
  其无功德者　　斯等不见宝
  又其尊妙珠　　永无吝惜想
  安住身如此　　惠施一切愿
  若睹有所游　　如志悉逮成
  其怀凶危心　　此人不见佛
  如来无吝想　　亦无有贪嫉

佛告普贤菩萨。何谓佛子。菩萨顺从如来之音。而等游达宣正觉声。不可限量众响言辞。则从众生心意所好。而为说法。至令众会各得所乐。如其志操而现化之。从心所念随时而入。不失三昧。不终不没。不起不灭。又而察之犹若呼响。悉无有主。亦无有我。众生罪福。所积行故。违失深妙。便有归趣。遐邈难济。兴不洁净。分别法界。故随无断。不舍坏法故。无嗔无恚。无没究竟。所缘住故。亦无有主。亦无不主。亦无教化。亦无不教。斯则为随如来音响。所以者何。譬如世遭大灾变时。即有自然四大音声。乃得知法而无有主。则无贪业。何谓为四。世灾变起。有一大音。自然而出。诸贤且听。一禅为安。第一禅者。离爱恚患。度于欲界。已得超越而致自然。于是众生。闻斯音声。成第一禅。度于欲界。即生梵天。适逮法已。闻于二音。诸贤且听。二禅安隐。则无想行。超度梵天而得自在。于时众生。闻斯二声。则行二禅无想无行。其内为寂。心无所著。成第二禅。即得生于光音天上。适逮法已。闻于三音。诸贤且听。三禅最安。离喜所欲。于心寂定。内无所念。第三禅者。随圣所教。度光音天。于时众生。闻斯三声。超光音天。生离果天。这生天上。这逮法已。闻于四音。诸贤且听。四禅寂然。除苦去安。忧戚喜欢。无苦无乐。清净具足。为第四禅。度离果天。于时众生。闻斯四声。舍离果天。超生清净难及天上。是为佛子。世灾变时。闻四大音。而致弘典自然之声则无部主。大圣之德巍巍无量。自然音声微妙柔软。播越远震。如是无主。亦无所造。无应不应。无举无下。若有欲逮如来法者。则有自然四大音声四大言教。何等四。一声出曰不造德者。皆为苦患。地狱饿鬼畜生三趣。计吾我人。言是我所。贪着所有一切万物。亦复为苦。设殖德本。生天人间。受贤圣教。弃八无闲。所生艰难。奉行十善。诸厄乃除。常值佛法。二声出曰诸贤且听。万物皆苦。烧炙然炽。转相逼迫。思想众患。身则无常别离之法。无形寂灭。不志利养。便无然炽。寻离众难。于时众人。闻此声已。奉持宣行。稍渐精进。得声闻乘。以忍度岸。三声出曰过于罗汉。则有微妙所乐之乘。名曰缘觉。无有师主。而自觉了。于是诸人。闻斯音已。信乐微进逮。缘觉乘。四声出曰。过于声闻缘觉之地。而有大乘菩萨所行。所苞含桴筏回御洪舟。济于彼岸。不断道心。所度无极。将护终始众生患厌。而现有声闻缘觉。其大乘者。为最尊乘为极殊特乘。一切众生。所戴仰乘。信乐超绝。正真乘者。闻此声已。斯等诸根。明达往古宿殖德本。如来至真威神圣旨之所建立。令其志性。含弘光大。自在至诚则发道意。其音说曰。诸如来者。无身无心。亦无所演。无所开化。而令众生。如得蒙安。是为佛子。第一缘事。为诸菩萨。而得顺从如来之音。于是颂曰

  如四无量音　　普宣于世间
  众生界清净　　本出虚无际
  则有四智慧　　寂然安隐禅
  众人闻斯响　　便弃捐欲界
  十力亦如是　　普周于法界
  为众生之故　　畅演无量音
  其有致斯印　　则超有为相
  安住之音响　　未曾有疑想

复次佛子。譬如深山岩石之间。因对有声。世假如是。记是方俗。言而无有。身亦无有。见则因呼。对而有声矣。一切音声。言语所由。皆缘对耳。诚谛计之。永无想念。如是仁者。如来音声。无有言教。亦无所处。众生之类。心怀念道。因缘出意。究理音声。亦无有响。亦不可得。是为佛子。第二缘事。为诸菩萨。而得顺从如来之音。于是颂曰

  犹如深山中　　因缘而有响
  从众人所呼　　寻报一切音
  佛劝化群萌　　以音令开达
  虽有言辞说　　未曾有疑想
  十力之音响　　法界无著念
  分别开导人　　制化诸根原
  诸微细众生　　令其可意悦
  有诸十力者　　不怀忘想求

复次佛子。如大雷震出音声时。名曰诸天诚谛之法。假使诸天。游行放逸。应时虚空。畅法雷震。一切爱欲。皆归无常。苦恼诳惑。须臾间耳。愚騃所习。觉无放逸。勿务驰骋。若自放恣。当归恶趣。无得迷谬。放逸诸天。闻斯言教。寻则愁戚。各各弃舍爱欲之乐。诣天王宫。乐于天王无尽之典。遵奉法行。且观其法雷震之音。而可自然。亦无别异。为诸天人众。而兴因缘。欲建立众生之故。而有此音。如来音声。亦复如此。则不可得。随人所行。而加演畅大法之音。亦无贪爱无业之音。无放逸音。无常苦空非身之音。皆告法界。悉逮无余。普周众生。随其所乐。而劝化之。便得悦可。导以三乘。各令得所。已无有量自在之慧。菩萨所行。令咸游入不可思议。又如来者。慧无财业。亦无处所。而以诱引。宣告一切。闻此声已。不可计会。众生品类。精进奉行。于是德本。或求声闻缘觉之乘。或志无上无极大乘。又佛道音。普于一切。无所猗着。亦无言说。是为第三为诸菩萨而得顺从如来之音。于是颂曰

  假使天放逸　　自然有雷震
  发明于诸法　　令乐于道义
  则于虚空中　　宣扬说法音
  诸天闻此声　　便改不驰骋
  十力亦如是　　雷震演法雨
  流溢于十方　　导利诸众生
  具足胜言说　　以开化他人
  闻此音响已　　黎庶成佛道

复次佛子。喻有天子。名曰自在。又名善门。所向瞻望。则诸玉女。有百千品。而来集会。鼓作琴瑟。歌颂应弦。节奏若干。且观伎乐。调发妙曲。如来若此。则以一音。随群生心。依本志性情所慕乐。无量之行因其所信。各各现教。令得开解。是为第四为诸菩萨。而得顺从如来之音。于是颂曰

  犹如魔自恣　　兴造天伎乐
  玉女之姿颜　　节奏互相和
  一心而歌颂　　齐音发妙曲
  具足亿百千　　种种之新声
  诸十力若兹　　常演一声诏
  则以权方便　　音气畅群萌
  黎庶随信乐　　若得闻言教
  这听尘劳断　　其音无想念

复次佛子。犹如大梵处于天宫。发意之顷。敕诫之音。扬溢于外。众会之表。令诸梵天梵身天子。敬奉音诏。如是仁者。如来正觉演出无上微妙佛音。普告一切众会。仪默于内。声达十方。开度群萌。使至道场。如来等哀。无吝众生。众生诸根。不纯不寂。见闻法化而不爱者。一切悉得。普集道场。各心念言。今者如来。而独为我。演法音声。又如来音声。亦无所御。而造成立所当教化。是为第五为诸菩萨而得顺从如来之音。于是颂曰

  假使逮尊处　　梵天之床座
  则以一言诏　　悦可梵天心
  其梵天之响　　不超逸于外
  悉知一切心　　及来众会意
  谓十力之德　　净处于佛坐
  则畅一音响　　普遍于法界
  不佹戾众会　　亦不怀贪吝
  其不笃信者　　不闻佛音响

复次佛子。犹计如水一切同等。以为一味。若随器中。为若干变。又分别知。诸味各异。法教若斯。如来道教。为一味者。谓解脱味。众生之心。志性各异。谓为正觉。所说不同。如来音声。无有想念。是为第六为诸菩萨而得顺从如来之音。于是颂曰

  犹如计诸水　　一切雨自然
  味等均清净　　无秽八种甘
  诸佛子如是　　晓了众生音
  若志念一味　　得佛自然道
  遭遇因缘故　　随地各差别
  其器各各异　　令水永不同
  一切诸群类　　众生行各异
  随心闻佛音　　所听故不同

复次佛子。如阿耨达大龙王者。若欲雨时。阴云普遍于阎浮提。然后降雨。长育百谷众药树木。竹芦丛林。皆得茂盛。华实充满。诸河源流。悉从无焚龙王身出。令无数物难计众类。致得滋益。如是仁者。如来普于一切世界。周遍无余。大哀优渥。而澍甘露大法之雨。悦可众生。长茂功德。具足备悉十方诸乘。如来之音不从内出。亦不从外。如是无量不可计人。群萌品类。而荷戴仰。是为第七为诸菩萨而得顺从如来之音。于是颂曰

  如众水流行　　周于阎浮提
  无所不通彻　　普润于大地
  山陵草众木　　五谷依因生
  有察其水者　　所至无想念
  世尊亦如是　　宣扬诸法界
  布演正法雨　　众满于众生
  长育百千善　　灭除诸尘劳
  已晓了佛言　　于外不驰骋

复次佛子。如摩奈斯大龙王。假使兴大阴雨时。先贮集云。遍诸天宫。靡不周接。或不演降雨之一渧。观察众人农业普备。然后乃雨。所以者何。不欲烦恼众生之故。心念大龙。设而七日。徐详而下。则放微渧咸周土田。多所滋茂。如是仁者。如来至真。为大法王。兴法重阴。开化众生。若有所道。雨甘露味。为纯淑类。然后乃演无极道化。雨于法泽畅深奥典。不令众生怀恐惧心。宣于无上诸通慧味。多所充满。使得成就。是为第八为诸菩萨而得顺从如来之音。于是颂曰

  犹如有贤龙　　名曰摩那斯
  则雨周七日　　徐泽无所伤
  斯龙所以来　　欲成众生业
  然后设愍伤　　安隐降澍雨
  十力因黎庶　　云集布法阴
  欲化众生故　　显示第一义
  从其人之器　　宣奥之法音
  闻诏不恐懅　　则入于佛慧

复次佛子。譬巨海中。有大龙王。名大严净。一念之顷。便能演出十品之雨。不可计限百千之类。莫不沾洽。雨无想念。又其龙王。无异想念雨之自然。百千众品。而令差别。如是仁者。如来至真。假使欲演法音雨时。发念之顷。分别十法了其所归。宣法光曜。出百种音。或复显畅八万四千众生之行。现八万四千所入之响。至于无量亿百千垓言声之说。悦于无限众生之心。道教法音。亦无想念。而则裂解一切根原。如来之法。若慈无极若干种变。善妙清净。巍巍如是也。是为第九为诸菩萨而得顺从如来之音。于是颂曰

  犹如大严净　　龙王之嫡子
  而先设云集　　然后乃降雨
  佛道则自然　　而主有所度
  口出十种音　　二十或至百
  或复至百千　　法泽无限量
  所尊无所畅　　不毁坏法界
  自恣之龙王　　一切龙中尊
  荫雨且普达　　周遍四方域
  润一切有形　　堕雨若干品
  其海所有水　　无有若干种
  世尊亦如是　　道教等一品
  行者心各异　　所获故不同

复次佛子。海大龙王。欲兴无极感动变时。必安众生。令怀欣踊。雨四天下。周遍大地。上达自在清明天宫。云布覆荫若干品类。又众云同。现如是像。种种别异。或紫金色。或复黄色。或琉璃色。或白银色。或水精色。或赤珠色。或马瑙光。或车磲光。或首陀光。如是杂逮。大阴所覆。普遍四嵎及四天下。又其水者。无有别异。而云雾布若干种像。变出电已。畅大雷音。从其群萌所欲乐雨。或出玉女倡乐之音。或天琴瑟众伎箫和。或以若干龙妃乐音。或揵沓和妃乐音。或阿须伦偶乐音。或以土地所出音。或以海中雷震伎乐音。或以鹿王鸣呦音。或以无坏鸟乐音。或若干种万舞之伎。其巨云阴之所覆盖。如是色像。时节大悦。自然龙风。普有所吹。假其风出。云雾安详。先放微渧。后散大雨。上达自在清明之天。下遍地上。虚空天宫。靡所不接。雨于大海。莫所破坏。又至自在诸天游居。玉女伎。名欢乐。雨诸舞乐。至其不乐慢天。雨诸如意珠。于兜术天。雨珠璎饰于盐天上。雨若干种华。忉利天上。雨软名香。四天王上。雨好衣服。于郁单曰。雨微妙华。于大龙王宫。雨超等光赤明真珠。为阿须伦。雨于兵仗。名坏怨敌。如是比像。周于四方四天下域。诸天宫殿。所雨弥漫。不可计会。海大龙王。无所吝惜。亦无悭嫉。又诸众生。所殖德本。各各别异。而不一等。自然变为差特之雨。如是佛子。如来至真。以无上慧。为大法王。常显法乐。而以自娱。寂然无以普布法界。法身阴云。靡不周遍。因其众生所信乐者。而示现之。或为众生。颁宣畅示最正觉身。而兴法雨。现变化身。放法云雨。现建立身。而降法雨。现色像身。若干品雨。现功德身。而演云雨。或复示现慧身云雨。或复随俗。示现其身。有十种力。或复现身。四无所畏。自然为显无所损乏。或现法界而无身形。是为大圣法身阴雨。普遍世界。随其音声之所信乐。而为众生演其耀光。除诸垢浊。斯光名曰平等晖曜。或复名曰无量光明。或名普世。或名佛所建立秘奥之藏。或复名曰光照于世。或复名曰无尽之行入总持门。或复名曰其意不乱。或复名曰其心无侣。或复名曰游步所入。或复光明。名曰悦可众愿。如是比像。法雨所闻。雷震之响。至于正觉。晓了佛道。若净逮闻平等雷震。寻则畅达离垢之印。三昧雷震自然之声。一切诸法自在三昧。金刚场三昧。须弥幢幡三昧。日定光三昧。巨海印三昧。可众庶心三昧。无尽响解脱无嗔三昧。无所志乐三昧。常愍无失三昧。假使扬声。各令闻此佛法之音。是如来身。而演甘露。出于无数法音云雨。所闻讲法。游无等侣。悦可众生。是为正觉一切智门不可思议。悦群萌心。悉得其时。名曰晓了弘慧道场成就往古无垢方便。大慈大悲。究竟无逸。兴隆道化。斯则所遵一切菩萨。定厥身心。然后乃演大法之雨。是为佛子。若兹色像显大法雨愍哀之雨不可议雨。平等之觉。导诸群生。开化身心。如来至真。畅不可畅。无极甘露。若诣佛树道场之时。为诸菩萨。宣大法雨。名法界无所破坏。最究兴成阿维颜地。又名如来秘藏菩萨所乐大法之雨。成诸菩萨一生补处。有大法雨名严净饰普令群生。无所违失。不废菩萨。如来之地有大法雨。名曰庄校道自严饰。合逮法忍诸菩萨等。合集宝慧。有菩萨行。名善化。无所断截。而阐法雨。行成菩萨。名无慢门。入深奥门。行不懈厌。又有法雨。令初发菩萨意者。遵无上道。名如来行。大慈大哀。将济群生。兴发法雨。化缘觉乘。信乐中行。为众现说十二因缘之所。或超有解脱果。名入普至际诸见事。而演法雨。开声闻乘。众生信乐。以圣达刀。截割一切尘劳之垢。有智慧剑。而布法雨。名欣灭诸害。为众邪见不可了者。积累德本。而雨诸法。闻音斯名十法畅显法雨。悉得充满。周于一切。随其信乐。应得解脱。如来则为演大法雨。普遍法界。靡所不达。大圣未曾吝惜于法。从其众生纯熟之行。而因根源精进若干。现于法雨。是为佛子诸菩萨行第十之事

  犹如云雾集　　四方而风起
  超过以时雨　　及水之所流
  菩萨分别说　　黎庶之德本
  故今现在世　　立此三千界
  诸十力如是　　善修慧为风
  因缘澍法雨　　志性甚清净
  察众生无等　　劝助以清净
  所谓诸十力　　导师因开化
  上于虚空中　　云集而降雨
  无有而堪任　　执持所雨水
  唯世遭灾变　　乃能堪受耳
  言辞谛无著　　身界为广普
  诸十力如是　　自然无所有
  大圣有所说　　法界之言辞
  而雨法教化　　所润不可限
  无能堪任持　　唯有法净志
  未曾有斯念　　去来之所由
  亦复无所造　　永无所遭遇
  犹如虚空中　　云雾而致雨
  但假名法耳　　自然而无化
  诸十力如是　　法雨无所有
  亦无有来者　　未曾见往者
  尽菩萨威神　　而兴造斯行
  觉了法幻变　　获世而放雨
  众生无所行　　则无有三界
  犹如自然荫　　而降随水渧
  唯有尊自在　　三千之教名
  造立得自由　　斯本福果报
  安行雨若斯　　遍佛土无余
  思念及限量　　无能计数者
  其于众生上　　一切世间尊
  斯而思惟雨　　道宝为手掌
  寂灭应澹泊　　自然得解达
  又断除余事　　所起诸阴盖
  弃捐斯众瑕　　长益道宝行
  品任三千界　　悉晓了一切
  十力之所由　　灭尽尘劳欲
  思惟念自然　　垓德不可量
  又复断绝去　　一切诸邪见
  分别志性行　　最胜宝为富
  一味而真谛　　犹空中放雨
  所雨无有际　　散渧各有处
  又计其水者　　无应不应想
  众人怀欢喜　　犹因生诸法
  又复其法者　　不起一不多
  其无本味等　　无应不应想
  至于无边际　　成佛及圣众
  斯等为受持　　如是之像法

佛言。以十名德。于如来之音。入无限量。何谓十。游入虚空。则无限量。普至诸法一切境界。而无限量。游入无余。分别晓了众生之界。而无限量。游入一切悦黎庶心。罪福所趣而无限量。游入因缘报应萌类。去尘劳结。慧无限量。游入究竟寂然澹泊无生之音。而无限量。随众所乐。而开化之。入于脱心。而无限量。顺解脱味。游入三界。无有边际。而无限量。处于无底。得无境界。游入慧行。而无限量。选诸法要。诸佛境界。不复回还而无限量。入于如来。顺法不奏。而无限量。如是。贤目菩萨。为不可计。群生言响。畅如来音。于是颂曰

  以十德之事　　入佛无量慧
  至一切诸法　　境界无齐限
  大道亦如是　　巍巍无能思
  而多所愍伤　　一切悉蒙度
  分别生死际　　萌类不可极
  化除众罪福　　悦心令开解
  使不求报应　　道慧无崖底
  了佛之音声　　忽入于寂然

佛说如来兴显经卷第二佛说如来兴显经卷第三

        西晋月氏三藏竺法护译

佛言。何谓佛子。而诸菩萨。游入如来至真等正觉心所念行。如来不为心有所念。不分别名。不晓了识。如来无心。乃能入游无量之念。如倚虚空。造立一切。因其由趣。有所成就。又如虚空悉无所著。如是仁者。若欲求道。恃怙慧者。一切世俗及度世事。因佛圣慧而逮兴显。又如来慧而无所著。是为第一因缘之门。菩萨游入如来行念。于是颂曰

  犹如虚空中　　而受一切形
  而着依怙之　　亦无空想念
  如来之妙慧　　如是无所著
  咸救于一切　　不想吾我人

复次佛子。犹如法界不离一切诸声闻度及诸缘觉。一切菩萨。所习游至。又其法界。不增不减。大道如斯。如来慧。合集世间。度世之慧。分别了念。所造巧便。慧不增减。是为第二。于是颂曰

  譬如声闻地　　及与缘觉乘
  菩萨之大士　　悉从虚空生
  大圣亦如是　　解空无极慧
  心等无增减　　救济无适莫

复次佛子。犹如大海与四大域八十亿土。而相连接。地形所尽。至其境界。而普悉可获得水矣。自然踊出。其大海者。亦无所念。如来之慧。亦复若斯。普至一切众生心意。靡不达遍。从诸黎庶意之所念。所在逮致清净法门。则以顺之。令世人获自然之慧。又如来世尊。所可演慧。悉为平等。从其志性。以奇特事而疗治之。道德超世。是为第三。于是颂曰

  譬如四大海　　与八十亿域
  而悉相连接　　地形所尽到
  水靡所不至　　而自然涌出
  海亦无想念　　如来慧如此
  至诸众生心　　慧莫不通达
  从群黎所好　　则为开导之
  致于清净明　　令获自然明
  所演悉平等　　如来无想念

复次佛子。犹如巨海。自有四大如意宝珠。演集积累无量之德。所以致此如意珠者。不以龙神有德故有此大珠生。诸琦珍悉大海恩也。生一切宝。黎庶戴仰。莫不济之。何谓为四。一名曰等集众宝。二曰无尽音。三曰归趣。四曰等集众辞。又计于此大如意珠。则非凡类。阿须伦。迦留罗。真陀罗。摩休勒。诸龙鬼神及余水居。含血之类。能致光耀。所以者何。宝固在于海王龙王藏。又其大海诸摩尼珠。而有四角。在于四方海龙王宫。各自别立。如来至真等正觉。亦复如是。道德晖赫。有四大宝无极之慧。则以于此四大慧宝。劝化开导一切众生诸学不学。及至缘觉菩萨慧宝。缘此致之。靡不济度。何谓为四。兴隆法乐。至无所猗。善权之慧。有数无数。有为无为。法宝藏慧。于诸法界。而无所坏。随时演慧。以得超度。于时不时扰动之慧。是为四。则复以此四大之慧。求如来藏。入道府库。不与众生。而同尘垢。在于世间。逮开士慧。令诸菩萨。游诣四方。所可玩习。无上正真而令坚住立不退转。是为第四。于是颂曰

  四珍之尊义　　逮致安妙藏
  所以巨海中　　自然生诸宝
  其如意明珠　　不离清净妙
  分别在四面　　所处有光明
  如来四品慧　　无量不可限
  安住圣巍巍　　开道于五趣
  斯无极至慧　　无有异想念
  唯察诸十方　　所说无不达

复次佛子。有彼巨海。而复现于四大之宝如意之珠。威神巍巍。光明无极。斯如意宝。功德之耀。消于大海所积聚水。而令厥水不复游逸。斯以大海不增不减。以是之故。如意大珠。至使大海常自停贮。何谓四。日之耀藏大如意宝。师子之步大如意宝。照耀光明大如意宝。无余究竟大如意宝。是四大宝。假使大海。若无有此如意珠者。水当流溢。四大域界。荡合漭漾。至围神山大围神山。悉当没溺。其日耀藏如意宝珠。则以二事。变大海水。其光照之。消伏其水而令色变化成像乳。师子之步如意宝光。照变乳色。成如苏揣照耀光明。如意宝珠。晖[火*僉]照之。除去苏像。犹劫烧时。火[火*僉]盛赫。皆焚天地。大如意光。照于巨海。令其无余。忽然灭尽。不知所归。如是仁者。如来正觉。为众生故。则以四慧。照耀一切。因斯明照。于诸菩萨。至令逮成如来三昧。何谓为四。除灭众罪。则以法河。究尽恩爱。令成道化。皆以智明。照于世间。如来之慧。无冥无明。为平等圣。是为如来四大之慧。为诸菩萨。忍众恐惧。殖不可议功德之本至于一品诸天人民及阿须伦浊俗之众。不堪诸患无量苦痛。若值如来寂寞之地。慧明所照。降伏诸着。立于三昧。能闻法颂。消生死海。遭遇如来。所开化慧。笃乐三昧。因得兴于大圣神通。微妙行音。大慧照世。消化众秽。致神足行。能自成立。为世大明。开道盲蔽。无冥无明。以能蒙此如来慧圣则能降伏世之邪智。大人之地。无三昧定。灭除一切财业贿赂。身无所有。而逮得此大道之慧。若无于斯如来四慧道德光明。假使欲令诸菩萨众。逮得如来至真正觉三昧正定。未之有也。亦不能除生老病死四。无所畏。无本际行。是为五事。于是颂曰

  海水无限际　　而有四品宝
  大力无极威　　次有微妙尊
  四方域众流　　自然有万川
  常入于大海　　大海无增减
  慧处在法座　　决断诸所著
  以法广布施　　欢喜无所说
  安住有四慧　　咸为诸开士
  最胜及菩萨　　未曾有众患

复次佛子。犹如假喻。其下方水。及至上界想无想天。一切三千大千世界。悉处虚空。如是计之。一切三界群生有形。不离虚空。而想吾我。虚无所计。则无所猗。空无所著。亦不迫迮。生死亦然。察于十方所周虚空。含受一切诸佛世界。亦无所受。如是仁者。诸声闻乘。缘觉之慧。有为行慧。无为行慧。皆以依猗如来之慧。如来智慧之所开化。大道通达。普入一切。无不周接。无所想念。亦无挂碍。辄以圣智。多所济导。是为第六。于是颂曰

  旨极从下方　　起至于上界
  一切三千国　　欲色及无色
  所住无所住　　诸界无吾我
  亦不计有常　　不念于断绝
  安住慧如是　　一切慧之本
  诸学及不学　　并诸缘觉乘
  众菩萨明达　　而志怀愍哀
  若建立道门　　佛智慧最上

复次佛子。犹如下方。而生大药。达山王顶。号无根原。又大药者。根通地下。过于金刚。六万八百千由旬。住于水界。安隐而立。无能拔者。其原分布。悉遍周匝阎浮提土。万物萌芽。绕集一切树木根株。近茎生茎近枝生枝。近节生节。近叶生叶。近华生华。近实生实。其有天下。树木华果。皆因之生。又大药者。其根转体。体令根转。以用二事。不生万物。近于地狱。依水纯阴故。虽在于彼而不回转。是以于法而不得生。又其余处。大地之场。所布根原药之所生。尽极其地。法应当然也。如来道慧。亦复如是。从本清净。则以大哀。生坚固元。平等觉种。乃为真谛。微妙达要。而不可动。斯谓根也。善权方便。则谓茎也。慧则枝也。法界节也。一心脱门三昧正受无所破坏。叶也。觉意庄严。华也。究畅树形。诸通慧也。解度知见实也。辩才之议。靡不通达。则谓地也。其如来慧。无有根着。用何等故。而无根着。永无所信。是则名曰为究畅矣。则无根着。所可兴发。悉无所行。断菩萨行。则为无本故。谓如来也。演菩萨行。斯则名曰无所依猗。若有菩萨。亲近如来无极慧原。则不违舍一切众生。因其道根。而生大哀。近于茎者。坚精进也。因其茎。次生其枝。度无极也而长成就。近枝生叶。学于禁戒。静寂知时也。近于华者。谓诸相好。若干德本也。节谓随时。次生果者。则谓究畅。不起法忍。至无粗辞。柔仁和雅。又其实者。为诸通慧。则为道果也。以是之故。如来之慧。不由二事而有所生也。何等为二。谓无为及与有为之大旷谷。若堕于溪涧。而游无极无为之事。于诸声闻缘觉之乘。又其志性。不与俱合。亦无所畏。游于三爱三流之原。于如来慧。亦无所生。亦不退还。若有所生。已达圣性。修平等心。于诸菩萨。无有彼此。且观正觉。大道晖赫。巍巍无底。而为真谛。慧不增减。其根坚住。令诸众生。究竟通达。了无笃信。是为佛子第七之事。于是颂曰

  于雪山冈岭　　药名无根着
  其药有大神　　威曜无等伦
  普长育一切　　丛林诸树木
  而根茎叶枝　　枝因诸根无
  一切诸佛种　　自然成道慧
  德旨亦如是　　遵修一切智
  晓了行佛道　　奉宣于圣路
  等习于慈哀　　生长觉明哲

复次佛子。譬劫灾变。大火熙赫。烧三千大千世界。一切树木。药草万物。及至围神大围神山。大金刚山。莫不焚冶。假使有人。取枯茭草肥松重阁。以投盛火。于意云何。宁有一叶得不烧乎。答曰不得不烧。欲令不烧。未之有也。报曰如是。尚可使火不烧树木大积薪草。有欲限节。如来圣慧三达神智。众生之数。国土多少。诸法之底。去来现在无央数劫。令不普见。而有微碍。不悉及者。未之有也。所以者何。正觉道慧。无有限量。不可计会。靡不通彻。故号如来至真等正觉。是为第八。于是颂曰

  若劫之遭患　　天地被陶冶
  一时悉焦然　　男女树木果
  佛子且忆察　　于斯诸游居
  金刚尚消融　　何况枯草木
  山陵诸所有　　岂可脱不烧
  安住之智慧　　皆能分别知
  当来众生类　　若干劫佛土
  诸佛悉明达　　如是无限量

复次佛子。犹如灾变风起之时。而有大风。名曰毁明。则发且兴。毁坏围神。大围神山及金刚山。一切三千大千世界。吹令破散。使无有余。又复有风名因缘盖。吹于三千大千世界。飘举擎接。越置他佛国。假使于彼因缘盖风。独值自恣。无毁明风。便当摧破十方。不可限量诸佛境界。如是仁者。如来则有无极大慧。名曰毁坏一切尘欲。正觉以斯无极大慧。吹除一切诸菩萨众尘劳挂碍。如来次有无量圣达。名曰总摄大权方便。则能消灭爱结之患。至妙道场。因复开化新发菩萨。一切诸根。未纯熟者。设诸如来。不总摄斯大权方便。成大道场。令无央数不可计会诸菩萨众。修于声闻缘觉之乘。世尊。顺从善权方便。令诸菩萨大士之等。超越声闻缘觉之地。由斯自在。而无所住。是为第九。于是颂曰

  劫中若恐懅　　诸天乱不安
  神围须弥山　　咸悉为毁坏
  风即时兴起　　无能制止者
  无量诸佛土　　糜碎无有余
  有诸十方者　　圣慈得自在
  则以毁破碎　　诸菩萨尘劳
  彼复有道风　　遵修于善权
  寻便以救护　　声闻行者安

复次佛子。如来之慧。游入一切圣智巍巍。靡不周遍一切黎庶。终始之界。所以者何。若有欲想。世尊之慧。欲及达者。未之有也。又如来慧。悉离诸相。自在之慧。则游自然无所挂碍。如书一经。其卷大如三千世界。或有大经。而未书成犹如三千世界之海。或如神围山。如大神围。或如普地。举要言之。如千世界。或如四域。天下之界。或如阎土。或如大海。如须弥山。如大神宫。欲行天馆。如色行天。如无色天。假集大经。广长上下。犹如三千大千世界。而有一尘在大经卷。又诸经上。各各有尘。悉各周遍。在大经里。当尔之时。有一丈夫。自然出现。聪明智慧。身试入中。又有天眼。其眼清净。普有所见。则以天眼。而观察之。今斯经卷。如是比像广大无极。其上则有少少尘耳。于诸众生。无所加益。我身宁可以无极力大精进势。裂坏此经。解散大卷。当以饶益一切黎庶。适念此已。则时兴隆无极之力精进之势。辄如所愿。取大经卷。各自散解。以给黎庶。如一经卷。众经之数。亦复如是。若此仁者。如来至真以无量慧。不可计明。悉入一切众生江海心之所行。而普晓了群萌志操。如来之慧。不可限量。靡不周达。不可穷极。正觉之智。不可计会。观察一切萌类境界。怪未曾有。斯众生类。愚騃乃尔。不能分别如来圣慧。世尊普入。而自念曰。吾宁可宣显示大道。使诸想缚。自然蠲除。如佛法身圣涂力势。当令舍离一切着念。设使晓了正真之慧谊所归趣。获致无极三昧之定。畅说正道。去一切想。诲令使念无上道慧。化诸黎庶在五趣者。令达无极。是为佛子第十之事。如来至真。劝诸菩萨。心入道义。如是比像。济无央数诸菩萨等。蒙如来慧开化其心。使入大道也。于是颂曰

  犹如有经卷　　大如三千界
  自然有微尘　　悉散于其上
  有一慧士夫　　明眼坏经卷
  悉分别布散　　施于五趣人
  世尊亦如是　　智慧如大海
  见众生心意　　悉惑诸想念
  佛以愍哀人　　为解除众想
  诸菩萨戴仰　　谛蠲弃着次

复次佛子。何谓菩萨游入如来之境界。于斯菩萨慧入无碍。知一切界。为如来界。一切佛土诸所有境。众生之界。则悉无本。靡所部分。不有所坏。其法界者。无阴盖际。又本际者。无际强畔。犹如虚空。无有边崖。亦无有界。亦不不有。悉以游入如来境界。犹众生种。不可限量。无有边崖。如来之界。亦复若斯。不可限量。无有边际。所以者何。如其众生心之所念不可计会。如来寻则以无量慧。而开化之。如龙王尊。而得自在。摄无量水。因时放雨。不可计渧。不从内出。亦不从外。如来境界。亦复如是。从意所欲。有所兴造。即自然成。彼无所咨。亦无有师。如大海中水不可量。悉从龙王心所念生。亦复如是。一切所有无量圣达。至诸通慧。行如法海。咸斯菩萨往古发心之所造愿。因从厥行。而生差别。问曰。何谓无量。为巨海者。何谓无限。诸通慧海。曰无思议。多所解说。至于大海。今粗举要。分别说之。谛听谛听。善思念之。阎浮提有五百江河。而入大海。拘耶尼域。亦五百江入大海中。弗于逮域。四千江河。而入大海。郁单曰域。具足万江。流入大海。于意云何。此水合会。流入大海。宁增多不。答曰甚多。报曰。十光龙王。所雨之水。则多于彼诸江之流。又四大域所有诸水。十光龙王所雨之水。入大海者。其水不如百光龙王之所雨水。堕于海者。为最多矣。又四大域水。十光龙王。百光龙王。所雨大水。入巨海者。不如大游龙王。身中所出。入于大海。其水倍多。举要言之。如摩奈斯龙王。雷吼所雨。则复加倍。难头和难。所出之雨。无量之光。妙群龙王。大[火*僉]龙王。大频申龙王。雨亦如兹。斯十大龙王。立亿龙王。各各降雨。不可称限。其四大域。巨海之水。及十龙所雨之水。并八十亿种龙王。悉归巨海。不如阎浮提海。龙王长子。诸大江河。所有众水。及诸洪雨。不如十光大龙王宫所出水。计四大域。一切江河。及前所说。诸龙王雨。十光龙王。百光大龙王。宫所出水。咸悉不如大严净龙王宫所出水。举要言之。摩奈斯。雷震难头。和难。无量光明。及大妙若群。大明[火*僉]龙。皆悉不如斯十龙王。及八十亿龙王宫所出水则悉不如海龙王长子宫所出水。如是。诸龙王等水归大海。咸为不如海大龙王。雨无所坏。水为最多。其阎浮提水。及拘耶尼。弗于逮。郁单曰。十光龙王。宫殿所雨。百光龙王。大琉璃龙王。宫殿所雨。摩奈斯龙王。雷震。难头。和难。无量光明。妙君龙王。大明[火*僉]龙王。及大频申龙王。宫殿所出雨者。及八十亿。种姓龙王所出。诸是有水。及四大域海之龙王长子所雨有海龙王。无所坏雨。众大雨水。咸悉不如海大龙王。清琉璃中所出诸水。而悉周遍。充于大海。大海之水。如是无限。又如海水。无有量者。其宝品界。亦复无量。众生之界。亦复无限。观于大身。亦不可计。大海水。不可限量。诸宝品种。亦复无限。于佛子意所趣云何。其大海水。宁无限乎。报曰无限。如大海德。无能计量。如来若斯。慧无限量。百倍千万亿倍。巨亿万倍。无以为喻。不依言辞。随人所解。而以牵引大海譬喻。佛之大道。圣过于兹。因假三昧。其明无边。则如来慧。所达巍巍。犹如大海。其意无限。从初发意。乃至菩萨一切智行。而不断绝。道宝无量。一切道品。三宝之法。不可尽极。劝化众生。当造斯观。诸学不学。其缘觉乘。悉见济度。以无极谛。志无所在。悉睹无量。住于第一欣然之地。始从菩萨。便能至于无挂碍地。化诸菩萨。令不废退。是为佛子诸菩萨众则能游于诸佛境界。亦能普周一切所有。亦无限量。于是颂曰

  积清净诸品　　无数不可量
  众念之境界　　一切无边际
  如意之齐限　　其心无所周
  一切诸十力　　当求斯境界
  犹如龙所处　　未曾有舍离
  应其心所念　　而放于雨渧
  设使心有来　　乃可得还反
  其龙不有念　　吾当有所雨
  诸十力如是　　未曾有来至
  亦无有还反　　能仁不可得
  永无所兴造　　况遣心有念
  法界无限量　　犹如江河沙
  其海无边际　　水及宝亦然
  诸含血所居　　一切无限量
  其水悉一味　　生者咸仰之
  若处于此中　　不饮余水业
  大圣亦如是　　妙慧无崖底
  三宝无限碍　　道要不可计
  诸学及不学　　人民无央数
  不可计群萌　　志愿佛道慧

何谓佛子。菩萨游入如来圣慧无挂碍行。威仪礼节。犹若如来。往本无生。于当来世。亦无所造。随时缘故。而忽成矣。斯如来行。不起无灭。不有不无。亦不游入。有为无为。譬如法界。无有限量。亦无不限。所以者何。无有自然。亦无有身。故曰法界。大圣若斯斯名如来。行无限量。亦不无限。游入无身。亦无自然。犹如飞鸟行虚空中。于百千岁。而飞行者。如有所度。亦无所度。观前察后。其虚空者。无有边际。如来之行。亦复如是。于亿百千劫。所讲无极。若叹有极。设无所说。其如来行。故无边际。如来已住无挂碍行。亦无所住。而为众生。畅现如是如是比行。佥度一切挂碍之迹。如金翅鸟王游在虚空。以清净眼。观龙宫殿。变易本形。知应终者。骞翥奋翩。搏扬海水。波荡披竭。攫食诸龙及龙妻妾。如来若斯。慧无挂碍。住无底行。咸于法界。普观众生诸根纯淑因随宿本。殖众德原。寻以无极如来十力。而示形像。入终始海。披生死渊。开导众庶。能为应器。挑出群黎。于终始海。则建立志。于佛道法。而悉断除一切言行。获致如来无所想念。以无想念。慧无挂碍。则为住立。住无所住也。如日月光照于天下。独己游步。而无有侣。则无所立。行虚空路。人民瞻望。日月不念。吾有所奏。若复回还。世尊如是。游于泥洹。入清净法。亦无想念。于诸法界。示现超度一切诸行。五趣群萌。亦无懈息。无所专信。而则畅达。宣布佛事。亦无往反。是为佛子。诸菩萨等游入如来之慧行也。则无限量。亦无不限。代诸缘事也。于是颂曰

  无本不可尽　　未曾有起灭
  有计无本者　　无处不可见
  诸愍哀如斯　　其行无有量
  无本者自然　　则无有二事
  犹如此诸种　　法界无处所
  亦复无限量　　亦无不限量
  道行亦如斯　　圣达无崖底
  所分别无极　　斯则无有身
  如有鸟游步　　亿劫在虚空
  前后亦如是　　虚无界适等
  最胜百千劫　　讲论所当行
  如方便随成　　不失于善德
  金翅鸟在空　　遥望察水中
  知龙命所终　　举食龙妃后
  十力智自在　　烧尽诸尘劳
  善造众德本　　拔出生死原
  譬若如日月　　游行虚空中
  黎庶蒙安隐　　光亦无想念
  世尊亦如是　　由法众无碍
  开化无数众　　不兴诸想念

何谓佛子。菩萨游入如来开道。于斯菩萨佥度一切。诸所著行。而不犹豫。平等法味。了不二入。如来所阐则复游入于无想觉。无行之觉。无处所觉。无限中觉。无边际觉。弃不成就。猗着中间。则观一切文字音响。而无处所。于诸言声。而无言教。究竟尽极众生之行。奉平等觉。志性诸根。尘劳爱欲。悉为清净。如来道眼。一切普等一切三世。犹如大海。天下人民。悉戴仰之皆苞众生。见诸有身。故曰大海。如来之道。亦复如是。睹群萌心。志性所归。虽有所照。亦无照想。则为自然。是故名曰如来之道。所开导之也。彼便以化所可开导。既讲文字。亦无所说。于一切响。无所宣畅。虽有辞教本无所言。纵有所仰。亦无所仰。又复劝化于群生类。今当演说。举其大较。如来之道。所开化者。成最正觉不限众生。如号如来也。如身住数。众国土数。一切三世之所有数。诸身住数。亦复若兹。而无差别。如道教数。一切言数。如诸如来法界之数。如虚空数。无挂碍界。如诸御行之所开导。言教之界。如泥洹限。众生身形。所处住数亦复如是。口之言限。亦复若兹。如身口数。无挂碍心。所住限数。等无差特。彼以游入。如此无数。则净三场。致于道德。由是之故。等御己身。及诸众生。睹见如是一切寂然。而察等导于泥洹界。已睹若斯之自然者。咸入一切则无自然无尽自然。不起不灭。则亦自然。于我非我。亦复自然。于人不人。亦复自然。佛无所想。亦复自然。法界自然。虚空自然。亦无自然。已晓了此。成最正觉。逮致正法无余之慧。得睹如来无极大哀。多所开化。诸群萌类。犹如虚空。含受世界。一切方俗。志性自然。成于世间。如是比类。无尽无长。亦无所生。所生澹泊。亦复如是。成最正觉。亦无所觉。又其相者。亦无所相。亦复是相。而无若干。譬若士夫。兴化变人。如江河沙等。为诸如来也。令无比类。亦无形容。适化现此。则复宣举江河沙等皆为劫数。于意云何。其人所化。以奚等化。而令发心。成如来乎。白世尊曰。如吾所知。当为显义。化如来数。如无所化。化数亦然。答曰。善哉善哉。诚如所云。如是佛子。一切群萌。斯须之间。皆逮无上正真之道。成最正觉。成菩萨数。亦复若兹。其不成者。亦复若此。无所增损。所以者何。又省于道。则无有相。其无相者。无成正觉。无所长益。虽得正觉。亦无所逮。是诸菩萨。当以若兹入于如来乃成正觉。若欲觉了。当作斯觉。如来一相。而同品类。则无品相。斯则号曰。慧成道觉三昧正受通定意已。一一所觉。法身无余。超于一切众生立身。犹如一人。成最正觉。至道门者。一切众生。若成佛道。至于法门。亦复若兹。等无差别。使无量人。逮成正觉门。游入住于无限诸身如来之界。无有涯底。众生之界。不可计数。是诸菩萨。游入如来成最正觉。一一得致。如众生本。入如来身。所以者何。若得普入如来至真最正觉门。其身所行。亦无所生。亦无所失。如获一事。其余亦然。一切法界。作是游入。不离处所。不舍言辞。信此如来法身者也。所以者何。若能普入。乃成正觉。至无极慧。弘兹寂然。诣佛道树师子之座。复次菩萨。普了己心。能成正觉。则入法身也。所以者何。如来至真。不舍心本。乃致大道。如己心者。其余若斯。则以开导一切诸心。当造斯入。是为佛子。诸菩萨众为诸大圣以此推入。成最正觉。广远周普。普无不入。而不违舍。无所继着。则无休懈。无所笃信。入不思议法品之门。于是颂曰

  已脱二无二　　晓了一切法
  等犹如虚空　　普解诸经典
  等已无吾我　　是为解诸法
  已分别圣觉　　一切无所觉
  犹如四方域　　受诸有形体
  等苞于川流　　是故字曰海
  十力亦如是　　众生之海印
  晓了其志性　　是故号分别
  心意悉如化　　诸佛如化现
  奉自然平等　　如化之所化
  佛道皆辞说　　一切群萌类
  本自然平等　　不增无所损
  最胜有三昧　　名曰善觉道
  住于佛树间　　得成斯定意
  则演出晖曜　　照无限黎庶
  开道如莲华　　教诲于众生
  若于当来劫　　众生国自然
  思法亦如兹　　诸根及志性
  一切平等观　　无吾我以所
  以故无崖底　　觉了道之覆
  行菩萨之道　　弘慈慧寂然
  处树师子座　　逮成无上觉
  道力无等伦　　法身圣巍巍
  普入无不周　　不舍于众生

何谓佛子。菩萨游入如来音响所导法轮其菩萨者。善立如来弘所思念一切黎庶。悉无本末。无所成就。当入诸法永无所住。断于一场游于真谛。诸所有法。离诸见际。舍欲之际则无有际。便皆游入一切诸法。如虚空际。无所行念则为游入一切诸法。不可逮致。本末永寂。一切诸法。泥洹自然。其诸文字音声之说。悉以自然。斯乃游入。至于法轮。咸悉遍畅如来之音。如呼声响。乃曰自然。则入法轮法门自然。一切诸音。悉为一响。乃入法轮。本末无主。文字无尽。乃入法轮。于内于外。无所积聚。犹如一切文字所演诸所言辞。纵有言辞。不舍真谛。讲说往古。叹叙本末。无央数劫。一切文字。而不可尽。如是仁者。如来至真。所转法轮。一切假号。悉文字矣。畅说无尽则无笃信。悉无所有。亦无所思。而无有响。亦无所施。彼则所可转法轮者。普入一切。亦无所入。如假文字。言曰无矣。若曰镫明。一切所造。皆托言耳。悉入诸数一切世俗。所说度世。游入于斯。永无住者。是如来音。普入一切众生之界。诸法身界报应之事。永无所住。其诸群萌。说若干种言辞之响。悉为宣畅一切如来法轮之音。所以者何。如来至真所转法轮。悉出一切诸所音响。而无进退。是菩萨者。游入如来所转法轮。菩萨大士。当造立斯。入于如来陶演言辞不可限量。何谓如来所入言辞。如来至真。转法轮时。所演音声。畅众生行志操所好。所以者何。佛有三昧。名无挂碍究竟无畏。转于法轮。以此定意正受之时。众生一切。咸随其音。而转法轮一一正觉音从口出。一一言辞。兴显群萌譬喻之响。悉各从志。假使以是三昧正受。悦可众心。是为游入。如来至真所转法轮。以斯柔顺道法所说。亦无所入。如此所游。则乃入斯。闻如来法圣教言辞。是为佛子。诸菩萨众游入如来所转法轮至无限量于是颂曰

  其轮无限量　　成就究竟界
  亦无所长益　　一切无二护
  所说诸文字　　一切不可尽
  十力亦如是　　法轮常无穷
  讲说于律教　　入一切有为
  亦复无所入　　佛轮亦如是
  悉入诸言辞　　自然无所入
  普宣于众生　　一切行无余
  超有为三昧　　究竟诸定意
  欲求妙法故　　是为佛定意
  蒙佛恩所致　　达一切群黎
  最胜所演音　　而畅柔软辞
  以一言声教　　宣布诸众生
  分为若干响　　讲咏无有余
  佛为一切尊　　解了众生心
  如有所说者　　黎庶闻其音
  文字不处内　　亦无由于外
  计斯悉灭尽　　真诚无所有
  若转法轮者　　悉为众生故
  且观诸十力　　变化所感动

如来兴显经卷第三佛说如来兴显经卷第四

        西晋月氏三藏竺法护译

何谓佛子。诸菩萨游入如来至真现大灭度。于斯菩萨。欲入灭度。晓了一切。本净自然。则为佛矣。犹如无本。而归灭度。如来灭度。亦复如是。又如本际。法界若斯。犹如虚空无极之界。又如本净。如真本际。而离欲际。如无相际。无自然际。犹如一切诸法本净。如真本际。取于灭度。如来灭度。亦复如是。所以者何。应与不应。斯诸所有。等无差特。无生不起。设使诸法无生不起。计于彼法。无往不往无离不离。又如来者。不为兴发诸菩萨众。咨嗟叹说。令取灭度永寂无余。所以者何。一切如来。悉立目前。若如现在过去亦然。及复当来。一时悉逮。速疾成慧斯须得道。睹诸如来。皆当宣畅。色像音响。不兴二想。亦不无二。弃诸思想。应菩萨行。捐舍诸猗。如来不念。悦可众心。是为如来之灭度也。愍哀群生众想之患。故兴出矣。亦不灭度。所以者何。如来所住。处在法界。悦可众生。所以现身而有灭度。用之所由。法界无边。如日宫殿出于水中。则便普照一切天下。日之宫殿。无所想念。亦不转移。而咸悉照。靡所不遍。诸水众器。悉睹其影。举器无水。又日殿光。则不复见。于意云何。岂可谓是日之咎也。而令其影。不现器乎。答曰不也。无水器咎。非日之咎。答曰如是。如来慧日。往本所行。至诸法界。皆为众生。常演清净。兴自然事。逮致道念。显曜其心。而常睹见。如来之身。破坏器人。心怀秽浊。不见威光。佛子。应当化度众类渴仰。无如来故。为现灭度也。亦无有生。亦无不生。亦不灭度。于是颂曰

  假如日遍照　　其界及边崖
  难畏所见影　　适见不复见
  人中尊如此　　普现于世间
  众生离笃信　　诲示以无为
  普观诸佛国　　等由若如幻
  狎习众因缘　　而计于吾我
  假使有造行　　究竟佛所作
  或不见大圣　　所睹而不同
  最胜有定意　　名曰解无常
  佛以是造业　　然后现等生
  以分别身形　　为无量无限
  须臾遍十方　　佛犹如莲花

犹如火者。普为世间。成所当熟。或于异时一聚落县。而火忽灭。于意云何。将无一切诸世界火悉灭尽乎。答曰不也。报曰如是。如来皆入一切法界。悉遍无余。兴于佛事。则于异时复他佛土。显发道意。便见灭度。而不灭度。当以如斯入于如来之般泥洹。复次佛子。假喻幻师。善学幻术。晓了方便。悉通神咒。则住精进。皆化三千大千世界。悉变为水。自现其身。在郡国邑。幻术。停住一切。而建立威。欲得诣于他异郡国。县邑州城。便化没已。于意云何。将无幻术皆灭尽乎。答曰不也。报曰如是。如来善觉无量慧幻。示现善权圣术之咒。普入一切。现诸法界。亦无所入。犹如幻化。现如来身。处在法界。究虚空界。则随众生之所信乐。各为化示诸佛之土。而现灭度。不独一国示般泥洹。如来悉于一切法界。靡不开达。是为佛子。为菩萨者。当知游入诸如来至真等正觉。现大灭度

复次佛子。如来至真等正觉。又有三昧名无所著定意正受现大灭度。适以斯定。而正受时。如来仪体。一一毛孔。演出难计亿百千垓光明晖曜。一一光明。变出莲花不可计会。一一莲华。化作英妙无数自然师子床座。有化如来。各坐诸座。如来则随众生畴数。而自化立。形貌具足。真谛之德。严净周备。悉是往古所志之愿。其有黎庶诸根纯熟。则寻了见如来从容。便随律教。建立严净。当来本际。顺从群萌志纯熟者。因律而度。其如来像。亦无有处。亦无不处。亦无所说。亦无不说。亦无有常。亦无不常。又复悉是诸如来等。宿世本愿之所誓行。开示群萌。演达诸根。悉是威神。所化圣至。斯为佛子。诸菩萨众游入如来大般泥洹。所入无限无所挂碍。究竟法界无边中间虚空之界。又如来者。则为自然无起无灭。处真本际。若欲现时。使诸黎庶。悉得休息。普以威神。有所建立。皆示一切众生法界顺化其性。而演法要。虽有缘觉。唯菩萨了。于是颂曰

  佛定王无著　　一切众生尊
  大哀力无极　　周遍于身阴
  处在正真道　　分别演法雨
  光润无想念　　普世各各异
  欲慕如斯慧　　诸十力之心
  观察最胜圣　　以何等为道
  普于诸十方　　黎庶诸有形
  念一切悉空　　无自然无身
  菩萨善权慧　　变师子莲花
  安隐若干处　　众生之法界
  一切安住圣　　自然成智谋
  以此无极慧　　超越诸有身
  已犹等解脱　　法界无人物
  其在于十方　　缘觉所由居
  唯有佛子斯　　达法界无余
  又察诸法界　　不增无所损
  亲近最胜圣　　一切慧自在
  习学若不学　　有为及无为
  诸安住自在　　不损无所增
  不尽无所起　　佛慧不可限
  犹如水流行　　渐渐如次遍
  柔润于土地　　其水无谀谄
  地亦无想念　　令水不周遍
  遵修精进力　　一切广分别
  十力无边际　　解诸众生界
  斯等群萌类　　思惟安住慧
  则随遵修行　　兴立精进事
  知是不复久　　当建功德慧

何谓佛子。菩萨而闻如来所现。当入一切众德之本。菩萨以斯无尽真行。不以虚妄观于如来。又闻所说殖众德本。入于无量贪欲之行。威神究竟。以等御之。生有为中。普具众愿。而不可尽。游入无为。有所兴发。当来之际。而无边限。究竟色欲。逮自在地。如有一人。以小小风。欲坏金刚。其人虽尔。不能谮增。当思其体。不净之器。解散五藏。悉无所有。又其风者。自然之法。有所毁落。如是佛子。从于佛法。随如来教。殖德虽薄。皆以破坏一切有为。所住尘劳。如来慧者。则应无为。悉无所有。除诸挂碍。如来所殖众德之本。而无所灭。犹如有人。积聚薪草。如须弥山。如芥子火。投于薪上。即时悉然。令无所余。所以者何。其火之谊。主有所烧。行者如是。虽于如来种福德少。悉烧尘劳。令无有余。速得亲近归于灭度。所以者何。则永究尽诸所蔽碍。已于如来。种德本故。灭众瑕秽。如有大药。名曰善见。设睹其色。闻声嗅香。服食佩形。眼耳鼻舌身意。自然得净。若终入地。变为医药。则复疗病。如是仁者。如来至真。为大药王。具以圣慧。饶益众生。多所疗治。若觐如来色身。眼即清净。耳闻三昧。则得彻听。若嗅戒香。鼻自然净。服尝法味。充饱众行。其有得闻如来所讲。舌自然净。辩才无量。若有遭遇如来光明。便得法身。其有思念于如来者。其心等净。其有供养如来至真。则成德本。除劳尘病。今属佛子。劝喻显示。其有见闻于如来者。则能净除阴盖罪患。若见闻说。无欢喜信。佛令斯等。殖成德本。不为虚妄。至得灭度。是见如来若闻声者。而得游入众德之本。因得除断诸不善之法。则普证明众道之元。靡所乏短。悉以脱了。引诸譬喻。如来兴显。一切咸备。不可引譬为假喻也。佛之功德。不可思议。起度诸心。欲以开化群萌志性。令得悦豫。以故如来。为诸菩萨。引诸譬喻。欲令解达。斯非正要。如是洪范。则是如来秘奥之藏。斯则名曰一切世间所不及知。乃入如来之妙印也。如来大慧无极圣明之种性也。名曰怀来一切菩萨一切众生所不能及。名曰游入如来境界平等之土。名曰净群黎界悉令无余。名曰普说一切根原诸所挂碍。又复至真不为余人说斯弘典。唯为志求大乘行者无思议乘。讲菩萨道。又斯经典。终不归余趣诸菩萨。犹如佛子。转轮圣王。金轮白象。绀马明珠。玉女藏臣兵臣。自然七宝。有斯化来。不归余人。唯当趣王适太子也。所以者何。因其圣后怀胎而生。则为具足转轮圣王。设使正后生是太子。则为具足。为圣王相。若寿终者。转轮圣王。所有七宝。七日之后。悉没不现。则无有余。如是比像经典之本。终不归趣于他人也。唯当至于正觉长子如来族姓道所生者。殖种如来之德本者。假至法身。遵修正士。则当蒙恩。势不得久。亦当逮成。如是色像。如来秘藏。经典之要。不断三宝。法若没尽。便无见者。所以者何。一切声闻及缘觉乘。不能堪任。逮是经典。亦不闻音。何况受持。讽诵读者。唯归大人诸菩萨乎。书在经卷。靖着屋宇。是故佛子。若有菩萨。得闻斯讲。志性恂恂。敬侍法师。供奉所安。当受斯典。所以者何。设有菩萨。笃信景摸。当成无上正真之道。菩萨大士。无央数亿百千垓劫。奉行积累六度无极。而复怀来道品之法。遵修悲哀。亦不入斯如来无极不可思议。不闻不进。斯非名曰为菩萨也。于菩萨法。为不长益。则不顺从如来胄绪。设有菩萨。讲诸如来无挂碍慧。笃信入道。而不狐疑。斯乃名曰为真菩萨。则不违失诸通慧强。普能究竟一切世法大圣之行。随如来教。于诸佛界。而无所著。皆得建立诸菩萨法。便得通达诸佛正典。而无沉吟。道品境界多所变动。由得自在立成诸法。于众菩萨。威神巍巍。寻入如来。无挂碍界。是以菩萨。若闻斯法。普至安住。道意无限。又其志性。力势至真。皆弃众想。应与不应。入在圣明。一切如来。悉在目前。所可念者。了虚空界。遵奉三昧。开心发寤。其有行入无量法界。为诸菩萨。志所造立。成就众德。而得自在。畅达通慧。除世众垢。发心无余。其国普周一切十方入菩萨道。去来今佛。合为一涂。等趣德本。劝助圣道。导利群生。使兴道心。开化未闻。当入斯法。入无所入。无能得便。皆令诸法归无因缘。常造斯念。顺一切智及一切法。悉为无限。菩萨已能游入若兹。所思念者。则为少事。所入难及。其慧自在。威神巍巍。普贤菩萨。承佛圣旨。说是法时。十方不可称计亿百千垓尘数诸佛国土。六反震动。十八部变而现感应。如来威神。显畅法施。则雨天华。箜篌乐器。不鼓自鸣。散衣服饰。诸盖幢幡。所雨众香。超于天上。诸名芬熏。杂香捣香。天上璎珞。又复雨降大如意珠。又其光明。越天所珍。赞曰善哉。菩萨之道。过于诸天。永永无形。而不可获。又诸菩萨。承己宿德。遍雨瑰琦。不可思议。清净严庄。诸佛国土。成最正觉。而悉云集。雨无量法。讲雅诵音。亦叹如来所讲言诏。犹如菩萨于四大域。初成正觉。建立发起。成就菩萨。而令欣喜。如是一切诸佛世界。悉无有余。周接十方。都不可计八十亿垓百千佛土。满其中尘。各越如是诸佛国数。现在诸佛。见普贤菩萨。闻所言讲。而遥赞曰。善哉善哉。卿族姓子。是为如来所分别说不可思议。所以者何。建立真谛。游入法界。又是十方八十不可称计亿百千垓佛之世界。满其中尘。一切诸佛。自然有音。而说经法。吾等于此。而现告诏。犹如余党。被蒙开化。亦如一切诸佛讲法。等无差特。又若百千国中尘数一切菩萨。皆得神通。入诸三昧。因见十方佛当授决。一切悉获一生补处。归于无上正真之道。千佛国土满中尘数众生之类。志发无上正真道意。皆为圣尊所见授决。尽于将来无数佛土满尘之劫。当得为佛。号曰佛界之乎如来至真等正觉。而常建立于斯法讲。当来菩萨。闻所未闻。宣畅奉行。于此四域一切世界众生悉知。犹若此界群萌被蒙。开化道教。而顺律者。十方佛国亦复如是。亿百千垓。不可限量。不可称计。不可思议。无有边际。道所化度。尽虚空界。诸佛境土。诸所黎庶咸被开化。十方诸佛。威神照明。如来宿本。建立所致。逮得诸法。遵修德本。如来圣慧。无能喻者。佛教随时。导利遍御。诸菩萨众。所获从宜。诸根调定。宿世所行。无所亡失。普贤菩萨。威神恢广。为诸通慧。威圣恺悌。悉见十方不可计量亿百千垓佛土。满尘诸菩萨等品数如是。悉来集会。充于十方诸法境界。示现无极严净菩萨。奋演大光。感动一切诸佛世界。惊骇天宫。降伏魔众。灭除一切众恶诸趣。宣畅如来无量威尊。不可称计诸法之乐。赞如来德。弦出无量。而雨一切。无有崖底。众宝奇特。种种供具。示现无极。各各异身。一切咸为如来法门。己身之器。所受无量。承佛圣旨。悉共同音。演一等声。善哉善哉。卿佛之子。乃能颁宣如来无等伦法。又所玩习。皆顺普贤。达无量称。入音声号。亲从如来。辞来至此。其佛世界。名曰普光。其法亦然。如今于此。等无有异。咸说斯法。承佛圣旨。逮如来典。是为佛子。证明现在。佛所建立。诣此众会。又如于今。至此会者。十方法界。所教无限。亦复如是。咸同虚空。诸佛国土。一一界土。四方之域。显示如来之所建立。佛之国土不可限量。百千佛土满其中尘诸菩萨来。皆是如来威神之德。修无等伦。以此章句。于是严饰。审谛无损。无能过者。于斯普贤菩萨。悉观一切诸菩萨德。察法际已。宣畅大圣之姓族也。理释诸佛无极之道如来之法。而无有侣。即便咨嗟。广达无边。悉宿德本。剖判光动。一切无形。演说佛典。普解众生志性所趣。靡不遍睹。令诸群黎逮得。应时不舍法句。使诸菩萨念不可量。道法光明。综了缕练。世尊无极。建立无慢。现言歌咏。一切如来。悉为一身。合一法体。又复宣畅往本大行。精进力势。无所藏匿。吉祥之力。等际所有。承佛威神道之所感。无可为喻。无言乃达。尔时普贤。重告之曰。菩萨大士。逮得法忍。有十事。以能具足于法忍者。则无阴盖。便致一切法忍之地。于诸佛法。而无挂碍。何谓为十。一达音响。二柔顺行。三不起法忍。四曰喻幻。五曰野马。六曰若梦。七曰呼响。八曰若影。九曰如化。十曰如空。是为菩萨逮十法忍。彼则何谓为音响忍。诸所闻音。不怀恐怖。不畏不懅。喜乐思顺。诸所遵行。无所违失。是音响忍。何谓柔顺法忍。菩萨随顺应游法生。而观察法。造立行等。不为逆乱设使诸法。应柔顺者。当度度之。志性清净。遵修平等。勤加精进。顺入成就。是柔顺法忍。何谓菩萨不起法忍。菩萨设睹诸法有所生者。都无处所。不计灭尽。亦无所见。其不生者则无所灭。其无灭者则无所尽。其无尽者则无所坏。其无坏者则无崖底。其无底者则寂然地。其寂然地者则澹泊也。其澹泊者则无所行。其无所行者则无所愿。是为不起第三法忍。何谓菩萨喻幻法忍。晓了诸法一切如幻因缘而成。笃信一法。济度若干无央数法。以无数法。等入一法。入于吾我。入无所入。诸所建立。导利众行。悉无所著。犹如巨象众乘之上。若幻不与众象车骑步人游居。不与男女童子童女。大小游居。不与树木枝叶华实。而俱游居。菩萨晓了一切诸法。若如幻者。不合不散不与地水火风。而俱游居。不与昼夜十五日。一月一岁。而俱游居。不计百年千年。不与日月劫数。而俱游居。不与影响诸所见众。而俱游居。不与若干。亦不若干而俱游居。不以若干入于一事。而俱游居。不与微妙及劣下极。柔软粗犷。而俱游居。不与鲜少弘多游居。不与有限无限游居。不与若干各异众会并处色者。而俱游居。其众会者。不与幻变。而俱游居。其所幻变。不与众会。而俱游居。无居不居。无所不居。而等济度。一切诸见。及若干幻。各各异见。于斯诸见。永无所见。乃见一切诸趣根原。是为佛子。名曰菩萨游入如幻。而度于世。世所行尘劳世。国土俗游法世。吾我世。痛痒世。有为世。离有世。合会世。无合会世。分别世。所造行世。是为菩萨济度世名。则为幻化普入诸世。不受众生。不坏众生。不受国土。不败国土。不受于法。亦不坏法。不念过事。于过去事。亦无所想。亦不离想。亦无当来。亦无造行。不堕未然。不住现在。不毁所存。则于佛道。而不驰骋。不想念道。亦不与佛。亦不劝佛而取灭度。不住诸愿。不舍所誓。遵修平等。亦不严净。无所挂碍开导国土。劝使进入。无所破坏。住于法本而不动转。等入吾我。亦不违毁吾我之想阴种诸入。训诲众行。蠲除所著。度脱黎庶。于斯诸行。无所依猗。晓了诸法。而悉平等。永不可得。分别诸法但假字耳。圣达明慧。无能逝者。度脱众生。恒顺时宜。亦不依猗群萌因缘。住于大哀。畅宿世行不可计会报应之事。皆令信了。是为幻喻第四法忍

何谓佛子。菩萨大士野马法忍。菩萨晓世一切所有悉为慌惚。犹如野马。人遥睹之。如江河流而有波起。达士了之炎气无水。菩萨如是。分别诸法有无众事。无内无外。不有不无。亦无断灭。不计有常。不入教诲轻慢之内。观睹如有。而无恶趣。心不归外。亦不处内。为一像貌若干之像。知无像貌。一切诸法。具足微妙。皆悉无本。是为野马第五法忍何谓佛子。菩萨大士。喻梦法忍。菩萨观世。犹如梦想。如人之梦。不处于世。不从世兴。不从世生。又梦者梦无有欲界。亦无色界。无无色界。所以谓梦。则无所生。悉无所有。梦无尘劳。则无结恨。又计梦者。既无所生。亦无清净。梦不见梦。菩萨大士。观一切世。晓了如梦。亦无明达。亦无闇冥。梦者自然。梦无所著。梦者恍惚。梦者本净。有所建立。而有此梦。梦无所坏。因所念想故。而有斯梦。设能晓了一切诸法若如梦者。开导世间。是为若梦第六法忍

何谓佛子。菩萨大士如响法忍。菩萨学法。所入诸音。设有所学。度于未度。学法开化。了于一切。犹若呼响。非不有声。然本悉寂。亦无所度。菩萨大士。如是色像。察于如来内外诸响。亦不别见内外诸事。亦不知外。亦不以内而了外事。不见所托。晓知言辞进退之宜。是为解知。若干章句。因缘如响。有所启导。于诸法施。靡所不达。亦无所碍。有所学者。分别晓了一切诸声。悉无所有。犹如天上殊妙玉女。属天帝释。而以一口。身同时鼓出百千妓乐之音。又其妓乐。无所想念。口亦无念。吾今演出百千妙响。菩萨大士。度诸境界。亦无想念。亦无言辞。晓了权宜。成无量音。方便无限。度于世法。亦不退还。常转诸界。入群黎众。为诸会者。分别说之。多所开导。则建立之。口畅演现无挂碍音。遍诸佛土。令其信乐。班宣经典。训导蒸庶。为奋光明。散照未悟。悉使觉了一切诸音。纵有所说。皆无所生。游若干音。都无想念。益加开导。解无所生。宣诸觉场。逮至圣涂。菩萨大士。已住于此等无所获。令普听者入于一切诸佛所兴。面见诸佛转于无限。所度法轮。顺无想念。是为如响第七法忍

何谓佛子。菩萨大士。若影法忍。菩萨。不没于世。不生于世。不游于世。不出于世表。不行于世。不信法界。不坏习俗。又于世界。亦无不坏。不至于世。不贪乐世。不御于世。不长于世。又彼菩萨。不处于世。亦不度世。亦不奉行菩萨之行。无所笃信。于大誓愿。不实不虚。不有不无。无虚妄行。则趣一切诸佛之法。普周世间。靡所不遍。于世俗法。亦无所住。不随俗教。犹若如影。假如日殿。亦如月照。男女树木。山陵屋宅。诸神宫殿。诸江河流。若干种形。无量因缘。不可尽极。诸所方面。因日光明。悉睹众像。知其所趣。如清净水。又如船师。若夜光珠。因其所见。而得自恣。于斯所好。当所施者。其不清净。无光耀者。悉蒙其明。而蒙晖照。亦无所造。又其光明。亦无所有。无有音响。亦无所生。因其光明。而有所别。然其光明。无所游居。虽为清显。亦复不与。清显同处。于光明地。亦谓光明。照若干流。亦无所照。则无所周。影亦不入江河泉源大海渊池。又计其影。亦无所处。亦无所著。其影所现。亦无鲜洁。不有瑕疵。斯影不现。则于彼间。不猗得本。其影广现。无远无近。菩萨如是。所开化者。已及彼性。志行所趣。而得自在。所观众生道慧之场。有所劝化。他志所行。等无差特。分别己身所游道场。而普审察己界他界。悉无二品。如种树者。从始生芽。展转滋茂。稍渐成长。而生茎节。枝叶华实。菩萨如是。于己法界。及与他界。分别诸相。法无有二。则得超入无碍本际。彼菩萨身。则得越过不可思议诸佛国土。见诸佛土。亦无所著。于诸世界。亦不转移。至诸佛界。亦无所至。法身所至。如日殿影。在所具矣。其身普入。现一切界。有所现生。行无挂碍。亦不分身。亦无所行。无是世间世俗之想。蠲除方土虚无之辞。亦不散身。逮不终始无所不覆。如来之种本际所行。亦不复净身口意行。便得游入咨嗟无量。净一切身靡不周达。是为如影第八法忍

何谓佛子。菩萨大士如化法忍。菩萨普入世俗。若有所至。观了众生。一切如化。然不适识。念如化事。所谓化者。则谓一切诸有世界。因所造行。思想所化。皆是一切苦乐颠倒。斯化等类。一切世间。悉缘无明。或以思想。便成尘劳众想之念。因缘化生。由是建立宣畅咨嗟音响法律。以无想教。而开化之。坚固不退。导令平等。悟诸不觉。立志誓愿行如化者。观察如来大哀之行。黎庶化生。晓了于斯。谓修法轮善权方便。以慧无畏四分别辩。圣达自在。如是菩萨。化度于世。超世功德辩才自由。恢弘无际。入于无量亿千之众。处于其中。而得自恣。悉能晓了。人行天动。睹无圣路。示以大道。如其所行。无所违失。譬如化人。则无所念。亦无所造。不兴心事。亦不于法而有所住。不从业起。亦不望报。无所游至不出于世。亦不于世而成正觉亦不念法。不习诸法。亦不久住。亦不须臾。亦无所处。不行习俗。不长世间。无方面辞。不近诸限。亦无不限。不增不损。无有笃信。亦无不信。无有贤圣。亦不凡夫。无有尘劳。亦不结恨。不没不生。亦无有慧。亦无不慧。亦无所有。亦无微妙。不依猗世。亦不导御。于诸法界。不智不愚。亦无所受。亦无不受。无有五阴。亦不无阴。无有生死。亦不灭度。不有不无。如是菩萨游行于世。修菩萨行。晓了辩才。不建憍慢。睹见世间。无有自大。遵所修行。不为己身。不为世俗。无放逸者。而无吾我。离着贡高。亦不倚此。亦不依俗。舍其慢恣。无所想念。不处于世。不断于世。亦不于法而溢自在。不于人界有所猗着。无所开导。亦不处于众生之界。无有所愿。亦无想念。亦无所净。又于诸法。无所庄严。诸佛之法。悉无所有。具足成就。乃至大道。又斯诸法。不有不无。犹如彼化。不有不无。达化菩萨住于法忍。而等晓了一切佛道。已得成就。造立诚谛。斯则菩萨。周揽佛法。如化无处。普于佛道。而无所获。众生之行。无诸阴盖。不起有身。入一切身。而开导之。有所建立。而无所著。若见色者。于色如化。悉无所著。而等具足。真谛本际。自然之明。有所照耀。于解脱法。而无所猗。于一切法。现有所生。而无所生。如彼化人无所识念。本性清净。有所受言。如所咨讲。顺一切律。亦无想念。如化感动。变异所造。现来诣此一切如来至圣道场。无诸退缘。亦无所生。兴无挂碍。成一切力。悉无所想。如彼化人。其心咸达。而不蔽碍围神之山。是为如化第九法忍

何谓佛子。菩萨大士如空法忍。菩萨观入众生之界。犹如虚空无有缘相。一切法众亦复如兹。入诸佛土。而无有诚。诸法虚空。无有二事。菩萨如斯入无所誓。犹如虚空。苞诸佛土。亦复如斯。无所缚着。兴于如来所入之力。而俱游同。犹如虚空所入无二。道亦如斯。无去来今。慧亦如之。皆分别说一切诸法。所入如是。菩萨大士。逮得法忍。犹如虚空所致圣慧。亦复如兹。于斯诸乘。有所致获。悉如虚空。身口意所获自在。犹如虚空。所逮诸法。因意所念。而有所成。犹如虚空。于一切法。而无所种。不没不生。菩萨如是。于一切法。而得自在。不终不始。犹如虚空无有处所无能毁者。于诸通慧。无有处所。亦无所坏。于诸佛力。犹如虚空自然而住。于一切世而无所住。则为自然之境界也。菩萨如是。建立众生。亦无所立。一切如化。犹如虚空。不起不灭。亦无所生。合受一切世界所有。菩萨大士。如是亦无所住。无所成就。有所严净也。因其普显一切世界。犹如虚空。无有处所。亦无方面。无有边际。亦无崖底。畅达深广。靡不周至。菩萨如是。无有处所。亦无方面而有所至也。于一切法。宣达恢弘。等御诸行。靡不周遍。犹如虚空。有住依立。则无所生。而现众庶含[果/衣]众形。菩萨如是。不行不住。游随众行。而有所现。亦无所生。犹如虚空无有形像。亦无不像。无清净行。亦无秽浊。因有道御。菩萨如是。无世形像。无度世像。无无量像。因有所现。犹如虚空。无有久固。无须臾立。菩萨如是。不久存立。不须臾住。犹如现影。而无有影。为菩萨行。若晓了此。乃得究竟。行如虚空。现诸尘劳。而无秽疵。现诸结恨而无怨憎。菩萨如是。则以道力。降伏众魔。一切清净。其心鲜洁。寂寞恬怕。等苞一切世间所有。又如虚空所[果/衣]世间。等无差特。菩萨如是。于一切法。而悉平均。菩萨大士。又于诸法。亦无所碍。无所亡失。犹如虚空等[果/衣]一切。欲限虚空无有边际。菩萨如是。于一切法。志性俱游。又其道心。无有边际。所以者何。其虚空者。所周平等菩萨于己。而遵修行。成就清净。造于平等。为一周业。则以一事。转为无量。普游诸刹。若如虚空。于诸佛土。无所究竟而得具足。于诸方面。而无所住。游入诸方。成就神通。一切诸德。不可限量。殊特之事。自然具足。悉获诸法至度无极。得坚固术。志如虚空。若如金刚于一切响。无所想念。开导诸音。则不违舍。法轮之转。假使菩萨行能具足成斯忍者。则得自在。亦无所至。无往无来。悉无所趣。乃得自在。而无所灭。便于无为。而得由己。无所亡失。除无实身。成就真体。顺如律教。心无所望。则为一相。其身自在。入于无相。则以无相。无有限量。佛力无限。身普自恣。靡不周达。则护己行。身无所坏。而得由己。坚固平等。有所降伏。一切普入。其因咸睹。眼则清净。已无阴盖离欲之行。亦无不行。犹如虚空寂默无限。所入之处。则以无忍。无所不忍。是所谓功德也。己普辩大。至于澹泊。犹如虚空无有危厄。一切菩萨。晓了所行。入于清净。心等如空。无所毁失。一切佛法。若巨海。殊特无限。有所游入。无有断绝。入诸佛土。建立诱导无限国界众生之党。虚空无底。离诸色像。无众音响。察长见诸普随示现。寻开化之。具足成就。志固如空。无能沮败。其心坚强。悉得究竟。普等世界。亦如虚空。悉无所有。其坚固者。无趣诸世。除诸恩爱。能具大道。其劫悉烧天地然尽。不烧虚空。虚空总揽含受一切诸佛世界。菩萨如是。入于诸力。建立无上正真之慧。是为佛子。菩萨大士了诸法如空第十法忍。普贤菩萨。说是经时。诸菩萨众。诸天龙神。阿须伦世人。莫不欢喜

佛说如来兴显经卷第四


佛说十地经卷第一

    No. 287 [Nos. 278(22), 279(26), 285, 286]

佛说十地经卷第一

        大唐国僧法界从中印度持此梵本请于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨极喜地第一之一

如是我闻。一时薄伽梵。成道未久。第二七日。住于他化自在天中。自在天王宫。摩尼宝藏殿。与大菩萨无量众俱。其诸菩萨悉从异佛刹来集。皆于无上正等菩提。得不退转。一生所系。当证正觉。所谓。已得安住一切菩萨智所行境。皆能趣入一切如来智所行处。无有休息。善能示现。种种神通诸所作事。应时无滞。成熟调伏一切有情。利乐他事皆不虚弃。引发一切菩萨愿。劫世刹土量等修行。暂无休息。一切菩萨。福智资粮。善备无尽。令诸世间。共所受用。已到一切菩萨智慧方便彼岸。示入生死及涅槃门。而不废舍修菩萨行。善能游戏解了。趣入一切菩萨。静虑解脱等持等至神通明智。于是一切诸所作事。皆得善巧。由获一切菩萨神通威力自在。以无功用随心刹那。悉能往诣一切如来道场众会。而为上首请佛说法。受持一切如来法轮。广能供养承事诸佛。常勤修习。一切菩萨所行事业。其身普现一切世间言音无碍。清彻法界心智无滞。普见三世一切境界。一切菩萨所有秘藏功德正行悉已圆满。设加无量不可说劫赞其功德亦不能尽。其名曰金刚藏菩萨。宝藏菩萨。莲华藏菩萨。德藏菩萨。莲花德藏菩萨。日藏菩萨。曜藏菩萨。地藏菩萨。无垢月藏菩萨。示一切庄严光明藏菩萨。智慧普照明藏菩萨。旃檀德藏菩萨。妙吉祥藏菩萨。花德藏菩萨。拘苏摩德藏菩萨。优钵罗德藏菩萨。天德藏菩萨。福德藏菩萨。无碍净智藏菩萨。功德胜藏菩萨。那罗延德藏菩萨。无垢藏菩萨。离垢藏菩萨。种种辩才庄严藏菩萨。大光明网照藏菩萨。离垢威德光明王藏菩萨。无碍妙音美响藏菩萨。总持功德能度一切有情愿藏菩萨。大海庄严藏菩萨。苏迷卢德藏菩萨。示现一切功德清净藏菩萨。如来德藏菩萨。佛德藏菩萨。淳金微妙。大威德王光明藏菩萨。一切相庄严净藏菩萨。金刚焰胸万字相庄严菩萨。星宿王光照藏菩萨。虚空库无碍智藏菩萨。解脱月菩萨。如是等菩萨。摩诃萨无量无数不可思议。不可量不可称无边无际。无有分齐。不可说不可说。皆从异异佛刹来集金刚藏菩萨而为上首

尔时金刚藏菩萨。承佛神力。入于菩萨妙三摩地。名大乘光明。入此定已。即时十方各过十俱胝佛刹微尘数世界之外。各有十俱胝佛刹微尘数诸佛如来。同名金刚藏。皆现其面。俱作是言。善哉善哉。佛子。汝今乃能入是大乘光明菩萨等持。然善男子今彼十方各十俱胝佛刹微尘数诸佛如来其加持汝。以此世尊毗卢遮那本愿威神力所持故。为一切菩萨趣入。能显不可思议佛法光明。诸智地中为令摄受一切善根。为择一切佛法善巧。为广知法。为正演说善成立法。为无分别智得清净。为一切魔法不染。为出世法善根得净。为证不思议智所行境。乃至为证佛智境界。又为一切菩萨十地发趣及得。为如实说诸菩萨地安立善巧。为正缘虑诸佛妙法。为修无漏法之差别。为善选择决定大慧光明善巧。为趣入于决定智门。为获显示如所应处无畏辩说。为证广大无碍解地。为菩提心念不遗失。为善成熟诸有情界。为一切处通达决定选择辩才。然善男子。汝当辩说此法差别善巧法门。所谓由承诸佛威神力故。已诸如来智慧光明所加持故。已善圆净自善根故。已善莹饰真法界故。已普摄益诸有情故。已证法身智所依故。已从诸佛受灌顶故。已现超过一切世间最大身故。已越一切世间趣故。已净出世正法趣故。已能圆满一切智智故。尔时十方彼诸如来。与金刚藏菩提萨埵无映夺身。与无挂碍演说辩才。与入微妙清净智辩。与无忘失念所加持。与善决定慧之善巧。与不弃舍周遍行智。与正等觉力无有能摧伏。与如来无所畏令无怯弱。与以一切智智所摄大无碍解辩法理趣决定安立。赐与引发一切如来善分别身语意庄严。所以者何。由此菩萨获彼大乘光明等持。法尔如故。以本誓愿所引发故。善净增上妙意乐故。已善莹饰净智轮故。已善积集诸资粮故。已善炼治所作事故。以无量念而为器故。明朗胜解得清净故。善达无杂总持门故。法界智印之所印故

尔时十方彼佛世尊。不起于座以神通力。各申右手摩金刚藏大菩萨顶。时金刚藏菩提萨埵。蒙彼十方佛摩顶已。即从定起。普告一切菩萨众言。唯诸佛子是菩萨愿。决定无杂不可照了广大法界尽虚空性。穷未来际能救一切诸有情类。唯诸佛子菩萨安处于此愿中。方能入于过去诸佛世尊智地。乃能入于未来诸佛世尊智地。亦能入于现在诸佛世尊智地唯诸佛子一切菩萨有十智地。是以过去未来现在诸佛。已说当说今说由此密意我作是言。何等为十一名极喜地。二名离垢。三名发光。四名焰慧。五名难胜。六名现前。七名远行。八名不动。九名善慧。十名法云。唯诸佛子。此名一切菩萨十地。是以过去未来现在诸佛。已说当说今说。唯诸佛子。我不见有诸佛国界。彼中如来不叹说此菩萨十地者。所以者何。是诸菩萨增上胜妙。能净一切诸菩萨道法门光明。谓即十地安立解释。唯诸佛子。当知此处不可思议。谓于诸地安立法中自所证智

尔时金刚藏菩萨。标斯十地名已默然而住。不复分别而解释之。是时一切诸菩萨众。闻说菩萨十地名已。不闻解释。咸生渴仰作如是念。何因何缘是金刚藏菩提萨埵。唯说菩萨十地名已。默然而住更不解释。尔时于此菩萨众中有一菩萨名解脱月。知诸大众心之所念。即以颂问金刚藏菩萨曰

  何故正觉者　　念智功德具
  标诸上妙地　　自在不解释
  一切咸决定　　菩萨大名称
  何故说地名　　而不演其义
  一切诸佛子　　无畏皆乐闻
  愿为正分别　　说诸地义趣
  众会悉清净　　离懈怠严整
  鲜洁住坚实　　具足功德智
  相视咸恭敬　　一切悉专仰
  唯望法甘露　　如蜂念净蜜
  大智无畏者　　金刚藏闻是
  欲令大众悦　　以颂詶佛子
  虽作最胜甚希有　　此能显示菩萨行
  辩地能作最微妙　　由此佛地有修证
  微细难见离分别　　远离心地难证悟
  智者境界纯无漏　　世间闻者悉迷惑
  安心不动如金刚　　信解佛智最殊胜
  了知无我唯心地　　此能闻斯微细智
  如以众彩画虚空　　如风依于鸟路行
  无漏佛智亦如是　　虽为分别而难见
  故今吾兴如是智　　世间难有知此者
  及能信此最胜法　　是故不任广解释

尔时解脱月菩萨闻是语已。白金刚藏菩萨言。佛子今此众会皆悉清净。其诸菩萨善净意乐。善洁思念善修诸行已。善承事无量百千俱胝诸佛。善集资粮成就无量种种功德。永离疑惑无诸垢亹。善任增上意乐胜解。于佛法中不随他教。善哉佛子演说此义。是诸菩萨于如是处现证而住。尔时解脱月菩萨。欲重宣此义而说颂曰

  愿说最安隐　　菩萨无上行
  分别于诸地　　智净成正觉
  此众无诸亹　　志解悉明洁
  承事无量佛　　能知此地义

时金刚藏菩萨言。佛子虽此众会皆悉清净其诸菩萨善净意乐。善洁思念善修诸行已。善能承事无量百千俱胝诸佛善集资粮。成就无量种种功德永离疑惑无诸垢衅。善住增上意乐胜解。于佛法中不随他教。然有其余劣解有情。闻此甚深难思议处忽生疑惑。是彼长夜能引无义无利众苦。我愍此等故乐默然。尔时金刚藏菩萨。欲重宣此义而说颂曰

  虽此众净广智慧　　甚深明利能决择
  其心不动如山王　　不可倾覆犹大海
  有行未久解未得　　随识而行不随智
  闻此生疑堕恶道　　我愍是等故不说

尔时解脱月菩萨。复白金刚藏菩萨言。善哉佛子愿说勿疑。由佛神力佛所护念。此如是等不思议处皆得可信。所以者何。唯佛子说此十地解释之时。法尔如是。谓一切佛皆悉护念。一切菩萨为欲卫护此智地故皆发勇悍所以者何。此是菩萨最初正行。亦是一切佛法修证。唯佛子譬如一切书字数。说字母为始字母为终。无有少分书字数说离字母者。佛子一切佛法亦复如是。以地为始发修行故。以地为终证佛智故。是故佛子愿为演说。诸佛应供正遍等觉加持护念尔时解脱月菩萨。欲重宣此义而说颂言

  善哉佛子愿演说　　趣入菩提诸地行
  十方一切自在尊　　无不护念智根本
  此正行始此智终　　一切佛法从此起
  如诸书等字母摄　　佛法依地亦如是

尔时此诸大菩萨众。亦为此义一时同声。而以颂请金刚藏菩萨曰

  上妙无垢智　　善说无边辩
  宣扬美妙言　　胜义相应理
  念持清净慧　　为十力意乐
  无碍解决择　　说殊胜十地
  此众离憍慢　　及见疑杂染
  戒定审悦意　　唯愿闻善说
  如渴思冷水　　如饥念美食
  如病忆良药　　如众蜂嗜蜜
  此众亦如是　　愿闻甘露法
  善哉清净智　　说无垢地位
  显十力相应　　无碍善逝道

尔时世尊释迦牟尼。从白毫相放无数光。名照菩萨力无数光明以为眷属。其光普照十方世界靡不周遍。诸恶趣苦皆令休息。映蔽一切诸魔宫殿。悉照无量诸佛众会显示诸佛不可思议境界行相威力游戏照于十方诸世界中。及于一切诸佛众会以佛神力所加说法。菩萨身已于上空中。成大光云网台而住。彼诸世尊亦复如是。从白毫相放无数光。无数光明以为眷属。其光普照十方世界靡不周遍。诸恶趣苦皆令休息。映蔽一切诸魔宫殿。悉照无量诸佛众会。显示诸佛不可思议境界行相威力游戏。照于十方诸世界中及于一切诸佛众会以佛神力所加说法。菩萨之身。显不思议诸佛游戏。并照世尊释迦牟尼大会之众及金刚藏菩萨身已。于上空中亦复成就大光明云网台而住。由是世尊释迦牟尼。从白毫相所流光明。彼彼世界彼佛众会。及彼菩萨身与法座。皆现了然于此得见。由彼无量佛刹土中。诸佛世尊从白毫相所流光明。此之三千大千世界。及此世尊释迦牟尼大会之众。并金刚藏菩提萨埵身及法座。皆现了然于彼得见。尔时从此光云网台出是颂曰

  佛无等等如虚空　　十力自在无边众
  于释师子妙法中　　天人最上今加汝
  佛子当承佛神力　　开此法王妙法藏
  显示微妙广大行　　分别建立诸智地
  若有闻此胜法门　　亦蒙善逝所加护
  十方一切诸菩萨　　悉皆摄持及护念
  当能修集诸正行　　次第成满无垢地
  能证十力等功德　　契悟无上正等觉
  虽住海水劫火中　　无疑堪闻此法门
  其有疑惑不信者　　永复不闻如是义
  当说最胜地智道　　证入安住及升进
  修行境界如次说　　利乐一切有情故

尔时金刚藏菩萨观察十方。欲令大众增净信故而说颂言

  微细难知大仙道　　不可分别离分别
  难证无浊慧者境　　性常寂静无生灭
  性空能寂无二尽　　离趣平等至涅槃
  无边中缘无所证　　出过三世等虚空
  寂静寂灭佛所证　　以诸言趣难宣说
  此地及行亦如是　　说犹甚难何况听
  远离思惟及心道　　此智所引牟尼境
  非蕴界处所显了　　非心所测意所思
  譬如空中诸鸟迹　　智者叵宣难可示
  诸佛子地亦如是　　说尚极难何况听
  今当但说此一分　　由大慈悲及愿力
  如其渐次非心境　　以智能满如意乐
  如是此境极难见　　叵说唯住自意乐
  然承佛力我今说　　汝等一心恭敬听
  如是智门及正行　　亿劫宣说犹难尽
  我今略说汝等听　　真实法义尽如理
  仁者专心恭敬待　　我承佛力当善说
  宣扬微妙正法音　　譬喻相应协伦字
  此以言词难显了　　而蒙无量佛神力
  光形聚入于我身　　由是我今能演说

唯诸佛子若有有情。善积善根善集资粮。善修诸行善事诸佛。善聚白法善友所摄善净意乐。随顺广大增上意乐。具妙胜解悲愍现前。为求佛智。为欲证悟十力之力。为获如来大无所畏。为得平等佛不共法。为欲救拔一切世间。为净大悲愍。为悟十方无所余智。为以无碍净诸佛刹。为一刹那能知三世。为无所畏转大法轮。发如是心。菩萨发心大悲为先导。慧智增上方便善巧之所摄受。意乐及与增上意乐常所辅持。佛力无量以坚持力及以智力。善择决定无碍智。现前随顺无师自然妙智。能受一切佛法慧智。教授诲示。极于法界尽虚空性。穷未来际始发此心。即是菩萨超异生地。证入菩萨正性离生。生如来家种族尊贵无可讥嫌。已离世趣入出世道。住于菩萨本法性中。已善安住于菩萨处。随顺三世平等之法。绍如来种决定趣向正等菩提。唯诸佛子菩萨住于如是等法。名已善住极喜地中以不动故

唯诸佛子菩萨住于极喜地时。极多欢喜多净信。多爱乐多适悦。多忻庆多踊跃。多勇悍多无斗诤。多无恼害多无嗔恨。唯诸佛子菩萨住于极喜地中念诸佛时。发生极喜念佛法时。念菩萨时。念菩萨行时。念到彼岸清净之时。念诸菩萨地殊胜时。念余菩萨不映夺时。念佛教授教诫之时。念令有情得利益时。念当趣入一切如来智加行时。皆生欢喜。又此菩萨了知我今转离一切世间境界。亲近诸佛远异生地近至智地。永断一切堕险恶趣。与诸有情为依止处。近见诸佛住佛境界。入诸菩萨平等性中。舍离一切怖畏毛竖故生极喜。所以者何。唯诸佛子菩萨才。证极喜地已。所有怖畏谓不活畏恶名畏死畏恶趣畏处。众怯畏悉皆远离。所以者何。由是菩萨离我想故。尚无我爱况复生。于诸资具爱由是因缘无不活畏由于他所无所希望唯自起欲。我应给施一切有情诸资生具。由是因缘无恶名畏由离我见。于我无有失坏之想故。无死畏自知死后。于当来世决定不离诸佛菩萨。由是因缘无恶趣畏。由意乐见一切世间尚无有一与我齐等何况殊胜。是故无有处众怯畏。唯诸佛子菩萨如是。已离怖畏憍傲毛竖。以大悲愍而为先导以无憎背无俗意乐。为欲修证一切善根勤修加行。以信增上。以多证净。以洁胜解。以多信解。以引发悲愍。以具足大慈。以无厌倦心。以惭愧庄严。以常忍辱柔和相应。以深敬顺信重尊贵如来圣教。以无厌足日夜积集一切善根。以奉事善友。以乐于法苑。以无厌足访求多闻。以所闻法如理观察。以无依着心。以不耽嗜名利恭敬。以不希恋资生之具。以无厌足引平等心犹若宝珠。以专希求一切智地。以缘如来力无所畏不共佛法。以求无著波罗蜜多。以离谄诳。以如说行。以常护实语。以不污佛家而劝于他。以不舍离诸菩萨学。以不倾动萨波若心如大山王。以不离诸世间事而能成就出世间道。以无厌修觉分资粮。以常希求后后胜法。唯诸佛子以如是等诸净地法相应。菩萨名住安住极喜地中复次菩萨住于极喜地时。引发如是诸大誓愿诸大勇决诸大出离。为以无余供养之具及以周备承事。品类普遍供养一切如来。一切行相胜妙成就。而以最上胜解。清净广大法界尽虚空性穷未来际。一切劫数佛出世数无有休息。为大供事发初大愿。为欲受持一切如来所说法眼。为欲摄受诸佛菩提。为护一切正等觉教。广大法界尽虚空性穷未来际。一切劫数无有休息。为摄受妙法发第二大愿。为一切佛出现于世。无余一切诸世界中。住睹史多天宫为首。降下入胎住胎生长出家成道。受梵王请转大法轮示大涅槃。为悉往诣。供养受法加行为先。为一切处同时而转。广大法界尽虚空性穷未来际。一切劫数佛出世数无有休息。为悉往诣发第三大愿。为欲引发诸菩萨行。广大无量及无分别波罗蜜多之所摄受。净治诸地总相别相同相异相成相坏相。诸菩萨行如实无倒。显示菩萨智地之道。悉能莹饰诸到彼岸。授与教授教诫所持资助发心。广大法界尽虚空性穷未来际。一切劫数及正行数无有休息。为是引发第四大愿。为欲成就无余一切诸有情界有色无色有想无想非有想非无想卵生胎生湿生化生。三界所系入于六趣系属一切受生之处名色所摄为令趣入于佛法中。为令永断一切趣数。为令安处一切智智。广大法界尽虚空性穷未来际。一切劫数有情界数无有休息。为欲成熟诸有情界发第五大愿。为欲无余一切世界广大无量粗细。乱住覆住仰住帝网差别。入于十方种种异相。皆以随行现前。知见广大法界尽虚空性穷未来际。一切劫数及世界数无有休息。为欲往趣发第六大愿。为令一切诸佛刹土复一刹土入于一切诸佛刹土。普皆清净无量佛刹光明严具以为庄饰。离诸烦恼成清净道。无量智性有情充满。普入广大诸佛境界。随诸有情意乐示现皆令欢喜。广大法界尽虚空性穷未来际。一切劫数及佛刹数无有休息。为饰一切诸佛刹土发第七大愿。为与一切菩萨同一意乐加行。为无怨敌积集善根。为一所缘与诸菩萨得平等性。为常逢遇诸佛菩萨不相舍离。为随自欲示佛出世。为随心念解佛威力。为获圆满一切生中常不退转随行神通。为遍游历一切世界。为于一切众会影现。为随一切受生之处同类而行。为恒成就不可思议大乘理趣。为欲修行菩萨正行。广大法界尽虚空性穷未来际。一切劫数及正行数无有休息。为大智神通发第八大愿。为行乘御不退转轮诸菩萨行。为身语意业不唐捐。为暂见者便得决定诸佛法性。暂闻言音便随智证。才生净信永断烦恼为身得成如大药王。为得身心如如意宝。为当修行大菩萨行。广大法界尽虚空性穷未来际。一切劫数及正行数无有休息。为不唐捐发第九大愿。为于一切诸世界中。当证无上正等菩提。为不殊异于一毛道。遍于一切诸毛道中。示生出家道场正觉转大法轮归大寂灭。为当现证弘佛境界威力智慧。随于一切有情意乐示佛出世。令其所化刹那刹那觉寂证修。为刹那顷以一正觉。普遍一切法寂灭性。为以一音演说法要。令诸有情心皆悦豫为示大涅槃而行力不绝。为示大智地。建立一切法为以法智神变幻通。悉能充遍一切世界。广大法界尽虚空性穷未来际。一切劫数及正觉数无有休息。为引发大乘菩萨发起第十大愿。唯诸佛子初地菩萨。发如是等诸大誓愿诸大勇决诸大出离。菩萨住此极喜地中。十大愿门以为上首。引发圆满百千阿僧企耶诸余正愿。是诸大愿以十尽句而引发之。何等为十。所谓以有情界尽。以世界尽。以虚空界尽。以法界尽。以涅槃界尽。以佛兴界尽。以入如来智慧界尽。以心所缘界尽。以智入佛所行界尽。以世间转法轮智转界尽。若有情界有断尽者。是大誓愿乃有断尽。乃至若智转界有断尽者。是大誓愿乃有断尽。然有情界终无断尽。此诸善根愿无断尽。乃至智转界终无断尽。此诸善根亦无断尽

佛说十地经卷第一佛说十地经卷第二

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨极喜地之余

复次菩萨如是已发诸大誓愿。得堪能心并柔软心及调柔心。成就净信能信诸佛正等觉者。本所入行。修证到彼岸修证诸胜地。成就诸力成满无所畏。由不共佛法不可映夺。不可思议诸佛法性引发。无中无边甚深如来境界。随入无量如来所行信果成就。举要言之。能信一切菩萨正行。乃至佛地解释加持

复次菩萨作是思惟。诸佛之法如是甚深如是寂静。如是寂灭如是性空。如是无相如是无愿。如是无际如是广大。如是无量如是难证。然复彼诸愚异生类。由堕邪见心之相续。由无明闇缠绕意识。由骄慢幢高建计度。由渴爱网希求作意。由逐谄诳稠林意乐。由悭嫉相应趣生处加行。由贪嗔痴积集诸业。由以忿恨炽然心焰。由颠倒相应引发业用。由以欲有及无明漏所系心意意识种子。于三界中生后有芽。所谓名色俱生不相舍离。名色增长成六处聚落。六处成已。由互相触因缘有受。展转于受有忻乐者。增长爱取增已成有成就。此故有生老死愁叹苦恼。有情苦蕴。如是发生离我我所。不实虚伪空无作用。无动愚钝。譬如草木如影而现。然彼有情不觉不知。菩萨见彼诸有情类从大苦蕴不得解脱。为拔彼苦引发大悲。为欲令彼住于毕竟安乐涅槃故兴大慈

复次诸佛子菩萨。如是以此随顺大慈大悲增上意乐住初地时。于一切事心无顾恋。以慧希求诸佛妙智修行大舍。凡是所有一切能舍。所谓财谷仓库等舍。或以金银摩尼真珠琉璃珂贝璧玉珊瑚车磲码瑙钱物等舍。或以珍宝庄饰严具璎珞等舍。或以殊妙象马车乘辇舆等舍。或以可意寺舍园林楼观流泉浴池等舍。或以奴婢僮仆等舍。或以国土聚落城邑王都等舍。或以妻妾男女等舍。或以一切所爱之事皆悉能舍。或以头目手足一切身分等舍。如是一切所施事中心无顾恋。以慧希求诸佛妙智皆悉能舍。如是菩萨住于初地能成大舍

复次菩萨既得如是大慈大悲大舍意乐已。为欲救拔一切有情。转更访求世出世间诸利益事。访求之时心无厌倦。即得如是无厌倦性。无厌倦者于一切论得无怯弱故。此菩萨于诸论中智得成就。此以如是诸论相应应不应。作善筹量。智于劣中胜。诸有情所如应如宜而修正行故。此世智而得成就得世智已。应时应分应量而行。以惭愧庄严心之相续。勤修自利利他加行。由此菩萨惭愧得成。即于如是正加行中。皆能出离得无退屈及无转易力所持性。是故菩萨坚力持性而得发生。菩萨得此坚力持已。即能殷勤供养承事诸佛如来及教法中而正修行。菩萨如是成就十种净诸地法。所谓净信慈悲慧舍无有厌倦。善知诸论善解世间。惭愧庄严坚力持性供养诸佛

菩萨住此极喜地中由广大见及由愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛多百俱胝佛多千俱胝佛多百千俱胝佛多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具病缘医药诸资生具奉献菩萨诸妙乐具于僧伽众而作恭敬。以此善根皆悉回向无上菩提。由此供养诸佛如来。发生成就有情方便。以布施爱语成就有情。后二摄法未全通达。但以胜解力故。而行。于此十种波罗蜜多施到彼岸而得增上。余到彼岸随力随分。非不修行。此菩萨如如供养诸佛世尊。修习成就有情加行。受持修行诸净地法。如是如是此诸善根于一切智所回向者。转更明净隐意堪用。唯诸佛子如巧金师以矿性金置于火中。如如烧炼如是如是。转得明净随意堪用。唯诸佛子当知。菩萨亦复如是。如如供养诸佛世尊。修习成就有情。加行受持修行诸净地法。如是如是此诸善根。于一切智所回向者。倍复明净随意堪用

复次诸佛子菩萨住此极喜地中。应从诸佛及诸菩萨善知识。所访求请问初地行相并得等流。应无厌足成此地支。第二乃至第十地中行相。并得等流亦尔。又此菩萨于诸地中所治对治应修善巧。于地坏成应修善巧。于地得修应修善巧。于地支清净应修善巧。于地地运转应修善巧。于地地安处应修善巧。于地地殊胜应修善巧。于地地得不复退转应修善巧。于诸菩萨地清净已。乃至转入如来智地应修善巧。唯诸佛子菩萨如是引发诸地行相善巧。始从菩萨初地升进无有间憩。乃至转入第十智地。以无憩行地智光明证佛智光明。唯诸佛子。譬如黠慧善巧商主。将欲率领诸大商侣往诣大城。先未发时访求请问道中胜利。及于道中退转过失道处。中间胜利差别道处。中间退转过失于道资粮作所应作。从初道处虽未发足而善了知。如是乃能到彼大城。此大商主善以如是智慧筹量具大资缘。与大商侣度险旷野。身及商侣悉免忧患。乃至安隐到彼大城。唯诸佛子菩萨善巧大智商主亦复如是。若住初地于诸地中所治对治得成善巧。于地行相等流之中得成善巧。于地得修得成善巧。于地支清净得成善巧。于地地运转得成善巧。于地地安处得成善巧。于地地殊胜得成善巧。于地地得不复退转得成善巧。诸菩萨地得清净已。乃至入于如来智地得成善巧。是时菩萨。善受广大殊胜福德圣道资粮。及善决择智慧资粮。将欲率领无量有情诸大商侣。往诣一切智智大城。先未发时。应从诸佛及诸菩萨善知识所。访求请问诸菩萨地圣道功德。及从此道退转过失。于道处间胜利差别。于道处间退转过失。广大福智圣道资粮作所应作。从初道处。虽未胜进而善了知。如是乃能到于一切智智大城。此以如是智慧筹量。具大福慧圣道资粮。将已成就无量有情。诸大商侣经过生死旷野险道。自身及彼有情商侣悉免忧患。乃至安隐到于一切智智大城。唯诸佛子是故菩萨。应无厌倦修行诸地莹饰差别。唯诸佛子。是名略说菩提萨埵极喜初地趣入之门。住于此者生处多作赡部洲王得大自在。常护正法能以大施摄取有情。善巧能令诸余有情远离悭垢。常行大施无有穷尽。诸所作业或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意无所畏作意不共佛法作意。乃至不离一切行相胜妙相应一切智智作意。复作愿言。我当一切诸有情中为首为胜为殊胜。为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智。所依止处。若乐发起如是精进。弃舍一切家属财位。归佛圣教净信出家。既出家已一刹那顷瞬息须臾。能证菩萨百三摩地。见百如来。彼佛加持皆能解了。能动百世界。能往百刹土能照百世界。成就百有情。能住寿百劫。于前后际各能入百劫。于百法门能正思择示现百身。身身皆能现百菩萨。眷属围绕。从此以去是诸菩萨有愿力者。由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或加持或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨欲重宣此义而说颂言

  若有集众善　　具修白净法
  供养天人尊　　净意乐大志
  成就妙胜解　　随顺悲愍道
  为求佛智慧　　发此无上心
  为获佛十力　　及以无所畏
  成佛不共法　　救摄群生类
  为得大慈悲　　为严净佛土
  为转大法轮　　发此最胜心
  一念知三世　　而无有分别
  种种时不同　　以示于世间
  略说求诸佛　　一切胜功德
  发生广大心　　量等虚空界
  悲先智为主　　摄以方便慧
  净意乐所持　　如来力无量
  无碍智现前　　随顺自然智
  具受佛法诲　　发此最胜心
  佛子始发生　　如是妙宝心
  即超凡夫地　　入菩萨正性
  生在如来家　　种族无瑕玷
  绍诸佛圣种　　决成无上觉
  才生如是心　　即得入初地
  志乐不可动　　勤修正加行
  多喜多爱乐　　亦复多净信
  极大勇猛心　　及多庆跃心
  远离于斗诤　　恼害及嗔恚
  惭敬而质直　　善守护诸根
  救世无等者　　所有众德慧
  此处我当得　　念是极生喜
  始得入初地　　即超五怖畏
  不活恶名死　　恶趣处众怯
  由不贪着我　　及以于我所
  是故诸佛子　　远离诸怖畏
  恒有信恭敬　　常行大慈愍
  惭愧功德备　　日夜增善法
  乐游正法苑　　无厌求多闻
  思惟所闻法　　远离取着行
  不贪于利养　　唯引平等心
  一志求佛智　　缘虑十力等
  修行到彼岸　　远离谄虚诳
  如说而修行　　常能护实语
  不污如来家　　不舍菩萨学
  一切智智心　　不动如山王
  不舍世间事　　而入出世道
  以无厌足心　　修觉分资粮
  常恒无异念　　转求增胜道
  如是法相应　　名善住初地
  引发大誓愿　　大勇决大行
  愿当能供养　　承事诸世尊
  护持诸佛法　　摄取大仙道
  常奉觐诸佛　　修行最胜行
  成就诸群生　　往趣诸世界
  严净佛国土　　令智者充满
  与诸菩萨众　　一心等修行
  以身语意业　　所作无空过
  一切毛道中　　一时成正觉
  如是等大愿　　无量无边际
  若有情界尽　　世界虚空界
  法界涅槃界　　世间佛兴界
  诸如来智界　　及心所缘界
  入如来智界　　世法智转界
  彼诸若有尽　　我愿乃有尽
  如彼无尽期　　我愿亦无尽
  如是发大愿　　心柔软调顺
  能信佛功德　　观察诸有情
  知从因缘起　　即兴大慈悲
  如是苦有情　　我今应救拔
  为救有情故　　而行种种施
  王位与珍宝　　及以象马车
  头目并手足　　乃至身血肉
  一切皆能舍　　心得无忧悔
  求种种诸论　　其心无厌倦
  善解字义趣　　能随世所行
  惭愧自庄严　　修行转坚固
  供养无量佛　　恭敬而尊重
  如是常修习　　日夜无懈倦
  善根转明净　　如金数烧炼
  菩萨住于此　　炼治一切地
  所作无障碍　　具足不断绝
  譬如大商主　　为领诸商侣
  问知道险易　　安隐至大城
  菩萨住初地　　应知亦如是
  勇猛无障碍　　乃到第十地
  住此初地中　　作大功德王
  以法化有情　　慈心无损害
  统领赡部洲　　化行靡不及
  皆令住大舍　　成就佛智慧
  欲求最胜道　　舍已国王位
  佛教中出家　　勇猛勤修习
  得百三摩地　　及见百诸佛
  震动百世界　　游行照亦尔
  成就百有情　　能知百劫事
  入于百法门　　示现百化身
  及现百菩萨　　以为其眷属
  若愿自在力　　过是数无量
  我于地义中　　略述其少分
  若欲广分别　　亿劫不能尽
  菩萨最胜道　　利益诸群生
  如是初地法　　我今已说竟

    菩萨离垢地第二

  诸菩萨闻此　　最胜微妙法
  其心尽清净　　一切皆欣庆
  悉从于座起　　踊在虚空中
  普散上妙花　　同时共称赞
  善哉金刚藏　　大智无畏者
  善说于此地　　菩萨所行法
  解脱月菩萨　　知众心清净
  乐闻第二地　　所有诸行相
  即请金刚藏　　大慧愿演说
  佛子皆乐闻　　所住第二地

尔时金刚藏菩萨告众菩萨言。唯诸佛子。若是菩萨善莹初地欲求第二菩萨智地。当起十种心之意乐。何等为十所谓正直意乐。柔软意乐。堪能意乐。调伏意乐。寂灭意乐。贤善意乐。不杂意乐。无顾恋意乐。胜妙意乐。广大意乐。起此十种心意乐已。即得安住菩萨第二离垢地中。唯诸佛子菩萨住此离垢地时。自性成就十善业道。远离杀生弃舍刀杖不怀嗔恨。有惭有愧仁恕具足。于诸有情有命之者。常有慈愍利乐之心。而此菩萨尚以计度。于有命者不作恼害。何况于他诸有情所起有情想。正意思惟以粗身业而行杀害。离不与取于自财位常知止足。有愍不坏他财位。若物属他有他物想终不于此发起盗心。乃至草叶不与不取。何况其余诸资生具离欲邪行于自妻属常知止足。不求他妻于属他女及他妻妾亲族媒定法。所护女尚不发生贪染之心。何况彼此二形交婚或于非道。离虚诳语常作实语真语时语。乃至梦中亦不能覆见忍乐照以诳他意出虚诳语。何况故犯。离离间语。为诸有情常不破坏。无恼害故而修正行。不将此语为破彼故而向彼说。不将彼语为破此故而向此说。于未坏者令不破坏。已破坏者令不增长。不喜离间不乐离间不说离间语。若实若不实。离粗恶语。谓所有语蜥螫粗犷碜刺于他。令他嗔恨背面惨厉。庸浅鄙恶不可乐闻闻者。不悦嗔忿所出。如火烧心令生怨结。意起热恼不可爱乐。能坏自他心心相续。如是等语悉皆远离。常作润泽柔软悦意。深可乐闻闻者生喜善入于心。风雅典则多人爱乐。多人悦乐。令心踊跃令心悦豫。能净自他心相续语离杂秽语。善思审语时语真语。义语法语。顺道理语巧调伏语。有分段语随时筹量有缘起语。乃至戏笑尚恒思审。何况故出散乱之言。其心无贪于他欲乐及他财位他资具中。不起贪爱不求不愿不生贪心。心无嗔恚常于一切诸有情类发起慈心及利益心怜愍心安乐心润泽心摄益一切世间之心。永离忿恨嫉妒嗔恚。常思顺行仁慈祐益性。得正见随顺正道。舍离种种占卜吉凶邪戒者。见其见正真无谄无诳。于佛法僧起定意乐。唯诸佛子菩萨如是无间无缺护持十善业道之时。引发如是心之意乐。有情所有险秽恶趣深坑施设此。悉皆由受行十种不善业道。是故我当自住正行。亦劝于他住于正行。所以者何。若自不能修行正行。令他修者无有是处。复作是念由现受十不善业道。有捺落迦傍生鬼趣。复由现受十善业道。方有人趣乃至有顶受生差别。从此已上由慧行相修习。即此十善业道心狭劣故。怖三界故。阙大悲故。从他闻声而解了故。随声闻行故。成声闻乘。又从此上修治清净十善业道。非他所引自觉悟故。阙大悲方便故。悟解甚深缘起性故成独觉乘。复从此上修治清净十善业道。由心广大无限量故。具悲愍故。方便善巧之所摄故。发大愿故。不舍一切诸有情故。现观如来无量智故。能成菩萨诸地清净到彼岸。净广大正行。又此上上十善业道。以一切种得清净故。乃至能成诸佛十力及余一切佛法修证。是故我今于同出离。遍于一切行相清净出离之中应作加行唯诸佛子菩萨转更应如是学。复次十种不善业道。以由上品积集多作为捺洛迦因。由中品故为傍生因。由软品故为鬼界因。害生将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者短命。二者多病。不与取将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者乏少资财。二者共分资财。于欲邪行将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者妻不贞良。二者眷属不可依怙。虚诳语将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者多被诽谤。二者为他所诳。离间语将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者眷属乖离。二者多被毁呰。粗恶语将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者闻不可意。二者言多诤讼。杂秽语将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者言无人受。二者辩不明了。贪欲将导于捺落迦。将导傍生将导鬼界。若复人中受生引二种果。一者心不知足。二者多欲无厌。嗔恚将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者常被他人求其长短。二者恒被于他之所恼害。邪见将导于捺落迦。将导傍生。将导鬼界。若复人中受生引二种果。一者堕在邪见。二者心多谄诳。如是此十不善业道能生此等无量无边诸大苦蕴。是故我今永离此十不善业道。于内法苑赏玩法乐。即此菩萨自善安住十善业道亦劝于他令住其中

复次菩萨。于有情所转更发起利益心安乐心悲心怜愍心摄受心守护心自己心轨范心发起师心。此作是念。苦哉有情堕在邪见。随邪思量。顺邪意乐。行于僻路稠林之中。我应令彼归于正趣正见之道。令得安住如实法中。是诸有情互相乖离违诤欺凌。常无间断忿恨炽然。我当令彼住于无上大慈之中。是诸有情心无厌足希求他财邪命自活。我当令彼住于清净身语意业正命法中。是诸有情随贪嗔痴因缘而转。常以种种烦恼火焰之所烧爇。不复访求出要方便。我当令彼除灭一切烦恼炽火。住无灾患清凉涅槃。是诸有情痴昏翳瞙无明黑暗之所覆蔽。入在广大黑暗稠林。远离慧明堕大暗处。趣入见取险难之路。我当令彼得无障碍清净慧眼。能知一切法如实性不随他教。是诸有情驰骋生死旷野险道。将堕地狱傍生饿鬼恶趣深坑。投妄恶见邪见緪网。愚痴榛梗之所覆蔽。行邪僻路。丧失慧目。阙大导师。有非出离想游波旬境。劫贼所擒远离大悲善巧导者。趣入诸魔意乐稠林。去佛意乐极为深远。此诸有情我当从彼如是生死旷野险难救拔济度。令得安住一切智智无畏大城。是诸有情没大瀑流。波浪沦溺入欲有见。无明瀑流沿生死驶爱河漂转。湍驰奔激不暇观察。随顺欲恚害觉弥漫。身见罗刹之所执持。趣入欲习气洄澓旋返。于中沉溺欣乐淤泥洪涛漂掷。我慢滩渚无有依怙。不能超越六处聚落。远离善巧能济度者。我以大悲善根势力。救拔令住于无灾患离尘寂静。无诸恐怖一切智洲。是诸有情闭在于彼多苦愁恼忧。随非爱爱憎连缚。常与愁叹相应。随转渴爱械鋜之所捡系。无明昏暗稠林。覆障三界牢狱。我当令彼永离三界。住无障碍究竟涅槃。是诸有情执着于我。从蕴执藏不能胜进。随顺四种颠倒而行。依止六处空旷聚落。被四大种毒蛇迫逐。五蕴怨贼之所娆害受无量苦。我当令彼住于最胜无依着处。谓于离障无余涅槃。是诸有情胜解下劣怯弱狭小。闻兴无上一切智心。设求出离唯发声闻独觉乘意。我当令观微妙佛法。住于广大无上道心。唯诸佛子菩萨。如是随顺净戒力所住持。善巧引发诸所作事。住于菩萨离垢地时。由广大见及由愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛多百俱胝佛多千俱胝佛多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。于诸如来正等觉所。以尊重心复更咨受十善业道随其所受。乃至菩提终不忘失。由是菩萨于无量劫无量百劫无量千劫无量百千劫无量俱胝劫无量百俱胝劫无量千俱胝劫无量百千俱胝劫无量百千俱胝那庾多劫。远离悭吝犯戒垢故布施净戒清净成满。唯诸佛子。譬如真金置矾石中。如法炼已离一切垢转复明净。菩萨住此离垢地中亦复如是。于无量百千俱胝那庾多劫远离悭吝犯戒垢故布施净戒清净成满。然此菩萨四摄法中爱语偏多。十到彼岸中戒到彼岸而为增上。余到彼岸随力随分非不修行。唯诸佛子是名略说菩萨第二离垢地也。菩萨住此受生多作转轮圣王。得法自在七宝具足。有自在力能除有情犯戒之垢。善巧令彼有情安处十善业道。诸所作业或以布施或以爱语或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意诸地作意。无所畏作意不共佛法作意。乃至不离一切行相胜妙相应一切智智作意。复作愿言。我当一切诸有情中。为首为胜为殊胜。为妙为微妙为上为无上。为导为将为师。乃至愿得一切智智所依止处。若乐发起如是精进。弃舍一切家属财位。归佛圣教净信出家。既出家已。一刹那顷瞬息须臾。能证菩萨千三摩地。能见千佛彼佛加持皆能解了能动千世界。能往千刹土。能照千世界。成就千有情。能住寿千劫。于前后际能入千劫。于千法门能正思择。示现千身身皆能现千菩萨眷属围绕。自此以去是诸菩萨。有愿力者由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫。不易可数。尔时金刚藏菩萨欲重宣此义而说颂言

  正直柔软及堪能　　调伏寂灭与贤善
  无杂无恋胜广大　　以十意乐入二地
  住此成就戒功德　　远离杀生无恼害
  离不与取欲邪行　　诳恶乖离杂秽语
  不贪财位常慈愍　　正见直心无谄伪
  离险奢慢极调柔　　依教而行不放逸
  地狱傍生受众苦　　饿鬼烧然出猛焰
  一切皆由罪所致　　我当离彼住法苑
  人中随意得受生　　乃至有顶诸喜乐
  声闻独觉佛乘道　　皆因十善而成就
  如是思惟不放逸　　自持净戒教他护
  复见群生受众苦　　转更增益大悲心
  凡愚邪智不正解　　常怀忿恨多诤讼
  贪求境界无足期　　我应令彼除三毒
  愚痴大暗所缠覆　　入大险道邪见网
  生死旷野怨所拘　　我应令彼摧魔贼
  四流漂荡心没溺　　三界禁系受众苦
  计蕴为宅我在中　　为欲度彼勤行道
  设求出离心下劣　　舍于最上佛智慧
  我欲令彼住大乘　　发勤精进无厌足
  菩萨住此集功德　　见无量佛咸供养
  亿劫修治善更明　　如炼真金以矾石
  佛子住此作轮王　　普化有情行十善
  所有善法皆修习　　为成十力救于世
  欲舍王位及财宝　　即弃居家依佛教
  勇猛精进一刹那　　获千等持见千佛
  所有种种神通力　　此地菩萨皆能现
  愿力所作复过此　　无量自在度群生
  一切世间利益者　　所修菩萨最胜行
  如是第二地功德　　为诸佛子已开演

    菩萨离垢地第二竟

佛说十地经卷第二佛说十地经卷第三

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨发光地第三

  佛子闻此地行已　　菩萨境界难思议
  靡不恭敬心欢喜　　散花空中为供养
  赞言善哉大仙主　　慈心愍念诸有情
  善说智者律仪法　　第二地中之行相
  是诸菩萨微妙行　　真实无异无差别
  为欲利益诸群生　　如是演说最清净
  一切天人供养者　　愿为演说第三地
  与法相应诸智业　　如其境界为具阐
  大仙所有施净戒　　安忍精进静虑慧
  及以方便慈悲道　　佛清净道愿皆说
  时解脱月复请言　　无畏大师金刚藏
  愿说趣入第三地　　柔和心者之功德

尔时金刚藏菩萨告众菩萨言。唯诸佛子若是菩萨。第二地中增上意乐善清净已。欲入菩萨第三地者。当以十种心之意乐作意而入。何等为十。所谓以清净心意乐作意。以安住心意乐作意。以厌离心意乐作意。以离欲心意乐作意。以不退心意乐作意。以坚固心意乐作意。以炽然心意乐作意。以勇健心意乐作意。以胜妙心意乐作意。以广大心意乐作意。菩萨以是十心意乐作意证入第三地中。唯诸佛子菩萨住此第三地时。观察一切诸有为行。皆见无常有苦不净不可依怙。终皆败坏不得久住。刹那生灭前际不来后际不去。现在不住。菩萨如是无倒观察一切行时。复观见身无有救者无所依怙。与忧与叹与恼相应。爱憎所系多苦愁恼。无有停积。以贪恚痴猛火炽然共众病长。见如是已从一切行令心胜进趣如来智印。此菩萨见如来智不可思议无等无量。难得无杂无灾无恼。至无畏城不复退还。能救无量诸苦有情。菩萨如是见如来智无量利益见一切行无量灾患。则此转更于有情所。发起十种心之意乐。何等为十。所谓孤独无依心之意乐。常恒贫穷心之意乐。以贪恚痴猛火炽然心之意乐。于有牢狱之所禁闭心之意乐。常无间断以诸烦恼稠林所覆心之意乐。不能观察心之意乐。无善法欲心之意乐。迷失佛法心之意乐。随生死流心之意乐。失解脱道心之意乐。发此十种心之意乐。菩萨如是见有情界众灾患已。发大精进作是念言。此诸有情我应救济应令解脱。应令清净应当拔出应令趣入应令安住。应令欢喜应令爱乐。应令调伏应令寂灭。菩萨如是于彼诸行深心厌离。于诸有情兴悲恋心。于佛妙智见大胜利。以如来智为所依止。为救有情勤修加行作是思惟。此诸有情堕在众苦烦恼杂染。以何等道而能拔济。令住究竟常乐涅槃。即此菩萨便作是念。此皆不离以无障碍智解脱处。此无障碍智解脱。不离一切法如实觉。此一切法如实觉悟。不离无行无生行慧。此慧光明。不离静虑善巧决择妙慧观察。复此静虑善巧决择妙慧观察。皆不离于多闻善巧。菩萨以是善观察智。专为访求正法而行。日夜慕法闻法无厌。玩法乐法依法靡法。住法须法怙法归法法随法行。菩萨如是为求佛法修正行时。无有少物或资生具。或财谷仓库而不能舍。于此终无难作之想。唯于说法补特伽罗生难遭想。为佛法故无有少分执受外物而不能舍。无少内物而不能舍。无有师长不誓承事。除慢过慢。下意受行。无有身苦而不誓受。若闻佛法一四句颂欢喜踊跃。胜得三千大千世界充满其中大珍宝聚。若闻一颂善说正法。欢喜胜得转轮王位闻未闻法是佛所说。能引正等觉能净菩萨行欢喜踊跃。胜得一切释梵王等。住百千劫极尊贵位。设有告言我有一句。佛所说法能引正等觉能净菩萨行。汝今若能投极炽然大焰火坑。受剧苦者当为汝说。菩萨闻已作是念言。我为一句佛所说法。能引等正觉能净菩萨行。正使火坑量等三千大千世界。满中炽火我从梵天尚投身入。况小火坑。又复我等为求佛法。尚应久处大捺落迦诸险恶趣受大苦恼。况于人中诸余小苦而不能受。菩萨发起如是精进求正法已。如其所闻而能如理内审观察。闻正法已独居静处心自决了作是思惟。以正修行法随法行。方得名为随顺佛法。非但纯以语业演说而得清净。菩萨住是发光地时。为欲修行法随法行。离欲离诸恶不善法。有寻有伺。离生喜乐。入初静虑具足安住。寻伺寂静内等净故一心趣故。无寻无伺定生喜乐。入第二静虑具足安住。于喜离欲安住于舍正念正知。有身受乐。于是处所。诸圣宣说。具足舍念及以正知。住身受乐入第三静虑具足安住。乐断苦断先喜忧没。不苦不乐舍念清净。入第四静虑具足安住。又此菩萨超一切种色之想故。灭没一切有对想故。以不作意种种想故知无边虚空。入空无边处具足安住。超一切种空无边处。知无边识。入识无边处具足安住。超一切种识无边处。知无所有。入无所有处具足安住。超一切种无所有处。知非想非非想。入于非想非非想处具足安住。但为随顺法随法行。不以乐着安足处也

复次菩萨修慈俱心。广大无二无量无恨无怨无障无所恼害。遍至一切极于法界尽虚空性。诸世界中以慈普覆一切世间具足安住。修悲俱心修喜俱心亦复如是。修舍俱心广大无二无量无恨无怨无障无所恼害。遍至一切极于法界尽虚空性。诸世界中以舍普覆一切世间具足安住。复次菩萨受用无量诸神变事震动大地。一身为多身多身为一身。或显或隐迅疾无碍。墙壁山嶂皆能彻过如行于空。于虚空中跏趺而去犹如飞鸟。出没于地犹若水中。履水如地。身出烟焰如大火聚。从身注水喻如大云。此之日月大神德有大威势。以手扪摸乃至梵世转身自在。以天耳界清净过人悉闻人天二种音声。若近若远乃至蚊蚋蜣螂等悉闻其声。以他心智如实而知他有情心。所谓有贪心如实知有贪心。离贪心如实知离贪心。有嗔离嗔有痴离痴有染离染。狭小广大无量聚散。住定出定已得解脱未得解脱。有亹无亹粗心细心皆如实知。菩萨如是以他心智。于他有情他数取趣心之所念心自了知。以宿住智随念。无量诸宿住事谓能随念。自他一生二三四五至十二十三四五十。乃至百生多百多千多百千生。成劫坏劫及成坏劫乃至随念。无量成坏劫随念百劫随念千劫百千劫俱胝劫百俱胝劫千俱胝劫百千俱胝劫。乃至无量百千俱胝那庾多劫皆能随念。谓我宿生曾在某处。如是名如是性如是种族如是形貌。如是饮食如是寿量如是久住如是苦乐。从彼处没来生此处。从此处没往生于彼。如是形貌如是言说。若略若广诸宿住事皆能随念。以天眼界清净过人。见诸有情死时生时。好色恶色善趣恶趣。若劣若胜随业所行。诸有情类皆如实知。谓彼有情成就身语及意恶行。诽谤贤圣具足邪见由邪见业。现受因缘身坏命终。堕险恶趣生捺落迦。复彼有情成就身语及意善行。赞美贤圣成就正见由正见业。现受因缘身坏命终。当升善趣生于天中受诸快乐。菩萨如是以天眼界清净过人。以共形貌以共言说。见诸有情死时生时。好色恶色善趣恶趣。若劣若胜随业所行。诸有情类皆如实知。而此菩萨于彼静虑解脱等持及诸等至。随意入出而不由彼威力受生。若见彼处速能圆满菩提分法故。以愿力而生其中。菩萨住此发光地已。由广大见及由愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛多百俱胝佛多千俱胝佛多百千俱胝佛多百千俱胝那庾多佛。菩萨见是如来应正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。殷重奉事诸佛如来。于其佛所恭敬听法。闻已受持随分修行。复次菩萨观一切法无有移转。亦无坏灭因缘而有。而此菩萨一切欲缚皆转微薄。一切色缚一切有缚诸无明缚皆转微薄。一切见缚先已除断。菩萨住是发光地中。于无量劫无量百劫无量千劫无量百千劫。无量百千那庾多劫无量俱胝劫无量百俱胝劫无量千俱胝劫无量百千俱胝劫无量百千俱胝那庾多劫。不积集故邪贪除断。不积集故邪嗔除断。不积集故邪痴除断。所有善根转更明净。唯诸佛子譬如真金。善巧金师自手炼治。离诸垢已称量不减菩萨住此发光地中亦复如是。无量百劫乃至无量百千俱胝那庾多劫。由不积集邪贪除断。由不积集邪恚除断。由不积集邪痴除断。所有善根转更明净。又此菩萨转更安忍。柔和意乐而得清净。又悦美意乐。不嗔意乐。不动意乐。不浊意乐。无高下意乐。不希有情意下意乐。不望酬报意乐。无谄诳意乐。不稠林意乐皆转清净。而此菩萨四摄事中利行偏多。十到彼岸中忍到彼岸而得增上。余到彼岸随力随分非不修行。唯诸佛子是名略说菩萨第三发光地也。菩萨安住于此地中。受生多分作释天帝。有自在力善化有情。令离欲贪善拔救护没欲泥者。诸所作业。或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意。到彼岸作意。诸地作意。佛力作意。无所畏作意。佛不共法作意。乃至不离一切行相胜妙相应一切智智作意。复作愿言。我当一切有情中。为首为胜为殊胜。为妙为微妙。为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。弃舍一切家属财位归依圣教净信出家。即一刹那顷瞬息须臾。能证百千诸三摩地。能见百千诸佛如来。彼佛加持皆能解了。能动百千世界。能往百千刹土。能照百千世界。能成熟百千有情。能住寿百千劫。于前后际能入百千劫。于百千法门能正思择。示现百千身身身皆能现百千菩萨。眷属围绕。从此以上是诸菩萨有愿力者。由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨。欲重宣此义而说颂曰

  清净安住厌离心　　离欲无退及坚固
  炽然勇健胜妙广　　以此十心入三地
  菩萨住于此地中　　观行无常苦不净
  无怙败坏不久停　　迁变无住无来往
  观身无救无依怙　　有忧有恼续爱憎
  多苦不停或火然　　与病俱有无休息
  厌离三有求佛智　　见彼妙智不思议
  无等无量难证悟　　无杂无灾无逼恼
  归大寂灭无退转　　能救无量苦有情
  见佛智已愍众生　　孤独无依无救护
  三毒炽然常困乏　　住诸有狱恒受苦
  烦恼习覆无慧目　　志乐下劣丧法宝
  随顺生死怖涅槃　　我应救彼勤精进
  将求智慧益有情　　思何方便令解脱
  不离处佛无碍智　　斯由觉法如实理
  觉由无行无生慧　　慧从定发定由闻
  如是思惟自策励　　日夜听习尊重法
  为闻正法起敬心　　国城资具诸珍宝
  妻子眷属及王位　　如是一切皆能舍
  头目耳鼻舌牙齿　　手足骨髓心血肉
  此等皆舍未为难　　但于法师生难想
  设有人等语菩萨　　孰能投身大火坑
  我当与汝佛法宝　　闻以投之无怯惧
  假使火满三千界　　身从梵世而投入
  为求法故不为难　　况复人间诸小苦
  从初发意至菩提　　其中设有无间苦
  为闻法故皆能受　　何况人中诸苦事
  闻已如理正思惟　　获四静虑四等至
  四无量心五神通　　不随其势而受生
  菩萨住此见多佛　　供养听闻心决定
  断诸邪惑转净明　　如炼真金体无减
  住此多作释天帝　　化导无量诸有情
  令舍贪心住善道　　一切专求佛功德
  住此精进刹那顷　　能证百千三摩地
  见百千佛相严身　　若具愿力复过是
  一切有情普利乐　　彼诸菩萨最上行
  如是所有第三地　　我依其义已解释

    菩萨发光地第三竟

    菩萨焰慧地第四

  佛子闻此广大行　　可乐深妙殊胜法
  心皆勇悦大欢喜　　普散众花供养佛
  演说如是妙法时　　大地海水皆震动
  一切天女咸欢喜　　悉吐妙音同赞叹
  自在天王大欣庆　　雨摩尼宝供养佛
  赞言佛为我出兴　　演说第一功德行
  如是智者诸地义　　于百千劫甚难遇
  我今忽然而得闻　　菩萨胜行妙法音
  愿更演说聪慧者　　后决定地无余道
  利益一切诸大众　　此诸佛子皆乐闻
  勇猛大心解脱月　　请金刚藏言佛子
  从此转入第四地　　所有行相愿宣说

尔时金刚藏菩萨告众菩萨言。唯诸佛子若是菩萨。第三地明善清净已。欲入菩萨第四智地。当以十种法明而入。何等为十。所谓以有情界思察明入。以诸世界思察明入。以真法界思察明入。以虚空界思察明入。以识界思察明入。以欲界思察明入。以色界思察明入。以无色界思察明入。以妙意乐胜解界思察明入。以广大意乐胜解界思察明入。菩萨以此十法明入升第四地。唯诸佛子菩萨才得焰慧地已。则由十种智成熟法。长如来家得彼体法。何等为十谓由意乐不退转故。于三宝中不坏净信至究竟故。观察诸行生灭性故。观辩诸法性不起故。观世间成坏故。观业有生有死故。观生死涅槃故。观有情刹业故。观前际后际故。观无性无尽故。唯诸佛子菩萨成就如是十种智成熟法。长如来家得彼体法

复次诸佛子菩萨住此焰慧地时。随于内身住循身观。炽然精进正知具念除世贪忧。随于外身住循身观。炽然精进正知具念除世贪忧。随内外身住循身观。炽然精进正知具念除世贪忧。于内受于外受于内外受亦复如是。于内心于外心于内外心亦复如是。随于内法住循法观。炽然精进正知具念除世贪忧。随于外法住循法观。炽然精进正知具念除世贪忧。随内外法住循法观。炽然精进正知具念除世贪忧

复次菩萨。于诸未生恶不善法为不生故。生欲策励发起精勤策心持心。于诸已生恶不善法为永断故。生欲策励发起精勤策心持心。于未生善法为令生故。生欲策励发起精勤策心持心。于已生善法为令安住不忘。增广倍修满故。生欲策励发起精勤策心持心。复次菩萨。修欲等持断行成就神足依离依无染依灭回向舍。修勤等持断行成就神足依离依无染依灭回向舍。修心等持断行成就神足依离依无染依灭回向舍。修观等持断行成就神足依离依无染依灭回向舍。复次菩萨。修信根依离依无染依灭回向舍。修精进根依离依无染依灭回向舍。修念根依离依无染依灭回向舍。修定根依离依无染依灭回向舍。修慧根依离依无染依灭回向舍

复次菩萨。修信力依离依无染依灭回向舍。修精进力依离依无染依灭回向舍。修念力依离依无染依灭回向舍。修定力依离依无染依灭回向舍。修慧力依离依无染依灭回向舍。复次菩萨修念等觉支依离依无染依灭回向舍。修择法等觉支依离依无染依灭回向舍。修精进等觉支依离依无染依灭回向舍。修喜等觉支依离依无染依灭回向舍。修轻安等觉支依离依无染依灭回向舍。修定等觉支依离依无染依灭回向舍。修舍等觉支依离依无染依灭回向舍。复次菩萨修正见依离依无染依灭回向舍。修正念依离依无染依灭回向舍。修正思惟依离依无染依灭回向舍。修正语依离依无染依灭回向舍。修正业依离依无染依灭回向舍。修正命依离依无染依灭回向舍。修正精进依离依无染依灭回向舍。修正定依离依无染依灭回向舍。修正慧依离依无染依灭回向舍。菩萨修此菩提分法。但于一切诸有情界有悲恋故。引发本愿所扶持故。以大悲愍为先导故。成就大慈故。缘虑一切智者智故。引发佛刹诸庄严故。引发如来力无所畏不共佛法相好言音故。希求后后殊胜法故。随顺甚深解脱佛法所闻行故。观察广大方便善巧故。唯诸佛子。菩萨住此焰慧地时。所有微细身见等惑。谓我有情命者育者士夫。数取趣蕴界处执。所起动乱思惟伺察。护持摄受畜积着处。如是一切皆悉远离。所有一切不应作业。诸佛所诃杂染所引。如是一切皆悉舍离。所有应作能顺菩萨正行资粮。一切如来赞美之业皆悉受行。复次展转为菩萨道得圆满故。如如方便慧所引发。修诸道支如是如是。得滋润心柔和之忍。有堪能心引利乐心无杂染心。访求后后殊胜法心。希胜智心。能救一切世间之心。尊重随顺诸师长心。如所闻法而修行心。又善知恩善知报恩。其心调和共住安乐。质直柔软无稠林行无诳无慢。善顺语者右受教诲。菩萨如是安忍成就调伏成就寂灭成就。如是忍调寂灭成就思惟现行。能净上地诸业之时。获大精进无有休息。不杂染精进不退转精进。广大精进无边精进。炽然精进无等精进。无映夺精进。成熟一切有情精进。善分别道非道精进。又此菩萨善意乐界转更清净。增上意乐界不遗失。胜解明利善根得净。离世垢浊断诸疑惑。无疑之性现前具足证喜轻安。如来加持而得现前。无量心意乐皆悉成就。菩萨住此焰慧地中。以广大见及以愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛多百俱胝佛多千俱胝佛多百千俱胝佛多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。殷重奉事诸佛如来。于其佛所恭敬听法。闻已受持随分修行多分。于彼诸佛圣教净信出家。于此菩萨所有意乐增上意乐。胜解平等性转复清净。菩萨住此焰慧地已。复更无量百千俱胝那庾多劫。此之意乐胜解平等清净而住。所有善根转复炽然转更明净。唯诸佛子如巧金师。以所炼金作庄严具。非余未作庄严具金之所映夺。唯诸佛子菩萨安住焰慧地中亦复如是。所有善根非余安住下地菩萨。所有善根而能映夺。又诸佛子如摩尼宝。清净光轮。所放光明。非余宝珠所能映夺。所放光明一切世间风水雨等不能断灭。唯诸佛子菩萨住此焰慧地时亦复如是。非余安住下地菩萨能所映夺。所有慧光一切魔怨。烦恼现行不能断灭。而此菩萨四摄事中同事偏多。十到彼岸中精进到彼岸而得增上。余到彼岸随力随分非不修行。唯诸佛子是名略说菩萨第四焰慧智地。菩萨住此第四地中。受生多作苏夜摩天王。有自在力善化有情。令其除灭萨迦邪见。能令有情安住正见。诸所作业或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意佛不共法作意。乃至不离一切行相胜妙相应一切智智作意。复作愿言。我当一切诸有情中为首为胜为殊胜。为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进一刹那顷瞬息须臾。能证俱胝诸三摩地见俱胝佛。彼佛加持皆能解了。能动俱胝世界。能往俱胝佛刹。能照俱胝世界。能成熟俱胝有情。能住寿俱胝劫。于前后际能入俱胝劫。能正思择俱胝法门。能示现俱胝身。身身皆能现俱胝菩萨眷属围绕。从此以上是诸菩萨有愿力者。由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫。不易可数。尔时金刚藏菩萨。欲重宣此义而说颂言

  菩萨已净第三地　　次观有情世法界
  空识欲色无色界　　胜大意乐能趣入
  菩萨才登焰慧地　　长如来家永不退
  于佛法僧信不坏　　观法生灭无生起
  观世成坏业有生　　生死涅槃刹等业
  观前后际无性尽　　如是修行长佛家
  得是法已增慈愍　　转更勤修四念住
  身受心法内外观　　世间贪爱皆除遣
  菩萨修治四正断　　恶法除灭善增长
  善修神足及根力　　七等觉支八圣道
  为度有情修觉分　　本愿扶持慈悲首
  求一切智严佛土　　亦缘如来十种力
  四无所畏不共法　　殊特相好深美音
  亦求妙道解脱处　　寻大方便修觉分
  身见为首六十二　　我及我所无量种
  蕴界处等诸取着　　第四地中悉远离
  如来所诃烦恼杂　　无义之业皆舍离
  诸佛所赞清净业　　为度有情无不作
  菩萨勤修不懈怠　　即得十心皆具足
  专求佛道无厌倦　　希受灌顶度有情
  恭敬尊德修法行　　知恩易悔无愠暴
  舍慢离谄心调柔　　转更精勤不退转
  又其意乐界清净　　增上意乐永不失
  胜解决定善根增　　疑网垢浊悉永离
  无疑现前得喜安　　蒙佛加持无量志
  菩萨住此焰慧地　　供那庾多无量佛
  听闻正法亦出家　　不可映夺如金饰
  菩萨住此具功德　　以智方便修行道
  不为众魔心退转　　譬如妙宝无能坏
  多作夜摩天中王　　于法自在众所尊
  普化众生除恶见　　专求佛智修善业
  菩萨勤加精进力　　获等持等俱胝数
  若以愿智力所为　　过于此数无能算
  如是菩萨第四地　　所行精进微妙道
  功德义智共相应　　我为佛子已宣说

佛说十地经卷第三佛说十地经卷第四

        大唐于阗三藏尸罗达摩于北庭龙兴寺译

    菩萨难胜地第五

  菩萨闻此胜地行　　于法解悟心欢喜
  空中雨花赞叹言　　善哉大士金刚藏
  自在天王与天众　　闻法踊跃住虚空
  普放种种妙光云　　供养如来喜充遍
  天诸婇女奏天乐　　亦以言词歌赞佛
  悉以菩萨威神故　　于彼声中发是言
  佛愿久远今乃满　　佛道久远今乃得
  释迦文佛至天宫　　利天人者久乃见
  大海久远今始动　　佛光久远今乃放
  有情久远始安乐　　大悲音声久乃闻
  功德彼岸皆已到　　憍慢黑暗皆已灭
  尊极清净如虚空　　不染世法如莲花
  大牟尼尊现于世　　譬如须弥出巨海
  供养能尽一切苦　　供养必得诸佛智
  此应供处供无等　　是故欢心供养佛
  如是无量诸天女　　发此言词称赞已
  一切恭敬喜充满　　瞻仰如来默然住
  是时大士解脱月　　复请无畏金刚藏
  第五地中之行相　　愿为佛子今演说

尔时金刚藏菩萨告众菩萨言。唯诸佛子若是菩萨。第四地道善圆满已。欲入菩萨第五地中。当以十种平等清净心意乐入。何等为十。所谓过去佛法平等清净意乐。未来佛法平等清净意乐。现在佛法平等清净意乐。戒平等清净意乐。定平等清净意乐。除见疑惑平等清净意乐。道非道智平等清净意乐。断智平等清净意乐。一切菩提分法后后观察平等清净意乐。成熟一切有情平等清净意乐。菩萨以是十种平等清净意乐入第五地。唯诸佛子菩萨已至此第五地。由善莹饰觉分道支。由善清净增上意乐。复求后世殊胜道时。为如是事随正行故。愿力所持故。以大慈悲不舍一切诸有情故。积集福智二资粮故无休息故。引发善巧妙方便故。观照后后地光明故。由常勤求佛加持故。念慧趣觉力所持故。得不退转正作意已。如实了知此苦圣谛。此是苦集此是苦灭此能灭苦。正行圣谛皆如实知。又此菩萨于世俗谛而得善巧胜义谛。善巧相谛。善巧差别谛。善巧安立谛。善巧事谛。善巧生谛。善巧于尽无生智谛。善巧于趣入道智谛。善巧一切菩萨地。次第相续已成就故。乃至如来智集谛中而得善巧。复次此菩萨令他有情如其意乐皆欢喜故。知世俗谛以能证入一切理趣故。知胜义谛觉法自相及共相故。善知相谛悟法差别安立义故。知差别谛解了蕴界处安立故。知安立谛了达身心逼恼的故。名知事谛通达诸趣生相续故。能知生谛一切热恼究竟灭故。名为知尽无生智谛。引发无二故。知入道智谛遍以一切行相觉故。一切菩萨地次相续得成就已。乃至能知如来智集谛。此复但由胜解智力。非以究竟智而知之。菩萨如是以谛善巧所引正慧。如实了知一切有为。虚妄诈伪诳惑愚夫。即此菩萨转复一切诸有情所。大悲现前大慈光明。而得发生菩萨如是智力所持。于有情界有所顾恋。希求佛智观察一切诸有为行。前际后际如从前际。无明渴爱所生有情。随生死流之所漂转。从蕴执藏不胜进者增长苦蕴。无我无寿无养育者。无数取趣离我我所皆如实知。如其未来于无所有愚痴爱欲。究竟有断边际出离。或非有者亦如实知。即此菩萨作是思惟。此诸迷倒异生之类甚为可愍。有无数身已灭当灭今亦灭没。如是尽灭不能于身而生厌离。转更增长众苦机关。随生死流不能还返。不能弃舍诸蕴执藏。不能厌离大种毒蛇。不能拔出见慢箭镞。不能息灭贪恚痴火。不能飘荡无明黑闇。不能枯涸渴爱巨海。不求十力大圣导师。随魔意乐稠林而行。常于无际生死溟渤种种寻伺波涛海兽。纷扰之中漂转无息我今为彼如是无量众苦所逼。孤独无救无依无宅无洲无道。盲无目者无明卵[穀-禾+卵]厚膜缠里昏闇所覆诸有情故。独一无侣修集无量福智资粮。以是资粮令彼一切有情当证究竟清净。乃至获得如来十力无碍佛智。菩萨如是以善观察智所引慧所修善根。皆为救护一切有情。为欲饶益一切有情。为欲安乐一切有情。为欲哀愍一切有情。为令有情无诸灾患。为欲解脱一切有情。为欲引起一切有情。为令有情发起净信。为欲调伏一切有情。为欲灭度一切有情而修集之。菩萨安住于此第五难胜地时名具念者不忘正法故。名具慧者智善决了故。名具趣者觉于经趣秘密教故。名惭愧者护自他故。名坚持者不舍律仪及戒行故。名为觉者观处非处得善巧故。名随智行者非他所引故。名随慧行者于有义无义二俱句中得善巧故。名为引发神通者于修引发得善巧故。名为方便善巧者随世间而转故。名为无厌足者善集福德资粮故。名无休息精进者访求智慧资粮故。名无厌倦意乐者集大慈愍资粮故。名为一切有情加行者以能灭度诸有情故。名为不慢求加行者求如来力无畏不共诸佛法故。名善引发作意行者引发佛土诸庄严故。名造种种善业行者集相好故。名为常恒善加行者求佛身语意庄严故。名大尊重能承事者于一切菩萨诸法师所如教行故。名为心无碍者以大方便善巧相续入世间故。名为日夜离余心者唯为成熟一切有情而修行故。菩萨如是勤修行时以依布施成熟有情。又以爱语又以利行又以同事。又以示现端严色身。又以说法又以开示诸菩萨行。又以显示如来大我。又以现示生死过失。又以称赞佛智胜利。引发广大神通游戏。种种方便作用加行。成熟有情。而此菩萨如是精勤成熟有情。其心相续恒趣佛智。善根加行无有退转求胜法故。而勤修学为欲饶益诸有情故世间所有种种书论印玺算计金性等论诸医方论谓疗干痟。癫痫鬼魅损坏蛊毒。及起尸鬼咒诅和合。文笔赞咏歌舞妓乐。戏笑谈说喜乐之处。国城村邑宫宅园苑泉流陂池。花果药草丛林布列。显示金银摩尼真珠。琉璃贝玉珊瑚等性。入于日月星宿地震。诸鸟兽鸣梦相吉凶。所受遍身及支分相。律仪戒行静虑神通。四无量心无色定处。及余所有无恼害事。能引一切有情利乐无罪事业。如是一切皆能引发于诸有情有悲愍故。渐令安住无上佛法。菩萨住此难胜地中。由广大见及由愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛多百俱胝佛多千俱胝佛多百千俱胝佛多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具。病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。殷重承事诸佛如来恭敬尊重。以希有想听闻正法。闻已受持随分修行。多分于彼诸佛圣教。净信出家既出家已。便则能作闻持法师。此复多分以闻行相。逮得总持而为法师。菩萨住此难胜地者。于无量劫此诸善根。转胜炽然而得明净。无量百劫无量千劫无量百千劫无量百千那庾多劫无量俱胝劫乃至无量百千俱胝那庾多劫。此诸善根转胜炽然而得明净。唯诸佛子譬如金师。以所炼金作庄严具。以车磲磨莹转更炽然转复明净。唯诸佛子菩萨住此难胜地中。此诸善根亦复如是。以方便慧思惟观察。更胜炽然转复明净。由智加行功德所引。思惟观察不可映夺。又诸佛子譬如日月。星宿宫殿所有光明。一切风轮不能映夺亦非风共。唯诸佛子菩萨住于难胜地中。于此善根亦复如是。以方便慧智思惟观察随所行故。一切声闻诸独觉等不能映夺。亦非世间余善根共。而此菩萨十到彼岸中。静虑到彼岸而得增上。余到彼岸随力随分非不修行。唯诸佛子是名略说菩萨第五难胜智地。菩萨安住于此地中。受生多作珊睹史多天王。能为自在善化有情令舍一切外道邪法。能令有情住实谛中。诸所作业或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意。佛不共法作意。乃至不离一切行相胜妙。相应一切智智作意。常作愿言。我当一切诸有情中。为首为胜为殊胜。为妙为微妙为上为无上为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进一刹那顷瞬息须臾。证百俱胝诸三摩地。能见百俱胝佛彼佛加持皆能解了。能动百俱胝世界。能往百俱胝诸佛刹土。能照百俱胝世界成熟百俱胝所化有情能住寿量百俱胝劫。于前后际各皆能入百俱胝劫。能正思择百俱胝法门。能示现百俱胝身。身身皆能现百俱胝菩萨眷属围绕。从此以上是诸菩萨。有愿力者由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨欲重宣此义而说颂言

  菩萨第四焰慧地　　所修正行已清净
  便悟三世佛平等　　谓由戒定除见疑
  于道非道并正行　　观察后后觉分智
  成熟有情平等故　　通达此入第五地
  念处为弓根利箭　　正勤为马神足车
  五力坚铠破怨敌　　勇健得入第五地
  惭愧为衣觉分鬘　　净戒芬馥定涂香
  善巧方便妙庄严　　游总持林等持苑
  神足为足正念颈　　慈悲为眼智慧牙
  人中师子无我吼　　殄灭惑兽入五地
  菩萨住此第五地　　转修胜上清净道
  志求佛法不退转　　思念慈悲无厌倦
  积集福智胜功德　　精勤方便观上地
  佛力所加具念慧　　了知四谛皆如实
  善知世谛胜义谛　　相谛差别成立谛
  事谛生尽及道谛　　乃至无碍佛智谛
  如是观谛虽微妙　　未得无碍胜解脱
  以此能生大功德　　是故超过世间慧
  既观谛已知有为　　体性虚伪无坚实
  得佛慈愍光明分　　为利有情求佛智
  观诸有为前后际　　无明昏闇爱缠缚
  流转迟回苦趣中　　无我有情及寿者
  爱取为因受来苦　　欲求边际不可得
  迷妄漂流无返期　　此等可愍我应度
  蕴宅界蛇诸见箭　　欲火猛炽无明闇
  爱河漂转不假观　　苦海沦湑阙明导
  如是知已勤精进　　所作皆为度有情
  名为具念具慧者　　乃至觉解方便者
  习行福智无厌足　　恭敬多闻不疲倦
  庄严刹土引相好　　如是一切为有情
  为欲教化诸世间　　善知书论数印等
  亦能善解诸方药　　疗治众病悉令愈
  文词歌舞皆巧妙　　布列宫宅园池等
  种种宝性咸示人　　利益无量有情故
  日月星宿地震动　　乃至身相亦观察
  静虑等至及神通　　为益世间皆显示
  智者住此难胜地　　供养诸佛及听法
  如以车磲莹真金　　善根转净亦如是
  譬如星宿宫殿光　　非为风轮所映夺
  如莲处泥无染污　　菩萨于世行亦然
  多作睹史多天王　　能摧异道诸邪见
  所修诸善为佛智　　愿得十力济群生
  此若发起大精进　　刹那见百俱胝佛
  得定至现身亦然　　愿力所作过于是
  如是第五难胜地　　人天尊者真实道
  我以种种方便力　　为诸佛子宣说竟　菩萨难胜地第五竟

    菩萨现前地第六之一

  菩萨既闻诸胜行　　其心欢喜雨妙花
  放净光明散宝珍　　供养如来称善说
  百千天众皆欣庆　　共在空中雨众宝
  花鬘缨珞及幢幡　　宝盖涂香咸供佛
  自在天王并眷属　　心生欢喜在空中
  散宝成云持供养　　赞言佛子快宣说
  无量天女空中住　　共以乐音歌赞佛
  声中悉作如是言　　佛语能除烦恼病
  法性本寂无诸相　　犹如虚空离分别
  超诸取着绝言道　　真实等品常清净
  若能通达诸法性　　即于有无心不动
  为欲救世勤修行　　此佛口生真佛子
  不取众相而行施　　本绝诸恶坚持戒
  解法无生常堪忍　　知法性离具精进
  烦恼已尽而入禅　　善达性空分别法
  具足智力能广济　　灭除众恶称大士
  如是妙音千万种　　赞已默然瞻仰佛
  解脱月言金刚藏　　以何行相入后地

尔时金刚藏菩萨告众菩萨言。唯诸佛子若是菩萨。第五地中所修之道善圆满已。欲入菩萨第六地者。当以十种法平等性而入。何等为十。所谓以一切法无相平等。以一切法无自相平等。以一切法无起平等。以一切法无生平等。以一切法寂净平等。以一切法本来清净平等。以一切法无戏论平等。以一切法不取不舍平等。以一切法如幻如梦如影如响如水中月如镜中像。如阳焰水如化平等。以一切法有无不二平等。以此十种法平等性入第六地。菩萨如是观察随莹。随顺不逆一切诸法平等性故。通达第六现前智地。但以猛利须心而证。犹未现得无生忍门。菩萨随行如是自性一切法时。以大悲愍为先导故。以大悲愍为增上故。为欲圆满大悲愍故。观诸世间合散生灭。菩萨观此世生灭时。作是思惟。世间所有受生施设。一切皆由我执而起。若离我执即无世间受生施设。复作是念。此诸异生愚痴无智执着于我。无明眩翳之所覆蔽。求有非有随不如理。作意驰散。奔鹜僻路随邪而行。集福非福不动诸行。而彼有情诸行所植有漏有取心之种子。复续来世生及老死。中有后有业田摄藏。无明闇覆爱水滋润。我慢溉灌见网增盛。生名色种芽生已增长。名色长已五根流转。诸根转已递互与识相对有触。由触相对诸受发生。自后于受欣乐名爱。爱增长取。取增生有。由有生已五蕴发生。五蕴起已于五趣中。渐渐衰变衰已失坏。衰失坏故有诸热恼。因热恼故一切愁叹。及苦忧恼众苦皆集。此之一切无有集者。任运而灭亦无灭者。菩萨如是随顺行相观察缘起

复次菩萨作是思惟。以胜义相于谛无知名为无明无明所作业果名行。行为依止初心名识。与识俱生余四取蕴说为名色。名色增长说为六处。根境与识三事和合名有漏触俱生名受。于受味著名为渴。爱渴爱增长是名为取。从取起有漏业名为有。业等流诸蕴起名为生蕴熟为老蕴坏名死。临死欲坏愚迷之者有贪恋故心热名愁。由愁发语号嗥喟叹。五根相对不悦名苦。意识相对不悦名忧。忧苦所生吁嗞名恼。纯大苦对如是增成。于中永无作者受者。复作是念。由执作者方有作用。既无作者以胜义谛作用亦无。即此菩萨作是思惟。所言三界此唯是心。如来于此分别演说十二有支。皆依一心如是而立。何以故若于事中贪欲相应。心起是识事即是行。于行迷惑是即无明。行与无明及心共生是谓名色。名色增长是谓六处。六处分是谓触。触共生是受。受用之时无厌是爱。爱逼摄受不舍是取。彼有支生起是有。有所起名生。生熟为老。老坏为死。此中无明有二种所作。一所缘故迷惑有情。二为诸行生起与因。诸行亦有二种所作。一能生起未来异熟。二为于识生起与因。识亦有二种所作。一能续有。二为名色生起与因。名色亦有二种所作。一互相资助。二为六处生起与因。六处亦有二种所作。一能现示自境差别。二为于触生起与因。触亦有二种所作一能触所缘。二为于受生起与因。受亦有二种所作。一能领纳爱非爱境及二相违。二为于爱生起与因。爱亦有二种所作。一令可染事中染着。二为于取生起与因。取亦有二种所作。一能续杂染。二为于有生起与因。有亦有二种所作一令后有异趣现前。二为于生生起与因。生亦有二种所作。一能起诸蕴。二为于老生起与因。老亦有二种所作。一令诸根有衰变异。二共死会合生起与因。死亦有二种所作。一能坏诸行二非遍知断

复次于中无明缘行者。无明缘性。谓行不断复有扶助。行缘识者于行缘性。谓识不断复有扶助。识缘名色者于识缘性。谓名色不断复有扶助。名色缘六处者名色缘性。谓六处不断复有扶助。六处缘触者六处缘性。谓触不断复有扶助。触缘受者于触缘性。谓受不断复有扶助。受缘爱者于受缘性。谓爱不断复有扶助。爱缘取者于爱缘性。谓取不断复有扶助。取缘有者于取缘性。谓有不断复有扶助。有缘生者于有缘性。谓生不断复有扶助。生缘老死者于生缘性。谓老死不断复有扶助。无明灭故行灭者。由于无明缘性无故。诸行断灭更无扶助。行灭故识灭者。由于诸行缘性无故。识亦断灭更无扶助。识灭故名色灭者。由于识缘性无故名色断灭更无扶助。名色灭故六处灭者。由于名色缘性无故。六处断灭更无扶助六处灭故触灭者。由于六处缘性无故。触亦断灭更无扶助。触灭故受灭者。由于触缘性无故。受亦断灭更无扶助。受灭故爱灭者。由于受缘性无故。爱亦断灭更无扶助。爱灭故取灭者。由于爱缘性无故。取亦断灭更无扶助。取灭故有灭者。由于取缘性无故。有亦断灭更无扶助。有缘故生灭者。由于有缘性无故。生亦断灭更无扶助。生灭故老死灭者。由于生缘性无故。老死断灭更无扶助

复次于中无明爱取。是谓烦恼流不断绝。行有是业流不断绝。余支是苦流不断绝。以差别故前后际灭。是流断绝如是三流。悉是无我离我我所。自性生灭犹若束芦

复次所说无明缘行是前世观待。识乃至受是现世观待。爱乃至有是后世观待。由是于后相续流转。无明灭故行灭者是观待断绝。复由如是十二有支有三苦性。此中诸行乃至六处是行苦性。触受此二是苦苦性。所余有支是坏苦性。无明灭故行灭者。是三苦性究竟断灭。无明缘行者是则显行。从因从缘所生之性余亦如是。无明灭故行灭者此则显示。行无自性余亦如是。无明缘行者是生连缚余亦如是。无明灭故行灭者。是灭连缚余亦如是。无明缘行者是随顺有观余亦如是。无明灭故行灭者。是随顺尽灭观余亦如是。菩萨如是以十行相顺逆观察诸缘起法。所谓有支相续故入一心故。自业差别故不相舍离故。三流不断故前今后世观待理故。三苦集故因缘所生故。生灭连缚故观有尽故。菩萨以是十种行相观诸缘起。由以无我无寿命者。无数取趣自性空寂。离作者受者观缘起故。空解脱门而现在前。即此菩萨彼诸有支自性灭故。究竟解脱现证住故。无少法相后生起者。由是无相解脱门而现在前。又此菩萨如是趣入空无相已。无余愿求唯除大悲。为先导故成熟有情。由是无愿解脱门而现在前。菩萨如是修习此三解脱门时。离自他想远离作者及受者想。离有无想大悲为首。于未修证诸觉分法为修证故。转复修行作是思惟。由相应故有为法转。由不相应不能流转。由和合故有为流转。若无和合则不流转。我已解了诸有为法。如是多咎污染而转。是故我今当断相应及彼和合。然为成熟诸有情故。不应永灭一切有为。唯诸佛子菩萨如是。观诸有为多咎污染。永无自性本性毕竟不生不灭。观察此时兴大悲故。不舍一切有情聚故。名无著智现前般若波罗蜜多住。以寄现故而现在前。菩萨成就如是智已。慧到彼岸住之所照。引发能引觉分众缘。然非有住而住之。观有为法自性寂灭不住。于彼菩提分法未圆满。菩萨住此现前地中。名入空性三摩地而现在前。自性空性三摩地。胜义空性三摩地。最上空性三摩地。大空性三摩地。相应空性三摩地。引发空性三摩地。如理无分别空性三摩地。有顾恋空性三摩地。离不离空性三摩地。而悉现前。此菩萨如是上首于空性门。百万三摩地而现在前。如是于无相门百万三摩地。于无愿门百万三摩地皆现在前

佛说十地经卷第四佛说十地经卷第五

        大唐于阗三藏尸罗达摩于北庭龙兴寺译

    菩萨现前地之余

唯诸佛子菩萨住此现前地中。不坏意乐转更圆满。决定意乐贤善意乐。甚深意乐不退转意乐。不休息意乐无垢意乐无边意乐求智意乐。方便与慧相应意乐皆得圆满。于是菩萨此诸意乐。顺佛菩提对诸异论。精进不退入于智地。舍离声闻独觉乘地。一向决定趣于佛智。以诸魔怨烦恼现行不可映夺。善住菩萨智光明中。善修习空无相无愿法之现行。恒与方便慧观相应。间杂引发菩提分法。菩萨住此现前地时。慧到彼岸住得增上。及证第三猛利顺忍。以于诸法如理随顺不违逆故。菩萨住此现前地中。以广大见及以愿力。现见多佛多百佛多千佛多百千佛多百千那庾多佛多俱胝佛。多百俱胝佛多千俱胝佛多百千俱胝佛。多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具。病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。殷重承事诸佛如来。恭敬尊重以希有想。听闻正法闻已受持。以无颠倒等持慧智。光明修行。坚固正行忆持不忘。转更得入如来法藏。于是菩萨住此第六现前地者。于无量劫此诸善根转复炽然转更明净。无量百劫无量千劫无量百千劫无量百千那庾多劫无量俱胝劫无量百俱胝劫无量千俱胝劫无量百千俱胝劫无量百千俱胝那庾多劫。此诸善根转复炽然转更明净。唯诸佛子譬如金师。以所炼金作庄严具。以琉璃宝莹饰厕填。转得炽然转更明净。唯诸佛子菩萨住此现前地中。此诸善根亦复如是。以方便慧随所思察。转得炽然转更明净。展转寂灭无能映夺。又诸佛子譬如月光。能令有情身得悦豫。非四风转所能断坏。唯诸佛子菩萨住此现前地中。此诸善根亦复如是。能灭无量百千俱胝那庾多有情烦恼火焰。非四魔道所能断坏。彼于十种波罗蜜多慧到彼岸而得增上。余到彼岸随力随分非不修行。唯诸佛子是名略说菩萨第六现前地。菩萨安住于此地时。受生多作妙化天王。能作自在善化有情。令增上慢毕竟休息。常以一切声闻问难不可映夺。能令有情证入缘起诸所作业。或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意佛不共法作意。乃至不离一切行相妙相应一切智智作意。常作愿言我当一切诸有情中。为首为胜为殊胜。为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进一刹那顷瞬息须臾。证入菩萨百千俱胝诸三摩地。能见百千俱胝诸佛。彼佛加持皆能解了。能动百千俱胝世界。能往百千俱胝佛刹。能照百千俱胝世界。成熟百千俱胝有情。住寿百千俱胝大劫。于前后际各能入百千俱胝劫。思择百千俱胝法门。能示现百千俱胝身。身身能现百千俱胝菩萨眷属围绕。从此以上是诸菩萨。有愿力者由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨欲重宣此义而说颂言

  菩萨已净第五地　　观法无相无自性
  无起无生常寂静　　性本清净无戏论
  亦无取舍如幻等　　有无不二离分别
  随顺法性如是观　　由此智入第六地
  猛利顺忍智具足　　观诸世间生灭相
  知由我执世间生　　除我执已世无有
  如理通达缘起空　　不坏假立和合用
  无作无受无命者　　诸行如云遍兴起
  于谛无知名无明　　痴所造业果名行
  生时初心名为识　　俱生余蕴是名色
  即此增长名六处　　三和谓触俱生受
  欣受名爱爱增取　　有漏业有蕴起生
  蕴熟名老蕴坏死　　纯大苦聚如是集
  了达三界唯是心　　十二有支依心有
  生死皆由心所作　　若心灭者生死尽
  无明所作有二种　　由缘迷故与行因
  如是乃至老终殁　　从此苦生无有尽
  无明缘性谓诸行　　不断而复有助成
  由斯无故诸行断　　更无扶助余亦尔
  痴爱取是烦恼流　　行有是业余皆苦
  无明与行为过去　　识至于受是现在
  爱取有生未来苦　　观待断是苦边际
  行至六处是行苦　　触受增长是苦苦
  所余有支是坏苦　　若见无我三苦灭
  以从因缘行等起　　缘离则断故性空
  无明为缘是生缚　　于缘得离缚乃除
  随顺无明起诸有　　若不随顺诸有断
  由此彼有无亦然　　十种思惟心离着
  有支相续一心摄　　自业不离及三流
  三际三苦因缘生　　连缚起灭顺无尽
  如是普观缘起行　　无作无受无自性
  如幻如梦如光影　　亦如愚夫逐阳焰
  观是入空解脱门　　知缘性离入无相
  了其虚妄无所愿　　唯除慈愍救有情
  大师修行解脱门　　转益大悲求佛法
  知有为从和合有　　志乐决定勤精进
  证空等持具百万　　无相无愿亦复然
  般若顺忍皆增上　　解脱智慧得成满
  复以意乐供多佛　　于佛教中修习道
  得佛法藏增善根　　如金琉璃所莹饰
  如月清凉被众物　　四风来触无能坏
  此圣能超四魔道　　息世惑热亦如是
  住此多作善化王　　化导有情除我慢
  所作皆求一切智　　悉已超胜声闻道
  此地精勤获百千　　俱胝菩萨三摩地
  亦见若干无量佛　　譬如盛夏空中日
  甚深微妙难见知　　声闻独觉无能了
  如是菩萨第六地　　我为佛子已宣说

    菩萨现前地第六竟

    菩萨远行地第七

  是时大众心欢喜　　散宝成云在空住
  普发种种妙音声　　白于最胜清净者
  了达胜义智自在　　成就功德百千亿
  人中莲花无所著　　为利群生演深行
  自在天主在空中　　放大光明照佛身
  亦散最上妙香云　　普供除忧烦恼者
  尔时大众皆欢喜　　悉发大音同赞述
  我等闻斯地功德　　则为已获大善利
  天女是时心庆悦　　竞奏乐音千万种
  悉以如来神力故　　声中共作如是言
  威仪寂静最无比　　能调难调世应供
  已超一切诸世间　　而行于世阐妙道
  虽现种种无量身　　知身一一无所有
  巧以音词说诸法　　不取文字音声相
  往诣百千诸国土　　以诸上供供养佛
  智慧自在无所著　　不生于我佛国想
  虽勤教化诸有情　　而无彼已一切心
  虽已修成广大善　　而于善法不生着
  以见一切诸世间　　贪恚痴火常炽然
  于诸想念悉皆离　　发起大悲精进力
  一切诸天及天女　　种种供养称赞已
  悉共同时默然住　　瞻仰人尊愿闻法
  时解脱月复请言　　此诸大众心清净
  第七地中诸行相　　唯愿佛子为宣说

尔时金刚藏菩萨告众菩萨言。唯诸佛子若是菩萨。第六地中所修地道善圆满已。欲入菩萨第七地者。当以十种妙方便慧所引不共进道胜行而入。何等为十。所谓善修空无相无愿三摩地。而集广大福德资粮。证入诸法无我无寿者无数取趣。而不舍修四无量心。发起广大福德及法修行增上到彼岸行。而于诸法无少执着。已得远离一切三界。而能引发三界庄严。已得毕竟寂静寂灭。远离一切诸烦恼焰。而能引发一切有情。贪嗔痴焰寂灭之行。现知诸法如幻如梦如影如响。如水中月如镜中像自性无二。而能引发业用无量差别意乐。依善修习诸刹土道与虚空等。而能引发佛刹清净庄严之行。了知诸佛法身为性犹如虚空。而能引发妙色相好庄严其身。又知诸佛音声本性寂静不可言说。而能引发一切音韵差别庄严。了知诸佛一刹那顷顿悟三世。而能随入显示种种相劫数等。观诸有情心意乐故。菩萨如是以此十种妙方便慧所引不共进道胜行。从第六地入第七地。唯诸佛子菩提萨埵。由此十种妙方便慧所引不共进道胜行现在前故。名为已入于第七地。菩萨住此第七地中。入于无量诸有情界。入于无量诸佛世尊。成就调伏有情之业。入于无量诸世界网。入于无量诸佛世尊佛刹清净。入于无量法差别性。入于无量诸佛世尊智正等觉入于无量劫数差别。入于无量诸佛世尊觉悟三世。入于无量有情胜解差别之相。入于无量诸佛世尊。示现种种名号色身。入于无量有情意乐根之差别。入于无量诸佛世尊。言音令他有情生喜。入于无量有情种种心行差别。入于无量诸佛世尊广大智行。入于无量诸声闻乘游路胜解信解。无量诸佛世尊演说入道。入于无量诸独觉乘修证成就。入于无量诸佛世尊。演说趣入甚深智门。入于无量诸菩萨行所修加行。入于无量诸佛世尊。演说趣入大乘之集。即此菩萨作是思惟。诸佛境界如是无量百俱胝劫不易算数。千俱胝劫百千俱胝劫。乃至尔所百千俱胝那庾多劫不易算数。此佛境界我应发起。以无功用无分别无异分别。当令圆满。菩萨如是多善观智通。无间无缺精勤修学。以不动故名已安住于方便慧熏修不共进道胜行。又此菩萨于一刹那能引发道不起于定。行时引发如是正智。精勤修学住坐卧时。乃至眠梦远离盖障。诸威仪中不道如意。正想作意彼于一心一刹那中。十到彼岸具足成就。所以者何由是菩萨所起一切心之所念。念念皆以大悲为首。回向修证一切佛法趣如来智。于此菩萨所有善根。为求佛智施与有情。是彼布施波罗蜜多。慈悲为首于诸有情不为损害。是彼安忍波罗蜜多。无厌增进后后善法。是彼精进波罗蜜多。一切智道常现在前未尝散乱。是彼静虑波罗蜜多。于性不生不灭法中现前之忍。是彼般若波罗蜜多。引发无量智是彼方便善巧波罗蜜多。引发后后智是彼愿波罗蜜多。一切异论及诸魔众。无能坏道是则彼力波罗蜜多。如实建立一切诸法。是名彼智波罗蜜多。唯诸佛子菩萨住此远行地中。如是十种波罗蜜多刹那。皆得具足四种摄事及四加持。三十七品菩提分法三解脱门。略言一切觉分之法。刹那刹那皆悉圆满。如是说已解脱月菩萨。问金刚藏菩萨言。唯诸佛子菩萨岂但于第七地一切觉分而得圆满。为于一切菩萨地中亦满足耶。金刚藏菩萨言。佛子菩萨一切十地位中。一切觉分悉皆圆满。然于菩萨第七地中最为殊胜。所以者何唯佛子此菩萨地。今有加行行得圆满。转能趣入智神通行。然唯佛子于初地中。一切大愿为所缘觉支圆满。第二地中遣心垢故。第三地中正愿增长得法明故。第四地中趣入道故。第五地中随顺一切世间事业故。第六地中趣入甚深诸法门故。今此菩萨第七地中。具足发起诸佛法故觉支圆满。所以者何菩萨所有始从初地。至第七地中之所引发智加行分。此从菩萨第八智地。以无功用悉皆成就。佛子譬如有二世界。一者染净二者纯净。是二界中间难可得过。唯除有大神通力持。佛子菩萨杂净行门亦尔。难可得过。唯除有大誓愿方便慧通力。解脱月菩萨言唯诸佛子。岂于前七菩萨地中菩萨正行以烦恼行之染污耶。金刚藏菩萨言。佛子以从初地诸菩萨行。当言远离诸烦恼业。回向菩提增上力故。然与随类道平等故。于七地中未可当言超烦恼行。佛子譬如转轮圣王。乘天象宝巡四大洲人间。贫苦杂染皆能了知。而不为彼众患所污。然未名为超过人位。若舍王身生于梵世。乘梵宫殿巡览千界。示现梵天光明威德。尔乃名为超过人位。佛子菩萨亦复如是。始初地乘御菩萨到彼岸乘。遍游世间知诸有情杂染过患。而不为彼众患所污乘正道故。然于七地犹未可言超烦恼患。若舍一切有功用。从第七地入第八地。乘御菩萨清净之乘遍游世间。知杂染患不为所染。已超过故菩萨安住于此。菩萨第七地中多分超过贪等一切诸烦恼。众菩萨修此远行地时。如应当言非有烦恼非无烦恼所以者何。一切烦恼不现行故。不应说为有烦恼者。希求佛智犹未得故。不应说为无烦恼者。菩萨住此第七地中。成就增上意乐清净身语意业超过一切。如来所毁不善业道。常恒护持诸佛所赞十善业道如前所说。于第五地所引世间工巧业处。此之一切七地菩萨。以无功用自然而转。于此三千大千世界共许为师。唯除如来正遍等觉及已安住第八地等。诸大菩萨意乐加行无与等者。所有静虑等持等至神通解脱。此彼一切皆得现前。由修行相现在前故。非由异熟而得成就。如第八地于此菩萨。安住第七远行地者。诸心念中妙慧方便修力成满。一切觉支转得圆满。复次而是菩萨住此第七菩萨地时。入名善思择菩萨三摩地。名善思义三摩地。名殊胜慧三摩地。名分别义藏三摩地。名择一切义三摩地。名善住坚根三摩地。名智神通门三摩地。名法界莹饰三摩地。名如来胜利三摩地。名入种种义藏生死涅槃门三摩地。菩萨如是大智神通为首。入满百万诸三摩地净治此地。由得如是妙方便慧之所熏修三摩地故。获大悲故。超过声闻独觉乘地。智慧观察地现在前。于是菩萨住此菩萨第七地者。无量身业离相随转。无量语业离相随转。无量意业离相随转。极善清净无生法忍之所显发。解脱月菩萨言。唯佛子初地菩萨。岂无无量身语意业。超诸声闻独觉行耶。金刚藏菩萨言佛子。虽有此行但由佛法所缘增上力故。非由自觉慧所观察。于此菩萨第七地中。由自觉慧观境界故无能映夺。佛子譬如王子生在王家。正后所生具足王相。才生即能映蔽臣众。但以父王增上自在。非以自智之所思察。若身长大艺业悉成。乃以自智力所持故。超过一切众臣所作。佛子菩萨亦复如是。由初发心映蔽一切声闻独觉。但由广大增上意乐。非由自觉慧所观察。今此菩萨第七地中。于自所行安立智故。出过一切声闻独觉所作事业

佛子菩萨住此第七地已。虽得甚深寂静无行身语意业而不舍离。寻求胜进勇猛加行。解脱月菩萨言佛子菩萨齐何等地能入灭定。金刚藏菩萨言佛子菩萨从第六地能入灭定。今住菩萨第七地中。能于一一心刹那中。趣入灭定而不应言于灭作证。由此菩萨说为成就甚难希奇身语意业。谓常安住实际住中。而于寂灭能不作证。佛子譬如有人乘大船舶入于大海。得船善巧善知水相。此终不遭大海水难。佛子菩萨住此第七地中亦复如是。乘到彼岸船常能安住实际住中。而于寂灭能不作证。佛子菩萨得是智已。由三摩地智力修习所引妙慧。以大方便善巧力故示生死门。而其意乐住在涅槃眷属围绕。常乐远离以愿力故三界受生。而非世法过患所污虽常寂灭而以方便还示炽然。虽然不烧常顺佛智。示入声闻及独觉地得佛境界藏。示住魔境界趣四魔道现行魔法。示行一切诸外道行。而其意乐不舍佛法。示顺一切世间业行。而常乐入出世法趣所有一切庄严之事。皆过一切人天龙药叉鬼神。及释梵护世之所有者。而不舍乐法作意。佛子菩萨成就如是智慧。住此菩萨远行地已。由广大见及以愿力。现见多佛。多百佛。多千佛。多百千佛。多百千那庾多佛。多俱胝佛。多百俱胝佛。多千俱胝佛。多百千俱胝佛。多百千俱胝那庾多佛。菩萨见是如来应供正等觉已。悉以广大增上意乐。恭敬尊重承事供养。奉施衣服饮食卧具。病缘医药诸资生具。奉献菩萨诸妙乐具。于僧伽众而作恭敬。以此善根回向无上正等菩提。尊重承事诸佛如来。恭敬尊重以希有想。听闻正法闻已受持。以无颠倒等持慧智光明修行。以成就于诸佛所护持圣教。一切声闻及诸独觉。自现观中所有问难无能退屈。于彼多分饶益有情法忍得净。菩萨住此远行地中。于无量劫此诸善根转得炽然。清净堪能转复明净。无量百劫无量千劫无量百千劫无量百千那庾多劫无量俱胝劫无量百俱胝劫无量千俱胝劫无量百千俱胝劫无量百千俱胝那庾多劫。此诸善根转复炽然转更明净。佛子譬如金师。以所炼金作庄严具。诸摩尼宝莹饰厕填。甚为光丽极为明净。余庄严具所不能及。佛子菩萨住此第七远行地中。此诸善根亦复如是。以方便慧之所引发。转得炽然转复明净。一切声闻独觉善根不能映夺。佛子又如日光。不为一切众星月光所能映夺。多分枯涸赡部州中秽湿泥潦。佛子菩萨住此远行地中。此诸善根亦复如是。一切声闻独觉善根不能映夺。多分枯涸一切有情烦恼垢秽。彼于十种波罗蜜多方便善巧波罗蜜多以为增上。余到彼岸随力随分非不修行。佛子是名略说菩萨第七远行地也。菩萨安住于此地时。受生多作他化自在天王。善授一切声闻独觉现观方便。能令有情入离生正性。诸所作业或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意佛不共法作意。乃至不离一切行相胜妙。相应一切智智作意。常作愿言我当一切诸有情中。为首为胜为殊胜为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进一刹那顷瞬息须臾。证得百千俱胝那庾多诸三摩地。能见百千俱胝那庾多佛彼佛加持皆能解了。能动百千俱胝那庾多世界。能往百千俱胝那庾多佛刹。能照百千俱胝那庾多世界。成熟百千俱胝那庾多有情。住寿百千俱胝那庾多劫。于前后际各能入百千俱胝那庾多劫。善能思择百千俱胝那庾多法门。示现百千俱胝那庾多身。身身能现百千俱胝那庾多菩萨眷属围绕。从此以上是诸菩萨有愿力者。由愿力故所有游戏。或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨欲重宣此义而说颂言

  第六地行善备已　　则修方便慧所印
  不共进道殊胜行　　以此趣入第七地
  处三脱门积福德　　通达无我修慈悲
  福德及法常充满　　行到彼岸无执着
  远离三界而庄严　　寂然灭世无烦恼
  知法如幻而办业　　了刹如空乐严土
  解身无相集相好　　达响离言善开演
  刹那顿悟显众相　　智者以此升七地
  观察此法得明了　　广为群迷兴利益
  入有情界无有边　　佛教化业亦无量
  能入刹土法劫数　　胜解意乐及心行
  说三乘法无限量　　由是教化诸群品
  刹那引发双运道　　于四威仪常修慧
  一一回向佛菩提　　念念具十到彼岸
  善施有情是布施　　灭惑为戒不害忍
  求善无厌斯精进　　于道不动即静虑
  忍法无生名为慧　　起无量智是方便
  引发后后智谓愿　　无能摧伏是为力
  如实成立法是智　　如是念念皆成满
  初地胜愿觉支满　　二地远离心垢故
  三地愿增法明故　　第四地中入道故
  五顺世间事业故　　六入甚深法门故
  第七地中由发起　　一切佛法觉支满
  以是能令第八地　　一切所作咸清净
  此地难过唯智者　　以大愿智乃能超
  如杂纯净二界间　　唯依神通乃能过
  又如轮王无染着　　然未名为超人位
  若住第八智地中　　尔乃踰于心境界
  如生梵世超人位　　如莲处水无染着
  此地虽超诸惑众　　不名有惑非无惑
  以无烦恼而现行　　希求佛智犹未得
  世间所有众技艺　　经书词论普明了
  静虑等持及神通　　是由修行速成就
  菩萨修斯七道地　　超过一切二乘行
  初地愿故此由智　　譬如王子力具足
  成就甚深仍进道　　数入灭定不作证
  譬如乘船入海中　　在水不为水所溺
  方便慧行功德具　　一切世间无能了
  供养多佛心益明　　如以妙宝庄严金
  此地菩萨智最明　　如日舒光竭爱水
  又作自在天中主　　化导群生修正智
  若加勇猛精勤力　　获多等持见多佛
  百千俱胝那庾多　　愿力自在复过是
  此是菩萨远行地　　方便智慧清净道
  一切世间天及人　　声闻独觉无能测

    菩萨远行地第七竟

佛说十地经卷第五佛说十地经卷第六

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨不动地第八

  是时天王及天众　　闻此胜行皆欢喜
  为欲供养于如来　　及以无量大菩萨
  雨妙幡花及幢盖　　香鬘璎珞与宝衣
  无量无边千万种　　悉以摩尼作严饰
  天女同时奏天乐　　普发种种妙音声
  供养于佛并菩萨　　共作是言而赞叹
  一切见者两足尊　　哀愍有情现神力
  令此种种诸天乐　　普发妙音咸得闻
  于一毛端百千亿　　那庾多国微尘数
  如是无量诸如来　　于中安坐说妙法
  一毛孔内无量刹　　各有四洲及大海
  须弥铁围亦复然　　悉见在中无迫隘
  一毛端处有六趣　　三种恶道及人天
  诸龙神众阿素洛　　各随自业受果报
  于彼一切刹土中　　悉有如来演妙法
  随顺一切有情心　　为转最上净法轮
  刹中种种有情身　　身中复有种种刹
  人天诸趣各各异　　佛悉知已为说法
  大刹随欲变为小　　小刹随欲变为大
  如是神通无有量　　世间共说不能尽
  普发此等妙音声　　称赞如来功德已
  众会欢喜默然住　　一心瞻仰欲听法
  时解脱月复请言　　今此众会皆寂静
  愿说随次之所入　　第八地中之行相

尔时金刚藏菩萨。告众菩萨言。唯诸佛子若是菩萨。于七地中善修决择。以慧方便善净诸道。善集资粮善结大愿。善蒙安住如来加持。得自善根力所持性。随顺如来力无所畏不共佛法作意而行。善净增上意乐思察。由福智力之所涌起。以大慈悲于诸有情。不舍加行随于无量智道而行。入一切法本来无生无起无相无成无坏。无断尽无流转无止息性为性。初中后位皆悉平等以真如中无分别故入一切智。即此菩萨。远离一切心意及识分别妄想无所执着。与虚空等显然入性。名为已得无生法忍。佛子菩萨成就如是无生法忍。才证菩萨不动地故。得甚深住难可了知。同无差别离一切相。止息一切想之执着无量无边。以诸声闻及以独觉不可映夺寂静现前。佛子譬如苾刍。具足神通得心自在。渐入第九想受灭定。一切动乱忆想分别悉皆止息。佛子菩萨才得不动地已亦复如是。离诸功用任运至得无功用性。远离一切身语意。务安住异熟。佛子譬如有人梦见自身堕在大河。为欲渡故发大勇猛起大翘勤。以大勇猛起翘勤故。即便寐寤既寤寐已。所作一切勇猛。遽务皆悉休息。佛子菩萨亦复如是。见有情聚堕在烦恼四大瀑流。为欲救度故。发大勇猛起大翘勤。由以发起大精进故。才至菩萨不动地已。一切功用靡不。皆息即此。菩萨所有一切二取现行。或相现行不复影现。佛子譬如天仙生在梵世。欲界烦恼终不现行。佛子。菩萨住此不动地时亦复如是。一切心意及识现行不复现起。又此乃至诸佛现行。菩提现行菩萨现行。涅槃现行尚不现起。况复发起世间现行

复次佛子菩萨如是行此第八不动地时。安住本愿力所持已。即于如是法门驶流。蒙诸如来觉悟劝导。是时诸佛授与。引发如来妙智。作如是言。善哉善哉善男子。此即随顺一切佛法胜义之忍。然善男子我等诸佛。所有十力四无所畏。十八不共佛法自在。汝今未得当为成就佛法自在。应起精进于此忍门勿复弃舍。又善男子。汝虽得是寂灭解脱。然彼一切异生种类未得寂静。未能寂灭常顺异异烦恼现行。种种寻伺之所侵害。汝当愍念。又善男子汝当忆念本所誓愿。谓令有情。皆得义利及不思议智慧之门。又善男子。一切诸法法性如是。若佛出世或不出世法界常住终无变易。非但以此诸佛得现一切声闻及诸独觉。亦证此法无分别法性。又善男子。汝观我等佛身无量。智慧无量。刹土无量。光轮无量。智所引无量清净音韵亦无有量。汝今亦应引发此事。又善男子。汝今唯得此一法明。谓诸法中无分别慧。然善男子如是法明。诸佛如来无边所行。无边所作无边所系。为欲证彼当起引发又善男子。汝观十方无量。刹土无量。有情无量诸法种种差别。应是一切如理通达。佛子如是诸佛世尊。觉悟劝导此地菩萨。授与此等无量无边引发智门。令其无智差别故。能成如是引发之业。佛子我今告汝得解。若时诸佛不垂诲示。令此菩萨入于如是引发门者。当时即入究竟涅槃。休息一切利有情业。以是诸佛授与如是引发无量智慧业故。此地菩萨于一念顷所引智业。此比于前从初发心。乃至七地所修诸行。百倍为胜千倍百千倍。俱胝倍百俱胝倍。千俱胝倍百千俱胝倍。百千俱胝那庾多倍为胜。算数计喻乃至乌波尼杀昙倍。亦复为胜。所以者何。佛子菩萨先以一身引发诸行。今乘此地以依无量分身差别。修菩萨行以能引发无量音声。以能引发无量智慧。以能引发无量受生。以能严净无量佛刹。以能成熟无量有情。以悉承事无量诸佛。以悟无量法之理趣。以起无量神通势力。以依无量众会差别。以无量行身语意业一切菩萨正行之力。皆悉成满以不动故。佛子。譬如海船未至大海。以有功用排牵而去。若至海已则无功用任运而行。以于大海风轮飘泛。一日所行。此比于前有功用时。设经百岁不能尔所无量而至。佛子菩萨亦复如是。已善积集善根资粮修证大乘。随至菩萨正行大海。一须臾顷以无功用智入一切智智。此比于前有功用业。经百千劫不能尔所无量而至。唯诸佛子菩萨已至于第八地。以由广大方便善巧。妙智所引无功用行。菩萨正慧观察一切智智之时。观世界成观世界坏。如世间成皆能了知。如世间坏皆能了知。由何业集世间成就皆能了知。由何业尽世间坏灭皆能了知。几时世界成皆能了知。几时世界坏皆能了知几时世界成已住皆能了知。几时世界坏已住皆能了知。又知地界小大无量及差别相。了知水界小大无量及差别相。了知火界小大无量及差别相。了知风界小大无量及差别相。又知微尘细相粗相。无量相及差别相。于何世界所有若干微尘积聚。微尘差别皆能了知。于何世界所有若干地界微尘皆能了知。所有若干水界微尘皆能了知。所有若干火界微尘皆能了知。所有若干风界微尘皆能了知。所有若干有情界微尘皆能了知。所有若干刹土聚微尘皆能了知。又此菩萨。知有情身粗相细相身差别相。知依那洛迦身有若干微尘。知依傍生身有若干微尘。知依鬼界身有若干微尘。知依阿素洛世间身有若干微尘。知依天世间身有若干微尘。知依人世间身有若干微尘。菩萨如是。趣入微尘差别智已。知欲界成知色界成知无色界成。知欲界坏知色界坏知无色界坏。能知欲界小大无量及差别相。能知色界小大无量。及差别相。能知无色界小大无量及差别相。了知三界。于观三界随行智中。复善引发智光明已。于诸有情身差别智已得善巧。于身分别智得善巧。则于示现受生引慧。此菩萨随有情类受生差别及身成就。随其所应而为同类。示现自身成熟有情

复次菩萨。于一三千大千世界。普能遍满随有情身。胜解差别引发受生。以影现智随所行故。若二若三若四若五。若十二十三十四十五十。若百乃至不可说数。无量三千大千世界。皆能遍满随有情身胜解差别。随其所应引发受生。以影现智随所行故。菩萨成就如是智已。从一佛刹其身不动。于不可说诸佛刹土众会之中皆悉显现。而此菩萨随诸有情身及胜解意乐差别。能于彼彼佛国土中。及于彼彼众会道场彼彼之处。如是如是示现其身。所谓于沙门众中现沙门形。婆罗门众中现婆罗门形。刹利众中现刹利形。吠舍众中现吠舍形。长者众中现长者形。居士众中现居士形。于四天王众中现四天王形。于三十三天众中示现三十三天形。夜摩众中睹史多众中。乐变化众中他化自在众中魔王众中。各随其类而为现形。于梵众中现梵形色。又此菩萨。应以声闻身得调伏者。而为示现声闻身形。应以独觉身得调伏者。而为示现独觉身形。应以菩萨身得调伏者。而为示现菩萨身形。应以如来身形得调伏者。而为示现如来身形。佛子菩萨如是。于不可说佛刹土中所有若干有情胜解于彼彼处。如是如是现身差别

复次此菩萨。远离一切身相分别。得身平等性。知有情身刹土身。业果身声闻身。独觉身菩萨身。如来身智身。法身虚空身。此菩萨知有情心意乐引发。若乐随欲将有情身置于自身。如是刹土身。业果身声闻身。独觉身菩萨身。如来身智身。法身虚空身。置于自身。又此菩萨。知有情心意乐引发。若乐随欲能以自身。置于一切诸有情身。能以自身。置于刹土身。业果身。声闻身。独觉身。菩萨身。如来身。智身。法身。虚空身。亦复如是。菩萨已知诸有情心意乐引发。而将此身随欲置于彼彼身中。是菩萨于有情身中。知业身异熟身烦恼身有色身无色身。于刹土身中。小相大相无量相杂染相。清净相乱住相仰住相覆入相。方网差别相皆悉能知。于业果身中。能知差别知假建立。于声闻身于独觉身于菩萨身。能知差别知建立。于如来身中知等觉身。显身化身加持之身。相好庄严微妙色身。光明身意生身。福德身法身智身。皆悉能知。于智身中。善思察相如实观相。果及加行所摄之相。世间出世间差别相。三乘安立相。共不共相。出离非出离相。有学无学相。皆悉能知。于法身平等性相不毁坏相。随诸分位及假世俗安立之相有情无情法安立相佛法圣僧法安立相。皆悉能知。于虚空身。知无量根遍行之相。无形质相无异无边相。以持色聚得显了相。皆悉能知。即此菩萨。如是已能引发身智得寿自在。于不可说不可说劫。加持寿量故得心自在已。于无量无数等持观。入智故得资生自在。已能示现一切世界无量庄严具。庄饰加持故。得业自在。应时能现业果加持故得生自在。于一切世间示现受生故得胜解自在已。能示现一切世界。佛充满故得愿自在。于随所欲佛刹时分。示等觉故得神通自在。诸佛刹中皆能示现。神通游戏故得法自在。已能示现无边无中法门明故得智自在。示现佛力无畏不共佛法相好正等觉故。菩萨得此十自在故。即得名为不思议智者广大智者不可映夺智者。于是菩萨已至如是。已能成就如是智慧。毕竟无罪。身业现行任运随转。毕竟无罪。语业现行任运随转。毕竟无罪。意业现行任运随转。于一切业智为先导。随智而转慧到彼岸。以为增上大悲为首。方便善巧善所分别。愿善所引如来加持善所加护。于诸有情利益加行无有休息。随于无边世界差别行。佛子举要言之。菩萨至于不动地已。所有身语意业现行。皆为积集一切佛法

复次菩萨。如是至于不动地中。于意乐力得善安住。远离一切烦恼现行。故于增上意乐力得善安住。不离道故。于大悲力得善安住。不舍利益有情事故。于大慈力得善安住。能救一切诸世间故。于总持力得善安住。无忘失法故。于辩才力得善安住。于一切佛法选择分别得善巧故。于神通力得善安住于无边际诸世界中行差别处得善巧故。于大愿力得善安住。不舍一切菩萨所作故。于到彼岸力得善安住。普集一切诸佛法故。于如来加持力得善安住。一切行相一切智智现在前故。然此菩萨已得如是势力所持。能现一切诸所作事。而于一切所作事中无有过咎。佛子此之第八菩萨智地。名为不动地不可映夺故。名为不退地智无退故。名为难得地一切世间无能测故。名为童真地无过失故。名为生地如所乐欲自在转故。名为成就地无复所作故。名为究竟地以能善作智决择故。名为涅槃地以善引发本愿力故。名为住持地非他所坏故。名为无功用地前际所引故。佛子菩萨引发如是智已。入佛种姓以佛功德光明所照。随顺如来威仪正行。佛境现前无间无缺。如来威德常所加持。释梵护世之所奉迎。金刚力士常随侍卫。恒不舍离三摩地力。引发无量分身差别一切身行。势力相应成就广大异熟神通。于无涯际三摩地中自在而转。能受无量菩提记别。随已成熟诸有情类现成正觉。然此菩萨如是通达入大乘会。获善观察大智神通常恒能放妙慧光明。趣入无碍真法界道。能知世界差别之道。示现一切诸大功德。于自心起自在能转。于前后际善能知行。善能通达伏除一切魔道之智。证入如来所行境界。能于无边诸世界中。行菩萨行已。能成就不退转故。是即说为菩萨已至于不动地

佛子菩萨住此不动地时恒常无间不离现见无量诸佛。由三摩地力所引故。然不弃舍广见诸佛承事供养。然此菩萨于一一世界。见无量佛无量百佛。无量千佛无量百千佛。无量百千那庾多佛。无量俱胝佛。无量百俱胝佛。无量千俱胝佛。无量百千俱胝佛。无量百千俱胝那庾多佛。见诸佛已恭敬尊重。以一切行相引发供养。悉以奉献彼诸如来。皆悉承事于诸佛所领受世界差别义等无量法明。转复得于如来法藏。于诸世界差别问答无能屈者。于无量劫此诸善根。转得炽然光丽明净。无量百劫。无量千劫无量百千劫。无量百千那庾多劫。无量俱胝劫无量百俱胝劫。无量千俱胝劫。无量百千俱胝劫。无量百千俱胝那庾多劫。此诸善根转得炽然光丽明净。佛子譬如善巧金师。以所炼金作严具已。置赡部洲圣王顶上成于颈下。赡部洲中一切臣民。诸庄严具无与等者。佛子菩萨住是不动地中。此诸善根亦复如是。一切声闻独觉。乃至七地菩萨。所有善根无与等者。以住此地大智光明。普灭有情烦恼黑闇。善能开阐智慧门故。佛子譬如千世界主。大梵天王遍运慈心。普放光明满千世界菩萨住此不动地已亦复如是。能以光明普照遍满。乃至百万佛刹微尘数等世界。渐灭有情烦恼炎热令身悦豫。于十种波罗蜜多。愿到彼岸以为增上。余到彼岸随力随分非不修行。佛子是名略说菩萨第八不动智地。若广说者经无量劫不可穷尽。菩萨安住于此地已。受生多作大梵天王。主千世界威德最胜无所映夺。善见义利得大自在。为诸有情。善说声闻独觉菩萨到彼岸道。世界差别问答之中。无能屈者诸所作业。或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意佛不共法作意。乃至不离一切行相胜妙。相应一切智智作意。常作愿言。我当一切诸有情中。为首为胜为殊胜。为妙为微妙为上为无上。为无等为无等等。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进一刹那顷瞬息须臾。证得百万三千大千世界微尘数诸三摩地。能见百万三千大千世界微尘数佛。彼佛加持皆能解了。能动百万三千大千世界微尘数诸佛刹土。能照百万三千大千世界微尘数诸佛国土。成熟百万三千大千世界微尘数有情。住寿百万三千大千世界微尘数劫。于前后际。各入百万三千大千世界微尘数劫。善能思择百万三千大千世界微尘数法门。示现百万三千大千世界微尘数身。身身能现百万三千大千世界微尘数菩萨。眷属围绕。从此以上是诸菩萨有愿力者。由胜愿故所有游戏。或身或光明或神通。或眼或境或界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫。不易可数。尔时金刚藏菩萨。欲重宣此义。而说偈言

  七地已修方便慧　　善集资粮发大愿
  得佛加持具善力　　顺佛功德净志念
  福智已超恒慈愍　　智慧广大等虚空
  为求胜智登八地　　契悟寂灭无生忍
  知法无生无起性　　无相无成无坏灭
  无尽无转无止息　　无性为性常平等
  以无分别入佛智　　超心意识分别想
  证此忍已得静住　　甚深不动常寂灭
  一切世间无能测　　心相取着悉皆离
  住于此地不分别　　譬如苾刍入灭定
  如梦渡河起翘勤　　寤已坦然无遽务
  菩萨为度有情界　　功用此地息亦然
  如生梵世绝下欲　　于此二相除亦尔
  于法驶流蒙诸佛　　觉悟劝导次其忍
  语言我等诸佛德　　汝今未获常勤进
  汝虽已灭烦恼火　　世间惑焰犹炽然
  当念本愿度有情　　悉使修因趣解脱
  法性常尔离分别　　非但由此显世尊
  二乘于此亦能得　　故当引发一切行
  如是人天应供尊　　授此智令慧观察
  无边佛法悉得成　　一念超过曩众行
  菩萨住兹妙智地　　则获广大神通力
  一念分身遍十方　　如船入海因风济
  心无功用任智力　　悉知世界成坏住
  诸界种种各殊异　　小大无量皆能了
  三千界中四大种　　六趣有情身各别
  及以众宝微尘数　　以智观察悉无余
  菩萨能知一切身　　为化有情同彼形
  刹土无量种种别　　悉为现形无不遍
  譬如日月住虚空　　一切水中皆现影
  住于法界无所动　　随其心乐各不同
  一切众中皆现身　　声闻独觉与菩萨
  及以佛身靡不现　　有情刹土业报身
  种种现身智法身　　虚空身相皆平等
  普为群生而示作　　十种圣智普观察
  复以慈悲作众业　　所有佛法皆成就
  净戒不动如须弥　　十力成就不摇动
  一切魔众无能转　　诸佛加持天王礼
  密迹金刚恒侍卫　　此地功德无边际
  千万亿劫说不尽　　复以供佛善益明
  如王顶上庄严具　　菩萨住此第八地
  多作梵王千界主　　演说三乘无有穷
  慈光普照灭众惑　　一念获得百万界
  微尘数等三摩地　　余所作事悉亦然
  愿力示现复过此　　菩萨第八不动地
  我为汝等已略说　　若以次第广分别
  经于亿劫不能尽

    菩萨不动地第八竟

佛说十地经卷第六佛说十地经卷第七

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨善慧地第九

  已说菩萨第八地　　如来现大神通力
  震动十方诸刹土　　无量亿数难思议
  一切知见无上尊　　其身普放大光明
  照曜彼诸无量土　　悉使有情获安乐
  菩萨无量百千亿　　俱时踊在虚空住
  以过诸天上妙供　　供养说中最胜者
  大自在王自在天　　悉共同心喜无量
  各以种种众供具　　供养甚深功德海
  复有天女千万亿　　身心欢喜悉充遍
  各奏音乐无量种　　供养人天大导师
  是时众乐同时奏　　百千万亿无量别
  悉以善逝威神力　　演出妙音而赞叹
  寂静调柔无垢害　　随所入地善修习
  心如虚空遍十方　　广说佛道悟群迷
  天上人间一切处　　悉现无等妙庄严
  以从如来功德生　　令其见者乐佛智
  不离一刹诸众生　　如月普现照世间
  音声心念悉皆灭　　譬如谷响无不应
  若有有情心下劣　　为彼演说声闻行
  若心猛利乐独觉　　即为彼说中乘道
  若有慈悲乐饶益　　为说菩萨所行事
  若有最胜智慧心　　即示如来无上法
  譬如幻师作众事　　种种形相皆非实
  菩萨智幻亦如是　　虽现一切离有无
  如是美音千万种　　歌赞佛已默然住
  解脱月言今众净　　愿说第九地行道

尔时金刚藏菩萨。告解脱月菩萨言。佛子若是菩萨以从如是无量功德智筹量慧。复于上上寂灭解脱精勤思慕。复更思察上上究竟智慧。趣入如来秘密之门。如理选择不可思议智大我性。净治选择诸陀罗尼三摩地门。善能引发方广神通。善能遍览世界差别。莹饰如来力无所畏不共佛法。无映夺性。于随诸佛转妙法轮入雄特性。不舍所得大悲加持。证入菩萨第九智地。菩萨安住于此地中。如实了知诸善不善无记法行。有漏无漏法行。世间出世间法行。可思议不可思议法行。决定不决定法行。声闻独觉法行。菩萨行法行如来地法行。有为法行无为法行。皆如实知。彼以如是随智行慧。如实了知诸有情心近稠林行。烦恼近稠林行。业近稠林行。根近稠林行。胜解近稠林行。种性近稠林行。意乐随眠近稠林行。受生近稠林行。习气相续近稠林行。三聚安立近稠林行。皆如实知。于是菩萨如实了知诸有情心种种之性。谓心杂性。心相速转坏不坏性。心无质性。心无边际于一切处皆充足性。心本净性。心有杂染无杂染性。心缚解性。心幻起性。心随诸趣现前住性。乃至无量百千种种心差别性。皆如实知

又此菩萨了知烦恼远随行性。于加行无边性。皆悉俱生不相离性。随眠与缠一处住性。与心相应不相应性。受生相续随趣住性。于三界中差别之性。渴爱无明及见箭镞是意罪性。三业因缘不断绝性。略说乃至八万四千。诸烦恼行差别之性。皆如实知

又此菩萨了知诸业善不善无记性。有表无表性。与心共生不相离性。自相因坏积集不失果相续性。有报无报性。黑业白业黑白俱业。不黑不白业受差别性。业田无量性。圣凡有情业差别性。现法生起后所受性。于乘非乘定不定性。乃至无量百千种种业差别性。皆如实知

又此菩萨了知诸根软中胜性。前际后际有差别无差别性。上中下性。与烦恼共生不相离性。于乘非乘定不定性。已成熟未成熟性。根网随转速坏取相性。由根增上无能摧坏性。有退无退根差别性。久远随行共生异性。略要言之。乃至无量百千根差别性。皆如实知

又此菩萨了知胜解软中胜性。前际后际有差别无差别性。上中下性。与烦恼共不相离性。于乘非乘定不定性。知已成熟未成熟性。根网随转速坏取相性。由胜解增上无能摧坏性。有退无退胜解差别性。久远随行共生异性。略要言之。乃至无量百千种种胜解差别皆如实知

又此菩萨了知种性软中胜性。前际后际有差别无差别性。上中下性。与烦恼共生不相离性。于乘非乘定不定性。知已成熟未成熟性。根网随转速坏取相性。由种性增上无能摧坏性。有退无退种性。差别性。久远随行共生异性。略要言之。乃至无量百千种种种性差别皆如实知

又此菩萨了知意乐软中胜性。前际后际有差别无差别性。上中下性。与烦恼共生不相离性。于乘非乘定不定性。知已成熟未成熟性。根网随转速坏取相性。由意乐增上无能摧坏性。有退无退意乐差别性。久远随行共生异性。略要言之。乃至无量百千种种意乐差别皆如实知

又此菩萨了知随眠与意乐共生与心共生性。与心相应及不相应不相离性。久远随行性。无始世来未曾吐性。以诸静虑解脱等持等至神通难摧伏性。能系缚三界受生相续性。从无始世心缚现行性。处门集了别性。得对治事实性。他处和会不和会性。唯以圣道能吐出性。皆如实知

又此菩萨了知受生种种异性随业受生性。地狱傍生鬼阿素洛人天安立性。有色无色受生性。有想无想受生性。诸业为田渴爱所润无明闇覆识为种子生后有芽性。名色俱生不相离性。于有愚痴渴爱希求续受生性。欲爱欲生有情欣乐无始终性。执受三界相牵出性。皆如实知

又此菩萨了知习气行不行性。随趣相续处熏习性。随有情行所熏习性。随业烦恼惯薰习性。随善不善无记法惯熏习性。熏随后有行熏习性。随次第熏习性。远随行惑不断不灭所熏习性。实事体熏习性。见闻亲近声闻独觉菩萨如来熏习之性。皆如实知

又此菩萨如实了知诸有情聚正定邪定俱不定性。由正见故堕正定性。由邪见故堕邪定性。此二俱离堕不定性。于五无间随造一故堕邪定性。由修五根堕正定性。此二俱离堕不定性。由习八邪堕邪定性。由修八正堕正定性。更无所作此二俱离堕不定性。悭嫉无悲现行不息堕邪定性。诲示无上圣道修习堕正定性。此二俱离堕不定性。如是一切皆如实知

佛子菩萨随顺如是智已。名住菩萨善慧地中。彼住菩萨善慧地时。如是了知一切有情诸行差别。如应授彼解脱方便。善能了知有情成熟有情调伏。善能演说声闻乘法。独觉乘法菩萨乘法。了知演说如来地法。此菩萨知如是已。为令有情得如性故演说妙法。随其有情意乐差别随眠差别。随根差别随胜解差别所行境。分别种种现行惯习一切行处智随行故。随顺种性稠林行故。随顺烦恼业受生习气永止息故。随聚安立而随行故。随乘胜解得解脱故。而为说法。佛子菩萨住此善慧地时。作大法师常能守护如来法藏。于是菩萨具法师行。以无量智随行善巧。以诸菩萨四无碍解所引音词。而演说法。于此菩萨圆满无杂四无碍解。恒常随转何等为四。所谓法无碍解义无碍解。词无碍解辩说无碍解。以法无碍解。了知一切诸法自相。以义无碍解。了知一切诸法差别。以词无碍解。善能无杂演说诸法。以辩说无碍解。能知诸法次第相续无间断性

复次以法无碍解。能知诸法无性之体。以义无碍解。如实了知诸法生灭。以词无碍解。能随一切法假安立。能无间断演说正法。以辩说无碍解。不坏诸法如所施设。而能演说无边法要

复次以法无碍解。了知现在诸法差别。以义无碍解。如应了知过去未来诸法差别。以词无碍解。于去来今无杂说法。以辩说无碍解。于一一世能以无边法明说法

复次以法无碍解知法差别。以义无碍解知义差别。以词无碍解随诸言音演说正法。以辩说无碍解随意乐智演说法要

复次以法无碍解。依现法智了知差别无杂善巧。以义无碍解。依于比智了知诸法如是性安。以词无碍解依世俗智显示解释。以辩说无碍解。依胜义智善能说法

复次以法无碍解。知一理趣无毁坏性。以义无碍解。随行趣入蕴界处谛缘起善巧。以词无碍解。依诸世间易可解了。美妙音词文句演说。以辩说无碍解。复依展转无边慧明。如理解释

复次以法无碍解。了知一乘入门差别。以义无碍解。知善分别诸乘差别。以词无碍解。善能无杂演说诸乘。以辩说无碍解。一一各以无边法明解释

复次以法无碍解。能入一切诸菩萨行智行法行。随智而行。以义无碍解。入释十地安立差别。以词无碍解。随应无杂演说授与诸地之道。以辩说无碍解。一一智地能以无边行相解释

复次以法无碍解。知一切佛一刹那顷成正等觉。以义无碍解知种种时事相差别。以词无碍解。如所正觉分别解释而演说法。以辩说无碍解。一一法句无量劫中释无穷尽复次以法无碍解。知诸佛语力无所畏。不共佛法大慈大悲。辩才加行转大法轮。一切智智随顺之行。以义无碍解。了知如来随诸有情。八万四千行类差别。随其意乐随根胜解所演音词。以词无碍解。为诸有情随行差别。以佛音词演说正法。以辩说无碍解。随如来智清净行轮胜解说法。佛子菩萨安住第九善慧地已。成就如是无碍解智。得佛法藏作大法师。得具义陀罗尼。具法陀罗尼。具引发智陀罗尼。具光照陀罗尼。具善慧陀罗尼。具众财陀罗尼。具威德陀罗尼。具无碍门陀罗尼。具无边际陀罗尼。具种种义陀罗尼。获如是等圆满百万阿僧企耶诸陀罗尼。仍以百万阿僧企耶。音支善巧及以若干。无量辩才剖析之门为他说法。而此菩萨以依如是无量百千阿僧企耶陀罗尼门。无量佛所听闻妙法。闻已不忘。而所闻法。能以无量差别演说。于一佛前。悉以百万阿僧企耶陀罗尼门领受正法。如一佛前。无量佛所亦复如是。然此菩萨以一念顷。于佛世尊正等觉前。所领无量妙法明门。彼得多闻闻持声闻。于百千劫不能领受。即此菩萨成就如是诸陀罗尼。得辩才已坐于法座。遍满三千大千世界。随其有情意乐差别。而为说法。彼之法座最为殊胜。唯除诸佛及受灌顶上地菩萨。其余菩萨威德光明。无能与比。而此菩萨处于法座随自乐故。以一音词演说妙法。能令大众皆得解了。或随自欲。以种种言词音支剖析。今诸大众皆得开悟。或随自欲放大光明。从此演出无量法门。或随自欲。从其身上一一毛孔皆演法音。或随自欲。于此三千大千世界。所现色像从此一切悉能演出妙法言音。或随自欲。以一音词。周遍显了一切法音。或随自欲。加持一切所有音词。皆能令作微妙法音。或随自欲。以从一切世界所属歌咏乐声皆演法音。或随自欲。从一字音演出一切法差别音。或随自欲。于不可说无量世界地水火风。四大聚中所有微尘。令一一尘皆悉演出不可说法门。假使千界所系有情咸至其前。于一刹那瞬息须臾。一一皆以无量言音而兴问难。一一问难各各不同。而此菩萨于一念顷。彼诸言音随句随文悉能领受。仍以一音普为解释。令随意乐各得欢喜。假使二千或三千界。或至不可说三千大千世界所系一切有情。一刹那间一一各以无量言音而兴问难一一问难各各不同。菩萨于一念顷悉能领受。亦以一音普为解释。令随意乐各得欢喜。乃至遍满不可说不可说世界。随其有情意乐根解。演说妙法。得法讲论求佛加持。能转法轮广作佛事。普为有情作所依怙

复次而此菩萨。更为受持如是法明发此愿言。假使于一毛端之处。有不可说诸世界中微尘数佛。各于若干众会说法。一一如来亦为若干有情随心差别说法。各随一一有情意乐。授与若干无量法门。如一如来众会之中。一切如来众会亦尔。如一毛端处。一切法界中悉亦如是。我等于中应发如是无量念力。如于一切诸如来所。一切法明悉能领受。菩萨住此善慧地中。昼夜转更无余作意。入佛境界亲近如来。逮得甚深菩萨解脱。而此菩萨随如是智。常在定中现见诸佛未曾暂舍。一一劫中见无量佛无量百佛。无量千佛无量百千佛。无量百千那庾多佛。无量俱胝佛无量百俱胝佛。无量千俱胝佛无量百千俱胝佛。乃至无量百千俱胝那庾多佛。常以微妙供养之具供养承事。于诸佛所种种启问。得法总持复能演说。于是菩萨此诸善根。转更明净不可映夺。佛子譬如善巧金师以所炼金。作庄严具善莹终毕。转轮圣王以严其首。或置颈下。其余一切诸粟散王。及四洲内一切臣民。庄严之具无与等者。佛子菩萨住此善慧地中。此诸善根亦复如是。此以一切声闻独觉。并住下地一切菩萨所不能及。又此菩萨善根光明。悉能照曜有情烦恼心等稠林。从此回转。佛子譬如二千界主大梵天王。身出光明二千界中。稠林幽邃悉能照曜。菩萨住此善慧地时。善根光明亦复如是。照曜有情心及烦恼稠林等已。从此回转。彼于十种波罗蜜多。力到彼岸而为增上。余到彼岸随力随分。非不修行。佛子是名略说菩萨第九善慧智地。若广说者于无量劫说不能尽。此地菩萨。受生多作大梵天王。具大威势王二千界。最为殊胜无所映蔽。善见利益得大自在。能为有情演说声闻独觉菩萨到彼岸行有。情意乐问答之处无能屈者。诸所作业。或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意法作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意佛力作意。无所畏作意不共佛法作意。乃至不离一切行相胜妙相应一切智智作意。常作愿言。我当一切诸有情中为首为胜为殊胜。为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进于一刹那瞬息须臾。得满百万阿僧企耶佛刹微尘数诸三摩地。能见百万阿僧企耶佛刹微尘数佛。彼佛加持皆能解了。能动百万阿僧企耶佛刹微尘数世界。能往百万阿僧企耶佛刹微尘数诸佛国土。能照百万阿僧企耶佛刹微尘数世界。成熟百万阿僧企耶佛刹微尘数有情。住寿百万阿僧企耶佛刹微尘数劫。于前后际各入百万阿僧企耶佛刹微尘数劫。思择百万阿僧企耶佛刹微尘数法门。示现百万阿僧企耶佛刹微尘数身。身身皆能示现百万阿僧企耶佛刹微尘数等菩萨。眷属围绕。从此以上是诸菩萨。有愿力者由胜愿故。所有游戏。或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数。尔时金刚藏菩萨。欲重宣此义而说颂言

  于前无量甚深智　　不乐趣求胜解脱
  观佛智入佛秘密　　选择妙智不思议
  净治总持等持门　　获大神通入众刹
  修力无畏不共法　　顺大悲入第九地
  菩萨住斯善慧地　　了善不善及无记
  有漏无漏世出世　　思不思议悉善知
  若法决定不决定　　三乘所行及佛地
  有为无为行差别　　如是而知入世间
  即能解了有情心　　烦恼业报及胜解
  种性意乐并随眠　　受生习气聚稠林
  知心种种速转性　　无质无边等众相
  烦恼无边互相生　　眠缠共处续诸趣
  业性种种各差别　　因坏果集皆了知
  诸根种种下中上　　前后际等无量别
  胜解种性及意乐　　皆亦如是靡不知
  随眠常惑有情见　　无始稠林未除剪
  与意乐俱心并生　　常相羁系不断绝
  但唯妄想无实体　　不离于心无处所
  虽修定等犹难遣　　唯金刚道方能灭
  六趣受生各差别　　业田爱润无明覆
  识为种子名色芽　　三界无始恒相续
  集趣行业烦恼习　　渐次复生不离惑
  群生悉在三聚中　　或溺于见或行道
  此地菩萨善观察　　随其意乐及根解
  悉以无碍妙辩才　　如应差别为说法
  处于法座如师子　　亦如牛王宝山王
  又如龙王布密云　　霔大甘雨充巨海
  善知法相及奥义　　随顺言词能辩说
  总持百万阿僧祇　　譬如大海受众雨
  总持等持皆清净　　能于一念见多佛
  一一佛所皆闻法　　复以妙音而演畅
  随欲三千大千界　　教化一切诸群生
  如云广布无不及　　随其根欲悉令喜
  十方无量诸有情　　咸来亲近会中坐
  一念随心各问难　　一音普对悉充足
  毛端佛众无有数　　有情意乐亦无穷
  悉应其心与法门　　一切法界皆如是
  菩萨勤加精进力　　复获功德转增胜
  闻持字所诸法门　　如地能持一切种
  住此绍法太子位　　随机诲诱无厌倦
  日夜见佛未曾舍　　入深寂灭智解脱
  供养诸佛善益明　　如王顶上妙金饰
  复使有情灭烦恼　　譬如梵王光普照
  住此多作大梵王　　以三乘法化有情
  所行善业普饶益　　乃至当成一切智
  一念能入于百万　　阿僧祇刹尘数定
  见佛等事亦复然　　愿力所作犹过是
  此是第九善慧地　　大智菩萨所行处
  甚深微妙难可见　　我为佛子已略说

    菩萨善慧地第九竟

佛说十地经卷第七佛说十地经卷第八

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨法云地第十之一

  净居天众那庾多　　闻此地中之胜行
  空中踊跃心欢喜　　悉共虔诚供养佛
  不可思议菩萨众　　亦在空中大欢喜
  俱燃最上悦意香　　普熏众会令清净
  自在天王与天众　　无量亿数在虚空
  普散天衣供养佛　　百千万种缤纷下
  天诸婇女无有量　　靡不欢喜供养佛
  各奏种种妙乐音　　悉以此言而赞叹
  如来安坐一刹土　　一切世界悉现身
  身相端严无量亿　　法界广大悉充满
  于一毛孔放光明　　普灭世间烦恼闇
  国土微尘可知数　　此光明数不可识
  或现如来具众相　　转于无上正法轮
  或现游行诸佛刹　　或现寂然安不动
  或现住于喜足宫　　或现下生入母胎
  或示住胎或出胎　　悉令无量国中见
  或现出家修圣道　　或现道场成正觉
  或现说法或涅槃　　普使十方无不睹
  譬如幻师知幻术　　在于大众多所作
  如来智慧亦复然　　于世间中普现身
  佛住甚深真法性　　寂灭无相同虚空
  而于第一实义中　　示现种种所行事
  所住利益有情事　　皆依法性而得有
  相与无相无差别　　入于究竟皆无相
  若有欲证如来智　　应离一切妄分别
  有无通达皆平等　　疾作人天大导师
  无量无边天女众　　种种言音称赞已
  身心寂静共安乐　　瞻仰如来默然住
  即时菩萨解脱月　　知诸众会咸寂静
  白金刚藏而请言　　大无畏者真佛子
  从第九地入第十　　所有功德诸行相
  及以神通变化事　　愿为慧者今宣说

尔时金刚藏菩萨。告解脱月菩萨言。佛子若是菩萨以于如是无量所知能观察慧。乃至菩萨第九地终。善选决择善备白法。善集无边资粮之集。已善摄受广大福智。已证无量大慈大悲。了知世界剖析差别。已入有情界稠林行。以想作意顺入佛境。缘力无畏不共佛法。名为已至于一切种。一切智智受灌顶地。佛子即此菩萨。已能随顺如是智行。预于菩萨灌顶位者。得名无垢大三摩地而现在前。名法界剖析差别三摩地。名庄严菩提道场三摩地。名一切种光华三摩地。名海藏庄严三摩地。名海印三摩地。名虚空界广大三摩地。名选择一切法自性三摩地。名随一切有情心行三摩地。名现在一切诸佛现。前住三摩地而现在前。然此菩萨如是。上首百万阿僧企耶诸三摩地皆现在前。菩萨于此诸三摩地出入自在。于三摩地得善巧已。乃至现受一切等持所作事业。而此菩萨乃至百万阿僧企耶三摩地。后名一切智智殊胜。灌顶大三摩地而现在前。此三摩地才现前时。有大宝王莲花出现。其花量等百万三千大千世界以众妙宝间错庄严。超过一切世间境界。出世善根之所生起。如幻自性。境界所成。依善成立法界影现。非诸天处之所能有。摩诃吠琉璃摩尼宝为茎。无比旃檀王。以为其台。码瑙为须。阎浮檀金为叶。无量光明以众名花之所晃耀。一切妙宝厕填其藏。以无边际宝网弥覆。以满百万三千大千世界微尘数莲花而为眷属。尔时菩萨身相姝妙。与其莲花正等相称。即此菩萨一切智智。殊胜灌顶大三摩地现在前故。示坐宝王莲花座上。菩萨适坐于此座已。其大宝王莲花妙座。所有若干莲花眷属亦有尔所菩萨眷属来坐其上。周匝围绕此大菩萨。恭敬瞻仰大菩萨身。一一菩萨各得百万诸三摩地。是大菩萨并其眷属。一切菩萨适入定时。一切世界咸大震动。一切恶趣皆悉休息。光明遍照一切法界。一切世界周遍严净。诸佛刹中所有言音此皆得闻。所有一切同行菩萨靡不来集。一切世间人天音乐同时发声。一切有情悉得安乐。一切诸佛正等觉前。不可思议供养承事同时而转。十方一切诸佛众会。皆有证知。所以者何。佛子菩萨适坐此大宝王莲花座已。从两足下放百万阿僧企耶。光明普照十方。下至无间大捺洛迦除灭其苦。从两膝轮放百万阿僧企耶光明。普照十方诸傍生趣除灭其苦。从脐轮中放百万阿僧企耶光明。普照十方诸琰魔界除灭其苦。从左右放百万阿僧企耶光明。普照十方一切人身除灭其苦。从两手掌放百万阿僧企耶光明。普照十方一切诸天及阿素洛所居宫殿。从两肩上放百万阿僧企耶光明。普照十方诸声闻众。从其项背放百万阿僧企耶光明。普照十方诸独觉身。从其面门放百万阿僧企耶光明。普照十方从初发心乃至九地一切菩萨。从白毫相放百万阿僧企耶光明。于十方界隐蔽一切诸魔宫殿。并照十方得灌顶位诸大菩萨照已而住。从其顶上放满百万阿僧企耶三千大千世界微尘数光明。普照十方一切诸佛道场众会。右绕十种诸世间已。住虚空中成就广大光明网轮。于诸佛前转大供养名炽然光耀。从初发心乃至九地。所转无量诸佛供养。而比于此百倍不及一。千倍百千倍。俱胝倍百俱胝倍。千俱胝倍百千俱胝倍。百千俱胝那庾多倍不及其一。算计譬喻乃至邬波尼杀昙分所不能及。从其广大光明网轮。雨众妙香烧香涂香末香花鬘。衣服幢幡宝盖宝璎。摩尼宝等庄严之具。犹如大云降注大雨。此诸一切超过其余世间所有。皆从出世增上善根力所生起。普及十方一一如来众会之前以为供养一切诸佛。若诸有情觉知如是大供养者。此等一切皆于无上正等菩提得不退转。是诸光明已转如是供养事毕。已照一切如来众会。已遍右绕十种世间。从诸如来足下而入。尔时诸佛及诸菩萨。寻即了知于某世界。某大菩萨成就如是广大正行到灌顶位。佛子是时十方无量无边。乃至九地诸菩萨众皆来围绕。设大供养一切瞻仰。此菩萨时各获百万诸三摩地。当尔之时十方所有。已受灌顶诸大菩萨。彼悉皆于金刚庄严臆德相中。出一大光明名能摧伏一切魔怨。百万阿僧企耶光明以为眷属。普照十方现于无量神通变化。作是事已。入此菩萨金刚庄严臆德相中。其光入已。令此菩萨智慧威势增长。比前过百千倍。佛子尔时十方一切诸佛如来应供正遍等觉。皆从眉间白毫相中。出大光明。名具一切智性神通。无数光明以为眷属。其光普照十方无余一切世界。右绕十种一切世间。显示如来广大游戏开悟无量百千俱胝那庾多诸菩萨众。一切佛刹六种震动。止息一切诸险恶趣死生轮转。隐蔽一切诸魔宫殿。普示一切如来成道正觉之座。显示一切诸佛众会。庄严威德普遍照曜。极于法界尽虚空性诸世界已。时大光明。还来至此一切菩萨众会之上。周匝围绕。显示广大庄严事毕。从大菩萨顶上而入。其眷属光明亦各入彼诸来会坐菩萨顶上。光入之时彼诸菩萨各得百万先所未得诸三摩地。是诸光明俱时入此菩萨顶已。则得名为于佛境界已受灌顶。若满十力则堕正遍等正觉数。佛子譬如转轮圣王太子。正后所生具足王相。其转轮王。令此太子坐白象宝妙金之座。张大网幔建大幢幡。华盖衣服然香散花。末香花鬘奏诸音乐。令取四洲四大海水置金瓶内。转轮圣王手自执瓶灌太子顶。才灌顶已。则堕灌顶刹利王数。若转具足十善业道。而乃得名转轮圣王。佛子菩萨亦复如是。才从诸佛得灌顶已。名为已受智水灌顶。若满十力则堕正遍等正觉数。佛子是名菩萨大乘灌顶。为此灌顶菩萨发起无量百千难行之行。菩萨如是受灌顶已。增长无量智慧功德。名为安住法云地中

佛子菩萨住此法云地时。知欲界集色界集无色界集。有情界集识界集有为界集无为界集。虚空界集法界集涅槃界集。皆如实知。了知见行烦恼之集。世界成坏集声闻行集。独觉行集。菩萨行集。佛力无畏不共佛法色身法身集。以一切种一切智智集。示成正觉转大法轮入灭度集。入一切法分别显了集。举要言之。以一切种一切智智集。皆如实知。又此菩萨以依如是随智行慧。渐更了知有情变化。业烦恼变化见行变化。世界变化法界变化。声闻变化独觉变化。菩萨变化如来变化。于诸一切变化差别无分别性。皆如实知

又此菩萨知佛加持法加持。僧加持业加持。烦恼加持。时分加持。愿加持供养加持。正行加持劫加持智加持。皆如实知

又此菩萨了知诸佛正等觉者入微细智。所谓或入行微细智。或入降下受生微细智。或入生微细智。或入游戏微细智。或入出家微细智。或入成正觉微细智。或入转法轮微细智。或入加持筹量微细智。或入涅槃微细智。或入法住微细智。此之一切皆如实知又此菩萨了知佛正等觉者。所有一切秘密之处。所谓或身秘密。或语秘密或心秘密。或时非时筹量秘密。或授菩萨记别秘密。或摄摧伏有情秘密。或乘种种差别秘密。或有情根行差别秘密。或入诸业作用秘密。或行成道觉悟自性秘密此之一切皆如实知又此菩萨了知诸佛所有一切趣入劫智。所谓或时一劫入无数劫。或无数劫入于一劫。或有数劫入无数劫。或无数劫入有数劫。或刹那入劫。劫入刹那。或劫入非劫。非劫入劫。或有佛劫入无佛劫。无佛之劫入有佛劫。或入无佛刹或入有佛刹。或过去劫入未来现在。现在劫入过去未来。未来劫入过去现在。或长劫入短劫。短劫入长劫。或短劫入非短劫。非短劫入短劫。一切劫中入相所作。此之一切皆如实知

又此菩萨了知诸佛正等觉者所有入智。所谓或入愚道智。或入微尘智。或入刹土身正觉智。或入有情身心正觉智。或入一切处随顺正觉智。或入示现乱行智。或入示现顺行智。或入示现逆行智。或入示现思议不思议世间可了不可了行智。或入示现声闻所知独觉所知菩萨所知如来所知行智。此之一切皆如实知。佛子诸佛如来智广无量。于此地中菩萨入智亦无有量

佛子复次菩萨如是随顺此地之行。逮得菩萨不可思议解脱。无障碍解脱。清净决择解脱。普门显发解脱。如来藏解脱随顺无碍轮解脱。随三世行解脱。法界藏解脱。解脱轮光耀解脱。无余境界解脱。佛子菩萨安住于此第十法云地中。此十解脱而为上首。逮得无量无数百千诸解脱门。如是逮得乃至无量无数百千诸三摩地。无量无数百千陀罗尼。逮得无量无数百千神通引发

佛子此菩萨成就如是随智行慧。随顺无量善巧念力。十方无量诸佛如来。所有无量大法光明。大法照耀大法之云。此一刹那瞬息须臾。皆能堪任咸能领纳。悉能摄受普能任持。佛子譬如娑伽罗云注大水聚。此除大海余地方所不能堪任领纳。不能摄受不能任持。诸佛所有入佛秘藏。所谓大法光明大照曜大法之云。此诸有情诸声闻众一切独觉。并从初地至第九地。一切菩萨不能堪任不能领纳。不能摄受不能任持亦复如是。菩萨住此法云地中。此之一切皆能堪任咸能领纳。悉能摄受普能任持。佛子譬如大海一大龙王所注大雨。皆能堪任皆能领纳。悉能摄受普能任持。若二若三乃至无量。诸大龙王同一刹那瞬息须臾。所注大雨。皆能堪任咸能领纳。悉能摄受普能任持。所以者何。大海无量纵广宽故。佛子菩萨住此法云地中。亦复如是。于一佛前无量法明法照法云。刹那瞬息须臾皆能堪任领纳摄受任持。若二若三乃至无量诸如来前。无量法明法照法云。刹那瞬息须臾皆能堪任领纳摄受任持。是故此地名为法云

解脱月菩萨言。唯佛子岂能算数此地菩萨。于刹那顷瞬息须臾。能几佛所。堪任领纳摄受任持大法光明大法照曜大法云耶。金刚藏菩萨言。佛子不可以算数宣说此事。此地菩萨能于若干诸如来所。于刹那顷瞬息须臾。堪能领纳摄受任持大法光。明大法照曜大法之云。然为仁者当说譬喻。佛子譬如十方百万俱胝那庾多不可说佛刹微尘等诸世界中所有无余诸有情界。其中设有随一有情。已得最上闻持总持为佛侍者。声闻众中多闻上首。犹如金刚莲花上佛如来应供正等觉所大胜苾刍。此一有情。设得成就如是多闻善巧力持。如一有情。于彼无余诸世界中一切有情。设亦成就如是多闻陀罗尼力。然一有情所受之法余不重受。佛子于意云何。彼诸有情多闻善巧宁无量不。解脱月菩萨言。佛子彼诸有情多闻善巧甚多无量。金刚藏菩萨言。佛子今当告汝令得解了。菩萨安住于法云地。于一佛所一刹那顷。所任所领所摄所持。名三世法界藏大法光明法照法云。比此大法光明照云任持善巧。于前尔所世界有情多闻善巧。百倍不及一。千倍百千倍俱胝倍百俱胝倍千俱胝倍百千俱胝倍百千俱胝那庾多倍不及其一。算计譬喻乃至邬波尼杀昙倍所不能及。如一佛所。如是十方如前所说诸世界中。所有若干微尘之数。尔所如来正等觉所。复过此数无量无边。诸如来所所有三世法界藏大法光明法照法云。此等皆能一刹那顷瞬息须臾堪任领纳摄受任持。是故此地名为法云

复次佛子菩萨安住法云地已。从此愿力起大悲云震大法雷。神通无畏电光晖昱。大光明风迅转遐布。以大福智厚雾弥覆。现种种身叆叇旋还。发大法吼骇蹙魔军。于一刹那瞬息须臾普遍十方。于前所说诸世界中微尘数等。复过此数。普覆无量百千俱胝那庾多世界。澍大无比甘露法雨。殄息有情无知所起众惑尘焰。令随意乐善根稼穑增长成熟。是故此地名为法云

复次佛子菩萨住此法云地中。于一世界处睹史多天宫为首。降下入胎住生出家成道。受请转大法轮归大涅槃。随所应度有情意乐。示现种种一切佛事。若二若三乃至如上诸世界中。所有微尘复过此数。无量百千俱胝那庾多。诸世界中处睹史多天宫为首。乃至示入大般涅槃。随所应度有情意乐。示现种种一切佛事。菩萨如是得智自在极善决择。大智神通随自心欲。能以狭小世界示现宽广。宽广世界示现狭小。复随心欲杂染世界示为清净。清净世界示为杂染。如是广大无量粗细。乱住正住覆仰住等。一切世界自在力故。皆能引发彼彼示现。或此菩萨随其心欲。于一尘中置一世界。周遍乃至轮围山际。微尘不增世界不减。然彼作用悉令显现。或复于一微尘之中。置二置三四五乃至不可说世界。一一世界皆悉周备。各各乃至轮围山际。而彼微尘体相如本。于中世界悉得明现。或随心欲于一世界中示二世界庄严之事。乃至示现于不可说世界庄严。或随心欲能以一世界庄严之事示二世界中。乃至示现于不可说诸世界中。复随乐欲乃至于不可说诸世界中所有有情。此之一切悉能示现。于一世界而于有情无所逼恼。复随乐欲一世界中。所有若干诸有情界此之示现。于不可说诸世界中。而于有情无所逼恼。复随意欲于一毛道。示现一佛境界庄严。乃至示现于不可说一切诸佛境界庄严。复随心欲于一刹那瞬息须臾。化不可说诸世界中微尘数身。于一一身示现若干微尘数手。以此诸手殷勤供养十方诸佛。以一一手各持殑伽沙数花奁。以散诸佛香箧花鬘。涂香末香衣服宝盖。幢幡一切诸庄严具。皆亦如是于一一身。复示尔所微尘数头。一一头中加持尔所微尘数舌。以此诸舌称赞十方诸佛功德。复于一一心念之间遍历十方。于心念顷普遍十方。示成正觉乃至涅槃。加持国土庄严之事。于三世中示无量身。或于自身示有无量诸佛世尊。无量无边佛刹庄严。于自身中能示一切世界成坏。从一毛孔随欲引出一切风轮。而于有情无所恼害。复随心欲无边世界示一大海。此海水中现大莲花。其光严饰遍满无量无边世界。于中示现大菩提树庄严之事。乃至示成以一切种胜妙相应一切智性。或于自身现十方界一切光明摩尼宝珠日月星宿云电等光。靡不皆现。以口嘘气能动十方无量世界。而不令彼有情惊怖。复现十方风灾火灾及以水灾。随意随欲悉能加持。一切有情色身严好。或自身中示现佛身。或佛身中示现自身。或佛身中现已刹土。或已刹土示现佛身。佛子菩萨安住法云地已。能现如是及余无量百千俱胝那庾多数神变游戏

佛说十地经卷第八佛说十地经卷第九

        大唐于阗三藏沙门尸罗达摩于北庭龙兴寺译

    菩萨法云地之余

尔时会中。一类菩萨天龙药叉健达缚阿素洛竭路茶紧捺洛牟呼洛伽。释梵护世摩醯首罗净居天众。各起是念。若时菩萨神通行相智力境界。如是无量佛复云何。尔时解脱月菩萨。知诸众会心所念已。白金刚藏菩萨言。佛子今此大众。闻其菩萨神通智力堕在疑网。善哉仁者为断彼疑。当少示现菩萨神变庄严之事。尔时金刚藏菩萨。即入示现一切佛刹体性菩萨三摩地。时金刚藏菩提萨埵。入此示现一切佛刹体性菩萨三摩地已。时彼一切天龙药叉健达缚阿素洛释梵护世摩醯首罗净居天众。皆见自身在金刚藏菩萨身内。于中复见成佛刹土。于其刹中所有种种行相庄严。彼经满足俱胝大劫说不能尽。又即于中见菩提树。其身周围量等百万三千世界。枝条棽俪高广无量。垂荫圆满俱胝三千大千世界。称树形量有师子座。其上见佛号一切神通慧王如来。坐在树下菩提道场。如是于中所现种种妙庄严事。设使圆满俱胝大劫说不能尽。时金刚藏菩提萨埵。示现如是大神变已。还令一切菩萨众会。一切天龙药叉健达缚阿素洛揭路茶紧捺洛牟呼洛伽。释梵护世摩醯首罗净居天众。各在本处。时诸大众生未曾有希奇之想默然而住。向金刚藏菩提萨埵。一心瞻仰

尔时解脱月菩萨白金刚藏菩萨言。佛子甚奇希有。此三摩地具足尔所威力庄严。佛子此三摩地名为何等。金刚藏菩萨言。此三摩地名为示现一切佛刹体性。解脱月菩萨问言。佛子此三摩地所行境界庄严云何。金刚藏菩萨答言佛子菩萨修此三摩地故。能示身中如上所见。殑伽沙数世界微尘等诸佛刹土。复过此数示现身中如上所见无量刹土。佛子菩萨住此法云地中。获如是等无量百千诸三摩地。由是义故。余诸菩萨乃至已得法太子位。安住菩萨善慧地者。不能测知此地菩萨身或身业。语或语业意或意业。神通自在观察三世。诸三摩地所行随入智慧境界。游戏一切诸解脱门。不能测知诸变化业。或加持业或威力业。略要言之乃至已得法太子位已。住菩萨善慧地中。诸菩萨众不能测知此地菩萨乃至举足下足之业。佛子此菩萨法云地如是无量。但以略说若广说者。假使百千阿僧企耶劫中演说亦不能尽。解脱月菩萨言。佛子若于此中菩萨正行境界加持如是无量。如来所行境界证入其复云何。金刚藏菩萨言。佛子譬如有人于四洲界。取一砂砾或二或三。大如枣核而作是言。为于无边诸世界中地界土多。为此多耶。我观汝问亦复如是。如来应供正遍等觉。无量智者无比法性。云何汝今以与诸菩萨法性比量。然善男子如从四洲世界地分所取砂砾。此谓极少余诚无量。佛子即此菩萨法云智地亦复如是。设于无量劫中演说。但能说其一分之义。况如来地。佛子我今告汝令汝解了。如来世尊坐在我前为我作证。佛子假使十方于一一方。各有无边世界微尘诸佛刹土。一一刹土得如是地菩萨。充满如甘蔗竹稻麻丛林。彼诸菩萨无量劫中。所引菩萨正行智慧。此比如来境界。百分不及一。千分百千分俱胝之分。百俱胝分千俱胝分百千俱胝分百千俱胝那庾多分不及其一。算数计喻乃至邬波尼杀昙分亦不能及。佛子菩萨随顺如是智行。不异如来身语意业。不舍菩萨三摩地力。而见诸佛承事供养。一一劫中。以一切种上妙供具。如应供养无量诸佛。而能具受诸佛如来加持显发转更增胜。于法界中所有问难善为解释。无量百劫无量千劫。无量百千劫无量百千那庾多劫。无量俱胝劫无量百俱胝劫。无量千俱胝劫无量百千俱胝劫。无量百千俱胝那庾多劫。无能屈者。佛子譬如善巧金师。以天真金作大严饰。大摩尼宝钿厕其间。自在天王以严其首或系其颈。其余天人庄饰严具所不能及。佛子菩萨住此法云地中亦复如是。此之智行不可映夺。一切有情一切声闻及诸独觉。始从初地乃至九地。一切菩萨所有智行皆不能及。此地菩萨智慧光明。能令有情乃至入于一切智智。而以一切余智光明不可映夺。佛子如大自在天王。光明超过一切受生之处。能令有情身心悦豫。佛子菩萨安住于此第十法云地者。智慧光明亦复如是。一切声闻及诸独觉。始从初地乃至安住第九地中。一切菩萨智慧光明所不能及。能令有情乃至住于一切智智法性之中。佛子菩萨如是已能随顺智慧而行。诸佛世尊。复更为说通三世智法界差别智。遍满一切诸世界智。照一切世界加持之智。遍知一切诸有情类刹土法智。举要言之。乃至为说一切智智。彼于十种波罗蜜多。智到彼岸最为增上。余到彼岸非不修行随力随分。佛子是名略说菩萨第十法云地。若广说者。假使无量阿僧祇劫不可穷尽。菩萨住此受生多作大自在天王。于法自在能授有情声闻独觉一切菩萨到彼岸行。法界差别问答之中无能屈者。诸所作业或以布施或以爱语。或以利行或以同事。此等一切悉皆不离佛作意僧作意。僧伽作意菩萨作意。菩萨行作意到彼岸作意。诸地作意。佛力作意。无所畏作意佛不共法作意。乃至不离以一切种胜妙相应一切智智作意。常作愿言。我当一切诸有情中为首为胜为殊胜。为妙为微妙为上为无上。为导为将为帅。乃至愿得一切智智所依止处。若乐发起如是精进。由是精进于一刹那瞬息须臾。得入百万俱胝那庾多不可说佛刹微尘等诸三摩地。能见百万俱胝那庾多不可说佛刹微尘等诸佛。彼佛加持皆能解了。能动百万俱胝那庾多不可说佛刹微尘等世界。能往百万俱胝那庾多不可说佛刹微尘等诸佛国土。能照百万俱胝那庾多佛刹微尘等世界。成熟百万俱胝那庾多不可说佛刹微尘等有情。住寿百万俱胝那庾多不可说佛刹微尘等劫。于前后际。各入百万俱胝那庾多不可说佛刹微尘等劫。思择百万俱胝那庾多不可说佛刹微尘等法门。示现百万俱胝那庾多不可说佛刹微尘等身。身身皆能示现百万俱胝那庾多不可说佛刹微尘等菩萨眷属围绕。从此已上是诸菩萨。有愿力者由胜愿故。所有游戏或身或光明或神通。或眼或境界或音声或行。或庄严或胜解或所作。此等乃至尔所百千俱胝那庾多劫不易可数佛子是诸菩萨十种智地悉皆随顺。一切种一切智智渐现前故。佛子譬如从无热池。流出之水以四河口。流注润泽赡部洲地。无尽无竭复更增长。乃至入海令其充满。佛子从菩提心流出善根亦复如是。以大愿流四种摄事。充满饶益诸有情界。无有穷尽复更增长。乃至入于一切智海令其充满

佛子是诸菩萨十地依因佛智而得显现。佛子譬如依因大地。十大山王而得显现。何等为十。所谓雪山王。香醉山王。裂穷山王。神仙山王。持双山王。马耳山王。持鱼山王。轮围山王。幢相山王。妙高山王。佛子如雪山王一切药草种类出处。是诸药草采不可尽。菩萨住在极喜地中亦复如是。能为一切世间书论。文颂明咒所依出处。其诸世间书论技艺。文颂明咒说不可尽。佛子譬如香醉大山王。一切香类为所出处。于中诸香取不可尽。菩萨住在离垢地中亦复如是。能为一切菩萨净戒律仪行香所依出处。以诸菩萨净戒律仪行香无尽。佛子譬如裂穷大山王纯宝所成一切众宝种类出处。于中众宝取不可尽。菩萨住在发光地中亦复如是。能为一切世间静虑。神通解脱等持等至所依出处。以于一切世间静虑神通解脱等持等至。问答之中不可穷尽。佛子譬如神仙大山王纯宝所成。五通神仙所依出处。于中五通神仙众会不可穷尽。菩萨住在焰慧地中亦复如是。能为一切于道非道。殊胜智慧所依出处。于一切道非道殊胜智问答中不可穷尽。佛子譬如持双大山王纯宝所成。一切药叉大神出处。于中一切药叉大神众不可穷尽。菩萨住在难胜地中亦复如是。能为一切神通威力自在变化所依出处。于诸一切神通威力自在变化问答之中不可穷尽。佛子譬如马耳大山王纯宝所成。一切诸果种类出处。于中诸果取不可尽。菩萨住在现前地中亦复如是。能为趣入演说缘起所依出处。声闻果证问答之中不可穷尽。佛子譬如持鱼大山王纯宝所成。一切大力龙神出处。于中一切大力龙众无有穷尽。菩萨住在远行地中亦复如是。能为演说方便妙慧所依出处。独觉果证问答义中不可穷尽。佛子譬如铁轮围大山王纯宝所成。诸自在众所依出处。以自在众不可穷尽。菩萨住在不动地中亦复如是。能为引发一切菩萨自在问答所依出处。于诸世间剖析问答不可穷尽。佛子譬如幢相大山王纯宝所成。诸大威德阿素洛众所依出处。以大威德阿素洛众不可穷尽。菩萨住在善慧地中亦复如是。能为一切世间流转止息智行所依出处。一切世间生问答中不可穷尽。佛子譬如妙高大山王纯宝所成。大威德天所依出处。于中诸大威德天众不可穷尽。菩萨住在法云地中亦复如是。能为如来力无所畏不共佛法所依出处。于诸佛事示现问答不可穷尽。佛子如此十种大宝山王同在大海所显菩萨十地。亦复如是。悉皆同在一切智智亦以一切智智所显

佛子譬如大海以十行相。无映夺故堕在海数。何等为十。所谓渐次深故。不共死尸而停宿故。余水入中舍名数故。同一味。故多珍宝故。深难下故。广无量故。大身种类所居处故。潮不违越所立限故。能受一切大云之雨不厌足故。佛子诸菩萨行亦复如是。以十行相无映夺故堕大行数。何等为十。所谓极喜地中引发大愿渐次深故。离垢地中不共毁禁死尸停故。发光地中世间假立舍名数故。焰慧地中以于诸佛不坏净信同一味故。难胜地中引发无量方便神通世间事用多珍宝故。现前地中观察缘起甚深理故。远行地中以广无量妙慧决择诸善巧故。不动地中引发示现大庄严故。善慧地中如理通达甚深解脱及世间行终不违越所立限故。法云地中能受一切诸佛法明。大云之雨无厌足故。佛子譬如大摩尼宝。若时超过十种宝性。而乃采得善巧上匠。以火炙治善圆无缺。善净离垢善莹明彻善妙钻穿贯以宝缕。置吠琉璃高幢之上。普放一切种种光明王所许可。是时能雨一切众宝。随欲摄益一切有情。令其心愿悉得充满。佛子当知萨婆若心亦复如是。若时菩萨大菩提心。超过十种圣者种性。而乃得起杜多功德。远离戒禁善炙炼冶。静虑等持等至圆满。道支行相善净无垢。方便神通善莹明彻。以缘起观善妙钻穿。贯以种种方便慧缕。置于自在高幢之上。观众生行放闻慧光。正等觉智受灌洒已。是时得名一切智者。能为一切诸有情界广作佛事。佛子当知此能积集诸菩萨行。以一切种一切智智功德性聚妙法门品。未种善根诸有情类终不得闻。解脱月菩萨言。唯佛子。若有有情耳根得闻此一切种一切智智功德性聚妙法门品。此等成就几所福聚。金刚藏菩萨言。佛子一切智智所有若干威力自在。发一切智心摄缘故。亦有尔所福德之聚。发一切智心摄缘故。所有若干福德之聚现前。闻此妙法门品。当得尔所福德之聚。所以者何。佛子当知此一切智智功德性聚妙法门品。若非菩萨不能得闻不能信解。况复于中以修行相精勤加行。佛子是故当知若有有情。一心听闻此法门品。闻已信解解已受持。以修行相于中加行。此诸有情皆悉随顺一切智门。尔时佛神力故法尔如故。十方世间十俱胝佛刹微尘数世界。皆悉六变十八相动所谓动遍动等遍动。起遍起等遍起。踊遍踊等遍踊。震遍震等遍震。吼遍吼等遍吼。击遍击等遍击。佛神力故法尔如故。雨天花云雨天鬘云。天妙衣云诸天宝云。天庄严云天宝盖云。天宝幢云天宝幡云。雨天乐云其音和雅同时发声。雨超诸天赞咏一切智地之云。如此世界于四大洲。他化自在天王宫中演说此法。十方一切诸世界中。此说法声普遍流转悉亦如是。尔时复以佛神力故。从十方面过十俱胝佛刹微尘数诸世界外。有十俱胝佛刹微尘数诸菩萨众。遍满十方来集此会。至此会已咸作是言。善哉善哉佛子。汝今善能显此菩萨法性。佛子我等悉亦同号名金刚藏。我等各各所住世界名金刚胜。于中诸佛正等觉者。皆亦同号名金刚幢。我等各各从彼而来。于彼一切诸世界中。由佛神力亦说此法众会悉等。文字句义与此所说无有增减。佛子我等今者承佛神力。而来此会为汝作证。如今我等入此世界十方一切诸世界中。一一世界于四大洲。各于他化自在天中。自在天王宫摩尼宝藏殿。悉亦如是而往作证。尔时金刚藏菩萨。观察十方一切众会。普照法界。为欲赞叹发菩提心。为欲示现菩萨境界。为欲净治菩萨行力。为说摄取一切智道。为除一切诸世间垢。为欲施与一切种智。为欲示现不可思议智庄严事。为欲显示一切菩萨诸胜功德。为欲令此如上地义转更开显承佛神力而说颂言

  其心寂灭恒调顺　　平等无碍如虚空
  离诸垢浊住于道　　汝等应听此胜行
  百千亿劫修诸善　　供养无量无边佛
  声闻独觉亦复然　　为利群生发大心
  勤持净戒常和忍　　惭愧福智皆具足
  志求佛智修广慧　　为得十力发大心
  三世诸佛咸供养　　一切国土悉严净
  了知诸法皆平等　　为利有情发大心
  初地已发菩提心　　永离众恶常欢喜
  愿力广修诸善法　　以悲愍故入后地
  戒定具足念有情　　涤除垢秽心明洁
  观世三毒火炽然　　广大解者趣三地
  三有一切皆无常　　如箭入身无救护
  厌离有为求佛法　　广大智趣焰慧地
  念慧具足得道智　　供养百千无量佛
  常观最胜诸功德　　斯则趣入难胜地
  智慧方便善观察　　种种示现救有情
  复供十力无上尊　　此能趣入现前地
  世所难知而能知　　不受于我离有无
  法性本寂随缘转　　由此妙智向七地
  智慧方便心广大　　难行难伏难了知
  虽证寂灭勤修习　　能取如空不动地
  蒙佛劝从寂灭起　　广修种种诸智业
  具十自在观世间　　以此而升善慧地
  以微妙智观有情　　心惑业等诸稠林
  为欲化其令趣道　　演说诸佛胜义藏
  次第修行具众善　　乃至九地集福慧
  常求诸佛最胜法　　以佛智水受灌顶
  获诸无数三摩地　　皆善了知其作业
  其后定名受灌顶　　住广大境恒不动
  菩萨得此后定时　　大宝莲花忽然现
  身量称彼于中坐　　同观菩萨众围绕
  放大光明百千亿　　灭除一切有情苦
  复于顶上放光明　　普入十方诸佛会
  悉住空中作光网　　供养佛已从足入
  即时诸佛悉知此　　佛子今登灌顶位
  十方菩萨皆来集　　瞻此大士获众定
  诸佛眉间亦放光　　普照而来从顶入
  十方世界咸震动　　一切恶趣苦销灭
  是时诸佛灌其顶　　如转轮王灌太子
  若蒙诸佛与灌顶　　是则名登法云地
  智慧增长无有边　　开悟一切诸世间
  欲界色界无色界　　法界世界有情界
  有为无为空涅槃　　如是一切咸通达
  一切变化大威力　　诸佛加持微细智
  秘密劫数毛道等　　皆能如实而观察
  受生舍俗成正觉　　转妙法轮入涅槃
  乃至寂灭解脱法　　及所示说皆能了
  菩萨住此法云地　　具足念力持佛法
  譬如大海受龙雨　　此地受法亦复然
  假使十方无量土　　微尘数等诸有情
  悉得闻持陀罗尼　　各持别别无量法
  菩萨住此法云地　　于一佛所所受法
  名为三世法界藏　　此过彼数无有量
  由昔智愿威神力　　一念普遍十方界
  注甘露法灭烦恼　　是故此地名法云
  神通示现遍十方　　超出人天世间境
  复过是数无量亿　　若以世智思必迷
  十地菩萨身业等　　至举足量智功德
  此乃登法太子位　　九地诸圣不能测
  何况一切诸群生　　及以声闻独觉等
  此地菩萨供养佛　　十方国土悉周遍
  亦供现前诸圣众　　具足庄严佛功德
  诸佛为住此地说　　三世法界无碍智
  遍照世界有情等　　乃至为说一切智
  此地菩萨智光明　　能示有情正法路
  如大自在天王光　　除闇能悦有情身
  此地智光能除闇　　悦豫世间亦如是
  住此多作三界王　　善能演说三乘法
  刹那能证百万亿　　那庾多数不可说
  刹土尘等三摩地　　见佛等事余亦然
  此地我今已略说　　若以广说不可尽
  是诸地于佛智中　　嶷然住似十山王
  初地艺业不可尽　　如雪山中诸药性
  二地戒香如香山　　三如裂穷丰妙珍
  焰慧道宝无有尽　　如仙山中神仙众
  五地神通如持双　　六如马耳具众果
  七地大慧如持鱼　　八地自在如轮围
  九无碍解如幢相　　十如妙高具众德
  初地愿首二净戒　　三静虑等诸功德
  四专一行觉支道　　五地微妙方便慧
  六地甚深缘起观　　七广大慧八庄严
  九地思择微妙义　　出过一切世间道
  十地受持诸佛法　　如是行海无尽竭
  十行超世发心初　　净戒第二静虑三
  行净第四成就五　　缘起第六贯穿七
  第八置在金刚幢　　第九观察众稠林
  第十法王授灌顶　　如是德宝渐清净
  十方国土碎为尘　　可于一念知其数
  毫末度空可知量　　亿劫说此不可尽

尔时金刚藏菩萨摩诃萨。以佛神力说此经已。如来应供正遍等觉。称许印可。彼诸一切菩萨大众。及诸天龙药叉健达缚阿素洛。释梵护世摩醯首罗净居天众。皆大欢喜信受奉行。时薄伽梵。成道未久第二七日。在于他化自在天王宫摩尼宝藏殿。随喜金刚藏菩萨所说

    菩萨法云地第十竟

十地经卷第九


佛说庄严菩提心经一卷

    No. 307

    佛说庄严菩提心经一卷

        姚秦三藏鸠摩罗什译

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众千二百人俱。菩萨万人。其名曰智光菩萨。法光菩萨。月光菩萨。日光菩萨。无边光菩萨。跋陀婆罗等。十六正士。如文殊师利本所修行。复有六十菩萨。如弥勒菩萨本所修行。此贤劫中菩萨摩诃萨等。尔时世尊与无央数大众围绕。而为说法

尔时会中有菩萨名思无量义。即从坐起整衣服。偏袒右肩右膝着地。以种种宝华而散佛上。散佛上已合掌白佛言。世尊。欲有所问。唯愿世尊。哀愍听许。佛告思无量义菩萨。恣汝所问。思无量义菩萨白佛言。世尊。云何菩萨修菩提心。何者是菩提心。佛告思无量义菩萨。菩萨修菩提心者非于众生。菩提心者不可得。此心非色非见。法亦无有得者。何以故。众生空故。思无量义菩萨白佛言。世尊。法相如是甚深。菩萨当云何修行。佛告思无量义菩萨。善男子。菩提心者。非有非造离于文字。菩提即是心。心即是众生。若能如是解。是名菩萨修菩提心。菩提非过去未来现在。如是心众生亦非过去未来现在。能如是解名为菩萨。然于是中实无所得。以无所得故得。若于一切法无所得。是名得菩提。为始行众生故说有菩提。如阿罗汉取证。于法无所得。以世俗言辞故说有菩提。然菩提实不可得。若于一切法无所得。是名得菩提。然于是中亦无有心。亦无造心者。亦无有菩提。亦无造菩提者。亦无有众生。亦无造众生者。亦无有声闻。亦无发声闻者。亦无辟支佛。亦无发辟支佛者。亦无有菩萨。亦无发菩萨者。亦无有佛。亦无成佛者。亦无有为。亦无造有为者。亦无无为。亦无造无为者。是中已得今得当得皆不可得。佛告善男子。谛听谛听善思念之。所应说者吾今当说。菩萨发菩提心有十法。何等为十。发第一心成就众善本。譬若须弥山以众宝庄严发第二心行檀波罗蜜。譬若大地长养众善法。发第三心行尸波罗蜜。喻若师子王能降伏众兽。灭除邪见故。发第四心行羼提波罗蜜。喻若那罗延坚固不可坏。灭除烦恼故。发第五心行毗梨耶波罗蜜。现行众善法。喻若天华如意说法故。发第六心行禅波罗蜜。喻若日光明灭除众闇故。发第七心行般若波罗蜜。诸愿得满足。喻若商贾客得离众难故。发第八心行方便波罗蜜。灭除诸障碍。喻若月盛满清净无秽故。发第九心欲满足本愿游净佛国土乐听深妙法灭除贫穷故。发第十心喻若虚空其智无穷尽。譬如转轮王成就一切种智故。善男子。如是能发十种心名为菩萨。亦名摩诃萨。亦名无为众生。亦名无障碍众生。亦名已得度众生。亦名不思议众生。然于此中亦无有心亦无菩提复次善男子。复有十三昧护持菩提心。何等为十。发第一心法宝三昧所护持。发第二心坚固三昧所护持。发第三心不动三昧所护持。发第四心不退三昧所护持。发第五心宝华三昧所护持。发第六心日光三昧所护持。发第七心一切义三昧所护持。发第八心智照三昧所护持。发第九心诸佛现在前三昧所护持。发第十心首楞严三昧所护持。复次善男子。菩萨初地相。能见三千佛刹土满中亿千那由他伏藏。二地能见三千佛刹土坦然平整以众宝暐晔庄严。三地能见诸力士为降伏怨敌。四地能见四方有诸风轮来。有种种妙华遍布其地。五地能见众妓女以众宝璎珞其身。上有忧钵罗华天冠。胆匐华天冠。婆师迦华天冠。阿提目多伽华天冠。而为严容。六地见众宝池八功德水湛然盈满。其池四边有七宝阶道底布金沙。自见己身在此池中嬉戏娱乐。七地见其左右有诸地狱。而从中过无诸艰难。八地自见两肩上有师子王形容端严头上有幡有大威力降伏众兽。九地见转轮圣王百千大臣刹利居士而自围绕。以正法化无量众生。见虚空中有众宝盖垂覆其上。十地见佛色身。身真金色放大光明。大众围绕而为说法。善男子。如是十种相应善分别成就十地。以三昧力故复次善男子。初地生胜进陀罗尼。二地生不坏陀罗尼。三地生安隐陀罗尼。四地生难沮坏陀罗尼。五地生功德华种种庄严陀罗尼。六地生智圆明陀罗尼。七地生增益陀罗尼。八地生无分别陀罗尼而为上首。八万四千陀罗尼同共俱生。九地生无边陀罗尼而为上首。六十二亿那由他陀罗尼同共俱生。十地生无尽陀罗尼而为上首。亿千恒河沙陀罗尼同共俱生

复次善男子。初地行檀波罗蜜。二地行尸波罗蜜。三地行羼提波罗蜜。四地行毗梨耶波罗蜜。五地行禅波罗蜜。六地行般若波罗蜜。七地行方便波罗蜜。八地行智波罗蜜。九地行成就众生满足波罗蜜。十地行诸愿满足波罗蜜。如是诸波罗蜜。于诸地中皆悉成就

复次善男子。菩萨摩诃萨行檀波罗蜜有十种。何等为十。一曰信根。二曰定根。三曰大慈。四曰大悲。五曰我喜。六曰彼喜。七曰发一切愿。八曰持一切众生。九曰四摄。十曰亲近诸佛法。是名十种法成就檀波罗蜜复次善男子。行尸波罗蜜有十法。何等为十。一曰离八难。二曰成就佛功德。三曰离声闻地。四曰离辟支佛地。五曰身清。六曰口清。七曰意清。八曰庄严心。九曰断地狱缘。十曰所祈得满足行。此十法即成就尸波罗蜜复次善男子。行羼提波罗蜜有十法。何等为十。一曰忍力。二曰踊跃。三曰成就众生。四曰于甚深法能忍。五曰无彼我。六曰断嗔恚。七曰不惜身。八曰不惜命。九曰舍痴。十曰观法身平等。如是十种法成就羼提波罗蜜复次善男子。菩萨摩诃萨行毗梨耶波罗蜜有十法。何等为十。一曰精进根。二曰精进力。三曰正勤。四曰正念。五曰以身助众生。六曰以心口随生。七曰行处不退转。八曰除懒惰。九曰降伏恶知识。十曰集一切智。是名十法成就毗梨耶波罗蜜

复次善男子。菩萨摩诃萨行禅波罗蜜有十法。何等为十。一曰定根。二曰定力。三曰等定。四曰游戏诸禅。五曰三昧。六曰三昧报。七曰不毁众善法。八曰灭除烦恼怨。九曰于正法舍。十曰定阴。如是十法成就禅波罗蜜复次善男子。菩萨摩诃萨行般若波罗蜜有十法。何等为十。一曰慧根。二曰慧力。三曰正见。四曰正念。五曰阴方便。六曰分别界。七曰圣谛。八曰无障智。九曰回邪见。十曰无生法忍行。如是十法。得成就般若波罗蜜复次善男子。菩萨摩诃萨行方便波罗蜜有十法。何等为十。一曰同众生行。二曰持众生。三曰大悲。四曰无厌。五曰离声闻辟支佛行。六曰入波罗蜜。七曰如实分别器量。八曰扶助善心。九曰入不退转地。十曰降伏众魔。是名十法成就方便波罗蜜

复次善男子。云何名为波罗蜜义。行胜进满足。是波罗蜜义。成就第一智。是波罗蜜义。不在有为不处无为。是波罗蜜义。生死大患善能觉知。是波罗蜜义。本所未觉今悉了知。是波罗蜜义。无尽法藏广能示现。是波罗蜜义。善除障碍。是波罗蜜义。布施持戒忍辱精进禅定智慧方便等不望报。是波罗蜜义。解一切众生界。是波罗蜜义。满足无生法忍。是波罗蜜义。成不退转。是波罗蜜义。修净佛国。是波罗蜜义。成就众生。是波罗蜜义。处于道场觉一切智。是波罗蜜义。降伏众魔。是波罗蜜义。成就诸佛一切种智。是波罗蜜义。破诸异见。是波罗蜜义。十力四无所畏十八不共法成就满足。是波罗蜜义。成就十二行法轮。是波罗蜜义。如是善男子。波罗蜜义甚深无量我但为汝略说之耳

尔时会中有天子。名师子奋迅光。即从坐起合掌白佛言。善哉世尊。如上所说。甚深希有诸佛功德。譬如甘露充足一切。佛告天子。善哉善哉。如汝所说。若有比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。及菩萨摩诃萨闻是经典。必于阿耨多罗三藐三菩提不复退转。何以故。天子。若有善男子善女人。宿殖德本乃能得闻是经。非是少功德人之所听闻。若有暂闻此经读诵书写。此人舍是身已常见诸佛。见诸佛已能于佛所转妙法轮。即得无尽陀罗尼印。亦得解一切众生心行陀罗尼。亦得日光普照陀罗尼。亦得净无垢陀罗尼。亦得一切诸法不动陀罗尼。亦得金刚不坏陀罗尼。亦得甚深义藏演说陀罗尼。亦得善解一切众生语言陀罗尼。亦得虚空无垢游戏无尽印陀罗尼。亦得诸佛化身陀罗尼。况复闻已如说修行。善男子。若有菩萨得如是法。则能于十方世界诸佛刹土化作佛身。而为众生演说妙法。然于法相不动亦无去来。虽成就众生。无有众生而可得者。常为说法而无所说。恒现受生而无生灭。虽现来去无来去相。尔时世尊说是法时。三千菩萨得无生法忍。无量众生皆发阿耨多罗三藐三菩提心。思无量义菩萨。及诸天龙夜叉乾闼婆阿修罗人非人等。闻佛所说欢喜奉行佛说庄严菩提心经


渐备一切智德经卷第一

    No. 285 [Nos. 278(22), 279(26), 286, 287]

渐备一切智德经卷第一　　　　　　　　(一名十住又名大慧光三昧)

        西晋月支三藏竺法护译

    初发意悦豫住品第一

闻如是。一时佛游第六他化自在天上天王宫如意藏珠妙宝殿上。与大菩萨众不可计俱。各从他方诸佛国来。普集会此。金刚藏菩萨等。尔时金刚藏菩萨。承佛威神。以大慧光三昧正受。适定意已。应时十方诸佛刹土。一一诸方。如十亿佛刹满中诸尘若干亿国。诸如来现。边有菩萨。其号各各曰金刚藏。十方亦然。皆同一号。时此诸佛。俱赞曰。善哉善哉。汝乃以此大慧光菩萨三昧。而以正受。在十方佛土。各如十亿满中诸尘诸如来等之所建立。一切等号。悉是照明。如来至真。本愿所致。而建立此。亦是仁者慧净所致。复是一切诸菩萨等。不可思议法光圣旨。住明智地。多所度脱。摄取一切众德之本。皆晓诸佛本所行成。愍念十方。解了善权。敷演道化。普弘法慧。周流十方。所讲经谊。尽令坚住。其智慧明无能毁者。随时建立佥使得安。游诸世间不着方俗。度世清净。庄严善本。入不可议慧之境界。通一切智。高远圣道。乃能招致诸菩萨等。十住行无。如开士众所当建立。有所宣布。往返周旋。执无漏法。光明咸照。而善思惟。撰于离心。晓了随时。大慧光明。其未善度。至圣道门。使得度脱而无所著。住于内行。专精奉修无上大乘。其辩才慧不可称载。威曜普照消除闇冥。已超众行班宣无极。住在佛地逮菩萨意。愍念众生未曾忘舍。游入一切诸佛至真善权方便。决众结网。承佛圣旨。自恣讲说。演此法门靡不解了。如来在世。故为建立。亦是卿本善愿所致。清净行业。而谛庄严一切法界。又救众生之所惑乱。以致法身至圣慧体。具足诸佛本所志愿。其身所行。皆越世俗。普过世间无益之业。严饰清净。度世之法。诸佛世尊。为金刚藏菩萨大士。无所吝惜。各现己身。宣布无限辩才之义。分别决解其清净慧。怀抱不忘。建立显示。随时便宜。畅众疑心。普入一切诸佛所念。诸等正觉十力所由。如来所致四无所畏。而不怯弱。宣布至教。一切智业。诸分别辩。超越得入体解道法。入诸如来身口心行。所以者何。皆由此定。成就所致。亦由本愿。行通巍巍。其心清净。而无沾污。内性明了。常怀清净。威耀弘昭。入于慧场。诸所行业。靡不备焉。斯所造立。而悉具足。其道器意。不可限量。信志清净。巍巍普达。逮总持门。无所破坏。常以法界慧门之印。善印一切。是诸佛世尊。各自显现。各申右臂。皆共手摩金刚藏菩萨头首。时金刚藏为诸世尊。所见摩头。道德巍巍遂得成就。威耀光光如佛无异。尔时寻即从三昧起。请诸菩萨而解言曰。诸最胜子。吾已明达诸菩萨愿。破坏疑网。则无所坏。世无所生亦无罪衅。法界弘广亦无远近。其所游居譬。如虚空。以是救济。拥护十方一切众生。所以然者。族姓子知。过去菩萨。往古诸佛。由此慧地而得过度。当来现在亦复如是。诸佛子知。我向者云。菩萨之地。为何谓也。诸菩萨学有十道地。因得成就无上正觉。去来今佛之所讲说。初菩萨住名曰悦豫。第二菩萨住名曰离垢。第三菩萨住名曰兴光第四菩萨住名曰晖曜。第五菩萨住名曰难胜。第六菩萨住名曰目见。第七菩萨住名曰玄妙。第八菩萨住名曰不动。第九菩萨住名曰善哉意。第十菩萨住名曰法雨。是诸菩萨十住道地也。我观十方去来今佛。诸如来至真。无不讲此十住之业。所以者何。诸佛子等。是十住者。令诸菩萨。现在亲近清净道无为诸法门。名显远照于十方无数佛土。三界众生。咸蒙得济。照天下如日明。疗众病如医王。度众人如船师。曜十方如月盛。活一切犹如地。安众生如时雨。含道法如虚空。正坚住如须弥。宣布此教。则得坚立在十道地。又解此地不可思议诸菩萨住。佥入圣慧。时金刚藏菩萨。粗举其要。叹此菩萨十住地业。寻即默然。不复重解

于是大众。咸怀饥虚。闻此菩萨十住道名。欲令分别重敷演义。闻者佥解。心怀入道。离诸颠倒各心念言。金刚藏菩萨。今何以故。粗举其要。宣于十住菩萨之业。称叹其号而更默然。不复重散解了本末。时彼会中有一菩萨。名月解脱。亦来俱会。时月解脱菩萨大士。知彼众会开士所念。以偈叹颂。问金刚藏此义所归

  净念以何故　　怀慧称功勋
  明智宣十住　　不重解所入
  诸菩萨勇猛　　心各抱犹豫
  云何说义名　　不闻道地处
  咸欲悉共闻　　最胜子无畏
  决义入平等　　所行住道地
  众会佥悦豫　　清净除谀谄
  坚住解明地　　功勋慧平均
  一切立恭敬　　展转相承望
  求微妙无瑕　　志无上甘露
  因闻金刚藏　　无畏大智慧
  常欢悦来众　　仁宜与佛谈
  未曾最难及　　显菩萨所行
  分别如道地　　所由最上胜
  弃想微难见　　常住远离心
  柔仁行成慧　　面闻所归趣
  所止如金刚　　第一解佛慧
  立心舍吾我　　乃闻此上智
  如来尽虚无　　离欲亦如空
  慧如地无漏　　兴别最难见
  道无念如此　　信者甚难值
  佛慧不可议　　故默不重说

月解脱菩萨。谓金刚藏。佛子当察。诸来会者。性行淳淑。清净离秽。其志仁和。悉诸菩萨。斯行真正。积功累德。每生自克。六度无极。以自庄严。四等四恩。习权方便。功勋远着。名德无量。大慈大哀。欲兴道化。分流法教。救济三界诸危厄众。消众冥如日明。生道品如良田。成正觉如虚空。长弘教如流水。除狐疑如日光。疗三毒如医王。度生死譬船师。是故佛子。仁者善哉。宜当班宣现在学行。令此道地缘修所归。使诸会者各得开解。如冥睹明。应病授药。使无余疑。时月解脱菩萨大士。欲令此义重散本末。显示归趣。为金刚藏。说此颂曰

  茂盛愿讲说　　殊特最上法
  人中上所行　　诸菩萨之业
  敷演说其教　　所住之道地
  圣慧甚清净　　巍巍仁和业
  诸会者清净　　不可计第一
  坚住在正路　　志性怀笃信
  善累功积德　　奉无数亿佛
  各欲得决解　　寻现逮十住

金刚藏菩萨。报月解脱。佛子察之。今此众会。四面云集。云何见之。所念应宜。柔弱仁和。清净无瑕。岂离狐疑无犹豫乎。于斯法要。宁有高行。不依他人。无戴仰耶。不从他教。进退不安。怀抱久病。不可疗治。坚住罗网。未出深堑。六十二疑。四倒五盖。火林蛇室。十二牵连。十重之阁。三坑三户。三流之逸游在旷野。未向佛门。设闻此法。踌躇不进。或复有人。若闻于此不可思议。如是道住。各怀异心。闻之狐疑不肯笃信。由此惑乱。长夜不安。永失利义。舍根取枝。吾故向者默然不言。慈愍此等。无辞为住乐无所乐。又说偈言

  岂见于众会　　智慧净无垢
  善敷演圣道　　诸根通深妙
  而无所戴仰　　无动等如山
  志性无嗔恨　　思平如水正
  习修何所行　　其慧无等伦
  住在乐所识　　为求义慧信
  适闻恐犹豫　　便堕于恶趣
  以故愍念此　　不说慧住地

月解脱菩萨。复谓金刚藏。仁者顾意。承佛威神。宣如来旨。感动十方。反伪向真。消诸垢尘。荡涤结滞。裂三界网。通无极慧。唯敷演之。如是比像不可思议。善当将养。宽弘之士。必当信乐无犹豫者。所以者何。佛子当知。若讲此教。将致道法。一切菩萨。皆念诸佛。识达经义。拥护奉此。行慧道地。靡不蒙赖咸得安隐。所以者何。斯之所行。必归平等。诸佛道法。犹如佛子。一切书疏唯说文字。此悉由意心为源首。从志因缘而有所倚。书本无文。所演文字。心之源空。宣之虚无。如是佛子。一切佛法。住为源首。因行而成。依于道地。至自然慧。是故唯说。顾愍一切如来至真等正觉。道力助卿。建立分别如此文字。令其坦然。将护正法。因得久存。使无余结。又说偈言

  善哉演清净　　解入一切智
  普游诸道要　　至觉成圣慧
  诸在十方佛　　安住最道胜
  慧室至境界　　皆共愍念之
  立此亲近慧　　行是究竟迹
  诸佛无比法　　悉由无量业
  犹书意合集　　因心事为首
  此住意如是　　解畅至佛道

于是一切菩萨。各各发心。咸共劝助。欲令宣扬仁本兴意。誓为一切。勤劳积功。累无量德。犹如虚空。欲济危厄。不难劫数。周游生死。心常慺慺。欲济一切心无所著。行如莲华在泥涂中。三界之苦不以为拘。唯怀愍伤。拔恼根株。三世之树永令无余。时诸菩萨。同时举声。劝叹金刚藏菩萨。而说颂曰

  最胜殊特志觉远　　辩才无量心念具
  宣传柔软至佛教　　第一至真甚微妙
  其意坚固行清净　　不舍功勋十种力
  以分别辩故造行　　唯愿当演上道法
  心之所念如明珠　　意寂以见消尘欲
  今此众会离狐疑　　咸皆愿乐仁所说
  虚渴言教如望泉　　饥服仁者病待医
  甘美之饼在目前　　如是欣乐甘露味
  故善垂念广其志　　宣殊胜住除垢尘
  调寂正安不舍无　　讲众祐行无患难

于是世尊。有诸菩萨至圣光明。号曰力势。佛从眉间。演此光耀。兴无数明。普照十方一切佛土。消灭一切诸所恶趣。勤苦休息。不复考治。皆安隐。照斯如来。一切道场。十方佛国。建立法讲。靡不周悉。不可思议诸佛境界。其光则还。绕佛三匝。上住虚空。合成大光。光明炜炜。立交露帐。又有诸佛兴出世间。自然威曜。从其眉间。演如是伦。诸菩萨等。力势光明。现如此比。神足变化。照斯忍界。曜是能仁。众会道场及金刚藏师子之座。乃住虚空。成光交露帐。是能仁佛。眉间毫跱。光明广远。照诸闇冥。十方佛界。众会道场。莫不蒙明光。咸显现在诸菩萨。大士屋宇。一切晃现。其于十方诸佛国土。现诸如来所可演出。眉间光耀。皆复照耀此忍世界能仁众会菩萨道场。周照师子高广之座。在金刚藏菩萨身。现于大光。巍巍晃然。珠交露帐。各有坐佛。自从口出如是辈声。而叹颂曰

  喻之无等伦　　譬之如虚空
  十力境界尊　　功勋不可量
  殊胜最上特　　普世为无上
  建立第一业　　释师子之法
  讲众安住子　　蒙导师恩慈
  法王人中帝　　演眉间光明
  班宣佛道慧　　入妙众行无
  赖十力垂顾　　分别普化众
  安住已建立　　斯闻能宣照
  宝法为上尊　　是寂其志性
  一切住无秽　　具足满本愿
  因十力最胜　　志求上尊路
  海水尚可尽　　一切数知限
  若人欲度此　　不可卒得闻
  其能离志念　　永除众狐疑
  一切未有愍　　照以此经典
  是故辩才尊　　缘住慧径路
  所处奉斯行　　游步依本业
  至行入境界　　普到佛圣智
  愍一切众生　　布散此法因

于是金刚藏菩萨。观于十方。欲令众会重怀悦豫。渴仰于法。兴发大哀无极之慈。应时因是。嗟叹此颂

  大圣之道法　　微妙甚深远
  无念以舍念　　清澄永难了
  圣明达玄微　　智慧解所行
  自然业寂安　　柔仁无诤乱
  自然空净法　　寂寞除苦患
  游居至解脱　　逮平等灭度
  无限无极义　　言辞近超度
  以越于三世　　行等犹虚空
  诸众祐所行　　寂然甚淡泊
  一切之行业　　径路难逮解
  此等行如地　　志性亦若斯
  甚难可讲说　　何能分别了
  以去弃心意　　永无心句迹
  诸众祐所行　　智慧消言食
  亦复无所行　　无阴众衰入
  圣达依慧业　　其心无想念
  犹如有飞鸟　　游行在虚空
  不可以言辞　　何况欲睹见
  安住自然慧　　如是行道住
  其心所行念　　不可分别知
  何所有入处　　殊胜慧土地
  愍伤常慈哀　　志愿普备悉
  渐以具众行　　心亦无想念
  犹如心本性　　智慧以明了
  如斯行之业　　微妙甚难解
  自己志性无　　不可卒达知
  何况能宣布　　安住之所念
  一切共恭敬　　明听玄妙教
  以入正真慧　　如行道之住
  若于亿千劫　　不可尽究竟
  等俱咸悦豫　　普共且专听
  至诚妙真义　　无厌亦无异
  不以为愦乱　　犹如成大海
  今当具敷演　　诸众祐道行
  又当班宣说　　殊特之法音
  牵引众譬喻　　正真等文字
  其所讲分别　　甚难可解散
  安住行业事　　如是不可量
  今已得逮入　　吾我之自然
  咸乐如一渧　　且听所宣言

尔时金刚藏菩萨大士。谓众会者。佛子且察。诸集众生。积累德本所行真谛而无虚伪。所造行业甚善将护。诸佛兴世常勤供养。极以合会诸清白法。恒以咨受善知识俱。以除忧戚志性宽弘。笃信微妙定意平等。面睹现在愍念慈哀。心常志慕诸佛圣慧。化诸众生悉发道心。皆令至真好一切智。其十种力强而有势。则得游行大无所畏。其意坦然得佛正法。拥护救济一切众生。修大愍伤其哀清净。十方无余悉解一切。明智至门悉现目前。一切佛土无为清净。一时觉了三世世事。转大法轮疗众疾病。菩萨大士须臾发意。愍众生行无极大哀以为元首。智慧明了甚为巍巍。常勤学受善权方便。意性和柔亲近道法。如来十力不可限量。善思选择计一切人力佛力最上。所宣法门无所挂碍。而以和顺自在之慧。佛悉了知一切佛兴。因是自在。造立道法法界行最。立虚空际。所可发心。显了当来发菩萨意。适发道意超凡夫地。以得超越菩萨之地。则得生在如来种姓。因号之曰无所从生。无有罪衅。辄以回转世俗所趣。适过世俗由度世行。因得住立菩萨道法。已得住立菩萨道法。便能顺从三世佛教。勤心道义常深第一。菩萨住如是道法。悦豫道地。佛子当知。如斯得立住菩萨道。所行不动入不回还。以住菩萨悦豫地者。因是发意多所悦豫。其有见者莫不欢然。常有恭敬以致利养。其来见者咸共欣喜。开化众人佥然受教。普来云集共相娱乐。虽致远近计无坚固。常抱仁和无所伤害。恒志悦豫心不怀恨。和颜悦色而无嗔恨是为菩萨悦豫之地。住于道教。诸佛世尊。皆共念之。第一悦豫思于佛法。适发悦豫。念于菩萨大士本业。适怀悦豫念菩萨行。适发悦豫念于六度清净无极。适发悦豫。念于开士所住殊特。适发悦豫。思道最微而无等侣。适发悦豫。用众生故利益道义。适发悦豫进心深法。适发悦豫。念于如来至真之教。念以劝化一切众生。适发悦豫。念诸菩萨入如来慧精进之业。重复思惟将导不逮。为以得度。说诸众生所慕境界。怀来进入诸佛平等。已得远出愚痴之地。亲近道场。断除一切恶趣勤苦。为诸众生劝导之首。已得睹见如来至真。具足成就如来境界。皆已逮睹诸菩萨定平等之业。故悦豫耳。永以消除一切恐惧。衣毛不竖。故悦豫耳。所以者何。是故佛子。诸菩萨学以是悦豫。便逮得立菩萨道地。以得住立菩萨道地。诸所恐畏。永无复难。在无命安。无世俗畏无死之畏。不畏恶趣。所入众会无所忌难。皆以永除一切诸惧。所以者何。无吾我想。不贪己身。况复贪爱一切荣异。所生业乎。不畏无寿。亦不思念悕望侥幸。唯愍群生一切所有无极之业。救诸穷乏。贪不识道是无俗畏。成其道明。不自见身。不畏失己无吾我想。不畏当死。虽身寿终。成菩萨行。不离诸佛。由是之故。不畏恶趣。普观世间。察于道心。而无等伦。志性仁和。谁能踰者。以是之故。所入众会。不怀忌难。离于恐懅。衣毛不竖。佛子当解。菩萨大士。以具大哀。不抱伤害。修本净心。益加精进。合集一切众德之本

佛言。以笃信至。威神渐备多所欢悦。净诸不信。笃信以兴。常行愍哀。归无极慈。心不患厌生死之难。志于惭愧。而自庄严。心所生处。忍辱仁和。若干种物。供养奉上如来至真最等正觉夙兴夜寐。精进勤修。不厌讲诵。积功德本。习于善友。以法乐而自娱。求博闻不懈惓。若闻法顺思惟。已思惟无所著。不悕望衣食。业诸利养。心不贪慕。万物恩爱。心永已除。唯慕义求三宝。发意之顷。不废正行。勤修慕乐一切智地。如来十力。四无所畏。佛十八法。专精奉行六度无极。弃捐虚伪。而无谀谄。言行相应。不违心口。所至到处。常顺言行。未曾毁乱如来种姓。恒一心念菩萨禁戒。一切智心。不可动摇。犹如太山不可倾覆。普于世间。无所慕乐。求度世业。以化未闻。学于道品。不知厌足。心常勤勤。求殊特事。是为佛子如是像业清净道事净菩萨法辄得坚住悦豫之地。世尊复言。若能得立悦豫地者。成菩萨住建立广大无极之道。如是景模无限大愿弘誓之铠。又有十事法。何谓为十。班宣无尽。和雅音辞。至于无喻。无不周悉。供养诸佛一切奇珍。笃信微妙清净之业。法界坦然。志归空界。究畅解达。于当来际。一切无想。无所悕望。令佛道兴。无所思乐。所奉事者。供于无极。志务大愿。念诸如来所开演教。执持法目。将护诸佛诸菩萨业。不违一切平等觉训。已能具足如上法训。辄得出生。在兜术天上。从天来下。入母腹中。处在胎藏。从母腹出。随行七步。举手自赞。三界最尊。释梵稽首。诸龙浴体。学书手博。游观所睹。出家入山。成佛降魔。释梵劝助。转大法轮。现大灭度。供养舍利。宣布道化。显众经义。皆以一时。至不退转。法界弘广。不可限量。处虚空界。究竟解畅当来之际。于一切念而无想念。从无数劫。会成佛道。笃信无惓。俱往合同。班宣义音。无极弘誓。乃至菩萨一切诸行。弘普无穷。无量无数。摄取一切诸度无极。住清净道。校计众会品类音响有相无相。合会别离有为无为。为诸菩萨一切师首。道住真妙。所演章句。诸度无极。所当宣行。勤修正行。而无所生。近成发心。以能具足此诸法已。具足解畅众生境界。色无色想。无想有想无想。水生陆地。合会聚处。一切所生。三界受形。六品所趣。此皆受形。而有处所。受无像形。一切无喻众生之界。悉分别之。化入佛法断除一切有为所生。则得建立成一切智。是则名曰法界弘广。而得处在虚空之界。心能解畅当来原际。一切诸想有为之业。笃信无惓。演御音响。乃至无极弘誓之业。一切解此众生境界。道俗悉达无所不通。普诸佛界广狭粗微。大小所现。有量无量。眇眇难名。旷远原顶。入于平等。已入平等。晓了诸根。一切罗网解如门阃。入诸十方。以慧遍观。解畅法界虚空原际。则得了入无极弘誓。又一切国以为一国。又以一国为一切国。而平等御。清净无秽。其光普照无量佛国。庄严诸国。永无尘埃。分别清净章句所归。圣慧道堂。不可限量。具众生愿。显示诸佛微妙境界。随其黎庶本行所兴。而为现化。法界弘广。察空虚界永无边幅。究竟本际一切想念。计校合会。无有休息。亦不信随邪行之业。修于清净。建弘誓铠。以化未闻。使诸菩萨入寂和性。当行至诚。积功累德。以一缘进。劝化诱导一切菩萨。未曾违舍菩萨之业。恣其意解。显现佛兴。自发己心。思如来教。无复往返。逮致神通。普游诸国。其大圣慧。不可思议。行菩萨业。法界弘广。虚空之界而无边际。游当来际。达诸想数。佛与众数。其行之数。莫能损毁。入于圣智。显发言行。无极弘誓。行菩萨道。心得逮转。不退法轮。其身口意。未曾虚妄。适得见佛闻经法教。班宣圣众。演明智业。适发悦豫。消除尘劳。致真志性。犹大医王疗众生病。皆修一切诸菩萨行。以故名曰法界弘广。其虚空界而无崖际。畅当来际。皆知一切无央数劫。众生行迹。善恶所趣。在于十方诸佛国土。逮成无上正真之道。为最正觉。入于一切体中毛孔。尽遍众毛。在所生处。坐佛树下。转于法轮。现大灭度。修大境界。宣佛慧业。在众生界。从其本行。兴佛现形。频数开化。灭众秽行。一成佛道。普通法界。谦下恭顺。靡不周悉。一发音响。皆悦一切众生心性。现大灭度。不毁十力。以大明地。显示宣布一切法藏。神足法慧。六通之业。周游十方诸佛境界。以故名曰法界弘广其虚空界而无崖际。畅当来际无央数劫。当成佛道。致大神通弘誓之铠。是为佛子菩萨十愿。以得亲近具足十愿。令无央数不可称载诸菩萨众。心怀悦豫。住菩萨地。随时开化佛言。是菩萨学。以成此愿。复有十事所可班宣不可究竟。何谓为十。众生境界不可究竟。诸佛境界亦不可尽。其虚空界亦不可量。思法境界亦不可畅。无为境界亦不可限。佛之境界不可得底。如来境界亦无崖际。其心因缘亦不可限。慧行本末不可得崖。诸佛境界所可进退。法回慧转不可究竟。是为十事众生境界不可究竟成大弘誓。是十事业。一切皆悉不可究竟。诸界虚空。法界无为。佛与如来。其心慧行。世界法转。慧进致成。是大弘誓亦尽无尽。众生之界亦不可尽。以不可尽此众德本。如是究竟成其道慧。以是巨尽众德之本。成无损秏弘誓之铠。其心微妙而怀仁和。常抱至诚笃信质朴。以此信乐如来大化。入平等觉本所誓愿。而复信乐诸度无极。信入道地殊特之业。信十种力开化十方。信无所畏四事不护而具足是独步三界。信诸佛法十八不共超绝之义。而无等侣。信诸佛法不可思议。信如来界不可得底。宣传圣教而不可尽。信入如来无量道业。信诸菩萨其行平等。而无偏谠。住于如来。班宣道教。彼念如是如来道法。甚深微妙巍巍如斯。寂寞无限淡泊无量。空净无际如此无相。为灭无著为极宽弘。如是无极所入无边。如此难当况复佛法。谁能限哉。是诸凡夫所见颠倒。邪不能正唯念愚冥求无益事。心怀意忆游于尘劳。求恩爱网协于谀谄。心行虚伪悭嫉贪妒。志慕生死。周游往来。而抱三毒。淫怒痴垢轮转无际。兴于恚害心欻欻然炽。在颠倒业造行罪患。所有恩爱无明诸漏。常思在心缚其意识。展转三界苦恼之厄。篡逆之行往返无休。与名色俱由相生。以是名色。增长所生。便有六入诸衰聚宅。以生六入转相合流。成于更习。则兴痛痒。倍复贪乐。于痛痒业。因即业成长养因爱。适成恩爱。因从致生。以致此生。便老病死忧恼啼哭。心抱恼热。合成大患。计于众生。由是之故生苦阴恼身。若离吾我。心自计察。又此我身。由以愚冥。譬若草木瓦石墙壁。犹若形影。晓了无名。以是之故。解脱名色。五阴之身。永消诸见。六十二疑。因斯得成无极大哀。吾等当护救济此行。志在永平固安道地。便致大慈弘坦圣慧。菩萨以能如是慈愍。是故佛子。致成仁和。真正顺从。初发意业。心弃一切万物利养。汲汲吝惜。修广大业。其意内怀。所有珍宝。帑藏金银。琉璃水精。诸明月珠。车磲马瑙。珊瑚虎珀。妙玉璎珞。[王*步]瑶奇异。象马车乘。奴客婢使。眷属徒使。普能布施。无所爱惜。能惠郡国县邑丘聚。村落园观。池水果实。妻子男女。己所重爱头目肌肉。髓脑支体。以能不吝一切所有。则好布施。供众贫乏。入佛圣明无极大道。是为名曰得立初发第一道地。成广大施。志性如是。行于愍哀。施慈布仁。救济众生。加护见在度世之业慕求利义。将顺群萌。未曾兴发患厌之心。心不懈惓。勤学众典微妙经籍。普达诸经。晓了一切诸所造业。进退由己。众义法藏。睹诸众庶。随上中下。而顺其意。各得所。从其本器。应大小故。故解世事。以解世事。便行时宜因护彼我被惭愧服。戒德自熏。忍辱心和。精进无过。一心智慧。所行精进。为己为众。惭愧行成。以是修行。便复出家。心不回动。无能倾者。其力坚强。缘是坚强。供养如来。奉受其教。由是之故。修治道地。令其严净。兴显正法。乃至笃信。慈愍施众。悉具此已。乃住菩萨悦豫之地。为无数佛所见照念。于无量亿百千垓无限兆载诸佛所护。便得进现。所愿有力。微以逮见如来至真等正觉。以仁和心。而奉事之。积累菩萨永安之业。诸有群生。所在危厄。往将护之。以是德本。劝助使发无上正真之道。供养诸佛。开化众生。使得成就。欲化众生。布施饮食。先救饥渴。发于四恩。悦乐有力。奉上敬中。愍顺其下。惠施仁爱。利人等利。一切罪除。无有余殃。不复种祸。所可供佛。开化众生以成究竟。住此道地。以是德本助一切智。诸通愍慧。转更茂盛。犹如佛子紫磨真金。绝工金师烧治炼金。以着火中其色益发。菩萨如是供养诸佛。勤化众生功祚转茂。严净此法住于道地。以是德本兴显本元。乃至元本进退自由。金刚藏曰。唯听佛子。菩萨以住初发之地。当作是求。观其行迹问其本末。诸佛菩萨为护善友。正行无厌。以成道品。当所施住。是故名曰第一地住。以当次问第二住地所行之业。云何致之。诸佛菩萨。明师贤友。行法无厌。以成道住。取要言之。如是第二。第三第四。第五第六第七第八。第九第十。问其本末所当施行。而得成就诸佛菩萨。明师贤友。行法无厌。成就道地。道地之品。所观道业。奉行德本。道地处所。晓了方便。一一分别。道地清净。所入殊特。圣慧曰进。各各逮致。使不退转。彼以如是净菩萨住。解别如来无量圣慧。以立若斯方便随时。是为菩萨第一道地。而不回转也。未曾废退。如是遂进。得成十住。不还堕落声闻缘觉。慧住显明。稍近佛智无极光明。犹如佛子明智导师。将护大贾。诸品群众。度厄难路。得愿到国入大城中。所越径路悉晓了之。径路好丑善恶难易。某处殊安某处恐难。重问余路所当兴立。所乘车马诸象大乘。可得通度。而不动倾。第一住地亦复如斯。犹如斯人至大城里。悉别安处无诸动转。从第一住所立道地。奉慧如是靡所不达。以大财富无穷之业。等化大众至入大城。不为秽浊之所见溺。能自为己不危众贾。如是佛子。菩萨犹如明智导师。以能得住第一道地。晓了诸地。严净修治一切道地。至于十住解畅菩萨一切道地。入如来慧。摄取菩萨无极福庆积德之业。累于圣慧。所作已办。为众大导应意开化。使越生死往返大难无穷旷野饥渴苦患。则以通达。入一切智无极法城。是故佛子。菩萨大士。以无惓心。常修精进。致于殊特严净道地。是为佛子名曰菩萨大士悦豫第一住地入于道门演普等教。菩萨住此。所游天下。国土处所。得大威豪将护道法。以大惠施济于众生。以善功德消除贪嫉。退其垢秽宣无穷施。所兴德本施救众乏。诸可珍爱。割情济众。行四恩义。惠施仁爱。利人等利一切救济。合聚黎庶心不舍佛。思法圣众惟菩萨业。志菩萨行诸度无极十住之地。念于十力。四无所畏。十八不共。诸佛之法。至悉具足一切智矣。以是德致一切至尊无极豪相。为最为上为无畴匹。为无等侣。开导宣化。显示众人。成一切智。将济危厄。发意之顷。精进勤修一切顺化。不慕时俗财利之业。道法之正。出家学道。奉佛法教。斯须之间。致无央数。诸三昧定。见诸佛尊不可称载。以是建立。睹诸世界无央数千。念得越度无数国土。照诸境界。开化众生。识念过去当来诸劫。撰择法门。显示诸身。现诸菩萨无央数载。眷属围绕。菩萨由是。所建立力。入殊特愿。在所变现。诸可兴善。宣布惠施。乃至普通无数亿垓百千劫事。于是金刚藏菩萨大士。思惟察是菩萨住义之所归矣。即时颂曰

  积累清白法　　殖众德之本
  稽首归诸佛　　顺行慈仁业
  入于信解脱　　清净善之元
  心御无限量　　最胜之圣慧
  佛为一切智　　净力现其处
  成就众祐法　　导利护群黎
  以行大愍哀　　转殊胜法轮
  如来田佳良　　兴发心甚尊
  一时所晓了　　思惟泥洹业
  若干觉众生　　随时显其义
  合集一切德　　是为众导师
  其心所周入　　犹等如虚空
  智慧最威神　　本哀行善权
  志性怀笃信　　清净力无量
  面见无挂碍　　救济外众生
  殖种平等业　　思惟念安住
  适生心之宝　　众祐自然慧
  以通雅力行　　究竟佛道法
  生十力种性　　永无诸罪殃
  最胜曜正真　　至于尊上道
  是为心和同　　显发致平地
  无动犹如山　　在国等性行
  多所抱欢悦　　志意修笃信
  欣乐应广普　　善哉意义妙
  要离诸恐惧　　无有嗔恚行
  应时胜弃秽　　谨顺善将养
  乐救众群生　　圣慧无等侣
  心怀至踊跃　　捐除众非处
  以消五恐畏　　缘是致道地
  至死不保命　　远于诸恶趣
  以舍众会畏　　终无恐惧心
  何因至今无　　则无有吾我
  若能离恐惧　　专精行慈愍
  至信修恭敬　　除慕富功勋
  夙兴而夜寐　　修习众德本
  以立诚信法　　不为欲所污
  心若闻雅典　　修善无厌极
  永除爱欲利　　常好乐佛道
  志慕净慧力　　修治佛经法
  求诸度无极　　弃捐谀谄业
  言行常相应　　终无虚妄言
  最胜种无秽　　疾学至佛道
  以离方俗事　　不乐世诸利
  不违清白法　　勤修最上行
  精勤功勋义　　唯好如此法
  导御以自誓　　所欲见最胜
  为诸奉持法　　所至无嫉妒
  将顺以弘誓　　身行常殊妙
  严净诸佛土　　开化众群生
  是遍诸佛土　　与诸佛俱游
  佛以一名称　　彼此无虚妄
  一切皆可得　　觉了最上义
  如是愿无量　　导利至永安
  是广普无限　　逮致无可畏
  众生犹虚空　　诸法所因生
  最胜究竟俗　　兴显于慧地
  其心之境界　　极入于圣慧
  逮致三达智　　以开于众生
  究竟至弘誓　　令我获此愿
  如是之畅达　　其行亦若兹
  如是善藏恩　　仁和心柔软
  笃信佛功德　　观察众生元
  缘行入愍哀　　兴发于大慈
  吾当护养育　　欲安立黎庶
  以是故布施　　若干种可惠
  国土城邑聚　　众宝及象马
  头目及手足　　并以己身肉
  一切普能施　　不可坏怯弱
  志慕众经典　　不以为患厌
  晓了世经籍　　随俗而劝化
  其智超三世　　怀惭志坚强
  供养无等双　　奉敬诸长者
  众圣行如是　　夙夜勤不废
  炽盛诸功德　　犹火中之金
  彼勤精行此　　菩萨十住地
  慕于无为业　　而化诸有为
  犹如有导师　　愍伤大众贾
  豫问安隐路　　故在前指示
  菩萨亦如是　　初发第一住
  稍进至十住　　成致无碍道
  以能住此义　　究畅执功勋
  慈心不怀害　　以法而教众
  在天下知时　　开化咸将护
  立众令布施　　使乐佛圣慧
  至圣发意顷　　弃国捐王舍
  入于佛法教　　出行修精进
  寻逮得三昧　　见佛无数千
  感动诸佛国　　睹光往听经
  净化无数众　　使入道法门
  游于百千劫　　随时现其身
  诸最胜本业　　觉寤众睡眠
  如过去诸佛　　觉寤众懵懵
  是为第一住　　最胜所宣布
  普愍伤世间　　无上诸菩萨

诸菩萨等。咸有闻此无上道业。慕乐尊行。心抱悦豫。忻然安隐。自从坐起。迎逆稽首。踊在虚空。散众天华。口宣妙言。叹曰。善哉金刚藏。圣猛无所畏。晓了道住。行菩萨法。众会悦豫。闻解脱元。唯咨上道第二之住。其行云何。当所思奉。大智唯宣。闻者坦然。进至无极。开化众生

    渐备一切智德经离垢住品第二

金刚藏报。诸佛子。是菩萨大士。以了初发第一住竟。尔乃好乐第二住矣。意性怀笃。奉修十事。何谓为十。一曰志性柔和。而无粗犷。二曰修正真业。无有邪思。三曰其行质直。永无谀谄。四曰心怀调仁。不为嗔恨。五曰其行寂然。未曾愦乱。六曰意抱至真。不为虚伪。七曰其行方幅。无有杂碎。八曰进止坦然。无所贪慕。九曰行在微妙。不为下劣。十曰其意宽弘。未曾迫迮。是为十事。菩萨意性怀笃。具成初住。至第二住。金刚藏曰。又诸佛子。菩萨已住第二离垢之地。离于杀生。不执刀杖。心怀惭愧。愍哀群生。常抱慈心。欲济众生。无有思想。心不念杀。不求人便。不危他人。舍身之安。而解众患。无有二心。况复犯乎。又不盗窃。心常好施不贪他财。己财止足不数多求。睹他所有万物生业财宝之利。不生嫉心。众人迎逆莫不戴敬。草叶毛米未曾默取。念广布施救济诸乏。割身所供惠众穷困。蜎飞蠕动蚑行喘息。随其水陆皆欲令安不遇众患。又舍爱欲邪淫之行。不欲重习。自于妻室而知止足。未曾兴心慕乐他妻。心不思想不干他室。奉清白行不为秽浊。如母如姊如妹如女无异。清净鲜明而无沾污。无有二心况犯色耶。又不妄语。不乐虚言。所宣至诚。言辞真正。所传顺理。言不失时。不窃妄语。至于梦中。不演非法。况昼日乎。不为色教。况心念耶。常说正法佛之经典。不出俗辞无益之业。又离两舌。不传彼此斗乱于人。不误两盲。未彻视者。使诤不和。不侵犯人。彼间恶言不传至此。此间恶言不宣到彼。和解诤讼使无怨望修德为法令无罪殃。讲论经道各有篇章。又不骂詈。不演粗辞。不宣恶言。不伤人心。世人所说。口演不仁。恼于他人。不微中人。无所恐畏。常行仁和。不兴嗔恨害心向人。不使众人意怀汤火愁戚之患。口所布言可一切心。柔软慈和闻者安隐。心中爱乐。喜欲见之。多所悦豫。远近思睹。乃传此言。久思其言。无厌其辞。又不绮语。离于饰辞。言无所犯。未曾传语。常护身口。终不戏言。而取误教。况复由利。有获财宝贡上归遗。而宣虚乎。虽身溺死。不演非义。身口相应。言行相副。不失神明不违佛教。又不嫉妒不抱贪餐。未曾兴心慕求众欲。他人财业。高德贵性。不发痴心。贪利无义。见人多有豪贵至尊。不以为嫉。心存道义。犹鱼依水。不舍正真。又无嗔恨。心常怀慈。愍哀之心。调和之心。安隐之心。柔软之心。其心常念欲济一切。而将护之。假使其心。发嗔恚者。若有患厌。不能自制。众垢危害。心中恼热。寻除其根。令不炽盛。抱以仁和。慈心弘坦。如畏蚖蛇。毒兽之聚。恶心便休。成斯仁和。又弃邪见。奉于正见。不堕外学。舍于贪事虚伪之术。吉良之日。不择时节。不思国位。若睹帝主。不以为贵。不怀谀谄。表里相应心性仁和。奉佛法众不失三宝。愍哀三界皆欲度脱。是为十善。常当守护此十善德。心行如是。思惟奉行。若见众生犯诸恶业。当归恶趣。以十善事而开化之。又其学士。已立正见。奉行至真。亦劝众人入于至真。所以者何。其自己身不能修德。欲化他人立道德者。未之有也。彼选择念。奉行十善。不归三恶地狱饿鬼畜生之处。其十善行得生人间。及生天上三十三天。又能奉行此十善者。成大智慧。思惟其义。畏于三界。兴发大哀。不为毁损。从他人闻。所宣音声。得成声闻。自然中间。修清净志。不欲仰人。不从他受。自欲意解。求成正觉。好立大哀。不以损耗。志入深要。思十二因。不了无根。得缘觉业。其心宽弘。最极无上不可限量。愍伤众生。执权方便。坚立弘誓无极法铠。坦然无迹。欲救一切众生之类。不舍三界。得成佛慧无碍道原菩萨所行清净道地。成无穷业。习转最上。众宜究竟。至逮十力。乃致佛法。十八不共吾等闻之。故当志学。一切学已。勤修精进。彼益深观其此十恶不善章句。甚为招致地狱缘报。中殃畜生。微衅饿鬼。是故我等若杀生者。归于地狱畜生饿鬼。设生人间。有二恶报。何谓为二。所生之处。其寿常短。又多疾痛。而中夭逝。家室忧戚。莫不感哀。若喜窃取。亦归三恶苦。若生人间。亦有二报。何谓为二。乏少财业。怨贼劫取。亡无多少。令人忧恼。犯他人妻室。亦归三恶。复有二报。眷属不贞。数共斗诤。喜妄语者。归于三苦。有二恶报。何谓为二。人多诽谤。言不见用。其两舌者。亦归三苦。复有二报。眷属离散。生下贱子。共为伴党。其恶口者。亦归三苦。复有二报。何谓为二。闻不可声骂詈之音。其绮语者。亦归三苦。复有二报。何谓为二。热恼他人。所在至凑。不能自决。其贪餐者。亦归三苦。复有二报。少于产业。又多疾病。其怀嫉妒。亦归三苦。复有二报。何谓为二。若在人间。堕于邪见。不知止足。起于嗔恚。亦归三苦。复有二报。何谓为二。自危己身。而恼他人。其邪见者。亦归三苦。若生人间。复有二报。何谓为二。没在邪见六十二非喜。行谀谄如是多患。因致苦阴。由以合成不善根本。假使能弃此十恶者。能以道法。自乐伏意。以弃十恶。建立十善。亦能劝他。令住十善。彼加大仁。愍哀众生。心怀弘坦慈心愍心。调和之心。广布恩心。散拥护心。是我之心。奉师之心。敬如世尊。心自念曰。一切众生。邪见所缚。心意颠倒。志念反逆。发起虚行。吾当尽立。令住真实。修于正真。言行相应。而安立之。众生一切。破坏诤讼。转相诽谤。常抱嗔恚。转相投祸。吾等当设无上大哀无极之慈。立坚固行。令无彼此。众生不厌结缚之难。嫉他人业。造反邪行。不顺道本。吾等令净身。亦净口心。众生心迷。建立罪福。习淫怒痴。为三盖碍。堕在尘网。常自投己不便之地。当求坚固。善权方便。消寂一切众劳之患。令立无难。众生在于愚痴之厄。无明所缚。住在六冥。远于大智。游闇昧门。行窈弊业。吾等当为开化严治。无所挂碍。清净慧眼。使一切法。辄如所言。由得自在。不戴仰人。众生堕在生死困患地狱畜生饿鬼苦门。漂在邪见六十二疑。罗网所缦。愚痴所蔽。邪径所迷。游盲哑路。不亲圣师。无有救护。有所归趣。无解脱业。为贼所劫。魔鬼在心。远离佛心。吾当将养。度生死原旷野悬路。立之无难。前在无畏一切智城。众生堕在大林盛火欲处色处无色之处。浮泅三渊。为生死流。所见漂没。随恩爱江。大患所摄。强在愚痴。心念贪淫。志思危害。欲行贼役。而计有身。犹海水岸。淫鬼所迷。随放逸走。慕入嗜欲。住己自大。各怀异心。未度想度。或诸衰入。而为震动。远众德本。吾等当化。修大德本。道力拔救。令在灭度。使离恐惧众危之厄。因建立之于一切智。众生悉为贪乐所缚。无数苦痛。愁戚之恼。多所志慕。憎爱所结。合会别离。而相恋嫪。无明所蔽。受在三界。吾等当开示其正路。至无挂碍。脱三界难。令立灭度无为之道。众生悉为猗见吾我。五阴诸入。不可转移。处四颠倒。依六衰舍。为诸恶贼。所见攻击。遭无量苦。吾等当化。除诸患厄。一切阴盖。使至无为。众生志存下劣之业。乏于尊慧一切智心。无天人道。志在恐畏生死之难。乐声闻缘觉吾等当化。使立微妙广大之心。是为佛子菩萨所入。如此戒力。劝化贫匮。常抱慈愍。以权方便。立于菩萨离垢道地。因得睹见无央数亿百千垓佛。供养衣被。饮食床卧具病瘦医药。一切施安身命。自归如来至真平等正觉。受是至清。十善奉行。虽受行之。无所违失。于无央数亿百千垓兆载劫中。所受身形。亦若干劫。不怀贪嫉犯戒垢浊无益之业。好喜布施。奉持净戒。犹如有人适生堕地。端正姝好。寻而洗之。清净无垢。菩萨如是。在此开士离垢之地。于无央数亿百千垓。兆载劫中。所受身形。不怀贪嫉犯戒垢浊无益之业。行于四恩。惠施仁爱。利人等利。救济合聚众生。拔众危厄。十度无极。勤修精进。戒度无极。悉为具足不使乏少。又族姓子。菩萨已能奉此初第一住。有第二住。名曰离垢。菩萨住是。为转轮王。治以正法。然有七宝。假使众生。退在犯戒十恶之业。以权方便。而劝立之。令行十善。若兴福施。惠施于人。仁爱之德。有所饶益。等利之义。一切不舍。常心念佛。惟慕正法。志在徒党。菩萨之业。开士之行。六度无极。十住之源。思念十力四无所畏。十八不共。诸佛之法。众行普备念一切智。以何方便。劝化众生。令逮至尊。为最为上。为胜为超。至于无上。为众导师。劝化一切。养育将护。至一切智。发意之顷。捐弃家业爱欲黑冥。顺如来教。出为沙门。普行精进。须臾逮致百千三昧。见无量佛。适见诸佛。建立道谊。动百千国。愿生其国。越无限界。严治清净无数世界。开化度脱无量众生。入不可限识本宿命。所历劫数。选择志求不可称载道法诸门。睹见十方众生形像。观无限量诸菩萨会。从学志愿。摄取菩萨殊特弘誓。亿百千垓兆载劫数。莫能称焉。时金刚藏菩萨大士。演此住已。寻则颂曰

  此等心质朴　　修治己意性
  其志已真实　　柔顺而调和
  已舍诸习贪　　慕求最上道
  其行极弘大　　辄在第二业
  执德住于斯　　积累众德本
  远离于杀生　　心未曾怀害
  离于悭嫉行　　不犯他妻室
  至诚不两舌　　不恶口绮语
  已消恚贪行　　常修大慈愍
  入于正见业　　无谄行质朴
  无爱舍自大　　作性粗举要
  将护世尊教　　常行无放逸
  地狱之苦痛　　畜生亦如是
  佛教兴光曜　　常以消饿鬼
  弃舍一切恶　　不善之心意
  灭除众为害　　志大至诚法
  自谨敕其意　　所生转善处
  至三十三天　　寂然永安隐
  犹如缘觉乘　　声闻及正觉
  皆由此十事　　从清白句生
  见此常当观　　恒修无放逸
  意坚立禁戒　　亦复劝化人
  益加增愍哀　　志性日弘慈
  观苦恼众生　　兴发心伤念
  皆堕诸邪见　　斯由意不寤
  嗔恚怀毒害　　心喜抱斗诤
  常不厌眷属　　勤约慕境界
  吾当度脱之　　令济此三厄
  造立大闇冥　　其性乐愚痴
  堕在奸恶路　　游于诸见网
  周旋在生死　　当行方便度
  济脱诸六情　　立正解五阴
  消除众尘劳　　越于四使渎
  灭尽三界苦　　然炽之恼患
  永离诸贪身　　世力吾我想
  吾以此等故　　苦行欲度脱
  游心尊最胜　　无上佛之慧
  导御修至诚　　弃捐劣愵心
  立志于宽弘　　诸如来道慧
  勤精进无量　　坚固得佛道
  住此寂功勋　　积累众德本
  见无数诸佛　　咸悉供养之
  斯等解清白　　见亿百千劫
  其身无挂碍　　心口亦如是
  诸佛子住此　　应时转法轮
  开化立众生　　使行十善业
  一切所积累　　清净之行本
  齐护于众生　　斯富十种力
  因时发意项　　弃国捐财业
  佛所作沙门　　修入勇猛行
  已通大精进　　致尊三昧定
  见无数诸佛　　应时如佛界
  以是若干变　　及与不可计
  辄睹其就界　　各在斯道住
  已能住此愿　　致最微妙慧
  造若干变化　　开化于众生
  是为第二住　　大圣之所宣
  普愍世群黎　　众菩萨最上

已得闻是最始上法菩萨第二境。不可思议。至真无异。诸佛子等喜。而修恭敬。住于虚空。则雨天华。各宣善哉。德如山王。而分布说禁戒之源。心念愍哀一切群黎。唯演尊妙第三行本。所说至诚永无有异。众菩萨行最为无上。普欲令世一切安隐。以愿称讲。第一雅妙。益当供顺。天人所敬。第二离垢菩萨尊住。除其爱欲精进造立。建大法慧。如之所为。行布施事。惠施禁戒。成为大圣。忍辱精进。一心寂然。善修智慧。慈心殊胜。愍哀行道。众祐宣布清净之行譬如月明。金刚藏踊演第三住。心乐善说莫不欣然。咸发道意。

渐备经卷第一渐备一切智德经卷第二

        西晋月支三藏竺法护译

    兴光住品第三

金刚藏曰。佛子菩萨大士。已得究畅第二住地。便入第三。寻当思惟。性行十事。何谓为十。一曰志性清净。二曰性行明达通利。三曰消灭淡泊其意。四曰心怀无垢瑕秽。五曰志念永不退转。六曰其心坚固而不怯劣。七曰其念极上无穷。八曰性行轻便而不迟钝。九曰其行微妙巍巍高玄。十曰其心弘广不协局迮。假使菩萨住第三地。观诸万物一切无常。苦空不净不可保信。悉归坏败不久存立。适起寻灭。本无所成。当来未至。现在无住。察于一切万物所有。皆归没尽。已得入此无所有地。悉是忧恼。危厄众难患害合会。结在憎爱之业。多有愁戚。咸以无常。淫怒痴火。甚为炽盛。因为成立。无所依怙。察此一切犹如幻化。一切万物。悉为恐惧。无有救护。心数动移。便以违失本之慧。见如来慧不可思议。不可限量。不可称载。极远巍巍。无有杂碎。亦无众厄。无为常存。无畏第一。不复退转多所济护。所见平等。已见如来无量圣慧。睹众危厄。益加愍哀念于众生心行十事。何谓为十。一曰心念将济孤独危困。二曰常化贫乏使入道法。三曰消于淫怒痴火所然炽盛。四曰其心周旋生死而不造乱五曰其心常欲蠲除尘劳之秽觉未觉者。六曰其心显耀令习自在。七曰劝导离善法者使乐大雅。八曰其心忘失佛法令入正道。九曰其心迷惑随生死流使返其源。十曰其心见在愚径而怀恐惧令立无畏。彼已睹察众生无数危厄。三界之患。辄修精进。吾当将济一切群黎。度之解脱令致清净。使得超越。化之立之。劝之寤之。开之示之。令至灭度。已能如是。达至无为。普入万性。如斯将济一切众生。所化若兹具一切智如来圣慧。心念勤修。拥护众生。又自思之。以何因缘。以何方便。化此无数众生之类。堕在苦恼尘劳之厄。所遭焚烧。使立永安。令无复异。住在无碍三脱之门。已立斯法。开化他人。以无挂碍三脱慧门。无复异行。解一切法。知无所行。了本真谛。导之为行行无所行。以此慧明。不复观听。猗他之义。唯学佛道。又心念言。何所为具一切佛法之根本也。唯以博闻分别义理。以观此慧益加增修。勤求正法。专精奉行。夙夜思法。欲听受之。不以为厌。乐法不废。发生好法。求法导法。志法由法。流法归法。救法护法。行法。善求道法。不慕世间无限宝物。无用诸藏盈满之珍。已得自在。发意布施。不念有难唯思法师。于世难值甚为希有。以用法故无所爱惜。内外所有咸以布施。所可惠施。若施眷属。田地。财宝帑藏。珍琦。璎珞。妻子男女。头目手足。耳鼻肌肉。支体衣食。及己身命。用经典故。无所贪吝。皆能惠施。用法典故。极重爱乐。所用安已。明珠如意。贵价瑰琦。布施之时。谦下卑言。所可放施。不怀悔恨。身心不恼。其有受者。因是令度。所不闻法。闻之欣然。胜得三千大千国土满中珍宝。宁闻一偈不用梵释转轮王位。修无央数百千劫行。或有来谓。卿今所兴习。是平等正觉之业。菩萨净行。假欲得闻此大正法。自投大火。更无极苦苦恼之患。越斯大火。若使己身。遭是困厄。乃成佛道。即念言。今我身求经。道宁爱乐一句法。不用此身。正使此三千世界满中火至梵天。求法故自投中。况小火也。设命堕在一切地狱。苦痛不安。故当勤慕。求于法典。况复值遇人间之恼。以此方便。求于经典。若使闻法。如法观察。一心解达。彼若听经。自伏己心。念志上道。识如是意。在于经典。而行要法。慕乐佛道。终不唐举。口言清净。照察如是。住菩萨地。寂除情欲。消灭诸恶不善之法。专惟善业。欢悦安隐。成第一禅。又除想念。其内寂然。而心一矣。无复思想。随时顺行。欢悦安隐。成第二禅。又好喜离。欲造恬泊行。其心寂默。身意快然。犹如众圣所言。观察其心。安隐行第三禅。又除其乐。弃捐众苦消竭前本。无乐无苦。专精永然其心清净。行第四禅。彼则越度一切色想。已超色想。逮有无想。入于名号。因时思念若干名想。辄以修行无量虚空虚空之想。彼已越度诸虚空想。因修奉行无量识慧之想。彼则越度诸虚空想。便无所著。修无所有。已度一切无所有业。因修无想。亦不离想。则不乐余。所兴发处。唯奉道法。因修慈心。广大无际。不可限量。无怨不恨。欲护众生。一志普周。遵行悦豫。慈念十方。哀喜行护。亦复如是。其心广大。愍护无际。无怨不恨。欲济众生。救护十方。具四等心。一切蒙安。又彼修成若干变化。神足示现。震动天地。以一身化为无数身。以无数身。还合一身。彻越虚空。通过墙壁。入出太山。须弥铁围。无所挂碍。如游虚空。虚空中坐。犹如飞鸟出没于地。如入在水。履水上行如行于地。身出烟火如大炬然。察是日月。神足巍巍。威神无极。游行四域。消除闇冥。以手扪摸日月宫殿。其身远超。上至梵天。耳之彻听。清净洞达。过于天人闻其言声诸天人民。又复了知众生心念。所念如是。知有欲心无欲之心。有恚心无恚心。有痴心无痴心。有尘劳心。无尘劳心。小心大心。多心少心。要心无要心。乱心正心。定心不定心。解脱心无脱心。最上心无上心。审见本末。皆悉知之。如是一切分别众生诸心所念。善恶祸福。道俗真伪。靡所不达。又识无限前宿所居。一生十生。百生千生。不可称载宿命时事。悉识别之。劫坏劫成。悉知无数不可计会天地成败。吾曾更历国土处所。名姓如是。所游饮食。寿命长短。衣服好丑。所遭苦乐。彼没生此。此没生彼此没生此。彼没生彼。周遍没来生。寻复还返。以是比类。晓知无限前宿所更。已复清净。清净天眼。过诸天眼。见人生死善恶所归。尊卑贵贱。如所作受。又此众生身行善。口言善。心念善。不谤圣贤。奉修正见。寿尽身散。得上天生。又若众生。身行恶。口言恶。心念恶。诽谤圣贤。或于邪见。寿尽身散。堕于地狱以净天眼。普见天人。蜎飞蠕动蚑行之类。所行祸福善恶所趣。又以一心三昧正受。若从定起。不用此德。有所向生。唯睹具足菩萨道品。愿有所济。故示现生。住于菩萨兴光之地。见于十方无数亿千兆载诸佛。奉事供养。衣服饮食。床褥卧具。病瘦医药。归命诸佛。听所演法。已闻受法。随器授与。未曾越法。不毁佛教。各各观察。益以愍哀。普如己身。亲族无异。欲解诸缚。于无央数亿百千劫兆载垓限。断邪见欲。心不在言。亦除邪嗔愚痴之态。如金宝师工治宝矣。以作臂钏。钗镮。璎珞。[王*步]瑶之属。无不成好。菩萨如是。住兴光地。则以无言。消诸所见。诸淫怒痴。以是德本。增行巍巍。清白日甚。渐备仁和忍辱之原。将顺戒禁而无所犯。心不怀恨不抱怒乱。志性无谄。心怀详序。而不卒暴。一切所作。不以究竟。所作成办。不行谀谄。无虚伪时。性无所受。行甚清净。彼以四恩。而宣爱敬。行益利义内志笃厚。十度无极。忍辱精进。所度无极。殷勤修此。亦复劝化余诸菩萨。谨慎清净。是为菩萨诸大士等第三住法。名曰兴光。菩萨住此。诸根通达。若作天王。执权方便。有所造立。若行布施。作行敬爱。设修利益。其心常一。念佛不舍。致普具。念一切智业。以何等行。为诸众生。致于最尊。得普敏达。为众导师乎。发意之顷。精进超绝。一时悉逮百千三昧。时金刚藏菩萨大士。欲复重散此义所归。说此颂曰

  斯等性清净　　德室心通达
  贪欲患消除　　成不退转业
  兴发坚固志　　强勇进微妙
  其意甚广大　　因是入三住
  已立于此地　　宣布光曜住
  说非常苦空　　不净毁散法
  为不得久存　　须臾虚无声
  选择悉有为　　无来无所往
  由是致疾病　　遭愁忧涕泣
  与众恼俱合　　受结着恩爱
  苦患不可意　　常炽然三火
  以见有为业　　发起无限难
  若厌于三处　　其心无所慕
  欲求诸佛慧　　其意不变异
  无量不可思　　所度无等伦
  睹彼众灭度　　诸最胜圣慧
  已见于诸佛　　永无众患厄
  无救离依怙　　扶济使得出
  常贫于道法　　为三火所灾
  犯所有苦恼　　百种缚其心
  重敬众尘劳　　无明志下贱
  已失威神力　　违安住道宝
  流堕生死渊　　恐怖求解脱
  我应拥护之　　坚强等精进
  志乐于尊慧　　不贪世人荣
  观察何等宜　　逮致至解道
  无他诸挂碍　　成诸如来慧
  其慧为智明　　是众安住乐
  以闻智专惟　　成菩萨圣慧
  适听所说法　　寻精进奉行
  夙夜欲启受　　无余因缘业
  以法而乐义　　以法广救护
  明月珠众宝　　所爱敬亲里
  国土广无极　　具足丰盛尊
  妻子及男女　　眷属诸走使
  以经典之故　　布施不吝此
  头目及手足　　己身之肌肉
  目见而口言　　施血如流江
  见害屠割刑　　所重髓布施
  不以此为苦　　不闻法为患
  假使有来者　　口宣如是辞
  犹如火所起　　自投炎赫盛
  若听安住说　　微妙法要宝
  闻之甚思惟　　功勋义章句
  一句法义故　　顶戴须弥山
  设使三千世　　满火至梵天
  我闻法善利　　其意达玄妙
  若人闻致是　　任如是苦恼
  正使于中死　　求得道慧明
  虽遭此众难　　忍苦不以患
  何况人身苦　　若干之厄难
  我之所恋慕　　惟志求闻法
  若得数闻法　　随时而思惟
  四禅四等心　　悦豫三昧定
  承于五神通　　渐备具足行
  以是由自在　　不堕所向生
  住立此轨德　　顺无数亿佛
  意常奉供养　　听受斯经典
  晓了离邪住　　启颡清净行
  犹若金无垢　　号曰为紫磨
  住是雅功勋　　报处忉利宫
  造立为豪尊　　回转处魔天
  魔天若干会　　功德诸章句
  以住无以意　　唯求佛功德
  佛子已住此　　殷勤慕精进
  逮致三昧定　　其数各百千
  睹见诸佛最　　相好若干种
  如益极微妙　　功勋尊无量
  是为第三住　　安住身自说
  普愍诸世间　　诸菩萨无上
  时诸天人闻大行　　微妙巍巍所住地
  众祐诸子怀踊跃　　则以天华散佛上
  会在地树持衣被　　嗟叹称扬此经典
  魔后可敬柔软好　　鼓乐歌颂胜妙法
  其自在天欢悦句　　以月明宝贡安住
  口宣我等故有佛　　兴发德时度彼岸
  其最法胜何故然　　独叹菩萨行第一
  我今得听妙道地　　于百千劫难得闻
  益加宣布愍诸天　　诸佛之子行殊胜
  得闻此软圣众会　　当得服行寂无地
  如月除患盛　　已兴安住谈
  第四所游行　　演行最为上

    渐备经晖曜住品第四

金刚藏复曰。佛子复听。菩萨大士。已能清净。住第三地。便进入在第四地住。辄得超越。入十明曜。何等为十。一曰游在众生之界。二曰周行通诸法界。三曰遍察三千世界。四曰观于无穷虚空之界。五曰普省众神识源。六曰流布在于欲界之处。七曰周旋往来于色界中。八曰优游而化于无色界。九曰志在上最微妙解脱。十曰其性弘宽心和柔软。是为十。菩萨大士。复有十法。逮法光明。从第三住。入第四住。且听佛子。其菩萨业。第四行住。名曰晖曜。适逮此已。则能将护如来种姓。致于内法。教化十慧。何等为十。一曰其心性行得不回转。二曰笃信三宝莫能坏者。逮所游处而悉究竟。三曰勤修清净玄妙之业。四曰解自然兴故行尊道。五曰分别世间从因缘生成败之事。六曰晓了一切悉从罪福致所生处。七曰敷演生死泥洹之源。八曰觉知众生国土之本。九曰宣畅散意过去当来。十曰能剖判说无所尽行。因得成就如来种性。是为十。金刚藏曰。又佛子听。若有菩萨。住第四地。自观内身。而行寂然。自御其意。不怀俗法。亦观外法。而行寂然。亦御其意。不怀俗法。重察内外。亦无所起。永无所坏。观内痛痒。察其心法。亦观本法。法之所行。观内外法。而行寂然。自御其意。不怀俗法众恶诸法。不善未起将使不生。精进摄心。成就方便令永断绝。不善法起寻消除之。诸善德法。若不兴者。方便精进。志乐兴劝。功勋之法。令立不失。进使广大。勤修道地。从行具足。自摄己心。未曾懈废。永除众秽。定意离贪。修行为首。念行神足。成就闲静究竟无欲。乃至灭尽。劝助功福。精进以定。备悉众行。以断心定。便安众行。断识定意。辄行神足。成就闲静究竟无欲之宜。乃至灭尽。劝助功福。念行信根。精进勤劬。念根定根慧根。成就闲静。而无众欲。灭尽众尘。劝德念行。信力精进力。念力定力慧力。成就闲静。无欲灭尽。劝德定念觉意。修法觉意。精进觉意。欢悦觉意。笃信觉意。观护觉意。成就闲静。令其无欲。灭尽众尘。劝德念行。正见正念。正言正业。正命正便。正意正定。成就闲静。令其无欲。灭尽众尘。普察劝德。目见一切众生所在。为其宣畅本宿世愿。志无极哀。兴发大慈。使疾逮得一切智矣。令速究竟净治佛国。具足如来十力无畏诸佛之法。诸相种好。音声言辞。念尊最上殊特之业。普使具足。求学深妙。听佛脱门。而行无极善权方便。又佛子听。菩萨若住此晖曜地。前本所习。自见贪身。猗于吾我。而计有人。依形寿命。诸阴种大。贪住众人。浮没高下。撰择狐疑。疲极之态。谓言我所。恃怙财业。实有处所。一切永除。如是猗着。皆亦断去。一切思念。诽谤之事。亲忍尘劳。勤学立志。善权智慧。在在所游。以道为宝。遵兴道教。其心润泽。心怀柔软。抱仁和意。心常愍哀。心不厌惓。求最上心。志好思慕殊特慧心。将护化育诸众生心。尊敬师友顺应器心。如所闻之辄奉行心。逮玄妙慧。所作甚快。仁慈柔软。所居安隐。止顿贤和。志性质直。行无所受。不以自大。不以憍慢。而受其教。归命无违。彼行是已。所受修行。寂然若斯。为上道地。清净住法。专精思惟。习合会行。奉行勤修不退转。精进不休。而不懈惓。遵不回还。所奉广远。所行无量。最上精进。求无等侣。皆护众生。所劝不毁。又其菩萨。心性清净。志分和贤。无有可不。成信诸界。意性长益诸功德本。永以消除贪妒慢恣。离于犹豫。亲近贡高。已得具足无疑脱门。因合会法。无厌不懈。已得速近建立如来。将顺其心。令无限量。其住在此晖曜菩萨道地者。值见无数亿百千垓兆载诸佛。普以供养衣被饮食床敷卧具。病瘦医药。奉所宣法。启受尊行又诸佛所。出家为道。行作沙门。益增勤修。心性仁和。信解习净。于无央数亿百千垓。不废德本。一切转加。巍巍遂高。丰赫弘茂。犹如宝师工作众物。成诸璎珞。所合无比。钗镮[王*步]瑶。靡不成好。菩萨大士。亦复如是。住晖曜地。其功德本。转以加增。越诸下地诸菩萨住。犹如佛子如意明珠。光曜清净。其晖远照。明无等伦。其余诸宝。虽在其边。光蔽不现。菩萨如是。逮晖曜住。则无等侣。诸下地菩萨。功德不现。众魔尘劳。悉为消灭。是为佛子菩萨大士住于第四晖曜地者。所在游立。弘坦和雅。若处天位。为天王时。开化众生。诸贪身者。所造立业。惠施仁爱。利人等利。一切救济。合聚群黎。常念诸佛。未曾忘舍也。乃至普具一切智道。何因得为众生最尊。咸致一切无极圣慧。为众生护。导之利之。发意之顷。殷勤精进。须臾一时。逮亿百千诸三昧定。睹众菩萨亿百千垓眷属围绕。菩萨之力。度于所愿。所愿殊特。变化自在。亿百千垓兆载计劫。无能计限。功德威神。于时金刚藏菩萨。重欲分别义之所归。便说颂曰

  修治至光明　　第三之住地
  众生处世间　　各各周流行
  其第三之住　　等犹如虚空
  其志性笃信　　清净行无犯
  适获致光曜　　大威无极住
  将养世尊种　　至诚而回转
  住佛无怀疑　　法圣众亦然
  立清白之行　　唯睹见品类
  在世尊吉祥　　从缘报往生
  因随于生死　　众生之国土
  以法为无始　　所兴无尽际
  奉行常谨敕　　逮归世尊种
  积累法如是　　愍哀于群黎
  其身遵道行　　心法消痛痒
  内外行相应　　思惟正其意
  专精修言教　　弃捐于所有
  已除尽众恶　　长成诸善法
  这消化诸非　　便修第四业
  奉行四神足　　五根并五力
  微妙觉意宝　　遵八路如是
  道念诸群萌　　意寂然眷属
  近办所誓愿　　因由本行慈
  志愿一切智　　以成治佛土
  其力上最豪　　心思惟章句
  又勇猛无畏　　与法俱教化
  殷勤志慕求　　乐佛殊妙声
  深远之道宝　　脱门之处所
  积德而惟念　　大善权方便
  已离于贪身　　消六十二见
  永除内所猗　　及其计有命
  无五阴四大　　诸种处亦然
  已得第四住　　皆除是诸碍
  咸离弃贡高　　安住悉无慢
  不复求贪乐　　所生之罪劳
  已消众瑕垢　　性行甚清净
  精进修道德　　修善不求身
  其心甚柔软　　所行无放逸
  心仁和质直　　贤雅而愍哀
  求慕上利义　　一切不患厌
  乐喜于圣慧　　为众生行业
  恭敬奉师长　　远离求爱敬
  作人有反复　　无谄顺教命
  无慢无所爱　　心性常乐快
  精进不回还　　奉尊等合集
  其行以得立　　第三微妙住
  内性无不可　　治心令清净
  睹见喜信乐　　增长清白法
  去众垢秽浊　　一切化痴结
  菩萨已住此　　殊胜无所著
  供养诸众祐　　无央数亿垓
  出家作沙门　　专精闻受法
  成道无等伦　　紫金成璎珞
  已能住是义　　功勋志性和
  善权智慧俱　　修行清净业
  若亿百千垓　　魔众不回转
  奉行殊妙宝　　犹如魔为侣
  已得住斯义　　供养人中上
  致成寂然道　　极尊法行句
  因能蠲众生　　六十二诸见
  若能行殊特　　为最胜慧故
  精进而志学　　亿百人中尊
  见佛无他念　　安和广大业
  又无数上妙　　将养无量劫
  愿乐誓慧堂　　尊功勋之行
  是为第四住　　清妙清净行
  名德应慧义　　真安住所演

时诸会者。皆咸得闻第四住地最胜之子知解诸法。欢喜踊跃。心中欣然。住在虚空。雨散天华。善哉佛子。宣扬无极。其魔虽尊。与诸天俱。踊在虚空。悉抱悦豫。供养众祐。若干妙云雨柔软华。贡上安住。诸根坦然。琴瑟箜篌。畅悲哀音。诸天集会。欲奉世尊。睹最胜像。及所建立。一切举声。演如是音。面目充满。性行巍巍行道甚久。今乃获愿。久来不见天人之尊。诸天已到。现能仁前。久未得察。动大海者演净光来。为甚大久。众生久来。今乃获安。甚久以来。闻悲音响。别来长迥。不诣大圣。获一切德勋所度无极。弃捐贡高。寂静致上。供养尊敬于大沙门。此间供养。经还天上。于此供养。趣安无限。能供养者尽一切苦。能供养者逮佛圣慧。众祐清净犹如虚空。不着世俗如水莲华。超照高远坚如须弥。心中欢喜奉敬最胜。演是音已心怀喜悦。降诸魔子。不可称载。喜笑瞻睹如是众德。当尔之时。咸悉寂然。宣布大财。如月毁复。勇猛无畏。散第四住。最胜愿说

渐备经卷第二渐备一切智德经卷第三

        西晋月支三藏竺法护译

    难胜住品第五

金刚藏曰。又有佛子菩萨大士。已能备治第四之住。四住已成。转得前进第五住地。当行十意。乃得通达。何等为十。念于过去。诸佛之法。亦思将来诸佛之法。复惟现在诸佛之法。修戒清净。其心鲜明。消灭诸见六十二疑。晓了求道。亦行清净。所行圣慧。悉见清净。剖判一切三十七品上妙之法。亦复清净。开化众生。所行清净。是为十事。金刚藏曰。又有佛子菩萨大士得第五住。然后乃成修善妙业。有行三十七品。心甚清净。道业益胜。所誓宽弘。因所愿力。亲近如来。慈愍群生。未曾忘舍。积功累德。合集圣慧。精进殷勤。而不懈废。善权方便。将导不逮。而常好乐。住妙晖曜。密喜如来所建立义。己意已入佛之势力。所念专惟不退转。如审解了是四圣谛。是为苦谛习谛尽谛道谛。彼能究竟至诚名德。分别圣谛。达其原际。晓了诸相。真正圣谛。其无方便。随顺宣布。解了真正。分别是谛。因行圣谛也。剖判其事。所度圣谛。有复能行。悉解知事。正业圣谛。次复宣布。行道圣谛。敷演其意。尽无生谛。体解得入谛智道业。皆已普入诸菩萨住。成就逮近。乃至辩才。如来大慧。散去结恼。班宣圣谛。又复能化他心念。咸令可悦。晓了随时。究畅圣谛。已能得入一因道义。转便晓了。达斯源际真正圣谛也。觉解己相。则能晓解诸相圣谛。解知志性之所归趣。则达五阴诸种。众衰情盖。别处所生因圣谛。度了兴身众恼之患。晓苦圣谛。更历周旋。缚结拘然。闭后乃解习诸谛源。一切永灭诸热焚烧。然后乃解诸尽圣谛也。初无二言。所宣如义。然后解道之圣慧。皆已觉了。至如来慧。然后乃解真习圣谛。信明慧力。晓诸不尽。令苦无余。彼若分别谛计。如是方便。降伏生死之源。解达一切所从生处。因由斯法。虚伪愚痴。所为不真。谛解本末。益愍众生。亲近大哀。在世兴发无极之慈。已能致此慧力道财。普护群生。好乐佛慧。观本昔来。生死所趣。察其始原。众生所从。致是无明。三处恩爱。漂生死流。阴盖所著。为之动转。增益苦阴。若能解达。无有众生。无我无人。无寿无命。已离吾我。皆悉了是。如过去事。当来现在。亦复如是。慕乐虚无愚痴之业。生死周游。而无断息。永无边际。无将护者。复无所知。彼无师友。虽有师友。不受道教。乃为无智。痴冥凡夫。眠盖所缚。不可称计。自灭诸我。方尽当尽。不复起身。亦无所生。不信佛道。转复长益。勤苦恼患。有为生死。所见漂流。不舍阴盖。不厌四大。不拔贡高。诸见疮病。不别淫怒。不消无明。窈冥之室。不竭爱欲渊池之难。不求十力导师之业。入在魔行。堕于生死反覆之海。无善之想。去于自在。如是苦患。不可称计。永而无护。无所归。无救济。无利义。一己身。无辈伴。当以修行。如是像业。积功累德。每生自克。因能修慧。已能逮解一切众生。究竟本净。乃成十力。畅无为慧。巍巍明曜。如是要慧。意已觉了。得道成就。所可造行。积功累德。皆为众生。而兴立护。愍伤群黎。普安众生。垂哀一切。欲度脱之。无娆害心。不诽谤之。劝化众生。靡不欢悦。为之导师。而令灭度。彼勤修已。住于第五难胜之地。由得自在。心无所忘。晓达善行处处之业。志意坚强。善分别慧。其意普至解经次叙。章句之谊。意怀羞惭。彼我皆护。其意勇猛。将养禁戒。随无所犯。意中明了。宣布处处。所当正行。周入众圣。无所戴仰。往返智慧。以宣畅义。随时散布。得神通行。诘誳方便。而显道化。修行善权。随俗而导。积功累德。常不厌足。慕求道慧。未曾懈废。奉无极慈。合集愍哀。意不怠惓。求于道业。不以闲退。精进殷勤。务佛十力无所畏慧。诸佛之法十八不共。常以善行。思惟深入庄严佛土。立若干行。合集积累诸相种好。常行精进志求如来庄严清净。身口意行。修无极业。敬尊奉戒。顺诸菩萨。重众法师。无所危害。以诸菩萨善权方便。普游世间。夙夜一心。舍他之念。常以道法。勤化众生。能修如斯。以布施业。劝导众生。爱敬利言。大利济彼。等救群黎。乃复示现色身之形。为班宣法。因而遵行菩萨如来大业。以开化众。乃复睹见生死瑕秽。称扬诸佛圣慧功勋。能行如是以大神足。变化感动。以若干种善权之谊。唱导众生。而教化之。已能精进。如是化者。入于佛慧。心性行道。以不退转。修众德本。勤求殊特正真法矣。愍伤众生。其有游行。处于世间。书疏经典。印绶众会。计校守府。诸身种大。所应疗治。医药众病。寒热羸瘦。鬼神所娆。中毒狂病。若有追逐。所在疗形。合偶伎术。跳越嘲说。多所欢悦。郡国县邑。江河泉池。树木华实。所生药草。金银明月。珠玉水精。琉璃所现。众宝日月。[阿-可+聚]邑村落。居家田地。地动眠寐。所梦怪应。所入一切众身形像所在。诸相所应。所当修治。谨慎遵行。财业货物。神通无色。以无放逸。四等心行。所造专精。而无危害。愍哀众生。因修永安。彼以此行。愍伤世间。稍渐立之。诸佛正法。能化立之。难胜菩萨。道地供养。奉事无央数亿百千兆载诸佛。衣被饼食。床褥卧具。病瘦医药。在如来所。弃舍家业。出为沙门。于诸如来。听受经典。成为法师。又复重闻。逮得总持无数亿垓百千劫中。兴显德本。究竟清净。又如佛子妙宝车磲。共合相近。转相照曜。菩萨如是住于难胜开士之地。以此德本。修善权慧。道义遂高。加大乘。应造功勋。所行无侣。犹如佛子村落之中。有夜光珠。普照田地如云风遍。吹浮游转诸天宫殿。菩萨如是得难胜住。以是德本善权智慧。心行普入。常处在世。无能乱者。是诸菩萨大士之业。第五住。菩萨住此。多所悦可。若为天王。降伏一切众邪异学。有兴立者。布施爱敬。饶益等利。见众生念。未曾心离诸佛行法。乃复普忆。思念诸圣一切智业。以何方便。蒙济众生。乃至巍巍无极道堂。发意之顷。须臾精进。一时之间。逮不可计亿千三昧。见众菩萨无数百千。眷属围旋。论经说谊。于彼得度。建立誓力。咸成菩萨殊特变化。无能称计限量其德。乃至如是亿百千劫。莫能咨嗟畅其功勋。时金刚藏菩萨大士。欲重散此经典之业。便说颂曰

  第四晖曜住　　甚清净如是
  其意已平等　　思惟三世事
  斯心行业戒　　道德修清净
  发意顷离结　　转入第五住
  而意念诸根　　若闻不回转
  以有四意止　　道御乐章句
  已超游五力　　一切无所坏
  则勇猛周旋　　因得第五住
  惭愧为衣服　　清净禁戒香
  觉意成华鬘　　禅思为途薰
  遵奉智慧业　　道尊自严容
  总持为苑囿　　定意平等行
  四神足游步　　意净为脑户
  慈心愍哀眼　　殊妙见圣慧
  摄持无吾我　　其意伏尘劳
  便得入第五　　人中师子住
  适得入第五　　特异之道地
  道业以清净　　修行转复上
  若能净志性　　辄求最胜諠
  怜伤厌众患　　思惟离意念
  积累功德本　　尊慧亦如是
  兴发无数众　　照显行道地
  为佛所建立　　念无慢圣意
  晓了自然解　　不废正四谛
  究畅真谛諠　　将养护众根
  若分别真正　　转复度诸佛
  如是消着意　　并及行道谛
  等志而道明　　乃至无挂碍
  以微真雅心　　修治若斯谛
  智慧脱门尊　　不恼无阴盖
  已修功勋本　　行慧甚广远
  超度众因缘　　济一切群黎
  其怀真实意　　成就如是谛
  亲自畅解之　　达本净无安
  慈愍无所得　　尔乃为安住
  因众生劳患　　求众祐道慧
  勤观其造始　　本源之所从
  愚痴由闇冥　　闭在恩爱种
  众生贪取阴　　便成苦恼身
  已逮无吾我　　察之如草木
  从劳尘致有　　数数往诸趣
  犹轮转无际　　众苦患戚恼
  呜呼亡失已　　众人可愍伤
  愚戆之所憔　　生死流不返
  五阴情犹牛　　诸种邪见疮
  火然烧其心　　志贵于闇冥
  堕于爱欲河　　方慕求明显
  处在勤苦江　　明求最导师
  以见如是难　　当修无放逸
  诸所遵行业　　皆用度众生
  志强性行安　　游步有气势
  既勇怀惭愧　　晓了成智慧
  积功德无厌　　圣尊行如是
  清白法无惓　　力势是其意
  是最胜福田　　宣音觉意相
  所作无饱满　　精进哀众生
  欲化众生故　　因往入工匠
  或画师刻印　　计数人疗疾
  像如鬼邪娆　　由以转除病
  立之于经要　　解觉乐慈愍
  合偶作赋颂　　若干种戏笑
  流河及园囿　　浴池树华实
  建立无数业　　以用安众生
  现无量像色　　众珍宝若干
  取地令动摇　　则睹日月光
  众生之有相　　游诸国处所
  无色财为胜　　神通不可量
  欲以修愍哀　　普安于众生
  于斯谓难胜　　殊妙智慧业
  供养亿载佛　　同听受经典
  彼等修性仁　　清白行遂显
  犹紫金车磲　　磨治平明好
  其宅众宝成　　宫殿转游行
  此风转之前　　无有违护者
  如行世俗法　　然悉为众生
  游是觉朋侣　　譬莲华在水
  于是处兴术　　所建造豪尊
  违舍异学术　　睹修欢悦事
  所行众善德　　皆由最胜慧
  救护于群黎　　因致十种力
  等尊逮威势　　精进为无上
  见若干亿千　　安住天中天
  得殊妙三昧　　观察亿国土
  所愿差特故　　复过是功勋
  是第五住地　　若干亿品术
  御化众邪术　　显已曜众生

时诸佛子。闻班宣此诸菩萨行。从地踊上。住虚空中。欢喜雨华。明月珠宝。璎珞衣服。光明清净。供散佛上。口叹善哉。一切神明。处虚空中。百千之众。莫不踊跃。时诸天下殊妙杂宝。贡奉众祐。香华涂香。缯幡幢盖。诸魔眷属。自在天子。诸天俱来。在于其上。游步虚无。雨诸宝华。其心悦豫。供养最胜。意抱无量。口宣善哉。诸佛之子众神皆集。无数亿千。亦住于上。鼓众妓乐。其音清和。又一切妓。畅如斯音。佛响仁和。弃散恶尘。本净空寂。消众法想。犹如虚无。等无思念。行步清净。住立成就。不着于俗。永无放逸。无本平等。而悉真正。法无想念。若有晓了。诸法悉无。则成无本。无所有业。辄无所思。愍伤众生。精修救度。是为佛子法王诸子修布施行。皆舍相着。其戒坚固。心性恬怕。为众生忍。无尽法慧。授精进力。令诸法寂。入禅定门。净除众尘。察诸万物。信解空无。圣慧力成。为一切护。是诸佛子。高德除秽。如是声有百千。自然宣柔和音。最胜大圣。寻默然时诸天玉女。众如食息。还复天上。金刚藏叹志勇猛。化得行成第五住地。遂致究竟。莫能废哉

    渐备经目前住品第六

金刚藏曰。诸佛子听。菩萨大士。以能修成第五住者。辄超进入第六住地。则行十法。何谓为十。了一切法皆无有想。而普平等。诸相平坦。永无形类。悉无所生。超绝无侣。皆无所起。故曰平等。为甚清净。调定真正。皆无放逸。不为驰骋。无应不应。无[雨/隻]无只。寂寞坦然。而无伦匹。犹幻梦影。山中呼响。水月现像等亦如化。所行道业。而无二意。是为十法。从第五地。逮第六住。作是行已。自然观是。一切诸法。计校思惟。反覆察之。不令错乱近第六住。自然目见。以逮成此。则得通利。柔顺法忍。不从迷惑。尚未逮近无所从生法忍。稍以近之能致自然。入于一切诸法处所。转能进前。致于大哀。为尊元首。显耀大哀。具无极悲。解世五趣。有无合散。以观如是。名第六住。乃畅世习所可由生。皆从倚已。吾我所致。以觉欲事。世无所有。怀愚意者。倚着吾我。因其无智。而成痴冥。慕乐生处。习不顺业。志务犇逸。反邪之行。积累若干。罪福兴衰。万物无常。由无益生。解是所行。心善自修。消除诸漏。至真本无。其发善德。故当还返。周游生死报应之地。所作是田。神识是种。无明之本。则是闇冥。爱是润泽。贡高自大是其志性。长养诸见罗网众结。使因得是。自生名色。转增名色。则成诸根。诸根已成。起若干种所更习事。习事以起。便有痛痒。从痛痒故。便有喜乐。则益所受。以益所受。辄成所有。发意合成以成发念。因成五阴五体之形。寻至五趣。渐稍生着。以至诸着。众猗悉备。由是发起恼热烧炙一切忧戚啼哭之苦。诸不善业。本空无形。不了得习。无乱别者。皆复自然。稍习无盖。故致得此。有解斯义。便无所慕。菩萨如是。乐于柔顺。观十二缘。则自思惟。以是至诚。是所生识。究竟无慧。无明之业。本为清净。成行报应。所行以成。神识在先。神识之侣。有受四阴。则致名色迷惑之事。诸衰六入。诸根境界。辄成神识。因为同伴。与诸漏更。更成痛痒。因爱适长。益于所受。以御所受。则成漏业。从所作生兴生身阴。斯生之内。因致老羸。身阴散坏。致于死亡。与愚冥俱。甚可恐畏。此从危害。至住结网。致口言辞。是生五根。苦起意根。从其忧愁。多所戚患。因成受有。以是缘故。退生苦树。造立所作。被自思察。由倚所作。用知所作。方当作者。计彼有作。则无所作。本末无相也。亦不可得。又复思惟。其三界者。心之所为。其计于斯十二缘起。五趣所归。如来至真之所解畅。又此一切一种一心。同时俱成。所以者何。若诸根等。心生贪欲。悉由神识生死之痴。因从无明。其名色者。心为伴侣。而立迷惑。从其名色。名色以成。为六衰入。从致所更。为痛痒侣。痛痒意爱。所以有爱。从不舍受。发起众难。由此缘合。而致所有。因倚致生。其兴罗网。誓愿老死。从神识中。因致此有。别知名色缘对。而其名色。各各有趣。六情衰入。已睹已界。能入寂寞。更习缘故。从其更习。意念致之。生痛痒缘。从痛痒故。便复作行。善恶好丑。从恩爱缘。致乐尘劳贪淫之事。从爱缘故。致结缚狱。从有缘故。致于他生。生现在处。不可解从。生缘因发。生五阴本。致老之缘。以致老耄。诸根便熟。则致死亡。以至死者。有十二事。发缘起处。其身阴坏。而不能断。未曾永绝。从无明缘。则致众行。名色六入。习更痛爱受有生老病死愁忧啼哭。无明缘故。无有断绝。不可究畅。如是有余。无明适消。众行便灭。由是有耳。如是有余。彼以无明恩爱所受。长益尘劳。无断绝时。及行所作。往返报应。报应展转。根无拔时。尽其余殃者。苦痛辄转。亦无休息。以无明矣。为去来今。见缚流布。宜当断绝。如是三转。三转无我。以离吾我。无明灭去。自然之业无有处所。犹如苇屋。若池清净。若苦众恼。无明之故。则有行矣。是为本宿。未曾诸痛。因其识故。乃致痛痒。是为现在之痛痒行也。从爱致有。是为将来痛痒之原。从此以上。则无所生。无明适消。众行便灭。亦为断绝。有苦三患。十二报应。从因缘起。彼从无明。致于六入。是能灭行。众行已灭。因是别致。众行如是。有余二事。自缚苦更痛痒。尚有余尽别离之苦。无明适消。诸行便灭。三苦永断。从无明故。致诸行矣。从作缘故。致众行耳。如是有余。无明适消。众行便灭。是为所有。一切诸行。有是余故。有无明行。以权方便。开解大缚。有是余故。而有轮转。彼当以故观十二缘起灭所趣。反覆察之。由从因有。勤勤倚着。御身口意。因自作缘。供养所致。无有生业。其三回转。使不复转。宿本无痛。习更三苦。修行报应诸缘起耳。假如有人。举其负债。而在解缚。观察无尽。无所有尽。彼观此缘。缘适起时。识当来事。悉当了之。无我无人。无寿无命。自然为空。寂然恬怕有所造作。因遭得报。遵空脱门。心性怀此。如是灭尽。以无有余。现在之处所也。思惟专志。无相脱门。以故知之。无所慕乐。唯志大哀。教授开化宿本众生。是为心抱无愿脱门。以能奉行。是三脱门。则以消除彼我之行及见作相。去于有无诸相之着。复加进抱。大哀为无。益便精进。化诸凡夫未成道者。使得究畅。以能成就。辄达法会。转通法会。不复退还。具备和同。以进仁和。成就不退。若睹如是。所生嗔结瑕秽之病。由此合会。适以合会致此众患。犹如江水流无休息。心自念言。不用余行。永修寂然。开化众生。如是佛子。若能行此。处在无恨。殃毒恶世。导御自然。观本净者。不起不灭。遵奉大哀。化顺众生。行智度无极。号无碍慧门。渐修熟志。学至照曜。合会道明。成慧如是。正道大业。道利应时。服食道义。不与邪业而俱合会。因佥观察。自然寂灭。亦不往彼道品具足。亲自睹解。目前道地。便入于空。惟解定意。其定意。名入空自然空定。究竟空定。第一空定。为无极空定意。为合会空定意。所奉行空定意。真无念空定意。为等察空定意。离业无物空定意。如是比像。逮得一万三昧门。自然目前。无相无愿。亦复如是。转复进修。亲近逮至诸菩萨住。其心充满。性不可坏。心性了了。性行真正。其性深远。意不可转。意无休息。其意弘广。心思无限。意慕乐慧。其意集会。善权智慧。尔乃备悉。此菩萨性。遂致淳和。在如来道。永不回转。能化异学一切邪术等顺慧地。不堕弟子缘觉之地。专一增进。目见佛慧。而无等伦。舍尘劳行。得坚固志。住菩萨慧。而熟修奉空无相愿。遵承法教。随时应宜。善权智慧。不复毁散道品法行。彼住菩萨。目见道地。智度无极。益复超异。今日成就。通利应道。疾逮第三忍。名曰柔顺。是谓道法。转而顺从。彼以住此目见菩萨第六道地。见不可计亿百千垓兆载诸佛。寻时供养。下意奉事。进其衣食。床卧坐具。病瘦医药。在诸佛所。出家捐业。行作沙门。受听经典。如所闻之。奉行智慧。勤修圣达。所行求义。即能逮致。转修觉进如来法藏。逮大法明。在不可数亿百千劫兆载无限。成功德本。遂显巍巍。犹如佛子上宝琉璃。洗治发明。其光灼灼。菩萨如斯。住是目前菩萨道地。其德日增。行善权智。益加显发。以此德本。转增寂然。游步无侣。犹如佛子。其月大光。照众生心。使各坦然。其四大风。所御宫殿。独而无侣。菩萨如是。以住目前菩萨道地。德本日增。照除无数众生尘劳。拔爱欲瑕。总四魔径。独步无侣。是为佛子菩萨大士以近目。前第六菩萨所逮道地。遵修住此。善能变化。设为天王。其四大者。睹之降息。独步三界而无畴匹。声闻缘觉不敢咨问。所行德本。布施爱敬。利益等利。化众生心。不舍佛道至皆具足。念一切智。何所陈生。最第一愿。势力坚强。导御开化。成其普智。发意之顷。如是比像。无极精进。须臾之顷。逮致亿百千诸三昧定。开化无数亿百千垓诸菩萨众。睹诸眷属菩萨愿力。而有殊特。有所感动莫能称计行若干亿百千垓劫。不可为喻。时金刚藏菩萨大士。欲广解散此义所归。即说颂曰

  以能具备悉　　第五之道地
  因法为瑞应　　无相无所生
  不起甚清净　　以为无放逸
  奉行圣慧意　　便入第六住
  诸法为寂寞　　静然无想念
  自然犹幻化　　解脱于生死
  以致柔顺忍　　法自无所乱
  其慧转殊胜　　则勤修六住
  聪达住柔顺　　频入明慧力
  观察一切世　　从习而有报
  由愚痴盲冥　　而有己人物
  欲度脱斯等　　故兴修勤行
  从选择因缘　　本末悉为空
  所作缘报应　　和会致诤乱
  犹若有所作　　便睹造所见
  选择亲近众　　犹如蜂采华
  假使慧察之　　本末为明冥
  思想缘罪福　　得报以痴果
  从思想已故　　名色为伴侣
  如是致有难　　乃成五阴苦
  因其我心所　　堕入在三界
  又是诸所趣　　十二悉一心
  从贪淫而生　　心行亦如之
  有尽亦如斯　　复为心所误
  由无明痴故　　造立十二苦
  愚冥之因缘　　数施诸想念
  如是之所致　　老病俱散身
  又一切诸患　　由当尽冥坏
  从痴无明缘　　因是无断绝
  思想若消灭　　因缘则断除
  以起愚恩爱　　而缘致尘劳
  勤苦之恼患　　想念有余害
  从诸入致痴　　故有生死苦
  更乐及痛痒　　从苦复至苦
  有复余受身　　展转复长苦
  断除诸苦恼　　则乃无吾我
  本无有痛痒　　亦无诸想念
  其神识所更　　现在而往返
  用当来受行　　故成诸苦恼
  又所消灭者　　观之所永尽
  由愚痴因缘　　自然成觉了
  因其患厌故　　灭除诸因缘
  因其因缘故　　于是断诸缘
  观诸卑贱士　　自然为永空
  柔顺及愚冥　　承其行业意
  逮之乃尽痴　　蒙此皆断缘
  深妙之因缘　　解之虚无相
  察省十事分　　了其不可别
  有计诸所趣　　罪福处未来
  其财业三品　　从本来展转
  剖判三苦行　　起灭之处所
  无所有阴尽　　柔顺解因缘
  因缘起如是　　所入畅平等
  譬如现幻化　　爱欲业若斯
  如梦之所睹　　形影亦如是
  冥騃愚痴类　　自然犹野马
  其解如是行　　彼智乃了空
  诸缘为恍惚　　奉此无坚相
  以能了如此　　亦无有志愿
  唯欲愿愍伤　　一切众生类
  其大志宽弘　　如是行脱门
  心转加慈愍　　思乐佛功德
  勤修忧众生　　实思察其元
  无诸情戚患　　逮无量功勋
  承空三昧具　　识本百千劫
  勇猛士如是　　无相亦无愿
  建立斯道业　　柔顺尊法忍
  其慧应无为　　脱门为善宝
  如是性宽弘　　供养于大圣
  应寂然除愦　　志顺最胜命
  逮成觉意定　　益增加清净
  犹琉璃紫金　　雕治益光荣
  以照众生意　　犹月之弘光
  四品风游行　　独步无等伦
  因越魔径路　　最胜光美妙
  消灭众尘劳　　燋炙诸苦痛
  天师大锭镣　　宣布此慧住
  善化立道意　　变消心怀风
  所可奉圣慧　　演章句所讲
  勇士已超越　　声闻所不逮
  发意须精进　　已逮安住业
  宿世已获致　　亿百千三昧
  须臾见无数　　十方诸现佛
  其德照曜世　　犹日秋时月
  微妙深难了　　胜声闻不及
  众雄自由讲　　第六之道地

于时诸天。闻所说法。心中坦然。住虚空中。雨若干种。华香珍宝。称扬咨嗟。柔软妙音。口宣清净具足可敬功勋之声。善哉上最思惟利义。累功积德。慧得自在。殊胜之行。为最巍巍。犹如莲华。愍伤群生。其行超绝。不可称量。大神妙天。在虚空中。散雨殊妙众杂华香。消除粗细尘劳忧冥。颁宣琦异上好音响。逮最清净第一之利。我等以闻所畅道地。时诸伎乐。出悲音声。诸天玉女。心怀踊跃。于彼诸天。承佛圣旨。令诸门户皆自为开。除众闇冥。心解如日。奉最尊法。于是彼世无数之众。俗间贤人。皆超越世。显示方俗第一微妙。遥见其身。寂然恬怕。而现其形无身之身。自归于法。消灭调定。使无想念。有其音响。眼目大明。越无央数诸佛国土。供养诸佛。奉众导师。自察其身。忆如最胜。弃诸瑕秽。慧得自在。开化众生。无彼我想。奉精进行。应所行业。诸天玉女一切皆乐寂默之义。观人中尊。众会悦豫。启白众祐。为供养佛。身自在已。愿说殊特。正法言教。功勋如海。唯时宣之。显第七住

渐备经卷第三渐备一切智德经卷第四

        西晋月支三藏竺法护译

    玄妙住品第七

金刚藏曰。惟佛子。菩萨大士。以能净治第六道地。具足安住。入第七地行善权智。则有十事修玄妙道。何谓为十。谓行空事无相无愿。所遵真谛。成就忍力。愍伤慈哀。念于众生。奉行佛法。乐供如来。笃信无违。心抱慧门。常顺空义。积累功德。无穷之福。解三界虚。在于三世。劝化群黎。永以消秽。所由恬怕。除一切尘炽然之炎。欲消众生一切贪淫嗔恚愚痴。晓诸所有。如幻如化。如梦影响。野马水中之月。而无有二。罪福之事。终不腐朽。意念国土。犹如虚空。开导众生。庄严国土。法身清净。坏来至义。得入一切诸佛名号。具悉色身诸相种好而自庄严。行无所著。离于音响。信如来声。本寂清净。解群黎音。导利庄严。一时之间觉了三世。入于诸佛世尊之业

又能普入若干时劫。分别诸数。剖判众生志性所行。是为十事。修殊特道。从六道地。至于十住。名曰玄妙。是菩萨大士。当勤修学善权方便智度无极。因便得入第七道地住第七地。劝化无数众生之类。以用诸佛无限之法。教授无量众生之恼。入不可计诸佛世界。严净无数诸佛国土。入不可议若干品藏经典之教。入不可计诸佛正觉圣慧道业。下入无量不可计劫。入不可计诸佛所行去来今世。劝不可计众生之类。令入笃信殊特之行。入不可计诸佛色身现若干形。解不可计众生根性。入不可计诸佛所宣音声言教可悦一切。入不可计众生所思若干心行。入不可计诸佛大圣导利慧堂。入不可计诸佛应时化利声闻所归笃信。乐不可计诸佛所宣好入导教。尊习开化不可计数缘觉之众使得成就。入不可计诸佛至圣深要之慧所演道门。入不可计诸菩萨众开士之行。班宣诸佛不可称计大乘之业所布导慧斯等自谓是不可计乃逮佛名诸平等觉玄妙之地。所行殊特。不可称限。乃至若干无央数劫亿百千垓。乃能积累如是佛法。自谓我等建立此道。不贪财业。无想不想。具足众行。如斯谛观。缘神通慧。常行精进。入于道行。善权智慧。善住圣道。所行无动。一时闲静。奉行道教。未曾懈废。自恣所欲。其行如是。巍巍之业。坐起经行。卧寐言谈。默然无盖。常立威仪。不忘一切。不离若斯念道之行。彼发意顷心一念间。备积菩萨十度无极。普累功勋所以者何。菩萨大士。奉修如是所在发心。兴无极哀。以为元首。合聚佛法。劝如来慧。以是德本。施于众生。习于佛道。是施度无极。烧灭众尘。是戒度无极。若能愍慈无尽之慧。知众生无。是忍度无极。若能勤行众德之本。习念救济一切众生。行是方便。是为进度无极。其不舍道向一切智。是禅度无极。若了本净自然之行。无所生门。逮得法忍。是智度无极若能导利。无量圣慧。益于十方。是权方便所度无极。若能修行极上妙智。宣于道业。是为誓愿而度无极。降除一切诸外异学。伏魔兵众。是为势力而度无极。审如至诚。越一切法。发悲义行。是为慧度无极。以是具足斯十度无极。辄能宣备四恩之业。具悉三十七道品之法。至三脱门。常平等心。一念之顷。渐备普备。成立如是

有一菩萨。名曰解脱月致究畅。时问金刚藏大士。菩萨之行。以何等业。一切具足第七道地。欲悉能备成菩萨道。必当学进至十住乎。答曰佛子。一切菩萨。菩萨行道。皆当具足十住道地。因是济脱。何况于斯七住菩萨。所以者何。又是佛子。菩萨道地行。以具足。入神通慧。普能具足一切道品。亦复成就一切十住。具足十住勉力解脱。从一发意。备斯七住。所以者何。是为佛子菩萨道住具足诸行备慧神通。又有佛子从初发意。始第一住。一切誓愿。渐以亲近具足道品。心好第二。次至第三弘要之业。逮法光曜第四道地顺从之业。第五光明随俗之行。入于第六深妙之法。劝立一切诸佛之法。所以者何。若有菩萨成就七住。入神通慧。辄在八住。具足究畅无家业地。犹如佛子有二世界。一者瑕疵。二者清净。本际平坦。一等清净。所度一等。其两界间。不可越度。以大神通。至力愿力。乃可越矣。如是佛子。菩萨当以至勤清净开士之行。乃能究畅。不以轻懈唯以弘誓善权智慧神通之力。乃能普备

又问云何在第七住。宁复亲慕尘劳行乎。诸菩萨业。当以何察。答曰佛子。从始发意。住菩萨地。乃至十住。咸悉消除一切尘劳祸福之业。劝助道元。当作是观。犹如佛子别知同道。义无所越度。故名曰七。犹如佛子转轮圣王。乘大宝象。游四天下。晓了是非。与诸贫穷苦恼之患。尘劳杂居。解众杂垢。不为瑕秽所见污染。亦无所犯。成人威德。舍人间性。生于梵天。升梵天宫。睹见千界。住在梵天。显现光耀。不入人间。如是佛子。从初发意。在菩萨住。乘度无极。皆知一切众生之行。不为尘秽之所污染。升奉道堂。亦无所犯。乃名曰七。假使能弃一切诸行。因从第七。至第八住。亦承清净菩萨之乘。悉了一切众生之行。不着尘劳。瑕秽不染。永无所犯。辄得超度。入玄妙法。是故佛子。菩萨若逮此第七住。若在淫种。越一切欲。住在彼欲。行清净法。不当谓之有尘无尘。虽习在欲。则无尘劳。愿如来慧。未具所愿。不当谓之离尘劳也。住此地已。志性清净。身行清白。究竟鲜洁。口所言辞。心所念行。本末清净。其心一切所可念事。皆度众生。咨嗟诽谤如来至真。有形无形。诸平等觉。所可言教。皆悉顺从。未曾违之。无复慕乐世俗所有工匠异术。犹如第五住菩萨道。不好世间。普为师友。多所悦可。一切所好。至未曾有。乐至真法。住于三千大千世界。如来至真等正觉。及第八住菩萨道行。无等侣。志性所行。常怀仁和。其意所乘。以恒进定。及与神通三脱之门。皆修专精。奉行道门。无所希望。尚未成就第八菩萨道地。住斯地已。一切发意。遵承权慧咸以具足。遂修道品。以得菩萨普具。足业七住道地。逮成开士善择三昧正受。次名善念义定。意胜定。分别义定。审宣法定。善住本定。慧通门定。修法诫定。若干义藏定。生死无为定门。菩萨逮此三昧正受。如是备悉百万定意。道地清净。因其正受。以斯定意。逮净权慧。又入大哀无穷之力。过声闻地。越缘觉地。近行慧门。以住此定。持顺无量身行之业。进诵瑞应。口言心念。亦不可限。见谛清净。光明巍巍。无所从生法忍又问其初发意。得第一住。其身口意。不普越度声闻缘觉乎。答曰。以故勤修弘广之心。行至七住。乃能逮成自在己行。而无等侣。犹如有人。生于王家。乃为王子。有殊异德。为诸群臣。所见奉敬。不以自己而放恣行。假使长大。承己身力。超诸臣下所论国位。菩萨如是。这初发意。过诸声闻缘觉之地。心性柔和。宽弘无极。是为菩萨七住之地。己慧自在。入七住菩萨。甚为深也。亦寂然也。至无行也。身口心也。逮得道业。不复重进。更求义也。何所望舍。不望不舍。乃为大道也

又问佛子。何谓菩萨所住道地也。乃至菩萨寂灭成就正真之行。答曰。已逮六住。能行斯法。乃致菩萨七住道地。一时发心。心数数念。辄致寂灭成就正行。不当谓之证于灭尽。以是之故。身口心行。不可思议。从其所作。此之谓也。若有菩萨。游于本际。而不取证。犹如佛子。时彼丈夫乘大舟船。入于大海。将船之师。工有方便。知水之宜。既行大海。不遭水难。如是佛子。菩萨立行。逮第七住。乘度无极道法之船。游行本际。而不取证。以逮如是圣慧势力。承三昧力。成就诸行。解觉道意。以大善权智慧之力。现生死门。游辄灭度。心性自然。已现其身。与眷属俱。往来围绕。在愦闹中。而常专精。逮致寂定。本愿之故。生在三界。不为世俗之所污染。出入进退。寂寞惔怕。善权光明。靡所不耀。无所燋然。逮致佛慧。退舍声闻缘觉之地。获佛藏界。现在魔界。已过四魔。游在其部。行度魔事。现在异学。一切诸邪。九十六种。六十二见。开化外异。令舍邪学。不违佛道。现在一切世间俗业。以等导利。度世之法。示在一切天龙鬼神。揵沓和。阿须伦。迦留罗。真陀罗。摩睺勒。人与非人。释梵四天王。随其习俗。庄严居服。清净好妙。其心不舍法乐之娱。斯慧如是。具足究畅菩萨道地。住于深远。难逮巍巍玄迥之法。如是供养。无量不可计数百千亿垓诸佛大圣。贡上衣食床卧之具。病瘦医药。所用为安。归命稽首斯等如来。奉受诸佛之道化。过众声闻缘觉法。独步无侣所问以时

又彼菩萨。用摄众生。法忍清净。遂转显耀。其善德本。无央数亿百千垓劫。乃复益茂。清净赫盛。犹如佛子。而有琦珍。于众宝中。光独明昭。巍巍无侣。如是佛子。菩萨住斯妙法难逮开士道业。以是德本。逮成善权智度无极。遂更名显成无上道。声闻缘觉。所不能逮。犹如佛子日之弘光。月之台宫。光明所照。普遍天下。皆使丰熟。亦能干燥污泥之地。日月之光。亦无蔽碍。莫不能通利。如是佛子。菩萨住斯玄妙难逮开士道业。其功德本无能逮者。德转巍巍。皆化一切声闻缘觉。令怀羞耻。除众尘劳。使性清净。是为佛子菩萨大士玄妙难逮第七道住。菩萨大士。若成七住。益得自在。若为天王。以随时慧。诸所兴立。行精进业。若行布施。爱敬仁慈。有所劝利。等惠利义。心常念佛。未曾忘舍。乃至普慧。一智愍智。心初不念何时。不逮成佛最正觉。处众生中。而最圣尊。导利众生。示一切智。发心之顷。如是比像。精进超绝。一时须臾。逮致百千亿兆垓三昧正受。睹诸菩萨。亿百千垓眷属围绕。以斯誓力。承于菩萨。所显殊特。因显神变。莫能称计。以若干亿百千垓劫。所修德义不可限量。时金刚藏。说是法已。重欲散义。即说偈曰

  玄妙之圣慧　　顺第一句义
  心了第六住　　谨顺己身行
  勤修于道教　　应善权智慧
  辄善逮入尊　　第七之道地
  遵空无相愿　　志行慈愍哀
  若奉行供养　　诸佛之道法
  晓知众圣慧　　于德力无厌
  由是行之故　　入第七道地
  而在于三界　　大乱中寂静
  消灭诸群黎　　寂凝尘劳炎
  如影照幻化　　在梦因行法
  以入第七住　　显示愍伤业
  严净佛土空　　世性无有想
  备悉最胜相　　舍于动摇法
  以致妙音响　　除众生瑕秽
  思惟慧本空　　最胜等导利
  以修行此法　　逮致斯显明
  通在殊胜地　　为众生所乐
  已住于是地　　众生行无量
  选观安住法　　数察不可限
  若干无数国　　众念想各异
  志性坏笃信　　心行若干品
  宣布三乘教　　导利等无量
  吾等皆当进　　诵读化斯党
  如是等慧心　　逮致殊妙道
  威仪有四事　　遵善权智慧
  心念一切顷　　逮护道功勋
  则能具足此　　十度无极业
  若以发意念　　是施劝众生
  戒灭众尘劳　　忍无所思念
  精进勤遵修　　转上增行业
  道不可动摇　　慧功德立意
  无所从生忍　　离垢慧圣尊
  愿劝助善权　　永无复狐疑
  周旋有势力　　以圣明普济
  道功勋如是　　一切随时授
  先行如是着　　名显以具足
  拔去心之垢　　断绝斗讼源
  等四等奉道　　造立第五业
  无起不分别　　乃长成第六
  是逮第七住　　彼成时功勋
  能遵若干行　　誓愿不可计
  用何等之故　　受此圣慧业
  因逮第八住　　一切悉清净
  玄微行难逮　　慧无无央数
  犹入第二国　　超越于中间
  修行七住法　　无著如锭燎
  若住于道义　　勇猛越一切
  得入第八住　　前乃圣慧地
  以越心念境　　住在慧之业
  在梵天常观　　不倚世民间
  贤圣行如是　　无著犹莲华
  住是若干品　　越度众尘劳
  此无尘劳行　　亦无所尽灭
  如是至道住　　无尘劳秽行
  最胜幻无本　　以慧消灭瑕
  于世若干品　　工匠所修业
  明达是一切　　化住世尊教
  一心为神通　　咨受奉行力
  遵御若干品　　增进三品定
  超越诸声闻　　缘觉行如是
  其住第七业　　修菩萨之行
  住本心性行　　致此真慧明
  成就诸圣子　　犹长养道力
  遂增精勤行　　得入深微妙
  心归趣灭尽　　亦不造取证
  犹如入大海　　而住舟船前
  观见一切水　　不增亦不减
  若能勤受行　　殊胜权智慧
  一切众生类　　不能限德藏
  供养亿载佛　　益更净道业
  犹若干璎珞　　无央数珍宝
  贤明住此行　　殊胜智慧光
  消竭爱欲源　　亦如月盛耀
  已入住此地　　自在为圣王
  造修最道义　　宣布慧果实
  而发意之顷　　强治精进力
  见佛诸佛千　　亿百之垓数
  善修顺己身　　普见诸十方
  加增在至愿　　功勋尊无限
  普世难可了　　自由行道缘
  是为第七住　　严净善权慧

诸菩萨众位尊。神妙巍巍。无量天龙。无数人民。闻其所说。莫不欢喜。供养安住华香幢幡。杂成捣香。珍宝衣服。伫立众盖不可称载。雨诸璎珞。诸天在上。宣扬妙声柔软之音。自然演畅美柔和声。以奉众祐及诸佛子。咨嗟能仁世尊无量。皆见至圣人中之上。睹佛境界。愍伤众生。其音若雨。布大雷响。伎乐箫成。演若干声。诸佛无限亿百千垓。帝王国土。亦如恒沙。供养诸佛。刹土无侣。最为豪富。威力能化。入一毛孔。诸佛班宣离垢无穷之法。如演一毛。岂复难乎。国土处所。及四方域。若干种品。泉源大海。亿载铁围及须弥山。皆自然现。无所逼迮。悉入毛孔。在中自恣。地狱饿鬼。及与畜生。诸天人民。鬼神众魅。阿须伦。罪福各异。俱来会在。诸佛境界。游一切国。在诸郡县。自然成现尊妙法轮。讲说柔软。安住音响。众生心念。如所修行。群黎若干。其身各异。众祐国土。群黎有身。所在成体。生天人间。各各别异。一切如佛所宣法教。消除微想众垢之秽。兴怀道念。广大佛土。诸佛神足。如是变异。一切世人。称不能畅。诸佛如是道慧无穷。磬畅柔和微妙之音。时来众会。寂然欢喜。咸共观敬。最殊特圣。以智众会。寂寞静思。犹如月蚀。其光还复。唯复欲闻第八住也。愿时演之。行者所入

    渐备经不动住品第八

金刚藏曰。唯听佛子。菩萨大士。若能畅成第七住。以慕谛志求清净之业善权智慧。谨顺众行。乐在所施。无极弘誓。依承如来所建立旨。蒙宿德本。逮得势力。如来十力。四无所畏。思念正觉。十八不共。诸佛之法。志性仁和。念其清净。功德圣慧。威势转上。兴大悲哀。愍众生界。不舍法乐。通入无量一切诸法。至无所生。而无有相。不有合成。不失慧明。无所究畅。亦无所灭。然无所有。等入元本。转上得度。普除一切心念识想。等摄志性本净惶慌。因是超越。应时逮得无所从生法忍。此之谓也。菩萨以逮如是法忍。这得是住菩萨地。不可倾动。获致菩萨。深要之行难知玄妙。无能坏者。消一切想。皆摄众念。而究竟矣。无量无侣。一切声闻缘觉之众。永不能逮其寂寞事。以淳淑矣。自然现哉。犹如佛子神足比丘。所念自在。稍渐进前。乃至寂灭三昧正受。悉除一切所欲妄想。菩萨如是。适逮此住。舍众俗业。致无业财至真之法。离身口意之所习乐。住于寂寞。犹如佛子假使在梦。逮大功德。即自知之。因在于彼大精进力。普以越度。逮则解觉。彼修方便。夙夜思念。以除好乐。如是佛子。菩萨大士。无极精进。适逮此已。住菩萨地。如是不动。远一切业。稍习诸宜。于行无二。又等修行。无所亲近。犹如佛子。若生梵天。住于梵宫。不着欲行。亦无尘劳。菩萨如是。住此道地。其心普游诸所习行。虽在是行不以是行。有所染污彼意晓了所在作行。菩萨之行。在泥洹行。不以为行。何况俗行。菩萨大士。以入是地本愿力故。至如来觉无极大圣。是法典门。道如来法。造立圣慧。如是辞曰。善哉善哉。族姓子。是诸正士第一法忍。归于佛法。又族姓子。佛十种力。四无所畏。佛法尊位。仁则未有。以是勤行。慕求精进。慎莫违失。是道忍门。为众生故。而尊修行。又族姓子。仁宁逮此。若斯寂行。而愚凡夫。失不寂静。习在无数尘劳之行。为若干想之所危害。又族姓子。众生设忆念本宿愿。哀念在冥。故为求道。奉行静寞不可思议圣慧道门。终不懈废。又族姓子。是诸法本。从法发来。兴成如来。以立如来。住在法界。如来至真。不别行是。一切声闻及与缘觉。不能逮至斯不相法。又族姓子。且观我身不可称限慧莫能论。土不可量。明不可量。道场不可量。音响清净亦不可量。以是之故。仁慈所行。因显发业。又族姓子。所可定言。光明之谓。云一切法。无所想念。乃为光明。诸族姓子。法明若斯。如来所行。行无边际。眷属无底。斯等所入。从发行来。巍巍如是。又族姓子。仁且观此十方无量诸佛国土众生无限。分别经典。而不可计。普入一切。言行相应。如是佛子。佛天中天。菩萨行是。如斯比类。不可限量导利道门。用开化众。若有菩萨。分别解说无量圣慧。具足成就导众之业。诸佛子等。吾嘱累汝。假使诸佛。化此菩萨。入众生中导利道门。由是之故。致于灭。度众生之事。自然舒畅。诸佛世尊。劝化于斯。诸菩萨法。无量慧业。乃令一时。所导利众。因其圣业。以为元首。从初发意。计七住竟。合集方便。由此功勋。百倍千倍。万倍巨亿万倍。终不与等。无以为喻。所以者何。以是宿命。一身导众。致导利业。逮得此住。诱进平等诸菩萨行。分别身事。行力成就。宣畅布散无量音声正法之教。修慧无量。导利无量。所生之处。严净无量。诸佛国土。开化无量。又众生类。供养遵奉。无量诸佛。发觉无量。诸法道门。神通之力。不可限量。剖判开化众生厄难。广令无量。众会道场。所可游居。亦不可量。持身口意。积累菩萨一切要行。亦不可量。犹如佛子大舶舟船。欲入大海。安无放逸。庠序进前。致无量宝珍琦瑰异。适到大海。望风举帆。其风和顺。一日之中。超越大海。一切财宝所得利入无央数藏。皆为充满。用不可尽。菩萨如是。积成无极广大德本。合集大乘逮菩萨行道法慧海。一时须臾。致圣明财无极道宝。入一切智。前宿所积世俗财宝。不可比之。思惟计校百劫千劫。万劫无央数劫。不以为喻。又佛子。菩萨若立第八道地。遵大善权智度无极。宣布劝化。无财业义。若菩萨。解奉一切智。遍知十方诸成佛土。亦复分别坏散佛土。若以睹知世界散坏。若世合成。用何因故世界散坏。以何缘故世界合成。悉能见知。地种少。地种多。地种有限。地种无量。悉别知之。水种火种风种。亦复如是。皆晓了知多少大小。有限无限。诸尘微妙。分别所在。诸尘限数。随时悉解。若干世界。有若干种。无限众尘微妙难了。普悉知别。若干品尘。自然合成。诸佛世界所有尘限。悉能知之。众生之数。国土形数。其身长短。大小。悉能知之。地狱处所。[狂-王+禽]兽饿鬼性行。何因堕此。皆知所行多少。诸尘合数。阿须伦行。诸天所居。世人所处。悉能知之。合会教化。欲界合散。色界无色界合散。皆悉知之。少多大小。有限无限。而悉知之。游居三界取舍之义。开化众生。彼能成就。晓了众生诸身方便。诸身形像。所在之处。悉晓明之。所行生处。诸佛所游。如众生类。所生安居。身所积行。随其身行。而建立之。己身国土。随立己身。其意无尽。己身建立。无身之身。己身国身。罪福之身。乃须建立。罪福报身。建立己身。无尽身意。无身之身。己身无尽。众生类身。国土身。缘报应身。声闻身。缘觉身。菩萨身。如来圣慧身。法身。随时建立。显此诸身。悉解众生。罪福身。报应身。尘劳身。色身无色身。国土身。多少大小。秽浊清净。广大无量。减损平正。导利平等。讲说报应。皆悉知之。罪福身行。所当获报。合散成别。亦复了之。声闻乘缘觉乘菩萨乘。所行业。合散所归。而悉知之。如来圣体。成最正觉。所誓愿身。及灭度身。所建立身。色像相好。所庄严身。其行者身。可意身。自大身。谦恪身。功德身。圣慧身。报应身。谨慎行业圣慧之身。所归度脱。皆悉知之。法身平等无身之身。不可限量一切普入。有身无身靡不分别。一一畅解。其身以逮如是行业。致寿自在。心得由己用度所为。自恣无难。所行无拘。所生从己。本愿所致。笃信之故。神足之恩。蒙圣慧行。因法所将。而逮致此。以是菩萨十事自在。适得自在。成无量慧明不可思弘普之圣。圣无有侣。以入如是。究竟永在无所生身。转所习行。永无生故以转诸行。慧为元首习转身行。以慧为首转口习行。取要言之。智度无极。为大锭光。大哀为首。分别晓了善权方便。不弃至愿。为诸如来威神所立。不应休息。其慧以应一切众生。游于无际诸佛世界。宣义散结。佛子。又省菩萨常修平等所逮道住。不可动摇。积累一切诸佛法典。身口意行转增进业。以获此住。其力志性。则辄坚。住。皆以消除一切尘劳。心怀仁和。力势坚强。在于元首。恣化群生大哀之力。所可建立。用众生故。无所望舍。益加建立。大慈之力。将护一切众生之类。总持要力。而得坚住不舍众生。其誓愿力。而谛得住一切佛法。选择分别。善谛建立。神通之力住无限世。于诸行本。拥护一切。众生之类。坚住愿力。遵习一切菩萨道业。而无所舍。度无极力。其行坚住。合集一切诸佛经典。正住如来所建立力。成就正觉一切敏知。以入此行。如是力势。普现一切神变无穷。辄往生于一切所趣。金刚藏曰。是为佛子诸菩萨业住于慧地。而不可动。是谓无侣。亦复号曰不退转地。慧不回还。则谓难当一切众生。所不能逮。则童真地。为无所生为所生地。所愿自在为灭具地。无所造作究竟之地。积累真慧则无为地。善修志愿为建立地。度无所作为无财业。宿世所行。众苦消去。邪以降伏。如是佛子。菩萨大士。以入佛种承佛功勋威神远照由归如来威仪至业佛境界门。常为如来之所建立。得入释梵四天王宫。金刚力士。常随侍后。逮致定力。其身无限。降伏色藏。散无量结。以皆永离诸身行力。具威无极。大神通力。所行报应。而得自在。无限定意。受莂无量。自恣由己。而无所碍。如其淳淑。觉度众生。所示现义。以入是行。得入道场。无极大慧。以行大慧神通之业。常演大圣智慧光明。施与章句。无挂碍界。分别世界十方国土所宣章句。现一切业功勋之德。发心自在。而谛思惟。解去来今。回转一切众魔径路。下于圣慧。游入如来。州郡境界。无际国土。所处讲堂。奉菩萨行。其所诱进。无能退转。以故名曰入无动地。金刚藏曰。是故佛子。菩萨逮得无动转地。常在无际。见诸如来不可称限。未曾违远。彼行究竟。成三昧定。威力所入。见佛供养。奉事归命。终不忘舍。于一一劫中一一世界。所见讲堂。各现诸佛。咸各供养无央数亿百千垓佛。一切施安。稽首归命。以礼如来。晓了世界。以为元首。慕导道明启受法教。重复加增。逮佛灭度。行无等侣。巍巍超绝。与众殊异。咨受世界。讲问宣传。遵无央数亿百千垓所积德本。转进显耀。犹如佛子。此阎浮利。上明月珠。又其价直。一阎浮提。以用着颈。为无等伦。一切天下人民之众。所著璎珞。无能及者。如是佛子。菩萨住是不动转地。以此德本。成其大明。一切声闻。及缘觉众。所不能逮。及于七住菩萨行业。菩萨以入此道地者。承无极慧。消除众生一切尘劳。剖判圣慧微妙道门。犹如佛子。主于梵天。所行慈心。遍大千界。其光普照。菩萨大士。亦复如是。住此菩萨无动转地。照耀百千诸佛刹土满中尘数。光明悉周无量佛国。照尽一切众生尘劳。稍渐灭除心之毒垢。是为佛子。菩萨住是不动转行所宣平正。菩萨功德第八道地。弘普咨嗟。诸劫无际。不可究竟。菩萨所住。因为梵天大梵天王。主千世界。声闻缘觉。菩萨所行。真正莫能逮者。而度无极。分别世界。修无等伦。闻所讲说。所兴因缘。方便之业。布施敬爱。利人等利。一切救济。常思念佛。未曾违舍。众行具足。至一切智。专惟大道。以何修行。为众生尊。一切殊特。将顺普圣。覆护十方。发意之顷。遵如是像。勤奉精进一时须臾。逮具足成十千世界百千刹土。满中诸尘三昧正受。及见十千百千三千世界满中尘数诸菩萨等。眷属围绕。从是发愿菩萨力势。所誓殊特。靡不感动。智慧明了。不可称计。如是思之。亿百千垓不可限载行无量劫。功勋无底。无以为喻。时金刚藏菩萨大士。复欲重散分别此义。即说颂曰

  渐备七住地　　智净行善权
  谛将护导业　　结立无极愿
  积功而累德　　坚住人中上
  志乐于圣慧　　辄入第八住
  殖德大圣慧　　精进行慈愍
  其心无限量　　意念犹虚空
  闻法能晓了　　入大圣势力
  忍力无所生　　寂寞顺微妙
  所受无所起　　不生无有相
  不灭无所坏　　亦无所究畅
  处所为自然　　无本藏舍念
  已离心意性　　其思等如空
  斯忍以如是　　所行无放逸
  行深要感动　　逮致惔怕行
  众生无能解　　由闲居行业
  执持心所想　　晓了众行念
  其意立若斯　　心无有思想
  如比丘消灭　　逮得无所著
  心之所想念　　犹梦所见觉
  若梵天具足　　欲界亦如是
  安住本立愿　　数数而劝众
  是为第一忍　　得致阿惟颜
  我等慧玄迥　　势力意解法
  彼则无我所　　精进勤修行
  所可奉寂寞　　消一切爱网
  灭于大然炽　　世俗尘劳火
  自识本宿愿　　行愍哀众生
  以慧利造立　　用度脱黎庶
  常能尊此法　　住本无无想
  佛解一切住　　越声闻缘觉
  世间俗威势　　无及此十力
  唯智无能限　　三世无挂碍
  无等伦如是　　天人所奉敬
  合集以导化　　行无数慧门
  成就最胜法　　入无量彼岸
  前世行佛道　　假使顺随时
  如是致贤明　　逮入殊圣地
  一时普周遍　　至于十方界
  以致慧所归　　逮得诸神通
  犹如大海水　　诸天华神器
  心贪以永除　　得立慧道业
  选择诸刹土　　住在晓分别
  四种之境界　　离若干贪利
  微细及粗犷　　等入识解义
  一切三千界　　满中众尘数
  分别众生本　　四大所生身
  计数诸慕乐　　六趣限如是
  解散慧境界　　不可称限量
  慧剖判心意　　至于一切心
  彼修己身行　　故将导众生
  一切三千界　　周普若干色
  彻见众品形　　然在无限世
  犹如日周行　　在上虚空行
  已斯殿舍进　　光明普照耀
  御以本无慧　　在法界不动
  黎庶性清净　　道明所遍照
  如众生本性　　其身各所在
  显现一切众　　照化天世间
  己身得自在　　胜降无性行
  示现安住身　　庄严诸相好
  众生土如是　　从罪福受身
  若干种圣性　　成法之慧体
  虚无为身界　　受以平等业
  现神足诸变　　消黎庶众秽
  十力广自在　　因慧广无极
  造圣逮慧明　　兴发愍顺哀
  一切最胜教　　以法生道业
  谨慎护三事　　无动如须弥
  诸众祐号力　　柔士势无恚
  是士无回转　　众魔莫能当
  佛之所建立　　释梵咸奉敬
  其金刚力士　　以力势常侍
  于是土地处　　合德不可量
  亿百千劫中　　不能尽其限
  稽首归诸佛　　其亿数那术
  成就最上道　　犹严王者服
  极是道地处　　菩萨斯集会
  得为大梵天　　若干界功德
  宣布三乘业　　逮得无限侣
  慈心为清净　　光明慧消尘
  一时发心顷　　至百千佛土
  逮诸定意元　　如满刹土尘
  勇猛睹处所　　十方化众生
  所愿亦如是　　庄严尊无限
  此说取要言　　第八胜自在
  具足亿千劫　　皆不能尽极

说此第八住时。应时震动百亿佛土。佛之威神之所建立。不可思议功德巍巍。不可限量演妙光明。普现一切诸身形类。照诸国土。安诸众生。无央数千诸菩萨众。住于虚空。所供养具。超天上物。所贡上佛。玄绝殊特。大神妙天。与其眷属自在天人。亦咸悦豫。以若干品。而供养尊。奉事德海。诸天玉女。无数亿千。欢喜踊跃。诸根和悦。以妙伎乐。鼓天倡乐。供养大圣。斯诸伎乐。乐大神圣。出如是辈百千音声。其响柔和。寂寞惔怕。消诸患厌。离众秽垢。舍于土地。所行至真。而有卓然。用众生故。游到十方。大通所显。现最上行。志若虚空。心亦如之。天中之尊。人中为上。觉了最明。玄妙境界。无底功勋。十方严净。奉事道门。众祐诸子。以道显示。不可限量佛之功勋。遵行圣慧。不慕径迹。于一刹土而不动移。皆周诸国无有尘垢。遍辄愍伤众生之类。为之元首。灭一切向。无所想念。所言畅音。辞百千种。若有闻教。不肖众生。心在下劣。其意自归。彼若闻声。至圣所现。随其本行。而开化之。若有众生。诸根明达。心好因缘。无所志乐。为现离垢慧明之义。若有众生。心抱愍哀。意怀慈仁。佛在彼处。勤示正行。若有众生。志在上尊。意乐斯法。在彼显示无量佛身。因其化现。犹如幻师。所周旋处。导无央数亿千垓身。佛子如是。乐于慧幻。现一切行离诸所有。如是音声。其数百千。班宣柔软。仁和之向。天人玉女。在世归伏。默然乐寂。众会欣豫。歌颂安住。功勋德称。巍巍无量。不可讲论。说此菩萨。第八道地。奉行正法。通至大乘

    渐备经善哉意住品第九

金刚藏曰。且听佛子。菩萨大士。诸佛慧行。无量如是。转复增加。游于寂寞。志在脱门。诸如来慧。长益至德。又以仁意。所可修行。如来秘密。因可游入斯大道慧不可思议选择至要总持清净三昧正受。放舍众非清净之业。导利一切。成大神通。弘广殊远。分别世界。教令黎庶。只行独。步。十力无畏。诸佛之法。十八不共。而无等伦。严治道本。如来至真。转于法轮归趣境土。建立大哀。住于大愿。不舍十方。入于菩萨第九道地。住此地已。有不决行。善恶之心。知如审谛。供养经典。奉事至真。以及有漏无漏之法。各顺俗法度世之法。修行所思。不可思议。遵承究竟。不决了法。顺从声闻缘觉之法。奉行菩萨。敬重斯道。要誓随时如来道地。以时归至。有为之法。亲近志在无为之法。知如审谛。如是慧明。觉了所归。如审解知众生心行。所可取舍。尘劳之垢。所受祸福。摄取诸根所行。笃信诸种归趣心性众结造行之处。所生受处所居止处。决了三聚。业所至奏。知如审谛。察众生心。所行是非。若干品心。其心须臾而有进退。若合若散。其心无身。心不可限。一切普兴。心为显耀。其心若尘。若无尘劳。若有缚心。及与解心。亦如幻化晓了其心。所归住止因缘进退。又其尘劳。玄绝远游。疗治当来。等类无业。诸结因缘。所游居处。心之合会。在一处所。若有别离。有所生处。周旋现在。进止行来。分别三界恩爱无明诸见病痛自大愚痴。无极罪殃。断截灭除。三藏之珍。晓了审知。入至计常。八万四千。众尘劳行。未决罪福善不善义。教告无明。使乱心党。令无异业。思惟众祐。以致报应。积聚众利。所亲造行。不失果实。所报无报。黑冥清明。无闇结白。如是辞语。所行缘报。而有齐限。罪福田地。则无有量。贤圣处世。所行治事。现在罪福。当来所习。方可更历。解乘所趣。不了所趣。晓解分别方便随时。常等识知八万四千。若干品罪。知审所由所趣。彼达诸根柔劣中间明了之本。取要言之。随众生本。前世宿命。毁坏之事。不坏之业。微妙中间。下劣之行。尘劳伴党。无有财业。从本行心。能以决了。若不决了开化真厚。诸根罗网。分别退转。摄取众想。诸相豪劣。周旋往来。进退无回。解畅三世。远游无穷。独步无侣。于若干品。常以平等。八万四千若干种根。悉能知之。取要言之。其笃信乐。柔劣中间。诸根明达。常随诸根八万四千。所坏笃信。而悉畅了。若干种品诸众生行。其界柔劣。中间明达。随从诸根八万四千。诸种四大。上中下心。性行善恶。解畅诸根之所归趣。彼心性行。心意伴侣。志造[仁-二+般]党。其心合会。或有别离。玄迥远游。若有自大。无有自大。其意调顺。无有众厌。亦不懈废。皆承一心脱门三昧正受神通之宜。而无合会。缚着三界。愿至实心。不习众行。习入道门。无言教矣。不倚伴党。无财业事。无异无侣。修治道门。审谛知正。众生之行。有若干品所生处行。其行而住。生地狱饿鬼畜生之中。阿须伦诸天。人民之所归处。色无色所生处。想无想所生处。悉了知之。罪福报由恩爱情欲。无明闇冥精神种类。还复回生。名色为侣。用无道业。生死愚騃。亲近恩好。则致贪欲。慕求情爱。若不慕荣。众生所乐。于三界趣。意怀至实。无所伤害。悉审谛知志行所居。所当行者。如来归趣系习所在。从众生行。各由罪福。而习尘劳。善恶未宣。本末所作。转轮无际。复转回旋。归本所行。未有远游难断难断。欲拔淫尘。贪嫉虚事。不可卒清。心明开达。乃能超出。于所作事。至无所有。悉审谛知。于众生行。究决不决。志在邪业。驰趣反见。愚惑之业。在于正见。定在正业。除众恐畏。莫不究竟。又有五逆中间之难。悉以究畅五根达趣正真之行。以舍恐畏。及无究竟。晓了邪灭。及正寂灭。并所犯事。令趣寂业。还无所归。而堕邪业。回行退转。导示贤圣无上正道。若不决了。随时散结。将护业耶。当所宣布。悉当知谛。是为佛子若归此慧菩萨大士则得安立善哉意地菩萨之住。已住此地。皆能晓了一切众生。如是行业。随其积行。应当解脱而开化之。能明众生。应时教导。知以劝诱声闻缘觉。化诸菩萨说如来地。从其众生。而为说法。导利度脱。如其性行。从本根元。应当解脱而为说法。因其所行。更历本末。而为开化。如所乘法。修思脱门。因其脱门。班宣道法。住此道地。睹大法师之所兴隆。拥护如来无极法藏。彼若往诣法师所。咨入无量。晓了圣慧。奉行宣布。四分别辩。菩萨所行。随其说法。彼常修行。无所破坏。菩萨大士。四分别辩。游不退转。何谓为四。一曰分别法。二曰晓了义。三曰顺次第。四曰解辩才。彼所谓言分别法者。明宣诸法自然之相。晓了义者。能解畅法之所归趣。顺次第者。说无所坏剖判诸法深远之慧。解辩才者。无所结缚。知法无断。分别辩法。晓了法者。谓法自然。自然之身。晓了义者。知以照耀。咸归经典。顺次第者。畅一切法。当可讲宣无能断绝。分别辩者。如其道教。无所希望。演布无际。解畅法者。达现在法。所宣归趣。晓了义者。知去来法报应之理。顺次第者。说解一切去来今法。无所破坏。分别辩者。一一所说。而无二心无有边际。振法光明。解畅法音。能识诸法。剖判众事。晓了义者。分别诸义。靡不蒙慈。顺次第者。从众生音言辞远近。而为说法。分别辩者。观察一切心性所行。因为演经。解畅法者。晓知方便。明散法慧。不坏众善。晓了义者。明通本无住无二慧。而为黎元。各各了之。顺次第者。而讲说业。圣慧财富。不可破坏。分别辩者。解畅众理随时之义。晓了本末。解畅法者。知一切法其元为一。失其本源。随流生死轮转无际。晓了义者。则能越度五阴四大。又十八种诸衰众入。方便解脱。明十二因缘。悉无端绪。顺次第者。宣说一切众生之元。五趣周旋。志性和雅。音声柔软。闻者普受。分别辩者。演要言教。其明转增。而无边际。光明远照。去众愚冥。莫不蒙耀。解畅法者。导利一品。无有若干菩萨大士。兴无极慈。立无尽哀。开发大乘。晓了义者。分别诸乘。度众齐限。弘迥之行。坦然无侣。独步众会。顺次第者。班宣一切所志诸乘。上中下学。无所破坏。稍引诱进。入于大道。分别辩者。而为一乘无有边际。宣布正法。炎照三界苦恼之厄。除去阴盖。逮致三昧。解畅法者。奉诸菩萨圣慧之业。遵修法行。道明超越。巍巍无量。晓了义者。敷演十住所处本末。开解学者各得其所。不失志行。得度世俗靡所不通。顺次第者。宣布法禁。各从慕求。婉娈道教。无所破坏。分别辩者。宣一切行。而无边际。讲说本业。至成正真。不在二乘声闻缘觉。解畅法者。心自然达。一切如来。皆为一佛。诸力无量。觉了此义。由是之故。因转法轮。至一切智。而有所度。晓了义者。又能知识若干种类。制住正真。须臾分别。当所归趣。道俗是非。靡不宣布。顺次第者。如其正觉。剖判言说。观其根本。上中下行。心之深浅。而开化之。分别辩者。所班宣法。一一章句。演若干义慧无边际。不可断绝。饱满饥虚。解畅法者。普请如来。所布言诲。一切十力。及无所畏。诸佛之法。十八不共。修于大哀。而转法轮。畅达无穷一切敏慧。晓了义者识知众生八万四千若干品行。从其志性。察彼根源。随如信乐。宣如来音。而为散结。顺次第者。于一切行。无所破坏。为师子吼。出如来音。八部之声。闻于十方。彻睹无表。分别辩者。畅如来慧威神光明。消除众冥闇昧盲塞。自以己行道场之力。随其信乐。而开化之。各令得所。金刚藏曰。如是佛子。第九菩萨。立九住者。其惠德本。巍巍如是。辩才若兹。逮得如来无极道藏。为大法师。造立义器。为义之君。获致义句。玄妙总持。摄救三界。法主总持。取要言之。圣慧神通而用拔济。照明总持照于十方。善意总持摄一切意。如地总持行犹虚空。威神难逮帝主总持之要无极法门。所向总持所游无量。回转总持周旋往来也。逮若干种方便总持。如是等类具足备悉。逮十不可计百千总持。音声随宜无所不达所分别门不可限量。班宣经典莫能称载。如是总持不可限载正法道门。闻不可计诸佛世尊现身演法闻之不忘。所听班宣不可讲论。在于一一如来之所咨受讽诵十不可计百千总持。如一如来所可开化。无有边限如来至真无上之法。亦复如是等无有异。彼稽首顷转复增加。于无央数至真等正觉。受道法门。声闻缘觉不能称载。所修博闻受音总持。逮此总持者。建立恩施。以德总持。于百千劫。逮如是持。获致辩才。而以建立。如斯巍巍。法与圣众。若合会时。周满一切三千大千世界随众生心所应当化。而为说法。处于法座。而于法座承如来旨。逮得十住阿惟颜地。于余一切自在自在。尊无有侣。致于光明靡所不耀。处于法座。须臾之间。适发意顷。则以一音。演若干向。普告众会。一时之间。光从口出。其诸毛孔。宣一切音。演布道化。无所不解。照于三千大千世界及与有色无色之界。咸演法音。尔时于彼大千世界。所在众生。一时皆来。难问义理。各各讲说。质无数事。不再重启。各得开解。彼时菩萨。一时须臾。悉受众向。所宣诸音。以一言教。普告一切。取要言之。遍二三千大千世界。三四五十。二十五十。乃至周百三千大千。不可称计大千世界。光作法事。建立如来威神圣旨。常以应时。为诸众生。兴作佛事。发起得立。转复增进。如是圣慧。受振光明。而行精进。假使一一从诸毛孔。如无边际诸佛世界满中众尘。睹若干数不可限量诸佛国土。及其众会。集在道场。班宣经典。一一如来。与无央数众生之类。若干群黎。而为散结。一一众生。心性所怀。不可称载。心各各异。劝导利法。因开化之。如一如来之所度脱。一切如来。亦复如是等无有异。犹一毛孔。一切亦然。悉演法音。吾等于学亦当如之。广然其志。思方等谊。将导不逮。一切如来。一时之间。普现其身。悉受法明。斯皆一音。恣其所乐。顺所称叹。诸众生会。充满道场。欲听法者。具足备悉。吾等于彼。亦当复然。智慧光明。辩才通彻。清净之业。一时须臾。悦解众生。其身周旋。若干世界。所有众生。以逮此住菩萨道地。夙夜转进。所念无异。入佛道行。逮得如来平等之教。致于菩萨深妙脱门。以入斯惠。常见诸佛。未曾违离。一一劫中。睹无央数亿百千垓诸如来尊。供养奉事。问诸如来。咨受所演。执持经典。而班宣之。其功德本。遂更滋茂。超无等侣。犹如佛子工师绝伎。能成璎珞。治文饰好。以用进上转轮圣王。尊玉女宝。系在颈着。巍巍无比。晃然炜炜。暮处一切高台楼上。普照天下诸四方域。众生璎珞。掩蔽不现。以独显耀。如是佛子菩萨大士。逮得行此。善哉意开士道住。其功德本。转更茂盛。超无等伦。过诸声闻缘觉之乘。越初发意七八住表。其德本明。消灭众生诸尘劳心。咸能昭之。从是得恩。回恶就善。舍俗入道。犹如佛子。大梵天光。周于一切三千国土。明无不至。众人蒙耀。菩萨如是。住此善哉开士道地。一切德本光明之耀。普照众生。圣明远达。以道法耀。消众冥尘。咸令一切回俗就道。是为佛子诸菩萨大士。名曰善哉意第九道住平等之教玄旷之业。宣讲其德。无央数劫不可究竟。无能穷极。菩萨大士。以住此地。若为梵天。若大梵王。居三千世界。而得自在。造立声闻缘觉之法菩萨之行。讲度无极。明无有侣。咨问众生志性本末。所谓道业。布施惠人。爱敬仁和。利人饶益。等劝财共。以是四恩。普济一切。以斯积德。常感念佛。心不违远。乃至备悉。成一切智。思念不忘。云何逮致于诸众生最尊无极。至于普圣。将导不逮。发意之顷。如是色像。勤修精进。须臾一时。具足充备十无央数百千佛土满中诸尘定意正受。见诸菩萨。亦如十不可计诸佛国土尘数大士眷属集会。以上妙愿道力所致。诸菩萨等所愿殊特。感动变化。无能称载。至不可计亿百千垓无限之劫。皆不可议。时金刚藏。欲广此义。重散其意。即说颂曰

  斯力不可量　　奉行佛要道
  微妙慧第一　　众生难晓了
  如是处秘藏　　众祐面执持
  为众生之故　　得入第九住
  以是逮总持　　三昧无极尊
  广普神通业　　又周遍国土
  决解圣慧力　　最胜现处所
  志愿心愍哀　　正住入第九
  以通此道地　　上胜摄持藏
  真妙之法要　　不分别义德
  其在有漏行　　及世贤圣身
  斯心不可议　　尊觉了至义
  分别畅诸法　　所思惟究竟
  成就三乘事　　称量计所作
  有为若无为　　体解所当行
  二事俱造有　　顺世而随入
  以入如是慧　　意微妙殊特
  摄受众生心　　思求其本末
  心若干犹画　　远移而回转
  其神识无限　　晃耀皆遍入
  诸尘劳之门　　伴侣难疗治
  众结受处所　　周旋亲近患
  所作若干种　　入于剖判业
  等下无果报　　因缘以消灭
  有入明达根　　软劣及中间
  坏除诸过去　　下通当来义
  笃信无央数　　清净不清净
  通周八万行　　又边四千事
  若入于诸种　　成騃邪见尘
  由是受驰骋　　无边不可断
  其心之结缚　　党侣而俱游
  斯心等思惟　　缚束无穷竟
  志性之径路　　众结犹覆月
  永无有处所　　亦不止宿居
  以故会难化　　人界不反源
  以金刚断截　　其道而无异
  分部随行入　　生在六趣处
  欲情为爱润　　无明罪福田
  神识为下种　　造行为名色
  在于三界中　　所游无边际
  至于天坐处　　随尘劳心行
  一切遍周游　　故复还生死
  众生处三品　　故使有往反
  诸邪见之火　　便种神识迹
  以至如斯行　　因住此道地
  从众生心性　　诸根顺应解
  为其说经法　　班宣分别事
  剖判斯义理　　善权真辩才
  若诣法师所　　辄以到所居
  言说无所著　　犹如须弥山
  雨为柔软泽　　甘露普润众
  觉意之根力　　充满犹如海
  晓了善义慧　　解法亦如是
  一切皆灭尽　　逮得至辩才
  获明无央数　　一万诸总持
  以执众法要　　如雨于大海
  如是有总持　　逮清净三昧
  一时见无数　　诸佛亿百千
  以闻于法宝　　数数而班宣
  言辞畅清白　　自然妙音声
  须臾发意顷　　知三千世界
  众会一黎庶　　若干种所念
  可悦一切众　　如其心诸根
  所入等亦如　　四方域大海
  其德复超此　　总要致精进
  思惟如恒沙　　实为不可限
  安住唯说法　　化凡夫众生
  闻之寻受持　　犹下种于地
  假使诸众生　　处在十方界
  普令此众生　　悉会坐一处
  斯等性行念　　皆能周遍至
  则能一音声　　普以充饱足
  人中尊住斯　　最上之法王
  转进悉国土　　成就世尊子
  恒以夙夜宁　　得胜合志愿
  住在深妙寂　　勇猛慧脱门
  奉事专供养　　礼诸佛亿垓
  成如道巍巍　　庄严如轮转
  光耀消尘劳　　所受演威明
  犹如梵天光　　照三千世界
  功勋住于斯　　持无极梵天
  佛分别说解　　造立于三乘
  有所勤修行　　愍哀于群黎
  以入一切智　　逮得圣慧德
  国土不可计　　乃至王舍城
  威势一时思　　三昧遍十方
  睹见十方佛　　众祐音柔软
  兴造微妙愿　　其心无限际
  是为第九住　　深微妙难解
  安住已自演　　大乘之行业

净居诸天。亿载来会闻如是行无上正教。住于虚空。心怀踊跃。恭敬谦下。承事安住。诸菩萨众。无量亿垓。处于虚无。心中欣豫。雨众华香。可悦无限。炙然众生尘劳之秽。自在天王。甚大欢然。住于其上。亿千众俱。恭恪之心。散诸妙衣。梵天等。寂然琦珍。一心自归。诸玉女众。无数悦颜。鼓诸伎乐。亿百千垓。亦复作礼。一切普演如是像音。众祐眷属。坐遍佛国。其光明耀。皆照诸刹。诸身亿载。若干柔软。周遍法界。靡不悉达。如来至真。一毛光耀。其光晃然。灭众生尘。尚可数尽。刹土之尘。此会人数。不可称计。有时佛身。微妙诸相。而以咸睹。诸转轮王。复游他国。所行最上。甚好巍巍。见天人圣诸大神尊。处兜术天。现下母胎。复以出生。虽在胎中。现无数亿国。适生堕地。现其佛土。导师本愿。用众生故而复出家。得成佛道。为最正觉。转于法轮。现诸佛土。无数亿载。犹如幻师。善学术咒。将顺寿命。现无数术。世尊如是。修学智慧。用众生故。而复出家。空无寂寞。本净无相。诸法平等。犹如虚空。佛之教戒。最利本无。示现殊胜。佛之游居。诸安住行。皆为自然。愍哀众生。逮成经典。诸相之相。见平等相一切诸法。第一无相诸众祐义。圣慧所从。悉弃众相。有想无想所行。等解诸行。速得成就众人之上。如是音响。无数亿千。宣仁和声。在世降伏众魔天女。以知众会。至真寂寞。如月盛猛。照于天下。又金刚藏。演若干品时。诸佛子。修于大乘十事之业。当可施行。诸室宅行。功勋之业。见瑞应来。心怀悦豫。上人圣慧。咸悉歌咏

渐备经卷第四渐备一切智德经卷第五

        西晋月支三藏竺法护译

    金刚藏问菩萨住品第十

金刚藏问菩萨大士。谓解脱月菩萨。于是佛子菩萨大士。其圣慧意。巍巍无量。如是行业。乃至第九。严净道地。具足清净鲜明之法。而无边际。积功累德。每生自克。无益众生。以何方便。救济三界。善谛摄受。无极慧德。其无尽哀。所入弘广。靡不周流。分别世界。明了无边。入众生界。寂寞回旋。终而复始。开第一藏如来道业。所思惟念。力无所畏。诸佛经典。空无无量。及一切敏慧。具足成得阿惟颜。此之谓也。又诸佛子。入如是圣菩萨之业。近阿惟颜。适住此已有三昧名其号无垢。菩萨亲具宣布法界。菩萨道场。名庄严净。名巨海藏。又名海印。名广如虚空。名积一切法自然。名众生心行。如是等类。得近百千阿僧祇定意正法。适能逮得此诸定意。而以正受亲众善德三昧定。施众方便。以斯因缘。如是定意。乃为究畅一切敏智。而有殊特。尔乃名近阿惟颜菩萨三昧。这得近已。以是三昧。十三千土。而自然生百千无极无穷奇宝。清净莲华。一切之宅。自然道宝。以得超越一切法界。奉行道义至真正法。具足度世众德之本。究竟成就。达玄自然。又其法界。善修清净。演圣光明。其茎甚大。琉璃明月珠合。以越诸天。无量旃檀。珍宝相挍。无极马瑙。紫磨真金。生为华叶。其明光光。不可计限。莲华照耀。皆以众宝。而合成之。其上虚空。琦珍之缦。化交露帐。具足充满十三千大千之土。满中尘众。不可称计。百千莲华。罗列周遍十方虚空。其香甘美。勋诸菩萨大士身形。备一切智。若逮致此阿惟颜住三昧定者。寻则现坐斯大莲华。这坐已竟。乃复周遍。所化一切。自然罗列。诸大莲华。不可称载。诸菩萨等。眷属围绕。坐诸莲华。周匝巍巍。一一菩萨。逮万百千三昧。而以正受。观诸菩萨。这正受已。十方一切无有边际。诸佛刹土。自然清净。诸如来等。在会道场。以成教照。所以者何。又彼菩萨。这坐斯诸大莲华上。其下足底。出十不可计阿僧祇光。照于十方至无择狱大泥犁中。灭于众生苦恼之患。左右膝。亦如所演。光明这等无异。皆悉照耀饿鬼畜生。勤苦痛息。左右之胁。各出无限若干光明。照十方人。皆为蒙耀。二手掌中。各演光明。照于诸天阿须伦宫。其二肩肘。出二品光。照众声闻。背脑户颈各演光明。照于十方诸缘觉心。其口面门。演妙光明。照于十方诸第九住菩萨之众。眉间白毫。演大威耀。照于十方一切魔宫。皆令蔽冥。以阿惟颜菩萨之身。遂上虚空。照于十方不可计百千三千佛土。满中尘数十方如来。众会道场绕佛十匝。在虚空中。成大光明。珠交露帐。名曰大光。晖曜灼灼。以用进奉。供养如来。遂增功勋。缘是供养。从初发意。至第九住。奉顺如来。寂然随时。百千亿倍。不可为喻。其大光明珠交露帐。巍巍光明。乃至十方一切境土。普布众华。香华杂香。捣香。衣服。幢盖旛彩。布以宝瑛。明月珠珍。周遍十方一切世界。成为普世。其善本德。无上正真雨大众华。一一悉雨若干种物。供养众会一切道场。供养奉进十方如来。众生之类。敢有见知。咸发无上正真道意。斯雨众华。微妙如是。光绕诸佛众会道场。十匝已竟。入佛足下。华光忽然。照诸如来众菩萨。见其佛世界。立行如斯诸菩萨号。其逮阿惟颜。十方无际。诸菩萨。众九住菩萨。俱来会者。斯诸菩萨。及与眷属。修大供养。观见此以三昧正受。至于十方。睹阿惟颜众菩萨等。庄严元首。名曰首幻。坚立金刚。降伏魔怨。其一光曜。演百千明。各出无数晃昱营从。照于十方无边佛土。显大变化。其光奄忽。入于首幻。庄严菩萨元首。这没未久。即时菩萨。蒙其晖曜。威神力势。遂更茂盛。彼时佛子。复有大光。名一切慧。神通圣君。出诸如来至真等正觉。眉间毫相。各演无限。光明眷属。照于十方无边世界。绕诸佛土。十匝竟已。显诸如来无极神足感动变化。告诸无数亿百千兆垓诸菩萨众。诸佛国土。六反震动。皆悉消灭一切恶趣。蔽魔宫殿。十方诸佛。皆自然现。普现一切至真正觉众会道场。威神严净。法界第一。周遍虚空。咸照一切十方世界。光寻回还。上虚空中。右绕一切诸菩萨众。现大严净。此众光明。忽然在上。寻入聚会诸菩萨顶。光明这没。此诸菩萨。前未所更。所不蒙定。承佛威光。辄即逮得百万三昧。此诸光明。称量时节。堕菩萨上。一切如来。等无有异。光明这没。诸菩萨。成阿惟颜。名曰如来至真境界也。具十种力平等正觉。平若虚空。犹如佛子。转轮圣王第一太子。从尊真后。怀胎而生。其相具足。应为圣王。时转轮王。坐天宝象紫金床上。取四大海。致海水来。执大盖覆。幢幡伎乐。而严庄之。取金澡瓶。转轮圣王。以四海水。洗太子首体。适洗浴已。应时名曰圣顶盖王。转轮王者。具十善本。故谓神帝。为转轮圣。是为佛子菩萨大士成就大慧。所以菩萨。行无央数。百千勤苦。如是备悉。其功勋慧。转复增进。所立道地。名曰法雨。菩萨所住。菩萨若住法雨道地。解达欲界。审从如有。所习色界。习无色界。众生之界。无识之界。有为无为界。虚空之界。习于法界。解了泥洹。知审如有。晓知诸见邪网遮罗五趣尘劳。习诸生灭。众声闻行。缘觉之行。诸菩萨行。如来十力。四无所畏。色身法身。及一切智。成最正觉。而转法轮。示现灭度。常以平等。入一切法。分别越度。解达诸习。审如从兴。以入此慧。其意转上。使众生类。无自大业。又如审谛。超越得度。尘劳之元。不为憍慢。在于俗法。不怀恐畏。若在道法。不以自大。不舍大慈。若声闻缘觉之法。诸菩萨法。诸如来法。不以自大。于众嗔恚欢悦之中。不以增减。至真得度。亦复审知。佛所建立。经典事业。若在尘劳。顺时誓愿。供养众行。思惟劫数。建立圣慧。审如有知。无所不达。其诸如来至真等正觉。所入玄妙。谓慧微远。生死周旋。晓了微妙。现出生时。弃国捐王。成最正觉。变化开度。解微妙慧。转于法轮。寿限长短。心所建立。至于灭度。法立多少。悉微妙慧。又悉晓了诸平等正觉。佛道藏处。身口心藏。有时无时。所行秘密。菩萨受决。恩流众生。而救摄之。若干种品。众生蔽匿。群黎所行。诸根分部。执持造业。正觉所行。威神圣藏。亦复晓知所在劫数。出入多少。一劫百劫。千劫无央数劫。悉识知之。无央数劫。能入一劫。又计数无数。计念识之。不可计数。闲静劫限。悉识念之。闲静之劫。有劫无劫无念。有劫有念。有无之念。悉识念之。成正觉无正觉最正觉。悉识念之。去来现在。去来当来。过去今现在事。悉识念之。现在去来未来当来。长劫短劫。现平等事。咸亦悉知。一切诸劫。近远年岁。天地成败。不可称载。悉亦解达。诸如来等。在所感动。执如毫毛。又如微尘刹土诸身。最正觉慧。众生身心。所觉成慧。一切普入最正觉慧。显示究竟。现柔顺慧。知可思议不可思议。诸佛世界。声闻所知。缘觉所解。菩萨所达。及所不逮如来道明。所下圣慧。而悉了之。是为佛子诸等正觉慧不可量宽弘无际。菩萨住此无限道地。入无穷慧。又彼佛子。菩萨以入如是道地。入于菩萨不可思议所立脱门。有名无盖门。净境界门。有名普照脱门。又号如来藏。号莫能当藏。号入三世。号法界藏。号解脱道场光明照远。号遍入至无余菩萨脱门。是为菩萨造十脱门。不可称计。至阿僧祇百千脱门。若有菩萨。住十道地。寻即逮得如是三昧。至亿百千。总持神通无限。彼以是慧。意了所入。游遍无量。所思方便。众德备悉。彼已一时。受于十方无量诸佛所宣道义。演不可限圣法光明。法典晖曜。而雨法泽。寻即受持。犹如佛子。海中诸龙欲雨之时余不能任唯大海受。如是佛子。若入如来诸佛秘藏

尔时辄能雨大法泽。其余众生。不能任受有。报应缘。执持众行。至第九住。菩萨之业。无能执任。十住菩萨。住此道地。雨法润泽。执持一切众生心意。犹如佛子。大海之中。有大雨云。名胜谛无极。怀抱二乘。一时须臾。咸放甘雨。周遍国土。悉润天下无际普地。及诸大城州域大国。所以者何。其大海者。不可限量如是佛子。菩萨大士。住是法雨。如来一身。怀抱法雨。劝化二乘。乃至无限诸如来慧。而无央数。不可思议。不可称不可量。无边无际。超出无表。不可引喻。诸如来身。一时之间。振大光明圣法之雨。遍润十方。谁能计知彼法雨数。又问宁有能计此菩萨行。在几佛所。论其法雨多少数乎。须臾了耶。报曰不能称限合集引喻节限。犹如佛子。十方佛国。不可称计百千亿垓。诸佛世界。满中众尘。众生之类。其数如是。如此尘限。令不减少。一一众生。皆使博闻。逮得总持。悉为如来元首侍者也。为大弟子。极尊博闻。犹金刚上莲华如来至真。有一比丘。名曰大明。建如是像。博闻方便。势力坚强。一一之人智各如斯。普十方界众生之类。尽使如此。功勋智慧。巍巍无量。各各咸受一切法泽。于佛子意。所趣云何。此诸众生。博闻宁增多乎。答曰无限。金刚藏曰。吾嘱累仁。殷勤告敕。菩萨得此大法雨。住开士道地。一时须臾。一如来身。法界所雨。演三世藏无极道法。是法光明。斯之前喻。博闻方便。百倍千倍。万倍千亿万倍。不可为喻。如一如来。十方国土。诸佛世界。满中众尘。亦复如是。诸佛之数。若此尘限。乃复过是。从不可计诸如来尊。一时之间。振大法雨光明之耀。不可比喻彼之法泽。又复佛子。菩萨住此法雨道地。在兜术天。至大灭度。皆是如来己身誓愿。威神势力。兴大慈哀。无极法泽。放大法光。发圣经雷。承六神通。三达之智。四无所畏。普有所照。以无极耀。消众垢冥。以大功德圣慧之明。断众疑网。在若干众。示现诸身。称举大法。不舍众会。除诸阴盖。消灭十方一切然炽。如本前说。诸佛世界。所有尘数。亿百千垓诸佛之土。从是以往。雨大甘露。随众生心。性行所在。消尘劳垢。灭然炽火。承彼法泽。靡不永安。又复佛子。菩萨得立此大道地。演以法雨。从一世界。至兜率天大灭度地。建立一切如来之业。随众生心。如应开化。一一世界。所有众尘。如是比数。亿百千垓诸佛世界。下兜率天。至大灭度。一切普立如来之业。随众生心。应当开化。慧得自在。以变神通圣明至达。发意之顷。近小国土。建立广大。其广世界。能现令小。发意之顷。秽浊世界。变令清净。清净世界。现使秽浊。一切世界。亦复如是。建立所部。发意之顷。以用一尘。现一佛土。普建一切铁围。大铁围。众堑溪涧。一二三。至十五十一百。乃至无数诸佛世界。而建立之。入在一尘。虽在一尘。亦不广大。不增不减。以是所造。而所示现。发意之顷。一佛世界。严净显示。一一佛国土。乃至无限一切世界。而现其身。亦一念顷。遍于十方一切众生。不娆一国一佛世界。众生之类。亦复如是。至不可计诸佛世界。周入十方无际佛土。现入一毛。无所娆害。一发意顷。一切佛界。现入一毛。显示严净。一发意顷。一时化已。其数多少。如无央数。诸佛世界。满中众尘。一一所化。变现己身。如是无量。现在手掌。以是手掌。精进供养十方诸佛。一一手掌。示江河沙华。在诸裓上。以用供养诸佛世尊。众香华饰。杂香捣香。衣被幢盖缯彩。如是一切严净之业。而建立之。一一诸身。亦化若干头。一一诸头。化若干舌。咨嗟诸佛十方世尊。发意之顷。周遍十方。一心念顷。令不可计成最正觉乃至建立清净之业大灭度矣。在于三世。建立无数无量诸身。则以己身。现无央数诸佛世尊。无限佛土。建立清净。又现己身。变于一切诸佛国土。散坏合成。己身建立一切普具。诸佛之土。着一毛孔。不娆众生。发意之顷。变现无际诸佛国土。成为大海。在于其中。建众莲华。又彼莲华。光明清净。照不可计周遍佛土。又于其中。化诸佛土。乃至巍巍一切敏慧。其身普至十方佛土。日月周照。一切建立光明道门。所向一一。诸有方面。建立得见无量世界。不畏众生。乃至十方散坏之时。现是散坏。风灾变。火灾变。水灾变。发意之顷。示诸众生。如其所愿。建化色身。严庄志性。能以己身。现如来身。以如来身。现为己身。以如来身。建立己身。在佛土中。以己身土。建在佛身。佛子具听。若有菩萨。住法雨道地之业。现此变化及余无数百千神变

尔时彼场诸会菩萨。诸天龙神。揵沓和。阿须伦。迦留罗。真陀罗。摩睺勒。释梵四天王大神妙天王。净居天人。各心念言。假使菩萨。神足道化。无量巍巍之德。乃如是者。游步亘然。如来至真。所建威化。何所比乎。于是解脱月菩萨。知众会者心之所念。问金刚藏菩萨大士。唯愿佛子。众会疑网。以时断结。善哉决之。菩萨清净之所显变。化而无等伦。时金刚藏菩萨。取一切佛土。自然身威三昧。而以正受。这定意已。应时一切诸菩萨众。诸天龙神。揵沓和。阿须伦。迦留罗。真陀罗。摩睺勒。释梵四天王。大神妙天王。净居天王。自见己身。在金刚藏菩萨体中。又复睹察三千大千世界。亦在其体。在彼所作清净之业。不能周体。亿劫之中。修精进行。在彼佛树。其佛树广长。三十万里。若百若三千。广普无边具足。亦如三千亿刹。悬迥极远。斯佛树下道场师子座。巍巍如是。彼有菩萨。名诸神通。当成如来。号曰意王。诣树道场。于是会者。悉遥见之。所见庄严。具足亿劫。嗟叹其德。不能究竟。以现此变。寻还众会。复在故处。时普众会。怪未曾有。默然无言。察众菩萨寂然而住。时解脱月菩萨。问金刚藏。至未曾有。佛子。此三昧定。威耀乃尔。境界英妙。是菩萨定。所号云何。答曰。号一切佛土自然身威。又问斯三昧定。以何游行。境界严净。答曰。能备悉行。假使族姓子。若有菩萨。善修斯定。如是像类江河沙等。三千大千世界。遍中众尘。诸菩萨等。周满诸三千世界。自现其身。若复得是法雨道地。若有菩萨。住此道地。获不可计百千定意。无能限知。诸菩萨等。所现身数。及诸菩萨之所奉行。其善哉妙意。菩萨之住。不知身行。口言心念。其神足力。亦不能知。察其三世三昧所入。圣慧境界。变化之法。所建立法。不可限知。常可所行。举足下足。无能知者。至精进行。菩萨行业。住善哉妙意。菩萨道地。如是佛子。其此法雨菩萨道地。说平等时。其义广大。不可限量。所演正真。不可思议。班宣正辞。百千无际。不可为喻。又问佛子。诸如来行。境界玄妙。为如何乎。今诸菩萨。建立所行。境界神化。无边若斯。答曰。犹如佛子。而有丈夫。示其身形。如四方域。取之大杖。如四方域。若二若三。手持大杖。手执至石。以受此石。口说此言。我以投石。如十方尘诸佛世界。乃至无限。满中众尘。宁可计知此尘数。得此无极。悉了所有。无所不达。是乃名曰平等之谓。成就法雨菩萨道地。乃为无量。过是众喻。诸如来慧。至不可计喻。尔乃成至真正觉。则等修诸菩萨法。又复佛子。犹如有人。取如四方域。少所有土其余无限。如是佛子。今吾宣说是法雨菩萨道地。歌颂少所。无数劫中。咨叹功德。欲尽其福。不可畅竟。何况如来之道地也。吾今嘱累。殷勤告敕。于今住在如来之前。取要言之。假使佛子。一一方域。不可称计。诸佛世界。满中众尘。若干佛土。皆令逮得如是道住。菩萨满中。犹若甘蔗竹苇稻麻丛林。是无数劫。成菩萨行。合集此德。以为菩萨一圣明慧。比如来智。百倍千倍。万亿倍巨亿万倍。不可为喻。是为佛子菩萨以入如是圣慧。如来至真。身口心行。无有二也。菩萨不舍诸三昧力也。亲见诸佛。供养奉事。于一一劫中。供奉诸佛。不可称载。一切供养。无所乏少。入受道化。稽归诸佛。所建立教。于彼行增而无等伦。咨问。法界。不可计限。乃至巨亿百千垓劫。犹如佛子。金师绝工。作天宝冠。造大璎珞。治大宝珠。自在天王。着在其颈。而无等伦。及余天人。瑰异宝璎。终不能逮庄严妙好。如是如是。佛子。若有菩萨。逮得十住。以是菩萨净修慧行。超绝无侣。乃过逮成第九道地。住此道地菩萨。道光巍巍。乃成一切敏慧。其行无比。如是圣器。莫不蒙济。犹大神妙天王光明。超越一切所生诸天之位。照于众生心性所行。菩萨如是。以逮得立第十道地法雨地住圣慧光明。一切声闻缘觉菩萨。所不能逮。至第九住。亦不能及。建立乃到一切敏慧。导利众生。立于道义。又是菩萨。以能得入如是圣慧诸佛世尊通达三世无穷之慧。法界圣慧普遍一切诸佛世界。皆照一切诸佛国土而建立之。悉知诸法一切众生之刹土也。常以平等至一切智。逮所普解。众生悉闻。是为佛子。菩萨大士。名曰法雨开士十住。菩萨住斯。假使得作大神妙天。若为天王。说诸声闻缘觉菩萨所度无极。所问法界。则无有侣。所修诸业。布施爱敬利益之理。等利之义。一切不离诸佛之念。乃至备足一切智念。当以何致一切众生之最上尊。道御普智。发意之顷。如是色像。勤修精进。一时须臾。至不可计亿百千垓。诸佛国土。满中众尘。三昧正受。十不可计亿百千垓诸佛国土。见诸菩萨国土满中尘数。亦等无异。眷属围绕。从其中愿。菩萨势力。殊特弘誓。变化神足。咨嗟功德。不可称载。所行严净。笃信喜乐。若有所行。身所现行。其眼神足。音声种姓。乃至若干亿百千垓劫。悉见晓了。又有佛子。菩萨十住入一切智渐成道门。犹如阿耨达大池流水四河之顶。乘经水门。充润四域。增长遂盛。而不可尽。乃入巨海。若如大海无有边际。菩萨如是。所愿善本。由叙径志。以四恩义。充满众生。而开化之。功不可尽。转上增进。至一切智行无边际。又此佛子。菩萨十住。缘致佛慧。犹如十大山王。因于大地。而得自立。何谓为十。一曰雪山。二曰香勋。三曰抲陀利。四曰嫉妒山。五曰执持眴。六曰马耳山。七曰眴持。八曰铁围。九曰英意。十曰大铁围须弥山王。其雪山者。因一切药。以为屋宅。疗众生药草。不可限计。菩萨如是。住悦豫地。造立行业。皆了一切世间之行。传颂经典神咒之语。所立俗术。化无边际。其香勋山。生一切香。流众香室。则无有量。菩萨如是。住离垢地。成为舍宅。戒闻之香。守护禁法。而不可限。将养戒义。其抲陀利山。清净淳宝。以为屋室。生一切华。其花无限。普受众华。菩萨如是。住兴光地。为众屋室。处在于世。禅定脱门。三昧正受。则而无限。能问一切定意之宜。其嫉妒山。清净宝城。是为五神通之屋宅也。无限仙人所殿居耳。若干品山。菩萨如是。住晖耀地。为之屋宅。讲说道度。名无限路。咨问诸慧。其执持眴山王。真净之宝。鬼神神足之所屋室。诸鬼无限。若干品种。菩萨如是。住难胜地。一切神足。在所变化。布说无限无限神通。马耳山王。淳以宝成。因为屋室。生一切果。受无数宝。菩萨如是。住近目见菩萨道地。则为屋宅。宣布度故。诸声闻等。无际果实。随时之宜。其眴持山王。是大龙神。所居之室。诸龙无际。有若干品。菩萨如是。住玄妙地。是其屋室。宣布(丹注诸本此处玄妙地合词不尽无动地喻文全阙请验异译即知脱略)菩萨如是。住于无动开士道地。为诸菩萨自在屋室。所行独步。咨问无量十方世界也。咸共启受。英意山王。纯以净宝。为阿须伦众大神居宅。不可计数。诸阿须伦。菩萨如是。住善哉意地。成就众生。以为屋宅。所现佛身。无有边际。十方来受。究竟慧行。咨问无始。众生本末。轮转无际无边之业。其须弥山王。淳用众宝。诸神足天所居之宅。诸阿须伦。不可称计。菩萨如是。住在法雨开士道地。如来十力。四无所畏。现不可限诸佛之身。是故佛子。十宝诸山。周围大海。菩萨如是。住是十地平等普智。奉一切敏。犹如大海。以十事成而无有侣。何谓为十。一曰渐备具足。二曰不与死尸而俱杂错也。三曰异门降众。四曰一味之业。五曰无数众宝。六曰受深远色。七曰广无边际。八曰受诸大身。九曰随于住时不越故岸。十曰受一切雨而无厌足。菩萨如是行十事业。则无双比。何等为十。乃修悦豫道行之地。渐备誓愿。导化群黎。离垢地业。不与犯戒而俱同居。兴光之地。降伏世间杀生之事。晖曜之地。笃信佛道。莫能坏者。常修等行。难胜之地。善权神通。不可限量。诱化世俗。随其所乐。目见之地。深妙因缘。观察众生玄妙之地。解如审谛。众行无为。无动之地。则能欢导无极如来严净之行。善哉意地。深妙脱门。犹如佛子。大明月珠。越十宝种。所著之处。靡不明曜。绝工之师。善权合之磨治晃昱。合贯清净光之鲜明。永使究竟。琦珍为绳。以谛了达。贯之通之。为作直琉璃衡。着高幢头。演其光明。照于远近。帝王所有。为诸众生。摄护此宝。使得蒙光。出前奉现。菩萨如是。发一切智。心便得通。入十贤圣种。一智止足。乐在闲居。谛晓合德一心脱门。三昧正受。谛晓合集此三清净修治道业正法之事。善修纯清。善权神通。剖判逮了十二缘起若干品行。善权智慧。执持圣幢。而得自在。因演光明。以慧之宜。观众生行。至阿惟颜。成近得办最正觉道。建立众生。使住十地。尔乃名曰一切智耳。是为积累菩萨之行。合集功勋一切敏慧法门之品。若有众生。无有德本。终不得闻此大道业。月解脱又问。若有闻声。得值此谊。为曾积累何所功德。答曰。其功德福。宿本往时。曾以奉行。顺一切智。圣慧以斯不能顺照。照不能远。不行大慈愍于一切。周流如斯。恩施普护。缘致积德。逮法门品。其明若兹。睹现功勋。通入积功。所以者何。乃得解此。又有佛子。自非菩萨。不能得闻是法门品。亦不笃信受持讽诵。况复奉行。精进勤修。降伏成就。是故佛子。入一切智功勋之德。等类之人。乃受持斯。若得闻此法门之品。闻之则信。思惟奉行。勤修精进。时佛威神。应时十方十亿佛国。如满中尘。诸佛世界。六反震动。兴大雷音。承佛圣旨。法典恩养。寻雨天华。薰流名香。天之庄饰。天衣天宝。天之璎珞幢幡。诸天伎乐。不鼓自鸣。箫笛琴瑟。自然出声。过诸天物。一切智圣。以得亲近。无为之地。雨微妙供。如此世界。四方之域。乃至他化自在天宫。自在天王。其天宫殿。如是一切天下世界。周遍十方。是法之说。靡不流普。承佛威神。其于十方十亿佛国。满中众尘。世界若干十亿佛土。满中众尘。诸菩萨等。其数如是。各来聚会。周遍十方。各自赞言。善哉善哉。佛子。仁乃兴讲是菩萨道地法典之要。吾等亦复皆同一号。为金刚藏。从金刚首世界。而来至此国土。其佛名号金刚幢。从彼佛来。一切诸佛。皆亦转是经典之要佛之圣旨。其诸众会。亦复如是。若斯章句。义理微妙。形像如是。其义亦然。利养之行。无异不别。亦无猗他。吾等证明。承佛威神。至此众会。如吾到此佛之国土。十方无量一切世界。亦复如斯。一一佛土。四方之域。上至他化自在天宫。自在天王。天王之宫。明月之珠。宝藏宫殿。如十亿佛土满中众尘。诸菩萨数。如是来会。时金刚藏。察于十方诸菩萨等。观众部会。顾眄法界。咨嗟发起一切智心。睹众菩萨行力清净。受一切智。班宣道行。消除世垢。导利普智。示现变通。不可思议诸菩萨业功勋之德。宣布此道。承佛圣旨。则说颂曰

  寂寞无所乐　　静定心专精
  等犹如虚空　　平正若惶慌
  以离患厌垢　　而住于道慧
  闻行有殊特　　诸菩萨至尊
  千部众善德　　其心行亿劫
  供养至大圣　　诸佛有百千
  最胜由自在　　奉敬不可量
  愍伤众群生　　兴菩萨之心
  精进念外路　　忍辱长仁和
  惭愧盛元首　　功勋慧为最
  其意无垢秽　　佛圣性慧明
  胜力永平等　　劝发菩萨心
  诸众祐三世　　供义第一最
  限犹如虚空　　一切国清净
  平等顺佛义　　乃至一切法
  度脱利众生　　降伏至道场
  得为尊道地　　发心无等伦
  欢悦以离垢　　消除一切恶
  行微妙势力　　因成清白法
  奉行慈哀心　　转进入上道
  戒禁闻德富　　慈心愍众生
  舍垢无所怀　　则成清净志
  观一切世间　　三火为炽然
  第三其志广　　超越利众生
  苦恼无吾我　　及疾病疮痏
  寂灭三处苦　　常消诸炽然
  慕乐佛功勋　　造修见瑕秽
  慧弘广照曜　　以过踰众明
  心意行平净　　以逮道圣智
  善供于是住　　诸佛亿百千
  等奉人中上　　心寂诸功勋
  降伏一切众　　以越难得胜
  圣明为善权　　所修智慧意
  所造不可量　　降伏利众生
  供养于十力　　以道化群黎
  亲近无所生　　得入第六地
  众生皆难了　　进普回世间
  用身故无患　　受解知有无
  诸法本净空　　从十二品生
  下劣念微妙　　便得入第七
  智慧及善权　　逮得清明心
  远游难可胜　　大志难得喻
  寂然本清净　　心利志变故
  诸苦悉平等　　超越不可动
  作福罪若干　　慧圣无数品
  人中上为胜　　建立于寂然
  遭治十自然　　游行众生界
  用群萌之故　　入善戒道意
  于是第一微　　进步一切世
  救摄众生等　　行解垢尘劳
  此等奉律教　　则入功勋富
  所行犹妙华　　宣布上我慧
  受如是行已　　本宿行清白
  至逮第九住　　获致功德慧
  诸胜劝施力　　慕乐上正宜
  以近慧功勋　　一切逮佛道
  有诸十百千　　三昧之无为
  以得弘广明　　游居慧甚大
  然后乃逮成　　普慧阿惟颜
  其境界宽博　　三昧致无尽
  犹如成究竟　　亲近一切慧
  大莲华无限　　众宝若干种
  其身长无极　　而坐在中间
  最胜子眷属　　住立而察之
  其德无数千　　光明无量亿
  消灭于十方　　众恼诸苦患
  然后元首胜　　光耀亿百千
  人中尊众会　　越度入十方
  在于上虚空　　化光交露帐
  即受佛众行　　随顺供养佛
  于彼睹诸佛　　一切解道最
  佛子阿惟颜　　逮得上法宜
  佛子靡不普　　周旋用供养
  阿惟颜如是　　放演尊光明
  人中上眉间　　以成一切智
  受光踰诸耀　　逮入于斯顶
  说寂灭无量　　震动一切世
  无择狱众苦　　尔时寻消灭
  犹如吾所归　　一切诸佛道
  亦若最帝王　　尊上之太子
  吾成就亦然　　一切慧究竟
  如是趣逮致　　法雨豪道场
  至仁住在斯　　慧行不可量
  众生共嗟叹　　立此觉成佛
  色界无色界　　欲界所讽诵
  群黎之国土　　法界之所赞
  有为及无为　　并无身之界
  一切以选择　　咨嗟皆以法
  于是加无极　　一切无慢业
  建立如是行　　诸佛微妙慧
  人中尊秘密　　解达无数劫
  犹如毛沙数　　普入诸世界
  人中人所生　　觉了圣舍家
  回绕铁围山　　成就而示现
  一切归所趣　　至寂然脱门
  其志所获致　　一切皆入道
  志弘以住此　　诸胜演法雨
  一切普周旋　　摄持其心意
  雨一切众生　　犹如风持水
  诸佛之法雨　　所揽亦如是
  安住以一法　　弘音令得闻
  于十方佛土　　无数众生种
  闻众祐奉持　　一切为声闻
  无数众时行　　是菩萨博闻
  行慧至势力　　蒙惟宿本行
  一时须臾间　　周遍亿佛土
  雨放甘露渧　　乐灭众尘劳
  所造性仁和　　诸佛之法雨
  六通以住此　　造越至天宫
  人中上境界　　示现诸十方
  展转变改异　　无数亿千劫
  梵天通众生　　其心行佛道
  圣明以立斯　　举足一步中
  辄至第九住　　所住不可移
  总持慧功勋　　况复畏众生
  一切三界众　　成声闻缘觉
  最胜立在是　　亦复普示现
  三界无所碍　　晓了法界慧
  皆遍一切国　　众生法无余
  诸佛悉功勋　　亦复依三尊
  圣达住于此　　遵习奉事佛
  一切十方土　　周旋诸法界
  现目前供养　　奉敬众徒类
  一切成功勋　　如天服庄严
  贤圣以住此　　照众之慧光
  消灭众愚冥　　为示法之日
  自在明最胜　　消除众世乱
  诸佛子如是　　光明消尘劳
  住此在三世　　普世之上尊
  解道为极雄　　宣布三乘业
  一时须臾间　　逮无数三昧
  所在十方土　　见不可限佛
  诸佛子如是　　粗举说道地
  若干百千劫　　广叹德无尽
  离垢德如是　　其地平等觉
  所依犹如华　　若太山因地
  诸佛子第一　　睹怨无嗔恨
  譬山顶积雪　　而中众生药
  明解戒禁闻　　如名香流熏
  犹如池莲华　　因是生由然
  道宝无能乱　　辄逮圣光明
  若仙处山中　　乐居犹自娱
  鬼神之妙香　　逮得五神通
  讲论六报果　　若如马耳珍
  其七殊胜觉　　如龙执瑞应
  以致八自在　　犹如大铁围
  以入第九住　　微妙最上乘
  诸佛十功勋　　如须弥照曜
  具足第一愿　　宿布戒禁香
  行第三功勋　　如是行第四
  第五之清净　　第六行玄妙
  七意无所著　　说八无央数
  以受第九圣　　其心求微慧
  于行在众生　　尔乃入圣慧
  诸佛十事身　　因总持诸法
  如是行大海　　菩萨心无嗔
  以得通十行　　犹因本发心
  修十二至行　　一心定第三
  清净第四地　　则便照第五
  第六坏下苦　　因辄至七住
  自然执正幢　　第八为太和
  第九受众行　　慧光明远照
  第十阿惟颜　　晓了最殊胜
  功勋宝清和　　本曾行如是
  能坏十方国　　一切悉计数
  能以一心睹　　普解众生心
  尚可以一毛　　量尽于虚空
  叹亿百千劫　　不能尽佛德

金刚藏曰。所以名曰大光定意。道慧已具。成阿惟颜。便备佛道。一切蒙安。犹如日明。天下戴仰。十方诸佛。皆由中生。因其得成。佛谓诸菩萨。善哉善哉。金刚藏。嗟叹讲说此十住事。众开士等。所当施行。从初发意。至阿惟颜。犹月初生。十五日满。众星独明。菩萨如是。渐备众行。五戒十善。四等四恩。六度无极。大慈大哀。善权方便。自致成佛。润泽众生。犹如种树。生根茎节。枝叶华实。众人服食。除其饥虚。菩萨如是。从初发意。自致成佛。莫不蒙济。普得至道。犹如百谷。草木果实。众药皆因地生。菩萨如是。行此十住。自致成佛度脱十方。犹如大海出众妙宝。无量之珍。益于天下。此经如是。成就菩萨十住道地。乃使得佛。德过虚空。犹如日月。忽照四域。天下戴仰。菩萨行此。自致佛道。众生蒙恩。除生老病死无量之难。悉升道堂。犹如医王。疗众人病。无不除愈。此经如是。消众生类淫怒痴病。使至正真。如转轮王。教化四方。莫不顺命。菩萨如是。四等四恩。化授吾我。猗四大者。至无所畏。四事不护。心病永除。犹须弥山四方之中。此经如是。众典之英。道德弘明。志平等正。解达无身。乃至无上正真之道。度脱一切生死老病终始之患。去来今佛之所由生。诸经之渊海。道德之宫。藏诸菩萨行。所会道堂。三界众人。所求福粮。其淫怒痴。忽自消亡。犹如虚空。含受一切诸有形类。生之长之。靡不因之。此经如是。诸菩萨等。去来今佛之所由生。善权智慧。开化声闻诸缘觉众。皆令得度。三界黎庶。悉得蒙济。三苦脱难。咸得解缚。普发道意。入深法藏。无穷法身。开化十方。十方恒沙诸佛国土满中七宝。供十方佛。不如受是。以讽诵说。宣示同学。报去来今诸佛之恩。诸佛之地。一切十方。圣道德无。虚空尚可度。十方海可知渧数。学此经典。德无能限。金刚藏菩萨。说法如是。如来悦可。一切菩萨。诸天龙神。揵沓和。阿须伦。释梵四天王。大神妙天。净居天。他化自在。第六天宫。所住犹行。明月宝堂。从初发心。而修悦豫。从一至二。三至四上。五六至七。八九至十。成最正觉。一切会者。闻金刚藏菩萨所说。莫不欢喜

渐备经卷第五

元康七年十一月二十一日。沙门法护。在于长安。于市西寺中。己执梵本。手自演出为晋言。普使十方一切蒙光。得至无形。度脱众生。咸共欣济。今解十住。释梵为晋。名第一住。天竺语彼牟提陀。晋曰悦豫。第二住名维摩罗。晋曰离垢。第三住名彼披迦罗。晋曰兴光。第四住名阿至摸。晋曰晖曜。第五住名头阇邪。晋曰难胜。第六住名阿比牟佉。晋曰目见。第七住名头罗迦摩。晋曰玄妙。第八住名阿遮罗。晋曰无动。第九住名杪头摩提。晋曰善哉意。第十住名昙摩弥迦。晋曰法雨


菩萨十住行道品一卷

    No. 283 [Nos. 278(11), 229(15), 281(2), 284]

    菩萨十住行道品一卷

        西晋三藏竺法护译

昙昧摩提菩萨。持佛威神。便于佛前。于是阿难波渝迦三昧。悉见十方诸佛。十方诸佛者。其数如千佛刹尘等。一尘者。为一佛刹。一佛刹如是十方四面。见十方诸佛。皆悉言。善哉善哉。昙昧摩提菩萨。十方诸佛。皆赐与智慧。悉语昙昧摩提菩萨言。是释迦文佛。前世本愿。所结成功德。威神使若益。诸经益者。佛威神益。深入经处。悉示诸十方。虚空法心无所著。悉入无所挂碍中。悉入大道中。疾近逮佛。悉知诸经。诸十方人所思想。悉学知十方诸所说经。皆悉知用。是故悉为诸菩萨等。说菩萨十法住。悉及得持佛威神。悉能说。尔时昙昧摩提菩萨。所语说。无所挂碍。无所难也。无有尽赐时。无有能升量者。无有极止时。无有能逮者。无有能得长短者。未曾有忘时。无不得明者。悉等无异。无有懈慢时。众所不能及。持是三昧力。十方诸佛等。皆各各伸右手。着昙昧摩提菩萨头上。以昙昧摩提菩萨。使于三昧中觉。便语菩萨言。诸佛子皆听。菩萨舍甚大。悉如虚空。经处何因。菩萨舍甚大。过去诸佛悉那中生。当来诸佛悉那中生。今现在诸佛悉那中生。何因菩萨入大道中。从何因缘。入是大道中。何因正尔。菩萨有十法住。用分别如过去当来今现在佛等所说。何等为诸菩萨十法住

第一者。波蓝耆兜波菩萨法住

第二者。名阿阇浮菩萨法住

第三者。名渝阿阇菩萨法住

第四者。名阇摩期菩萨法住

第五者。名波渝三般菩萨法住

第六者。名阿耆三般菩萨法住

第七者。名阿惟越致菩萨法住

第八者。名鸠摩罗浮童男菩萨法住

第九者。名渝罗阇菩萨法住

第十者。名阿惟颜菩萨法住

一何等为波蓝耆兜波菩萨法住者。上头见佛。端政无比。视面色无有厌。时无有及逮者。尊贵无有能过者。飞无有能过者。所教授无有能过者。是菩萨。见佛威神仪法如是。使稍入佛道中。转开导之。皆随其意教度既见勤苦者皆愍伤。稍稍近晓佛语。信向之。新发起意。学佛道。悉欲得了佛智十难处。悉欲逮得知之何等为十难处十种力。波蓝耆兜波菩萨教。有十事。何等为十事。一者当供养佛诸菩萨。二者随其所乐当教语。三者所生处皆尊贵。四者天上天下。一无有能及者。五者佛所有智悉当逮得。六者波罗世所生处。常见无央数佛。七者所有深三昧经悉当逮得。八者死生道无边幅处以来。九者命既去不久。十者若悉当度脱十方人。所以者何。益入于佛法中故

二何等为阿阇浮菩萨法住者。有十意。念十方人。何等为十意。一者悉念世间人善。二者净洁心。三者皆安隐心。四者柔软心。五者悉爱等。六者心念但欲施与人。七者心悉当护。八者心念人与我身无异。九者心念十方人我。观如师。十者心念十方人视如佛。阿阇浮菩萨法。当多学经。既多学经。以当独处止。既独处止。当与善师从事。既与善师从事。当在善师边。既在善师边。当易使。既易使。当随时。既随所作为。当勇所作为。既勇。当学入慧中。既学入慧中。以所受法。当悉持。既当悉持法。当不忘。既不忘。当安隐处止。所以者何。益于闵伤十方人故。三何等为渝阿阇菩萨法住者。入于诸法中。用十事。何等为十事。一者诸所有皆无常。二者诸所有皆勤苦。三者诸所有皆虚空。四者诸所有皆非我所。五者诸所有皆无所住。六者诸所有皆无利。七者诸所有皆无所止。八者诸所有皆无有处。九者诸所有皆无所著。十者诸所有皆无所有。诸法悉入中不复还。渝阿阇菩萨教法。悉当念于十方人。念于十方人已。悉当念法处。念法处已。悉当念诸佛刹。念诸佛刹已。悉当念地法。念地法已。悉当念水法。念水法已。悉当念火法。念火法已。悉当念风法。念风法已。悉当念欲法。念欲法已。悉当念色法。念色法已。当念无有欲色法处。念无所欲色法处已。心无所贪。所以者何。用是故。悉当法明四何等为阇摩期菩萨法住者。常念于佛处生。有十事。何等为十事。一者不复还。二者多深慈于佛。三者深思惟法。四者皆视十方人慈心。五者思惟十方了无所有。六者十方佛刹皆虚空。七者宿命所作了无所有。八者诸所有皆虚空。譬如作幻耳。九者诸所有勤苦无所有。十者泥洹虚空无所有。用是故。生于佛法中。是为阇摩期菩萨教法。过去诸佛虚空无所有。当来诸佛虚空无所有。今现在诸佛虚空无所有。过去诸佛法无所有。当来诸佛法无所有。今现在诸佛法无所有。过去诸佛法。念从何所出生索了无所有。当来诸佛法。念从何所出生索了无所有。今现在诸佛法。念从何所生索了无所有。诸佛法等悉了无所有。所以者何。是三世法。等皆了无所有一五何等为波渝三般菩萨法住者。所作功德。悉度十方人。有十事。何等为十事。一者悉护十方人。二者悉令十方人善。三者悉念十方人命安隐。四者悉爱十方人。五者悉哀十方人。六者悉教十方人莫使作恶。七者悉引十方人着菩萨道中。八者悉清净于十方人。九者悉度十方人。十者悉脱十方人令般泥洹。不可复计十方人。不可复数十方人。不可复议十方人。不可复称十方人。不可复量十方人。了不可议说十方人。何等为十方人者。都卢十方人。皆虚空人。皆非我所人。皆无所有人。皆所有皆无他奇。所以者何。心无所著故

六何等为阿耆三般菩萨法住者。有十法深慈心哀。何等为十法。一者用说佛善恶心无有异。二者说法善说法恶心无有异。三者说菩萨善说菩萨恶心无有异。四者求菩萨道人共相道善恶心无有异。五者中有人言十方人多十方人少心无有异。六者都十方人转相道善恶心无有异。七者中有人说言十方人易脱难脱心无有异。八者说法多说法少心无有异。九者说法坏说法不坏心无有异。十者有法处无法处心无有异。是菩萨当学。是诸法无有处。复有十事。何等为十事。一者诸法无有处。二者诸法不可得见处。三者学诸法譬如化作。四者诸法皆虚空。五者诸法若干种虚空。六者诸法无有挂碍极虚空处。七者诸法譬若幻所化。八者诸法譬梦中所有。九者诸法不可计。十者诸法无所有不可得视。所以者何。益深入佛法中。无有能胜者

七阿惟越致菩萨者。何等法住。菩萨闻十事坚住。何等为十事。一者有佛无佛不动还。二者言有法无法不动还。三者有菩萨无菩萨不动还。四者有求菩萨道者无有求菩萨道者不动还。五者持是法得持是法不得不动还。六者有诸过去佛无诸过去佛不动还。七者有诸当来佛无诸当来佛不动还。八者有诸现在佛无诸现在佛不动还。九者佛智慧尽佛智慧不尽不动还。十者过去世事。当来世事今现在世事。乎若干种乎一种心终不复动还。是菩萨当教令学此十事。何等为十。一者向一慧。入若干慧。二者持若干慧。入一慧。三者一慧入若干事。四者从若干事。入一慧。五者持十方人。处虚空。六者持虚空。皆入十方人。七者持思想。入不动摇。八者持不动摇。入思想中。九者持虚空。入想中。十者持想。入虚空中。所以者何。诸功德法悉入中。用是故不复动

八鸠摩罗浮童男菩萨者。为何等法住。菩萨于十事中住。何等十。一者身所行。口所言。心所念。悉净洁。二者无有能得长短者。三者心一反念在欲生何所。四者十方人知谁慈心者。五者十方人所信用悉知。六者十方人若干种悉知。七者十方人所作为悉知。八者诸刹土成败悉知。九者神足念飞在所到。十者诸法清净学。是菩萨。当复学十事。何等为十事。一者当学知诸佛刹佛刹。二者当学感动诸佛刹。三者当学自在所作威神。四者当学视诸佛刹。五者当学从一佛刹复至一佛刹。六者当学往到无央数佛刹。七者当学知无央数法在所问。八者当学变化。譬如幻自在所作。九者当学佛音声响。十者当学一反念。供养无央佛所。即悉遍至到。所以者何。入于一法中多所遣

九者渝阿罗阇菩萨者。何等法住。菩萨用十事得。何等为十事。一者诸十方人。所出生悉知。二者十方人。所系恩爱悉知。三者十方人。所念本末所从来悉知。四者十方人。所作为宿命善恶所趣向悉知。五者若干种诸法悉知。六者十方人所念。若干种变化悉知。七者诸佛刹坏败善恶悉知。八者过去当来今现在。无央数世事悉知。九者十方人。等不等悉知。十者教授十方人。说虚空法悉知是。菩萨复有十处当学知。何等为十处。一者佛法宫当学。二者造佛法宫当学。三者佛宫中所有当学。四者佛宫中所教敕当学。五者佛所出入宫当学。六者法宫当学。七者法王宫当学。八者法所教敕当学。九者安行法王当学。十者更造作法中王所教敕。当承用学。所以者何。心稍稍入佛大道中。所闻法自用教十阿惟颜菩萨者。为何法住。菩萨入于若干十智中。悉分别知。何等为十智中。一者当何因感动无央数佛刹。二者当明无央数佛刹中事。三者我日日当置无央数佛刹中菩萨。四者我日日当度无央数佛刹中人。五者我当安隐无央数佛刹中众。生六者十方人无央数。皆闻我声。七者悉知十方人民。八者十方人所思想善恶。我悉当知。九者十方人。我悉当内佛道中。十者十方人。我悉当度脱。渝罗阇菩萨。不能及知阿惟颜身所行口所言心所念所作为。了不能及知阿惟颜菩萨事。不能及知神足念。不能知飞。亦不能逮知阿惟颜菩萨过去当来今现在事。亦不能逮知所念佛刹。亦不能逮知心所念所行。为智慧用十事。渝罗阇菩萨。不能逮知阿惟颜菩萨所行事。是阿惟颜菩萨。逮入佛十智中。何等为十智中。一者过去当来今现在。无端亟从佛学。二者诸佛法悉具足。从佛学。三者诸法处无所挂碍。从佛学。四者诸法处。无边幅无崖底。从佛学。五者诸所有刹土。我悉当护持是功德威神。从佛学。六者不可复计刹土处无边幅。悉当明知。从佛学。七者十方无央数佛刹。悉当安隐。从佛学。八者十方人所行。为悉当从佛学。九者诸法智慧悉入中。从佛学。十者佛所有智慧。悉当知。从佛学。所以者何。悉具足知。皆晓了佛智慧。都无所复从谁学道。是为阿惟颜。以十法菩萨行道如是菩萨十住行道经


普贤菩萨行愿赞

    No. 297 [No. 296; cf. 293(Fasc. 40)]

    普贤菩萨行愿赞

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

  所有十方世界中　　一切三世人师子
  我今礼彼尽无余　　皆以清净身口意
  身如刹土微尘数　　一切如来我悉礼
  皆以心意对诸佛　　以此普贤行愿力
  于一尘端如尘佛　　诸佛佛子坐其中
  如是法界尽无余　　我信诸佛悉充满
  于彼无尽功德海　　以诸音声功德海
  阐扬如来功德时　　我常赞叹诸善逝
  以胜花鬘及涂香　　及以伎乐胜伞盖
  一切严具皆殊胜　　我悉供养诸如来
  以胜衣服及诸香　　末香积聚如须弥
  殊胜灯明及烧香　　我悉供养诸如来
  所有无上广大供　　我悉胜解诸如来
  以普贤行胜解力　　我礼供养诸如来
  我曾所作众罪业　　皆由贪欲嗔恚痴
  由身口意亦如是　　我皆陈说于一切
  所有十方群生福　　有学无学辟支佛
  及诸佛子诸如来　　我皆随喜咸一切
  所有十方世间灯　　以证菩提得无染
  我今劝请诸世尊　　转于无上妙法轮
  所有欲现涅槃者　　我皆于彼合掌请
  唯愿久住刹尘劫　　为诸群生利安乐
  礼拜供养及陈罪　　随喜功德及劝请
  我所积集诸功德　　悉皆回向于菩提
  于诸如来我修学　　圆满普贤行愿时
  愿我供养过去佛　　所有现住十方世
  所有未来速愿成　　意愿圆满证菩提
  所有十方诸刹土　　愿皆广大咸清净
  诸佛咸诣觉树王　　诸佛子等皆充满
  所有十方诸众生　　愿皆安乐无众患
  一切群生获法利　　愿得随顺如意心
  我当菩提修行时　　于诸趣中忆宿命
  若诸生中为生灭　　我皆常当为出家
  戒行无垢恒清净　　常行无缺无孔隙
  天语龙语夜叉语　　鸠槃荼语及人语
  所有一切群生语　　皆以诸音而说法
  妙波罗蜜常加行　　不于菩提心生迷
  所有众罪及障碍　　悉皆灭尽无有余
  于业烦恼及魔境　　世间道中得解脱
  犹如莲华不着水　　亦如日月不着空
  诸恶趣苦愿寂静　　一切群生令安乐
  于诸群生行利益　　乃至十方诸刹土
  常行随顺诸众生　　菩提妙行令圆满
  普贤行愿我修习　　我于未来劫修行
  所有共我同行者　　共彼常得咸聚会
  于身口业及意业　　同一行愿而修习
  所有善友益我者　　为我示现普贤行
  共彼常得而聚会　　于彼皆得无厌心
  常得面见诸如来　　与诸佛子共围绕
  于彼皆兴广供养　　皆于未来劫无倦
  常持诸佛微妙法　　皆令光显菩提行
  咸皆清净普贤行　　皆于未来劫修行
  于诸有中流转时　　福德智慧得无尽
  般若方便定解脱　　获得无尽功德藏
  如一尘端如尘刹　　彼中佛刹不思议
  佛及佛子坐其中　　常见菩提胜妙行
  如是无量一切方　　于一毛端三世量
  佛海及与刹土海　　我入修行诸劫海
  于一音声功德海　　一切如来清净声
  一切群生意乐音　　常皆得入佛辩才
  于彼无尽音声中　　一切三世诸如来
  当转理趣妙轮时　　以我慧力普能入
  以一刹那诸未来　　我入未来一切劫
  三世所有无量劫　　刹那能入俱胝劫
  所有三世人师子　　以一刹那我咸见
  于彼境界常得入　　如幻解脱行威力
  所有三世妙严刹　　能现出生一尘端
  如是无尽诸方所　　能入诸佛严刹土
  所有未来世间灯　　彼皆觉悟转法轮
  示现涅槃究竟寂　　我皆往诣于世尊
  以神足力普迅疾　　以乘威力普遍门
  以行威力等功德　　以慈威力普遍行
  以福威力普端严　　以智威力无著行
  般若方便等持力　　菩提威力皆积集
  皆于业力而清净　　我今摧灭烦恼力
  悉能降伏魔罗力　　圆满普贤一切力
  普令清净刹土海　　普能解脱众生海
  悉能观察诸法海　　及以得源于智海
  普令行海咸清净　　又令愿海咸圆满
  诸佛海会咸供养　　普贤行劫无疲倦
  所有三世诸如来　　菩提行愿众差别
  愿我圆满悉无余　　以普贤行悟菩提
  诸佛如来有长子　　彼名号曰普贤尊
  皆以彼慧同妙行　　回向一切诸善根
  身口意业愿清净　　诸行清净刹土净
  如彼智慧普贤名　　愿我于今尽同彼
  普贤行愿普端严　　我行曼殊室利行
  于诸未来劫无倦　　一切圆满作无余
  所须胜行无能量　　所有功德不可量
  无量修行而住已　　尽知一切彼神通
  乃至虚空得究竟　　众生无余究竟然
  及业烦恼乃至尽　　乃至我愿亦皆尽
  若有十方无边刹　　以宝庄严施诸佛
  天妙人民胜安乐　　如刹微尘劫舍施
  若人于此胜愿王　　一闻能生胜解心
  于胜菩提求渴仰　　获得殊胜前福聚
  彼得远离诸恶趣　　彼皆远离诸恶友
  速疾得见无量寿　　唯忆普贤胜行愿
  得大利益胜寿命　　善来为此人生命
  如彼普贤大菩萨　　彼人不久当获得
  所作罪业五无间　　由无智慧而所作
  彼诵普贤行愿时　　速疾销灭得无余
  智慧容色及相好　　族姓品类得成就
  于魔外道得难摧　　常于三界得供养
  速疾往诣菩提树　　到彼坐已利有情
  觉悟菩提转法轮　　摧伏魔罗并营从
  若有持此普贤愿　　读诵受持及演说
  如来具知得果报　　得胜菩提勿生疑
  如妙吉祥勇猛智　　亦如普贤如是智
  我当习学于彼时　　一切善根悉回向
  一切三世诸如来　　以此回向殊胜愿
  我皆一切诸善根　　悉已回向普贤行
  当于临终舍寿时　　一切业障皆得转
  亲睹得见无量光　　速往彼刹极乐界
  得到于彼此胜愿　　悉皆现前得具足
  我当圆满皆无余　　众生利益于世间
  于彼佛会甚端严　　生于殊胜莲花中
  于彼获得受记莂　　亲对无量光如来
  于彼获得受记已　　变化俱胝无量种
  广作有情诸利乐　　十方世界以慧力
  若人诵持普贤愿　　所有善根而积集
  以一刹那得如愿　　以此群生获胜愿
  我获得此普贤行　　殊胜无量福德聚
  所有群生溺恶习　　皆往无量光佛宫

    八大菩萨赞(出八大菩萨曼茶罗经末)
  圆寂宫城门　　能摧户扇者
  诸佛法受用　　救世我顶礼
  自手流清水　　能除饿鬼渴
  三界如意树　　顶礼莲花手
  大慈水为心　　能息嗔恚火
  顶礼慈氏尊　　能断欲弓弦
  虚空藏妙慧　　虚空寂静尊
  生死流解脱　　顶礼佛心子
  无边有情惑　　能息无益心
  普贤我顶礼　　善逝上首子
  尘劳尽僮仆　　超胜魔罗军
  顶礼金刚手　　能说一切明
  顶礼妙吉祥　　持妙童子形
  舒遍智慧灯　　攘夺三界明
  一切除盖障　　是故我顶礼
  无尽智慧尊　　能生无竭辩
  如地诸有情　　所依一不断
  坚慧悲愍藏　　地藏我顶礼
  此真善逝子　　赞扬所获福
  以此诸有情　　如彼成赞器　普贤菩萨行愿赞速疾满普贤行愿陀罗尼曰襄么悉底哩也(四合)地尾(二合)迦(引)南(二)怛佗(引)孽哆南(二)唵(引三)阿(引)戌嚩啰尾拟儞娑嚩(二合引)诃(引四)每日诵普贤菩萨行愿赞后。即诵此真言才诵一遍。普贤行愿悉皆圆满。三摩地人速得三昧现前。福德智慧二种庄严。获坚固法速疾成就


十住经卷第一

    No. 286 [Nos. 278(22), 279(26), 285, 287]

十住经卷第一

        后秦龟兹国三藏鸠摩罗什译

    欢喜地第一

如是我闻。一时佛在他化自在天王宫摩尼宝殿上。与大菩萨众俱。皆于阿耨多罗三藐三菩提。不退转。从他方界。俱来集会。此诸菩萨。一切菩萨。智慧行处。悉得自在。诸如来智慧入处。悉皆得入。善能教化一切世间。随时普示神通等事。于念念中。皆能成办具足一切菩萨所愿。于一切世界一切劫一切国土。常修诸菩萨行。具足一切菩萨所有福德智慧。而无穷尽。能为一切。而作饶益。能到一切菩萨智慧方便彼岸。能示众生生死及涅槃门。不断一切菩萨所行。善游一切菩萨禅定解脱三昧。神通明慧。诸所施为。善能示现一切菩萨无作神足。皆悉已得。于一念顷。能至十方诸佛大会。劝发咨请。受持法轮。常以大心。供养诸佛。常能修习诸大菩萨所行事业。其身普现无量世界。其音遍闻。无所不至。其心通达。明见三世一切菩萨。所有功德。具足修习。如是诸菩萨摩诃萨功德无量无边。于无数劫。说不可尽

其名曰金刚藏菩萨摩诃萨。宝藏菩萨。莲华藏菩萨。德藏菩萨。莲华德藏菩萨。日藏菩萨。月藏菩萨。净月藏菩萨。照一切世间庄严藏菩萨。智慧照明藏菩萨。妙德藏菩萨。栴檀德藏菩萨。华德藏菩萨。优钵罗华德藏菩萨。天德藏菩萨。福德藏菩萨。无阂清净智德藏菩萨。功德藏菩萨。那罗延德藏菩萨。无垢藏菩萨。离垢藏菩萨。种种乐说庄严藏菩萨。大光明网藏菩萨。净明威德王藏菩萨。大金山光明威德王藏菩萨。一切相庄严净德藏菩萨。金刚焰德相庄严藏菩萨。焰炽藏菩萨。宿王光照藏菩萨。虚空无阂妙音藏菩萨。陀罗尼功德持一切世间愿藏菩萨。海庄严藏菩萨。须弥德藏菩萨。净一切功德藏菩萨。如来藏菩萨。佛德藏菩萨。解脱月菩萨。如是等菩萨摩诃萨。无量无边。不可思议。不可称说。金刚藏菩萨摩诃萨。而为上首

尔时金刚藏菩萨摩诃萨。承佛威神。入菩萨大智慧光明三昧。即时十方世界。于一方。过十亿佛土微尘数世界乃有如来。名金刚藏。如是次第。十亿佛土微尘数诸佛。皆现其身。名金刚藏。十方世界。皆亦如是。同声赞言。善哉善哉。金刚藏。乃能入是菩萨大智慧光明三昧。如是十方世界微尘数等诸佛。皆同一号。加汝威神。又卢舍那佛。本愿力故。又汝有大智慧故。又与一切菩萨不可思议。诸佛法明。所谓。令入智慧地故。摄一切善根故。善分别选择一切佛法故。广知诸法故。决定说诸法故。无分别智善分别故。一切世间法不能污故。出世间善根清净故。得不可思议智力故。得一切智人智处故。又得菩萨十地故。如实说菩萨十地差别故。分别说无漏法不着故。大智慧光明。善择以自庄严故。令入具足智门故。随所应住次第说故。得无阂乐说光明故。具足大无阂智地不忘失菩萨心故。教化成就一切众生性故。得一切遍至决定智故。又金刚藏。汝当说此法门差别。所谓。诸佛神力故。汝能堪受如来神力故。自善根清净故。清净法性性故。饶益众生性故。令众生得清净法身智身故。于一切佛得受记故。得一切世间最高大身故。过一切世间道故。出世间善根清净故。即时十方诸佛。示金刚藏真实无上佛身。与无障碍乐说之辩。与善分别清净智慧。与善忆念不忘。与善决定意。与遍至一切智处。与诸佛无坏力。与诸佛无所畏不怯弱。与诸佛无碍智分别诸法善开法门。与一切诸佛上妙身口意所作。何以故。以得菩萨大智慧光明三昧法故。亦是菩萨本愿力故。志心清净故。智慧明白故。善集助道法故。善修本事故。能持无量念故。信解清净光明法故。善得陀罗尼门无分别故。以智印善印法性故。尔时十方诸佛。皆伸右手。摩金刚藏菩萨顶。金刚藏菩萨。即从三昧起。起已。告诸菩萨言。诸佛子。是诸菩萨事。先皆善自决定。无有过无分别。清净明了。广大如法性。究竟如虚空。遍覆一切十方诸佛世界众生。为救度一切世间。为一切诸佛神力所护。何以故。诸菩萨摩诃萨。入过去诸佛智地。亦入未来现在诸佛智地。诸佛子。何等是诸菩萨摩诃萨智地。诸佛子。菩萨摩诃萨智地。有十。过去未来现在诸佛。已说。今说。当说。为是地故。我如是说。何等为十。一名喜地。二名净地。三名明地。四名焰地。五名难胜地。六名现前地。七名深远地。八名不动地。九名善慧地。十名法云地。诸佛子。是十地者。三世诸佛。已说。今说。当说。我不见有诸佛国土不说是菩萨十地者。何以故。此十地。是菩萨最上妙道。最上明净法门。所谓。分别十住事。诸佛子。是事不可思议。所谓。菩萨摩诃萨。随顺诸地智慧。是时金刚藏菩萨摩诃萨。说诸菩萨十地名已。默然而住。不复分别义趣。尔时一切菩萨众。闻说菩萨十地名已咸皆渴仰。欲闻解释。各作是念。何因何缘。金刚藏菩萨。说菩萨十地名已。默然而住。不更解释。时大菩萨众中。有菩萨摩诃萨。名解脱月。知诸菩萨。心之所念。以偈问金刚藏菩萨言

  净智念慧人　　何故说菩萨
  诸地名号已　　默然不解释
  今诸大菩萨　　心皆怀犹豫
  何故说是名　　而不演其义
  大智诸菩萨　　咸皆欲听闻
  如是诸地义　　愿为分别说
  是诸菩萨众　　清净无瑕秽
  安住坚实法　　具足智功德
  皆以恭敬心　　瞻仰于仁者
  愿欲闻所说　　如渴思甘露
  金刚藏菩萨　　闻说是事已
  欲令大众悦　　即时说颂言
  诸菩萨所行　　第一难思议
  分别是诸地　　诸佛之根本
  微妙甚难见　　非心所能及
  从佛智慧出　　若闻则迷没
  持心如金刚　　深信佛智慧
  以为第一妙　　心无有疑难
  远离计我心　　及心所行地
  如是诸菩萨　　尔乃能听闻
  寂灭无漏智　　分别说甚难
  如画于虚空　　如执空中风
  我念佛智慧　　第一难思议
  众生少能信　　是故我默然

解脱月菩萨。闻说此已。语金刚藏菩萨言。佛子。是大菩萨众。深心清净。善行菩萨道。善集助道法。善能供养恭敬诸佛。于无量佛。多种善根。成就无量深厚功德。离痴疑悔。无有贪着及诸结阂。深心信解。安住不动。于是法中。不随他教。是故佛子。当承佛力。敷演此义。是诸菩萨。于是深法。皆能证知。时解脱月。欲重宣此义。而说偈言

  愿说安隐法　　菩萨无上行
  分别于诸地　　令智慧清净
  众智净无垢　　安住深信解
  于诸无量佛　　证知十地义

尔时金刚藏菩萨言。佛子。是诸大众。虽皆清净。离痴疑悔。于此事中。不随他教。其余乐小法者。闻是甚深难思议事。或生疑悔。是人长夜。受诸衰恼。我愍此等。是故默然。尔时金刚藏菩萨。欲明了此义。而说偈言

  是众虽清净　　深智离疑悔
  其心已决定　　不复随他教
  无动如须弥　　不乱如大海
  其余不久行　　智慧未明了
  随识不随智　　闻已生疑悔
  彼将坠恶趣　　愍念故不说

解脱月菩萨言。佛子愿承佛力。善分别此不可思议法佛所护念事。令人易信解。所以者何。善说十地义。十方诸佛。法应护念。一切菩萨。护是事故。勤行精进。何以故。是菩萨。最上所行。得至一切诸佛法故。譬如所有经书。皆初章所摄。初章为本。无有一字不入初章者。如是佛子。十地者。是一切佛法之根本。菩萨具足。行是十地。能得一切智慧。是故佛子。愿说此义。诸佛护念。加以神力。令人信受。不可破坏。尔时解脱月菩萨。欲显此义。而说偈言

  善哉智慧子　　清净行具足
  愿说十地行　　所入十地法
  具足于智慧　　得以成菩提
  所有十方佛　　最胜人中尊
  皆共护念汝　　说是十地义
  十地为根本　　是名智行处
  亦为究竟道　　佛无量法聚
  譬如诸文字　　皆摄在初章
  诸佛功德智　　十地为根本

尔时诸菩萨。一时同声。以偈请金刚藏菩萨言

  上妙智慧人　　乐说无有量
  德重如山王　　哀愍说十地
  戒念慧清净　　说是十地义
  十力之根本　　无阂智本行
  戒定慧功德　　集在仁者心
  憍慢诸邪见　　皆悉已灭尽
  是众无疑心　　唯愿闻善说
  譬如渴思水　　如饥思美食
  如病思良医　　如蜂欲食蜜
  我等亦如是　　闻甘露法味
  是故旷大意　　愿开初地门
  乃至第十地　　次第为我说

尔时释迦牟尼佛。从眉间白毫相。放菩萨力明光焰。百千阿僧祇光。以为眷属。放斯光已。普照十方诸佛世界。靡不周遍。三恶道苦。皆得休息。悉照十方诸佛大会。说法之众。显现如来不思议力。是光明。遍照十方诸佛大会。诸菩萨身已。于上虚空中。成大光明云台。十方诸佛。亦复如是。从眉间白毫相。俱放菩萨力明光焰。百千阿僧祇光。以为眷属。普现如来不思议力。悉照一切诸佛大会。及照娑婆世界。释迦牟尼佛大众。并照金刚藏菩萨摩诃萨。及师子座。照已。于上虚空中。成大光明云台。时诸大光明云台中诸佛神力故。而说偈言

  无等等诸佛　　功德如虚空
  十力无畏等　　最尊世间主
  于释迦佛前　　而现此神力
  以佛力开现　　法王师子藏
  说诸地所行　　诸地义差别
  承诸佛力说　　无有能坏者
  若人闻法宝　　则为诸佛护
  渐次具诸地　　得以成佛道
  若人堪任闻　　虽在于大海
  及劫尽火中　　必得闻此经
  若人痴疑悔　　终不能得闻
  是故今佛子　　说诸地智道
  入势力观法　　次第而修行
  得至于余地　　各得所利益
  利一切世间　　愿说勿令断

尔时金刚藏菩萨。观察十方。欲令大众。增益信敬。而说偈言

  诸佛圣主道　　微妙甚难解
  非思量所得　　唯智者行处
  其性从本来　　寂然无生灭
  从本以来空　　灭除诸苦恼
  远离于诸趣　　等同涅槃相
  无中亦无后　　非言辞所说
  出过于三世　　其相如虚空
  诸佛所行处　　清净深寂灭
  言说所难及　　地行亦如是
  说之犹尚难　　何况以示人
  诸佛之智慧　　离诸心数道
  不可得思议　　非有阴界入
  但以智可知　　非识之所及
  如空迹难说　　何可示其相
  十地义如是　　非无边心知
  是事虽为难　　发愿行慈悲
  渐次具诸地　　非心所能及
  如是诸地行　　微妙甚难见
  不可以心知　　当承佛力说
  汝等当恭敬　　咸共一心听
  诸地相入行　　修习出法门
  于无量亿劫　　说之不可尽
  今如实略说　　其义无有余
  一心恭敬待　　今承佛力说
  大音唱因喻　　义名不相违
  佛神力无量　　今皆在我身
  我之所说者　　如大海一渧

金刚藏菩萨。说此偈已。告于大众。诸佛子。若众生。厚集善根。修诸善行。善集助道法。供养诸佛。集诸清白法。为善知识所护。入深广心。信乐大法心。多向慈悲。好求佛智慧。如是众生。乃能发阿耨多罗三藐三菩提心。为得一切种智故。为得十力故。为得大无畏故。为得具足佛法故。为救一切世间故。为净大慈悲心故。为向十方无余无阂智故。为净一切佛国令无余故。为于一念中知三世事故。为自在转大法轮广示现佛神力故。诸菩萨摩诃萨。生如是心。诸佛子。是心以大悲为首。智慧增上。方便所护。直心深心淳至。量同佛力。善筹量众生力佛力。趣向无阂智。随顺自然智。能受一切佛法。以智慧教化。广大如法性。究竟如虚空。尽于后际。诸佛子。菩萨生如是心。即时过凡夫地。入菩萨位。生在佛家。种姓无可讥嫌。过一切世间道。入出世间道。住菩萨法中。在诸菩萨数。等入三世如来种中。毕定究竟阿耨多罗三藐三菩提。菩萨住如是法。名住欢喜地。以不动法故。诸佛子。菩萨摩诃萨。住是欢喜地。多喜多信。多清净多踊悦。多调柔多堪受。不好斗诤。不好恼乱众生。不好嗔恨。诸佛子。诸菩萨。住是欢喜地。念诸佛故生欢喜心。念诸佛法故生欢喜心。念诸菩萨摩诃萨故生欢喜心。念诸菩萨所行故生欢喜心。念诸波罗蜜清净相故生欢喜心。念诸菩萨与众殊胜故生欢喜心。念诸菩萨力不可坏故生欢喜心。念诸如来教化法故生欢喜心。念能为利益众生故生欢喜心。念一切佛一切菩萨所入智慧门方便故生欢喜心。诸佛子。菩萨复作是念。我转离一切世间界生欢喜心。入一切佛平等中生欢喜心。远离凡夫地生欢喜心。近到智慧地生欢喜心。断一切恶道生欢喜心。与一切众生作依止生欢喜心。近见一切诸佛生欢喜心。生诸佛境界生欢喜心。入一切诸菩萨数生欢喜心。我离一切惊怖毛竖等生欢喜心。所以者何。是菩萨摩诃萨。得欢喜地。所有诸怖畏。即皆远离。所谓。不活畏。恶名畏。死畏。堕恶道畏。大众威德畏。离如是等一切诸畏。何以故。是菩萨。离我相故。尚不贪身。何况所用之事。是故。无有不活畏也。心不悕望供养恭敬。我应供养众生供给所须。是故无有恶名畏也。离我见。无我相故。无有死畏。又作是念。我若死已生。必不离诸佛菩萨。是故无有堕恶道畏。我所志乐。无与等者。何况有胜。是故无有大众威德畏也。诸佛子。如是菩萨。离诸惊怖毛竖等事。诸佛子。是菩萨。以大悲为首。深大心坚固。转复勤修一切善根。所谓。以信心增上。多行净心。解心清净。多以信心。分别起悲愍心。成就大慈。心不疲懈。以惭愧。庄严。成就忍辱柔和。敬顺诸佛教法。信重尊贵。日夜常修善根无厌。亲近善知识。常爱乐法。求多闻无厌。如所观法正观。心不贪着。不求利养名闻恭敬。一切资生之物。心无悭吝。常生实心。无有厌足。贪乐一切智地。常欲得诸佛。力无畏不共法。求助诸波罗蜜法。离诸谄曲。如说能行。常行实语。不污诸佛家。不舍菩萨学戒。生萨婆若。心不动如大山王。不乐一切世间诸事。成就出世间善根。集助菩提分法。无有厌足。常求胜中胜道。诸佛子。菩萨摩诃萨。成就如是净治地法。名为安住菩萨欢喜地。菩萨如是。安住欢喜地。发诸大愿。生如是决定心。所谓。我当供养一切诸佛。皆无有余。一切供养之具随意供养。心解清净。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽供养一切劫中所有诸佛。以大供养具。无有休息。又一切诸佛。所说经法。皆悉受持。摄一切诸佛阿耨多罗三藐三菩提故。一切诸佛。所教化法悉皆随顺。一切诸佛法皆能守护。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽皆守护一切劫中一切佛法。无有休息。又一切世界。一切诸佛。从兜率天。来下入胎。及在胎中。初生时。出家时。成佛道时。悉当劝请转大法轮。示入大涅槃。我于尔时。尽往供养。摄法为首。三时转故。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽一切劫。奉迎供养一切诸佛。无有休息。又一切诸菩萨所行。广大高远。无量不可坏。无有分别。诸波罗蜜所摄。诸地所净。生诸助道法。有相无相道。有成有坏一切菩萨。所行诸地道。及诸波罗蜜本行。教化令其受行。心得增长。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽一切劫中。诸菩萨所行。以法教化成熟众生。无有休息。又一切众生。若有色若无色。若有想若无想。若非有想非无想。若卵生若胎生。若湿生若化生。三界系入于六道。在一切生处。名色所摄。为教化成熟一切众生。断一切世间道。令住佛法。集一切智慧。使无有余。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽一切劫。教化一切众生。无有休息。又一切世间。广狭极高。无量不可分别。不可移动。不可说粗细。正住倒住。首足相对。平坦圆方。随入如是世间。智如帝网。经幻事差别。如是十方。世界差别。皆现前知。发如是大愿。广大如法性。究竟如虚空。尽未来世。尽一切劫。如是世界。皆现前净知。无有休息。又以一切佛土。入一佛土。一佛土。入一切佛土。一一佛土。无量光明庄严。离诸垢秽。具足清净道。有无量智慧。众生悉满其中。常有诸佛大神通力。随众生心。而为示现。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽一切劫。清净如是国土。无有休息。又一切菩萨。同心同学。共集诸善无有怨嫉。俱缘一事。等心和合。常不相离。随意能现佛身。自于心中。悉能解知诸佛。神力智力。常得随意神通。悉能游行一切国土。一切佛会。皆现身相。一切生处。普生其中。有如是不可思议大智慧。具足菩萨行。发如是大愿。广大如法性。究竟如虚空。尽未来世。尽一切劫。行如是大智慧道。无有休息。又乘不退轮。行一切菩萨道。身口意业所作不空。众生见者。即必定佛法。闻我音声。即得真实智慧道。有见我者。心即欢喜。离诸烦恼。如大药树王。为得如是心。行诸菩萨道。发如是大愿。广大如法性。究竟如虚空。尽未来世。尽一切劫。行不退道。所作不空。无有休息。又于一切世界。皆得阿耨多罗三藐三菩提。于一毛头。示身入胎。出家坐道场。成佛道。转法轮。度众生。示大涅槃。现诸如来大神智力。随一切众生。所应度者。念念中。得佛道度众生。灭苦恼。知一切法。如涅槃相。以一音声。令一切众生。皆使欢喜。示大涅槃。而不断菩萨所行。示众生大智地。使知一切法皆是假伪。大智慧大神通。自在变化故。发如是大愿。广大如法性。究竟如虚空。尽未来际。尽一切劫。得佛道事。求大智慧。大神通等。无有休息。诸佛子。菩萨住欢喜地。以十愿为首。生如是等百万阿僧祇大愿。以十不可尽法。而生是愿。为满此愿。勤行精进。何等为十。一众生不可尽。二世间不可尽。三虚空不可尽。四法性不可尽。五涅槃不可尽。六佛出世不可尽。七诸佛智慧不可尽。八心缘不可尽。九起智不可尽。十世间道种法道种智慧道种不可尽。如众生尽。我愿乃尽。如世间尽。如虚空尽。如法性尽。如涅槃尽。如佛出世尽。如诸佛智慧尽。如心缘尽。如起智慧尽。如道种尽。我愿乃尽。而众生实不可尽。世间虚空。法性涅槃。佛出世。诸佛智慧。心缘起智道种。实不可尽。我是诸愿福德亦不可尽。诸佛子。菩萨决定。发是大愿。则得利安心。柔软心。调顺心。善心。寂灭心。和润心。直心。不乱心。不娆心。不浊心如是则成信者。乐心信相。分别功德。信诸佛本所行道。信行诸波罗蜜而得增长。信善入诸地得殊胜功德。信得成佛十力。信具足四无所畏。信不共法不可坏。信诸佛法不可思议。信诸佛力无中无边。信诸如来无量行门。信从因缘以成果报。举要言之。信诸菩萨普行诸佛功德智慧威神力等。诸佛子。菩萨作是念。诸佛正法。如是甚深。如是离相。如是寂灭。如是空。如是无相。如是无作。如是无染。如是无量。如是广大。如是难坏。而诸凡夫。心堕邪见。为无明痴冥。蔽其慧眼。常立憍慢幢。堕在渴爱网。随顺谄曲。常怀悭嫉。而作后身生处因缘。多集贪欲。嗔恚愚痴。起诸重业。嫌恨猛风。吹罪心火。常令炽盛。有所施作。皆与颠倒相应。欲流有流。无明流。见流相续起。心意识种于三界地生苦恼牙。所谓。名色和合。增长六入。诸入外尘。相对生触。触因缘故。生诸受。深乐受故生渴爱。渴爱增益故。生取。取增长故。复起后有。有因缘故。有生老死忧悲苦恼。如是因缘。集诸苦聚。众生受诸苦恼。是中无我无我所。无作者无受者。无知者。如草木瓦石。又亦如影。凡夫可愍。不知不觉。而受苦恼。菩萨于此。见诸众生不免诸苦。即生大悲智慧。是诸众生。我等应救。又欲令住毕竟佛道之乐。即生大慈智慧。菩萨摩诃萨。随顺如是大慈悲法。以深妙心。住在初地。于一切物。无所贪惜。尊重诸佛大妙智故。学行大舍。即时所有可施之物。尽能施与。所谓。谷麦库藏。金银摩尼珠。车磲。马瑙琉璃珊瑚琥珀。珂贝璎珞。严身之具。诸珍宝等。及象马车乘。辇舆人民。奴婢眷属。国土城邑。聚落庐舍。园林游观。妻子男女。一切所爱。皆悉舍与头目耳鼻。支节手足举身皆与。深重佛智故。而不贪惜。菩萨摩诃萨。住于初地。能行大舍。是菩萨。以大悲心大舍心。救一切众生故。转勤推求世间出世间利益胜事。心无疲懈。是故菩萨。生无疲倦功德。于诸经书。能自开解。是故。生知经书功德。得如是知经书智慧。善能筹量。应作不应作。于上中下众生。随宜而行。随有依止来亲近者。随力利益。是故菩萨。生世智功德。得世智功德。则知时知量。惭愧庄严。修习自利利彼之道。是故则生惭愧功德。如是功德行中。精勤修行。心不懈退。是精进不退功德。即时得堪受力。得堪受力已。勤行供养诸佛。随佛所说。如说而行。诸佛子。是菩萨。悉知生起如是清净地法。所谓。信慈悲舍不疲惓。知诸经书。善解世法。惭愧堪受力。供养诸佛。如所说行。又是菩萨。住欢喜地。以发愿故。广见于诸佛。数百数千数万亿那由他佛。菩萨见诸佛时。心大欢喜。深心爱敬。以菩萨乐具。供养诸佛。及供养僧。以是福德。皆回向阿耨多罗三藐三菩提。是菩萨。因供养诸佛故。生教化众生法。多以二摄。摄取众生。所谓。布施爱语。后二摄法。但以信解力。行未善通达。是菩萨。随所供养诸佛。教化众生。皆能受行清净地法。如是诸功德。皆自然回向萨婆若。转益明显。堪任有用。譬如佛子。金师炼金。随以火力。调柔可用。增益光色。如是菩萨。随供养诸佛。教化众生。受行清净诸地之法。此诸功德。皆自然回向萨婆若。转益明显。随意所用。又诸佛子。菩萨摩诃萨。于初地中。相貌得果。应从诸佛菩萨善知识所。咨受请问。成地之法。不应厌。废是菩萨。住初地中。应于诸佛菩萨善知识所。咨受请问第二地中相貌得果无有厌足。如是第三。第四第五。第六第七。第八第九。第十地中。相貌得果。应从诸佛菩萨善知识所咨受请问成十地法。无有废厌。是菩萨。悉应善知诸地逆顺法。善知诸地成坏。善知诸地相貌因果。善知诸地得舍。善知诸地清净行分。善知诸地从一地至一地行。善知诸地是处非是处。善知诸地转所住处。善知诸地初事后事差别。善知诸地得不退转相。乃至善知一切菩萨清净地法。善知入如来智地。诸佛子。如是诸菩萨。善知诸地相未发初地乃至十地。知无障阂。得诸地智慧光明故。能得诸佛智慧光明。诸佛子。如大商主。多将贾人。欲至大城。应先问道路。退还过咎。在道利害。未发初处。知道宿时。乃至善知到彼城事。能以智慧。思惟筹量。具诸资用。令无所乏。正导人众。得至大城。于险道中。免诸患难。身及诸人。皆无忧恼。诸佛子。菩萨摩诃萨。亦复如是。住初地。而善知。诸地逆顺法。乃至善知净一切菩萨清净地法。善知入如来智地

尔时菩萨。集大福德智慧资粮。为众生商主。随宜教化。令出生死险难恶处。示安隐道。乃至令住萨婆若智慧大城。无诸衰恼。是故诸佛子。菩萨摩诃萨。常应心不疲惓勤修诸地本行。乃至善知入如来智地。诸佛子。是名略说菩萨摩诃萨。入欢喜地门。广说则有无量百千万亿阿僧祇事。菩萨摩诃萨。住在此地。多作阎浮提王。豪贵自在。常护正法。能以布施。摄取众生。善除众生悭贪之垢。常行大施。而不穷匮所作善业。若布施若爱语。若利益若同事。是诸福德。皆不离念佛。不离念法。不离念诸菩萨摩诃萨伴。不离念诸菩萨所行道。不离念诸波罗蜜。不离念十地。不离念诸力无畏不共法。乃至不离念具足一切种智。常生是心。我当于一切众生之中。为首为胜。为大为妙。为上为无上。为导为将。为师为尊。乃至于一切众生中。为依止者。诸佛子。是菩萨摩诃萨。若欲舍家。勤行精进。须臾之间。于佛法中。便能舍家妻子五欲。得出家已。勤行精进。须臾之间。得百三昧。得见百佛。知百佛神力。能动百佛世界。能飞过百佛世界。能照百佛世界。能教化百佛世界众生。能住寿百劫。能知过去未来世各百劫事。能善入百法门。能变身为百。于一一身。能示百菩萨。以为眷属。若以愿力。自在示现。过于此数。若干百千万亿那由他不可计知。尔时金刚藏菩萨摩诃萨。欲重明此义。而说偈言

  若有诸众生　　厚修集善根
  成就于白法　　亲近于诸佛
  清净信力大　　随顺慈悲心
  如是人能发　　无量之佛智
  诸佛一切智　　无量力清净
  堪受力坚牢　　成就诸佛法
  悲心救世间　　净修诸佛国
  敷演转法轮　　发此无上愿
  一念知三世　　而无有别异
  种种时差别　　以示于世间
  略说则尽求　　诸佛之功德
  发于广大心　　犹若如虚空
  悲心智慧首　　方便合修行
  净信深心故　　其力无有量
  心向无障碍　　而不随他教
  同诸佛平等　　而生于大心
  诸佛子当生　　如是之实心
  即离凡夫行　　入于佛所行
  即生如来家　　无有可讥嫌
  则同于诸佛　　必成无上道
  生如是心时　　即便得初地
  其心不可动　　犹若如山王
  是菩萨便有　　大喜相显现
  其心常清净　　堪受于大事
  心不乐斗讼　　不好恼众生
  无有嗔恨心　　乐惭愧恭敬
  又习行直心　　守护于诸根
  常念救世间　　念求诸佛智
  心生于欢喜　　我当得此事
  得于欢喜地　　即过五恐怖
  不活畏死畏　　及与恶名畏
  三恶道怖畏　　大众威德畏
  以不贪着我　　及与我所故
  是诸佛子等　　远离诸怖畏
  常行慈悲心　　恒有信恭敬
  惭愧功德备　　昼夜增善法
  乐功德实利　　不乐于诸欲
  如有所闻法　　能常善思惟
  无有贪着行　　断诸利养心
  常乐于菩提　　一心求佛智
  行诸波罗蜜　　离于谄曲心
  随说而能行　　安住实语中
  不污诸佛家　　不舍菩萨学
  远世间事业　　乐利于世间
  求善法无厌　　精进转增益
  诸菩萨如是　　好乐诸功德
  而发于大愿　　求欲见诸佛
  护法至佛所　　行菩萨妙行
  化一切众生　　净一切佛土
  我佛国土中　　满诸大菩萨
  诸菩萨同心　　见闻皆不空
  一切微尘中　　诸佛成佛道
  发于如是等　　无量无边愿
  是愿无穷尽　　如虚空众生
  法性世涅槃　　诸佛出智慧
  心缘起智种　　我愿如是住
  如是发大愿　　心柔软调顺
  能信佛功德　　而观于众生
  知从因缘起　　则生慈悲心
  即于苦众生　　我当救度之
  为是众生故　　而行种种施
  所谓妙国土　　上妙诸珍宝
  象马及车乘　　眷属与人民
  头目及手足　　肌肉施无悔
  求种种经书　　心无有疲惓
  得解其义趣　　能随世而行
  惭愧堪受心　　渐令得增长
  能以恭敬心　　供养无量佛
  智者于日夜　　如是常修行
  善根得明了　　犹如成炼金
  菩萨住是地　　能了知十住
  展转修行时　　无有诸障碍
  譬如贾客主　　欲利诸商人
  先问道路中　　诸险艰难事
  菩萨住初地　　应知诸地行
  而无有障碍　　能至于佛地
  住是初地中　　多作阎浮王
  善知于诸法　　常行慈悲心
  如法而化导　　一切皆信敬
  劝令行布施　　以求佛智慧
  菩萨若舍国　　佛法中出家
  勤行于精进　　即得百三昧
  及见百诸佛　　震动百国土
  光明照百国　　飞行亦如是
  化百土众生　　入于百法门
  念知百劫事　　示现百种身
  能以百菩萨　　眷属而示现
  若以其愿力　　过是数无量
  今明初地义　　但以略解说
  若欲广说者　　亿劫不能尽
  是初菩萨地　　名之为欢喜
  利益众生者　　今已分别说

    离垢地第二

  一切菩萨众　　闻说上地义
  其心皆清净　　欢喜无有量
  各于所坐处　　踊住虚空中
  脱身上妙衣　　以散金刚藏
  咸皆称赞言　　善哉金刚藏
  大智无所畏　　善说菩萨地
  解脱月大士　　知众心清净
  欲闻第二地　　相貌之所说
  即请金刚藏　　大智愿解说
  第二地相貌　　一切皆欲闻

尔时金刚藏菩萨摩诃萨。语解脱月菩萨言。佛子。诸菩萨摩诃萨。已具足初地。欲得第二地者。当生十心。何等为十。一柔软心。二调和心。三堪受心。四善心。五寂灭心。六真心。七不杂心。八无贪吝心。九快心。十大心。若诸菩萨摩诃萨。已具足初地。欲得二地者。先当生是十心。诸佛子。菩萨欲住是离垢地。从本已来。离一切杀生。舍弃刀杖。无嗔恨心。有惭有愧。于一切众生。起慈悲心。常求乐事。尚不恶心恼于众生。何况粗恶。离诸劫盗。资生之物。常自满足。不坏他财。若物属他。他所受用。他所摄者。于是物中。一草一叶。不与不取。何况过者。离于邪淫。自足妻色。不求外欲。属他女人。尚不生心。何况从事。离于妄语。常真语实语。谛语随语。不作憎恶妄语。乃至梦中。尚不妄语。何况故作妄语。离于两舌。无破坏心。此闻不向彼说。彼闻不向此说。于斗诤离散人中。常好和合。离于恶口。所有言语。粗[麩-夫+黃]苦恶。令他嗔恼。又以嗔慢。令他怖畏恼热。不爱不喜。自坏其身。亦坏于他。如是等语。皆悉舍离。所有言语。甚可喜乐。美妙悦耳。能化人心。和柔具足。多人爱念。能令他人欢喜悦乐。常出如是之语。离于绮语。常自守护所可言说。应作不作。常知时语实语。利益语顺法语。筹量语不为戏乐语。乃至戏笑。尚不绮语。何况故作。不贪他物。若有属他。他所贪着。他所摄用。不作是念。我当取之。离嗔害心。嫌恨心。迫热心等。常于众生。求好事心。爱润心。利益心。慈悲心。离于占相。习行正见。决定深信罪福因缘。离于谄曲。诚信三宝。生决定心。菩萨如是。常护善道。作是思惟。众生堕诸恶道者。皆由十不善道因缘。我今当自住十善法。亦当为人说诸善法。示正行处。何以故。若人自不行善。为他说法。令住善者。无有是处。又是菩萨。复深思惟。行十不善道因缘故。则堕地狱畜生饿鬼。行十善道因缘故。则生人处。乃至有顶处生。又是十善道。与智慧和合修行。心劣弱者。乐少功德。厌畏三界。大悲心薄。从他闻法。至声闻乘。复有人。行是十善道。不从他闻。自然得知。不能具足大悲方便。而能深入众因缘法。至辟支佛乘。复有人行是十善道。清净具足。其心广大无量无边。于众生中。起大慈悲。有方便力。志愿坚固。不舍一切众生故。求佛大智慧故。清净菩萨诸地故。能净诸波罗蜜故。能入深广大行。又能清净行是十善道。乃至能得佛十力。四无所畏。四无碍智。大慈大悲。乃至具足一切种智。集诸佛法。是故我等。应行十善道。常求一切智慧。是菩萨。复作是思惟。此十不善道。上者地狱因缘。中者畜生因缘。下者饿鬼因缘。于中杀生之罪。能令众生堕于地狱畜生饿鬼。若生人中。得二种果报。一者短命。二者多病。劫盗之罪。亦令众生。堕于地狱畜生饿鬼道。若生人中。得二种果报。一者贫穷。二者共财不得自在。邪淫之罪。亦令众生堕于地狱畜生饿鬼道。若生人中。得二种果报。一者妇不贞良。二者得不随意眷属。妄语之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者多被诽谤。二者恒为多人所诳两舌之罪。亦令众生堕三恶道。若生人中。得二种果报。一者得弊恶眷属。二者得不和眷属。恶口之罪。亦令众生堕三恶道。若生人中。得二种果报。一者常闻恶音。二者所可言说恒有诤讼。绮语之罪。亦令众生堕三恶道。若生人中。得二种果报。一者所有言语。人不信受。二者有所言说。不能分了。贪欲之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者多欲。二者无有厌足。嗔恼之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常为他人。求其长短。二者常为他所恼害。邪见之罪。亦令众生。堕三恶道。若生人中。得二种果报。一者常生邪见之家。二者其心谄曲。诸佛子。如是十不善道。皆是众苦大聚因缘。菩萨复作是念。我等何故。不远离是十不善道行十善道。亦令他人行此善道。如是念已。即离十不善道。安住十善道。亦令他人。发心住于善道。是菩萨。尔时于一切众生中。生安隐心。乐心慈心。悲心怜愍心。利益心守护心。师心大师心。我所有心。作是念。是诸众生。堕于邪见。随逐邪心。行邪险道。甚可怜愍。我等应令是众生。住正见道。如实法中。是诸众生。常共嗔恨斗诤。分别彼我。我等应令是众生。住无上大慈中。是诸众生。无有厌足。常贪他人财物。恒以邪命自活。我等应令是众生。住于清净身口意业。是诸众生。随逐贪欲嗔恚愚痴因缘。常为种种烦恼大火之所烧然。不求得出方便。我等应令是众生。灭诸烦恼大火。安置清凉之处。是诸众生。常为无明黑闇所覆。入大黑闇。远离智慧光明。入于生死大险道中。随逐种种邪见。我等应令是众生。使得无碍清净慧眼。以是眼故。知一切法如实相。得不随他教。一切如实无障碍智。是诸众生。堕在生死险道中。将堕地狱畜生饿鬼深坑。入恶邪见网中。为种种愚痴丛林所覆。随逐虚妄邪道迳路。常为愚痴之所盲冥。远离有智导师。非是出道。谓为出要。堕恶魔道。随顺魔意。远离佛意。我等应令是众生。度于生死险道艰难。安处令住一切智人无畏大城。无诸衰恼。是诸众生为诸烦恼暴水所没。常为欲流有流。见流无明流所漂。常随生死。相续不绝。入大爱河。为诸烦恼势力所食。不能得求出要之道。常为欲觉嗔觉恼觉恶虫所害。又为身见水虫罗刹所执。入于五欲深流洄澓诸难之中。为喜爱淤泥之所染污。我慢陆地之所焦枯。无所归趣。于十二入怨贼聚落。不能得出。不遇导师能正度者。我等应于是众生。生大慈悲。以大善根力。而拔济之。得安隐处。离诸惊怖隐没。住一切智慧宝洲。是诸众生。深心贪着。多有忧悲苦恼患难。憎爱所缚。欲械所系。入于三界无明稠林。我等应令是众生。远离一切三界所著。令住离相无碍涅槃。是诸众生。深着我我所。于五阴樔窟。不能自出。常随四倒。依六入空聚。为四大毒蛇之所侵害。为诸烦恼众贼所杀。受此无量诸苦恼者。我等应令是众生。离一切贪着。令住空无我智道。所谓。涅槃断一切障碍。是诸众生。其心狭劣。乐于小法。远离无上一切智慧。以是贪着小乘心故。不求无底大乘出法。我等应令是众生。住广大心。无量无边诸佛法中。所谓无上大乘。诸佛子。是菩萨。如是随顺持戒力。善能广生大慈悲心。是菩萨。住离垢地。得见数百佛。数千万亿那由他诸佛。见诸佛已。以衣被饮食。卧具医药。资生之物。供养诸佛。于诸佛所。生恭敬心。复受十善道。受已乃至得阿耨多罗三藐三菩提。终不中失。是菩萨。若干多百多千。乃至多百千万亿劫。远离悭贪破戒垢故。净修布施持戒。诸佛子。譬如成炼真金。在矾石中。诸一切垢尽。转复明净。菩萨亦如是。住是离垢菩萨地中。多百多千。乃至无量百千万劫离悭贪破戒垢故。净修布施持戒。菩萨尔时。于四摄法中。爱语偏多。十波罗蜜中。戒波罗蜜偏胜。余波罗蜜。非不修集。但随地增长。诸佛子。是名菩萨摩诃萨第二离垢地。菩萨住是地中。多作转轮圣王。为大法王。广得法力。七宝成就。有力自在。能除一切众生悭贪破戒之垢。以善方便。令众生住于十善道中。为大布施。而不穷尽所作善业。若布施若爱语。若利益若同事。皆不离念佛。不离念法。不离念诸菩萨摩诃萨伴。不离念诸菩萨所行道。不离念诸波罗蜜。不离念十地。不离念诸力无畏不共法。乃至不离念具足一切种智。常生是心。我当于一切众生之中。为首为胜。为大为妙。为上为无上。为导为将。为师为尊。乃至于一切众生中。为依止者。诸佛子。是菩萨摩诃萨。若欲舍家勤行精进。须臾之间。于佛法中。便能舍家妻子五欲。得出家已。勤行精进。须臾之间。得千三昧。得见千佛。知千佛神力。能动千佛世界。能飞过千佛世界。能照千佛世界。能教化千世界众生。能住寿千劫。能知过去未来世各千劫事。能善入千法门。能变身为千。于一一身。能示千菩萨。以为眷属。若以愿力自在示现。过于此数。若干百千万亿那由他不可计知。尔时金刚藏菩萨摩诃萨。欲重明此义。而说偈言

  菩萨柔软心　　调和堪受心
  善心寂灭心　　真心不杂心
  无有贪吝心　　快心与大心
  得是十心已　　入于第二地
  菩萨住是地　　成就诸功德
  常离于杀生　　不恼于一切
  常离于劫盗　　不生邪淫心
  实语不两舌　　不恶口绮语
  他人所有物　　不生于贪心
  不恼于众生　　直心行正见
  无有憍慢心　　亦无谄曲心
  柔软不放逸　　护持诸佛教
  所有剧苦恼　　地狱与畜生
  饿鬼炽然身　　皆从恶心有
  我今已永离　　如是诸恶事
  行于真实理　　寂灭之善法
  从人至有顶　　所有受乐处
  禅乐三乘乐　　皆从十善生
  如是思惟已　　心常不放逸
  身自持净戒　　亦教人令持
  遍观诸众生　　种种受苦恼
  如是愍念已　　转生深悲心
  凡夫甚可愍　　堕在诸邪见
  心多怀嗔恨　　常好起诤讼
  常乐于五欲　　贪求无有厌
  起三毒因缘　　我应度此等
  深覆愚痴闇　　坠生死险道
  入大邪见网　　坠于世笼槛
  常为诸魔贼　　烦恼之所坏
  此等甚可愍　　我应度脱之
  没深烦恼水　　四流所漂漫
  具受于三界　　百种诸苦毒
  住五阴深樔　　生我我所心
  我为度此苦　　当勤修行道
  舍无上佛慧　　生于下劣心
  令住佛大智　　发无量精进
  菩萨住此地　　集无量功德
  得值遇诸佛　　承事而供养
  以是因缘故　　善根转明净
  犹如好真金　　炼之以矾石
  佛子住此地　　常作转轮王
  令诸众生等　　住于十善道
  从初发心来　　所修集诸福
  愿以救世间　　令得佛十力
  若欲舍王位　　出家行学道
  勤心行精进　　得入千三昧
  得见数千佛　　供养听受法
  菩萨住此地　　能示如是事
  若以其愿力　　示诸神通事
  度脱于众生　　过此数无量
  常为诸世间　　勤求好事者
  具足解说此　　第二地已竟

十住经卷第一十住经卷第二

        后秦三藏鸠摩罗什译

    明地第三

  诸菩萨闻是　　不可思议行
  心皆大欢喜　　恭敬无有量
  即时虚空中　　雨众名华香
  如云而垂下　　供养金刚藏
  咸赞言善哉　　善哉金刚藏
  善说诸大人　　护持净戒行
  于诸众生中　　深有怜愍心
  敷演解说是　　第二地行处
  菩萨微妙行　　真实无有异
  是诸菩萨等　　清净之行处
  为一切众生　　常求诸好事
  第二净明地　　今已解说竟
  天人恭敬者　　愿说第三地
  善示智所作　　菩萨之所行
  愿说诸大人　　云何行布施
  持戒及忍辱　　精进行禅定
  智慧与方便　　并及慈悲心
  云何行是法　　清净于佛行
  解脱月菩萨　　语金刚藏言
  菩萨至三地　　当以何等心

金刚藏菩萨摩诃萨。语解脱月菩萨言。佛子。诸菩萨摩诃萨。深净心行第二地已。欲得第三地。当以十心得入第三地。何等为十。一净心。二猛利心。三厌心。四离心。五不退心。六坚心。七明盛心。八无足心。九快心。十大心。诸佛子。是菩萨摩诃萨。以是十心。得入第三地。能观一切有为法如实相。所谓。无常苦空。无我不净。不久败坏。不可信相。念念生灭。又不生不灭。不从前际来。不去至后际。现在不住。菩萨如是。观一切有为法真实相。知此诸法。无作无起。无来无去。而诸众生忧悲苦恼。憎爱所系。无有停积。无定生处。但为贪恚痴火所然。增长后世苦恼火聚。无有实性。犹如幻化。见如是已。于一切有为法。转复厌离。趣佛智慧。是菩萨。知如来智慧不可思议。不可称量。有大势力。无能胜者。无有杂相。无有衰恼忧悲之苦。能至无畏安隐大城。不复转还。能救无量苦恼众生。如是见知佛智无量。见有为法无量苦恼。于一切众生。转生殊胜十心。何等为十。众生可愍。孤独无救。贫穷无所依止。三毒之火。炽然不息。闭在三有牢固之狱。常住烦恼诸恶刺林。无正观力。于善法中。欲乐心薄。失诸佛妙法。而常随顺生死水行。惊畏涅槃。是菩萨。见众生如是多诸衰恼。发大精进。是诸众生。我应救。我应解。应令清净。应令得脱。应着善处。应令安住。应令欢喜。应知所宜。应令得度。应使灭苦。菩萨如是。善远离一切有为法。深念一切众生。见诸佛一切智有无量利益。即时欲具佛智慧救度众生故。勤行菩萨道。作是思惟。以何因缘。以何方便。是诸众生。堕在大苦诸烦恼中。当拔出之。使得永住毕竟常乐。即时知住无碍解脱智慧中者。乃可得此是无碍智慧解脱不离通达诸法如实智。无行行慧。如是智慧之明。从何而得。当知不离多闻决定智慧。复作是念。无碍解脱等诸佛法。以何为本。不离闻法为本。菩萨如是念已。一切求法时。转加精进。日夜常乐听法。无有厌足。心无休息。喜法爱法。依法随法。重法究竟法。归法救法。随顺行法。菩萨如是。方便求法。所有。珍宝。财物金银等库藏无所匮惜。于此物中。不生难想。但于说法者。生难遭想。为求法故。于内外物。无不能舍世间所有可布施者。所谓。国土人民眷属。田业财物。摩尼宝珠。金银库藏。象马辇舆。众宝璎珞。诸严身之具。妻子男女。及支节手足。耳目鼻舌。举身施与。无所爱惜。又为求法故。于说法者。尽心恭敬。供养给侍。破除憍慢。我慢大慢。诸恶苦恼。无理等事。悉能忍受。深求法故。若得一句。未曾闻法。胜得满三千大千世界珍宝。得闻正法一偈。胜得转轮圣王。释提桓因。梵天王处。无量劫住。是菩萨。若有人。来作是言。我与汝佛所说法一句。能净菩萨所行道。令汝得闻。若能入大火坑受大苦者。当以相与。是菩萨作是念。我受一句法故。尚于三千大千世界火坑。从梵天投下。何况堕小火坑。我等求法应尽受一切诸地狱苦。犹应求法。何况人中。诸小苦恼。为求法故。发如是心。又如所闻法。心常喜乐。悉能正观。是菩萨。闻诸法已。降伏其心。于空闲处。心作是念。如说行者。乃得佛法。不可但以口之所言。菩萨如是。能住明地。即离诸欲恶不善法。有觉有观。离生喜乐。入初禅。灭觉观。内清净心一处无觉无观。定生喜乐。入二禅。离喜故。行舍心念安慧身受乐。诸贤圣。能说能舍。常念受乐。入三禅。断苦断乐故。先灭忧喜故。不苦不乐。行舍念净。入四禅。是菩萨。过一切色相。灭一切有对相。不念一切别异相故知无边虚空。即入虚空无色定处。过一切虚空相。知无边识。即入识无色定处。过一切识相。知无所有。即入无所有。无色定处。过一切无所有处。知非有想非无想安隐。即入无色非有想非无想处。但随顺诸法行故。而不乐着。是菩萨。以慈心高广无量。无嗔无恨无恼害。以信解力。遍满一方。二方。三方四方。四维上下。亦复如是。悲心喜心舍心。高广无量。无嗔恨无恼害。以信解力。遍满一方。第二三。四方四维上下。亦复如是。是菩萨。有种种神通力。能动大地。一身为多身。多身为一身。现灭还出。石壁山障。皆能彻过。如行虚空。于虚空中。加趺而去。犹如飞鸟入出于地。如水无异。履水如地。身出烟焰。如大火聚。日月有大神德威力。而能以手。扪摸摩之。身力自在。乃至梵世。是菩萨。以清净天耳。过于人耳。悉闻人天音声远近。是菩萨。以他心智。如实知他心。染心如实知染心。离染心如实知离染心。嗔心离嗔心。痴心离痴心。垢心离垢心。小心大心。散乱心如实知散乱心。定心不定心。缚心解心。有上心无上心。如实知有上心无上心。如是以自心知他心。是菩萨。念知宿命。诸所生处。所谓。一世二世。三四五世。乃至十二十三十。四十五十。乃至百世千世。万世百千万亿那由他世。一劫二劫。乃至百千万亿那由他无量劫数。其中诸劫。无量成坏。于诸劫中。所经因缘。悉能念知。我生彼处。如是种族。如是姓名。如是饮食。如是苦乐。如是久住。我于彼死。生于此间。于此间死。生于彼间。如是种种。相貌因缘。悉能念知。是菩萨。天眼清净过于人眼。见众生生死。形色好丑善恶。贫贱富贵。趣善恶道。随业受报。皆如实知。所谓是诸众生。成就身恶业。成就口恶业。成就意恶业。距逆贤圣。受邪见教。起罪业因缘故。身死堕恶道。生在地狱。是诸众生。成就善身业。善口业。善意业。不逆贤圣。信受正见。行善业因缘故死后生善处天上。是菩萨。于诸禅定。解脱三昧。能入能出。而不随生。但见何处。有助菩提法处。以愿力故。能生其中。是菩萨。住明地中。见数百千万亿那由他诸佛。恭敬供养尊重赞叹。衣服饮食。卧具医药。亲近诸佛。听受经法。听受法已。随力而行。是菩萨。尔时观诸法不生不灭众缘而有。于百千万亿劫所集欲缚。渐得微薄。一切有缚。一切无明缚。皆悉微薄。不复积集。不积集故。断于邪贪邪嗔邪痴。诸佛子。譬如真金。巧师炼治。转更精好。光明倍胜。菩萨亦如是。住在明地。不集三缚故。断于邪贪邪嗔邪痴。诸善根。转增明净。是菩萨。忍辱心柔软心。美妙心不坏心。不动心不浊心。不高心不下心。一切所作不望报心。他少有作当生报心。不谄曲心。不染乱心。转胜明净。尔时菩萨。于四摄法中。爱语利益偏多。十波罗蜜中。忍辱波罗蜜。精进波罗蜜转多。余助菩提法。皆转明净。诸佛子。是名诸菩萨第三明地。菩萨摩诃萨。住是地中。多作释提桓因。智慧猛利。能以方便因缘。转诸众生。令离淫欲。所作善业。若布施若爱语。若利益若同事。皆不离念佛念法。乃至不离念具足一切种智。常生是心。我当何时于众生中。为首为尊。乃至于一切众生。为依止者。是人若欲勤加精进。于须臾间。能得十万三昧。乃至能示十万菩萨。以为眷属。随其愿力。神通自在。不可算数。若干百千万亿那由他劫。不可计知。尔时金刚藏菩萨。欲令此义转明故。而说偈言

  菩萨以是心　　能得第三地
  净心猛厌心　　离心不退心
  坚心堪受心　　快心及大心
  以如是等心　　得入于三地
  智者住明地　　观有为作法
  不净无常苦　　无我坏败相
  无有牢固性　　不久念念灭
  如是思惟知　　无有来去相
  见诸有为法　　如病如痈疮
  爱心所缠缚　　生诸忧悲苦
  但为贪恚痴　　猛火所焚烧
  从无始世来　　炽然常不息
  即时于一切　　三界生厌离
  恶贱有为法　　心无所贪着
  但求诸佛智　　无量无边限
  甚深难思议　　清净无诸苦
  如是见佛智　　无诸苦恼已
  哀愍诸众生　　贫穷无福慧
  三毒火常然　　无有救护者
  堕在地狱中　　百种苦所切
  放逸凡夫人　　没诸烦恼聚
  盲冥无所见　　失诸佛法宝
  常随生死水　　无怖空怖畏
  我于是众生　　当勤度脱之
  精进求智慧　　为作饶益者
  思惟何方便　　可以得救护
  唯有诸如来　　深妙无碍智
  此智何为因　　唯从智慧生
  思惟是智慧　　但从多闻生
  如是筹量已　　勤求多闻法
  日夜常精进　　听受无厌惓
  读诵爱乐法　　唯法以为贵
  为欲求法故　　以诸珍宝等
  所亲爱妻子　　随意诸眷属
  国土及城邑　　资生诸好物
  欢喜而施与　　心无所恋惜
  头目耳鼻舌　　牙齿及手足
  支节身血肉　　心肝及髓脑
  以此等施人　　犹不以为难
  若得闻正法　　是为最甚难
  假令有一人　　语此菩萨言
  汝今若能入　　是大猛火聚
  然后当与汝　　诸佛所说法
  闻已即欢喜　　自投于火聚
  设使大千界　　火聚满其中
  须弥梵世下　　不足以为难
  若为求一句　　诸佛所说法
  救诸苦恼者　　得之甚为难
  始从初发心　　乃至成佛道
  我于其中间　　尽此诸劫数
  为欲求诸法　　备受阿鼻苦
  何况于人间　　小小诸苦恼
  以听法因缘　　能得正忆念
  正忆念因缘　　能生诸禅定
  深妙等三昧　　及五神通事
  次第皆能起　　自在不随生
  菩萨住是地　　能以决定心
  多供养诸佛　　听受所说法
  断邪爱恚等　　余烦恼微薄
  犹如成炼金　　调和得其所
  菩萨住是地　　功德藏充满
  多作忉利王　　自在化淫欲
  爱佛功德故　　化导无量众
  悉能令得住　　无上佛道中
  菩萨住是地　　能以柔软心
  勤行于精进　　得百千三昧
  悉得见诸佛　　相好庄严身
  其心转猛利　　愿力者殊胜
  常为诸众生　　勤求好事者
  分别解说此　　第三明地已

    焰地第四

  诸佛子闻说　　如是地相义
  深妙无有量　　心皆大欢喜
  散众名花香　　供养于如来
  地及大海水　　悉皆大震动
  天诸婇女等　　于上虚空中
  同以微妙音　　歌颂此上法
  他化自在王　　闻以大欢喜
  雨摩尼珠宝　　以散于佛上
  踊跃称赞言　　善哉佛出世
  功德藏流布　　利益于我等
  我今闻说此　　菩萨地相义
  是事百千劫　　难闻而得闻
  愿更说后地　　利益诸天人
  佥皆喜欲闻　　得地诸行相
  解脱月菩萨　　重请金刚藏
  愿为诸菩萨　　说至四地行

尔时金刚藏菩萨摩诃萨。语解脱月菩萨言。佛子。诸菩萨摩诃萨。具足清净行第三地已。欲得第四地者。当以十法明门。得入此四地。何等为十。一思量众生性。二思量法性。三思量世界性。四思量虚空性。五思量识性。六思量欲界性。七思量色界性。八思量无色界性。九思量快信解性。十思量大心性。诸佛子。菩萨。以此十法明门。能从三地。入第四地。诸佛子。菩萨摩诃萨。若得第四菩萨焰地。即于如来家。转有势力。得内法故。有十种智。何等为十。一不退转心。二于三宝中得不坏信清净毕竟智。三修习观生灭。四修习诸法本来不生。五常修习转还世间行。六修习知业因缘故有生。七修习分别生死涅槃门差别。八修习众生业差别。九修习前际后际差别。十修习现在常灭不住行。是十智心。则生佛家。转得势力。复次佛子。菩萨摩诃萨。住是菩萨第四地。观内身循身观。精勤一心。除世间贪忧。观外身循身观。精勤一心。除世间贪忧。观内外身循身观。精勤一心。除世间贪忧。观内受外受内外受。内心外心内外心。内法外法内外法。循法观。精勤一心。除世间贪忧。是菩萨。未生恶不善法。为不生故。欲生勤精进。发心正断。已生诸恶不善法。为断故。欲生勤精进。发心正断。未生诸善法。为生故。欲生勤精进。发心正行。已生诸善法。为住不失。修增广故。欲生勤精进。发心正行。是菩萨。修行四如意分。欲定断行成就。修如意分。依止厌。依止离。依止灭。回向于舍。精进定断行成就修如意分。心定断行成就。修如意分。思惟定断行成就。修如意分。依止厌离灭。回向于舍。是菩萨。修行信根。依止厌离灭。回向于舍。精进根念根定根。修行慧根。依止厌离灭。回向于舍。是菩萨。修行信力。依止厌离灭。回向于舍。精进力念力定力。修行慧力。依止厌离灭。回向于舍。是菩萨。修行念觉分。依止厌离灭。回向于舍。择法觉分。精进觉分。喜觉分除觉分定觉分。修行舍觉分。依止厌离灭。回向于舍。是菩萨。修行正见。依止厌离灭。回向于舍。正思惟正语。正业正命。正精进正念。修行正定。依止厌离灭。回向于舍。是菩萨。以不舍众生心故行。以本愿力故。大悲为首。大慈合行。为摄一切智。为庄严佛国。为具佛诸力无畏。不共法。三十二相。八十种好。具足音声。为随顺佛深解脱。为思惟大智慧方便故行。诸佛子。诸菩萨摩诃萨。住菩萨焰地。所有身见着等。着我。着众生。着人寿者。知者见者。着五阴十二入十八界。所起屈伸卷舒出没。推求心所行。爱着宝重所见。为归为洲。皆悉断灭。是菩萨。转倍精进。慧方便所生助道法。随所修行。心转柔和。堪任有用。心无疲惓。转求上法。增益智慧。救一切世间。随顺诸师。恭敬受教。如所说行。是菩萨。尔时知恩知报恩。心转和善。同止安乐。直心软心。无有邪曲。行正定行。无有憍慢。则易与语。随顺教诲。得说者意。如是具足善心软心。寂灭心忍辱心。净地诸法。思惟修行。是菩萨。尔时成不转精进者。不舍精进。不坏精进。不厌精进。不惓精进。广大精进。无边精进。猛利精进。无等等精进。救一切众生精进。分别是道非道精进。是菩萨。心志清净。不失深心。信解明利。诸善根增长。远离世间垢浊。不信疑悔等。皆已灭尽。无疑无悔。现前具足。于一切佛大信解事中。不厌不舍。自然习乐。无量之心。常现在前。菩萨住是第四焰地。能见诸佛数百数千数千万亿那由他佛。供养恭敬。尊重赞叹。衣服饮食。卧具医药。亲近诸佛。一心听法。听受法已。能信奉持。多于佛所。出家修道。是菩萨。乐心深心。清净信解平等。转更明了。住寿多劫。若干百千。万亿那由他劫。善根转胜明利。诸佛子。如上真金。以为庄严。余金不及。如是诸菩萨摩诃萨。住此菩萨焰地。诸善根转增明利。下地菩萨。所不能及。譬如摩尼珠。光明清净。能照四方。余宝不及。雨渍水浇。光明不灭。菩萨住焰地中。下地菩萨所不能及。一切诸魔。及诸烦恼。皆不能坏其智慧。诸佛子。是名略说诸菩萨摩诃萨第四焰地。菩萨摩诃萨。住是地中。多作须夜磨天王。多教化众生。破于我心。所作善业。若布施若爱语。若利益若同事。皆不离念佛。不离念法。不离念诸菩萨摩诃萨为伴。乃至不离念具足一切种智。常生是心。我当何时于一切众生中。为首为尊。乃至于一切众生中。为依止者。是菩萨摩诃萨。若欲如是勤行精进。须臾之间。得百亿三昧。乃至示现百亿菩萨。以为眷属。若以愿力。自在示现。过于此数。若干百千万亿那由他不可计劫。尔时金刚藏菩萨。欲重明此义。而说偈言

  诸菩萨具足　　修治明地已
  观诸众生性　　法性世间性
  虚空性识性　　三界性信解
  深心清净故　　得入第四地
  即于如来家　　增长得势力
  不退于佛道　　三宝不坏信
  观生灭无作　　知世间转行
  从业而有生　　生死涅槃异
  知众生诸业　　观法先后际
  不住常灭相　　佛家生势力
  诸大菩萨等　　得如是法已
  怜愍诸众生　　习身受心法
  内外四念处　　依止于厌离
  亦依止寂灭　　回向于涅槃
  除灭恶法故　　善法得增长
  习行四正法　　修四如意分
  习行于五根　　及以修五力
  修习七觉意　　行于八圣道
  修习如是法　　皆为众生故
  本愿之所助　　慈悲心为首
  求觅一切智　　为净诸佛土
  成十力功德　　无畏不共法
  诸音声言说　　甚深妙道法
  及无碍解脱　　大智慧方便
  从身见为首　　六十二见等
  众生见人见　　命者知者见
  于诸阴界入　　之所贪着处
  得是第四地　　皆悉已除断
  随断烦恼业　　其心亦随净
  诸所作善业　　皆为救世间
  菩萨柔软心　　常不为放逸
  堪用心直心　　求利众生心
  如此所求事　　皆为无上道
  大智慧职位　　利益世间故
  深心敬养师　　如说乐修行
  知恩报恩者　　易化无嗔恨
  无有邪曲心　　柔和同止乐
  修习如是法　　精进不退转
  菩萨住是地　　深心及直心
  净心与信解　　皆转得明净
  增长诸善根　　垢浊疑悔法
  如是等诸事　　皆悉得除灭
  诸菩萨住是　　第四焰地中
  得值无量佛　　咨受所说法
  于是诸佛所　　出家难沮坏
  如真金庄严　　余金所不及
  菩萨住是地　　诸功德深心
  智慧及方便　　所行清净道
  乃至千亿魔　　皆所不能坏
  如真妙明珠　　不为水雨败
  菩萨住是地　　天人所供养
  多作夜摩王　　能转诸邪见
  所作诸善业　　皆为佛智慧
  其心常坚固　　不可得动转
  若勤行精进　　得百亿三昧
  能见百亿佛　　愿力则过是
  如是第四地　　清净名为焰
  无量福慧者　　今已解说竟

    难胜地第五

  诸菩萨闻是　　第四地行法
  心皆大欢喜　　踊跃无有量
  雨天众宝花　　雰雰如雪下
  咸赞言善哉　　金刚藏大士
  他化自在王　　与诸眷属等
  于上虚空中　　心皆大欢喜
  放众妙光明　　作天诸伎乐
  歌叹佛功德　　并及菩萨众
  天诸婇女等　　各以清妙音
  同声称赞佛　　而说如是言
  世尊久远来　　勤苦所求愿
  无上正真道　　于今始乃得
  利益天人者　　久乃今得见
  释迦牟尼佛　　今至于天宫
  从久远已来　　今始异相动
  久远世已来　　今始放妙光
  众生从久来　　今始得安乐
  久来方得闻　　大慈悲德音
  度诸功德岸　　久远今乃值
  圣王能悉破　　憍慢我心等
  无比可供养　　而今得供养
  能开诸天道　　使得一切智
  世尊甚清净　　无量如虚空
  不染于世法　　如莲花在水
  处世最高大　　犹如大海中
  须弥金山王　　是故欢喜礼
  如是诸天女　　各以众妙音
  敬心歌颂已　　默然而观佛
  解脱月菩萨　　请金刚藏言
  菩萨得五地　　相貌之因缘

金刚藏菩萨摩诃萨。语解脱月菩萨言。佛子。诸菩萨摩诃萨。已具足第四地。欲得第五地。以十平等心。能入第五地。何等为十。一过去佛法平等。二未来佛法平等。三现在佛法平等。四戒净平等。五心净平等。六除见疑悔净平等。七知道非道净平等。八行知见净平等。九诸菩提分法转胜净平等。十等化众生净平等。诸佛子。诸菩萨摩诃萨。以是十平等净心。具足得入于五地。善修菩提法故。深心清净故。求转胜道故。则能得佛道。是菩萨。得大愿力。以慈悲心。不舍于一切。以得念慧心道理之势力。修习于福慧。不舍起方便。欲得转胜道上地。明观法受诸佛神力所护。生定不退心。如实知是苦圣谛。是苦集谛。是苦灭谛。是至灭苦道谛。是菩萨。善知世谛。善知第一义谛。善知相谛。善知差别谛。善知示成谛。善知事谛。善知生起谛。善知尽无生谛。善知令入道谛。次第成菩萨诸地故。善知习如来智谛。尔时菩萨。常在一乘故。善知第一义谛。随众生意。令欢喜故。知世谛。分别诸法自相故。知相谛。诸法各异故。知差别谛。分别诸阴界入故。知示成谛。以身心苦恼故。知苦谛。诸道生相续故。知集谛。毕竟灭一切恼热故。知灭谛。起不二法故。知道谛。以一切种智。知一切法次第。成一切菩萨地故。善知习如来智谛。以信解力故。知非得无尽谛智。菩萨如是。以此诸谛智。如实知一切有为法。虚伪诳诈。败坏相。假住须臾。诳惑凡夫人。菩萨尔时。于众生中。大悲转胜。而现在前。能生大慈光明。得如是智慧力。不舍一切众生。常求佛智慧。如实观一切有为法。先际后际。知众生从先际。无明有爱故。生流转生死。于五阴归处。不能动发。增大苦恼聚。是中无我无我所。无众生无人。无知者无寿命者。后际亦如是。如是无所有。而愚痴贪着不断。不知无边有出无出。尔时作是念。凡夫众生。甚为可怪。无明痴故。有无量无边阿僧祇身。已灭今灭当灭。如是常受生死。不能于身生厌离想。转更增长机关苦身。常为生死水漂。不能得返归五阴舍。不能舍离。不畏四大毒蛇。不能拔出憍慢见箭。不能灭除贪恚痴焰。不能破坏无明愚闇。不能干竭爱着大海。不求十力大圣导师。常随魔意。于生死城中。多为诸恶觉观所转。如是苦恼孤穷众生。无有救者。无有舍者。无有究竟道者。唯我一人。独无等侣。修集福德智慧。以是资粮。令此一切众生。得住毕竟清净。乃至使得一切法中。佛无碍智力。如是思惟。从正观生于智力。发愿所作。一切善根。皆为度诸众生故。为一切众生求好事故。求安乐故。为利益一切众生故。为解脱一切众生故。为一切众生无苦恼故。为一切众生无粗恶故。为一切众生心清净故。为调伏一切众生故。为灭一切众生诸忧恼苦满其愿故。是菩萨。尔时住此第五难胜地中。不忘诸法故。名为念者。决定智慧故名为智者。知经书意。次第故。名为有道者。自护护彼故。名为有惭愧者。不舍持戒故。名为坚心者。善思惟是处非处故。名为觉者。不随他故。名为随智者。善分别诸法章句义故。名为随慧者。善修禅定故。名为得神通者。随世间法行故。名为方便者。善集福德资粮故。名为无厌足者。常求智慧因缘故。名为不舍者。集大慈大悲因缘故。名为无疲惓者。常正忆念故。名为远离破戒者。深心求佛十力四无所畏十八不共法故。名为常念佛法者。常令众生离恶修善故。名为庄严佛国者。种诸福德庄严三十二相八十种好故。名为行种种善业者。求庄严佛身口意故。名为常行精进者。供养一切说法菩萨故。名为乐大恭敬者。一切菩萨。诸世间方便中。心无嗔碍故。名为心无碍者。常乐教化众生故。名为昼夜远离余心者。菩萨如是行时布施。亦教化众生。爱语利益同事。亦教化众生。又以色身示现。亦教化众生。亦以说法。教化众生。亦示菩萨行事。教化众生。亦示诸佛大事。教化众生。亦示生死过恶。教化众生。亦示诸佛智慧利益。教化众生。菩萨如是修习。以大神力种种因缘方便道。教化众生。是菩萨。虽种种因缘方便心常在佛智。而不退失善根。又复常求转胜利益众生法。是人利益众生故。世间所有经书伎艺。文章算数。名性经书。治病医方。所谓。治干消病。小儿病。鬼着病。蛊毒病。癞病等。伎乐歌舞。戏笑欢娱经书。国土城郭。聚落室宅。园观池泉。华果药草林树。金银摩尼珠。琉璃珊瑚虎魄。车磲马瑙。示诸宝聚。日月五星。二十八宿。占相吉凶。地动梦书怪相。身中诸相布施持戒。摄伏其心。禅定神通。四禅四无量心。四无色定。凡诸不恼众生事。安乐众生事。怜愍众生故。出令入诸佛无上之法。菩萨住是难胜地。值数百数千数万亿佛。供养尊重赞叹。衣服饮食。卧具医药。亲近听法。听法已出家。出家已。于诸佛所。听受经法。而为法师。说法利益。得转胜多闻积三昧。乃至过百千万亿劫。不忘此事。是菩萨。尔时一切福德善根。转胜明净。佛子。譬如成炼真金。以车磲磨莹。其光转胜。菩萨住是地中。方便智慧力故。功德善根。转净明胜。下地所不及。又如日月星宿。诸天宫殿。风持令去。不失法度。如是佛子。菩萨住难胜地。以方便思惟故。福德善根。转倍明净。而不取证。亦不疾至佛道。诸佛子。是名诸菩萨摩诃萨难胜地。今已略说。菩萨摩诃萨。住是地中。多作兜率陀天王。诸根猛利。能摧伏一切外道。有所作业。若布施爱语。利益同事。皆不离念佛念法。念菩萨伴。乃至不离念具足一切种智。我当何时。于众生中。为首为尊。乃至于一切众生中。为依止者。诸佛子。是菩萨若欲如是勤行精进。须臾之间。能得千亿三昧。乃至示千亿菩萨。以为眷属。若以愿力。神力自在复过是数。若干百千万亿不可得知。尔时金刚藏菩萨欲明此义故。重说偈言

  诸菩萨具足　　四地行法已
  思惟三世佛　　戒等心亦等
  除见疑悔等　　道非道行等
  观诸平等已　　得入第五地
  四念处为弓　　诸根为利箭
  四正勤为马　　四如意为车
  五力以为铠　　破诸烦恼贼
  勇健不退转　　直入第五地
  惭愧无垢衣　　净戒以为香
  七觉为华鬘　　禅定为涂香
  智慧与方便　　种种念庄严
  如是得入诸　　陀罗尼园林
  四如意为足　　正念为头项
  慈悲明净眼　　利智慧为牙
  以空无我吼　　破诸烦恼贼
  如是人师子　　能入第五地
  是菩萨得至　　住于第五地
  转修胜净法　　皆为佛道故
  常行慈悲心　　未曾有厌惓
  但为修习此　　第五地行法
  深集二资粮　　福德及智慧
  种种方便力　　欲得上明观
  常为佛所护　　得成于念慧
  次第能善观　　如实知诸谛
  第一谛世谛　　差别谛成谛
  事生灭道谛　　至无障碍谛
  如是观诸谛　　心微妙清净
  虽为未能得　　无障碍解脱
  以能有智慧　　及与信力故
  得胜于一切　　世间诸智慧
  如是观诸谛　　悉知有为法
  虚妄伪诈诳　　无有一坚实
  能得于诸佛　　慈悲光明分
  为诸众生故　　专心求佛慧
  知有为先后　　众生甚可愍
  堕在无明闇　　爱因缘所系
  是菩萨能拔　　世间之苦恼
  知法无寿者　　犹如草木等
  众生常以二　　烦恼因缘故
  从于先世来　　后世亦如是
  相续不断绝　　不能尽苦边
  于此生愍伤　　我当度脱之
  不出五阴舍　　不畏四大害
  不拔诸邪箭　　不灭三毒焰
  不破无明闇　　堕在大爱海
  无有智慧明　　离大导师故
  知如是事已　　转加勤精进
  有所作起业　　皆为度众生
  常念正念慧　　修道有惭愧
  坚心与智慧　　转更令增益
  修福慧无厌　　持戒不羸弱
  求多闻无倦　　正修净佛土
  种相好音声　　因缘无厌足
  所作诸善业　　皆为利众生
  为利世间故　　造立经书等
  名姓鬼病方　　歌舞戏笑等
  堂阁园林法　　衣服诸饮食
  示种种宝聚　　令众得欢喜
  占日月五星　　二十八宿等
  地动吉凶相　　梦书诸怪事
  布施持戒等　　离欲修禅定
  四无量神通　　安乐世间故
  大智慧菩萨　　得此难胜地
  供养数亿佛　　从佛而听法
  而修诸善根　　皆悉得明净
  犹如车磲宝　　莹磨于真金
  譬如宝宫殿　　随风不失法
  世法利不染　　如莲华在水
  菩萨住是地　　多作兜率王
  诸根转猛利　　破诸外道见
  所作诸善业　　皆为佛智慧
  得佛力无畏　　能度诸众生
  是菩萨勤修　　转胜精进力
  能得千万亿　　诸深妙三昧
  供养千亿佛　　能动千世界
  随其所愿力　　过是数无量
  如是第五地　　种种诸方便
  上智慧大人　　如法解说竟

十住经卷第二十住经卷第三

        后秦三藏鸠摩罗什译

    现前地第六

  诸菩萨闻说　　上地之行相
  在于虚空中　　雨众妙珍宝
  放清净光明　　供养于世尊
  咸赞言善哉　　善哉金刚藏
  时有无量亿　　诸天皆欢喜
  于上虚空中　　雨众宝末香
  光明相绮错　　微妙甚可乐
  众香华璎珞　　幡盖雨佛上
  他化自在王　　与诸眷属等
  雨众妙宝物　　雰雰如云下
  歌颂供养佛　　称叹金刚藏
  咸赞言善哉　　善哉快说此
  千万亿天女　　于上虚空中
  作众天音乐　　歌叹佛功德
  咸作如是言　　如来之所说
  微妙无有量　　能灭诸烦恼
  诸法本性空　　无有毫末相
  空无有分别　　同若如虚空
  无有去住相　　亦无有戏论
  本来常清净　　如如无分别
  若人能通达　　一切诸法性
  于有于无中　　其心不动摇
  但以大悲心　　为度诸众生
  是名诸佛子　　从佛口法生
  常行于布施　　利益诸众生
  本来虽善净　　持戒而坚心
  虽知法无伤　　而行于忍辱
  虽知法性离　　而行于精进
  虽先灭烦恼　　而入于诸禅
  虽先解法空　　而选择诸法
  寂灭智虽多　　而求利世间
  能灭诸恶者　　名之为大人
  如是诸天女　　百千种妙音
  称赞歌颂已　　皆默然观佛
  解脱月菩萨　　请金刚藏言
  当以何相貌　　得成第六地

金刚藏菩萨言。诸佛子。菩萨摩诃萨。已能具足五地行。欲入六地。当以十平等法。得入于六地。何等为十。一以无性故。一切法平等。二以无想故。一切法平等。三以无生故。一切法平等。四以无灭故。一切法平等。五以本来清净故。一切法平等。六以无戏论故。一切法平等。七以不取不舍故。一切法平等。八以离故。一切法平等。九以幻梦影响水中月镜像焰化故。一切法平等。十以有无不二故。一切法平等。诸佛子。诸菩萨摩诃萨。具足五地行。以是十平等法。能入第六地。诸佛子。若菩萨摩诃萨。能如是观一切法性。能忍随顺得第六地。无生法忍。虽未现前。心已明利。成就顺忍。是菩萨。观一切法如是相。大悲为首。增长具足。更以胜观观世间生灭相。故作是念。世间所有。受身生处。皆以贪着我故。若离着我。则无世间生处。诸凡夫人。愚痴所盲。贪着于我。常乐求有。恒随邪念。行邪妄道。习起三行罪行。福行。不动行。以是行故。起热心种子。有漏有取心故。起生死身。所谓。业为地。识为种子。无明覆蔽爱水为润。我心溉灌。种种诸见。令得增长。生名色牙。因名色故。生诸根。诸根合故。有触生。从触生受。乐受故。生渴爱。渴爱增长故。有四取。四取因缘故。起业。于有起五阴身。名为生。五阴衰变。名为老。衰变灭。名为死。老死因缘。有忧悲热恼众苦聚集。是十二因缘。无有集者。自然而集。无有散者。自然而散。因缘合则有。因缘散则无。菩萨摩诃萨。如是于六地中。随顺观十二因缘。又作是念。不如实知诸谛第一义故。有无明覆心。无明业果。是名诸行。依诸行。有初识。与识共生。有四取阴。依止取阴。有名色。名色成就。有六入。诸根行尘故。有识。从是和合。生有漏触。触共生。有受。贪乐于受。名为爱。爱增长。名为取。从取起有漏业。有业有果报五阴。名为生。五阴熟名为老熟。五阴坏名为死。死别离时。愚人贪着心热。名为忧悲。发声啼哭五识。名为苦。意识名忧。忧苦转多名为恼。如是但生大苦树大苦聚。如是十二因缘苦聚。无我无我所。无作者无使作者。菩萨作是念。若有作者。则有作事。若无作者。则无作事。第一义中。无作者无作事。又作是念。三界虚妄。但是心作。如来说。所有十二因缘分。是皆依心。所以者何。随事生贪欲心。是心即是识。事是行。行诳心故。名无明。识所依处名名色。以入生贪心。名六入。三事和合有触。触共生名受。贪着所受。名为渴爱。渴爱不舍。名为取。是和合故。名为有。此有更有有相续。名为生。生变熟名为老。老坏名为死。此中无明有二种作。一者缘中痴。二者为生诸行因。行亦有二种作。一者生未来世果报。二者与识作因。识亦有二种作。一者能令有相续。二者与名色作因。名色亦有二种作。一者互相助成。二者与六入作因。六入亦有二种作。一者能缘六尘。二者能与触作因。触亦有二种作。一者能触所缘。二者能与受作因。受亦有二种作。一者觉憎爱事。二者与爱作因。爱亦有二种作。一者所可染中生贪心。二者与取作因。取亦有二种作。一者能增长烦恼。二者与有作因。有亦有二种作。一者能于余道中生。二者与生作因。生亦有二种作。一者能起五阴。二者与老作因。老亦有二种作。一者令诸根熟。二者与死作因。死亦有二种作。一者坏五阴身。二者以不见知故。而令相续不绝。是中无明缘诸行者。无明令行不断。助成行故。行缘识者。令识不断。助成识故。识缘名色者。令名色不断。助成名色故。乃至生缘老死忧悲苦恼。生不断。相续助成故。无明灭故。则诸行灭。乃至老死忧悲苦恼。亦如是。是中无明若无。诸行亦无。因灭。则果灭余分亦如是。是中无明爱取。是三分。不断烦恼道。诸行及有。不断业道。余因缘分。不断苦道。先际后际。相续不断故。是三道不断。是三道。离我我所。而有生灭。如二竹相对而住。不坚似坚。无明因缘诸行者。即是过去世事。识名色六入触受。是现在事。爱取有生老死。是未来世事。于是有三世出。无明灭故诸行灭。名为断相续说。十二因缘。说名三苦。无明行识名色六入。名为行苦。触受名为苦苦。爱取有生死忧悲苦恼。名为坏苦。无明灭故。诸行灭。乃至老死。名为断三苦相续说。因无明。诸行生。余亦如是。无明灭。诸行灭。以诸行体性空故。余亦如是。无明因缘。诸行以生缚说。余亦如是。无明灭故。诸行灭。以灭缚说。余亦如是。无明因缘诸行。是随顺无所有观说。无明灭诸行灭。是随顺尽观说。余亦如是。如是逆顺十种。观十二因缘法。所谓。因缘分次第。身心所摄。自助成法。不相舍离。随三道行。分别先后际故。三苦差别故。从因缘起生灭缚故。无所有尽观故。尔时菩萨。随十二因缘。观无我无众生。无寿命者。无人性空。离作者使作者。无主属众。因缘无所有。如是观时。空解脱门现在前。灭此事。余不相续故。名无相解脱门现在前。知此二种。更不乐生。唯除大悲心。教化众生。无愿解脱门现在前。菩萨修行是三解脱门。离彼我相。离作者受者相。离有无相。悲心转增。以重悲心故。勤行精进。未满助菩提法。欲令满足。菩萨作是念。有为和合故增。离散则灭。众缘具故增。不具故灭。我今知有为法多过故。不应具和合因缘。亦不毕竟灭有为法。为教化众生故。诸佛子。菩萨如是。知有为法。多过无性。离坚固相。无生无灭。与大慈悲和合。不舍众生。即时得无障碍。般若波罗蜜。光明现在前。得如是智慧。具足修集。取阿耨多罗三藐三菩提因缘。而不与有为法共住。观有为法性寂灭相。亦不住其中。欲具足无上菩提分故。菩萨住现前地中。得快空三昧。性空三昧。第一义空三昧。第一空三昧。大空三昧。合空三昧。生空三昧。如实不分别空三昧。摄空三昧。离不离空三昧。如是等。万空三昧门现在前。无相无愿三昧。亦如是。是菩萨。住现前地中。志心决定心。妙心深心。不转心不舍心。广心。无边心。乐智心慧方便和合心。如是等心。转胜增长故。随顺阿耨多罗三藐三菩提。一切外道论师。不能倾动。入于智地。转声闻辟支佛。决定向佛智。一切众魔。及诸烦恼。所不能制。安住菩萨智慧明中。善修应空无相无愿解脱门。专以慧方便。行助菩提法。是菩萨。住现前地。于般若波罗蜜中。得转胜行。得第三上顺忍。以顺是法。无有违逆故。菩萨住是现前地中。得见数百数千佛。乃至数百千万亿佛。供养恭敬。尊重赞叹。衣服饮食。卧具医药。亲近诸佛。于诸佛所。听法。听法已。如实随智慧光明故。如所说行。令诸佛欢喜。是人转胜。知诸佛法藏。乃至无量百千万亿劫。诸善根转妙明净。诸佛子。譬如真金。以琉璃磨莹。光色转胜。菩萨住此现前地。以慧方便故。善根转胜。明净寂灭。余地所不及。诸佛子。譬如月明。能令众生。身得清净。四种风吹。不能遏绝。菩萨摩诃萨。住是现前地。善根转胜。能灭无量众生烦恼之火。四种恶魔。所不能坏。诸佛子。是名诸菩萨摩诃萨现前地。菩萨住是地中。多作善化自在天王智慧猛利。能破一切增上慢者。声闻问难。不能穷尽。有所施作。布施爱语。利益同事。皆不离念佛。念法念诸菩萨伴。乃至不离念一切种智。常发愿言。我于一切众生。为首为尊。乃至于一切众生。为依止者。是菩萨。若欲勤行精进。于须臾间。得十万亿三昧。乃至能示十万亿菩萨眷属。若以愿力。能过是数。不可称计。若干百千万亿劫。尔时金刚藏菩萨。欲令此义明了故。而说偈言

  诸菩萨已得　　具足行五地
  知诸法无相　　无相无生灭
  本来常清净　　无有诸戏论
  修集如是智　　得入第六地
  诸法常离相　　不取亦不舍
  性空犹如幻　　离二无分别
  若能顺如是　　微妙之理趣
  心无有违逆　　得入第六地
  住于利顺忍　　智慧得力故
  观察于一切　　世间生灭相
  悉知诸世间　　皆从痴闇出
  痴闇若灭者　　则无诸世间
  观择因缘法　　随顺第一义
  而不坏缘报　　所作及假名
  如实无作者　　亦无有受者
  如是观有为　　如云无实事
  不知真谛义　　名之为无明
  从是则生思　　身口行得报
  从行故有识　　即生于名色
  如是生世间　　至生死苦聚
  了知于三界　　但从心而有
  知十二因缘　　在于一心中
  如是则生死　　但从心而出
  心若得灭者　　生死则亦灭
  无明二种作　　作痴作于业
  乃至于老死　　破散坏五阴
  从于此事边　　具出于苦恼
  是事若尽者　　苦恼则亦尽
  无明若具足　　相续则不断
  因缘若不具　　则断于相续
  无明及爱取　　即是烦恼道
  行有是业道　　余则是苦道
  痴至于六入　　是名为行苦
  触受是苦苦　　余分是坏苦
  灭三苦相续　　则更无有我
  无明及诸行　　则是过去世
  识与及于受　　是则为现在
  从爱而生苦　　则是未来世
  无明若灭者　　是则无有苦
  痴从众缘生　　则生于诸缚
  众缘若灭者　　则灭于诸缚
  从因而生果　　因灭则果灭
  如是观诸法　　自性则皆空
  随顺于无明　　则有世间出
  若逆于无明　　是则断于有
  从是则有是　　是无则无是
  如是十种观　　甚深因缘法
  观因缘相续　　去来及现在
  不离一心中　　分别有三道
  从三种苦观　　及以生灭法
  无所有而尽　　能行逆顺观
  菩萨如是入　　十二因缘法
  知空犹如幻　　如梦亦如影
  如焰亦如化　　虚诳无作者
  亦无有受者　　但诳于愚人
  如是观因缘　　智者所修空
  无缘则无相　　知此二虚假
  其诸一切有　　于中无所愿
  但以大悲心　　愍度众生故
  如是诸大士　　修习解脱门
  悲心爱乐佛　　无量诸功德
  知诸有为法　　皆从和合有
  即得万空定　　无相愿亦尔
  智慧转增进　　入于上顺忍
  得于诸菩萨　　无为智解脱
  如是诸善根　　转胜明净利
  供养无量佛　　诸佛所称赞
  常于诸佛所　　出家学佛道
  到诸佛法藏　　善根转增长
  犹以琉璃宝　　莹磨于真金
  光明转清净　　其喻亦如是
  如于虚空中　　满月光清净
  四种风所吹　　不能令遏绝
  菩萨智慧光　　灭诸烦恼热
  四魔不能制　　其喻亦如是
  菩萨住是地　　多作善化王
  诸根悉猛利　　能破增上慢
  所作诸善业　　皆随顺智慧
  声闻诸问难　　不能得穷尽
  是佛子若欲　　如是勤精进
  能得于百千　　亿数诸三昧
  得见于百千　　亿数十方佛
  如春清了时　　日光明则净
  如是第六地　　深妙难知见
  声闻所不了　　大士略说竟

    远行地第七

  尔时诸天众　　在于虚空中
  雨香花珍宝　　如云散佛上
  踊跃发妙音　　咸赞言善哉
  善哉金刚藏　　善知第一义
  无量功德聚　　人中之莲花
  说此上妙行　　利益诸世间
  他化自在王　　雨光明华香
  雰雰而供养　　除忧烦恼者
  诸天及天王　　发妙音声言
  若闻此地义　　则为得大利
  时作百千种　　上妙诸伎乐
  诸天女善歌　　承佛神力故
  佛是最寂灭　　能令恶为善
  一切诸世间　　皆所共恭敬
  虽出过世间　　而示世间法
  知身同实相　　而示种种身
  虽以诸言音　　演说寂灭法
  而知于语言　　无有音声相
  能过百千土　　上妙供诸佛
  知身佛国土　　舍相智自在
  虽教化众生　　而无彼我想
  广集大功德　　不于中起着
  以见取相故　　三毒火然世
  不取一切相　　慈悲起精进
  诸天及天女　　欢喜设供养
  如是赞叹已　　默然而观佛
  尔时解脱月　　请金刚藏言
  大众皆清净　　愿说七地相

金刚藏菩萨言。诸佛子。菩萨摩诃萨。已具足第六地行。若欲入第七菩萨地者。从方便慧。起十妙行。何等为十。是菩萨善修空无相无愿。而以慈悲心。处在众生。随诸佛平等法。而不舍供养诸佛。常乐思惟空智门。而广修集福德资粮。远离三界。而能庄严三界。毕竟寂灭诸烦恼焰。而能为众生。起灭贪恚痴烦恼焰法。随顺诸法。如幻如梦。如影如响。如化如水中月。镜中像不二相。而起分别种种烦恼。及不失业果报。知一切佛国土。空如虚空。诸国土皆是离相。而起净佛国土行。知一切佛。法身无身。而起色身。三十二相。八十种好。以自庄严。知诸佛音声不可说相。信解如来音声本来寂灭相。而随一切众生。起种种庄严音声。知诸佛于一念顷。通达三世事。而知种种相种种时种种劫。得阿耨多罗三藐三菩提。随众生心信解故。作如是说。诸佛子。是名从慧方便。生十妙行。菩萨摩诃萨。具足六地行已。修此妙行。得入七地。诸佛子。如是方便慧现前。故名为入七地。是菩萨。住七地中。入无量众生性。入无量诸佛教化众生法。入无量世间性。入诸佛无量清净国土。入无量诸法差别。入无量诸佛智得无上道。入无量诸劫算数。入无量诸佛通达三世。入无量众生信乐差别。入无量诸佛色身别异。入无量诸佛众生志行根差别。入无量诸佛音声语言令众生欢喜。入诸佛无量众生心心所行差别。入无量诸佛随智慧行。入示无量声闻乘信解。入诸佛无量说道因缘令众生信解。入无量辟支佛智慧习成。入诸佛无量甚深智慧所说。入诸菩萨无量所行道。入诸佛无量所说大乘集成事。令众生得入。诸菩萨。作是念。如是诸佛世尊。有无量无边大势力。不可以若干百千万亿劫算数所知。如是诸佛势力。我皆应集。不以强分别此彼得成。以不分别不取相故成。此菩萨如是智慧。善思惟。常修习大方便慧。令其安住佛道智中。以不动法故。若欲常起种种度众生道。无有障碍。来时亦起。去时亦起。坐卧住立。皆能起道。度脱众生。离诸阴盖。住诸威仪。常不离如是想念。是菩萨。于念念中。具足菩萨十波罗蜜及菩萨十地。何以故。是菩萨摩诃萨。于念念中。以大悲心为首。修习一切佛法。皆回向如来智慧故。十波罗蜜者。以菩萨求佛道所修善根。与一切众生故。是檀波罗蜜。能灭一切烦恼热。是尸罗波罗蜜。慈悲为首。于一切众生中。无所伤。是羼提波罗蜜。求转胜善根。无厌足。是毗梨耶波罗蜜。修道心。不驰散。常向一切智。是禅波罗蜜。忍诸法先来不生门。是般若波罗蜜。能起无量智门。是方便波罗蜜。期转胜智慧。是愿波罗蜜。一切外道诸魔。不能沮坏。是力波罗蜜。于一切法相。如实成故。是智波罗蜜。如是念念中。具足十波罗蜜。是菩萨。具足十波罗蜜时。念念中亦具足四摄法。三十七菩提分法。三解脱门。举要言之。一切助阿耨多罗三藐三菩提法。于念念中。皆悉具足。尔时解脱月菩萨。问金刚藏菩萨言。佛子。菩萨摩诃萨。但于七地中。具足助菩提法。一切诸地中。亦具足。金刚藏菩萨言。佛子。菩萨摩诃萨。于十地中。悉具足助菩提法。但第七地胜故得名。何以故。诸菩萨摩诃萨。于七地中。功行具足。入智慧神通道故。佛子。菩萨于初地中。发愿缘一切佛法故。具足助菩提法。第二地中。除心恶垢故。具足助菩提法。第三地中。愿转增长。得法明故。具足助菩提法。第四地中。得入道故。具足助菩提法。第五地中。随顺行世间法故。具足助菩提法。第六地中。入甚深法门故。具足助菩提法。此第七地中。起一切佛法故。具足助菩提法。何以故。诸佛子。菩萨摩诃萨。于此地中。得诸智慧所得道。以是力故。第八地自然得成。佛子。譬如二三千大千世界。一定清净。一定垢秽。是二中间。难可得过。但以大精进力。大神通力。大愿力故。乃能过诸佛子。诸菩萨如是。行于杂道。难可得过。但以大愿力。大智慧力。大方便力故。乃可得过。解脱月菩萨言。第七菩萨地。为是净行。为是垢行。金刚藏菩萨言。从初欢喜地来。菩萨所行。皆离烦恼罪业。何以故。回向阿耨多罗三藐三菩提故。随地所行清净。不名为过。佛子。譬如转轮圣王。乘大宝象。游四天下。知有贫穷苦恼者。而过不在王。然王未免人身。若舍王身。生于梵世。住梵天宫。游行千世界。示梵王威力。尔时乃离人身。诸佛子。菩萨亦如是。从初地来。在诸波罗蜜乘。知一切众生心所行事。及烦恼垢。而不为烦恼垢之所污。以乘善道故。而不名为过。若菩萨。舍一切所修功行道。从七地。入八地。尔时名为乘菩萨清净乘。悉知一切世间诸烦恼垢。而不为诸烦恼所污。亦名为过。诸佛子。菩萨住是七地。多过贪欲等诸烦恼。众在此七地。不名有烦恼者。不名无烦恼者。何以故。一切烦恼。不发起故。不名有烦恼者。贪求如来智慧。未满愿故。不名无烦恼者。菩萨住是七地。成就深净身业。深净口业。深净意业是菩萨。所有不善业道。诸佛所呵。随烦恼垢者。如是诸业。悉已得过。所有善业道。诸佛所赞。是则常行。又世间经书伎艺。如五地中说。自然而得。于三千大千世界中。最为希有。得为大师。唯除如来入八地菩萨。无有众生。深心妙行。能与等者。是菩萨。所有禅定。神通解脱三昧。虽未得果报。所生而随意自在。菩萨住是远行地。于念念中。具足修集方便慧力。及一切助菩提法。转胜具足。住是远行地中。能入善择菩萨三昧。善思义三昧。益意三昧。分别义藏三昧。如实择法三昧。坚根安住三昧。知神通门三昧。法性三昧。如来利三昧。种种义藏三昧。不向生死涅槃三昧。如是具足百万菩萨三昧。能净治此地。是菩萨。得是三昧。智慧方便。善清净故。深得大悲力故。名为过声闻辟支佛地。趣佛智地。是菩萨。住是地。无量身业无相行。无量口业无相行。无量意业无相行。是菩萨清净行故。显照无生法忍。解脱月菩萨言。佛子。若菩萨住初地。有无量身业。无量口业。无量意业。已能过一切声闻辟支佛地。金刚藏菩萨言。缘大法故。能过。非是实行力。此第七地。自实行力故。一切声闻辟支佛。所不能坏。佛子。譬如生在王家。即胜一切群臣百官。何以故。豪尊力故。身既长大。智慧成立。真实得胜。诸佛子。菩萨摩诃萨。初发心时。已胜一切声闻辟支佛。以发大愿。深心清净故。今住此地。自以智力故胜。诸佛子。菩萨住在七地。得甚深远离无行。身口意业。转求胜法。而不舍离。以是转胜心故。虽行实际。而不证实际。解脱月言。佛子。菩萨摩诃萨。从何地来。能入寂灭。金刚藏言。菩萨摩诃萨。从第六地来。能入寂灭。今住此地。于念念中。能入寂灭。而不证寂灭。是名菩萨。成就不可思议。身口意业。行实际而不证实际。佛子。譬如有人。乘船入于大海。善为行法。善知水相。不为水患所害。如是菩萨摩诃萨。住此七地。乘诸波罗蜜船。能行实际。而不证实际。菩萨如是。以大愿力故。得智慧力故。从禅定智慧。生大方便力故。虽深爱涅槃。而现身生死。虽眷属围绕。而心常远离以愿力受生三界。而不为世法所污。心常善寂。以方便力故。而还炽然。虽然不烧。随行佛智。转声闻辟支佛地。得至诸佛法藏。而现于魔界。虽过四魔道。而现行魔行。虽现诸外道行。而深心不舍佛法。虽现身一切世间。而心常在出世间法。所有庄严之事。胜诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。四天王。释提桓因。梵天王。而不舍乐法爱法。菩萨成就如是智慧。住是远行地中。值百千亿万那由他诸佛。供养恭敬。尊重赞叹。衣服饮食。卧具医药。供养诸佛已。护持诸佛法。诸声闻辟支佛。智慧问难。所不能坏。是菩萨怜愍众生故。法忍转得清净。是菩萨。无量百千万亿那由他劫。善根转胜清净。佛子。譬如成炼真金。以诸好宝。庄饰间错。转胜明好。余宝不及。诸佛子。菩萨亦如是。住菩萨远行地中。诸善根。从方便智慧生。转胜明净。无能坏者。佛子。譬如日光。一切星宿月光。所不能及。阎浮提内。所有泥水。悉能干竭。菩萨亦如是。住远行地。善根转胜。一切声闻辟支佛。所不能及。又能干竭众生烦恼污泥。诸佛子。是名菩萨摩诃萨。第七远行地。菩萨摩诃萨。住是地中。多作他化自在天王。诸根猛利。能发众生。悟道善缘。所作善业。若布施若爱语。若利益若同事。皆不离念佛。不离念法。不离念诸菩萨摩诃萨伴。乃至不离念具足一切种智。常生是心。我何时。当于一切众生中。为首为尊。乃至于一切众生。为依止者。是菩萨若欲如是勤行精进。于须臾间。得百千亿那由他三昧。乃至能示现百千亿那由他。菩萨眷属。菩萨若以愿力。自在示现。过于此数。百千万亿那由他劫不可计知。尔时金刚藏菩萨。欲重明此义。而说偈言

  深智慧定心　　具行六地已
  一时生方便　　智慧入七地
  行空无相愿　　而修慈悲心
  顺佛平等法　　而供养诸佛
  虽以智观空　　而修福无厌
  然后能得入　　第七远行地
  虽能严三界　　而心乐远离
  虽心常寂灭　　而灭烦恼者
  行空不二法　　如幻如梦等
  而行慈悲心　　得入第七地
  虽观一切土　　空若如虚空
  而能善庄严　　清净诸佛土
  虽知诸佛身　　同法相无相
  而种三十二　　八十诸相好
  虽知于诸佛　　不可言说相
  而严佛音声　　令世欢喜故
  虽知于诸佛　　一念中成道
  而示时劫数　　引导诸众生
  如是知于法　　则得法照明
  菩萨如是者　　即入第七地
  住是地能观　　无量众生行
  亦知于诸佛　　势力亦无量
  世间及劫数　　法性皆无量
  又知诸众生　　所欲之所乐
  知说三乘法　　皆悉是无量
  我当应教化　　成就是众生
  以如是思惟　　方便慧和合
  于四威仪中　　常行如是道
  于一一念中　　能具助菩提
  所谓是十种　　波罗蜜等法
  如是诸菩萨　　所修之福德
  皆与诸众生　　名檀波罗蜜
  灭除心恶垢　　名尸波罗蜜
  不为六尘伤　　羼提波罗蜜
  能起转胜法　　精进波罗蜜
  于是道不动　　名禅波罗蜜
  无生忍是名　　般若波罗蜜
  回向佛道名　　方便波罗蜜
  求于转胜法　　名愿波罗蜜
  无有能坏者　　名力波罗蜜
  能解如实说　　名智波罗蜜
  是助菩提法　　念念皆能摄
  发于广大愿　　缘于大事故
  初地中功德　　名之为具足
  第二地名为　　除诸心恶垢
  第三愿增明　　第四地住道
  第五随世行　　第六入深法
  得无生相分　　渐渐而增长
  第七集一切　　具菩提分法
  能起诸功德　　及以一切愿
  如是诸功德　　令后八地中
  一切诸所行　　自然得清净
  远行地难过　　大智力所能
  如二国中间　　难可得过度
  在于七地中　　不污如圣王
  住于此道中　　不名一切过
  若到于第八　　菩萨智慧地
  尔时过意界　　住于智业中
  如梵王观世　　不得名为人
  菩萨罪不污　　如莲花在水
  菩萨住是地　　过种种烦恼
  不名有烦恼　　不名尽烦恼
  入是正道中　　无有诸烦恼
  愿求佛道故　　不名尽烦恼
  于诸世间中　　经书伎艺事
  文颂咒术等　　自然能了知
  修习诸禅定　　及诸神通等
  无量心利世　　是事皆能起
  尔时此菩萨　　过于二乘行
  安住第七地　　菩萨诸行中
  以初发心时　　大愿力故胜
  今于此地中　　智慧力故胜
  犹如国王子　　小时豪性胜
  后以功德成　　于诸人中胜
  住此得深智　　转发胜精进
  念念入寂灭　　而亦不取证
  犹如人乘船　　入于大海中
  虽行深水难　　不为水所害
  菩萨行转胜　　方便智慧故
  功德悉备足　　诸世所难知
  供养无量佛　　其心清净故
  如真金杂宝　　间错而庄严
  得佛智慧光　　干诸爱水润
  犹如日光明　　消涸于泥潦
  菩萨住是地　　他化自在王
  诸根悉猛利　　通达诸道果
  若欲勤精进　　见十万千亿
  那由他诸佛　　愿力过是数
  七地智慧净　　一切世二乘
  皆所共难知　　今已略说竟

    不动地第八

  他化自在王　　诸天及菩萨
  闻说此上行　　心皆大欢喜
  供养佛佛子　　雨上妙华香
  璎珞众幡盖　　末香诸宝衣
  真妙摩尼珠　　庄严身诸物
  如云空中下　　散佛及大众
  天女于空中　　作种种伎乐
  供养于如来　　并及诸菩萨
  同以微妙音　　歌颂诸功德
  一切智慧者　　众生中最尊
  怜愍世间故　　佛现神通力
  华香珍宝等　　皆出如是音
  所有毛尘沙　　各示那由他
  无量数诸佛　　于中而说法
  于一毛头中　　见无量佛国
  须弥铁围海　　世间不迫隘
  于一毛头中　　具有三恶道
  天人阿修罗　　各各受业报
  见诸佛国中　　一切佛妙音
  转无上法轮　　随起众生念
  诸佛世界中　　众生身种种
  国有众生身　　众生身有国
  一切诸天人　　悉皆离共住
  佛先观察已　　然后为说法
  微尘中国土　　众生心想细
  以国土粗故　　众生心想粗
  佛现如是等　　种种神通力
  若为众生说　　是事不可尽
  如是以妙音　　称叹于世尊
  心皆大欢喜　　默然而观佛
  解脱月菩萨　　请金刚藏言
  佛子今可说　　入于八地相

金刚藏菩萨言。佛子。诸菩萨摩诃萨。已习七地微妙行。慧方便道。净善集助道法。大愿力故。心住不灭。诸佛神力所护。善根得力。常念随顺如来力无畏。不共法。乐心深心。善净成就。福德智力。大慈悲心故。不舍一切众生。修行无量智道。能入诸法本来。无生无灭。无相不出。不失不去。不还无所有性。初中后平等。不异如来。无分别智。一切心意识。忆想分别。无所贪着。入一切法。如虚空性。是名菩萨得无生法忍入第八地。即时得是第八不动地。名为深行菩萨。难可得知。无能分别。离一切相。离一切想。一切贪着。无量无边。不可思议。一切声闻辟支佛。所不能坏。深大远离。而现在前。诸佛子。譬如比丘。得于神通。心得自在。次第乃入灭尽定。一切动心。忆想分别。心所行事。皆悉尽灭。菩萨亦如是。住是远行地。即时一切匆务都灭。得无身口意务。住大远离。诸佛子。如人梦中。欲渡深水。是人尔时。发大精进。施大方便。欲渡此水。未渡之间。廓然便觉。所渡方便。乃匆遽事。即皆放舍。诸佛子。菩萨摩诃萨。亦如是。从初已来。发大精进。广修行道。至不动地。一切遽事。皆悉放舍。不行二心。诸所忆想。不复现前。譬如生梵世者。欲界烦恼。不现在前。如是诸佛子。菩萨住是不动地。一切心意识。不现在前。乃至佛心。菩提心涅槃心。尚不现前。何况当生世间心。诸佛子。是菩萨摩诃萨。随顺是地。以本愿力故。又诸佛。为现其身。住在诸地。法流水中。如来智慧。为作因缘。诸佛皆作是言。善哉善哉。善男子。汝得是第一忍。顺一切诸佛法。善男子。我有佛十力。四无所畏。十八不共法。汝今未得。当为得是诸功德故。加勤精进。亦莫舍此忍门。善男子。汝虽得此第一甚深寂灭解脱。凡夫众生。不善非寂灭。常发种种烦恼。为种种觉观所害。汝当愍此众生。又善男子。汝应念本所愿。欲大利益众生。欲得不可思议智慧门。又善男子。一切法性。一切法相。若有佛若无佛。常住不异。诸如来不以得此法故说名为佛。声闻辟支佛。亦能得此寂灭无分别法。善男子。汝观我等无量清净身相。无量智慧。无量清净国土。起无量智慧无量方便。无量圆光无量净音。汝今应起如是等事。又善男子。汝今适得此一法明。所谓。一切法寂灭。无有分别。无生法明。我等所得。无量无边。若干亿劫。算数所不能知。汝为得此故。应起此法。善男子。汝观十方无量国土。无量众生。无量诸法差别。汝应如实通达是事。随顺如是智。是菩萨。诸佛与如是等无量无边。起智慧因缘门。以此无量门故。是菩萨。能起无量智差别业。皆悉成就。诸佛子。我今为汝说。若诸佛。不令此菩萨住如是智慧门者。是菩萨。尔时毕竟则取涅槃。舍利益一切众生。以诸佛与此菩萨如是无量无边起智慧因缘故。于一念中。所生智慧。比从初地已来。乃至竟。第七地。百分不及一。千万亿分。百千万亿那由他。乃至无量无边。阿僧祇分。不及一。乃至算数譬喻。所不能及。所以者何。先以一身行道。修集功德。今此地中。得无量身。修菩萨道。以无量音声。以无量智慧。无量生处。无量清净国土。无量教化众生。供养给侍无量诸佛故。随顺无量佛法故。无量神通力故。无量大会差别故。无量身口意业。集一切菩萨所行道。以不动法故。佛子。譬如乘船。欲入大海。未得大海。多用功力。或以手力。若至大海。不复用力。但以风力而去。若本功力。于大海中。一日之行。于百千岁。不能得及。诸佛子。诸菩萨摩诃萨。亦如是。多集善根资粮。乘大乘船。到菩萨所行大智慧海。于须臾间。不施功力。能近一切诸佛智慧。本所施功。若一劫。若百千万劫。不能得及。诸佛子。菩萨摩诃萨。得至第八地。从本方便慧。生无功用心。在菩萨道。思惟诸佛智慧势力。所谓。知世界生。世界灭。世界坏。世界成。知以何业因缘灭故世界坏。知以何业因缘集故世界成。是菩萨。知地性小相。知地性大相。知地性无量相。知地性差别相。知水火风性。小相大相。无量相。差别相。知微尘细相。知微尘差别相。于一世界中。所有微尘差别。皆悉能知。此一世界所有地。若干微尘。皆悉能知。若干水火风微尘。皆悉能知。知若干宝物。斤两微尘。若干众生身微尘。世界中万物。微尘差别。分别众生。粗身细身。从若干微尘。生地狱身。从若干微尘。生畜生身。以若干微尘。生饿鬼身。以若干微尘。生阿修罗身。以若干微尘。生天身。以若干微尘。生人身。皆悉了知。是菩萨。入如是分别微尘智中。知欲界坏。知欲界成。知色界坏。知色界成。知无色界坏。知无色界成。知欲界色界无色界成坏。知欲界小相。知欲界大相。知欲界无量相。知欲界差别相。知色界无色界。小相大相。无量相差别相。如是知三界。是名菩萨教化众生助智明分。善知分别众生身。善观所应生处。随众生生处。随众生身。而为受身。是菩萨。现身遍满三千大千世界。随众生身。各各差别。如日于一切水。皆现其像。若二三千大千世界。三四五。十二十三十四十五十百。三千大千世界。若千若万。若百万若千万。若亿若百千万亿。那由他世界。身遍其中。乃至无量无边。不可思议。不可说。三千大千世界。身遍满其中。随众生身差别。而为受身。是菩萨。成就如是智慧。于一世界。身不动摇。乃至不可说诸佛世界。随众生身。随所信乐。于诸佛大会。而现身像。若于沙门会中。示沙门形色婆罗门众中。示婆罗门形色。刹利众中。示刹利形色。居士众中。示居士形色。四天王众中。帝释众中。魔众中。梵天众中。示梵天形色。乃至阿迦贰吒天众中。示阿迦贰吒形色。以声闻乘度者。示声闻形色。以辟支佛乘度者。示辟支佛形色。以菩萨乘度者。示菩萨形色。以佛身度者。示佛身形色。诸佛子。所有不可说。诸佛国中。随众生身。信乐差别。现为受身。而实远离身相差别。常住诸身平等。是菩萨。知众生身。知国土身。知业报身。知声闻身。知辟支佛身。知菩萨身。知如来身。知智身。知法身。知虚空身。菩萨如是。知众生深心所乐。若于众生身。作己身。若于众生身。作国土身。业报身。声闻身。辟支佛身。菩萨身。如来身。智身法身。虚空身。若于国土身。作己身。业报身。乃至虚空身。若于业报身作己身。乃至虚空身。若于己身。作众生身。国土身。业报身。声闻身辟支佛身。菩萨身如来身。智身法身虚空身。是菩萨。知众生集业身。报身。烦恼身。色身无色身。诸佛国土。小相大相。垢相净相。无量相。广相倒相。平相曲相。方相方差别相。知业报身假名差别。声闻身假名差别。辟支佛身假名差别。菩萨身假名差别。如来身差别。菩提身愿身。化身受神力身。相好庄严身。势力身意生身。福德身智身法身。善分别。如实说诸身相。知诸法身平等不坏相。知虚空身。无量相周遍相无形相。是菩萨。善知起如是诸身。则得命自在心自在。财物自在业自在。生自在愿自在。信解自在如意自在。智自在法自在。是菩萨。得是菩萨十自在。即时为不可思议智者。无量智者。广智者。不可坏智者。菩萨随如是智慧。毕竟常净。起无罪身业口业意业。身业随智行。口业随智行。意业随智行。般若波罗蜜为增上。大悲为首。善修方便。善起诸愿。善为诸佛神通所护。常不舍行利益众生智。悉知无边世界中差别事。诸佛子。举要言之。菩萨住无动地。身口意业所作。皆能集一切佛法。是菩萨。到此地中。离一切烦恼故善住净心力中。心常不离道故善住深心力中。不舍众生故善住大悲力中。救一切世间故善住大慈力中。不忘所闻法故善住陀罗尼力中。分别选择一切佛法故善住一切乐说力中。行无边差别世界故善住神通力中。不舍一切菩萨所行故善住愿力中。修集一切佛法故安住波罗蜜力中。善起一切种智故安住如来力中。是菩萨。得如是智力。示一切所作无有过咎。诸佛子。诸菩萨摩诃萨。此地不可坏故。名为不动地。智慧不转故。名为不转地。一切世间。难测知故。名威德地。无家过故。名王子地。随意自在故。名菩萨生地。更不作故。名为成地。善择知故。名为究竟地。善发大愿故。名为变化地。不怀诸法故。名为胜处地。善修起先道故。名为无功力地。诸佛子。诸菩萨摩诃萨。得如是智慧。名为得入佛境界。名为佛功德所照明。名为随佛威仪行。趣向佛法。常为诸佛神力善护。常为四天王。释提桓因。梵天王等所奉迎。常为密迹金刚神之所侍卫。善能生诸深禅定。常能作无量诸身差别。于诸身中。皆有势力。得大果报神通力。于无边三昧中。得自在。能受无量记。随众生成就处。示成阿耨多罗三藐三菩提。是菩萨。入如是大智慧。善通达诸法。常放大慧光明。度无障碍法性道。善知世间法道差别。能示一切诸功德。随意自在。善解先际后际。能入回转魔道智中。入如来所行境界中。能于无边世界。行菩萨道。以不转相故。是故此地名为不动。诸佛子。诸菩萨摩诃萨。在不动地。善生禅定力故。常不离见无边诸佛。而不舍粗供养。供给诸佛。是菩萨。于一一劫。一切世界中。见数百千万亿那由他无量无边阿僧祇佛。供养恭敬。尊重赞叹。具一切供养事。而用供养。亲近诸佛。从诸佛。受世间别异等诸法明。是人转深入如来法藏。问世间性差别事中。无能尽者。乃至百千万亿劫。说不可尽。又诸善根。转胜明净。譬如成炼真金。巧匠杂宝。作璎珞已。系四天下主颈。阎浮提人。无能夺者。诸佛子。菩萨摩诃萨。亦如是。住是无动地。诸善根转胜明净。一切声闻辟支佛。乃至七地菩萨。所不能坏。菩萨住是地。以善分别智门故。智慧光明。灭众生恼热。譬如佛子若千世界主。大梵天王。能于一时。流布慈心。满千世界。亦能放光。遍照其中。诸佛子。菩萨摩诃萨。亦如是住无动地中。能放身光。照十万三千大千世界微尘数等世界众生。次能灭诸恼热。令得清凉诸佛子。是名略说菩萨摩诃萨不动地。若广说者。无量劫数。所不能尽。菩萨住是地中。多作大梵天王。主千世界。诸根猛利。与诸众生。声闻辟支佛菩萨。波罗蜜道因缘。无有穷尽。说世间性差别中。无能坏者。所作善业。若布施若爱语。若利益若同事。皆不离念佛念法念诸菩萨伴。乃至不离念一切种智。常生是心。我当何时于众生中。为首为尊。乃至于一切众生。为依止者。是菩萨。若欲勤行精进。于须臾间。得百万三千大千世界微尘数诸三昧。乃至能示百万三千大千世界微尘数菩萨眷属。若以愿力。神通自在。能过是数。若干百千万亿劫。不可称计。尔时金刚藏菩萨。欲重明此义。而说偈言

  菩萨住七地　　慧方便已得
  善集助道法　　大愿之所系
  诸佛神力护　　善根悉成就
  求于胜智故　　能入第八地
  善集于福德　　而有深慈悲
  离诸有量心　　心同如虚空
  如所说法中　　心得决定力
  如是得寂灭　　微妙无生忍
  诸法从本来　　无生亦无灭
  无相亦无出　　不失亦不行
  诸法初中后　　与如无分别
  无有心意行　　同若如虚空
  成就如是忍　　无有诸戏论
  得是不动地　　甚深寂灭行
  一切诸世间　　不能得测量
  一切诸心相　　皆悉已坏尽
  菩萨住是地　　心识无分别
  如入灭尽定　　无念想分别
  犹如人梦中　　遽欲行渡水
  觉则心廓然　　自知无所作
  得是深忍已　　一切想念灭
  亦如诸梵王　　无欲界烦恼
  先以愿力护　　诸佛今劝言
  如是第一忍　　是诸佛职位
  我等深智力　　无畏不共法
  汝既无有此　　当加勤精进
  汝今虽得灭　　一切烦恼火
  当观诸世间　　烦恼常炽然
  当念本所愿　　欲利诸众生
  悉遍知诸法　　广度于一切
  诸法实性相　　常住无变异
  二乘亦得此　　不以得名佛
  但以得无碍　　甚深微妙智
  通达三世故　　乃得名为佛
  是诸无等等　　天人所恭敬
  开是众智门　　令入诸佛法
  成就无边底　　无量妙智慧
  先所行诸法　　不及今一念
  如是诸菩萨　　得妙智慧地
  能在一念中　　身遍于十方
  入是智慧门　　行道疾无碍
  如行于大海　　风力令去疾
  离诸功用心　　但在于智业
  观十方世界　　成坏及与住
  能知四大一　　亦知种种异
  小大无量相　　种种诸差别
  能数知三千　　大千界微尘
  亦知众生身　　四大微尘数
  诸天身众宝　　微尘数差别
  皆悉遍照了　　余亦如是知
  智慧因缘故　　心转得调柔
  为利诸众生　　遍诸世界身
  能于众生身　　而自作己身
  及诸佛世界　　诸余种种身
  如日月随风　　影现一切水
  菩萨亦如是　　随顺智慧风
  常住于法性　　湛然不移动
  于净心众生　　各现其身像
  随诸心所乐　　而现为受生
  于诸人天会　　悉皆示其身
  菩萨于因缘　　和合中自在
  乃至能随意　　而为现佛身
  众生国土身　　业报贤圣身
  智身与法身　　知皆同平等
  以是因缘故　　得如意神通
  为令世欢喜　　而现种种身
  能得于十种　　妙大自在智
  所作随智行　　顺于慈悲心
  诸佛所有法　　皆能善修习
  住三净业中　　不动如须弥
  能得大菩萨　　所有十种力
  一切诸魔众　　皆所不能转
  常为诸佛护　　释梵所敬礼
  密迹金刚神　　常随而侍卫
  菩萨得是地　　功德无有量
  百千万亿劫　　说之不可尽
  得近无数佛　　增益诸善根
  如真金杂宝　　庄严在王颈
  菩萨在是地　　多作大梵王
  典领千国土　　功德富无量
  能以三乘教　　而无有穷尽
  慈心光普照　　破诸烦恼热
  若欲于须臾　　能得百三千
  大千世界数　　微尘诸三昧
  能见十方佛　　其数亦如是
  若以其愿力　　过是无有量
  今已略解说　　第八地妙相
  若广演说者　　千亿劫不尽

十住经卷第三十住经卷第四

        后秦三藏鸠摩罗什译

    妙善地第九

  佛子演说此　　八地妙义时
  以佛神力故　　震动无量国
  一切智身出　　无量微妙光
  遍照十方界　　众生得安乐
  千万数菩萨　　住于虚空中
  设众妙供养　　诸天所无有
  大自在天王　　并及他化王
  欢喜众妙供　　大海功德佛
  天女数千万　　恭敬咸欢喜
  同以微妙音　　歌叹佛功德
  以佛神力故　　出如是妙法
  善行寂灭者　　无有诸恶心
  各在于其地　　善修菩萨行
  利益世间故　　遍游于十方
  示众以佛道　　心同空无碍
  诸菩萨神力　　上妙供养具
  胜十方人天　　福德之所致
  佛子乐智者　　以此示佛力
  于一国不动　　而现一切处
  利益于世间　　如满月明净
  灭一切音声　　语言诸想念
  而以诸音声　　说法犹如响
  随众生下劣　　其心厌没者
  示说声闻道　　令出于众苦
  随所有众生　　诸根少利者
  乐于因缘法　　为说辟支佛
  随所有利根　　利益众生者
  有大慈悲心　　为说菩萨法
  若无上大心　　决定乐大事
  为示于佛身　　说无量佛法
  譬如幻化师　　示种种身色
  如是诸身相　　皆无有实事
  如是诸佛子　　善知智慧术
  能示一切行　　心离于有无
  诸天女千万　　微妙音歌叹
  如是歌叹已　　默然而视佛
  又解脱月言　　佛子大会净
  一心愿乐闻　　过八地正行

金刚藏菩萨言。佛子。诸菩萨摩诃萨。以如是无量智善观佛道。欲更求转胜深寂灭解脱。欲转胜思惟如来智慧。欲入如来深密法中。欲选择取不可思议大智慧。欲选择诸陀罗尼三昧重令清净。欲令诸神通广大。欲随顺世间差别行。欲修诸力无畏佛不共法。无能坏者。欲顺行诸佛转法轮力。欲不舍所受大悲大愿。得入第九地。诸菩萨。住此地中。如实知起善不善无记法行。知有漏无漏法行。世间出世间法行。思议不可思议法行。定不定法行。声闻辟支佛法行。菩萨道法行。如来地法行。有为法无为法行。随顺如是智慧。如实知菩提心所行难。知诸烦恼难。业难诸根难。愿乐难性难。志心难深心难。生难残气难。三聚差别难。知众生诸心差别相。心杂相。心轻转相。心坏不坏相。心无形相。心无边遍自在相。心清净差别相。心垢相。心无垢相。心缚相。心解相。心谄曲相。心质直相。心随道相。皆如实知。是菩萨。知烦恼深相。知浅相。知烦恼心伴相不离相。知使缠差别相。知是心相应不相应相。知是生时得果报相。知是三界中差别相。知爱痴见深入如箭相。知憍慢痴重罪相。知是三业因缘不断相。略说乃至如实知入八万四千烦恼行差别相。是菩萨。知诸业善不善无记相。分别未分别相。心伴相不离相自然尽相。行道尽相。种相集相。不失果报相。次第相。有报相无报相。黑黑报相。白白报相。黑白黑白报相。非黑非白能尽业相。知业起处相。受业法别异相。知无量因缘起业相。知世间业出世间业差别相。现报相生报相后报相。随诸业定相不定相。略说。乃至如实知八万四千诸业差别相。是菩萨。知诸根软中利差别相。知先际后际别异相不别异相。知上中下相。知烦恼伴相。不相离相。随诸乘定相不定相。淳熟相未淳熟相。随心行相。易坏相。深取相。增上相。不可坏相。转相。不转相。三世差别相。深隐共生差别相。略说。乃至如实知八万四千诸根差别相。是菩萨。知众生诸欲乐软中利相。略说。乃至如实知八万四千欲乐差别相。是菩萨。知诸性软中利相。略说。乃至如实知八万四千诸性差别相。是菩萨。知深心软中利相。略说。乃至如实知八万四千深心差别相。是菩萨。分别知诸结使有伴。共心生不共心生心相应心不相应。深入相。无始来随恼众生相。与一切禅定。解脱神通相违。坚系缚。三界系。无量心。而不现前。开诸业门。而无所知。可对治相。无所有相。无定事相。不异圣道相。灭动相。是菩萨。如实知诸生差别相。所谓。地狱畜生饿鬼阿修罗人天差别。色界无色界差别。有想无想差别。业是田。爱是水。无明是黑闇。覆识是种子。后身是生牙。名色共生。而不相离。有痴爱相续相。欲生欲作欲爱。不离乐众生相。分别三界差别相。三有相续相。皆如实知。是菩萨。如实知诸习气。若有余若无余。随所生处有习气。随共众生住有习气。随业烦恼有习气。善不善无记有习气。离欲有习气。随后身有习气。次第随逐有习气。深入道断相。持烦恼相。离则无法。皆如实知。是菩萨。如实知众生定不定相。正定相邪定相。不定相。邪见中邪定相。正见中正定相。离此二无定相。一一五逆。是邪定相。五根是正定相。邪位是邪定。正位是正定。更不作故。离此二位。是不定相。深入邪聚。有难得转相。令修无上道因缘相。不定聚。邪定聚。众生守护相。皆如实知。佛子。诸菩萨摩诃萨。随如是智。名为安住妙善地。菩萨住是地。知众生如是诸行差别相。随其解脱。而与因缘。是菩萨。知化众生法。知度众生法。如实知而为说法。声闻乘相。辟支佛乘相。菩萨乘相。如来地相。如实知随众生因缘。而为说法。随心随根。随欲乐差别。而为说法。又随行处。随智慧处。而为说法。知一切行处。随而说法。随众生性。深入难处。而为说法。随道随生。随烦恼随习气转故说法。随乘令解脱故说法。是菩萨。住此地中。为大法师。守护诸佛法藏。堕在大法师深妙义中。用无量慧方便。四无碍智。起菩萨言辞说法。是菩萨。常随四无碍智。而不分别。何等为四。一法无碍。二义无碍。三辞无碍。四乐说无碍。是菩萨。用法无碍智。知诸法自相。以义无碍智。知诸法差别。以辞无碍智。知无分别说诸法。以乐说无碍智。知诸法次第不断。复次以法无碍智。知诸法无体性。以义无碍智。知诸法生灭相。以辞无碍智。知诸法假名。而不断假名说。以乐说无碍智。随假名不坏无边说。复次以法无碍智。知现在诸法差别相。以义无碍智。知过去未来诸法差别相。以辞无碍智。知过去未来现在诸法。以无分别说。以乐说无碍智。于一一世。得无边法相故说。复次以法无碍智。知诸法差别。以义无碍智。知诸法义差别。以辞无碍智。随诸言音。而为说法。以乐说无碍智。随所乐解。而为说法。复次以法无碍智。以法智知诸法差别。以方便知诸法无差别。以义无碍智。以比智如实知诸法差别。以辞无碍智。以世智说诸法差别。以乐说无碍智。知善说第一义。复次以法无碍智。知诸法一相不坏。以义无碍智。善入阴入界谛因缘法。以辞无碍智。一切世间之所归趣。以微妙音故。以乐说无碍。智所说转胜。能令众生得无边法明。复次以法无碍智。知诸法无有分别。摄在一乘。以义无碍智。入分别诸法差别门。以辞无碍智。能说诸乘。无分别义。以乐说无碍智。以一法门。说无边法明。复次以法无碍智。能入一切菩萨行。智行法行随智行。以义无碍智。能分别说十地义差别。以辞无碍智。不分别说随顺诸地道。以乐说无碍智。说一切行无边相。复次以法无碍智。知一切佛。于一念中。得菩提。以义无碍智。知种种时处差别。以辞无碍。智随诸佛得道事差别说。以乐说无碍智。于一句法无边劫。说而不穷尽。复次以法无碍智。知一切佛说。一切佛力。无所畏不共法。大慈大悲。无碍智转法轮等。随顺一切智。以义无碍智。随如来音声。出八万四千。随众生心。随根随欲乐差别。以辞无碍智以如来音声。不分别说一切诸行。以乐说无碍智。以诸佛智慧力。随众生所乐音声说。诸佛子。菩萨摩诃萨。如是善知无碍智。安住第九地。名为得诸佛法藏。能为大法师。得众义陀罗尼。众法陀罗尼。起智陀罗尼。众明陀罗尼。善意陀罗尼。众财陀罗尼。名闻陀罗尼。威德陀罗尼。无碍陀罗尼。无边旋陀罗尼。杂义藏陀罗尼。得如是等百万阿僧祇陀罗尼。随应方便说。如是无量乐说差别门演法。是菩萨。得如是无量陀罗尼门。能于无量诸佛所听法。闻已不忘。如所闻法能以无量差别门。为人演说。是菩萨。于一佛所。以百万阿僧祇陀罗尼。听受法。如从一佛听法。余无量无边诸佛。亦如是。是菩萨。于礼敬佛时。所闻法明门。非多学声闻得陀罗尼力。于十万劫。所能受持。是菩萨。得如是陀罗尼力。诸无碍智。乐说力。以说法故。在于法座。遍三千大千世界众生。随意说法。是菩萨。在法座上。唯除诸佛及受职菩萨。于一切中。最为殊胜。心中得无量法明。是菩萨。处于法座。或以一音。令一切大众悉得解了。即得解了。或以种种音声。令一切大众。各得开解。即得开解。或以默然。但放光明。令一切大众。各得解法。即得解法。或一切毛孔。皆出法音。或三千大千世界。所有色无色物。皆出法音。或以一音。周满世性。悉令得解。是菩萨。三千大千世界。所有众生。一时问难。一众生。以无量无边音声差别问难。如一人所问。余者异问。是菩萨。于一念中。悉受如是问难。但以一音。皆令开解。如是二三千大千世界。三四五十二十三十四十五十。若百三千大千世界。若千三千大千世界。若万十万百万。若亿三千大千世界。若十亿百千万亿那由他。乃至不可说不可说。三千大千世界。满中众生。广为说法时。承佛神力。能为众生广作佛事。倍复精勤。摄取如是智明。若于一毫末中。有不可说不可说世界微尘数大会。佛在此中。而为说法。佛随若干众生心说法。令一一众生。心中得若干无量诸法。如一佛。一切佛在大会中说法。皆亦如是。如一毛头。一切十方世界。皆亦如是。于是中。应生大忆念力。于一念中。从一切佛所。受一切法明。而不失一句。如上大会满中众生听法。或于是中。以决定清净法明演说。令得开解。于一念中。令尔所众生。皆得欢喜。何况若干世界中众生。是菩萨。住是地中。善根转胜。昼夜更无余念。深入诸佛行处。常与一切佛会。深入菩萨解脱。菩萨随顺。如是智。常见诸佛。而于一一劫中。无量无边百千万亿。以妙供具。供养诸佛。于诸佛所。种种问难。通达诸陀罗尼。是菩萨。善根转胜明净。如是佛子。如成炼金。具足庄严。转轮圣王宝冠。若在璎珞。一切小王。四天下人。无能夺者。诸佛子。菩萨摩诃萨。亦如是。住此妙善地中。诸善根。转胜明净。无能坏者。声闻辟支佛。及诸地菩萨。所不能坏。是菩萨善根转明。能照众生烦恼难处。照已还摄。佛子。譬如大梵王。三千大千世界。一切所有难处。皆悉能照。菩萨亦如是。住是菩萨妙善地中。善根明净照众生烦恼难处。照已还摄。诸佛子。是名略说菩萨摩诃萨第九菩萨妙善地。若广说。则无量无边劫。不可得尽。菩萨摩诃萨住是地中。多作大梵王。典领三千大千世界。无有能胜。如实解义者。于自在中。而得自在。善能宣说声闻辟支佛。菩萨波罗蜜。众生问难。无能穷尽。所作善业。若布施若爱语。若利益若同事。皆不离念佛念法念菩萨伴。乃至不离念一切种智。常生是心。我当何时于众生中。为首为尊。乃至于一切众生中。为依止者。是菩萨。若欲如是勤行精进。于一念中。得百万阿僧祇三千大千世界微尘数三昧。乃至能示百万阿僧祇三千大千世界微尘数菩萨眷属。若以愿力。神通自在。复过是数。百千万亿那由他劫。不可称说。尔时金刚藏菩萨。欲重明此义。而说偈言

  诸菩萨随顺　　无量深智力
  第一最微妙　　一切世难知
  利益众生者　　能至第九地
  得入于诸佛　　秘密之藏处
  得微妙最上　　三昧陀罗尼
  广大神通力　　善入世间相
  智慧力决定　　能观诸佛法
  大愿悲心净　　得入第九地
  顺行此上地　　持诸佛藏者
  即能通诸法　　善不善无记
  是有漏无漏　　世间出世间
  是则可思议　　是不可思议
  知法定不定　　三乘具足相
  思惟分别此　　有为无为相
  起知如是法　　破诸无明闇
  随顺是智心　　则为第一妙
  悉知诸众生　　崄难诸杂心
  轻躁易转心　　无边自在心
  烦恼深浅相　　心伴不离心
  又知使缠相　　随顺相续有
  知业种种杂　　各各差别相
  因灭果不失　　通达如是事
  又知于众生　　诸根软中利
  广大差别等　　先际后际相
  上中下差别　　及诸欲乐等
  乃至能悉知　　八万四千种
  世间性亦尔　　烦恼见难处
  无始来不断　　诸心一切使
  皆与心共行　　缚心难可断
  知诸结使等　　但妄想分别
  无有方处所　　亦无定事相
  亦不离于身　　又亦难得知
  禅定力能遮　　金刚道能断
  又能知众生　　入六道差别
  爱水痴闇覆　　业田识是种
  生于后身牙　　名色共增长
  无始生死来　　相续在三界
  及知天龙等　　烦恼诸业心
  若离于心者　　是则无所有
  一切诸众生　　皆在三聚中
  或没诸邪见　　或在于智道
  菩萨住是地　　悉知众生心
  诸根及欲乐　　种种差别等
  深心善思惟　　随宜而说法
  通达无碍智　　善以言辞说
  菩萨为法师　　犹如师子王
  牛王如山王　　安住无所畏
  普于诸世界　　雨美甘露味
  犹如大龙王　　能雨满大海
  是菩萨善知　　法义辞无碍
  善能随顺行　　具足乐说力
  能得于百万　　阿僧祇总持
  能受诸佛法　　如海受龙雨
  菩萨得如是　　诸深妙清净
  无量陀罗尼　　诸三昧力故
  能于一念中　　得见无量佛
  闻已净梵音　　演说妙法宝
  是菩萨或教　　大千界众生
  随心根所好　　说法令欢喜
  如是等无量　　三千大千国
  转深勤精进　　而作是思惟
  或于一毛头　　无量佛说法
  佛为种种人　　演说于妙法
  是菩萨皆受　　如地受诸种
  复作如是愿　　十方诸所有
  国土中众生　　皆合为一会
  应于一念中　　皆悉知其心
  以一音说法　　悉令断疑网
  菩萨住是地　　人天中法王
  为大说法师　　随顺众生心
  常于日夜中　　与诸佛共会
  能住甚深妙　　寂灭智解脱
  供养无量佛　　善根转明净
  犹如转轮王　　真金严宝冠
  光明照众生　　烦恼崄难处
  如梵王光明　　照于大千界
  菩萨住是地　　作三千大千
  世界大梵王　　诸根悉猛利
  善以三乘法　　示悟诸众生
  所作诸善业　　皆顺于正念
  能在一念中　　而得于无量
  世界微尘数　　诸深妙三昧
  得见十方佛　　微妙音说法
  见佛大神力　　更发无量愿
  如是第九地　　大智所行处
  深妙难知见　　今已略说竟

    法云地第十

  说诸大菩萨　　所行无上事
  无数那由他　　首陀会诸天
  于上虚空中　　心皆大欢喜
  咸以恭敬心　　众妙供养佛
  那由他菩萨　　欢悦无有量
  烧诸奇妙香　　灭除诸烦恼
  他化自在王　　与诸天大众
  住在虚空中　　心皆大欢喜
  咸以恭敬心　　种种设供养
  各散众宝衣　　空中旋转下
  无量亿天女　　诸根欣悦豫
  于上虚空中　　敬心供养佛
  同作无量亿　　那由他伎乐
  于诸众物中　　皆出如是音
  佛坐于此处　　悉遍于一切
  十方国土中　　皆亦有佛现
  无量亿种种　　相好庄严身
  姝妙无有比　　充满于世界
  于一毛孔中　　出无量光明
  灭除于一切　　世间烦恼火
  十方微尘数　　不可得计量
  一毛孔光明　　亦复不可尽
  各见有佛身　　以三十二相
  八十好庄严　　转于无上轮
  或见佛种种　　为众而说法
  或见在兜率　　教化于诸天
  或见从兜率　　来下处胞胎
  或见初生时　　或见夜出家
  或见坐道场　　而成无上道
  或见转法轮　　或见入涅槃
  于无量国土　　种种而示现
  欲度众生故　　皆有如是事
  譬如巧幻师　　善知于幻术
  多示诸众生　　种种诸异身
  如是佛慧中　　善巧于示现
  变化一切身　　周遍诸世间
  如诸法空寂　　先来无性相
  同若如虚空　　大师亦如是
  得入第一义　　微妙之性相
  随于法性相　　示佛大神力
  诸佛所行性　　一切诸众生
  皆在是性中　　相可相同相
  一切诸法等　　入在于第一
  寂灭义趣中　　悉皆无有相
  若欲得佛智　　应离诸想念
  有无俱通达　　疾作天人师
  诸天婇女众　　皆出如是等
  千万种妙音　　寂然而观佛
  解脱月菩萨　　见众皆寂然
  请金刚藏言　　大名称佛子
  菩萨从九地　　至于第十地
  诸大神通力　　愿今为略说

尔时金刚藏菩萨言。佛子。诸菩萨摩诃萨。如是无量智慧。善修行佛道。乃至九地。善集诸白法。集无量助道法。大功德智慧所护。广行大悲。深知分别世间性差别。深入众生难处。至诸如来行处。念随顺如来寂灭行处。趣向诸佛力无所畏。不共法等。坚持不舍。得至一切智慧位。诸佛子。菩萨摩诃萨。随行如是智。近佛位地。则得菩萨离垢三昧。而现在前。又入法性差别三昧。庄严道场三昧。雨一切世间华光三昧。海藏三昧。海印三昧。虚空广三昧。观择一切法性三昧。随一切众生心行三昧。如实择一切法三昧。得如来智信三昧。如是等百万阿僧祇三昧。皆现在前。是菩萨悉入此三昧。善知其中功用差别。最后三昧。名益一切智位。是三昧现在前时。大宝莲花王出。周圆如百万三千大千世界。一切众宝。间错庄严。过一切世间所有。出世间善根所生。行诸法如幻。性空慧所成。光明能照一切世界。大宝琉璃为茎。胜一切诸天所有。不可量栴檀王为台。大马瑙宝为须。阎浮檀金光为叶。中有无量光明。一切妙宝。皆在其内。宝网覆上。满十三千大千世界微尘数莲花为眷属。尔时菩萨。其身姝妙。称可华座。是菩萨。得益一切智位三昧力故。身现在大莲华座上。即时诸眷属莲华上。皆有菩萨围绕之。一一菩萨。坐莲华上。即得百万三昧。皆一心恭敬。瞻仰大菩萨。是菩萨。升莲华座时。十方现在。一切世界。皆大震动。一切恶道。皆悉休息。光明普照十方世界。一切世界。皆悉严净。皆得见闻一切诸佛大会。何以故。是菩萨。坐大莲华座上。即时足下。出百万阿僧祇光明。照十方阿鼻地狱等。灭众生苦恼。两膝上。放若干光明。悉照十方一切畜生。灭除苦恼。脐放若干光明。照十方一切饿鬼。灭除苦恼。左右胁。放若干光明。照十方人身。安隐快乐。两手放若干光明。照十方诸天阿修罗宫殿。两肩放若干光明。照十方声闻人。项放若干光明。照十方辟支佛。口放若干光明。照十方世界诸菩萨身乃至住九地者。白毫放若干光明。照十方得位菩萨身。一切魔宫。隐蔽不现。顶上放百万阿僧祇三千大千世界微尘数光明。照十方诸佛大会。围绕世界十匝。住于虚空。成光明网。高大明净。供养诸佛。如是供养。从初发心。乃至九地。菩萨所作供养。百分不及一。乃至百千万亿分不及一。乃至算数譬喻。所不能及。是大光明网。胜十方世界所有华香末香。烧香涂香。衣服幡盖。众宝璎珞。摩尼宝珠。供养之具。以从出世善根生故。一一佛大会上。皆雨众宝。状如大云。若有众生。觉知如是供养者。当知皆是必定无上大道。如是诸光。雨大供养已。还绕诸佛大会十匝。入诸佛足下。尔时诸佛。及大菩萨。知某世界中。某甲菩萨摩诃萨。行如是道。成就受职。诸佛子。即时十方无边菩萨。乃至住九地者。皆来围绕。设大供养。一心恭敬瞻礼各得万三昧。诸得职菩萨摩诃萨。于金刚庄严胸。出一大光。名破魔贼。有无量百千万光。以为眷属。照十方世界。示无量神力。亦来入是大菩萨胸。此光明灭已。是菩萨。即时得大势力。神通智慧。百千万倍。诸佛子。尔时诸佛。出眉间白毫相光。名益一切智位。有无量无边光明眷属。照一切十方世界。无有遗余。十匝围绕一切世界。示于诸佛大神通力。劝进无量无边百千万亿诸菩萨。一切十方世界。六种震动。灭除一切恶道苦恼。一切魔宫。皆蔽不现。示一切诸佛得道之处。示一切诸佛大会庄严事。广大如法性。究竟如虚空。照明一切世界已。集在虚空。右绕。示大神通庄严之事。入是菩萨顶上。其诸眷属光明。入诸眷属莲华菩萨顶上。即时诸菩萨。各得先所未得十千三昧。是光明入此菩萨顶。如一佛光。一切佛光。皆亦如是。一切十方佛光明。入是菩萨顶时。名为得职。名为入诸佛境界。为具佛十力。当堕在佛数。诸佛子。譬如转轮圣王长子。大夫人所生。成就转轮王相。转轮圣王。令子在白象宝阎浮檀金座上。取四大海水。上张罗幔。种种庄严。幢幡伎乐。执金钟香水。灌子顶上。即名为灌顶。大王具足。转十善道故。得名转轮圣王。诸佛子。菩萨摩诃萨。亦如是。受职时。诸佛以智水。灌是菩萨顶。名灌顶法王。具足佛十力故。堕在佛数。诸佛子。是名诸菩萨摩诃萨大智慧职。以是职故。诸菩萨摩诃萨。受无量百千亿万苦行难事。是菩萨。得是职已。住菩萨法云地。无量功德。智慧转增。诸佛子。菩萨住是法云地。如实知集欲界。集色界。集无色界。如实知集世间性。集众生性。集识性。集有为性。集无为性。集虚空性。集法性。集涅槃性。集邪见诸烦恼性。如实知诸世间行法还法。如实知集声闻道。集辟支佛道。集菩萨道。集诸佛力无畏。不共法。集色身法身。集一切智慧。如是集得佛道。集转法轮。集示灭度。举要言之。如实知示集一切法差别。是菩萨。以如是智慧。随顺菩提行。如实转深入。知众生化。业化烦恼化。诸见化世性化。法性化。声闻化。辟支佛化菩萨化。如来化一切化。分别无分别化。皆如实入。是菩萨。尔时如实知佛力所持。如实知法处持。如实知业持。烦恼持。时持愿持。先世持行持。劫寿持智持。是菩萨。住十地中。诸佛所有。微细行智。所谓。细微生死智。细微世智。细微出家智。细微得道智。细微神力自在智。细微转法轮智。细微持寿命智。细微示涅槃智。细微法久住智。如是等细微智。皆如实知。又诸佛密处。所谓身密口密意密。筹量时非时密。与菩萨受记密。摄伏众生密。诸乘差别密。八万四千诸根差别密。业如实所作密。行密。得菩提密。如是等密。皆如实知。是菩萨。诸佛所有入劫智。所谓。一劫摄阿僧祇劫。阿僧祇劫摄一劫。有数摄无数。无数摄有数。一念摄无量世。无量世摄一念。劫摄非劫。非劫摄劫。有佛劫摄无佛劫。无佛劫摄有佛劫。过去未来劫摄现在劫。现在劫摄过去未来劫。未来过去劫摄现在劫。现在劫摄未来过去劫。长劫摄短劫。短劫摄长劫。诸劫摄想。皆如实知。是菩萨。诸佛所入毛道智。若入微尘智。若国土智。身心智。得道智。若众生身心得道智。若众生行智。得道智。遍行佛道智。顺行示智。逆行示智。不可思议智。世间能知。声闻能知。辟支佛能知。菩萨能知。有不能知。但如来能知。皆如实入。诸佛子。诸佛智广大。无量无边。菩萨住是地。则能得入如是智慧。诸佛子。是菩萨摩诃萨。随是地行。得菩萨不可思议解脱。得菩萨无碍解脱。净行解脱。普门明解脱。如来藏解脱。随无碍论解脱。入三世解脱。法性藏解脱。解脱明解脱。离差别解脱。诸佛子。是菩萨。十解脱为首。如是等无量无边百千万亿阿僧祇解脱。皆于此地。得得百千万无量阿僧祇三昧。百千万无量阿僧祇陀罗尼。百千万无量阿僧祇神通。亦复如是。是菩萨。成就如是智慧。随顺于菩提。成就无量念力。能于一念顷。至十方无量佛所。受无量法明。无量法雨。皆能受持。譬如娑伽罗龙王。所澍大雨。唯除大海。余地不能堪受。诸佛子。菩萨摩诃萨。亦如是。受大法雨故。能入如来密处。是大法雨。一切众生声闻辟支佛。皆不能受。从初地乃至九地菩萨。亦不能受持。唯此菩萨摩诃萨。住法云地。悉能受持。诸佛子。譬如大海一龙王。起大云雨。皆能堪受。若二龙王。三四五十二十三十四十五十。若百龙王。若千若万。若亿若百亿。若千万亿那由他龙王。乃至无量无边大龙王。起云所雨。一时澍下。皆能受持。所以者何。大海是无量器故。诸佛子。菩萨摩诃萨。亦如是。住法云地。于一佛所。能受大法明雨二佛三四五十百千万亿。乃至无量无边。不可称不可说。无有限过诸算数。于一念中。皆能堪受如是诸佛大法云雨。是故此地。名法云地。问言佛子。是菩萨。于一念中。为能堪受几所佛法明大雨。答言。不可以算数所知。但以譬喻可说。诸佛子。譬如十方所有不可说百千万亿那由他世界中微尘。尔所微尘世界中众生。假使皆得闻持陀罗尼。为佛侍者。为大声闻。多闻第一。譬如金刚莲花上佛。有大择比丘。多闻第一。其一众生。成就如是多闻之力。余若干众生。皆亦如是。其一人所受法。第二人不重受。如是一切。各各不同。诸佛子。于意云何。是一切众生。受持多闻力。为多不。答言无量。诸佛子。我今当为汝说。是菩萨住此法云地。于一念一时。于一佛所。能堪受三世法性藏。名曰大法明雨。上一切众生多闻之力。比此百分不及一。千分万分。千万亿那由他。乃至算数譬喻。所不能及。如一佛所闻。十方若干世界。所有微尘诸佛。皆能堪受大法明雨。复能过此。无量无边。于一念一时。悉能堪受大法明雨。是故名为法云地

复次佛子。菩萨摩诃萨。住是大法云地。自从愿力。生大慈悲。放大法雷音。诸通明无畏。以为电光。发大智慧。以为疾风。大福德善根。以为密云。现种种身色。为杂色云。说法降魔。以为雷音。一念一时。能于上所说微尘世界。皆悉周普。无有遗余。复过此数。以雨善法甘露法雨故。灭众生随心所乐。无明所起。烦恼尘焰是故名为法云地。复次诸佛子。菩萨摩诃萨。住是法云地。于一世界中。从兜率天上来下。乃至示大涅槃。一切佛事。随所度众生。皆现神力。若二三千世界。乃至如上微尘数世界。又复过是百千万亿阿僧祇世界。从兜率来下。乃至示大涅槃。一切佛事。随所度众生。皆现神力。是菩萨。住在此地。于智慧中。得上自在力。善择大智慧。或以狭国为广。广国为狭。或以垢国为净。如是。一切世间性。皆有神力。是菩萨。或于一微尘中。有一三千大千世界铁围山川。而不迫隘。或二三四五十二十三十四十五十。若百若千。万亿无量。不可说不可说世界。诸庄严事。皆示入一微尘。若以一世界庄严事。示不可说不可说世界。或以乃至不可说不可说世界众生。置一世界中。亦不迫隘。或以一世界众生。置不可说不可说世界中。或以不可说不可说世界。示着一毛头。而不恼众生。或于一毛中。示一切佛神通力庄严之事。或以十方所有不可说不可说世界微尘。于一念中。现如是等身。于一身中。示若干无量手。以此手。勤心供养十方诸佛。以一一手。捉恒河沙等莲华。聚以散诸佛。涂香杂香。末香衣服。幡盖宝物。亦复如是。一切庄严之具。皆以手执供养诸佛。于一一身。皆亦如是。又一一身。化有尔所尘数头。于一一头。有尔所尘数舌。以是神力。赞叹诸佛。如是等事。于念念中。遍满十方。于念念中。以神通力。于无量世界。示得佛道。转于法轮。乃至大般涅槃。于三世中。以神通力。示现无量身。于自身中。现佛无量无边。佛土庄严事。于自身中。示一切世界成坏事。或令一切诸风皆于一毛孔出。而不恼众生。或欲以无量无边世界。为一海水。此海水中。作大莲华。形色光明。遍照无量无边世界。于中示得菩提庄严妙事。乃至示得一切种智。自身中所有一方光明。摩尼宝珠。电光日月。星宿诸光明。乃至十方世界。所有光明诸物。皆于身中现。以口嘘气。能令一切十方无量无边世界震动。而不令众生。有惊畏想。示十方世界。水劫尽风劫火劫尽。而众生身。随意庄严。或欲于自身。示作如来身。如来身作自身。如来身作己佛国。己佛国。作如来身。诸佛子。菩萨摩诃萨。在此菩萨法云地。神变如是。又余无量神力自在。奇异示现。尔时会中。有诸菩萨。天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。释提桓因。梵天王。四天王。自在天子。净居天等。各作是念。若菩萨神通力。智慧力。如是无量无边。佛复云何。尔时解脱月菩萨摩诃萨。知大众心所念。问金刚藏菩萨言。佛子。今诸大众。皆有所疑。闻是菩萨大神通智慧力。堕在疑网。汝今当断一切疑惑。示菩萨神通庄严妙事。即时金刚藏菩萨。入一切佛国体性三昧。时诸大众。天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。释提桓因。梵天王。护世天王。自在天子。净居天等大众。皆自见知入金刚藏菩萨身中。于其身内。见有三千大千世界庄严众事。若满一劫。说不可尽于中见佛道场树。其茎周围。十万三千大千世界。高百万三千大千世界。覆荫三千亿三千大千世界。称树高广。有师子座。其座上有佛。号一切智王如来。一切大众。咸皆见佛坐在座上。其中所有庄严上妙供养之具。满一劫说。亦不可尽。金刚藏菩萨。示现如是大神力已。还令大众各在本处。尔时一切众会。生希有想。默然一心。观金刚藏菩萨。尔时解脱月菩萨。问金刚藏菩萨言。佛子。甚为希有。是三昧。有大势力。是三昧者。名为何等。答言。是三昧者。名为一切佛国体性。问言。是三昧。所有势力为齐几所。答言。佛子。若菩萨摩诃萨。善修成是三昧力者。能以如是无量恒河沙世界微尘数三千大千世界。于身中现。复过是数。佛子。菩萨摩诃萨。在此法云地。得如是诸菩萨三昧。无量无边百千万亿。以是故。此菩萨。住是地中。身身业。难可测知。口口业。难可测知。意意业。难可测知。神力自在。难可测知。观三世法。难可测知。诸三昧行入。难可测知。智力。难可测知。游戏诸解脱。难可测知。变化所作。神力所作。势力所作。难可测知。略说。乃至举足下足。乃至小王子菩萨。住妙善地者。不能测知。诸佛子。菩萨法云地。如是无量。今已略说。若广说者。无量无边阿僧祇劫。不能得尽。问言佛子。若菩萨。行处力神通力如是者。佛行处力神通力。复云何。答言佛子。譬如有人取四天下中二三块土。作是言。无边世界地性。为多此耶。汝所问者。我谓如是。如来无量智慧。云何以菩萨智慧。而欲测量。诸佛子。如人取四天下中少地性。余在极多。诸菩萨法云地。于无量劫。但可说耳。何况如来地。诸佛子。我今唱说。令汝知之。佛现在为证。如一一方。无量无边世界微尘等诸佛世界。十地菩萨皆满其中。譬如稻麻丛林。是诸菩萨。有无量无边业。修习菩萨功德智慧禅定。于如来功德智慧力。百分不及一。百千万亿分不及一。乃至算数譬喻。所不能及。诸佛子。是菩萨。随如是智慧。顺如来身口意。亦不舍诸菩萨三昧。而勤心供养诸佛。于一一劫。以一切粗现(丹本微妙)供养具。供养无量无边诸佛。而能具受诸佛神力。转复明胜。是菩萨。于法性问难。无能胜者。乃至无量无边百千万亿劫不可穷尽。佛子。譬如大金师。善治此金。为庄严物。以无上摩尼宝珠。间错其中。安置自在天王颈上。其余诸天。无能夺者。又诸天人庄严之具。无能及者。诸佛子。菩萨住十地中。智慧功德善根。从初地至九地。诸菩萨摩诃萨。所不能及。菩萨住是地中。得大智照明故。能随顺一切智慧。其余智慧之明。所不能坏。譬如佛子。大自在天王光明。一切生处。众生光明。所不能及。能令众生。身心凉冷。诸佛子。菩萨摩诃萨。亦如是。住是法云地中。智慧光明。一切声闻。辟支佛。所不能及。从初地乃至九地菩萨摩诃萨。亦不能及。是菩萨。住是地中。能令无量众生。住一切智道。诸佛子。菩萨摩诃萨。住是地中。诸十方佛。为说智慧。令通达三世。正知法性相。以智普覆一切世间。照一切世间性。大悲大慈。普覆一切众生。正遍见知一切诸法。举要言之。具足为说。至一切智道。佛子。是名菩萨摩诃萨第十菩萨法云地。菩萨摩诃萨。住是地中。多作摩醯首罗天王。智慧明达。善说声闻辟支佛。菩萨波罗蜜。于法性中。有问难者。无能令尽。所作善业。若布施若爱语。若利益若同事。皆不离念佛念法念菩萨伴。念菩萨行。念诸波罗蜜。念诸地行。不离念十力。念无所畏。念不共法。乃至不离念具足一切种智。常作是念。我当何时于众生中。为首为胜。为大为妙。为上为无上为导为将。为师为尊。乃至于一切众生中。为依止者。若欲如是勤行精进。于一念中。得无量百千万亿那由他不可说不可说世界微尘数三昧。乃至示尔所微尘数。菩萨眷属。若以愿力。神通自在。复过是数。所谓诸行上妙供具。信解起业若身若口。若光明若诸根。若如意若音声。若行处。乃至若干百千万亿劫。不可称数。诸佛子。是名菩萨摩诃萨地次第顺行趣向一切种智。佛子。譬如从阿耨达池。四河流出。满足四天下。转增无有穷尽。乃入大海。诸佛子。菩萨摩诃萨。亦如是。从菩萨出于善根大愿之水。以四摄法。满足众生。而不穷尽。转更增长乃至一切种智。诸佛子。是诸菩萨十地。因佛智故。而有差别。譬如因大地故。有十大山王。何等为十。所谓。雪山王。香山王。轲梨罗山王。仙圣山王。由乾陀罗山王。马耳山王。尼民陀罗山王。斫迦婆罗山王。众相山王。须弥山王。佛子。如雪山王。一切药草。集在其中。取不可尽。诸佛子。菩萨摩诃萨。亦如是。住在菩萨欢喜地。一切世间。经书伎艺。文颂咒术。集在其中。无有穷尽。诸佛子。如香山王。一切诸香。聚在其中。而不可尽。菩萨摩诃萨。亦如是。住菩萨离垢地中。持戒头陀。威仪助法。集在其中。无有穷尽。诸佛子。如轲梨罗伽山王。但以宝成。集诸妙华。取不可尽。诸佛子。菩萨亦如是。住于明地。集一切世间。禅定神通。解脱三昧门不可尽。诸佛子。如仙圣山王。但以宝成。多有五神通圣人。不可穷尽。诸佛子。菩萨摩诃萨。亦如是。住菩萨焰地中。集令众生。入道因缘。种种问难。不可穷尽。诸佛子。如由乾陀罗山王。但以宝成。集夜叉大神。夜叉罗刹众不可穷尽。诸佛子。菩萨亦如是。住菩萨难胜地中。集一切自在。如意神通。说不可尽。诸佛子。如马耳山王。但以宝成。集众妙果。取不可尽。诸佛子。菩萨摩诃萨。亦如是。住现前地中。集深因缘法。说声闻果。不可穷尽。诸佛子。如尼民陀罗山王。但以宝成。集诸一切大力龙神。不可穷尽。诸佛子。菩萨摩诃萨。亦如是。住菩萨远行地中。集种种方便智慧。说辟支佛道。不可穷尽。诸佛子。如斫迦婆罗山王。但以宝成。集心自在者。不可穷尽。诸佛子。菩萨摩诃萨。亦如是。住无动地。集一切菩萨自在道。说世间性。不可穷尽。诸佛子。如众相山王。但以宝成。集大神力。诸阿修罗。无有穷尽。诸佛子。菩萨亦如是。住菩萨妙善地中。集转众生行智。说世间相。不可穷尽。诸佛子。如须弥山王。但以宝成。集诸天神。无有穷尽。诸佛子。菩萨亦如是。住法云地中。集如来十力。四无所畏。说诸佛法。不可穷尽。诸佛子。是十宝山。同在大海。因大海水。有差别相。诸菩萨摩诃萨十地。亦如是。同在佛智。因一切智故。有差别相。诸佛子。譬如大海。以十相故。数名大海。无有能坏。何等为十。一渐次深。二不共死尸宿。三余水失本名。四一味。五多宝聚。六极深难入。七广大无量。八多有大身众生依住。九不过常限。十能受一切大雨无有盈溢。诸佛子。诸菩萨行。亦如是。以十因缘故。得名无有能坏。何等为十。欢喜地中。渐次生坚固愿。离垢地中。不与破戒者共宿。明地中。舍诸世间假名。焰地中。于佛所得一心不坏信净。难胜地中。生世间无量方便神通。起世间事。现前地中。观甚深因缘法。远行地中。以广大心。善择诸法。无动地中。能起大庄严事示现。妙善地中。能得深解脱。通达世间行。如实不过。法云地中。能受一切诸佛大法明雨。诸佛子。譬如大摩尼宝珠。有十事。能与众生一切宝物。何等为十。一出大海。二巧匠加治。三转精细。四除其垢秽。五以火炼治。六众宝庄严。七贯以宝缕。八置在琉璃高柱。九光明四照。十随王意雨众宝物。诸佛子。菩萨摩诃萨。发菩提心宝。亦有十事。何等为十。一初发心布施离悭。二修持戒头陀苦行。三以诸禅定解脱三昧令转精妙。四以道行清净。五练以方便神通。六以深因缘法庄严。七以种种深方便智慧贯穿。八置以神通自在憧上。九观众生行放多闻智慧光明。十诸佛授智职。尔时于一切众生。能为佛事。堕在萨婆若数。诸佛子。是诸菩萨所行。集一切智慧功德法门品。若不深种善根者。不能得闻。问言。若得闻者。是人为得几许福。答言。随诸佛所有智慧慧力。如是发萨婆若心。所缘摄福德。是人得闻此法门。所得福德。亦复如是。何以故。若无菩萨心。闻是法门。不能信解受持。何况以身修习。能成是事。诸佛子。以是故当知。是人随顺一切种智。得闻信解受持修行。说是经时。以佛神力。十方世界。十亿佛国。微尘数世界。六种十八相动。又法应震动。诸天雨华。如云而下。雨诸香璎珞。天宝衣。天幡盖。天宝物。天庄严身具。雨天伎乐歌颂。而下更有大音。赞叹十地殊胜之事。此他化自在天王宫。四天下中。如是十方一切世界周遍。皆说十地经。以佛神力故。十方过十亿佛国微尘数世界。有十亿佛国微尘数诸菩萨来。遍满十方虚空。皆作是言。善哉善哉。金刚藏。佛子。善说诸菩萨摩诃萨住诸地相。佛子。我等皆亦名金刚藏。从金刚德世界。金刚憧佛所来。所经历处。皆说是经。众会亦如是。言辞亦如是。义趣亦如是。不增不减。佛子。我等以佛力故。到此大众。来证是事。诸佛子。如我等来至此众。如是十方一切世界。一一世间种性。四天下上他化自在天王宫摩尼宝殿。皆有十亿佛国微尘数菩萨。往为作证。尔时金刚藏菩萨观察十方。观一切大众。观深法性。赞叹助发萨婆若心。示众生菩萨大力。欲净诸菩萨行摄一切众生。随顺萨婆若。除一切世间之垢。与诸众生一切种智因缘。示不可思议智慧庄严妙事。说一切菩萨功德差别相。欲令此义转胜明显示众生故。承佛神力。而说偈言

  诸菩萨所行　　乐于善寂灭
  其心无所著　　犹若如虚空
  除贪恚痴垢　　安住道智中
  如是无上行　　愿乐欲听闻
  如是诸菩萨　　在于无量劫
  勤心常修习　　万亿种善根
  供养无量佛　　辟支阿罗汉
  为利众生故　　乃生菩提心
  精勤持戒行　　头陀除罪垢
  修善忍转妙　　惭愧威德满
  福慧因缘故　　高胜心明净
  深乐于佛智　　同佛生菩提
  供养于一切　　十方三世佛
  如虚空等国　　悉皆令清净
  一切法平等　　善悉通达故
  为度一切众　　生于菩提心
  诸菩萨如是　　生是无量心
  至于欢喜地　　息恶乐布施
  得诸本愿力　　慈悲心偏多
  深行十善道　　能到离垢地
  戒闻功德富　　慈心愍世间
  永离诸垢秽　　深心常清净
  普观诸世间　　三毒火炽然
  如是之大士　　能入三明地
  观三界皆空　　无常亦如病
  如痈如疮箭　　百种苦常然
  见诸有为过　　贪着佛功德
  得佛智明焰　　得入于焰地
  成就于念慧　　得至道智中
  在此地供养　　百千种诸佛
  常能思惟念　　诸佛无量德
  得入于一切　　世间难胜地
  能以慧方便　　种种而示现
  诸有所为作　　以利于世间
  供养于诸佛　　作益众生事
  无生法在前　　得入现前地
  菩萨诸所行　　一切世难知
  常无有我心　　离有亦离无
  诸法先空寂　　十二缘故行
  善了此微细　　能入远行地
  行慧方便等　　得法寂灭相
  如是之大士　　难知难可及
  为欲令世间　　得善寂灭故
  还起修诸行　　种种福德事
  普入于众生　　种种心行处
  如是能得入　　等空不动地
  大智诸菩萨　　悉善能具行
  种种诸智业　　得十自在力
  能以无有量　　无边限诸身
  普现十方界　　而为说妙法
  善达世间性　　及诸众生性
  如是大慈悲　　能入妙善地
  第一妙净智　　善观诸世间
  缕练烦恼业　　深曲险难处
  为度是等故　　得诸佛法藏
  善说第一义　　悉无所违错
  如是次第行　　具足诸善法
  乃至到九地　　所修集福慧
  欲得诸佛力　　第一深妙利
  乃于一切佛　　能得受智职
  先得无数定　　智行极广大
  末后得难坏　　诸智职三昧
  若能得如是　　一切职三昧
  一切宝庄严　　大莲花即出
  菩萨称莲花　　现身坐其上
  余花诸菩萨　　咸共一心视
  尔时大菩萨　　从身放无量
  百千亿光明　　灭诸世间苦
  然后顶上出　　百千亿光明
  普照十方界　　诸佛大会众
  于上虚空中　　化成光明网
  供养诸佛已　　入诸佛足下
  时诸一切佛　　及诸大菩萨
  各知其菩萨　　得受于智职
  如是一切佛　　报以眉间光
  名曰一切职　　入此菩萨顶
  一切无量佛　　与此菩萨职
  犹如转轮王　　假授太子位
  时诸十方界　　普皆大震动
  乃至阿鼻等　　诸苦皆除灭
  菩萨为一切　　智慧得是职
  如是名为到　　无上法云地
  住于是地中　　智慧无边限
  善知度一切　　世间诸因缘
  入色无色法　　欲色无色界
  能知众生性　　国土性法性
  又能入可数　　不可数法中
  乃至能观择　　虚空无量性
  入此地悉具　　菩萨变化事
  诸佛威神力　　微细智密事
  又能悉通达　　一切诸劫数
  于一毛端中　　观见世间性
  一切诸如来　　于此无上地
  初生及出家　　得道转法轮
  示入于涅槃　　皆随顺于智
  寂灭妙解脱　　悉于此地得
  此地诸大士　　忆念力大故
  诸佛大法雨　　皆悉能受持
  譬如大海水　　能持龙王雨
  诸佛大法雨　　菩萨受亦尔
  若于一佛所　　一时听受法
  十方无量土　　微尘数众生
  皆得闻总持　　成于声闻乘
  不如是菩萨　　算数所不及
  大智慧力故　　及生大愿力
  能于一念中　　遍满无量国
  雨甘露法水　　灭诸烦恼火
  是故诸佛名　　此地为法云
  大士住此地　　供养诸佛具
  过诸天所有　　普示大神力
  示众转胜力　　过是数无量
  若人欲思量　　迷闷不能解
  大智住此地　　举足下足事
  及余诸菩萨　　乃至于九地
  皆悉不能知　　何况余众生
  三世诸声闻　　及与辟支佛
  住此诸佛示　　一切智慧事
  亦与令通达　　三世无碍智
  亦示法性寂　　亦示种种变
  一切诸世界　　所有众生类
  所行一切法　　深微隐妙事
  一切佛功德　　次第示令知
  菩萨住此地　　能以大供具
  供养十方佛　　遍满一切方
  一切诸世间　　所有众生类
  其余诸供具　　皆所不能及
  智者住此地　　皆能破一切
  无明诸闇冥　　开示以佛道
  如自在天王　　光灭众热恼
  佛子智光明　　灭众恼亦尔
  住是地皆作　　三界自在王
  通达诸智慧　　善以三乘化
  能于一念中　　得无量三昧
  能见十方佛　　其数亦如是
  金刚藏菩萨　　告诸大士言
  我今略解说　　十地妙行已
  若广演说者　　千亿劫不尽
  是则名清净　　诸大菩萨地
  为得佛智故　　住于此地中
  安住不移动　　犹如大山王
  初地具一切　　经书诸伎术
  犹如雪山王　　积聚众药草
  持戒及多闻　　在于二地中
  犹如香山王　　集诸一切香
  如轲梨罗山　　多积诸宝花
  明地集闻智　　其喻亦如是
  焰地多积聚　　道法宝不坏
  如仙圣山中　　善寂人不少
  五地诸神通　　无能得及者
  如由乾陀山　　夜叉神不少
  六地善分别　　诸果无穷尽
  犹如马耳山　　诸果无有量
  七地中大慧　　无有能及者
  如尼民陀山　　诸龙王不少
  住于八地中　　自在智无量
  如斫迦罗山　　多心自在者
  九地心清净　　说法无障碍
  犹如众相山　　阿修罗不少
  十地中诸佛　　功德无穷尽
  如须弥山王　　多诸天神众
  又复初地中　　发于广大愿
  二地持戒品　　三地行功德
  第四地专一　　五地众妙事
  六地甚深相　　七地广大心
  八地中种种　　庄严诸神通
  九地思妙智　　能过一切世
  十地能受持　　诸佛大法雨
  菩萨行大海　　难动不可尽
  发心出世间　　得入于初地
  二地净持戒　　三地修诸禅
  四地道行净　　五练方便慧
  六因缘庄严　　七深方便慧
  八到琉璃幢　　九地行众生
  一切险难处　　智慧光普照
  十地受智职　　犹如国王许
  如是次第净　　菩提心妙宝
  十方诸世界　　所有微尘数
  可于一念中　　计知其多少
  可以一毛头　　数知于虚空
  诸佛大功德　　无量不可尽

说是十住经时。自在天王。及诸天众。解脱月菩萨。及诸菩萨。一切世间。皆大欢喜。信受奉行

十住经卷第四


文殊师利发愿经

    No. 296 [No. 297; cf. 293(Fasc. 40)]

    文殊师利发愿经

        东晋天竺三藏佛陀跋陀罗译

  身口意清净　　除灭诸垢秽
  一心恭敬礼　　十方三世佛
  普贤愿力故　　悉睹见诸佛
  一一如来所　　一切刹尘礼
  于一微尘中　　见一切诸佛
  菩萨众围绕　　法界尘亦然
  以众妙音声　　宣扬诸最胜
  无量功德海　　不可得穷尽
  以普贤行力　　无上众供具
  供养于十方　　三世一切佛
  以妙香华鬘　　种种诸伎乐
  一切妙庄严　　普供养诸佛
  我以贪恚痴　　造一切恶行
  身口意不善　　悔过悉除灭
  一切众生福　　诸声闻缘觉
  菩萨及诸佛　　功德悉随喜
  十方一切佛　　初成等正觉
  我令悉劝请　　转无上法轮
  示现涅槃者　　合掌恭敬请
  住一切尘劫　　安乐诸群生
  我所集功德　　回向施众生
  究竟菩萨行　　逮无上菩提
  悉供养过去　　现在十方佛
  愿未来世尊　　速成菩提道
  普庄严十方　　一切诸佛刹
  如来坐道场　　菩萨众充满
  令十方众生　　除灭诸烦恼
  深解真实义　　常得安乐住
  我修菩萨行　　成就宿命智
  除灭一切障　　永尽无有余
  悉远离生死　　诸魔烦恼业
  犹日处虚空　　莲花不着水
  遍行游十方　　教化诸群生
  除灭恶道苦　　具足菩萨行
  虽随顺世间　　不舍菩萨道
  尽未来际劫　　具修普贤行
  若有同行者　　愿常集一处
  身口意善业　　皆悉令同等
  若遇善知识　　开示普贤行
  于此菩萨所　　亲近常不离
  常见一切佛　　菩萨众围绕
  尽未来际劫　　悉恭敬供养
  守护诸佛法　　赞叹菩萨行
  尽未来劫修　　究竟普贤道
  虽在生死中　　具无尽功德
  智慧巧方便　　诸三昧解脱
  一一微尘中　　见不思议刹
  于一一刹中　　见不思议佛
  见如是十方　　一切世界海
  一一世界海　　悉见诸佛海
  于一言音中　　具一切妙音
  一一妙音中　　具足最胜音
  甚深智慧力　　入无尽妙音
  转三世诸佛　　清净正法轮
  一切未来劫　　悉能作一念
  三世一切劫　　悉为一念际
  一念中悉见　　三世诸如来
  亦普分别知　　解脱及境界
  于一微尘中　　出三世净刹
  一切十方尘　　庄严刹亦然
  悉见未来佛　　成道转法轮
  究竟佛事已　　示现入涅槃
  神力遍游行　　大乘力普门
  慈力覆一切　　行力功德满
  功德力清净　　智慧力无碍
  三昧方便力　　逮得菩提力
  清净善业力　　除灭烦恼力
  坏散诸魔力　　具普贤行力
  严净佛刹海　　度脱众生海
  分别诸业海　　穷尽智慧海
  清净诸行海　　满足诸愿海
  悉见诸佛海　　我于劫海行
  三世诸佛行　　及无量大愿
  我皆悉具足　　普贤行成佛
  普贤菩萨名　　诸佛第一子
  我善根回向　　愿悉与彼同
  身口意清净　　自在庄严刹
  逮成等正觉　　皆悉同普贤
  如文殊师利　　普贤菩萨行
  我所有善根　　回向亦如是
  三世诸如来　　所叹回向道
  我回向善根　　成满普贤行
  愿我命终时　　除灭诸障碍
  面见阿弥陀　　往生安乐国
  生彼佛国已　　成满诸大愿
  阿弥陀如来　　现前授我记
  严净普贤行　　满足文殊愿
  尽未来际劫　　究竟菩萨行　文殊师利发愿经


显无边佛土功德经

    No. 289 [Nos. 278(26), 279(31), 290]

    显无边佛土功德经

        大唐三藏法师玄奘译

如是我闻。一时薄伽梵在摩揭陀国闲寂法林。坐妙菩提金刚坚固无量妙宝共所庄严红莲华台师子座上。与十不可说俱胝那庾多百千佛土极微尘数大菩萨俱。及诸天人。阿素洛等。无量大众。前后围绕

尔时会中。有一菩萨摩诃萨。名不可思议光王。承佛威神。从坐而起。顶礼佛足。合掌恭敬。而白佛言。世尊。诸佛国土。时分庄严。有胜劣不。佛言。善男子。我此索诃世界。释迦牟尼佛土一劫。于极乐世界无量光佛土。为一昼夜。极乐世界一劫。于袈裟幢世界金刚坚固欢喜佛土。为一昼夜。袈裟幢世界一劫。于不退轮音世界极妙圆满红莲敷身佛土。为一昼夜。不退轮音世界一劫。于绝尘世界法幢佛土。为一昼夜。绝尘世界一劫。于明灯世界师子佛土。为一昼夜。明灯世界一劫。于妙光世界遍照佛土。为一昼夜。妙光世界一劫。于难超世界身放法光佛土。为一昼夜。难超世界一劫。于庄严世界一切神通慧光王佛土。为一昼夜。庄严世界一劫。于镜轮世界月觉佛土。为一昼夜。善男子。如是世界。展转渐增。满十不可说俱胝那庾多百千佛土极微尘数世界佛土。最后世界。佛土一劫。于莲华德世界贤德佛土。为一昼夜。于彼世界。诸菩萨众。修治殊胜普贤行地。善男子。如诸世界昼夜渐增。如是诸佛寿量身相。菩萨世界庄严亦尔。由彼有情福转增故。若有善男子善女人。闻此显示无边佛土功德法门。欢喜信重。受持读诵。如理思惟。广为他说。临命终时。十方佛土。无量诸佛。皆现其前。慰喻赞美。令其增进无量善根。随愿往生诸佛净国。乃至无上正等菩提。于生生中。常忆宿命。修菩萨行。速得圆满。时薄伽梵。说此经已。不可思议光王菩萨摩诃萨。并诸天人。阿素洛等。一切众会。闻佛所说。皆大欢喜。信受奉行显无边佛土功德经


信力入印法门经卷第一

    No. 305

信力入印法门经卷第一

        元魏天竺三藏昙摩流支译

归命一切诸佛。如是我闻。一时婆伽婆。住如来住持境界之处。去寂灭道场不远普光法殿大福德善根所成之处。平等普遍无可嫌处。具足无量功德之处。金刚坚固所成之处。不可坏地安固之处。一切摩尼宝珠众华庄严之处。无诸垢秽光明赫奕摩尼宝王庄严之处。无量光明宽博广大摩尼宝海示现之处。不可穷尽摩尼宝雨如意宝网所生之处。众华回轮摩尼树枝庄严之处。一切华香摩尼宝网间错之处。悉能示现一切众生诸佛住持奋迅之处。诸世界中最妙之处。出生一切无垢摩尼力能示现遍诸世界庄严之处。庄严寂灭道场大毗琉璃摩尼宝性出生增长积聚之处。如意宝王栏楯之处。能以如意真珠宝绳庄严之处。建立宝幢幡盖之处。种种宝铃间错庄严。以忧茶伽坚固栴檀涂地之处。自在如意宝王罗网覆盖之处。大海住持清净庄严普光摩尼宝王树网坚缚之处。置师子髦摩尼宝王妙案之处。师子座幢摩尼宝王楼阁窗牖庄严之处。建立种种宝幢幡盖庄严之处。曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。卢遮华。摩诃卢遮华。斫迦罗华。摩诃斫迦罗华。须摩那华。婆师迦华多罗尼华。婆罗华。衢多罗尼华。极妙香华。陀师迦离迦华。天须摩那华。优钵罗华。波头摩华。拘物头华。分陀利华。诸大天人妙华之处。无障无碍诸华庄严师子坐处。如是处住。婆伽婆善清净智慧。得成究竟无二之行。得至诸法无相彼岸。依于诸佛所行而行。得一切佛平等之处。得至无障无碍之处。得不退转法轮之处。得无能伏境界之处。得不思议差别之处。得于三世平等之处。得诸世间去来无障无碍之处。得一切法无疑智处。得一切行毕竟智处。得于一切诸如来智无疑之处。得无分别法身之处。得佛境界彼岸之处。得无差别诸佛如来究竟解脱无疑之处。得至平等无边无中佛地之处。得至诸佛广大如法界究竟如虚空无有边际自然智业一切诸佛如来所作不休息处。得未来际尽一切劫能转不退法轮之处。复能示现无障碍智庄严之藏。得一切种一切智智无有差别依止之处。于一时中十方世界。兜率天退。初生出家。行于苦行。往诣道场。降伏魔怨。证大菩提。转于法轮。示大涅槃。住持佛法。及以灭法。善能示现与十佛土不可说亿那由他百千万微尘数诸菩萨摩诃萨俱。彼诸菩萨摩诃萨等。一切皆得首楞严定奋迅三昧。悉得成就无量法行起陀罗尼门。无佛世界。善能示现无量诸佛。能悉清净诸染世界。有不可数阿僧祇天龙夜叉。乾闼婆阿修罗。伽楼罗紧那罗。摩睺罗伽。释提桓因。大梵天王。护世四王。人非人等

尔时。文殊师利法王子菩萨摩诃萨。从坐而起。更整衣服。右膝着地。向佛合掌。而白佛言。世尊。唯愿世尊。为诸菩萨摩诃萨。说能清净初地之法。得大无畏安隐之处

尔时佛告文殊师利法王子菩萨摩诃萨言。文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住一味心故。生安隐心。为令他住一味心故。起安慰心。有言一味心者。所谓正心。言正心者。所谓异异胜善根信。无差别故。二谓菩萨生如是心。我已得住增上心故。生安隐心。为令他住增上心故。起安慰心。有言增上心者。所谓直心。言直心者。所谓诸佛如来大行毕竟能取胜进之处。观诸法故。三谓菩萨生如是心。我已得住恭敬心故。生安隐心。为令他住恭敬心故。起安慰心。有言恭敬心者。所谓正信。言正信者。谓住般若根本业故。四谓菩萨生如是心。我已得住欢喜心故。生安隐心。为令他住欢喜心故。起安慰心。有言欢喜心者。所谓身心毕竟寂静故。五谓菩萨生如是心。我已得住魔业佛业无差别智故。生安隐心。为令他住魔业佛业。无差别智故。起安慰心。有言魔业者。所谓能起一切颠倒诸邪见故。从诸邪见起魔业故。此诸魔业与佛地业。无有差别。何以故。不异魔业有佛地业。以魔业体即佛地业体无差别故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住邪见无差别空智故。生安隐心。为令他住邪见无差别空智故。起安慰心。有言邪见无差别空智者。所谓邪见体即空智体。谓邪见作即空智作。何以故。以空智作不异邪见作。邪见作不异空智作。以空智体不异邪见体。邪见体不异空智体。即邪见体邪见作空故。依彼邪见体邪见作空智。一切法空不取不舍差别故。二谓菩萨生如是心。我已得住差别无差别无差别智故。生安隐心。为令他住差别无差别无差别智故。起安慰心。有言差别无差别无差别智者。所谓差别体即无差别体。何以故。无差别体不异差别体。差别体不异无差别体。即差别体无差别故。依彼差别体无差别智一切法无差别故。三谓菩萨生如是心。我已得住增上无差别无增上智故。生安隐心。为令他住增上无差别无增上智故。起安慰心。有言增上无差别无增上智者。所谓增上体即无增上体。何以故。无增上体不异增上体。增上体不异无增上体。即增上体无增上故。依彼增上体无增上智一切法无增上故。四谓菩萨生如是心。我已得住颠倒无差别不颠倒智故。生安隐心。为令他住颠倒无差别不颠倒智故。起安慰心。有言颠倒无差别不颠倒智者。所谓颠倒体即不颠倒体。何以故。不颠倒体。不异颠倒体。颠倒体不异不颠倒体。即颠倒体不颠倒故。依彼颠倒体不颠倒智一切法不颠倒故。五谓菩萨生如是心。我已得住取舍无差别不取不舍智故。生安隐心。为令他住取舍无差别不取不舍故。起安慰心。有言取舍无差别不取不舍智者。所谓取舍体即不取不舍体。何以故。不取不舍体不异取舍体。取舍体不异不取不舍体。即取舍体不取不舍故。依彼取舍体不取不舍智一切法不取不舍故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住有为无差别无为智故。生安隐心。为令他住有为无差别无为智故。起安慰心。有言有为无差别无为智者。所谓有为体即是无为体。何以故。以无为体不异有为体。有为体不异无为体。即有为体是无为故。依彼有为体无为智一切法无为以事无差别故。二谓菩萨生如是心。我已得住事无差别无事智故。生安隐心。为令他住事无差别无事智故。起安慰心。有言事无差别。无事智者。所谓事体即无事体。何以故。以无事体不异事体。事体不异无事体故。以即事体是无事故。依彼事体无事智一切法无事故。三谓菩萨生如是心。我已得住依止无差别无依止智故。生安隐心。为令他住依止无差别无依止智故。起安慰心。有言依止无差别无依止智者。所谓依止体即无依止体。何以故。无依止体不异依止体。依止体不异无依止体。即依止体无依止故。依彼依止体无依止智一切法无依止故。四谓菩萨生如是心。我已得住观无差别无观智故。生安隐心。为令他住观无差别无观智故。起安慰心。有言观无差别。无观智者。所谓观体即无观体。何以故。以无观体不异观体。观体不异无观体故。以即观体是无观故。依彼观体无观智一切法无观故。五谓菩萨生如是心。我已得住对治无差别无对治智故。生安隐心。为令他住对治无差别无对治智故。起安隐心。有言对治无差别无对治智者。所谓对治体即无对治体。何以故。以无对治体不异对治体。对治体不异无对治体。即对治体无对治故。依彼对治体无对治智一切法无对治故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住相无差别。无相智故。生安隐心。为令他住相无差别无相智故。起安慰心。有言相无差别无相智者。所谓相体即无相体。何以故。以无相体不异相体。相体不异无相体故。以即相体是无相故。依彼相体无相智一切法无相故。二谓菩萨生如是心。我已得住实无差别不实智故。生安隐心。为令他住实无差别不实智故。起安慰心。有言实无差别不实智者。所谓实体即不实体。何以故。以不实体不异实体。实体不异不实体故。以即实体是不实故。依彼实体不实智一切法不实故。三谓菩萨生如是心。我已得住二无差别不二智故。生安隐心。为令他住二无差别不二智故。起安慰心。有言二无差别不二智者。所谓二体即不二体。何以故。以不二体不异二体。二体不异不二体故。以即二体是不二故。依彼二体不二智一切法不二故。四谓菩萨生如是心。我已得住色无差别无色智故。生安隐心。为令他住色无差别无色智故。起安慰心。有言色无差别无色智者。所谓色体即无色体。何以故。以无色体不异色体。色体不异无色体故。以即色体是无色故。依彼色体无色智一切法无色故。五谓菩萨生如是心。我已得住世间无差别涅槃智故。生安隐心。为令他住世间无差别涅槃智故。起安慰心。有言世间无差别涅槃智者。所谓世间体即涅槃体。何以故。以涅槃体不异世间体。世间体不异涅槃体。即世间体是涅槃故。依彼世间体涅槃智一切法涅槃故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住障碍无差别无障碍智故。生安隐心。为令他住障碍无差别无障碍智故。起安慰心。有言障碍无差别无障碍智者。所谓障碍体即无障碍体。何以故。无障碍体不异障碍体。障碍体不异无障碍体。即障碍体无障碍故。依彼障碍体无障碍智一切法无障碍故。二谓菩萨生如是心。我已得住执着无差别无执着智故。生安隐心。为令他住执着无差别无执着智故。起安慰心。有言执着无差别无执着智者。所谓执着体即无执着体。何以故。无执着体不异执着体。执着体不异无执着体。即执着体无执着故。依彼执着体无执着智一切法无执着故。三谓菩萨生如是心。我已得住智无差别无智智故。生安隐心。为令他住智无差别无智智故。起安慰心。有言智无差别无智智者。所谓智体即无智体。何以故。以无智体不异智体。智体不异无智体故。以即智体是无智故。依彼智体无智智一切法无智故。四谓菩萨生如是心。我已得住有无差别无智故。生安隐心。为令他住有无差别无智故。起安慰心。有言有无差别无智者。所谓有体即是无体。何以故。无体不异有体。有体不异无体。即有体无故。依彼有体无智一切法无故。五谓菩萨生如是心。我已得住识无差别无识智故。生安隐心。为令他住识无差别无识智故。起安慰心。有言识无差别无识智者。所谓识体即无识体。何以故。以无识体不异识体。识体不异无识体故。以即识体是无识故。依彼识体无识智一切法无识故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住名无差别无名智故。生安隐心。为令他住名无差别无名智故。起安慰心。有言名无差别无名智者。所谓名体即无名体。何以故。以无名体不异名体。名体不异无名体故。以即名体是无名故。依彼名体无名智一切法无名故。二谓菩萨生如是心。我已得住我无差别无我智故。生安隐心。为令他住我无差别无我智故。起安慰心。有言我无差别无我智者。所谓我体即无我体。何以故。以无我体不异我体。我体不异无我体故。以即我体是无我故。依彼我体无我智一切法无我故。三谓菩萨生如是心。我已得住因缘和合作无差别无因缘和合作智故。生安隐心。为令他住因缘和合作无差别无因缘和合作智故。起安慰心。有言因缘和合作无差别无因缘和合作智者。所谓因缘和合作体即无因缘和合作体。何以故。无因缘和合作体不异因缘和合作体。因缘和合作体不异无因缘和合作体。即因缘和合作体无因缘和合作故。依因缘和合作体无因缘和合作智一切法无因缘和合作故。四谓菩萨生如是心。我已得住别相无差别无别相智故。生安隐心。为令他住别相无差别无别相智故。起安慰心。有言别相无差别无别相智者。所谓别相体即无别相体。何以故。无别相体不异别相体。别相体不异无别相体。即别相体无别相故。依彼别相体无别相智一切法无别相故。五谓菩萨生如是心。我已得住字无差别无字智故。生安隐心。为令他住字无差别无字智故。起安慰心。有言字无差别无字智者。所谓字体即无字体。何以故。以无字体不异字体。字体不异无字体故。以即字体是无字故。依彼字体无字智一切法无字故。文殊师利。是名五法诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住憍慢无差别无憍慢智故。生安隐心。为令他住憍慢无差别无憍慢智故。起安慰心。有言憍慢无差别无憍慢智者。所谓憍慢体即无憍慢体。何以故。无憍慢体不异憍慢体。憍慢体不异无憍慢体。即憍慢体无憍慢故。依彼憍慢体无憍慢智一切法无憍慢故。二谓菩萨生如是心。我已得住自赞无差别无自赞智故。生安隐心。为令他住自赞无差别无自赞智故。起安慰心。有言自赞无差别无自赞智者。所谓自赞体即无自赞体。何以故。无自赞体不异自赞体。自赞体不异无自赞体。即自赞体无自赞故。依彼自赞体无自赞智一切法无自赞故。三谓菩萨生如是心。我已得住不了义无差别了义智故。生安隐心。为令他住不了义无差别了义智故。起安慰心。有言不了义无差别了义智者。所谓不了义体即了义体。何以故。了义体不异不了义体。不了义体不异了义体。即不了义体是了义故。依彼不了义体了义智一切法了义故。四谓菩萨生如是心。我已得住人法无差别无人法智故。生安隐心。为令他住人法无差别无人法智故。起安慰心。有言人法无差别无人法智者。所谓人法体即无人法体。何以故。无人法体不异人法体。人法体不异无人法体。即人法体无人法故。依彼人法体无人法智一切法无人法故。五谓菩萨生如是心。我已得住邪见无差别正见智故。生安隐心。为令他住邪见无差别正见智故。起安慰心。有言邪见无差别正见智者。所谓邪见体即正见体。何以故。以正见体不异邪见体。邪见体不异正见体即邪见体是正见故。依彼邪见体正见智一切法正见故。文殊师利。是名五法诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无平等无差别平等智故。生安隐心。为令他住无平等无差别平等智故。起安慰心。有言无平等无差别平等智者。所谓无平等体即平等体。何以故。以平等体不异无平等体。无平等体不异平等体。即无平等体是平等故。依彼无平等体平等智一切法平等故。二谓菩萨生如是心。我已得住边无差别无边智故。生安隐心。为令他住边无差别无边智故。起安慰心。有言边无差别无边智者。所谓边体即无边体。何以故。以无边体不异边体。边体不异无边体故。以即边体是无边故。依彼边体无边智一切法无边故。三谓菩萨生如是心。我已得住知可知无差别智智故。生安隐心。为令他住知可知无差别智智故。起安慰心。有言知可知无差别智智者。所谓知可知体即是智体。何以故。智体不异知可知体。知可知体不异智体。即知可知体是智体故。依彼知可知体智智一切法智故。四谓菩萨生如是心。我已得住取无差别无取智故。生安隐心。为令他住取无差别无取智故。起安慰心。有言取无差别无取智者。所谓取体即无取体。何以故。以无取体不异取体。取体不异无取体故。以即取体是无取故。依彼取体无取智一切法无取故。五谓菩萨生如是心。我已得住修行无差别无修行智故。生安隐心。为令他住修行无差别无修行智故。起安慰心。有言修行无差别无修行智者。所谓修行体即无修行体。何以故。无修行体不异修行体。修行体不异无修行体。即修行体无修行故。依彼修行体无修行智一切法无修行故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住非中道无差别中道智故。生安隐心。为令他住非中道无差别中道智故。起安慰心。有言非中道无差别中道智者。所谓非中道体即中道体。何以故。以中道体不异非中道体。非中道体不异中道体。即非中道体是中道故。依彼非中道体中道智一切法中道故。二谓菩萨生如是心。我已得住非虚空无差别虚空智故。生安隐心。为令他住非虚空无差别虚空智故。起安慰心。有言非虚空无差别虚空智者。所谓非虚空体即虚空体。何以故。以虚空体不异非虚空体。非虚空体不异虚空体。即非虚空体是虚空故。依彼非虚空体虚空智一切法虚空故。三谓菩萨生如是心。我已得住非石女子平等无差别石女子平等智故。生安隐心。为令他住非石女子平等无差别石女子平等智故。起安慰心。有言非石女子平等无差别石女子平等智者。所谓非石女子平等体即石女子平等体。何以故。石女子平等体不异非石女子平等体。非石女子平等体不异石女子平等体。即非石女子平等体石女子平等故。依彼非石女子平等体石女子平等智一切法石女子平等故。四谓菩萨生如是心。我已得住非如阳炎无差别如阳炎智故。生安隐心。为令他住非如阳炎无差别如阳炎智故。起安慰心。有言非如阳炎无差别如阳炎智者。所谓非如阳炎体即如阳炎体。何以故。如阳炎体即非如阳炎体。非如阳炎体即如阳炎体。以非如阳炎体即如阳炎故。依彼非如阳炎体如阳炎智一切法如阳炎故。五谓菩萨生如是心。我已得住邪见无差别无邪见智故。生安隐心。为令他住邪见无差别无邪见智故。起安隐心。有言邪见无差别无邪见智者。所谓邪见体即无邪见体。何以故。无邪见体不异邪见体。邪见体不异无邪见体。即邪见体无邪见故。依彼邪见体无邪见智一切法无邪见故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无明无差别明智故。生体即无痴体。何以故。以无痴体不异痴体。痴体不异无痴体故。以即痴体是无痴故。依彼痴体无痴智一切法无痴故。五谓菩萨生如是心。我已得住依托无差别无依托智故。生安隐心。为令他住依托无差别无依托智故。起安慰心。有言依托无差别无依托智者。所谓依托体即无依托体。何以故。无依托体不异依托体。依托体不异无依托体。即依托体无依托故。依彼依托体无依托智一切法无依托故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住布施行摄受事智故。生安隐心。为令他住布施行摄受事智故。起安慰心。有言布施行摄受事智者。所谓布施及以回向故。二谓菩萨生如是心。我已得住爱语行摄受事智故。生安隐心。为令他住爱语行摄受事智故。起安慰心。有言爱语行摄受事智者。所谓直心及以修行故。三谓菩萨生如是心。我已得住利益行摄受事智故。生安隐心。为令他住利益行摄受事智故。起安慰心。有言利益行摄受事智者。所谓大慈大悲故。四谓菩萨生如是心。我已得住同事行摄受事智故。生安隐心。为令他住同事行摄受事智故。起安慰心。有言同事行摄受事智者。所谓方便及以智慧故。五谓菩萨生如是心。我已得住发心智故。生安隐心。为令他住发心智故。起安慰心。有言发心智者。所谓直心及以修行故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住离贪心故。生安隐心。为令他住离贪心故。起安慰心。有言离贪心者。谓不执着一切法故。二谓菩萨生如是心。我已得住离嗔心故。生安隐心。为令他住离嗔心故。起安慰心。有言离嗔心者。谓不生他一切众生嫌恨心故。三谓菩萨生如是心。我已得住身业不作诸恶行故。生安隐心。为令他住身业不作诸恶行故。起安慰心。有言身业不作诸恶行者。谓离三种身恶行故。四谓菩萨生如是心。我已得住口业不作诸恶行故。生安隐心。为令他住口业不作诸恶行故。起安慰心。有言口业不作诸恶行者。谓离四种口业过故。五谓菩萨生如是心。我已得住意业不作诸恶行故。生安隐心。为令他住意业不作诸恶行故。起安慰心。有言意业不作诸恶行者。离贪嗔痴诸恶行故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住佛正念故。生安隐心。为令他住佛正念故。起安慰心。有言佛正念者。所谓见佛清净念故。二谓菩萨生如是心。我已得住法正念故。生安隐心。为令他住法正念故。起安慰心。有言法正念者。所谓能见清净法故。三谓菩萨生如是心。我已得住僧正念故。生安隐心。为令他住僧正念故。起安慰心。有言僧正念者。所谓得入菩萨位故。四谓菩萨生如是心。我已得住舍正念故。生安隐心。为令他住舍正念故。起安慰心。有言舍正念者。所谓舍彼一切取故。五谓菩萨生如是心。我已得住戒正念故。生安隐心。为令他住戒正念故。起安慰心。有言戒正念者。所谓得入一切法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无常观故。生安隐心。为令他住无常观故。起安慰心。有言无常观者。所谓过彼欲贪色贪无色贪故。二谓菩萨生如是心。我已得住无我观故。生安隐心。为令他住无我观故。起安慰心。有言无我观者。所谓不着一切观故。三谓菩萨生如是心。我已得住实谛法故。生安隐心。为令他住实谛法故。起安慰心。有言实谛法者。所谓不诳诸天人故。四谓菩萨生如是心。我已得住实法故。生安隐心。为令他住实法故。起安慰心。有言实法者。不诳诸天及自身故。五谓菩萨生如是心。我已得住诸法行故。生安隐心。为令他住诸法行故。起安慰心。有言诸法行者。谓依一切诸法行故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住坚固戒故。生安隐心。为令他住坚固戒故。起安慰心。有言坚固戒者。所谓乃至不犯小戒不作小罪故。二谓菩萨生如是心。我已得住不缺戒故。生安隐心。为令他住不缺戒故。起安慰心。有言不缺戒者。所谓不求诸余乘故。三谓菩萨生如是心。我已得住不点戒故。生安隐心。为令他住不点戒故。起安慰心。有言不点戒者。谓离一切诸恶行故。四谓菩萨生如是心。我已得住不浊戒故。生安隐心。为令他住不浊戒故。起安慰心。有言不浊戒者。谓摄一切诸菩萨故。五谓菩萨生如是心。我已得住善护戒故。生安隐心。为令他住善护戒故。起安慰心。有言善护戒者谓于一切诸菩萨所生尊心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住善密戒故。生安隐心。为令他住善密戒故。起安慰心。有言善密戒者。所谓善护一切根故。二谓菩萨生如是心。我已得住名称戒故。生安隐心。为令他住名称戒故。起安慰心。有言名称戒者。谓入诸法无差别法界不二智无障碍故。三谓菩萨生如是心。我已得住知足戒故。生安隐心。为令他住知足戒故。起安慰心。有言知足戒者。离诸贪故。四谓菩萨生如是心。我已得住差别戒故。生安隐心。为令他住差别戒故。起安慰心。有言差别戒者。谓身寂静故。五谓菩萨生如是心。我已得住阿兰若处戒故。生安隐心。为令他住阿兰若处戒故。起安慰心。有言阿兰若处戒者。谓入诸法无中无边故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

信力入印法门经卷第一信力入印法门经卷第二

        元魏天竺三藏昙摩流支译

复次文殊师利。菩萨摩诃萨。有五种法则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住大慈心故。生安隐心。为令他住大慈心故。起安慰心。有言大慈心者。所谓拔济一切众生诸苦恼故。所谓身心修集一切诸功德故。二谓菩萨生如是心。我已得住大悲心故。生安隐心。为令他住大悲心故。起安慰心。有言大悲心者。所谓教化诸众生故。无有诸苦而不取故。无有诸乐而不舍故。三谓菩萨生如是心。我已得住大喜心故。生安隐心。为令他住大喜心故。起安慰心。有言大喜心者。所谓得闻诸佛大事生欢喜故。四谓菩萨生如是心。我已得住大舍心故。生安隐心。为令他住大舍心故。起安慰心。有言大舍心者。所谓菩萨离爱心故。五谓菩萨生如是心。我已得住论义方便故。生安隐心。为令他住论义方便故。起安慰心。有言论义方便者。谓入诸法无言语故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住忍辱戒故。生安隐心。为令他住忍辱戒故。起安慰心。有言忍辱戒者。谓于一切众生不生嗔恨心故。二谓菩萨生如是心。我已得住精进戒故。生安隐心。为令他住精进戒故。起安慰心。有言精进戒者。所谓菩萨令诸众生住不退法故。三谓菩萨生如是心。我已得住禅定戒故。生安隐心。为令他住禅定戒故。起安慰心。有言禅定戒者。所谓菩萨令诸众生住禅支故。四谓菩萨生如是心。我已得住般若戒故。生安隐心。为令他住般若戒故。起安慰心。有言般若戒者。所谓能令一切众生住诸善根故。五谓菩萨生如是心。我已得住不粗犷戒故。生安隐心。为令他住不粗犷戒故。起安慰心。有言不粗犷戒者。谓于一切佛法柔软心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住不悔戒故生安隐心。为令他住不悔戒故。起安慰心。有言不悔戒者。所谓善作所作业故。二谓菩萨生如是心。我已得住不憍慢戒故。生安隐心。为令他住不憍慢戒故。起安慰心。有言不憍慢戒者。所谓教化一切众生故。所谓佐助一切众生所作业故。三谓菩萨生如是心。我已得住善戒故。生安隐心。为令他住善戒故。起安慰心。有言善戒者。所谓教化一切众生。能忍众生骂辱嗔故。四谓菩萨生如是心。我已得住摄受法戒故。生安隐心。为令他住摄受法戒故。起安慰心。有言摄受法戒者。谓信诸法空解脱故。五谓菩萨生如是心。我已得住佛三昧戒故。生安隐心。为令他住佛三昧戒故。起安慰心。有言佛三昧戒者。谓于一切众生得平等心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住苦谛智故。生安隐心。为令他住苦谛智故。起安慰心。有言苦谛智者。所谓诸阴不生智故。二谓菩萨生如是心。我已得住集谛智故。生安隐心。为令他住集谛智故。起安慰心。有言集谛智者。所谓断除诸爱智故。三谓菩萨。生如是心。我已得住灭谛智故。生安隐心。为令他住灭谛智故。起安慰心。有言灭谛智者。谓不生诸有无明使智故。四谓菩萨生如是心。我已得住道谛智故。生安隐心。为令他住道谛智故。起安慰心。有言道谛智者。谓得诸法平等不颠倒智故。五谓菩萨生如是心。我已得住观察自身过故。生安隐心。为令他住观察自身过故。起安慰心。有言观察自身过者。谓观察自戒自心寂静故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住能护他心故。生安隐心。为令他住能护他心故。起安慰心。有言能护他心者。谓见他过不生嗔恨故。二谓菩萨生如是心。我已得住善软心故。生安隐心。为令他住善软心故。起安慰心。有言善软心者。谓教化众生不疲倦故。三谓菩萨生如是心。我已得住不嗔恨心故。生安隐心。为令他住不嗔恨心故。起安慰心。有言不嗔恨心者。谓于一切众生不生恶心故。四谓菩萨生如是心。我已得住观察自身故。生安隐心。为令他住观察自身故。起安慰心。有言观察自身者。谓观无我故。五谓菩萨生如是心。我已得住乃至无有微少烦恼故。生安隐心。为令他住乃至无有微少烦恼故。起安慰心。有言乃至无有微少烦恼者。所谓身业善寂静故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无生法忍故。生安隐心。为令他住无生法忍故。起安慰心。有言无生法忍者。谓证寂灭故。二谓菩萨生如是心。我已得住无灭法忍故。生安隐心。为令他住无灭法忍故。起安慰心。有言无灭法忍者。谓证无生法忍故。三谓菩萨生如是心。我已得住身念智故。生安隐心。为令他住身念智故。起安慰心。有言身念智者。谓离身心故。四谓菩萨生如是心。我已得住受念智故。生安隐心。为令他住受念智故。起安慰心。有言受念智者。谓息一切受故。五谓菩萨生如是心。我已得住心念智故。生安隐心。为令他住心念智故。起安慰心。有言心念智者。所谓观心犹如幻故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住法念智故。生安隐心。为令他住法念智故。起安慰心。有言法念智者。谓如实知一切法故。二谓菩萨生如是心。我已得住信根故。生安隐心。为令他住信根故。起安慰心。有言信根者。谓于一切法中不依他故。三谓菩萨生如是心。我已得住精进根故。生安隐心。为令他住精进根故。起安慰心。有言精进根者。谓如实知一切法故。四谓菩萨生如是心。我已得住念根故。生安隐心。为令他住念根故。起安慰心。有言念根者。谓善作所作故。五谓菩萨生如是心。我已得住定根故。生安隐心。为令他住定根故。起安慰心。有言定根者。谓得心解脱故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住慧根故。生安隐心。为令他住慧根故。起安慰心。有言慧根者。所谓现知一切法故。二谓菩萨生如是心。我已得住信力故。生安隐心。为令他住信力故。起安慰心。有言信力者。谓过一切诸魔业故。三谓菩萨生如是心。我已得住智力故。生安隐心。为令他住智力故。起安慰心。有言智力者。所谓远离无智故。四谓菩萨生如是心。我已得住精进力故。生安隐心。为令他住精进力故。起安慰心。有言精进力者。所谓成就不退法地。五谓菩萨。生如是心。我已得住念力故。生安隐心。为令他住念力故。起安慰心。有言念力者。所谓住持一切佛法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住三昧力故。生安隐心。为令他住三昧力故。起安慰心。有言三昧力者。所谓远离一切觉观故。二谓菩萨生如是心。我已得住般若力故。生安隐心。为令他住般若力故。起安慰心。有言般若力者。谓他不能降伏智故。三谓菩萨生如是心。我已得住念觉分故。生安隐心。为令他住念觉分故。起安慰心。有言念觉分者。谓如实知念觉分诸法故。四谓菩萨。生如是心。我已得住择法觉分故。生安隐心。为令他住择法觉分故。起安慰心。有言择法觉分者。所谓照知一切法故。五谓菩萨生如是心。我已得住精进觉分故。生安隐心。为令他住精进觉分故。起安慰心。有言精进觉分者。谓如实知一切佛法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住喜觉分故。生安隐心。为令他住喜觉分故。起安慰心。有言喜觉分者。所谓三昧三摩跋提故。二谓菩萨生如是心。我已得住猗觉分故。生安隐心。为令他住猗觉分故。起安慰心。有言猗觉分者。谓于一切佛法善作所作故。三谓菩萨生如是心。我已得住定觉分故。生安隐心。为令他住定觉分故。起安慰心。有言定觉分者。谓平等觉一切法故。四谓菩萨生如是心。我已得住舍觉分故。生安隐心。为令他住舍觉分故。起安慰心。有言舍觉分者。谓于诸圣法中不生乐着心故。于非圣法中不生厌背心故。五谓菩萨生如是心。我已得住正见故。生安隐心。为令他住正见故。起安慰心。有言正见者。谓入定位故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住正觉分故。生安隐心。为令他住正觉分故。起安慰心。有言正觉分者。所谓远离分别异分别广分别故。二谓菩萨生如是心。我已得住正语故。生安隐心。为令他住正语故。起安慰心。有言正语者。谓于一切名字声响不生诸相故。三谓菩萨生如是心。我已得住正业故。生安隐心。为令他住正业故。起安慰心。有言正业者。所谓入一切法业果报故。四谓菩萨生如是心。我已得住正命故。生安隐心。为令他住正命故。起安慰心。有言正命者。所谓离诸求故。五谓菩萨生如是心。我已得住正修行故。生安隐心。为令他住正修行故。起安慰心。有言正修行者。谓舍此岸到彼岸故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住檀波罗蜜故。生安隐心。为令他住檀波罗蜜故。起安慰心。有言檀波罗蜜者。谓善教化悭嫉众生故。二谓菩萨生如是心。我已得住尸波罗蜜故。生安隐心。为令他住尸波罗蜜故。起安慰心。有言尸波罗蜜者。谓善教化毁禁众生故。三谓菩萨生如是心。我已得住羼提波罗蜜故。生安隐心。为令他住羼提波罗蜜故。起安慰心。有言羼提波罗蜜者。谓善教化嗔恨众生故。四谓菩萨生如是心。我已得住毗梨耶波罗蜜故。生安隐心。为令他住毗梨耶波罗蜜故。起安慰心。有言毗梨耶波罗蜜者。谓善教化懈怠众生故。五谓菩萨生如是心。我已得住禅波罗蜜故。生安隐心。为令他住禅波罗蜜故。起安慰心。有言禅波罗蜜者。谓善教化散乱众生故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住般若波罗蜜故。生安隐心。为令他住般若波罗蜜故。起安慰心。有言般若波罗蜜者。谓善教化愚痴众生故。二谓菩萨生如是心。我已得住摄受正法戒故。生安隐心。为令他住摄受正法戒故。起安慰心。有言摄受正法戒者。所谓摄受诸菩萨故。三谓菩萨生如是心。我已得住诸功德故。生安隐心。为令他住诸功德故。起安慰心。有言诸功德者。所谓供养诸菩萨摩诃萨故。为称十方诸菩萨名而赞叹故。四谓菩萨生如是心。我已得住智功德故。生安隐心。为令他住智功德故。起安慰心。有言智功德者。所谓与诸菩萨增上智故。与衣服饮食卧具汤药故。五谓菩萨生如是心。我已得住寂静功德故。生安隐心。为令他住寂静功德故。起安慰心。有言寂静功德者。谓入诸法平等不生高下心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住正见功德故。生安隐心。为令他住正见功德故。起安慰心。有言正见功德者。所谓入一切法无初中后际故。二谓菩萨生如是心。我已得住布施故。生安隐心。为令他住布施故。起安慰心。有言布施者。所谓能舍一切法故。三谓菩萨生如是心。我已得住持戒故。生安隐心。为令他住持戒故。起安慰心。有言持戒者。所谓不起一切恶故。四谓菩萨生如是心。我已得住忍辱故。生安隐心。为令他住忍辱故。起安慰心。有言忍辱者。所谓信诸业故。五谓菩萨生如是心。我已得住精进故。生安隐心。为令他住精进故。起安慰心。有言精进者。谓入一切功德不疲惓故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住禅定故。生安隐心。为令他住禅定故。起安慰心。有言禅定者。所谓不住一切念故。二谓菩萨生如是心。我已得住般若故。生安隐心。为令他住般若故。起安慰心。有言般若者。所谓现见诸法故。三谓菩萨生如是心。我已得住摄取一切如来法故。生安隐心。为令他住摄取一切如来法故。起安慰心。有言摄取一切如来法者。谓直心摄取菩提心故。四谓菩萨生如是心。我已得住如说法故。生安隐心。为令他住如说法故。起安慰心。有言如说法者。谓随如来言语智故。五谓菩萨生如是心。我已得住正念故。生安隐心。为令他住正念故。起安慰心。有言正念者。谓入诸法不忘念故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住意心故。生安隐心。为令他住意心故。起安慰心。有言意心者。谓如实知诸法次第意故。二谓菩萨生如是心。我已得住坚固心故。生安隐心。为令他住坚固心故。起安慰心。有言坚固心者。所谓成就威仪行故。三谓菩萨生如是心。我已得住去心故。生安隐心。为令他住去心故。起安慰心。有言去心者。谓入义故。四谓菩萨生如是心。我已得住正解脱故。生安隐心。为令他住正解脱故。起安慰心。有言正解脱者。谓证妙法故。五谓菩萨生如是心。我已得住离烦恼心故。生安隐心。为令他住离烦恼心故。起安慰心。有言离烦恼心者。谓悔已起诸烦恼过故更不造作新烦恼故生善法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住如行故。生安隐心。为令他住如行故。起安慰心。有言如行者。谓住成就菩萨行故。二谓菩萨生如是心。我已得住作所应作故。生安隐心。为令他住作所应作故。起安慰心。有言作所应作者。谓信空解脱故信诸业故。三谓菩萨生如是心。我已得住远离恶心所求处故。生安隐心。为令他住远离恶心所求处故。起安慰心。有言远离恶心所求处者。谓不作诸恶求于供养恭敬等故。四谓菩萨生如是心。我已得住不自赞毁他故。生安隐心。为令他住不自赞毁他故。起安慰心。有言不自赞毁他者。谓于自身不生实功德相。又于他身不毁不隐他实功德故。五谓菩萨生如是心。我已得住实法故。生安隐心。为令他住实法故。起安慰心。有言实法者。谓于诸法不起相故不执着相故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住断除无明习气烦恼故。生安隐心。为令他住断除无明习气烦恼故。起安慰心。有言断除无明习气烦恼者。谓本愚痴凡夫行不厌故不念声闻辟支佛地故。二谓菩萨生如是心。我已得住不随爱故。生安隐心。为令他住不随爱故。起安慰心。有言不随爱者。谓未生诸恶不善法令不生故。已生诸善法令不散灭故。三谓菩萨生如是心。我已得住显现智故。生安隐心。为令他住显现智故。起安慰心。有言显现智者。谓证圣谛故。四谓菩萨生如是心。我已得住直心故。生安隐心。为令他住直心故。起安慰心。有言直心者。谓不分别圣道故。五谓菩萨生如是心。我已得住不生异身相故。生安隐心。为令他人不生异身相故。起安慰心。有言不生异身相者。谓离增恶法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住先意语故。生安隐心。为令他住先意语故。起安慰心。有言先意语者。谓先发语言善来故及慰喻言来无疲劳诸难疾等故。二谓菩萨生如是心。我已得住无障碍智故。生安隐心。为令他住无障碍智故。起安慰心。有言无障碍智者。所谓十方一切世界世间之业出世间业诸论伎术自然知故。三谓菩萨生如是心。我已得住于诸业中无疑智故。生安隐心。为令他住于诸业中无疑智故。起安慰心。有言于诸业中无疑智者。所谓远离常见断见故。四谓菩萨生如是心。我已得住无言语说言语说故。生安隐心。为令他住无言语说言语说故。起安慰心。有言无言语说言语说者。谓离心意意识念故。五谓菩萨生如是心。我已得住法界智故。生安隐心。为令他住法界智故。起安慰心。有言法界智者。谓不离一切诸法法界不二智故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住心远离故。生安隐心。为令他住心远离故。起安慰心。有言心远离者。所谓无相于诸观中不着相故。二谓菩萨生如是心。我已得住无障碍智故。生安隐心。为令他住无障碍智故。起安慰心。有言无障碍智者。谓边无边清净智故。三谓菩萨生如是心。我已得住说言语意故。生安隐心。为令他住说言语意故。起安慰心。有言说言语意者。谓依胜愿力回向诸善根故。四谓菩萨生如是心。我已得住柔和法故。生安隐心。为令他住柔和法故。起安慰心。有言柔和法者。谓令一切众生信善事故。五谓菩萨生如是心。我已得住离诸业故。生安隐心。为令他住离诸业故。起安慰心。有言离诸业者。谓知诸见故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住归依佛故。生安隐心。为令他住归依佛故。起安慰心。有言归依佛者。谓不毁犯如来戒故。二谓菩萨生如是心。我已得住归依法故。生安隐心。为令他住归依法故。起安慰心。有言归依法者。谓不谤法故。三谓菩萨生如是心。我已得住归依僧故。生安隐心。为令他住归依僧故。起安慰心。有言归依僧者。谓观察戒故。四谓菩萨生如是心。我已得住无憍慢故。生安隐心。为令他住无憍慢故。起安慰心。有言无憍慢者。谓于一切众生生尊重心故。五谓菩萨生如是心。我已得住不恨心故。生安隐心。为令他住不恨心故。起安慰心。有言不恨心者。谓离心热火故。文殊师利。是名五法。诸菩萨摩诃萨得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住不谀谄故。生安隐心。为令他住不谀谄故。起安慰心。有言不谀谄者。谓离饮食诸供养等。为他作恩故。二谓菩萨生如是心。我已得住离妄语故。生安隐心。为令他住离妄语故。起安慰心。有言离妄语者。谓教化众生不取不舍故。三谓菩萨生如是心。我已得住不为利养语故。生安隐心。为令他住不为利养语故。起安慰心。有言不为利养语者。谓圣种成就满足头陀诸功德故。四谓菩萨生如是心。我已得住正命故。生安隐心。为令他住正命故。起安慰心。有言正命者。谓摄受法故无有少苦而不受故无有少乐而不舍故。五谓菩萨生如是心。我已得住无有同侣独行处故。生安隐心。为令他住无有同侣独行处故。起安慰心。有言无有同侣独行处者。谓离语故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住法乐故。生安隐心。为令他住法乐故。起安慰心。有言法乐者。所谓怖畏三界苦故所谓不失菩提心故。二谓菩萨生如是心。我已得住离九种事故。生安隐心。为令他住离九种事故。起安慰心

有言离九种事者。谓离九种众生住处故。三谓菩萨生如是心。我已得住寂静心故。生安隐心。为令他住寂静心故。起安慰心。有言寂静心者。谓心不悔故。四谓菩萨生如是心。我已得住奢摩他修行功德故。生安隐心。为令他住奢摩他修行功德故。起安慰心。有言奢摩他修行功德者。谓心柔软故。五谓菩萨生如是心。我已得住心不放逸故。生安隐心。为令他住心不放逸故。起安慰心。有言心不放逸者。谓不放逸戒故行戒见毁过一切诸见故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住不诳天人故。生安隐心。为令他住不诳天人故。起安慰心。有言不诳天人者。所谓不舍菩提心故。二谓菩萨生如是心。我已得住修行故。生安隐心。为令他住修行故。起安慰心。有言修行者。谓与诸众生安隐乐故安隐事上首故。三谓菩萨生如是心。我已得住不鄙恶行故。生安隐心。为令他住不鄙恶行故。起安慰心。有言不鄙恶行者。谓善调伏心故。四谓菩萨生如是心。我已得住一切众生作弟子故。生安隐心。为令他住一切众生作弟子故。起安慰心。有言一切众生作弟子者。谓与一切众生作弟子故一切众生有所作业助彼作故。五谓菩萨生如是心。我已得住随顺伏从一切众生故。生安隐心。为令他住随顺伏从一切众生故。起安慰心。有言随顺伏从一切众生者。谓于福田无憍慢心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住求法成就故。生安隐心。为令他住求法成就故。起安慰心。有言求法成就者。所谓教化一切众生不疲惓故及得清净佛国土故能增上故常求戒闻法故不取布施不舍悭嫉不取持戒不舍毁禁不取忍辱不舍嗔恨不取精进不舍懈怠不取禅定不舍觉观不取般若不舍愚痴不取善根不舍不善根故。二谓菩萨生如是心。我已得住尊重心故。生安隐心。为令他住尊重心故。起安慰心。有言尊重心者。所谓于法如实修行故。三谓菩萨生如是心。我已得住于法师所尊重心故。生安隐心。为令他住于法师所尊重心故。起安慰心。有言于法师所尊重心者。谓于法师生佛想故。四谓菩萨生如是心。我已得住不恶口心故。生安隐心。为令他住不恶口心故。起安慰心。有言不恶口心者。谓作言语摄取众生故。五谓菩萨生如是心。我已得住不嗔心故。生安隐心。为令他住不嗔心故。起安慰心。有言不嗔心者。谓入诸业故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法。故能清净初欢喜地。得大无畏安隐之处

信力入印法门经卷第二信力入印法门经卷第三

        元魏天竺三藏昙摩流支译

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住布施故。生安隐心。为令他住布施故。起安慰心。有言布施者。谓如所闻法如是说故。二谓菩萨生如是心。我已得住爱语故。生安隐心。为令他住爱语故。起安慰心。有言爱语者。谓心不为饮食说法故。三谓菩萨生如是心。我已得住利益故。生安隐心。为令他住利益故。起安慰心。有言利益者。所谓教他一切众生为令众生受持读诵不疲惓故。四谓菩萨生如是心。我已得住同事故。生安隐心。为令他住同事故。起安慰心。有言同事者。谓布施令诸众生住大乘故。五谓菩萨生如是心。我已得住菩提心故。生安隐心。为令他住菩提心故。起安慰心。有言菩提心者。谓令诸法恒常住故为不灭故生于欲心发精进心摄取之心正修行心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住义无碍故。生安隐心。为令他住义无碍故。起安慰心。有言义无碍者。谓入如实法故。二谓菩萨生如是心。我已得住法无碍故。生安隐心。为令他住法无碍故。起安慰心。有言法无碍者。谓入一切佛法智故。三谓菩萨生如是心。我已得住辞无碍故。生安隐心。为令他住辞无碍故。起安慰心。有言辞无碍者。谓入一切诸字名声智故。四谓菩萨生如是心。我已得住乐说无碍故。生安隐心。为令他住乐说无碍故。起安慰心。有言乐说无碍者。谓入一切法文句差别方便智故。五谓菩萨生如是心。我已得住无障碍智故。生安隐心。为令他住无障碍智故。起安慰心。有言无障碍智者。所谓说一切佛法不休息智故。取一句法于无边劫住持演说而不起心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住教化一切诸众生故。生安隐心。为令他住教化一切诸众生故。起安慰心。有言教化一切诸众生者。谓能忍受一切众生烦恼染故。烦恼染者。所谓身心俱逼恼故。二谓菩萨生如是心。我已得住无诸失故。生安隐心。为令他住无诸失故。起安慰心。有言无诸失者。所谓不失诸善根故。三谓菩萨生如是心。我已得住心不相触故。生安隐心。为令他住心不相触故起安慰心。有言心不相触者。所谓不失诸善根故。四谓菩萨生如是心。我已得住精进故。生安隐心。为令他住精进故。起安慰心。有言精进者。所谓满足诸善法故远离一切不善法故。五谓菩萨生如是心。我已得住慈心观察诸众生故。生安隐心。为令他住慈心观察诸众生故。起安慰心。有言慈心观察诸众生者。谓于一切诸众生中平等心故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住不害心故。生安隐心。为令他住不害心故。起安慰心。有言不害心者。谓护一切诸众生故。二谓菩萨生如是心。我已得住远离心故。生安隐心。为令他住远离心故。起安慰心。有言远离心者。谓入三世一切诸法悉平等故。三谓菩萨生如是心。我已得住法念慈心故。生安隐心。为令他住法念慈心故。起安慰心。有言法念慈心者。所谓不见一切法故而不执着不见法故。四谓菩萨生如是心。我已得住初功德故。生安隐心。为令他住初功德故。起安慰心。有言初功德者。所谓不舍菩提心故。随顺一切菩萨行故。有随顺一切菩萨行者。谓大慈心平等摄受一切众生故。降伏一切嫉妒心故远离一切诸破戒故。远离一切嗔恨心故。远离一切懈怠心故。不行一切散乱心故。远离一切愚痴心故。有四摄法。摄取教化诸众生故。于诸众生心皆平等如大地故。不念小乘狭劣心故。随顺一切众生所作诸善行故。大悲布施持戒忍辱精进禅定般若满足故。摄受诸佛胜妙法故。学诸善业般若根本故。恒常修行功德智慧二庄严故。五谓菩萨生如是心。我已得住希有相故。生安隐心。为令他住希有相故。起安慰心。有言希有相者。谓一切法不二相故。于一切行生自行相故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安慰之处。何等为五。一谓菩萨生如是心。我已得住忍辱柔和故。生安隐心。为令他住忍辱柔和故。起安慰心。有言忍辱柔和者。所谓为他恶口骂辱诸不善语毁谤说时不生嗔恨心故。二谓菩萨生如是心。我已得住颜色怡悦故。生安隐心。为令他住颜色怡悦故。起安慰心。有言颜色怡悦者。谓不说他诸过失故。三谓菩萨生如是心。我已得住一切法无事故。生安隐心。为令他住一切法无事故。起安慰心。有言一切法无事者。所谓唯是谓名字故。何以故。以无事体不异事体。事体不异无事体故。以即事体是无事故。依彼事体无事智一切法无事故。四谓菩萨生如是心。我已得住法住持故。生安隐心。为令他住法住持故。起安慰心。有言法住持者。谓一切法不动故。五谓菩萨生如是心。我已得住法故。生安隐心。为令他住法故。起安慰心。有言法者。谓无差别不依住故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住入非智慧断烦恼非不智慧断烦恼故。生安隐心。为令他住入非智慧断烦恼非不智慧断烦恼故。起安慰心。有言入非智慧断烦恼非不智慧断烦恼者。所谓智慧体即烦恼体。何以故。以智慧体不异烦恼体烦恼体不异智慧体。即智慧体是烦恼体。即烦恼体是智慧体。以是义故。非即智慧能断烦恼。譬如指端不能自触。此亦如是。非即智慧能断烦恼故。二谓菩萨生如是心。我已得住入如来非常非不常故。生安隐心。为令他住入如来非常非不常故。起安慰心。有言入如来非常非不常者。谓不取体相故。三谓菩萨生如是心。我已得住入不思议如来智故。生安隐心。为令他住入不思议如来智故。起安慰心。有言入不思议如来智者。谓随可化诸众生心如是说法不过彼故。四谓菩萨生如是心。我已得住入无色相故。生安隐心。为令他住入无色相故。起安慰心。何以故。无色相体不异色相体。色相体不异无色相体。即色相体无色相故。依彼色相体无色相智一切法无色相故。五谓菩萨生如是心。我已得住方便故。生安隐心。为令他住方便故。起安慰心。有言方便者。所谓摄取一切法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无尽功德故。生安隐心。为令他住无尽功德故。起安慰心。有言无尽功德者。所谓回诸善根向菩提故。二谓菩萨生如是心。我已得住智功德故。生安隐心。为令他住智功德故。起安慰心。有言智功德者。谓信一切诸法空故。三谓菩萨生如是心。我已得住善业根本般若法故。生安隐心。为令他住善业根本般若法故。起安慰心。有言善业根本般若法者。所谓自身住白法故。有善业根本般若法者。谓令他住般若法故。四谓菩萨生如是心。我已得住三昧故。生安隐心。为令他住三昧故。起安慰心。有言三昧者。谓寂灭定三昧故。五谓菩萨生如是心。我已得住满足心故。生安隐心。为令他住满足心故。起安慰心。有言满足心者。谓入一切诸事作故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住中道智故。生安隐心。为令他住中道智故。起安慰心。有言中道智者。所谓究竟清净智故。何以故。以中道体不异边体。边体不异中道体故。以即边体是中道体故。二谓菩萨生如是心。我已得住一切法无常故。生安隐心。为令他住一切法无常故。起安慰心。有言一切法无常者。所谓诸法有中有边。是故诸法有中有边。何以故。以有为体无异体故。有中有边体不异有为体。有为体不异有中有边体故。三谓菩萨生如是心。我已得住一切法常故。生安隐心。为令他住一切法常故。起安慰心。有言一切法常者。所谓诸法无中无边。是故诸法无中无边。何以故。以无为体无异体故。无中无边体不异无为体。无为体不异无中无边体故。无中无边者所谓常恒净不变故。四谓菩萨生如是心。我已得住胜供养佛故。生安隐心。为令他住胜供养佛故。起安慰心。有言胜供养佛者。所谓供养现在佛故。谓信大乘诸菩萨善供养恭敬咨请闻法饮食卧具等奉施给与如分如力令住大乘故。五谓菩萨生如是心。我已得住一切法无为故。生安隐心。为令他住一切法无为故。起安慰心。有言一切法无为者。谓有为句故。何以故。以无为体不异有为体。有为体不异无为体。即有为体是无为故。依彼有为体无为智一切法无为故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法。故能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住难见一切法故。生安隐心。为令他住难见一切法故。起安慰心。有言难见一切法者。谓一切法因缘体故。二谓菩萨生如是心。我已得住难知一切法故。生安隐心。为令他住难知一切法故。起安慰心。有言难知一切法者。谓观心念无实体故。三谓菩萨生如是心。我已得住难觉一切法故。生安隐心。为令他住难觉一切法故。起安慰心。有言难觉一切法者。谓一切法觉所觉平等故。四谓菩萨生如是心。我已得住不浊一切法故。生安隐心。为令他住不浊一切法故。起安慰心。有言不浊一切法者。谓常清净故。五谓菩萨生如是心。我已得住一切法不尽故。生安隐心。为令他住一切法不尽故。起安慰心。有言一切法不尽者。谓无譬喻体故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安慰之处。何等为五。一谓菩萨生如是心。我已得住一切法不坏故。生安隐心。为令他住一切法不坏故。起安慰心。有言一切法不坏者。谓入三世诸法平等故。以一切法不离法故。不差别法故。二谓菩萨生如是心。我已得住四圣谛无差别故。生安隐心。为令他住四圣谛无差别故。起安慰心。有言四圣谛无差别者。谓四圣谛无差别故。有言四圣谛无差别者。常清净故。三谓菩萨生如是心。我已得住无明缘行无差别故。生安隐心。为令他住无明缘行无差别故。起安慰心。有言无明缘行无差别者。所谓无明即是缘行。何以故。不异无明因有缘行故。若异无明因有缘行者。则应无因而有诸行。以是义故。不异无明因而有诸行果。如是因果义成以本来清净故。四谓菩萨生如是心。我已得住一切法常故。生安隐心。为令他住一切法常故。起安慰心。有言一切法常者。所谓无常体即是常体故。何以故。常体不异无常体。无常体不异常体。即无常体是常体故。五谓菩萨生如是心。我已得住如来不生不灭故。生安隐心。为令他住如来不生不灭故。起安慰心。有言如来不生不灭者。所谓以无对治法故。譬如虚空不生不灭以虚空无边无中际故。而依因观察见下中上。此是针孔虚空。此是瓶孔虚空。此是无量孔虚空。而虚空无下中上。以不生不灭故。而虚空不分别无分别。而虚空自然无分别。如是等事现前见以不共法相应故。文殊师利。如是如来应正遍知。不生不灭无中无边。而依一切众生见下中上。依无中无边心见如是等事。此是声闻乘。此是辟支佛乘。此是佛乘。一切众生能受能用。而如来无分别离分别。而自然无分别。如是等事作故。以不共法相应故。文殊师利。譬如日光依住处观见种种影。而日光明不分别离分别。以不共法相应故。文殊师利。如是如来应正遍知。依众生心观智差别种种见。而如来不分别离分别。而自然无分别。如是等诸事现见。以不共法相应故。而无诸乘及以大乘。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住为一切众生离诸烦恼故。生安隐心。为令他住为一切众生离诸烦恼故。起安慰心。有言为一切众生离诸烦恼者。谓遍身心法门明故。二谓菩萨生如是心。我已得住般若门故。生安隐心。为令他住般若门故。起安慰心。有言般若门者。有四种法得名。何等为四。谓信。不放逸。直心。增上心。是名四种法。诸菩萨等得法明门般若成就。依法明门般若。诸菩萨摩诃萨。离诸恶道故。三谓菩萨生如是心。我已得住智明门般若故。生安隐心。为令他住智明门般若故。起安慰心。有言智明门般若者。有四种法得名。何等为四。谓功德。信空。解脱。令诸众生住菩提心。是名四种法。诸菩萨等。得智明门般若成就。依彼智明门般若。诸菩萨摩诃萨。断诸魔业故。四谓菩萨生如是心。我已得住施心无尽修行般若故。生安隐心。为令他住施心无尽修行般若故。起安慰心。有言施心无尽修行般若者。谓能教化悭嫉众生令成就故。五谓菩萨生如是心。我已得住戒心无尽修行般若故。生安隐心。为令他住戒心无尽修行般若故。起安慰心。有言戒心无尽修行般若者。谓能教化破戒众生令清净故。文殊师利。是名五法。诸菩萨摩诃萨。行此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住寂静故。生安隐心。为令他住寂静故。起安慰心。有言寂静者。谓离身心故。发起一切善根不怯弱故。二谓菩萨生如是心。我已得住有为法故。生安隐心。为令他住有为法故。起安慰心。有言有为法者。谓一切法非空非不空。非颠倒非不颠倒。非增上非不增上。非事非不事。非有为非无为。非相非不相。非依非不依。非二非不二。非减非不减。非取非不取。如是入者。是则名为有为法体故。三谓菩萨生如是心。我已得住无为法故。生安隐心。为令他住无为法故。起安慰心。有言无为法者。谓即此诸法无差别不生心非颠倒不分别离分别。是则名为无为法体故。四谓菩萨生如是心。我已得住正见故。生安隐心。为令他住正见故。起安慰心。有言正见者。谓入二不二相故。何以故。以不二体不异二体。二体不异不二体故。以即二体是不二故。若能如是入二不二。是名正见故。五谓菩萨生如是心。我已得住无嗔心故。生安隐心。为令他住无嗔心故。起安慰心。有言无嗔心者。谓安隐事故。一切众生得入业故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住入波罗蜜道故。生安隐心。为令他住入波罗蜜道故。起安慰心。有言入波罗蜜道者。所谓方便摄取般若故。二谓菩萨生如是心。我已得住生诸佛家故。生安隐心。为令他住生诸佛家故。起安慰心。有言生诸佛家者。谓功德庄严智慧庄严故。三谓菩萨生如是心。我已得住发菩提心故。生安隐心。为令他住发菩提心故。起安慰心。有言发菩提心者。谓住大慈大悲心故。何以故。以得入于一切法故。四谓菩萨生如是心。我已得住般若故。生安隐心。为令他住般若故。起安慰心。有言般若者。所谓有为无为之法无差别故。五谓菩萨生如是心。我已得住方便故。生安隐心。为令他住方便故。起安慰心。有言方便者。所谓摄取一切法故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住有障碍行故。生安隐心。为令他住有障碍行故。起安慰心。有言有障碍行者。谓五波罗蜜故。二谓菩萨生如是心。我已得住无障碍行故。生安隐心。为令他住无障碍行故。起安慰心。有言无障碍行者。谓般若波罗蜜故。三谓菩萨生如是心。我已得住有漏行故。生安隐心。为令他住有漏行故。起安慰心。有言有漏行者。谓见诸法行故。四谓菩萨生如是心。我已得住无漏行故。生安隐心。为令他住无漏行故。起安慰心。有言无漏行者。所谓不见诸法行故。五谓菩萨生如是心。我已得住有量行故。生安隐心。为令他住有量行故。起安慰心。有言有量行者。所谓有诸心相住故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无量行故。生安隐心。为令他住无量行故。起安慰心。有言无量行者。所谓无诸心相行故。二谓菩萨生如是心。我已得住有量智故。生安隐心。为令他住有量智故。起安慰心。有言有量智者。所谓观察阴界入因缘集是处非处观察方便相智故。三谓菩萨生如是心。我已得住无量作智故。生安隐心。为令他住无量作智故。起安慰心。有言无量作智者。谓无作心行处所故。四谓菩萨生如是心。我已得住有边故。生安隐心。为令他住有边故。起安慰心。有言有边者。谓五波罗蜜故。五谓菩萨生如是心。我已得住无边故。生安隐心。为令他住无边故。起安慰心。有言无边者。所谓般若波罗蜜故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住自身能寂静故。生安隐心。为令他住自身能寂静故。起安慰心。有言自身能寂静者。所谓观察无我法故。二谓菩萨生如是心。我已得住身心寂静故。生安隐心。为令他住身心寂静故。起安慰心。有言身心寂静者。所谓教化一切众生无疲惓故。三谓菩萨生如是心。我已得住直心清净故。生安隐心。为令他住直心清净故。起安慰心。有言直心清净者。所谓观察一切众生故。四谓菩萨生如是心。我已得住观察一切诸众生故。生安隐心。为令他住观察一切诸众生故。起安慰心。有言观察一切诸众生者。所谓观察一切众生故。五谓菩萨生如是心。我已得住一切众生平等功德故。生安隐心。为令他住一切众生平等功德故。起安慰心。有言一切众生平等功德者。谓五功德波罗蜜故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住降伏悭嫉心故。生安隐心。为令他住降伏悭嫉心故。起安慰心。有言降伏悭嫉心者。谓能舍一切内外物故。二谓菩萨生如是心。我已得住不谄曲故。生安隐心。为令他住不谄曲故。起安慰心。有言不谄曲者。谓于一切众生得平等心故。三谓菩萨生如是心。我已得住供养佛故。生安隐心。为令他住供养佛故。起安慰心。有言供养佛者。所谓依止供养住持能生诸佛出世法故。复能成就说法法故。为供养彼佛菩萨故。四谓菩萨生如是心。我已得住供养如来智行故。生安隐心。为令他住供养如来智行故。起安慰心。有言供养如来智行者。谓为众生一切令住不退法故。五谓菩萨生如是心。我已得住心口行故。生安隐心。为令他住心口行故。起安慰心。有言心口行者。谓令众生离口心过得清净故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处。复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住不见魔业住佛业故。生安隐心。为令他住不见魔业住佛业故。起安慰心。有言不见魔业住佛业者。谓不见魔业教化众生故。二谓菩萨生如是心。我已得住信于诸佛如来常故。生安隐心。为令他住信于诸佛如来常故。起安慰心。有言信于诸佛如来常者。谓诸佛常以无差别故。三谓菩萨生如是心。我已得住信于诸佛如来恒故。生安隐心。为令他住信于诸佛如来恒故。起安慰心。有言信于诸佛如来恒者。谓信诸佛如来恒作一切佛行不休息故。四谓菩萨生如是心。我已得住信于诸佛如来净故。生安隐心。为令他住信于诸佛如来净故。起安慰心。有言信于诸佛如来净者。所谓不空见闻念故。五谓菩萨生如是心。我已得住信于诸佛如来我故。生安隐心。为令他住信于诸佛如来我故。起安慰心。有言信于诸佛如来我者。谓诸如来身无边故。身无边者。谓说如来无边身故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住安隐事故。生安隐心。为令他住安隐事故。起安慰心。有言安隐事者。所谓为令一切众生护自身心逼恼事故。无有少法能生苦者而不受故。无有少法能生乐者而不舍故。二谓菩萨生如是心。我已得住一切法无相故。生安隐心。为令他住一切法无相故。起安慰心。有言一切法无相者。谓无相体。何以故。谓以不取无相体故。三谓菩萨生如是心。我已得住归依佛故。生安隐心。为令他住归依佛故。起安慰心。有言归依佛者。所谓不作一切恶行故。四谓菩萨生如是心。我已得住归依法故。生安隐心。为令他住归依法故。起安慰心。有言归依法者。谓归依法因缘集故。五谓菩萨生如是心。我已得住归依僧故。生安隐心。为令他住归依僧故。起安慰心。有言归依僧者。所谓远离爱憎心故。所谓菩萨生如是心。我已得住菩提心故。生安隐心。为令他住菩提心故。起安慰心。有言菩提心者。谓起不可思议智故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住身无差别故。生安隐心。为令他住身无差别故。起安慰心。有言身无差别者。谓过一切诸法相故。二谓菩萨生如是心。我已得住信无差别故。生安隐心。为令他住信无差别故。起安慰心。有言信无差别者。谓信诸业及果报故。三谓菩萨生如是心。我已得住三摩跋提智故。生安隐心。为令他住三摩跋提智故。起安慰心。有言三摩跋提智者。所谓观察入体智故。四谓菩萨生如是心。我已得住法无差别故。生安隐心。为令他住法无差别故。起安慰心。有言法无差别者。谓法修行故。五谓菩萨生如是心。我已得住善知识无差别故。生安隐心。为令他住善知识无差别故。起安慰心。有言善知识无差别者。所谓不诳诸善知识故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处何等为五。一谓菩萨生如是心。我已得住随顺法故。生安隐心。为令他住随顺法故。起安慰心。有言随顺法者。谓于诸法如实修行故。二谓菩萨生如是心。我已得住惭愧行故。生安隐心。为令他住惭愧行故。起安慰心。有言惭愧行者。谓身口意业修善行故。三谓菩萨生如是心。我已得住离爱心故。生安隐心。为令他住离爱心故。起安慰心。有言离爱心者。所谓能生未生善法故。四谓菩萨生如是心。我已得住离嗔心故。生安隐心。为令他住离嗔心故。起安慰心。有言离嗔心者。所谓不失已生善法故。五谓菩萨生如是心。我已得住防护自身他身善根故。生安隐心。为令他住防护自身他身善根故。起安慰心。有言防护自身善根者。谓护令入业所作故。有言防护他身善根者。谓护令住大慈大悲故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

复次文殊师利。菩萨摩诃萨。有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无障碍解脱智故。生安隐心。为令他住无障碍解脱智故。起安慰心。有言无障碍解脱智者。谓非二清净故。二谓菩萨生如是心。我已得住信于因缘诸法生故。生安隐心。为令他住信于因缘诸法生故。起安慰心。有言信于因缘诸法生者。谓见诸因缘法体不生故。三谓菩萨生如是心。我已得住诸法无住处故。生安隐心。为令他住诸法无住处故。起安隐心。有言诸法无住处者。谓一切法无十方界差别处故。四谓菩萨生如是心。我已得住诸佛如来如虚空故。生安隐心。为令他住诸佛如来如虚空故。起安慰心。有言诸佛如来如虚空者。谓佛无差别无依止故。五谓菩萨生如是心。我已得住诸佛如来离心意意识故。生安隐心。为令他住。诸佛如来离心意意识故。起安慰心。有言诸佛如来离心意意识者。谓诸佛得至自然智。以得无障碍智故。文殊师利。是名五法。诸菩萨摩诃萨。得此五法故。能清净初欢喜地。得大无畏安隐之处

信力入印法门经卷第三信力入印法门经卷第四

        元魏天竺三藏昙摩流支译

尔时文殊师利法王子。知如来说法竟。而问普贤菩萨摩诃萨言。佛子。云何诸佛如来无障碍智。云何诸佛如来教化众生力。云何诸佛如来自然智普门现前。云何诸佛如来不可思议智清净佛国土。云何诸佛如来无边之身一切遍见。云何诸佛如来不可思议境界。云何诸佛如来无差别无依止智。云何诸佛如来无障碍身。尔时普贤菩萨摩诃萨。语文殊师利法王子言。文殊师利。此法门难见难知。非觉境界无觉境界难可得信。文殊师利。若有人信此法门。当知彼人。已曾供养无量无边百千万亿那由他佛。文殊师利。我为一切生盲众生。说此法门作照明灯

文殊师利法王子言。如是如是。佛子。彼诸众生。已曾修集无量无边功德智慧。是故我为彼众生问。彼诸众生多有无量阿僧祇业。应入地狱饿鬼畜生。为令现身即得消灭。是故我为彼众生问。以何等众生不空见闻而供养者。为彼众生。是故我问。佛子。若有不信此法门者。终不能得阿耨多罗三藐三菩提。佛子。为多众生得安隐故。为与无量众生乐故。为多怜愍诸世间故。为令多人得利益故。为多天人安隐乐故说此法门

尔时普贤菩萨摩诃萨。答文殊师利法王子言。文殊师利。云何诸佛如来无障碍智。文殊师利。所谓诸佛如来。十方世界。一切世界。一一世界。一一四天下。可化天人。及诸菩萨。若有应见真金色者。诸佛如来。即为示现。令彼众生得见如来真金之色无有障碍。文殊师利。可化众生。若有应见火光明炎如意宝王色者。诸佛如来。即为示现。令彼众生得见如来火光明炎如意宝王之色无有障碍。文殊师利。可化众生。若有应见电光明炎如意宝王色者。诸佛如来。即为示现。令彼众生得见如来电光明炎如意宝王之色。无有障碍。文殊师利。可化众生。若有应见日月灯明如意宝王色者。诸佛如来。即为示现。令彼众生得见如来日月灯明如意宝王之色。无有障碍。文殊师利。可化众生。若有应见集一切光明如意宝王色者诸佛如来。即为示现。令彼众生得见如来集一切光明如意宝王之色无有障碍。文殊师利。可化众生。若有应见自在王如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来自在王如意宝王之色。无有障碍。文殊师利。可化众生。若有应见师子王如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来师子王如意宝王之色。无有障碍文殊师利。可化众生。若有应见师子幢如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来师子幢如意宝王之色。无有障碍。文殊师利。可化众生。若有应见帝释王璎珞如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来帝释王璎珞如意宝王之色。无有障碍。文殊师利。可化众生。若有应见一切诸天光明如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来一切诸天光明如意宝王之色。无有障碍。文殊师利。可化众生。若有应见金刚如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来金刚如意宝王之色。无有障碍。文殊师利。可化众生。若有应见清水如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来清水如意宝王之色。无有障碍。文殊师利。可化众生。若有应见波头摩华如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来波头摩华如意宝王之色。无有障碍。文殊师利。可化众生。若有应见随心思惟如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来随心思惟如意宝王之色。无有障碍。文殊师利。可化众生。若有应见大琉璃如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来大琉璃如意宝王之色。无有障碍。文殊师利。可化众生。若有应见帝释王大青琉璃如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来帝释王大青琉璃如意宝王之色。无有障碍。文殊师利。可化众生。若有应见马瑙如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来马瑙如意宝王之色。无有障碍。文殊师利。可化众生。若有应见胜功德藏如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来胜功德藏如意宝王之色。无有障碍。文殊师利。可化众生。若有应见清净庄严如意宝王色者。诸佛如来。即为示现。令彼众生得见如来清净庄严如意宝王之色。无有障碍。文殊师利。可化众生。若有应见。无有障碍如意宝王色者。诸佛如来即为示现。令彼众生。得见如来无障碍如意宝王之色。无有障碍。文殊师利。可化众生。若有应见白真珠如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来白真珠如意宝王之色。无有障碍。文殊师利。可化众生。若有应见青真珠如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来青真珠如意宝王之色。无有障碍。文殊师利。可化众生。若有应见杂真珠如意宝王色者。诸佛如来。即为示现。令彼众生得见如来杂真珠如意宝王之色。无有障碍。文殊师利。可化众生。若有应见虚空光明真珠如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来虚空光明真珠如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇功德庄严大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇功德庄严大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇智功德庄严大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇智功德庄严大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇波罗蜜大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇波罗蜜大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇住地大海音声如意宝王色者。诸佛如来。即为示现。令彼众生得见如来出阿僧祇住地大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇陀罗尼大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇陀罗尼大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇三昧大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇三昧大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇解脱大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇解脱大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇无碍乐说辩才大海音声如意宝王色者。诸佛如来。即为示现。令彼众生得见如来出阿僧祇无碍乐说辩才大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇神通大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇神通大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇大愿大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇大愿大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇发勤精进大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇发勤精进大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇得安隐大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇得安隐大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入菩萨行大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入菩萨行大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入如来大海音声如意宝王色者。诸佛如来。即为示现。令彼众生得见如来出阿僧祇令入如来大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入随顺众生心行大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入随顺众生心行大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入劫大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入劫大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入世界大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入世界大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入三世说大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入三世说大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入三世大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入三世大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入不疲倦心大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入不疲倦心大海音声如意宝王之色。无有障碍。文殊师利。可化众生。若有应见出阿僧祇令入无差别智大海音声如意宝王色者。诸佛如来。即为示现。令彼众生。得见如来出阿僧祇令入无差别智大海音声如意宝王之色。无有障碍。何以故。以得不共法相应故。文殊师利。如大琉璃如意宝王。垢衣所缠。依垢衣故。种种事现。而大琉璃如意宝王。不分别离分别。而自然如是。无分别离分别。自然如是。种种事现。何以故。以不共法相应故。文殊师利。如是诸佛如来应正遍知。依可化众生。如是示现种种色行。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。种种异异。诸事可见。何以故。以得不共法相应故。文殊师利。是名诸佛如来无障碍智。文殊师利。云何诸佛如来无障碍智。文殊师利。所谓诸佛如来。十方世界一切种种异异世界。一一世界微尘数世界。令入如是微尘数世界智大海。无有障碍。文殊师利。一切种种异异世界。一一世界。一一四天下。一切世界微尘数异异功德。一一功德庄严大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数智。功德庄严大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数波罗蜜大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数住地大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数陀罗尼大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数三昧大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数解脱大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数无碍乐说辩才大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数神通大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数大愿大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数发勤精进大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数得安隐大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入菩萨行大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入如来大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入随顺众生心行大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入劫大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入世界大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入三世说大海。于念念间有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入三世大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种。异异世界。一切佛国土微尘数令入不疲惓心大海。于念念间。有阿僧祇异异说智。无有障碍。如是种种异异世界。一切佛国土微尘数令入无差别智大海。于念念间。有阿僧祇异异说智。无有障碍。何以故。以得自然智故。文殊师利。譬如山河深谷等中。闻于响声。依异异声异异名字。而出种种异异响声。而山谷等。不分别离分别。而自然如是无作心。无分别离分别。自然如是。种种声现。何以故。以不共法相应故。文殊师利。诸佛如来。说法音声。亦复如是随众生心。随诸众生可化。种种法门。闻种种声。种种自说。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。种种声现。何以故。以得不共法相应故。文殊师利。是名略说诸佛如来无障碍智。若广说者。尽未来际。劫数住持。不可说尽

文殊师利。云何诸佛如来。教化众生力。文殊师利。所谓诸佛如来肉髻。十方世界。一切世界。一切住处。一一世界。一一阎浮提。无障无碍。无有差别。遍覆一切。虚空法界。一切世间。教化众生。尽未来际。遍至无边世界。劫数住持无有休息。文殊师利。如是如来三十二相。于一一相。十方世界。一切世界。一切住处。一一世界。一一阎浮提。无障无碍。无有差别。遍覆一切虚空法界一切世间。教化众生。尽未来际。遍至无边世界。劫数住持无有休息。文殊师利。如是如来八十种好。于一一好。十方世界。一切世界。一切住处。一一世界。一一阎浮提。无障无碍。无有差别。遍覆一切虚空法界一切世间。教化众生。尽未来际。遍至无边世界。劫数住持无有休息。文殊师利。如是如来一切毛孔。一一毛孔。十方世界。一切世界一切住处。一一世界。一一阎浮提。无障无碍无有差别。遍覆一切虚空法界。一切世间。教化众生。尽未来际。遍至无边世界劫数住持无有休息。文殊师利。如是如来一切资生。十方世界。一切世界。一切住处。一一世界。一一阎浮提。无障无碍。无有差别。遍覆一切虚空法界一切世间。教化众生。尽未来际。遍至无边世界劫数住持。无有休息。何以故。以得不共法相应故。不共法相应者。依本愿力故。为诸众生住持力故。文殊师利。是名略说诸佛如来教化众生力。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来普门现前。文殊师利。所谓诸佛如来。十方世界。一切世界。一切住处。一一世界。一一阎浮提。一一微尘。文殊师利。过五十世界微尘数世界微尘大海阿僧祇百千万亿那由他微尘数一切世界。一一世界微尘数种种差别菩萨大海。如是处住。而不障碍。一切众生。住于四天下诸须弥山。大须弥山。斫迦罗山。摩诃斫迦罗山。城邑聚落。诸国土等。大河大池。无所妨碍。如本不异。而有是事。何以故。以得不共法相应故。而随众生心。随众生可化。天龙夜叉。乾闼婆阿修罗。迦楼罗紧那罗。摩睺罗伽。帝释梵天。人及非人。诸菩萨等。各各皆见诸佛如来普现其前。何以故。以得不共法相应故。文殊师利。譬如白月于十五日正中夜时。阎浮提中。若男若女童男童女。一切皆见月轮现前。而彼月轮。不分别离分别。而自然如是。无分别离分别。自然如是。一切皆见。何以故。以不共法相应故。文殊师利。诸佛如来。亦复如是。十方世界。一切世界。住处众生。随众生心。随众生可化。各各皆见诸佛如来现于其前。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。一切皆见。何以故。以得不共法相应故。文殊师利。是名略说诸佛如来普门现前。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来清净佛国土。文殊师利。所谓诸佛如来。十方世界。一切世界。种种住处。一一世界。一一微尘中。入一切世界微尘数世界海功德庄严大海。有阿僧祇异异说智。能清净之。或有世界海智功德庄严大海。有阿僧祇异异说智。能清净之。或有世界海波罗蜜大海。有阿僧祇异异说智。能清净之。或有世界海。住地大海有阿僧祇异异说智。能清净之。或有世界海陀罗尼大海有阿僧祇异异说智。能清净之。或有世界海三昧大海。有阿僧祇异异说智。能清净之。或有世界海解脱大海。有阿僧祇异异说智。能清净之。或有世界海。无碍乐说辩才大海。有阿僧祇。异异说智。能清净之。或有世界海神通大海。有阿僧祇异异说智。能清净之。或有世界海大愿大海。有阿僧祇异异说智。能清净之。或有世界海发勤精进大海。有阿僧祇异异说智。能清净之。或有世界海得安隐大海。有阿僧祇异异说智。能清净之。或有世界海令入菩萨行大海。有阿僧祇异异说智。能清净之。或有世界海令入如来大海。有阿僧祇异异说智。能清净之。或有世界海令入随顺众生心行大海。有阿僧祇异异说智。能清净之。或有世界海令入劫大海。有阿僧祇异异说智。能清净之。或有世界海令入世界大海。有阿僧祇异异说智。能清净之。或有世界海令入三世说大海。有阿僧祇异异说智。能清净之。或有世界海令入三世大海。有阿僧祇异异说智。能清净之。或有世界海令入不疲倦心大海。有阿僧祇异异说智。能清净之。或有世界海令入无差别智大海。有阿僧祇异异说智。能清净之。而诸佛如来不动本处。何以故。以得不动法故。文殊师利。是名略说诸佛如来清净佛国土而无所畏。若广说者尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来无边之身。文殊师利。所谓诸佛如来。十方世界。一切世界。一一世界。一一四天下。过五十世界微尘数世界微尘大海阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜功德大海。而自庄严。以得如是种种异异诸胜功德力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异。诸胜智功德庄严大海。而自庄严。以得如是种种异异诸胜智功德庄严力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨。大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜波罗蜜大海。而自庄严。以得如是种种异异诸胜波罗蜜力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜住地大海。而自庄严。以得如是种种异异诸胜住地力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜陀罗尼大海。而自庄严。以得如是种种异异诸胜陀罗尼力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜三昧大海。而自庄严。以得如是种种异异诸胜三昧力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜解脱大海。而自庄严。以得如是种种异异诸胜解脱力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜无碍乐说辩才大海。而自庄严。以得如是种种异异诸胜无碍乐说辩才力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜神通大海。而自庄严。以得如是种种异异诸胜神通力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜大愿大海。而自庄严。以得如是种种异异诸胜大愿力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜发勤精进大海。而自庄严。以得如是种种异异诸胜发勤精进力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜得安隐大海。而自庄严。以得如是种种异异诸胜得安隐力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入菩萨行大海。而自庄严。以得如是种种异异诸胜令入菩萨行力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入如来大海。而自庄严。以得如是种种异异诸胜令入如来力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入随顺众生心行大海。而自庄严。以得如是种种异异诸胜令入随顺众生心行力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得

阿僧祇种种异异诸胜令入劫大海。而自庄严。以得如是种种异异诸胜令入劫力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入世界大海。而自庄严。以得如是种种异异诸胜令入世界力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入三世说大海。而自庄严。以得如是种种异异诸胜令入三世说力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入三世大海。而自庄严。以得如是种种异异诸胜令入三世力住持故。一切皆得现见尔数诸佛如来。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入不疲惓心大海。而自庄严。以得如是种种异异诸胜令入不疲惓心力住持故。一切皆得现见尔数诸佛如来

文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨大众一一菩萨大众大海。各各皆得阿僧祇种种异异诸胜令入无差别智大海。而自庄严。以得如是种种异异诸胜令入无差别智力住持故。一切皆得现见尔数诸佛如来。

文殊师利。如是略说得诸依止诸希有相。行善知识。发勤精进。得心安隐。教化众生。禁戒受记。入菩萨行。入如来行。入众生行。入世界海。入诸劫海。入三世法。入心发起。不生疲倦。差别诸智陀罗尼门。说诸如来普贤诸心。普贤诸行。种种法相大慈之心。菩萨心因缘。恭敬善知识。发心诸行。诸修行清净。诸波罗蜜。如实觉知。得如实入诸力妙力平等诸道。说诸佛法。专取乐说。诸智增上。得不执着。心得平等。发起诸智。作诸应化。住持诸法。得大安隐。入诸深法。依佛依法。依止而住。得生慈心。不怯弱心。断诸疑网。得发起心不思议心。依何意说种种方便。诸智差别方便而说。得诸三昧。得一切入。得诸解脱诸通诸明。一切得心自在解脱。诸妙水池。诸妙楼阁。诸胜庄严。诸心不退。不舍心住。一切直心。智如海入。犹如诸宝。菩萨发心。得如金刚。而起发心大乘发心。平等发心。究竟发心。得不毁坏诸尊重心授记诸法诸善根回向。得智增上无边无中平等发心。得诸宝藏。得诸禁戒。得诸自在。得诸奋迅。一切境界一切诸力一切无畏。具足无量不共之法。教化一切诸菩萨等。一切身业。一切诸身。得诸口业。诸心发心。心遍普覆一切诸根。诸质直心。诸增上心。诸行诸信。入信世界。入诸勋习。得入诸取。入如实行。入成就行。入菩萨位。诸菩萨法定。诸法进趣道。亲近善知识。得诸善知识。是道非道。是量非量。成就见道。具道功德。修行识道。诸道庄严。文殊师利。如是一一皆应广说。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。种种示现。何以故。以得不共法相应故。文殊师利。如是如来。十方世界。一切世界。一切住处。一一世界。一一阎浮提。一时示现。随众生可化。而自见诸佛如来。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。种种示现。何以故。以得不共法相应故。以无障碍如来身故。文殊师利。是名略说诸佛如来无边之身。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来遍见。文殊师利。我譬喻说。何以故。有智慧者。依诸譬喻。得解义故。文殊师利。如大池水五百由旬。若千由旬。溢满地平。大莲华叶。覆彼池水。莲华叶上。中有一人。乘驾铁车。行华叶上。彼铁车轮。具有千辐。其车驾马。行疾之速。过金翅鸟。彼铁车行。如是速疾。而水不湿车轮车辐及以马足。车轮马足。不损华叶。彼池上人。如是车行。当尔之时。即水池中。生大毒蛇。以何等时。彼车轮及以马足一转依彼念时。彼大毒蛇。绕车七匝。文殊师利。以何等时。彼大毒蛇。绕车一匝。依彼刹那。阿难比丘。十遍说法。又复更有示现彼义。以何等时。阿难比丘。一遍说法。依彼刹那。舍利弗比丘。千遍说法。令众生知。以何等时。舍利弗比丘。一遍说法。依彼刹那。大目揵连。能过八十千世界外。以何等时。大目揵连。过一世界。依彼刹那。诸佛如来。一切世界。一切住处。一一世界。一一阎浮提。于一时间。非前后时。从兜率天。退生出家。行于苦行。坐于道场。降伏魔怨。现证正觉。转于法轮。示大涅槃。住持佛法。示诸法灭。能令一切外道行中。诸本生处。令一时见。非前后见。何以故。以无障碍故。无障碍者以无差别。无差别者以无依止。文殊师利。如大琉璃如意宝珠。无价色衣。以用缠裹。依彼衣故。见种种相。而大琉璃如意宝珠。不分别离分别。而自然如是。无分别离分别。自然如是。见种种相。何以故。以得不共法相应故。文殊师利。诸佛如来应正遍知。亦复如是。依可化众生。十方世界。一切世界。一切住处。于一时间。非前后时。念念如是。种种异见。而诸佛如来。非分别离分别。而自然如是。无分别离分别。自然如是。种种异见。何以故。以得不共法相应故。文殊师利。譬如月轮。或如日轮。于阎浮提一切器水。清净不浊。离于障碍。皆悉现见。而日月轮。本处不动。文殊师利。如是应正遍知。十方世界。一切世界。无障无碍。如是如是。可化众生。自心清净。皆见如来。而诸佛如来。兜率陀天。如本不动。如是十方一切世界。一切众生。发起心中。皆悉现前。何以故。以如来得不退智故。文殊师利。譬如世间一切众生。依下中上诸果报故。则下中上有为诸行。皆悉成就。而有为行。不分别离分别。而自然如是。无分别离分别。自然如是。如是种种诸事成就。何以故。以得不共法相应故。文殊师利。如是众生。依下中上业果报故。见诸佛如来。有下中上。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。见下中上。何以故。以得不共法相应故。文殊师利。譬如一雨一色味等。堕阎浮提。依种种器。有种种色。有种种味。有种种香。而大雨。不分别离分别。而自然如是无分别离分别。自然如是。色香味异。何以故。以得不共法相应故。文殊师利。如是诸佛如来。一味法界。依可化众生。见有种种差别诸法。而诸佛如来。不分别离分别。而自然如是。无分别离分别自然如是。见差别法。何以故。以得不共法相应故。文殊师利。譬如何处出生自在如意宝王。如是彼处无有铁生。种种铁器彼处不生。何以故。以得不共法相应故。文殊师利。如是。何处出生诸佛如来光明。彼处不生火之光明及电光明日月光明。不生种种如意摩尼宝王光明。不生天龙夜叉。乾闼婆阿修罗。伽楼罗紧那罗。摩睺罗伽。天帝释王。大梵天王。护世四王等诸光明。彼处天子诏敕不行。彼处不生四种姓氏。彼处不生八种诸难地狱饿鬼畜生等难。彼处不生十恶业道。彼处不生种种诸乱。彼处不生诸余外道恶命生活尼干子等。文殊师利。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。诸事不生。何以故。以得不共法相应故。文殊师利。是名略说诸佛如来不可思议境界。若广说者。尽未来际劫数住持。不可说尽

信力入印法门经卷第四信力入印法门经卷第五

        元魏天竺三藏昙摩流支译

文殊师利。云何诸佛如来自然智。文殊师利。譬如十方各过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数世界。一切世界。一一世界。一一阎浮提。于念念间。见佛色身。于一时见。非前后见。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。一时遍见。何以故。以得不共法相应故。文殊师利。十方各过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数世界。一切世界。一一世界。一一阎浮提。于念念间。诸佛如来自然智。依诸众生异异善根异异修行。一切种种异异伎术。自然而现。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。诸伎术现。何以故。以得不共法相应故。文殊师利。十方世界。一切世界海。一切所住处。世间出世间。一切法成就。彼一切种事。皆诸佛如来自然而现在前。何以故。以得不共法相应故。文殊师利。譬如大地。依大地故。住持一切种子草木诸树林等。能生能长。广狭大小。皆悉成就。而彼大地。不分别离分别。而自然如是。无分别离分别。自然如是。生长广狭。大小成就。何以故。以得不共法相应故。文殊师利。如是。依诸佛如来住持十方世界海刹。外道尼干子等。一切作业。及诸众生诸善根业。若世间业出世间业。生长广狭。大小成就。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。生长广狭。大小成就。何以故。以得不共法相应故。文殊师利。譬如有人到离恶刺诸药草处。一切恶刺。皆自堕落。然彼到处。不分别离分别。而自然如是。无分别离分别。自然如是。恶刺药草。悉皆堕落。何以故。以得不共法相应故。文殊师利。如是一切诸众生等。乃至尽解诸佛如来。或有经夹。彼诸众生。因彼因故。一切贪欲嗔恚痴刺。悉皆堕落。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。贪嗔痴刺。悉皆堕落。何以故。以得不共法相应故。文殊师利。譬如如意宝王。随诸众生有所须者。悉皆能与。而如意宝王。不分别离分别。而自然如是。无分别离分别。自然如是。有所须者。悉皆能与。何以故。以不共法相应故。文殊师利。如是。若有人天若诸菩萨摩诃萨等。往到诸佛如来之所。欲得如是如是闻法思议。彼人天等。一切悉得闻彼彼法。而诸佛如来。不分别离分别。而自然如是。无分别离分别。自然如是。一切悉得闻彼彼法。何以故。以得不共法相应故。文殊师利。是名略说诸佛如来无障碍智。若广说者。尽未来际劫数住持。不可尽说。文殊师利。云何诸佛如来不可思议境界。文殊师利。所谓诸佛如来。十方世界。一切世界。一一世界。一切微尘。一一微尘。入一切世界海。微尘世界。一一世界。一一阎浮提。亦复如是。文殊师利。过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来种种异异功德庄严大海。有阿僧祇种种说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异智功德庄严大海。有阿僧祇异异说法。异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异波罗蜜大海。有阿僧祇异异说法异异差别念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异住地大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异陀罗尼大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异三昧大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异解脱大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异无碍乐说辩才大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异大愿大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异得安隐大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异令入菩萨行大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异令入如来大海。有阿僧祇异异说法异异差别。念念示现。无障无碍。无差别遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异令入随顺众生心行大海。有阿僧祇异异说法异异差别。念念示现无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。如是种种异异令入世界大海。有阿僧祇异异说法异异差别。念念示现。无障无碍。无差别。遍虚空法界。无有边际。尽未来际。劫数住持。如是种种异异令入劫大海。有阿僧祇异异说法异异差别。念念示现。无障无碍。无差别。遍虚空法界。无有边际。尽未来际劫数住持。文殊师利。十方世界。一切世界。过去未来现在世界大海。诸佛如来。一切毛孔。一一毛孔。于一时间。非前后时。皆悉示现。何以故。以得无边无中际故。文殊师利。是名略说诸佛如来不可思议境界。若广说者。尽未来际劫数住持。说不可尽

文殊师利。云何诸佛如来普见文殊师利。所谓诸佛如来。十方世界。一切世界中。见诸众生若退若生。若入善道。若入恶道。如是如来顶上相。见如是如来白毫相。见如是如来一切诸相。一一遍见。如是如来一切诸好。一一遍见。如是如来一切毛孔。一一遍见。如是一时。非前后见。一切世界。见诸众生若退若生。若入善道。若入恶道。文殊师利。是名略说诸佛如来遍见。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来名称。文殊师利。所谓诸佛如来。十方世界。一切世界。一一世界一一阎浮提。一一微尘。一切微尘世界。入一切世界海。如是一一世界。一一阎浮提。于念念间。一切世界微尘数众生。奋迅示现。无障无碍。无差别。遍虚空法界。无有边际。可化众生。尽未来际劫数住持。何以故。以得不共法相应故。如是佛国土奋迅。如是身奋迅。如是愿奋迅。如是境界奋迅。如是智奋迅。如是神通奋迅。如是力奋迅。如是等。于念念间。一切世界微尘数奋迅示现。无障无碍。无差别。遍虚空法界。无有边际。可化众生。尽未来际劫数住持。何以故。以得不共法相应故。文殊师利。是名略说诸佛如来名称。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来无差别无依止。文殊师利。所谓诸佛如来。非此世界差别余世界无差别。文殊师利。诸佛如来。非依止此世界不依止余世界。文殊师利。诸佛如来。非此阎浮提差别余阎浮提无差别。文殊师利。诸佛如来。非依止此阎浮提不依止余阎浮提。文殊师利。诸佛如来。非此畜生道差别余畜生道无差别。文殊师利。诸佛如来。非此饿鬼道差别余饿鬼道无差别。文殊师利。诸佛如来。非此畜生道依止余畜生道不依止。文殊师利。诸佛如来。非欲界差别色界依止。文殊师利。是名略说诸佛如来无差别无依止。若广说者。尽未来际劫数住持。不可说尽文殊师利。云何诸佛如来身无障碍。文殊师利。所谓诸佛如来。十方世界。一切世界。国土大海。一切住处。三世无边一切众生。随众生心。随其可化。于念念间。顶相示现法相生灭如彼众生所应见闻。令见闻知。乃可虚空容有遍见。如来顶相终不可见。如是如来。十方世界。一切世界。国土大海。一切住处。三世无边一切众生。随众生心。随其可化。于念念间一切相好。一一相好。一切毛孔。一一毛孔。皆悉示现法相生灭。如彼众生所应见闻。令见闻知。乃可虚空容有遍见。诸佛如来一毛孔相终不可见。如有天人菩萨。随众生心。随其可化。依彼生灭法相而说。如彼所信。令入法中。文殊师利。或有天人菩萨。见如来顶相出阿僧祇功德庄严大海异异说法。知如是法。为众生说。令众生闻。如彼所信。入于法中。或有众生。知阿僧祇智功德庄严大海异异说法。或有众生。闻阿僧祇波罗蜜大海胜说法声。或有众生。闻阿僧祇住地大海胜说法声。或有众生。闻阿僧祇陀罗尼大海胜说法声。或有众生。闻阿僧祇三昧大海胜说法声。或有众生。闻阿僧祇解脱大海胜说法声。或有众生。闻阿僧祇无碍乐说辩才大海胜说法声。或有众生。闻阿僧祇神通大海胜说法声。或有众生。闻阿僧祇发勤精进大海胜说法声。或有众生。闻阿僧祇得安隐大海胜说法声。或有众生。闻阿僧祇令入菩萨行大海胜说法声。或有众生。闻阿僧祇令入如来大海胜说法声。或有众生。闻阿僧祇令入随顺众生心行大海胜说法声。或有众生。闻阿僧祇令入世界大海胜说法声。或有众生。闻阿僧祇令入劫大海胜说法声。或有众生。闻阿僧祇令入三世大海胜说法声。或有众生。闻阿僧祇令入三世说大海胜说法声。或有众生。闻阿僧祇令入不疲倦心大海胜说法声。或有天人菩萨。见佛顶相出阿僧祇无差别智大海异异说法。知如是法。为众生说。令众生闻。如彼所信。入于法中。如是念念一切相好。一一相好。一切毛孔。一一毛孔。如是十方世界。一切世界。一一世界。随众生心。随其可化。天人菩萨。见佛如来一毛孔相出阿僧祇异异法海异异说法。知如是法。为众生说。令众生闻。如彼所信。入于法中。文殊师利。是名略说诸佛如来身无障碍。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来顶相不可得见。文殊师利。所谓诸佛如来过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨摩诃萨大众大海。文殊师利。如是过五十世界微尘数世界微尘大海。阿僧祇百千万亿那由他微尘数诸佛如来菩萨摩诃萨大众大海。文殊师利。或有菩萨。见如来身高百由旬。或有菩萨。见十二十三十四十百由旬高。如是或有菩萨。见如来身高百由旬。或有菩萨。见十二十三十四十百由旬高。或有菩萨。即于如是大众中。见高千由旬。或有菩萨。见十二十三十四十千由旬高。如是或有菩萨。即于如是大众中。见高千由旬。或有菩萨。见十二十三十四十千由旬高。或有菩萨。见如来身高亿由旬。或有菩萨。见十二十三十四十亿由旬高。如是或有菩萨。见如来身高亿由旬。或有菩萨。见十二十三十四十亿由旬高。或有菩萨。见如来身高千亿由旬。或有菩萨。见十二十三十四十千亿由旬。十方世界。一切世界海刹。一切阎浮提。同一时中。皆见如来。非前后见。文殊师利。譬如若有菩萨摩诃萨。住不思议解脱三昧。于念念间。五十世界微尘世界。以为一步。行东方世界。其一一步。过五十世界微尘数世界大海。去向东方。为欲观察如来顶相。如是而去。经五十世界微尘数劫大海。而去彼处。观察如来顶相。二倍转高。何以故。以如来得不共法相应故。文殊师利。是名略说如来顶相不可观察。若广说者。尽未来际劫数住持。不可说尽

文殊师利。云何诸佛如来住持菩萨行教化众生。文殊师利。所谓诸佛如来十方世界微尘数世界。犹尚是少。诸佛如来。过于是数。一切世界。一一世界一一微尘教化行事。文殊师利。所谓随若干数如来身中。说尔许菩萨行。尔许如来无见顶相。一切诸相一一相中。一切诸好一一好中。一切毛孔一一毛孔。念念常出一切世界微尘数阿僧祇光明大海。或有常出一切世界微尘数阿僧祇功德庄严光明大海或有常出阿僧祇智功德庄严光明大海。或有常出阿僧祇波罗蜜光明大海。或有常出阿僧祇住地光明大海。或有常出阿僧祇陀罗尼光明大海。或有常出阿僧祇解脱光明大海。或有常出阿僧祇无碍乐说辩才光明大海。或有常出阿僧祇大愿光明大海。或有常出阿僧祇得安隐光明大海。或有常出阿僧祇令入菩萨行光明大海。或有常出阿僧祇令入如来光明大海。或有常出阿僧祇令入随顺众生心行光明大海。或有常出阿僧祇令入世界光明大海。或有常出阿僧祇令入劫光明大海。或有常出阿僧祇令入三世说光明大海。或有常出阿僧祇令入不疲倦心光明大海。文殊师利。如是常出阿僧祇光明大海。无差别智大海。无障无碍。无差别。遍虚空法界。无有边际。劫数住持。教化众生。而无所畏

文殊师利。诸佛如来。如是不思议事。十方世界。一切世界大海。一时念念众生大海。同时教化。或有众生海。以阿僧祇异异功德庄严大海异异说智。而教化之。或有众生海。以阿僧祇异异智功德庄严大海异异说智。而教化之。或有众生海。以阿僧祇异异波罗蜜大海异异说智。而教化之。或有众生海。以阿僧祇异异三昧大海异异说智。而教化之。或有众生海。以阿僧祇异异解脱大海异异说智。而教化之。或有众生海。以阿僧祇异异无碍乐说辩才大海异异说智。而教化之。或有众生海。以阿僧祇异异神通大海异异说智。而教化之。或有众生海。以阿僧祇异异大愿大海异异说智。而教化之。或有众生海。以阿僧祇异异发勤精进大海异异说智。而教化之。或有众生海。以阿僧祇异异得安隐大海异异说智。而教化之。或有众生海。以阿僧祇异异令入菩萨行大海异异说智。而教化之。或有众生海。以阿僧祇异异令入如来大海异异说智。而教化之。或有众生海。以阿僧祇异异令入随顺众生心行大海异异说智。而教化之。或有众生海。以阿僧祇异异令入世界大海异异说智。而教化之。或有众生海。以阿僧祇异异令入劫大海异异说智。而教化之。如是。或有众生海。令入三世。或有众生海。令入三世说。或有众生海。令入不疲倦心。或有众生海。令入无差别智。或有众生海。令入奋迅智。或有众生海。复入国土奋迅智。或有众生海。令入海奋迅智。或有众生海。令入身奋迅智。或有众生海。令入愿奋迅智。或有众生海。令入境界奋迅智。或有众生海。令入智奋迅智。或有众生海。令入神通奋迅智。或有众生海。令入力奋迅智。如是念念众生大海。一切微尘数。一切若干微尘数智。以阿僧祇异异说智。而教化之。文殊师利。是名略说诸佛如是教化众生而无所畏。若广说者。尽未来际。劫数住持。不可说尽

文殊师利。若有善男子善女人。于一切世界微尘数诸众生。日日以天甘露百味饮食及天衣服卧具汤药。给施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。给施供养。文殊师利。若复有善男子善女人。于一优婆塞不信余尊。持十善业道。摄取彼人。生如是心。此是学佛诸戒行人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数不信余尊持十善业道诸优婆塞。日日以天甘露百味饮食。及天衣服卧具汤药。给施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一比丘。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数比丘。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一信行人。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子。善女人。于一切世界微尘数诸信行人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一法行人。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸法行人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于八人中一人。摄取彼人乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸八人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一须陀洹向。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸须陀洹向。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一须陀洹。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸须陀洹。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一斯陀含向。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸斯陀含向。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇。恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一斯陀含。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸斯陀含。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一阿那含向。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸阿那含向。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一阿那含。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸阿那含。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一阿罗汉。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸阿罗汉。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一辟支佛。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸辟支佛。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。见于壁上一画佛像。或经夹中见画佛像。文殊师利。此福胜前。无量阿僧祇。何况合掌。若以一华。奉施佛像。或以一香。或以末香。或有涂香。或然一灯。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一恒河沙等世界诸佛如来。及声闻僧。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至无量无边阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一羊车乘行菩萨得直心人。随一善根能作佛种。摄取彼菩萨。乃至一日。以粗饮食。一施其人。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸羊车乘行菩萨人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一象乘行菩萨人。随一善根能作佛种。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸象乘行菩萨人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一日月乘行菩萨人种佛善根。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸日月乘行菩萨人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一声闻乘神通行菩萨人。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸声闻乘神通行菩萨人。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于一如来神通行菩萨人。摄取彼人。乃至一日。以一食施。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。于一切世界微尘数诸如来神通行菩萨摩诃萨。日日以天甘露百味饮食。及天衣服卧具汤药。奉施供养。如是乃至阿僧祇恒河沙数世界微尘等数劫海。而供养之。文殊师利。若复有善男子善女人。于此法门。能自书写。若令他书写。文殊师利。此福胜前。无量阿僧祇文殊师利。不善业罪。亦如是说应当善知。文殊师利。如是羊乘行人。象乘行人。日月乘行人。声闻乘神通行人。菩萨乃至为畜生道。令生善根。若男子女人。起微嗔心貌相变异。乃至畜生障一善根。文殊师利。此罪过前。无量阿僧祇。文殊师利。若有男子女人。于十方世界。一切世界微尘数诸众生。挑却其眼。劫夺一切资生财物。文殊师利。若复有男子女人。于一菩萨所。起欺慢心。骂辱毁訾。文殊师利。此罪过前。无量阿僧祇。文殊师利。若有男子女人。于一菩萨。乃至微少。随何因缘。以欺慢心。骂辱毁訾。彼男子女人。堕大叫唤地狱之中。身形大小。五百由旬。有五百头于一一头有五百口。于一一口有五百舌。于一一舌有五百犁。以耕其舌。文殊师利。若有男子女人。于三千世界所有众生。若以刀杖。斫打杀之。劫夺一切资生财物。文殊师利。若复有男子女人。于菩萨所。生欺慢心。起嗔恨意。文殊师利。此罪过前。无量阿僧祇。文殊师利。若有男子女人。起于恶心。不生众生安隐之心。于恒河沙等一切诸世界。一一世界。一一阎浮提。恒河沙等。诸阿罗汉。尽皆杀害。恒河沙等诸佛如来。七宝塔庙。七宝栏楯。宝幢幡盖。皆悉破坏。尽令消灭。文殊师利。若复有男子女人。于信大乘菩萨。乃至微少。随何因缘。生欺慢心。嗔骂毁訾。文殊师利。此罪过前。无量阿僧祇。何以故。以从菩萨生诸佛故。以从菩萨不断诸佛如来种故。若其有人。谤菩萨者。彼人名为谤佛谤法。何以故。以不异法有菩萨故。以诸菩萨即是法故。文殊师利。若有男子女人。于十方世界一切世界一切众生。以嗔恚心。系缚安置黑闇地狱。文殊师利。若复有男子女人。嗔于菩萨。乃至回身异方看顷。文殊师利。此罪过前。无量阿僧祇。文殊师利。若有男子女人。于一切阎浮提。一切众生。所有资生。一切财物。悉皆夺尽。文殊师利。若复有男子女人。随一菩萨。若好若恶。以嗔恨心。骂辱毁訾。文殊师利。此罪过前。无量阿僧祇。文殊师利。譬如须弥山王胜于诸山光明照曜。胜者所谓高下广狭。文殊师利。如是菩萨。信此法门。十方世界一切世界微尘等数诸菩萨中。最胜最上。何以故。若有菩萨。信此法门。五波罗蜜。所起功德。一切善根。阿僧祇劫之所修行。信此法门。其福为胜。所谓胜者高下广狭。文殊师利。若有善男子善女人。于十方世界微尘数菩萨。令发菩提心。文殊师利。若复有善男子善女人。信此法门是出世间法。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。一切众生。信此法门。令发菩提心。文殊师利。若复有善男子善女人。信此法门。信已书写。若教他书。若自身诵。若教他诵。乃至经夹书写信敬。受持供养。然灯香华。末香涂香。华鬘供养。此法门者。文殊师利。此福胜前。无量阿僧祇。文殊师利。若有善男子善女人。一切世界。所有众生。信声闻道。彼声闻道。一一众生。皆与无量阿僧祇转轮圣王住处善根。及与生天胜妙善根。尽皆断灭。文殊师利。若复有异人。于一菩萨摩诃萨。障一善根。文殊师利。此罪过前。无量阿僧祇。何况嗔恚骂辱毁訾。文殊师利。若有男子女人。恒河沙等诸佛塔庙。破坏焚烧。文殊师利。若复有男子女人。于信大乘菩萨众生起嗔恚心骂辱毁訾。文殊师利。此罪过前。无量阿僧祇。何以故。以从菩萨生诸佛故。以从诸佛有塔庙故。以因佛有一切世间诸天人故。是故供养诸菩萨者。即是供养诸佛如来。若有供养诸菩萨者。即是供养三世诸佛。毁訾菩萨。即是毁訾三世诸佛。文殊师利。若有善男子善女人。若欲得依无上供养诸如来者。应当供养诸菩萨也

文殊师利。若有城邑聚落等中。或有一亿。或有千亿。或有百千亿无量无边阿僧祇菩萨。于此法门。不生信心。彼诸菩萨。若有王乱。或有业乱。或有水难。或有崄难。或有火难。或有贼难而彼城邑聚落等中。有一菩萨。信此法门。而彼菩萨。有阿僧祇罪业。皆尽远离诸难。然此菩萨。于彼城邑聚落等中。无有王难。无有业难。无有水难。无有崄难。无有火难。无有贼难。无恶众生不信法难。菩萨若信此法门者。阿僧祇劫。所有众罪。应入地狱畜生饿鬼。即现身灭。然彼菩萨。有阿僧祇不可说劫阿鼻地狱极重罪业。即现身灭。一切诸难悉皆消尽。若十二十若三十劫阿鼻地狱极重罪业。即现身中皆得消灭。何以故。以大功德积聚集故

文殊师利。如大水池广百由旬。彼池中水。具足八味。若有人以一波罗毒。着彼池中。乃至千斤即无毒气。何以故。以得大水多聚集故。文殊师利。如是虽有无量无边诸恶罪业。应堕地狱畜生饿鬼满一劫住。而即消灭。何以故。信此法门。故大功德无量无边故。佛说此法门已。十方世界。阿僧祇诸来菩萨摩诃萨。大会之众。及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。闻佛所说。欢喜奉行

信力入印法门经卷第五


诸菩萨求佛本业经一卷

    No. 282 [Nos. 278(7), 279(11), 282]

    诸菩萨求佛本业经一卷

        西晋优婆塞聂道真译

若那师利菩萨。问文殊师利菩萨。菩萨何因身有所行。不令他人得长短。口所言。不令他人得长短。心所念。不令他人得长短。何缘身不法他人长短。口不说他人长短。心不念他人长短。持是身所行口所言心所念。众阿罗汉辟支佛。及诸天人世间人民。所不能及知。身所行口所言心所念。无能逮者。无有能动转者。身所行口所言心所念。无有能害者。身所行口所言心所念。皆成就遂意。身所行事净洁。口所言净洁。心所念净洁。身所行无瑕秽。口所言无瑕秽。心所念无瑕秽。身所行智慧在上头。口所言智慧在上头。心所念智慧在上头。生时端正。生时智慧。生时布施。生时种类中好。生时于尊贵家。生时面色好。生时善相与众异。意所念皆强。多所护持不忘。无所爱惜。高才猛健。猛中尊。猛中贵。猛中勇。猛中勇猛。猛中无有比。所识为无有能斟量者。所议无有央数。所议为不可计。无有边幅。无有能胜者。慈爱于佛经。皆前世筋力行所致。多所出入语者。人皆信用之。无有不敬附者。身所行。无有不净洁者。诸所视经。无有不了知者。一心降意。思惟明晓。回念入禅。出入五音中。入于四事中。入于三事中。入于十二事中过去当来今现在所出生福祐功德中。入于七觉意中。入于虚空无常无所挂碍中。入于六波罗蜜经中。悉具足念善慈爱愍伤等。心悉无所憎爱。入于十种力慧中。为诸天梵释。阿须轮鬼神龙所供养。悉爱护十方人。诸有惊怖者。皆归仰得解。诸有恐惧急缘者。无不得安隐者。明于十方。如灯火如炬火。如大火如日月。过度诸世间人。如船佐。如船中人。有尊师。于诸天世间人民蜎飞蠕动之类。极善极豪。都于大众中。最独尊雄中复重雄。极上无有与等者。如是法当何以致之。文殊师利菩萨。谓若那师利菩萨言。善哉善哉。佛子所问。乃尔极大慈爱。多所度脱。乃作是发意问。所问者皆有佛子菩萨身所行。有口所言。有心所念。有意所念道。诸所施行功德悉可得。未曾增减。佛经时。过去当来今现在佛。悉受得之。皆从是起成。皆使世间人民悉安隐。诸所说经悉谛受。诸所有宿命恶悉消尽。诸经悉受得之。诸所有皆快。诸所有皆好。无有与等者。如是佛子。行于大道者。悉皆得之

菩萨居家法。心念言。十方天下人。皆使莫为爱欲所拘系。悉入虚空法中。菩萨孝顺供养父母时。心念言。十方天下人。皆使早得佛道。以当度脱十方天下人。菩萨妻子共居时。心念言。十方天下人。皆使诸有爱欲悉消去。菩萨居家。有所思时。心念言。十方天下人。皆使脱于爱欲中。得道极过度。菩萨居家相娱乐。作音乐时。心念言。十方天下人。皆使听受诸经。悉得闻如是作音乐时欲听闻。菩萨着七宝时。心念言。十方天下人。皆使脱于重担去。悉得止休息。菩萨在婇女中相娱乐时。心念言。十方天下人。皆使悉入佛经中。拔弃于淫泆。菩萨在楼上时。心念言。十方天下人。皆使上佛经讲堂上。悉受诸经无有与等者。菩萨布施时。心念言。十方天下人。皆使诸所有。但欲施与人。无有贪爱者。菩萨与妻子恩爱时。心念言。十方天下人。皆使早脱去于淫泆恶露悉弃捐。令觉知入虚空中。菩萨患厌家中时。心念言。十方天下人。皆使早得脱解。无所复拘着。菩萨弃家行学道时。心念言。十方天下人。皆使得出去莫复还入爱欲中。无所复贪若菩萨到佛寺时。心念言。十方天下人。皆使但念佛。悉入诸经中。无所复挂碍。菩萨至师和上所时。心念言。十方天下人。皆使心所念。善无有不得者。悉入正经中。菩萨索作沙门时。心念言。十方天下人。皆使所至到。悉令得成就。莫复中悔止。菩萨去白衣时。心念言。十方天下人。皆使极照明。于功德中。莫令有懈怠。菩萨受袈裟时。心念言。十方天下人。皆使无所沾污。持心如佛。菩萨剃头发时。心念言。十方天下人。皆使垢浊悉除去。莫复与共会。菩萨作大沙门时。心念言。十方天下人。皆使还沤和拘舍罗波罗蜜悉得经。菩萨作沙门时。心念言。十方天下人。皆使作沙门时。令如佛悉度十方天下人。菩萨持戒时。心念言。十方天下人。皆使护持禁戒。莫令犯如法。菩萨受和上时。心念言。十方天下人。皆使念所知禅。极过度。无所一挂碍。菩萨受师时。心念言。十方天下人。皆使所作。悉为狎习。如所教法。持不失。菩萨自归于佛时。心念言。十方天下人。皆使无不欢乐于佛法。悉生极好处。菩萨自归于经时。心念言。十方天下人。皆使无不得深经藏。所得智慧如大海。菩萨自归于僧时。心念言。十方天下人。皆使无不得依度如比丘僧。有所依度乐于佛道德。菩萨开户时。心念言。十方天下人。皆使早开天门。入佛经门。莫复厌还者。及自到佛泥洹道。菩萨入室中时。心念言。十方天下人。皆使得度脱。所居止处。早如佛所止处。早逮得深经。众阿罗汉辟支佛所不能及。菩萨闭户时。心念言。十方天下人。皆使早闭塞恶道门。诸所有宿命恶悉烧尽。菩萨敷床时。心念言。十方天下人。皆使早入至深经中。悉视十方人虚空。菩萨坐时。心念言。十方天下人。皆使坐安如佛坐于师子座上时。莫令心有所著。菩萨正坐时。心念言。十方天下人。皆使入正功德中。无令有狐疑增减佛经中。菩萨喘息时。心念言。十方天下人。皆使喘息定成止足。菩萨徊念观时。心念言。十方天下人。皆使当作是念。见无常法。菩萨起坐时。心念言。十方天下人。皆使所见虚空法。无有不了知者。菩萨足蹈地时。心念言。十方天下人。皆使住安隐。不复动摇。菩萨着泥洹僧时。心念言。十方天下人。皆使捡持功德。悉愧于世间诸所有早令得佛道。菩萨系带时。心念言。十方天下人。皆使结诸功德悉令坚。菩萨被安和时。心念言。十方天下人。皆使重益得诸功德。悉入诸经中。极过度去。菩萨被震越时。心念言。十方天下人。皆使常乐喜于佛经。未曾有离时。菩萨持杨枝时。心念言。十方天下人。皆使学诸经。悉净洁得。菩萨漱齿洗口时。心念言。十方天下人。皆使诸垢浊。悉净洁去清净住。菩萨左右时。心念言。十方天下人。皆使弃众恶。断绝淫泆嗔恚愚痴。菩萨行至水时。心念言。十方天下人。皆使上佛经。悉净洁。菩萨持水行时。心念言。十方天下人。皆使无不谨敕软好心净洁。菩萨澡手时。心念言。十方天下人。皆使软好手取诸经道法。菩萨洗面时。心念言。十方天下人。皆使入佛经道。面门莫令有瑕。秽菩萨向出门时。心念言。十方天下人。皆使逮所求索。悉疾得无所复挂碍。菩萨向道时。心念言。十方天下人。皆使早得佛。莫复令还。菩萨行道时。心念言。十方天下人。皆使入无底经中。悉深入经。净洁身体。无所挂碍。菩萨行道上阪时。心念言。十方天下人。皆使喜乐佛经。无有厌极时。菩萨行道下阪时。心念言。十方天下人。皆使入佛大道中。悉贯诸智慧。菩萨行曲道中时。心念言。十方天下人。皆使莫有邪念。无令有恶口。菩萨行直道中时。心念言。十方天下人。皆使心念正道。无令有谀谄。菩萨见扬尘满道时。心念言。十方天下人。皆使诸欲去。常得明经。菩萨见淹尘满道时。心念言。十方天下人。皆使常柔软心。悉得诸慈哀。菩萨见阴凉树时。心念言。十方天下人。皆使诸所恶法。悉除去通利。入佛经中悉觉知。菩萨见讲堂精舍时。心念言。十方天下人。皆使听受诸经悉入中。菩萨见林大树时。心念言。十方天下人。皆使无不归仰供养者。天上世间皆悉然。菩萨见山时。心念言。十方天下人。皆使心念高才。明诸功德法。无有能胜者。菩萨见棘树时。心念言。十方天下人。皆使疾远离于淫泆嗔怒愚痴。菩萨见叶树时。心念言。十方天下人。皆使道覆盖得禅。回入三昧。菩萨见华树时。心念言。十方天下人。皆使庄身得三十二相。菩萨见实树时。心念言。十方天下人。皆使得华实。悉具足于佛经中。菩萨见流水时。心念言。十方天下人。皆使入佛经流渊中。悉得佛智。菩萨见井时。心念言。十方天下人。皆使早开经门。一味无有异。菩萨见汲水时。心念言。十方天下人。皆使所道智悉具足。开入功德法中。菩萨见泉水时。心念言。十方天下人。皆使所问慧者。多所解。悉会于佛经道中。菩萨见大水时。心念言。十方天下人。皆使悉重持诸功德法。无有尽[歹*斯]。时无有能过者。菩萨见桥梁时。心念言。十方天下人。皆使得诸经。极过度人。如桥梁过人。无有极止时。菩萨见宅舍时心念言。十方天下人。皆使远离于爱欲。十方人心所念者皆悉知。菩萨见园时。心念言。十方天下人。皆使心无所拘着。不乐于五音乐五所思。菩萨见果园时。心念言。十方天下人。皆使心无所愁忧。悉得深智本根。菩萨见戏园时。心念言。十方天下人。皆使无不精进者。莫令离于佛诸经。菩萨见庄严大众出时。心念言。十方天下人。皆使庄严于三十二相悉逮得。菩萨见人愁忧时。心念言。十方天下人。皆使莫复愁忧。菩萨见人乐时。心念言。十方天下人。皆使乐喜深经。菩萨见人不乐时。心念言。十方天下人。皆使恩爱。无所著。菩萨见人安隐时。心念言。十方天下人。皆使安隐。逮得如佛安隐。菩萨见人勤苦时。心念言。十方天下人。皆使灭[歹*斯]诸勤苦。悉见正真道。菩萨见人强健时。心念言。十方天下人。皆使强健如佛。时身强健。菩萨见人病时。心念言。十方天下人。皆使念无常。悉入虚空中。尽究竟于佛经。莫复还。菩萨见端正人时。心念言。十方天下人。皆使爱乐于佛经。菩萨见丑人时。心念言。十方天下人。皆使莫堕丑恶中。菩萨见报恩时。心念言。十方天下人。皆使报恩于诸菩萨。菩萨见不报恩人时。心念言。十方天下人。皆使无有悭贪。悉示人于正道。菩萨见沙门时。心念言。十方天下人。皆使受诸经。悉究竟得。菩萨见异道人时。心念言。十方天下人。皆使诸恶根本。悉消尽赐。究竟诸经。菩萨见仙人时。心念言。十方天下人。皆使所求愿。尽悉得。所作为皆成足。菩萨见被铠人时。心念言。十方天下人。皆使受铠悉具足于佛经。菩萨见愚钝时。心念言。十方天下人。皆使黠健。所作为。莫堕众恶中。菩萨见讲经时。心念言。十方天下人。皆使所闻知。无不解慧者。菩萨见帝王时。心念言。十方天下人。皆使自致为经中王。自然转经。说道无有休绝时。菩萨见太子时。心念言。十方天下人。皆使作佛子。常化生于经中。菩萨见公卿时。心念言。十方天下人。皆使明于深经中所问慧。莫不解遣承用者。菩萨见旁臣长吏时。心念言。十方天下人。皆使念正莫用有恶。无令远离于诸菩萨。菩萨见城时。心念言。十方天下人。皆使身体。无有与等者。悉令人善无有能过者。菩萨见宫阙时。心念言。十方天下人。皆使乐明于心。常念与善功德相值。菩萨见持锡杖时。心念言。十方天下人。皆使常作善。为人所仰。常欲施与人。教人为善法。菩萨持钵时。心念言。十方天下人。皆使多所馈遗。悉受所供养。皆入于无底功德中。菩萨行分越时。心念言。十方天下人。皆使入佛法处。无有忘误时。菩萨至人家门时。心念言。十方天下人。皆使至佛经门。菩萨入门内时。心念言。十方天下人。皆使入佛智慧内。菩萨未受饭食时。心念言。十方天下人。皆使无有逆难。悉入般若波罗蜜经中。菩萨未得饭时。心念言。十方天下人。皆使莫复堕泥犁。禽兽。薜荔。监楼。恶道中。菩萨见空钵时。心念言。十方天下人。皆使空于爱欲中。菩萨见满钵时。心念言。十方天下人。皆使满诸功德中。菩萨见受饭钵时。心念言。十方天下人。皆使奉行佛道事。菩萨见惭愧人时。心念言。十方天下人。皆使无不惭愧于爱欲者。菩萨见不惭愧人时。心念言。十方天下人。皆使心所念恶悉弃捐。莫不慈哀者。菩萨得美食时。心念言。十方天下人。皆使所愿。无不悉得者。心无沾污。菩萨得粗饭食时。心念言。十方天下人。皆使柔软心。无不愍伤者。菩萨饭时。心念言。十方天下人。皆使如禅食足。常饱于经。菩萨食味时。心念言。十方天下人。皆使饱味。如佛喉咽所化味时。悉令逮得于甘露名经。菩萨饱已时。心念言。十方天下人。皆使所作。为悉成足。入佛经极过去。菩萨说经咒愿时。心念言。十方天下人。皆说所道。无有尽时。悉入佛诸深经中。菩萨说经咒愿已出去时。心念言。十方天下人。皆使出于三处色。无常空中。悉受得佛智慧。菩萨入水时。心念言。十方天下人。皆使入佛智慧中。过去当来今现在悉平等。菩萨浴时。心念言。十方天下人。皆使洗除心垢。悉令去明极照至边。菩萨见热时。心念言。十方天下人。皆使远离于热极过度去。菩萨见寒时。心念言。十方天下人。皆使作人中将。得极明凉好处。菩萨见诵经时。心念言。十方天下人。皆使解于诸经处。尽求索智。悉揽持诸慧。菩萨见佛时。心念言。十方天下人。皆使与诸佛共会。心无所挂碍。菩萨上向视佛时。心念言。十方天下人。皆使眼所视。无所挂碍。见无极处。菩萨为佛礼拜。头脑着地时。心念言。十方天下人。皆使无有能逮见佛头上者。天上天下。菩萨拜起。正视佛时。心念言。十方天下人。皆使行经无有与等者。菩萨绕佛一匝时。心念言。十方天下人。皆使绕极善所作。为皆究竟赐经明。菩萨绕佛三匝时。心念言。十方天下人。皆使所作为。心常勇。未常远离于佛道。菩萨称誉佛功德威神时。心念言。十方天下人。皆使所作为。功德不可计。威神不可计。功中极过度。菩萨洗足时。心念言。十方天下人。皆使悉得佛神足念飞。无所复挂碍。悉入具。菩萨称誉佛相时。心念言。十方天下人。皆使身体。悉具足如佛经身。菩萨卧坐时。心念言。十方天下人。皆使得佛智慧。得十力。是为菩萨常所行道

是释迦文佛刹。凡有百亿释提桓因坻。皆忉利天上。悉各思想欲请佛。诸释提桓因坻皆为佛于紫绀正殿上。施七宝师子座。以天所有名好劫波育杂色。若干种绝殊好。皆敷着座上。皆施绝好交露帐。皆各于适已。佛即悉知之。佛便分身威神。悉皆在百亿忉利天上释提桓因抵外门。一一释提桓因坻。皆有一佛。凡有百亿佛。皆与诸菩萨等俱。诸释提桓因坻。皆大欢喜。悉出迎。为佛作礼。请佛入。佛即与诸菩萨等俱入。至紫绀正殿上帐中坐。诸菩萨等。悉各于一一七宝莲华师子座交露帐中坐。佛续在是百亿小国土。与诸菩萨共坐。威神不动。十方诸菩萨大复来会

昙昧摩提菩萨。复有昙昧摩提菩萨。师利摩提菩萨。俱那摩提菩萨。堕夜摩提菩萨。沙头摩提菩萨。若那摩提菩萨。沙遮摩提菩萨。阿迦摩提菩萨。沙罗摩提菩萨。萨和摩提菩萨诸菩萨求佛本业经


最胜问菩萨十住除垢断结经卷第一(一名十千日光三昧定)

    No. 309

最胜问菩萨十住除垢断结经卷第一(一名十千日光三昧定)

        姚秦凉州沙门竺佛念译

    道引品第一

闻如是。一时佛在毗舍离城奈氏树园。与大比丘众八万四千。菩萨十万四千人俱。普皆大圣玄鉴通达。获致总持辩无滞碍。三昧常定慧无畏难。解了缠縺十二行本。以逮深要不起法忍。周流五趣观察训导。以佛弘智覆盖众生。随其根源而救济之。执持威仪不失礼节。其名曰常净菩萨。宝积菩萨。宝士菩萨。宝印首菩萨。宝藏菩萨。趣意菩萨。转法轮菩萨。除阴盖菩萨。施莲华行菩萨。师子菩萨。日光菩萨。见正反邪菩萨。不置远菩萨。无损志菩萨。持地菩萨。持魔菩萨。造化菩萨。水光菩萨。施相菩萨。应声菩萨。金璎菩萨。慈氏菩萨。濡首等。十万四千人俱。尔时地主。四大天王释提桓因。将诸忉利天。焰天。兜术天。化自在天。他化自在天第一梵天王。将诸梵众来诣佛所。及诸天龙鬼神揵沓和阿须伦迦留罗真陀罗摩休勒人与非人悉来集会

尔时如来。与无央数亿千之众眷属围绕。而为说法。弊魔波旬不安本位。复将官属前后围绕来至佛所。头面稽首在一面立。此贤劫中一切大圣。诸正士等皆悉云集。是时如来。复以舌相光明普照三千大千刹土。见光明者各相谓言。今日忍土释迦文佛。放大光明引致十方。高行菩萨于光明中演出此音。能仁如来至真等正觉。在娑诃国土。放微妙光。与诸大人演说十千三昧正定。非是缘觉声闻所行。我等各各赍供养具。诣彼忍土兴致礼敬承受奉觐

于时东方去此九万二千诸佛世界。国名盛妙。佛号殊胜如来。其佛左右有菩萨名曰执志。通慧大士住不退转。光明遍彼劝进菩萨。寻自往诣盛妙如来至真等正觉所。稽首长跪而白佛言。唯然大圣。欲至忍土奉觐释迦文佛至真等正觉。稽首问讯咨受未闻。其佛告曰。宜知是时便往勿疑。又谓执志。虽至忍界即当奉行五十五事。戢在心怀无令漏失。何谓五十五事。施与不施等。于戒犯戒等。忍对不起等。进退强意等。乱心禅定等。深智浅愚等。怨储二亲等。见骂若空等。三乘无高下。亦无若干想。亦不见善亦不见不善。亦不见佛土净。亦不见佛土不净。若见众生生恶趣者不怀恐畏。见诸上士观如众祐。亦不有二常若一心。若见有杀盗淫泆。妄言绮语嗜酒愚乱。嫉妒恚痴斗讼彼此。心执邪见非常言常。悉当平等无增减心。莫见戒具受上福。报施受大福。亦复莫云我今护杀延寿无量。亦莫相轻我相好胜教诫殊特。彼人卑秽凡夫朋党。除去七慢十二无记。是为五十五事。当念修行。佛言执志。若有族姓子族姓女。心志质直等住定意可游彼土。设百千劫于吾之土建立梵行。不如忍界弹指之间无高下意。是为殊胜亿千万倍。于时彼土五万菩萨各誓愿言。我当具足心意清净。侍卫执志菩萨。得诣奉觐能仁如来至真等正觉。执志菩萨即与五万菩萨。譬如力士屈伸臂顷。斯须之间于其佛土忽然不现。寻在忍界奉觐能仁。稽首礼拜退住一面。尔时世尊观众来会集坐已定。告四部众。汝等见此执志菩萨乎。对曰已见。佛言。诸族姓子。斯大士者。超越三有分别深奥。辩才通达慈哀感动。神足变化导引劝进。所游居处多所饶益。是时座上有菩萨。名曰最胜。承佛威神即从坐起头面礼足。白世尊曰。唯然无著志性愚痴愿欲所问。若见听许乃敢陈启

佛告最胜。恣汝所问。如来当为解说。尔时最胜菩萨以听所启。即白佛言。唯然世尊。如来至真入何三昧。放大光明踰于日月。若有众生观如来光必至所愿不失人根。此何变化神妙乃尔

佛告最胜。快哉问矣。诚如来言光明威力。接度众生多所开化。如来随宜入亿百千诸三昧定。游于恒沙无量佛土。尘数垓兆性行所趣。有淫怒痴强梁自用贡高放泆者。如来观察具分别之

尔时最胜复白佛言。何谓菩萨从初发迹至成作佛。一地二地至于十地。为断几结消除几垢。何谓菩萨解了己身内外无生。何谓菩萨自称广施不除断灭。何谓菩萨行戒具足终而不犯亦不毁戒坠堕本位。何谓菩萨忍而不起于忍退还为凡夫行。何谓菩萨精勤不懈复有慢怠从始积业。何谓菩萨入定意法天雷震动心不错乱。云何菩萨初发心行无能断者。云何菩萨意识安隐不可舍离。何谓菩萨其心独尊与众超异。云何菩萨心之所趣无能知意

尔时世尊告最胜曰。善哉善哉。乃问斯义。多所饶益多所成办。今当为汝敷演其谊。菩萨所行不可思议。智无边崖亦无等侣。乃能兴心于如来前而师子吼。谛听谛听善思念之。最胜则曰。受教而听

佛言。菩萨发心求无上道。先断妄见身邪戒盗分别苦智。建立志愿具足禁戒。每自思惟我之所行。愿乐远离凡俗之法。以五阴性不可得故道亦不可得。况于在道外者。猗色痛想行识求度众生。佛复告最胜。五阴亦无观行。众生亦无观行。亦复不见所可度者。无言教法。非罗汉辟支佛所能及也。尔时最胜菩萨。白佛言。世尊。不从五阴无观行得道不从众生无观行得道。宁可从四禁法得乎。佛言非也。最胜复白佛言。设不从四事得者。复可从空得耶。佛言非也。尔时最胜菩萨复白佛言。不从空得不从四事得者。今日如来及众会者。不成无上道。亦不得果报乎。佛言。成无上道耳。但不住有性亦不住无性。而成等正觉。最胜白佛言。云何色痛想行识。及内外法善恶法。有漏无漏法。有为无为法。如来所说名号之法。云何以名想字体教授一切乎。佛言。行亦无名复无想念。不见入出之二来往周旋。故号一切智。菩萨常当以十法了十地事。云何十法了十地事。以苦习义尽道之义。灭尽无生一切遍义。自识己身及他人义。于六邪本及六十二见皆知空无义。菩萨行是时。当除有迹无迹。云何除有迹无迹。道是迹非道无迹。来往是迹。无来往者便无有迹。菩萨当念修诸住地。当行苦义断淫欲之火嗔恚之毒愚痴之刺。悲慈之心遍满四方。虽有愍哀意亦不有想。已所惠施终不为己。普及众生亦无所吝。施不见施不有受者及与财物。念与善者周接。常当下意无生贡高。说法之时不见有法。出生窠窟无法之想。出家之日与爱欲别。以空无法断除顾恋。求佛成道莫着相好。亦复莫念吾先成道某在吾后。设欲分流法教。终不败法毁法。进趣果证不为尘欲所牵。心常怀念灭于贡高。自用不求法报及财宝物。所授谛说无言教想。持身如空空无想念。是为菩萨以苦智成办净一地迹。复次菩萨。复以苦义习义行百千定。若欲得佛心定意三昧者。不以色想亦不以种好。亦复不以本宿行故而致一住。亦不希望作是致是不作是亦不获。是常建是志不念过去。当来之着。亦复不念今现在世生死所趣。不从五阴六衰而克此法。亦不离五阴六衰。复当思惟六无根本。六无根本者。眼耳鼻口身意。从所起生从所起灭。复当分别六衰所兴。了知寻察色声香味细滑之法。亦复不用见闻念知心意识法。得净一住。不以巧伪生灭之法有常之想。净于一地。无正无邪不造等意无所希望。亦不是是亦不非非。而净住地。亦不从一二三四至百千定。亦复不离百千定意而净住地。不因心意而晓内外众念望想是非之事。亦不色痛想行识而净其地。亦不用戒闻定意慧解度知见。十力无所护四无所畏。诸佛所宝十八法本。不可以意想知见我想无我想。不以五阴六衰生灭之处。亦无所住亦无不住。是谓菩萨净一住地。亦无色痛想行识之屋室。亦不眼色耳声鼻香舌味身细滑之处所。何以故。不可目视而见众想。解不起不灭之法无终无始。是谓菩萨于初地中而净其迹。悉具足成道慧。备满如来所宣无有差别。若干之念便能解畅。亦能为人启受讽诵。普能周悉诸佛深藏。佛复告最胜。菩萨复当具足六度无极。念舍形色无所希望。不生三念染着之法。是则名曰施度无极。欲知根源不念佛身达了本无。当知以备戒度无极。不自想念我得成就三十二相。计挍诸法假号名句。相貌无尽住不起法。是故名之忍度无极。一切诸法普无观行。亦无闻见行道士法。见善不悦逢恶不戚意无适莫。是故名曰进度无极。心不兴念起于乱想。寂怕自守意识永定。是故名曰禅度无极。解色相空败毁色空。亦不自高不怀自大。诸法之相达知为一亦非有一。是故名曰智度无极。复以权道应适众生。随缘拔济使不漏失。是故最胜。发意菩萨以苦圣智治初地行。便能具足诸三昧门陀邻尼门智慧自在。复次菩萨得是十千三昧住于欲界。当以苦智等智果报。分别十法欲恚慢痴狐疑身见耶见内见戒见盗见法。已知已了不除不尽亦不令生。复以苦智等智。于有形无形晓了十八结母。虽分别结不尽不赐。最胜当知。初学发意。复以习义等义。于三昧定。住于欲界形无形界。思惟十九怨对之灾疮痍之患。渗漏无首尽灭等义。复于三界观察十九迷误之法。道在三处有二十二。亦当思惟三十四无漏圣意具诸功德悉为成办。观于无常苦空非身解知无二。乃于一地而净其迹也

    留化品第二

尔时最胜菩萨前白佛言。云何菩萨于二住地而具足行。必果所愿无有中错。佛告最胜。菩萨于二地中常当思惟。念净其戒识其重恩。勤行忍辱谦恭卑下。常怀喜悦先笑后言。行大慈悲孝顺师长。笃信三宝崇习妙慧。无生染着计有常存。夫计常者。谓生死业解有道常。常道非尊尊出非常乃谓为尊。尊既无尊何言道尊。是故最胜。菩萨了道亦无尊卑亦无相像。虚空犹常言有形质。真道号字不可睹见。其心坦然无所缚着。所修德业不离诸佛。无能中道而得断绝。一切诸恶悉尽无余。其心永定不可动转。志如金刚亦无伴侣。皆知一切诸法之本。已除众垢消灭闇冥。其法晃曜靡不照明。心怀质直亦无谀谄。性行平等无彼此意。发心已来常怀鲜洁。由本净故得去诸垢。沐浴清渊荡除众秽。其信坚固无所遗舍。施意广大无有边崖。心若虚空亦无穷尽。含受下劣将养使度。所以然者。其慧纯淑无所挂碍。心之所规无所不容。大慈无穷不尽之藏。得识辩才常怀羞耻。坚固之行心不可沮。觉道之力无所不入。辩才过众无不渴仰。得诸总持亦不忘失。初不演说不急之事。于百千定终不狐疑。闻善恶法不怀忧喜。不自贡高复不自下。进趣安详不失威仪。十二行本晓知五阴。六衰所起复以苦习尽道。分别十二缘起。痴行生死靡不贯达。观察五根具满思念。不复往来生死秽着。乃以八十四智消灭诸漏。誓留化身一劫教授。如我今身必当入于无余泥洹。不永灭度亦复留化。在贤明土将无数众。前后围绕说微妙法。最胜当知。贤明去此北方度十三亿恒河沙等诸佛刹土。彼有世界名不动转。有佛号照意如来至真等正觉。现在说法不动转界。亦无声闻缘觉之名。纯诸登位大乘行人。布施戒忍精进禅定。以神通慧而自娱乐。无极之智缠络其身。随时分别章句深妙。慈悲喜护等如虚空。观前众生知其志性。为雨甘露无极法味。其服食者无嗔恨结。行三三昧空无想愿。拔济生死立无为岸。降魔尘劳怀害之毒。彼佛神足感动变化。周旋往反无量佛土。彼受训者。不知是化谓为真佛。过去恒沙诸佛世尊。皆留化佛。接缘众生使获无为是故如来隐形适化不可思议。方将来佛慈氏等辈。亦各有化如来之像开导众生。我虽灭度彼化佛身亦不灭度。是故最胜。化亦无化佛亦无佛解知空寂。亦不二三若干之相。二地菩萨。常当修习幻化之法。观了慧地诚信之地。见地薄地终成之地。缘觉声闻所居之地。虽疗其疾不取其证。假使最胜二住菩萨。欲取声闻缘觉证者甚无有难。譬如有人手执华鬘及明月珠。仰掷虚空未堕地顷。于其中间断结除垢诸漏永灭。无生老死忧患之苦。但为菩萨虽知断结终不取证。所以然者。未察众生上中下意。坚固其心永处究竟。兴无盖云击慧雷声。降甘露药宣真谛宝。不断三业。意念鲜洁如水清彻。恒用禁戒而自庄严。复以众德修饰形相。奉遵上妙贤圣觉道。至后胎分一生补处。觉现诸佛所造本业。觉意总持悉无处所。先念兴意严净道场。随时进止行安般念。在众强志御无所畏。心便勇健而得自在。发心愿成甚可爱敬。为诸众生说喜乐法。其心特尊与众超异。若能执持空无之相。外道奇术无奈之何。声闻缘觉常所宗敬。是时世尊复告最胜。二地菩萨达知本无远离身行。去口殃祸除意乱念。消灭三秽抑制三灾。阉塞五弊推寻十二痴行之本。上下五结散在三界。以渐除却无令增多。思惟十一苦恼之疮。舍诸四大耽着之病。分别诸物恶露之法。当避家业息诸习俗。断其爱欲嗔恚贪垢。净刈根本不使流驰。常念思惟计无我想。坚立四信。住四意止。成四意断称说五根。布现五力无缺减志。晓知七觉诸宝之藏。修行八正贤圣之道。八大人念初不废舍。如是最胜。二地菩萨执心调意。不若干念解知悉空而无真实。乃得上位受菩萨记。不动劳行亦不离行。学于上智虽有尊贵意不贡高。观知诸法一法不二不计三想。亦复不兴无益之想。不有限际有无之想。了想无处不住无处。惟正觉净诸佛亦净。善御于心正住不邪。等一善恶审知俱空空不疑碍。亦复不见有争无争有观无观。本无为一亦不见一。知一除一不住于一。复不从一而起众想。等习胜意无习。有际不见有际有胜有负。不听心散越内外法。善防御识定而不转。虽在三有不着于三。深察诸性了知无根。知无根者所谓净地二住菩萨。自整其心观诸法本悉同无常。常无所入不见出生。无善不善好恶之名利衰毁誉称讥苦乐。调正心意无有忧戚。在所入处开示大藏。入大法海念求七慧。煎熬三爱善制四流。修六重法成果证行。如是最胜。菩萨大士具诸法已。知无形貌而不可见。是谓习学净于二地

    空观品第三

尔时最胜菩萨复白佛言。云何菩萨于三地中当净其行

世尊告曰。进学菩萨无出入念。虽多学问义无厌足。不入文句字体本末。分流法施谦下于人。修治国土无国土想。建立善业亦不贡高。初发心行无令有断。成功德愿志如安明。观诸众生说喜乐法。从初发意以为道本。由是得至永寂道果。心念广施遍及一切。建立志愿具足禁戒。开意精进行无懈怠。无所喜乐。惟道为务。无归趣者与作将导。因为分别大智之法。从初立心永无所住。用极大慈不可见故。欲拔根原立大乘迹。当行悲哀愍其未度。设见度者当怀悦豫。于诸众生平等其心。虽遇苦乐亦不为动。将护一切引入道门。为诸如来所见扶持。念顺十方诸佛教诫。当度一切五趣之难。兴隆道化无损三宝。无所违失便成道果。将顺禁戒为众人则。畅演智慧无穷之宝。犹如虚空不可穷尽。其一切智亦不可尽。如来心识亦复如是。无有生灭着断之二。定意三昧智慧解脱。度知见身无有近远亦不可见。最胜当知。一切诸佛深法之要。亦不可尽亦无端绪。去来现在三世合散。亦无所有不见有集。有所成办复无散落。变易非一四大所造。地水火风亦无有对而不可见。用智了别众生心行。本愿不断不可思议。皆无所生亦无仿佛。一切诸法寻不可知。以是之故故无所生。亦复无法可有生者。生已无生何者是生。是故最胜。发菩萨心而无穷尽。不设心意形相诸法。复无谀谄侥望诸法。其心质直在众殊特。修息心法自观身法。观他人身皆悉空寂不生想念。观身无染而不可得。亦无授者分别为一。行步进止探察三界受形之类。皆由痴爱遭诸苦恼。了知无二而不可见。痛意行法内外虚空无有生灭。复次最胜。进学菩萨观息出入长短迟疾。身中毛孔气息所经靡不了达。出气为温还报为冷。解知寂寞都无形质。菩萨观身分别识知亦无处所。用清净故平正无邪。柔软其心不怀粗穬。笃信真要未曾变改。志常坚强而无动转。无能憎嫉而娆害者。何以故。尔以其行际不可逮。及有所建立无能诽谤。何敢兴造无根无罪心垢为消。愿令法轮常转于世。使一切人疾得妙慧。光照幽冥如日贯云。立道善本自观无我。生无处所于内外法俱亦如是。亦复不见生死所趣起灭之处。乃至罗汉缘觉及佛皆无见闻。有想见者为非见也。无所想见一切清净。不止净想乃为非想。是为空见为无所见。复次最胜。心不在内亦不处外。不于道法不住于俗。亦不住有亦不住无。不见起灭动摇之处。心无崖畔广普无底。亦无音响本末悉尽。如是最胜当作是观观无所观。当作是见见无所见。习行菩萨为空为灭为无所有。三住菩萨以诸法定。使意专精计念成净。作是计者为应泥洹应无所生。是法无法无亦无无。强为生名字为法性。晓了法性无来往缘。习意断法哀世现名。恶法未生精进御止摄使不起。以兴恶者御意令断。未生善法精勤使生。已生增多不使漏失。三住菩萨行神足定。得乐喜定止所作行。总其神足持身心意。以精勤定除所作恶。复总神足摄持身心。复以意定除其所作。统摄神足持于身心。以智慧定除诸所作。统其神足亦持身心。渐进修根信精进根。意定慧根便得入要。佛法空尽无彼无我。亦无因缘复无缠缚。贪有计常生死苦断。一切无迹人多相猗。见着性名于无数世。当复精行忧恼相随。如影随形往来不停。如轮在辙莫知端绪。行定无猗正观不着。贪尽想灭结解清净。于行不惑意无忧恼。生老病断无复往来。慧眼大明普照世人。拔十二缘无黠慧惑。复次最胜。菩萨大士复当修行神力之德。夫神力者莫能沮坏天魔外道威力之神无侵暴者。信力精进意定慧力。是谓菩萨每修行者。遂应渐进七觉意华。以意觉花行十五心。断悭吝心履菩萨迹。成深妙慧而不退转。法觉意花无为无作。除去秽恶不善之行。精进觉华合受戒慢。有放逸者抑使不起。欢悦觉花应三禅地。摄诸乱想寂怕无为。猗觉意花无所贪着。观了诸法亦无所习。以信觉花其志牢固。畅说微妙而无悔恨。亦当思惟无著觉花。断百八瑕染着心者。复当修习八贤圣道。等念等定等语等行等业习等意等定。超过八难越度六衰。亦复分别三三昧法。具此行已乃得称为净三住地。如是最胜。菩萨大士习行慧门。校计空无不可得睹。无有形想相亦无相。与人说法恒用中正所言至诚终无有异设有所与无所希望。不求名称为人所叹。咸共戴奉兴致供养。有所造作不自为己。先求彼安后乃恤己。所以自致获安隐者。所施功德不怀懈惓。有所施为苦无厌足。用愍一切众生故也。用无极慈拔济老死。为懈惓者而兴精进。所以勇猛兴精进者。欲以养育众生之类。常当自念我由众生得办道果。诸功德业亦复具足。所可陈力不希望报。所以然者。以心净故蒙法润泽。是故无求世人有求为除利求。以是慧力护一切法。愿令群黎各宁其所。使上中下悉无怨恨。所作事业安隐审谛。由是菩萨无能制者。亦复无能抑断之者。如是最胜。菩萨宿誓弘普难量。其慧无边不可穷极。犹若天金而无点污。所以然者。用无瑕秽。消荡尘盖永无贪欲。其诸恶心不能复乱。又其意猛不为恶屈。守护邪念亦不使生嗔恚愚痴所有贪着。汲汲五欲贡高自大。诸所不可皆悉除尽。三住菩萨常护是心。晓了内法而不可见亦无形相。假使有相则毁法性。捐舍重担及诸垢浊。当建是心不令懈怠。寻其心识悉无处所。而不可见无若干想。有愦乱者护使定意。无智慧者育养成办。计于一切受形之分有功德者无功德者。悉欲度脱至于大乘。思念大乘亦不有迹。训诲一切履行法者。毕志坚固净于三地成于道果。诸在厄难皆令建立无极功德。虽获其报知无所有。心亦如是永不可见。所以然者。用慧观知无去来今。如是最胜。菩萨常学修于大慈。若有苦难自投归命。欲求救济全身命者。宁丧躯体愿受苦恼。先度前急不负要誓。其行慈者平等如称。若有增益不以喜悦。设毁谤者不怀忧戚是为菩萨随时行慈。夫行慈者。常以三事净身口意。终不传恶亦不念邪。虽在愚痴尘劳之间。独步无畏亦不自大。所学之法不舍普智。诸神通慧揽诸佛法。随人所求不逆其心

尔时世尊复告最胜。昔我游学净三住结。功齐德整共同友者不可称计。其中退转在吾后者不可陈说。吾从一住至于三住。建立弘誓心不移转。于其中间所作功德亦不可量且舍珍宝奇异妙物国财妻子不在其例。但念愿施与其前人九千九百九十九头。最后遇虎饥羸穷急。伺捕群兽竟不克获。便欲啖子以全其命。舒身张爪前欲搏撮。吾与慈氏柔顺为伴。顾谓二人今正是时。谁能建心勇猛特出。以身自投施彼饿兽。二人各自还相视面。口虽不言心怀退转。吾寻观知彼有悔意。即于山顶投于深谷。首陀会天寻下接持。即化甘露状似吾身。飤彼饿虎使得满足。母子俱全吾亦不损。思计彼身乃充万头。是故最胜。进学菩萨修成三地。亦有悔还心不坚固。正使我身入虎口者。虎亦不食亦不亲近。所以然者。由其立根得神力故。于一切法而得自在。当习悔过未曾藏匿。用无量施劝助功德。菩萨修学班宣道义奉习勤学。大士之法其意牢固不舍弘誓。无极德铠用自缠络。佛复告最胜。进学菩萨修治三地。常当专心无令变异。不以所见为动众心。于诸烦劳恒知远离。于己止足无有侥幸。不于想着心不流驰。不求荣冀尊豪高位。令一切人如法习法。宣开上智使同其原。彼我为一然无差别。随其因缘而示现之。当不以生非不有生无生不生乃净其地以为不惑终不以惑。惑出尘劳乃谓为惑。惑不见惑无惑不惑。深知眩惑乃应真空。如是最胜。菩萨之行分别空无引致入法。具在苦痛皆令普安。是谓最胜。进学菩萨于三住地而净其行

    色入品第四

是时最胜菩萨前白佛言。何谓生贵菩萨于四地中而净其行

佛告最胜。生贵菩萨于四地中。常当不舍奉真人法。念在闲静不离燕坐。于淫怒痴恒以少欲。意趣知足亦不贪着。不舍苦行十二法要。执持禁戒如防蚖蛇。见欲秽恶如被火燃。除爱欲意亦不使生。兴意视众如泥洹想。惠施所有不惜身命。不怀慢惰于众贡高。不慕所有亦无三碍。修行开士心识之法。于大众中念行法施。训诲众生果其所愿。积功累德为无上道。习在闲居山岩独处。所有多少取足而已。行诸德业而无厌足。博学多知咨受不惓。所演智慧不以为劳。挍计身中思惟本末。智虑通达所念具足。离于众恶修行脱门。其解脱者是菩萨教。了诸法本思惟微妙。当别五阴成败之相。观知四大地水火风。睹见六衰所起根本。十二因缘深无边际。生死变易不可穷尽。苦言忠谏念持不忘。不计我人寿命长短。寂寞无为行非常业。解知一切虚而不实。复次最胜。四住菩萨当护佛土。分别道俗悉不可见。菩萨之行智不可穷。办一切德修治国土。随其次第成就处所。慧海无边所受无厌。多所救度一切众生。其所修行常为先首。最尊最上无能及逮。所念总持强记不忘。各获善本令不缺漏。所以然者。用尊贵法得远缘缚。因斯受决入正士室。亦因专勤意不退转。自致具足无上圣业。所愿辄成亦不见成。若见成者则为非成。其所修行永无所见。行其定意摄揽诸法。所为之行无令有短。制伏心意是其道业。修行自守无若干想。所以者何。乃离诸恶不与从事。专精行施良祐福田。菩萨发心于一切众生。不以身心有所贪爱。转增上妙无极之哀。专精奉戒如护双目。教犯戒者使不为恶。亦当专精修行忍辱。夫行忍者亦为甚难。虽在尊位财富极乐。不轻贫贱羸瘦之人。如是最胜。忍辱为难。勤加精进亦不可及。坐佛树下正身正意。结跏趺坐亦不动转。若有人来言避吾处。我欲坐此当建牢固勿为彼伏。先取佛道具诸相好。降伏魔已即舍与处。是谓精进为难得及。专心定意亦复难及。生贵菩萨入定意时。天雷霹雳万响俱震。欲得动乱菩萨心者。不能转乱如毛发许。是谓最胜菩萨定意。故曰难也。菩萨以慧修诸功德。不以怀劳于诸众生。出入行步和雅安详。威仪备悉法服齐整。是谓菩萨修其智慧功德坚强无能危者。晓知本无钩玄致远。博览微妙其明极照无所不达。专精其心无有流驰。常念一切无所依者。为设方便令得其依。有闇冥者使睹大明。无所归者为受其归。处卑贱中与作善友。行奸伪者教修质朴。见强梁者为是忍辱。于饰好中不为绮雅。见无反复教使报恩。处在天宫令行十善。在懈退处修奉业德。设见贡高不怀自大。有求其便不能得短不思念恶不说缺漏。若在邪业辄住将护使入安谛。众生之类来到其所。欢喜承受无嗔恚心。有谏喻者示进退法。此当应尔此不应尔。可然不然心无增减。笃信罪福知有报对。设在城郭游近人间。如在旷野岩居不异。不贪利业不惜身命。心怀清净无是非意。常护口过言无彼此。不求供养望其奉敬。明知节限止足而已。心常柔和不由弊恶。度于生死息诸患苦。由是永致成大乘迹菩萨慧心亦不可见。生死往返亦无所有。以权方便明了训诲。随时适化断于终始。终始无来亦无去者。解知悉空而无处所。菩萨计有便为著有。于布施中亦计无有。亦无所有复不可见。所以者何。六度无极复不可见亦无所有。如是最胜。菩萨布施悉无科限。有科限者则非真施。设当选择当施与是不应施是。分别高下意生是非。施不周普不应为施。若能惠施不生染着。无种种念乃谓为施。受施之主得全其命。便能安隐坐起诵习。身体得定气力强盛。周旋生死常不渴乏。所生之处神足飞行。在所到方为人所敬。得神通眼见十方国。耳听远闻无极音声。逮致妙香戒定慧解度知见身。为被种种德勋之音。身体香洁莫不悦豫。常得肴馔甘美之味。宿福所殖而致奇相。清净无垢为人所护。随其所乏而施与之。身常无病不生不死无有众患。恒获安隐一切具足。备悉成就三十有二大人之相。得八十种众好之容。敷开法藏不生贪欲。充备道慧无所匮乏。有来求索而不爱惜。辄能尽施逮一切智。诸通圣慧广济无穷。得深经典乐法之乐。于佛树下坐于道场。降伏魔兵及诸官属。不以色故有所施为。知色为空色亦自空。色不自知乃知色空。如是最胜。菩萨解知色性空者。便为一切道法之首。成就法眼为一切道。三世特尊独步无侣。斯由具足诸通慧故。佛复告最胜。生贵菩萨终不信邪颠倒之法。若见众生各有所奉。祠祀求福心不动转。以食向口见有生类。正立无上独尊之行。终不动转舍就小道。知是深法无与等者。勤心进业亦无他想。虽有他法杂异之仪。常以法性观了别知。虽共周旋意终不转就于他道。正使遭世有佛出世及般泥洹。遗法教授复遇灭尽。圣众游化又值中断。心常一定亦不变改。虽无三宝不随邪念。恒习深妙无量经文。用十二部遍见一切。善权方便无所不入。不贪名誉现身变化不自称誉。如是最胜。生贵菩萨执行正见知空不真。无正不正正无所有。明解此者是谓正道。复次最胜。菩萨大士修习智慧分别有无。晓知真空亦无所著。复当修行诸慧句义亦无所有。苦谛灭苦习结已断。尽断爱习道果受证。等智照察息淫怒痴。法智除垢达上中下。以远思智上观二界。知他心智普了众生。心中所念无生智者。不受生死胎分之秽。行灭尽智晓断五阴生灭端绪。思惟三根所应行本。未知已知无知之根。至竟成道当学斯根。从三白衣至须陀洹。修未知根从斯陀含至阿那含。学已知根从阿罗汉至成作佛。学无知根复当习定观了禅智初禅总摄有觉有观。次禅中间无觉有观。后从二禅至无想定。无觉无观其心寂灭亦无动摇。常念笃信入于正定。如是最胜。菩萨昼夜不作是念。吾知奉戒真人之处。亦知无戒行恶之人。无有异心分别之意。悉知虚寂无有一二前后中间乱念之想。菩萨精勤念不离佛法及圣众。戒施天念安般休息。身苦死念亦知无处。思除五结敬六重法。行四神足育养大众。端心正意奋振无畏。设有沙门外道异学。或天梵魔及余众辈。亦无有难诘问之者。不见若干起吾我想。以是之证行常安隐亦无所畏。得精进力立第一处。在诸大众而师子吼转大法轮。沙门净志梵释魔众一切外道所不能转。唯佛能转。如来身者金刚所成。诸漏已尽而无尘埃。正使恒沙亿垓众生。无敢言佛诸漏未尽。如来所说言真无二。善恶之报不失本愿。一切余众离内法者。不见敢能违佛言教。所说贤圣至道之要。行是得道犯恶入罪。亦无有能非如来教。亦不见教有所出处。无教不教教无所有。深知教诫是谓真道如是最胜。生贵菩萨求成佛道行无缺漏。欲听法者舍诸不要先说微妙。使获所起悉遍志愿各得具足。若有所施不恐怖处。心未曾变无有狐疑。不别好丑兴二见心。亦不思惟善恶差别。所行法性亦无希望。菩萨不念受其功报。普为一切有形之类。不习声闻缘觉之心。亦不生念有所成办令一切众不离佛藏。知一切空佛法亦空。以因缘想有所兴发。由斯观察而不可见。亦无形质言有形者则毁法相。相亦无相相不自生。生无根芽何由有相。相一无形而不可见。是谓正真无上之道。如是最胜。生贵菩萨于四住地。净修其行不离诸佛神通之慧。有所施为应适前人。所说辄成无有不应。从佛法教不舍本誓。其心坚强完具甚安。所可施为皆达无愿。为诸愿者作善因缘。其在三界无能逮者。愿令其德周遍一切菩萨之业其志常定。一切智心无所不入。以是之故名曰空寂。所作施与过诸想着。降伏众魔令不自在。如是最胜。生贵菩萨常念修四无所碍慧。于真谛法亦无所碍。于圣要义慧无所碍。于辩才智慧无所碍。所说明达慧无所碍。是谓菩萨行无碍智与众超异决断心疑得至无为。及无央数不可称计众生之类。普使济度永处安宁。除计常想思惟无常。便断欲爱形无形爱。无明憍慢消尽不生。先除身贪无令生想。此五阴身漏结不净。眼如水泡亦不牢固。幻伪不真或世愚士染着不惓。眼耳鼻口身意之法。斯亦无常而不可见。无形无主永无名号。当熟观色色非我有亦非我造。乃从无有而生此有。以有形色便有识神。以有识神便生五阴。以生五阴便染六情。以染六情乃有痴行。至老病死忧苦万端。往来周旋宛转三界。流趣五道无有穷已。斯由合会因缘所成。因是有是无是则无。此起则起此灭则灭。眼耳鼻口身意之法。亦复如是。皆悉虚寂而无形质。智者达了本末皆空。何用疲劳困苦识神。如是最胜。生贵菩萨去离色想心不染污。解知本末而无所有。亦不见成复不见败。诸法之本寂寞空无。无能动转超越其上。况复过者此则不然。学一切智广布其义。悉了诸法空而不真。是故最胜。当勤习学学无所学。当作是行行无所行。生贵菩萨于四住中而净其地

十住断结经卷第一十住断结经卷第二

        姚秦凉州沙门竺佛念译

    了空品第五

尔时最胜菩萨复白佛言。云何修成菩萨于五住中当净其地。佛告最胜。修成大士常当远离居家财业。亦莫亲近频头弥淫材。修善功德念除憎嫉。远离俗会世间因缘。当念和合远离忿诤。言当护口无乱彼此。常当自卑不怀贡高。虽多伎术不轻篾人。断除无明消灭五阴。息老病死诸所作为。不兴尘劳亦复不与六十二见而共和同。不自称誉亦不自卑。过世八事无有高下。常知恭顺去诸苦恼。不行痴冥觉寤眠睡。度诸恐惧不与罪俱及诸心垢断。于五阴乃至生死身魔罪魔死魔天魔。思惟抑制不造彼缘。如所闻慧辄能建立。应如斯行而无所有。谛入慧意学无厌足。无所贪慕亦无适莫。欢喜启受心怀悦豫。身轻志定其意和雅而无烦愦。所学法本说法无穷。心常趣道禁法自守。好从正真不处邪部。唯好妙慧分别种种诸度无极。逮得菩萨大乘经籍。善权方便随前应适。心复察解了无神通。常欲听闻无生灭法。了十二缘达知无常。畅演苦谛亦无吾我。解知空定分别无想。深体无愿晓生死苦。成就功德所闻勤执。贪慕三宝亦欲知俗复知道法。忠心附近以为伴侣。普入诸法欲除贫匮。甘受正道其无智者化令成就同功勋业。明识其本念避众恶。约身智达兼利众生。处安隐行亦不怀恨。欲了最妙无极之行。复次最胜。修成菩萨念诸佛法。云何得成无上道要。如所闻慧便能成办。所入随时亦不越次。听彼音响然后调正。深入于观知心所行。御身求度而济众生。不计无常亦无所著。探察因缘所可施设。我人寿命去来现在。成功德业分别禅定。空无想愿护已自守。不随贪欲游于三昧而修正受。如是最胜。修成菩萨入百千定不以为难。菩萨同处靡所不到。唯不愿生无色天上及光音天。亦不永入灭尽定中。悉知本际思惟执持。亦了本无而不取证。所以然者。皆由众生垢未除故。知其众生解无吾我。习行大慈不舍悲哀。普入一切生死之难。远离贪着诸所荣冀。教诸犯法亦不为非。行权方便教化无方。随前众生心在爱欲。使观恶露修不净行。然后菩萨乃取尽证。虽现灭度亦不永灭。修成菩萨。所度无穷亦不可尽。各得其所使心无恨。不失威仪礼节之禁。出入安祥无有卒暴。夫欲无诤莫若自守。贤圣默然唯当寂静而无言说。夫无言者。乃谓清净虚无澹然。亦无方圆科限之异。贤圣默然者。自护身口心观。说者勿与同处。身欲不动心无变易。亦无希望复无所想。是谓修成大士之行。欲不色惑当正其心。以正其心。便为达至永寂无为。若不寂静将养已者。无得自称亦莫不仁。无高下者可谓顺法。所为不失亦无所失。解本无空便无所得失。等观三世亦无差特。眼色及识无所止住。耳声识鼻香识舌味识身细滑识意法识悉无有主。亦无所住亦无吾我。观诸法行悉无我所。我者变易从本净故。如尔审谛知无吾我。无吾我者是谓为慧。明了所有如无所有。亦悉空寂。本末清净。心常不离诸法之本。思惟远离九众生居。所以然者。轮转没溺周回驰趣。不免九处众生之类。身异想异诸天及人。复次最胜。或有众生身非一种成就一想。谓梵身天。最初出现降形世间。贪着甘味渐失天威。复有众生一身不异有若干想。谓光音天。功德仪容威神殊特。或有众生一身一想。谓遍净天。进趣宜则唯行极妙。复有众生意至无量虚空之念。心不著有亦不趣灭。是则名曰空入天也。复有众生。意系识想遗去形体。不复役思有希望求。斯则名曰识入天也。复有众生无所贪求。消除是非内心充足。于诸味着无所兴想。是亦名曰不用入天。复有众生建立弘誓求于无为。观无色界而无形质。谓为泥洹无为无作亦无造者。精其志愿会得生彼。寿八万四千。劫数之期竟彼寿已。神当迁转趣于五道。应所生处中阴便往。迎其魂神将诣胎室。然后乃知非真灭度。痴心隆盛便兴恚怒。心念口发种罪深殃。背圣言教虚辞不真。诳惑世人权诈不实。乃从久远经历苦行停至泥洹必然无疑。我今云何更涉生死。吾今乃信知无泥洹。亦无神通得道之人。思念之顷神趣恶道。斯由诽谤贤圣之人。如是最胜。修成菩萨欲成无上正真之道等正觉者。常当思惟心念去离九众生居。一切众生我人寿命无所希望。所作因缘皆悉避之。亦莫思惟俗间之念。消除一切众念之想。修成菩萨。复于十五殊特之心。向法次法进成其道。从第一法入苦法忍。增于善根同无漏行。从于五住至得如来。悉具善根思惟欲爱。五住菩萨断除欲爱。灭不善根住于欲界。执忍苦慧思惟苦本。无形界中无色之身。不得思惟苦之无本。是故菩萨不于无形除欲界法。增不善根有九十事。无漏慧药亦有九十。以十要法。对不善根及欲界淫微细之垢。余八十法。断除八十不善根本。虽非斯尽转转使微。尽道圣谛亦有无漏合法。亦有有漏合法。修成菩萨于五住中唯断有漏合法。不断无漏合法。于有为性亦有合法。于无为性亦有合法。尔时菩萨唯断有为未除无为相应合法。如是最胜。修成菩萨复当修行五分法性。思惟分别了知无二。戒身护命清净无贪。瑕秽已除众定已成。是谓最胜名曰定身。分别诸观无若干想。亦复不起想着之念。解了无一故曰慧身。三世解脱无所沾污。亦不恐畏怀退转心。是谓名曰解脱之身。已能成办第九解脱。故曰解脱知见之身。有为缘者是解脱身。无为缘者解脱见慧身。有漏无漏亦复如是。是谓最胜修成菩萨便能习学色缘尽法。未能断除非色缘尽。云何菩萨色缘尽法非色缘尽。色缘尽者。若眼见色便生眼识。分别是非善恶之法。兴意染着终已不离。修成菩萨便当执智御使不生。除去秽恶不净之行。非色缘尽非智所及。不生眼识分别是非善恶之行。所以然者。非彼境界之所摄持。今当引喻用自觉寤。大智之人以譬得解。犹如有人疲极睡眠。神识安静形不动摇。无触扰者。目不见色识不流驰。不兴想念。眼既内存外色游逸。当时澹然目不加功识不散落。应现之色忽然便过。亦不停住有所滞碍。所以者何。用无所有性自空故。如是最胜。修成菩萨常当思惟分别妙观。断除非色缘尽之法。亦不与俱复不施设。当学了知非色缘尽。非有非无亦无成败。复当修行贤圣八正除于八邪。成就三昧百千定意。五邪心法三邪非心见。念定方便斯在诸地。初禅以还便有邪志。邪见颠倒不在六识四邪尽在六识身中。共相连缀。不相去离。所以邪见不通识者。五识虽决无方便力。意识慧了有方便力。中禅以上亦无邪志。但有邪见与三十六法共相受。入初禅以还唯有邪志。与十八法而相受。入五识阴中。虽有邪志自不相知。中间禅内虽有邪见自不相应。发意菩萨至于四住。行于苦智忍辱之慧。消灭邪见远离邪志。修成菩萨进向六住行玄通智。断三界缘乃应真际。先当精勤断于奔逸殃祸之病。愚痴犹豫兴造五邪。遍布三界无空缺处。十八结本生八百法。有苦无习亦与相应。有习无苦亦与相应。痴爱同空而共相生。于苦门中无明结除。习谛无明而不消尽。还生于苦爱亦不除。坐佛树下决众疑心。正住佛道不怀异意。得成正觉无上道时。与无央数不可称计众生之类普使济度。解知缘着诸起灭法。斯亦空寂而不可见。五住菩萨得非色缘尽空性法时。诸尘垢病亦皆消灭。常以五法制御爱着。通六识病普在三界。拔其根本使不增长。嗔恚五药具六识身。不及上流独在斯界。慢有五法。一意识身。而在三处根深难动。邪见四药一意识身。亦在三处往来不息。愿疑四行及意识身。复在三处悭嫉思惟。不在三处睡眠觉寤。当念远离不与杂错。去众烦恼不为痴冥。求脱恐惧不与同处。常念建立一切智心。随谛黠慧如审无碍。如无有吾则无有我。除去我见故曰苦慧习诸所有皆无所有。悉无本末亦无住处。不染爱着故曰习慧。解知习着为磨灭法。学正真要知无本际。悉为消灭故曰尽慧达照众心。朗如云消。玄通明彻无有尘垢。是谓最胜菩萨道慧便能观察为晓五阴。知四大本解六衰病。分别四谛畅十二缘。广演三世分别一切诸使所兴。晓了五阴诸所生灭。不见诸法有来往者有尘垢者。亦复不见有生老死。所以然者。由其本性不可得故。因缘以灭离诸着断。诸法垢尽无有挂碍。言教已定亦不动摇。犹如幻化梦中所见。芭蕉野马呼声之响。镜中之像水中泡沫。观于色相我人寿命。解色如是谛无所生。观了此法而悉清净。空无所有晓是五阴。我人寿命实如幻化。识亦无形而不可见。不见动转有其处所。复当晓了非常苦空非身之业。其知是者乃达五阴诸法慧义亦无起灭边际。所生地水火风不见增减。观于法界亦无刚柔。究寻水性则无有水有所润渍。思惟火界复不见热。了风境界不见施张有动摇者。分别四大不见有起生灭增减。便能晓知言数之慧。广慧深慧无比之慧。谓眼见色便生识想。以法界观亦无眼视悉知虚寂。复于法界观耳听声。亦复不见声所从来。恍惚自生而复自灭。鼻香舌味细滑意法。不着不断无有兴衰。悉具足观众生性行。志操不起皆悉平等。不可别离无若干想。空无有异亦不可量。泥洹法身等如虚空。法界真际斯同虚空。如是最胜。修成大士复观眼空而无吾我。非不有我我及无我是亦悉空。解我空者。在诸衰入不见端绪。谛计六衰不着不断。是谓菩萨于六衰法而无起灭。眼色为衰众乱之首。设能视而不转者。则六衰净而无瑕秽。成大果证无复忧畏。于衰不净则损道性。菩萨弘誓。行大慈悲普覆一切。为其受苦不以为痛。无有近远崄恐之难。要度众生而不乐道。劝行施德修善功德。是曰修成菩萨思惟观法。五阴六衰悉无处所。亦无形兆进止所趣。复以苦习尽道分别五阴。生者灭者有增有减而悉无形。生苦老苦病苦死苦。忧悲恼苦怨憎会苦。恩爱离苦所欲不得亦复是苦。取要言之。五盛阴苦是谓最胜。名曰知苦。寻察根原由苦枝傥所生为习。贪着爱欲。玩之宝之莫知为幻。知而远之故曰知习诸垢永除更不造新。愿欲毕故使不复生。色现寻灭不令停滞。了习常寂是谓知尽。解八正道亦无体性。亲疏近远住止之处。变化无穷而不可极。荡除尘秽照曜愚冥。无形无声存亡之体。为诸迷惑导引之首。入无为路故曰知道菩萨分别四谛亦不取证。欲护一切在生死者。真谛之相无相无形而不可见。审解如本则应法性。世俗言教假号有名。其实字体不生不灭。无所染着得圣谛心。不念有无审解本者。一切诸色普悉平等。亦无高下生若干心。是则名曰分别圣谛。菩萨圣谛其实有一而无有二。无著至真无所希望。亦不想求色亦不想求无色。于想无想平等无二。是则名曰真谛之相。已获审谛。如实谛相者。便能晓了五阴之相。五阴所生苦毒之相。是烦恼相。菩萨复当思惟灭于百千之苦。皆归空无磨灭之法。不起念故名曰苦谛。演畅五阴所出生处。除去爱着是曰习谛。若心流驰多诸想求。分别其意亦不贪慕。不与三世愚心同处。亦不住中而有侥幸。悉去尘劳是为尽谛。欲成无上正真道者。了苦习尽断邪疑心。如是最胜。修成菩萨于五住中当净其地

    根门品第六

尔时最胜菩萨复白佛言。云何上位菩萨于六住地而净其行。佛告最胜。上位菩萨常当修行六度无极。不慕所有成本果誓去声闻心。欲净国土无缘觉意。所为弘广不为小心。见乞索者先自除贪。寻赴前人使得饱满。所有珍奇殊妙之物。念先给人不怀悔意。远离吾我去计常心。其智无量亦无穷尽。愿欲听采深妙之法。净身口意不犯一切戒。常欲拥护诸持戒人。上位菩萨心恒慈仁。不怀伤害加于众生。身自不杀不教他杀。见有杀者劝使修善。不盗人物如毫厘许。设有犯者教令改悔。又常专心不犯淫泆。若见犯者使修净行。常行至诚初不两舌离别彼此。有诤讼者和解令散。忠言谏喻普令行善。终不骂詈使人恚怒。见嗔恚者念行忍辱。不为恶口有惭愧心。所言护口不妄言说。于一切人思惟平等。不念憎嫉除其憍慢。不生恚想向于众生。每自克责愿欲上及。今不行忍后致丑陋。常正其心不轻后学。怀抱悦心在道法者。其心清净无有尘劳。爱乐深妙无比之法。四无所畏降伏外学。使修净业能出其上。至心在道遵奉慈仁。若见沙门异学梵志。便能师事务令得所。所以然者。由成佛道成一切智。心常柔软不行卒暴。若见他非护己不为。初不漏失有非法行。亦无声闻缘觉之心。于诸所犯不见所犯。所生之处亦不愚闇。常行精勤不为懈怠。不与邪部而共周接。设见弊恶无返复者。不与从事言谈密款。奉戒完具未曾缺漏。近智慧人解深法者。亦不违远有疲厌意。笃信净戒所修真正。不为邪部之所染污。慎守其法如所应行。一切众生歌叹其德。掌护法律清净无瑕。所行坚固本心决了。无能说非言有瑕疪。所以然者。斯由行正不怀邪道。其戒完具不复迷惑。所演音响莫不宣闻。诸佛正觉之所扶持。任己娱乐亦无所求。常知止足无所贪慕。其心纯熟众恶已除。身意澹然无所欣乐。常好闲居无心亲近。在于乱愦具能分别备悉道法。不从外道有所咨受。谨慎威仪未曾失礼。不以好服而为绮雅。誓如本愿德无能逮。不以甘美而乱心意。己有道力制持德业。所修顺戒不妄调戏。天人卫护使成究竟。行慈普念众生之类。又修悲哀忍众尘劳。遵奉守护使不懈怠。行平等心善恶无二。为一切任荷负重担。常察观了不为损耗。不听心识驰骋众想。不念其恶不传人非。护一切意总摄牢固不兴其意。随所思惟念恒布施。养育一切众生之类。使行忍辱不起异心。志愿精进终不回转。禅思寂寞得安隐定。奉遵智慧博揽众义。所演如海亦无厌足。故修广闻学戒要法。随逐善友欲达诸法。常离恶师远诸邪学。夫邪学者非真正道。无猗身相贪著文饰。知诸万物皆归无常。其戒功德净如紫金。所施意净亦无悔恨。心意清净终无虚饰。所学微妙亦不烦愦。其意鲜明无有垢浊。本行清净心不焦燃虽在迷惑不随淫欲。意不怀乱常若一定。息诸结缚永无起灭。终不误失静寂通彻。戒具不缺无所漏失。随其本要亦不遗舍。诸佛定根而悉分别。用平等心度诸众生。从一切智入解脱门。游诸三昧悉现在前。不贪身命不有一切乱想之念。不计我人寿命之着。亦不思惟名色痛想行识。不猗身口四大造色。其真谛想实解如本。分别造色一无有二。复当思惟眼色耳声鼻香舌味身更心法。普皆清净一相无相而不迷荒。谛观诸法以过空行。无想无愿亦无形像。度于三界不染不着。无解不解亦无系缚。复不生念亦不见生。所以然者。一切诸法都无所生。常当慈愍不念杀盗。育养一切欲令生活。亦不妄取他人财宝好喜恩施。不念邪淫远离于色。初无欺诈谤谗于人。所说忠信受人善谏心不迷荒。见诸耆年恒念尊敬。所游之方加以仁心。各使得所不令有恨。宽弘包容示以正教。念以平等应于律法。一切之类亦无抂愠。众行以备无所复进。演说究竟度诸众生。广为一切发去覆盖。上位菩萨法之大主。普演三乘无极之训。德过须弥慧超江海。道踰虚空无以为譬。最胜当知。用一切人愚痴懈怠放逸迷惑不顺法教。复当迳历涉生死苦。退废迷荒缠绵阴盖不免三趣。是故如来愍诸不及。为遵一切诸法之本。悉为一法断诸习着。二十二病更乐之本。此诸法者。亦无有法亦无非法。亦无言教都无所说。所以然者。其无法者。则无所生亦无所灭。为人说法不见所说。如是最胜。上位菩萨分别思惟更乐所起更乐所灭。菩萨观彼有对更乐。与六更乐而为根本。亦当知之。不为六根本。亦当知之。与七更乐共相受入。复次菩萨思惟观了广语更乐。与三更乐而作根本。枝流七更少有其分。复次最胜。菩萨当复思惟明更乐自相应时。于余四更共相受入。亦当思惟不兴染着。复次菩萨无明更乐与三更乐自相应时。复与十一更乐少有其分。亦当思惟不兴染着。复次最胜。非明非无明更乐自相应时。余十一更乐少有其分。复次菩萨爱欲更乐自相应时。十一更乐少有其分。假使恚怒更乐自相摄持。十一更乐少有其分。复次乐痛更乐复与十二更乐少有其分。苦痛更乐十一更乐少有其分。无苦无乐痛更乐。亦与十三更乐少有其分。复次菩萨眼识更乐自相应时。与八更乐少有其分。耳鼻舌身亦如眼更而无有异。色想更乐与五更乐为体。便与七更共相牵连。若复声更与三更乐为体。尔时便与十一更乐而共相连。若使香更与二更乐为体。尔时便与九更而共相连。或时味更与四更为体。是时便与十一更而相牵连。若使细滑与三更为体。便与十三更共相牵连。或时法更与二十二更共相为体。尔时与一切诸更而相牵连。上位菩萨常当思惟更乐兴衰起灭之处。一一分别令不增减。便能消灭诸尘欲结。以能灭结。心亦不着计常之想。亦复不见我人寿命生灭着断。如是最胜。六住菩萨以真谛心。不念有无审解空者。于诸更乐了别为一。菩萨当知。或时有对更乐与一根为体。是时别与八根相与牵连。上位菩萨复当思惟专意在前。一一分别心不染着。菩萨复当观察。广语更乐与五根为体。尔时别与八根共相牵连。亦当思惟竟不染着。菩萨复当思念明更乐与三更乐为体。尔时别与九根共相牵连。复次无明更乐自为体时。亦与六根共相连缀。非明非无明更乐自作体时。与十一根而共牵连。爱欲更乐亦与四根共相牵连。恚更乐复与四根共相牵连。乐痛更乐与二根为体。与九根共相牵连。苦痛更乐二根为体。复与六根共相牵连。无苦无乐痛更乐与一根为体。尔时复与无根共相牵连。复次菩萨眼更乐自为体时。与九根共相牵连。耳鼻舌身亦复如是。意更乐与五根为体。是时与八根共相牵连。色更乐与二根为体。便与五根共相牵连。声更乐与三根为体。尔时便与八根共相牵连。复次菩萨亦当思惟。香更乐与六更乐为体。尔时便与九根共相牵连。设味更乐与二根为体。是时便与十一根共相牵连。或时细滑更乐与一根为体。便与八根共相牵连。菩萨复当观知。法更乐与十九根为体。便与十三更乐共相牵连。假使菩萨思惟校计。除去贪着不造更乐。便能充满一切诸愿。以金色光相好严身。光曜普照靡不周遍。深解诸法悉为空寂。晓知法本亦无有法亦无非法。所以者何。其无法者。则无所生亦无所灭。而为说法不见所说。非真实法假号言耳。内有六受外有六入。五阴诸种及一切入。斯皆虚寂皆悉假号。分别章句及一切法。以真谛观亦无五阴。四大诸种及二十二更乐之本无有断灭。亦无是常非常。亦无坚固。是谓名曰诸法无言。一切诸法本末清净。皆空皆寂无有其名。一切法性及与名号。皆亦自然悉无所有。是诸佛教亦复如是。普当修习无处所法。何谓修习无处所法。谓习憺怕悉无所生。修于无欲行真谛法。习学本无而行法界。亦习本际了知悉空。一切诸法皆无所住。无所习行无行不行。如是最胜。六住菩萨解诸法空。复当修习威仪礼节。不取当来已舍过去。不念现在亦无我所。无所受取亦不有主。复无被服不可睹见。为究竟空故无有尽。设有文字亦假号耳。其无尽者则无所生。以其本净志意憺怕。亦无出生当离所生及无所生。已所习学亦无声响不见进趣亦无退者。推寻边幅则无有底亦不无底不起不灭。是则名曰达于本空。讲宣平等亦无想念。无近无远亦无足迹。是谓为习。所言习者。入于法律。一切诸法假有号耳。亦无来往周旋之处。无得无失无闻无见。是谓常在住于法界。其能奉行如是法者。是名为习。云何为法。所言法者。法不念法亦不毁败。复不恐难无有希望。设无希望亦不想报。若不念报则除一切望想之累。不迟当来不住现在不忆过去。如是行者便能具足等于三世。三世等者则无言说。不用住故而度众生。最胜当知。如来出现演此言教。使众生类得度彼岸。有佛无佛法性常住。法界自然亦不变易。法界住者是谓寂然。复以何故法界自然。以无吾我故曰自然。或时菩萨计是我所。自谓有身意所专著。受五阴形观见因缘。名色思想周旋处所。言辞往来依猗识知。名号假设心中称量。观察本末四大诸入。是时菩萨复作是念。我当劝进度三界人。当使捐舍淫怒痴病。修习道教入三脱门。若复思惟使众生等到于道迹。至成罗汉得四果证或复思念。意止意断神足根力七觉八道。空无想愿四谛真如灭于尘劳。有是思想内于众生为眷属者。则于法界而有缺减。六住菩萨。以是远离不与缘觉声闻之心。行菩萨业大乘之誓。发大弘盖旷大之意。心自念言。若我作佛务求道慧。于百千行使不耗减。我当布施舍乎悭吝施以法财。净其禁戒断除瑕秽谨慎守行。建立忍辱刈去嗔恚体行柔和。若修精进。护懈怠垢。勤力遵修初不弃舍。若处闲居修于正受。意不乱转逮得一心。从三昧起奉行其义。六度无极开化众生。以求佛道欲成道果要由六住成等正觉降伏众魔。转无上法度脱人民。以佛永寂而灭度之。究尽圣慧学治住地。宣畅如来十力之业。十八殊胜不共之法四无所畏。分别辩才通达无碍。亦不想求于色无色无所贪慕。应这前人分别五阴无所起灭。生老死苦是恼之相识解空者。是谓苦谛。晓知五阴所从缘起。所见万物皆有想求。别了其意而无是非。虽不求者亦不永忘。是谓习谛。不与去来今现在事而俱同尘。亦不住中有侥幸心。悉知消灭而无所有。是谓尽谛。欲致道者了苦习尽。以八十四圣所尊重神达之智。除去缘缚犹豫结网。是谓尽谛。分别四谛一切所现。善恶苦乐心知世间。悉了本末不以为求。虽不求望不取其证。是谓菩萨行于道谛。解了身空寂灭不起。亦无殃衅亦不除罪。无取无舍复无断坏。无身不身不见施设有造作者。不在彼此亦无中间。如是最胜。上位菩萨常当思惟。除二十二更乐之本相连之殃。乃能修习崇菩萨业。是谓最胜上位菩萨于六住中而净其行

    广受品第七

尔时最胜菩萨复白佛言。云何阿毗婆帝菩萨于七住地而净其行。佛告最胜。菩萨常当于七住中。必报施劳终果其愿。去离计着不见有我。虽度众生不见有度。亦复不见我人寿命。断灭计常十八本持诸入之性。远诸衰入颠倒之想。亦不愿求欲生三界。常欲亲附依佛法众。戒念天施空无想愿。亦复不见有入道者。虽知有空无想之证。知而不处不入其境。慧过无愿身口意净。悲念一切众生之类复不自念。哀愍众生等视诸法。斯空无主亦无所入。欲为导御勿为贡高。无所生忍报应之果。一道教授不猗名色。永离邪业而无所著。求想知灭而不回转。自调其意慧无所碍。永去三涂不染于欲。菩萨所说建立应时。出入进退不失仪容。一切妄想贪求之意永不生念。诸所受取审谛安详。散所施设无有错误。亦无此心怀胜负意。常当思惟寂然之法。其寂然者。斯乃名曰不退转法。诸佛嘉叹而授名号。乃得称为无所生慧。所以者何。于一切法亦无有心。其无心者则无所生。无所生者。是则坚固不退转地。又初发意菩萨心者。牢固其志。常当守护弘誓之心。犹若金刚不可沮坏。游于无量生死之难。一切所有施无希望。常有等心加于众生。我皆当度一切萌类。以佛无为而灭度之。虽度众生亦无有人。至无为者。解一切法斯无所生。分别晓了一切诸法。常加精进无所遗漏。其慧普入靡所不达。具一切智了入妙门。诸所爱重无有增减。以无贪吝断诸妄见。阿惟越致。虽在三界不起众想。若起想着便在边际。在边际者。计于吾我猗其所施。愿及一切蒙劝助福。作是施者。便有三碍我人想施。流转生死缠绵在俗。终不能得度世之道。最胜当知。于是菩萨若惠施时不着吾我。不见受者而有所取。设有所施未曾望想而求报应。菩萨所施劝助一切。用求无上正真之道。平等三世无去来今。了一法身不处生死不止灭度。教化一切悉无所住。柔和心性愍哀诸厄。等心广济一切众生。亲善知识咨承未及。习求经籍用寤疑结。数念舍家不慕居业。解了相好达之无形。等观诸法明悉解正。无所从生宣畅一品。蠲除众念去诸乱想。舍诸邪见灭尘劳秽。寂然审谛其心调和。志不怀害不随染污。若入此地在其处者。乃当名曰号不退转。一心入众。恒以神通而开化之。解诸佛土空无所有。普悉逮致究竟之处。具足晓了众生根源。随其所好而为示现。最胜当知。七住菩萨精进勇猛如幻三昧常现在前。随彼众生心意所趣而度脱之。或入五道逐而救护。不舍本愿从其本誓。辄得成就识别种种。言辞所说寻以辩才。报前音响则为说法。先达了知命根所趣。至欲成道坐佛树下。庄严道场功勋具足。通诸佛法靡不周悉。菩萨恒当思惟退不退转。极妙之法悉达诸观。了其边际而无处所亦无有终亦无有生。菩萨思惟不退智忍。明知诸法聚散坚强。永使灭度不退智忍。虽处放逸了于诸法。而无驰骋不退智忍。复在诸法解知五阴起无所起。不退忍者。解一切法无有音声。所谓无响亦无往还。不退智者。存于诸法具足众妙。六度无极周遍虚空而无缺减。不退忍者虽在诸法无来无去。立坐卧寐无应不应。不退智者。法性常住住无所住。亦无窠窟有其处所。不退忍者。悉于诸法无尊无卑无高无下不退智者。于一切法舍离断灭计有常心。不退忍者。皆由众苦而生恐惧。当知本空亦无处所不退智者。于一切法去诸覆盖。普遍如空舍除六事。不退忍者。复于诸法消化尘垢不念不忘。不退智者。一切诸法无应不应亦无合散。虽游诸法蠲除尘劳永使无余。不退忍者。因从其慧行无所习。悉无知者亦无不知无思无见。不退智者。诸法无动无能摇者。澹泊寂然亦无想念。不退忍者。诸法磨灭无有退转。皆悉灭尽不可摸则。不退智者。于一切法本末无住性自如空不退忍者。一切诸法皆在幽隐静漠之地。所至无碍亦无患难。不退智者。法界性住常以随时兴显诸法。不退忍者。一切诸法悉为空寂。不念不舍无著不着。不退智者。乘载诸法令度彼岸。不见彼此有度无度。不退忍者。不念诸法生老病死诸入忧恼。不退智者。摄取诸法而不可得。志在深妙获六度法。不退忍者。计于诸法以离垢秽本末无瑕。不退智者。于一切法奉修平等亦不有转。不退忍者。不见诸法种性所造了知为一。不退智者。于一切法亦无所求不怀忧戚。不退忍者。亦由诸法共相发起。无有中息而怀懈怠堕在边际。不退智者。晓了本无无进无退亦无若干。不退忍者。断除诸法所归音响。皆悉虚空不见相貌。不舍本无法性自尔。不退智者。于一切法无有挂碍。无去无来无著无脱亦无所生。不退忍者。除诸秽恶行甚清净。不退智者。宣畅诸法调定众智。降伏缚着使兴道心。不退忍者。悉度诸法轻慢之辈。乃至恩爱报应之缘。不退智者。一切诸法以离名句。其名本无无得无失。不退忍者。普使诸法无放无取不没不生。不退智者。去心贪着究竟本末亦无增减。不退智者。为法根本出生殊胜独步三界。不退忍者。思惟苦本退寻分别知所从来。不退智者。分别根门意识因缘。不退忍者。菩萨要誓终不差违。不退智者。不以今身更受胎分恒当化生。不退忍者。思惟阴入诸种兴衰持入阴性不退智者。分别身中起不净观。从头至足无可贪者。最胜。菩萨常当思惟分别了知。初发起学菩萨心者。以不退忍观了七本。亦不生灭着断之名。七住菩萨。复当思惟贤圣八本。皆悉不见生灭着断。设使最胜。随所受生在彼挍计若生色界。五地十六四三二一。在下位者正有七本亦当思惟。无形界中复有十一。了知空寂阿惟越致。以能成办苦忍苦智。习尽道忍及贤圣智。亦当分别八玄通忍。除五十二无明之漏。七住菩萨常念依初禅行六圣智。修二三昧及三梵堂缘于喜根。设依中禅而不取证。当修七智无觉有观。心行守护空无想愿。假使菩萨因彼二禅思惟八慧。无觉观喜空无想愿亦不受证。若复菩萨复念三禅。分别十慧不念觉观。空无想愿快乐自娱。是时菩萨于四禅中。复当分别十六圣智。亦无觉观行三梵堂等。守护其意而不漏失。其能入此菩萨宝藏。行于智忍解无疮病。不为五十二漏之所系着。分别诸法次地所趣。逮得圣慧不退转法。假使菩萨修行十六殊胜之智。终不怀抱狐疑邪见。则能消除一切众结。其心坚强而不怯弱。意念牢固亦不昏妄。独步三界无所忌难。志若金刚终无羸劣。心常惭愧羞耻不及。意能照鉴靡不通达。智如玄明莫不蒙曜。辩才言辞终不有滞。逮致总持未曾忽失。所为决了不怀沉吟。所在游居辄行佛业。所造平等意无增减。言常柔软不伤于人。性不卒暴审谛安详。知人志趣辄为说法。分别五阴剖判诸入。晓了诸法靡不备悉。遥睹三世报应因缘。知人心念而为说法。是处非处善恶果报。慧心甚深亦无边畔。明解善权随时适化。知时进止出入行步识别可否。威仪礼节初不失宜。所可游居兴发无上正真道意。如是最胜。菩萨大士在在处处。说法度人令成道果。弃舍众难使获永安。终不生于八不闲处。所游国界而得自在。闻其所说辄得度脱。其有承受奉其言教。寻便逮致不退转法。晓了空慧无所从生。便成无上正真之道。菩萨常当施权方便亦不自念。吾今以能降伏色想。本我求愿今日已果。不生小心而随取证。是谓菩萨无有退转。分别十二因缘之法。皆由无明便致生死。寻其所生求不可见亦不可观。亦非有相亦非无相。非不有相非不无相。达知如斯因缘之本。不见所行有正无正及上中下。亦复不见罪福报应造不善行。解了诸法悉无所生。修诸法本不见合散。是乃名曰因缘所起。假使无缘便无忧患。言无患者。无明行灭则无老死忧悲苦恼。通达识知别十二法。一切有因诸法名号。因缘合散非我无我非彼无彼。亦复不见我人寿命生老无常。不见所入复非有入。达知识入悉无所入。如是入者则了一切退不退法。是谓最胜。不退大士若欲具足一切法者。当了无常苦空非身。虽知虚寂用众生故而不取证。菩萨行净不著有为。众生根深不尽有为。解十二缘斯有为法。菩萨导引使了无为。菩萨虽处无为境界。行空无想无愿之法。不住无为而取其证。了知无常为磨灭法。修行功德不怀疲极。观彼受生众苦之元。护彼众生而自省察。观诸法灭亦不究竟。观痛意法寻无处所。观无所生不见所生。观念众生为彼重任。观漏无漏不灭三界。行四等心愍彼后学。意存无著不舍弟子缘觉之道。如是最胜。菩萨清净意志审谛。随人所好而为示现。应适众生终无有损得一切愿。以功德慧其心鲜洁。眼所视色索之了无。习行忍辱不兴乱想。其有骂詈嗔恚向者。唯念其法。解内外空而无所有。亦不起疑而限于空。不自见身及与他人。所以者何。阿惟越致从索手脚欢喜与之。设复求头其心倍悦。不逆前人无所贪惜。求妻子者即持施与心无变异。所说章句唯务无上正真之道。不大殷勤劝进于人。作金轮王帝释梵天。为一切人说微妙法。发心起学为菩萨道。神通游行见十方佛。礼事供养诸佛世尊。正使三千大千刹土满其中宝。心终不兴想着之心。一切所有视无所有。亦复不念是我所有。意悉清净不想色求。用一法身不可见故。视一切人如法界住。逮得道眼神足备具。以得慧眼。便知所有都无所有。渐解如尔真际法性。便获佛眼十八法本。分别法眼通达无碍。具足十力执持弘誓。便至无为不死之境。最胜当知。其所修行如一切智。习行所住故无所住。解了此住住无所住学亦无学。菩萨常念空寂之法。诸法随顺而无返逆。不以随顺而在平正。不以返逆而随边际。复不习邪堕于魔界。亦不学正侥幸大乘。所以然者。不弃舍法牢固之要。以不舍法则不犯非。以自知者无所复作。便能专心制持五阴。使不流驰便度魔界。无能中道弊菩萨心

尔时最胜白世尊言。云何不退转菩萨住无所住学亦无学

佛告最胜。七住菩萨住于三界。不染三界亦无所习。不习学者是谓为内。不求习者是谓为外。虽习于外不随弟子。观无所学亦非缘学。所谓习者。生死所学菩萨所修。谓学无知。习无所习学无所学。习是名色习是因缘。习谓我见习者是爱。习是我所亦非我所。习者虽贪学习布施。习虽犯戒学习护戒。复不于戒而自贡高。习亦恚相学习忍辱。习为懈怠学习精进。习为乱想学习一意。习者无明学习智慧。习无果报学习功德。习为俗业学习于道。习谓无脱学习得度。如是最胜。七住菩萨习无所习学无所学。至无极慧一切诸法不见得失。亦无所入亦无不入。不可以色计有所入。痛想行识亦复如是。不从法数而至有极。亦复不从非法之数。得至无极求一切智。当如智住。不自念法言是我作。作解了者为一切智。菩萨欲求一切智者。当从四大造色中求。所以者何。计身则碍而受四生。不计身者则离爱欲。菩萨住者如智之住。以过诸界住无所住。不计有生不为生母。若见生者是皆非生。以知无生号无生慧。作是等者。是谓平等无极无限大乘之等。佛说是时。十一那术百千天子。悉得无所从生法忍。七万二千人皆发无上平等道意

尔时座上尊大声闻。长老迦叶。舍利弗。摩诃目揵连。阿那律。离越。难头婆罗。分耨。文陀尼弗。空须菩提等。五百罗汉。即从坐起。齐整袈裟右膝着地。悉以头面着佛足下。皆共同时举声悲号。哽噎哀感以手挥泪。前白佛言。我等见浅永断圣种。佛道深邃不蒙洗濯。若有男子女人下至凡夫。在三涂中欲求道者。当发尊意至成作佛。所以者何。如佛今日以百千法为吾等说。不能成就发菩萨意。私抱悔恨永无所及。今虽得道称为罗汉。六通清彻德超三有。故不如本百千万劫。作五逆罪入无择狱。冀望罪灭会有出期。渐蒙解脱以至灭度。便得发意成菩萨道。今已根败无益时遇。所以然者。以其烧燃菩萨种故。器以穿漏不复容止成菩萨道。飞行蠕动有形之类。一足二足至百千足。皆悉依地而得生活。食以甘美衣着软细。群鸟飞空系命在地。吾虽得道犹养四大。我与鸟兽有何差别。彼虽杂垢渐渐得免畜兽之形。种德不息成大乘迹。诸天及人皆蒙度脱。自怨鄙陋不及上尊。皆怀愁忧悔本所修。时彼会中千七百入未践迹者。先修声闻缘觉之法。毕志坚固发无上心。即于座上逮得无所从生法忍。因其敷演六度大法。宣畅四谛苦习尽道四恩四等。训诲一切令发道心

时舍利弗承佛威神。宣告来会诸菩萨等。听我曩昔在坏器时。或从一住进至五住。还复退堕而在初住。复从初住至五六住。如是经历六十劫中。竟复不能到不退转。所兴即悔亦不究竟。设当持心如净戒者。所愿必得而不犯俗。以智慧法靡不照明。菩萨以住不退转地。亦复不计施与不施。亦不见戒忍辱精进一心智慧。亦复不从欲色无色界法。亦复不从身口意行。于一切法皆无所著。悉如幻化野马影响。所住本末而悉清净。无有吾我寿命长短。不见道俗是非名号。亦不自念我当求是当不求是。无忧喜想无缘无作。亦无所生亦无所见亦无处所。作是学者。无欲怒痴无增减学。不堕恶趣有退转心。欲成至佛当如是习。亦不作罪亦不作福。亦不有成亦不无成。不想无想诸法悉等而无差特。时舍利弗。说是语时。复有无央数百千众生。皆发无上正真道意

尔时最胜前白佛言。云何一切诸法皆如幻化野马乎。佛告最胜。譬若如化来不见来去无处所。解知诸法亦复如是。无所从来无所从去。性自然住不见变易。诸法无作亦无造者。如来身者。一为化身二为法身。夫法身者。不可睹见亦无形像。化身如是虚空无形。是谓最胜。阿惟越致所修行本。在诸大众能师子吼。行于空慧无能逮者。功勋纯熟诸法清净。无极深妙不可思议巍巍难量。如是最胜。不退大士于七住中而净其行

十住断结经卷第二十住断结经卷第三

        姚秦凉州沙门竺佛念译

    童真品第八

尔时最胜菩萨白佛言。世尊。云何第八菩萨于八住地而净其行。佛告最胜。第八菩萨常当具足以神通慧晓众生根。观其意趣而为示现。复以神通游诸佛国。观其奇特殊妙之行。还自庄严其佛国土。自往奉觐礼敬诸佛。观佛身相空无所有。学习知忍分别诸根。常入如幻三昧定意知其无本。所作功德随前形器。各随其所而成就之。以过空行无想无愿。不有形像。度于三界永无缚着。慧无所念不有生灭。以无所生故曰为慧。作不见作亦无造者。是谓名慧。无疆界中间处所。都无住止亦无窠窟。慧为清净识无所猗。所以然者。由无想念慧无有限。用力方便不止贪欲。亦不住色不住无色。虽与同垢不为染着。是谓最胜名曰大智。离淫怒痴不处愚冥。永为解脱而无挂碍不着不断。去十二缘无明根本不见我人。无我不我。不住贪欲了之为一。无求色想复不念在一切色中。是谓第八菩萨慧业。终不随缘无烦恼患。不与疑合。亦不有为非不有为。亦不求福非无功德。以越诸恶非法之事。所以然者。法性常存不见。愚者而行非法。不见扰恼其身心识。意不乱想流驰异念。是谓最胜。名曰为慧。分别空观了知无生。断灭计常不使兴起。抑制六关终不邪窥誓在广远不计限局。修童真禁而不越序。若见退堕在下位者。辄便诱劝务使上及。奉顺法者。不断诸佛所修律本。身心怡然不能穷已。兴隆道乐不除法身。不断圣众不有缚脱。复当修习道俗之法。以法性故不断诸学。使慎禁戒因本清净而不可尽。诸在生死斯皆有尽。流转五道周旋往返亦不宁息。住无常处斯亦尽灭。外道异学虽获五通不离世智。愿求长生后失神足。亦复命尽便涉生死。或有众生勤行五戒十善之法得生人天。精勤五戒在欲天中。封受自然功德具足。或有众生习学空定在色天中。以欢悦为食不念苦本。或有众生心识澹然希望无为。谓为无想永寂泥洹。斯皆自调不至究竟灭度之处。第八菩萨观了斯处而不染着。恒敷演法劝进学者使远离之。最胜当知。童真之业亦复远离二乘之道。从须陀洹至辟支佛皆有衅咎。菩萨终不念罗汉法。所以然者。以其用心猗泥洹道。缘觉所修菩萨不学。以其发意无大慈哀。有斯学者此皆非正。若有菩萨欲究竟学习智慧海。尽其元本而不可穷。誓愿不舍一切众生。修如来法为不灭性。慧无穷极故不可见。道果开敷使得成就。言种实者菩萨发意弘誓之心。十力无畏十八不共殊特之法。亦不思议亦不可尽。第八菩萨在在游化。执意行忍无能思议。心不念非无有众恶。不怀恚恨加于众生。又不兴意与人竞诤。复不导人有所毁败。慎护身口不妄有犯。将护众生慎己行本。不处邪部思惟善业。无爱欲意能庄严身如佛色像。尔时世尊告最胜曰。童真菩萨常当习行音响句义。云何菩萨学音响义。于是菩萨知诸法空不染诸见。思惟无相不兴乱念。分别无愿永离三有。法无淫欲本性自净。不起恚怒永使不生。观了无明不为愚冥。复当思惟当来过去现在之法。尽无所起诸法自然。不见兴灭不见生死不为报应。信作善恶知有果实。修口清净不行妄语。其心明解行无沾污。所兴事胜不舍一切。常自挍计梦幻之法。设有邪念即自觉知。志性柔和守护其意使不生恶。常生清净真正之士。设在人间众德具足。相好八十声如哀鸾。亦若梵天所说微妙不怀绮饰。去淫怒痴无复忧戚。终不恶颜恚恨向人。所造功德未曾忘失。随其根本使至永安。常以法言劝进一切。降伏外道邪学异术。以离苦恼无复厄难。备悉诸佛具足之法。人常忍辱身心至密。现受骂詈默然不报。若使众生取挝捶者。不念怨储亦如地大包受万物。终无识想有增减意。所以然者。斯由法性本来空故。设有忿怒终不有恨。视彼恚色如幻如化。兴意来向不持心逆。若念恶者佯若不知密自思惟。吾今审谛知之为空。当求远离不兴彼缘。前人怀恚我宜慎之。假使有人来称誉者不以为喜。若见捶者亦无愁恼。所以然者。不见己身及彼杖痛。皆由积行降伏心意。在闲静处挍计身中。生老病死非常苦痛。愁忧恐怖饥渴寒热。复重观察。是身坏败为非常法。是身为苦器众病聚集。是身虚空四大还本。是身无我无生无灭。三界众生为流所漂。爱欲流者沉没流转亦无休息。先当制心不使增多。复当思惟有流之本。处在三界所更生死受身不息。亦当思惟邪见之流。众生愚痴。随兴倒见六十二尘迷荒之道。无明流者。三界众生瞢瞢为痴不知真道。以不净为净返入欲流。以苦为乐。以非常为常。以非身为身。亦不思惟除去贪浊而自侵欺。长夜不习老不息淫。有财不施不受佛语。是谓四弊遂增爱根。意念身行共相受入。如是最胜。菩萨入定寂寞而观。弃恶除欲不善之想。内自观身思忆三宝。念察非常苦空非身。随贤圣教无苦乐心。修行四证究畅其义。生为苦证爱为习证。清为尽证度为道证。患厌此形无一可贪。深思根本为从何生。随性观之方知根原。苦从身生。习因爱生。爱灭成尽。无欲成道。常遵慈愍无有害意。长养道化愍伤众生。生死勤苦为之拔济。和颜悦色向于群萌。劝教众生使发道意。所言通利而无滞碍。知诸法相真谛之义。达了诸法随时而入。卒问寻对应机无难。所说应时辞无错乱。菩萨慈心愍伤一切。遍念众生有形之类。不免疾病衰丧之痛。为设方便欲令解脱。复起悲心哀感一切。饥渴寒热得失罪咎艰难之患。思惟巧便欲令恬然。复以喜心念诸世间。皆有忧苦恐怖之难。吾当方宜永使安隐。常以守护之心。愿度三界八难生者。愚痴曚闇不见正道念欲成济使得无为。愍哀众生心不动转。虽行此法意不染着。不以勤苦而生退转。渴仰无上正真之道。于诸通慧而无厌足。设在五乐歌舞之中。亦不生心而用欢喜。晓了世俗斯皆幻化。一切万物尽归无常。不为八法所见倾动心恒远离如避劫烧。不处其中为人所恼。若欲恚恨来向己者。终不还报如毫厘许。为人所敬无敢犯者。假使有人欲害菩萨。节节解身各在异处。悉能忍之不生乱想。因欲具足童真之行。菩萨复观身心之法。合成散灭何足贪着。而欲宝之。缘是果行必获佛身。备悉成就如来匿藏。建立大誓究道根源。菩萨行权变化无穷。若在外道异学之中。现身入火坐卧自由。复从火起无所伤害。辄使其人知有真道。心自改悔修清净行。化愚惑意还令返真。因从生天为讲演法。解知天位亦复衰丧。菩萨权道无所不入。释梵四天王无不自归而稽首者。斯由积功道德超殊。亦非二乘所能及逮。童真神智亦无边底。心旷无崖不可限量。所说有益亦无损耗。以是之故慧不可尽。一一分别眼耳鼻舌身心之法。了知悉空亦无所有。达过忍慧便逮众智。不念一切是常非常。寻便得入无极之慧。若与前人音声来往。思惟言教犹山中响。有解此者名曰权慧。亦复观察有为无为空性之法。谛自虚寂假有号耳。不念己身以得道果。余下劣者亦不及逮。复不自念。修行戒律奉尊法教。终不兴意生若干念。是谓童真权慧无边。或有菩萨行中和忍空忍顶忍不退转忍。如实观察而无虚妄。修三梵堂。空不住本不念牢实。无思想观不念有想。亦不愿求而兴愿想。法界一相亦无形貌。思惟生死亦无终始。亦无施为无有施为。不见过去当来现在。周回往来都无真实。过去磨灭现在不住当来不生。有德不见无德。无德不见有德。不为有德不为无德。非不有德非不无德。了知有德无德澹然空寂。不有生灭着断之名。复观无生不有所生不见无生。分别有生及与无生。虚而无实一而无二。不见度世道果之证。亦复不见前后中间。文字言教不见解散不与世合。复不见聚而共同流。如是最胜。童真所修深远难及。不可思议无能及者。不见道忍与智忍合。不见智忍与道忍合亦不不合。不见无道与无智合。不见无智与无道合。道忍及道自不共合。非不有合亦不不合。所以然者。性自空故。最胜当知。世有二法令新学者有狐疑想。云何二法起狐疑者。于是菩萨修百千法。猗着泥洹谓为以脱。有斯行者则有减损。或有菩萨。知泥洹性永为解脱。不兴染着施设生死无从无离深知为一。而无若干分部之名。菩萨慧忍终不生心。而有彼此平等大乘。解入空慧无著无断。无所染污乃谓平等。等性观了无缚无脱。亦无所造故无所生。不见自然有生灭者。解脱然者乃谓自然。不见有然不见无然。解达自然悉无所有。是谓清净是谓灭尽。如是最胜。菩萨积行慧无穷极。行无生慧而不可尽。从初积学至于道场。坐佛树下降伏魔怨成无上道。先当入此忍慧定意。然后乃游师子奋迅独步三昧。放大光明普照三千大千刹土。有见光者斯皆忍慧所见缠络。意识柔软无强梁心。常以慈哀摄身口意。言教清净终始无损。任纵无为于尊佛道。游志三昧心无乱想。为人谦下不憍篾人。功德道果日夜滋生。缚结怨恶永无根芽。堪游他方诸佛刹土。知其光明神感之应。训化群萌靡不度者。寻其光明了无所有。分别相貌亦无真实。复当分别色痛想行识所起相像。云何观达五阴之相。有见光者是谓为色。有形质者是亦为色。取受付与是亦为色。己身护持亦复是色。若与他人亦复是色。次当了知痛之起灭。为由何等而有此痛。苦痛乐痛不苦不乐痛。常念分别而无苦乐。况当有痛此则不然。具晓了者是为痛相。深记去就流驰不停。追忆往古未来现在若男若女。及余无数无限之念。名曰思想。解知此想无来无去亦无处所。虚而非真亦无名号。故名思想。若复见行善恶之法有记无记。有漏无漏有为无为。有所造作不以为碍。菩萨于时见行善者非为不善。见行恶者非为不恶。若复有时亦不行善亦不行恶。当念分别不见无善亦复无恶。是谓最胜名曰为行。复当晓了何因有识识非一相。眼耳鼻舌身意之法亦名为识。色声香味细滑之法亦名为识。达知更乐兴衰之法亦名为识。在思想中亦名为识。离思想者亦名为识。有善有恶亦名为识。无善无恶亦名为识。亦非有善亦非不善。亦名为识。解知此识为从何生复从何灭。解知无生亦无起灭。达了此者是谓为识。如是最胜。童真菩萨舍身受形。身根意识初不错乱。不受中阴而有留难。众生神离住于中阴。随其轻重殃祸之本便有留难。菩萨大士发意之顷。随意所向寻往受形而无留难。最胜当知。童真菩萨常与一生补处菩萨以为朋友。随侍游观佛土清净。选择极妙最上佛土。志存盛好施为佛事。第八菩萨逮得自在。从其缘化靡不周遍。所宣道法而无穷尽。常以善教悦可众生。时彼众会有诸菩萨。各心念言。今日如来颁宣慧业叹童真行。功德果报亦无等伦。今观最胜大士所修。履童真业亦无差违。假使最胜。成最正觉无上之道。得佛道时所号云何。其佛国土功勋严净为何等类。诸菩萨众成就云何。奉修法律有差别不。尔时世尊知彼众会心中所念。便于座上寻时即笑。无数亿百千光明从佛口出。照于十方无限世界。蔽日月明覆魔宫殿。光还绕佛无央数匝从顶上入。时会菩萨即从座起偏袒右肩。叉手礼佛而问笑意。佛不妄笑愿闻其意。尔时世尊告众会曰。汝等见此最胜菩萨不乎。对曰唯然我等已见。佛告来会诸菩萨等。此贤劫中百佛过去当有佛出号师子威。如来出现于世至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。国土名号如今无异。时彼土境国界神妙。五[聲-耳+木]卒贱自然无价。人民滋盛城郭严整。合以七宝金银琉璃水精车磲玛瑙珊瑚琥珀及摩尼宝。时彼佛土平正。有八交道纯以宝成。其地柔软如天细衣犹兜术天。被服饮食宫殿室宅。园观浴池交路棚阁巍巍殊妙。其佛国土神德如是。诸天人民自然显发。作倡伎乐悬诸缯幡。竖立幢盖烧众名香雨宝妙华。将护正法使不缺漏。导利开益无量众生。今此最胜菩萨从此间没。当生无怒佛土极乐世界。已生彼土时。无怒佛为诸菩萨宣八千四百奇异法门。阐扬道教归于句义。往返周旋不断三宝。皆使众生立不退转。说是语时其在会者。咸皆叹曰。善哉善哉。最胜大士。以成佛号何其速耶。愿将来世得生此国。值师子威如来出现世时。遭蒙道教修童真行如最胜也。时会菩萨重自念言。令诸众生普皆得慧忍智之法。如今无异其闻此声。无有恐怖不怀犹豫。尔时世尊告最胜曰。菩萨行备具足众德显示殊特无量言教。应时示现靡所不入。或为凡俗孤老之形或为幼童婴儿之像。复以权变入于四道。与须陀洹已成就者而为朋友。便说上要使不懈息。复执方便入斯陀含。劝使断除五灾之难。能令得入不经七返。或在天上敷演甘露。纯熟行者不来世间。或与无垢真人共会。为说身苦六十八法。自叹鄙陋缺无上道。徒丧慧明损辱法典。或现诸佛缘觉之道。显扬神足现十八变。默然教授使得解脱。内怀权慧应适人心。随缘投药使不增减。或与新学初发意者入清净定。使诸众生普见色身。乃令三千大千佛土。在手掌中共相供养。于中往来无增无减。令发无上正真道意。时有菩萨名曰究畅。即从坐起长跪叉手。前白佛言。唯然世尊。是三昧定有何名号。乃令三千大千刹土。十方境界普在掌中。其中众生兴敬供养而无增减乎。佛告究畅菩萨大士曰。其三昧定号曰清净。普见色身显现变化靡不容受。国土境界如故不异亦不增减。正使三千大千刹土。及恒边沙无量佛国悉在掌中。共相敬事施行福业。坐卧经行随意所娱。其中众生各不相知。己身所在无所触娆。究畅当知。皆是童真菩萨威神之所施为。在所现化亦不见身。竟为所在不使众生有增减心。尔时座上诸来会者。天龙鬼神干沓和阿须伦迦留罗。真陀罗摩休勒人及非人。各自生念欲令最胜大士菩萨。示现神变清净定意

是时世尊知众会心各有想念。便告最胜菩萨大士曰。汝今最胜。当为一切众生及来会者。现是三昧清净定意。令诸会者有笃信心。是时最胜菩萨大士。承佛威神敬奉圣教。即于座上三昧正受。令其十方恒沙刹土。天龙人民及鬼神王。并余尊天诸会菩萨有形之属。皆现掌中于中显示。有禅定者有经行者。有兴功德作佛事者。所现殊特巍巍难喻无以为譬。现神足已。一切十方诸来之会。还在本位如故不异。最胜菩萨亦在本座。衣服严整不失威仪

时究畅菩萨。语最胜曰。仁者所现三昧威神。超越无量无限之德。神感威显实无等伦。乃能容受十方世界。在其右掌而无增减。我等勤加兴功立德。进修清净定意之法。务及童真大士之行

尔时最胜报究畅曰。如是如是如汝所言。若有新学发意行者。务欲修习童真之法。当念勤加成就道果。使不中退。菩萨精勤有二十事。所当应行育养拥护不使损减。何谓二十无缺漏法。于是菩萨修童真行。发大弘誓无盖之心。念欲拔济危险之厄。是为精勤而无有退

复次菩萨合集徒众。训以道教无形状法。恒说空无虚寂之声。是谓童真行无有退。复次菩萨广布功德。使诸下劣得蒙缠络。先除贪意使无想念。却乃训导檀度无极

复次菩萨见前众生。有困厄者辄身往化。安慰其人使不受痛。常念育养心无变易。复次菩萨造立苦行。经无数难求高明师。咨受言律奉修正法。常念拥塞六无根本

复次菩萨求无上道。心无荣冀有所染污。心常精勤诸神通慧。行于止观除爱着心。复次菩萨随时应适。晓了权变无觉知者。前受教人痴心通达。然后乃告方便之宜

复次菩萨发心誓愿。备悉相好庄严其身。自净其土。作黄金色。所将眷属同为一相。复次菩萨誓度旷远不怀怯弱而有滞碍。虽处生死不辞劳苦。毕志坚固降伏外道

复次菩萨。造立无数功福之业。常念众生不自为己有系着心。思惟四谛觉明观慧。复次菩萨被弘誓铠。从无数劫求无上道。终不生念我行真实。有此行者则有耗减。复次菩萨包容凡夫。来自归者微说道教。指示径路令知所趣。观前人器乃授甘露

复次菩萨观察方俗。王法所制勿生叛逆。善则从之恶则窃避。无自贡高毁败风俗。复次菩萨当学入众。若梵志众若长者众。观采礼仪可行知行。可坐知坐可卧知卧。应适威仪而无错谬。是谓童真菩萨而知入众

复次菩萨常当修学无生法忍。无起灭慧而悉具足一切佛法。游化十方无量佛国。欲得备悉诸总持门诸众智门晓了智慧而无穷极。当念修习童真之行

复次菩萨。执正御乱不处邪部。具施戒忍精进禅定智慧善权三十七品。空无想愿。其心不懈亦不疲厌。终不忽忘弘誓之心。是谓童真牢固之心

复次菩萨合集功德众善之本。自缠络身修诸相好而自庄严。消除憍慢无明邪见。童真菩萨一相清净则不染着。不见境界有净不净。尔乃周备相好功德。无量福业而悉具足。亦不懈怠有退转心。何以故。以其童真菩萨发大弘誓不舍本愿。广布慧业精进无惓。是谓菩萨修童真行

复次菩萨分别幻化欺诈之法。观了虚寂永无所有。亦无形质而可睹见。长养精进务修本业。于十六分而不遗舍。行慈菩萨恒自挍计。欲为我生为从何出。深自思惟出无窠窟。此是世人自起识想染着之意而兴欲火。焚烧善本坠堕五道。斯由贪欲无明结故。若有菩萨分别五欲皆不真实。勤欲思惟永不与处。设闻他方旷野之处。彼有苦行断欲之人。便能方宜诱导众生到彼方域。辄见苦行断欲之人。心意清凉不怀热恼。使其众生皆发道心。除去五欲渐渐将导。游诸佛国礼事供养诸佛世尊。转复引入深法之奥。然后乃具布施之德。戒忍恩和建志精进。一意入定念不驰散。广修智慧无崖之业。是谓究畅童真菩萨所修行道。弘益靡不周悉。若有菩萨初发习学讽读讲论二十行业。然后乃发履童真迹。当其最胜说是法时。万七千人皆发弘普无穷之意。慕修童真二十行业。十千天人皆得无所从生法忍。复有无数众生之类。增益功德不怀中退

尔时世尊告最胜曰。善哉开士。多所饶益多所度脱。若有菩萨被弘誓心。合集功勋不怀懈惓。加行劝助而修法施。欲以开化众生之类。合集度脱入泥洹界永无来往。是谓最胜。童真所修德不可量。若有菩萨发心起学。常当修习二十行法。却乃渐入深法宝藏。如是最胜。当作是学。如是学者便应第八菩萨之道

    定意品第九

是时最胜菩萨复白佛言。何谓常净菩萨于第九地而净其住。尔时世尊告最胜曰。九住菩萨修习定意一心解门。三昧正受而不耗损。于净不净常若一心。虽处尘劳恚恨之中。不兴乱想生若干念。观知众生心意识着。缘结苦恼之所系缚。所因报应而致此患。复求方便权诈之法。当何巧便得至永灭而取度脱。是时第九菩萨大士。当复思惟斯诸想着。皆由不顺正法之相。从无明行致斯缘报。唯当一心生其道念。念佛法众戒施天念。安般摄身及死亡念。守护一切使不烦乱。勤行精进如救火灾。所逮功德充满一切。内怀志愿存于道果。行诸通慧靡不周悉。常念思惟愍伤一切。由何众生有尘劳患。谛自观察寻其源本。皆由无明而致行报。以生行报则有识神。识既有窟谓为名色。名色已生具成六入。内外相因便起更乐。心已染着转复生痛。解了苦乐乃生爱意。爱根已生共相受入。生老病死愁忧苦恼。渐渐长益欲爱报应。第九菩萨观斯报应深虑思惟。尘劳之缚虚而不真。谛无有实自观缘报。复知众生分别果实都无处所。应无所应报无所报。复以清净真观之法。使其众生令致清净。常念劝勉勤修定意。先以权便观一佛界。有几众生建立坚誓造功德业。集修无上庄严道树。有几众生禅寂入定神足变化权现无方。复几众生荷负重担为人重任。而代拔苦不使受恼。有几众生断三结使具成道迹。有几众生三垢已薄得频来道永与苦别。有几众生无五下分缠缚之难。不复往还至此世界。有几众生断上五结。游诸解脱而自娱乐。复以神通五眼观察诸在幽隐法没尽处。当有缘觉居止山林。随时出现人间教化。菩萨亦复思惟彼处。有可亲近有不可亲近。云何族姓子一意观视。一佛境界众生之类。建立坚固造功德业。进修无上庄严道树。于是族姓子九住菩萨。若见众生有坚固心。即设权便与作善知识。随时育养增益精进。拥护成就毕志牢固不可沮坏。诱进开示使知深法。不虑远近险难之中。正使前有火灾隆炽。烧一佛界融然一体。路由其中到他方界。闻彼有佛敷演道法。无生无灭无老死法。便能前进没身自归。安隐至彼身不被烧亦无热恼。得觐彼佛礼事供养。合集功德殊异之法。便得成就亦无退转。若使遭遇大海深水。如一佛界上下周匝而无有异。于中立誓能自投归。亦不怯难所立功德。志愿坚固不可动转。是谓九住菩萨住大慈哀。不舍一切摄众生故

云何九住菩萨观彼众生禅寂入定。神足变化应适无方。于是菩萨若见众生远居深山无人之处。执意思惟入第一四禅。第二四禅。第三四禅。第四四禅。是时菩萨见彼众生。复从第四四禅起。入第三四禅第二四禅第一四禅是时菩萨复见众生。但入一禅不入二三四。或入二禅不入一三四。或入三禅不入一二四。或入四禅不入一二三。是时菩萨亦见众生。入空处识处不用处。或时菩萨观见众生。但在空入不在识入不用入。或时独在识入不在空入不用入。或时独在不用入不在空入识入。或时乃在第四四禅。不在上下三禅。九住菩萨便往至彼与为善祐。使成功德不令厌惓。能使众生必至坚固者。乃当称之名曰九住。何谓九住菩萨荷负重担为人重任。常代拔苦不使受恼。于是菩萨以权方便往入五道。随时应适衣被饮食床敷卧具病瘦医药。若在三涂八难之处辄身往度。趣使前人不令受苦。或入地狱饿鬼之中。便能广惠各得饱满。是谓第九菩萨堪为众生荷负重担

云何菩萨劝喻前人。断三结使令成道迹。渐得果证永与苦别。于是菩萨执权方便现若干变。与说声闻缘觉之教。说泥洹乐寂然无为。或时与说菩萨大士无生无灭虚无之法。以能知彼众生念已。先论大乘方等之要。布施持戒忍辱精进一心智慧。大慈大悲四禅四等。根力觉意八贤圣道及三梵堂。其人闻已心意肃然衣毛皆竖。随器劝进使成道证。或时菩萨观彼众生本发菩萨意。自忖疲厌而不能得。便欲退还入声闻道。菩萨于时复至彼所言。卿积德以来今已垂办。光相种好当庄严身。广运众生修治佛土。何乃退还就于小道。其人闻已倍自悔责。咄哉无状实为可耻。乃使通神菩萨道者而见怨责。我今自励要当勇猛。积功立志执弘誓意。为一切故不舍本愿。发意菩萨生是念时。尔时天地六变振动。动魔宫殿不安本位。是时弊魔自生此念。向者天地六变振动。是谁瑞应示现若此。将非如来至真等正觉出现于世。若不尔者当是无欲之人得阿罗汉。令其瑞应乃至于斯。设无此者当是发意菩萨立坚固誓发大乘意。欲求作佛独步三界。愍伤危厄济渡十方。空我境界使无侍卫。若不尔者。当是百二十八鬲子罪王生地狱中。以理治化心不增减。或能是彼神变所感。若不尔者吾有万子。勇猛刚健才艺非恒。在我左右统摄六天。吾最小者名曰恶子。受姓凶暴行无慈仁。吾遣使知王地狱事。料简善恶分别贤愚。亦有神足感动天地。今称号曰治罪治法王治无高下。将非即是神感之应。魔复思惟。我有仆使名曰阿傍。亦能现变威德无量。当生之日天地大动。若取命终地亦大动或能即是现瑞怪耳。如是魔王兴若干念。便以天眼观于三千大千世界。于时便见断欲之人应得须陀洹道。今乃更发摩诃衍心。正是斯人欲空我界。当求方便坏子善心。是时弊魔自将兵众到善男子所。自见常净九住菩萨。心自怀惧衣毛皆竖。便自退还不堪前进。是谓常净菩萨神德感应。使道迹寂成无上道。建立誓愿终不屈还。何谓九住菩萨观众生类。知三结薄得斯陀含。无欲怒痴永与苦别。于是菩萨观彼众生。久远以来所积功德。有利根者有钝根者。设见众生心意纯熟垂成道果。意不可回令至大道。若见钝根劝使精进具众德本道果之报。菩萨将导使心不懈。寻能成就四道之证。或有超越取第四果。不使流滞住阿那含。皆是第九常净之德。未曾违舍弘誓之心。是谓菩萨修勤精进无能称量。不计报应十二因缘。九住菩萨修习常净而致清净。或从他人闻柔顺法。内省己身应其法念。专精一心志存学问。常在闲静不处愦乱。知彼方便寂然定意。观察人根终不虚妄。是谓菩萨于斯陀含而有长益

云何菩萨扶接众生。断五结使缠缚之患。即彼天上劝使灭度。亦不往还至此世界。于是菩萨至彼天上。与说无生无断灭法。即于其前入灭尽定现取灭度。诸在彼界阿那含天。心各生念共相劝勉。于无余泥洹界而般泥洹。菩萨虽现殊异之法心亦不变。有若干想自识久远无数劫事。发动所趣皆悉了知。不见往者亦无还返。亦复不见住止之处。观无所生本无处所。自致清净坦然无为。是谓菩萨于阿那含而有增益

云何菩萨复观众生。育养学者逮获无著。于是九住菩萨大士。以天眼观三千大千世界。谁应漏尽垂得道果。作是观已。或见有十有百有千。乃至无数不可计人。断除结使同时同日。应成无垢得阿罗汉。是时菩萨以神足力。一日之中周满三千大千世界。以权方便拥护其人。各令适志而致无著。永离生死寂然无为。是谓菩萨于阿罗汉而有增益云何菩萨劝缘觉乘而获无著。于是菩萨复以天眼。观诸世界高山平地幽隐之处。静寂独止眇然思惟四十三止定意之法。是时菩萨亦复至彼。相去不远以草敷地。结跏趺坐系意在前。亦不邪视内自思惟欲现权化。或现雷电霹雳音声或现树木共相[打-丁+棠]触于中出焰胜于火光。或出鸟兽哀鸾之声

尔时菩萨在彼众前。忽改其形勇在虚空。作十八变存亡自在。有三十二相八十种好。身出水火无所伤害。彼缘觉人即见殊特奇异之变。各自生念我等会当早成佛道。亦当复有众相严身。宜共勤修精进不令有懈。时彼诸人复于异时。出彼山林到人村聚。家家乞求以自救生。尔时或闻钟鼓音乐之声。或现哀哭涕吁之音。内心恻怆如被火然。豁若自寤漏尽意解。故号名曰无著缘觉。如是九住菩萨所行。智慧达了而无穷极。缘觉虽有光相功德。故不及如来一毛相之功德。复合计之身体支节一一毛孔所作功德。故不及如来眉间相之功德。复取计之不及如来顶相之功德。正使三千大千世界其中众生。尽笃信佛信法信比丘僧。假令信心百千万倍。故不及持信奉法之人百千万倍。复使持信奉法之人。满三千世界智慧闻施合集功德。故不及道迹之人所作德本。复从道迹一一计之。乃至无垢及其智慧百千万倍。不及一缘觉智慧功德。正使三千大千世界满中缘觉。亦复不如一发意菩萨智慧功德。复使三千大千世界满中发意菩萨。其智闻慧百千万倍。复不如一阿惟越致所作功德。复取计之大千世界满中阿惟越致菩萨。其智百千万倍。复不如一生补处菩萨所造功德亿百千倍。复使三千大千世界。尽满其中一生补处菩萨。复不如一如来慧力功德。如是最胜。九住菩萨心之所明。达知三世众生心意。随病疗救靡不济度。我自忆念于九住中。度脱民萌不可称量。自初发意至于九地。其间所度得罗汉者一阿僧祇。为除心垢永无微曀。从须陀洹至阿那含复有一阿僧祇。普行四谛习想知灭。复劝众生发菩萨意。志各坚固立不退转一阿僧祇。末后降神临欲上生兜术天时。要除十九不成之思尘欲之患。辩才勇猛而无所畏。蠲除一切识神止处。皆尽诸漏虚伪之法。以无漏心修诸解脱。执慧利剑刈除尘欲。获神通证奉遵其行。生死已断梵行已立。所作已办更不受有。如实知之菩萨所修大哀之法。威仪礼节亦无缺漏。住于坚固功德慧中。一切诸魔及诸外道。不能究悉菩萨行业。为诸欲漏众生之等。为讲无漏无生灭法。除诸想着无有限碍。最胜当知。时我思惟入无尽慧。观过去佛所受生法。所行平等亦无偏党。于凡夫法及贤圣道。学及无学缘觉菩萨。诸佛世尊所修行法。悉皆平等世俗及道有数无数。有为无为有漏无漏。于此诸法皆悉平等。故曰称号为等正觉。平等法者当等彼我斯同自然不见起灭。自念所修多有漏脱。宜当禁制广平等法。若心错乱不得专精。当念御意不使流驰。达了乱定悉无所有。普皆平等而同自然。若复怀抱无惭愧时。当兴方便使生畏惧。若复有时身口意恶行不善法。复当思惟除使灭尽无令增长。若复心念嫉姤痴疑穿漏法者。复求巧便永使无余。若复兴念杀盗淫泆妄言饮酒。复当思虑祸败之原。若复意欲贪着豪尊无恭恪意。有人请求秘惜经法。轻毁禁戒不顺律法。教入禅寂不随定法。终不兴想念佛法众。心生贡高憍慢法师。设有此者皆妨圣道。无得亲近而修习之。若复兴念生诸慢意。一曰自大。二曰甚慢。三曰慢慢。四曰我慢。五曰邪慢。六曰等慢。七曰无我等慢。当执慧意永无所生。解无所有悉无所起。平等无二亦无若干。斯皆自然而无处所。是谓菩萨平等正觉。若心生念兴于乱想。一曰邪见。二曰邪念。三曰邪语。四曰邪业。五曰邪治。六曰邪方便。七曰邪意。八曰邪定。常当息心使不损耗。若复有时心横生念。我常所敬而取轻蔑。如今现在复取轻之。或能将来而取侵欺。我恒所嫉汝今敬之。今于我前复恭敬之。当于将来亦当恭敬。复重思惟。曩昔以来曾侵欺我。今现我前复取侵欺。焉知将来复不侵欺。设心如是有此想者。则为败毁圣道根栽。堕于颠倒滋生阴盖。依猗邪见恩爱之秽。则自亡失永离人道。若复有时心念十恶不善之行放逸之道。一曰杀生。二曰盗窃。三曰淫泆。四曰妄言。五曰离别彼此。六曰恶口。七曰绮语。八曰恚恨。九曰嫉妒。十曰邪见。若具生是身口意法。悉当远离不造彼缘。当除此法无使有碍。复当思惟恶何因灭善何由生。达了善恶悉无所有虚而非真。斯皆平等而无有二。菩萨虽获九住之处。常当思惟此诸秽浊。我今所以成无上道。受菩萨莂皆由痴愚十恶所造。而得具足五分法身。直至一道亦无若干。一一分别空无相愿。复当勤行修四意止。何谓为四。四者所谓身痛意法。达晓空观。游意四禅四等四空定八维无九次第禅。复求方便。离于所生入无所生。乃谓平等贤圣之道。皆悉有尽而无有尽。了尽无尽乃应无生。一切尘劳是菩萨尽。设不更兴所谓无尽。欲爱缚结是菩萨尽。若不生者所谓无尽。嗔恚悭贪是菩萨尽。若无是者所谓无尽。迷荒之道是菩萨尽。若无迷荒所谓无尽。意有解脱门是菩萨尽。无解脱者是谓无尽意止断法是菩萨尽。无意断者所谓无尽。根力觉道是菩萨尽。若无此者所谓无尽。沙门四果是菩萨尽。无四果者所谓无尽。有缘觉道是菩萨尽。解无缘觉所谓无尽。有菩萨道是菩萨尽。若无是者所谓无尽。平等正觉是菩萨尽。无平等觉所谓无尽。逮成佛道是菩萨尽。不见有成所谓无尽。往诸佛树是菩萨尽。无稽留者所谓无尽。谓修相好及净佛国是菩萨尽。教化人民显扬法要是菩萨尽。行空无相无愿之法是菩萨尽。有所希望专行德本是菩萨尽。造诸功德分布大道是菩萨尽。菩萨所处亦无高下。亦复不见内外中间。是菩萨尽。不见凡夫所修之行。亦复不见贤圣之行。是菩萨尽。虽在生死于染污法不见染着。是菩萨尽。菩萨说灭观灭无生。亦不于灭永取灭度是菩萨尽。达了真际亦不随顺是菩萨尽。不求远离于诸魔界是菩萨尽。以广慧业不以为劣是菩萨尽。常当习行知时之行是菩萨尽。于诸缘起而不去离是菩萨尽。不以真谛非不有谛是菩萨尽。于禅脱门不见定乱是菩萨尽。虽在人间闲居不异是菩萨尽。在愦闹中随俗而入不摄威仪是菩萨尽。若在禅寂不灭身意是菩萨尽。不见有施非不有施。戒忍精进持戒忍辱一心智慧。不见有行非不有行是菩萨尽。自觉三明眼生智兴。游诸神通不见尘劳。生者灭者常处爱欲。亦不厌惓是菩萨尽。在须陀洹修于道迹。亦复不灭大道之行。是菩萨尽。见佛法没不孚有惧。亦复不见劫数长短。是菩萨尽。不见句体字体味体。此则有数此则无数。是菩萨尽。淫怒痴根不成谛行是菩萨尽。不起法忍至无生慧是菩萨尽。欲界及无思想九众生居。是菩萨尽。游在人间郡县国邑。天宫龙宫诸神妙宫。于彼所修威仪礼节。有可亲近不可亲近。是菩萨尽。是谓最胜九住菩萨有尽无尽之法门。菩萨所行靡不周备有尽无尽解脱之要。众生习苦菩萨亦习。便为说苦真谛之性。若眼见色有苦有乐。思惟眼识皆悉虚寂。修以平等消灭患害。菩萨正法常化众生寂然无为。是谓菩萨为苦众生演畅苦慧。生苦老苦病苦死苦。忧悲恼苦。怨憎会苦恩爱离苦。所欲不得亦复是苦。取要言之五盛阴苦。达知此苦亦无起灭。是谓菩萨有尽无尽之法门也。若复菩萨见习众生。便为演说爱着根本。爱心深固深着难拔。我先有誓要使除尽。若使不灭终不取证。是时菩萨渐渐转入瞻颜法观。于众生前现其容貌。见者嗟叹靡不顺奉。斯须之间变形丑陋。见者心变兴无常想。是身非真而无牢固。我等颜貌与世殊绝。如是不久便当坏败。宜当自修除去恋着不处恩爱。如是菩萨为习众生而有增益。若复菩萨见尽众生。以权方便而为说法。生者归尽成者亦败。正使寿命亿恒沙劫。斯皆灭尽不得久存。诸族姓子当知无常迁转之法。如幻如化亦无真实。菩萨解了无有真实。乃应清净亦无染污。习由藏积遂不舍之。以尽灭法观无所有。亦复不见有起灭处。若使心生憍慢愚痴是常非常。复以空慧无相无愿而分别之。或时菩萨为说至竟一道。教授诸族姓子。当念思惟七处受观。若在五阴分别成败。众生由此致阴弊患。一一思惟色之所兴。前有色相我生识着。因识生痛共相受入。兴意生想转成行业。斯由一色遂成五法。痛想行识亦复如是。若复菩萨见前众生。兴起十八阴衰之毒。娆固人心致令有碍不获彼岸。渐以善权和顺将护。要设权便毕使成就不使堕落。若复菩萨见此众生。心常游在爱尽念中。不见有离亦无所离。是谓具足七处观法。于观行法亦不妄舍。察其迟疾别其冷暖。己已具足复教人行而得成办。如是最胜。九住菩萨行止观法亦无所畏。释梵四王天龙沙门梵志及魔子。无能隐塞止观之行。不使留难于正觉法。所以然者。菩萨晓了达一切法悉为平等。于凡夫法及贤圣道。心若虚空亦无偏党。学无学法声闻缘觉菩萨佛法亦皆平等。若复有时见有漏法及无漏法。分别世俗度世之法。尽除累着乃成菩萨道。所以然者。以空观故故曰自然。来炽自然灭炽自然。空与实等无相相等无愿愿等。于三界中同于自然。复当思惟于无所生等于所生。无行法观等于观法。依与无依等与无等。起无所起斯皆自然。非有自然于三界等。不见欲界色无色界。菩萨复当思惟挍计。于淫怒痴道。及明慧皆悉自然。爱欲缚脱乃成乎道。入泥洹境悉了无二平等自然。是谓菩萨行大慈哀而为众生。设于若干种种因缘。建立众生随其根源。各为如应而分别说。普令和顺住于大乘。尽令消灭苦恼之本。于时菩萨在大众中独无所畏。超绝无侣而无俦匹。众德之本自璎珞身。菩萨若在大士众中。便能演畅于尊佛道。哀愍声闻不达上智。虽得尽漏不离止处。唯自解缚无广大心。复念缘觉无弘益意。圣智辩才清净无瑕。亦能知人根源所趣。唯自守住不净国土。是以菩萨于中特出。能悉分别逮尊佛道。十方感动所济无穷。心恒怜伤不及道者。以勇猛力降伏外道。常转法轮使不断绝。殊妙大法流转于世

如是最胜。九住菩萨权现适化无所不入。解知泥洹如泥洹相。谓有真谛非有真谛。空慧无主亦无住处。故曰无为自然快乐。亦不在彼亦不在此都无处所。无形无对而不可见住无所住。是谓为住谓法界住。是谓为尽为无所生。是谓泥洹寂灭无为。唯有三十四微末结存。余诸尘劳无所挂碍。九住菩萨逮正觉时。现在灭四当来灭四过去灭四。坐于佛树降伏魔已。执忍谓意入无形定。尽观三千大千世界。我今于此五浊之世当成作佛。所求已办无复疑难。我今宜自执权方便。当为众生颁宣道义尽诸漏结。如我今日而无有异。是时十方诸如来无所著等正觉。各于其方遥赞叹曰。今日某方某国土。有佛出现有三十二大人之相。八十种好庄严其身。光照幽冥声如哀鸾。善哉佛种而无断绝

当十方佛说此语时。是时三千大千世界六变振动。诸天龙神干沓和阿须伦迦留罗真陀罗摩休勒人及非人。魔若魔天各各惊愕不安本处。皆共云集至彼佛所。稽首礼敬而自归命。侍卫如来成最正觉。悉护清净无有怨恨。皆致尊重致甘露城。众善具足道法无漏。心兴勇猛游诸解脱。观察众生所应之念。随时布现各得其所。为灭尘劳永寂无为。使众生类除去吾我。弃舍彼此无若干相。不见依法不依非法。非不有依非不无依。达知平等诸法恍惚。如空如响亦如幻化而无有实。彼则得致度生死岸不复往来周旋生死。是谓九住菩萨功祚兴隆道业亦无穷极。所修真正不怀狐疑。于诸无漏亦无沾污。在诸沾污不见受取。永度欲界色界无色界。皆悉归斯无所生慧。复广演布普使闻知

如是最胜。九住菩萨所修行业。威神巍巍与世超异。若入众中执持威仪不失礼节。举动视瞻随顺正法。所著被服亦不绮饰。若欲入国州郡县邑。法衣应器意常舒缓。行步进止往来周旋。坐卧起立心恒审谛。语言柔软不怀粗矿所演如空无有想着。究竟苦行不造报缘。其所施设唯在佛道

是谓最胜九住菩萨名曰一住非九住也。八七六五乃至初地。亦非其住。菩萨进修第十地法诚地谛地无恐惧地。亦复名曰如来之地道地定地无所畏地观地慧地自然性地。菩萨逮此十地之法。便无菩萨号字之称。当名如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛众祐。亦无等伦。具足十八殊特之法。所说辄辩靡不应时。众行具满现生兜术清净无瑕。或现降神接度众生。是谓菩萨于第九地而净其行

十住断结经卷第三十住断结经卷第四

        姚秦凉州沙门竺佛念译

    成道品第十

是时最胜菩萨复白佛言。世尊。云何十住菩萨于十地中而净其行。是时世尊告最胜曰。所谓菩萨修神妙道广度众生。以性空法畅演文字进修禁戒。其德无量不可思议亦无有限。一切世人所不能及。天龙鬼神及神尊者。无能齐限称叹其德。贤圣默然初无所说。若有所演悉成章句。示现神足到十方国。面觐礼敬诸佛世尊。复入定意解脱正受。周普恒沙诸佛国土。见诸正觉闻奇异要。皆悉过度邪部之业。志若安明亦不倾动。心如虚空无所想念。分别晓了法界起灭。其所说法皆应圣印。游诸正受初无差违。十方诸佛所说言教。与圣法律不相违背。所出音声微妙殊绝。观诸世界等若虚空。意念充满解脱之门。补处菩萨辩才通达义应识机。心与道慧而共相应。何谓为心。何谓道慧。周流世典现入邪业。是谓为心。专精一意在度世法。是谓道慧。舍悭布施使无想报。调意和顺审谛安详。是谓为心。正入寂寞不兴诸想。澹泊自守不离圣典。是谓道慧。若在生死务修其法。虽处其中亦不厌恶。是菩萨心。若复菩萨在八难中不闲之处。不起颠倒有二见心。悉能度于始终之病。是谓道慧。于世俗法嗟叹泥洹无为之道。所造功德终不唐捐。是谓为心。菩萨游于诸法之空。达了清净而无所有。是谓道慧。观乎前人随其本意。而为分别所应之法。是谓为心。菩萨入定观一法慧。同于百千诸法之相。是谓道慧。决意惠施不惜所有。国财妻子无所爱吝。是谓为心。处在平等无三乘道。净于道场尽归佛道。是谓道慧。是谓十住菩萨大士。道心所入靡不周备。守护身口不令放逸。叹誉具足八大人念。当念少欲止足之行。奉修禁戒而无沾污。能为众生净于尘垢。若见众生每自叹己毁辱他人。自大贡高憍慢豪贵。怀淫怒痴不善之法。如斯之类。便能与说忍辱之德。皆使众生随时自致无所从生法忍。于中立勤愍困厄不及道者。意猛精进心不退转。分别一切德本之业。不见集聚共合偶者。复不见散有若干别。所兴福业而无所住非不有住。悉与相应而无所应。不见有应不见无应。无应不应是谓审谛。心常娱乐禅思脱门。思惟四食除去染着。观察尽灭不起定意。所闻强记辄能讽诵。慧无所乱分别根原无有处所。欲寻其本亦不可得。为众生宣三十七品。解空无相无愿之行。常能奉持崇于佛道。随诸报应令得道果。诸佛世尊所可宣说亦无若干。所因兴出斯是真谛。乃至灭度亦复如是。无有他想杂念之心。是谓最胜十住菩萨善权方便无所弊碍。以无碍道修于等觉。而为众生转其法轮。令不退转坚固之地。十住菩萨立坚固誓。接度众生而无有难。譬若工巧造印章人。知人姓字便为克记。随类记识亦不错误。菩萨大士亦复如是。以贤圣印而印生死。随器成办终不谬误。复当审谛思惟此义。印非泥本泥非印原。然能示现名号姓字。菩萨圣慧亦复如是。执慧宝印印可众生。随器布现使成名号。便能出生三乘道教。如于良田种于谷子。茎节萌芽展转成长。谷败芽生无复本体。深自思惟芽非本子亦不离本。菩萨大士亦复如是。因缘合会乃应法律。观诸众生所兴瑕秽三患六碍十二因缘。邪疑身见颠倒之想。便为演说苦空非身无常之法。然后乃说如尔法性。分别苦谛习尽道谛。离于重担永获寂灭。复当思惟原究本末因其所生乃有斯患。悉由无明无黠慧法。致于老病生死苦恼。我当方便煎消其病。渐渐令入贤圣法律。以灭无明生老病死永无有余。讲演空观寂然之法。皆使有归令得恃怙。广其慧明至于解脱。悉共崇习微妙之智。了淫怒痴等无差特。寻其原本亦不可别。以获消灭众想之念。终不怀恨生增减心。得离一切诸种阴盖缚着结使。无复挂碍心常游于解脱之门。嗟叹三宝功德之业。常念远离贪欲之患。堪为众生宣布功勋。菩萨精进于彼无疑。示现空慧而开导之。凡所学法。尽无所著。以次成就于不退转。颁宣经道净修佛座。招引众生来入佛境。令得灭度永无起灭。是谓菩萨无上众祐要典。如是菩萨当作是观。十住所入不可思议。修于平等不二之门。达于三世不断三宝。除去三垢成三脱门。菩萨于彼示不思议。从初发意至于十住。常叹开士所修禁戒。德香之熏靡不周遍。弹指之顷皆悉晓了音响之义。于诸通慧而得成就。悉能讲演无量法要。于诸文字解无所著亦无识想。寻其处所了无窠窟。若有学人系识在色心不违之。常怀希望缚着不舍。游于生死周旋往来。意常迷荒不能自拔。有此结网则坠生死。轮转五道无复休息。菩萨执正御诸乱想。不为五阴之所流驰断诸阴盖。亦不使色痛想行识令有起灭。思惟安般出入息念。复当分别四大造色。地水火风各有其性。若使彼识不在五处。便能成就不坏法界。识不流驰十二尘劳。眼色耳声鼻香舌味身更意法。是谓无漏慧根之识。非为生死染污之识。若能消灭外不驰骋。于一切法则无希望。设有所猗便生识想。有所侥幸亦名为识。菩萨起学无所受入。心不生念无所慕乐。所施功劳不望其报。有为有漏斯为识种。修无为行乃谓无识。菩萨阐扬慧明之灯。竖无为炬放大光明。显示殊胜无等之教。为求质直不求文饰。住于道业其身自然无能及者。能显一切诸佛国土。于中示现独步无畏。复于诸法永无所获。亦不选择见有高下。心应自在不怀怯弱。随其音响而教化之。若为众生说深法要。舍离一切所兴因缘。悉了众生心之所念。志性所趣善恶之法。皆能周普诸佛国土。诸佛世尊所修平等。不见众生佛国清净。若见有行则毁法界。是故菩萨心无所住。若睹众生住于起分。则于法性自生识累。不起不灭识无所住。是谓清净无为道慧。设无道慧平等之法。诸佛世尊终不愍哀兴出于世。菩萨弘誓行业无本。亦不住本达于自然。不有精勤有所成办。不见疲厌有懈怠者。于平等观无生无灭。勇猛精进受菩萨莂。悉能分别经典本末。采取要慧除去尘劳。观察生死及与灭度不以为异。恒自怀抱深经之义。探采远近寂然无迹。虽度众生亦无想识。亲善知识心无所著。不计吾我及与寿命。分别思惟空无相愿不起不灭。若在欲界思惟欲爱秽臭不净。色无色界受形之处达知不净。因欲开化迷惑之徒。故为说此真谛之义。分别空无悉无处所。不见造作有形质者。无作不作不见依猗。住无所住亦无根本。亦复不见受三恶趣。不见生天食封自然。显示径路使入道义。无所希望悉无所行。于诸法观自致自然。诸法之相不可究竟。亦如虚空而无边际。十住菩萨教人惠施不兴想碍。持戒忍辱精进一心。宣畅智慧善权方便。慈悲喜护救摄贫匮建立大道。十住菩萨虽未升于如来正座。已能究畅慧海之源。庄严土地修清净国。放大光明普致众生。训以正法悉归于道。建立慧业而获大乘。十方诸佛恒将护之。常以威神助扬其德。乃至作佛成一切智为无上道。不使魔众而得其便。十住菩萨以自觉知功德具满。欲成作佛坐树王下。先当修行习四意止。分别身意各各有性。便自观身起灭兴衰。心自庆贺永离苦恼。观身因缘成精进定。思惟此身报应之对因缘合成。散则磨灭。知身无主。亦不可贪。何为生意着此色身。莫随五阴四大诸入之所迷惑。是身为空。不见四大吾我之法。累劫积行今始乃得。何为着此无坚固身危脆之物。我今当受如来色身及佛法身。夫色身者功德之聚。犹如金刚不可沮坏。十方世界恒沙之数。满中世俗有漏之身。不及如来色身一毛之德。菩萨自念以无量德成此色身。今因此形当受如来佛法之身。虽涉生死往返五道受苦无量不可称限。今受如来色身之体。不念曩日更苦恼患。自今永与诸尘劳别。不复贪着五欲之中。观己身已观他人身悉无处所。修其净行而无瑕秽。是谓菩萨修习己身意止之法。云何菩萨复当思惟痛意止之法。于是菩萨从初发意至于成佛。于其中间所更苦痛不可限量。专心建志慕求佛道。不以苦痛经历心怀。若见苦人趣恶处者。便能拔济使不受苦。恒念众生不能自寤。终不随欲而与系着。我昔以来所更痛痒。非真非有悉无所生。若使遭遇不苦不乐痛。此名无记不可字名。夫人习近着乐痛者。便自远离如来之座。不应如来贤圣戒律。自今永息不复生痛。使诸众生观痛无主。若彼众生于色起痛若好若丑善色恶色。地水火风四大造色。达知虚寂而无所有。或有众生先痛后乐。或有先乐后痛。当说深经使护痛痒。眼耳鼻舌身意所与色声香味细滑之法。从因缘起从因缘灭。思惟苦乐悉无苦乐。复当分别内外之痛。或有乐痛于现在生。或已过去或将来世而有生者。或有乐痛从爱结生。转增识着不能舍离。或有乐痛从痴爱生。思惟正观乃得消灭。或有乐痛因邪疑惑转转滋长。以四非常深远之慧除使不生。或有乐痛从四受生。以无想定而除诸受。或有乐痛从五盖生。便当思惟七觉意法永使无余。或有乐痛因六身法生。分别于空无相无愿。或有乐痛从七识生。当建精进不造彼缘。或有乐痛因世八法生。常当下意不自贡高。或有乐痛从九恼生。当自勖勉永离九处。或有乐痛从十患生。当除望求不念横货。或有乐痛从七澜四使生。便当思惟智慧大明。或有乐痛从九众生居及三观生。便当执意入空寂定。或有乐痛非过去现在因未来爱。非未来现在因过去爱。非过去未来因现在爱。或非过去因未来现在爱。或非未来因过去现在爱。或非现在因未来过去爱。菩萨于彼思惟七处三观之法。灭此十三隆炽之毒。于是菩萨复当思惟乐痛所兴。或有乐痛由八邪见及六识身。共相受入便生乐痛。遂增阴衰诸入之种。是谓菩萨以解脱观分别此痛永使无余。或有乐痛与十不善秽陋之法共相因缘。慧业所断五疑罗网。于现在生即现在灭。若未来生亦现在灭。若过去生亦现在灭。是谓菩萨以解脱观便能除却十五疑网。云何菩萨复常思惟意止之法。于是菩萨执意御乱心不流驰。有所造作必有所缘。自观己意观他人心。其意正等不怀增减。所适之方行步出入举动安详。常自专精守护其心。有缘众生无缘起灭。无缘众生有缘起灭。于己缘起自缘灭之。他缘起灭因他缘灭。或缘起灭亦不在内复不在外。亦复不在住两中间。于中出生有缘起灭有非缘起灭。或因贪淫嗔恚愚痴。七使七慢七识止处。七解七观七忍慧业。若因此处有缘起灭有非缘起灭。斯皆由心因心而生。此四十五盲闇之法。意识所造不自觉知。意不知意谁为意本。既无根本何有意哉。菩萨分别心意识法。通达往来而无处所。是谓菩萨以解脱观知心缘本而不可得。亦不见心与善恶合。无合不合应解脱观。又复思惟十二因缘。甚为深远不可究尽。所种之果不失报应。于诸法界心无染着。设观法界从因缘起。了知诸法无有真谛。自然寂净将养自守。心所造化而无形质而不可见。寻其相貌亦无色像。圣慧通达。便入不起无所生法。不住声闻缘觉之地。常自执意游诸佛法。内自思惟踊跃无量。吾今乃得降伏于心。舍生死着入智慧海。斯由其心得获无上正真之道成最正觉。是谓菩萨于意止法而得自在。云何菩萨于法意止而分别观。于是菩萨修习止法初不忘失。至成佛道而不放舍。内自观法外观人法。菩萨悉知诸法之相一而不二亦不若干。皆归于空无相无愿。远离邪见平等诸法。分别十二缘起之本。常念法界成败兴衰。有漏无漏有为无为。善法恶法有记无记。是时菩萨思惟观察。不随法界自生识想。不见非法而有吾我。亦不兴念计人寿命。或有菩萨自兴法想习着吾我。养育其命思惟断灭。无常谓有常。天下物类皆悉常在。于无常中计无合散。或于法中生颠倒想。无自常无有自常有。无不生有有不生无。无自然生无自然灭。有自然生有自然灭。无不能见我自然有。有不能见我自然无。十住菩萨明慧达观分别有无。断灭计常我人寿命。平等空无而无所有。最妙第一空观察之。第一性空亦不生有。有自常有。不知无之所无。无自常无。不知有之所有。菩萨思惟以慧分别。有性自空无亦自空。无不造有有不造无。著有无者是生死法。非最第一泥洹之要。无自无空无不知无无自性空。有自有空有不知有有自性空。有则是无无则是有。是谓菩萨于诸法性一一分别。思惟校计是常非常生灭着断。有为无为有漏无漏。善法恶法有记无记。一切诸法。有名号者无名号者。皆悉虚寂亦无起灭。而自观法观他人法。于诸想着亦无思想。解空无相无愿之法。于法界中推求佛法及与禁戒。悉无处所亦无径路。不见度人逮解脱者。亦复不见没在生死。于中开导一切众生。便能兴起无盖大哀。疗诸尘劳了诸缠结。空无所有。分别五趣。训以平等。虽处尘欲不怀怯弱。晓了三毒无所挂碍。逮此处者名曰大士。住不思议权现之道。苦习尽道普归自然。于自然中不见起灭尽意如空而无所有不念住处。推求法界及虚空界。众生处所悉无所住。一切诸法等若空界。是谓菩萨随时将导顺于道法。虽度众生亦不见度。若有菩萨自观身法观他人法。能自制意游于智慧。解知诸法悉归解脱。便能将导一切众生。显发无上正真之道。使获无为自然之法。不见所生亦不不生。虽处所生思惟所生。不舍无生无起灭法。是谓菩萨于法意止而得自在。佛复告最胜。十住菩萨复当思惟四意断法。常念分别现在目前。未兴恶法制令不生。已兴恶者方便灭之。未生善法求令生之。已生善法重令增多。常当修习勤行精进。自摄其心使不流驰。古昔以来所积功德。不失威仪礼节之法。所行平等以能检心。思惟正谛祸中重者。三不善根堕入恶趣。轮转五道无有休息。是故菩萨勤修精进。便能消灭恶不善根。不复重来兴起乱想。常自观察不善报应。斯是秽行非是真道。吾今以离非法之行。习第一义而尽尘劳永除嗔恚。分别十二因缘之根。未有善法建立功德。令生萌芽使不败朽。其心清净亦无瑕玼。不猗三界缚着诸碍。离于所著永无所著。常能劝率至一切智。于诸深慧不有损减。所以得致功德之本。皆由精勤而成道果。是谓菩萨于四意断而得自在。于是菩萨复当思惟分别神足。菩萨虽获神足定意。临欲成道于第十地要当习定。如初所学专意入定。思惟四等加愍众生。彼自称身亦称心意。转入一禅次入二禅。复还摄意从初禅起入第三禅。于中思惟专精一意。从三禅起复入初禅。于禅现变而现神足。从一禅起入第四禅。是时菩萨于四禅中。便试神足以身举心以心举身。初如芥子转如麻豆。渐渐转高大如胡桃。如是勤加至三七日。身心轻便无所挂碍。所以菩萨重入定意而试神足。可依此神足化一亿人。立不退转成神足定。是时菩萨复自示现广布神足而无穷极。从阎浮地至第一天第二第三。乃至六天诸天见已各生此心。今此菩萨自现神足。所演光明靡所不照。我等诸天各相劝令。拥护菩萨使成佛道。或以天华杂香天衣被服自然甘露而供养者。于中开化诸天人民。必志神足而有长益。过去恒沙诸菩萨等。修习十住而净其行。皆于此处而试神足。一心观察伺求方便能现众变。以精进力辄成就道。所为自在无能违逆。所欲化者到便降伏。究竟根原皆使充足使获果报。魔若魔天不能倾动。是时菩萨以天眼观三千大千世界。有淫怒痴无淫怒痴。有清净行无清净行。有定意者无定意者。有乱意者无乱意者。菩萨悉知而为分别诸根所趣。复以天耳闻众生声。悉能随次知音响通而教化之。以神足力入定三昧。见一切人志性所趣。自睹原本所从来处。是为菩萨行于神足。于是菩萨复当思惟分别根力七觉意法八贤圣道。信念精进定意慧根。菩萨常以玄通之智。观察众生颇有成就。根力觉道诸神通慧。是时菩萨以他心慧观前众生。或有具足成就信根。常习八道平等之法。心怀正见不处魔界。信知生死苦痛无量。复知泥洹快乐无为。信有三尊世间大明。不信外道九十六径。于诸通慧而无狐疑。积功累德炽燃正法。于中建立直信无难。复以玄通无挂碍智。观彼众生昼夜勤力修精进根。坐卧经行心无懈怠。以获精进则具诸根。犹如天衣周匝四方。上下正等而无差违。时若有人从一面来。捉衣一角举而移之。余三角者皆悉随从。精进根者亦复如是。设有修习精进根者。当知具足一切诸法。以有精进便成念根。心不错乱名曰定根。常以方便摄意守一。分别善恶心如虚空。是谓慧根。十住菩萨入玄通定。豫知众生受胎之相。分别男女男根女根。一生十生百生千生。至无数生皆能晓了而无穷极。是谓菩萨具足道门。思惟诸住智辩难及。当念感动十方国土。复当游于诸佛国土示现光明。有见光者皆得蒙度。复当于诸国土兴立法律。普使遵奉贤圣经典。亦当安利国土人民导引法味闻无厌足。常当晓了国土人民种姓成就不别眷属。亦当观知众生心意。便为演说六度无极。复当禁制众生乱念。渐渐延致一切众生。自为导首牵引众生入善法慧。常念入定不失神足。修己神通分别三世知去来今。复当思惟学佛深藏无边际慧。亦当学习具诸佛法。学了诸法而无染着。学演无底开七宝藏。学以神智成其刹土。学习光明普照十方。得佛定意感动国土。学权方便化诸外道。学于禁戒成就道果。学当集会而转法轮。己身所学成一切智。已成所学而无所学。佛告最胜。是谓菩萨修十住行。进成作佛严治国土。降神兜术权化天人。示现殊异奇胜之法。观察种姓托生何国。从兜术天来下世间。三十六返周旋往来而化天人。于中度脱无数众生。以权方便独步三界而无恐惧。最后下降六年苦行。专心苦体枯木不别。吾虽示现在此苦行。然我乃在无号佛土。于彼教化八十四亿那术天人。皆使建立不退转地。此土众生见我形者。谓为命过不成命根。行过众生。积薪焚烧不能使然。善权一心转进圣慧。不舍众生诸所好慕。除诸不要哀愍不及。是故菩萨现于苦行。十住菩萨于十地中。开化众生不别生死。所度人民与成佛等。若使菩萨意欲速成无上道者。如弹指顷身黄金色。具足十力四无所畏十八不共殊胜之法。菩萨眷属一日成就。不求国土种类好恶。但以众生心怀贡高。轻彼尊己不舍自大。是以菩萨现受胞胎。随世权化在所至到多所饶益。十住菩萨无菩萨号即当称之。号曰如来至真等正觉明行成为善逝。世间解无上士道法御天人师号佛世尊。无量福会诸佛所护诸天宿卫。所讲说法要有缘本。随时应适终不唐举。最胜当知。所以名曰无号。佛土者。去此东南七十七亿江河沙等诸佛国土。彼有世界名曰仁贤。佛名善眼。彼无声闻缘觉之道。以无名号无生灭法。而相教授知解脱空不计解脱。闻空寻解通利无难。亦无三毒淫怒痴病。总持强记亦不可尽。吾于彼土施为佛事。此彼众生亦不知吾身为所住。是谓菩萨多所润及。是谓最胜十住菩萨于十地中而净其行

    灭心品第十一

是时最胜菩萨前白佛言。云何菩萨观无常义谛分别空。解了己身内外无主。又心自在所作具足。尔时世尊告最胜曰。菩萨所游心无所著。论讲诸法无所挂碍。达知人根是梦幻法。皆了一切众生之心善恶之念。因缘报应来者游去。若净不净苦乐好丑。顺逆缚解定乱窠窟。悉能知之。先以晓了虚而不实。复以宿命神通之道。如应说法令知空寂。神足无滞靡所不睹。是谓菩萨观达本无。或现佛身而取灭度。现以方便不永灭度。尽知众生本末清净。或现分离散落异处因为说法。知为恶露臭处不净。计常之人令除爱着。复叹尽漏至泥洹门。设漏不尽亦不受证。复为众生赞叹无漏。一切萌兆致无尽慧。行大慈哀御禅三昧。游止三四至四空定。逮空无相不愿之法。修三十七道品之德。善权方便靡不开化。观彼众生在至八难。除去尘劳永使无垢。复以无碍贤圣之道。入于生死使至泥洹。亦以权慧大智之法。兼化缘觉声闻之乘。随从劝进令至道场。若在愦乱烦恼之中。教人行寂不兴众想。若有众生计诸所著。有数无数现无所有。亦使诸人逮无所著。虽处境界周旋往来。不兴想着无所挂碍。常与众生说微妙法。有漏无漏有为无为善法恶法。悉了知之亦无挂碍。复以无碍无漏慧本。晓了众生心行法本。随彼形像安处无为。随习俗教令解明法。心意识想不使起灭。权慧适化常得自在。是谓最胜菩萨行观。解了身本内外无主。念常修行怀来无厌自获永安。复使众生蒙其福祐。行大慈悲不怀怯弱。然后乃致解身无主。及内外法亦复如是。视其众生如己骨肉。有所求索先彼后己。大哀坚强所济不虚。皆使得立奇特之德。心识寂净亦不动转。观察身本无可贪者。复为众生而说不净。是身如城终无盈虚。身如沟涧时时流溢。身如炽火吞薪无厌。亦如江湖投海无满。如是最胜。菩萨教诲分别思惟知之不净。亦使前人兴不净想。深入辩才亦无滞碍。逮得总持无所遗忘。所教之言不失次第。常得审谛正受三昧。恒入寂然诸度无极。降伏魔怨去邪乱想。如是最胜菩萨观身。达知内外无有处所。亦如幻化影响焰光。入真谛法分别法界。远离贪尘勤修正觉。空无相愿知一切法。生亦无生无生亦无生。虽处于生而无有二。随其所生开导度之。执志勇猛不舍道意。坐树王下而自誓愿。吾今自盟。若我不成等正觉者。终不起于座也。持心平等不舍佛道。常处三界亦无所著。自观内法观他人物亦复如是。念求审谛清净之慧。了知常想悉无常想。复次最胜。菩萨自念如吾今日。受有漏形何由而获。斯由永劫积德不惓。合集智业乃致此身。不念缘觉声闻之道。若有人来而趣向之。心不恐惧亦不狐疑。行于布施去众乱想。内自思惟。使我得成等正觉时。相好严身作黄金色。复训众生使立禁戒不堕恶趣。顺忍不起根门不乱。勤加精进舍自大心。三昧正受心不流驰。修成大智远离欲尘。以权训诲达无边际。圣智之业未曾漏失。所住牢固如佛之住。分别辩才随顺应义。游心总持不损道教。充满众生一切所愿。进御退转使不堕落。所陈言教与禁相应。既自无隙不说彼短。行菩萨道常省己过。宁丧命根不毁彼此。若有众生自来归命不以为欢。设不来者亦不忧戚。闻善不喜闻恶不怒。将顺一切令至道场终成佛道。不违禁戒先救彼危不自求安。施以七宝惠而不悔。入深法要神通无碍。复以神力观众生根深浅高下。分别圣慧而为敷演。行无所著亦无穷尽。虽在缘起心不染着。一切诸漏不以为证。观察法性而无吾我。正法寂寞清净无著。三世兴衰法无所住。不见过去永以灭尽。不察当来有对无对。不念现在而常存者。如是最胜。菩萨遍观亿垓京兆。法无所起法无所灭。身行清净而不为恶。口言清净念常至诚。意在清白不犯十恶。是谓菩萨应度无极。便为诸佛而见授决。慧根巍巍功德炽盛。居十住位定不退转。奉遵于法亦不差违。情性和顺所行具足。逮佛十力志若金刚。了于法本有起有灭。晓一切人心病轻重。众生若干性行不同。所受果报能悉分明。云何菩萨而受果报。手执慧明除其大冥思惟果证。最胜当知。持强记剑刈去疑聚。有所兴造皆是果证。因其果证修行广施。持戒完具如吉祥瓶。心行忍辱如频头大士。精进超殊犹善颜王。禅定入微空慧菩萨是也。慧心果证不可移转。菩萨惠施平等无二。不见吾我有若干想。于诸人物亦复平等。人物以等得诸法等。了法平等正觉亦等。戒忍精进一心智慧。悉解平等而无若干。了一切生亦无所生。生亦不生不生亦不生。解生无生乃应法性。是谓最胜菩萨达观实穷一切真正大法。不兴尘劳而与共俱。舍一切生不见所生。既自布施不见所施。或有菩萨以施求道。又以想着欲得灭度。斯由杂毒还在生死。计吾往古无数劫时。曾于此界作转轮王飞行皇帝。随意所念自然在前无敢违者。子孙相继经六十九中劫。其间行施戒忍精进一心智慧。兴七宝塔高至梵天弥满世界。时世有佛号名勇进。翼从罗汉九十亿百千那术。菩萨大士不可称计。吾自躬身四事供养。衣被饭食床褥卧具病瘦医药。国财妻子象马七珍。奴仆走使下及民吏。尽持供养彼佛世尊。时我所施有染着心。由是坠落处在生死。唐劳其功不获其报。欲计彼时所兴功德如毫厘许。今存在者未之见也。如是最胜。菩萨惠施。施亦有施施亦无施。亦不见施亦不见非施。施亦非施非施亦非施。于施等者得诸法等。解施无施乃应自然。戒忍精进一心智慧。亦复如是。了智空寂亦不有智。于智无智乃应智慧。复次最胜。菩萨复当思惟法宝。云何法宝所谓四意止四意断四神足五根五力七觉意八直行。神通三昧。诸度无极。一一分别而无吾我。蠲除闇冥使知大明。建立慧智开化众生。弃诸重担而无犹豫。修奉禁戒身意寂然。复当思惟建立慧珍。亦不生心而有所猗。意离三世亦无内外。不猗阴盖四大诸入。取证灭度不见灭度。七觉意花以为花鬘。贤圣八品以为果报。庄严道场以为室宅。导进众生引至无极。淡泊寂然无老病死。亦无忧喜众苦之恼。独步三界而无所畏。观诸人物悉皆清净。我人清净人物亦净。了达清净而无所有。菩萨从初发意以来。当念清净起微妙意。于其中间终不复生淫怒痴意。亦不施心当娆众生。亦复不兴二乘之心。在于大众方为上首。虽处豪贵亦不贡高。护于众生不舍众生。本无之心各各无实。心无有心亦无结网。是为菩萨金刚之意而不可沮。长养善法使不漏失。思惟深妙弘誓旷大不可思议。察一切性不见所起。亦复不见有成就者。观世幻事皆不真实。以清净观斯是颠倒。不随诸法应与不应复不舍之。有杂索者不见现在有所积聚。不见去来出有所由。去亦无端来亦无绪。分别现在皆无处所。寻究正法而不可得。菩萨建意要在颠倒。不成之想是菩萨要。六十二邪是菩萨要。身想戒见是菩萨要。沉吟犹豫是菩萨要。贸求天福是菩萨要。或入泥犁不计有苦是菩萨要。或复变身入饿鬼中及畜生道是菩萨要。菩萨虽处五无间中。于中拔济苦痛众生。安处无为长存永乐。亦无起灭乱想之患。思惟法界亦不可得。所以者何。人由法生法由人兴。自起自灭亦无死本。人不离性性不离人。人物自然不见踪迹。吾我寿命亦复如是。吾我自然诸法自然。法以自然道亦自然。解知如是空达观者。便得自然积聚之道。所谓自然积聚道者。妙观无二亦不见二。菩萨复有速疾三昧。入此三昧者弹指之顷游于十方恒沙诸佛国土。礼事供养诸佛世尊。还在故处人无觉者。寻于座上即如其像。三昧正受到于东方亿百那术江河沙等诸佛刹土。礼事供养诸佛世尊。问讯听受微妙之法。忽然西过复至无量江河沙佛国。礼事供养诸佛世尊已。寻复南至无量国土。即还北方无量国土。四维上下亦复如是。于大众中一坐一起无觉知者。如是最胜。菩萨入此正受定意。弹指之顷游于十方无量刹土。忽然还至在于本位。时坐众生无觉之者。如吾今日于大众中敷说法义。有二亿菩萨不起于座。各各游至十方刹土。今各还来在于斯坐。听法众生无能觉者。皆由菩萨行纯淑故。是时最胜前白佛言。斯正士等所入三昧为号何等。令诸菩萨周游往返速疾乃尔。是时世尊告最胜曰。且舍菩萨所入三昧。复有三昧名无碍通。是诸佛世尊常所游居。如来入此三昧已。出入息顷游于亿百千垓江河沙等诸佛刹土。亦使十方诸佛世尊来内此界。不娆众生有觉知者。或持十方一切海水。移住虚空如悬明珠无不见者。不使水性有惊恐者。斯名无碍通慧三昧。时二亿中上首大士。有一菩萨名曰海藏。在于座上便自思惟。如来必欲使我现于三昧神力。即从坐起往诣高座众会之前。稽首礼佛并诸上尊。则住佛前叉手白言。佛道深远不可喻及。无上正真之道实为难逮。如今我观一切菩萨。及四部众诸尊神天并来会者。见此菩萨于大众中而师子吼。又且众人饥虚于法来甚久矣。今时难遇。欲有所问。若见听者乃敢发言。佛告海藏。随汝疑网而问。如来悉当为汝分别说之。使诸菩萨及一切会令得悦豫。当以智剑之大火。烧汝愚痴之丛林。是时海藏菩萨复白佛言。唯然世尊。向在座上心独思惟而自念言。斯诸二亿正士。积善甚久功德具足。降调心意志存道法。累诸善本获此正受。从无数劫。承事诸佛礼事供养。神通菩萨而此正士为众生故。象马七珍而已惠施。皆使生类得成佛道。或以退转不坚固者。行此定意正受三昧。复有菩萨以尘劳故深入生死。欲使众生永无苦痛。或有菩萨入慈三昧。令彼众生长离憎嫉。复有菩萨兴发悲心。使彼众生解无常义。或有菩萨游喜定意有瞻睹者令解空寂。复有菩萨发金刚心皆使众生成弘誓意。复有菩萨广大其志迎致一切入己刹土。复有菩萨以身法本令彼众生初中竟善。复有菩萨八不闲处兴显三宝使不断绝。或有菩萨以权方便随前众生应变适化。复有菩萨闲居静处观有为法如幻如化。或有菩萨乐在空慧观此形体如彼墙壁。或有菩萨心意质直所行清净亦无秽污。复有菩萨情性至密所游之方而无漏失。复有菩萨心趣一道不使众生闻三乘之名。复有菩萨志乐解明洗浴前人永无尘秽。尔时世尊在大众中赞叹彼菩萨曰。善哉善哉海藏菩萨。乃能吾前于大众中而师子吼。叹誉菩萨所入定意。使来会者悉得闻知。斯诸正士所游定意三昧正受。不可思议无能逮者。非是二乘所能思量。菩萨积德不自为已。念拔众生受苦恼者。正使三千大千刹土。其中风起弥满世界。周旋速疾如随岚风。设有人捡道迹之人。心欲专逝于中往来。寻能成办而无挂碍。况复菩萨神通大士三昧正受而可思议。转念之间以过恒沙无量刹土。复以六度十善之法。教化众生训以善道。其心永安不可动转。志行寂静亦无错乱。若兴心行亦无能及。斯由前世众德具足。志行庠序不别种类。大慈无尽亦无穷极。一切诸法常自存在。众生不达谓有兴衰。法法自生法法自灭。法不生法法不灭法。法生法灭性不移转。斯是菩萨大士之道。非诸凡俗之所及也。众生之类在于生死不达道本。谓为法性而有变易。设当尔者此事不然。菩萨从初发意以来。行施行戒众德具足。所获果报得成道者。由解空观虚无寂静。宣扬去来神妙行业皆悉成办。入诸菩萨所修行地。游于殊胜无量佛国。劝发众生度生死岸。晓了根门随时适化靡所不济。或以世俗威仪礼节。或以神足神通道慧育养生类。分别六情尘劳兴衰。眼耳鼻口身意所起。眼亦无常亦无真实。去亦无处来亦无迹。耳鼻口身意亦复如是。过去当来现在之法。亦不见生亦不见灭。群生愚惑计有常想。何以故。最胜当知。菩萨大士权智普备。行于无量诸度无极。立成信地广修诸法。为诸如来所见称叹。除去妄想得无量智。辩才无碍常怀惭愧。观法无起不见动摇。或以相好庄严佛土。所行与法不相违错。入于甚深一切道智。咨嗟听法亦无厌足。权智只步降伏众魔。或至有想无想之处。或至梵天帝释宫舍。或至十方恒沙国土。所游之方兴有佛法。所设玄远不可思议。除去慢惰亦无是非。尔时世尊复告最胜。菩萨达士修于无量正觉法门。四意止四意断四神足五根五力七觉意八直行。总持强记而无缺漏。以法意止有为无为。有记无记有漏无漏。十力具足诸法无畏。三昧正受断除阴盖。晓了分别不退转地。复以三昧正受之力。超越慧业五十七法。菩萨当念使不忘失。若人布施求诸天福。或求鬼神诸龙宫中。或以施心生四天王。复有欲得生二十八鬼神将军。斯皆不真不获其愿。尔时世尊便与最胜。而说斯偈

  身净不行恶　　口行无四殃
  意法不念罪　　是菩萨总持
  颁宣无量德　　永无悭贪心
  神通除闇冥　　是菩萨总持
  教人布施时　　无令有愿求
  失愿堕三涂　　功劳唐有捐
  吾昔求正觉　　想着经劫限
  方便涉生死　　五道为游观
  复于阿僧祇　　造修立德本
  由不得自在　　游戏四渊池
  今虽得成佛　　独王三千界
  斯缘去想念　　得入玄路门
  道场放金光　　亿神来归命
  随沙门善神　　皆来而自归

是故最胜。当念专意除去想求。解了法界一相无形。修治佛土明慧不断。不劝助业普施一切。无施无圣了无所生。平等一乘不见若干。最胜。复当分别四谛。苦由何生复由何灭。此五阴身苦之根本。以审谛观当求灭之习由苦生尽灭无余。邪疑倒见有六十二。以无量智解无处所。复以四谛观十二缘起从何生复从何灭。渐渐思惟乃知净寂。身口意行亦复无主。亦无受者亦无来去亦无住处。从须陀洹上至正觉亦复如是。分别欲界色无色界。复次最胜。菩萨思惟知苦出要。苦习出要苦尽出要苦道出要。如实思惟。复当分别十六圣法甚深难测。三十六物恶露不净。宣扬无上道果之慧。颁示训诲导之以渐。诸佛深藏靡不贯达。所出言教终不虚发。或现大财殊特长者。因其所施摄取众生。周旋往返令成其道。或以香华光明幡盖。广显照曜皆使周遍。复以神足感动诸天。宣及佛道使趣一乘。故我累劫不以为拘。复现声闻缘觉之道。托居山泽不现灭度。复入龙宫化诸龙子得在道捡。如是最胜。菩萨功业不可称限。非口所宣非意思惟。或时菩萨生转轮王家。天上世界悉蒙将导复受十善。若见众生在饥俭中。辄以甘露令充其乏。荷负众恼离爱欲中。菩萨比像不可称量。复次最胜。菩萨当念千七百定意法门。令诸无著得成正觉。复有光明定意法门。令菩萨逮总持显要。复有道树荫盖定意法门。三千世界蒙获覆盖。复有雨世神珠定意法门。放百千亿无数光明。一一光明出若干种。苦空非身无我音响。闻音声者皆发无上无见之心。复有水精无像定意法门。令十方世洞然一色。加出若干音乐之声。其闻音者自识宿命。知所从来处所窠窟。复有月盛满足光明。在众独曜如月在星。复有日精光明。现众生眼令知进趣。复有威神光明。授大乘决无能知者。复有无见顶相光明定意法门。在众独尊兴恭敬故。复有舌相光明定意法门。处众信用无诽谤故。如是最胜。菩萨所入比像千七百定意光明法门无量清净。即于座上无数之众闻斯法者。发于无上正真道意。自昔以来未曾闻见。是时东方去此无数恒沙世界。有一菩萨名曰宝勇。将诸眷属前后围绕。至此忍土前至佛所。头面礼足在一面立。叉手向佛而叹颂曰

  和颜色殊特　　人中尊第一
  尘劳无垢秽　　施以无量德
  其明照百亿　　鲜洁知无涯
  慈悲一切人　　独步王三千
  我等今日来　　欲闻甘露慧
  愿演时得济　　如渴奔流泉
  导师时乃至　　如彼优昙钵
  我等病根人　　为救为作护
  今我从来处　　去此无数土
  饥虚甚积久　　愿为宣示之

是时宝勇菩萨。以此偈赞佛已。复礼佛足各次第坐。尔时世尊。告来会者。谛听谛听善思念之。吾当分别说于菩萨无生灭行。上中下善戢在心怀。时诸菩萨白世尊曰。愿乐欲闻。世尊告曰。道者非生生亦非道。无想是道想亦非道。无者是道有者非道。无著是道著者非道。有欲成道斯亦非道。无成无欲乃谓为道。意系根门亦非真道。除根门者乃谓为道。时会菩萨。复生此念。云何名为无生灭行。复言是道今言泥洹岂非道乎。尔时世尊。复知大会心之所念。告众菩萨曰。云何泥洹异于道乎。对曰非也。若使泥洹不异于道。何以故。言斯是泥洹斯是道耶。此是无为此是灭尽。此是快乐安隐之处。或复称言此是名色六入。此兴则兴此灭则灭。复是泥洹道耶。对曰非也世尊。佛告曰。善哉善哉如汝所言。道非泥洹泥洹非道。生是灭本然灭非生。道是泥洹之本。然泥洹亦非道也。名色六入亦复如是。尔时众会。闻斯说法无生灭行定意观时。皆逮得无生灭心不复退转

十住断结经卷第四十住断结经卷第五

        姚秦凉州沙门竺佛念译

    神足品第十二

是时最胜菩萨前白佛言。世尊。云何菩萨于施戒忍辱精进禅定智慧有进有退。复有菩萨从初发意至成作佛。未曾处在父母胞胎常得化生。复以神足游诸佛国。亦无国土之想。唯愿世尊。一一分别使将来世诸学菩萨道者知其所趣。尔时世尊告最胜曰谛听谛听善思念之。吾当为汝一一分别。最胜白佛。愿乐欲闻。佛告最胜。若有菩萨行施戒忍心念有想。精进禅智。一切诸法兴想着意。或有世界无世界想。见有众生无众生想。见有去来无去来心。见有现在无现在意。见有着断无著断心。斯是初地根力成就。便当与十法相应。云何为十。所谓如来神德不可限量。如尔一相无所挂碍。正觉名号不见染着。一切诸法不见越度。等现三乘不见所趣不着世界解知名号无去来今。所谓名相。谓一切智亦名法界。怀来道故将护彼志不伤其心。如是最胜。斯诸法者亦无处所。来亦不知所从来处。去亦不知为从何灭。菩萨行戒忍辱精进亦复如是。戒亦无戒忍亦无忍。解知精进不见有进。若人持戒恒护彼短。设见毁戒不以为恨。见戒完具不受用喜。是谓菩萨成就于戒。菩萨行忍心不增减。有人来取菩萨身体节节支解。执心坚固不可沮坏。菩萨具施戒忍精进禅思智慧。其想着断心不怀二。不起不灭兴若干念。于诸罪福平等无二。复当思惟三向梵堂空无相愿。不见空义与相愿合。相愿亦不见与空合。无愿不见与空相合。空相不见与无愿合亦不不合。无相不见与空无愿合。空无愿不见与无相合亦不不合。去来现在亦复如是。复次最胜。菩萨神足非思非虑。龙种境界不可思议。亦不着世复非离世。往来周旋都无住处。愿相诸法亦复如是。菩萨进前修其道果。圣道自然不见边岸。若有人来求其端绪。于贤圣法则为自损。如是最胜。菩萨戒闻慧施六重清净之法。义理深邃得修梵行。若有菩萨得修德本。获斯深法微妙之要。于无余灭度而取灭度。教授众生无去来际乃谓为道。菩萨现入爱欲之中。观察根原而为说法。或时入灭尽定。断出入息永无有余。形体膖胀漏诸不净。众生睹者兴无常想。又观众生有定有乱。随宜示现令得解脱。或以威仪道品之法。训诲一切除其重担。神智五法是菩萨业。十八微细是菩萨业。十六金刚是菩萨业。二十一戒贤圣所修是菩萨业。在树王下思惟三十四法是菩萨业。于施戒等不见吾我是菩萨业。去来现在分别不住是菩萨业。如是最胜。菩萨所修境界难量。解知报应乃得趣道。其有来者随因缘合。声从空来耳识往听。言教书疏非真非实。随缘合会随缘散落。缘合则合缘散则散。散不自知为从何散。聚不自知为从何聚。是时最胜前白佛言。善哉善哉。快说斯法种种分别说缘本末。为诸菩萨被大德铠。令无数人发大道意。称叹菩萨功业所趣。及如来号十法德义。诸来会者咸得闻知。如来智业无所挂碍。若有菩萨闻斯法者。阴衰诸盖永得消除。使诸众生靡不通达。我等世尊。自今日始奉尊如来所训道教。纯熟之行不敢放逸布施调意。恒常分别一切文字。章句义理悉现在前。心怀平等如空覆盖。所行慈哀普周一切。随其根源而开化之。常以四等加被众生食以甘露。弃除一切恚恨结使。放舍十法去离三毒。拔其九恼乱想之法。死魔尘埃伤害人心永使无余。分别十二因缘之本。从痴缘行至生老死。复当思惟缘起所趣。痴灭则行灭至老病死亦复如是。随其种类察其根原然后投药持心坚固。明审众人心所思念斯为善行。重为说法不令流驰。秽浊众想不复兴起。是故最胜。菩萨宣布所设言教。多所饶益多所成就。视彼众生如母爱子。随时将养无增减意。恒在正见不随异学。在大众中如师子王。思惟体中地水火风。地动则水微。水动则火微。火动则风微。四法动者诸情衰微神离其身。临时宗亲有何恃怙。唯有善法乃可凭耳。复当思惟深观之法。诸佛所游正受三昧。顺其本则不失威仪。分别有无漏失之行。超越世间八法之业。利衰毁誉不染其心。计我人寿命都无处所。最胜当知。若有众生怀倒见心。来诘菩萨所行法则。若从一劫至百千劫。承受一住菩萨所说。言辞流利无能障塞。是故当知。菩萨所行无能及者。不可以譬喻为比。所以然者。皆是菩萨神足变动之所设为。往至十方礼事诸佛兴敬供养。从一佛国至一佛国。所至到处辄为众生兴显道法。蠲除一切始终之难。诸有怨储遭苦恼者自然消灭。所以眷属成就者何。皆由舍弃憍慢自大。或时在于大众之中。其声流利若如梵音。使三部众获其志愿。趣使引入无为究竟之地而灭度之。亦如大龙兴无盖云。雨于三千大千世界。百谷草木普蒙其润随时滋长。菩萨大士亦复如是。畅一音声以八解脱法味之水布道法教。使三千世普蒙其度。其解脱者志若金刚内外清净。复以神足禁戒法律。自璎珞身众相炳着如纯金山。所经过处令各得所。其闻法者笃信不疑。复令众生入觉意三昧。使三千大千世界其中有形之类。蜎飞蠕动自识宿命。皆令众生觉本习绪知苦所由。因是皆发菩萨之心。奉遵修行如来正受。是时闻法众生用心精勤。承佛威神明识来趣。随其远近尽来趣至净妙道场。至道场者其志坚固入无所畏。不复恐惧其志究竟。利根众生或经一日二日三日。乃至七日舍其形寿。而取命终皆生天上。其德纯熟行不缺者。便生十方诸佛刹土。生天众生自取天上若干种华。及诸杂香所有自然供养之具。而来供养散诸大众及来会者。花处虚空皆不堕地。化成自然宝交露台。以大音声而自赞叹。我等善利快蒙斯福。乃能遇此觉意三昧。使三千大千世界获其所愿。如是世尊快得善利。复以香花别供养最胜菩萨。今蒙仁恩得遭值此觉意三昧。使我等身咸蒙庆会。其有众生得闻觉意三昧不笃信者。当知此人乃前世时。不遭此三昧之所致也。是时世尊告来会者。吾昔无数阿僧祇劫行此三昧。使我今日得成阿惟三佛。过去无数恒沙诸佛及当来者。皆当修此觉意三昧。三昧威德不可称量。其闻名者悉皆启发菩萨大心不可复计。四部之众皆逮此三昧定意。复有百千诸来会者。即于座上皆发无上正真道意。尔时世尊。复放觉花定意三昧光明。照彼三千大千世界地狱饿鬼畜生之类。众苦消灭皆得还生在人道中自识宿命。是时座上有四亿众。见此瑞应各生患厌。心自思惟夫生有死皆由因缘。死此生彼牵连不断。淫之为源斯由贪爱。我等愿乐生无欲国。乃得修此觉意三昧定意正受。是时世尊。知来会者心中所念而告之曰。西方去此无数佛土。有佛名无量寿。其土清净无淫怒痴。悉同一心皆由莲华中生。不因父母情欲生也。纯是童男亦无女形无大小便。以禅悦乐法无想念识以为饭食。共相敬念如父如母。欲生彼者可发誓愿。时四亿众即于座上。同心发愿求生彼土。尔时世尊。即如其像放觉意三昧光明照彼国土。使四亿人得见彼土如来世尊及化生菩萨。其国广博纯金银琉璃众宝杂厕。无三恶道八难之苦。见彼国已。此四亿人随其形寿。皆得同时生彼国土而得修此觉意三昧。斯由本誓发愿所致。觉意三昧之所感动其德如是

    恭敬品第十三

是时最胜菩萨复白佛言。云何种类菩萨常从佛闻法而兴恭敬意加勇跃不能自胜。世尊告曰。斯法要者犹那提神药。若人服食斯神药者。心神悦豫自然濡满。淫怒痴除无复众病。其闻此法一句之义至大乘者。超出妄想得离恶趣。志愿自在未获者获。诸根具足未常缺漏。若使有人专心一意勤修正行。无他余念而顺其法。诸尘垢病自然消除。若善男子善女人。得音响信加敬正法。树下端坐一心思惟。设意倒错复从一始。若意不定当自克责。有何不及恶心不除。勤苦劫数不在道捡。何日进成而获无漏。因平等法得蒙度脱。如是最胜。夫顺法者。不居三界亦不离之。复以三观七露明禁而自防慎。常悔前过将来不造。当得诸佛十八之法四无所畏五根五力禅脱定门。其所说法平等无二。身黄金色相好自严。种种功德以自璎珞。音声言训达于十方。是谓最胜菩萨大士当获十法功德。云何为十。所闻正教专意思惟。从善知识亦不违慢。不自大不自下恒处于中。所施行业终不虚妄。谛入深慧意亦不乱。欢喜念施心悦无悔。若前布施无所选择。达于苦际宣畅无我。神通自游不失善权。是为十法获十功德。尔时世尊便说斯偈

  闻教专意听　　慎道无想愿
  凭受善知识　　施念无悔吝
  爱彼犹养已　　高下随颜色
  一心念恭敬　　获十功德福

最胜当知。善权适化智度无极。逮于菩萨大乘方等。如来出世愍于俗故。而现若干行法不同。或现缘觉声闻之乘。或在山崖深窟自隐。或复经行而自克责。挍计身中无一可贪。由是之故当自思惟。斯为如来之所开化。信吾言者而在心怀。于现法中即得灭度。虽在异学不改正行。为诸异学讲演法鼓。其法无想亦无诸念。令其众生尽诸有漏。诸有会者致微妙慧。行有若干志性不同。如是之比不可称计。好慕听经非图一类。舍真就伪亦不可计。现在目前其数难量。或有菩萨专观脱门。虽行备具贪在灭度。所以然者。未解善权故致留难。如来神足导引使知。方自觉寤非菩萨行。复为波旬之所扰固。复从是退还在凡夫。最胜当知。如来昼夜三达观察。谁根闇钝退不进者。谁复进前上菩萨位。退如恒沙进如毫毛。心复自知而无神通。夫人初意其心坚固。设当成者众生根断。无为之法定无生灭。众生疑惑谓为非真。善权方便务于真谛。愿乐欲听无从法忍。十二因缘法之深要。先当分别解空无相愿。达知无常非真非有我人寿命虚无寂然。佛复告最胜菩萨及众会。又自念吾昔未成佛时。为诸如来所见训诲。复加威神所见接导。亦是本愿行念所逮。得蒙清净志趣安隐。今成如来平等正觉。众行具足出现于世。斯由执意不退转故。诸菩萨众亦无央数。神足之变不可限量。降伏于魔无余侥幸。若至城廓郡县聚邑。其众生类睹见吾者。执意听经亦无他念。兴隆三宝使不断绝。欲求法者皆得充足获安隐行。佛复告最胜菩萨。若有众生信从法教空无相愿。当行三十六事令不堕损。云何菩萨行三十六事令不堕损。于是菩萨。分别三向亦不怀恨。虽处爱欲无所染污。观于无常亦无观想。心行清净不失法性。求诸脱门法诸贤圣。怀来道故而济众生。妄见已断悉知无常。应无所著等正觉行。随缘起灭除去缚着。所施为事不自为已。解知人本本无出生。寿是磨灭恒不久住。命逝变易如幻如化。过去永尽不见纵迹。来无形像复当受有。现在流驰靡知所趣。知业慧明神识不住。空慧止处缚解无缚。勤修三事复修除三。不猗空慧受其果证。将养形命令至道场。于欲无欲亦不离欲。诸佛正受恒现在前。往来周旋不生无想。志常着在诸神通慧。深入法藏不见所入。灭尽无生以为屋室。如如如尔无形无相。本无有际际亦无际。常不有常思惟无常。虽见生死亦不见生。入于五道解无五道。尘劳为缚己已离之。自守无为无悕无望。度人如空空无所成。身行口言无无所损。是谓最胜菩萨所行三十六事上妙之法。非是声闻缘觉所及。当善察之为人解畅。无令众生有诤讼心。所以然者。希有众生能信之者。夫能宣畅缘业之法。斯乃应于无生之心。若观众生意不坚固。便当渐渐开使得解。得失虽殊亦当下意勿得称已。设复有疑以本无观。三世平等等无差特。亦不见等亦不见无等。见亦无见亦无复见况有色相。色自无色本无有色。色识无识岂有识耶。耳声有识受外音故。鼻香起识自生臭恶。舌味生识分别好丑。身细滑识因彼粗涩。意法兴识由前善恶。了达诸法无住不住亦不见住。最胜当知。吾我所有诸法所有本悉清净亦不见净。诸法吾我本无所有不见所有。无亦自无亦不见无。慧解菩萨皆无所有。菩萨解慧不猗身口。亦不自高复不自下。从本至竟了达自然。如是菩萨解空慧义。便成无上正真等正觉。多所建立多所饶益。尔时座上诸来会者。四部之众及八部鬼神。心怀踊跃不能自胜各兴恭敬。以天香花意花大意花散于佛上。及散诸菩萨大弟子上。悉在虚空罗列而住。作唱伎乐自然而鸣。复有诸天侧塞虚空。皆发大声自然雷震。皆自叹曰。今所闻法自昔未有。为诸菩萨讲论法要空无之法。所造言行意皆坚强。前在鹿野苑中。与诸天世人所转法轮盖不足言。今闻如来说空无法无生无灭。最第一义世之无双不可称量。自昔闻法未如是也。善哉世尊。使我等心永无犹豫。疑网悉除无余结恨。是时世尊。告来会者。慧解菩萨为一切众生故。心不去离诸法之本。况当远离空无之法。此事不然。菩萨习学不当兴意生于是非。若在诸法念无所著。法实甚深不可思议。习智浅者用无黠故堕四颠倒而兴阴盖。以去持入复生十二缘着以生。便与六十二见共相受入以生受入。复与一切诸尘劳垢而共合同。如是菩萨常当远离。不与同处亦不离之。从痴至死世间乱想及意所念。若见精进心不慕及。诸见懈怠亦不慢惰。有奉戒者复不有异。见毁戒者意等无二。忍体满具嗔致恶道。一心不乱诸想不兴。智拔济苦永尽无余。恒当远离一切诸念去其世事。云何为世事。所谓五阴六衰四大四患。十八本持十二因缘。与心不相应者。是谓世俗法。佛告最胜。若有菩萨于三世中而行布施。亦莫思惟过世受报。不念过世所施财物。亦复不念过世受物之人。不念过世所施之处。所住屋舍不念种姓。生某家字某亦复不念。

尔时所施今乃获报。设今造福后报倍胜。如是菩萨。为不成就为堕边际。为在魔界为断佛种。终不至无上正真之道成最正觉。所以然者。有想着故。想着施者非真实果。若复菩萨念现在施及当来施。常当牢意无众乱想。或时菩萨给施所乏衣被饭食。床褥卧具病瘦医药。随其所须而不有逆。欲成无上等正觉者。解诸法空了达为一。空法无相空法不生。无造无作无所施为。不见来时亦不见去。以法性空观了无形。戒品慧品定品解脱品解脱见慧品。三十二相八十种好。法界如法界定。法界观法界无著。佛如佛定。佛观佛无著。佛者无我亦无所生。道意意明。法意意明。众意意明。此十三行无漏慧观。当来过去现在十三。佛以睹见一切诸界。分别其界无来无往。不见出生法自常住。亦不见动亦不见转还。一切众生自起识想。有不信者而取化之。三场清净修如来室。诸法若干行不究竟。所说亦异受者不同。欲净三场及五眼者。现转法轮无碍之想。先行十三无漏之观。是谓最胜菩萨摩诃萨无碍之智无碍慧根。为众生故示现法界姓字名号。无量无限不可思议。皆是善权智力所及。是时最胜复白佛言。云何菩萨入定三昧。修行善权摄智不乱。佛告最胜。于是菩萨入无著定。身意口教无所挂碍。观诸佛土如掌观珠。化育众生亦无所著。放大光明导引一切而转法轮佛力无碍。或以菩萨以为眷属。复以佛智自璎珞身住如佛住。游至诸国如佛所游。净诸刹土以佛之度而度脱之。其心盟誓以教教人以智训人。是谓最胜诸佛所入定意三昧。所游所行不可思议。不恐不畏无所忌难。听无厌足心不转还亦不疲惓。不舍当归堕于余法。何以故。以其菩萨在诸法中志意旷大。弘誓之心不可沮坏。发心起学修佛正法无底之源。加被众生而不舍离。解众生空诸法亦尔。诸法空者道性亦尔。善察众生进趣来往。以大慈心遍满一切。三世诸佛所行法则而不差违。无形像法而悉成就。所以者何。犹如男子以意宝珠悬着空中。其有观者莫不欢喜。色甚微妙所照无碍。自不言我广有所照。菩萨大士亦复如是。以心宝珠出智慧口。一切智光普照三千大千世界。亦不自言我今慧光能有所照。何以故。然此菩萨为彼众生不自为己。欲使众生至解脱门。以佛圣印而印可之。净诸佛国为诸众生。而作覆护离一切念。其智慧眼无微不照。明生死本去来现在八法功德。及漏尽通想知灭尽。罗汉缘觉所不能了。菩萨觉知法性所觉。如幻如化热时之炎。芭蕉野马呼声之响。镜像水月泡沫梦现。皆不真实。此五盛阴苦空非身四大合成。复当思惟地水火风空识六事处在三界。欲界色界无色界斯是死界。泥洹法身乃是真界。解生死界及泥洹法。一而不二亦无若干。四大吾我亦复如是。吾我空者诸法亦空。诸法空者六思念法亦复如是。不堕倒见不处生死。亦复不念中道取证。是谓菩萨深了法要。所度不虚受养不妄。安隐处道而无唐捐。复有菩萨用四等心。深究生死无底之源。救之以财恤之劝道。大慈菩萨举目成宝。山河石璧树木茎节悉为七宝。便用广施令得道证。菩萨于时观察众生有着苦者。为说五阴为苦为老为无真实。习色着苦灭习成道。苦义众多习为原本。斯二事尽乃谓为道

    勇猛品第十四

尔时最胜菩萨前白佛言。云何菩萨初发心行无能断者。云何菩萨意识安隐不可舍离。是时世尊告最胜曰。初发意菩萨当学所学。不滞生死不畏吾我。虽处过去当来现在亦不畏惧。便能勇猛毁坏邪见。初闻法味信根成就。意常系在灭尽之处常离世业。唯慕无上正真之道。咨叹经典听之无厌。设遭苦乐不以为惓。所以然者。其心牢固不可移动。或经一身二身三身。应时逮得如来正受三昧定意。复得信受不妄三昧。复得想持受决三昧。渐渐便至无所从生不起法忍。以是名曰发意菩萨内心所行无能断者。菩萨专意不着色相。不念是常非常有苦有乐。若好若丑若远若近。亦复不念过去当来现在之法。亦复不念吾当成佛典领三千大千刹土。不念有想不念生想着想染想结想心想。无量门受其妙法。不还亦不见还。不厌亦不见厌。不足亦不见足。不废亦不见废。无舍无坏。无见亦不有见。不增亦不有减。不异亦不有变。不自然行非不有行。所以然者。言自然者。虚空法界之所摄也。如是菩萨无限无量弘誓之心而自成就。不厌不患亦不退转。赐欲度脱一切众生。所以然者。菩萨欲度一切众生使般泥洹。住十七劫不舍不离。分别三世诸法虚寂。诸法空诸法无我。何以故。欲从此至彼故。菩萨大士至虚空界以天眼观。依地大住众生多耶。虚空界众生多耶。然观虚空众生。不可称计无有边限。天眼菩萨复更思惟。吾今所观极为玄远。宁从四天下绕须弥山。其中所有虚空无形众生多耶。为有形众生多耶。佛告最胜。天眼菩萨犹不能知无形众生之多少。所以然者。非彼境界。今吾引喻重解斯义。有明目者。当了此譬。犹如辟方八肘虚空上下俱等无空缺处。算计其中无形众生。与四天下众生共等。欲知数者从一数至亿以亿为一。复从一至亿还数亿为一。如是数至七。欲知无形虚空众生限者其数如是。复告最胜。天眼菩萨观虚空无形众生之时。犹如人观辟方大石。上下俱等实而无缺。故不知数。发意菩萨从初起学上菩萨位。当度尔许众生心不移动者。当知不为魔所扰固。游于三界凭善知识。恐畏之难亦不复生。其有菩萨住于是者至诚受莂亦不复久。行权方便兴发劝助。指授泥洹说灭度决。加说四谛如来印章。一一分别而示其路。若有众生不肯觉寤。无数方便以为唱导。习痴所惑而致诸苦。能断爱欲乃应无著便得越度正觉。所有圣贤默然则为解脱。所名解脱解脱生老病死。彼亦不死亦不为死。彼亦不脱亦不为脱。何所解脱。无著无缚无灭无生。无所成无所办无所逮乃应正道。众生迷塞不时开解。如来哀愍现出于世。在所游处便现导师。闻法众生至不退转。若有欢喜奉持正法。便逮无生不起法忍。发意菩萨常念思惟。眼耳鼻口身意分别六衰。为从何生复从何灭。法自生法法自灭法。不见邪不见正。不造不作不见是我所非我所。不依内性自观。不依外当分别。复当思惟。色痛想行识不过去色。过去色不在内不在外。不两中间得。不过去痛想识行。过去痛想识行。不在内不在外。不两中间得。不过去色住。不过去色不住。不在边不在此。不过去眼耳鼻舌身意法。过去眼耳鼻口身意法。不在内不在外。不两中间得。不过去意想知灭。不在内不在外。不两中间得。当来现在色痛想行识。眼耳鼻口身意想知灭。亦复如是。复次最胜。菩萨大士以神通慧修无碍道。一切诸佛功德慧业尽共计之十倍百倍千倍万倍。不如发意菩萨安一众生发无上道心成一切智。具足一切诸佛之法。妄想已断无复狐疑。诸天世人无不恭敬而礼拜者。达知诸法幻化非真。一切有形进趣于道。便获如来神足之力。是时座上十四亿众。渴仰如来神足之德。迟见如来现其威变。佛知众会心中所念。即于座上放大光明。身诸毛孔亦放光明。一一毛孔放百千亿光明。一一光明有百千亿夜光神宝。雕文刻镂众宝杂厕。众花杂香而覆其上。宝四角头悬四香璎一一宝上有百千亿帐。一一宝帐有百千亿自然莲花师子之座。一一座上有百千亿殊异之色。一一色中有百千亿摩尼珠宝在莲花上。一一花上复有百千亿种种殊异宝交露盖。一一盖下有百千亿如来说法。一一如来有百千亿诸佛刹土。一一刹土有百千亿自然浴池。一一浴池有百千亿凫雁鸳鸯自然游戏。尔时宝交珞台诸如来无所著等正觉。复放百千亿光明。一一光中复有化佛。一一化佛各说发意菩萨所行功德。十二因缘无常苦空非身之法趣泥洹门。一一门中转百千亿不退转法。古昔未转今日如来而为转之。现佛威仪神足变化。未曾所见未曾所闻。不可思议不可称计。是时诸来会者。叹未曾有甚奇甚特。是我等福乃能见此神足变化。燃法炽法。无尽之化如来。如如来藏。不住于住。无形像无根本。不得得不获获。甚深玄远。实而不虚。智慧广博。除去愚惑亦不破坏。成就法界。当来过去现在诸佛之法皆现在前。出如来力增益诸佛国。为佛意印出生菩萨道。于现法中为净眼法王。慧眼清净。种性纯熟。佛眼无碍由慧眼知。分别句义而开法门。与善知识成就道心。不毁境界不败种性。为一切众生而作覆护居家成就。若处在众无所畏难。所兴巧便无适不化。名德清净无复悕望。胞胎均政。增上智业兴无盖云。智炽猛火烧疑结聚。阐扬政教振于道场。慈悲四等总持审谛。九观六业勇力无畏。信念慧定行训无尽。入三昧定由观十方。礼拜恭敬供养诸佛。是谓最胜菩萨大士心难沮坏。犹如菩萨性空自然。有目之士知是为空。空不自知言我自空。菩萨行本亦复如是。度人恒沙复过恒沙。及至诸佛所游刹土。而度众生非算所筹。菩萨不自念。我今乃度尔所众生。使至涅槃寂然无为。亦不言我缘斯果报。当成无上正真之道。发意菩萨执心牢固。从初发迹乃至道场。坐树王下降伏魔众。其中所作功祚福业。尽为众生不自为己。犹如虚空普覆无外。然不自知言我是空。如来神德智慧光明。周接黎庶使成法眼。无离无著一切诸法不可沮坏。无人无我以智慧明善权利剑。一切诸佛所用正教。无量功德除去疑网。菩萨大士之所修行。菩萨所行净三梵堂。无空不空。空亦不生亦无所有。无人无我无寿无命。亦不见生亦不见死。独步无侣无可思议。不毁境界。无想亦空。不生亦不见生。亦不见出。无去无来无作无造。法界无量成道场业。空界无边无所缚着。为众生故故作处所。是我所非我所。起吾我想菩萨执意依善根本。无量智慧而净其道。去心垢意以智慧除。如是最胜。菩萨入净观三昧。观察十方恒沙众生。谁应法行。谁应智行。谁应净行相应。若有众生应受法者。便当与说二十五法。云何为二十五。诸法无相。诸法无形。诸法忍。诸法想。诸法无根。诸法境界不可得。诸法无所取。诸法不二入门。诸法无度。诸法不可断。诸法甚深不可追寻。诸法觉不觉者。诸法力不可坏。诸法成不成者。诸法无毁而毁。诸法无常去常。诸法无染污。诸法行净。诸法性观。诸法无漏。诸法过去已舍。诸法拔疑去网。诸法无从生慧受决。诸法本无无苦名。是谓菩萨清净修行二十五法。复次菩萨。行三忍智。过智。无过智。亦不过亦不不过智。云何菩萨修行过智。不坏法界身是本无。如来之所修行。非缘觉罗汉之所修习。无过智者。增上慧明。贤圣缘觉之所修行。非佛罗汉之所行也。亦不过智亦不不过智。阿罗汉之所修行。非佛缘觉之所修行。云何过智。是佛所行非罗汉辟支。于是菩萨弹指之顷。以智慧念。我当弘济无底众生。无边无崖缘想智业。金刚正受亦无转还。弘誓之心过出罗汉辟支佛上。是为过智。非是罗汉辟支佛之所修行。云何亦不过智。贤圣辟支佛之所修行。于是菩萨发心起学。欲净法界导引众生。宣畅佛法演甘露慧。为无上道求诣道场。若有众生直从一径至菩萨所。头目髓脑国城妻子。意所爱物尽用惠施给与乞者。除父母师长。施果不求报。如是一世至百世。一劫至百劫。财物惠施亦不见物。物是谁许为从何生。本从何来灭至何处。解物无本。不见住止屋舍。时此菩萨以空慧观。亦不见身亦不见物。亦不见人。亦复不见何处惠施。然此菩萨积行殊久心意捷速。欲成无上正真之道。慕度众生净佛国土。然此菩萨心乐闲静常处山岩。意想静寂系念在前。内自思惟。前后所施众德具足。应成无上正真之道为最正觉。然佛出世众相严身。广济众生至无为岸。要须大圣于无余界而取灭度。然后我当进成佛道。佛告最胜。彼菩萨心所念所行愿不违错。如来在世教化周讫。于无余泥洹而般泥洹。正法灭尽世无复佛。一劫二劫或至百劫。山泽菩萨方自克责。咄哉所为唐劳其功。佛去世久像法灭尽。宿缘众生尽为所在心怀烦恼。周章经行诣一树下。以右手指爪刮于树皮。正值空处騞然有声。心霍然寤。便成无上正真之道。左右顾视不见翼从。隐形匿相不转法轮。如凡常人。人间分越。是谓亦不过智贤圣辟支之所修行非佛罗汉也。云何亦不过智亦不不过智。罗汉所修非佛辟支佛耶。于是菩萨从久远以来积行勤苦。欲得无上正真之道为最正觉。行施行忍行精进行禅行智。或施头目国财妻子仆从给使。有所求索不逆人意。但刺身出血多于四海。体骨布施遍四天下。然于其中不获其证。渐渐却退在凡夫行。厌患生死心不猛进。忆本所作内心窃悔。趣欲脱身捐舍众生。久久方便求师咨受。承声闻法乃得觉寤追前功劳想责无逮。是谓亦不过智亦不不过智罗汉所修非佛辟支佛也。云何菩萨净行相应。是佛罗汉辟支佛之所修行。所谓净行者。净三场。净三眼。净三聚。戒净定净慧净解脱净解脱见惠净。从三善法至十八无漏之法。道俗善法皆悉清净。佛辟支佛阿罗汉修此净行。至成得道不有中还。众想不兴亦不可见。不起不灭亦无识止。有终有始便有窠窟。达无终始岂有处所。时最胜菩萨复白佛言。世尊。云何离欲菩萨心无增减。亦复不念是苦是乐是好是丑。亦复不念前后中间。去来现在禅止三昧。复不自念吾于欲无欲。

尔时世尊告最胜曰。无欲菩萨游处欲界。周游往来说法教诫。心虽无染如处煻煨无底火坑。愍彼众生结着四流没十二海。欲求出路不知当如趣。内心堪忍不以为难。分别五阴兴衰之法色痛想行识。思惟四大诸所生灭。水泡野马芭蕉幻化。虚而不真亦不牢固。何以故。甚深之法难可究竟。色法甚深道亦如是。五阴甚深俗法亦尔。俗法甚深虚空界亦尔。善察虚空界及与法界。亦无识想我人寿命。挍计斯者实如幻化。思惟世俗八无闲法。秽浊染污妨人趣道。净观思惟悉无处所。何以故尔。非常苦空非身之法。有目之士能达此者。是谓菩萨心无增减不见苦乐善恶好丑。都无三世缘起之着。地种为刚境界自然。水性为湿性自柔软。火性隆炽性自然热。风性漂摇动转不住。法性观察寂无四大。地水火风为从何生复从何灭。若菩萨分别法界。设地增者。水火风性各各不如。神识自溺渐不相应。地重神轻各欲相离。若水增者。地火风界转转衰微。神辄欲移不安其宅。犹如有人处在静室。意欲出行造余村落。先出右脚在门阈外。是谓地大增也。次出右手复在门外。所谓水性增也。转出左脚在门阈外。是谓火性增也。复出左手在于门外。可谓风性增也。进前趣路。是谓神以逝矣。诣村落者趣五道也。其知是者乃了法界。不坚不柔不热不轻。刚为所在柔为所至。热为所趣轻为所向。如是菩萨分别法界。一一观了亦无处所。思惟法界性自不同。养神长体各自殊异。四大之中火为盛毒。余三大者性自相应。所以然者。菩萨当观内外四大亦复如是。三界众生四大不同。欲寻其原莫知处所。当复思惟六情所趣。其眼亦空眼识亦空。解于空者乃为法界。菩萨大士复当思惟解于六衰。眼之视色色亦无有。前物入色亦复无有。耳鼻口身意亦复如是。菩萨复当学谛相非谛相。道相非道相。空相非空相。云何菩萨学谛相非谛相。于是菩萨审解本无。本无为一而无有二。亦知道证而无有证。不见受证不见不受证。亦不见应亦不见不应。了应不应。是谓谛相。菩萨谛相。在空亦谛远空亦谛。亦不在亦不不在。是谓谛相金刚正受猗空习本取护得尽。解此三事者。亦是谛相。菩萨谛相达内无实。知外无入。不见爱乐不见不爱乐。不见是处非处。亦是谛相。于内不断正见于外示现。若如闲居心常寂静。外若愦乱。知苦等住所适亦等。其谛相者。道证明验五阴空。五阴无主。所从缘起亦复是空。不住不见住慧尽想。不住在疑结亦无住。不在五事不随十善。十恶世间本末。是曰谛相。如是菩萨行谛相者。则不退转。非谛相者。虚空界最第一义。知之为寂缘解无缚。是谓菩萨非谛相也。云何菩萨学道相非道相。犹豫结疑世间不可爱染。自用横害中暴堕苦。是谓道相。现在身作来世受报。不猗师不向善知识。亦是道相。云何菩萨亦非道相。非道相者。三十七品。有为无为法所趣入。不在二亦不远二。不从缘不离缘。不住缘不随缘。不度非不度。不果非不果。不一二三四。乃至十非不十。非所生非不生。非灭尽非不灭尽。非起灭非不起灭。非言教非不言教。非解空非不解空。非思止非不思止。若菩萨察二十四事。观了本末分别在心。不处生死离于缚着。无胜负心亦无强梁。不自举不下人。便应碎身游散三昧。于百亿定为最上首。为尊为贵无过是者。非是罗汉辟支境界。尔时世尊。即于座上三昧正受。其三昧名一意无畏。使四部之众上下齐同。各无他念亦无乱想。是时世尊告最最胜曰。谛听谛听善思念之。吾今为汝分别三昧。使来会者各无狐疑。最胜对曰。如是世尊。愿乐欲闻。乐者令得安隐。佛告最胜。有三昧名散诸结。令无限无量刹土有形众生。除去苦痛无复众恼。复有三昧名勇慈明。使诸众生各无怨储。复有三昧名德充。如来入此三昧。使众生类无饥渴想。复有三昧名清净。如来入此三昧。使诸众生得法眼净。复有三昧名耳根清净。如来入此三昧。使众生类得天耳听。复有意寂三昧。如来入此三昧。使众生类回邪就正。复有除恶三昧。如来入此三昧。使众生类修十善行迹。复有三昧名独步。如来入此三昧。使众生类不怀邪见而受正道。复有趣路径三昧。如来入此三昧。使众生类趣道不迷。复有三昧名成办。如来入此三昧。使众生类舍于恶戒就清净戒。复有三昧名惭愧乐。如来入此三昧。使众生类奉持忍辱。复有三昧名进德。如来入此三昧。使众生类懈慢堕者兴勇猛意。复有三昧名一己无侣。如来入此三昧。使喜妄众生速入禅定。复有三昧名曰降伏。使执愚众生智慧自珞。复有三昧名无穿漏。使无信众生安处信根。复有三昧名总持德。如来入此三昧。使少闻众生而获多闻。复有三昧名威仪则。如来入此三昧。使众生类仪容整顿不失礼节。复有三昧名施恩。如来入此三昧。使着欲众生永无爱欲。复有三昧名以度。如来入此三昧。使嗔怒众生断除恚恨。复有三昧名无惑。如来入此三昧。使愚痴众生亲习智业。复有遍至三昧。如来入此三昧。使众生类不着三有。复有三昧名一切身体形色三昧。如来入此三昧。使十方国土一切众生化作百千亿形色。然彼众生各各不相知。我今最胜略说其要。设当如来从劫至劫。乃至百劫说如来所入三昧者。不可究尽。唯佛世尊乃能畅耳。是时最胜前白佛言。甚奇甚特。如来身相所造变化。不可思议无能测量。以无形善权而自严饰。如来所说所入三昧。昔所不见昔所不闻。若有菩萨闻此三昧名号定意持讽诵者。在所游处常得自在。若复劝助代其欢喜。为以供养诸佛法已。诸声闻等非其境界。缘觉之乘复不能及。若有毁谤斯定三昧。常处闇冥未尝决了。设复人身入无救狱。罪犹鲜微盖不足言。若有憎嫉定意三昧。其罪难量动有劫数。聋盲喑哑终不闻法。虽得为人恒多苦痛。两舌诈欺口不能言。自非菩萨广博多闻。乃能信此正定三昧。若有劝发诵习此定。寻时得见诸十方佛。又我今日讲解定意。志不改易乃应正定。尔时最胜承佛威神复白佛言。今日此众诸来会者。菩萨四部天龙神鬼。备欲得见如来定意所可感动。或能蒙斯多所润泽多所成就。唯愿世尊。垂愍见怜。放大光明照诸十方佛佛刹土。其中纯淑众生之徒。蒙光得化普得度脱。尔时世尊。可其所说。寻于座上。即如其像三昧正受。其三昧名右足指轮定意。放大光明。其光明照此忍世界已。复照十方诸佛恒沙刹土。十方国土诸菩萨等。百千亿众寻其光明来至忍界。东方去此九十六江河沙等诸佛刹土。过此数已国名海宝。有佛名宝净如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。现在说法。彼有菩萨名曰辩聪。不退转大士。见此光明。便往至宝净如来所。头面礼足在一面立。尔时宝净如来。告辩聪菩萨曰。汝到彼土。摄持威仪无失宜则。所以然者。彼土志性刚强所行卒暴勿见苦乐。彼土众生多怀憍慢不顺正法。若见有短慎莫惊惧。能如是者宜知是时。彼佛刹土众多菩萨。自白其佛。我等快得善利宿福自贺不生忍土。是时辩聪菩萨。将十千菩萨前后围绕。犹如力士屈伸臂顷。来至忍界。往至释迦文佛所立。尔时世尊。知而告最胜曰。汝颇见辩聪菩萨及余菩萨不乎。对曰唯然已见。佛告最胜。此菩萨者。义辩第一慈悲喜护。言语柔和志行高远。先笑后言和颜悦色。问不复重所说约少。接度众生如佛之度。成不退转立菩萨道。是时辩聪菩萨及十千菩萨。礼世尊足右绕三匝。叉手向佛而叹颂曰

  声振彻十方　　功德名训称
  人尊所适方　　靡不蒙其度
  佛土界清净　　不闻五道名
  舍彼而就此　　慈悲难喻等
  世尊今所现　　人中实难有
  德积如须弥　　自投于足下
  正使行精进　　一劫至百劫
  不如须臾间　　忍界行哀心
  诸佛兴出世　　先选清净土
  仁尊独能忍　　于此五浊世
  善哉甚难有　　将护平等度
  流教及三乘　　令净身口意
  既成菩萨道　　亦无退转心
  意趣倍精进　　今故稽首礼
  断诸狐疑结　　快修十善行
  诸佛法具足　　所说智海渊
  若在本刹土　　亿百劫导师
  不如在此土　　住劫度一人
  亦游无量刹　　恒沙不可计
  不闻有苦恼　　及八无闲处
  此人多刚强　　众垢以成身
  四谛真如水　　洗浴内外净
  我等信心至　　故远来归命
  欲闻定意法　　愿时敷演之

尔时辩聪菩萨。以偈赞佛已前白佛言。何谓菩萨志意坚牢堪受定意。所闻教诫亦无厌足。云何菩萨言行相应内性柔软。尔时世尊告辩聪曰。谛听谛听善思念之。吾当为汝分别其义。对曰如是世尊。佛告辩聪菩萨。修定心成就四法。使菩萨志意坚固堪任受定。所闻教诫亦无厌足。何谓四法。所谓慈悲四等心不懈怠。所度人民如幻如化。谓佛智慧无与等者。是谓辩聪菩萨成就四法志意坚牢堪任受定。云何菩萨一意趣向言无错乱。佛告辩聪。于是菩萨复当成就四法。何谓四法。菩萨一向说众生空说诸法空。于诸受入都无所著。叹誉菩萨所作功德。分别善恶有为无为之法念行善权。是谓四法。云何菩萨增益善根转多不减。佛告辩聪。复有四法增益善根。云何为四。一曰信。二曰闻。三曰施。四曰出要。是谓四法令菩萨增益善根。云何菩萨心不乱错亦不狐疑。佛告辩聪。复当思惟四法意专不乱。云何为四法。所谓心常专之。禁持礼节。不望利养。不求名称。是谓四法意不有乱。复有四法增益善根。云何为四。所谓四法。教他立信。既施之后不望其报。及护法之主。菩萨言教教授不违。是谓四法之所修行。复有四法。菩萨当念思惟。从一地复至一地。或退或进。云何为四法。教众生类习其善根。远离诸恶。不行愚惑。无舍弘誓意不怯弱。是谓四法菩萨之所修行。复有四法菩萨之所奉持。云何为四。所谓化众生以权方便。立凡夫人在于信地。所度无虚妄。现佛威相而接众生。是谓四法菩萨之所奉持。复有四法。菩萨当念思惟。云何为四。所谓随宜进止。不着服饰。随彼时宜。恒忍苦乐。是谓四法之所修行。复有四法。云何为四法。所谓自伏意性。常发道心。不离善权。专意念佛。是谓四法。复有四法。菩萨当念思惟。云何为四。于是菩萨当念独处。远声闻心及辟支佛意。求法无厌足。所闻正法广与人说。是谓四法。复有四法。菩萨当念思惟。云何为四。求宝给穷乏。医药疗治病。求义无厌。忍一切苦。是谓四法。复有四法。菩萨当念思惟。云何为四。行不起忍。超灭尽忍。思惟根本十二因缘。于忍不着忍各各自离。是谓四法。复有四法。菩萨当念思惟。云何为四。思惟恶露不净之观。数出入息。行清白法。当自谦卑。是谓四法。复有四法。菩萨当念思惟。云何为四。当观应法众生然后投药。常念恭敬无得自高。若在大众不着利养。行权方便所适无碍。是谓四法。复有五法。菩萨当念思惟。云何五。受平等法而不遗漏。观己彼身等无有异。与善知识从事。永断结使令无有余。是谓五。复有五法。菩萨当念思惟。云何为五。自省己过不见彼短。若在恶部使行慈心。燃炽诸法去其缘着。道心牢固终不忘失。亦使前人行其道意。是谓五。复有五事菩萨当念思惟。云何为五。施恒在前。次复教人使行惠施。执心施时亦不选择观众生是非。诸法甚深皆得解脱。至成作佛庄严道树。是谓五法。复有五法。菩萨当念思惟。云何为五。知行起灭。于力无畏不舍众生。分别众智。亦知增上知。不相违背。是谓五法。复有五法。菩萨当念思惟。云何为五。在五道中永度无极。供养诸佛礼事恭敬。入慈三昧以自娱乐。佛智无量现在目前。无量三昧亦不疑难。是谓五。复有五法。菩萨当念思惟。云何为五。发弘誓心终不中悔。言从语用言不妄发。依禅不着禅。念持不着。游处当不乐。是谓五法。辩聪菩萨菩萨摩诃萨。修此定意本行。便得如来正受。尔时世尊说此法时。二亿诸天世人发无上正真道意。复有五千天子得不起法忍。是时诸佛刹土诸菩萨等。各赍华香而兴供养。花至于膝

十住断结经卷第五十住断结经卷第六

        姚秦凉州沙门竺佛念译

    碎身品第十五

佛告最胜。菩萨摩诃萨入碎身定。使菩萨入此定。具足十种如住。何谓为十。一切世界如如住。一切诸方如如住。一切劫数如如住。一切众生如如住。一切诸法如如住。一切诸菩萨行如如住。一切菩萨愿中如如住。一切众定中如如住。一切诸佛世尊如如住。一切地界如如住。若有菩萨得此碎身定者。便获此十如如住。云何菩萨入众生碎身定。于是最胜。菩萨摩诃萨入碎身时。先入身内定从身外起。入身外定从身内起。入一身定从异身起。入异身定从一身起。入人身定从阅叉身起。入阅叉身定从龙身起。入龙身定从阿须伦身起。入阿须伦身定从天身起。入天身定从梵天身起。入梵天身定从欲界身定起。入天道身定从地狱身定起。入地狱身定从人道身定起。入人道身定从余道起。入千身定从一身起。入一身定从千身起。入亿身定从一身起。入一身定从亿身起。入阎浮里地有形众生定从瞿耶尼有形众生定起。入瞿耶尼有形众生定从郁旦曰有形众生定起。入郁旦曰有形众生定从弗于逮有形众生定起。入东方有形众生定从三方有形众生定起。入三方有形众生定从四方有形众生定起。入四方有形众生定从一切诸海有命形定起。入一切诸海有命形定从海神身定起。入海神身定从海水种定起。入海水种定从海地种定起。入海地种定从海火种定起。入海火种定从海风种定起。入海风种定从四大定起。入四大定从无有法定起。入无有法定从须弥山定起。入须弥山定从七宝山定起。入七宝山定从百草树木山川石壁定起。入百草树木山川石壁定从净洁香花一切宝器定起。入净洁香花一切宝器定从一切四方上方下方一切众生所乘服食具定起。入一切四方上方下方一切众生所乘服食具定从三千刹土有形众生身定起。入三千刹土有形众生定从三千大千刹土有形众生定起。入三千大千有形众生定从亿百千及三千大千刹土有形众生定起。入亿百千及三千大千刹土有形众生定从无限刹土有形众生定起。入无限刹土有形众生定从无数刹土有形众生定起。入无数刹土有形众生定从无量佛刹土有形众生定起。入无量佛刹土有形众生定从无边佛刹土有形众生定起。入无边佛刹土有形众生定从无称佛土有形众生定起。入无称佛土有形众生定从不思议佛土有形众生定起。入不思议佛土有形众生定。入无限无量不可思议佛土有形众生定。从无限无量不可思议佛土有形众生定起入极远有形众生定从极远众生定起入极近众生定。从极近众生定起入眼入定。从眼入定起入耳入定。从耳入定起入眼入定。入鼻入定。从舌入定起入舌入定。从鼻入定起入身入定。从意入定起入自入定。从自入定起入他入定。从他入定起入自入定。入一切有形众生定从阿僧祇刹土复及无限无量不可称计刹土定起。入阿僧祇刹土复及无限无量不可称计刹土定从一切有形众生定起。入声闻定从辟支佛定起。入辟支佛定从声闻定起。入自身定从佛身定起。入佛身定从自身定起。入一念定从百亿劫定起。入百亿劫定从一念定起。入现在定从现在定起。入过去定从过去定起。入未来定复入三世定。如是菩萨随所入定。随所从起。入虚空界定从虚空界起。最胜当知。犹如有人为鬼所著。随彼鬼神持身所诣不自觉知。然彼鬼神托彼人身不自现形。菩萨摩诃萨亦复如是。意入内定从外定起。入外定从内定起。犹如有人身死神去无所依猗更不动摇。身亦不知神之所在。神自受形不知故身今为所在。最胜当知。菩萨摩诃萨亦复如是。初入有定分别等观。复入空定永不见有。前生后灭各不相知。菩萨复当观。犹如心自在度无极人。一身能化作众多身。众多身还合为一。识不从一身没即时生众多身。亦复不得识从众多身没生一身中。不从一至众多。不从众多至一。菩萨摩诃萨亦如是。入一身定众多定起。入众多定一身定起。譬如地界所润以水为本。所生万物各各不同。人界鬼界悉同其润。万物亦不自知我为所生。水亦不知我为所润。菩萨摩诃萨亦复如是。得是三昧。一为无数无数为一。无数不知所以为一。一亦不知所以为无数。是谓最胜菩萨摩诃萨一切众生碎身三昧。第八菩萨之所修行。住是三昧者。菩萨便获佛十号。加十功德而见叹誉。云何为十。所谓号如来。如如修如。号名为佛。佛者于诸法悉觉知。从此岸至彼岸。号名最胜。众生尊贵兴供养故。号名一切智。于一切智德悉具足故。号名无尽。为一切众生作覆护故。号名导师。令众生类示其正路故。号无等伦。于一切众生法界及诸众智皆具足故。号曰妙光。一切众生被蒙照故。号曰十力。所愿成办分别法智无著不可污故。号一切现。使一切法同一自在度无极故。是谓最胜菩萨摩诃萨获佛十号及十称叹功德。皆是三昧威神力恩也。菩萨摩诃萨住是三昧者。获十光明而自照曜。何谓为十。谓一切诸佛光明而自照曜。一切世界乘无不乘道场光明以自缠络。一切众生及教诫光以为香熏。四无所畏无量光明法界处所法界光明。出要之明一切无欲除爱之光。化一切众生感动光明。诸佛无猗无染着光。善思光明等正觉度无极光。一切法性如尔真际光。说除结患无上之光。若菩萨摩诃萨住是三昧者。得此十光明而自照曜。菩萨复当善学十无迹行。云何为十。意之所念身无行迹。口无行迹。意无行迹。空欲立处所。无行欲成行。不为有为法。不坏败法。不毁智业习无生智。学不学法应智辩智。无形之智义味清净。是谓菩萨摩诃萨住是三昧。有若干差特能断缘着。从一入若干种定。或起或思惟等分于等分亦不等分。从小至大从大至小。从狭至广从广至狭。屈而使舒舒而使屈。无身使有身。有身使无身。或起或定或定或起。有垢使无垢。无垢使有垢。觉此三昧者。能坏一切境界。如人坏坏瓶。犹如大咒之术防护为验。若干种色若干种声。或为咒所禁。或为幻声所使。咒者使役于神。幻者役于外形。见幻色者眼识所摄。闻幻声者耳识所摄。嗅幻香者鼻识所摄。幻所作味舌识所摄。幻所作诸形质身识所摄。有幻大幻回上为下回下为上。所作追寻。不可思量。意识所摄。如是菩萨摩诃萨住是三昧者。或散或聚现若干变。最胜当知。今当引喻有目之士乃达此耳。犹如诸天与阿须伦共斗。诸天得胜阿须伦不如。是时阿须伦自知不如。便设权计化作浴池生种种莲花。阿须伦身长七千由旬。还隐其形及诸兵众。却退入莲花茎节糸孔中藏。诸天求而不见。所谓阿须伦善解幻法。菩萨摩诃萨亦复如是。成就一切智慧之幻。从一地至一地。智无耗减。彼彼菩萨自相招致。号菩萨者。皆以智慧幻法而摄取之。如是菩萨入全身定。现散法定。譬如有人若在人界若在鬼界以种子着地。随时溉灌令得长大。子入于地果生于上。前子非后子。后子非前子。前子不离后子。后子不离前子。菩萨大士亦复如是。独受有形住此三昧。便能离有不处于有。亦如男女交会。男清女浊识处其中。在母胎中渐经十月。宿行清净福愿追随。形体支节转转充足。六根成就种性均正。识与六根源本各异。六根者受有之相。随行善恶而来受形。寻本来生如幻如化。菩萨大士亦复如是。以增上解脱心。以为父母。智慧之识而住受生。入无有定从有定起。或入有定。从无地而住。便能乘云虚空雷电。随时降雨多所润泽。然彼龙宫不在虚空非龙住处。于虚空中现若干变化。或奣或随使众生类仰而观之。宫舍依地降雨于上。变易之法何其奇哉。菩萨大士亦复如是。住此三昧及幻化之法。入无相定从有相起。入有相定从无相起。如是最胜。菩萨住此三昧。使空为地使地为空。亦无有难。犹如天上水精光殿舍众宝所成。若彼大自在梵天升此殿时。举目观见千世界十千世界。百千世界。三千大千世界。其中所有天宫龙宫阅叉犍沓和阿须伦迦留罗旃陀罗摩休勒。人及非人至三恶趣。须弥山铁围山大铁围山。黑山大黑山及七宝山。江河海源城郭村聚。山川树木药草花实。好丑清浊三千大千所有形质。至虚空界微细之形。梵天于彼宫殿悉遥见之。光光相照亦无微翳。犹如在此人间服饰悬在架上。亦如明镜见其面像。彼天宫者亦复如是。坐起往来饮食睡眠。悉在目前如掌观珠。菩萨摩诃萨亦复如是。住一切众生碎身定者。于诸三昧而得自在。获佛自在定。化众生自在定。游诸法自在定。成就行自在定。具足增上解脱自在定。于诸正受自在定。出入坐起自在定。得诸智慧自在定。弹指之顷以为一劫自在定。是谓菩萨摩诃萨住此三昧者。等正觉十自在定而自娱乐。菩萨摩诃萨显威无畏有十事。云何为十。谓显佛威曜过虚空界不坏精进于诸坏法得度无极。显菩萨行弘誓无畏游如来戏口度无极。显世界净显净虚垢照曜世界。显在众生示不思议。显诸菩萨不断经法。显至佛国供养礼事。显智慧业行本不可思议故。显分别三昧而无所畏。显入微妙定知所进趣以菩萨度而度脱之。显净佛国不断菩萨誓愿之法而自显照亦无所畏。菩萨摩诃萨处在俗中。现佛形像复无所畏。现转法轮为受化故。显诸如来善根之本。立在佛乘皆使成就。显意威足致度无极。复次菩萨摩诃萨思惟不起法忍。一一了达无数无限。亿百千劫所修行法皆悉在前。显法威曜燃炽道教。复次菩萨摩诃萨昼夜日月时节年岁。悉能算知菩萨用心。弹指之顷所用等智。知三世事了无差违现其无畏。是谓最胜菩萨摩诃萨住此三昧者。便能显曜诸度无极得十无畏。在大众中入定正受。碎身如尘善权方便。第八菩萨之所修行

    身入品第十六

是时世尊告最胜曰。复次菩萨摩诃萨。还自观身身持身入。悉能分别了无处所。是时菩萨入身入持法界定意。于诸定中最得自在。身诸毛孔。一一毛孔。入法界定意三昧而得自在。于诸法界示现幻法。知有前世后世分别世法。了知世界亿百千事。无数无限阿僧祇劫诸佛世界。其中好恶悉能达了。观等正觉眷属成就。于净不净亦悉平等。不断善法大乘不损。心意牢固复不移动。于彼一劫百劫百千劫。亿劫百千亿劫。无限无量阿僧祇不可称计。非筹所算非意所度。如是劫数。诸佛世界。入正受三昧。复从中起入此间定。从彼间起游彼世界。便能成熟彼众生行。不失法界体之正法。三世往来无所挂阂。说法教化有限阂者。令知归趣慧眼碎入法。于诸法界而得自在。具足坏耳定度无极亦无挂碍。入鼻入定意不损善权。善入舌根定意解味所著。成就碎身定往来无碍。入碎意定而顺智识。彼菩萨摩诃萨作如是观。作如是知。住此身入定者。便获菩萨十千亿总持。于世转法轮随俗而入。复得十千亿箧藏之行清净无污。复得十千亿根门越一切智。复得十千亿神通周游无碍。复得十千亿定超过众定。复得十千亿神足游至虚空无边际界。复得十千亿力于诸众行渐渐增多。复得十千亿求望永断众想。复得十千亿止处现无所有。复得十千亿显威神变而现在前。是谓最胜菩萨摩诃萨获此十千亿行而不亏损。复次菩萨当念修行十千亿支节璎珞。而自缠裹。复当修行十千亿具度众生者。复当修行十千亿乘。使众生类乘此乘得至彼岸。复当修行十千亿炎定三昧。照曜世界无闇冥处。复得十千亿义辩无应不应。复得十千亿弘誓。有来观者心不移转。复得十千亿信愿无邪倒见。复得十千亿正路菩萨所可往来周游之处。而净其迹。复得十千亿光明从面门出。复得十千亿典训显菩萨德。复得十千亿清净之本而净道场。是谓最胜菩萨摩诃萨无量功德而自缠络。庄严道树不失本际。皆是菩萨趣道之具。若菩萨成就此众具者。便上菩萨位而得称誉。熏以德香为人所敬。所行众中辄得利养。现世德业不可穷尽。若有菩萨住此法界定意自在三昧者。生豪族家不处卑贱。众菩萨等以为眷属。住三昧已。遥见东方十亿阿僧祇等如来至真等正觉名字姓号国土大小皆悉分明。南西北方四维上下。十亿阿僧祇诸佛刹土及诸如来。皆能识知一一姓号。立菩萨行指示。道门。使彼菩萨而净佛土。放如来身无量光明。现如来眼不可思议。如来耳通无能限量。如来鼻通倍不可计。如来舌通广无边际。如来心通非无形观。如来神足无上之法所度无限。如来之道无上中下具成就故。如来名称远流布故。如来法轮常转不转现世转故。如来翼从现咨受故。如来正法无量无能中绝故。如来善根现称叹故。如来行普遍论无堪当故。如来种成就于三世无不降伏故。如来生一切诸法宣示愚人故。如来法处所显现智明故。如是最胜。菩萨摩诃萨现界清净为立处所。以佛重阴雨法甘露。一切诸佛境界。示有言教现诸佛法。幻形不真了诸法性。兴起自然不动转故。诸法形像分别义理。如来无量功德具足不可穷尽。是谓菩萨摩诃萨住此三昧。所游之方无所挂碍。复次菩萨住此三昧。游阴持入亦无障蔽。心为幻法知无量无限无边之法。安处诸菩萨。入此定意自在三昧。便能知诸佛如来等正觉名号姓字。一一名号。至十千亿阿僧祇等诸佛如来。一一名号至百千亿佛刹。安处菩萨身皆在中住。无量无限心想意想。复以无为巧便为立处所。一切诸法亦不忘失得度知见故。常亲近智海希现智故。住亦有处示现诸法无处所故。为立佛处示现广普诸法无前后故。示现根门无碍智慧利法。善用智分别故。不毁威仪为立诸界无往还故。为示现慧处。所净无碍智故。示现成等正觉故。显曜法界无增减故。是谓菩萨摩诃萨住此三昧中。便能发趣于大乘迹。菩萨摩诃萨复当修习十趣海门而无厌足。云何为十。所谓佛海现无厌足。人海动转不动转化无厌足。法海增益智无厌足。善田海生无厌足。住无有法亦无观行神足功德海。无处所亦无厌足。显智明海。执慧无分散故。住根门海。从一地至一地慧无乱错故。住心意海。尽能觉知一切众生。若干种心若干种意。知无量心有增有减。住修行海。具足众愿故。住弘誓海。要成就究竟清净出要故。是谓菩萨摩诃萨住此三昧。便能获此十趣海门而无厌足。菩萨大士之所修行。菩萨摩诃萨复当思惟十第一无生。云何为十。所谓观众生类第一一无生。观天豪尊第一二无生。观最上梵天第一三无生。观世护心不坏第一四无生。观在众生独步无侣第一五无生。观降魔众心定不乱第一六无生。观五趣无形第一七无生。观诸众生亦无染污第一八无生。观尊贵诸佛法第一九无生。观自在出要显曜第一十无生。是谓菩萨摩诃萨当念思惟此十第一无生。菩萨复当思惟。众生界所趣生有十事。云何为十。所谓出家坚固化诸众生。立不退转行精进力。清净无著力无染污一切法空故。休息力成就诸法自在故。成就心心转不转力分别议故。具足自然法力成大智慧故。成办无碍力以说法故。无畏力成就为法立处故。成就意断力未知已知。智成就无二力无生灭故。是谓最胜菩萨摩诃萨。思惟此十力。最大力。无比力。不上不下力。无量力。育养力。不动力。善趣生力。不怒力。智炽盛力。勤苦积行力。是谓十力当念修行。复次菩萨当善思惟十力。云何为十。所谓善入空力。善清净力。善微妙力。善法身力。善世法力。善燃法力。善根寂力。善未曾有力。善觉寤力。善超度力。是谓菩萨摩诃萨住此十力便能摄持定意。菩萨摩诃萨。复当思惟二十力得至定门。云何为二十。所谓大人之力。亲近善知识力。等正觉究竟力。本修善根得亲近力。无量善根被熏香力。得如来度不度力。降心秽垢无生灭力。增益菩萨念不断力。庄严菩萨得欢喜力。助菩萨善不断法力。除菩萨心无缘着力。充菩萨愿无所求力。成菩萨意思惟定力。获菩萨根无错乱力。立法王力。无著无量身力。得善权方便智慧之力。于一切法无畏难力。立众生本不漏失力。于诸众生独步不娆彼力。是谓菩萨摩诃萨住此定者。乃应无所有力。过诸罗汉辟支佛上。乃能入于菩萨定力

    辩才品第十七

尔时最胜菩萨前白佛言。云何菩萨具足众德断众生望。充饱一切令无嫌恨。佛告最胜。谛听谛听善思念之。今当与汝善分别之。菩萨从初发心以来至于成佛。要当庄严清净道场。放大光明照彼境界。幽冥之处皆蒙其光。其见光者心不怀惧无所畏难。心遂炽盛倍加欢喜。增益功德不离净行。自净其行修无上道。使功德业不可穷尽智无边崖。菩萨行法亦无有边行。菩萨乘亦无有底。菩萨境界不可思议。非是罗汉辟支佛所能筹量。菩萨所度复无边幅。成就众德复无崖畔。菩萨所净不舍弘誓。菩萨出要指示道门。欲论菩萨诸法端绪而不可得。菩萨摩诃萨从无数劫方得为菩萨。然后乃成菩萨之道。有来亲近奉菩萨者。增益劝发成菩萨德名称远闻。其闻名者皆来承事宿卫供养。欲为后世良祐福田。若有众生见菩萨者。辄为说法无上之智。前闻法者而无厌足。广布慧明不毁法性。所以然者。闻法众生承受正教倍增智业。颁宣正训无有耗尽。菩萨摩诃萨住此三昧中。便能广布诸善功德。菩萨以无限无量不可称计旷大之意。一一施意随其前缘入三昧定复从定起。自省法性之观。因此三昧而知三昧境界。分别无数三昧。定意观三昧。广普观三昧。无欲观三昧。相观三昧。所现观三昧。威仪观三昧。猗观三昧。念观三昧。待观三昧。喜观三昧。安隐观三昧。护观三昧。出要观三昧。弃舍已生。未生皆舍。应禅悦定意。虽游于定亦不染定。最胜当知。犹如阿耨达大龙王宫殿皆七宝成。阿耨达泉出四大河。四门流盈不伤生苗。泉水清彻亦如虚空之色。是时四河从四门出。而趣四方皆归于海。其四河者。一名恒伽从象口出。二名私头从师子口出。三名私陀从牛口出。四名婆叉从马口出。此四大河从四口出。趣于四方归于四海。恒伽大河者。车磲真宝以为象身流出其水。私头大河者。真金刚宝以为师子身流出其水。私陀大河者。以马瑙宝以为牛身流出其水。婆叉大河者。青琉璃宝以为马身流出其水。此四宝者。皆天上宝非人间宝。此四大河当初出处各各广一由旬。流时庠序寂无声响。一一大河各各右绕神泉七匝皆投于海。七匝中间相去一由旬。间生若干杂种莲花。优钵莲花钵头牟花。须犍提花满愿犍提花。众宝杂珍皆生其中。复有种种微妙熏香。其色香美。若干种宝自相照明。其有睹者观无厌足。珍奇异宝视表见里一由旬内宝宝相照。如摩尼珠靡所不曜。其七重内异类众鸟。悲哀和鸣共相娱乐。复有百种神树药草。香风远布彻彼随沙门境界。然彼阿耨达龙宫殿舍。东西南北各五十由旬。纯以七宝以为挍饰。复以若干种异色摩尼宝杂厕其间。复以摩尼宝珠悬在虚空。以为日月星辰罗列虚空。牛头栴檀薪以用供厨。于宫殿中一日三时雨众香花。优钵莲花拘牟头花。分陀利花须犍提花。满愿犍提花。若干种宝以成宫殿。光光相照明明相续。如彼阿耨达泉出四大河。从四口流趣于四海。菩萨摩诃萨亦复如是。得四辩才无滞之河。分别四道归于智海。如彼恒伽河者车磲真宝所成从象口出水流至于海。菩萨摩诃萨亦复如是。从青白法口出无量义。尽是如来秘藏之箧解畅深义。皆令诸法各得名字。布现法味燃智光明。皆使投于无边智海。譬犹如彼私头大河真金刚宝以成其体从师子口流至于海。菩萨大士亦复如是。演出法辩御佛金刚。护诸生类使得照明。执智金刚投无碍海。如彼私陀大河马瑙宝所成从牛口出流至于海。菩萨摩诃萨亦复如是。演出应辩有疑滞者永无犹豫。亦使众生无诤讼者。随机报应分别义趣。使众生类纯熟其行。皆令归趣无缘着海。犹如婆槎大河青琉璃所成从马口出悉投于海。菩萨摩诃萨亦复如是。得无尽辩思惟诸法亿百千劫于中示现而无穷尽。善法营护将至善道。令诸守禁之人悉归佛海而同一味。如彼四大江河右绕阿耨达泉七匝。趣于四方而归四海。菩萨大士亦复如是。身行成就亦不有左。口行成就亦不有左。意行成就亦不有左。意志所修智慧为首。如彼四河趣于四方而归于海。菩萨大士亦复如是。乘四智慧之辩趣于四方。于是菩萨当观一切诸佛所住之方。承事礼敬不失威仪。复次当现一切诸佛之法光曜。执总持法使不忘失。复次现诸智度。具足菩萨众行之本。复次现大慈悲。处在众生现转法轮。如彼四河绕阿耨达七匝。于其中间有诸杂种。优钵莲花拘牟头花。分陀利花须犍提花。满愿犍提花。及诸香花香熏四方。菩萨摩诃萨亦复如是。从初发意至成作佛。于其中间化导未被训众生。劝进说法至不退转。为演正受从亿百千劫亦无疲极。一人不度终不舍之。净佛国土严治住地。入师子步定意三昧。进向道树意如金刚而无异难。如彼阿耨达泉七重之内生。七宝树以自庄饰。众果香花不可称量。菩萨摩诃萨亦复如是庄严佛土清净之国。生三十七道树之花。觉观道心思惟正法。如彼阿耨达宫殿纵广五十由旬。清净无瑕秽亦无风尘坌垢。菩萨摩诃萨亦复如是。道心清净而无瑕秽。内怀种种善本功德。具足无量定意法门。犹如阿耨达泉以牛头栴檀。及众杂宝以为垣墙。菩萨摩诃萨亦复如是。道心所念十亿百千智所见围绕。不缺所誓本无心通。成心通行智业成就。众善根本悉为清净。犹如阿耨达宫内纯以真珠虎珀以厕其地。出若干种光靡不照曜。菩萨摩诃萨亦复如是入极微智意所规度不可思议。将护众生出无忧泽。以若干种珍宝璎珞而自庄严。亦不毁坏法界体性。住诸如来无为之室。意之所趣终不退转。如彼阿耨达龙王。与诸小龙而作覆护。有恐惧者使无所畏。左右神龙皆有威德。及海中诸小龙王皆来朝贺。菩萨摩诃萨亦复如是。为一切有形众生怀恐怖者而作覆护。随时将育令无怨恨。界内越界心等如空。虽处于世布慧光明。将护萌类如身无异。如彼阿耨达泉出四江河遍阎浮地。诘屈周障而归于海。所经过处多所润泽。菩萨摩诃萨亦复如是。乘四智之海。载诸天及人魔若魔天释梵诸天人及非人皆使趣于大智之海。发于无上正真之道。十力无畏十八事不共。至道树下终不退转。所谓四智河者。一曰愿智之河。恒常誓愿度众生故。亦不猗内身无所著。二曰具足智度无边之河。净菩萨道摄一切界。来往周旋亦无所著。所闻无尽亦不有尽。出三世智演非常苦空非身之义。三曰菩萨定意智海。以无央数定而自庄严。游至十方诸佛刹土礼事供养诸佛世尊。演出诸佛无源之海。第四名曰大慈悲河。使众生类安处慈悲立不退转。拔一切苦使无热恼。复以无数善权方便。导彼前进无所顾恋。十力之海多积珍宝。有缘著者知趣所归。如彼阿耨达泉出四大河悉归于海。无尽无穷不可思议。菩萨摩诃萨亦复如是。得增上弘誓。成就愿智修菩萨行。智慧观法亦不可尽。成无上道而无疑滞。亦知诸佛普集定意。以佛所乐而娱乐之。如彼阿耨达泉出四大河。夫一河者分为五百支。一一五百悉归于海不娆众生无所伤害。菩萨摩诃萨亦复如是。依猗弘誓之慧志不移动。修普济之行慈及一切。现有相无相觉一切法。行无碍智不断法本。教令出要住无碍地。犹如阿耨达泉七重中间生若干种珍奇宝物。光光相照与日光同明。所照之处百倍千倍悉蒙其明。有目之士观阿耨达宫五色玄黄。如日在空靡不蒙赖。各各形质自有光明不相逼迮。宝宝相[打-丁+棠]出若干声。声甚柔软听无厌足。菩萨摩诃萨亦复如是。住此法界自在定意。观一一毛孔无数无量亿百千如来。及佛刹土菩萨弟子。众会多少听闻法味。执持不忘昼夜讽诵。如救彼人溺于深渊。现如来身遍诸世界。不可思议不可度量。复往亲近诸佛世界。礼事供养现闻法味。于百千劫所入定意。亦不见长亦不见短。亦不见大复不见小。菩萨观见一一毛孔。诸佛如来国土城郭。弟子翼从众生多少。若干种形言辞不同。周旋往来随意所造。各随志愿共相娱乐。亦不见迮复不见宽。所以者何。其有菩萨入法界定意者。心微难见亦无形质。行迹极细无以为喻。生生自坏亦不自知。三昧境界不可思议。思惟禅行所游境界无能思议。诸佛住处亦无处所。显佛威仪不可穷极难为难行。终不中舍失菩萨行越诸魔界。不牢固者安处无为获清净德。具足如来十力大要。欲求无上无限之业。修行正法深妙之义。不以为难。菩萨摩诃萨亦复如是。随其心意。一念之顷从三昧起知三世事。寻能分别善恶所趣。于诸法界而得自在。亦不猗内复不猗外。推寻本末不见端绪。都无处所亦不见想。以度众想辩诸义辩。游佛国界礼事供养亦无厌足。入诸法界思惟分别尽其原本。不处无为不堕边际。修一切智不着于智。虽有往来不见周旋。观智如化实无有化。众生等分亦复如是。寻其根本无能齐限。净诸世界不见有净。宣示众生苦为何生为从何起。苦空非身无我人寿悉无所有。为现若干无常之变。不处生死不着泥洹。越一切劫度诸死地。观诸相貌意不迷惑。然彼菩萨以善权方便谛满众智。至竟清净志不移易。观诸世界及诸众生。有往还者无往还者悉令度脱。使诸众生智无减少。一切世间法界威仪。次法得法不失次第。观佛积行亦无厌足。依诸佛藏致大珍宝。于诸三昧权现无碍。如尔自然守护。无滞深法句义。所畅道教不可穷尽。辩才大智分别字体。演出总持畅若干种诸佛秘藏。已以离淫亦使众生无淫怒痴。菩萨大士无数劫中行权方便。现显若干种种之道。随类化之令得度脱。一切诸法自然度脱不见自然。度不度故立大慈悲。于诸众生亦不见有众生之想。数出入息。有息出时有息入时。了诸世界性本自然法自常住。前人行者自起识者谓为不定。不见动转言法流驰。虽化众生不见有化。净三戒场入如来室。兴诸法想心获无畏。说法清净而转法轮不可毁坏。道心隆盛终无罗汉辟支之意。是谓最胜菩萨摩诃萨得此法界自在定意三昧。大事增益上菩萨位终不虚劳

    权智品第十八

复次最胜。菩萨摩诃萨复当思惟第十权智定慧三昧。当念修行。云何菩萨修行第十权智定慧三昧。于是最胜。菩萨摩诃萨有三昧名无量定意。菩萨住此三昧者。观知无量身行。观知无量口行。观知无量意行。观知无量佛刹而往庄严。观知无量众生以知往降。观知无量受化众生智业成就。观知无量放大光明接未度者。观知无量放大人威相之光靡所不照。观知无量转正法轮。诸天世人魔若魔天梵释四天王所不能转而独能转。观知无量菩萨游诸佛刹。与诸众生而作导首。虽得佛力不依于力。自放身意如无所放。获佛智慧亦不猗慧。以佛兴起而发起之。执佛神足度无量境。以佛清净而清众行。以佛所行而过其行。以佛之量过诸所量。以佛奋迅之定不怀怯弱。得佛清净而行佛事。菩萨摩诃萨住此三昧已。普观一切智。以观一切智。复观一切智业。已观智业寻能修智。以能修智便受智教。已受智教思惟妙智。已思妙智便求智缘。已与智缘便得解脱之智。以得解脱便得解脱无余。以得无余便应法律。无上正要。长菩萨行成菩萨业。进菩萨意忍菩萨苦。退菩萨恶入菩萨藏。执菩萨明除菩萨冥。住菩萨地现菩萨相。擿菩萨聋净菩萨声。菩萨闻是亦不动还。复不怀惧亦不退转。心不患厌不念有益。亦不舍离复不有疑。亦不中断亦不依猗。菩萨闻见所以然者。菩萨摩诃萨在诸众生随类而入。观察法则成弘誓心。与彼众生而作模范。御大乘法入佛江海。直至所趣不失于彻。菩萨摩诃萨常当思惟三大弘誓。执弘誓心导引众生。而从此岸将至彼岸。何谓名为三大弘誓。一名增上弘誓。二名增中弘誓。三名增下弘誓。复次菩萨复有三弘誓。何谓为三。所谓一名中上。二名中中。三名中下。是谓三弘誓。复次菩萨复有三弘誓。何谓为三。所谓一名下上。二名下中。三名下下。是谓三弘誓。最胜当知。菩萨摩诃萨获此第十权智定慧三昧者。乃能逮此第一增上大弘誓心。育养众生净佛国土。执权行智离爱欲缚。善学深入菩萨一相。解知诸相亦无有相。善了菩萨幻化之法。立众生意在于坚固。施心系意尽为萌类。当来过去现在诸如来无所著等正觉。行大慈悲普覆一切。其无智者为现慧明。盲无目者为作眼目。无救护者为作覆护。充足一切诸佛之法。使有希望众生除法之想。所以然者。犹如长者积财千亿。金银珍宝车磲马瑙。真珠虎珀库藏之中。加有如意明月珠宝。所至着处靡不照曜色像第一。彼珠性分体自明故。菩萨亦复如是。得心意珠出智慧门。以智光明普有所照。通达往来无所挂碍。入此定意亦无留难。如彼明珠光明所照。自现志能本性自尔。无能制使令不尔者。何以故。体性自然无能使不然。然亦不然。不然亦不然。不见众生然。不见众生不然。最胜当知。众生亦出于然。亦出于不然。云何众生亦出于然亦出于不然。所言众生出于然者。五道科限流转不断。一身百身或千万身。一劫百劫或千万劫舍身受身。成就四大长育五阴。是谓众生出于然也。云何众生出于不然。于是众生体性本空。空亦无识复无想念。时彼四方有四风起。一为地气风吹至空。二为水气风吹至空。三为火气风吹至空。四为风气即空风是也。神交识碍忽然相值。五法交集乃成形体。遇天为天遇人为人。随形所染即成其身。设有地气无水火风亦不得成。设有水气无地火风亦不得成。设有火气无地水风亦不得成。设有风气无地水火亦不得成。设有神识猗空自管无地水火风亦不得成。菩萨当观识为空性法界所摄。有识四大五法。相应成五阴身。健利速疾即于空界。识自觉冷粗涩坚[革*卬]。寻知离空专意思惟。心念空想寂然无为。即自开寤于虚空中不来此世。入无为无余泥洹界而取灭度。若彼识神迟钝不利。[夢-夕+登]瞢恍惚不信离空。谓为己身即是虚空。因形受对当趣生门。遇善则善遇恶则恶。遇善众生信有善恶。知今世后世尊卑长幼。厌患世苦习善不惓久乃得道。遇恶神识永离于善甘心行恶。流转生死涉地狱苦。识神受恼暂无停息。方自觉寤念本所行不应禁律。渐自改责舍恶就善。从初发心涉历劫数积功累德。具一切行乃得成道。是谓众生亦出于不然。菩萨摩诃萨常当思惟一心观察然与不然。云何菩萨观然不然。然者世法不然是道。然者是累不然无著。然者是有不然是空。然者有识不然已离。然者有名有生有老有病有死。不然无生无起灭法。亦不流转驰趣五道。菩萨当念。舍然有法修无然行。众知光明无所挂碍。舍灭己法自然不起亦不见灭。净于十方一切世界未度者度。虽有亲近亦不见近。为人执劳不计有苦。荷负重担常为元首引入法海求无乱定。采致无限无量珍宝五分法性空无想愿禅定解脱相好神足。以此为宝心不怀惧亦不恐怖。复有三昧名无为定。菩萨摩诃萨住此三昧者。以显曜正受净众生迹。不以为厌。于诸众生演法性空。解空众生乃得时寤。回心就道终不退还。尔时世尊告最胜曰。如我今日住此法界自在定意。以天眼观上虚空际。不然众生所处之界。弹指之顷。亿百千众生不可称计。始欲受形来趣生门。尔时十方无数恒沙诸佛世尊。皆以化身住虚空界。与彼四气神识说虚无之法。适空复离空。造离识亦然。我空计我有。永以离空矣。若彼猗空受识之形。思惟空观者即于空界舍识形质。入无余境而取灭度。不来此世受五阴形涉诸苦恼。如来权智无形。度识入虚空界。现其奇特神变德化。或现诸佛清净国土。或时住立贤圣默然。或时经行讽诵不惓。识虽不睹但诸佛世尊威仪礼节初不有废。菩萨当观虚空所覆无边刹土。虚空亦无是念。我今乃覆尔许刹土。空亦不自念极有功劳。何以故。空之所覆本性自尔。法不变易自然常住。法不动转亦不若干。不生不灭复不变异。所以然者。虚空法界性自然故。菩萨复当思惟虚空神识。识有三相。云何为三。一趣。二悔。三亦不趣亦不悔。云何虚空神识一趣。所谓一趣者。趣向生门长育阴种。随类染神便受其形。菩萨当知。虚空神识亦有中止。识合四气来趣中止。中止受形。或经半月或经满月。或经三四五六七八九十十一十二月。便从虚空中止来趣五道。五道中止便现在前。入五道中止已。或经一二三四至十二月。天化中止亦无日月年岁之期。地狱饿鬼畜生亦有中止。各各不同空识中止。澹然无形而不可见。至阿维颜诸佛世尊乃能见耳。是谓菩萨摩诃萨虚空中止趣向生门。云何虚空神识识有二悔。所谓二悔者。四气以合识处其中。悔受其形心念空想。泊然无为不计想着。又诸佛世尊以化佛性。住教寻时得寤。于无余泥洹界而般泥洹。最胜当知。诸佛世尊于三世中教诫众生。令得至彼无为岸者不可称数。为一众生周旋三世执劳勤苦。无数方便化令得度。虽处苦恼不以为劳。亦复无有疲厌之心。如来出世化诸佛身。在虚空界神识中止。为说极微无上道教。中止父母神识觉寤。受化法言即于彼处。入无余泥洹界而般泥洹不可称计。多于十方诸佛世尊。所度众生无以为喻。是谓菩萨摩诃萨住此法界定意自在三昧者。便能执权行智。修无量法乃上菩萨位。云何第三虚空神识亦不有趣亦不有悔。所谓亦不有趣亦不有悔者。空界法性识处其中。中止形质如影如光。极微极细念空意识。不逮无为之境。退不及人间之有。是谓菩萨摩诃萨亦不有趣亦不有悔。尔时最胜菩萨前白佛言。世尊如是。世尊所说。虚空神识虚空中止形如光影。阿维颜菩萨诸佛世尊乃得见耳。若使四气神识及空中止有往来者。彼泥洹界及第一义。亦当有神识亦当有中止。设有识有中止者彼泥洹界与虚空识及空中止。有何差别。设无差别则无泥洹。以无泥洹则无道果及三乘法。生死法界及泥洹界。则无有异。泥洹则是生死。生死则是泥洹。世尊。如我从佛所闻虚空神识。及空虚中止倍增疑惑

尔时世尊告最胜曰。彼泥洹界及第一义。亦有神识亦有中止。泥洹神识及彼中止。与空神识中止法性各别。泥洹神识泊然不动。亦不移易亦无生门。当所趣向亦复无有生老病死愁忧苦恼。言识永灭亦不永灭。言识更生亦复不生。彼中止者以永寂为中止。佛告最胜。如来出现于世。过去当来现在恒沙诸如来等正觉。不取泥洹亦不永灭。若佛世尊入泥洹者。则非正觉非具弘誓。佛告最胜。三世诸佛世尊有名号以来吾未见有入泥洹者。正使将来诸佛出现法界。周旋止住有余泥洹。不入无余泥洹之境。最胜当知。如来神识泥洹神识则无有异。但为泥洹神识。无形无影亦无光相。不动而不可移。如来识者。有动有移。彼识此识一而不异。唯有动不动而有异耳。菩萨当观空。空有识有止。有有识有止。若复有法在泥洹外者。有识有止。是谓最胜虚空神识虚空中止。泥洹神识泥洹中止。是谓各各差别

十住断结经卷第六十住断结经卷第七

        姚秦凉州沙门竺佛念译

    化众生品第十九

尔时最胜菩萨白佛言。世尊。云何菩萨摩诃萨涉历生死执勤苦行。从一佛国至一佛国。育养众生庄严道场。虽化众生亦不见化。亦不见众生。亦不自见我有所化。所以然者。以法性观虚无寂寞无所有故

佛告最胜。如是如是如汝所言。菩萨摩诃萨执大弘誓无边幅意。育养众生净佛国土。虽化众生亦不见化。亦不见众生。所以然者。以法性观虚无寂寞悉无所有。皆空皆寂无形无相不可见故。一切诸法法亦自空。众生众生自空。国土国土自空。泥洹泥洹自空。菩萨菩萨自空。如是最胜。菩萨当作是观。深入法要解知诸法。一相如尔。诸法众智虚寂无为无所染着。菩萨摩诃萨亦复如是。御意趣道心难沮坏。必至无上正真之道为最正觉。志如金刚亦不转还。璎珞道树以无为法。从初发意至于道场。坐树王下。已降当降未降之徒。于其中间不兴慢意。我胜彼不如慢。我与彼等慢。彼胜我不如慢。增上慢增中慢增下慢。中上慢中中慢中下慢。下上慢下中慢下下慢。如是菩萨摩诃萨当念思惟除此诸慢。亦不嫉妒隐贡高心。菩萨入定观察众生。应度不度。以善权方便入于五道八无闲处。若有众生应受化者。便与彼人作朋友知识。或为父母兄弟眷属。或为大富豪尊长者。随前众生给施穷乏。出无量藏金银珍宝[王*車]磲玛瑙真珠琥珀好明月珠及如意宝珠。或以饭食床褥卧具病瘦医药。悉以给施无所吝惜。或复有人至菩萨所。殷勤求索头目手足国财妻子七珍之具。悉能惠施亦无施想。是时菩萨。便入法界自在定意三昧正受。以权方便与彼众生说虚无法。汝等当知。法者无为亦无所为。分别六情都无有主。若眼见色色亦无对。众生愚惑于中起识。分别思惟眼识无主。若耳闻声鼻嗅香。舌知味身知细滑。意分别法。菩萨观察都无所有。法起随所处起。法灭随所处灭。起不知起灭不知灭。十二因缘十八本持亦复如是。或时菩萨入师子奋迅三昧。复能示现若干种变。于中演畅清净音声。现已国土众宝庄饰。香花芬熏五色玄黄。威仪清白。志如安明。不可移转。复现无量定意法门。如来恒常所娱乐者。一切诸法众生根本。皆现在前。是时菩萨复以神足。入无量定而自示现。处一莲华结加趺坐。现其色身无限无量阿僧祇劫诸法功德。净除众生想着之迹。导引菩萨出要之路。依一切智演甘露法。畅慧光明示现佛慧无所染着。或以珍宝起七宝塔满一天下。或二天下或三或四。或至梵天至一究竟天。住寿经劫不取灭度。或时菩萨以权方便。入无为静定具诸善根。不舍如来具一切智。以三昧力训诲众生。或有众生应闻声教而得度者。或有众生应闻香教而得度者。或有众生知其味义而得度者。或有众生身获柔软而得度者。或有众生体法意悟而得度者。是时菩萨复作是念。闻声众生必欲闻我清净之义。我今当演如来八音音演八句。苦音习音。尽音道音见苦向苦见习向习。见尽向尽见道向道。是时众生闻如此声。意不开悟欲睹光明及其身体。菩萨入定以平等观。便化地种山河石壁。树木华果尽为七宝。车磲马瑙水精琉璃珊瑚虎珀皆放光明。明明相照翳日月光。是时众生意不开悟。复欲得见日月光明。菩萨观察知彼心念。即入无碍心念三昧。放千亿无数毛孔光明。一一光明有七宝莲花。一一莲华有七宝台。一一台上有七宝盖。一一盖下有七宝座。一一座上皆有如来。与彼众生说苦原本。生苦无苦是无苦谛。生习无习是无习谛。生尽无尽是无尽谛。生道无道是无道谛。彼闻声众生及见光者。闻苦音响心怀厌患。各兴苦空无我之想。无生灭想便于坐上。尽苦原底应清净响。是时座上闻香众生。意不开悟复生斯念。我等意乐极妙之香。然今大圣乃说声教。菩萨知彼众生心念。便入极微众香定意正受三昧。便化地种山河石壁树木华果尽为香熏。牛头栴檀鸡舌艾纳。跋香梦经木榓酥合。分陀利花须干提花。满愿干提花青莲芳花。如是众花数千百种。普遍四方靡不闻香。是时众生虽闻此香意不开寤。欲使香中出于道教。尔时菩萨知彼众生心中所念。便于香中说六重之法。是时闻香众生心开意寤。毕此世患更不来生。尽于苦际即成道果。是时座上贪味众生意不开寤。便作是念。我意在于乐着妙味。然今大圣乃说香教。实非本心之所贪慕。菩萨知彼众生所念。便入极微净味定意正受三昧。便化地种山河石壁树木花果。尽为甘露自然饮食。香气芬熏甘美无量。尔时众生虽获此味意不开寤。意欲贪前自然奉送。及见其形乃果我愿。菩萨知彼众生心念。便入速疾无碍三昧。便化地种山河石壁树木华果尽为众生。一一众生擎若干种自然甘露。甘露食中出斯辈声。甘味在外舌识而尝。二法交会乃兴尘劳。我今自节知足为上。趣欲支形使痛不生。如车须膏以致重载。疮痍得药勉济其痛。如此法教皆出于味。众生闻之心开意寤。毕此世患更不来生。尽于苦际即成道果。是时座上众生之类。贪细滑者意不开寤。便作是念。我今意在贪着细滑。然今大圣乃说妙味。实非本心之所贪慕。菩萨知彼众生心念。便入极欲微细柔顺定意正受三昧。便化地种山河石壁树木花果。尽为众生。一一众生皆被自然劫波育衣。天缯天彩以自缠络。众生见之以手亲近。自觉柔软不可获持。意念一衣百副自至。众生心寤方自克责。咄哉何为贪着此衣。将非自坠增于尘劳。形为枯骨缠以血肉。便闻空中出斯辈声。男子当知。人间五乐非真非有。心着细滑渐兴牵縺。念自克责舍此贪爱。尔时众生闻空中声方乃得寤。毕此世苦更不来生。尽于苦际即成道果。是时座上众生之类。贪于法者意不开寤便作是念。我今意在微妙之法。今日大圣乃说细滑。实非本心之所贪慕。菩萨知彼众生所念。便入无量法界定意三昧正受。便化地种山河石壁树木华果。尽为众生。一一众生皆说六度无极。空无想愿禅定解脱。有为无为有漏无漏。生灭着断斯无所有。或时菩萨观众生心意之所趣。便设权计现身色相隐没自由。腾在虚空作十八变。从空往来无所挂碍。或复示现国土城郭演说佛法。使众生类逮不思议诸佛要定。是时菩萨所化城郭。人民周旋各各无限共相敬待。如父如母如兄如弟。谦恭卑下常先兴敬。菩萨尔时复入无喻光明。令诸菩萨入此光明结加趺坐。或坐高座或坐莲华。遍满世界无空缺处。或现佛身坐宝莲花。皆演诸佛六度无极。空无相愿禅定解脱。复以如来十八不共四无所畏。加被众生各蒙得济。尔时菩萨复以神足之力放大光明。现佛世界亿百千国。一一光明各各引致亿百千众生。乘光至此闻法得度。一一毛孔有十亿光明。一一光明有十亿国土。时化国土有自然自寤摩尼宝。以种种珍宝杂厕其间。其摩尼宝悬在虚空去地十仞。珠光明彻靡不照曜。复有奇异摩尼之宝以为庄严。一一宝上十亿江河沙刹诸佛国土。十亿百千楼观台阁。一一楼观有十亿百千佛土宝莲华师子之座。一一宝师子座有十亿百千国土神宝莲华。一一花上有十亿百千如来坐师子座。一一如来放大光明。覆十亿百千佛土。一一佛刹土有十亿百千如来师子无畏之德。一一无畏之德有十亿百千众生居处。一一众生有十亿百千现诸佛国。一一佛国有十亿百千法句义味及诸佛法。一一法句义味之法。有十亿百千生诸经法炽然尘劳。乃至诸法定门亦复如是。一一诸法门中演出无量众智相貌不退转法。若干种智义味不同。一一所转法轮之中。度十亿百千众生得纯熟行。一一众生刹土复有十亿百千佛国。各化己界使趣善处。令众生类咸至佛道。菩萨大士入此三昧。自现无量威神之变。三昧境界未曾所有未曾所见。所化穷异非心所度非意所图。内外中间睹无处所。亦不见来时亦不见去时。所以者何。斯由诸法体自然故。百劫修行欲尽其垢。行如来誓加于众生。复于无量无限数劫。无著无住亦无所染。亦复无能为立名字。寻其根本永无处所。若使有人欲设权诈寻究此定造化形相。义极甚深不可思议。乃是诸佛所应行法。非是罗汉辟支所修。最胜。复当思惟此理。菩萨谦苦游于八难。观众生意有爱欲心无爱欲心。有多有少亦悉知之。有嗔恚心无嗔恚心。有多有少亦悉知之。有愚痴心无愚痴心。有多有少亦悉知之。若彼众生有爱欲心。偏着女色计好肥白。心玩不能去离。是时菩萨。复现权诈广设方谋。辄为示现觉观恶露不净之想。于众生前现身无常。四大散落落在异处。一日二日乃至七日。形体膖胀臭处不净。或时死尸血肉消尽筋骨相连。复现异变若干种形。或现髑髅髀骨臂肘各在一处。久久转变似白鸽色。岁月转久与粪土同。如是菩萨众生观已。便自开寤乃知妄欲。是凡夫行堕入恶趣。非归正道心自改悔。追昔不及乃投大圣。遵修梵行入清净渊。洗淫欲垢练神弃缚。逮成无上至真正觉。净己国土育养众生。是谓菩萨观爱欲心。便为说法得成道果。菩萨当知或有众生无爱欲心。意局在小不至大道。菩萨劝勉成就平等正觉道也。以智慧藏无二之法。导引指示令知正路。安立大乘不取小道。从无数劫积功立德行善不惓。意迷心惑不别真伪。今乃自觉不到究竟。云何菩萨无二之道。菩萨修行不二道者。菩萨常净不处于净。于净游乐外化众生。是不二道。菩萨常寂外现如乱。于寂游乐而化众生。是不二道。菩萨入定未始有错。从定意起外化众生。是不二道。菩萨施心初不怀悔。持无想报牢固之意。外化众生使除三想。是不二道。菩萨戒具未始有缺复以禁律外化众生。是不二道。菩萨甚深智虑广远。不自叹说有所成办。内常一心无所沾污。是不二道。执智造化实无边崖。于中捡意使不分散。亦以此法诲化众生。令过旷野无忧之泽。是不二道。菩萨修忍正定三昧。现身勤苦处在山泽无人之处。或近村聚现行乞食。或经一岁至百千岁。或经一劫至百千劫。于中现身受无量苦。尔时山中人及非人。或罗叉鬼二足四足及无数足。各赍刀杖来触菩萨。或以利刀而截其鼻。鼻寻还生如阎浮果。最胜当知。阎浮果者。取一生两取两生四。取四生八取八生十六。取十六生三十二。如是展转树尽为果无复树形。亦复不见枝叶茎节。菩萨入定行忍如是。若有人来截菩萨鼻。取一生两取两生四。取四生八取八生十六。取十六生三十二。如是展转身尽为鼻无复身形。亦复不见手足头目。众生但见鼻无央数。寻时生念悔取其鼻。愿乐欲见菩萨本体。是时菩萨舍三昧已。心意安详而从定起。还现其形如本无异。渐渐动摇现出入息。转复开目如有所说。众生见已皆投于地五体自归。愿为给使在菩萨侧。是时菩萨观察众生内心所念。随时应适而度脱之。菩萨复还入定三昧。内心寂静无他余念。复有众生至菩萨所。尽共围绕而挑其目。目寻还生。如散成融琉璃。设当有人取成融琉璃。如毗罗果许而洒地者。散如芥子不可收拾。然明明相照各有精光。众生但见菩萨形体尽为眼目。不复见本形体相貌。寻时生念悔本所作。即自克责。愿乐欲见菩萨本体。是时菩萨寻舍三昧。心意安详而从定起。还现其形如本无异。渐渐动摇示出入息。如有所说众生见已。皆投于地五体自归。愿为给使在菩萨侧。是时菩萨观察众生内心所念。随时应适而度脱之。是时菩萨复还入定。内心静寂无他异念。复有众生至菩萨所。手执利刀杌其首足。首足还生如瞿多罗树。瞿多罗树者。若有人来诛伐其树枝叶茎节。诸觚段段各在异处。弹指之顷寻因地气还生如旧。枝叶茎节各各成树。尔时菩萨亦复如是。形体肢节尽为首足无复本形。众生但见菩萨形体尽为首足。不复见本相貌之像。寻时生念悔本所作。即自克责。愿乐欲见菩萨本体。寻舍三昧心意安详而从定起。还现其形如本无异。渐渐动摇示出入息。转复开目如有所说。众生见已皆投于地五体自归。愿为给使在菩萨侧。是时菩萨观察众生内心所念。随时应适而度脱之。是谓菩萨有爱欲心无爱欲心。有多有少皆悉知之。亦不自念吾在尘劳唐捐其功。亦复不念斯众生等而易诱进。菩萨所行行不见行。亦复不见有受教者。行教二业都自虚寂。亦不见一亦不见无一。一自无一。况言有一言一法者。亦自假号言眼。眼自假号。耳鼻舌身意法及以色声香味细滑法。亦复如是。菩萨所以言一法者。欲开法门现无量门。引至无法训于众生。是时最胜复白佛言。云何众生有嗔恚心无嗔恚心。有多有少皆悉知之。佛告最胜。菩萨大士游入世界无量佛土。一一观察有形之类。蜎飞蠕动蚑行喘息下至蚁子。有嗔恚心无嗔恚心。有多有少皆悉分别。一一料简而投其药。设有众生嗔恚多者。便见苦空非常之变。或有虫兽所见啖食。或有盗贼兵刃所害。或为水火横见烧煮。如是众变不可称计。设彼众生心得寤者。随彼教诫而受其化。寻于彼处即得度脱。若有众生见无常变心不觉悟。菩萨尔时复以权慧入忍三昧。其三昧名无常观。复有三昧。名慈降伏去恚三昧。若菩萨摩诃萨入此三昧正受者。便能降伏除嗔恚心。若有极恶罗叉鬼神虎狼盗贼弊恶之部。来趣菩萨欲取伤害。未到之间中道便还。所以然者。慈定之力覆护方界。亿垓刹土莫不蒙济。以得入慈三昧者。法度有十事。云何为十。所谓修甚深智行无量业。总持强记意难沮坏。自无有量。以法界为量入于无量。当来过去现在诸佛之所修习。无上法印而封印之。依如来力增益佛土。恒自立志净修道场建菩萨业。如是行者。为应法律应无所生。得开眼目[火*霍]然大寤。慧眼清净永无尘曀。获种姓眼得佛净眼慧眼无外。议眼深远法眼常定。善知识眼以为营护。道眼甚深获辩才眼。言无滞碍致无疑眼。心无彼此亦无犹豫。入法门眼导示盲类。分别义味开露法门。亲真知识成就道心。所建境界无能障蔽。亦复无能有求毁呰。是谓菩萨分别诸眼成办道业。为诸世间作良祐善友。豫了未生显示威相。立于善根所化无碍。功德清净所愿必果。胞胎真正遇诸解脱断诸疑网。布慧重云遍满空界。以贤圣法解畅心垢。所建志愿恒现在前。心所作为终不疑难。信根坚固功业无尽。亲奉诸佛除忧乐想。道心转深采慧珍宝。供奉智士犹妙香花。为风所吹靡不闻者。其有秽恶悉为清净。最胜当知。吾今居此阎浮利内。所居之国名毗舍离。以肉眼观诸方刹土。诸苦忧恼不过此处。然复出于如来种性。今此众生不馨之臭。上彻虚空十千由延。然天于人人为天种。天亦自知观于宿命。吾所积德皆由人身。设不从人植众德本者不蒙福庆。最胜当知。尔时诸天各将营从。欲来世间咸来到空。人间臭气重云之际。便闻人间腥臊不净。即还彼去不至人间。所以然者。以其香洁不堪住故。菩萨大士行大慈悲。所化国土亦不选择是好是丑是净是不净。亦不心念我今愿乐堪教化此不堪彼处。如我今日处此忍界教化众生缘毕无余。十方诸如来等正觉皆遥赞叹。各各自于彼刹告四部众。某方某甲称佛姓字。名号能仁如来。于彼忍界五鼎沸中。五刺铁中五刀剑中。五盛焰中五荒乱中。五无救中五难债中。能处其中训诲众生甚奇甚特。分别贤圣诸度无极。诸天清净身无垢秽。至臭云际辄还天上。至宫殿中出到后园。入无忧池七日七夜而自洒浴。犹恐人间臭气着身。心不愿乐人间周旋。是时诸天香风远布。下至空界万八千由旬。复过此数有随岚风。香气下过至空风香界二千由旬。诸天虽有众德之香。犹不如此无欲之人持戒香也。菩萨当观诸天食福谓为永久。天使在前乃悔不及。愿贪人中兴功福业。是时意岂在香臭间乎。菩萨大士亦复如是。虽处苦恼五盛焰中。心不疲厌亦不悔还。意常念在度脱众生。若有贤圣神通之人。以其神力接一凡夫至上虚空香熏之界。还复来下在此世间。身体香熏经三七时香气乃歇。无欲之人戒完具者。经劫去劫戒德之香终不断绝。然菩萨大士。同处世间于世间长。复于世间作大炬明。虽有勤劳不以为苦。道意兴盛心不缺减。是谓菩萨观察众生。有嗔恚心无嗔恚心。有多有少皆悉知之。尔时最胜复白佛言。世尊。云何菩萨一心思惟观察众生。有愚痴心无愚痴心。有多有少皆悉知之。于是菩萨便入明慧正受三昧。普观世界至虚空际。其中所有众生之类。一足二足至无数足。天龙鬼神阿须伦迦留罗栴陀罗摩休勒人若非人知其原本。一一分别寻究审实。若有众生愚痴多者。便为挍计。演说因缘十二根本。无明缘行。行缘识。识缘名色。名色缘六入。六入缘更乐。更乐缘痛。痛缘爱。爱缘受。受缘有。有缘生。生缘死愁忧苦恼。有诸不净乱想之心。逆顺畅演无尽之智。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则更乐灭。更乐灭则痛灭。痛灭则爱灭。爱灭则受灭。受灭则有灭。有灭则生灭。生灭则死灭。死灭则无复有愁忧苦恼诸不净行。漏为大患泥洹为妙。如是菩萨观诸相貌。而为演说究尽原本。若有众生痴心弥固识不了朗。渐进导引将至静处。复与解畅本无之法。无生灭法无著断法。分别三世兴衰之相。痴行过去识不可灭。广曜法门出现妙智。兴起佛道众德具足。不舍菩萨善知识行。常游菩萨闲静之堂。入诸如来深要之观。复当思惟十牢要法。云何思惟十牢要法。亲近佛藏法身之相。念不思议还摄为一。解空无念亦无若干。自起自灭亦无主质。过行无绪不可护持出生诸道。法界虚空境界亦无穷尽。缚解自解去众生着。依于善根成一切智。越于无量智慧之境。捷疾之智皆悉成就。充足菩萨希望之心。净诸菩萨言迹之行。如来道义未曾漏失。不舍一切法性之相。所入极微意不谬误。心若金刚力不可坏。诸佛之所授其号莂。悉无众生应可度者。所说无二不可转还。是谓菩萨十牢要法。进成道果取道不难。是谓最胜菩萨上妙无尽之法。当念修行

    三道灭度品第二十

尔时最胜菩萨即从座起长跪叉手。前白佛言。唯然世尊。如来至真道德无崖。不猗道门求出解脱。于清净学勤修慕及金刚三昧不可称量。今闻如来说灭度净三道归一。更无二名亦不着二。若审然者。何求无上至真道乎。唯然世尊。愿为敷演令渴道家永忘识惑。是时世尊。回金体身四面顾眄诸来会者。寂静无名各无众念。微视最胜而告之曰。快哉问矣。诚难得闻。如来为汝一一畅演。令将来学永无犹豫。最胜白佛愿乐欲闻。佛告最胜。清净道根不生秽枝。体性净故则诸法净。复于法性亦悉清净。渐当分别有数无数。无数净者得三世净。以了三世空观三界。是谓名曰微净三昧。最胜当知。三道灭度其品不同志趣各异。身为垢本。念为垢池。想为游尘。识为结首。一灭三存不致清净。二灭二存亦不至净。三灭一存亦不至净。四灭空存乃至于净。至一切智清净亦尔。从初道迹上至无著。复从一住乃至十住。皆灭四还四归四碍。云何为四。所谓四者。身为垢本凡夫满足。念为垢池纵逸四流。想为游尘兴八万爱。识为结首系于三有。是以大圣。现有三道像如优劣。其实灭度无若干差别。道在泥洹不离虚寂。菩萨泥洹以度人为名。辟支佛泥洹现神足为名。声闻泥洹现狭劣为名。复次最胜。菩萨泥洹慈悲喜护育养众生。设导一人入道捡者。诸根容悦欣怡无量。当时意识澄静无为。无道俗念诸情悉净。净若泥洹于彼永尽。而无所有是谓无念。应无所念亦不见念念亦无念。无念学者学亦无学。色亦无色亦不见色。心意识念亦无识念。从五阴身乃至无形。法体清净不见有念而无所念。最胜当知。夫言泥洹。泥洹尔者岂为远乎。莫作斯观。所以然者。无念法体无形观体则是泥洹。泥洹性体则是法观。一而不二亦无差别。泥洹无名而不可见。亦无能立泥洹名号。是谓最胜。菩萨大士学是泥洹清净道者。而应于道应念无念。最胜复当分别。菩萨大士欲行了达斯清净道泥洹体性者。当修净行。云何菩萨修其净行。恒使身口意清净无瑕秽。何谓身净而无瑕秽。于是菩萨己身已净。解诸外身亦复清净。己身虚寂解诸身空。身之寂静知诸身寂。己身解脱诸身亦然。菩萨复当思惟法观。了知懈慢亦无懈慢。己身无慢道岂有慢。是故菩萨解身无慢。菩萨兴念世恶露观。身如影响不见净想。达净无想方应泥洹。是谓菩萨摩诃萨清净泥洹道无差别。最胜菩萨复白佛言。云何菩萨体净无欲欲而无欲。佛告最胜。菩萨大士周旋五趣流转生死。方便权现适化应时。有说身净则论无生。其睹生死则无生死解知无生。生死一而不异。亦无若干差别之名。菩萨复当了别身行彼达无生。此等生死则知身行达内外法。何谓身行。去来现在三世兴衰。过去无迹现在无记当来无号。复次最胜。去者永尽来者无穷。现在迁转亦当思惟尽不尽法。云何思惟尽不尽法。于是菩萨分别了达虚空净想。其无尽者淡然无为无有想念。有想念者于贤戒律乃有大缺。佛告最胜。吾昔成佛坐道树下。七日七夜观树不眴。心念过去恒沙诸佛。由何自觉先达何法。时我最胜。复作是念过佛恒沙先达身法逮最正觉。因缘合会有识有想。其知缘者则空无想无所染着。亦复不见生灭着断。若此最胜。如斯观者是谓身净。夫身净者悉归智海。最胜当知。归海之义其事有十。云何为十。一者归佛之海法无形观。归众生海超越有难。归法之海集众智故。归福田海立本无根。归五阴海示现秽法。归智慧海分别若干教诫所趣。归根义海增善根故。归住心海了知众生若干心意所念。无量解知无碍。归于行海不违愿故。归弘誓海究生死原。是谓最胜。菩萨摩诃萨归海十门之义。当念修行悉归如来无漏法身。又观如来无漏身者。不住本无不堕三界。达知本无为一法身。观身无漏如本无住。住不见住亦无所住。以无漏身入生死海。示现色身如无色身。无边无际无形不可睹现。色身灭已亦不见灭。亦不见生身之本无如本无住。如来身净亦无瑕秽。入众生聚随前形质随像而现。了达众生身之清净。己身清净众生身净。一而不二亦不若干。平等本无。本无无道不见有道。亦无俗法有漏无漏。亦复不见三乘教诫。斯是罗汉辟支佛菩萨佛道。亦复不见十力四无所畏十八不共。于诸贤圣道法都无所著。是谓菩萨行应清净应无所应。复次最胜。菩萨摩诃萨当念思惟口言清净。何谓口言而应清净。于是菩萨入虚空界清净三昧。普观三千世界。其中众生有形之类。一切贤愚清白好丑。悉归于空皆悉清净。菩萨复当思惟等观。于第一义亦不见等亦不见不等。何以故。以等相观故。亦不见等与不等相与无相。复以等相观察诸法。不见道法无限无际。不见俗法有限有际。不见贤圣超过三有。不见凡夫力有优劣。最胜当了。菩萨分别清净音声。无有众生想着意者。善察音响观了无响。不见忧喜是常非常。乐于颠倒非颠倒者。达知众生一切皆净。无欲无染亦无生灭着断。无淫怒痴三毒根本。复当观察十二因缘十八本持。从痴至死皆悉清净。痴亦不知我所造行。行亦不知从痴而有。法法自生法法自灭。法不见法何有痴行。如是最胜。法不相知法生则生法灭则灭。法不自知生与不生灭与不灭。故言无生灭着断也。尔时最胜菩萨白佛言。世尊。三世痴行随身回转。有身则行随。无身则行灭。乃至老死亦复如是。唯愿世尊。敷演狐疑令将来众生永无疑滞。尔时世尊告最胜曰。痴不染身身不染痴。痴亦不见我有身。身亦不见我有痴。各各清净亦无吾我。言吾我者悉自虚寂。是谓菩萨一切清净。言清净者。何者是言何者非言。言不在内亦不在外。不见言有出有入。便当具足十坚固义。分别众生阴种所趣。云何为十。于是菩萨先求出要化一切众生故。现无数化精进无著故。现无碍力。以一切法空故。现息意力。于一切法得自在故。现回心意识转不转故。分别义味故。现自性法力智慧显故。现自在力为众生说法故。现无畏力。安处正法故。现辩才。现无量智一一布现故。现无二力。无畴匹故。如是最胜。菩萨摩诃萨分别众生种性所趣。亦不内亦不外亦不在两中间。欲以言是菩萨耶。对曰。非也世尊。云何欲淫怒痴是菩萨耶。对曰。非也世尊。若不以欲怒痴是菩萨者。复以诸垢缚着是菩萨乎。对白。非也世尊。佛告最胜。菩萨摩诃萨亦不着言亦不着不言。一切诸法皆无著不着。眼耳鼻口身心亦不见着不着。所演音响风动声出。因缘合会乃有声响。贤愚好丑声无若干。亦不住内复不在外。寻其中间而不可得。佛告最胜。菩萨摩诃萨住本无动三昧者。思惟勤念及其所行。皆如空等无住不住亦无众想。是谓最胜。众生言声一切音响悉空非真。权诈之法不可恃怙。尔时最胜白佛言。世尊。如来圣谛成贤圣道果。权诈非真云何成最正觉乎。佛告最胜。如来等正觉。道法审谛真实以获真实之法故。解知诸法非真非有也。又复最胜。菩萨摩诃萨周旋五道教授众生。随前所应而度脱之。观察众生名字音声。转于无上法轮。随法句义令达报应。乐苦众生说苦原本。解了诸法言皆无言。何者为言言从何出。了知言者无有出生。是时菩萨复与乐习众生说习根本。是习是生是因是缘。分别因缘本无习绪。不见有习亦不见有字。是为最胜。乐习众生一切音声皆空非真。又复菩萨随前众生报以道教。使闻法者顺法而行。亦不知行之所趣报应之果。是谓菩萨行无所行证不见证。如尔一相等灭众苦。复次菩萨复当思惟乐尽众生。了达诸法不见出生。言音声者无所住止。若坐若行常若一心。虽游愦乱常若闲静。设在大众贤圣默然。意欲现言言便自止。追寻所言于着无著。不见尽与不尽。一切诸法亦不见尽。生灭着断声出于言永无踪迹。复次菩萨乐道众生思惟八行。众生修习进趣泥洹。正言正业乃至正定。其如法者不如法者。平等一虚空观无二不有违错。是谓菩萨摩诃萨口言清净而无瑕秽。复次菩萨摩诃萨当念思惟意识清净。云何菩萨意识清净于是菩萨心为清净。亦无瑕秽本无清净不见有本。其心本者不可染污。无能为心作留难者。何以故。菩萨摩诃萨了心本净不见有净。世多愚惑于斯染着。达空思惟不有所著。分别究竟行权方便于本自净。菩萨当知。又其心本本无往来。不择高下尊卑贵贱。不见本有今无。不见今有本无。不念德本。念德本者。是谓空是谓无生是谓泥洹。问曰彼德本者。了识心本乎。曰非也。内本空解外乎。曰非也。最胜白佛言。若尔者云何空耶。佛言。心本空。亦非本非不本。亦非心非不心。空心定菩萨若不自见心。己心本无外亦本无。一而不二而无若干差别之名。心非我心无心于心。我心非心无我于我。色非我色无色于色。我非色我无我于我。我心我色。非我心我色。色我心我非色我心我。至声香味细滑意法。非我意我法。亦非意我法我也。何以故。心本空外亦空。以知外空达了诸法亦复如空。一而不二无若干相像。一切诸法亦复如是。不见本有今无。亦复不见今有本无。无亦不无有亦不有。有不知所以有。无不知所以无。无无恒自无。有有恒自有。有不出于有。无不出于无。无无不自无。有有不自有。有不知无无不知有。一切音声皆空非真。是谓菩萨心为清净。其心净者。不可染污三十六湮。心本尘垢永无所著。复以善权方便达本自净。亦不于净起于想着。菩萨摩诃萨以了本末净空。定意自在三昧者。便能屈还周旋生死。往来五道植众德本。彼德本者。知心意识无心意识。复以本心愍及一切。识了众生空无所有。我人寿命本末清净。复以德本普及一切。令众生类进修于道。众生及道平等无二观如是者。斯谓本末清净。复以此净等淫怒痴痴等道等。道则是欲怒痴痴则是道。道净痴净一无有二亦不若干。菩萨观察本末自净不着诸秽。尔时世尊告最胜曰。身行清净而不作恶。口言清净恒归至诚。意念清净慈悲一切。众行具足乃称菩萨。尔时世尊说此本无清净品时。五千菩萨皆得一生补处。无数千人皆发无上平等道意

    乘无相品第二十一

最胜白佛言。菩萨摩诃萨从初发意至成作佛。云何了达一相无相。复以无相分别一相。云何菩萨以清净心游处爱欲从爱欲中复至清净。佛告最胜。行权菩萨乘无相净心。周旋五道十方世界。或生欲界形无形界。虽处于界不染于界。与善男子善女人。以法之乐而娱乐之。复游形界与诸天人同处宫殿。或在梵天与梵天王说于微妙乘无相法。处众梵中或时经行或时贤圣默然。在中独尊无能及者。又复最胜。菩萨在彼微现道教。渐降诸天使行真谛。除去诸梵计净之心。住彼形界或经百劫至百千劫。复从形界下生欲界。内常乐静独处山林。虽处人中意常禅定。或时菩萨现有居家妻子自随。复与众生同世居业。处高现卑在卑现尊。观众生心周旋坐起言语。行来进止不兴憍慢亦不自毁。所以然者。以其达了本末净故。又复菩萨复游于百千定正受三昧。以三昧威神。复观三千大千世界。现身相好光明神足。权慧方便游化自在。心应清净乃谓无相。菩萨摩诃萨应此定者。乃得求于乘无相道。不相见生不相见无。生以无习道亦不想。于圣无道之相。亦不求相亦不求无相。了达道相无相。起时即起灭时即灭。有趣道相。不相行灭有相行灭。是谓菩萨而为道相。菩萨摩诃萨亦不求相以为道相。何以故。道自无相。不求无相为道之相。不见合散以为道相。不见十二缘本我人寿命。从痴有行而有道相。亦复不见无我人寿命。从痴有行有道相也。何以故。道自无相亦不见相。不望所生冀于道相。了知四大是身非身。是常非常是空非空。是我非我取舍合散皆非真实。是谓菩萨摩诃萨应如应尔。亦不异非不异。亦不见异亦不见不异。乃应道相无相。善身不善身。记身无记身。漏身无漏身。有为身无为身。成身败身。合散取舍。以相道相分别悉空。而无所有。如梦如影如响如热时焰。亦不身空亦不身无空。亦不身想亦不身无想。亦不身愿亦不身无愿。不身亦不与无欲相应非不相应。不身亦不与十二因缘相应非不相应。十二因缘亦不相应非不相应。至十八界亦复如是。法性如尔亦不与道相相应非不相应。从痴生爱亦复如是。不与道相相应亦非不相应。一切诸法名色六入。不与道相相应亦不不相应。菩萨摩诃萨复当入于灭尽定意不动三昧。次观道相不与十八本持相应非不相应。法性不与十二因缘相应非不相应。无限无量不可思议尘劳之垢。不与道相相应亦不不相应。乃至法性诸情。不与十二因缘相应非不相应。乃至老死无淫怒痴法。不与道相相应。亦不不相应非不相应。有数无数。不与道相相应亦不不相应。道相无二。不与有数无数相应亦不不相应。于第一义。有俗无俗有漏无漏有为无为有记无记。善法恶法若好若丑。以不二行非不二行。无坏败意求于道相。求道相者。不与第一义。有俗无俗有漏无漏有为无为有记无记。善法恶法若好若丑。而共相应。亦不不相应。复次菩萨摩诃萨复于诸法无相之相。亦不见相非不无相。是道。无相亦不见相。斯谓道相应于无相。无相之相法自虚寂。如空无相非不有相。当应此相应无所应。如是菩萨摩诃萨得此道相定意者。于诸法界悉得自在。入此定已。分别己身一一毛孔。无限无量不可思议。诸佛世界悉现在前。已现世界。复现翼从弟子。菩萨渴仰闻法听无厌足。使彼大众普见三千大千刹土。如来金体出无量光。一一光明无数无量佛土。于彼佛刹现身色相。在彼大众阐扬大法。闻者牢固不舍金刚定意三昧。复于彼界百千亿劫。周旋教化示现权智。如无权智。不见权智所可化者。虽处彼界心如影像。猛焰镜形心无是念。劫数长远寻之无原。于其中间生懈慢意。亦复不念众生易化。吾于一日一夜教化周旋。普遍恒沙诸佛世界亿千万劫。诸佛所化吾为特胜。如是菩萨摩诃萨入道性无相定者。一一分别身体毛孔。周旋教化亦不疲厌。无受化者。于淫怒痴不大殷勤。净彼世界诣彼如来大会之处。不见长短起不净念。何以故。菩萨摩诃萨游无量法界降伏心意。忍诸尘劳未曾有行。无方喻行建精进行悉分别故。不思议定无道相定真际相定。一而不二亦无差别。令彼众生分别道相。有俗无俗有漏无漏。有为无为有记无记有欲无欲。不见与道相相应。亦不不相应。道相不与有俗无俗有漏无漏有记无记有欲无欲相应。亦不不相应。道相不与十二因缘相应。亦不不相应。缘痴有爱生老病死亦不相应。十二因缘不与道相应亦不不相应。缘痴有爱生老病死。不与道相应。亦不不相应。如是最胜。菩萨摩诃萨得此道相定意者。不见相应不见不相应。是谓菩萨摩诃萨于道相定意应无所应。于无相定亦不见应。亦不见不应。是谓应无所应。非罗汉辟支佛所能及知。何以故。非彼境界故。诸佛世尊不可思议。普入一切十方世界。现诸相好威仪礼节十八变化师子奋迅无畏三昧。是时最胜。菩萨摩诃萨具足如来道相定意。不舍金刚誓愿定意。过诸佛度无所度。亦不见度亦不见不度。菩萨摩诃萨心一念顷从三昧起。不舍十方苦厄众生。寻复往至四事供养。衣被饭食象马七珍。床褥卧具病瘦医药权慧调御一切。尽为众生不自为己。从一佛国至一佛国。教化周旋阐扬正法。亦无厌足入诸佛土。令彼众生悉令受化。无觉知者。兴隆佛事现一切智。心所周接寻念即至。菩萨摩诃萨入此道相定意。普入十方恒沙无央数刹诸佛世界众生之类心意识中。观察所念分别宿行。是趣泥犁。是趣饿鬼。是趣畜生。是趣天道。是趣人道。如是菩萨摩诃萨弹指之顷尽能分别众生所趣。或有众生修行善道应道相定。亦知彼众生有小乘心辟支佛心菩萨心。如是菩萨摩诃萨普游诸佛世界。礼拜承事诸佛世尊。净诸佛土。具满一切众生所念。或在诸佛刹土。见悭贪众生类。辄自示现行于大施。于彼刹土竖大施幢。以清净梵音告一切曰。诸贤当知。我名一切施无求报者。若有乏短衣被饭食病瘦医药。床卧具等。国财妻子象马七珍。菩萨布施从初发意至于成佛。除三不施。余者尽施。云何为三。一者父。二者母。三者师长。是谓立根菩萨在诸佛刹土行于布施。复次菩萨摩诃萨以善权方便。复游十方恒沙刹土。见彼众生在懈慢者。现身持戒行十八法。或在树下旷野冢间。高山深崖隐处林窟。殷勤奉戒不犯众法。游在人间执持威仪礼节。出入进止若行若坐心常恳恻。初不离戒达了禁戒。本无所有。生者皆尽一切无常。我身与彼一而不异。至竟清净。从地至地乃至十地。不见十地是碍度十地是无碍。犹如鸟飞虚空亦无足迹。解知万物皆空如空。物亦非物。非物亦非物。菩萨摩诃萨亦复如是。游于无量诸佛世界。不舍弘誓牢固之心。摄彼懈怠众生。安处入于道相正受。复次菩萨摩诃萨执权智慧。复游十方恒沙刹土。见彼众生有懈怠者。常怀嗔恚未始有悦。菩萨于彼现身忍辱。若人骂者默而不报。设复有人截其手足。毁辱其形心不变易。不兴恚怒持心如地。观达此身四大合成。神离则散有何可贵。智者分别无一可贪。亦如屠牛之家分牛为四分。了知本末悉无所有。菩萨大士亦复如是解身无主亦无所有。何者是身身为谁有。名相号字悉不真实。或有菩萨因禅行忍。在于旷野无人之处。树下端坐一心思惟。行路之人及牧牛人。担薪负草迳过其边。或以草枝而刺其鼻或刺耳门。菩萨寻觉熟观彼已。还闭其目寂然心意意无乱念亦无他想。或值行人以瓦石打掷。破伤头目毁坏形体。菩萨心识亦不移变不兴乱想。是谓菩萨摩诃萨因禅行忍接度众生不可称记。复次菩萨摩诃萨以不思议力。游至十方恒沙刹土。见有众生常怀懈慢。菩萨于彼现身精进。摄取众生安处无为。是时菩萨为一众生经百千劫。心不懈惓亦不疲厌。何以故。达了法界空无所有。以如来之道而度脱之。虽度众生亦不见度。亦不见不度。是谓菩萨摩诃萨殷勤精进心不变移亦不他想。于其中间受诸苦恼。或值刹土劫烧火起焰至梵天。或值水出亦至梵天。或值风动吹诸刹土碎如尘雾。菩萨处彼尽取生类。安处无为令不扰乱。是谓菩萨摩诃萨游恒沙刹土精进不阙。复次菩萨摩诃萨复以善权方便。游至十方恒沙刹土。见彼众生心乱不定。菩萨于彼现乎坐禅。或坐村落或坐树间。或坐山林深窟之中。或经百千劫心无他想。引取众生令心不乱。是时菩萨在于路侧入定。其三昧名无形想定。入此定者。或经一劫至百千劫。天地融烂山河树木悉皆散落。海水泉源江河駃流悉皆涸竭。入定菩萨处中坐禅。心不变移亦不腐坏。或放牛人担薪负草经过其边。或以木枝而刺鼻者或刺耳孔。或直擘眼而视者。或开口而看齿者。或前取发顶捉而不能得者。或以利刀剪菩萨爪而不能得者。何以故。皆是菩萨定力威神不可沮故。十方诸佛复加威神。令此菩萨不遭苦恼。是谓菩萨摩诃萨游于十方恒沙刹土。见彼乱意便自入定。从劫至劫不以疲惓。复次菩萨摩诃萨复以善权方便游至恒沙刹土。观见众生有愚惑者。菩萨于彼示现智慧。为彼众生分别义趣。思惟三世现在之事。越次诸地。从地至无地。从无地至地。犹如飞鸟无所触碍。菩萨亦复如是。非像为像像为非像。非物为物物为非物。云何非像为像像为非像。于是菩萨入虚空际定意正受。观他方世界。药果树木山河石壁。悉空如空。空亦空无。菩萨摩诃萨亦复如是。一切世界皆如空等。是谓菩萨摩诃萨非像为像像为非像。非物为物亦复如是。复入众智自在定意示现众生除愚闇想。皆悉安处令至彼岸。是谓菩萨摩诃萨游于十方无量世界。观彼众生愚惑想者。为现慧明永无闇昧

十住断结经卷第七十住断结经卷第八

        姚秦凉州沙门竺佛念译

    等慈品第二十二

尔时最胜菩萨前白佛言。云何菩萨入等慈三昧。遍观三千大千世界。人阴神阴诸龙鬼界。一身二身至百千身。云何菩萨以神足力。从一佛国至一佛国。如人游虚亦无挂碍。尔时世尊告最胜曰。快哉斯问甚奇甚特。吾今与汝敷演其义。谛听谛听善思念之。一切诸法虚寂无本。成道众智寻亦无迹。菩萨入定正受三昧。遍观三千大千世界。其中众生有形之类。观五阴身生者灭者。为所从生为所从灭。复入空界地水火风。一一分别了无所有。法起则起法灭则灭。最胜当知。昔我久远修菩萨道。禅定一意执心不乱。入不动三昧。观虚空众生。无限无量不可称记。随其形类而教化之。其中众生有淫怒痴无淫怒痴。有爱欲意无爱欲意。有嗔恚心无嗔恚心。菩萨权慧随类而入。形与彼俱称适一切。心入定意终无乱错。弹指之顷入于百千诸佛刹土。或以法性慧观教化。或以空法苦空非常导以正法。菩萨所化亦无边崖。以十善之行而教授之。云何为十。先净国土不计其功。敷演其慧明知无碍。坐道树下心无怯弱。降伏魔怨令知邪趣。游处境界度人无量。心如地界忍而不动。分别根门难易之相。纯熟之行靡不斟酌。一一分别阴持入行色痛想行识。观内六情去外六尘。若眼见色不兴眼识。外色内识悉了虚无。色为是谁眼识所在。若耳闻声不兴耳识。外声内识悉了虚无。声为是谁耳识所在。若鼻嗅香不兴鼻识。外香内识悉了虚无。香为是谁鼻识所在。若舌知味不兴舌识。外味内识悉了虚无。味为是谁舌识所在。若身知细滑不兴识想。外更内识悉了虚无。细滑为谁身识所在。最胜当知菩萨入定一一分别随类教化。或以言教或以神足或以权慧。随类而入无所挂碍。是时菩萨复以十法训化众生。云何为十。一者慧根具足定意不乱。二者觉意牢固演慧无碍。三者敷畅道品具足义趣。四者解相玄寂众好不阙。五者解道非道了知虚无。六者意崇法轮诲而不惓。七者行菩萨道不见己身。八者虽度众生不见有度。九者解内外空一而无二。十者分别身体不见有化。是谓菩萨摩诃萨具足十法。便能周旋诸佛刹土。从一佛国至一佛国。亦未曾离诸佛世尊。菩萨当念修诸总持门。云何为总持。诸法印可总持。菩萨得此总持者。于一切法去诸妄想。复有普光总持。菩萨得此总持者。等慈一切不怀颠倒。复有慧明总持。菩萨得此总持者。不净国土令得清净。复有照曜总持。菩萨得此总持者。于诸乱意悉无尘翳。复有义辩总持。菩萨得此总持者。习观众行入定不动。复有法辩总持。菩萨得此总持者。分别句义不失次叙。复有响辩总持。菩萨得此总持者。观察音响随类而度。复有应辩总持。菩萨得此总持者。应适一切具足众行。复有意止总持。菩萨得此总持者。尘劳结缚永息不起。复有意断总持。菩萨得此总持者。微察诸法亦无犹豫。复有神足总持。菩萨得此总持者。住寿在世经百千劫。复有根本总持。菩萨得此总持者。分别根门兴衰不变。复有力势总持。菩萨得此总持者。修金刚体无能沮坏。复有觉意总持。菩萨得此总持者。敷演诸法开悟一切。复有道品总持。菩萨得此总持者。观了三世因缘法本。复有定意总持。菩萨得此总持者。于诸乱想怀来道故。复有权慧总持。菩萨得此总持者。应适无方亦无觉者。复有布施总持。菩萨得此总持者。解知三事悉无所有。复有持戒总持。菩萨得此总持者。不见修戒及以毁者。复有忍辱总持。菩萨得此总持者。不见恚忍及以乱想。复有精进总持。菩萨得此总持者。不见进业及以懈怠。复有正受总持。菩萨得此总持者。万响雷震衣毛不坚。复有慧空总持。菩萨得此总持者。包识万智畅演无碍。复有无碍总持。菩萨得此总持者。于诸通慧无所挂碍。复有旷远总持。菩萨得此总持者。虽百千身还合为一。复有教授总持。菩萨得此总持者。训以正法言不烦重。复有不思议总持。菩萨得此总持者。非是罗汉辟支所及。复有道树总持。菩萨得此总持者。庄严刹土不离诸佛。复有降魔总持。菩萨得此总持者。执意牢固心不倾斜。复有容相总持。菩萨得此总持者。一一诸相致百千福。复有众好总持。菩萨得此总持者。不见相好璎珞随身。复有光曜总持。菩萨得此总持者。于百千光见化无量。复有度人总持。菩萨得此总持者。虽度众生亦无度者。复有广慧总持。菩萨得此总持者。意如虚空无有偏狭。复有道意总持。菩萨得此总持者。不想泥洹亦不著有。复有灭度总持。菩萨得此总持者。不见有灭及以生者。复有清净总持。菩萨得此总持者。尘埃以净无尽不尽。复有无苦总持。菩萨得此总持者。解苦无苦名曰苦谛。复有生习总持。菩萨得此总持者。习本意缘悉了虚无。复有灭尽总持。菩萨得此总持者。灭习尘劳更亦不造。复有圣道总持。菩萨得此总持者。安处无为永寂泥洹。复有止观总持。菩萨得此总持者。观了妙法兴衰所趣。复有空藏总持。菩萨得此总持者。于深法要无所挂碍。复有法观总持。菩萨得此总持者。观了诸法悉知无主。复有净声总持。菩萨得此总持者。口言柔软如梵天音。复有称可总持。菩萨得此总持者。为人所说可其心意。复有等意总持。菩萨得此总持者。温润流利言不滞碍。复有游处总持。菩萨得此总持者。所可教戒无所伤损。复有威曜总持。菩萨得此总持者。在于大众亦无怯弱。复有奋迅总持。菩萨得此总持者。为师子吼飞落走伏。复有戒律总持。菩萨得此总持者。降伏一切难悟众生。复有趣道总持。菩萨得此总持者。解知泥洹无起灭想。复有法性总持。菩萨得此总持者。诸谀谄人令见真道。复有息意总持。菩萨得此总持者。不兴憍骜生人自大。复有通达总持。菩萨得此总持者。闻彼圣慧不失法教。复有兴敬总持。菩萨得此总持者。即弃贡高承事诸佛。复有空界总持。菩萨得此总持者。渐入本净寂然法界。复有无碍总持。菩萨得此总持者。以达仪轨解诸法本。复有无量总持。菩萨得此总持者。古昔所说亦无穷尽。复有强记总持。菩萨得此总持者。分别文字知法趣向。复有究竟总持。菩萨得此总持者。解人本性法界亦净。复有难灭总持。菩萨得此总持者。晓众生净内外虚寂。复有无际总持。菩萨得此总持者。解知本无本无亦无。复有璎珞总持。菩萨得此总持者。所说经法无所挂碍。复有妙要总持。菩萨得此总持者。于尽无尽亦不见尽。复有分别总持。菩萨得此总持者。非是二乘之所筹量。复有如来总持。菩萨得此总持者。觉寤众生趣寂寞道。复有十地总持。菩萨得此总持者。恒说无住亦不见住。复有阴种总持。菩萨得此总持者。分别身本不兴染着。复有寂寞总持。菩萨得此总持者。譬如呼声亦无音响。复有识性总持。菩萨得此总持者。悉能思惟不著文字。复有了本总持。菩萨得此总持者。无言无说亦无教戒。复有文字总持。菩萨得此总持者。自识宿命知所从来。复有法轮总持。菩萨得此总持者。无意无想亦无神识。复有甘露总持。菩萨得此总持者。讲诵说法亦无挂碍。复有深入总持。菩萨得此总持者。一一分别四句合义。复有法幢总持。菩萨得此总持者。晓了谊理明识法本。复有无尽总持。菩萨得此总持者。究畅本际不离眷属。复有等觉总持。菩萨得此总持者。常讲无量无著正法。复有诸法总持。菩萨得此总持者。玩习诸法不失次绪。复有弘誓总持。菩萨得此总持者。解了智慧悉无逆顺。复有善权总持。菩萨得此总持者。随类适化不怀怯弱。复有道慧总持。菩萨得此总持者。分别顶法修度无极。复有幻化总持。菩萨得此总持者。分别法界无内外性。复有中阴总持。菩萨得此总持者。诸佛世尊所居窠窟。复有道场总持。菩萨得此总持者。十方刹土晃然金色。复有降魔总持。菩萨得此总持者。一切外道靡不降伏。复有自守总持。菩萨得此总持者。护身口意不见有护。复有说法总持。菩萨得此总持者。具足法本无所缺漏。复有自用总持菩萨得此总持者。观察无量众生心意。复有殷勤总持。菩萨得此总持者。方便所说使入道捡。复有流化总持。菩萨得此总持者。分别诸慧不着古今。复有柔顺总持。菩萨得此总持者。受法无厌亦无恚惑。复有进德总持。菩萨得此总持者。于诸法本悉无所有。复有色像总持。菩萨得此总持者。其有睹形未曾忘舍。复有声闻总持。菩萨得此总持者。挍计诸法无量无著。复有苦顺总持。菩萨得此总持者。听采法味平等无二。尔时世尊说此总持法门时。十二亿那术人皆得尽信不起法忍。复有无央众生悉发无上正真道意。是时世尊告最胜曰。菩萨所行不可思议。非是罗汉辟支佛所知。等慈三昧定意正受之所感动威神能尔。以是之故说大乘律。导以正化捡以法服。是时最胜前白佛言。善哉善哉。快说斯言。一切诸法习无本末。解了法性虚无寂寞。一一分别皆虚皆寂。大乘所演广及一切。闻菩萨行寿终之后。皆得生于旷忍世界。尔时众会尽皆犹豫。欲得睹见彼佛刹土。如来神鉴寻知众生心之所念。即以神足出顶光明。普照三千大千世界。及彼旷忍无量刹土。旷忍佛名号曰无尽。顺执总持强记不忘。殊特之法恒以在前。从恒沙劫供养诸佛。积累道法自致得是无上等正觉。佛告最胜菩萨当念修行十住。云何为十。一者分别法界了知虚无。二者解身虚寂内外无主。三者四大觉意不猗有余。四者于一切法不见灭度。五者身口意行寂寞不住。六者护戒无戒亦不毁戒。七者无放逸行捡心为本。八者誓愿成道不舍本志。九者不思议法度难寤者。十者众行清净所行不重。是谓菩萨摩诃萨之所修行十法之本。复次菩萨次当习于十法之号。云何为十。一者戒具清净无放逸行。二者闻以施惠不毁法界。三者分别阴入了知虚寂。四者知四非常悉归磨灭。五者十八难解阴持入病。六者具足誓愿诸佛加叹。七者未立根众生安处无为。八者菩萨入定无能乱者。九者遍观一切内外诸行。十者自观身本生灭之相。是谓菩萨摩诃萨当念修行十法之本。便得自致成最正觉。复次菩萨复当习定正受三昧。所谓三昧者等观三昧。菩萨得此三昧者。建立慧观不为放逸。复有三昧名曰摄意。菩萨得此三昧者。能摄众结不令缚着。复有护戒三昧。菩萨得此三昧者。守身口意不生尘劳。复有平等三昧。菩萨得此三昧者。意如虚空不兴二想。复有大宝三昧。菩萨得此三昧者。演七觉意无尽之宝。复有道树三昧。菩萨得此三昧者。道花敷卓见莫不欢。复有海量三昧。菩萨得此三昧者。非是二乘所可斟量。复有入室三昧。菩萨得此三昧者。深要法藏靡不斟酌。复有月光三昧。菩萨得此三昧者。普游诸佛往来周旋。复有月明三昧。菩萨得此三昧者。普曜一切靡不蒙光。复有玄鉴三昧。菩萨得此三昧者。解了三世无起灭法。复有无憎爱三昧。菩萨得此三昧者。怨储平等视如赤子。复有大哀三昧。菩萨得此三昧者。视一切众如父如母。复有悲慈三昧。菩萨得此三昧者。为一切众为其雨泪。复有愍哀三昧。菩萨得此三昧者。亦无吾我我人寿命。复有无想三昧。菩萨得此三昧者。便能转于无上法轮。复有行苦三昧。菩萨得此三昧者。于阿僧祇劫不唐其功。复有建力慧戒三昧。菩萨得此三昧者。不见吾我清净之行。复有离身三昧。菩萨得此三昧者。去离系缚亦不毁戒复。有吾我三昧。菩萨得此三昧者。于彼此岸亦无染着。复有玄通三昧。菩萨得此三昧者。语法忍辱无寂不寂。复有清白三昧。菩萨得此三昧者。于清白行思惟分别。复有相应三昧。菩萨得此三昧者。与相应法不起不灭。是谓菩萨摩诃萨正受三昧。游至他方诸佛刹土。事事供养诸佛世尊。亦不恐惧无所畏难。正使身坏于中命终节节离解。自观其身如草木墙壁。不兴染着而行忍辱。彼闻恶言不以为戚。虽遇欢乐亦不为庆。寻其言教亦无处所。晓了所言亦无本末。本无之心各各无实。是谓菩萨摩诃萨清净定意。彼虽乱心心无所结。亦不在此复不在彼。于内外法皆悉清净。以观如此则为忍辱。是谓菩萨摩诃萨身口意净建立慧忍。复次最胜。菩萨摩诃萨当复修行精进定意。长诸善法无所漏失。观其法界不增不减。无漏慧观以为法御。复当思惟观猗世法。不见诸法有成就不成就者。不见正谛及与颠倒。不随不舍亦无去就。是诸菩萨摩诃萨珍宝积聚无尽之藏。不见去来现在之法。何所从来何所从去。来亦无处去亦无迹。贤圣八道诸法之首。一一分别贤圣四谛。去离颠倒妄想之行。为人说法无所滞碍。解了众生虚而无实。推寻诸法亦不可得。所以然者。法法相生法法相灭。人不离法法不离人。人自虚寂法亦虚寂。如人自然法亦自然。解自然者乃应无上正真之行。便逮佛法无尽之行。其有求法。若以求者。方当求者。三世无著无所染污。彼以求者彼求此已。亦无所得亦无所失。是谓最胜菩萨摩诃萨建立妙慧精进之行。最胜当知。菩萨摩诃萨复当思惟禅定之行正受三昧。不毁法戒平等无二亦不见二。亦不成就非不成就。彼于禅定而以正受。一切诸定不起乱想。诸法无想亦无放舍。解了内外悉无有主。是谓菩萨摩诃萨一意正受不毁禅定。亦复不见有合会。舍诸境界无有去离。行无著禅意趣无难。是谓菩萨摩诃萨不立于法亦不离法。恒以一意诸法自然。解了诸法无生灭想。非身非心所能忖量。思惟定意平等无二。志性所趣无应不应亦不见应。分别十二因缘之本。缘行有痴。缘痴有识。缘识有名色。缘名色有六入。缘六入有更乐。缘更乐有有。缘有有爱。缘爱有受。缘受有生。缘生有死愁忧苦恼。不可称计。取要言之。五盛阴身危脆之形不可久保。菩萨是时等行本无。分别色痛想行识悉了虚寂。复以正受。于本净法亦无染着。亦不见色解色无色。度于一切颠倒之行。是谓菩萨摩诃萨禅定一意。非是罗汉辟支佛所及。外道五通虽寿无量。由失神足不至究竟。禅定之人正受三昧。住寿一劫复过一劫不以为难。以得禅定出智慧上。除弃尘劳不兴妄见。是谓菩萨摩诃萨志愿于道开化众生。随形应适随病投药。复以空性慧观之法。入等慈三昧。遍观三千大千世界。转至恒沙诸佛刹土。应度众生悉令解脱。是则如来禅定正受。皆使黎庶至于灭度。是谓菩萨摩诃萨建立等慈定意。所济无量不可称限。是谓最胜。如来神德巍巍如是。夫欲观法当以慧眼。亦非肉眼亦非天眼。亦非罗汉辟支所睹。以观诸法。解诸法寂解诸法净。解诸法虚解诸法定。是谓菩萨摩诃萨无限无量弘誓之心。无行无处亦无所入诸法寂然。定者所习非乱者所行。普观诸法悉皆如是。如是观者是为法观。法观菩萨不见诸法之所归趣。其有观法而不分别斯等之类。阙于道场不至究竟。不以正法而成定意。菩萨当念除去妄见无求无取。亦不摸贸求受重福。知内外法悉皆虚寂。是为菩萨摩诃萨入等慈三昧。观了诸法悉无所有。以无所有乃名见法。夫见法者。无我无人无寿无命。斯皆假号非真实法。有为之法非无为境界。无为之界非有为之法。菩萨解知有为无为有漏无漏是常非常。我人寿命悉无所有。是为菩萨摩诃萨分别定意无生灭法。假使菩萨观诸法相。解知众相虚寂无二亦不见二。解二无二乃应定意。于颠倒法解无所有。不见有正趣于道者。不见有邪当趣诸见。盖于众生无量之慧皆发大哀。净佛境界净佛刹土。从一佛国至一佛国。承事供养诸佛世尊。复以神通明慧之观。普察三千大千世界。颇有众生诸根纯淑。不遇贤圣坠于三途。是时菩萨要住拔济使不雕落。或复是时菩萨达士。因庶众生兼复造缘。周旋往来不唐其功。弹指之顷游于百千正受定意。建立慧观修诸功德。若行施时。计天人本亦无施者。解知三事悉无所有。是谓菩萨乃应于施。若复菩萨以律训诲。解知犯戒及以禁律亦无所有。无戒不戒乃应戒也。或复菩萨恒行忍辱。见行忍者代其欢喜。设遭恚怒不怀忧戚。懈怠忍辱悉无所有。亦非一二至于百千。解忍无忍乃应忍辱。复次菩萨常行精进。见精进者代其欢喜。设遭懈怠不以为恨。解知懈怠及以精进。一而不二亦不有二。亦不有进亦不有怠。解进怠虚寂乃应精进。复次菩萨若行若坐常若一心。禅定正受未曾亏损。天雷地震万响俱作。专心一意无能移转动菩萨心。解知定乱悉无所有。解定无定乃应定意。复次菩萨智慧所润泽及黎庶。包识万机应适无方。畅达演说不毁佛教。平等慧观不见贤愚。解慧无慧及与愚惑悉无所有。亦不见有亦不见无。有无悉虚空寂无二。是谓菩萨应于智慧。如是清净诸法之相。亦不见相非不有相。解相无相乃成相好。拔济众生至无为岸。复次菩萨复入空定游虚空界。一一分别空界众生。或以言教或以神足。或以光相或以苦行。而教化之趣使众生得入道捡。复次菩萨行无想法。除去想着颠倒之行。复游他方诸佛刹土。恒以无想不变易法。训化众生普至无为。复次菩萨行于无愿。不求三界受有之报。不猗着人不着相好。分别内外五阴成败。色痛想行识外尘内入。一一分别虚而不真。如是最胜。菩萨大士发大弘誓。度众生类不见有度。尚无众生况有度者。是谓菩萨摩诃萨建立等慈定意。普使众生逮得慧根。尔时世尊说此等慈品时。十四那术人皆发无上正真道意。八千菩萨寻于坐上逮得等慈三昧

    法界品第二十三

尔时世尊。放舌相光明普照三千大千世界。复照十方诸佛国土。四维上下靡不蒙照。复照东方八十四亿。江河沙数寂寞世界。诸佛普集无有二乘。恒讲菩萨殊持之行。分别世界各有次第。吾亦从彼来至忍界。所以然者。发愿探筹无错乱故。佛告最胜。今我自忆在彼佛众。一亿诸佛同时取筹。我为元首当此世界。慈氏元吉师子勇慧德普广闻金颜玄寂宝雄常悲鲜洁弘誓。如斯等佛一亿如来。同时受筹适此忍界。佛告最胜及来会者。诸佛世界不可思议。改形变化权现无方。汝等焉知慈氏菩萨方习菩萨行乎。莫造斯观。所以然者。慈氏积行恒沙数劫。先以誓愿成等正觉。吾方习行而在其后。或现苦行或现光相或现菩萨儒童弟子。随人本行而为说法。慈氏菩萨在彼坐上。佛告弥勒。现佛光相翼从多少。尔时弥勒隐菩萨身。还现佛形刹土国界。弟子菩萨不可思议。众会见之叹未曾有。无形自然。色相自然。诸法自然。一切诸佛亦复自然。时彼大众复见东方八十四亿。江河沙数寂寞世界。诸佛世尊论讲菩萨殊特之行。千八百微妙法门。何谓千八百微妙法门。菩萨习于本净法门。获此法门者。不于本际而受其证。复有无言说法门。菩萨得此法门者。游虚空界无能觉知。复有无所得法门菩萨得此法门者。虽度众生亦不见度。复有无所持法门。菩萨得此法门者。解知本净内外无主。复有名号法门。菩萨得此法门者。一切诸法虚而无实。复有成就法门。菩萨得此法门者。虽处有为不著有想。复有化识法门。菩萨得此法门者。入无形界无形教化。复有现形法门。菩萨得此法门者。现形无数而教化之。复有因缘法门。菩萨得此法门者。为彼众生而造因缘。复有法声法门。菩萨得此法门者。但闻音响不见其形。复有离有法门。菩萨得此法门者。不见生灭着断之法。复有解脱法门。菩萨得此法门者。不见泥洹有趣灭度。复有深奥法门。菩萨得此法门者。分别如来秘要之典。复有无色像法门。菩萨得此法门者。入无色定而教化之。复有无观行法门。菩萨得此法门者。佛法无教亦无处所。复有数息法门。菩萨得此法门者。诸法无数解息无息。如是最胜。菩萨摩诃萨获如此等千八百微妙法门。时诸众会闻彼诸佛说此微妙法门。尽于坐上得尽信法忍。无数众生趣小乘者。皆发无上平等道意。尔时世尊及以弥勒。还摄光明从面门入。如来大哀巍巍若兹。开化众生不可称量。各使至趣令立坚固。

尔时众会复作是念。向者我等皆共普见寂寞世界。如今忽然悉无所有。将非幻化野马水影乎。复非梦镜恍惚耶。尔时世尊。即知众会心中所念。便告舍利弗曰。云何舍利弗。汝颇曾闻如来与汝。说声闻行是有为法是无为法。是有漏法是无漏法。是真实法是非真实法。是现法是非现法。是尘劳法是非尘劳法。是有数法是无数法。是有着法是无著法。是有习法是无习法。是嗔恨法是非恨法。是可舍法是非舍法。是凡夫法是非凡夫法。是贤圣法是非贤圣法。此意止神足法此非意止神足法。此根力觉道法此非根力觉道法。此学法此非学法。此声闻法此非声闻法。此缘觉法此非缘觉法。此菩萨法此非菩萨法。此佛法此非佛法。云何舍利弗。汝曾闻如来说此言教乎。舍利弗对曰。非也世尊。佛告舍利弗。我今犹尚在声闻众。不说断漏有缘着想。况当演教有窠窟乎。此事不然。说法轮讲悉无处所。无言无教亦无法想。法出响应岂有法也。云何舍利弗。今当引譬智者以譬喻自解。犹如士夫勇猛之人。观虚空界悉了无形。然复彼人意欲规郭。以众彩色欲画虚空。或作天像或作人像。或作龙鬼神旃陀罗像。或作蜎飞蠕动畜生之像。云何舍利弗。彼人施意宁能不乎。舍利弗对曰。非也世尊。甚难甚难至未曾有。佛告舍利弗。如来权化不可思议。施设言教甚难于彼。所以者何。一切众行有为法无为法。有漏法无漏法。道法俗法。十二因缘及六识身。四意止四意断四神足五根五力七觉意八直行。过去当来现在诸佛。无形无像不可睹见。亦无取舍亦无聚散。不可携持而不可得。虚空境界虚寂无二。诸佛世尊游诸方界。为一切众生讲说言教。实无名号强为假号。实无文字强为文字。实无法性而说法性。复次舍利弗。菩萨摩诃萨以权方便应适众生。随彼根本此乃甚难。设有比丘僧比丘尼优婆塞优婆夷。笃信如是虚无寂法。具足众行便能成就如来相好。从一佛国至一佛国。承事供养诸佛世尊。复于彼佛得强记总持。亦复受此深妙之义。转复演布咸使闻知。菩萨摩诃萨当念具足七无著法。云何为七。解一切有悉无所有。不染于有亦不见有。现其形像亦无色相。犹无有佛况色相乎。一切世界亦无端绪。况当有本而可推耶。众生根本无穷无底。谁能发意料量其行。法自然生法自然灭。亦复不见有生有灭。诸法如化诸法如幻。亦复不见幻化野马。诸法自然诸法无生。亦复不见生灭着断。是谓舍利弗。菩萨摩诃萨成就此七无著法者。便能具足一切众行。渐渐得至成菩萨位。坐佛树下降伏魔怨。众德著积光相具足。从第一住乃至十住。于其中间未曾退转。恒为诸佛所见拥护。天龙鬼神干沓和阿须伦迦留罗旃陀罗摩休勒。供养华香作唱伎乐被服幢幡。转加功德威神扶接。自上无上至真之道。佛复告舍利弗。自念我昔修菩萨道。或为儒童。或为梵身。或时出家修沙门律供养江河沙数诸佛世尊。或以头目国财妻子。或以医药四事供养。但闻诸佛论讲苦义空义非身之义。或说六度空无想愿。或说禁戒学道之法。或说忍辱仁和之教。或时隐处经劫不起。或禅入定形神不动。皆由内法未成就故。佛复告舍利弗。吾始从寂寞世界诸佛世尊。即得闻此深妙之法。诸来菩萨大士集者。应时逮成柔顺法忍。尔时众会诸在坐者。二万四千众生。应时逮得不起法忍。去来诸佛及现在者。皆共宣传颁畅深法悉无处所。亦复不见我人寿命。观察众生根本纯淑。众生有想以无想教授。众生有念以无念教诫。众生有碍示以无碍。若有善男子善女人。讽诵善持此深奥法。若复演布为他人说。其福功德不可称限。若有学人修菩萨道。慈悲喜护愍伤一切。欲令成就登菩萨位。常当修持深奥法藏。若善男子善女人。遍满三千世界。受持五戒遍行十善。四禅四等四空定。不如一闻斯深法奥。若不能多思惟亦可七日。若不能七日六五四三乃至一日。若不能一日弹指顷可。云何舍利弗。如汝声闻其数弥满十方世界。四事供养衣被饭食。床敷卧具病瘦医药。从亿亿劫复过亿亿劫。不如一闻深要之法。所以者何。菩萨法藏珍宝之聚。若复演说一句之义。无常苦空非身之义。三脱法门及四明慧。空无想愿虚寂之行。不生不起无灭尽行。如是菩萨摩诃萨是则安隐无量德行。福不可限无以为喻。若有菩萨以限碍身修有为法。教化众生使充所愿。然彼之类未曾更闻无为之道。欲履菩萨深奥法者此事不然。若有菩萨定意正受从无量法。宣畅演布深奥法典闻无为法。诸法虚空悉无所有。是则深义无能及者。是故菩萨若欲具足众生愿者。欲与他人说其义者。复欲宣畅如来菩萨秘要法者。欲使众生成四果证者。常当念学此深法要。佛复告舍利弗。昔吾游学为菩萨行。常习六度四等。大慈加被众生演甘露味。或演言教。或贤圣默然。或现神足。或以善权巧便。或以神通五道。或以一道周游。或以辟支飞钵虚空。或以声闻禀受言教。或现儒童状如无知。舍利弗当知。菩萨教化权现无方不可穷尽。随世习俗随类而入。亦入于地亦入于水。亦入于火亦入于风。菩萨分别四大本原皆无有主。分别地界内外虚寂。水火风界亦复如是。复观众生有淫怒痴无淫怒痴。有爱欲心无爱欲心。有憍慢意无憍慢意。有定意无定意。有乱心者。无乱心者。菩萨悉皆分别。或以安般守意。或以恶露不净观。或以泥洹灭尽之法。或以有为无为法。或以有漏无漏法。或以俗法。或以道法。或以神通漏尽之道。而教化之。吾曾游处通慧世界。为一众生十二中劫入禅定意形神不动。不辞劬劳待而教化。此众生者岂异人乎。莫造斯观。卿欲知者。今最胜菩萨是也。最胜菩萨。在通慧世界生豪族家。由宿积德不生贫匮穷困之家。一生二生至百千生。乃至十二中劫受形。常在豪贵不处卑贱。吾亦入定去彼不远观其心意。于百千劫不解一句深奥之法。后能自悟豁然心开自归我身。欲闻深妙无量法典。而为说法无尽之藏。所谓无尽藏者分别音响。或以一音遍满三千大千世界。或以一句应适一切众生心意。所吐言教过于梵音。复有六通无尽藏。往诣十方诸佛世界。承事供养如来世尊。禀受深妙难有之法。于诸苦行。过于精进持戒忍辱精进一心智慧善权。复有无尽藏。使有四意止。四意止者无漏法行。法意止者泥洹径路。余者凡夫之所修。四意断四神足。五根五力。七觉意八贤圣道。报应果证悉无所有。亦不见有。是谓菩萨无尽之藏。何者可尽。平等光曜善讲本性是可尽也。法性相修为可尽也。心所思惟为可尽也。思惟五阴为可尽也。晓了十二因缘为可尽也。知内外四大为可尽也。舍利弗对曰。非也世尊。非是如来所能究尽。佛复告舍利弗。复有四事法无尽之教为辩才门。云何为四。一者分别无尽慧。二者分别无尽慧明。三者思惟强记总持。四者分别辩才无外。是谓舍利弗四无尽之藏菩萨所可修行。复有四无尽之藏不可携持。云何为四。一者其性难携放逸不住。二者道心难携本性甚深。三者入诸本际习无本末。四者入众生意了知无法。是谓菩萨摩诃萨无尽之藏。佛复告舍利弗。菩萨复有四牢固无尽之藏为辩才法门。云何为四。一者志愿牢固不着邪部。二者本行清净不兴尘劳。三者古佛言教立忍无恚。四者随缘造行不失本誓。是谓菩萨摩诃萨无尽之藏辩才法门。在道树下降伏魔怨意无怯弱。复有四转轮法门无尽之藏。云何为四。一者所言至诚不毁他人。二者究尽缘起知所从生。三者训诲众生初无懈倦。四者分别明慧上菩萨位。是谓菩萨摩诃萨不毁法戒无尽之藏。菩萨摩诃萨常所修行。佛复告舍利弗。菩萨摩诃萨复有四无尽之藏成就法界。云何为四。一者照曜法界通达往来。二者照曜法性解无所有。三者分别肉眼天眼慧眼法眼佛眼。云何为肉眼。观睹色像不无眼识。云何为天眼。所谓天眼者。睹天色像不见报应。慧眼分别不见尘垢。法眼清净具足六度。佛眼了朗观相无相。四者照曜报应不着三界。是谓菩萨摩诃萨无尽之藏成就法界。佛复告舍利弗。菩萨摩诃萨复有四无尽之藏。云何为四。一者精进不定意。有求慧意无求慧意。有尽意无尽意。有得意无得意。内外分别悉无所有。是故舍利弗。行权菩萨在在处处。周旋教化精进为上。修行禁戒勤力为本。从诸世尊求积功德。闻法欢喜合集明慧。布演道教亦无言教。当来过去见在诸法。慧观坚固乃为真教。如来所说不以文字。文者清净说法亦净。是为积慧功德立忍坚固立不退转。是谓舍利弗。不以贪色亦不猗色。非不有色解色无色。故曰法性。正使三千大千刹土。香薰细滑缯彩幡盖。来供养者不孚用喜。远离懈怠不怀怯弱。避贪乱意除嗔恚心。成等正觉演布秘要乃得成佛。舍身所安立弘誓心。代彼众生受其苦恼。精进乐法。趣使众生进入法室至修道者。诸天证明。天龙鬼神犍沓和阿须伦迦留罗旃陀罗摩休勒人与非人悉来供养。善男子善女人。扶佐劝助使成佛发愿坚固要使成慧中无有退。度诸因缘堕三涂者。无识无觉亦无究竟。是谓舍利弗。菩萨摩诃萨修无想念法无言教法。乃能得成如来圣教。尔时坐上诸来会者。闻斯深法。皆发无上不退转地。尔时舍利弗前白佛言。向所闻者。斯等诸人久如成佛乎。佛告舍利弗。斯等诸人二百无央数劫当成为佛。皆同一号无垢超德如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰清净劫名难度。彼佛世界纯以一乘。无有声闻辟支佛名。常论菩萨无量德行。土地平正无有山河堆阜河涧溪谷若干种色。如天綩綖。无有日月光明所照。自谓众相光光相照。众德广普众生所念万若干想。所以然者。以其法界无差违故。彼佛世界食自然甘露着。劫波育衣。犹如第六天乐所居。土地丰熟五谷平贱。七宝具足金银珍宝车磲马瑙真珠虎珀。有转轮圣王名曰雨华。七宝导从。所谓七宝者。一名轮宝。所谓轮宝者。纵广十四肘。纯以七宝。轮有千辐。辐辐有相。王意欲东轮即前导。二者象宝。所谓象宝者。色如白雪。口有六牙。牙牙有相。王欲乘象游观世界。弹指之顷游于世界亦无有难。三者马宝。所谓马宝者。身绀青色朱髦尾。乘虚而行脚不蹑地。马一鸣吼震于世界。靡不闻者。王意欲乘东西南北。弹指之顷皆悉周遍。四者玉女宝。所谓玉女宝者。身作优钵莲华香。口作牛头栴檀香。纯肉无骨为人端正。不肥不瘦不长不短不白不黑。备具女姿六十四变。王意欲纳辄便在前。五者珠宝。所谓珠宝者。方三仞高七仞。王意欲试彼珠宝者。夜非人时。即召军马集四种兵。夜出珠宝着万丈台头。普照世界靡不蒙光。珠自往来随王所念。六者典藏宝。所谓典藏宝者是时转轮圣王。意欲游行方域世界。路由大海无底之源。王意欲试典藏证验。即敕御者且止此海。吾欲停息便敕典藏宝。吾今须金银珍宝车磲马瑙珊瑚虎珀水精琉璃。卿能得乎。时典藏宝寻跪水中。以器[(爽-(爻*爻)+(目*目))*斗]水。随意所念七宝自至。七者典兵宝。所谓典兵宝者。王意欲集四种兵众。即告典兵宝曰。吾欲捡挍四种兵众。使时不移能得办乎。彼典兵宝。复白王言。不审圣王须兵多少。王告之曰。吾须前后左右各各万葙。时彼典兵宝。随王教令即如其言。四种兵集。所谓四种兵者。象兵马兵车兵步兵。一一兵者。将从有十。四种兵各各亦然。尔时佛告最胜诸来会者。尔时转轮圣王。岂异人乎。莫造斯观。所以然者。今最胜菩萨身是也。所在变化言声柔软。人民之类皆承法音。寂然恬泊讲度无极。四恩四等六重之法。善权方便入灭尽定。离欲无垢。空无相愿无为之法。无生灭法无端绪法。其有萌类诸天世人在彼境界者。分别圣慧无漏道根。或示音响指授明法。以苦切之教将入法律。或以神足变化光明教授。欲使众生渐入究竟。佛告舍利弗。一切众生无我人相。诸法本净诸法无形。无著断法诸法无坏。观了佛土悉无所有。又复舍利弗。十二因缘五阴六衰都无形像。如来八种音声。不男音不女音。不强音不软音。不清音不浊音不雄音不雌音。此由檀度受实果证。解知清净照于法界。或以一音遍满三千十方世界。吾曾游处野马世界。去此七十二亿。江河沙数诸佛刹土。在彼周旋放大音声。遍满彼佛刹土。其闻音者百亿众生立不退转。皆发无上正真道意。时我弟子名曰目连神足第一。登一须弥山。复登一须弥山。如是经劫从劫足不蹑地。时目犍连在野马世界。放大音声遍满三千十方世界。于彼音声而演斯教。如来说法未曾有行。亦不见行非不有行。解行无行故曰清净。诸法无象亦无音响。复说四谛如尔法性。解苦无苦不住于苦。入如此慧故曰苦智。因习畅本解习无习。不见有习故曰习智。知尽处所由尽而生由尽而灭。亦不见尽是谓尽智。无为道者。不见窠窟。去来今佛之所称誉。今佛说者亦无有道。去来所说亦复如是。道无形像不可睹见。解道无道故曰道智。是谓菩萨摩诃萨分别道议。时彼野马世界一切众生之类。但闻其声不见其形。时彼大众愕然有怪。斯是何人。布大音声震动世界。兼复演说深奥之议。时彼如来知众生心中所念。便告目连曰。舍汝神足可在此众现其形像。时目犍连即如其像。忽然以至处大众中。彼菩萨等身长八万四千由旬。佛身长十六万八千由旬。众会见目连形体着衣持钵状如沙门。皆共愕然怪未曾有此是何像。为是畜兽为是人耶。是时彼佛知众会心中所念。即告之曰。汝等勿生此心。所以然者。去此七十二亿江河沙数诸佛世界。有佛世界名曰忍土。彼有佛名曰释迦文如来至真等正觉十号具足。于五浊世出现于世。恒以文字教授众生。人寿百岁过者无几。以四谛至真分别议趣。其说慧无处无著。此目连比丘。是彼神足第一弟子。彼佛即告目连曰。现汝神足。此会大众虚想欲见时目犍连。承佛教诫。即从坐起头面礼足。忽然不现入无碍三昧定意。尽接十方诸佛刹土安着右掌。左手接彼佛土悬处虚空。各各共见目连神足。欲睹其形不能得见。时彼菩萨寻自归命彼佛世尊。伏惟天师当见拯济。佛告无苦终不有损。尔时彼佛告目连曰。止止目连。舍尔神足令此菩萨粗识轨迹。尔时目连承佛教旨。即舍神足复坐如故。时彼菩萨前白佛言。彼忍刹土释迦文佛。以何教化云何说法。复以何道训诲众生。以何权智周旋往来。佛告诸菩萨。彼刹众生刚强难化。互相是非各自谓尊。是以如来以苦切之教。引入道捡。犹如龙象及诸恶兽[怡-台+龍]悷不调。加之捶杖令知苦痛。然后调良任王所乘。彼土众生亦复如是。以若干言教而度脱之。或以苦音说苦音响。习尽道音亦复如是。时彼菩萨叹未曾有。善哉善哉世尊。彼佛如来执勤劳行甚为难有。能于五鼎沸世。教化众生演布大道。寂然灭尽归于无为也

十住断结经卷第八十住断结经卷第九

        姚秦凉州沙门竺佛念译

    道智品第二十四

尔时座上百亿众生。及诸大会菩萨之人。及天帝释梵天王。兜术天。焰天。化自在天。他化自在天。乃至一究竟天。各各狐疑。欲得闻说至道之要。道者无相而不可见。云何如来言有道乎。尔时世尊。知来会心中所念。寻告最胜菩萨曰。卿等欲得宣畅微妙至道之要乎。对曰。如是世尊。愿乐欲闻。佛告最胜及菩萨摩诃萨天龙鬼神阿须伦旃陀罗摩休勒人与非人。解道无迹寂然无名。假使最胜道有处者。菩萨摩诃萨不于平等法中成最正觉。以其道果无处所故。菩萨摩诃萨成等正觉。佛复告最胜。菩萨道智定意有十。云何为十。不造身行亦无所著。不造口行亦无所著。不造意行亦无所著。游佛境界不兴佛想。教化众生逮无碍智。皆使萌类解道无道。复使众生成最正觉。放大光明靡所不照。一一光明无量化佛。一一化佛演说极深六度无极。恒转法轮发菩萨心。解我无我亦无寿命。身心自然乃谓为道。其自然者。觉道无智亦不有智。觉无所觉都不见觉。言吾是道亦不见吾。言我是道亦不见我。我人寿命亦复如是。一切众智亦无形像。尔时最胜菩萨前白佛言。设道无形而不可见。如今转法轮演说四道果证。言须陀洹斯陀含阿那含阿罗汉辟支佛菩萨及佛。何以故。说五阴萨云然四意止四意断四神足五根五力七觉意八贤圣道。何以故。说净佛国土教化众生。从一佛国至一佛国。分别明慧六识更乐。云何复说四等六度真如法性有道之名。是时世尊告最胜曰。如汝所问。菩萨摩诃萨解了佛慧五分法身善权所有不见动转。见动转者则非道议。远离一切之所猗住。推其法界亦无法界。所以然者。俱本无故无道着智。如本净故设转法轮。解了一切诸法无著。是故最胜。菩萨摩诃萨等于一切悉无所著。亦不见生亦不见灭。佛土清净众生亦净。布现无量智慧光明。是故菩萨摩诃萨应总持行立。不退转登菩萨位。或入定意正受三昧。教化众生净佛国土。无若干道忍一行故。无言法智强为设智。菩萨大士当念修行。化诸未悟皆无识想。是谓最胜入一定意。清净道智一切无尘。调未调者不计苦乐。是常非常若好若丑。悉无想着无乱智者。求索佛藏十力具足。四无所畏四分别慧。大慈大悲真如法性。悉无所有皆虚皆寂。分别报应。至诚道智。无起灭故。谓空无相无愿。亦无所生。是故最胜。菩萨大士至道之要。所论道者即虚空界也。所以然者。道则是空空则是道。一而不二亦无若干。是时最胜菩萨前白佛言。善哉善哉。快说斯法。尔时众会之中天龙鬼神干沓和阿须伦迦留罗栴陀罗摩休勒人与非人。心自念言。如来今日为诸大会。演布道智无比之法。满众生愿随其所趣。此最胜菩萨。何时当成最正觉无上道乎。佛知诸天龙神心之所念。即告四部之众。此最胜菩萨。却后无数三百三十阿僧祇劫。当成为佛号曰明慧至真如来等正觉。世界曰无量。劫名清净。其佛如来翼从弟子。九千九百九十二亿。寿百二十小劫。尔时众会。闻佛授莂各自发愿。乐欲生彼佛世界。佛即告曰。如汝所愿必生不疑。佛复告最胜曰。今此大众多有忉利天帝与阿须伦共斗。或时诸天得胜阿须伦不如。或时阿须伦得胜诸天不如。各各共斗怀其怨结。各有恚毒不能舍离。伏惟天尊。以权方便与说道智虚无之法。令诸天人及阿须伦各各和合兴慈悲心

尔时世尊告诸会者。道者无形亦不可见。三毒根本永无本末。在世修道惟信为强。人之行慈善神卫护。十方诸佛皆共称叹。今世后世积德无量。此阎浮利内蜎飞蠕动有形之类。皆当归于灭尽之法。命如电焰亦如野马镜中之像水上浮泡。合会有离生者必死。汝等受形不免此患。虽受天寿故在三涂。当自谨慎求离此道。汝等谛听受吾教诫。尔时四部之众。佥然喜庆各自兴敬。欲听如来道法之教。尔时世尊告四部众。汝等谛听善思念之。菩萨摩诃萨当念修行八解脱法门。云何为八。若善男子善女人。奉律无缺护身口意。行四等心慈悲喜护。常念亲近随善知识然炽三宝。常念志求无上佛道。所闻正法为人讲说。所演道教不说小乘。劝进众生修行大道。或时菩萨讲演大乘。平等无二不见受教。犹如虚空无形无像。佛所建立不可思议。包容万行无法不周。或说空无虚空寂然之行。或说五分法身。譬如有人得随意摩尼珠。在大众中欲使珠之威德青黄白黑。亦使众人同其色像。菩萨摩诃萨亦复如是。随众人心意所思念。辄演道智无穷之法。各令欢喜志崇佛道。尽导将示智慧法门。益于众生而发大道。如是菩萨发弘誓心。济度众生亦不见度。犹如虚空往来无碍。菩萨发意度人如是。亦不见众生有得度者。佛告最胜。汝般泥洹供养舍利。当经十二中劫。一切众生皆悉奉事。无因缘者为造因缘。无救护者为设救护。无覆盖者为作覆盖。尔时人民之类。皆当供养华香伎乐稽首自归。一一舍利皆放光明。神德变化见者欢喜。皆由弘誓发愿所致。如佛威神殊特之变。巍巍堂堂靡不照曜。布现无量智慧光明。缘是兴发无上道意。其中众生发意错者。或成缘觉声闻之法。或生天上逮得人身。舍利分布八方上下。天龙鬼神干沓和阿须伦迦留罗旃陀罗摩休勒人与非人。蚑行喘息有形之类。皆当供养五乐自娱。佛复告最胜。汝作佛时地黄金色七宝具足金银珍宝车磲马瑙珊瑚虎珀水精琉璃。或有众生欲得供养全身舍利。辄如其愿皆悉从意。数千万亿全身舍利布现于世。经法流布十七中劫。尔时座上有菩萨名曰无量觉慧。心自念言。最胜大士遗身舍利。分布在世兴发道心。度人多少为有几许。佛知其意心中所念。便告之曰。止止贤土。勿宣斯言。莫以己身限碍之智度量如来无碍之慧三昧定意。光明舍利接度众生。非心所度非意所察。如来神德道智自在。又诸佛所化权现变异。非是辟支声闻所逮。菩萨摩诃萨得寂定三昧。都无近远想着定念。普游十方郡国县邑天宫龙宫。诸尊神宫丘聚人中旷野天上。五道所趣。各各示现全身舍利。一一舍利放光明者。解说六度无比之法。空无相愿大慈大悲。四恩明慧分别虚寂。畅达定意供养舍利。平等无二。施心牢固无增无减。是谓菩萨摩诃萨入寂意定心三昧。便能分别内外六情。何以故名为六情。所谓六情者。若眼见色不兴色想。解色外物而兴眼识。便起七十四尘劳之患。何谓七十四。欲识十五。色识十五。有想无想识十五。生阴十五。中阴十四。佛告菩萨摩诃萨。于眼识中兴此尘劳便起眼识。复次菩萨摩诃萨。设族姓子族姓女。若耳闻声不兴耳患。解声外物而兴耳识。便起七十四尘劳之患。欲耳识十五。色耳识十。有想无想耳识十。中阴及受形阴三十九。佛告菩萨摩诃萨。于耳识中兴此尘劳便起耳识。复次菩萨摩诃萨。若鼻嗅香不兴鼻识。解鼻外物而兴鼻识。便起七十四尘劳之患。欲界鼻识十五。色界十五。有想无想四空定四十四。佛复告菩萨摩诃萨。设族姓子族姓女。舌识知味而兴舌患。于中分别悉了无主。欲中识中。便能兴起七十四尘劳之患。何谓七十四。欲十五。色十五。有想无想及至中阴四十四。菩萨摩诃萨。复当思惟起灭之法。外更内乐粗细尘劳。一一分别悉无所有。便于更乐以兴身识。乃兴七十四尘劳之患。何谓七十四。所谓七十四者。欲十五。色十五。有想无想及至中阴四十四。菩萨摩诃萨。复当思惟意法之行。法生则生法灭则灭。亦不见生亦不见灭。愚惑之人。于中兴起意识之想。便起七十四尘劳之患。云何七十四尘劳之患。欲十五。色十五。有想无想及中阴四十四。佛复告菩萨摩诃萨。云何道智。菩萨于欲界道智十五。所谓十五者。观世有七。何谓为七。一者诽道。二者信言。三者受教。四者在谛。或便退转。五者得报犹豫。六者意进身碍。七者目睹不获。猗佛深藏有八事。何谓为八。一者佛法无像为设窠窟。二者现在不住念计常存。三者过去永灭誓言不睹。四者当来未至言无生灭。五者缘苦致患自招缘对。六者未尽言尽方便习行。七者见道舍道始从一进。八者佛法无二意在参差。是谓菩萨摩诃萨于欲界道智十五尘劳之行。云何色十五尘劳之行。所谓十五者。一为恩润。二心不移。三着天乐。四忘罪福。五谓永久。六无痛痒。七在正地。八行平均。九忍不起。十道无变。十一想具。十二着色。十三自在。十四远照。十五羯磨。是谓菩萨摩诃萨往适色天当念远离十五尘劳之行。云何菩萨摩诃萨。有想无想及中阴。远离四十四尘劳之行。于是菩萨入神通定意无形三昧。往至彼间说四十四识着之行。云何四十四。于是菩萨与识说行。一者识我无本。二者舍色无形。三者有痛受报。四者想不牢固。五者行本末断。六者猗空无慧。七者寂然息定。八者无想如灭。九者在识不乱。十者忘意非意。十一者亦不在意。十二者识不在道。十三者亦不在俗。十四者如尔性空。十五者闻响无形。十六者念道无尽。十七者谓空无余。十八者泥洹清净。十九者觉了趣寂。二十者痴心恩润。二十一者迁现中阴。二十二者见中阴受形二十三者与中阴形交往。二十四者知所从来。二十五者见彼中阴众生往来。二十六者见中阴形生者灭者。二十七者自见受形受地狱阴。二十八者有受罪形不受罪形。二十九者见受天阴有受福不受福者。三十者见受人阴有受福者不受福者。三十一者见受饿鬼中阴有高有卑者。三十二者见受畜生阴重者轻者。三十三者或从天阴还入天阴。斯由死时识不乱故。三十四者或从天阴而生人阴。斯由本识虽猛无慧。三十五者或从天阴受畜生阴。斯由识浅意兴乱想。三十六者或从天身受饿鬼阴。斯由死时意贪无厌。三十七者或从天身受地狱阴。斯由神誓诽谤贤圣。三十八者或从人阴复受天阴。斯由禁戒法清净。三十九者或从人身受畜生阴。斯由行本意不专一。四十者或从人阴受饿鬼阴。独善其美不广普故。四十一者或从人阴受地狱阴。先受其福后受其祸。四十二者或从畜生阴受天人阴。斯由造福毕故不造新。四十三者或从畜生阴受饿鬼地狱阴。斯由无救八无闲罪。四十四者有阴受阴形神识不错。是谓菩萨摩诃萨有想无想及中阴形四十四尘劳之患。佛复告最胜。菩萨摩诃萨复当思惟虚空神识中阴。或从空识生识阴。或从识阴受不用处阴。或从不用处阴受无色天阴。从无色天阴受六天阴。乃至一究竟天。从一究竟天。复受色无色天阴。人受天阴。形如一仞半。寻往不中留。人受人阴形如三肘半。极迟经七日。或六日五四三二一日。人受畜生阴。极迟三日半。或二一半日。人受饿鬼阴极迟半食顷。或弹指之间。人受地狱阴形如三仞半。或有出者。不经旬日死辄至彼。菩萨摩诃萨皆逐人教化为说妙道。心速悟者。不受众形中间得道。畜生受人阴。如二肘半。极迟经四日三二一日。畜生受天阴形如三仞半。极迟一日半或一日半日弹指之顷。畜生受饿鬼阴形如七仞。或有出者。极迟经五日或四三二一日。畜生受地狱阴。形如一仞半。极迟半食顷或弹指之间。饿鬼受天阴形如半刃极。迟经一日或半日食时或弹指之间。饿鬼受人阴形如二肘半。极迟四日半或三二一日。饿鬼受畜生阴。形如四仞半。极迟十五日四三二一日十日九八七六五四三二一日。饿鬼受地狱阴形如五仞半。极迟九十日。或有出者八七六五四三二一亦复如是。复次菩萨摩诃萨当复如是观察。地狱众生受彼天阴。形如四仞半极迟经五月四三二一月。若地狱阴受人中阴者形如二肘半。极迟经三月二一月。地狱受畜生阴。形如八肘半。极迟三月半二一月亦如是。地狱受饿鬼阴。形如九仞。极迟经三日。或时天阴应受人阴。中间未至还受天阴。斯等利根经不涉苦。或时天阴应受人阴。忽然便在生畜生阴。斯等之类福尽行至。或时天阴应受畜生阴。忽然便在生人中阴。斯等之类不毁戒度。或时天阴应受饿鬼阴。忽然便在生畜生阴。斯等之类奉修顶忍。或时天阴应受地狱阴。忽然便在饿鬼阴中。斯等之类报果以熟生人道中。或有人阴受饿鬼中阴。众生忽然便在天中阴。斯等之类定意不乱故。或有应受三恶道中阴忽然便受人天中阴。斯等之类有智通慧意广博故。或有应受一究竟中阴忽然便在光音中阴。斯等之类心专一故。或有应受遍净中阴。忽然乃在有想无想中阴。斯等之类有智意不达故。佛告最胜。菩萨摩诃萨坐道树下。以一切智无碍等智。执玄通智辩才慧智。了音响智无退转智。遍观三千大千世界。谁受形者不受形者。谁受中阴不受中阴。有几众生在于人道。有几众生在人中阴。菩萨复观人阴众生。受四阴形皆知多少。佛告最胜。菩萨摩诃萨观天道众生在天中阴。复观天道众生趣于四道皆知多少。或时菩萨摩诃萨以六神通不退转智。观畜生受形众生。有几众生受畜生中阴。转受四道中阴皆知多少。菩萨复观受饿鬼众生。有几众生在饿鬼中阴。应受四道皆知多少。或时菩萨摩诃萨观受地狱众生。有几众生受地狱中阴。趣于四道皆知多少。佛告最胜。菩萨摩诃萨以无退转智。遍观五道中阴有受形不受形者。或有处在人阴忽然便在天阴形。于天阴形即取灭度。竟不受天身人身。或有处在天中阴忽然便在人中阴形便取灭度。不受天身人身。或有处在畜生中阴于畜生中阴。忽然便在人中阴。于人中阴便取灭度。不受畜生人形。或有处在畜生中阴于畜生中阴。忽然便在天中阴。于天中阴便取灭度。不受畜生天身。或有处在饿鬼中阴。于饿鬼中阴忽然便在人中阴。于人道中阴便取灭度。不受饿鬼身人身。或有处在饿鬼中阴。于饿鬼中阴忽然便在天中阴。于天中阴便取灭度。不受饿鬼天身。或有处在地狱中阴。于地狱中阴忽然便在人中阴。于人中阴便取灭度。不受地狱人形。或有处在地狱中阴。忽然便在天中阴。于天中阴便取灭度。不受地狱天形。是谓菩萨摩诃萨以不退转智。遍观三千大千世界。有受形者不受形者。有罪有福皆悉知之。尔时最胜菩萨及万八千人。十万天人。天龙鬼神犍沓和阿须伦迦留罗甄陀罗摩休勒。即从坐起叉手长跪白佛言。异响同音叹未曾有。善哉善哉。世尊。快说中阴无形之法。无限无量不可思议。非是罗汉辟支所度。我等愿乐欲见中阴形质。唯愿世尊。顾愍下劣众生。得蒙洗除永去心垢

尔时世尊告诸会者。善哉善哉。快问斯义。吾今与汝现其神足。使八部之众得睹中阴形质。尔时世尊即入无形观三昧。普见五道中阴众生。有受形者不受形者有罪有福。皆悉知之。尔时座上众生。亦复见彼五道中阴形质。又闻如来与说道教。即于彼形诸尘垢尽得法眼净。或有发于大乘之心。或有说于志密之行。随类教化无所染着。亦复见彼中阴形质。从一住地至于十住地。见彼有得一生补处。坐树王下降伏无数亿百千魔。身黄金色众相具足。亦有诸天帝释梵四王。来请菩萨演说法响。普闻三千大千世界。复见异方诸佛世尊。遣化菩萨。请说名号国界远近清净之行。或见在前叹说如来十号之法。或有兴教致供养者。或以杂偈叹如来之德。此国众生在彼中阴。种种观见神足变化不可思议。复见如来出舌相光明。一一光明皆有化佛。及八部众前后围绕。说无畏法智不退转。诸法深藏皆悉具足。或授弟子缘觉记莂。于当来世汝当成佛。号字如是。尔时万八千人及百千天子。即于座上皆发无上正真道意。

尔时世尊。还舍神足复坐如故。告四部众。如来神德不可究尽。又有四法不可思议。云何为四。一者如来志密不可思议。二者众生根本不可思议。三者如来道慧不可思议。四者如来音响不可思议。复次最胜。复有四事不可思议。云何为四。一者如来仪则不可思议。二者如来法座不可思议。三者如来教诫不可思议。四者金刚定意不可思议。复有四事。不可思议。云何为四。在道树下意如虚空不可思议。亦不见是亦不见非不可思议。以小为大以大为小不可思议。言必有济亦不见济不可思议。复有四事。所应行法不可染着。言有吾我。亦不见生复无有灭。无造无作亦无著断。一切众生根本清净。是谓最胜。菩萨摩诃萨所应行法无所染着。云何最胜。世尊有边际乎。对曰。无也。世尊复告最胜。诸有正法从法界生本无边际。为有有耶生。为无无耶无。对曰。世尊。不从有有不从无无。云何最胜。诸无际法。不从有有不从无无。云何成等正觉乎。对曰世尊。无有成正觉者

佛告最胜。如来坐道树下以无际之法。无起灭教皆虚皆寂。自然无智亦不有智。以无有智谁有知乎。是故最胜。吾我之法权诈不实。亦不见道道不见道。无见无闻无慧无著解法界亦复如是。不见起灭为作窠窟。有受教者。亦不见文字章句。如是最胜。解知诸法虚空无形。设有愚夫无智之士安处虚空者不乎。对曰。非也世尊。一切诸法如尔法性。真际本无斯无所有。今言有道大慈大悲。四意止四意断四神足五根五力七觉意八贤圣行。空无相愿。六增上法。十八不共。不由斯法而得成道。道者无形亦不可见。以无形法乃谓为道。道亦无来亦不见去。是谓最胜。乃谓为道。若使如来从法界生从法界灭。乃是生死秽浊之行。以无生灭故谓为道

佛告最胜。菩萨摩诃萨入虚空观三昧。于诸境界行无染禅。以此禅法。游至无碍亦无错乱。非身非心无等不等。思惟空定不见刚柔。志惟澹泊无应无所。应亦不见应亦不见不应。是谓最胜。菩萨空定无限无量不可思议非是罗汉辟支所及。譬如最胜。焚烧山野丛林草木。火非丛林丛林非火。亦不是火亦不离火。当知菩萨结使亦然。结非是道道非是结。亦不离道解知空定。无形三昧亦复如是。诸法清净平等本无。或以正受观察法际。而致平等无染无污。心不在内亦不游外。色无所住亦不见住。度于一切在颠倒者。设法无形是谓为道。或以五通三达妙智。周流四域欲化众生。化自有化亦不见化。是谓为道超外五通。或离声闻缘觉定意。不见五通缘觉定意。是谓为道。复以定意正受三昧观察法本。法从何生为从何灭。亦不见生亦不有灭。乃谓为道。有为俗法无为道法。亦不见俗复不见道乃谓为道。有漏是尘无漏清净。亦不见漏亦不有漏。十善行迹十恶法本。亦不见善复不有恶。利衰毁誉称讥苦乐。亦不见苦复不见乐。不见成道亦不在俗。不见说法贤圣默然。是谓最胜。菩萨摩诃萨入空正受。乃谓为道

复次最胜。菩萨摩诃萨复当思惟虚空藏三昧。不见有余无为住寿经劫。不见无余无为无有变易。乃谓为道。是谓菩萨摩诃萨建立空慧善权方便。从一佛国至一佛国。供养诸佛承事诸佛世尊。教化众生净佛国土。不见色相为现色像。声香味细滑识亦复如是。不见有度至于泥洹。不见流转处在生死。若善男子善女人。讽诵执持怀抱不忘。便得现在八功德福。云何为八。观诸空法信不犹豫。得佛深藏意不怯弱。意净无垢无所染污。心如金刚不可沮坏。所行真正不着魔界。净佛国土度未度者。心广大乘不乐小智。亲善知识不着外部。所求真观无我人想。是谓菩萨摩诃萨获八功德。解知世法无我无人无寿无命。于本无法乃应正受。常以禅定至于灭度。开化众生不以为倦。是为见法乃应为道。以见诸法寂寞无形无行无处。是谓最胜菩萨摩诃萨。空非有空亦非有空。空非空者寂寞无名。名亦不有不无。是谓为道。或时菩萨游诸法观不猗三处不着三有。如是菩萨在人天世。发弘誓心广度群萌。不见众生有得度者。是谓菩萨摩诃萨。建立空慧永无所著。最胜当知。如来周旋入无形定意。非是二道所能晓了。唯佛明。佛智慧无碍无著无染无所点污。于诸境界无所染着。设得深法不以为欢。不着世俗八无闲业。四辩无碍。不灭不燃非不有燃。不起不生非不有生。过去永灭非有过去。现在不住亦不有住。当来未起不见生者。是谓菩萨摩诃萨。无著无碍不着三处不染三有

尔时座上九万众生。十一那术天人。及诸天龙鬼神即从座起。偏露右臂长跪叉手白佛言。我等鄙贱得厕净法。乃能宣畅。无形之法无幖帜法。唯愿世尊。使将来世生人天中阴。佛土境界即于彼处受无为证。同日同时共一国土

尔时世尊。哂然而笑口出五色光。遍照三千大千世界。绕身三匝还从口入。阿难长跪叉手白佛言。自惟侍佛三十有余。未曾见光有踰此者。唯愿世尊。当为敷演为将来会者永无尘翳

尔时世尊告阿难曰。汝今见此九万众生。十一那术天人。于此命终皆当往生微尘空界中阴。已生中阴各各以次成佛皆同一号。号无色如来至真等。正觉明行成为善逝世间解无上士道法御天人师号佛世尊。纯以菩萨以为翼从。于彼中阴住寿一劫。般泥洹后遗法一劫。以次成佛中间不绝

尔时世尊说此法时。遍净菩萨及无数众生悔受人形及彼天身。在坐号泣不能自胜。佛知而问曰。善男子。何为悲泣未曾所见。遍净白言。我等亦欲乐生彼土。不在厕豫故悲泣耳。佛告遍净。止止勿说斯言。汝昔发愿弘誓心异。何为中欲生于异国。贤劫名灭。汝当次继号为遍净如来至真等正觉十号具足

    身口意品第二十五

尔时最胜菩萨前白佛言。一切诸法皆如幻化。云何幻化法中。教化众生净佛国土。云何净除三想我人寿命。云何从一佛国至一佛国。承事供养诸佛世尊

佛告最胜。善哉善哉。乃能于如来前作师子吼。谛听谛听善思念之。吾当与汝敷演其义。最胜当知。菩萨摩诃萨常念修身口意行法。观了诸法如幻如化。去来现在悉无猗着

尔时座上有菩萨名曰欢乐。前白佛言世尊。诸有众生乐深法本兼复供养。净身口意诸根纯熟。是谓菩萨慧。增上菩萨曰。解知诸法无离无染。于无染法净身口意。是谓菩萨慧。等慈菩萨曰。诸有行慈普愍一切。解知文字尽无所著。不见身口之所行法。于中便得清净法者。是谓菩萨慧。濡首童真曰。一切诸法本说不见说。不见法想。于中净身口意。是谓菩萨慧。炎光菩萨曰。佛法无二亦不见二。息诸结使尽无起灭。于中净身口意。是谓菩萨慧。莲华结菩萨曰。遍能游至十方世界。见净世界不起净想。于中净身口意。是谓菩萨慧。光明菩萨曰。一切诸法归无所归。于身口意亦无起灭。于中净身口意。是谓菩萨慧。法净菩萨曰。一切诸法悉归于空。于正受定摄意不乱。于中净身口意。是谓菩萨慧。莲华行菩萨曰。于本无法无尽之行。于无尽法净身口意。是谓菩萨慧。正等菩萨曰。知苦知乐亦无苦乐。于中净身口意。是谓菩萨慧。除怒藏菩萨曰。一切诸法解无起怒。于无起怒法净身口意。是谓菩萨慧。师子童真菩萨曰。于三法本无恚淫痴。亦不见色有起有灭。于中净身口意。是谓菩萨慧。施宝菩萨曰。我人寿命有起有灭。解了诸法悉无起灭。于中净身口意。是谓菩萨慧。勇慧菩萨曰。总持法门不见归趣。于无归趣法。是谓菩萨慧。贤护菩萨曰。名号虚诈不可护持。愚戆凡夫谓为真实。于中净身口意。是谓菩萨慧。月光菩萨曰。如如如尔性本际净修梵行。不见如如如尔性于中净身口意。是谓菩萨慧。善来菩萨曰。以戒德香。普熏三千大千世界。香如风等。亦不见香。亦不见风。于中净身口意。是谓菩萨慧。不思议菩萨曰。无为不离有为。有为不离无为。解知有为无为悉无所有。于中净身口意。是谓菩萨慧。洁净菩萨曰。诸生净居天。不见天福清净之行。于中净身口意。是谓菩萨慧。至诚菩萨曰。不见至诚当犯四法。不见欺诈当受后报。于中净身口意。是谓菩萨慧。善观菩萨曰。一切色想觉无色想。于中净身口意。是谓菩萨慧。宝璎菩萨曰。处在生死观见众生有苦有乐复自观身苦乐如彼。于中净身口意。是谓菩萨慧。无毁根菩萨曰。于诸结使知本清净。于中净身口意。是谓菩萨慧。常笑菩萨曰。于诸根法不见吾我。亦复不见造吾我者。于中净身口意。是谓菩萨慧。常悲菩萨曰。行四等心。慈悲喜护遍满佛国。不见四等有救众生。于中净身口意。是谓菩萨慧。梵意菩萨曰。邪见众生安处正见。于正见中不见邪正。于中净身口意。是谓菩萨慧。布演菩萨曰。弘誓心固不为小道所屈。于中净身口意。是谓菩萨慧。勇士菩萨曰。拔淫众生不染三有。于中净身口意。是谓菩萨慧。心胜菩萨曰。建立慧忍恒修精进。于中净身口意。是谓菩萨慧。雷音菩萨曰。于诸善本。观其法界不增不减。不见诸法有窼窟者。于中净身口意。是谓菩萨慧。无厌患菩萨曰。以恒沙劫以为一日。十五日为半月。三十日为一月。十二月为一岁。于中经历亿百千劫。乃一佛出照曜世间。复以方便供养恒沙如来。净修梵行后方受决。修菩萨道未曾厌患生死之苦。于中净身口意。是谓菩萨慧。住寿菩萨曰。恒以神足化六十二见。于六十二见净身口意。是谓菩萨慧。尽意菩萨曰。观诸法本空无所有。生者自生灭者自灭。法法相生法法相灭。生不知生灭不知灭。于中净身口意。是谓菩萨慧。心广菩萨曰。心所思念出息入息。一一分别不失次第。亦不见出亦不见入。于中净身口意。是谓菩萨慧。善胜菩萨曰。分别三世。为从何起为从何灭。亦不见起亦不见灭。于中净身口意。是谓菩萨慧。持禁菩萨曰。不见持戒及以毁戒。不见毁戒当入地狱。不见持戒受天福报。于中净身口意。是谓菩萨慧。无畏菩萨曰。修四神足。于四意止不怀怯弱。心本无本不见心本。于中净身口意。是谓菩萨慧。无量悲菩萨曰。诸有发心慈愍一切。游至他方无量佛界。要度众生不以为倦。亦不见度亦不见不度者。于中净身口意。是谓菩萨慧。宝施菩萨曰。兴隆四恩亲近三宝。惠施仁爱利人等利。不见受报四恩之德。于中净身口意。是谓菩萨慧。毁根菩萨曰。一切众生视如赤子。欲自护身当护他人。安隐众生至无为岸。不见灭度至彼岸者。于中净身口意。是谓菩萨慧。寂志菩萨曰。佛不思议受报难量。诸根寂定信无贪嫉。于中净身口意。是谓菩萨慧。护身菩萨曰。成其佛道身护相好。及泥曰后舍利分布。四维八方上下充满。天龙鬼神无不宗奉。亦不见舍利有教化者。于中净身口意。是谓菩萨慧。香首菩萨曰。一一毛孔出无量香。一一香者出无量教。济度众生无有穷极。神足威神巍巍无量。皆使众生发无量道意。其中错误众生不应正真道者。或成缘觉声闻之道。或生天上还复人身。心不怀恨。大道可贵。亦不侠耻度于小者。于中净身口意。是谓菩萨慧。弘誓菩萨曰。于染无所染。于世八法不兴想着。于中净身口意。是谓菩萨慧。愍救菩萨曰。道者为二无道为一。亦不见一亦不见二。于中净身口意。是谓菩萨慧。无上菩萨曰。有佛有法不成觉道。无佛无法乃成觉道。亦不见成亦不见不成。于中净身口意。是谓菩萨慧。奉德菩萨曰。诸有众生自立名号。是男是女我人寿命。解知本性悉无男女。亦复不见从彼生此从此生彼。当知权诈合数之法非真非实。于中净身口意。是谓菩萨慧。目见菩萨曰。诸有色像解无色像。彼色我识内外无形。解色性空悉无起灭。于中净身口意。是谓菩萨慧。妙锦菩萨曰。吾我寿命本自无主。如人外声耳识耳闻。挍计声者本无形质。于中净身口意。是谓菩萨慧。常住菩萨曰。若于七法一一分别。不关三处不求五果。于中净身口意。是谓菩萨慧。玄通菩萨曰。寂不寂为垢。戒不戒为垢。忍不忍为垢。亦不见忍亦不见不忍。解知忍辱无寂不寂。于中净身口意。是谓菩萨慧。香熏菩萨曰。不见阴盖睡调之病。悭贪谀谄愦乱犯戒。于中净身口意。是谓菩萨慧。尔时最胜菩萨即从座起。长跪叉手前白佛言。善哉善哉世尊。我亦愿乐说净身口意菩萨之慧。普现一切无去来今。如尔清净住无所住。诸法幻化不可捉持。譬如日光月现水中。诸佛世尊亦复如是。亦无生灭不取泥洹。于中净身口意。是谓菩萨慧

佛告最胜。云何族姓子。汝观何义于如来前而说此义住无所住乎。答曰如来所住如如所住如众生住。云何如来所住如如所住如众生住乎。答曰。如众生住如有为住如无所住。云何如众生住如有为住如无所住乎。答曰如来所住住无所住。云何从第一空义住乎。答曰非也世尊。云何族姓子。如来所住如凡夫住乎。对曰非也世尊。曰非如来住非凡夫住。云何从中成正觉耶。答曰不从如来及凡夫法成正觉也。云何族姓子。如如至真于凡夫地有何差别。对曰世尊。欲使虚空有差别乎

佛告最胜。一切诸法皆空皆寂无有差别。最胜白佛。以其诸法不可护持。相无有相。如如所住如无所住

尔时最胜菩萨问濡首童真言。住云何为住乎。言无住云何无住耶。濡首答曰。所谓住者。如如所住住无所住。又曰。解四梵堂住无所住。故谓为住住无所住。最胜问曰。吾所问住。非四梵堂亦非一类。或在闲静或在聚落。或在冢间或在树下。可谓此为住乎。濡首答曰。吾所谓四梵堂住心为止止。捡恶不起故谓为住。最胜问曰。云何心为止止。濡首答曰。慧义为本故曰止止。最胜复问。慧者无本亦无究竟。可从知见成止止乎。濡首答曰。如是如是。如汝所言。先自观我然后净慧。最胜复问。云何濡首先自观我耶。濡首报曰。诸无我法至竟如如。我自无我无起无不起。是谓我自观我也。最胜复问。正使濡首为从义得不从义得。自观我者为观佛像。若使有我则有佛耶。我自无我云何有佛。亦不见言言亦无我。云何观佛像乎。濡首答曰。诸言观我我即无我是谓观我。所以者何。夫观我者则观诸法。观诸法者则观佛也。佛者无形亦不可见。最胜问曰。颇有方便诸不成就可使至正见耶。濡首答曰。有此方便。诸不成就有为境者安处正见。又问云何濡首。正尔便是正见耶。濡首答曰。不以尽证。亦不果报。亦不取果报。故谓正见。又问云何为见。答曰不以慧眼见诸法。非不慧眼见诸法。不有为见不无为见诸法。何以故。夫慧眼者。亦见有为境。亦见无为境。无有有为眼见有为境无为境。又问云何濡首。颇有方便从其等见成比丘果证耶。濡首答曰。亦不从等见成其果证。亦不离等见成其果证。最胜当知。皆由希望五垢所成。解此义者乃成果证。最胜复问。云何希望五垢所成。濡首答曰垢为心本心是道根。道者无形不可见。故成果证。最胜又问。道者无形不可见。云何成果证。濡首答曰。吾所证道由其果证。成果证者即非道耶。凡夫愚人谓果证为道乎。莫作斯观。何以故。道非果证果证非道。亦不离道亦不离果证。最胜又问。道以果证无差别耶。濡首答曰。道者无为而不可见。果证有为亦不可见。是谓差别。又问濡首。如仁所言。从有际至无际耶。濡首答曰。诸法未生亦不见生。非不有生生亦无生。亦不见已生非不有已生。夫已生者亦无已生。诸法无当生非不有当生。解知当生悉无所有。是谓从有际至无际。最胜又问。不从有生至无际乎。濡首答曰。从有生得至无际。又问从无生得至无际乎。答曰如是从无生得至无际。云何濡首。从有生得至无际。从无生得至无际。有何差别。濡首答曰。生亦无生。无生亦无生。是谓差别。最胜又问。生既有形无生无名。云何差别。尔时濡首报最胜曰。吾与汝引喻。有目之士以喻自解。云何最胜。虚空有形乎。对曰无也。又问空有正见耶。对曰无也。又问何谓为空。对曰空空也。濡首复问。云何空空。最胜报曰。诸法空空又问云何诸法空空。最胜答曰。诸法无言无说空如空。濡首问曰。诸法无言无说云何空如空。

尔时最胜寂默不对

是时世尊告最胜曰。善哉善哉族姓子。真解无无泥洹之道。道者无形亦不可见。无言无教亦无受者。说此无形法时。一切众生叹未曾有。九千比丘有漏心解脱。二万七千天子诸尘垢尽得法眼净。复有千二百天与世人发于无上正真道意。五千菩萨即于座上得不起法忍。尔时座上有无畏魔王。自将其众前白佛言。我等愚惑永在盲冥。今日始闻无形教法。若有善男子善女人。执持讽诵此经典者。常当拥护至竟成佛不使留难。于是咒曰

那罗伽罗阿毗呵呵

持是拥护善男子善女人。讽诵经典戢在心怀者。尔时梵王复从座起。即将营从前白佛言。我当拥护善男子善女人执持讽诵此经典者。若百由延千由延内。不使外邪得善男子善女人。便即于佛前而说咒曰

伊摩鼻周那毗伽奢黎罗

当拥护是善男子善女人。至竟成佛不使留难是时释提桓因。复将翼从前白佛言。若有善男子善女人执持讽诵此经典者。我等当拥护至竟成佛不使留难。于是咒曰

留遮耶摩那那僧求时那写

持是拥护善男子善女人。至竟成佛不使留难。是时东方天王提鞮赖吒将其翼从。即从座起前白佛言。我等当拥护是善男子善女人讽诵读说此经典者。常当拥护至竟成佛。于是咒曰

谛那赐那谛那赐

持是拥护善男子善女人。至竟成佛不使留难。是时南方天王毗楼勒伽。即将翼从前白佛言。若有善男子善女人执持讽诵此经典者。至竟成佛不使留难。于是咒曰

摩诃赐陀那赐

持是拥护善男子善女人。至竟成佛不使留难。西方天王毗楼波叉。将其翼从前白佛言。若有善男子善女人执持讽诵此经典者。我当拥护至竟成佛不使留难。于是咒曰

伊昵弥昵奢弥

持是拥护是善男子善女人。至竟成佛不使留难。是时北方天王拘毗罗。将其翼从前白佛言。若有善男子善女人执持讽诵此经典者。我当拥护至竟成佛不使留难。于是咒曰陀譬陀罗譬

持是拥护是善男子善女人。至竟成佛不使留难。是时无畏魔王。梵天王。释提桓因。及四天王。各说神咒已。绕佛三匝头面礼足。各还复坐

十住断结经卷第九十住断结经卷第十

        姚秦凉州沙门竺佛念译

    梦中成道品第二十六

尔时治地菩萨即从座起右膝着地。叉手白佛言。世尊。甚奇甚特。今闻濡首菩萨得与最胜论无形法道无言教。未曾所闻未曾所见。便为绍继佛种不断。又行佛事不思议法。佛告治地。如是如是如汝所言。从亿百千劫积功累德。兴显佛事未曾耗减。有佛出世法乃流布。是时濡首前白佛言。诸佛出世法乃流布。诸法有相貌耶。言流布乎。对曰无也。又白佛言。如来出现。使无量众生皆取灭度。今闻如来欲齐限众生。齐限众生者则无灭度。佛告濡首。颇闻吾说无众生言有众生耶。对曰不也。欲使有众生无众生耶。对曰不也。欲使如来起灭有窠窟耶。对曰不也。若使如来无窠窟者。云何如来度众生皆使灭度。濡首白佛。今我所说分别四句。解知诸法皆得总持。寻其本性无生无灭。不见生死又无泥洹。以是之故。无限众生当取灭度

佛告濡首。于尽无尽法界本净。晓了义理故称无著。以知文字无意无想亦无识着。岂由识想分别诸慧乎。晓众生净人之本性不可究尽。吾今与汝分别义趣。谛听谛听善思念之。菩萨大乘不可思议。非是罗汉辟支所及。濡首受教愿乐欲闻

佛告濡首。无形之识无觉知识。无想念识梦幻化识。以用救摄无量众生。或有佛土文字教化。解知文字性空寂寞。上方去此七万六亿阿僧祇刹土。彼有佛土名曰安寂。佛名妙识如来至真等正觉明行成为善逝。十号具足。彼土众生诸根具足。玩习本愿无所漏失。众生受化睡乃得寤。唯有如来入寂定意。随众生根权现如睡。设欲说法便自右胁着地脚脚相累。众生见之皆效如来。右胁着地脚脚相累悉各睡眠。是时彼佛于睡眠中。与诸众生神识说法。或说布施蠲除三想。或说持戒德香远布。或说忍辱降意不起。或说精进除去懈怠。演说禅定识不流驰。宣畅智慧闭塞愚闇。修行善权随类无著。于四法门究畅无碍。随识高下而演其教。随说大小以授正法。时彼如来。复以演说四非常慧苦空非身无我之法以。渐渐与说三十七道品之教。四意止四意断四神足五根五力七觉意八贤圣道。究畅定意空无相愿。尔时梦中受化之识应成道迹。便于梦中。识受成道。频来不还至无著道。亦复如是。各佛取证。亦复于梦识在旷野。无师自寤于睡眠中身黄金色众相自严。飞钵虚空作十八变。又于梦中身上出火身下出水。坐卧虚空无所挂碍。欲入无为泥洹之境。亦于梦中结加趺坐。于无余泥洹而般泥洹。故身如石无所觉知。众生之类还觉寤已。各无言说寻梦识着。便取舍利而耶维之。菩萨受决乃至成佛。皆于梦中坐树王下。地黄金色。降伏魔怨。无量福具。身有三十二相八十种好。紫磨金色光明远照。梦中如是。寤即身黄金色众相具足。神足变化无所触碍。无有言教音响往来。欲有所度悉于梦中。不假外形而有所济。濡首当知。众生根原受寤不同。诸佛权化其慧无方。或有佛土地大成者。地界众生不可称计。如来入彼而教化之。皆使众生于无余泥洹界而般泥洹。或有佛土水大成者。水界众生不可称计。如来入彼而教化之。皆使众生于无余泥洹界而般泥洹。或有佛土火大成者。火界众生不可称计。如来入彼而教化之。皆使众生于无余泥洹而般泥洹。或有佛土风大成者。风界众生不可称计。如来入彼而教化之。皆使众生于无余泥洹而般泥洹。或有佛土空大成者。空界众生不可称计。如来入彼而教化之。皆使众生于无余泥洹而般泥洹。或有佛土识大成者。所谓安寂佛土妙识如来。识神通达梦中受教而取灭度佛复告濡首。北方去此七十亿恒沙佛土。彼有佛土名曰深要。佛名梵慧如来至真等正觉。十号具足。彼国众生皆发誓愿乃生彼土。尽同一号名曰接识。濡首当知。彼土众生悉皆神通。心念形随无所挂碍。所谓接识者。发弘誓心。诸有神识应趣生门受胞胎形。要以神足游空往来。接识留住。化而灭度不受四大。今此座上颰陀和等八菩萨是。东南去此百四十恒沙国土。有佛土名曰梵音。佛名胎真如来至真等正觉。十号具足。彼土众生六通清彻同一色相。斯由誓愿乃生彼土。所谓胎真者发弘誓心。诸有识神以处母胎。愿以神足入胎教化。令彼母人不知我之所在。即于胎中拔济无为得至泥洹。今此座上宝迹童真治地菩萨是。如来权化神变无方。以亿百千佛土安处掌中。复还如故无觉知者。虚空法界不可思议。是谓濡首菩萨摩诃萨所应行迹。非是罗汉辟支所能及也。分别微识化诸众生各使得度。或说虚无空无之法。无我无人无寿无命。不起灭法。云何濡首。若有善男子善女人发弘誓心。令十方世界辟支罗汉充满其中。各使成道心不退转。其福宁多不乎。濡首答曰。甚多甚多。天中天。佛言。其有菩萨以无形法与识演说。或说无常苦空非身空无相无愿。一一分别无形无相。不可携持。是则化识其福无量。所以者何。有为四大遮迦越罗之所迳历。无为四大永寂不起。是为诸佛之所演法。以是方便微识寂寞。法性无教而不可量。有为有相无为无相。所以者何。不离有为不离无为。亦复不言习是舍是无形之教无有此教。是凡夫法是贤圣法。斯为学法斯无学法。是声闻法是缘觉法。是菩萨法。是佛法。佛复告濡首。如来所讲与识说法。不见诸法亦无法想。虚空无形亦不可见。愚惑凡夫以诸彩色画于虚空。欲作天龙鬼神八部之形。是人所施宁能不乎。濡首答曰。甚难甚难。天中天。未曾有也。佛言。如是如是如仁所言。诸法无数。如来所化亦复无数。诸法无形则无有二。于濡首意云何。无形之法有处所乎。对曰不也世尊。佛告濡首。以故当知佛法无数。无言无教悉无所有。尔时濡首前白佛言。向闻世尊诸法无相亦无形质。如来大哀物无不察。云何复说开化众生净佛国土。是法有漏是法无漏。是法现在是法过去未来。又佛说言是度世法是非度世。有着无著有称无称有数无数。此生死法此为泥洹。云何世尊。说诸法无相亦无形质乎。佛告濡首。如是如是如汝所问。三乘诸法三世六度。度世生死有为无为。无有为无无为。有着无著有称无称。有数无数有漏无漏。三十七品空无相愿。从有为法乃至无为。皆是俗数非是第一之义。无形法者。无形无响而不可见。布施持戒忍辱精进一心智慧善权。皆是俗事非第一义。灭尽泥洹永寂快乐

佛告濡首。菩萨应寻其本性而复演说有报应耶。说除八难音声无响有报应耶。究尽众生推寻根原有报应耶。顺从经典蠲除结使有报应耶。正使如来不染三世。正法开化未曾唐捐有报应耶。正使诸法有报应果复可尽乎。心识周旋入出无碍。复可尽乎。或履权慧顺从爱欲复可尽耶。威仪礼节顺而不犯复可尽耶。三乘教化皆令充满复可尽耶。思惟法本不舍总持复可尽耶。解了诸法章句清净。深了妙法章句分明。观四意止诸佛定意复可尽耶。分别意断未曾舍离。演法无穷不以为难复可尽耶。神足无碍山河石壁通达无碍复可尽耶。一一分别五根圣典。非是外耶所能沮坏复可尽耶。如来神力审言正法。不起狐疑是非之想。七觉意华以自璎珞。处在大众不怀怯弱。论说三十七贤圣之道。永离外耶。复可尽耶。讲说逆顺正受三昧。或复分别名身句义。复可尽耶。苦习尽道至道印封三十二相。相相受报。复可尽耶。濡首白佛言。世尊。无形法教而不可尽。诸有为法皆是耗减。无为泥洹而不可尽。尔时最胜复白佛言。泥洹泥洹者。云何为泥洹

佛告最胜。所谓泥洹。息也。复问云何为息。答曰无为闲静。又问云何无为。云何闲静。答曰想灭者闲静。识停者无为。又问非空乎。答曰非空空。又问非空空。云何识停耶。答曰非空空。尔时最胜菩萨。倍生狐疑即白佛言世尊。向问二事然同答乎。佛告最胜。止止。族姓子。勿谓如来答性空同。但族姓子意未解耳。吾今问汝非空空义及识澄静。随汝辩才一一詶吾。云何族姓子非空义乎。对曰诸法无数非不有数。佛言。非也族姓子。佛复问。云何识停澄静。最胜白佛言。悉归不起非不有起。佛言。非也族姓子。尔时最胜即从坐起五体投地。接足而礼须臾退却。复白佛言。自审有过于如来所说。愿世尊愍恕不及。愿垂敷演永除愚惑

佛告最胜。法无若干唯解为本。香山有树一枝万寻。倒屈入地果实乃熟。果应在上反更入地。汝今所见亦复如是。吾问汝空乃以有报。与彼果树有何异哉。吾当与汝一一分别。善思念之。对曰如是世尊

佛告最胜。非者非空。一切诸法皆号为非。非者诸法之名。有名者则非空也。解非归空故曰非空也。所谓识者非有非无。云何识非有非无。不染于世是谓非有。在空澄静是谓非无。识者舍此适彼是谓非有。踞生死岸顾愍众生是谓非无。能以化身满十方界化化空寂是谓非有。一识感化化皆说法是谓非无。如来入定身心寂静。迳亿千那术恒沙劫数无起灭想是谓非有。复从定起接度众生令至无为。是谓非无。云何最胜。吾今与汝一一分别非有非无。为是真空泥洹义乎。最胜白佛。空实空泥洹实泥洹。佛告最胜。止止。族姓子。此非空亦非泥洹。所以者何。皆由世俗假号权诈文字相传。故谓非有非无。法性境界。尽无端绪无名字法。岂当有非有非无耶。蠲除高下无是非心。知欲怒无欲怒心。解知无明无无明心。五盖诸缚了之为一。亦不见一是谓为空。是谓为泥洹。尔时最胜前白佛言。善哉善哉世尊。说空性法及泥洹界。非有非无实无等伦。尔时说此法时。六万比丘。本愿声闻回意大乘皆得不退转。十一那术诸天世人。皆得尽信之行。复有异方八十千菩萨悉获不起法忍

佛复告族姓子。菩萨摩诃萨解空性法有十事行得至灭度。云何为十。一者诸佛世尊恒住法界不舍道智。二者诸佛世尊慈愍一切不舍大悲。三者所行如愿中无差违。四者度诸众生诸根纯淑。五者诸佛世尊观了诸法空无所有。六者诸佛世尊分别智慧。三毒等分亦无所有。七者诸佛世尊于诸法界不起增减。八者发心起学平等无二。九者解如法性不舍本际。十者诸佛世尊行诸道法一相无相。是谓族姓子菩萨摩诃萨解空法性修此十法得至泥洹。复次菩萨摩诃萨行六神通至空法界有十事行。云何为十。一者尽观过去不失慧明。二者尽观未来不失慧明。三者尽观现在不失慧明。四者观五趣众生尽知根原不失慧明。五者一切世间生者灭者不失慧明。六者观一切众生。从有而生从有而灭不失慧明。七者观一切众生从无而生从无而灭不失慧明。八者道心坚固不舍众生不失慧明。九者无选择心。是可度是不可度不失慧明。十者解知法界根门不缺不失慧明。是谓族姓子菩萨摩诃萨修六神通至空法界。佛复告族姓子。菩萨摩诃萨。至空法界当修十慧。云何为十。一者观诸众生若干种心若干种行悉知。是谓菩萨慧。二者观一切众生。若干种心若干种报悉知。三者寂寞无言。如务魄太子。尽知众生心意所念。四者知诸众生异心异行。以佛圣慧而教授之。五者从久远已来修于法性不舍衍心。六者安处众生住佛所住。七者以佛圣慧尽知五趣心意识念。八者言有所说不舍大乘。九者得佛心识定意不乱。十者度心无量不处解脱。亦复不见众生度者。是谓族姓子菩萨摩诃萨至空法界修若干十慧

    菩萨证品第二十七

佛复告族姓子。菩萨摩诃萨乘六神通游至十方无数佛土。承事供养诸佛世尊。从一佛国至一佛国。教化众生不怀怯弱。叹佛功勋德行之业。普使十方闻佛音响。最胜所行无不济度。或以神足或以教诫。福田清净无三恶趣。永舍邪部悲念未度。已过诸量住于佛量。为人福祐安处无为。于百千劫净修梵行。不如五浊一行慈心。夫慈心者福难称量。世多有人行三恶业。身三口四意三法本。应向三恶当受其报。设能专意讽诵此典。于现法中尽其苦原。或有菩萨疲厌生死。遭遇此典终不退还。更不受生在母胞胎。神识了朗未尝错谬。夫欲解缚净诸结使。当护佛法兴显慧明。若于他方百千万劫奉行正法演畅其义。不如此土弹指之顷讽念一偈分别义趣此最为胜。吾见妙乐安明佛土。亦见永寂无量佛国。彼无忧苦烦恼之难。亦复不得行福业事。若能于此尽诸结缚。此则为奇胜生彼国。所以者何。于五浊世众恼万端。亿千万劫时乃有佛。众生行恶希睹贤圣。或生边地八不闲处。或在佛后不闻正法。正使有佛不闻不见。能于其中兴显佛法。是为奇特无与等伦。吾今虽为三界至尊。犹愿行福不以为厌。慈悲喜护拔其苦原。难革众生染邪来久。卒闻正教倍怀狐疑。会值今日如来要集。菩萨大士不可称数。闻法无厌如海吞流。应与演说正真佛道。释梵四王天龙鬼神阿须伦旃陀罗摩休勒人与非人魔若魔天十方云集。今得闻法霍然大悟。皆由前世福业所致。正使吾于百千万劫。演畅一句深妙之义。不能究尽此慧法本。是故最胜。菩萨大士。苦行无数不以为难。若使三千大千刹土。同时劫烧火至梵天。凡夫众生未履道迹。闻此正典在他佛国。投身自归入彼火灾。安隐得度无所伤损。有时三千大千世界。火灭水盛乃至梵天。复自投身入彼水灾。安隐得度终不没溺最胜当知。有时三千大千世界。水涸风盛乃至梵天。复自投身入彼风灾。安隐得度不被飘浪。所以者何。诸佛威神之所拥护。若比丘比丘尼优婆塞优婆夷。执持讽诵此经典者。现世获祐不逢苦恼。若能进业净修梵行。即于现世受无为证。今此座上神通大士。亿百千垓那术众生。普修此典乃受果证。吾今殷勤敷演经典。闻者得度不至恶趣。随前志操应适解慧。向佛乘者意广无崖。恒愍众生不自为己。乃至成佛终不耗减。趣缘觉者毕其所愿因缘成道。飞钵虚空变化自由。愿声闻者。求师咨受无所挂碍。断诸结缚尽漏成道。复观众生心意所趣。或有发意应成道迹。菩萨权慧诱进异道。渐渐将导即成罗汉。或有众生应频来道。复以权慧以次指导便得罗汉。或有众生应成不还。复以权慧开化进趣使成罗汉。或有众生不越次第以成三道。菩萨权慧欲令学者。小节不真。即便诱进成须陀洹。或有众生已成二道。复以权慧接引前人成斯陀含。或有众生越次取证受应真者。菩萨权慧观察前人。已得须陀洹斯陀含阿那含阿罗汉。复以诱进成缘觉道。尔时如来。告四部众诸来会者。众生若干佛土不同。谓为缘觉如来无刹土乎。莫造斯观。所以者何。转轮圣王十善已具。展转绍继王名不灭。缘觉自寤亦复如是。佛去世后佛法灭尽。或经一劫至百千劫。缘觉应真为行佛事佛佛相继。于诸佛事终不耗减。是故菩萨摩诃萨。恒以权慧开导众生。福应相次将导众生。离三世患安处永寂。尔时最胜菩萨。即从座起前白佛言。甚奇甚特。非是二乘之所及也。愿乐欲闻成道证验乎

佛告最胜。若乐闻者今当与汝说之。谛听谛听善思念之。吾昔求道不可称计。从初发意施作功德至今成佛。于其中间遗形流布有可计哉。吾昔证验发弘誓心。其有众生趣向道根。或复投身归命三尊。要以神通现证告人。不但我身宿有此愿。诸佛世尊誓愿皆同。若有众生四向四果。吾亦睹见明其所实。正使前人成缘觉者。吾亦证验因缘自寤。若有众生坐树王下。开方五十俞旬里内。于其中间。魔若魔天不睹其际。此者我之所证。佛复告族姓子。菩萨摩诃萨如我今日现身受验旷济众生。不见吾我心识了朗。分别所趣施行佛事。寻忆百千无数佛土。周旋往反究尽道者。恒在前立证明界实。吾昔游于无畏佛刹。时彼大士不可称计。或有志趣小乘罗汉。或有中止在缘觉地。或有超越志存佛道。时吾专心入定三昧。普为众生敢以为证。复次菩萨摩诃萨若有已向须陀洹得须陀洹。向斯陀含得斯陀含。向阿那含得阿那含。向阿罗汉得阿罗汉。吾常于中证成果报。未曾失于法性之本。佛复告族姓子。菩萨摩诃萨游至三千大千世界。有信无信有受无受。或有众生住尽信之地。复有众生住奉法地者。或有众生修于八解童真行者。我恒往现证使彼得道。佛复告族姓子。菩萨摩诃萨身识清净无能染污。诸有众生怀邪业者。吾亦往证此为邪术不得久立。或复祭祀地水火风。吾亦往说知不真实。复见群邪唱生梵天。复往劝进福尽还本。或有欲生无色天上住寿一劫。心常专一中无断绝。吾时入定正识定意。复与彼说色不有色色不自有。我色彼色彼我无形。色则无色岂有我也。识非我识岂有我也。痛想行法亦复如是。尔时最胜菩萨前白佛言。善哉善哉世尊。如来所说现证法教不可思议。非是罗汉辟支所及。是时最胜重白佛言。向承佛言。云何无色。云何为无色乎。唯愿世尊。垂愍敷演永使黎庶不怀狐疑

佛告最胜。善哉族姓子。谛听善思念之。吾当与汝说无色定。所谓无色者非有色也。四大造色乃谓为色。彼无此色乃谓无色。夫色有五乃成四大。唯无形色故谓无色。痛色想色行色识色。非是凡夫五通所睹。唯有如来阿维颜菩萨乃见彼色。佛复告族姓子。不退转菩萨执权方便入寂静定意三昧正受。往游有想无想天上。与彼微识说微妙法空无相愿。六身受法无起灭行。渐渐与说生法老法病法死法。所谓生者。在母胞胎生藏下熟藏上。四大已具便当别离。宿有善行。如游浴池后园观看。宿积恶者。如登崄谷荆棘上卧。复与演说识神所趣。我人寿命不可久保。于中拔济识神得寤。唯于阿兰迦兰。如此之比不可称数。亿千那术诸佛在前。各现殊特甚深之法。本识愚惑如器穿漏。不受正法道品之教。一劫若减一劫干烧。如是经历亿百千那术之数劫数干烧。或有一劫一佛出世。或有一劫二佛出世。或于一劫百佛千佛亿百千佛。如是之比。然后乃受正教。复与演说老耗之法。所谓老者。诸根纯熟皮缓面皱。悲愁呻吟厌患四大。无复少壮荣华之心。此法衰耗不可久保。次复与说四大参差地水火风。地胜水性水胜火性火胜风性。互有增减便成其疾。或生疮痍万病所逼。脓血流溢不可瞻睹。以次与说无常变易。如水上泡一生一灭。生者自生灭者自灭。生不自生灭不自灭。无想神识即于彼处。随其所趣各获果证。于无余泥洹界而般泥洹。最胜菩萨白佛言。世尊。向闻如来四大参差神识所居。地增水减则生其疾。水增火减则生其疾。火增风减则生其疾。又复闻佛说。风增火减火增水减水增地减。识非四大四大非识。今闻佛说。一大增三大病。三大增一大病。四大具足神识得宁。衰由四大非识所生。云何世尊。病由四大为识所生。佛告最胜。识非四大四大非识。识不离四大四大不离识。是故一大增诸大病。识大增一大病。识随衰耗。又问为四大病为识神病耶。答曰识由大病。大由识病。又问识由四大乃自役用。舍身受形四大各归。其本识神何不减乎。佛告族姓子。善哉善哉。于如来前乃发斯问。吾当与汝一一分别。识者无形而不可见。识非有识因大为识。四大尽增则识有病。病非四大由识而生。万病增减皆由识生。从初发意乃至成佛。神识无垢不由四大

    解慧品第二十八

尔时最胜菩萨白佛言。世尊。云何菩萨摩诃萨执意坚固不可沮坏。云何菩萨执意真诚终不虚妄。云何菩萨一向佛道不趣二乘。云何菩萨执持威仪不失礼节。云何菩萨守意禅定不舍正受。云何菩萨住诸佛法而不退转。云何菩萨留化教授不断佛种

尔时世尊告最胜曰。善哉善哉。于如来前而问此义。吾今与汝敷演分别善思念之。唯然世尊愿乐欲闻。佛告最胜。菩萨摩诃萨修行四法意志坚固不可沮坏。云何为四法。一者慈愍众生如母爱子。二者勤加精进而不懈怠。三者度诸众生如幻如化。四者诸佛箧藏无不究练。是谓菩萨摩诃萨行此四法进成佛道未曾退转。菩萨复当修行四法。便得入定贤圣默然。云何为四。一者解知众生无众生想。二者观诸世间不可乐想。三者叹誉大乘永离二道。四者于诸苦乐无所荣冀。复有四法。云何为四。一者戒二者闻三者施四者出要。复有四法。至成佛道。无有狐疑不失威仪。云何为四。一者无利。二者无衰。三者无毁。四者无誉。复有四法增益善根。云何为四。一者教训众生住于信地。二者惠施于人不望其报。三者说法无法想。四者菩萨名号不可称记。复有四法。菩萨所行从一地乃至十地。云何为四。一者兴显善根。二者除去愚闇不处邪部。三者善权适化导以无方。四者执心勇猛精进日增。复有四法。善权方便得至佛道。云何为四。一者劝进邪部安处正道。二者化诸未寤令向善趣。三者说法无二受有高下。四者以佛圣慧度未度者。复有四法威仪成就。云何为四。一者不染三有知之为苦。二者我与彼人苦乐俱然。三者恒行忍辱不兴恶心。四者在上无慢居下不耻。复有四法不舍道心。云何为四。一者念佛功德之本。二者安处众生道心坚固。三者亲善知识不染邪见。四者上及大乘不修妄见。复有四法。乐在闲静不处愦闹。云何为四。一者向小乘者令至大乘。二者应成缘觉进成佛道。三者闻法不厌道心不断。四者如所闻法不有吝惜。复有四法菩萨所行。云何为四。一者不起法忍悉知无生。二者无尽法忍亦无过量。三者因缘法忍除缘觉心。四者无住法忍悉知众生心无猗着。复有四法除去结使。云何为四。一者专精一意思惟恶露。二者去者永灭更不造新。三者诸法明白不处闇冥。四者心常游戏百千三昧。复有四法游行四部众。云何为四。一者恒自为法不计吾我。二者兴致重敬心无放诞。三者于诸善本转增其德。四者去离小乘导以大道。复有四法。法施财施得至无为。云何为四。一者受法不误。二者不从他心。三者不惜身命。四者意无退转。复有四法施无想报。云何为四。一者彼我无形了之悉空。二者行应正真修无上道。三者解见无我由痴爱生。四者道性无际行合真际。复有四法度人无量。云何为四。一者解淫怒痴无有起灭。二者行慈广济不见恚怒。三者燃炽诸法。四者虽在五浊不舍道心。复有四法得成道根。云何为四。一者恒以惠施以为元首。二者劝进他人除去悭贪。三者行辄合空法无吾我。四者于甚深法不起狐疑。复有四法禅定不戏。云何为四。一者不计众生有数无数。二者不见佛土有净无净。三者慈悲喜护遍满世界。四者佛慧具足不舍本誓。复有四法游佛道场。云何为四。一者先言后笑不伤人意。二者如所说法行应正真。三者解道无道亦无窠窟。四者有望无望悉知归空。是谓菩萨摩诃萨行应合空于诸佛法修无上道。说此四四法时。二万二千天及世人皆发无上正真道意。复有万二千人。即于座上逮不起法忍。复有无数十方天子。散华供养乃至于膝

    三毒品第二十九

尔时濡首童真白佛言。世尊。今闻如来说四法门慧。甚深微妙立根得力。菩萨所行非是罗汉辟支所及。今问如来未来中间。初禅思惟恶露不净之观。为观自身不净。观他身不净耶。佛告濡首童真。或有菩萨未上菩萨位。便自观身恶露不净立根得力。或自观身观他人身。复以权慧现身臭秽脓血流溢。于中开寤无数众生。去离净心皆知不真。复次濡首。或有菩萨在未来地。上修中间未明初禅。复有菩萨已离未来住在中间。复以权慧上修初禅。或有菩萨已过未来中间净地。次复修习初禅。念持五行之本。遂复上及二禅之法。或有菩萨舍上四禅未来中间。初禅第二以次仰修。三禅根本喜安自守。复有菩萨已离三禅。复舍四行修第四禅。复于四禅思惟恶露不净之观。复有菩萨。不由七定径逮灭尽定意。或有菩萨已入永寂三昧普观世界。无有众生我人寿命。生者灭者悉无所有。或有菩萨在一地住受菩萨位。分别三毒淫怒痴法。权慧适化观众生心。有无明心无无明心。有爱欲心无爱欲心。有嗔恚心无嗔恚心。菩萨悉知。最胜当知。菩萨摩诃萨遍观诸法。不见生者不见灭者。复于诸法不见毕竟不见不毕竟。如是诸问为清净。复次最胜。菩萨摩诃萨观诸缚着于中求净。应问当问。此法永寂安隐无变易法。生死清净不见秽浊。是谓菩萨摩诃萨无生之论。越度生死不见有度。是谓无生之论。泥洹无形寂然无为。是谓乃应无生之论。若使最胜于诸缚着悉知归空。不见生死有取证者。不见出生起灭之处。亦不见出亦不见泥洹。是谓菩萨无生之论。复次最胜。因缘聚散恶露不净。是谓菩萨无生之论。亲近成证不退转果。断智无碍知尽不生。是谓菩萨无生之论。复次最胜。菩萨摩诃萨因缘合散证不退还。断知无碍永离三有。是谓菩萨无生之论。乃名诸法善根不断。知善不善。此是世法是度世法。此是碍法此不碍法。此有为法此无为法。此有漏法此无漏法。是谓菩萨摩诃萨无生之论。复次最胜。思惟分别佛像无形。亦复分别法性若干。思惟圣众功德难量。以次思惟众生非一。复当分别刹土不同。心所趣向难可究尽。是谓菩萨摩诃萨无生之论。复次最胜。一切诸法皆悉清净。一切诸法皆不清净。是谓菩萨无生之论。最胜白佛言。云何一切诸法是无生之论。一切诸法皆不清净是无生之论。佛告最胜。诸法无识亦无行报。诸有识想与法相应。是谓净无净也。一切诸法若干种相。或有诸法未离念持。便求方便增益其德已益其德诸善普备。诸善已备则数出入息。数息已定是谓净不净。最胜又问。云何观察诸法定不定耶。答曰。自于境界永离无欲。于亿万法悉知定不定义。又问。定者非净非不有净。不定非净。可谓定不定乎。报曰。少有明者能解定不定义。云何世尊。永离无欲于亿万法知定不定定者是道。不定非道。佛言。如是如是。如汝所言。若有族姓子族姓女。于诸法界不知已定当定未定。则于诸法未解已解当解。何以故。如香乐经所说。诸法已定闻不狐疑。则能进上而不退转。如所闻法玩习不舍。是谓定不定义。若有众生于定不定生狐疑者。则不能从一地复至一地。以不超次干地则不离生死住泥洹法。何以故。诸佛世尊不究生死根本不至泥洹

佛告最胜。诸佛世尊恒不演说越度生死安处泥洹耶。答曰如是。又问。颇闻世尊演说诸法斯是生死斯是泥洹。答曰。非也佛言。是故族姓子。诸佛世尊不说生死以为下劣。不说泥洹以为增上。但为族姓子。言生死泥洹者便有二识。则不能离生死至泥洹之岸佛复告最胜。菩萨摩诃萨从空往来。不见众生有众生想。不见泥洹有泥洹想。何以故。不见周旋处在生死。不见泥洹有得灭度。尔时最胜菩萨即从座起。偏露右臂长跪叉手。白佛言。世尊。善哉善哉。如来所说。说无众生泥洹之相。法说义说正应寂然。不见生死及与泥洹。尔时座上二千七百比丘。有漏心解脱得不起法忍。何以故。解了生死则无生死。解了泥洹则无泥洹。亦复不言有度众生。亦不说泥洹永寂。解空性法。非有生死非有泥洹。

尔时坐上七百比丘。密从座起收摄衣钵。无何而去。各各低头自相谓言。我等何为涉此慊苦。日夜精勤修于梵行。或言有泥洹。泥洹无取灭度者。亦无有道。况当有成道者

    问泥洹品第三十

尔时最胜菩萨白佛言。世尊。若有众生欲使诸法出生。则无有道成等正觉。何况于泥洹欲成道乎。此则不然。泥洹无姓亦无名号。云何欲于空中求空。泥洹无一。况当欲求诸法之数。世尊。此七百比丘于如来所剃除须发服三法衣。手执应器净修梵行。方便退转在凡夫地。欲求泥洹窠窟处所。犹如麻油醍醐酪酥。油则遍周酥则凝住。生死泥洹亦复如是。至竟泥洹无诸法相。泥洹大道亦无崖底。群惑之人执迷来久。却谓泥洹有生灭着断。唯有修行之人执行正见。不见诸法有起有灭。不见诸法有受有舍。尔时。最胜菩萨前白佛言。世尊。此七百比丘即闻法教各舍驰散。当复经历几时乃得度脱。永离生死不在邪见。佛告最胜。汝欲知者谛听谛听善思念之。吾当与汝蠲除狐疑。对曰。如是世尊。佛言。恒沙劫过乃一佛出。如是经历七十二亿恒沙劫数。犹不得度。何以故。亿千万劫佛乃出世。值佛甚难经难得闻。今日如来至真等正觉。在大众中敷演道教。说无生灭泥洹之法。于正法中生邪见心。所生之处。恒在邪见不在正道。犹如士夫勇猛多力。无方伎术无不贯练。六艺备具。天文地理星宿灾怪皆悉开通。然此力士。恒畏虚空窃自设计。驰趣四方投无空界。在在处处恒见虚空。此诸比丘亦复如是。正使经历百千万劫。欲于空中立泥洹名。此事不然。所至到处不了空性。愿求于道终不可果。如复有人欲求于空。在在处处空恒在前。亦不演说此空彼空有若干相。不见从空往来有所成办。斯乃解知泥洹之要。彼诸比丘前世习邪至今不寤欲求泥洹无为大道。犹尚不识名号姓字。岂能分别泥洹道乎。终日周旋求于灭度。唐劳其功而不可获。何以故。泥洹假号如幻如化。空无所有假名为空。假号虚诈。愚人所传非贤圣法律之所赞叹。尔时复有立行比丘七百余人。即于座上诸尘垢尽得法眼净。三达六通无所挂碍。了佛无生亦不起灭。不以过去诸法求于泥洹。无数恒沙诸佛过去所说教诫智慧辩才悉无若干。从凡夫起乃至无学。演说道教无有差违。不见众生流浪生死。不见泥洹当有起灭。何以故。一切诸法悉空如空。不见诸佛所出窠窟。尔时座上六百优婆塞三百优婆夷。皆得尽信之行。无数天与世人皆发无上正真道意。尔时长老舍利弗告五百比丘曰。汝等诸人各获通慧必本愿耶。诸比丘言。尊者舍利弗。曩昔所愿今日已获。所作已办更不受有。舍利弗言。善所问者知所趣乎。诸比丘言。尽诸结缚更不染有。不爱生死不着泥洹。泥洹无为行合空性。无结缚尽亦不见尽。是谓泥洹。尔时舍利弗赞彼比丘曰。善哉善哉。族姓子。真解空性甚深之义。今有几贤住于福地。诸比丘曰。尊者舍利弗。即是福田如来所称。施行佛事未曾唐捐。我等诸人。于十六分未获其一。舍利弗言。汝五百人。悉是彼此解脱之士。亦是福田。诸比丘曰。如来圣慧性自清净。于诸法界无所染着。是时最胜菩萨前白佛言。世有几贤必报施恩。佛告最胜。不着世法能报施恩。又问。复有几贤于施清净。答曰。不受诸法乃谓清净。又问。何者是施福田。答曰。忘佛道法乃谓福田。又问。复有几贤于众生种。为善知识指授善恶。答曰不舍一切众生之类。是谓善知识。又问。世有几贤能报佛恩。答曰。获四无畏不断佛种。又问。世有几贤能供养如来。答曰。亿万劫行于中不惑。是谓供养。又问。世有几贤能护佛藏。答曰。尽其形寿不毁佛戒。又问。复有几贤能兴恭敬。答曰。守护诸根能闭六情。又问。何者世间名大珍宝。答曰。成就七宝者。又问。云何解知足行。答曰。修于第一无上慧义。又曰。云何于世少欲。答曰。不愿求于世。又问。云何解世无著。答曰。断诸结缚无复五盖。又问。世谁快乐无复众苦。答曰。无所系属故谓为乐。又问。云何无所系属。答曰。解知五阴十八本持空寂无为。又问。谁有此难。答曰。外舍六尘内舍六情。又问。谁度此岸。得至彼岸。答曰。立根得力成道者也。又问。云何菩萨施心不断。答曰。消除三想不兴尘劳。又问。云何持戒而不缺漏。答曰。道心坚固不舍弘誓。云何行忍遭对不惧。答曰。解心空寂不起恚本。云何菩萨修于精进。答曰。心之所念无有端绪。又问。云何禅定意不戏损。答曰。心定永寂不受外尘。云何慧业演畅诸法。答曰。分别义趣不舍道心。又问。云何菩萨修行慈心不舍道根。答曰。不舍众生见有度者。又问。云何菩萨行于悲心。答曰。思惟诸法而不退转。又问。云何菩萨喜意不断得至灭度。答曰。不兴我想计有吾我。又问。云何菩萨护心不断。答曰。守护道根毕至成佛。于其中间不兴余想。又问。云何菩萨立于信根。答曰。超越外法不与邪俱。又问。云何解空而无犹豫。答曰。解道非道道无根源。是谓菩萨摩诃萨所应行业

    四梵堂品第三十一

尔时濡首童真。内心自念。云何菩萨摩诃萨。于身口意净修梵行。周遍四荒往度众生。从一佛国至一佛国。未曾舍离众生。云何菩萨进成佛业。不失菩萨所行之定。佛知其意。即告之曰。如是如是。如汝所言。菩萨行本其类不同。吾今与汝敷演其义。谛听谛听。善思念之。对曰。如是世尊

佛告濡首。身行清净不为众恶。口行至诚不失法性。心念定意恐畏不动。是谓菩萨通慧之本。慈念众生不着爱欲。恒修不净恶露之观。守固其心不处愚闇。是谓菩萨通慧之本。在众如野不失威仪。进止行来仪容齐整。未曾违失如来禁戒。是谓菩萨通慧之本。于诸佛法悉皆解脱。无欲无为不可思议。圣众修习永无三乘。是谓菩萨通慧之本。于欲解脱晓了无形。嗔恚解脱痴懈亦然。修九次第不动禅觉。是谓菩萨通慧之本。不着欲界求转轮位。不处色界希望成福。复不思惟无色界道。是谓菩萨通慧之本。复于空无无愿无相。无不尽有漏之行。解了诸法如幻如化。是谓菩萨通慧之本。或有众生终不失意。从住至住爱憎意等。是谓菩萨通慧之本。不违过去诸法之本。未来现在亦复如是。于染无染不见染着。是谓菩萨通慧之本

    梵天请品第三十二

尔时最胜菩萨摩诃萨白佛言。世尊。身行清净不行恶业。演说言教终不虚妄。心念清净超越道根。尊今所论四等梵堂。慈悲喜护济度众生。一人不度终不忘舍。以慈去淫。以不净去净。观相无形。是谓菩萨通慧之本。于诸法本悉得解脱。于三法宝悉得解脱。有为无为有漏无漏。是谓菩萨通慧之本。已知无欲知之不生。嗔恚无本皆知为空。是谓菩萨通慧之本。行慈不断。不着欲界色无色界。于诸四禅尽不起想。是谓菩萨通慧之本。菩萨摩诃萨。恒入空无想愿。亦不求索诸法之相。或有菩萨发弘誓心。设我成佛国界众生无三乘道名。然我今日至诚。作佛成等正觉。广化众生不以为厌。尔时八千天人立于信地。魔王营从即还本所

    梵天嘱累品第三十三

佛告无畏梵天及诸大众诸菩萨等。吾从无数阿僧祇劫积功累德自致成佛。不染于世八法之累。一切众生蜎飞蠕动有形之类。染着五阴玩而不舍。是以贤圣不染八法。解知五阴十八本持空无所有。离世八事。利衰毁誉称讥苦乐

佛复告梵天。若有善男子善女人。讽诵受持此经典者。魔若魔天不能沮坏。何以故。诸佛世尊威神所护。若有善男子善女人。求于无上正真等正觉。皆由此典而取果证。佛复告梵天。吾今从劫至百千劫。满中众生。皆共称叹此经典者不能究尽。何以故。此经名曰无尽之藏。非是罗汉辟支所及。一名最胜菩萨所问。吾今嘱累此经。无令缺漏一字。味身句身。皆令具足。如我今日成于佛道。相有三十二。好有八十种。身黄金色圆光七尺。遍满三千大千世界。有一善男子善女人。至诚求佛道供养如来至真等正觉。不如弹指之顷诵此经典。何以故。如来至真等正觉。皆由此经而成佛道。须陀洹斯陀含阿那含阿罗汉辟支佛。皆由此典而得成就。尔时无畏梵天前白佛言。世尊。若有善男子善女人。至诚求佛。讽诵此经典戢念不忘。我等当拥护此善男子善女人。百由旬内。魔若魔天不得其便。佛告梵天。如是如是。如汝所言。过去当来现在诸佛皆诵此典。必至坚固终不退转。若有善男子善女人。修习四意止四意断四神足五根五力七觉意八贤圣道空无想无愿。皆由此典成就世间。便有四性比丘比丘尼优婆塞优婆夷。尔时濡首童真。最胜菩萨。尊者舍利弗。天龙鬼神干沓和阿须伦迦留罗栴陀罗摩休勒。闻佛所说。作礼而去

十住断结经卷第十


阿閦佛国经卷上

    No. 313 [No. 310(6)]

阿閦佛国经卷上

        后汉月支国三藏支娄迦谶译

    发意受慧品第一

闻如是。一时佛在罗阅只耆阇崛山中。与大比丘众比丘千二百五十人俱。皆阿罗汉也。生死已断无复有结。悉坏牢狱。已得自在意。已善解智慧。为度诸天龙王。皆为之伏。所作已办。诸当为者已脱重担。便得所有用正慧解。意得自在所度无极。独阿难未也。尔时贤者舍利弗。起长跪叉手。而白佛言。善哉天中天。昔者诸菩萨求无上正真道者。行德号发意。便得至号。是诸菩萨。以仪哀念安隐诸天及世间人。为作安谛。多所安隐。于众人民。以仪故哀念安定。以大身于世间无盖。哀伤诸天及人。今现在及过去诸菩萨摩诃萨。为现光明。乃至法之明为作照明。令至佛光明。而无有名。若有求菩萨道者。当如昔者诸菩萨摩诃萨所愿。及行明照并僧那。令入德号以闻者。当如是学奉行之。学如是者。即为成阿惟越致及无上正真道也。佛言善哉。贤者舍利弗。所问甚善。汝乃问过去诸菩萨摩诃萨所愿及行照明并僧那。令至所号。念诸当来菩萨令受取之。谛听是舍利弗。善思念之。为汝解说过去诸菩萨摩诃萨所施行。舍利弗言。唯然世尊。愿乐欲闻

佛告舍利弗。有世界名阿比罗提。其佛名大目。于彼为诸菩萨摩诃萨。说法及六度无极之行。尔时贤者舍利弗心念言。我欲问如来天中天。何所是阿比罗提世界。及大目如来无所著等正觉。为诸菩萨摩诃萨说法及六度无极之行者乎。时佛即知贤者舍利弗心所念。告舍利弗言。东方去是千佛刹有世界名阿比罗提。其佛名大目如来无所著等正觉。为诸菩萨说法及六度无极之行者乎。时有比丘。从坐起正衣服。右膝着地。向大目如来。叉手白大目如来言。唯天中天。我欲如菩萨结愿学所当学者。如是舍利弗。其大目如来。告其比丘言。如结愿学诸菩萨道者甚亦难。所以者何。菩萨于一切人民及蜎飞蠕动之类。不得有嗔恚。如是舍利弗。其比丘白大目如来言。天中天。我从今以往。发无上正真道意。以意劝助而不离之。用愿无上正真道也。当令无谀谄所语至诚所言无异。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。若于一切人民蜎飞蠕动之类。起是嗔恚。第一意若发弟子缘一觉意。第二唯意念淫欲。第三若发意念睡眠念众想由誉。第四发意念狐疑。第五乃至成最正觉。我为欺是诸佛世尊。诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。若我发意念杀生者。第一若发意念盗取他人财物。第二若发意念非梵行者。第三若发意念妄言。第四若发意念悔恨。第五乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。若我发意念骂詈。第一若发意念恶口。第二愚痴。第三若发意念绮语。第四若发意念邪见。第五乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者

佛语舍利弗。其比丘如是。为以被是大僧那僧涅。菩萨摩诃萨初发是意。乃于一切人民蜎飞蠕动之类。意无嗔怒。亦无恚恨也。舍利弗。尔时其菩萨摩诃萨。用无嗔恚故。名之为阿閦。用无嗔恚故住阿閦地。其大目如来无所著等正觉。亦欢乐作是名。四天王亦欢乐为是名。天帝释及梵三钵。亦欢乐作是名。佛语舍利弗。其阿閦菩萨摩诃萨。白大目如来无所著等正觉言。唯天中天。我发是萨芸若意。审如是不离愿。为无上正真道者。不奉行如今所语。常不舍得律行迹。不发萨芸若意。而欲念成佛者。世世不常作沙门。世世不常着补纳之衣。世世作沙门以三法衣不具。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发萨芸若意。审如是愿。为无上正真道者。世世不常为人说法。世世不常作法师。世世所说事。不有无所挂碍高明之行。世世不有无量高明之智。世世作沙门不常行分卫。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。世世作沙门已不常在树下坐。世世不常精进行三事。何等三。一者经行。二者坐。三者住。世世若发意念罪本。妄语欺人诽谤谗言。世世为女人说法。及食饮因缘。若起想着笑为说法者。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。世世若举手说法。世世见余菩萨不发佛心。世世若发意念。供养外异道人舍诸如来。世世若在坐上听法。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。世世若发意念。我当布施与某。不布施与某。世世若发意念。我当于某处立福施。于某处不立福施。世世若发意念。我常持法施与某。不持法施与某。世世见孤穷。用其人故不分身命。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数不可思议无量世界中。诸佛天中天今现在说法者。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。我世世于诸菩萨所意无有异。至无上正真最正觉也

佛语舍利弗。尔时其比丘如是。如来无所著等正觉为作保任。若如来为作保任者。诸天阿须伦世间人民亦为作保任。尔时大目如来为作保任。时诸天阿须伦世间人民。亦为作保任。佛言。若复有比丘菩萨摩诃萨。以是色像僧那。求无上正真道者。皆当成无上正真道最正觉也。佛语舍利弗。其阿閦菩萨。白大目如来无所著等正觉。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。令我成最正觉时。其刹所有比丘比丘尼优婆塞优婆夷。若有罪恶者及谗罪恶者。我为欺是诸佛世尊诸不可计无央数不可思议无量世界中。诸佛天中天今现在说法者。复次天中天。我当修行乃至成无上正真道最正觉。令我佛刹诸弟子一切皆无有罪恶者。我当修佛道至令佛刹严净。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。我若于梦中失精。乃至成最正觉。我为欺是诸佛世尊诸不可计无央数。不可思议无量世界中。诸佛天中天今现在说法者。复次天中天。我当修行乃至成无上正真道最正觉。令我佛刹中。诸菩萨出家为道者于梦中不失精。唯天中天。我发是萨芸若意。审如是愿。为无上正真道者。世间母人有诸恶露。我成最正觉时。我佛刹中母人有诸恶露者。我为欺是诸佛世尊诸不可计无央数不可思议无量世界中。诸佛天中天今现在说法者。是为菩萨法事如意所念行。佛亦为如应说法。佛语舍利弗。尔时有一比丘。谓阿閦菩萨摩诃萨。乃作是结愿。若使不退转者。当以右指案地令大震动。尔时阿閦菩萨。应时承佛威神。自蒙高明力乃令地六反震动。阿閦菩萨摩诃萨所感动。如语无有异也。佛语舍利弗。若有菩萨欲成无上正真道最正觉者。当学阿閦菩萨摩诃萨行。菩萨摩诃萨以学阿閦菩萨行者。不久亦当即取佛刹土。当复成无上正真道最正觉也

尔时贤者舍利弗问佛言。天中天。阿閦菩萨摩诃萨初发意时。有几何天在会中。佛告舍利弗。阿閦菩萨初发意学时。三千大千世界中四天王天帝释及憋魔梵三钵。一切皆向阿閦菩萨。叉手说是语。昔所不闻是僧那。诸天闻以便说言阿閦菩萨成无上正真道。若有人生其佛刹者。是人福德不小也。贤者舍利弗白佛言。未曾闻余菩萨摩诃萨以是色像学僧那。我亦不见亦不闻。如阿閦菩萨摩诃萨。及天中天。为作如是之名。佛言如是也。舍利弗。少有菩萨摩诃萨以是色像。学僧那及无上正真道。如阿閦菩萨摩诃萨。于是舍利弗。陂陀劫中诸菩萨摩诃萨。其德不及阿閦菩萨摩诃萨之功德也。佛语舍利弗。尔时其大目如来无所著等正觉。授阿閦菩萨无上正真道决。汝为当来佛。号阿閦如来无所著等正觉。成慧之行。而为师父。安定世间。无上大人。为法之御。天上天下尊佛天中天。亦如提洹竭佛授我决。时佛语舍利弗。大目如来授阿閦菩萨摩诃萨无上正真道决时。其三千大千世界皆为大明。譬我亦如是。授无上正真道决时。其三千大千世界皆为大明。复次舍利弗。其阿閦菩萨摩诃萨成无上正真道最正觉。得萨芸若慧时。其三千大千世界六反震动。譬我亦如是。成无上正真道得萨芸慧时。三千大千世界。为六反震动。复次舍利弗。阿閦菩萨摩诃萨授无上正真道决时。是三千大千世界中诸药树木。一切皆自曲低。向阿閦菩萨作礼。譬我亦如是。成无上正真道最正觉得萨芸若慧时。是三千大千世界诸药树木。一切皆自曲低向我作礼。复次舍利弗。其大目如来无所著等正觉。授阿閦菩萨摩诃萨无上正真道决时。其三千大千世界中。诸天龙鬼神揵沓和阿须伦迦留罗真陀罗摩休勒。一切皆向阿閦菩萨。叉手而作礼。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。三千大千世界。诸天龙鬼神揵陀罗阿须轮迦留罗真陀罗摩睺勒。皆向我叉手作礼

复次舍利弗。其大目如来无所著等正觉。授阿閦菩萨摩诃萨无上正真道决时。遍三千大千世界。诸妊身女人皆安隐产。盲者得视。聋者得听。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。是三千大千世界。诸妊身女人皆安隐产。盲者得视。聋者得听。复次舍利弗。大目如来无所著等正觉。授阿閦菩萨摩诃萨无上正真道决时。遍三千大千世界中人非人皆烧香。譬我亦如是。成无上正真道最正觉得萨芸若慧时。遍三千大千世界中人非人皆烧香。贤者舍利弗白佛言。阿閦菩萨摩诃萨乃有是无极之德。佛告舍利弗。阿閦菩萨摩诃萨不但有功德。不独大目如来授其决。如是不可称说无央数功德。得度无极。复次舍利弗。大目如来。授阿閦菩萨摩诃萨无上正真道决时。诸天阿须伦世间人。其意皆安隐悉得其时。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。诸天阿修罗世间人意。皆得安隐悉得其时。复次舍利弗。其大目如来。授阿閦菩萨摩诃萨无上正真道决时。和夷罗鬼神常随后护之。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。和夷罗鬼神常随我后行。复次舍利弗。大目如来。授阿閦菩萨摩诃萨无上正真道最正觉。得萨芸若慧时。诸天阿修罗世间人。以天华天香供养之。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。诸天阿修罗世间人。以天华天香来供养。复次舍利弗。大目如来。授阿閦菩萨摩诃萨无上正真道决时。二十亿人及三十亿诸天。发无上正真道意。大目如来无所著等正觉皆授其决。复次舍利弗。大目如来无所著等正觉。授阿閦菩萨摩诃萨无上正真道决时。其地大动自然生优钵华。莲华。拘文华。分陀利华布其地。譬我亦如是。成无上正真道最正觉。得萨芸若慧时。大地自然生优钵华莲华拘文华分陀利华布其地。复次舍利弗。大目如来无所著等正觉。授阿閦菩萨摩诃萨无上正真道决时。若干百天人。若干千天人。若干百千诸天人住于虚空。以天衣用散阿閦菩萨上。即说是言。菩萨摩诃萨。当度成无上正真道最正觉也。复次舍利弗。大目如来。授阿閦菩萨摩诃萨无上正真道决。尔时诸天阿须罗世间人民相爱。剧父母哀其子。譬我亦如是。成无上正真道最正觉时。诸天阿修罗世间人民相爱。剧父母哀其子也

复次舍利弗。大目如来。授阿閦菩萨摩诃萨无上正真道决时。其三千大千世界中诸天及人民。承佛威神。皆闻授阿閦菩萨决。如是舍利弗。昔授菩萨决时。其此国中人民。一心布施为福德快饮食。若有求索者。已所喜而施与。譬我亦如是。成无上正真道最正觉时。是三千大千世界中诸天及人民。皆承佛威神闻授决时。如是舍利弗。昔此国中人民。一心布施为福德快饮食。若有求索者。已所喜而施与。复次舍利弗。其大目如来。授阿閦菩萨摩诃萨无上正觉道决时。诸欲界天悉鼓天伎乐供养。舍利弗。是阿閦菩萨摩诃萨授决时之功德行。贤者舍利弗白佛言。难及天中天。如来无所著正觉。诚谛说之。不可思议诸佛佛之境界。不可思议诸神神之境界。不可思议诸龙龙之境界。不可思议诸龙之境界乃从阿閦菩萨摩诃萨初发意。学受得此功德。天中天。是阿閦菩萨摩诃萨授决时。亦不可思议。是时贤者阿难。谓贤者舍利弗。阿閦菩萨摩诃萨初发意。学僧那及得号如是也。舍利弗谓阿难言。是皆有因缘所致。阿閦菩萨摩诃萨初发意。学僧那及德号。今佛当广解说之。时佛告舍利弗言。阿閦菩萨初发是意时。可令虚空有异。我所结愿不可使有异。被僧那僧涅乃如是。佛语舍利弗。如阿閦菩萨摩诃萨所被僧那僧涅。宝英菩萨摩诃萨。亦从阿閦菩萨学行。舍利弗。无央数菩萨。不能及知阿閦菩萨所被僧那僧涅。甚坚积累德行乃如是。舍利弗。其阿閦菩萨。以成无上正真道也。最正觉今现在阿比罗提世界。阿閦如来无所著等正觉。行菩萨道时。世世人求手足及头目肌肉。终不逆人意也。舍利弗。阿閦如来从初发意。至成无上正真道最正觉。不中有头痛。亦无风气上隔之病。舍利弗是阿閦如来无所著等正觉。昔行菩萨道时。甚难及未曾有之法。阿閦如来昔行菩萨道时。世世见如来一切常奉梵行世世亦作。是名阿閦菩萨。从一佛刹复游一佛刹。所至到处目常见诸天中天生于彼。佛言舍利弗。譬如转轮王得天下。所从一观复至一观。足未曾蹈地。所至常以五乐自娱得自在至尽寿。如是舍利弗。阿閦如来行菩萨道行。世世常自见如来无所著等正觉。常修梵行。于彼所说法时。一切皆行度无极。少有行弟子道。彼所行度无极为说法。有立于佛道者。便劝助为现正。令欢喜踊跃。皆令修无上正真道。便发是大尊意。彼说法时诸所德本以愿持。作无上正真道。我持是德本愿无上正真道。成最正觉时。说法令我佛刹中诸菩萨摩诃萨。佛说法时承佛威神皆受讽诵持之。讽诵已是诸菩萨摩诃萨。从一佛刹复游一佛刹。意常乐诸佛天中天。至成无上正真道最正觉。我亦如是。从一佛刹复游一佛刹。即住于兜术天得一生补处之法。佛复语舍利弗。如是诸菩萨摩诃萨从兜术天。自以神力下入母腹中。从右胁生。菩萨生堕地时地为大动。以修行有是应。菩萨在母腹中时。都无有臭处。亦无恶露。亦无不可意。时佛语舍利弗。譬如神通比丘。若入绞露精舍。于虚空中游行周匝虚空中行。于绞露精舍无所触碍。如是舍利弗。菩萨入母腹中时。如在虚空中游观周匝无所触碍。亦无臭处。其阿閦如来昔行菩萨道时如是。我亦如是。行无上正真道时。一切皆破坏魔事。我如是成无上正真道最正觉。阿閦佛刹。求菩萨道及弟子道者。皆破坏诸恶。降伏众魔一切皆尽。其佛刹人民。不复作魔事。我当修是佛道至得出家学道。佛语舍利弗。阿閦如来无所著等正觉。昔行菩萨道听说法时。其身不生疲极。意亦不念疲极。舍利弗。阿閦如来昔求菩萨道听说法时。如是好法。令我佛刹中诸菩萨摩诃萨。好法如是

    阿閦佛刹善快品第二

贤者舍利弗白佛言。天中天。是阿閦如来无所著等正觉。昔行德号时。以成号阿閦如来。甚善天中天。愿佛当复广说其佛刹之善快。所以者何。若有求菩萨道者。闻知彼佛刹之善快。及阿閦如来所现行教授。若复有求弟子道未得度者。闻彼佛刹之善快。及阿閦如来所现教授。恭敬清净之行。佛言。善哉善哉。舍利弗。所问甚善。汝问佛义快乃如是。念阿閦佛刹之善快。阿閦如来成无上正真道最正觉。得萨芸若慧时。其三千大千世界皆为大明。地六反震动。阿閦如来成最正觉时。其三千大千世界中诸人民。七日不食饮。亦不妄食饮。亦不妄谀谄。身亦无疲极之想。如是也。俱想念安隐。好喜相爱敬。欢喜意以得时念。尔时诸人民诸欲天。皆弃秽浊思想。所以者何。用阿閦如来昔时愿所致得是德号。其三千大千世界一切人民。叉手向阿閦如来。其佛刹如是。无央数佛刹。不及是阿閦佛刹之善快。舍利弗。是为阿閦如来昔行菩萨道之所愿而有持。诸菩萨摩诃萨所愿有持者。佛佛刹便善快

佛语舍利弗。我昔行菩萨道时。如所愿今自然得之。阿閦如来成无上正真道最正觉时。其三千大千世界诸人民得天眼者。未得天眼者。皆见其光明。舍利弗。是为阿閦如来昔行菩萨道时所愿而有持。佛复语舍利弗。阿閦如来成无上正真道最正觉。往诣佛树时。诸憋魔不能发念。何况当复能往娆萨芸若慧。舍利弗。是为阿閦如来昔行菩萨道时所愿而有持。复次舍利弗。阿閦如来成无上正真道最正觉。得萨芸若慧时。无央数那术亿百千诸天人。于虚空住。以天华天栴檀杂香天捣香伎乐。供养散阿閦佛上。供养已。其天华天香天捣香天栴檀香天杂香。悉于虚空中合住。化成圆华盖。舍利弗。是为阿閦如来昔行菩萨道时所愿而有持。阿閦如来光明皆照明三千大千世界常明。阿閦如来光明悉蔽日月之光明。及一切诸天光明皆令灭。使人民不复见日月之明。舍利弗。是为阿閦如来昔行菩萨道时所愿而有持

贤者舍利弗白佛言。天中天。阿閦如来无所著等正觉。昔行菩萨道时。以被是大僧那僧涅。乃作是愿。佛言。昔行菩萨道时。若干百千人不可复计。无央数人积累德本。于无上正真道持是积累德本。愿作佛道及净其佛刹。如所愿欲严其佛刹。即亦具足其愿。复次舍利弗。阿閦佛树以七宝作之。高四十里周匝二十里。其枝叶旁行四十里。其枝下垂。其栏楯绕树。周匝五百六十里。阿閦如来于其树下得萨芸若慧。佛语舍利弗。如世间巧人鼓百种音乐。其声不如阿閦佛刹中梯陛树木之音声。风适起吹梯陛。树木相叩作悲声。佛语舍利弗。听说阿閦如来无所著等正觉刹中之净快。谛听善思念之。今当为汝说之。贤者舍利弗言。唯然世尊。愿乐欲闻佛言。阿閦如来刹中无有三恶道。何等为三。一者泥犁。二者禽兽。三者薜荔。一切人皆行善事。其地平正生树木。无有高下。无有山陵溪谷。亦无有砾石崩山。其地行足蹈其上即减。这举足便还复如故。譬如綩綖枕头枕其上即为减。这举头便还复如故。其地如是。其佛刹无有三病。何等为三。一者风。二者寒。三者气。其佛刹人。一切皆无有恶色者。亦无有丑者。其淫怒痴薄。其佛刹人民。皆悉无有牢狱拘闭之事。一切皆无有众邪异道。其刹中树木常有花实。人民皆从树取五色衣被。众共用着之。其衣被甚姝好无败色者

佛语舍利弗。人民所著衣香。譬如天华之香。其饭食香美。如天树香无有绝时。诸人民着无央数种种衣被。其佛刹人民。随所念食。即自然在前。譬如舍利弗。忉利天人。随所念食即自然在前。如是其刹人民。随所念欲得何食。即自然在前。人民无有贪于饮食者。复次舍利弗。其佛刹人民所卧起处。以七宝为交露精舍。满无有空缺处。其浴池中有八味水。人民众共用之。其水转相灌注。诸人民终不失善法行。譬如舍利弗。玉女宝过踰凡女人不及。其德如天女。如是舍利弗。其佛刹女人德。欲比玉女宝者。玉女宝不及其佛刹女人。百倍千倍万倍亿倍。巨亿万倍不与等。人民以七宝为床。上布好綩綖。悉福德致自然为生。舍利弗。是阿閦如来无所著等正觉。昔行菩萨道时所愿而有持。阿閦佛以福德所致成佛刹如是比。佛复语舍利弗言。其刹中人民饭食胜于天人饭食。其食色香味。亦胜天人所食。其刹中无有王。但有法王佛天中天。佛言舍利弗。譬如郁单越天下人民无有王治。如是舍利弗。阿閦如来无所著等正觉佛刹无有王。但有阿閦如来天中天法王。譬如忉利天帝释。于坐这发念。诸天便来受其教。舍利弗。是为阿閦如来佛刹之善快。其刹人民不从淫欲之事。所以者何。用是阿閦如来真人法御天中天所致。舍利弗。是为阿閦如来昔行菩萨道时愿所致。令佛刹善快

尔时有异比丘。闻说彼佛刹之功德。即于中起淫欲意。前白佛言。天中天。我愿欲往生彼佛刹。佛便告其比丘言。痴人汝不得生彼佛刹。所以者何。不以立淫欲乱意者。得生彼佛刹。用余善行法清净行。得生彼佛刹。佛语舍利弗。阿閦如来佛刹。有八味水。是诸人民所为。悉共用之。人民意念。欲令自然浴池。有八味水满其中。用人民故。即自然有浴池。有八味水满其中。意念欲令水转流行。便转流行。意欲令灭不现。即灭不现。其佛刹亦不大寒。亦不大热。风徐起甚香快。是风用诸天龙人民故。随所念风便起。若一人念。欲令风起自吹。风即独吹之。意念不欲令风起。风便不起。风起时不动人身。风随人所念起。舍利弗。是为阿閦如来佛刹之善快。如昔时所愿。佛语舍利弗。阿閦如来佛刹女人。意欲得珠玑璎珞者。便于树上取着之。欲得衣被者。亦从树上取衣之。舍利弗。其佛刹女人无有女人之态。如我刹中女人之态也。舍利弗。我刹女人态云何。我刹女人。恶色丑恶舌。嫉妒于法。意着邪事。我刹女人有是诸态。彼佛刹女人无有是态。所以者何。用阿閦如来昔时愿所致。佛复语舍利弗。阿閦佛刹女人。妊身产时身不疲极。意不念疲极。但念安隐亦无有苦。其女人一切亦无有诸苦。亦无有臭处恶露。舍利弗。是为阿閦如来昔时愿所致。得是善法。其佛刹无有能及者。舍利弗。阿閦佛刹人民无有治生者。亦无有贩卖往来者。人民但共同快乐安定寂行。其佛刹人不着爱欲淫劮。以因缘自然爱乐。其刹风起吹梯陛树。便作悲音声。舍利弗。极好五音声不及阿閦佛刹风吹梯陛树木之音声也。舍利弗。是为阿閦如来昔行佛道时所愿而有持。佛语舍利弗。若有菩萨摩诃萨。欲取严净佛刹者。当如阿閦佛昔行菩萨道时。所愿严净取其刹。佛复语舍利弗。阿閦佛刹无有日月光明所照。亦无有窈冥之处。亦无有挂碍。所以者何。用阿閦如来无所著等正觉光明。皆照三千大千世界常明。譬如绞露精舍坚闭门风不得入。好细涂以白垩之。持摩尼宝着其中。其珠便以光明照。其中诸人民昼夜承其光明。如是舍利弗。其阿閦如来无所著等正觉光明。常照三千大千世界。舍利弗。绞露精舍者。谓是阿比罗提世界也。摩尼宝者谓是阿閦如来也。摩尼宝光明者。谓是阿閦如来之光明也。精舍中人者。谓是阿閦佛刹中人民安乐者也

佛语舍利弗。阿閦如来行所至处。于足迹下地。自然生千叶金色莲华。舍利弗。是为阿閦如来昔行菩萨道时所愿而有待。贤者舍利弗问佛言。阿閦如来无所著等正觉。入殿舍时。自然生千叶金色莲华耶。为在所至处自然生乎。佛告贤者舍利弗。阿閦如来若入郡国县邑。所至到处。亦等如入殿舍时也。亦自然生千叶金色莲华。若善男子善女人。意念欲令入殿舍足下自然生莲华者。皆使莲华合聚一处便合聚。意欲令上在虚空中承佛威神。其莲华用人民故。便上在虚空中。而罗列成行。佛复语舍利弗。其三千大千世界乃如是。阿閦如来无所著等正觉。若遣化人到他方异世界。彼亦自然生。以佛威神所致。其三千大千世界。以七宝金色莲华而庄严之

    阿閦佛国经弟子学成品第三

佛复语舍利弗。阿閦如来说法时。于一一说法之中。不可计无央数人。随律之行至。有作阿罗汉道证者。如是比无央数诸弟子聚会。及复得八惟务禅者。阿閦如来佛刹诸弟子众不可复计。佛语舍利弗。我都不见持计者与挍计。巨能计数其众会者也。以脱重担离于牢狱。远于波头犁。阿罗罗犁。阿比舍犁。阿优陀犁。如是舍利弗。众会不可计数诸善男子。是弟子智慧无央数不可计众。在须陀洹斯陀含阿那含阿罗汉道也。若懈怠者得须陀洹为七生七死。于是说法时。其人为不得上持为七生七死。阿閦如来说法时。第一说法作须陀洹道证。第二说法作斯陀含道证。第三说法作阿那含道证。第四说法作阿罗汉道证者。其佛刹。谓是善男子为懈怠。用不一坐听法。作阿罗汉道证故。其刹须陀洹。不复七上下生死。便于人间坐禅。得三昧须陀洹。即于彼自以威神力作阿罗汉道证。其刹斯陀含不复往还世间。以弃众苦便于彼得三昧斯陀含。便于其刹自以威神力作阿罗汉道证。其刹阿那含。不复上生波罗尼蜜和耶越天。便于彼自以威神力作阿罗汉道证。其刹阿罗汉不上下。便于彼至无余泥洹界般泥洹。其刹说沙门四道。如是至令得道住。佛言舍利弗。若善男子善女人。于法自在者不复失学住。亦不失学余事。如是于不学地便般泥洹也。无所学地。谓是阿罗汉地。舍利弗。是为阿閦如来无所著等正觉刹诸弟子学成无有粗立。在上好要处者。谓是阿閦如来刹弟子众阿罗汉也。生死已断所作而办。所当为者以脱重担。便得所有尽坏勤苦牢狱之事。以中正解复知八维无禅。阿罗汉行八维无禅。舍利弗。是为阿閦如来刹弟子之善行。是为阿罗汉之功德所为福行。其刹以三宝为梯陛。一者金。二者银。三者琉璃。从忉利天下至阎浮利地。其忉利天。欲至阿閦如来所时。从是梯陛下。忉利天人。乐供养于天下人民言。如我天上所有。欲比天下人民者。天上所有大。不如天下及复有阿閦如来无所著等正觉也

佛语舍利弗。忉利天人乐供养天下人民。天下人若上至忉利天者。便不乐供养忉利天人。所以者何。我天下佛说经。如我天下所有。于是天上无也。不如我天下所有我天下乐供养有佛。忉利天见天下人民。天下人遥见忉利天宫殿。譬如此刹天下人遥见日月星辰殿舍。如是舍利弗。其佛刹天下人。遥见诸天宫殿如是。及欲行天承佛威神所致。是为阿閦如来佛刹所有善快。佛复语舍利弗。阿閦如来佛刹。三千大千世界皆说法四辈弟子。满三千大千世界无空缺。阿閦佛刹弟子意不念。今日当于何食。今日谁当与我食。亦不行家家乞。时到饭食便办满钵自然在前。即取食食已。钵便自然去。其刹饭食如是。诸弟子不复行求衣钵也。亦不裁衣。亦不缝衣。亦不浣衣。亦不染衣。亦不作衣。亦不教人作。以佛威神所致。同共安乐自然生。阿閦如来不为诸弟子说罪事。如我为诸弟子说十四句法。阿閦如来不为诸弟子说如是之法。所以者何。其刹无有行恶者。阿閦佛不复授诸弟子戒。所以者何。其佛刹人无有短命者。亦无蔽恶人。无有秽浊劫。亦无有诸结。无有秽浊。见其刹以除诸恶秽浊

佛复语舍利弗。阿閦佛说法时。诸弟子便度于习欲。所以者何。已弃于恶道故。其刹众弟子终无有贡高憍慢。不如此刹诸弟子于精舍行律。其刹弟子无有作是行者也。所以者何。舍利弗。用其人民善本具故。所说法悔过各得其所。其刹不说五逆之事。一切皆断诸逆已。诸弟子不贪饮食。亦不贪衣钵。亦不贪众欲。亦不贪着也。为说善事。所以者何。用少欲知止足故。舍利弗。阿閦佛不复授诸弟子戒。如我于此授诸弟子戒。所以者何。其刹无有恶者。是诸弟子但以苦空非常非身以是为戒。其刹亦无有受戒事。譬如是刹正士。于我法中剃除须发。少欲而受我戒。所以者何。其阿閦佛刹诸弟子。得自在聚会无有怨仇。舍利弗。阿閦佛刹诸弟子不共作行。便独行道不乐共行但行诸善。其刹无有过精进者。亦不可见懈怠者。舍利弗。是为阿閦如来佛刹出家诸弟子之德行

佛语舍利弗。阿閦如来。为诸弟子说法时。弟子不左右顾视一心听经。中有住听经者。身不知罢极。中有坐听经者。身亦不知罢极。意亦不念罢极也。阿閦如来于虚空中说法时。诸弟子悉听之。是时得神足比丘。未得神足比丘。承佛威神。皆于虚空中行而听法。是诸弟子于虚空中以三品作行。何等三。一者住。二者经。三者坐。中有坐般泥洹波蓝坐居而般泥洹者。诸弟子皆般泥洹时地即为大动。般泥洹已诸天人民共供养之。中有阿罗汉。身中自出火还烧身而般泥洹。中有阿罗汉般泥洹时。自以功德行如疾风中有。譬如五色云气于空中行便不复知处。中有弟子自以功德便没去不复知处。般泥洹如是。中有般泥洹时。于虚空身中放水其水不堕地便灭不现。其刹如是清净。令身灭不现。其刹如是清净。令身灭不现而般泥洹。诸弟子般泥洹如是也。舍利弗。是为阿閦如来无所著等正觉。昔行菩萨道时所愿而有持成无上正真道。诸弟子以是三品般泥洹。复次舍利弗。阿閦如来佛刹诸弟子。无央数不可计诸弟子。少有不具足四解之事者。多有得四解事具足者。诸弟子少有不得四神足安隐行者。多有得四禅足安隐行者。舍利弗。是为阿閦如来佛刹诸弟子所成德行。贤者舍利弗白佛言。阿閦如来无所著等正觉佛刹。诸弟子所行。皆无极也

阿閦佛国经卷上阿閦佛国经卷下

        后汉月支国三藏支娄迦谶译

    诸菩萨学成品第四

尔时贤者舍利弗心念言。佛已说弟子所学成。愿佛当复说诸菩萨所学成。所以者何。皆当学成是诸菩萨所照光明。时佛即知贤者舍利弗心所念。即告舍利弗。其阿閦如来无所著等正觉佛刹。有若干百菩萨。若干千菩萨。若干亿菩萨。若干亿百千菩萨。大会如是。佛语舍利弗。诸菩萨摩诃萨于阿閦佛所下须发。皆承佛威神悉受法语讽诵持之。如我于是所说法由为薄少耳。阿閦佛所说法无央数不可复计。比我所说法。百倍千倍万倍亿万倍不在计中。舍利弗。是为阿閦如来昔行菩萨道时所愿。我成无上正真道最正觉时。令我佛刹诸菩萨。我说法时。令诸菩萨皆承佛威神。悉受讽诵持之。佛复语舍利弗。尔时诸菩萨摩诃萨皆承佛威神。受所说法讽诵持。是诸菩萨摩诃萨自生意念。欲从其刹至他方世界。俱至诸如来所听所说法。为诸佛世尊作礼讽诵之。复重问意解。为诸佛作礼讽诵已。重问意解已。便复还至阿閦如来所。佛语舍利弗。是陂陀劫中当有千佛。甫始四佛过。菩萨摩诃萨欲见是诸佛者。当愿生阿閦佛刹。若有善男子善女人。于是世界若他方世界。终亡往生阿閦佛刹者。甫当生者即当得住弟子缘一觉地。所以者何。其有因缘见如来者及众僧。为以断弊魔罗网去。得近弟子缘一觉及佛地。当得无上正真道最正觉。其人为以成如来。为以见诸菩萨摩诃萨之事。菩萨生阿閦佛刹者。其行皆住清净。为行诸法。为在诸法士。为以住于法。为佛道不可动转。复当坚住阿惟越致。佛语舍利弗。若善男子善女人。于是世界若他方世界。终亡往其刹者等辈。得入诸佛住。其菩萨为得觉意入无恐惧。觉意菩萨。合会于智慧度无极在所各同义。见世尊知所住。其佛刹诸菩萨摩诃萨。在家者止高楼上。出家为道者不在舍止。佛告舍利弗。阿閦佛说法时诸菩萨摩诃萨。承佛威神皆受法语讽诵持之。其不出家菩萨摩诃萨不面见佛所说时。在所坐处承佛威神皆亦闻法语。闻已即受讽诵持之。其出家菩萨摩诃萨。身自面见佛说法时。及所行至坐处。亦承佛威神皆闻。闻已即受讽诵持。是菩萨摩诃萨。终亡已后俱持法语。所至生诸佛刹续念之。舍利弗。是为阿閦佛之善快。所以者何。如昔所愿自然得之

佛语舍利弗。若有一世菩萨摩诃萨。欲见若干百佛。若干千佛。若干万佛。若干亿那术百千佛。当愿生阿閦佛刹。菩萨已生阿閦佛刹者。便见若干百佛。若干千佛。若干亿万佛。若干亿那术百千佛。当于其刹种诸德本。当为无央数百千人。无央数百千亿人。无央数亿那术百千人说法。亦当令种德本。佛言舍利弗。若菩萨摩诃萨于是陂陀劫中。皆供养诸所佛天中天。衣被饭食床卧具病瘦医药供养。以便出家学道。悉于是诸佛天中天。下须发为沙门。若复有菩萨摩诃萨。不知于阿閦佛刹一世合会行度无极得福多。佛言舍利弗。是福德善本行具足。百倍千倍万倍巨亿万倍不与等。舍利弗。是为阿閦佛刹之善快。佛语舍利弗。若一世菩萨于是世界他方世界终亡。生阿閦佛刹者。甫当生者皆得阿惟越致。所以者何。其佛刹无有憋魔事在前立。憋魔亦不娆人。佛言舍利弗。譬如人咒力语咒毒咒蛇。除其毒便放舍。其力不可胜。救无央数人恐畏。其蛇亦不恐人亦不娆触人。如是其人。但以前世禅三昧行故。自以功德得灭于蛇毒。如是舍利弗。阿閦佛昔求菩萨道时。行愿德本如是乃得佛道。消除于憋魔毒不复娆人。阿閦佛成无上正真道最正觉时。憋魔不能复来娆。亦不能复娆诸菩萨摩诃萨及凡人。一切皆不复娆三千大千世界中人。如是先坐三昧寂定。以自威神。生和耶越致天。于彼以前世因缘行广普。亦于和耶越致天。以因缘三昧。以自威神寂寞。以是比于彼说法。炎天闻之。闻已便得信欢喜。来供养诸弟子。炎天言。乃作是无所著。知止足空闲处作行。其刹诸魔。教人出家学道。不复娆人。舍利弗。是阿閦佛刹德之善快。夜初鼓时先哀念人民。欲令度脱诸菩萨及学弟子并凡人安隐寂寞行

贤者舍利弗白佛言。唯天中天。若善男子善女人。以七宝满三千大千世界。持用布施得生阿閦佛刹者。其人不当惜也。便当布施。所以者何。其人不复堕弟子缘一觉道。所以者何。其人即为立不退转地。从一佛刹复至一佛刹。目常悉见诸佛。皆悉讽诵佛道行。当成无上正真道最正觉。常当见若干百佛若干千佛若干亿那术百千佛。于彼积德本。舍利弗白佛言。天中天。以是故善男子善女人。以七宝满三千大千世界布施。得生阿閦佛刹者。其人当欢喜与。便安隐至其佛刹。佛言如是。舍利弗。菩萨摩诃萨为安隐得生阿閦佛刹。譬如出金地无有砾石亦无草木。中有紫磨金。人便取其金。于火中试消合。以作诸物着之。如是舍利弗。阿閦佛刹诸菩萨摩诃萨。清净微妙住清净共会。是诸菩萨摩诃萨行也。其有生阿閦佛刹者。甫当生者。皆一种类道行悉等。诸菩萨当成如来。其人以过诸弟子缘一觉地。是谓为一类道。无有众邪异道。菩萨欲得一类者。当愿生阿閦佛刹。舍利弗。是菩萨摩诃萨为成阿惟越致阿閦佛为受决。以我不欲遣菩萨摩诃萨至阿閦佛所。譬如舍利弗。转轮王遣使者。至诸小王所。使持王宝物来。于是闻王遣使者。令诸小王来。便愁忧涕泣。用王宝物故。夫人婇女及太子。闻以宝物故皆畏王。便往至大王所居城。垣坚止顿其中得安隐。不复恐见怨家谷贵苦。如是舍利弗。我不欲遣诸菩萨至阿閦佛所。譬如彼王以宝物故。令诸夫人婇女及太子同等愁忧视。求菩萨道人。当如大王城所有宝处太子为无有恐难。观诃閦佛刹当如大王。憋魔见求菩萨道者。如是不复娆乱。譬如王边臣难当。如是舍利弗。魔及魔天官属。不能当如来无所著等正觉。譬如孤寡恐惧之人畏对家。便往至城中即安。对家人无奈之何。所以者何。是人已离于对人得安隐处故。如是舍利弗。诸菩萨摩诃萨。生阿閦佛刹者。为以断魔及魔天之道。其三千大千世界憋魔及魔天不复娆求菩萨道及弟子道人。及阿閦佛刹魔及魔天不复起魔事亦不复娆。复次舍利弗。若有菩萨。往生阿閦佛刹者。甫当生者。其人不复为魔天之所娆也。所以者何。阿閦佛昔行菩萨道。便作是愿德本。令我成无上正真道最正觉。使我佛刹诸魔及魔天。无有起魔事娆乱者。譬如人饮毒。复饮除毒药。其饮食便消其毒不行。以等愿故。如是舍利弗。阿閦佛昔时作是愿德本。乃至其佛刹诸魔及魔天子。不复起事娆乱。其佛刹所有德等乃如是。尔时贤者舍利弗心念言。愿欲见其佛刹及阿閦佛并诸弟子等。于是佛即知舍利弗心所念。即令如其像三昧正受神足行。承佛所致。贤者舍利弗。于其座中。见阿閦佛刹及弟子等

尔时佛告舍利弗言。汝宁见阿閦佛及诸弟子并佛刹不。对曰。唯然见之。天中天。云何舍利弗。汝意所知。宁复有胜阿閦佛刹诸天及人不。舍利弗白佛言。天中天。我不复知有城郭能胜者也。其刹诸天及人民无有邪道。但有正道耳。极相娱乐。所以者何。我见其佛刹。皆以天物快饮食相娱乐。阿閦佛在中央。遍为诸弟子说法。譬如天中天。人在大海中央。不见东方山树木之际。亦不见南西北方树木之际。如是天中天。阿閦佛刹诸弟子。不可得东方涯。亦复不可得南西北方之涯。如是思惟。闻法身亦不动摇。天中天。于是思惟。定身便不动摇。阿閦佛刹诸弟子。听法身不动摇坐定。如是听法身亦不动摇。若善男子善女人。于是三千大千世界满七宝。持施与布施已。得生阿閦佛刹者。当欢喜与其人便得安隐生阿閦佛刹菩萨摩诃萨。所以者何。其人如是得为阿惟越致。譬如天中天。有人持王书及粮食。以王印封书往至他国。其人行至他国县邑。中道无有杀者。亦无有能娆者。独自往还无他。佛言如是也。舍利弗。菩萨摩诃萨生阿閦佛刹。甫当生者。于是世界若他方世界终亡。生阿閦佛刹者。皆得阿惟越致。便见无上正真道。从一佛刹复游一佛刹。皆讽诵佛道事。常乐于佛天中天。至成无上正真道最正觉。舍利弗白佛言。天中天。是间须陀洹道菩萨摩诃萨。生阿閦佛刹者。是适等耳。所以者何。须陀洹以断截恶道住于道迹。如是天中天。若有菩萨摩诃萨。生阿閦佛刹者。甫当生者。是人皆现断恶道。不复在弟子缘一觉地。从一佛刹复游一佛刹。当乐于佛。天中天及弟子。至成无上正真道最正觉也。佛言如是。舍利弗。若有菩萨摩诃萨。于是世界若他方世界终亡。生阿閦佛刹者。为以现过弟子缘一觉地。从一佛刹复游一佛刹。皆讽诵诸佛道事。皆面见诸如来。至成无上正真之道最正觉。譬如舍利弗。须陀洹度脱异道恶法。得道无有异。如是舍利弗。若有菩萨摩诃萨。于是世界若他方世界终亡。往生阿閦佛刹者。甫当生者。其皆不复离无上正真道。从一佛刹复游一佛刹。皆讽诵诸佛道事。常乐于佛天中天无上正真道。至成无上正真道最正觉。贤者舍利弗白佛言。天中天。是间斯陀含住往来地。菩萨摩诃萨生阿閦佛刹者。是这等耳。天中天。是间阿那含住不复还地。菩萨摩诃萨生阿閦佛刹者。是这等耳。天中天。是间阿罗汉住无所著地。菩萨摩诃萨生阿閦佛刹者。是这等耳

佛告贤者舍利弗言。莫得说是语。所以者何。是间菩萨摩诃萨受无上正真道决。菩萨生阿閦佛刹者。是这等耳。复次舍利弗。是间菩萨摩诃萨坐于佛树下。菩萨生阿閦佛刹者。是这等耳。所以者何。舍利弗。菩萨摩诃萨为现如来。憋魔不复能动摇。过弟子缘一觉地。从一佛刹复游一佛刹。常皆随诸佛之教令。至成无上正真道最正觉

尔时阿难心念言。我欲试须菩提知报我何等言。贤者阿难。问贤者须菩提言。唯须菩提。为见阿閦佛及诸弟子等并其佛刹不。须菩提谓阿难言。汝上向视。阿难答言。仁者须菩提。我已上向视上皆是虚空。须菩提谓阿难言。如仁者上向见空。观阿閦佛及诸弟子等并其佛刹当如是。尔时贤者舍利弗问言。如属天中天所说。是间菩萨摩诃萨受决。菩萨生阿閦佛刹者。是这等耳。天中天。以何故等而等。佛告舍利弗言。用法等故而等

    阿閦佛国经佛般泥洹品第五

尔时贤者舍利弗心念言。佛已说阿閦佛昔者行菩萨道时德号。复说佛刹之善快。亦复说诸弟子及诸菩萨所学成愿。佛当复说阿閦佛摩诃般泥洹时。有何感应。天中天。于是佛即知舍利弗心所念。便告舍利弗言。阿閦佛摩诃般泥洹。是日一切三千大千世界诸郡国。变化作化人而说法。所可说者。如前所说法。时人民复行阿罗汉道不复上下。便令住阿罗汉道。阿閦佛般泥洹时。有菩萨摩诃萨。名众香手。当授是众香手菩萨决。号曰羞洹那洹波头摩(汉言金色莲华)

如来无所著等正觉。复次舍利弗。其金色莲华佛之刹所有善快。亦当如阿閦佛刹之善快所有安谛。金色莲华佛所有众弟子。亦当如阿閦佛。复次舍利弗。阿閦佛摩诃般泥洹时。当大动摇皆悉遍三千大千世界。声上闻阿渐货罗天。乃复至闻阿迦尼吒天。阿閦佛般泥洹时当有是瑞应

复次舍利弗。阿閦佛刹诸好药树木。皆曲向阿閦佛般泥洹所作礼。阿閦佛摩诃般泥洹时。诸天及人民持华香杂香捣香。供养散其身上。供养已。其诸天人民华香杂香捣香及余宝。上至虚空四十里成圆华盖。阿閦佛摩诃般泥洹时。其三千大千世界。诸天龙鬼神揵陀罗阿须伦迦留罗真陀罗摩休勒。皆向阿閦佛摩诃般泥洹时。是人民及诸天以佛威神所致。悉见阿閦佛摩诃般泥洹时。复次舍利弗。阿閦佛摩诃般泥洹时。诸天及人民昼夜常愁忧言。阿閦佛般泥洹大疾。为己亡人民娱乐。不复得乐所欲。意愁忧言。阿閦佛般泥洹大疾亡失人民安隐。意愁忧言。亡天下眼。佛语舍利弗。若有菩萨摩诃萨于是世界若他方世界终亡。生阿閦佛刹者。甫当生者。其人皆为以受决。从一方复至一方。共等辈游行。若干百千等辈共游行。菩萨摩诃萨当见若干百千如来。当见无数佛。当见无数萨芸若。若有菩萨摩诃萨于是世界若他方世界终亡。生阿閦佛刹者。甫当生者。其人亦与众等俱游行。以佛威神所致萨芸若故。为阿惟越致。菩萨摩诃萨闻是阿閦佛德号法经。皆为离魔罗网。复次舍利弗。阿閦佛摩诃般泥洹时。至法行在者。诸菩萨摩诃萨生阿閦佛刹者。亦当与等辈游行。求索阿閦佛昔时愿。然后当生阿閦佛刹。菩萨摩诃萨。便当讽诵八百门。讽诵已。皆当讽诵诸法。便有上微妙阿閦佛刹。诸菩萨摩诃萨。得念行住八百门。我当生阿閦佛刹。亦当讽诵八百门。讽诵已。皆当复讽诵诸法见上妙句。如是谛受之。菩萨摩诃萨。阿閦佛现在及般泥洹时。说法等无异。佛刹等如来所示现。从阿惟越致。至成无上正真道最正觉。复次舍利弗。阿閦佛身中自出火。还烧身已便作金色。即碎若芥子。不复还复。讫已便自然生。譬如舍利弗。有树名坻弥罗。若发段段断已不复见。自然生。如是舍利弗。阿閦佛摩诃般泥洹时。身破碎不复见。还自然生。复次舍利弗。阿閦佛摩诃般泥洹时。其身骨坐处见自然。譬如有山碎破其山不复见。自然还其处。如是舍利弗。阿閦佛摩诃般泥洹时。其骨自破碎其身骨不复见。还自然。时一切三千大千世界人民。皆供养其身。以七宝作塔。其三千大千世界。当以七宝塔及叶金色莲华而庄严。复次舍利弗。阿閦佛刹诸菩萨摩诃萨当作礼。有瑞应乃如是。自然诸宝于其处在前住。其有菩萨摩诃萨。往生阿閦佛刹者。甫当生者。当见佛意无乱。命过时一切诸天人当供养其身。诸天及人民。愿发起是供养其身。菩萨摩诃萨自以功德。稍于虚空疾行。都不复知其处。譬如舍利弗。持草木着火中熏烟而行。其烟上于虚空中。亦于虚空中而行。亦于虚空中都灭。不知所至处。其佛刹诸菩萨摩诃萨法身如是。复次舍利弗。阿閦佛刹菩萨摩诃萨。寿命尽临寿终时。见余菩萨摩诃萨。他方世界坐佛树下时。是诸菩萨摩诃萨临寿终时瑞应。复见余菩萨入母腹中。时亦复见余菩萨摩诃萨从母右胁生出。时行七步。时见在婇女中相娱乐。时见余菩萨摩诃萨出家学道。时见余菩萨坐佛树下降伏魔得萨芸若慧。时见他方世界诸佛天中天转法轮。时佛言舍利弗。阿閦佛刹菩萨临寿终时。以是比有自然瑞应。复次舍利弗。阿閦佛摩诃般泥洹时。佛所说法。当住至若干百千劫。贤者舍利弗问佛言。天中天。以何等数佛所说法。住至百千劫。佛告舍利弗言。二十小劫为一劫。是为数佛所说法住百千劫。复次舍利弗。其法灭尽时。一切三千大千世界。当大照明。其地当大动。其法不是憋魔及魔天之所灭。亦不是天中天弟子所灭。诸比丘稍乐寂往还是。稍寂共往还已。俱行不复大听闻法。不听闻已。亦不大承用。复不得大精进。法师比丘。于法教亦寂说法少。以是故法稍灭尽。稍稍不见。尔时贤者舍利弗问佛言。云何天中天。菩萨摩诃萨用何等德行故。得生阿閦佛刹。佛告舍利弗。是菩萨摩诃萨。当学阿閦佛昔求菩萨道时行。当发如是意愿。令我生阿閦佛刹。菩萨摩诃萨用是行故得生彼佛刹。复次舍利弗。菩萨行布施度无极。积累德本。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是行故得生彼佛刹菩萨行诫度无极。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是行故得生彼佛刹。菩萨行忍辱度无极。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是行故得生彼佛刹。菩萨行精进度无极。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是行故得生阿閦佛刹。菩萨行一心度无极。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是行故得生彼佛刹。菩萨行智慧度无极。持愿无上正真道。得在阿閦佛边。菩萨摩诃萨用是故得生彼佛刹

复次舍利弗。诃閦佛光明。皆炎照三千大千世界。我当愿见是。见已令我成无上正真道最正觉。当复自炎照其佛刹。菩萨摩诃萨用是行故得生阿閦佛刹。我当见阿閦佛刹。无央数不可计诸弟子见已。我亦当作如是行。令我成无上正真道最正觉时。使有无央数诸弟子。菩萨摩诃萨用是行故得生阿閦佛刹。阿閦佛刹。有若干百菩萨。若干千菩萨若干百千菩萨。我当见是诸尊菩萨。寂寞观行。我当学之。当于处处晓了知之。我当与同学等无差特。当与是一等类俱在一处。欲具大慈大悲用佛故沙门义故。无辟支佛义。无有弟子之行。无有弟子意。无有缘一觉意。谛住于空。无有恶道法。于诸佛名等。诸如来名等。萨芸若名等。于诸法名等。于众僧名等。常念诸名等。如诸菩萨摩诃萨。若有善男子善女人。闻名得生阿閦佛刹。何况合会诸度无极善本。持愿阿閦佛刹。合会众善本已。便成无上正真道最正觉。何况合会诸度无极众善本。便得生阿閦佛刹。菩萨摩诃萨用是行故得生阿閦佛刹

复次舍利弗。菩萨摩诃萨欲生阿閦佛刹者。当念东方不可计诸佛天中天。善法品等因缘。诸佛天中天所可说法。念其无有等者。令我成无上正真道最正觉。当复说法如是。如诸佛天中天。念其众弟子因缘等。我何时成无上正真道最正觉。亦当有无央数不可计诸弟子众。舍利弗。若有善男子善女人。当念三事。当晓了念是三大事。若善男子善女人。以念是三大事合会德本。为一切众生作迹念持愿。作无上正真道。用一切众生故愿三事。善男子善女人。菩萨摩诃萨。愿无上正真道。不可限一切众生。若有人来。以器欲限取虚空。来已谓言。善男子持善本。与我共分之。佛言舍利弗。若使善本有色者。一切众生。便可以器满限取虚空。不可竟是善本以器取。如是舍利弗。愿善本于无上正真道。是亦不可以器取。如是谓为萨芸若善本。若有念三事善本。便转得三宝。若有菩萨摩诃萨念是三事善本愿。皆见善法。菩萨行三事善本愿。降伏众魔及官属。所向欲念生何佛刹。即得生其佛刹。南方西方北方上方下方亦如是。四维亦如是。若有菩萨摩诃萨。念是三事善本积累。以持作劝助。劝助已持愿向阿閦佛刹。其人即得生其佛刹

佛告舍利弗。若干百佛刹。若干千佛刹。若干百千佛刹。如是佛刹之善快。诸佛刹之善快空耳。阿閦佛刹亦如是。我当见其佛刹之善快。见是以我亦当取。如是比佛刹之善快。当劝助若干百菩萨。若干千菩萨。若干百千菩萨为现正。令欢喜踊跃上及阿閦世尊等。菩萨摩诃萨用是行故得生阿閦佛刹。若有菩萨摩诃萨。专发是意向阿閦佛。若使不行者如是为欺。专发是意便得生阿閦佛刹。譬如有城中无市无有园浴池及万物。亦无有象马。亦无有往来中者。云何舍利弗。其城宁有疆王在其中止不。是城德为最下。如是为快不。强王在大城。其城有善德万物。如是城为最上也。如是舍利弗。于是我三千大千世界佛刹力之善快。如我佛刹为下耳。是不为上好也。是间我佛刹所有之善快。如是舍利弗。若菩萨欲净其佛刹之善快者。欲取者。当如是清净取之。如阿閦佛昔行菩萨道时。所取清净佛刹之善快。复次舍利弗。于是成无上正真道最正觉。令人民在须陀洹道。斯陀含。阿那含。阿罗汉道。复教令在辟支佛道。我所教授诸弟子。及余弟子皆共合会。当令在阿閦佛刹诸弟子众边。百倍千倍万倍亿百千倍。巨亿万倍不与等。但说解脱者无有异。我诸弟子。及弥勒佛所有诸弟子。及复余弟子皆复共合会。当令在阿閦佛刹诸弟子众边。是亦百倍千倍万倍。亿万倍不与等。所以者何。阿閦佛一一说法时。人民得道者不可复计。佛言舍利弗。置我诸弟子。复置弥勒佛诸弟子。于陂陀劫中。诸佛天中天所有诸弟子。及余得道弟子。复共合会。当令在阿閦佛刹诸弟子众边。百倍千倍万倍亿万倍巨亿万倍不与等。但说解脱者无异人

尔时贤者舍利弗白佛言。如天中天所说。如我所知。当观其佛刹为阿罗汉刹不为凡夫之刹也。所以者何。彼阿罗汉甚众多。佛言。如是舍利弗。彼刹阿罗汉生死已尽者甚众多。三千大千世界中所有星宿不可计亦不可知多少。阿閦佛一一说法时。得阿罗汉者不可计。如是舍利弗。一一聚会时。不可计无央数人得阿罗汉道。三千大千世界中星宿可知数。阿閦佛刹是诸天人民。以天眼见光明。用积累德本。阿閦佛刹三千大千世界。是诸人民善男子善女人。昼夜往至阿閦佛所。若有闻是德号法经。闻已即受持讽诵者。舍利弗。是善男子善女人。前世为皆已闻见阿閦佛昔求菩萨道时。所以者何。若有闻是德号法经。即有信者。是阿閦佛德号法经。十方等世界佛刹求菩萨道。及求弟子道之人。悉受讽诵持说之。他方佛刹诸阿惟越致菩萨摩诃萨住及余菩萨。亦说阿閦佛所结愿。及生阿閦佛刹者。甫当生者。东方亦如是。南方西方北方上方下方等十方亦如是。一切诸佛刹求菩萨道人。皆受是德号法经。讽诵持说之。阿惟越致菩萨摩诃萨住。复有成无上正真道最正觉。及余菩萨亦如是说阿閦佛所结愿及生其佛刹者甫当生者。如是舍利弗。阿閦佛阿比罗提世界住。炎照十方等诸求菩萨道之人。若有善男子善女人。讽诵阿閦佛德号法经。闻已即持讽诵愿生阿閦佛刹者。临寿终时。阿閦佛即念其人。所以者何。傥憋魔得其便即转所愿如来故念之。其善男子善女人不复转会。当得所愿及无上正真道。若有他异因缘。无能娆害者。如是火刀毒水是亦不行。若复有挝捶者是亦不向。亦不畏人非人。其人如是等见护。便生阿閦佛刹

佛言。譬如舍利弗。日宫殿远住遥炎照天下人。如是阿閦佛远住。炎照他方世界诸住菩萨摩诃萨。譬如得天眼比丘远住遥见色之光。如是舍利弗。阿閦佛远住遥见他方世界诸住菩萨摩诃萨。见其颜色形类。譬如神通比丘远住知他人意所念。如是舍利弗。阿閦佛远住遥知他方世界诸住菩萨摩诃萨意。譬如神通比丘远住遥以天耳闻声。如是舍利弗。阿閦佛远住遥闻他方世界诸菩萨摩诃萨语。及生其刹者。是善男子善女人阿閦佛知其名字及种姓。若有受是德号法经讽诵持者。舍利弗。是人为见阿閦佛。当知是人临寿终时。阿閦佛即为其人。贤者舍利弗白佛言。难及天中天。诸佛世尊。谛嘱累诸菩萨摩诃萨。佛言如是。舍利弗。诸佛天中天。谛嘱累诸菩萨摩诃萨。所以者何。菩萨谛受嘱累者。便为谛受一切众生已。譬如转轮王。若有第一第二第三第四第五第十第二十不可计诸仓。中有稻米大麦小麦及种种谷。谷贵时便出令谷贱。如是舍利弗。菩萨如来记竟。菩萨摩诃萨未成最正觉时。譬如谷贵。已成无上正真道最正觉。便安隐说法如谷贱。是故诸佛天中天。谛嘱累诸菩萨摩诃萨。佛言。舍利弗。若有菩萨摩诃萨。闻是阿閦佛德号法经。闻已即受讽诵持。虽不愿生阿閦佛刹者。当知是菩萨摩诃萨。为比阿惟越致。若有菩萨摩诃萨。受是阿閦佛德号法经。持已受讽诵。为若干百人若干亿百千那术人解说之。当令若干亿那术百千人积累德本。是人如所积德本。其菩萨是德本不可计。是菩萨摩诃萨德本众多。已便坐无上正真道。佛言。舍利弗。若有菩萨摩诃萨。欲疾成无上正真道最正觉者。当受是德号法经。当持讽诵。受持讽诵已。为若干百若干千若干百千人解说之。便念如所说事。即得大智慧。其罪即毕。以得是大智慧。其罪毕已。其人自以功德。便尽生死之道。佛告舍利弗。若有善男子善女人。求弟子道者。闻是阿閦佛德号法经。便当受持当讽诵。受持讽诵已。为若干百人若干千人若干百千人解之。若有善男子善女人受是法经。自以功德即自取阿罗汉证。佛言。舍利弗。若有善男子善女人。专持说是德号法经。是人如是便舍等正觉。自以功德取阿罗汉证。佛语舍利弗。是阿閦佛德号法经。终不至痴人手中。当至黠人手中。佛言。舍利弗。是善男子善女人。是德号法经至其手中者。为见如来已。譬如舍利弗种种诸宝其价甚重。从大海采来者。云何舍利弗。从大海采种种宝当先至谁手中。舍利弗言。天中天。当先至国王若太子左右手中。佛言。如是舍利弗。是阿閦佛德号法经。当先至菩萨手中及阿惟越致。复次舍利弗。菩萨摩诃萨闻是阿閦佛德号法经。便受持讽诵。讽诵已。

即当专成无上正真道最正觉。贤者舍利弗白佛言。是阿閦佛德号法经。薄德之人终不得闻受持讽诵。所以者何。天中天。不能得阿惟越致故

佛告贤者舍利弗。审如是。若有善男子善女人。持金银满是天下。以布施愿言我持是使闻阿閦佛德号法经。薄德之人终不得闻是经。亦不得受持讽诵。菩萨摩诃萨闻阿閦佛德号法经者。为成阿惟越致行。闻已受持讽诵。是故专得无上正真道行。佛语舍利弗。二生补处。三生补处等正觉。求弟子道人所不能及。若有闻阿閦佛德号法经受持讽诵。为若干百人若干千人若干百千人说之。譬如舍利弗转轮王以福德自然生七宝。如是舍利弗。阿閦佛昔愿所致。我为说是德号法经。若有菩萨摩诃萨说是德号法经。若复有菩萨摩诃萨闻是经。甫当闻者亦福德所致。佛语舍利弗。阿閦佛德号法经。于是陂陀劫中所有诸佛天中天皆当说是经。如是令无缺减安谛。亦如我所说。若有菩萨摩诃萨。欲疾成无上正真道最正觉者。当受是阿閦佛德号法经。当持讽诵说之。当令广普。若是德号法经在郡国县邑。有善男子善女人受持讽诵。其菩萨摩诃萨。有是经为护郡国县邑。其有受是德号法经。当持讽诵。复出家学道离罪。菩萨摩诃萨。当令居家学道者知之。所以者何。善男子善女人。党不能究竟是德号法经。佛语舍利弗。若远郡国县邑有行是经菩萨摩诃萨。当往至彼。当受是经讽诵持说。善男子善女人虽不讽诵。但有是经卷当说供养之。若不得经卷者便当写之。若使其人不与是经卷持归写者。菩萨便就其家写之。若使善男子善女人言。自饿写者自饿写之。若言经行写当经行写之。若言住写当住写之。若言坐写当坐写之

阿閦佛国经卷下


阿弥陀佛说咒

    No. 369

阿弥陀佛说咒

那(上)谟菩(上)陀夜(药可反下同)那谟[馬*犬]啰(上)摩夜那谟僧伽夜那摩(上)阿(上)弭多婆(上)夜跢(丁可反下同)他伽(上)多夜阿(上)啰(上)诃(上)羝三藐三菩(上)陀夜跢侄(地也反下同)他阿(上)弭唎(上)羝阿(上)弭唎都婆(上)鼙(菩继反下同)阿(上)弭唎跢三婆(上)鼙阿(上)弭唎跢鼻(菩弭反)迦(上)[口*闌]羝伽弭儞伽(上)伽(上)那(上)稽(居移反)唎底(都儞反)迦(上)[口*(黍-禾+利)]婆(上)啰(上)皤波跢叉(楚我反)焰迦[口*(黍-禾+利)](一切恶业)娑(上)婆诃(若能如法受持决定得生弥陀佛国)


阿弥陀鼓音声王陀罗尼经

    No. 370

阿弥陀鼓音声王陀罗尼经

        失译人名今附梁录

如是我闻。一时佛在瞻波大城伽伽灵池。与大比丘众五百人俱。尔时世尊告诸比丘。今当为汝演说。西方安乐世界。今现有佛。号阿弥陀。若有四众。能正受持彼佛名号。以此功德。临欲终时。阿弥陀即与大众往此人所。令其得见。见已寻生庆悦。倍增功德。以是因缘。所生之处。永离胞胎秽欲之形。纯处鲜妙宝莲花中。自然化生。具大神通。光明赫弈。尔时十方恒沙诸佛。皆共赞彼安乐世界。所有佛法不可思议。神通现化种种方便不可思议。若有能信如是之事。当知是人不可思议。所得业报亦不可思议。阿弥陀佛与声闻俱。如来应正遍知。其国号曰清泰。圣王所住。其城纵广十千由旬。于中充满刹利之种。阿弥陀佛如来应正遍知。父名月上转轮圣王。其母名曰殊胜妙颜。子名月明。奉事弟子名无垢称。智慧弟子名曰贤光。神足精勤名曰大化。尔时魔王名曰无胜。有提婆达多。名曰寂静。阿弥陀佛。与大比丘六万人俱。若有受持彼佛名号。坚固其心忆念不忘。十日十夜。除舍散乱。精勤修集念佛三昧。知彼如来常恒住于安乐世界。忆念相续勿令断绝。受持读诵此鼓音声王大陀罗尼。十日十夜。六时专念。五体投地礼敬彼佛。坚固正念悉除散乱。若能令心念念不绝。十日之中必得见彼阿弥陀佛。并见十方世界如来及所住处。唯除重障钝根之人。于今少时所不能睹。一切诸善皆悉回向。愿得往生安乐世界。垂终之日。阿弥陀佛与诸大众。现其人前安慰称善。是人即时甚生庆悦。以是因缘。如其所愿寻得往生。佛告诸比丘。何等名为鼓音声王大陀罗尼。吾今当说。汝等善听。唯然受教。于时世尊即说咒曰

多狄他(一)婆离(二)阿婆离(三)娑摩婆罗(四)尼地奢(五)昵阇多祢(六)昵茂邸(七)昵茂企(八)阇罗婆罗车驮祢(九)宿佉波啼呢地奢(十)阿弥多由婆离(十一)阿弥多蛇伽婆昵呵隶(十二)阿弥多蛇波罗娑陀祢(十三)涅浮提(十四)阿迦舍昵浮陀(十五)阿迦舍昵提奢(十六)阿迦舍昵阇啼(十七)阿迦舍久舍离(十八)阿迦舍达奢尼(十九)阿迦舍提咃祢(二十)留波昵提奢(二十一)噜跛坦泥势(二十二)遮埵唎达摩波罗娑阿祢(二十三)遮唾唎阿利蛇娑帝蛇波罗娑陀祢(二十四)遮埵唎末伽婆那波罗娑陀祢(二十五)婆罗毗梨耶波罗娑陀祢(二十六)达摩呻他祢(二十七)久舍离(二十八)久舍罗昵提奢(二十九)久奢罗波罗啼咃祢(三十)佛陀久奢离(三十一)毗佛陀波罗波斯(三十二)达摩迦罗祢(三十三)昵专啼(三十四)昵浮提(三十五)毗摩离(三十六)毗罗阇(三十七)罗阇(三十八)罗斯(三十九)罗娑岐(四十)罗娑伽罗婆离(四十一)罗娑伽罗阿地咃祢(四十二)久舍离(四十三)波罗啼久舍离(四十四)毗久舍离(四十五)咃啼(四十六)修陀多至啼(四十七)修波罗舍多至啼(四十八)修波罗啼痴啼(四十九)修离(五十)修目企(五十一)达咩(五十二)达达啼(五十三)离婆(五十四)遮婆离(五十五)阿[少/兔]舍婆离(五十六)佛陀迦舍昵裘祢佛陀迦舍裘祢(五十七)娑婆呵(五十八)

此是阿弥陀鼓音声王大陀罗尼。若有比丘比丘尼。清信士女。常应至诚受持读诵。如说修行。行此持法当处闲寂。洗浴其身着新净衣。饮食白素。不啖酒肉及以五辛。常修梵行。以好香花。供养阿弥陀如来。及佛道场。大菩萨众。常应如是专心系念。发愿求生安乐世界。精勤不怠如其所愿。必得往生于彼佛世界。时阿弥陀佛。与诸大众坐宝莲花。其土丛林花果鲜敷。间错严饰。复有树王。香风馥扇出和雅音。纯说无上不思议法。复有妙香名曰光明。若干涂香亦是宝香。阿弥陀佛。于大宝花结加趺坐。有二菩萨。一名观世音。二名大势至。是二菩萨。侍立左右。无数菩萨周匝围绕于此众中。若能深信无狐疑者。必得往生阿弥陀国。其地真金。七宝莲花自然踊出。若有四众。受持读诵彼佛名号。乃至无有水火毒药刀杖之怖。亦复无有夜叉等怖。除有过去重罪业障。极至七生。必果所愿。佛说是阿弥陀鼓音声王陀罗尼时。无量众生皆悉发愿。志求生彼极乐世界。于时世尊赞言。善哉善哉。如汝所愿必得生彼。闻佛说已。天龙八部。欢喜踊跃作礼奉行

阿弥陀鼓音声王陀罗尼经


拔一切业障根本得生净土神咒(出小无量寿经)

    No. 368

拔一切业障根本得生净土神咒(出小无量寿经)

        刘宋天竺三藏求那跋陀罗奉　诏重译

南无阿弥多婆夜哆(多曷切一)他伽哆(都饿切二)夜哆地(途卖切三)夜他阿弥利(上声四)都婆毗(五)阿弥利哆(六)悉眈婆毗(七)阿弥利哆(八)毗迦兰谛(九)阿弥利哆(十)毗迦兰哆(十一)伽弥腻(十二)伽伽那(十三)枳多迦隶(十四)莎婆诃(十五)

若有善男子善女人。能诵此咒者。阿弥陀佛常住其顶日夜拥护。无令怨家而得其便。现世常得安隐。临命终时任运往生阿弥陀经不思议神力传(附隋录未详作者)昔长安僧睿法师。慧崇。僧显。慧通。近至后周。实禅师。景禅师。西河鸾法师等数百余人。并生西方。西河绰禅师等。因见鸾法师得生净土。各率有缘。专修净土之业。绰师又撰西方记验。名安乐集流行。又晋朝远法师。入卢山三十年不出。乃命同志。白黑有一百二十三人。立誓期于西方。凿山铭愿。至陈天嘉年。卢山珍禅师。于坐时见有数百余人。共乘七宝华舫往西方。珍禅师遂求附载。其船上人报云。法师虽讲得涅槃经亦大不可思议缘。法师未诵得阿弥陀经及咒。所以不得同去。法师遂废讲业。日夜专诵弥陀经及咒。计应满二万遍。未终四七日前。夜向四更有神人。从西方送一白银台来空中。明过于日。告云。法师寿终当乘此台往生阿弥陀国。故来相示令知定生。终时白黑咸闻空中如奏音乐。并闻异香。数月闻香气不歇。其夜峰顶寺僧众。咸见一谷内有数十炬火大如车轮。寻验古今。得生安乐世界者非一。多见化佛徒众来迎灵瑞。如传广明不可繁录。因珍禅师于此经有验故。略述此一条以悟来哲。助成往生之志。拔一切业障根本得生净土。神咒者乃宋元嘉末年。求那跋陀重奉制译。合计五十九字一十五句。龙树菩萨愿生安养。梦感此咒。耶舍三藏诵此咒。天平寺锈法师。从耶舍三藏口受此咒。其人云。经本外国不来。若欲受持咒法。嚼杨枝澡豆漱口然香。于佛像前胡跪合掌。日夜六时各诵三七遍。即灭四重五逆十恶谤方等罪。悉得灭除。现世所求皆得。不为恶鬼神所惑乱。若数满二十万遍。即感得菩提牙生。若至三十万遍即面见阿弥陀佛


称赞净土佛摄受经

    No. 367 [No. 366]

称赞净土佛摄受经

        大唐三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。在室罗筏住誓多林给孤独园。与大苾刍众千二百五十人俱。一切皆是尊宿声闻。众望所识。大阿罗汉。其名曰尊者舍利子。摩诃目犍连。摩诃迦叶。阿泥律陀。如是等诸大声闻而为上首。复与无量菩萨摩诃萨俱。一切皆住不退转位。无量功德众所庄严。其名曰妙吉祥菩萨。无能胜菩萨。常精进菩萨。不休息菩萨。如是等诸大菩萨而为上首。复有帝释大梵天王。堪忍界主。护世四王。如是上首。百千俱胝那庾多数诸天子众。及余世间无量天人。阿素洛等。为闻法故。俱来会坐

尔时世尊告舍利子。汝今知不。于是西方去此世界。过百千俱胝那庾多佛土。有佛世界名曰极乐。其中世尊名无量寿及无量光如来应正等觉。十号圆满。今现在彼安隐住持。为诸有情宣说甚深微妙之法。令得殊胜利益安乐

又舍利子。何因何缘。彼佛世界名为极乐。舍利子。由彼界中诸有情类无有一切身心忧苦。唯有无量清净喜乐。是故名为极乐世界。又舍利子。极乐世界净佛土中处处皆有七重行列妙宝栏楯七重行列宝多罗树。及有七重妙宝罗网。周匝围绕四宝庄严。金宝银宝。吠琉璃宝。颇胝迦宝。妙饰间绮。舍利子。彼佛土中有如是等众妙绮饰功德庄严。甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。处处皆有七妙宝池。八功德水弥满其中。何等名为八功德水。一者澄净。二者清冷。三者甘美。四者轻软。五者润泽。六者安和。七者饮时除饥渴等无量过患。八者饮已定能长养诸根四大。增益种种殊胜善根。多福众生常乐受用。是诸宝池底布金沙。四面周匝有四阶道。四宝庄严甚可爱乐。诸池周匝有妙宝树。间饰行列香气芬馥。七宝庄严甚可爱乐。言七宝者。一金。二银。三吠琉璃。四颇胝迦。五赤真珠。六阿湿摩揭拉婆宝。七牟娑落揭拉婆宝。是诸池中。常有种种杂色莲华。量如车轮。青形青显青光青影。黄形黄显黄光黄影。赤形赤显赤光赤影。白形白显白光白影。四形四显四光四影。舍利子。彼佛土中。有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。自然常有无量无边众妙伎乐。音曲和雅甚可爱乐。诸有情类闻斯妙音。诸恶烦恼悉皆消灭。无量善法渐次增长。速证无上正等菩提。舍利子。彼佛土中。有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。周遍大地真金合成。其触柔软香洁光明。无量无边妙宝间饰。舍利子。彼佛土中。有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。昼夜六时。常雨种种上妙天华。光泽香洁细软杂色。虽令见者身心适悦。而不贪着。增长有情无量无数不可思议殊胜功德。彼有情类昼夜六时。常持供养无量寿佛。每晨朝时持此天华。于一食顷。飞至他方无量世界。供养百千俱胝诸佛。于诸佛所。各以百千俱胝树花。持散供养。还至本处。游天住等。舍利子。彼佛土中。有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。常有种种奇妙可爱杂色众鸟。所谓鹅雁鹙鹭。鸿鹤孔雀。鹦鹉羯罗频迦。命命鸟等。如是众鸟。昼夜六时恒共集会。出和雅声。随其类音宣扬妙法。所谓甚深念住正断。神足根力。觉道支等。无量妙法。彼土众生闻是声已。各得念佛念法念僧。无量功德熏修其身。汝舍利子。于意云何。彼土众鸟。岂是傍生恶趣摄耶。勿作是见。所以者何。彼佛净土无三恶道。尚不闻有三恶趣名。何况有实罪业所招傍生众鸟。当知皆是无量寿佛变化所作。令其宣畅无量法音。作诸有情利益安乐。舍利子。彼佛土中有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。常有妙风。吹诸宝树及宝罗网。出微妙音。譬如百千俱胝天乐同时俱作。出微妙声甚可爱玩。如是彼土常有妙风。吹众宝树及宝罗网。击出种种微妙音声。说种种法。彼土众生闻是声已。起佛法僧念作意等无量功德。舍利子。彼佛土中有如是等众妙绮饰。功德庄严甚可爱乐。是故名为极乐世界

又舍利子极乐世界净佛土中。有如是等无量无边不可思议甚希有事。假使经于百千俱胝那庾多劫。以其无量百千俱胝那庾多舌。一一舌上出无量声。赞其功德亦不能尽。是故名为极乐世界

又舍利子。极乐世界净佛土中。佛有何缘名无量寿。舍利子。由彼如来及诸有情寿命无量无数大劫。由是缘故。彼土如来名无量寿。舍利子。无量寿佛证得阿耨多罗三藐三菩提已来。经十大劫。舍利子。何缘彼佛名无量光。舍利子。由彼如来恒放无量无边妙光。遍照一切十方佛土。施作佛事无有障碍。由是缘故。彼土如来名无量光。舍利子。彼佛净土成就如是功德庄严。甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。无量寿佛常有无量声闻弟子。一切皆是大阿罗汉。具足种种微妙功德。其量无边不可称数。舍利子。彼佛净土成就如是功德庄严。甚可爱乐。是故名为极乐世界

又舍利子。极乐世界净佛土中。无量寿佛常有无量菩萨弟子。一切皆是一生所系。具足种种微妙功德。其量无边不可称数。假使经于无数量劫。赞其功德终不能尽。舍利子。彼佛土中。成就如是功德庄严。甚可爱乐。是故名为极乐世界

又舍利子。若诸有情生彼土者。皆不退转。必不复堕诸险恶趣边地下贱蔑戾车中。常游诸佛清净国土。殊胜行愿念念增进。决定当证阿耨多罗三藐三菩提。舍利子。彼佛土中。成就如是功德庄严。甚可爱乐。是故名为极乐世界

又舍利子。若诸有情闻彼西方无量寿佛清净佛土无量功德众所庄严。皆应发愿生彼佛土。所以者何。若生彼土。得与如是无量功德众所庄严。诸大士等同一集会。受用如是无量功德。众所庄严清净佛土。大乘法乐常无退转。无量行愿念念增进。速证无上正等菩提故。舍利子。生彼佛土诸有情类。成就无量无边功德。非少善根诸有情类当得往生无量寿佛极乐世界清净佛土

又舍利子。若有净信诸善男子或善女人。得闻如是无量寿佛无量无边不可思议功德名号极乐世界功德庄严。闻已思惟。若一日夜。或二或三。或四或五。或六或七。系念不乱。是善男子或善女人。临命终时。无量寿佛与其无量声闻弟子菩萨众俱。前后围绕来住其前。慈悲加祐令心不乱。既舍命已随佛众会。生无量寿极乐世界清净佛土

又舍利子。我观如是利益安乐大事因缘。说诚谛语。若有净信诸善男子或善女人。得闻如是无量寿佛不可思议功德名号极乐世界净佛土者。一切皆应信受发愿。如说修行生彼佛土

又舍利子。如我今者称扬赞叹无量寿佛无量无边不可思议佛土功德。如是东方亦有现在不动如来。山幢如来。大山如来。山光如来。妙幢如来。如是等佛如殑伽沙住在东方。自佛净土各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是南方亦有现在日月光如来。名称光如来。大光蕴如来。迷卢光如来。无边精进如来。如是等佛如殑伽沙住在南方。自佛净土各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是西方亦有现在无量寿如来。无量蕴如来。无量光如来。无量幢如来。大自在如来。大光如来。光焰如来。大宝幢如来。放光如来。如是等佛如殑伽沙住在西方。自佛净土各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是北方亦有现在无量光严通达觉慧如来。无量天鼓震大妙音如来。大蕴如来。光网如来。娑罗帝王如来。如是等佛如殑伽沙住在北方。自佛净土各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是下方亦有现在示现一切妙法正理常放火王胜德光明如来。师子如来。名称如来。誉光如来。正法如来。妙法如来。法幢如来。功德友如来。功德号如来。如是等佛如殑伽沙。住在下方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是上方。亦有现在梵音如来。宿王如来。香光如来。如红莲华胜德如来。示现一切义利如来。如是等佛如殑伽沙。住在上方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是东南方。亦有现在最上广大云雷音王如来。如是等佛如殑伽沙。住东南方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是西南方。亦有现在最上日光名称功德如来。如是等佛如殑伽沙。住西南方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是西北方。亦有现在无量功德火王光明如来。如是等佛如殑伽沙。住西北方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。如是东北方。亦有现在无数百千俱胝广慧如来。如是等佛如殑伽沙。住东北方自佛净土。各各示现广长舌相。遍覆三千大千世界。周匝围绕。说诚谛言。汝等有情。皆应信受如是称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。何缘此经。名为称赞不可思议佛土功德一切诸佛摄受法门。舍利子。由此经中。称扬赞叹无量寿佛极乐世界不可思议佛土功德。及十方面诸佛世尊。为欲方便利益安乐诸有情故。各住本土。现大神变。说诚谛言。劝诸有情信受此法。是故此经。名为称赞不可思议佛土功德一切诸佛摄受法门

又舍利子。若善男子或善女人。或已得闻。或当得闻。或今得闻。闻是经已深生信解。生信解已。必为如是住十方面。十殑伽沙诸佛世尊之所摄受。如说行者。一切定于阿耨多罗三藐三菩提。得不退转。一切定生无量寿佛极乐世界清净佛土。是故舍利子。汝等有情。一切皆应信受领解。我及十方佛世尊语。当勤精进如说修行。勿生疑虑

又舍利子。若善男子或善女人。于无量寿极乐世界清净佛土。功德庄严。若已发愿。若当发愿。若今发愿。必为如是住十方面。十殑伽沙诸佛世尊之所摄受。如说行者。一切定于阿耨多罗三藐三菩提。得不退转。一切定生无量寿佛极乐世界清净佛土。是故舍利子。若有净信诸善男子或善女人。一切皆应于无量寿极乐世界清净佛土。深心信解。发愿往生。勿行放逸

又舍利子。如我今者称扬赞叹无量寿佛极乐世界不可思议佛土功德。彼十方面诸佛世尊。亦称赞我不可思议无边功德。皆作是言。甚奇希有。释迦寂静。释迦法王如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛世尊。乃能于是堪忍世界。五浊恶时。所谓劫浊。诸有情浊。诸烦恼浊。见浊。命浊。于中证得阿耨多罗三藐三菩提。为欲方便利益安乐诸有情故。说是世间极难信法。是故舍利子。当知我今于此杂染堪忍世界五浊恶时。证得阿耨多罗三藐三菩提。为欲方便利益安乐诸有情故。说是世间极难信法。甚为希有不可思议

又舍利子。于此杂染堪忍世界五浊恶时。若有净信诸善男子或善女人。闻说如是一切世间极难信法。能生信解。受持演说。如教修行当知是人。甚为希有。无量佛所曾种善根。是人命终。定生西方极乐世界。受用种种功德庄严清净佛土大乘法乐。日夜六时。亲近供养无量寿佛。游历十方供养诸佛。于诸佛所闻法受记。福慧资粮疾得圆满。速证无上正等菩提。时薄伽梵说是经已。尊者舍利子等。诸大声闻。及诸菩萨摩诃萨众。无量天人阿素洛等。一切大众闻佛所说。皆大欢喜信受奉行

称赞净土佛摄受经


大阿弥陀佛经

    No. 364 [Nos. 360-363]

    大阿弥陀佛经序

大藏经中。有十余经。言阿弥陀佛济度众生。其间四经本为一种。译者不同。故有四名。一名无量清净平等觉经。乃后汉月支三藏支娄加谶译。二曰无量寿经。乃曹魏康僧铠译。三曰阿弥陀过度人道经。乃吴月支支谦译。四曰无量寿庄严经。乃本朝西天三藏法贤译。其大略虽同。然其中甚有差互。若不观省者。又其文或失于太繁。而使人厌观。或失于太严。而丧其本真。或其文适中。而其意则失之。由是释迦文佛所以说经。阿弥陀佛所以度人之旨。紊而无序。郁而不章。予深惜之。故熟读而精考。叙为一经。盖欲复其本也。其校正之法。若言一事。抂此本为安。彼本为杌陧。则取其安者。或此本为要。彼本为泛滥。则取其要者。或此本为近。彼本为迂。则取其近者。或彼本有之。而此本阙。则取其所有。或彼本彰明。而此本隐晦。则取其明者。大概乃取其所优。去其所劣。又有其文碎杂而失统。错乱而不伦者。则用其意。以修其辞。删其重以畅其义。其或可疑者。则阙焉而不敢取。若此之类。皆欲订正圣言。发明本旨。使不惑于四种之异。而知其指归也。又各从其事类。析为五十六分。欲观者易见。而喜于读诵。庶几流传之广。而一切众生。皆受济度也。予每校正。必祷于观音菩萨求冥助。以开悟识性。使无舛误。始末三年而后毕。既毕乃拜而自喜。目之曰大阿弥陀经。盖佛与舍利弗说者。亦阿弥陀经。彼则其文少。故此言大以别之。然佛说经。非若吾圣人所说也。吾圣人所说。或深其文而丛其意。使人索之而愈见其多。或简其文而晦其意。使人思而后得。佛则不然。必欲详陈曲布。使人人可晓。虽至愚下者。亦知其意焉。然而有辞直而意愈深者。经所谓须信佛语深是也。切不可以轻其辞而忽其意。诏兴壬午秋。国学进士龙舒王日休谨序

礼祝仪式

诵净口业真言　唵修利修利摩诃修利修修利娑婆诃

次诵五净真言　唵尾鼠提娑婆诃

净身器神咒　唵秫殿都戌陀那耶娑婆诃

次向西顶礼祝云

弟子(某甲)谨为尽虚空界一切众生。归依尽虚空界一切诸佛。一切正法一切圣僧。西方极乐世界阿弥陀佛。观世音菩萨。大势至菩萨。一切菩萨。声闻诸上善人。(某甲)今为尽虚空界一切众生。持诵大阿弥陀经。及赞佛忏罪回向发愿。愿如此等众生各各自诵经。赞佛忏罪回向发愿。愿尽拔济生于极乐世界。乃念大慈菩萨。赞佛忏罪回向发愿。偈云

  十方三世佛　　阿弥陀第一
  九品度众生　　威德无穷极
  我今大归依　　忏悔三业罪
  凡有诸善福　　至心用回向
  愿同念佛人　　尽生极乐国
  见佛了生死　　如佛度一切

如为荐亡。或禳灾或保安。则随意祝愿不须如前祈祷。亦须诵真言。先归依三宝及西方四圣。然后祝愿。若为自身往生。则宜一一如前。其功德甚大矣

佛说大阿弥陀经卷上

        国学进士龙舒王日休校辑

    法会大众分第一

如是我闻一时佛在王舍国灵鹫山中。与大弟子众千二百五十人俱。一切大圣神通已达。其名曰尊者了本际。尊者正愿。尊者正语。尊者大号。尊者仁贤。尊者离垢。尊者名闻。尊者善实。尊者具足。尊者阿难。若此皆上首者。又大乘众菩萨。普贤菩萨。妙德菩萨。慈氏菩萨等。此贤劫中一切菩萨。又贤护等十六正士。善思议菩萨。信慧菩萨。空无菩萨。神通华菩萨。皆尊普贤大士之德。具诸菩萨无量行愿。安住一切功德之法。如是等菩萨大士。一时来会

    阿难发问分第二

尔时世尊。容色光丽异于他日。尊者阿难。即从座起偏袒右肩。长跪合掌而白佛言。今日世尊诸根悦豫。姿色清净光显巍巍。如镜明莹畅彻表里。自我侍佛以来。未尝获睹威容有如今日。岂非念过去诸佛。或现在未来诸佛。故致然耶。佛言善哉。阿难。有诸天教汝来问。汝自问耶。阿难言。我自以所见而发此问。佛言。汝所问者。胜于供养一天下声闻缘觉。及布施诸天人民。下至蜎飞蠕动之类。虽至累劫。尚百千万亿倍。不可以及。所以者何。盖诸天帝王人民。下至蜎飞蠕动之类。皆因汝所问而得度脱之道。阿难。如世间有优昙钵华。虽有其实不见其华。有佛出世华然后有。佛难值遇亦如此华。今我出世。汝善知吾意。特为发问诚不妄侍佛矣。汝当谛听。吾为汝说。对言诚欲闻之

    五十三佛分第三

佛言。前已过去劫。大众多不可计。无边幅不可议。尔时有佛出世。名定光如来。教化度脱无量众生。皆令得道乃取灭度。次有佛名光远。次有佛名月光。次有佛名栴檀香。次有佛名善山王。次有佛名须弥天冠。次有佛名须弥等曜。次有佛名月色。次有佛名正念。次有佛名离垢。次有佛名无著。次有佛名龙天。次有佛名夜光。次有佛名安明顶。次有佛名不动地。次有佛名琉璃妙花。次有佛名琉璃金色。次有佛名金藏。次有佛名炎光。次有佛名炎根。次有佛名地种。次有佛名月像。次有佛名日音。次有佛名解脱华。次有佛名庄严光明。次有佛名海觉神通。次有佛名水光。次有佛名大香。次有佛名离尘垢。次有佛名舍厌意。次有佛名宝炎。次有佛名妙顶。次有佛名勇力。次有佛名功德持慧。次有佛名蔽日月光。次有佛名日月琉璃光。次有佛名无上琉璃光。次有佛名最上首。次有佛名菩提华。次有佛名月明。次有佛名日光。次有佛名华色王。次有佛名水月光。次有佛名除痴冥。次有佛名度盖行。次有佛名净信。次有佛名善宿。次有佛名威神。次有佛名法慧。次有佛名鸾音。次有佛名师子音。次有佛名龙音。次有佛名处世。如此诸佛皆已过去

    法藏本因分第四

佛言。次有佛名世自在王如来。应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。十号具足。在世教化四十二劫。尔时有大国王。闻佛说法喜悦开悟。即弃王位往作沙门。号法藏比丘。高才智慧勇猛无能及者。诣彼佛所稽首礼足。右绕三匝长跪合掌。以偈赞佛

  如来妙色相　　世间无等伦
  远胜日摩尼　　火月清净水
  威神无有极　　名声震十方
  皆由三昧力　　精进成智慧
  持觉若溟海　　深广无涯底
  无明与贪恚　　冰释已无余
  从是超世间　　叹仰不能已
  端如好树华　　莫不爱乐者
  处处人民见　　一切皆欢喜
  布施及净戒　　忍辱并精进
  禅定大智慧　　吾誓得此事
  一切诸恐惧　　普为获大安
  过度诸生死　　无不解脱者
  我至作佛时　　种种如法王
  假使恒沙数　　诸佛悉供养
  不如求正觉　　坚勇必成就
  能使无量刹　　光明普照耀
  济度越恒沙　　威德谁可量
  我刹及庄严　　华好独超卓
  凡欲求生者　　清净安以乐
  度脱永无穷　　幸佛作明证
  发愿既如是　　力行无懈怠
  虽居苦毒中　　忍之终不悔

    大愿问佛分第五

佛言。尔时法藏比丘说此偈已。复白世自在王佛言。世尊我发无上菩提之心。愿作佛时。于十方无央数佛中为最。智慧勇猛。顶中光明照耀十方。无有穷极。所居刹土自然七宝极明丽温柔。我化度名号。皆闻于十方无央数世界。莫有不闻知者。诸无央数诸天人民。以至蜎飞蠕动之类。来生我刹者。悉皆菩萨声闻。其数不可穷尽。比诸佛世界悉皆胜之如是者宁可得否。时世自在王佛。知其智识高明心愿广大。即为说言。譬如大海一人斗量。历劫不止尚可见底。况人。至心求道。精进不止。何求不得何愿不遂时法藏比丘。闻佛所说则大欢喜。佛乃选择二千一百万佛刹中。诸天人民之善恶国土之粗妙。随其心愿悉令显现。法藏即一其心。遂得天眼莫不彻见

    四十八愿分第六

佛言。尔时法藏比丘。乃往一静处其心寂然。俱无所著默坐思惟。摄取彼佛刹清净之行。如彼修持。复诣佛所而白佛言。世尊。我已摄取二千一百万佛刹。所以庄严国土清净之行。愿有[敲-高+尃]陈惟佛听察。彼佛告言。善哉汝可具说。诸菩萨众闻汝志愿因以警策。亦能于诸佛刹修习庄严。法藏白言。第一愿我作佛时。我刹中无地狱饿鬼禽畜。以至蜎飞蠕动之类。不得是愿终不作佛。第二愿。我作佛时。我刹中无妇女。无央数世界诸天人民。以至蜎飞蠕动之类。来生我刹者。皆于七宝水池莲华中化生。不得是愿终不作佛。第三愿。我作佛时。我刹中人欲食时。七宝钵中百味饮食。化现在前。食已器用自然化去。不得是愿终不作佛。第四愿。我作佛时。我刹中人。所欲衣服随念即至。不假裁缝捣染浣濯。不得是愿终不作佛。第五愿。我作佛时。我刹中自地以上至于虚空。皆有宅宇宫殿楼阁池流花树。悉以无量杂宝百千种香而共合成。严饰奇妙殊胜超绝。其香普熏十方世界。众生闻是香者皆修佛行。不得是愿终不作佛。第六愿。我作佛时。我刹中人。皆心相爱敬无相憎嫉。不得是愿终不作佛。第七愿。我作佛时。我刹中人。尽无[泳-永+(炙-火+(午/一))]泆嗔怒愚痴之心。不得是愿终不作佛。第八愿。我作佛时。我刹中人皆同一善心无惑他念。其所欲言皆豫相知意。不得是愿终不作佛。第九愿。我作佛时。我刹中人。皆不闻不善之名。况有其实。不得是愿终不作佛。第十愿。我作佛时。我刹中人。知身如幻无贪着心。不得是愿终不作佛。第十一愿。我作佛时我刹中虽有诸天与世人之异。而其形容皆一类金色。面目端正净好无复丑异。不得是愿终不作佛。第十二愿。我作佛时。假令十方无央数世界诸天人民。以至蜎飞蠕动之类。皆得为人。皆作缘觉声闻。皆坐禅一心。共欲计数我年寿。几千亿万劫无有能知者。不得是愿终不作佛。第十三愿。我作佛时。假令十方各千亿世界。有诸天人民。以至蜎飞蠕动之类。皆得为人。皆作缘觉声闻。皆坐禅一心。共欲计数我刹中人数有几千亿万无有能知者。不得是愿终不作佛。第十四愿。我作佛时。我刹中人寿命皆无央数劫。无有能计知其数者。不得是愿终不作佛。第十五愿。我作佛时。我刹中人。所受快乐。一如漏尽比丘。不得是愿终不作佛。第十六愿。我作佛时。我刹中人住正信位。离颠倒想远离分别。诸根寂静所止尽般泥洹。不得是愿终不作佛。第十七愿。我作佛时。说经行道十倍于诸佛。不得是愿终不作佛。第十八愿。我作佛时。我刹中人尽通宿命。知百千亿那由他劫事。不得是愿终不作佛。第十九愿。我作佛时。我刹中人尽得天眼。见百千亿那由他世界。不得是愿终不作佛。第二十愿。我作佛时。我刹中人尽得天耳。闻百千亿那由他诸佛说法。悉能受持。不得是愿终不作佛。第二十一愿。我作佛时。我刹中人得他心智。知百千亿那由他世界众生心念。不得是愿终不作佛。第二十二愿。我作佛时。我刹中人尽得神足。于一念顷。能超过百千亿那由他世界。不得是愿终不作佛。第二十三愿。我作佛时我名号闻于十方无央数世界。诸佛各于大众中。称我功德及国土之胜。诸天人民以至蜎飞蠕动之类。闻我名号乃慈心喜悦者。皆令来生我刹。不得是愿终不作佛。第二十四愿。我作佛时。我顶中光明绝妙。胜如日月之明。百千亿万倍。不得是愿终不作佛。第二十五愿。我作佛时。光明照诸无央数天下幽冥之处。皆当大明。诸天人民以至蜎飞蠕动之类。见我光明莫不慈心作善。皆令来生我国。不得是愿终不作佛。第二十六愿。我作佛时。十方无央数世界诸天人民。以至蜎飞蠕动之类。蒙我光明触其身者。身心慈和过诸天人。不得是愿终不作佛。第二十七愿。我作佛时。十方无央数世界诸天人民。有发菩提心。奉持斋戒。行六波罗蜜。修诸功德。至心发愿欲生我刹。临寿终时我与大众。现其人前引至来生。作不退转地菩萨。不得是愿终不作佛。第二十八愿。我作佛时。十方无央数世界诸天人民。闻我名号。烧香散花然灯悬缯。饭食沙门起立塔寺。斋戒清净益作诸善。一心系念于我。虽止于一昼夜不绝。亦必生我刹。不得是愿终不作佛。第二十九愿。我作佛时。十方无央数世界诸天人民。至心信乐欲生我刹。十声念我名号必遂来生。惟除五逆诽谤正法。不得是愿终不作佛。第三十愿。我作佛时。十方无央数世界诸天人民。以至蜎飞蠕动之类。前世作恶。闻我名号即忏悔为善。奉持经戒愿生我刹。寿终皆不经三恶道径遂来生。一切所欲无不如意。不得是愿终不作佛。第三十一愿。我作佛时。十方无央数世界诸天人民。闻我名号。五体投地稽首作礼。喜悦信乐修菩萨行。诸天世人莫不致敬。不得是愿终不作佛。第三十二愿。我作佛时。十方无央数世界有女人。闻我名号喜悦信乐。发菩提心厌恶女身。寿终之后其身不复为女。不得是愿终不作佛。第三十三愿。我作佛时。凡生我刹者一生遂补佛处。惟除本愿欲往他方。设化众生修菩萨行。供养诸佛即自在往生。我以威神之力令彼教化一切众生皆发信心。修菩提行。普贤行。寂灭行。净梵行。最胜行。及一切善行。不得是愿终不作佛。第三十四愿。我作佛时。我刹中人欲生他方者。如其所愿不复坠于三恶道。不得是愿终不作佛。第三十五愿。我作佛时。刹中菩萨以香华旛盖真珠缨络种种供具。欲往无量世界供养诸佛。一食之顷即可遍至。不得是愿终不作佛。第三十六愿。我作佛时。刹中菩萨欲万种之物。供养十方无央数佛。即自在前供养既遍。是日未午即还我刹。不得是愿终不作佛。第三十七愿。我作佛时。刹中菩萨受持经法。讽诵宣说。必得辩才智慧。不得是愿终不作佛。第三十八愿。我作佛时。刹中菩萨能演说一切法。其智慧辩才不可限量。不得是愿终不作佛。第三十九愿。我作佛时。刹中菩萨得金刚那罗延力。其身皆紫磨金色。具三十二相八十种好。说经行道无异于诸佛。不得是愿终不作佛。第四十愿。我作佛时。刹中清净照见十方无量世界。菩萨欲于宝树中。见十方一切严净佛刹。即时应现犹如明镜睹其面相。不得是愿终不作佛。第四十一愿。我作佛时。刹中菩萨虽少功德者。亦能知见我道场树高四千由旬。不得是愿终不作佛。第四十二愿。我作佛时。刹中诸天世人及一切万物。皆严净光丽形色殊特。穷微极妙无能称量者。众生虽得天眼不能辩其名数。不得是愿终不作佛。第四十三愿。我作佛时。我刹中人随其志愿。所欲闻法皆自然得闻。不得是愿终不作佛。第四十四愿。我作佛时。刹中菩萨声闻皆智慧成神。顶中皆有光明语音鸿畅。说经行道无异于诸佛。不得是愿终不作佛。第四十五愿。我作佛时。他方世界诸菩萨。闻我名号归依精进。皆逮得清净解脱三昧。住是三昧一发意顷。供养不可思议诸佛。而不失定意。不得是愿终不作佛。第四十六愿。我作佛时。他方世界诸菩萨。闻我名号归依精进。皆逮得普等三昧。至于成佛。常见无量不可思议一切诸佛。不得是愿终不作佛。第四十七愿。我作佛时。他方世界诸菩萨。闻我名号归依精进。即得至不退转地。不得是愿终不作佛。第四十八愿。我作佛时。他方世界诸菩萨。闻我名号归依精进。即得至第一忍第二忍第三法忍。于诸佛法永不退转。不得是愿终不作佛

    愿后说偈分第七

佛言。尔时法藏比丘发此愿已。复说偈言

  我今对佛前　　特发诚实愿
  如获十力身　　威德无能胜
  复为大国王　　富豪而自在
  常施诸财宝　　利乐于贫苦
  尽令诸众生　　长夜无忧恼
  发生众善根　　长养菩提果
  我至成佛时　　名声超十方
  人天欣得闻　　俱来生我刹
  我以智慧光　　广照无央界
  除灭诸有情　　贪嗔烦恼暗
  地狱鬼畜生　　亦生我刹中
  一切来生者　　修习清净行
  如佛金色身　　妙相悉圆满
  还以大慈心　　普济诸沉溺
  我于未来世　　当作天人师
  百亿世界中　　说法师子吼
  一切闻音者　　解悟复圆明
  又如过去佛　　所生慈愍行
  度脱诸有情　　已无量无边
  我行亦如斯　　咸使登觉岸
  此愿若克果　　大千应震动
  虚空诸天神　　必雨珍妙华

    初修善行分第八

佛言。尔时法藏比丘。于彼佛所。诸天魔梵龙神八部大众之中。发斯弘誓。应时大地震动。天雨妙华以散其上。空中赞言。决定成佛。于是法藏住真实慧。勇猛精进。修习无量功德。以庄严其国。是故入三摩地。历大阿僧祇劫。修菩萨行。不生欲想嗔想痴想。不生欲觉嗔觉痴觉。不着色声香味诸法。忍力成就不计众苦。但乐忆念过去诸佛所修善根。行寂静行。远离虚妄坚守诚正。常以和颜爱语饶益众生。于佛法僧信重恭敬依真谛门植众德本。善护口业不讥他过。善护身业不失律仪。善护意业清净无染。恒以布施持戒忍辱精进禅定智慧。利乐众生。令诸众生功德成就。远离粗言。免自害害彼。免彼此俱害。修习善语自利利人。致人我兼利。复教化众生修行六度。于一切法而得自在。了空无相无愿无为无生无灭。轨范具足善根圆满。堕其生处在意所欲。有无量宝藏自然发现。以此施惠众生令生欢喜。以行教化。致无量无数众生发无上菩提之心。如是善行无量无边说不能尽

    亲近诸佛分第九

佛言。法藏比丘行菩萨行时。于诸佛所尊重恭敬。承事供养未尝间断。为四大天王诣佛所。恭敬礼拜承事供养。为忉利天王诣佛所。恭敬礼拜承事供养。为夜摩天王。兜率天王。化乐天王。他化自在天王。乃至大梵天王等诣佛所。恭敬礼拜承事供养。其次处阎浮提。为转轮王受灌顶位。及大臣官族等诣佛所。恭敬礼拜承事供养。为刹帝利婆罗门等诣佛所。恭敬礼拜承事供养。如是无量无数百千万亿劫。亲近诸佛植众德本。以成就所愿

    愿成作佛分第十

佛言。法藏比丘行菩萨行时。容体端严。三十二相八十种好悉皆具足。口中常出栴檀之香。身诸毛孔出优钵罗华香。其香普熏无量无边不可思议那由他由旬。众生闻此香者。皆发无上菩提之心。又手中恒出一切衣服。一切饮食。一切幢旛宝盖。一切音乐。及一切最上所须之物。利乐一切众生令归佛道。如是积功累德。无量无数百千万亿劫。功德圆满威神炽盛。方得成就所愿而入佛位

    蜎蠕亦度分第十一

阿难白言。法藏比丘为已成佛而取灭度。为未成佛为今现在。佛言。彼佛如来。来无所来。去无所去。无生无灭。非过去现在未来。但以酬其志愿度一切众生。现在西方。去此百万世界。其世界名曰极乐。其佛号阿弥陀。成佛以来于今十劫。又在十方世界。教化无央数诸天人民。以至蜎飞蠕动之类。莫不得过度解脱者

    光明独胜分第十二

佛言。阿弥陀佛光明最为远着。诸佛光明皆所不及。十方无央数佛。其顶中光明有照一里者。有照二里者。有照三里者。如是展转渐远。有至于照千二百万里。复有佛顶中光明照一世界者。有照二世界者。有照三世界者。如是展转渐远。有至于照二百万世界者。惟阿弥陀佛顶中光明。照千万世界无有穷极。诸佛光明所以有远近者何以故。初为菩萨时。愿力功德各有大小。至期作佛皆随所得。是故光明亦从而异。若威神自在随意所作。不必豫计则无不同。阿弥陀佛愿力无边功德超绝故。比诸佛光明特为殊胜

    十三佛号分第十三

佛言。阿弥陀佛光明。明丽快甚绝殊无极。胜于日月之明千万亿倍。而为诸佛光明之王。故号无量寿佛。亦号无量光佛。无边光佛。无碍光佛。无对光佛。炎王光佛。清净光佛。欢喜光佛。智慧光佛。不断光佛。难思光佛。难称光佛。超日月光佛。其光明所照无央数天下。幽冥之处皆常大明。诸天人民禽兽蜎飞蠕动之类。见此光明莫不喜悦而生慈心。其淫泆嗔怒愚痴者。见此光明莫不迁善。地狱饿鬼畜生。考掠痛苦之处。见此光明无复苦恼。命终之后皆得解脱。不独我今称赞阿弥陀佛光明。十方无央数佛菩萨缘觉声闻之众。悉皆称赞亦复如是。若有众生。闻此光明威神功德。日夜归命称赞不已。随其志愿必生其刹。复为诸菩萨声闻所共称赞。当亦如是。我说阿弥陀佛光明威神巍巍殊妙。昼夜一劫尚未能尽。今为汝等略言之耳

    阿阇世王分第十四

尔时阿阇世王太子与五百长者子。各持一金华盖。前以献佛却坐一面。闻说阿弥陀佛功德光明皆大欢喜。其心愿言。我等后作佛时。皆如阿弥陀佛。佛即知之。告诸比丘言。阿阇世王太子与五百长者子。后无央数劫皆当作佛。如阿弥陀佛。此等行菩萨道已。无央数劫。皆各供养四百亿佛。今复供养于我。往昔迦叶佛时。皆常为我弟子。今又至此是复会遇也。时诸比丘闻是语已。莫不喜悦恭敬赞叹

    地平气和分第十五

佛言。阿弥陀佛刹中皆自然七宝。所谓黄金白银水晶琉璃珊瑚琥珀砗磲其体性温柔。以是七宝相间为地。或纯以一宝为地。光色照耀奇妙清净。超越十方一切世界。其国恢廓旷荡不可穷尽。地皆平正无须弥山及金刚围一切诸山。亦无大海小海。及坑坎井谷。亦无幽暗之所。无地狱饿鬼众生禽虫。以至蜎飞蠕动之类。无阿须伦及诸龙鬼神。亦无雨露惟有自然流泉。亦无寒暑气象。常春清快明丽不可具言。有万种自然之物。如百味饮食。意有所欲悉现在前。意若不用自然化去。随其所念无不得之。此娑婆世界。有他化自在天。其中天人一切所须自然化现。以比于此佛刹中自然之物。犹万亿倍不可以及

    讲堂宅宇分第十六

佛言。阿弥陀佛讲堂精舍。皆自然七宝相间而成。复有七宝以为楼观栏楯。复以七宝为之缨络悬饰其侧。复以白珠明月珠摩尼珠。为之交络遍覆其上。殊特妙好清净光辉不可胜言。其余菩萨声闻所居宫宇。亦复如是。彼诸天及世人。衣服饮食华香缨络。伞盖幢旛微妙音乐。随意而现。所居宫宇楼阁。称其形色高下大小。或以一宝二宝乃至无量众宝。悉化现而成。然宫宇有随意高大浮于空中若云气者。有不能随意高大。止在地上如世间者。其故非他。能随意者。乃前世求道时慈心精进。益作诸善德厚所致。不能随意者。乃前世求道时不慈心精进。作善微鲜德薄所致。若衣服饮食则皆平等。惟宫宇不同。所以别进有勤堕。德有大小示众见之。此讲堂宫宇。初无作者。亦无所从来。以此佛愿大德重。自然化生

    宝池大小分第十七

佛言。阿弥陀佛刹中讲堂宫宇。胜于此世界中第六天上天帝所居。百千万倍终不可及。其内外复有自然流泉及诸池沼。与自然七宝俱生。有纯一宝池者。其底沙亦以一宝。若黄金池者底白银沙。水晶池者底琉璃沙。珊瑚池者底琥珀沙。有二宝为一池者。其底沙亦以二宝。若黄金白银池者。底沙则以水晶琉璃。若水晶琉璃池者。底沙则以珊瑚琥珀。若珊瑚琥珀池者。底沙则以砗磲玛瑙。若三宝四宝以至七宝。共为一池则底沙亦如是。此诸宝池有方四十里者。有方五十里者。有方六十里者。如是展转渐大。以至于方二万四百八十里若大海。然是诸池者。皆菩萨声闻诸上善人生长之所。有时浴于其间。若彼佛池其方倍此。皆七宝相间而成白珠明月珠摩尼珠为之底沙。是诸池者。皆八功德水湛然盈满。清净香洁味如甘露。其间复有百种异华。枝皆千叶。光色既异。香气亦异芬芳馥郁不可胜言

    莲华化生分第十八

佛言。十方无央数世界诸天人民。以至蜎飞蠕动之类。往生阿弥陀佛刹者。皆于七宝池莲华中化生。自然长大亦无乳养之者。皆食自然之食。其容貌形色端正净好。固非世人可比。亦非天人可比。皆受自然清虚之身无极之寿

    [句-口+止]者比类分第十九

佛言。譬如[句-口+止]者在帝王之侧。相容仪宁可类否。阿难答言。[句-口+止]者在帝王之侧。羸陋丑恶无以为喻。百千万倍不可以及。所以然者。皆坐前世不植德本。积财不施富有益悭。但欲唐得贪求无厌。不信修善得福益作诸恶。如是寿终堕于恶趣。受诸长苦。得出为人下贱丑弊示众见之。所以帝王人中尊贵。皆由宿世积德所致。慈惠温良博施兼济。损已利物无所违争。是以寿终应生天上享其福乐。余庆犹存遂生王家。自然尊贵仪容端正。众所敬事。美衣珍膳随心服御。自非宿福何以能然。佛言。汝言是矣。若言形相威光。帝王虽人中尊贵。比转轮圣王。犹如鄙陋若彼[句-口+止]者在帝王之侧。转轮圣王天下第一。比忉利天王。又百千万倍不可以及。忉利天王比第六天王。又百千万倍不可以及。第六天王。比阿弥陀佛刹中诸菩萨声闻诸上善人。又百千万倍不可以及

    澡雪形体分第二十

佛言。阿弥陀佛刹中。诸菩萨声闻诸上善人。若入七宝池中澡雪形体。意欲令水没足水即没足。欲令至膝水即至膝。欲令至腰至腋。以至于颈。水亦如是。欲淋灌其身悉如其意。欲令其水如初。即亦如初。调和冷暖无不顺适。开神悦体涤荡情虑。清明澄洁莹若无形。既出浴已。各坐于一莲华之上。自然微风徐动吹诸宝树。或作音乐。或作法音。吹诸宝华皆成异香。散诸菩萨声闻大众之上。华堕地者积厚四寸。极目明丽芳香无比。及至小萎自然乱风吹去。诸菩萨声闻大众。有欲闻法音者。有欲闻音乐者。有欲闻华香者。有皆不欲闻者。其欲闻者辄独闻之。不欲闻者寂无所闻。各适其意无所违忤。其为快乐常得自然

    澡毕进业分第二十一

佛言。饶皆浴已各往修进。有在地讲经者。有在地诵经者。有在地自说经者。有在地口授经者。有在地听经者。有在地念经者。有在地思道者。有在地坐禅一心者。有在地经行者。仍有在虚空中讲经者。在虚空中诵经者。在虚空中自说经者。在虚空中口授经者。在虚空中听经者。在虚空中念经者。在虚空中思道者。在虚空中坐禅一心者。在虚空中经行者。其间有未得须陀洹者。因是得须陀洹。未得斯陀含者。因是得斯陀含。未得阿那含者。得阿那含。未得阿罗汉者。得阿罗汉。有未得不退转地菩萨者。乃得不退转地菩萨。各随其质而有所得。莫不欣然适意而悦

佛说大阿弥陀经卷上佛说大阿弥陀经卷下

        国学进士龙舒王日休校辑

    池流法音分第二十二

佛言。诸宝池中其水转相灌注。不迟不疾波扬无量。自然妙声或作说佛声。或作说法声。或作说僧声。或说寂静声。说空无我声。说大慈悲声。说波罗蜜声。说十力无畏不共法声。说诸通慧声。说无所作声。说不起灭声。说无上忍声。乃至说甘露灌顶一切妙法。如是等声。称其所欲莫不闻者。喜悦无量发清净心无诸分别。正直平等成熟善根。永不退于无上菩提。于彼世界。不复闻于地狱饿鬼畜生夜叉。杀生偷盗斗诤恶口两舌。如是等一切恶声。闻且绝无况有其实。但有自然清净之音。自然快乐之事。是故其刹名曰极乐

    池岸花树分第二十三

佛言。诸宝池岸上。有无数栴檀香树。吉祥果树。花果恒芳香气流布。又有天优钵罗华。钵昙摩华。拘牟头华。分陀利华。杂色光茂弥覆水上。复有七种宝树。其纯一宝树者。根茎枝叶花果。皆以一宝。二宝为一树者。根茎枝叶花果。间以二宝。三宝为一树者。根茎枝叶花果。间以三宝。四宝为一树者。根茎枝叶。各以一宝。其华与果同于根茎。五宝为一树者。根茎枝叶花。各以一宝。果则同于其根。六宝为一树者。根茎枝叶花果。各以一宝。七宝为一树者。亦复如是。惟加其节益用一宝。如是诸树种种各自异行。行行相植。茎茎相望。枝枝相准。叶叶相向。花花相顺。果果相当。如是行列数百千里。间以宝池又复如是。乃至周遍世界荣色光耀不可胜视。清风时发自成微妙音声。无可比者

    树音妙乐分第二十四

佛言。如世间帝王有万种音乐。不如转轮圣王诸音乐中一音之美。百千万倍。如转轮圣王万种音乐。不如忉利天王诸音乐中一音之美。百千万倍。如忉利天王万种音乐。不如第六天王诸音乐中一音之美。百千万倍。如第六天王万种音声。不如阿弥陀佛刹中诸七宝树一音之美。百千万倍。复有自然种种妙乐。而其音声无非妙法。清畅嘹喨微妙和雅。十方世界音声之中最为第一

    自然饮食分第二十五

佛言。阿弥陀佛刹中诸往生者。其饮食时有欲银钵者。有欲金钵者。有欲水晶琉璃钵者。有欲珊瑚琥珀砗磲码瑙钵者。或欲明月珠摩尼珠白玉紫金等钵。皆随其意化现在前。百味饮食充满其中。酸碱辛淡各如所欲。多亦不余。少亦不缺。亦不以美故过量而食。惟以资益气力。食已自然消散而无遗滓。或但见色闻香意以为食。自然化去。再欲食时复现如前。极彼刹中清净安稳微妙快乐。次于无为泥洹之道

    景象殊胜分第二十六

佛言。阿弥陀佛刹中。皆诸菩萨声闻诸上善人。无有妇女。皆寿命无央数劫。皆洞视彻听遥相瞻见。遥相闻语声。皆求善道者无复异人。其面目皆端正净好无复丑陋。其体性皆智慧勇健无复庸愚。其所欲言皆豫相知。意心所存念无非道德。形于谈说无非正事。皆相爱敬无或憎嫉。皆相顺序或无差池。动合礼义穆若弟兄。言语诚实转相教令。钦若承受不相违戾。意皆洁清无所贪染。淫决嗔怒愚痴之态。尽绝无余。邪心妄念消释无有。神气和静。体力轻清乐从经道。启迪慧性通其宿命。虽历万劫。己所从来靡不知之。复知十方世界去来现在之事。复知无央数天上地下人民。以至蜎飞蠕动之类。心意所念口所欲言。复知此等众生。当于何劫何岁。尽度脱为人。得生极乐世界。或作菩萨。或作声闻。皆豫知之。其有神智洞达威力自在者。能于掌中擎一切世界

    道场宝树分第二十七

佛言。阿弥陀佛刹中。其道场树高一千六百由旬。四布枝树八百由旬。根入宝地五百由旬。及一切众宝自然合成。花果敷荣。作无量百千殊丽之色。于其树上。复以月光摩尼宝。帝网摩尼宝。持海轮宝。如是等众宝庄严周匝其间。复垂爱宝璎珞。大缘宝璎珞。青真珠璎珞。如是等众璎珞缀饰。复有真妙宝网罗覆其上。成百千万色种种异变。无量光艳照耀无极。或时微风徐动演出无量妙法音声。其声流布遍诸佛刹。众生闻者得深法忍。住不退转地无其耳病。以至成就无上菩提。若有众生。见此树者乃至成佛。于其中间不生眼病。若有众生。闻树香者乃至成佛。于其中间不生鼻病。若有众生。食树果者乃至成佛。于其中间舌亦无病。若有众生。树光照者乃至成佛。于其中间身亦无病。若有众生。观想树者乃至成佛。于其中间心得清凉。远离贪等烦恼之病。皆得甚深法忍。住不退转地。彼刹诸天人世人。见此树者得三法忍。一者音响忍。二者柔顺忍。三者无生法忍。如是树木花果。与诸众生而作佛事。皆以此佛本愿力故。坚固愿故。精进力故。威神力故

    宝网音香分第二十八

佛言。阿弥陀佛刹中。复有无量宝网弥覆其上。皆以金银真珠百千杂宝。奇妙珍异庄严校饰。周匝四面垂以宝网。光色晃曜尽极严丽。又有自然德风徐动。不寒不暑温和柔软。不迟不疾吹诸宝网及诸宝树。演发无量微妙法音。流布万种清雅德香。其有闻者尘劳垢习自然不生。风触其身皆得快乐。譬如比丘得灭尽定三昧。或时风吹散花遍满其刹。随色次第而不杂乱。柔软光泽馨香芬烈。足履其上陷下四寸。随举足已还复如故。花用已讫自然化没

    莲花现佛分第二十九

佛言。阿弥陀佛刹中。众宝莲华周遍世界。一一宝花百千万叶。其华光明无量杂色。青色青光。白色白光。玄黄朱紫之色。其光亦然。炜烨焕烂明耀日月。一一华中。出三十六百千亿光。一一光中。出三十六百千亿佛。其身皆紫金色相好殊特。一一诸佛。又放百千光明。普为十方众生说微妙法。如是诸佛各各安立无量众生于佛正道

    大会说法分第三十

佛言。阿弥陀佛。为诸菩萨声闻及诸天世人。广宣大教敷演妙法之时。皆以次序大会于七宝讲堂。佛初为诸菩萨声闻及诸天世人说法。莫不欣然悦适心得解悟。各随其资而有所得。即时四方自然微风。吹诸宝树作五百音声。复吹诸宝花停结空中。枝叶下向以成供养。既而坠地则自然乱风吹去。于是第一四天王天诸天人。持百千花香百千音乐。自空而降以供养佛及菩萨声闻之众。听闻说法。散诸香花。奏诸音乐。于是第二忉利天。上至欲界诸天。以至第七梵天。及三十六天。如是等天诸天人。各持百千香华。百千音乐转相倍胜。自空而降。皆以前后次序更相开避。供养佛及菩萨声闻之众。听佛说法散诸香花。奏诸音乐。诸天人中有未得须陀洹道者。有未得斯陀含道者。有未得阿那含道者。有未得阿罗汉道者。有未得不退转地菩萨者。闻佛说法即心开意解。随所未得而自得之。当此之时。熙然欢喜不可胜言

    十方听法分第三十一

佛言。其次东方恒河沙数诸佛。各遣无量无数菩萨。及无量无数声闻之众。持诸香华幢幡宝盖。种种供具前以献佛。各礼足已。称赞宝刹功德庄严。听说妙法皆大喜悦。作礼而去。其次南方世界。恒河沙数诸佛。各遣无量无数声闻。及无量无数声闻之众。持诸香华幢幡宝盖。种种供具前以献佛。各礼足已。称赞宝刹功德庄严。听说妙法皆大喜悦。作礼而去。其次西方北方。曰隅上下亦复如是。尔时世尊。复说偈言

  东方诸世界　　数若恒河沙
  一一世界中　　声闻与菩萨
  无量复无数　　各发最胜心
  持诸妙供养　　往献阿弥陀
  南西北四隅　　上下亦如是
  悉皆供献已　　旋绕怀爱敬
  赞叹大福田　　最上复希有
  皆由宿愿弘　　精进无穷极
  究达神通慧　　游入胜法门
  具足功德宝　　妙智无等伦
  慧日朗世间　　消除生死云
  庄严极乐刹　　威神叵思议
  旷荡已无边　　佛刹绝无比
  称赞既如是　　钦慕不能已
  复以天妙花　　散空成宝盖
  纵广百由旬　　色相愈新丽
  假兹伸供养　　自喜还自庆
  愿我积众善　　致我刹亦然
  先了诸法性　　梦幻本来空
  次度诸众生　　远大无穷极
  如是宝刹者　　何忧不可成
  尔时佛慈悲　　开导一切心
  神通化大光　　从佛面门出
  四散数无穷　　普照亿佛刹
  人天咸睹已　　还归佛髻中
  时会诸有情　　敬叹未曾有
  愿与沉沦者　　尽证菩提道

    观音发问分第三十二

尔时佛说此偈已。会中有观自在菩萨。即从座起。合掌向佛而作是言。世尊。以何因缘。阿弥陀佛于其面门。放无量光照诸佛刹。惟愿世尊方便解说。令诸众生及他方菩萨。闻是语已心生解悟。于佛菩提志乐趣求。永无退转。佛言。汝当谛听吾为汝说。彼佛如来于过去无量无边阿僧祇劫前。为菩萨时。发大誓言。我于未来世成佛时若有十方世界。无央数诸天人民。以至蜎飞蠕动之类。闻我名号。或顶礼忆念或称赞归依。或香花供养。如是众生速生我刹。见此光明即得解脱。若诸菩萨见此光明。即得授记证不退位。手持香华及诸供具。往十方无边佛刹。供养诸佛而作佛事。增益功德。经须臾顷复还本刹。是故光明而入佛顶

    菩萨出供分第三十三

佛言。阿弥陀佛刹中。诸菩萨承佛威神。一食之顷遍至十方无量世界。供养诸佛。随心所欲。花香妓乐。衣盖幢幡。无数供养之具。自然化现在前。珍妙殊特非世所有。辄以奉佛及诸菩萨声闻之众。或欲献花者。即于空中化成花盖。小者周圆四十里。或五十里。或六十里。如是展转渐大。有至于六百万里。名随其小大停于空中。以成圆象势皆下向以成供养。光色照耀香气普薰。不可胜言。既已用已。随其前后以次化没。诸菩萨复于空中共奏天乐。以微妙音歌叹佛德。听受经法喜悦无量。既供养已忽然轻举。还至本刹犹为未食之前

    菩萨功德分第三十四

佛言。阿弥陀佛刹中诸菩萨众。容貌柔和相好具足。禅定智慧通达无碍。神通威德无不满足。深入法门得无生忍。诸菩萨道究竟明了。调伏诸根身心柔软。安住寂静尽般涅槃。深入正慧无复余习。依佛所行七觉圣道。修行五眼照真达俗。辩才总持自在无碍。善解世间无边方便。所言诚谛深入义味。敷演正法广度有情。除彼一切烦恼之患。等观三界空无所有。知一切法悉皆寂灭。无相无为无因无果。无取无舍无缚无脱。去诸分别远离颠倒。坚固不动如须弥山。智慧明了如日月朗。广大如海出功德宝。炽盛如火烧烦恼薪。忍辱如地一切平等。清净如水洗诸尘垢。如虚空无边不障一切故。如莲华出水离一切染故。如雷音震响出法音故。如云叆叇降法雨故。如风动树长菩提芽故。如牛王声异众牛故。如龙象威难可测故。如良马行乘无失故。如师子座离怖畏故。如尼拘陀树覆荫大众故。如优昙钵华难值遇故。如金刚杵破邪山故。如梵王身生梵众故。如金翅鸟胜毒龙故。如空中禽无住迹故。如雪山照功德净故。如慈氏观法界等故。专乐求法心无厌足。常欲广说志无疲倦。击法鼓建法幢。曜慧日除痴暗。修六和敬常为师导。为世灯明最胜福田。拔诸欲刺以安群生。功德殊胜莫不尊重。恭敬供养无量诸佛。常为诸佛所共赞叹。究竟菩萨诸波罗蜜。修空无相无愿三昧。及不生不灭诸三昧门。远离声闻缘觉之地。阿难。彼诸菩萨。成就如是无量功德。我但为汝举要言之。若广说者虽历一劫不能穷尽

    泥洹去者分第三十五

尔时座中有阿逸多菩萨。即从座起。合掌问佛。阿弥陀佛刹中诸声闻。有般泥洹者否。佛言。此四天下星汝见之否。答云。皆已见之。佛言。如大目犍连飞行四天下。一日一夜可尽知其星数。彼刹声闻之众。尚百千亿倍。于四天下星。不可尽知其数。其一声闻般泥洹者。犹如大海减去一渧不觉其少。其般泥洹者数虽众多。犹如大海减去一溪之水亦不觉其少。虽般泥洹者及无央数。其现在者与新得声闻者。其数亦无量无极。犹如大海减一恒河之水而不觉其少。使天下诸水皆入于海。亦不能觉海水增多。所以者何。以海为天下诸水之王。容纳无穷。彼佛刹中亦复如是。使十方无央数佛刹诸天人民。以至蜎飞蠕动之类。皆往生其中。亦不能觉彼刹人数增多。所以者何。以彼刹独冠于十方无央数佛刹。而至广至大旷若无边。所以者何。本其为菩萨时。志愿广大精进不懈。积德无穷故能如是

    光明大小分第三十六

佛言。阿弥陀佛。与其刹中诸菩萨声闻。顶中光明各有大小。诸声闻顶中光明各照七丈。诸菩萨顶中光明各照千亿万里。有二菩萨尊为第一。其一名观世音。一名大势至。常在佛侧坐侍政论。佛与二菩萨对议十方世界未来现在之事。佛欲使二菩萨往他方佛所。神足而往驶疾如佛。分身生此世界助佛扬化。于彼刹中不失现在。其智慧威神最为第一。顶中光明各照千佛世界。世间人民善男子善女人。若有急难恐怖或值官事。一心归命观世音菩萨。无不得解脱者。其佛顶中光明极大极明。彼世界中日月星辰。以佛光胜故亦无光耀。皆住空中亦不运转。故无一日二日一月二月。亦无岁数亦无劫数。以此间计之。彼佛光明。后无数劫无数劫。重复无数劫无数劫。不可复计劫。终无冥晦之时。其世界无坏亦复如是

    恩德无穷分第三十七

佛言。阿弥陀佛。于世间教化。意欲度脱十方无央数佛刹中诸天人民。以至蜎飞蠕动之类。皆往生其刹悉令得泥洹之道。其间欲作佛者。即令修菩萨行以至成佛。既成佛已转相教化。度脱十方无央数世界中诸天人民。以至蜎飞蠕动之类。往生其刹者不可胜数。作菩萨以至成佛者。亦不可胜数。是此佛恩德。及于十方世界。无穷无极不可思议

    佛寿人数分第三十八

佛言。汝欲知阿弥陀佛寿命无极否。阿逸多对言。诚欲闻知。佛言明听。悉十方无央数世界诸天人民。以至蜎飞蠕动之类。皆得为人。又皆作缘觉声闻。共坐禅一心。合其智慧为一智慧。以计数彼佛寿命。几千亿万劫。无有能知者。其诸菩萨声闻。及彼刹诸天世人寿命。亦复如是。复令十方各千世界中诸天人民。以至蜎飞蠕动之类。皆得为人。又皆作缘觉声闻。共坐禅一心。合其智慧为一智慧。以计数彼刹中诸菩萨声闻几千亿万人。莫有能尽知者。彼佛寿命浩浩渺渺无穷无极。谁能信知惟佛知耳

    递次作佛分第三十九

阿逸多复白佛言。阿弥陀佛功德寿命。威神光明乃如是耶。佛言。彼佛至般泥洹时。观世音菩萨乃当作佛掌握化权。教化度脱。十方世界诸天人民。以至蜎飞蠕动之类。皆令得泥洹之道。欲作佛者则至作佛。既作佛已转相教化转相度脱。如一大师阿弥陀佛。无有穷极。其恩德所及一无有异。复住无央数劫无央数劫不可复计劫。一一皆法阿弥陀佛乃般泥洹。其次大势至菩萨作佛掌握化权。教化度脱一如阿弥陀佛。经历劫数永无般泥洹时

    佛智无极分第四十

阿难复从座起。长跪合掌而白佛言。他方世界皆有须弥山。阿弥陀佛刹中独无此山何耶。佛言。汝有疑于佛耶。十方世界无穷无极。不可思议。佛智亦如是。其中诸大海水。欲以一人斗量而尽。汝智亦如是。往昔过去世亿万亿劫。有亿万亿佛。各各自有名号。无有同我名号释迦文者。复经亿万亿劫间。有同我名号。如是积劫不已。其同我名号者。乃如恒河水边流沙。一沙一佛。此属过去。我尽见之。今现在面南正坐。见南方亿万亿世界。其中有佛。各各自有名号。无有同我名号释迦文者。又复过亿万亿世界间。有同我名号。如是过世界不已。其有同我名号者。乃如恒河水边流沙。一沙一佛东西北方四隅上下。亦复如是。此属现在我尽见之。将来亿万亿劫中。有亿万亿佛。各各自有名号。无有同我名号释迦文者。复经亿万亿劫间。有同我名号。如是积劫不已其同我名号者。如恒河水边流沙。一沙一佛。此属未来我尽见之。是知佛之智慧。能通十方世界。去来现在无穷无极。不可思议。岂可以斗量之智而妄窥测

    独无须弥分第四十一

阿难闻佛所言。则大恐怖毛发耸然。复白佛言。非敢有疑于佛。所以问者。以他方世界四天王天及忉利天。皆依须弥山而住。彼独无此山。恐佛般泥洹后。有来问者无以告之。故以问佛。佛言。他方世界第三炎摩天。上至第七梵天。皆何所依而住。对言。自然在于空中。佛言。彼刹中无须弥山。其四天王与忉利二天。亦复如是。天人行业果报不可思议。其诸众生住行业之地。亦不可思议。况彼佛威神浩大。凡有作为无施。不可无须弥山。无复何疑

    十方称赞分第四十二

佛告阿难。东方有恒河沙世界。诸佛出广长舌相。放无量光。说诚实言。称赞阿弥陀佛功德不可思议。南方亦有恒河沙数世界。诸佛出广长舌相。放无量光。说诚实言。称赞阿弥陀佛功德不可思议。西方北方四隅上下。亦复如是。所以者何。欲令诸天帝王人民。尽闻阿弥陀佛名号。忆念受持归依供养求生其刹。是人命终必得往生。若有众生闻其名号。信心喜悦。乃至一念至诚回向。愿生其刹。必得往生。惟除五逆诽谤正法

    三辈往生分第四十三

佛言。十方世界诸天人民。有志心欲生阿弥陀佛刹者。别为三辈。其上辈者。舍家弃欲而作沙门。心无贪慕持守经戒。行六波罗蜜修菩萨业。一向专念阿弥陀佛。修诸功德。是人则于梦中见佛及诸菩萨声闻。其命欲终时。佛与圣众悉来迎致。即于七宝水池莲华中化生。为不退转地菩萨。智慧威力神通自在。所居七宝宫宇。在于空中去佛所为近。是为上辈生者。其中等者。虽不能往作沙门大修功德。常信受佛语。深发无上菩提之心。一向专念此佛。随方修善。奉持斋戒。起立塔像。饭食沙门。悬缯然灯。散华烧香。以此回向愿生其刹。命欲终时。佛亦现其身光明相好。与诸大众在其人前。即随往生。亦住不退转地。功德智慧。次于上等生者。其下辈生者。不能作诸功德。不发无上菩提之心。一向专念。每日十声念佛。愿生其刹。命欲终时。亦梦见此佛。遂得往生。所居七宝宫宇。惟在于地。去佛所为远。功德智慧。又次于中辈生者

    必修十善分第四十四

佛言。行菩萨道生阿弥陀佛刹者。即得不退转地菩萨。具三十二相紫磨金色八十种好。渐次以入佛位。欲于何方世界作佛。皆如所愿。若不能大精进禅定。尽持经戒必修十善。一不杀生。二不偷盗。三不邪淫。四不调欺。五不饮酒。六不两舌。七不恶口。八不妄言。九不嫉妒。十不贪欲。不靳吝。不嗔恨。不邪见。笃于孝顺谨于诚信。信受佛语。深信作善得福。奉持如是善法。昼夜思惟阿弥陀佛。及彼刹种种功德庄严。志心归依顶礼供养。是人命终心不颠倒。即得往生。闻无量无数诸佛。称赞此佛功德。永不退转无上菩提

    复有三等分第四十五

佛言。其次斋戒清净。一心常念阿弥陀佛。欲生其刹。十昼夜不断绝者。命终必得往生。纵不得昼夜。当绝虑去忧。勿与家事。勿近妇人。端身正心。断除爱欲。斋戒清净。志心忆念彼佛。持诵名号欲生其刹。止一昼夜不绝断者。命终亦得往生。若有善男子善女人。发菩提心。持诸禁戒坚守不犯。饶益众生。所作善缘悉以施与。令得安乐。当忆此佛及彼刹境界。是人命绝往生。即如佛色相种种庄严。贤圣围绕。速闻无上妙法

    一生补佛分第四十六

佛言。诸往生者。皆具足三十二相。究竟深入妙法要义。诸根明利。其初钝根者成就二忍。利根者得不可计无生法忍。皆当一生遂补佛处。所以者何。彼佛刹中。皆住于正定之聚。无诸邪聚及不定之聚。复无三种过失。一者心无虚妄。二者住不退转。三者善无唐捐。所以生于彼者。有进无退直至成佛。惟有宿愿速度众生。则以弘誓功德而自庄严。入他方生死界中。作师子吼说法度脱。尔时阿弥陀佛。以威神力。令彼教化一切众生。皆发信心乃至成佛。于其中间不受恶趣。神通自在常识宿命。虽生五浊恶世。形迹与同。其清净快乐。无异本刹

    大会宝池分第四十七

佛言。十方无央数世界诸天人民。比丘僧比丘尼。优婆塞优婆夷。往生阿弥陀佛刹者。群众大会于七宝池中。人人各坐一大莲华之上。自陈前世所持经戒。所作善法。所从来生本末。其所好法。及所得浅深。与智慧多寡。从上次下转相言之。其人若不豫作诸善。不明经理。于此应对。自然促迫其心惭悔。悔亦无及。但慷慨发愤。慕及等夷

    世人极苦分第四十八

佛言。世人于剧恶极苦之中。勤身营务以自给济。无贵贱贫富。无少长男女。皆忧财物累念积虑。为心走使无时安息。若有田忧田。有宅忧宅。有牛马六畜奴婢。衣食什物。悉共忧之。尊贵豪富既有斯患。婴结于心不能自适。若贫穷下劣常苦困乏。无田亦忧欲有其田。无宅亦忧欲有其宅。无牛马六畜奴婢。衣食什物无不爱之。欲其皆有。适有一物复缺一物。适有是事复缺是事。勤苦若此休息无时。不达于道德。迷没于嗔怒。贪恨于货色。坐斯不得道。当入苦恶趣展转其中。虽数千亿劫无有出期。痛不可言极可哀愍。今语汝等世间之事。择其善者勤而行之。爱欲荣华不可常保。皆当别离无可乐者。乘佛在世当勤精进。愿生极乐世界

    五道昭明分第四十九

佛言。苦心与语令得解脱。若不信悟无益。其人大命将至悔亦何及。天地之间五道昭明。恢廓浩渺窈窈冥冥。业报相生转相承受。美恶惨毒皆自当之。孰使如是理之自然。善人行善。从乐入乐。从明入明。恶人行恶。从苦入苦。从暗入暗。世人昧此恶道不绝。故有自然地狱饿鬼。禽兽蜎飞蠕动之类。展转其中世世累劫。无由出离。是为大患。痛不可言。惟修净土直得超去

    寿数随意分第五十

弥勒复白佛言。今闻佛所说莫不喜悦。诸天人民以至蜎飞蠕动之类。皆蒙慈恩授解脱法。佛语教诫甚善甚深。佛言。汝从无数劫来修菩萨行。欲度诸天人民。以至蜎飞蠕动之类。从汝得道者无央数。至得泥洹之道者。亦无央数。汝及十方世界诸天帝王人民。若比丘僧比丘尼。优婆塞优婆夷等。从无数劫来流转五道。忧畏勤苦不可具言。至于今世生死不绝。与佛相值听受经法。又复得闻阿弥陀佛快哉甚善。吾助汝喜。汝今可厌生老病死痛苦。恶露不净无可乐者。宜自决断端身正行。益作诸善修已洁体。洗除心垢。言行忠信。表里相应。人能自度转相拯济。精明求愿积累善本。虽一切勤苦亦须臾之间。后生阿弥陀佛刹。快乐无极。长与道德合明。永拔生死根本。无复贪恚愚痴苦恼之患。欲寿一劫百劫。千劫万亿劫。无央数劫。不可复计劫。皆随意所欲无不得之。欲衣得衣。欲食得食。皆如其意。次于泥洹之道。汝等各宜精进无得狐疑。无得中悔自为过咎。以至生于彼刹边地。虽在七宝城中。经五百岁。受其困谪

    八端检束分第五十一

佛言。汝等当自端身。当自端心。耳目鼻口手足。皆当自端束检中外。无随嗜欲益作诸善。当布恩施德不犯道禁。忍辱精进一心智慧。展转复相教化。使彼为德立善。慈心正意斋戒清净。如是一昼夜。胜于阿弥陀佛刹中为善百岁。所以者何。以彼刹中无修营为物皆自有。人悉为善无毛发之恶。于此修善十昼夜。胜于他方佛刹为善千岁。所以者何。他方佛刹悉皆为善。无造恶之所。故其福德亦皆自然。其次有世界。为善者多。为恶者少。亦有自然之物。不待修营。若此世界中。为恶极多。为善极少。不自修治物无自有。或转相欺诒劳心苦形。如是匆务未尝宁息。吾哀世人教诲切至。令超彼岸。永脱苦趣

    众见佛相分第五十二

佛告阿难。汝起整衣合掌恭敬。面西为阿弥陀佛作礼。阿难如教作礼。白佛言。愿见阿弥陀佛。及极乐世界。与诸菩萨声闻大众。说是语已。阿弥陀佛。即放大光明。普照一切世界。其中所有悉皆不现惟见佛光。犹如劫水弥满世界。尔时阿难。见阿弥陀佛。容体巍巍如黄金山。高出一切诸世界上。相好光明无不照耀。会中四众悉皆睹见。佛言。我说阿弥陀佛及诸菩萨声闻。及彼刹中自然七宝。及一切所有。与此相见有无异否。对言。今此所见。与佛所言一无有异。尔时诸天人民。以至蜎飞蠕动之类。皆睹见阿弥陀佛光明。莫不慈心喜悦诸地狱畜生饿鬼。有拷治痛苦者。即皆解脱。诸盲者悉皆能视。聋者即皆能听。喑者即皆能言。偻者即皆能伸。跛蹇者即皆能趋。凡病者即皆痊愈。诸狂愚者即皆黠慧。淫泆者皆修梵行。嗔恨者皆慈和为善。有被毒者毒皆不行。钟鼓琴瑟。箜篌乐器诸伎不鼓自成五音之声。妇女珠璎。亦皆自然震响。百鸟畜兽皆自然欢鸣。当此之时莫不喜悦。咸得过度

    疑城胎生分第五十三

佛告弥勒。汝见彼刹有胎生否。对云见。胎生者所处宫殿。或百由旬。或五百由旬。各于其中受诸快乐。如忉利天人。何因缘故彼刹而有胎生。佛言。若有众生。修诸功德愿生彼刹。后有悔心亦复疑惑。不信有彼佛刹。不信有往生者。亦不信布施作善后世得福。其人虽尔续有念心。暂信暂不信。志意犹豫无所专据。临命终时。佛乃化现其身。令彼目见。口虽不能言。其心即喜乃悔。不免作诸善。以悔过故其过差少。亦生彼刹。惟不能前至佛所。方入边地见七宝城。即入其中。于莲华中生。受身自然长大。饮食亦皆自然。其快乐如忉利天人。惟于城中经五百岁。不得见佛不闻经法。不见菩萨声闻圣众。无由供养于佛。修习菩萨功德。以此为苦示其小谪。是故彼刹名为胎生。当知生疑惑者失大利益。若有众生信受经法。奉持斋戒作诸功德。至心回向。命终即于七宝池中莲华中生。跏趺而坐。须臾之间。身相光明智慧威神如诸菩萨。安得名为胎生。他方诸大菩萨。发心欲见阿弥陀佛。及诸菩萨声闻。恭敬供养。命终径于极乐世界七宝莲华中化生。自然即时见佛。安得名为胎生

    菩萨往生分第五十四

弥勒复白佛言。世尊。于此世界。有几何不退转地菩萨。往生阿弥陀佛刹。佛言。此世界有七百二十亿。不退转地菩萨。往生彼刹。一一菩萨已曾供养无央数佛。以此如弥勒者。皆当作佛。及诸小菩萨。及修习少功德者。不可胜计。皆当往生。不但我刹诸菩萨等往生于彼。他方佛刹亦复如是。其第一佛名光远照。有八十亿菩萨。皆当往生。第二佛名宝藏。有九十亿菩萨。皆当往生。第三佛名无量音。有二百二十亿菩萨皆当往生。第四佛名无极光明。有二百五十亿菩萨。皆当往生。第五佛名龙胜。有六百亿菩萨。皆当往生。第六佛名勇光。有万四千菩萨。皆当往生。第七佛名具足交络。有十四亿菩萨。皆当往生。第八佛名离垢光。有八十亿菩萨。皆当往生。第九佛名德首。有八百一十亿菩萨。皆当往生。第十佛名妙德山。有万亿菩萨。皆当往生。第十一佛名慧辩。有十亿菩萨。皆当往生。第十二佛名无上华。有无数不可称计菩萨。其地皆不退转。智慧勇猛。已曾供养无量诸佛。于七日中。即能摄取百千亿劫。大士所修坚固之法。斯等菩萨皆当往生。第十三佛名乐大妙音。有七百九十亿大菩萨。诸小菩萨及比丘等。不可称计。皆当往生。不特此十四刹中。诸菩萨众皆当往生。十方无量佛刹中。其往生者甚多。无数不可复计。我但说十方无央数佛名号。昼夜一劫尚未能尽。况其菩萨当往生者。今为汝等。乃略言之

    闻法因缘分第五十五

佛言。世间人民前世为善。乃得闻阿弥陀佛名号功德。若慈心喜悦志意清净。毛发耸然泪即出者。皆前世尝行佛道。或他方佛所。尝为菩萨固非凡人。若不信心。亦不信佛语者。乃恶道中来。余殃未尽。愚痴不解。未当解脱。多有菩萨。欲闻此经而不得闻。若得闻者。于无上道永不退转。故当信受读诵如说修行。吾今为汝等说此经典。令见阿弥陀佛及其国土。与一切所有所当为者。必勉为之。当来之世经道灭尽。我以慈悲哀愍。特留此经百岁。众生值遇无不得度。若有众生。于此经典书写供养。受持读诵为人演说。乃至昼夜思惟佛刹。及佛身功德。临寿终时。佛与圣众现其人前。经须臾间。即生彼刹

    正法难闻分第五十六

佛言。佛世难值。正法难闻。如来所言必应从顺。于此经典作大守护。为诸众生长夜利益。超生净刹永离五趣。尔时世尊。复说偈言

  若不往昔修福慧　　于此正法不能闻
  已曾钦奉诸如来　　故有因缘闻此义
  闻已受持及书写　　读诵赞演并供养
  如是一心求往生　　决定径归极乐刹
  上品上生复何疑　　皆赖平时修积力
  彼佛刹乐无边际　　惟佛与佛乃能知
  声闻缘觉满世间　　尽其神智莫能测
  假使长寿诸众生　　命住无数俱胝劫
  称赞如来功德身　　究竟浅智不能尽
  大圣法王宣妙法　　济度一切脱沉沦
  若有受持扬说者　　真是菩提殊胜友

佛说是经已时。弥勒菩萨。长老阿难。诸菩萨声闻。及十方来诸大众。靡不喜悦。信受奉行

佛说大阿弥陀经卷下右龙舒居士王虚中日休。校正四译经文。析为五十六分。无量寿尊因地果海。纶次焕然。安乐世界真景佳致。皎如指掌。披卷详阅。端坐静思。则七宝庄严。混成宇宙。圣贤海会。声教仪刑。密移于此土矣。大哉寿尊之愿力。奇哉净域之境象。美哉虚中之盛心也。第十四分增入。阿阇世王太子。与五百长者子一段缘起。则知如来法门广大。不拒来者。凡具是志。归斯受之。不意法藏之后。复见此人。尘劫之外。净刹相望。彼既丈夫我亦尔。不应自轻而退屈。后学之士睹斯记莂。宁无闻风而兴起者乎。至第三十九分则现在会中。二法王子。旷劫精勤。位邻等妙。次补佛处。掌握化权。一曰普光功德山王。二曰善住功德宝王。后无央劫相继出兴。到此则安乐旧号。转而为众宝善集庄严矣。此则备见于他经。约其依报住处。盖在彼界第四兜率天宫。而此书之所未及言者。其第三十二分。二法王子。于彼佛土。智慧威神。德业辉光。最为第一。入则坐侍正论。出则扬化他方。于彼刹中不失现在。故圆通大士。元住海山。璎珞童子。曾绍祖位。法起于此。愿轮与彼行海。虽未之逮。而实有志焉。方法藏菩萨之发是愿也。先佛世尊。勉而谓曰。譬如大海。一人斗量。历劫不止。尚可见底。况人志心求道。精进不止。何求不得。何愿不遂。至哉斯言。与今释尊所以劝驾。阿阇王子。五百同盟之意。则一而已矣。然第六分中。尚有一字阙文。所当校正而增修者。案释尊所述。无量寿如来。本起因地。正以然灯出兴之时。为彼佛发心起行。劫数久近之准。盖溯然灯而上。经涉五十三重过量劫数。乃至古佛世自在王。则然灯以往。当更增次前二字以别之。然后知其世数悬远。位序着明。若但言次有某佛。则是沿然灯而下。所历劫数四十九重。方至世自在王。则佛出之后先。发心之久近。舛误多矣。故愚以谓。当于光远佛以上。各加一前字。共加五十二前字。则五十三觉皇兴世之序。无量寿如来因地之的。时分条理。井然不紊。事相颠末。了无舛差。传之久远。以诏无穷。真可以会人天于圣域。闭恶道于永劫矣。余得此书。喜不能寐。手不停披。但读至此犹有遗恨。是用斋心炷熏。对越玄元圣母。及紫府先生。白华老人。而题其后焉。虚中居士。神迁净域。必已位登上地。天眼智证。必已洞烛。此间九原。可作同声相应。必有契于斯文。淳祐己酉建日除夕。海山旧住空常氏法起谨跋


大宝积经并序

    No. 310

    大宝积经并序

        大唐太上皇制

朕闻。天之为大也高。上下之容可纪。地之为大也广。纵横之数可推。则知无去无来。不生不灭。拯沉沦于沙劫。救焚灼于尘区。毒龙惧其威光。醉象惮其神力。其大则包于宇宙。其小则隐于毫芒。七十二君。先在陶钧之内。万八千载。即为俄顷之间。汉日载其通晖。周星彰其降诞。鹫头峰下。演金口之微言。鸡足山中。舒玉毫之瑞色。干戈不用。梵志摧锋。甲胄无施。波旬溃旅。辟圆明之净域。启方便之禅门。慧晷耀于昏衢。慈云清于朽宅。无得而称者。其惟正觉乎。然则教自西方。法流东夏。马鸣龙树肇阐琼编。罗什道安承宣宝偈。关中道俗。虽传贝叶之文。江左黎元。未极莲花之旨。又以元魏迷于释典。宇文扇于魔风。开皇之初。暂为修建。大业之末。遽即分崩。我大唐之有天下也

睿圣重光。文思御历。吞沙静[薛/女]。练石称神。巢燧执鞭。羲农拥彗。悬法王之镜。转梵帝之轮。被正朔于蟠桃。混车书于细柳。三藏沙门菩提流志者。南天竺国。净行婆罗门种。姓迦叶氏也。年十有二。外道出家。事波罗奢罗。学声明僧佉等论。并历数咒术。及阴阳等。年踰耳顺。遽乃心归。知外法之乖违。悟释教之深妙。隐居名岳。积习头陀。初就耶舍瞿沙三藏学经论。其后遍游五天竺国

高宗天皇大帝。闻其远誉。挹其道风。永淳二年。遣使迎接

天后圣帝。应干司契。当宇披图。令住东都居福先寺。译佛境界宝雨花严等经一十一部

中宗孝和皇帝。循机履运。配永登枢。神龙二年。令住京下于崇福寺翻译此经。俄属灵祐亏微。绵区集祸

乔岳之仙长往。茂陵之驾不还。朕以庸虚。谬膺不构。敬遵前旨。勖就斯编。法师寻绎故文。发挥新句。炎凉不懈。晓夕忘疲。旧翻新翻。凡有四十九会。总其部帙一百二十卷成。以先天二年六月八日。毕功进内。法师戒珠在握。慧炬明心。为法门之栋梁。启僧徒之耳目。伏愿上资七庙。八百之祚长延。下及万方。亿兆之甿恒逸。远迩宁谧。朝野欢娱。致浇俗于淳源。归迷生于寿域。暂乘紫机之暇。聊题缃帙之前。所有会名。具于其目云尔

    大宝积经述

        唐朝议郎行河南府告成县主簿徐锷撰

夫日月出矣。而辉耀十方。时雨降矣。而澡漉万物。况我身常乐。湛虚空之相。妙觉圆明。融心行之本。唯曒唯昧。不生不灭者哉。是以辟无学之地。聿修迦兰。启息言之津。亶作罗奈。智胜菩萨。起方便之缘。净居天人。发成就之力。称谓所绝者。其第一义乎。自恒星夜掩。仙虹昼烁。青钵传其睟容。宝棺现其金臂。法山摧仞。拂魔箭于危屏。直水横流。系慈航于彼岸。乌呼妙藏不可以常秘。戒轮不可以终[盩-ㄆ+系]。虽双林下砉示于泥洹。逮一千年。遹被于声教。龙持贝叶。亟传摩竭之城。象负莲华。遂满真丹之境。三十七品。慈悲于火宅。一十二经。引喻于沙界矣。大宝积经者。后汉迦叶摩腾竺法兰。及今朝玄奘法师。菩提流志等。咸自西天竺所致也。如来昔在鹫峰。利建平等。金口注海。酌之而不竭。宝言如纶。振之而有绪。炯兹瑞宪。久翳鸿都。原壑屡非。市朝多变。历代徇齐之主。竞兴参译。跋陀授记之言。罕能丕就。洎我唐之有天下也。功横铁围。化緜忉利。苑御千界。提封万刹。张四摄之扉。广纳诸有。骋六道之骥。冥济群惑。太上皇以泽深智海。掌耀禅珠。神皇帝以勋格梵空。胸悬法印。肃敷玄诰。照洒鸿波。历选缁徒。明[改-己+易]列采。博考同异。聿兴刊缉。勇振颓纲。严持绝纽。爰有沙门大德思忠。东天竺国婆罗门大首领臣伊舍罗等。译梵文者。求善住缘。悟无生忍。博闻强识。精而译之。复有天竺沙门波若屈多。沙门达摩。证梵义者。开忍辱场。破烦恼众。弼谐神侣。明而辨之。复有沙门大德履方。宗一。普敬。慧觉等笔授者。令闻孔胶威仪不忒。手握仙札。受而字之。复有沙门大德深亮。胜庄。尘外。无著。慧迪等证义者。国之大师。佛之右臂探诸了义演而证之。复有大德沙门承礼。云观。神暕。道本等次文者。庇影多林。息肩香窟。勤修精进。纂而次之。复有润文官者。银青光禄大夫邠王傅上柱国固安县开国伯卢粲。银青光禄大夫太子詹事崇文馆学士兼修国史上柱国东海县开国公徐坚。朝议大夫守中书舍人崇文馆学士上柱国野王县开国男苏晋。朝议郎给事中内供奉崔璩等。位列凤舞。声流鸡圃。分别二谛。润而色之。复有银青光禄大夫守侍中兼太子左庶子兼修国史上柱国钜鹿县开国公魏知古。兵部尚书上柱国郭元振。银青光禄大夫检校中书令上柱国范阳县开国男张说。银青光禄大夫行中书侍郎同中书门下三品监修国史上柱国兴平县开国侯陆象先等。朝践琐闼。夕游珠域。护持四法。总而阅之。尔乃杖锡之士。端圭之俊。麻列定筵。林攒乐土。荫祥云而演译。倏换炎凉。吸甘露而勤求。载淹衡晷。大乘章句。义不唐捐。小品精微。拯无遗溺。能事毕矣。佛何言哉。今所新翻经。凡有四十九会七十七品。合一十二帙。以类相从撰写咸毕。以先天二年六月三十日进太上皇。八月二十一日进皇帝。禁闱晓辟真教上闻。仙宁克怡。宸襟允穆。竦钧阵于白日。亲御灵台。落云雨于彤霄。荐加殊尉。贤愚稽首。以为利见仁王。真俗归心。以为潜登觉道。次有清信佛弟子。前少府监丞李式颜等。皇朝金紫光禄大夫兵部尚书赠侍中陇西公迥秀子也。复有清信佛弟子。前右拾遗徐鐈等。皇朝银青光禄大夫太子宾客昭文馆学士高平公子也。咸属彼穹。降祸私门坠构。陟遥岵而崩心。瞻冥途而献福。于是胠箧探笥。檀波罗蜜。广叠简笺。首崇书写。不变槐火。遽盈苔袟。然后装之镂轴。缀以琼签。罗彩簟而霓舒。播珠函而锦缛。方使猛风吹岳。长存妒路之文。劫火烧天。不坏多罗之典

    大宝积经三律仪会第一之一

        大唐三藏法师菩提流志奉　诏译

如是我闻。一时佛住王舍城耆阇崛山。其山高峻严丽可观。持诸杂种犹如大地。众华卉木悉皆茂盛。其中复有天龙夜叉毗舍阇紧那罗等。常所游止。复有种种异类诸兽。所谓师子虎狼麒麟象马熊罴之属。止住其中。复有无量百千众鸟。所谓孔雀鹦鹉鸲[只*鳥]罗鸟凫雁鸳鸯命命等类。依之而住。是诸众生。以佛威力。不为贪欲嗔痴所恼。不相茹食。共相亲爱犹如母子。是山王中多诸杂树。丛林蓊郁枝叶繁荣。谓天木香树。庵摩罗树。甄叔迦树。尼俱陀树。栴檀沉水。如是等树。无不备有。复有水陆无量杂华。所谓阿提目多华。瞻婆香华。波吒罗华。婆师迦华。苏曼那华。由提迦华。优钵罗华。波头摩华。俱物头华。芬陀利华。迦罗娑华。摩诃迦罗娑华。如是等类诸杂名华。光饰山王处处充遍。是山王中常于夜半兴大密云。轻雷细雨。从初至末渐遍其山。八功德水流滋普洽。如[(殼-一)/牛]乳顷廓然消散。凉风微动适悦身心。是山王中所住众生。及诸卉木。滋润光泽如妙华鬘。微加水洒。光色鲜明倍更增胜。此山王中众生草木。含滋发晖亦复如是。而此山中生诸软草。靃靡右旋色香具足。青绿晖映如孔雀咽。其香喻若婆师迦华。其触又类轻兜罗绵。枝叶华果繁荣茂盛。未尝有一不具足者。山地柔软无伤趾步。下足之时陷深四指。举足之时还复如故。其中多有陂泉池沼。清冷盈满生杂莲华。青黄赤白红紫颇梨金火等色。大如车轮。香气普熏一踰缮那。是山王顶生于大妙宝莲华座。无降伏宝帝青金刚。以为其茎。大吠琉璃为诸宝铎。瞻部檀金为广净叶。顺时清净。栴檀为台。玛瑙宝王以为其须。其华纵广犹如大海。十亿阿修罗王常所执持。十亿杂色摩尼宝网弥覆其上。十亿龙王雨妙香雨。十亿金翅鸟王口衔缯彩。十亿紧那罗王至诚瞻仰。十亿摩睺罗伽王虔恭俯视。十亿乾闼婆王歌咏赞叹。十亿百千诸大天帝。兴布瑞云。而雨末香烧香衣服华鬘幢幡宝盖。十亿梵王曲躬恭敬。十亿净居天众合掌顶礼。十亿转轮人王七宝侍从来至其所。十亿海王从大海出而敬礼之。十亿光明摩尼宝以为照曜。十亿净福摩尼宝珠。为胜庄严。十亿遍照摩尼宝。为无垢藏。十亿妙光摩尼宝。为大照明。十亿杂色摩尼藏宝。而为遍照。赡部幢宝为善安持。十亿金刚师子摩尼宝。难胜庄严。十亿日藏摩尼宝。间错厕填广大严饰。十亿不思议摩尼宝。出种种色为妙庄严。十亿如意宝。出无尽庄严。是大莲华从于如来超过世间善根所生。菩萨志意之所爱慕。遍现诸方。从如幻法出善法业生。以无诤法性理趣。庄严如梦法性。无行法印顺无著理。遍满十方一切法界。是顺佛境功德所致。若于无量阿僧祇劫。叹其色相功德庄严。不可穷尽。尔时世尊。于其华上结跏趺坐。与大比丘众八千人俱。其名曰尊者阿若憍陈如。尊者阿湿婆氏多。尊者摩史波。摩诃男优陀夷。耶舍。富那。无垢。善臂。憍梵钵提。优楼频螺迦叶。那提迦叶。摩诃迦叶。舍利弗。大目干连。阿那律。须菩提。离波多。富楼那弥多罗尼子。优波离。罗睺罗。难陀等。而为上首。悉皆觉悟自性谛理。现证实际。入法本性。度诸有海。行于如来虚空之行。悉能永断随眠结缚。而于摄藏。住无所住行空寂静。于如来所永断疑惑。入佛智海胜信道中。利益世间为不请友。常能卫护一切众生。与诸有情为不舍友。通达佛法。所行境界守护圣法。誓愿受持诸佛正教。现前得生如来种性。善能趣向一切智智

复有菩萨摩诃萨众八千人俱。普贤菩萨。文殊师利菩萨等。而为上首。所谓最上智智菩萨。最上宝智菩萨。一切语言智菩萨。无著智菩萨。花上智菩萨。日上智菩萨。月上智菩萨。无垢上智菩萨。金刚智菩萨。远尘智菩萨。光幢菩萨。妙高幢菩萨。宝幢菩萨。无碍幢菩萨。华幢菩萨。净幢菩萨。日幢菩萨。端严幢菩萨。离垢幢菩萨。遍照幢菩萨。陀罗尼威德菩萨。宝威德菩萨。大威德菩萨。金刚智威德菩萨。无垢威德菩萨。日威德菩萨。月威德菩萨。福山威德菩萨。智照威德菩萨。普胜威德菩萨。地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。清净功德藏菩萨。法海藏菩萨。遍照藏菩萨。齐藏菩萨。胜莲华藏菩萨。日眼菩萨。净眼菩萨。无垢眼菩萨。无碍眼菩萨。普明眼菩萨。善利智眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。普眼菩萨。天冠菩萨。照法界摩尼冠菩萨。妙菩提摩尼冠菩萨。照十方冠菩萨。出现一切佛藏冠菩萨。超一切世间冠菩萨。普照冠菩萨。无映蔽冠菩萨。执持一切如来师子座冠菩萨。普照法界虚空冠菩萨。梵王髻菩萨。龙王髻菩萨。一切佛变化影像髻菩萨。妙菩提髻菩萨。一切愿海音声摩尼王髻菩萨。放一切如来圆光摩尼宝雷声髻菩萨。一切虚空无差别表示摩尼宝网覆髻菩萨。一切如来法轮声髻菩萨。一切三世名轮声髻菩萨。大光菩萨。无垢光菩萨。宝光菩萨。离尘光菩萨。法光菩萨。寂静光菩萨。日光菩萨。神变光菩萨。天光菩萨。福光菩萨。智光菩萨。法光明菩萨。神通光菩萨。光照菩萨。华光菩萨。宝光菩萨。觉光明菩萨。梵光菩萨。普照光菩萨。梵音菩萨。海音菩萨。地吼音菩萨。世间王音菩萨。山王音菩萨。山王相击音菩萨。遍法界音菩萨。一切法海雷音菩萨。摧伏诸魔音菩萨。大悲理趣云雷音菩萨。遍息一切世间苦恼音菩萨。法胜涌菩萨。殊胜涌菩萨。智胜涌菩萨。福须弥胜涌菩萨。功德最胜涌菩萨。名闻胜涌菩萨。普光胜涌菩萨。大慈胜涌菩萨。智照胜涌菩萨。如来种姓胜涌菩萨。光德菩萨。胜德菩萨。法涌德菩萨。遍照德菩萨。法德菩萨。月德菩萨。虚空德菩萨。宝德菩萨。光德菩萨。智德菩萨。婆罗帝王菩萨。法帝王菩萨。象帝王菩萨。梵帝王菩萨。山帝王菩萨。众帝王菩萨。天帝王菩萨。寂静帝王菩萨。不动帝王菩萨。最胜帝王菩萨。菩提寂静声菩萨。无著声菩萨。地声菩萨。大海声菩萨。音声菩萨。照法声菩萨。虚空声菩萨。一切声菩萨。善根雷声菩萨。发悟本愿声菩萨。摧一切魔军声菩萨。智须弥觉菩萨。虚空觉菩萨。清净觉菩萨。无碍觉菩萨。开寤觉菩萨。照三世觉菩萨。宝觉菩萨。广大觉菩萨。普光觉菩萨。法界理趣照觉菩萨。如是等菩萨摩诃萨八千人俱。皆悉安住普贤愿行。所行无著者。普遍一切诸佛刹故。变无边身者。亲近一切佛如来故。所缘无际限境界清净者。了知一切佛神变故。趣无量者。往诣诸佛现等觉处。无休息故。无边光明者。于一切法实相海中。得无边智光明故。无边劫中说功德无尽者。辩才清净故。等虚空界者。智所行境清净故。无所依者。随世意乐现色身故。能离翳者。了知无有众生界故。虚空智慧者。放光明网遍法界故。究竟寂静者。最寂静心故。一切陀罗尼种性智境界者。于三摩地勇猛无畏者。眼住法界尽其际者。于一切法住无所得者。游无边智海者。已度智彼岸者。般若波罗蜜多者。般若波罗蜜多到一切世间波罗蜜者。于三摩地彼岸得自在者。复有五百比丘尼俱。其名曰摩诃波阇波提比丘尼。瞿昙弥比丘尼。安隐比丘尼。优钵罗华比丘尼。瘦瞿昙弥比丘尼。耶输陀罗比丘尼等。而为上首。复有五百优婆塞俱。其名曰善威德优婆塞。天威德优婆塞。慧光优婆塞。名称威德优婆塞。超名称威德优婆塞。善慧优婆塞。月德优婆塞。月欢喜优婆塞。大欢喜优婆塞。罗睺贤优婆塞。大贤优婆塞等。而为上首。复有五百优婆夷俱。其名曰大光优婆夷。善光优婆夷。善身优婆夷。可乐身优婆夷。贤德优婆夷。月光优婆夷。光明优婆夷。胜光优婆夷。善眼优婆夷等。而为上首。及余无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。围绕恭敬。而为说法。所谓广说三律仪品。一切如来毗奈耶法。开现一切诸菩萨行。明照法界入诸法门。能净庄严一切佛刹。摧诸邪论降伏魔怨。令众生界心得欢喜。开晓有情稠林之心。随众生意而为宣说。开示照曜众生诸根。令其转趣

尔时尊者摩诃迦叶。从坐而起偏袒右肩。右膝着地合掌向佛。白佛言。世尊。若诸众生。求于佛法力无畏者。摄受何法而修行之。摄受何法增长成熟诸如来道。摄受何法取诸功德。增长证入阿耨多罗三藐三菩提。得不退转。佛告大迦叶言。善哉善哉。迦叶。汝今所问多所安隐哀愍世间。义利饶益安乐人天。乃能问佛如是之事。汝今谛听善思念之。吾当为汝分别解说。时大迦叶及诸大众。受教而听。佛告迦叶。若诸众生。求佛智慧力无畏者。是等众生。无有少法为其可得。无所依倚种诸善根。迦叶。菩萨乃至求于阿耨多罗三藐三菩提时。有所得者即为着想。若着想者。于佛法外起有为想。于有为外起无为想。即于佛法而生想着及起解执。起解执时于佛法中坚住不舍。当知是人不名为向无上佛道。何以故。以于佛法起想执我。而作勤修。则与我执数相应故。而不舍离。则分别所分别。由是分别所分别处。则为所害。若为所害则便驰骋。若驰骋者则有流转。若流转者则有贯穿。有贯穿者则有妄想。有妄想者则有分别。有分别者则增妄想。若增妄想则有遍计。若有遍计则离寂静。若离寂静则有随逐。若有随逐则有游行。若有游行则便失坏。云何失坏。谓失安隐。云何安隐。谓无分别。若失坏者则便常入。若常入者则便亲近。若亲近者则有随眠。若有随眠则有相续。若有相续则增相续。若增相续则遍相续。若遍相续语则狂乱。语若狂乱则便诳惑。若有诳惑则便忧恼。有忧恼者则有悔恨。若有悔恨则依倚无明。为忧喜损害。而于是中。无有少法。可为依倚。然从妄想流澍生故。为想系缚。从想系缚则想相续故名想缚。无有实处。一切贪处忿嗔痴处。皆是虚妄遍计分别增分别。计度增计度。是故彼人不能速得阿耨多罗三藐三菩提。迦叶。是名爱处。何名爱处。无有定法名之为爱。名为爱者。名爱处所。然有爱者但由坚着。若坚着时为虚空爱。若虚空爱生执著者。彼人即当得爱执着。我爱执著者。众生爱执著者。善不善爱执著者。迦叶。是人则于一切空法。起非空分别则于非物而生物想。何谓为物。谓以菩提若以菩提为其物者。彼彼众生由我想故。而有我想即非菩萨。于是中想若不可得。彼中想者。亦不可得。是名我想无真实句。此即增语。所谓我想。若复有能圆满萨埵。则圆满菩提。何谓菩提。所谓圆满犹如于幻。云何如幻。谓说大我想者。大命想者。若复以想依止想者。则由非想依止非想。若以非想依非想者。则由狂醉故醉。若由狂醉故醉。则以苦逐苦。若以苦逐苦者。则彼彼如来皆说安住。狂言驰骋者。何故名住狂言驰骋者。谓增作意。若增作意则有贡高。若有贡高则有言说。若有言说则便增说。若有增说如来记之。是言说者教授者所持者。是故诸法皆从作意而得生长迦叶。如上空中有云聚起。不从东西南北四维上下而来。是故如来名实语者。知是云聚非十方来。如实说之。以其义说。理相应说。以实理说。言云聚者。则为非聚故名云聚。何名云聚。以其各别起相状故。云何种类各别相状。以种种相皆是广大。迷惑相续。而于其中无少大相以为可得。汝观云聚起广大相。则为非相。若非想者。但由毕竟广大之相。非实云聚。迦叶。譬如有人语他人曰。可共往诣荫处坐耶。智者言曰。我不往坐。彼作是言。我于今者不作是说。但言是荫。尔时智者复语彼言。汝言荫者即是非荫。迦叶。汝观彼人乃至随俗犹能觉了。如是如是迦叶。如来如实了知诸法真实理性。于大众中正师子吼。复次迦叶。如来乐欲于随顺法住非顺想。于诸众生所有我想。于如来所是第一义。何以故。如来今者已知彼想。悉知一切众生想者即为非想。此是最胜秘密之言。或有愚夫而生违背与如来诤。是故我言。世与我诤。我不与世诤。云何名世。所谓众生。何故众生名之为世。如来了知如是世间。是故众生名之为世。如彼愚夫异生之解。则便坏灭。极为所害。此是彼等常得信住。随其世俗所谓无明。何以故。彼居大。闇名住世者。若住世者则便有贪。若有贪者则便有嗔。若有嗔者则便有痴。若有痴者则为不净。若不净者则便相违。与谁相违。所谓如来及声闻众若相违者则便乖背。若乖背者则重相违。重相违者则乐于有。乐于有者心则求之。求于有者则便遍求。若遍求者则不知足。不知足者则多所作。多所作者则便多欲。若多欲者彼则随眠于三界中。若随眠三界则令他随眠。令他随眠者彼则随流。亦随流行者。若是随流随流行者。则趣于死。若趣死者则不趣涅槃。不趣涅槃者则至非行处。至非行处者则趣地狱。如是迦叶。由不祥法与之相应。嗔忿毒心及不覆蔽。不覆蔽者不观我想。不观察者作一合想。不能销灭我及我所。何名为我执。不实故。住种种想造诸世业。若如是者。彼执我相以为其我。何名我所。谓贪欲。故名为我所以于诸欲与身和合即起贪心。起贪着已能坏戒蕴。便于他所生不善心。由嗔覆蔽互相轻毁。及于财物摄为己有亲近守护。是名我所。有我所者则有流转。有流转者则有迷惑。有迷惑者则有诽谤。有诽谤者则便有嗔。有嗔恚者则有吞害。有吞害者则为所烧。为所烧者则便遍烧。如是等过皆由贪欲。起男女想及以命想是我所有。名为我所。以是义故。说我所者则骂己身。一切愚夫。以我随眠为愚夫法。是故说之以为我所。迦叶。若有众生不闻此法。而说菩提及菩萨行。则为非行。言菩萨行者。实无所行是菩萨行。复次迦叶。若诸菩萨得行圆满无有缺减。清净极清净遍清净者。是人则能说此大法。名有势力勇猛精进。其所说法等于虚空而无积聚。为如理者。有功德者。能修行者。终不为彼不如理者。无功德者。不修行者。汝等应当受持此法。于是法中勿生执着。何以故。如来所说最为第一。为于最上应供。有情而发问故。我以胜法而为解说。云何胜法。谓无法想。迦叶。如是菩萨具足护持最初净戒。心不贡高。不造无间业。不犯比丘尼。亦不亲近诸俗人家。远离杀生及不与取欲邪行法。离虚诳语离间粗恶杂秽语言。远离欲贪嗔恚邪见。既不自恼亦不恼他。不与欲俱亦不受欲。不为博戏亦不教化。终不亲近不男之人。不往淫女寡妇处女之家。不近他妻。亦不亲近罗捕鱼鸟畋猎魁脍旃荼罗等。于饮酒人不执其手而与斗诤。离此诸事。如避恶狗旃荼罗辈。由住慈心。于彼一切所远离者。乃至不起一念恶心。有二十处应当远离。何等二十。谓离女人。亦不与他调戏粗言论义诤讼。于父母处及佛法僧。离不恭敬。若诸女人减二十众不为说法。除有男子。终不往诣比丘尼尼僧说法会处。不应问讯诸比丘尼。不与女人作其书疏。或为他人传书送彼。应付丈夫勿付妇女。于一切时亲族别请终不受之。不以欲心经须臾顷住女人前。又亦不应舍离本居往其屏处而与女人共为谈说。不得随逐比丘尼行。若比丘尼所施衣服不应受用。除在四众演说法时。为说法故有施衣者。应生是心犹如大地。然后受之。不应别观施者之面。若闻有尼劝导施衣不应受用。若比丘尼劝请受食。设令病苦终不受之。况复无病。若有寡妇而来请食。僧数不满亦不受之。又亦不应入尼众内。不应唤彼比丘尼来。若比丘尼来唤菩萨。应离住处拱手仰头背而舍去。若说法时有比丘尼来礼其足。无令足动。但应目视双手掌中。善男子。不应唯身修习精进。亦当勤心正念一处。于诸境界勿起贪嗔。为求一切智故。起坚牢誓。闻是法已。成就信心应当修学。迦叶。若有趣菩萨乘善男子善女人等。适闻此法。不能生于如实深信。终不能得阿耨多罗三藐三菩提。何以故。由修学故证彼菩提。非不修学而能得证。若不修习得菩提者。猫兔等类亦应证得无上菩提。何以故。不正行者。不能证得无上觉故。何以故。若不正行得菩提者。音声言说亦应证得无上菩提。作如是言。我当作佛我当作佛。以此证故。无边众生应成正觉。迦叶。若有众生修学此行。甚为难有。犹尚不能经一昼夜专念在心。何况一劫乃至千劫。是故如来出现于世。甚为难事。迦叶。假使三千大千世界一切众生。若经一劫百劫千劫乃至亿百千劫。为一众生同唱是言。汝应作佛汝应作佛。是诸众生。悉共围绕相续唱言。当得成佛当得成佛。如是次第。出息入息犹可断绝。彼所发言曾无间断。如是之言。尚不能熟初菩提心。何况能证无上佛果。若能证者无有是处。迦叶。我灭度后末法之时。及与汝等已般涅槃。不为诸天之所信护。当于尔时。多有众生闻我功德。发菩提心。于中或有诸比丘等。虽发无上菩提心已。而便安住二十法中。何等二十。所谓亲附诸比丘尼。受不净食。贪着美味。受比丘尼劝化饮食。迦叶。譬如今世多闻比丘住阿兰若或聚落中。勤修习法。于当来世诸比丘等。亦复如是。于聚落间或阿兰若。与比丘尼聚集言谈问答法义。彼诸比丘及比丘尼。多生染心少生法心。迦叶。汝观是辈得菩萨名。堕大危险取于恶趣。当于尔时初为法缘而相亲附。互相见已欲火烧心。动于唇口表其欲念。彼相近时初为弟子。以阿阇梨法而申礼敬。自此之后当渐遣使。通致语言道路期会。或于街衢或在寺内。遥相瞻视。于出入时问其所由。互称亲族结为姊妹。彼等由是数相见故。而相习住。既习住已生于染心。生染心已共为秽事。为秽事已更以非梵行名而相呼召。由行非法退失菩提及以善趣。远离涅槃弃舍如来。违背正法厌恶于僧。在于屏处。起欲恚害诸恶寻思。是人无有菩萨胜业四净梵行。譬如今时勤修梵行诸菩萨众。于未来世起欲恚害恶寻思者。亦复如是。迦叶。当于尔时住是种类。所谓恶行贼行矫行。汝观尔时毁禁戒者。闻是等经便生诽谤。若有已能住戒布施。生于欢喜发菩提心。后闻是经复生谤毁。汝观尔时有此相貌。可为记验。若闻是经而生诽谤。于中智者。修净戒者。持正法者。知是经内说此比丘名不知法。即应舍离。如是等人。此辈无心爱敬法故

大宝积经卷第一大宝积经卷第二

        大唐三藏菩提流志奉　制译

    三律仪会第一之二

复次迦叶。当于尔时。有人诈现修菩萨行。便自显扬生于放逸。生放逸已。谓胜独觉及阿罗汉。住于非理。名不可治。当堕恶趣。复次迦叶。未来有人住于非业作非业故。取众生相为说法故。处处游行唯修似行。极似布施持戒安忍精进静虑般若波罗蜜。炽盛流布。若有如实说是经者。则为他人憎嫌舍弃。于是经中。起邪见想。是愚痴人不知此经呵责破戒。迦叶。当于尔时。皆为贼行之所秽污。是故彼人不思己过。能甚破坏正等菩提。由覆藏故怀羞而谤无上佛果。复次迦叶。当尔之际。不随顺僧。不知恩报。而行开发。云何开发。谓开发他心。如来说彼数以语言诳惑他故。招致饮食。迦叶。当于尔时。不护语言。诃毁如来别解脱戒。复与不护语人同其事业。不摄威仪住不净处。为住不净处者。说诸法门。此法渐当为人轻贱。如是渐渐。多有女人弃舍丈夫入于寺舍。为闻法故而便就坐。时有比丘。即为宣说相似涅槃。迦叶。我观尔时。有五百数非法之门。不修行人常当随顺。五百烦恼悉无所减。诸有所为与俗无别。当有如是大可畏事。而复于中希望利益。是故求菩提者。不应亲近诸比丘尼。亦不应行如是之行。常当舍离一切交游。应一切时舍诸利养。受行乞食。舍所爱服受粪扫衣。弃舍一切楼阁房宇床铺卧具。应住溪涧岩窟树下。舍离一切病缘医药资具所须。依陈弃药。知诸众生昔为亲属。行大慈心。常应忍受捶打呵骂。终不捶打毁骂他人。舍离一切知友施主诸眷属家。应当随顺自业行智。不应同彼在家俗人。常应顺奉波罗提木叉教。迦叶。世若有人于别解脱起违背想。则为于佛力无所畏而生违背。彼若于佛力无所畏生违背者。则于去来现在诸佛而生违背。由此未来所受异熟无量大苦。假使三千大千世界一切众生。受地狱苦。比前众生所受苦毒。百分不及一千分不及一。百千俱胝乃至算数譬喻。优波尼沙昙分亦不及一。若欲远离如是苦恼。应当远离如是种类恶行。比丘纵远相去千踰缮那。亦应遥避。何况近耶。若但闻名尚应弃舍。何况见闻而不远离。是故应当亲近一法。何等一法。谓一切法悉无所有。若得诸法无所有忍。则不亲近供养承事如是恶人。是人复应亲近二法。云何为二。谓求诸法本无所有。及求诸法性。而亦不应起于求心。应云何求如所求者都不可得。不可得中不应起无所得心。犹如邪见。如是离一切三界心顺菩提行。离一切相心。顺菩萨行。菩萨行者。谓前所说为菩萨行。是故闻此法已应舍离之。则于来世亲得奉事弥勒世尊。心不贡高亦不卑劣。作是唱言。快哉安乐。我得解脱魔之罥网及诸恶趣。迦叶。若于后时闻是经典。不惊不怖。及见己身于中随顺。复能发心受持此教。佛知是人定当守护我之正法。迦叶。譬如长者财宝无量。子于家中。乃至见一盛水之器。起父财想。彼于异时。其父丧亡资财散失。忽见其器寻自念言。是我父物。将置身边或时藏举。迦叶。当于尔时。诸比丘辈亦复如是。闻此经已作是念言。此是如来柔软微妙大梵音声之所演说。复有比丘闻已诽谤。持法比丘作如是言。此最真实如来所说。彼持法者。人众微少住处劣弱。将如是经昼夜藏举。极遭诽谤。如是等人我亦知见。悉皆付嘱弥勒世尊。于最后时。当为卫护如来法城。次后当为无碍大施。复次迦叶。若善男子闻是法已。随其智慧而修行之。成就深信正见众生。于当来世遇弥勒佛。初会之中具修梵行。于最后时。亦当卫护如来法城。迦叶。我今普观。乃至不见一人不亲近我。于当来世五十年中。闻是经典不生诽谤。则能受持读诵之者。无有是处。若于此时。得见我身。及以奉事供养之者。彼于来世五十年中。当得读诵受持是经。不待于我叹其功德。彼等自成一切智智同一体时。随念于我。心生欢喜作如是言。希有奇特释迦牟尼佛。善能摄受护念我等。是故迦叶。应学此法。学此法者。随所乐求一切功德皆不难证。尔时大迦叶白佛言。世尊。我已究竟无复志求。于此法中。退于阿耨多罗三藐三菩提。我于是中极为知足。终不能成一切智智。世尊。无上菩提是希有事。于我声闻难为证得。佛告大迦叶言。我不为汝说。然今因汝为他敷演。汝今勿于如是大事而生疑惑。汝等亦当速证无上正等菩提。复次迦叶。若诸众生成渴法心。成求法心。渐次皆证无上菩提。既证得已。为断一切希求心故。与诸众生宣说正法。迦叶。菩萨应当成就四法发大精进。何等为四。云何精进。所谓不求色受想行识。求无漏法。谓无地界。无水火风界。不说地界。不说水火风界。所有言说悉名表示。是表示法皆非实有。菩萨不应取表示法以为坚实。时大迦叶白佛言。世尊。我等于如来所实无疑惑。若他问言。是表示法非真实者。佛之音声言说表示为虚妄耶。若有此问当云何答。佛告大迦叶言。于未来世有诸比丘。不修身戒。心不识义理。嗔恚炽盛言辞粗犷。于是经典不能受持如法读诵。何以故。彼住色受想行识生心故。未来比丘。住是经典表示法中。如住色受想行识生故。复有一类诸比丘等。住在家法。于胜义谛无复志求。如生盲人以金华鬘冠饰其首。而不自见。当于尔时。诸比丘辈亦复如是。闻是等经言说文字。尚不受持。况复能入所修胜义。譬如幼童若男若女。为大丈夫之所诃叱。此幼男女。于后异时。闻是人名惊恐怖畏。当于尔时。诸比丘等亦复如是。闻此等经如实说过。知已不悔乐好衣服。返于是经而生怖畏。迦叶。如系虾蟆在猕猴手。而此猕猴面不回顾。当于尔时。诸比丘等亦复如是。闻此等经违背不顾。不住其前。迦叶。譬如野干为狗所逐走趣冢间窟穴深坑。当于尔时。诸比丘辈亦复如是。闻说此经如野干走野干走者。谓犯禁戒诽谤是经。闻是经已退道还家。驰求欲境趣向女人。趣于斗诤喧杂医术及以断事。而于其中多犯禁戒。我说此等如趣冢间。身坏命终堕于恶趣。如趣窟穴。驰骋剑叶刀刃枪林诸大地狱。如趣深坑。迦叶。当于尔时诸比丘辈成就如是野干之法。不能悟入如是等经。但能毁谤称扬过失。身坏命终堕大地狱

复次迦叶。若有比丘作如是言。若表示法非真实者。如来言说亦非实耶。彼若说言。佛之表示名为真实。诸表示法亦应名实。有智比丘应问之曰。大德今者为执何事。为执空耶。为表示耶。彼若说言。我执表示。应报之曰。汝即是佛。何以故。汝有言说表示法故。彼若说言。我执于空。应问彼言。当为我说。执何等空。何以故。不可言说名之为空。若执表示以为空者。或于我我所众生寿者。非空执空。又问彼言。汝意云何。乐一切法空不。彼若答言。我不喜乐一切法空。智者言曰。汝久忘失沙门释子。何以故。佛说一切空无我故。不说有我众生寿者数取趣故。彼若说言。一切法空我乐空性。应语彼言。汝心尚乐一切法空。况复如来应正等觉。复次尊者。为眼是如来。耳鼻舌身意是如来。彼若说言。眼是如来。耳鼻舌身意是如来。应语彼言。汝于今者。亦是如来。彼若说言。眼非如来。耳鼻舌身意亦非如来。应语彼言。仁者汝作是言。眼表示非如来。乃至意表示非如来。即非表示是如来也。我于此处岂不悟耶。彼若说言。眼非如来。亦不离眼而有如来。乃至意非如来。亦不离意而有如来。应语彼言。如来所说十二处有。谓眼处色处乃至意处法处。此即众生及众生名字。仁者。为眼是如来非如来耶。乃至法是如来非如来耶。彼若答言。眼是如来乃至法是如来。应告之曰。如仁者言。一切众生及山林大地应是如来。彼若答言。眼非如来。乃至意非如来。复应告曰。如仁者言。如来即法及以非法。彼若说言色非如来。乃至法非如来应告彼言。若如是者。岂以非法为如来乎。彼若说言。即以非法以为如来。应告之曰。若如是者。所有众生。不孝父母。不敬沙门婆罗门及诸尊宿。杀害生命。犯不与取。行欲邪行。虚诳离间。粗恶杂秽。贪嗔邪见。应是如来。彼若说言。非非法而是如来。应告之曰。非法非非法应是如来。若非法非非法是如来者。则无表示。仁者。无可表示是如来耶。迦叶。应当如是折伏愚人。我不见有世间人天。能与如是如法说者。而共对论。唯除嗔恚愚痴之人不堪忍者。虽为开示不生信心。毁呰空法弃舍而去。迦叶。汝等应当受持是经。于未来世有诸比丘。持是经者。当得三名而为表示。何等为三。谓说断灭。无物无蕴及无恭敬。当尔之时。如是经典为他诽谤。汝观尔时。不恭敬佛。不恭敬法。但依表示名字语言。虚荷僧名而无实德。虽称佛号于他开示而不能解。云何可得瞻奉如来。虽说佛法。而不能知如来意趣。云何得名为善说法。四双八辈是佛弟子。声闻之僧。但知其名。于彼功德不知其义。不能领受依名实德。为于衣服饮食卧具病药缘故。毁谤于法。菩萨于中应勤精进。于是等经。深生希有乐欲之心。受持读诵。何以故。是人来世为护法城。迦叶。我念过去九十一劫空无法时。如是等经不复流布。又念过去超于千劫。有佛出世。号休息热恼。住世八万四千劫。成熟菩萨利益世间。又念过去。复有如来。号无边力。住世二十亿劫。于二十亿劫行菩萨道。然后证阿耨多罗三藐三菩提。迦叶。汝观于佛。修习几何难作之行。摄诸众生。复次迦叶。劫浊尽世。我等不应轻贱己身。何以故。于劫浊中。乃至一人能于我所信解此法甚为希有。一切众生不持刀杖。追逐我等亦为希有。何以故。此法即是善丈夫法。谓于诸行为无行想。难了知故。若有我见众生见命见数取趣见有见。若依诸蕴起于戒见若多闻见佛见法见涅槃见。若有起于涅槃见者。如来悉知见为邪见。何以故。佛于涅槃而无分别亦无所得。若于涅槃起于分别及有所得。如来尽说名为邪见。若邪见者则名无智。若无智者名为损害。若损害者名曰愚夫。名愚夫者。于大菩提则无乐欲。乃至远离生天胜道。迦叶。于未来世。当有比丘。年纪二十三十四十乃至百岁。为老所侵。庄严衣服。虽剃须发毁坏威仪。老病衰朽无有威光。趣向邪法。临命终时。由罪意乐之所障蔽。熟思已犯懈怠不修。而于三处示现证得。何等为三。或矫现威仪。或复诈现修持净行。或举手自称言。我无与等。以此三处示现有证。斯人咸堕增上慢中。临命终时心生追悔。既命终已生地狱中。是故迦叶。我今分明宣告汝等。我为汝等真善知识。乐欲利益哀愍汝辈。不令于后受大热恼。如慕理迦(唐言尾宿)。畔地迦(唐言路生)。波利婆罗理迦(唐言女梵志)。受诸苦毒。迦叶。我终不听执着我见众生见寿者见。补特伽罗见者。于我法中而得出家。我若不许强出家者。皆为是贼。食重信施。亦不成就真比丘戒。迦叶。宁当绝食至于六日。不于我法得出家已食重信施。起于我见众生寿者数取趣见乃至涅槃见。是故菩萨应发精勤不应执着我众生寿数取趣见有见涅槃见。为断一切见故应当说法。迦叶如是等经。我今付嘱诸菩萨等。何以故。彼等意乐同于我故。若彼意乐同于我者。是我伴侣。我伴侣者。则便堪能受我付嘱。尔时世尊而说颂曰

  众苦所逼迫　　都无能救护
  唯除世导师　　无有戏论者
  诸苦恼众生　　修下劣邪道
  渐增诸欲贪　　由斯堕恶趣
  无导无救护　　住之崄旷远
  趣向邪道中　　终无安隐处
  譬如人持财　　求利行远道
  于中群贼起　　劫尽诸赀财
  失财已空归　　为利增热恼
  所贷他人财　　被债倍生苦
  斯等亦如是　　为法故出家
  本所持法财　　白业皆销灭
  唯净剃须发　　愚堕诸见中
  执着我众生　　补特伽罗想
  说空法比丘　　不着数取趣
  于此起谤心　　速堕于地狱
  以嗔恚因缘　　递互相诽谤
  自犯畏人知　　妄宣他过失
  身恶及口恶　　意业多谀谄
  颠倒随见流　　斯人生恶趣
  造诸恶业已　　速疾往三涂
  众苦所烧然　　无能救护者
  未来有比丘　　卒暴多嗔恚
  逼恼诸出家　　趣向菩提者
  此诸可畏众　　诽谤如是经
  不复能信受　　释师子之教
  互起嗔恚心　　递共相苦切
  更相扬过失　　恶名遍十方
  虚加恶唱他　　于己便生耻
  柔和者劣弱　　邪友势力增
  是知正法衰　　恶人多势力
  我之所爱子　　谓诸善比丘
  应趣向余方　　往求安隐处
  从恶得解脱　　于此起悲心
  宜于是经中　　当自审思念
  佛有如是教　　当乐住余方
  正法灭坏时　　柔和者难得
  相随俱往诣　　如来称叹所
  或有言此处　　可离不可居
  当诣大仙人　　得大菩提地
  复有称仁者　　汝实善为言
  绕塔以求真　　是名世尊教
  宁当至于彼　　悦意菩提地
  不可恒此居　　没于嗔迫所
  比丘当诣彼　　为我故应行
  见佛所游方　　昔曾安止处
  经行宴坐地　　若石及空闲
  集已共咨嗟　　为之数啼泣
  言是彼大仙　　经行受用处
  昔日曾游止　　转无上法轮
  有为悉无常　　我等今不见
  人及非人等　　天龙皆会集
  善化令欢喜　　何乃见空虚
  时往道场中　　最胜菩提地
  同来集会已　　当如理思惟
  世尊于是处　　成无上佛果
  惊怖恶魔军　　犹如野干众
  是为道场地　　大觉所端居
  过去及未来　　一切诸佛座
  安处大雄尊　　亿天所敬礼
  七日加趺坐　　谛视菩提树
  瞻观供养毕　　次往鹿林中
  言此转法轮　　声闻于梵世
  彼诸比丘等　　当为数悲啼
  为欲调五人　　导师来至此
  五人初见佛　　各起忧恼心
  立制自相要　　我等勿为起
  时大悲世尊　　哀愍群生类
  为五比丘说　　甘露果时成
  礼转法轮方　　心悲数啼泣
  次往涅槃处　　感佛最后身
  于此双林下　　利益群生类
  碎身分支节　　于兹般涅槃
  呜呼大圣尊　　释迦大寂灭
  今但闻其名　　惜哉我不见
  大师复于此　　最后度善贤
  能以智先知　　此为最后度
  或修时寿尽　　或发趣命终
  或修己身亡　　彼皆生善趣
  从于彼时后　　深广法沉沦
  持戒毁禁人　　皆当得供养
  受他重信施　　速堕恶趣中
  汝观诸比丘　　有如是差别
  智者修虽后　　速受人天身
  是等照世灯　　怜愍世间者
  大智诸菩萨　　慈心利众生
  常作勤修事　　勇跃心欢喜
  当成大觉尊　　亦逢事弥勒
  供养彼如来　　众中蒙授记
  随心所忆念　　为彼大威神
  我说诚实言　　安慰如是辈
  彼虽不见佛　　而与见佛同
  我昔求菩提　　礼敬于诸佛
  若诸女人等　　趣无上菩提
  我及无量佛　　皆当安慰彼
  速成男子身　　得见于弥勒
  供养彼如来　　所求悉如意
  应学诸智者　　净信而出家
  坚固乐欲心　　多闻学持戒
  于弥勒佛前　　得受其记莂
  是故闻胜利　　起信修善贤
  安住坚固心　　摄诸众生类
  谁于如是处　　求而不得之
  有慧及精勤　　菩提不难证
  修习慈悲念　　舍离谄曲心
  常乐在空闲　　是则菩提道
  若人于是法　　空说不能行
  众皆礼敬之　　此为可畏贼
  若人为饮食　　及诸利养事
  受持正法门　　互共相传说
  斯恶活命人　　名为空过世
  于此舍人身　　恶趣受众苦
  或于佛法内　　假名为比丘
  诽谤于契经　　善说解脱禁
  言我具弘宣　　所有木叉教
  虽为比丘像　　终失人天身
  若诽谤人天　　及毁一切智
  如是谤法人　　得罪复过彼
  善防身语意　　令不起诸恶
  能除此三行　　必当得涅槃

复次迦叶。如来灭后。昔于佛所深种善根诸比丘等悉般涅槃。具胜意乐诸众生类命终复尽。后五十岁正法灭时。当有比丘性怀贪着。猛利贪欲映蔽其心。乐离间语毒害于他。言词粗犷惨励颦蹙。住三法中。何等为三。所谓医道。贩易。亲近女人。住此三法。退失四事。何等为四。谓退戒蕴善趣果证如实见佛。由退此四。复成四法。不生厌离炽盛增长。云何为四。所谓嫉妒增长炽盛。嗔恚恶心增长炽盛。耽着种族增长炽盛。贪着饮食积聚众味。爱乐衣服映蔽心故置之箧笥。专行此事以为常业。于沙门法空无所获。亦不发生沙门证道。闻是等经当堕四处。何等为四。谓堕谤法。佛所不许而反说之。独为女人宣说法要。毁谤如来别解脱戒。闻是等经转加坏法。而堕生长恶业之中。迦叶。譬如恶狗以苦胆灌鼻。于意云何。彼狗倍生凶恶心不。迦叶白佛言。世尊。如是如是。佛告迦叶。彼等恶人犹如恶狗及毗舍遮。见有比丘住净意乐。持是法者。说是法者。住于真实少欲之者。叹少欲者。于是人所不生欢喜而起厌背。心怀怯劣复生热恼。以其嗔恚障蔽心故。作是念言。我等住在非时非处。于非时中而为他人轻毁我等。是故闻说如是等经。起于诽谤面加毁辱。嗔恚粗言此非佛教。此辈受用多欲因缘。非少欲者。迦叶。我种种名。赞叹少欲及以喜足。名为易养。亦名易满。名净除者。行头陀者。极端严者。我亦赞叹住阿兰若者。发精进者。遍净命者。汝等不应多修贮聚箱箧等法。何以故。应当修习如是法故。汝等不应犹如铜钹空有其声。应顺如来修行此法。又亦不应起重嗔恚。亦复不应摄取事物。应当住于无事无物。勿于处所生住着心。应无所住。不应自赞。亦不应畜牛驴等类。不应成就住懈怠处。应当发起殊胜精进。舍离不善摄受善法。迦叶。我种种名赞叹寂静。住阿兰若不处愦闹。今于是中。种种名说极净除行。若有不住极净除者。具大欲者。成罪恶者。即当诽谤诸有安住极净除者。迦叶。譬如愚夫于四月中。服苏患渴。寻诣池所求水而饮。他人谓曰。汝已服苏勿复饮水而致命终。是时愚夫嗔蔽心故。毁呰骂詈不顺他言。饮水而死。迦叶。如是如是。未来比丘。贪著有见住不善行。有持法者。作是教言。此是应作。此不应作。彼恶比丘嗔蔽心故。毁呰骂詈谤是经典。迦叶。今时尚有于如来所多兴诤竞。何况未来。汝且观是贤护比丘。如来制戒。令诸比丘受一坐食。嗔蔽心故。于夏三月不至我所。迦叶。今于我前。尚有如是轻梵行者。况佛灭后。贪着饮食衣钵病药。睡眠所覆嗔恚猛利。如是比丘闻是法已。尚不恭敬如来大师。岂能敬彼持法比丘。迦叶。名为不善。亦名极恶。如是法宝即当隐没。于中若有求大利益。善男子善女人。信我教者。后滓浊世极覆藏时。善人难得。时闻如是等甚深法已。应为如理者说。不为不如理者。为信者说。非不信者。我今亦为如理者说。非不如理者。为信者说。非不信者。迦叶。譬如恶马不受被甲。若同良马为被甲者反生惊怖。何况更闻螺贝鼓声。能堪受者无有是处。如是如是。破戒比丘。无有时分堪能忍受善丈夫法。犹如恶马反生惊怖。迦叶。破戒比丘。乃至闻说一言诸法无我。执我想故。于中便生怖畏诤竞。何况闻说被善甲耶。若被甲已。即能降伏百亿魔军。而令毕竟不生斗诤。诸善比丘被精进甲。不破根本头陀功德。净除根本。无贪恚痴根本。无嫉妒根本。离欲根本。独处性根本[宋-木+悎]寤根本。于一切时一切种中。不应发起恚贪之心。于种种物无所希求。如是被甲名无根本。若被如是种种甲已。应发无上菩提之心。于一切处不应执着。况起我想。是故不应起于我想。众生想寿者想。数取趣想。女想男想。地水火风想。欲界色界无色界想。持戒想破戒想。空性想。取要言之。一切诸想皆不应起。以一切想无所得故。迦叶。贪若实有则应了知。近之令灭贪爱之心。非住一处无住可得。唯除妄语。是故如来名实语者。如来说之诸所有贪皆为非我。如是诸法是沙门法。诸沙门法皆无所得。若复有人着此想者。是人则为着我想等。如须弥山。退失圣教诸沙门法少不可生。亦复不能住沙门法。如是广大最胜之法。于彼愚夫痴所衰损。少不应说。何以故。若执少法。则当摄受极怖畏处。大地狱中住之一劫。迦叶。汝观俱迦利比丘(唐言恶时者)。提婆达多比丘(唐言天授)。骞荼达罗比丘(唐言鈌财)。迦卢底输比丘(唐言器鬼宿)。母达罗多比丘(唐言海授)。阿湿繁比丘(唐言马腾)。布那婆苏比丘(唐言柳宿)。苏气怛罗比丘(唐言善星)。是我给侍。亲对我前。闻我说法见我经行。见我端坐。见我神足游处虚空。见我降伏多千外道于大众中摧彼邪法。如是等人。尚于我所不生信乐。于步步间恒欲毁我。由是步步渐增其恶。复次。若说佛名信为实者。应持上器如须弥山盛栴檀末而散其上。应作伞盖犹如三千大千世界。持在空中而覆其上。何以故。为信佛故。何况信已舍欲出家。无所依倚修诸静虑。迦叶。如是众生。于中忍可极为希有。能善护持佛所制戒。则能了知彼甘露法。如大众中。以其皮革及余臭秽。共制人像。或造种种诸杂面相。彩画庄饰令极端严。有人持之置于面上。或以衣物缠裹游行。岂以相貌谓为好耶。审知秽恶便生厌离。如是如是。诸恶比丘。以如来威德容仪严整审谛观察。方知极恶由自他我想而生贪爱。若人了知我想非实。闻是等经不生嗔恚。何以故。由为他人毁呰违逆。闻此等经倍增厌离。若有众生心怀执着。当知即是邪见之人。若起邪见。于是等经如实教诲。即生嗔恚。何以故。有我想者有嗔恚故

若有比丘比丘尼优婆塞优婆夷。闻是等经嗔恚毁坏诽谤之者。即非沙门。虽复说有沙门名字。非我声闻。我非彼师。何以故。是我声闻则不妄语。我非妄语之师。何以故。如来是实语者。能如实说一切法空者。迦叶。如来能破我执。与之斗诤。若与如来诤者名为恶魔。如来不许魔众出家受具足戒。如有人言。青雀小鸟生大龙象。于意云何。如是之言为可信不。迦叶白言不也。世尊。佛告迦叶。于意云何。为等类不。迦叶白言。非为等类。复次迦叶。又如说言。妙翅鸟王生于飞鸟。于意云何。为可信不。为等类不。迦叶白言。不也世尊。亦为非类。复次迦叶。又如说言。萤火小虫负须弥山飞空而去。于意云何。为可信不。为等类不。迦叶白言不也。世尊。亦为非类。佛告迦叶。如是恶人。若住我想乃至涅槃想者。称我为师转为非类。迦叶。如有帝王安住国界。抚育群生快乐无极。种种饮食自然成办。傍有侍臣奉王正化。时有一人众未曾识。为财利故随学臣法不禀王命。自于大臣王等众中。诈宣王制。作如是言。汝等应当止住于此或言汝等作如是事。迦叶。如来法王亦复如是。王大千界摄化一切三乘众生。十力功德圆满成就。作诸佛事安乐无边。饮食供养自然丰足。于中一类众未曾识。为活命故说我众生乃至涅槃。不受如来无我圣教。作如是言。如来所说此事应作。此不应作。于中有人。信佛顺教不诽谤者。闻其所说。谓是胜妙清净福田。辍己资财及妻子分。殷重信心如法施与。乃至未觉诸过。已来初无断绝。如是恶人。同于众人所未识者。饮食既终。于聚闹处。日日谈说王事。贼事。食事。淫事。女人事。医方事。饮酒事。日月博蚀事。王者来去事。种族事等。或言吉日应行他所当得饮食。如是等类种种言谈。推度昼夜还僧伽蓝。或经二宿乃至六夜。随所住处亦常谈说如是等事。无正念慧失坏威仪。昏痴睡眠涎唾流溢。随所想像睡梦中见。或见己身往诣他所。疾行缓行种种诸事。既[宋-木+悎]寤已互相向说。或梦汝身如是行坐。从如是处有得不得。复有说言。此梦吉祥。宜时速往村邑王城至他家处出入往来。摇动面目。苦逼恼故心不安和。无等引定贡高自举。诸根秽杂与俗无殊。言不应时。心多驰散乐游俗里。诸族姓家。不能奉持别解脱戒。独为女人宣说法要。于说法时心住贪染。而于是中增获利养。染着之心犹如噬啮。愚痴耽爱增住增着。不生悔故。于别离时啼泣而去。又于二处开示他人。云何为二。得净好施便赞叹之。得非净好即便毁呰。相会遇时互看所得。复相问言。施主今者为施何物为施与谁。饮食资财几多几少。迦叶。当知是谓不修行者。乃至命终之所言说。不修行者。复有余过。生恶意乐。谓谤正法。迦叶。应于如是诸比丘辈生怜愍心。何以故。以其当受苦恼果故。尔时世尊而说颂曰

  愚夫缘活命　　随学帝王臣
  故往诣余处　　诈宣王制令
  至彼传密言　　勿致王嗔罚
  愚人于此处　　亦以活命缘
  何况最胜佛　　于多百劫中
  舍身支节等　　及作多难事
  我非法王家　　僮仆被谪罚
  亦无问者能　　为作为不作
  施与比丘房　　上妙美珍馔
  及施上妙衣　　一切恭敬与
  勤苦求财物　　奉施持戒人
  不以自供身　　亦不将供子
  不如法住者　　食之便舍去
  共相会遇时　　言我快意啖
  所在聚集处　　说王事贼事
  关逻镇守事　　种种饮食论
  说日月博蚀　　及王来去事
  或言当得胜　　或说当败亡
  此非所应言　　常共数论说
  极妙卧具上　　昼夜耽睡眠
  昼往善人家　　求多富有处
  言此施非少　　亦非为最上
  寻思是事已　　安敷空坐谈
  愚惰不勤修　　如驴恒负重
  而于眠梦中　　见所分别相
  觉已宣示他　　相向益谈说
  言勿忧勿笑　　汝当得安乐
  此事宜速成　　勿复生忧恼
  数往于村邑　　动止无威仪
  喻若行猕猴　　回转于面目
  入于聚落内　　为女说法言
  弃舍佛契经　　及善别解脱
  既从施家出　　观其物少多
  见少则骂他　　亦毁他眷属
  于相会遇时　　发言互相问
  得何物何食　　相问答何事
  略说如是事　　经于百年中
  如是所寻思　　以为自活命
  争蒲桃酒味　　及以香华等
  为药疗其身　　求之少病恼
  假令有百佛　　无能奈彼何
  弃舍所修行　　与在家无异
  于身生保爱　　不离于我人
  彼作是修行　　由斯堕恶趣
  若人谤正法　　重苦所烧然
  无觉慧愚夫　　与在家无别
  若诸释师子　　修实行声闻
  不以活命缘　　毁犯微少戒
  智者不贪食　　常生重檐想
  不净观修心　　以还施主债
  舍离欲漏故　　了知一切想
  我听如是等　　此教中出家
  智人不诽法　　于所说空性
  数数起勤求　　不可得坚实
  勇健大智人　　了知空性理
  能怖畏魔军　　彼堪销供养
  若能离贪染　　不毁于空性
  佛子勇健人　　两足中应供
  正法不久住　　生世多愚痴
  少柔和比丘　　求不放逸者
  智者应生忧　　不久自磨灭
  后于昼夜间　　谈说曾有我
  世间无救护　　唯除两足尊
  修行学处人　　悉皆当灭没
  彼不了如是　　所有密意言
  则不恭敬佛　　及无上正法
  正法当尽灭　　应速发精勤
  乃至少时间　　听闻当不久

大宝积经卷第二大宝积经卷第三

        大唐三藏菩提流志奉　诏译

    三律仪会第一之三

尔时尊者摩诃迦叶白佛言。甚奇世尊。如是人等闻此等经不生厌离。佛告大迦叶言。若有众生成就四法。闻说此经不生厌离。云何为四。多放逸故不能深信。业异熟故亦不深信。大地狱故不能审信。我当死故。若人成就如是四法。不生厌离。迦叶。复有众生成就四法不生厌离。何等为四。年盛壮时自恃强力。耽着欲乐。贪嗜诸酒。不能了知明思惟观。若人成就如是四法。不生厌离。迦叶。若有比丘。成就四法谤佛菩提。何等为四。本造恶业已成就故。毁坏正法。如是比丘不自发露不善异熟诸恶业故。于比丘尼行秽欲故。彼有和上或阿阇梨。多人所敬谤佛菩提。如是弟子。随学于师亦生诽谤。是寡闻者。由嫉妒故谤毁诸佛。比丘成就如是四法。谤佛菩提。迦叶。若有一法得成沙门及婆罗门。何者为一。于一切法心无所住。如是一法。得成沙门及婆罗门。譬如有人堕高山顶。谓无大地树木丛林。唯起空想出入息断。迦叶。着诸法者亦复如是。若执眼想及以眼相。执耳鼻舌身意想乃至意相。若执色受想行识想。执净持戒多闻惭愧经行往来得菩提想。如此等法皆悉非作沙门婆罗门。若起想者则为所害。为谁所害。谓贪嗔痴。若执眼相。由着可爱不可爱色相故。为眼所害。如是执着耳鼻舌身意相。乃至由着可爱不可爱法相故。乃至为意所害。若被害者。则于地狱畜生饿鬼人天界中。极为所害。何缘被害。由想执着。何名想着。谓执我想及我所想。女想男想。地水火风想。骨想坏想青瘀想血涂想。色变想离散想。胜解脱想。彼有少分得胜解脱想。此有少分不得胜解脱想。有无量种宿住随念现证作想。我随念想。异于过去异于现在。我是过去我是现在。于诸法中起想执着乃至涅槃想我得涅槃想。迦叶。以要言之。诸执著者处处起想。乃至于空性中起一切想。皆悉非作沙门婆罗门法。非沙门行。非婆罗门行。迦叶。如来说言沙门婆罗门法者。譬如虚空及以大地。何以故。虚空之法。终不念言我是虚空。如是迦叶。沙门婆罗门者。终不自谓我是沙门是婆罗门。是故诸法亦不自谓是作沙门。婆罗门法。沙门法者不作不除。是为沙门及婆罗门。迦叶。譬如有人于夜闇中。掉弄手臂摇动面目。作如是言。我弄世间我弄世间。于意云何。彼为弄谁。迦叶白言。世尊。是人自弄。何以故。于中无人为可弄故。佛告大迦叶言。如是如是。若有比丘至阿兰若。或至树下空室露处。作如是想。眼是无常。耳鼻舌身意悉是无常。复作思惟。色是无常。声香味触法亦悉无常。作是思惟。我趣涅槃。如是等类为自劬劳。非沙门行。何以故。以有若干诸邪执故。知眼相已。为灭眼故勤劳修习。如是能知耳鼻舌身意相已。乃至为灭意故勤修习之。若于三处了知信受。则于三处而生分别。若于诸见起分别者。云何能得心一境性。迦叶。甚深菩提难入难趣。难具资粮。心一境性者。为以几何名心一境性。周遍推求乃至一法亦不可得。所谓于眼不可得实。于耳鼻舌身意亦不得实。于一切法皆不得实。何以故。本性如是心性不生。一切诸法无实可得。是故彼心不可得也。若过去未来现在无所得故。无所作故。是谓无所作。何名无所作。若新若故俱不可作。名无所作。是中过去心不解脱。现在心不解脱。未来心不解脱。随所有心无所得者。是为心一境性。此即名入心之数也。迦叶。未来当有比丘比丘尼优婆塞优婆夷。执着眼等说为灭坏。于诸蕴中起于物想。如来说蕴犹如于梦。然彼说言梦为实有。由世间中说有是梦。若无梦者。我等不应有梦想事。以有表示。是故我等于其眠梦起于梦想。如是如是。蕴有所因故说如梦。若无蕴者不应说蕴犹如于梦。彼诸愚夫谓梦为实。闻是等经便生诽谤。于中当有比丘尼等。于施主家妄称我是阿罗汉果。或依浅智说现证得。若优婆塞优婆夷等。闻经律颂说我现证。迦叶。当于尔时。若有比丘。或二十年三十年中。常乐居止阿兰若处精勤修习。为佛法故来诣初信一日优婆塞边。唯以空言互相唱说。言空空故。我已遍知我已遍知。或有比丘。闻是经等相向谈说。有人闻之便生怖畏。复作是言。若诸在家出家人等。不应亲近。应当远离此非教师。何以故。彼等所知不相亲附。复有宣说甚深法者。为诸在家出家人等。弃舍轻贱。何以故。我今宣说胜妙梵行。尚少知者。况未来世乃至最少知者亦皆灭没。当尔之世。说法比丘千人之中。能如实解信入法者。一亦难有。乃至二千亦复如是。于中或有余比丘等。下至不能暂发言词。况能解了。迦叶。当于尔时。在家出家共轻此教。若有比丘发勤精进。为灭不善生善法故。初夜后夜减省睡眠精进修学。则为他人讥嫌弃舍。或断命根。如是等经即当毁灭。住法比丘亦皆灭尽。于中智者深胜无染解了之者。应当尊重深心恭敬共集会已住阿兰若。尔时世尊而说颂曰

  我所说善法　　第一义相应
  言蕴无坚实　　应观察如梦
  尔时诸比丘　　斗诤心纷扰
  无礼别尊卑　　唯有空名相
  比丘所发言　　俗亦如是说
  如斯之教法　　道俗语皆同
  比丘谓俗言　　汝解法希有
  是谓佛菩提　　已发初地果
  彼心谓见法　　亲近在家人
  数奉施比丘　　与其最上供
  如斯比丘说　　无异语皆真
  与彼共相亲　　言我能见法
  生于彼时者　　为施故出家
  不住正法中　　毁坏菩提道
  我示汝道者　　近我勿亲余
  不久汝得之　　还如我所得
  此最寂静位　　共汝相向言
  和合大众中　　毁坏我教法
  犹如劫村贼　　性怀凶险心
  破坏诸国城　　及以大聚落
  比丘亦如是　　无智多愚痴
  少慧起诸非　　着命数取趣
  离我所说教　　依止诸见心
  说是罗汉人　　尽怀增上慢
  于大和合会　　诸比丘众前
  说已慧名闻　　于中一难得
  或时有比丘　　安住如实者
  被说恶名闻　　言非佛弟子
  法王大菩提　　于时被诽谤
  天众怀忧戚　　相向数悲啼
  对彼信心天　　身自投于地
  观斯释师子　　无上法轮摧
  嗟叹佛如来　　快哉所说法
  奇特福田僧　　佛之所爱子
  我等不复闻　　法王之所说
  牟尼今灭度　　无觉抱迷心
  地居天次后　　出于大音声
  唱令告诸天　　法炬今将灭
  汝等得闻佛　　不亲近如来
  勿致后天龙　　而当怀悔恨
  经于无数劫　　为自及为他
  遍受于众苦　　尔乃方成佛
  此是诸世尊　　为诸众生类
  所说善法门　　今皆当隐没
  矫乱人兴世　　可畏造诸非
  魔使及恶魔　　恣情恶言说
  谄诈多痴钝　　诳惑劣愚夫
  若嗔与不嗔　　毁师及胜教
  闻地天声已　　上天皆惨然
  人及四王天　　悉亦怀忧恼
  夜叉众来集　　阿吒筏底城
  皆发可畏声　　满面流悲泪
  天居众宝饰　　城郭妙庄严
  皆悉失光晖　　犹如于聚土
  国城非似本　　堪生爱乐心
  今见宝严城　　须臾不可乐
  诸天同诣彼　　善逝本生国
  躄踊而号啕　　转增大悲苦
  我从天降地　　往诣诸国城
  真法尽沉沦　　遍观皆不见
  下至阎浮境　　见法大崩摧
  逼恼诸出家　　发声大号哭
  胜城七日内　　处处失光晖
  天亦七日中　　数非数啼泣
  呜呼大雄健　　昔曾亲面奉
  何期今不见　　言说亦成空
  曾住舍卫城　　来已皆恭敬
  于其地界内　　数悲而数啼
  见佛所坐林　　言佛曾于此
  转四谛法轮　　我等亲闻听
  世间还黑闇　　更互不相尊
  己造诸罪因　　往生三恶趣
  天众多宫殿　　今者悉空虚
  赡部诸众生　　无主无救护
  言佛经行处　　毁坏悉荒芜
  法王已涅槃　　世间不可乐
  三十三天主　　帝释立其中
  苦恼发忧愁　　高声大悲恸
  诸忉利天等　　举手共哀号
  适闻园苑中　　其次便驰走
  是等诸天众　　恒叹佛如来
  自嗟离世尊　　曾为说法者
  不能食甘露　　亦绝歌乐声
  如是等诸天　　心忧经六月
  阿修罗闻说　　教法空无主
  于是即相呼　　兴师伐忉利
  赡部诸王等　　毁坏佛制多
  当于尔时中　　天与修罗战
  多有诸比丘　　及多比丘尼
  生诸恶趣中　　备受众苦毒
  在家犯诸罪　　近事坏尸罗
  互相扬恶名　　以之生苦趣
  女人行不善　　皆亦入三涂
  如是事兴时　　世间不安静
  或时行聚落　　或投窜山林
  人众以波逃　　寿命便夭促
  多有贼盗起　　亦复有饥荒
  苗稼不时登　　蝗虫起灾暴
  若于饥馑世　　人有寿命终
  便生饿鬼中　　具受多辛苦
  所有施塔庙　　及与四方僧
  尔时诸比丘　　悉共分张取
  于我灭度后　　如是众苦兴
  应速发精勤　　勿复更回顾
  诸有愚夫类　　而无智慧人
  愚夫业已成　　速生诸恶趣
  应乐读诵说　　智慧从此生
  人修智慧心　　速能升善趣
  常以智慧观　　如我如是学
  永离众系缚　　速至于涅槃
  正法不久留　　应发坚精进
  我已如是说　　宜速正思惟
  此劫过去已　　满于六十劫
  当不闻佛名　　何能生信乐
  若人相会遇　　饥饿苦所侵
  母子是时中　　互相食其肉
  彼时所生子　　慞惶行不安
  住在己家中　　犹生大怖畏
  见闻此事已　　知其生死烧
  谁有智慧人　　于中生爱乐
  无明是生根　　女人是欲根
  蕴为苦恼根　　是故应舍苦
  世有愚众生　　耽着于女欲
  人能离痴者　　疾当得涅槃
  宣畅此法时　　不遭于恶果
  不说果有漏　　故堕恶趣中
  所有无漏法　　空空无所有
  寂静本无坚　　宜应速了悟

复次迦叶。若有比丘或余众生。由能成就此第一法。求无漏者应作是言。于一切法心无所住

复次迦叶。菩萨应为坚固修习。云何坚固。云何修习。言坚固者。谓坚固心坚固精进。何者名为坚固之心。菩萨念言。乃至供养恒河沙佛。然后乃发一念之心而求佛道。次后复经恒河沙劫一佛现世。以发恒河沙等心故。一得人身。以恒河沙等人身闻一句法。智慧光明于阿耨多罗三藐三菩提。作大利益。应发如是坚固之心。又以种种方便。摄佛智慧。种种苦行以为希求。种种苦行摄受佛智。复有如是坚固之心。复次迦叶。我今为汝宣说譬喻。由此喻故诸有智人而能解了尔所说义。由是种种难行苦行。能得菩提。于恒河沙劫不应休废。若于恒河沙劫学不休废。则能现证无上菩提。应发如是坚固之心。以为势力以作策勤。终不舍离阿耨多罗三藐三菩提。复有如是坚固之心。迦叶。若有菩萨发是心者。何以摄受。谓不取处不取非处。何故不取处非处耶。若有取于处非处者。于无上觉则为障碍。以不取于处非处故。速得无上正等菩提。迦叶。譬如有人。以满三千大千世界珍宝持用布施。若有如是种种经典如来所说。随顺菩提受持教法以信安住。所生福聚倍多于彼。迦叶。菩萨复有坚固之心。乃至坚固心亦不可得。是故修行不可休废。言修习者谓多修行有几多耶。随有若干多修习法。若起一心不能解了。何以故。彼法不可为表示故。然是最胜修习之法。谓坚固心性。尔时世尊即说颂曰

  无心起心想　　当有大怖畏
  我当成不成　　是事为云何
  而常起寻伺　　住在于一边
  诽谤于正道　　不可得菩提
  此是懈怠心　　非是菩提相
  斯人疑一切　　诸佛及声闻
  不行而希望　　贤圣诸佛法
  非但由言说　　能成安乐果
  要有信乐心　　能成广大法
  亦非唯心量　　能获胜堪任
  由一法能成　　诸有所作事
  知其殊胜已　　为佛故应修

复次迦叶。菩萨以能成就此法。亦不亲近供养诸佛。而自记言。我当得作如来应正等觉。迦叶。在家菩萨有三种修。能于菩提而作利益。何等为三。为一切智故深生爱乐。不堕本业坚持五戒。具此三支能成六法。何等为六。谓得圣处。不哑不吃不聋不失聪听。身变端严速得深信。于甚深法不生怖畏。随所闻法不用功劳。而能领解速得不退。于此六法应当善知。有五障转。何等为五。谓离间语。一切妄语。意乐不成。心怀嫉妒。耽着诸欲。如是五法为障碍转。复有三法应当修行。何等为三。谓常兴心欲出家故。于持戒沙门婆罗门所。尊重恭敬。若非同类说法之者应远离之。何以故。菩萨不应修学彼法。若修学者如负刍草。何以故。非佛道故。若担负者即为执着。同诸愚痴。是故不应修学彼法。复次迦叶。菩萨又应受学三法。何等为三。谓常随顺诸佛如来。为他演说勤自修行。于众生所修习慈心。于此三处受已应学。复次应当亲近三法。何等为三。谓离捶打。不毁他人说云卑贱。于怖畏者施其无畏。应当亲近如是三法。尔时世尊而说颂曰

  不亲下劣人　　见不正直者
  见已当远离　　犹如避毒蛇
  不应随学他　　不礼应远离
  犹如见恶狗　　以生恶趣中
  有怀执着人　　学之同恶趣
  闻说胜空法　　应生爱乐心
  及乐空比丘　　亦应起尊敬
  增长多闻道　　而生利智心
  亲近胜菩提　　有情应敬礼
  疾行受其教　　速生诸善根
  增长智慧心　　如莲生在水
  宜多听受法　　所增善速增
  以增智慧心　　能断于诸漏
  大威德无畏　　大智大精勤
  为欲利益他　　自身盛利益
  在家应舍离　　捶楚打众生
  发趣求菩提　　于法得不退
  无病最端正　　人皆爱敬之
  若修习慈心　　舍离诸恶道
  三十三天上　　五欲自欢娱
  从天若命终　　不堕于三恶
  生处于人世　　种族豪贵家
  形貌最端严　　人无能毁者
  天龙所守护　　随法正修行
  受于胜妙处　　为人所爱重
  善得安隐眠　　寤亦心安隐
  以为天拥护　　终无怖畏心
  此之广大法　　有如是胜相
  在家或出家　　更有大饶益
  令发悟忆念　　多人诸善根
  怖者以施安　　趣向菩提果
  更不事余天　　唯除一切智
  是人得正道　　诸智共相应
  以此诸善根　　舍离三恶趣
  得智获三明　　善学于三学
  如所作功德　　如其所礼敬
  独为众生尊　　人多恭敬礼
  礼敬如来者　　众中为最上
  住于在家地　　若发菩提心
  为彼说法言　　及余汝当听

复次迦叶。在家菩萨应成三法。何等为三。应离世间嬉戏放逸互相赠遗及以选择良日吉辰。应常清洁离多纳受。复当精进修学多闻。菩萨应成如是三法。复有三法应受修行。何等为三。于说法者不为障碍。应当劝请说法之人。恒然灯烛。常应作是三种之行。复次迦叶。有三种法终不应作。若有作者则受女身。何等为三。不应障母听闻正法及见比丘。不应障妻见诸比丘及闻正法。乃至不应于己妻所犯其非路。如是三法终不应作。若有作者便受女身。尔时世尊而说颂曰

  常应以信心　　燃灯烛光曜
  便获无尘垢　　清净之佛眼
  由依此眼故　　了诸所知法
  若能了所知　　以知过去法
  知现在亦然　　不分别未来
  无有三种相　　有斯二种相
  舍离于第三　　相即名无相
  皆同为一义　　佛所说诸根
  然法无根本　　于斯起分别
  便失胜菩提　　净修佛眼已
  现证一切法　　此句即菩提
  如上所开示　　法无有能示
  亦无能毁者　　诸法如虚空
  是故说开示　　导师宣此义
  以为在家人　　常燃灯烛光
  得佛眼明了　　不断他说法
  释师子之教　　终不往三涂
  不受生盲果　　能常劝请他
  宣扬最胜教　　以此善根力
  转无上法轮　　若人于母所
  为作法留难　　受鄙陋女身
  盲伛多众罪　　不曾睹众色
  亦不少闻声　　住于幽闇间
  犹如蝙蝠类　　于妻生妒忌
  与作障法缘　　从兹速命终
  当为极陋女　　发黄眼睛绿
  黧黯目盲冥　　足跛怀毒心
  耳聋多口舌　　如斯种类处
  速受众恶身　　常为欲因缘
  丈夫生嫉妒

复次迦叶。在家菩萨。有三种法所不应作。何等为三。若他施物。设有微少苏醍醐等乃至或多难施之物。主若不请不应行施。他欲出家不应留难。未出家者。应当劝喻令使出家。见有建立如来塔庙。当助修营。不应缘此取其财物。如是三法在家菩萨所不应作。尔时世尊而说颂曰

  他施功德财　　不应与非处
  于重便获罪　　所施不能遮
  信者诣施前　　合掌俨然立
  于中人力少　　乐欲给侍僧
  应随施主言　　助其少人力
  水浆汤饮等　　及余轻物类
  无违施主心　　不令他怨恨
  若有欲出家　　或子或亲属
  菩萨于是中　　不应作留难
  愿有情安乐　　愿得证涅槃
  我胜意乐然　　愿说无上法
  知其过失已　　不应秽自身
  勿长夜忧嗟　　为烦恼所染

复次迦叶。在家菩萨。有三种法不应修行。何等为三。不应贩卖男子女人。又亦不应与他非药。若有作者不应亲近。尔时世尊而说颂曰

  应离贩卖男　　亦离贩卖女
  非药勿与他　　若与者应离
  为苦众生故　　天等所同诃
  随趣诸方维　　忧箭所中害
  长夜增忧恼　　众苦逼其身
  夭寿自销亡　　是故不应作
  此过及余失　　我悉了其因
  为诸菩萨等　　略说其少分

复次迦叶。在家菩萨。有三种法所不应作。何等为三。不应往彼淫女之家。不应亲近诸媒媾者。不住屠杀牛羊等处。如是三法所不应作。尔时世尊而说颂曰

  不至淫女家　　专行秽欲者
  速致世讥嫌　　亲近下欲故
  尊者知其往　　便即起嫌诃
  招疾害其身　　以之令寿尽
  常不应亲近　　媒媾男女人
  他娶女为婚　　近之被诽谤
  亦不应往诣　　诸为屠宰家
  菩萨胜依人　　皆所不称赞
  此诸深过患　　如来悉了知
  为不正行人　　我今如实说
  世尊所有教　　我弟子能知
  斯人于佛前　　能诣所行处
  众生住圣道　　将速至涅槃
  佛为如是人　　非为恶行说

复次迦叶。在家菩萨应成三法。何等为三。住在家中观己身命如客使想。于己施物起积聚想。于未施者。如远离我百由旬想。不为妻子作积聚想。在家菩萨。应当成就如是三法。尔时世尊而说颂曰

  常修于死想　　我命速当终
  于其所积财　　应修取坚实
  财不为妻子　　亦不为己身
  速疾得坚牢　　身命及财物
  殷重求佛道　　不起贡高心
  若舍饶益门　　常遭诸损害
  犹如於戏童　　少尝非饱足
  法味尚轻微　　虽信非堪保
  修行非猛励　　相去实全遥
  弘扬若不休　　名为究竟法
  迦叶我今说　　如斯诸法门
  人能解了之　　名为一切智
  以智善观察　　于身生厌离
  常自正思惟　　想之如对我

复次迦叶。在家菩萨成就三法。得不退转于阿耨多罗三藐三菩提。何等为三。父母不信令其住信。父母毁戒劝令住戒。父母悭贪劝令住舍。赞叹无上正等菩提。为他说法是为第一得不退转无上菩提。复次迦叶。在家菩萨。知可供养不可供养。可供养者而供养之。若不可者即不供养。然于彼所修习慈心。由成如是第二法故。得不退转无上菩提。复次迦叶。在家菩萨勤苦积财。不令虚费无令散失。不浪与他宜坚举置。而于净戒沙门婆罗门诸众生所。平等施之。与同法者无所障碍。由成如是第三法故。得不退转无上菩提。尔时世尊而说颂曰

  若在家菩萨　　求无上菩提
  生三根本慧　　此为最上觉
  若父及与母　　恶慧无信心
  劝令生信乐　　令其住胜法
  悭犯住戒舍　　无慧教令慧
  亦常劝于是　　为菩提胜法
  应往于四方　　遍求说法者
  法施以教人　　由斯增智慧
  犯戒令住戒　　无信令信心
  无慧教令慧　　得成不退转
  若逢慧比丘　　持戒多闻者
  恭敬亲近之　　数往而咨问
  在家由此法　　得不退菩提
  知彼胜德人　　多闻具诸智
  慧解堪尊重　　可持身肉施
  此为信心相　　如我前所言
  无信则不能　　发大菩提意
  聪明见胜事　　速成深利益
  于诸殊妙法　　取证不为难
  知自及与他　　如斯胜饶益
  与出离相应　　是故增智慧
  本来恒积集　　所有诸资财
  为与持戒俱　　共贮当来物
  是无有异语　　彼亦不虚言
  勇进坚施成　　当证如来果
  持戒易共住　　勇健获深慈
  布施摄众生　　如先后无异
  清净最上施　　无所有希求
  若金若与银　　无有不施者
  勇猛施一切　　宿世所行檀
  希求无上乘　　甚深最胜位
  非法而供养　　一切诸天人
  不如能顺法　　供养一众生
  勇健为法求　　以法能了法
  聪明由胜道　　获无上菩提

复次迦叶。在家菩萨。发阿耨多罗三藐三菩提心已。成就三法。于声闻乘而般涅槃。何等为三。此有一类怖三恶道。于大菩提起重担想。已集善根不专思念。不好善求。为心所害便生苦想。以成如是第一法故。退失菩提。于声闻乘而般涅槃。复次迦叶。此有一类。于所行施不生喜心。行布施已便生追悔。复不回向佛之智慧。由成如是第二法故。退失菩提。速于声闻乘而般涅槃。复次迦叶。此有一类。不勤精进专求多闻。以下劣善根速般涅槃。由成如是第三法故。退失菩提。速趣声闻乘而般涅槃。尔时世尊而说颂曰

  发菩提心已　　不正随顺行
  退失于佛乘　　入于声闻道
  菩提非不信　　及以懈怠心
  无智守悭贪　　则为有障碍
  知恩住净戒　　常乐广行檀
  菩提不难得　　由心造诸恶
  心亦善行檀　　众生心若坚
  当为世间塔　　若能离三法
  心趣大菩提　　当为世间尊
  成无上应供

复次迦叶。在家菩萨。由成三法退失菩提。于独觉乘而般涅槃。何等为三。此有一类。虽已发趣大菩提心。于法悭吝。复有一类耽着观望。及取世间吉凶之相。复有一类发菩提心。以懈怠故不能遍求菩提分法。由成如是三种法故。一一皆能退失菩提。于独觉乘而般涅槃。尔时世尊而说颂曰

  悭吝于正法　　不教诲他人
  得独觉菩提　　退失无上道
  由斯二种义　　失利众苦生
  亲近而修行　　疑惑菩提道
  思惟大乘法　　就吉以避凶
  此非正信心　　为佛所弃舍
  有能专意乐　　坚固向菩提
  终不礼余尊　　唯除世间塔
  若有净信心　　不事余天等
  是为成最上　　号曰天中天
  若有乐菩提　　不事余天等
  在在所生中　　色力恒具足

复次迦叶。在家菩萨。由成三法受身黑闇。何等为三。如来塔所取其灯明。于他诤讼而现嗔恚。于他黑人不预己事横加毁呰。由此三法其身黑闇。尔时世尊而说颂曰

  塔所燃灯明　　断取是光焰
  身便为黑闇　　犹如乌毯毛
  毁呰于黑人　　我白汝身黑
  由其轻毁他　　受身便黑闇
  宜善护其语　　业终不败亡
  随其所造业　　当为彼业器

复次迦叶。在家菩萨。由成三业生工匠家。何等为三。菩萨自身能持五戒。若有亲属从远而来与酒令饮。或劝他人而令饮酒。即当生彼工匠之家。名第一法。复次迦叶。在家菩萨自修梵行。和合他人令行秽欲。缘造此业积集成故。而当生彼工匠之家。名第二法。复次迦叶。菩萨见他精勤读诵。然己家内起作兴功。寻语彼言。汝且休废读诵之业。宜时为我营办所成。以是业缘积集成故。而当生彼工匠之家。名第三法。尔时世尊。而说颂曰

  持酒劝他人　　及与诸亲属
  以成狂饮故　　便为饶语匠
  不解作刀针　　及余工巧处
  唯能坐摇手　　炉前鼓槖囊
  自能修梵行　　为他称赞淫
  此业异熟时　　当为饶语匠
  不解作刀针　　不能鼓风槖
  唯解奋长槌　　砧前而锻铁
  令他弃舍法　　从兹而命终
  速生工巧家　　禀识常愚闇
  初不见囊槖　　亦不见钳槌
  其业报应然　　悉破坏众器
  迦叶应防意　　及善护其言
  永勿教他人　　一切不善法
  轮回生死苦　　由爱故增生
  善法可勤修　　应诃诸不善

复次迦叶。在家菩萨成就三法。当生刹利豪族之家众同分中。颜貌端严人所爱敬。聪慧巧便不为懒惰。何等为三。谓睹未曾见沙门婆罗门。即生信心供养礼敬。言是福田。以清净心。延请供养衣服饮食卧具医药一切所须。在家菩萨成此初法。当生刹利豪族之家众同分中。复次迦叶。在家菩萨坚住本誓。如说修行终不妄语。成就如是第二法故。当生刹利豪族之家众同分中。复次迦叶。在家菩萨。于具戒蕴沙门婆罗门所。修供养时而能摄受坚固之法。由成如是第三法故。当生刹利豪族之家众同分中。尔时世尊而说颂曰

  诸有智慧等　　见持戒多闻
  应生欢喜心　　往彼而请命
  既为请命已　　如法供养之
  无有厌悔心　　所施无挂阂
  是取坚牢法　　所为亲近者
  种种智相应　　于难而速得
  如斯深信意　　趣向大菩提
  是智之所行　　佛道非难证
  恒为上活命　　应受最胜财
  希求殊妙法　　证无上涅槃
  当生豪族家　　颜貌甚端严
  得上妙衣服　　证最上涅槃
  如佛所称誉　　行于最上乘
  以佛乘能证　　清凉妙涅槃
  是为最胜果　　如其所造业
  获果亦等流　　设经百亿劫
  是业终无坏

复次迦叶。在家菩萨成就三法种诸善根。乃至证得无上菩提。终不受于五欲世乐。何等为三。在家菩萨受持五戒。不向他人赞五欲乐。勤修自业不使女人。及发是心。我止亲近一切女人。乃至证得无上菩提。愿我不逢五欲世乐。由成如是最初法故。乃至菩提不受五欲。复次迦叶。在家菩萨。闻是等经而生深信求趣涅槃。虽复受持如是等教。隐蔽不行。有能演说及发起者。若人闻已。即当舍离诸恶作处。以此善根得无碍辩。得无著辩。若于现在及命终时。速得见佛。命终之后往生天上。不久证得阿耨多罗三藐三菩提。由成如是第二法故。乃至菩提不受五欲。复次迦叶。在家菩萨所有善根。悉皆回向无上菩提。不乐色声香味触法财封尊贵。不爱眷属。以无为心无为果报。速证无上正等菩提。由成如是第三法故。乃至菩提不受五欲。尔时世尊而说颂曰

  在家修五戒　　坚守善护持
  不亲近女人　　于中生厌恶
  如是等法门　　勤求无厌足
  所有恶作处　　应速舍离之
  一切诸善法　　悉回向菩提
  以此诸善根　　速离于五欲
  常获胜多闻　　为众生说法
  发生大慈意　　求无上菩提
  是故闻此利　　应生贤善心
  不近于诸欲　　速疾转法轮

尔时大迦叶。白佛言世尊。今此经法以何为名。我等今者云何奉持。佛告迦叶。是经名曰说三律仪。亦名宣说菩萨禁戒。亦名同入一切诸法

佛说此经已。尊者大迦叶及诸大众。一切世间天人。阿修罗乾闼婆等。闻佛所说。皆大欢喜信受奉行

大宝积经卷第三大宝积经卷第四

        大唐三藏菩提流志奉　诏译

    第二无边庄严会

    无上陀罗尼品第一之一

如是我闻。一时佛住王舍城。迦兰陀竹林。与大比丘众及无量无数菩萨摩诃萨俱。此诸菩萨皆是一生补处。从异佛刹而来集会。尔时世尊。大众围绕供养恭敬。而为说法。时彼众中有一菩萨。名无边庄严。从座而起偏袒右肩。右膝着地向佛合掌。而白佛言世尊。我有少疑今欲咨问。唯愿如来哀愍听许。尔时佛告无边庄严菩萨摩诃萨言。善男子。如来应正等觉恣汝所问。当随汝疑而为解说令汝欢喜。时无边庄严菩萨摩诃萨白佛言。世尊。我为趣求无边智慧。被精进甲。诸菩萨等求大方便善巧地者。趣无边义智善巧者。决定大智初发起者。于菩提道已安住者。世尊。我为如是诸菩萨故请问如来。亦为利乐有情之类。心无等喻。思惟诸法清净智义甚深大智方便。简择得无量义善巧决定。为欲趣求大师子座。升一切智师子之座。正初发起勇猛勤修。获不退转。言词善巧积集精进被甲胄者。为如是等诸菩萨故。请问如来。世尊。若有菩萨。于诸有情。愿欲超升到于彼岸。复有志求无碍无畏。住无畏中。方便随机演诸法义。善巧分别不增不减。又于诸法本性自性如实宣扬。世尊。复有趣入无等喻心。最胜之心及无上心。得自在故。为如是等请问如来。世尊。若诸有情。求自然智及无师智。破无明壳超于天人。最为殊胜有希。利乐一切世间。当欲趣求大智无畏。除自然智。欲示无边知见善巧。将说无量决定之法。欲以光照世间天人。复有为诸众生乐欲开示无上无碍大智方便。欲行究竟清净智见。求一切智善巧地者。我今为彼诸菩萨故。欲问如来。世尊。若诸菩萨住是地已。速能圆满成如来地。及能证得不可思议方便善巧波罗蜜多。以少功用成熟众生。现前能得如是智慧。令诸众生舍离恶法增长善法。示菩提道诸佛种性。及能安立无量众生。于阿耨多罗三藐三菩提皆不退转。世尊。彼诸菩萨能开觉路。于佛法中令心欢喜。我为斯辈请问如来。世尊。此诸大众皆悉已集。说微妙法今正是时。唯愿如来。开示演说如是法门。授诸菩萨。令得圆满不思议愿及一生补处所有善根。世尊。如是善巧陀罗尼门。如来随时应当授与。使诸菩萨能持无量法门理趣。善巧决定。及以言词演说诸义。复有志乐当证菩提。安住无边大神通业。成熟无量无数众生。摄受如来善巧之智。惟愿开示如是法门。当令众生证菩提道。世尊。往昔于长夜中已发弘誓。令无数众生安住佛智及自然智。如是陀罗尼门。应当演说。令诸菩萨成自善根。及以如来威加之力。持彼无上不思议愿。世尊。如来应正等觉。已证无量方便善巧。得不思议住无畏地。了诸众生意乐差别。无量亿劫蕴诸觉慧。世尊。此诸大众瞻仰如来无时暂舍。于一切智智及诸法藏。志求不怠。欲乐无厌。愿闻如来决定之义。世尊。安住一切智境。皆已知此诸菩萨愿及发趣善巧成熟。世尊。是诸法门陀罗尼门。圆满句义。一切诸法决定善巧。如是法门如来应说。令诸菩萨未成熟者。悉令成熟。已成熟者。速得神通及一切智心解脱智见。世尊。若诸菩萨住不定地。是诸菩萨预闻法已。而得成就一切智境。世尊。我以此缘敢申巨问。惟愿大慈。威加守护摄诸菩萨说如是法。世尊。于后末世诤论起时。执著有情更相贼害。三毒增长坏乱正法。令诸菩萨于彼时中。以大慈悲堪忍斯事。流布此法而无诤论。由顺无诤则能摄受大慈大悲。及当积集诸善根力。世尊。我今敢缘斯义。请问如来无碍法门决定之义。世尊云何。彼诸菩萨无量法门。法光明门。及一切法方便发起。复愿如来说不灭坏寂静法门。兼演无边微密法藏。具足成就念力无断。降伏魔怨及诸异论。而不为彼之所摧伏。惟愿如来演说正法。令诸众生积集善根。亦令积集无边善巧。于一切智智示现出生。随念结集无量法要。得诸辩才清净具足。相续不乱无等句义。欲令证得无量法门及陀罗尼真实方便。又令众生发起意乐。为说先后两际加行。示见去来现在诸法。于因自在。法无所住。愿诸菩萨。了知十方如来本事。以神通无畏遍诸佛刹。授彼众生清净法眼。亦为开示不思议法。成熟佛智方便善巧。我缘斯义敢有所请。惟愿世尊。说如来地广大方便甚深之法。为一切智。摄诸善巧无量不思议法理趣。令彼菩萨愿及方便善巧圆满。此诸菩萨预闻法已。悉皆获证大法光明。成就菩提殊胜善巧。及彼弘誓悉令圆满

尔时佛告无边庄严菩萨摩诃萨言。善哉善哉。无边庄严。汝今为诸菩萨。住清净愿方便善巧。亦为哀愍诸众生故。以决定慧善问如来。汝之功德无有限量。谛听谛听如实思惟。我今为汝分别解说。令诸菩萨于佛智境出生无量种种功德。无边庄严菩萨言。唯然世尊。我等乐闻。尔时佛告无边庄严。若诸菩萨。为求无边善巧愿者。应知诸佛秘密语言。受持思惟如理观察。云何观察。无边庄严。如来之智摄诸善巧。有所宣说无不清净。是诸菩萨。应当进修此之法要。诸佛所说皆是平等。安住大悲普于群生。决定成熟诸有情类。或于下乘志希解脱。于声闻道。有于真实最胜涅槃。弘誓圆满成一切智。我今安住无上解脱。远离余乘下劣之法。善入诸佛秘密语言。及说如来无比词句。广大清净摄受诸法。令诸有情随彼根性解脱成熟。然于是法皆悉平等。不增不减无缺无漏。乃至无色及无等色。无边无际自性清净。诸佛世尊之所演说。自性本性如实了知。而无有法了不了者。何以故。一切诸法皆是如来假名说故。若彼诸法由假名者。是则不可以法施设。亦无示现。无示现故。如来所说皆真胜义。随法同入一切诸法。于一切法不住分别。亦非不住。以分别法及无分别。如实平等证一切法。无有差别。法无有生。如是生法无所有故。法无有法。生妄分别遍计度故。法无有起不自在故。法无观待舍圆满故。法无作用无去来故。法无自性超过一切自性法故。法本平等无有差别。无戏论故。随所作法起殊胜愿。无不成就。而于其中无有作者。乃至无有少法所得。皆归于空。是故如来说一切法如幻如梦。无有高下。我当以此清净弘誓。摄众生时。实无少法而可著者。无边庄严。此是诸菩萨等法光明门。由斯门故。于殊胜愿而得增长。如日出现光明普照。如是善男子等。于此法门能信解者。与诸众生作法光明。无边庄严。若诸菩萨。内正思惟外无散乱安住能断诸障碍者。随念菩萨普光三昧。及能信解甚深法者。应当观察此诸法门。一切诸法如来悉知。以缘起门开示宣说。如是缘起虚妄不实。自性本性皆悉空寂。是缘起性亦非真实。能令众生杂染清净。于十方求皆不可得。无所得故无有摄受。无摄受故。于我所说尚应舍离。何况非法。所言舍离彼亦非有。亦无所取无有功用。本性清净。一切诸法无有分别。了知分别如实性故。一切诸法无有所住。亦不可见无异性故。是故诸法无住无依。但以名字施设而有。彼皆空寂无有自性。无住而住。是故诸法无有住处。处无有故。尽故。灭故。及变易故。如来但以异名宣说。如是密意应当了知。不应执着善与不善。若执善法。彼不善法亦当执着。由执如是不善法故。生诸苦恼。佛以异名于此示说为苦圣谛。由不执着善不善故。彼诸爱灭。如来于此善法所断。异名示说为集圣谛。第二圣谛能了知故。灭故尽故无忆想故。厌离观察无所有故。无喜想受无分别故。如来于此异名言说。为苦灭谛。了知第三灭圣谛故。是所求道如实悟入。一切法地。超过一切忆想分别戏论之境。八支相应修习正见乃至正定。苦灭趣道圣谛了知。佛以异名于此宣说。为第四谛。诸佛世尊于此施设。知苦断集证灭修道。苦集苦灭及灭趣道。此苦无有。以世俗故假名施设。是无明等。一切皆是无智攀缘。何以故。于彼无智。亦无有少攀缘可取。无有所证。无有光明。不可了知亦不可得。而于其中当有何物。一切皆是虚妄坏法。无有坚实。于中若以实物施设。彼即于常应有执着。若以无分别执着。彼即于断应有执着。是故于苦不应分别。以智慧故应当了知。无智自性即苦自性。由与无明共相应故。无明亦不与物相应。或不相应彼亦无有。由彼不相应故。是故无明非分别。非不分别。不作不坏亦无作者。施设作者不可得故。无边庄严。此是诸菩萨。了知悟入无明自性顺明法门。由是门故。能舍一切无明黑闇。现前证得随顺明法。于菩提分能善修习。于诸圣谛能善了知。是诸菩萨。于此法门能得清净。所谓由不生故苦得清净。不攀缘故集得清净。由灭尽故灭得清净。由修习故道得清净。信平等故道即平等。如是诸法异名差别。应当解了。了已应断应证应修。于如来言。若能解了彼即遍知。彼即随断。彼即作证。彼即修习。是故圣者如是知已。于一切法不取不舍。便得安住四谛法门。无边庄严。一切诸法无有分别。亦不增长。亦不积集。圣者如实善了知故。不起分别不行戏论。能如实见不毁不着。由道断故。于诸善法不起分别。亦无戏论。况不善法。由无分别共相应故。亦复不住法非法断。若遍知断。即无法结及非法结。彼能了知结法虚妄。此虚妄法空无所有。此是彼等所入谛门。由是门故不爱不恚。证舍圆满能断诸结。安住正道到于彼岸。证法自性而无入出。无边庄严。汝今当观一切诸法。本性皆空自性寂静。无有作者。诸法非实与结相应。非不相应。于彼无性法中不应执着。亦复不应离性非性而起分别。既能了知因缘清净。不应戏论诸有一切因缘生法。彼缘性空究竟清净。如是因缘非互相应。诸法展转无有所作。无有所行。无有事业。如是思惟一切诸法。互相空故无有自性。无依无住。无边庄严。汝于此中。应当悟入。则能增长不可损坏。普遍光明清净法门。由摄受故当得清净。无戏论故当作光明。超过结使无所著故当得出离。无边庄严。一切诸法。唯有名相开示宣说。何谓名相。相谓四大所造诸色。名谓一切非色之蕴。如是名相一切皆悉虚妄不实。以颠倒故而有执着。或色是我。色是我所。相分别故有名示说。如是名色二俱不实。一切皆是虚妄坏法。如幻如梦。色体不坚如梦所见。乃至四蕴亦非真实。但以世俗文字施设。如是知时不见有苦。由实谛故无有攀缘。无攀缘故心无所有。无所有故何有与彼攀缘相应。由此而能于涅槃界。得超过想及所知灭。无边庄严。三界由想作意所生。是故说言三界虚妄。想及作意亦非真实。彼所有想即色执着。所有作意皆与受想行识相应。诸法本性亦无相应。非不相应。乃至非想亦非作意。想及作意本性皆空。所有言说亦皆虚妄。但假施设令性寂静。无边庄严。诸法本性以假名故。如是所说亦皆平等。无边庄严。于此法中证于实谛。诸菩萨等应当了知。谓诸如来一切结使皆舍离故。凡所演说终不唐捐。汝等于此应善思惟无令执着。于一切法勿生分别。离诸戏论。了一切法无有自性。而于众生起慈悲想。思惟悟入如是法门。为利一切开示演说。云何法门。谓了无明诸有为法。悟智见等诸无为法。应遍清净证入一切有为无为无戏论智。非数入数非数住数。随顺如是非数法故。证入无为清净法门。获得遍持光明智慧。摄受诸法令不失坏。能以觉慧方便善巧。广为众生演说诸法。无边庄严。此是诸菩萨等入陀罗尼门。由是门故。出生广大差别觉慧。及能发起演诸法义善巧之智。无边庄严。此中何者是彼陀罗尼门。由是菩萨于诸法中能得总持方便善巧。无边庄严。此中菩萨。住遍清净善巧之智。行于辩才。由义觉慧观察诸法本性自性。然一切法自性无住。无名无相无所建立。无边建立不可宣示。但以世俗言词演说。所有诸法本性自性皆不可说。无来无去无有文字。文字清净无有功用。何以故。诸法本性等虚空故。一切诸法亦复如是。无作无起无相清净。以虚空开示演说。此则诸法无门之门。门清净故究竟无染。亦不随染。何以故。诸法究竟不生不起。所有自性亦不生起。是故当知。三世所说一切诸法自性。无性亦不应执诸法无性。此是诸菩萨无所执着陀罗尼门。为诸菩萨门清净故。如是开示说一切法。有形相者。所说形相即非形相。不作不坏不爱不恚。是故当知。形相门者则为非门。门清净故。由是能得入无形相清净法门。为欲了知此形相门无所有故。不以有义。如是宣说。无所作故入无形相。无边庄严。如是所说无形相门。为陀罗尼清净故转。无边庄严。所言门者。犹如虚空。一切诸法依于虚空而有生灭。彼生灭者性皆平等。作是观时无有生灭无所摄受。于一切法应如是知。一切诸法亦非摄受。非不摄受。非等非不等。乃至无有少法而可得者。由是能了此形相门。为得无相门清净故。开示演说。无边庄严。言无相者。所谓无身及身施设。无名无句亦无示现。于此教义。应当了知。彼无形相与虚空等。言虚空者。亦无虚空及空示说。此是无明随顺明智力聚法门。菩萨能证陀罗尼门理趣方便。由证入故无有诤论。无有忘失。随入无断秘密语言。陀罗尼门。譬如有龙名无热恼。降澍大雨流澍无断。无边庄严。所言陀罗尼者。是何句义。无边庄严菩萨摩诃萨白佛言世尊。陀罗尼者。即是随顺诸法秘密方便假名。即是随念遍持之业。即是说法语言之句。由智聚力。得入如是陀罗尼数。以善觉慧。应当受持无量无边菩提之力。世尊。如我所解。此无边智演说方便。为欲利益诸众生故。开示流布令法不断。世尊。此陀罗尼门。是大虚空。是大方广。以是义故能广宣说。由说平等能摄受故。名随教法。善巧开示广大流布。文字差别得圆满故。通达辩才而得成就。由观察义善巧说故。于义辩才而得圆满。决定诸法善开示故。于法辩才而得圆满。哀愍众生以大慈悲而能摄受。由摄受故次第调伏令得清净。无诸戏论而能演说平等舍法。世尊说此陀罗尼秘密方便法门品时。无量无边善巧之义。从佛口出。尔时佛告无边庄严菩萨摩诃萨。所言门者。即是如来一切智智门之增语。于此门中由语言故。而得演说一切诸法。如来安住无边清净。究竟清净自然智见。以无所住无所建立。流注广大甚深之法。无边庄严。如来尝说一切诸法皆是佛法。以于诸法能善了知。名为佛法。诸法本性与佛法等。是故诸法皆是佛法。由能了知法非法故。说能了知一切诸法。能了知者。即能了知陀罗尼门。此陀罗尼而能遍入一切诸法。所谓语言演说谈论。一切语言演说谈论。皆由文字表示宣说。是中文字。阿字为初。荷字为后。犹如入胎受胎持胎以母为先。又如种子长养以父为先。如蕴积集以生为先。次后建立余分差别。六处诸根次第成熟。如是字母为先。一切文字差别和合。如是字母为先。光发长养。所谓阿字为先。荷字为后。诸余文字在其中间。随彼相应和合而转。此即能入演说语言陀罗尼门。又当了知一切诸行皆悉坏灭。如彼文字书学成已寻当除灭。如是一切有支建立。皆当坏灭。如彼诸行和合故生。彼不和合应知坏灭。如是二种相应和合。建立一切诸有爱结。亦由如是二种和合。建立一切有为诸法。如是观察。渐次能净无作法门。由此能入演说生灭陀罗尼门。令诸菩萨方便善巧速得圆满。犹如字母阿字为初荷字为后。如是作已。应以语言演说谈论。善入一切秘密言词。又应了知无障碍法开示宣说。无边庄严。犹如字母阿字为初。乃至诸余一切文字。分别作已。作意相续入于书写。荷字之后更无文字而可建立。由是二种作意。能生一切有意之行。彼二分别无有真实。以于真实无少文字。本性自性。亦无分别及不分别。而于其中。亦复无有少分所作。无边庄严。一切诸法以智所知。是智皆从文字建立而得生起。由是文字不成就故。彼智亦复无有形相可得。何以故。以于真实无有形相。由入如是无形相故。舍离一切所作事业。无所作故。舍离一切有为之事。无边庄严。此是陀罗尼清净善巧遍持法门。若诸菩萨于此学时。能起一切无痴事业。为诸众生宣说正法。令不缺减。不住诸想覆盖着心。及能远离想及作意。以能趣入诸法觉慧。证无边智理趣善巧。无边庄严。若诸菩萨遍取名已。了一切法唯有种种积集言说所起之名。而无真实。如是知者。应当随入陀罗尼门理趣善巧。云何应入陀罗尼门理趣善巧。知所有名而无住处。不住诸法内外中边。于一切处都不可得。但依积集种种言说。而假施设。于施设名如实随觉。是如实句。以此实句。应当了知一切诸法无名无说。此是诸佛力无畏地。于所有法。应以此门开示演说。如来所说一切诸法。非一性非异性。诸法无有一异性故。此一切法非生非有。如是宣示诸法亦空。法若空者彼即无相。若无相者即无愿求。若法是空无相无愿。则不可知不可遍知。不应说彼若有若无。言有无者但是言说。不应于中而生执着。何以故。如来常说。若不执着一切法者。是真胜义。若有著者。由是着故。于彼彼法随生执着。如是执着一切皆空。是败坏法。但唯虚妄戏论分别。无边庄严。汝应当观演说诸法。而于彼法实无示说。岂于此中有能说者而为他说。无边庄严。此清净法。从诸如来之所演出。能了知者甚为希有。无边庄严。汝等今于我前。闻如是法能善了知住清净信。能生胜解虽复众多。而于后世希有众生于此法中能遍了知。唯除今时亲于我所发弘誓言。愿于来世。利益安乐诸众生故。而当受持如来法教。若曾往昔于如来所。承事供养深生信解。爱乐希求于甚深法理趣善巧愿听闻者。此诸菩萨。常能获得陀罗尼法。无边庄严。由于往昔供养如来。复得值遇无量诸佛承事供养。于甚深法因缘理趣深信解者。善求于法多胜解者。趣行深广求大乘者。声闻乘人厌离三界。于甚深法勤修行者。此诸人等。未曾听闻此甚深法。无边庄严。如来为欲利益安乐此诸有情。令证甚深广大无量难见难解种智觉故。而复宣说甚深之法。此非愚夫无闻执着不求法者之所行地。有如理修行善根具足。于微少过生大怖畏。于诸怖畏而求解脱。是此等类之所依处。无边庄严。如来今为汝等天人世间。常演说法不生劳倦。由佛往昔行菩萨道时。于无量亿劫精勤修学此甚深法。既修学已方便回向。云何为诸有情。当转无上微妙法轮。及为有情。而得示现无上大智。令一切智智种性不断。无边庄严。此由如来往昔愿力。为令一切种性不断。及威加此陀罗尼句。开示演说此甚深法。广令流布。使诸有情于佛法中当能悟入。令一切智种性不断。光阐弘宣此诸法教。无边庄严。汝等今欲随学如来。有诸众生希求法者。开示演说勿生劳倦。无边庄严。诸菩萨等如所闻法。于大众中。当广开演所有法行。由是当得近于佛智能速证获陀罗尼门。由证陀罗尼故。以少功力。而能受持光明照耀清净法门。无边庄严。一切诸法本性清净。若法本性非彼相应。非不相应。非和合住非不和合。于诸法中而无有法。若无有者则无有处而可示说。唯除因尽。因尽故即离。离故即灭。我为有情了知故。说一切诸法本性自性。于彼无因即无因尽。无因尽故无离无灭。无边庄严。汝观如来之所说法如是清净。若有以法观如来者。彼于如来见不清净。何以故。如来非法亦非非法。如来尚不安住少法。何况非法。若住非法。无有是处。如来超过诸表示法不可宣说。一切语言皆清净故。是故如来最极甚深广大无量。无边庄严。如是如来非色表示。非受想行识之所表示。如来亦非色尽解脱。非受想行识尽解脱。由是如来绝诸表示。与色等法非共相应。非不相应。而于一切有为无为。能遍解脱。不起分别无有戏论。如来不与色取相应。亦复不与受想行识诸取相应。永断一切取蕴根本。而亦远离诸法根本。谓无戏论。不入不出。超度瀑流。不住无上诸佛智境。亦非不住。应说如来不住少法不取不舍。如说如来说法亦尔。如来不相应故。如来之法亦不相应。如如来法诸法亦尔。依如实理。诸法皆如是故。世尊说一切法悉是真如。一切法如与佛真如无二无别。非一非异。如来安住无分别法。非遍计故。无边庄严。如来说法。终不超过一切诸法。何以故。无有少法可超过故。无边庄严。如来于彼某时。证得无上正等菩提。然于彼时。实无有法而可得者。以一切法及诸随法不可得故。不起分别。亦复不起法与非法及作意想。于彼本性清净法性。而不安住亦不建立。如是了知简择法时。亦无了知及简择者。无边庄严。此所演说第一义句。即是如来非句之句。句清净故。以是义故。诸菩萨等得一切句清净之智。由是能入无边理趣陀罗尼门。亦无少法而可证入。不来不去。无边庄严。所言句者。无句可得。非句句故。于一切句应如是知。如是诸句是厌离句。若厌离句是虚妄句。若虚妄句即厌离句。彼一切句是灭尽句。若灭尽句即真如句。若真如句即究竟句。若究竟句是尽离灭句。若尽离灭句即涅槃句。若涅槃句即非世俗。无句施设亦无示说。无边庄严。言一句者。于一切善不善法中。平等趣入。云何一句。所谓离句。于厌离中无有少句是一切句。犹如厌离句。亦非句句清净故。若句清净即涅槃清净。若涅槃清净即句清净。如是诸句皆不可说。若以语言宣示句者。而彼诸言。于十方界求不可得。谁为谁说。故诸言说一切皆空。彼若空者即无有义。不应于中戏论分别出生。如是诸句义者。一切皆是无分别句。无戏论句。是故修观行者。寻求观察一切句时。当知皆为离灭涅槃。如是诸句不异涅槃。亦不可说。然非不异。由言说句皆虚妄故。为清净句。宣说善巧表示诸句。非实表示。若非表示非不表示。则处中道。若处中道则无分别。以于此中分别断故。于此法性平等入时。而无有处行少恶行。无所得故。如是不行。亦不遍行不等近行。若如是行。诸佛说为菩萨乘者。无有少法而可行时。彼行菩萨地。安住无上清净陀罗尼故。无边庄严。我今当说陀罗尼句。由是句故。令诸菩萨得陀罗尼。而能开示无边法藏。应说此等住无诤地。以能摧破诸他论故。极寂静故。广演法故。此中何者是彼法门陀罗尼句

哆侄他若曳(一)微若曳(二)坞计(三)乌迦(上)筏底(丁以反四)阿(引)[口*路]计(五)阿(引)[口*路]迦(上)筏底(丁以反六)钵啰(二合上)陛(七)钵啰(二合上)婆(上)筏底(丁以反八)娜唎设儜(九)儞(尼顶反)那唎设昙筏底(十)遏替(十一)遏他筏底(十二)戍闼儜(十三)鞞戍闼儜(十四)钵唎戍闼儜(十五)吃唎(二合)耶(十六上声)吃唎(二合)耶筏底(十七)嗢哆啰尼(十八上声)珊哆啰尼(十九上声)摩诃毗社曳(二十)么诃毗社耶筏底(丁以反二十一)阿怒珊地(上二十二)阿钵啰(上二合)底(丁以反)珊地(上二十三)庾伽(上)磨[阿-可+欠]奈陀(上二十四)悉地(二十五)悉驮遏挮(二合二十六)悉陀(上)遏他(上)筏底(丁以反二十七)么底(丁以反二十八)么底(丁以反)钵啰(二鞞合二十九)嗢哆唎(三十)嗢哆啰筏底(丁以反三十一)弭磨唎(三十二)弥磨啰怒散地(三十三)萨嚟(三十四)萨啰筏底(三十五)萨啰(引)怒伽底(三十六)娑冥(上三十七)娑么嚂婆(上)弭伽底(三十八)羯底(丁以反三十九)阿儞伽底(四十)阿钵啰(上二合)底(丁以反)儞筏底(四十一)弥势晒(四十二)弥势晒筏底(四十三)阿(上)磨醯儞(四十四)儞磨醯儞(四十五)钵啰(二合)磨醯儞(四十六)邬(引)荷邬哆啰咛(四十七)么啰钵娜曳(四十八)阿(上)势铩(去四十九)阿怒跛势铩(五十)阿怒伽迷(五十一)阿钵啰(二合)底伽迷(五十二)阿伽(上声呼)帝(五十三)阿娜伽(上声呼)底(五十四)伽底弭戍驮儞(五十五)钵唎戍第(五十六)姜(去)竭差(初假反二合)掣(尺曳反)娜儞夜帝(五十七)么底(丁以反)钵啰(二合)避帝(五十八)么底毗戍驮儞(五十九)三缦多(引)怒羯帝(六十)三缦多钵唎缚(房可反)嚟(六十一)三缦多毗戍驮(六十二)儞阿怒跛仡啰(二合)呬(六十三)阿儞仡啰(二合)呬帝(六十四)呬那(引)啰梯(二合六十五)阿啰他(二合)毗戍地钵啰冥(六十六)奚都儞地珊宁钵啰(二合)避底(六十七)钵啰(二合)避多筏底(丁以反六十八)毗儞设者(二合)曳(六十九)避儞设者(二合)耶(引)怒羯帝(七十)阿难多啰挮(七十一)阿难多苾仡啰(二合)奚(七十二)么社毗戍地(七十三)阿怒竭啰奚(七十四)钵啰(二合)竭啰荷毗戍驮儞(七十五)阿地耶(二合引)多么(二合)毗竭帝(七十六)么呬啰驮(二合)毗戍驮儞(七十七)苾地耶(二合引)怒竭底(丁以反七十八)苾地耶(二合引)怒散地(七十九)钵唎戍驮儞(八十)

无边庄严。此是陀罗尼标释之句。诸菩萨等由是句故。而能随念无量如来所有法藏。亦能为诸有情。开示演说住无诤地。复能随入一切义句理趣善巧。善能了知无量广大差别智觉。随其所愿皆得圆满

大宝积经卷第四大宝积经卷第五

        大唐三藏菩提流志奉　制译

    第二无边庄严会无上陀罗尼品第一之二

尔时佛告无边庄严菩萨言。我当说彼陀罗尼门理趣差别智慧善巧。令诸菩萨得陀罗尼善巧方便。由证此故。当能了知随法秘密善巧理趣。云何了知。无边庄严。于眼所见色陀罗尼。乃至意所知法陀罗尼门。无边庄严云何六内诸法所取外法陀罗尼门。无边庄严。若诸菩萨眼见色已。而由不可映夺智力。及念善巧不迷忘故。了知遍持色是无常生灭不住皆尽离灭。由此复能于内眼界。而不执着我及非我。善巧安住眼处清净。于色攀缘不摄受故。而能清净陀罗尼门。善能观见尽厌离灭则无戏论。由不戏论总持善巧。住无妄念无有积集。所行道中而能舍离眼与眼识及所知法。无有分别。由如实见得清净故。亦能随念诸法如幻。于能所识。清净善巧得总持时。善能摄取不共世间广大智蕴。如是略说。乃至意所知法陀罗尼门。菩萨以意了知法已。而由不可映夺智力。及念善巧不迷忘故。而能总持诸法无常生灭。不住尽厌离灭。于内意处安住总持。亦不执着我及非我。善于内住意识地者。随能妙观总持善巧次善安住意处清净。于外法处不摄受故。能得清净陀罗尼门。由内外法及余结使不相应故。能随观见尽厌离灭不作戏论。由不戏论总持善巧。住无妄念无有积集。趣行之道而能舍离。意及意识并所知法。无有戏论不起分别。以如实见得清净故。而能随念诸法如幻。亦能总持于识所识清净善巧。而能摄取不共世间殊胜福慧。又能如是。于去来今及诸内外一切法中。由随义觉。摄取方便善巧智力。不于少法起无因见。而不于因起于缘见。亦不于缘而起因见。了一切法各不相应。如实随入诸法本性。此一切法本性清净展转寂静。若一切法展转依持随种类持。由于遍持共相应故。得安住者。应知彼法不由依持共相应故。而得安住。不生不起而不流转。亦非言说之所能得。彼所有义一切诸法。各不同分非共相应。非不相应。以一切法无有作者令作者故。无有寿者。无有众生无补特伽罗。此说法句。非如其实。非不如实。一切诸法不摄受故。同于涅槃。无有执着。断于执着远离执着。无边庄严。此是诸菩萨。演说陀罗尼差别善巧。如内外法于一切法应当了知。如是说时。彼诸菩萨舍离内句。亦不取外。及能观察无有始终。乘生死轮堕在世间。入无明室处无明[穀-禾+卵]。周遍流转。彼虽如是生死轮转。于中亦无生死可得。亦无真实生死之轮。虽复随顺生死轮转。堕在世间于中可得。然诸众生不能了知此诸法故。于生死中游行驰走周遍驰走。又不能了虚妄颠倒。于非众生起众生想。若众生想所系缚者。彼于诸法不能了知。随入破坏极破坏法。为虚空执之所执着

佛告无边庄严。若诸菩萨。于此法中能解了者。速疾获得智慧光明。随证法门。辩才清净修习忍辱。而能精勤起大慈悲。志无懈倦善能安住。秘密言词演说方便。亦能了知一切诸法异名差别。最胜语言随所忆念。往昔住处能善赞说。无少相违。令诸众生住无诤论。能坏一切外道诸论。为破众生诸黑闇故。宣说法时。而为十方无量世界诸佛如来之所称叹。放法光明。作不思议法之施主。善能开示诸佛法藏。无有迷惑。及能摄取殊胜大愿。如其所愿皆令满足。得不思议方便善巧。令诸众生意乐开发。及能示现前后际因。亦能示现去来方便。无边庄严。是中菩萨。于能发起三摩地门。应勤修习。既修习已。而能证入陀罗尼门。于陀罗尼门得自在已。于诸秘密广大异名。而能演说。及能入于异名之智。能随顺入甚深理趣。善能了知言说示现。令无少处而生疑惑。不由他教住于忍地。无边庄严。若诸菩萨。能善发起勇猛精进。为欲哀愍诸众生故。求诸法智证入通达。无有余乘而不成就。得佛大智。超过一切世间之智。究竟清净。一切智智未足为难无边庄严。于此演说陀罗尼门甚深方便法品之中。所有诸法。为欲摄取诸菩萨故。开示发起。我今当说令诸菩萨普遍开悟。善能摄取秘密言教。凡有所作。皆能了知一切语言音声之义。复能证入差别觉慧善巧之智。何者是彼所有之法。无边庄严。是诸菩萨具净尸罗。安住实谛加持之力。则能增长布施方便。求无我所无摄受法。修习方便。证一切法真实理趣。得不退法及善安住不退转地。速疾具足无碍辩才智慧。增广犹如大海。无边庄严。当于后时。无有余人颇能恭敬受持此法。唯除菩萨希求甚深如实法者。为欲开示如来法藏。希求乐欲增上心者。调善意乐正思惟者。彼等于此甚深法中。精勤修学入此理趣。则能了知异名演说。亦能了知一切诸法自性本性。无边庄严。假使如来以种种名演说诸法。然于诸法本性自性亦不相违。如来开示诸法本性不相违法。说一切法无所造作。凡所演说。无有所说及能说者。无边庄严。如来已得演说善巧胜波罗蜜。如来亦无少法可得。亦无随得亦不遍得。如来不为少法安住故。不舍离故。不为生故。而能说法。亦不为得少分法故。亦非不得故。如来行无所得。如来不行亦非不行。亦不应说诸佛如来行如实行。何以故。无有少法说名如来。此是如来住如是住。行如是行。若彼如来以名字故名如来者。如来与名非异非不异。非异非不异故。不应说言如来若来若去。如来非戏论者。超过戏论。亦无超过。如来无有超过。超过亦无如来。如是如来。与如来性。非即非离。不虚妄性。不变异性。亦复如是。如是称扬如来体性。无有少法开示演说。亦无示现。如来证得一切诸法如实本性。然一切法所有本性不可宣说。一切诸法无所有故。如是如来说一切法。无有所作亦无变异。不生不灭不出不离。一切诸法究竟清净故。非得非遍得。于一切法无有所得。无所得故无有可证。如是无有少法可得。若法可得。于诸法中应有受者。既无受者。是故当知一切诸法由不生故无有得者。如来名号亦由圣教假名施设。如是言说性清净故。圣者于中不得少法。然于圣者。亦无有法及与非法。亦无有法名为圣者及非圣者。无有少法与彼相应或当相应。于此如来所有演说。皆应了知。亦复不应随俗而转。如来能说法及非法。亦不建立有法非法。如来能说善不善法。亦不建立有善不善。如来能说一切诸法。亦不建立有一切法。如来能说法无表示。亦不建立有无表示。无边庄严。如来所说此甚深法。无净业者不能了知。若有乐求无上菩提。于生死中求解脱者。应当觉了诸佛如来所演说法。无边庄严。若诸菩萨于此法中能解了者。应无犹豫不取不舍。亦不见有少法生灭。无有戏论。非无戏论。则能演说此真实法。于此演说真实法中。亦不执着。无边庄严。譬如须弥山王。与诸福德善根众生所用宫殿。作依止处。众生于彼而受欢乐。如是如是。作善根者诸菩萨等。于此法宝积集教中。而能听受。由此法宝菩萨能得一切智智。无边庄严。此契经法。能随顺入无上法智。为欲开示如来法藏陀罗尼故。如是流布此陀罗尼。能摄一切所有广大真实之法。诸佛如来所说之法。皆悉从此无边陀罗尼门之所流出此陀罗尼。为欲清净一切法门。是故如来开示演说此陀罗尼。能摄一切契经等法。不成不坏。无初中后。此陀罗尼如来护念。遍于十方诸佛世界。能作无量无边佛事。无边庄严。于此最初陀罗尼品说义品理趣品中。而能摄受一切诸法。无边庄严。彼中诸菩萨等。欲随觉了此教法者。欲流注法令不断者。欲入诸法无住印者。欲随觉了无有障碍秘密门者。欲随发起趣向加行大精进者。欲随觉了诸法性相说此法者。应当受持诸佛如来所演言教。既受持已。随应了知一切所有秘密言词。欲随趣入总相演说文字智者。欲随觉了演说诸法差别理趣者。欲随忆念一切诸法简择智者。为欲利益安乐一切诸众生故。施设胜义。善随机根授与众生令得利益。若称扬法。若流传法。若演说法。以资粮心哀愍利益。求佛之智。不于少法而生执着。由不执着无有所取。亦不观察无二法智。亦不示现内智外智。不于少法而生厌足。亦不应以下劣精进希求上智。勤修一切甚深之法。所有难问随义而说。应住自利及以利他。应善观察自他之想。入一切法皆悉无我。我清净已。随入一切诸法清净。爱乐开示演说言教。若问不问乃至少法不生悭吝。菩萨应作如是四无量心。我为利益诸众生故。随与胜施最上之施。所谓无上法宝之藏。我今当令一切众生与不可说法宝相应。假令众生作诸重恶。终不于彼生悭法心。离诸悭惜。能为舍施为法施主。我今当作如来之事一切智事。令诸众生舍离重担。于大瀑流。当以法船运度群品。能令众生得于一切安乐资具。菩萨当以如是悲心发生觉慧。速疾证于殊胜之法。于此契经陀罗尼门。演说诸法差别总持。当得成就舍离生死。不为他论之所摄受。能破一切外道诸论。降伏魔军。为欲灭坏诤论法故。应如是住。无边庄严。此陀罗尼门一切如来之所摄受。善作忆念。譬如后身菩萨。住于三十三天。夜摩天。兜率陀天乐变化天。他化自在天中。兜率陀宫一切诸天承事供养。一切众生咸生爱乐。成熟善根摄诸胜福。余有一生。施戒福蕴具足清净。成就一切殊胜智蕴。于此三千大千世界。一切众生。所不能及。而能映蔽一切有情所有善根。亦为一切诸有情等恭敬赞叹。现前获得一切智智。若彼菩萨。从兜率宫下阎浮时。即于中国无怖畏地最胜妙处。在大城内一切众生众会之中。降生出现。为诸众生瞻仰礼拜供养恭敬。此陀罗尼契经之门。亦复如是。入于一切诸法之中。而得安住。一切诸法皆从此生亦从此灭。菩萨于此得安住已。成熟增长。于一切法而得安住。一切法中而得自在为其主故。菩萨最后受身生于人中。以无观视一切法印三摩地力。普遍观察一切有情。及遍观察一切三千大千世界。由得法陀罗尼醍醐之味。以广大心善住广大智慧境界。终不贪爱一切欲乐玩好资具。亦不希求一切染法端严相续。由住彼空三摩地觉。能善观察一切诸法。随得无相方便善巧。而于一切无所执着。能善了知一切三界有为之法。无非过患。安可贪着。应求出离。速得寂静极寂静界。及胜解脱胜出离界。然于彼识不住不着。观察生灭积集散坏。于诸有情起大慈悲。为成熟故生出离觉。以觉理趣随宜方便。能随顺入最胜智慧。随念一切有情。善巧方便而得自在。随得诸法无有障碍陀罗尼善巧理趣。以善巧智。简择观察一切有情。及善观察不思议法决定理趣。虽复少年端严美丽。于诸欲境曾不爱乐。舍离所有一切资财珍玩众具亲戚眷属。思惟观察。以厌离心希求寂静。从家出已趣于非家。既出家已。而能成就不思议觉甚深方便。随所作业积集资粮。趣向无上菩提道场。随愿庄严获得无上陀罗尼印甚深方便最胜尊顶。由是清净陀罗尼门善巧理趣。得一切法自然之智。及无障碍一切智智遍持善巧。彼既得于一切智智陀罗尼门。随得决定一切智智。善清净已。安住无上一切智智。加持之力能转无上清净法轮。亦能随得一切法智巧妙言词诸法。譬如盛日光明照曜。如是法声光明遍示一切天人之类。无边庄严。菩萨住于一切智智陀罗尼已。得阿耨多罗三藐三菩提。彼陀罗尼门句义差别。诸余菩萨所不能知。若一生补处菩萨坐于道场。以清净觉无师自悟。此陀罗尼而得现前。亦犹菩萨为菩提故。无量劫中积集善根。于其长夜久修梵行。得深法忍。哀愍一切诸众生故。大慈悲心方得现前。无边庄严。菩萨由是陀罗尼故。坐于道场。当证阿耨多罗三藐三菩提。我今于汝不可示说。汝得菩萨智慧现前。能证彼法。当于尔时。诸菩萨等自应解了。尔时菩萨得无边门无量门因门无譬喻门。悉皆现前。而得门者不可宣说。超过世间。不共一切天人魔梵及诸沙门婆罗门等。逮得最上清净之法。一切智智及自然智。菩萨由是能入清净自然之智。能转无上清净法轮。渐次为于无量众生。摄取无上一切智智。于诸法门及涅槃门。得清净故。开示演说无量种种善巧理趣。而能发生持蕴善巧。亦能示现持蕴清净善巧之智界处缘起。亦复如是。又令众生发生趣入圣谛法门。亦能示现圣谛清净善巧之智。又能发生三十七品菩提分法差别善巧。亦能示现菩提分法清净之智。而能发起持奢摩他毗钵舍那善巧之智。亦能示现持奢摩他毗钵舍那清净善巧。又能发起持三摩地三摩钵底善巧之智。亦能示现禅三摩地三摩钵底清净善巧。又能发起持无迷惑功不唐捐善巧之智。亦能示现持无迷惑功不唐捐清净智慧。又能发起持厌离尽无生之智。亦能示现持厌离尽无生清净善巧之智。又能发起持明解脱善巧之智。亦能示现持明解脱清净善巧。而能演说大涅槃门。亦能住持一切句义。舍离清净善巧方便。于有为无为有漏无漏世出世法。以无量名表示宣说。法门清净故。为诸众生开示无上决定之法。及持清净微妙智因。无边庄严。如来说此大陀罗尼遍持方便。为一切智陀罗尼善巧之力。得安住故。随诸众生一切本愿。示如是行。令入随觉理趣差别。善能开示陀罗尼威力无上法藏。而能流注降洒法雨。润洽一切枯槁有情。施以妙法咸令满足。汝等应当随如来学。于此甚深决定之法。不应违逆。汝等于此一切智智大陀罗尼。不久当得遍持自在住陀罗尼。为诸众生。当作如是无量义利。如我今者。汝等当以无量异名开示演说此陀罗尼。决定诸法甚深智慧。无边庄严。此中应当希求胜解。不应舍离菩提资粮。云何应当希求胜解。谓诸菩萨。应当解了一切诸法不生不灭不动不住不来不去自性空寂。于彼空性亦不执着。何况于相起执着想。彼空性中无有相想。若彼空中无有相者能入。如来说有为空无我我所一切我人众生寿者。如是空性非染着。非不染着。非污非不污。非迷惑非不迷惑。非爱非不爱。不住于空。亦不遍住。亦不建立。若空厌离。彼即寂灭无有分别。无遍分别无胜分别。无普分别无有功用。乃至无有少法可取。自性清净。彼即诸法本性自性。一切有为本性皆空。乃至一切善不善法。有为无为。世出世间亦复如是。菩萨摄受如是胜解。得入解脱解脱智见。及能摄受普净无垢解脱之处菩提资粮。云何名为菩提资粮。谓戒清净智慧清净。三昧清净解脱清净。解脱智见清净。施波罗蜜清净。戒波罗蜜清净。忍波罗蜜清净。精进波罗蜜清净。禅波罗蜜清净。慧波罗蜜清净。若彼清净即普清净。若普清净即无垢法门。性净之心。光明照耀无有烦恼。彼心常住本性空寂。亦无照曜。客随烦恼三种染污。彼皆不实空无所有。如是心性。不与烦恼清净相应。何以故。是心无二亦无二分。本性清净。若能如是了知心性。非烦恼染之所染污。非内非外。不在中间。皆不可得。唯除妄想因缘和合。虽有心生亦不可见。十方推求了不可得。亦无有心能见于心。如是攀缘非心和合。心亦不与攀缘和合。亦非因缘与心相应。心亦不与因缘相应。唯由心故。彼一切法与心相应。凡所有法与心相应非互相知。亦不可见。何况诸法非心相应。以第一义思惟观察。无有少物可相应者及不相应。何以故。无有少法与少法相应及不相应。一切诸法自性寂静。自性亦不与少物相应及不相应。一切诸法所有自性即是本性。若是本性彼无自性。汝今当知。若以言说得一切法本性自性。无有是处。于诸法中无有少法名为诸法。本性自性。一切诸法本性皆空。一切诸法自性无性。若空无性彼则一相所谓无相。以无相故彼得清净。若空无性。彼即不可以相表示。如空无性不可以相表示。乃至一切诸法亦复如是。是空无性非染非净。然是一切诸法本性。若是一切诸法本性。非由染净之所建立。无住无起。无边庄严。汝今当观一切诸法。无住无起无所建立本性清净。云何众生。于中迷惑。此由世间乘虚妄轮。为虚妄轮之所迷惑。所言乘者。亦无有乘亦非无乘。而此世间乘虚空轮。为虚空轮之所系缚。然虚。空轮亦无所有。此诸众生。为大愚痴之所迷惑。而于其中无有愚痴亦无迷惑。无边庄严。汝观众生以愚痴故。于此法中不能了知。住于诤论。无边庄严。住诤论者即为非住。然诸世间。以迷惑故不能了知彼即清净。若不住者即名为住。是则不住清净善根。无边庄严。如是如来秘密法门难解难入。唯除汝等能于长夜修行善法而得了知。无边庄严。如来尝说住诤论者则为非住。云何为住。所谓不善。然不善者是无所有。若有于此无所有中。不能了知住与不住无有别异。是则名为住于诤论。若复有住清净善根。则不名住。若不住者无有过失。无过失故则能了知。如是法门若不清净。无有是处。若诸众生无有智慧。为大烦恼之所覆蔽。无智慧故。假使少有明了顺说。尚不能解。何况秘密非随顺说。若不住者是则清净。云何不住。谓不住善法及出离界。何以故。无出离界及界施设。于涅槃界若不住者。名得涅槃。此涅槃名但假施设。如是涅槃无有所得。亦复无有得涅槃者。若有得者则应灭后更有如来。若无得者则应灭后无有如来。若灭度后。言有如来及无如来。俱不可说。此不可说亦是如来假施设句。有诸众生。于甚深法不勤修行而生疑惑。若有说言如来有色。灭度之后应有如来。若有说言如来无色。灭度之后应无如来。乃至灭后非有如来。非无如来。亦复如是。若法不生不灭彼法灭后。不应说有说无。如是如来不生不灭。彼亦灭后。不应说有说无。乃至边无边等。如来说彼俱不可说。若说有边则无有中。若说有中则无有边。所言中者非有非无。若复于中实有实无。是则便与缘起相违。若复有法非从缘起。及非缘起。彼法不灭。若有若无俱不相违。所有一切从缘起法。及缘起法。此无中边非有非无。若非有无云何可说。无边庄严。如来以大方便安住彼中。为诸众生破无明[穀-禾+卵]。开示演说不违缘起。一切诸法皆入缘起。若入缘起。是则无有中边之说。若离言说。乃至无有少法可得。无边庄严。汝今当观无所有法。无有边法说名中道。以于方便说有觉慧能持诸法。然持法者亦不可得。不可得故无有言说。无边庄严。汝等智者应如是知。一切诸法真实之相。不来不去无分无断。不一性不异性。到一切法第一彼岸。无有少法不到彼岸。到彼岸者即是涅槃。一切诸法悉涅槃相。是故当知不可宣说。唯除世俗说为中道。如是中道彼即趣向大涅槃路。亦无涅槃是彼所趣。若有涅槃是彼所趣。而于诸法应有去来。一切诸法性皆平等。是故涅槃名无所趣。无边庄严。此名中道。然此中道即非中道。何以故。无增无减故。无边无取故。法若无边云何有边。谓无处所是无边法。凡夫众生。于无处所执为边处。见边处故不得解脱。以于真实无处所故。无边庄严。汝观如来以善方便决定觉慧。乃能演说如是中道。无边庄严。诸佛如来于一切法无有疑惑无忘失念。诸佛世尊心常在定。得三摩地无碍自在。常善观察。安住最胜三摩呬多。而说语言。无量知见不住非处。说清净法。说究竟法。说寂静法。如来所说无有遗余。无边庄严。如有宝珠名种种色。在大海中。虽有无量众多駃流入于大海。以珠火力令水销灭而不盈溢。如是如来应正等觉。证菩提已。由智火力能令众生烦恼销灭。亦复如是。无边庄严。若复有人于日日中。称说如来名号功德。是诸众生能离黑闇。渐次当得烧诸烦恼。如是称念南无佛者。语业不空。如是语业名执大炬能烧烦恼。若复有人。得闻如来及佛名号。离诸黑闇。与彼众生为涅槃因。无边庄严。我为信于如来众生及诸众生。烦恼灭故。降澍法雨。无边庄严。如来所说是法真实。以真实故。无有少法开示演说。而于是法无实无虚。无边庄严。如来是实语者。住真实法。能演说此陀罗尼门。无边庄严。此真实法谁当能了。唯除菩萨如实见者。具足见者。作善业者。于甚深法余无能了。无边庄严。于此义中应当随顺。自于此法。系念现前不信乐余。从他生智。为欲利益安乐众生。于此法中应生随顺。若于此中生随顺忍。是则不住不随顺中。无边庄严。无闻众生无随顺忍。于此法教不能了知。或复有余异见所行。乘异路者。趣恶道者。不作善者。亲近诸余行异行者。彼等不能入此法门。无边庄严汝今当观。若有说此无障碍藏法光明时。所有一切无闻众生。未善调伏凡夫心故。无有威仪。由此远离如是法教。若有众生能修习身。于此法中。假使无有能随顺忍。尚不远离。何况有能生无漏忍。无有执着。于此众会能转无障无碍法轮。何以故。此等皆住无障碍地。无边庄严。我为成就善根众生。及为如来加持众生。于无碍法见清净故。亦欲利益哀愍一切故。演说此陀罗尼门。无边庄严。若有于此法门能悟入者。应知彼已住菩萨地。能速疾证无生法忍。不久当得授菩提记。无边庄严。汝等于此甚深法门。应生胜解。无边庄严。汝今当知如是法门。无执著者。无得忍者。以之为地。若有供养往昔诸佛。能于长夜勤心修习。善身威仪。善护语业。善调伏心。平等智慧随忆念者。心无所住。于此法中善受持者。不顾身命。彼人则能流传此经。当于后时若有众生。于此法中为听闻故。勤修习者尚难可得。何况有能书写受持读诵通利开示流布为他广说。是人不久获得清净陀罗尼门。速疾逮得清净智慧。当能入于一切智智。无边庄严。汝观如来。为诸菩萨得一切智智故。开示演说如是法藏。然于其中。无有少法而不演说。如是所说无说而说。能生清净。及能开示清净法门。一切诸法等虚空相。云何为等。以一切法与虚空等。而是虚空非等不等。一切诸法亦复如是。如空无边诸法亦尔。一切诸法边不可得。不可得故无有边际。无边际故说为无边。若能于中如是住者。是即名为住如来法。住如来法则无所说。若无所说。于一切法以假名相。随应了知。不应于中而起执着。若不执着即不堕边。若不堕边则不堕中。若堕于边则堕于中。是故应当离于中边。若离中边即离一切。若离一切则无所说。由此获得清净智慧。于一切法无所取着。无有所取及能取者。何以故。诸法无我我无所得故。我性自性无所有故。如是如是。无边庄严。如佛所说诸行无常。如是演说无变异义不相应义。如佛所说诸有苦义。如是演说涅槃义厌离义。如佛所说涅槃寂静。如是演说一切有为。皆舍离义。或无常故或诸苦故。或无我故。或涅槃故。如是等门。此是如来之所演说。此亦开示一切诸法本性自性。无边庄严。如来以种种名。以种种门种种语言。演说诸法。如来亦不异于诸法。本性施设。非一性非异性。一切诸法非一非异。不可见故。速疾证入虚空自性。趣一切法无所有相。无边庄严。此陀罗尼门。为诸菩萨本性清净自性调伏。是故发起。言调伏者。为欲调伏贪嗔痴故。调无明故。及令趣入如是平等。以贪嗔痴能调伏者。亦不可得。若不可得即是调伏。无边庄严。或贪嗔痴。如理推求。亦不可得。以贪嗔痴空无所有虚空不实。诳惑愚夫无所安住彼亦如是。无有住处亦不可得。是贪嗔痴。从于彼生即于彼灭。本性空寂应如是知。云何应知。如其不生彼则不实。亦不颠倒。是贪嗔痴皆以无明黑闇为首。从彼所生。由彼所生。一切皆悉虚妄不实。是贪嗔痴本性清净。如是见者。能生清净不思议门。及能获得陀罗尼门。若有能于如是法中思惟观察。是名获得陀罗尼业及智慧业。是名平等了知之智。是名清净菩提资粮。是名精进不放逸地。是名调伏憍放逸地。是名不坏戒见威仪。是名清净身语意业。是名随顺无我智相。是名能断能灭离相。是名出生无量无边善巧方便。无边庄严。汝今当观。于此信解出离法中。开示演说一切诸法本性自相。及能开示此诸法门。说一切法等虚空性。能说法者亦不可说。所为说者亦不可得。无边庄严。我今说此诸菩萨等悟入句门。若诸菩萨于此学已。能得甚深如海智慧。一切他论无能摧伏。随得一切智所趣行。善说法要不由他教。得不思议平等智慧。由智慧故无有所著。能演说此无名无相一切法门。能得邻近诸佛如来。一切智智及自然智所有名号。逮得一切名相清净。随证速疾普遍音声。得悦意声。得殊妙声。得清净声。为诸众生信受语言。亲近咨问。以决定慧能善巧答。所谓时语。如理语利益语。柔软语义决定语。以一义说。能令众生了知多义。无边庄严。汝今当观诸菩萨等。于此修行而能觉了诸佛菩提。能得如是无量功德。断诸爱恚忧恼愚痴。能办所作得差别智。于一切处已善修学。获具足忍不退失法。意乐清净住于大愿。于诸众生善言问讯。无边庄严。若诸菩萨于此法中。已不勤修。今不勤修。当不勤修。于诸如来殊胜功德。无有少分。无边庄严。若有菩萨于此法中。能勤修习志求一切。如其所愿。如其所行。如所发趣。如所意乐。当满足者。少极少难。得极难得。若有于此甚深法中能住能忍观察简择者。当得证于无尽神通大神通智。超过一切世间智自然智无边智无量智。无边庄严。此出离法陀罗尼门。若有于此勤修学者。当得近于菩提道场。为诸众生。安住发起大慈大悲。作诸佛事

大宝积经卷第五大宝积经卷第六

        大唐三藏菩提流志奉　诏译

    第二无边庄严会出离陀罗尼品第二

尔时无边庄严菩萨摩诃萨。白佛言世尊。云何名为出离诸法陀罗尼门。佛言。无边庄严。此是出离一切文字印法。一切诸法悉入其中。云何名入。以平等故。一切诸法皆入平等。亦不见法入于平等。不可了知不可得故。于一切法自性如实不分别时。一切诸法悉入其中。离于无作及有作故。由诸文字及以语业演说诸法。如是二种不如实故。性平等故所有文字及以语业皆悉平等。于诸法中所有言说皆非如实。此是诸法如实句义。所有文字及以语业此二皆无。以无有故。无有真实开示演说。所言文字及以语业无真实者。即是诸法无差别句。无增胜句。无建立句。此甚深法不可宣说。一切诸法皆非真实非不真实。何以故。诸法本性。非以文字语业宣说可见可得。一切诸法皆无本性。如是诸法。非作非不作。非等非不等。非寂静非不寂静。然于诸法。亦住寂静及不寂静。所言住者亦无所住。亦不变异。亦复不住不变异法。何以故。法无住故不入算数。非由算数建立言教。而能令法入于算数。一切文字语业演说。皆不可得。不住于处及一切处。如是文字及以语业。无所从来。去无所至。不住中边。一切文字及于语业。业非业故。非功用故。以于一切文字语业自性空故。文字语业亦复皆空。亦以文字语业他性空故。他性亦空。乃至自他性空故。自他性亦空。自他空故彼则寂静。若寂静者彼则寂灭。若寂灭者。彼一切法即寂灭门。由彼彼门得说法名。若说文字。若说语业。彼一切门亦不可得。门清净故。无所有故。由彼彼门演说诸法。而于此门究竟清净。能平等入于一切法。如是厌离。云何厌离。谓贪本性。贪本性者彼则清净。若清净者彼则究竟。若究竟者云何有贪。云何有说。无边庄严。如是略说。无有分别无有戏论。法门清净陀罗尼门。入是门故能破无明黑闇重障。能随忆念明法种性。于一切法。得入光明清净法眼陀罗尼门。及能证得文字差别。演说法门。由是门故。便得入于一切智智。及得近于诸佛如来。于诸法中得为勇健。能破外道降伏魔军。令诸众生增长善根。入于如来秘密之法。随得法门陀罗尼门。由是法门。于十力中获大法光。速疾成就如来之力。无边庄严。诸佛如来。以十力为力为无上力。超过一切世间之力。能于众中作师子吼。何等名为如来十力。无边庄严。如来于此。以无上上一切智智。于处非处。以处非处如实了知。此是如来第一之力。由此力故处大仙位。为诸众生演说正法。及能为转无上法轮。唯除如来。天人世间。先无有能如法转者。复次如来以无分别一切智智。如实了知过去未来现在诸业。业摄取因善与不善无量行相。无著无碍。此是如来第二之力。复次如来。以无分别一切智智无著无碍。能善了知一切有情无量诸行。此是如来第三之力。复次如来以无上上一切智智。如实了知种种胜解无量胜解各各胜解所有分别及妄分别。此是如来第四之力。复次如来能如实知无量界种种界。无量缘种种缘世间住处。此是如来第五之力。复次如来能如实知若因若缘知见趣道。此是如来第六之力。复次如来以于天眼无碍智见。及以无上一切智智。如实了知诸有情等生死之智。此是如来第七之力。复次如来能如实知静虑解脱等持等至。离染清净能出入智。此是如来第八之力。复次如来宿住忆念作证明智如实了知。此是如来第九之力。复次如来漏尽智证明智如实了知。此是如来第十之力。无边庄严。如是无量无上一切智力。以是智力悉成就故。为诸菩萨及诸众生。于诸佛智得摄受故。于诸法智证清净故。开示演此无边法藏

佛复告无边庄严菩萨摩诃萨言。善男子。汝今当观如来所说。如是甚深如是难了。一切智智力清净故。所有诸法。说名如来及如来力。然于彼法亦不可见。亦不可说。无边庄严。所言力者。此是如来不可摧伏无上法门。于彼安住。开示演说此法理趣。由斯理趣建立力故。能演说此一切诸法无建立性。以之为力。如是诸力无生起性。无有自性离于自性。如是如来十力圆满。而能开示无量无边甚深之义。无边庄严。此是诸佛无上法门。住斯门已。便能演说如来十力。及能说此力清净门普清净门。无边庄严。我当复为诸菩萨等。能于法门得清净故说陀罗尼。汝应听受。陀罗尼曰

怛侄(地也反)他钵啰(二合)牟折宁(一)儞牟折宁(二)牟折宁(三)毗钵啰(二合)闷折儞(四)阿折黎(五)阿毗耶(二合引)咤儞(六)钵啰(二合)婆怒揭帝(七)帝誓(八)摩诃帝誓(九)阿钵啰(二合)底耶(二合)末啰尼(十)阿那(引)靺啰尼(十一)阿(引)靺啰拏毗戍达儞(十二)儞驮那钵啰(二合)吠设儞(十三)突啰阿儞乞屣钵儞(十四)靺虞(十五)靺虞萨嚩黎(十六)萨嚩啰尾戍惮儞(十七)母达啰(二合十八)母达啰(二合)尾戍惮儞(十九)萨钵唎缚嚟(二十)三漫多钵嚟嚩嚟(二十一)阿揭啰(引二合)弩么底(二十二)遏他(二合)娑惮儞(二十三)僧羯啰(二合)尼么掣惮儞(二十四)戍嚟(二十五)戍啰寐唎曳(二合二十六)阿(引)褐啰(二合)尼(二十七)乌波那末底(二十八)儞那嚟(二合)设儞(二十九)三曼多波嚟普里也(二合)揭帝(三十)驮罗(引)弩揭帝(三十一)阿儞迷设儞(三十二)阿伞儞迷设儞(三十三)陀(引)啰尼揭帝(三十四)儞驮那钵唎戍惮儞(三十五)阿弩达啰毗婆枲儞(三十六)跋[口*致]囇(二合三十七)跋达啰(二合)筏帝(三十八)莫[异-己+巳](三十九)莫企筏底(四十)珊驮(引)啰尼(四十一)乌筏驮(引)唎尼(四十二)阿难多钵啰(二合)皤吠(四十三)钵啰(二合)步(引)多钵唎嚩嚟(四十四)设儞(四十五)钵唎(二合)些设儞(四十六)摩诃嚩迦(引)世(四十七)阿迦(引)舍娑牟萨啰尼(四十八)弭底弥啰迦啰尼(四十九)萨婆若钵他(上)毗输达儞(五十)涅槃那钵他(上)珊那唎设儞(五十一)莎诃(五十二)

无边庄严。此是陀罗尼印法教法门。一切诸法悉入其中。若诸菩萨。于此法中如说修行。具胜辩才差别智慧。能善了知最胜出离陀罗尼句。云何名为胜出离句。陀罗尼曰

娑(上)揭啰阿(上)钵演多(一)苏迷(上)嚧啰怛那婆揭啰珊儞折耶(二)阿毗怛儞(三)阿三毗怛儞(四)阿卑靺嚟(五)拔折啰(二合)珊儞(六)涅陛设儞(七)阿乞刍(二合)毗儞(八)阿僧乞刍(二合)毗儞(九)阿乞沙(二合)耶(十)阿避夜已(二合十一)乞沙(二合)耶阿钵演帝(十二)阿乞师(二合去)那乞沙演多萨侄里(二合)世(平十三)阿钵唎乞沙(二合)曳(十四)阿毗乞疏(二合)避儞(十五)阿毗揭嚟(十六)阿毗揭罗若那揭啰尼(十七)莎诃(十八)

无边庄严。此胜出离陀罗尼句。若有菩萨。于此法中精勤修习。则能增长智慧如海。能以大慈慰喻众生。言我授汝广大法药。破灭汝等无明黑闇。拔除汝等无始无终生死烦恼忧苦毒箭。亦令汝等爱缚当解。超度一切生死瀑流。作大法光。使诸众生善根生长。能得究竟永拔济故。如是善人为善导首。能令入于一切智智。亦复不令有一众生从此无上大智退失。能以大慈普遍一切。令诸众生于未听受与义相应。寂灭厌离无生智门得无碍辩。无边庄严。若诸菩萨欲说法时。云何于此陀罗尼句。系念现前令法不断。谓诸菩萨处师子座。以无碍辩。思惟如来无量功德。由于方便广大智慧。令善巧地极清净故。若诸众生。于听法所来云集时。当于彼所发生大悲。于诸众生起大慈心。以广大智决定理趣。如实开示令不增减。知诸众生意乐差别。以善分明决定语业及文字句。广为宣说。由是说故。能令自身善根增长。以清净法摄受众生。如来能以无量譬喻。开示演说如是法聚陀罗尼门。汝等若能如是宣说无上正法。是则住于佛所作事。速疾圆满四无所畏。无边庄严。如是菩萨以大方便清净智慧。善能修习起神通业。所有诸法即能摄取广大智聚。此中何者起神通业。无边庄严。若诸菩萨住神足中。以如虚空无所依想。善能分析大种积聚。如来成就无碍智见无边智见。以智见力。于一切法得善巧智。能善决定。无有少法而可了知。住无所得。住无等等。亦不与俱住阿兰若。住无执着。住清净智。无有少法不知不见。远离黑闇无有障碍。善住无量无边智见。是故如来平等见。觉一切诸法如幻如梦。及能开示无名法想。是故我等应随佛学。如来智慧无有障碍。能善了知一切众生上中下根。令诸菩萨安住平等起神通业。由是成就神足现前。由是神足加持之力。于戒定慧及以解脱智见。净施法智善能安住。由此能得真实加持。摄受无量差别神变。于梵世间而得自在。处师子座击大法鼓。令诸众会皆悉欢喜。及为众生作大利益。无边庄严。譬如大铁轮围山王。以诸众生业增上力。于此世界围绕而住。不令众生嗅地狱香闻地狱声见于地狱。如是菩萨于此法中。善修学已。为诸众生。除灭一切有障碍法。授与一切无障碍法。如是菩萨。以金刚智摄受善巧。于此法教悟入甚深。住无所得甘露灌洒。云何名得甘露灌洒。谓烦恼魔蕴魔天魔所不能损。纵于死时虽有死魔。亦得自在不起死想。何以故。由彼正士。住于空性无相无愿。于一切法无所分别。不生不灭。不堕不起。不来不去不住。不染不净。亦不怯弱。无有障碍。无有所得。舍离憍慢其心谦下。内离迷惑善了于外。见闻觉知所不能摄。了知诸法皆悉平等。如实入于如来法中。以不虚妄无有变异。安住真如。此即名为诸菩萨等所入般若波罗蜜门。于此住已。则能成就无边智慧。由是慧力。能使入于不思议智及诸如来秘密言说。于一切法能善了知。随觉无间等菩提故。随觉无间不可思议。等于菩提不可思议。随觉无间无所分别。等于菩提无所分别。了知无间及菩提法。无所得故。彼亦不作无间差别。不作菩提平等之想。无间菩提不作不坏。不集不散。于此义中能作业者。于此所说寂静法门。而不执着。亦不分别诸业果报。能善了知业果平等。以平等故不得业果。亦不分别。亦不执着。何以故。彼于烦恼及以业障。获得轻安远离结因。于诸法门能得照曜。于此陀罗尼品能得光明。彼住如是清净门故。能于十方世界游化。具清净行无所住着。不为世法之所染污。于诸世间天人之中。堪为福田亲近供养。无边庄严。我说供养住第八地诸善男子功德无量。何况菩萨于如是法。而修行者。若于菩提及以众生。众生之法乃至世间之法。无有所得。亦不分别及诸戏论。彼人则能了知此法。如说修行。能消世间广大供养。应以如来供养而供养之。无边庄严。若诸菩萨修学此法。于诸供养。一切所有皆悉具足。离诸怖畏乃至能舍一切身命。彼于诸法无所摄受。而能摄受广大之法。处无畏座作师子吼。降伏外道及外道法。摧灭波旬及魔军众。能除众生一切覆障。当以法船渡诸众生。当示众生一切智道。当能安住一切众生于随顺道。当能令彼一切众生随顺圣谛不相违逆。当为众生开示一切菩提分法。当以法施慰喻众生。当令众生能得法喜。无边庄严。若有于此陀罗尼门能忍信受。则与得受菩提记人等无有异。彼既闻法。当于己身而自授记。如来法王施设此法。开此法藏。而能安立此陀罗尼印。及能建立此诸法门。摄受我等。是我等父哀愍我者。无边庄严。若有菩萨。以胜意乐能于我所起于父想。彼人当得入如来数如我无异。无边庄严。于此陀罗尼门法品之中。此是第二出离陀罗尼印。演说法藏

    清净陀罗尼品第三之一

尔时世尊。观察四方。作如是类种种神通。以神通力。令此众会诸菩萨等见于十方无量诸佛。及闻诸佛所说之法。尔时佛告无边庄严。汝观如来。于一切法无有所作。无数离数及寂静数。能作如是自在神通。如来之力无畏如是。无边庄严。如来之性。不一不异非不一异。无所有故。非有非无。无有自性。非无自性。应如是知如来之性。乃至无有少法可得。如是见者。亦复无有少法可见。若不可见则无所有。亦无所取。无边庄严。如来之性。无少真实少不真实。若少真实少不真实。是则应言有如来性无如来性。如来之性离有离无。亦不曾离。无边庄严。一切诸法自性本性。犹如虚空。如是法门。诸佛如来未出世时。所未曾说。无边庄严。若诸菩萨。于此法中如是解者。则能发生无量辩才。于诸法中能为照曜。于佛无畏而作光明。无边庄严。言无畏者。谓得如来最上无畏。能于少法不摄受故。不增长故。不可得故。不遍得故。不随得故。如来出世。若不出世。法不增减不遍增减。诸法自性本性常住。法界住性法界定性。无边庄严。一切诸法住法定性。如是无有不可得故。一切诸法皆妄分别。不以业报而得成就。是故能入一切诸法无业报门。如是诸法无自性故。不如实故。诸业于果非生灭因。于灭趣道。亦复非因。如来但以世俗施设。说一切法有因非因。因自在故。无有因故。此是如来无畏之地。如来具足无量辩才故。能得入大无畏地。无边庄严。云何无畏。谓诸如来四无所畏。此四无畏。缘觉尚无。何况声闻及余世间。何等为四。一者唱言。我是如来应正等觉。一切知者。一切见者。或有一切天人世间。立论于我言。我不能觉了诸法。无有是处。由此能得最上无畏。于众会中正师子吼。我能演说无上甚深广大法教。二者唱言。我是一切诸漏尽者。或有一切天人世间。立论于我诸漏不尽。无有是处。由此能得住于安乐。我开示此无量俱胝劫所积集无上法藏。三者。我所宣说出离觉了。于彼修习正苦灭尽。或天世间立论于我。若苦尽道不出离者。无有是处。我不见此相。我不见此相时。得安乐住。为诸众生。示现此法种性。于众会中作师子吼。四者。我所宣说诸障碍法。于此或有天人魔梵沙门婆罗门众。立论于我。于彼习行无障碍者。无有是处。我不见此相时。得增上安乐住。我于众中正师子吼。我能转此无上法轮。一切外道诸天世间所不能转。无边庄严。此是如来四无所畏。此中菩萨勤修学时。速疾获得无畏之地。于人天中最为殊胜。无边庄严。若诸菩萨。由善修习虚空相故。则能发生不可思议遍清净门。由是门故。于一切法最初了知。见一切法等虚空相。无二无别。一切诸法亦复如是。然于虚空亦不分别。亦不戏论。得义善巧。无少法界所从将来亦不将去。亦不积集。乃能观察一切诸法。无有积集不来不去。于一切法行无所行。燃大法炬。为诸众生作法照曜。无边庄严。汝观此法。能为菩萨几许利益几许事业。谓佛十力四无所畏。亦复无有少法可得。亦非不得。无边庄严。一切诸法等虚空相。为得义利开示演说业所依事及彼业因。于中亦无义利可得。无边庄严。此甚深法。一切世间之所难信。一切世间皆是灭坏虚妄建立。由是于此法毗奈耶。不能信受。亦非世间能知世间。皆悉非法。以执着故。言有世间及安住处。假使乃至法想执着。亦无有法而可执着。由于非法起执着故。则与如来及所说法。共兴诤论。又不能了一切诸法自性本性。复与无生法等相违。是故于此甚深法教。不能解了。无边庄严。我为一切天人所信。如实语者。无诤论者。如来世尊息诤论故。舍离蕴故。开示演说如是法教。于中无蕴亦无蕴尽。无边庄严。一切有者。所谓一切善不善法。于中都无善不善法。善不善法皆悉寂静。善不善法各不相知。善不善法不相映蔽。以善不善执着因缘。是故如来说一切法皆悉无记。以彼真实善不善法不可得故。若不可得则无有记。何以故。于中无因。无因可见。无边庄严。汝今当观一切诸法皆悉无记。若诸菩萨如是觉已。于一切法无记言说亦不可得。如是法门为诸菩萨。于不善法如实见故。得舍圆满于法不住。以无记门证入诸法。是无记门彼则非门。若非门者则不可得。若不可得彼则清净。此是诸菩萨所入陀罗尼清净法门。由是门故。得一切法光明照曜。于诸法中。无有愚闇迷惑犹豫。及能获得无碍法智慧眼清净。无边庄严。于此法中应生愿乐。云何愿乐。谓于诸法无所取故无有执着。究竟离舍超过摄藏。无希求故。于善不善一切有为及世间法。不观待故。此是无上不放逸地。离攀缘地。于诸法中无有所住。不来不去无所建立。此则说名慧眼清净究竟远离。无所取故。善能观察舍离一切。自性本性此名慧眼。言慧眼者。所谓尽灭厌离智性。如是智性。无生无作本性寂静。亦复不与寂静相应。断相应故。亦复非断亦非无断。无缺无减。此则名为清净慧眼无戏论道。由是慧眼得成就故。以大慈悲摄诸众生。令其发心住缘众生无尽妙行。及能觉了一切诸法。无有我人众生寿者。彼若证得大菩提时。决定当能开示演说无上法藏。及能清净陀罗尼门。为诸众生种性教法不断尽故。应置法印

佛复告无边庄严菩萨摩诃萨言。此陀罗尼清净法门。一切诸佛常所护念摄受开演。住于十方三世诸佛。亦皆宣说如是法门。为诸菩萨。开示三世平等法性。由是能于三世诸法如实悟入此之法门。成就菩萨清净三世总持慧故。彼诸菩萨无有世想。于善不善了知无二。而能生长种种善根。身语意业悉皆清净。能遍清净无量法门。为得清净总持慧故。亦能开演无起作性清净法教。复能开示一切诸法毕竟空寂。犹如虚空。又能示现广大慧光。而为开示清净智故。亦能开示一切诸法及与菩提如虚空性。而为示现一切智智道清净故。又能开示清净道法。即是菩提随其所愿得圆满故。能正了知演出实谛方便善巧。而能宣说无分别谛故。能善开示诸佛智慧。随顺觉了一切义故。无边庄严。若诸菩萨。于此法中善修学者。能速清净菩提资粮得住菩提无有远近。不与少法共相违背。亦不于此所说诸法而见远近。不以法及非法随见菩提。通达菩提绝诸显示。能以平等无显示义。了知菩提。及观诸法寂静义时。不分别菩提。亦不见寂静不寂静义。非寂静外见不寂静。无有少分能观见想。于一切处能清净见。亦无少有可能清净。此是诸菩萨清净智门。由此门故。而能随念诸佛如来无边法藏陀罗尼门。能遍了知诸有情类自性本性。为诸有情开示演说此诸法藏。能遍清净。诸智慧业诸所愿求。于阿耨多罗三藐三菩提。现等觉已。增上意乐终不退转。及能随念善清净愿。于一切法速得自在而能习行。诸佛如来大慈大悲。一切如来善巧法藏。皆现在前。及能示现无量无边大法光明。身常安住诸佛智境。无边庄严。此无量无边法门。谁之增语。无边庄严。无量无边者。谓一切法地水火风虚空识界。皆无量故。欲界色界及无色界。诸有情界无有量故。然无少分诸有情界可得了知。有情无故。如是如是。此有情界不可得不可了知。界无有故。是故诸法等涅槃界。趣入涅槃。一切诸法皆同趣入不可说处。于涅槃界无有少分而可说故。涅槃界中无有障碍。亦无盖覆障碍。盖覆永清净故。是故涅槃界清净最清净。是涅槃界。界亦非界。远离界故。无有界故。超过界故。然以似界方便显说。所言界者。安住非界及非非界。于言说中亦无有界。但以语言显说诸法。所有言说及能说者。皆不可得不可了知。一切言说即非言说。如是一切言说。如虚空性等入虚空。由是地界不能言说。无能说力。乃至空界不能言说。无能说力。言识界者。由是但以语言显说诸法。而彼识界。界亦非界。不入诸界。不与界相应。非不相应。从虚空生入于虚空。如是识界。不在内不在外不在中间。随其空分之所摄受。趣入虚空。不可施设不可睹见。若不可施设彼无所作。余缘相应说有识界。此是菩萨之所入门。一切诸法本性自性。犹如虚空。以依法界开示演说。而亦无有诸法之界。界非界故。一切诸法犹如虚空。是故如来。说一切法皆是虚空。量难得故。显一切法皆虚空性。诸法本性如虚空故。但以语言开示演说。无边庄严。汝观如来智所演说。尔所清净。彼无法可生。亦无法授与。如是清净法教。是诸菩萨不颠倒智。是故汝等。应当愿乐不由他缘。智得无分别不增分别。及能清净。不可言说理趣法门。由一切法智清净故。佛告无边庄严。诸飞鸟类于何所行。无边庄严白佛言。世尊。行于虚空。佛复问言。虚空复何所行。答言世尊。如是虚空无有所行。佛言。如是如是。一切诸法犹如虚空无有所行。行无所行法不可得。是故诸法无有所行。亦复不行。诸法本性无有可行。及无可说。而此法门为诸菩萨得虚空智清净故转。此是无边光明法门。普遍照耀无量无边。犹如虚空。彼之光明普遍照耀亦不可见。菩萨得是门已。能遍观察十方世界。及能随见一切世间。无边庄严。此是菩萨智所知地。通达智地。而非一切他论者地。彼不能说故。此法理趣是不可说法印。语言显示不可得故。是故一切诸法不印。亦不增印。了知不印。修习善巧故。以虚空印印一切法。以无相印能示现彼虚空无相。无有为相无语言相。以空无故说此虚空。所言虚空。彼无实体故说为空。以真胜义。应知诸法无言彼岸。无边庄严。我于此中。当说陀罗尼印能清净句。为虚空句。智清净故。如空无句无句清净。如是应当了无诸句。其句云何。即说咒曰

毗筏嚟(一)毗筏啰(引)弩娑呬谛(二)钵啰(引二合)弩儞(三)儞珊那(上)尾筏啰尼(上四)阿毗夜(二合)筏伽(引)赊珊奈设儞(五)钵啰(二合)皤(去)嚟(六)钵啰(二合)皤(去)啰弭输达儞(七)涅毗羯鞞(八)阿(引)迦(去)赊三摩筏娑啰尼(上九)儞省霓(十)省(上)伽(上)波揭底(十一)省(上去)伽(去)毗牟折儞(十二)阿(引)娜(上)驮儞(十三)阿(引)驮(去)曩毗揭帝(十四)姜(去)乞沙(二合)掣(去)那钵唎羯么(十五)遏掣(去)泥(十六)阿弩钵掣泥(十七)阿三(去)冥(十八)地毗耶(二合十九)若曩阿(引)呵啰宁(二十)钵啰(二合)攘斫刍毗输驮儞(二十一)设黎耶(二合引)播那耶儞(二十二)地孕(二合)只乌怛啰尼(上二十三)阿喻鸡(二十四)阿毗喻鸡(二十五)阿三钵啰(二合)喻鸡(二十六)阿毗钵啰(二合)喻鸡(二十七)阿纥啰(二合)钵驮涅贺嚟(二十八)涅提赊钵驮毗输达儞(二十九)阿底多(引)那揭多钵啰(二合)底逾(二合)般那毗输达儞(三十)讫唎(二合)多钵唎(二合)羯么毗儞谛(三十一)曩多(引)啰他(二合)弩揭谛(三十二)阿僧羯啰(二合)冥(三十三)阿讫啰钵驮毗输达儞(三十四)钵驮钵啰(二合)陛驮攘那毗输达儞(三十五)涅皤斯(三十六)阿(去)皤(去)婆毗输达儞(三十七)三漫多奈赊地赊毗耶(二合)筏卢羯宁(三十八)弭啰(引)疟(上)钵驮涅诃嚟(三十九)钵啰(二合)若弭输地(四十)呜(上)皤(去)娑阿钵啰(二合)冥迦啰尼(四十一)阿矩罗波(二合)达摩奈唎设那弭输达儞(四十二)步多(去)遏啰他(二合)珊奈唎设儞(四十三)阿怒耄驮遏他(二合)弭输诞儞(四十四)娑竭啰质多弩钵啰吠世(四十五)谜嚧钵唎僧萨他(二合引)宁(四十六)啰湿弭(二合)钵啰(二合)多钵儞(四十七)萨婆路迦(引)地钵帝耶攘囊尾输诞儞(四十八)阿钵啰(二合)底褐多(四十九)阿僧伽攘那奈唎(二合)设宁(五十)

佛言。无边庄严。此诸陀罗尼印能清净句。演说虚空分段之句。无有分段遍无分段。无分段故于中无句。无句清净。由一切法句清净故。为彼发趣住大乘者。希求甚深清净法者。由如来力所加持故。此诸咒句而得流布。无边庄严。若善男子爱乐现证大菩提者。欲为众生作利益者。于此咒句虽未曾闻而能悟解。若有非人或净居天。持此咒句当授与彼。若有发趣阿耨多罗三藐三菩提者。诸天子等。亦持此咒而授与之。即说咒曰

乌波僧荷嚟(一)娑荷嚟(二)纥唎(二合三)室唎(二合)地唎(二合)底弭输诞儞(四)羯量曩遏他(二合)涅弟闪钵啰(二合)底皤底(五)质多末弩弭攘那弭输诞儞(六)阿(引)地耶(二合)怛么(二合)么呬遏驮钵唎输诞儞(七)揭底枲蜜里(二合)底末底(八)阿(引)褐啰儞岌多(九)岌多钵底(十)萨嚟(十一)萨啰筏底(十二)

佛言。无边庄严。有诸天神住雪山中。彼等天神。若如来力之所加持。而能授与诸说法者法之光明。即说咒曰

末底弭输诞儞(一)苏育多寐唎曳(二合二)阿竭啰(二引)呬多钵驮涅荷唎(三)阿枳逻(引)枲儞(四)阿弭逻枲儞(五)郁他(引)曩三半宁(六)弭儞多三么(引)那钵底(七)末底阿揭罗(二合)怒蘖谛(八)

大宝积经卷第六大宝积经卷第七

        大唐三藏菩提流志奉　制译

    第二无边庄严会清净陀罗尼品第三之二

尔时佛告无边庄严。有诸天神住鸡罗娑山。彼等天神。能令诸说法者六根清净。于诸演说开示法时。助其语业令相续说。即说咒曰

钵啰(二合)多钵怛底(一)吠嚧折那筏底(二)没陀末底(三)嚩苏末底(四)达摩末底(五)遏三钵啰(二合)谋(上)沙筏底(六)粤皤珊奈唎设曩筏底(七)乌波僧荷啰涅弟赊筏底(八)

佛言。无边庄严。有诸天神住娑罗林。彼等天神。能令诸说法者身语意业皆悉清净。及能令彼言音清彻。谓美妙声可爱乐声。及能授与爱语不相违语。即说咒曰

涅啰(引)蓝婆阿孽啰(二合)羯嚟(一)乞晒么毗制曳(二)涅皤娑筏底(三)涅荷啰筏底(四)乌阇筏底(五)乌波曩酩底(六)乌波僧荷啰羯啰尼(上七)阿(引)尾舍他(八)伊荷驮啰尼目溪(九)达摩目溪(十)达摩波吒嚟(十一)

佛言。无边庄严。有诸天神住雪山南面。彼等天神为说法者。于此法中勤修行者。乐求法者。爱乐法者。益其精气。即说咒曰

羯唎耶(二合)曩遏他(二合)微萨若儞(一)骄赊唎耶(二合)怒孽帝(二)呜播(引)耶僧仡唎(二合)呬(引)帝(三)微宁目帝(四)扇(引)多钵那微萨啰儞(五)乌皤(引上)婆耶赊筏底(六)

佛言。无边庄严。有诸天神住大海岸。彼等天神为闻法故。为诸法师而作安乐。如来为欲利益彼故。说此咒句。及天帝释亦能授与此诸咒句。此是能摄帝释等句。即说咒曰

么弃钵底(一)么苏莽底(二)泥(引)婆(上)阿啰(二合)若(三)舍至钵底(四)萨婆阿苏啰曩(五)涅罗(二合)伽(引)多儞(六)未而晒(二合)野(七)素钵啰(二合)底瑟耻多(八)钵啰(二合)莽阿啰(二合)娜怒(上)比(九)阿素啰(上)喃(十)泥嚩南(上)阿地钵砧(知临反十一)萨(上十二)那布啰塞仡唎(二合)睹(引)呬涅(十三)泥微呬庶(上)皤(上)细(十四)嚩(引)娑嚩萨那(十五)布烂奈啰(十六)都(十七)多(引)闭肆(十八)阿素啰(二合)萨那(十九)堕喏(上)阿[起-巳+乞](其迄反)林(二十)多嚩(二合)钵施埵(二十一)微图孕(二合)肆多(二十二)么诃素啰(二十三)阿素丽那啰(二合)钵啰演底(二十四)避(引)多啰(二合)悉多(二合二十五)那输地赊(二十六)那莽勃陀肆也(二合二十七)已曷底(二合)使曳(二合二十八)曩么狱(去)多啰(二合二十九)摩诃野舍(三十)泥嚩(引)阿素啰肆酩(三十一)僧孽啰(二合)名(上三十二)勃陀摄陀(三十三)阿耨多啰(三十四)室啰(二合)末斯(三十五)泥嚩微誓耶(三十六)那么勃陀(引)底曩(引)莽斯(三十七)僧(上)羯啰(二合)么阐(引)那(去)斯末捻(引三十八)勃陀囊(引)铭曩嚩呬多(三十九)微誓曳素(四十)多多泥嚩(四十一)阿素啰室者(二合四十二)微宁多[口*梵](四十三)讫里(二合)多(引)帝(四十四)啰乞沙(二合)泥嚩(引)南(上四十五)么努沙(引)南(四十六)啰乞沙(二合)三(上)尾那(四十七)曳翳诃(四十八)达么儞泥世(四十九)污多囒(二合)底(五十)素(引)钵啰(二合)底瑟耻(二合)多(五十一)宁疙(鱼近反)里(二合)呬多(五十二)多嚩(二合)夜(引)阿素(引)啰(五十三)阿啰(二合)去洒(二合)娑药叉紧那啰(五十四)曩(引)伽鸠盘吒步多儞(五十五)毗舍(引)遮那曩嚩多他(五十六)阿者罗悉他(上二合)曩(五十七)钵啰(二合)钵睹肆(五十八)印那啰(二合)印那啰(二合五十九)布啰(二合)塞讫里(二合)多(六十)阿底严毗(引)啰(六十一)扇(引)旦(引)者(六十二)阿孽啰(二合)布[口*路]沙(六十三)细(引)尾囊(六十四)钵啰(二合)攘漫睹(引)肆(六十五)泥末那啰(二合六十六)勃地么(引)多他微庶路(二合)多(六十七)阿(引)末舍翳诃(六十八)素多啰(二合)肆氏(六十九)阿啰(二合)乞沙(二合)三(上)末娜呬多(七十)娑诃萨啰(二合)泥多啰(二合七十一)素(引)目佉罨播娑(二合)丽(七十二)钵唎嚩(引)履多(七十三)污波闷攘(汝阳反)萨嚩(二合)甘羯忙(七十四)布啰(二合)迷呬睹肆酩(七十五)野讫唎(二合)檐(七十六)阿底钵始遮(七十七)阿努钵啰(二合)没多(七十八)阿者罗素钵唎(二合)底瑟耻(二合)多(七十九)讫里(二合)胆呬(八十)据舍蓝布啰(二合)迷(八十一)么怒世数(八十二)忙呬(引)钵底(八十三)布啰嚩(二合)虚牟肆(八十四)泥嚩(引)南(上八十五)布[口*誓]印底(八十六)答嚩忙努(引)沙(上八十七)勃陀肆野(二合)讫唎(二合)得嚩(二合八十八)萨得迦(二合)蓝(八十九)布阇陛杀底(九十)帝莫呼(九十一)摩诃嚩莽宁(九十二)微者蓝皤嚩南者(九十三)素庶(引)皤底(九十四)泥嚩来野肆(去九十五)莽地野(二合)肆氏(九十六)野去疏(二合)呬(九十七)播履嚩履睹(九十八)钵啰(二合)滥磨(九十九)呵唎磨[合*牛]者(一百)多嚩肆迦(一百一)微舍那阿疙啰(二合)嚩(引)呬(一百二)娑哆底么底(一百三)素啰多钵啰(二合)底(一百四)娑啰多娑多他(一百五)钵啰(二合)部(引)萨建陀(一百六)阿儞啰者莽啰者(一百七)摩诃磨霓(一百八)摩诃萨建(引)陀(一百九)摩诃计都(一百十)素钵啰(二合)地者(一百十一)摩诃磨啰(一百十二)翳帝药叉(一百十三)摩诃帝喏(一百十四)阿啰(二合)乞羼(二合)底皤嚩南多嚩(一百十五)摩护药叉钵唎(二合)嚩(引)[口*路](一百十六)曳那输皤肆嚩娑嚩(一百十七)摩素萨嚩嚩素底喏(一百十八)摩诃帝喏摩诃仰儞(一百十九)摩诃钵啰(二合)诃啰怒制嚩(一百二十)阿尾呬(上)娑那耶(引)多替嚩者(一百二十一)素名嚧暮啰陀(二合)儞(一百二十二)多嚩嚩娑嚩(一百二十三)萨嚩泥嚩(一百二十四)布啰塞讫唎(二合)睹(一百二十五)庶(去引)婆底(一百二十六)婆嚩曩污婆(引)娑(一百二十七)钵啰(二合)磨闷者肆(一百二十八)底喏娑(一百二十九)

佛言。无边庄严。此是能摄帝释等句。若善男子趣菩提者。于彼后时有诸众生摄受法者。及为众生摄法善巧得安住者。由是诸句。天帝释等而当授与此等诸句。佛言。无边庄严。何者是能摄四天王并眷属句。而说颂曰

  于彼住夜叉　　无忿无扰乱
  多闻之长子　　及父咸恭敬
  删阇耶夜叉　　及诸胜军旅
  而常拥护彼　　爱乐此法者
  持国大神王　　恒将诸眷属
  彼亦常卫护　　善说此经者
  丑目之眷属　　自身与军众
  若能住此教　　一切当拥护
  增长王亦尔　　军旅及诸众
  爱乐此法者　　普皆作卫护
  幢幡大幢力　　此住于东方
  大称罗刹斯　　彼皆摄入此
  而于此法门　　有能受持者
  自身与眷属　　常亲近守护
  蓝婆毗羯遮　　并及悉驮多
  奚离末底等　　此皆住南方
  侍卫于帝释　　彼皆摄入此
  拥护益精气　　一切智者说
  剑离三蜜多　　及伽罗系翅
  并与蜜室多　　名称罗刹斯
  皆住于西方　　此等皆摄来
  说法了义者　　一切常拥护
  实谛有实谛　　名称罗刹斯
  深信于此法　　彼住于北方
  佛为拥护故　　摄彼来入此
  由如来威力　　一切合掌住

佛言。无边庄严。何者是能摄四天王并诸眷属侍从内宫令入之句。即说咒曰

散宁微舍儞(一)摩诃(引)萨嚟(二)摩诃揭儞(三)摩诃揭若儞(四)钵啰(二合)步(引)多微誓曳(五)驮嚩(二合)社阿孽啰(六)污播嚩(引)萨儞(七)阿儞逻(引)细曩睹娑呵(八)曩曩筏囊奈赊儞舍(九)折埵唎(引)路(引)迦播(引)啰儞(十)睹肆铭啰(引)若曩污折他(十一)阿(引)吠设娜(十二)伊呵萨曼嚩(引)呵啰他(去十三)勿啰(二合)[口*誓]宁孽啰(二合)呵(十四)萨迷折突地舍(十五)

佛言。无边庄严。何者是摧伏魔波旬句。汝应谛听善思念之。即说咒曰

蜜底丽(二合一)蜜多啰嚩底(二)迦[口*路]宁(三)迦[口*路]曩嚩底(四)微步(引)底(五)微步(引)多嚩底(六)钵啰(二合)牟折儞(七)钵啰(二合)牟折囊嚩底(八)讫唎(二合)多讫唎(二合)多嚩底(九)阿怒仰酩(十)阿怒仰莽嚩底(十一)邬播(引)多掣娜儞(十二)伽(引)么微嚩攘儞(十三)底唎(二合)瑟曩(二合)娑牟姝(去)杀儞(十四)儞孽唎(二合)呬(引)多忙(引)啰嚩蓝(十五)嗢多啰囊嚩底(十六)钵啰(二合)底与(二合)多啰嚩底(十七)邬闭(引)去沙怒娑呬帝(十八)阿(引)灆么囊微输驮儞(十九)宁那啰(二合)舍曩(二十)阿三(引)暮(引)诃儞(二十一)儞瑟(二合)钵啰(二合)半(引)者宁(二十二)

佛言。无边庄严。此是摧伏魔波旬句。由是句故。不令天魔及诸军众而得其便。佛言。无边庄严。何者是能摄彼大梵天句。汝今谛听善思念之。即说咒曰

阿地钵底(一)摩诃悉他(去引二合)曩(上)筏底(二)娑嚩(二合)琰讫唎(二合)多(三)悉他(引二合)曩酩底(四)曩曩摩护微尾驮(五)钵啰(二合)底与(二合)播萨他(二合)曩伽啰曩(六)阿地伽萨他(二合)曩钵底(七)庶驮萨他(引二合)曩孽睹(八)娑含(引)钵底(九)阿地羯烂(引二合)多(十)微庶(引)驮曩(十一)庶婆钵唎(十二)钵啰庶皤(引)地目多(十三)钵啰(二合)勃多(二合)室唎(二合)多(十四)儞嚩(引)娑囊(十五)钵啰(二合)步(引)多(十六)钵啰(二)皤(十七)儞孽啰(二合)蹊(引)多伽(上)么(十八)娑嚩(二合)悉底(二)伽(引)么(十九)钵啰(二合)底与(二合)播萨他(引二合)曩(二十)

佛言。无边庄严。此是能摄大梵天句。由是句故。大梵诸天能授与彼诸说法师清净妙善等。引梵行圆满文句。佛言。无边庄严。何者是净居诸天法光明句。汝今谛听善思念之。即说咒曰

微输(引)驮曩嚩底(一)案底么伽(引)噜儞(二)伽(引)么磨嚩(三)邬娑(引)多(上)儞(四)钵啰(二合)涅酩多(引)儞(五)钵唎(二合)演多(六)钵啰(二合)底与(二合)波悉他(二合)曩钵耶(引七)嚩娑(引)曩(八)阿(引)赖耶微输(引)驮儞(九)阿(引)攘钵演多伽啰儞(十)案底么泥(上)舍(十一)钵啰(二合)底与(二合)播悉他(引二合)宁(十二)

佛言。无边庄严。此是净居诸天法光明句。由是咒句而能授与诸善男子我诸法藏。佛言。无边庄严。若有天王。人王。阿修罗王。迦楼罗王。及诸龙王。或大威德小威德者。若信不信诸众生等。我皆授与陀罗尼句。令其信者于此法中获增上信。其不信者默然舍之。不令得起语言诤论。说此法时。若有来作障碍留难而悉摧伏。此中何者是能摄取净信者句。即说咒曰

愚嚧那(上)嚟(一)阿者钵丽(二)娑嚩(二合)毗涅呵(引)啰(三)句末泥(四)涅攘曩钵啰(二合)底微嚧异宁(五)只多珊者曩儞(六)只多钵唎(二合)羯酩(七)只多三(上)钵啰(二合)娑(引)那儞(八)么曩肆也(二合九)呵唎洒(二合)伽啰儞(十)微攘曩肆也(二合十一)阿怒娑嚩(二合)底(十二)阿怒达么努闭去洒(二合)宁(十三)呬都珊那唎舍儞(十四)多他阿去杀(二合)啰钵那(十五)涅泥(上)舍(十六)输(引)地多(上)嚩底(十七)野他(引)孽多(十八)野他努句路(上)播么(十九)邬播莽涅泥(上引)舍(二十)微庶(引)地多(二十一)怛多啰(二合)伽(引)丽(二十二)曩者羯答微阎(二合二十三)三(上)钵啰(二合)娑(引)娜遏他(二合)睹娑么(二十四)野他(引)怒句懒者目佉(二十五)邬波僧贺啰喻儞舍(二十六)阿(引)舍耶肆也(二合二十七)微庶(引)地耶(二十八)野他庶(引)地底(二十九)罗去洒(二合)曩罗去洒(二合)儞(三十)罗去洒(二合)曩嚩底(三十一)罗去洒(二合)囊微输驮儞(三十二)钵啰底吠驮遏他(三十三)珊那唎(二合)舍儞(三十四)句舍啰冒他萨谜呵(三十五)钵啰(二合)微者曳(三十六)娑么娑啰儞(三十七)讫唎多(引)怒阿啰(二合)去史(二合三十八)萨底也(二合)遏替(三十九)萨底也(二合)南(上四十)素微输(引)地帝(四十一)

佛言。无边庄严。此是能摄净信者句及授与句。由是当能授与说此法师善品及义

善男子。我今复说摧伏不信者句。即说咒曰

去洒(二合)迷(一)去洒么嚩底(二)迷多啰(二合)钵唎(二合)羯么(三)钵啰(二合)底与(二合)波娑他(二合引)宁(四)伽[口*路]囊钵啰(二合)底逻(引)婆(五)呬多努剑跛(六)散喏曩儞(七)僧揭啰(二合)呵嚩萨睹(二合八)呬多嚩萨睹(九)散那啰(二合)舍儞(十)钵唎(二合)嚩喏儞耶(十一)嚩喏儞(十二)簸跛咩多啰(二合十三)细嚩儞(十四)曩坦多啰(二合)泥世萨他(二合)答微耶(二合十五)野多啰(二合)尾揭啰(二合)呵嚩底怒(十六)萨摩孽烂(二合)陀(十七)钵啰(二合)那(引)逻儞(十八)邬波蔗啰珊那唎舍儞(十九)儞舍啰(二合)夜微庶(引)驮儞(二十)阿(引)多么(二合)怒伽酩(二十一)钵啰(二合)邬波僧呵啰(二合)儞(二十二)涅酩多(引)儞(二十三)阿怒啰去沙(二合二十四)钵啰(二合)底与(二合)波娑他(引二合)宁(二十五)

佛言。无边庄严。此是调伏不信者句。由是不令造诸过恶。直尔善法尚多憎嫉。何况于此无上法教。是故此诸咒句。为灭一切诸过恶故。为断一切烦恼故转。无边庄严。我见众生心无净信。或欲斗诤。或欲损害。或欲恼乱。而来亲近如来。知彼心所动作。随其种类。以诸法门而作觉悟。令其舍离不善寻思。及令发起诸善根因。无边庄严。如来安住于十八种不共法中。能善了知众生心行。及能了知心所摄法。无边庄严。何等名为十八佛不共法。无边庄严。所谓如来于某时夜。现觉阿耨多罗三藐三菩提。乃至入于无余涅槃。于其中间无有误失无卒暴音。无忘失念。无不择舍。无种种想。无不定心。精进无退。念无退。志欲无退。等持无退。慧无退。解脱无退。解脱智见无退。一切如来身业智为前导。随智而转。一切如来语业智为前导。随智而转。一切如来意业智为前导。随智而转。如来智见于过去世无著无碍。如来智见于未来世无著无碍。如来智见于现在世无著无碍。无边庄严。如来成就此等十八不共法故。无量智见力悉皆成就故。能开演此陀罗尼门清净法品。为于不信一切有情生净信故。为净信者于此法门得清净智。无边庄严。如来随所乐欲。以诸无量种种语言。分别解说此陀罗尼门。亦不能说此陀罗尼门断疑理趣百分之一乃至俱胝百千算数及譬喻分。何以故。此诸法门是无量门。不思议门。此所有门。能得一切智智转故。复次无边庄严。由此如来以无量异名。今为汝等。开示演说此诸法门。欲令汝等普遍了知无量法门。得陀罗尼故。即说咒曰

怛侄他阿(引)唎曳(一)阿(引)唎耶(二合)嚩底(二)阿(引)唎耶(二合)怒(上)揭帝(三)儞驮(引)宁(四)儞驮曩嚩底(五)嚩睹钵啰(二合)酩(六)嚩啰睹(二合)簸掣那(上)伽啰儞(七)阿(引)伽(引)舍微输(引)驮儞(八)阿怒去铩(二合)簸儞(九)阿宁去铩(二合)簸儞(十)阿微孽多钵啰酩(十一)阿怒播孽(上)底儞(十二)涅畔(引)曩钵他微输(引)驮儞(十三)微耶(二合)波儞去史(二合)钵底(十四)阿怒播(引)那(十五)宁[口*路](引)驮播啰酩(十六)萨嚩攘涅畔(引)曩(去)宁那啰(二合)舍宁(十七)

佛告无边庄严菩萨言。此诸陀罗尼印能清净句。异名说句。由受持此陀罗尼法门。以少功用。证菩萨位差别妙智。及近大悲。由随义觉。证得悟入一切法智。无边庄严。此陀罗尼句是大良药。以能除破诸重病故。复能除灭无明无智极黑闇障。随顺明法圆满转故。随何明法圆满而转。谓随顺明法智圆满故。而能现证宿住智明。随顺明法智善巧故。而得出生天眼智明。随顺舍离诸烦恼故。能现证得漏尽智明。由此复能获得一切所学波罗蜜多无上知见一切智智见一切智智地。无边庄严。汝观如来善能如许广大说法。于诸方便善巧圆满。无边庄严。如来如是成就大智。能善安住一切智智力无畏等。此无上宝藏。于无量俱胝那由他劫。所修善根之所积集。以是缘故。能善安住此诸法门。今为汝等成熟佛法。于法理趣出生善巧。开示演说此陀罗尼清净法品。若善男子善女人等。发心求趣大菩提者。而欲随我正修学者。于我法教欲拥护者。于诸如来无量法藏欲受持者。于此法中。当勤修习志乐精进。住不放逸不着三界。于一切智智心作意善加持者。于诸色缘清净善巧善修习者。于受想行识清净善巧勤修习者。于实谛句出生清净勤修习者。于诸法中。应可乐求诸清净智。无边庄严。由内清净故一切法清净。由内寂静故一切法寂静。由内寂灭故一切法寂灭。由内无所取故一切法无所取。由内不住故诸法不住。由内灭故一切法灭。由内无所作故一切法无所作。由内无来去故一切诸法亦无来去。无边庄严。此诸门句。令诸菩萨内清净转。由外本性无分别故。不起分别。然能受持清净陀罗尼门。舍离贪恚心不贡高。为诸如来之所称叹。于诸众生最为殊胜。作无上主。当能证得无碍智说欢喜辩才。于前后际得清净智。能遍记[竺-二+別]而能随念中道之性。及能证得无生法忍。能证缘起愿殊胜性。及于诸愿能遍清净。当能遍持不共一切法智善巧。所发语言众皆信受。能于当来雨大法雨。无边庄严。菩萨由得陀罗尼故。必定当证无生法忍。逮得一切法清净智。及能出生如是法智。谓一切法不生不灭。而复证得如是法智。谓虚妄生生不成就。不成就者即便散坏。散坏法者而无所趣。此一切法皆灭坏门。此灭坏门同无生相。若是无生彼即无灭。如实观察一切诸法。远离相已则不执着则不戏论。无边庄严。此是诸菩萨无生智门善巧观察。而能入此诸陀罗尼。由是速能获无生忍辩才具足。尔时世尊欲重宣此义。而说颂曰

  若法虚妄生　　生已必灭坏
  诸法离于有　　于谁可遍持
  诸法既非有　　无有无可取
  若法不可得　　于何而遍持
  若不了诸法　　自性不可得
  彼则行于相　　不得陀罗尼
  诸法如虚空　　由是说开示
  虚空及开示　　二俱无所有
  此二离于有　　诸法亦空无
  如是解法者　　彼能获总持
  随觉无初始　　不分别中后
  诸法离分别　　一切悉空无
  若处无坚实　　不实亦非有
  依诸法真理　　云何得遍持
  如是了诸法　　自性无所有
  我今略说彼　　得清净总持
  诸法如虚空　　亦等于空旷
  以慧常观察　　彼能获总持
  诸法无所有　　不生亦不起
  无有无可取　　此云何遍持
  一切法无相　　自性无戏论
  一切皆离相　　说法无所有
  若能如是解　　一切法如理
  彼则无分别　　而能得遍持
  诸法以自性　　无故不可得
  解了无有义　　彼成就总持
  若如是观察　　一切法不染
  智不分别空　　彼能持诸法
  无常义空义　　苦义及厌离
  若以慧了知　　彼智得增长
  示说无所取　　涅槃如理义
  坚无分别意　　亦不分别法
  由是能受持　　诸法不坚固
  无有无所取　　寂静空难见
  若解法已说　　于说不分别
  无著无分别　　能持此法门
  若解了相已　　能了于无相
  彼亦于诸法　　不起舍离想
  彼能了此义　　正觉之所说
  善巧说秘密　　彼能随我觉
  若如理观察　　无量一切法
  彼舍离诸量　　能觉此理趣
  若能观察法　　无名及无相
  能了达此义　　彼能增长忍
  诸愿与殊胜　　及如理观察
  所愿并诸色　　不住能违彼
  了此法门义　　能如理观察
  于诸法理中　　彼亦无疑惑
  若以慧观察　　一切诸法相
  决定解了者　　彼则入无相
  彼于此理趣　　能了善安住
  如是无畏者　　能速证佛法
  于法不戏论　　平等无分别
  了法相应已　　于厌离无惑
  于灭不分别　　蕴尽寂静义
  彼于法平等　　得如理辩才
  能修习慈悲　　利益诸众生
  善住相应者　　彼觉了无上
  若离众生相　　能了法无我
  法无戏论义　　如理不戏论
  若闻此法已　　能速得净信
  彼当见正觉　　弥勒两足尊
  彼令我欢喜　　于此众会中
  若有闻此法　　彼能作贤爱
  敬爱如来者　　是则无破坏
  由闻此法已　　能为善贤爱
  若于贤劫中　　欲见诸如来
  修学此法门　　能令诸佛喜
  无量寿威光　　阿閦大名称
  若欲见彼者　　当学此法门
  若欲成菩提　　寂静最胜法
  或求转轮位　　当学此法门
  若乐求最上　　善巧总持门
  当于此法学　　常应不放逸
  若欲成广大　　最上殊胜愿
  求证菩提者　　当学此法门
  此经之所说　　陀罗尼法门
  能开示诸法　　此印最无上
  诸法内真实　　以总持开示
  此虚空法门　　善决无边义
  所说诸善门　　此法能开示
  总持义善巧　　陀罗尼力故
  总持说为慧　　能持一切法
  总持义善巧　　以慧能了知
  于此异多释　　已善说佛法
  以义正开示　　无上菩提分
  差别智善巧　　于斯正开示
  若于此法学　　证无上菩提
  于此教开示　　无上善法门
  得方便智已　　应当说此法
  未曾说诸法　　此无上种性
  于此义当学　　开示甘露句
  智者若欲求　　诸佛无碍慧
  若于此义学　　当获最上智
  我于往昔时　　无量无数劫
  若不学此法　　不证寂理趣
  由我曾供养　　无量百千佛
  为是能了知　　说此无上法
  我为诸众生　　作无边义利
  汝等应当作　　得此陀罗尼
  若能了知此　　陀罗尼门印
  智者由一句　　能入此法门
  我智慧无上　　亦无有数量
  由我具智蕴　　能开示此法
  智者于此求　　随觉菩提义
  于此义法门　　无畏当勤学
  智者若欲求　　广大智慧性
  于佛生尊重　　当学此法门
  若欲转法轮　　及吹大法螺
  智者应如理　　当学此法门
  若欲放光明　　普照无边际
  求于佛法时　　于此如理学
  于天人世间　　若欲为上首
  彼可学此经　　决定一切法
  欲求广大智　　发起诸功德
  乐求佛慧时　　于此应随学
  欲开示法门　　乐求于最胜
  无戏论佛智　　于此义当学
  若欲乐开示　　无碍智所说
  修学此法已　　应说甘露句
  若欲照俱胝　　无量无边界
  彼等于此教　　应当善修学
  此无上法门　　能净除诸法
  一切法清净　　于此经中说
  种智两足尊　　演此广大法
  于为菩萨说　　此经最无上

佛告无边庄严。是故诸菩萨。于此法教生爱乐已。为摄此法令久住故。复为哀愍诸众生故。于此法教应当书写受持读诵。无边庄严。若复有人。于彼时中闻此法已。于如来所。以爱乐心而常思念。彼诸人等。当得如来无边法藏诸陀罗尼。辩才具足。于一切法速得自在。能具摄受不可思议佛刹庄严声闻菩萨。无边庄严。若诸菩萨住一切法无戏论者。由陀罗尼清净门故。此诸法门常得现前。皆能摄受无量不可思议殊胜功德。无边庄严。此是第三陀罗尼门清净法品。无边庄严。于彼后时。若有菩萨。欲随我学此陀罗尼法门者。当亲近善友远离恶友。为遍拥护此诸法门。当舍身命受持陀罗尼清净法印。譬如迦利邸迦月圆满时。光明照耀于众星中最为殊胜。如是此陀罗尼印三品。摄受所有法门亦复如是。于一切契经中。此法光明最为殊胜。一切菩萨皆大尊重故。能出生无量辩才。此无量辩才。应知即是不放逸地。何者是于不放逸地。谓于此法作意思惟。如理观察不生妄念。如是能令遍忍清净。若诸菩萨精勤志求不放逸者。于此法门应善修习。为令此法得久住故。心常谦下尊重于法。书写经卷不离身手。见有志乐希求法者。发心趣向大菩提者。应当为彼开示流布教授读诵书写经卷。乃至随义而为解释。如其受持所有法门不应藏匿。愿诸众生得此无上佛法。利益我等。当令一切众生于诸佛法常不缺减。如是菩萨。于法无吝常乐施人。于义不秘尽皆为说。无少法门而不开示。无边庄严。应为利益安乐诸众生故。汝当受持此法门品陀罗尼门能清净句。尔时世尊。复告尊者阿难陀曰。汝当受持此法门品。我诸弟子承事我者。亦当受持如是经典。时阿难陀白世尊言。以佛神力我已受持。我由成就此法门故。无量法门皆得现前。佛言阿难陀。如是如是如汝所说。由佛威力及此法门遍清净故。诸有受持此法门者。及亲事我能受持者。无量法门皆得现前。是故阿难陀。汝当受持如来法教无量法藏。说此法时。于众会中。无量菩萨即便获得大法光明。得法光故。无量诸佛所说法门皆得现前。及得近于一切智智。如所乐求。胜愿庄严悉能成就。阿难陀。汝观诸法本性甚深。如是如来能于无名相法作名相说。又能开示诸法本性。亦复净除令见清净。虽说诸法无法可说。亦无能说。佛言阿难陀。若能如是观诸法性。便得发生无量智慧。说此法时。无数菩萨证无生法忍。无量众生发阿耨多罗三藐三菩提心。于阿僧祇劫当证无上正等菩提。复能出生无量辩才。尔时世尊。加持此陀罗尼门。放大光明。其光普照无量无边诸佛世界。由此光明。彼诸世界所有菩萨。皆悉得闻此陀罗尼。闻此法已能遍成熟菩提法分。于彼复有无量众生。皆发阿耨多罗三藐三菩提心。当于尔时。一切众生皆得安乐。是时复有诸天。雨天波头摩华。于大众会诸菩萨中。唱如是言。愿一切众生得佛智慧。尔时无量辩才菩萨白佛言世尊。当何名此法门。我当云何奉持。佛告无量辩才菩萨言。此法门名陀罗尼王。亦名陀罗尼印。亦名三品所摄善巧。汝当受持。此是无边辩才。摄一切义善巧法门。由此法门。而能照了一切诸法。断一切疑。是故诸菩萨于此法门。应当奉持。尔时一切大众。为供养法故。以五色华散于佛上。佛说此经已。诸菩萨摩诃萨一切众会。及天人阿修罗乾闼婆等。闻佛所说。皆大欢喜信受奉行

大宝积经卷第七大宝积经卷第八

        西晋三藏竺法护奉　诏译

    密迹金刚力士会第三之一

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。四万二千菩萨。八万四千一切大圣。神通以达。各在十方异佛国会。故来集此。皆得法忍。至不退转一生补处。逮致总持。辩才无碍周流十方无数佛土。神通自娱。弃诸外学。降伏众魔消诸怨敌。等心众生睹一切原。晓了三界众生根本。普入一切诸度无极。常处闲静。善权方便靡所不通。诸佛咨嗟宣扬其德。修无数劫奉开士行。积功累德亿载兆垓。从无限世心平如地。诸佛土境不可限量。所行清净。弃众挂碍除诸阴盖。其身坚强犹如钩锁。得金刚志致道圣性。大师子吼独步众会。体解所入得无所畏。光蔽日月阐曜真法。等于三世。去来今得寤惑决疑。深入微妙下于缘起开化刚强。捐舍断灭有常之想。一切禅思三昧正受。将护畅达处处所入。十方闻声受无重问。不断三宝训诲言教。积德无量兴隆道宝。过诸声闻缘觉之地。行无尽慈遵无极哀。摄四梵行四恩普济随时开度。过三脱门至三达智。周旋三界犹如日月。往来四域如转轮圣王。以勇猛慧度生老死。出入五趣如炬照冥。心无所著犹如莲华生于污埿。行无增损犹如虚空无所增爱。颁宣三藏如国明君赐报印绶拜与官号。超俗八法不以戚忻。游入八难化众危厄。以慧成就转不退轮。解众废乱显示正真本无之法。发训超分至一切智三界为震。佛十八法。诲诸愚冥。离于三毒如吹浮云。以道法舟往度众生。劝十二海脱生死轮。往来三处济十二因。诸会菩萨具足功勋。其名曰月施菩萨。月英菩萨。寂英菩萨。首英菩萨光英菩萨。光首菩萨。首积。首寂。钩锁。龙忻。龙施。执像蜜天。缘胜。缘手。常举手。常下手。宝印手。宝掌。普世。宿王。金刚意。金刚步。不动行迹。过三世度。无量迹。无量意。海意。坚意。上意。持意。增意。常惨。常笑。喜根。善照威。离垢。弃恶趣。去众盖。极精进。智积。常观。光世音。大势至。山顶。虚空藏。不眴。不慕乐。宝上。宝心。善思。善思义。珠结总。豪王。净王。严土。宝事。恩施。帝天。水天。帝罔。明罔。喻天。积快。臂善。白象。香手。众香手。师子。英普。利意。妙御。大御。寂意。慈氏。普首。童真。其八万四千菩萨号各如是。尔时于是三千大千佛土。大尊巍巍。释梵四天王。诸天龙神。阿须轮。迦留罗。真陀罗。摩休勒。揵沓和。诸王官属咸来集会。阿耨达龙王。和轮龙王。摩那斯龙王。多朱龙王。雪色龙王。无量色龙王。须深龙王。及余无数百千龙王。并其官属皆来在会。闲居阿须轮。须摩质阿须轮。决河阿须轮。顺树阿须轮。璎珞阿须轮。狂惑阿须轮。断绝阿须轮。执鬼阿须轮。各与无数眷属。围旋皆来在会。摩竭国王萍沙。及宫人眷属皆来在会诸比丘比丘尼。清信士清信女。主天。地神。欲行天。色行天。净居天。悉来在会。彼时世尊。与无央数百千之众眷属围旋而为说经。颁宣菩萨诸大士业。其法名曰净济广布道义。何谓菩萨业。以行布施。开化众生救济危厄。修禁戒业。周满所愿十善之事。行忍辱业。备悉诸相八十种好严饰己身。行精进业。所造德本一切具足无所缺漏。行禅思业。志性和安成无思议。行智慧业断众尘劳。成就圣明化诸不达。行博闻业致无碍辩。所说如流听者辄受。行功德业。劝益众生无限之福。行圣明业。缘致无量至真辩才。行寂然业。所兴发众不可思议。行正观业。弃舍邪行无益之事。行慈心业。常修仁和未尝怀害。行哀之业。欲济众生不厌终始。行喜之业。乐法之乐而以自娱。亦化众生使慕道法。行于护业。断无量衅示其罪福。以法兼利。听法会业。去众阴盖令不自大。行出家业。捐舍恩爱恋恨之心世俗之习。行闲居业。所立要义不失一心。行有志业。逮得总持念法不忘以化众庶。行思念业。其意晓了靡不通达。行游步业。解义所趣有益不损。行意止业。观身痛痒心意诸法。行意断业。皆断一切众罪恶法。普修道义诸行妙法。行神足业。轻其身心往来趣厄救众下劣。行诸根业。具足寂静。眼耳鼻口身心使定不乱。行诸力业。消众尘劳瑕秽之非。常能自制亦化众庶。行觉意业。畅自然法以达正己。行于道业。越众邪径九十六种。行真正业。致仁义事无有嗔喜。行解辩业。见众生心而为开阐。行自归业。己身自达不须仰人。行善友业。通功勋门济以慧德。行纯性业。普和三世无有欺惑。行应时业。皆能具足越一切难。行圣贤业。所往殊特与众超异。行宴坐业。如所闻法常奉行之。行四恩业。合聚于众为演经法。行正法业。顺三宝教令不断绝。晓劝助业。勤化众生严净佛土。权方便业。普用具足一切愍智。世尊如是。广为一切宣菩萨业。名曰清净。于是金刚力士。名曰密迹。住世尊右。手执金刚前白佛言。至未曾有如来至真。快说菩萨号净济业经典之要。如向大圣颁宣斯法。我察思议是一切业。皆入菩萨众德慧业。所以者何。其妙功德悉诸菩萨之所娱乐。所化变示。以是所乐摄导众生。其慧业者。菩萨雅词多所悦可。若有菩萨。晓了举要功德之业。修慧明业。是行第一真实至诚。所以者何。其功德业。则是菩萨善权方便所度无极具足福庆。其斯慧业。则是菩萨智度无极众行备悉。以是二业。普备一切诸菩萨道而恩广济。诸魔官属莫能当者。以度魔界。菩萨如是至不退转。当成无上正真之道。计于法本。诸不退转近佛世尊。皆致如来秘密要藏。恣意颁宣未曾覆匿。于时寂意菩萨。谓密迹金刚力士。密迹。所云有二事业。近于如来慧。仁能乐住宣于如来秘密之业。非诸声闻缘觉之地所能及逮。况余凡庶之所及乎。时密迹金刚力士默然不报。时寂意菩萨前白佛言。密迹力士。岂能屈意为斯众会。随时敷演诸菩萨密如来秘要。一切众会普共渴仰欲得闻之。若闻所说心中坦然。忻喜大悦奉菩萨行。具足成就此要密事。心性调和入无极慈。佛告密迹。金刚力士。仁能重任为此众会。说菩萨密如来秘要。千佛劝叹。卿宣诸菩萨道品诸行。众会乐闻。密迹金刚力士前白佛言。少能堪任为诸众会。宣菩萨密如来秘要。假使如来劝佐威神。而见扶接。乘大慧光承佛圣旨。乃敢宣布诸菩萨密如来秘要。犹如世尊。夜闇冥时依灯火明。得见形色往来好丑东西南北所当进退。如是世尊。若见建立。承佛圣旨。所知少小粗举叹说。佛言善哉。便时宣之。时密迹力士语寂意菩萨。仁者且听。及诸来会。闻诸菩萨密如来秘要。勿恐勿怖无以怀怖时寂意菩萨告诸会者。如来所宣布四不思议。以是得成无上正真之道。逮最正觉。何谓为四。所造立业不可思议。志如龙王行不可计。禅思一心不可称限。诸佛所行无有边际。是为四事。仁者当知。是四不可思议。佛道所行不可思议。为最至尊以成正觉。是故名曰四不可思议。诸仁集会。若闻菩萨诸佛世尊不可思议。不当恐怖而怀畏惧。益加踊跃倍抱恭恪。乃达大道。尔时寂意。即如其像三昧正受。令一切众会闻如来法。无诽谤者各心忻豫。一切来集众会场地。天雨众华诸心念华若干种品。散于佛上及众会上。以用供养。于是密迹力士。语寂意曰。谛听谛听。善思念之。今当宣布诸菩萨密如来秘要夙夜寂然而修惔怕。如来菩萨所言至诚。无分别决乃授道别。从是以往顺从菩萨五行。菩萨无有谀谄。不为匿訑。不自贡高。现相应时自在变化。以自在心不计邪佞非法之业。谨慎身行威仪礼节。开化众生。口无所说不妄有辞。菩萨威仪不可限量。又次寂意。随众生行。因可开化一切威仪礼节之事。所行学问禅思礼节。使学若干音响言辞各令明了。男女所行举动进止威仪礼节。各以大小乳下婴孩。应见化者各慎威仪。长老中年少小之类。所可应化威仪礼节。尊卑豪贱明愚所行开塞达騃。所行多少威仪礼节。因依训诲应得度者而开化之。地狱饿鬼畜生之类。诸天龙神。阿须轮。迦楼罗。真陀罗。摩休勒。若人非人。所应开化而诱导之。比丘比丘尼。清信士清信女。释梵四天王。大神妙天。所应开化而训诲之。菩萨皆知深浅厚薄难度易化。应病与药而为说法。使诸贪淫不贪财业。建立威仪随其礼节。菩萨在彼无为寂然。以身修行。不舍静默显身威仪。若有贪嫉各为示现。不惜身命随时救济。身行清净体演光明。诸在地狱饿鬼畜生勤苦之患。济其危厄。立在安处令无众难。若有众生多所吝业。随其所好现若干种珍宝财业。各使得所。头目肌肉骨节支体髓脑妻子群从车马奴仆衣裘。从志所乐皆施与之。若求甘膳上好衣被。皆令充意各得其所。受诸众生无央数身法界无量举安无处饱满一切。道智无穷各现其身。在于十方不可限极。因缘方便亦不可尽。以无数身随时现体。开化众生各令得所。若有众生多贪欲者。淫想情色。化现女像端正殊妙。其人见之喜悦敬向。与共相娱视之无厌如宝明珠。卒便臭秽颜色甚恶。睹是所变心患厌之。便示死亡益用恶见。因为说法无常苦空。一切三界犹如幻化无一真谛。闻之则达。便发无上正真道意。逮不退转。又彼菩萨以一宝盖。覆斯三千大千世界。靡不周遍。复能内之于一芥子。若劫烧时皆举一切着其一掌。斯身不大亦不增减。其身供养周于十方诸佛世尊。复变化华如须弥山。怀之裓上。成为华盖贡上如来。化一香炉如千佛土。作一灯炬如须弥山。供奉如来。照恒河沙诸佛国土。以贡上佛。以细帛[疊*毛]裹覆其身。灌用麻油以为灯火。自然己身演其光明。照遍三千大千佛土。若众生见怪之所以。或得想念菩萨境界。睹此变化。无央数众皆发道心。得悦可意充实饱满。被弘誓铠现和罗势。执于无极。手持金刚力士侍佛而自显耀众人恐怖自归作礼。菩萨大士听受经法。示大力士在于冢间。大聚众人自现身死。形体广长弃大冢间。又诸禽兽食啖其肉。四足两足服食其体。寿终之后皆得生天。缘是为本乃至灭度。悉是菩萨本愿殊特之所致也。所以者何。其彼菩萨本发意时。心自要誓。设使有人禽兽飞鸟。见我身死来啖肌肉。寿终生天度世得道。奉持禁戒所愿者得。如是寂意。当作是观。菩萨所行随时之仪而开化之。密迹金刚力士谓寂意菩萨。乃往过去久远世时。是阎浮利天下广大。周合一域。有八万四千国。其余郡县丘聚无数百千。人民炽盛不可计限。尔时多有财宝衣食。自然周匝充满。众奇宝树交络屋宅。斯诸众生有若干疾不安众患多羸瘦者。金痍疗疮疽痛恶疾。又有无数百千良医。所不能疗。众人得疾积有年岁。无能自安求哀自归。当是众人遭是其厄则无救护。各自称怨。呼天龙神。揵陀罗。真陀罗。摩休勒。人与非人。谁能疗治消我病厄。菩萨尔时为一切首。现为良医疗众人疾。常用慈心。专精走使侍从其后。犹如奴仆给所当得。以报恩慈济人危厄。是故寂意。乃往古世。今斯世尊。当尔世时作天帝释。名曰善自。在于天上遥见众人得若干病困厄难言。以天耳闻众人厄困呻呼悲嗟。见闻如是兴大悲哀。心自念言。今此众人。委厄甚困。无所归依。今吾应宜济众困厄。其无救者为立善救。无所依者为设众依。无所归者为造受归。尔时天下阎浮利中。有一大国城名曰具留。彼时天帝菩萨去国不远。化作一虫兽名曰仁良。自然化生在其国界。时天帝释往在虚空。以偈告语天下阎浮利人

  去此国土不大远　　而有一虫名仁良
  其有服食此虫肉　　则得免济一切厄
  汝等勿恐莫怀惧　　睹其虫身恣取肉
  终不抱嗔无厌秽　　斯是神妙好良药

密迹金刚力士。复语寂意菩萨。尔时彼大国城郡县村落丘聚众疾。诸彼病人。闻此音声咸皆集诣具留大国。到其虫所。取其肌肉各赍来归。以救疗病各得除愈。其虫身肉如故不减。时其国界空野中虫。说是颂曰

  以斯之言要　　令众成佛道
  使吾妙智慧　　究竟无穷尽
  周习学禁戒　　取肌肉施与
  以是至诚辞　　速逮正真道

密迹金刚力士曰。如是寂意。其天下阎浮利诸有病者。皆往取是仁良虫肉。悉服食之。疗体之病靡不得瘳。于时其虫愍慈众生。其身如故亦不增减。各各截取复生如故。其身完具亦不缺漏。郡国县邑州城大邦诸有苦患。敢来食此仁良虫肉。皆得安隐。七日之中。使天下人无复疾病众患之难。唯去身病。未消心疾淫怒痴疹。时天下人男女大小。皆得安隐无复身患。各心念言。今我等身以何方便。报答仁良所育慈养。乃能被荷众病得愈。身得安隐永无众患。诸病愈者普共集会。诣具留国到仁良虫所。皆共叉手。为仁良虫说此偈言

  仁为是救护　　仁身良医药
  咸令我除患　　以何报仁养

尔时仁良虫。自没其身现天帝形。为大众人而说颂曰

  如吾今日身　　不用众居业
  不以饮食供　　金银及珍宝
  不以好象车　　不快马细车
  男女诸大小　　咸供心和同
  皆改往修来　　身奉行十善
  各相向慈心　　展转相愍伤
  相见如骨肉　　犹如父母子
  心不怀害念　　乃报其慈养

密迹金刚力士。语寂意菩萨。时彼众人闻。其训诲。宿福所化皆共奉行是十善业。具足清净不令缺漏。如是寂意。时天下人男女大小。奉行十善终身没已。不堕恶趣三厄之难。寿终之后自然得生忉利天上。又天帝释。为讲说法开示大业。皆发无上正真道意。应时悉立不退转地。寂意当了。是则菩萨所修密行。护身清净不惜身命。以己用施开化救济。无数众生。使至大道。佛告寂意菩萨。身所行众密坚固牢强。不可破坏犹如金刚。其身散以众人所学从志律故。虽欲毁之不能破坏。众生以学从学法住一切不坏。所宣言教。火不能烧刀不能伤。其身坚强要不可毁。犹如寂意。其菩萨身。身顺法律调化众生。其菩萨心。不以寂然。不怀妄想。一切众生身悉本无。其己亦然。亦复本空。以了本无己身本无。一切诸法亦复本无。诸法本无。又解己身以归本无。一切诸法亦复本无。诸法本无。己身自然亦归本无。己以本无。过去当来今现在法亦复本无。去来今法以了本无。又复己身亦复本无。过去本无。当来本无。而不错乱。当来本无。不与过去本无相违也。过去本无。不与现在本无相违也。现在本无。不与过去本无相违也。现在本无。不与过去当来相违也。过去当来本无。不与现在本无相违也。其当来本无。不与现在本无相违也。去来今现本无。不与现在本无而相违也。其去来今本无。行者诸阴诸种诸入众衰四大。未曾相违也。设使生死及与无为自然本无。生死本无。以无所行本无自然。无行本无。不违本无。诸行本无自然。又族姓子所谓本无。其本无者等无有异。不离于欲。无所成立。本无诤讼。是诤讼者与诸诤讼亦无所诤。以无所诤其本无者亦无所诤。是则名曰如来本无。如来无像归斯本无。是则名曰如来形像。普现一切诸所色像。是故形像如来形像一切本空。是则名曰如来之像。是故菩萨现一切像。如来未曾造现形像。无像无诤。尔乃普现一切众像。不以本无有所成立。以本无业自观其身诸身本无。自察法身一切诸身皆无有身。观如来身。晓一切身从因缘生以了法身。本所从行因与法身乃成法身。无阴种诸入。则曰法身行平等业。消除众生所见之缘。若有所闻。所更粗细。犹如寂意。耆域医王合集诸药。以取药草作童子形。端正姝好世之希有。所作安谛所有究竟。殊异无比。往来周旋住立安坐。卧寐经行无所缺漏。所显变业。或有大豪国王太子大臣百官贵姓长者。来到耆域医王所。视药童子与共歌戏。相其颜色病皆得除。便致安隐寂静无欲。寂意且观。其耆域医王疗治世间。其余医师所不能及也。如是寂意。若菩萨奉行法身。假使众生淫怒痴盛。男女大小欲相慕乐。即共相娱。贪欲尘劳悉得休息。以得休息于内息想。谓离热欲。因斯受化。皆是菩萨所愿具足。如是寂意。若菩萨行善修法身。斯诸菩萨则是法身。示以饮食充实斯体。不服抟食以安其身。以断众膳。愍伤众生而现复食。不以饭食入于体里。不着身中。又其法身力不增损。菩萨法身不知所生。亦无有死。无终无始。而随习俗现有生死。虽现终没。解一切法悉无所行。示现所生。畅一切法。无为无会。一切诸法。虽有所生悉无所生。皆晓诸行自现其身。诸根阙减。而所游行不毁法身。则以法身法食法力。以法自归了如来身。寂意。欲知如来身者。即虚空身而无等伦。处于三界为最至尊。施于众生身无所归。不可譬喻而无比类。其身清净舍垢无尘。其身本净而无沾污。自然鲜明永无尘冥。本性仁和悉无所生。其身寂然。不为心意识所见拘系。其身自然。犹如幻化野马水月。其身已度空无相愿。其身普周十方虚空。心悉平等了三界本。一切众生无有吾我。其身无底不可限量。无作无想。斯身无著无所思念。所住真谛致不可还。其身无像自然现像。无痛现痛。自然无想而现有想。无生死识而自然现诸生死识。无地水火风因其示现地水火风四大之身。解诸世间一切现法皆虚不实。眼无所见。耳无所闻。鼻无嗅香舌不在味。身不倚行永消众识。意无所受心无转移。无心意识。解了真谛未曾进退。尔时寂意。如来法身若有菩萨。以能逮斯如来等身。靡不周普奉菩萨行。在此三千大千世界。诸四方域郡国县邑州城大邦。悉化其身皆遍现之。一切众魔不能见知菩萨所为。现若不现悉能明了微妙之业。虽无所现。普现一切未曾念行。见闻知识有所修行。开化众生。不以身行失四意止。为众生类。因现其身无常苦空非身之义。解达诸身本法悉寂。为众生现身归坏败。其以报应求于身者。以是退转。以是求报。随四颠倒。其有解睹无作无见。晓知其身。犹如草木墙壁瓦石。为诸众生现清净身。如是寂意。曾为菩萨。从锭光佛授决以来。致于密身清净之体。正使菩萨口有所宣。悉无言说。又有寂意。如来所说随时之宜。因其想念。说菩萨密身之寂静。从是转进而得拔济。所至无际。所谓菩萨身之秘密由得自在。菩萨以宣己身秘密。粗举其要。假欲具说江河沙劫。不能究畅。密迹金刚力士谓寂意菩萨。何谓言密。其言清净随众生类。堕畜生中多少限数。菩萨亦现若干音响言语其察音响现若干辞。顺其众生章句言语。而演言教。随时颁宣而与谈语。说其苦乐善恶之处。其菩萨音一切普入靡所不达。或有歌戏幻化嗔喜。演其音句。随其众生言辞音响。而入训诲。因其一切身意所信心所好乐。菩萨悉解而分别之。各使闻了。寂意菩萨问密迹力士。菩萨所化音响如何。密迹答曰。从其众生一切音响。又菩萨音所顺无限。犹如众生所生之处心念各异。五趣音辞各各不同。不可称计。菩萨如是各从音辞。亦无言辞。是则名曰随众生音无不达之晓无所有。当作是观。一切众响所宣言辞。终竟一切不可思议。言无穷极。是为菩萨所化随时。不可喻尽。自恣颁宣不可计响。或演释梵四天王音。或复恣宣诸天龙神。阿须轮。迦楼罗。真陀罗。揵沓和。摩休勒。人与非人。随众生音上中下声粗细好丑。而演音响喜悦一切。于是颂曰

  以如言辞　　多所解决　　敷演无数
  所说言教　　疗以慈心　　达入愍哀
  宣布广说　　喜悦护意　　天帝合集
  柔软和调　　若有闻斯　　蔽众音响
  因从伎乐　　所演悲声　　颁宣斯出
  经典训诲　　诸真陀罗　　思好雅颂
  其音喻此　　普悉具足　　闻令欲止
  淫心不兴　　一切山神　　皆好音乐
  计于欲界　　众诸妙音　　诸伎乐出
  诸天声响　　皆悉起此　　诚可爱悦
  其法音声　　随时方便　　所宣歌颂
  消嗔恚欲　　除去痴慢　　自大之行
  分别畅了　　行所归趣　　以闻道术
  宣传之故　　其在色界　　一切诸天
  皆能悦可　　斯诸天意　　因得听闻
  殊异言教　　在世发意　　当成佛道
  龙揵陀罗　　摩休勒等　　一切妓乐
  若干种品　　德海若宣　　微妙音教
  众生皆悦　　心豫踊跃　　入无央数
  若干音响　　阎浮天下　　所居人民
  其音普遍　　入斯众生　　若得闻者
  悉得度脱　　虚空天神　　及此地祇
  其声通达　　咸至彼间　　皆得闻教
  莫不悦豫　　佥然决疑　　悉心欢欣
  哀鸾鹄雁　　赤嘴鸦音　　山鸟孔雀
  鹦鹉鹍鸡　　雁殊异鸟　　耆域鸳鸯
  若闻此声　　皆可意悦　　师子虎狼
  熊罴猿猴　　麑鹿骡驴　　野狐诸兔
  象马狗犬　　牛羊猪类　　闻其音声
  可意喜悦　　四足二足　　诸有形貌
  其多诸足　　诸无足者　　皆乐闻是
  解知音声　　宣布受诲　　舍众邪业
  于斯三千　　诸国有音　　最上中间
  及豪下贱　　地狱饿鬼　　至畜生类
  诸天人民　　众诸音响　　行无妄见
  唯念至真　　亦无想求　　未曾诤讼
  奉行所业　　志存道心　　颁宣令现
  当应时节　　己以专一　　忍众生诤
  以音教告　　百亿国土　　从是通达
  江河沙数　　不倚财业　　心无所行
  诸佛国土　　所有众魔　　此等得闻
  斯大和声　　悲哀将护　　所救如是
  出入行步　　悉为兴礼　　正使众生
  有百千亿　　其心各抱　　若干志念
  闻是言辞　　不以蔽碍　　叉其十指
  稽首作礼　　卧寐聋哑　　口不能言
  跛蹇无足　　诸大疾病　　彼若闻此
  微妙善语　　宣畅柔和　　至好音教
  心常怀念　　尘劳危厄　　口所宣说
  亿载尘劳　　其得闻是　　清净法音
  开化乌鸟　　致于清凉　　口所宣布
  众生悉闻　　诸佛经法　　及诸圣众
  布施禁戒　　行忍辱事　　精进一心
  智慧之法　　说意所存　　功勋众行
  亿百千劫　　不能畅尽　　本际无底
  其意无量　　演于佛音　　所往无极

大宝积经卷第八大宝积经卷第九

        西晋三藏竺法护奉　诏译

    密迹金刚力士会第三之二

密迹金刚力士。语寂意菩萨。菩萨所说。口未曾宣污染恶言不仁之辞嗔恚痴言。亦无谀谄。无刚结言崎岖之语调戏俳说无益之文语。不妄笑谗言两舌。不顾男女。不坚硬。无有粗辞卒暴之性。不有怀害。无取舍心。不失仪节志。亦无结心。无所著。无斗讼言。无所倚。无尘劳。无所举。无轻放逸。无自恣。无横理无宜之行。无非时辞。无贪欲。无非恶。无所爱乐。无有处所。亦无非净。无违时。无失节。诸根无毁。音声无瑕。心不怀害亦无偏党。无恣訑。无覆蔽。不诤言语。不有怨嫌。无有结恨。不妄受邪非。无自归。不计吾我。不娆他人。不恼彼己。不宣伤害。无殃罪法。不失所言。无不受行。无不顺业。无不可忍。所宣言和。无种姓事。无轻调之教。去非法之行。不毁法行。不越时节。不违宜度。不宣须臾。不自叹类。不坏他伴。于己得誉不以喜悦。见叹他人亦不愁愦。谨慎守节不轻慢人。不说非宜。不毁有宜。不诽密言。常随时护。不谤明智。不呵贤圣。言不虚妄。不非证明。不入人罪。不求他短。所言转教不伤筋骨。不称他恶。志愿无上。不相颜色。不求异党。不念业便。不行逆事。心常柔顺。密迹力士语寂意。是为菩萨言行相应。以空慌忽神勇为力。功德报应所作果实。宣至诚辞从所作报。假使有人行诣大。树下。若复住立作是观树。以观转问他人言。男子能知此树所生。叶数为有几枚。有大智人。不观树木亦未计数。知彼树叶便口出辞。其数如是。与侣俱坐。亦不计之。既未能度。至于道德即知其数。来在一切而演若干。其人语词等无有异。若有来问大江河沙。能有几沙。一一计之能得几枚几百千亿兆载垓数。水有几升斗斛限数。不可以喻量度。不观其限。亦不数之。悉知江河沙之多少几亿兆载。皆知水升斗斛限。各各为演若干品语。唯大圣知天不能证。诸龙鬼神。阿须轮。迦楼罗。真陀罗。揵沓和。摩休勒。人与非人。声闻缘觉。悉不能证明。独佛世尊乃能知之。以是观之。如来至真等正觉慧不可计量。宣万亿音。众生皆闻各得开解。密迹金刚力士语寂意菩萨。乃往过去久远世时。有一神仙名曰楼夷。尔时之世。有一梵志名曰寂然。时国有一大树。名曰仁贤。其树枝叶华实茂盛。其楼夷神仙常处其下。具足十二岁。数其树叶而复观之。彼于后日。寂然梵志从城中出。往至仁贤树所昼夜游观。饭食已后数树茎叶。又以圣明一心数之。又曰何谓告启神仙。我当数之知有几枚。时寂然梵志。不观其树不数其叶。寻时说颂曰

  有八千垓　　八千亿叶　　节有九千
  六百二十　　觚有五枚　　二百五十
  痱癗六千　　六百六十　　圣师欲知
  叶有若干　　数其树茎　　分布所在
  并所知解　　启曰如是　　今无放逸
  有疑数之

楼夷神仙。嗟而说言。善哉至言谛辞无欺。吾十二年坐计限之。其树叶数亦不数之。悉知本末叶有若干。唯愿梵志为我说之。其音声行何所以类。寂然即曰。神仙听之。天不助我亦非世人。以至诚故传大正行。皆以真净无所诤讼。楼夷神仙舍利弗是。寂然梵志释师子是。当执持此至真言教。住于至诚以应法宜。密迹金刚力士谓寂意。是则菩萨至密之业清净之元。其无极慧。深入无量巍巍无限。随时示现。至真无形不可说名。密迹金刚力士。复谓寂意菩萨。何谓心密。心行清净不失神通。造立慧业。神通自娱在所示现。正住神通。建立大哀无极之业。以神通化无央数变。一切普显以诚谛通。智慧为室。现目睹见一切诸法。是则菩萨正真之法。慧通无极普御一切。其神通慧皆显众像。解畅诸色本无有色。其以神通普入诸音等本音响。皆能观察一切众生心念诸行。因见本净。常见一切随时开化。常念识之未曾忽忘。断去来心。普现神足无所挂碍。独步三界不以为拘。悉无所有不造立行。其神通明尽一切漏。晓了随时不失其节现生死难。示度世业所察玄远。其神通明。皆超声闻一切缘觉。深入微妙。坐佛树下降伏魔官。解畅一切诸佛道法。而转顺时道法圣轮。开化一切十方众生。使入法律至阿维颜转一切法寂意欲知。是为菩萨心密之业心行清净。若心真净。永无所归亦无不喜。性安调和随行极良。则以普慧三昧定意。而行正受不永灭度。不厌欲界。设生其中无所系着不为所缚。所生现决未曾有结。所以者何。以度一切虚空妄想。解众尘结颠倒所受。心无所著。由是之故得脱生老病死。虽有所生悉无所生。以大乘本。成就一切诸佛道法。斯诸佛法救护十方。求之无处而不可得。乃了一切诸佛之法。一切诸法悉归佛法。是诸佛之法悉一切法。是一切法及与佛法。不是是法亦非非法。所以者何。求一切法本末处所。而不可得。若求诸法悉无处所则无有数。超诸住数一切诸法。知一切法。则不依倚一切诸法。以不依倚一切诸法。其求利义便致大衰。其无思求彼则无利亦无衰折。转进学前其见利义。心无忧戚亦不喜欢。其心无忧志无挂碍。则无所住。其无所住乃无杂碎。其无杂碎则无所向。其无所向如是乃向。如是乃向者尔乃无向。其无所向乃无吾我。其无吾我则无所受。其无所受则无诤讼。其无诤讼则无斗乱。其无斗乱是沙门法。其心平等犹如虚空。住其平等如虚不随欲界。不处色界不着无色。若以一切悉无所著无誉无毁。其无誉无毁谓一切法。斯等皆解如是深义。以能知是六事之业。宣畅分别亦复如是。以何等故解畅分别。以是之故一切诸法不可得也。其能解畅分别诸法。本无所处三界悉虚。乃能解畅悉以分别。是为心密。密迹金刚力士复谓寂意菩萨。其心行密。斯行慈愍不计吾我故。其行悲哀无有众生故。以行欢喜则无命故。以能济护乃达无寿故。行四布施心无悭故。奉行禁戒调和其心故。斯忍辱行尽心之业故。若修精进思惟寂静故。其寂一心弃心所在故。其知圣心无所行故。其四意止无意无念故。若四意断其心以了以不起不灭故。其神足飞心广无际故。以行笃信心无挂碍故。若修精进心行寂静故。其意已念心行得自在故。其定意者斯平等心无有若干故。其智慧根心无想故。其势力者顺流心本故。若以觉意心分别慧故。奉行道业心无所想故。其寂然者惔怕静思故。其观法心见无著故。修行贤圣究竟解心故。心念于佛其明慧者心不妄想故。其心思道志不可量故。其思念法心平等故。思念圣众心无所住训诲众生故。其心湛净护于正法故。其法诸界心无所坏故。佛土清净心等如空故。众相具足心无别形相故。逮致忍辱心无颠倒故。阿惟越致心不复回还故。庄严道场在于三界心不堕故。降伏魔业心摄众生故。道所训诲一切法心平等觉故。以转法轮诸法无转用心不还故。现大灭度解生死原。以心平等自然之故。密迹金刚力士谓寂意曰。菩萨若得不起法忍。心则甚密心亦清净。心已清净便解一切众生心净。普无不入其众生心。入于道心。一切众生心趣道心而被照明。犹如虚空普悉平等。遍入一切有形无形道心。如是一切皆入众生心行。密迹金刚力士。说是菩萨身口心密不可思议时。七万二千诸天人众皆发无上正真道意。三万二千菩萨逮得无所从生法忍。万四千人远尘离垢诸法眼净。八千比丘意解无漏。是三千大千世界六反震动。其大光明普照十方。上虚空中天雨众华。箜篌乐器不鼓自鸣。其妓乐音中演出如是。其有闻是密迹金刚力士所说法谊。若有乐信。是等之人得立授决。爱喜经典受持读诵。广为人说不失道心。积功德本终不虚妄。曾以供养无央数佛殖众德本。益于众生靡不蒙济。于是世尊告寂意。汝宁闻彼伎乐所畅言响乎。答曰已闻世尊。唯然大圣。谁之威神。佛语寂意。有菩萨名雷音。从雷音王如来佛国发。其国土名两氏。来诣忍界。欲见吾身。稽首作礼启问法要。欲听说是如来秘要法教。在于虚空不现其身。供养如来及斯经典。故雨天华作诸伎乐。从其伎乐出是辈声。佛说未久。雷音菩萨从虚空下。稽首佛足绕佛七匝。住于佛前白天师言。唯然世尊。雷音王如来敬问无量。兴起轻便游步康宁。尔时世尊。告问雷音菩萨。善来正士。快哉顾义故致奉现。宁欲听受如来秘要经典之慧。今密迹金刚力士。承佛威神而颁宣之。于是众会或有菩萨。心自念言。斯密迹金刚力士。在于何世积众德本。在何佛所而发道心。本何誓愿所逮辩才广大无极巍巍如是。时佛悉知是诸菩萨心中所念。告寂意菩萨。乃往过去久远世时。无央数劫不可思议。尔时有佛。名无量勋宝锦净王。出现于世。如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰庄严。劫名善见。其佛国土有异威德。人民炽盛皆得安隐。五谷丰收土地大盛。咸共快乐。天人繁炽地悉平等犹如砥掌。无沙尘秽荆棘瓦石。唯琉璃水精明月珠玉。珊瑚虎珀砗磲马瑙遍布其地。其地柔软犹如天衣。有甘美香光色甚好。生其好草如天綩綖。以足蹈上足下四寸。举足如故。其土快乐无有大寒。亦不大热。人民仁慈性行和调。身口心定。香芬熏地绀琉璃色。彼国人民普得自在。皆受训诲淫怒痴薄。安隐寂静悉有威力。闻说法言皆识议理。其佛世尊时。诸声闻众有十二垓。诸菩萨三千二亿。其佛寿命三十六亿岁。无中夭者。斯庄严国其中四城。名曰快见。甚大广长。风雨时节五谷丰饶。人民安宁强不凌弱各得其所。一一方城广长各八十万里相去四百里。有一大国。一一大国各有千郡县及诸村落丘聚。其土人民身长四里。是时大城快见四方大城。复有大城名曰清净。王所治处土地广长。其城东西长二千五百六十里。南北广千二百八十里。郡国县邑各有一万。具足快乐。诸游观园各有一万。极甚清净七宝合成。时有转轮圣王。名曰勇郡王。有七宝一曰金轮。二曰白象有六牙。三曰绀色马朱髦尾。四曰明月神珠。五曰玉女妻。六曰主藏圣臣。七曰主兵大将军。主四天下。供过去佛殖众德本。威神难量。发无上正真之道心。逮不退转。在城中央立一屋宅。广长高大。长广各六百四十里。以七宝立七重墙壁栏楯。七重交道。七重宝幔。七重七重深堑。其宅里内有四大果园生若干华。一名妙华。二名功勋阿。三名山河。四名春安。有池水满。广长各二十里。皆以众宝而作栏楯。紫金为池紫金琉璃以为底沙。满八味水合生宝华。凫雁鸳鸯异类之鸟游戏其中。一浴池名施财。二名上窟。三名上香。四名妙御。中宫婇女七万六千。如天玉女。各有好相端正殊好非世之有。其王正后玉女宝及诸婇女。皆发无上正真道意。王有千子。具足勇猛与众殊异端正超绝。二十八相严饰其身。志性仁和。亦俱同心发大道意。尔时其佛游在清净大国。其王勇郡。供养无量勋宝罽净王如来。具足亿岁。诸菩萨众声闻等。衣被饮食床卧医药一切所安。园观浴池屋宅讲堂。房室精舍高台楼阁。一一比丘。与二侍使给所当得。其王诸子。志性安和无放逸行。常以至心供奉如来听受经典。不乐爱欲戏笑邪业。以无放逸听受经典不以生心。不久即逮兴五神通。以得神通踊在虚空。犹如雁王飞行自在无所挂碍。从其一观复至一观。从县至县从国游国。从一天下至一天下普行游观。以是要偈为大众说

  诸佛兴出世　　玄远甚难值
  人生在世间　　亦甚难得遇
  诸人咸同志　　俱信乐听经
  于亿百千劫　　甚复不可遭
  今人中之雄　　以出于世间
  欲令寂然定　　故说经法义
  从安住世尊　　咨受教训诲
  求于大圣明　　奉启佛至言
  以听受经法　　弃捐于恶趣
  以逮闻正法　　得坐极安处
  以逮闻正法　　消除众尘劳
  因其听受慧　　得致正真法
  彼时布宣训　　而演是甘香
  缘其斯瑞应　　地六反震动
  普布告天人　　诸天举叹曰
  即时雨天华　　其华若干种
  众生皆来集　　不可称计数
  最胜之开化　　皆入于道法
  前稽首足下　　礼于天人尊
  皆俱以叉手　　恭恪而住立
  其最胜圣师　　是逮得是心
  随时顺义理　　而为说经法
  斯等之伴侣　　得闻安住法
  三十六亿俱　　悉发大道心
  其三百亿众　　具足不减一
  皆以得清净　　极上之法眼
  其心以厌患　　于俗之家业
  悉共在彼世　　弃家行学道
  诸人无数众　　亿载兆垓人
  咸启受经戒　　皆作清信士
  以逮闻经法　　稽首佛足下
  各各前辞别　　悉自还归家

佛告寂意。尔时王太子并共父王。以栴檀造立楼阁。广长清净好校饰之。作诸窗牖以众宝成。以牛头栴檀香一升烧气遍天下皆有美香。以是栴檀造立楼阁。广长高大高四百里庄严校饰。威神显现巍巍无量。正四方好四角四柱。所作平正安不倾斜。其王勇郡。因欲往到无量勋宝罽净王如来所。奉视稽首咨问听受经典。劝王眷属。人命难得佛兴难值。亿载时有经道难闻。宜往奉视咨受经典。王及太子夫人婇女。大臣百官人民大小。皆入校露高台楼阁。坐于百千严饰宝床。以众华香杂香衣服宝盖幢幡鼓诸妓乐。以恭恪心奉事尊敬。宝珠挍露高台楼阁。以贡上之。一切同心仁和之意。上在虚空犹凤凰王。与诸众俱无所挂碍。飞行浮疾往诣佛所。其宝挍露高台楼阁以到大会。前诣佛所。斯宝挍露高台楼阁。绕佛七匝还住一面。王及大众各下以出。前礼佛足及礼圣众。绕佛七匝因在前住。白世尊曰。久服圣音国有多事。不寻奉现惭愧无颜。饥虚之情今日乃果。时佛大圣。见王真心宫人眷属故来听法。则以随观。从其心本。应病与药颁宣经法。佛告大王。志建大乘有四事法。所游殊特不违大道。何谓为四。若学大乘笃信重人。所游殊特不违道意。何谓为信。若以喜乐奉诸贤圣。所不当造终不行之。大王恭敬则学大乘。所游殊特不违大道。若谦恪听于贤圣经。至心入耳闻则受持以不自大。学于大乘所游殊特不违大道。以不自大观见众圣。稽首作礼一心归命。若尊精进学于大乘。所游殊特不违大道。以用精进轻身口心。举动便宜行以越度于一切行。是为四事。佛告王曰。复有四事。见无放逸。所见拥护。何谓为四。将护诸根见爱欲难。晓一切受想。知无常。因法得生命根第一。是为四事。菩萨有四事。名曰法王。何谓为四。一曰不舍道心。二曰亦复劝化他人发意。三曰以诸德本劝助道心。所可闻者意广无极。四曰一切释梵及四天王其诸声闻并缘觉地。至于无极无坏弘广无穷之业。是为四事。是故大王。当行无放逸常修笃信。好喜无量道法之义常受正法。以法之乐而以自娱。若以精进求于道法。大王所行不贪境界。所以者何。大王当解。贪欲无厌犹饮碱水。其见贤圣智慧之明乃知限节。人命甚短安少苦多。生无不终当就后世。常畏将来心不可保。今日大王所供养佛。因是德本。以有四事具足劝助。何谓为四。世世财富不可限量。功德福报不可尽极。圣明之慧而无涯底。辩才之智悉无穷尽。是为四。复有四事而当劝助。何谓为四。身行清净功德之业。言行清净戒禁具足。心行清净博闻无厌。其法清净圣明为党。是为四。复有四事劝助德本。何谓为四。善权方便修清净行。训诲众生智度无极。以清净业降伏魔官誓愿清净言行相应。一切诸佛法悉清净。积功累德逮见诸佛是为四。尔时世尊。为勇郡转轮圣王。说经中慧分别深义。其王心解即时欣然。便解身颈无数百千奇珍珠璎。以贡上佛。举国事佛给所当得。奉持五戒。尽其形寿净修梵行。其王中宫夫人婇女。从佛闻法心中喜悦。随时之心抱柔和意。无阴盖心。脱身衣被奇异宝璎。以覆佛上。启白报王。欲得舍家出为沙门。净修梵行。尽其形寿奉持禁戒。王即听之。如是寂意。其勇郡王奉无极法。逮法财富。稽首佛足绕佛七匝。与中宫婇女及其官属。入大高台楼阁挍露。便涌出上于虚空中。须臾之间即复还服清净大国。于是圣王以十五日月盛满时若干种华。出入行到游观之园。中宫眷属观见好地。彼时圣王在游观园作众妓乐。其二正夫人。一名不行步。二名无虚损。从宫中出洗身沐浴适还去已。以香熏衣坐莲华台妙胜床席。有二孩童自然来上夫人膝上结加趺坐。端正殊好非世所见。有二十八大人之相庄严其身。适自然现。即时虚空中百千诸天举声叹曰。是二孩童则法神圣。一名法意二名法念。是二孩童适自然现。时其名法念孩童。坐不移夫人膝上。其法意孩童子。化生无损夫人膝上。适加趺坐。异口同音而说颂曰

  若有守己身　　能发菩提心
  斯等之学士　　为致善福庆
  以为曾睹见　　护吼兴现世
  常以欢悦心　　一志供事佛
  为大神通业　　快得受救护
  得消生死轮　　疾灭无所生
  若发菩提心　　未曾忽忘之
  以救摄众生　　坏破生死难
  其上方境界　　不可计佛土
  彼土而有佛　　号名曰时节
  从彼佛土来　　以用法故举
  亦欲见功勋　　国土之所有
  于时二孩童　　各从所坐起
  因便从母膝　　移下在于地
  俱发进其路　　行诣天人尊
  前稽首佛足　　却退叉手住
  四方宣佛德　　今故来听经
  佛法甚难致　　闻受亦难遇
  以得闻是法　　当启人尊胜
  至诚于佛道　　无上正真业
  诸佛之道法　　为甚难得值
  爱乐经义者　　亦复倍难遭
  今日以闲静　　用亲友好法
  随顺之威则　　奉敬信法教
  慕嘉于精进　　所行无放逸
  以得为沙门　　如是处闲居
  愍念住如是　　质朴等无量
  常抱惭愧心　　知博闻难遇
  其慈普具足　　愍念于众生
  以能达深法　　乃可逮法忍
  计诸威力势　　其心无怯羸
  摄救诸众生　　开化一切难
  若在于独处　　造业无思议
  以不贪其身　　寿命根亦然
  于学禁无厌　　我思于道法
  以是能晓了　　逮功勋若斯
  若能学如是　　第一甚难得
  其法王之业　　咨嗟此最上
  斯诸法之要　　报应普备足
  当发往俱到　　圣安住佛所
  其斯诸明智　　受菩萨道行
  奉行清白法　　以用宣布教
  随时而闲静　　逮到五神通
  因其识皆念　　所行法惔怕
  其王二太子　　与夫人婇女
  斯二明智等　　行菩萨之法
  以获神通慧　　经行虚空中
  往到世尊所　　功勋智慧海
  前稽首佛足　　自归人中尊
  一切悉和同　　俱往叉手礼
  法意前启佛　　并余一切众
  唯愿大圣尊　　为我说道法
  最胜知是等　　心中之所念
  则为分别说　　深妙之法义
  是一切诸法　　皆从因缘起
  本无主师教　　从造化现生
  其解内以空　　外则无因缘
  是一切诸法　　慌忽悉空虚
  以能察本末　　无作见清净
  计之犹虚空　　常不可护持
  佛以无数便　　为此等颁宣
  分别敷演此　　深奥之正真
  七十六垓人　　及二亿载众
  一时皆得成　　柔顺之法忍

是时转轮圣王勇郡。中宫太子眷属万民。绕佛作礼。供养世尊及与圣众。昼夜七日毕竟还归其宫。于是勇郡转轮圣王。独处宴坐在于清净高阁挍露。自心念言。是吾诸子皆发无上正真道意。今当试之。何所太子先当逮致无上正真之道为最正觉者。便敕工师作七宝瓶极好团圆。作七宝[((十/工)刀)/瓦]显现微妙。又高七刃为四十九尺。使诸千太子各各疏名。作七宝筹。着瓶中举瓶着[((十/工)刀)/瓦]上。咸共夙夜七日供养。以天华香捣香杂香华盖幢幡。作众伎乐。供养宝瓶所疏名号。十千天子来佐劝助供养名号。时转轮王过七日后。取是七宝瓶。在中宫夫人婇女诸太子众前。举着紫金案上使人举瓶。令诸太子各各探筹。有太子名曰净意。得第一筹。适得此筹于时三千大千国土六反震动。中宫夫人婇女一切妓乐不鼓自鸣。于寂意所念云何。彼时净意太子岂异人乎。莫造异观。所以者何。则拘留孙如来是也。从次太子名离名闻兵。则拘那含牟尼佛是也。次有太子名寂根。则迦叶如来是也。次有太子名一切苦利。则吾身是也。次有太子名雨室则弥勒如来是也。次有太子名明月珠服。将来作佛名曰师子。次有太子于将来世成佛。名曰妙英。次有太子名贤氏。将来成佛名曰供养。次有太子名曰光首。后成佛时号曰妙华。次有太子名曰莲华氏。后成佛时号曰奉养。次有太子名离垢光。后成佛时号曰善目。次有太子名兵氏。后成佛时号曰快臂。次有太子名曰意妙。后成佛时号曰焰光。次有太子名曰净复净。后成佛时号曰焰味。次有太子名曰富党。后成佛时号无退没。次有太子名曰离垢净。后成佛时号曰执德。次有太子名曰坚强。后成佛时号曰宝事。次有太子名曰宝称。后成佛时号曰无欺世。于是寂意。取要言之。次广具足。有太子名曰甘铠。庄严第九百九十九。千不满一。后成佛时号曰无量德宝称。在是贤劫立兴来世。佛言如是寂意。有太子名意无量。得最后筹。是王太子当在最后成行觉道。时其诸太子。轻易调戏数数笑之。众等各言。我当成佛时降魔官属转于法轮。开化度脱无量众生令至灭度。假众生尽后何所设。当何救济。其后太子名意无量。目自睹见。得最后筹穷底成佛。应时愁恼。吾独何衅穷底得筹。五体投地犹太山崩。口自宣言。诸佛道法不可称量。众生之界亦无有限。所愿殊特不可思议。寻即立一切愿。令我兄弟千人成佛。后所教弟子所度多少。其寿长短计合是等一切寿命。与我成佛道时所寿久长若干适同。仁等所有一切圣众。我成佛时圣众独尔。颁宣经法所化度脱一切众生。亦复如是。与仁千人功勋巍巍适等无异不可限量。假使吾身所言至诚合成不虚。三千大千世界为吾现瑞。六反震动天雨众华。箜篌乐器不鼓自鸣。时意无量国王太子适立斯誓。寻时三千大千世界。六反震动天雨众华。箜篌乐器不鼓自鸣。上虚空中诸天百千。而叹颂曰。当如所愿最后成佛。名曰楼由如来至真等正觉。佛言寂意何故名之楼由。尔时愁感自投于地。用得下筹自积誓愿。由斯世尊号之楼由(楼由者晋言涕泣)于彼世时。其王太子誓愿已竟。说此偈言

  是诸佛道法　　犹等如虚空
  意觉若如幻　　众生不可尽
  所愿誓吉祥　　戒禁成清净
  诸仁且听是　　我所欲誓愿
  合集诸仁君　　所寿之有限
  诸重尊圣王　　一切皆尽见
  计是诸佛名　　与我一寿等
  成佛名楼由　　比丘众如是
  其王太子感　　故宣是言辞
  诸天立虚空　　举声叹颂曰
  如今清净人　　所愿必当成
  因以众生故　　会成所要誓

佛告寂意菩萨。欲知尔时意无量太子乎。答曰不及。佛言。在是贤劫最后成佛号曰楼由。于贤劫中。所与诸佛千不满一。所度众生诸菩萨学比丘圣众。不及楼由。最后成佛而寿半劫。所度众生菩萨声闻一切圣众。竟于贤劫。与九百九十九佛。所度适等无有差特。佛告寂意。且观菩萨善权方便。成就禁戒而有殊特。具足誓愿独步独坐。周旋三界曾无休废。所以者何。楼由如来独以一身开化众生。与千佛兴所度无异。所益无限巍巍若斯。如是寂意。王千太子。其后二子各心念言。汝等正士所志云何。法意太子曰。吾自要誓诸人成得佛时。当作金刚力士。常亲近佛在外威仪。省诸如来一切秘要。常委托依。普闻一切诸佛秘要密迹之事。信乐受喜不怀疑结。法念太子曰。诸正士听。吾心自誓言。诸仁成佛道。身当劝助使转法轮。适见相劝辄转法轮。寂意。欲知尔时勇郡转轮圣王乎。答曰不及也。佛言。则往过去定光如来是也。其时诸子。此贤劫中千佛兴者是也。从拘留孙为始作佛。至楼由竟千佛也。其法意太子。则今金刚力士名密迹是也。其法念太子者。今识其梵天是也。彼时圣王中宫夫人婇女。今诸来会者是也。彼世之时。王诸太子所劝。出家作沙门者。及所教化。皆此贤劫稍渐受决当次第成最正觉。寂意。且观十二缘起。不乱德本获报应果。诸所发意不失其功。斯等正士十力普备悉获所愿。是故寂意。若有菩萨疾欲逮成无上正真道为最正觉。当学斯等诸正士业。勤修奉行悉存佛道。彼何谓佛道。不以害心于众生。兴乎慈心奉度无极习行四恩常修梵行。遵道品法具进神通。行权方便成就德本。是为佛道。佛复告寂意。其道心净斯性通达。其道和雅志性安隐。其道质朴而无谀谄。其道广普无所挂碍。其道平等心无偏党。其道无畏不犯众恶其道财富施度无极。其道丰饶戒度无极。其道不咨忍度无极。其道离处进度无极。其道不乱寂度无极。其道善择智度无极。道归己慧奉于大慈。道不曲意至于大哀。道受喜悦行以大喜。道归妙御至于大护。其道以除众苦之恼。消去贪害嗔恚之想。其道趣安心不怀色。道化难调刈色声香味细滑之法。道降魔官属令化去心自大及众怨贼。道消除阴种诸入悉无所著。道舍魔事。在众尘劳而得自在。道归上心离于声闻缘觉之念。道习诸去来所行致平等觉。道御大宝顺一切智。道常分别无碍慧明。道宣善行摄善亲友。道废坑堑消众结着。道弃尘劳越嗔诤地。道归安隐捐众非恶。道归吉祥趣泥洹业。是为菩萨行佛道业三十二事。菩萨住此。疾成无上正真之道。逮最正觉

大宝积经卷第九大宝积经卷第十

        西晋三藏竺法护奉　诏译

    密迹金刚力士会第三之三

尔时寂意。复问密迹金刚力士。如来有几事秘要。一切声闻诸缘觉地所不能及也。何况凡庶闇蔽之类。善哉密迹愿意乐任。颁宣如来秘要普入。一切众会咸欲闻之。密迹力士谓寂意曰。谛听谛听善思念之。今当敷演如来秘要。有三事。何谓为三。一曰身密。二曰口密。三曰意密何谓身密。如来于斯无所思想。亦不惟念。普现一切威仪礼节。或有诸天人民。自喜经行。见睹如来经行之时。诸天人民心自念言。世尊为上。斯等逮见如来身密。佛之所念亦不思望。一切众生睹见如来至真妙德威仪。若诸天人喜坐。见如来坐。若诸天人喜卧。见如来卧。若喜听经见如来说经。若喜寂静见如来默然。若喜禅思见如来三昧。若天人民目视不眴者。见如来目未曾眴。若意自在有喜光者。便见如来光无所阂。喜紫金色者。亦见紫磨金色。若诸天人民喜银色水精色琉璃色马瑙色砗磲。黄色真珠正白正赤黄白红紫色。或取明月珠色暴乱色。炎光日月四天王释梵阿须伦。或中分色。须弥华色。或思妙色。或药形色。或碧石色。或无忧华旃匐色。或思夷华色。或青莲红黄白华色。或了忉利天色。或毗沙门王颜。或四天王形。首藏青帝黄帝赤帝白帝。或虚空净。或天人民心志无量品色各异。亦见如来若干品种功勋德色。如是寂意。正使江河沙等诸佛世界满中众生有含命类。展转相爱展转相生。皆决罪毕得为人形。从思想生。其中一人正使所生。亦犹如彼一切众生。如来亦见若干品色。威仪礼节心所好乐。不可限量。悉欲察知本末言行。亦复如是。如来至真。有以是缘各于众生。现如来像威仪礼节言行使然。犹如一人心得解脱。不与二人俱共同也。欲宣至实心得解脱乃至乎道。如来至真乃能可悦一切众生。以悦众生显示色像。威仪礼节言行亦然。犹如寂意。清净明镜。随其色貌以往照之。则现其像不失本类。等示无异未曾变改。明镜照形亦无想念。如来如是。虽以法济一切众生。无有想念无利养心。可悦一切众生心行。随上中下深浅之法。开化度脱三界迷惑。是为如来身行秘要。密迹金刚力士复谓寂意菩萨。如来秘要亦不分别阴种诸入。不归罪福。不生尘劳。不成父母。无四大胞胎。亦无骨肉。所闻功勋。无涂华香。悉无所有。不系在色。无出入息。寿命灭尽。欲知佛身则是法身身无有色。无众妄想。所现色相为贪慕好求豪尊位众生之故。而示形相令目睹矣。法相静寂为敬慧故。一切众生使趣天眼。密迹复谓寂意。若有众生俱在一会。各见佛身以缘意睹。其远住观住本不见。其住本也。见住远不见者。无意缘也。见者以乱意缘不见也。若以意缘不得见者。若以己身而察见之。用见他人故。不见之也。又见他人故。复能见者。用见己心故。不见之也其在梦中有所见者。从梦觉已则无所见也。定意所见起无所见。起往所见定无所见。其空静所见不静不见。其在空静则无不见。其见无业。离于无业无所见之。其离无业乃有所见一无所见。密迹复谓寂意。其如来身从无数事。各随显现其色行天身行寂然威仪礼节。而心自定然后复乱。斯如来身无有边际。亦无限碍。亦无妄想。不可想节。如来身者不可限取。无若干像。如来身者亦复如是。无所不遍。犹如虚空不有妄想。如来若斯永无思想。犹如虚空皆以遍入一切形色。如来若斯。悉以周遍照诸众生。犹如虚空普入诸色间关其里。如来之身亦复如是。普照众生靡所不遍。犹如虚空皆长一切百谷草木。如来若斯。至真之体长育德本。犹如虚空不计有常及与无常。亦无昼夜。如来若斯。身不有常不云无常。不能见顶。又复寂意。诸佛世尊。佛以普见天上世间魔王梵天。无敢当佛睹其顶者。诸天龙神。揵沓和。阿须伦。迦楼罗。真陀罗。摩休勒。人与非人。声闻缘觉。若诸菩萨。莫能堪任见如来顶所以者何。佛成道未久时。转法轮游波罗奈。东方去是世界甚远。乃得思夷华佛土。世界曰怀调。有菩萨名曰应持。来诣忍界奉觐世尊。稽首作礼敬问供事。礼足下已。绕佛七匝则往其前。应持菩萨时心念言。我欲度知如来身限。自变其身高三百三十六万里。观如来身五百四十三万兆垓二万亿里。则心念言。我获神足。神通自娱。我宁可复测度佛身所入云何。佛以威德。以神足力。上方去此百亿江河沙诸佛国土。有世界名莲华严。其土有佛名莲华上。如来至真等正觉。现在说法。应持菩萨往在其前。不能睹之。在上而立遥视。永不逮见世尊大圣能仁佛顶。欲见顶相永不得见也。不知佛身高长广远几千亿载江河沙佛土。时应持菩萨。往诣莲华上佛所。稽首佛足右绕三匝。住于佛前而白佛言。我身所来去是远近。佛言。去此百亿江河沙佛土卿族姓子从彼到斯。应持菩萨白佛言。我上过到若干佛土。不能得见释迦文佛顶。不知高长几百千亿江河沙佛土。彼佛答曰。假族姓子。以是方便圣明之慧斯神足力。从此转上江河沙劫。忽以越过上无喻佛土。尚不能得见于世尊释迦文顶。亦不可得其身边限。又族姓子当知。佛身无限巍巍如是不可譬喻。诸佛世尊不可称载。又族姓子。用无侣故名不可喻。如来禁戒亦无譬喻。三昧定意智慧解脱。度知见品身口心业。色相众好悉不可喻。一切众生以若干品。引譬举喻。咨嗟如来禁戒无极。定慧解脱度知见品。身口心业色相威好。犹如虚空不可得边。如来之身无际若斯。于时应持菩萨。闻莲华上如来所说。忻然大悦得未曾有。即礼佛足绕圣七匝。没彼佛国。承佛圣旨蒙已神力。发意之顷到此佛土。往诣佛所前稽首礼释迦文佛足。右绕七匝则住佛前。以偈颂曰

  欲解达佛身　　犹如喻虚空
  乐得知边际　　以舍所造作
  过此百千亿　　无量江河沙
  上越若干土　　欲见佛身顶
  过到无限土　　至莲华佛界
  乐得身边限　　不睹见佛顶
  其彼国土佛　　名曰莲华上
  见我心所念　　便以分别说
  假使引众喻　　讲诸佛世尊
  便不顺佛教　　则为诽谤圣
  若欲知譬喻　　诸佛法平等
  颁宣虚空限　　实无有边际
  设犹如虚空　　佛戒禁若斯
  定意智慧业　　解脱度知见
  犹虚空无际　　色身亦如是
  欲观世护顶　　等譬如虚空
  如虚空所周　　佛身遍如是
  如虚空所遍　　光明照亦然
  其光照所至　　有言辞若兹
  如言辞所至　　心遍亦复如
  如心所遍至　　慈心布如是
  如慈心所遍　　慧周等无异
  如慧之所周　　身所周若斯
  功德亦如是　　道心无有二
  如道心功德　　解色亦如是
  充满于虚空　　所度复越是
  如一切众生　　所受福德品
  其发道心福　　一人德如是
  如其发道心　　功德业名称
  若受正法者　　功德过于彼
  一切诸佛兴　　颁宣百亿劫
  叹持正法功　　不得其边际
  其兴于道心　　而护诸正法
  好乐解空无　　十六不获一
  以乐解空无　　则不失道心
  执持尊上法　　是慧乃和同
  逮得斯法趣　　菩萨则勇猛
  获致佛功勋　　奉修佛道行
  说是颂偈时　　震动亿佛土
  诸天亿百千　　鼓亿千伎乐
  无数亿千人　　悉发大道心
  因闻大法故　　应持之所叹
  是处不可议　　无上不可限
  诸佛普示现　　自在之秘业

密迹力士谓寂意曰。是如来身秘要。若彼众生皆集一会。或有能见如来身者或不见者。其能见者欢喜观之。其不见者默然而观。如来不食。众生悉见如来服食。又寂意。如有天名精力。初化受道取如来食。而器受之济诸穷乏。众人皆见如来而食。见如来举食着于口中。自然还器。诸天子取往古宿世如来所种。植众德本而有余殃。在在所生就与羸劣。使服食之。饥乏困厄不得食者。如来愍此以食授之。是众生等食斯饭已。身体安隐消除尘劳。众想休息心性仁和。志存无上。以平等觉发不可思议。以是之故当作是观。如来不食。如来至真以法为食。所以者何。如来之身成钩锁体。犹如金刚铿然坚强不可破坏。其如来身无有生藏。亦无熟藏。复无坚软。亦无不净大小诸便欬唾之秽。又如来身如紫金色。无怯无弱不有恐畏。寂意。且观于如来身。旷然无极甚妙坚固。犹如金刚。而身柔软如细天衣。或时上妙显微妙身。天人玉女稽首足下。礼如来身触如来足。柔软极细不可为喻。悉发无上正真道意永无众尘。若贪淫人嗔恚愚痴。若有等分。见如来身适值目睹。其淫怒痴所有等分一切身行。悉为消除无复众尘。若有悭贪犯戒嗔恚懈怠乱心愚痴。使布施持戒忍辱精进一心智慧。取要言之。若有离于清白之法。见如来身。弃不善想皆修德本。以不妄想观于如来。乃曰真道。是为寂意。如来身秘要。若有布施。如来瑞应所化自在。以律开化众生不受长育。解众生想而为颁宣。建立应度。如来于彼观无所业。又无所行。如来至真未曾念是。我当化形。所当化者。若方当化心自念言。又化所观。如来至真在此业前。乃至世界所说土地无数世界。如来所化往来所至。如来在彼观无所想。其如来者。从身放光明。若干种色无央种色。不可计限百千曜色。其光所照江河沙等诸佛国土。光明远照所奉行业。众生皆从彼开化之。以是无业所作行无。是故寂意。如来身秘要。诸所念行。所颁宣说。所成就发无上正真道意。又如来身秘不可称计。说是如来身行秘要时。十千人发无上正真道意。八千菩萨逮得无所从生法忍。诸天人民。阿须轮。世间人。赞叹密迹。善哉善哉。诸天伎乐不鼓自鸣。雨于天华。世尊以右紫磨金色手。举着密迹金刚力士顶上。叹曰。善哉善哉。密迹快善说是如来身秘要。今所宣说如佛所教而无有二。密迹力士谓寂意。何谓为如来口秘要。其夜如来逮无上正真道。成最正觉。至无余界泥洹之界。灭度日夜。于其中间。施一文字以能颁宣。一一分别无数亿载。讲演布散无限义理。所以者何。如来常定。如来至真无出入息。无所思念。亦无所行。无复思想。悉无所行。虽口所宣无想无行。如来所行无应不应。无言无说。不想有人。世尊所说一切超越三昧正受。皆以文字而分别说。颁宣文字而自倚着。一切众生如是周旋往来。如来为我讲说经法。是则名曰如来在彼亦无想念。如来所观而知止足。其舌之门口宣音响。闻所宣音莫不悦喜。而演如来言辞之教。散一音声。悉普周遍众生所想众生心念。是则如来从口敷演。如来言辞出六十品。各异音声。何谓六十。吉祥音。柔软音。可乐音。悦意清净音。离垢音。显曜音。微妙音。明听音。无乱音。无愦音。师父音。无刚鞕音。无粗犷音。善顺音。安重音。身所吉和音。随心时音。空悦音。与爱安想音。无恼热音。方正音。识达音。亲近音。意好音。欢悦音。和教音。晓了音。精勤音。忍和音。重了音。其响去秽音。应师子音。龙鸣音。雨好音。海雷龙王音。真陀罗伎音。哀鸾音。鹰畅音。鹤鸣音。耆域音。英鸟音。雷震音。不卒音。不暴音。普入响音。去非时音。无乏音。无怯音。悦豫音。通畅音。戒禁音。美甘音。进行音。广普音。具足音。诸根无瑕音。不轻疾音。无住音。响普入众会音。宣诸德音。密迹金刚力士谓寂意菩萨。是为如来六十品音。其如来音。普通十方诸佛世界。可悦一切众心性行。如来所观无有妄想。如来道心不作是念。吾当为其口宣经法。通闻经德经所演经分别经颂诗经藏经。于是顺经生经方等经未曾有法经譬喻经章句经。若说古喻。若有引喻。有颁宣言论谈语。诸无上讲诸事敷演众事。有所处当分布远近。开通其本自解晓了。宣畅其义而为开化。又众会等。如来至真所宣法典。亲近佛坐。入比丘众比丘尼清信士女。诸天龙神。揵沓和。阿须轮。迦留罗。真陀罗。摩休勒若人非人众会之党。随众生根所行精进。从所乐法而令入道。以顺入道。求众生无因开化之。乐法音响亦复如是。斯诸众生心自念言。从如来口出。不以各各说法。随心别异言行应时。各各闻法而得开解。是则名曰如来口密要也。又有寂意。无数众生行不可计。其所言辞八万四千闇处下劣。诱进此辈无明众生。入如来法而蒙开化。又众生行不可限量。若有贪淫。随时因彼众生所行。由入其中便救济之。怒痴众生及等等分行三事。蔽众生之类。随其三界思想之顷。庄严拔之令无所住。而无异心。入众生类罪福之行。而为分别。现如来寿而有限尽。不知众生所行罪福。以权方便各说异法。如来善权众生无限。不可计量。所行不同。便为颁宣若干品法。又以众生。在于我所面现相值。如来所说悉遍入心。随其本行宣布道业。各解入道。是则名曰如来秘要。若有菩萨入如来秘要。是等不知。谓于如来至真。演有为之门。而如来法悉是无为。又有如来宣一品音。众生想念坐有所说。唯忆想乐如来音者。望想所说。不当作是观。而如来口永无所说。所以者何。或有众生闻如来音。眉间之相谓之在顶。若有想发。知之绀色从天中[立*寺]。目善明好。人不堪任谛视如来。所以施与。消除诸非。弃诤讼门。无危害心。若颈肩臂去众阴事。若诸指事。若以身胁。若有宣颁。从背至足。若以腹。若以脐又阴马藏。若以膝腨无嗔休息。若以有相及成种好。于世最上。若有想知如来至真闻其音响。随其所好诸根厚薄。从其应度而开化之。演斯音训悉使入律。虽尔如来所观开化亦无相念。犹如寂意。或譬如伎乐以调其音。以手鼓之其声悲和。无有在彼作是声者。皆由方便缘合。而有殊特悲和之音。如是寂意。如来言辞化众生心。缘其畅教。如来在彼。有所演说无有偏党。皆是宿缘所造立行而有殊特。如来至真在于众生。超绝巍巍由本殊特。犹如寂意。呼声之响其音远彻。其音所出不在于内。亦不处外。不在中间。如来若斯宣音训诲众生之心。其辞言教不从身出。亦不从心。不内不外不从中间犹如大海之中如意明珠。演其光曜可一切众。若宝明珠系在幢头。遍照城市。从众生心所欲志愿。其明月珠出宝。众人各得所欲。斯明珠宝亦无想念。如来若斯其有宝心。志存清净执大哀幢。从众生性根无所不应。各使开解。虽显是教亦无想念。是则如来所宣秘要。密迹金刚力士复谓寂意菩萨。吾今普观天上世间诸魔梵天沙门梵志诸天人民。都不能限如来所宣音响文辞。所以者何。我身忆念。如是世尊在灵鹫山。与诸菩萨眷属围绕。而有法典名净音场。广为众生而颁宣此。时慈氏菩萨之所建立。当尔之时。贤者大目连心自念言。吾欲试知如来音响所彻远近。时大目连。自于其坐忽然不现。住须弥顶闻如来音。如在目前。自以神力即游于是三千大千世界。最在其边。越众须弥诸四方域一切铁围山。住在极边大铁围山顶闻如来音。如故无异如近不远。佛自念曰。是大目连欲试如来清净音场。吾今宁可显其神足。于是世尊发现神足。时大目连。承佛圣旨蒙己神足。西方界分去是悬远。然过九十九江河沙等诸佛国土。有佛世界名光明幡。又其土佛名光明王如来至真等正觉。今现在说法。目连到彼。住其佛土。故闻佛音。如人对住听所语辞。其光明幡佛土有大光明。佛身长四十里。诸菩萨身长二十里。其诸菩萨所食钵器。其高一里。目连行钵际上。时诸菩萨白世尊曰。唯然大圣。此虫何所从来。被沙门服行钵际上。于时彼佛言。诸族姓子。慎勿发心轻慢此贤。所以者何。今斯耆年名大目连。是释迦文佛诸声闻中大弟子。神足第一。时光明王佛告大目连。吾土菩萨及诸声闻。见卿身小咸发轻慢。仁当自显现神足力。承释迦文佛威德圣势。时大目连往诣光明王佛所。稽首足下。右绕七匝却在前住。白其佛言。又今是身我欲加趺坐此地容不。佛告之曰。如意所乐。时大目连踊在虚空亿百诸仞。在彼宝域便作一床。加趺而坐。从其床座。垂众名宝珠璎亿百千垓。一一珠璎一一珠中。演百千光。一一光明各有莲华一切莲华现释迦文身坐莲华上。其所说音如释迦文音响。清净颁宣经典。等无有异。时大目连。显神足力已复往佛前。时诸菩萨得未曾有。怪之所以前白佛言。是大目连以何等故诣此世界。世尊告曰。欲试释迦文佛音响所彻远近故到此土。时光明王佛告贤者大目连。仁者不宜试如来至真音响。无限无有远近。岂欲知限卿甚大误假使目连仁以神足过江河沙劫西行不休。不能得知如来音响所闻。诸佛世尊音响旷远超绝无限。巍巍无量不可为喻。时大目连在彼世尊。自投足下自忏悔过。唯然世尊。我身不敏。佛音无量而横生心。欲知其限所闻远近。其光明王告目连曰。汝虽远来过九十九江河沙诸佛世界到此佛土。复白佛言。甚远甚远天中之天。身甚劳极不能复还至其本土。世尊告曰。于目连意所在云何。以己神力到此世界。莫作是观。故是世尊释迦文佛威德所立到此世界。当遥自归稽首作礼于释迦文佛。其佛圣旨将仁本土。假使卿身以己神足欲还本国。一劫不至。卿既未至。到不见能仁佛灭度时。于目连意所念云何。我从何方。东方南西北方乎。目连答曰不知何方也。今以迷惑。不知本土何所在处。为在何方。世尊告目连。释迦文佛在于东方。时大目连右膝着地向释迦文佛所在东方。叉手自归。尔时颂曰

  唯天人之尊　　见垂力愍念
  威德大巍巍　　天人所恭敬
  音响彻无量　　其慧无边际
  愿显其国土　　今欲还斯土

如是寂意。诸佛世尊音声无际不可限量。释迦文佛游在灵鹫山。时舍利弗。闻贤者大目连宣扬大音。怪之所以。贤者阿难前白佛言。谁为于今宣扬大音遥自归命。佛语阿难。耆年大目连在西方境。去是九十九江河沙佛土。世界名光明幡。其土佛号光明王如来至真。今现说法。耆年大目连到彼佛土。意中欲还归斯国土故。遥宣扬此大洪音。阿难又问。以何因缘到彼佛土。佛告阿难。大目连至当问其意。时大众会各白佛言。欲乐得见光明幡世界及光明王佛如来至真等正觉。睹大目连游在其国。尔时世尊。见诸众会劝助意。时从眉间相。有大光明名俱受。照九十九江河沙等诸佛世界。至光明幡佛土。其大光明普遍众会。悉睹其土光明王如来至真。大目连见之自投其地称宣大音。尔时世尊释迦文佛。告贤者大目连。承其光明来还此土时目揵连依佛光明。发意之顷还到此土。稽首佛足右绕七匝。则住佛前悔过自归。重自克责我甚迷误。如来音响不可限量。而欲试之。我所至到极为旷远。所至到处听音适等。近不觉远。如来音响巍巍无际。佛言。如是目连。如汝所云。如来音响彻远。无以为喻。欲知如来音响远近。犹限虚空欲得边际。所以者何。犹如虚空普周无边。如来言辞响彻无际。回远如是。寂意。当说目连往反品时。寻于彼会。一万人皆发无上正真道意。是为如来言辞秘要。密迹金刚力士言。于寂意所知云何。一切众生心各所念。宁可知乎。寂意答言。一人心念思想难限。正使三千大千世界众生。一劫共计观察多少不能知之。何况一切众生心念思想。不可称限乃如是也。今故语汝殷勤嘱累。计如一切众生心想。所演音响无限若斯。何况一切众生心性。是无形想。不可计喻。于是颂曰

  三千界众生　　皆使成缘觉
  一人一劫中　　心念不能知
  一切心所念　　佛悉知志思
  以无想之心　　佛悉了此念
  其一切众生　　三世所想念
  世护口所言　　所布各得解
  佛随之所念　　宣音讲经典
  斯音响在心　　乃演其道宜
  如一切众生　　所思诸名色
  世雄一毛孔　　所演光如是
  如一切众生　　名色及心念
  如来演音响　　过于彼众想
  佛颁宣一切　　引喻计诸想
  其音不休废　　不得佛言际
  无色谁能得　　愍无言之辞
  无色无有言　　消灭无色尘
  假使尘无色　　一切不可得
  以是无色尘　　究竟不可获
  设言虚无实　　无内亦无外
  尘劳虚空等　　故曰无内外
  如使不得辞　　佛言通十方
  尘劳亦无际　　斯建立所处
  一切众生言　　上中下之辞
  无身口心事　　不舍无所立
  想应如倡妓　　诸天之音乐
  亦无身言辞　　而音响普周
  如是本甚净　　众生心若斯
  佛皆颁宣之　　其心无所想
  犹如呼声响　　无内亦无外
  人尊言如是　　乃无内无外
  无想如妙宝　　所说悦众生
  其言无妄想　　可一切萌类

密迹金刚力士。谓寂意曰。是则如来口言秘要。又如来密要随其音声。而为众生说法开化斯三千大千世界。设若干种。如来至真宣布训诲。从其音辞。以不可计诸有名号。化立至诚。若往无业。斯则名曰苦习尽道。名曰地神拥护其心坚固意本于是。咒曰

阿裨　阿婆牟黎　加阿呵那移　阿迦优头

是护一切。是神咒乃名曰苦习尽道。其虚空中一切诸天悉叹所言。各宣咒曰

活知　阿活知　阿活吒迦弥　阿和尼抳黎

救一切。是则名曰苦习尽道。其四天王诸天复咒曰

伊泥弥泥　多闭多多闭　维卢

救一切众生。是则名曰苦习尽道法。彼忉利天上诸天咒曰。是诸咒护一切其回转　贯习　主灭尽　为尽不相举要

第三焰诸天而复咒曰

首黎　道罗　斯和尼　道罗　犀虽耶　道犀虽耶被和尼

第四兜率天咒曰

独犯面触　固转种畜业　是诸咒护一切

第五乐无慢天说咒曰

所度　俱所度　护所度　主度女　是诸咒护一切

第六他化自在诸天咒曰

呵呼事业　呼和泥移　啊罗尼含　是咒护一切

第七诸梵天咒曰

有事业　事业种　因缘树以因缘度　是咒护一切

第八梵身诸天咒曰

清明　造清净　清净风　动清净　是神咒护一切

第九梵满诸天咒曰

无极氏　俱将去　道御主　念坚要　是神咒护一切

第十梵度着诸天咒曰

和那和那散提　和那呵呵那　和那拘摩那

是神咒护一切

第十一大梵诸天咒曰

木密　木密鞕彼亦鞕印氏　是神咒护一切

第十二光曜诸天咒曰

伊谐谐　将谐去　亲近　是神咒护一切

第十三少光诸天咒曰

是取去　不将去　不使去　无所至　是神咒护一切

第十四无量光诸天咒曰

贯习　俱供习　习灭尽　习无量　是神咒护一切

第十五光音诸天咒曰

以断终　自在断　顺从和　常清净　是神咒护一切

第十六约净诸天咒曰

所至趣　所可归　近所到　以近所到　是神咒护一切

第十七少净诸天咒曰

清净　清净氏　净复净　归清净　是神咒护一切

第十八无量净诸天咒曰

无我氏　无吾我氏　非贡高归自大　是神咒护一切

第十九净难逮诸天咒曰

解脱以遮　迹解度本近解　是神咒护一切

第二十应果天。第二十一御辞天咒曰

以无作无所作除所作所作　究竟　是神咒护一切

密迹金刚力士言。是则名曰苦习尽道。所当奉行。所应开化。而随律教。显现微妙无极之业。第二十二离辞诸天。第二十三假使诸天。第二十四善见诸天。第二十五一究竟诸天。净居有四天。谓所奉行决了一处究竟天。真究竟天。无嗔恚天。不亲近天。是为寂意。诸天立至诚誓慧众。如是诸夜叉鬼神。揵沓和。阿须轮。迦楼罗。真陀罗。摩休勒。迦卢迹鬼神。持花鬼神。其言辞教各各别异。又寂意。是阎浮利天下大国。具足有一千。各有大郡。其十六大国。以用治政而相摄护。各自咨嗟。一切诸人及与非人。言语各异音声不同。辞有轻重。如来圣慧从其音响随时而入。皆悉化之立正真业。各有种号。释种。安息。月支。大秦。剑浮。扰动。丘慈。于阗。沙勒。禅善。乌耆。前后诸国。匈奴鲜卑。吴蜀秦地。诸么夷狄。他罗多愚民野人。及诸须曼耶咒。女人处国。牟兜吒国。因缘国。波罗奈国。数树国。金本国。脾罗本国。倚脾沙国。益本国。上本国。他谈国。北方异国。西方所持国。海中诸神。众虫鱼鳖。诸山中神。有形含血之类。阿拘罗。摩拘罗。阿那散诸牧羊诸禽兽。所负诸瘘种。心不平正。前曾生者。处在世者。如是寂意。如斯千国周围充满。于阎浮利天下。各自异居。又是诸人及非人类。言语各异志操不同。音声各别。如来至真随其言音而入其中。因开化之立于正真。密迹金刚力士谓寂意菩萨曰。此三千大千世界。有八十四亿百千垓众生之类。言辞各异。计是一切皆归一谊。至真之慧至诚无怒。如是寂意。是则如来言辞秘要。又寂意。如来言辞。决于一切众生疑网。令无余结。十方一切所有众生。众生种类多于地土。此众生之类所行各异。与本不同。罪皆使毕。逮得人身。以得人身。从思想生。是诸众生逮得智慧辩圣勇猛。如舍利弗。合斯智慧为一人圣。如是比像普使众生皆得智慧。各如前一圣明。以是圣明在于一劫。若过一劫。智慧禅思以察众想。求其本末。如其一人智慧禅思。不复训诲。从第二人。咸受言教。智慧圣达各有大明。以是比像。斯众生等各各所疑。往诣如来。如来一时弹指之顷悉说本末。大圣如是。常以一心入于一切众生心念。皆能分别慧明所在。以一言辞悉决结网。各各处当慧本所在。各令欣然而得其所。所闻如来智慧明达。如来悉令明了。又次寂意。如来悉决一切众生前后所疑。令无余结。是为如来言辞秘要。所入音响又其言教。是不足言。如来言辞不可限量。无以为喻。说是如来秘要言辞时。二万二千众生。皆发无上正真道意。一切众会得未曾有。普闻密迹金刚力士宣如来言辞秘要之业。各怀悦豫。各从坐起。稽首自归密迹金刚力士

大宝积经卷第十大宝积经卷第十一

        西晋三藏竺法护译

    密迹金刚力士会第三之四

密迹金刚力士。复谓寂意菩萨。何谓为如来心秘要。其业清净。所以因缘一切诸天子所生。以一识慧。寿八万四千劫。又其神识不转不变。以为余识乃至定意还得寿命。从彼终没。因其所行受身而生。如是寂意。如来从其夜得成佛道。至灭度日。于其中间。如来无疑亦不回转。心无思行。心无游行。心无不坚。心无所合。心无所散。心无乱。心无移。心无游。心无护。心无寂。心无失时。心无迷。心无求理。心无暗。心无生。心无喜。心无怯。心无住。心无往。心无想。心无望。心无求想。心无消灭。心无所观。心无御识。心无住处。心无观他。心目无睹。耳无所听。无鼻口身。心无想念。意不倚色。无声香味细滑。心不依法。心无乐处。心不非乐。心不住内亦不住外。心不入法。心不越慧。心不观过去。心不观当来。心不观现在。心如来圣。心清净巍巍。其心不造罪福之业。于一切法慧无挂碍。而普示现已。心清净不见他人心不清净。其所见者亦无所观。若所观者。亦无妄想。察无放逸。睹所观见。亦无驰骋。观有所见。永无所见。如来所见。不肉眼视。不天眼睹。不慧眼察。不法眼看。不佛眼观。不合天耳听。不合观他心。不杂念识过去世事。不依神足而为变化。不倚所有。诸漏已尽。于一切法悉无合会。应于诸法无所挂碍。其无吉祥。无有众业。永无所行。其慧所住。犹若本无。皆知一切众生心行。十种力业四无畏慧十八不共诸佛之法。是亦若斯。进退无业。舍心意识。不离如来三昧定住。普造一切诸佛道事。一切诸法慧无挂碍。悉无所著。犹如寂意。如来至真化如来像。其化如来。无心意识身口意。其行所在至真示现。随时能作佛事。化亦无想。亦无求念。如是寂意。道心如斯。犹如来化等无有异。其所化者所念无念。无身口心。因缘进退。目睹见之。皆作佛事。亦无所有。所谓化者悉无所行。诸法如化。如来解是。成最正觉。已成正觉。如来慧识不住五阴。无十八种。亦无诸入。不住内外。无善无不善。无现世。无度世。无有漏无不漏。无尘劳诤讼之厌。不住无为有数无数。无有三世去来今行。周旋往反。不住有为有所观察也。不住无为观也。其慧亦如是。悉无所住。如来至真处于一切众生志性。显仁慈慧。无所伤害。救济危厄。寂意当知。是如来秘要。若有所入。其所班宣无不普达。又有寂意。如来秘要不可限量。所宣秘密不可得底。密迹金刚力士说如来秘要品时。无央数诸佛世界六反震动。其大光明照于十方。睹于十方无量佛土。天雨众花。箜篌乐器不鼓自鸣。无央数人皆发无上正觉道意。不可计菩萨。逮得无所从生法忍。不可限人逮得柔顺法忍。倍复不可计菩萨得一生补处。德本淳淑。以是因缘故。十方所在诸佛国土。各各在诸佛世尊。于贤劫中。众菩萨等净修梵行。是诸菩萨以法供养。皆各散花。奉事贡上密迹金刚力士。其所散花化成花盖。承佛威神。是诸花盖一切咸来。在于佛所。而绕佛及密迹金刚力士。三匝普覆众会。又其宝盖住虚空中。当于佛上从宝盖。出如是比好妙音声。唯然世尊。贤劫菩萨遣我等来。供养大圣及密迹金刚力士。奉法供养及班宣是如来至真不可思议所说秘要。皆佛威变之所为也。尔时一切诸来众会。闻说是法。欣然大悦皆共叉手。咸礼稽首密迹金刚力士。益加恭敬。现若干变。宣说是言。我等世尊。为得善利。获无极庆。乃逮得见密迹金刚力士。值闻如来不可思议秘要言教。若有众生。得致闻是经典之要。而信乐者。以近道业不怀狐疑。未曾犹豫入佛训诲。则当观之。为不退转。当至无上正真道也。时佛嗟叹密迹金刚力士言。善哉善哉快说是言。诚如宣意。复告寂意菩萨。大士。如来功勋甚奇真谛。四无所畏。是经典者。如密迹金刚力士所可咨嗟。快说至训。斯诸正士。诸佛尊法道慧巍巍如是。其闻是法。不恐不怖心不怀惧。解义所趣。若复受持能讽诵学。广为人说不久受决。当作是观。疾逮无上正真之道。成最正觉。尔时彼众会场地。正其中间。于世尊前。地寻时劈裂。深六十八百千由旬。自然出水渧大如车釭。上虚空中高至梵天。洒三千大千世界。佛告寂意。汝宁见此其大渧水上虚空中。洒乎三千大千世界地乎。对曰已见。天中之天。唯然大圣。垂愍唯说何所先瑞。佛告寂意。仁当知此。今斯水渧地无思想无所裂坏。水自然出。诸法师等亦复若斯。若以受持是经至要。住如上教而奉行法。皆当裂坏六十二见众邪疑网。逮得于此不可尽明法辩才之慧。斯诸正士为诸众生。快说正法普悦众心。又寂意。知是经典者。尽脱众恶三涂之难乎。时贤者舍利弗。前白佛言。今贤劫中诸菩萨众。在于十方诸佛世界净修梵行。云何于是密迹金刚力士。期诸菩萨后成佛时。皆当手执金刚侍从后乎。佛言。且止舍利弗。是不可思议。诸天世人得闻是言。将无怪惑。菩萨所行或能不信。舍利弗复白佛言。若有学人殖众德本。当信乐之。我等咸当受如来命。佛言。汝宁见此密迹金刚力士住侍佛后乎。答曰已见。佛言。以神通力本愿所致。常当供养诸菩萨众。于贤劫中当成佛时。密迹力士常应侍之。亦如侍我也。是舍利弗。密迹金刚力士。皆于贤劫诸菩萨众常当侍卫。贤劫诸佛以神通力。皆是本宿自在誓愿。佛言。舍利弗。正使三千大千世界一切众生将来成佛。皆当须侍。得佛道时亦执金刚悉卫侍后。而自示现。虽尔变化。又此正士神足之德。建立圣威未曾损耗。舍利弗。宁见弥勒菩萨。今密迹金刚力士常侍其后。答曰已见。世尊。以是之故承佛圣旨。从古以来未曾闻斯。佛告舍利弗。常侍弥勒汝等不见也。亦在他方诸佛国土诸菩萨来。天帝释梵及四天王。见密迹金刚力士侍于弥勒菩萨之后。又时其余贤劫之中弥勒菩萨及余菩萨化作亿百千垓诸菩萨众。皆在其后而侍化人。开度众生。以是正士所建立威。不可思议神足威变巍巍如是。具足众德六通慧力。不可限量。于是寂意菩萨谓密迹金刚力士曰。岂能屈意班宣如来修勤苦行。庄严道树降伏魔官。而转法轮造立至谛。仁者所明具说意旨。密迹金刚力士谓寂意曰。其功德勋不可限量。假使住命一劫称其至德。不能具宣讲论意旨。承佛威神粗举其要。又曰寂意。菩萨所行。不以一事修勤苦行。菩萨行法为外异学。欲济危厄故示现义。各以随宜从其身行。多少明宣显其威仪。因而得化外学众邪。现身最胜尊豪难逮。所行勤苦甚不可及。示现菩萨威仪礼节。一切外学众邪异业。所不能逮。菩萨在彼。住一章句解无量义。或现上方。或现日月。周旋往反。或现神通飞行仙人隐处。或现儒林国师居士。或现宗长圣帝四王。或现帝释梵天转轮圣王。或以自现行不具足。或现其身卧荆棘上。或现卧[麥*弋]草上。或卧土上。或现所卧。或畏。或无所畏。或现卧处。或现坐食果。或现弊衣。或卧泡上。或现赭衣。或现裸形所共游居。或现服食犹孝子睒。或现恶食。或现食豆谷。或现食麻米。或现食萝菔若芋芜菁。或以食餔若食菜茹。或食荆棘。或服叶花实。或现食枣果。或能一食。或再食。或现常食。或现七日一食。或现十五日一食。或有一月一食。或服一渧苏。或服一渧油。或服一渧蜜。或服一渧水。或服一渧乳。或现不食。或现常住。或现常坐。如是寂意。是及余行不可称计威仪礼节。是为菩萨所现苦行。菩萨所现勤苦之行。具足六年。不但一行威仪礼节。行若干种示现具足。复以超是坚固勤修精进。又诸众生不见如来若干品威仪礼节。亦不能知菩萨所为。若有众生能修行道。如其所行。举动进止威仪礼节。以是开化使得度脱。若见菩萨威仪礼节。乃能睹之。菩萨所行观无妄想。是为菩萨所行勤苦。具足开化六十垓人三百万诸天人民。皆入道业。尔时菩萨行微妙业。又菩萨行在于所生。坐宝挍露高阁之台。而示现生无众患难。永得安隐三昧常定。而反示现六年苦行。复见起去。彼时诸天求于法乐。若志经典不慕世俗。住菩萨边无有异业。唯班宣法是为菩萨。时有菩萨名曰法种。好乐大乘入于大哀。复有法典。名入不可思议法门。又号普摄。降伏众邪一切诸魔。入苦难慧永获大安。密迹金刚力士谓寂意菩萨。菩萨勤行竟六年已。辄如所现精进威仪。从其坐起。诣于尼连闲静河边。顺示从世故。到闲静流河水际。洗身清净度河水去。往至他处而独立焉。有弥迦女名善荫构千头牛而取其乳。展转相饮取后淳湩。用作湩糜。在釜跳上数十丈。女怪所以。梵志占之。临成佛者乃应服耳。时女赍往诣菩萨所。及六万天龙鬼神揵沓和等。各各赍食奇异甘膳。诣菩萨所各自启曰。唯愿垂愍受是供养。于时菩萨受善荫弥迦女乳糜服食。亦取一切六万天龙鬼神揵沓和妻饭。示现皆食。诸来施者各各自见。独受其食不见他人。他人亦不知之。时一一人各自念言。菩萨独念取我供食。当逮无上正真之道成最正觉。以是喜悦发大道意。应时得立不退转地。是为名曰受供膳食。开化众生故现六年勤苦行业。密迹金刚力士谓寂意曰。是为菩萨随其世俗受供而食。使身气力充备安和。往诣树下。又有地神名善地天子。告诸天子及余地行天神。持地不动莫令肃震。断众爱欲及诸结着菩萨。已到于树王下。严净其地次第诸施。欢然三千世界自然清净。散花烧香。香水洒地。迦留迹天持花鬼神下其天宫。住虚空中。见菩萨欣然雨种种华。其四天王与其眷属。至四方域。以紫磨金网缦妙帐。周遍覆盖三千佛土。以供养佛。天帝释梵前有大神足。庄严如意。咨嗟三千世界。忉利天焰天各紫磨金帐而挍露之。绀琉璃帐覆三千大千佛土供养。兜率天珠校露帐挍饰。供养如来巍巍堂堂。及诸天王微妙甚好如紫磨金。其心大悦供养如来。雨好真珠。化善天王。以明月珠光明晃耀。白玉银帐。演其和音流布十方。令三千世界莫不悦豫。乃至诸天清净众宝威神。无量无垢显明。他化自在天化作一帐众宝合成。普奉事佛。诸天龙神。阿须伦。迦楼罗。真陀罗。摩休勒。各以神足圣力示现庄严。修治一切欲界。力士谓寂意。尔时有大梵天王。名曰威神自在。主三千世界极尊无量。其菩萨行往睹佛树。又是天王告诸梵天。诸仁当知是菩萨大士。于过去佛。修治正行殖众德本。稽首归命无数诸佛。大愿不动坚强意固。志不患厌。皆兴一切诸菩萨行。奉修诸度所度无极。悉于其地而得自在。志性普和善修清净。尽入一切众生根本。皆通一切如来秘要悉度魔事。其众德本不依仰人。为诸如来。善修建立无上道法。为大导师救济众生。班宣经典。一切众生合一勇猛拔乎魔境。永无魔业晓了道法。为大医王疗众生病。服解脱冠为大法王。演智慧光无极圣帝。不为世俗八法所拘。犹如莲华不着尘水。执持诸法未曾忽忘。犹如江海智不可限。如须弥山不可动摇。净洗其心如水洗垢。终不自大常行谦下。如明月珠去冥众浊。于一切法而得自在。积众德本。犹如梵天天上第一。往诣树下降伏众魔。逮得无上正真之道。为最正觉。具足诸佛十种力四无所畏十八不共诸佛之法。转大法轮为师子吼。充满一切润以法施。欲净一切众生道眼。摄取诸法。弃外邪业九十六种。具足本愿。好见诸佛十方境界。大圣威德游得自在。第一诸度所济无极。汝等仁者。常当谦恪恭诸菩萨。于是自在梵天。于诸天前说是颂曰

  清净正行　　决上妙法　　愍伤世间
  哀及诸天　　天中之天　　天人中尊
  大圣今往　　诣佛树下　　当降伏魔
  及与官属　　逮得正觉　　成一切智
  已乐备悉　　最正觉业　　便复以转
  正法之轮　　大智无穷　　大师子吼
  可悦一切　　众生之心　　以清净故
  致妙法眼　　导师往诣　　于佛树下
  降弃众魔　　消外异学　　皆悉具足
  本宿誓愿　　正觉法身　　所见无倦
  其时导师　　往诣佛所　　善哉一切
  皆共和同　　当好庄严　　三千界地
  是以校饰　　于其欲界　　色无色界
  庄严如是　　善哉梵天　　其心仁和
  此三千国　　一切严净　　如是欲界
  以清净好　　所见供养　　复过于彼
  名香木櫁　　众花顺义　　斯宝光明
  鼓众伎乐　　其有睹者　　莫不欣喜
  而梵天王　　普三千界　　从梵天王
  至迦尼吒　　各各梵天　　平生清净
  在虚空中　　神尊复尊　　有天中天
  见净复净　　六十亿载　　诸天来会
  为于菩萨　　严金刚场　　下诸天花
  而雨供养　　众香香水　　以用洒地
  众宝妙床　　施设诸座　　严净校饰
  佛树下坐　　我等导师　　一切咨嗟
  随所安处　　令其清净

时密迹金刚力士谓寂意菩萨。时菩萨往而坐树下。于其足底生千辐相。从出光明。其光遍照斯佛国土。靡不周至。一切地狱畜生饿鬼。一切众人苦恼休息。又大光照黑耳地狱。时黑耳地狱蒙世尊光。欢喜踊跃众云集焉。于时诸天咸说颂曰

  紫磨金色光　　从天中眉出
  来照我等身　　令心中欣然
  我值过去佛　　睹见好瑞应
  大雄必不疑　　佛定出世间
  善哉杂饰鬘　　香花及涂熏
  紫金明珠成　　右手执持衣
  鼓其妙伎乐　　而受彩幡盖
  亦竖其大幢　　供养于世尊
  诸地狱中人　　蒙光普清净
  以供奉于佛　　承事于大圣

于时黑耳大地狱中。王与中宫俱。其所集众。一切各持花香杂香泽香衣服幢盖幡彩伎乐。出其宫宅上虚空中。化作宝云。雨明月珠名香木櫁及栴檀香众花真珠。承龙大神神足变化。诣菩萨所稽首足下。右绕三匝与其眷属。各以所执供养之具。进上菩萨作其伎乐。以是颂偈而叹世尊

  犹如有宝地　　庄严杂丰妙
  佛树花果茂　　获坐其道场
  如河定不流　　若月住虚空
  成佛普一切　　降伏魔官属
  世尊众祐曜　　犹如日盛光
  若如重六通　　蜂王宣和音
  演其光明慧　　如梵天须轮
  今日众祐现　　充满藏无限
  日月珠火光　　天帝释梵曜
  能仁光适出　　皆覆蔽其明
  光现我宫殿　　知佛兴乎世
  显瑞应欢喜　　知今佛出现
  见闻拘留孙　　拘那牟尼佛
  迦叶诣佛树　　适闻音供之
  见于无等伦　　瑞应与彼同
  心生欢喜悦　　今必当有佛
  世尊我善利　　得广供养佛
  以四事世光　　奉信行恭敬
  所积功德福　　具足奉明眼
  是世光明曜　　成佛无等伦

尔时菩萨。往到迦邻龙王所止土界。龙王见佛心中欣然。自出其室往诣佛树。住佛之右。又有一人名曰吉安。遥住视佛。因求好草手执此草。观菩萨至诣佛树下。诸天宣畅柔软微妙。咨嗟德音安隐巍巍可意快乐无上之德。绕佛转进。其草香好香风流布。靡丽光泽好细无量。犹如天衣。如是好草以时执持。往到其所。以此好草贡与菩萨。稽首足下右绕七匝。以仁和心至不退转。发无思议无上正真之道。心自念言。不当作是非宜之行。所观若斯无吉不来。乃至吉安。以时施与菩萨之草。当发无上正真道意。所以者何。本愿所致。寂意当知。吉安乃往宿世本愿作是。所以者何。我忆识念。寂意菩萨。乃往过去无央数世经九十一劫。维卫佛时兴出乎世。如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。其佛世时。有千比丘净修梵行。彼时世尊授是千比丘决。在贤劫中当成无上正真之道。为最正觉。时于会中有一长者。名曰有志。闻授菩萨决。心自念言。我于贤劫当成如来逮最正觉。则不违宜。吾于彼世见施好草时布师子座。甚妙严净仁和安然。缘是则发无上正真之道。寂意。欲知尔时有志长者。今吉安是也。以是之故当作是观。如其本愿致吉安行。彼以随时施与好草。所可因号。后成佛时。名如来至真宝净师子。尔时菩萨以授好草布佛树下。又上树神乃至虚空一万天女。各以衣裓盛好天华。各取香花杂香泽香。往迎菩萨。稽首作礼。各持众花香幡盖供养菩萨。以此赞曰

  无恐无所畏　　无怯不怀难
  建立难得值　　无染无痴恶
  无凶祸之罪　　无悭嫉无愚
  离欲以解脱　　愿稽首大圣
  以律化得度　　粗犷及邪行
  善为俗良贤　　疗治众苦疾
  见诸无救护　　无灯光自归
  今佛兴出世　　济脱于三世
  诸天之大众　　各心抱踊悦
  一切普雨花　　众花若干种
  诸天所造供　　衣被及细好
  当成为佛道　　皆发欢喜心
  以坐树王下　　心不怀恐怖
  以甘露之味　　坏裂尘劳网
  觉了乎寂然　　致最尊佛道
  如过去诸佛　　晓了最胜法
  其所奉行要　　修无央数劫
  以积累苦行　　欲度于众生
  昔愿已得成　　今正是其时
  逮得尊佛道　　唯演布慈愍

密迹金刚力士谓寂意菩萨。佛以时取草往诣道树。以此好草布其树下。稽首作礼右绕七匝。适布座竟。应时八万四千诸天子等。睹菩萨布座心中欣然。寻设八万四千师子之座。座甚微妙若干殊异。极高广长众宝合成以奇珍为栏楯。周回兴立挍露之帐。以紫金饰。则用真珠垂珞其间。明月夜光杂厕罗列瑰奇之宝以用作铃。悬之甚鸣。其音和雅无量调合。无数天衣而布其上。菩萨应时自变其身。普遍八万四千师子之座。是诸天子各不相见。亦不相知。一一天子心自念言。菩萨独处我师子座。成最正觉。以是悦心至不退转。然后皆当逮得无上正真之道也。密迹力士谓寂意。于时菩萨建立威神。使魔知之。与无央数不可称计亿百千垓鬼神俱。发眷属围绕。皆被铠甲。显大神足兴最势力。将众鬼兵。周三百三十六万里颜貌各异所从不同。各现威势无数众难若干种像。兵仗严整。头首各异志愿各别。饭食所行志操不同。言声各别辞谈音异。皆诣菩萨。时魔波旬与大眷属甚可畏惧。不顺仁义所作大非。兴反逆事。不可见闻。不怙道德。各执兵仗称叫大呼。扬其音声惊动三界。假使凡夫未离欲者。得闻此音辄当沸血从面孔出。或恐怖死。其时菩萨不以此难而有畏矣。亦无挂碍。于时菩萨兴大悲哀。可畏音响自然消灭。不知所凑。所以者何。欲安众生不令被娆。无危害患。菩萨逮承奉净道心善权方便。虽闻此音了之本虚。本无有声。衣毛不竖。见魔众来光颜益荣。大明显发宣四事业。志无所畏以十六事。兴己辩慧。随所可乐摧折大难。而告魔曰。且止波旬。用为兴发如斯色像无益之事。而怀嗔毒。还自危身长夜不安。所以者何。波旬。今日发心欲坏菩萨。菩萨弘仁。以大勇猛无尽大哀。怀无极慈降伏恶逆。欲乱菩萨。菩萨本净消除垢浊羸劣阂心弊恶之尘。今日波旬。反成菩萨。欲以萤火越日月光明。菩萨已免无限之底。演大柔和深妙道味甘露正觉。诸小虫兽欲惊师子。魔今欲躄大无极树以使摧折拔其根本。以牛迹水欲比大海。反长怨贼。无益之城起凶敌心。今日魔王。当与度怨。言谈说事横兴反祸。恶鬼为伦。当蠲迷惑取道伴党。令至平等而无殊特。弃非法王自归圣道严净微妙。生无上慧仁义法味。舍众邪曲令心质朴。今日波旬。心当惟念。过大旷野最后究竟尽生死源。而反驰骋入大海中。当乘大舟度终始流。今遇习学。值被劫烧并灾树木众杂药草。莫复毁坏大金刚术。当归大道然后得佛度脱十方众生人物。密迹力士谓寂意。于时诸天叹咏佛德巍巍。如是而无比像。其魔波旬。以得叹佛闻是十六事。好乐所慕心存大猷。于是密迹力士谓寂意菩萨。菩萨自念。吾不可计劫功勋普着。因行成就从无央数百千亿垓。积功累德。皆是宿本世世本法。每生自克愍念众生三界之厄。故行柔软平正鲜明。致清净业。谁敢毁坏独地证明。于时菩萨。从袈裟里出紫磨金色手。普摩己身不舍大哀。志性调和欲度众生。常行安徐。举其右手向十方界。自见诸佛适至乎地。三千大千世界六反振动。有自然音。其音宣彻十方佛土。其魔波旬闻斯音声。及魔官属在虚空中。亦闻斯音响。咸共自责。饥虚禁戒乐乎勤修。又时大圣加施无畏。愍伤众生。应时八十垓魔及鬼神伏向菩萨。自然躄地心自归命。唯见拥护诸在众中。与魔眷属破坏亡去。自然迷惑不知所凑。所以菩萨演大光明。愍哀斯等各离恐畏。皆归天宫。以是之故。菩萨大士现降魔王及众官属八十亿垓鬼神。皆发无上正真道意。九十二亿载人以仁和心立不退转。八万四千诸天子等。宿殖德本。逮得无所从生法忍。密迹力士谓寂意曰。以是比像所降众魔。诸天世人不可称载受化得济。其诸天人追魔波旬。若人以见菩萨所行。或见坐于宝净莲花师子之床。或见在地。或在虚空师子座上。或复见在贝多树下。或见在忉利天上昼夜树下。或以见在众宝树下。或复普见一切诸人七尺诸佛树下。或诸天见坐佛树下处在师子半仞座上。或在七仞。或复十里。或二十里。或四十里。或诸天人悉见八万四千由旬佛树下座。或复现在四万二千由旬坐师子床。如是寂意。诸菩萨不可称计境界难限。诸菩萨众由是道场归乎殊特。菩萨所行有若干种欢乐之业。八百千行。菩萨所现不同。各从本性而开化之。发贤圣意成最正觉至一切智。随时音响而班宣法。供所当奉。菩萨于彼以若干品。其所咨嗟。皆是菩萨本宿所行。菩萨所因劝乐示义。咸来咨嗟而供养之。虽尔菩萨心无所著。无有魔难以舍众害。普逮一切诸佛道法。须臾一时发心之顷。等行智慧悉当知此。逮致佛道为最正觉。以达一切逮最正觉。住在一切十方世界。见不可计无限如来。授其右掌尽问佛道。又咨永安道德之源。道慧微妙无有患厌。讲论至道慧得自在。宣布平等入无邪业。分别示众无央数行。剖判三宝使不断绝。敷演大哀。于一切法而得自在。入于豪势无穷之业。若有众生诸根淳熟。悉能了是菩萨所行。若诸根乱不知所趣。菩萨适成如来道法。夙夜七日悉存法乐。观佛道树不以为厌。目未曾眴。百千亿天来叹供养。百千玉案贡上甘膳。咸发无上正真道意。睹见如来威仪礼节。已成佛道如来至真。时四天王各往执钵奉上如来。如斯刹土一四方域。三千大千世界为中国土。大千国土各有百亿。诸四方域四百亿四大天王。皆各执钵往授如来。如来悉受。佛显威神。使诸天王各不相见。各自心念。佛受我钵当以饭食。以此忻喜心中坦然。咸发无上至真道心。至不退转。佛以成道。提谓波利五百贾客。佛欲度之。现车马顿。贾客伴党及余而不自在。怪之所以。天于虚空告言。佛兴在世可往供养。闻之忻然。各上蜜糗醍醐。八万四千诸天子众。亦贡供膳。如来受之。其本宿世曾建至愿。如来成道。我等第一进奉供膳。欲遂本愿。各不相见不知所在。一一各念。独供养佛余无进者。以是忻预逮不退转。然后当得无上正真之道为最正觉度众危厄

大宝积经卷第十一大宝积经卷第十二

        西晋三藏竺法护译

    密迹金刚力士会第三之五

尔时密迹力士。谓寂意曰。菩萨往诣佛树以成佛道。如来至真未转法轮。开导众生巍巍如是。所化无量。多于初发行道时心。及坐佛树所济众生。岂可呰哉。以故知之。当作是观。若有菩萨坐在法床。疾近无上正真之道。所度众生益复加倍。适成佛道。妙式梵天王与六十八万亿垓百千眷属。围旋往诣佛所。稽首足下右绕七匝。侧住佛前劝助世尊。唯垂大哀转乎法轮宣布道化。多有众生应在法器。闻佛说法能解受行。如是寂意。妙式梵天王劝助如来。使转法轮。殷勤若兹。住在佛前。本宿所愿得见天尊。其一天王名提头罗(晋曰勇护)。与其子俱勇出本誓。我当普劝贤劫千佛一切如来使转法轮。欲知妙式梵天王独劝助佛使转法轮乎。莫作是观也。所以者何。与十亿梵众眷属俱。十亿天帝及十亿百千垓诸菩萨众。劝助如来使转法轮。世尊适然。当转法轮。妙式梵天王。诣波罗奈鹿苑之野神仙所游。布师子座。高三千二百八十里。若干种品文饰微妙众珍严校。妙式梵天王。适为如来布师子座。其十亿梵天。十亿天帝。十亿百千兆垓诸菩萨。亦为世尊布师子座。高广俱等。各自心念如来当坐我师子座转于法轮。密迹力士谓寂意言。尔时如来。诣波罗奈鹿苑之野神仙所游。坐师子床。梵释四天王及诸菩萨。各自心念。如来独坐我师子床。如来遍坐师子床已。应时十方无限佛土六反震动。尔时世尊。以无极界三昧正受。即时三千大千世界皆悉平正。等如手掌。此三千大千世界地狱畜生。若在饿鬼天上世人普获安隐。一切众生无淫怒痴。消三毒病清净无尘。慈心相向如父如子如母如女。十方无限诸佛世界。不可计数诸菩萨。来听佛说经。三千大千世界。大神。无极诸天。龙神。揵沓和。阿须轮。迦楼罗。真陀罗。摩休勒。人若非人。皆诣佛所欲听经法。诸来会者皆遍充满。于此三千大千世界。无如毛发空不周者。皆共同心饥虚于法。悉欲稽颡咨受大道。于时世尊。见大众会皆来云集请转法轮。为诸沙门异学梵志诸天魔王上梵天王及其世俗。宣布正法。又有寂意。于时如来适转法轮。随时之宜。从众生心各令得解。因其云集。各各为宣宿本所习。令心开达悉遵法行。如来至真适说斯法。为重分别。拘邻欲知。眼悉无常。了眼无常则随律业。计眼有常不喜无常。闻眼无常眼苦毒痛。计眼吾我不好无身了无吾我。以闻于眼无有吾我。乃随律教解其音响。眼如幻化野马水中之月。如梦已觉。犹若形影山中之响。随此律教乃奉行法空无相愿。其眼无行惔怕寂寞。闻眼静默。眼从缘起以闻缘起。耳鼻舌身心亦复如是。皆归无常。以闻无常解意为苦。睹无吾我寂然惔怕。空无相愿用不达故。从因缘起五阴无常。其计有阴不了无阴。虽说诸种悉归无常。以得闻说诸种无常。心无所著。心得闻说五阴无常。悉解空耳。计有诸入。不解诸入无常之谊。以闻诸入归于无常。五阴诸入四大诸种亦复如是。闻四意止四意断四神足念五根五力七觉八品道行。以得闻是三十七品。解无常空。若闻寂然。颁宣道法乃随律教。若闻所观。其可声闻不乐缘觉。乐闻缘觉不志声闻。若慕二乘不说大乘。若宣大乘闻其义趣。不好声闻缘觉之辞。如是寂意。如来以斯随众生心所可爱乐。而转法轮。各令得所。如来以是。为众生讲转于法轮。时耆年舍利弗。于百千岁。思惟本行道义所入处。不能限知。何况于余众生无底。时佛说是菩萨苦行。庄严道树。降伏魔官。转法轮时。八万四千人皆发无上正真道意。尔时密迹金刚力士前白佛言。唯然大圣。我向所宣如来秘要。将无违失毁谤如来傥不顺法。如来秘要甚为玄妙广大无际。一切世间所不能信。下劣虽说如来秘要。心自忆之。如来至慧入我身中。非我威势圣猛之力。佛言如是。如密迹言。如来道慧所入至处。莫不蒙安。敢佛弟子班宣经典。皆承如来威神圣旨。以入如来空法之身。道慧玄妙靡不通达。所以者何。欲使众生奉承建立。如来圣旨宣柔顺义。未之有也。卿审真谛承如来慧。得无所畏今演斯法所云真谛。正谓此法。所以者何。所谓正谛。去来今佛普世布信。靡不笃乐。其行无上正真之道。假使班宣此经典要。如法不违。皆当成佛。若有闻说是如来秘要经法之典。而信乐者。斯等之类。普世一切皆信敬之。设使有人。以顶若肩戴须弥山。在虚空中。是事当可。无德之士不能堪任闻是经典。既闻不信不能爱乐。况复受持讽诵讲说。未之有也。若闻是经受持讽诵为他人说。前世宿本以曾供养无央数亿百千兆载诸佛世尊。斯等正士殖众德本。志存大乘受决无疑。何况至真能奉行者。尔时寂意菩萨前白佛言。唯然大圣。所云寂然惔怕之义。为何谓也。佛告寂意。所云寂然惔怕义者。谓消尘劳惔怕众秽。以消尘劳。尔乃名曰去于贪欲众想希望。以去欲想便无所思。以无所思便不着界。以不着界。便无报应因缘之对。以无报应因缘之对。便无无明所有恩爱。以消无明所有恩爱。便消吾我。以无吾我。便消名色。以无名色。便消断灭计常之业。以无断灭计常之业。便消贪身。佛告寂意。诸因缘报随于诸见颠倒之业。便成尘劳。皆由贪身而生斯患。以无贪身。便舍诸见六十二疑。以无贪身便寂众缘。以无贪身。一切贪欲自然惔怕。以无贪身一切诸愿寂然消灭。犹如寂意。拔树根株。茎节枝叶花实一时并除永无有树。行者如是。以消贪身便无诸见六十二疑。以无贪身。皆去一切诸所受法五阴六入尘劳之患。以无贪身。无有五阴尘劳诸患。唯然大圣。不断贪身故有吾我。佛告寂意。住吾我故不断贪身。住人寿命故不断贪着。其所见者不住内外。诸见无处一切所至永无所见。以无所住见慧无所住。是则名曰断贪身见。贪身悉空以能解空。柔顺法忍不受彼见。己身无想悉无所行。无生无起亦无所兴。乃名之曰柔顺法忍。不受诸见是断贪身。寂意。欲知若不贪身解脱身无身。何谓无身。身四大成本亦无名。以了是者意解虚伪。故曰不真而不可得。皆由不真妄想而兴。若无所求不怀妄想。不迷不惑。不作不住。若无所住则无嗔诤。其无嗔诤乃曰寂然。为行惔怕。何所消灭名曰寂然。消众因缘乃曰寂然。所以者何。从其因缘令心炽然。以无因缘则无炽然。犹如寂意。从其缘对而生有火。两木相揩因火然炽。无对无火则不然炽。如是寂意。从其缘对令心然炽。以无缘对则不然炽。又彼寂意菩萨大士以权方便。晓了随时消寂因缘。而不消灭众德根本。不兴尘劳因缘之对。兴发诸乱诸度无极。弃舍魔事众邪之业。不舍诸佛道行缘业。舍因泥洹。不舍道业三十七品。心不志乐声闻缘觉。不舍菩萨至真道意。用观空无。以兴大哀。察众因缘。以无相缘宣讲至德。不以妄想失乎道心。以无愿缘厌于三界。因对诸对惟无生缘。不舍所生无犹豫缘。因诸所行修其德本入道业行。是为菩萨权智入净逮得自在。无常缘哉。不厌生死而得自由。无所畏故。有苦缘哉。建立众生存灭度安。使得立故。无我缘哉。建立愍心安于众生。行大哀故。虚无缘哉。心得八正如来净身故。缘欲行哉。为诸贪爱病清净药故。颁宣其法哉。令心坚住故。缘嗔恚哉。使众怒行宣慈心药。志住无病故。缘愚冥哉。为众痴行施十二因缘药。治其心病使不动移故。等分缘哉。等于三事化众生行建立其心。讲无常药故。缘无欲哉。心以存立化开声闻故。离嗔恨哉。使心得立缘觉之乘故。离愚冥哉。开化其心立乎大乘故。色像缘哉。其心等住逮得如来像身故。缘音响哉。心以住在如来言声故。缘众香哉。心以存立如来戒勋故。缘众味哉。心以住存如来道味故。缘大人相哉。心行以住得庄严故。缘细滑哉。心以存立得于如来手足柔软故。缘经法哉。心以住在逮得如来无所生意故。缘布施哉。心以住在相好具足故。缘持戒哉。心以存在佛土严净故。缘忍辱哉。心以住在逮梵音响故。缘精进哉。心以存立度于众生故。缘禅思哉。心以住在兴大神通故。缘智慧哉。心以存立断众邪见六十二疑挂碍之因故。缘慈心哉。心以住在等志众生而不怀害故。缘愍哀哉。心以存立救济众生故。缘喜悦哉。心以住在好乐听法故。缘于护哉。心以存立弃舍众结危厄之患故。缘四恩哉。心以存在开导众生故。缘贪恚哉。心以存立一切所有训施众生故。缘犯恶哉。心以存立如来戒品清净行业故。缘诤秽哉。心以住在如来忍诤故。缘怨害哉。心以存立如来十力四无所畏故。缘乱愦哉。心以住存逮佛三昧故。缘邪智哉。心以存立无所挂碍智度无极具足众生故。缘下乘哉。心以住在积功累德志好大乘故。缘顺应哉。心以存立志和安然。不犯众恶一切非宜故。缘恶趣哉。心以住在救护一切众生恶趣堕八难故。缘诸天哉。心以存立解诸合会皆当别离故。缘众人哉。心以住在一切妙善故缘念佛哉。习见诸佛故。缘念法哉。心以存立奉行道法舍无益宜故。缘念众哉。逮致便御不退转法故。缘施与哉。心以住在不舍众生故。缘禁戒哉。具足所愿故。缘念天哉。心以存立备悉功德一生补处故。缘身行哉。逮致佛身故。缘口言哉。心以住在致佛言教诸经典故。缘其心哉。心以存立获乎佛意故。缘有为哉。心以住在积功累德具足自克故。缘无为哉。心以住在圣慧具足故。如是寂意。不以无缘化至道乘。皆由缘心得至佛道。导一切智。若有菩萨。皆由缘故导一切智。是为菩萨善权方便。皆由见诸法。悉怀来导。犹如三千大千世界含受土地。十方众生草木五谷。诸水河海毛发之形。靡不苞之。一切咸仰而得生活。如是寂意一切众缘。皆由菩萨善权方便。行最第一众行之英。至一切智。犹如众色诸形貌皆有四大。菩萨。如是执权方便。所造行缘皆至佛道。所以者何。一切众生所兴殃罪。为无反复。菩萨缘是行施度无极。辄能具成戒度无极。若人嗔恚心怀毒害。于时菩萨行忍度无极。寻时充备进度无极。若见众生在于愦闹。不能安心。缘是菩萨行禅度无极。忽以具成智度无极。若有众生存在诸蔽。立冥冥室窈昧之厄。菩萨为断众缚挂碍众结之网。若有众生能勤修业。便为消除一切所著。有求咨嗟。稽首叹之。示其自师。喜诽谤者。亦随顺意。令不起心。若见勤苦被无数恼菩萨则时为兴大哀。见在安者。则以大悦而救摄之。菩萨随时若见刚强难化之类。开训导示兴发觉意见仁和人。菩萨在彼修治至业。发起道心。若有众生力势。在缘菩萨则随兴显。将护证发意心。若有力士报应业行。菩萨寻顺摄取训诲。显起道意。是曰随缘而得自在。菩萨随顺善权方便晓了众生。应时宣法在报应力。志欲爱慕开化剖判。各使坦然。勤进大道圣慧。为论深远无逮之义。其存侧慧广为敷演至真之道。渐为班宣示斯道因。解别章句。以一句法畅若干慧。乐寂然者因为分别。普观一切。好于观者。以观解脱三昧定意。讲说禁戒不可究竟。复为宣讲地狱饿鬼畜生。以闻其法。为解无常无救护事。使求道护。若有定意。为论慧度慕在闲居。因行化之静身口心。知限足者。显发智根圣贤之业。在于自大愚冥之思。当为宣布勤学博闻。好贪欲者。示其不净无益之患。喜于嗔恚。劝发慈心不怀厄害。若存愚惑。显化其心。十二缘起生死之法。其存等分。为演无常苦空非身。勤志色欲。各化不净仁慈至无解愚冥者。为诲瑕秽缘起事。或作诸见。因其决了空无之慧。其怀希望。演无想行。志存要誓。训以无愿。训慕诸盖剖析诸阴。想如幻化虚伪不真。贪着诸种。为了四大十八诸种。犹如形影行照而现。其倚衰入讲说诸入。内外十二皆非我有。犹梦所睹觉不知处。其依欲界。为人分别畅说一切万物皆归无常。若恃色界。敷演一切众行悉苦恼根。设怙无色界。宣布道教。一切诸法而无吾我。难化之人。常令勤习贤圣之法。易安化者。当为开示无极之辞。志存天人。欲往心懅。咨嗟戒品清净无垢。乐声闻乘。指示四谛苦习尽道。若慕缘觉乘则为开示十二缘起以痴为本。觉大乘业。因其流布六度无极四等四恩。而训导之。初发心者。观其志性而训喻之。备悉众行不厌生死。示以无难令立不转。为不退转者。因分别说佛土清净。一生补处菩萨大人。显示至真佛树道场。如是寂意。若有菩萨逮得自在。从其缘化所宣道法无有罪衅。以善言辞可悦众生。说是语时。有一万人发无上正真道意。五百菩萨皆悉逮得无所从生法忍。时彼众会有诸菩萨各心念言。密迹金刚力士。久如当逮无上正真之道。为最正觉。得佛道时所号为何。其佛国土严净功勋为何等类。诸菩萨众成就云何。尔时世尊。知众菩萨心念本末。寻时即笑。无央数亿百千光明从佛口出。照于十方无限世界。蔽日月光。盖魔宫殿。光还绕佛无央数匝。从顶上入。时寂意菩萨即从坐起。偏出右臂。叉手礼佛。以偈叹佛而问笑意

  巍巍犹紫金　　妙光舍众垢
  意寂然坚住　　如日在虚空
  其光大盛明　　悉消诸幽冥
  今所以显现　　人中尊宣之
  惔怕如莲花　　生立淤泥中
  其茎根在水　　稍长无垢秽
  功勋甚馨香　　意念转广远
  唯安住说之　　何故而欣然
  其意慧永安　　寂然以柔和
  慈愍日增益　　消除众垢秽
  以智慧光明　　蠲去诸闇冥
  安住如莲花　　弃舍众狐疑
  如哀修道场　　奉行得自在
  口面演光明　　干竭众爱欲
  开化于众生　　令其眼清净
  安住消逆贼　　除去众瑕疵
  晓了生死无　　众生之性行
  以训觉所有　　诸天世间人
  一切普众会　　观大圣颜貌
  今所笑现义　　唯为分别说

佛告寂意菩萨。见密迹金刚力士乎。白曰。已见世尊。佛言。是密迹金刚力士。已当供养贤劫诸如来众。将护正经。受而持之。道利开益无量众生。从是没已。生阿閦佛土。在妙乐世以生彼土。其阿閦佛为诸菩萨。宣千八百印。皆当逮是。归于道义。往反周回。然后来世。见不可计无数如来。稽首自归净修梵行。然后来世。过此劫数积累德本。逮致无上正真之道。成最正觉以得至佛。号金刚步。出现于世。如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰普净。劫曰严净。又彼寂意。普净世界神妙丰炽安隐。五谷卒贱自然无价。众民滋盛天人甚多。合以七宝金银琉璃水精车磲马瑙珊瑚真珠。以成佛土城。有八交道平等若掌。其地柔软如天綩綖。如兜率天。被服食饮宫殿屋宅。园观浴池校露楼阁。其佛国土巍巍如是。诸天人民自然显发。如天妓乐。悬诸彩幡竖好幢盖。烧众名香。雨宝众花遍散其土。上虚空中罗列众盖。和雅妓乐。其佛国土无有恶趣三苦之毒。亦无八难不闲之处。所有诸业。如兜率天。被服饮食宫殿园观校露楼阁。等无有异。天人不别。诸天人民皆慕微妙。唯志佛道。又其佛土无有二乘。无有声闻缘觉之名。纯诸菩萨。其如来尊宣不退转菩萨大法。其金刚步世尊。诸菩萨众不可称计。无能限量。亿百千载。其佛国土无有恶姓疽嫉之行。无有毁戒堕邪见者。此国土人皆至究竟。好慕佛法。无有盲聋喑哑瘿瘇。性行和雅。悉二十八相庄严其身。又其如来现在世时。寿八小劫。其诸天人临欲寿终。如来至真常为讲法。演身光明。皆照三千大千世界。时诸天人蒙斯光明。悉决众疑。叹法随佛。各心念言。当往诣佛咨受经典。或以己身神足之力。往诣佛所。或有学人承佛圣旨往诣佛所。佛住虚空去地百千仞。在其世界。于四衢路周一大座。告于十方可悦一切诸来众会以如来辞。为诸菩萨敷演经道。唯宣大乘无极大道。其佛国土无有一人违逆世尊教。亦无诽谤骂詈毁辱者。一切众生诸根明利。其慧通达。土无君王。唯佛世尊以为法王。其土人民无有吾我。无受业处。悉无我所不主田宅。诸天人民。皆悉如是。其金刚步如来至真。所欲受食。以愍伤故。先宿晡时现佛身像。着衣持钵住其门前。其家则知便心念言。佛愍念我欲就我食。即夜庄严施设床座。清净布具。甘美供膳若干种味。明旦早往日时以到。佛与圣众往入其舍。饮食毕讫行澡水竟。佛为施家随时说经。其人逮得不退转法。当成无上正真道。已乃为说讫。佛从坐起还归精舍。若佛宴坐在于静室。时诸菩萨。各从本行所逮三昧。而自修已。如是寂意。其佛世界功勋快善。无量巍巍殊特如是。土地严净普平博好。快不可量。佛说是经法。授密迹金刚力士决时。应时会中二万人。皆发无上正真道意。诸来会者各各心念。愿生其土。佛即记说。金刚步。成佛道时。诸愿见者皆生彼土。其佛授决。亦皆当成无上正真之道。为最正觉。尔时密迹金刚力士。从佛闻斯所授决已。欢喜踊跃。以持金刚投之虚空适投空中。应时三千大千佛土六反震动。光照十方。天雨众华纷纷如雪。箜篌乐器不鼓自鸣。一切众会各在右手。自然有华香若干种品幢盖众饰。各执持行。于时密迹金刚力士。以宝花香幢盖缯幡。周匝绕佛。以偈叹曰

  广法普自在　　法藏不可尽
  晓了分别法　　导利益众生
  以付授我义　　常乐以法施
  极奉行正法　　住道愿自归
  智慧能清净　　明了所行业
  其名闻三世　　功勋度无极
  其智通三处　　能仁无所著
  以度众挂碍　　班宣快济厄
  清净犹月净　　颜貌甚鲜明
  斯曜极远照　　喻于日火光
  其音殊妙好　　和声喻梵天
  宣布于愍哀　　稽首众生宝
  自显现其身　　示有形寿命
  唯愿班宣法　　演布文字音
  虽讲说经法　　亦无有法想
  度脱于众生　　亦无有人想
  世尊所开化　　谁能报佛恩
  设一切众生　　积行无量劫
  唯启受佛教　　志不在余业
  己身能奉行　　复化他人众

于时密迹金刚力士。绕佛众会竟七匝已。手执众花及与宝盖。供上散佛。适供散佛。应时四天下一切方域。自然化生若干品花。庄严校饰八重交道。八味池水。承佛威神靡不周遍。巍巍难限。尔时寂意菩萨问密迹金刚力士。如来以授仁者道决答曰族姓子。以见授决所受道决。自然如梦。又问。仁者受决为何所逮。答曰族姓子。所受决者为无所逮。又问何所不逮。答曰。不逮吾我。不得人寿命。不得五阴六衰四大。不见现世度世之业。不逮诸罪及与不罪。无漏不漏。尘劳嗔恨。有为无为。生死无为。悉不逮是。此族姓子。乃曰受决。寂意又问。设无所逮谁为受决。答曰。无所逮者乃曰为逮。又问。若无吾我。谁为受决。谁授决者。答曰。其有受决及授决者。适俱平等本际无二。又问密迹。若无本际。彼谁受决。答曰。本际无生亦无所灭无有二际。以是本际今日受决。又问。住何本际而受决也。住于自然。无二本际。无我本际。无人寿命。住于自然。乃曰受决。又问。吾我本际住在何所。答曰如来所住。又问。无所识知。为何所知。答曰其所识知为无所知。又曰。若无所告语为无所语。又问。设无所语为何所教。答曰。教无所教。又问。何谓教无所教。答曰一切诸法悉无所教。又问。说无所教云何知之。答曰设无所教所知若斯。又问。云何教所知。答曰。不问所知。又问。云何不问所知。答曰。识无放逸。又问。何谓识无放逸。答曰。自归要谊。又问。何谓自归要谊。答曰。不见无谊。又问。何谓不见无谊。答曰不以于谊亦非无谊。乃曰为谊。又问。何谓不以于谊。亦非无谊乃曰谊乎。答曰。其不以谊亦非无谊。彼则进谊。又问。若以无谊不成法义乎。答曰。其法义者。云何义乎。所以者何。其趣义者则为非法。不成为法。又问。何谓为法。答曰。法无音响乃曰为法。又问。法无音响何谓为法。答曰。其于彼法无有文字。乃曰为法。其无所得。彼法无音。无有言词。又问密迹。何谓所逮。答曰族姓子。如所可逮。是乃名曰一切无逮。离于所得。又问密迹。是曰我所逮得如来。其习诸法乃能逮得。又问。岂能寂然吾我之心。一切所宣智慧之明。因其文字宣如来业。不以无逮。不以当逮。又问。其所逮者。何所不可。答曰。口之所说为不可也。又问。口之所说心倚文字。则为不可。又问。何谓为可。答曰。其无所逮。彼无所教。其无所教知则不自知。不知他人。其不自知不知他人。乃曰为可。又问。不可谁为是本。可谁为是本。答曰。所受是本。又问。所受谁是其本。答曰。所倚为本。又问。所倚谁是其本。答曰。虚伪妄想即是其本。又问。虚伪妄想谁是其本。答曰。虚伪妄想尘劳是本。又问。虚伪妄想尘劳何所是本。答曰。慕着是本。又问。慕着何所是本。答曰。色声香味细滑所著是本。又问。何所著本。答曰。恩爱结集是曰着本。于是诸着而无所慕。乃曰无著。是为寂意。诸恩爱结求于所著。永无所著。诸佛世尊为班宣法。重说是法。授密迹金刚力士决时。五百比丘众漏尽意解。二百菩萨得无所从生法忍

大宝积经卷第十二大宝积经卷第十三

        西晋三藏竺法护译

    密迹金刚力士会第三之六

于是密迹金刚力士。所愿已备得受佛决。所望已毕欣然大悦。叉手白佛言。唯佛大圣。就我旷野之界鬼王国土。在密迹宫舍。七日受请。诸菩萨等及大声闻。唯见垂愍。顾意不忽。当于佛所在。于旷野鬼王土地。在于鄙舍。垂意小食化鬼神众妖魅反足之物。揵沓和摩休勒。及余所居众生。见如来尊。听闻斯经法。长夜安隐无有众患。一定无难。便当弃捐嗔恚毒害。无怀逆心。其四天王一切眷属。游在旷野鬼神王界。若见如来。闻所说法。常获安和不遭危难。时佛默然。受密迹请七日供养。用愍念故。并欲开化无数众生使殖德本。尔时密迹见佛默然以受其请。欢喜踊跃稽首佛足右绕三匝。礼退而去忽然不现。还旷野国因归其宫。时密迹力士心自念言。当为大圣庄严宫殿。欲行天人。色行天人。得未曾有。十方世界诸菩萨等。皆当欢喜。心自念言。吾忆识念。往故一时夜怀志愿。所尊道法不可思议。今亦当然。即时三昧正受。宣不可限。彼时高座无央数亿百千兆载师子众座自然普现。以宝作脚及奇珍栏楯。以百千天衣而布其上。清净妙华真珠璎珞。在八交道。以宝莲华覆盖其上。适三昧正受。东方去是恒河沙佛国。有世界名无量宝德净。佛号净王。当致彼净王如来所。庄严净师子之座。欲授万菩萨决。其佛国土所见严净。越无央数诸天人民所有严净。我今宁可往彼佛土庄严高座。尔时密迹力士。以净宝王三昧正受。适三昧已自然庄严现好高座。高广好净。如无量宝德净佛土师子高座。等无有异。忽然以至在于旷野鬼神界土。所施高座巍巍如是。甚高广长东西二千四百八十里。南北千二百八十里。绀琉璃水精砗磲为地。吉祥藏宝无量名香杂香熏之。竖立无数众宝香炉烧殊妙香。散诸天花若干品物。极好巍巍光色暐晔。可悦人心安和其身。从心应时。行菩萨法不失其节。功勋无际。所叹妙德而无崖底。又其高座所化自然。有亿百千垓不可计数诸师子座。以宝为脚。宝为栏楯。无数天衣而布其上。诸宝莲华净珠校露。立八交道。以用众宝而布其上。建在地上一切普具。于时密迹力士。如是比像不可思议。设诸高座高广严净。殊特无量师子之座。安然庠序从三昧起。即于宿夜。设若干种甘膳饮食。尊奉菩萨。和调性行。兴发如来报应之果。众供已办。夜未向明告四天王。诸人当知。世尊今日诣我宫食。请竟七日。诸菩萨众及诸声闻。皆当来集。仁等恭恪设无放逸。大圣难遇亿世时有。咸皆一心。舍俗慕道恭恪奉事。除去生死弘慈至道。时亦难遭法不可闻。三界无怙唯道可恃。普如虚空无所复碍。勿怀乱心为放逸行。眷属徒使妻子仆从。供养七日勿倚身心。唯道为本。莫顺他业损违道教。专精一心供养如来。常当下意加敬无二。令其旷野鬼神之处。王者土地鬼神妖魅。反足诸鬼揵沓和等。皆归命佛密议道法。其四天王及余众生。皆不失时普蒙济度。诸仁当了。已请天尊。稽首归命供养佛已。勤听经典宣布八方。使一切蒙乃报佛恩。尔时密迹力士。有一太子名曰密兵。而告之曰。汝往遍。令地神及虚空神。告四天王忉利天。焰天兜率天无憍慢天。他化自在天。上至魔天。各令使知世尊。今日在于旷野鬼王土界。受密迹金刚力士请于宫舍。当就饮食。菩萨声闻亦复同然。若欲见佛听闻道教咸皆往至。太子金刚兵受教宣命。须臾令遍。其第二子名曰善分。而告之曰。子汝今自往。己力神足。告诸梵天。梵迦夷天。梵满天。梵度着天。大梵天。有光天。少光天。无量光天。光音天。清净天。少净天。无量净天。净难逮天。净离秽天。顺行天。少顺行天。无量行天。行果实天。亦然天。于是天。善愿天。善现天。至一善天。悉遍令之。今日世尊游于旷野鬼王国土密迹金刚力士宫舍就请。诸人欲见悉共往会善分。受教宣令。如是须臾之顷。欲行天。色行天人。皆共集会在于虚空。广纵四万里上下俱然。亦四万里周遍诸天。各次第坐。于是密迹金刚力士。庄严场地。供膳办已。叉手向佛所在遥启白言。今时已到。愿佛大圣垂光回意。而说颂曰

  丈夫尊雄屈　　人中上愿顾
  莲花正士发　　大圣人时到
  两足尊在神　　天人圣祠祀
  人中尊屈意　　圣明时以至
  戒如莲华盛　　精进转增长
  覆护上惭愧　　最胜唯顾意
  建立于圣谛　　慈哀加弘恩
  无我无所施　　最胜师子愿
  戒行博闻业　　茂盛觉意花
  解脱具足实　　殊胜树愿来
  功勋海唯在　　其意深且广
  清水定为意　　炽盛精进业
  奉哀道场业　　智慧璎珞严
  明本慧开觉　　圣达降怨顾
  第一明无动　　以药树疗病
  学不学盛明　　最胜唯屈神

于是世尊。见密迹金刚力士白时已到。告诸比丘。皆早严服着衣持钵。并敕护寺。密迹金刚力士来启时到。各自建行七日就请。其诸声闻众菩萨等。若得神足。以己神力往追侍佛。其无神足。入如来光承其威明。佛愍念之皆得往就。于时世尊。适发进路。诸菩萨皆于前而导。诸声闻众在后侍从。诸天龙神。花香妓乐在虚空侍。诸天玉女而嗟叹佛。因说颂曰

  欢喜发光明　　妓乐自然鸣
  震动佛刹土　　天雨于众花
  佛之大威德　　神足度无极
  圣变化无限　　娱乐佛无底
  佛吉祥无际　　佛神圣无量
  佛威仪无底　　佛功勋无限
  游灵鹫之山　　在于八山中
  于上虚空中　　无碍如鹰王

于时欲行天人。色行天人。见佛世尊从虚空来。犹如日光现于水中。如月盛满众星独明。犹若天帝诸天中尊。若如梵王照乎众会。见是变化大悦欣然。雨天青红黄白若干诸杂莲华。供养散佛。意花大意花。柔软花。大柔软花。昼夜树花。有果大实。及诸转轮王离垢之华。百叶千叶。又百千叶。乐欢喜生。味兴起光照一切香华。善妙香常熏香。乌虚延香。常有花乐。眼目乐。如是众花兴云致雨。雨众杂香鼓天妙乐。诸天玉女眷属百千。尔时须臾至于旷野鬼王国土。毗沙门天王界。在其宫殿。一切声闻诸菩萨众眷属围绕。佛适下住。地大震动。光照十方。安和柔软不娆众生。时四天王见佛世尊到大旷野鬼王之国。速疾速疾与其宫人及诸眷属。花香杂香泽香缯彩幢盖妓乐。行列吹贝。各持此供。往诣佛所。稽首佛足绕佛三匝。却住一面。以持所赍供养佛上。见佛大悦心中欣然。供散佛已却住一面。叉手自归。尔时世尊因四天王。应病随时班宣经法。万三千鬼神妖魅厌鬼之属。皆发无上正真道意。一万玉女亦复发是无上大意。时密迹力士与宫人婇女诸子眷属。花香杂香捣香幢盖妓乐。从其宫中。诣毗沙门天王宫舍。至世尊所。稽首佛足右绕七匝。各从所执皆供散佛上。毗沙门天王宫中次第而坐。鼓众妓乐。自入清净心无所著。所将侍从各自就座。如来高座独显巍巍清净妙极。密迹诸子。举所庄严校露之帐师子高座。从虚空下安着于地。寂然不动。诸菩萨众及诸声闻。故坐本位。时欲行天人。色行天人。睹其设座高广严好。得未曾有。怪之难及。心自念言。密迹力士何所得睹。斯宝高广师子之座。玄妙无极殊特难喻。于时承佛威神。于虚空中自然闻音。仁欲知者。东方去是界分。过江河沙诸佛国土。有世界。名为限净。佛号净王如来至真等正觉。密迹金刚力士。曾见其土微妙严净。今以法故。遣此殊妙巍巍高座。时佛适入上处师子高广之座。应时旷野鬼王国土鬼神妖魅反足之鬼。揵沓和。迦楼罗。真陀罗。摩休勒。往诣佛所稽首足下。退住一面。叉手归佛。尔时密迹金刚力士。语四天王及诸来会诸贤。屈意咸共和心。饮食已办各手斟酌。勤供养佛菩萨圣众。所以者何。如佛所说。若能欢悦佐助兴功。供养蒙祐得福无量。于本施主其福不减。诸仁者等。以是劝助佐其所施。得受功祚不可限量。于是密迹金刚力士。与其宫人婇女一切诸子及诸眷属。手自斟酌百种肴膳不可计味。心佐开士求如来福。供养大圣加谦恪心。佛及菩萨诸声闻众。皆悉充满饮食毕讫。行澡水竟。密迹金刚力士更取小床。于佛前坐白世尊曰。唯加弘慈应时演法。宣入法门使众生类了于道心。行所从生其未发心。兴斯道心。已发道心至不退转。令此鬼神妖魅揵沓和等。长夜永安使无众患。多所安和多所愍伤。诸天及人三界众生。得殊特愿。与世超殊。尔时世尊告密迹金刚力士及诸大会。谛听谛听善思念之。若族姓子族姓女。行入法门。坚住于斯。至殊特愿。无所分别。不至损耗。密迹力士与诸大众。受教而听。佛告密迹力士。若族姓子及族姓女。当奉笃信善从道法。多诸顺宜。欲见贤圣乐听于法。心不悭嫉不缩财业。舒手布施舍俗所习。好所施福不望其报。心不怀害。其志清净专精一心。而不暴乱。信报应果好善真业。不以狐疑未曾犹豫。睹清白理。知不亡果。宁失身命不犯非义。仁慈不杀。不与不取。不为邪淫不犯妄言两舌恶口绮语嫉妒恚痴。不犯十恶身行十善。亦劝人行。常奉等信。见诸沙门奉戒具法。勤精修行志存思道。常应义节。寂然调和心存惔怕。受无所著不受邪语。志性仁慈弃捐恶法。行不卒暴。明如炬火。不愚如兽。言无所毁。心性平和绝却睡眠。弃唐突心捐其重檐。数数惠施。见诸善友一切诸佛及佛弟子。常行恭恪。如是比像。常追侍从沙门梵志。谦下作礼。习与相随不失其意。常奉斯等诸善知识。以爱乐故。加用法施救济危厄。以班宣法而劝化人。演所报应施致大富。持戒生天博闻大智。修行合道各为说报布施大财。悭贪饿鬼。持戒忍辱精进一心智慧。稍入道元。犯戒地狱。嗔恚丑陋。懈怠废道。乱意堕罪。愚痴投冥。是为由身由言由意恶行之报。是身口意善恶之果。犯是三事长夜不安。投于地狱饿鬼畜生。护斯三业。生天人间十方佛前。长夜永安无有众患。各为开示罪福之报善恶所趣。若见应器。为演深法。空无相愿行无所行。至无所至。无我无人无寿无命。分别幽奥十二缘起。若倚是事便有生矣。若不倚是则无有生。从是致是。不从不致。从无明致行。从行致识。从识致名色。从名色致六入。从六入致更。从更致痛。从痛致爱。从爱致取。从取致有。从有致生。从生致老死。从老死合大苦阴。成四大身。痴灭无行。行灭无识。识灭无名色。名色灭无六入。六入灭无更。更灭无痛痛灭无爱。爱灭无取。取灭无有。有灭无生。生灭无老病死大苦阴合。不受四大。则常永安长无众患。以灭尽者则无所有。所以者何。起是生是无是则无。犹如种树始生芽根茎节枝叶花实。拔树无芽。何从有是茎节枝叶花实。解无无明心无所著。则无牵连。十二缘起。皆从缘对。无缘无对。一切三界皆悉本无。悉从无生。从有而死。不达无故。谓有致生。不知有空。倚是我故便致死矣。解无不生。了有不死。为罪所追尘劳所逮。颠倒苦恼痴冥不实。为宣真谛应其仪节。所观如法。而于诸法无所造作。不得所造则不有退。亦不无退。不有往来周旋之难。假使意法意无所著。信受本空。一切诸本悉净惔怕置是人者。若菩萨大士常得见佛。未曾远离。不失闻法。不违圣众。在在所生常见诸佛。虽有所生。不生无佛之土。生以见佛行无放逸。慕求真正精进之法。勤修此已不用家业。善奉净行。不用妻子男女奴婢仆使。守护宅舍速疾持法。无以戏逸自恣爱欲。诸佛世尊所施言教。以笃信故舍家为道。信舍家已。为善亲友真正伴侣。以受真业。性行微妙闻玄妙法。以行为要。不归严饰。觉意第一而不厌足。求于博闻。如所闻法广为人说。无冀养心。不以己言有所依仰。讲说经典从所闻慧。因其行住而为人说。使听法者兴隆大慈。而于众生发无尽哀。以致博闻无所爱吝。不贪身命。少欲少求而知止足。以善重业至快供养。好乐闲居专精守节。从所闻法观其义趣。自归正义思惟奉行。不归严饰。其所导御天上世间。不但为己。而有所行。为众生故求上大乘。至慕佛道自在之乘。成无放逸。何谓无放逸。以达境界。眼不见色。不受妄想。不著文饰了色之难。虽以慕乐便舍之逝。晓之本无若耳闻声。鼻香众想。舌嗜美味。身更心法亦复如是。所言无逸。己心无生。护他人心。弃爱欲乐入于法乐。不行欲想无嗔恚想及危害想。无贪嗔恚愚痴之业。无是恶本。身不行恶。口不说非。心不行秽。不为反念。不犯一切诸不善法。是曰无放逸。以无放逸常应节行。晓了有无知无无有。彼何谓有何谓无行平等者有贤圣脱。修邪行者无贤圣脱。又次亦有罪福之报。或有无罪福之报。或有眼。或无眼。或耳鼻舌身。或有意。或无意。又能了色无常苦空别离之法。是谓名有。志学于道。计色有常。长存永立无别离法。以无平等住。有是念故。有痛想行识。有了无常苦空别离之法。又从无明缘。便生不善。若无无明。则无有行。从生缘故。有老病死。若无生缘。便无老病死。施致大福。贫无放舍。穷有贪嫉。悭无大财。奉法至道。不顺义则。不至道业。精进菩萨得至大慧。懈怠菩萨不得至道。不自大者真得异决。其贡高者不至灭度。若普入寂至于空无。计吾我人。贪身寿命。不至道慧。是为人者。应顺时仪。佛言。若族姓子族姓女。修普明智。或致所知。若在于世。若无于世。普智计斯。不有所知。彼有天食而无所著。若无天食亦无所著。一切如来皆以敷演。入于顺义一切诸法。如来明证下四法故。何谓为四。一曰一切万物皆归无常。二曰一切诸有悉为苦毒。三曰一切诸法皆无有我。四曰一切有形悉至于空无。为泥洹寂。所以言曰。一切万物皆归无常。众生愚惑自想有常。如来说法断诸计常。一切所有悉为苦毒。众生闇塞计想有乐。故为说法断除诸乐。一切诸法皆无有我。而众生心计有吾我。故为说法断诸我想。一切有形悉归于空。众生沉冥反想悉有。故为说法断有着想。寂然泥洹。一切众生怀自大者。如来说法。使自大者不复贡高。捐去倚着。以闻无常。解音悉空。尔乃晓了无常之义。其义何谓。都不生不增不起不灭。是乃名曰入永无常以闻苦音。入际所愿五阴空无所起。是名曰苦义。以闻诸法皆无我音。奉空脱门。于我不我无是二相是非我义以闻泥洹寂志造无想。不然不灭为都灭定。无终始是乃名曰解了空义。不以无想而为取证。如是贤者。若有菩萨。能行是者。未曾违失一切诸行道品之法。以无想行。普周备悉诸佛道法三十七品。于时世尊。在密迹金刚力士宫殿。应病演法。寻时彼会。二万天人皆发无上正真道意。不可计人悉受五戒。尔时四天王前白佛言。唯哀愍说。我等云何护于世间。佛告四天王。仁等宜以当行十法。护世众生。何谓为十。一曰不害一切命类。二曰不窃取他财宝。三曰不犯他人妻室。四曰不两舌斗乱于人。五曰不妄言欺诈于人。六曰不恶口以辞伤人。七曰一切所说未曾绮饰。八曰不怀嫉妒生彼此心。九曰在于善恶业不发嗔恚。十曰常修正见不随邪疑。是为十。诸仁者等。以是十事护于世间。乃应法教。佛复告四天王。又诸仁者。复有八法。护于天下。何谓为八。一曰言行相应未曾相违。二曰奉敬尊长不怀轻慢。三曰言辞柔软不宣粗犷。四曰谦下恭顺常执逊意。五曰常行质朴不为谀谄。六曰常修仁和而无佞饰。七曰一切诸恶悉无所犯。八曰以诸德本将顺世间。是为八。佛告四天王。复有六事。护于天下。何谓为六。一曰身常行慈不害众生。二曰口宣仁慈不演恶言。三曰意念慈心不抱增损。四曰以得利养等御于业。五曰等护禁戒而无所犯。六者等以正见开导曲戾。是为六。佛告四天王。复有四事。常为法首护于世间。何谓为四。一曰有所立行未曾贪嫉。二曰不怀嗔恚加害于人。三曰不用愚冥蔽加不逮。四曰所行至处不怀恐惧。是为四事。佛告四天王。复有二事。以用护法世间人民。何谓为二。一曰惭耻从无数劫不应道法。二曰怀愧自责不深入法救护一切。是为二。佛言诸仁。当行是法以护天下。以能建立如是法行。乃能护世间。尔时密迹金刚力士。以宝挍露用贡覆佛。复白佛言。菩萨云何无嗔恚法。至于无上正真之道。佛言族姓子。菩萨有十事。行无嗔恚法。至无上正真之道。何谓为十。一曰常行慈心不犯伤害。二曰不厌众难常修大哀。三曰所作事业常勤精进而有殊特。四曰常奉空行逮致三昧。五曰从因缘发入于智慧。六曰以权方便普入一切。七曰解达三世净过去来今。八曰以真谛见无所挂碍。九曰遵奉道业入一切法。十曰一切诸法皆悉归空。是为十。密迹金刚力士复白佛言。菩萨有几法。闻佛不可思议法。不以恐惧。佛言族姓子。菩萨有八法。闻佛不可思议。心无恐惧。何谓为八。一曰所造功德常能究竟。二曰一心禅思畅达不乱。三曰以为善友而见将顺。四曰心常笃信乐微妙法。五曰以解诸法悉如幻化。六曰晓一切法不可思议。七曰而了诸法不可成就犹入虚空。八曰畅一切法狂惑放逸虚伪之相。是为八。密迹金刚力士复白佛言。何谓菩萨而得自在。于一切业开士之法。佛言。菩萨有四事法而得自在。何谓为四。一曰遵行如幻三昧畅一切法。入五神通而特超越。二曰以三脱门过于四禅。三曰以智度无极修四梵行。四曰行权方便具六度无极。是为四。密迹金刚力士复白佛言。菩萨有几法入于法门。佛言族姓子。菩萨有四事法。入于法门。何谓为四。一曰入禅思门。具足晓了一切众生根本。二曰入智慧门。分别一切章句义理。为众敷演。三曰入总持门。一切所执常念不忘。四曰入辩才门。因能可悦诸众生心是为四。密迹金刚力士复白佛言。菩萨为有几力致开士行。又斯道力。无能当者降伏众魔。佛言族姓子。菩萨有八力。莫能当者降伏众魔。何谓为八。一曰道心之力性行清净。二曰精进行力而不退转。三曰博闻行力奉无极慧。四曰忍辱行力护众生故。五曰无所生力不怀嗔恚。六曰不虚妄力具足解脱。七曰修道行力备悉智慧。八曰以大哀力开化众生是为八。佛说是法时。密迹金刚力士及五百子。悉逮得无所从生法忍。以得法忍。前白佛言。唯愿大圣。以是八法经典之要。使流天下。用愍我等。是密迹宫使自然广。以是德本光明普照。如来灭已。令遍流布而不没尽。于时世尊。睹密迹诸子等心中所念劝助启佛。佛告密迹金刚力士。密迹堪任斯诸章句。我诣佛树下。汝于彼时与诸菩萨。魔将兵来。卿以威势。至拥护我故降魔兵。即时想念讽诵通利。今复当护将来末世令法流布。遍阎浮利周于十方。令所施教使法久存。持制一切诸外异学。于时密迹金刚力士。观佛世尊以见劝告。即从座起长跪叉手。应时于是言辞章句。用宣咒曰

醯黎　休留休留　其强飙聚　各罗眼动摇归救　忍力力尽　寂怕作角鸱伊犁佉丘佉犁佉犁　护无择　住胜生往还无曲以慈受之调和成　施持已

诸天龙告鬼神揵沓和妖魅若人非人。常吉安隐。动于山王。亦震天地。亦扰水王。用说此咒故。摄伏外道法君所救。晃曜法炎。笃信是句。闻此咒已。诸天众各各举声而叹曰

  正法住甚久　　动三千佛土
  一切众会同　　自投人王前
  归命使无罪　　施此无恐难
  其持是言教　　令正法永存

尔时世尊。从旷野鬼王土密迹金刚力士宫。受供七日。开化无数众生。七日之中。忽没旷野宫踊在虚空。与诸菩萨及声闻众。一切诸天于上普共供养佛及圣众。诸玉女众咸共咨嗟演大光明。诸天人伎百种自鸣。空中雨华。佛土大动显佛大变。佛没密迹力士宫殿。犹凤凰王还住灵鹫山。佛在灵鹫山。与比丘众俱。及诸菩萨眷属周旋。各思道教

尔时王阿阇世出罗阅只大城。与笃信慕乐长者梵志俱。一国人民闻佛还国。各集晡时亦出其城。往诣灵鹫山到佛所。稽首佛足右绕七匝。却住一面。王前白佛。我曾立坐有所参议。时诸比丘到太子所。口自宣言。今日世尊往到旷野鬼王土界。诣密迹金刚力士舍食。唯然世尊。我得闻是怪之难及至未曾有。诸佛世尊不可思议。乃能大哀垂愍众生如来行慈普济众生。犹如虚空言无偏独。用一切故。往到旷野鬼王土界。就密迹金刚力士舍食。佛大弘志至不可喻。无辞可尽。若有得蒙如来讲法。宣传道训决疑之律。靡不得安。又复世尊。其密迹力士。为有几事在于平等。而逮正觉最为至重。殖众德本。乃能有是妙大辩才。佛言大王。是事究竟而不可逮。其至德本无能过上。王白佛言。实为至真。种其德本故获此果。若有信者。其功德云何。佛言大王。假使十方各如江河沙数。一一沙尚可知限。密迹金刚力士所见诸佛不可计数。尽其崖际供养奉事。缘是行故合积大辩。当作是观。皆有本末

佛告王曰。乃往过去无央数劫不可限量。尔时有佛。号曰息意如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰选主。劫名不移。其息意佛纯化一切诸菩萨众。皆令精进。言作菩萨法无懈怠。心无厌倦。弃身寿命不以为吝。唯志道法。时有菩萨。名曰勇力。即从座起。往诣息意佛所。稽首足下前白佛言。如大圣宣我承解议。若有菩萨心自念言。我等疾逮无上正真之道为最正觉。念是菩萨。名曰懈怠。所以者何。若菩萨不用精进。厌患生死。不与此心成佛大道。若有菩萨。见生死难则见缚结。不至灭度唯化众生。乃成正觉。所以者何。唯然世尊。菩萨之法普行勤修。在在生死常所在处。开导利益无量众生。悉令灭度。亦无所教。是故世尊。菩萨作行。宜重生死不敬灭度。菩萨造行重生死已。奉无限佛。导利开化无量众生。闻无数法。入众生念。所行志性敬泥洹行。重于众观。便自堕落没在小节。若有菩萨畏于生死而怀恐难。乐泥洹行。当作是观。如是菩萨则为堕落。以无行堕失如来行。于诸众生则有衅咎。何谓菩萨而不顺行。乐于声闻缘觉地者。自观其行欲化众生。是故名曰无开士行。其行声闻无菩萨行。所以者何。诸声闻行畏生死苦。菩萨游于无量生死。不以为拘。时息意如来赞勇力菩萨曰。善哉善哉正士。仁快说此教言淳淑。菩萨行道舍身之安不舍他人。常省己身不求他漏。又问。何谓菩萨所行。佛言族姓子。自正己行而为众生。宣成败事生死之难。受于无量生死之患。而无恐畏。不乐声闻缘觉之地。习菩萨行。不近禅思在于三界。晓了禅定。分别恶趣。习乎方便尽了禅智。功德圣慧而不可尽。发无生慧为人班宣。一切本无慧无所生知其所受。了诸众生而无吾我。以慧开化一切众生。晓诸法寂解护诸法。畅诸佛土了于一切。自然虚空佛国清净。其慧鲜明。以慧圣达一切法无。增益相好入于庄严。慧无所行因其奉遵。一切德本未曾忘舍。少恼鲜事。有为众生所可造作。常行拔难身心惔怕。积功累法无所秽厌。兴发法思晓了长寂。正定一心方便觉达深妙之禅。若以宣布若干品教。分别诸观护于德果。开化声闻缘觉之律。爱乐如来所解脱业。降菩萨行。示现如来所行之本。是为族姓子如来所行之业。王当知之。尔时勇力菩萨。于彼如来所。闻说是法所行清净。复白彼佛。甚难世尊。至未曾有。于今如来至真之言。宣斯菩萨之所应行。又复世尊。如佛所说。我察解议善权方便。是诸菩萨一切诸法。由己所行。犹如世尊察于虚空含受一切。十方万物为一切色显现己体不可称计。现苞一切有形之类虚空行业已无所碍。如是世尊。善权方便。是诸菩萨。在一切法而得自在。诸学之法。及未学法。凡夫之法。最正觉法。皆悉由之。犹如世尊若火所遇草木百谷靡不被烧。菩萨如是于一切法自在所行。以智慧炎烧诸愚冥。三界无烟。犹如世尊大怒丈夫嗔恚炽盛。逆害他人无所顾难。菩萨如是。以权方便自在由己。智度无极。断除一切众生尘劳。犹如世尊清水宝珠着浊水中寻时清彻。菩萨如是。以权方便消一切尘三垢秽浊犹如世尊有大威药名曰消。除若着毒中消一切毒永无有余。菩萨如是。以权方便。游于一切三界之难。执权智业。灭去众生尘劳爱欲。以是之故。世尊当作斯观善权方便。是诸菩萨一切诸法自在己行。如是大王。勇力菩萨说是语时。不可计人。皆发无上正真道意。王欲知之。尔时勇力菩萨。岂异人乎。莫造斯观所以者何。则今密迹金刚力士身是也。此正士身坚强精进。被弘誓德无极大铠。巍巍如是。供养诸佛不可称限。光光若斯无以为喻。尔时阿阇世王。心自念言。是密迹金刚力士。所执金刚为重几所。以承大力谓应执持乎。时密迹金刚力士知王阿阇世心之所念。以持金刚下着地上。适置地上三千大千世界六反震动。密迹金刚力士谓王阿阇世。王试举此。时阿阇世王以大力士力。尽势举之。而不能摇离地如毛发。时王怪之得未曾有。前白佛言。我身世尊有大力士被极异铠。牵捉大象。举鼻投身在所无碍。今日举此小金刚杵。不能动移大如毛发。时王阿阇世益用怀疑。何故世尊。乃如是乎。佛言。大王是金刚者。入在重德。不可用被铠力及象力而举移此也。尔时密迹谓天帝释。仁者名号执持金刚拘翼。今日仁者。且从地举此金刚杵。时天帝释以无限神力。极阐神足欲举其金刚了不能举。尔时天帝释前白佛言。吾等之身及诸天俱。与阿须轮斗。以一手指。举维质阿须轮所在。投之如一圆丸。皆令犇驰不知所凑。又是金刚其形小小。而不能动乎。佛言拘翼。是金刚者。入在重德。不可以比阿须轮三百三十六万里身在所可投。于拘翼心所知云何。须弥山王为重不乎。白言甚重世尊。不可计喻。佛言拘翼。假有勇士大神无极。取是金刚右手执持。以是金刚着须弥山边。藏之在中。才现形取。俱举二形。须弥山王尚复微轻。不如金刚重。若天帝释。密迹金刚力士以是金刚。击铁围山大铁围山及金刚山。令碎如尘。虽尔正士。未尽现力。不可喻极

大宝积经卷第十三大宝积经卷第十四

        西晋三藏竺法护译

    密迹金刚力士会第三之七

尔时密迹金刚力士。谓贤者大目揵连。耆年目连。世尊所叹神足第一。仁且从地举是金刚。时大目连前举金刚。以无极力。以四大海水上沃日。其势又牵曾到野马世界。无所不至。道力显变。奋其神足而欲移之。此三千大千世界震动上下。而不能摇金刚大如毛发

时大目连怪未曾有。投佛足下。白世尊曰。唯愿大圣。叹我于声闻中神足第一。自试神足。动是三千大千世界。如挑小钵举掷他方佛土。我身开化降伏难头和难龙王。能食大[木*圂]如须弥山。不能动是小金刚乎。发意之顷捉牵日月。使止不行以手摩之。不能动是小金刚杵大如毛发。有何意也。将无我身失神足力也。佛言目连。不失神足。又目揵连。菩萨神足威力所感。一切声闻及与缘觉所不能逮也。假使恒河沙等诸佛世界诸须弥山。合成一须弥。尚可震动。不可动是金刚杵也。菩萨威神所建立行。不可思议巍巍如是

尔时贤者大目揵连。得未曾有。口自宣言难及。大圣。菩萨大士威力所致。是密迹金刚力士承于金刚杵乎。又此密迹今所有力。父母遗体之力也为神足力乎。佛言。父母遗体之力也。假使菩萨行神足力普能示现。悉达天上世间。佛告密迹金刚力士言。卿自举是金刚。于时密迹动三千大千世界。以己右手举取金刚。投于虚空。在于虚空七反回旋。还立密迹力士右手而住。彼时诸来一切众会得未曾有。咸悉叉手自归礼之。异口同音各自说言。难及难及。密迹金刚力士。其力甚妙乃如是乎。使诸众生得斯大力无穷之势也。于是王阿阇世前白佛言。菩萨有几法行。逮如是力无极之势。佛言。菩萨有十大法。逮如是象无极大力。何谓为十。一曰宁弃身命勤受正法二曰未曾自大谦恪下意礼敬众生。三曰见于刚强难化众生立之忍辱。四曰见饥馑人以好美膳而充施之。五曰睹诸恐惧劝慰安之。六曰若有众生得于重疾疗以良药。七曰若有羸劣人所轻慢。敬念恋之令无忽易者八曰以净泥水涂如来庙补其亏缺。九曰见孤苦人贫匮困厄常负重檐。使去其难极重之殃。十曰若有无护无所归依常将济之。所语如言而不变失。是为十事法。王复问佛言。菩萨仁和为有几法。往反周旋常存和雅不兴粗心。佛言。菩萨仁和有八事法。何谓为八。一曰志性质直而无谀谄。二曰性行和雅常无佞伪。三曰心存淳熟永无虚妄。四曰心行坚要亦无羸劣。五曰无迷惑志存于仁和。六曰为世众祐受异德行。七曰心行了达而无所著。八曰思惟罪福心无所念。是为八事。佛言。复有四事法。志性淳熟往来周旋。何谓为四。一曰在于人间为转轮圣王。逮见诸佛兴不舍道心。二曰在于天上作天帝释诸天中天。常见诸佛不违经道。三曰若在梵天王而得自在。殖于道业不坏道心。四曰而常生在清净佛土。面见诸佛世尊说法。是为四事。王阿阇世复问佛言。何谓信坐。佛言。大王。善友所坐。又复问佛。施何所坐。佛言。大王。布施处在。大富饶财多宝。其持戒者得生天上。坐其忍辱者。面色净悦常得端正。其精进者。勤修通达与众超异。其禅思者。常得寂定诸根不乱。其智慧者。断诸尘劳众垢之患。其博闻者。得生大智。若每事问决众狐疑。令无余结。其勤学者。合集入道无上正真。其察无常无我寂然。所存坐处消除颠倒是为信坐。又问顺时之念。为何所坐。佛言。大王。观无常苦寂。坐在正见。不随邪业身心清净。坐在禅思。兴发神通。又问。道在何所。答曰。存坐无脱。成于道果无三界难。又问。无脱坐在何所。答曰。其无脱者。坐在解脱生死众患。又问。佛兴何坐。答曰。坐在所习三十七道品之法。无所破坏。转于法轮。而不断绝三宝之教。又问。谁兴佛乎。答曰。大王。能兴笃信了本无者也。又问。谁兴笃信乎。答曰。若有能发菩萨心者也。又问。谁发菩萨心乎。答曰。其有志性定不乱者也。又问。谁有志性定不乱乎。答曰。其行大哀未曾绝者也。又问。谁不绝大哀乎。答曰。其不弃舍一切众生者也。又问。谁不舍众生乎。答曰。其安己身并安一切者也。又问。谁安己身并及一切众生乎。答曰。其兴隆道不断三宝者也。又问。谁不断三宝乎。答曰。弃于尘劳乃不断三宝也。王阿阇世前白佛言。至未曾有世尊。如来班宣入于法律。如来布教所可宣法。至于柔顺。弃乎断灭有常之业。而不忘失报应之果。入于所造立行无所乱。无善不恶。净不净业。勤修果实无所违失。唯然世尊。谁入是愿决众狐疑。顺于如来正真法教。谁闻是法而发犹豫。唯有宿世不殖德本者也。随于恶友。不信诽谤。我等世尊。前世宿命曾殖德本。非无功福。吾今蒙听所闻正法。欲报恩养至意不能。诸佛世尊文殊师利慈德。乃为我等决众狐疑。显大光明。世尊善言具悉梵行。至善亲友。得大人慈。上友党故

于是寂意菩萨前问密迹金刚力士曰。仁以为建立是经法。于将来世流布一切。答曰。建立是经典要。最于末世如来灭度之后。普布天下阎浮利地。令诸法师正士之等靡不蒙耀。密迹复曰。今族姓子。佛以建立是经典要。诸佛皆护。所以者何。其能护者则善学法。不生文字言辞不尽。无能中断。又族姓子。如来至真不废诸法。所以者何。彼无所生。其无所生则无所坏。以是之故。如来言曰。如来兴出为无所生。如来所住立于法界。法住如法。有佛无佛。佛法常住如故。以如是住。十二缘起为不错勃。不乱缘起。不乱正法。又察其法常无言说。故曰正法以无言说。寂意问曰。密迹。其护正法被弘誓铠。以是被铠。又问寂意。被弘誓铠将护正法。不乱诸法。不以是法。所以者何。是正法者。一切诸法悉无所乱。彼护正法。又问。何谓乱于正法。答曰。依倚恐畏为成迷乱。又族姓子。究竟无乱。谓义乱。尔乃名曰将护正法。又问密迹金刚力士。宁有方便。一切世乱因护正法乎。曰族姓子。因乱将护。所以者何。其以因世。倚于邪疑六十二见故。菩萨所行以空为本。是故与世一切为乱。又族姓子。其世俗者。以诸计有常。立倚吾我以为净安。菩萨常了无常苦空非身之法。是故名曰与世共诤随世没流。菩萨方便逆流尽源。反生死流现在重世。菩萨敬重积功累德。以是之故与世诤乱。世人依倚阴衰诸入十八诸种。行菩萨业心无所著。是故与世而诤乱矣。所以者何。不同尘故。以故寂意。菩萨将护一切正法。便与世诤。又问密迹。行者云何护于正法乎。答曰。族姓子。以受正法而护己身。亦护众生人寿命形。护一切法为无所护。又问。云何受之。答曰寂然吾我。众生惔怕。众生已寂三世便默。三世已默佛法便默。佛法已默佛土便寂。佛土已寂诸法便寂。其于诸法无所归趣。是则名曰将护正法。尔时世尊。叹密迹金刚力士曰。善哉善哉。是则名曰将护正法。其护诸法。为无所护。无所忘失。又护正法者。斯受一切。于一切想而无妄想。已无有想。于诸妄想无行放逸。是则名曰于诸一切法而无放逸。乃名道法

尔时会中有一天子。名曰贤王。前白佛言。唯然世尊。诸佛言辞甚为寂然。其见者何所是也。佛言。言辞正教寂然之义。一切所乐行寂然耳。彼以加忍。已能加忍故能然炽。已能然炽故曰晃曜。已能晃曜故曰寂然成为惔怕。则是如来将护正法。是乃名曰诸如来众总持。佛道所持如是。若不持法。又不舍法。宣如是行。说如是证答贤王天子时。具足千比丘漏尽意解。千天子远尘离垢诸法眼生。于时寂意菩萨谓贤王天子言。从何所得此辩才也。天子答曰。若能断除一切挂碍。悉无所得。得第一义者。因无所倚。是曰辩才。自了解之。神识不转。不经他识。亦无所立。乃曰辩才。其意不逸。游在所著。若能奉行无所著法。乃逮此辩。若以思惟一切诸法。往反示现皆当知之。神识信休乃逮辩才。是族姓子。如是行者逮致辩才。其无所住无有应行。度于流波四渎之难。其无所生无所起者。亦无所灭。无能灭者乃曰为度逮辩才耳

尔时寂意菩萨前白佛言。是贤王菩萨。从何所来至于此土乎。乃有斯辩。佛言。从阿閦佛土而来。没彼生此妙乐世界。举欲得见闻如来秘要所演经典。寂意当知。是贤王天子逮入法室总持其心。若一劫若复过一劫宣其功德。而不可尽辩才之际。又问佛言。何谓法室总持乎。是天子令所逮致遵法也。佛言。族姓子。所云得至逮法室总持者。入于聪慧文字无尽。一切诸法皆入此室。于一切法悉无所作。解了法室奉行法室。于诸文字。宣以音响口之所说。作屋舍事。不舍事。亦不知之。宣布一切音响之事。是则名曰入于法室总持之业。又寂意。法所可入者。又复诸法而不可得。所可曰入。所出智慧其文字者。无所从来。入于内室。又其文字不现内室。亦不现出。又无所向。亦无方面。又其文字展转所凑。亦不想念。字不顺法亦无非法无斯想念。其文字者悉无有说。亦无非说。亦无增损。又文字者。不见有起。无所灭者。无作文字。亦无所失。又复寂意。若如文字文字之数。心数亦然。一切如是诸法之数。有所归趣。若诸法数彼则无数。所以者何。不归法数无有数者乃曰法数。以随法数。如是乃曰入于法室。不入过去。入于不生无所起法。其无所生以无所起。何所入乎。以无所入。若有入是诸所数者。如是如是。乃能逮于法门。自睹本无。便得安住。入于法室总持之业。入众生心。以入众生心随众生心。应当度者而为说法。若受总持乃曰寂意。寂意。菩萨心以离垢。其心清净严和甚明。其性超越所住安详。智慧无失所愿坚固。所当度者魔不能坏。诸外异业无不摧伏。降消尘劳除诸怨贼。其身力盛心无怯弱。辩才无尽所说无量。所归无限。慧无挂碍入乎觉意。其明甚远。班宣深妙真正之辞。其所博闻犹如江海。斯三昧定。如须弥山处在大海。在于大众若如师子。不倚俗法。犹若莲花不着尘水。无所憎爱心。若如地百谷草木因其得生万民得安。洗净众尘若如清水。开化众生。烧众毒难。譬如火炽燃诸草木。普诲众生。犹如大风靡所不吹。行平等心。若月盛满照于星宿。消淫怒痴。譬如日光照于众冥。伏心意识。譬如勇将摧折严敌。调和其心犹如龙王。淳熟随时。譬如淳阴雷震乃雨。菩萨如是调和其心。敷演法雨润泽三界。宣甘露水净除心秽。若如天雨洗诸风尘。疗治众疾淫怒痴病。若如良医治众人病。志存无为奉行正法。则是法王君训十方。亦如国王治于万民。护化一切生老病死。犹如四天王君四天下。犹天帝释处忉利宫主诱教天人。菩萨如是。在于欲界化众生类。色声香味细滑之法。净如明珠。能伏心意而得自在。若如梵王主于天民。其心清净无所倚着。譬如飞鸟飞行虚空无所触碍。御安其行。犹如鹿王从众群属。敬承法教爱于真行。如母恋子令得安隐。晓诸妓术。犹如严父化导子孙。闻趣诸法。如息意王德自庄严。以三十二福相交饰。用八十好若干品媚。一切世间所共戴仰。不为邪见而被系缚。具足七财无贫匮业。为十方佛所见拥护。诸明智者所见咨嗟。总达众党所共叹誉。及上诸天所见守养。诸善亲友所念摄救。于众讲法最为上选。具六神通而得自在。又普遍入众生性行。而遍周入一切诸根。班宣经典未曾懈厌。永不志慕于诸利养。乐布法训不以吝惜。其志清净无所犯负。忍辱解明无所越失。所作事业能令究竟。清净精进心性安和。一心清净蠲除诸垢。觉意坦然。智慧清净。修四梵行而无放逸。以成度世禅定三昧至于正受。逮于无上菩萨道佛道。普能成就。所当行业不中懈止。至阿惟颜是为寂意。菩萨大士入于法空逮得总持。功勋无量巍巍如是。寂意当知。假使菩萨住在世间。不修余事。于百千岁。咨嗟难宣其总持行诸菩萨众。不能穷尽总持行诸菩萨德

尔时寂意菩萨谓贤王天子曰。仁者。大利无极善庆。今者如来相叹誉德。光光如是。天子答曰。又族姓子。于此诸法无真究竟可得处所也。咨嗟功勋。又族姓子。其无色无有像无形貌。如是行者咨嗟功勋。无能畅尽。于是贤王天子前白佛言。一切诸法不可受取。亦无吾我而无所属。以是之故不可授人。亦不可夺。唯然大圣。若使有人修行乐是。当行平等。若勤奉行修平等训。訢逮法门。犹如世尊。现此大地土在水上。水在风上。假使地种斯土处所周布天下。设使有人穿凿其地。出去尘土。极其功力乃致水耳。不置远去。以水给渴。如来圣慧普入一切众生性行。如来脱者。随向法门而修精进。从是方便致大慧光。其精进者不见侵欺。犹如去土穿地大深因得其水。若复有人于如来世奉行精进。是兴大慧光明。是故世尊。若族姓子及族姓女。欲求佛道常行精进。以何精进。当以用是于诸法门。而诣法门。犹如世尊。从生而盲。又其男子初不见色。假使有人不行精进。则名愚闇盲冥之侣。不见诸法所生本末。犹如世尊。有目之士蒙光有见。不有光出冥夜无睹。外仙天眼亦复如是。离于善友无所开化。不晓诸观见所受法。犹如天眼。若有男子有自然慧。不用光明以成就眼。以有大智德其行如是。犹如世尊。旷野飞鸟游广泽地。不见空野有所增损。一切菩萨精进所行如是。不见佛道有所增损。一切菩萨入道品法。犹如世尊。其彼雪山雨雪生长树木。不为诸风所见灾害。菩萨如是随时应行。生慧光明照于一切。不于众生有所计数。所游居处无所忘失也。犹如世尊。转轮圣王生种姓家七宝则现。何谓为七。一曰紫金轮有千辐。二曰白象有六牙。三曰绀色神马乌头朱髦。四曰明月化珠八角。五曰玉女后口优钵香身栴檀香。六曰主藏圣臣。七曰主兵大将军御四域兵。如是大圣。菩萨大士以七宝现于世时。自然道宝现于世间。何谓为七。一曰施度无极。宝。戒忍精进一心智慧。善权方便度无极宝。出现于世度济一切。犹如转轮圣王游四方域。不可计人民有若干念。菩萨如是。以四恩法救摄众生。不想众生有若干品。解之本无。犹如转轮圣王所举事业。坐于正座无斗诤者无理曲直。众民自然而顺其命。菩萨如是处佛法座。无斗诤者何所从来。魔诸官属。虽抱恶意自然为降。犹如于此三千大千世界前第一立铁围。大铁围山须弥山王。如是大圣。学者菩萨如是。先建大乘。次立大哀。志性仁和最住无极。譬如日初出时。其大光明先照铁围大铁围山须弥山王。乃照其余。菩萨如是。演慧日明普曜三界以仁和心先照众生。大乘光明去三毒之冥皆得神通。犹如世尊。一切诸树郡国县邑乐依于地。一切所生百谷草木皆悉仰地。所生万物而得自在。菩萨如是。一切德本悉因道心。长育圣慧而成正觉也

尔时世尊。赞贤王菩萨曰。善哉善哉。仁族姓子。解引其譬。说功勋业。快乃如是。又族姓子。如众生界及与法界。逮得总持菩萨圣慧。亦复如是。一切万物皆归无常。引喻说相皆能堪任。取要言之。未曾患厌。亦复如是。悉能敷演其所说者。所以者何。皆无口辞亦无所说若有菩萨未得总持。无有言教所造因缘。又其菩萨无有挂碍。不兴辩才。其余声闻无此辩才。不思观本乃为说法。所以者何。此菩萨众得无碍辩。言不可尽。无有阴蔽。无闲无休。分别辩才。诸佛尊前说经法。不怯无弱。菩萨如是。佛所建立逮总持门故有所说。不怀怯劣菩萨如是得三无碍。何谓为三。一曰总持无所挂碍。二曰辩才无所挂碍。三曰道法无所挂碍。是为三。复有三事。得入清净业。何谓为三。一曰自然清净。二曰本无清净。三曰本际清净。是为三。复有三事。得入无尽矣。何谓为三。一曰经法不可穷尽。二曰文字之义而不可尽。三曰所宣训诲而不可尽。是为三。又复得入三无住处。何谓为三。一曰圣慧而无住处。二曰言辞文饰亦无住处。三曰所修建立亦无住处。是为三。又复逮得三卒决对。何谓为三。一曰应讥宣慧。二曰寻发辩才。三曰应时智慧。是为三。复有三疾得归慧。何谓为三。一曰决疑令无余结。二曰断犹豫使无沉吟。三曰可悦一切众生心意。是为三。说是语时。八千菩萨逮得总持

于是密迹金刚力士前白佛言。愿佛世尊建立法典。然后如来灭度之时。最后末世遍布天下。阎浮利地使得久存令不灭尽。尔时世尊周观四方。观察已竟。时说颂曰

  降根自然胜　　寂根无所害
  无本断其无　　伏魔兵众党
  解脱解清净　　无恐解所畏
  舍弃于重檐　　医神咒上师
  降制外异学　　以法而救摄
  护于行法者　　神咒佛所说
  无我以除我　　其义宜以度
  斯于四天王　　说无泽之句
  勇持章句勋　　净复净正等
  梵天释天帝　　作是如此乘
  慈氏彼通忍　　以观哀所察
  爱敬睹梵天　　此者无所犯
  旷野离空旷　　无根法曰净
  降伏魔官属　　故说此神咒
  人中尊建立　　是经善义辞
  尔时普流布　　随器能受者
  以说此咒术　　其地则大动
  诸魔皆悉来　　各口宣是言
  用言护头首　　是曰为法师
  若手得斯经　　归逮佛所说

尔时佛告密迹金刚力士。以建立竟是经典要。今建立是无能乱者。所以者何。佛忆识念过去世时。有佛名宝月。兴出于世。如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰无悦。其佛世时。有二比丘而为法师一名智寂。二名持至诚。威神变化高德无极。大尊巍巍。受彼如来是章句咒。而奉持之。如来灭度之后半劫持法。其彼三千大千世界百千亿魔。皆见开化。承无上正真之道。密迹。欲知尔时二比丘。为法师者。岂异人乎。莫造斯观。所以者何。其法寂者。则我身是也。持至诚法师比丘者。则密迹金刚力士是也。此诸章句令是经法。多所饶益成护正法。彼时世尊。观于四面一切众会。而口宣言。汝等正士。为能堪任。于斯如来。从无数劫亿百千垓。积功累德总持无上正真之道。以持拥护无所挂碍。从是以来至今蒙济。去来今佛之所由生。于是菩萨众会之中。三万二千菩萨即从坐起叉手而住。稽首礼佛。说是偈言

  弃其身寿命　　思惟好寂然
  受持是经法　　世护之所叹
  其是经如药　　疗治一切病
  受持所言教　　发生世尊意

尔时贤王天子之等五百天子。说是偈言

  用一切众生　　以故想积德
  受持是经典　　最胜特深妙

于是密迹金刚力士。时说颂曰

  是议无文字　　而反宣文字
  人中尊所作　　班宣我当持

尔时世尊。告识氏梵天。如来有三不可限量无上供养。德无有极何谓为三。一曰至心仁和发其道心。二曰以发道心护于正法。三曰如所闻法为人解说。身行如是。是为至不可计德。梵天当知。如来以是三事。积累功勋。假使其寿住世一劫。广分别说不能究畅。是故梵天。当以随顺恭敬奉事如来至真。是为三事。梵天。供养如来。受四句颂。是去来今佛世尊之所说法。受而拥护。所以者何。诸佛世尊皆从是法生。故当供法。供法不用衣食。以法供养。诸养中尊。为上为长为无俦匹。为无等伦。是故梵天。当以正法而相供养。是养真谛无以衣食。佛自忆念。梵天王。过去曾生为王太子。名曰意行。生于王家。以是见教。谛乐道法。时卧梦中闻是四句颂。本行放逸无脱路。以众生故志于道心在山空闲随顺念无所贪受本悉安。佛语梵天。彼时闻是颂教。从梦中觉。思惟了了。惟是忻然大悦。心中解畅。即时以偈而叹颂曰

  快哉安上乐　　得法藏无尽
  当充满众生　　诸贫天人民

佛告善安大梵天。时王大子得安谛藏。晓文字无。心自念言。以是偈义。充满众生贫匮之人。往语父母。宁有金银琉璃水精车磲马瑙明珠藏乎欲济穷乏以是欢喜。父母报言。一切财业非是真宝。五家水火盗贼怨家债主县官恶子分耳。博闻之慧。无衣食求。甚为难得。父母言善。如子所志。便取广施与诸乏者。了三界空。令得难致无尽之慧。以故梵天闻是一四句偈。化八千人劝入道意。无数众生当生天上。以故梵天。其有受是深妙之法。持讽诵读为人广说。闻之欢喜若奉行。是德不可量逮无极藏。假使梵天行大乘业有三事法。多益菩萨。何谓为三。一曰闻行得立受之无厌。二曰以闻建立。以行为要守口第一。不以害心加于众生。三曰不舍大哀。是为三。以故梵天。益于众生。当加劝助是经典要。复有二事。所造行愿无所忘失。何谓为二。一曰佛初成道。劝助如来使转法轮。二曰梵天。当劝助是贤劫中当来具千如来至真等正觉。使转法轮。令化出家众人作菩萨行。如佛世尊。为自在法王。善教训诲少有能及。难逮如是。以故梵天。如是比像多所亲立。一切众人除老病死。至无为业。于色无著。以解了是能忍众苦忍无所求。主诸天人造立三忍。执持正法。受讽诵读是乃甚难。受是经者。当作是观。受我身亿百千垓劫。修清净行严净佛土。拥护正法疾成正觉。佛告贤者阿难。受是经典持讽诵读。为他人说。阿难曰诺。当受持之令其坚固。佛言阿难。勿持是法授非法器。莫得授与诸恶知友。当施善友慕乐学者。授是经法。常当奉护。阿难。是经不归非法。当归应器。能奉行法。常慈心众。又是经者无有妄想。瑞应现前精进所致。行是经典有是福报。阿难白曰。当受是经。承佛威神常令普流。若受是法承佛威神。其光远照是等不随无器之业。又是经者。所号为何。云何奉行。佛言。是经名曰佛所训诲。阿难。又有号曰密迹金刚力士所宣布义。当持奉行。又名如来功勋报应。当奉持之。又复名曰如来秘要经法之品。为他分别无冀养心。归于无量功德而顺法律。当奉持之。所以者何。若有奉持是经法者。令以佛眼普见佛土及十方国。从地以上高至三十三天思想天。满中七宝百种众膳。贡施如来。若有受是经学持奉行。以无冀养为他人说。是德最多。又以衣食供养是经典要。宣如来德。得福无量不可为喻。说是经时。无量众生发大道心。不可计菩萨逮得法忍。复无央数菩萨逮一生补处。佛说如是。贤者阿难。密迹金刚力士寂意菩萨。及大声闻一切众会。及诸天人。诸阿须轮。揵沓和。及世间人。闻佛所说。莫不欢喜。稽首而去

大宝积经卷第十四大宝积经卷第十五

        西晋三藏竺法护译

    净居天子会第四之一

如是我闻。一时佛住王舍城耆阇崛山中。与大菩萨比丘众六万人俱。皆悉住于阿耨多罗三藐三菩提。其诸声闻众所知识。尔时世尊。于中食后。入于三昧。此三昧威神力故。震动三千大千世界。时诸释梵天。护世四王等。来诣佛所。到已头面礼足。在一面立合掌向佛。以此三昧威神力故。尔时净居天。欢喜天子。善欢喜天子。大欢喜天子。贤欢喜天子。善受天子。兜率陀天。自在天。大自在天。一切诸天。大众净居天等。各诣世尊所。头面礼足。在于一面一心而住。尔时净居天众白世尊言。大德世尊。菩萨所行相貌。摄受诸法。过去诸佛之所说者。唯愿演说分别显示。为利益安乐多众生故。怜愍世间利安天人。为未来诸菩萨。于如来般涅槃后。闻此法者生欲乐心。于阿耨多罗三藐三菩提。如实自知不生疑悔究竟安住不放逸行。值遇于苦不生退转。时净居天众及兜率陀天。向于世尊。说是语已默然而住。时有天子名金刚摧。为诸天众。请于世尊。而说偈言

  百福德满故问此　　人天敬爱故问此
  住不放逸故问此　　多众医王故问此
  无过法句愿显说　　诸音最胜世明慧
  能断百千诸疑悔　　能放众明故问此
  犹日能破诸黑闇　　如月净明除郁蒸
  于怨于亲生平等　　难忍能忍犹如地
  亦如净水洗尘垢　　如火能烧烦恼网
  三有意净故问此　　无碍智辩望宣说
  如医疗治众生病　　如毗沙门多财宝
  赈给穷下贫苦者　　如云能灭三种热
  是句最胜唯愿说　　若破烦恼众苦箭
  烦恼众垢奸谄诈　　善能调伏施安乐
  念众生故故问此　　惭愧明慧念坚固
  大尊无奸离谄曲　　无相德聚故问此
  嗔恚怨嫌永寂灭　　于诸众生安乐忍
  和颜悦色视众生　　常以欢喜先意语
  于诸众生亲友想　　度诸众生至彼岸
  合指十爪一心请　　十力善逝众生宝
  唯愿时说断众疑　　天人闻此道行已
  见于第一诸相貌　　使彼得知大丈夫

尔时世尊。告金刚摧菩萨摩诃萨言。金刚摧。汝谛听善思念之。当为汝说所有相貌。使菩萨摩诃萨得知如是。大德金刚摧菩萨言。我听受是因缘。世尊作如是言。有百八相。金刚摧。菩萨乘人应当知。何等为百八梦中所见。已有梦见如来身共语见妙身。复次梦见如来默然。复次梦见如来覆头坐。复次梦见如来背坐。复次梦见如来身红色。复次梦见如来彩色画身。复次梦见如来去。复次梦见如来为他说法。复次梦见如来神通虚空中行。复次梦见如来般涅槃。复次梦见阇维如来身。复次梦得如来舍利。复次梦得如来发。复次梦见如来未曾见塔。复次梦见如来宝庄严塔。复次梦见如来神通塔。复次梦见如来光。复次梦闻如来声不见身。复次梦见如来身。复次自梦见花鬘香涂覆如来上。复次自梦见如来着垢腻衣。复次自梦闻未曾闻法。复次自梦为人说未曾闻法。寤已无所显示。乃至不念。又见未曾见法师。复次自梦坐法座为他说法。复次自梦得无畏。复次自梦见道场。复次梦见如来经行。复次梦见如来转法轮。复次梦见如来般涅槃塔。复次梦得如来衣。复次梦得如来钵。复次梦独见一如来。复次梦见如来多人围绕。复次梦见如来盖。复次梦见如来革屣。复次梦见如来坐。复次自梦与如来食。复次自梦与如来衣。复次自梦与如来花。复次自梦入山。复次自梦裸形。复次自梦四维行。复次自梦见未曾方。复次自梦浊水中行。复次自梦见云雨。复次梦见地旋。复次自梦在豺狼野干中行。复次自梦病。复次自梦堕山无所依仗。复次自梦被缚将杀。复次自梦刀剑中行。复次自梦虚空中行。复次自梦手捉炬火。复次梦见菩萨踰宫出城。复次自梦得经。复次自梦闻陀罗尼声。复次自梦闻三昧声。复次自梦闻方广经声。复次梦某甲法师声。复次自梦梦中得偈。复次自梦梦中得经说。复次自梦闻法藏声。复次自梦闻他方世界如来名。复次自梦闻他方世界某甲菩萨名。复次自梦入海去。复次自梦集宝。复次自梦在须弥山顶。复次自梦上山。复次自梦上到山顶。复次自梦上树。复次自梦见龙象。复次自梦乘龙象。复次自梦乘马。复次自梦发真实誓愿。复次自梦见果树。复次自梦见花树。复次自梦见未曾见城。复次自梦见阿耨大池。复次自梦见天子。复次自梦见龙。复次自梦见余阎浮提去。复次自梦见着白衣。复次自梦宝鬘在头。复次自梦见花鬘在头。复次自梦取散花。复次自梦打鼓余人作乐。复次自梦见日蚀月蚀。复次自梦以不净自涂。复次自梦作王。复次自梦作王辅相在大众中行。复次自梦乘乘往园林中去。复次自梦见未曾见方土聚落僧坊房舍人众。复次自梦得盖。复次自梦为多人说法。复次自梦入聚落。复次自梦施系桥梁。复次自梦集船。复次自梦见云雷电。复次自梦得力着铠仗。复次自梦得器物。复次自梦示众生道。复次自梦入园林中。复次自梦见众谷聚。复次自梦治众生病。复次自梦受记声。复次自梦觉道。复次自梦得满瓶。如是金刚摧。是名百八相。若见如来覆头坐者。是人见善知识修善说法因缘。为作留难。应以无碍心修集说法所须。此是说初相。复次金刚摧。梦中见如来背坐者。前为出家人作留难。为听法人作留难。此人令常当敷施法座。劝多众生。听法如是。得除业障。是七地初相。亦是从初地至七地。处处地相。复次金刚摧。若梦见如来泥像。是菩萨初地相。是人曾毁呰说法师故。此人应于经像前若如来塔前。以无碍心。顶戴灯供养。如是用净业障

复次金刚摧。菩萨梦中见如来画像者。此菩萨是见五地中处处相。是人应以花香供养佛像。此是菩萨六地处处地见相。复次金刚摧。菩萨若梦中见如来行者。此人应勤修精进。当勤修受学读诵。此是菩萨三地见相。此人常应法施。又应扫如来塔。破除憍慢以此净业障。见余菩萨诣如来所。是何相。见如来向食之处。此是初地相。见如来向经行处。是第二地相。见如来向说法处。是第三地相。见如来默然坐。是第四地相。见如来静处坐。此是五地相。见如来行呗者。是六地相。见如来疾走。是七地相。若见如来作神通。是八地相。见如来变化。变化去者。是九地相。见如来行去回顾共语说空。是十地相。复次金刚摧。菩萨梦中自知为众生说法不知所说。是第二地相。是人于如来般涅槃后。毁呰说法师。不自知过。此人当求善知识。供养听闻善法。不求其过如是。净除业障。闻佛说施。是初地相。闻说戒是二地相。闻说忍是三地相。闻说精进是四地相。闻说禅是五地相。闻说般若慧是六地相。闻说大悲是七地相。闻说无碍是八地相。闻说三昧是九地相。闻说成就力是十地相

复次金刚摧。菩萨梦中见如来虚空中神通行者。此是七地相。闻受道记。此人常应修尊重默然。修习成就甚深忍。如是疾成正觉。见如来在虚空中。是初地相。见如来食是第二地。见光是第三地。见说法是第四地。见现神通是第五住地。见入三昧是第六住地。见放光见如来虚空中行去。是第七住地

复次金刚摧。菩萨梦见如来般涅槃者。此人前谤法。出家谄曲求利。应勤供养三宝奉施说法之人。一心三时精进。如是以净除业障。见前五地处处相

复次金刚摧。菩萨梦见阇维如来。是人口恶知识。见毁法随喜。此菩萨初地。此人发菩提心不久。是人应于七日七夜中持灯。若说法人前。若如来塔前一心忏悔。于日中昼三时。劝众人听法。以此净除业障

复次金刚摧。菩萨梦中得如来舍利。此说菩萨三地。梦中亲近如来。闻受记得度。梦住余地。得如来舍利。如是相得如来发是初地。梦得如来爪是第二地。梦得舍利是第三地。梦得齿第四地。梦得牙第五地。梦得白毫第六地。梦得手第七地。梦得冠第八地。梦见阇维如来全身不散第九地。见如来全身第十地。复次金刚摧。菩萨梦见得如来发不散。此是菩萨第九住地。梦佛前授菩提记。除生死业障。梦得在家时发是初地。梦得出家时发第二地。梦市中得发说第三住。于城中得发第四住。于城门中得说第五住。于外得第六地。于园观中得第七地。于乘上得第八地。于虚空中得第九地。于三昧中得第十地

复次金刚摧。菩萨梦中见塔。此菩萨少业障。少许魔业若亲近善友。善解法忍。得陀罗尼。此是一切十地相。见如来泥塔。此说是菩萨初地。见石塔第二地。见石泥像说是第三住地。见栏楯塔第四住地。见石柱围绕是说第五住地。见金覆塔是说第六住地。见宝塔是第七地。见铃网覆塔是第八地。见若七地初见是觉魔业。若九地十地见。是不颠倒见。复次金刚摧。菩萨梦中见如来庄严塔。不久觉菩提道。为诸天忆念。此是菩萨第八住。复次金刚摧。菩萨梦中见如来神通塔。此生当净业障。此是菩萨第八住地。若菩萨忆念。此应离恶知识。应初住修信。二住修智。三住地多修信解。四住地久修行。五住地修净信解。六住地修平等心。七住地第一义解。第八住地修庄严佛土。第九住地授持。十住地住不颠倒。若住余初住。当知是魔业。若七住人不可欺诳无巧方便。复次金刚摧。菩萨梦中闻如来声不见形。是菩萨四地。以住自在地。破见佛地众生出家谄曲说法。此人应昼三时夜三时修净心。如是净除业障。复次金刚摧。菩萨梦中供养如来。说是菩萨初地乃至九地。如是菩萨能成就陀罗尼。是菩萨诸佛所念。此菩萨应修平等心。如是疾成无上道。若梦住供养如来。此说菩萨初地相。若坐与者。是说二住地。若庄严与。此说是三住地。共自眷属与者。是说四住地。与多人共与。是说五住地。若与自眷属及与多人共与。是说六住地。一切庄严成就与。是说七住地。若称赞与。是说八住地。若作神通与。是说第九住地。觉一切魔事

复次金刚摧。菩萨若梦中自见以花鬘香末栴檀供养如来塔此是菩萨见初地五地处处地。是前少行檀波罗蜜。觉已忆念此相。生长施心。此说是初地相。生长戒心说是二地。生长忍说是三地。生长精进是见四地。生长禅是见五地。生长无碍心。疾遍一切不退转地

复次金刚摧。菩萨梦中见如来着垢腻衣。此菩萨多法障。是初地处处。见一向憎疾回向缘。是见初地离憎爱。回向是见二地。若身见第三地。若心见是第四地。若梦中见是第五地。若成就菩萨。梦中少梦见受报

复次金刚摧。菩萨梦闻未曾闻法此菩萨曾供养多佛。多世中作说法师。此说见初地处处乃至七地。此如说修行。此疾觉菩提。若闻种种说是见初地。若有疑心。犹欲更听。是见第二地。若闻已断疑。是见第三地。若闻说陀罗尼。是见第四地。若闻说佛相者。是见第五地。若闻第一义谛。是见第六地。若闻说一切法。是见第七地。如是地地知

复次金刚摧。菩萨若梦中得未曾学法。学已不忘不失不见。若忘失此菩萨前身。为利养心不清净心。法施。今应以清净供给。摄取学人。以无谄曲心。求一切物。供给说法学问人。以此净除业障。若初地二地闻法不失。是见初地。若觉失是见二地。此觉魔业业障

复次金刚摧。菩萨梦中见未曾见法师。此菩萨为诸菩萨所忆念少业障。觉已得见明此菩萨说。是六地初地。若说偈不说经是说初地。若说经是说二地。若说经说偈是说三地。若说种种是说四地。若说甚深是说五地。若说无碍是说六地

复次金刚摧。菩萨若梦中自梦在法座说法。此菩萨前身为佛敷法座。此菩萨是甚深法忍器。是见第八地初相。若梦乐说是说初地。若非乐说是说第二地。若忍乐说是说第三地。若无辩说是说第四地。若说凡夫界是说第五地。若说声闻界是说第六地。若说菩萨界是说第七地。若说佛界是说第八地

复次金刚摧。菩萨若梦中自知得无畏。此菩萨过一切业障。过八地见九地处处。若梦得无所畏。所说众人乐闻。此菩萨是见初地。若梦得无畏说法得财。此菩萨见第二地。若得法利无畏。此菩萨见第三地。若见善知识无畏。此菩萨见第四地。若思善心无畏。此菩萨见第五地。若得身安乐无畏。此菩萨见第六地。若心乐无畏。此菩萨见第七地。若得通无畏。此菩萨是见第八地。若得记无畏。此菩萨见第九地

复次金刚摧。菩萨若梦中见道场。此菩萨纯善。心向道不退转是十地处处见。若见道场不见树。是说初地。若见树不见菩萨。是说第二地。若见多树围绕。是说第三地。若见叶具足成就。此菩萨是说第四地。若见花叶具足。此菩萨见第五地。若见果成就。此菩萨见第六地。若见敷坐。此菩萨是见第七地。若见人围绕。此菩萨是见第八地。若见龙围绕此菩萨见第九地。若见天围绕散花闻欢喜声。此菩萨见第十地

复次金刚摧。菩萨若梦中见如来经行。此菩萨应勤修精进。勤修法施。安慰眷属不求其过。若菩萨是七地处处见。若见如来不净地经行。此菩萨是初地。若见净地经行。此菩萨见第二地。若见敷座经行。此菩萨是见第三地。若坐者。此菩萨见第四地。若见树围绕。此菩萨见第五地。若见散花。此菩萨见第六地。若见高座覆上者。此菩萨见第七地

复次金刚摧菩萨。若菩萨梦中见如来转法轮。此菩萨是不退转。是七地初地。见处处地。净无业障。若见座。是菩萨是见初地。若见敷座。是菩萨是见二地。若见敷杂色座。是菩萨见三地。若见散花于座。此菩萨是见四地。若见种种宝覆盖高座。此菩萨是见五地。若闻空中歌颂称叹声。此菩萨是见六地。若见白盖以宝网覆上。此菩萨见十地

复次金刚摧菩萨。若菩萨梦中见如来般涅槃塔。此菩萨是初地八地处处见。近无上道。少于业障。若见尘土坌塔。此菩萨是见初地。若见净无尘者。是菩萨见二地。若上生草。此菩萨是见三地。若见青草覆上。此菩萨是见四地。若见种种杂花树围绕。此菩萨是见五地。若见花果树围绕覆上。此菩萨是见第六地。若见种种杂姓众生围绕。此菩萨是见七地。若见幢盖聚集。此菩萨是见八地

复次金刚摧菩萨。若菩萨梦中得如来衣。此菩萨是见初地八地处处地相。此菩萨应勤修成就念佛智。此菩萨少于业障。若得如来垢腻衣。此菩萨是见初地相。若得如来净衣。是见二地。若得如来染衣。此菩萨是见三地相。若得如来打衣。此菩萨是见四地相。若得如来放光衣。此菩萨是见五地相。若得如来一衣。此菩萨是见六地相。若得如来三衣。此菩萨是七地相。精进相不精进相除魔业。是菩萨有疑

复次金刚摧。菩萨梦中得如来钵。此菩萨佛所忆念。是见八地。此菩萨是闻明法器。修无业障忍。如是趣无上道。若得污不净钵。此菩萨是初地。若得空净钵。此菩萨是二地。若得满钵味。此菩萨是三地。若得满钵花。此菩萨是四地。若得满钵果。此菩萨是五地。若得满钵食。此菩萨是六地。若得满钵香。此菩萨是七地。若得满钵花鬘香。此菩萨是八地。若得如来衣钵。此菩萨是九地。若虚空中得如来钵。此菩萨是十地。此菩萨应觉魔业。除初业不勤修

复次金刚摧。菩萨梦中见一如来。应静处勤修空三昧。此菩萨是八地杂业障。应勤修净心

复次金刚摧。菩萨若于梦中见如来。多人众中见如来身。此应忍乐摄取多人。此菩萨一切地处处见。相应勤进修道。若见居士杂姓人围绕如来。此菩萨是初地。若见王者众围绕如来。此菩萨是二地。若见婆罗门围绕如来。此菩萨是三地。若见王围绕如来。此菩萨是四地。若见龙围绕如来。此菩萨是五地。若见四大天王围绕如来。此菩萨是六地。若见帝释围绕如来。此菩萨是七地。若见梵天围绕如来。此菩萨是八地。若见净居天围绕如来。此菩萨是九地。若见菩萨围绕如来。此菩萨是十地除魔业

复次金刚摧。菩萨梦中得如来盖者。此菩萨最后地处处见地。解魔业杂业。求利养疾趣向。若见草叶盖。此菩萨是初地。若见竹盖。此菩萨是二地。若见桦皮盖者。此菩萨是三地。若见大盖者。此菩萨是四地。若见铁叠盖者。此菩萨是五地。若见铜盖者。此菩萨是六地。若见金盖者。此菩萨是七地。若见七宝盖者。此菩萨是八地。若见铃网盖垂下者。此菩萨是九地。应觉六地魔业

复次金刚摧。菩萨梦中见如来革屣。见一切十地。此菩萨应勤修精进趣向。此菩萨受记系在受记界。若向村间见革屣者。此菩萨是初地。若僧坊中见革屣者。此菩萨是二地。若园观中见革屣者。此菩萨是三地。若经行处见革屣者。此菩萨是四地。若房中见革屣者。此菩萨是五地。若坐禅中见革屣者。此菩萨是六地。若河水中见革屣者。此菩萨是七地。若山中见革屣者。此菩萨是八地。若空中见革屣者。此菩萨是九地。若神通见革屣者。此菩萨是十地。除魔业

复次金刚摧。菩萨梦中见如来坐。此菩萨是初地六地。此菩萨应乐修寂静少于业障。未成就业无敷座。此菩萨是初地。敷座。此菩萨是二地。显现敷座。此菩萨是三地。若敷种种座坐。此菩萨是四地。毕竟敷座。此菩萨是五地。若善敷好座。此菩萨是六地。应觉魔业

复次金刚摧。菩萨若梦中与如来食。此菩萨是七地见初地相应。勤修精进趣向道。此菩萨少于业障。若见如来入家中立施食者。此菩萨是初地。若在家中坐施食者。此菩萨是二地。若门外立施食者。此菩萨是三地。若市中施食者。此菩萨是四地。若城门中施食者。此菩萨是五地。若僧房中施食者。此菩萨是六地。若房中施食者。此菩萨是七地除魔业

复次金刚摧。菩萨若于梦中。自知施如来衣者此菩萨是六地初地。此菩萨应勤修无相三昧趣向菩提。若恭敬心施如来衣者此菩萨是初地。若施如来白衣者此菩萨是二地。若施染衣者此菩萨是三地。若施如来杂色衣者此菩萨是四地。若施如来金色衣者此菩萨是五地。若施如来杂宝衣者此菩萨是六地。若施如来色衣者此菩萨是七地。若施如来天衣者此菩萨是八地

复次金刚摧。菩萨梦中自知施如来花。此菩萨是六地处处相。此人多业障善根难生。若梦中施如来曼陀罗花。此菩萨是初地。若散花施者此菩萨是二地。若种种杂色花施者。此菩萨是三地。若以花着如来上。此菩萨是四地。若自手以花着如来手中此菩萨是五地。若以天花施如来此菩萨是六地除魔业。除二种人初业多疑悔者

复次金刚摧菩萨。若菩萨梦中梦入山生疑心生谤。当知多有业障。多有病痛少于智慧。此人应于一切众生生无碍心。以此心趣向菩提此菩萨。是五地初地见。此菩萨应七年中昼夜六时起清净心。初地明慧相当勤具安乐具。供给二地。第三地供养三宝。第四地应勤修甚深法忍第五地。复次金刚摧。菩萨若梦中自见裸形。当知自无业障。当知见初地。若城中自见裸形。是见第二地。若阿练若处见裸身。是见第三地。若山中见裸形。此见第四地。当知魔业

复次金刚摧菩萨。若菩萨梦见自趣四维去。此菩萨舍善知识。是见初地。少于智慧懈怠多忧多恼。为多人所笑。多于病痛。心多狂癫。为善根故求于出家。复还入俗。贫苦无有财物多病。为利养故谤毁法师谤法不信不解。当还生正直心亲近法师。勤修一切施无碍心趣向菩提。此菩萨乃至解于六地。此菩萨以软中上心。除害过罪

复次金刚摧。菩萨梦中见趣向未曾见方。此有魔业业障。此菩萨三地处处见地。应勤修净根供养三宝净初地。若勤修空见第二地。修法忍见第三地。乃至住六地。自知此菩萨见初地。出入多于善根。亦多不善根。此舍命不生愁恼。舍恶知识。亲近信解知法人无奸伪。如是净于业障。彼以奸诈心盗法。当亲近善知识。此菩萨自梦见在浊水中去。是见初地。若自见在浊水沫中行此是见二地。若见涌没水中行。此是见第三地。若涸水中行。见第四地。若梦在清水中行。是见第五地

复次金刚摧。菩萨若梦中见云雨。此菩萨多魔业。此菩萨是初地七地见。此以自在力。娆说法师。前出家为利养故。呵责法师。若法师如法教悔。常违反师语。应勤修忍辱生信解心。离于利养一向为利他。以此净业障。若见尘土云雨。此菩萨是初地。若见黑云。此菩萨是二地。若见乱云。此菩萨是三地。若见雷云。此菩萨是四地。若见电云惊怖。此菩萨是五地。若见雨雹。此菩萨是六地。魔业地地应知

复次金刚摧。菩萨梦中见地摇。此菩萨是初地。久行初业多。初业多初业障多恐怖众生。应修无畏施众生守护三业。以此净除业障。彼若常见地摇。是初业初地。破城池烧人众。此菩萨二地。若地久动是三地。发真实誓是四地。魔业是五地六地。勤修总持是七地。大威德诸天悉来集会。是八地。诸龙来增益气力。是九地。是梵天来。是十地。闻如来秘密语。地摇动地。地应觉知

复次金刚摧。菩萨梦中自见在斗讼中。是菩萨是四地初地。若见上地。是魔业乃至七地。不勤修习摄取伏非法人。先时为利养故。违说法人。奸诈说法自活。当学方便。当善心修六波罗蜜。以此净除业障。若被呵嗔生惊畏心。是初地。梦被刀斫。是二地。若被土块杖。是三地。若被恶骂。是四地。魔不解不勤修

复次金刚摧。菩萨梦中见自病。此菩萨是二地处处地见相。世间出世间多作艰难。欲多法施复还断绝。欲多财施。复还断绝。应当供给修行法人。修无碍心修不放逸。慢修不自在慢。以此净除业障。若见在余处地病。此觉魔业。复次金刚摧。菩萨梦中堕山。无所依止。先时于善心。一向诈奸多不信解。多于业障。魔业增盛。身心羸劣。受法疾得寻复忘失。生欲乐心中间放舍。若见财封舍离。若见佛法舍离。舍离忍辱。亲近恶行。不近善法。于深信解入边。不生信解。此菩萨是见二地初地。若自见刀山中行。是见初地。若自知石山中堕。是见二地。住余地无业障无魔业。应生信心于三月中昼三时夜三时忏悔。应观世间因缘法。应修供养。如是以除业障

大宝积经卷第十五大宝积经卷第十六

        西晋三藏竺法护译

    净居天子会第四之二

复次金刚摧。菩萨梦中自见被缚将杀。此菩萨魔业增盛非业障。彼应修无碍定修于慈心。以此净除业障。此菩萨是见六地初地。若梦被系在死尸中。是见五地。若被缚至亲里围绕是六地。是魔业不勤修初地羸劣。为无上道应修增上进

复次金刚摧。菩萨若梦中自知在刀中。此菩萨是初地五地。多恶知识多艰难。应静无忿怒无障碍心。一向勤利他人。以此净除业障。前曾在上位恼乱持戒人。见人持种种刀。自见在中。此菩萨初地见。若见人持一刀在中。是第二地。见捉杖在中。是见三地。若见捉石在中。此见四地。见在空手众中住。是五地除魔业。复次金刚摧。菩萨梦自见在空中。此菩萨在信地。得无生法忍。此菩萨诸天所念。应修好威仪。应常修精进劝发众生求无上道。不应常住一处。如是清净此菩萨是初地七地。见处处地。若见虚空中行施。此是初地。若空中见仙人。此见第二地。若见沙门。此见第三地。若见龙第四地。若见天第五地。若见梵天是第六地。若见菩萨如来。是第七地除魔业。复次金刚摧。菩萨若梦中自见捉炬。应勤修明慧。此菩萨是初地五地。此菩萨应不顾身命不观饮食。应行禅不生疑悔。如是趣向。住初地乐修对治。住二地乐修禅。住三地乐修慈。住四地乐修悲。住五地乐修舍。住初地应修念佛为明见。住二地应修放解。住三地应修闻。住四地应修持。住五地应修空。如是应得明。复次金刚摧。菩萨若梦中见菩萨踰宫出。此菩萨初地六地处处见。增加精进得不退转。在菩提记界疾近无上道。若见步出是见初地。见乘牛车出是见二地。见乘马车出是见三地。见乘象车出是见四地。若见乘人车出是见五地。若见乘空中车出是见六地除魔业

复次金刚摧。菩萨若梦中得经。此菩萨是初地三地处处地见。此人多诸因缘。多诸谤毁。数数多诸艰难。应一心修悔过常修精进。若梦得世俗典籍声闻经法。此是初地。梦得檀相应经。是见二地。梦得甚深相应。是见三地。不勤修乃至七地。若诸天与。若菩萨与。如法来与藏

复次金刚摧。菩萨梦中闻得法功德声。此菩萨是初地六地。见处处地。见前得佛总持。此菩萨少于业障。魔业增盛。应施于辩才不求人过。如是清净。闻出香陀罗尼声。此菩萨是初地。闻文字陀罗尼。是第二地。闻书写陀罗尼。是八地初地。见处处地。此不应爱着三界。勤修独处。彼少于业障少于魔业。烦恼增盛。应听种种法。应修多观。如是相应。有觉观三昧。是初住地。无觉少观。是三住地。无觉无观是四住地。梵处空处三昧是五住地。现一身三昧是六住地。大通三昧是七住地。出生佛庄严三昧是第八住地。复次金刚摧。菩萨若梦中闻方广经声。此菩萨是六地初地。应修信解法决定忍。此菩萨少于障。缓趣无上道。勤问持戒之相。应尊重师长。如是趣向菩提。闻檀波罗蜜经声。是初地。闻戒经声是二地。闻忍经声是三地。闻精进经声是四地。闻禅经声是五地。闻般若波罗蜜声是六地。除不勤修人。佛所持善心成就者

复次金刚摧。菩萨若梦中闻说法比丘字声。此菩萨是四地初地。此应依止善知识。此菩萨多诸艰难。多诸疑悔。少于智慧。应修无碍心。应方便劝一切众生修无疑悔心。如是清净。若见前所闻法师名此初地。若闻不见法师名。见第二地。若闻他异世界法师名。是第三地。若闻一生补处菩萨。若闻乐上地声。是第四地

复次金刚摧。菩萨若梦中得信辩。此菩萨是初地三地。此菩萨是辩器。若远离三法疾得明。何等三。见他得利心生嫉妒。为利养故。奸诈亲近。如是三法当远离。然后趣向说少偈颂是初地。能说种种偈是二地。说甚深偈是三地。多说上地偈

复次金刚摧菩萨。若菩萨梦中得经辩。是初地八地见。此有多功德因缘。当勤依修戒当修胜供养供养净行人。不应修智慢。如是梦中当受业障。少受苦报。彼出初地。四辩说方等经。是说二地。说种种经是三地。说前因缘是四地。说三世是五地。说波罗蜜是六地。说甚深经是七地。说一切决定是八地

复次金刚摧菩萨。若菩萨梦中闻陀罗尼声彼是七地。此菩萨受诸烦恼少业障。应问智者修静默处趣解脱。如是趣向。梦在村中是初地。在房中是二地。在僧房中是三地。在阿练若处坐是四地。若梦坐是五地。若园观中是六地。梦在山顶是七地

复次金刚摧菩萨。若菩萨梦中闻他方世界未曾闻如来名。此菩萨是受记初地八地。憍慢自在故。不趣向道多魔业。为供养故修不净威仪。然后趣向。修舍是初地。梦戒慢是二地。闻慢是三地。方便慢是四地。疑慢是五地。智慢是六地。所说慢是七地。受持慢是八地

复次金刚摧。菩萨若梦中闻某世界某菩萨声。此菩萨是五地初地。此菩萨为菩萨所忆念。少烦恼应离憍慢。劝多人修智。如是相应得陀罗尼。是闻初地。梦出家是闻二地。梦苦行是三地。梦道场降魔是四地。梦觉道是五地。闻见上多闻见不定羸劣善心。是见初地。住于疑心是二地。退心放逸是三地。增上放逸是四地。多定是五地

复次金刚摧。菩萨梦在海中。此菩萨精进是八地。见处处地。应修多闻精进慧解。若梦中无所依止是初地。若在海际是二地。若在船乘是三地。梦往去是四地。梦上船是五地。梦水中坐是六地。在船中坐是七地。梦船中满宝在上坐欲出海是八地

复次金刚摧。菩萨若梦中集宝此菩萨是初地三地。见处处地。此菩萨多逢苦恼。应乐修净业不求人短。于说法者知恩。如是趣向。梦掘地中得宝初地。杂土得宝是见二地。杂草得宝是见三地。是不勤进相是魔业。若六地若四地。不勤方便。魔业业障

复次金刚摧。菩萨梦中在须弥山顶。此人不退转。是见初地五地。彼有少功德。亲近恶友。因缘奸诈。无信亲近善知识。今应修不奸诈多修信解。如是趣向。若梦在须弥山。当知上六住。梦住须弥山是七地。梦四顾望是八地。梦坐者是九地。梦山动是十地。此初地乃至见五地。勤进修善心。在善知识手是魔业

复次金刚摧。菩萨梦中自见上山。此菩萨是初地五地。害一切烦恼业障。于说法人不生恭敬。应修不谄曲净除业障。如是趣向菩提。初地增长三时勤进。二地勤修念佛。三地修空。四地修大悲。五地修慧。梦自上山是初地。在山中是二地。在山上是三地。梦观看是四地。坐者是五地

复次金刚摧。菩萨若梦上山此菩萨见是七地初地。此菩萨少于业障。魔业增盛。应舍一切所爱物供养智慧者。于智慧人边。应自伏憍慢。若梦度七大山乃至须弥山是七地

复次金刚摧。菩萨若梦中梦上树。此菩萨是初地四地。处处地见。应觉业障魔业。应亲近依止善知识。得于慧明。时时当决断法义觉知。如是趣向。见树枝叶具足阴凉是初地。见香树是二地。见花树是三地。见果树是四地。是勤进相若不勤进是魔业。若见高处树枝叶花果具足除业报

复次金刚摧。菩萨若梦中见龙象。此菩萨是初地六地。处处地见。此菩萨行施不行慧。困乏善根。应当修信。当修善念如是相应彼初地。见不清净龙象二地。见白龙象三地。见六牙白龙象四地。见庄严象五地。见捉幡盖龙象六地。见欢戏龙象

复次金刚摧。菩萨自梦上龙象。此菩萨是见初地七地。一生当得如来应供。有入法智。多希望应修恭敬劝发。菩萨离于幻伪奸诈。应处处知足修适意施。如是清净。梦上象是初地。梦自着白衣上象是二地。若梦染衣是三地。若梦种种色衣是四地。若梦香染衣具足庄严是五地。若梦着冠是六地。若梦捉庄严盖是七地。除魔业不勤进上地相。见一切具足

复次金刚摧。菩萨若梦中上马。此菩萨是初地四地。此应修依止戒波罗蜜度。彼魔业增盛。少于业障。当多修空慧勤修生信。如是清净。自梦上住马是初地。梦上行马是二地梦上走马是三地。上庄严马第四地。除上地魔业。此菩萨增上慢魔业

复次金刚摧。菩萨若梦中作成实誓。此菩萨一切地十地处处地见。彼于业障多增盛魔业。多诸方术行。善修出生三昧。应正修威仪不多积聚。如是净业障。作成实施誓。此是初地。为解系缚是二地。为解病是三地。为城池是四地。为王是五地。为阎浮提是六地。为四天下是七地。为千世界是八地。为三千世界是九地。日出时地游雨天花是十地。除魔业初地六地。复次金刚摧菩萨。若菩萨梦中见药树。是菩萨是见初地七地。满足成就受记法。应修不望报施正直不求人过。如是清净。梦见少果树是初地。若见多果树是二地。若见苦果树是四地。见药树是五地。若见天树是六地。若见甘果树是七地

复次金刚摧菩萨。若菩萨梦中见花树。此菩萨是七地初地。应作种种善根不亲近四众。如是趣向。见多花树无香是初地。见香花树是二地。梦见多香花树是三地。见杂花果树是四地。见无叶花树是五地。见天花树是六地。若见菩提树是七地。除在恶知识手慢缓不勤精进魔业。上地一切成就见

复次金刚摧。菩萨若梦中见未曾有城。此是六地初地。此菩萨有业障。此无生法忍。先修坚固三昧空三昧。无碍心极苦行。如是清净。梦见初起城是初地。见作竟城是二地。见城中街市成就是三地。见游戏处成就是四地。见池水成就是六地。除在恶知识手慢缓不精进魔业。上地具足见

复次金刚摧菩萨。若菩萨梦中见阿耨龙王池。此是八地初地。少众烦恼彼疾出生明。若无奸诈勤修进行不顾身命。一切所须满适他意。如是清净。若见阿耨龙池岸际此是初地。若见池中是二地。若一切见是三地。若手触水是四地。若洗是五地。若岸际坐是六地。若见阿耨龙王是七地。若入龙宫增与气力是八地。除魔业九地。复次金刚摧菩萨。若菩萨梦见天子。此菩萨上地五地见处处地。彼少业障少魔业。犹如微滴。应三月勤修寂静除业障得明净。如是人应念十方佛。应修不愁恼。彼若见四大天王众。是见六地见三十三天是七地。见兜率天是八地。见梵天众是九地。见净居天是十地。初地相应。一切见魔业。成就善心。见一切十地

复次金刚摧。菩萨若梦见龙。此是见八地处处见。当成就慎忍。虽勤精进数数废稽。勤修方便数复放舍。彼所有财封。当以供给法师。乃至所爱之物悉以舍与。然后趣向。若山上见龙是初地。若旷野见是二地。若池岸上见是三地。若林中见是四地。若人众中见是五地。若王城中见是六地。若多人众围绕见是七地。若空中见是八地。除魔业业障初地六地

复次金刚摧。菩萨若梦自见向余方阎浮提是初地六地。若得忍彼少于障。若不勤修。不得于明。若懈怠奸诈亲近彼。若生信如是清净。若不乐见阎浮提是初地。若乐见是二地。若见村落城邑可爱是三地。若见园观杂花是四地。若见大众喜乐是第五地。若相娱乐是六地除魔业

复次金刚摧。菩萨梦着白衣。此菩萨是见八地初地。此业障清净魔业增盛。彼生乐法心。数复退减功德。多诸艰难。一切物不应悭惜。如是清净。若自见一切所须一切敷具人所喜者。不惜身命。多闻修善根。若着久故好衣。是初地。若见长领新衣是二地。若见长领衣是三地。若见打治衣是四地。若见打治摩衣是五地。若见染衣是六地。若见象色衣是七地。若见天衣是八地

复次金刚摧。菩萨若梦得宝鬘此是初地九地。彼无业障无魔业。当自责己过。不责于他。求修闻法不作斗讼。如是清净。若一种宝鬘是初地。如是二种乃至七种宝鬘是七地。若得转轮王摩尼宝鬘是八地。若见天宝鬘是九地。除魔业。是见初地起业相。若戏笑懈怠。亲近戏笑懈怠不省录人。应当觉知

复次金刚摧。菩萨若见头着花鬘是八地初地。此实有业障。若初中后生定善心。舍一切物不生愁恼。如是清净。若得一色鬘是初地。若得恶色鬘是二地。若得种种色鬘是三地。若得一切花鬘是四地。若得龙花鬘是五地。若得天花鬘是六地。若得天种种花鬘是七地。若得杂天人花鬘是八地

复次金刚摧。菩萨若梦取得乱花。此菩萨是见六地初地。此菩萨应劝化菩萨。若有自在力势不侵抂余人。若取有色无香花是初地。若取有色香花是二地。若取金色花是三地。若种种色花是四地。若取水陆花是五地。若水陆种种杂花是见六地。如是相勤修精进。若魔业若上地若四地。一切适意龙所持来

复次金刚摧。菩萨若梦中打鼓作伎彼是九地。见处处业障魔业增盛。此应勤修多闻精进。于一切众生生平等心。如是清净。若梦空中打鼓是初地。若平地见是二地。若村中见是三地。若大城中见是四地。若大众中见是五地。若屋上见是六地。若山中见是七地。若须弥山顶见是八地。若虚空中见是九地。除勤修智魔业

复次金刚摧。菩萨若梦中见日月蚀。是菩萨初地六地。毁灭善法多诸烦恼。成就恶业。应以一切物施不望业报。如是清净。见日月初出是见初地二地。见云三地。见聚云五地见无尘雾六地。见日月中时除魔业业障

复次金刚摧。菩萨梦中见不净涂身。是菩萨见初地三地。于前身毁骂贤圣。修恶行菩萨。此菩萨应三年中。昼夜三时勤修忏悔。自后更不于余人生轻慢心。应多修信解如是清净。以青淤泥自涂身者是初地。若涂半身是二地。若处处被涂。是三地。乃至六地。应觉魔业

复次金刚摧菩萨。若自梦见作王。此菩萨一切十地见处处地。有厚善根亦有厚艰难。不应于他希望。供养于他不起奸诈。修质直施。所有持戒。与他共不自赞不毁于他。如是以觉道。若在村中恐怖者是初地。若在僧房中是二地。若在园观中是三地。若天祀中是四地。若在大城中是五地。若在山中是六地。若作阎浮提王是七地。若作转轮王是八地。若在海中是九地。若在须弥山顶是十地。除魔业不勤精进。应念诸佛菩萨也

复次金刚摧菩萨。若梦王前若辅相前若大众中。是菩萨是八地。见此杂烦恼。彼应教化众生。应修供养自修清净。如是清净。彼初地施杂众烦恼。二地戒。三地闻。四地定。五地持。六地通。七地说法。八地眷属成就

复次金刚摧菩萨。若梦骑乘在园林中。此菩萨是九地初地。见此菩萨不知是世间利养饮食。为魔所牵缚。少于业障。应供给法师供养所须应习寂默。如是趣向彼。初地无智行。二地无慧。三地无决定智。四地无禅智。五地无无碍智。七地无出生智。八地无庄严智。九地无愿智

复次金刚摧菩萨。若梦见所未见有村落僧坊人众。此菩萨是初地六地。彼多艰难应修念佛。如是清净。修信心施修一切信解。见如是行相者是初地。若卒有所作是二地。若庄严是三地。若见庄严竟是四地。若见四众聚会是五地。若见天众是六地

复次金刚摧菩萨。若梦中得盖是初地七地。见佛所持多艰难不为所屈。彼于说法人不应起恶意。如是清净。若见花盖是初地。若见琉璃盖是二地。若见花及盖是三地。若见物盖是四地。若见画茎盖是五地。若铃网盖是六地。若见宝网盖宝网垂覆是七地。除魔业不勤精进

复次金刚摧菩萨。若菩萨自梦与多人说法。此菩萨一切十地。见彼地地应觉知魔业业障。欲得决定辩当出推求。于一切物不应爱着。于求法人生清净信心。修六和敬戒。如是清净。若梦说云何修行施。此是初地。云何十善法是二地。云何闻是三地。云何头陀德是四地。云何说空是五地。云何说诃责习是六地。云何说无染着是七地。云何说庄严定是八地。云何说庄严佛是九地。云何说妙时是十地。初地施财二地戒财。三地方便财。四地具七财。五地奉给财是。六地决断财。七地决定财。八地通无碍财。九地行财。十地得财。彼初地善根增上。二地戒增上。三地方便增上。四地所作增上。五地十二因缘增上。六地甚深忍增上。七地坏智增上。八地。坏教化众生增上。九地调伏增上。十地坏净国土增上

复次金刚摧菩萨。若自梦见初立城郭。此菩萨是八地。受不退转记。应亲近供养甚深信解。人多决定疑悔法障。彼应供养法师得除疑悔。如是清净。彼中住初地疑道为得佛为不得佛是二地。教化众生智疑是三地。出生定疑是四地。应作智疑是五地。道果疑是六地。出生疑是七地。游戏疑是八地

复次金刚摧菩萨。若梦缚筏浊水中过。彼是七地初地业障魔业增盛。应生增上欲心坚固不坏和合相应。无生明净。若智方便艰难是初地。若欲修勤善身懈怠是二地。若心非时是三地。或时明是四地。若少无畏是五地。若教化艰难是六地。若佛法艰难是七地

复次金刚摧菩萨。若自梦集船。此菩萨是六地。若平等行六波罗蜜有艰难。当行无依六波罗蜜。如是清净。若梦作船未竟是初地作船竟是二地。若梦二船并是三地。若并缚二船是四地。见大众上船是五地。见入船去是六地

复次金刚摧菩萨。若自梦见云雷放电。是菩萨五地初地。彼魔业增上。少于业障。当多思善念舍所爱物。集陀罗尼。如是清净。若见云雨电惊怖是初地。若不惊怖是二地。若忆念法是三地。若住山顶忆念是四地。若空中念是五地。除魔业。若上地龙来集。会奉事所。作不生惊怖

复次金刚摧菩萨。若梦庄严得刀。此菩萨是初地三地。此魔业业障增盛。彼应亲近忍波罗蜜。毗梨耶波罗蜜。般若波罗蜜。如是清净。若是垢腻刀是初地。得无垢刀是二地。得利刀是三地

复次金刚摧菩萨。若梦中得器物。此菩萨是七地。如是相应当修行。彼不定有魔业业障。应勤行四摄法。如是清净。应净除六地退法得增上七地。复次金刚摧菩萨。若自梦示众生道。此是一切十地相。此如是初相应觉业障烦恼障。应供养亲近法师。舍一切物勤修精进。如是趣向。若见乘在道转动是初地。示趣园观道是二地。示趣城道是三地。示阿练若道是四地。示山道是五地。示趣海道是六地。示天道是七地。示声闻道是八地。示菩萨道是九地。示佛道是十地。说示道竟示地初地。觉魔业觉烦恼业。此前六地无过也

复次金刚摧菩萨。若梦中入园林中。此菩萨八地初地。彼梦中受魔业烦恼业。梦惊怖悟已生愁苦。此应当修空听甚深法。应当默然离于睡眠。应亲近决定说道法者。如是清净。若自梦退失王位心生惊怖是初地。梦破戒惊怖是二地。梦法没尽惊怖是三地。梦法师无常惊怖是四地。若梦为火所烧惊怖是五地。梦被惊怖是六地。梦堕山惊怖是七地。梦见世尊入涅槃惊怖是八地。不勤进六地觉魔业。复次金刚摧菩萨。若梦中见五谷聚。此菩萨是八地上地住。初地第二地如是见不勤进。见魔业不要谈说。前身曾供养诸佛。多诸艰难。不依一切世间。不观于舍守护三业。如是清净。梦见聚谷是七地。梦聚三千大千世界谷是八地。若梦五谷聚熟是九地。若梦刈谷是十地

复次金刚摧菩萨。若梦中见治众生病。此菩萨是八地。少于业障魔业增盛。应修大悲勤劝化不生疑悔。如是相应。梦治小儿是初地。若梦治女人是二地。若梦治大人是三地。若梦治热病是四地。若梦治白癞病是五地。若梦治自残病是六地。若梦治干消病是七地。若梦治鬼病是八地。除魔业。应修集忍行成就菩萨大悲善心。复次金刚摧菩萨。若自闻授菩提记。此菩萨。是见十地。此受记魔业业障应觉知。受十地记。初地受道记。二地受菩萨行记。三地受忍记。四地受愿记。五地受三昧记。六地受慧记。七地受方便记。八地受出过声闻辟支佛地一切知记。九地受一生补处记。十地受佛灌顶记。彼修大悲般若波罗蜜善权方便。亲近如是趣向

复次金刚摧菩萨。若梦中觉道此菩萨是初地。应觉大悲应勤修精进。应信善心。如是趣向觉知是八地。动三千大千世界是九地。梦放光诸天大声歌颂喜啸是十地。初地七地不勤进魔业如是相

复次金刚摧菩萨。若梦中得满瓶。此菩萨见一切十地。当如是知。若村中得是初地。若门中得是二地。若道中得是三地。若树下得是四地。若住得是五地。若坐得是六地。若山顶头得是七地。若空中得是八地。若食时得是九地。若庄严乘骑。若园观是十地。此地地魔业业障。应觉如是清净趣向。尔时世尊。而说偈言

  如是相所得　　决定无有疑
  大士应如是　　莫见他少短
  人德难可量　　大海可炽火
  火中可生水　　此一一有相
  若退于菩提　　终无有是处
  若以于两肩　　顶戴于须弥
  游至于十方　　恒河沙世界
  如是之相貌　　此事犹可作
  如此菩提心　　终无有退转
  大地可反覆　　菩提心退转
  终无有是处　　此中少功德
  若有善心人　　以向无上道
  有四法无量　　世间无智者
  虚空界难知　　如是众生界
  佛知菩提心　　愚者应当知
  诸菩萨所行　　不应生轻毁
  可以一小草　　测量于大海
  众生之所行　　不可得思议
  假使大海水　　尽融为洋铜
  为己身命故　　犹尚可饮尽
  于诸菩萨行　　终不可轻毁
  如饮洋铜苦　　其苦不可数
  或有业障碍　　或为魔所乱
  彼人受生处　　终无有忧悔
  若人为乐故　　于恶色愚痴
  破戒可厌恶　　不可恭敬者
  如是等人所　　不应生轻慢
  众生之所行　　甚难可得知
  犹如舍利弗　　寂默入禅定
  能于一心中　　唯知五十心
  犹如诸世尊　　一念知无量
  不应于诸佛　　而生于疑心
  犹如阿罗汉　　不知自境界
  况复当能知　　众生之境界
  是故一切人　　不应作是言
  我能知众生　　心中之所念
  我见染服人　　须臾着白衣
  如是念念间　　念念有变异
  况谁能复知　　真实者愚患
  譬如阿阇世　　杀害于己父
  又于如来所　　而生恶逆心
  还于一念中　　深悔过罪心
  即能除罪报　　脱于恶道苦
  况有能自生　　清净善心者
  此心或时缚　　此心或时解
  此身是无记　　亦无有所知
  云何令此身　　而有于过恶
  是身亦不应　　亲近于身色
  亦复所不应　　杀害他人身
  譬如真净金　　堕于不净中
  本性常清净　　不净不能损
  彼人虽贪乐　　行于世间法
  彼人实功德　　善心无损减
  王子长者子　　众中作戏笑
  一切诸大王　　见者悉喜乐
  此众生中行　　或在天人中
  或食毒不死　　或捉火不烧
  况于知觉者　　世间愚痴人
  不能夺痴行　　缘觉及声闻
  不如施菩萨　　清净心福田
  平等犹如佛　　菩萨等如佛
  见善心甚深　　譬如恒河沙
  诸佛世界中　　满中七宝施
  若书持此经　　欲比其功德
  倍数无比喻　　善得于命利
  菩提心不失　　若人为财故
  入于大海中　　必当获大利
  若持一切经　　能为多人说
  不闻于此经　　不知众生行
  以是因缘故　　应当知胜如
  不自赞己德　　不应谤毁他
  善心行清行　　若欲速觉悟
  第一菩提道　　乐阿练若处
  常护诸情根　　勤修于精进
  远离于亲里　　修第一义慈
  如是当速疾　　得于菩提道

尔时世尊。说此经时。六万天人。得不退于阿耨多罗三藐三菩提。十八那由他天人未发心者。令发菩提之心。闻此经故。除舍八十劫生死之罪。是故若欲不舍菩提者。当受持此经读诵通利善思念之。勤于方便忍受欢喜奉行。尔时众中十千菩萨。欲退菩提心生于疑悔。欲还归家。不知障及魔业过。闻说此经。舍除罪过。于世尊前。生少信心。于此世界。当与弥勒菩萨一时成佛。净除二十劫魔业。不起此坐。住一生补处。当生他方世界。弥勒成佛时。当一时成佛。彼除二十劫魔业及烦恼故。菩萨但闻此经。尚能多作利益。况受持读诵显说。佛说此经已。天人阿修罗欢喜奉行

大宝积经卷第十六大宝积经卷第十七

        大唐三藏菩提流志奉　诏译

    无量寿如来会第五之一

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。皆是诸大声闻众所知识。其名曰尊者阿若憍陈如。马胜。大名有贤。无垢。须跋陀罗。善称圆满。憍梵钵提。优楼频蠡迦叶。那提迦叶。伽耶迦叶。摩诃迦叶。舍利弗。大目揵连。摩诃迦旃延。摩诃劫宾那。摩诃注那。满慈子。阿尼楼驮。离波多。上首王。住彼岸摩俱罗。难陀。有光善来。罗睺罗。阿难陀等。而为上首。复有菩萨摩诃萨众。所谓普贤菩萨。文殊师利菩萨。弥勒菩萨。及贤劫中诸菩萨摩诃萨众。前后围绕。又与贤护等十六丈夫众俱。所谓善思惟义菩萨。慧辩才菩萨。观无住菩萨。善化神通菩萨。光幢菩萨。智上菩萨。寂根菩萨。慧愿菩萨。香象菩萨。宝幢菩萨等。而为上首。咸共遵修普贤之道。满足菩萨一切行愿。安住一切功德法中。到诸佛法究竟彼岸。愿于一切世界之中成等正觉。又愿生彼兜率陀天。于彼寿终降生右胁见行七步。放大光明。普佛世界六种震动。而自唱言。我于一切世间。最为尊贵。释梵诸天咸来亲奉。又见习学书计历数声明伎巧医方养生符印。及余博戏擅美过人。身处王宫厌诸欲境。见老病死悟世非常。捐舍国位。踰城学道。解诸缨络及迦尸迦。被服袈裟六年苦行。能于五浊刹中作斯示见。顺世间故浴尼连河行趣道场。龙王迎赞。诸菩萨众右绕称扬。菩萨尔时。受草自敷菩提树下。结加趺坐。又见魔众合围将加危害。菩萨以定慧力降伏魔怨。成无上觉。梵王劝请转于法轮。勇猛无畏。佛音震吼击法鼓吹法螺。建大法幢然正法炬。摄受正法及诸禅定。雨大法雨泽润含生。震大法雷开悟一切。诸佛刹土普照大光。世界之中地皆震动。魔宫摧毁惊怖波旬。破烦恼城堕诸见网。远离黑法生诸白法。于佛施食能受能消。为调众生宣扬妙理。或见微笑放百千光。升灌顶阶受菩提记。或成佛道。见入涅槃。使无量有情皆得漏尽。成熟菩萨无边善根。如是诸佛刹中皆能示见。譬如幻师善知幻术而能示见男女等相。于彼相中实无可得。如是如是诸菩萨等。善学无边幻术功德故。能示见变化相应。能善了知变化之道故。示诸佛土见大慈悲。一切群生普皆饶益菩萨愿行。成就无疆无量义门。通达平等一切善法具足修成。诸佛刹中平等趣入。常为诸佛劝进加威。一切如来识知印可。为教菩萨作阿阇梨。常习相应无边诸行。通达一切法界所行。能善了知有情及土。亦常发趣供诸如来。见种种身犹如影像。善学因陀罗网能破魔网。坏诸见网入有情网。能超烦恼眷属及魔侣魔人。远出声闻辟支佛地。入空无相无愿法门。而能安住方便善巧。初不乐入二乘涅槃。得无生无灭诸三摩地。及得一切陀罗尼门。广大诸根辩才决定。于菩萨藏法善能了知。佛华三昧随时。悟入。具一切种甚深禅定。一切诸佛皆悉见前。于一念中遍游佛土。周旋往返不异其时。于难非难边能了诸边。敷演实际。差别善知。得佛辩才住普贤行。善能分别众生语言。超过世间一切之法。善知一切出世间法。得资具自在波罗蜜多。荷担有情为不请友。能持一切如来法藏。安住不断一切佛种。哀愍有情能开法眼。闭诸恶趣开善趣门。普观有情能作父母兄弟之想。又观众生如己身想。证得一切。赞叹功德波罗蜜多。能善了知赞叹如来一切功德。及余称赞诸功德法。如是菩萨摩诃萨众无量无边。皆来集会。尔时尊者阿难。从坐而起整理衣服。偏袒右肩右膝着地。合掌向佛白言。大德世尊。身色诸根悉皆清净。威光赫奕如融金聚。又如明镜凝照光晖。从昔已来初未曾见。喜得瞻仰生希有心。世尊今者。入大寂定行如来行皆悉圆满。善能建立大丈夫行。思惟去来现在诸佛。世尊何故住斯念耶。尔时佛告阿难。汝今云何能知此义。为有诸天来告汝耶。为以见我及自知耶。阿难白佛言。世尊。我见如来光瑞希有故发斯念非因天等。佛告阿难。善哉善哉汝今快问。善能观察微妙辩才。能问如来如是之义。汝为一切如来应正等觉。及安住大悲利益群生如优昙花希有大士出见世间。故问斯义。又为哀愍利乐诸众生故。能问如来如是之义。阿难如来应正等觉。善能开示无量知见。何以故。如来知见无有障碍。阿难。如来应正等觉欲乐住世。能于食顷住无量无数百千亿那由他劫。若复增过如上数量。而如来身及以诸根无有增减。何以故。如来得三昧自在到于彼岸。于一切法最胜自在。是故阿难谛听善思念之。吾当为汝分别解说。阿难白佛言。唯然世尊。愿乐欲闻

尔时佛告阿难。往昔过阿僧祇无数大劫。有佛出现号曰然灯。于彼佛前极过数量。有苦行佛出兴于世。苦行佛前复有如来号为月面。月面佛前过于数量。有旃檀香佛于彼佛前有苏迷卢积佛。卢积佛前复有妙高劫佛。如是展转。有离垢面佛。不染污佛。龙天佛。山声王佛。苏迷卢积佛。金藏佛。照曜光佛。光帝佛。大地种姓佛。光明炽盛琉璃金光佛。月像佛。开敷花庄严光佛。妙海胜觉游戏神通佛。金刚光佛。大阿伽陀香光佛。舍离烦恼心佛。宝增长佛。勇猛积佛。胜积佛。持大功德法施神通佛。映蔽日月光佛。照曜琉璃佛。心觉花佛。月光佛。日光佛。花璎珞色王开敷神通佛。水月光佛。破无明暗佛。真珠珊瑚盖佛。底沙佛。胜花佛。法慧吼佛。有师子吼鹅雁声佛。梵音龙吼佛。如是等佛出现于世。相去劫数皆过数量。彼龙吼佛未出世前无央数劫。有世主佛。世主佛前无边劫数有佛出世。号世间自在王如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛世尊。阿难。彼佛法中有一比丘。名曰法处。有殊胜行愿及念慧力增上。其心坚固不动。福智殊胜人相端严。阿难。彼法处比丘。往诣世间自在王如来所。偏袒右肩顶礼佛足。向佛合掌。以颂赞曰

  如来无量无边光　　举世无光可能喻
  一切日月摩尼宝　　佛之光威皆映蔽
  世尊能演一音声　　有情各各随类解
  又能现一妙色身　　普使众生随类见
  戒定慧进及多闻　　一切有情无与等
  心流觉慧如大海　　善能了知甚深法
  惑尽过亡应受供　　如是圣德惟世尊
  佛有殊胜大威光　　普照十方无量刹
  我今称赞诸功德　　冀希福慧等如来
  能救一切诸世间　　生老病死众苦恼
  愿当安住三摩地　　演说施戒诸法门
  忍辱精勤及定慧　　庶当成佛济群生
  为求无上大菩提　　供养十方诸妙觉
  百千俱胝那由他　　极彼恒沙之数量
  又愿当获大神光　　倍照恒沙亿佛刹
  及以无边胜进力　　感得殊胜广净居
  如是无等佛刹中　　安处群生当利益
  十方最胜之大士　　彼皆当往生喜心
  唯佛圣智能证知　　我今希求坚固力
  纵沈无间诸地狱　　如是愿心终不退
  一切世间无碍智　　应当了知如是心

复次阿难。法处比丘。赞佛德已白言世尊。我今发阿耨多罗三藐三菩提心。惟愿如来为我演说如是等法。令于世间得无等等成大菩提。具摄清净庄严佛土。佛告比丘。汝应自摄清净佛国。法处白佛言。世尊。我无威力堪能摄受。唯愿如来说余佛土清净庄严。我等闻已誓当圆满。尔时世尊。为其广说二十一亿清净佛土具足庄严。说是法时经于亿岁。阿难。法处比丘。于彼二十一亿诸佛土中。所有严净之事悉皆摄受。既摄受已。满足五劫思惟修习。阿难白佛言。世尊彼世间自在王如来寿量几何。世尊告曰。彼佛寿量满四十劫。阿难。彼二十一俱胝佛刹。法处比丘所摄佛国超过于彼。既摄受已往诣世间自在王如来所。顶礼双足右绕七匝。却住一面白言世尊。我已摄受具足功德严净佛土。佛言。今正是时。汝应具说令众欢喜。亦令大众皆当摄受圆满佛土。法处白言。唯愿世尊。大慈留听。我今将说殊胜之愿

若我证得无上菩提。国中有地狱饿鬼畜生趣者。我终不取无上正觉

若我成佛。国中众生有堕三恶趣者。我终不取正觉

若我成佛。国中有情若不皆同真金色者。不取正觉

若我成佛。国中有情形貌差别有好丑者。不取正觉

若我成佛。国中有情不得宿念。下至不知亿那由他百千劫事者。不取正觉

若我成佛。国中有情若无天眼。乃至不见亿那由他百千佛国土者。不取正觉

若我成佛。国中有情不获天耳。乃至不闻亿那由他百千踰缮那外佛说法者。不取正觉若我成佛。国中有情无他心智。乃至不知亿那由他百千佛国土中有情心行者。不取正觉

若我成佛。国中有情不获神通自在波罗蜜多。于一念顷不能超过亿那由他百千佛刹者。不取正觉

若我成佛。国中有情起于少分我我所想者。不取菩提

若我成佛。国中有情若不决定成等正觉证大涅槃者。不取菩提

若我成佛。光明有限。下至不照亿那由他百千及算数佛刹者。不取菩提

若我成佛。寿量有限乃至俱胝那由他百千及算数劫者。不取菩提

若我成佛。国中声闻无有知其数者。假使三千大千世界满中有情及诸缘觉。于百千岁尽其智算亦不能知。若有知者不取正觉

若我成佛。国中有情寿量有限齐者。不取菩提。唯除愿力而受生者

若我成佛。国中众生若有不善名者。不取正觉

若我成佛。彼无量刹中无数诸佛。不共咨嗟称叹我国者。不取正觉

若我证得无上觉时。余佛刹中诸有情类。闻我名已所有善根心心回向愿生我国。乃至十念若不生者。不取菩提。唯除造无间恶业诽谤正法及诸圣人

若我成佛。于他刹土。有诸众生发菩提心。及于我所起清净念。复以善根回向愿生极乐。彼人临命终时。我与诸比丘众。现其人前。若不尔者。不取正觉

若我成佛。无量国中所有众生。闻说我名以己善根回向极乐。若不生者。不取菩提

若我成佛。国中菩萨皆不成就三十二相者。不取菩提

若我成佛。于彼国中。所有菩萨于大菩提。咸悉位阶一生补处。唯除大愿诸菩萨等。为诸众生被精进甲。勤行利益修大涅槃。遍诸佛国行菩萨行。供养一切诸佛如来。安立洹沙众生住无上觉。所修诸行复胜于前。行普贤道而得出离。若不尔者不取菩提

若我成佛。国中菩萨每于晨朝。供养他方乃至无量亿那由他百千诸佛。以佛威力即以食前还到本国。若不尔者不取菩提

若我成佛。于彼刹中诸菩萨众。所须种种供具。于诸佛所殖诸善根。如是色类不圆满者不取菩提

若我当成佛时。国中菩萨说诸法要。不善顺入一切智者。不取菩提

若我成佛。彼国所生诸菩萨等。若无那罗延坚固力者。不取正觉

若我成佛。周遍国中诸庄严具。无有众生能总演说。乃至有天眼者。不能了知所有杂类形色光相。若有能知及总宣说者。不取菩提若我成佛。国中具有无量色树高百千由旬。诸菩萨中有善根劣者若不能了知不取正觉若我成佛。国中众生读诵经典教授敷演。若不获得胜辩才者。不取菩提

若我成佛。国中菩萨有不成就无边辩才者。不取菩提

若我成佛。国土光净遍无与等。彻照无量无数不可思议诸佛世界。如明镜中现其面像。若不尔者。不取菩提

若我成佛。国界之内地及虚空有无量种香。复有百千亿那由他数众宝香炉。香气普熏遍虚空界。其香殊胜超过人天珍。奉如来及菩萨众。若不尔者。不取菩提

若我成佛。周遍十方。无量无数不可思议无等界众生之辈。蒙佛威光所照触者。身心安乐超过人天。若不尔者不取正觉

若我成佛。无量不可思议无等界诸佛刹中菩萨之辈闻我名已。若不证得离生获陀罗尼者。不取正觉

若我成佛。周遍无数不可思议无有等量。诸佛国中所有女人。闻我名已得清净信。发菩提心厌患女身。若于来世不舍女人身者。不取菩提

若我成佛。无量无数不可思议无等佛刹菩萨之众。闻我名已得离生法。若不修行殊胜梵行。乃至到于大菩提者。不取正觉

若我成佛。周遍十方无有等量诸佛刹中所有菩萨。闻我名已五体投地。以清净心修菩萨行。若诸天人不礼敬者。不取正觉

若我成佛。国中众生所须衣服随念即至。如佛命善来比丘法服自然在体。若不尔者。不取菩提

若我成佛。诸众生类才生我国中。若不皆获资具心净安乐。如得漏尽诸比丘者。不取菩提

若我成佛。国中群生。随心欲见诸佛净国殊胜庄严。于宝树间悉皆出现。犹如明镜见其面像若不尔者。不取菩提

若我成佛。余佛刹中所有众生闻我名已。乃至菩提诸根有阙德用非广者。不取菩提

若我成佛。余佛刹中所有菩萨。闻我名已若不皆善分别胜三摩地名字语言。菩萨住彼三摩地中。于一刹那言说之顷。不能供养无量无数不可思议无等诸佛。又不现证六三摩地者。不取正觉

若我成佛。余佛土中有诸菩萨。闻我名已。寿终之后。若不得生豪贵家者。不取正觉

若我成佛。余佛刹中所有菩萨闻我名已。若不应时修菩萨行。清净欢喜得平等住具诸善根。不取正觉

若我成佛。他方菩萨闻我名已。皆得平等三摩地门。住是定中常供无量无等诸佛。乃至菩提终不退转。若不尔者。不取正觉

若我成佛。国中菩萨随其志愿。所欲闻法自然得闻。若不尔者。不取正觉

若我证得无上菩提。余佛刹中所有菩萨闻我名已。于阿耨多罗三藐三菩提有退转者。不取正觉

若我成佛。余佛国中所有菩萨。若闻我名应时不获一二三忍。于诸佛法不能现证不退转者。不取菩提

尔时佛告阿难。彼法处比丘。于世间自在王如来前。发此愿已。承佛威神。而说颂曰

  今对如来发弘誓　　当证无上菩提日
  若不满足诸上愿　　不取十力无等尊
  心或不堪常行施　　广济贫穷免诸苦
  利益世间使安乐　　不成救世之法王
  我证菩提坐道场　　名闻不遍十方界
  无量无边异佛刹　　不取十力世中尊
  方趣无上大菩提　　出家为求于欲境
  于彼念慧行无有　　不作调御天人师
  愿获如来无量光　　普照十方诸佛土
  能灭一切贪恚痴　　亦断世间诸恶趣
  愿得光开净慧眼　　于诸有中破冥暗
  除灭诸难使无余　　安处天人大威者
  修习本行已清净　　获得无量胜威光
  日月诸天摩尼火　　所有光晖皆映蔽
  最胜丈夫修行已　　于彼贫穷为伏藏
  圆满善法无等伦　　于大众中师子吼
  往昔供养自然智　　多劫勤修诸苦行
  为求最胜诸慧蕴　　满足本愿天人尊
  如来知见无所碍　　一切有为皆能了
  愿我当成无与等　　最胜智者真导师
  我若当证大菩提　　如斯弘誓实圆满
  愿动三千大千界　　天众空中皆雨花
  是时大地咸震动　　天花鼓乐满虚空
  并雨栴檀细末香　　唱言未来当作佛

佛告阿难。彼法处比丘。于世间自在王如来。及诸天人魔梵沙门婆罗门等前。广发如是大弘誓愿。皆已成就世间希有。发是愿已。如实安住种种功德。具足庄严威德广大清净佛土。修习如是菩萨行时。经于无量无数不可思议。无有等等亿那由他百千劫内。初未曾起贪嗔及痴欲害恚想。不起色声香味触想。于诸众生常乐爱敬犹如亲属。其性温和易可同处。有来求者不逆其意。善言劝谕无不从心。资养所须趣支身命。少欲知足常乐虚闲。禀识聪明而无矫妄。其性调顺无有暴恶。于诸有情常怀慈忍。心不诈谄亦无懈怠。善言策进求诸白法。普为群生勇猛无退。利益世间大愿圆满。奉事师长敬佛法僧。于菩萨行常被甲胄。志乐寂静离诸染着。为令众生常修白法。于善法中而为上首。住空无相无愿无作无生不起不灭无有憍慢。而彼正士行菩萨道时。常护语言不以语言害他及己。常以语业利己及人。若入王城及诸村落。虽见诸色心无所染。以清净心不爱不恚。菩萨尔时。于檀波罗蜜起自行已。又能令他行于惠施。于尸波罗蜜乃至般若波罗蜜。起前二行皆悉圆满。由成如是诸善根故。所生之处有无量亿那由他百千伏藏自然涌出。复令无量无数不可思议无等无边诸众生类。安住阿耨多罗三藐三菩提。如是无边诸菩萨众起诸妙行。供养奉事于诸世尊乃至成佛。皆不可以语言分别之所能知。或作轮王。帝释。苏焰摩天。兜率陀天。善化天。他化自在天。大梵天王。皆能奉事供养诸佛。及能请佛转于法轮。若作阎浮提王及诸长者。宰官婆罗门刹帝利等。诸种姓中皆能尊重供养诸佛。又能演说无量法门。从此永弃世间成无上觉。然彼菩萨能以上妙衣服卧具饮食医药。尽形供养一切如来得安乐住。如是种种圆满善根。非以语言能尽边际。口中常出栴檀妙香。其香普熏无量无数乃至亿那由他百千世界。复从一切毛孔。出过人天优钵罗花上妙香气。随所生处相好端严殊胜圆满。又得诸资具自在波罗蜜多。一切服用周遍无乏。所谓诸宝香花幢幡缯盖。上妙衣服饮食汤药。及诸伏藏珍玩所须。皆从菩萨掌中自然流出。身诸毛孔流出。一切人天音乐。由是因缘能令无量无数不可思议诸众生等。安住阿耨多罗三藐三菩提。阿难。我今已说法处菩萨本所修行

尔时阿难白佛言。世尊。彼法处菩萨成菩提者。为过去耶为未来耶。为今现在他方世界耶

佛告阿难。西方去此十万亿佛刹。彼有世界名曰极乐。法处比丘在彼成佛。号无量寿。今现在说法。无量菩萨及声闻众恭敬围绕。阿难。彼佛光明普照佛刹。无量无数不可思议。我今略说。光照东方如恒河沙等国土。南西北方四维上下亦复如是。唯除诸佛本愿威神所加。悉皆照烛。是诸佛光。或有加一寻者。或有加一由旬乃至亿那由他百千由旬光者。或普照佛刹者。阿难。以是义故。无量寿佛复有异名。谓无量光。无边光。无著光。无碍光。光照王端严光。爱光。喜光。可观光。不思议光。无等光不可称量光。映蔽日光。映蔽月光。掩夺日月光。彼之光明清净广大。普令众生身心悦乐。复令一切余佛刹中。天龙夜叉阿修罗等皆得欢悦。阿难。我今开示彼佛光明。满足一劫说不能尽。复次阿难。彼无量寿如来。诸声闻众不可称量知其边际。假使比丘满亿那由他百千数量。皆如大目揵连神通自在。于晨朝时周历大千世界。须臾之顷还至本处。彼经亿那由他百千岁数。欲共计算无量寿佛初会之中诸声闻众。尽其神力乃至灭度。于百分中不知其一。于千分百千分乃至邬波尼杀昙分中。亦不知其一。阿难。譬如大海深八万四千由旬。以目极观不知边际。若有丈夫。析一毛端为五十分。以其一分于大海中沾取一滴。阿难。彼之水滴比于大海。何者为多。阿难白言。假使取千由旬水。犹以为少。况以毛端一分而可方之。佛告阿难。假使比丘满亿那由他百千数量。皆如大目揵连。经百千亿那由他岁。皆共算数彼无量寿如来初会声闻。所知数量如彼毛端一滴之水。余不测者犹如大海。诸菩萨摩诃萨众亦复如是。非以算计之所能知。阿难。彼佛寿命无量无边。不可知其劫数多少。声闻菩萨及诸天人寿量亦尔。阿难白佛言。世尊。彼佛出世于今几时。能得如是无量寿命。佛告阿难。彼佛受生经今十劫。复次阿难。彼极乐界无量功德具足庄严。国土丰稔天人炽盛。志意和适常得安隐。无有地狱畜生及琰魔王界。有种种香周遍芬馥。种种妙花亦皆充满。有七宝幢周布行列。其宝幢上悬诸幡盖及众宝铃。具足百千诸妙杂色。阿难。彼如来国多诸宝树。或纯黄金白银琉璃颇梨。赤珠马瑙玉树。唯一宝成不杂余宝。或以二宝乃至七宝庄严。阿难。彼金为树者。以金为根茎。白银为叶及以花果。白银之树银为根茎。黄金为叶及以花果。马瑙之树马瑙根茎。美玉为叶及以花果。美玉树者。玉为根茎七宝为叶及诸花果。或有金树。黄金为根。白银为茎。琉璃为枝。颇梨为条。赤珠为叶。马瑙为花。美玉为果。或有银树。以银为根黄金为茎。余枝果等饰同金树。琉璃树者。琉璃为根黄金为茎。白银为枝颇梨为条。赤珠为叶马瑙为花美玉为果。颇梨真珠马瑙等树。诸宝转饰皆若琉璃。复有玉树。玉为其根黄金为茎。白银为枝琉璃为条。颇梨为叶赤珠为花马瑙为果。复有无量摩尼珠等宝庄严树周遍其国。是诸宝树光辉赫奕世无能比。以七宝罗网而覆其上。其网柔软如兜罗绵。复次阿难。无量寿佛有菩提树。高十六亿由旬。枝叶垂布八亿由旬。树本隆起高五千由旬周圆亦尔。其条叶花果。常有无量百千种种妙色。及诸珍宝殊胜庄严。谓月光摩尼宝。释迦毗楞伽宝。心王摩尼宝。海乘流注摩尼宝。光辉遍照超过人天。于其树上有诸金锁垂宝璎珞周遍庄严。谓卢遮迦宝。末瑳宝。及赤白青色真珠等宝。以为璎珞。有师子云聚宝等。以为其锁饰诸宝柱。又以纯金真珠杂宝铃铎以为其网。庄严宝锁弥覆其上。以颇梨万字半月宝等互相映饰。微风吹动出种种声。令千世界诸众生等随乐差别。于甚深法证无生忍。阿难。彼千世界诸有情等。闻此音已住不退转无上菩提。及无量无数有情得无生法忍

复次阿难。若有众生。见菩提树闻声嗅香。尝其果味触其光影念。树功德。由此因缘乃至涅槃。五根无患心无散乱。皆于阿耨多罗三藐三菩提得不退转。复由见彼菩提树故获三种忍。何等为三。一者随声忍。二者随顺忍。三者无生法忍。此皆无量寿佛本愿威神见所加及往修静虑。无比喻故。无缺减故。善修习故。善摄受故。善成就故

大宝积经卷第十七大宝积经卷第十八

        大唐三藏菩提流志奉　诏译

    无量寿会第五之二

复次阿难。彼极乐界。无诸黑山。铁围山。大铁围山。妙高山等。阿难白佛言。世尊。其四天王天三十三天既无。诸山依何而住。佛告阿难。于汝意云何。妙高已上有夜摩天。乃至他化自在天及色界诸天等。依何而住。阿难白佛言。世尊。不可思议业力所致。佛语阿难。不思议业汝可知耶。答言不也。佛告阿难。诸佛及众生善根业力。汝可知耶。答言不也。世尊。我今于此法中实无所惑。为破未来疑网故发斯问。佛告阿难。彼极乐界其地无海而有诸河。河之狭者满十由旬。水之浅者十二由旬。如是诸河深广之量。或二十三十乃至百数。或有极深广者至千由旬。其水清冷具八功德。浚流恒激出微妙音。譬若诸天百千伎乐。安乐世界其声普闻。有诸名花沿流而下。和风微动出种种香。居两岸边多栴檀树。修条密叶交覆于河。结实开花芳辉可玩。群生游乐随意往来。或有涉河濯流嬉戏。感诸天水善顺物宜。深浅寒温曲从人好。阿难。大河之下地布金砂。有诸天香世无能喻随风散馥。杂水流馚天曼陀罗花。优钵罗花。波头摩花。拘物头华。芬陀利花。弥覆其上。复次阿难。彼国人众。或时游览同萃河滨。有不愿闻激流之响。虽获天耳终竟不闻。或有愿闻。即时领悟百千万种喜爱之声。所谓佛法僧声。止息之声。无性声。波罗蜜声。十力四无所畏声。神通声。无作声。无生无灭声。寂静声。边寂静声。极寂静声。大慈大悲声。无生法忍声。灌顶受位声。得闻如是种种声已。获得广大爱乐欢悦。而与观察相应。厌离相应。灭坏相应。寂静相应。边寂静相应。极寂静相应。义味相应。佛法僧相应。力无畏相应。神通相应。止息相应。菩提相应。声闻相应。涅槃相应

复次阿难。彼极乐世界。不闻诸恶趣名。边无障碍烦恼覆蔽名。无有地狱琰摩畜生名。边无八难名。亦无苦受不苦不乐受名。尚无假设何况实苦。是故彼国名为极乐。阿难。我今略说极乐因缘。若广说者穷劫不尽。复次阿难。彼极乐世界所有众生。或已生。或现生。或当生。皆得如是诸妙色身。形貌端正神通自在。福力具足受用种种宫殿园林。衣服饮食香华璎珞。随意所须悉皆如念。譬如他化自在诸天

复次阿难。彼佛国中有微细食。诸有情类尝无啖者。如第六天随所思念。如是饮食即同食已。色力增长而无便秽。复有无量如意妙香。涂香。末香。其香普熏彼佛国界。及散花幢幡亦皆遍满。其有欲闻香者随愿即闻。或不乐者终无所受。复有无量上妙衣服宝冠环钏耳珰璎珞花鬘带锁诸宝庄严。无量光明百千妙色。悉皆具足自然在身。复有金银真珠妙宝之网。悬诸宝铃周遍严饰。若诸有情所须宫殿楼阁等。随所乐欲高下长短广狭方圆。及诸床座妙衣敷上。以种种宝而严饰之。于众生前自然出现。人皆自谓各处其宫。复次阿难。极乐国土。所有众生无差别相。顺余方俗有天人名。阿难。譬如下贱半挓迦人。对于轮王则无可谕。威光德望悉皆无有。又如帝释方第六天。威光等类皆所不及。园苑宫殿衣服杂饰。尊贵自在阶位神通。及以变化不可为比。唯受法乐则无差别。阿难应知。彼国有情犹如他化自在天王。阿难。彼极乐界。于晨朝时周遍四方。和风微动不逆不乱。吹诸杂花种种香气。其香普熏周遍国界。一切有情为风触身。安和调适犹如比丘得灭尽定。其风吹动七宝树林。华飘成聚高七人量。种种色光照曜佛土。譬如有人以花布地手按令平。随杂色花间错分布。彼诸花聚亦复如是。其花微妙广大柔软如兜罗绵。若诸有情足蹈彼花没深四指。随其举足还复如初。过晨朝已其花自然没入于地。旧花既没大地清净。更雨新花还复周遍。如是中时晡时。初中后夜飘花成聚亦复如是。阿难。一切广大珍奇之宝。无有不生极乐界者。阿难。彼佛国中有七宝莲花。一一莲花有无量百千亿叶。其叶有无量百千珍奇异色。以百千摩尼妙宝庄严。覆以宝网。转相映饰。阿难。彼莲花量或半由旬。或一二三四乃至百千由旬者。是一一花出三十六亿那由他百千光明。一一光中出三十六亿那由他百千诸佛。身如金色具三十二大丈夫相。八十随好殊胜庄严。放百千光普照世界。是诸佛等。现往东方为众说法。皆为安立无量有情于佛法中。南西北方四维上下亦复如是。复次阿难。极乐世界无有昏闇。亦无火光。涌泉陂湖彼皆非有。亦无住着家室林苑之名。及表示之像幼童色类。亦无日月昼夜之像。于一切处标式既无亦无名号。唯除如来所加威者。阿难。彼国众生若当生者。皆悉究竟无上菩提到涅槃处。何以故。若邪定聚及不定聚。不能了知建立彼因故。阿难。东方如恒沙界。一一界中如恒沙佛。彼诸佛等各各称叹阿弥陀佛无量功德。南西北方四维上下诸佛称赞亦复如是。何以故。他方佛国所有众生。闻无量寿如来名号。乃至能发一念净信欢喜爱乐。所有善根回向愿生无量寿国者。随愿皆生得不退转。乃至无上正等菩提。除五无间诽毁正法及谤圣者。阿难。若有众生。于他佛刹发菩提心。专念无量寿佛。及恒种殖众多善根。发心回向愿生彼国。是人临命终时。无量寿佛与比丘众。前后围绕现其人前。即随如来往生彼国得不退转。当证无上正等菩提。是故阿难。若有善男子善女人。愿生极乐世界欲见无量寿佛者。应发无上菩提心。复当专念极乐国土。积集善根应持回向。由此见佛生彼国中。得不退转乃至无上菩提。阿难。若他国众生发菩提心。虽不专念无量寿佛。亦非恒种众多善根。随己修行诸善功德。回向彼佛愿欲往生。此人临命终时。无量寿佛即遣化身。与比丘众前后围绕。其所化佛光明相好与真无异。现其人前摄受导引。即随化佛往生其国。得不退转无上菩提。阿难。若有众生住大乘者。以清净心向无量寿如来。乃至十念念无量寿佛愿生其国。闻甚深法即生信解。心无疑惑乃至获得一念净心。发一念心念无量寿佛。此人临命终时。如在梦中见无量寿佛。定生彼国得不退转无上菩提。阿难。以此义利故。无量无数不可思议无有等等无边世界诸佛如来。皆共称赞无量寿佛所有功德

佛告阿难。东方如恒河沙界。一一界中有如恒沙菩萨。为欲瞻礼供养无量寿佛及诸圣众来诣佛所。南西北方四维上下。亦复如是。尔时世尊。而说颂曰

  东方诸佛刹　　数如恒河沙
  如是佛土中　　恒沙菩萨众
  皆现神通来　　礼无量寿佛
  三方诸圣众　　礼觐亦同归
  彼于沙界中　　道光诸辩论
  住深禅定乐　　四无所畏心
  各赍众妙花　　名香皆可悦
  并奏诸天乐　　百千和雅音
  以献天人师　　名闻十方者
  究竟威神力　　善学诸法门
  种种供养中　　勤修无懈倦
  功德智慧景　　能破诸幽冥
  咸以尊重心　　奉诸珍妙供
  彼观殊胜刹　　菩萨众无边
  愿速成菩提　　净界如安乐
  世尊知欲乐　　广大不思议
  微笑现金容　　告成如所愿
  了诸法如幻　　佛国犹梦响
  恒发誓庄严　　当成微妙土
  菩萨以愿力　　修胜菩提行
  知土如影像　　发诸弘誓心
  若求遍清净　　殊胜无边刹
  闻佛圣德名　　愿生安乐国
  若有诸菩萨　　志求清净土
  了知法无我　　愿生安乐国

复次阿难。极乐世界所有菩萨。于无上菩提皆悉安住一生补处。唯除大愿能师子吼擐大甲胄摩诃萨众为度群生修大涅槃者。复次阿难。彼佛刹中诸声闻众。皆有身光能照一寻。菩萨光照极百千寻。除二菩萨光明常照三千大千世界。阿难白佛言。世尊。彼二菩萨名为何等。佛告阿难。汝今谛听。彼二菩萨。一名观自在。二名大势至。阿难。此二菩萨从娑婆世界舍寿量已往生彼国。阿难。彼极乐界所生菩萨。皆具三十二相。肤体柔软诸根聪利智慧善巧。于差别法无不了知。禅定神通善能游戏。皆非薄德钝根之流。彼菩萨中有得初忍或第二忍者无量无边。或有证得无生法忍。阿难。彼国菩萨乃至菩提不堕恶趣。生生之处能了宿命。唯除五浊刹中出现于世。阿难。彼国菩萨皆于晨朝。供养他方无量百千诸佛。随所希求种种花鬘涂香末香。幢幡缯盖及诸音乐。以佛神力皆现手中供养诸佛。如是供具广大甚多。无数无边不可思议。若复乐求种种名花。花有无量百千光色。皆现手中奉散诸佛阿难。其所散花。即于空中变成花盖。盖之小者满十由旬。若不更以新花重散。前所散花终不堕落。阿难。或有花盖满二十由旬。如是三十四十乃至千由旬。或等四洲或遍小千中千。乃至三千大千世界。此诸菩萨生希有心得大喜爱。于晨朝时。奉事供养尊重赞叹无量百千亿那由他佛。及种诸善根已。即于晨朝还到本国。此皆由无量寿佛本愿加威及曾供如来。善根相续无缺减故。善修习故。善摄取故。善成就故

复次阿难。彼极乐界诸菩萨众。所说语言与一切智相应。于所受用皆无摄取。遍游佛刹无爱无厌亦无希求。不希求想。无自想。无烦恼想。无我想。无斗诤相违怨嗔之想。何以故。彼诸菩萨。于一切众生。有大慈悲利益心故。有柔软无障碍心。不浊心。无忿恨心。有平等调伏寂静之心。忍心忍调伏心。有等引澄净无散乱心。无覆蔽心。净心。极净心。照曜心。无尘心。大威德心。善心。广大心。无比心。甚深心。爱法心。喜法心。善意心。舍离一切执着心。断一切众生烦恼心。闭一切恶趣心故。行智慧行已成就无量功德。于禅定觉分善能演说。而常游戏无上菩提勤修敷演。肉眼发生能有简择。天眼出现鉴诸佛土。法眼清净能离诸着。慧眼通达到于彼岸。佛眼成就觉悟开示。生无碍慧为他广说。于三界中平等勤修。既自调伏亦能调伏一切有情。能令获得胜奢摩他。于一切法证无所得。善能说法言辞巧妙。勤修供养一切诸佛。摧伏有情一切烦恼。为诸如来之所悦可而能如是。如是思惟。作是思惟时。能集能见一切诸法皆无所得。以方便智修行灭法。善知取舍理非理趣。于理趣非理趣中皆得善巧。于世语言心不爱乐。出世经典诚信勤修。善巧寻求一切诸法。求一切法增长了知。知法本无实不可得。于所行处亦无取舍。解脱老病住诸功德。从本已来安住神通勤修深法。于甚深法而无退转。于难解法悉能通达。得一乘道无有疑惑。于佛教法不由他悟。其智宏深譬之巨海。菩提高广喻若须弥。自身威光超于日月。凡所思择与慧相应。犹如雪山其心洁白。光明普照无边功德烧烦恼薪。方之于火不为善恶之所动摇。心静常安犹如大地。洗涤烦惑如清净水。心无所主犹如火。不着世间犹如风。养诸有情犹如地。观诸世界如虚空。荷载众生犹如良乘。不染世法譬之莲花。远畅法音犹如雷震。雨一切法方之大雨。光蔽贤圣犹彼大仙。善能调伏如大龙象。勇猛无畏如师子王。覆护众生如尼拘陀树。他论不动如铁围山。修慈无量如彼恒河。诸善法王能为前导如大梵天。无所聚积犹如飞鸟。摧伏他论如金翅王。难遇希有如优昙花。最胜丈夫其心正直。无有懈怠能善修行。于诸见中善巧决定。柔和忍辱无嫉妒心。论法无厌求法不倦。常勤演说利益众生。戒若琉璃内外明洁。善闻诸法而为胜宝。其所说言令众悦伏。以智慧力建大法幢。吹大法螺。击大法鼓。常乐勤修建诸法表。由智慧光心无迷惑。远众过失亦无损害。以淳净心离诸秽染。常行惠施永舍悭贪。禀性温和常怀惭耻。其心寂定智慧明察。作世间灯破众生闇。堪受利养殊胜福田。为大导师周济群物。远离憎爱心净无忧。勇进无怖为大法将。了知地狱调伏自他。利益有情拔诸毒箭。为世间解为世间师。引导群生舍诸爱着。永离三垢游戏神通。因力。缘力。愿力。发起力。世俗力。出生力。善根力。三摩地力。闻力。舍力。戒力。忍力。精进力。定力。慧力。奢摩他力。毗钵舍那力。神通力。念力。觉力。摧伏一切大魔军力。并他论法力。能破一切烦恼怨力。及殊胜大力。威福具足相好端严。智慧辩才善根圆满。目净修广人所爱乐。其身清洁远离贡高。以尊重心奉事诸佛。于诸佛所植众善本。拔除憍慢离贪嗔痴。殊胜吉祥应供中最。住胜智境赫奕慧光。心生欢喜雄猛无畏。福智具足无有滞限。但说所闻开示群物。随所闻法皆能解了。于菩提分法勇猛勤修。空无相愿而常安住。及不生不灭诸三摩地。行遍道场远二乘境。阿难。我今略说彼极乐界所生菩萨摩诃萨众真实功德悉皆如是。阿难。假令我身住寿百千亿那由他劫。以无碍辩欲具称扬彼诸菩萨摩诃萨等真实功德不可穷尽。阿难。彼诸菩萨摩诃萨等。尽其寿量亦不能知

尔时世尊告阿难言。此是无量寿佛极乐世界。汝应从坐而起合掌恭敬五体投地为佛作礼。彼佛名称遍满十方。彼一一方恒沙诸佛。皆共称赞无碍无断。是时阿难。即从坐起偏袒右肩。西面合掌五体投地。白佛言。世尊。我今欲见极乐世界无量寿如来。并供养奉事无量百千亿那由他佛及菩萨众。种诸善根。时无量寿佛。即于掌中放大光明。遍照百千俱胝那由他刹。彼诸佛刹所有大小诸山。黑山。宝山。须弥卢山。迷卢山。大迷卢山。目真邻陀山。摩诃目真邻陀山。铁围山。大铁围山。丛薄园林及诸宫殿天人等物。以佛光明皆悉照见。譬如有人以净天眼观一寻地见诸所有。又如日光出现万物斯睹。彼诸国中比丘比丘尼优婆塞优婆夷。悉见无量寿如来如须弥山王。照诸佛刹时诸佛国。皆悉明现如处一寻。以无量寿如来殊胜光明极清净故。见彼高座及诸声闻菩萨等众。譬如大地洪水盈满。树林山河皆没不现唯有大水。如是阿难。彼佛刹中无有他论及异形类。唯除一切大声闻众一寻光明。及彼菩萨摩诃萨踰缮那等百千寻光。彼无量寿如来应正等觉光明。映蔽一切声闻及诸菩萨。令诸有情悉皆得见。彼极乐界菩萨声闻人天众等。一切皆睹娑婆世界释迦如来。及比丘众围绕说法

尔时佛告弥勒菩萨言。汝颇见具足清净威德庄严佛刹。及见空中树林园苑涌泉池沼不耶。汝见大地乃至色究竟天。于虚空中散花树林以为庄严。复有众鸟住虚空界。出种种音犹如佛声普闻世界。是诸众鸟皆是化作非实畜生。汝见是耶。弥勒白佛言。唯然已见。佛复告弥勒菩萨言。汝见此诸众生。入踰缮那百千宫殿已。游行虚空无著无碍。遍诸刹土供养诸佛。及见彼有情于昼夜分念佛相续不耶。弥勒白言。唯然尽见。佛复告言。汝见他化自在天与极乐诸人受用资具有差别不。弥勒白言。我不见彼有少差别。佛告弥勒。汝见极乐世界人住胎不。弥勒白言。世尊。譬如三十三天夜摩天等。入百由旬若五百由旬宫殿之内游戏欢乐。我见极乐世界人住胎者。如夜摩天处于宫殿。又见众生于莲华内结加趺坐自然化生。时弥勒菩萨复白佛言。世尊。何因缘故。彼国众生有胎生者化生者。佛告弥勒。若有众生。堕于疑悔积集善根。希求佛智。普遍智。不思议智。无等智。威德智。广大智。于自善根不能生信。以此因缘。于五百岁住宫殿中。不见佛不闻法。不见菩萨及声闻众。若有众生。断除疑悔积集善根。希求佛智乃至广大智信已善根。此人于莲华内结加趺坐忽然化生。瞬息而出。譬如他国有人来至。而此菩萨亦复如是。余国发心来生极乐。见无量寿佛奉事供养。及诸菩萨声闻之众。阿逸多。汝观殊胜智者。彼因广慧力故受彼化生。于莲花中结加趺坐。汝观下劣之辈。于五百岁中不见佛不闻法。不见菩萨及声闻众。不知菩萨威仪法则。不能修习诸功德故。无因奉事无量寿佛。是诸人等皆为昔缘疑悔所致。譬如刹帝利王其子犯法。幽之内宫处以花观。层楼绮殿妙饰奇珍。宝帐金床重敷茵褥。名花布地烧大宝香。服御所资悉皆丰备。而以阎浮金锁系其两足。佛告弥勒。于意云何。彼王子心宁乐此不。答言不也。世尊彼幽絷时常思解脱。求诸亲识居士宰官长者近臣。王之太子虽希出离终不从心。乃至刹帝利王。心生欢喜方得解脱。佛告弥勒。如是如是。若有堕于疑悔。种诸善根希求佛智乃至广大智。于自善根不能生信。由闻佛名起信心故。虽生彼国于莲花中不得出现。彼等众生处花胎中。犹如园苑宫殿之想。何以故。彼中清净无诸秽恶。一切无有不可乐者。然彼众生于五百岁。不见佛不闻法。不见菩萨。及声闻众。不得供养奉事诸佛。不得问于菩萨法藏。远离一切殊胜善根。彼等于中不生欣乐。不能出现修习善法。往昔世中过失尽已然后乃出。彼于出时。心迷上下四方之所。若五百岁无疑惑者。即当供养无量百千俱胝那由他佛。并种无量无边善根。汝阿逸多当知。疑惑与诸菩萨为大损害

尔时弥勒菩萨白佛言。世尊。于此国界不退菩萨当生极乐国者其数几何。佛告弥勒。此佛土中有七十二亿菩萨。彼于无量亿那由他百千佛所。种诸善根成不退转当生彼国。况余菩萨由少善根生彼国者不可称计。阿逸多。从难忍如来佛国。有十八亿不退菩萨。当生极乐世界。东北方宝藏佛国中。有九十亿不退菩萨。当生彼土。从无量声如来国中。有二十二亿不退菩萨。当生彼土。从光明如来国中。有三十二亿不退菩萨。当生彼土。从龙天如来国中。有十四亿不退菩萨。当生彼土。从胜天力如来国中。有十二千不退菩萨。当生彼土。从师子如来国中。有五百不退菩萨。当生彼土。从离尘如来国中。有八十一亿不退菩萨。当生彼土。从世天如来国中。有六十亿不退菩萨。当生彼土。从胜积如来国中。有六十亿不退菩萨。当生彼土。从人王如来国中。有十俱胝不退菩萨。当生彼土。从胜花如来国中。有五百菩萨。具大精进发趣一乘。于七日中能令众生离百千亿那由他劫生死流转。彼等亦当生极乐界。从发起精进如来国中。有六十九亿不退菩萨。当生彼土。到彼国已。供养礼拜无量寿如来及菩萨众。阿逸多。我若具说诸方菩萨生极乐界。若已到今到当到。为供养礼拜瞻仰无量寿佛等者。但说其名。穷劫不尽。阿逸多。汝观彼诸菩萨摩诃萨善获利益。若有闻彼佛名。能生一念喜爱之心。当获如上所说功德。心无下劣亦不贡高。成就善根悉皆增上。阿逸多。是故告汝及天人世间阿修罗等。今此法门付嘱于汝。应当爱乐修习。乃至经一昼夜。受持读诵生希望心。于大众中为他开示。当令书写执持经卷。于此经中生导师想。阿逸多。是故菩萨摩诃萨。欲令无量诸众生等。速疾安住不退转于阿耨多罗三藐三菩提。及欲见彼广大庄严。摄受殊胜佛刹圆满功德者。应当起精进力听此法门。假使经过大千世界满中猛火。为求法故不生退屈谄伪之心。读诵受持书写经卷。乃至于须臾顷为他开示。劝令听闻不生忧恼。设入大火不应疑悔。何以故。彼无量亿诸菩萨等。皆悉求此微妙法门。尊重听闻不生违背。是故汝等应求此法。阿逸多。彼诸众生获大善利。若于来世乃至正法灭时。当有众生殖诸善本。已曾供养无量诸佛。由彼如来加威力故。能得如是广大法门。一切如来称赞悦可。若于彼法摄取受持。当获广大一切智智。随意所乐种诸善根。若善男子善女人等。于彼法中广大胜解之者。当能听闻获大欢喜。受持读诵广为他说常乐修行。阿逸多。无量亿数诸菩萨等。求请此法不曾厌背。是故汝等诸善男子及善女人。于今来世能于是法若已求现求当求者。皆获善利。阿逸多。如来所应作者皆已作之。汝等应当安住无疑种诸善本。应常修学使无疑滞。不入一切种类珍宝成就牢狱。阿逸多。如是等类大威德者。能生广大佛法异门。由于此法不听闻故。有一亿菩萨。退转阿耨多罗三藐三菩提。阿逸多。佛出世难。离八难身亦为难得。诸佛如来无上之法。十力无畏无碍无著甚深之法。及波罗蜜等菩萨之法。能说法人亦难开示。阿逸多。善说法人非易可遇。坚固深信时亦难遭。是故我今如理宣说。汝等修习应如教住。汝阿逸多。我以此法门及诸佛法嘱累于汝。汝当修行无令灭没。如是广大微妙法门。一切诸佛之所称赞。勿违佛教而弃舍之。当令汝等获不善利。沦没长夜备众危苦。是故我今为大嘱累。当令是法久住不灭。应勤修行随顺我教。尔时世尊。而说颂曰

  若于福德初未修　　终不闻斯微妙法
  勇猛能成诸善利　　当闻如是甚深经
  彼人曾见诸世尊　　能作大光拯浊世
  多闻总持如巨海　　彼获圣贤喜爱心
  懈怠邪见下劣人　　不信如来斯正法
  若曾于佛殖众善　　救世之行彼能修
  譬如盲人恒处闇　　不能开导于他路
  声闻于佛智亦然　　况余有情而悟解
  如来功德佛自知　　唯有世尊能开示
  天龙夜叉所不及　　二乘自绝于名言
  若诸有情当作佛　　行超普贤登彼岸
  敷演一佛之功德　　时逾多劫不思议
  于是中间身灭度　　佛之胜慧莫能量
  是故具足于信闻　　及诸善友之摄受
  得闻如是深妙法　　当获爱重诸圣尊
  如来胜智遍虚空　　所说义言唯佛悟
  是故博闻诸智士　　应信我教如实言
  人趣之身得甚难　　如来出世遇亦难
  信慧多时方乃获　　是故修者应精进
  如是妙法已听闻　　常念诸佛而生喜
  彼人往昔真吾友　　善能乐欲佛菩提

尔时世尊说是经已。天人世间有万二千那由他亿众生。远尘离垢得法眼净。二十亿众生。得阿那含果。六千八百比丘。诸漏已尽心得解脱。四十亿菩萨。于无上菩提住不退转。被大甲胄当成正觉。有二十五亿众生得不退忍。有四万亿那由他百千众生。于无上菩提未曾发意。今始初发种诸善根。愿生极乐世界见阿弥陀佛。皆当往生彼如来土。各于异方次第成佛同名妙音。有八万亿那由他众生。得授记法忍成无上菩提。彼无量寿佛昔行菩萨道时成熟有情。悉皆当生极乐世界。忆念俦昔所发思愿皆得成满

尔时三千大千世界六种震动。并现种种希有神变。放大光明普照世界。无量亿那由他百千天人。同时音乐不鼓自鸣。雨天曼陀罗花没至于膝。乃至阿迦腻吒天。皆作种种殊妙供养。佛说经已。弥勒菩萨等及尊者阿难。一切大众闻佛所说。皆大欢喜

大宝积经卷第十八大宝积经卷第十九

        大唐三藏菩提流志奉　诏译

    不动如来会第六之一

    授记庄严品第一

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众千二百五十人俱。皆是阿罗汉众所知识。诸漏已尽无复烦恼。心慧解脱自在无碍犹如大龙。所作已办舍于重担。逮得己利尽诸有结。正教通达到于彼岸。唯有阿难住于学地。尔时尊者舍利弗。从座而起偏袒右肩。右膝着地合掌向佛。白言世尊。云何往昔诸菩萨摩诃萨。发趣阿耨多罗三藐三菩提。修行遍清净行。被精进甲功德庄严。是诸菩萨由被甲故。于阿耨多罗三藐三菩提得不退转。世尊。如是行愿及以发心。惟尊大慈开示演说。世尊。彼诸菩萨摩诃萨。为利益安乐天人世间。精勤修习遍清净行被精进甲。由是利益安乐一切众生。及为现在未来菩萨。当作佛法光明。赞扬功德证获善根故。使诸菩萨闻此法已。于真如法性精勤修学。当得阿耨多罗三藐三菩提。佛言。善哉善哉。舍利弗。汝能问过去未来菩萨摩诃萨净行光明广大甲胄阐扬功德。为摄受未来菩萨摩诃萨故。谛听谛听如理思惟。当为汝说。舍利弗言。唯然世尊。愿乐欲闻。佛告舍利弗。从是东方过千世界。彼有佛刹名曰妙喜。昔广目如来应正等觉出现于彼。与诸菩萨摩诃萨说微妙法。从六波罗蜜为首。舍利弗。彼时有一比丘。从座而起偏袒右肩。右膝着地向佛合掌。白言世尊。如佛所说。菩萨法教志愿修行。佛言。善男子。汝今当知。菩萨教法难可修习。何以故。菩萨于诸众生不生嗔害心故。时彼比丘白佛言。世尊。我从今日发阿耨多罗三藐三菩提心。以无谄无诳实语不异语。求一切智智。乃至未得无上菩提。若于众生起嗔害心者。则为违背无量无数无边世界中现在说法诸佛如来。世尊。我今发此一切智心如是回向。于其中间若发声闻独觉心者。则为欺诳一切诸佛。世尊。我今发此一切智心如是回向。乃至未得无上菩提。若于众生起爱欲嗔痴之心。或与惛沈贡高恶作相应。则为欺诳一切诸佛。世尊。我今发此一切智心安住回向。乃至未得无上菩提。若生疑惑心。如是或起杀害不与取心。或起邪见及非梵行。妄语两舌粗语相应。或与损害相应。则为欺诳一切诸佛。舍利弗。时有异比丘作如是念。此菩萨摩诃萨。由初发心被精进甲。于一切众生不为嗔等之所摇动。舍利弗。时彼菩萨因此念故。妙喜国中号为不动。时广目如来应正等觉。见彼菩萨得不动名。随喜赞善。四大天王释梵世主。闻彼名已亦皆随喜。舍利弗。彼不动菩萨摩诃萨。于彼佛前作如是言。世尊我今发此一切智心。如是回向阿耨多罗三藐三菩提。乃至未证无上正觉。所修行业或违此言者。则为欺诳无量无数世界诸佛如来安住说法者。世尊。我今发此大心如是回向。乃至未证菩提。若于一一语言。不与念佛及一切智相应。则为欺诳一切诸佛。世尊。我今如是发心回向。乃至未证无上菩提。生生在家不出家者。则为违背一切诸佛。世尊。我今发此一切智心。乃至未得无上菩提。生生出家。若不乞食。不一坐食。不节减食。再食不食。不持三衣不着粪扫衣。不随所而坐。不常坐。不住阿兰若。不安止树下。不露坐。不住冢间。则为欺诳一切诸佛。世尊。我今发此大菩提心如是回向。乃至未得一切智智。若不成就无碍辩才说诸妙法。则为欺诳无数诸佛。世尊。我今如是发心。乃至未得无上菩提。若不住三威仪。或立或坐。或复经行。则为欺诳无量诸佛。世尊。我今发如上心。乃至未得一切智智。或于众生犯根本罪。或作妄语及余世俗愦闹之言。或起摧伏他论相应之心。则为欺诳无数诸佛。世尊。我今发此一切智心。安住回向阿耨多罗三藐三菩提。或与妇人说法。若不起无常苦空无我之相。而取彼相及露齿而笑。则为欺诳一切诸佛。世尊。若我发此一切智心。安住回向阿耨多罗三藐三菩提。于说法时顾指轻躁。或见余菩萨不生大师之想。则为欺诳无数诸佛。世尊。我今发此一切智心。乃至阿耨多罗三藐三菩提。若坐听法及礼外道沙门婆罗门。唯除诸佛沙门弟子。则为欺诳一切诸佛。世尊。我今发此大心至无上觉。若行财法施时。情有彼此。应供养所生简异心。则为欺诳一切诸佛。世尊。我今发一切智心。乃至无上菩提。若见诸罪人将被刑罚。不舍身命而救护彼。则为欺诳一切诸佛。舍利弗。时彼菩萨修此大行。乃至未证无上菩提。无一众生将被刑罚不救护者。舍利弗。尔时有一比丘作如是念。如来于此行者当为作证。彼天人阿修罗等亦为证见。舍利弗。时广目如来应正等觉。知彼比丘心之所念。告言。如是如是。如来应正等觉之所证见。彼诸世间天人阿修罗等亦为证见。比丘。若复有菩萨摩诃萨。被如是等大精进甲。趣向阿耨多罗三藐三菩提彼皆当成无上正觉。舍利弗。时不动菩萨摩诃萨白佛言。世尊。我今发此一切智心。乃至未证无上菩提。于其中间。若比丘比丘尼优婆塞优婆夷。有诸罪衅若说其所犯。则为违背诸佛如来。世尊。我修是行愿成无上正等菩提。使我刹中广大清净。诸声闻众悉无过失。世尊。若我发此一切智心。若未证得无上菩提。乃至梦中若生欲想而有所泄。则为违背诸佛如来。世尊。我修是行证无上觉。使彼国中出家菩萨。彼于梦间亦无漏泄。世尊。若我发此一切智心。乃至证得无上菩提。我佛刹中若诸女人。有女过失如余土者。终不取正觉。若取正觉则为欺诳一切诸佛。舍利弗。若菩萨以此大愿种子成就者。念随出生如是诸法。能为众生说种种教

舍利弗。时有比丘。白不动菩萨言。大士。若此诚心不退至言无妄者。愿以足指摇动大地。时不动菩萨。以佛威神及本愿善根力故。令彼大地六种摇动。所谓动。大动。遍动。摇。大摇。遍摇。舍利弗。彼不动菩萨摩诃萨。如昔所愿今已成办。是故菩萨摩诃萨欲证阿耨多罗三藐三菩提者应学。不动菩萨摩诃萨。若有菩萨善修其行。当获如彼佛刹。及能速证阿耨多罗三藐三菩提。尔时舍利弗白佛言。世尊。不动菩萨初发心时。几何天子而来集会。佛告舍利弗。彼时三千大千世界。所有四大天王及与帝释魔王。娑婆世界主梵天王等。皆欢喜合掌作如是言。今此所闻被功德甲。我等昔未曾闻。世尊。彼不动菩萨当成佛时。于彼刹中所有众生。不以下劣善根而得成就。舍利弗白佛言。世尊。如佛所说不动菩萨被甲功德。诸余菩萨所未曾有。佛告舍利弗。如是如是。诸余菩萨被大甲胄。发趣无上菩提。无有如不动菩萨摩诃萨者。舍利弗。彼不动菩萨成就功德。于贤劫中一切菩萨皆悉无有。舍利弗。尔时广目如来。授不动菩萨摩诃萨阿耨多罗三藐三菩提记言。善男子。汝于来世当得作佛。号曰不动如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛世尊。如然灯佛与我授记。舍利弗。不动菩萨得授记时。有大光明普照世界。是时大地六种震动。如我往昔证一切智时。此大千界六动震动

复次舍利弗。彼时三千大千世界所有卉木丛林。皆向菩萨倾靡。亦如我昔证菩提时。一切草木倾向于我

复次舍利弗。不动菩萨蒙佛记时。彼大千界所有天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽。皆悉合掌顶礼菩萨。如我于此证大菩提。娑婆世界所有天龙等。皆悉合掌顶礼于我

复次舍利弗。彼不动菩萨摩诃萨得授记时。彼世界中所有女人怀孕。皆得安和分释无诸苦难。盲者得视。聋者能闻。如我成佛时等无有异

复次舍利弗。彼不动菩萨摩诃萨。发趣阿耨多罗三藐三菩提。及广目如来应正等觉授菩提记。于彼二时。一切众生无横死者。亦如我证一切智时无有异也。复次舍利弗。彼不动菩萨得授记时。有悦意香普熏世界。亦如我昔证大菩提。妙香遍闻适意无异。尔时舍利弗白佛言。世尊。彼不动菩萨摩诃萨。成就如是广大功德。佛告舍利弗言。彼不动菩萨。蒙佛授记。非唯有此功德。又能到无边功德彼岸。复次舍利弗。彼不动菩萨。由广目如来与授佛记。彼时天人世间阿修罗等。心皆悦庆柔顺调善。亦如我证无上菩提。诸天人等皆同欢喜

复次舍利弗。彼不动菩萨获授记时。有大夜叉手持金刚侍卫菩萨。如我无异。复次舍利弗。不动菩萨蒙佛记时。诸天及人散诸名花涂香末香于菩萨上。亦如我证大菩提时散诸香华。复次舍利弗。彼不动菩萨得授记时。有诸天人各二十亿。皆发阿耨多罗三藐三菩提心。得广目如来授佛菩提记。复次舍利弗。彼不动菩萨蒙佛记时。优钵罗花。波头摩华。纷陀利华。遍满大地。亦如我道场诸华遍覆。复次舍利弗。彼不动菩萨得授记时。有无量诸天在虚空中。散诸天衣覆菩萨上咸作是言。愿此菩萨速证无上正等菩提。亦如我昔得一切智诸天散衣无有异也。复次舍利弗。彼世间天人阿修罗等。见不动菩萨得授阿耨多罗三藐三菩提记。皆大欢喜甚于世间父母生子。犹如我证一切智时。诸天人等皆大欢悦

复次舍利弗。彼三千大千世界所有天人。以佛神力皆闻不动菩萨授菩提记。各施种种上服名衣珍奇美膳。譬如比丘加提月满。一切诸人悉皆供养。舍利弗。彼不动菩萨得授记时。欲界众生持诸上味。并奏天乐而以供养。舍利弗。彼不动菩萨摩诃萨得授记已。有如是等功德成就。时尊者舍利弗白佛言。世尊。如来应正等觉甚为希有。善说诸佛境界不可思议。如是禅定境界。及诸龙境界不可思议。诸业果报不可思议。世尊。彼不动菩萨住初发心。摄受如是殊胜功德得如来记。又成此等不可思议诸大功德。佛告舍利弗。如是如是如汝所说。尔时尊者阿难白舍利弗言。大德。彼初发心菩萨被精进甲胄。世尊略说少分功德犹故未尽。舍利弗言。如是如是。如来略说。何以故。彼菩萨住初发心被精进甲。成就不可思议无量功德。时舍利弗复白佛言。世尊。今已略赞不动菩萨被甲精进殊胜功德。唯愿世尊。为摄受现在未来诸菩萨故。广为宣说。佛告舍利弗。不动菩萨住初发心被精进甲。如是功德不可思议。吾今为汝说其少分。谛听谛听善思念之。舍利弗言。唯然世尊。愿乐欲闻。佛言。彼不动菩萨发如是愿。假使虚空而有变异。我之弘誓终无退转。由此愿故。不动菩萨所有功德皆速成就。舍利弗。我不见有于贤劫中诸菩萨辈被精进甲如不动菩萨者。舍利弗。宝幢菩萨所修之行。比于不动菩萨。于少分中乃至歌罗分亦不及一。舍利弗。不动菩萨所被精进甲胄。无量千菩萨悉无与等。舍利弗。不动菩萨摩诃萨。以此坚固誓愿。证得阿耨多罗三藐三菩提。今现住于妙喜世界。号为不动如来应正等觉。复次舍利弗。彼不动如来往昔行菩萨行时。诸有乞求头目髓脑手足支节。不逆其意悉皆施与。舍利弗。彼不动如来从初发心。乃至未证无上菩提。由此因缘无风黄痰及头痛等和合诸病。舍利弗。彼不动如来往昔行菩萨道时。得如是等未曾有法。舍利弗。彼由往昔于生生处供养奉事诸佛如来。于彼佛所常修梵行。由是因缘生生之处。还复本名号为不动。从一佛刹至一佛刹。生有佛世常见如来。舍利弗。譬如刹利灌顶大王。于世间中得胜自在。从一宫殿至一宫殿。足不履地受五欲乐。彼不动菩萨往昔行菩萨行时。生生之处常修梵行供养诸佛。随所说法示教利喜。皆与波罗蜜相应。少与声闻地相应。能令诸菩萨趣入安住阿耨多罗三藐三菩提。由此发心于无上菩提故。获此广大功德利益。又以法施善根回向菩提。发如是愿。愿我成佛于彼刹中。一切菩萨以佛威力。闻我说法。受持读诵。及能历事诸佛如来。从一佛刹至一佛刹。乃至未证无上菩提。常不远离诸佛世尊。譬如于我。唯除至兜率天宫补处之位。何以故。诸菩萨摩诃萨。法尔如是。若从兜率天众降神母胎。右胁生时大地震动。舍利弗。最后身菩萨摩诃萨。有如是瑞相。舍利弗。譬如比丘具诸神足。入宫殿内犹处虚空。住诸威仪皆无障碍。彼后身菩萨亦复如是。虽在母胎而住虚空。一切胎垢不净不能污染。臭秽之气彼亦不闻。舍利弗。彼不动如来往昔行菩萨道发如是愿。若我当证无上菩提。于彼佛刹。行菩萨乘及声闻乘者皆断诸魔业。诸众生类。于一切种于一切时。令诸魔众不得其便。亦犹于我行菩萨行时断一切魔业。而彼诸菩萨乃至未成诸大功德。常勤摄受修菩提行。舍利弗。彼不动如来应正等觉。往昔行菩萨行。演说诸法及听闻时。身之与心不生疲倦。何以故。彼初发心修菩萨行时。得法身威力故。舍利弗。不动如来应正等觉。往昔行菩萨行时。作如是愿。我佛刹中所有菩萨摩诃萨。皆得法身圆满。如我无异

    佛刹功德庄严品第二

尔时舍利弗白佛言。世尊。如佛已说不动如来修菩萨行时所有功德。复愿世尊。开示广说不动如来见今刹土功德严胜。何以故。使诸补特伽罗行菩萨乘者。闻彼功德生爱乐心。欲见彼佛礼拜供养。住声闻地补特伽罗证无学者。闻彼刹土功德庄严。亦希瞻礼供养奉事。佛告舍利弗。善哉善哉。汝今乃能问如是义。谛听谛听善思念之。今当为汝分别解说。舍利弗言。唯然世尊。愿乐欲闻。佛告舍利弗。彼不动如来应正等觉。证一切智时放大光明。普照三千大千世界。是时大地六种震动。彼世界中所有众生。知不动如来证无上觉经七昼夜。无有食想无饥渴想。亦无疲倦宴处睡眠之想。唯有安乐欢喜爱乐善心。而于彼时。世界之中所有众生。及欲界天无有淫欲。何以故。由彼如来本愿力故。彼诸众生现世摄受此诸功德。舍利弗。不动如来应正等觉。证一切智时。彼世界中所有众生。皆至诚合掌向不动如来。由渴仰如来故。能于现世摄受如是无量功德

复次舍利弗。彼佛世界功德庄严。无量佛国悉无与等。舍利弗。由彼如来修菩萨行时发斯弘誓愿。此佛刹殊胜庄严。如我于今本愿成就。舍利弗。彼不动如来应正等觉。证无上菩提时。于其刹那或须臾顷。三千世界所有众生。若有天眼若无天眼。彼皆得见不动如来。舍利弗。此亦如来本愿成就。令诸有情获此功德

复次舍利弗。不动如来坐菩提道场证无上觉时。天魔波旬不生障碍之想。复有无数百千诸天。以诸香花及天伎乐供养如来。各持细末栴檀而散佛上。是诸香末及彼花鬘。于虚空中合而成盖。舍利弗。此皆不动如来本愿之力今得成满

复次舍利弗。彼佛得菩提时。大光普遍三千世界。日月诸天光悉不现。此亦不动如来。昔愿圆满今获斯瑞。时舍利弗白佛言。世尊。彼不动如来昔行菩萨道。诚有广大精进甲胄。能发如是弘誓之心。由彼往修菩萨行愿。能令无数百千众生殖诸善本于无上菩提。又以善根回向阿耨多罗三藐三菩提清净佛刹。如是如是回向愿力悉皆圆满

复次舍利弗。彼佛刹中有菩提树。成以七宝高一由旬。树身周围半拘卢舍。条叶垂荫周一由旬。下有基陛周四由旬。佛坐其上证菩提道。道树四边有多罗树及苏漫那树周遍行列。微风吹动出和雅音。世间音乐所不能及

复次舍利弗。彼佛刹中无三恶趣。何等为三。所谓地狱畜生剡魔王界。一切众生成就十善。地平如掌而作金色。无有沟坑荆棘瓦砾。其地柔软如兜罗绵。足所履时其地即下。随举其足还复如初。舍利弗。彼佛刹中无三种病。云何为三。谓风黄痰所起之病。舍利弗。彼佛土中一切有情无虚妄语。亦无丑陋身无臭秽。于贪嗔痴皆悉微薄。亦无牢狱囚系众生。舍利弗。彼佛刹中无有外道异学之众。所生诸树常有华果。复有奇树时号劫波。上出名衣皆备五色。光花鲜洁异气芬芳。于一切时常无变易。譬如天花种种芬馥。彼衣香气亦复如是。诸服用者身所出香与衣无异。譬如此界富乐之人。名衣自丰服用如意。舍利弗。彼土众生所须饮食。如三十三天应念而至。无有便利秽恶不净。舍利弗。彼国所居宫殿楼阁。皆以七宝而严饰之。于其四边多诸池沼。八功德水受用随心。园观又多悉皆清净。诸众生辈多以法乐而居。舍利弗。彼刹人伦无有嫉妒。一切女人超诸女宝。获天功德此无能比。假令况之百分不及一。千分不及一。百千分不及一。百千俱胝那由他算数譬喻。乃至邬波尼杀昙分亦不及一。舍利弗。彼刹诸人随其业报感诸床座。皆七宝成严丽具足。其所偃息以兜罗绵枕。此皆由不动如来往昔愿力。成就如是种种严好。舍利弗。彼刹诸人所资饮食。色香味等不异诸天。譬如郁单越人无别王者。彼妙喜国亦复如是。唯有不动如来以为法主。又如三十三天奉事帝释。彼诸人等咸事如来。舍利弗。汝应知彼不动佛刹功德庄严。舍利弗。彼土众生心无放逸。何以故。亦由不动如来本愿力故。时一比丘闻佛赞扬不动如来佛刹功德。心生贪着而白佛言。世尊。我今愿生不动佛刹。佛告比丘。汝之愚迷岂得生彼。何以故。不以爱着之心而得往生。唯有殖诸善本修诸梵行得生彼故

复次舍利弗。彼土众生随其所乐。有清净池应念而见。八功德水充满其中。饮漱洗沐皆适人意。有不乐者即便不见。舍利弗。彼佛刹中香风和畅悦可众心。而彼香风为诸天人作诸香事。曲从人心有至不至。舍利弗。此皆不动如来本愿力故功德庄严。复次舍利弗。彼佛刹中女人衣服及庄严具。从树而生随意受用。彼国女人无女过失。不如此界诸女等心多嫉妒两舌恶口。又彼怀孕之时至于诞育。母子安适亦无秽污。何以故。此皆不动如来本愿力故。舍利弗。彼佛刹中有如是等安隐快乐。舍利弗。彼不动如来应正等觉佛刹土中。无有市易商贾。亦无田业农作常得快乐。舍利弗。彼佛刹中歌咏游戏。无有淫欲相应。彼诸人等唯受法乐。舍利弗。彼佛刹中所有苏漫那树。及多罗树。而为行列。微风吹动。出和雅音。假使天人音乐不如彼树。舍利弗若菩萨摩诃萨欲摄佛土者。应当摄受如是功德。及净修佛国如不动如来行菩萨行。摄受佛刹功德庄严。舍利弗。彼佛土中无诸黑闇。虽有日月不现晖光。何以故。不动如来常有光明普照佛刹故。舍利弗。譬如高大楼阁密闭户牖。以摩尼宝置于室中。其内有情虽经昼夜常睹光耀。彼佛刹中诸众生类。见如来光亦复如是。舍利弗。大楼阁者。彼方妙喜世界。摩尼宝者。此喻不动如来。摩尼宝光者。喻佛光明。阁中有情。譬妙国土诸群生等。舍利弗。不动如来随所行住。有千叶莲花自然承足。是华金色世无可喻。舍利弗。此亦不动如来应正等觉殊胜力之所成就

时舍利弗复白佛言。世尊。彼不动如来若入室中。金色莲花为承足不。佛告舍利弗言。斯事微浅何勤致问。彼佛世尊。若入村坊舍宅。其千叶华。即随而现。若有善男子善女人作如是念。若如来降尊入此室者。足下莲花应聚一处。随其所念花则为聚。若复有人愿花住空。即如彼念在空中住。由彼如来威神力故。舍利弗。彼承足莲华。与诸人等为塔供养。舍利弗。彼佛世尊为演法故。遍游三千大千世界。随所行处其花即现。又复如来随所化现。他方刹土其金色花亦现于彼。以佛威力故。三千大千世界。皆以金色千叶莲花庄严其土

    声闻众品第三

复次舍利弗。彼不动如来于说法时。能善调伏无量众生。皆令现证阿罗汉果。安住静虑八解脱者其数甚多。舍利弗。彼不动如来应正等觉。有无量无数诸声闻众。我不见若算师算师弟子。有能算数彼声闻众尔许。频婆罗。殑伽罗。波头摩。阿罗吒。若干阿频婆。阿部多。舍利弗。如此算数无有能知彼声闻众定其数量若干名者。舍利弗。如我此刹诸善男子获预流果斯陀含果阿那含果则无其数。于彼刹中证阿罗汉亦复如是。舍利弗。譬如懈怠预流果入七返受生。为其说法方获胜果。我说名为七返生人。舍利弗。若有于不动如来初说法时获预流果。第二说法证斯陀含。第三说法证阿那含。第四说法证阿罗汉者。此诸人等非一坐定得尽诸漏名懒惰人。舍利弗。彼佛刹中得预流者。于此现身而得漏尽。非如此界经七返生。斯陀含者。即于现生能尽苦际。匪如此界经一往来名斯陀含。阿那含者。彼于现身成阿罗汉。非如此界往上地生。不还来此名阿那含。舍利弗。不动如来。于彼刹中说诸声闻行位差别。乃至安立如是圣果。若善男子善女人能了此法。不住诸识及于学地。而身殁亡住无学地方取灭度。舍利弗。无学地者。是阿罗汉地假名建立。言无学者。是阿罗汉假名建立。舍利弗。彼不动如来。诸声闻众清净具足安住坚固。舍利子。此是不动如来。诸声闻众假名建立。所谓大阿罗汉。诸漏已尽所作已办。弃舍重担逮得己利。尽诸有结正教解脱。是诸罗汉多住静虑八解脱中。舍利弗。彼不动如来。有如是等诸声闻众。具足功德之所庄严

复次舍利弗。彼佛刹中。以金银琉璃三宝为阶。从阎浮提至忉利天。舍利弗。三十三天。若欲乐见不动如来礼拜供养。彼诸天众从宝阶下至于佛所。时彼诸天见阎浮提人富盛具足。便生爱乐作如是言。我等诸天有天福报。彼阎浮提人有人福报。我今所见殊胜之福与我无异。然阎浮提。复有胜福过于天者。谓不动如来演说正法。是故天众常乐人间。舍利弗。阎浮提人。若升天者了无爱乐。何以故。不动如来在于人间。常演正法饶益我等。然我之福报不异诸天。是故三十三天所不能及。舍利弗。彼界人天以佛神力互得相见。譬如此界阎浮提人见诸星月。舍利弗。彼诸人众。仰观上界诸天宫殿亦复如是。舍利弗。此亦是不动如来本修菩萨行时愿力成就。舍利弗。彼佛说法之声。普遍三千大千世界。听法四众间无空缺。舍利弗。彼声闻众。唯希法食无余食想。于听法时。一心寂静。若坐若立身心无倦。舍利弗。不动如来住虚空中为众说法。彼声闻众若得神通及不得者。以佛威力皆住虚空。以三威仪而听法要。何等为三。谓行住坐。是声闻辈。若欲涅槃。结加趺坐而便灭度。尔时大地为之震动。既灭度已。一切天人皆来供养。或有阿罗汉将欲灭度。身中出火而自阇维。或有自然化灭无遗舍利。或有于灭度时游行空中如五色云。须臾消散灭无遗迹。或住虚空如降时雨至地消尽。舍利弗。此亦不动如来应正等觉。本修菩萨行时作如是愿。若我得证无上菩提。诸声闻众以三威仪而取灭度

复次舍利弗。彼佛国中诸声闻众。多获四无所畏。得四神足者复多于此。舍利弗。彼刹土中诸声闻众。成就如是具足功德。时舍利弗白佛言。世尊。彼不动如来应正等觉。诸声闻众功德炽盛广大成就

大宝积经卷第十九大宝积经卷第二十

        大唐三藏菩提流志奉　诏译

    不动如来会第六之二菩萨众品第四

尔时尊者舍利弗作如是念。世尊今者已说声闻功德。复愿说诸菩萨具足功德。何以故。一切功德从此出生。尔时世尊。知其所念。告舍利弗。彼佛刹中有无量百千亿诸菩萨众皆来集会。所有出家菩萨。以佛神力随所听闻。皆能领悟受持读诵。舍利弗。我于此界。说法至少。比不动如来所说法藏。百分千分百千分。亿百千分算分数分。迦罗分。邬波尼杀昙分。亦所不及。舍利弗。此皆不动如来应正等觉。修菩萨行时发如是愿。愿我成佛。彼刹土中所有菩萨。以我威力随所听闻。皆能领悟受持读诵。舍利弗。是诸菩萨由彼如来本愿神力。于佛所闻悉能领受讽诵通利

复次舍利弗。若彼菩萨自心欲乐往异佛土。举心便至。形服言音。善同方俗。于彼如来礼拜供养。听闻正法善为问难。能事已周还归佛所。舍利弗。此贤劫中有九百九十六佛。当出于世。若有菩萨乐见此如来者。应愿生彼不动佛刹。舍利弗。若善男子善女人。从此佛刹及余佛刹。于命终后。若已生若今生若当生。不动如来佛刹中者。必不信住诸声闻地。何以故。彼行佛道常遇如来。天魔波旬不得其便。于二乘地永断相续。必定当得无上菩提。常在如来诸大集会。舍利弗。汝应当知。若住不动如来清净佛刹者。彼诸众生终不退堕。不可引摄。亦不退还。住无上菩提。有大势力不可摇动。永无退转。舍利弗。若有善男子善女人。于此世界或他世界。若命终后生于彼土。即于生时得如是念。我已入如来室住无畏城。舍利弗。彼诸菩萨所有言议。皆与般若波罗蜜相应。互相遵敬起导师想

复次舍利弗。彼佛刹中诸菩萨众。在家者少出家者多。皆以佛神力随所听闻。即能领悟受持讽诵。舍利弗。若在家菩萨摩诃萨虽不系念。于法会中随在方所若坐若立以佛神力。皆能听闻领悟受持读诵通利。彼出家菩萨亦复如是。诸在异方乃至讽诵无别。是诸菩萨舍身受身。于所闻经终不忘失。于诸佛土随愿受生。舍利弗。彼亦是不动如来。本愿功德之所庄严。舍利弗。若菩萨于一生中。欲见无量百千亿那由他诸佛者。应当愿生不动如来之所。若菩萨于彼生已。即见无量诸佛种诸善根。复能为无数百千众生演说法要。令诸众生增长善根。舍利弗。此贤劫中诸佛世尊当出于世。若诸菩萨以衣服饮食卧具医药种种资具。供养如来便即出家。既出家已于诸佛所净修梵行。以此善根。方余菩萨于不动如来之所。于一生中与波罗蜜相应。所有福聚百分不及一。千分不及一。算分。迦罗分。数分喻分。邬波尼杀昙分。亦不能及。舍利弗。此亦不动如来清净佛刹。功德庄严。舍利弗。若有菩萨从此世界。或余世界于寿终后。若已生现生当生不动如来佛刹者。一切皆得不退转位。何以故。彼佛刹中天魔波旬不为障碍。亦无魔业之所娆乱。舍利弗。譬如毒蛇神咒所伏不能为害。一切诸虫见彼毒蛇。亦无忧惧。然此毒蛇虽无毒害。由本业故受此蛇身故名毒蛇。舍利弗。彼魔波旬亦复如是。由不动如来往修菩萨行时。本愿善根如是回向。愿我当证无上菩提。调伏诸魔不为障恼。彼诸菩萨声闻凡夫。乃至三千大千世界亦不为障恼。然由先业所感受此魔身。生彼天中而自悔责。无始故业获此身名。虽得自在常生厌患。于彼如来说法之时。诸魔眷属常预听闻闻已心净。于声闻众而生爱乐。云何当得住于寂静少欲知足。彼诸魔众常起出家之心。而无障碍之想故。彼国中声闻菩萨及凡夫众。皆由彼佛往昔精勤弘誓威力得安乐住。舍利弗。此亦不动佛刹殊胜庄严。时舍利弗白佛言。世尊。若有善男子善女人。以七宝满三千大千世界。持用布施愿生彼国。由兹行愿此善男子善女人。终不退堕声闻辟支佛地。从一佛刹至一佛刹。历事供养诸佛如来。于诸佛所听闻正法。虽未证得无上菩提。而能见彼无量百千乃至亿那由他百千诸佛。于诸佛所种诸善根。世尊。若善男子善女人由此方便。以七宝满三千大千世界持用布施。由兹善舍往生彼国。佛告舍利弗。如是如是彼善生善往。如是诸菩萨摩诃萨满彼刹中。舍利弗。譬如金矿精加铸炼。除去砂砾唯有真金。造诸饰好严身之具。舍利弗。彼佛刹中菩萨摩诃萨。住于真实亦复如是。然彼菩萨摩诃萨清净集会。汝今应知。复次舍利弗。彼佛刹中所有菩萨。若已生若现生若当生。如是菩萨皆行一行。所谓住如来行。舍利弗。云何如来行。所谓超过声闻辟支佛地。言行一行者是彼假名。是故舍利弗。若菩萨摩诃萨乐行一行者。应当愿生彼佛刹土。舍利弗。我所授记得不退转菩萨摩诃萨。此辈应生不动佛所。舍利弗。是诸菩萨生彼佛刹者我不舍离。譬如刹利灌顶大王。有敌国来欲侵财位。王既闻已作是思惟。我之妃后爱子不堪御敌。及诸财宝收入宫城。不为怨敌之所侵害。王之国祚安静无虞。威震强敌不忧灾难。舍利弗。我不舍离诸菩萨者。亦复如是。如彼王之宝物爱子妃后。修菩萨行者应如是知。彼佛刹中无有畏惧犹如宫城。彼敌王者即魔波旬。于菩萨行人勤为障碍。如彼灌顶大王不被怨敌之所侵扰。如来亦复如是。不为天魔之所扰恼。舍利弗。譬如有人畏于债主远适边国。不为债主及于他人之所陵夺。何以故。由路远险绝债主家人不能达彼。彼诸菩萨生妙喜国者。波旬路绝亦复如是。舍利弗。此三千大千世界天魔波旬。常为菩萨声闻作诸障碍。妙喜刹中诸天魔众不为魔业。彼诸菩萨若已生现生当生。常无恐怖。何以故。由彼如来本行菩萨道时。所有善根如是回向。我证无上正等觉时。彼天魔众不为障恼及作魔事。舍利弗。譬如丈夫善服毒药能使消化。方为食事无有诸毒。彼刹天魔亦复如是。常加利益不为损害。舍利弗。彼佛刹土成就如是无量功德。尔时舍利弗。作是思惟。我今欲见彼佛世界不动如来。应正等觉及声闻众。尔时世尊。知舍利弗心之所念。则以神力。不起于座皆令得见。告舍利弗言。汝今见不。答言已见。佛告舍利弗。汝见彼诸天人微有胜劣殊异相不。答言不见。何以故。我见妙喜国人衣服饮食及诸珍玩。皆是诸天乐具。彼不动如来处众说法。犹若金山光明赫奕。诸声闻众无量无边。譬如有人游于大海。中流四望涯际莫知。观彼声闻亦复如是。是诸声闻随所听法。身心不动如入禅定。匪如此界入定之人时或摇动。世尊。若善男子善女人。以七宝满三千大千世界持用布施。由兹善舍彼诸菩萨善得往生妙喜世界。何以故。彼亦如是得不退转。世尊。譬如王使远适他国。执持符印经途来往。关防主司莫能为碍。何以故。以王印力人无遮止。彼诸菩萨摩诃萨亦复如是。或从此界若他世界寿命终后。于彼佛刹。若已生若现生若当生。皆不退转于阿耨多罗三藐三菩提。从一佛刹至一佛刹。常不远离诸佛世尊。皆当速证无上菩提。时舍利弗。复白佛言世尊。彼界所生菩萨摩诃萨。与此世界预流果人无有差别。何以故。如预流果人不堕恶趣。彼界菩萨若已生现生当生。亦皆断诸恶趣及声闻辟支佛地。乃至未证无上菩提。从一佛刹至一佛刹。不离诸佛及声闻众。佛告舍利弗。如是如是。是诸菩萨摩诃萨受生彼国。不堕声闻辟支佛地。及至未证无上菩提。从一佛土至一佛土。常得现前供养诸佛。及当证得佛菩提果。舍利弗。譬如预流果人。决定当得声闻菩提终不堕恶趣。是诸菩萨亦复如是。或从此世及以他世。命终之后受生彼刹。彼皆决定当证阿耨多罗三藐三菩提。从一佛刹至一佛刹。于诸佛所。常不远离阿耨多罗三藐三菩提。时舍利弗。复白佛言。世尊。于此世界。所有一来向及一来果。乃至住阿罗汉向及罗汉果。与彼佛刹所生菩萨摩诃萨等无有异。佛告舍利弗。汝勿作此言。何以故。于此佛刹。菩萨摩诃萨佛授记者。与彼所生菩萨等无有异。复次舍利弗。于此世界坐道场菩萨。与彼所生菩萨等无有异。何以故。彼诸菩萨行如来行。不为天魔之所得便。于二乘地永断相续。从一佛刹至一佛刹。常能供养一切如来。乃至证得无上正觉。尔时阿难作如是念。我今应察长老须菩提辩才之力。作是念已白须菩提言。我等应观不动如来及声闻众兼彼佛土。时须菩提告阿难言。汝欲见彼如来者。今应且观上方。尔时阿难观上方已。白须菩提言。我极观上方皆空寂静。须菩提言。彼不动如来。诸声闻众及彼佛土。亦复如是如见上方。尔时舍利弗白佛言。世尊。如佛所说。此世获记菩萨。与彼所生菩萨等无有异。世尊。我今不知以何为等。佛告舍利弗。以法界等故。得无有异

    涅槃功德品第五

尔时尊者舍利弗。复作是念。世尊已说不动如来应正等觉。修菩萨道功德无边。又说彼土及声闻菩萨殊胜德业广大庄严。复愿世尊。于兹开示彼佛灭度化迹如何。尔时世尊。知舍利弗心之所念告言。舍利弗。不动如来般涅槃日。化身分布一切世界。于地狱中说诸妙法。以法调伏无量有情。皆当证得阿罗汉果。然此时获果方灭度。前证无学人转增其数。即于此日。授香象菩萨摩诃萨记云。汝于我灭度后当得作佛。号曰金莲如来应正等觉。复次舍利弗。彼金莲如来佛刹功德声闻众数。与不动如来等无有异。复次舍利弗。不动如来入般涅槃。是时大地普皆震动。一切三千大千世界震吼发声。其声上彻乃至阿迦尼吒天。诸天闻已即知彼佛入于涅槃。复次舍利弗。彼佛刹中所有丛林及诸药草。皆悉倾向不动如来涅槃之处。是时天人。悉以华鬘杂香及诸衣服而散佛上。所散香花周匝围绕高一由旬。复次舍利弗。彼涅槃时。三千大千世界所有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。皆向不动如来合掌作礼。他方诸天以佛神力。悉皆得见入般涅槃。是诸天人经七昼夜心怀悲恼不受人天嬉戏娱乐亦无欲想。互相谓言。不动如来为世光明作众生眼。今取灭度一何速哉。舍利弗。若菩萨摩诃萨。从此世界或余世界。于命终后生彼佛刹。若现生彼。皆得授阿耨多罗三藐三菩提记。非可以百数而数彼以千数及百千数。舍利弗。是百千菩萨摩诃萨数者。应知入如来数皆入佛数。皆入佛数入一切智性数。若有菩萨摩诃萨。当生彼刹者。亦皆得入如来等数。舍利弗。除彼不退菩萨摩诃萨。所余菩萨于此世界。若不闻称赞不动如来功德法门者。皆为恶魔之所摄受。复次舍利弗。不动如来般涅槃后。乃至正法住世。彼佛刹中所生菩萨摩诃萨。亦当入其数。所以者何。由彼如来本愿力故。是诸菩萨。若于后时受生彼者。应当读诵百八法门。读诵兹已方能受持彼一切法。不动如来之所安立。一百八法门本性。我灭度后。若有菩萨摩诃萨当生彼刹者。亦当读诵一百八法门。及能受持一切法门。舍利弗。不动如来应正等觉。善能摄受诸菩萨摩诃萨。佛虽灭度其说法声及庄严功德。与佛在世等无有异。复次舍利弗。彼不动如来应正等觉。从身出火而自阇维。舍利遗形皆作金色。譬如低弥罗树。随分断处皆有卍(音万)字之文。如来舍利亦复如是。复次舍利弗。不动如来所有舍利分分周圆。表里皆有吉祥之相(相表之文其状如下)卍。舍利弗。譬如补罗迦树。随解之处中表皆有吉祥之文。彼佛舍利亦复如是。舍利弗。彼国众生。为供舍利起七宝塔。遍满三千大千世界。又以金色千叶莲华而为供养。其大千世界。即以塔华而为严饰。复次舍利弗。若诸菩萨于不动佛国将灭度者。临寿终时曾不失念。而见如是种种瑞相。或有菩萨见当生土。无有如来自方作佛。或见彼有佛当即奉事。或见菩萨入于母胎。或见菩萨被大甲胄。或见舍家趣于非家。或见坐于道场降伏魔军。或见菩萨证一切智智。或见菩萨于某世界。成等正觉转于法轮。或有菩萨住虚空中。自身渐灭不遗少分。譬然湿草烟气上腾。渐以消散至于灭尽。舍利弗。是诸菩萨既灭度已。一切天人备修供养。复次舍利弗。不动如来以大涅槃。般涅槃已正法住世经百千劫。时舍利弗白佛言。世尊。不动如来正法所住。是何等劫。佛告舍利弗。二十小劫以为一劫。彼住如是百千劫数。舍利弗。正法灭已。有大光明照十方界。地皆震动发大音声。然彼非天魔之所能坏。亦非如来及声闻众而自沉隐。但由彼时人少有听闻多无欲乐。能说法者皆悉远之。既于正法寡闻转增不信。不信增长则无精勤。知法比丘自当退静。观无乐欲不复弘宣。彼佛微言渐当隐没

    往生因缘品第六

尔时尊者舍利弗白佛言。世尊。菩萨摩诃萨。以何因缘善根之力。于彼佛刹而得受生。佛告舍利弗。若菩萨摩诃萨。欲生妙喜世界者。应学不动如来往昔行菩萨行。发弘誓心愿生其国。如是行愿能作因缘生彼佛刹。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。以此相应善根。回向无上菩提。愿与不动如来共相会遇。舍利弗。以此因缘当生彼界。如是菩萨摩诃萨。行尸波罗蜜乃至般若波罗蜜亦复如是。复次舍利弗不动如来光明。普照三千大千佛之刹土。愿于来世当见此光证无上觉。因见光已成大菩提。复以身光遍满世界。舍利弗。菩萨以是因缘当生彼土。复次舍利弗。彼不动如来应正等觉。诸声闻众无量无边。愿我当见。见已起如是行证佛菩提。证菩提时。亦有如是无量无数诸声闻众。舍利弗。以是因缘故菩萨摩诃萨于彼佛刹而得受生。复次舍利弗。彼佛刹中菩萨摩诃萨无量无边。我当欲见此诸菩萨。行禅定行愿当随学。与诸菩萨处处结集。同学同乘同俱究竟。愿当会遇欲求圆满大慈悲者。欲求菩提及沙门者。舍离二乘心者。安住真实空性者。于佛如来一切智性及法僧名号。念住相续者。舍利弗。若善男子善女人。闻是色类菩萨名者。于彼佛刹当得受生。何况与般若波罗蜜。相应善根。回向不动如来应正等觉。舍利弗。以是因缘。是人于彼佛土决定当生。复次舍利弗。若菩萨摩诃萨。愿生彼佛刹者。于东方无量世界。诸佛如来说微妙法。及声闻众应以其像随念在前。愿我当证菩提说微妙法。及声闻众皆如彼佛。舍利弗。是诸菩萨应修三种随念善根。愿与一切众生平等共习。以此善根回向阿耨多罗三藐三菩提。舍利弗。如是菩萨回向善根无有限量。假使一切众生。各持一器量等虚空。作如是言。丈夫彼之善根分与于我。舍利弗。此诸善根若有色相。给与众生皆满其器各各持去。而彼善根亦无穷尽。以回向阿耨多罗三藐三菩提。无有限量不可移转故。舍利弗。彼三随念所成回向一切种智。以此善根三宝随转。舍利弗。若有菩萨成此善根。应知不堕一切恶趣。而能摧伏波旬及诸魔众。于彼彼佛刹随乐受生。乃至南西北方四维上下亦复如是。皆得随愿受生。是故菩萨摩诃萨。于此随念善根应当积集。彼积集已应回向不动如来故。于彼刹当得受生。复次舍利弗。不动如来佛刹功德广大庄严。于无量佛刹中彼皆无有。是故菩萨摩诃萨。应当发如是心。我以此善根愿当见彼土。彼土庄严愿当摄受。亦愿当见彼诸菩萨。舍利弗。以此因缘菩萨当生彼国。舍利弗。菩萨摩诃萨愿生彼佛刹者。应发增上乐欲之心。舍利弗。若善男子善女人。发增上心我皆与记。于彼佛刹而得受生。舍利弗。譬如有城无有楼阁园林池沼。亦无象马游行之处。彼城之王虽有力安处。而城无楼阁诸功德故则非庄严。舍利弗。我此佛刹亦复如是。无彼功德故则非严饰。舍利弗。我此刹中若有如是功德庄严。则如不动如来佛刹严胜。舍利弗。若菩萨摩诃萨。愿当摄受清净佛刹者。应如不动如来往修菩萨行。植众德本严净佛刹已。及当如是摄取功德。复次舍利弗。如我今时得阿耨多罗三藐三菩提已。调伏无量众生。于二乘道皆获果证。及我声闻所调伏者悉皆积聚。方彼如来诸声闻众。百分不及一千分不及一。百千分亿百千分。数分算分喻分邬波尼杀昙分亦不及一。何以故。由数无量故。若言解脱则无有异。且止斯事。舍利弗。彼弥勒如来当出于世。诸声闻众及彼调伏所余声闻。以方不动如来声闻之数。不及之分如上。应知舍利弗。由彼如来于一说法。善能调伏无量有情。然彼世尊之所摄受。无有能知其数量者。舍利弗。我之声闻及弥勒如来诸声闻众。乃至贤劫诸佛世尊所有声闻。及彼声闻当所调伏余声闻众彼皆积聚比不动。如来诸声闻众。百分不及一。乃至邬波尼杀昙分亦不及一。何以故。其数多故。解脱无异故。时舍利弗白佛言世尊。如我解佛所说义者。应知彼阿罗汉刹非愚夫刹。何以故。彼佛刹中阿罗汉多故。佛告舍利弗。如是如是。如汝所说。彼佛刹中多漏尽阿罗汉故。复次舍利弗。此三千大千世界星宿数量。不如彼佛声闻众多。由彼如来于一说法。无量有情得阿罗汉。舍利弗。此三千大千世界星宿犹有数量。彼一一会无量有情得阿罗汉故。诸会声闻无有数量。复次舍利弗。彼刹天人殖众善本。余界人天纵以天眼亦不能见。舍利弗。假令余界诸天及人。往彼刹中善男子善女人所。尽其天眼亦不得见。若人闻此功德称扬法门。闻已受持读诵通利。彼善男子等。皆于不动如来往昔行菩萨行时。皆已见闻。是故闻此法门即得信心清净。舍利弗。东方一切世界诸刹土中。若菩萨乘人。或声闻乘人。于此法门。读诵通利者其数甚多。彼诸菩萨及声闻人。由愿力故于不动刹中。若已生现生当生。唯除不退菩萨。由彼菩萨于诸刹中当得阿耨多罗三藐三菩提故。南西北方四维上下亦复如是。舍利弗。彼不动如来。于妙喜世界及他方刹土。在菩萨等乘中而为上首。舍利弗。若有善男子善女人。闻不动如来功德法门。善能受持读诵通利。愿生彼刹者乃至命终。不动如来常为护念。不使诸魔及魔眷属退转其心。舍利弗应知。是善男子或善女人。乃至无上菩提。无有退转之怖。亦无水火刀杖恶兽毒虫之所损害。亦不为人非人等之所怖畏。何以故。由不动如来常加护念。于彼佛刹当受生故。舍利弗。譬如日轮虽复遥远。与阎浮提众生而作光明。不动如来亦复如是。虽在遥远能与他界诸菩萨众而作光明。舍利弗。譬如比丘有天眼者。能见远方诸善恶色。不动如来虽在彼刹。余世界中诸菩萨众所有形类等色皆悉能见。舍利弗。又如比丘得心自在。获彼神通波罗蜜者。虽在遥远了知一切有情之心。不动如来亦复如是。能知余界诸菩萨心。舍利弗。譬如比丘证得天耳。身虽在远能闻诸声。不动如来亦复如是。余世界中所住众生作如是言。我于彼刹愿当生者彼佛皆闻。舍利弗。如是色类善男子善女人所有姓名。不动如来皆悉了知。若有受持读诵通利此功德法门者。此诸人等。皆为不动如来之所知见及已护念。时舍利弗白佛言。希有世尊。乃至彼佛世尊。护念彼诸菩萨摩诃萨。如是白已。佛告舍利弗。如是如是。如汝所言。彼菩萨摩诃萨。如来之所护念。何以故。由护念菩萨故。一切众生皆得护念。舍利弗。譬如刹利灌顶大王。多有仓廪盈储谷豆。严诫主司善令监守。何以故。于饥馑世当济群生。舍利弗。是诸菩萨。于彼如来灭度之后。当证无上正等菩提。能于正法饥馑之时作大丰稔。如来亦复如是。善能覆护此诸菩萨。舍利弗。于此世界有诸菩萨。当闻不动如来功德法门。能善受持读诵通利。于彼佛刹愿欲受生。应知此人得不退转。舍利弗。若余菩萨于此法门。善能受持读诵通利。为无量无数百千众生开示演说。亦令诸有情如是殖众善本。使当亲近无上菩提。舍利弗。若菩萨愿速证无上菩提者。应当受持读诵通利如是法门。为诸众生开示演说。何以故。菩萨摩诃萨。应如是演说此功德门大智慧业。当如是如是发起积集。彼诸人等由发起积集故。于其现身诸漏当尽。舍利子。是故声闻乘者。若闻彼法门应当受持读诵通利。广为众生开示演说。何以故。此善男子善女人。由受持如是正法。于其现身当证无学。舍利弗。若有净信男子女人。于此功德称赞法门。应当为他时时演说。彼诸人等不越两生。当于现身得尽诸漏。复次舍利弗。此不动如来所有功德称赞法门。非愚浅者之所能受。其有智慧深广方能受持。舍利弗。彼善男子善女人当见诸佛。于此功德称赞法门必当身得。舍利弗。譬若无价宝珠从海持来。于意云何。此无价宝何人先得。舍利弗白佛言。世尊。有诸国王王子大臣此人先得。佛告舍利弗。彼佛功德法门。亦复如是菩萨先得。是诸菩萨当不退转。若闻此法。必能受持读诵通利。为无上菩提于真如性当勤修学。舍利弗白佛言。世尊。若诸菩萨欲住不退地者。闻此称赞法门。应当受持读诵通利。何以故。菩萨摩诃萨住此法门。于法性中当不退转。佛告舍利弗。假使有人终以金宝满阎浮提。持用布施冀闻此法终亦不闻。何以故。此功德法非薄福众生当执持故。复次舍利弗。若声闻乘人闻此功德法门受持读诵。为无上菩提及真如相应故精勤修习。彼于后身当得成就。或于二生补处。或复三生终不超过当成正觉。彼若闻此称赞法门读诵通利。复为无量。百千众生开示演说。舍利弗。如转轮王。以先业感七宝见前。不动如来亦复如是。以本愿力。我今说此功德法门。舍利弗。若诸菩萨摩诃萨。于此称赞法门。若已闻若当闻者。彼皆由不动如来往昔行菩萨行时慈悲愿力。或当于贤劫中诸佛世尊之所。预闻开示此之法门。如我于今演说开示。不增不减名数若干。舍利弗。是故菩萨摩诃萨欲速证无上菩提者。于此功德称赞法门。应当受持读诵通利为他广说。复次舍利弗。若善男子善女人。为求此法门故。于彼村落城邑。听闻受持读诵通利。虽出家菩萨居白衣家。我说无过亦随听住。何以故。彼善男子善女人。于命终后欲。令此法当不隐没。舍利弗。若彼村邑在于遥远。是诸菩萨亦当应往。及住彼中受持读诵开示演说。舍利弗。彼善男子善女人。于已流布称赞法门。或于他人有是经卷。应可诣彼而书写之。彼人若有愿求汝当断食。或使经行若坐若立。等应曲随教命书写是经。若于彼村求不能得。应诣邻境书写受持读诵通利。复为他人开示演说。若往余方勤求不获。彼人应发如是誓心。我于无上菩提。不应生于退转之相。由我已闻不动如来法门名号。是人于我欲为利益令我听闻。舍利弗。如是称赞法门。有能演说及预闻者。皆由如来威神之力。时舍利弗白佛言。世尊。如来灭后由谁威力而当得闻。舍利弗。我灭度后。由不动如来威神之力。当复得闻。或由四大天王释提桓因等当勤加护。令诸法师宣扬此法。及彼菩萨本业成熟。四天王等威加策进。令诸菩萨而得听闻。舍利弗白佛言。世尊。如此法门能成就广大功德。佛告舍利弗。如是如是。如汝所言。舍利弗。若于国中雨雹为灾。非时霹雳及余种种可怖之事。彼善男子善女人等。应当专念不动如来及称名号。是诸灾害皆得消除。由彼如来往昔弘济百千诸龙解脱众苦。又由慈悲本愿诚谛不虚。回向善根要期圆满故。称彼名号忧患自消。唯除有情宿业成熟。舍利弗白佛言。世尊。是诸菩萨现身欲证无上菩提者。应如不动如来往修愿行。佛告舍利弗。如是如是。如汝所言。舍利弗。少有菩萨摩诃萨。已能如是具修净刹及当净修。如不动如来者。舍利弗。彼诸菩萨皆当证得阿耨多罗三藐三菩提。而于佛性及一切智。摄受佛国悉皆同等。菩萨声闻非无优劣。而于解脱则无有异

尔时欲界诸天及梵众天等。皆向彼如来合掌顶礼。而三唱言。南无不动如来应正等觉甚为希有。又归命此界释迦牟尼如来应正等觉。善能说彼称赞法门。尔时欲界诸天。以曼陀罗花及诸天香以散佛上。所散香华于虚空中合而成盖。复以诸天花香。遥散彼佛以为供养。时天帝释作如是念。我此四众及欲界诸天。皆欲见彼不动如来应正等觉。尔时世尊。知彼释天心之所念。结加趺坐安处虚空。是诸大众。以佛神力亦住空中。皆遥见彼妙喜世界不动如来及声闻众。众皆见已右膝着地。向不动如来应正等觉。尔时此界众人皆作是念。岂非三十三天为见彼佛而来集会礼拜供养。是时帝释作如是念。彼界诸天以人相而住。我见彼诸人等服玩资具。与彼诸天无少优劣。尔时世尊摄神通已。告天帝言。彼诸人民皆受天乐汝应爱乐。是诸人等见彼如来。及爱乐彼受天资具者。彼诸众生从余世界命终以后。皆得往生不动佛刹。尔时舍利弗告帝释言。汝见释迦牟尼佛。及不动如来。由此缘故。汝于此身得大善利。况汝已得过人之法。时天帝释作如是念。彼诸众生闻此法门亦得善利。何况得生不动佛刹。尔时佛告天帝释言。彼菩萨乘人。当生彼佛刹者。亦得善利。何以故。彼诸菩萨皆应得住不退转故。若余菩萨于其现身。愿生彼佛国者。应知皆是住不退转。佛说此法门时。五百比丘。于无漏法心得解脱。五千菩萨。六千比丘尼。八千优婆塞。十千优婆夷。及欲界中无量天子。于彼佛刹皆愿受生。如来是时皆与授记。于彼佛刹当获往生。若余有情当愿生者。如来亦当与记生彼佛刹。是时三千大千世界六种震动。所谓动遍动。等遍动。摇遍摇。等遍摇。震遍震。等遍震。由此法门所加持故。佛说此经已。舍利弗等。及诸世间天人阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽。闻佛所说。皆大欢喜信受奉行

大宝积经卷第二十大宝积经卷第二十一

        大唐三藏菩提流志奉　诏译

    被甲庄严会第七之一

如是我闻。一时佛住王舍城迦兰陀竹林。与大比丘众及诸菩萨摩诃萨俱。悉从种种佛刹来集。尔时世尊。无量百千众所围绕供养恭敬。时彼众中有菩萨摩诃萨。名无边慧。即从坐起。偏袒右肩右膝着地。稽首作礼合掌向佛白言。世尊。我有少疑请问如来。愿垂听许为我宣说。尔时无边慧菩萨摩诃萨。而说偈言

  大雄大丈夫　　世间无与等
  我为众生故　　少疑当请问
  不起师子座　　现身遍十方
  一切异论中　　无能倾动者
  智藏无边际　　诸力无有量
  世尊一一力　　普能度世间
  善住一切智　　善住于十力
  无畏大师子　　最胜无上尊
  十八不共法　　如来之所有
  照明于世间　　摧伏诸外道
  了知一切法　　是故无过上
  无失大导师　　我疑当请问
  无边离垢智　　大海不动智
  境界无碍智　　我疑当请问
  世尊善修集　　于道无疑惑
  安隐大导师　　我疑当请问
  已度诸暴流　　已断诸结缚
  能拔众毒箭　　我疑当请问
  已破无明[穀-禾+卵]　　已息烦恼热
  清凉善安住　　我疑当请问
  无畏无上智　　无著无碍智
  法海一切智　　如来已证得
  佛无量功德　　智证悉圆满
  尽一切有漏　　破诸烦恼见
  世尊多积集　　无量大功德
  不思议法王　　我疑当请问
  世尊殊胜智　　普能照世间
  演畅法光明　　无边功德海
  导师法光故　　遍照于世间
  是故世间中　　佛法光明现
  法海一切智　　辩才无有上
  精进不思议　　清净离诸见
  佛眼无边故　　智境亦无边
  世间无等尊　　我疑当请问
  法王大牟尼　　能断众生惑
  导师我当问　　愿随其意乐
  我观一切处　　天上及人间
  无有等如来　　普遍照明者
  善住诸功德　　庄严大丈夫
  不思议法王　　仙中照曜者
  譬如大雪山　　众宝端严处
  世尊安法座　　端严亦如是
  妙音大精进　　能宣悦意声
  众生若得闻　　善根悉清净
  世尊人中胜　　时演法光明
  以是诸众生　　随意便开觉
  知时知众会　　知人大导师
  敷演法光明　　以时智慧者
  梵音大精进　　愿赐清净言
  如天雨大地　　法润遍沾洽
  世尊处众会　　普宣法雨已
  于此法悕望　　众生皆满足
  最上胜安住　　如王处妙高
  惠施诸众生　　能令众欢喜
  大雄两足尊　　不思议境界
  一切诸众生　　无有能知者
  无量大丈夫　　众会已和合
  依怙大牟尼　　志求佛境界
  我于佛境界　　发趣故来集
  导师无碍智　　如何疾开觉
  我随其意乐　　瞻颜欲请问
  世尊愿开示　　为断诸疑惑
  若闻无上法　　便得心欢喜
  踊跃充遍身　　能断众疑网
  法王无上尊　　一切智无畏
  一切知见者　　我疑当请问
  佛于一切法　　无有少疑惑
  精进大导师　　我疑当请问
  无上断疑者　　于法不疑惑
  无边功德海　　我疑当请问
  无边大光明　　无边大功德
  无边清净智　　我疑当请问
  无边精进智　　无边境界智
  无边饶益智　　我疑当请问
  世尊无边智　　离边及无边
  能断一切疑　　我疑当请问
  不思议法王　　垂哀听我问
  见许我当问　　牟尼为宣说
  请问一切智　　释迦名称尊
  若垂听许我　　愿决我疑网

尔时世尊。告无边慧菩萨摩诃萨言。无边慧。汝今于我渴仰志求。欲于如来几何所问。若有问者我当解说。尔时世尊。而说偈言

  告无边慧　　汝欲何问　　悉应问之
  我当解说　　如彼所问　　一一发明
  随其乐欲　　速为开示　　我为汝说
  一切无疑　　如汝志求　　称汝所问
  汝今时问　　如时如义　　以时问故
  我决定说　　如汝意乐　　问所应问
  我皆随顺　　为汝说之　　汝今时问
  我亦时说　　断汝疑网　　当得无疑
  我为法王　　了义究竟　　于一切法
  得无疑惑　　我于诸法　　正觉难思
  如众生意　　所问为说　　我于诸法
  悉无有疑　　时而问者　　速当为说
  我时为说　　无有疑惑　　如其意乐
  释彼所疑　　我常了知　　时及众会
  诸众生等　　意趣所同　　亦常观察
  一切众生　　有欲无欲　　彼皆明见
  若有智者　　能善修行　　我皆以时
  正法开悟　　若无智者　　愚痴迷乱
  彼无慧明　　不尊重法　　若无尊重
  于法不求　　虽闻此法　　无大明智
  法善巧者　　于法希求　　若闻此法
  得大明智　　乐大乘者　　求人中尊
  闻斯法已　　得大明智　　佛无上智
  不思议智　　而发趣者　　闻皆满足
  乐无碍智　　求最上尊　　彼闻此法
  得大饶益　　若有智性　　求不思议
  彼闻此法　　得无上智　　若有众生
  求佛道场　　转无上轮　　得法欢喜
  爱乐精进　　于法尊崇　　闻离垢法
  欣然踊跃　　若有众生　　乐善修习
  以法光明　　说无上法　　荷诸重担
  无边策修　　彼闻法已　　欢喜充满
  若有希愿　　善法思惟　　于彼慈哀
  为之开释　　哀愍汝等　　随汝所问
  我能决定　　当断汝疑　　我多千岁
  修行善巧　　疑惑已除　　知汝意乐
  若有疑者　　恣汝所问　　当为汝说
  断诸疑惑　　若有疑者　　恣汝所问
  如其乐欲　　我当说之　　若有疑者
  恣汝所问　　我住于法　　得无动摇

尔时无边慧菩萨摩诃萨白佛言。世尊。如来应正遍知。我于菩萨乘中少有所疑。今当请问。何等善丈夫远离于怖畏一心正念。为诸众生被大甲胄。于大甲胄而庄严之。起大爱乐而尊重之。以不放逸乘此大乘。以大清净平正之道。无诸堆阜瓦石荆棘众恶杂秽。诸见稠林亦无毒刺苦恼坑陷。亦无系执怖惧艰难。正直无曲如理平道。无障碍道。剪诸稠林。裂一切网。远离黑闇。蠲除爱着舍和合故。而发趣于阿耨多罗三藐三菩提。世尊。如来应正遍知。我于此义故致斯问。何等善丈夫。何等大甲胄。被此甲胄乘于大乘。以斯大道而当发趣。世尊。应说诸菩萨摩诃萨甲胄庄严。安住于道。安住诸法理趣善巧。于法理趣住善巧故。而能起于诸法理趣善巧光明。法光明故不舍甲胄。乘于大乘。以不退转精进之力。无忘念根。相续慧力。速能成就法界理趣分明善巧。往诣道场转于法轮。为诸众生演说法故。一切众生如其所愿。如其发趣解脱生死。世尊。如来应正遍知。此之大乘。我欲利益安乐众生故问斯义。世尊。如来一切知者。一切见者。以何等法成就诸菩萨摩诃萨一切诸法海印三昧。以三昧故令诸菩萨摩诃萨乃至未证阿耨多罗三藐三菩提犹不退转。世尊。如来知见成就未曾有法。善诸众生智慧之药。故我问耳。尔时无边慧菩萨摩诃萨。而说偈言

  为诸菩萨故　　我问两足尊
  一切知见者　　甚深佛法义
  大乘所修行　　何定能发趣
  我今皆请问　　饶益诸众生
  云何善丈夫　　能被无边甲
  如是被甲已　　云何当发趣
  云何起乐欲　　云何爱于彼
  云何大精进　　云何不放逸
  云何诸菩萨　　乘于此大乘
  乘已复云何　　此事应当说
  云何乘大乘　　发趣菩萨道
  唯愿世尊师　　速为我宣说
  云何平正道　　平等而发趣
  于诸见稠林　　剪伐恒无倦
  于诸境界中　　云何得超越
  云何以平等　　裂于贪爱网
  云何除黑闇　　得大智光明
  彼诸菩萨等　　云何当发趣
  云何能观察　　远离众结缚
  云何诸菩萨　　离缚善安住
  云何诸菩萨　　超过大怖畏
  善巧诸法义　　发趣于无上
  菩萨被何等　　无边大甲胄
  被斯甲胄已　　乘于此大乘
  云何诸菩萨　　发趣平正道
  我今所问者　　世尊应演说
  菩萨云何得　　庄严大甲胄
  庄严无上乘　　世尊应演说
  安住于斯道　　及彼道庄严
  诸法之善巧　　世尊应演说
  云何能了知　　法界之理趣
  法善巧光明　　世尊应演说
  云何诸菩萨　　得此法光明
  究竟一切法　　世尊应演说
  云何诸菩萨　　得法光明已
  不舍大甲胄　　由是而发趣
  云何诸菩萨　　乘于此大乘
  精进不退转　　由是而发趣
  云何诸菩萨　　志念常坚固
  能以智慧力　　而得善调伏
  云何得法界　　理趣之善巧
  法王不思议　　世尊愿宣说
  云何能速往　　至于菩提场
  转于大梵轮　　世无能转者
  云何无所动　　演说于诸法
  为一切众生　　如其昔所愿
  演说诸法故　　解脱于生死
  云何令众生　　究竟获安乐
  饶益众生故　　我问世导师
  一切知见者　　愿为我宣说
  当以何等法　　成就诸菩萨
  一切法大海　　所作印三昧
  乐求佛法者　　渴仰大菩提
  若闻此法者　　举身悉充悦

尔时世尊。告无边慧菩萨摩诃萨言。善哉善哉无边慧。汝于往昔供养承事无量诸佛。种诸善根集诸功德不可称量。于此深法欣求渴仰。以大志乐成就众生。而兴大悲问于如来。汝今谛听善思念之。吾当为汝说诸菩萨摩诃萨以功德成就。而发趣于阿耨多罗三藐三菩提。唯然世尊。愿乐欲闻

尔时世尊。告无边慧菩萨摩诃萨言。无边慧。诸菩萨摩诃萨。为阿耨多罗三藐三菩提被甲胄者。为欲摄取诸众生故被大甲胄。为诸众生布施清净故被大甲胄。为诸众生持戒清净故被大甲胄。为诸众生忍辱清净故被大甲胄。为诸众生精进清净故被大甲胄。为诸众生禅定清净故被大甲胄。为诸众生智慧清净故被大甲胄。为诸众生获安乐故被大甲胄。为诸众生起饶益事相应心故被大甲胄。为诸众生贪嗔痴病作对治故被大甲胄。为大功德作善巧故被大甲胄。为无上智善圆满故被大甲胄。为诸众生生死怖畏作救护故被大甲胄。为欲显现无等等智善圆满故被大甲胄。于此三千大千世界。所有诸魔若魔眷属。若魔使者住魔业者。及行诸见稠林险迳。一切外道诸遮罗迦出家。吠陀乌摩利迦。路伽耶陀。及此外道相应之辈与交战故被大甲胄。诸菩萨摩诃萨如是被于大甲胄已。不舍甲胄起大精进。能入一切众生界中。以忍安住远离怖畏。不惊不惧不动不乱。而复被于无边甲胄。所谓救护一切众生甲胄。剪一切见稠林甲胄。破诸魔军甲胄。能授智慧甲胄。无边津梁甲胄。度诸重担甲胄。增长净信甲胄。安住尸罗甲胄。净治业藏甲胄。一切清净力藏甲胄。方便善巧力藏甲胄。能断一切执着甲胄。不退不悔智慧甲胄。诸菩萨摩诃萨。被于如是大甲胄已亦不舍离。乃至尽边际。坚固精进力曾不动摇。而发趣于阿耨多罗三藐三菩提。尔时世尊。而说偈言

  菩萨被甲胄　　为摄诸众生
  众生无边故　　被甲亦无边
  布施清净故　　一切令充悦
  为利诸众生　　乃被斯甲胄
  持戒清净故　　饶益于世间
  为利诸众生　　乃被斯甲胄
  忍辱清净故　　勇猛善安住
  为利诸众生　　乃被斯甲胄
  精进清净故　　成就不退转
  为利诸众生　　乃被斯甲胄
  禅净定清故　　所行境亦然
  为利诸众生　　乃被斯甲胄
  智慧清净故　　无漏无过上
  为利诸众生　　乃被斯甲胄
  一切诸众生　　乐具悉当与
  善知此义故　　乃被斯甲胄
  菩萨于众生　　能为饶益事
  以清净四摄　　普遍诸有中
  若病贪嗔痴　　而为对治者
  授诸众生药　　所患令消除
  由是诸菩萨　　善能被甲胄
  于功德资粮　　获无边善巧
  众生生死苦　　逼迫不安隐
  我当为救护　　被甲胄无边
  无边生死苦　　我能令解脱
  爱见网所缚　　一切皆当断
  于此烦恼网　　一切能断者
  坚固精进力　　勇猛而被甲
  一切诸众生　　令住安乐道
  以是趣涅槃　　安隐而无上
  以大精进力　　乃被斯甲胄
  当共一切魔　　敌战尝无倦
  若住于诸见　　稠林而行者
  路伽耶陀等　　被甲利于彼
  及余无量众　　行诸非道者
  于彼咸利益　　故被甲无边
  如是被甲已　　不舍于甲胄
  起大精进力　　被甲胜坚固
  入于生死界　　以忍得安住
  成就坚固忍　　被甲无过上
  远离于怖畏　　亦无有惊惧
  被无边甲胄　　一切勤修习
  善住于甲胄　　常能正了知
  寂然不动摇　　不乱不退转
  被如是甲已　　智者复当被
  救护众生甲　　破坏众魔甲
  无边津梁甲　　一切悉当被
  勇猛胜智人　　被已得安住
  为大重担故　　被甲无有上
  度一切众生　　苦担悉令脱
  增长清净信　　善住于六根
  戒得共相应　　被甲无过上
  成就勇猛智　　菩萨能安住
  威仪戒相应　　被甲无所动
  于昔胜尊众　　清净修诸业
  是故被甲胄　　而常不怯弱
  以爱众生慧　　饶益诸世间
  通达于方便　　被甲善安住
  于巧方便智　　菩萨能通达
  如是被甲已　　断除众结缚
  远离一切执　　正信不违背
  被甲之智人　　发趣于无上
  菩萨能决定　　自利及利他
  以善精进力　　坚固无退转

复次无边慧。诸菩萨摩诃萨。于无量劫荷诸重担被大甲胄。如是甲胄。若魔若魔眷属或魔使者。及行邪见稠林恶碛。诸众生等所不能见。何以故。无有形色不可示现。无对无相舍相离相无名字故。无边慧。假使飞箭量如须弥。攒锋激射无能中者。设以三千大千世界所有众生。一一为魔。各有若干魔军眷属。竞共俱时发诸利箭。亦如须弥彼终不能坏。诸菩萨摩诃萨。如是甲胄乃至不能损一毛端。于诸菩萨摩诃萨意。尚犹不能令有异念。何况身也。诸菩萨摩诃萨。若以一心摧伏彼者。能令众魔退散消灭善能安住。如是甲胄而不动摇。一切众生无能坏者。何以故。以无相故。非诸众生见所行故。一切众生不能见知。诸菩萨摩诃萨。而能了知一切法故。如实知见被大甲胄。为欲救护诸众生故。于一切法无所执着。为欲饶益诸众生故。于一切法亦无所得。是故众生不能见知。如是甲胄无有形相无有示现无言说故。不与色相应。不与受想行识相应。不与内相应。不与外相应。不与亦内亦外相应。不与非内非外相应。不与界相应。不与处相应。不与地界相应。不与水界相应。不与火风空界相应。不与欲界相应。不与色无色界相应。不与有作相应。不与无作相应。不与亦有作亦无作相应。不与非有作非无作相应。不与声闻地相应。不与独觉地相应。不与佛地相应。不与语言道相应。亦不与色因相应。不与色相相应。不与受想行识因相应。不与受想行识相相应。亦不与相非相相应。亦不与一切法相应。非不相应。无有系缚。无有解脱。亦非算数譬喻可知。以一切法过诸数故。如是甲胄。一切法见皆不可得。色见不可得。受想行识见不可得。乃至无少法见可得。如是甲胄不与一切法相应。非不相应。不与色相应。非不相应。不与受想行识相应。非不相应。于一切法若相应不相应彼皆远离。如是甲胄。亦无有作。作者无故。亦无有相。相非有故。无处所相。无和合相。无有分别。无有动摇。无有攀缘。无性可见。被甲胄者亦不可得。如是被甲亦不可见。何以故。诸菩萨摩诃萨被甲胄时。而不见有谁为被甲。何处被甲。从何被甲。亦不见有我能被甲我所被甲。亦不见有此处被甲他处被甲。亦不见有如是被甲所为。众生于一切法无所行故。无所有故。诸菩萨摩诃萨。被如是甲胄则被如来所被甲胄。身不可得。心不可得。意不可得。不可得故远离分别。诸菩萨摩诃萨。若住少法。若得少法。现被甲胄。当被甲胄。不应说名被大甲胄。若心超过。乃可说名被不思议大甲胄也。诸菩萨摩诃萨。不为少众生故被大甲胄。亦不为一劫众生故被大甲胄。亦不为百千劫百千俱胝劫。百千那由他俱胝劫。诸众生故被大甲胄。为于无量无数劫中诸众生故被大甲胄。是故说名被于无量大甲胄也。诸菩萨摩诃萨被甲胄时。被于不住众生想甲胄。不起我想甲胄。离众生想甲胄。灭我想甲胄。知众生性甲胄。知我性甲胄。过想受甲胄。知一切法无作相甲胄。空相甲胄。无想相甲胄。无愿相甲胄。知一切法无生相甲胄。无灭相甲胄。知一切法差别性相甲胄。无差别性相甲胄。知一切法事相甲胄。无事相甲胄。无边慧。若住于事而被甲胄。终不说名被大甲胄。以诸菩萨摩诃萨不住于事求大智慧。是故说为被大甲胄。尔时世尊。而说偈言

  无量千劫中　　被大无边甲
  为欲令众生　　解脱诸苦恼
  如是大甲胄　　若魔若魔使
  作诸魔业者　　眼所不能见
  及余众生等　　行见稠林者
  甲胄不思议　　亦非彼所见
  无色无形像　　无对无相待
  甲胄不思议　　故非眼所见
  无名亦无相　　远离一切相
  甲胄无有边　　故无相见者
  假如须弥箭　　攒钻来中射
  甲胄不思议　　令箭自摧折
  世界所有魔　　亦以须弥箭
  于斯大甲胄　　竞共来激射
  然于大甲胄　　不损如毛端
  甲胄不思议　　无能摧坏者
  由是诸菩萨　　身心无变异
  甲胄不思议　　谁能倾动者
  若以一念心　　摧伏诸魔众
  菩萨不思议　　魔军咸退散
  如是大甲胄　　未尝有动摇
  一切诸众生　　而无能见者
  一切诸众生　　不知甲胄相
  是故诸众生　　眼所不能见
  菩萨为依怙　　能知一切法
  犹若胜金刚　　斯为善被者
  不受一切法　　救护诸众生
  顺诸佛法故　　斯为善被者
  甲胄无所取　　随顺一切法
  甲胄不思议　　斯为善被者
  甲胄无示现　　净治一切法
  诸法离言说　　无能示现者
  不与色相应　　不与受相应
  不与想行识　　相应及和合
  不与内相应　　不与外相应
  不与内外俱　　相应及和合
  不与界相应　　不与处相应
  若界若处中　　亦无有和合
  不与地相应　　不与水相应
  不与火风空　　相应及和合
  不与欲相应　　不与色相应
  不与无色界　　相应及和合
  一切无所得　　不与诸有作
  不与诸无作　　相应及和合
  甲胄不思议　　无住无和合
  无缚无解脱　　亦无不相应
  甲胄无边际　　不共声闻地
  不共独觉地　　相应及和合
  乃至诸佛地　　及与一切法
  一切不相应　　一切不和合
  种种语言道　　而无能及者
  甲胄无有边　　无体难思故
  不与一切法　　相应不相应
  甲胄不思议　　超过一切数
  甲胄无有上　　无缚无非缚
  亦无有色相　　受想行识相
  不与彼诸相　　相应及和合
  不与诸法相　　相应不相应
  亦不与无相　　相应及和合
  甲胄无有上　　无缚无解脱
  一切诸法中　　不堕一法数
  一切诸法中　　甲胄不可得
  是故无有上　　说名不思议
  甲胄无有色　　无受亦无想
  无行亦无识　　非诸蕴所摄
  如是勇猛者　　被斯大甲胄
  身心无所得　　不见微少法
  过诸思择故　　清净心安住
  而常无怯弱　　说名不思议
  坚固被甲胄　　其心无所动
  不计诸劫量　　说名不思议
  甲胄无有量　　不取法非法
  以无时量故　　说名不可量
  不起众生想　　亦无有我想
  能知此想故　　一切想不生
  亦知一切法　　此法皆无相
  如是被甲胄　　说名不思议

复次无边慧。此大甲胄。名曰妙法严具庄严。亦名最上。不可坏故。亦名一切法无差别。不于少法作差别故。诸菩萨摩诃萨被此甲胄。持大慧力。乘于大乘最上之乘。无等等乘。大摄受乘。无边摄受乘。一切众生乘此乘者。于此乘中无不容受。然于此乘不增不减。能令众生安乐而住。亦令众生安乐而出。若有众生乘此决定安乐乘者。无有身心疲倦劳苦。无边慧。此乘映蔽一切世间天人阿修罗声。闻缘觉。及余诸乘而当出离。此乘无来无去无住无见无知。前际不可得后际不可得。中际不可得。三世平等犹如虚空。不离尘染。无有相待。无有障碍。亦无执着。以此乘故而当出离。此乘无量不可量故。本无碍相不住相故最上第一。乘此乘者无怯弱心。而发趣于阿耨多罗三藐三菩提。无边慧。此乘如灯如日月轮。为诸众生作大光明。此之大乘亦复如是。光照三千大千世界。无能映蔽无能障碍。能以无边大功德海。而发趣于阿耨多罗三藐三菩提。无边慧。此乘离闇。能除一切世间之病。超过一切世间之法摄大众生。非诸下劣所能乘也。唯除能被大甲胄者。如我所说。于无量劫救护众生。供养诸佛种种善根。资粮清净之所能乘。声闻缘觉及余下劣。系缚世间世间相应。或增上慢。慢所调伏一切外道无信之辈。尚不欲闻此乘之名。何况而能乘此乘也。若有众生游戏不可思议境界。乘此乘已如其胜愿。而发趣于阿耨多罗三藐三菩提。无边慧。此乘无际。初中后际不可了知。此乘际断。际不可得无边际。是乘际无量际。是乘际无边慧。乘无边际。亦无中际。无有少际而可断者。言际断者。以无少际说为际断。不分别际说为际断。如是名为此乘际断。际无所有说为中际。际无所有说为边际。际无所有以际说之。于彼际中际不可得。不可得故边际中际无际无断入于际门。入际门故此乘超过。于彼超过亦无所得。无边慧。何者为际。谓断常际。入语言故际则非际。彼断常际无有边际。以彼际相相无边故。所言际者无有分别。分别断故超过于际远离断常。无边慧。有身见者。则于际门有所依止。若无身见。则于际门无所执着。无执着故。于断常际乃能超过。无边慧。断常际者而无有实。但诳语言。于三有中分别二际。于彼二际。若不摄取若不相应。乃能超过断身见故。于二际门而无所执。无边慧。若诸菩萨摩诃萨。未离身见。则不名为被大甲胄乘于大乘。于彼际门则为执着。设欲断际起断际想。于前后际而有分别。若诸菩萨摩诃萨。已离身见。是则名为被大甲胄乘于大乘于彼际门则无所执。过二际已以安乐乘。而发趣于阿耨多罗三藐三菩提。无边慧。诸菩萨摩诃萨。以大慧力。能于一切住际之法不断不破。善巧方便摄取止观。修习无相得无相证。则为诸佛授法光明。法光明故一切际断。于彼际断亦无所执无有少际。于彼际门。若相应。若不相应。若忆念。若不忆念。于一切法。善巧方便安住止观。便获无边大法光明。法光明故远离黑闇怖畏毛竖。建大法幢出大梵音。大师子吼告众生言。汝等速来。于此大乘大安乐乘大调御乘大发趣乘。而发趣于阿耨多罗三藐三菩提。为诸众生演法光明。法光明故。能令众生被大甲胄乘此大乘。无边慧。诸菩萨摩诃萨。于此大乘此大甲胄勿生悭吝。当愿众生发菩提心。被此甲胄乘此大乘。于此大乘此大甲胄亦勿悭吝。而能展转劝诸众生。复愿众生被此甲胄乘此大乘而当出离。诸菩萨摩诃萨。住是行时。摄取佛国清净佛国。摄取声闻及诸菩萨圆满功德。以此无边大功德海。而发趣于阿耨多罗三藐三菩提。无边慧。此之大乘等于法界。此岸彼岸无可得者。然能运载一切众生。从此至于法界之中。无处相应。法界相应。甲胄相应。若于此乘等于法界。勤修习者。而发趣于阿耨多罗三藐三菩提。无边慧。譬如法界无有尘染。无能坏者。无能染者。此之大乘亦复如是。无坏无染无坏染故。而当趣于一切智智。是故此乘说为大乘。此乘无碍。一切世间天人阿修罗不能退转。以无著故而当趣于一切智智。是故此乘说为大乘。言大乘者谓大庄严。一切庄严无不入此大乘中者

尔时无边慧菩萨摩诃萨白佛言。世尊。于此乘中。岂有有为诸庄严耶

尔时世尊。告无边慧菩萨摩诃萨言。如是如是无边慧。我随世俗。于此乘中亦说一切有为庄严。无边慧。若转轮王帝释梵王。无不皆从此大乘出。若已出者。若当出者。虽住转轮释梵尊位。不为生死烦恼过失之所染着。能于诸欲一一称量。既称量已则便厌舍。于出离道而能了知。无边慧。若诸菩萨摩诃萨。乘此乘者虽受生死。于一切处不为染污。能见过患能知出离。若我于此未说诸法及诸庄严。以此乘相。于彼诸法及诸庄严亦能了知。而发趣于阿耨多罗三藐三菩提。尔时世尊。而说偈言

  大乘无上乘　　此乘不思议
  若有乘此乘　　彼皆当出离
  是大依止处　　此乘不思议
  无量无边际　　故名为大乘
  一切诸众生　　乘于此乘者
  此乘无有减　　亦复无有增
  一切诸众生　　乘于此乘者
  安乐而发趣　　于中无苦恼
  若诸菩萨等　　于此乘发趣
  直进无他行　　身心不疲倦
  照明于世间　　天人阿修罗
  当于此大乘　　无上而发趣
  映蔽诸缘觉　　及以声闻乘
  亦于此大乘　　无上而发趣
  无来亦无去　　无住无前际
  后际及中际　　无得无所见
  三世悉平等　　犹若净虚空
  此乘亦如是　　远离诸烦恼
  此乘无相待　　无障无挂碍
  一切悉能救　　所向无执着
  此乘无有量　　亦无一切相
  自性不可得　　无畏不思议
  若有乘此乘　　得无所畏者
  乃于佛法中　　无障无挂碍
  以此乘发趣　　普明于世间
  如日百千光　　无时而不照
  此乘不可坏　　无能映蔽者
  无量德资粮　　无上而发趣
  此乘超世间　　出过于三界
  远离诸黑闇　　能趣于无漏
  此乘唯摄取　　一切诸菩萨
  其余众生类　　于中不容受
  若有智慧者　　无量千劫中
  方便勤修习　　乃乘于此乘
  非诸声闻众　　及以诸缘觉
  一切外道辈　　而能乘此乘
  若有诸众生　　趣于非道者
  斯人鲜福德　　不堪闻此乘
  若有诸众生　　于不思议法
  善巧而游戏　　安住于此乘
  随其所建立　　殊胜之誓愿
  住斯正道中　　无上而发趣
  此乘无边际　　亦无有中际
  边际及中际　　一切不可得
  以际不可得　　此乘无有际
  一切际断故　　安乐而发趣
  此乘无边际　　无边是乘际
  此乘无量际　　无量是乘际
  此乘无际断　　无际为际断
  于际不分别　　断亦不可得
  乘际无边际　　亦无有中际
  亦无无际际　　际性无所有
  于际无际相　　非际为际相
  于彼诸际中　　际相无所有
  非际说际门　　此乘已超过
  于彼所过量　　相应不可得
  我说断常际　　有边无边际
  如是一切际　　彼际悉非际
  一切际无边　　际相无所有
  一切际自性　　于中不分别
  如是诸际中　　以断于分别
  边际无边际　　一切悉能断
  若有有身见　　则说诸际门
  执着此诸际　　为无依怙者
  若无有身见　　不着诸际门
  不执一切际　　为能照明者
  一切际非际　　诸际非真实
  一切际性相　　彼皆无所有
  不受一切际　　于际悉超过
  不着诸际门　　能断有身见
  若于有身见　　不断不远离
  不被大甲胄　　不乘于大乘
  以受于诸际　　分别诸际相
  前际及后际　　一切皆分别
  若于有身见　　一切已能断
  乃被无边甲　　乘于无上乘
  不着诸际门　　为世智慧者
  能于种种际　　一切悉超过
  由是佛法中　　安乐而发趣
  菩萨善观察　　能以大慧力
  不得少有法　　可断可除灭
  常以善方便　　善摄于止观
  一相了知故　　诸相皆了知
  安住于正法　　得大法光明
  以是法光明　　决了彼诸际
  不见少有际　　若际及非际
  于彼可相应　　一切无所著
  若见苦众生　　慰谕而告言
  汝来于此乘　　安乐而出离
  一切受生处　　能作法光明
  被甲乘大乘　　亦以此开示
  此乘此甲胄　　于彼勿悭吝
  亦令诸众生　　被甲乘大乘
  乘此安乐乘　　无上而发趣
  如是诸菩萨　　安住此修行
  能于佛法中　　以速而发趣
  清净佛国土　　摄受诸声闻
  及诸菩萨等　　功德庄严事

大宝积经卷第二十一大宝积经卷第二十二

        大唐三藏菩提流志奉　诏译

    被甲庄严会第七之二

复次无边慧。我念往昔修菩萨行时。被如是甲胄。乘如是大乘。超过诸际能灭黑闇能除怖畏。以大精进。乃于无量百千俱胝那由他佛所。闻此菩萨摩诃萨甲胄庄严大乘庄严。踊跃欢喜观此法时。于佛世尊恭敬尊重。不作是念。我被如是甲胄我有如是甲胄。我得如是法。我有如是法。我有如是种类之法。我于尔时无有我想。远离身见。远离我慢。心无高下亦无分别。为欲摄受一切众生。护持诸佛如来法藏。成熟无量百千俱胝那由他众生。曾无一念劳倦之心。我于尔时。不舍甲胄乘无边乘。世世生中能破魔军。魔诸眷属退败消灭。魔之使者怖畏驰散。一切异道诸遮罗迦路伽耶陀波利婆罗遮伽。及此外道相应之辈。我皆降伏为作安隐。一切异论悉已摧殄。一切外道悉已降伏。邪趣众生令于此乘住众善轭。为诸众生开示甲胄甲胄庄严。亦为众生演说如是种类之法。安乐大乘。住此乘者便获一切安乐资具。所谓有为安乐资具。转轮圣王安乐资具。帝释梵王安乐资具。及得无为安乐资具。为诸众生说此法时。令诸众生入此法中生圣种性。建大法幢作师子吼。而发趣于阿耨多罗三藐三菩提。无边慧。诸菩萨摩诃萨。应被如是大甲胄已。如理观察而选择之。当于何法而发趣之。于一切法尽能知见无有分别。何以故。诸菩萨摩诃萨。安住正道如理知故。正道发趣如理见故。如理清净则不分别非不分别。而于分别不分别中平等知见。若见有法可求可觅。则不平等不住如理清净知见。以无分别无不分别。于彼分别不分别中。而无执取。以无执取远离分别及不分别。于此道中无有怜愍。无有施为。亦无增益。亦无取舍。住平正道亦不分别。过现未来遍能了知。一切分别所有随眠。于一切法得住平等。无颠倒义。乃得名为住斯道者。无边慧。何等为道及道清净。所谓说名八支圣道。正见。正思惟。正语。正业。正命。正精进。正念。正定。正见能断萨迦耶见。超过一切见所行境。一切诸见于一切处悉得清净。而能了知一切分别。若胜分别。若遍分别则无分别。无胜分别。无遍分别。不住邪思断邪思惟。能见正命。见正命想。见命清净。住清净命。如理能见清净身业。清净语业。清净意业。住于正业。正见语业。于语语者悉能见知。住于正语能净对治。正精进见善摄精进。住正精进。正见忆念而无有念。亦无作意无所执取。以清净念住于正念。正见三昧。于三昧中无所依止而能清净。三昧之见住于正定。无边慧。诸菩萨摩诃萨如是见时。得一切处清净正见住清净道。此清净道为善丈夫之所修行。智者尊重众圣悦可如来称赞。非一切魔魔民。魔使。魔天。大众之所行处。亦非一切爱着外道。依止诤论行见稠林。趣诸非道路伽耶等之所行处。亦非一切爱涅槃者之所行处。何以故。住无为者则于涅槃有所分别。涅槃分别则诸行分别。何以故。涅槃界中超过一切动念分别。尚无无为况有有为。此道能净一切分别。乃无少有无为分别。宁有一切有为分别。若于圣道有分别者。则不名为住于圣道。若断一切动念分别。是则名为住于圣道。住无畏道。住安隐道。住安乐道。此道能至无老病死忧苦之处。此道能至无有自性超过性处。此道能至远离一切性非性处。此道能至无示现相非色相处。此道如空遍一切处。能至无上大宫殿中。如是去者不复退还。便获若干安隐快乐。彼大宫殿不可示现。无诸事相。无少有为。无少无为。已灭有为已舍无为。不与众生有为安乐无为安乐。无边慧。诸有欣乐有为涅槃。彼尚不求有为安乐。况有能于大宫殿者。大宫殿中无有施设。清凉寂静故名涅槃。灭贪嗔痴。断诸随眠。裂爱见网。竭无明流。拔众毒箭。尽不善法。故名涅槃。远离一切憍慢病疾众苦逼恼。故名涅槃。非心意识心所所行。故名涅槃。息诸诤论一切结使乃至法想。故名涅槃。绝诸意乐意乐所求。亦无分别所分别相。故名涅槃。无边慧。是为大般涅槃体性。涅槃无边不可宣说。若有所趣则非是道。道亦无言不可宣说。诸菩萨摩诃萨。若以此道趣于涅槃大宫殿时。亦令无量百千众生住于斯道

无边慧。诸菩萨摩诃萨。于此道中而发趣时。无有劳倦。亦无忧恼。随欲所求。随欲庄严。随庄严处。一一庄严。随摄众生而为说法。令诸众生皆得欢喜。何以故。此道无等能净对治所作究竟。诸佛世尊声闻缘觉。皆于此道而发趣之不相违背。未到彼地未如其愿终不相离。何者为地。谓涅槃地。大宫殿地。譬如虚空不可为喻。唯除虚空以喻虚空。广大空寂名曰虚空。涅槃宫殿亦复如是为大空寂。无有主宰亦无我所。一切众生设入其中。无能摄取一毛端量。广大空寂广大无量名大涅槃。名大宫殿

无边慧。诸菩萨摩诃萨此殊胜道。非诸声闻缘觉所有。住此道者成就一切功德资粮得不退转。为诸众生作大饶益。以殊胜行为大庄严。以是道故而发趣之。如彼庄严亦非声闻缘觉所有。诸菩萨摩诃萨住此道时。若作轮王无所顾吝。有大威德神通变现。而能了知世出世间。若作帝释大梵天王。无所耽着远离憍慢。乐见诸佛乐闻正法。成熟无量百千诸天。趣于阿耨多罗三藐三菩提。尔时世尊。而说偈言

  菩萨殊胜道　　世间无有上
  众圣及二乘　　皆趣于斯道
  一切诸菩萨　　发趣大菩提
  为得道庄严　　以斯道开示
  若于斯道中　　已趣今趣者
  彼皆以正见　　安住于斯道
  一切诸菩萨　　若住平等见
  行于斯道中　　安乐而发趣
  斯道最殊胜　　斯道为无上
  如实能诱进　　于中无所执
  若住于斯道　　行于斯道中
  一切诸智人　　其意不倾动
  不说于斯道　　少有倾动者
  由是无所动　　于动常远离
  我说于斯道　　无动无施为
  亦无有增益　　斯道故无上
  一切诸菩萨　　善住于斯道
  斯道无有爱　　亦复无有憎
  斯道非过去　　斯道非未来
  彼际不分别　　如是而修习
  斯道无烦恼　　斯道无分别
  于义不乖违　　如是而安住
  住于最胜道　　无住为安住
  住于斯道者　　能获清净性
  我说八支道　　众圣之所行
  住于斯道者　　菩提不难得
  菩萨依怙者　　如是住斯道
  能得道清净　　一一而进趣
  斯之最上道　　善士所修行
  如来所称赞　　此智为无上
  魔及魔军众　　魔之所摄者
  外道余众生　　非其所行处
  分别涅槃者　　不住斯胜道
  愚为分别害　　不能趣涅槃
  超过分别者　　无想无分别
  于斯大道中　　以是而发趣
  众圣之胜道　　愚夫皆远离
  若行此法者　　斯道为无上
  斯之最胜道　　能至无上处
  其中无衰恼　　无畏无灾难
  斯之无上道　　无色无形相
  不可以色相　　而能示现者
  斯之安隐道　　正直无所畏
  以斯道发趣　　究竟大涅槃
  斯之最净道　　犹若太虚空
  一切无挂碍　　常趣于涅槃
  若至涅槃者　　一往无复退
  斯之大涅槃　　最上胜安乐
  涅槃大宫殿　　空寂不可量
  故名大涅槃　　亦名大宫殿
  斯大涅槃中　　三毒烦恼灭
  若至其中者　　无退无受生
  涅槃大空寂　　犹若太虚空
  广大空寂故　　于中无挂碍
  涅槃大宫殿　　永离苦忧恼
  无边境界处　　说名为涅槃
  涅槃无数量　　数量不可得
  寂灭清凉性　　设名为涅槃
  涅槃无施设　　趣道亦无上
  无量无分别　　分别不可得
  我为诸菩萨　　开示于斯道
  若住斯道者　　彼近于涅槃
  若住于斯道　　世间胜安乐
  一切皆当得　　说名无畏者
  善住于斯道　　其心无所染
  由是道清净　　说名无畏者
  以见平正道　　一切能随觉
  一切资具中　　一切不贪着
  菩萨依怙者　　殊胜真实道
  饶益诸众生　　勇猛而发趣
  若得无上道　　最上道庄严
  令世悉欢喜　　斯道而发趣
  斯道最殊胜　　能令意清净
  随其所乐求　　一切当发趣
  若得圣王位　　转轮大军旅
  能舍大王位　　出家行学道
  若得天帝释　　大梵天王位
  于彼无耽着　　斯为善顺道
  世间诸学处　　一切能明了
  住于斯道中　　乃为实语者

复次无边慧。诸菩萨摩诃萨。于此道中而发趣时。为欲摄取八正道故修行一法。所谓不作诸不善法。又为摄取八正道故修行二法。一者于内随何善法。如理思惟。二者于外随何善法如理请问。又为摄取八正道故修行二法。一者如事了知诸法。二者了知无事无住无所分别。又为摄取八正道故修行二法。一者于内随顺觉知。二者于外无所执着。又为摄取八正道故修行二法。一者自信无所分别。二者众生若未有信。我令安住于此道中。又为摄取八正道故修行二法。一者能于所作之业如实知见。二者能于所作之业而无执着。又为摄取八正道故修行三法。一者于诸苦取蕴中一一了知。二者于诸无苦取蕴勤求至乐。三者于诸和合法中专修远离。又为摄取八正道故修行三法。一者宣说最上之法语不乖违。随说法义心无诤论。二者不着一切文字。三者摄取一切诸法。又为摄取八正道故修行四法。一者于义正方便事。二者随义而作相应正方便事。三者顺法而作观察正方便事。四者不起一切执着正方便事。又为摄取八正道故修行四法。一者能以坚誓自守如说而行。二者能以六根善巧于道发趣。三者能令意乐清净。四者能住不放逸行

无边慧。诸菩萨摩诃萨。以此法行摄取道故。乃可名为随顺道者。观一切法性空故。无名故。无相故无愿故无生故。无作故厌故离故灭故出故。得法光明。观生尽时。不于无生而起生想。便于尔时超升离生出过非法。得道清净获无生忍。道清净故过一切想。不住非想灭于道想。离于法想出无明网。以明修习所应得法悉能得之。明所修习得何等法。谓明修习得想受灭。得一切法决定善巧。得随秘密顺于法性。诸菩萨摩诃萨。行此道时。不住于处不为相覆。知一切法同于虚空生如空生。性如空性无有少相而为挂碍。此道清净不畏灾患。被大甲胄不为执缚。乘于大乘无所迷惑。离诸障难犹如虚空。于此道中而发趣之。为诸众生作大光明。无边慧。是为诸菩萨摩诃萨殊胜之道。非诸声闻缘觉所行。尔时世尊。而说偈言

  为摄八正道　　演说诸法行
  若住此道中　　斯为大精进
  善法修行者　　能于一切时
  不作不善法　　斯行摄于道
  菩萨修习者　　于内如理思
  于外求请问　　斯行摄于道
  菩萨观察者　　如事正了知
  如理如法住　　斯行摄于道
  菩萨依怙者　　于内随觉知
  于外无所执　　斯行摄于道
  菩萨无畏者　　自信无分别
  令他住净信　　斯行摄于道
  菩萨思惟者　　净诸所作业
  于业无所执　　斯行摄于道
  菩萨无系者　　常知苦取蕴
  求无苦取蕴　　斯行摄于道
  菩萨善智者　　修离和合行
  能离于和合　　斯行摄于道
  菩萨思义者　　随义能了知
  演说无违诤　　斯行摄于道
  菩萨具慧者　　不着于文字
  摄持一切法　　斯行摄于道
  菩萨行法者　　能与法相应
  亦随义相应　　斯行摄于道
  菩萨顺道者　　正住于坚誓
  如说而修行　　斯行摄于道
  菩萨道清净　　善净于意乐
  住法不放逸　　斯行摄于道
  菩萨一切时　　勤修此诸行
  身心获安乐　　斯行摄于道
  菩萨正念者　　住于清净道
  了知一切法　　皆空无有相
  菩萨观察者　　能令愿清净
  亦不住无愿　　远离于诸相
  菩萨如理观　　理趣悉平等
  于诸法不生　　无有少疑惑
  菩萨妙智者　　能观一切法
  厌离寂灭故　　明见而发趣
  菩萨观法者　　如理见法生
  不于生见生　　不于尽见尽
  菩萨精进者　　如是观察时
  出离于非法　　超升正位中
  菩萨妙智者　　斯道为清净
  速至大安隐　　成就无上忍
  菩萨妙智者　　随顺观诸法
  超过一切想　　常住于无想
  菩萨妙智者　　斯道能净治
  远离于道想　　亦不住法想
  菩萨妙智者　　斯道净治故
  出于无明网　　获大法光明
  菩萨妙智者　　能以明修习
  教授诸众生　　由是而发趣
  菩萨明修习　　为得一切法
  决定甚深义　　善巧大方便
  菩萨明修习　　方便离诸想
  随顺秘密法　　能知决定义
  菩萨妙智者　　以大法光明
  能灭于想受　　由是而发趣
  菩萨妙智者　　不住于斯道
  不住斯道故　　于道而发趣
  菩萨无畏者　　能知一切法
  犹若净虚空　　诸相无所覆
  菩萨知诸法　　其性同虚空
  诸法如空故　　清净而无垢
  菩萨如是住　　不为相所碍
  速为诸众生　　演说而教授
  菩萨妙智者　　一切道清净
  于道无灾患　　无碍而发趣
  如是清净道　　速往大菩提
  能于无为证　　平等而发趣
  菩萨大甲胄　　大乘及大道
  如空无挂碍　　清净而发趣
  趣斯乘及道　　如趣太虚空
  远离于众相　　无相而发趣
  大乘平等乘　　广大如虚空
  于斯清净道　　此乘当发趣
  一切诸菩萨　　尊重于斯法
  为诸众生故　　勇猛而发趣
  若诣大菩提　　住斯殊胜道
  非诸二乘等　　于此能发趣
  菩萨正忆念　　能令道清净
  以斯清净道　　最上而发趣

复次无边慧。诸菩萨摩诃萨。如是发趣之时。能以善巧而正了知无量念处。正断根力。觉分解脱。等持等至。神足止观。无量功德殊胜庄严。为欲降伏诸世间故被大甲胄。出三界故乘于大乘。摄受天人阿修罗故安住斯道。而发趣于阿耨多罗三藐三菩提。无边慧。诸菩萨摩诃萨。被大甲胄乘于大乘住斯道时。不以慈悲喜舍遍照众生。于诸众生不爱如己。如是甲胄大乘大道。而于大地所不堪受。一切众生不任亲近。若以哀愍利益众生。被大甲胄乘于大乘安住斯道。如是甲胄大乘大道。一切世间天人阿修罗所不能行。一切愚夫耽着世间住世间者亦不能见。又诸菩萨摩诃萨。哀愍一切诸众生故被大甲胄。能以甲胄加持地界水火风界。令此地界而不倾覆。一切众生不生恐怖。能令水界火界风界。随彼所应作所应作。又诸菩萨摩诃萨。始自初心发趣甲胄。乃至今被斯大甲胄乘此大乘。以清净道而发趣于一生补处。诣菩提树坐道场时。此三千大千世界之中。金刚所成坚固场地。若不加持踊没倾覆。虽以坚固金刚所成。无堪荷负斯大甲胄大乘大道。又诸菩萨摩诃萨往昔誓愿。于诸众生趣慈悲故。十方诸佛诸大菩萨共称赞故。设复金刚大轮围山。须弥卢山。一切宝山。及余山王。若不加持亦无堪荷斯大甲胄大乘大道。又诸菩萨摩诃萨本愿力故。诸佛如来本愿力故。于诸众生不为恼故。不为害故。不为损故。不为怨故。不为仇故。不凌恃故。不逼迫故。为令众生获安乐故。被大甲胄乘于大乘住斯道中而发趣于阿耨多罗三藐三菩提

无边慧。诸菩萨摩诃萨被甲胄时。被慧甲胄持慧刀仗。大慧回向乘回向乘。起慧光明住光明道。以慧明眼观察诸法。而发起于一切智智。为欲摄取一切智智。为诸众生修行般若波罗蜜。檀那波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。一切皆以慧为先导。慧为修习。慧为摄持。回向阿耨多罗三藐三菩提

尔时无边慧菩萨摩诃萨白佛言。希有世尊。诸菩萨摩诃萨若干智慧。遍一切处悉能摄持。成就无量诸佛之法。尔时世尊。告无边慧菩萨摩诃萨言。无边慧。如是如是。如汝所说。诸菩萨摩诃萨若干智慧。遍一切处摄一切法。被大甲胄乘于大乘住斯大道。一一皆以慧为先导而发趣之。无边慧。设有智慧无慧先导。于此道中不能发趣。若有智慧以慧先导。遍一切处随转随行。以慧摄持以慧防御。尔时乃名被大甲胄乘于大乘住斯大道。以安隐法饶益世间。能开慧眼以眼观察。慧身朗照放大光明。而发趣于阿耨多罗三藐三菩提。无边慧。是为诸菩萨摩诃萨所被甲胄。甲胄庄严所乘大乘。大乘庄严所行大道。大道庄严。而发趣于阿耨多罗三藐三菩提。无边慧。诸善丈夫。甲胄庄严。大乘庄严。大道庄严。一切功德种种庄严。我若具说。于无量劫不可穷尽。为令汝等而了知故。亦为未来诸善丈夫。甲胄庄严。大乘庄严。大道庄严。无边功德资粮庄严。我今于此略说少分。彼善丈夫若闻我法。亦当被大甲胄乘于大乘住斯大道。功德庄严而发趣之。尔时世尊而说偈言

  我说一切断　　亦说四念住
  一切善方便　　斯由不放逸
  具足正忆念　　法善巧相应
  勇进而出离　　斯由不放逸
  根力菩提分　　被甲乘大乘
  以此为侍卫　　菩萨当发趣
  禅定胜解脱　　等持及等至
  以此为侍卫　　菩萨当发趣
  大慈悲喜舍　　被甲乘大乘
  以此为侍卫　　菩萨当发趣
  成就于止观　　神足及神变
  以此为侍卫　　菩萨当发趣
  无量诸功德　　被甲乘大乘
  于道无疲倦　　菩萨当发趣
  精进不放逸　　被甲乘大乘
  了知彼念处　　菩萨当发趣
  光明大甲胄　　降伏诸世间
  被斯甲胄已　　乃名为智者
  正趣一切智　　出过三界中
  乘斯大乘已　　乃名为智者
  大道清净道　　映蔽诸世间
  天人阿修罗　　乃名遍闻者
  如是诸菩萨　　普为诸众生
  能于一切时　　精进被甲胄
  菩萨不修习　　大慈及大悲
  大喜大舍等　　大地不堪受
  菩萨不修习　　于彼诸众生
  知时饶益事　　大地不堪受
  菩萨不修习　　于彼诸众生
  爱之如己者　　大地不堪受
  菩萨不修习　　以慈乘大乘
  诸山及大海　　大地不堪受
  菩萨不修习　　慈念诸众生
  乘于此大乘　　众生不亲近
  若被斯甲胄　　慈光不照明
  于彼大甲胄　　众生不亲近
  若被斯甲胄　　功德海无边
  加持四大界　　彼乃堪荷负
  摄取众生故　　普照以慈光
  加持四大界　　彼乃堪荷负
  摄取众生故　　成就大菩提
  加持四大界　　彼乃堪荷负
  不讥恼众生　　被斯大甲胄
  大乘而出离　　斯名为智者
  善巧大方便　　一切悉加持
  无上而出离　　斯名为智者
  由是此大地　　不没亦不倾
  水火风界等　　能作所应作
  然诸大菩萨　　被甲乃无边
  乘于此大乘　　以道而发趣
  成就一生处　　至于最后身
  往诣树王下　　坐于坚固地
  于此道场处　　安住如金刚
  身心不疲倦　　现证一切智
  菩萨无畏者　　若不以加持
  彼地当倾覆　　坏已无复成
  一切大地界　　若不以加持
  假使金刚成　　无不倾覆者
  菩萨于往昔　　大誓愿庄严
  于诸众生所　　已起大慈念
  现在十方界　　诸佛刹土中
  遍知两足尊　　一切皆护念
  设复余石山　　须弥卢宝山
  金刚轮围山　　坚固嶷然住
  菩萨智慧者　　若不以加持
  于斯大甲胄　　不堪为荷负
  诸佛诸菩萨　　神力所加持
  众生及大地　　堪近堪荷负
  被斯大甲胄　　不为恼众生
  甲胄无有上　　以乘当发趣
  被斯大甲胄　　不为害众生
  甲胄不思议　　以乘当发趣
  被斯大甲胄　　不为仇众生
  为除众生病　　以乘当发趣
  具足殊胜道　　无上最净治
  不恼不仇怨　　不害正安住
  被慧大甲胄　　乘慧回向乘
  甲胄不可坏　　回向无过上
  菩萨依怙者　　住道慧光明
  以慧观诸法　　无上而发趣
  菩萨殊胜道　　甲胄及大乘
  斯由慧光起　　是故心清净
  乘诸波罗蜜　　趣佛大菩提
  慧摄慧清净　　以慧为先导
  一切波罗蜜　　以此慧为先
  慧摄慧清净　　能授无上智
  菩萨不思议　　能起慧光明
  能然大慧灯　　安乐而发趣
  起慧光明故　　慧眼由是开
  于佛无上智　　明见而发趣
  菩萨勇猛者　　甲胄乃无边
  无边庄严故　　名为大甲胄
  菩萨大智者　　大乘大庄严
  于佛一切智　　无染而发趣
  菩萨大智者　　大道大庄严
  殊胜不思议　　清净而发趣

大宝积经卷第二十二大宝积经卷第二十三

        大唐三藏菩提流志奉　诏译

    被甲庄严会第七之三

复次无边慧。诸菩萨摩诃萨。乃于无边甲胄境界。无边大乘境界。无边大道境界而发趣之。何以故。于一切处能随入故。诸菩萨摩诃萨。为欲随入一切法故被大甲胄。为欲随入一切法故乘于大乘。为欲随入一切法故住斯大道。于一切法得平等故。而发趣之。然此甲胄。不得少法若内若外。若粗若细。若远若近。过现未来。有为无为。住不住者。若此甲胄于一切法不能选择。不能决了。不能遍知。不能随入。不能作证。不能超过。不可名为被大甲胄。于一切法。若能选择。若能决了。若能遍知若能随入。若能作证。若能超过。乃可名为被大甲胄。又此大乘亦无少法若内若外。乃至回向一切智智。遍知随入作证超过。是故此乘名为大乘。法善巧乘。至涅槃乘。无上上乘。无等等乘。又此大道亦无少法若内若外。乃至能于一切诸法。平正大道而发趣之。此平正道无有少法不遍知者。是故此道名无上道。无数量道。无等等道

无边慧。诸菩萨摩诃萨被大甲胄。遍能随入一切众生心心所行。遍能清净一切众生杂染烦恼。乘于大乘增长众生一切善根。住斯大道。劝化众生一切善法。无边慧。诸菩萨摩诃萨。为一一众生。一一心行。尽生死际。长时流转求智慧乐。不舍甲胄而能坚固。被大甲胄。无量甲胄。难思甲胄。清净甲胄。无边甲胄。无取甲胄。知众生想甲胄。知无众生甲胄。知无我甲胄。知众生自性甲胄。随觉众生自性甲胄。知我自性甲胄。随觉我自性甲胄。知内自性甲胄。随觉内自性甲胄。知外自性甲胄。随觉外自性甲胄。知内外自性甲胄。随觉内外自性甲胄。知一切法自性甲胄。随觉诸法自性甲胄。知一切法无所得甲胄。知一切法自性无所得甲胄。了知一切诸法甲胄。无边甲胄。无中甲胄。无中边甲胄。非过去甲胄。非未来甲胄。非现在甲胄。无作甲胄。无作者甲胄。无边慧。诸菩萨摩诃萨于此甲胄。亦无所被。亦不随觉。亦不决了。亦不出离。亦不现证。无甲胄故而被甲胄。不随觉故而能随觉。不决了故而能决了。不出离故而能出离。不现证故而能现证。无所乘故而乘大乘。不于大乘而有施设。无所施设而为施设。然于大乘无少施设。若有施设则非施设。于彼施设不可得故。不可见故。亦无有乘以乘安住。以无所得而住大乘远离趣向。不至究竟。不到涅槃。不可得故非道为道。于道发趣以平正故。此平正道无所施设。谁为施设何处施设从何施设。亦无有作亦无作者。亦非和合非不和合。一切厌离一切不求。何以故。此平正道与一切法不异不同。不相应故。不起法想。离一切法无垢无净。法性亦尔无垢无净。是故此道名无染道。以不可趣而为进趣。以不可摄而为摄取。此道甚深。无生无起无出无作无得无行无处无住无障无事。于一切事而能显了。于一切事而无差别。不随事转以无事故。至无上处。无边慧。诸菩萨摩诃萨。于此甲胄此乘此道。应如是知。然此甲胄此乘此道。无所可见。无所可知。不可得故。谁为被甲。谁乘此乘。谁行此道。亦不可见。亦不可知。亦不可得。无边慧。若诸菩萨摩诃萨闻斯法已。不惊不怖读诵宣说。于法理趣无所乖违。随顺修行而生爱乐入于胜解。为斯法故应勤精进。若于斯法决定理趣。善巧方便有堪能者。被此甲胄。乘于此乘。行于此道。于此深法无所得故。而发趣之尽生死岸。为正觉者。能以无边功德庄严。出现世间。无边慧。诸菩萨摩诃萨。于此法中应生爱乐起大精进而无放逸。若有众生。于此深法才生爱乐。我说彼人得大饶益。况能精勤不为放逸。戒行清净而发趣者。无边慧。汝观斯法若干广大。若干殊胜。若干清净。我于此法殷勤称赞。欲令众生而生爱乐。当得长夜利益安乐。为厌离故。寂灭故。遍知故。无边慧。汝当复观斯法。能授世间出世间具足安乐。诸有若干匮乏众生。于此深法而退失故。远离世间及出世间。一切具足丰饶安乐。无边慧。汝当复观如来现前此深法宝若干丰饶若干易得。汝今于此甚深之法应勤修习。诸有愚夫。于我演说此法宝时尚不欲闻。况能受持如来现前法宝丰饶。不乐听闻。不欲咨问。若于末世后五百岁正法灭时。佛及法宝及持法者三不现前。何能欲闻爱乐咨问。无边慧。然于后时。若为如来善加持者。此深法宝亦令可得。无边慧。彼怖畏时此深法宝实无损减亦无灭尽。但于此法无听闻者。无受持者。唯除我前渴仰听闻被甲胄者。当于彼时乃能爱乐听受斯法。彼时众生闻此法已能生净信。我说彼人当得成就斯广大法。况于今时于此法中。能生净信勤修行者。无边慧。诸菩萨摩诃萨。被无上甲胄无量甲胄大甲胄时。应作是念。我为一切匮乏众生。所谓乏于戒者。乏于闻者。乏于慧者。乏解脱者。乏于解脱知见者。以此大法而丰足之。由是大法丰足之故。一切匮乏皆令舍离。戒财闻财。慧财解脱财。解脱知见财。皆令富饶。贪嗔痴火皆令息灭。一切众病皆令除愈。无上良药皆令服之。服斯药故众病消除。获大安乐永离有余。证清凉性无上涅槃。无复有余思惟观察。不求一切有为无为。何以故。以此涅槃最上安乐。一切所求更无余故。所求永息已灭尽故。无边慧。诸菩萨摩诃萨。被于如是大甲胄已。又为哀愍摄取一切诸众生故乘此大乘。此大乘者。过去诸佛已乘出离。未来诸佛当乘出离。现在诸佛今乘出离。无有去者。亦无有乘。亦无出离。何以故。以空无相无愿无生无作者故。非已出离。非今出离。非当出离。乘此乘者如是出离。为善出离而无执着。于一切法。非有和合。非无和合。无来无去。此乘此道而出离时。亦非和合。无来无去此乘此道。于大甲胄而出离时。亦非和合。非不和合。无来无去。不可得故。无边慧。诸菩萨摩诃萨。以此甲胄此乘此道而发趣之。又此甲胄此乘此道而发趣时。不作是念。若凡夫法。若声闻法若缘觉法。若诸佛法。彼法于我若远若近。亦不作念。若空无相无愿无生无作。彼法于我若远若近。亦不作念。若厌若离若灭。乃至大般涅槃。彼法于我若远若近。无边慧。此大甲胄此乘此道。一切菩萨。一切声闻。一切缘觉。一切众生。所不能动。而发趣于阿耨多罗三藐三菩提。无边慧诸佛世尊于此甲胄此乘此道。得不动已而般涅槃。何以故。一切诸法不可动故。一切法性法性之相。相远离故。相清净故。遍清净故。不可以相而为观察。为胜观察。为遍观察。一切法相法相之性。不可以性而为观察。为胜观察。为遍观察。一切诸法无性无相。不可显示。不可言说。是为诸法真实性相。无边慧。如此甲胄此乘此道。真实之相不可显示。不可言说亦复如是。为令众生当了知故。增长一切法光明故。于此甲胄此乘此道。假以施设而略说之。汝今若欲于此甲胄此乘此道随义行者。勿以施设勿以显示。勿以言说。应随义行。随义行者无少应行无少随行。若于非义不应随行。若于是义则应随行。随义行时不随声行。不随字行。不随语行。不随行者。不随彼转。何者为义。谓秘密说。于秘密说应随觉了。应以信行。以信行者。于是义中无所分别。于无分别乃应随行。应随行者乃为不行亦不随行。何以故。于是义中无少有行。无少随行。无少遍行。远离行故。不应随行。不随菩提相应而行。不随流转相应而行。于彼相应及不相应。皆非作意。皆非正念。念清净故。故不应行

无边慧。于是义中。汝应随行勿异有行。若异随行则为妄失。随逐音声。随逐文字。随逐语言。于彼语言不能舍离。遍知音声。超过文字。随觉语言。则不随行。则不流转。于是义中。如是随行。如是随入则无少行。行止息故。无边慧。于义行时。勿复以行而行于义。若不以行而行于义。则为不来不复退还。若得不来不复退还。于此甲胄此乘此道。随顺趣于阿耨多罗三藐三菩提。为诸众生作大饶益。无边慧。若于此法如是说者。随义行者能随入者心不颠倒。无有疑惑成就胜解。于此甲胄此乘此道若未摄取。能摄取之速当发趣。若有未被斯甲胄者则能速被。若有未乘于此乘者。则能速乘。若有未住于此道者。则能速住。无边慧。彼诸众生当摄广大福德资粮。为佛世尊之所护念。于法无违与僧同行。无边慧。汝已摄取无量善根。于后末世当以此法摄诸众生。为诸众生荷负重担。所获福德其量难说。尔时世尊。而说偈言

  菩萨无畏者　　如是被甲时
  为利诸众生　　乃被无边甲
  众生若贫乏　　弊苦无法财
  无戒无多闻　　无慧无解脱
  被此无边甲　　令法致丰饶
  以法丰饶故　　一切获安乐
  为舍诸贫苦　　演说无上法
  闻者皆离尘　　住斯安乐道
  戒蕴备充足　　多闻如大海
  便得最上慧　　由斯能断缚
  解脱遍照明　　解脱正知见
  若能现证者　　一切获安乐
  贪嗔痴大火　　恒烧遍炽然
  众生由是苦　　彼火我令灭
  授诸众生药　　一切病皆除
  若病消除已　　得至涅槃界
  永舍一切余　　趣于安乐处
  从彼安乐中　　无有退还者
  一切有为乐　　于彼不复求
  无上大安乐　　于彼皆当证
  以无戏论法　　成熟诸众生
  究竟大安乐　　一切皆当得
  如是发趣者　　一往不复还
  出过于发趣　　常得胜安乐
  于大安乐中　　乐欲不乐欲
  发趣无发趣　　一切皆当断
  如是被甲已　　当乘于此乘
  为愍诸众生　　一切皆摄取
  过去正遍知　　此乘已出离
  未来正遍知　　此乘当出离
  现在佛世尊　　此乘今出离
  故于此大乘　　无不皆乘者
  一切诸最胜　　世间大依怙
  以此乘出离　　不起于乘想
  非乘以为乘　　非道以为道
  非出以为出　　出离故无上
  此乘出离时　　曾无少出离
  以空无有相　　无愿无作故
  非乘非出离　　乃名为大乘
  一切悉平等　　由是而发趣
  此乘无和合　　亦无不和合
  发趣无上道　　现证大安乐
  此乘无相应　　亦无不相应
  无处无所依　　由是而发趣
  此道无有来　　此道亦无去
  行斯正道者　　寂静而发趣
  我说于此道　　此乘此甲胄
  于法无所依　　寂静最无上
  一切凡夫法　　一切声闻法
  一切缘觉法　　一切不可得
  于佛一切法　　离垢无上法
  不远亦不近　　一切不可得
  于空无相法　　无愿无作法
  不远亦不近　　一切不可得
  于厌离灭法　　涅槃寂静法
  不远亦不近　　一切不可得
  此乘此甲胄　　此道无所取
  无上不可动　　毕竟不可得
  一切法自性　　真实希有相
  不可以施设　　诸法性空故
  此乘此甲胄　　此道无显示
  如诸法自性　　彼性亦如是
  一切诸法中　　相性不可得
  于无相性法　　我略为开示
  一切诸法中　　一切自性相
  于我如是说　　毕竟无所有
  此乘及此道　　甲胄自性相
  于彼求言说　　毕竟亦非有
  言说非有故　　是为希有相
  于彼言说中　　语相亦非有
  诸法不可量　　无胜无边量
  一切不可测　　是故法无上
  此乘此甲胄　　此道亦如是
  于彼无相中　　如是应随入
  为令诸众生　　遍知勤修习
  速逮法光明　　故我如是说
  诸法无语言　　一切不可说
  于彼诸法中　　一切应随入
  以法无言故　　于彼应随行
  行无少有行　　一切法无行
  无求而乐求　　无行而随行
  如是随行者　　于义不观察
  汝今于实义　　一切应随行
  音声及语言　　于彼勿随转
  音声语言中　　若得不随转
  于义乃随行　　是为求义者
  何者名为义　　应知秘密说
  以信无分别　　是义乃随行
  明了如是义　　能于秘密说
  无执无所著　　不行不随转
  若有随行者　　彼则随执着
  若无随行者　　一切不随转
  由是正忆念　　远离于随转
  菩提及生死　　二俱不相应
  于彼亦无念　　无念为正念
  于念清净故　　说为清净者
  若异此修行　　远离无上法
  汝应于是义　　如说而修习
  若随语言者　　是则随音声
  于彼不超过　　同于世间法
  音声及文字　　不应随彼转
  应知真实义　　无行以随行
  实义无音声　　亦无有文字
  超过语言故　　乃名为实义
  是义应随行　　随行无所有
  以行止息故　　乃名为实义
  于真实义中　　不行以为行
  斯则不退转　　不舍于甲胄
  随顺大甲胄　　大乘及大道
  趣于安乐处　　利益诸众生
  此诸安隐法　　我今为汝说
  汝当随义行　　能断汝疑惑
  若乘此乘者　　乘已当发趣
  速诣大菩提　　现证无上觉
  于此最上乘　　不乘为速乘
  于道于甲胄　　其义亦如是
  于此无上法　　精勤修习者
  彼诸众生等　　为佛之护念
  于后怖畏时　　汝当开此法
  广为诸众生　　而作利益者
  于后怖畏时　　若能开此法
  所生无上福　　其数不可量

无边慧。诸菩萨摩诃萨。所被甲胄名曰大胜。亦名无边胜。亦名大庄严。所乘之乘名曰大商。亦名无边光。亦名妙庄严。所行之道名曰无量庄严资粮。亦名无量方便资粮。以是道故。诸善丈夫而发趣于阿耨多罗三藐三菩提

复次无边慧。乃往古昔过无量劫。复倍是数有佛出世。号栴檀香光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名电光国名光明。时彼刹土地平如掌。无诸杂秽瓦砾荆棘。黄金白银而为沙聚。行列国界睹者欣悦。时四天下其洲皆广二亿由旬。一一洲中复有四万八千大城。其城一一广十由旬长二十由旬。垣墙周回严丽峻极。一一城有八俱胝人止住其中。十千聚落一千园苑。围绕庄严。而此国界。复有种种花树果树香树衣树上味之树及金刚树间错庄饰。池沼泉流涯岸端直。八功德水盈满其中。优钵罗花。波头摩花。拘物头花。芬陀利花。杂色辉映靡不周遍。彼栴檀香光明如来。寿六十八俱胝那由他岁。复有六十俱胝那由他诸声闻众以为眷属。彼时人民颜貌端正安隐快乐。薄贪嗔痴易可开示。以少劝化而能遍知诸法性相。无边慧。复于彼时有转轮王。名一切义成。七宝具足四天归化。彼阎浮洲有一大城。其城纵广四十由旬。人民炽盛安隐丰乐。宫城之内广五由旬。间以七宝而为庄饰。妙多罗树垂诸铃铎。真金罗网弥覆其上。王之正殿纯绀琉璃。广一由旬四面千柱。其殿之上复有千楼。高峻严丽众宝装饰。于其殿前有大香池周环澄澈。其傍复有十六香光小池。七宝所成布列围绕。一一池间流渠激注。出妙音声如奏众乐。一一小池有八阶道。香光大池三十二道。一一阶道纯金所成。宝树行列宝网弥覆。上妙香气遍满城中。故号彼池名曰香光

无边慧。彼转轮王有四夫人。一名无边音。二名贤善音。三名众妙音。四名鹅王音。一一夫人各有二子。一名不空胜。二名贤胜。三名龙胜。四名胜音。五名妙音。六名梵音。七名胜云。八名云音。婇女六亿诸子十千。尔时彼王于内宫中。与其眷属娱乐嬉戏。忽于空中见一如来妙色之身。时彼如来即告王言。大王应被无上甲胄乘无上乘。而发趣于阿耨多罗三藐三菩提。授诸众生智慧之药。勿得贪着人天五欲。此大甲胄而能摄受无上安乐。此无上乘而能诱入无上园苑。入此中者不复退还。一切人天种种诸欲。皆是无常变坏之法。势不久住须臾磨灭。无边慧。尔时一切义成大王。闻此说已于彼如来而白言曰。其谁能示斯大甲胄如彼甲胄。而严被之。其谁能示斯之大乘。如彼大乘而乘御之。其谁能示斯之大道如彼大道而发趣之。时彼如来告一切义成大王言。大王当知。有栴檀香光明如来。王应诣彼。当为大王演说斯法。被大甲胄。乘于大乘。趣于大道。时彼如来如是说已欻然不现

无边慧。尔时一切义成大王。睹斯事已悚栗毛竖发希有心便生怖畏。不乐人天种种欲乐。厌舍一切诸行有为。求大甲胄大乘大道。即与八子及四夫人并余诸子婇女侍从俱。往诣彼栴檀香光明如来所。既到彼已与其眷属恭敬作礼稽首佛足。即以一百檀卢那七宝杂花。散于如来应正遍知。复以无量支婆罗。奉献如来及声闻众。复以一切安乐资具。满十千岁而供养之。从是以后弃舍王位与其眷属。于栴檀香光明如来法中出家。无边慧。时彼栴檀香光明如来。知一切义成比丘及其眷属至乐之心。便为开示甲胄庄严大乘庄严。彼既闻已发坚固心。为深法故尽其躯命。端坐思惟精勤无退。常近如来。而于世间一切诸欲得无动念

无边慧。时彼如来。问一切义成比丘言。善男子。汝于今时被大甲胄乘于大乘发趣道耶。以是道故而能成就一切智智无等等智。汝当如理精勤修习。彼一切义成比丘白栴檀香光明如来言。世尊。我于今时乃不见有名甲胄法。亦不见有能被甲胄者。亦不见有被甲所从。亦不见有被甲之处。世尊。我不见有名乘之法。亦不见有乘大乘者。亦不见有乘之所从。亦不见有乘大乘处。世尊。我不见有名道之法。亦复不见由此道故已发趣者。今发趣者。亦不见有道之所从。亦不见有道之处所。世尊。我于阿耨多罗三藐三菩提。若远若近若去来今无得无见。如我今者作是观时。实无少法而可亲近而可证者。若我无证。世尊。宁当而问我言。被大甲胄乘于大乘发趣道耶。世尊。一切知者一切见者。如我等比于法修行。唯有如来乃能了知。非诸声闻缘觉境界。无边慧。彼一切义成比丘于如来前作是说时。与其眷属便得菩萨无生法忍。得法忍故皆不退转。尔时栴檀香光明如来悉为授记。过五百阿僧祇劫。当证阿耨多罗三藐三菩提。彼闻授记欢喜踊跃。上升虚空高七多罗。即以偈颂赞如来曰

  无量大名称　　挺特如山王
  世尊一切智　　能演诸功德
  佛眼悉明见　　犹如日照临
  尊严大会中　　我礼如来足
  无量德资粮　　佛智已圆满
  我等亦当得　　世尊无上智
  无上大光明　　普照于人天
  开示诸法藏　　无边功德海
  智慧常无失　　正觉离烦恼
  慧光大精进　　我礼深功德
  大龙大庄严　　众相以严身
  安住如须弥　　御众无伦匹
  能为世导师　　映蔽人天众
  演说无所畏　　我礼胜丈夫
  世尊大牟尼　　无边功德海
  能开我法眼　　令我被甲胄
  然我一切时　　为乘大乘者
  常于此胜道　　发趣更无余
  牟尼勇猛尊　　觉知一切法
  世无有过者　　我等咸归命

无边慧。彼栴檀香光明如来应正遍知说此法时。成熟无量无数众生。一切义成比丘从是已后。与其眷属供养承事无量无数诸佛世尊。过五百阿僧祇劫。证阿耨多罗三藐三菩提。号曰超无边境界王如来。彼佛刹土。所有功德广长之相。亦如栴檀香光明如来应正遍知光明世界无有异也。诸声闻众其数无量。王之夫人诸子眷属。亦过五百阿僧祇劫。皆证阿耨多罗三藐三菩提。无边慧。诸菩萨摩诃萨。被大甲胄乘于大乘。于此道中。持大法炬作大法明。放大法光建大法幢。击大法鼓乘大法船。以摄大法而发趣之。善丈夫戏而游戏之。霔以法雨润于众生。皆令欢喜。精勤勇进。而发趣于阿耨多罗三藐三菩提。无边慧。诸菩萨摩诃萨住此道时得法光明。以光明故能见一切诸法缘起。自性本空。自性无相。自性无起。不于色中而见于色。受想行识亦复如是。不于识中而见于识。异识缘起。了知识相自性本空。自性无相。自性无起。但属众缘见缘和合。众缘亦空无相无起。作是见时。不于眼中而见于眼。耳鼻舌身意亦如是。不于意中而见于意。异意缘起。了知意相自性本空。自性无相。自性无起。乃至地界水界火界风界空界。欲界色界及无色界。无有作者。无有受者。不于少法见有少法。异缘而起属众因缘。自性无相。自性无起。缘性亦空无相无起。无边慧。是为诸菩萨摩诃萨。住此道观察缘起。作是观已能以智慧。于缘起中证真实际。以斯一切法光明故。如来十力四无所畏。十八不共大慈大悲大喜大舍。乃至一切诸佛之法。速得圆满。尔时世尊。而说偈言

  菩萨无畏者　　如是能安住
  作大法光明　　妙智而发趣
  建于大法幢　　此幢无有上
  一切佛法中　　正念而发趣
  智慧善游戏　　法施诸众生
  霔于大法雨　　无畏而发趣
  以法润众生　　皆令得欢喜
  以是诸菩萨　　妙善而发趣
  如是诸菩萨　　得大法光明
  能于正法中　　勇猛善安住
  由是法光明　　了知一切法
  以众缘故起　　一切无坚实
  诸法自性空　　自性无有相
  自性无有生　　自性无有体
  诸法以众缘　　和合而共起
  众缘和合故　　自性无所有
  菩萨能观察　　了众缘亦空
  众缘自性空　　自性无有相
  亦无有生起　　亦非有所作
  如是观察者　　于法勤修习
  诸起无体故　　众缘亦非缘
  如是如理观　　能知一切法
  观诸色受想　　行识亦如是
  皆以众因缘　　由斯诸蕴起
  诸蕴无有实　　自性本来空
  性空故无相　　一切无所起
  诸蕴远离相　　离相则无生
  无生则无灭　　诸蕴如是相
  无相妄有相　　彼相从何有
  诸法无体故　　斯蕴亦无性
  界处亦如是　　一切从缘起
  自性本来空　　无相无有体
  一切诸法中　　法体不可得
  了知一切法　　名义思惟者
  欲色无色界　　一切从缘起
  自性本来空　　无相亦无体
  观此能观智　　何能知彼境
  此智及彼境　　自性常远离
  所起及众缘　　此二俱无作
  能作如是知　　斯为真实相
  无相以相说　　菩萨由斯入
  而亦不分别　　若相及无相
  如斯善智者　　能见真实相
  于诸法界中　　不作少法相
  若法及法界　　此二俱无相
  诸法远离相　　说名为法界
  说名法界者　　无界无非界
  虽名为法界　　然实不可得
  思惟此义时　　不念不可得
  离诸分别故　　获大法光明
  诸法无性故　　光明亦无性
  由斯观察故　　复得法光明
  不见能观智　　斯见亦不见
  见法虚妄故　　说此名为观
  光明不思议　　无边无有量
  见诸法皆空　　说名不分别
  若法有诸相　　常无证入者
  闻斯净法音　　应生大欢喜
  若法无有生　　常无分别者
  闻斯净法音　　寂然获安乐
  若后末世时　　闻斯无上法
  应说彼众生　　久集诸功德
  若后末世时　　闻斯无上法
  当于此法中　　以速而发趣

大宝积经卷第二十三大宝积经卷第二十四

        大唐三藏菩提流志奉　诏译

    被甲庄严会第七之四

复次无边慧。诸菩萨摩诃萨。如是观察一切法时。便于诸法得法光明。不于空中而见于空。亦不离空而见于空。不见少法与空相应。若不相应。不以空空。不见于空。不见不空。亦不以见观一切法。作是见时。不于无相而见无相。不异无相而见无相。亦无少法而与无相若相应若不相应。不于无相以无相见。不于有相以有相见。非有相见非无相见。无生无作亦复如是。不于尽中而见于尽。亦不异尽而见于尽。不见少法与尽相应若不相应。亦不于尽而以尽见。亦不于尽以无尽见。亦非尽见非无尽见。诸菩萨摩诃萨作是见时。无有少法若可得见不可得见。若可显了不可显了。若可趣入不可趣入。若可觉知不可觉知。无边慧。是为菩萨摩诃萨安住斯道大法光明。法光明故见一切法悉无有边。于边于中亦无所执。无所执故于佛法中而发趣之。尔时世尊而说偈言

  不于空见空　　不异空见空
  能作如是见　　说名为见空
  不住于少法　　亦不见少法
  于彼空相应　　及以不相应
  空以自性空　　于空无所取
  以无所取故　　能知一切法
  于见无所取　　于观无所执
  能知见与观　　此二俱不受
  于见悉清净　　于观不可得
  如是观诸法　　毕竟无所执
  不以无相见　　不以无相观
  亦不于无相　　而作无相观
  无相无所显　　无愿不可得
  无有少法体　　而可修习者
  不念于无相　　亦不念无愿
  如是无分别　　显了相无相
  不趣于无相　　亦不入无相
  无趣无所入　　显了平等住
  智人不见相　　亦不见无相
  不见不思惟　　一切无显了
  若人常思惟　　无思无显了
  于思及显了　　平等平等住
  如是于无相　　无作亦复然
  虽显无所显　　思惟了知故
  无生亦如是　　曾无少法生
  自性无所有　　显了而无体
  若生若无生　　有作及无作
  亦无少所执　　智者不分别
  念慧无所动　　显了无思择
  有体及无体　　平等离诸性
  不于尽见尽　　亦不见无尽
  显了无所见　　尽智无过上
  若尽若无尽　　二俱不分别
  以无分别故　　无念平等住
  于尽无尽见　　亦无无尽见
  如是见尽时　　不执尽无尽
  若于尽无尽　　一切无所执
  以无所执故　　尽智当显了
  尽智之境界　　无畏之所得
  显了斯法故　　菩萨善安住

尔时众中。复有菩萨摩诃萨。名曰胜慧。从坐而起偏袒右肩。右膝着地合掌向佛。白言世尊。诸菩萨摩诃萨为欲摄取诸法智故。起于修行乃能得此大法光明。于法光明无少可见。法光明故了一切法有为无为。世间出世间。若顺若逆。若有戏论。若无戏论。世尊。此法光明。岂诸菩萨摩诃萨无修行而当得耶

尔时世尊。告胜慧菩萨摩诃萨言。胜慧。诸菩萨摩诃萨无少修行。无胜修行。不随修行。不遍修行。能得无边大法光明。诸菩萨摩诃萨。尚不可得不可见耳。况菩萨行而当可得当可见乎。如何乃见。若干劫行能得无边大法光明。诸菩萨摩诃萨。一切行息所行清净得法光明。法光明行非数量行。非随相行。从何施设一切诸行。然所修行非施设行而亦不离。胜慧。诸菩萨摩诃萨住此行时。舍一切行无所执取。具斯行者非数量行。非随相行。无相无行乃能得此大法光明。尔时世尊而说偈言

  菩萨无所行　　而亦无有行
  得无有行者　　无畏而发趣
  未曾有胜行　　亦无有遍行
  无行无胜行　　平等而发趣
  此行无示现　　示无有诸相
  无相无行者　　斯为行之相
  菩萨无相行　　不住于诸事
  无行无所住　　智者乃成就
  无行则无动　　斯行为无上
  能行不动行　　勇进而发趣
  菩萨不可得　　行亦不可见
  亦不见色身　　斯为善顺者
  无色无形相　　故无一切行
  于见无所取　　斯为无比行
  菩萨无上行　　不堕于施设
  亦无有迁变　　于中无所执
  行无施设故　　乃为无上行
  若得如是行　　获大法光明
  菩萨所修行　　无言无劫量
  能以无量劫　　显说于诸行
  菩萨行清净　　清净妙安住
  悉舍一切行　　曾无摄取者
  菩萨恒住舍　　守护于诸行
  已舍一切行　　于舍妙安住
  菩萨无边行　　离边及无边
  彼行无所动　　名为无上行
  菩萨无相行　　斯行为无上
  修行此行时　　超越诸魔界
  菩萨无相行　　明了于无相
  若相及无相　　一切无所依
  菩萨住此智　　此行善成就
  无有少所行　　说名不行者
  菩萨常清净　　于行无所畏
  正念而发趣　　斯为善安住

尔时胜慧菩萨摩诃萨复白佛言。希有世尊。诸善丈夫若干修行乃为甚深。非诸愚夫有相有为所修行者少能行之。世尊。无有少法入此行中。是故此行为善丈夫平等之行。世尊。善丈夫行非诸数量边际能测。尔时胜慧菩萨摩诃萨。即以偈颂赞如来曰

  大雄正等觉　　无上两足尊
  演说甚深行　　饶益诸菩萨
  世尊妙辩才　　其量颇难测
  无边辩才者　　最胜大丈夫
  法王息讥论　　斯由正遍知
  乃为诸菩萨　　说此无上行
  世尊能演说　　灭行之方便
  于行悉超过　　智人当发趣
  大龙不思议　　无边智境界
  遍知两足尊　　善开斯妙行
  世尊所开示　　牟尼不动行
  此行无能动　　故名无比行
  大雄大牟尼　　往昔所修行
  设以多劫行　　无人能到者
  菩萨闻斯法　　虽住于世间
  而于诸种智　　不久亦当证
  我等愍众生　　当于末世中
  于此无上法　　能为护持者
  我等闻斯法　　当于末世中
  为诸众生故　　能行亦能说
  我等以光明　　当于末世中
  为诸求法者　　而兴大利益
  我等发誓愿　　当于末世中
  为诸众生故　　护持而建立
  我等常思念　　当于末世中
  供养佛法海　　愿持无上法
  我等于法藏　　当为胜丈夫
  愿持此法门　　守护令久住
  我等于法水　　誓愿悉能饮
  而于此法门　　当为守护者
  我等闻法已　　当于末世中
  愿为大丈夫　　受持佛正法
  我等宁失命　　不舍无上法
  愿于此法中　　而为持法者
  我等持此法　　未曾生喜足
  渴闻斯甚深　　决定契经故
  我等于末世　　为求诸法者
  当演斯正法　　能令悉欢喜
  法王叵思议　　能作大依怙
  愿垂加护我　　念我持法者

尔时世尊。告胜慧菩萨摩诃萨言。善哉善哉。胜慧。汝能于后末世之中。为欲护持此诸法故。被大甲胄。亦如往昔诸菩萨摩诃萨。于最胜所供养承事。种诸善根。久修梵行。被大甲胄。护持诸佛世尊。法者而无异也。尔时世尊而说偈言

  于后怖畏时　　汝当持此法
  为利诸众生　　以此法开示
  于后末世时　　汝持最胜法
  若闻斯法者　　悉当生爱乐
  于后末世时　　汝为持法者
  我说甚深法　　汝当悉受持
  秘密修多罗　　汝闻当忆念
  于斯理趣中　　勿复有疑惑
  决定甚深义　　汝闻当忆念
  饶益诸众生　　为持法藏者
  以法施一切　　普润诸众生
  闻已令充悦　　身心遍欢喜
  为诸菩萨道　　所行之理趣
  及彼修多罗　　究竟受持故
  汝当能广度　　无量诸众生
  一切世间中　　所不能度者
  汝持此法故　　饶益诸世间
  获胜众福聚　　以是而发趣
  我今说此法　　汝当悉受持
  于后末世中　　为诸聪慧说
  现在未来世　　能持斯法者
  则为能受持　　千佛之正法
  为诸众生故　　护持斯法门
  于后末世中　　而兴大饶益
  若能于末世　　护持斯法者
  彼不于一佛　　亲近而承事
  若能于末世　　护持斯法者
  彼已多承事　　善说斯法者
  能于此法中　　无有少疑惑
  末世护持法　　斯为聪慧者
  被大无边甲　　敌战为殊胜
  而于末世中　　乃能持此法
  彼于佛正法　　疑网悉已除
  闻法无所畏　　乃能持此法

是故胜慧。若有善男子善女人。勤求最胜大功德者。于末世中为深法故。应被甲胄受持读诵解说其义

复次胜慧。我念往昔过无量劫。复倍是数。有佛出世。号曰遍照如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名超胜国名离垢。其地平正广博严净。七宝所成。时彼大洲。广长延袤七万由旬。于中复有六万大城。一一大城。纵广正等十六由旬。垣墙周匝楼雉严饰。门刹殊胜睹者欢悦。妙多罗树行列围绕。百千园苑而共庄严。诸园苑中。台座床敷处处严设。池沼渠流一一盈满。涯岸阶砌饰以众宝。周回平正出入安隐。于其岸边。沉水栴檀多摩罗等杂香之树扶疏布列。彼一一城。各有十千俱胝人民止住其中。彼诸众生悉已成就十善业故。一切皆受如是安乐。时彼如来。始从初劫超二百劫于中出现。是故彼劫名曰超胜。于彼劫中。有五百如来次第出现。一一刹土皆七宝成。其佛灭后正法住世各十千岁。如是五百如来现化于世。多有声闻菩萨法会。一一法会各有俱胝那由他数无量菩萨。趣一乘道获无生忍

时彼劫中有转轮王名勇猛军。七宝成就王四天下。于阎浮提有一大城。其城周回六十由旬。复有八万俱胝人民止住其中。安隐快乐丰饶炽盛。七重隍堑。七重行树。七重街道。七重表刹。七重铃网。一千园苑所共围绕庄严大城。一一园苑纵广正等二十由旬。其中各有七重垣墙。七重罗网。种种庄严。一一微妙众宝珍玩犹如诸天。各各复有一百池沼。毗琉璃宝以为堤岸。马瑙杂玉以为阶砌。众华敷荣宝树行列。于大城中。王之正殿量七由旬。黄金青宝间错所成。周以宝竿饰以琉璃。摩尼珠网弥覆其上。诸多罗树晖映庄严。二十渊池围绕萦带。底布真金覆以金网。杂琉璃宝以为津桥。纯妙黄金而为阶道。于其池中。优钵罗华。拘勿头华。芬陀利花敷荣遍满。彼转轮王。二千婇女六万诸子。与其眷属于彼园中五欲娱乐。窃作是念。诸欲无常不久变坏。我当决定志求佛法。若闻法已如教修行。令我长夜利益安乐。适思惟已。忽然有天现虚空中。告彼王言。善哉丈夫。今有遍照如来出现于世。演说正法初中后善。王应速诣于彼佛所。当闻正法。令王长夜利益安乐。成就佛法圆满佛法。王闻天言踊跃欢喜。与其眷属侍从围绕。即往遍照如来之所。头面礼足而白佛言。世尊。以何等法。能摄诸法善巧方便。能令梵行速得圆满。我当修行。如是问已。时彼如来广为开示。王闻法已。与其眷属。悉舍安乐资生之具。恭敬供养遍照如来及诸大众满二万岁。于遍照如来法中出家修行正法。以闻法故。于时获得受法善根。持法善根。说法善根。有所闻法思惟不忘。无量功德精勤修习。乃发誓愿。愿持如来三时正法。为诸众生种种宣说。作是愿已。于胜超劫诸如来所。一一亲近供养承事。彼诸如来现前正法。中时正法。后时正法悉能受持。教化成熟四万八千俱胝那由他众生。趣于阿耨多罗三藐三菩提。方便调伏无量众生。住于声闻辟支佛乘。彼劫之中最后如来。号曰电光。勇猛军比丘。闻电光如来说法之时。获无生忍。电光如来即为授记。汝勇猛军。于未来世供养无量千佛世尊。受持如来三时正法。利益无量无数众生。安立百千俱胝那由他众生于阿耨多罗三藐三菩提。无量众生住声闻乘。如是乃过阿僧祇劫。证阿耨多罗三藐三菩提。号曰无边精进光明功德超胜王如来。其佛刹土。积集无量清净功德。安隐丰乐人民充满。多有声闻及菩萨众。其佛寿命至五小劫。灭后正法住一小劫。法教流布天人受持。舍利塔庙遍诸刹土。是故胜慧。诸菩萨摩诃萨于此清净甚深之法。应当尊重受持修习。以法严具庄严其身。法庄严故证得如来金刚所成大那罗延坚固之身。假使三千大千世界。一切众生尽其躯力。而欲破坏坚固之身。乃无有能摧伏之者。一切世间天人阿修罗众中。演法光明亦无有能敌论之者。若有众生。于此深法受持读诵精勤修习。随其意乐生于清净大族姓家。乃至坐于菩提树下。名称具足。世界殊妙不杂异道。尚无梵志遮罗迦名。况有恶见邪求之辈。诸不善法亦尝未闻。宁有习行不善根者。能以足指放大光明。遍照无边一切世界。一切众生遇斯光者。皆得安乐当证阿耨多罗三藐三菩提。是故胜慧。若诸菩萨摩诃萨。于我法中勤修行者。当获如是殊胜功德。我若具说不可穷尽

尔时世尊告无边慧菩萨摩诃萨言。无边慧。若有住斯菩萨道者。勤修如是清净深法。与空相应。寂静相应。得法光明。以法光明见一切法自性无异。性无异故所见清净。见清净故则无法见。亦无有法。离自性见。法见清净。亦无清净。无清净者。无清净时。能得清净智之境界。见诸法界非界非非界界见清净。远离诸界种种性想。离性想故。于界理趣秘密言辞而能觉了。亦能遍知诸法非界。以见法界无差别故。不可坏故。不变异故。便获一切法界理趣善巧方便。以善方便遍能了知法界理趣。以等持力。于诸法界差别理趣随顺能入。住此行时。以一切法善巧方便。于一切法无住无著。无所著故能于一切法界理趣。随其所应种种开示。等持力故复能出生静虑解脱等持等至。游戏神通变一为多变多为一。山石墙壁飞行自在而无挂碍。善巧能知四界和合不住于界。知一切界与空界合。于虚空界无著无系。以界和合善巧智故。于一切界方便修习。以修习故决了水界。能于水界或令起烟。或令发焰。或复于中烟焰俱炽。乃至无量种种变现。为诸众生作大饶益。以能安住法界理趣善巧方便而无所动。随其意乐。随何佛刹。能于诸有转胎藏形受化生身。常见十方一切世界诸佛如来。彼诸如来。如是名号。如是族姓。如是众会。如是说法。悉分别知

尔时众中。复有菩萨摩诃萨。名无边胜。前白佛言。世尊。诸菩萨摩诃萨住何等法。如佛所说。能得如是最胜功德。尔时世尊告无边胜菩萨摩诃萨言。无边胜。诸菩萨摩诃萨。于一切法无所住者。如我所说。能得如是最胜功德。无边胜。诸菩萨摩诃萨。若住于色受想行识。若住地界水界火界风界空界。若住欲界色界无色界。我于此经。则不说有斯诸功德。然诸菩萨摩诃萨。于一切法而无所住。不入不出。故我说彼当得无边大功德海。何以故。诸菩萨摩诃萨。无有少法可得可住。亦无少法若入若出。善能安住诸法理趣而无所动。何以故。诸菩萨摩诃萨无住无动。以无动故无高无下。无高下故。远离于高不住于下。以不住故名善处住。善处住者于无处住。无处住者不住于处。诸菩萨摩诃萨。不于少法若有安立若有积集。无处无住无起无作。何以故。处不可得。以无处故则无分别。无分别故不动处住如法界住。无有处住则无有住。于处无处无所执著名为善住。无边胜。诸菩萨摩诃萨。于法理趣而安住者。如是安立住于无住。无住处住。见一切法无有分别。住于如是无分别行。以如是行。见一切法而无所动。则与如理而住相应。则与如理不动相应。则与如理不取相应。尔时世尊。而说偈言

  菩萨正忆念　　于义善思惟
  不住诸法中　　说名为智者
  未曾有少法　　可为安立者
  以无安立故　　无畏而发趣
  不立于诸色　　亦不立诸受
  诸想及诸行　　识等亦如是
  不住于诸蕴　　诸界及诸处
  若处若非处　　亦常无所住
  不住于地界　　亦不住水界
  火界及风界　　亦常无所住
  不住于欲界　　色界无色界
  得无安立故　　不住于三界
  及以虚空界　　于彼无所住
  以无有所住　　平等而发趣
  故无有少法　　于中而可住
  若得无所住　　斯为妙智者
  妙智无所住　　无住为菩萨
  能得如是住　　则住法界中
  无住相应故　　彼常能善住
  无住无依止　　于法得安住
  若得不依止　　则常无所动
  不入亦不出　　平等善安住
  于法如是住　　斯为勇猛者
  一切法无高　　一切法无下
  如是无所动　　法界善安住
  安住不动故　　便得无上住
  不住住相应　　斯为勇猛者
  不住于住处　　于处无所动
  成就无住处　　而得善安住
  若处若非处　　一切无所动
  住于不动处　　乃名为不动
  若住不动处　　一切无所住
  不念处非处　　常住无分别
  不住于处故　　则无有所动
  于处无所动　　一切得无住
  若得不住处　　处非处不动
  若于处不动　　乃善住于处
  善住处安住　　则住无所住
  能见一切法　　住法相应住
  如是见诸法　　种种无所住
  无住无安住　　善巧于法住
  常住于诸法　　而无有分别
  离诸分别故　　斯为不动者
  若能住不动　　于行无分别
  远离处非处　　斯为观察者
  若能观不动　　一切无所动
  诸法常平等　　如是而发趣
  如理住相应　　如理而不动
  得无动处者　　常住于无处

尔时无边胜菩萨摩诃萨。复白佛言。希有世尊。乃能安立诸菩萨摩诃萨。于法理趣。无有系缚无有解脱。世尊。诸菩萨摩诃萨。于法理趣善巧安立。不与少法若相应若不相应。若和合若不和合。若摄取若不摄取。若有所归若无所归。若贪离贪。若嗔离嗔。世尊。诸菩萨摩诃萨。于一切法理趣之中善巧安立。设有众生供养恭敬。不生贪爱毁辱逼恼。不生嗔恚。无种种想。离一切法。不见少法。能与少法若相应若不相应。超过相应不相应故。远离相应不相应想。了知相应不相应想。超过了知不于少法。若进若退。若有所趣若无所趣。而作相应。于一切法理趣之中。而无妄念。亦无所取。以善方便不坏法性。世尊。诸菩萨摩诃萨。于一切法如是住时。能以善巧。宣说一切法界理趣。一切佛法速得圆满

尔时世尊告无边慧菩萨摩诃萨言。无边慧。诸菩萨摩诃萨。于佛法中。无所安立无所住时则见佛法无有安立。无有所住。亦无胜住亦无遍住见佛法住。不倾动故。不流转故。不变异故。一切法界相应而住。乃名一切法界理趣善巧安立。无边慧。诸菩萨摩诃萨于佛法中。无住无不住。无胜住无遍住。无处住无非处住。亦无所动。亦无分别。无胜分别。无遍分别。乃名一切法界理趣善巧安立。无边慧。诸菩萨摩诃萨不见少法。能与少法而为安立。亦不见有一切法处为胜安立。亦无分别。无胜分别。无遍分别。乃名一切法界理趣善巧安立。无边慧。诸菩萨摩诃萨。不见少法若住若去。亦无分别。无胜分别。无遍分别。见一切法如净虚空。光明显照远离烦恼。于一切法光明照故。乃名一切法界理趣。得善方便不以安立而观法界。何以故。不于法界少安立故。譬如虚空及以风界。无有处所。亦无可见。无安立处。无依止处。无可示现。法界亦尔。无可入处。无可见处。无安立处。无依止处。亦无了知。亦无示现。诸菩萨摩诃萨无示现故。与如如界相应而住。无边慧。一切法界无生无命无老无死无升无沈无示现界。是为法界。无变异界是为法界。而法界者遍一切处。无边慧。法界无去亦无去处。无去处故乃名法界相应而住。如如法界。于中无处亦无非处。何以故。如如法界。如如自性无所有故。无边慧。诸菩萨摩诃萨闻我此说。则于一切法界理趣。便获无边大法光明。以法光明得无生忍。速能圆满如来十力十八不共一切佛法。为欲成熟一切众生广大善根胜资粮故。如来种性无断绝故。速诣道场转于法轮。蔽诸魔宫摧伏异论。作善丈夫大师子吼。为诸众生演说妙法。随其乐欲。随其志愿。随其发趣正解脱故。皆令趣于阿耨多罗三藐三菩提。尔时世尊。而说偈言

  一切菩萨　　不住诸法　　于佛法中
  无所安立　　一切菩萨　　无安立故
  于佛法中　　无畏发趣　　一切菩萨
  见诸佛法　　无住无处　　妙善安立
  一切菩萨　　不住于处　　能见诸法
  无住无退　　一切菩萨　　见法无住
  不动佛法　　不求佛法　　一切菩萨
  见法不异　　不动佛法　　亦不推寻
  一切菩萨　　见法如是　　于法善巧
  方便而住　　一切菩萨　　见常平等
  不住佛法　　亦非不住　　常无住处
  亦非无处　　常不分别　　非不分别
  种种分别　　常无所有　　一切菩萨
  无住相应　　于诸时处　　而无所动
  一切菩萨　　于法理趣　　平等住时
  名为善住　　一切菩萨　　于法理趣
  不见少法　　可平等住　　一切菩萨
  能见诸法　　无有处所　　亦不离处
  得无所动　　亦无亲近　　一切菩萨
  于一切法　　理趣善巧　　方便安住
  住无所住　　名为菩萨　　一切菩萨
  不于少法　　若去若来　　分别而住
  尔时乃住　　诸法理趣　　一切菩萨
  于法理趣　　种种安住　　能起无边
  大法光明　　以法光明　　住平等见
  见一切法　　及法理趣　　如净虚空
  如影如像　　平等无垢　　一切菩萨
  于见了知　　亦无了知　　远离自性
  一切菩萨　　如是观察　　于一切法
  理趣而住　　能于法界　　坚固勤修
  说名法界　　理趣方便　　一切菩萨
  不住法界　　观诸法界　　毕竟非有
  一切菩萨　　决了法界　　见一切法
  如虚空风　　无有安立　　遍一切处
  法界亦尔　　遍一切处　　法界难思
  无可示现　　于诸智者　　不作亲近
  无示现界　　乃为法界　　无有住处
  名为住者　　法界无生　　无命无老
  无死无沈　　亦无出离　　法界难思
  无来无去　　法界非蕴　　非界非处
  亦不离处　　而无所动　　法界如如
  自性非有　　一切菩萨　　如是了知
  法界难思　　得法光明　　由是发趣
  往诣道场　　而于佛法　　无有疑惑
  不为所动　　以法光明　　令诸众生
  获大安乐

无边慧。诸菩萨摩诃萨。能于如是甚深之法。勤修行者。乃得如是大法光明。以此智慧。而发趣于阿耨多罗三藐三菩提

大宝积经卷第二十四大宝积经卷第二十五

        大唐三藏菩提流志奉　诏译

    被甲庄严会第七之五

复次无边慧。我念往昔过二阿僧祇劫。尔时有佛出现世间。号曰月灯王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名甘露。国名清净。彼佛世界。颇梨所成。常有光明。遍照其土。若有众生遇斯光者净妙端严。是故世界名为清净。无别城邑聚落之名。交道殊妙金绳界饰。诸交道间。一一等量半俱卢舍。一一道间。光明宝柱杂多罗树。各八十四辉映行列。复有四池堤塘围绕。七宝台观人民止住。覆以铃网悬诸缯带。花饰珍玩犹如诸天。彼界众生寂静安乐。十善业道悉已成就。颜貌端严寿命长远。薄贪嗔痴易可开悟。以少方便广知诸法。彼佛寿命千俱胝岁。灭度之后。正法住世一俱胝岁。十会说法。诸声闻众住学地者。一一法会各有二十俱胝那由他诸菩萨众。趣一乘者其数无量

无边慧。彼月灯王如来宝菩提树。周五十由旬高一百由旬。珊瑚为根琉璃为干。黄金为枝马瑙为叶。道场纵广一百由旬基陛周匝栏楯围绕。妙多罗树布植行列。金铃宝网弥覆庄严。大菩提座高三由旬。细软敷具张施其上。妙衣百千间饰垂下。幢幡二十树列其傍。月灯王佛于此座上。证阿耨多罗三藐三菩提。时彼国界无三恶趣及恶趣名。亦无诸难及诸难名。月灯王佛常于一切诸世界中。化现其身转于法轮

无边慧。彼月灯王如来有二菩萨。一名云音。二名无边音。是二菩萨。于彼如来白言。世尊。云何诸菩萨摩诃萨。于一切法理趣之中。而得善巧方便安立。时彼如来欲令诸菩萨摩诃萨于一切法理趣之中。而得善巧方便安立。为二菩萨广说斯法。时诸菩萨摩诃萨闻斯法已。于一切法理趣之中。便获善巧方便安立。是二菩萨从是已后。于二万岁。无有睡眠无欲恚恼。不起食想不生卧想。亦无病缘汤药等想。不乐世间游观谈戏。于彼如来说法之时。即于法座得无生忍。时彼如来而问之曰。善男子。于一切法理趣之中。如是善巧方便安立。汝今求耶。是二菩萨即白佛言。世尊。我尚不见有一切法理趣善巧安立之名。亦复不见有一切法理趣善巧安立之法。况一切法理趣善巧方便安立。世尊。我亦不得一切诸法。我亦不得诸法安立。于一切法无住无不住。世尊。我如是见。宁复说言于一切法理趣之中。如是善巧方便安立。为求耶为不求耶。世尊。我亦不见于一切法理趣之中。如是善巧方便安立而作求者。亦不见有若内若外若二中间。若一切法。若法理趣善巧方便而安立者。亦不见法若内若外。若二中间。若一切法。若法理趣善巧方便而可安立。世尊。我亦不见乃至少法内外中间。理趣善巧方便安立而可趣向。而可亲近。世尊。既无少法而可趣向而可亲近。我于其中当何安立。世尊。我亦不见过现未来为安立处。若安立处无所有者。我于何处而可安立。世尊。无安立故。非住相应。非不住相应。无尽相应。无生相应。世尊。我亦不见从谁由谁何处何时。我心意识。若生若灭。当何说言。以心意识。于一切法理趣善巧方便安立

无边慧。是二菩萨。于如来前如是说时。一千菩萨得无生忍。千俱胝菩萨发菩提心。尔时月灯王如来复告之曰。善男子。汝以无住而住无处。而住于一切法理趣善巧方便安立。善男子。一切诸法亦复如是。如来随顺世俗道故。现证阿耨多罗三藐三菩提。若于如来。不随世俗。现证阿耨多罗三藐三菩提。亦复如是。善男子。诸法无处亦非无处。若处无处皆随世俗。若随世俗则于其中无有少法而可生者而可了者。是故善男子。应加精勤速于诸法逮得解脱。是二菩萨。于如来前闻斯法已。飞腾虚空。即以偈颂。赞如来曰

  法王不思议　　得未曾有法
  遍知两足尊　　佛法无过上
  以法无上故　　如来世无等
  一切法无生　　我今获此忍
  我常不分别　　若生若无生
  如是亦不念　　一切无分别
  法王大牟尼　　功德离言念
  愿说清净法　　令众皆欢喜
  于佛胜功德　　欲知其边际
  设经无量劫　　而亦不可得
  功德无边故　　最胜无过上
  一切法无生　　我亦不分别
  我于佛法中　　未曾有毁坏
  不谓众善根　　云何当可得
  诸法无示现　　无生亦无相
  如是无相忍　　于此亦皆证
  我今所得忍　　毕竟无退转
  故于一切智　　以此生欢喜
  我于如来法　　决定不犹豫
  亦于一切法　　远离众疑惑
  无上佛法中　　我今得此忍
  我亦不分别　　亦无不分别

无边慧。是二菩萨说此偈已。于月灯王如来右绕三匝。以天妙花栴檀末香而散佛上。时彼如来即为授记。而告之曰。汝云音等。过二万劫当证阿耨多罗三藐三菩提。是二菩萨。闻如来记踊跃欢喜。谛观如来入于诸禅游戏神通。出没自在烟焰晖发。复为众生说法开示。令二十四俱胝人天。趣于阿耨多罗三藐三菩提。是二菩萨。乃至尽命勤修梵行。于彼如来中时正法后时正法悉能护持。复于尔时。教化成熟四俱胝众生。趣于阿耨多罗三藐三菩提。是二菩萨。次第供养亲近承事多百千佛。及诸如来三昧正法一一受持。过二万劫复值宝幢如来。随转法轮教化成熟无量众生。趣于阿耨多罗三藐三菩提。宝幢如来刹土清净。无诸声闻。唯有一生补处菩萨。宝幢如来将灭度时乃为授记。我灭度后。云音菩萨次当现证阿耨多罗三藐三菩提。号曰日灯王如来。其佛刹土成就庄严。积集无量无边功德。菩萨声闻大众圆满。日灯王如来灭度之后。无边音菩萨。次当现证阿耨多罗三藐三菩提。无边慧。以此法门无所得故。无言说故不可示现。无生无灭。诸菩萨摩诃萨。当应如理精勤修习。若有菩萨。住一切法理趣善巧方便安立。以无所得获无生忍。圆满佛法无量功德以为庄严。而发趣于阿耨多罗三藐三菩提。无边慧。我曾不说诸菩萨摩诃萨离此法外。别有少法速能成就一切智智。若有于此无生无灭甚深空法勤修行者。速得菩萨法界理趣善巧方便及陀罗尼。具足辩才。无上摄化。诸佛世尊之所称赞。以法严具而庄严之。能圆满施住清净戒。得清净忍无上精进无缘禅定。以大智慧而发趣于阿耨多罗三藐三菩提。于诸胜中最为殊胜。速得名为一切智者。坐于道场。四大天王持盖来诣请转法轮。为诸人天作大光明。皆令趣于阿耨多罗三藐三菩提

复次无边慧。若诸菩萨摩诃萨。于一切法海印三昧勤修行者。见一切法同于法界。如是见时。不于法界见一切法。不于诸法见于法界。精进修习。以一切法诸界和合善巧方便。于一切法诸界和合。无所执着。亦无所动。于一切法诸界和合善巧方便。亦无执着。亦无分别。能于一法和合之中。而见一切诸法和合。能于一切诸法和合。而复见于一法和合。不于一切诸法和合而亲近于一法和合。不于一法和合之中亲近一切诸法和合。以能了知此一法故。亦能了知一切诸法。以能了知一切法故。于此一法应了知处。亦能了知。不以诸法亲近一法。于诸取蕴和合之中。悉能了知。不于取蕴种种性相。若有和合若无和合而生执着。诸菩萨摩诃萨如是行时。若有诸法以众因缘和合而生。若有诸法以众因缘和合而成。于彼诸法悉能了知。若有诸法因缘和合。以种种性相应而起。于彼诸法亦能了知亦无执着。随顺了知一切诸法施设之相。亦能了知若相无相。亦能了知诸界差别诸界种种性相差别。亦能了知以谁为因不以烦恼亲近趣向诸缘起法。亦于世间出世间法。不相违背。随顺了知世间出世间一切诸法。世间相印皆遍了知。以一法门而能了知一切法门。以诸法门复能了知一法之门。不以一切诸法之门。而亲近于一法之门。亦复不以一法之门。而亲近于诸法之门。如是法门悉能净治。无边慧。诸菩萨摩诃萨。于此法中勤修习者。以一理趣言教之门。而能了知一切诸法性同一味。于一切法得胜无诤。如理寂静不相违背。能于大会赞说斯法。精勤修习得一切法海印三昧。如是修习。若有诤论若无诤论。皆令寂静如理而住。随顺断除憍慢放逸。于决定说善能受持。差别名言亦能觉了。法界理趣方便勤修。于诸法门善寂思念。当以何法何法相应。若不相应。能以方便于决定义住清净念。无边慧。诸菩萨摩诃萨。于此法门如是住者。以少加行得一切法海印三昧。以此无量法海三昧。而发趣于阿耨多罗三藐三菩提。尔时世尊。而说偈言

  汝观一切法　　流入法界中
  诸法同法界　　理趣悉平等
  复观于法界　　流入诸法中
  法界同诸法　　理趣亦平等
  不于法界中　　观察一切法
  亦不离法界　　而见于诸法
  不于诸法中　　观察于法界
  亦不离诸法　　而见于法界
  了知种种界　　法界种种性
  一切法和合　　善巧无所住
  一切时及处　　种种性和合
  无住无所依　　亦无有所取
  和合差别性　　分别不分别
  于彼二俱无　　智者平等见
  知一和合故　　则知诸和合
  知诸和合故　　则知一和合
  和合不和合　　一性差别性
  不近不分别　　无执无所著
  了知一切法　　彼法无和合
  亦不念和合　　无执无所著
  了知一切种　　彼法施设相
  亦不念亲近　　无执无所著
  业及业果报　　一切悉能知
  于彼不相违　　斯为精进者
  业及业作者　　此二和合相
  知彼相无相　　斯为精进者
  于诸界和合　　诸界差别性
  知彼常平等　　斯为精进者
  因果相系属　　一切悉能知
  于彼诸缘法　　被甲如理住
  能知出世法　　于诸世间法
  无有少相违　　如是平等住
  亦知世间法　　于诸出世法
  亦无少相违　　如是平等住
  世间所应作　　一切诸相印
  随顺能观察　　遍知平等住
  能以一法门　　了知诸法门
  亦以诸法门　　了知一法门
  不以一法门　　亲近诸法门
  不以诸法门　　亲近一法门
  一切法门中　　平等遍清净
  于法无异相　　斯为观察者
  于诸法言教　　而能平等说
  常住平等性　　斯为观察者
  于诸法言教　　如理能知见
  便得善相应　　斯为方便者
  不起于诤论　　不作诤因缘
  一切不相违　　斯为相应者
  常起于无诤　　无诤得相应
  平等不相违　　斯为智慧者
  于法理趣中　　永息诸诤论
  被甲如理修　　斯为勇猛者
  如是遍观察　　纯一无违诤
  能于法会中　　赞说无上法
  如是诸菩萨　　成就一切法
  大海印三昧　　斯为正念者
  如是勤修习　　纯一无违诤
  息诤论相应　　成就此三昧
  如理而安住　　能知秘密说
  知我及我慢　　断慢绝矜高
  决定言教中　　成就善方便
  亦知差别名　　斯为有智者
  诸法理趣中　　如理勤修习
  能见诸法门　　斯为见法者
  如是勤修习　　能知一切法
  何法共相应　　何法不相应
  一切诸法中　　念业清净者
  能于决定义　　而得善方便
  一切诸法中　　精进思惟者
  了知一切法　　乃获此三昧

复次无边慧。诸菩萨摩诃萨。于此法中勤修习者。复有能摄三昧之法。谛听谛听善思念之。吾当解说。唯然世尊。愿乐欲闻

尔时世尊。告无边慧菩萨摩诃萨言。无边慧。有诸菩萨摩诃萨法光明门。而能出生诸法理趣善巧方便。亦能出生一切法印。能入一切法印之门。于一切法所应作者能了能入。于法光明能得能说。以法光明随顺趣入诸法句门。何者名为法光明门而能出生善巧光明。谓能了知异名教门。秘密教门。异名事门。摄取事门。诸差别门。云何于彼而得了知。乃能出生三昧之门。一切法界理趣之门。入于一义。能随解了诸法光明

无边慧。诸菩萨摩诃萨。于此甚深诸法理趣善巧方便。若现修行。若当修行。若现求者。若当求者。闻此法门。以少加行得大光明入诸法门。从此法门复起光明。以是光明随何法门。随何所行。应入应行。如其理趣。以三昧力观诸法门。于三昧门出生智慧。而能了知如实理趣三昧力故。观法门故。生智慧故。以三昧门了知法界。住善方便。能起一切法门光明。得一切法海印三昧

无边慧。云何法门。谓阿字印。印一切法。无明所作。行得圆满。阿字为首。无明止息。无所作故。诸菩萨摩诃萨。应入无相印门。以[橠-多+可](阿可反)字印印一切法。业异熟果。业所应作。业果和合。了知业果和合缘故。诸菩萨摩诃萨。应入无业无果。无有和合。无缘印门。以诸行印印一切法。于种种业。业所应作。起一切法智光明故。诸菩萨摩诃萨。应入一切诸行善巧印门。以[打-丁+袲](那可反)字印印一切法。以么字助。施设名言与种种法而作相应。了知[打-丁+袲]么而相助故。诸菩萨摩诃萨。应入无合无助无名印门。以无边印印一切法。一切分别而不可得。离分别故。诸菩萨摩诃萨。应入无分别印门。以无际印印一切法。际不和合。尽于际故。诸菩萨摩诃萨。应入无寻无伺无言说印门。以无种种自性之印印一切法。以一自性起作之相。断除种种自性想故。诸菩萨摩诃萨。应入种种自性印门。以欲相应和合之印印一切法。现起有为诸行圆满。离欲寂静无和合故。诸菩萨摩诃萨。应入尽欲智见无和合印门。无边慧。是为菩萨摩诃萨印门印一切法。以此印门而应入于一切法中。无边慧。复有无障碍门无和合门。诸菩萨摩诃萨应随悟入。云何无障碍门无和合门。谓虚空印印一切法。诸菩萨摩诃萨。应入无著印门。以空闲印印一切法。诸菩萨摩诃萨。应入无二印门。以寂静印印一切法。诸菩萨摩诃萨。应入止息印门。以无门印印一切法。诸菩萨摩诃萨。应入不动印门。以无处印印一切法。诸菩萨摩诃萨。应入无染印门。以性空印印一切法。诸菩萨摩诃萨。应入无得印门。以无相印印一切法。诸菩萨摩诃萨。应入善巧修习方便印门。以无愿印印一切法。诸菩萨摩诃萨。应入善寂静愿光明印门。以无贪印印一切法。诸菩萨摩诃萨。应入遍知分别如实印门。以无生印印一切法。诸菩萨摩诃萨。应入生正智见无生印门。以寂灭印印一切法。诸菩萨摩诃萨。应入离蕴印门。以尽相印印一切法。诸菩萨摩诃萨。应入生尽印门。以法界印印一切法。诸菩萨摩诃萨。应入显现法界善巧印门。以无念印印一切法。诸菩萨摩诃萨。应入实无分别平等印门。以离性印印一切法。诸菩萨摩诃萨。应入遍知一切自性印门。以涅槃印印一切法。诸菩萨摩诃萨。应入如实寂静顺灭印门。无边慧。是为诸菩萨摩诃萨于一切法无障碍门。不和合门。超过一切断常见门。无边际门。前后际门。以厌离故。寂灭故。止息故。清凉故。诸菩萨摩诃萨。于此一切法印之门随学随入。以善修行此诸法门。得一切法海印三昧。此三昧者。如实相应能摄诸法善方便智。是故诸菩萨摩诃萨。于此印门。应善修习住一切法海印三昧。观一切法。而能出生无量无边大法光明。无边慧。譬如大海水乃无量而无有能测其量者。一切诸法亦复如是。终无有能测其量者。又如大海一切众流悉入其中。一切诸法入法印中。亦复如是。故名海印印一切法悉入诸法海印之中。于此印中。见一切法同于法印。又如大龙及诸龙众。诸大身众能有大海。能入大海。于彼大海以为住处。诸菩萨摩诃萨亦复如是。而于无量百千劫中。善修诸业。乃能入此三昧印门。于彼印门以为住处。为欲证得诸佛法故。善巧圆满一切智故。成就如是诸法印门。诸菩萨摩诃萨。精勤修学此法门时。则能修学一切法门。见诸法门在此门故。而能发起诸法光明。入于一切法海之中。是故此法名一切法海印三昧。又如大海是大珍宝积集之处。此三昧者亦复如是。是一切法及法善巧积集之处

无边慧。若有众生。为得无上佛之知见。于此三昧。若已求者若当求者。若现求者。彼则能求一切法海圆满智慧。以是义故。我此法印付嘱于汝。汝于末世后五十岁正法灭时。以此法印印诸众生。为此法印而印之者。皆于阿耨多罗三藐三菩提得不退转。成就佛法速诣道场。转无上轮绍隆佛种。随顺住于一切智地。能于无上大般涅槃而般涅槃。令诸天人受持正法。无边慧。诸菩萨摩诃萨。若欲摄取如是无量殊胜功德。于此深法。精勤爱乐而无放逸

复次无边慧。我念往昔过大无量阿僧祇劫。复倍是数。尔时有佛出现世间。号曰超过须弥光王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名善住国名悦意。时彼劫中众生寿命不可限量。安隐丰饶住众善法。是故彼劫名为善住。彼佛国界广博严饰多诸美妙。见者和乐悦意。名香周流普遍。是故彼国名为悦意。时四洲中。三洲等量八万由旬。一一洲中有二万城。一一城量各十由旬。唯有阎浮一洲。广量俱胝由旬。有八万城。一一城量二十由旬。重楼表刹垣墙周匝。种种衣树。种种味树。诸杂花树。宝多罗树。而庄严之。国界安乐人民充满。其中复有最大都城周百由旬。二万园苑而围绕之。诸园苑中。澄潭溯流处处盈注。华蕊甘实一一荣茂。名香普熏闻者欣悦。鸟兽和鸣其声雅亮。尔时彼佛。住一园中为众说法。无边慧。超过须弥光王如来寿十小劫。灭度之后。正法住世满一小劫。时彼如来四会说法。一一法会。诸声闻众住学地者。各有五百俱胝那由他。诸阿罗汉及菩萨众。各有五十俱胝那由他。时彼如来有二菩萨。一名勇猛军。二名勇猛力。是二菩萨。具足神通得无生忍。前白佛言。世尊。以何等法。成就菩萨摩诃萨一切诸法海印三昧。时彼如来。以此句门广为宣说。说此法时。十千菩萨得无生忍。是二菩萨证一切法海印三昧。及证菩萨一切三昧。以证诸法海印三昧。及证菩萨诸三昧故。能于一切佛刹土中。现大神变放大光明。出妙梵音。为诸众生演说正法。而能成熟八俱胝人。趣于阿耨多罗三藐三菩提。时彼如来即为授记。过一百劫。皆当证于阿耨多罗三藐三菩提。百劫之中于一一劫。供养承事五百如来。于彼如来中时正法后时正法。悉能受持。为诸众生作大饶益。一一劫中一心不乱。一一生处皆受化生。一一生中不退三昧。神变说法度诸众生。过百劫已复值无边功德如来。供养亲近。善能游戏无量三昧神变解脱。是二菩萨。于彼佛所。一名离忧。二名善住。能随如来转于法轮。教化无量无数众生。令住三乘。时彼如来复为授记。我灭度后。离忧当证阿耨多罗三藐三菩提。号曰无边辩才如来。灭度之后。善住当证阿耨多罗三藐三菩提。号曰最胜光明如来。共寿一劫。刹土积集无量功德。是二菩萨。于如来前受斯决已。次第证于阿耨多罗三藐三菩提。无边慧。若诸菩萨摩诃萨。为一切法海印三昧。应生爱乐起大精进不惜身命。以不放逸而修行之

时彼众中。复有菩萨摩诃萨。名曰慧义。即从坐起前白佛言。希有世尊。乃能为诸菩萨摩诃萨。得一切法智善巧故。及得如来一切智故。说一切法海印三昧。世尊。若得诸法海印三昧。决定当得诸法理趣善巧方便速诣道场。以此无边功德大海。而发趣于阿耨多罗三藐三菩提。常见诸佛。勤修正法与僧同行。能消如来最上之供。超过声闻缘觉之地

尔时世尊告慧义菩萨摩诃萨言。如是如是如汝所说。慧义。诸菩萨摩诃萨。得一切法海印三昧。则得无量殊胜功德。若住诸法海印三昧。能以诸法海印三昧善巧方便。决定趣于阿耨多罗三藐三菩提。慧义。譬如须弥山王众宝所成。出于大海。量高八万四千由旬。嶷然安住最极光明。诸菩萨摩诃萨亦复如是。以此三昧善发趣故。出于一切法藏大海。映蔽一切世间天人。无上安住最极光明。又如满月众星围绕。诸菩萨摩诃萨亦复如是。能于一切世间天人大众之中。作大光明。慧义。汝观斯法。其谁于此不生爱乐。不起精进而为放逸。唯除下劣薄福众生。若诸众生有大智慧。而能成就此广大法。广大法者具足功德。诸善丈夫之所摄取。如我所说。若能摄此广大法财。为诸天人之所侍卫。十方诸佛诸大菩萨之所护念。尔时世尊。告无边慧菩萨摩诃萨言。无边慧。诸菩萨摩诃萨。若于此法勤修学者。能为众生作大饶益。除一切疑解一切结。舍诸习气断诸随眠。超诸喜爱渡诸有海。永灭黑闇永离惊怖。速以善巧能知一切众生之心

尔时世尊说是语已放大光明。其光遍照无数世界。映夺一切日月光明。放斯光已复告无边慧菩萨摩诃萨言。无边慧。诸菩萨摩诃萨。若能勤修海印三昧。亦当如是现大神变放大光明。大师子吼演说斯法。超过三界作大照明。如我今日而无异也。时无边慧菩萨摩诃萨白佛言。世尊。唯愿如来加持此法。于后末世。若有众生闻斯法名。当获无量无边功德

尔时世尊。为欲加持此法门故。又放光明。复以一指。遍动三千大千世界。令诸众生得大安乐。于时会中。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。如是众等。散天妙花及天妙衣。天诸妓乐俱时而作。无量诸天手执天衣。摇裔翩翻满虚空中。同声唱言。奇哉奇哉。诸佛境界不可思议。若有受持此深法者。当知堪受一切众生恭敬作礼

尔时世尊复告无边慧菩萨摩诃萨言。无边慧。后末世时薄福众生。不得闻此甲胄庄严三昧庄严。若诸众生有善方便摄大资粮。于后末世乃闻斯法。若于斯法勤修行者。则为三世诸佛世尊之所摄受。无边慧。于后末世大怖畏时。我此法门付嘱汝等。我于无数俱胝那由他劫。积集无上诸法宝藏。具足功德无边安乐汝今皆得。一切苦蕴汝今皆舍。汝以无边功德大海。而速趣于阿耨多罗三藐三菩提。尔时无边慧菩萨摩诃萨。与五百菩萨摩诃萨及诸居士贤护商主等。而为上首顶礼佛足。白言世尊。我随力能当持如来大菩提法。于后末世。为诸众生作大饶益。尔时诸菩萨摩诃萨。各从坐起。以诸杂花散于如来。脱身妙衣持以供养作如是言。世尊。以此善根。我皆回向一切众生。愿诸众生悉得圆满菩提分法。成就如来一切法智。于后末世一切众生所有善根愿皆成就。尔时世尊。为令一切菩萨摩诃萨生欢喜故。而说偈言

  为诸众生故　　当兴大饶益
  持我菩提法　　法王师子吼
  于后末世中　　若诸求法者
  闻斯广大法　　一切获安乐
  如我之所说　　若有见此乘
  闻斯契经法　　得随其所乐
  若有智慧者　　修习善方便
  闻斯最上法　　身心大欢喜
  若在于此会　　现前见我说
  得闻斯法已　　善能爱乐者
  于后末世中　　生汝大福聚
  无数无有量　　广大无边际
  于后末世中　　若能受持此
  法王所说法　　为佛之摄受
  于后末世中　　持我菩提法
  则为无量佛　　最后持法者

尔时世尊说此法已。无量菩萨得无生忍。无量众生成熟善根。无边慧菩萨摩诃萨。及诸菩萨摩诃萨。一切世间天人阿修罗等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第二十五大宝积经卷第二十六

        梁三藏法师曼陀罗译

    法界体性无分别会第八之一

如是我闻。一时佛在舍卫国只陀林给孤独园。与大比丘八千人俱。菩萨摩诃萨万二千人。从无量佛土而来集会。复有三万二千天子悉向大乘。时大众中有菩萨摩诃萨。名文殊师利童子及宝上天子。尔时宝上天子作是思惟。若今世尊告文殊师利演说于法。若告已说。令诸魔宫皆悉闇蔽无复威德。使魔波旬忧恼不悦。令诸魔众悉善调伏。诸增上慢者破增上慢。自记所得善修行者获沙门果。已得果者转更增上。使佛法僧种相续不断。令多众人发菩提心。此如来无量阿僧祇劫。所集菩提令得久住。若如来在世及灭度后常闻说此法。随所向乘疾得灭度。尔时世尊。于宝上天子所念。即告文殊师利童子。于此众中可少说法。今此大众欲从汝闻。尔时文殊师利童子。即白佛言。世尊。当说何法。佛言。说于法界体性因缘。文殊师利言。世尊。一切诸法界法界体性。世尊。出法界外无有所闻。世尊。云何言因法界演说于法。佛言。文殊师利。憍慢众生若闻此法生于惊怪。文殊师利言。世尊。法界体性无有惊怪。世尊。是惊怪者即法界体性。尔时大德舍利弗。问于文殊师利童子。文殊师利。若一切法皆法界体性。众生何处有污染净。法界体性无污净故。文殊师利言。大德舍利弗。是诸众生身见颠倒。安住我胜我所胜。是凡夫人发起我想。是众生等执着我想。及着他想起心心数法。是心心数法。造作诸业若善不善。是诸众生行业因故获得果报。大德舍利弗。若已有生即有染污。是污染者法界体性。大德舍利弗。若知污染是法界体性。是名白净然第一义。无有污净。若污染法。若白净法。文殊师利说是法时出百比丘悉断诸漏得无漏心。尔时大德舍利弗语文殊师利童子言。所说法界无有错谬。说是法已。过百比丘悉断诸漏得无漏心。文殊师利言。大德舍利弗。此法界者。本是系缚今得解耶。舍利弗言。文殊师利。是法界者非本系缚今得解耶。大德舍利弗。是诸比丘今于何处心得解脱。舍利弗言。文殊师利。如来甚多调伏声闻。皆断诸漏心得解脱。文殊师利言。大德舍利弗。汝是世尊声闻不耶。舍利弗言。文殊师利。如是如是。如汝所说。我是世尊声闻人也。文殊师利言。大德舍利弗。汝断诸漏得于无漏解脱心耶。舍利弗言。我得无漏解脱之心。文殊师利言。大德。以何等心得于解脱。为过去心为未来心现在心耶。大德。过去世心已灭之想。未来世心未至之想。现在世心不住之想。云何大德心得解脱。舍利弗言。文殊师利。非过去心得于解脱。非未来现在心得于解脱。文殊师利言。大德。汝云何言心得解脱。舍利弗言。文殊师利。住世谛说心得解脱。第一义中都无有心系缚解脱。文殊师利言。大德舍利弗。汝欲令法界体性有于世谛第一义谛耶。舍利弗言。文殊师利法界体性无有世谛第一义谛。文殊师利言。大德汝云何。说住于世谛心得解脱。舍利弗言。文殊师利。宁无有心得解脱耶。文殊师利言。大德舍利弗。若心有内有外中者是得解脱。大德而是心者无内外中。无系缚解脱。尔时众中有二百比丘。闻于文殊师利所说。即从坐起说如是言。若无解脱。无解脱心。我等何故出家修道。若无出世何故修道。是诸比丘说粗语已背众而去。尔时文殊师利童子。欲调伏是诸比丘故。知诸比丘所去道。前化一比丘。是诸比丘到化比丘所在化比丘前如是问言。大德从何处来。是化比丘答诸比丘。大德。我于文殊师利所说。不解不知不信不向。以是缘故从彼众来。是诸比丘即复语此化比丘言。大德。我等亦尔。不解不知不信不向。以是缘故从彼众来。化比丘言。大德。于文殊师利所说法中。云何不适。违逆汝意从众出来。诸比丘言。大德。以文殊师利说无向果。无有证果。又无解脱。我等闻已作如是念。若无向果无有证果无解脱者。我等何义修行梵行。若无出者何故修道。思是义故出彼众来。是化比丘作如是言。大德。汝不解故。为诽谤故。为骂詈故。出彼众来。诸比丘言。我等亦不诽谤骂詈。但以不见于解脱故出彼众来。是化比丘即便称叹诸比丘言。善哉善哉大德。我等今当善共思议。若非骂詈则非诤讼。非诤讼者。是第一义沙门法也。汝等心者何等相耶。为青黄赤白紫颇梨色实耶。不实耶。常耶。无常耶。色耶。非色耶。诸比丘言。大德。心者非色而不可见无有形照。亦无触对。无处无教。化比丘言。大德。而是心者实非是色而不可见。无有形照亦无触对无处无教。而是心者内住外住内外住耶。是诸比丘答言不耶。化比丘言。大德。汝心非色而不可见。无有形照无有触对。无处无教非内外中。是正成就不。是诸比丘答言不也。化比丘言。大德。汝心非色而不可见无有形照无有触对无处无教非内外中是正成就不。诸比丘答言不也。化比丘言。大德。若心不实无成就者。云何解脱。是诸比丘答言不也。化比丘言。大德。以是义故。文殊师利说法界体性无污染净。大德。汝凡夫颠倒故。执我我所而起于心。行诸境界起攀缘心。是尽能灭一切攀缘生灭。不住变易之法。若心缘出家受具足戒。修道得果。是心体性空无有实从妄想起。若不实妄想则是不生不住不灭。若其非是生住灭者。无有系缚亦无解脱无向无得。大德。以是义故。文殊师利说法界体性无污染净。亦无向得无解脱者。是化比丘如是说时。诸比丘等无漏解脱。得解脱已。即便还向文殊师利所。到已各脱郁多罗僧。以用供养文殊师利。说如是言。文殊师利。汝今善能守护我等。我等不信向是甚深调伏法故远离舍去。尔时大德须菩提。如是问言。诸大德等。为何所得为何所觉。各各脱于郁多罗僧。以为供养文殊师利。诸比丘言。大德须菩提。我等今者无得无觉。是故我等供养文殊师利童子。大德须菩提。我等以有所得想故。于此众中从坐起去。我等已能舍离得想是故还此。须菩提言。何故汝等说如是语。诸比丘言大德须菩提。著名为动摇爱着。若有动摇有爱著者无向无得。大德须菩提。若无向得即于此处能断一切动摇爱着。须菩提言。谁调伏汝。诸比丘言。大德须菩提。无有所得无所觉者是调伏我。是人不生亦不灭度。亦非禅定又非乱心。须菩提言。谁调伏汝。诸比丘言。可问文殊师利童子。尔时大德阿难问文殊师利言。此诸比丘谁所调伏。文殊师利言。大德阿难。无阴界入者。亦非凡夫。非缘觉。非声闻。非菩萨。非如来。非身相应。非言相应。非心相应。阿难言。文殊师利尔说谁耶。文殊师利言。大德阿难。若如来化化而是化者有相应乎。阿难言。文殊师利。化无有法可与相应不相应者。文殊师利言。大德阿难。一切诸法体性是化。阿难言。文殊师利。如汝所说。一切诸法体性是化。文殊师利言。大德阿难。是化调伏此诸比丘。大德阿难。如化调伏者。一切声闻亦复如是。大德阿难。如是调伏者正是调伏。若不解如是调伏者。当知名为增上慢者。尔时大德阿难。问于文殊师利童子。文殊师利。是增上慢比丘可识知也。文殊师利言。大德阿难。戒聚清净即是动摇。当知此即是增上慢。定聚慧聚解脱聚解脱知见聚清净即是动摇。当知此即是增上慢。我得我证。如是思惟动摇妄想。当知此即是增上慢。惊畏身见。亦空如空。入一道亦空。此说是正说。当知此即是增上慢。复次大德阿难。若比丘云。身见是空乃至入一道空。如是之空是平等空。当知此即是增上慢。何以故。大德阿难。身见异空。异故身见即是空。空与异道不异。道者即是空。复次大德阿难。若有惊畏无明。有爱喜明解脱。当知此即是增上慢。何以故。若有二相非是解脱。复次大德阿难。若有比丘。畏贪嗔痴。喜三解脱。惊畏四倒。喜于四相。惊畏五盖。喜于五根。惊畏六入。喜于六通。惊畏七识住。喜七助道法。惊畏八邪。喜八圣道。惊畏九众生居。喜九次第定。惊畏十不善。喜十无漏善。惊畏有为界。喜无为法。当知此即是增上慢。何以故。大德阿难。而是一切皆是动摇皆是戏论。大德阿难。若有动摇。若有戏论。心即自高。自在摄取。依止妄想。堪忍成就。如是等法。名为自在。自在故生于憍慢。大德阿难。如是比丘。当知名有增上慢也。所以者何。大德阿难。云何有为界空。是空入空。当知此比丘有增上慢。大德阿难。问文殊师利。云何比丘无增上慢。文殊师利言。大德阿难。若有比丘。寂静于内则外寂静。一切境界。若平等非平等。若有若无若有为无为。无有动摇。亦无妄想无不妄想。无二无一。无庄严无不庄严。非有戏论不执着。始见于一切诸法平等。亦无平等无不平等。无有一法能作平等非平等者。如是不动不摇。无有妄想无不妄想。又不执着亦不见妄想。何况向解得果智证。有动摇者无有是处。大德阿难。如是比丘。无增上慢侣亦无戏论。远自他伴舍诸爱着。一切爱着非爱着故。离诸攀缘觉观思惟。思惟解脱解脱向。无有取者。悉皆寂静。因寂静缘。是我身我所身度到彼岸。不见有法解向断证。若有比丘如是修行。无增上慢空平等故。解知一切诸法平等无有上下。若善不善可作不可作有漏无漏。若世出世有为无为。如是等上下动摇。无不妄想亦不见知。如是诸法悉见平等。喻如虚空。大德阿难。若有比丘如是解者。名善解脱。如是比丘无增上慢。以是义故如来说言。若有比丘解诸法平等。喻如虚空如动于虚空无所触着。沙门法者亦复如是。说是语时。二百比丘悉断诸漏得于无漏解脱之法。尔时宝上天子问文殊师利。云何菩萨无增上慢。愿如实说。文殊师利言。天子。若有菩萨一切智心无等等心三界最胜心。过诸声闻及缘觉外诸境界。以安住心。然亦修行一切善根。为增上故。化众生故。摄正法故。为余众生为他人说一切智心。是心如实解本始平等。如随所闻其心体性。解知一切众生体性。解知一切诸法体性故。解知一切善根体性。解知一切善根体性故。解知演说菩萨体性。天子。是菩提萨埵如实说受记。复次天子。若菩萨布施。随所施与。随所愿施。及诸余施一切无碍。施无所依不着。无觉无有解。无有解故即是空也。若能如是解施体性。解施体性故。解如实始体性。解如实始体性故。解诸法体性。解诸法体性故。解诸一切众生体性。解诸一切众生体性故。说菩萨体性。天子。是名菩萨施清净。故说授记也。复次天子。若有菩萨。解知身者即解知戒。解知口者即解知戒。解知心者即解知戒。解身口者解觉寂静。解觉寂静故解众生寂静。解众生寂静故解一切法寂静。解一切法寂静故解如实始寂静。解如实始寂静故得寂静法因寂静缘寂静。随有所闻一切诸法能说寂静。天子。是名菩萨戒清净。故如实说受记。复次天子。若有菩萨。知于法性毕竟是空。知于法性毕竟自在。于诸众生能忍众恶。心不起忍。不思外事不背众生。能灭一切众恶。如诸众生性忍体性亦尔。如忍体性菩提性亦尔。如菩提性一切诸法体性亦尔。如知一切诸法体性。如实如法亦尔。如如所闻同尽法性。法性界毕竟空。法性毕竟空说行顺忍。天子。是名菩萨真实净忍说授记也。复次天子。菩萨知慎一切法行离诸思惟。无诸庄严成舍进行。如有所为亦无所作。其知坚固一切能离。内性寂静外化众生。知精进寂故知菩提寂。知菩提寂故亦知一切诸法寂静。知诸法寂故知如实始如所闻法。精进性寂故一切能说。天子。是名菩萨清净精进如实知授记。复次天子。若菩萨入诸法平等无增减禅。以禅力故其心安住。心安住故识无所住。识无所住故七觉心平等。七觉心平等故得禅定平等。得禅定平等故知菩提平等。知菩提平等故知一切众生平等。知识一切众生平等故知诸法平等。若如是知诸法平等。随所闻法。能说诸法体性平等。天子。是名菩萨清净禅定如实说受记。复次天子。若有菩萨。慧眼清净如实知见于一切法。随所见法皆无所见无有动摇。得无动智无行无因无缘行。亦不行诸威仪法则。亦非不行。不行因缘。知诸法平等不救不行。何以故。若不行者即无分别。断诸妄想悕望贪着。是菩提萨埵离诸所有。亦行一切众生行处。为欲教化诸众生故。聚集一切助菩提法故。摄取正法故。不断三宝种故。如来所行者。于一切法清净体性无所分别。以此般若体性净故。知菩提体性净。知菩提体性净故知众生体性净。知众生体性净故知一切法体性净。知一切法体性净故。于诸法体性得如实智。得如实智故随所闻事是法界性说无分别。天子。是名菩萨慧眼清净如实说受记。复次天子。菩萨观身行身念处。知过去身无有边际。知未来身无趣向者。现在身者犹如草木瓦石墙壁身亦如是。若能如是观身身行。是身体性痴行寂静。思惟并行亦无发起。不思惟不起自在是名离我。识无所住修身念处行。亦无有法可修行者亦非不修。知一切法无有体性非不有性。如是观身修于身行。观心如幻化。知心如响应。如实知心。受乐不爱受苦不苦受不苦乐不失正念。不执无明。离受于受不为所牵。是名如实知见受念处。若能如是观受行者。于诸受法心无所行心不安住。是一切心亦不放舍。菩提之心亦不失念。亦不远离。是名观心行心念处。善知法知见法行法。无念无思惟。入于法性无身受心。非观法相。发起见行入于法性。是名观法行法念处。是一切法体性和合。聚集无物犹如虚空。如所闻事无念无思惟。自然说法念处。天子。是名知于净法念处说受记也。复次天子。又是菩萨一切智心而得自在如所教悔。正住不施不乱不失。念于初发一切善根无垢心行。随所行处一切能舍。诃犯戒心不依止戒。忍无诤讼。身口心意于诸众生不生嗔心。不起声闻缘觉精进乘进。不念思惟一切善法。不依诸禅定次第定。心无所行不见行诸见。不行诸法入一切法。如诸圣人。于诸境界而无所行。虽近非圣身口意业未曾被诃。不以信故。求于善法独行无侣。欲自过世行精进行。永断贪欲嗔痴结故。心无烦恼不破戒故。亦不亲近行恶行者。无有谀谄内行净故。无散乱语者口业净故。无所求者自财知足故。非驱使者非邪命活故。无积聚者随有所得皆知足故。无希望者离三界欲故。是知足者离恶求故。是寂静者解一切法皆寂静故。现嗔痴者舍世行故。无戏论者断诸戏论故。是不还者断欲嗔痴故。贪嗜法者调伏憍慢故。是易解者善调心故。善守护者护戒聚故。心善解脱者慧聚净故。是不舍者行圣种故。无退转者发菩提心毕究竟故。无所用者一切世行故。无诤讼者等一切众生故。善自护者护他人故。调自心者不求他过故。离诸悕望者护净戒故。广说法者无吝惜故。是爱护者护于一切众生心故。初发心者集一切善法故。无异行者于一切法得一味故。不动摇者断诸动故。不观种性者教化众生故。等众生者摄取一切诸众生故。初观空者一切法故。调诸见者善教化故。无想行者调伏行想诸众生故。知无愿者所愿满足善调伏故。一切知者观无作故。是行善者不知足故。无物观物者示现非物而是物故。不思惟观者我寂静故。无自我者观化众生以无我故。无非道行者化诸众生离结使故。方便之心得毕竟者修行般若故。定住无去者终不证触一切声闻缘觉乘故。离道非道者第一义故离行非行者。一切凡夫证正行故。无庄严无不庄严者无不悕望诸法故。不自赞者不戏论他故。无等等智者具佛法故。无生法忍者。一切诸法无生无灭忍故。天子。是名菩萨得于自在。天子。菩萨者随所生处。非不知故生以知故生。而是菩萨摄取生死得自在故。亦得具足成就佛法。而是菩萨非生死流转。以愿力故。在在处生得自在智。是名菩萨得自在智。菩萨非以得边际故。名自在智。若不断绝一切善根。是名菩萨得自在智。菩萨非得诸善根故。名自在智。于诸善根无厌足故。名自在智。菩萨非不生三界得名自在。为化众生故生三界名为自在。菩萨非以离自结故得名自在。为诸众生断结使故勤修精进。是名菩萨得自在智。菩萨不以为己身故得名自在。为于寂静一切众生诸苦恼故名为自在。菩萨非以舍故自在。摄取教化众生故名为自在。菩萨非断自贪嗔痴得名自在。断诸众生贪欲嗔痴诸结使故名为自在。菩萨非自证灭法故得名自在。为诸众生证灭法故得名自在。菩萨非自断漏故得名自在。菩萨为诸善根增长不断漏法名得自在。菩萨非证三解脱故名得自在。菩萨解了三解脱故名为自在。菩萨非自在寂灭五阴名得自在。为舍一切众生重担名为自在。菩萨非以灭六根故名得自在。知诸众生上下根故名为自在。菩萨非以生分尽故名得自在。菩萨不以断绝生故名为自在。菩萨非得过于声闻缘觉解脱名得自在。菩萨道场得解脱果受用一切诸众生故名为自在。演说如是自在品时。于是众中三万二千诸天子等皆发无上正真道心。尔时世尊赞于文殊师利童子。善哉善哉。善说一切菩萨受记。文殊师利。若有菩萨闻说如是菩萨受记。一向信解不生惊畏。诸佛世尊为说真实无上道记。尔时宝上天子语文殊师利童子。汝今演说于受记也。文殊师利言。天子。我说受记我有是法。有觉了者我说受记。天子。我今不得乃至一法亦无觉了。云何说受记。天子言。文殊师利。恒河沙等诸佛世尊。岂无解向而得果耶。文殊师利言。天子。诸佛世尊无解向得果。天子。诸佛世尊不为解向得果说法。天子言。文殊师利。诸佛世尊云何说法。文殊师利言。天子。诸佛世尊亦不分别体性而说法也。无生无灭无因无缘无去无来。无有众生非无众生。无污染无白净。无生死无涅槃。天子。诸佛世尊如是说法。天子问文殊师利言。诸佛世尊不为涅槃而说法者。何以故。名为佛出世耶

大宝积经卷第二十六大宝积经卷第二十七

        梁三藏曼陀罗译

    法界体性无分别会第八之二

文殊师利言。天子。觉了身见之体性故名佛出世。天子。示现无明有爱体性名佛出世。觉了贪嗔痴体性故名佛出世。天子。示现颠倒体性平等名佛出世。天子。觉了诸见之体性故名佛出世。天子。示阴界入法界体性名佛出世。天子。佛出世者。诸法无生是名演说无生法也。是无生法。都无生死亦无涅槃。天子言。文殊师利。当为众生说庄严无上正真道法。何以故。文殊师利。诸佛出世无所增长。文殊师利言。天子。知恩报恩者。天子言有所作者当知报恩。文殊师利言。天子。汝欲使如来有所作也。天子言。文殊师利。如来者无有所作。诸佛如来到于无为。无为之道无有所作。文殊师利言。天子。汝许无为者无报恩非不报恩。天子言。文殊师利。如此法者不应为初发意者说。何以故。若闻是法生于惊畏便当退转。文殊师利言。天子。若有菩萨初发无上菩提之心。惊畏退转是人则住于退转也。天子言。文殊师利。何故说是。文殊师利言。天子。若有菩萨。初发道心惊畏声闻缘觉地则便退转。若悭惜破戒嗔怠乱痴住于不退。天子言。文殊师利。云何住也。文殊师利言。天子。若有菩萨初发道心。安住法界平等中故是名善住。初发心菩萨名之为住。天子言。文殊师利。菩萨齐几名初发心。文殊师利言。天子。若有菩萨初发心者。修行于空无相无作。解一切法无生无灭。是名菩萨初发心也。天子言。文殊师利云何菩萨名为久行。文殊师利言。天子。一切凡夫名为久行。于生死中不知始故。天子。复问文殊师利。云何菩萨名久行者。文殊师利言。天子。若有菩萨行于爱染。为化爱染诸众生故。而亦不共是爱染住。名菩萨久行。行于嗔恚为化嗔恚诸众生故。不共嗔住。亦行愚痴。为化愚痴诸众生故。不共痴住。亦行等分。为化等分诸众生故。而亦不共一切结住。天子。若有菩萨。化众生故观一切相。亦不分别法界体相。名菩萨久行者。天子言。文殊师利。云何菩萨名为不退转。文殊师利言。天子。若有菩萨观一切法无灾无不灾。观法界体性无灾无不灾。是名菩萨不退转也。复次天子。若有菩萨亦退不退。是名菩萨不退转也。所以者何。退者欲界退诸善故。复次天子。菩萨不知不解故退。以知解故无有诤讼。是名不退。何以故。解一切性法性。我以能解了一切法性更不复退。是名不退。于佛法无疑不信他语。离是不是。初心清净无有嫉妒亦无动摇。智慧明照。于一切法而得自在。解了佛法。是名菩萨不退转也。天子言。文殊师利。云何菩萨名为一生。文殊师利言。天子。菩萨若知一切诸生而亦不生。亦知一切众生生死。于诸生中善能说法。教化众生生处无取。亦取诸生离生死取。不去不来不上不下。一切诸法悉平等故。亦知因缘和合增长。一切众生身口心意悉皆平等。一切众生无有境界。住佛境界入于法界。法界平等故。平等解了众生之心。善解知时至于道场。是名一生。天子。是则名为菩萨一生。尔时宝上天子问于文殊师利童子。云何名菩萨不生。亦于一切而得自在。文殊师利言。天子。若有菩萨知于行业。非憍慢故。是菩萨不生。亦于一切而得自在。复次天子。菩萨能舍一切所有菩提之心。毕竟不退是名不生若不共诸嫉妒结住。是名一切而得自在。若有菩萨威仪法则。诸功德戒具成就行。是名不生。不共犯戒住。是名一切而得自在。心不舍背一切众生。是名不生。不共一切无明嗔恚诸结使住。是名一切而得自在。于诸善根坚住不动。是名不生。于善根中发勤进勇意。是名一切而得自在。入诸禅定及次第定。是名不生。不味禅乐。是名一切而得自在。若勤精进求般若慧学问无厌。是名不生。不共痴住。是名一切而得自在。不嗔恼诤是名不生。不共嗔恼诸诤讼住。是名一切而得自在。若如实语是名不生。若如实住名得自在。若内寂静是名不生。若不污染外诸境界。名得自在。若能究竟。一切智心。是名不生。不求下乘名得自在。觉诸业果是名不生。降伏魔业名得自在。得世光明是名不生。世法不污名得自在。不逆所住是名不生。不堕所作名得自在。若离诸慢放逸势力。是名不生。若智慧识成就圣乐。名得自在。不退所誓是名不生。所誓出世名得自在。顺行缘生是名不生。不执缘生法名得自在。若以尽智观一切空。是名不生。具诸善根名得自在。若方便智发起所作。生大悲心修勤进行。是名不生。若能安住诸解脱法。名得自在。若不污染于一切法。名为不生。若断诸见而为说法。名得自在。若善思惟不见诸法。是名不生。得力不证一切诸法。名得自在。若观一切诸法性空。是名不生。若不放舍一切众生。名得自在。若不住三界。是名不生。为众生故不入涅槃。名得自在。复次天子。若有言语。是动摇语。是妄想语。是执着语。是有发起。天子。于一切法无有言语。不行不动无诸戏论语。不舍众生亦不灭度无所言说。天子。若无言说亦无文字则无所说。若有用者则有发起言说文字。天子。以是义故。菩萨之行。不可说用不可行念。是名慈心。是名不杀。于诸圣中得名自在。说是法已。世尊赞言。善哉善哉。文殊师利。善为诸菩萨说不生自在。文殊师利。若菩萨行如是法自在无碍。是菩萨疾得诸佛授无上道。闻此法时。于是众中。有五百菩萨得无生法忍。尔时世尊。即与无上正真道记。各各佛土各各名字某甲如来。尔时众中有于天子。如是思念。是宝上天子。当于几时成无上道。佛名何等。佛土云何。以佛力故。尔时大德阿难白佛言。世尊。是宝上菩萨当于几时得成无上正真之道。佛土云何。得成道已其佛何名。佛告阿难。是宝上天子于百千劫。当成无上正真之道。号宝庄严如来。于此东方。其佛国土名宝庄严。劫名宝来。阿难。是宝庄严佛土丰乐甚可欣乐。饶诸财宝多诸人民。无有诸难亦无恶道。阿难。是佛土中。无诸瓦石沙土荆棘山谷堆阜。地平如掌三宝所成。阎浮檀金琉璃颇梨。互相间错甚可爱乐。以金网覆上。阿难。如化乐天宫殿园池衣服丰饶。行来往返。是宝庄严佛土人民亦复如是。土无声闻缘觉乘名。唯有菩萨。受种种法乐。入种种禅定庄严。作于种种神通。以自娱乐无有余乐。唯除法喜悦预之乐。是故世界名宝庄严。彼佛寿命六十六亿岁。出家菩萨僧六十六亿。在家菩萨无量无边。是庄严如来。为诸菩萨演说法时。上升虚空高八十亿多罗之树。结加趺坐满千国土。出千光明照彼佛土。雨于天花天香末香。天乐各各有百千种。说法音声普闻佛土。说无尽主陀罗尼法。何谓无尽主陀罗尼法。一切诸法寂静主故。显示身心寂静之想。一切诸法观照主故。显示分别于一切法。一切诸法善思惟主故。显示一切诸法寂静。一切诸法善行主故。显示一切可作之法光明照曜。一切诸法智光明照平等主故。显示诸法无有增减。一切诸法决定主故。显示一切诸法增长。一切诸法智慧主故。显示一切法无诤讼。一切诸法善观主故。显示一切诸法无嗔。一切诸法正念主故。显示一切法不失念。一切诸法导引主故。显示一切诸法相义。一切诸法慧分别主故。显示一切法清净意。一切诸法空寂主故。显示诸法断诸见道。一切诸法无相主故。显示一切诸法寂静。一切诸法无愿主故。显示诸法断于诸道。一切诸法无作主故。显示诸法离于作者。一切诸法无出主故。显示一切诸法无出。一切诸法无生主故。显示一切诸法无尽。一切诸法离欲主故。显示一切诸法无错。一切诸法无二主故。显示一切法现在智。一切诸法无二主故。显示一切诸法离二。一切诸法无依主故。显示一切诸法不动。一切诸法无众生主故。显示诸法众生平等。一切诸法寂静主故。显示一切诸法不变。一切诸法不得主故。显示一切诸法无行。一切诸法无居主故。显示一切诸法离处。一切诸法无定主故。显示一切无法自在。一切诸法因缘生故。显示一切诸法出过。一切诸法勇猛主故。显示一切诸法不出。一切诸法无过主故。显示一切诸法无起。一切诸法如主故。显示一切法无不如。一切诸法如始宝主故。显示一切诸法无坏。一切诸法法性主故。显示一切诸法一味。一切诸法如实主故。显示诸法三世平等。一切诸法不可说主故。显示不执一切诸法言语谈论。一切诸法禅定主故。显示一切诸法寂静。一切诸法法性主故。显示一切诸法无人。一切诸法菩提主故。显示一切诸法平等。一切诸法愿主故。阿难。宝庄严如来坐空未起。此无尽主陀罗尼。陀罗尼主。为诸菩萨广演说之。彼土无量阿僧祇菩萨摩诃萨皆得法忍。尔时大德阿难白佛言。世尊。未曾有也。若诸如来自然无作。过去未来现在法中得无碍智。佛言阿难。我今为汝说诸如来自然无作。过去未来现在法中得无碍智。尔时大德阿难语宝上天子言。天子。汝得大利。如来说汝无上道记。天子言。大德阿难。都无有法不说受记。何以故。色非菩萨。非说色记。受想行识非菩萨。非说识记。地界非菩萨。非说地界记。水火风界亦非菩萨。非说风界记。眼非菩萨。非说眼记。耳鼻舌身意非菩萨。非说意记。名色非菩萨。非说名色记。过去未来现在非菩萨。非说三世平等之记。因见非菩萨。非说因见记。生灭非菩萨。非说生灭记。大德阿难。菩萨名者即是假名。是寂静句。若法究竟是寂静者。无有受记。大德阿难。夫受记者摄取一切言所说法。大德阿难。亦无有法菩萨可执。若内若外。若善若不善。若有为无为。然后受记。大德阿难。菩萨记者一切诸法无有所属。名为受记。一切法不取。是名受记。一切法无处是名受记。一切法无居是名受记。一切法无出是名受记。一切诸法无有妄想。是名受记。大德阿难。夫菩萨者如是受记。尔时世尊赞宝上天子言。善哉善哉。天子。菩萨通达是诸法故。则能如是说于受记。如诸佛世尊说于无上菩提道记。说是法时。魔王波旬与诸眷属。各有所乘来至佛所。到已却住一面。说如是言。世尊。何因缘故说菩萨记。不说声闻。波旬问已。佛即答言。波旬。是菩萨者三千大千世界国土。所有人天悉善知之。以是因缘故说菩萨记。声闻者非人天所识。是故不记说菩萨记。多诸众生发菩提心。以是缘故说菩萨记。说声闻记者菩萨退转。是故不说。尔时文殊师利童子语波旬言。汝今何故来至此众。波旬答言。文殊师利。以佛世尊为宝上天子说无上道记。汝当作佛。号宝庄严如来应供正遍知。不说记声闻。我宫殿楼观栏楯宝树。园林娱乐处。互相枨触出如是音云。释迦如来应供正遍知。为宝上天子说无上道记。又闻是音。波旬。汝今往至众所。勿令更受记菩萨来生汝宫。文殊师利语波旬言。说菩萨记。汝今不喜也。魔言。文殊师利。我实不喜。为阎浮提一切众生。说罗汉记。我无愁恼。说一菩萨无上道记。我之愁恼不可言也。何以故。文殊师利。若说菩萨无上道记。我诸魔宫闇蔽不明。而是菩萨以三乘法。拔济无量阿僧祇诸众生等出于三界。文殊师利。我以是事受诸忧恼。文殊师利言。波旬。汝还所止。汝无力势能留难遮。毕竟向于菩提之道。成就方便具足般若波罗蜜行者。何以故。是诸菩萨离诸魔缚。成毕竟行善知方便。行般若波罗蜜。时佛神力令魔波旬问文殊师利。云何菩萨修毕竟行善知方便行般若波罗蜜。文殊师利答言。波旬。若有菩萨离于一切诸少分行。是名菩萨成毕竟行。若见一切结使魔业。悉能利益于无上道。是名菩萨善知方便。不共一切诸结使行。是名菩萨行般若波罗蜜。复次波旬。若菩萨心毕竟拔济诸众生故。以大庄严而自庄严。是名菩萨毕竟心行。若以四摄摄诸众生。是名菩萨善知方便。若毕竟观一切众生体性寂灭。是名菩萨行般若波罗蜜。复次波旬。若有菩萨舍于内外一切能施。菩提之心毕竟究竟。是名菩萨毕竟心行。菩萨若为一切众生起受者心。是名菩萨善知方便。若有菩萨乞者受者。知如实始行平等行。是名菩萨行般若波罗蜜。复次波旬。若有菩萨于诸善法。从初发心终不退转。是名菩萨毕竟行于菩提之心。若有菩萨不为他逼能舍自利。是名菩萨善知方便。菩萨念义不念文字。是名菩萨行般若波罗蜜。复次波旬。若见乞者不背舍之。是名菩萨毕竟心行。若有菩萨集诸善根愿求一切智。是名菩萨善知方便。菩萨善知诸法体性。是名菩萨行般若波罗蜜。尔时宝上天子语文殊师利言。是魔波旬眷属及乘可以神力。内之腹中。或能令诸善男子善女人向大乘者。为作留难。文殊师利言。天子。不如汝言。内魔波旬置菩萨腹。复次天子。汝所受持佛相庄严第一受乐。令魔波旬坐师子座。以佛力故佛辩说法。尔时波旬闻是语已。欲隐身出众而不能隐。文殊师利之所持故。尔时文殊师利作是念已。魔王波旬作佛身相。坐师子座。是时一切大众见知是魔波旬。文殊师利复言。波旬。汝今得诸如来道耶。成佛色身坐师子座。以文殊师利力所持故。魔波旬言。文殊师利。世尊尚不得于菩提。况我得也。所以者何。菩提者是报恩相。非离欲得。非解向得。又菩提者得无为相。彼得无为相故。觉知空相是名菩提。非空觉知空故。觉知无相相是名菩提。非以无相觉知无相相故。觉知无愿相。是名菩提。非无愿相觉知无愿相故。觉知法界之体性者。是名菩提。非以体性觉知体性故。觉知于如无分别相。是名菩提。非如觉知如故。觉知住于如实始故。是名菩提。非住如实始觉知住于如实始故。觉无我无有众生无命无人丈夫体性。是名菩提。无觉知者故。文殊师利。若有菩萨闻说如是菩提之相。闻已能于诸法体性无所分别。即名为佛。魔以佛辩说是法时。五百菩萨得无生法忍。尔时大德舍利弗。语文殊师利言。未曾有也。汝力持故。令魔波旬作如来身身相具足坐师子座。说是深法。文殊师利言。大德舍利弗。一切草木树林无心。可作如来身相具足悉能说法。我亦能令大德舍利弗作如来身。身相具足以佛辩说法。尔时大德舍利弗即作是念。我今可于此众中没。文殊师利或能使我作如来身身相具足。戏弄于我。令声闻人作世尊相。文殊师利神力持故而不能隐。时文殊师利知大德舍利弗心所念。变大德舍利弗。为如来身。身相具足坐师子座。一切众会亦悉见知。尔时文殊师利童子语大德舍利弗。汝可与魔波旬共说。犹如如来共如来说。尔时大德舍利弗。如是问言。波旬。夫菩提者何等体性。波旬答言。觉知一切诸法平等。是菩提体性。觉知二法是菩提体性。一切智观是菩提体性。非不体性。非行非不行。永断一切诸行非行非道非不道。是名诸佛世尊菩提。波旬问言。大德舍利弗。诸佛如来住于何处。舍利弗言。住生死中平等。住涅槃不动。住一切诸见如实之性。住于一切众生结使。亦住一切诸法根本。住于有为无为二法。诸住不住无有住故。波旬。诸佛如来如是住也。时舍利弗问波旬言。菩提者当何处求。波旬答言。大德舍利弗。从身见根本。求于菩提。无明有爱求于菩提。颠倒起结求于菩提。障碍覆盖求于菩提。舍利弗言。波旬。何因缘故如是说也。波旬答言。大德舍利弗。如实觉知如是诸法。是名菩提。说是法时。八百比丘。悉断诸漏得无漏心。诸天子等信舍利弗魔波旬故。三万二千诸天子等。发阿耨多罗三藐三菩提心。为欲调伏诸天子故。文殊师利童子令魔波旬及大德舍利弗。作如来身身相具足。文殊师利还摄神力。大德舍利弗及魔波旬。身复本相。尔时四方出千菩萨。从诸佛土乘空而来。至于佛所顶礼佛足。右绕如来住一面已。白佛言世尊。我等闻说法界体性无分别经。闻已来此守护正法。世尊。我等受持守护此经。读诵通利为他广说。摄取正法。尔时大德阿难白佛言。世尊。是诸菩萨从何处来。佛告阿难。是诸菩萨各各集在诸佛国土。此等菩萨皆是文殊师利童子本所教化。常为说此法界体性无分别经。以开化之。是诸菩萨知报经恩故来至此。及见如来礼敬围绕。亦欲供养礼拜文殊师利童子。又愿护此经是故来此。阿难。我涅槃后。是诸菩萨于此阎浮提。当广流布护此正法。阿难。是诸菩萨于百千佛所。志意勇猛护持正法。是时众中有释梵护世诸天王等。白言世尊。我等若此若彼有护持法者。是善丈夫善男子女人等。我当守护供给。使令得无苦恼。尔时世尊。赞释梵护世诸天王言。善哉善哉。汝能勇猛守护是诸爱护正法善丈夫等。即是供养过去未来现在诸佛并爱护正法。尔时佛即告于文殊师利童子。汝受持此经后末世时。于阎浮提当广流布。文殊师利言。世尊。火灾起时而此虚空。都无受持亦不被烧。世尊如虚空体性。是一切法亦复如是。而是诸法不生不灭。若法无生无有灭者。亦无受持诸法体性。无受持故如法体性。受持诸法亦复如是。文殊师利即白佛言。唯愿世尊。受持此经。为善男子善女人等。种善根故。若供养法者贪乐此经。世尊。如是如是受持此经。调伏憍慢诸怨憎故。无能留难。于当来世此阎浮提广行流布。尔时世尊身放光明。是光遍照三千大千佛之世界。皆作金色。尔时佛告文殊师利童子。如来光明一切普照。而此经者亦复如是。心行无碍者于佛法究竟。是善男子善女人等手执此经。尔时世尊复告阿难。阿难。受持此经读诵通利为他广说。阿难。汝则供养去来现在诸佛世尊。尔时阿难白佛言。世尊。此经何名。云何受持。佛告阿难。汝受持此经。名说法界体性无分别。亦名宝上天子所问。亦名文殊师利童子所说。善受持之。佛说是经已。大德阿难。文殊师利童子。宝上天子。及诸佛土诸来菩萨。天人阿须罗。及世间人。皆大欢喜顶戴奉行

大宝积经卷第二十七大宝积经卷第二十八

        元魏三藏法师佛陀扇多译

    大乘十法会第九

如是我闻。一时婆伽婆。住王舍大城耆阇崛山中。与大比丘众五百大阿罗汉俱。菩萨摩诃萨无量无边。尔时会中。有一菩萨摩诃萨。名净无垢宝月王光。即从坐起整服右肩。右膝胡跪莲花台上。至如来所合掌向佛。白言世尊。行大乘住大乘比丘。云何行大乘。云何住大乘。世尊。以何义故。此大乘名为大乘。复以何义名为住大乘。尔时世尊告净无垢宝月王光菩萨摩诃萨言。善哉善哉。净无垢宝月王光。善男子。汝善能问此甚深义。谛听谛听善思念之。我今为汝分别解说。时净无垢宝月王光菩萨摩诃萨。闻佛听许即白佛言。唯然世尊。顶受圣教。佛言。善男子。菩萨摩诃萨成就十法。是行大乘是住大乘。何等为十。一者信成就。二者行成就。三者性成就。四者乐菩提心。五者乐法。六者观正法行。七者行法慎法。八者舍慢大慢。九者善解如来秘密之教。十者心不悕求声闻缘觉乘。时净无垢宝月王光菩萨摩诃萨白佛言。世尊。云何菩萨摩诃萨信成就。佛言。善男子。菩萨摩诃萨行不谄行。得柔软行。彼菩萨信诸如来正真正觉无上菩提。信诸如来于一念中说三世事。信如来藏不老不死无量无边不生不灭不常不断。信诸佛实际法界一切智一切智人所知力无所畏。不共佛法信诸如来无见顶相。信诸如来三十二相八十种好庄严其身身有圆光。信声闻所说缘觉所说菩萨所说。及信所有善言说者。信此世过世。信正行者住正行者若有沙门若婆罗门。信善业果甚可爱乐微妙最胜。所谓若天天主若人人主。信不善果不可爱乐苦恼无量。或在地狱或在饿鬼或在畜生。彼菩萨如是信已得离三法。一疑二惑三不决定。善男子。菩萨摩诃萨。成就如是信。名为信成就。尔时世尊。为显此义。偈重说言

  信为增上乘　　信者是佛子
  是故有智者　　应常亲近信
  信是世间最　　信者无穷乏
  是故有智者　　应常亲近信
  若不信之人　　不生诸白法
  犹如烧种子　　不生根牙等

善男子。云何菩萨摩诃萨行成就。善男子。菩萨摩诃萨行成就故。剃除须发被正法服。舍家出家。既出家已。修学菩萨戒行等事。修学声闻戒行等事。修学缘觉戒行等事。修菩萨如是学已。身口意等恶业悉灭。何者名为身不善业。所谓杀生偷盗邪淫。瓦石刀杖欺掷他人。伤手足等。若来若去行欺凌事。善男子。如是等名身不善业。善男子。何者名为口不善业。所谓妄言绮语。两舌恶口。不善言说。诽谤正法甚深经典。说诸和上阿阇梨等住正法者所有过短。如是等名口不善业。善男子。何者名为意不善业。所谓姤吝邪见。增上妒吝。乐利乐称。乐亲爱等。家慢色慢。恃少壮慢。恃无病慢。恃寿命慢。恃多闻慢。恃修行慢。欲觉害觉嗔恼觉等。及国土觉。衣服等觉。着处着乘着敷具等。着饮着食及着儿女。犁牛耕种诸所作等。忧奴忧婢忧诸作者。谷帛库藏诸财物等。彼菩萨如是着已。于向所说种种事中。若失一事。其心则生忧悲苦恼。彼菩萨以爱润心。是故生于后有牙心。善男子。略说意业犹如轮转。如是名为意不善业。彼菩萨离身等业。于和上所起于尊想。于阿阇梨起和上想。于余若老若少起止恭敬。彼菩萨在于独处作是思惟。我不应尔。我已起度一切众生。救一切众生。心令一切众生住正定行中。彼菩萨作是思惟。我今自身不调诸根。不勤修行。不覆诸根。不调诸根。彼菩萨作是思惟。今我已作如是修行。是诸众生既见我已。心即调伏随顺我教。诸佛欢喜及诸天龙乾闼婆等悉皆欢喜。善男子。如是等行名菩萨惭。彼菩萨作是思惟。勿令若道若俗。于我若身若口若意等业诸威仪中。诃责我者。所谓毁坏戒行。或作见行。或作行行。或行邪命。彼行菩萨如是惭已。日夜系心观察戒行。观戒行已。无诸忧悔离诸障碍。菩萨如是正修行已。于诸如来正法之中而修诸行。善男子。如是等行名菩萨愧。善男子。菩萨摩诃萨成就如是行。名为行成就。尔时世尊为显此义。偈重说言

  行为增上乘　　诸佛缘觉等
  是故智者修　　彼等微妙事
  菩萨大名称　　无畏行成就
  是故证菩提　　诸佛本所说

善男子。云何菩萨摩诃萨性成就。善男子。菩萨摩诃萨性自少欲少嗔少痴。不吝不涩不粗犷。不我慢不卒暴。调和柔软善言软语。易共同止。彼菩萨于一切上胜供养。如心行施。所有诸事衣服饮食分舍与他。如是施已。即生欢喜遍满身心。如是乃至舍上身分。善男子。彼菩萨行如是行。若见如来。若见声闻。见已即生欢喜之心。善男子。菩萨摩诃萨成就如是法。名为性成就。尔时世尊。为显此义。偈重说言

  相烟即知火　　见鸳鸯知水
  异相知菩萨　　菩萨大智慧
  不涩不恼众　　舍诸谄曲行
  善信众生故　　是名菩萨性

善男子。云何菩萨摩诃萨乐菩提心。善男子。菩萨摩诃萨。以有菩提相故发菩提心。未发菩提心时。或诸如来或诸声闻劝发菩提心。善男子。此是菩萨初发菩提心相。善男子。彼菩萨闻有菩提。闻菩提心有大功德。闻发阿耨多罗三藐三菩提心。此是菩萨第二发菩提心相。善男子。彼菩萨见诸众生。无主无亲。无救无护。无能度之令至彼岸。菩萨即为彼诸众生。起慈悲心而作是言。我当于彼无主无亲无救无护诸众生等而作救护。为彼因缘故。发阿耨多罗三藐三菩提心。此是菩萨第三发菩提心相。善男子。彼菩萨以见如来相具足身。生欢喜心。生勇悦心。心生欢喜。以是因缘故发阿耨多罗三藐三菩提心。此是菩萨第四发菩提心相。善男子。彼菩萨为彼众生令得利益安隐乐故。修行布施持戒忍辱修行精进禅定般若。善男子。云何菩萨修行布施。善男子。菩萨作是思惟。我当云何行于布施。即生念言须食施食。须饮施饮。须床敷者施与床敷。须衣服者施与衣服。指环臂钏若宝冠等。所须之物皆施与之。善男子。菩萨乃至割自身肉施于众生。如是行施愿取阿耨多罗三藐三菩提。而不取着受者财物。不住事等。是名菩萨修行布施。善男子。菩萨云何修持于戒。善男子。彼菩萨先自调顺身业。调顺口业。调顺意业。菩萨所有自身恶业一切舍离。所有口恶业一切舍离。所有意恶业一切舍离。持戒不缺不漏不杂。菩萨如是持禁戒已。回向阿耨多罗三藐三菩提。而心终不取着于戒。是名菩萨修持于戒。善男子。云何菩萨修行忍辱。善男子。菩萨为闻若道若俗。乃至毁骂。闻说其恶。若打系闭。若截手足。皆能忍受。为彼前人起忍辱心。菩萨如是修行忍已。回向阿耨多罗三藐三菩提。不以彼忍而起慢心。是名菩萨修行忍辱。善男子。菩萨云何修行精进。善男子。菩萨作是思惟。如虚空界无量无边。众生界亦无量无边。唯我一人独无等侣。令入无余涅槃界中。如是菩萨为彼因缘发精进行。初持自身。持身行已观受心法。如是正观受心法已。行持心行。菩萨既行持心行已。次复修行见法等行。菩萨如是持心意已。为令未生恶不善法断不生故起欲勤精进。为令未生善法生故起欲勤精进。菩萨如是次复修行初如意足。如是修行第二第三乃至第四如意足分。修如是行不起慢心。是名菩萨修行精进。善男子。菩萨云何修行禅定。善男子。菩萨不着欲故。不着灭故。不着离欲故。不着自身故。不着他身故。不着色受想行识。不着欲界。不着色界。不着空。不着无相无愿。不着此世界。不着未来世界。而行布施。不依止施。不依止戒。不依止忍。不依止精进。不依止禅。如是修行禅定。回向阿耨多罗三藐三菩提。而不分别。是名菩萨修行禅定。善男子。菩萨云何修行般若。善男子。菩萨常作如是思惟而化众生。化众生已复作是念。我化无量无边众生界。令入无余涅槃界中。而无一众生入涅槃界者。何以故。如佛所说。一切诸法。无我无众生无命无养育无富伽罗。如是修慧而以彼慧。回向阿耨多罗三藐三菩提。作如是愿。而于智慧不生分别。是名菩萨修行般若。善男子。菩萨摩诃萨如是发菩提心。名为菩萨乐菩提心。尔时世尊。为显此义。偈重说言

  犹如真宝珠　　光明不舍离
  又如矿中金　　治已转增明
  如是菩提性　　转明菩提心
  二边清净已　　魔所不得便

善男子。云何菩萨摩诃萨乐法。善男子。菩萨摩诃萨。性自乐法喜法润法。若见沙门若婆罗门如法人已。随所有物而以奉上。若饮食等一切施与。乃至合掌生恭敬心。生恭敬已。从彼闻于未曾闻法。菩萨如是求正法已如实修行。菩萨于彼持法法器。生于尊想。生和上想阿阇梨想。起如是意。我从昔来久失导师。今忽遇之生导师想。又作是念。我常缚在世间牢狱。无解无救无推访者。今忽遇之生推觅想。又作是念我久远来睡于世间。愚痴盲目。忽于今者令我目开。即起觉想起开示想。又作是念。我久远来没深泥中无拔济者。今忽遇之生拔济想。又作是念。我久远来失于导师引导众生。今忽遇之起导师想。又作是念。我久远来闭在世间。贫苦难处无救接者。今忽遇之是故即生救接者想。又作是念。我久远来遇难愈病。无有良医能疗治者。今忽遇之起良医想。又作是念。我久远来为贪欲火之所烧然。未蒙云雨。今忽遇之。是故即起大云雨想。菩萨如是为彼因缘。忍寒热等诸苦恼事。及诸众生能恼人者。若蚊虻等皆能忍之。亦能忍受饥渴等事。见乐众生不生着心。彼菩萨作如是念。我虽得受世间快乐。若我得闻一句法已。能成闻慧。生闻慧想。菩萨以是乐法因缘故。行布施不生忧愁。乃至无有忧苦等事。菩萨如是远离一切忧苦等事。起如是心。我为得闻如来所说一句法故。乃至入于阿鼻地狱。寿命一劫。若百千劫无疲倦。无疲倦已。然修行一切种智。若有未得佛正法者。能令得之。善男子。菩萨摩诃萨。如是乐法名为菩萨乐法。尔时世尊。为显此义。偈重说言

  大智求法者　　所谓诸菩萨
  求法无厌足　　以恭敬心故
  当求于正法　　是名菩萨相
  闻已常忆持　　复如法修行

善男子。云何菩萨摩诃萨观正法行。善男子。菩萨摩诃萨作如是观。一切法如幻诳凡夫故。愚痴覆心无正慧故。一切法虚妄如梦。以唯念故。一切法如水中月。非有事故。一切法如镜中像。无众生故。一切法如响。空声生故。一切法生灭。因缘成故。一切法不生。真如性故。一切法不灭。以无生故。一切法无作。以无作者故。一切法如虚空。以无染故。一切法寂静。体性无染故。一切法离垢。离一切垢故。一切法永灭。以本灭烦恼故。一切法无色。不可见故。一切法离心意意识。以无身故。一切法无住灭。一切阿梨耶故。一切法无求。离此彼亲爱故。一切法无著。离一切烦恼境界故。一切法如蛇。以无方便咒术力故。一切法如芭蕉。以不实故。一切法如水沫。性无力故。善男子。菩萨摩诃萨如是观正法行。名为菩萨观正法行。尔时世尊。为显此义。偈重说言

  一切法如幻　　覆众生心故
  虚妄犹如梦　　应如是受持
  诸法如水月　　以影像起故
  诸法如镜像　　智何不觉知

善男子。云何菩萨摩诃萨观法顺法。善男子。菩萨摩诃萨观色无常。而不以灭色故证于法界。以如实智于法界中所有诸法。如实觉知诸法相已。善记善修彼法界中所有诸相。有所说者修者记者。自然如是入法界行。如是乃至受想行识。以如实观。正观察已。而不灭识。不厌离识。证入法界。所有法界一切诸法。以实智慧如实证知。彼诸法中有诸名字。善说善知善修善记。以善知故。以善修故。以善记故。自然如是入法界行。如知无常如是知苦无我不净亦复如是。观色无常如实善知。于彼色中。不复生于恐怖之想。何以故如实知色虚妄生故。如是菩萨如实善知受想行识悉皆无常皆苦无我及不净等。于彼识中不复生于恐怖之想。何以故。如实知识是虚妄故。菩萨如是如实善知。善男子。譬如善巧幻师幻师弟子。幻作种种四兵等事。所谓象兵马兵车兵步兵。智者见已不生恐怖。何以故。善知虚妄幻所作。诳惑众生而示现之。善男子。菩萨如是观色无常。观无常已于中不生恐怖之想。何以故。如实知色虚妄生故。菩萨如是如实善知。受想行识悉皆无常。观无常已则于识中不生恐怖。何以故。如实知识虚妄生故。菩萨如是如实善知。善男子。菩萨如是观法顺法。尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。云何菩萨观色无常。而不离色说于法界。证于法界习学法界。一切诸法以智慧力如实证知。尔时世尊告净无垢宝月王光菩萨摩诃萨言。善男子。为汝问故我今说喻。善男子。譬如世间有智之人持诸毒药。持毒药已。或煎或熬。或合余药。合余药已。为财利故。而炫卖之而不自食。何以故。彼人思惟勿令我身由此因缘。而致断命。善男子。菩萨摩诃萨心顺向涅槃。心润向涅槃。心润流涅槃。心正取涅槃。菩萨摩诃萨而不证涅槃。何以故。菩萨思惟勿令我身由此因缘退转菩提。复次善男子。我更说喻。善男子。譬如有人奉事于火。彼事火已。尊重敬顺善将护之。而不生于如是之心。我供养火。尊重赞叹善将护故。二手捉之。何以故。彼人作念。勿令我身由此因缘身苦心恼。善男子。菩萨摩诃萨虽心顺向涅槃。心润向涅槃。心润向涅槃流。心正取向涅槃。顺向涅槃岸。而彼菩萨不证涅槃。何以故。菩萨思惟。勿令我身以此因缘退菩提智。尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。如我解佛所说法义。菩萨应当常住世间。佛言善男子。如是如是。菩萨常应住于世间。时净无垢宝月王光菩萨摩诃萨白佛言。世尊。云何菩萨住于世间。而不为世间法之所染。佛言善男子。我今为汝以譬喻说。善男子。譬如有人。善解方便捉诸禽兽。以咒力故。共毒蛇戏捉诸毒蛇。若含若磨种种弄之。而终不以弄蛇因缘被害命终。何以故。以有善巧咒术力故。善男子。菩萨摩诃萨住于世间行世间法。以有善巧大智方便咒术力故。共诸烦恼恶毒药戏。弄烦恼蛇。而不为彼烦恼因缘退于菩提。何以故。菩萨成就善巧方便智慧力故。尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。甚奇世尊。奇哉善逝。最难有世尊。最难有善逝。世尊。是诸菩萨摩诃萨。虽心向涅槃而不证涅槃。虽在世间而不为世法之所染污。世尊。我今归依诸菩萨。世尊。若有善男子善女人得闻如此菩萨行已。生欢喜心者。彼人过去种诸善根。何以故。若闻此法门。乃至一弹指顷生希有心。世尊。彼诸善男子善女人。已为如来之所记也。何以故。闻此法门至心谛听故。佛言。善男子。如是如是。说此法门时。五百比丘得无漏心。得无漏心已从座而起。整服右肩。右膝着地合掌向佛。白言。世尊。世尊诸菩萨可以正恭敬善逝。可以礼敬诸菩萨。佛言诸比丘。如是如是。善男子。菩萨摩诃萨如是观法顺法。名为菩萨观法顺法。尔时世尊。为显此义。偈重说言

  应敬大智慧　　应敬大无畏
  应敬正服者　　应敬佛所生
  以方便力故　　智慧善巧故
  超过声闻地　　菩萨大智慧
  善知诸阴虚　　生灭不定故
  见世间火然　　是故不证灭

善男子。如是名为菩萨摩诃萨观法顺法。善男子。云何菩萨摩诃萨离慢大慢。善男子。所言慢者生如是心。我今所有若家若姓若色。及以种种金银珍宝。诸宝藏等。象兵马兵车兵步兵。不劣他人。若人如是起憍慢心。是名为慢。以其不生恭敬心故。善男子。何者大慢。善男子。若有菩萨作如是念。唯我若家若姓若色。若金银宝藏。象兵马兵车兵步兵。胜于他人。是故不生恭敬之心是名大慢。善男子。如是憍慢及以大慢。菩萨摩诃萨悉已舍离。善男子。菩萨摩诃萨。如是离慢离于大慢。尔时世尊。为显此义。偈重说言

  离慢离大慢　　常行慈悲心
  以彼润心故　　于世不放逸
  虽行乞食事　　诸菩萨大事
  说义利益事　　若诸天及人

善男子。云何菩萨摩诃萨。善解如来秘密之教。善男子。菩萨摩诃萨。于诸经中所有隐覆甚深密义。于彼说中如实善知。善男子。何等是为如来密教。善男子。我记声闻得阿耨多罗三藐三菩提者。此不应尔。如言阿难。我患背痛。此不应尔。语诸比丘我今老弊。汝可为我推觅侍者。此不应尔。语目连言。汝可往问耆婆医王。我所有患当服何药。此不应尔。善男子。如来处处逐诸外道论义捔胜。此不应尔。善男子。佉陀罗刺。刺如来足。此不应尔。善男子。如来又说提婆达多是我宿怨。常相随逐求觅我便。此不应尔。善男子。如来昔日入舍卫城。于奢犁耶婆罗门村。周遍乞食空钵而出。此不应尔。善男子。旃遮摩那毗孙陀梨。木器合腹以谤如来。亦不应尔。善男子。如来昔在毗兰多国。受毗兰若婆罗门请。三月安居而食麦者。此不应尔。尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。此向所说当云何取。世尊。何故记诸声闻。得阿耨多罗三藐三菩提。佛言。善男子。我记声闻。得阿耨多罗三藐三菩提者。以见声闻有佛性故。时净无垢宝月王光菩萨摩诃萨白佛言。世尊。此诸声闻断诸有漏离于三有。生分已断而有性。故为如来授阿耨多罗三藐三菩提记者。此事云何。佛言。善男子。我今为汝说于譬喻。善男子。譬如灌顶转轮圣王具足千子。随最大者授其王位。然彼轮王以子根钝。应初教者而中教之。应中教者而后教之。一切工巧咒术等事。然是王子以根钝故。应初学者而中学之。应中学者而后学之。善男子。于意云何。彼轮王子如是学已。岂可非是王正子耶。时净无垢宝月王光菩萨摩诃萨言。不也世尊。不尔善逝。是真王子。佛言。善男子。菩萨摩诃萨亦复如是。以根钝故。应初学者而中学之。应中学者而后学之。如是依观众生五阴。灭诸烦恼。烦恼灭已。然后得成阿耨多罗三藐三菩提。善男子。于意云何。彼诸声闻以此因缘得成正觉。岂可得言声闻不得成正觉耶。时净无垢宝月王光菩萨摩诃萨言。如是世尊。我曾不见若人若天若魔若梵。是等众中。而有能说声闻不得成正觉者。若有能说无有是处。除一阐提。尔时如来告净无垢宝月王光菩萨摩诃萨言。善男子。我今为汝更说譬喻。善男子。利根菩萨住第十地。除二无我坐道场者。为除故坐不除坐耶。时净无垢宝月王光菩萨摩诃萨言。世尊。已除故坐世尊。已除故坐善逝。佛言。善男子。彼利根者以此因缘。岂可不得成正觉耶。时净无垢宝月王光菩萨摩诃萨言。得成世尊得成善逝。尔时如来告净无垢宝月王光菩萨摩诃萨言。善男子。此处亦如是。尔时净无垢宝月王光菩萨摩诃萨言。世尊。如来何故昔告阿难我患背痛。佛言。善男子。我观后世怜愍众生作如是说。言我背痛。令诸病者作如是知。佛金刚身尚有背痛。何况我等及其余者。以是事故我说此言。而诸愚人如实取之。谓佛有病有背痛等。则便自坏亦令他坏

如来复告净无垢宝月王光菩萨摩诃萨言。善男子。我于昔日告比丘言。我今老弊。汝可为我推觅侍者。善男子。我说此言亦为怜愍念后世故。作如是说。为令后世声闻弟子。年老朽弊应须给侍。故说此言。我今老弊须觅侍者。令未来世如是知已不生退转。以是义故我说此言。我今老弊汝可为我推觅侍者。而诸愚人如实取之。如来老弊故须侍者

善男子。云何当知。佛告目连。令到耆婆大医王所。问服药法。善男子。此亦是我怜愍后世故作是说。有诸声闻假药将身。彼当忆我佛金刚身犹尚服药。何况我等及其余者。以是事故我说此言。汝到耆婆大医王所。问服药法。而诸愚人如实取之。谓如来身是病患身。善男子。如来昔告目连比丘。令彼目连问耆婆药。耆婆无容故不正答。唯作是言。但当服苏但当服苏。然是如来示业果报。令诸弟子闻当忆知而不退还

善男子。如来处处。逐诸外道尼干子等。捔胜论义。此事云何。善男子。我观后世愍念众生故作是事。令彼众生作如是知。诸佛如来正真正觉尚有怨家。何况我等及其余者。而诸愚人如实取之。谓佛如来实有怨家。善男子。转轮圣王以少福故尚无怨家。何故如来成就无量无边功德

善男子。佉陀罗刺。刺如来足。是事云何。善男子。如来示现业果报故。令未来世作如是知。如来成就无量功德而有业报。何况我等及其余者。以是因缘令彼息恶。复为因缘我作是说。有是业报。而诸愚人。如实取之。佉陀罗刺。刺如来足

时净无垢宝月王光菩萨摩诃萨言。世尊。提婆达多是佛宿怨觅如来便。佛言。善男子。若无提婆善知识者。终不得知如来具有无量功德。善男子。提婆达多是善知识。共我诤胜现作怨家。得显如来无量功德。善男子。提婆达多善友知识。在于宫内语阿阇世王。令害如来。时王故放护财象王令灭如来。善男子。如来见象即调伏之。尔时无量无边众生。见象调伏生奇特心。即生正信归依三宝。所谓佛宝法宝僧宝。显三宝故。善男子。如此之事应如是知。提婆达多是善知识。久来随逐示现怨家。而诸愚人如实取之。作如是言。提婆达多是害佛者是怨家者。善男子。乃至过去五百世中所生之处。提婆达多是善知识。示怨家事。悉是示现显诸菩萨。及显如来无量功德。而诸愚人如实取之。提婆达多是害佛者是怨家者。以是不善取义因缘。堕三涂中。所谓地狱饿鬼畜生诸苦恼处。何以故。善男子。提婆达多善知识者。善修无量诸胜功德。善修善根。亲近诸佛宿殖德本。心向大乘顺向大乘。向大乘彼岸。近于阿耨多罗三藐三菩提。善男子。彼坏心故于未来世。生于地狱饿鬼畜生诸恶道中

尔时净无垢宝月王光菩萨摩诃萨言。世尊。如来昔日入舍卫城。于奢犁耶婆罗门村。周遍乞食空钵而出。此事云何。善男子。我此所作。亦为愍念后世众生故示是事。令未来世作如是知。如来具足无量功德。尚空钵出。何况我等及其余者。善男子。复有说言。是魔波旬劝于婆罗门长者居士。令其不肯供养如来。此亦不尔。何以故。善男子。魔王无力能劝长者。令不供养如来食故。善男子。此事不应如是取之。何以故。魔王无力而能遮障如来供养。乃是如来劝持魔王。令语长者婆罗门等而不供养。善男子。如来已灭一切障碍。成就无量诸胜功德。而有能障如来供养。无有是处。如来无有实业果报。为彼众生令得道故。如来示现如是方便善巧诸事。善男子。如来若断一餐食已。令诸声闻及魔波旬天龙八部及诸天子。作如是念。无令眷属生忧苦心。为彼诸事。是故如来。日夜示现如是等事。令发一念不善之心。乃是如来断于诸有。如前示现后亦如是。令未来世作如是知。如来断有尚有此事。何况我等及其余者。现此事时七万天众。于如来所起清净心。如来尔时知其心已。种种说法。彼闻法已得法眼净。善男子。我观后世故示是事。如来无有如是业报

尔时净无垢宝月王光菩萨摩诃萨言。世尊。旃遮摩那毗孙陀梨。木器合腹以谤世尊。此事云何。佛言。善男子。此亦不尔。如来成就无量功德。无业报患。善男子。乃是如来威神之力。能令旃遮摩那毗孙陀梨等。置过无量恒河等世界之外。而被谤者。乃是如来以方便力示业果报。我诸弟子以薄福故。既得出家在我法中。以被谤故则退我法。以不思量如来言教作如是说。我等今者已被谤故。不应得在佛正法中。令彼诸人闻教忆念。诸佛如来具足成就一切白法。灭诸恶法尚有如是恶对被谤。何况我等及其余者。如是知已不复退还修净梵行。善男子。旃遮摩那毗孙陀梨等。起于恶心。以佛力故令梦开悟。我实谤佛。我若舍身必堕三恶。善男子。如来若知可防护者必防护之。是故示现如此之事。善男子。无一众生如来舍者故现此事

尔时净无垢宝月王光菩萨摩诃萨言。世尊。如来昔在毗兰多国。受毗兰若婆罗门请。而食麦者。此事云何。佛言。善男子。我亦愍念后世众生故现是事。如来实知诸婆罗门居士等请而不供养。而受其请彼处安居。何以故。善男子。彼安居处有五百马。所有食麦施与众僧。令至三月。善男子。彼马悉是大菩萨也。宿殖德本而值恶友。造诸恶业生畜生中。善男子。彼五百马有调马者。是日藏菩萨。以愿力故生在彼处。善男子。是日藏菩萨。劝五百马发菩提心。为令得脱故生彼处。善男子。以彼善调马主力故。彼五百马皆忆宿命。得菩提心还得本心。善男子。如来愍念彼五百马故。受彼请彼处安居。调马人麦与如来食。五百马麦诸弟子食。善男子。彼调马者以马音声调五百马。皆令忏悔劝其发心。复令彼马于佛法中。于三宝所起敬重心。善男子。过三月已。彼五百马舍身生于三十三天。彼在畜生尚得是利。如来尔时为彼说法。令得阿耨多罗三藐三菩提记。善男子。彼处所有调五百马。防护马者如来记彼。当得成就自调伏心缘觉之道。善男子。世间无有是可食物。如来食之而有不作微妙味者。善男子。假使如来食于土块瓦石等物。而无不退微妙味食。善男子。如来所食皆作上味。无有世间三千大千世界之中所食之物而可比者。何以故。以如来得味中上味。得食上味。得大丈夫诸相好等。善男子。汝今应当如是正取如来所食。悉微妙味无有可比。善男子。阿难比丘怜愍我故而作是言。云何。如来生转轮圣王家。舍王位出家而能食麦。如来善知阿难心已。故与一麦告言。阿难。汝当知之此是何味。阿难食已生奇特心。即语我言。世尊。我生在王家长养王家。而未曾得如是上味。善男子。阿难比丘以彼食味身心得安。七日不食。善男子。以是事故当知。如来无有业报。然彼居士婆罗门。请诸有德清净比丘。不供养者。诸比丘等受请往彼。而不供养示现业报。善男子。汝应当观如来神力。彼婆罗门请佛及僧而不供养。如来记彼不堕恶道。善男子。共佛受请彼处安居五百比丘。于中乃有四十比丘。多有贪心不能观察。不净行故。若得称意微妙食者。悉皆退转。食马麦故不生欲心。过七日已得阿罗汉果。善男子。如来善巧知众生心故。受彼请为度彼故。善男子。菩萨摩诃萨。善巧成就如是甚深秘密法教示现之事。若如是知名为善解如来密教。尔时世尊。为显此义。偈重说言

  善知渐法门　　及以顿所说
  内心善巧知　　诸菩萨示现
  善巧知秘密　　远离诸疑惑
  善知诸佛说　　所有秘密教

尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。云何菩萨摩诃萨不求声闻缘觉乘。佛言。善男子。菩萨摩诃萨在于地狱饿鬼畜生诸恶道中。虽在彼处受极重苦不可具说。而心不求声闻缘觉乘。亦无心求自得解脱。不念少欲。不念少作。不行少欲。不行少作事。善男子。菩萨于彼善业众生而与同事。然是菩萨于彼众生善劝化之。令其修行发阿耨多罗三藐三菩提心。善男子。菩萨摩诃萨成就如是法故。不求声闻缘觉菩提。尔时世尊。为显此义。偈重说言

  常化诸众生　　心不生疲惓
  于无上菩提　　坚固不退转
  其心不可动　　犹如妙山王
  修行慈悲心　　不求二乘道

尔时净无垢宝月王光菩萨摩诃萨白佛言。世尊。如来已说菩萨成就如是等法。是故名为行大乘。住大乘。而如来不说。以何义故此大乘名为大乘。尔时世尊。告净无垢宝月王光菩萨摩诃萨言。我今问汝。随汝意说。善男子。于意云何。转轮圣王所行之道。具四兵众所行处道。以何而说。时净无垢宝月王光菩萨摩诃萨言。世尊。是名王道。是名大道。是无畏道。是无碍道。是胜一切诸国王道。佛语净无垢宝月王光菩萨摩诃萨言。善男子。诸佛如来正真正觉所行之道。彼乘名为大乘。名为上乘。名为妙乘。名为胜乘。名无上乘。名无上上乘。名无等乘。名不恶乘。名为无等等乘。善男子。以是义故名为大乘。时净无垢宝月王光菩萨摩诃萨白佛言。善哉世尊。善哉善逝。善哉世尊。快说如是大乘名义

如来说是十法法门时。魔波旬作是念言。今日沙门瞿昙过我境界。若我具备四种兵众。恼彼瞿昙。令其不得说此法门。时魔波旬作是念已。即具四兵。至王舍城耆阇崛山。时净无垢宝月王光菩萨摩诃萨。遥见波旬具四兵众。为恼如来令不得说此法门故欲来至此。时净无垢宝月王光菩萨摩诃萨即现神通。现神通已。令魔波旬至王舍城四衢道头。唱如是言。汝王舍城诸人民等。当知今日沙门瞿昙。在王舍城耆阇崛山。为诸四众具说正法。初中后善文义俱深。淳备具足清净梵行。汝等诸人。可往诣彼沙门瞿昙听其说法。令汝长夜成大安乐诸利益事

尔时王舍大城之中。诸婆罗门。刹利长者。及居士等。被魔劝已。手执香花涂香末香烧香宝幢宝盖。出王舍城至耆阇崛山。到如来所。顶礼佛足。尊重赞叹却坐一面。时魔波旬亦具四兵。从王舍城出至耆阇崛山到如来所。化作曼陀罗华散如来已。与四兵众却坐一面。时净无垢宝月王光菩萨摩诃萨。知魔波旬坐一面已。即语魔言。汝魔波旬。以何因缘将四兵众。恼乱如来并障如来说此法门。汝今应当于如来所。生惭愧心起忏悔心。无令汝于长夜。得无利益成大苦报。时魔波旬闻净无垢宝月王光菩萨语已。即合十指爪掌拄地礼如来足。于如来所。生惭愧心起忏悔心。而作是言。我于今者甚畏如来。甚奇善逝。唯愿大慈受我忏悔。我甚愚痴无有智慧。无善巧智不自惜身。而于如来起于恶心。复欲令此法门绝灭。善哉世尊。重受我忏。佛言波卑椽。善哉善哉。长养善根。若我法中有善男子若善女人。起心忏悔以求清净。善哉波卑椽。时魔波旬。至佛所立白言。世尊。如来诸经皆断恶语不善语耶。如来答言。如是如是。魔波旬言。云何如来法王法主。得法自在而语。称我言波卑椽。如是唤我。佛言。波卑椽。我今为汝说于譬喻。善男子。譬如长者居士财富无穷。唯有一子甚爱念之。不用离目以命系子。然彼一子。诸根不调甚恶谄曲。长者居士爱念心故以杖打之。或瓦或石欲令此子息彼事故。善男子。于汝意云何。是长者居士挝打其子有恶心不。魔波旬言。不也世尊。欲令成就爱念子故。作如是事。佛言。波旬当知。如来正真正觉善知众生心性根欲。是故观察。应以恶言而得度者。即说恶言。应以默然无所言说而得度者。即为默然。应以驱遣而得度者。即驱遣之应以说法而得度者。即为说之。应以摄受而得度者。即摄受之。应见色身而得度者。即现色身令彼见之。应闻声香若得味触而得度者。即为现声而为说法。至香味触现令得度。时魔波旬欢喜踊跃。复合十指爪掌顶礼佛足。白言。世尊。随所有处。若村若城若在王都。说此法门。我为听受此法门故。当往其所护此法门。亦为护彼持法法器。世尊。我至彼时必有众相。诸众寂定离睡眠盖。复令诸方上胜法器而来问法。若读若诵若受持者。身心俱安不起慢心随说此法。若广说者。若略说者。于如来所生欢喜心。又复如来。于诸众生起欢喜心。彼诸众生心欢喜已。善根增长恶法消灭。时大众中有诸外道尼干子等。闻魔波旬如是忏悔。心大欢喜踊跃无量。得无生忍

尔时尊者阿难白佛言。世尊。以何因缘说此法时。此诸外道得无生忍。佛言。阿难。乃往。过去过无量劫。此王舍城耆阇崛山。尔时有佛。名上力足正真正觉。在此说法。佛说法已。有诸外道来向佛所。欲恼如来。复欲障说此法门故来至佛所。既闻法已心生欢喜。即言世尊。快说此法。于如来所生奇特心。以是因缘六十劫中。不堕地狱饿鬼畜生。唯生人天所生之处忆念彼佛。虽忆念佛而无善友。阿难。于意云何。彼诸外道尼干子等。岂异人乎。今此众中诸外道是。何以故。此诸善男子。当尔之时具足恶见故。欲恼如来并障此法。彼既闻法生大欢喜。以是因缘今蒙佛记。是诸外道当得阿耨多罗三藐三菩提。何况于今得无生忍

说此法门时。万二千众生远尘离垢得法眼净。二万众生发阿耨多罗三藐三菩提心。尔时尊者阿难白佛言。世尊。若有善男子若善女人。于此法门起一念信功德无量。况复读诵受持。拥护广为人说

佛言。阿难。若有善男子善女人。劝无余众生界。令发阿耨多罗三藐三菩提心。若复有善男子善女人。于此法门起一念信。若读若诵广为他说。此人得福过前说者。何以故。阿难。以此法门是一切智智道处。阿难。若有男子女人。闻此法门及见持此法门法师。若起恶心得罪过前

尔时净无垢宝月王光菩萨摩诃萨言。若有男子女人。谤此经者。如来已说得罪过前。佛告净无垢宝月王光菩萨摩诃萨言。若男子女人。一时挑却一切众生所有眼目。若复有男子女人。于此法门及持法者。起一恶心得罪过彼。何以故。阿难。以此法门名为光明。能施一切众生慧目

尊者阿难白佛言。世尊。此法门不应于不信男子女人前说。何以故。须护众生故。世尊。我见如是谤法业缘。生于地狱饿鬼畜生恶道中故

佛言阿难。应说此法门。不应不说。何以故。以此名为彼者因故。令修行已得阿耨多罗三藐三菩提故

阿难白佛言。世尊。当以何名名此法门。云何奉持。佛言。阿难。阿难当知。以说十法是故名为十法法门。如是受持。亦名净无垢宝月王光菩萨所问。如是受持

佛说此法门时。尊者阿难。净无垢宝月王光菩萨摩诃萨。并众会中诸大菩萨。及声闻众天龙八部。闻佛所说皆大欢喜。顶受奉行

大宝积经卷第二十八大宝积经卷第二十九

        大唐三藏菩提流志奉　诏译

    文殊师利普门会第十

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众八百人俱。菩萨摩诃萨四万二千。时有菩萨名无垢藏。与九万二千诸菩萨众。恭敬围绕从空而来。尔时世尊即告大众。彼诸菩萨。为遍清净行世界。普花如来。劝发来此娑婆世界。令于我所听受普入不思议法门。其诸菩萨亦当集会。说是语已。无量无边他方此界诸菩萨众。悉来集会耆阇崛山。顶礼佛足却住一面

尔时无垢藏菩萨。手持七宝千叶莲花。至如来所头面礼足。白佛言。世尊。遍清净行世界。普花如来。以是宝花奉上世尊。致问无量。少病少恼起居轻利安乐行不。作是语已。即升虚空结加趺坐

尔时文殊师利菩萨摩诃萨。于大众中即从座起。偏袒右肩右膝着地。合掌恭敬而白佛言。我念过去久远世时。曾于普灯佛所。闻说普入不思议法门。我于尔时。即便获得八千四百亿那由他三昧。又能了知七十七万亿那由他三昧。善哉世尊。愿垂哀愍为诸菩萨说此法门

尔时佛告文殊师利。汝今谛听善思念之。当为汝说。文殊师利言。唯然世尊。愿乐欲闻。佛言。若诸菩萨欲学此法。应当修习诸三昧门。所谓色相三昧。声相三昧。香相三昧。味相三昧。触相三昧。意界三昧。女相三昧。男相三昧。童男相三昧。童女相三昧。天相三昧。龙相三昧。夜叉相三昧。乾闼婆相三昧。阿修罗相三昧。迦楼罗相三昧。紧那罗相三昧。摩睺罗伽相三昧。地狱相三昧。畜生相三昧。阎魔罗界三昧。贪相三昧。嗔相三昧。痴相三昧。不善法三昧。善法三昧。有为三昧。无为三昧。文殊师利。若诸菩萨于如是等一切三昧。善通达者。是则已为修学此法。文殊师利。云何名为色相三昧。即说颂曰

  观色如聚沫　　中无有坚实
  不可执持故　　是名色三昧

复次文殊师利。云何名为声相三昧。即说颂曰

  观声如谷响　　其性不可得
  诸法亦如是　　无相无差别
  了知皆寂静　　是名声三昧

复次文殊师利。云何名为香相三昧。即说颂曰

  假令百千劫　　常嗅种种香
  如海纳众流　　而无有厌足
  其香若是实　　则应可满足
  但有假名字　　其实不可取
  以不可取故　　鼻亦无所有
  了知性空寂　　是名香三昧

复次文殊师利。云何名为味相三昧。即说颂曰

  舌根之所受　　碱醋等诸味
  皆从众缘生　　其性无所有
  若能如是知　　因缘和合起
  了此不思议　　是名味三昧

复次文殊师利。云何名为触相三昧。即说颂曰

  触但有名字　　其性不可得
  细滑等诸法　　皆是从缘生
  若能知触性　　因缘和合起
  毕竟无所有　　是名触三昧

复次文殊师利。云何名为意界三昧。即说颂曰

  设集三千界　　无量诸众生
  一心共思求　　意界不可得
  不在于内外　　亦不可聚集
  但以于假名　　说有种种相
  犹如于幻化　　无住无处所
  了知彼性空　　是名意三昧

复次文殊师利。云何名为女相三昧。即说颂曰

  四大假为女　　其中无所有
  凡夫迷惑心　　执取以为实
  女人如幻化　　愚者不能了
  妄见女相故　　生于染着心
  譬如幻化女　　而非实女人
  无智者迷惑　　便生于欲想
  如是了知已　　一切女无相
  此相皆寂静　　是名女三昧

复次文殊师利。云何名为男相三昧。即说颂曰

  自谓是男子　　见彼为女人
  由斯分别心　　而生于欲想
  欲心本无有　　心相不可得
  由妄分别故　　于身起男想
  是中实无男　　我说如阳焰
  知男相寂静　　是名男三昧

复次文殊师利。云何名为童男相三昧。即说颂曰

  如树无根枝　　花则不可得
  以花无有故　　其果亦不生
  由无彼女人　　童男亦非有
  随于分别者　　假说如是名
  了知彼女人　　及童男非有
  能如是观察　　是童男三昧

复次文殊师利。云何名为童女相三昧。即说颂曰

  如断多罗树　　毕竟不复生
  何有智慧人　　于中求果实
  若有能了知　　诸法无生者
  不应起分别　　童女为能生
  又如焦谷种　　其牙本不生
  女人亦复然　　是童女三昧

复次文殊师利。云何名为天相三昧。即说颂曰

  因清净信心　　及以众善业
  受诸天胜报　　端正殊妙身
  珍宝诸宫殿　　非由造作成
  曼陀罗妙花　　亦无种植者
  如是不思议　　皆因业力起
  能现种种相　　犹若净琉璃
  如是殊妙身　　及诸宫殿等
  皆从虚妄生　　是名天三昧

复次文殊师利。云何名为龙相三昧。即说颂曰

  受此诸龙身　　由不修于忍
  兴澍大云雨　　遍满阎浮提
  不从前后际　　亦不在中间
  而能生此水　　复归于大海
  如是诸龙等　　积习性差别
  起于种种业　　业亦无有生
  一切非真实　　愚者谓为有
  能如是了知　　是名龙三昧

复次文殊师利。云何名为夜叉相三昧。即说颂曰

  是大夜叉身　　从于自心起
  是中无有实　　妄生于恐怖
  亦无有怖心　　而生于怖畏
  观法非实故　　无相无所得
  空无寂静处　　现此夜叉相
  如是知虚妄　　是夜叉三昧

复次文殊师利。云何名为乾闼婆相三昧。即说颂曰

  彼实无所趣　　名言假施设
  了知趣非趣　　乾闼婆三昧

复次文殊师利。云何名为阿修罗相三昧。即说颂曰

  修罗相所印　　其相本无生
  无生故无灭　　阿修罗三昧

复次文殊师利。云何名为迦楼罗相三昧。即说颂曰

  无身以为身　　名字假施设
  名相无所有　　迦楼罗三昧

复次文殊师利。云何名为紧那罗相三昧。即说颂曰

  法无作而作　　说为紧那罗
  了知此不生　　紧那罗三昧

复次文殊师利。云何名为摩睺罗伽相三昧。即说颂曰

  彼由于名字　　随世而安立
  是中无有法　　而妄起分别
  了知此分别　　自性无所有
  彼相寂静故　　摩睺罗三昧

复次文殊师利。云何名为地狱相三昧。即说颂曰

  地狱空无相　　其性极清净
  是中无作者　　从自分别生
  我坐道场时　　了此无生相
  无相无生故　　其性如虚空
  此相皆寂静　　是地狱三昧

复次文殊师利。云何名为畜生相三昧。即说颂曰

  如云现众色　　是中无有实
  能令无智人　　于此生迷惑
  于彼畜生趣　　而受种种身
  犹如虚空云　　现于诸色像
  了知业如幻　　不生迷惑心
  彼相本寂静　　是畜生三昧

复次文殊师利。云何名为阎魔罗界三昧。即说颂曰

  造作纯黑业　　及以杂业者
  流转阎罗界　　受于种种苦
  实无阎罗界　　亦无流转者
  自性本无生　　诸苦犹如梦
  若能如是观　　阎罗界三昧

复次文殊师利。云何名为贪相三昧。即说颂曰

  贪从分别生　　分别亦非有
  无生亦无相　　住处不可得
  贪性如虚空　　亦无有建立
  凡夫妄分别　　由斯贪染生
  法性本无染　　清净如虚空
  十方遍推求　　其性不可得
  不了性空故　　见贪生怖畏
  无畏生畏想　　于何得安乐
  譬如愚痴人　　怖畏于虚空
  惊惧而驰走　　避空不欲见
  虚空遍一切　　于何而得离
  愚夫迷惑故　　颠倒分别生
  贪本无自性　　妄生厌离心
  如人欲避空　　终无能脱者
  诸法性自离　　犹如于涅槃
  三世一切佛　　了知贪性空
  住此境界中　　未曾有舍离
  于贪怖畏者　　思惟求解脱
  如是贪自性　　究竟常清净
  我证菩提时　　了达皆平等
  若执贪为有　　于彼当舍离
  由妄分别故　　而言舍离贪
  此唯分别心　　实无有舍离
  其性不可得　　亦无有灭坏
  平等实际中　　无解脱分别
  若于贪解脱　　于空亦解脱
  虚空及与贪　　无尽无差别
  若见差别者　　我说令舍离
  贪实无有生　　妄起生分别
  彼贪本性空　　但有假名字
  不应以此名　　而生于执着
  了贪无染故　　是则毕竟空
  不由灭坏贪　　而得于解脱
  贪法与佛法　　平等即涅槃
  智者应当知　　了贪寂静已
  入于寂静界　　是名贪三昧

复次文殊师利。云何名为嗔相三昧。即说颂曰

  以虚妄因缘　　而起于嗔恚
  无我执为我　　及由粗恶声
  起猛利嗔心　　犹如于恶毒
  音声及嗔恚　　究竟无所有
  如钻木出火　　要假众缘力
  若缘不和合　　火终不得生
  是不悦意声　　毕竟无所有
  知声性空故　　嗔亦不复生
  嗔不在于声　　亦不身中住
  因缘和合起　　离缘终不生
  如因乳等缘　　和合生酥酪
  嗔自性无起　　因于粗恶声
  愚者不能了　　热恼自烧然
  应当如是知　　究竟无所有
  嗔性本寂静　　但有于假名
  嗔恚即实际　　以依真如起
  了知如法界　　是名嗔三昧

复次文殊师利。云何名为痴相三昧。即说颂曰

  无明体性空　　本自无生起
  是中无少法　　而可说为痴
  凡夫于无痴　　而妄生痴想
  于无著生着　　犹若结虚空
  奇哉愚痴人　　不应作而作
  诸法皆非有　　杂染分别生
  如欲取虚空　　安置于一处
  设经千万劫　　终无有积聚
  愚夫从本来　　经不思议劫
  所起于痴结　　而无少分增
  如彼取虚空　　终无有增减
  多劫集于痴　　增减亦如是
  又如于槖籥　　受风无际限
  愚痴着欲乐　　无有厌足时
  是痴无所有　　无根无住处
  以根非有故　　亦无痴可尽
  以痴无尽故　　边际不可得
  是故诸众生　　我不能令尽
  设我一日中　　能度三千界
  所有诸众生　　皆令入涅槃
  复经不思议　　无量千万劫
  日日如是化　　众生界不尽
  痴界众生界　　是二俱无相
  彼皆如幻化　　故不能令尽
  痴性与佛性　　平等无差别
  若分别于佛　　彼则住愚痴
  痴及一切智　　性皆不可得
  然彼诸众生　　皆与痴平等
  众生不思议　　痴亦不思议
  以不思议故　　不应取分别
  如是思惟心　　思量不可得
  痴亦不可量　　以无边际故
  既无有边际　　从何而得生
  自性无生故　　相亦不可得
  了痴无有相　　观佛亦复然
  应当如是知　　一切法无二
  痴性本寂静　　但有于假名
  我证菩提时　　亦了痴平等
  能作如是观　　是名痴三昧

复次文殊师利。云何名为不善三昧。即说颂曰

  知彼贪嗔痴　　种种诸烦恼
  所有诸行相　　虚妄无真实
  能如是观察　　是不善三昧

复次文殊师利。云何名为善法三昧。即说颂曰

  汝等应当知　　诸善意乐者
  心行各差别　　皆同于一行
  以一出离相　　了知于一切
  皆悉寂静故　　是名善三昧

复次文殊师利。云何名有为三昧。即说颂曰

  汝等应当知　　一切有为法
  非是所造作　　亦无可称量
  我了知诸行　　性无有积集
  一切皆寂静　　名有为三昧

复次文殊师利。云何名无为三昧。即说颂曰

  无为性寂静　　于中无所著
  亦复无出离　　但有假名字
  为执着众生　　而说彼名字
  能如是了知　　名无为三昧

尔时世尊。说如是等不可思议微妙偈时。九万二千菩萨。得无生法忍。三万六千比丘。而于诸漏心得解脱。七十二万亿那由他诸天。及六千比丘尼。一百八十万优婆塞。二千二百优婆夷等。皆发阿耨多罗三藐三菩提心。尔时文殊师利菩萨复白佛言。唯愿世尊。为诸菩萨。演说种种三昧名字。令其闻者诸根通利。而于诸法得智慧明。不为一切邪见众生之所摧伏。亦令证得四无碍辩。于一文字而能了知种种文字。于诸文字了一文字。复以无边辩才。为诸众生善说法要。亦令证得甚深法忍于一刹那了一切行。是一切行。各各复有无边行相。皆能了知。佛言。文殊师利。有三昧名无边离垢。若菩萨得此三昧。能现一切诸清净色。复有三昧名可畏面。得此三昧。有大威光映蔽日月。复有三昧名出焰光。得此三昧。能蔽一切释梵威光。复有三昧名为出离。得此三昧。令诸众生出离一切贪恚愚痴。复有三昧名无碍光。得此三昧。则能照曜一切佛刹。复有三昧名无忘失。得此三昧。能持诸佛所说教法。亦能为他敷演斯义。复有三昧名曰雷音。得此三昧。善能显示一切言音上至梵世。复有三昧名为喜乐。得此三昧。令诸众生喜乐满足。复有三昧名喜无厌。得此三昧。其见闻者无有厌足。复有三昧名专一境难思功德。得此三昧。而能示现一切神变。复有三昧名解一切众生语言。得此三昧。善能宣说一切语言。于一字中说一切字。了一切字同于一字。复有三昧名超一切陀罗尼王。得此三昧能善了知诸陀罗尼。复有三昧名为一切辩才庄严。得此三昧善能分别一切文字种种言音。复有三昧。名为积集一切善法。得此三昧能令众生悉闻佛声法声僧声。声闻声缘觉声。菩萨声波罗蜜声。如是菩萨住三昧时。令诸众生闻声不绝。尔时文殊师利白佛言。唯愿世尊。加威护念。令我获得无碍辩才。说此法门殊胜功德。佛言。善哉随汝所愿。文殊师利复白佛言。若有菩萨。于此法门。受持读诵无疑惑者。当知是人于现身中。决定获得四种辩才。所谓捷疾辩才。广大辩才。甚深辩才。无尽辩才。于诸众生心常护念。随所修行欲毁坏者。皆能觉悟令无毁坏。尔时世尊赞文殊师利菩萨言。善哉善哉。汝于斯义能善分别。如布施者获大财富。持禁戒者决定生天。若能受持此经典者。现得辩才必无虚妄。如日光出能除诸暝。亦如菩萨坐菩提座。成等正觉决定无疑。受持读诵是经典者。现得辩才亦复如是。文殊师利。若复有人。于现身中欲求辩才。当于此经心生信乐。受持读诵广为人说勿生疑惑

尔时无垢藏菩萨白佛言。世尊。若诸菩萨佛涅槃后。于此法门心无疑惑。受持读诵为他广说。我当摄受加其辩才

尔时天魔波旬愁忧苦恼悲涕流泪。来诣佛所。而白佛言。如来昔证无上菩提。我于尔时已怀忧恼。复于今者说此法门。倍生大苦如中毒箭。若诸众生闻是经典。决定当于阿耨多罗三藐三菩提。无有退转入般涅槃。令我境界皆悉空虚。如来应正等觉能令一切诸苦众生。咸得安乐。愿垂哀愍与大慈悲。不于此经加威护念。令我安隐忧苦皆除

尔时世尊告波旬言。勿怀忧恼。我于此法不作加护。诸众生等亦不涅槃。天魔波旬闻是语已。欢喜踊跃忧恼悉除。即于佛前忽然不现。尔时文殊师利菩萨前白佛言。如来今者有何密意。告波旬言我于此法不作加护。佛言。文殊师利。以无加护加护此法。是故为彼说如是言。以一切法平等实际。皆归真如同于法界。离诸言说不二相故。无有加护。以我如是诚实之言无有虚妄。能令此经于阎浮提广行流布

尔时世尊。说是语已。告阿难言。此经名为普入不思议法门。若能受持如是经典。则为受持八万四千法门等无差别。何以故。我于此经善通达已。方能为彼诸众生等。演说八万四千法门。是故阿难。汝于此法当善护持。读诵流通无令忘失。佛说是经已。文殊师利菩萨。无垢藏菩萨。尊者阿难。及诸世间天人。阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第二十九大宝积经卷第三十

        大唐三藏菩提流志奉　诏译

    出现光明会第一十一之一

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众五百人俱。一切皆悉得大自在。复有八十那由他菩萨摩诃萨。皆是一生补处。弥勒菩萨而为上首。复有四十那由他诸大菩萨。文殊师利法王子等而为上首。尔时会中有一童子。名为月光。即从座起偏袒右肩。右膝着地顶礼佛足。合掌恭敬而白佛言。世尊。如来往昔修何等业。能得如是决定光明。摄取光明。发起光明。显现光明。种种色光明。无杂色光明。狭小光明。广大光明。清净光明。遍清净光明。无垢光明。极无垢光明。离垢光明。渐增长光明。鲜净光明。极鲜净光明。无边光明。极无边光明。无量光明。极无量光明。无数量光明。极无数量光明。速疾光明。极速疾光明。无住光明。无处光明。炽盛光明。照曜光明。爱乐光明。到彼岸光明。无能障光明。不动光明。正直光明。住无边处光明。色相光明。种种色相光明。无量色相光明。青黄赤白色相光明。红色相光明。颇梨色相光明。虚空色相光明。如是等种种光明。一一皆与五色光明和合显现。乃至青黄赤白等事。一一亦与无量无边种种色光和合显现。尔时世尊。即为月光而说偈言

  我以不思议　　善业因缘故
  远离诸迷惑　　成就种种光
  复以种种行　　安住于佛道
  以空无作慧　　而现和合光
  譬如外法中　　种种相差别
  于中空无我　　无作无心意
  又如内身中　　空无我无作
  于中能示现　　种种诸音声
  由如是无作　　现无边色光
  随其所意乐　　皆令得满足
  或于一光中　　出生二种色
  各有上中下　　差别而显现
  或于一光中　　出生三种色
  各有上中下　　差别而显现
  或于一光中　　出生四种色
  各有上中下　　差别而显现
  或于一光中　　出生五种色
  各有上中下　　从于净业生
  或于一光中　　出生六种色
  各有上中下　　从于方便生
  或于一光中　　出生七种色
  各有上中下　　从于善业生
  或于一光中　　出生八种色
  各有上中下　　从于胜善生
  或于一光中　　出生九种色
  各有上中下　　从于资粮生
  或于一光中　　出生十种色
  各有上中下　　从于布施生
  或于一事中　　出生二十色
  各有上中下　　从于持戒生
  或于一事中　　出生三十色
  各有上中下　　从于忍辱生
  或于一事中　　出生四十色
  各有上中下　　从于精进生
  或于一事中　　出生五十色
  各有上中下　　从于禅定生
  或于一事中　　出生六十色
  各有上中下　　从于智慧生
  或于一事中　　出生七十色
  各有上中下　　从于慈心生
  或于一事中　　出生八十色
  各有上中下　　从于悲心生
  或于一事中　　出生九十色
  各有上中下　　从于喜心生
  或于一事中　　出生百种色
  各有上中下　　从于舍心生
  或于一事中　　出生千种色
  各有上中下　　从千功德生
  或于一事中　　出生万种色
  各有上中下　　从福资粮生
  或于一事中　　现一俱胝色
  各有上中下　　从于净信生
  或于一事中　　现二俱胝色
  各有上中下　　从于随喜生
  或于一事中　　现三俱胝色
  各有上中下　　从于轻安生
  或于一事中　　现四俱胝色
  各有上中下　　从尊重佛生
  或于一事中　　现五俱胝色
  各有上中下　　从尊重法生
  或于一事中　　现六俱胝色
  各有上中下　　从尊重僧生
  或于一事中　　现七俱胝色
  各有上中下　　从尊重戒生
  或于一事中　　现八俱胝色
  各有上中下　　从尊重定生
  或于一事中　　现九俱胝色
  各有上中下　　从普怜愍生
  或于一事中　　现十俱胝色
  各有上中下　　从无放逸生
  又从一毛孔　　所现诸光明
  彼光种种名　　今当为汝说
  我有一光明　　名为云净照
  其光由积集　　无量善根生
  以于往昔时　　见有众生类
  种种多病恼　　皆生怜愍心
  给施诸医药　　令彼悉除愈
  以此因缘故　　得如是光明
  我复有光明　　名为眼清净
  以灯明施佛　　由是故得生
  我复有光明　　名为耳清净
  以音声供养　　由是故得生
  我复有光明　　名为鼻清净
  以香水供养　　由是故得生
  我复有光明　　名为舌清净
  以上味供养　　由是故得生
  我复有光明　　名为身清净
  以衣服供养　　由是故得生
  我复有光明　　名为心清净
  于佛常信乐　　由是故得生
  我复有光明　　名为色清净
  彩画于佛像　　由是故得生
  我复有光明　　名为声清净
  于法常称赞　　由是故得生
  我复有光明　　名为香清净
  于僧常恭敬　　由是故得生
  我复有光明　　名为味清净
  随意皆施与　　由是故得生
  我复有光明　　名为触清净
  以涂香供养　　由是故得生
  我复有光明　　名为法清净
  以摄受诸法　　由是故得生
  我复有光明　　名为地清净
  涂扫佛僧地　　由是故得生
  我复有光明　　名为水清净
  以井泉供养　　由是故得生
  我复有光明　　名为火清净
  持火而奉施　　由是故得生
  我复有光明　　名为风清净
  持扇而奉施　　由是故得生
  我复有光明　　名为蕴清净
  以身供养佛　　由是故得生
  我复有光明　　名为界清净
  常修于慈心　　由是故得生
  我复有光明　　名为谛清净
  常离于妄语　　由是故得生
  我复有光明　　名为刹清净
  常行于布施　　由是故得生
  我复有光明　　名为声清净
  以称叹诸佛　　由是故得生
  我复有光明　　名为念清净
  以称叹三昧　　由是故得生
  我复有光明　　名为辩清净
  以称叹总持　　由是故得生
  我复有光明　　名为日和合
  以和合乖诤　　由是故得生
  我复有光明　　名为显现义
  以通达空性　　由是故得生
  我复有光明　　名为青色相
  以青莲供养　　由是故得生
  我复有光明　　名为黄色相
  以薝卜供养　　由是故得生
  我复有光明　　名为赤色相
  以真珠供养　　由是故得生
  我复有光明　　名为白色相
  以金华供养　　由是故得生
  我复有光明　　名为胜功德
  以众彩严饰　　由是故得生
  我复有光明　　名为龙威力
  以龙幡供养　　由是故得生
  我复有光明　　名为象威力
  以象幡供养　　由是故得生
  我复有光明　　名为师子王
  师子幡供养　　由是故得生
  我复有光明　　名之为牛王
  牛王幡供养　　由是故得生
  我复有光明　　名为月清净
  洒扫于佛塔　　由是故得生
  我复有光明　　名为龙调伏
  以缯带奉施　　由是故得生
  我复有光明　　名夜叉调伏
  以能谛观察　　由是故得生
  我复有光明　　名为觉悟女
  以离于女相　　由是故得生
  我复有光明　　名为觉悟男
  以离于男相　　由是故得生
  我复有光明　　名金刚威力
  以业智清净　　由是故得生
  我复有光明　　名为显现空
  以开示世报　　由是故得生
  我复有光明　　名觉悟真实
  以离于颠倒　　由是故得生
  我复有光明　　名显示佛语
  以赞于法界　　由是故得生
  我复有光明　　名为离诸过
  以赞于胜解　　由是故得生
  我复有光明　　名庄严普照
  以赞施灯燎　　由是故得生
  我复有光明　　名为离恩爱
  以赞于定慧　　由是故得生
  我复有光明　　名为离诸习
  以赞前际智　　由是故得生
  我复有光明　　名为离诸着
  以赞无生智　　由是故得生
  我复有光明　　名为离诸趣
  以赞漏尽智　　由是故得生
  我复有光明　　名为舍离处
  以赞于苦智　　由是故得生
  我复有光明　　名为佛神变
  以赞神通力　　由是故得生
  我复有光明　　名为超戏论
  以赞一切智　　由是故得生
  我复有光明　　名为现众色
  以赞于神足　　由是故得生
  我复有光明　　名为乐善友
  以赞于觉性　　由是故得生
  我复有光明　　名为眼前际
  以赞眼前际　　由是故得生
  我复有光明　　名为眼尽际
  以赞于无尽　　由是故得生
  我复有光明　　名之为有际
  以赞于无有　　由是故得生
  我复有光明　　名为不可坏
  以赞于灭性　　由是故得生
  我复有光明　　名为无边际
  以赞于无际　　由是故得生
  我复有光明　　名之为有相
  以赞于无为　　由是故得生
  我复有光明　　名为无变异
  以赞无差别　　由是故得生
  我复有光明　　名之为不入
  以赞于无著　　由是故得生
  我复有光明　　名之为不出
  以赞于无起　　由是故得生
  我复有光明　　名之为无起
  以赞不出现　　由是故得生

  我有光名无表示　　而能成熟诸群生
  我有光名法本性　　其光能动俱胝刹
  我有光名调伏魔　　其光威德令魔怖
  我有光名福德幢　　持其名者离危厄
  我有光名有力幢　　持其名者离怨对
  我有光名寂静幢　　持其名者离贪欲
  我有光名禅定幢　　持其名者离邪行
  我有光名名闻幢　　持其名者得称赞
  我有光名悦意幢　　持其名者无忧恼
  我有光名净戒幢　　持其名者离毁禁
  我有光名妙香幢　　持其名者无臭秽
  我有光名法甚深　　持其名者无疑惑
  我有光名无所住　　持其名者离诸有
  我有光名离分别　　持其名者无执取
  我有光名妙高山　　持其名者无能动
  我有光名秘密行　　持其名者无所著
  我有光名解脱行　　持其名者无系缚
  我有光名善调伏　　持其名者得柔软
  我有光名无动摇　　持其名者离贪染
  我有光名善调顺　　持其名者戒圆满
  我有光名众善行　　持其名者无所染
  我有光名多利益　　闻其名者离诸过
  我有光名胜知见　　闻其名者无迷惑
  我有光名求利益　　闻其名者无嗔恚
  我有光名心适悦　　闻其名者得安乐
  我有光名无热恼　　持其名者了空性
  我有光名空无性　　持其名者超戏论
  我有光名无依止　　持其名者不动摇
  我有光名离迷惑　　持其名者不犹豫
  我有光名无住处　　持其名者离愚闇
  我有光名厌肉身　　持其名者当不受
  我有光名无所取　　持其名者离文字
  我有光名无有痴　　持其名者离言说
  我有光名无去处　　持其名者知未来
  我有光名普边际　　持其名者知过去
  我有光名无与等　　持其名者了无漏
  我有光名证圣者　　持其名者知最上
  我有光名无垢染　　持其名者离诸着
  我有光名离尘坌　　持其名者无闇蔽
  我有光名无爱恋　　持其名者离所依
  我有光名最胜上　　持其名者摧他论
  我有光名少壮年　　持其名者成六行
  我有光名最胜尊　　持其名者智无碍
  我有光明名速疾　　持其名者成胜僧
  我有光明名有相　　持其名者了深法
  我有光明名无相　　持其名者离于慢
  我有光明名无生　　持其名者获无得
  我有光明名念佛　　为诸如来之所赞
  于多佛所修诸行　　尔乃得成如是光
  佛身所现诸光明　　千俱胝刹微尘数
  如是无量俱胝刹　　其数又如大海沙
  一一微尘诸光明　　各有若干多眷属
  其光遍往无佛刹　　化作如来清净身
  演说甚深微妙法　　安住众生忍辱中
  我有光明名为佛　　令诸众生住佛道
  我有光明名为法　　清净照曜无瑕垢
  我有光明名为僧　　诸佛如来所称叹
  我有光明名清净　　其光殊胜甚难得
  我有光明名为华　　利益众生得成熟
  我有光明名为梵　　或名帝释或名天
  名月名龙名夜叉　　名阿修罗迦楼罗
  或有名王名妇女　　或名童女或童男
  如是种种诸光明　　各以善法化同类
  能令无量俱胝众　　皆得成就于菩提
  我有光明名智慧　　或有名戒或名慈
  或名悲喜或名灯　　或号涂香或音乐
  如是等类诸光明　　各随本行为其称
  皆摄无量群生类　　由是成就此光明
  我有光明名尊重　　诸佛如来之所赞
  于佛教法常恭敬　　由是成就此光明
  佛眼所见众生数　　一毛孔现若干光
  而彼一一诸光明　　各有眷属共围绕
  随诸众生心所念　　蒙佛光明皆成熟
  若有闻说此光明　　能生欢喜深爱乐
  是人往昔诸佛所　　已曾得闻如是经
  我有光明名最胜　　眷属八十俱胝数
  昔曾一偈赞于佛　　是故成就此光明
  我有光明名无忧　　眷属八十那由众
  持一如来所说法　　是故成就此光明
  我有光明名胜净　　眷属八十俱胝数
  若能受持一三昧　　是故成就此光明

  过去有佛　　名为最胜　　彼佛住世
  寿命无量　　最初成道　　法会之中
  时有八十　　那由他众　　尔时于此
  阎浮提中　　有一国王　　名为乐声
  其王复有　　五百王子　　颜貌端正
  见者欢喜　　是时父王　　威德自在
  于三宝所　　深生信乐　　其王所有
  胜妙园苑　　悉皆奉施　　彼佛世尊
  是园苑中　　经行之处　　复有无量
  薝卜迦树　　拘律陀树　　甄叔迦树
  优昙钵罗　　波罗波吒　　及尸利沙
  无忧树等　　其数各有　　八十俱胝
  如是诸树　　冬夏敷荣　　华果枝叶
  光色鲜茂　　出微妙香　　薰如来身
  有诸比丘　　身真金色　　各各皆坐
  是林树下　　勇猛精进　　得陀罗尼
  尔时彼佛　　愍其父王　　及诸王子
  并余大众　　演说如是　　决定光经
  其王闻已　　心生欢喜　　以无量偈
  称赞如来　　其王复以　　八十俱胝
  微妙宝盖　　奉献于佛　　一一宝盖
  以摩尼珠　　于其网间　　周匝严饰
  是摩尼宝　　一一价直　　八十俱胝
  阎浮檀金　　是一一盖　　八十俱胝
  摩尼宝珠　　以为璎珞　　是摩尼宝
  色泽鲜净　　无有昼夜　　常放光明
  一一光明　　照百由旬　　其光显曜
  蔽于日月　　其盖复以　　八十俱胝
  师子宝带　　八十俱胝　　金缕宝鬘
  四面严饰　　复以种种　　妙色珍奇
  间错庄严　　真珠宝网　　以如是盖
  周覆园苑　　其上复有　　苏摩那花
  阿提目多　　目真邻陀　　优昙钵罗
  青莲华等　　如是种种　　无量华盖
  一一皆悉　　称其宝网　　复以金缕
  俱吒摩衣　　以为缯盖　　而覆其上
  复有金足　　栴檀宝床　　其数亦有
  八十俱胝　　其床复以　　八十俱胝
  缯彩茵褥　　而严饰之　　是时一切
  诸众生类　　乃至有顶　　皆来集会
  于如来所　　听是经典　　天龙夜叉
  乾闼婆王　　摩睺罗伽　　阿修罗等
  闻是经已　　生欢喜心　　以百千偈
  称赞如来　　一切皆发　　大菩提愿
  诸天龙神　　及阿修罗　　以殷净心
  雨曼陀华　　真珠等宝　　而为供养
  尔时复有　　八十俱胝　　大威力天
  闻是经已　　心生欢喜　　发菩提愿
  于未来世　　得斯光明　　是时如来
  知彼意乐　　即授其记　　当得作佛
  尔时复有　　八十俱胝　　释提桓因
  并诸梵众　　闻说如是　　现光经典
  亦生欢喜　　发菩提心　　皆得授记
  当来作佛　　尔时复有　　八十俱胝
  那由他龙　　闻是经已　　发菩提心
  皆蒙授记　　尔时复有　　八十俱胝
  金翅鸟王　　闻是经已　　坚持五戒
  亦授其记　　尔时复有　　八十俱胝
  乾闼婆王　　闻是经已　　奏千种乐
  出微妙声　　供养于佛　　而得授记
  复有八十　　那由他数　　夜叉鬼王
  闻是经已　　于佛智慧　　深生净信
  一切皆得　　受菩提记　　月光当知
  时乐声王　　种种供养　　彼如来者
  岂异人乎　　即汝身是　　汝因往昔
  闻是经典　　是故今者　　还复咨问
  若人于我　　般涅槃后　　法轮将欲
  灭坏之时　　于是教中　　生净信者
  则能广说　　如是经典

  若于未来说是经　　则为护持于我法
  犹如众商善导师　　亦名护持于宝藏
  若于末世闻此经　　如弹指顷生欣乐
  当知皆是佛威神　　亦由文殊所加护
  是人则为见诸佛　　授其秘法令聪慧
  若人质直心柔软　　常勤供养于诸佛
  修行无我生慈忍　　是人爱乐于此经
  若人常怀不善心　　贪求利养无厌足
  于诸寂静无欣慕　　是人不乐于此经
  若人供养诸如来　　善能了知深妙法
  于佛正智生净信　　是人爱乐于此经
  若人散乱无净心　　常行魁脍难调伏
  于诸欲境为僮仆　　是人不乐于此经
  若人常乐阿兰若　　独处空闲心寂静
  不着利养及亲属　　是人爱乐于此经
  若人随顺恶知友　　损坏自他诸善法
  彼于戒定多退失　　是人不乐于此经
  若人意乐极清净　　常以智慧观诸法
  为善知识之所护　　是人爱乐于此经
  若人系着亲友家　　与之花果令欢喜
  心无正直怀谄曲　　是人不乐于此经
  若人常念诸佛恩　　于胜善根生爱乐
  回向菩提无谄曲　　是人爱乐于此经
  若人恋着于妇女　　种种上服而严饰
  常愿与彼同游戏　　是人不乐于此经
  若人深心无所依　　于诸欲境曾无染
  不以饮食生谀谄　　是人爱乐于此经
  若人教导诸群生　　而言淫欲无诸过
  则为诽谤三世佛　　是人不乐于此经
  若人信乐常坚固　　发起精进求诸法
  不生疲倦及轻慢　　是人爱乐于此经
  若人系着诸妇女　　常于欲境怀思念
  不修智慧广饶益　　是人不乐于此经
  若人宴坐山林中　　修习智慧皆清净
  不贪一切资生具　　是人爱乐于此经
  若人于眼前后际　　而常迷惑不能了
  彼则愚痴为魔罥　　是人不乐于此经
  若人于眼前后际　　而常通达无迷惑
  彼则解脱诸魔罥　　是人爱乐于此经
  若人于眼有无边　　而常迷惑不能了
  彼则愚痴为魔罥　　是人不乐于此经
  若人于眼有无边　　而常通达无迷惑
  彼则解脱诸魔罥　　是人爱乐于此经
  若人于眼成坏相　　而常迷惑不能了
  彼则愚痴为魔罥　　是人不乐于此经
  若人于眼成坏相　　而常通达无迷惑
  彼则解脱诸魔罥　　是人爱乐于此经
  乃至耳鼻舌身心　　色声香味并触法
  地水火风与体性　　事物众生及以苦
  蕴界世生声名谛　　贪嗔痴慢爱覆憍
  悭嫉谄诳并忿等　　当知一一皆如是
  若人于彼眼尽边　　而常迷惑不能了
  彼则堕诸凡夫行　　是人不乐于此经
  若人于彼眼尽边　　而常通达无迷惑
  彼则离诸凡夫行　　是人爱乐于此经
  若人于彼眼灭坏　　而常迷惑不能了
  彼则堕诸凡夫行　　是人不乐于此经
  若人于彼眼灭坏　　而常通达无迷惑
  彼则离诸凡夫行　　是人爱乐于此经
  若人于彼眼寂灭　　而常迷惑不能了
  彼则堕诸凡夫行　　是人不乐于此经
  若人于彼眼寂灭　　而常通达无迷惑
  彼则离诸凡夫行　　是人爱乐于此经
  若人于眼无去来　　而常迷惑不能了
  彼则堕诸凡夫行　　是人不乐于此经
  若人于眼无去来　　而常通达不迷惑
  彼则离诸凡夫行　　是人爱乐于此经
  若人不了眼无我　　于眼尽性常迷惑
  彼则堕诸凡夫行　　是人不乐于此经
  若人能了眼无我　　于眼尽性常通达
  彼则离于凡夫行　　是人爱乐于此经
  若人不了眼无我　　于忍行处常迷惑
  彼则堕诸凡夫行　　是人不乐于此经
  若人能了眼无我　　于忍行处常通达
  彼则离诸凡夫行　　是人爱乐于此经
  若人不了眼尽性　　彼不成就无依戒
  以不成就无依戒　　是人不乐于此经
  若人能了眼尽性　　彼则成就无依戒
  以能成就无依戒　　是人爱乐于此经
  若人不了眼尽性　　彼不成就无漏戒
  以不成就无漏戒　　是人不乐于此经
  若人能了眼尽性　　彼则成就无漏戒
  以能成就无漏戒　　是人爱乐于此经
  若人不了眼尽性　　彼不成就无漏慧
  以不成就无漏慧　　是人不乐于此经
  若人能了眼尽性　　彼则成就无漏慧
  以能成就无漏慧　　是人爱乐于此经
  若人不了眼尽性　　于眼空性常迷惑
  彼不能生总持智　　是人不乐于此经
  若人能了眼尽性　　于眼空性常通达
  彼则能生总持智　　是人爱乐于此经
  若人了知眼尽性　　彼则成就总持智
  乃至无上无著智　　是人爱乐于此经
  若人不乐于此经　　于眼尽性常迷惑
  彼则退失诸禅定　　证无上智实为难
  若人爱乐于此经　　于眼尽性能通达
  彼则成就诸禅定　　证无上智不为难
  若人了知眼尽性　　于无我相能通达
  彼则常闻如是法　　深生信解得无疑
  若人思惟眼尽性　　昼夜精勤无懈惓
  彼则成就总持辩　　常能演说于此经
  若人思惟于此经　　成就出现光明智
  彼则显发诸如来　　于眼空性能通达
  假使建立百千塔　　供养一切诸世尊
  若人思惟于此经　　所获功德复过彼
  假使百千诸伎乐　　供养如来之舍利
  若人得闻于此经　　所获功德复过彼
  佛眼所见诸众生　　皆同如来而供养
  过于无量俱胝劫　　不如受持于此经
  若人于此契经中　　受持演说四句偈
  当于是人生恭敬　　犹如最胜大悲尊
  我于往昔百千劫　　流转三有生死中
  曾于无量诸佛所　　为是经故而供养
  或然无量百千灯　　其炷各等由旬量
  为于此经得自在　　是故供养大导师
  或以薝卜婆利花　　苏摩那花无忧花
  以此花鬘及幢盖　　种种供养如来塔
  我于往昔生死中　　有来求者咸能施
  或施花果诸林苑　　或施桥梁及井泉
  或施白象及麒麟　　或施宝马并彩女
  或施金床珍宝帐　　或施璎珞杂花鬘
  如是一一满百千　　为此经故心无倦

大宝积经卷第三十大宝积经卷第三十一

        唐天竺三藏菩提流志译

    出现光明会第十一之二

  我昔为是经　　护持清净戒
  常修于定慧　　及施诸众生
  我昔为是经　　恶人来毁骂
  我时生怜愍　　于彼不加害
  我昔为是经　　求者皆施与
  各随其所乐　　悉令得欢喜
  我昔为是经　　奉施诸宫殿
  庄严众宝网　　供养于诸佛
  我昔为是经　　舍种种珍玩
  及以摩尼宝　　供养于诸佛
  我昔为是经　　有恩常忆念
  乃至闻一偈　　于彼恒尊重
  我昔为是经　　尊重持戒者
  乃至经行处　　于彼常恭敬
  我昔为是经　　或处于生死
  乃至有少恩　　于彼常怀报
  我昔为是经　　不求利谤法
  哀愍于亲友　　乃至诸众生
  我昔为是经　　具多闻善说
  于法无所著　　不悭亲友家
  我昔为是经　　若心生不善
  速忏令除灭　　终不使增长
  我昔为是经　　身为王太子
  所得诸珍宝　　涂香及末香
  我时生净心　　回施于诸佛
  我昔为是经　　愍诸囚徒类
  种种加楚毒　　以身而代受
  我昔为是经　　舍诸五欲乐
  常于月六斋　　受持诸禁戒
  我昔为是经　　常修行忍辱
  乃至于妻室　　亦不生贪吝
  我昔为是经　　令诸贫乏者
  皆悉得安乐　　丰足诸财宝
  我昔为是经　　摄受于一切
  沙门婆罗门　　种种群生类
  我昔为是经　　利益于一切
  常为大施主　　求者心无吝
  或莳于华果　　不令人剪伐
  普施诸众生　　随意皆充足
  我昔布施时　　其心常平等
  持戒具功德　　破戒无惭愧
  或证大神通　　下至凡愚类
  皆生希有心　　恭敬而周给
  我昔布施时　　其心无高下
  不求生善趣　　志乐于此经
  或令国界中　　一切无怨敌
  调伏诸龙众　　应时霔甘雨
  月光汝当知　　我于无量劫
  为求是经故　　修习诸苦行
  设于百千劫　　宣说不能尽
  汝已住净信　　当来末世时
  应生正念心　　演说是经典
  我以佛眼观　　明见未来世
  随其种种行　　一切皆了知
  若有诸比丘　　为求无上智
  能以净信心　　演说此经典
  是人及方所　　一切皆了知
  若于末世时　　闻是经爱乐
  志愿及方便　　一切皆了知
  若诸下劣人　　不闻是经典
  诽谤宣说者　　一切皆了知
  若有诸比丘　　及诸比丘尼
  得闻于是经　　悲感而涕泣
  我皆与受记　　得见最胜尊
  月光汝当知　　诸佛神通力
  若人意清净　　或有不清净
  乃至于信解　　一切皆了知
  若有诸众生　　志乐常寂静
  安住诸禅定　　不着生死中
  乃至于习气　　究竟皆永断
  如是等功德　　一切皆了知
  或有诸众生　　耽着虚妄法
  或有诸众生　　于佛生欣乐
  如是未来事　　一切皆了知
  若有诸众生　　染着世间乐
  于佛菩提种　　不能善开发
  以是因缘故　　退失诸方便
  若有能了知　　诸佛菩提种
  是人当获得　　清净无边光
  月光汝当观　　如是光明等
  一一诸因缘　　各各有差别
  汝以智慧力　　一切应了知
  若舍恶知识　　亲近于善友
  护持清净戒　　成就佛光明
  汝当护诸根　　舍离无惭愧
  修行于善法　　随护诸众生
  汝当舍违诤　　了达于性空
  不贪着利养　　具多闻善说
  汝当观利养　　犹如于粪秽
  无以利养垢　　染污清净心
  常求于明脱　　常得无上利
  汝当修佛道　　观佛同法性
  常然大法炬　　普照于世间
  汝当如山王　　其心安不动
  毁骂及捶打　　一切皆能忍
  汝当为众生　　作真实善友
  应舍下劣心　　常修于净业
  汝以坚固心　　演说无上法
  如是微妙经　　当授慈心者
  欲求无上智　　勿怖于生死
  由此舍诸恶　　当得于胜利
  譬如明智人　　善能用于火
  成熟种种味　　不为火所烧
  若诸愚痴人　　无有善方便
  将火置于掌　　便为火所烧
  亦如人中毒　　迷闷心狂乱
  以火而炙疗　　因此得除愈
  月光汝当知　　智者亦如是
  依意了意空　　故处于生死
  依眼了眼空　　于眼无执着
  若能如是知　　住眼亦无恼
  若了眼性空　　成就真实智
  以真实智故　　当得出现光
  若了眼性空　　永灭于贪欲
  以无贪欲故　　当得出现光
  如是嗔与痴　　我执并覆恼
  悭嫉无惭愧　　不忍将贡高
  憍慢及增上　　谄诳兼放逸
  乃至憍诈等　　一一如贪说
  若得真实智　　了知眼寂灭
  以知寂灭故　　当得出现光
  若得真实智　　住佛理趣中
  以住理趣故　　当得出现光
  若得真实智　　住佛方便中
  以住方便故　　当得出现光
  若不修实智　　永离于障恼
  成就出现光　　我昔未闻见
  若勤修实智　　永离于障恼
  能顺于是行　　当得出现光
  若求最胜行　　当学于此经
  供养诸如来　　得实智方便
  若修真实智　　当供养诸佛
  成就出现光　　犹如掌中果
  若迷眼无我　　退失沙门法
  彼人不能得　　如是出现光
  若了眼无我　　成就沙门法
  彼人当证得　　如是出现光
  若了眼尽际　　亦了耳生边
  由了耳生边　　是大沙门法
  若不遍了知　　眼性之边际
  于眼生边际　　亦不能遍知
  彼人不能得　　如是出现光
  若能遍了知　　眼性之边际
  于眼生边际　　亦能遍了知
  彼人当证得　　如是出现光
  若不善了知　　眼性之边际
  于眼生边际　　亦不能善知
  彼人不能得　　如是出现光
  若能善了知　　眼性之边际
  于眼生边际　　亦能善了知
  彼人当证得　　如是出现光
  若不现了知　　眼性之边际
  于眼生边际　　亦不能现知
  彼人不能得　　如是出现光
  若能现了知　　眼性之边际
  于眼生边际　　亦能现了知
  彼人当证得　　如是出现光
  若不善了知　　眼性之边际
  于眼生边际　　亦不能遍知
  彼人不能得　　如是出现光
  若能善了知　　眼性之边际
  于眼生边际　　亦能现了知
  彼人当证得　　如是出现光
  若不善了知　　眼性之清净
  于耳性清净　　亦不能善知
  彼人不能得　　如是出现光
  若能善了知　　眼性之清净
  于耳性清净　　亦能善了知
  彼人当证得　　如是出现光
  乃至耳鼻舌　　身意与色声
  香味并触法　　地水若火风
  性事世间苦　　蕴界世将生
  及以声名等　　一切皆如是

尔时世尊告月光童子言。善男子。若有众生发趣大乘。为欲圆满成就如是出现光者。有八十种善根资粮。云何八十。所谓护念众生。心无损害。于清净戒奉持无缺。其心平等。无有谄曲。亦无悭嫉贪诳之心。深信大乘微妙经典。亦不耽爱富贵憍逸。忍力具足。志愿无退。意乐清净。住阿兰若。不依眷属利养名闻。安住诸禅现光三昧。于有戒者无谄承事。于同梵行起胜意乐。以敬法故常于和上阿阇梨所深生尊重。了达契经。善巧宣说。所言诚谛。住正思惟。勤种善根。常行慧施。觉知魔业。密护诸根。言词安审。善解真谛。亦能了知诸地自相。求无尽色。不惜身命。教于四众绝世思惟。离诸邪见无后世法。不于未学矫现其相。常于已学任力开示。曾不赞美歌咏音声。亦不称誉庄严资具。证入诸谛。具足多闻。舍离睡眠。勤求正法。于佛尊重。发菩提心。舍于世业。修诸学处。为爱法故依于胜友。求诸善根心无厌足。爱乐出家。护持佛法。不起恶业。于教无疑。善说譬喻。开示秘密。于大菩提志求无倦。所受经典未尝忘失。不舍自学。摧伏他论。求出离道。修无量行。于彼法智其心决定。明见因果相续轮回。不着三有。离增上慢。为于信者建立对治。了达未来果报差别。善知前际不假他缘。于远离行精勤修习。于佛相好具足庄严。是为八十。复次月光。此八十法入于五法。云何为五。所谓知生死。知涅槃。知烦恼尽。知增上。知福果。复次月光。如是五法入于二法。云何为二。所谓心清净庄严。色清净庄严。复次月光。如是二法入于一法。云何为一。所谓能成诸佛如来无碍解脱

复次月光。复有八十种法。善能成就诸佛如来无碍解脱。云何八十。所谓布施资粮。广大智慧。修清净戒。离烦恼热。摧伏憍慢。柔软言词。于种种事无不知时。亦知善友。发趣大乘。被精进甲。威仪利物。堕烦恼者令断疑惑。毁诸不善。修行白法。不与恶人而为伴侣。种诸善根无有厌足。发菩提心勇猛精进。觉知魔事。证于诸谛。真实供养决了无疑。心念众生常怀济度。不着诸有。起于大心。不善众生示其过恶。舍贪嗔痴。不求欲利。成熟众生。修治佛塔。于诸圣者尊重恭敬。住大乘者亲近承事。终不赞叹下劣乘人。远离声闻。摧伏怨敌。于世尊所广大供养。以殊胜心种种奉施。得无碍智。具足辩才。以诸譬喻开示正法。而于性空不相违背。求法无懈。显发深义。具大总持。说法无染。能广流布。化导无厌。圆满诸行有大威德。辩才无滞。成就多闻。不赞恶人。修于善业。解了诸蕴。舍离诸见。通达因性。超过所行。远离非境。生清净信。住于正道。爱乐大乘。平等摄受。不着无我。不厌生死。乐求涅槃。以少欲故住阿兰若。常行乞食无有懈惓。随有所得心生喜足。离无惭愧。亲近于佛。善友同止。舍于非类。愍诸凡夫。同众生行。于佛净信。离于非器。有相违者不与言说。不来求者不为开晓。若有来求如应为说。于食平等。常施等施。开门大施。如是童子。此八十法。能得诸佛无碍解脱。尔时月光童子。得闻是法生大欢喜。即于佛前以偈赞曰

  如来了知眼尽边　　故能出现清净智
  以能出现清净智　　具足如来清净光
  如来了知眼无我　　故能出现清净音
  以能出现清净音　　具足如来梵音相
  佛于往昔利众生　　故能成就语清净
  以能成就语清净　　饶益无量诸世间
  如来了知眼性空　　故能成就总持智
  以能成就总持智　　出现如来无量光
  如来了知眼差别　　眼名差别亦无边
  以知名字无边故　　出现如来无量光
  佛知文字差别门　　即知眼空离文字
  以知眼空离文字　　出现如来无量光
  若人思惟眼无我　　即了佛语为真实
  以能知佛语真实　　出现如来决定光
  如来成就胜神通　　即了无边眼灭坏
  以能了知眼灭坏　　利益一切诸世间
  大悲最胜两足尊　　了达无边眼生起
  如佛能知眼生起　　愿我不久亦当然
  如是耳鼻舌身心　　色声香味并触法
  乃至世生声名等　　当知一切皆应作
  大悲最胜两足尊　　已具布施波罗蜜
  如佛布施波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具净戒波罗蜜
  如佛净戒波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具忍辱波罗蜜
  如佛忍辱波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具精进波罗蜜
  如佛精进波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具禅定波罗蜜
  如佛禅定波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具智慧波罗蜜
  如佛智慧波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具法身波罗蜜
  如佛法身波罗蜜　　愿我不久亦当然
  大悲最胜两足尊　　已具无边清净色
  如佛已具清净色　　愿我不久亦当然
  大悲最胜两足尊　　已具无边清净意
  如佛已具清净意　　愿我不久亦当然
  大悲最胜两足尊　　已具无边胜功德
  如佛已具胜功德　　愿我不久亦当然
  大悲最胜两足尊　　已具无边诸色相
  如佛已具诸色相　　愿我不久亦当然
  大悲最胜两足尊　　已具无边声清净
  如佛已具声清净　　愿我不久亦当然
  大悲最胜两足尊　　已具无边大神变
  如佛已具大神变　　愿我不久亦当然
  大悲最胜两足尊　　为化众生处三有
  如佛化彼众生类　　愿我不久亦当然
  大悲最胜两足尊　　已度无边生死行
  如佛已度生死行　　愿我不久亦当然
  大悲最胜两足尊　　已度无边贪欲行
  如佛度于贪欲行　　愿我不久亦当然
  大悲最胜两足尊　　已度无边嗔恚行
  如佛度于嗔恚行　　愿我不久亦当然
  大悲最胜两足尊　　已度无量愚痴行
  如佛度于愚痴行　　愿我不久亦当然
  大悲最胜两足尊　　已度无量贪嗔行
  如佛度于贪嗔行　　愿我不久亦当然
  大悲最胜两足尊　　已度无量嗔痴行
  如佛度于嗔痴行　　愿我不久亦当然
  大悲最胜两足尊　　已度无量贪痴行
  如佛度于贪痴行　　愿我不久亦当然
  大悲最胜两足尊　　已度无边等分行
  如佛度于等分行　　愿我不久亦当然
  导师已度于贪欲　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师已度于嗔恚　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师度于愚痴行　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师已度贪嗔行　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师已度嗔痴行　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师已度贪痴行　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  导师已度等分行　　普能饶益诸世间
  如佛饶益诸世间　　愿我亦成如是智
  如来具足殊胜智　　调伏一切诸天众
  我亦愿成如是智　　得为调御天人师
  如来具足殊胜智　　调伏一切诸龙众
  我亦愿成如是智　　得为调御天人师
  如来具足殊胜智　　调伏一切夜叉众
  我亦愿成如是智　　得为调御天人师
  如来具足殊胜智　　调伏一切乾闼婆
  乃至无量鸠槃茶　　所有若干诸眷属
  我亦愿成如是智　　得为调御天人师
  如来具足殊胜智　　了知诸法真实义
  我亦愿成如是智　　于彼真实得无疑
  如来若了苦尽边　　利益一切群生类
  我亦愿成如是智　　于彼苦尽得无疑
  如来善了因尽边　　利益一切群生类
  我亦愿成如是智　　于彼因尽得无疑
  如来具足殊胜智　　了达世间之所行
  我亦愿成如是智　　于世间行得无疑
  如来具足殊胜智　　了达世间处非处
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达世间诸业果
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达世间种种性
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达一切诸趣行
  我亦愿成如是智　　利益无量诸世间
  如来具足殊胜智　　了达世间诸胜解
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达一切诸根性
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达静虑之所行
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达解脱之所行
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达等分之所行
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达等至之所行
  我亦愿成如是智　　利益一切诸世间
  如来善了于生死　　流转皆因烦恼生
  我亦愿成如是智　　利益一切诸世间
  如来一切皆了知　　利益世间无与等
  我亦愿成如是智　　利益一切诸世间
  如来善住于等持　　发起殊胜方便智
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达无边宿住行
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达生死无有边
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了达一切烦恼尽
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　成就无上正等觉
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　离诸烦恼并习气
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了知欲染障菩提
  我亦愿成如是智　　利益一切诸世间
  如来具足殊胜智　　了知出离生死法
  愿我亦成如是智　　利益一切诸世间
  如来善了于法义　　觉悟无量诸众生
  我亦愿成如是智　　利益一切诸世间
  如来善了于法性　　如幻如梦如阳炎
  我亦愿成如是智　　利益一切诸世间
  如来善了于世间　　一切文字并言说
  我亦愿成如是智　　利益一切诸世间
  如来具足胜辩才　　开示甚深微妙法
  我亦愿成如是智　　利益一切诸世间
  如来善调身语意　　一切皆随智慧行
  我亦愿成如是智　　利益一切诸世间
  如来善了于三世　　无取无著无挂碍
  我亦愿成如是智　　利益一切诸世间
  如来善修戒定慧　　于彼一切无退转
  我亦愿成如是智　　得为三界大悲尊
  如来善修于解脱　　解脱知见无退转
  我亦愿成如是智　　得为三界大悲尊
  如来善修于正观　　天人世间无等伦
  我亦愿成如是智　　得为三界大悲尊
  如来具足殊胜智　　于诸世法无所染
  我亦愿成如是智　　得为三界大悲尊
  如来善了于世间　　种种诸趣皆明见
  我亦愿成如是智　　于彼诸趣得无碍
  如来善了尽生边　　是故于彼无迷惑
  我亦愿成如是智　　于尽生性得无疑
  如来善了寂静边　　是故于彼无迷惑
  我亦愿成如是智　　于彼寂静得无疑
  如来善了流转边　　是故于彼无迷惑
  我亦愿成如是智　　于彼流转得无疑
  如来善了前后际　　是故具足无师智
  我亦愿成如是智　　于前后际得无疑
  如来善了转生边　　是故具足无师智
  我亦愿成如是智　　于彼生转得无疑
  如来善了前后际　　于眼断常无所执
  我亦愿成如是智　　于前后际得无疑
  如来善了尽生边　　于眼断常无所执
  我亦愿成如是智　　于尽生性得无疑
  若人不了前后际　　彼则于贪生取着
  如来于彼能证知　　是故于贪无所染
  若人不了有无边　　彼则于贪生取着
  如来于彼能证知　　是故于贪无所染
  若人不了尽无边　　彼则于贪生取着
  如来于彼能证知　　是故于贪无所染
  若人不了转无转　　彼则于贪生取着
  如来于彼能证知　　是故于贪无所染
  嗔痴忿覆并嫉诳　　谄曲贡高与憍慢
  布施持戒将忍辱　　禅定智慧皆如是

尔时世尊。知月光童子深心所念。熙怡微笑放金色光。其光普照无量无边诸佛国土。于彼国界作利益已。绕佛三匝还从如来顶上而入。是时弥勒菩萨。即从座起。偏袒右肩右膝着地。顶礼佛足合掌恭敬。以诸偈赞而问佛言

  云雷师子吼　　迦陵频伽声
  出大法鼓音　　何缘现微笑
  殊胜百千日　　清净妙音声
  功德甚希有　　何缘现此光
  施戒忍精进　　定慧等庄严
  一切皆圆满　　何缘现此光
  如来柔软音　　常远离粗语
  善疗众生病　　何缘现此光
  大悲两足尊　　知眼常空寂
  以清净梵音　　为众生演说
  耳鼻舌身心　　乃至声名等
  并诸集灭道　　智忍亦如是
  大悲两足尊　　知眼尽生际
  寂静及流转　　一切皆空寂
  耳鼻舌身心　　色声香味触
  乃至声名等　　一切皆如是
  又说因缘法　　远离于断常
  非自非他作　　众缘之所生
  或以种种门　　开示于苦本
  或以种种义　　称赞佛光明
  以无量言词　　演说寂灭法
  无人无寿者　　无我无众生
  过去无量佛　　亦以不思议
  百千诸偈颂　　演说如是法
  如来所演说　　真实功德法
  无说无说者　　所说法亦无
  佛说最胜法　　觉悟于群生
  诸天及夜叉　　闻者皆能了
  一切阿修罗　　意乐已清净
  无量诸人众　　疑网悉皆除
  了知贪自性　　灭坏嗔与痴
  爱慢及无明　　谄嫉并戏论
  乃至苦蕴等　　一切皆舍离
  如是诸句义　　究竟悉清净
  如来于一法　　通达种种名
  其数百千万　　乃至不思议
  于无量佛所　　善学如是法
  而于一法中　　演说无穷尽
  如来善了达　　种种诸法门
  亦能分别知　　名句上中下
  修学于一切　　种种异言词
  善巧而宣说　　微妙第一义
  如是清净音　　因缘和合起
  亦不依喉舌　　乃至于身心
  其地六种动　　十方众咸集
  合掌瞻仰佛　　愿为除众疑
  如来善了知　　眼尽生边际
  自性常空寂　　无去亦无来
  无住无处所　　深入于实际
  佛眼无障碍　　是故我今问
  如来善了知　　眼性前后际
  尽无尽流转　　自性常空寂
  开示诸法义　　令世间欢喜
  牟尼美妙音　　何缘现微笑
  佛知前后际　　眼性常空寂
  离分别言词　　何缘现微笑
  佛知眼无量　　种种言宣说
  本性常空寂　　何缘现微笑
  佛知尽生边　　眼性常空寂
  舍离诸烦恼　　证佛菩提智
  具足胜名闻　　何缘现微笑
  如来久修学　　演说不思议
  了达眼性空　　离垢常清净
  无量诸心行　　一念皆了知
  光明照世间　　为是何瑞相
  大仙等正觉　　最胜两足尊
  烦恼悉已除　　其心常寂静
  如来殊胜智　　深达眼尽边
  复以何因缘　　而今现微笑
  耳鼻舌身心　　六尘并四大
  乃至声名等　　一切皆如是
  佛知眼无我　　亦达耳无常
  及了鼻性空　　何缘现微笑
  佛知舌无我　　亦达身无常
  及了心性空　　何缘现微笑
  佛知色无我　　亦达声无常
  及了香性空　　何缘现微笑
  佛知味无我　　亦达触无常
  及了法性空　　何缘现微笑
  佛知地无我　　亦达水无常
  及了火性空　　何缘现微笑
  佛知风无我　　亦达性无常
  及了事性空　　何缘现微笑
  知世间无我　　亦达苦无常
  及了蕴性空　　何缘现微笑
  佛知界无我　　亦达世无常
  及了生性空　　何缘现微笑
  佛知声无我　　亦达名无常
  及了道性空　　何缘现微笑
  佛知智无我　　了寂静无常
  及众生性空　　何缘现微笑
  佛知性无性　　亦知我非我
  及了意乐空　　何缘现微笑
  观生死无我　　亦达常无常
  及了涅槃空　　何缘现微笑
  如来心解脱　　名闻满三界
  帝释与人王　　龙神咸供养
  如来善了知　　眼尽生边际
  乃至于寂静　　何缘现微笑
  无量诸佛子　　俱集于众会
  从佛口所生　　从法变化生
  皆来佛前住　　合掌而尊重
  为于彼众故　　问此光因缘
  如来善了知　　眼性空无我
  超过于一切　　在家修学者
  佛以平等智　　了法无差别
  如来意乐知　　非是神通见
  佛知眼无我　　性空无去来
  清净智无边　　何缘现微笑

大宝积经卷第三十一大宝积经卷第三十二

        唐天竺三藏菩提流志译

    出现光明会第十一之三

  如来已尽于生际　　大悲普覆诸世间
  法王最胜人中尊　　愿说何缘现微笑
  无量无边大菩萨　　并余威德诸天众
  悉于空中持妙盖　　而此大地皆振动
  谁于往昔如来所　　长夜修行诸善法
  平等悦意大悲尊　　愿说何缘现微笑
  谁于往昔供诸佛　　得闻此法生欢喜
  导师最胜人中尊　　愿说何缘现微笑
  世尊音声悦众意　　犹如雁王声美妙
  自然无量音和雅　　愿说何故放斯光
  无量俱胝讽颂言　　劝赞悦可相应语
  拘抧罗声殊胜类　　愿说何故放斯光
  雷鼓深远说法声　　普闻无边千亿界
  慈心粗言或软语　　何故现斯金色光
  了生无生尽无尽　　知眼性离无来去
  为世照明甘露灭　　何故现斯金色光
  知眼起作常空寂　　无去无来无住处
  犹如阳炎水泡沫　　示现微笑何因缘
  如是耳鼻舌身意　　色声香味并触法
  乃至音声及名等　　当知一切亦复然
  金刚常身不坏身　　具足百千殊胜相
  体无机关而运动　　愿说微笑何因缘
  髀膊佣满足跟长　　腹相不现如师子
  脐深妙好腰圆满　　愿说微笑何因缘
  金色净身离尘垢　　一一众毛绀青色
  右旋上靡香芬馥　　愿说微笑何因缘
  妙身圆满常安住　　犹如尼拘陀树王
  一切功德以庄严　　音声悦众令欣乐
  修臂佣圆肩妙好　　项约圆满螺文现
  游步无边百千刹　　示诸众生邪正道
  齿白无垢如珂雪　　舌相广长周覆面
  师子颊辅鼻修直　　皆从方便净心生
  优钵罗香从口出　　栴檀香气遍于身
  已于往昔广修慈　　清净意乐常相续
  如来足下善安平　　随所履地无窊曲
  犹如师子象王步　　超过一切诸世间
  千辐轮相妙端严　　殊胜光文常炳着
  所行善利诸群品　　见者皆生净信心
  一指能出百千光　　普照无边诸佛刹
  往昔勤修众善行　　获此种种相庄严
  成就色身无等伦　　面相端严最殊胜
  神变利益诸世间　　愿说何缘现微笑
  膊佣平正如鹿王　　身不低屈犹师子
  出与为世作灯明　　愿说何缘现微笑
  马王隐相无尘染　　掌中平满手过膝
  希有最胜人师子　　愿说微笑何因缘
  从身出现无边光　　妙色寂静而恒照
  其心清净常相续　　演说无边诸契经
  非彼安住断常人　　所能净修如是法
  若能舍离诸边见　　速成如来清净身
  天鼓云雷声远震　　迦兰陀鸿响清彻
  天乐音声千万种　　愿说何故现斯光
  导师一音演说法　　令诸毁戒断相续
  如来所说妙言音　　皆是甚深希有法
  牛王眉间白毫相　　遍至百千诸佛刹
  妙眼犹如绀青色　　顶相空天无能见
  齿白齐密具四十　　犹如清净颇胝宝
  皆从无量善业生　　愿说何缘现微笑
  如来圆满功德身　　成就无边微妙色
  出现希有净光明　　愿说何缘现微笑
  大悲最胜两足尊　　了达众生心志乐
  已得无碍妙辩才　　愿说何缘现微笑
  如来已到于彼岸　　具足三明及六通
  示现无边清净光　　愿说何缘现微笑
  佛于往昔无量劫　　供养百千诸世尊
  如是因果不败亡　　愿说何缘现微笑
  佛于往昔无量劫　　安住微妙诸等持
  知眼生边及尽边　　愿说何缘现微笑
  过去未来现在世　　导师于彼悉能了
  净智无碍不思议　　愿说何缘现微笑

尔时世尊。于大众中。以金色手。摩月光顶。而说偈言

  童子谛听　　吾今付汝　　此菩提法
  出现光经　　于后恶世　　法欲灭时
  当为众生　　开示演说　　我以佛眼
  见未来世　　于是微妙　　甚深经典
  若乐不乐　　皆悉了知　　若有众生
  志求佛道　　常念诸佛　　当授此经
  若坏净信　　乐于愦闹　　长夜惛睡
  不乐斯经　　于我法中　　虽得出家
  于涅槃法　　不生欣乐　　如是痴人
  虚食信施　　闻有为法　　多诸过患
  犹着世间　　不生惊怖　　如是痴人
  智者呵责　　虽服法衣　　而无智慧
  牟尼诸说　　真实之言　　无智若闻
  不能信受　　如是愚人　　勿与同止
  若有得闻　　此殊胜法　　不生欢喜
  爱乐之心　　如是等人　　我所呵责
  虽得人身　　则为空过　　若有得闻
  此甚深法　　能生欢喜　　爱乐之心
  是人已曾　　值遇诸佛　　决定当得
  无上菩提　　若人愚痴　　恶见所害
  断于慧命　　远离菩提　　是故应当
  舍恶知识　　亲近恭敬　　明慧之人
  一切世间　　无量过患　　众生常没
  三恶趣中　　皆从痴恶　　因缘所起
  随惑流转　　不得自在　　弃舍正法
  行于非法　　是故当离　　愚小之人
  犹如御者　　自折其轴　　既作恶业
  生地狱中　　口出恶言　　恒自伤害
  如持利斧　　自伐其身　　不知诸法
  因缘所造　　随业受报　　无能救者
  亲近世仙　　以为善友　　而便自谓
  修习于空　　已证无为　　生断灭见
  如身器破　　心亦随灭　　多所乐说
  绮饰言辞　　于此味着　　终无义利
  虽为毒蛇　　之所螫害　　终不令人
  堕于恶趣　　愚者说法　　坏人善根
  令无量众　　堕于地狱　　汝等大众
  应当观察　　如是童子　　今在我前
  往昔已曾　　供养无量　　恒河沙数
  诸佛世尊　　坚固修行　　求无上智
  心不依止　　一切诸有　　知眼生边
  毕竟清净　　离诸戏论　　无所染着
  为欲利益　　无量众生　　演说无上
  现光经典　　愚人不能　　修学是法
  于修行者　　见其过失　　是故应舍
  愚痴之人　　不应亲近　　修学是法
  愚痴之人　　乐于诤论　　不能勤修
  无诤论行　　彼诸人等　　无如理心
  是故不应　　恭敬称赞　　愚痴之人
  懈怠懒惰　　常行不善　　身语意业
  无有净戒　　智慧多闻　　常思欲境
  乐于愦闹　　汝等应观　　如是愚人
  种族及身　　皆悉鄙恶　　嗔恚佷戾
  形貌丑陋　　设生善处　　身常下劣
  执着我相　　迷于真理　　无有智慧
  分别语言　　闻性空法　　不生爱乐
  如来世尊　　久已远离　　一切世间
  语言戏论　　凡夫于此　　深生染着
  尽其寿命　　不能了知　　虽赞持戒
  不修梵行　　口说于法　　身行非法
  自说是律　　常行非律　　佛教弟子
  着坏色衣　　破戒之人　　而披此服
  增长憍慢　　放逸之心　　所食信施
  如吞猛火　　既舍居家　　无五欲乐
  又于佛法　　无胜妙乐　　乐于杂行
  不离二边　　所有意乐　　皆不清净
  如是愚人　　处在大众　　犹如野干
  入师子群　　虽说如是　　寂静之法
  不能了知　　真实空义　　为众称赞
  生贡高心　　不念大师　　惭愧谦下
  受不净物　　如得摩尼　　欢喜执持
  心无暂舍　　是辈下劣　　虽复出家
  守护威仪　　执持衣钵　　但有形像
  无实智慧　　虽复剃发　　不舍恶心
  堕于倒见　　非沙门法　　退失寂静
  涅槃之道　　亦无沙门　　所证之果
  无明烦恼　　不灭微尘　　游行聚落
  自称寂静　　愚人无智　　不知正趣
  心所乐欲　　皆为不善　　因利养故
  住阿兰若　　不为修习　　涅槃之因
  惛沈喜睡　　但念安身　　常乐修行
  如是等事　　虽住兰若　　经历多年
  以倒见故　　失涅槃道　　终不能得
  沙门道果　　毁破正见　　违犯禁戒
  爱好衣服　　庄严其身　　于诸欲乐
  常生爱染　　若入城邑　　现憍慢相
  放纵身业　　不住威仪　　或入城邑
  游行自说　　彼阿兰若　　山窟之中
  汝等当知　　是我所住　　徐行低视
  进止安庠　　发言诡异　　现罗汉相
  令白衣众　　咸相谓言　　兰若比丘
  是真圣者　　或复在彼　　阿兰若处
  见有人来　　即便指示　　我于是处
  昼夜经行　　或施软草　　宴坐之所
  或入聚落　　诣白衣家　　诈现殷勤
  问讯安隐　　说于世俗　　王贼之事
  或以染心　　于女人前　　种种方便
  自赞其德　　我能为世　　作大福田
  我舍王位　　出家修道　　宫人婇女
  皆悉生天　　彼人闻已　　益加恭敬
  衣服饮食　　种种供养　　大德哀愍
  数来我所　　贪着美味　　不知过患
  为魔得便　　如龟堕网　　于兰若众
  矜高利养　　轻毁诽谤　　精进比丘
  心迷名利　　转生贪着　　为活命故
  常行欺诳　　增长身语　　不善之业
  若有施主　　净心供养　　由懈怠故
  损减其福　　如是愚人　　常生恶欲
  于此空法　　无顺忍心

  若于我法中　　能离如是过
  勤修不放逸　　得此法非难
  于利与非利　　称讥苦乐等
  世法不能动　　得此法非难
  观身不净想　　诸蕴疮疣想
  受食涂疮想　　得此法非难
  虽受好衣服　　亦不生憍慢
  为遮惭耻故　　得此法非难
  不矜持色力　　于食无贪着
  为存寿命故　　得此法非难
  了知诸有空　　于欲无取舍
  常修空寂行　　得此法非难
  去一由旬山　　独坐修禅定
  观有为无我　　得此法非难
  观眼尽生边　　及眼流转相
  勤修眼净道　　得此法非难
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  如是未来世　　无量诸比丘
  精勤懈怠者　　一切皆应了
  彼遇善恶友　　修习不修习
  生信及不信　　一切皆应了
  彼遇善恶友　　于诸根尽道
  修习不修习　　一切皆应了
  若爱乐菩提　　或一二三月
  后时还退失　　一切皆应了
  若人闻此法　　能生爱乐心
  设令时退失　　还得于净信
  若人闻此法　　不能离放逸
  便生是念言　　此经非佛说
  若人闻此法　　为魔所摄持
  初虽起信心　　后则还弃舍
  于法无欣乐　　虚空求名利
  游行于聚落　　赞说陀罗尼
  三昧总持光　　彼实不能了
  缠缚于五欲　　贪求诸世业
  以分别言说　　诽谤修空者
  无有念慧心　　尽寿为空过
  愚人舍空法　　是则为破戒
  当堕阿鼻狱　　终不得生天
  若于一刹那　　造立于千塔
  不如闻是经　　受持四句偈
  以百千华鬘　　供养于佛塔
  不如闻是经　　思惟四句偈
  若人造宝塔　　其数如恒沙
  不如刹那顷　　思惟于此经
  于百亿佛刹　　散华以供养
  不如刹那顷　　思惟于此经
  袈裟百万亿　　奉施于诸佛
  不如刹那顷　　思惟于此经
  佛眼胜清净　　无所不知见
  若爱乐此经　　当得如来眼
  过去无数劫　　有佛名然灯
  我为摩纳仙　　持华来供养
  便记我成佛　　号释迦牟尼
  当坐于道场　　演说此经典
  汝时为童子　　闻我得受记
  欢喜生净心　　合掌而发愿
  若摩纳成佛　　我当助宣化
  乃至灭度后　　护持于法藏
  如彼然灯佛　　所说现光经
  摩纳与童子　　尔时俱听受
  我曾于往昔　　以优钵罗华
  供养于彼佛　　汝时在此会
  即发如是愿　　于我末法中
  受持此经典　　广宣说流布
  若有闻是法　　心不生嗔恚
  能受持读诵　　是名善丈夫
  汝当于后世　　持此难闻法
  广为诸众生　　分别其义趣
  我亦于过去　　正法欲灭时
  持此现光经　　广为众生说
  愚人不勤修　　于此生诽谤
  我虽闻此言　　亦不生嗔恚
  我常修忍力　　饶益诸世间
  由忍力成就　　相好庄严身
  童子汝当观　　佛身妙圆满
  金色最清净　　皆从忍力生
  我足指按地　　震动无边刹
  众生不颠坠　　皆从忍力生
  我从一毛孔　　出百千光明
  清净照一切　　皆由胜忍力
  罗刹甚可畏　　吸人精气者
  常慈心敬我　　皆由胜忍力
  我所有眷属　　善能调伏心
  尊重于如来　　皆由胜忍力
  百千诸音乐　　遍于大众中
  称赞佛功德　　皆由胜忍力
  百千诸龙王　　嗔毒甚可畏
  见佛生欢喜　　皆由胜忍力
  罗叉夜叉等　　持百千华鬘
  悉来供养我　　皆由胜忍力
  无量百千刹　　现在诸如来
  称赞我功德　　皆由胜忍力
  八千鸠槃荼　　及阿吒嚩迦
  散华供养我　　皆由胜忍力
  六十百俱胝　　诸夜叉王等
  悉来供养我　　皆由胜忍力
  复有千龙王　　摩那娑伽等
  赤真珠奉我　　皆由胜忍力
  百千兜牟卢　　及与尸弃毗
  音乐供养我　　皆由胜忍力
  百千鸠槃荼　　毗卢释迦等
  香华供养我　　皆由胜忍力
  持大地龙王　　示现于半身
  合掌恭敬我　　皆由胜忍力
  有百千俱胝　　无身罗怙等
  净心供养我　　皆由胜忍力
  童子汝当观　　如来光所照
  离苦得安乐　　皆由胜忍力
  百千三暮多　　风天遍虚空
  雨香供养我　　皆由胜忍力
  百千诸天众　　散天华供养
  悉舍诸爱着　　亲近于如来
  汝观佛神通　　所说施戒声
  周闻于一切　　皆由胜忍力
  演说蕴界声　　及四谛音声
  周闻于一切　　皆由胜忍力
  由我神通力　　闻空中演说
  眼尽边寂静　　生边亦复然
  由我神通力　　闻空中演说
  眼从因缘生　　无来亦无去
  由我神通力　　闻空中演说
  眼观察寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼尽边寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼边际寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼生边寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼流转寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼无生寂静　　诸佛由是生
  由我神通力　　闻空中演说
  眼寂灭寂静　　诸佛由是生
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  贪嗔痴忿覆　　嫉妒及谄诳
  贡高憍慢等　　广说亦复然

尔时月光童子。闻说如是最胜之法。欢喜合掌而白佛言。世尊。我于明日欲请如来并诸大众。唯愿哀愍而受我食。尔时世尊知彼童子意乐清净。亦知饶益无量众生。起大慈心默然受请。是时童子即从坐起。顶礼佛足右绕三匝。欢喜还家。与其眷属及诸天龙夜叉罗刹鸠槃荼等。皆共严饰王舍大城。于四衢道张施彩幔。其幔高广普覆一切。金绳交络珠缨垂布。师子幡带金药钩鬘。百千万种而校饰之。复有宝华其色殊特。丛厕错糅以为华鬘。薝卜迦华鬘目真邻陀华鬘。如是种种无量无数。于宝帐间周匝垂下。普遍大会一切庄严。又于其下敷诸床座。烧众宝香。毕力迦香。都摩遮香。栴檀郁金清净悦意。如是种种和合妙香。而为供养。复以香水遍洒街道。杂华覆地处处充满。尔时诸天童女。阿修罗女。摩睺罗女。其数无量心生欢喜。为欲成就菩提因故。俱来严饰最胜大城。月光童子知是城中普遍严净。食时已到前白佛言。愿为利益诸众生故。入是城。尔时如来。与其大众前入城门。当下足时。城中大地普皆震动。周遍十方百千亿刹。悉亦震动。于是时中。盲者能视。苦者得乐。聋者能听。色下劣者得妙好色。无财物者而得财物。无子得子。无衣得衣。无金宝者得诸金宝。无亲属者得诸亲属。若乏一切严身具者。普皆令得严身之具。复有诸鸟拘抧罗鸟鹦鹉孔雀。舍利迦罗。是诸众鸟。见如来已。生欢喜心出胜妙音。闻是音者能令意悦。如来复以神通之力。化作无量薝卜迦树。百千众生持彼净华并余妙香。散佛供养。复有百千阿修罗女摩醯首罗。持赤真珠及栴檀末。于如来上欢喜奉散。阿修罗众及余诸天。执持宝盖。皆是黄金白银之所校饰。于虚空中覆如来上。世尊复以神变之力。化作无量栴檀香树。百千金刚树。宝器衣服。如是等树无量无边。珍宝庄严华叶繁茂。一切众生福德之果而共成熟。微风吹动最胜妙香。流溢普遍无量佛土。百千众生俱持散佛。如是无量情与非情。皆是如来神通道力之所变化。若有希求以神变故。随彼意乐悉令充足。佛入城时一切大众。于虚空中闻殊妙声。其声演畅不可思议。亦复不知彼从何出。以百千颂宣说诸法

  尔时世尊方入城　　空中有声如是说
  了贪尽边常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪生边常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪边际常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪寂静常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪流转常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪无有常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪无生常空寂　　证其实性得菩提
  尔时世尊方入城　　空中有声如是说
  了贪寂灭常空寂　　证其实性得菩提
  嗔痴忿覆并嫉诳　　谄曲贡高憍慢忧
  苦集灭道及有情　　童男童女并妇女
  丈夫养育兼六根　　六尘四大性事物
  世间苦蕴界世生　　音声名等亦如是
  法王演说微妙音　　一切众生悉欢喜
  诸天世人共闻已　　乐欲住于如来乘
  尔时世尊方入城　　空中有声如是说
  佛于施力深爱乐　　由施力故证菩提
  尔时世尊方入城　　空中有声如是说
  佛于净戒深爱乐　　由净戒力证菩提
  尔时世尊方入城　　空中有声如是说
  佛于忍辱深爱乐　　由忍辱力证菩提
  尔时世尊方入城　　空中有声如是说
  佛于精进深爱乐　　由精进力证菩提
  尔时世尊方入城　　空中有声如是说
  佛于禅定深爱乐　　由禅定力证菩提
  尔时世尊方入城　　空中有声如是说
  佛于智慧深爱乐　　由智慧力证菩提
  神通福德智住力　　方便色力名称力
  业因缘友净信闻　　施相应力寂静力
  调伏实际谛善力　　所畏欢喜利爱乐
  慈悲喜舍忍无恼　　空无相等亦如是
  十力圣主天中尊　　功德名闻无等量
  当入胜城初下足　　广为饶益诸众生
  昔于三有修净业　　增长诸天众善行
  一切世间普宗仰　　闻我此说咸欢喜
  如来入城当下足　　城邑大地皆震动
  咸睹世尊清净光　　靡不渴仰生欣跃
  世尊入城广饶益　　人天大众心欢喜
  地及空行三有中　　皆叹如来善安乐
  世尊足轮初按地　　净光普照未曾有
  善马城中出妙声　　众鸟于空亦欢喜
  复有清净女人众　　手足环钏及璎鬘
  如是种种宝庄严　　不击自生微妙响
  各各互来相庆美　　同声共叹胜吉祥
  聋盲残缺得诸根　　皆是如来殊胜果
  世尊入城咸庆悦　　天人散华以供养
  普遍空中出妙声　　无量诸天大欢喜
  复有失念诸众生　　狂乱已除相庆慰
  女人怀妊生忧惧　　蒙光离苦得安乐
  或有惭愧诸男女　　为说离于垢染法
  皆生欢喜清净心　　顶礼最胜牟尼足
  或求如来无上道　　或求菩萨声闻乘
  犹入最胜栴檀城　　瞻仰尊容自欣庆
  佛慧善了于他行　　随顺世间作饶益
  殊胜法财与菩萨　　上妙珍宝施众生

  世尊当入城　　空中如是说
  若爱眼尽边　　于佛能尊重
  世尊当入城　　空中如是说
  若爱眼尽边　　于佛生净信
  若爱眼尽边　　得佛不坏信
  于净信相续　　由观眼尽边
  若爱眼尽边　　得法不坏信
  于净信相续　　由观眼尽边
  若爱眼尽边　　得僧不坏信
  于净信相续　　由观眼尽边
  若爱眼尽边　　得戒无取着
  于净戒相续　　由观眼尽边
  若爱眼尽边　　离恶趣贪欲
  舍离贪相续　　由观眼尽边
  若爱眼尽边　　离恶趣嗔恚
  舍离嗔相续　　由观眼尽边
  若爱眼尽边　　离恶趣愚痴
  舍离痴相续　　由观眼尽边
  若爱眼尽边　　则住菩提智
  菩提智相续　　由观眼尽边
  乃至眼生边　　边际及流转
  寂静并无有　　无生将寂灭
  如是等诸门　　皆同眼尽说
  若爱眼尽边　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼生边　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼边际　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼流转　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼寂静　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼无生　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼无有　　彼常无疑惑
  以无疑惑故　　即得佛神通
  若爱眼寂灭　　彼常无疑惑
  以无疑惑故　　即得佛神通
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  知眼生无边　　发起无边智
  以智无边故　　说此法亦然
  知眼尽无边　　于眼无障碍
  以无障碍故　　得佛无碍智
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  世尊入城时　　百千众生类
  闻空声说法　　于佛德无疑
  或虽起贪欲　　于佛智不坏
  或有起贪欲　　退失佛功德
  或虽起贪欲　　而求无上智
  勤修不共法　　不乐声闻乘
  愚人修习禅　　乐于禅定乐
  便起增上慢　　谓得沙门果
  愚人修习禅　　无眼尽边智
  设于百千劫　　彼终无解脱
  一切受生者　　于中皆染着
  若了生性空　　所见常清净
  若复修四禅　　无眼尽边智
  设经百千劫　　于禅不清净
  若证于等引　　无证尽边智
  不知证尽故　　常行于证漏
  若执着于想　　无想尽边智
  不知想尽故　　常行于想漏
  若乐着世间　　无世尽边智
  不知世尽故　　常行于世漏
  若住有漏心　　无心尽边智
  不知心尽故　　常行于心漏
  若住有漏法　　无法尽边智
  不知法尽故　　常行于法漏
  若具头陀法　　无眼尽边智
  不知眼尽故　　非实头陀者
  虽着坏色衣　　无眼尽边智
  不知眼尽故　　非实应法服
  虽生贵族家　　无眼尽边智
  不知眼尽故　　彼非家清净
  虽多畜眷属　　无眼尽边智
  速堕恶趣中　　眷属无能救
  虽善声明论　　无眼尽边智
  不知眼尽边　　非达声明者
  虽善诸工巧　　无眼尽边智
  不知眼尽故　　彼非工巧者
  虽于多问难　　一字广分别
  无眼尽边智　　彼非随义说
  虽学智者说　　不知密非密
  无眼尽边智　　于法无所得
  虽了种种言　　世论及诸法
  无眼尽边智　　如坠险攀藤
  虽善于声明　　推步吉凶相
  及文字音韵　　读诵皆穷了
  不知眼尽边　　彼等终无智
  虽明女人相　　邪语令迷惑
  按摩蠲劳法　　秘密之幻术
  不知眼尽边　　彼等终无智
  虽演说百宗　　一字无遗失
  不知眼尽边　　所说终无义
  如是眼生边　　边际与流转
  乃至于寂灭　　当知亦复然
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  虽读诵声论　　而悉了其义
  不知眼尽边　　彼终为下劣
  虽诵四围陀　　及咒皆通利
  不知眼尽边　　彼终为下劣
  如是眼生边　　边际与流转
  乃至于寂静　　当知亦复然
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是

大宝积经卷第三十二大宝积经卷第三十三

        唐天竺三藏菩提流志译

    出现光明会第十一之四

  世尊入城时　　无量诸众生
  闻空中所说　　得眼尽边智
  世尊入城时　　无量诸众生
  闻空中所说　　了知眼自性
  毕竟空无我　　皆获眼清净
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  贪嗔痴忿慢　　悭嫉诳贡高
  乃至于放逸　　当知亦复然
  世尊入城时　　无量众生类
  于上虚空中　　闻佛种种名
  或闻灭坏贪　　无有等比名
  或闻灭坏嗔　　利益世间名
  或闻了愚痴　　摧伏憍慢名
  或闻示世间　　寂静导师名
  或闻现智慧　　利益世间名
  或闻现方便　　饶益众生名
  或闻降伏魔　　无有怼恨名
  或闻以教法　　示现解脱名
  或闻广度脱　　诸苦众生名
  或闻人中尊　　运济世间名
  闻是诸名已　　皆得眼清净
  虚空及海水　　乃至于须弥
  一切皆可量　　佛智无穷尽

  若于眼尽得决定　　成就法身不为难
  若能成就胜法身　　当获无边总持智
  若获无边总持智　　彼悟无量诸契经
  若悟无量诸契经　　于佛神通不难得
  若于眼生得决定　　成就法身不为难
  若能成就胜法身　　当获无边总持智
  若获无边总持智　　彼悟无量诸契经
  若悟无量诸契经　　于佛神通不难得
  如是耳鼻舌身心　　色声香味并触法
  乃至音声及名等　　当知一切亦复然
  尔时大地皆震动　　大海诸山亦如是
  阿修罗众及诸天　　一切皆悉生欢喜
  魔及魔军摧谄曲　　咸求成就佛庄严
  诸天各处妙宫殿　　净心欢喜相庆言
  导师今已出世间　　为利一切人天众
  地居天众在本宫　　亦以净心相庆慰
  善哉导师今出现　　普为世间安乐因
  空行天众闻是言　　咸皆欢喜生净信
  以悦意声称叹佛　　导师出现利世间
  四王天众闻是言　　咸皆欢喜生净信
  以殊胜音称叹佛　　导师出现利世间
  忉利天众闻是言　　咸皆欢喜生净信
  以殊胜音称叹佛　　导师出现利世间
  夜摩天众闻是言　　咸皆欢喜生净信
  以殊胜音称叹佛　　导师出现利世间
  我等当发菩提心　　志求如来无上智
  依止天人最胜尊　　度脱一切众生类
  兜率天众闻是言　　咸皆欢喜生净信
  以殊胜音称叹佛　　导师出现利世间
  如来往昔俱胝劫　　修习无边殊胜行
  示苦众生安隐道　　令超生死证涅槃
  化乐天众闻是言　　咸皆欢喜生净信
  以殊胜音称叹佛　　导师出现利世间
  他化天众闻是言　　咸皆欢喜生净信
  以微妙声称赞佛　　导师出现利世间
  如来已度于生死　　降伏众魔并外道
  成就无上佛菩提　　拯济群生登彼岸
  诸梵天众闻是言　　咸皆欢喜生净信
  以微妙声称赞佛　　导师出现利世间
  如是展转声递闻　　诸梵眷属皆欣庆
  导师出现利世间　　魔军怖畏怀忧戚
  上至有顶诸天众　　闻佛出现利世间
  如是展转声遍闻　　修罗损减天增长
  恶魔宫殿悉空虚　　诸天眷属皆充满
  以无畏力降邪众　　速成最胜大菩提
  如是刹那天遍知　　世尊出现利群品
  善哉世间开导者　　以清净眼施众生

  世尊入城时　　贪欲逼恼者
  闻说不净观　　贪欲灭无余
  世尊入城时　　嗔恚逼恼者
  闻说慈悲法　　嗔恚灭无余
  世尊入城时　　愚痴逼恼者
  闻说智慧法　　愚痴灭无余
  世尊入城时　　憍慢逼恼者
  闻说离慢法　　憍慢灭无余
  世尊入城时　　嫉妒逼恼者
  闻说离嫉法　　嫉妒灭无余
  世尊入城时　　忿怒逼恼者
  闻说离忿法　　忿怒灭无余
  世尊入城时　　悭吝逼恼者
  闻说离悭法　　悭吝灭无余
  若修调伏行　　闻此无边法
  便入多闻海　　成就总持门
  又闻空中说　　以华供养佛
  成就胜功德　　大悲神变说
  又闻空中说　　赞叹如来身
  生处及种族　　言音悉殊胜
  如彼众生趣　　神通随类说
  眼耳鼻舌身　　若色若声等
  屈伸或俯仰　　所现皆殊胜
  如来超世间　　而作世灯炬
  示现诸色像　　皆佛神通力
  凡夫乐着色　　为现种种身
  随彼众生类　　说色无坚固
  若人多执着　　如来现神力
  随彼器非器　　为说相违法
  众生无量世　　未曾供养佛
  刚强难调伏　　为说于地狱
  若人迷业道　　依见乐戏论
  世尊令彼闻　　息见戏论声
  又闻空中说　　眼性决定空
  无来亦无去　　无相无所有
  又百千众生　　闻空中演说
  肉眼及慧眼　　乃至于法眼
  世尊神变力　　闻说戒定声
  智慧及解脱　　解脱知见声
  众生若干种　　如应现神变
  以随类言音　　演说真实法
  若有诸众生　　乐修施戒忍
  神通随类说　　施戒忍辱声
  世尊神变力　　随众生根性
  皆为广分别　　令受持演说
  世尊神变力　　闻说蕴界处
  缚解若远近　　地位差别相
  又闻说诸地　　无量智光明
  亦闻烦恼习　　有离有非离
  世尊神变力　　闻说人天性
  由业果不同　　受生有差别
  或于女人众　　化女庄严身
  空声说厌离　　闻者除贪欲
  若于舍利子　　深心有净信
  大悲随应现　　为说无上法
  拘律陀迦叶　　劫宾那难陀
  摩诃迦叶波　　及憍陈如等
  随彼所爱乐　　闻说声闻法
  天及阿修罗　　及诸夜叉众
  毗娄迦眷属　　无量鸠槃荼
  以佛神力闻　　陀罗弭拏咒

一致徙(一)毕致徙(一)瑿啰(上)苏(上)瑿啰(二)污囊(上)徙(四)曼(去)囊(上)徙(五)污企(上六)阿怒企(上七)阿乞差罗忙囊夷(八)陀啰尼儞瑟咤儞名(上九)多迦儞(十)伊(上)名满多啰(十一)儞呵(上引)啰(十二)阿不唎步底(十三)儞啰阿(去)察啰(十四)微耶乞里夜帝(十五)阿(去)察啰缚啰耳帝(十六)迦(上)罗嚩呬(去)宁(十七)萨攘微蛇呢底攘曩(十八)钵啰舍萨帝舍萨多(十九)钵啰舍萨多(二十)多啰[薩/女]多部名(上二十一)暗嚩啰暗嚩啰(二十二)丽罗嚩曩室者(二十三)质多微嚩耳多(二十四)质多阿难(上)多(二十五)乌闭啰呵嚩耳多部名(上二十六)囊南(上二十七)迦(上)尼(上)阿迦(上)尼(上)微嚩耳多(二十八)室丽瑟咤(二十九)阿么罗宁么罗(三十)弗(奔没反)理底曩啰始者(三十一)呵呵里(三十二)摩摩(上)里(三十三)吠啰妮(三十四)底瑟咤(三十五)斫刍怩呵啰(三十六)乌地哩多嚩枳(三十七)安吒哩(三十八)句吒哩(三十九)计都(四十)苏计都(四十一)素颇啰奶(四十二)迦啰奶(四十三)句素磨(上)儞曳(四十四)迦迦[口*((禾*ㄉ)/牛)](四十五)郤佉[口*((禾*ㄉ)/牛)](四十六)呜般罗暮[口*((禾*ㄉ)/牛)](四十七)底瑟咤呬(四十八)陀罗尼(四十九)那伽昵呵啰(五十)般啰罗也底(五十一)阿底般啰罗也底(五十二)頞哆啰般提(五十三)安多啰多嚩地失遮(五十四)呵呬哩(五十五)摩佉里(五十六)瑿妮三婆(去)[口*((禾*ㄉ)/牛)](五十七)底瑟咤呬(五十八)陀罗妮(五十九)[況*鳥](多霖反)蒲卢若提(六十)

  又以毗沙门　　提头赖吒等
  无数殊妙声　　说真实咒法
  如是无量声　　善逝神通说
  神通无有量　　所说亦无边
  或于无佛刹　　游戏神通力
  佛身众围绕　　亦如今所见
  于不思议刹　　现无量变化
  初生行七步　　舍王位出家
  道场成正觉　　思惟所得法
  为众转法轮　　示现入涅槃
  及以神变力　　演说种种法
  令无量众生　　成就殊胜智
  尔时大悲现　　诸梵众围绕
  为说修慈法　　增广于慈心
  尔时大悲现　　诸天众围绕
  为说四摄法　　增广四摄行
  尔时大悲现　　诸龙众围绕
  为说嗔恚过　　令舍嗔恚心
  尔时大悲现　　夜叉众围绕
  为说损害过　　令舍损害心
  尔时大悲现　　修罗众围绕
  为说斗诤过　　称赞修忍心
  尔时大悲现　　迦楼罗围绕
  为说乖违过　　称赞和合心
  尔时大悲现　　乾闼婆围绕
  以无边爱语　　称赞于如来
  尔时大悲现　　摩睺众围绕
  呵毁外道法　　称赞如来教
  尔时大悲现　　鬼神众围绕
  广称赞如来　　希有诸功德
  大悲现神变　　令百千众生
  闻说眼尽边　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼生边　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼边际　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼流转　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼寂静　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼无有　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼无生　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼寂灭　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼无我　　究竟能通达
  大悲现神变　　令百千众生
  闻说眼无人　　究竟能通达
  大悲现神变　　令百千众生
  闻眼无众生　　究竟能通达
  大悲现神变　　令百千众生
  闻眼无命者　　究竟能通达
  大悲现神变　　令百千众生
  闻眼无养育　　究竟能通达
  大悲现神变　　广为诸众生
  呵责于世智　　不令起爱着
  大悲现神变　　广为诸众生
  呵责于世利　　赞无为功德
  大悲现神变　　广为诸众生
  呵责有漏智　　赞诸无漏慧
  大悲现神变　　广为诸众生
  呵责世间禅　　称扬出世定
  大悲现神变　　广为诸众生
  呵责有漏戒　　赞无漏学处
  大悲现神变　　广为诸众生
  呵责小心过　　称扬大心德
  大悲现神变　　称赞修身戒
  乃至于心慧　　无漏无所依
  大悲现神变　　称赞灭苦道
  乐着戏论人　　诸佛所呵责
  大悲现神变　　广为诸众生
  分别眼断过　　开示寂灭相
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是
  大悲现神变　　广为诸众生
  盛年少壮者　　示以无边过
  大悲现神变　　广为诸众生
  生处憍逸者　　示以无边过
  大悲现神变　　广为诸众生
  种姓憍逸者　　示以无边过
  大悲现神变　　广为诸众生
  受用放逸者　　示以无边过
  大悲现神变　　广为诸众生
  自在放逸者　　示以无边过
  大悲现神变　　广为诸众生
  于色放逸者　　示以无边过
  大悲现神变　　广为诸众生
  女人放逸者　　示以无边过
  大悲现神变　　广为诸众生
  衣服放逸者　　示以无边过
  大悲现神变　　广为诸众生
  于酒放逸者　　示以无边过
  大悲现神变　　广为诸众生
  为王放逸者　　示以无边过
  大悲现神变　　广为诸众生
  于戒放逸者　　示以无边过
  大悲现神变　　广为诸众生
  智慧放逸者　　示以无边过
  如是觉神通　　禅巧增上慢
  财说明眷属　　音乐及歌咏
  是名称赞叹　　供养并利养
  美妙诳谄憍　　无惭及无愧
  贡高具足慢　　放逸贪亦然
  大悲现神变　　开示诸众生
  心意下劣者　　为说殊胜想
  大悲现神变　　开示诸众生
  自轻退屈者　　为说精进力
  大悲现神变　　开示诸众生
  贪着财物者　　为说知足法
  又化香宫殿　　及以华宫殿
  皆挟妙楼阁　　化佛于中坐
  又化诸天女　　住薝卜华宫
  皆现于半身　　持华鬘供养
  又化诸天女　　住婆师华宫
  皆现于半身　　持金鬘供养
  又化修罗女　　住摩利华宫
  皆现于半身　　持花鬘供养
  又化诸天女　　住青莲华宫
  皆现于半身　　称赞佛功德
  又化诸梵天　　坐真金宫殿
  而现于全身　　慈声称叹佛
  又化诸天女　　种种庄严身
  环佩牙樘触　　出微妙音声
  说诸有为法　　迁变无坚固
  愚人妄分别　　不能如实知
  如是严具声　　不从身心出
  无去亦无来　　亦无有方所
  乃至于色心　　一切皆如是
  愚者不能思　　于此生疑惑
  如是庄严具　　所出妙音声
  闻于百千刹　　解脱无量众
  汝等当观察　　导师自然智
  无边功德身　　超过爱戏论
  寂静无诸过　　离见治心翳
  相好以庄严　　身意皆清净
  汝观佛入城　　犹如师子步
  鹅王象王行　　满足众生愿
  成就殊胜福　　真实相庄严
  普令诸众生　　瞻仰无厌足
  汝观两足尊　　具大慈心者
  虽以少物施　　获无量功德
  能令诸众生　　于多百千劫
  乃至证涅槃　　果报无穷尽
  汝观两足尊　　成就无漏戒
  令诸众生等　　恭敬而顶礼
  无量诸天众　　各舍其宫殿
  不耽乐游戏　　亲近于导师
  汝观魔及民　　于佛生信乐
  咸持金柄扇　　侍奉于左右
  五百诸魔子　　以天悦意华
  共散于如来　　希求无上慧
  曾于过去佛　　称赞而供养
  今者遇世尊　　各各怀欣庆
  亦以无量辩　　赞叹于如来
  尔时有魔子　　名为舍爱者
  最初称赞佛　　能知眼尽边
  亦了眼生边　　乃至寂灭相
  又知眼尽等　　无边名义句
  以善巧言词　　为众生演说
  而于名义中　　无著无疑惑
  了知无去来　　无取亦无舍
  自性常空寂　　远离于文字
  亦无能受持　　读诵修行者
  往昔诸如来　　已曾广开示
  得以假名字　　而实无所说
  如是自性空　　超过蕴界处
  无妄无真实　　亦无处非处
  乃至言语断　　心行处亦灭
  愚夫着相故　　见佛有入城
  世尊离诸相　　愚人妄分别
  世尊入城时　　若人生欢喜
  是则相分别　　当必怀忧戚
  若离相分别　　则不见入城
  乃至行动相　　得无分别慧
  若以相见佛　　则见有入城
  于生转法轮　　一切皆分别
  若以相见佛　　乃至生欢喜
  彼人住魔行　　魔境常现前
  若以相见佛　　当见于变异
  是人懒忧戚　　智者应怜愍
  于法若见得　　便有失法忧
  于佛若见生　　则有涅槃苦
  若多劫修行　　了知一切相
  不分别入城　　亦无涅槃想
  若了心相空　　则住佛行处
  不分别入城　　亦无涅槃想
  若人如是知　　则见于诸佛
  亦能了性空　　毕竟无生灭
  世尊无量劫　　修习诸苦行
  为证于性空　　愚人不能了
  世尊入城时　　百千众围绕
  人及非人等　　净心而供养
  若于刹那顷　　思惟眼尽边
  了达诸相空　　其福复过彼
  乃至算数分　　皆所不能及
  如是眼生边　　边际与流转
  乃至于寂灭　　当知亦复然
  耳鼻舌身心　　色声香味触
  乃至音声名　　一切皆如是

  尔时世尊　　当入城时　　以足按地
  普皆震动　　诸山倾靡　　悉向于佛
  人天为法　　咸来恭敬　　尔时世尊
  当入城时　　天主人王　　阿修罗众
  并诸夜叉　　各舍本城　　来诣佛所
  欢喜供养　　尔时世尊　　当入城时
  复有无量　　异类诸鸟　　鹦鹉孔雀
  迦陵频伽　　睹佛如来　　殊胜功德
  于虚空中　　欢喜游戏　　皆出种种
  微妙音声　　尔时世尊　　当入城时
  以佛功德　　威神力故　　能令无量
  百千众生　　盲者能视　　聋者能听
  不完具者　　令得完具　　不安乐者
  令得安乐　　尔时世尊　　当入城时
  于虚空中　　闻如是说　　若以诸相
  分别如来　　是人不名　　供养于佛
  亦不了知　　眼尽边性　　若离诸相
  殖众德本　　则能了知　　眼尽边性
  以能了知　　眼尽边故　　则能了知
  诸佛功德　　于眼尽边　　无有执藏
  于眼生边　　无有依止　　于眼寂静
  无有动念　　是人则为　　见于如来
  于眼生边　　无有分别　　于眼边际
  无有意谓　　于眼灭坏　　无有表示
  是人则为　　见于如来　　于眼无有
  无有染着　　于眼无生　　无有摄受
  于眼寂灭　　无有所执　　是人则为
  见于如来　　知眼尽故　　于根修习
  知眼边故　　于根决定　　知眼生故
  于根自在　　是人则为　　见于如来
  知眼无有　　于色了达　　知眼灭坏
  于法观察　　知眼无生　　于道修习
  是人则为　　见于如来　　如实了知
  眼尽边故　　于业差别　　亦能了知
  以能了知　　业差别故　　是人则为
  见于如来　　如实了知　　眼生边故
  于苦差别　　亦能了知　　以能了知
  苦差别故　　是人则为　　见于如来
  如实了知　　眼灭坏故　　于苦灭坏
  亦能了知　　以能了知　　苦灭坏故
  是人则为　　见于如来　　如实了知
  眼无有故　　于离诸相　　亦能了知
  以能了知　　离诸相故　　是人则为
  见于如来　　如实了知　　眼无生故
  于离习气　　亦能了知　　以能了知
  离习气故　　是人则为　　见于如来
  又如实知　　眼无常性　　于离障碍
  亦能了知　　以能了知　　离障碍故
  是人则为　　见于如来　　又如实知
  眼无文字　　于佛智力　　亦能了知
  以能了知　　佛智力故　　是人则为
  见于如来　　又如实知　　眼不来性
  于离诸欲　　亦能了知　　以能了知
  离诸欲故　　是人则为　　见于如来
  又如实知　　修习禅定　　于离烦恼
  亦能了知　　以能了知　　离烦恼故
  是人则为　　见于如来　　彼人亦能
  成就如是　　眼前际智　　眼无住智
  眼无生智　　佛神通智　　眼下劣智
  眼殊胜智　　智下劣智　　智清净智
  戒清净智　　身律仪智　　声清净智
  语律仪智　　心清净智　　处差别智
  诸心法智　　心过失智　　业清净智
  心律仪智　　智过失智　　声清净智
  蕴差别智　　蕴因缘智　　眼遍知智
  苦出生智　　无漏戒智　　戒因缘智
  苦因缘智　　苦因尽智　　诸有为智
  尽无尽智　　又如实知　　十二因缘
  有所行智　　无所行智　　有相无相
  有为无为　　建立摄受　　自他心智
  又如实知　　眼尽生边　　边际寂静
  乃至流转　　无有无生　　寂灭之性
  令诸众生　　得清净智　　诸势力智
  精进之智　　又如实知　　一异门智
  一切众生　　意乐之智　　又如实知
  一切众生　　殊胜意乐　　心清净智
  业异熟智　　诸根界智　　心变异智
  慧解脱智　　遍解脱智　　胜辩才智
  又如实知　　诸恶众生　　不乐法者
  令渴仰智　　又如实知　　于诸理趣
  知时修习　　无懈怠智　　又如实知
  神通之力　　分析诸法　　无障碍智
  又如实知　　于广大义　　及以言教
  随解了智　　又如实知　　善友同处
  衣服饮食　　节量之智　　又如实知
  于诸无作　　陀罗尼法　　勤修习智
  又如实知　　身心无过　　远离增减
  求无上智　　又如实知　　神通威力
  于虚空中　　现变化身　　成就无量
  百千众生　　皆令欢喜　　发净信智
  于诸如来　　乐尊重智　　于离欲法
  乐修习智　　于诸圣众　　乐供养智
  于大菩提　　乐回向智　　于陀罗尼
  乐演说智　　于诸意乐　　善观察智
  于圣者定　　善了知智　　于诸护念
  能决定智　　于无边心　　善趣入智
  于无边颂　　能演说智　　于诸欲结
  能觉悟智　　于下劣趣　　不堕落智
  于恶知识　　应舍离智　　于善知识
  能亲近智　　于诸问答　　能决择智
  于处非处　　能解了智　　于地非地
  能了知智　　于上中下　　能分别智
  有为之智　　无为之智　　事物之智
  非事物智　　摄受之智　　非摄受智
  修习之智　　非修习智　　眼非眼智
  眼共相智　　眼差别智　　眼自性智
  耳鼻舌身　　乃至名等　　二十五法
  亦复如是　　若人思惟　　眼因缘性
  真实空寂　　毕竟无我　　是人则能
  成就如是　　真实决定　　心三摩地
  若人思惟　　眼因缘起　　决定了知
  眼无常相　　是人则能　　如实了知
  眼及因缘　　毕竟无有　　耳鼻舌身
  乃至名等　　二十五法　　亦复如是
  尔时世尊　　当入城时　　以足按地
  现希有事　　我今略说　　少分功德
  普令众生　　闻者欢喜　　天人导师
  从一毛孔　　出现无量　　百千光明
  一一光明　　遍无量刹　　为诸众生
  而作佛事　　若人往昔　　供养诸佛
  长夜修行　　布施持戒　　彼人得闻
  如是所说　　神变之事　　欢喜爱乐
  若能了知　　诸佛神变　　非诸声闻
  所行境界　　彼人得闻　　如是神变
  当生信解　　发希有心　　天人导师
  不思议力　　现如是等　　种种神变
  能令无量　　百千众生　　于诸如来
  亲近供养　　天人导师　　不思议力
  演说无量　　百千契经　　令诸众生
  闻其所说　　皆能信受　　心生欢喜
  尔时世尊　　当入城时　　以神通力
  于虚空中　　作如是说　　知眼尽边
  乃至寂灭　　眼性所因　　无去无来
  毕竟空寂　　耳鼻舌身　　乃至名等
  二十五法　　亦复如是

  尔时世尊　　当入城时　　于虚空中
  出微妙声　　称赞如来　　种种名号
  令诸大众　　生信解心　　今现在世
  人中师子　　名为摧伏　　魔军法王
  若有得闻　　如是名者　　则能降伏
  一切邪众　　今现在世　　人中师子
  名为摧灭　　贪欲法王　　若有得闻
  如是名者　　则能舍离　　一切贪欲
  今现在世　　人中师子　　名为摧灭
  嗔恚法王　　若有得闻　　如是名者
  则能舍离　　一切嗔恚　　今现在世
  人中师子　　名为摧灭　　愚痴法王
  若有得闻　　如是名者　　则能舍离
  一切愚痴　　今现在世　　人中师子
  名为摧灭　　憍慢法王　　若有得闻
  如是名者　　则能摧灭　　一切憍慢
  今现在世　　人中师子　　名为摧灭
  忿恚法王　　若有得闻　　如是名者
  则能舍离　　一切忿恚　　今现在世
  人中师子　　名为摧灭　　嫉妒法王
  若有得闻　　如是名者　　则能舍离
  一切嫉妒　　今现在世　　人中师子
  名为摧灭　　虚诳法王　　若有得闻
  如是名者　　则能舍离　　一切虚诳
  今现在世　　人中师子　　名为摧灭
  诸见法王　　若有得闻　　如是名者
  则能舍离　　一切诸见　　今现在世
  人中师子　　名为摧灭　　戏论法王
  若有得闻　　如是名者　　则能舍离
  一切戏论　　今现在世　　人中师子
  名为正法　　清净法王　　若有得闻
  如是名者　　则能解了　　清净之法
  今现在世　　人中师子　　名为通达
  诸业法王　　若有得闻　　如是名者
  则能解了　　一切诸业　　今现在世
  人中师子　　名为具足　　神通法王
  若有得闻　　如是名者　　则能成就
  威德神通　　今现在世　　人中师子
  名为具足　　诸度法王　　若有得闻
  如是名者　　则能成就　　六波罗蜜
  今现在世　　人中师子　　名为了达
  诸行法王　　若有得闻　　如是名者
  则能了达　　一切诸行　　今现在世
  人中师子　　名生清净　　光明总持
  若有得闻　　如是名者　　则能成就
  殊胜受生　　今现在世　　人中师子
  名色清净　　光明总持　　若有得闻
  如是名者　　则能成就　　殊胜妙色
  今现在世　　人中师子　　名身清净
  光明总持　　若有得闻　　如是名者
  则能成就　　殊胜色身　　今现在世
  人中师子　　名性清净　　光明总持
  若有得闻　　如是名者　　则能成就
  殊胜种族　　今现在世　　人中师子
  名为名称　　光明总持　　若有得闻
  如是名者　　则能成就　　广大名称
  今现在世　　人中师子　　名为布施
  持戒忍辱　　精进禅定　　智慧总持
  若有得闻　　如是名者　　则能成就
  布施持戒　　乃至智慧　　陀罗尼门
  今现在世　　人中师子　　名为成就
  空性法王　　若有能持　　如是名者
  则能演说　　诸法空义　　今现在世
  人中师子　　名为成就　　无我法王
  若有能持　　如是名者　　则能演说
  无生灭义　　今现在世　　人中师子
  名眼清净　　总持法王　　若有能持
  如是名者　　则能演说　　眼尽边义
  耳鼻舌身　　乃至名等　　二十五法
  并华鬘香　　灯伞衣服　　悉皆如是

大宝积经卷第三十三大宝积经卷第三十四

        唐天竺三藏菩提流志译

    出现光明会第十一之五

  尔时世尊　　当入城时　　以不思议
  神通之力　　于虚空中　　出微妙声
  演说种种　　陀罗尼行　　令诸大众
  闻如是言　　是陀罗尼　　于眼尽边
  生边边际　　寂静流转　　乃至寂灭
  如是诸法　　皆能通达　　究竟安住
  以布施力　　究竟摄取　　以持戒力
  究竟成就　　以忍辱力　　究竟庄严
  以精进力　　究竟发起　　以智慧力
  究竟宣说　　离诸文字　　语言音声
  乃至色心　　究竟清净　　有漏无漏
  若义若利　　皆悉空寂　　究竟清净
  亦不依止　　一切诸有　　究竟安住
  总持三昧　　无去无来　　非善不善
  乃至无记　　自利利他　　如是诸相
  究竟清净　　亦不安住　　自在威德
  声闻凡夫　　诸佛之法　　亦不安住
  于眼尽边　　生边边际　　乃至寂灭
  如是诸行　　究竟寂静　　若生不生
  是苦是乐　　称赞毁谤　　皆悉舍离
  究竟清净　　究竟照明　　空陀罗尼
  之所解了　　此即住佛　　所行之处
  此即住佛　　游戏之处　　此即安住
  诸佛神通　　此即安住　　诸佛智慧
  安住如是　　眼尽边力　　安住如是
  眼生边力　　安住如是　　眼边际力
  乃至安住　　寂灭之力　　耳鼻舌身
  乃至名等　　二十五法　　亦复如是
  是陀罗尼　　成就如来　　殊胜之力
  是陀罗尼　　成就如是　　威德之力
  入诸如来　　一切行处　　住诸如来
  一切境界　　令诸世间　　于修罗众
  离坚固心　　住梵天行　　能令无量
  百千夜叉　　及鸠槃荼　　皆生欢喜
  亦令无量　　乾闼婆众　　并诸罗刹
  爱乐调伏　　假使梵众　　以妙音声
  于其句义　　不能宣说　　非诸心法
  之所计度　　亦非心法　　之所受持
  是陀罗尼　　非眼所得　　是陀罗尼
  亦不至身　　是陀罗尼　　非眼所得
  亦不至于　　眼所行处　　耳鼻舌身
  乃至名等　　二十五法　　亦复如是
  又说于眼　　尽边生边　　边际流转
  乃至寂灭　　无我无人　　众生寿者
  乃至无有　　补特伽罗　　无相无为
  不来不去　　如是等相　　皆悉了知
  又说了知　　法性之眼　　又说了知
  法成就眼　　智眼慧眼　　梵眼天眼
  梵生得眼　　天生得眼　　梵异熟眼
  天异熟眼　　梵因生眼　　天因生眼
  天神变眼　　天精进眼　　下劣生眼
  珠胜生眼　　舍离阎罗　　世间之眼
  龙夜叉眼　　鸠槃荼眼　　热恼之眼
  非热恼眼　　清净之眼　　非清净眼
  广狭之眼　　声闻乘眼　　禅定之眼
  三摩地眼　　境界之眼　　想出生眼
  贪出生眼　　贪舍离眼　　从因生眼
  非因生眼　　相应之眼　　不相应眼
  依门生眼　　非门生眼　　因缘生眼
  因门生眼　　非肉成眼　　智清净眼
  无所有眼　　不可得眼　　耳鼻舌身
  乃至名等　　二十五法　　亦复如是
  尔时世尊　　于虚空中　　复出无量
  微妙音声　　演说殊胜　　陀罗尼法
  皆是如来　　之所变化　　陀罗尼曰

呬丽(一)么丽么丽(二)赐(上)弟(三)伊(去)泥(四)弭(上)泥(五)句路尔庾(二合六)句路尔庾(二合七)句丽(八)么丽(九)句拏(上)帝(十)阿啰(二合)艺(十一)阿呬丽(十二)弭弭丽帝(十三)素弭丽(十四)弭丽弭丽(十五)弃比丽(十六)阿比丽(十七)素帝替(十八)驮奶(十九)么奶(二十)伽(上二十一)伽(上)唎帝(二十二)素伽(上)[口*((禾*ㄉ)/牛)](二十三)钵唎(二合)野然曩泥(二十四)阿努卢弭计(上二十五)微[口*路]迷(去二十六)素婆涅里(二合)世(二十七)阿施唎丽(二十八)萨么钵啰(二合)本帝(二十九)钵啰尾醯(三十)陀罗尼(三十一)底瑟耻呵(三十二)素底(引)阿替(三十三)步攘伽(上)伽曩(三十四)躬(去)盘拏(三十五)嚩娑(引)嚩曩(三十六)播唎妒(引)里野(二合)宁(三十七)钵唎伽(上)拏宁(三十八)么曩娑(三十九)素路指多(四十)钵那(四十一)恶察啰(四十二)阿毗罗(引)比野(二合四十三)钵啰(二合)底瑟咤诃(四十四)陀罗尼(四十五)阿(引)耳多(四十六)虞泥(去)毗(四十七)

  如是陀罗尼　　诸佛之所得
  具足大威神　　智慧无边量
  远离于执着　　念处悉清净
  无色无去来　　非方及方所
  无相离言说　　超过诸戏论
  菩萨勤修习　　究竟得清凉
  假使以百千　　那由他偈颂
  演说于一句　　不能得其边
  众圣之所赞　　清净无染着
  一切诸众会　　皆悉生尊重
  如是陀罗尼　　善法威神力
  能摧灭烦恼　　令得于胜利
  功德及智慧　　广大犹如海
  成就忍辱力　　其心安不动
  菩萨常修习　　智者所称叹
  舍离于贫穷　　当获大财宝
  如是陀罗尼　　增长诸功德
  常以空性等　　真实句庄严
  以舍于文字　　名之为空性
  以舍于心识　　名之为法性
  如是陀罗尼　　离垢常清净
  安住于实智　　现种种饶益
  令诸众生等　　欢喜发净心
  无量夜叉众　　及于鸠槃荼
  如是众鬼王　　亦生大欢喜
  如是陀罗尼　　寂静无戏论
  爱乐于众生　　普皆与安乐
  于多百千劫　　常在于诸趣
  作无量利益　　清净无所染
  或以百千偈　　演说甘露法
  令无量众生　　皆生大欢喜
  往昔无量佛　　以清净意乐
  于是陀罗尼　　常思惟法性
  释梵诸天众　　龙王阿修罗
  闻此陀罗尼　　心生大欢喜
  如是陀罗尼　　所经诸国土
  常无有灾难　　病苦及忧恼
  一切诸众生　　各各皆欣乐
  愿此陀罗尼　　常住于我心
  如是陀罗尼　　随所在身心
  喉齶及唇舌　　生无量功德
  若能常受持　　获无量功德
  利益多众生　　皆令得欢喜
  如是陀罗尼　　舍离诸过恶
  演说微妙法　　得无尽辩才
  令百千众生　　皆断除疑惑
  摧破诸憍慢　　获无量功德
  如是陀罗尼　　甚深微密法
  智者常思惟　　勇猛勤修习
  被于智慧甲　　摧灭诸烦恼
  增长功德已　　爱乐无厌足
  如是陀罗尼　　具广大名称
  能了尽无尽　　生边无生边
  以如是智慧　　种种自庄严
  百千诸如来　　尊重而供养
  如是陀罗尼　　明行为两足
  依止于胜定　　趣向菩提道
  随顺于止观　　通达无漏慧
  以净信根力　　成就于二手
  以精进忍辱　　成就于两乳
  智慧波罗蜜　　而为其顶相
  修多罗为线　　贯穿四辩鬘
  往昔所修行　　种种诸功德
  及无量譬喻　　一切悉庄严
  如是陀罗尼　　具无量功德
  于眼前后际　　尽边无尽边
  若生若无生　　边际非边际
  寂静不寂静　　流转非流转
  无有及无起　　寂灭并无我
  无人无寿者　　乃至无众生
  如是无量门　　一切皆解了
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  如上所称叹　　微妙陀罗尼
  寂静胜功德　　诸佛之境界
  陀罗尼实义　　非文字诠表
  随顺于世间　　但以假名说

尔时世尊。与诸大众到童子家。敷座而坐。是时月光童子。知佛坐已。躬自赍持微妙供具。奉献如来及诸大众。其供纯以禅定福德殊胜善根不思议力之所成熟。如是施时亦不为己。普令一切无量众生。发趣菩提获大善利。其供周遍皆悉充足。尔时世尊饭食已讫。于众会中。告月光童子言。童子。若善男子善女人等。住大乘者行施资粮。有八十种殊胜功德。云何八十。所谓成熟众生善言摄受。妙相圆满。诸根无缺。舍离生死。证于涅槃。尽诸结使。得胜自在。具足功德。庄严佛土。眷属清净。有大威德。具足智慧。成就最上殊胜之行。圆满无上无等等行。除灭习气。增长如来一切智行。身及舍利为诸世间声闻缘觉之所供养。摧破恶人。能令人王天龙夜叉阿修罗王迦楼罗王及梵天王皆生清信。有大威德。宣说契经。应颂。受记。自说。讽诵。譬喻。因缘。本事。本生。方广。希法。乃至论义。受持演说心无懈惓。于法无吝。安住佛道。世界最胜。名色清净。证于法身。得无所畏。成就福德。蔽诸外道。具善人法。舍恶人行。信福智因。和合佛法。降伏众魔。于佛所说安乐之法无有疑惑。摧破恶欲。具大威德。修菩萨行。得胜神通。舍离生死。成就众生。赞无边行。摄受功德。慰喻众生。受用法乐。修行惠施。入大智门。住于暖法。种性决定。修行法忍。安住佛道。童子。若善男子善女人等。修施资粮。具足成就是八十种殊胜功德。尔时世尊。复说偈言

  大智诸菩萨　　具足施资粮
  胜利有八十　　我今已略说
  复有诸功德　　无量难思议
  皆从布施生　　今当少宣说
  汝以平等施　　普遍于大会
  如是施资粮　　智者应修习
  此施能积集　　福聚不思议
  相好庄严身　　一切皆圆满
  生处及种族　　国土若居家
  名称与色心　　一切皆清净
  诸天神变事　　及宫殿婇女
  清净无碍辩　　皆从布施生
  布施胜资粮　　诸佛咸称叹
  此即是菩提　　最初安住本
  精进诸菩萨　　于施无疑惑
  安住决定心　　勤修于布施
  如是布施心　　成就殊胜福
  菩萨勤修习　　当证佛菩提
  由布施威力　　成就胜神通
  振动俱胝刹　　不损诸众生
  由布施能引　　净戒及多闻
  正信与精进　　三昧无漏慧
  由布施能引　　根力菩提分
  正断及神足　　远离诸习气
  由布施能引　　清净妙音声
  于百俱胝刹　　开示无边法
  由净信行施　　速得诸神通
  为成就神通　　应勤修布施
  无量诸天众　　百千阿修罗
  龙神及夜叉　　眷属共围绕
  咸乘妙楼阁　　自在而游戏
  如是等诸王　　见勤行施者
  皆当起远迎　　敷座而供养
  如是行施人　　具足大威德
  自在神通力　　摄受诸天王
  鸠槃荼夜叉　　皆悉来归伏
  及乾闼婆众　　亦献诸音乐
  贼害起慈心　　恶人当远离
  珍财无损减　　库藏悉充盈
  以修布施故　　成就胜资粮
  乃至于佛智　　不行外道法
  是人无病恼　　守护陀罗尼
  得诸殊胜力　　皆由布施生
  如是行施人　　修习菩提道
  不遇恶知识　　得同类善友
  复有诸菩萨　　积集施资粮
  成就不思议　　陀罗尼智慧
  以无量偈颂　　演说于总持
  一切无挂碍　　不失于本义
  广大菩提心　　志愿常坚固
  具足于净戒　　舍离诸魔业
  不着五欲乐　　专精求正念
  心常无迷惑　　亦不生贪爱
  嗔恚诸烦恼　　如实皆了知
  于一切境界　　不着不迷惑
  是人善了知　　如是诸烦恼
  以因缘和合　　能生诸过失
  乃至于佛法　　若因若因因
  如是因作用　　一切皆能了
  是人能了知　　眼尽边因性
  远离诸迷惑　　于眼无所染
  是人能了知　　眼生边边际
  寂静与流转　　无有及无生
  乃至于寂灭　　如是等因性
  远离诸迷惑　　于眼无所染
  是人能了知　　眼前际言说
  随世假安立　　于中无有实
  是人能了知　　眼后际言说
  随世假安立　　于中无有实
  是人能了知　　眼生边边际
  寂静与流转　　无有及无生
  乃至于寂灭　　如是等言说
  随世假安立　　于中无有实
  是人能了知　　眼前际言说
  但因缘和合　　于中无所著
  是人能了知　　眼后际言说
  但因缘和合　　于中无所著
  是人能了知　　眼生边边际
  寂静与流转　　无有及无生
  乃至于寂灭　　如是等言说
  但因缘和合　　于中无所著
  是人能了知　　眼前际言说
  自性无表示　　于中无所染
  是人能了知　　眼后际言说
  自性无表示　　于中无所染
  是人能了知　　眼生边边际
  寂静与流转　　无有及无生
  乃至于寂灭　　如是等言说
  自性无表示　　于中无所染
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  是人能了知　　贪欲即佛道
  自性无差别　　于贪无所染
  一切诸佛道　　当于烦恼求
  知性无差别　　是入总持门
  说贪是总持　　总持即是贪
  知性无差别　　是学总持门
  如是供养贪　　即为供养佛
  以供养佛故　　成就总持门
  是人能了知　　嗔恚即佛道
  自性无差别　　于嗔无所染
  嗔即是总持　　总持即是嗔
  知性无差别　　是学总持门
  如是供养嗔　　亦为供养佛
  以供养佛故　　成就总持门
  是人能了知　　愚痴即佛道
  自性无差别　　于痴无所染
  若如实了知　　痴性之边际
  是则修佛道　　成就总持门
  痴即是总持　　总持即是痴
  知性无差别　　是学总持门
  如是供养痴　　即为供养佛
  以供养佛故　　成就总持门
  如是供养痴　　即为供养法
  以供养法故　　成就总持门
  如是供养痴　　即为供养僧
  以供养僧故　　成就总持门
  如是供养痴　　即为供养戒
  以供养戒故　　成就总持门
  如是供养痴　　即供养精进
  供养精进故　　成就总持门
  如是供养痴　　即供养赞叹
  供养赞叹故　　成就总持门
  如是供养痴　　即供养佛法
  供养佛法故　　成就总持门
  如是供养痴　　即供养法性
  供养法性故　　成就总持门
  如是供养痴　　即供养真如
  供养真如故　　成就总持门
  如是供养痴　　即供养无生
  供养无生故　　成就总持门
  如是供养痴　　即供养无灭
  供养无灭故　　成就总持门
  如是供养痴　　即供养无尽
  供养无尽故　　成就总持门
  如是供养痴　　即供养无有
  供养无有故　　成就总持门
  如是供养痴　　即供养无边
  供养无边故　　成就总持门
  如是供养痴　　即供养三有
  供养三有故　　成就总持门
  如是供养痴　　即供养寂静
  供养寂静故　　成就总持门
  如是供养痴　　即供养流转
  以供养转故　　成就总持门
  如是供养痴　　即供养无转
  供养无转故　　成就总持门
  如是供养痴　　即供养无有
  供养无有故　　成就总持门
  如是供养痴　　即供养无起
  供养无起故　　成就总持门
  如是供养痴　　即供养寂灭
  供养寂灭故　　成就总持门
  如是供养痴　　即供养不来
  供养不来故　　成就总持门
  如是供养痴　　即供养无行
  供养无行故　　成就总持门
  如是供养痴　　即供养有为
  供养有为故　　成就总持门
  如是供养痴　　即供养苦等
  以供养苦等　　成就总持门
  如是供养痴　　即供养苦智
  供养苦智故　　成就总持门
  如是供养痴　　即供养集智
  供养集智故　　成就总持门
  如是供养痴　　即供养灭智
  供养灭智故　　成就总持门
  如是供养痴　　即供养道智
  供养道智故　　成就总持门
  如是供养痴　　即供养法智
  供养法智故　　成就总持门
  如是供养痴　　即供养类智
  供养类智故　　成就总持门
  如是供养痴　　供养无生智
  供养无生故　　成就总持门
  如是供养痴　　即供养尽智
  供养尽智故　　成就总持门
  如是于正断　　念住并神足
  五根及五力　　七觉八道支
  兼彼奢摩他　　毗般舍那等
  于斯九种法　　一切皆如是

尔时世尊。告月光童子言。善男子。若有众生住于大乘。为欲成就如上所说陀罗尼者。应当远离八十种人。云何八十。所谓杀父。害母。杀阿罗汉。以屠害心出佛身血。破和合僧。贼住出家。无根二根。邪见。邪思惟。邪语。邪业。邪命。邪精进。邪念。邪定。不知处。不知时。不知法。不知道。不知量。不知自他。于佛法僧并诸学处不能尊重。于不放逸及殊胜境亦不宗仰。不知法。不知律。不知学处。不知其罪若重若轻。不知其戒是毁是缺。又不知行若细若粗。亦不知业未来现在。于下劣事亦不了知。赞声闻乘毁如来法。劝导开示辟支佛乘远离厌舍无上正道破戒。破见。破诸威仪。行于非道。说有我人。说有众生。说有命者。说有补特伽罗。志意下劣。起贪嗔痴。断见。常见空无因见。不见有。不见无。不见业。不见精进。不知业。不知业因。不知异熟。不知异熟因。不知诸根。不知诸根因不知界。不知界因。不知解脱。不知解脱因。不知道。不知道因。不知烦恼。不知烦恼因。不知施。不知施因。不知前际及于后际。不知前际及后际因。不知生死。不知生死因。不知有漏。不知有漏因。不知尽非尽。不知有非有。不知边际非边际。不知寂静非寂静。不知转非转。不知性非性。不知生非生。不知灭非灭。童子。若善男子善女人等。为欲成就如上所说陀罗尼者。应当舍离是八十种非法之人。尔时世尊。复说偈言

  若不了于眼　　生尽之边际
  是人迷总持　　智者应远离
  若能了于眼　　无我无众生
  是人住总持　　智者应亲近
  若能了于眼　　生尽离文字
  是人住总持　　智者应亲近
  若能了于眼　　寂静无所住
  是人住总持　　智者应亲近
  若能了于眼　　自性无所住
  是人住总持　　智者应亲近
  若能了于眼　　无转无色相
  是人住总持　　智者应亲近
  若能了于眼　　无生性寂灭
  是人住总持　　智者应亲近
  若能了于眼　　自性离名相
  诸佛无能说　　称叹及表示
  是人住总持　　智者应亲近
  若能了于眼　　自性离名相
  无有能思惟　　受持及演说
  是人住总持　　智者应亲近
  如是总持性　　非文字诠辩
  无有诸方所　　亦非心所到
  是法无欢喜　　亦不住嗔恚
  不动如山王　　虽说无所得
  总持实无有　　乃至我亦无
  若我自性空　　总持亦无有
  总持自性空　　愚者计为有
  由是妄分别　　不闻生忧恼
  若分别贪性　　及以总持空
  如是二分别　　毕竟不可得
  若了空性空　　总持亦非有
  乃至菩提分　　三摩地亦空
  若有能了知　　总持及空性
  乃至三摩地　　于眼亦了知
  若于眼尽边　　如实善了知
  则于总持门　　究竟能成就
  若于眼生边　　如实善了知
  则于总持门　　究竟能成就
  若于眼边际　　如实善了知
  则于总持门　　究竟能成就
  若于眼寂静　　如实善了知
  则于总持门　　究竟能成就
  若于眼流转　　如实善了知
  则于总持门　　究竟能成就
  若于眼无有　　如实善了知
  则于总持门　　究竟能成就
  若于眼无生　　如实善了知
  则于总持门　　究竟能成就
  若于眼寂灭　　如实善了知
  则于总持门　　究竟能成就
  若于眼变异　　如实知尽边
  则于总持门　　究竟能成就
  若于眼变异　　如实知生边
  则于总持门　　究竟能成就
  若于眼变异　　如实知边际
  则于总持门　　究竟能成就
  若于眼变异　　如实知寂静
  则于总持门　　究竟能成就
  若于眼变异　　如实知流转
  则于总持门　　究竟能成就
  若于眼变异　　如实知无有
  则于总持门　　究竟能成就
  若于眼变异　　如实知无生
  则于总持门　　究竟能成就
  若于眼变异　　如实知寂灭
  则于总持门　　究竟能成就
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  若于眼前际　　无变无异相
  无取无分别　　是住总持门
  若于眼尽边　　无变无异相
  无取无分别　　是住总持门
  若于眼生边　　无变无异相
  无取无分别　　是住总持门
  若于眼边际　　无变无异相
  无取无分别　　是住总持门
  若于眼寂静　　无变无异相
  无取无分别　　是住总持门
  若于眼流转　　无变无异相
  无取无分别　　是住总持门
  若于眼无有　　无变无异相
  无取无分别　　是住总持门
  若于眼无生　　无变无异相
  无取无分别　　是住总持门
  若于眼寂灭　　无变无异相
  无取无分别　　是住总持门
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  贪嗔痴忿慢　　嫉诳悭忧恼
  过失垢毒箭　　暴流黑白业
  不生亦不灭　　不去亦不来
  不动亦不异　　非作亦非行
  非明亦非闇　　非流舍暴流
  无尽及无住　　非行非不行
  非字非攀缘　　非出亦非入
  分别妄想等　　六十二诸门
  各随其义理　　一切皆如是
  若知眼前际　　乃至于上下
  无取无分别　　是住总持门
  若知眼尽边　　乃至于上下
  无取无分别　　是住总持门
  若知眼生边　　乃至于上下
  无取无分别　　是住总持门
  若知眼边际　　乃至于上下
  无取无分别　　是住总持门
  若知眼寂静　　乃至于上下
  无取无分别　　是住总持门
  若知眼流转　　乃至于上下
  无取无分别　　是住总持门
  若知眼无有　　乃至于上下
  无取无分别　　是住总持门
  若知眼无生　　乃至于上下
  无取无分别　　是住总持门
  若知眼寂灭　　乃至于上下
  无取无分别　　是住总持门
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  于地不变异　　无取无分别
  如是了知者　　成就总持门
  于地无生相　　无取无分别
  如是了知者　　成就总持门
  于地无灭相　　无取无分别
  如是了知者　　成就总持门
  于地证入相　　无取无分别
  如是了知者　　成就总持门
  于地出离相　　无取无分别
  如是了知者　　成就总持门
  于地无愿相　　无取无分别
  如是了知者　　成就总持门
  于地无住相　　不来亦不去
  无边与无尽　　相应不相应
  离名字计度　　观察与流转
  无有及修治　　无言说表示
  寂静无所依　　念住并正断
  神足及根力　　觉支无畏道
  如是诸地法　　无取无分别
  如是了知者　　成就总持门
  若于我无入　　无取无分别
  如是了知者　　成就总持门
  若于我无出　　无取无分别
  如是了知者　　成就总持门
  若于我无相　　无取无分别
  如是了知者　　成就总持门
  若于我无愿　　无取无分别
  如是了知者　　成就总持门
  若于我无住　　无取无分别
  如是了知者　　成就总持门
  若于我无生　　无取无分别
  如是了知者　　成就总持门
  若于我无灭　　无取无分别
  如是了知者　　成就总持门
  若于我文字　　无取无分别
  如是了知者　　成就总持门
  若我离文字　　无取无分别
  如是了知者　　成就总持门
  知眼前后际　　远离于断常
  因缘自性空　　导师方便说
  若演说法时　　分别于眼相
  是人妄分别　　不名真说法
  若思惟法时　　分别于眼相
  是人妄分别　　不名思惟法
  若修习法时　　分别于眼相
  是人妄分别　　不名修习法
  若了眼空性　　即不趣菩提
  诸佛于是人　　常现前说法
  若不了知眼　　亦不了知色
  若能了知眼　　于色亦了知
  若能了于眼　　于色亦了知
  若于色了知　　于眼亦能了
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  若演说法时　　分别于因相
  是人妄分别　　不名为说法
  若演说法时　　分别寂静相
  是人妄分别　　不名为说法
  若演说法时　　分别于道相
  是人妄分别　　不名为说法
  若演说法时　　分别于空相
  是人妄分别　　不名为说法
  若演说法时　　分别于积集
  是人妄分别　　不名为说法
  若演说法时　　分别于事物
  是人妄分别　　不名为说法
  若演说法时　　分别眼摄取
  是人妄分别　　不名为说法
  于眼不了知　　是则生贪欲
  若能了知眼　　贪欲则不生
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是
  若演说法时　　分别种种果
  是人妄分别　　不名为说法
  不退于志愿　　了达于性空
  得诸三昧门　　彼能善说法
  不退于志愿　　于眼离分别
  以无分别故　　彼能善说法
  不了眼性空　　亦迷眼自性
  以不了知故　　是不应说法
  若了眼性空　　即知眼自性
  以能了知故　　是人应说法
  不了眼性空　　亦迷句自性
  以不了知故　　是不应说法
  若了眼性空　　即知句自性
  以能了知故　　是人应说法
  不了眼性空　　亦迷文自性
  以不了知故　　是不应说法
  若了眼性空　　即知文自性
  以能了知故　　是人应说法
  不了眼性空　　亦迷名自性
  以不了知故　　是不应说法
  若了眼性空　　即知名自性
  以能了知故　　是人应说法
  不了眼性空　　亦迷色自性
  以不了知故　　是不应说法
  若了眼性空　　即知色自性
  以能了知故　　是人应说法
  不了眼性空　　依世相分别
  不能善随顺　　调伏诸众生
  若了眼性空　　不依相分别
  即能善随顺　　调伏诸众生
  不了眼有无　　处众而说法
  是人贪利养　　一切无信受
  若了眼有无　　处众而说法
  是人不贪着　　一切皆信受
  不了眼性空　　而处于法座
  虽说多譬喻　　一切无信受
  若了眼性空　　而处于法座
  所说诸譬喻　　一切皆信受
  耳鼻舌身心　　六尘并四大
  乃至世生名　　一切皆如是

尔时世尊说是经已。月光童子及诸大众。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第三十四大宝积经卷第三十五

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之一

    开化长者品第一

如是我闻。一时薄伽梵。于室罗筏国雨安居。过三月恣举已。作衣服竟。与大苾刍众千二百五十人俱游化诸国。是薄伽梵。成就广大微妙名称。出现世间。为诸天人之所赞颂。所谓如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。深住自证具足神通。威德映蔽诸天世间魔王梵王阿素洛等。常为众生说微妙法。开示初善中善后善。文义巧妙纯一圆满清白梵行。时四部众。国王大臣。种种外道。沙门婆罗门。及诸长者。天龙药叉。人非人等。以无量上妙衣服饮食卧具医药种种供具奉献如来

尔时世尊。大众围绕。供养恭敬尊重赞叹。渐次游行至摩揭陀国。诣王舍大城住鹫峰山。时王舍城中有大长者。名曰贤守。已曾亲觐过去诸佛宿殖善根。福感通被大族大富。资产财宝无不具足。时彼长者闻大沙门出释氏宫。证于无上正等菩提。与诸大众来游此国。彼佛世尊。有如是等广大名称出现世间。十号具足。成就通慧说微妙法。乃至圆满清白梵行。时彼长者作是思惟。我今当往鹫峰山王。为欲奉见彼如来故。若我见者必获善利。作是念已。与五百长者出王舍城将往佛所。尔时世尊于日初分。服僧伽胝执持衣钵。诸苾刍僧侍从围绕。在大众前威仪严整。进止安庠正智而行。顾视屈申端严殊异。为化众生现乞食法。方欲入城处于中路。时贤守等五百长者。遥见如来。威严超挺众所乐观。成就金色之身大丈夫相三十有二。诸根寂定神虑憺怕。逮得上胜调顺寂止。摄护诸根如大龙象。清净无挠如澄泉池。足蹈七宝所成百千亿叶红莲华上。为诸无数天人药叉之所供养。雨大天华散如来上。其华若流弥满于地。诸长者等既睹世尊。以无量百千功德庄严从远而来。叹未曾有。以清净心往如来所。顶礼佛足却住一面

尔时贤守等五百长者白佛言。世尊。未曾有也。如来神力映夺天仙吉祥魔梵。如来威德具大名称。圆光妙色蔽诸大众。世尊体相如大金山。容貌端严无等等者。世尊成就一切世间甚希奇法。我惟世尊威德如是。观何等相。弃舍家法。悟大菩提。尔时贤守长者。即于佛前而说颂曰

  我昔曾闻最胜尊　　吉祥妙色大名称
  今睹威光胜所闻　　如真金像备众德
  如来色像喻金山　　高广严净观无厌
  威德庄严苾刍众　　犹如满月处众星
  世尊顶相无能见　　高显映发踰山王
  顶髻周圆渐次敛　　其相平偃犹天盖
  绀发软腻而右旋　　如安缮色帝青宝
  鲜净光踰孔雀项　　我今瞻仰无厌足
  面貌端严额平正　　眉相皎净若天弓
  白毫映彻无瑕秽　　光洁照曜如星王
  发喜净眼甚微妙　　众睹皆生欣乐心
  我今奉观无暂舍　　顶礼净眼世间依
  鼻相高平修旦直　　渐广圆成如铸金
  唇相丹晖极清净　　喻频婆果末尼等
  妙齿鲜白含光润　　等鹤牛乳莲华根
  坚密齐平极明净　　调顺奢摩他所感
  齿及随齿根深固　　断际上下皆齐整
  佛牙光白最超胜　　如彼雁行王处中
  善逝广长之舌相　　覆面薄净如莲华
  赤铜赤色末尼宝　　含晖皎镜如初日
  世尊耳相极端严　　梵世天人不闻见
  乔答摩种狻猊颔　　无畏犹如师子王
  我观善逝咽喉相　　能引世间甘露味
  清净映彻无瑕秽　　具大神力不思议
  颈前横约修旦直　　处中都无孅杂文
  现人中胜天中天　　恒食味中第一味
  肩膊充圆悉成满　　胸臆雄猛威容盛
  人中尊相世未闻　　如山顶日光流照
  手足两肩及项后　　七处光净恒平满
  修臂佣圆象王鼻　　双掌垂下摩于膝
  上身广厚如兽王　　瞿陀树相周圆满
  那罗延力合成身　　具足大力及忍力
  无垢身毛皆上靡　　随现一孔一毛生
  烟尘不污如莲华　　右旋相成而细软
  我昔传闻隐密相　　阴藏深如天马王
  髀腨周圆渐次敛　　其相犹如天鹿王
  足厚隆起跟圆长　　手相网鞔如雁王
  平满孅长二十指　　赤铜甲色如莲华
  双跖千辐金轮相　　光净微妙具庄严
  如来游步于世间　　瞿拉坡相不相触
  去地四指蹈空行　　众宝红莲随足现
  顾视安行象王步　　进趣端肃如天主
  大圣威严无所畏　　处众踰于师子王
  妙色映蔽毗沙门　　威光超胜百千日
  梵世天人尚无等　　何况出过如来者
  行住说法度众生　　天仙龙神咸恭敬
  或散天华奏天乐　　纷然繁会满虚空
  今睹世尊大神变　　故我窃怀疑惑心
  本观何等胜功德　　出家趣于无上道

尔时世尊告贤守长者曰。长者当知。我观世间一切众生。为十苦事之所逼迫。何谓为十。一者生苦逼迫。二者老苦逼迫。三者病苦逼迫。四者死苦逼迫。五者愁苦逼迫。六者怨恨逼迫。七者苦受逼迫。八者忧受逼迫。九者痛恼逼迫。十者生死流转大苦之所逼迫。长者。我见如是十种苦事逼迫众生。为得阿耨多罗三藐三菩提。出离如是逼迫事故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  我观诸凡夫　　闭流转牢狱
  常为生老病　　众苦所逼迫
  愁忧及怨恨　　死苦等所牵
  为除牢狱怖　　令欣出离法

复次长者。我观世间一切众生。为十恼害互相憎嫉。何谓为十。一者曾于我身作不饶益。心生恼害。二者今于我身作不饶益。心生恼害。三者当于我身作不饶益。心生恼害。四者曾于我之所爱作不饶益。心生恼害。五者今于我之所爱作不饶益。心生恼害。六者当于我之所爱作不饶益。心生恼害。七者曾于我所不爱而作饶益。心生恼害。八者今于我所不爱而作饶益。心生恼害。九者当于我所不爱而作饶益。心生恼害。十者于诸过失作不饶益。心生恼害。长者我见如是十种恼害。恼害世间一切众生。为得阿耨多罗三藐三菩提。出离如是恼害事故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  众生互憎嫉　　皆由十恼生
  于我及我亲　　三世俱恼害
  或于我非亲　　起诸饶益相
  怨憎由此生　　三世俱恼害
  第十诸过失　　生长怨憎苦
  我观如是过　　厌患故出家

复次长者。我观世间一切众生。入于十种恶见稠林。由异见故不能自出。何谓为十。一者我见恶见稠林。二者有情见恶见稠林。三者寿命见恶见稠林。四者数取趣见恶见稠林。五者断见恶见稠林。六者常见恶见稠林。七者无作见恶见稠林。八者无因见恶见稠林。九者不平等因见恶见稠林。十者邪见恶见稠林。长者。我见众生入于十种恶见稠林不能得出。为得阿耨多罗三藐三菩提。永断如是诸恶见故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  一切愚凡夫　　入恶见稠林
  我见有情见　　及以寿命见
  断见与常见　　依无作见等
  为安立正见　　是故我出家

复次长者。我观世间一切众生。于无数劫具造百千那庾多拘胝过失。常为十种大毒箭所中。何谓为十。一者爱毒箭。二者无明毒箭。三者欲毒箭。四者贪毒箭。五者过失毒箭。六者愚痴毒箭。七者慢毒箭。八者见毒箭。九者有毒箭。十者无有毒箭。长者。我见众生为于十种毒箭所中。求阿耨多罗三藐三菩提。永断如是诸毒箭故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  爱箭毒众生　　过拘胝大劫
  无明之所盲　　从闇入于闇
  欲箭中诸蕴　　吸染名贪箭
  闷乱过失箭　　被服愚痴箭
  陵高发慢箭　　违诤起见箭
  因有无有箭　　堕有及无有
  诸愚痴凡夫　　锋刃由其口
  更相起诤论　　此实此非实
  为拔毒箭故　　如来兴世间
  救诸中箭者　　出家成圣道

复次长者。我观世间一切众生。由十种爱建立根本。何者为十。所谓缘爱故求。缘求故得。缘于得故便起我所。缘我所故起诸定执。缘诸定执故起欲贪。缘欲贪故起深耽着。缘深耽着故起悭吝。缘悭吝故起于聚敛。缘聚敛故起诸守护。缘守护故执持刀仗。诤讼讥谤起种种苦。又因此故兴别离语。长养诸恶不善之法。长者。我见众生由此十种爱根本法之所建立。求于阿耨多罗三藐三菩提。为得无根无所依法故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义而说颂曰

  爱所吞众生　　寻逐于诸欲
  得利兴我所　　从此生定执
  我当作所作　　欲贪缚增长
  耽着悭吝等　　相续次第生
  悭过染世间　　能起坚积聚
  聚敛故守护　　遍生无有间
  守护在愚夫　　刀仗相加害
  种诸不善业　　因此生众苦
  观爱因缘已　　众苦则不生
  无根无住觉　　诸觉中最上

复次长者。我观世间一切众生。皆由十种恶邪性故建立邪定。何等为十。一者邪见。二者邪思惟。三者邪语。四者邪业。五者邪命。六者邪精进。七者邪念。八者邪定。九者邪解脱。十者邪解脱智见。长者。我观众生由如是等十邪性故建立邪定。为欲证得阿耨多罗三藐三菩提出离如是诸邪性故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  怀邪见众生　　邪思惟境界
  宣说于邪语　　及行诸邪业
  邪命邪精进　　邪念与邪定
  成就邪解脱　　及趣邪智见
  邪性决定聚　　愚夫之所依
  为令住正性　　故趣无上道

复次长者。我观世间一切众生。由于十种不善业道。而能建立安处邪道多堕恶趣。何等为十。一者夺命。二者不与取。三者邪淫。四者妄语。五者离间语。六者粗语。七者绮语。八者贪着。九者嗔恚。十者邪见。长者。我见众生由是十种不善业故。乘于邪道多趣多向多堕恶道。为欲证得阿耨多罗三藐三菩提超出一切诸邪道故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  诸害命众生　　劫盗他财物
  行诸邪欲行　　速堕于地狱
  粗言离间语　　妄语乖寂静
  绮语等凡夫　　愚痴之所缚
  贪着他资财　　数起于嗔恚
  兴种种邪见　　是人趣恶道
  三种由身起　　四种语业生
  意能成三恶　　故名恶行者
  行诸恶业已　　牵趣恶道中
  吾今现世间　　拔济令出离

复次长者。我观世间一切众生。由于十种染污法故。处在烦恼堕烦恼垢中。何谓为十。一者悭垢染污。二者恶戒垢染污。三者嗔垢染污。四者懈怠垢染污。五者散乱垢染污。六者恶慧垢染污。七者不遵尊教垢染污。八者邪疑垢染污。九者不信解垢染污。十者不恭敬垢染污。长者。我见众生以如是等十染污法之所染污。为得阿耨多罗三藐三菩提证于无染无上法故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  世多分众生　　十染所逼迫
  乐有为烦恼　　曾不生厌离
  悭垢所染污　　一切愚凡夫
  犯戒非寂静　　不习三摩地
  嗔垢背忍辱　　懈怠退正勤
  其心不专住　　恶慧愚钝者
  于父母师长　　不遵奉言教
  疑见网众生　　不求照世觉
  诽谤于甚深　　佛所说妙法
  被服无明蕴　　圣蕴怀轻贱
  观是染污已　　谁乐处有为
  当勤证寂灭　　无为无染污

复次长者。我观世间一切众生。为十种缠缚之所缠缚。何谓为十。一者由悭嫉网之所缠缚。二者由无明膜之所覆翳。三者烦恼迷醉堕愚痴坎。四者爱欲驶流之所漂没。五者末摩死节邪箭所中。六者忿恨密烟之所熏[火*孛]。七者贪欲盛火之所烧然。八者过失毒药之所闷乱。九者诸盖毒刺之所遮碍。十者常处生死流转饥馑旷野正勤疲怠。长者。我观众生为如是等十种缠缚所缠缚已。求阿耨多罗三藐三菩提为证无缠无缚法故。以净信心舍释氏家趣无上道。尔时世尊。欲重宣此义。而说颂曰

  老吞少盛年　　老坏净妙色
  老损念定慧　　终为死所吞
  病能摧势力　　劫夺勇猛心
  坏诸根聚落　　羸劣无依怙
  死如罗刹女　　猛健甚可畏
  常随逐世间　　饮竭众生命
  我已厌世间　　老病死逼迫
  为求无老死　　清安法出家
  世为三火烧　　我观无救者
  雨甘露法雨　　灭除三毒焰
  观诸失道者　　生盲痴瞽等
  为与世间眼　　示导故出家
  众生疑乳养　　蕴盖所蔽障
  为彼除悔恼　　说法故出家
  愚夫互违反　　伺隙兴加害
  为和怨憎故　　利世故出家
  于父母师长　　力慢无恭敬
  为摧憍慢幢　　是故我出家
  观贪障世间　　由财相损害
  为得七圣财　　断诸法贫者
  或致相刑残　　利已终非益
  我观定舍身　　求离三有狱
  三有昔未知　　真实利益事
  为开真实益　　是故我出家
  观趣地狱者　　恶业因炽然
  受无边重苦　　为脱故出家
  观诸畜生趣　　互相加杀害
  无依为作依　　悲心故出家
  观焰魔鬼趣　　饥渴大苦逼
  为证妙菩提　　施不死甘露
  人道追求苦　　诸天舍命苦
  观苦遍三有　　为济故出家
  我观耽欲者　　远离诸惭愧
  凌逼于尊亲　　荒淫甚猪狗
  又观诸愚夫　　女媚所吞食
  放逸造非义　　为舍故出家
  观劫浊众生　　恶法娆魔使
  我为摧伏故　　趣成无上觉
  在家众过本　　出家趣菩提
  故舍大地等　　为穷生死际

尔时五百长者。闻佛所说得未曾有。方知如来是真觉者。即于佛前。异口同声。而说颂曰

  我等怖畏老死逼　　愿宣妙法尽其际
  世尊诸有趣清净　　离有性净超诸有
  愿拔诸有令不有　　及在禁闭有家者
  世雄离染最解脱　　远离尘垢心清净
  调御法中大调御　　愿开微妙甘露门
  备上妙色胜丈夫　　天人世间无等者
  世无等等最胜尊　　愿说妙法济群生
  三垢永灭吐诸过　　慧眼清净翳障消
  净尘离闇开痴网　　愿无等尊宣妙法
  众生苦聚无依怙　　溺大有池无救者
  愿起慈悲广济心　　速拔高升安隐岸
  有河憍慢痴回澓　　斗讼病苦波涛盛
  众生漂没无依救　　愿发慈心济有流
  朗日千亿曜金山　　佛身光盛踰于彼
  愿以胜妙梵音声　　宣布端严最上法
  诸法自性本清净　　体相洞彻等明珠
  无有作者无受者　　不从他闻遍照觉
  自然具足力无畏　　行妙净行称无边
  无边智解如游空　　愿大法王宣妙法

尔时世尊。作如是念。是五百长者善根已熟堪任法化。我今当为如应说法。令诸长者即于此处。除舍俗相以信出家。断诸烦恼得漏尽慧。作是念已。即升虚空结跏趺坐。诸长者等既睹神变。叹未曾有。于如来所倍生敬重信仰之心

尔时世尊。告诸长者。汝等善听。世有十种逼迫苦事。所谓生苦。老苦。病苦。死苦。愁苦。怨苦。苦受。忧受。痛恼生死。如是十种逼迫苦事。逼迫众生。汝等今者欲解脱不。复次诸长者。世有十恼害事。所谓曾于我身作不饶益。今于我身作不饶益。当于我身作不饶益。于我曾爱作不饶益。于我今爱作不饶益。于我当爱作不饶益。我曾不爱而作饶益。我今不爱而作饶益。我当不爱而作饶益。又于一切不饶益过心生恼害。如是十种恼害之事。汝等今者欲解脱不。复次诸长者。世有十种异见恶见稠林。所谓我见。众生见。寿命见。数取见。断见。常见。无作用见。无因见。不平等见。邪见。如是十种恶见稠林。汝等今者欲解脱不。复次长者。世为十种大毒箭所中。所谓爱毒。无明毒。欲毒。贪毒。过失毒。愚痴毒。慢毒。见毒。有毒。无有毒。如是十种大毒之箭。汝等今者欲解脱不。复次诸长者。世有十种爱根本法。所谓缘爱故求。缘求故得。缘于得故便起我所。缘我所故起诸定执。缘诸定执故起欲贪。缘欲贪故起深耽着。缘深耽着便起悭吝。缘悭吝故起于聚敛。缘聚敛故便起守护。缘守护故执持刀仗。讥谤诤讼起别种语。种种诸苦恶不善法并因斯起。如是十种爱根本法。汝等今者欲解脱不。复次诸长者。世有十种邪性。所谓邪见。邪思惟。邪语。邪业。邪命。邪勤。邪念。邪定。邪解脱。邪解脱智见。如是十种邪性。汝等今者欲解脱不。复次诸长者。世有十种不善业道。所谓害命。不与取。行邪淫。妄语。离间语。粗恶语。绮语。贪恚邪见。如是十种不善业道。汝等今者欲解脱不。复次诸长者。世有十种染污垢法。所谓悭垢。恶戒垢。嗔垢。懈怠垢。散乱垢。恶慧垢。不遵尊教垢。疑垢。不信解垢。不恭敬垢。如是十种染污垢法。汝等今者欲解脱不。复次诸长者。世有十种生死流转大怖畏事。所谓缠缚悭嫉之网。覆翳无明之膜。堕坠愚痴深坑。漂没爱欲駃流。末摩邪箭所中。薰[火*孛]忿恨密烟。焚烧贪欲盛火。迷闷过失毒药。遮障诸盖毒刺。饥馑流转旷野。如是十种。生死流转大怖畏事。汝等今者欲解脱不。尔时五百长者一心同声白佛言。世尊。我等今者愿欲解脱所说十种逼迫苦事。所谓生老病死愁怨忧苦恼害生死。如是广说乃至流转饥馑旷野诸逼迫事。我等皆当愿得解脱

尔时世尊告是五百诸长者曰。汝等善听。吾今当说正法之要。诸长者眼不求解脱。何以故。眼无作无用故。眼不能思不能了别。是故诸长者。眼非是我应如是持。如是耳鼻舌身意意不求解脱。何以故。意无作无用故。意不能思不能了别。是故诸长者。意亦非我应如是持。复次诸长者。色不求解脱。何以故。色无作无用故。色不能思不能了别。是故诸长者。色亦非我应如是持。如是声香味触法法不求解脱。何以故。法无作无用故。法不能思不能了别。是故诸长者。法亦非我应如是持。复次诸长者。色蕴不求解脱。何以故。色蕴无作无用故。色蕴不能思不能了别。是故诸长者。色蕴非我应如是持。如是受蕴想蕴行蕴识蕴。识蕴不求解脱。何以故。识蕴无作无用故。识蕴不能思不能了别。是故诸长者。识蕴非我应如是持。复次诸长者。地界不求解脱。何以故。地界无作无用故。地界不能思不能了别。是故诸长者。地界非我应如是持。如是水界火界风界空界识界。识界不求解脱。何以故。识界无作无用故。识界不能思不能了别。是故诸长者。识界非我应如是持。复次诸长者。诸法不实分别所起依于众缘。无能无力从众缘转。若有众缘假设诸法。若无众缘则无假法。诸长者。一切诸法唯假施设。此中都无生者老者死者尽者起者。唯有永断诸趣。清净寂灭可以归依。是故汝等应如是知。是故诸长者。一切诸法不实分别之所生起。依于众缘羸劣无力从众缘转。若有众缘假立诸法。若无众缘则无假法。诸长者。一切诸法唯是假立。此中都无生者老者死者尽者起者。唯有永断诸趣。清净寂静可以归依。如是诸长者。若有不实分别。则有假立不正作意。若无不实分别。则无假立不正作意若有不正作意则有假立无明。若无不正作意则无假立无明。若有无明则有假立诸行。若无无明则无假立诸行。若有诸行则有假立于识。若无诸行则无假立于识。若有假识则有假立名色。若无有识则无假立名色。若有名色则有假立六处。若无名色则无假立六处。若有六处则有假立于触。若无六处则无假立于触。若有于触则有假立于受。若无于触则无假立于受。若有于受则有假立于爱。若无于受则无假立于爱。若有于爱则有假立于取。若无于爱则无假立于取。若有于取则有假立于有。若无于取则无假立于有。若有于有则有假立于生。若无于有则无假立于生。若有于生则有假立老死。若无有生则无假立老死。如是诸长者。云何为老。所谓情识惛耄。头白发落。皮缓面皱。寿命损减。诸根衰熟。诸行朽故。是名为老。云何为死。所谓丧灭转世。休废堕落。诸蕴散坏。委弃于地。舍众同分是名为死。若老若死合名老死。诸长者。生若是有。有假老死。生若是无。无假老死。云何为生。所谓是生等生趣起诸蕴出现。及得诸处会众同分。是名为生。诸长者。有若是有则有假生。有若是无则无假生。云何为有所谓欲有色有。及无色有。福及非福不动业等。是名为有。诸长者。取若是有则有假有。取若是无则无假有。云何为取。所谓欲取见取。戒禁取我取。故名为取。诸长者。爱若是有则有假取。爱若是无则无假取。云何为爱。所谓色爱声爱。香爱味爱。触爱法爱。是名为爱。诸长者。受若是有则有假爱。受若是无则无假爱。云何为受。所谓眼触所生受。耳触鼻触舌触身触意触所生受。是名为受诸长者。触若是有则有假受。触若是无则无假受。云何为触。所谓眼触耳触鼻触舌触身触意触。是名为触。诸长者。六处若有则有假触。六处若无则无假触。云何为六处。所谓眼处耳处鼻处舌处身处意处。是为六处。诸长者。名色若有有假六处。名色若无无假六处。云何为名色。所谓受想思触作意。四大界及四大界之所造色是名名色。诸长者。识若是有有假名色。识若是无无假名色。云何为识。所谓眼识耳识鼻识舌识身识意识是名为识。诸长者。行若是有则有假识。行若是无则无假识。云何为行。所谓色思声思香思味思所触思法思。是名为行。诸长者。无明若有则有假行。无明若无则无假行。云何为无明。所谓前际无知后际无知。前后际无知。内无知外无知。内外无知。苦无知集无知。灭无知道无知。缘无知缘起无知。于缘生法。若黑若白。有缘无缘。有光影无光影。有罪无罪。可亲近不可亲近。无知无见。无对观无达解。如是等相是名无明。诸长者。不正作意若有。则有假立无明。若无不正作意。则无假立无明。云何名为不正作意。所谓我于过去。是何等性。是何等处。是何等类。我往未来。是何等性。是何等处。是何等类。复于内身多起疑惑。云何名我。我为是谁。为有为无为虚为实。是何等性。是何等处。是何等类。我昔何处住于彼处。起如是等不正作意。从六见中随生一见。执有我见执无我见。或依我故而观我见。或不依我而观我见。又复虚妄起如是见。我即世间或当缘起。为常为恒不转不变。永正住止。如是诸见。是名不正作意。诸长者。不实分别。若有则有假立不正作意。不实分别若无。则无假立不正作意。云何名为不实分别。谓我。有情。命者。丈夫。数取。生者。意生。摩纳婆。作者。受者。是名不实。而诸无闻凡夫。妄起如是我分别。有情分别。命者分别。丈夫分别。数取分别。生者分别。意生分别。摩纳婆分别。作者分别。受者分别等分别故。是为不实分别。诸长者。如是不实分别。若有则有假立不正作意。不实分别。若无则无假立不正作意。诸长者。不正作意若有。则有假立无明。不正作意若无。则无假立无明。无明若有则有假立诸行。无明若无则无假立诸行。如是乃至生若是有。则有假立老死。生若是无。则无假立老死。尔时佛告诸长者。汝今当知。一切诸法不实分别所起。依于众缘。羸劣无力。从众缘转。众缘若有则有假法。众缘若无则无假法。诸长者。一切诸法唯是假立。此中都无生者老者死者尽者及以起者。唯有永断诸趣清净寂灭。可以归依。诸长者。于意云何。譬如大池所生诸鱼水族之属。依何力住。长者白言。世尊。此诸鱼等依水力住。佛言。如是如是。诸长者。此水颇有思念为有力不。长者白言。世尊。此水无力无能。何所思念。佛言。如是如是。诸长者。不实分别所起诸法亦复如是。但假施设无力无能。从众缘转。众缘若有则有假法。众缘若无则无假法。诸长者。一切诸法唯是假立。此中都无生者老者死者尽者起者。唯有永断诸趣清净寂灭。可以归依。是故诸长者。汝等应正观察如是众缘。非安隐处难可保持。深生怖惧逃走远避。复应观察此是何法。因怖何法而来至此。汝等如是正观察时。无法可得无怖无舍。何以故。一切诸法皆不可得。一切种求不可得故。诸法无我离尘垢故。诸法无众生远离我故。诸法无命出过生老病死愁忧苦恼逼迫等故。诸法无数取三世断故。诸法无字一切言音不可说故。诸法无著无所缘故。诸法寂静寂灭相故。诸法普遍虚空性故。诸法性空无定属故。诸法无动无所依故。诸法依实际住。善住无动相应故。诸法不可开阐。离相波浪故。诸法不可显示。无相无形。无有光影。离诸行故。诸法非我所有。离我所故。诸法不可分别。离心意识故。诸法无有爱藏。超过眼耳鼻舌身意道故。诸法不可举移。离生住坏故。诸法无作无用。离心意识故。诸法属缘性羸劣故。诸长者。我说是眼四大所造。无常无住。无恒不坚之法。羸弱速朽难可保信。众苦所集多病多害。汝诸长者。眼为如是不应依止。耳鼻舌身意亦复如是不应依止。当如是观。复次诸长者。眼如聚沫不可撮摩眼如浮泡不得久住。眼如阳焰业惑爱生。眼如芭蕉性不坚固。眼如幻术从颠倒起。是眼如梦唯虚妄见。是眼如响系属众缘。眼如光影业光影现。眼如浮云聚乱散相。眼如流电刹那便灭。是眼无主犹如地。是眼无我犹如水。眼非有情犹如火。眼非寿命犹如风。眼非数取犹如空。眼为不实依藏诸大。是眼为空离我我所。是眼无知如草木土石。是眼无作机关风转。是眼虚假朽秽所聚。是眼浮伪摧散破坏灭尽之法。眼如丘井常为老逼。眼无住际终归磨灭。诸长者。眼为多过应如是观。乃至于意一切诸法亦复如是。复次诸长者。一切诸法唯有妄欲。异生愚夫不知妄欲故。妄谓是眼。妄谓是耳。乃至妄谓是意。诸长者。但有妄欲。异生愚夫不知妄欲故。谓此是色。谓此是声。香味触法亦复如是。诸长者。但有妄欲异生愚夫不知妄欲故。谓此色蕴。谓此受蕴。想行识蕴亦复如是。诸长者。但有妄欲。异生愚夫不知妄欲故。谓此地界。谓此水界。火风空识亦复如是。诸长者。一切诸法唯有妄欲。异生愚夫不知妄欲故。谓此有为。谓此无为。乃至一切诸法亦复如是。诸长者。汝等今者应舍妄欲趣于无欲。于诸妻子家宅财物。深知虚妄不应执着。不执着故。以净信心舍离家法。趣于非家当得无欲。诸长者。何等名为出家无欲。谓住尸罗别解脱戒。具足摄持威仪行处。见于小犯生大怖畏。受学律仪成就戒蕴。诸长者。汝等若能奉持戒已。于是六根六境五蕴六界。深知虚假皆不执着。以不着故是名出家无欲之法。诸长者。若不着眼乃至识界。以不着故则不保护。何者不保护。眼不保护。耳鼻舌身意不保护。色不保护。声香味触法不保护。色蕴不保护。受想行识蕴不保护。地界不保护。水火风空识界不保护。以不保护则无烦恼。若无烦恼则名为轻。云何为轻。谓无所见。若无所见则不依物起嗔害心。由无嗔害则不自害。不思害他。不思俱害。以无害故。则于无余大涅槃界而便入证。诸长者。汝等应知。谁于寂灭而便入证。诸长者。眼不入寂灭。耳鼻舌身意不入寂灭。然因于眼起诸妄执。或计为我。或计我所。若远离者即是寂灭。远离何等而为寂灭。若远离贪即是寂灭。若远离嗔即是寂灭。若远离痴即是寂灭。若离无智即是寂灭。复次诸长者。过去无智不可远离。未来无智不可远离。现在无智不可远离。然要因于远离无智而正智起。诸长者。何等为智。所谓尽智。何等尽智。过去非尽智。未来非尽智。现在非尽智。然诸长者。因离无智而此智生。此智不远离智。因离眼无智而此智生。又诸长者。眼非我所。若非我所则不取着。若不取着即是最上。若是最上即是解脱。何处解脱。于我执所而得解脱。有情执所。寿命执所。数取执所断常执所。一切执所。乃至分别执所而得解脱。行者若能于执解脱。则不分别。若不分别。则非分别非不分别。何等不分别。所谓不分别我及以我所。行者尔时于一切法离散不积。舍而不取。舍故寂灭。解脱除遣。最胜解脱离诸系缚。于何等处名为除遣。一切苦处而得除遣。汝诸长者。若求出离。勿于一法而生取着。何以故。若有取着则有怖畏。若无取着则无怖畏

复次诸长者。眼非寂灭。耳鼻舌身意亦非寂灭。色非寂灭。乃至识界亦非寂灭。然诸长者。因于识界起不实执。或计为我及以我所。若离于此即是寂灭。远离何等而得寂灭。谓远离贪而得寂灭。离嗔离痴及以无智而得寂灭。复次诸长者。过去无智不可远离。未来无智不可远离。现在无智不可远离。然离无智而得智生。诸长者。何等为智。所谓尽智。何等尽智。过去非尽智。未来非尽智。现在非尽智。然诸长者。因离无智而智得生。此智不远离智。因离识无智故而智得生。而此识界非是我所。若非我所则不取着。若不取着即是最上。若是最上是即解脱。何处解脱。于我执所而得解脱。有情寿命乃至于一切分别执所。而得解脱。行者若能于执解脱则不分别。若不分别。则非分别非不分别。何等不分别。谓不分别我及我所。行者尔时离散不积。舍而不取。舍故寂灭。解脱除遣。最胜解脱。离诸系缚。于何除遣。一切苦处而得除遣。汝诸长者。若求出离。勿于一法而生取着。何以故。若有取着则有怖畏。若无著者则无怖畏。尔时世尊。欲重宣此义。而说颂曰

  取着生怖畏　　由斯趣恶道
  观此有怖处　　智者不应取
  汝修诸圣道　　应当善观察
  如是观便得　　异此则不可
  一切处皆空　　虚动非坚实
  爱诳惑世间　　勿于此生乱
  我已知空法　　了诸法不坚
  湛然获安泰　　证无动妙乐
  若如是了知　　诸法唯空者
  彼解脱众苦　　及灭于诤论
  欲摄受一切　　生诸灾横者
  摄受故取着　　着故生诸有
  从有生于生　　由生远寂灭
  生者老病死　　如是大苦逼
  无欲故无取　　无取故无有
  无有故无生　　老病死亦尔
  聚集资生具　　一时皆弃舍
  并舍爱妻子　　趣苾刍威仪
  勿贪亲与财　　咄哉念知足
  勿如旃茶罗　　下贱心来往
  勿自恃持戒　　轻毁犯戒者
  恃戒凌于人　　是名真破戒
  譬如鹿被弶　　若缚若致死
  处魔罥慢者　　缚害亦如是
  慢能坏善心　　又损自他善
  故勿轻毁戒　　况持戒梵行
  当学大仙子　　常住空闲处
  勿顾于身命　　趣寂静解脱
  应离无义本　　顺世尼干论
  爱敬演甚深　　空相应妙法
  内外十二处　　我说心为本
  彼复因业生　　业由思久住
  眼色俱为缘　　而生起于识
  缘阙则不生　　譬无薪之火
  如是生诸法　　和合互相生
  无作无受者　　现作用如幻
  一切内外法　　我已知空幻
  愚夫颠倒执　　分别我我所
  眼中无有情　　外诸处亦尔
  非我作寿者　　诸法类应知
  眼不思解脱　　耳鼻舌亦然
  身意等无作　　诸法观如是
  譬如巨海中　　鼓涛成沫聚
  明眼者察知　　审其非坚实
  如是五蕴体　　达者知非固
  当解脱生老　　愁忧灾横等
  我法中出家　　知诸法如幻
  不虚彼信施　　即名供诸佛

尔时五百长者。闻是法已。即于此处远尘离垢。于诸法中得法眼净。如无黑净衣置染器中速受染色。如是诸长者法眼清净亦复如是

尔时世尊。复为长者宣说妙法。示教赞善。诸长者。我说此眼自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火之所炽然。生老病死。愁叹忧苦。不安等法之所炽然。如是诸长者。我说此耳鼻舌身意自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火。生老病死愁叹忧苦。不安等法之所炽然。诸长者。我说此色自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火之所炽然。乃至声香味触法亦复如是。诸长者。我说色蕴自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火之所炽然。乃至受想行识蕴亦复如是。诸长者。我说地界自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火之所炽然。如是乃至水火风空识界。自性是苦而复炽然。何等炽然。所谓贪火嗔火痴火。生老病死愁叹忧苦。不安等法之所炽然。是故诸长者。我今不执眼耳鼻舌身意。汝等亦应如是随学。我今不执色声香味触法。乃至不执色等诸蕴地等诸界此世他世。汝等亦应如是随学。诸长者。汝等若于眼耳鼻舌身意。不执著者则不依眼住。不依耳鼻舌身意住。汝等不依色声香味触法时。汝等则不依于一切法住。汝等不依色蕴。乃至不依识蕴住者。则不依色蕴乃至识蕴住。汝等不依地水火风空识界时。则不依地界乃至识界住。汝等不依此世他世。及以一切世间住者。如是汝等不取一切法时。则不依于一切法住。若能不依一切法住者。是则名为非当有非不当有。汝等若悟非当有非不当有者。我说汝等解脱生老病死诸苦。尔时世尊。欲重宣此义。而说颂曰

  生死所炽盛　　烧然诸世间
  受苦无能救　　丧失于圣道
  照世诸如来　　时乃一兴现
  无刹那远离　　当起坚精进
  修习于正行　　慧观应察知
  如慧观当得　　异此非所获
  若于此修习　　应知一切空
  了达空法已　　非心空菩提
  贪嗔及与痴　　是三毒大火
  烧诸世愚者　　长眠而不觉
  生老病及死　　愁叹诸苦等
  知世逼迫已　　勿依诸法住

尔时五百长者白佛言。世尊。我等今者欲于佛所出家。受具足戒修清净行。未审世尊垂愍听不。佛言。善来苾刍。即名出家具足戒已成苾刍法。尔时世尊。欲重宣此义。而说颂曰

  袈裟执受已　　其发自然断
  一切皆持钵　　即座成罗汉
  知得罗汉已　　于苾刍众前
  及对诸天等　　大师已问说
  昔于世依怙　　广行诸布施
  随其所生处　　常感多安乐
  彼今得见我　　复生清净心
  由彼心清净　　故为说妙法
  闻说得罗汉　　永离于我见
  证空法现前　　解脱诸生死

大宝积经卷第三十五大宝积经卷第三十六

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之二金毗罗天受记品第二

尔时世尊。于彼中道不移其处。令诸长者建立圣果。以如来威势入王舍城。四众围绕容仪庠序。时有护王舍城诸天药叉大善神王。名金毗罗。作如是念。今者如来形相殊异。于世间中最胜难遇。堪受人天之所供养。我等今当应以种种上妙供具奉献如来。作是念已。便以最胜饮食具足香味成就妙色。奉上于佛。尔时世尊。愍其所献故为纳受。时金毗罗王所领大药叉众六万八千在虚空中咸生随喜。以清远音唱言。善哉善哉。时金毗罗即以此义告其众曰。我已奉佛上妙供具。汝等亦应以诸供养施苾刍僧。当令汝等于长夜中利益安乐。诸药叉众受王教已。即以上供施苾刍僧。时诸僧众哀受其供

尔时世尊。为乞食故入王舍城。既得食已将还所止。时有无量千众天龙药叉健达缚阿素洛揭路荼紧捺洛牟呼洛伽。及无量千人与非人。又有无量拘胝那庾多百千众生。随从佛后。尔时如来往彼最胜宽广之地。敷如常座而坐其上。时金毗罗与其部从。即持种种天曼陀罗花殟钵罗花钵特摩花拘贸陀花奔荼利花。复持种种天旃檀末诸供养具。而散于佛。所谓胜散大胜散。妙散大妙散。作如是等殷勤散已。合掌佛前礼敬而住。尔时如来。知金毗罗及其大众心之所念。即便微笑。诸佛常法现微笑时。从其面门出种种无量色光。所谓青黄赤白红色银色及水精色。其光遍照无量无边一切世界。日月威光掩蔽不现。下照地狱令彼悦乐。乃至上踊至于梵世。所应作已而复还来。右绕七匝。或于世尊顶上而没。或从两肩。或从两膝而灭没者。诸佛常法。若授地狱众生记时。尔时光明两足下没。若授畜生光从背没。若授鬼趣从身前没。若授人道从左胁没。若授天趣从右胁没。若授声闻从两膝没。若授独觉从两肩没。若佛世尊授诸菩萨摩诃萨阿耨多罗三藐三菩提记时。尔时光明从顶上没。时长老阿难陀。既睹世尊微笑光明。以七条衣覆左肩已。偏袒右肩。右膝着地。合掌礼足。以颂问曰

  照世依怙者　　何故放光明
  利益世间尊　　何缘现微笑
  谁今下圣种　　为佛菩提因
  今为谁授记　　谁应住解脱
  大雄猛导师　　非无因而笑
  愿牟尼当说　　现光之所为

尔时世尊。即便以颂。报阿难曰

  金毗罗净心　　奉献诸供具
  救世依怙者　　故现斯微笑
  舍神王报已　　往三十三天
  受彼天福尽　　上生焰摩天
  又生睹史多　　受诸天欲乐
  福尽生人中　　兴为智慧王
  王四洲人主　　自在转轮帝
  舍后人王已　　便生梵世天
  天上及人中　　数往来不息
  二十拘胝劫　　常感诸妙乐
  最后舍王位　　出家求佛道
  众缘具足已　　成究竟菩提
  三万诸药叉　　由奉养于佛
  便舍药叉报　　生三十三天
  后见慈氏尊　　复获阿罗汉
  既蒙授道化　　即各供诸佛
  满千药叉众　　为住大菩提
  由是善根故　　不生诸恶趣
  或有千药叉　　当供佛导师
  求无上菩提　　利益众生故
  或有二三千　　持香花鬘等
  当供养诸佛　　为得佛菩提
  或有千拘胝　　当供诸佛已
  修自体清净　　后证入菩提
  金毗子世罗　　具大神通力
  亦发大愿心　　我当成等觉
  曾供养诸佛　　遍起于弘誓
  今复供养我　　心趣无上道
  由此善根力　　舍诸弊恶趣
  当见慈氏尊　　又献拘胝盖
  献拘胝盖已　　复献拘胝衣
  献拘胝衣已　　尔时便出家
  具满五百岁　　专修行梵行
  求最上菩提　　利益众生故
  当成彼愿故　　修行施戒等
  如殑伽沙劫　　精勤常不断
  如是汝当知　　为示现故说
  彼修行胜行　　倍增过上数
  如前说譬喻　　殑伽沙劫数
  得见彼诸佛　　当修大供养
  奇哉胜妙智　　奇哉无上心
  诸众大导师　　名所不能显
  后当成正觉　　一切众生尊
  号名曰医王　　普闻十方界
  七十拘胝岁　　说法度众生
  其两足世尊　　久当入寂灭
  二十大集会　　调伏众生心
  最后一大会　　经二百亿岁
  如所说大会　　度无量声闻
  如声闻数量　　菩萨众亦尔
  利益众生已　　如来方涅槃
  正法住世间　　经于百千岁
  满五百劫中　　是苾刍成佛
  于彼一一劫　　千如来出现
  诸有智慧者　　当思法水灌
  应生勇猛心　　行多闻正理
  远于非正理　　常修正理法
  应修习多闻　　由此慧增长
  四根本法义　　济度诸菩萨
  施戒闻舍法　　贤善菩提道
  为众说是法　　最胜无上乘
  演布声闻道　　善断诸疑网
  诸有请问者　　我今悉开许
  能说深妙法　　照世者难遇

尔时金毗罗子世罗。即于佛前闻佛授记。欢喜踊跃得未曾有。作如是念。今者世尊将往鹫峰山王。我当复应于如来所殖少善根。作是念已。告其众曰。卿等当知。如来当发王舍大城升鹫峰山。卿等宜可发勇猛心。随其力能办诸供养。时彼世罗即与官属。从王舍城至鹫峰山。中间道路屏除草秽甎瓦砾石株[木*瓦]毒刺。极令遍净如明镜面。又以香水沾洒其地。敷胜妙衣遍于中路。散布名华量与人等。烧妙坚香顺路普熏。列树幢旛悬诸宝盖。于虚空中张施缯彩。条别间设罗布其上。又作种种天诸音乐。前后充满。其路极广尽一箭道。皆遍覆以水生诸花。所谓殟钵罗花钵特摩花拘贸陀花奔荼利花。又以鸳鸯胜鸟间错其花。行列道侧。于彼道上。又以金缕缯彩而用敷之。上施七宝所成殊妙等网。遍覆于道。时彼世罗。于佛由路。作如是等大庄严已。自化其身极令姝大。与诸官属欢喜踊悦。倍生欣庆发诸胜心。所谓畅适心调善心。柔软心清净心。离盖心充美心。归依佛心归依法心归依众心。不动菩提心不退转心。无等心无等等心。超过一切三界心。于一切众生起大慈心。起大悲心起大喜心起大舍心。起一切佛法器心。坚心固心。不可坏心不朽败心。舍离声闻独觉地心。成立一切菩萨地心。彼住如是诸胜心已。往如来所顶礼佛足。右绕三匝却住一面。合掌向佛。而说颂曰

  我已为世依　　办无上供养
  佛为世间尊　　演最上法者
  十力皆成就　　安住诸无畏
  利益众生事　　如导师所作
  具相三十二　　八十随形好
  世怙犹如日　　流光遍于世
  转于妙法轮　　最胜十二行
  宣布深妙法　　利益群生故
  显示诸神变　　如佛之仪式
  为多拘胝众　　作诸利益事
  未来诸大雄　　祐世间如日
  宣扬彼圣法　　悟成无上智
  为舍为救拔　　为道为归趣
  为诸生盲众　　导之施慧眼
  五趣众生类　　我当作依怙
  解脱诸苦聚　　如先佛所离
  我为两足尊　　天中天日月
  天帝那伽众　　阿素洛奉敬
  所设诸供具　　世无有等者
  我作上妙业　　无有相似者
  如法主世尊　　具足三十二
  上微妙福相　　世无与等者

尔时世尊。为金毗罗子世罗。而说颂曰

  诸供大师者　　为最上法因
  彼有情中胜　　菩提不难得
  供养照世间　　光性世依怙
  诸天龙及人　　所应供养者
  悟上妙菩提　　坐最胜道树
  摧伏诸恶魔　　为众生说法

尔时世尊。与无量百千天龙药叉罗刹健达缚紧捺洛牟呼洛伽人与非人。复有无量百千那庾多拘胝诸众生等。前后围绕。佛于其中最居众首。以如来大威德故。大神通故。大宗势故。种种自在大变化故。放大光明震动大地。雨大莲花满虚空中。鼓于百千那庾多拘胝天诸伎乐。时诸大众叹未曾有。既睹神变倍加恭敬。尔时如来。足步莲花大如车轮。随庄严道往鹫峰山王。既到彼已。告长老阿难陀曰。汝为如来敷置胜座。所谓最上之座。法座微妙座。胜过一切三界座。尊胜座佛座。如来之座。我当于此坐。为欲利益一切众生故。说大乘菩萨行所依经。名微妙吉祥大菩萨藏。此经能令一切众生疑山崩堕。此经能令一切众生疑网断绝。此经能令一切众生疑根不生。此大乘经利益安乐诸众生故。哀愍大众及诸天人。是故如来方为开阐。尔时长老阿难陀。如佛所教敷施法座。时彼众中有六十八拘胝天子。各舍上衣。为如来故敷法座上。佛于其上如常敷座。顾诸天子。而说颂曰

  诸天敷衣服　　最胜上微妙
  救世大导师　　安处此法座
  到诸法彼岸　　如来升座已
  大地六种动　　令众皆欢喜
  放光照佛土　　并耀诸山王
  世尊现神通　　济度乐法者
  诸天龙及人　　鸠槃荼饿鬼
  布怛那等众　　互相见无障
  百千那庾多　　拘胝诸天等
  睹佛放光明　　此时甚难遇
  频毗婆罗王　　诸大臣围绕
  来诣世依怙　　最胜如来所
  佛知天龙人　　大众皆坐已
  为利诸众生　　顾视于四方
  告诸有疑者　　当问两足尊
  我将导世间　　善断诸疑网

尔时三千大千世界所有众生。为听法者皆来集会。既闻如来说是法已。为闻法故静息外缘。心住一境摄念而住。尔时世尊。告长老大目揵连。汝今当知有。谁苾刍。住在远处未来会坐。当召令集。时长老大迦叶。在大雪山南面而住。大目揵连忆念知已。以神通力往彼白言。如来今者在鹫峰山。于大众前为诸天魔梵沙门婆罗门天人阿素洛等。当说妙法。正待仁者可共往彼。勿令我等于法障碍。时大迦叶语大目揵连言。汝且前往吾寻后至。作是语已。时大迦叶不起于座。化神通力入王舍城。将从四部导众而行。往鹫峰山顶礼佛足。于大众中对于佛前。不远而坐。时大目揵连睹斯化已。以神通力来至佛所。乃见迦叶先已处座。白迦叶言。尊者。成就速疾大神通分。乃能不起本座现斯神化。大迦叶言。世尊说汝神通第一。吾今微现未可涉言

    试验菩萨品第三

尔时长老舍利子。即从座起。以郁多罗僧覆左肩上。偏袒右肩以右膝轮而置于地。向佛合掌恭敬而住。白佛言世尊。我今欲有少问。唯愿如来应正遍知。哀愍听许为我解说。佛告长老舍利子言。恣汝所问。如来今者当为解说令汝心喜。舍利子白佛言。世尊。菩萨摩诃萨成就几法。身业无失。语业无失。意业无失。成就几法。身业清净。语业清净。意业清净。成就几法。身业不动。语业不动。意业不动。不为天魔及魔军众之所娆转。从初发一切智心修行正行。地地增胜善巧方便。为一切众生作胜导师。为普导师。为大照炬。为大梯蹬。为桥为船。为济度者。为彼岸者。为舍为救。为归为趣。而能不舍一切智心。尔时舍利子。欲重宣此义。以颂问曰

  菩萨何等义　　能住大菩提
  何名德及法　　由此悟无上
  又行何等行　　利益诸众生
  修习何法已　　成佛人中胜
  云何伏恶魔　　住最胜菩提
  震动拘胝土　　悟无上正觉
  菩萨者何义　　如是句云何
  云何为菩提　　及无上佛法
  云何行世间　　利益群生类
  不染如莲花　　解脱拘胝众
  云何为天龙　　非人等供养
  我诸所请问　　慈悲愿为说

尔时佛告长老舍利子。善哉善哉。吾今当为分别解说。舍利子。菩萨摩诃萨成就一法。则能摄受汝所问法及余无量无边佛法。何者一法。谓菩提心及备信欲舍利子。是名菩萨摩诃萨成就一法则能摄受无边佛法。舍利子白佛言。世尊。何等名为信欲具足。复以何义名菩提心。佛告舍利子。信欲具足者。是谓坚实不可坏故。是谓牢固不可动故。言不动者无蹶失故。无蹶失者能善住故。能善住者不退转故。不退转者观众生故。观众生者大悲根本故。大悲根本者不疲倦故。不疲惓者成熟众生故。成熟众生者善知自乐故。善知自乐者无希望故。无希望者不染资具故。不染资具者为众生依故。为众生依者观待下劣众生故。观待下劣众生者为救济故。为救济者为归趣故。为归趣者不卒暴故。不卒暴者善观察故。善观察者无怨嫌故。无怨嫌者善调信欲故。善调信欲者无所存故。无所存者善清净故。善清净者妙鲜白故。妙鲜白者内离垢故。内离垢者外善清净故。舍利子。如是坚实难坏。乃至内离于垢外善清净者。是名信欲具足也

佛复告舍利子。菩提心者何相何貌。舍利子。菩提心者无有过失。不为一切烦恼之所染故。菩提心者相续不绝。不为余乘中所证故。菩提心者坚固难动。不为异论所牵夺故。菩提心者不可破坏。一切天魔不倾败故。菩提心者常恒不变。善根资粮所积集故。菩提心者不可摇动。必能独证诸佛法故。菩提心者妙善安住。于菩萨地善安住故。菩提心者无有间断。不为余法所对治故。菩提心者譬如金刚。善能穿彻佛深法故。菩提心者胜善平等。于诸众生种种欲解无不等故。菩提心者最胜清净。性不染故。菩提心者无有尘垢。发明慧故。菩提心者宽博无碍。含受一切众生性故。菩提心者广大无边。如虚空故。菩提心者无有障碍。令无碍智遍行一切无缘大悲不断绝故。菩提心者应可亲近。为诸智者所称赞故。菩提心者犹如种子。能生一切诸佛法故。菩提心者为能建立。建立一切喜乐事故。菩提心者发生诸愿。由戒净故。菩提心者难可摧灭。由住忍故。菩提心者不可制伏。由正勤故。菩提心者最极寂静。由依一切大静虑故。菩提心者无所匮乏。由慧资粮善圆满故。复次舍利子。菩提心者即是如来尸罗蕴三摩地。蕴般罗若。蕴解脱。蕴解脱智见。蕴之根本也。又菩提心者即是如来十力四无所畏十八不共佛法之根本也。舍利子言。菩提心者谓以此心用菩提为生体故名菩提心。如是舍利子。诸菩萨摩诃萨成就信欲菩提心故。是名菩提萨埵。是名广大萨埵。是名极妙萨埵。是名胜出一切三界萨埵。是名身业无失语业无失意业无失。是名身业清净语业清净意业清净。是名身业无动语业无动意业无动。菩萨摩诃萨以具如是诸业净故。不为天魔及魔军众之所娆转。从初发一切智心修行正行。地地增胜善巧方便。不为一切世法所动。能为众生作大导师。作胜导师。作普导师。为大照炬。为大梯蹬。为桥为船。为济度者。为彼岸者。为舍为救。为归为趣。舍利子。菩萨摩诃萨如是发一切智心故。魔及魔军不能倾动

尔时佛告舍利子。诸菩萨摩诃萨。由具如是净信欲故。发阿耨多罗三藐三菩提心已。心多净信。乐睹贤圣。乐闻正法。乐不悭吝。开舒心手。而行大施。欣乐大舍。乐均普施。于诸众生心无挂碍。心无秽浊。心无愦乱。心不间杂。于业业报深心奉敬。无疑无虑。知黑白法果报不坏。乃至命难。不起诸恶。永离杀生不与取。邪淫行。妄语。乖离语。粗恶语。绮语。贪染。嗔恚。愚痴。邪见。为断如是不善业道。受持奉行十善业道。由具信故于诸沙门若婆罗门。正至正行具德具戒。其心纯净成调顺法。具足多闻勤行咨问。修正作意。调善寂静。亲近寂灭不起诤讼。非不爱语。善知信欲。非不善知。善法相应。远诸恶法。不掉不高。性离躁动。性离粗言。语无浮杂。守念正住。心安妙定。善断有本。不中毒箭。舍离重担。超度疑虑。及以后有诸佛世尊。菩萨摩诃萨。声闻独觉。于如是等善知友所。如实觉已亲觐敬仰奉事将遇。行者如是于善知友身行奉事。复以法施而摄受之。宣说妙法示教赞喜。所谓若行柁那得大财富。若行尸罗得生天乐。若好多闻获得大慧。若修诸定便离系缚。复为开显种种微妙清净胜法。此是布施此布施报。此是悭吝此悭吝报。此是尸罗此尸罗报。此是犯戒此犯戒报。此是忍辱此忍辱报。此是嗔恚此嗔恚报。此是正勤此正勤报。此是懈怠此懈怠报。此是静虑此静虑报。此是乱心此乱心报。此是智慧此智慧报。此是恶慧此恶慧报。此身妙行此身妙行报。此身恶行此身恶行报。此语妙行此语妙行报。此语恶行此语恶行报。此意妙行此意妙行报。此意恶行此意恶行报。此善此不善。此应作此不应作。此若作已感得长夜义利安乐。此若作已感得长夜非义非利非安乐果。舍利子。行者如是为诸善友。宣说是法示教赞喜。已觉知堪任大法器者。即为开示甚深微妙空相应法。所谓空法。无相法。无愿法。无行法。无生法。无起法。无我法。无数取法。无寿命法。无众生法。复为开示甚深缘起。所谓此有故彼有。此生故彼生。无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死愁叹忧苦身心焦恼。如是种种生起纯大苦聚。又此无故彼无。此灭故彼灭。谓无明灭故行灭。行灭故识灭。乃至生灭故老死灭。如是乃至纯大苦聚灭。舍利子。又应为说。此中无有一法。是有可得而可灭者。何以故。由彼诸法从因缘生。无有主宰。无有作者。无有受者。从因缘转。又无一法流转旋还。亦无随转。由痴妄故假立三界。从烦恼苦之所流转但假施设。行者如是如实观察痴妄之时。无有一法能作余法。若于是中无有作者。作者不可得故。乃至无有一法流转旋还。流转旋还不可得故。舍利子。行者若闻如是甚深法已无疑无虑。善入诸法无挂碍性。是人不着于色。不着受想行识。不着眼色及以眼识。不着耳鼻舌身意法及以意识。皆不可得故

复次舍利子。菩萨摩诃萨信受如是性空法已。不退见佛。不退闻法。不退奉僧。在在所生不离见佛。不离闻法。不离奉僧面生佛前猛励正勤志求善法。是人住正勤已。不恋居家男女眷属奴婢仆使及诸资具。是人不为淫欲所娆。速于今生舍盛年乐。以净信心于佛法中出家入道。既出家已得善知识善伴善友。善住思惟善住信欲。由善住信欲故。善听闻法坚奉修行。不但言说以为宗极觉慧成就。乐求多闻无有厌足。如所闻法以无染心为他广演。于诸利养恭敬名誉情无希望。不舍正义妄为他说。如其所闻如其所住而为说法。于听法众起大慈心。于诸众生起大悲心。舍利子。行者如是有多闻故。不顾身命。少欲知足。寂静欣乐。易满易养。乐处空闲。如所闻法观察其义。依于实义不依于文。为诸天人阿素洛界之所依止不专为己。为诸众生求于大乘。所谓佛智无等智无等等智。胜出一切三界之智。舍利子。我说是人获得第一不放逸法。舍利子。云何名为不放逸法。所谓诸根寂静。何等诸根寂静。所谓眼见于色不取相貌。如实觉知色味色患及色出离。如是耳所闻声。鼻所嗅香。舌所尝味。身所觉触意所识法。不取相貌。如实觉知法味法患及法出离。舍利子。如是名为心不放逸。复次不放逸者。调伏自心善护他心。除乐烦恼趣乐正法。不行欲觉恚觉害觉。不行贪不善根嗔不善根痴不善根。不行身恶行语恶行意恶行。不行不如理作意。不行一切恶不善法。此则名为不放逸也。如是舍利子。是诸菩萨摩诃萨既不放逸。能勤修习如理作意。若法是有如实知有。若法是无如实知无。观察此中何者是有何者是无。即以慧力如实能知。正修习者圣解脱有。邪修习者圣解脱无。无业报者此则是有。有业报者此则是无。复次眼为是有有眼者无。耳鼻舌身意。意为是有有意者无。复次色为无常苦变异法。此则是有。色为常住不变不坏。此则是无。受想行识无常苦变异法。此则是有。受想行识常住不变不坏。此则是无。复次无明为缘诸行则有。若无无明诸行则无。乃至以生为缘老死则有。若无生者老死亦无。复次施感大财此则是有。施感贫穷此则是无。持戒生天此则是有。犯戒生天此则是无。闻生大慧此则是有。诸恶慧者能生大慧。此则是无。修定离缚此则是有。修定系缚此则是无。复次若如理作意而有系缚。不如理作意离系缚者。此二俱无。若诸菩萨发起正勤菩提则有。若起懒惰菩提则无。若无憍慢出家授记。是名为有。若憍慢者寂灭则无。复次遍一切处空性是有。遍一切处有我数取众生寿命丈夫等类。此则为无。如是舍利子。若诸菩萨摩诃萨行不放逸。能善修习如理作意。世间智者同知是有。施设为有。世间智者同知是无施设为无。舍利子。若定说有非正了知。若定说无是亦名为非正了知。何以故。诸佛世尊所说实义能随觉了故。舍利子。诸佛世尊具大智力总摄诸法。安处四种邬柁南中。何等为四。所谓一切行无常。一切行苦。一切法无我。涅槃寂灭。舍利子。所演一切行无常者。如来为诸常想众生断常想故。所演一切行苦法者。如来为诸乐想众生断乐想故。所演一切无我法者。如来为诸我想众生断我想故。所演寂灭涅槃法者。如来为诸住有所得颠倒众生。断有所得颠倒心故。舍利子。是诸菩萨摩诃萨。若闻如来说一切行为无常者。即能善入毕竟无常。若有闻说一切行苦。则能兴厌起离愿心。若有闻说诸法无我。则能修习于三摩地妙解脱门。若有闻说寂灭涅槃。则能修习无相三摩地。而不非时趣入真际。如是舍利子。若诸菩萨摩诃萨。能善修习如是法者。终不退失一切善法。速能圆满一切佛法

大宝积经卷第三十六大宝积经卷第三十七

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之三如来不思议性品第四之一

尔时佛告舍利子。是诸菩萨摩诃萨。善住如是清净信已。复能信受如来应正遍知十种不可思议法。谛奉清净无惑无疑不异分别。倍复踊跃深生欢喜发希奇想。舍利子。何等名为如来十种不思议法。舍利子。一者信受如来不思议身。二者信受如来不思议音声。三者信受如来不思议智。四者信受如来不思议光。五者信受如来不思议尸罗及以等观。六者信受如来不思议神通。七者信受如来不思议力。八者信受如来不思议无畏。九者信受如来不思议大悲。十者信受如来不思议不共佛法。舍利子。是名十种不思议法。若有菩萨摩诃萨。为求法故兴起正勤。不怯不退不生舍离发如是心。我今未得不思议法。宁使风所转身皮肉筋骨受大苦恼。或复血肉干枯竭尽。要必勤行精进中无暂废。如是舍利子。已得信解诸菩萨摩诃萨。若闻如是如来十种不思议法。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  佛身难思议　　为真法身显
  无相不可观　　唯佛子能信
  诸趣杂种类　　音声不可思
  随音为说法　　信诸佛境界
  一切种群生　　三世诸根异
  佛皆能觉了　　信是不思议
  诸佛无边光　　光网不思议
  遍满十方界　　无边佛土海
  佛戒超世间　　不依止世法
  神足不思议　　菩萨能信受
  众生不能知　　如来之境界
  如来常在定　　解脱不思议
  法界不相杂　　唯佛力能知
  大仙诸智力　　犹若空无际
  为利一众生　　住无边劫海
  令其得调伏　　大悲心如是
  一切诸群生　　种种问难海
  一音令悦解　　无畏不思议
  成一切种智　　随觉于诸法
  及不共佛法　　遍智皆能见
  一切难思议　　诸佛法如是
  有能奉信者　　是为善住信

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议身。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。舍利子。所谓如来身者永断一切恶不善法。何以故。由能成就一切微妙诸善法故。如来身者远离一切不净洟唾。痰癊脓血大小便利。何以故。如来久已解脱一切骨肉筋脉故如来身者自性清彻。何以故。如来久已远离一切烦恼诸垢秽故。如来身者出过世间。何以故。不为世法之所染污故。如来身者无量功德。久已积集福智资粮。一切众生慧命依止。如来身者无量净戒之所熏修。无量等观及无量慧解脱解脱智见之所熏修。如来身者诸功德华之所严饰。如来身者如净镜中微妙之像。如净水中明满之月。又如光影之所照耀。如来身者不可思议等虚空界极法界性。如来身者清净无染远离一切诸染秽浊。如来身者即是无为远离一切诸有为相。如来身者是虚空身。是无等身。无等等身。一切三界无与等身。如来身者无譬喻身。无相似身。如来身者清净无垢。离诸烦恼自性清彻。又舍利子。如来身者不可以前际求。不可以后际求。不可以现在求。不可以生处种姓求。如来身者不可以色求。不可以相求。不可以好求。如来身者不可以心求。不可以意求。不可以识求。如来身者不可以见求。不可以闻求。不可以念求。不可以了别求。如来身者不可以蕴求。不可以界求。不可以处求。如来身者不可以生求。不可以住求。不可以坏灭求。如来身者不可以取求。不可以舍求。不可以出离求。不可以行求。如来身者不可以显色求。不可以相貌求。不可以形色求。不可以来求。不可以去求。如来身者不可以净戒作意求。不可以等观作意求。不可以正慧作意求。不可以解脱作意求。不可以解脱智见作意求。如来身者不可以有相求。不可以无相求。不可以诸法相求。如来身者不可以力增益求。不可以无畏增益求。不可以无碍辩增益求。不可以神通增益求。不可以大悲增益求。不可以不共佛法增益求。舍利子。菩萨摩诃萨欲求如来身者。当应如幻如焰如水中月如是自性求如来身。舍利子。如来身者即是空无相无愿解脱之身。无变异身。无动坏身。无分别身。无依止身。无思虑身。如来身者即是安住善住得不动身。如来身者即是无色色自性身。即是无受受自性身。即是无想想自性身。即是无行行自性身。即是无识识自性身。舍利子。如来身者无有无生无四大身。如来身者即是希有希有法身。如来身者非眼所起。不在色中。亦不在外。不依于耳。不在声内亦不在外。非鼻所知。不在香中。亦不在外。非舌所显。不在味中。亦不在外。不与身合。不在触中。亦不在外。如来身者不依心转。不依意转。不依识转。安住不动。非是旋还。亦不随转。舍利子。如来身者等量虚空。如来身者极于法界。如来身者尽虚空界。舍利子。是名第一如来不思议身。是诸菩萨摩诃萨。闻如来不思议身如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  拘胝那庾劫　　行无量大行
  善净身三业　　获无等佛身
  慈心遍十方　　起大悲行施
  常离邪淫行　　得胜虚空身
  于世尊福田　　佛子广行施
  舍净珍服等　　如无量殑沙
  奉持于净戒　　如牦牛护尾
  假使碎身苦　　于怨大忍生
  正勤波罗蜜　　修行极疲苦
  发弘大誓愿　　求常住佛身
  乐观诸定境　　乐广慧方便
  乐观于法界　　愿等法界身
  于佛行善已　　成无等妙觉
  获大虚空身　　清白离尘染
  无我人性空　　无相不可说
  证是牟尼身　　过诸眼境界
  意净离色声　　本空无起作
  见真如身者　　则见十方佛
  如种种幻化　　象马狂夫等
  诳惑愚倒者　　如是观十方
  三世无量佛　　同处法性身
  无等等虚空　　极清净法界

如是舍利子。是名如来不可思议身。菩萨摩诃萨。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议音声。信受谛奉清净无疑。乃至发希奇想。舍利子。如来出世愍诸含识敷演法化。所发音声齐于众会。由所调伏众生力故。如来音声普遍十方无量世界。令诸众生心欢喜故。舍利子。然诸如来所出音声。虽遍世界不作是念。我为苾刍众说法。我为苾刍尼众说。法。我为邬波索迦众。邬波斯迦众。婆罗门众。刹帝利众。长者众。天众梵众。如是等众。而为说法。亦不作是念。我今演说契经。应颂。记莂。伽他。自说缘起。本事。本生。方广。希法。譬喻。解释。如是等趣十二分教。初未生念为之敷演。舍利子。如来随诸众集。所谓苾刍乃至梵众。如其所闻种种正勤而为说法。是诸众生乐闻法故。各自谓闻如来法声面门而发。然是法声于其所说。种类言词不相障碍。各别悟解自所了法。是则名为不可思议。舍利子。诸佛如来先福所感。果报音声其相无量。所谓慈润声。可意声。意乐声。清净声。离垢声。美妙声。喜闻声。辩了声。不[革*卬]声。不涩声。令身适悦声。心生踊跃声。心欢悦豫声。发起喜乐声。易解声。易识声。正直声。可爱声。可喜声。庆悦声。意悦声。师子王吼声。大雷震声。大海震声。紧捺洛歌声。羯罗频伽声。梵天声。天鼓声。吉祥声。柔软声。显畅声。大雷深远声。一切含识诸根喜声。称可一切众会声。成就一切微妙相声。舍利子。如是等如来音声具足如是殊胜功德。及余无量无边功德之所庄严。舍利子。是名第二如来不思议音声是诸菩萨摩诃萨。闻如来不思议音声具足无量殊胜功德。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  导师演妙音　　所谓梵音声
  由是法具足　　令诸梵欢喜
  牟尼演妙音　　从大悲流涌
  谓与慈相应　　喜舍亦如是
  如是具足音　　灭众生贪火
  息除嗔恚毒　　坏裂诸痴暗
  假使赡部洲　　无量种人声
  纵获遍闻已　　终不悟解脱
  天地虚空声　　不悟亦如是
  若闻圣主声　　必能证寂灭
  二足及四足　　多足及无足
  悉同彼音声　　悟之善恶法
  三千世界内　　下中上音声
  随彼种类音　　化令证解脱
  演无分别声　　无缚无摄受
  处定开真谛　　闻者息烦恼
  无边众生闻　　佛法僧音声
  及施戒闻忍　　如来声如是
  彼声非有量　　声智但无边
  信佛声无疑　　唯聪慧菩萨

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议大智。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。舍利子。如来无碍智见不可思议。于一切法中依之而起。诸菩萨摩诃萨则能信受谛奉。乃至发希奇想。舍利子。如来为生信故。依如来智波罗蜜多。广说譬喻。诸有智者便得开解。舍利子。假使有人以殑伽沙等世界中所有草木茎干枝叶。下至量齐四指积为大聚。以火焚之乃变成墨。掷置他方殑伽沙等世界海中。于百千岁就以磨之尽为墨汁。舍利子。如来成就如是无碍智见。以是智故。从彼如是大海之中取一墨滴。以智力故。分析了知是某世界。如是树成某根某茎。某枝某条。花果叶等。类别所作皆悉了知。何以故。舍利子。由如来善通达法界故。而能如是了知此墨从某世界某树而来。如是次第乃至广说。舍利子。是名如来应正遍知。具足如是大神通力。具足如是大威德力。具足如是大宗势力。是故舍利子。若有善男子善女人。于如来大智清净信受。又于佛所起爱敬心者。彼善男子善女人。所有善根叵知其边速尽苦际。何以故。舍利子。如来善通达法界故。由通达故。若有众生于如来所起微善者。尽于苦际毕竟不坏。舍利子。我今为汝复说譬喻。令有智者因此喻故于义解了。舍利子。如有男子寿命百年。此人持一毛端。散分以为百五十分。取毛一分沾水一滴。来至我所而作是言。敢以滴水持用相寄。后若须者当还赐我。尔时如来。取其滴水置殑伽河中。而为彼河流浪洄澓之所旋转。和合引注至于大海。是人满百年已来至我所。而白我言。先寄滴水今请还我。舍利子。如来成就不思议智。由是智故。如来应正等觉。知彼水滴在于大海。便以一分毛端就大海内。沾本水滴用还是人。舍利子。此譬喻者义何谓耶。所谓众生曾以一滴微善之水。寄置如来福田手中久而不失。如是舍利子。若有善男子善女人。于如来不思议智。清净信受起爱敬心。缘念如来兴诸供养。又以名花散空奉献。是人所有善根叵知其边速尽苦际。何以故。舍利子。如来善通达法界故。若人于如来所起一念善心者。尽于苦际毕竟不坏

尔时长老舍利子。白佛言。世尊。如来不思议大智离识而转不。佛言不也。舍利子复白佛言。世尊。若如是者云何为智。云何为识。佛言。舍利子。有四识住识。依此住故名识住。何者为四。所谓色识住者识缘于色识住色中。由如此故生喜住着。转加增长坚固广大。受识住者识缘于受识住受中。由如此故生喜住着。转加增长坚固广大。想识住者识缘于想识住想中。由如此故生喜住着。转加增长坚固广大。行识住者识缘于行识住行中。由如此故生喜住着。转加增长坚固广大。舍利子。如是等相名之为识。复以何等名之为智。所谓不住五受蕴中了达识蕴。是名为智。又舍利子。所言识者。谓能了别地界水界火界风界。是名为识。所言智者。若有不住四大界中能善通达识之法界不相离者是名为智。又舍利子。所言识者。谓能了别眼所知色。耳所知声。鼻所知香。舌所知味。身所知触。意所知法。是名为识。所言智者。于内寂静不行于外。唯依于智。不于一法而生分别。及种种分别。是名为智。又舍利子。从境界生是名为识。从作意生是名为识。从分别生是名为识。无取无执。无有所缘。无所了别。无有分别。是名为智。又舍利子。所言识者。住有为法。何以故。无为法中识不能行。若能了达无为之法。是名为智。又舍利子。住生灭者名之为识。不生不灭无有所住。是名为智。舍利子。如是诸相若识若智。是名如来第三不思议大智。若诸菩萨摩诃萨。闻如是不思议大智无障无碍。一切法中依之而起。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  无量殑伽沙　　十方界草木
  尽焚成墨灰　　亿载磨于海
  十力智深妙　　取滴示含生
  如实分别知　　此某界树等
  如是十方界　　尘水示如来
  佛智等虚空　　遍晓无疑滞
  十方众生心　　发贪嗔痴行
  如实悉能知　　无增减解脱
  十力世尊智　　照明于法界
  无分别离思　　佛子能信受

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议大光。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。舍利子。诸佛如来善通达法界故。不可思议。由通达故一切如来放大光明。遍照三千大千佛之世界而无障碍。舍利子。譬如空中无诸云雾。日轮炎盛放大光明遍照于世。如是舍利子。如来应正等觉放大光明遍照一切。亦复如是。又舍利子。如世间中灯油之光。于萤火光为广为大。显照明净超过最胜。烛炬之耀超胜灯光。庭燎火聚又胜烛炬。药草发光踰于火聚。星宿之光倍过药草。满月流光又过星耀。炎盛日光踰超于月。四天王天身所发光宫殿光。墙壁光。庄严具光。倍胜于前不可为喻。如是展转。乃至他化自在天身。宫殿墙壁身庄严具。皆发光明又倍于上。梵身天光。梵辅天光。梵众天光。大梵天光。如是少光。无量光。光净。少净乃至遍净。广果。有想。无想。无烦。无热。善现。善见。色究竟天。所有身光。宫殿光。墙壁光。庄严具光。比前诸光为最第一。如是色究竟天所有光明。比于如来正遍知光。而如来光超过于彼。微妙显照最胜明净。广大第一不可为喻。何以故。舍利子。如来光者不可思议。从无量戒聚生。从等持聚生慧聚解脱聚。解脱智见聚生。从如是等无量功德之所由生。又舍利子。三千大千世界所有诸光。比如来光百倍。不及其一。乃至优波尼商倍不及其一。如是算数譬喻所不能及。复次舍利子。如赡部捺陀金置凡金中。令彼凡金犹如墨聚失于明照。如是舍利子。于此三千大千世界中所有光明。若于如来光前不能明照亦复如是。又一切世间所有诸光。于如来光前不可说言。有光有净有胜有上有无上也

复次舍利子。汝今当知如来不为怜愍众生摄持此光。令周一寻者但以一分业所生光。则能遍照三千大千佛之世界。令日月光悉不复现。若如是者不可分别有昼有夜。不可分别有月半月。及以时节岁数分齐。但为怜愍诸众生故现周一寻。舍利子。若如来应正遍知。发意欲以光明遍满。无量无数无边世界则能遍照。何以故。舍利子。如来以得第一般若波罗蜜多故。舍利子。我今为汝更说譬喻重明此义。诸有智者倍增显了。舍利子。假使有人以此三千大千世界。碎为微尘置衣襟中往至东方。过尔所微尘数世界乃下一尘。如是展转尽此微尘。而此东方所有世界未尽其边。如是南西北方四维上下亦复如是。舍利子。于汝意云何。颇有人能得是世界诸边际不。舍利子言。不也薄伽梵。不也苏揭多。舍利子。是诸世界所有诸光。无量无边不可思议。而如来光最为第一。彼一切光于如来光百倍不及其一。乃至优波尼啇分不及其一。如是算数譬喻所不能及。舍利子。如来发意。欲以光明遍照一切世界。则能遍照。何以故。由如来得第一般若波罗蜜多故。舍利子。如来光者无有障碍。所有墙壁。若树若木。若轮围山。大轮围山。乾陀摩达那山。目脂邻陀山。大目脂邻陀山。伊沙陀罗山。雪山黑山。及苏迷卢山王。如是等皆不能障。佛之光明悉能洞彻。遍照三千大千世界。舍利子。少智众生不能信解如来光者。或有众生见如来光唯照一寻。次有智者见如来光照于二寻。次有智者见如来光照拘卢舍。次大智者乃至能见如来光明。遍照三千大千世界。舍利子。乃至百千世界主梵天王。能见如来光明遍照百千世界。如是展转。乃至已登上地诸大菩萨摩诃萨。能见如来光明遍照无量无边世界。舍利子。如来为欲怜愍诸众生故。又放光明遍照如虚空等诸众生界。舍利子。是名第四如来不思议光。诸菩萨摩诃萨。闻如来说是大光不可思议如虚空已。无惑无疑清净信受。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义而说颂曰

  日月等光明　　及诸释梵等
  乃至色究竟　　无光等佛者
  色究竟天光　　遍照三千界
  比佛一毛光　　十六不及一
  如来所放光　　遍满虚空界
  诸大慧众生　　方能见如是
  佛光无有边　　量等虚空性
  随所化众生　　见光有差别
  如有生盲者　　不见日光明
  彼不见光照　　谓日光无有
  下劣诸众生　　不见佛光明
  彼不见光照　　谓佛光无有
  或见光一寻　　或见拘卢舍
  或及一由旬　　或满三千界
  已住于大地　　大慧光菩萨
  或住八九地　　至于十地者
  如来超彼地　　光轮无有边
  不思议佛土　　施作诸佛事
  诸佛不思议　　佛光不思议
  信者及获福　　亦尔难思议

尔时佛告舍利子。云何菩萨摩诃萨。于如来不可思议净尸罗众及三摩地众。信受谛奉清净无疑。倍复踊跃深生欢喜。发希奇想。舍利子。汝等应知如是正说。若诸含识在于世间。奉持尸罗清净无染。由清净故。当知是人成就清净身业。成就清净语业。成就清净意业。是人虽复常处世间。而不为彼世法所染。当知是人为婆罗门。为离诸恶。为沙门者为寂静者。是名第一修静虑者。得第一三摩地波罗蜜多者。舍利子。如是含识则是如来。如是说者是名正说。何以故。舍利子。我初不见诸天世间。若魔若梵若沙门若婆罗门。及余天人阿素洛等。具有如是无量无边不可思议清净尸罗三摩地众等如来者。何以故。舍利子。如来以得第一尸罗三摩地波罗蜜多故。舍利子。汝今欲闻佛说如来尸罗波罗蜜多譬喻不。舍利子言。今正是时薄伽梵。今正是时苏揭多。世尊。若诸苾刍闻佛所说如来尸罗波罗蜜多譬喻者。如所闻已当共受持。佛告舍利子。善哉善哉。吾当为汝分别解说。舍利子。于汝意云何。诸众生界与大地界何者最多。舍利子言。如我解佛所说义者。众生界多非地界也。佛言。如是如是。舍利子。众生界多非如地界。舍利子。假使三千大千世界所有众生。卵生胎生湿生化生。若有色若无色。若有想若无想。若非有想非无想所有众生。彼一切众生于一刹那顷。或一牟呼罗多顷。或一罗婆顷。假使同时皆得人身。舍利子。彼一切众生得人身已。于一刹那乃至一罗婆顷。假使同时悉成阿耨多罗三藐三菩提。是一一如来复化作尔所如来。是一一所化如来各有千头。是一一头各有千口。是一一口各有千舌。时彼一切诸化如来。皆悉成就如来十力四无所畏四无碍解。又成就佛无障无碍无尽辩才。舍利子。是诸如来以尔所舌。布演无碍无尽辩才。依一如来尸罗波罗蜜多众无量称赞。虽经拘胝那庾多百千大劫。如是称赞而如来戒众犹不能尽。舍利子。如来戒众无量无边。无有穷尽不可思议。是诸如来无上智慧。无碍无障无尽辩才。亦无穷尽不可思议。乃至诸化如来未至。同时入大涅槃。赞说如来戒众亦不能尽。何以故。如来戒众及诸世尊。无上智慧无碍辩才。此二俱是不可思议故。无量无数与虚空界平等平等。舍利子。且置三千大千世界所有众生。假使东方殑伽沙等世界中所有众生。如是南西北方四维上下。十方殑伽沙等世界中所有众生。彼一切众生于一刹那顷。乃至罗婆顷。同时皆得人身。俱成阿耨多罗三藐三菩提。如是广说。乃至如来戒众。及诸如来无上智慧无碍辩才。俱是不可思议无量无数。与虚空界平等平等。何以故。舍利子。由如来证得第一尸罗波罗蜜多故

尔时佛告舍利子。汝今欲闻佛说如来三摩地波罗蜜多譬喻不。舍利子言。今正是时。若诸苾刍闻佛所说。如来三摩地波罗蜜多譬喻者。如所闻已当共奉持。佛告舍利子。假使有时于此世间。劫将欲烧由第七日。彼日出故。三千大千世界一时烧然。如是极然遍极然大洞然。舍利子。当知如来于此大洞然等世界之内。随于一处。假使如来在中若依经行若住若坐若卧。当知此处成就十种甚希奇法不可思议。舍利子。何等名为十希奇法。所谓如来游止之处。不加功力坦然平正犹如掌中。舍利子。是名此处成就第一甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然高踊显敞无杂瓦石。舍利子。是名此处成就第二甚希奇法。复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然平博严净。而为如来之所受用。舍利子。是名此处成就第三甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然生诸香草。光色青翠卷软右旋。具细滑触如迦遮邻地。舍利子。是名此处。成就第四甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然八功德水出现于地。所谓一轻二冷三软四澄静五无秽六清净七乐饮八多饮无患。舍利子。是名此处成就第五甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然凉风和畅轻靡相发。此是如来先业所感。舍利子。譬如极炎热时。于日后分有一丈夫。热所逼故奔趣殑河。投于水中沐浴身体。热乏既息清凉悦乐。往返游戏度至余岸。经行往来遥见不远。有大树林枝叶翠盛阴影厚密。便往林中。复见施妙床座敷胜[毯-炎+瞿]毹。上加绵蓐。覆以迦遮邻地之帔。轻妙鲜支重覆其上。排软倚枕置床两头。彼大丈夫升于此床若坐若卧。于床四面清风微动轻扇相续。如是舍利子。如来于此大洞然等世界之中。行住坐卧。自然凉风微扇相续亦复如是。舍利子。是名此处成就第六甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来在中若依经行若住坐卧。其处自然江河池沼。有水生花种种出现。所谓殟钵罗花。钵特摩花。拘贸陀花。奔荼利花。其花芬馥光彩映发见者悦乐。舍利子。是名此处成就第七甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来于中行住坐卧。其处自然原陆陵阜。皆生妙花种种出现。所谓阿底目多迦花。瞻博迦花。苏末那花。婆使迦花。阿输迦花。波吒罗花。迦腻罗花。怛罗尼花。瞿怛罗尼花。如是等花开敷鲜荣色香具足。众生见者得未曾有。舍利子。是名此处成就第八甚希奇法

复次舍利子。假使如上世界乃至大洞然等。如来于中行住坐卧。其处自然金刚为体坚固难坏。舍利子。是名此处成就第九甚希奇法

复次舍利子。假使如上三千大千世界劫欲尽时。乃至烧极烧遍极烧然极然遍极然大洞然等。是诸世界如来在中。若依经行若住坐卧。当知其处是佛灵庙诸天世间。若魔若梵若沙门若婆罗门。天及人民阿素洛等。恭敬供养尊重之处。舍利子。是名此处成就第十甚希奇法

复次舍利子。汝今当知如是十种甚希奇法。皆是如来先世业力之所成就。何以故。舍利子。如来善通达法界故。由通达故。如来应正遍知入是三摩地。依此定心受乐不退。虽经殑伽沙等诸大劫住。然如来未曾退起三摩地心。舍利子。如来应正遍知。依此定心经一食顷。或住一劫百劫千劫。或住百千劫或住一拘胝劫。百拘胝劫。千拘胝劫。百千拘胝劫。或复乃至过于上数。何以故。如来应正遍知。成就第一三摩地波罗蜜多故。由成就故。如来具足如是大神通力。具足如是大威德力。具足如是大宗势力。舍利子。如彼非想非非想处。诸天子生识缘一境。经八万四千劫住。乃至三摩地寿命未尽已来。此识不为余境界识之所移转。舍利子。彼诸天子尚以世定之力经尔所时。何况如来三摩地波罗蜜多而无久住

复次舍利子。如来应正遍知。初证阿耨多罗三藐三菩提夜乃至入无余大般涅槃界夜。于其中间。如来之心于三摩地未曾有起。故名此定无回转心。无所行心。无观察心。无动虑心。无流荡心。无摄众聚心。无散乱心。无高举心。无沉下心。无防护心。无覆藏心。无欣勇心。无违逆心。无萎悴心。无动摇心。无惊喜心。无惛沉心。无分别心。无异分别心。无遍分别心。又此定者不随识心。不依眼心。不依耳鼻舌身意心。不依色心。不依声香味触法心。不趣诸法心。不起智心。不观过去心。不观未来心。不观现在心。舍利子。如来应正遍知住三摩地。如是离心无有一法而可得者。于一切法中无碍智见生。以无功用故。又舍利子。如来不起于三摩地。离心意识而能作诸佛事。以无功用故。如是舍利子。是诸菩萨摩诃萨。闻如来不思议尸罗及三摩地已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  无量无等百千劫　　昔有趣中行觉行
  戒闻定忍不放逸　　导师能修妙觉因
  最胜业果净如是　　妙广净戒超诸有
  十力尊戒如空净　　难说无垢譬虚空
  从佛初得菩提夜　　至后入于寂灭夜
  佛心无行无异行　　大静虑定未曾起
  十力戒聚无退分　　解脱神力亦如是
  一心住经无量劫　　大圣无思无异思
  佛智如空非思境　　明达无缘照三世
  无心意思无改变　　唯有佛子能信受

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议神力。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。舍利子。如来应正遍知所获神通。不可思议不可宣说。今当为汝方便开显。舍利子。如来常说我声闻众中得神通者。所谓长老大目犍连最为第一。舍利子。如是所得神通。若以称量观察声闻神通。不见有与菩萨神通等者。若以称量观察声闻菩萨所得神通。不见有与诸佛如来。神通等者。舍利子。是名如来不可思议神通。是诸菩萨摩诃萨。为欲证得如来神通者。倍应发起上品正勤则能获证。舍利子。汝等今者欲于如来所闻说不思议神通譬喻不。舍利子言。今正是时。若诸苾刍闻佛所说神通譬喻者。如所闻已当共受持。佛告舍利子。谛听谛听。当为汝说。舍利子言。如是世尊。愿乐欲闻佛告舍利子。于汝意云何。尊者大目揵连有大神通不。舍利子言。我昔从佛受持是语。尊者大目揵连于声闻僧中神通第一。佛言。如是如是。舍利子。今当为汝广说譬喻。假使三千大千世界满中声闻。皆得神通如大目揵连。譬如甘蔗竹苇稻麻丛林。是诸声闻以诸正勤。迅速势力神通变化显现之时。欲比如来神通变化。百分千分。百千万分不及其一。拘胝分。百拘胝分。千拘胝分。百千拘胝分不及其一。如是僧佉分。迦罗分。伽拏那分。沤波摩分。优波尼商分不及其一。何以故。如来应正遍知。以得第一神通变化波罗蜜多故

复次舍利子。假使如来以一芥子投之于地。彼声闻众以诸正勤。迅速势力神通变化大显现时。终不能动所投芥子如毛端许。何以故。如来应正遍知。以得第一神通变化故。又舍利子。且置三千大千世界。假使东方乃至如殑伽沙等世界中所有众生。如是十方殑伽沙等世界众生。若卵生若胎生。乃至非想非非想处。一切众生俱是声闻。成就第一神通变化。皆如尊者大目揵连如是声闻以诸正勤。迅速势力神通变化大显现时。终不能动所投芥子如毛端许。何以故。如来以得第一波罗蜜神通波罗蜜多故。舍利子。是名如来具足如是大神通力。具足如是大威德。力。具足如是大宗势力

尔时薄伽梵。复告长老舍利子言。舍利子。汝颇曾闻风劫起时。世有大风名僧伽多。彼风所吹。举此三千大千世界。苏迷卢山王。轮围山。大轮围山。及四大洲。八万少洲。大山大海。举离本处高踰缮那碎为末不。舍利子言。我昔面于佛前亲闻受持如是之事。佛言。如是如是。舍利子。又风灾起更有大风名僧伽多。彼风所吹。举此三千大千世界。并苏迷卢山。轮围山等。及诸大海。举高百踰缮那已碎末为尘。或复举高二百踰缮那。或高四百五百。乃至举高千踰缮那。或高三千四千踰缮那已碎末为尘。乃至或高无量百千踰缮那。已碎末为尘。而此诸尘随风散灭了不可得。何况山石当有存者。此风又上击散坏灭焰摩天宫。乃至诸尘散灭。何况宫殿当有存者。如是展转次第而上。击散坏灭睹史多天。乐变化天。他化自在天。魔罗众天。婆摩天。净光天。遍净天所有宫殿。乃至彼诸微尘。亦皆散灭不可而得。何况宫殿墙壁而可存者。舍利子。假使如上大风卒起摧坏世界。即以此风吹如来衣。一毛端际尚不能动。何况衣角及全衣者。何以故。如来应正等觉。成就不可思议神通。不可思议威仪。不可思议妙行。不可思议大悲故。复次舍利子。假使十方如殑伽河沙等世界。有如是等大风轮起。将欲吹坏此诸世界。尔时如来以一指端。持此世界往至余处。或令风轮无力能吹飒然还返。然于如来神通变化。及一切力无有退减。舍利子。如来神通不可思议难闻难信。唯有诸大菩萨摩诃萨。乃能信受谛奉清净无惑无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  假使三界诸含灵　　一切变成声闻众
  尽得神通波罗蜜　　譬如尊者目揵连
  获大神通力如来　　以一芥子投于地
  一切声闻现神通　　未能摇转毛端量
  假使十方世界中　　所有殑伽河沙等
  吠岚僧伽大猛风　　吹碎如斯诸世界
  如是诸风大猛盛　　将吹一切智衣服
  尽其势力不能动　　乃至如一毛端量
  大牟尼尊以一毛　　能障彼风令不起
  佛具如斯大神力　　等彼虚空无边际

如是舍利子。是名如来不可思议大神通力。菩萨摩诃萨。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想

大宝积经卷第三十七大宝积经卷第三十八

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之四如来不思议性品第四之二

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议力。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。舍利子。诸佛如来俱足成就如是十力。由成就故。如来应正等觉。于大众中正师子吼。自称我处大仙尊位转大梵轮。一切世间所有沙门婆罗门。若天若魔若梵等不能如法而转。舍利子。何等名为如来十力。所谓处非处智力。业报智力。种种界智力。种种解智力。种种根智力。一切遍行行智力。静虑解脱三摩地三摩钵底杂染清净智力。随念前世宿住作证智力。死生作证智力。漏尽作证智力。舍利子。如来成就如是十力故。乃至于大众中能转梵轮。一切世间所不能转

复次舍利子。云何如来是处非处智力。舍利子。如来无上智力处非处者。所谓于是处如实知是处。于非处如实知非处。舍利子。何等为是处。何等为非处。舍利子言。非处者无所摄受。谓身恶行语恶行意恶行。能感可喜可乐可爱可意报者。无有是处。言是处者有所摄受。谓身恶行语恶行意恶行。能感不可喜不可乐不可爱不可意报者。斯有是处。又舍利子。言非处者无所摄受。谓身妙行语妙行意妙行。能感不可喜不可乐不可爱不可意报者。无有是处。言是处者有所摄受。谓身妙行语妙行意妙行。能感可喜可乐可爱可意报者。斯有是处。复次舍利子。言非处者无所摄受。谓由悭故能感大富。由犯戒故得生人天。由嗔恚故感得端正。由懈怠故能得对观。谓心乱者入正决定。由恶慧故永断一切相续习气。如是说者无有是处。言是处者有所摄受。谓由悭故能感贫穷。由毁犯戒便感地狱畜生鬼趣由嗔恚故感丑陋报。由懈怠故不得对观。由心乱故不入正定。由恶慧故不断一切相续习气。如是说者。斯有是处又舍利子。言非处者无所摄受。谓由布施能感贫穷。由持戒故堕于地狱畜生鬼趣。由含忍故感得丑陋。由正勤故不得对观。由心一缘不入正定。由圣慧故不断一切相续习气。如是说者无有是处。言是处者有所摄受。谓由布施能感大富。由持戒故得生人天。由怀忍故感得端正。由正勤故能得对观。由心一缘入正决定。由圣慧故永断一切相续习气。如是说者斯有是处

复次舍利子。言非处者无所摄受。谓因杀生而感长寿。不与取者能得大富。行邪欲者感贞良妻。如是说者无有是处。言是处者有所摄受。谓杀生者能感短寿。不与取者能感贫穷。行邪欲者妻不贞良。如是说者斯有是处。又非处者无所摄受。谓离杀者能感短寿。离不与取能感贫穷。离于邪欲妻不贞良。如是说者无有是处。言是处者有所摄受。谓离杀者能感长寿。离不与取能感大富。离邪欲者感贞良妻。如是说者斯有是处

复次舍利子。如是一切善不善业道是处非处。今当略说显示其要。谓妄语者不感诽谤。无有是处。若能感者斯有是处。离妄语者能感诽谤。无有是处。不感诽谤斯有是处。离间语者若能感得不坏眷属。无有是处。不能感者斯有是处。远离间语感坏眷属。无有是处。感不坏眷属斯有是处。粗恶语者若得常闻可意之声。无有是处。闻不可意声斯有是处。离粗恶语闻不可意声。无有是处。若不闻者斯有是处。若怀绮语感说言教令他信受。无有是处。若不信受斯有是处。若离绮语所说言教令他不受。无有是处。若信受者斯有是处。又舍利子。若贪著者感财不散。无有是处。若感散失斯有是处。若离贪着感财散失。无有是处。若不能感斯有是处。若心嗔恚不趣地狱。无有是处。若有趣者斯有是处。若离嗔恚不生善趣。无有是处。若往生者斯有是处。若兴邪见受邪见因能得道者。无有是处。不能得道斯有是处。谓正见者受正见因不得圣道。无有是处。能得圣道斯有是处

复次舍利子。造无间者心得安住。无有是处。若不安住斯有是处。又舍利子。若戒净者心不安住。无有是处。若得安住斯有是处。又舍利子。若住有所得见能得顺忍。无有是处。若不得者斯有是处。若信解空不得顺忍。无有是处。若有得者斯有是处。又舍利子。若住恶作得心安息。无有是处。若不能得斯有是处。若系心者不得心安。无有是处。若能得者斯有是处。又舍利子。若有女人为转轮王。为释天主。为梵自在。无有是处。若丈夫作斯有是处。若有女人出世作佛。无有是处转女身已出世作佛。斯有是处。又舍利子。若第八人未证于果而出受者。无有是处。证果已出斯有是处。若至圣流受第八有。无有是处。即此诸蕴而般涅槃。斯有是处。若一来人受第三有。无有是处。即此诸蕴而般涅槃。斯有是处。若不还人复还于此。无有是处。即于彼处而般涅槃。斯有是处。若阿罗汉更续生有。无有是处。若不更续斯有是处。又舍利子。若诸圣人更求邪师受邪标帜。无有是处。不求邪师及邪标帜。斯有是处。又舍利子。若得无生法忍菩萨有退转者。无有是处。定得菩提无有退转。斯有是处

复次舍利子。言非处者无所摄受。若诸菩萨安坐道场。不证菩提中而起者。无有是处。言是处者有所摄受。若诸菩萨坐于道场。证佛道已而便起者。斯有是处。又舍利子。言非处者。若谓如来习气相续。无有是处。言是处者。一切如来习气永断。斯有是处。又舍利子。若谓如来智有碍者。无有是处。佛智无碍斯有是处。又舍利子。若有能观如来顶者。无有是处。无有能观斯有是处。又舍利子。若有能知如来心住。无有是处。若不能知斯有是处。又舍利子。若言如来有不定心而可得者。无有是处。诸佛世尊心恒在定。斯有是处。又舍利子。若诸如来行不实语。无有是处。若诸如来是真语者。是实语者。是谛语者。不异语者。斯有是处。又舍利子。诸佛如来误失可得。无有是处。由无误失故名为佛及薄伽梵。斯有是处。舍利子。如是四无所畏十八不共佛法。亦应如是广分别说

复次舍利子。言非处者无所摄受。乃至如来于现在世。有障有碍智见转者。无有是处。言是处者有所摄受。佛薄伽梵于现在世。无障无碍智见转者。斯有是处。舍利子。是名如来处非处智力。不可思议无量无边。譬如虚空无边无际。如是如来处非处智力。无边无际亦复如是。若有欲求如来。应正等觉处非处智力边。际者不异有人求虚空际。舍利子。菩萨摩诃萨闻诸如来不可思议。是处非处智力如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  十方虚空无边量　　处非处智亦无边
  如实知处非处已　　为众广宣微妙法
  解脱道器成就人　　佛知其行方为说
  若非解脱道器者　　知非处已便舍离
  假使虚空可移动　　十方大地同时裂
  世出世间大圣尊　　处非处智皆如实

舍利子。此谓如来第一处非处智力。由成就故。如来应正等觉。于大众中正师子吼。自称我处大仙尊位转大梵轮。于诸世间所有沙门婆罗门。若天魔梵等。一切不能如法而转。复次舍利子。云何如来。业报智力。舍利子。如来应正等觉。以无上智力。如实能知去来今业及于业受。若因若处若诸异报皆能了知。舍利子。云何如来如实知耶。所谓如来应正等觉。如实能知过去业受。得于善因远离不善。于未来世当与善根为因。若于过去业受。得不善因远离于善。在未来世当与不善根为因。如是等相如来于此如实知之。若诸业受于未来世当顺劣分。若诸业受于未来世当顺胜分。如是等相如来于此如实知之。又舍利子。若诸业受于现在世顺下劣分。于未来世当顺胜分。若诸业受于现在世随顺胜分。于未来世顺下劣分。若诸业受于现在世顺下劣分。于未来世亦顺劣分。若诸业受于现在世随顺胜分。于未来世亦顺胜分。如是等相如来于此如实知之。又舍利子。若诸业受于过去世狭劣方便。于未来世广大方便。若诸业受少有所作获大胜进。若诸业受广有所作得少胜进。如是等相如实知之。又舍利子。若诸业受当得声闻性因。当得独觉性因。当得佛性因者。如是等相如来于此如实知之。又舍利子。若诸业受现在世苦。能于未来感乐异报。若诸业受现在世乐能于未来感苦异报。若诸业受现在世苦。能于未来感苦异报。若诸业受现在世乐。能于未来感乐异报。如是等相如来于此如实知之

复次舍利子。如来如实能知过去未来现在。一切有情若业若因。若诸异报。若即若离。若有随顺不异分者。如是等相如来知已。为诸有情如实宣说。舍利子。如来应正遍知去来今业。及业受因处所异报智。无量无边不可思议。譬如虚空无边无际。如是如来业异报智力。无边无际亦复如是。若有欲求如来应正等觉业异报智力边际者。不异有人求虚空际。舍利子。菩萨摩诃萨闻诸如来业异报智力如虚空不可思议已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊欲重宣此义。而说颂曰

  如来善知因异报　　明眼如实了诸业
  最胜三世无有碍　　有情诸行如实知
  一切含灵于五趣　　当得成诸苦乐因
  若能转因所转苦　　明照善逝如实知
  黑白异报一切业　　随其所应因异报
  犹若掌中如意宝　　善逝了观如实知
  诸异报业因虽少　　当来获果无有量
  或无量因感少果　　善逝遍能如实知
  若因当证声闻果　　及当证于独觉果
  能感无上妙智力　　善逝无余如实知
  若业成熟因时苦　　此业当获于乐果
  若业成熟因时乐　　当获苦果如实知
  若业因果皆住苦　　若业因果皆住乐
  若业自体因自体　　善逝相应如实知
  苦果循环于三世　　有情流转五趣中
  最胜圆满菩提智　　皆能不异如实知

舍利子。是名第二如来业异报智力。由成就故。如来应正等觉于大众中正师子吼。自称我处大仙尊位转大梵轮。于诸世间所有沙门婆罗门。若天魔梵等。一切不能如法而转。复次舍利子。云何如来种种解智力。舍利子。如来应正等觉以无上智力。能如实知彼有情类。彼数取趣非一欲解种种欲解。如来于此能并了知。舍利子。吾更为汝广分别说彼数取者。或住贪欲起嗔恚解。或住嗔恚起贪欲解。乃至住于愚痴起贪嗔解。如是等相如来如实皆能了知。又舍利子。若数取者住于不善起不善解。或住善法而起善解。是亦如来如实了知。若数取者住于下劣方便起广大解。或住广大方便起下劣解。或由此解下劣方便当住胜进。或由此解胜进方便当住下劣。是亦如来如实了知。又舍利子。若由此解当殖邪定种。若由此解当殖正定种。若由此解当殖正定解脱种者。是亦如来如实了知又舍利子。若由此解当趣欲界。或趣色界。或无色界。若由此解遍趣三界。是亦如来如实了知。又舍利子。若由此解顺下劣分当获胜进。或得胜进当住下劣。是亦如来如实了知。又舍利子。若由此解当于来世受种种生。受种种类种种受用。是亦如来如实了知。又舍利子。若由此解当退堕顶。或由此解殖解脱种。是亦如来如实了知。既了知已如其所应。广为有情如法演说。如是舍利子。如来非一解种种解智力。不可思议无边无际与虚空等。是诸菩萨摩诃萨。闻如来种种解智力如虚空不可思议已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  世间种种解　　过现无有量
  彼种种解心　　导师皆能了
  若有贪解者　　复当住嗔恚
  或现住嗔恚　　痴解如实知
  住痴起贪解　　心注不思议
  间杂流转起　　导师悉能知
  诸下劣方便　　而起广大解
  或增上方便　　导师悉能知
  随入于邪性　　复入所不趣
  解脱三界解　　如来悉能知
  种种生及类　　诸受用差别
  若退堕于顶　　两足尊能知
  知种种解已　　导师如法说
  是第三佛力　　最胜子能信

舍利子。是名如来第三种种解智力。由成就故。如来应正遍知。于大众中正师子吼。自称我处大仙尊位能转梵轮。一切世间沙门婆罗门。及天魔梵。不能如法而转

复次舍利子。云何如来种种界智力。舍利子。如来应正等觉以无上智力。如实了知一切世间种种诸界。由此界故。世间含生集起福行。集非福行。集不动行。或由此界殖出离种。如是等界如来于此如实了知。又舍利子。如来如实了知眼界色界及眼识界。如是等界云何知耶。谓如实知。由内空外空内外空故。乃至如实了知意界法界及意识界。如是等界云何知耶。谓如实知。由内空外空内外空故。又如实知地界水界火界风界。如是等界云何知耶。谓如实知。如空界故。如是欲界色界及无色界如实了知。遍分别所起故。又如实知有为界造作相故。无为界无造作相故。杂染界烦恼所引相故。清净界自体光净相故。又如实知诸行界不顺理无明相故。涅槃界顺理明相故。如是诸界皆能明了。是故舍利子。若界能安立世间。此界世间之所依住。如是若界能发牵引。若界能兴建立。若界能起方便。若界能生意欲。若界能起炽然。若界能为依止。舍利子。如是等界无量无边。是亦如来如实明了。既明了已如其所应。广为有情如法演说。舍利子。如来非一界种种界智力。不可思议无有边际与虚空等。若有欲求如来种种界智力边际者。不异有人求于空际。如是舍利子。是诸菩萨摩诃萨。闻如来种种界智力如虚空不可思议已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  世间诸含生　　依止种种界
  随其所流转　　最胜悉能知
  福非福不动　　及顺于出离
  住如是界已　　证寂静涅槃
  若眼界色界　　及以眼识界
  耳鼻舌身意　　诸界悉能知
  又知于法界　　及以意识界
  内外界悉空　　佛能如实知
  地界及水界　　火界与风界
  四界同空相　　如是悉能知
  若欲界色界　　及以无色界
  遍分别所起　　佛能如实知
  如虚空无边　　界无边亦尔
  佛皆能照了　　不谓我能知
  诸界本无生　　亦无有灭者
  是谓涅槃界　　胜丈夫能知
  如空量无边　　诸佛智如是
  由智能了知　　变异于诸界
  已知种种界　　调伏诸含生
  是佛第四力　　最胜子能信

舍利子。是名如来第四非一界种种界智力。由成就此力故。如来应正等觉。于大众中正师子吼。自称我处大仙尊位能转梵轮。一切世间沙门婆罗门。及天魔梵所不能转

复次舍利子。云何如来非一根种种根智力。舍利子。如来应正等觉。以无上智力故如实能知。若他有情若数取者。种种诸根差别之相。如来皆能分别了知。舍利子。如是等相云何知耶。所谓了知钝根中根利根胜根劣根。由随遍分别根故。能知众生起极重贪。起极重嗔。起极重痴。如是诸根。是亦如来如实了知。又舍利子。由随遍分别根故。如来能知。或起假立贪嗔痴。或起微薄贪嗔痴。或起颠倒贪嗔痴。或起摧伏贪嗔痴。如是等相是亦如来如实了知。又舍利子。若不善因所生诸根。若由善因所生诸根。若不勤因所生诸根。若出离因所生诸根。是亦如来如实了知。又舍利子。如来如实了知。眼根耳根。鼻根舌根。身根意根。女根男根命根。乐根苦根。忧根喜根。舍根信根。正勤根。念根慧根。三摩地根。未知当知根。知根知已根。如是诸根差别之相。是亦如来如实了知。又舍利子。如来如实知彼诸根。因于眼根当住耳根。而不住彼鼻舌身根。或因耳根当住鼻根。或因鼻根当住舌根。或因舌根当住身根或因身根。当住眼根。如是等根如来于此如实知之

复次舍利子。若诸有情住布施根修戒方便。尔时如来。以胜劣根智为说布施。若住戒根修施方便为说于戒。若住忍根修勤方便为说忍法。住正勤根修忍方便为说正勤。住静虑根。修慧方便为说静虑。若住慧根修定方便为说正慧。如是一切菩提分法。诸根差别如实了知。皆应广说。又舍利子。若诸有情住声闻根而返修于独觉方便。如来以诸根智为说下乘。住独觉根而修声闻智方便者。以诸根智为说中乘。住大乘根而修二乘智方便者。以诸根智为说大乘。住下劣根修大乘行。以诸根智为说二乘。若诸有情无堪任根无堪任相。如来如实知无堪任非法器已而便舍置。若诸有情有堪任根有堪任相。如来如实知有堪任是法器者。即便殷勤郑重说法令其悟入。如是舍利子。如来了知一切有情诸根纯熟及不纯熟。诸根出离及不出离。舍利子。诸有情根如来如实一切了知。住如是相。如是方便。如是信解。如是本因。如是所缘。如是等流。如是究竟。舍利子。如来种种根智。不可思议无边无际与虚空等。若有欲求如来诸根智力边际者。不异有人求虚空际。诸菩萨摩诃萨闻是根力如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  到根彼岸含灵尊　　善达有情意性行
  随诸众生根所堪　　人中师子为说法
  下中上根所堪任　　善逝胜智根中起
  观彼解脱器心已　　知行慧者为说法
  若人诸根能发起　　至极相续微烦恼
  善达彼人所有根　　知行随顺为说法
  若诸丈夫有善根　　随勤信欲广开示
  又随根行相差别　　说诸胜义定慧等
  若人发起于信欲　　慧者随根说净道
  知彼所行众行已　　为说胜法超诸苦
  有定住佛菩提根　　迷倒误转声闻智
  为说大乘成正觉　　此佛难伏第五力

舍利子。是名如来第五种种根智力。由成就此力故。如来于大众中正师子吼。自称我处大仙尊位能转梵轮。一切世间沙门婆罗门。及天魔梵不能如法而转

复次舍利子。云何如来遍趣诸行智力。舍利子。如来应正等觉以无上智力故。如实了知遍行诸行。舍利子。如是等相云何了知。谓能了知有情性等正定之性。不正定性及邪定性。舍利子。云何名为正定之性。谓由因力先世方便。开智利根之所生故。若诸如来为彼说法。若不说法。如来如实知彼有情前世因果堪任法器。随应说法令速解脱。舍利子。云何名为不定之性。由外缘力而成熟相。若得如法教授教诫。可得解脱。不得如法教授教诫。不得解脱。如来为说随顺缘因相应之法。彼诸有情闻正法已。如理修行证解脱果。为如是等得义利故。诸佛世尊出兴于世。舍利子。云何名为邪定之性。谓有情性烦恼所蔽不修净业。识性薄弱愚痴深厚。住邪见网非正法器。若使如来为彼说法。若不说法。终不堪任证于解脱。如来如实知彼有情非法器已而便舍置。是故舍利子。诸菩萨摩诃萨。愍此有情作利益故。被弘誓铠入邪见军教化摧伏。又舍利子。如来如实了知三种贪行。或净美相起于贪行。或爱恋相起于贪行。或先世因起于贪行。又能了知三种嗔行。或损害相起于嗔行。委练观察起于嗔行。先世随眠起于嗔行。又观了知三种痴行。或有痴行因无明生。或有痴行因妄有身见生。或有痴行因疑而生。如是一切如来如实皆能了知

复次舍利子。如来如实了知诸行。苦乐二行俱能速通。诸根利故。苦乐二行俱是迟通。诸根钝故。又如实知迟行迟通。舍所缘故。迟行速通道不息故。速行迟通勇决进故。速行速通非彼性故。又如实知。或有诸行简择力满非修习力。或有诸行修习力满非简择力。或有诸行简择修习二力俱满。或有诸行简择修习力俱不满。如是诸相如来如实皆能了知。又如实知。或有诸行信欲具足非方便具足。或有诸行方便具足信欲不具足。或有诸行信欲方便俱不具足。或有诸行信欲方便二俱具足。如是一切皆能了知。又如实知。或有诸行身业清净非由语心。或有诸行语业清净非由身心。或有诸行心业清净非由身语。或有诸行非身语心。或有诸行由身语心而得清净。舍利子。如是乃至一切有情所有诸行。或因流转。或因不流转。或因流转及不流转。如来以无碍智见故。于如是等一切处转。如是舍利子。如来遍教行智力。不可思议无边无际与虚空等。诸菩萨摩诃萨闻是智力不可思议如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  善逝如实了诸行　　能知定因有情性
  又知不定成熟相　　及诸根因相应法
  诸行三种贪相应　　及与三种嗔痴合
  无边广惑相应行　　缘因大师如实知
  诸有苦行而根利　　及有此行而钝根
  诸有乐行根利钝　　世大依怙如实知
  诸有钝行及钝修　　或复行钝而修利
  或复行速而修迟　　或有俱速非彼性
  或有诸行简择生　　不由修习道力起
  或修习生非简择　　俱生别异共相应
  或有诸行信欲转　　清净而非方便净
  或有返此俱不俱　　佛遍智者皆明了
  复有净修于身业　　非语非心业清净
  或复语净及身净　　而彼心体非清净
  或有内心常清净　　身语二业非清净
  或复语净及心净　　而彼身业未尝净
  或身语心净不净　　诸行流转及寂灭
  遍智见者如实知　　是为如来第六力

舍利子。是名如来第六遍趣行智力。由此力故。如来自称处仙尊位转大梵轮。乃至无有如法转者

复次舍利子。云何如来静虑解脱三摩地三摩钵底发起杂染清净智力。舍利子。如来应正等觉。以无上智力故。如实了知若自若他。一切静虑解脱三摩地。及三摩钵底。发起杂染清净之法。舍利子。如是等相云何知耶。谓如实知。由因由缘一切有情能令杂染。又如实知。由因缘故一切有情能令清净。舍利子。何因何缘能令杂染。舍利子。由不称理作意为因无明为缘。令诸有情发起杂染。如是无明为因诸行为缘。诸行为因识为其缘。以识为因名色为缘。名色为因六处为缘。六处为因诸触为缘。诸触为因受为其缘。以受为因爱为其缘。以爱为因取为其缘。以取为因有为其缘。以有为因生为其缘。以生为因老死为缘。烦恼为因诸业为缘。诸见为因爱为其缘。随眠为因诸缠为缘。舍利子。由如此等诸因缘故。令诸有情发起杂染。如是等相是亦如来如实了知。舍利子。何因何缘能令清净。舍利子。有二因二缘能令一切有情清净。所谓由他顺音。及由内自如理作意。又奢摩他缘于一境。及毗钵舍那善巧方便。复有二因二缘能令清净。谓不来智及不去智。复有二因二缘能令清净。谓无生观及证正定。复有二因二缘能令清净。谓行具足及明无明解脱作证。复有二因二缘能令清净。谓修解脱门及性解脱智。复有二因二缘能令清净。谓随觉谛及随得谛。舍利子。如是诸因诸缘能令一切有情清净。是亦如来如实了知

复次舍利子。如来如实知诸有情杂染境界。知诸有情清净境界。或有杂染境界入于清净境界。或有清净境界入于杂染境界。如是皆由如实观故。或有杂染境界入于杂染境界。或有清净境界入于清净境界。如是皆由增上慢执故。如来于中如实智转。又舍利子。如来以如实知。于诸静虑超越间杂差别中转。所谓离欲恶不善法。有寻有伺离生喜乐。具足安止最初静虑。如来安住初静虑已从灭定出。如是乃至入灭定已从初静虑出。又舍利子。如来以如实知。于八解脱或顺次入。或复逆入。或顺逆入。或间杂入。舍利子。如是解脱何等为八。谓有色观诸色。是初解脱。内无色想外观诸色。是第二解脱。于净解脱或于净性起于净解。是第三解脱。虚空想处定。是第四解脱。识想处定。是第五解脱。无所有处定。是第六解脱。非有想非无想处定。是第七解脱。若想受灭。是第八解脱。又舍利子。如来以如实智。或安住一三摩地中。而复示现余三摩地及三摩钵底。又复示现种种观解。而诸如来于诸等持未曾混乱。又舍利子。诸佛如来不缘三摩地故。入于三摩地。或依一三摩地故。成就一切余三摩地。或不起一三摩地。而能遍入诸三摩地。又诸如来心常住定无展转缘。又诸如来无不定心而可得者。诸佛如来住定深妙。无有能观如来所得三摩地者。舍利子。声闻所得三摩地。为独觉三摩地之所映夺。独觉所得三摩地。为诸菩萨三摩地之所映夺。菩萨所得三摩地。为诸佛三摩地之所映夺。如来所得三摩地无映夺者。何以故。以诸如来无映夺智常现转故。舍利子。如来如实了知。如是教授。如是教诫。而能发起声闻独觉诸三摩地。又以如是教授教诫。而能发起诸菩萨等妙三摩地。诸佛如来如实知已。便作如是教授教诫。舍利子。如来静虑解脱三摩地三摩钵底杂染清净发起智力。不可思议无边无际与虚空等。若有欲求如来定力边际者。不异有人求空边际。舍利子。诸菩萨摩诃萨。闻是诸定智力不可思议如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义而说颂曰

  由此有情兴杂染　　由此有情得清净
  大雄如是了知已　　广为宣扬微妙法
  由彼违理作意因　　无明为缘生杂染
  复因无明诸行缘　　乃至展转生诸苦
  违理作意及无明　　为彼有支生根本
  诸佛如实了知已　　随其所应宣妙法
  一切杂染之根本　　所谓业行及无明
  复从此缘生诸识　　如是展转兴诸苦
  由彼所说随顺音　　及由内怀如理观
  如斯二因二缘故　　一切含灵证清净
  由奢摩他如理因　　及由毗钵舍那缘
  如是含灵证解脱　　大师如实皆能了
  行者安住净尸罗　　观察诸法皆空寂
  已善修习解脱门　　远离诸有迫迮苦
  此皆诸佛如实知　　一切有情清净行
  空无相愿解脱门　　善逝随根而显示
  独觉最胜及声闻　　顺逆履游诸静虑
  如来宣示彼所证　　如有毒刺及怨仇
  诸佛所证定解脱　　究竟无怨无毒刺
  当知第七如来力　　不为异证所摧伏

舍利子。是名如来第七诸定智力。由得此力故。如来自称处仙尊位转大梵轮。乃至无有如法转者

复次舍利子。云何如来宿住随念作证智力。舍利子。如来应正等觉。以无上智力故。随所忆念如实了知。舍利子。如来如是如实了知。若自若他一切有情无量宿住。或念一生十生百生千生。乃至无量拘胝那庾多百千生。悉皆随念而能知之。又随念知劫坏劫成。或劫成坏。或无量劫坏。无量劫成。无量劫成坏。或复随念百拘胝劫。乃至无量百千拘胝那庾多劫皆能了知。又能随念我于先世曾彼彼处。如是名。如是姓。如是种类。如是饮食。如是色。如是相。如是形貌。如是寿量。如是久住。如是苦乐。我于彼彼处终生彼彼处。复于彼彼处终来生此处。如是若自若他并诸形相。处所流类无量宿住。悉能随念而并知之。又舍利子。如来如实了知。一切有情随其往因。以此因故。如是有情来生于此。知此因已随应说法。又能了知一切有情。于过去世诸心相续。此心无间缘如是境如是心生。由是所缘不具足故如是心灭。如是一切如来如实随念了知。又舍利子。若一有情心生展转。从如是心无间次第如是相续。于如殑伽沙劫种种言说不能令尽。如一有情心相如是。一切有情其心亦尔。如来随彼所有一切心相。随念悉能如实了知。又舍利子。如来依诸有情诸心展转尽于后际。拘胝劫数说不能尽而如来智亦无有尽

复次舍利子。如来宿住随念作证智力。不可思议。无有等者。无等等者。无量无数。不可宣说。又不可说有边尽际。舍利子。如来以佛神力。加诸有情令念宿住。而告之曰。汝今应念于过去世。已种如是诸善法根。或于佛所。或声闻所。或独觉所。或于正法种诸善根。如是善根悉当忆念。彼诸有情以如来力随念皆知。舍利子。如是如来以佛神力加彼有情。令知宿住无量善根所缘境已。如其所应而为说法。舍利子。若诸有情。于阿耨多罗三藐三菩提。得不退转。随其欲解而求出离。或依声闻乘。或依独觉乘。或发阿耨多罗三藐三菩提心者。如是如来随念智力如实了知。如是舍利子。如来宿住随念作证智力。不可思议。无量无数。无有边际。与虚空等。诸有欲求如来宿住随念边际者。不异有人求空边际。舍利子。诸菩萨摩诃萨闻是宿住智力不可思议如虚空已。信受谛奉无惑无疑。乃至踊跃欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  不思那庾拘胝劫　　照世明灯悉随念
  亦念过往自他生　　如观掌内五庵果
  随念名姓色分别　　住寿命尽诸生趣
  含灵具足如是因　　知时如应为说法
  诸过去世无边际　　众生所有心心法
  是心无间是心生　　最胜大智皆能了
  善逝了知一有情　　过往无间心相续
  如殑伽沙拘胝劫　　不能说尽其边际
  乃至后际拘胝劫　　演诸含灵往所行
  而不与等智无尽　　是名诸佛智海量
  一切有情善信欲　　已曾供养诸世尊
  佛威神力所加被　　令缘过去修净行
  大师随念彼所受　　过去曾修诸福行
  念彼所住三乘智　　不退解脱所依处
  善逝称往无边智　　诸有情界难思议
  无边名称第八力　　最胜长子能信受

舍利子。是名如来第八宿住智力。由得是力故。如来自称处仙尊位转大梵轮。乃至不能如法而转

复次舍利子。云何如来天眼通作证智力。舍利子。如来应正等觉。以无上智力。清净天眼超过于人。观诸有情死此生彼。若劣若胜。好色恶色。如其习业或往善趣。或往恶趣。如是等相如来明见如实了知。又能如实知诸含灵所造业行。如是有情成就身恶行。成就语恶行。成就意恶行。诽谤贤圣起诸邪见。彼乘如是邪见业受因故。身坏命终堕诸恶趣。或生地狱。或生畜生。或生鬼趣。如来又知如是有情。成就身妙行。成就语妙行。成就意妙行。不谤贤圣修行正见。彼乘如是正见业受因故。身坏命终往诸善趣。若生天上乐世界中。又复如来以净天眼观于十方。不可宣说过殑伽沙数。尽虚空际穷法界量。诸佛世界种种相状。或复现见诸佛刹土有洞然者。或见刹土有正坏者。或见刹土有正成者。又复现见一切含识死时生时。或复现见诸大菩萨从睹史多天降神母胎。或复现见出母胎者。或观诸方各行七步。或复现见入处内宫。或见出家现修苦行。或见诸佛悟大菩提。或复现见转大法轮。或复现见舍诸寿行入大涅槃。或复现见诸声闻众一切毕竟入般涅槃。或复现见一切独觉示诸神通报净施福而涅槃者。又诸有情非可现见。而为如来天眼所见。亦非彼外五通仙眼之所能见。亦非声闻独觉菩萨等眼之所能见。彼一切如来天眼悉能现见。如是非所现见微细众生如车轮量。如来以天眼观之。多于三千大千世界所有人天。如是一切无量无边不可思议。如来悉能如实明见。舍利子。如来以净天眼观察一切无量佛土诸含灵性。何等众生是如来化。何等众生见如来已方调伏者。如来尔时随应利见。即于前住令彼悟解。非余众生之所能知。如是舍利子。如来天眼随念作证智力。不可思议无有边际与虚空等。诸有欲求如来天眼智力边际者。不异有人求空边际。舍利子。诸菩萨摩诃萨闻如是力不可思议如虚空已。信受谛奉乃至发希奇想。尔时世尊。欲重宣此义。而说颂曰

  善逝天眼净无垢　　净业修治无量劫
  最胜由是观十方　　无垢难思诸佛土
  或坏或成或成坏　　乃至起住火洞然
  或有佛住或无佛　　自然尊眼悉能见
  有情性广难思议　　乃至有色及无色
  若堕恶趣善趣生　　自然尊眼悉能见
  或多拘胝佛现在　　或现如来入涅槃
  并及缘觉若声闻　　自然尊眼悉能见
  或为利生诸菩萨　　或行近妙菩提行
  住诸如来无障处　　自然导师皆能见
  善逝如是眼无垢　　能见极细诸众生
  第九眼力不思议　　最胜聪慧了能信

舍利子。是名如来第九天眼智力。由此力故。自称我处大仙尊位转大梵轮。乃至一切世间不能如法而转

复次舍利子。云何如来流尽作证智力。舍利子。如来应正等觉。以无上智力。如实了知。为尽诸流无流。心解脱慧解脱自然通慧。作证具足而住。如实了知。我生已尽梵行已立。所作已办。不受后有。舍利子。如来流尽智力清净无垢光洁圆照。永断一切相续习气。诸声闻乘虽复流尽。唯能断除少分习气。诸独觉乘虽复流尽。亦能断除少分习气。而远离大悲及诸才辩。唯有如来诸流永尽。具一切种微妙佛法。断除一切相续习气。大悲所摄无畏才辩之所观察。一切世间诸有含识不能映夺。一刹那心而常具足相应无异。何以故。由如来无业无烦恼无忘失威仪诸习气故。舍利子。譬如清净虚空。不与一切烟尘云雾而共住止。如是如来流尽智力。不与一切烦恼习气而共住也。舍利子。诸佛如来住如是等流尽智已。复能为彼有流有取一切众生说流尽法。及说永断一切取法。一切众生诸流诸取。皆从虚妄遍分别起。如来如实观察是已。欲令一切不复起故。如其所应以诸譬喻而为说法。令如实知诸流虚妄。由知是已不取诸法。由不取故则能毕竟入般涅槃。又舍利子。如来如实了知一切有情诸流起灭诸流趣行。如是知已为诸有情如应说法。如是舍利子。如来流尽作证智力。不可思议无有边际与虚空等。若有欲求如来流尽智力边际者。不异有人求于空际。舍利子。诸菩萨摩诃萨闻如来流尽作证智力不可思议如虚空已。信受谛奉心虑清净无惑无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  导师流尽智无垢　　无量广大净无障
  由成如是第十力　　故说寂静妙菩提
  诸声闻乘流尽智　　有量习气随系缚
  人中最胜大导师　　无量结习同灰烬
  有证缘觉菩提者　　远离大悲才与辩
  唯薄伽梵诸流尽　　大悲才辩无有量
  诸佛安住流尽智　　了知众生流取相
  皆从虚妄诸法生　　彼未解斯真理趣
  如来起悲为敷演　　无常不净无我法
  彼观诸法空无性　　当证如来寂静地
  无我无寿无数取　　无人摩纳作受者
  虚妄遍入诸法中　　起大悲心说令脱
  善逝慈悲无厌倦　　真智常流无忘失
  由是最胜恒方便　　为利众生开妙法
  能伏他论第十力　　无有边际等虚空
  世尊常住十力故　　无等法轮恒转世

舍利子。是名如来第十流尽智力。由成就此力故。如来应正等觉。自称我处大仙尊位。于大众中正师子吼转大梵轮。一切世间沙门婆罗门。诸天魔梵。不能如法而转。如是舍利子。诸菩萨摩诃萨。由闻如来功德不可思议故。于如来十力信受谛奉。心虑清净无惑无疑。倍复踊跃深生欢喜发希奇想

大宝积经卷第三十八大宝积经卷第三十九

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之五如来不思议性品第四之三

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议无畏。信受谛奉心志清净无惑无疑。倍复踊跃深生欢喜发希奇想。舍利子。如来应正等觉。有四种不思议无畏。由成就是四无畏故。如来应正等觉。于大众中自称我处大仙尊位。正师子吼转大梵轮。一切世间沙门婆罗门。诸天魔梵。不能如法而转。舍利子。何等名为四无所畏。舍利子。如来应正等觉成就无上智力故。于大众中自称我是正等觉者。此中诸天世间。不见有能于如来前立如是论。汝于此法非正等觉。舍利子。云何如来名正等觉。舍利子。如来能于一切诸法。平等正觉无非平等。若凡夫法。若诸圣法。若诸佛法。若诸学法。若无学法。若独觉法。若菩萨法平等平等。若世间法。若出世间法。若有罪无罪。有流无流。有为无为。如是等一切诸法。如来悉能平等正觉。是故名为正等觉者。舍利子。云何名为平等之性。舍利子。诸见自体与彼空性其性平等。诸相自体与彼无相其性平等。三界自体与彼无愿其性平等。生法自体与彼无生其性平等。诸行自体与彼无行其性平等。起法自体与彼不起其性平等。贪性自体与彼无贪其性平等。三世自体与彼真如其性平等。无明有爱自体与明解脱其性平等。生死流转自体与彼寂静涅槃其性平等。如是舍利子。如来能于一切诸法平等正觉。是故如来名正等觉

复次舍利子。此如来无畏不可思议。又以大悲而为方便。真如平等。真性如性。非不如性。不变异性。无覆藏性。无怖畏性。无退屈性。无违诤性。由如是故光显大众。能令悦豫遍身怡适。心生净信踊跃欢喜。舍利子。世间众生无有能于如来无畏起违诤者。何以故。由如来无畏不可为诤故。如性平等处法界性。流布遍满诸世界中无能违害。舍利子。如如来无畏于一切甚深微细杂可知法。能正等觉。如是如来安住大悲。种种言音种种法门。为彼有情开示妙法。若能依此修远离行速尽苦际。若诸含识实非大师自称大师。非正等觉称正等觉。以如来不思议无畏故悉皆映夺。令彼众生傲慢摧碎逃迸远避。舍利子。如来无畏不可思议无边无际。譬如虚空。若有欲求如来。无畏边际者。不异有人求空边际。舍利子。诸菩萨摩诃萨闻如来说是不思议无畏已。信受谛奉清净无疑。欢喜踊跃发希奇想。舍利子是名第一正等觉无畏。由如来成就此无畏故。于大众中正师子吼转大梵轮。乃至一切世间所不能转。复次舍利子。如来应正等觉。成就无上智力故。于大众中自称我今诸流已尽。此中诸天世间。无能于如来前如法立论。汝有如是诸流未尽。舍利子。云何如来流尽之性。舍利子。如来于欲流中心善解脱。永断一切贪行习气故。如来于有流中心善解脱。永断一切嗔行习气故。如来于无明流中心善解脱。永断一切痴行习气故。如来于见流中心善解脱。永断一切烦恼行习气故。以是因缘故说。如来诸流已尽。舍利子。如是说法依世俗故非为胜义。于胜义中无有一法住圣智前。可遍知可永断可修习可作证者。何以故。舍利子。所言尽者未尝不尽性究竟尽。不由对治说名为尽。如实性尽。如实性尽故无法可尽。无法可尽故即是无为。以无为故无生无灭。亦无有住。是故说言如来出世。若不出世常住法性常住法界。即于其中圣智慧转。虽如是转无转无还。舍利子。由是法门故无有诸流。亦无流尽而可得者。如是如来住大悲已。为诸有情说流尽法

复次舍利子。如来无畏不可思议。复以大悲而为方便。真如平等。真性如性。非不如性。不变异性。无覆藏性。无怖畏性。无退屈性。无违诤性。由如是故光显大众。能令悦豫遍身怡适。心生净信欢喜踊跃。舍利子。世间众生无有能于如来无畏起违诤者。何以故。由如来无畏不可为诤故。真如平等处法界性。流布遍满诸世界中无能违害。如是不可思议无量无数无有边际。妙法成就。由如来大悲熏心。为诸众生说流尽法。欲令永断彼诸流故。舍利子。如来无畏不可思议无边无际。譬如虚空。若有欲求如来无畏边际者。不异有人求空边际。舍利子。是诸菩萨摩诃萨闻如来说是不思议无畏已。信受谛奉清净无疑。乃至发希奇想。舍利子。是名第二流尽无畏。由成就此无畏故。如来于大众中正师子吼。自称我处大仙尊位转大梵轮。乃至一切世间所不能转

复次舍利子。如来应正等觉。成就无上智力故。于大众中唱如是言。我说障法决定能障。此中诸天世间。无能于如来前如法立论。汝说如是障法不能为障。舍利子。云何名为能障碍法。舍利子。谓有一法能为障碍。何等一法。谓心不清净。复有二法能为障碍。谓无惭无愧。复有三法能为障碍。谓身恶行语恶行意恶行。复有四法能为障碍。由贪欲故行所不行。由嗔恚故行所不行。由愚痴故行所不行。由怖畏故行所不行。复有五法能为障碍。谓杀生不与取欲邪行妄语饮酒。复有六法能为障碍。谓不恭敬佛菩提。不恭敬法。不恭敬僧。不恭敬律仪。不恭敬三摩地。不恭敬建立施设。复有七法能为障碍。谓慢胜慢胜上慢增上慢邪慢下慢我慢。复有八法能为障碍。何等为八。谓邪见邪思邪语邪业邪命邪勤邪念邪三摩地。复有九法能为障碍。何等为九。谓于我身去来今世作不饶益生恼害事。于我所爱去来今世作不饶益生恼害事。我所不爱于去来今而作饶益生恼害事。复有十法能为障碍。谓十不善道。是故略说。是十种法能为障碍。为欲止息寂静永断如是障碍法故。如来为诸有情敷演正法。舍利子。乃至一切违罪作意相应诸结。若由诸法住爱味观。颠倒相应违背出离。爱见执着于有味着。有所依事身语意业。彼一切相如来了知皆是障碍。既了知已。如实说为能障碍法。复次舍利子。此如来无畏不可思议。以大悲为方便。真如平等。真性如性。非不如性。无变异性。无覆藏性。无怖畏性。无退屈性。无违诤性。由如是故光显大众。能令悦豫遍身怡适。心生净信踊跃欢喜。舍利子。世间众生无有能于如来无畏起违诤者。何以故。由如来无畏不可为诤故。如性平等处法界性。流布遍满诸世界中无能违害。如是无量无数。不可思议。无与等者。不可宣说。妙法成就。而如来大悲熏心。为诸有情说障碍法。欲令止息寂静永断彼障法故。舍利子。如来无畏不可思议无边无际。譬如虚空。若有欲求如来无畏边际者。不异有人求于空际。舍利子。是诸菩萨摩诃萨。闻如来说是不思议。无畏如虚空已。信受谛奉清净无疑。乃至发希奇想。舍利子。是名第三说障法无畏。由如来成就此无畏故。于大众中正师子吼转大梵轮。乃至一切世间所不能转

复次舍利子。如来应正等觉成就无上智力故。于大众中唱如是言。我说圣出离所修能正尽苦道。若诸有情修习此道必定出离。此中诸天世间。无能于如来前如法立论。汝所说道不能出离。舍利子。云何名为圣出离道。舍利子。所谓一正趣道。能令众生毕竟清净。复有二法。能令众生毕竟出离。谓奢摩他及毗钵舍那。复有三法能令出离谓空无相无愿解脱之门。复有四法能令出离。谓缘身生念缘受生念缘心生念缘法生念。复有五法能令出离。谓信根勤根念根三摩地根慧根。复有六法能令出离。谓念佛念法念僧念戒念舍念天。复有七法能令出离。所谓念等觉支择法等觉支。勤等觉支。喜等觉支。安息等觉支三摩地等觉支舍等觉支。复有八法能令出离。所谓圣八支道。正见正思惟正语正业正命正勤正念正三摩地。复有九种悦根本法能令出离。所谓悦喜安息乐三摩地如实智见厌及离欲解脱。复有十法能令出离。谓十善业道。如是如来为诸有情如实开示离圣出行。舍利子。乃至一切所有正善菩提分法。或戒聚相应。或三摩地聚慧聚解脱聚解脱智见聚相应。或圣谛相应。如是名为能出离行。又舍利子。能出离者。所谓正行。言正行者。于此法中无有一法。若增若减若来若去。若取若舍。何以故。非行正行者行一种觉。若能如实知见诸法皆不二性。是则名为圣出离行。舍利子。此如来无畏不可思议。以大悲为方便。真如平等。真性如性。非不知性。无变异性。无覆藏性。无怖畏性。无退屈性。无违诤性。由如是故光显大众。能令悦豫遍身怡适。心生净信踊跃欢喜。舍利子。世间众生无有能于如来无畏起违诤者。何以故。由如来无畏不可为诤故。如性平等处法界性。流布遍满诸世界中无能违害。如是圣出离行。无量无数。不可思议。无与等者。不可宣说妙法成就。而如来大悲熏心。为诸众生开示演说圣出离行。若有众生如实解了修行正道。必能出离速尽诸苦。舍利子。如来无畏无边无际。譬如虚空。若有欲求如来无畏边际者。不异有人求于空际。舍利子。诸菩萨摩诃萨闻是如来不思议无畏已。信受谛奉清净无疑。乃至发希奇想。舍利子。是名第四说圣出离道无畏。由如来成就此无畏故。于大众中正师子吼转大梵轮。一切世间沙门婆罗门。诸天魔梵。不能如法而转。舍利子。如来如是四种无畏无边无际。譬如虚空。一切众生不能得尽其边际者。诸菩萨摩诃萨闻如来如是不思议无畏如虚空已。信受谛奉清净无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  自然正觉悟　　诸法平等性
  故遍见如来　　说名正等觉
  若诸凡夫法　　及学无学法
  最胜独觉法　　佛法悉平等
  一切世间法　　及诸出世法
  善不善不动　　涅槃路平等
  若空若无相　　若离诸愿乐
  无生无有为　　悉见平等性
  觉平等性已　　如所应宣说
  解脱诸有情　　大牟尼无畏
  已解脱三有　　复开示解脱
  诸人天圣尊　　显第二无畏
  最胜觉障法　　习不证解脱
  非清净下劣　　不具诸羞愧
  未尝有身护　　及以语意护
  贪嗔痴怖畏　　害命损他财
  行邪欲妄语　　饮酒不恭敬
  七慢八邪支　　悉非解脱处
  九恼害多过　　十不善业道
  不如理思惟　　愚痴无解脱
  颠倒修诸行　　执虚妄放逸
  佛知说障法　　是第三无畏
  清净门无量　　修习证菩提
  佛自然通达　　说趣甘露法
  乃至诸所有　　众多妙善法
  助清净菩提　　最胜所称赞
  若善修习已　　不证诸解脱
  必无有是处　　十力者诚言
  若如理思惟　　息广大烦恼
  观诸法平等　　善修习圣行
  不执着诸相　　是法及非法
  解脱诸忧怖　　大净者所说
  善知种种法　　虚廓如净空
  又如幻如梦　　解脱诸有海
  若放逸造业　　轮回诸有趣
  大悲愍众生　　欲令证解脱
  十力牟尼尊　　处生死化法
  是第四无畏　　清净等虚空

如是舍利子。是名如来不思议无畏。菩萨摩诃萨信受谛奉清净无疑。乃至发希奇想。尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议大悲。信受谛奉。乃至发希奇想。舍利子。诸佛如来大悲常转。何以故。诸佛如来不舍一切众生故。于一切时为成熟一切众生故。当知大悲常起不息。舍利子。此如来大悲如是无量。如是不可思议。如是无等等。如是无边。如是不可说。如是猛利。如是久远。随诸众生乃至如来一切语业。于是大悲亦难宣说。何以故。犹如如来证得菩提。不可思议。如是如来于诸众生大悲发起。亦复如是不可思议。舍利子。云何如来证得菩提。舍利子。犹如来入如是无根无住故证得菩提。舍利子。何等为根。何等为住。有身为根。虚妄分别为住。如来于此二法平等解了。是故说言。犹如如来入无根无住故。证得阿耨多罗三藐三菩提。一切众生不能解了。如是二法如来于彼发起大悲。我今定当开示令其解了。如是无根无住法故

复次舍利子。夫菩提者其性寂静。何等名为寂静二法。舍利子。于内为寂于外为静。何以故。眼性是空离我我所。如是耳鼻舌身意意性是空离我我所。若如是知名之为寂。如实了知眼性空已不趣于色。乃至如实了知意性空已不趣于法。若如是知名之为静。一切众生于此寂静二法不能解了。如来于彼发起大悲。我今定当开示令其解了。如是寂静二法故

复次舍利子。我证菩提自性清净。云何名为自性清净。舍利子。菩提之性体无染污。菩提之性与虚空等。菩提之性是虚空性。菩提之性同于虚空。菩提虚空平等平等究竟性净。愚痴凡夫不觉如是自性清净。而为客尘烦恼之所染污。一切众生于是自性清净不能解了。如来于彼发起大悲。我今定当开示令其解了。如是自性清净故

复次舍利子。我证菩提无入无出。何等名为入出二法。舍利子。所言入者名执诸法。所言出者名不执诸法。如来明见无入无出平等法性。犹如如来明见无远及无彼岸。何以故。以一切法性离远及彼岸故。能证是法故名如来。一切众生于此无入无出法性不能觉了。如来于彼发起大悲。我今定当开示令其觉了。如是无入无出法故

复次舍利子。我证菩提无相无境。何等名为无相无境。舍利子。不得眼识名为无相。不观于色名为无境。乃至不得意识名为无相。不观于法名为无境。舍利子。无相无境众圣所行。何等所行。谓在三界愚痴凡夫。于众圣所行不能行故。于无相无境不能觉了。如来于彼发起大悲。我今定当开示令其觉了。如是无相无境法故

复次舍利子。言菩提者非去来今。三世平等三相轮断。何等名为三相轮断。舍利子。于过去世心无顾转。于未来世识无趣向。于现在世意无起作。是心意识无有安住。不分别过去。不执着未来。不戏论现在。一切众生不能觉悟。三世等性三轮清净。如来于彼发起大悲。我今定当开示令其觉悟。如是三世三轮平等清净故

复次舍利子。我证菩提无为无性。何故名曰无为无性。舍利子。是菩提性非眼识所识。乃至非意识所识。言无为者无生无灭。亦无有住。三相永离故名无为。舍利子。知无为性当觉有为。何以故。诸法自性即是无性。夫无性者即体无二。一切众生。不能觉悟此无性无为故。如来于彼发起大悲。我今定当开示令其觉悟。如是无性无为故

复次舍利子。我证菩提无差别迹。何故名为无差别迹。舍利子。真如法性二俱名迹。性无别异性无安住名无差别。诸法实际名之为迹。性无动摇名无差别。诸法空性名之为迹。性不可得名无差别。诸法无相名之为迹。性不可寻名无差别。诸法无愿名之为迹。性无发起名无差别。无众生性名之为迹。即体性无名无差别。是虚空相名之为迹。性不可得名无差别。其性无生是名为迹。其性无灭名无差别。其性无为是名为迹。性无行住名无差别。为菩提相是名为迹。其性寂静名无差别。为涅槃相是名为迹。其性无生名无差别。舍利子。一切众生不能觉悟无差别迹。如来于彼发起大悲。我今定当开示令其觉悟。如是无差别迹故

复次舍利子。言菩提者不可以身证。不可以心证。何以故。身性无知无有作用。譬如草木墙壁琢石之光。心性亦尔。譬如幻事阳焰水月。若能如是觉悟身心是名菩提。舍利子。但以世俗言说假名菩提。菩提实性不可言说。不可以身得。不可以心得。不可以法得。不可以非法得。不可以真实得。不可以非真实得。不可以谛得。不可以妄得。何以故。由菩提性离言说故。亦离一切诸法相故。又以菩提无有形相用通言说。譬如虚空无有形处故不可说。舍利子。如实寻求一切诸法皆无言说。何以故。由诸法中无有言说。于言说中亦无诸法。一切众生不能觉悟如是诸法理趣。如来于彼发起大悲。我今定当开示诸法理趣令其觉悟。如是谛实义旨故

复次舍利子。言菩提者无取无藏。何等名为无取无藏。舍利子。了知眼故名无所取。不观色故名曰无藏。舍利子。如来证是菩提无取无藏故。不取于眼。不藏于色。不住于识。乃至不取于意。不藏于法。不住于识。虽不住识。而能了知一切众生心之所住。云何了知。谓诸众生心住四法。何等为四。一切众生心住于识。心住于受。心住于想。心住于行。如来如是如实了知住与不住。一切众生不能觉悟无住实际。如来于彼发起大悲。我今定当开示令其觉悟。如是无住实际法故。复次舍利子。言菩提者空之异名。由空空故菩提亦空。菩提空故诸法亦空。是故如来如其空性觉一切法。不由空故觉法空性。由一理趣智故觉法性空。空与菩提性无有二。由无二故不可说言。此是菩提。此是空性。若有二者则可言说。此为菩提。此为空性。以法无二无有二相。无名无相无行。毕竟不行亦不现行。所言空者远离取执。胜义谛中无法可得。由性空故说名为空。如说太虚名为虚空。而太虚性不可言说。如是空法说名为空。而彼空性不可言说。如是悟入诸法实无有名假立名说。然诸法名无方无处。如名诠诸法。此法无方无处亦复如是。如来了知一切诸法从本已来无生无起。如是知已而证解脱。然其实性无缚无脱。诸痴凡夫不能觉悟此菩提性。如来于彼发起大悲。我当开示令其觉悟。如是菩提之实性故

复次舍利子。菩提之性与太虚等。然太虚性无等不等。菩提亦尔无等不等。犹如诸法性无真实。不可说等及不平等。如是舍利子。如来觉悟一切诸法。其性平等无不平等。如实觉悟无有少法。可为平等及不平等。如是如来如实智量穷诸法量。何者名为如实智耶。谓知诸法本无而生生已离散。无主而生无主而散。若生若散随众缘转。此中无有一法若转若还及随转者。故说如来为断诸径说微妙法。一切众生不能觉悟断诸径法。如来于彼发起大悲。我当开示令其觉悟。如是断诸径法故

复次舍利子。言菩提者。即是如句。何等名为如句之相。舍利子。如菩提相诸色亦尔。同彼真如无有退还而不遍至。受想行识亦复如是。如彼真如无不遍至。舍利子。如菩提相同彼真如。四大之性亦复如是。如彼真如无有退还而不遍至。如菩提性同彼真如。眼界色界及眼识界。乃至意界法界及意识界亦复如是。如菩提相但假施设。一切诸法蕴界处等但假施设。亦复如是。知如是相名为如句。又舍利子。如来一切如实觉悟不颠倒觉。犹如前际中后亦尔。何以故。前际无生。后际无趣。中际远离。如是一切名为如句。如是一句一切亦尔。如是一切一句亦尔。非如性中一性多性而是可得。一切众生不能觉悟此之如句如来于彼发起大悲我当开示令其觉悟如是真如法句故

复次舍利子言菩提者。名入于行及入无行。何等名为行及无行。舍利子。发起善法名之为行。一切诸法即不可得名为无行。住不住心名之为行。无相三摩地解脱门名为无行。舍利子。所言行者称量算数观察于心。言无行者过称量等。云何名为过称量等。以一切处无有诸识作用业故。舍利子。所言行者谓于是处观察有为。言无行者谓于是处证于无为。愚痴凡夫不能觉悟入行非行。如来于彼发起大悲。我当开示令其觉悟。如是入行非行法故

复次舍利子。夫菩提者无流无取。云何名为无流无取。舍利子。离四流性故曰无流。何谓为四。离欲流性。离有流性。离无明流性。离见流性。舍利子。离四取性故名无取。何等为四。离欲取性。离有取性离见取性。离戒取性。舍利子。如是四取皆由无明。而为盲闇爱水隍池之所拥闭。由执我故受蕴界处。如来于中如实了知。我取根本自证清净。亦令众生证得清净。舍利子。如来既证是清净故。于诸法中无所分别。何以故。舍利子。由此分别起不如理思惟。此但如理相应故不起无明。不起无明故不能发起十二有支。若不发起十二有支此即无生。若无生者此即决定。若决定者此即了义。若了义者此即胜义。若胜义者即无人义。无人义者即不可说义。不可说义者即缘起义。诸缘起义者即是法义。诸法义者即如来义。舍利子。若能如是观缘起者即是观法。若观法者即观如来。如是观者离真如外无有所观。此中云何有所有耶。谓相及缘。如是二法。若能观察无相无缘。即真实观如来。觉悟如是诸法平等故平等。愚痴凡夫不能觉悟此无流无取性。如来于彼发起大悲。我当开示令其觉悟。如是无流无取性故

复次舍利子。夫菩提者。其性清净无垢无执。云何名为清净无垢及以无执。舍利子。空故清净。无相故无垢。无愿故无执。又舍利子。无生故清净。无作故无垢。无取故无执。又舍利子。自性故清净。遍净故无垢。光洁故无执。又舍利子。无戏论故清净。离戏论故无垢。戏论寂静故无执。又舍利子。真如故清净。法界故无垢。实际故无执。又舍利子。虚静故清净。无碍故无垢。空寂故无执。又舍利子。内遍知故清净。外不行故无垢。内外不可得故无执。又舍利子。蕴遍知故清净。界自体故无垢。处损减故无执。又舍利子。过去尽智故清净。未来无生智故无垢。现在法界住智故无执。舍利子。如是清净无垢无执之性同趣一句。言一句者谓寂静句。诸寂静者即极寂静。极寂静者即遍寂静。遍寂静者名大牟尼。舍利子。犹如太虚菩提亦尔。如菩提性诸法亦尔。如诸法性真实亦尔。如真实性国土亦尔。如国土性涅槃亦尔。故说涅槃诸法平等。亦名究竟。无边际相故无有对治。离对治相故。如是诸法本来清净无垢无执。舍利子。如来于是色无色等一切诸法。如实觉悟观有情性。游戏清净无垢无执。发起大悲。我今定当开示令其觉悟。如是清净无垢无执法故

复次舍利子。如是如来不可思议大悲。不由功用任运常转。流布遍满十方世界无有障碍。舍利子。如来大悲不可思议。无边无际犹如虚空。若有欲求如来大悲边际者。不异有人求于空际。舍利子。是诸菩萨摩诃萨闻如来不思议大悲同虚空已。信受谛奉清净无疑。乃至发希奇想。尔时世尊。欲重宣此义。而说颂曰

  诸佛证菩提　　无根无所住
  如佛所证已　　为诸众生说
  诸佛证菩提　　寂静极寂静
  观眼等内空　　色等外空性
  有情不觉悟　　寂静极寂静
  如来知句义　　于彼起大悲
  菩提性光洁　　清净等虚空
  是众生不了　　于彼起大悲
  诸佛证菩提　　无去来取舍
  是众生不了　　于彼起大悲
  诸佛证菩提　　无相无境界
  众圣之所行　　非愚夫所履
  诸凡夫不知　　虽知不明达
  如来于彼类　　兴起于大悲
  无为之自性　　无生亦无灭
  于彼亦无住　　三轮长解脱
  愚夫不能觉　　诸有为自性
  于彼起大悲　　开如是理趣
  菩提非身证　　亦不由心证
  身自性无知　　心如幻事等
  愚夫不能觉　　身心自体性
  于彼起大悲　　开如是妙理
  诸佛自然证　　广大胜菩提
  安坐树王下　　观察含灵性
  登上生死轮　　循环种种趣
  如来见彼已　　兴猛厉大悲
  憍慢之所坏　　见网恒缠裹
  于苦生乐想　　无常起常想
  计诤我众生　　命者见所坏
  如来观彼已　　兴猛厉大悲
  一切众生性　　覆障于痴膜
  无有慧光明　　如重云掩日
  如来见彼已　　兴猛厉大悲
  以无垢智光　　当为彼明照
  既入诸恶趣　　常迷失正道
  或堕地狱趣　　畜生鬼趣中
  过去佛已知　　导开前正路
  今佛见彼已　　兴猛厉大悲
  佛知一切法　　真如及实性
  清净等虚空　　证成真解脱
  诸众生不知　　如是净妙法
  如来见彼已　　兴猛厉大悲

如是舍利子。是名如来不思议大悲。诸菩萨摩诃萨闻是不可思议大悲已。信受谛奉清净无疑。倍复踊跃。深生欢喜。发希奇想

大宝积经卷第三十九大宝积经卷第四十

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之六如来不思议性品第四之四

尔时佛告舍利子。云何菩萨摩诃萨。于如来不思议不共佛法。信受谛奉清净无疑。乃至发希奇想。舍利子。如来成就十八不共佛法。由成就故。如来应正等觉。于大众中正师子吼。自称我处大仙尊位转大梵轮。一切世间沙门婆罗门。诸天魔梵。不能如法而转。舍利子。何等名为十八不共佛法。舍利子。所谓如来处世无诸误失。以无失故名为如来。何等名为无有误失。舍利子。如来身业无有误失。以无失故。一切世间若愚若智。不能立如法论。谓如来身有误失者。何以故。佛薄伽梵身业毕竟无误失故。舍利子。诸佛如来游步世间。直视于前转身回顾。若屈若伸服僧伽胝。摄持衣钵进止往来行住坐卧。如来于中无失威仪端严庠序。舍利子。如来若往城邑若旋返时。双足蹈空。而千幅轮现于地际。悦意妙香钵特摩花。自然踊出承如来足。若畜生趣一切有情为如来足之所触者。极满七夜受诸快乐。命终之后往生善趣乐世界中。舍利子。如来被服不着其身。如四指量吠岚婆风不能披动。舍利子。如来身光极照无间。触彼众生令兴乐受。舍利子。如是一切身无过相。故说如来身无误失。如自所证身无误失。亦为众生说如斯法。令其永断身业误失。舍利子。如来语业无有误失。以无失故。一切世间若愚若智。不能如法伺求如来语业误失。何以故。舍利子。如来为迦罗时语者。如来为实语者。为谛语者。为三摩耶时语者。为如语而作者。为善训释词语者。为令众生欢悦语者。为无重述语者。为文义庄严语者。为随发一音皆令信解欢悦语者。舍利子。如是一切语无过相。故说如来语业无失。如自所证语无误失。亦为众生说如是法。令其永断语业误失。舍利子。如来之心无有误失。以无失故。一切世间若愚若智。不能如法伺候如来心业误失。何以故。舍利子。如来不舍甚深定法。而能发起作诸佛事不役神虑。于一切法无碍智见任运而转。故说如来心无误失。如自所证心无失故。亦为众生说如斯法。令其永断心业误失。舍利子。如是身语心业无有失故。是名如来第一诸业无有误失不共佛法

复次舍利子。云何如来所发言音无有卒暴。舍利子。如来以无卒暴发言音故。一切世间若魔若魔眷属。及余天子诸外道等。不能伺候如来便者。何以故。舍利子。如来言音本无卒暴。无随卒暴。何以故。久已永离诸爱恚故。一切众生虽加尊敬而心不高。虽加轻侮而心不戚。又舍利子。如来无有所作过时及不究竟。非由此事而起追悔。及随前事起卒暴音。又舍利子。如来无有与世诤讼。是故如来无卒暴音。如来常止无诤深定无我所执。亦无有取远离诸缚。是故如来无卒暴音。舍利子。如是无量音无卒暴。如来于中悉皆证入。如佛所证音无卒暴。亦为众生说如斯法。令其永断诸卒暴故。舍利子。是名如来第二言无卒暴不共佛法

复次舍利子。云何如来念无忘失。舍利子。如来正念无忘失故。不于一法而生愚乱。何以故。如来住于静虑解脱三摩地三摩钵底中。不痴忘故。观诸有情心行动转无挂碍故。如其所应宣说妙法无忘失故。于诸义法训词辩才无碍解中。无忘失故。于去来今无碍智见。如是无量无忘失故。如自所证去来现在无碍智见无有忘失。亦为有情说如斯法。令其证得无忘失念。舍利子。是名如来第三念无忘失不共佛法

复次舍利子。云何如来无不定心而可得者。舍利子。如来若行若住。若坐若卧。若食若饮。若语若默。常处深定中无出离。何以故。由如来证得甚深三摩地最胜波罗蜜多。成就无障无碍深静虑故。舍利子。无有众生处有情类。若定不定能观如来心及心所。唯除如来威力加被而能得知。如自所证常处定心。亦为有情依三摩地。说如斯法。令其永断散乱之心。舍利子。是名如来第四无不定心不共佛法。复次舍利子。云何如来无诸异想。何以故。舍利子。由异想故可有安住不平等心。如来心常安住平等故。于一切无诸异想。舍利子。如来于诸佛土无诸异想。以彼佛土如虚空故。如来于诸有情无种种想。由彼有情性无我故。如来于诸佛所无种种想。由彼法性无有差别平等智故。如来于一切法无种种想。由离欲法性平等故。如来于持戒者其心无爱。于犯戒者其心无恚。于有恩所无不酬报。于有怨所情无加害。于所调伏无不平等。于住邪定心不轻慢。于诸法中平等安住。故名如来无种种想。如自所证无异想故。亦为众生说如斯法。令其永断种种异想。舍利子。是名如来第五无诸异想不共佛法

复次舍利子。云何如来无简择舍。何以故。舍利子。如来已修圣道而证此舍。非未修道而有证故。如来已修于心。已修于戒。已修于慧而证此舍。非所未修而有证故。舍利子。如来舍者随智慧行不随痴行。如来舍者是出世间不堕世间。如来舍者是圣是出离。非为不圣非不出离。如来舍者能转梵轮。悲愍众生常不舍离。如来舍者任运成就不随对治故。舍利子。如来舍者无高不高。亦无下劣。得住不动远离二边。超过一切思量简择。观待于时。亦不过时。无动无思。无有分别。无异分别。无修无损。无有憍逸。无有示现。真性如性。不虚妄性。非不如性。如是无量。舍利子。如来如是大舍成就。为诸众生舍圆满故说如斯法。舍利子。是名如来第六无简择舍不共佛法

复次舍利子。云何如来志欲无有退减。舍利子。何等志欲而无退减。所谓如来善法志欲复有何义名为志欲。舍利子。如来大慈志欲无减。如来大悲志欲无减。如来说法志欲无减。调伏众生志欲无减。成熟众生志欲无减。兴于远离志欲无减。教导菩萨志欲无减。绍三宝种令不断绝志欲无减。一切如来不随欲行。如来志欲智为前导。如自所证志欲无减。亦为众生说如斯法。令彼证得圆满无上一切智智之志欲故。舍利子。是名如来第七志欲无减不共佛法

复次舍利子。云何如来正勤无有退减。舍利子。何等正勤而不退减。所谓不舍所化众生正勤。于听法众不怀摈遣正勤。以如是等无有退没故。说如来正勤无减。舍利子。假使如来。值遇如是。乐闻法众堪任法器。若能听法经劫无倦。如来亦随经劫不起于座。不缘食饮相续说法中无暂废。又舍利子。如来为众生故。假使过于殑伽沙等诸佛世界。唯一众生是佛化限。尔时如来躬往其所为说法要。令其悟入正勤无厌。舍利子。如来身无疲倦。及以语心亦无疲倦。何以故。如来身语及心常安息故。舍利子。如来长劫发起精进。赞叹精进。为诸众生说如是法。令彼勤修是精进故证圣解脱。舍利子。是名如来第八正勤无减不共佛法

复次舍利子。云何如来于一切一法及一切种一切念。无有退减。何以故。由诸如来念无退故。舍利子。如来证得阿耨多罗三藐三菩提。无间观察一切众生。去来诸心相续知已。如来于中毕竟了知无有忘念。又如实知众生行已。如来于中无复役智。而如来念曾无退减。又舍利子。如来安立三聚众生。诸根悟入意解趣行。审观察已更不忆念。无重思惟不复观察。常为众生宣说妙法无有断绝。何以故。由如来念无退减故。如自所证无退减念。亦为众生说如斯法。令其永断诸念退减。舍利子。是名如来第九念无退减不共佛法

复次舍利子。云何佛三摩地无有退减。舍利子。佛三摩地与一切法。其性平等无非平等。何以故。由一切一法及一切种法无有不平等性故。舍利子。何因缘故佛三摩地复无退减。舍利子。以真如平等故。即三摩地平等。以三摩地平等故。即如来平等。以能证入如是平等性故。三摩地者名为等定。又舍利子。若贪际平等即离贪际平等。若嗔际平等即离嗔际平等。若痴际平等即离痴际平等。若有为际平等即无为际平等。若生死际平等即涅槃际平等。以如来证入如是平等性故。于三摩地而无退减。何以故。平等之性无退减故。舍利子。此佛三摩地非眼相应。亦非耳鼻舌身意相应。何以故。然彼如来诸根无缺故。又如来三摩地。不依地界。不依水火风界。不依欲界色无色界。不依此世及他世间。何以故。由无依故无退无减。是故如来如自所证。诸三摩地无有退减。亦为众生说如是法。令彼证得诸三摩地故。舍利子。是名如来第十三摩地无有退减不共佛法

复次舍利子。云何如来智慧无有退减。舍利子。何等名为如来智慧。所谓了知诸法不缘他知。为他有情及以他人演妙法智。无尽善巧无碍解智。分别一切句智。悟入一句百千大劫说无尽智。如其所闻断疑网智。于一切处无障碍智。宣说安立圣三乘智能遍了达八万四千。有情心行智。如应开示八万四千诸法藏智。舍利子。此如来智慧无边无际无有穷尽。由此智慧不可尽故。随慧而说亦无有尽。故说如来智慧无有退减。如自所证智慧无减。亦为众生说如斯法。令其证得无尽智慧故。舍利子。是名如来第十一智慧无减不共佛法

复次舍利子。云何如来解脱无有退减。舍利子。何等名为如来解脱。舍利子。诸声闻乘随悟音声故得解脱。诸独觉乘随悟众缘故得解脱。佛薄伽梵远离一切执着二边故得解脱。是故说为如来解脱。何以故。舍利子。如是解脱前际无缚。后际无转。不住现在故。又舍利子。眼之与色二执解脱。如是耳声鼻香舌味身触二执解脱。摄受无执依止解脱故。又舍利子。心之与智自性光洁体无瑕秽。是故诸佛由刹那心相应慧故。证得阿耨多罗三藐三菩提。以是如来随所证觉。亦为众生说如斯法。令彼证觉如是法故。舍利子。是名如来第十二解脱无减不共佛法

复次舍利子。云何如来一切身业。智为前导随智而转。何以故。舍利子。由能成就是身业故。一切有情若见如来即便调伏。或闻说法亦皆调伏。是故如来或现默然调伏众生。或现饮食调伏众生。或现诸威仪调伏众生。或现诸胜相调伏众生。或现随形好调伏众生。或现无观顶调伏众生。或现观视相调伏众生。或现神光触照调伏众生。或现游步举足下足调伏众生。或现往还城邑聚落调伏众生。舍利子。以要言之。佛薄伽梵无有威仪而不调伏诸众生者。故说如来一切身业智为前导随智而转。亦为众生说如是法。令其证入如是智故。舍利子。是名如来第十三身业智导不共佛法

复次舍利子。云何如来一切语业。智为前导随智而转。何以故。舍利子。佛薄伽梵不虚说法故以智前导。所有记莂无不圆备。凡所宣说言词显妙。舍利子。如来语言随现而转不可思议。今当略说。舍利子。如来语者易解了语。易明识语。不高大语。不卑下语。非不胜语。不邪曲语。不謇吃语。不繁乱语。不涩钝语。不粗犷语。不隐没语。柔和声语。可欣乐语。不虚羸语。不轻掉语。不调疾语。不繁重语。不迅急语。善断约语。善调释语。极妙和美语。胜妙音语。善唱导语。大清亮语。大雷震语。无遗逸语。饮甘露语。有义旨语。可亲附语。广大之语。可爱重语。无尘染语。离尘黩语。无栽秽语。无垢浊语。无鲁钝语。威严盛语。无障碍语。能教导语。明洁之语。有正直语。无怯惮语。无缺减语。非轻急语。能生喜乐语。令身怡适语。令心踊跃语。寂静贪语。寂静嗔语。坏灭痴语。吞啖魔语。调伏恶语。摧异论语。有表示语。天鼓音语。智者悦语。羯罗频迦音语。上帝音语。梵天音语。海潮音语。云雷音语。地山震吼音语。鸿鹤王音语。孔雀王音语。黄鹂音语。命命音语。鹅雁王音语。鹿王音语。箜篌音语。伐洛迦音语。钵拏缚音语。大[虫*豕]吼音语。长笛音语。易开解语。易了别语。畅明晓语。适悦意语。可听闻语。深远音语。无喑哑语。悦可耳语。生善根语。文句无缺语。善说文句语。义句相应语。法句相应语。时相应语。时捷对语。不过时语。知根胜劣语。庄严施语。净尸罗语。教授忍语。练正勤语。令乐静虑语。悟入正慧语。慈善集语。悲无倦语。清净喜语证入舍语。安立三乘语。令三宝种不断绝语。安立三聚语。净三解脱语。遍修谛语。遍修智语。达者不毁语。圣者称赞语。随虚空量语。一切种妙成就语。舍利子。如是无量无边微妙清净如来之语故。说如来一切语业智为前导随智而转。如自所证如是语业。亦随诸有情而为说法。令其证入如是语故。舍利子。是名如来第十四语业智导不共佛法

复次舍利子。云何如来一切意业智为前导随智而转。舍利子。夫如来者心意与识皆不可说故。舍利子。夫如来者应以智求。智增上故说名如来。此如来智随至一切众生之心。随入一切众生之意。不离一切众生之识。焚荡诸法诸三摩地。不从他缘超过一切所缘境界。远离缘生灭三有趣。超诸慢种。解脱魔业。离诸谄诳。舍我我所。除灭无明痴暗之膜。善修道支。与虚空等无有分别。与诸法界而无差别。舍利子。如来证入如是意业。为如是相智为前导。随众生心而为说法。令彼证入如来意故。舍利子。是名如来第十五意业智导不共佛法

复次舍利子。云何如来于过去世。无著无碍智见转。舍利子。何以此智名之为转。舍利子。如来以无碍智。能知如是无量无边过去世中。所有诸佛国土若成若坏。彼一切事无量无数。如来方便悉能数知。如是乃至诸佛国中。所有卉木丛林众药所摄彼一切事。如来于此悉能了知。如是乃至诸佛国中。诸众生身众生假立。彼一切相悉能了知。又能了知彼中所有若干众生种种性种种色。乃至广说。如来于此悉能了知。舍利子。如是彼中所有诸佛出现于世。彼一一如来所宣正法。如来于此悉能如实分别了知。如是乃至尔所众生。于声闻乘已调伏者。或独觉乘已调伏者。或于大乘已调伏者。是亦如来悉能了知。又诸佛土差别之相。苾刍僧众寿量法住。入息出息受用饮食。如是等类差别之相。如来于此悉能了知。舍利子。一切有情过去世相。若死若生若界若趣。如来于此悉能分别如实了知。又诸有情种种根性。种种行性。种种意解性。如是无量悉能了知。又能了知诸心相续。所谓如是如是心无间。如是如是心生起。彼诸心相若干非一。如来方便悉能数知。舍利子。如来或以现智。或种类智。证得如是过去谢往诸心相续。自既证是智无不备。随众生心而为说法。欲令证入如是智故。舍利子。是名如来第十六过去无碍智不共佛法

复次舍利子。云何如来于未来世。无著无碍智见转。舍利子。何以此智名之为转。所谓未来世中所有如来。或当出现。或当灭度。或复当有。或复当无。彼一切相。如来于此悉能了知。如是乃至当来火劫烧。当来水劫坏。当来风劫坏。乃至一切诸佛国土。当住久近若干等异。如来于此悉能了知。如是乃至当来诸佛国土。所有地界若干微尘。所有卉木丛林众药等事。乃至当来星宿色相若干非一。如来于此悉能了知。如是乃至遍满一一诸佛土中。当来诸佛独觉声闻。及以菩萨出现于世。所有受用若饮若食。入息出息。行住威仪无量等相。如来如实悉能了知。如是乃至一一如来化行差别。观有情性当证解脱。或乘声闻乘。或乘独觉乘。或乘大乘当证解脱。如来一切悉能了知。如是遍满未来之世一一佛土。尔所众生生处差别。诸有情心心所有法。如来一切悉能了知。舍利子。如来如是如实了知。非有来世远心相续。然由如来观于来世如实了知。自既证已亦与众生演说斯法。欲令证入如是智故。舍利子。是名如来第十七未来无碍智不共佛法

复次舍利子。云何如来于现在世。无著无碍智见转。舍利子。何以此智名之为转。舍利子。如来于现在世十方一切诸佛土中。所有三种方便数知如是了知。现在诸佛诸菩萨众。诸声闻众。诸独觉众。若干差别悉能了知。又能了知现在世中星宿色相卉木诸药丛林等事。乃至现在十方一切地界微尘分量。如来如实方便数知。舍利子。十方国土一切水界不可思议。如来以一毛端举滴令尽。如是无量悉能明了方便数知。又十方国土一切火界焰起差别。如来于此方便数知。又十方国土一切风界依色处起。如来亦能方便了知。又十方国土诸大虚界。毛端际量若干非一。如来如实方便数知。舍利子。如来如是了知现在三种众生界。乃至了知现在地狱众生界。彼能生因及彼出因。又知现在畜生众生界。生因出因俱能了知。焰魔界众亦复如是。又能了知现在人间诸众生界。生彼之因及终殁因俱能了知。又能了知现在天趣诸众生界。生彼之因及终殁因俱能了知。又能了知现在众生诸心相续。有烦恼性离烦恼性。及以现在所化众生。诸根差别及非所化。一切众生诸根差别。如是无量。如来如实悉能了知。舍利子。如来如是了知现在一切诸法。非如来智随二识行。为诸众生悟入无二而说斯法。令其觉悟如是之智。舍利子。是名如来第十八现在无碍智不共佛法

复次舍利子。诸佛如来成就如是十八不共佛法故。圆满无余遍十方界。光明流照一切大众。复由是法希有奇特威光名称功德法故。映夺一切天魔众会。舍利子。如来不共佛法不可思议。无边无际犹如虚空。若有欲求如来一切不共佛法边量者。不异有人求于空际。舍利子。是诸菩萨摩诃萨。闻如来不共佛法不可思议如虚空已。信受谛奉志怀清净无惑无疑。倍复踊跃深生欢喜发希奇想。尔时世尊。欲重宣此义。而说颂曰

  导师身语及意业　　无有误失亦无动
  即以此法导众生　　是为如来不共法
  其心不高亦不下　　究竟远离于嗔爱
  常住无诤诤永灭　　是为如来不共法
  导师于法及与智　　解脱所行无忘念
  诸无碍解亦无失　　是为如来不共法
  若住若食若经行　　若坐若卧心常定
  无乱亦无众生想　　是为如来不共法
  善逝于诸佛国土　　有情及佛无异想
  住平等性大意解　　是为如来不共法
  最胜无诸简择舍　　胜决定道善修故
  无有分别异分别　　是为如来不共法
  大师善欲无退减　　常与慈悲方便俱
  调伏众生广无量　　是为如来不共法
  善逝精进曾无减　　观所化众量无边
  三业调伏诸众生　　是为如来不共法
  诸佛大念曾无减　　处菩提座成正觉
  已觉诸法无重觉　　是为如来不共法
  无有分别异分别　　自然住等三摩地
  静虑诸法无所依　　是为如来不共法
  导师智慧最吉祥　　了达一切众生行
  演说妙法随意解　　是为如来不共法
  随声而闻缘独觉　　及与诸佛胜解脱
  无碍离垢譬虚空　　善逝大舍难思虑
  诸佛本来无有心　　自性解脱心相续
  如解脱法为众说　　是为如来不共法
  众生眼见佛威仪　　若住若行入城邑
  相好光明诸所现　　莫不调伏而修善
  真实萨埵放光明　　多拘胝众受安乐
  光现无不度众生　　是为最胜不共法
  自然圣者演法音　　皆得听闻随意解
  所闻法声如响应　　是名最胜不共法
  善逝导师无心业　　诸行业转皆由智
  智入一切众生心　　是名最胜不共法
  诸三摩地及静虑　　善修成满离戏论
  住平等性类虚空　　是名最胜不共法
  于过去世一切法　　种种诸趣解脱智
  善逝妙智无碍转　　是名最胜不共法
  诸佛于彼未来世　　世界当有及当无
  众生国土及最胜　　无有遗余正明了
  善逝观于未来世　　心静曾无散乱时
  众生及法如实知　　是名最胜不共法
  诸有流行现在世　　最胜无障悉能知
  导师境界等虚空　　是名如来不共法
  已说如来不共法　　最胜十八不思议
  真如实性等虚空　　聪慧菩萨能信受

舍利子。是名如来成就如是十八不共佛法。由成就故。如来应正遍知。于大众中正师子吼。自称我处大仙尊位能转梵轮。一切世间沙门婆罗门。诸天魔梵。不能如法而转。舍利子。如是安住净信诸菩萨摩诃萨。于如来十不思议。及十种不可思议法。信受谛奉志怀清净无惑无疑。倍复踊跃深生欢喜发希奇想

大宝积经卷第四十大宝积经卷第四十一

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之七四无量品第五

尔时佛告舍利子。菩萨摩诃萨。安住如是清净信已。佛薄伽梵。知是菩萨摩诃萨为菩萨藏法门之器。知是诸佛正法器已。躬往其所。开发显示菩萨之道。舍利子。汝今当知。如是法门差别之相。所谓菩萨摩诃萨。安住净信佛薄伽梵。知是菩萨为菩萨藏法门之器。知是诸佛正法器已。躬往其所。开菩萨道。舍利子。如彼往昔超越无数广大无量不可思议阿僧企耶劫。尔时有佛出现于世。名为大蕴如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。住自作证具足神通。为诸世间天人魔梵。沙门婆罗门。阿素洛等无量大众。宣说妙法开示演畅。初中后善文义巧妙。纯满清白随顺梵行。舍利子。尔时大蕴如来应正等觉。有七十二那庾多声闻弟子。共会说法。皆是大阿罗汉。诸漏已尽无复烦恼。乃至心得自在。到于第一究竟彼岸。舍利子。是时有王名最胜寿。如法治世号持政王。所治大城名最胜幢。广博严丽安隐丰乐。甚可爱乐。人物充满諠哗炽盛。舍利子。时胜寿王有子名精进行。年居童幼形貌端严。成就第一圆满净色。为诸众生之所乐见。已曾供养承事拘胝那庾多百千诸佛。亲觐奉敬殖诸善本。舍利子。尔时精进行童子。与诸内宫出游园观。时大蕴如来应正等觉。知是童子为菩萨藏法门之器。又是诸佛正法之器。便往彼园精进行所。既到彼已上住空中。为是童子开菩萨道

又复赞说三世诸佛。童子当知。云何名为菩萨道耶。所谓菩萨摩诃萨。于诸有情。精勤修习四无量心。何等为四。所谓大慈波罗蜜。大悲波罗蜜。大喜波罗蜜。大舍波罗蜜。又勤精进于诸摄法随顺修学。童子。若有菩萨如是修行。是名开菩萨道

复次童子。云何菩萨摩诃萨。于诸众生精勤修学。大慈无量波罗蜜。所谓菩萨摩诃萨。行菩萨道。为阿耨多罗三藐三菩提故。尽众生界慈心遍满。以何等量为众生界。所谓尽虚空界是众生量。童子当知。如虚空界无所不遍。如是菩萨摩诃萨大慈无量。亦复如是。无有众生含识种类而不充遍。童子当知。如众生界无有限量。如是菩萨摩诃萨所修之慈亦无限量。空无边故众生无边。众生无边故慈亦无边。童子当知。众生界多非大地界。又非水界火界风界。吾今为汝广说譬喻。令汝了知诸众生界无限量义。童子当知。假使十方各如殑伽河沙等世界数量。一切同时合成大海。满其中水。复有如上殑伽河沙等众生。同共集会。析一毛端为百五十分。共以一分沾取海中第一滴水。复有余殑伽河沙等众生。如前同会。取一分毛沾取海中第二滴水。复有余殑伽河沙等众生。如前同会。取一分毛沾取海中第三滴水。童子当知。假使以是毛滴方便尚可沾尽此大海水。而众生性边量无尽。是故当知众生之性无量无边不可思议。而菩萨慈悉皆遍满。童子。于汝意云何。如是无量无边修慈善根。颇有能得其边际不。精进行童子白佛言。不也世尊。佛言。如是如是。童子。菩萨摩诃萨亦复如是。修慈善根遍众生界为无限量。复次童子。我今更说大慈之相。童子当知。此慈无量能护自身。此慈如是发起他利。于无诤论慈最第一。慈能除断忿恚根栽。慈能永灭一切过失。慈能远离诸有爱缠。此慈如是。但见众生清净胜德。而不见彼有诸愆犯。慈能超越热恼所侵。慈能生长身语心乐。慈力如是。不为一切他所恼害。慈性安隐离诸怖畏。慈善根力随顺圣道。慈能令彼多嗔暴恶不忍众生发清净信。慈能济拔诸众生聚。以慈力故。于彼刀杖性无执持。慈能将导一切众生趣于解脱。是慈能灭诸恶嗔恚。是慈远离诈现威仪谀谄矫饰逼切求索。而能增长利养恭敬名誉等事。以慈力故。梵释天王之所礼敬。以慈严身所有威德。行慈之人。为聪慧者所共称赞。慈能防护一切愚夫。是慈力故超过欲界。顺梵天道开解脱路。慈为大乘最居前导。慈能摄御一切诸乘。慈能积集无染福聚。慈善之力一切有依。诸福业事所不能及。慈能庄严三十二相。及随显相。慈能离彼鄙贱下劣不具诸根。慈为坦路善道涅槃归趣之所。是慈能远一切恶道及诸八难。是慈力故喜乐法乐。不贪一切富贵王位受用乐具。是慈力故。于诸众生等心行施。是慈能离种种妄想。慈为门路。一切尸罗学之所由。慈能救济诸犯禁者。是慈能现忍辱之力。慈能远离一切憍慢矜伐自大。慈能发起无动精进。慈能令修正方便行速疾究竟。慈能为诸静虑解脱及三摩地三摩钵底之所根本。慈能令心出离烦恼诸有炽然。慈为一切智慧生因。由慈无量能闻持故。自他诸品皆悉决定。慈能除遣顺魔烦恼。是慈力故同住安乐。慈能令人起住坐卧密护威仪。慈能损减诸掉性欲。是慈犹如妙香涂身。是慈能涂惭愧衣服。是慈能遣一切诸难烦恼恶趣。慈能济拔一切众生。大慈无量捐舍自乐。能与一切众生安隐快乐。如是无量不可思议大慈之相。吾今略说。童子。是名菩萨摩诃萨大慈无量波罗蜜。菩萨摩诃萨。由成就是大慈无量故。观诸众生常怀慈善。勤求正法无有疲倦。童子当知。诸声闻慈唯能自救。诸菩萨慈毕竟度脱一切众生。童子当知。众生缘慈。初发大心菩萨所得。法缘之慈。趣向圣行菩萨所得。无缘之慈。证无生忍菩萨所得。童子。是名菩萨摩诃萨大慈无量波罗蜜。若菩萨摩诃萨。安住大慈波罗蜜故。则于一切众生慈心遍满

复次精进行童子。云何名为菩萨摩诃萨大悲无量波罗蜜。童子当知。菩萨摩诃萨。为欲证得阿耨多罗三藐三菩提故。应以大悲而为导首。如人命根出息入息而为上首。如是童子。证得大乘菩萨摩诃萨亦复如是。必以大悲而为导首。童子。如转轮王所有众宝。要以金轮而为前导。如是童子。菩萨摩诃萨亦复如是。所有一切诸佛正法。皆以大悲而为导首

复次童子。菩萨摩诃萨。为阿耨多罗三藐三菩提故。度诸众生行于大悲。毕竟不舍一切众生。童子。云何菩萨摩诃萨于众生所发起大悲。童子。菩萨摩诃萨行大悲时。观诸众生虚伪身见之所缠缚。为诸恶见之所藏隐。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法。令其永断虚伪身见种种缠缚诸恶见等

复次童子。菩萨摩诃萨行大悲时。观诸众生安住不实虚伪颠倒。于无常中妄起常想。于诸苦中妄起乐想。于无我中妄起我想。于不净中妄起净想。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令其永断虚妄不实诸颠倒故

复次童子。菩萨摩诃萨行大悲时。观诸众生愚痴颠倒耽嗜爱欲。于母姊妹尚生陵逼。况复于彼余众生等。菩萨摩诃萨观是事已。作如是念。苦哉世间。乃能容止非圣之聚。恶业无愧充满其中。复作是念。咄哉苦哉。如是众生曾处母胎。卧息停止生由产门。如何无耻共行斯事。如是众生深为大失极可怜愍。种种过患极可诃责。何以故。为贪嗔痴之所害故。又为无智所加害故。舍离正法安住非法。修行恶法堕在地狱畜生焰魔鬼趣。如是众生恶业引故。所往之处行于非道。童子。譬如野干于彼冢间为诸群狗之所搏逐逃迸走避临大峻崖穷途所逼夜中嗥叫。如是童子。彼诸众生亦复如是同于野干。复次童子。譬如生盲群狗逼逐临大坑涧。如是童子。彼诸众生亦复如是同于生盲。复次童子。譬如圂猪行处粪秽兼又食啖初无厌恶。如是童子。彼诸众生亦复如是同于圂猪。如是众生极可怜愍。淫恼所逼于亲非亲。为诸烦恼之所加害。行魔徒党魔罥所缚。缠裹惑网陷没欲泥。童子。菩萨摩诃萨观是事已。于彼众生发起大悲。我当为彼宣说妙法令其永断诸欲烦恼故

复次童子。菩萨摩诃萨行大悲时。观诸众生五盖所覆。欲箭所中。贪着六处。眼见色已。执着像貌不能舍离。如是耳所闻声。鼻所嗅香。舌所尝味。身所觉触。执着形相皆不能舍。是诸众生多于嗔恚互相怨仇。若得义利称我善友。得非义利便相加害。是诸众生多于惛沈及以眠睡羸劣愚钝。为无智膜之所覆障。是诸众生不善掉悔之所缠缚。常为种种诸恶烦恼染污其心。是诸众生疑网缠裹。于甚深法不能决定。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令其永断诸荫盖故

复次童子。菩萨摩诃萨行大悲时。观诸众生为慢所害。过慢所害。我慢所害。增上慢所害。邪慢所害。于诸下劣计我为胜。于彼等者计我最胜。或有众生计色为我。或复乃至计识为我。于所未证计我已证。由恃此故。应可问讯而不问讯。应可礼拜而不礼拜。于诸长宿心无敬顺。于尊重师不加只仰。于聪睿者而不请问。何等为善何等不善。何等应修何等不修。何等应作何等不作。何等有罪何等无罪。何等为道。何等为三摩地。何等为解脱。如是等法曾未明了。但自计我为胜为尊。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令其永断一切憍慢种故

复次童子。菩萨摩诃萨行大悲时。观诸众生爱缚所缚。为爱僮仆妻妾男女所共缠裹。为无义利之所围绕。为诸衰祸之所系缚。生死关键之所遮碍。不能出离地狱傍生焰魔鬼道。为彼有缚之所拘捡。而不能得纵任自在。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令其获得纵任自在随欲而行趣涅槃故

复次童子。菩萨摩诃萨行大悲时。观诸众生远离善友为恶知识之所缠执由彼昵近诸恶友故。耽着一切不善之业。所谓杀生偷盗邪行妄语离间粗犷绮语贪恚邪见。诸如是等无量恶业炽然建立。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令其为诸善友所摄舍弃十种不善业道令具受持十善业故

复次童子。菩萨摩诃萨行大悲时。观诸众生为诸愚痴之所覆蔽。无明暗暯之所翳障。颠倒执着。于其自体有情命者。生者人者。少年丈夫。及数取者。作者受者。我及我所。如是诸见无边无量坚执不舍。童子。菩萨摩诃萨如是观已。于诸众生发起大悲。我当为彼说微妙法令圣慧眼得清净故。又令永断一切见故

复次童子。菩萨摩诃萨行大悲时。观诸众生乐着生死流转不息五蕴魁脍常恒寻逐三界囹圄曾无远离桎梏枷锁不思开释。菩萨摩诃萨观见是已。于诸众生发起大悲。我当为彼说微妙法令彼解脱五蕴魁脍。又令越度生死旷野及以出离三界牢狱诸系缚故

复次童子。菩萨摩诃萨行大悲时。观诸含识从不善生。如鞠如轮转圆不定。由此业故。从此世间至彼世间。又从彼世间至此世间。迅速流转驰向五趣背涅槃道。童子。菩萨摩诃萨观是事已。于诸众生发起大悲。我应为彼说微妙法。当为开辟涅槃宫门令其趣入。如是童子。菩萨摩诃萨行大悲时。观众生性发起十种大悲无量。复次童子。菩萨摩诃萨。复有十种大悲转相。所谓如是大悲。由于不谄而得生起。譬如虚空永出离故。如是大悲。由于不诳而得生起。从增上意而出离故。如是大悲。非由诈妄而得发起。从如实道质直其心而出离故。如是大悲。由于不曲而得生起。极善安住无曲之心而出离故。如是大悲。由彼无有憍高怯下而得生起。一切有情高慢退屈善出离故。如是大悲。由护彼故而得生起。从自心净而出离故。如是大悲。由坚固慧而得生起。永离一切动不动心。妙住其心善出离故。如是大悲。由舍自乐而得生起。授与他乐善出离故。如是大悲。为欲荷负诸众生故而得生起。坚固精进善出离故

复次童子。菩萨摩诃萨大悲无量。复有如是十种转相。所谓一切大乘出离。皆因大悲而得出离。以是因故说名大悲。如是大悲。建立一切布施持戒忍辱精进静虑智慧。由是因故说名大悲。如是大悲。建立念处正断神足。如是大悲。建立根力觉支随念共法觉支。及与道支。欢喜本业。诸定次第。十善业道。乃至诸相皆如是说。以是因故说名大悲。如是大悲。建立如来自然智慧。以是因故名为大悲。童子当知。如是大悲作自所作。善作所作不变异作。为诸众生作所应作。如是大悲。一切众生如意圆满。童子。是名菩萨摩诃萨大悲无量波罗蜜。由成就是大悲波罗蜜故。菩萨摩诃萨。观诸众生处如是位。复于彼所重兴悲愍

复次精进行童子。云何名为菩萨摩诃萨大喜无量波罗蜜。童子当知。菩萨摩诃萨为众生故求阿耨多罗三藐三菩提时。修行大喜。如是喜者有无量相。童子当知。菩萨喜者名诸善法。忆念欢悦清净妙喜。何以故。于诸善法无下戚性无退屈性无疲倦性故。是喜名为远离一切乐世间性。何以故。安住一切乐法乐性故。是喜能令内以欢悦身力勇锐。何以故。慧觉怡畅心意踊跃故。是喜乐于如来之身。何以故。乐求相好好庄严故。是喜闻法无有厌倦。何以故。欣乐依法能正行故。由斯喜故于法欣勇。于诸众生心无损害。喜乐菩提于广大法悉能信解。发起远离少分乘心。是喜名为制伏悭喜。何以故。于诸求者行必施故。由斯喜故。于诸犯戒爱心摄受。于诸持戒心常清净。又复能令自尸罗净。是喜名为超过一切恶道怖畏安隐之喜。是喜名为忍受他人诸恶言词鄙语路喜。是喜名为无返报喜。何以故。若遇挑眼截手刖足斩支节时心堪忍受。是喜名为敬尊重喜。何以故。于诸长宿具修威仪。曲躬恭敬跪拜尊严故。是喜名为恒舒颜喜。何以故。心志和泰远离嚬蹙先言问讯故。是喜名为远离一切诈现威仪谀谄矫诳逼求之喜。何以故。是喜趣向坚实正法之道路故。由此喜故。于诸菩萨起深爱乐犹如大师。于正法所起爱乐心如自己身。于如来所起爱乐心如自己命。于尊重师起爱乐心犹如父母。于诸众生起爱乐心视如一子。于阿遮利耶受教师所起爱乐心敬如眼目。于诸正行起爱乐心犹如身首。于波罗蜜起爱乐心犹如手足。于说法师起爱乐心如众重宝。所求正法起爱乐心犹如良药。于能举罪及忆念者起爱乐心犹如良医。如是童子。是名菩萨摩诃萨大喜无量波罗蜜。诸菩萨摩诃萨。住是大喜波罗蜜故。行菩萨行常怀欢喜。勤求正法无有厌倦

复次精进行童子。云何名为菩萨摩诃萨大舍无量波罗蜜。童子当知。菩萨摩诃萨为众生故。发阿耨多罗三藐三菩提已。当行大舍。当知是舍有于三种。何等为三。谓舍烦恼舍。护自他舍。时非时舍。何等名为舍烦恼舍。童子当知。菩萨摩诃萨。于敬事所其心不高。于不敬事心无卑下。若受利养心不憍高。不得利养心无纡郁。于彼持戒及犯戒所起平等觉。得胜名誉心不悕乐。被诸毁谤情无忧戚。若致讥诃志无贬退。于称赞所善住法性。于诸苦事有择慧力。于诸乐事有无常苦观解之力。弃舍爱欲断诸嗔恚。于怨亲所其心平等。于善作恶作其心无二。于有爱不爱情无所观。于善闻恶闻不生执着。于善说恶说心无爱恚。于诸欲味及过患所平等称量。于我自身及他众生。起于平等信欲之意。于身命所情无顾恋。于下中上诸众生所起平等照。于隐显法起平等性。于谛非谛自体清净。如是童子。菩萨摩诃萨。若能自然起胜对治。是名菩萨摩诃萨舍烦恼舍

复次童子。何等名为护自他舍。童子当知。菩萨摩诃萨。若被他人节节支解割皮肉时。常自观心住于大舍。虽复支解割其身肉。然其内心唯住于舍。无所希望。及以追求纵于身语起诸变异俱能堪忍。是则名为护自他舍。尔时菩萨。又观二种心无损害。何等为二。所谓不由眼相及以色相。乃至不由意相及以法相。心生损害而住于舍。何以故。无损无害。是乃名为护自他舍。复次。何等名为护自他舍。被他所损不加报故。于自于他俱能忍受。是名为舍。于诸有恩及无恩所平等方便。是名为舍。是舍名为无诤极舍。灭自心舍。观自体舍。不害他舍。于诸定事菩萨能舍。然佛世尊非所听许。诸菩萨等唯修于舍。何以故。菩萨摩诃萨。尚应修习诸行作用。日夜常念发起精进。求诸善法。于时非时乃应修舍

复次童子。何等名为时非时舍。童子当知。菩萨摩诃萨。具大智慧。善能修习时与非时。谓非法器诸众生所。应起于舍。不恭敬所应起于舍。于无利益讥毁苦恼应起于舍。于声闻乘趣正决定。应起于舍。于修施时应舍修戒。于修戒时应舍修施。于修忍时应舍牵引施戒精进。修精进时应舍修戒。修静虑时应舍施度。修习慧时应舍缘发五波罗蜜多。童子。是名菩萨摩诃萨时非时舍。何以故。由所不应作法无造作性故。是故菩萨深知非益而行于舍。若有菩萨摩诃萨。安住大舍波罗蜜行菩萨行。则于一切恶不善法能兴大舍。童子。如是等相。是名菩萨摩诃萨大慈大悲大喜大舍。若诸菩萨摩诃萨。安住如是四无量波罗蜜者。当知是则为菩萨藏法门之器。又是诸佛正法之器

如是舍利子。此薄伽梵大蕴如来。为精进行童子。广开示此四无量已。复为开解六波罗蜜多及诸摄法。令是童子随顺修学。舍利子。是精进行童子。精勤修习如所闻法。广如后说

    陀那波罗蜜多品第六

尔时佛告舍利子。云何菩萨摩诃萨。为阿耨多罗三藐三菩提故。精勤修习诸波罗蜜多行菩萨行。舍利子。菩萨摩诃萨行菩萨行者。即于如是六波罗蜜多精勤修学。是则名为行菩萨行。舍利子。何等名为六波罗蜜多。舍利子。所谓柁那波罗蜜多。尸罗波罗蜜多。羼底波罗蜜多。毗利耶波罗蜜多。静虑波罗蜜多。般若波罗蜜多。舍利子。如是名为六波罗蜜多。菩萨摩诃萨。依如是六波罗蜜多故行菩萨道

复次舍利子。云何名为菩萨摩诃萨依柁那波罗蜜多行菩萨行。舍利子。菩萨摩诃萨度众生故。行柁那波罗蜜多时。为诸众生而作施主。若沙门婆罗门等。有来求者悉皆施与。须食与食。须饮与饮。珍异肴膳无不尽施。如是或求车乘。衣服华鬘。涂香末香。或求坐卧依倚。床席敷具。病药灯明。音乐奴婢。或求金银末尼。真珠琉璃。螺贝璧玉。珊瑚等宝。或求象马车辂。园林池苑。男女妻妾。财谷库藏。或求四大有洲自在之王一切乐具。及诸嬉戏娱乐之物。或有来求手足耳鼻。头目肉血。骨髓身分。菩萨摩诃萨见来求者。悉能一切欢喜施与。舍利子。以要言之。一切世间所须之物。菩萨摩诃萨行大施故。但见来求无不施与。复次舍利子。菩萨摩诃萨行柁那波罗蜜多故。复有十种清净施法。何等为十。一者菩萨摩诃萨。无有不正求财而行布施。二者菩萨摩诃萨。不逼迫众生而行布施。三者菩萨摩诃萨。不以恐怖而行布施。四者菩萨摩诃萨。不弃舍邀请而行布施。五者菩萨摩诃萨。不观颜面而行布施。六者菩萨摩诃萨。于诸众生情无异想而行布施。七者菩萨摩诃萨。无贪爱心而行布施。八者菩萨摩诃萨。无起嗔恚而行布施。九者菩萨摩诃萨。不求刹土而行布施。十者菩萨摩诃萨。于诸众生起福田想。不以轻蔑而行布施。舍利子。是名菩萨摩诃萨行于十种清净之施。为满柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。复有十种清净行施。何等为十。一者菩萨摩诃萨。不毁业报而行布施。二者菩萨摩诃萨。不以邪意而行布施。三者菩萨摩诃萨。无不信解而行布施。四者菩萨摩诃萨。无有厌倦而行布施。五者菩萨摩诃萨。无有现相而行布施。六者菩萨摩诃萨。勇励炽然而行布施。七者菩萨摩诃萨。无有变悔而行布施。八者菩萨摩诃萨。于持戒者不以偏敬而行布施。九者菩萨摩诃萨。于犯戒所不以轻鄙而行布施。十者菩萨摩诃萨。不希果报而行布施。舍利子。是名菩萨摩诃萨行于十种清净之施。为欲满足柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。复有十种行清净施。何等为十。一者菩萨摩诃萨。不以毁呰而行布施。二者菩萨摩诃萨。不以背面而行布施。三者菩萨摩诃萨。无不清净而行布施。四者菩萨摩诃萨。不现忿相而行布施。五者菩萨摩诃萨。不现嫉相而行布施。六者菩萨摩诃萨。不现恚相而行布施。七者菩萨摩诃萨。无不殷重而行布施。八者菩萨摩诃萨。无不自手而行布施。九者菩萨摩诃萨。不以许多后便与少而行布施。十者菩萨摩诃萨。不求来生而行布施。舍利子。是名菩萨摩诃萨行于十种清净之施。为欲满足柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。复有十种行清净施。何等为十。一者菩萨摩诃萨。无不常施。二者菩萨摩诃萨。无系属施。三者菩萨摩诃萨。无差别施。四者菩萨摩诃萨。无他缘施。五者菩萨摩诃萨。无微劣施。六者菩萨摩诃萨。不希财色及以自在。而行布施。七者菩萨摩诃萨。无求生于释梵护世诸大天故。而行布施。八者菩萨摩诃萨。无有回向声闻独觉地故。而行布施。九者菩萨摩诃萨。无为聪慧所讥诃故。而行布施。十者菩萨摩诃萨。无不回向萨伐若故。而行布施。舍利子。是名菩萨摩诃萨行于十种清净之施。皆为满足柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。复有十种行清净施。何等为十。谓如前说十种法中。出离有为证得无为。又舍利子。菩萨摩诃萨。如是行施能得十种称赞利益上妙功德。何等为十。一者菩萨摩诃萨。由施食故。获得长寿才辩。安乐妙色。雄力勇健。无不具足。二者菩萨摩诃萨。由施饮故。获得永离一切烦恼渴爱。无不具足。三者菩萨摩诃萨。由施诸乘故。获得一切利益安乐众事。无不具足。四者菩萨摩诃萨。由施衣服故。获得成就惭愧。皮肤清净犹如金色。无不具足。五者菩萨摩诃萨。由施香鬘故。获得净戒多闻诸三摩地。涂香圣行。无不具足。六者菩萨摩诃萨。由以末香涂香施故。当得遍体香洁。妙香圣行。无不具足。七者菩萨摩诃萨。由施上味故。获得甘露上味。大丈夫相。无不具足。八者菩萨摩诃萨。由以舍宅房宇施故。当得与诸众生。为舍为宅。为救为洲。为归为趣。无不具足。九者菩萨摩诃萨。由愍病者施医药故。当得无老病死。圆满甘露不死妙药。无不具足。十者菩萨摩诃萨。由以种种资生众具施故。感得一切圆满众具。菩提分法。无不具足。舍利子。是名菩萨摩诃萨为得菩提。修行是施。获得如是十种称赞利益上妙功德。皆为满于柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。修行布施。又复获得十种称赞利益上妙功德。何等为十。一者菩萨摩诃萨。施灯明故。获得如来清净五眼。无不具足。二者菩萨摩诃萨。施音乐故。获得如来清净天耳。无不具足。三者菩萨摩诃萨。以诸金银。末尼真珠。琉璃螺贝。璧玉珊瑚。一切珍宝施故。感得圆满三十有二大丈夫相。无不具足。四者菩萨摩诃萨。以种种杂宝。及众名花施故。获得圆满八十随显之相。无不具足。五者菩萨摩诃萨。以象马车乘施故。获得广大徒众眷属繁多。无不具足。六者菩萨摩诃萨。以园林台观施故。获得成就静虑解脱。三摩地。三摩钵底。无不具足。七者菩萨摩诃萨。以财谷库藏施故。获得圆成诸法宝藏。无不具足。八者菩萨摩诃萨。以奴婢仆使施故。获得圆满自在身心闲豫。无不具足。九者菩萨摩诃萨。以男女妻妾施故。获得圆满可爱可乐可意。阿耨多罗三藐三菩提。无不具足。十者菩萨摩诃萨。以四洲自在一切王位施故。获得一切种微妙圆满一切智智。无不具足。舍利子。菩萨摩诃萨如是行施。名为摄受十种称赞利益上妙功德。皆为满足柁那波罗蜜多故

复次舍利子。菩萨摩诃萨。为得阿耨多罗三藐三菩提故。行柁那波罗蜜多时。所修布施。又得十种称赞利益。何等为十。一者菩萨摩诃萨。以上妙五欲施故。获得清净戒定慧聚。及以解脱解脱智见聚。无不具足。二者菩萨摩诃萨。以上妙戏乐器施故。获得清净游戏法乐。无不具足。三者菩萨摩诃萨。以足施故。感得圆满法义之足。趣菩提座。无不具足。四者菩萨摩诃萨。以手施故。感得圆满清净法手。拯济众生。无不具足。五者菩萨摩诃萨。以耳鼻施故。获得诸根圆满成就。无不具足。六者菩萨摩诃萨。以支节施故。获得清净无染威严佛身。无不具足。七者菩萨摩诃萨。以目施故。获得观视一切众生清净法眼。无有障碍。无不具足。八者菩萨摩诃萨。以血肉施故。获得坚固身命。摄持长养一切众生贞实善权。无不具足。九者菩萨摩诃萨。以髓脑施故。获得圆满不可破坏等金刚身。无不具足。十者菩萨摩诃萨。以头施故。证得圆满超过三界。无上最上一切智智之首。无不具足。舍利子。菩萨摩诃萨。为得菩提行如是施。摄受如是相貌。圆满佛法称赞利益上妙功德。皆为满足柁那波罗蜜多故

复次舍利子。如是菩萨摩诃萨。行柁那波罗蜜多时。其性聪睿智慧甚深。无量方便行于布施。以世间财求于无上正等菩提众圣王财。以生死财而求甘露不死仙财。以虚伪财而求坚实贤圣之财。由如是故广行布施。舍利子。是菩萨摩诃萨。为求无上菩提及涅槃故。以世间财物修行施时。一切世间财物乐具无不尽舍。何以故。皆依无上正等觉故。舍利子。如世农夫依彼犁牛。耕治地已便下种子。如是农夫依彼犁具无量功力。展转获得金银末尼一切宝物。及得种种上妙衣服。何以故。一切世间无有财物与谷等故。如是舍利子。菩萨摩诃萨。有时有分依世间财证觉无上正等菩提亦复如是

复次舍利子。譬如乳牛或啖干草。或啖湿草。或饮冷水。或饮暖水。而能出于乳酪生苏熟苏及以醍醐。如是舍利子。菩萨摩诃萨。依于无上正等菩提。行世财施随所乐欲。有能获得转轮王报。及获帝释梵王胜报。由成就是三种报故。菩萨十地速得圆满。如来十力四无所畏。因是施故速得圆满。乃至具足千业所起十八不共佛法。又具千业所起六十种圆满妙音。又具百业所起一一大丈夫相。又具二百业所起无见顶髻相。又过此百倍。圆满成就如来大法螺相。又过拘胝百千倍。成就如来皓齿齐列。不缺不疏平等之相。如是等相。无量功业之所合成皆由如来业果报相施行所起。速得圆满

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。于乞者所起大慈心而行布施。此心续起殑伽沙等。方得成满。中无间绝佛三摩地。舍利子。如来应正等觉。住此三摩地已。能于一一毛孔。而出百三摩地。犹如殑伽大河流化不绝而得自在。是故当知。如来所有一切神通变化。多由施行而得成就。舍利子。如是如来所有佛法。皆由昔日行菩萨行。世间财施之所摄受。舍利子。是名菩萨摩诃萨行财施时。为求甘露。为求坚实。为求菩提。为求涅槃。应知如是法门差别。所谓菩萨摩诃萨。依世财施。而与柁那波罗蜜多相应。证觉阿耨多罗三藐三菩提故

复次舍利子。菩萨摩诃萨。行柁那波罗蜜多时。其相无量吾今当说。往昔过去无数广大。无量不可思议。阿僧企耶劫。于彼时分有佛出世。号旁耆罗私如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。彼佛住世寿十千岁。与百千苾刍大声闻众。同共集会。皆阿罗汉。离诸烦恼具大势力。乃至一切心得自在。逮胜究竟。舍利子。时彼世中有纺绩者。名织纺线。形貌端正众所乐观。彼作业处去佛不远。每日将晚欲还家时。往诣佛所。常以一缕微线。奉施如来。因白佛言。愿薄伽梵哀愍我故。受此缕线为摄受处。以此善根于未来世。得成如来应正等觉能摄一切。时彼世尊便为纳受。如是日施一缕。满千五百为善摄受。由此福故。乃经十五拘胝劫中。不堕恶趣。又经千拘胝。反为转轮王。又经千拘胝。反为天帝释。以此善根柔和微妙欣爱等业。便得奉觐千拘胝佛。于诸佛所供养恭敬尊重赞叹。又以诸花涂香末香。及以香鬘缯盖幢旛。衣服饮食坐卧之具。病缘医药一切众物奉献如来。从是已后又经一阿僧企耶劫出现于世。证觉阿耨多罗三藐三菩提。号善摄受如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。住寿世间经二十拘胝岁。有二十拘胝那庾多大声闻众。一切皆是大阿罗汉。彼佛世尊成立安住。五拘胝等菩萨摩诃萨。于阿耨多罗三藐三菩提演说妙法。利益安乐无量无数诸有情已现入涅槃。彼薄伽梵灭度之后。正法住世满一千年。广布舍利流遍供养。亦如我今涅槃之后。舍利子。汝今当观。由施微缕发大心故。次第展转成满佛法。舍利子。当知此施由心广大不由于缕。何以故。若施广大不由心者。如向施主以微缕施。不应得心清净究竟。如是舍利子。当观菩萨摩诃萨。行柁那波罗蜜多时。依世财施便得一切圆满功德。舍利子。菩萨摩诃萨。行柁那波罗蜜多时。其性聪睿智慧甚深。因于少施多有所作。由智力故增上所作。由慧力故广大所作。回向力故无边所作。尔时世尊。欲重宣此义。而说颂曰

  行施不求妙色财　　亦不愿感天人趣
  为求无上胜菩提　　施微便感无量福
  行施不求名称声　　未曾为乐及徒众
  亦不求诸生死报　　施微而获于大果
  布施饮食及衣服　　不求诸有及诸趣
  为求开解甘露门　　施如毛端福无量
  既无掉动及高慢　　亦离谄诳悭嫉心
  懈怠诸缘皆悉舍　　唯勤行施利于世
  财谷王位及身命　　欢喜舍已心无变
  如斯善舍获广大　　菩提解脱未为难
  爱乐诸来乞求者　　如父如母如妻子
  所获财物常行施　　见彼感财无妒心
  行施之时众繁杂　　土块杖木来加害
  虽见曾无忿恚心　　爱语如旧情欣悦
  若施彼怨犹若亲　　于惊怖者施无畏
  凡所有物皆能舍　　而心未尝生鄙吝
  恒乐正求无上法　　于世王位绝希求
  出离世间严饰处　　常勤奉行于法施
  除彼乐求秽欲者　　谁有能求天世王
  是故智者不贪乐　　诸欲王位生天乐
  大名称者所行施　　恒求无上佛菩提
  舍捐身命及余事　　速疾能感多安乐
  聪慧菩萨行诸施　　未曾远离上菩提
  不求妙色世间财　　又不愿乐生天乐
  虽求涅槃无所依　　远离一切诸希愿
  若能如是善修习　　则名知道开道者

舍利子。聪慧菩萨摩诃萨。于是布施具足成就。善能修行菩萨妙行。无有疑惑。舍利子。是名菩萨摩诃萨柁那波罗蜜多。若诸菩萨摩诃萨。为阿耨多罗三藐三菩提故。精进修行是菩萨行。一切众魔魔民天子。于此菩萨不能娆乱。又不为彼异道他论。所能摧屈

大宝积经卷第四十一大宝积经卷第四十二

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之八尸波罗蜜品第七之一

尔时佛告舍利子。云何菩萨摩诃萨。尸罗波罗蜜多。菩萨摩诃萨。为阿耨多罗三藐三菩提。依此勤修行菩萨行。舍利子。菩萨摩诃萨。行尸罗波罗蜜多故。有三种妙行。何等为三。一者身妙行。二者语妙行。三者意妙行。舍利子。何等名为身妙行语妙行意妙行耶。舍利子。所谓菩萨摩诃萨。远离杀生。离不与取。离欲邪行。是名身妙行。舍利子。菩萨摩诃萨。远离妄语。远离离间语。远离粗恶语。远离绮语。是名语妙行。舍利子。菩萨摩诃萨。于诸贪着嗔恚邪见。皆无所有。是名意妙行。菩萨摩诃萨。具足如是三妙行故。是名尸罗波罗蜜多

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。如是思惟。云何身妙行语妙行意妙行耶。舍利子。菩萨摩诃萨。如是思惟。若身不造杀生不与取欲邪行业者。是名身妙行。菩萨摩诃萨。如是思惟。若语不造妄语离间粗恶绮语业者。是名语妙行。菩萨摩诃萨。如是思惟。若意不造贪着嗔恚邪见业者。是名意妙行。由具如是正思惟故。是名菩萨摩诃萨行尸罗波罗蜜多

复次舍利子。如是菩萨摩诃萨。行尸罗波罗蜜多时。作如是念。若业不由身语意造。此业为可建立不。菩萨摩诃萨。如是如理观察。若业不由身语意造。此业不可建立。若青若黄。若赤若白。若红若颇胝色。此业又非眼所识。非耳所识。非鼻舌身意所识。何以故。舍利子。由于此业非能生非所生非己生。不可执受。都无有能了别此业。菩萨摩诃萨。如是了知。此尸罗性不可为作。若不可为作。则不可建立。若不可建立。我等于中不应执着。如是菩萨摩诃萨。由观解力故。不见妙行及以尸罗。亦不见有具尸罗者。不见尸罗所回向处。菩萨摩诃萨如是观已。毕竟不起妄有身见。何以故。舍利子。有身见故可有观察。此是持戒。此是犯戒。如是观已。于彼守护及以仪则。若行若境皆悉具足。正知而行。正知行故名持戒者。菩萨摩诃萨。不取着自不取着他。而行于行。不毁尸罗不取尸罗。而行于行。若取着我即取尸罗。若不着我不取尸罗。若知尸罗是不可得。即不毁犯所有律仪。若于律仪无毁犯者。即不名为毁犯尸罗。又亦不名执取尸罗。舍利子。以何因缘。于是尸罗而不执取。谓一切法知他相故。若由他相则无有我。若我是无何所执取。尔时世尊。欲重宣此义。而说颂曰

  若有身语意清净　　行时恒修一切净
  常住清净诸禁戒　　是名菩萨具尸罗
  贤圣聪慧诸菩萨　　能善护持十业道
  不由身语及意作　　如是智者说尸罗
  若非造作非所生　　非执无形亦无显
  由无有形有显故　　未曾可得而建立
  尸罗无为亦无作　　非眼能见非耳闻
  非鼻非舌亦非身　　又非心意所能识
  若非六根之所识　　则无有能施设者
  如是观察尸罗净　　曾未依执住尸罗
  不恃持戒生憍慢　　不计我想护尸罗
  善护尸罗无戒想　　具足尸罗行觉行
  妄有身见已除遣　　见与见者曾无有
  无有能见无彼处　　不观持戒犯戒者
  善入无护法理趣　　威仪具足不思议
  妙善正知能守护　　除斯更无具戒者
  无我想者无尸罗　　无所依我能依戒
  我说究竟常无畏　　不执身我与尸罗
  说无我者不取戒　　说无我者戒无依
  说无我者不希戒　　说无我者戒无心
  不毁尸罗不执戒　　亦不计我起尸罗
  无所依我及戒想　　甚深慧行菩提行
  如是尸罗无所畏　　此人常不犯尸罗
  若能不执有诸法　　如是尸罗圣所赞
  若住我见诸愚夫　　计我具戒能持戒
  彼受护戒果终已　　于三恶趣常缠缚
  若有断尽诸我见　　彼无有我及我所
  是真持戒无见故　　无复怖畏堕诸恶
  若能如是知戒行　　无有能见犯尸罗
  尚不观我及三有　　况见持戒及犯戒

复次舍利子。如是行尸罗波罗蜜多。菩萨摩诃萨。行菩萨行清净戒时。具有十种极重深心。何等为十。一者发起深心信奉诸行。二者发起深心勤加精进。三者猛励乐欲诸佛正法。四者广具崇重一切诸业。五者深怀信奉一切果报。六者于诸贤圣深发敬心。七者于诸尊重邬波柁耶阿遮利耶清净侍奉。八者于贤圣所兴起供养。九者于诸正法励意求请。十者求菩提时不顾身命。舍利子。如是行尸罗菩萨摩诃萨。有如是等十深心法。菩萨摩诃萨。安住深心修诸善法。何等名为诸善法耶。所谓三种妙行。身妙行语妙行意妙行。若诸菩萨摩诃萨。安住如是三种妙行。为欲勤求大菩萨藏微妙法门。何以故。以诸菩萨摩诃萨依此法门。能趣阿耨多罗三藐三菩提故。尔时世尊欲重宣此义。而说颂曰

  由身而发起　　佛所赞善业
  为得闻法故　　供养诸贤圣
  于法及圣人　　猛励起恭敬
  为利诸众生　　慈心不嫉妒
  当演智人言　　无谈不爱语
  所说欣乐相　　发语无粗鄙
  意业常居善　　曾无乐诸恶
  恒观察法性　　恭敬住慈心
  于如来圣教　　敬心而听法
  于法恭敬已　　速悟大菩提

舍利子。诸菩萨摩诃萨行尸罗波罗蜜多时。安住如是十最胜法。勤求菩萨藏法门故。于诸贤圣一切师长。勤加恭敬奉事供养。乃至施及贮水之器。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。应具如是十种发心。何等为十。舍利子。菩萨摩诃萨。观是病身。诸界毒蛇恒相违害。多诸苦恼多诸过患。癫狂痈疖疽癣恶疠。风热痰饮众病所聚。又是身者如病如疮。如被箭刺。如暴水流。如魁脍者。摇动不息速起速灭。又观是身。虚伪羸弱。老朽疾坏。暂时停住难可爱乐。状若冢间。尔时菩萨复作是念。我此病身虽经此苦。曾不值遇如是福田。我今得值。又复善感如此之身。我当依诸福田长养慧命。舍不坚身获于坚身。为欲勤求大菩萨藏微妙法门故。于彼贤圣邬波柁耶。阿遮利耶诸尊师所。奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第一发心。尔时世尊。欲重宣此义。而说颂曰

  诸界暴毒蛇　　展转相依附
  随一兴增动　　生则致大患
  所谓眼耳鼻　　舌齿内腹藏
  如是诸患恼　　皆悉依身生
  痈疖与癫狂　　疽癣大疾疠
  诸余种种病　　无不依身生
  是身犹如病　　如痈如中箭
  如是毒害身　　速坏暂时住
  如趣彼冢间　　悉是无常相
  摇鼓烂坏身　　众病速生灭
  我当修佛身　　所因贤善业
  以彼朽烂坏　　衰老无常身
  转成于佛身　　及难思法身
  以如是朽坏　　遍常流秽身
  当证得如是　　无流无秽身
  若人怖寒热　　遮障坚防护
  毕为老病死　　诸苦同煎害
  若人于寒热　　身遍能堪忍
  庄严丈夫业　　速成无上身
  我当勤供养　　世所同尊重
  以不坚实身　　当贸彼坚实

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是等第一心已。为欲勤求大菩萨藏微妙法门故。于说法师倍复奉事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是念。身是不坚性非牢固。当假覆蔽洗濯按摩。而复终归破坏离散摩灭之法。舍利子。譬如陶师埏埴瓦器。若大若小终归破坏。如是舍利子。身为不坚。终归破坏如彼瓦器。又舍利子。譬如树枝所依花叶果实。终归堕落。如是舍利子。身为不坚必堕落法。势非久住如熟果等。又舍利子。譬如草端霜露凝滴。日光照灼必不停住。如是舍利子。身为不坚。如霜露滴亦不久住。又舍利子。譬如大海及以众流。有泡沫聚一切不坚。其性虚弱不可[敲-高+亭]触。如是舍利子。是身不坚犹如沫聚。本性虚弱亦复如是。又舍利子。如天大雨流泡乱浮徐起徐灭。如是舍利子。身为不坚如水上泡。其性轻薄亦复如是。舍利子。菩萨摩诃萨深自观身。见是事已复作是念。我于长夜感得如是不坚固身。曾未值遇如是福田。我今得值。又复善感如此之身。我当依诸福田长养慧命。以不坚身贸易坚身。为欲勤求大菩萨藏微妙法门故。于说法师奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第二发心。尔时世尊。欲重宣此义。而说颂曰

  如世诸陶师　　埏埴坏成器
  皆当归破坏　　众生命如是
  譬如依树枝　　所有叶花果
  皆归堕落法　　人命亦如是
  如草端垂露　　日光之所照
  须臾不暂停　　人命亦如是
  如河海聚沫　　其性本虚弱
  如是不坚身　　虚浮亦如是
  譬如天大雨　　生起水浮泡
  刹那速消灭　　不坚身亦尔
  不坚起坚想　　于坚想不坚
  邪分别所行　　不能证坚实
  于坚起坚智　　不坚知不坚
  正分别所行　　能证于坚实
  为修坚实想　　微施于水器
  故以不坚身　　贸易彼坚实

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是第二心已。为欲勤求大菩萨藏微妙法门故。于说法师倍复奉事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我于长夜远离善友。诸恶知识之所拘执。其性懈怠不修精进。下劣愚钝多邪恶见。妄起如是痴不善心。无施无爱亦无福祀。无有善作及以恶作无作。增长诸业果报。菩萨摩诃萨作如是念。我为贪欲之所惑乱。长夜流转。造作种种恶不善业。由此不善恶业力故。感得秽恶自体报果。生鬼国中乏资生具。无有一切最胜福田。又我曾生饿鬼趣中。恒食炭火经无量岁。又于众多百千岁中。不闻水名况复身触。又作是念。而我今者值遇如是最胜福田。又感善身果报成就多资生具。我当依诸福田广修善业。不顾身命承事师长。邬波柁耶阿遮利耶。为欲勤求大菩萨藏微妙法门故。于说法师奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第三发心。尔时世尊。欲重宣此义。而说颂曰

  如是善知识　　常亲近敬奉
  便成如是性　　故应数亲近
  为恶友拘执　　远离贤善友
  懈怠鄙精进　　悭嫉多谄曲
  无施等邪见　　非拨于一切
  我曾生鬼趣　　受弊恶形质
  于生死长夜　　可畏大闇中
  饥渴遍煎恼　　多受于众苦
  于多百千岁　　曾不闻水名
  不见净福田　　不得无是难
  我今感于此　　难得之世间
  又奉值贤明　　获无难具足
  复离恶知识　　得逢贤善友
  誓不顾身命　　当为证菩提
  以清净善心　　恭侍尊师长
  亦当供诸佛　　为证菩提故

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是第三心已。为欲勤求大菩萨藏微妙法门故。于说法师倍复奉敬。勤加供养。乃至施及贮水之器。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我于长夜远离善友。恶友拘执懈怠懒惰。下劣精进无智愚痴。由如是见由如是忍。谓有众生受诸苦恼。如是悲泣号哭之时。复以身手妄加捶打种种恼害。以此因缘。便生如是无量恶见。谓无恶业无恶业报。复由嗔恚覆蔽心故。造作种种恶不善业。以是业报得秽恶身。生畜生中乏资生具。无有一切最胜福田。菩萨摩诃萨。作如是念。我于彼趣。或作馲驼。及牛驴等。食啖刍草。加诸杖捶诃喝恐怖。情所不乐强令驮负。复作是念。我于往昔虽经此苦。曾不值遇如是福田。我今得值又复善感如此之身。我当依诸福田不顾身命。以不坚身贸易坚身。供事师长。为欲勤求大菩萨藏微妙法门故。于说法师奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第四发心。尔时世尊。欲重宣此义。而说颂曰

  我于彼长夜　　未知登圣道
  堕在驼牛驴　　多受诸勤苦
  我今得人身　　当修贤善业
  由此证菩提　　是为聪慧相
  我当起恭敬　　建立诸佛法
  奉觐说法师　　为得菩提故
  过去难思劫　　循环生死轮
  往来非义利　　无福田养命
  远离善知识　　常亲近恶友
  随彼教诲转　　数堕诸恶处
  我曾于傍生　　闭缚驱打骂
  由斯恶业故　　受不爱苦果
  遂堕于恶处　　作馲驼牛驴
  负重犹加杖　　不亲善友故
  我今得难得　　人身及善友
  既蒙生善处　　又得值无难
  如龟久处海　　欣遇浮木孔
  身语善防护　　精进心强盛
  无谄事善友　　长养慧命身
  若有尊重师　　发我慧心者
  能宣说胜妙　　菩提道大师
  供养两足尊　　诸涂香末香
  种种衣花鬘　　我当承敬奉
  现在十方佛　　胜义常开示
  无边金色日　　当修行供养
  遍游诸佛土　　广供调御师
  为净菩提道　　当升大觉座

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是等第四心已。为欲勤求大菩萨藏微妙法门故。于说法师倍增奉事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我昔长夜远离善友。恶友拘执。懈怠懒惰。下劣精进。无智愚痴。由兴恶见。如是信忍。如是欲乐。妄作是念。若以一切有情一切众生。或取身肉同煮一镬。或取其身同剉为脍。虽作如是不名非福。又兴恶见。不由此故而招于恶。不由此故而生于恶。由妄见故。又于大海此岸所有众生。一切布施悉令充足。虽作如是不名非罪。妄生异计。不因此故而招于福。不因此故而生于福。以妄见故。又于大海彼岸所有众生。一切斩害。亦不因此而招于恶。又不因此而生于恶。菩萨摩诃萨。作如是念。我于往昔如是作已。不能了知是罪非罪。是福非福。习近恶见。愚痴所蔽。多造不善诸重恶业。由此业报。感得下弊秽恶地狱之身。于地狱中或啖铁丸。或以锯解。受于种种坚硬苦味。纯苦无间相续不已。乃至经彼多百千岁。尚不闻乐声。何况身触。尔时菩萨复作是念。我于往昔虽经此苦。曾不值遇如是福田。我今得值。又复善感如是之身。我当依诸福田长养慧命。以不坚身贸易坚身。不顾身命奉事师长。为欲勤求大菩萨藏微妙法门故。于说法师奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第五发心。尔时世尊。欲重宣此义。而说颂曰

  我曾亲恶友　　为恶心欺诳
  依止众恶见　　徒兴造恶业
  尽大海此岸　　所住诸众生
  施饮食充满　　谓不招生福
  尽大海彼岸　　所住诸众生
  我悉加杀害　　谓非招恶业
  如是诸恶见　　数习恒亲近
  堕极苦地狱　　厌榨于身首
  昔于三恶趣　　徒尽百千身
  未曾见诸佛　　世间之导首
  世善友名称　　其声尚难闻
  我幸人中利　　当修贤善业
  得人身甚难　　既得长命难
  正法闻难会　　诸佛出世难
  我已得人身　　感兹危脆命
  逢值佛兴世　　预如来正教
  我不复当行　　身语心恶业
  勿令我未来　　受不爱苦果
  我以清净心　　当修清净业
  由身语及意　　行世所难行
  我终不违师　　众人所许教
  又当兴供养　　为佛菩提故
  以我不谄诳　　及无幻伪心
  当开修直路　　为佛菩提道
  无畏大菩萨　　已发如是心
  奉施贮水器　　慧方便具足

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是第五心已。为欲勤求大菩萨藏微妙法门故。于说法师倍增奉事。勤加供养。乃至施及贮水之器。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我于长夜远离善友。恶友拘执。懈怠懒惰。下劣精进。无智愚痴。由是恶见。如是信忍。如是欲乐。妄生是念。拨无迎逆。曲躬跪拜。合掌问讯。诸善业报为慢所蔽。多造恶业。由恶业报。在人趣中感鄙秽形。于诸福田。未曾长养清净慧命。菩萨摩诃萨。作如是念。我忆往昔。受于孤露贫穷下贱。系属于他奴婢等类。又受耽嗜色欲有情众生。贪着一切诸色欲相。住不平等恶行之数。起于种种诸恶邪见。毁坏尸罗。毁坏正见。安住三种不善根中。安住四种不应行处。为五种盖之所覆荫。于六尊重不怀恭敬。于七种法未能随转。八邪性中邪决定行。九恼害事之所恼害。十恶业道常登游践。地狱因道常面现前。于天因道背而不面。远离一切诸善知识。为诸恶友之所执持。随逐魔怨自在而行。远诸善法现行一切不善之法。又为如是。横加鞭杖诃喝恐怖。情所不忍。强抑驱役供给于他。菩萨摩诃萨。又作是念。我昔未值如是福田。故受诸恶。我今得值。又复善感如来之身。我当依诸福田。以不坚身易于坚身。又当自养慧命。不顾身命奉事师长。为欲勤求大菩萨藏微妙法门故。于说法师奉事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第六发心。尔时世尊。欲重宣此义。而说颂曰

  亲近恶友增憍慢　　经于无量多劫海
  人趣受生奴婢身　　于诸有流长夜转
  我今已得于难得　　第一勇猛善人身
  又得生于妙国土　　值佛清净无诸难
  诸有贤善最胜友　　能宣菩萨行道者
  心宝增长诸菩萨　　多拘胝劫今乃值
  无常无恒虚薄身　　譬如水泡并聚沫
  又似幻事及戏变　　如梦所见寱言等
  命如云电不久住　　于世念念将消灭
  是命将逝刹那间　　故以不坚易坚命
  我忆往昔多时中　　堕在慢山深险处
  曾于过去被欺诳　　经不思议百劫海
  我今尽舍身贪爱　　又无顾恋寿命心
  当速舍离憍高慢　　于尊重师深敬奉
  又世所共同尊长　　所谓父母诸兄等
  当速舍离憍高慢　　第一崇遵极恭仰
  近妙菩提诸菩萨　　与我同奉菩提行
  应生坚固爱敬心　　当乐供养专承事
  昔具重慢慢增长　　不知调御断慢法
  当以无上智金刚　　令憍慢山永摧碎
  菩提妙行圆成已　　安止最胜菩提座
  摧伏斗诤魔军众　　当度四流群生等
  十方所有诸患人　　卧自粪中为众厌
  于彼兴发慈悲意　　为作拔济所归趣
  安住大施波罗蜜　　于佛威德能防护
  具足修成于忍行　　发起正勤令现前
  得具净虑波罗蜜　　此时调伏心令住
  安住大慧善方便　　当为一切尊福田
  增长盛福力如是　　不可思议善智慧
  若得第一自在智　　乃至应时奉水器

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是第六心已。为欲勤求大菩萨藏微妙法门故。于说法师倍复承事。勤加供养。乃至施及贮水之器。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我于长夜远离善友。恶友拘执。懈怠懒惰。下劣精进。无智愚痴。由是恶见。如是信忍。如是欲乐。妄生是念。谓无黑业无黑业报。无有白业无白业报。无黑白业无黑白报。无非黑白业无非黑白报。又不请问沙门婆罗门。何者为善。何者不善。何者有罪。何者无罪。何者应修。何者不修。何者应作。何者不应作。又不请问修何等行。于长夜中能感无义无利。及诸苦恼。又作何行。于长夜中能感有义有利。及诸安乐。菩萨摩诃萨。作如是念。我于往昔。由于此慢及以胜慢所障蔽故。而能多造不善恶业。以此业报感得人身。诸根缺减。于胜福田未养慧命。虽处人中等作覆器。童蒙嬉戏愚戆聋盲。于善恶义无力无能。了达宣畅。又作是念。我昔未遇是胜福田。故造诸恶。我今值遇。又复善感具诸根身。我当依诸福田增长慧命。又应不顾身命求诸力。能了达善说恶说之义。又当请问于说法师。何者为善。何者不善。何者有罪。何者无罪。何者应修。何者不应修。何者应作。何者不应作。作何等行。令彼声闻及独觉法。而现在前。作何等行。令诸佛法及菩萨法。而现在前。舍利子。菩萨摩诃萨。为欲勤求菩萨藏故。依尸罗波罗蜜多。行菩萨行。以不坚身易于坚身。于说法师承事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第七发心。尔时世尊。欲重宣此义。而说颂曰

  于昔过去多百劫　　远离益我亲善友
  未曾请问善不善　　有罪无罪诸业果
  由增上慢自在力　　堕于地狱鬼趣中
  习近恶念为同侣　　经多百劫坠恶道
  或习人趣多千劫　　轮回受身根不具
  不知何善何不善　　有罪无罪作业果
  我获人道猛健身　　具足诸根处清净
  远离诸难得无难　　如龟引颈遇浮孔
  值世作明灯照者　　闻说离欲诸圣教
  时我请问世间尊　　善与不善等业果
  云何具悭堕诸趣　　云何无悭为施主
  云何贪谄污尸罗　　云何戒财全守护
  云何忿恚愤乱人　　云何无忿忍辱力
  云何懈怠散乱心　　云何精勤乐静虑
  云何恶慧哑愚痴　　云何有慧乐真实
  云何专意行菩提　　具足寻求贤圣行
  云何流慈遍世间　　云何拔济诸恶趣
  云何乐法无厌心　　能求菩提诸行藏
  云何往诣十方刹　　现住诸佛世尊前
  云何致敬修功业　　云何请问普贤行
  我今正应勤请问　　法师尊重等尊重
  云何于师乐敬养　　云何令师意欢悦
  佛子已生如是心　　能集广大妙福力
  及胜自在智慧力　　欢喜奉施至水器

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发如是第七心已。为欲勤求大菩萨藏微妙法门故。于说法师倍复奉事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。我于长夜远离善友。恶友拘执。懈怠懒惰。下劣精进。痴钝无识犹如哑羊。舍离一切正义相应文句。正法相应文句。寂静相应文句。灭止相应文句。正觉相应文句。诸沙门婆罗门。般涅槃等相应文句。舍离如是诸文句已。反更受持读诵思寻。究达一切非义相应文句。非法相应文句。乃至非涅槃等相应文句。由如是故。妄兴是见。谓无有力。无有精进。无丈夫果。无势无勇。无行无威。或俱生念。无有行威。又生是念。无因无缘。可令有情而生染污。不由因缘有情杂染。又生是念。无因无缘。可令有情而得清净。不由因缘有情清净。菩萨摩诃萨。又作是念。我于长夜。由依如是不平等因。无因见故。多造种种恶不善业。由此业报。我于往昔在人趣身。诸相不具。于诸福田未长慧命。虽处人中等于覆器。童蒙嬉戏。愚蠢聋盲。无力无能。受持读诵思惟究达。正义相应文句。乃至涅槃相应文句。又作是念。我昔未遇是胜福田。故生妄见。我今值遇。乃至不顾身命。为求力能。当于正义相应文句。正法相应文句。寂静相应文句。乃至涅槃相应文句。如是等正法文句。皆是大菩萨藏微妙法门之所摄者。我今受持读诵思惟究竟。必当发起最上正勤。尽命承事于说法师。我今依尸罗波罗蜜多。行菩萨行。为欲于此菩萨藏法。能受能持能读能诵修行供养故。又作是念。我当以不坚身易于坚身。当善造集若福若智二种资粮。由是二力。常恒亲近菩萨藏法。菩萨摩诃萨如是思已。于说法师承事供养。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第八发心。尔时世尊。欲重宣此义。而说颂曰

  若法真实义相应　　随顺修习道支道
  为于寂灭而作证　　而能流通涅槃路
  我昔远离如是法　　反更流习于诸恶
  非法非义非寂静　　乃至涅槃不相应
  无有精进亦无力　　无丈夫果无威势
  拨无诸行无勇猛　　一切尽空无所得
  无有诸佛亦无法　　及无世间之父母
  无有黑法与白法　　若果若报悉皆无
  于如是等诸恶见　　无始世来恒习行
  由斯堕于地狱中　　纯受极苦久难出
  如是转受傍生趣　　及堕焰魔恶世间
  或时得生人趣中　　愚騃无智而喑哑
  童蒙嬉戏与盲聋　　闇钝顽嚚无智识
  从是复堕于地狱　　受诸重苦增愚暗
  我从久远无量劫　　未曾得是清净身
  已遇诸根皆具足　　是时宜速加精进
  诸法真实义相应　　能为寂静之助伴
  趣菩提道与菩提　　我宜及时求是法
  诸大菩萨秘奥藏　　甚深真实义相应
  经彼百千俱胝劫　　若得闻者为希有
  如是及余诸佛法　　无量无数不思议
  我当精勤受已持　　为证诸佛菩提故
  又当正勤起恭敬　　承事供养说法师
  所谓诸佛诸菩萨　　当于彼闻无上法
  诸无所畏大菩萨　　发起如是勇猛心
  智慧方便善成就　　乃至施及贮水器

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发起如是第八心已。为欲勤求大菩萨藏微妙法门故。于说法师倍增承事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。一切众生为无义行之所拘执。顾恋身命着无义行。不能励意专修义利。舍利子。云何名为着无义行。谓于身命有所顾恋。于觉分法情无希望。计我我所以为前导。恒于其身防卫覆障。沐浴调治庄饰宝护。是则名为着无义行。舍利子。复有着无义行。谓于身命有所顾恋。于觉分法情无希望。计我我所以为前导。而于妻妾。男女兄弟。朋友眷属亲戚。防卫覆障。乃至一切诸受用具。宝玩执着。是则名为着无义行。舍利子。复有着无义行。谓于身命有所顾恋。于觉分法情无希望。计我我所以为前导。而于奴婢僮仆。防卫驱役桎梏守护。是则名为着无义行。舍利子。云何名为专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。专修胜善身业意业。及以语业。是则名为专修义利。舍利子复有专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。专修引发柁那波罗蜜多。乃至般若波罗蜜多。是则名为专修义利。舍利子。复有专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。而专修行布施爱语利益同事。摄化一切诸众生故。是则名为专修义利。舍利子。复有专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。专修念处。正断神足。根力觉分。如是道支。是则名为专修义利。舍利子。复有专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。而于父母及诸师长。专修供养恭敬礼拜。曲躬合掌谦下问讯。迎逆给事并和顺业。是则名为专修义利。舍利子。复有专修义利。谓于身命无所顾恋。于觉分法有所希望。妙菩提心以为前导。于三宝所随顺法教。专修敬事。舍利子。菩萨摩诃萨作如是念。一切众生专著无义。为无义行之所拘执。顾恋身命放逸懈怠。而我今者专修义利。为有义利之所守护。我当勤加精进。以身供事诸说法师。以不坚身易于坚身。当修福智二力资粮。以修福智力资粮故。当近无上微妙菩提。舍利子。菩萨摩诃萨。依尸罗波罗蜜多。行菩萨行。为求如是菩萨藏故。承事供养诸说法师。乃至施及贮水之器。舍利子。是为菩萨摩诃萨第九发心。尔时世尊。欲重宣此义。而说颂曰

  诸愚痴凡夫　　常顾于身命
  不愿求菩提　　起杂染三业
  常为利自身　　及妻子眷属
  宝玩于无义　　是名痴凡夫
  驱役奴仆等　　多畜养四足
  宝着于无义　　是名无智者
  贮积多财谷　　不施不食用
  宝着于无义　　名守藏愚夫
  诸愚痴凡夫　　专宝着无义
  具妙慧菩萨　　精求诸义利
  不顾于身命　　欣乐助菩提
  起种种善业　　是名专义利
  方便善修习　　施戒忍正勤
  静虑与妙慧　　是名专义利
  供养于父母　　给侍诸师长
  深敬奉三宝　　是名专义利
  于摄一切法　　诸菩萨妙藏
  诵持及开阐　　是名专义利
  如是专义利　　诸佛之所赞
  精进善相应　　是胜无畏子
  发如是念已　　以清净信心
  敬养尊重师　　乃至奉水器

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发起如是第九心已。为欲勤求大菩萨藏故。于说法师倍复承事。勤加供养。乃至施及贮水之器

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。发如是心。世间众生邪僻自在。反执师教无所克获。不获何等。所谓圣财。云何圣财。谓信戒闻惭愧舍慧。如是等法是谓圣财。彼诸众生不获此故。名极贫穷。菩萨摩诃萨。又作是念。我今应修妙善自在。于师教诲随顺敬受。所以者何。菩萨摩诃萨。由妙自在。于师教诲随顺敬受。有所证得。何所证得。所谓圣财。何等名为菩萨圣财。谓菩萨藏法门差别。了知菩萨妙善自在。即说法师妙善自在。于菩萨藏法门差别。广为众生宣畅敷演。辩了建立。开阐分别。显示流布。菩萨摩诃萨。安住如是菩萨藏已。获圣法财永断贫穷。速疾证于阿耨多罗三藐三菩提。舍利子。菩萨摩诃萨。依尸罗波罗蜜多。行菩萨行。发是心已妙善自在。于师教诲随顺敬受。复作是念。我当以不坚身贸易坚身。为欲勤求菩萨藏故。承事供养于说法师。乃至施及贮水之器。舍利子。是名菩萨摩诃萨第十发心。尔时世尊。欲重宣此义。而说颂曰

  世间下劣诸众生　　谀谄幻惑多奸伪
  颠倒僻执不如理　　专恶自在违师教
  深知是已顺师诲　　便能分别广敷演
  由斯获得仙圣财　　信戒舍闻惭愧慧
  如是七财无尽藏　　知非器者勿开显
  世间多有善众生　　堪为诸佛净法器
  无谄美言来请问　　妙善自在而闲雅
  常发勇猛勤精进　　恭敬正法乐常闻
  为证诸佛妙菩提　　不顾所爱之身命
  知彼堪任正法器　　复能受持深妙理
  导师发起大慈悲　　为说无杂真法界
  诸大菩萨妙法藏　　依彼建立胜菩提
  又于其中广开示　　诸佛坚固圣财宝
  一切诸法为空相　　亦无相相无我相
  无有寿命无变异　　无诸戏论无受藏
  一切诸法之自性　　不从缘生亦无相
  曾无初起无终灭　　无相真如之所显
  若善自在柔和者　　于师教诲无倒执
  自然最胜为开示　　本境所学解脱门
  净信尸罗与惭愧　　正闻舍施般罗若
  为彼分别广敷显　　无尽七财之法藏
  佛子和柔妙自在　　随顺善友所诲言
  我当承事语法师　　为证无上菩提故
  菩萨适发是心已　　于渴乏者生悲爱
  乃至经营净瓦器　　盛满清水随时施

舍利子。诸菩萨摩诃萨。行尸罗波罗蜜多时。发起如是第十心已。为欲勤求大菩萨藏故。于说法师倍增承事。勤加供养。乃至施及贮水之器

大宝积经卷第四十二大宝积经卷第四十三

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之九尸波罗蜜品第七之二

尔时佛告舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是善根力故。获得四种广胜处法。何等为四。一者于诸善法速能趣入。二者为说法师之所赞美。三者修行成满无有毁犯。四者于佛正法坚持不坏。舍利子。是为菩萨摩诃萨获得四种广胜处法。又舍利子。菩萨摩诃萨。由是力故处在人中。复获四种广胜处法。何等为四。一者为多众生随逐修学。于诸白法究竟安住。二者于夷坦路营建逆旅极当坚密。速令众生获得欢喜。三者于长夜中得法利故。欢泰之心无有退减。四者临终舍命无惑缠心。往生善趣安乐世界。舍利子。是为菩萨摩诃萨处在人中。获得四种广胜处法。又舍利子。菩萨摩诃萨。由是力故处在天中。复获四种广胜处法。何等为四。一者以福感故能摄天众。二者诸天集会瞻仰面门。菩萨今者将何所演。我等闻已当有开悟。三者为天帝释及余天子之所参觐。请法断疑。而是菩萨不往其所。四者现大宫殿。为于菩萨之所受用。舍利子。是为菩萨摩诃萨处在天中。获得四种广胜处法。舍利子。如是菩萨摩诃萨。行尸罗波罗蜜多时。若在天上若生人中。复得无量无边。百千万亿诸妙法门。皆为满足尸罗波罗蜜多故。尔时世尊。欲重宣此义。而说颂曰

  菩萨处高座　　诸天所礼敬
  瞻仰彼尊颜　　将宣何等法
  一切皆恭敬　　具慧除悭吝
  处欢喜宫殿　　释天来请疑
  天中命尽已　　来生于人间
  为转轮圣王　　大力无悭吝
  若人中命终　　还复生天上
  曾未更众苦　　奉养法师故
  恒获如是等　　四种广胜处
  为无下劣心　　恭敬说法者
  若以敬爱心　　奉施于水器
  则天龙及人　　所应亲供养

复次舍利子。是诸菩萨摩诃萨行。尸罗波罗蜜多时。成就如是诸善根故。复于天中得四种法。何等为四。一者了知先世所经造业。二者了知因此善故来生天上。及能了知退失善法。三者了知从此命终当生某处。四者为诸天众宣说妙法示教赞喜。既利益已便舍天身。舍利子。是为菩萨摩诃萨生在天中得四种法。皆由尸罗波罗蜜多故

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是诸善根故。复得四种圆成胜法。舍利子。何等为四。一者菩萨摩诃萨舍天宫已。还来人趣与戒俱生。二者菩萨摩诃萨处在人中。获得五种成胜生法。云何为五。所谓得生胜家。得胜妙色。得胜净戒。得胜眷属。于诸众生得修胜慈。如是名为获得五种成胜生法。三者菩萨摩诃萨处在人中。复得五种成不坏法。云何为五。所谓得善知识不可破坏。所受之身终无中夭。所得财位中无退失。得菩提心无能坏者。于匮法时得自丰足。如是名为获得五种成不坏法。四者菩萨摩诃萨处在人中。又复获得五种希有圆满之法。云何为五。菩萨摩诃萨。于舍宅中安设空器。随菩萨手所及之处。一切众宝即皆盈满。是名第一获得希有圆满之法。菩萨摩诃萨。若遇渴时。即于其前具八德池。自然涌现。是名第二获得希有圆满之法。菩萨摩诃萨。福德持身不为外物之所侵害。所谓若毒若刀。若火若水。吸精气者。或复药叉及诸恶鬼。不能损害。是名第三获得希有圆满之法。菩萨摩诃萨。于赡部洲诸灾劫起。所谓若刀兵劫。若饥馑劫。若疾病劫。若火劫。若水劫。若风劫。若渴劫。若热光劫。若药叉劫。舍利子。如是别劫兴起之时。尔时菩萨不生其中。便处天上受极快乐。受多极乐。是名第四获得希有圆满之法。菩萨摩诃萨。即以如是善根力故。永不复生诸难之处。不生恶趣。若悔缠心。即能见知速疾远离。是名第五获得希有圆满之法。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多故。又复获得四种希有圆成胜法

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是善根力故。常不远离四种妙法。云何为四。一者菩萨摩诃萨。但见有苦诸众生时。即便获得大悲之心。二者菩萨摩诃萨所有男女。皆于菩萨恭敬随顺。三者菩萨摩诃萨。能制衰老不为所侵。四者菩萨摩诃萨。资生作业百倍获利。或复过此二倍三倍。舍利子。是为菩萨摩诃萨。行尸罗波罗蜜多时。成就如是四种妙法。恒无远离

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是诸善根故。不为三法之所劫夺。何等为三。一者不为贪欲之所劫夺。二者不为嗔恚之所劫夺。三者不为愚痴之所劫夺。舍利子。是为菩萨摩诃萨。行尸罗波罗蜜多故。远离三种劫夺之法

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是诸善根故。获得四种无病之法。何等为四。一者菩萨摩诃萨。不为长病之所缠逼。二者菩萨摩诃萨。支体鲜泽未曾羸瘁。三者菩萨摩诃萨。资生众具无有损减。四者菩萨摩诃萨。不为国王盗贼恶人。及余众生所加恼害。舍利子。是为菩萨摩诃萨。行尸罗波罗蜜多故。获得四种成无病法

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是诸善根故。获得四种尊位之相。何等为四。一者菩萨摩诃萨。为转轮王威加四域。以法御世名为法王。七宝来应皆悉成就。何等为七。所谓轮宝。象宝。马宝。女宝。末尼珠宝。主家藏宝。主兵臣宝。千子满足形貌端严。威势雄猛降伏怨敌。是转轮王为四大洲之所朝宗钦仰归化。又为宰相群臣守卫。众会国界人民。及诸小王共所遵敬。舍利子。是为菩萨摩诃萨。获得第一尊位之相。又舍利子。菩萨摩诃萨。于妙五欲不染乐着。所谓眼所识色。耳所识声。鼻所识香。舌所识味。身所识触。菩萨摩诃萨。于是五欲不染着故。以净信心舍家入道。速获五通。人及非人之所恭敬。舍利子。是为菩萨摩诃萨。获得第二尊位之相。舍利子。菩萨摩诃萨在所生处。自然常得最上觉。最上慧。最上辩。为诸大王之所尊敬。如过去世大乌末荼。为王敬重。而是菩萨亦复如是。为王敬重请升御座。又为宰相群臣守卫。众会国界人民。所共尊仰。舍利子。是为菩萨摩诃萨。获得第三尊位之相。又舍利子。菩萨摩诃萨。既悟阿耨多罗三藐三菩提已。威德殊胜圆满第一。为诸天龙药叉健达缚阿素洛揭路荼紧捺洛牟呼洛伽人非人等。一切有情同所归敬。何以故。由是菩萨成就最胜戒定慧品。解脱解脱智见品。于此法中证得清净故。舍利子。是为菩萨摩诃萨。获得第四尊位之相。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多时。获得四种尊位之相。皆为成满尸罗波罗蜜多故

复次舍利子。如是菩萨摩诃萨。行尸罗波罗蜜多时。具清净心以贮水器。奉施邬波柁耶。及阿遮利耶二尊师故。获得如是无量无边功德妙法。所谓菩萨摩诃萨为求法故。去来进止随顺于师。如其所言终不违逆。成就如是善根力故。复获四种最胜资财。何等为四。一者菩萨摩诃萨。所生之处。获得大王所用资财。非余众生下劣资具。二者菩萨摩诃萨。所生之处。受离欲法获得仙财。以净信心舍家入道。名圣法财。三者菩萨摩诃萨。所生之处得宿命念。名获念财。由此念故。生生之处。终不忘失菩提之心。四者菩萨摩诃萨。证得阿耨多罗三藐三菩提已。名菩提财常为四众天龙药叉健达缚阿素洛揭路荼紧捺洛牟呼洛伽人非人等。前后围绕。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多故。证得四种最胜资财

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。于说法师。乃至受持四句颂等。去来进止随顺教命。所谓是善是不善。是有罪是无罪。是应修是不应修。又如是教。乃至作此事已。于长夜中。能感无义无利。诸苦恼法。若作此已。于长夜中。能感有义有利。诸安乐法。如是等教随师所命。不作不善修习善法。无违无逆。由是菩萨摩诃萨。成就如是善根力故。复获四种成高胜法。何等为四。一者菩萨摩诃萨。得具尸罗成高胜法。二者菩萨摩诃萨。所感形体一切身分悉皆圆满。三者菩萨摩诃萨。获得大慧。涌慧高慧。广慧捷慧。利慧速慧。深慧决择之慧。四者菩萨摩诃萨。身坏命终生于善趣诸天世界。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多时。获得四种成高胜法。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是善根力故。又获四种无能观法。何等为四。舍利子。菩萨摩诃萨。成就如是善根力故。所在生处感得隐密阴藏之相。是名第一无能观法。舍利子。菩萨摩诃萨。成就如是善根力故。从初生已。若母若父。若余眷属。若天若龙药叉罗刹健达缚阿素洛揭路荼紧捺洛牟呼洛伽人非人等。所有众生若清净心。若杂染心。皆不能见菩萨之顶。是名第二无能观法。舍利子。菩萨摩诃萨。成就如是善根力故。从初生已。若母若父。乃至人非人等。所有众生若清净心。若杂染心。于菩萨面无能修饰。瞻睹之者若有起心。我当瞻饰菩萨面者。便于两足而现面像。何以故。舍利子。以是菩萨摩诃萨。成就如是希奇法故。名善丈夫。又复成就最胜丈夫第一诃辩。是名第三无能观法。舍利子。菩萨摩诃萨。成就如是善根力故。初生之时无人扶侍。自立于地遍观四方。即便获得明利之智。何以故。由是菩萨摩诃萨。于过去世以无谄心。求闻法故。而是菩萨摩诃萨。又复获得无邪谄眼。由成就是无谄眼故。以净天眼超胜于人。乃至能观三千大千世界所有众生。又此菩萨摩诃萨。获得速疾广大之智。由成就是广大智故。而能了知一切众生。于三时中所积集心。何以故。由是菩萨摩诃萨。于彼往昔求法之时。作意摄心勤加恭敬。于正法所起良药想。起珍宝想。起难遭想。起妙善想。如其所念求闻正法。闻已受持。菩萨摩诃萨又因是故。复获捷疾简择之智。由成就是简择智故。善能称量诸众生戒。乃至善能称量正闻。定慧解脱解脱智见。又菩萨摩诃萨。善能称量一切众生尸罗同性。乃至善能称量正闻定慧。解脱解脱智见同性。又菩萨摩诃萨。善能称量一切众生戒之等流。乃至善能称量正闻定慧。解脱解脱智见等流。又菩萨摩诃萨。善能称量一切众生。尸罗等流超胜之相。乃至善能称量正闻定慧。解脱解脱智见等流。超胜之相。又菩萨摩诃萨。善能称量一切众生进止威仪。修行正行勇猛之相。舍利子。菩萨摩诃萨。如是展转称量思惟。一切众生诸功德已。而作是念。是诸众生所有戒闻。乃至解脱解脱智见。是诸众生所有尸罗同性。乃至正闻定慧。解脱解脱智见同性。是诸众生所有尸罗等流。乃至正闻定慧。解脱解脱智见等流。是诸众生所有尸罗等流。超胜之相。乃至正闻定慧。解脱解脱智见等流。超胜之相。是诸众生所有进止威仪。修行正行勇猛之相。如是等相。皆是众生所有功德。我今于中称量观察。不见与己有平等者。尔时菩萨又更思惟。一切众生根本坚住。与己校量。不见一切与我等者。又舍利子。菩萨摩诃萨初生之时。于刹那顷。能速发起业报妙智。由此智故。一弹指顷善能了知。一切众生千种心相。是时菩萨摩诃萨。以智寻思此一切心。不见与己有平等者。菩萨摩诃萨如是正知。我今独处最上尊位。如师子王安住无畏。如大龙王有大威德。足不践地各行七步。念菩提座微妙业报。住在现前唱如是言。我于世间最为尊大。我于世间最为殊胜。我今当证生老死边。我当度脱一切众生生老病死忧悲苦恼。我当为诸众生宣说广大微妙最胜无上正法。舍利子。菩萨摩诃萨发是语时。中无有间。其声遍告。满此三千大千佛之世界。其中众生闻是声已。惊怖毛竖天鼓战掉数发大声。而此世界皆悉震动。唯有菩萨所住之地。如车轮许嶷然安静。即此地轮下依水聚。亦不为彼大风摇动。是菩萨摩诃萨自观己身。见无量光遍身而住。即证阿耨多罗三藐三菩提已。为诸众生所共瞻仰。是名第四无能观法。舍利子。是名菩萨摩诃萨获得四种无能观法。何以故。皆是菩萨摩诃萨。于过去世。行尸罗波罗蜜多时。随顺法师去来进止。遵承教命无违逆故。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。成就如是诸善根已。复获四种迅速之法。何等为四。菩萨摩诃萨成佛之时。具足如是诸佛如来所说之法。无有缺减。又所说法言无虚设。是名第一迅速之法。菩萨摩诃萨成佛之时。具足如是。诸佛如来若有所命。作如是言。进来苾刍。尔时众生便进佛所。发自断落。被服袈裟。持钵多罗。是名第二迅速之法。菩萨摩诃萨成佛之时。具足如是。诸佛如来善知众生三时之心。是名第三迅速之法。菩萨摩诃萨成佛之时。具足如是。诸佛如来善知众生应病药智。是名第四迅速之法。舍利子。是名菩萨摩诃萨。获得四种迅速之法。何以故。由于往昔行尸罗波罗蜜多时。以清净心奉施邬波柁耶。及阿遮利耶。诸说法师之水器故。复次舍利子。菩萨摩诃萨。依尸罗波罗蜜多。具足如是善根力故。成佛之时。复得四种他不害法。何等为四。舍利子。如来身者无依无受。何以故如来之身。若为火刀毒药他物。能损害者无有是处。舍利子。是为菩萨摩诃萨成佛之时。具尸罗故。获得四种无损害法

复次舍利子。菩萨摩诃萨。依尸罗波罗蜜多。由具如是善根力故。成佛之时。复得四种他无过法。何等为四。一者诸佛如来无依无受。所以者何。无有众生于如来前能发是言。我为如来说未闻法。乃至一句。若能说者无有是处。二者诸佛如来无依无受。所以者何。无有众生于如来前如法立论。乃至一句。若立论者无有是处。三者诸佛如来无依无受。所以者何。无众生能得如来。乃至微分一不定心。若能得者无有是处。何以故。舍利子。诸佛如来心恒在定。谓住慈悲喜舍等故。四者诸佛如来无依无受。所以者何。无有众生能取如来身色诸相。若取相者无有是处。舍利子。诸佛如来具尸罗故。获得四种他无过法

复次舍利子。诸佛如来成就如是善根力故。获得具足五无量法。何等为五。一者诸佛如来尸罗无量。二者诸佛如来正闻无量。三者诸佛如来正定无量。四者诸佛如来正慧无量。五者诸佛如来解脱解脱智见无量。舍利子。如是如来五无量法。皆由往昔行尸罗波罗蜜多时。于邬波柁耶。阿遮利耶诸尊重所。随顺师教。去来进止无违逆故

复次舍利子。诸佛如来。具足尸罗波罗蜜多已。成就如是善根力故。获得四种无障碍智。何等为四。所谓诸佛世尊。于过去世。无障无碍智见转。诸佛世尊。于未来世。无障无碍智见转。诸佛世尊。于现在世。无障无碍智见转。诸佛世尊。善能发起平等之心。由起如是平等心故。能知三世平等之性。舍利子。是为如来具尸罗故。获得四种无障碍智

复次舍利子。诸佛如来。又复善能成就正智。由正智故不依属他。而能悉知一切诸法。诸佛如来。又能成就不思议智。由成就此不思议智故。而能了知诸风雨相。舍利子。如来善知世有大风。名乌卢博迦。乃至众生诸有觉受。皆由此风所摇动故。此风轮量高。三拘卢舍。于此风上虚空之中。复有风起。名曰云风。此风轮量高。五拘卢舍。于此风上虚空之中。复有风起。名瞻薄迦。此风轮量高。十踰缮那。于此风上虚空之中。复有风起。名吠索缚迦。此风轮量高。三十踰缮那。又此风上虚空之中。复有风起。名曰去来。此风轮量高。四十踰缮那。如是舍利子。次第转上。六万八千拘胝风轮之相。如来应正等觉。依止大慧悉能了知。舍利子。最上风轮名为周遍。上界水轮之所依止。其水高量。六十八百千踰缮那。为彼大地之所依止。其地量高。六十八千踰缮那。舍利子。是地量表。有一三千大千世界。其中有佛。号曰弘蕴如来应正等觉。今现在彼住世施化。其佛寿量。三十拘胝岁。声闻弟子。有三十拘胝那庾多。一切皆是大阿罗汉。诸漏已尽无复烦恼。乃至证得诸心自在。最上波罗蜜。尔时彼佛与如是等大声闻众同共集会。复有百拘胝等。菩萨摩诃萨。皆悉证得菩萨藏法。于诸义理妙善决定。为多闻海为大法师。住空无相及以无愿。舍利子。我涅槃后具满千岁。彼佛方乃入般涅槃。正法住世满于千岁。流布舍利遍益世间。亦如我今般涅槃后。舍利流布遍益之相。舍利子。如来无障碍智。又能了知过于彼佛世界之上。无量无边风轮圆相。并诸佛土具足圆相。舍利子。又过此上有别世界。现无如来。而有百千独觉所住。其中众生。皆于独觉而种善根。舍利子。如来依彼智故。复能了知此世界上。有殑伽沙等诸佛如来。出兴于世。今现在彼度诸众生。如是十方无量无数。不可思议。不可称量。诸佛如来应正等觉出兴于世。今现在彼度诸众生。如来妙智悉能了知。舍利子。如来又能了知如上所说。诸佛世界现烧然等。成坏之相无量无边。如来妙智皆悉明了

尔时世尊说是语已。长老舍利子白佛言。世尊。如来应正等觉。成就何等诸善根故。而能获得如是无量不可思议无障碍智。佛告舍利子。如来由住尸罗波罗蜜多故。妙善自在。于正法所。发起恭敬尊重之想。起良药想。起珍宝想。起难遭想。起善根想。如所应想生深敬想。又能安住摄正法想。舍利子。如来由住尸罗波罗蜜多。敬重法故。获得如是明利大智。如是大智又能了知。无量无数过于前量。舍利子。诸佛世尊无断之智。无量无数。不可思议。不可称量。不可宣说往来之相。舍利子。诸佛如来具尸罗故。复得如是自在之力。是故如来如弹指顷。往殑伽沙等诸佛世界。而复旋返还本住处。舍利子。诸佛如来。于是正法尸罗波罗蜜多。所以净信解听闻受持。由此获得速疾解脱。由此解脱我善解脱。于何法中而得解脱。谓于诸苦善得解脱

复次舍利子。若有菩萨摩诃萨。于此四种恭敬住处。闻斯法已得清净信。行尸罗波罗蜜多故。发如是心。我如是住我于此住。由我如是常安住故。我常不离诸佛正法。舍利子。菩萨摩诃萨。受持是经法门章句。彼由如是善根力故。复获四种慧所成法。何等为四。一者由具慧故。能发大慧。二者由具慧故。逢值诸佛亲觐承事。三者由具慧故。以净信心舍家入道。四者由具慧故。速证阿耨多罗三藐三菩提。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多时。获得四种慧所作法

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。由成就是善根力故。又获四种多所作法。何等为四。一者受得人身。名多所作。二者值佛出世。名多所作。三者以净信心舍家入道。名多所作。四者速证阿耨多罗三藐三菩提。名多所作。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多时。获得四种多所作法。复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。由成就是善根力故。复获四种支分之法。何等为四。一者菩萨摩诃萨获转轮支。谓处人中作转轮王。二者菩萨摩诃萨。处于梵世为大梵王。三者菩萨摩诃萨。处诸天众而为天帝。四者菩萨摩诃萨。证得阿耨多罗三藐三菩提已。于一切法具足圆满。号为法王处世垂化。又复获得吉祥诸力净众生智神通境界。如是诸相皆能了知。为诸世间天人之眼。尔时世尊。欲重宣此义。而说颂曰

  救世之明眼　　诸群生最上
  善解诸医法　　由斯证寂灭
  往返随师教　　感报为如是
  未曾受众苦　　及不善自在
  速往生天上　　速还返人中
  速奉见诸佛　　速得离诸难
  巨富丰大财　　目观诸伏藏
  随手之所及　　众宝皆盈满
  化现妙池沼　　八德水常盈
  未曾受忧恼　　为善自在果
  手足不缭戾　　又无丑短相
  支体不干枯　　亦复不减少
  不伛不缺目　　指相无增减
  首异于象顶　　为善自在果
  仪貌皆圆满　　质重如金聚
  端严众乐观　　容相皆鲜妙
  诸天龙鬼神　　及以世人等
  供养而尊敬　　为妙自在德
  远离诸恶道　　往人天善趣
  速悟大菩提　　为善自在果
  若人悉能了　　一切众生心
  各行七步已　　妙音告世界
  斯人智最上　　斯人慧最上
  解脱亦最上　　众生中最上
  慧令慧清净　　慧依智安立
  慧智与解脱　　皆依诸佛证
  由慧自性生　　所知由智了
  若有具智慧　　所求无不遂
  如是甚深义　　我为汝略说
  无慧少欲人　　宁当受此义
  彼由痴所痴　　众恶所逼迫
  发起于忿恚　　不恭敬正法
  若少欲众生　　于如是正法
  不复兴恭敬　　更起诸余事
  不敬法众生　　忿恚所迷执
  常怀染污心　　不应为宣说
  诸老熟所及　　衰迈摩诃罗
  彼临命终时　　虚言住后有
  诸老熟所及　　衰迈摩诃罗
  妄吞罗汉供　　速堕于地狱
  具戒尚难得　　况阿罗汉果
  信者营灵庙　　复由沉恶趣

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。如是精勤修行戒行。为求菩萨藏故。以身承事正行诸师。获得如上所说功德。又复获得倍过前数无量无边不可思议功德利益。舍利子。当知菩萨摩诃萨。安住如是菩萨藏故。行善自在妙清净戒诸菩萨行。舍利子。云何名为妙戒清净。舍利子。菩萨摩诃萨。行尸罗波罗蜜多故。获得十种清净尸罗。汝应知之。何等为十。一者于诸众生曾无损害。二者于他财物不行劫盗。三者于他妻妾远诸染习。四者于诸众生不兴欺诳。五者和合眷属无有乖离。六者于诸众生不起粗言。由能堪忍彼恶言故。七者远离绮语。凡有所言谛审说故。八者远离贪着。于他受用无我所故。九者远离嗔恚。善能忍受粗言辱故。十者远离邪见。由不敬事诸余天仙及神鬼故。舍利子。是为菩萨摩诃萨行尸罗波罗蜜多时获得十种清净尸罗。当如是学

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。复有十种清净尸罗。汝今当知。何等为十。一者不缺尸罗。不由无智之所证故。二者不穿尸罗。不平等生所远离故。三者不斑尸罗。一切烦恼所不杂故。四者不染尸罗。唯为白法所增长故。五者应供尸罗。随其所欲自在行故。六者称赞尸罗。诸聪慧者不诃毁故。七者不呰尸罗。一切过恶不容受故。八者善护尸罗。善能守护诸根门故。九者善守尸罗。自然正智恒现前故。十者善趣尸罗。大菩提愿为助伴故。舍利子。是为菩萨摩诃萨行尸罗波罗蜜多时获得十种清净尸罗。当如是学

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多故。复有十种清净尸罗。汝今当知。云何为十。一者少欲尸罗。如法清净善知量故。二者知足尸罗。永断一切诸贪着故。三者正行尸罗。能令身心皆远离故。四者住静尸罗。于诸愦闹皆舍远故。五者杜多功德蠲除嗜欲尸罗。自在善根之所成故。六者圣种知足尸罗。不顾他颜无希望故。七者如说而行尸罗。幽明奉摄不欺人天故。八者自省己过尸罗。常以法镜照了自心故。九者不讥他阙尸罗。将护彼意故。十者成熟众生尸罗。不舍诸摄法故。舍利子。是为菩萨摩诃萨行尸罗波罗蜜多故获得十种清净尸罗。当如是学

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。复有十种清净尸罗。汝今当知。云何为十。一者于佛净信尸罗离心栽枿故。二者于法净信尸罗。守护正法故。三者于僧净信尸罗。恭敬圣众故。四者俯屈从事尸罗。不离思惟佛菩提故。五者亲近善友尸罗。觉分资粮善积集故。六者远离恶友尸罗。弃舍一切不善法故。七者大慈波罗蜜多尸罗。成熟一切诸众生故。八者大悲波罗蜜多尸罗。困厄众生令解脱故。九者大喜波罗蜜多尸罗。于彼正法生喜乐故。十者大舍波罗蜜多尸罗。于诸爱恚两俱舍故。舍利子。是为菩萨摩诃萨行尸罗波罗蜜多故获得十种清净尸罗。当如是学

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。复有十种清净尸罗。汝今当知。何等为十。一者柁那波罗蜜多尸罗。为善成熟诸众生故。二者羼底波罗蜜多尸罗。善护一切众生心故。三者毗利耶波罗蜜多尸罗。于诸正行不退转故。四者静虑波罗蜜多尸罗。静虑资粮善满足故。五者般若波罗蜜多尸罗。听闻根本无厌足故。六者乐求闻法尸罗。常乐请求菩萨藏故。七者不顾惜身尸罗。以无常想恒观察故。八者不宝重命尸罗。以如幻心常现观故。九者诸意满足尸罗。从初发心善清净故。十者佛戒和合尸罗。回向如来一切戒故。舍利子。是为菩萨摩诃萨行尸罗波罗蜜多故获得清净尸罗。当如是学

复次舍利子。是诸菩萨摩诃萨。行尸罗波罗蜜多时。具足如是清净戒故。无有人天诸妙快乐是诸菩萨而不受者。无有世间工巧等处是诸菩萨所不知者。无有世间诸众生等所受用具是诸菩萨不获感者。无有凡夫不互为怨。而是菩萨于彼众生曾无嗔恚。无有世间虚诳妄语菩萨于彼不生信受。无有世间诸众生等菩萨于彼不起母想。无有世间诸众生等菩萨于彼不生父想。无有世间诸众生等菩萨于彼不生保任亲附之想。无有一切有为之法菩萨于彼不起无常生灭之想。舍利子。菩萨摩诃萨。了知诸行皆无常已不顾身命修清净戒。行诸菩萨所行正行。皆为成满尸罗波罗蜜多故。尔时世尊。欲重宣此义。而说颂曰

  妙色妙音声　　能济乐法者
  菩萨未为难　　住净尸罗故
  面目皆圆净　　不生盲跛伛
  诸身分端正　　皆由净戒生
  具大力大势　　赫奕大威光
  复由精进慧　　令恶魔惊怖
  诸王咸供养　　天龙所尊敬
  善断诸疑网　　深心行大慈
  安住于戒聚　　法行大名称
  苦逼不生畏　　终不堕恶道
  众生皆惛睡　　菩萨能觉之
  常无有暂眠　　遍四方求法
  安住于戒聚　　为求菩提道
  舍最上名珍　　妻子身肉等
  求最胜法教　　及无上佛法
  于世间所依　　应修诸供养
  若诃责骂詈　　恼害兴恶行
  加哀及赞美　　斯由住忍故
  如所说修行　　言常不虚诳
  安坐道场已　　震动于大地
  于佛法无疑　　舍离邪天众
  恒事天所尊　　谓佛薄伽梵
  世间诸众生　　刀杖等相加
  能令彼和合　　是为聪敏相
  众生受重苦　　多百拘胝劫
  虽不来见求　　若睹常无舍
  善友交谈论　　义利由斯获
  而众生不求　　反更相加害
  我以赡部洲　　及诸佛国土
  满中珍宝聚　　用资求善友
  假使以利刀　　割断我支节
  于彼众生类　　常行平等心
  舍愚夫作业　　为佛法因缘
  常守净尸罗　　安住微妙法
  修习法随法　　行菩萨妙行
  为求佛菩提　　三明慧甘露
  安住于戒聚　　修学诸佛法
  是为聪慧者　　天世应修供
  一切法无疑　　善达诸工巧
  深晓众生意　　弘扬美妙法
  戒聚已清净　　安坐菩提树
  降伏恶魔军　　悟无上正觉
  扬晖满世界　　犹如日月光
  菩萨有情尊　　能开圣慧眼
  授手引群生　　问道皆开示
  常欢笑先言　　曾无怀嫉恚
  舍无量自身　　及施多财宝
  未尝有远离　　最上佛菩提
  信戒已圆具　　善住谛实言
  曾无有幻伪　　安住尸罗聚
  诸来菩萨所　　或设虚妄言
  有闻皆信受　　而恒依谛语
  若有许菩萨　　假言衣食施
  终无有惠及　　菩萨无恚心

大宝积经卷第四十三大宝积经卷第四十四

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十尸罗波罗蜜品第七之三

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。具足如是清净尸罗。于诸行中常恒发起不可乐想。于诸众生起父母想。于彼有情起难保想。于妙五欲起非妙想。于受了别起无识想。舍利子。是菩萨摩诃萨。作是观已。不起平等不平等心。何以故。是菩萨摩诃萨。作如是观。若当发起心平等者。应超出心入于寂灭。若当发起心不平等。应令染心转不平等。如是眼色为缘生于眼识。染心起灭由随眠故。彼心体生于所缘境妄心计净。若能了知彼不如理而体不净。如是知已便得解脱。若彼解脱即尽于彼。彼何所尽。所谓贪尽嗔尽痴尽。如是尽者。即非贪尽嗔尽痴尽。何以故。若刹那贪有灭尽者。即应贪异尽异。若如是者贪应是实尽亦是实。若贪是实不应灭尽。然舍利子。一切有情皆由不正思惟如理作意故生于贪欲。夫贪欲者分别所起。若无分别计执斯断。若断计执即无有实。由无实故中无所贪。由无贪故即是真实。若是真实于中无苦。由无苦故则无烧恼。无烧恼故即是真实。若是真实于中无热。由无热故是即清凉。是即涅槃。于涅槃中无有贪爱。何以故。舍利子。夫涅槃者无有思虑。我当除灭如是贪爱。贪爱尽故名得涅槃。若如是者即能贪异所贪亦异。涅槃复异。此若异者。则于彼为彼。若于彼为彼。智者应当寻思彼实。如是求已不得坚实。若无坚实即为是虚。若是虚者即为寂静。若寂静者即为是空。空无何法谓我我所。若常若恒若住若变异法。则无有情。则无命者。由如是故。于贪嗔痴则无所起。舍利子。以何等故。有我我所计此为我。此我所有起我我所。颠倒计我故执我所。执我所故便有所作。于所作中起四种行。云何为四。谓身所作。语心所作。由意思惟发粗恶语。从此便生运身加害。舍利子。一切愚痴凡夫。由起自他别异想故。为想所执。为想所缚。菩萨摩诃萨行尸罗波罗蜜多故。于如是事知颠倒已。不与诸行而相习近。何以故。由习近故则生怖畏。菩萨摩诃萨。作如是念。我今为求无怖畏故。度诸众生。不宜于彼而生怖畏。我当与之共为亲爱

复次舍利子。云何菩萨摩诃萨。依尸罗波罗蜜多故。于一切众生起父母想。舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。作是思惟。无有众生于彼过去久远世来非父非母易可得者。何以故。一切众生。定曾为我若父若母。然由于彼生贪心故。舍于母想。生嗔心故舍于父想。流转生死不能断绝。是故舍利子。菩萨摩诃萨。由斯事故。深思惟已。于诸众生起眷属想。舍利子。如彼过去超阿僧企耶广大无量不可思议劫。尔时有佛名最胜众。出现于世。如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。彼佛住寿九拘胝岁。与九拘胝那庾多大声闻众同共集会。尔时有一菩萨。名为得念。生在王宫。形貌端严众所乐见。成就第一圆净色相。然此菩萨初生之时。父母各以八万四千童少婇女。而以赐之。亲友眷属。复以八万四千诸妙彩女。而用上之。父母知友。复以彩女八万四千奉于菩萨。为欲生长常随翼从。舍利子。时菩萨父。为是菩萨起三时殿。热时雨时及以寒时。令彼菩萨居重殿上。随时而住。又令无量百千伎乐。围绕菩萨而娱乐之。尔时菩萨闻诸乐音。将举其声起生灭想。而现在前。乐音暂止。便思此声依何而起。何处而生。依何而息。何处而灭。尔时菩萨作是观时。不起昼夜差别之想。唯恒发起无常之想。一切世间不可乐想。舍利子。尔时得念菩萨。四万岁中未曾于乐而生耽着。又四万岁于诸欲中未曾贪染。是时菩萨住深宫中。入四静虑发五神通。即从内宫以神足力身升虚空。往最胜众如来应正等觉薄伽梵所。既到彼已请问彼佛。得少善法旋还本宫。舍利子。是得念菩萨。于彼如来入涅槃日。复往如来所住之处。问诸苾刍。最胜众佛今为何在。我今欲见亲觐供养。时诸苾刍告得念曰。善男子。汝不知耶。如来今者已般涅槃。尔时菩萨。既知如来般涅槃已。即于是处举身投地。涕泣闷绝。良久乃苏。便说颂曰

  如是照世间　　到诸法彼岸
  我住放逸地　　如何自欺诳
  百千劫拘胝　　如来乃一现
  而我不奉事　　谁当作依救
  如我自惟忖　　我母非亲善
  何不赞如来　　令我初生见
  父亦非亲善　　陷我于诸欲
  既被所拘执　　乖事世间依
  不闻佛所说　　六十妙音声
  生为失大利　　谓不事佛故
  到诸法彼岸　　利世大悲者
  我憍逸所执　　不事两足尊
  千亿那庾劫　　见诸佛甚难
  我不修供养　　灭后方来至
  今我重思忖　　父母俱非善
  当我初生时　　何不为赞佛
  令见最胜尊　　常住如来所
  广修诸供养　　及听闻正法
  如来所宣畅　　六十妙音声
  而我未曾闻　　灭后方来至
  我今失大利　　涅槃后方来
  无为演妙法　　如先佛所说

舍利子。尔时得念菩萨。即于是处悲啼而起。往最胜众如来般涅槃床。既到彼已哀恸悲噎。右绕如来满百千匝。却住一面而说颂曰

  佛为群生真实尊　　显扬无上微妙法
  我今发起至诚心　　为获最胜菩提故
  我今敬礼如来足　　世界真言大慧者
  愿我当获如斯智　　等最胜尊之所得
  我昔羸劣无智慧　　堕在魔罗品类中
  安处居家多迫迮　　不得奉事人中上
  我已曾修胜妙福　　由此暂得觐如来
  然佛不垂开正法　　故我于今受极苦
  我今天龙等众前　　兴发至诚真谛语
  若我本期如实者　　当依所言无不遂
  愿我当于未来世　　诸佛出现人中尊
  见甚深义广大用　　宣说无上真实法
  尔时诸难我不生　　既生诸欲不亲近
  女色自在无随转　　摧坏魔罗之囹圄
  生生常得见诸佛　　无上正法现前闻
  由睹诸佛净信生　　生净信已修诸行
  若我所发至诚言　　必当谛实非虚者
  由此如来还起坐　　如从重睡欻然觉
  菩萨适发诚言已　　如来应时便起坐
  百千拘胝诸天众　　以上妙衣而奉散
  菩萨是时心喜悦　　举身上踊住虚空
  既在虚空安住已　　以妙伽他赞最胜
  慈心利世大明照　　第一说者大神通
  觉悟愍念世间依　　演宣无上正法者

舍利子。尔时得念菩萨。宣说如是诸赞颂已。欲令大众倍欢悦故。复于佛前而说颂曰

  我于未来当作佛　　示现授记人中尊
  汝等大众应随学　　于如来所兴供养
  世间依怙不思议　　谁有于斯不生信
  哀愍我等及众生　　已入涅槃还重起

舍利子。是得念菩萨。于最胜众如来法中。大设供养殖诸善本。即以如是善根力故。于此命终。生彼善趣诸天世界。经二十大劫拘胝。不堕恶趣。又经二十大劫拘胝。不受欲乐。舍利子。是得念菩萨。于如是时亲觐奉事七千诸佛。于诸佛所广设供养。为求阿耨多罗三藐三菩提故。常修梵行。于最后劫来世之时。得胜上身自善根力之所发起。成等正觉。号娑罗王如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。出现于世。舍利子。是娑罗王佛。寿二十拘胝岁。与诸弟子再会说法。第一大会声闻弟子有二十拘胝。第二大会有四十千一切皆是大阿罗汉。诸漏已尽无复烦恼。获大势力。乃至得到诸心自在第一彼岸。舍利子。彼佛世尊般涅槃后。流布舍利广起灵庙。正法住世满十千岁。尔时薄伽梵。欲重宣此义。而说颂曰

  舍利子当知　　是得念菩萨
  二十劫拘胝　　未曾堕恶道
  又经如是劫　　不习诸贪欲
  于是中间时　　七千佛灭度
  爱乐诸佛法　　常修清净行
  最后悟菩提　　号娑罗王佛
  三十拘胝千　　住无上正觉
  悟上菩提已　　利益诸众生
  二十拘胝岁　　广宣微妙法
  二十拘胝众　　及余四十千
  一切尽诸漏　　皆佛之仙众
  彼佛涅槃后　　舍利广流布
  灵庙具足满　　六十千拘胝
  灭后法住世　　经于十千岁
  闻佛说正教　　皆生清净信
  如来所说法　　智者不生疑
  终不堕恶道　　速证于寂灭

复次舍利子。如是菩萨摩诃萨。行尸罗波罗蜜多故。清净戒众。于诸众生起父母想。何以故。我于往昔生贪心故舍于母想。生嗔心故舍于父想。我今行尸罗波罗蜜多。安住净戒。于彼诸欲。恒兴起厌违背之心。是菩萨摩诃萨。为除贪故。以正作意。于诸欲中。起于真实违厌之想。舍利子。是菩萨摩诃萨。由起如是正思惟故。能自了知诸欲之相。又能了知诸欲违厌。舍利子。云何名为了知诸欲。及能了知诸欲违厌。舍利子。所言诸欲名为贪爱。谓贪眼识所识诸色。是名为欲贪爱耳识所识诸声。是名为欲。如是贪爱。鼻识所识诸香。舌识所识诸味。身识所识诸触。是名为欲。舍利子。若有贪爱则有执着。夫执著者名之为结。结名发起。发起名缚。又亦名为不实戏论。如是舍利子。一切众生。皆为不实戏论诸缚所缚。缠缚遍缚。增上遍缚不得解脱。舍利子。一切众生为谁缚故。名之为缚。所谓色缚所缚故。名之为缚。乃至声香味触缚所缚故。名之为缚。又何等故名为色缚。谓于自身所得诸色。妄起我想。命者之想。数取趣想。常想恒想。不变异想。实想全想。一合之想。如是等想名为色缚。舍利子。何等名为色缚所缚。谓于所起我自体相。深亲宝重广兴我爱。于诸妻妾一切女色。恋着不已。如是名为色缚所缚。舍利子。是诸众生。既得受用诸欲法已。造不善业。不如实知诸欲过失。云何名为诸欲过失。舍利子。一切诸欲无非过失。是故智者。于诸过失不应生欲。然趣恶道是欲重过。吾当为汝开示其相。舍利子。云何名为能趣恶道诸欲重过。舍利子。我说一切习近欲时。无有少恶而不造者。彼若报熟。无有少苦而不摄受。是故舍利子。我观一切千世界中。众生大怨无过妻妾女色诸欲。何以故。舍利子。夫有智者即是如来。言无智者谓群生也。若诸智者之所诃毁。是名真实。若诸无智之所摄受。则非真实。舍利子。诸无智者何所摄受。所谓摄受诸有为法。摄受妻妾女色诸欲及男女等。彼无智者。又为妻子诸女色等之所摄受。如是展转更相摄受。则不摄受于彼圣道。舍利子。彼无智者。为于男女妻妾诸女色等所缠缚故。于诸善法多生障碍。何所障碍。所谓障碍出家。障碍尸罗。障碍静虑。障碍天道。障碍涅槃。又能障碍诸妙善法。又舍利子。彼无智者。若有摄受男女妻妾诸女色等。略说则是。摄受怨仇。即为摄受地狱傍生焰魔鬼趣等。舍利子。如是摄受。取要言之。即是摄受一切恶不善法。障碍一切诸贤圣法。又若摄受男女妻妾诸女色等。乃至则于一切美食。亦能障碍。况余胜事。舍利子。如是障碍略而言之。所谓障碍见佛。障碍闻法。障碍奉僧。障碍见佛所得净信。障碍闻法所得净信。障碍奉僧所得净信。又略而言。障碍获得具足无难。障碍信财。戒财闻财。舍财慧财。惭财愧财。舍利子。若有摄受男女妻妾诸色欲等。即为摄受不信恶戒邪闻悭吝恶邪之慧无惭无愧。又复摄受病痈毒箭火聚毒蛇。舍利子。若有乐处居家耽嗜不舍。当知即是乐处冢间。是故我说乐处居家。如住冢间。及旷野处无所投告。即为丧失诸白净法。又舍利子。若有众生味着男女妻妾诸女色欲。当知即是味着砾石之雹。即是味着利刀之刃。即是味着大热铁丸。即是味着坐热铁床。即是味着热铁机蹬。舍利子。若有味着花鬘香涂。即是味着热铁花鬘。亦是味着屎尿涂身。舍利子。若有摄受居处舍宅。当知摄受大热铁瓮。若有摄受奴婢作使。当知摄受地狱恶卒。若有摄受象马驼驴牛羊鸡豕。当知摄受地狱之中黑驳诸狗。又是摄受百踰缮那禁卫之卒。取要言之。若有摄受妻妾男女诸女色欲。当知即是摄受一切众苦忧愁悲恼之聚。舍利子。宁当依附千踰缮量大热铁床。是床极热遍热猛焰洞然。于彼父母所给妻妾诸女色欲。乃至不以染爱之心。远观其相。何况亲附抱持之者。何以故。舍利子。当知妇人是众苦本。是障碍本。是杀害本。是系缚本。是忧愁本。是怨对本。是生盲本。当知妇人灭圣慧眼。当知妇人。如热铁花。散布于地。足蹈其上。当知妇人于诸邪性流布增长。舍利子。何因缘故名为妇人。所言妇者名加重担。何以故。能使众生负重担故。能使众生弊重担故。能使众生受重担故。能使众生持于重担有所行故。能使众生荷于重担遍周行故。能令众生于此重担心疲苦故。能令众生为于重担所煎迫故。能令众生为于重担所伤害故。舍利子。复以何缘名之为妇所言妇者。是诸众生所输委处。是贪爱奴所流没处。是顺妇者所输税处。是妇媚者所迷惑处。是妇胜者所归投处。是屈妇者所凭仗处。妇自在者所放逸处。为妇奴者所疲苦处。随妇转者所欣仰处。舍利子。以如是等诸因缘故。名是诸处以之为妇。又舍利子。世间众生。由妇因缘不舍重担。不舍何等之重担耶。所谓五蕴。何等五蕴。色蕴受蕴想蕴行蕴识蕴。舍利子。世间妇人。能令众生不舍如是五蕴重担。故名五蕴以之为妇。舍利子。复何因缘世人名妇为故第二。舍利子。如是女人。是犯尸罗第二伴故。是犯威仪第二伴故。是犯正见第二伴故。是饮食时第二伴故。是往地狱傍生鬼趣第二伴故。能障圣慧碍涅槃乐摄一切苦第二伴故。是以名为故第二也。舍利子。复以何故。世人名妇以为母众。舍利子。一切女人生多过失无边幻诳。故名母众。若有随逐母众自在。当知即堕魔罗手中自在为恶。如是舍利子。当知世界一切女人生多过失无边幻诳。心多轻躁。心多掉动。其心流荡。倾覆不住。心似山狖。心似猿猴。善能示现幻诳之术。如是诸相。故名女人以为母众。又舍利子。言母众者即母幻村。又亦名为幻之城邑。幻王所都。幻客之亭。幻人之馆。幻国幻村。幻处幻方。是幻世间。是幻世界。是无边幻。是广大幻。是无量幻。是不可思议幻。舍利子。由如是等诸欲重过能趣恶道。故号女人名母幻村。舍利子。譬如幻师善学幻术于大众中示现种种幻诳之事。舍利子。母村亦尔。善学女人幻诳之术。能令丈夫若见若闻若摩若触皆被系缚。又诸女人巧知惑媚。由知媚故势力自在。凡有所作。歌舞戏笑。啼泣往来。若住坐卧。于一切时。能令丈夫不得自在。随彼女人系缚驱使。舍利子。譬如世间成熟稻田被大雹雨伤残滋甚。如是舍利子。是母幻村。犹如大雹堕丈夫田。摧坏一切白法苗稼。消灭都尽。舍利子。诸如是等能趣恶道。贪欲重过。一切世间愚痴凡夫。为之幻惑不能觉了。而复摄受所爱妻妾诸女色欲为之迷醉

复次舍利子。聪慧菩萨摩诃萨。行尸罗波罗蜜多故。于是诸欲深知过已。便依正法起二种想。所谓于诸愚夫起恶人想。于佛菩萨起善人想。菩萨摩诃萨作是观已。便自思惟。我今应往善丈夫趣。不宜往彼恶丈夫趣。我不应往地狱傍生焰魔鬼趣。我不应往毁尸罗趣。我不应往犯戒住处。我今应往最胜无上离前诸法无障碍趣。我今应往诸佛如来大智慧趣。又作是念。我当逆流而行。非顺流者。我当作师子吼。非野干鸣。我当示现金翅鸟王之大势力。不应示现微细昆虫之所有力。我今应作贤良之人。不作险恶愦杂之人。我今应啖贤良胜士清净之食。不应啖彼无良下士不净之食。我应修行微妙静虑。最胜静虑。殊特静虑。第一三摩地所得。彼类静虑不应修行。非彼类静虑。非下少静虑。舍利子。菩萨摩诃萨。又作是念。我应游戏诸佛静虑。不应游戏声闻独觉一切愚夫异生静虑。我当修行无依静虑。不应修行依色静虑。又亦不依受想行识静虑。不应修行依地界静虑。又亦不依水界火界风界静虑。亦不修行依欲界静虑。又亦不依色界无色界静虑。亦不修行依此世他世静虑。又亦不依已见已闻已念已识已得已触已证如是静虑。舍利子。是菩萨摩诃萨。复作是念言。我当修习无依静虑。由修习故。当不自损。又不损他。亦不俱损。我当追求圆成佛智。岂复应求世间诸欲

复次舍利子。如是聪慧菩萨摩诃萨。行尸罗波罗蜜多时。作如是等诸正观已。复应当发四种厌离。云何为四。所谓能于诸欲而生厌离。于诸有中能生厌离。于不知恩诸众生所而生厌离。于一切行诸苦恼所而生厌离。舍利子。是名菩萨摩诃萨行尸罗波罗蜜多故发起四种厌离之想。应如是学

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。观诸有情处于恶道见妙女色起贪心者。应起四种厌离之想。云何为四。所谓退失想。颠坠想。行厕想。脓溃粪秽不净之想。如是舍利子。处诸恶道有情识者。见妙女色。尚应发起如是四想。何况于人。舍利子。安住大乘诸族姓子。厌离一切有为行者。见妙女色起于退失颠坠行厕脓溃粪秽。如是四想。若起此想犹生贪心。又应更起三种亲想。所谓于母等类起于母想。姊妹等类起姊妹想。于女等类而起女想。佛告舍利子。菩萨摩诃萨。闻我所说能善解者。应当随顺如是经典尸罗波罗蜜多。何以故。无有众生是易可得久远世来非我父母。所以者何。是诸众生。皆曾为我而作父母。若有习近妻妾女人。则为习近过去之母。舍利子。菩萨摩诃萨闻我说已。为清净故。应当如是励勤修学

复次舍利子。一切世间愚痴凡夫。于彼正法违逆不信。菩萨不尔。随顺正法无有违逆。若有修行如是诸观。犹为贪心所随逐者。菩萨复应如理观察。所生贪心见何而生。若当于眼起贪心者。菩萨重应如理观之。我为于眼起染爱者。谁能见眼。为眼见眼耶。则彼自体见自体耶。何以故。彼亦是眼。此亦是眼皆为四大之所造故。又为大种之所生故。非由自体。于此自体而起染爱。又非于我自体而起染爱。何以故。彼则是此故。若有于彼起染爱者。应是于此而起染爱。以无差别故。一切世间愚痴凡夫。无差别住。我今应求差别之法。何以故。以诸欲觉都无有德故。尔时世尊。欲重宣此义。而说颂曰

  展转同一义　　都无差别性
  由乖理邪执　　起是贪爱心
  云何四大生　　还能染大造
  诸法犹如幻　　无由起贪爱
  我等邪分别　　妄起贪爱心
  不肖者生贪　　贤善人无爱
  遍于十方界　　无实贪可求
  但虚妄分别　　故起斯贪爱

复次舍利子。菩萨摩诃萨。行尸罗波罗蜜多时。作是观已。犹被贪心而随逐者。若有闻佛所说诸法善根力故。复应随顺如是经典。所谓眼如聚沫不可撮摩。何以故。彼聚沫等一切诸法。本无有我。亦无有情无有命者。无数取趣。无摩纳婆。无丈夫。无意生。无作者。无受者。于如是等无作无受。一切法中谁能染爱。又于何所而生染爱。舍利子。眼如浮泡性非坚实。何以故。彼浮泡等一切诸法。本无有我。亦无有情。无有命者。无数取趣。无摩纳婆。无丈夫。无意生。无作者。无受者。于如是等无作无用。诸法之中谁能染爱。又于何所而生染爱。舍利子。眼如阳焰业惑爱生。何以故。彼阳焰等一切诸法。本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如芭蕉体非贞固。何以故。彼芭蕉等一切诸法。本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。是眼如梦非如实见。何以故。彼虚梦等一切诸法。本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如传响系属众缘。何以故。彼传响等一切诸法。本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如光影依业影现。何以故。彼光影等一切诸法。本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如浮云飘乱散相。何以故。彼云等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如流电念坏相应。何以故。彼电等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。是眼如空离我我所。何以故。彼空等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼为无知如草木土石。何以故。无知等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼无作用随风机转何以故。无作等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼为虚诳不净朽烂之所积聚。何以故。虚诳等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼为虚伪摧破坏散灭尽之法。何以故。虚伪等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼如丘井常为老逼。何以故。丘井等法本无有我。亦无有情。乃至谁能染爱。于何染爱。舍利子。眼不久停终于死际。何以故。彼非久停。一切诸法本无有我。亦无有情。无有命者。无数取趣。无摩纳婆。无丈夫。无意生。无作者。无受者。于如是等无作无用。缘会所生诸法之中。谁能染爱。又于何所而行染爱。如是广说一切内外。诸根尘法亦复如是。舍利子。菩萨摩诃萨。如是正观察时。为诸贪爱所牵引者。无有是处。若有菩萨摩诃萨。作是观者。当知是则于诸法中。永离贪爱。舍利子。是名菩萨摩诃萨。行尸罗波罗蜜多时。毕竟清净灭诸贪爱

尔时佛告舍利子。如是清净行尸罗波罗蜜多。菩萨摩诃萨。不行一切害众生业乃至命难。于诸众生终不加害。不行一切不与取业。乃至命难。于他资具终不劫盗。不习一切淫荒邪行。乃至命难。于诸女色终不染趣。不说一切欺诳妄语。乃至命难。于诸众生不行虚诳。不说一切粗犷之言。乃至命难。于诸众生终不毁骂。不说一切离间之言。乃至命难。于诸众生不行破语。于自眷属生知足故。不传一切浮绮谈说。言必如量。乃至命难。终不绮绘异词矫饰文句。于他财物不起贪着。乃至命难。诸所受用终无爱染。于诸恼辱具忍成就。闻粗恶言善能堪耐。乃至命难。不生忿恚。于诸法中不生邪见。乃至命难。终不信事诸余天神。唯于佛所净心归趣。舍利子。如是名为菩萨摩诃萨尸罗清净

佛告舍利子。是菩萨摩诃萨。行尸罗波罗蜜多故。具足成就无量无边诸佛正法。舍利子。菩萨摩诃萨由行尸罗波罗蜜多故。具足成就不缺尸罗。不与无智相亲近故。具足成就不穿尸罗。不平等生能远离故。具足成就不斑尸罗。不近恶人诸烦恼故。具足成就不杂尸罗。唯为白法所增长故。具足成就应供尸罗。如其所欲自在行故。具足成就称赞尸罗。不为智者所诃毁故。具足成就善守尸罗。圆备正念及正知故。具足成就不呰尸罗。于诸过失所不生故。具足成就善护尸罗。于诸根门善防卫故。具足成就高广尸罗。为一切佛所忆念故。具足成就少欲尸罗。知净量故。具足成就知足尸罗。欣乐断故。具足成就正行尸罗。身心远离故。具足成就处静尸罗。厌烦闹故。具足成就圣种善喜尸罗。不顾他颜无希望故。具足成就杜多功德少事尸罗。自在生长诸善根故。具足成就如说而行尸罗。不诳世间诸天人故。具足成就大慈尸罗。不害一切诸有命故。具足成就大慈尸罗。堪忍一切诸苦恼故。具足成就大喜尸罗。于彼法乐无退减故。具足成就大舍尸罗。一切爱恚毕竟断故。具足成就常省己过尸罗。恒于内心善察照故。具足成就不讥彼阙尸罗。于众生心善随护故。具足成就成熟众生尸罗。究竟能到施彼岸故。具足成就善守护尸罗。究竟能到戒彼岸故。具足成就无憎害心尸罗。究竟能到忍彼岸故。具足成就不退转尸罗。究竟能到正勤彼岸故。具足成就定分圆满尸罗。究竟能到静虑彼岸故。具足成就正闻无厌尸罗。究竟能到大慧彼岸故。具足成就亲近善友尸罗。觉分资粮善修集故。具足成就远离恶友尸罗。弃舍不平等道故。具足成就不顾恋身尸罗。以无常想恒观察故。具足成就不顾恋命尸罗。以其所重不常保故。具足成就不起悔尸罗。心善清净故。具足成就不诈现尸罗。方便善清净故。具足成就不恼热尸罗。于增上意善清净故。具足成就不轻掉尸罗。永离诸贪爱故。具足成就不高慢尸罗。和柔质直故。具足成就不强戾尸罗。性贤善故。具足成就善调伏尸罗。无愤恚故。具足成就寂静尸罗。性安摄故。具足成就善语尸罗。如其所说无违逆故。具足成就成熟有情尸罗。常不舍离诸摄法故。具足成就守护正法尸罗。于圣法财自不坏故。舍利子。聪慧菩萨摩诃萨。如是清净戒聚。具足成就尸罗波罗蜜多。为阿耨多罗三藐三菩提故。善能修行菩萨妙行。舍利子。是名菩萨摩诃萨。尸罗波罗蜜多。若诸菩萨摩诃萨。精勤修行是菩萨行。一切众魔魔民天子。于此菩萨不能娆乱。又不为彼异道他论所能摧屈

大宝积经卷第四十四大宝积经卷第四十五

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十一羼底波罗蜜多品第八

尔时佛告舍利子。云何名为菩萨摩诃萨。羼底波罗蜜多。菩萨摩诃萨。为阿耨多罗三藐三菩提故。于如是法精勤修学。行菩萨行。舍利子。菩萨摩诃萨。由住如是羼底波罗蜜多故。具足忍力立性坚正。于诸寒热饥渴。蛇蝎蚊虻。风日等触。志能堪忍。又能忍粗恶言说鄙陋词句。及以依身所起猛迅苦受。坚鞕辛楚夺命至死。诸如是等所有苦受。并能堪忍。舍利子。若诸菩萨摩诃萨。能具是者。是则名为羼底波罗蜜多

复次舍利子。我昔长夜未成佛时。行菩萨行常修忍辱。舍利子白佛言。世尊。云何世尊为菩萨时。修集忍辱行菩萨行。佛告舍利子。我忆过去行菩萨行。多有众生数来毁骂。非法诃责。面于我前出诸非法弊恶言说。舍利子。我于尔时。行羼底波罗蜜多故。制伏其心。不生忿恚悭吝恼热。但作是念。于诸行中无有少法。是易可得。过于毁骂及诃责者。是故我今应当修舍。又我于彼应起慈悲。何以故。世间众生。多分安住毁骂诃责。由斯业故。还复感得如是之相诃毁果报。在在所生常得丑陋可恶之身。我今不乐丑陋之事。岂应乐行毁骂诃责。何以故。如是诃毁诸恶业者。是则名为不相应业。不称理业。愚夫之业。是下劣业。非善人业。非贤圣业。由此业故。堕于地狱傍生焰魔世界。又由此业与诸恶趣而为眷属。由此业故。感得贫穷药叉之身。又由此业。感贫药叉根本果报。由此业故。感得贫穷饿鬼之身。又由此业。感贫饿鬼根本果报。由此业故。感得贫穷人趣之身。又由此业。感贫人趣根本果报。又由如此诃毁业故。感得下趣及以下趣根本果报。我今不应求下劣趣。所以者何。若我求作如是事者。与诸众生有何差别。然彼众生不顺于理。我既顺理不应同彼。舍利子。是诸菩萨摩诃萨。行羼底波罗蜜多者。应当随我修学是法。何以故。舍利子。是诸菩萨为他毁骂诃责之时。便能依是正法作意思惟忍受。是菩萨摩诃萨由得如是忍辱力故。复获无量诸妙善根。假使以诸珍宝满佛世界。四大洲中持用布施。比前功德皆不能及。所以者何。是忍辱行。极善丈夫方能修习。何以故。一切众生。多为毁骂诃责之所拘执。由如是故。生死流转不能断绝

复次舍利子。是诸菩萨摩诃萨。行羼底波罗蜜多者。应自勉励审谛观察。作如是念。我若被他诃毁之时。为能思惟于佛菩提及法僧不。若能思惟是则为善。若不能思不名为善。复更以余无量方便。思惟于佛。思惟菩提及以法僧。舍利子。菩萨摩诃萨作是思已。应当观察。我今与一切众生。有何差别殊异之相。何以故。彼诸众生。现于我身起嗔害者。于佛菩提及以法僧。曾不思惟。我若同彼不思惟者。与诸众生有何差别。有何殊异希奇之相。舍利子。是菩萨摩诃萨。又复思惟。若被他人现嗔恚时。心便生舍。于佛菩提及法僧等。曾无思念。此非我宜。又作是念。若我于彼起嗔恚者。则为无智无忍辱力。亦于本愿而便弃舍。所以者何。若起嗔恚则无是心。我当摄受一切众生。我当不舍一切众生。我若起嗔于一有情。不名菩萨摄化之法。谁请于我行菩萨道。而况往昔发如是愿。我当速证阿耨多罗三藐三菩提已。广为众生宣说正法。适发如是弘誓之时。诸佛世尊同共证我便作是念。此族姓子发心安住如是无上正等觉已。当为众生广宣正法。又于今者。诸佛世尊无障碍智。无障碍见现证知我。是故不应为他毁骂诃责之时。若起嗔恚。于佛菩提法僧之所。若生舍者不应忆念。何以故。现在东方殑伽沙等诸佛世界。彼世界中。有殑伽沙等如来应正等觉现在住持。彼佛世尊亦证知我心生正愿。南西北方四维上下亦复如是。当我发是正愿之时。诸佛同声赞我忍力故我不应作师子吼已复作野干声。师子吼者。谓我当证大忍辱力。野干声者。谓于众生而行嗔恚诃毁等相。舍利子。是菩萨摩诃萨。复作是念。世间众生。若得彼利方乃利他。我亦如是得众生利方利彼者。我与世间有何差别。有何殊异希奇之相。又作是念。世间众生。若彼于此作无义利。此复于彼作无义利。我亦如是。众生于我作无义利。我复于彼作无义利。若如此者。我与众生有何希奇差别殊异。舍利子。菩萨摩诃萨。于是法中应当修学。又作是念。世间众生。互为怨对。若得彼利谓为善友。若不得利更相杀害。我见如是深过失故。应当不观一切众生。于我之身作诸利乐。及于我身作无义利。但作是念。我于今者。必当饶益一切众生。为欲满足羼底波罗蜜多故。尔时世尊。欲重宣此义而说颂曰

  设彼于我为无利　　经于多百拘胝劫
  见彼有情受众苦　　终无安住于舍心
  设有互得世财利　　更相称赞为善友
  若互不得世财利　　彼此怨对相残害
  假使以此赡部洲　　或复三千佛世界
  盛满珍宝来相惠　　常求我为贤善友
  假使执持利刀剑　　来解我身诸支节
  我当于彼诸众生　　平等利益心无二
  于诸毁骂我当忍　　亦忍一切诸难苦
  当为众生赞忍力　　亦自安住大忍中
  世间暴恶诸有情　　以刀毒等相加害
  能和合彼为善友　　此则圣贤聪睿相
  我当不学世愚夫　　又应与彼而为异
  凡夫圣者之所行　　流转寂灭差别故

复次舍利子。菩萨摩诃萨。行羼底波罗蜜多时。应作如是修学正法。舍利子。是菩萨摩诃萨。复作是念。假使经于百千那庾多拘胝大劫。被诸众生常以刀杖瓦石土块种种加害。但使须臾得存微命。犹应欣庆作如是念。奇哉如是有情圣者。能于我命不见全断。是菩萨摩诃萨。从是已后。转增修学。又作是念。假使众生行七步顷。斩截我首等殑伽沙。然我于彼终不发起若忿若恚。所以者何。夫忿恚者。速能损害百千大劫所集善根。若我善根为嗔害已。复当经于百千大劫。方始勤苦修行圣道。若如是者。阿耨多罗三藐三菩提极难可得。是故我当被忍辱铠。以坚固力摧忿恚军。又舍利子。菩萨摩诃萨住大乘者。起忿恚心魔得其便。既得便已。于阿耨多罗三藐三菩提能为障碍。舍利子。忿恚心者于菩提道能为扰乱。扰乱心者能发恶魔所有魔业。此中云何名为魔业。若有菩萨。心住衣钵不能舍离。当知魔业心住乞食。诸施主家不能舍离。当知魔业心住名闻。恭敬利养不能舍离。当知魔业于出家法常生厌患。当知魔业于白净法多生轻贱。当知魔业于空寂处无志求心。当知魔业不乐无上正等菩提。当知魔业于余智慧恒欣求习。当知魔业。乃至于邬波柁耶。阿遮利耶。二胜师所。不修敬仰恭顺之心。当知魔业。舍利子。诸如是等忿恚之心。能于菩提而为扰乱。舍利子。是则名为住扰乱心。菩萨摩诃萨。为诸恶魔之所使故。作诸魔业

复次舍利子。菩萨摩诃萨。行羼底波罗蜜多时。作如是念。于长夜中。诸众生等为诸恶魔伺求便者所谓嗔恚。舍利子。我今为汝广说其事。我念过去。为大仙人名修行处。时有恶魔。化作五百健骂丈夫。恒寻逐我兴诸恶骂。昼夜去来行住坐卧僧坊静室聚落俗家。若在街巷。若空闲处。随我坐立。是诸化魔。以粗恶言毁骂诃责。满五百年未曾休废。舍利子。我自忆昔。五百岁中为诸魔罗之所诃毁。未曾于彼起微恨心。恒兴慈救而用观察。舍利子。我于尔时复作是念。若有诸善男子。守护尸罗具众善法。于贪嗔痴性轻少者。不唯于彼作诸利益。说我以为行难行者。又亦不唯于彼作诸利益。能证无上正等菩提。何以故。若有众生刚强难伏。毁犯尸罗具诸恶法为性浊重贪嗔痴者。若我于彼作诸利益。是则说我为难行者。由我于彼作诸利益速成无上正等菩提。先当令彼证寂灭故。舍利子。是诸菩萨摩诃萨。若忿恚心现在前时。应生如是诸大正念。若生是念。诸利益事速得圆满。舍利子。如来于过去世。由行如是羼底波罗蜜多。菩萨行故证得阿耨多罗三藐三菩提。是故菩萨摩诃萨欲求无上正等觉者。于诸忍力常具成就。堪受一切寒热饥渴。风日蚊虻蛇蝎等触。又能堪忍粗恶言说鄙陋词句依身所生猛利诸苦坚鞕楚辛夺命至死如是苦受并能堪忍。舍利子。是名菩萨摩诃萨安住是忍。速能成就羼底波罗蜜多故

复次舍利子。云何菩萨摩诃萨羼底波罗蜜多。菩萨摩诃萨。依之修行。具足成满忍法之相。舍利子。菩萨忍者无有嗔恚。是菩萨忍。无有忿怼。是菩萨忍。无诸怒害。是菩萨忍。不起怨诤。是菩萨忍。无诸烦恼。是菩萨忍。善能自护。是菩萨忍。善能护他。是菩萨忍。当善护身。是菩萨忍。当善护语。是菩萨忍。当善护心。是菩萨忍。如理观察。是菩萨忍。厌离诸欲。是菩萨忍。依净业报。是菩萨忍。身善清净。是菩萨忍。语善清净。是菩萨忍。心善清净。是菩萨忍。受诸天人圆满净乐。是菩萨忍。如来相好圆满庄严。是菩萨忍。如来言说梵音微妙。是菩萨忍。行菩萨行摄诸善本。令不坏失。是菩萨忍。出离众生逼迫苦恼。是菩萨忍。除灭一切诸恶怨对。是菩萨忍。舍利子。略而言之。当知一切如来力无所畏不共佛法大慈大悲大喜大舍无量圆满诸佛妙法。皆是菩萨摩诃萨羼底波罗蜜多之所成就

复次舍利子。菩萨摩诃萨行羼底波罗蜜多时。应当具足诸忍正行。舍利子。菩萨摩诃萨。若被骂詈终无返报。善达言语如响声故。若被捶打终无返报。善达身形如影像故。若被忿怒终无返报。善观其心如幻幻故。若被赞毁终无爱恚。善知自身德圆满故。于得失利不生欣戚。调伏其心住寂静故。不希美称不犯恶名。善能观察广大慧故。毁而不下赞而不高。德善安住不倾动故。于诸苦事曾无厌恶。苦众生所深怀恋故。于诸乐相曾无欣爱。知有为乐性无常故。世间八法所不能染。不依一切有趣生故。于诸自苦善能堪忍。终不令他受苦恼故。于胜菩提心无退屈。觉分资粮善圆满故。节节支解乃至斩首。善能堪忍。希求如来金刚身故。屠割身肉善能堪忍。为求如来妙相好故。诸变恶事善能堪忍。为殖一切善业力故。舍利子。如是等相。名为菩萨摩诃萨。成就羼底波罗蜜多。应如是学

复次舍利子。菩萨摩诃萨。行羼底波罗蜜多时。诸忍之相。所谓菩萨摩诃萨。修行忍者。是则名为毕竟堪忍。何以故。若谓我能堪忍毁骂。而起忍者。是则名为俱生之忍。如是忍者非毕竟忍。若谓谁能起骂。复何所骂而起忍者。是则名为挍计法忍。若谓是眼能骂眼耶而起忍者。是则名为观诸处忍。若谓此中无能所骂而起忍者。是则名为悟入一切无众生忍。舍利子。如是诸忍。皆非菩萨毕竟之忍。又舍利子。若谓骂声但有诸字。是则名为响声之忍。如是忍者非毕竟忍。若谓彼我俱无常者。是则名为悟无常忍。若谓彼有颠倒我无颠倒。是则名为高下之忍。若谓彼非正理我是正理。是名相应不相应忍。若谓彼住邪道我住正道。是则名为二道别忍。如是忍者非毕竟忍。若谓我忍于空不忍见趣。我忍无相不忍诸觉。我忍无愿不忍志求。我忍无作不忍诸行。我忍惑尽不忍烦恼。我忍诸善不忍不善。我忍无罪不忍有罪。我忍无漏不忍有漏。我忍出世不忍世间。我忍清净不忍杂染。我忍涅槃不忍生死。舍利子。如是诸忍。但得名为治断之忍。皆非菩萨毕竟忍也

复次舍利子。云何菩萨摩诃萨。行于羼底波罗蜜多时。修行菩萨毕竟之忍。舍利子。若随顺空不减诸见。于彼空性亦无增益。如是忍者。是名菩萨毕竟之忍。若随顺空不减求愿。于无愿性亦无增益。若随顺空不减诸行。于无作性亦无增益若随顺空不减烦恼。于惑尽性亦无增益。若随顺空不减不善。于彼善性亦无增益。若随顺空不减有罪。于无罪性亦无增益。如是乃至若随顺空不减生死。于涅槃性亦无增益。舍利子。如是等相而生忍者。则名菩萨摩诃萨毕竟之忍。舍利子。一切诸法。非能生非所生。非已生非现生。无有一法是可生起。无生起故则无有尽。若有能知此无尽者。则名菩萨摩诃萨毕竟之忍。舍利子。一切诸法。非是有为。亦非无为。无有增益。无损无增。亦无长养。无盛无衰。无有作者。无有起者。由无起故。亦无有尽。如是忍者。则名菩萨摩诃萨无生之忍。舍利子。菩萨摩诃萨。为阿耨多罗三藐三菩提故。行菩萨行。若有具足成就如是忍者。是名菩萨摩诃萨。羼底波罗蜜多圆满成就。舍利子。若菩萨摩诃萨。安住如是羼底波罗蜜多。精勤修学。行菩萨行者。不为诸魔魔众天子之所扰乱。又亦不为异道邪论所能摧伏

    毗利耶波罗蜜多品第九之一

尔时佛告舍利子。云何菩萨摩诃萨。为阿耨多罗三藐三菩提故。依毗利耶波罗蜜多。行菩萨行。舍利子。菩萨摩诃萨。于是正勤波罗蜜多。精进修学行菩萨行。舍利子。菩萨摩诃萨具足成就不退正勤。而能不顾所重身命。发大精进求菩萨藏微妙法门。殷重听闻受持读诵究竟研寻通达义趣。广为他人敷演开示。或复书持如理修学。是名菩萨摩诃萨行菩萨行。舍利子。云何名为不顾身命。舍利子。菩萨摩诃萨。行正勤波罗蜜多时。设为于他所加恐怖。作如是言。若汝于此菩萨藏经。受持读诵。乃至广为他人开示书持。如理修学者。我当以百具箭槊。贯举汝身。除断汝命。舍利子。菩萨摩诃萨。当于尔时。虽闻此言曾不入心。无恐无怖无惊无畏。发四坚固勇猛威势。于菩萨藏微妙法门。转加精进。不弃不舍不远不离。具足成就猛利信解坚固信解坚固堪忍坚固正勤。舍利子。我当为汝说坚固忍坚固正勤方便譬喻。为令菩萨得坚固忍坚固正勤。行菩萨道不顾身命。舍利子。假使三千大千世界。所有众生有情所摄。若卵生若胎生若湿生若化生。若有色若无色若有想。若无想若非有想非无想。若可见若不可见。彼诸众生。乃至于刹那顷皆得人身。于菩萨所。同结百千极重怨仇。彼诸怨等语菩萨言。汝若于是菩萨藏经差别文句。受持读诵乃至广为他人开示书持。如理修学者。我等诸人同时执缚当断汝命。舍利子。菩萨摩诃萨行毗利耶波罗蜜多故。当于尔时。虽闻此语都无发起一念怖心。但具摄持四种正法。专务寻求大菩萨藏微妙法门。舍利子。是名菩萨摩诃萨具足成就不退正勤波罗蜜多故。又复成就无边势力。勇猛精进正勤勇健。心意勇健。净戒勇健。大忍勇健。等持勇健。大慧勇健。正行胜智皆悉勇健。舍利子。是菩萨摩诃萨行正勤波罗蜜多时。具足如是大忍力故。假使十方无量众生。各竞执持百千刀剑。于菩萨所兴加逆害。菩萨尔时。于诸有情终不微发一念嗔心。舍利子。如是菩萨摩诃萨住忍力故。如大梵王。如天帝释。如苏迷卢四宝山王。不可倾动。常住慈悲。恒起意解。救疗众生。于诸所行终无退转。而是菩萨。心如大地。心如大水。心如大火。心如大风。及以虚空。又能善修对治贪嗔痴等栽枿根本。舍利子。若有菩萨摩诃萨。以殑伽沙等无量世界盛满一切无价珍宝。持用奉施无量如来应正等觉。又有菩萨摩诃萨。行毗利耶波罗蜜多者。听闻如是大菩萨藏微妙法门。闻是经已往空闲处。系念思惟如是之法精进修学。令未修学诸菩萨等爱乐习行。舍利子。如是菩萨摩诃萨行正勤故。摄持无量诸妙善根非彼行施之所能及。何以故。舍利子。如是善根。系属阿耨多罗三藐三菩提故。是故诸菩萨摩诃萨。于菩萨藏微妙法门。应当听闻受持读诵。若复书写广为他说。发起正勤勇猛修习

复次舍利子。发起正勤波罗蜜多菩萨摩诃萨。当应修行不行行处。舍利子。云何名为不行行处。舍利子。不行行处。所谓涅槃。言不行者。诸恶天魔所不行故。所言行者。正勤善人之所行故。言善人者。所谓诸佛独觉及佛弟子。所以者何。诸登圣道所有善人及佛世尊。皆为趣向般涅槃故。舍利子。一切众生多行三处。何等三处。所谓随顺恶道。趣向恶道。将堕恶道。是故诸菩萨摩诃萨。于杂染法终不随顺。唯求出离戒忍多闻白等诸法。舍利子。世间众生多住无业。而恒自计住于有业。世间众生多诸懈怠。而恒自谓发起正勤。是故舍利子。聪慧菩萨摩诃萨。终不与彼无业懈怠共相习近。又亦不堕于其数中。唯与同行发起正勤诸大菩萨而相习近。何以故。舍利子。无有众生于彼最胜无染净相。大般涅槃生净信解如菩萨者。舍利子。发起正勤波罗蜜多菩萨摩诃萨。不唯自为证涅槃故。发勤精进。然为摄受一切有情。令诸众生得利乐故。修行正行发勤精进开示教导安处众生于圣道路故。说菩萨名善丈夫。尔时世尊。欲重宣此义而说颂曰

  正勤无缓缦　　常具大精进
  于菩萨藏法　　聪睿恒受持
  善思惟法义　　于佛不思议
  但勤求净法　　故名为菩萨
  正勤大慧者　　坐妙菩提树
  摧怖恶魔军　　由般若精进
  现守护禁戒　　任持诸世间
  为利益众生　　常精进无限

复次舍利子。如是大乘大菩萨藏微妙经典。流布于世能令众生发大欢喜。又能引生福德智慧感大财富。令其增长。能感诸天殊胜快乐。能感一切圆满具足。能生一切诸佛如来力无所畏无碍智解大慈大悲大喜大舍不共佛法。略而言之。能引一切诸佛之法。摧怖魔怨令心清净。能发猛慧穷生涯本。尽苦边际能近涅槃。舍利子。于当来世。我与汝等般涅槃后。后五百岁。尔时多有薄福众生当于是经不生信重毁灭舍弃。复有无量福德众生。钦奉是经如理修学勤加精进。为求无上正等菩提故。为求尸罗故。为求多闻。为求定慧解脱解脱智见故。为求一切佛法利乐一切众生故。为舍邪见修行正见故。为舍生死流转修于圣道故。为欲演说正法降伏天魔故。为欲舍离贪爱调伏嗔心摧破愚痴除灭无明发慧明故

复次舍利子。当来之世若有众生闻是法已。为求一切诸善法故。当发增上勇猛正勤。以闻如是微妙法故。于诸佛法无有障碍决定无疑。舍利子。尔时复有无量众生。福果所资住增上意。为求无上正等觉故。听是经典。闻已当获广大欢喜。于菩萨藏微妙法门。极善研习如说修行。又舍利子。尔时当有于如来教乐闻法者。彼诸众生随以何等差别因缘。遇得听闻如是经典。闻已当获广大欢喜。生欢喜已发坚精进。能于如是大菩萨藏微妙法宝取少宝分。舍利子。譬如大海水上漂流无量种种熟果色香美味皆悉具足。有一丈夫发起勇猛大精进力。便入海中运动手足接取彼果若二若三。然是丈夫执持此果。从海而出往至一处。取而尝之。乃知其味淳美希有。即作是念。如是妙果具色香味。我从生来未曾得食。当更发勤精进。重入海中运其手足敛收余果。作是念已。来至海滨通遍观之。了不复见。深起追悔生大忧恼。我先何为不多收取。乃令失是无量妙果。如是舍利子。于我灭后后五百岁。无上正法将灭之时。当有无量诸众生等。少信少施少戒少慧少修精进。随以何等差别因缘。遇得听闻如是经宝。既闻法已。于此经中但得少分微浅之义。乃至受持一四句颂。复为恶魔娆乱障蔽。不为众人之所敬问及以供养称赞信奉。是持经者知彼众人不敬重故。便于此经安住舍心。持先所闻经中句义微细少分。往一静处思惟观察。心生欢喜而复悔恨。作如是言。呜呼奇哉。我于今者大失善利。诸佛如来无上正教。如何不多听闻领受。又于如来起深重心。倍于先来发正念者。舍利子。当尔之时。有诸苾刍。恶魔持。故闻是经已。于众人前当起诽谤言。是经典诸文。华者之所造作。实非佛说。由如是故。有诸苾刍。于是经典全不听受。尔时世尊。欲重宣此义。而说颂曰

  闻是法已　　当无障碍　　于诸佛法
  最上无疑　　诸少福者　　不得听闻
  诸多福者　　闻是经典　　少福之人
  虽闻不信　　多福闻已　　顶戴如鬘
  诸少福者　　言非圣教　　当坠恶趣
  如盲堕坑　　多福之人　　闻生欢喜
  当往善趣　　如酥滴水　　诸薄福者
  闻生忧恼　　受苦长夜　　不脱黑暗
  虽得少闻　　复为魔娆　　谤佛菩提
  速入地狱

复次舍利子。诸佛如来。具足成就清净妙智。乃至能知四众之心。若一苾刍苾刍尼邬波索迦邬波斯迦。于当来世正法灭时。或有听闻如是经典随顺领受。或有闻已轻毁诽谤。或有众生全不听闻。如是一切如来净智悉能了知。舍利子。若有菩萨摩诃萨。及余一切诸有众生。闻已领受如是经典。精进修习当得成就四种无障清净之法。何等为四。一者成就尸罗无障清净。二者成就具足无难清净。三者成就逢值诸佛亲事供养无障清净。四者成就见慈氏佛初得见已无障清净。舍利子。彼诸众生闻是经已。如上所说诸妙善根。随其方便必当获得。舍利子。是名菩萨摩诃萨修行正勤波罗蜜多故成就四种无上清净之法

复次舍利子。于当来世正法灭时。有诸菩萨摩诃萨。安住大乘。修行正勤波罗蜜多者。于是经典勤加修学。发大精进听闻受持。书写读诵穷寻旨趣广为他说敷扬开显。尔时当有十障碍法。出现世间。诸有智者深当觉知。不应随转。但当发起勇猛精进受持是经。舍利子。何等名为十种障碍。智者觉知不应随转。舍利子。有诸苾刍发勤精进。于是经典求闻诵习。尔时恶魔。令持经者口噤不语。便于是经不得建立。是名第一障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进。于是经典求闻诵习。尔时恶魔。令持经者患其眼目。便于是经不得建立。是名第二障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进。于是经典求闻诵习。尔时恶魔。令持经者身诸支节一时皆病。便于是经不得建立。是名第三障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进。于是经典求闻诵习。尔时恶魔。令持经者于其住处心不喜乐寻欲舍弃。便于是经不得建立。是名第四障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进。于是经典求闻诵习

尔时恶魔。令持经者互生忿恚为忿坏心相加残害。便于此经不得建立。是名第五障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进。于是经典欲求诵习。尔时恶魔。令持经者起言诤事。起斗讼事。起讥刺事。起乖离事。起嗔骂事。由是事故彼此口中互生矛槊互相言讼。互相残害。互相乖竞。由起如是诤竞事故。便生障碍。于是经典不得流转。起意造作诸余事业。是名第六障碍之法。诸有智者深当觉知不应随转。又舍利子。有诸苾刍发勤精进于是经典欲求诵习。尔时恶魔。将坏灭故作诸形相。或俗人形。或出家形。来至其所娆乱其意。令于是经不能受持反加谤毁。复更起心乐余事业。是名第七障碍之法。诸有智者深当觉知不应随转。又舍利子。当来之世正法欲灭。尔时有诸年少苾刍。于是经典起清净信心生爱乐在我法律中。为行毗利耶波罗蜜多故。发勤精进。于阿耨多罗三藐三菩提。深心安住。又于是经恭敬听闻。既得闻已生大欢喜。时诸年少苾刍。当为邬波柁耶。及阿遮利耶。二本学师之所障碍。令于自法不生乐欲。是时二师而语之言。汝所持经此非佛语非佛菩提非是正法非毗奈耶非大师教。时彼苾刍。闻师教诲信受领解。于佛菩提即便弃舍。是时二师重语苾刍。汝等应当精进修学。如我所说若法若律。时诸苾刍信受领已。先所修习增上善根。为师所坏皆悉断灭。舍利子。彼诸苾刍断善根已。复为恶魔之所诳惑。由诳惑故于佛正教造障法业。临命终时恶境现前惛痴迷乱。乃至夭死都皆集现。而复重兴感地狱业。舍利子。如是当来诸不善事。如来于此悉能了知。又舍利子。当来之世。有诸年少苾刍。于是经典起诸恶见。诽谤不信。凡所游履经行往来以种种言常兴谤毁。如来于此悉能了知。舍利子。菩萨摩诃萨发勤精进。住大乘者。当于尔时应起四想。何等为四。一者应当发起自调伏想。二者应观自身所作事业。不应观他所有诸事。三者于彼有情起悲愍想。四者住空闲处。于自他心起随护想。舍利子。如是四想住大乘者。若被诽谤应当发起。又舍利子。当来之世。无量众生受诸邪见。于彼演说正法。苾刍信受者少不怀敬重请问经义。又不供养亲近往来。亦不承事返生凌蔑。于说非法。苾刍信受者多得大势力。为诸众生所共敬重请问经义。供养称赞是非法者。因此缘故复于是经毁谤讥笑。舍利子。当尔之时。诸众生等。于是经典不欣乐者。闻斯毁谤倍不欣乐。诸欣乐者被谤毁故。便于此经舍离乐欲教离乐欲。诸苾刍等转更炽盛。致令转读是经典者。于众会前不得开示。是名第八障碍之法。诸有智者应当觉知不应随转。又舍利子。当来之世有诸苾刍。贪爱所蔽多行劫盗。欣乐世间三种弊法。何等为三。一者欣乐追求世间衣钵。二者欣乐追求世间饮食。三者欣乐追求世间戏论绮饰文颂。如是三法是名第九障碍之法。诸有智者应当觉知不应随转。又舍利子。当来之世正法灭时。有诸菩萨安住大乘。行毗利耶波罗蜜多故。于是经典。发勤勇猛增上精进书写受持研寻读诵。广为他人开示演说。彼诸人等。当为诸魔之所执持。烦恼业障之所覆蔽。喜世间业。乐世间业。方便勤求世间事业。于世谈论喜乐转增。方便勤求世间谈论喜乐睡眠。方便勤求喜于众乱乐于众乱。方便勤求乐着众乱。于是经典不能受持。又不转读研寻其义。亦不为他广敷开示。舍利子。于佛教中无有所余。能为内损无有所余能速毁灭。唯除懒惰诸恶苾刍。是名第十障碍之法。诸有智者应当觉知不应随转。尔时世尊。欲重宣此义。而说颂曰

  正法灭时多障碍　　当兴种种恶魔业
  于白净法不修习　　亦不乐求胜涅槃
  薄少智慧具恶觉　　不求安住于正法
  备行种种非法行　　游诸恶趣定无疑
  彼诸众生临命终　　无有能为救护者
  又彼亲教及传授　　命终当堕三恶趣
  百千拘胝那庾劫　　为求世利涉诸苦
  常为三火所烧然　　云何令彼速解脱
  我已证成无等觉　　转于微妙梵法轮
  诸天世间不能转　　今故为转度众生
  如是彼时诸群生　　舍我世间难得法
  习近恶魔诸品类　　当受无边极重苦
  障彼习行施戒等　　菩提圣道之因缘
  若有精勤于佛教　　当迷惑彼正道路
  诸有听闻如是法　　宣说无我诸空理
  安住此法正行时　　恶魔当为彼障碍
  谓此最胜此真实　　于非胜实胜实想
  反加谤毁佛正教　　当知速堕于地狱
  若有众生于佛所　　深起坚牢爱恭敬
  听闻如是正法已　　欢喜随顺而称赞
  恶魔知彼既生喜　　与诸眷属同愁怖
  便与种种惊畏相　　于彼人所生留难
  或当变作苾刍形　　诈现相亲窃言议
  谓此非正菩提道　　何故在此而奔趣
  有诸众生于是经　　将发坚固住正勤
  又被诱附而轻弄　　用斯废舍不修学
  既被魔罗所惑乱　　随魔意转而拘执
  乃告此经非正法　　便于寂灭永弃舍
  彼又弃舍大导师　　复不勤求无上法
  又复发生我爱已　　速疾趣彼地狱中
  尔时当有少众生　　乐欲勤求此空法
  不得和合同修习　　乃各流散他方土
  如是无上最胜法　　诸当闻者皆轻毁
  持法者怖远逃避　　是相当兴未来世
  此国全无持法者　　远方虽有未为多
  纵有受持此经者　　悉皆捐舍无咨问
  世间依怙圣教中　　如是甚深无上法
  无量障碍在未来　　了然犹如现在住
  时有持法贤善者　　不顾身命住空闲
  修习演宣如是法　　速疾往升于善趣

大宝积经卷第四十五大宝积经卷第四十六

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十二毗利耶波罗蜜多品第九之二

复次舍利子。当来之世。法欲灭时复有菩萨摩诃萨。安住大乘。行毗利耶波罗蜜多者。见如是等诸恶众生。诽谤毁灭是正法已。倍增振发勇猛正勤大精进力。于是经典大菩萨藏微妙法门。殷勤听受书持读诵。广为他人开示演说。舍利子。如是菩萨摩诃萨。当于尔时应起四想。何等为四。舍利子。所谓我父宝藏不久当灭。由为此故。佛薄伽梵释迦牟尼如来应正等觉。于百千那庾多拘胝无数大劫。精勤修习难行苦行。方乃获是正法宝藏。是故我当发勤精进。奉持此藏遍持此藏。极当遍持广通此藏。欲令法宝久不灭故。舍利子。譬如有人唯有一子。怜念爱重具大福相。观无厌足。是人后时欲有所趣。而携此子将涉危难。恐颠坠故以手执持。又等遍持极等遍持。勿令我子堕险难处。如是舍利子。彼善男子亦复如是。深怀奉信敬重于我。不舍如是无上法宝。志恒希求清净寂灭。虽经恶世。而能摄受最胜正法。舍利子。我今以此菩提因缘无上正法。付嘱是人。又舍利子。譬如世间大军战时。少有众生。为护众故处于前阵。唯有果敢雄猛丈夫。合率骁勇抗拒勍敌。为护己众处大军前。振威而住。如是舍利子。于当来世正法灭时。怀正法者当现前时。有诸众生发起深心。欣乐寂灭。而能于是无上法宝。乃至受持少分要义。当知是人亦复如是。被于正勤坚固甲胄。奋发勇猛大精进力。摧碎诸魔所有军阵。何以故。舍利子。若有众生。于是经典。乃至受持一四句颂。不生诽谤随喜赞叹。言此经典真是佛说。于多人前广宣显示者。当知是人即为随喜赞说去来现在诸佛所说经法。舍利子。如来不说是人但得少分功德果报。我说是人乃能成就如虚空量大功德聚。何以故。舍利子。我说是等名为善人。如是善人甚为难得。谓知恩者及报恩者。舍利子。如是知恩及报恩者。当知是为人中珍宝。又舍利子。于当来世正法灭时。诸恶魔等威势现时。若有众生于如来所信重不舍。受持是经无有远离。我说是人第一丈夫。为善丈夫。为胜丈夫。为健丈夫。为大丈夫。当知是人则为如来胜法朋侣。非为诈现朋恶党者。当知是人行实行者。如是舍利子。菩萨摩诃萨。应当修习坚固正行。乃至命终中无暂废。于诸佛所当勤卫护。乃至命终中无暂废。于正法所当勤摄受。乃至命终中无暂废。甚深空法当勤信解。乃至命终中无暂废。舍利子。是为菩萨摩诃萨于后恶世所起四法。若有成就如是四法。菩萨摩诃萨。于当来世法欲尽时。谤正法时。灭正法时。犯戒徒党大强盛时。炽然追求顺世外道恶咒术时。劫浊乱时。有情浊时。寿命浊时。烦恼浊时。诸见浊时。菩萨摩诃萨。当于尔时应住三处而为依止。何等为三。所谓应住阿兰若处。应住诤息灭处。应住佛菩提处。舍利子。是为菩萨摩诃萨当来恶世住于三处。应如是持。是则具足毗利耶波罗蜜多故。尔时世尊。欲重宣此义。而说颂曰

  于最胜法不远离　　为尽生老病死苦
  常勤精进无妄念　　当速成就自他利
  若有于是善说法　　闻已安住正思惟
  当知我为彼大师　　彼则是我真弟子
  若不听闻如是法　　设闻不住正思惟
  是人当趣诸恶道　　犹彼众流归大海
  百千拘胝那庾劫　　诸佛出现甚为难
  虽复暂遇不亲奉　　当随恶魔自在转

复次舍利子。乃往过去九十一劫当于尔时。有佛出世。名曰胜观如来应正等觉明行圆满善逝世间解无上丈夫善调御士天人师佛薄伽梵。舍利子。彼佛法中有六苾刍。行诸恶行恒相随逐。一名善见。二名善乐。三名欢喜。四名调善。五名苏逾遮。六名火天授。舍利子。是六苾刍恒说非法。有我有人有常有断。结固周旋更相信任。趣深隐所同共谋议。我等应当各各诱化人别百家用为徒党。又令百家传告眷属。如是展转亲姻传告。或当至于五十百等。作是议已便往教化。若村若城郊野店肆。或至王都及余邦国。一一诸家悉皆往趣。既到彼已不说正法。于佛世尊先行毁谤。舍利子。彼恶苾刍云何毁谤。舍利子。诸恶苾刍告众人言。世间决定有我有众生有寿命者。有数取者。若诸世间定无有我及诸法者。谁去谁来谁坐谁卧谁语谁默。谁能行施。谁是所受。谁能受用。谁受苦乐。谁有能受不苦不乐。若有人来语汝等言。世间决定无我无众生无寿命者。无数取者。当知是人为汝等怨。非汝善友。舍利子。尔时诸恶苾刍重更诱化妇人丈夫及以男女。作如是言。若有人说无我等法。当知其人为不善者。为暴恶者。是汝恶友非汝善友。复更化言。汝等诸人是聪慧者。深能领解我所说义。自今已往。若诸恶友非善友来。当为汝说。世间决定无我等法。汝等不应辄相亲昵交顾往还承事供养。舍利子。诸恶苾刍行如是化。于半月间人各诱得。满五百家归从其见。舍利子。尔时有诸苾刍。是阿罗汉。永离一切烦恼垢秽。而是胜观如来应正等觉真实弟子。为乞食等诸因缘故。诣彼诸恶苾刍所化之家。暂至其门。便为妇人丈夫及诸男女。所共毁骂非理诃责。以粗恶言面陈挫辱。为诸苾刍。而说颂曰

  汝等不能知正法　　汝等迷失于圣道
  汝等退舍于净教　　汝等皆当堕地狱

舍利子。彼诸人等说是语已。于阿罗汉倍更诃骂。既诃骂已。复以种种言词。而骂于佛。即于佛前。说伽陀曰

  如来所说非虚妄　　所谓诸行悉无常
  又说诸法皆无我　　及以无恒无不变
  诸行都无有坚实　　皆为虚伪妄失法
  所说空华无所有　　但能诳惑彼愚夫

舍利子。彼诸人等说如是语。轻毁佛已倍增愤恚。又于佛前。说伽他曰

  如来所说一切法　　决定无我无众生
  无有寿命无数取　　亦无作者及受者
  而今现见诸世间　　有能行施及所受
  并余种种受用人　　及觉广大诸受等
  当知宣说定无我　　一切皆应堕恶道

舍利子。当尔之时。诸不善人同声说是非法语者。大小男女有六十八拘胝千众生。皆恶苾刍所化导故行是恶业。彼命终已同生无间大地狱中。受身粗大鱼形人首。其舌长广弥布于地。周遍下钉如殖姜田。又于舌上众多铁犁。常以耕之。彼一一身。又为一百极恶商佉之所唼食。又于空中大热铁丸。猛焰赫然光色炽盛。从空而堕常雨其身。是诸罪人以恶业故。受如是等种种楚毒。尔时世尊。欲重宣此义。而说颂曰

  铁丸猛焰如飞电　　可畏无量百千种
  常于其身而堕坠　　炽然恒受种种苦
  又于身内遍流转　　炎炽猛盛难逢近
  腾焰高踊百由旬　　流火遍出身毛孔
  又彼众生一一舌　　尽为无量铁犁耕
  一切舌分皆分裂　　如是苦受恒缠绕
  斯由亲近恶友已　　能感如斯大苦聚
  又由远离具戒者　　致令速堕于恶道

舍利子。时彼非法六恶苾刍。由恶教故。命终之后。皆生阿毗大地狱中。一一受身纵广等量。三十踰缮那。彼一一身皆生千口。一一口中各生二舌。是一一舌广长量等四踰缮那。一一舌上有五百铁犁。铁牛挽之以耕其舌。是诸罪人虽受苦痛。大苦逼故不遑号叫。又于头上各有万亿狱卒。手执害具刀锯矛槊。斫刺破裂坏其身首。在此狱中寿万亿岁。如是展转复往诸余大地狱中。具受辛酸种种苦楚。何以故。由彼嗔毁佛圣教故。舍利子。当于尔时。有大长者名曰安隐。财富无量资产具足。多诸珍宝金银琉璃珊瑚末尼真珠贝玉无不备有。又多仆使奴婢财谷库藏皆悉盈满是时长者。为恶苾刍之所教化。既受其语生于断见。长者有妻名为焰慧。容色盛美为人所重。彼生一男。形貌端严众睹无厌。成就第一圆满净色。曾于过去无量百千那庾多拘胝佛所。植诸善本。当初生时三返微笑。又发是言奇哉奇哉。云何今者生断见家。其母闻已惊恐惶惧身毛为竖。与诸女人弃之逃避。舍利子。时诸女人欲审悉故。还来近住观察是儿为何等类。天耶龙耶。为药叉耶。为健达缚。为阿素洛。为揭路荼。为紧捺洛。为牟呼洛伽。为究槃荼。为毕舍遮人非人耶。舍利子。时此婴儿再发是言。告诸女曰。汝虽怖走我甚安乐。时此婴儿。为诸女人。而说颂曰

  汝当乐义利　　于义利勿怖
  我当度汝等　　令脱于邪道
  汝安隐勿怖　　应怖前恶友
  我当度汝等　　令脱于邪见

舍利子。时彼父母及余大众。闻是婴儿说伽他已。便往儿所。是时婴儿。为其父母。而说颂曰

  家中凡所有　　广大诸财谷
  速持来见与　　供佛及声闻
  彼大声闻众　　照世胜观尊
  三界围轮中　　都无与等者
  彼大声闻众　　照世胜观尊
  广阐扬妙法　　利益诸群品
  彼大声闻众　　照世胜观尊
  身具三十二　　大丈夫威相
  彼佛声闻众　　犹如乌昙花
  名称甚难闻　　过亿拘胝劫

舍利子。时儿父母闻是法已。即取家中二十拘胝上妙财宝。将至儿所而语之言。此诸财宝。是汝父母所有之物。汝当取之随汝志意生信之所任持奉施。尔时父母。即为是儿。而说颂曰

  此是汝父母　　所致诸财宝
  随心所敬信　　汝当持布施
  若金若珍宝　　家中甚丰积
  随心所敬信　　汝当持速施
  衣服坐卧具　　花鬘及涂香
  随心所敬信　　汝持欢喜施
  于佛及法僧　　无上福田所
  为利诸群生　　当应行布施

舍利子。尔时婴儿。闻其父母所说颂已。复为父母。而说颂曰

  我今往胜观　　世间依怙所
  当广设供养　　为利群生故
  诸有欲希求　　天上人中乐
  应随我所诣　　胜观如来所

舍利子。尔时婴儿。以念正知观视四方。白父母曰。父母当知。我今应往薄伽梵胜观如来应正等觉所。于是众人闻是语已。皆大惊愕。云何婴儿当初生日。便能与人往返言议。又能徙步有所造诣。时有八万四千众生。闻是奇异皆来云集。而作是言。我等当观此婴儿者。是何等类。为天。为龙。为药叉耶。乃至为毕舍遮人非人耶。舍利子。尔时婴儿。与诸大众八万四千前后围绕。往诣胜观如来所止之处。当此婴儿往佛所时。以福德力恐为风日所损弊故。于上空中十千宝盖。自然而现用覆其身。又于婴儿所由之路。虚空之中罗布金网。雨上妙花及细末香超胜诸天。常所散者。扇清凉风与天香合。周流飘散相续不断。虚空诸天又于行路。以诸香水而用洒之。覆以金罗种种珍服。又彼诸天雨花布道。光彩相曜积齐于膝。于其道侧无量百千清净池沼自然出现。八功德水具足盈满。生诸妙花。所谓殟钵罗花。钵特摩花。拘贸陀花。奔荼利花。含发鲜荣弥满池内。又有凫雁鸳鸯异类众鸟游戏水上。舍利子。时彼婴儿所由之路。七宝栏楯以界道侧。诸天伎乐具无量千深远妙音。自然而发。左右宝树行列庄严。于大道中复施花路。现于身前为供养故。以待婴儿游履其上。于其花路承步诸花。举足之时自然隐没。及将下足花便踊现。尔时婴儿游此花道。经须臾顷。即便回顾观诸大众。说伽他曰

  汝等无理不应行　　异我此路余非理
  而我常游此正理　　故往有理最胜处
  超过无量那庾劫　　时复一福遇人身
  时有一佛出世间　　时勤修得净信慧

舍利子。尔时婴儿。为诸大众说伽他已。于虚空中。有八万四千诸大天子。同声赞言。善哉善哉。便说伽他。赞婴儿曰

  善哉善哉大智慧　　汝所宣说会正理
  仁者后顾为无理　　有正理者当前趣

舍利子。尔时婴儿。又以伽他。报诸天曰

  汝诸天等所宣说　　有理无理之正言
  我今问汝汝当答　　有理无理之实义

舍利子。尔时诸天。复以伽他。报婴儿曰

  若乐欲住诸财宝　　不乐出离所行处
  如是无理诸凡愚　　安住地狱之前道
  若乐舍家趣非家　　当应舍欲弃财宝
  是人于世有正理　　不久便开解脱门

舍利子。尔时婴儿。复以伽他。报诸天曰

  如汝所说理无理　　观汝全未能明晓
  如是有理无理义　　我深于此正开悟

舍利子。尔时婴儿。说是语已。即便前进趣薄伽梵毗钵尸如来应正等觉大会之所。既到彼已顶礼佛足右绕三匝却住一面。于薄伽梵胜观如来。深生敬仰。即以伽他。而赞颂曰

  常行利益诸世间　　胜观三明施甘露
  如大龙象大师子　　由是我今常敬礼
  世间明照甚难得　　犹如乌昙跋罗花
  为世依怙作光明　　形色微妙甚圆具
  世间众苦所逼迫　　不能了知真圣道
  踰越正路而逃迸　　譬等生盲处于世
  愿我此世当成佛　　如今胜观人中尊
  当拔众生无量苦　　及救三火烧然者
  如是无边百千众　　皆随我来至于此
  唯愿演宣微妙法　　悉令安住上菩提

舍利子。尔时婴儿。说是颂已。白胜观如来应正等觉言。世尊。愿我来世于此世间。当成如来应正等觉。为诸众生显扬正法。亦如今者胜观如来。为诸大众广说妙法。尔时会中有八万四千众生。复白胜观如来言。世尊。我等亦愿于当来世。得成如来应正等觉。为众生故显扬正法。亦如今者胜观如来等无有异。尔时胜观如来应正等觉。了知如是八万四千人增上意已。即便微笑。舍利子。诸佛法尔于微笑时有种种光青黄赤白红颇胝色。从佛面门自然而发。遍照无量无边佛之世界。上至梵世。映蔽一切日月光明。其光遍照所应作已。而复还来右绕胜观如来。百千匝已。从薄伽梵顶髻而入。舍利子。尔时胜观如来有一侍者。睹佛神变现微笑已。从坐而起偏覆左肩。以右膝轮安处于地。向佛合掌曲躬礼敬。即于佛前以颂问曰

  我今问佛胜观尊　　端严希有生众喜
  何等因缘大善逝　　现发微笑世间依
  两足世尊现微笑　　其相非无有因缘
  愿演微笑因缘本　　利益世间悲愍故
  今有百千拘胝众　　现住牟尼世尊前
  摄耳专注乐听闻　　愿世间依愍众说
  佛为一切众生眼　　为舍为救为归趣
  能断众生诸有疑　　怜愍世间利益者
  如来善知诸过去　　又能通达彼未来
  于一切法不生疑　　及以现在诸佛土
  通智法王论自在　　出过三世妙如来
  我今请问世间依　　何等因缘现微笑
  佛能永断他疑网　　于一切法自无疑
  八音畅宣微妙法　　善拔众生忧毒箭
  我心喜踊难陈说　　合十指掌怀恭敬
  敢问法主大圣尊　　何等因缘现微笑

舍利子。尔时胜观如来应正等觉。告侍者曰。苾刍。汝今见是婴儿在我前不。对曰唯然。我今已见。胜观佛言。此婴儿者往昔过去。曾于六十四拘胝那庾多百千佛所。供养恭敬尊重赞叹。以诸衣服饮食卧具病缘医药及余资物。持用奉施彼诸佛已。为欲趣向三菩提故。又于过去十那庾多佛所。修行梵行。回向阿耨多罗三藐三菩提。苾刍当知。今是婴儿所将大众八万四千。于过去世。并是婴儿本生父母。何以故。此婴儿者。曾于过去发如是愿。愿我经生在在处处所有父母皆令安住于佛菩提。又令诸母更无第二再受女身。由是愿故。彼诸众生至于今日。随逐婴儿来至我所。又随修学发于无上正等觉心。尔时胜观如来。欲重宣此义。为侍者苾刍。而说是颂

  苾刍当观此婴儿　　及现前住多千众
  其心踊跃发诚言　　愿我当来如法主
  当知曾于过去生　　如上数量诸佛所
  恭敬供养大导师　　利益天人世间者
  于十那庾诸佛所　　依佛舍家持正法
  常行最胜之所行　　为求无上菩提故
  汝观八万四千众　　今现皆住如来前
  曾于久远过去世　　悉是婴儿之父母
  又此婴儿曾发愿　　诸有生生父母者
  普令安住上正觉　　更不重受女人身
  彼皆随学婴儿行　　发菩提心于我所
  今我皆当授彼记　　方将为世两足尊
  由此因缘现微笑　　彼昔胜行我能知
  及以未来诸所作　　当证人中大圣主
  诸天龙神及人等　　无量百千那庾多
  闻佛为彼授记已　　于胜观尊生大喜

舍利子。尔时婴儿闻佛授记。心生欢喜踊跃无量。悦意泰然得未曾有。速疾往诣其父母所。说伽他曰

  如是多千众　　我前生父母
  皆已住菩提　　父母心何趣

舍利子。尔时父母。复以伽他。报其子曰

  如子志所趣　　我心亦如是
  当成一切智　　此决定无疑
  子已生我家　　愿后勿相舍
  常当忆念我　　令速证菩提

舍利子。尔时婴儿。复以伽他。报父母曰

  我诸行化导　　皆愿先成佛
  最后我当成　　照世人调御

舍利子。汝今当观彼过去世胜观如来法中婴儿者。岂异人乎。勿作余疑。今大自在天子是也。从是已后。又经拘胝那庾多劫更不退堕。过是劫后生转轮王圣种族中。彼当来父号曰名称。如我今父净饭大王。彼当来母号曰离暗。如我今母摩诃摩耶。彼当来子号曰无忧。如我今子罗睺罗。舍利子。彼既出家悟菩提已。得成为佛。名曰大悲如来应正等觉十号具足。其佛寿量满百千拘胝岁。佛身常光遍照所及十踰缮那。佛说法处大会充满百踰缮那。大悲如来处世教化。为度声闻三会说法。第一大会度诸弟子有百拘胝。第二大会度诸弟子有那庾多拘胝。第三大会度诸弟子有百千那庾多拘胝。舍利子。其弟子中满一拘胝。皆是大阿罗汉。诸漏已尽无复烦恼。得自在慧具八解脱。成就静虑及六神通。舍利子。大悲如来所度声闻阿罗汉众。如上所说三会数量。彼菩萨众其数亦等。皆是往世所生父母。彼佛世尊宣说妙法利益无数诸众生已。然后涅槃。佛灭度后正法住世满拘胝岁。分布舍利饶益众生。亦如我今般涅槃后。流布供养等无有异。舍利子。安住正勤菩萨摩诃萨亦复如是。修行毗利耶波罗蜜多时。为求阿耨多罗三藐三菩提故。能于是经修行正行。倍增振发勇猛正勤大精进力。度脱无量诸众生等。我说是人为善丈夫思觉观察不倦不退。勇猛精进明系在心。舍利子。云何菩萨摩诃萨不倦精进

舍利子。菩萨摩诃萨为众生故求菩提时。不应限以数量而有所求。何以故。菩萨摩诃萨。不作是念。于尔所劫我当流转。于尔所劫我不流转。以如是故。菩萨尔时被难思铠。处于生死。作是念言。假使如我前际所经。生死如是更受勤苦。经于生死倍过前际。为求菩提中无懈息。舍利子。菩萨摩诃萨。具足如是坚固弘誓。则名成就不倦精进

复次舍利子。菩萨摩诃萨。云何修行勇猛精进。舍利子。假使三千大千世界。满中炽火。发起勇猛正勤。菩萨摩诃萨。为欲往觐彼如来故。以精进力于是炽火从中而过不怯不退。又舍利子。勇猛正勤菩萨摩诃萨。为求听闻大菩萨藏微妙法门故。以精进力虽逢是火。从中直过而无怯退。又舍利子。假使三千大千世界满中炽火。勇猛正勤菩萨摩诃萨。为欲宣说大菩萨藏深妙法故。以精进力于是炽火。从中直过而无怯退。又舍利子。假使三千大千世界。满中炽火。勇猛正勤菩萨摩诃萨。为欲生起善根因缘。以精进力于是炽火。从中直过而无怯退。又舍利子。假使三千大千世界。满中炽火。勇猛正勤菩萨摩诃萨。为欲利益诸众生故。以精进力能于中过。如是为欲令他得寂静故。得调伏故。虽逢是火。皆由中过而无怯退。又舍利子。发起勇猛不倦正勤。菩萨摩诃萨。为欲令他般涅槃故。以精进力虽逢是火。能于中过而无怯退。舍利子。是名菩萨摩诃萨修行毗利耶波罗蜜多勇猛之相

复次舍利子。发起勇猛不倦正勤菩萨摩诃萨行毗利耶波罗蜜多时。由不懈倦。坚固不退。善根所发无上大悲之所熏故。恒发勇猛大精进力。于诸众生常行化导。又舍利子。如是发起勇猛不倦正勤菩萨摩诃萨。于一切时举足下足。常不舍离大菩提心。于佛法僧恒生珍敬。系念在前。于诸众生恒遍观察为利益故。不欲令被烦恼势力之所逼夺。又舍利子。发起勇猛不倦正勤菩萨摩诃萨。所有已生诸妙善根。一切回向无上菩提。令此善根毕竟无尽。譬如少水投于大海乃至劫烧中无有尽。舍利子。菩萨摩诃萨。亦复如是。以诸善根回向菩提亦无有尽。是名菩萨摩诃萨勇猛不倦大精进力。又舍利子。勇猛不倦精进菩萨摩诃萨。以平等行积集善根。于诸众生起平等行。积集善根。为欲引生一切智智积集善根。为欲利益诸众生故积集善根。舍利子。如是无量诸大善根。皆是菩萨摩诃萨勇猛无倦大精进力之所集起

复次舍利子。如是勇猛不倦正勤菩萨摩诃萨。常应精进修学是法。所得福聚无量无边。今当广说福聚之相。舍利子。我观世间一切众生所有福聚无量无边。如是乃至一切有学无学所有福聚。一切独觉所有福聚。转复无量不可思议。如上所有诸福聚等。假使皆悉内置众生一毛孔中。如是众生一一毛孔。皆有如上福德之聚。无量无边不可思议。如是假使一切众生一切毛孔所有福聚合集置一无关键会大法祠中。舍利子。如是法祠功德福聚。倍增于百。感得如来大丈夫身色相之一。如是一一大丈夫相。皆以如是功德所成。如是一切如来身中大丈夫相。所有福聚皆合成一眉间毫相。如是入一眉间毫相福聚。又过于此满百千倍大功德聚。合成如来顶上无能观见乌瑟腻沙大丈夫相。如是入一肉髻大功德聚又过于此满于拘胝百千倍大功德聚。合成如来大法商佉之相。舍利子。由此如来大法螺相。为无量种功德集成。以如是故。如来随所意欲出大音声遍告无量无边一切世界。为诸有情广说妙法。如其根性随闻信解悉令欢喜。何以故。皆由精进所修学故。舍利子。菩萨摩诃萨应作是念。如是无上正等菩提。虽极难得。我当不舍精进铠甲。发大勇猛必定速悟无上菩提。不足为难。既成佛已随我意欲。于法螺相出大音声。遍告无量无边一切世界。为诸众生说微妙法。随根信解皆令欢喜。舍利子。是名菩萨摩诃萨勇猛无倦正勤之相

复次舍利子。勇猛无倦精进菩萨摩诃萨。依毗利耶波罗蜜多故。常应如是精进修学。由修学故具足成就一切智慧。舍利子。假使三千大千世界所有众生一切成就随信行智。即用此智。欲以比一成就随法行智。百分不及一。千分不及一。百千万分不及一。僧佉分不及一。迦罗分不及一。伽拏那分不及一。乌波摩分不及一。乌波尼沙陀分不及一。复次舍利子。假使三千大千世界所有众生一切成就随法行智。欲以比一第八人智。百分不及一。乃至乌波尼沙陀分不及一。复次舍利子。假使三千大千世界所有众生一切成就第八人智。欲以比一预流果智。百分不及一。乃至乌波尼沙陀分不及一。复次舍利子。假使三千大千世界所有众生一切成就预流果智。欲以比一乃至一来向智。如是一来果智乃至欲比不还果智。如是乃至欲比阿罗汉智。若独觉智。若过百劫菩萨智。若成就不退转菩萨智。如是乃至欲比系属一生菩萨智。皆应广说。无量无边算数譬喻所不能及。如是舍利子。假使十方无量无边一切世界所有众生。皆悉成就系属一生菩萨之智。欲比如来十力之一处非处智。百分千分百千万分不及一。僧佉分不及一。迦罗分不及一。伽拏那分不及一。乌波摩分不及一。乌波尼沙陀分不及一。乃至算数譬喻所不能及。舍利子。是菩萨摩诃萨。行毗利耶波罗蜜多故。闻如来如是甚深智解之时。其心不惊无有怖畏。于是智人生乐欲心。发起正勤中无废舍。作如是念。我今修行勇猛精进。假使我身皮肉骨血筋脉髓脑。皆悉枯燥烂坏无遗。未得如来如是处非处智力已来。于其中间发大勇猛坚固精进终无懈废。舍利子。是名菩萨摩诃萨勇猛无倦正勤波罗蜜多坚固之相。应如是学。复次舍利子。菩萨摩诃萨。行毗利耶波罗蜜多故。发大勇猛无倦正勤。常应如是精进修学。由修学故。能灭众生诸烦恼火。舍利子。假使一切众生。于过去世所有诸心。皆入众生一心中转。如是众生一一诸心。乃至一切众生一一各有尔所诸心。无量繁杂难可了知。如是一切众生一一心中。各具无量贪嗔痴等诸惑繁杂。以此一切众生所有烦恼。皆入一众生一心中转。舍利子。假使展转一切众生。皆具如是无量烦恼。难可了知。菩萨摩诃萨。作如是念。我当策励勇猛发勤精进。寻求如是智慧资粮。随我所发正勤之力。于诸众生贪嗔痴火及余热恼我要当令息灭无遗。斩除毒害。摧破散坏同于灰烬。速令众生住涅槃道。舍利子。是名菩萨摩诃萨勇猛无倦正勤波罗蜜多。应如是学

复次舍利子。菩萨摩诃萨。依毗利耶波罗蜜多故。安住勇猛无倦精进。常应如是正勤修学。以修学故。诸善身业无有休废。诸善语业无有休废。诸善心业无有休废。乃至所有一切正勤。皆为方便策进菩萨身语心业。舍利子。然诸世间但说菩萨身语二业精进。第一不说菩萨心精进相。舍利子。菩萨摩诃萨。心精进相无量无边。吾今略说。何等名为心精进相。谓菩萨心修行正勤若进若止。如是为相。舍利子。云何名为正勤进止。舍利子。菩萨修行大精进者。为菩提故勤行精进。所言进者。于诸众生发起大悲。所言止者谓无我忍。所言进者摄诸众生。所言止者于法不取。所言进者生死无倦。所言止者不得三界。所言进者一切尽舍。所言止者不厌布施。所言进者摄取净戒。所言止者不厌尸罗。所言进者堪忍众苦。所言止者心无毁坏。所言进者起诸善法。所言止者心常远离。所言进者摄受静虑。所言止者心常寂灭。所言进者闻法无厌。所言止者如理善巧。所言进者听说无倦。所言止者无戏论法。所言进者求慧资粮。所言止者断诸戏论。所言进者增长梵信。所言止者真知行舍。所言进者具五神通。所言止者遍知漏尽。所言进者修诸念处。所言止者念无功用。所言进者正断方便。所言止者善恶俱舍。所言进者引发神足。所言止者任运作用。所言进者诸根善权。所言止者观非根性。所言进者摄受诸力。所言止者智无制伏。所言进者生菩提分。所言止者智简择法。所言进者求道资粮。所言止者无来往性。所言进者求奢摩他。所言止者心住寂止。所言进者资助胜观。所言止者伺察法性。所言进者随觉诸因。所言止者诸因遍智。所言进者从他闻音。所言止者如法修行。所言进者谓身庄严。所言止者谓法性身。所言进者谓语庄严。所言止者圣默然性。所言进者信解脱门。所言止者无有发起。所言进者远离四魔。所言止者舍烦恼习。所言进者方便善巧。所言止者观察深慧。所言进者观察缘境。所言止者无功用观。所言进者观察假名。所言止者了达实义。舍利子。诸如是等进止之相。是名菩萨摩诃萨唯心精进。若诸菩萨摩诃萨。闻如是等心精进相。应当发起勇猛无倦具足正勤。舍利子。如是名为菩萨摩诃萨修行正勤波罗蜜多无有厌倦勇猛精进修习之相

大宝积经卷第四十六大宝积经卷第四十七

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十三毗梨耶波罗蜜多品第九之三

复次舍利子。如是勇猛无倦正勤菩萨摩诃萨。成就五种增进之法。便能速悟阿耨多罗三藐三菩提。舍利子。何等名为成就五种增进之法。所谓值佛出世为增进法。得近善友为增进法。得具无难为增进法。随所修集一切善法永不失坏为增进法。于彼安住律仪菩萨摩诃萨所随从修学为增进法。舍利子。是为菩萨摩诃萨修行毗利耶波罗蜜多故成就五法增进不退速悟无上正等菩提

尔时长老舍利子白佛言。世尊。颇有菩萨于是五法而损减不。佛言有。曰何谓也。大德薄伽梵。何者是也。大德苏揭多。佛告舍利子。有五种法菩萨成就便能损减。何等为五。谓于佛世而不值遇。于彼善友不怀亲近。具无难法而不获得。修习善法多有失坏。于诸安住律仪菩萨心无随学。由具如是损减法故。亦不速悟无上菩提。舍利子。何等五法菩萨成就。舍利子。在家菩萨为王师傅。以威势力恐怖众生。致有缘务祈请威福。若为成办如是事者。重相酬谢。而是菩萨睹世利故。心无正直便为作之。凡所出言无非为利。舍利子。由如是法损减善道。由如是法损减无难。如是在家菩萨。为养身故行诸恶行。不值佛世。乃至不疾证于阿耨多罗三藐三菩提。舍利子。是名菩萨成就第一损减之法。复次舍利子。在家菩萨住毁城法。何等名为住毁城法。舍利子。若诸如来应正等觉。出现世间为诸天人魔梵说法。开示宣畅初中后善。文义巧妙纯一圆满清白梵行。尔时当有四众出现。所谓苾刍苾刍尼。邬波索迦。邬波斯迦。时苾刍尼。依附村城郊野馆舍国邑王都。为护戒故在中居止。彼诸在家菩萨。来是住处污其戒众。以毁戒故名住毁城。犯是事已不值佛世。乃至不能疾悟无上菩提。舍利子。是名菩萨成就第二损减之法

复次舍利子。在家菩萨见诸有依。善说法律演正法时。便于父母兄弟姊妹妻妾男女眷属及诸众生而为法障。舍利子。在家菩萨障碍法已。于长夜中自于法律常多障碍。不值佛世。乃至不能疾悟无上菩提。舍利子。是名菩萨成就第三损减之法

复次舍利子。在家菩萨闻佛经中如来赞说少欲知足出要相应独静山林离苦之法。心生不信轻毁诽谤。亦教他人起如是见。是诸在家不善菩萨。毁呰如来清净教已。还复沉溺可毁呰趣。何等名为可毁呰趣。谓堕地狱畜生焰魔世界。或生边地及蔑戾车恶邪见中。在家菩萨行是事故。不值佛世。乃至不悟无上菩提。舍利子。是名菩萨成就第四损减之法

复次舍利子。在家菩萨依止国王及诸大臣乃至富贵有自在者。行弊恶行恃为势力。讥诃毁骂轻蔑戏弄无量众生。舍利子。在家菩萨以成就此语恶行故。速能招集诸恶趣报。不值佛世。不遇善友。不得无难。失坏善根。不随安住律仪菩萨修学正法。不能速悟无上菩提。舍利子。是名菩萨成就第五损减之法。尔时世尊。欲重宣此义。而说颂曰

  菩萨成就五种法　　如是智慧无增长
  既不速疾见如来　　亦不逢事人中上
  或为王者大师傅　　欺诈诳惑诸众生
  由具如斯不善业　　不遇世间依怙者
  令多有情生怖畏　　若纳赃财若损害
  兴造如斯恶业已　　终不奉值人中尊
  或令诸尼净戒聚　　破坏摧灭生悲苦
  当离无量亿如来　　叵得成就诸无难
  于其父母妻子等　　障碍不令修法行
  又障听闻于正法　　速感愚痴覆蔽果
  若人厌世乐出家　　便致拘执缘留碍
  当离无量最胜尊　　叵得成就诸无难
  若有听闻如是法　　所谓赞说住空闲
  便生不忍忿恚心　　谤毁谓为非法说
  谤毁如是正法已　　常住生盲大剧苦
  一切重障罪业中　　方斯十六不及一
  彼难奉见诸如来　　设见不能怀信敬
  受女黄门生盲身　　又受驼驴猪狗等
  若有于佛及菩萨　　深生殷重爱敬心
  远离一切障碍已　　相续修行贤圣道
  父母妻子眷属等　　恒乐安勤正法中
  众生厌世求出家　　赞美劝助令其果
  若处眷属正法中　　当速往登贤善趣
  有能赞劝出家者　　速悟无上佛菩提

复次舍利子。出家菩萨。复有五法。若成就者。不值佛世。不亲善友。不具无难。失坏善根。不随安住律仪菩萨修学正法。亦不速悟无上菩提。舍利子。何等名为出家菩萨成就五法。一者毁犯尸罗。二者诽谤正法。三者贪著名利。四者坚执我见。五者能于他家多生悭嫉。舍利子。如是名为出家菩萨成就五法不值佛世乃至不获无上正等菩提。舍利子。譬如饿狗慞惶缘路。遇值琐骨久无肉腻。但见赤涂言是厚味便就衔之。至多人处。四衢道中以贪味故。涎流骨上妄谓甜美。或[齒*堯]或舐或啮或吮。欢爱缠附初无舍离。时有刹帝利婆罗门及诸长者。皆大富贵来游此路。时此饿狗遥见彼来。心生热恼作如是念。彼来人者将无夺我所重美味。便于是人发大嗔恚出深毒声恶眼邪视。露现齿牙便行啮害。舍利子。于意云何。彼来人者应为余事。岂复求此无肉赤涂之骨琐耶。舍利子白佛言。世尊。不也世尊。不也善逝。佛告舍利子。若如是者。彼悭饿狗以何等故。出深毒声现牙而吠。舍利子言。如我意解恐彼来人贪着美膳。必能夺我甘露良味。由如是意现牙吠耳。佛告舍利子。如是如是。如汝所言。当来末世有诸苾刍。于他施主勤习家悭。耽着屎尿妄加缠裹。虽值如是具足无难。而便委弃不修。正捡此之苾刍。我说其行如前痴狗。舍利子。我今出世怜愍众生。欲止息故专思此事。为如是等诸恶苾刍。说此譬喻

复次舍利子。是诸菩萨摩诃萨。为欲利益安乐无量众生故。求于佛智。行毗利耶波罗蜜多。彼诸菩萨摩诃萨。于己身肉尚行惠施。况复规求妄想恶肉。而于他家起诸悭嫉。舍利子。彼诸苾刍悭他家故。我说是人为痴丈夫。为活命者。为守财谷奴仆隶者。为重世财宝玩缚者。唯于衣食所钦尚者。为求妄想贪嗜恶肉起悭嫉者。舍利子。我今更说如是正法。彼诸苾刍先至他家。不应见余苾刍而生嫉妒。若有苾刍违我法教。见余苾刍或作是言。此施主家。先为我识。汝从何来。乃在此耶。我于此家极为亲密。调谑交顾。汝从何来辄相侵夺。舍利子。以何等故。彼悭苾刍。于后来者偏生嫉妒。舍利子。由诸施家许其衣钵饮食卧具病缘医药及供身等资生什物。彼作是念。恐彼施主将先许物施后来者。由如是故。即此苾刍。于施主家起三重过。一者起住处过。见余苾刍或起恨言。我于今者当离此处。二者凡所习近当言未知应与不应。三者于不定家。妄起诸过。舍利子。彼悭苾刍。于后来人发三恶言。一者说住处过。以诸恶事增益其家。令后苾刍心不乐住。二者于后苾刍所有实言。反为虚说。三者诈现善相谄附是人。伺有微隙对众治举。舍利子。如是苾刍。于他施家生悭嫉者。速灭一切所有白法。永尽无遗

复次舍利子。若有苾刍住家悭者。我说是人为不善者。则为弃舍菩提资粮。又为不能随逐安住律仪菩萨修正法者。又舍利子。如是种相。我更当说乃往昔时。过于无数广大无量不可思议阿僧企耶劫。有佛出世。名胜现王如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。彼佛住寿九十拘胝岁。声闻众会。九十拘胝那庾多。皆是大阿罗汉。诸漏已尽。乃至一切得心自在第一究竟。舍利子。当于尔时。有大长者名为善择。其家巨富多饶财宝。资产僮仆无不充遍。有二子。一名律仪。二名住律仪。年在幼稚。容貌端正。净色圆满。众人喜见。舍利子。时胜现王如来应正等觉。于晨朝时服衣持钵。大苾刍僧左右翼从。彼佛世尊。居僧上首。为福利故现乞食法。入彼长者所住大城。威仪庠序诸根寂定。心意恬怕逮得调顺奢摩他。及获第一调顺奢摩他。修摄诸根如大龙象。澄静无浊如深泉池。盛德巍巍如金楼观。色相超挺如紫金山。又如大海众宝充盈。如帝释主诸天围绕。如大梵王心虑寂静。舍利子。彼薄伽梵。有如是等威相庄严。长者二子。当于尔时。在重阁上。遥睹胜现王佛从远而来。容貌威严色像第一。发欢喜心叹未曾有。舍利子。彼住律仪童子。以先睹佛喜踊内心。白其兄曰。从生已来。兄颇曾见如是端严含灵王不。兄报弟曰。我从生来实未曾见。如是端严含灵中王。弟白兄言。如我惟忖。于未来世定当作是含灵中王。舍利子。尔时住律仪童子。即为其兄。而说颂曰

  如律仪兄今所见　　我于当来定如是
  大苾刍众所围绕　　当复倍胜于今日
  求菩提道因缘故　　当誓不啖诸饮食
  兄既乐居牢狱中　　我意决定当超胜
  如是一切众生尊　　譬等众星之满月
  谁有见斯不生信　　而乐居家不出离

舍利子。尔时律仪童子。即以伽他。报其弟曰

  弟当且止勿高声　　非但语言便遂事
  我岂当发世语言　　试谁在先成正觉

舍利子。尔时住律仪童子。复以伽他。白其兄曰

  如是无上菩提道　　非但弊鄙悭心证
  我当发大贤善声　　决定成佛人中上
  夫怀悭者相如是　　资产不欲令他知
  今我岂复守沉默　　尚舍身命况财宝
  我以家资咸布施　　为求菩提道因缘
  及以兄分家财宝　　尽施佛田深敬故
  谁见如是最胜尊　　具三十二妙相者
  而不发愿趣菩提　　唯除具诸下劣见
  所有家宅及财宝　　父母并诸眷属等
  我当一切皆舍离　　速往善逝如来所
  为世依怙作光明　　照世慈尊极难遇
  百千拘胝那庾劫　　如是胜相甚难闻
  我见世尊入王都　　大苾刍僧所围绕
  如盛满月在清天　　流光洞照诸依地
  我见世尊游四衢　　周遍庄严于一切
  犹彼具足千光日　　独满虚空常遍照
  我见世尊居众首　　庄严显发苾刍僧
  如彼苏迷卢山王　　映诸宝山悉严丽
  如来威光极炽盛　　通照此土诸群生
  圆成妙相两足尊　　荣光蓥饰诸大众
  如来住大神通力　　善御天龙非人等
  复兴无量种变现　　为众生故入王都
  谁见如斯正法主　　三十二相大庄严
  而复希趣下劣乘　　唯除不肖愚闇者
  我今欣睹人中尊　　发生难得清净信
  为利含识趣菩提　　要当往觐如来所

舍利子。尔时律仪童子。又以伽他。报其弟曰

  我于途路非懈怠　　而不速往如来所
  待我下斯重阁已　　当出外宇谛思惟
  宜应捐舍于我想　　又不顾惜吾身命
  及求最上丈夫智　　尔乃往诣如来所
  父母家宅及财宝　　于如是等生重爱
  我今一时皆弃舍　　尔乃往诣如来所
  若有欲愿当成佛　　又深爱乐如来者
  宜速捐诸珍宝聚　　舍离家法趣非家

舍利子。尔时住律仪童子。闻是语已。即于阁上下其阶道。将往胜现王如来应正等觉所。未至之顷。其兄律仪。又从重阁速疾而下驰诣佛所修敬已讫。时住律仪后乃方至。尔时律仪兄童子。即以十亿无价宝衣。奉献如来。又于佛前。而说颂曰

  我今不求于妙相　　奉施如来无价衣
  唯愿当来所获报　　如今世尊等无异
  一切含灵中最胜　　一切妙法善安住
  唯愿当来所获报　　如今世尊等无异
  具足无上智慧藏　　诸力正勤善安住
  三十二相身所持　　愿速当成人中上
  成就诸佛十种力　　四无所畏善安住
  唯愿当来所获报　　如今世尊等无异
  如佛所知真净法　　唯佛善住皆明照
  愿赐演通如是法　　令我速悟上菩提
  我今不求妙色相　　奉佛无价胜上衣
  唯希寂静妙菩提　　为利诸天世间故
  如来所住微妙法　　一切异论无倾动
  我今为求如是法　　敢施无价胜上衣
  诸法无生无老病　　亦无忧愁悲叹等
  愿为开斯寂静法　　导利诸天世间故
  若法无有贪嗔痴　　亦无诸慢及渴爱
  愿说菩提与佛性　　无为清凉甘露法
  若法如来所安住　　为天龙等深敬礼
  或有思虑或无思　　愿为开斯寂静法
  佛住是处能通照　　无量四方诸佛土
  如发大焰深暗中　　愿证如斯等甘露
  若诸一切爱无爱　　性常不依于欲界
  色无色界亦无依　　愿说如斯胜妙法

舍利子。尔时住律仪童子。闻兄律仪说是颂已。便以一具新妙宝屐。奉施胜现王如来。即于佛前。说伽他曰

  愿我当为诸群生　　为救为趣为依舍
  更不履践于邪径　　恒导群迷说正路
  愿常不习诸贪欲　　此乃愚夫之所行
  永离一切有为法　　恒值如来出兴世
  既逢明照世间者　　便应供养两足尊
  勤求无上佛菩提　　为利一切群生故
  当以无量香花鬘　　高妙幢幡诸宝盖
  奉献龙中之大龙　　为利一切群生故
  复以种种上衣服　　卧具饮食诸医药
  俱持奉献佛世尊　　为利一切群生故
  击大小鼓吹螺贝　　及奏箫管清歌等
  俱持奉献照世尊　　为利一切群生故
  厚味种种极淳浓　　世间微妙所珍尚
  俱持奉献救世尊　　为利一切群生故
  广行如是供养已　　利益无量诸群生
  我于尔时便出家　　精励勤修于梵行
  当安住斯八妙道　　复安无量亿众生
  愿我为诸有识依　　常不履于邪曲径
  众圣诃毁极下劣　　所谓淫欲我能捐
  又当弃捐诸放逸　　于不放逸恒修学
  愿我永不生众难　　常得生诸净信家
  生生常见人中尊　　见已于佛生深信
  既生信已修恭敬　　以妙花鬘及涂香
  种种音乐供养已　　为求诸佛深智慧
  如是广修诸供养　　乃经无量拘胝劫
  永断欲法舍居家　　精勤奉修清净行

舍利子。尔时住律仪童子。说是颂已。即于所赞胜现王如来之处。为彼如来。以赤栴檀建立道场。高花绮饰四踰缮那。纵广庄严备诸雕丽。尔时童子。既立道场庄严成就。即以奉施彼佛世尊。又于佛前。而说颂曰

  佛所安住四种住　　往昔最胜所称誉
  我今欣求如是住　　唯愿善逝慈哀许
  若有安住是所住　　心常了知无量众
  及知过去未来生　　我今欣求如是住
  若住是住至究竟　　四种正胜四神足
  及四最胜无碍辩　　我今欣求如是住

舍利子。尔时薄伽梵胜现王如来。哀此童子。受其所献上胜道场。与苾刍僧入中居止。时彼童子。既睹如来及苾刍僧受其施故。心大欢喜踊跃无量。又以种种上妙供具。而为供养。倍加恭敬尊重赞叹。于半月间中无断绝。过是已后。便于佛前除去须发。被袈裟衣。以净信心舍弃家法。趣于非家。专志精勤求诸善法。舍利子。时二童子求善法已。心正了知。于佛菩提俱发弘誓。其兄律仪作是誓言。愿我最先成等正觉。其佛名曰世间依怙放大光明。其弟住律仪者。又发誓言。愿我最先成等正觉。其佛名曰大导商主天人中尊。舍利子。尔时律仪童子菩萨摩诃萨。作是愿已。即于胜现王如来前。合掌而立大誓庄严。说伽他曰

  我当不复更安坐　　亦无放倚身眠卧
  专精勤求菩提道　　为利一切群生故
  我当不观身与命　　常舍懒惰勤精进
  志求上妙菩提道　　为利一切群生故
  假使血肉都干竭　　皮骨筋脉皆枯燥
  要舍懈怠及身命　　精勤为趣上菩提

舍利子。尔时住律仪童子菩萨摩诃萨。闻兄律仪童子菩萨摩诃萨发是愿已。欢喜踊跃。即于其前。说伽他曰

  今当共契同和好　　修行无上菩提行
  与发最胜勤精进　　为利一切群生故
  我今薄济于身命　　随彼血肉皆枯燥
  发千精进随兄学　　为求无上菩提故
  我当独处住空闲　　山野林中勤精进
  常求微妙最胜智　　随住庄严大法王

尔时佛告舍利子。彼过去世。胜现王如来法中。律仪童子菩萨摩诃萨。与住律仪童子菩萨摩诃萨。于彼佛所发大弘誓。行毗利耶波罗蜜多故。精勤不懈。修行正道。舍利子。彼二菩萨行精进时。于千岁中。乃至未曾如弹指顷。被于睡眠之所逼夺。于千岁中未曾起念欲卧息心。于千岁中未曾起念欲乐坐心。于千岁中未曾一返屈身蹲踞。唯除便利若食饮时。便就住立。于千岁中未曾再食。日止一食。食止一搏。饮水一器。于千岁中未曾起念欣乐食心。如谓我今极为饥渴。愿当疾得如是等念初无有生。于千岁中未曾一返过量饮啖。于千岁中未曾起念称量饮食。此碱此淡。此甘此苦。辛酢美恶初无兴虑。于千岁中每乞食时一心正念。未曾观彼授食人面。不生是念。谁与我食。为丈夫耶。为妇人耶。乃至童男童女。皆不瞻视。于千岁中居止树下未曾仰面观于树相。于千岁中所著衣服未曾再易。于千岁中未曾一念起于欲觉恚觉害觉。于千岁中未曾起念缘亲里觉。若父若母兄弟姊妹及余眷属皆不缘念。于千岁中未曾起念。于所居家发思觉心。于千岁中未曾起念仰观虚空日月星宿云霞等色。于千岁中未曾起念以身依倚若壁若树。于千岁中未曾起念以诸苏油用涂支体。于千岁中未曾起念身心惊怖。于千岁中未曾起念身心疲倦。于千岁中未曾起念懈怠懒惰放逸之心。唯兴是念我今修行阿耨多罗三藐三菩提。何时当证。何时当得。于千岁中未曾一返身心痛恼。于千岁中未曾起念我欲剃发。唯除四天大王。时来头上。以其神力手摩持去。于彼天宫起窣堵波。众宝庄严而为供养。于千岁中虽有天王若来若去而心都无去来之想。于千岁中未曾起念。从阴影处至光景处。从炎热处至清凉处。于千岁中于严寒时未曾起念覆厚暖衣而取温适。于千岁中未曾起念论说世间无益之语。舍利子。是二菩萨。于千岁中行如是等坚固精进时。有恶魔名愚痴念。如我今者出现世间。有恶魔罗愚痴念者。舍利子。彼时恶魔兴坏乱故。于律仪菩萨所经行道。仰布利刀遍其行处。尔时律仪菩萨。于彼刀道微失本心。生利刃想。适生想已便即追悔。发大音声再返唱言。咄哉奇事。我今如何住于放逸。舍利子。时彼菩萨所发音声。遍告三千大千世界。于上空中。有百千拘胝天魔徒党。闻是菩萨忆念音声。即共同时语菩萨言。如汝今者普告之声。深为善说深为善说。舍利子。如是天声唯律仪闻。彼住律仪。于诸天声及此菩萨。普告大声初不闻之。尔时律仪菩萨。闻天语已。奋发坚固大精进。欲复前经行。再转其心不缘刀刃。舍利子。时彼菩萨摩诃萨。降魔怨已。住如是威仪。行如是妙行。修如是道迹。起如是大悲。兴发如是勇猛精进。未曾休废。复次舍利子。彼二大士。于彼法中。行毗利耶波罗蜜多故。俱成就是威仪行迹大悲勇猛。又于千岁住空闲林。修佛随念。过是已后。胜现王如来。方入涅槃。尔时诸天。便来告曰。善男子。岂不知耶。如来今者已般涅槃。时二大士。既闻天告。即便往诣胜现王如来涅槃林所。既到彼已合掌而立。瞻仰如来目未曾舍。极怀恋慕深生敬重。作是念言。如来出世大慈悲者。覆护众生同于舍宅。如何一旦速般涅槃。令我等类无依无怙。舍利子。是二大士。立如来前深怀恋仰。七日七夜足不移处。不胜哀感遂立命终。往生梵世。既受梵身得宿智力。以大神通从上来下。至涅槃会。为胜现王如来应正等觉。所有舍利起窣堵波。珍宝妙物极世庄严。四十千岁方得成就。以诸轮盖安施其上。舍利子。时二菩萨。为彼如来。起窣堵波已。心大欢喜合掌而立。观其福相倍加欣庆。如是又经七十千岁。方始致礼。因尔命终。俱生赡部洲中大转轮王家。处太后胎。舍利子。彼初生已。便忆过去所经诸事。作如是言。我于今者应当安住最上第一不放逸法复以伽他。而自诫曰

  我今生处轮王家　　广大财食皆如意
  于极放逸当捐舍　　勤求无上佛菩提
  财宝色欲及王位　　无常迅速须臾顷
  智者于斯不欣乐　　勤求上妙佛菩提
  若于财宝不生乐　　为利含识证菩提
  应疾舍欲求出家　　修行胜妙诸梵行
  我昔过去无量劫　　耽滞五欲为功德
  若生天上及人中　　未曾于彼生知厌
  故应舍欲及王位　　父母眷属诸财宝
  及舍国城大军众　　出家勤求证菩提

舍利子。时彼菩萨身相端正。如十六少童不乐俗网常思过患。即剃须发服袈裟衣。以清净信弃舍家法。趣于非家。二十千岁勤修梵行。后命终已复生梵世。于彼寿尽还生赡部。舍利子。当于尔时。于赡部洲有佛出世。名曰妙香如来应正等觉明行圆满善逝世间解无上丈夫善调御士天人师佛薄伽梵。时彼菩萨既遇佛已。即于法中剃除须发。服袈裟衣。以清净信弃舍家法。趣于非家。满拘胝岁修行梵行。如是次第。十千如来出现于世律仪菩萨皆得值遇。于诸佛所殖众德本。常勤精进修行梵行。彼住律仪菩萨。常与其兄同生一处。修诸圣道。唯于一佛不修梵行。以是因故。律仪菩萨先得成佛。出现于世。名曰炽然精进如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。住世教化。经九十拘胝岁。声闻大众有九十那庾多。共会说法。舍利子。炽然精进如来兴世之时。彼住律仪菩萨。为转轮王威加四域。福德所被。于炽然精进如来。极起深信。以种种上妙衣服肴膳饮食病缘医药什物众具。供养恭敬尊重赞叹。于三月中。奉献彼佛及苾刍僧。舍利子。尔时炽然精进如来应正等觉。虽受供养为欲觉悟彼轮王故。令其忆念。说伽他曰

  若为证得诸佛法　　勇猛精进最为上
  贪着五欲诸含生　　凡有所求难果遂
  若求义利于五欲　　智者当知无义利
  汝今处在无义中　　求胜义利不可得
  我昔与汝为兄弟　　俱发弘誓趣菩提
  尔时竞列至诚言　　谁速在初成正觉
  今汝见我证菩提　　转胜梵轮于大众
  汝犹沉溺五欲家　　淫荒女色恒守护
  过去诸佛常宣说　　智者不应保弊欲
  是故我恒勤远离　　曾未追求行放逸
  汝摄恶慧行无义　　汝常安住无义业
  欲法引苦汝长迷　　离欲清净圣所赞

舍利子。时彼轮王闻炽然精进如来说伽他已。生大觉悟。深见欲过。希求出家。竟不辞诸妻子眷属长者僚宰大小诸王。亦不顾恋国邑人民财宝府藏。即从座起。往如来前。一心合掌。说伽他曰

  我当悉舍于家国　　要往空闲至命终
  宁使肌肉并干枯　　为佛菩提因缘故
  复当勇猛大精进　　利益无量诸群生
  弃舍家法趣非家　　当住虚静无为处
  不欣缘附于五欲　　弊恶诳惑彼愚夫
  由我陷没欲泥中　　故使掩面而随后
  诸欲财宝及王位　　一切一时皆弃舍
  即于如来圣教中　　专务精修无上道
  谁有智者当亲附　　谁行学藏有为行
  令我修行精进已　　不速成佛耽诸欲
  是故我舍诸欲乐　　王位财宝皆除断
  要归佛教趣非家　　为佛菩提因缘故

舍利子。尔时轮王说伽他已。即于炽然精进佛所。剃除须发服袈裟衣。以净信心弃舍家法。趣非家道。住空静处勤修梵行。于时复有六十拘胝百千众生。闻彼轮王出家学道。亦怀净信除舍俗相。随王出家修诸梵行。舍利子。时炽然精进如来。处世垂化久乃涅槃。轮王苾刍见佛灭度。悲感充塞。奉接如来遗身舍利。起窣堵波严饰供养。其后不久便致命终。生睹史多天。受天报尽。还生赡部洲中。即于是劫。成阿耨多罗三藐三菩提。名曰妙行如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。其佛住世满拘胝岁。声闻弟子。有拘胝那庾多。而共集会。皆是大阿罗汉。诸漏已尽。乃至一切心得自在。已到究竟第一彼岸。妙行如来。安住百千菩萨摩诃萨。令于阿耨多罗三藐三菩提。不复退转。又为无量无数诸众生等。宣扬妙法所应作已。入般涅槃。正法住世经余一劫。流布舍利饶益众生。亦如我今般涅槃后舍利广流等无有异

尔时佛告舍利子。诸菩萨摩诃萨。行毗利耶波罗蜜多故。安住正勤行菩萨道。应当依随律仪菩萨摩诃萨。修学勇猛无倦精进波罗蜜多。不应依附彼枯骨琐住悭众生而为修学。舍利子。若有菩萨乐求菩提。不应他家而生悭吝。若复失念起悭吝时。应乐观察三种怖畏。何等为三。谓于他家数致来往。或因乞食或复谈话。缠绵不已遂成亲好。见彼第二贤善苾刍。以贪着故便生悭嫉。或时微起一念恚心。不相随顺。由是缘故当知摄受地狱诸苦业道。当知下生盲种于其心田。当知生边地业具足摄受。舍利子。我今为汝更说其相。谓彼菩萨。见诸贤善清净苾刍来至其所。辄生嫉妒嗔恚之心。内虽忿结而外现清白。与交言论。心乃悭吝。而身恒将遇随事供拟。或私处隐屏。怒眼视之。或以不实事用加诬谤。舍利子。以是因缘。如是菩萨当知摄受地狱业道。生盲种子。植其中心。虽生人道复在边地。遭诸苦楚。受生盲报。多被诽谤。为他役使。昼夜辛勤初无停息。舍利子。若诸菩萨设于他家起悭嫉时。应思惟此三种怖畏。尔时如来说是语已。长老舍利子白佛言。甚奇世尊。未曾有也。是诸菩萨摩诃萨。极为希有。乃能善遇如来说是家悭出要之法。善哉世尊。愿为我等诸声闻众。说正法要离家悭相。所以者何。我等于佛法中。非为不愿脱于地狱生盲边地诽谤果报。常愿生于中国人趣。我等声闻。深欲乐闻离家悭法。唯愿世尊。舍无缘怨。不舍我等。必为宣说

尔时。佛告舍利子。善哉善哉。舍利子。甚为希有。汝等乃能住无浮谄。请问如来如是之义。谛听谛听当为汝说。舍利子。若有众生。欲随如来修学佛法。我当为彼如应显说。何以故。以诸众生能随佛学。如来不违彼意必现其前而为说故。又舍利子。若有众生。不乐随佛修学正法。若为彼说是人闻已。则当成立斗诤根本。舍利子。如是成就净信菩萨摩诃萨。行毗利耶波罗蜜多故。于诸佛法广生净信。长久大夜常乐观察。为欲救济沉溺众生故。往如来所。殷勤郑重咨疑问义。凡所敷演乐欲听闻。既闻法已。复获广大清净深信。欢喜踊跃倍加精进。受持正法如说修行。又舍利子。当来之世。我诸弟子少有苾刍。深心希乐趣般涅槃寂静之法。多依三事以为常业。何等为三。一者常喜追求世间名利。二者贪乐朋党追求食家往还不绝。三者喜乐追求花饰房宇。贮积财富什物资具。是名依止追求三事。舍利子。是诸苾刍。以依如是三种事故。终不解脱三种恶趣。舍利子。如是苾刍。不乐解脱地狱傍生焰魔鬼趣。而返喜乐。勤修灭尽趣天道法。又常勤修相言斗讼讥刺离间诤论之事。复乐摄受心不净信诸恶友等。舍空静林依泊村落。白衣俗人而为朋翼。舍利子。诸在家者作如是言。如是长老数来我家。与我同好。我当供给。施其衣服饮食卧具病缘医药诸余资具。彼住空闲。诸长老等。既于俗人素无周接。我等如何与之言问。以此事故。是诸苾刍。与在家者转相亲狎。更互谈说。但叙世事繁杂戏论。舍利子。是恶苾刍。乐共无良之人。同止游涉。久着住处。曾无移转。多觅朋党及多食家。数数瞻视躬行庆吊。由此事故密怀亲爱。设有客苾刍来都无供给。先行毁呰非法之言。而客苾刍实是贤圣。是恶苾刍亦不称说。汝为多闻具戒清净。汝是预流一来不还阿罗汉果。如是等言全不称说。舍利子。是恶苾刍。在我法中。不修我法。更无余事。唯乐毁呰诃骂不息。舍利子。彼诸俗人。为朋党者又作是言。诸客苾刍。未曾与我共住。久处周旋还往。旧住苾刍与我久住情事相委通致使命。经理缘务。以是义故。我当与诸旧住苾刍。共相护吝假为威势。舍利子。以是等故。诸恶苾刍。于是经典若解不解。一切时中。皆悉诽谤毁呰不信。又舍利子。若复有人听闻如来所说经典。如是文句差别法门常乐听闻。闻便信解无疑惑者。必能舍离如是众生。及舍应往恶趣之业。如是舍利子。修行无倦精进。菩萨摩诃萨。听闻如是悭嫉等相往恶趣业。既闻是已。便不自行家悭等事。况复为他开示此法。舍利子。如是名为菩萨摩诃萨精勤无倦修行毗利耶波罗蜜多应如是学

大宝积经卷第四十七大宝积经卷第四十八

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二毗利耶波罗蜜多品第九之四

复次舍利子。菩萨摩诃萨。精勤无倦修习毗利耶波罗蜜多时。于诸众生起病者想。何以故。一切众生常是病者。恒为三种热恼所烧恼故。舍利子。何等名为三种热恼。所谓贪欲热恼。嗔恚热恼。愚痴热恼。菩萨摩诃萨作如是念。我等今者应以如是无上正法阿竭陀膏药。涂傅如是热恼众生。何以故。由是无上正法清凉微妙膏药用涂傅故。一切众生贪嗔痴等。诸热恼病皆悉除灭。舍利子。诸菩萨摩诃萨。以是正法良药。涂傅众生令三毒灭故。是菩萨摩诃萨。无倦正勤。修行毗利耶波罗蜜多。应如是学

复次舍利子。菩萨摩诃萨。修行毗利耶波罗蜜多。其相无量。我今当说。舍利子。菩萨摩诃萨。常作是念。所谓一切众生皆是病者。何以故。由为三毒常热恼故若有众生。生地狱者。亦为如是贪嗔痴等之所烧恼。如是生傍生者。焰魔世界人中天上。所有众生无不为是三毒烧恼。若有众生成疑见等诸烦恼者。亦常为于贪嗔痴等之所烧恼。舍利子。是诸众生具烦恼病。非余良医及胜妙药若涂若傅能令贪嗔痴等热恼静息。唯除如来无上胜妙大法医王。及证法身菩萨摩诃萨。以大愿力自严持身。为良药已。乃能除灭一切众生贪嗔痴等诸热恼病

复次舍利子。汝应解了如是法门。所谓一切众生贪嗔痴病非余医药而能差愈。唯有如来无上医王法身菩萨。以大愿力而得除灭。舍利子。于汝意云何。众生界多。地等界多。舍利子白佛言。世尊。如我解佛所说妙义。众生界多。非大地界。亦非水界火界风界所能比类。佛言。如是如是。如汝所说。众生界多。非大地界。乃至众生界多。非彼风界。舍利子。我今更说如是之相。舍利子。有诸众生身形微细。难可睹见。非佛法外诸神仙眼之所能及。亦非声闻独觉天眼境界。唯是如来清净天眼所能照了。舍利子。如来以净天眼。明见如车轮量。所有微细含识众生。其数无量。多于三千大千世界。于人天趣诸受生者。舍利子。如是无量无边诸有情界。乃至三千大千世界一切有情若卵生。若胎生。若湿生。若化生。若有色。若无色。若有想。若无想。若非有想非无想。若可见。若不可见。如是乃至所有假名建立诸有情界。设使于一刹那。或一罗婆。或一牟呼多顷。非前非后。皆得人身。彼诸人等并成良医。寿命一劫明练方术。通闲医道为大医师。善疗众病。皆如今者时缚迦医王。舍利子。彼诸医王同共集议。作如是言。有一众生怀贪嗔痴热恼之病。我为医王勤加功用。当为除灭。如是舍利子。设使彼等一一诸医。皆持清凉妙药。其量高广。如苏迷卢山王。并又勤加功用将欲灭一众生贪嗔痴恼。又彼诸医于是清凉药分山王。摩以为末。尽其劫寿涂一众生。一切医王尽其功术。并悉疲倦。乃至药分山王。用末涂尽。皆亦不能灭一众生贪嗔痴等诸恼热病。复次舍利子。诸佛如来出兴于世。见诸众生具烦恼病。如来但说一不净观无上正法阿竭陀膏药。用以涂傅。无量众生贪欲热恼无不除灭。如是涂傅无量百众生。无量千众生。无量百千众生。无量拘胝众生。无量百拘胝无量千拘胝无量百千拘胝众生。无量拘胝那庾多众生。无量百拘胝那庾多。无量千拘胝那庾多。无量百千拘胝那庾多众生。如是无量姜羯罗众生。无量频跋罗众生。乃至无量不可说不可说众生。以闻一不净观故。贪欲热恼同时静息。舍利子。如来但说一慈悲观无上正法清凉妙药。用以涂傅。无量众生嗔恚热恼皆得除灭。乃至不可说不可说众生。嗔恚除灭亦复如是。舍利子。如来但说一因缘观无上正法清凉妙药。用以涂傅。无量众生愚痴热恼。皆得止息。乃至不可说不可说众生。愚痴止息亦复如是。又舍利子。证得法身菩萨摩诃萨。亦以大愿自严持身。为法良药。善能息灭无量众生三毒热恼。乃至息灭不可说不可说无量众生贪嗔痴等诸恼热病

复次舍利子。如我先说证得成就法身菩萨摩诃萨。愿力持身而为良药。用灭无量不可说众生烦恼热病。如是等相吾今更说。汝当谛听。舍利子。我念往昔过无数劫。有佛兴世。名曰然灯如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。尔时然灯如来应正等觉。为我授记。作如是言。汝摩纳婆。于当来世。过阿僧企耶劫。当得作佛号释迦牟尼如来应正等觉乃至佛薄伽梵。舍利子。彼然灯佛授我记已。尔时便证法身成就。佛灭度后。我为帝释。名微妙眼。于三十三天。得大自在。具大神通。有大威德。宗族炽盛。舍利子。是时赡部洲中。有八万四千大城。有无量千村邑聚落市肆居止。复有无量百千拘胝那庾多一切众生。住如是处。人物繁拥极为兴盛。舍利子。当于尔时。有大疫病。中劫出现。多有众生遭遇重病。身体溃烂。痈肿痤疖。疥癣恶疮。风热痰癊。互相违返。以要言之。一切病苦。无不毕集。于时复有无量百千诸医药师。为欲救疗如是病苦。勤加功用。极致疲倦。而众生病无有愈者。舍利子。彼诸无量病苦众生。不遇良医。为病所弊。无有救护。无有归趣。皆共呼嗟。失声号哭。涕泣横流。作如是言。我今受此无量重病。何处当有天龙药叉健达缚。及诸罗刹人非人等。以大慈悲而能见为除我病者。若有能除我病苦者。我当不吝一切财宝。厚报其恩。随其教诲。舍利子。我于尔时。以净天眼超过于人。见诸众生种种疫病逼恼其身。烦冤缠绕无有救济。又以天耳清净过人。彻听众生号诉之声。极为悲怨。酸楚难闻。舍利子。我于彼时。见闻是已。于是众生。深起大悲。即作是念。一何苦哉。如是无量无边众生。遭是重病。无舍无宅。无救无护。无归依趣。无能疗者。我今决定为诸众生。为舍为宅。为救为护。为归依处。为医疗者。必令病恼普皆平复。舍利子。我于尔时。便隐帝释高广之形。于赡部洲俱卢大城不远。受化生大众生身。名曰苏摩。既受生已住虚空中。以伽他颂。遍告赡部洲内所有众生。说其颂曰

  俱卢大城为不远　　有大身者名苏摩
  若有众生啖其肉　　一切病恼皆除愈
  彼无嗔恚诸忿害　　为作良药生赡部
  汝当欣踊勿惊疑　　随意割肉除众恼

舍利子。尔时赡部洲内所有诸城。八万四千村落市肆。又无量千一切含识。为病恼者闻是声已。一时皆往俱卢大城苏摩菩萨大身之所。竞以利刀或割或截彼之身肉。舍利子。苏摩菩萨行精进行。当被割时。于其身内。出大音声。说伽他曰

  若此能实证菩提　　智藏当成无尽者
  随我所发谛诚言　　亦愿身肉常无尽

舍利子。尔时赡部洲内。一切众生为病逼故。段段割截菩萨之身。或担持去。或就食者。虽被加害以愿力故。随割随生无有缺减。舍利子。是诸众生啖食苏摩菩萨肉已。一切病患悉皆除灭。病既除差。复令众生心得安乐。形无变易。是诸众生身心安乐。展转声告遍赡部洲。来食肉已。病皆除愈。无有变易。身心安乐。舍利子。尔时一切赡部洲中。人民之类。若男若女童男童女。食菩萨肉。病除愈者于是菩萨深怀恩慧竞自思惟。是苏摩者极有重恩。除我病苦施我安乐。令无变易。我当云何施设供养酬斯厚泽。作是念已咸共集会诣俱卢大城苏摩菩萨大身之所。既到彼已皆共围绕。感戴其恩不能自胜。说伽他曰

  仁为舍宅为救护　　仁为良医妙药者
  唯愿哀怜垂教敕　　我等如何修供养

舍利子。我于尔时为是大身。拔济众生如是病苦。知是无量诸众生等。衔我重恩归依我已。便灭所现苏摩大身。复帝释形住众生前。威光显盛而告之曰。卿等当知。若为病苦。由我身肉而得除差。卿等怀恩将思报者。卿等当知。我本不为村城馆邑王都国土田宅舍屋住处等事。愍卿病苦行身肉施。我亦不为金银末尼琉璃真珠珂贝璧玉珊瑚等宝。行身肉施。我亦不为象马牛羊放牧畜产行身肉施。我亦不为妇人丈夫童男童女奴婢仆使行身肉施。我亦不为肴膳饮食衣服卧具病缘医药及余资蓄行身肉施。我亦不为园林池苑宫殿楼观。愍卿病苦行身肉施。卿等当知。我本所以愍卿病苦行身肉施。为令众生离不善业。卿等但能为我永断永离杀生之业。永断永离不与取业。永断永离欲邪行业。如是永断永离虚诳语业。离间语业。粗恶语业。绮饰语业。贪欲嗔恚诸邪见业。卿等于此永断离者。是为利益。是为报恩。舍利子。尔时帝释。复为大众。说伽他曰

  我非为求珍宝聚　　其量高广等迷卢
  亦不为求天玉女　　及诸衣食床敷事
  欲奉苏摩大身者　　但当尊重同和合
  展转慈心相敬视　　专修净妙十业道
  卿等当于十业道　　但常和合坚防守
  是名大兴法供养　　菩萨非求世财故
  我不用诸世财宝　　芳羞饮食妙衣服
  象马车乘牛羊等　　床敷婇女资生具
  卿等但共同和合　　善持清净十业道
  展转发起大慈心　　彼此熏修利义意

舍利子。尔时赡部洲内。无量众人闻我说是劝发之言。感恩德故顶礼我足。皆悉受持十种清净妙善业道。舍利子。我于尔时。为彼大众广宣正法。示教赞喜便隐天身不现于世。如是舍利子。我正忆念。往昔世时赡部洲中。所有人民。食啖苏摩菩萨肉者。从是已来。乃至无有一人堕于恶趣。彼命终已。皆生三十三天。宿业力故与戒俱生。舍利子。我于尔时。复为彼天随其所应敷演法化。示教赞喜。皆令安住声闻乘中。或独觉乘。或有安住阿耨多罗一切智乘。如是等众闻我法故。或有已般涅槃正般涅槃当涅槃者。舍利子。汝观如是安住法身菩萨摩诃萨。行毗利耶波罗蜜多故。成就如是大神通力。成就如是大威德力。成就如是大势之力。乃能但舍一身之慧。而大成熟无边众生。皆住三乘得不退转

尔时长老舍利子白佛言。世尊。云何菩萨摩诃萨。行毗利耶波罗蜜多时。精勤修获法身之相。唯然世尊。愿为解说。佛告舍利子。菩萨摩诃萨法身之相无生无死。坚固难坏犹如金刚。不可思议。而诸法身菩萨摩诃萨。为欲化度身坏众生故现坏身。又欲化诸身不坏者。现不坏身。然此法身圆成具足。非火所烧。非刀能割。如彼金刚坚固难坏。舍利子。安住法身菩萨摩诃萨。行毗利耶波罗蜜多故。无倦精进。非有功用。但以其身。则能成熟无量众生。不假其心思量分别。即此菩萨身。自能知了诸身相随入自身真如法性。自身真如随入诸法真如。诸法真如随入自身真如。自身真如随入诸佛真如。诸佛真如随入自身真如。自身真如随入去来现在真如。去来现在真如随入自身真如。又过去真如不违未来真如。亦非未来真如违过去真如。又过去真如。不违现在真如。亦非现在真如违过去真如。又未来真如不违过去真如。亦非过去真如违未来真如。又未来真如不违现在真如。亦非现在真如违未来真如。又现在真如不违过去真如。亦非过去真如违现在真如。又现在真如不违未来真如。亦非未来真如违现在真如。又去来现在真如即蕴界处真如。又蕴界处真如即染污清净真如。又染污清净真如即流转寂灭真如。又流转寂灭真如即加行真如。又加行真如即一切行真如。而一切行即是真如。而此真如即一切行

复次舍利子。夫真如者即是实性。即是如性。是非不如性。是不远离性。是无发动性。是无娆乱性。是不相违性。是无违诤性。又舍利子。夫真如者无所违诤。以无违诤名曰真如。然诸如来说名违诤。舍利子。真如说名随顺摄受。何因缘故。如来乃说以为违诤。舍利子。如来违于一切诤故。以是因缘。菩萨常现一切违诤。又诸如来本无违诤。亦未曾起。何以故。无违无诤说名如来。而常现诸色像违诤。非唯如来而有动乱。诸菩萨摩诃萨。以如实智观如来身。于如来身平等法性。即观自身平等法性。又于自身平等法性。观察如来平等法性。又于自身平等法性。观察诸身及以非身。于一切身及以非身。观察于彼不思议身。菩萨摩诃萨。于缘生法了一切身。既了知已引摄法身。舍利子。菩萨摩诃萨。当于引摄此法身时。我说是等便证法身。既得证已。又能示现蕴界处身。当知是身法身所显。是故舍利子。一切众生。若有值遇如是法身。若见若闻即皆调伏。触彼身时。能令众生作诸义利

复次舍利子。如时缚迦大医王者。聚集众药和为形相。变成女像妍质华美净色悦人。由是医王善能作故。妙善成就善加严饰。舍利子。是药女像。虽无思虑又无分别。而能示现往来住止。若坐若卧。诸有豪贵大王王子大臣长者及诸小王有病恼者。至时缚迦大医王所。尔时医王观其所治。即以药女赐为仇匹。彼诸人等既蒙所惠。便执药女暂身交触。一切患苦自然消除。无病安乐无有变异。舍利子。此时缚迦大医之王。疗治世间诸病妙智。余有世医无与等者。如是舍利子。法身所显菩萨摩诃萨。亦复如是。乃至一切众生。若男若女童男童女。有贪恚痴热恼病者。至菩萨所暂触其身。一切病苦皆得消灭。又觉其身离诸热恼。何以故。由诸菩萨摩诃萨本发大愿善清净故

复次舍利子。法身菩萨摩诃萨。不由食搏食故。身得安住。虽复了知一切饮食本无所有。愍众生故而现受食。虽现食之情无耽着。于其自身未曾顾恋。何以故。法身之力无退无减。不以饮食安住其身。又舍利子。法身菩萨摩诃萨。于诸生死虽可了知。而示现身有生有死。何以故。为欲成熟诸众生故。示现终尽。然此菩萨摩诃萨。了知诸法无有终尽。示现有生。了知诸法无有起作。虽现生起。了知诸法毕竟无生。又此法身以法为食。法力所持。依止于法本愿力故。无有功用成熟众生。舍利子。法身菩萨摩诃萨。如是等相皆由无倦精进修行毗利耶波罗蜜多故。而便证入。尔时世尊。欲重宣此义。而说颂曰

  身如金刚不可损　　知时设化故现身
  毒恶刀火非烧害　　见烧害者所化众
  有病则见为良药　　饥渴众生见饮食
  以诸法性无分别　　法身无身一理证
  了知一法从缘生　　无摩纳婆意生等
  众缘有故苦纶运　　众缘无故苦纶断
  了色不坚如聚沫　　思惟诸受等浮泡
  想如热时阳焰动　　芭蕉诸行应观察
  如世善幻舞戏者　　刹那便现诸色像
  了知识用亦如是　　智者于彼皆无愿
  知世财如箭离弦　　复似电飞山水瀑
  暂聚还散类空云　　智者于彼皆无愿
  诸有都无有众生　　未曾不受天诸乐
  复堕地狱更贫苦　　佛子观已不求天
  彼心无依似游空　　非有非无离依止
  虽生诸有无生死　　证无老死大我故

复次舍利子。无倦精进菩萨摩诃萨。修行毗利耶波罗蜜多时。当应如是正心修学。舍利子。世间虽有诸医充满世界。不能了知三种大患。何以故。彼皆不善又无智故。而不能识贪嗔痴等三种大患。舍利子。彼无智医。非唯不识三种大患。又不了知三大良药对治三患。何等为三。所谓不能了知贪欲大患。不净良药而为对治。嗔恚大患慈心良药而为对治。愚痴大患缘起良药而为对治。舍利子。如是诸医唯能疗治一二别病。不能普治一切众病。惟能暂治少时降损。非为尽病毕竟除差。菩萨摩诃萨。作如是念。我今行毗利耶波罗蜜多故。修菩萨道。岂当随学如是诸医。我当依随诸佛世尊。善达诸法无上大医之王。毕竟疗治一切病者。是大医王。我今随从依凭修学。既修学已。我应普治一切病苦。岂当疗治别别诸病。我应毕竟除众病本。岂当暂差不除病本。舍利子。是菩萨摩诃萨复作是念。我应积集如是无上正法阿竭陀膏药。当使一切众生闻药声已。贪嗔痴等极重大患自然消灭。是故舍利子。无倦精进菩萨摩诃萨。行毗利耶波罗蜜多故。积集如是无上正法阿竭陀膏药。涂傅一切有病众生。不与声闻独觉法共。唯除如来无上大医之王善达一切法者。以无上正法阿竭陀膏药。遍涂所吹大法之螺。如是涂已便就吹之。其声遍告三千大千世界。于中所有非一众生。闻是声已。但使一切贪嗔痴等诸大重病皆悉除灭。如是除灭。非一百众生。非一千众生。非一百千众生。如是除灭。非一拘胝众生。非一百拘胝千拘胝百千拘胝众生。如是除灭。非一拘胝那庾多众生。非一百拘胝那庾多千拘胝那庾多百千拘胝那庾多众生。非一姜羯罗众生。如是除灭。乃至不可说不可说众生所有三毒大患皆得除灭

复次舍利子。如大雪山中。有大药王。名为毗伽摩。若闻其声。一切世间猛烈毒热。皆悉消灭。若药所住百踰缮那。其威盛故令诸恶毒皆无势力。若以药王涂大螺鼓。若击若吹其声所及。诸有众生。或饮毒药。或被毒螫。毒涂毒刺。众毒恼者。但闻如是螺鼓之声。暂至于耳。一切诸毒皆得除灭。舍利子。如是毗伽摩大妙药王。一切世医皆不能识。唯除时缚迦大医王者。方知色性。如是舍利子。无倦精进菩萨摩诃萨。亦复如是。行毗利耶波罗蜜多故。积集如是无上正法阿竭陀膏药。不与声闻独觉法共。唯除如来无上正法大医之王。能灭众生诸有病者。以无上正法阿竭陀膏药。用涂大法之螺。涂已吹之。声告三千大千世界。其中所有一切众生。乃至不可说不可说等。闻是声已。贪嗔痴等诸重大患。悉得寂灭无有遗余

复次舍利子。如是无上正法阿竭陀膏药。从于何所而来集此。舍利子。当知如是膏药。从大菩提法器中来。又舍利子。彼菩提器从何而来。当知从菩萨法财宝箧中来。又舍利子。如是菩萨宝箧从何而来。当知不异大菩萨藏法门中来。是故舍利子。无倦精进菩萨摩诃萨。为欲修行毗利耶波罗蜜多故。应极至诚寻求如是大菩萨藏法门经典听闻受持。若读若诵研究义理。广为众生宣说开示。舍利子。汝又应知如是之相。吾今当说重显其义。若诸无倦精进菩萨摩诃萨。修行毗利耶波罗蜜多故。闻我说已。于是经典。应极至诚寻究义理。为他开示

舍利子。乃往古世。过阿僧企耶劫。广大无量。不可思议。难可度量。乃至过是等数。又复过是等量。当于尔时。于此世界。有佛出现。名赤莲花胜如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。彼佛声闻弟子一大集会。其数具满八十拘胝。皆是大阿罗汉。诸漏已尽。乃至获得诸心自在最胜波罗蜜。舍利子。彼佛寿量满八十岁。便般涅槃。正法住世经五百岁。像法住世亦五百岁。舍利流布。如我今者。般涅槃后供养舍利当流布相

舍利子。彼佛去世入涅槃后。将满百年有一菩萨。他方界终。生此世界大王之家。适初生已便唱是言。奇哉今者生非法处。又作是言。奇哉今者生非法处。如是唱已复作是言。我于今者当行法行。我于今者当行法行。尔时众人皆生疑怪。以其所述同共号之。名为法行。舍利子。时法行王子。渐渐长大。诸根成满状年二十。净信舍家趣无上道。既出家已。独止幽闲空寂林中。宴处静室。时虚空中有大天神。来告之曰。苾刍当知。汝今若求如来佛果。声称高远尊上法者。但当勤学大菩萨藏微妙法门。若未获者勿舍精进。专志寻求无令不果。舍利子。时法行苾刍。从彼天神闻斯语已。心大欢喜。踊跃无量。身意悦豫。即行寻访菩萨藏法。躬诣村城王都国邑乃至亭馆。展转寻求了无所得。尔时法行苾刍。复更经历往诸僧坊。或见苾刍或苾刍尼。便至其所。作如是言。善哉仁者。何处当有大菩萨藏微妙法门。菩萨摩诃萨依之修学。出生无量诸佛妙法。彼便答言。苾刍当知我初不闻何等名为大菩萨藏微妙法门。我于今者因汝说故。方闻大菩萨藏法门名字。来入我耳。舍利子。尔时法行苾刍。重自思念。如是法门诸佛妙法。不应天神妄有所说。我于今者要当不舍勇猛精进。乃至未闻大菩萨藏法门已来。中无懈废。便更请问彼苾刍等。赤莲花胜如来般涅槃时。焚身之地为在何所。汝当示我此地方面。我当往彼行精进业。彼苾刍等即告之言。苾刍当知如是方面。是薄伽梵赤莲花胜如来焚身之地。尔时法行苾刍。即往其所。到已顶礼右绕无数。却退一面结加趺坐。一心摄念想对彼佛。作是誓言。我于此处结加趺坐。我若不从赤莲花胜如来。现前听闻大菩萨藏微妙法门者。要当不解此坐。不起此处。舍利子。时法行王仙苾刍。精进坚固发如是誓。结加趺坐过七日已。东方世界有薄伽梵。名曰宝藏如来应正等觉。为法行王仙苾刍故。从彼而来现其身前。为说开示八门句法。因又告曰。王仙苾刍。汝今当随八门句法大菩萨藏微妙法门精勤修行。则诸佛法不难得遂。时王仙苾刍闻佛教已。精勤修习八门句法。于后不久便得成就不可思议无上多闻。即从地起离本坐处。为欲广行毗利耶波罗蜜多故。勇猛正勤。往诸村城王都国邑乃至亭馆。从一一处至一一处。展转宣说显通如是大菩萨藏微妙法门。满六十岁。于如是时教化众生。天人等众满拘胝数。皆得安住于三乘中

舍利子。彼王仙苾刍。化众生已。临命终时发如是言。愿我还生此佛世界人趣之中。当修法行。作是愿已便就命终。以愿力故。于此世界赡部洲中。生居士家。彼初生日便唱是言。我于今者当修法行。又作是言。我于今者当修法行。尔时众人。因其所述。为立本号。还名法行。舍利子。是法行童子。形如八岁。净信舍家趣无上道。出家不久。以宿习故。法菩萨藏微妙法门。无上深义自然现前。法行苾刍。安住如是大菩萨藏。六十岁中广行法化。躬至村城王都国邑乃至亭馆。处处施化。为诸众生开示是法。于六十岁教化天人。满拘胝众。于三乘中皆已成熟。或住声闻乘。或住独觉乘。或住无上大乘之者

舍利子。彼时法行苾刍。化众生已。临命终时复发是言。愿我未来当得为人出家闻法。既命终后。以愿力故。于此世界赡部洲中。生于王家。彼初生日。于上空中。天神唱言。此众生界。法胜菩萨出现于世。又唱是言。此众生界。法胜菩萨出现于世。尔时众人闻天告已。便号王子以为法胜。舍利子。法胜王子。如是渐渐诸根成熟。壮年二十。净信舍家趣于非家。既出家已。众人便号法胜苾刍。舍利子。法胜苾刍。大念慧力之所持故。大菩萨藏微妙法门。自然现前。精勤修习。能善永断众生疑惑。六十年中躬事巡化。游历村城王都国邑乃至亭馆。为诸众生开示是法。于六十岁。成熟拘胝诸天人众。悉令安住阿耨多罗三藐三菩提心

舍利子。法胜苾刍。将欲命终。复发是言。愿我来世生人道中。正信出家。适发愿已便就命终。还生此界赡部洲中大富长者家。彼初生时。复有天神大声唱令。于此世界。得念菩萨今日出现。如是再返。尔时众人闻天告已。皆共号之。名为得念。舍利子。是得念菩萨诸根成满。壮如二十盛年之者。净信舍家趣于非家。才出家已。宿习力故。便得成就不可思议最胜无上不忘总持多闻具足。六十年中身行化导。巡历村城王都国邑乃至亭馆。处处流化宣说正法。断众生疑。开示如是大菩萨藏微妙法门。过六十岁。安置天人满一拘胝。或住声闻。或住独觉。或复安住无上佛智舍利子。是得念菩萨。化众生已临命终时复发是言。愿我未来生于人中。正信出家。彼命终已。还生此界大王之家。初生之时。复有天神大声唱告。此有情界。依法菩萨出现于世。如是再返。尔时众人闻天告已。便名王子。以为依法。舍利子。依法菩萨。如是渐渐诸根成满。壮二十岁。以信舍家趣于非家。才出家已。宿习力故。便得成就无间断念念力持故。大菩萨藏微妙法门自然现前。舍利子。依法菩萨而作苾刍。五十年中游行教化。从一聚落至一聚落。从一村墟至一村墟。从城至城。从馆至馆。从国至国。从一王都至一王都。为诸众生。开示如是菩萨藏法。断除疑惑。于五十岁令四拘胝诸天人众。住声闻乘。住独觉乘。或住无上诸佛大乘

舍利子。是依法菩萨摩诃萨。从是命终。生于东方宝藏如来佛之世界。初生之时。即得成就不可思议无上多闻。教化示导六十八拘胝诸天人众。皆得成满安住三乘。舍利子。是依法菩萨摩诃萨。于彼宝藏如来法中。化众生已。命终还来于此世界赤莲花胜佛土赡部洲中。生大王家。当初生时。彼所教化。六十八拘胝天人大众。皆成熟者于彼命终。亦随菩萨生此佛土。与是菩萨而为眷属。舍利子。当于尔时。此方世界有佛出世。名最高行如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。其佛寿命。满足八十拘胝岁。尔时人寿量与佛等。舍利子。最高行如来应正等觉。处世说法。一一岁中有一大会。一一大会。皆有八十拘胝诸声闻众。其佛凡有八十拘胝声闻大会。纯是大阿罗汉。尔时菩萨为王子时。名曰勇施。成就多闻聪睿胜观。与其眷属六十八拘胝。如是大众前后围绕。往诣薄伽梵最高行如来应正等觉所住之处。既到彼已顶礼佛足。绕无数匝却坐一面

舍利子。尔时最高行如来。了达勇施王子增上信乐。即便开示本行相应微妙胜法。时勇施王子。闻佛开示如是法已。豁然意解。得清净信。心清净故。即与六十八拘胝眷属。以信舍家趣于非家。既出家已。尽其寿量净修梵行。舍利子时勇施王子。彼佛法中精进经行。于菩萨道。其心将证无上菩提。时最高行如来。便为授记。告诸大众。今此苾刍勇施菩萨摩诃萨者。次我灭后。当证阿耨多罗三藐三菩提。出现世间。名大精进如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。是最高行如来。授彼记已便般涅槃。勇施菩萨。见佛灭度恋慕增感。恭敬供养如来舍利。广起灵庙利益众生。住持正法开化无量。其后不久。证得阿耨多罗三藐三菩提。名大精进。舍利子。是大精进如来。寿量半劫。其佛说法无量大会。一一集会。有十二那庾多声闻弟子。纯阿罗汉

舍利子。如是无倦精进菩萨摩诃萨。为欲修行毗利耶波罗蜜多故。郑重殷勤。寻求如是大菩萨藏微妙法门。听闻受持。若读若诵。思惟研究。开析义理。广为含生宣示演说。惟功不已遂至成佛。名大精进如来应正等觉。出兴于世。广宣法化饶益众生。如上所说。是故舍利子。若有善男子善女人。安住大乘微妙正行。欲疾证于阿耨多罗三藐三菩提者。应当奋发勇猛精进。郑重殷勤。寻求如是菩萨藏法。即得奉遇恭敬听受。乃至广为含生宣说开阐。何以故。舍利子。勇猛精进菩萨摩诃萨。必因寻求大菩萨藏微妙法门。方得成满毗利耶波罗蜜多故。舍利子。是名菩萨摩诃萨勇猛精进勤修毗利耶波罗蜜多。为众生故行菩萨行。若诸菩萨摩诃萨精进修行是菩萨行。一切众魔魔民天子。于此菩萨不能娆乱。又不为彼异道他论。所能摧屈

大宝积经卷第四十八大宝积经卷第四十九

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十五静虑波罗蜜多品第十之一

复次舍利子。云何名为菩萨摩诃萨精勤修学静虑波罗蜜多。为众生故行菩萨行。舍利子。菩萨摩诃萨为众生故。具足勤修四种静虑。何谓为四。舍利子。菩萨摩诃萨离欲离恶不善法故。有寻有伺离生喜乐。是名菩萨安住第一具足静虑。又舍利子。菩萨摩诃萨灭寻伺故。内正等净。心一趣体。无寻无伺。定生喜乐。是名菩萨安住第二具足静虑。又舍利子。菩萨摩诃萨。为离喜故。便住于舍。正念正知。身正受乐。众圣所说。有舍有念。乐住离喜。是名菩萨安住第三具足静虑。又舍利子。菩萨摩诃萨。为断乐故。断苦为先。及忧喜没。不苦不乐。舍念清净。是名菩萨安住第四具足静虑。舍利子。菩萨摩诃萨。于是静虑。定心清白无有秽浊。离随烦恼不舍深定。而能发起一切静虑种种作业。是名菩萨摩诃萨依静虑波罗蜜多故勤修如是四种静虑

复次舍利子。云何菩萨摩诃萨静虑作业。所谓菩萨成就神通智业圆满。舍利子。云何名为菩萨神通。复以何等而为智业。舍利子。言通智者菩萨摩诃萨。成就通智具足五种。何等为五。所谓天眼作证智通。天耳作证智通。他心智作证智通。宿住忆念作证智通。如意足差别作证智通。舍利子。是名菩萨摩诃萨五种神通。菩萨。于中具足成就智业圆满

复次舍利子。云何菩萨摩诃萨天眼性作证智通。云何神通智业圆满。舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。得是天眼智业圆满。如是定心清净明白。又无浊秽离随烦恼故。于含识死生作证智神通。其心善趣。入舍利子。如是菩萨摩诃萨。天眼清净。明亮显照。超过于人。观诸含识。若死若生。好色恶色。善趣恶趣。若劣若胜。随诸众生业所积集。悉能了知。如是以净天眼。见诸众生。成就身恶行。成就语恶行。成就意恶行。诽谤贤圣发起邪见。彼由邪见业受因故。身坏终后。堕于恶趣生地狱中。如是众生。成就身妙行。成就语妙行。成就意妙行。不谤贤圣。发起正见。彼以正见业受因故。身坏命终。往生善趣天世界中。舍利子。是名菩萨摩诃萨天眼清净超过于人随诸众生业所积集悉能明见

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。所获天眼明彻最胜。过诸含生所得天眼。舍利子。由是菩萨所获天眼极善明朗。彻视显现所有色相。若粗若细。若胜若劣。若远若近。如是诸境皆对目前悉能明见。又舍利子。菩萨摩诃萨由是眼故。一切有障诸色像等。经菩萨眼彻视明朗皆无障碍。是故舍利子。此菩萨摩诃萨所获天眼于诸天中为最为胜。如是一切那伽。一切药叉。健达缚。阿素洛。有学无学。及阿罗汉。诸独觉等所得之眼。菩萨于彼所得天眼。作证智通。为最为上为尊为胜为妙为明清彻第一

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。所获天眼。诸出离道之所发生。以是天眼极善明了彻视显现故。所有十方无量无边诸世界中。粗细胜劣。若近若远一切诸色如实明见。又以是眼于彼十方无边无际诸世界中。所有含识生一切趣。除无色界。彼一切类。皆能如实了知明见。又以是眼善知众生所有业因及业果报。又善了知彼诸众生所有诸根及诸根因诸根差别。悉能分别如实了知

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。又以是眼能观十方无量无边诸佛国土功德庄严。皆对目前悉能现见。既现见已清净修治。所行戒聚。即以回向所成佛土。清净功德之所庄严。舍利子。是名菩萨摩诃萨具足天眼安住尸罗圆满回向。又舍利子。菩萨摩诃萨。天眼清朗超过于人。如实明见一切诸佛及菩萨僧。既现见已。彼诸正士所有轨则。景行根念。正智威仪。圣法解脱智住证得总持胜智。巧妙智慧。方便善权。趣入如是一切胜妙法行。菩萨悉能如实明见。便志勤修速令圆满

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。所得天眼清净超人。无量功德之所成就。何以故。是眼无障于一切色悉能见故。是眼无著于一切色无执着故。是眼解脱解脱一切随眠见故。是眼清净性清彻故。是眼无依以诸境界无所依故。是眼无受烦恼随眠不执受故。是眼无医无疑惑故。是眼无缚离障法故。是眼明了证法明故。是眼依智行非识故。是眼无染无恚无痴远离一切烦恼浊故。是眼随顺胜决择分以为圣行之所根故。是眼无碍相于一切众生等放神光故。是眼清朗离聚乱故。是眼无垢性皎净故。又舍利子。是菩萨眼。能引佛眼。性如虚空。无所退舍。是菩萨眼。无著无缚。于诸爱恚皆悉远离。是菩萨眼。行义境界等行正法。清净智道于诸众生。善能安住高广大悲。是菩萨眼。于来求者无所恚碍。是菩萨眼。于犯戒者曾无讥毁。是菩萨眼。于诸愆失能随守护。是菩萨眼。于彼懒惰能施策进。是菩萨眼。于心乱者示静虑分。是菩萨眼。于恶慧者施正慧眼。是菩萨眼。行邪道者开示正路。是菩萨眼。于彼下劣信乐众生示现如来广大佛法。是菩萨眼。毕竟能趣一切智智。高广神通妙觉现前。乃至道场无有退转。舍利子。是名菩萨摩诃萨依静虑波罗蜜多故获是天眼神通作证智业圆满

复次舍利子。云何菩萨摩诃萨。修行静虑波罗蜜多故。获是天耳性作证智神通。复以何等神通智业具足圆满。舍利子。菩萨摩诃萨。以依静虑波罗蜜多故。勤修获得是天耳性。彻听清净超过于人。有二种声。人非人等若远若近。皆闻显现。舍利子。是菩萨摩诃萨。以天耳性。能闻十方无量无边诸世界中一切声响。所谓天声。龙声。药叉声。健达缚声。阿素洛声。揭路荼声。紧捺洛声。牟呼洛伽声。人非人声。及闻贤圣说法之声。如来声。独觉声。菩萨声。声闻声。如是等一切声响。菩萨摩诃萨。以天耳性彻听之力。悉现闻知。又能了知。诸弊恶趣所有音声。地狱声。畜生声。焰魔界声。如是等无量无边一切声响。菩萨摩诃萨。以天耳性彻听之力。悉能现闻。又诸小虫蚊虻蝇蚁。乃至微细有命之类。随所发声。菩萨摩诃萨。以天耳性。悉能现闻。又舍利子。菩萨摩诃萨。天耳清净。若诸众生。于心所缘。起善不善。发生语业。以天耳性。悉能了知。又能了知。或有诸业善因摄受。或有诸业不善因摄受。如是一切悉能了知。菩萨摩诃萨。又能了知。或有语业贪随眠故嗔恚发起。或有语业嗔随眠故。贪欲发起。又能了知。或有语业贪嗔随眠故。愚痴发起。或有语业痴随眠故。贪嗔发起。又能了知。或有语业贪随眠故。贪欲发起。或有语业嗔随眠故。嗔恚发起。或有语业痴随眠故。愚痴发起。如是一切随有言说。音声所显。悉能了知。又能了知。或有语业意解清净方便染碍。或有语业方便清净意解染碍。如是一切所有音声。菩萨摩诃萨。以无碍天耳大神通智。随诸远近皆如实知

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。天耳通智清净明达。十方世界圣及非圣。所有音声皆悉听闻。复能分别无有错谬。虽闻听已。于圣音声不起欣爱。于非圣声不生嫌嫉。又于圣声听闻知故。获得大慈。于非圣声听闻知故。获得大悲。又十方诸声一时无量。菩萨摩诃萨。以前后际分齐智力。天耳无乱皆如实知

复次舍利子。菩萨摩诃萨。以净天耳周广听闻。尽于十方一切世界。如来游化刹土之处。佛薄伽梵说法言音。悉皆听闻。既得闻已念器不忘。一切能持不令流散。如处器中坚住不溢。如是舍利子。菩萨摩诃萨。闻如来声亦复如是。悉能了知坚不坚法。又舍利子。是菩萨摩诃萨。为听法故。非于一佛所说法音而偏领受。于第二佛所说法音。缠缚障碍。何以故。菩萨摩诃萨。闻法无厌故。虽复前后一切如来所说法音。皆能任持无有错谬。又菩萨摩诃萨。以净天耳。悉能听闻十方世界善不善声。此诸声中。有所显说时非时语。如是无量皆如实知。舍利子。何等名为时非时语。舍利子。诸佛菩萨善知时宜。或时为众广说法要。或时为众略说法要。菩萨摩诃萨。如是诸声皆悉闻已。以一音声随其所应广略开演。又舍利子。菩萨摩诃萨。能善了知。或有实可记法。若为说者。恐恼他故。而不记别。或实非可记法。谓能引无义。菩萨摩诃萨。妙能随顺利他方便无量善巧。自净其心而便授记

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。天耳清净彻听之力。知诸声相。或时具有如是相声应须随喜而听闻者。菩萨摩诃萨。即便听闻如是相声。或时具有如是相声不应随喜而听闻者。菩萨摩诃萨。便不听闻如是相声。又舍利子。菩萨摩诃萨。若处大众说法之时。众生耳识不能清净。便以神力加被于彼。令其解了说法音声。若诸众生于一切法皆欲领解。便令得闻如是法声。若诸众生不欣诸法既无欲解。便令不闻如是法声

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故获得如是天耳通智。所闻音响无量无边。又舍利子。天耳性者。能令诸法皆明净故。天耳性者。能令智慧性清彻故。天耳性者。能令菩萨自清净故。天耳性者。能令众生性清净故。天耳性者。极善审察如其文字。所说音词而能听闻明了通畅。又能悟入于五趣生所有含识种种言词。音声差别。菩萨悉能同其类音。而为说法。舍利子。是菩萨摩诃萨。天耳性通。唯能趣向如来天耳。必定不趣诸余乘行。舍利子。是名菩萨摩诃萨修行静虑波罗蜜多故获天耳性彻听神通智业圆满

复次舍利子。云何菩萨摩诃萨修行静虑波罗蜜多故。获是他心作证智神通。何等复名他心神通智业圆满。舍利子。菩萨摩诃萨。以是清净他心智通明了所及尽于十方诸世界中所有含识无量心相。菩萨悉能如实了知。若诸众生。前际心相。后际心相。现在心相。菩萨于中皆能晓了。舍利子。是菩萨摩诃萨。具足如是他心通智故。以过去心智。悉能解入一切含识因及随因差别之心。何以故。由能了知如是众生是广大因所生心因。如是众生。是中品因所生心因。如是众生。是下劣因所生心因。如是一切皆如实知。菩萨摩诃萨。又能了知。如是众生有施欲解相应根。如是众生。有戒欲解相应根。如是众生有忍欲解相应根。如是众生有精进欲解相应根。如是众生有静虑欲解相应根。如是众生有智慧欲解相应根。如是一切诸根相应。菩萨悉能如实明了。菩萨摩诃萨。又能了知。如是众生有慈行根。如是众生有悲行根。如是众生有喜行根。如是众生有舍行根。悉能了知如实分别。菩萨摩诃萨。又能了知。如是众生有佛乘行根。如是众生有独觉乘行根。如是众生有声闻乘行根。如是一切皆能了知。菩萨摩诃萨。又如实知。如是众生有强因力。趣向大乘善因成就。如是众生有强缘力。趣向大乘缘因成就。皆能如实分别了知。菩萨摩诃萨。又如实知。如是众生有强因力。成就趣向大乘善因。然此众生。由方便因生下贱家。如是众生有强方便力。虽不成就广大善因。然此众生。更殖因力生广大家。如是一切皆能了知。菩萨摩诃萨。又能了知。如是众生。欲解清净非方便净。如是众生。方便清净非欲解净。如是众生。欲解清净方便清净。如是众生。非欲解净非方便净。舍利子。菩萨摩诃萨。以是通力故。如是一切皆能了知

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多时。获是他心通智故。所有一切众生。前际因根心行智。及随诸行说法智。如是皆名菩萨摩诃萨他心通智。舍利子。菩萨摩诃萨。具是智故。以彼后际心入智通。悉能了知。如是众生。于未来世当有戒因。于现在世而有施因。如是众生。于未来世当有施因。于现在世而有戒因。如是众生。于未来世当有精进因。于现在世而有忍因。如是众生。于未来世当有忍因。于现在世有精进因。如是众生。于未来世当有慧因。于现在世有静虑因。如是众生。于未来世当有静虑因。于现在世而有慧因。如是一切无量因行。悉如实知明了通达。菩萨摩诃萨。又能了知。如是众生。于未来世当有出世行因。于现在世而有世间行因。如是众生。于未来世当有世间行因。于现在世而有出世行因。如是一切悉能了知。菩萨摩诃萨。又能了知。如是众生。于未来世当有大乘因所生根。于现在世有独觉乘因所生根。如是众生。于未来世当有独觉乘因所生根。于现在世而有大乘因所生根。如是众生。于未来世当有大乘因所生根。于现在世有声闻乘因所生根。如是众生。于未来世当有声闻乘因所生根。于现在世而有大乘因所生根。如是众生。于未来世当有独觉乘因所生根。于现在世有声闻乘因所生根。如是众生。于未来世当有声闻乘因所生根。于现在世有独觉乘因所生根。如是舍利子。如前所说。诸有因行及以有缘。于未来世一切众生当有是根。菩萨摩诃萨。以他心智通力故。若因若行若缘。皆能如实分别了知。舍利子。当知是诸菩萨摩诃萨。于未成熟诸众生所。发起正勤方便化导不生厌倦。随彼众生心能悟入为说正法。何以故。菩萨摩诃萨。善知如是正法器已。即便为说如是正法。说法之业。常无差失。是故皆号之为不虚说法者

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。获是他心智业通证于现在世一切众生心及心法次第生起。如是无量悉皆了知。舍利子。云何名为心及心法次第转起。而能知耶。舍利子。菩萨摩诃萨。于诸含识有贪心如实知有贪心。离贪心如实知离贪心。有嗔心如实知有嗔心。离嗔心如实知离嗔心。有痴心如实知有痴心。离痴心如实知离痴心。又复能知。由彼如是如是诸烦恼惑。覆障如是如是诸众生心。菩萨摩诃萨。皆于是等如实了知。既了知已。随彼如是诸烦恼等。出离正法而为宣说

复次舍利子。菩萨摩诃萨。既具如是他心通智。将欲说法往大众中。先应观察一切大众诸根行等差别之相。既了知已。如彼众生所应行行而为说法。舍利子。当知是菩萨摩诃萨。以了知众生根心胜劣之智。能悉了知众生根心胜劣之性。舍利子。当知如是菩萨不妄轻毁于自心相及他心相。何以故。由此菩萨摩诃萨以智简集心相续故。如是以念简集。以悟简集。以趣简集。以慧简集。以觉简集。心相续故。离烦恼习。相续断绝。清净无垢明彻。无染无浊无躁。择照诸法。随入众生一切心行。如是简集心相续故。舍利子。菩萨摩诃萨。若能悟入如是一切心法智者。是名菩萨摩诃萨修行静虑波罗蜜多故获是他心神通智业圆满成就之法

复次舍利子。云何菩萨摩诃萨。修行静虑波罗蜜多时。获得宿住随念作证智神通智业圆满。舍利子。菩萨摩诃萨。以具如是宿住随念之智力故。尽于十方遍周世界所有众生非一种种诸宿住事悉能随念。如是一生十生。百生千生。若百千生。非一百生。非一千生。非一百千生。如是次第皆能了知。菩萨摩诃萨。又能了知。坏劫成劫。若成坏劫。非一坏劫。非一成劫。非一成坏劫。如是无量皆能了知。菩萨摩诃萨。又知如是众生。曾于彼处。有如是名。有如是性。如是种类。如是色相。如是状貌。如是形像。如是饮食。如是久住。受如是等苦乐之事。菩萨摩诃萨。以宿住智皆能随念。又能了知如是众生。此处命终。彼处受生。彼处命终。此处受生。如是此彼命终此彼受生。若自若他。如是一切所有行相。所有处所非一种种诸宿住事。菩萨摩诃萨。悉能随念分别了知

复次舍利子。是菩萨摩诃萨。以依静虑波罗蜜多故。宿住念力善能随念。前际所有自宿住事。悉能了知又能随念。前际所有他诸有情。他数取趣所受非一。无量种种诸宿住事皆能随念而得知之。菩萨摩诃萨。又能随念。前际因生自善根因。又能随念。一切含识前际因生他善根因。如是一切随念了知。舍利子。是菩萨摩诃萨。宿住智力无量方便。以自善根回向菩提。能令众生各自忆识所有善根。又令众生于菩提心勤行摄受。如是一切随念能知。又能随念先世所有诸苦乐因。善知此因。皆趣无常苦无我等。舍利子。是菩萨摩诃萨。既知是已。于菩萨行。无色憍逸。无财憍逸。无眷属憍逸。无自在憍逸。无有希求转轮圣王憍逸。无有希求帝释天主憍逸。无有希求梵世天王憍逸。无有希求护世天王憍逸。无有希求诸处受生乐着憍逸。无有希求诸欲之王富乐憍逸。唯除为欲成熟众生便以愿力故受诸有。舍利子。如是菩萨摩诃萨。了知一切皆趣无常苦无我故。于过去世烦恼诸行。善能诃责轻毁厌恶。于现在世。更不容纳如是烦恼。乃至命难重苦因缘。终不造作不善之法及诸恶业。舍利子。是菩萨摩诃萨。以先所集一切善根。皆悉回向阿耨多罗三藐三菩提。令其增广现在所集诸善根等。为欲摄受一切众生。远离一切不平等回向故。是菩萨摩诃萨。具如是等诸善根已。绍三宝种令不断绝。皆为回向一切智智。舍利子。当知菩萨摩诃萨。念定之力。乃能如是成就无量微妙善法

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。获是宿住妙缘随念。极善安住。住法界故。如是随念坚固不动。方便善巧简择集故。如是随念无有掉乱。已善修治静虑业故。如是随念无有躁扰。妙奢摩他善住持故。如是随念无诸迷谬。毗钵舍那善摄受故。如是随念性无鲁朴。善证清净现妙智故。如是随念能善忆持。久远诸念无忘失故。如是随念大宝伏藏。福德资粮善积集故。如是随念不随于他。智慧资粮善积集故。如是随念已到彼岸。诸度资粮善积集故。如是舍利子。当知无量无边诸妙善法。皆由念力所任持故。于过去世及现在世。发起忆念无忘失法。舍利子。是名菩萨摩诃萨依静虑波罗蜜多故获是宿住神通成就具足智业圆满

复次舍利子。云何菩萨摩诃萨如意足作证智神通。何等复名如意足通智业圆满。舍利子。菩萨摩诃萨。依静虑波罗蜜多故。获是欲三摩地断行成就修如意足。如是勤心观三摩地断行成就修如意足。舍利子。是菩萨摩诃萨。依如是等欲勤心观助发之法。极善修治极善成立。自在转故。能善修习四如意足。舍利子。菩萨摩诃萨。成就四种如意足已。随其愿欲。如意神通证得现前。能示非一种种神变。菩萨摩诃萨。虽现无量神通变化。皆为度脱诸众生故而修习之。舍利子。是诸众生。应见如是神通变化受调伏者。菩萨摩诃萨。随彼所应即便显示如是神通无量变化。或现色相。或现威力。或冥加被众生。因是而从度脱

复次舍利子。云何菩萨摩诃萨。如意足通现诸色相调伏众生。舍利子。是菩萨摩诃萨。观诸众生由如是等诸色像现。若见若闻。方从调伏。菩萨即便随其所念。现斯色像。或现如来色像。或现独觉色像。或现声闻色像。或现天帝色像。或现梵王色像。或现护世天王色像。或现转轮圣王色像。如是等诸余色像。菩萨摩诃萨。随所化度皆能示现。乃至由现畜生色像。及余一切而调伏者。即便示现如是色像。为诸众生宣说正法

复次舍利子。云何菩萨摩诃萨如意足通现诸威力。舍利子。菩萨摩诃萨。观诸众生恃增上慢忿恚憍逸。极怀深重。由如是力得调伏者。菩萨摩诃萨。随其所应。便为示现如是神力。或现摩诃诺伽那力。或现那罗延力四分之一。或现那罗延力全分之半。或现那罗延力具足全分。如是乃至渐致兼倍。令彼众生调伏化度。舍利子。菩萨摩诃萨。以静虑波罗蜜多如意足神通力故。能以二指举苏迷卢最大山王。轻转自在。犹如取一阿末罗果。复以山王掷置他方无边世界。舍利子。如此山王。举高一十六万八千踰缮那。量广八万四千踰缮那量。四宝所成高广第一。由是菩萨住如意足。虽掷异方于菩萨力无损无减。又舍利子。菩萨摩诃萨。住如意足故。又能以此三千大千世界。如是纵广尽其际量。从水轮聚上至有顶。擎置掌中住经一劫。现诸威仪无有妨碍。舍利子。如是无量不可思议。菩萨摩诃萨。悉能随应示现神变。舍利子。菩萨摩诃萨。化现成就如是大力。为令力增上慢忿恚憍逸极重众生见闻菩萨显现神变。所有恃力怀慢忿恚憍逸悉皆摧灭。菩萨了知既调伏已。随其所应为说法要

复次舍利子。云何菩萨摩诃萨证得如意足通加被之智。舍利子。菩萨摩诃萨。即以如是加被智力。随所加念即便成就。舍利子。菩萨摩诃萨。若欲加念深广大海使如牛迹。即如其念令是大海量如牛迹。又欲加念微浅牛迹犹如大海。即如其念令是牛迹量同大海。又舍利子。菩萨摩诃萨。若欲加念劫烧大火令成水聚。即如其念便成水聚。加念水灾令成火灾。即如其念火灾便起。舍利子。以要言之。一切加念神足之门。菩萨摩诃萨。随念加之皆得成就。又舍利子。菩萨摩诃萨。若有加念下中上法互相转易。即随其念皆得成就。又舍利子。菩萨摩诃萨。凡所加念神通被物。贞固难坏不可转变。一切世间无有能令摇动隐没。若沙门若婆罗门。诸天帝释魔王梵王。及余世间。皆无有能如法摇动及隐没者。唯除法主诸佛世尊。舍利子。当知是菩萨摩诃萨以如是等加念持力。但为尊重。种种广大奇特变现。诸众生等为宣正法故现威神。复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。获得如是如意神足无退自在。超过诸魔烦恼境界。趣入一切诸佛境界。是诸众生不恼方便。一切善根资粮积集。一切魔王及魔军众。诸威德天不能遮断。舍利子。是名菩萨摩诃萨依静虑波罗蜜多故获是如意足作证神通智业圆满

复次舍利子。云何菩萨摩诃萨。依静虑波罗蜜多故得是神通。此神通者何等义理。复以何等而名为智。舍利子。菩萨摩诃萨。若观色像名曰神通。若能了知色像尽法而不证尽。是名为智。又舍利子。若能听闻一切声响。是名神通。若能了知声响前际本不可说。是名为智。又舍利子。若能了达众生心行。是名神通。若能了知心性寂灭不证彼灭。是名为智。又舍利子。若能随念过去边际。是名神通。若能了知三世无碍。是名为智。又舍利子。于诸佛土若往若来。是名神通。若知国土等虚空相。是名为智。又舍利子。了法兴起故。名为神通。观法平等。是名为智。又舍利子。明达诸世间。故名神通。不杂诸世间。是名为智。又舍利子。威势映夺一切释梵护世诸天。故名神通。了知一切声闻缘觉其证下劣。是名为智。舍利子。诸如是等若通若智。其德无量不可思议。是名菩萨摩诃萨依静虑波罗蜜多故精勤获得如是神通智业圆满

复次舍利子。菩萨摩诃萨。依静虑波罗蜜多故。证得无边深妙静定。何以故。舍利子。菩萨摩诃萨。乃至尔所无数烦恼积集心舍。菩萨于彼亦有尔所无数静虑资粮功德安住其心。又舍利子。菩萨摩诃萨。乃至尔所一切众生。以烦恼心生诸散乱。菩萨于彼亦应积集尔所静虑资粮功德。舍利子。是名菩萨摩诃萨所证静虑无量无边皆由静虑波罗蜜多之所发起。复次舍利子。菩萨摩诃萨。所证之定极善深妙。菩萨应时安住于中平等引摄。是处说名三摩呬多。舍利子。云何名为平等引摄。舍利子。三摩呬多者引摄有情平等之性。故名此定三摩呬多。舍利子。三摩呬多者引摄其心平等性故。又三摩呬多者引摄欲解平等性故。又三摩呬多者引摄方便平等性故。又三摩呬多者引摄增上欲解平等性故。又三摩呬多者引摄拖那平等性故。又能引摄尸罗羼底毗利耶静虑般罗若平等性故。又三摩呬多者引摄一切诸法平等性故。舍利子。是名菩萨摩诃萨三摩呬多。深妙静虑引摄平等诸法性故

复次舍利子。菩萨摩诃萨。依静虑波罗蜜多故所获静虑微密深妙唯智能入。亦得名为三摩半那。舍利子。何等名为三摩半那。舍利子。如是妙定等诸法性。所以者何。若菩提平等。即是一切有情平等。若一切有情平等。即是诸法平等。若能平等证入是平等性。是则名为三摩半那。又舍利子。若空性平等。即诸法平等。若能证入是平等性。是则名为三摩半那。如是无相无愿及以无行性皆平等。即诸法平等。若能证入是平等性。是则名为三摩半那。又舍利子。若心性平等。即诸法平等。若能证入是平等性。是则名为三摩半那。舍利子。是名菩萨摩诃萨获是静虑三摩半那平等之性皆因静虑波罗蜜多故

复次舍利子。菩萨摩诃萨。依静虑波罗蜜多故。获是平等微妙静虑。于诸含识有恩无恩。皆生平等心无简约。是故菩萨。等心于地。等心于水。等心于火。等心于风。等心虚空。无有高下亦无萎屈。安住善住证无动摇。于诸威仪心恒在定。又不分别所住威仪。心性纯熟乐处深定。不掉不举无有飘转。远诸愚钝言无杂乱。知义知法善识诸时。所谓迦罗吠罗。及三摩耶。巧能随顺一切世间。而与世间性不相杂。超越世间利等八法。诸烦恼惑不能染污。杂愦闹处。远于所行。唯常安止平等法性。不舍深定而现世间一切作业。舍利子。是名菩萨摩诃萨依静虑波罗蜜多故证入如是无量功德。当知皆是妙慧方便之所发起。复次舍利子。云何菩萨摩诃萨依静虑波罗蜜多故证是妙慧及以方便。舍利子。菩萨摩诃萨。以大悲力系心于境为度众生。是名方便。证入寂静最极寂静。是名为慧。又舍利子。若能证入佛智无碍。是名方便。无有一法而可虑知。是名为慧。又舍利子。若能证入诸法摄观。是名方便。若于法性无杂思惟。是名为慧。又舍利子。平等证入佛身庄严而现在前。是名方便。观察法身性无处所。是名为慧。又舍利子。平等证入忆念诸佛所演言词梵言声等。是名方便。观察法性不可言说。是名为慧。又舍利子。平等证入其心安住金刚喻定。是名方便。念无散乱观察法性。是名为慧。又舍利子。若如是定安住本愿成熟众生。是为方便。观察众生皆无我性。是名为慧。又舍利子。若定缘彼增上境界。发起一切增上善根。是名方便。若能观察无根无住。是名为慧。又舍利子。若定修治佛土现前。是名方便。观察国土与虚空等。是名为慧。又舍利子。若定发起庄严道场。是名方便。若住寂静虑知诸法。是名为慧。又舍利子。若定发起转正法轮。是名方便。若观所转法轮无起。是名为慧。又舍利子。如是无量觉分资粮平等证入观察现前。是名方便。如是无量诸惑寂灭息除热恼。如来所有静虑妙乐。不与诸法而共相应。无有诸相诸相遍知。远离一切所缘境界。如是皆入菩萨正定所有静虑。舍利子。菩萨摩诃萨。若能如是观察具足。是名为慧。舍利子。若菩萨摩诃萨。成就如是无尽静虑与静虑波罗蜜多相应故。一切恶魔不能得便。即名安住诸佛法器。舍利子。如是方便。如是妙慧。是名菩萨摩诃萨静虑波罗蜜多具足成就皆是妙慧方便之所发起

复次舍利子。菩萨摩诃萨。依静虑波罗蜜多故。具足成就不退神通。善能建立智所作业。非彼慢力之所发起。游戏神通示现世间。一切作用安住神通。发起世间一切大事。又舍利子。此神通者为大智相。具足世出世间微妙作用故。此神通者为大慧相。现见世出世间一切诸法故。此神通者为无尽相。随遍一切如虚空故。此神通者等见诸色。色无色中平等见故。此神通者善能随入音声法门。前际音声平等性故。此神通者能观众生一切心行。现见彼性故。此神通者善能随念一切诸劫。分别了知前后际故。此神通者善能示现无量神变。恒现在前无加行相故。此神通者了知漏尽。观待迦罗及三摩耶不过时故。此神通者是圣出世。于一切法决择分故。又舍利子。如是神通微妙甚深。声闻独觉所不能测。如是神通有大威德。善能调伏一切有情。如是神通有大功业。证得灌顶一切诸法自在转故。如是舍利子。是名菩萨摩诃萨依静虑波罗蜜多故获是无退诸胜神通善能建立智所作业非彼慢力之所发起

大宝积经卷第四十九大宝积经卷第五十

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十六静虑波罗蜜品第十之二

复次舍利子。菩萨摩诃萨。修行静虑波罗蜜多故。获得如是无退神通。善能建立智所作业。舍利子。当知菩萨摩诃萨。得是通智。由清净心。鲜白心。明洁心。无浊心。离随烦恼心。善调顺心。善寂静心。善修治心。如是心相之所由生。静虑解脱三摩地三摩钵底之所发起。舍利子。是菩萨摩诃萨。处于世界。故作意生。非系缚生。不由系缚。命终受生。何以故。是菩萨摩诃萨。解脱一切虚妄分别故。解脱一切非真实烦恼缚故。解脱一切颠倒妄执所依止故。是故此菩萨摩诃萨。随现世界。解脱而生。解脱命终。解脱受生。舍利子。是菩萨摩诃萨。现受生已成办大乘。圆满一切诸佛正教。遍游十方广求佛法。虽志有所求。而无取无得。随入诸佛法。即为一切法。随入一切法。即为诸佛法。如是菩萨。随入佛法及一切法。然不随彼法非法行

舍利子。菩萨摩诃萨。若能如实求诸法时。安住无取及无得者。是则无有一法而可入于算数。何以故。一切诸法超过算数道故。若能了达法平等性。是则不执法与非法。何以故。一切诸法性无执故。若计于中而有义者。是则获得广大无义。若有善能不计于义。是则义与非义不现前故。不见义者于一切处觉慧无碍。是菩萨摩诃萨。若能如是了觉无碍。则为获得无障碍觉。若有无障碍觉。则于一切而无所著。若无所著则无所住。若无所住则无所乏。若无所乏则无痴无求若无痴无求则无迷无惑。若无迷无惑则无我所。若无我所则无摄受。若无摄受则无所执。若无所执则无诤论。若无诤论是则无诤沙门之法。若有无诤沙门法者。是则一切无碍无障等虚空求。若能等彼虚空求者。则不系属欲界色界及无色界。若于诸处无系属者。则无色相及以形量。若其无是色相形量。则能如是随觉。若能如是随觉。则能如是通达。舍利子。云何说名随觉通达。舍利子。菩萨摩诃萨。若能随觉通达。是处无有少法可得。此则说名随觉通达。舍利子。诸菩萨摩诃萨。由平等证入如是随觉通达故。说是菩萨摩诃萨依静虑波罗蜜多成就希奇未曾有法

复次舍利子。云何名为菩萨摩诃萨成就希奇未曾有法。舍利子。菩萨摩诃萨。依静虑波罗蜜多故。虽行大慈而恒观无我。虽行大悲而知无众生。虽行大喜而知无命者。虽行大舍而知无数取。虽广行大施而心恒调顺。虽缘境净戒而心常寂静。虽随辱行忍而心无穷际。虽勤加精进而心能简集。虽入诸静虑而正心观察。虽遍行智慧而心无所行。虽行四念住而心无缘念亦无作意。虽行四正断而心无生灭。虽行如意足而心无戏论。虽行净信而心无系着。虽行正勤而心恒远离。虽行于念而心恒自在。虽住三摩地而心证平等。虽行般罗若而心本无根。虽行诸力而心无摧伏。虽行觉分而解析菩提。虽修道分而心无所修。虽行奢摩他而心恒寂灭。虽行毗钵舍那而心无定观。虽修行圣谛而毕竟遍知。虽成熟众生而心本清净。虽摄受正法而不坏法性。虽净佛国土而心等虚空。虽证无生法而心无所得。虽行不退转地而心性无退。虽获诸妙相而知性无相。虽庄严道场而心游三界常处周轮。虽降伏魔军而于诸含识无所摧伏。虽知诸法即菩提性而心随觉了。虽转法轮而心住法性无还无转。虽复示现大般涅槃而于生死性心常平等。如是舍利子。是名菩萨摩诃萨平等证入随觉通达。如是希奇未曾有法。当知修行静虑波罗蜜多之所成就

复次舍利子。何等名为菩萨摩诃萨依静虑波罗蜜多修学菩萨静虑之相。舍利子。菩萨静虑不住自性。为满如是三摩地故。菩萨静虑无有爱味。不为贪着自安乐故。菩萨静虑缘于大悲。为断一切众烦恼故。菩萨静虑定无退转。缘于欲性增上性故。菩萨静虑蓥发神通。了达众生诸心行故。菩萨静虑心欣爱悦。善能显发心自在故。菩萨静虑了知一切三摩钵底。映蔽一切色无色界故。菩萨静虑是为寂静。最胜寂静。近于寂静。映蔽声闻独觉定故。菩萨静虑无有分别。极为究满妙清净故。菩萨静虑行品最胜。习气相续永除灭故。菩萨静虑以慧超度。超度一切诸世间故。菩萨静虑为诸含生欲解导首。善能度脱诸含生故。菩萨静虑绍三宝种令不断绝。以佛静虑无穷尽故。菩萨静虑最为高显。三摩呬多常现前故。菩萨静虑自在而转。诸有所作善圆满故。菩萨静虑是为大我。以妙智慧为大我故。舍利子。如是无量菩萨静虑。皆是菩萨摩诃萨依静虑波罗蜜多之所集起

复次舍利子。菩萨摩诃萨静虑波罗蜜多。何等之法而为前导。舍利子。静虑波罗蜜多者。心静观智。以为前导。心住一缘。以为前导。心无散动。以为前导。其心安住。以为前导。心奢摩他。以为前导。心三摩地。以为前导。三摩地根。以为前导。三摩地力。以为前导。三摩地觉分。以为前导。正三摩地。以为前导。静虑解脱。以为前导。九次第定。以为前导。九灭除法。以为前导。一切善法。以为前导。伏烦恼怨。以为前导。三摩地蕴具足圆满。以为前导。菩萨摩诃萨诸三摩地。以为前导。佛薄伽梵诸三摩地。以为前导。舍利子。如是等无量静虑。皆为静虑波罗蜜多前导之法。舍利子。复有无量无边证寂静法。并是静虑波罗蜜多之所前导。舍利子。是名菩萨摩诃萨静虑波罗蜜多。菩萨摩诃萨。为阿耨多罗三藐三菩提故。当于是中发勤精进具足修学行菩萨行。尔时世尊。欲重宣此义。而说颂曰

  静虑解脱到彼岸　　勤行此行多劫海
  其心清净无浊秽　　不染世法喻莲花
  有大静定名遍照　　此定依修到彼岸
  又名月光净庄严　　复名电光所严饰
  或名高行或心勇　　或定名为无垢光
  或戒德办或无忧　　或名诸法自在转
  或名法炬或法勇　　或名山威法自在
  或正法智自然超　　或持正法妙清净
  或名观察他心定　　或名正法宝光明
  复名灭惑严胜幢　　有定名为摧魔力
  或名断疑及无著　　或定名为寂静灯
  或力高胜或十力　　或名敬手大名称
  或名持山善安住　　或苏迷卢大明灯
  或名无胜胜彼胜　　或名智炬及慧行
  或无边智或自在　　或名发慧寂静定
  或名月净日音声　　或那罗延摧高慢
  或善调龙师子吼　　或名远离种种想
  或名旋转或返还　　或无瞚眼力清净
  或定名为念诸佛　　或名念法或念僧
  或名智转或入空　　或名无相或无愿
  或金刚喻或静地　　或金刚地或高胜
  或名山王或不瞚　　或无边转或净音
  或离烦恼或观察　　或虚空妙或如空
  或发广大诸功德　　或趣觉慧或念慧
  或辩无尽或相续　　或无边说词无尽
  或无坏善作所作　　或名观察或众悦
  或名慈现或悲广　　或入欢喜或欣庆
  或舍或脱二种碍　　或名法光或法义
  或金刚幢或智海　　或解脱坚或众喜
  或名智炬无动定　　或定名曰胜莲花
  或简集法或无动　　或名慧上及寂静
  或无边光或佛海　　或名解脱或智授
  或名如来妙庄严　　或名无边胜光焰
  或名欢喜庄严土　　或名悦豫众生意
  有定名为一切时　　顺菩提道三摩地
  或定名为到彼岸　　觉分花严施宝髻
  或施甘露坚解脱　　或风无动盛光明
  或名海潮沟宝藏　　诸那罗延山峰力
  或名神通广大义　　妙善摄受三摩地
  或定名为大通照　　诸佛如来之境界
  证得如斯寂静定　　及余拘胝无有边
  修行静虑到彼岸　　菩萨功德广无量
  行住恒游静虑境　　其心无扰常澹泊
  若坐若卧止定中　　无有威仪不在定
  处定能发大音声　　以诸法性恒寂静
  无异分别无自在　　无我无命无分别
  如是及余无涯际　　无有数量功德海
  聪睿菩萨愍含灵　　修行静虑到彼岸

    般若波罗蜜多品第十一之一

复次舍利子。云何菩萨摩诃萨。般若波罗蜜多。菩萨摩诃萨。为阿耨多罗三藐三菩提故。依此勤修行菩萨行。舍利子。菩萨行般若波罗蜜多故。于菩萨藏微妙法门。殷勤郑重听闻受持。若读若诵。思择义理。既能通达。复为他人广宣敷演开示其要。舍利子。若有菩萨摩诃萨。闻我说已如法奉行。于菩萨藏微妙法门。殷勤郑重听闻受持。读诵研寻。通达其义。为他宣说广开示已。当知是人证得如是无尽慧相。舍利子。如是慧者为何等相。云何入证。舍利子。所言慧者以闻为相。菩萨之人如理证入。是故说为无尽慧相。又舍利子。如是之相。我当广说。谓此相者。菩萨摩诃萨。为求正法。欲乐为相。欲解为相。方便为相。善友为相。无慢为相。于多闻所恭敬为相。尊重为相。旋绕为相。谦敬为相。亲觐为相。谛闻为相。承事为相。思惟为相。不乱为相。珍宝想为相。良药想为相。息诸病想为相。念器为相。趣觉为相。乐大慧为相。证入觉为相。闻无厌足为相。舍增益为相。调顺离薪为相。亲近多闻者为相。于诸作事喜爱为相。身调适为相。心勇锐为相。又舍利子。菩萨摩诃萨。于听法众无倦听闻为相。听闻正义为相。听闻正法为相。听闻正行为相。听闻证智为相。听闻波罗蜜多为相。听闻菩萨藏法为相。听闻诸摄法为相。听闻方便善巧为相。听闻梵住为相。听闻神通为相。听闻正念正智为相。听闻念住为相。听闻正胜为相。听闻神足为相。听闻缘起为相。听闻无常为相。听闻苦法为相。听闻无我为相。听闻寂静为相。听闻空为相。听闻无相为相。听闻无愿为相。听闻无加行为相。听闻善根加行为相。又舍利子。如是自在为相。闻法为相。对治杂染为相。制伏一切烦恼想为相。赞美智者为相。亲觐圣者为相。远离非圣为相。听闻圣者为相。听闻诸根为相。听闻修习随念为相。听闻觉分为相。听闻圣八支道为相。听闻如来力无所畏大慈大悲大喜大舍无碍辩才十八不共佛法为相。如是舍利子。当知菩萨摩诃萨。若于此听闻。即于此解了。若于此解了。即于此正行。何以故。舍利子。若菩萨摩诃萨。于菩萨藏微妙法门。闻相趣入。方便无量。吾今略说四十一种。舍利子。何等为相。一者若有菩萨。于此法门生欲乐者。当知此菩萨摩诃萨。即为听闻闻便解了。既解了已便行正行。二者若有菩萨。于此法门生于欲解当知此人。即是听闻解了。行于正行。三者若有菩萨。于此法门方便趣入。当知此人即是听闻解了。行于正行。四者若有菩萨。亲近善友。此人即为听闻解了。行于正行。五者若有菩萨。于多闻所心无有慢。此人即为听闻解了。行于正行。六者若有菩萨。恭敬多闻。此人即为听闻解了。行于正行。七者若有菩萨。于多闻者生尊重心。此人即为听闻解了。行于正行。八者若有菩萨。于多闻所旋绕奉敬。此人即为听闻解了。行于正行。九者若有菩萨。于多闻所行谦下心。此人即为听闻解了。行于正行。十者若有菩萨。亲近多闻。此人即为听闻解了。行于正行。十一若有菩萨。于多闻所摄耳谛听。此人即为听闻解了。行于正行。十二若有菩萨。于多闻所承事迎逆。此人即为听闻解了。行于正行。十三若有菩萨。于多闻所思惟义趣心定不乱。此人即为听闻解了。行于正行。十四若有菩萨。于多闻所起珍宝想。此人即为听闻解了。行于正行。十五若有菩萨。于多闻所起良药想。此人即为听闻解了。行于正行。十六若有菩萨。于多闻所能起息灭贪嗔痴想。此人则为听闻解了。行于正行。十七若有菩萨。于多闻所闻已能持。此人则为听闻解了。行于正行。十八若有菩萨。趣觉于法。此人则为听闻解了。行于正行。十九若有菩萨。于多闻所乐其智慧。此人则为听闻解了。行于正行。二十若有菩萨于多闻所闻已觉悟。此人则为听闻解了。行于正行。二十一若有菩萨。闻无厌足。此人则为听闻解了。行于正行。二十二若有菩萨。闻说柁那便增长舍。此人则为听闻解了。行于正行。二十三若有菩萨。闻说尸罗便守护戒。此人则为听闻解了。行于正行。二十四若有菩萨。闻说羼底便能修忍。此人则为听闻解了。行于正行。二十五若有菩萨。闻说毗利耶。便起正勤无倦精进。此人则为听闻解了。行于正行。二十六若有菩萨。闻说静虑便入静虑其心不散。此人则为听闻解了。行于正行。二十七若有菩萨。闻说般罗若其心决定。便修智慧为尽诸漏。此人则为听闻解了。行于正行。二十八若有菩萨。于多闻所生大欢喜。此人则为听闻解了。行于正行。二十九若有菩萨。听闻法已身调适者。此人则为听闻解了。行于正行。三十若有菩萨。听闻法已其心勇锐。此人则为听闻解了。行于正行。三十一若有菩萨。闻大乘经心生信欲。此人则为听闻解了。行于正行。三十二若有菩萨。闻摄法已其心趣入。此人则为听闻解了。行于正行。三十三若有菩萨。闻说念住便即趣于身受心法。此人则为听闻解了。行于正行。三十四若有菩萨。闻说正胜。便于恶法已生未生。若背若舍。若彼善法已生未生。不舍觉转。此人则为听闻解了。行于正行。三十五若有菩萨。闻说神足即能奉行生身轻性。生心轻性。生欲轻性。此人则为听闻解了。行于正行。三十六若有菩萨。闻说静虑便静思惟其心趣入。此人则为听闻解了。行于正行。三十七若有菩萨闻诸法中不轻蔑行。便于众生起大慈心。于入苦者起大悲心。于正法所起大喜心。于不善所起大舍心。此人则为听闻解了。行于正行。三十八若有菩萨。闻说根已。其心趣入于彼诸根。所谓信根精进根。念根。慧根。三摩地根此人则为听闻解了。行于正行。三十九若有菩萨闻说觉分。其心趣入觉悟法性。此人则为听闻解了。行于正行。四十若有菩萨。闻说道支。其心趣入涅槃正路。此人则为听闻解了。行于正行。四十一若有菩萨。闻说如来力无所畏大慈大悲大喜大舍无碍辩才十八不共佛法及余无量诸佛正法。皆听闻已。其心趣入阿耨多罗三藐三菩提。此人如是如法听闻。既听闻已便能解了。既解了已行于正行。舍利子。我已说是四十一法趣入闻相。诸菩萨摩诃萨。当于中学。舍利子。如是名为菩萨摩诃萨修行般若波罗蜜多闻慧本相

复次舍利子。菩萨摩诃萨。修行般若波罗蜜多行菩萨行者。应于如是大菩萨藏微妙法门。郑重听闻受持读诵。思惟其义通微妙法。复为他人广分别说。是行资粮。舍利子。云何菩萨摩诃萨于如是法而起正行。舍利子。菩萨于法起正行者。所谓如说修行。建立而住。是名于法而起正行。若复有能一切不取。是名于法而起正行。何以故。舍利子若取于法即名邪行。无处无位执取法人。由如是法能得出离。必无是处。何以故。无取行人。于法无行。尚应生疑。无作用故。况取法行而非邪行。是故应当不取诸法而行正行。又舍利子。若于诸法无有障碍。是名正行。若于诸法不轻蔑者。是名正行。若于诸法不取不舍不生不灭。是名正行。乃至若于诸法无合无散。是名正行。又舍利子。如我所说若有是处。无有少法而可见闻。亦无可说。如是一切诸法非可得见。非可执取。何以故。一切诸法皆是一相。所谓无相

又舍利子。一切诸法性本无相。若有菩萨。说于无相。是则无相。还应可说。何以故。无相有相皆无相故。不可说言。此为有相。此为无相。舍利子。若有菩萨摩诃萨。能悟如是一切法相。即是无相。不可得见。不可执取。如法了知。是名正行。菩萨摩诃萨。勤修如是正法行已。当于诸法证入无障照明之慧。如是舍利子。是名菩萨摩诃萨般若波罗蜜多正行之相。尔时世尊。欲重宣此义。而说颂曰

  安住正行聪睿者　　于菩萨藏善决定
  此人于法不起执　　无执取行相如是
  证得诸法不为空　　非于诸法空平等
  又非空法有所执　　无执正行相如是
  于法无取亦无舍　　亦非取法以为法
  无取是名诸法相　　无取正行相如是
  若于诸法智无碍　　此智无有不焚烧
  于焚烧智无所执　　诸法正行相如是
  智者安住远离德　　于法应起勤精进
  若能依止轨则行　　尔时当入清净门
  是清净门通诸法　　亦了有情诸欲解
  智者虽知无所观　　而能演宣如是法
  于甚深法了胜义　　常于深义胜决择
  踊现无边功德行　　明智多闻如大海
  于彼所说诸文义　　究竟无能证得者
  以彼文义俱无边　　真实正行恒无动

复次舍利子。菩萨摩诃萨。修行般若波罗蜜多时。于菩萨藏微妙法门。殷重听闻。乃至为他如法说已。当知是菩萨摩诃萨。于一切法获得光明。能破一切无明黑闇及诸翳膜。舍利子。如是光明即为智慧。何以故。善不善法皆能明了如实知故。是菩萨摩诃萨。修如是法获明慧已。乃至命难众苦因缘。决定不造诸不善法。舍利子。是菩萨摩诃萨。为欲永灭不善法。故随所闻法极善通达。既通达已。是则说为牟尼寂静。如是舍利子。是名菩萨摩诃萨修行般若波罗蜜多时正行之相。尔时世尊。欲重宣此义而说颂曰

  如人入闇室　　覆蔽绝光明
  虽有众色像　　非明眼所见
  如是虽有人　　内具诸明解
  不闻于正法　　善恶何能晓
  多闻解了法　　多闻不造恶
  多闻舍无义　　多闻得涅槃
  善听增长闻　　闻能增长慧
  慧能修净义　　得义能招乐
  聪慧得义已　　证现法涅槃
  净觉法相应　　证得第一乐
  闻菩萨藏已　　正法善安住
  为世大光明　　行菩提妙行

复次舍利子。菩萨摩诃萨。为欲修行般若波罗蜜多故。于能受持菩萨藏经正行人所。深起敬心善知识想。既生想已。又于大菩萨藏微妙法门。倍复寻求。令此法门转增明净。舍利子。是菩萨摩诃萨为求菩萨藏故。发生信欲。策励正勤。捡摄其心。令定安住。是菩萨摩诃萨。于四正断方便修成。一切法中得无障碍。如是舍利子。是名菩萨摩诃萨般若波罗蜜多正行之相。尔时世尊。欲重宣此义。而说颂曰

  所谓说法者　　即为善知识
  恭敬听闻法　　安住于正行
  欲解常无退　　精进常高勇
  净慧常修治　　于智常安住
  自然达诸法　　不随于信行
  以智观于法　　是为诸佛说
  智者分别句　　趣义善加学
  于白黑品等　　常修常远离
  心曾无厌倦　　于法无退没
  身欲并轻安　　速得心精进
  由闻法增智　　智增无退念
  智恒依念住　　了知净秽法
  学于无上法　　趣胜念慧力
  了众生欲解　　自学于长夜
  学法已升进　　极进智清净
  了众生欲解　　如解便开示

复次舍利子。菩萨摩诃萨修行般若波罗蜜多时。于菩萨藏微妙法门。如是寻求通达觉慧。依是清净善法明门。菩萨常应如是修学。舍利子。若有菩萨摩诃萨。于法修学。应作是念二因二缘能发正见。何等为二。所谓从他闻音及以内自如理作意。彼复思惟。从他闻音。如理作意。为何等相。寻重思惟。若有乐定。修相应行诸菩萨等。未曾听闻大菩萨藏微妙法门。又不听闻圣法律教。但于三摩地中生知足想。当知是人以慢力故起增上慢。我说是人不能解脱生老病死愁叹忧苦诸热恼等。既不脱诸热恼等苦。岂得脱。彼五门生死为之沉溺流转不息。是诸众生实非解脱。而便自谓我已解脱。实未离苦。而便自谓出离众苦。是故如来依是人故。如实说法。若能从他随顺听闻。是则解脱诸老死等。复作是言。如我先闻薄伽梵说

  多闻解了法　　多闻不造恶
  多闻舍无义　　多闻得涅槃
  善听增长闻　　闻能增长慧
  慧能修净义　　得义能招乐
  聪慧得义已　　证现法涅槃
  闻法净黠慧　　证得第一乐

是故舍利子。诸菩萨摩诃萨如是思已。当于大菩萨藏微妙法门。及以圣法毗奈耶教。殷重听闻受持读诵。广为他人敷演开示

复次舍利子。若诸含识于菩萨藏微妙法门。虽复听闻而不如理方便作意。当知是人于彼圣道不能正行。是故如来依是人故说正法要。作如是言。若欲解脱生老病死。当具内自如理思惟。诸菩萨等应如是学。舍利子。云何名为如理方便。何等菩萨如理作意而能修学。舍利子。菩萨摩诃萨如理方便者。无有一法若合若离。何以故。如理方便非方便故。又舍利子。菩萨摩诃萨。若有安住如理方便及作意者。当知此相但是音声。而此音声性无所起。亦不转起。及由彼故而发音声。何以故。彼一切皆不可得故。又复菩萨观是音声前际后际。从何而生灭往何所。如是观察了不可得。又更推求如此声者。为在已说。为在今说。为在当说。又重推求如是声者。若已所说。若今所说。若当所说。如是声者。若为断故已说。若为断故今说。若为断故当说。如是声者。若为证故已说。若为证故今说。若为证故当说。是菩萨如是一切寻求声已都无得者。又更观察。若过去相。若未来相。若现在相。如是观已皆不可得。舍利子。若菩萨摩诃萨。如是正观察时。是名如理方便作意。是故如理方便菩萨摩诃萨。于如是观应具修学

复次舍利子。云何菩萨摩诃萨。如理观耶。诸菩萨等云何应学。舍利子。是菩萨摩诃萨。观一切法自性息灭。若如是观。名如理观若观诸法自性寂静。是则名为如理正观。若观诸法毕竟空寂。是则名为如理正观。若观诸法入平等性。是则名为如理正观。若观诸法毕竟无生。是则名为如理正观。若观诸法毕竟不生。是则名为如理正观。若观诸法毕竟不起。是则名为如理正观。若观诸法毕竟寂灭。是则名为如理正观。舍利子。是菩萨摩诃萨作是观时。亦不见有能观之者。应如是观。所谓非观非不观故。若有菩萨作是观者名如理观。若他观者名非理观

复次舍利子。云何菩萨摩诃萨。应学如是如理方便。舍利子。菩萨摩诃萨。如理方便者。非于少法有愚迷故。如理方便者。非于少法而生障碍。如理方便者。无有少法非解脱门。如理方便者。无有为断少分法故发勤精进。如理方便者。不为证少法故勇励正勤。舍利子。菩萨摩诃萨应以如是如理正见。如其所见正观诸法。舍利子。云何名为如其所见正观诸法。舍利子。谓无所见名观诸法。何等是为无所见耶。舍利子。无所见者。名为无生。言无生者。是为无起。言无起者。名无所照。是故如来。依是正法。说如是言。若有菩萨。观一切行见无生时。即是趣入正性决定。夫正见者谓能趣入正性决定。舍利子。彼菩萨摩诃萨。作是思惟。何因缘故。当得趣入正性决定。舍利子。菩萨摩诃萨。应如是学。若观我见为平等者。即是一切诸法平等。若作是观。当知趣入正性决定。是故诸菩萨摩诃萨。若欲趣入正性决定者。当于如是大菩萨藏微妙法门。殷重听闻受持读诵研穷义趣。复应为他如法广说。便当于是法门如理方便作意修学。舍利子。如是名为菩萨摩诃萨为阿耨多罗三藐三菩提故修行般若波罗蜜多行菩萨行

大宝积经卷第五十大宝积经卷第五十一

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十七般若波罗蜜多品第十一之二

复次舍利子。菩萨摩诃萨修行般若波罗蜜多时。为求如是深极妙善清白觉慧故。由是妙善净法明门。精勤方便如理证入观如理句。舍利子。云何名为如理证入。复以何等为如理句。舍利子。菩萨摩诃萨如理证入者。谓依奢摩他证入。毗钵舍那证入。正行证入。如理证入。身远离证入。心调顺证入。非断证入。非常证入。因缘证入。缘起证入。无有情无命者无数取者证入。未来已来若有若无证入。无有转移因果不坏证入。虽修集空无相无愿证入。而不取空无相无愿证故。虽于三摩地三摩钵底证入。而不以如是等力受生证故。虽取神通智证入。而不尽诸漏证故。虽观察无生证入。而不正趣决定证故。虽观众生无我证入。而不舍大悲证故。虽观一切有生可怖证入。而故取诸有证故。虽于寂灭离欲证入。然于离欲法不作证故。虽舍乐妙欲证入。而不舍乐法证故。虽舍一切戏论思觉证入。而不舍善巧方便证故。舍利子。如是名为如理证入。菩萨摩诃萨。欲得如是如理证入。应当修学般若波罗蜜多故

复次舍利子。菩萨摩诃萨。修行般若波罗蜜多时。云何学是正法如理之句。舍利子。菩萨摩诃萨当如是知。如理句者即出生句。即趣理句。即法门句。即面门句。即是因句。即积集句。即不相违句。即无诤论句。即是舍句。即无执取句。即无弃舍句。即无戏论句。即无舍句。即无诽谤句。即无轻蔑句。即随足句。即无诤句。即无退转句。即无对治句。又舍利子。如理句者实性之句。如性之句。非不如性句。真如之句。如理之句。三世平等句离分别句。又舍利子。如理句者色识无依住句。受想行识识无依住句。眼色眼识性无依住句。耳声耳识性无依住句。鼻香鼻识性无依住句。舌味舌识性无依住句。身触身识性无依住句。意法意识性无依住句。又舍利子。如理句者即名依义句。即名依法句。即名依智句。即名依了义句。舍利子。如是等无量法门。是则名为如理之句。是故如理证入正勤方便。菩萨摩诃萨作如是观时。亦不见有能观之者。应如理观。所谓非观非不观故。若有菩萨作是观者名如理观。若他观者名非理观。舍利子。如理方便菩萨。非于少法而有愚迷。非于少法而生障碍。无有少法非解脱门。非为断少法故发勤精进。不为证小法故勇励正勤。应具如是如理正见。如其所见正观诸法。何等正观谓无所见。无所见者即是无生。言无生者即是无起。言无起者名无所照。舍利子。如是次第转法广如前说。乃至名为菩萨摩诃萨修行般若波罗蜜多故

复次舍利子。菩萨摩诃萨。修行般若波罗蜜多时。云何应学如理正观。舍利子。是菩萨摩诃萨。应作如是正观诸法。所谓我如理故。则观诸法一切如理。我无我故则观诸法亦复无我。众生无我故则观诸法亦复无我。舍利子。菩萨摩诃萨作是观者名如理观。舍利子。云何菩萨摩诃萨。修行如理方便。舍利子。当知是菩萨摩诃萨。不观如理生死性与彼如理涅槃性共相交杂。作如是观。是则名为如理方便。又是菩萨观烦恼性与涅槃性同一合相无有差异。亦不分别相应违背。作如是观。是则名为如理方便。亦得名为如理正观。舍利子。当知菩萨摩诃萨。所有一切如理方便。皆于无量众生处起。若众生处不弃舍于诸法不破坏。是名菩萨如理方便。舍利子。菩萨摩诃萨。应知如是相。如是闻。如是如理证入。如是如理观察。如是如理正见等流。是名菩萨如理正慧。舍利子。菩萨摩诃萨。应当如是修行正行。皆为成满般若波罗蜜多故

复次舍利子。菩萨摩诃萨。修行般若波罗蜜多时。所有般若自性清净不与一切有为行法而共同止。舍利子。何等诸法不与同止。舍利子。所谓如是般若不与无明而共同止。不与诸行而共同止。如是广说乃至不与老死而共同止。舍利子。如是般若不与身见而共同止。乃至不与身见为本六十二见趣而共同止。如是般若不与高慢而共同止。不与下劣而共同止。不与世间八法而共同止。舍利子。如是般若不与蕴界处法而共同止。乃至不与一切所缘作意而共同止。如是般若不与慢同止。不与下慢邪慢同止。乃至不与随烦恼等二十一法而共同止。如是般若不与微细下劣中上品贪同止。乃至不与一切烦恼而共同止。如是般若不与愚暗翳膜障盖诸缠同止。乃至不与一切随顺退分诸法而共同止。如是般若不与欲诤秽浊烦恼魔同止。不与蕴魔死魔天魔同止。乃至不与一切魔业而共同止。如是般若不与执我同止。不与有情命者数取养育意生摩纳婆等同止。乃至不与住我见等而共同止。如是般若不与业障同止。不与烦恼障法障见障报障智障同止。乃至不与一切随俗习气而共同止。如是般若不与思惟分别同止。不与相貌所缘见闻念识同止。乃至不与一切结缚增益而共同止。如是般若不与悭舍同止。不与持犯忍恚勤怠静乱愚慧同止。乃至不与一切波罗蜜多能治所治诸法智性而共同止。如是般若不与远离同止。不与住不远离邪性正性善及不善有罪无罪生死涅槃同止。乃至不与一切相对治法而共同止。如是般若不与种种差别性同止。不与国土差别性诸佛差别性有情差别性诸法差别性同止。乃至不与一切差别性而共同止。如是般若不与无智同止。不与智识世俗胜义乃至不与一切有情相貌作意而共同止。如是般若不与慧不现行同止。不与无身无形无相无为同止。乃至不与一切思惟心意识安住等法而共同止。舍利子。菩萨摩诃萨。修行般若波罗蜜多时。所有般若微妙清净。不与如是无量无边有为行法而共同止。舍利子。如是名为修行般若波罗蜜多。菩萨摩诃萨般若之相应如是学

复次舍利子。菩萨摩诃萨。安住大乘大菩萨藏。修行般若波罗蜜多时。获得般若分别善巧。当知是菩萨摩诃萨。即以此法于诸法中明了通达获得善巧。舍利子。云何名为如是般若分别善巧。舍利子。如是善巧无量无边。吾今略说十种善巧。何等为十。所谓蕴法善巧。界法善巧。处法善巧。谛法善巧。无碍解善巧。依趣善巧。资粮善巧。道法善巧。缘起善巧。一切法善巧。舍利子。如是十种微妙善巧所有分别。若通达者。是则名为般若分别。菩萨摩诃萨于是善巧应当修学。复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多故。而能通达蕴法善巧。舍利子。蕴法善巧者。所谓依诸蕴法起于言说。何等言说。舍利子。如是言说。犹如幻化阳焰梦中传响光影。是故如来以无碍辩。为诸众生说如是法。舍利子。我说此色喻如聚沫。何以故。舍利子。即此聚沫本无有我。亦无有情。无生者。无命者。无数取。无养育。无意生。无摩纳婆。以聚沫性即色自性。菩萨摩诃萨。于如是法善巧知之。是则名为蕴法善巧。又舍利子。我说此受喻如水泡。何以故。舍利子。即此水泡本无有我。亦无有情。无生者。无命者。无数取。无养育。无意生。无摩纳婆。以水泡性即受自性。菩萨摩诃萨。于如是法善巧知之。是则名为蕴法善巧。又舍利子。我说此想喻如阳焰。何以故。舍利子。即此阳焰本无有我。亦无有情。无生者。无命者。无数取。无养育。无意生。无摩纳婆。以阳焰性即想自性。菩萨摩诃萨。于如是法善巧知之。是则名为蕴法善巧。又舍利子。我说此行喻如芭蕉。何以故。舍利子。即此芭蕉本无有我。亦无有情。无生者。无命者。无养育。无数取。无意生。无摩纳婆。无作者。无受者。以芭蕉性即行自性。菩萨摩诃萨。于如是法善巧知之。是则名为蕴法善巧。又舍利子。我说此识喻如幻事。何以故。舍利子。即此幻事本无有我。亦无有情。无生者。无命者。无养育。无数取。无意生。无摩纳婆。无作者。无受者。以幻事性即识自性。菩萨摩诃萨。于如是法善巧知之。是则名为蕴法善巧。舍利子。所言蕴者说名世间。世间之法即败坏相。是故当知诸世间性即蕴自性。舍利子。何等名为世间性耶。谓无常性苦性无我性。如是等性名为蕴性。如是蕴性即世间性。菩萨摩诃萨。若于是中善巧知者。是则名为蕴法善巧。舍利子。若有菩萨摩诃萨。为欲修行般若波罗蜜多故。精勤修习蕴法善巧

复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多故。而能通达界法善巧。舍利子。界法善巧者。所谓法界即为地界。何以故。以彼法界非坚鞕相故。又法界者即为水界。何以故。以彼法界非湿润相故。又法界者即为火界。何以故。以彼法界非成熟相故。又法界者即为风界。何以故。以彼法界非摇动相故。舍利子。菩萨摩诃萨。若于是中如实了知。是则名为界法善巧。又舍利子。言法界者即眼识界。何以故。以彼法界非照明相故。又法界者即耳识界。何以故。以彼法界非闻声相故。又法界者即鼻识界。何以故。以彼法界非嗅香相故。又法界者即舌识界。何以故。以彼法界非尝味相故。又法界者即身识界。何以故。以彼法界非觉触相故。又法界者即意识界。何以故。以彼法界非分别相故。舍利子。菩萨摩诃萨。若于是中如实了知。是则名为界法善巧又舍利子。如是我界与法界平等。有情界与法界平等。欲界色界及无色界与法界平等。生死界涅槃界与法界平等。如是乃至虚空界法界。及一切法界皆悉平等。舍利子。以何义故而得平等。谓由空平等故。一切法平等。无变异平等故。一切法平等。又舍利子。若有宣说有为界证入无为界证入。如是则有无量无边。若诸菩萨摩诃萨。作是简择证入法界。是则名为界法善巧。舍利子。如是菩萨摩诃萨。为欲修行般若波罗蜜多故。应勤修习界法善巧

复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多故。而能通达处法善巧。舍利子。处法善巧者。眼为是空无我我所。菩萨摩诃萨。如实了知如是眼性。乃至意为是空无我我所。菩萨摩诃萨。如实了知如是意性。菩萨摩诃萨。虽于诸处不积集不善。而积集于善。然于善不善中。不起二相。如是了知是名菩萨摩诃萨处法善巧。又舍利子。云何菩萨摩诃萨。于眼处色处。而能通达善巧了知。舍利子。谓于眼色观见离欲。然于离欲而不作证。如是了知。是名菩萨处法善巧。如是耳声鼻香舌味身触意法。即此意法观见离欲。然于离欲而不作证。如是了知。是名菩萨处法善巧。又舍利子。诸佛如来说微妙法。或说圣处或非圣处。言圣处者堪受道法。非圣处者远离道法。菩萨摩诃萨安住于道。于离道住诸众生所。获得大悲不舍道处。若有菩萨。如是了知善通达者。是名菩萨摩诃萨处法善巧。舍利子。诸菩萨摩诃萨。为欲修行般若波罗蜜多故。应勤修学处法善巧

复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多故。而能通达谛法善巧。舍利子。当知菩萨摩诃萨。有四种行入谛善巧。何等为四。所谓苦智集智灭智道智。舍利子。云何名为苦智乃至道智。谓于诸蕴本无生智。如是之智名为苦智。于诸染爱永断灭智。如是之智名为集智。谓于一切无生无坏。如是之智名为灭智。于一切时诸所缘法无有损益。如是之智名为道智。舍利子。若菩萨摩诃萨。于是四谛。以如是等智慧了知。虽复明达而不作证。何以故。为欲成熟诸众生故。如是具足名谛善巧。又舍利子。菩萨摩诃萨。谛善巧者。复有三种。何等为三。一者世俗谛。二者胜义谛。三者相谛。舍利子。世俗谛者。当知乃至世间所有语言文字音声假说。如是等相名世俗谛。胜义谛者。所谓若于是处尚非心行。况复文字而能陈说。如是等法名胜义谛。相谛者所谓诸相即是一相。如是一相即是无相。如是说者名为相谛。舍利子。菩萨摩诃萨。于世俗谛为众生故说无厌倦。胜义谛者。于中作证而无退堕。于彼相谛深达本性了知无相。舍利子。是名菩萨摩诃萨为欲修行般若波罗蜜多故。精勤修学谛法善巧

复次舍利子。菩萨摩诃萨。精勤修学谛善巧者。如实当知。复有一谛无有第二。何等一谛。所谓灭谛。舍利子。诸佛如来于此一谛。明了通达无有增益。既通达已。为处增益诸含生等。宣说如是一谛之法。令彼修学悟无增益故。舍利子。若有菩萨作如是知。是名菩萨摩诃萨谛法善巧

复次舍利子。菩萨摩诃萨。复应修学谛法善巧。舍利子。谛善巧者。谓善通达诸圣谛故。何等名为通达圣谛。舍利子。苦圣谛者谓五受蕴其性实苦是名苦谛。菩萨摩诃萨。于是谛中通达五蕴皆为苦相。夫苦相者即为空相。如是则名为苦圣谛。舍利子。集圣谛者五受蕴因。随眠爱见是名集谛。菩萨摩诃萨于此因法。若爱若见无有增益。无取无迷明了通达。如是则名为集圣谛。舍利子。灭圣谛者。若五受蕴究竟灭尽是名灭谛。菩萨摩诃萨。观是谛法。不失前际。不往后际。不住现在。明了通达。如是则名为灭圣谛。舍利子。道圣谛者。若依彼道。证得苦智集智灭智。无第二智是名道谛。菩萨摩诃萨。于如是谛明了通达。无有分别。是则名为趣苦灭行圣谛。是故舍利子。菩萨摩诃萨。若于此谛以智观察。亦令众生观察解了。是名菩萨摩诃萨谛法善巧

复次舍利子。菩萨摩诃萨。于是谛法。又应观知如是四谛。云何苦谛。于诸一切能受所受皆是苦谛。于如是中善当简择。即此智性善简择觉明了通达。是名菩萨苦圣谛。云何集谛。若从是因诸蕴集起皆是集谛。于如此因如实了知。是名菩萨苦集圣谛。云何灭谛。诸受永息无所觉受。是名灭谛。虽观受灭而不作证如是通达。是名菩萨苦灭圣谛。云何道谛。若善修习离受圣道。是名道谛。譬如船筏不求于受亦不求道。是名菩萨趣苦灭行圣谛。如是舍利子。若有菩萨摩诃萨。如是现观依寂静定发四种见。而此四见非毕竟净。若能通达如此法者。是名菩萨摩诃萨谛法善巧

复次舍利子。菩萨摩诃萨。于是谛法善巧通达。若证于灭则苦不生。观无生智是名苦智。舍利子。有为生缘观察此有非有非无。如是之智名为集智。舍利子。一切生者即是无生。了知此故都无所灭。此无灭智名尽灭智。舍利子。若如是道无所称量。无所追寻。无所观察。名广大智。如是之智名为道智。舍利子。菩萨摩诃萨。于此谛法善能建立。而于谛智无所住着。是名菩萨摩诃萨谛法善巧。舍利子。菩萨摩诃萨。为欲修行般若波罗蜜多故。精勤修是谛法善巧

复次舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多故。获无碍解善巧。舍利子。菩萨摩诃萨。以具修学般若波罗蜜多故。具足四种无障碍解。何等为四。所谓义无碍解。法无碍解。词无碍解。辩无碍解。舍利子。何等名为义无碍解。舍利子。诸菩萨依般若波罗蜜多故。获是义无碍解。谓一切法胜义处智。观是智者即义无碍解。如是诸觉智。因智。缘智。和合智。遍随行智。广大缘生智。法性无杂智。如来随入智。安住实际智。于空法中随觉观智。于无相法如所观智。于无愿法起愿行智。于无加行起加行智。于一理趣观入证智。于无有情观入证智。于无我法观入证智。于无命者一向入智。于无数取观胜义智。于过去世观无碍智。于未来世观无边智。于现在世观一切处智。于诸蕴法观如幻化智。于诸界法观等毒蛇智。于诸处中观如空烬智。于诸内法观寂静智。于诸外法观无所行智。于诸境界观无所有智。于诸念住观安住智。于彼诸趣观随行智。于诸缘起观现见智。于诸谛法观通达智。于一切苦观无生智。于一切集观无加行智。于一切灭观离相智。于一切道观拔济智。于诸法中观句分析智。于诸根法观证入智。于诸力法观无屈伏智。于奢摩他观所依处智。于毗钵舍那观明照智。于诸幻事观虚集智。于诸阳焰观迷乱智。于所梦事观虚见智。于彼传响观缘合智。于彼光影观无动智。于差别相观一相智。于诸系缚观离缚智。于诸相续观无相续智。于声闻智观随声入智。于独觉智观广大缘生入一境智。于佛大乘观知一切善根资粮能积集智。舍利子。诸如是等一切观智。是名菩萨摩诃萨义无碍解。复次舍利子。菩萨摩诃萨。复有义无碍解。所谓依趣之义。以诸法性之所依趣。何以故。以一切法遍皆是空。空性义者说名为义。以一切法遍皆无相。无相义者说名为义。以一切法遍皆无愿。无愿义者说名为义。以一切法遍皆远离。远离义者说名为义。以一切法遍无有情无命者无数取无数取义。说名为义。菩萨摩诃萨。若能随入如是相义。是则名为义无碍解。舍利子。若有菩萨摩诃萨。说是义者。当知是为说无住法说无尽法。即说一切之所显说。即说一切智者诸无碍解所简择义。当知是人即为诸佛世尊印可随喜。当知此智是为真慧。是为实慧。是为无异慧。是为诸处简择无碍之慧。舍利子。菩萨摩诃萨如是了知。是则名为义无碍解

复次舍利子。云何菩萨摩诃萨法无碍解。舍利子。菩萨摩诃萨。修行般若波罗蜜多故。获是法无碍解者。谓诸法中随证入智。何等名为随证入智。舍利子。谓诸法中有所证入。何等诸法。谓善不善。有罪无罪。有漏无漏。世间出世间。有为无为。染污清净。若有随顺生死及以涅槃。于如是等一切法中。随能证入。法性平等菩提平等。如是智性是则名为法无碍解

复次舍利子。法无碍解者。菩萨摩诃萨。以如是解心智。证入如是贪行。如是入证假立贪行。或复证入方便贪行。或复证入坚固贪行。或复证入微薄贪行。或复证入非处贪行。或复证入营求贪行。或复证入宿世贪行。或复证入无边异相贪行。或复证入现在众缘贪行。又舍利子。菩萨摩诃萨。了诸有情如是贪相。所谓或有众生内贪非外贪。或有众生外贪非内贪。或有众生内外俱贪。又舍利子。或有众生色贪非声贪。或有众生声贪非色贪。或有众生色声俱贪。复次或有众生色贪非香贪。或有众生香贪非色贪。或有众生色香俱贪。复次或有众生色贪非味贪。或有众生味贪非色贪。或有众生色味俱贪。复次或有众生色贪非触贪。或有众生触贪非色贪。或有众生色触俱贪。又舍利子。或有众生声贪非香贪。或有众生香贪非声贪。或有众生声香俱贪。复次或有众生声贪非味贪。或有众生味贪非声贪。或有众生声味俱贪。复次或有众生声贪非触贪。或有众生触贪非声贪。或有众生声触俱贪。又舍利子。或有众生香贪非味贪。或有众生味贪非香贪。或有众生香味俱贪。复次或有众生香贪非触贪。或有众生触贪非香贪。或有众生香触俱贪。又舍利子。或有众生味贪非触贪。或有众生触贪非味贪。或有众生味触俱贪。又舍利子。或有众生色声贪非香贪。或有众生香贪非色声贪。或有众生色声香俱贪。复次或有众生色声贪非味贪。或有众生味贪非色声贪。或有众生色声味俱贪。复次或有众生色声贪非触贪。或有众生触贪非色声贪。或有众生色声触俱贪。又舍利子。或有众生声香贪非味贪。或有众生味贪非声香贪。或有众生声香味俱贪。复次或有众生声香贪非触贪。或有众生触贪非声香贪。或有众生声香触俱贪。又舍利子。或有众生香味贪非触贪。或有众生触贪非香味贪。或有众生香味触俱贪。又舍利子。或有众生色声香贪非味贪。或有众生味贪非色声香贪。或有众生色声香味俱贪。复次或有众生色声香贪非触贪。或有众生触贪非色声香贪。或有众生色声香触俱贪。又舍利子。或有众生声香味贪非触贪。或有众生触贪非声香味贪。或有众生声香味触俱贪。又舍利子。或有众生色声香味贪非触贪。或有众生触贪非色声香味贪。或有众生色声香味触俱贪。舍利子。如是等无量众生。具各起是无量贪相。入于贪行。由菩萨摩诃萨证入是门故。入诸众生二万一千贪行门。二万一千嗔行门。二万一千痴行门。二万一千等分行门。舍利子。若菩萨摩诃萨。证入如是八万四千烦恼行门者。当知如是菩萨摩诃萨。具足成就心广大智。及随行说智。不增不减说智。不过时说智。根器有差别智。立言不虚说智。舍利子。菩萨摩诃萨。具足如是诸胜智故。是名菩萨摩诃萨法无碍解

复次舍利子。云何菩萨摩诃萨词无碍解。舍利子。菩萨摩诃萨。修行般若波罗蜜多故。具足如是词无碍解。所谓于诸言词证入之智。获是智已。而能了知诸天言词。诸龙言词。药叉言词。健达缚言词。阿素洛言词。揭路荼言词。紧奈洛言词。牟呼洛伽言词。人言词。非人言词。乃至五道众生一切含识。所有言词音声筹议。菩萨悉能以智证入。又能以是言音。为彼众生宣说正法。舍利子。是则名为菩萨摩诃萨词无碍解。又舍利子。复有词无碍解。谓诸菩萨善能了知如是言词。唯应显了如是之法如是言词。唯应随辩如是之法。如是言词。应以是字隐藏是法。菩萨摩诃萨。又以是解。当应了知是一名言。是二名言。是多名言。又能了知是女名言。是男名言。是非男非女名言。又能了知是略名言。是广名言。是好名言。是恶名言。又能了知过去名言。未来名言。现在名言。又能了知如是等相。一字增益。如是等相多字增益。若诸菩萨能善了知。是则名为词无碍解。又舍利子。复有词无碍解者。菩萨摩诃萨所发言词。无量功德所共集成。何等是耶。舍利子。诸菩萨等所发言词无有微弱。即此言词善巧施设。无有繁重无有急速。词极明了文义圆备。顺悦大众。种种美妙显示深奥。世俗胜义之所庄严。自心智见通达无碍。诸佛印可悦豫众生。舍利子。如是具足是名菩萨摩诃萨词无碍解

复次舍利子。云何菩萨摩诃萨辩无碍解。舍利子。菩萨辩者。所谓菩萨摩诃萨。修行般若波罗蜜多故。获是言词无碍辩。无滞记别辩。宣畅无断辩。速辩迅辩。捷疾辩。不可动辩。不讷钝辩。随问对辩。无退怯辩。不相违辩。无诤论辩。可乐法辩。住忍力辩。妙甚深辩。种种差别辩。种种微妙辩。世俗胜义辩。建立一切布施持戒怀忍正勤静虑般罗若辩。建立一切念住正断神足根力觉支道分奢摩他毗钵舍那辩。建立一切静虑解脱三摩地三摩钵底谛广大智辩。一切圣人所乘辩。一切众生心行辩。无謇吃言辩。无梗涩言辩。无轻掉言辩。无粗犷言辩。爱润音言辩。清净言辩。横逸言辩。无著言辩。教诏言辩。三摩呬多言辩。妙相应言辩。无关钥言辩。美妙音言辩。柔滑音言辩。无致讥诃言辩。众圣所赞言辩。舍利子。菩萨摩诃萨。以如是等所有言辩。遍告无边诸佛刹土。所发言音。超过一切梵音言词。如是言音明了清净。为诸如来之所印可。是诸菩萨。具足才辩。以是言音。愍诸有情及数取者。广为宣说微妙正法。能令是等出离生死正尽众苦。舍利子。是名菩萨摩诃萨辩无碍解。舍利子。如是名为无碍解善巧。由此无碍解善巧故。菩萨摩诃萨。修行般若波罗蜜多。精勤修习无碍解善巧

大宝积经卷第五十一大宝积经卷第五十二

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十八般若波罗蜜多品第十一之三

复次舍利子。云何菩萨摩诃萨依趣善巧。舍利子。菩萨摩诃萨。修行般若波罗蜜多故。于四依趣善能具足。何等为四。所谓依趣于义。不依趣文。依趣于智。不依趣识。依趣于了义经。不依趣不了义经。依趣于法。不依趣数取趣者。舍利子。云何名为依趣于义不依趣文。复以何等为文为义。舍利子。所言文者。谓诸世间诸法作用传习文词。所言义者。谓所通达出世间法。所言文者。宣示可乐布施调顺寂静言词。所言义者。谓所布施调顺寂静。决定了知无朽坏智。所言文者。诃毁生死分别言词。所言义者。生死不染彻见法性。所言文者。称扬赞叹涅槃功德。所言义者。谓诸法性涅槃无分别性。所言文者。随顺诸乘建立言说。所言义者。一理趣法善通达智。所言文者宣说舍离诸所有法。所言义者。谓是三轮究竟清净。所言文者。宣说律仪身语意业受持学处杜多功德。所言义者。身语意业皆不可得。不由加行尸罗清净。所言文者。宣说忍受嗔恚裁忿憍慢傲逸。能行是忍名善丈夫。所言义者。谓善证得无生法忍。所言文者。演诸善根发起精进。所言义者。无取无舍无住精进。所言文者。宣说静虑解脱等持等至。所言义者。灭尽定智。所言文者。一切闻持诸慧根本。所言义者。不可说义。所言文者。谓能开示三十七觉分圣道正法。所言义者。证得菩提分法正行之果。所言文者。谓能开示苦集道谛。所言义者。于灭作证。所言文者。开示无明为初乃至老死。所言义者。谓无明灭故。乃至老死亦灭。所言文者。宣说止观资粮正法。所言义者。明解脱智。所言文者。宣说贪嗔及痴等分行法。所言义者。谓无分别心解脱智。所言文者。开示一切障碍之法。所言义者。谓无障碍解脱之智。所言文者。开示三宝称赞功德。所言义者。离欲法性无为无著功德正行。所言文者。宣说菩萨从初发心乃至道场修学功德发起正行。所言义者。谓刹那心相应。证觉一切智智。舍利子。举要言之。如来所演八万四千法藏声教。皆名为文。诸离一切言音文字。理不可说是名为义。舍利子是名菩萨摩诃萨。修行般若波罗蜜多故。依趣于义不依趣文。复次舍利子。云何菩萨摩诃萨。依趣于智不依趣识。舍利子。菩萨摩诃萨。依般若波罗蜜多故。善巧了知诸有言教数取趣义。是名为识此不应依。诸有言教如法性义。即是于智此应依趣。又舍利子。是菩萨摩诃萨。由二法善巧。便能修行般若波罗蜜多。何等为二。谓识及智。舍利子。何等为识。何等为智。舍利子。所言识者。谓四识住。何等为四。一者色趣识所依止。二者受趣识所依止。三者想趣识所依止。四者行趣识所依止。如是识住。是名为识不应依趣。所言智者。于五取蕴。识不安住。诸蕴遍智。是名为智此应依趣。所言识者。谓能了知地界水界火界风界。如是了知则名为识不应依趣。若有说言四种识住识不安住。此则名为识之法性。若于法性不杂乱智。是名为智则可依趣。又复识者。所谓了别眼所识色。耳所识声。鼻所识香。舌所识味。身所识触。意所识法。如是了别是名为识。所言智者。若于内处心虑寂静。若于外处寻伺不行。依趣于智。不于一法而生分别。如是等相名之为智。又复识者。从所缘境而生于识。从诸作意而生于识。从遍分别而生于识。如是等相名之为识。所言智者。无取无执无缘无了别无所分别是名为智。又复识者。于诸一切有为行法。识所依趣是名为识。所言智者于无为法无识能行此无为智是名为智。又复识者。有生有灭有住之识。故名为识不应依趣。无生无灭亦无所住。是名为智此应依趣。舍利子。是名菩萨摩诃萨。修行般若波罗蜜多故。依趣于智不依趣识

复次舍利子。云何名为菩萨摩诃萨。不依趣不了义经。依趣了义经。舍利子。诸菩萨等善能通达。即如先说所有广文。是则名为不了义经。如是广文不应依趣。即如先说所有广义。是则名为了义经际。如是广义则可依趣。又舍利子。何等经中以为了义。何等经中名不了义。舍利子。菩萨摩诃萨。依般若波罗蜜多故。善能分别。若诸经中宣说于道。如是言教名不了义。若诸经中宣说于果。如是言教名为了义。若诸经中说世俗谛名不了义。说胜义谛名为了义。若诸经中宣说作业烦恼惑染。名不了义。若有宣说烦恼业尽。是名了义。若诸经中宣说诃责染污之法。名不了义。若有宣说修治清净。如是法者是名了义。若诸经中有所宣说厌背生死欣乐涅槃。名不了义。若有宣说生死涅槃二无差别。是名了义。若诸经中宣说种种文句差别。名不了义。若说甚深难见难觉。是名了义。若诸经中文句广博能令众生心意踊跃。名不了义。若有宣说文句及心皆同灰烬。是名了义。若诸经中宣说有我有情命者养者数取趣者意生摩纳婆作者受者。又说立有种种受蕴无有主宰。如是言教名不了义不应依趣。若诸经中说空无相无愿无生无起。亦无出现无有我无有情无命者无养者无数取趣者及三解脱门。如斯言教是名了义。则可依趣。舍利子。是名菩萨摩诃萨。修行般若波罗蜜多故。依趣了义不趣不了之义

复次舍利子。云何名为菩萨摩诃萨。依趣于法不依趣数取者。舍利子。菩萨摩诃萨。依般若波罗蜜多故。于诸经教善能分别诸有宣说。不了义经。即为补特伽罗义。如是言教不应依趣。诸有了义即如性法义。如是言教此应依趣。又舍利子。复以何等名为依法。云何名为数取趣者。舍利子。若有依止数取之见诸所缘法。如是之相名数取者。此数取见所缘法住性之法性。如是相者是名为法。言数取者。所谓凡夫数取。善凡夫数取。随信行数取。随法行数取。第八数取。预流数取。一来数取。不还数取。阿罗汉数取。独觉数取。菩萨数取。舍利子。复有一数取者出现于世。利益安乐无量众生。悲愍世间。为诸天人义利安乐。如是数取。所谓如来应正等觉。舍利子。如是一切数取名言。如来依世俗谛为众生说。若有众生。于此言教起于执着。如是等类不应依趣。何以故。如来欲令于彼正依趣故。佛薄伽梵说如是法。汝等依趣诸法实性。无宜依趣彼数取者。舍利子。何等是为诸法实性。舍利子。所谓无有变异。无有增益。无作无不作。不住无根本。如是之相是名法性。又复于一切处通照平等。诸平等中善住平等。不平等中善住平等。于诸平等不平等中妙善平等。如是等相是名法性。又法性者无有分别。无有所缘。于一切法。证得决定究竟体相。如是名为诸法实性。舍利子。若有依趣法性之者。则诸法性无不依趣。菩萨摩诃萨。由证入如是门故。于一切法依趣一切法性故。舍利子。如是名为菩萨摩诃萨四种依趣。若有菩萨摩诃萨。于此法中能通达者。是则说名依趣善巧。舍利子。如是名为依趣善巧。菩萨摩诃萨。为欲修行般若波罗蜜多故。精勤修习依趣善巧

复次舍利子。云何名为菩萨摩诃萨资粮善巧。舍利子。当知菩萨摩诃萨。修行般若波罗蜜多故。善能通达二种。资粮何者是耶。谓福及智。舍利子。云何名为福德资粮。所谓布施体性福所作事。尸罗体性福所作事。诸修体性福所作事。及大慈定大悲方便。菩萨摩诃萨住福所作诸事业故。于诸善根。若自若他励志奉修。悉能兴起三世积集所有诸恶悉皆发露。又于一切众生所有功德。一切学无学所有功德。一切独觉所有功德。一切菩萨从初发心广修诸行。得不退转系属一生。如是等无量无边菩萨摩诃萨所有功德。菩萨普皆心生随喜。又于去来现在一切诸佛薄伽梵所。一切善根菩萨亦皆心生随喜。舍利子。是菩萨摩诃萨。又复善能随喜俱生福所作事。复能劝请一切诸佛转妙法轮。及诸贤圣令演胜法劝请俱生福所作事。复能以诸善根回向菩提。回向俱生福所作事。是菩萨摩诃萨。见有未发大菩提心诸菩萨等。方便教令发菩提心。若有已发菩提心者。说法示导教令成熟。诸贫穷者摄以财物。若疾病者施以医药。殷勤瞻视恭敬承事。于暴恶者心生忍受。所犯戒品无有覆藏。发露诸过善能除罪。已般涅槃诸佛世尊。于一切时常修供养。于邬波柁耶。及阿遮利耶。敬如大师。于正法所发勤精进追寻请问。于说法师敬爱尊奉犹如事佛。有说法会。虽去已远多百踰缮那。要往其所听闻正法无有厌足。或有众生来请疑滞以无染心宣说净法。于父母所承修供养知恩了恩无有变悔。积集一切诸清净福。修行建立情无厌倦。以诸律捡。防护于身身无诡诈。防护于语发言和雅。防护于心心无谄诳。欲摄梵福故。为诸如来营构制多令丈夫相具圆满故。积集无遮大祠法会。为随显相令圆满故。积集种种善根资粮。为庄严身故。舍离憍慢。为庄严语故。远诸语过。为庄严心故。远离一切憎嫉觉慧。为大庄严佛刹土故。化现神通转变自在。为欲庄严诸法相故。无上妙智善胜清净。为欲庄严大法众故。远离一切离间粗恶破坏语言。为不取着一切法故。离妄分别。令说法者无忧戚故。欢喜授与善哉言词。令说法者无唐捐故。远离诸盖恭敬听法。为欲庄严菩提树故。奉施诸佛清静园林。为欲庄严佛道场故。备修善根无有退转。为欲净除生死法故。不染一切诸业烦恼。为欲获得珍宝手故。修行布施一切珍宝。为欲获得无尽之财及无尽藏故。所爱重物先用行施。为欲令诸众生暂见便起清净信故。舒颜先问远诸嚬蹙为欲获得平掌相故。于诸众生起平等照。为放无边诸光网故。于不学识诸众生所。情不轻蔑。又无舍置。为令受生得清净故。常存积集清净戒福。为令胎藏得清净故。于诸毁犯善能清净。为欲生于天人中故。修治清净十善业道。远离无知往还进止故。于诸教诫无妄分别。为得法财富逸自在故。于深奥法性无藏吝。为诸世间所瞻仰故。修治清净增上欲解。为得广大法胜解故。于微少行而不修证。为欲摄取一切福故。心恒思惟一切智者。为七圣财得圆满故。于佛正法信为前导。为欲摄受诸净法故。于己身命曾无顾录。为诸世间所委任故。于先所许必令果遂。为令一切诸佛妙法得圆满故。圆满修习一切佛法。舍利子。若菩萨摩诃萨。具足成就如是相者。是名菩萨摩诃萨福德资粮善巧

复次舍利子。云何菩萨摩诃萨智德资粮善巧。舍利子。是菩萨摩诃萨。修行般若波罗蜜多时。由住如是如是因缘法故。摄取于智。是故名曰智德资粮。舍利子。如是摄智。以何等法为因为缘。舍利子。当知菩萨摩诃萨。欲无厌倦精进寻求智随行性亲近善友。趣诸佛智不趣声闻及独觉智。于彼善友情无憍慢。恭敬爱重如爱大师。而是菩萨知彼善友具诸欲解无有少分顺智言说而不咨受彼善友者。又知菩萨是法器已。即为宣说中无暂断。是诸菩萨。闻说如是正法资粮相应之行。精进寻思方便修习。舍利子。诸如是相此则名为智德资粮相应正行

复次舍利子。云何名为菩萨摩诃萨正法资粮相应正行。舍利子。正法资粮者。所谓菩萨摩诃萨具修正行故。嗜欲饕餮善能节俭。事绪缘务善能减约。言说谈话善能远离。于诸音声善能弃舍。初夜后夜无有睡眠。精勤修习相应正行。是菩萨摩诃萨。称量理义郑重寻思故。心无浊秽制伏诸盖故。于所毁犯善知出离无有谄诈现除悔故。无所追求坚修正行故。随顺正法。趣向正法俯临正法于法勇猛常如救彼头衣炽然故。勤求妙智无暂休息不处愚暗故。无有慢缓不弃善扼故。远离愦闹常乐独处故。宴默思惟圣种知足故。不舍杜多所有功德爱乐法乐故。常乐寻求出世间法不思宝玩随顺世间文章咒术故。成就正念无忘失故。备甚深义善随行故。具足妙慧道随顺故。坚固勇猛防卫外缘故。内怀羞耻惭愧庄严故。随行佛趣离非智故。舍愚痴膜慧眼清净善觉悟故。觉慧宽广于如是觉无狭劣故。妙觉明显证现智故。舍利子。是菩萨摩诃萨。所有功德不随于他。于自功德无增上慢。于他功德不嫉不毁。善修行业不轻业报。由如是故。具足成满业清净智。舍利子。如是等相具足圆满。是名菩萨摩诃萨智德资粮善巧之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能具足四种施法。便得成就智德资粮。何等为四。一者菩萨摩诃萨若见书写如是经典给施叶纸笔墨众事。二者菩萨摩诃萨请说法者演深妙义。三者菩萨摩诃萨以诸利养恭敬名闻赞颂称扬奉说法者。四者菩萨摩诃萨于说法师摄受正法无有谄曲赞悦彼意应施是言善哉善哉。舍利子。若有菩萨摩诃萨。行是四种清净布施。当知善能积集智德资粮善巧

复次舍利子。菩萨摩诃萨。复有四种积集无尽智德资粮。何等为四。一者菩萨摩诃萨巧能守护说法者身。二者巧能守护所有众善。三者巧能守护其所止处。四者巧能守护彼说法者所有徒众。舍利子是为菩萨摩诃萨四种积集智德资粮

复次舍利子。菩萨摩诃萨。复有四种任持智德资粮善巧。何等为四。所谓菩萨摩诃萨于说法者以法任持。以智任持以财任持。以菩提功德而用任持。舍利子。是为菩萨摩诃萨四种任持智德资粮

复次舍利子。菩萨摩诃萨。复有五种胜力能为智德资粮善巧。何等为五。所谓菩萨摩诃萨具足信力为欲成就信解心故。具足进力求善知识成多闻故。具足念力令菩提心无忘失故。具足定力审谛观察平等觉故。具足慧力由久修习多闻力故。舍利子。是名菩萨摩诃萨五力智德资粮善巧之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓具四种清净尸罗。能善积集智德资粮。何等为四。所谓菩萨摩诃萨乐法尸罗。求法尸罗。观法尸罗。回向菩提尸罗。舍利子。菩萨摩诃萨。若具如是四种清净尸罗。能善积集智德资粮善巧之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能具足四种忍法。能为智德资粮善巧。何等为四。一者菩萨摩诃萨勤求法时。善能忍受一切粗恶非法言说。二者菩萨摩诃萨勤求法时。善能堪忍一切风日寒热饥渴。三者菩萨摩诃萨勤求法时。于阿遮利耶邬波陀耶二胜师所。随有训诲顶戴领受。四者菩萨摩诃萨勤求法时。善能信解于空无相无愿之法。舍利子。如是四种含受忍法能为智德资粮之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能具足四种精进。能为智德资粮善巧何等为四。所谓菩萨摩诃萨。坚固精进听闻。正法。坚固精进任持正法。坚固精进演说正法。坚固精进修行正行。舍利子。如是四种坚固精进。能为智德资粮之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能具足四种静虑。于法修习。能为智德资粮善巧。何等为四。一者菩萨常乐行远离法。二者乐独专一守静山林。三者常乐寻求神通静虑。四者常勤修行广大佛智。舍利子。如是四种正法静虑。能为智德资粮之行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能具足四种正法智慧光明。能为智德资粮善巧。何等为四。所谓菩萨摩诃萨。修行如是智慧光明。不住于断。不说于常。不违缘起。信解无我。舍利子。如是四种诸慧光明。能为智德资粮正行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能成就四种正法无上方便。能为智德资粮善巧。何等为四。所谓菩萨摩诃萨。修行般若波罗蜜多故。随顺世间。随顺经典。随顺妙法。随顺净智。舍利子。如是四种正法方便。能为智德资粮正行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓能进趣四种法道。能为智德资粮善巧。何等为四。所谓菩萨摩诃萨。以依般若波罗蜜多故。具足修行到彼岸道。七觉分道。八圣支道。趣向一切智者智道。舍利子。如是四种正法之道。能为智德资粮正行

复次舍利子。菩萨摩诃萨。复有智德资粮善巧。谓具四种无厌足法。则能善集智德资粮。何等为四。所谓菩萨摩诃萨以修行般若波罗蜜多故。奉持正法无量听闻无有厌足。为众说法无有厌足。观察理义无有厌足。智慧方便无有厌足。舍利子。如是四种无厌足法能集智德资粮正行

复次舍利子。菩萨摩诃萨如是智德资粮善巧。随遍入于一切行处。何以故。舍利子。当知布施由智资粮而成就故。如是持戒忍辱精进静虑正慧亦是智德资粮成就。乃至慈悲喜舍一切善法亦因智德资粮成就。何以故。舍利子。菩萨摩诃萨所有发起坚固正行。皆依正智。彼一切行智为前导。由是菩萨具大智故。为诸无智之所归趣。一切恶魔不得其便。诸佛如来所共加护。将得趣入一切智智。舍利子。是为菩萨智德资粮善巧之行。若诸菩萨摩诃萨。成就如是福智二种资粮善巧。当知修行般若波罗蜜多故。获是资粮善巧之力

复次舍利子。云何菩萨摩诃萨念住善巧。舍利子。所谓菩萨摩诃萨修行般若波罗蜜多故。具足修习四种念住。则能成就方便善巧。舍利子。何等为四。一者于身随身观察修习念住。二者于受随受观察修习念住。三者于心随心观察修习念住。四者于法随法观察修习念住。舍利子。菩萨摩诃萨修行般若波罗蜜多故。云何于身随身观察修习念住。舍利子。菩萨于身住随身念。观察是身前际过咎。是菩萨摩诃萨作是思惟。如是身者。颠倒业起因缘所生。本无主宰。无所摄受。如彼卉木丛林诸药草等。从因缘生。本无主宰。无所摄受。此身又如馆舍所起。皆由草木墙堑众缘所共合成。此身亦尔。但为蕴界处等之所摄持。而其本性空无有我无有我所。无常无恒无有坚住。非不变法。我今不应于是身分妄有所计。是故我今当以如是不坚之身用贸坚身。何等身者名为坚实。谓如来身是坚实身。我观是身极为虚伪。要当成办如来之身。何以故。如来身者即是法身。金刚之身。不可坏身。坚固之身。超于三界最胜之身。又作是念。我此身者无量过咎之所杂染。我当求证离诸过染如来之身。舍利子。是菩萨摩诃萨以诸觉慧简择力故。观察是身四大种摄。为诸随眠所依窟宅。是故我今当以此身为诸众生驱役给使。何以故。譬如世间外四大种。所谓地界水火风界。以种种门无量差别众具资财。饶益养育一切众生。我今亦尔用此四大所合成身。以种种门无量差别境界资财。当为众生之所受用。舍利子。是菩萨摩诃萨。由依般若波罗蜜多观察是身。有如是等大义用故。虽观此身体性是苦。而不厌患如是苦身。虽观是身究竟尽性。而不厌患流转受生。虽观是身其性无我。而无厌倦成熟众生。虽观是身我寂灭性。而不堕彼永舍寂灭。虽观身空无相远离。而不堕于远离边际。舍利子。是菩萨摩诃萨。于此身法住随身观。观察是身无实无坚。又于内身住随身观随内而行。于诸烦恼无复容受。又于外身住随身观随外而行。于诸烦恼不与共住。舍利子。是菩萨摩诃萨成就如是身念住已。其身清净无有染污。具足一切清净身业。得清净相庄严之身。既具如是庄严身故。为诸天人之所归仰。舍利子。是名菩萨摩诃萨修行般若波罗蜜多故。于此身法随身观察修习念住

复次舍利子。菩萨摩诃萨修行般若波罗蜜多时。云何于受随受观察修习念住。舍利子。菩萨摩诃萨作是思惟。诸所有受一切皆苦。我于今者具觉慧力。于如是受当善决择。以智决择。以慧决择。方便决择。是菩萨摩诃萨。既具如是胜决择力。虽受于乐当乐触时。即于一切善道众生。起大慈心。不为贪欲随眠所恼。虽受于苦当苦触时。即于一切恶道众生。起大悲心。不为嗔恚随眠所恼虽复受诸不苦不乐。当触受时。不为无明随眠所恼。舍利子。是菩萨摩诃萨由依般若波罗蜜多。具足如是观解力故。随受而行修习念住所受诸受。若苦若乐不苦不乐。善能观察诸受出离。又能令彼一切众生证受遍智寂灭之法。又作是念。此诸众生具烦恼故。无有智慧。不能了知诸受出离。何以故。若受乐时便生贪爱。若受苦时便生嗔恚。若受不苦不乐便起愚痴。而况我辈。诸菩萨等随智慧行。一切所受诸过失法。皆已息灭。岂当于受更起烦恼。我于今者应具发起方便善巧及与大悲。摄诸众生。令于诸受皆得息灭。舍利子。如是菩萨何因缘故。说于诸受而能不随。舍利子。谓于诸受智慧简择。能引于乐不引于苦。舍利子。复以何等智慧简择。谓是菩萨观察此中。无能受者。若我。若有情。若命者。若数取等。于是观察竟无能受。唯有受者。有何等受。所谓执受。摄受。取受。有得受。颠倒受。分别受。见随眠受。眼想所生受。乃至意想所生受。色想所生受。乃至法想所生受。及彼种种眼触所生受。如是广说若内若外。所有诸法乃至诸触缘所生受。若苦若乐不苦不乐。如是等相是名为受

复次舍利子。诸佛如来分别诸受。无量诸门差别之相。舍利子。如来或时说为一受。所谓一心了别诸境。或说二受。谓内及外。或说三受。所谓过去了别。未来了别。现在了别。或说四受。所谓地水火风界别。或说五受。所谓思惟如是五蕴。或说六受。所谓分别如是六处。或说七受。谓七识住。或说八受。所谓八邪方便之相。或说九受。所谓九位众生所居。或说十受。所谓十善业道等。舍利子。如是广说。乃至无量一切诸受。随所缘境。随所作意。限量分齐有尔所受。然诸如来说受无量。何以故。众生无量故。随有众生。各具如是无量诸受。舍利子。如是菩萨摩诃萨。云何于受住随受观。舍利子。谓诸菩萨以清净智。方便善摄一切众生。所有诸受生灭住异。及善了知一切众生。善不善等所有受智。若诸菩萨如是随观。是名于受具足观察。舍利子。如是名为菩萨摩诃萨修行般若波罗蜜多故。于一切受随受观察修习念住

复次舍利子。菩萨摩诃萨修行般若波罗蜜多时。云何于心随心观察修习念住。舍利子。是诸菩萨摩诃萨无有忘念。密护防守离诸散乱。观察于心生灭散坏念念不住。于内于外不住不转。是名菩萨正观于心。舍利子。是菩萨摩诃萨复作是念。我忆最初曾所发心。如是诸心生已即灭。离散变坏。不可了知诣何方所。又我所有无量诸心积集善根生已即灭。离散变坏无有方所。又我所有无量心相回向菩提。而心体相不能自了。云何此心能作是念。我当证觉阿耨多罗三藐三菩提耶。何以故。以此心体不能了心。不能观心。不能通达于自心故。舍利子。是菩萨摩诃萨复作是念。若菩提心由善根心无有失者。则善根心由回向心无有迷失。若回向心由菩提故无有失者。则阿耨多罗三藐三菩提。为无有失。是菩萨摩诃萨作是观已。于无迷失不恐不怖。复作是念此缘起法因果不坏。虽复是心法性。无有自性。无有作用。无有主宰。然此诸法依止因缘而得生起。我当随其所欲积集善根。既积集已修相应行。终不舍离是心法性

复次舍利子。菩萨摩诃萨。云何此中积集之相。舍利子。是诸菩萨摩诃萨作如是观积集之相。是心本性犹如幻化。无有一法而可施者。是心法性而能布施一切众生。回向积集庄严佛土。是则名为善根积集。又舍利子。是心本性如梦所见其相寂静。是心法性而能积集守护尸罗皆为回向神通作用。是则名为善根积集。又舍利子。是心本性犹如阳焰。究竟尽灭。是心法性。而能修习一切可乐忍辱之力。回向积集庄严菩提。是则名为善根积集。又舍利子。心本性者如水中月。究竟远离积集之相。是心法性而能发起一切正勤。回向成熟无量佛法。是则名为善根积集。又舍利子。心本性者不可取得。不可睹见。是心法性而能修习一切静虑解脱三摩地三摩钵底。回向诸佛胜三摩地。是则名为善根积集。又舍利子。观此心性本非色相。无见无对。不可了知。是心法性而能修习一切慧句差别说智。回向圆满诸佛智慧。是则名为善根积集。又舍利子。心无所缘无生无起。是心法性而能建立无量善法摄受色相。如是名为善根积集。又舍利子。心无所因亦无所生。是心法性而能摄受觉分法因。是则名为善根积集。又舍利子。心性远离六种境界。亦不生起。是心法性而能引发菩提境界因所生心。是则名为善根积集。舍利子。如是名为菩萨摩诃萨依般若波罗蜜多故。于一切心随心观察修习念住

复次舍利子。是菩萨摩诃萨。又依般若波罗蜜多故。于一切心住随心观。为求证得胜神通故。系缚其心修学通智。得神通已。但以一心。而能善知一切心相。既了知已。依心自体宣说诸法。舍利子。如是住随心观。菩萨摩诃萨。以大悲力制御其心。成熟众生而无厌倦由是菩萨住随心观故。不为心尽不为心灭安住于心。但为令心远离生死相续结缚。而安住心。又复以诸心念智力。安住诸法无生无起正决定性。而不退堕二乘地中。又以是力持心相续。乃至成满一切佛法。一刹那心相应妙慧。觉悟阿耨多罗三藐三菩提。如是舍利子。是名菩萨摩诃萨依般若波罗蜜多。于一切心随心观察修习念住

复次舍利子。菩萨摩诃萨修行般若波罗蜜多时。云何于法随法观察修习念住。舍利子。是菩萨摩诃萨。以圣慧眼观见诸法。乃至坐于道场。于其中间无有迷失。是菩萨于一切法住随法观。不见少法。远离于空。远离无相。远离无愿。远离无生。远离无起。及以远离无加行者。又重观察不见少法远离缘起。舍利子。是菩萨摩诃萨安住如是随法观故。不观于法及以非法。此中何者以定为法。谓无我义是名法义。无有情义无命者义。无数取趣义。如是等义是名为法。复以何等为非法义所谓我见。有情见。命者见。数取趣见。断见常见。有见无有见。如是等见是名非法。又舍利子。举要而言。一切诸法或名为法。或名非法。何以故。若能了知如是诸法皆空无相及以无愿。即一切法并名为法。若有计着我及我所诸见随眠。即一切法并名非法。舍利子。菩萨摩诃萨。依般若波罗蜜多故。住随法观已。不见一法而非佛法。而非是佛。而非是道而非解脱而非出离者。是菩萨摩诃萨。了知诸法皆出离已。又复获得无障大悲。观诸众生所有烦恼。皆从虚假妄想而生。知诸烦恼体性自离。何以故。是诸烦恼等趣了义。无少烦恼可积可集。如是随觉即是菩提。烦恼之性即菩提性。菩萨如是虽安住念而无所住。非忆非忘。而能了知念所安住。何以故。所安住念即名法界。若住法界即住有情界。若住有情界即住虚空界。由如是故。说此诸法与虚空等。舍利子。如是住随法观。菩萨摩诃萨依趣佛法故。信解诸法即是佛法。虽复发起如是尽智。而于无为尽灭之法能不作证。虽复发起无生之智。愍诸含识而现受生。又不舍离无生实际。舍利子。是菩萨摩诃萨。于诸法中安住念故。遍能摄受二乘诸法。虽于一切假立诸法安住于念。而此正念无散无失。乃至后际于一切法。随法观察修习念住。能以无量言说所说不平等境。平等趣入一切佛法。能令一切众生心喜。能摧一切坚固魔军。因是证得自然大智。舍利子。是名菩萨摩诃萨修行般若波罗蜜多故。于一切法随法观察修习念住。是则名为四种念住善巧之法。如是舍利子。菩萨摩诃萨。欲得修行般若波罗蜜多者。应当修习念住善巧

大宝积经卷第五十二大宝积经卷第五十三

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之十九般若波罗蜜多品第十一之四

复次舍利子。云何菩萨摩诃萨四正胜道善巧。舍利子。菩萨摩诃萨。以修般若波罗蜜多故。道有四种。何等为四。一者未生恶不善法为不生故。便生欲乐。勇猛策励发勤精进。摄持于心平等安住。二者已生恶不善法为永断故。便生欲乐。勇猛策励发勤精进。摄持于心平等安住。三者未生善法为生起故。便生欲乐。勇猛策励发勤精进。摄持于心平等安住。四者已生善法令住不忘修习圆满。便生欲乐。勇猛策励发勤精进。摄持于心平等安住舍利子。如是四种又亦名为四种正胜

复次舍利子。云何名为未生恶不善法为不生故。乃至摄持于心平等安住。舍利子。所言未生恶不善法为不生故。便生欲乐勇猛策励者。是谓如理作意故。发勤精进者。是谓不舍如理作意故。摄持于心平等安住者。是则名为如理观察。何以故。由如理方便故。恶不善法不复现行。舍利子。何等名为恶不善法。复以何义。恶不善法。不复现行。舍利子。恶不善法。所谓尸罗戒所对治。定所对治。慧所对治。云何名为戒所对治。舍利子。言对治者。所谓犯戒及余一切发起。毁犯尸罗之法。诸妙戒聚之所对治。如是名为戒所对治。舍利子。何等名为定所对治。所谓违犯轨则及余一切。引心乱法诸妙定聚所对治法。如是名为定所对治。舍利子。何等名为慧所对治。所谓毁犯于见及余一切。能引诸见缠障盖法。诸妙慧聚之所对治。如是名为慧所对治。舍利子。诸如是等并得名为恶不善法。若诸所有如理作意。不令如是恶不善法得生起者。是则名为恶不善法不复现行。舍利子。是名菩萨摩诃萨第一正胜

复次舍利子。云何名为已生恶不善法为永断故。乃至摄持于心平等安住。舍利子。若诸恶不善法积集于心。无方无处及诸恶不善法现行觉心。依止于因缘所缘境。而得生起。何等名为缘境生起。所谓因净妙相而起贪心。损坏相故而起嗔心。无明相故而起痴心。尔时菩萨便住如是如理思惟。不净相故贪欲寂静。慈愍相故嗔恚寂静。缘起相故愚痴寂静。是诸烦恼虽由作意。永息灭故。假立言说名为寂静。而实寂静无别可得。但为断灭平等性故。现观诸法。即以此法而名正胜。舍利子。是名菩萨摩诃萨第二正胜

复次舍利子。云何名为未生善法为欲生故。乃至摄持于心平等安住。舍利子。如是义者文句无量。何以故。菩萨摩诃萨。无量善法皆应积集。由是文句而有无量。舍利子。当知菩萨一切善根。乐欲为本。由精进故。便能积集一切善根。何以故。由如是法摄持安住故。一切善根皆得究竟。舍利子。是名菩萨摩诃萨第三正胜

复次舍利子。云何名为已生善法。令住不忘修习圆满便生欲乐。乃至摄持于心平等安住。舍利子。如是义者。当知即是回向菩提。何以故。由回向菩提。所有善根无复失坏故。所以者何。以彼菩萨不依三界而发心故。舍利子。若诸菩萨不依三界修习善根。又复回向一切智者。当知所有一切善法。则为究竟无能有尽。舍利子。是名菩萨摩诃萨第四正胜。舍利子。菩萨摩诃萨为欲修行般若波罗蜜多故。精勤修习。如是四种道分善巧

复次舍利子。云何菩萨摩诃萨五分道善巧。舍利子。何等为五。所谓信根。精进根。念根。定根。慧根。是名为五。舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多信根。舍利子。如是信者信四种法。何等为四。一者信受如是处生死中世间正见。由此信故。菩萨摩诃萨依趣业报。乃至失命因缘。终不兴意造诸恶业。二者信受如是诸菩萨行。由此信故修行正行。终不起意乐证余乘。三者信受如是胜义了义甚深缘起。一切诸法无我无有情。但是言说之所假立。唯空无相无愿之相。由此信故。有情见趣及诸随眠不复增长。四者信受如是力无畏等一切佛法。既信受已。离疑离惑。修集一切所有佛法。舍利子。如是等相。是名菩萨摩诃萨信根。舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多精进根。所谓信所信法。由精进根而得生起。即以此法名精进根。舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多念根。所谓诸法由于精进之所积集。以念根力而不失坏。即以此法而为念根。舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多定根。所谓诸法由念根力所不失坏。即彼诸法以定根故摄住一缘故名定根。舍利子。云何名为菩萨摩诃萨修行般若波罗蜜多慧根。所谓诸法由定根故。摄住一缘。即彼诸法以慧根力观达明了故名慧根。舍利子。菩萨摩诃萨若具如是五增上根。无间相续修行正行。能速圆满一切佛法。亦速趣入授记别地。舍利子。譬如外道具五通仙。若诸胎藏男女二形犹未生起。终不为彼妄有授记。如来亦尔。若诸菩萨未具成就如是五根无间相续。终不为彼而授记也。舍利子。如是等相。是名菩萨五分道法。菩萨摩诃萨为欲修行般若波罗蜜多故。便能修习如是五分道善巧

复次舍利子。菩萨摩诃萨以依般若波罗蜜多故。道善巧者复有五分。何等为五。所谓信力。精进力。念力。定力。慧力。是名为五。舍利子。云何名为菩萨摩诃萨信力。舍利子。是诸菩萨清净胜解忍受决定。坚固难坏。不可制伏。设有恶魔化为佛像。到菩萨所为作障碍。令是菩萨于正法智及胜解脱。欲使远离情不欣乐。又作是言。如是法者非佛正教。舍利子。假使四大之性互相转变。终不能使成就信力。胜解菩萨为魔惑故信力倾动。舍利子。如是名为菩萨摩诃萨信力

复次舍利子。云何菩萨摩诃萨精进力。舍利子。所谓菩萨发勤精进方便修习一切善法。于彼诸处获得坚固住持之力。由是力故。乃至彼处所为之事未终究竟。于其中间。无有一切天及世间。于是菩萨住持之力。能令移动不住本处。舍利子。如是名为菩萨摩诃萨精进力

复次舍利子。云何菩萨摩诃萨念力。舍利子。诸菩萨等。于彼彼法由安住念。令心安住。无有能令移动散乱。是菩萨摩诃萨由念持力。善能摧灭一切烦恼。而无有能制伏此念。舍利子。如是名为菩萨摩诃萨念力

复次舍利子。云何菩萨摩诃萨三摩地力。舍利子。诸菩萨等安住远离诸静虑支。虽复观察一切音声。诸语业道及音声刺。而不能障最初静虑。是诸菩萨虽以如是一切善法。寻伺推求无量诸法。而不能障第二静虑。是诸菩萨虽复安住所生欢喜。而不能障第三静虑。是诸菩萨虽为成熟一切众生。摄受正法不住于舍。而不能障第四静虑。舍利子。菩萨摩诃萨。安住如是四种静虑。一切静虑所对治法不能制伏。又是菩萨虽于三摩地安住不舍。而不随彼定力受生。舍利子。如是名为菩萨摩诃萨三摩地力。复次舍利子。云何菩萨摩诃萨慧力。舍利子。是智慧力坚固难伏。所谓一切世间出世间法所不制伏。如是智力。又是菩萨生生之处。乃至世间已行正行。工巧业处难作难解。而诸菩萨于彼一切。不由师教现前了知。舍利子。是诸菩萨又于一切出世间法。谓能救度诸世间者。菩萨摩诃萨。以智慧力悉能摄受。不为一切世间天人之所制伏。舍利子。是名菩萨摩诃萨慧力。如此等相。是则名为菩萨摩诃萨五分道善巧。舍利子。是诸菩萨摩诃萨。为欲修行般若波罗蜜多故。精勤修习如是五分道善巧

复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多觉分善巧。舍利子。菩萨摩诃萨有七种觉分。何等为七。所谓念觉分。择法觉分。精进觉分。喜觉分。安觉分。等持觉分。舍觉分。是名菩萨摩诃萨七种觉分。舍利子。云何名为菩萨摩诃萨念觉分。所谓诸菩萨由依如是正念力故。随觉诸法。观察诸法。寻思诸法。了达诸法。简择诸法。鉴照诸法。是菩萨摩诃萨。由念力故。随觉一切诸法体相。舍利子。何等名为了达诸法自体相智。谓由念力觉一切法自体相空。若诸菩萨通达此者。是则名为念觉分法

复次舍利子。云何名为菩萨摩诃萨择法觉分。谓诸菩萨。具足简择八万四千诸法藏智。随彼诸法应当简择。如是简择所谓了义。如是了义由不了义。不了义者由世俗义。世俗义者由胜义义。胜义义者由假施设。假施设者由胜决择。此胜决择是名简择。舍利子。若诸菩萨成就此者。如是名为择法觉分

复次舍利子。云何名为菩萨摩诃萨精进觉分。所谓菩萨即于如是念择法喜安定舍智。摄受欣乐。勇猛势力欲无退减。正勤策励不舍善扼。为道现观所发正勤。舍利子。若诸菩萨成就此者。如是名为精进觉分

复次舍利子。云何名为菩萨摩诃萨喜觉分。谓由菩萨于法生喜。便喜悦法。由喜悦法故。心不沉没。不沉没故。生清净喜。由喜清净故。身心安隐离诸烦恼。舍利子。若诸菩萨成就此者。如是名为喜觉分法

复次舍利子。云何名为菩萨摩诃萨安觉分。所谓菩萨由身安故。获得心安。由心安故。息诸烦恼。远离一切所有盖障。于所缘境其心安住。如是便入于三摩地。舍利子。若诸菩萨成就此者。是则名为安觉分法

复次舍利子。云何名为菩萨摩诃萨三摩地觉分。所谓菩萨以是定心觉知于法。非不定心。何以故。若心得定觉了诸法。终不发起诸爱见等缠障邪觉。唯除于法平等实性。心定趣入觉一切法平等之性。舍利子。若诸菩萨成就此者。如是名为三摩地觉分法。复次舍利子。云何名为菩萨摩诃萨舍觉分法。所谓菩萨于能顺忧喜分法。心无执着。于诸世法心不摄受。不高不下。安住不动。无欣无厌。无爱无恚。唯能随顺修习圣道。若诸菩萨成就此者。是则名为舍觉分法。如是舍利子。菩萨摩诃萨。欲于是等七觉分法通达善巧故。便乐修行般若波罗蜜多。精勤修习觉分善巧

复次舍利子。云何菩萨摩诃萨。修行般若波罗蜜多道分善巧。舍利子。菩萨摩诃萨。具足如是八圣道分。何等为八。所谓正见。正思惟。正语。正业。正命。正精进。正念。正三摩地。如是名为诸菩萨等八圣道分。舍利子。云何名为菩萨摩诃萨正见。舍利子。谓众贤圣出世间见。如是见者非我见起。非有情见起。非命者见起。非数取者见起。非断见起。非常见起。非有见起。非无有见起。非善见起。非不善见起。乃至非涅槃见起。舍利子。若诸菩萨远离此见。是则名为菩萨正见

复次舍利子。云何菩萨摩诃萨。正思惟。舍利子。若诸菩萨由此思惟。则能发起贪嗔痴等一切烦恼。如是思惟终不发起。若诸菩萨由此思惟。便能生长戒聚定聚慧聚解脱解脱智见聚等诸功德者。如是思惟诸菩萨等恒常发起。舍利子。若有菩萨成就此法。是则名为正思惟分

复次舍利子。云何名为菩萨摩诃萨正语。舍利子。谓诸菩萨如是语言。不自损恼。不损恼他。不与众生共相交诤。由是菩萨成就是语。能入圣道故说名为菩萨正语

复次舍利子。云何名为菩萨摩诃萨正业。舍利子。谓诸菩萨终不造作黑黑报业。若业能感白净果报。若业能尽一切诸业。如是业者方便发起。舍利子。是诸菩萨即以此业而为白业。业为依趣。精勤方便修平等业。如是名为菩萨正业

复次舍利子。云何名为菩萨摩诃萨正命。舍利子。谓诸菩萨所有圣种杜多功德。不谄不诳不怀浮诈。于诸乞求性离逼切。易满易养。于彼轨则奉而修行。不生慢缓。于他利养不兴嫉妒。于自利养而生知足。于圣所开不深染着。而常清净自守命行。舍利子。若诸菩萨成就此者。是则名为菩萨正命

复次舍利子。云何菩萨摩诃萨正精进。舍利子。是诸菩萨。若于圣者所不开许。贪嗔痴等烦恼随眠及诸邪行。于是法中发勤精进者。菩萨不乐行于精进。若诸正勤为圣谛摄。趣入圣道。能至涅槃。引发正行。如是精进。为诸菩萨所乐修学。即以此法名正精进。复次舍利子。云何名为菩萨摩诃萨正念。舍利子。谓有诸念极善安住。性非下劣心善正直无有邪曲。能观生死所有过患。与大涅槃为归趣路。若诸菩萨于如是念恒正忆持。为令圣道不忘失故。即以此法名为正念

复次舍利子。云何名为菩萨摩诃萨正三摩地。舍利子。三摩地者。若于正性平等。则于一切法平等。诸菩萨等安住如是三摩地已。为欲解脱一切众生故。趣入正性。如是正定是无尽道。过去未来现在诸佛。为诸菩萨证现观故。宣说开示。是则名为菩萨正定。舍利子。是名菩萨摩诃萨八圣道分。若诸菩萨摩诃萨。为欲修行般若波罗蜜多者。应勤修是八圣道分善巧

复次舍利子。菩萨摩诃萨。以修行般若波罗蜜多故。修道善巧。道善巧者复有二种。何等为二。谓奢摩他。及毗钵舍那。是名为二。舍利子。何等名为奢摩他道。舍利子。谓诸菩萨其心寂静。深极寂静。最胜寂静。无有散乱诸根憺怕不掉不举。离诸躁扰及以惛沈。安静密护离诸谄曲。调顺堪能乐常独处。离彼諠闹乐远离行。身无尘染心无惑乱。于寂静门思惟作意。离诸恶欲无所希望。远诸大欲欢悦知足。正命清净正行圆满。密护威仪知时知分。易养易满善知其量。常乐思择无高无下。弊鄙粗言性能堪忍。于相应门发心安住。乐处闲室于静虑分作意缘念。生起大慈引发大悲。安住大喜修习大舍。从初静虑乃至八定次第证入。若诸菩萨成就此者。如是名为奢摩他道。舍利子。菩萨摩诃萨。复有无量诸奢摩他资粮正行。诸菩萨等于此资粮方便趣入。如是又名奢摩他道

复次舍利子。云何名为毗钵舍那道。谓诸菩萨于妙慧分修习圣道。于诸法中发起如是无作观智。又复发起无我无有情无命者无数取观智。于诸蕴中起法观智。于诸界中起法界观智。于诸处中起空聚落观智。于诸眼中起照了观智。于缘起中起不相违观智。于诸见趣起远离观智。于诸因果起业报观智。于所应得果起作证观智。于所入正性起趣入观智。舍利子。毗钵舍那者。所谓于诸法中起如理见。于诸法中起真实见。于诸法中起不变异见。于诸法中而起空见。于诸法中起无相见。于诸法中起无愿见。又舍利子。毗钵舍那者。非以有因故观。非以无因故观。非以生灭住因故观。非以有所得因故观。何以故。菩萨于此都无所观而复观察。不见而见。见而不见。舍利子。若诸菩萨。作是观者名如实观。名真实见。亦名证得毗钵舍那善巧方便。舍利子。菩萨摩诃萨于此观中。虽复发起如是观解。而不堕彼无所为作。亦不远离善根加行。若诸菩萨成就是者。是名菩萨摩诃萨毗钵舍那。舍利子。菩萨摩诃萨为欲修行般若波罗蜜多故。精勤修习奢摩他毗钵舍那道法善巧。复次舍利子。菩萨摩诃萨道相如是。我若略说菩萨道者。则唯有一趣道善巧。舍利子。何等是耶。所谓菩萨独一众表无有与等不假伴助。为证阿耨多罗三藐三菩提故。由自摄受。精进势力。清净欲解。被坚固铠。何以故。由是菩萨不由他悟。不缘于他自所建立。自力所起。严备如是坚固甲铠。舍利子。是诸菩萨兴发是念。如是甲铠一切众生所不能擐。我今独擐如是甲铠。一切圣贤诸新发意未住正位诸菩萨等。所未曾擐。我今独擐。尔时菩萨又作是念。我于今者严备如是。岂令布施自在度我。我当自在度彼布施。如是持戒忍辱精进静虑及般若等。岂令自在而度于我。我当自在先度于彼。又作是念。我于今者。岂令波罗蜜多发起于我。我当发起波罗蜜多。如是广说一切善根。皆当因我而便发起。不令善根发起于我。舍利子。若诸菩萨摩诃萨。于如是法不假伴助。自能建立。谓我独一无有等者。当坐坚固胜金刚座。自以势力摧伏魔军。用一刹那相应妙慧。当证无上正等菩提。舍利子。若诸菩萨起如是等欲解方便决定观察。是名菩萨摩诃萨趣一道善巧。舍利子。菩萨摩诃萨。为欲修行般若波罗蜜多故。修习如是趣一道善巧。舍利子。诸如是等道善巧相。诸菩萨摩诃萨。为欲修行般若波罗蜜多故。修习如是道法善巧

复次舍利子。云何菩萨摩诃萨缘起善巧。舍利子。谓诸菩萨依般若波罗蜜多。修缘起者处密静室。作是思惟。如是世间纯大苦聚。从于何所而得集起。既思惟已便自了知。如是苦聚。由不如理作意集故无明集起。无明集故诸行集起。诸行集故诸识集起。诸识集故名色集起。名色集故六处集起。六处集故。诸触集起。诸触集故诸受集起。诸受集故诸爱集起。诸爱集故诸取集起。诸取集故诸有集起。诸有集故而生集起。生集起故老死愁叹忧苦逼恼皆悉集起。舍利子。菩萨摩诃萨复作是念。如彼诸法虽复集起。无作无用无有主宰。如是诸法诸善为因。不动为因。涅槃为因。彼一切法从缘生起。无有主宰。亦复如是。若诸众生下根为因。中根为因。上根为因。诸业为因。因果流转亦复如是。舍利子。如是一切有所取法因缘和合而得集起。菩萨一切悉能了知。如是名为缘起善巧。舍利子。菩萨摩诃萨又作是念。由何灭故彼诸法灭。既思惟已便自了知。由不如理作意灭故而无明灭。无明灭故诸行便灭。诸行灭故乃至纯大苦聚灭。舍利子。若能了知如是法智。是则名为缘起善巧。舍利子。是诸菩萨又作是念。因依正法依止诸缘依止和合得修诸善。是法若由诸因和合依止诸缘则。此法等不依止我。不依有情。不依命者。不依数取。是则此法不可称量。舍利子。诸菩萨等。若能如是如理观察。是则名为缘起善巧。又复观察一切佛法。皆菩提相缘所起相。观诸缘起皆尽灭。相。以能观待诸众生故。而不趣入毕竟寂灭。是则又名缘起善巧。舍利子。是诸菩萨摩诃萨。为欲修行般若波罗蜜多故。修习如是缘起善巧。复次舍利子。云何菩萨摩诃萨一切法善巧。舍利子。菩萨摩诃萨。修行般若波罗蜜多故。于一切法遍摄一切有为无为。菩萨摩诃萨。于如是等有为无为一切诸法。应修善巧。舍利子。云何菩萨摩诃萨有为善巧。所谓妙善身行。妙善语行。妙善意行。是则名为有为善巧。云何名为无为善巧。即以如是妙善身语及以意行。回向毕竟无为菩提。回向无为菩提妙观。又复回向于萨伐若。是则名为无为善巧。复次舍利子。菩萨摩诃萨有为善巧者。即是积集五到彼岸。何等为五。所谓布施。持戒。忍辱。精进。静虑波罗蜜多。是名有为。若由般若波罗蜜多无为智故。则五到彼岸不可厌毁。如此妙智又能积集诸到彼岸资粮善法。信解无漏无上菩提。及以回向一切智智。是则名为无为善巧

复次舍利子。菩萨摩诃萨有为善巧者。所谓以无碍光照诸众生。以四摄法摄诸众生。是名有为。若观诸法无我无有情无取无执。于四摄法方便善巧。爱乐信受无为等觉。及以回向一切智智。是则名为无为善巧

复次舍利子。菩萨摩诃萨有为善巧者。所谓不断能令生死相续结缚。而复永断能令生死相续烦恼。任持菩提结缚相续一分结缚不复现行。是名有为善巧。若复修习空无相愿。诸法正智现观善巧无上菩提不由他缘于无为法而复作证。是则名为无为善巧

复次舍利子。菩萨摩诃萨有为善巧者。谓诸菩萨虽行三界。而不为彼三界烦恼之所染污。如是名为有为善巧。虽具通达一切三界出离之法。而不坠堕出离界中。是则名为无为善巧。舍利子。菩萨摩诃萨一切法善巧者。是则名为一切智智。若诸菩萨圆满证入一切智智。即一切时智慧善巧。即此名为诸法善巧。舍利子。菩萨摩诃萨为欲修行般若波罗蜜多故。修习如是一切法善巧。如是舍利子。若有依菩萨藏修行般若波罗蜜多菩萨摩诃萨。为欲修行般若波罗蜜多故。依慧分别善巧通达。修习如是十种善巧

复次舍利子。云何名为菩萨摩诃萨妙慧。云何名为到彼岸义。舍利子。所言慧者。谓能解了一切善法。是现见慧。随顺通达一切法故。是真量慧。如实通达一切法故。是通达慧。一切见趣诸缠缚法不为障故。是离愿慧。永离一切欲求愿故。是安悦慧。永息一切诸热恼故。是欢喜慧。缘法喜乐无断绝故。是依趣慧。于诸义智皆现见故。是建立慧。建立一切觉品法故。是证相慧。随其所乘证得果故。是了相慧。善能照了是智性故。是济度慧。救度一切诸瀑流故。是趣入慧。能趣正性无生法故。是策励慧。振发一切诸善法故。是清净慧。离先随眠烦恼浊故。是最胜慧。升陟一切诸法顶故。是微妙慧。以自然智随觉法故。是离行慧。更无杂染三界法故。是摄受慧。一切贤圣所摄受故。是断愿慧。除遣一切相分别故。是舍逸慧。远离一切愚黑闇故。是方便慧。安住一切瑜伽师地者所成就故。是发趣慧。当住一切圣智道故。是照明慧。除灭一切无明瀑流翳暗膜故。是施明慧。开导一切犹如眼故。是无漏慧。慧眼超过邪僻路故。是胜义慧。照了如是大圣谛故。是无别慧。善调顺故。是光明慧。诸智门故。是无尽慧。遍于一切随行照故。是无灭慧。常广见故。是解脱道慧。永断一切取执缚故。是不离处慧。不与一切烦恼障法而同止故。舍利子。如是慧相我今略说。当知菩萨摩诃萨更有无量无边诸慧。何以故。舍利子。如是乃至一切众生所有心行。当知菩萨摩诃萨亦有尔所慧业智行。如是乃至一切众生所有欲解。当知菩萨摩诃萨亦有尔所慧观察智。如是乃至一切众生所有诸烦恼门。当知菩萨摩诃萨亦有尔所广大慧门。如是乃至一切声闻独觉。及正等觉所有遍智。当知菩萨摩诃萨亦有尔所慧所行处。舍利子。如是等一切慧处诸菩萨摩诃萨皆于其中精勤修学。是则名为菩萨妙慧

复次舍利子。云何名为菩萨摩诃萨到彼岸义。舍利子。如是乃至一切所知诸妙善法能到彼岸者。当知皆是到彼岸义。又舍利子。如上广说一切慧句。应知皆是到彼岸义。又诸菩萨修行差别圆满之义。当知皆是到彼岸义。如是一切智智圆满之义。当知皆是到彼岸义。于诸一切为无为法。无执着义。当知皆是到彼岸义。能善觉悟无量生死大过失义。当知皆是到彼岸义。一切诸法有能开悟不觉者义。当知皆是到彼岸义。有能开示无穷尽法宝藏义者。当知是为到彼岸义。无障解脱圆满义者。当知是为到彼岸义。觉悟布施持戒忍辱精进静虑慧平等义。当知是为到彼岸义。最胜决择善巧义者。当知是为到彼岸义。遍行一切众生界义。是则名为到彼岸义。无生法忍圆满之义。是则名为到彼岸义。不退转地究竟满义。是则名为到彼岸义。清净修治诸佛土义。是则名为到彼岸义。成熟一切众生义者。是则名为到彼岸义。往诣道场升菩提座义。是则名为到彼岸义。毕竟摧伏诸魔军义。是则名为到彼岸义。一切佛法皆圆满义。是则名为到彼岸义。于菩萨藏差别法门正安住义。是则名为到彼岸义。舍利子。若于如是大菩萨藏微妙法门。正修学已。我说是等则于一切波罗蜜多皆得究竟

复次舍利子。若有安住大乘诸善男子及善女人。皆当于是大菩萨藏微妙法门。殷勤请求受持读诵通达义理。广为他说分别显示。何以故。舍利子。若有于是菩萨藏经殷重听闻受持读诵。乃至为他分别解说者。当知是人必定获得十种功德称赞利益。何等为十。一者在在所生一切微妙功巧业处究竟通达。二者在所生处常居高族荣望当世。三者所生之处有大威严势力自在。四者凡所言令一切皆从无不信伏。五者所生之处具大豪富。六者在所生处恒为天人所加爱敬。七者生处人中常为轮王得大自在。八者所生常得为天帝释。九者若生色界为大梵王。十者在所生处常不远离大菩提心。舍利子。受持经者。则为获得十种功德称赞利益

复次舍利子。是诸善男子善女人等。受持是经殷重听闻读诵解义。乃至为他广说开示。当知是人复得如是十种功德称赞利益。何等为十。一者不与尼伽兰陀邪论相杂。二者不起我见。三者无有情见。四者无命者见。五者无数取见。六者不起断见。七者不起常见。八者一切世务情无顾及。九者恒发胜心乐欲出家。十者若闻经典速能受持悟解深义。舍利子。是名获得十种功德称赞利益

复次舍利子。是善男子善女人等。受持是经殷重听闻读诵解义。乃至为他广分别说。当知是人复得如是十种功德称赞利益。何等为十。一者成就正念。二者成就正觉。三者成就正趣。四者成就志勇。五者成就正慧。六者得具无难。七者忆本生事。八者性薄贪欲无猛利贪。不为重贪之所烧恼。九者性薄嗔恚无猛利嗔。不为重嗔之所烧恼。十者性薄愚痴无猛利痴。不为重痴之所烧恼。舍利子。是名获得十种功德称赞利益

复次舍利子。是善男子善女人等。受持是经殷重听闻读诵解义。乃至为他广分别说。当知是人复得如是十种功德称赞利益。何等为十。一者成就机速慧。二者成就捷辩慧。三者成就猛利慧。四者成就迅疾慧。五者成就广博慧。六者成就甚深慧。七者成就通达慧。八者成就无著慧。九者常现前见一切如来。既得见已以清美颂而为赞叹。十者善能如理请问如来。又能如理开释疑难。舍利子。是名获得十种功德称赞利益

复次舍利子。是善男子善女人等。受持是经读诵解义。乃至为他广分别说。当知是人复获如是十种功德称赞利益。何等为十。一者常乐远离诸不善友。二者常乐亲近诸善知识。三者能缓诸魔所有系缚。四者摧殄诸魔所有军阵。五者善能诃厌一切烦恼。六者于一切行心恒捐舍。七者违背一切向恶趣道。八者归向一切趣涅槃道。九者善说一切越度生死清净之地。十者巧能随学一切菩萨所行轨则。又能奉行诸佛教敕。如是名为十种功德称赞利益。舍利子。若有善男子善女人。能于如是大菩萨藏微妙法门。殷重听闻受持读诵。研寻义趣明了通达。复能为他广说开示。当知是人则为获得如上功德称赞利益。尔时世尊。欲重宣此义。而说颂曰

  诸聪睿者慧无边　　妙能通达法及义
  尊胜文词善圆具　　由持如是大经王
  常获丰饶法宝藏　　恒欣悦意行法施
  发生最上胜欢喜　　由持如是大经王
  多众生闻说法者　　证斯广大胜功德
  我当云何说是法　　如持经者之所获
  证获如斯最胜慧　　于正法所终无坏
  由念发生微妙智　　能说无上智依处
  勤求善说正法句　　最胜众圣所称赞
  常闻发起超胜行　　由持如是大经王
  慧者闻已持深义　　于诸文句无妄执
  常随理趣而观照　　增长妙智量无边
  无边妙智无边义　　第一义解谅难思
  遍游十方广称赞　　闻经胜利无穷尽
  极善微薄贪嗔痴　　获得第一心清净
  由闻如是大经王　　功德胜利无边际
  虽获胜财无放逸　　称量财义谁坚固
  深达世财非有实　　于财无恋趣非家
  出诣闲静住中林　　于彼惛沈常远离
  听闻净法曾无厌　　静虑正教无悭吝
  请问疑难世导师　　闻已为他广开释
  由斯增长微妙智　　于白净法终无退

如是舍利子。诸菩萨摩诃萨。为欲修行般若波罗蜜多故。于是经典精勤修学。行菩萨行。是名菩萨摩诃萨于般若波罗蜜多方便修学正法之要

大宝积经卷第五十三大宝积经卷第五十四

        大唐三藏法师玄奘奉　诏译

    菩萨藏会第十二之二十大自在天授记品第十二

尔时佛告舍利子。往昔过去大蕴如来应正等觉。为精进行童子。广说如是四无量法。及说六波罗蜜多已。尔时彼佛复告精进行童子。云何菩萨摩诃萨随摄法转。童子当知菩萨摩诃萨。具足如来四摄之法。由是法故。菩萨摩诃萨恒处长夜摄诸众生。何等为四。所谓布施爱语利行同事。如是名为四种摄法。童子云何名为如是摄法。童子所言施者具有二种。一者财施。二者法施。是为布施。言爱语者。谓于一切诸来求乞或乐闻法。菩萨悉能爱语慰喻。言利行者。谓能满足若自若他所有意乐。言同事者。随己所有智及功德为他。演说摄受建立一切众生。令其安住若智若法。复次童子言布施者。于来乞求诸众生所心意清净。言爱语者。于来乞求诸众生所。善言安慰。言利行者。随诸众生所有义利。皆令成熟。言同事者。于来乞求诸众生所。行平等心成其义利。复次童子。言布施者谓诸菩萨发意行舍。言爱语者方便无断。言利行者深心无悔。言同事者回向大乘。复次童子。言布施者谓随慈心而行于舍。言爱语者常不舍离欢喜之心。言利行者成就大悲心。恒欣乐利众生事。言同事者修舍平等无有高下。心恒回向一切智智。复次童子。言布施者如法求财。常思行舍拯济贫乏。言爱语者既施财已重复安处令住法义。言利行者自利利他平等摄受。言同事者为欲利益诸众生故。究竟发起一切智心。复次童子。言布施者一切所有内外诸法悉皆舍离。言爱语者于一切法功德智慧无所秘惜。言利行者弃舍自利专务利他。言同事者总摄财物如置掌中。随缘惠施情无忧戚

复次童子。言法施者如所闻法广为他说。言爱语者以无染心分别开示。言利行者谓为于他授诵经典。乃至说法无有厌倦。言同事者以不舍离一切智心。安置含生于正法所。复次童子。所言法施若为往返求听法者。如佛正教不乱宣说。言爱语者。以微妙音开示正法。言利行者谓以衣服饮食床敷医药及余随用什物众具。于求法者及说法者。但有匮乏即便给施。言同事者常起深心无间说法。复次童子。言法施者由是菩萨了知法施诸施中上常行法施。言爱语者谓所演说利益之事。言利行者演畅其义不依于文。言同事者。欲令圆满一切佛法。常为众生如应敷化。复次童子。言布施者所谓柁那波罗蜜多。言爱语者所谓尸罗波罗蜜多。及以羼底波罗蜜多。言利行者所谓毗利耶波罗蜜多。言同事者所谓静虑波罗蜜多及般若波罗蜜多。复次童子。言布施者谓初发心一切菩萨。言爱语者。谓已发行一切菩萨。言利行者。谓不退转一切菩萨。言同事者。所谓系属一生诸大菩萨。复次童子。言布施者为欲坚固菩提根本。言爱语者为欲成就菩提萌芽。言利行者。为欲开发菩提妙花。言同事者为欲成熟菩提胜果。如是童子。是名菩萨摩诃萨四种摄法。菩萨摩诃萨为欲修行大菩提故。以如是等四摄之法。处于长夜摄受众生。是名菩萨摩诃萨随摄法转。童子如是摄法无量无边。皆说名为菩提之道

舍利子。尔时薄伽梵大蕴如来应正等觉为是精进行童子。开示如是大菩提道。时彼童子具于佛所闻是法已。又闻赞说过去未来现在诸佛。得大欢喜。即以上妙衣服肴膳饮食床敷医药什物众具。持以奉献大蕴如来及声闻众。如是乃经九十六拘胝岁。供养恭敬尊重赞叹。又复兴菩提大愿。虽作如是无量功德。而大蕴如来未与童子授于阿耨多罗三藐三菩提记。舍利子。汝谓彼时精进行童子岂异人乎。勿作余疑。即我身是也。我于彼佛所。以诸供养奉佛及僧。经尔所岁。又复起发大菩提愿。然彼如来不授我记。汝于来世当得作佛号释迦牟尼如来应正等觉。舍利子。从大蕴如来灭度之后。经阿僧企耶劫。尔时有佛出兴于世。名曰宝性如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。宝性如来有八十那庾多声闻弟子。共会说法。一切皆是大阿罗汉。诸漏已尽无复烦恼。乃至其心自在。证得第一波罗蜜。时彼世中有转轮圣王。名曰善见。七宝来应。所谓成就金轮乃至主将兵宝。是善见王。以其轮宝威四天下。正法治世名为法王。仁德育物众所欣重。国界人民居住宽博。所治大城名曰圆满。东西长十二踰缮那。南北广七踰缮那。安隐丰乐人民炽盛甚可爱乐。多诸财宝资具充溢。尔时城中有大长者。名曰善慧。其家巨富财宝充积。已曾供养过去诸佛殖众德本。舍利子。时薄伽梵宝性如来。观是长者深心欲解。作是思惟。此大长者善根已熟。堪为如是大菩萨藏法门之器。又是诸佛正法之器。既了知已。便往其所现大神变。上住虚空结跏趺坐。为彼长者开菩提道。又复赞说过去未来现在诸佛。舍利子。尔时善慧闻佛开示大菩萨道。又闻赞说三世佛已。获得广大欢喜净信。即以上妙衣服肴膳饮食及余资具。以用奉献宝性如来及弟子众。经于千岁供养恭敬尊重赞叹。又复兴起阿耨多罗三藐三菩提微妙大愿。虽作如是广发众行。然彼如来未为授记。舍利子。汝谓尔时善慧长者岂异人乎。勿余异疑。即我身是也。我于尔时。虽以种种供养奉佛及僧。并起广大菩提胜愿。然彼如来不授我记。云于来世当得作佛。号释迦牟尼如来应正等觉。舍利子。自宝性如来灭度之后。经阿僧企耶劫。有佛出世。名曰放光如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。舍利子。以何义故。佛名放光。舍利子。当于尔时有王出世。名曰胜怨。所都大城名盛莲花。安隐丰乐人民炽盛。财宝众具充积流溢。王有大臣婆罗门种。名曰光主。其家巨富。财产仓库具足盈满。而是大臣为胜怨王偏所爱重欣慕其德。常所见遇情无厌逆。舍利子。时胜怨王。割所王国四分之一。赐此大臣封以为王。时光主王治于小国以法御世不行邪抂。舍利子。是光主王。于后异时诞生太子。形貌端正众所乐观。成就第一圆满净色。以三十二大丈夫相具足庄严。又于王子一切身分。皆放光明。犹如日轮之所照耀。因为立号名曰放光。舍利子。时光主王。召集国中诸婆罗门善占相者。皆悉集已。便示王子令其相之。诸婆罗门既睹相已。便作是言。今此王子定当作佛。时光主王即以王子付诸养母。其后不久身相长大聪睿明达。时净居天处色究竟天宫。以通智力知是王子将登正觉。便于彼没来至放光王子菩萨所止处已。右绕菩萨即于其前。说是颂曰

  非谓安处大王宫　　能生清净胜功德
  要假仙幢袈裟相　　果证无上妙菩提
  盛壮须臾若流逝　　迅速过于大猛风
  不可喜乐弊衰老　　摧坏世间之所爱
  衰老能令薄势力　　难得欣乐趣非家
  大仙今者极盛年　　宜当及时发精进
  善哉善哉大慧者　　善哉善哉大超悟
  善哉善哉速出家　　定成坚固正等觉

舍利子。时放光菩萨摩诃萨。为净居天所开悟已。以清净信趣于非家。当出家夜。即成阿耨多罗三藐三菩提。时彼世尊。便以如是广大名称。出现世间。号曰放光如来。十号具足为诸天人之所赞颂。时胜怨王。闻光主王子出家修行证得无上正等菩提。名曰放光。即便往告光主王言。我闻卿子出家成佛。不审世尊大慈悲故能来降不。若不垂愍至于此者。我当严备四种力军。往如来所躬事奉敬。舍利子。时光主王。即集大臣守卫军众具宣是事。诸大臣言。王于今者应自往诣放光如来咨问是事。大悲世尊愍众生故。为欲往彼胜怨王所。为不往耶。时光主王。即便严驾与诸大臣侍卫导从。往如来所。既到彼已顶礼佛足。即以上事具白世尊。时放光如来告父王曰。大王当知。我今往诣胜怨王所。愍众生故。舍利子。时放光如来随所乐欲别住一处胜怨王都。即与二十拘胝大阿罗汉。出诣彼国。尔时父王亦备四种强力军众随从佛后。办具种种上妙衣服肴膳饮食床敷医药及余资具。供佛及僧。乃至随逐如来到已王领国界之际。便礼佛足。绕无数匝。涕泣哽噎。辞退而还。时胜怨王闻放光如来与诸大众。将来诣此盛莲花城。即便严饰所都大城。除去一切沙砾瓦石。清净夷坦街巷道路。扫洒修治极令华丽。又以香水重增沾洒。散布名花量齐人膝。以妙香瓶列薰于道。敷置种种微妙宝衣。于上虚空张施幡盖。作倡伎乐腾郁充满。舍利子。时胜怨王作如是等庄严。绮饰盛莲花城大王都已。又下严敕击鼓宣令。于此王都城之内外。所有花鬘及涂香等。无令有人辄自受用并将出卖。一切皆当奉献供养放光如来。若违此令当加重罚。舍利子。时胜怨王赍持种种花鬘涂香末香珍妙衣服幢幡宝盖。鼓击种种诸妙音乐。又设羽仪现大严备。以王威势出所都城。为欲瞻仰彼如来故。并申礼拜陈诸供养。与四种军及王城内所有婆罗门长者居士豪族类等。往诣佛所。既到彼已。时胜怨王最先顶礼彼如来足。复以种种花鬘涂香末香上妙衣服幢幡宝盖供养如来。自供养已。复令王子大臣及诸侍卫婆罗门长者居士等。亦如大王广修供养。舍利子。时胜怨王既供养已。具欢喜心。具妙善心。具离盖心。具适悦心。与诸群臣而随佛后。舍利子。尔时有婆罗门。名曰珍宝。住大雪山王侧。五百儒童以为弟子。众人所宗。名德远被。善持艺术。于三毗陀经达到彼岸。又于尼揵荼书。及计罗婆论。分别字论。伊底诃婆论。五分记论。随顺世论。祠祀咒论。丈夫相论。于是等论皆善通达。及以自宗师傅三明大教。晓其理趣妙识开遮。舍利子。是婆罗门。有一儒童近住弟子。名曰迷伽。受学珍宝备通幽旨。艺术经论并皆明达。智与师齐堪为导首。时彼迷伽白其师曰。大师当知。所学经论皆已通达。我今当返自所生地。云何奉酬大师恩德。时师告曰。伐瑳迷伽。夫为弟子欲报师恩。当以财宝方陈厚意。所谓何等。若办五百羯利沙钵那者。足表深心。舍利子。尔时迷伽儒童。奉师教已。致敬右绕辞退而行。遍游村城亭馆国邑王都。处处追觅谢师财宝。既具集已将陈酬报。渐渐往诣盛莲花城。遥见王都种种严饰明发华丽甚可爱乐。即问傍人。今此王都有何盛事。荣饰周布庄严乃尔。傍人答曰。卿不知耶。今日放光如来应正等觉。与八十拘胝大阿罗汉。八万四千诸大菩萨。将入此城。其中人民当行大施当兴大福。由斯事故致此庄严。时迷伽儒童。忽闻如是佛名之声。获得广大欢喜净信。窃自惟忖。诸佛如来出世甚难。极难得值过乌昙花。又似盲龟难遇浮孔。百千大劫时或一遇我今奉见甚为希有。定应以此五百羯利沙钵那。贸花散奉放光如来。当更求财用酬师德。舍利子。当于尔时有一女人。赍持七茎殟钵罗花。从市而来。迷伽告曰。何处得此水生花来。女曰。我于某处卖花鬘所。以五百羯利沙钵那买得此花。迷伽告曰。今酬本价能与花不。女曰不然。又曰若不许者。今有五百羯利沙钵那。汝当独取此七茎花。二人当共为可尔不。女曰。卿用此花为作何等。告曰。将用奉散放光如来。女曰。如卿所言从今已往。于诸有趣常能降及为我夫者。当以此花持用相委。尔时迷伽。便报女曰。止止女人勿作是说。何以故。汝女人性掉动轻转多诸放逸。汝之所言不足收采。又我当于阿僧企耶劫。修集佛法广行布施。或以金银珍宝珊瑚末尼真珠琉璃螺贝璧玉象马驼驴牛羊群畜。乃至或舍大国王位车辂服饰内宫妃后男女眷属。或舍手足耳鼻皮肉骨髓髻中明珠眼目头首。大略而言。无有一切内外之物于我施门而不舍者。或复有时当舍于汝。入佛法中以信出家趣于非家。汝性掉动轻转放逸。或当尔时于我大舍而为障碍。其女报曰。审如所言我为大利。纵使卿今卖我此身。乃至充一羯利沙钵那者。终无异心于施留碍。或复割截我身段段舍施。定无留碍修集佛法。迷伽告曰。若能如是此则为可宜速与花。尔时女人持花授与。迷伽取花。便即往诣放光佛所。遥见如来为无量百千拘胝那庾多众生。前后围绕。威仪庠序导众而前。乃至以无量百千功德庄严从彼而来。于世尊所心生净信。以无量种清净欢喜深爱重心。前诣佛所恭敬礼拜不胜欣庆。又见多人以诸大价微妙衣服。为供佛故敷施行道。便作是念。我今虽无上妙衣服。唯有所著弊鹿皮衣。当敷道中藉如来足。作是念已脱衣布地。尔时诸人竞取皮衣。远弃他所。咸生蚩责。云何为是含灵中宝敷设如此弊鹿皮衣。时彼迷伽即便驰往四衢道边泥湿之处。取鹿皮衣敷置其上。作如是念。放光如来大慈悲者。加哀怜我。以遍照眼及遍照智。赐观所为希愿。以足蹈我衣上。尔时如来愍其所念。便以足趾蹈鹿皮衣。迷伽见已。心生庆悦踊跃欢喜。即以所持殟钵罗花。用散佛上。于时复有无量天子。住虚空中。以天曼陀罗花殟钵罗花钵特摩花拘贸陀花奔荼利花及天栴檀末香俱散佛上。作天音乐咏天清歌。遍满虚空大兴供养。时彼迷伽所散之花列住空中。乃复变成无量千数殟钵罗花叶。皆垂下合成花盖随佛而行。迷伽见已倍复踊跃心生净信。于如来前。解十二年金色发髻以布于地。便发无上菩提大愿。若我来世当成如来应正等觉审不虚者。唯愿今者放光如来授手安慰。又发坚固势力弘誓。作如是言。若使如来不以足趾蹈金色发授手安慰。及不授我菩提记者我终不起。即于此地干枯命终。舍利子。尔时放光如来应正等觉。具遍照眼及遍照智。于三世中无事不达。知彼迷伽意欲解已。便举足趾蹑其发上。即便右顾如龙象回。告诸声闻一切大众。汝等苾刍勿蹈其发。所以者何。此儒童者。却后过阿僧企耶劫。当成如来应正等觉号释迦牟尼。舍利子。是时迷伽闻佛授记欢喜踊跃。上升虚空高七多罗树。证得百千那庾多拘胝无动诸定。又以神通智力。观见东方过殑伽沙等无量诸佛皆为授记。作如是言。儒童当知。汝于来世。经阿僧企耶劫。当得作佛号释迦牟尼。如是南西北方四维上下周遍十方。各如殑伽沙等无量如来。皆如东方诸佛授记。舍利子。迷伽儒童。既蒙诸佛授记安慰已。从虚空下来诣佛所。以信舍家趣于非家。修习坚固清净梵行。舍利子。汝今于此无生疑惑。谓彼往世迷伽儒童是余人乎。勿作是观。即我为彼儒童菩萨。我于尔时。以是五茎青色莲花。奉散彼佛。复解金发敷置道上。兴如是行便蒙授记。是故舍利子。若有菩萨摩诃萨。欲得速受如来记者。当于如是大菩萨藏微妙法门。殷重听闻受持读诵通明义趣。广为他说分别开示。复应修行无相正行。何以故。我忆往昔未得值遇放光佛前。无有一切白净行法不修行者。虽作如是无量勤苦。然不蒙佛为我授记。所以者何。由修诸行皆有相故。从是已后。我方于是大菩萨藏微妙法门。随所闻已安住正行。如是行者谓无相行。无功用行。无所得行。行如是等无相行已。放光如来乃为授记。舍利子。我忆往昔最初得见放光佛时。便得超过一切有相有功用行。又初见佛便能随觉一切法性。又得通达一切诸法自性无生。从是已后放光如来乃为授记。作如是言。迷伽儒童。汝于来世。过阿僧企耶劫。当得作佛号释迦牟尼如来应正等觉。舍利子。当授记时。我便证得无生法忍。舍利子。证得何等无生法忍。所谓证得一切色法无所得忍。证得受想行识法无所得忍。证得蕴界处法无所得忍。舍利子。言得忍者。是则名为忍受诸法都无所得。何以故。非于证得如是忍时。世间之法而复现行。非异生法。非诸学法。非无学法。非独觉法。非菩萨法。非诸佛法而复现行。所以者何。由一切法不现行故。说名得忍。由一切法毕竟无得亦无所得故名得忍。又是忍者。于一刹那尽一切相及诸所缘故得名忍。又是忍者。不忍于眼。不坏于眼及诸所缘故名得忍。不忍于耳鼻舌身意。不坏于意。如是忍者无尽境界。如是忍者非趣境界故名得忍。是故舍利子。若有菩萨摩诃萨。欲得速为如来授记证是忍者。当于如是大菩萨藏微妙法门。殷重听闻受持读诵。通达义趣。广为他说分别开示安住正行。谓无相行。无功用行。无所得行。如是等法名为正行

尔时大众中有长者子。名那罗达多。从薄伽梵。闻说如是大菩萨藏微妙法门。又闻赞叹诸佛菩萨胜功德已。即从坐起披一肩衣。以右膝轮安置于地。向佛合掌顶礼恭敬。而白佛言。世尊先为诸长者等广说诸法相续不绝。如是开示如是教导。皆令证得阿罗汉果。即于此生尽老死际。而未闻说大菩萨藏微妙法门赞叹诸佛菩萨功德。我幸大利今具得闻。窃生是念。如是大乘为尊为胜。为上为妙。为无有上。更无过上。所谓阿耨多罗三藐三菩提。我今现前亲闻佛说受持领悟开显诸法。如是法者分别诸法无所依执。无我我所。无有摄受。世尊。我作是念。如是妙法为尊为胜为上为妙。为无有上。更无过上。如是法者我当修集。世尊。我今思惟一切乘中为无上者。所谓佛乘。诸佛如来亦说此乘。置为第一。最为无上。我从今日发起无上正等觉心。为欲利安多众生故。为欲悲愍诸世间故。利益安乐无量天人。如佛建立诸大菩萨所有学处。我今皆当悉依随学。说是语已。尔时世尊告长者子。善哉善哉。善男子。阿耨多罗三藐三菩提。甚难证信。甚难修习。汝今乃能深发是意。时长者子白佛言。世尊。无上菩提虽复甚难证信修集。然我今者发起如是勇猛精进。必当修集阿耨多罗三藐三菩提。不以为难。又我于此阿耨多罗三藐三菩提。奉修牢强定无退转。世尊。我于今者发大弘誓。假使发菩提心。如殑伽沙数。方证无上正等觉者。我于是事弥增精进。乃至如上一一发心。经如殑伽沙等劫。乃至随是发菩提心。一一所发要由斩截殑伽沙等身分头首。方能起者是菩提心。虽复经履如是勤苦。我于是中倍加精进。终不放舍无上菩提。何以故。纵逢如是诸苦难事。犹应修集。藉斯缘故必证菩提。何况为证无上菩提。受诸安乐而不修学。所以者何。阿耨多罗三藐三菩提。其性高广具足周大无上佛法。不可思议。不可称量。无有涯际。不可宣说。虽复诸佛无障碍智。经历百千拘胝那庾多劫。以诸言音说此菩提。非易可尽。尔时长者子那罗达多。即于佛前。而说颂曰

  百千拘胝劫　　乃发菩提心
  虽众苦所逼　　不舍含生界
  随发菩提心　　要断诸身首
  聚量高迷楼　　我亦能堪忍
  我安住菩提　　利乐含生故
  愿我于来世　　如今日世尊
  远彼声闻乘　　兼济下乘者
  愿我于来世　　如今日世尊
  此乘为大乘　　最上佛称赞
  我观无与等　　故欣乐菩提
  为拔济危厄　　为脱三恶趣
  为求是如来　　出世现成佛

尔时长者子那罗达多说是颂已便自思惟。我今明达广大佛法。如何不以教化妻子诸眷属等。此非我宜。作是念已即从坐起。顶礼佛足右绕三匝。速疾还家。严办种种诸供养具。与其七妻男女奴婢各有七人。赍持千双上妙衣服。及诸花香供养之具。又与五百乐人相随。疾出王舍大城。为欲奉见薄伽梵故。时王舍城有多人众。见长者子与其眷属速疾驰出。因而问曰。汝等今者有何匆遽。与诸眷属将往何所。长者子言。诸善男子岂不知乎。今者如来应正等觉止鹫峰山。无量百千天人大众前后围绕。无数方便为诸众生。分别开示广大佛法故。我今者率领眷属将往佛所。为求如是广大佛法。为欲成办不可思议不可称量诸佛智慧。为欲种殖无上正等菩提善根。汝等若欲成就广大诸佛法者。可共同诣彼如来所。当共种是广大佛法无上善根。尔时王舍城中人民之类。闻长者子说是语已。有十千人皆乐随从往至佛所。时长者子那罗达多。与其眷属及以随从满十千人。同时见佛顶礼佛足却住一面。时长者子。与诸俱来所有大众。赍持花鬘涂香末香衣盖幢幡。作倡伎乐歌咏赞叹供养如来。复以千双净妙珍服以覆佛上。时长者子。作是奉已欢喜无量。即于佛前说伽他赞。其颂曰

  第一有情微妙者　　成清净行上菩提
  能发无边胜智见　　如是我今修供养
  昔无量劫多修行　　为利众生求大觉
  证法自在现成佛　　如是我今修供养
  我与妻子眷属众　　为利含识求菩提
  并及多千人民等　　同共归依大觉者

尔时长者子说是伽陀赞叹佛已。便白佛言。世尊。我今与此诸有情等至如来所。皆已安住阿耨多罗三藐三菩提。唯愿世尊哀愍此等。复为说法。当令一切于阿耨多罗三藐三菩提不复退转。又我今者。欲于佛所种诸善根。唯愿世尊现为我证。当使如是善根力故。令诸众生平等速证阿耨多罗三藐三菩提。又获无量广大佛法。亦如今者现在世尊。时长者子。与诸眷属五百乐工十千人众。一心同声白佛言。世尊。我等今者于如来前。同共至诚归依于佛。归依于法。归依于僧。唯愿世尊忆持我等。是邬波索迦始从今日乃至寿终。宁弃身命不舍归趣清净信心。又复世尊忆持我等。始从今日乃至菩提。为阿耨多罗三藐三菩提故。发起增上勇猛之心。又复世尊忆持我等。唯愿速证阿耨多罗三藐三菩提。为诸众生宣说正法。亦如今者如来无异。又复世尊忆持我等。唯愿来世成佛之时。大众围绕如今无异。又复世尊忆持我等。唯愿来世度脱无量苦逼众生。如今无异。时长者子及诸来众。并五百乐工。作是誓已。复以种种微妙音乐。供养如来。右绕三匝。尔时世尊愍此等故。上升虚空结加趺坐。时五百乐工。既睹如来现此神变。于世尊所倍生净信。以佛威力。诸音乐器不假摄持自然上踊。住在空中无所凭据。作众伎乐繁会充溢右绕如来。时长者子俱来大众。咸睹神变叹未曾有。心生庆悦踊跃欢喜。皆共合掌致敬如来。尔时空中周匝正等一踰缮那。复有无量百千音乐。亦无执持自然而现。犹如蜂房悬处虚空。作倡伎乐发微妙音。尔时长者子。与其眷属及五百乐工。十千城人及以先来听法众内六十千人。诸苾刍众千二百五十人。佛威力故皆踊空中。又佛神力于上空中。五百乐台自然出现。是诸台中皆说妙法。又有四大乐台现于佛前。庄严雕饰穷世瑰异。又有无量百千拘胝诸天子众列住空中。以天曼陀罗花而散佛上。佛神力故。所散之花。于虚空中变成八万高妙花台。时诸大众。睹上台中有如是等广大庄严。于如来所倍生净信爱敬之心。叹未曾有。尔时世尊。知诸大众其心清净。又复了知那罗达多及俱来众增上意已。便现微笑如前广说。乃至其光还从从顶没。时长老阿难。既睹微笑披一肩衣。向佛合掌恭敬作礼。白佛言。世尊。有何因缘现此微笑。我惟如来所现神相。非无因缘。佛告阿难。汝今当知。此长者子那罗达多七妇男女。并奴婢等三十六人。由供养我善根力故。当来之世经千拘胝劫。不堕恶趣。人天往返受诸快乐。过是劫已值佛出世。名曰商主如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。于是佛所供养恭敬尊重赞叹广修梵行。从是已后复经二十拘胝劫不堕恶道。阿难当知。是长者子七妇七女及以七婢。自此命终便舍女身得成男子。恒与那罗达多。不相舍离行菩萨道。于当来世同处一劫。得成阿耨多罗三藐三菩提。阿难当知。长者子那罗达多菩萨摩诃萨当成佛时。号平等心如来应正等觉。出现于世十号具足。是大菩萨所有眷属当成佛时。皆同一号阿若末若如来应正等觉。具足十号。是五百乐工。以供养我善根力故。当来又经阿僧企耶劫不堕恶趣。又经于彼满千拘胝。转轮圣王而为翼从。阿难当知。是五百乐工大略而言。于是劫中得值十千诸佛。皆得亲承供养无空过者。从是已后同一劫中。得成阿耨多罗三藐三菩提。皆号美音。是十千人以供养我善根力故。中四百人。当得值遇慈氏如来。于彼佛所净修梵行。得尽诸漏便般涅槃。所余人等。当来又经殑伽沙等如是大劫不堕恶道。渐次得值千拘胝佛。于彼佛所广修诸行。尔后一切得成阿耨多罗三藐三菩提。皆同一号名甚希有。阿难当知。是六万众中具满千人。于我灭后正法已尽。又过于彼刀兵中劫。慈氏如来未出现前。众生寿命渐增长时。尔时赡部。当有八万独觉出现于世。是一千人皆得值遇供养修善。于后复值慈氏如来还得供养。从是已后经二十五拘胝那庾多劫不堕恶趣。最后人身诸善根力所觉晓故。净信舍家趣于非家。便得证悟缘觉菩提。阿难当知。于此众中有十千人。具生圣见。余千人等。同发阿耨多罗三藐三菩提心。复有六十那庾多诸天子等。远尘离垢于诸法中生净法眼。如是阿难。谁有见斯殊特胜利。而于佛所。不生净信爱乐恭敬发希有心。唯除愚痴不肖之士。何以故。彼诸人等。于如来所。但修如是微细善根。乃能获得如来大我。或复证入无上涅槃。尔时世尊。欲重宣此义。而说颂曰

  于佛所修诸供养　　获得如斯胜功德
  若有希求高大果　　当于导师修供养
  若佛现在修供养　　或复于佛涅槃后
  供养驮都如芥子　　常得奉侍诸如来
  若复欲修诸供养　　如来住世或涅槃
  供养驮都如芥子　　行平等心果平等
  若有具修平等心　　供养平等人中上
  当成平等之胜报　　及证平等妙菩提
  若有欲摄诸善趣　　遮障绝除众恶道
  及欲趣向涅槃路　　如是获得不为难
  佛具最胜净尸罗　　佛具最胜三摩地
  若生最胜净信已　　当获最胜如来果
  若修最胜诸供养　　速登最胜之善道
  及证最胜尊正见　　能宣最胜微妙法
  若乐人中聪睿者　　亲持诸佛清净法
  当修猛利正欲乐　　多闻如理正思惟
  有得转轮之圣主　　或为帝释梵天王
  广修无量胜功德　　定趣无余大寂灭

尔时世尊说是颂已。告长老舍利子。若有安住大乘诸善男子及善女人。欲疾证得阿耨多罗三藐三菩提者。当于如是大菩萨藏微妙法门。发生猛利清净欲乐殷重听闻。受持读诵通达义趣。广为他说分别开示。何以故。若于是经受持读诵。乃至为他分别说者。能令三宝永不断绝。常不远离四无量行。常勤修习六到彼岸。恒正方便以四摄法摄化众生。舍利子。如是大乘大菩萨藏微妙法门。当知即是诸菩萨道。所以者何。是经典者。善能摄持阿耨多罗三藐三菩提故。舍利子。是经乃是诸菩萨等圣珍宝藏。我依是经正修学已。毕竟证得生死永断。又证一切波罗蜜多。由证是故。即号无上正等觉者。舍利子。如来于一切波罗蜜多。皆已毕竟。如来于一切所作皆已静息。如来于无量诸地皆已证得。又复更证无边之地。何以故。由佛证是诸波罗蜜多故。而能究竟安住一切到彼岸法。是故诸菩萨摩诃萨。应当于是大菩萨藏微妙法门。精进修行如我所证尔时世尊。而说颂曰

  于业应知业　　于报应知报
  无业亦无报　　是安隐涅槃
  诸有为皆苦　　于中无有智
  是故智生已　　有为皆解脱

尔时世尊说是颂已。长老舍利子。及大苾刍。并诸天人健达缚阿素洛等。一切众生。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第五十四大宝积经卷第五十五

        大唐三藏菩提流志奉　诏译

    佛为阿难说处胎会第十三

如是我闻。一时佛在舍卫国祇树给孤独园。尊者阿难。于日晡时从禅定起。与五百比丘俱诣佛所。合掌恭敬。顶礼佛足。却住一面。尔时世尊。即告阿难及诸比丘。我有法要初中后善。其义微妙纯一无杂。具足清白梵行之相。所谓入母胎藏修多罗法。应当谛听善思念之。我今为汝分别解说。阿难白佛言。唯然世尊。愿乐欲闻

尔时世尊告阿难言。若有众生欲入胎时。因缘具足便得受身。若不具足则不受身。云何名为缘不具足。所谓父母起爱染心。中阴现前求受生处。然此父母赤白和合。或前或后而不俱时。复于身中各有诸患。若如是者则不入胎。其母胎藏或患风黄血气闭塞。或胎闭塞或肉增结。或有碱病或麦腹病或蚁腰病或如驼口。或车辕曲木或如车轴。或车毂口。或如树叶。或曲绕旋转状如藤笋。或胎藏内犹如麦芒。或精血多泄不暂停住。或滞下流水。或胎藏路涩。或上尖下尖。或曲或浅或复穿漏。或高或下或复短小及诸杂病。若如是者不得入胎。若父母尊贵有大福德。中阴卑贱。或中阴尊贵有大福德。父母卑贱。或俱福德无相感业。若如是者亦不受胎。如是中阴欲受胎时。先起二种颠倒之心。云何为二。所谓父母和合之时。若是男者。于母生爱。于父生嗔。父流胤时谓是己有。若是女者。于父生爱。于母生嗔。母流胤时亦谓己有。若不起此嗔爱心者。则不受胎

复次阿难。云何得入母胎。所谓父母起爱染心。月期调顺中阴现前。无有如上众多过患。业缘具足便得入胎。如是中阴欲入胎时。复有二种。云何为二。一者无有福德。二者有大福德。其无福者觉观心起。所见境界便作是念。我今值遇风寒阴雨。大众愦闹众威来逼便生恐怖。我今应当入于草室及以叶室。或隐墙根。或入山泽丛林窟穴。复更生于种种诸想。随其所见便入母胎。大福德者亦生是念。我今值遇风寒阴雨。大众愦闹众威来逼亦生恐怖。即上高楼。或登大阁。或入殿堂及以床座。亦生诸余种种之想。随其所见便入母胎。佛告阿难。如是中阴初受胎时名歌罗逻。皆依父母不净及过去业而得受身。如是之业及以父母诸缘之中各不自生。和合力故而便受身。譬如以器盛酪及人绳等即便出苏。诸缘之中皆不可得。和合力故苏乃得生。歌罗逻身亦复如是。因缘力故便得受胎

复次阿难。譬如依止青草牛粪及以枣酪而各生虫。一一之中虫不可得。因缘力故虫乃得生。此虫生时青黄赤白。各随所依而作其色。是故当知。父母不净而生此身。诸缘中求皆不可得亦不离缘。和合力故而便受胎。此身生时与其父母四大种性亦无差别。所谓地为坚性。水为湿性。火为热性。风为动性。歌罗逻身。若唯地界无水界者。譬如有人握干糗灰终不和合。若唯水界无地界者。譬如油水其性润湿。无有坚实即便流散。若唯地水无火界者。譬如夏月阴处肉团。无日光照则便烂坏。唯地水火无风界者则不增长。譬如有人及其弟子能善炊糖。诸有所作而令其内悉使空虚。若无风力终不成就。如是四大互相依持而得建立。是故当知歌罗逻身。因于父母四大业风。而得生者亦复如是。众缘之中皆不可得。和合力故而便受身

复次阿难。譬如新净种子善能藏积不为虫食。无有烂坏干焦穿穴。或复有人选择良田润沃之处。下此种子。令一日中牙茎枝叶扶疏荫映花果滋茂皆具足不。不也世尊。佛告阿难。歌罗逻身亦复如是。皆从因缘次第生长。不得一时诸根具足。是故当知。虽从父母而有此身。诸缘中求皆不可得。和合力故而便受生

复次阿难。譬如明眼之人持日光珠置于日中。以干牛粪而悬其上。去珠不远火便出生。不即牛粪及以日光各能生火。亦不相离。因缘力故火便出生。从于父母所生之身亦复如是。歌罗逻身名之为名。受想行识说之为名。名色五阴刹那受身已经诸苦。我不赞叹况复长时轮回诸有。譬如少粪犹尚臭秽。何况于多。如是五阴歌罗逻身谁当爱乐

复次阿难。如是之身处在母胎凡经三十八七日已。方乃出生

第一七日处母胎时名歌罗逻身相初现犹如生酪。七日之中内热煎煮四大渐成

第二七日处母胎时。所感业风名为遍满。其风微细吹母左胁及以右胁。令歌罗逻身相渐现。状如稠酪。或似凝酥。内热煎煮便即转为安浮陀身。如是四大渐渐成就

第三七日处母胎时。复感业风名为藏口。由此风力令渐凝结。其安浮陀转为闭手。状如药杵而复短小。于其胎中内热煎煮。如是四大渐渐增长

第四七日处母胎时。复感业风名为摄取。由此风力能令闭手转为伽那。状如温石。内热煎煮四大渐增

第五七日处母胎时。复感业风名为摄持。由此风力能令伽那转为般罗奢佉。诸疱开剖两髀两肩及其身首而便出现。如春阳月天降时雨树木枝条而便出生。因业风力。诸疱现时。亦复如是

第六七日处母胎时。复感业风名之为饭。由此风力四相出现。云何为四。所谓两膝两肘。名为四相

第七七日处母胎时。复感业风名为旋转。由此风力四相出现。所谓手足掌缦之相。其相柔软犹如聚沫

第八七日处母胎时。复感业风名为翻转。由此风力二十相现。所谓手足二十指相而便出生。如天降雨树木枝条渐得增长。业风力故诸相现前亦复如是

第九七日处母胎时。复感业风名为分散。由此风力现九种相。云何为九。所谓眼耳鼻口大小便处名为九相

第十七日处母胎时。复感业风名为坚鞕。由此风力即便坚实。复有一风名为普门。吹其胎身悉令胀满犹如浮囊

十一七日处母胎时。复感业风名曰金刚。由此风力在于胎中。或上或下。令其身孔皆得通彻。又以风力使怀胎者或复悲喜行住坐卧。其性改常运动手足。令胎身孔渐渐增长。于其口中而出黑血。复于鼻中出秽恶水。此风回转于诸根已。而便息灭

十二七日处母胎时。复感业风名为曲口。由此风力左右胁间生大小肠。犹如藕丝及紧纺线置在于地。十八周转依身而住。复有一风名为穿发。由此风故。三百二十支节。及百一穴生在身中

十三七日处母胎时。复感业风名作饥渴。由此风力胎身虚羸生饥渴想。其母饮食所有滋味于身穴中及以脐轮资持润益。尔时世尊以偈颂曰

  其子处母胎　　已经十三七
  身即觉虚羸　　便生饥渴想
  母所有饮食　　滋益于胎中
  由此身命存　　渐渐而增长

十四七日处母胎时。复感业风名为线口。由此风力生九百筋。于身前后及以左右而交络之

十五七日处母胎时。复感业风名为莲花。由此风力生二十脉。饮食滋味流入此脉润益其身。何者二十。于身前后及以左右各有五脉。此一一脉皆有四十枝派小脉。如是等脉各各复有一百枝派。身前二万名曰商佉(此云赢)身后二万名之为力。身左二万名为安定。身右二万名为具势。如是八万大小支脉生于此身。其脉复有种种之色。所谓青黄赤白酥酪油色。是八万脉一脉一根。于其根上生于一孔。或复二孔乃至七孔。一一皆与毛孔相连。犹如藕根生诸孔穴

十六七日处母胎时。复感业风名为甘露由此风力令此眼耳鼻口胸臆心藏四边九孔之处悉令开发。出入气息上下通彻无有障碍。若有饮食滋润其身。有停积处复能销化从下流出。譬如窑师及其弟子。能善调泥安布轮绳下上回转。所造器物而得成就。此亦如是。皆由风力及善恶业。令眼耳等渐渐具足

十七七日处母胎时。复感业风名髦牛面。由此风力令其两眼而得光洁。耳鼻诸根渐渐成就。譬如有镜尘翳所覆。或取塼末及以油灰磨拭令净。是故当知以业风力吹其眼等使得明净亦复如是

十八七日处母胎时。复感业风名大坚强。由此风力令其诸根。渐渐成就而复明净。犹如日月云雾覆蔽猛风卒起吹令四散。而此日月忽然大明。以是业风吹其诸根。转更明净亦复如是

十九七日处母胎时。由前风力眼耳鼻舌四根成就。初入胎时已具三根。一者身根。二者命根。三者意根。如是诸根悉已具足

二十七日处母胎时。复感业风名曰坚固。由此风力能于身中生种种骨。于左脚中生二十骨。复于右脚亦生二十。足跟四骨膊有二骨。膝有二骨。髀有二骨。腰胯三骨。脊十八骨。肋二十四。胸十三骨。左右二手各二十骨。臂有四骨。肩有二骨。颔有二骨。髑髅四骨。及齿根等有三十二。譬如塑师及其弟子。先以坚木后以绳缠造诸形状。虽未有泥。如是之时名为骨相。以业风力生诸骨时亦复如是。是故当知于七日中。除其小骨大骨生者数有二百

二十一七日处母胎时。复感业风名为生起。由此风力能令其子生于身肉。譬如泥师及其弟子。能善调泥泥诸墙壁。此由业风能生身肉亦复如是

二十二七日处母胎时。复感业风名曰浮流。由此风力能生身血

二十三七日处母胎时。复感业风名为净持。由此风力能生身皮

二十四七日处母胎时。复感业风名曰持云。由此风力令其皮肤皆得调匀光色润泽

二十五七日处母胎时。复感业风名曰持城。由此风力令其子身血肉增长渐渐滋润

二十六七日处母胎时。复感业风名曰生成。由此风力便即能生发毛爪甲。一一皆与诸脉相连

二十七七日处母胎时。复感业风名为曲药。由此风力令其身相渐得成就。或于先世造诸恶业。于诸资具悭贪吝惜不肯惠施。或复不受父母师长教诲。由是业故而得种种不如意身。若以长大肥白柔软之身为端正者。而便受得短小瘦黑坚鞕之身。若以短小瘦黑坚鞕之身为端正者。而便受得长大肥白柔软之身。若于其身支分之中。高下多少疏密为端正者。而便受得无有高下疏密不具足身。或复受得聋盲喑哑手足挛躄诸根不具。所有音声人不喜闻。其身丑陋犹如饿鬼。以恶业故而受种种不如意身。父母亲属尚不喜见。况复余人。若于前世造十善业。好行惠施。无有悭贪谄诳之心。父母师长所有言教即皆信受。以是因缘若得为人。则不受于如上诸恶业身。而便获得种种殊妙之身。颜容端正诸相具足。所有言音而为众人之所爱乐。是故当知由善业故。便得如是胜妙果报。阿难如是之身。若是男者蹲居母腹右胁而坐。两手掩面向脊而住。若是女者蹲居左胁两手掩面背脊而住。生藏之下熟藏之上。内热煎煮。五处系缚如在革囊。其母多食。或复少食。甘食涩食。干食腻食。辛碱苦醋冷热之食。或复淫欲。急行跳踯久卧久坐。皆受苦恼。是故当知处母胎时。有如是等众苦逼迫。我今略说人中尚尔。何况地狱难可为喻。谁有智者于生死海当乐此身

二十八七日处母胎时。生于八种颠倒之想。何等为八。一乘骑想。二楼阁想。三床榻想。四泉流想。五池沼想。六者河想。七者园想。八者苑想。是故名为八种之想

二十九七日处母胎时。复感业风名曰花条。由此风力令此胎身光色润泽诸相分明。皆由过去所造诸业差别不同。随其形类有种种色。或作白色。或复黑色。或不白不黑色或作青色。或干枯色。或润泽色。如是色相而得成就

三十七日处母胎时。复感业风名为铁口。由此风力发毛爪甲皆得增长。亦复能现白黑诸光。从业缘起而生此相

三十一七日。乃至三十五七日处母胎时。身相长大。渐渐增广。人相具足

三十六七日处母胎时。生厌离心不以为乐

三十七七日处母胎时。便起五种不颠倒想。何者为五。一不净想。二臭秽想。三囹圄想。四黑闇想。五厌恶想。其子处胎生如是等厌离之心

三十八七日处母胎时。复感业风名曰拘缘。由此风力即便回转。复有一风名为趣下。能令其身头向于下。长伸两臂渐欲出生。然其此子或于前世。曾经积集堕落之业。令其此身手脚纵横不能转侧。恶业缘故于母腹中而便舍命。母于此时受大苦恼。或复命终。若于前世修诸善业。作长寿因。临欲生时母子安隐。无有如上恶业诸苦。过于三十八七日已。欲出胎时受种种苦方乃得生。是故当知。受此身者实为大苦。初出胎时。若男若女。适生堕地。或以手捧。或衣承接。或在床席。或在屋中。或复地上。或迥露处。或在日中。或冬夏时冷热风触此身。初生受大苦恼。如生剥牛触于墙壁。或复露地随在之处为虫所食。亦如有人而为蚊虻诸虫唼食。复加杖捶而鞭挞之。初出胎时。以暖水洗触其身时。所受之苦亦复如是。儿既生已渐渐增长。母身所出杂血之乳而养育之。我于诸余经中。先已广说。是故当知。此身皆是不净众苦之所成就。谁有智者于生死中。而当爱乐如是之身

复次阿难。初出胎时经于七日。八万户虫从身而生纵横食啖。有二户虫名为舐发依发食发。有二户虫依眼食眼。有四户虫。一名鞍乘。二名有齶。三名发病。四名圆满。依头食头。有一户虫。名黑稻叶。依耳食耳。有一户虫。名为藏口。依鼻食鼻。有二户虫。一名遥掷。二名遍掷。依唇唼唇。有一户虫。名曰针口。依舌食舌。有一户虫。名为利口。依于舌根而食舌根。有一户虫。名为手圆。依齶食齶。有二户虫。一名手网。二名半屈。依止手掌食于手掌。有二户虫。一名远臂。二名近臂。依臂食臂。有二户虫。一者名铁二名近铁。依止咽喉。食于咽喉。有二户虫。一名金刚。二名大金刚。依心食心。有二户虫。一者名羸。二名羸口。依肉食肉。有二户虫。一名具色。二名具称。依血唼血。有二户虫一名勇健。二名香口。依筋食筋。有二户虫。一名不高。二名下口。依止脊骨。食于脊骨。有一户虫。名曰脂色。依脂食脂。有一户虫。名曰黄色。依胆食胆。有一户虫。名曰真珠。依肺食肺。有一户虫。名之为荻。依脾食脾。有五百户虫。一百户虫名之为月。一百户虫名为月口。一百户虫名为辉耀。一百户虫名为辉面。一百户虫名为广大。依止左边而食左边。复有五百户虫亦如是名。依止右边而食右边。有四户虫。一名少穿。二名大穿。三名骨穿。四名骨面。依骨食骨。有四户虫。一名大白。二名小白。三名吸力。四名虎道。依脉食脉。有四户虫。一名意乐。二名师子力。三名兔腹。四名耽欲。依止生藏而食生藏。有二户虫。一名勇猛。二名勇猛主。依止熟藏食于熟藏。有四户虫。一名盐口。二名网口。三名蕴口。四名鸟口。依小便处食小便处。有四户虫一名应作。二名大作。三名碎末。四名臆皱。依大便处食大便处。有二户虫。一名黑面。二名可畏面。依髀食髀。有二户虫。一名疾癞。二名小癞。依膝食膝。有一户虫名为愚根。依膊食膊。有一户虫名为黑头。依脚食脚。阿难。我今为汝略说八万户虫依止此身昼夜食啖。亦复能令气力虚羸颜容憔悴。种种病苦皆集此身。复令其心忧悲热恼。虽有良医亦生迷惑。不知何药能治此病。谁有智者于生死海。而当爱乐如是之身

复次阿难。从初生时乃至长大衣食资养成立此身。然其寿命或经百年。或复短促。于百年中有三百时。谓春夏冬。春为热际。夏为雨际。冬为寒际。此三时中各有四月。一年之中有十二月。于百年中千二百月。黑月白月二千四百。凡经昼夜三万六千一日。再食七万二千。或有不食亦在其数。所谓或病或醉。或时断食。或复嗔恨睡眠调戏诸余事务及饮母乳。以此因缘名为不食。如是之身虽寿百年必归磨灭。谁有智者于生死海而当爱乐。复次阿难。受于此身有二种苦。云何为二。一者众病集身名为内苦。二者人与非人之所逼恼名为外苦。何者名为众病集身。所谓眼耳鼻舌咽喉牙齿胸腹手足有诸病生。或复风痫涕唾。癫狂干消。上气肺逆小便淋沥疥癞痈疽痃癖痔瘘恶疮脓血煎寒壮热种种诸病。皆集此身。复有百一心黄之病。百一风病。百一痰病。风黄痰等和合共起。复有百一。如是四百四病逼切其身名为内苦。复有外苦加害此身。所谓或在牢狱挝打楚挞杻械枷锁系缚诸苦。或劓耳鼻及刖手足斫截其头。不为诸天之所守护。即令非人诸恶鬼神夜叉罗刹而得其便。复为蚊虻蜂等毒虫之所唼食。寒热饥渴风雨并至。种种苦恼逼切其身。人中尚尔。况恶道苦难可具说。是故当知。皆由过去诸不善业受如是报。若为刀杖之所加害。而造城壁及诸墙堑防卫其身。为恶风雨蚊虻蜂螫而求屋舍。为四百四病内苦外苦。而求饮食卧具医药田园室宅金银七宝奴婢车乘资生之具供给所须。不称其心便生苦恼。设获珍财悭贪吝惜常加守护。或时散失复生大苦。阿难。此五阴身一一威仪行住坐卧无不皆苦。若长时行不暂休息是名为苦。住及坐卧各各长时亦复皆苦。若长时行而得暂住。便生乐想其实非乐。若长时住而得暂坐。若长时坐而得暂卧。妄生乐想实无有乐。是故当知。此五阴身皆名为苦。若复有人。或为自利。或为利他。若自他俱利。应当厌患如是诸苦出家修学则于涅槃解脱之法为不唐捐。若复有人或以衣服卧具医药资生之具供养彼者获大果报威德名闻

佛告阿难。于意云何。色是常耶。是无常耶。阿难白佛言。世尊色是无常。佛言。若无常者。为是苦耶。为非苦耶。阿难答言。色即是苦。佛言。若无常苦是败坏法。若有多闻诸圣弟子闻是说已。执于此身如是之色。即是于我及我所不。不也世尊。色中无我亦无我所。复次阿难。于意云何受想行识为是常耶。是无常耶。阿难白佛言。世尊皆是无常。佛言。若无常者为是苦耶。为非苦耶。阿难答言。如是四阴即名为苦。佛言。若无常苦是败坏法。若有多闻诸圣弟子闻是说已。执于此身如是四阴。即是于我及我所不。不也世尊。此四阴者实无有我及以我所。复次阿难。如是我者不在过去现在未来。若内若外若粗若细。若胜若劣。若近若远。彼一切法。悉亦非我及以我所。阿难当知以如实智。而观察之诸法无我。若有名闻诸圣弟子。作是观已便生厌离而得解脱究竟涅槃。如是修学证此法时。生分已尽梵行已立。所作已办不受后有。佛说是经已。尊者阿难。远尘离垢得此法眼净五百比丘不受诸法漏尽意解。时诸大众闻佛所说。皆大欢喜信受奉行

大宝积经卷第五十五大宝积经卷第五十六

        大唐三藏义净译

    佛说入胎藏会第十四之一

如是我闻。一时薄伽梵在劫比罗城多根树园。与大苾刍众无量人俱。尔时世尊。有弟名曰难陀。身如金色。具三十相。短佛四指。妻名孙陀罗。仪容端正世间罕有。光华超绝人所乐见。难陀于彼缠绵恋着无暂舍离。染爱情重毕命为期。世尊观知受化时至。即于晨朝着衣持钵。将具寿阿难陀为侍者。入城乞食次至难陀门首而立。以大悲力放金色光。其光普照难陀宅中皆如金色。于时难陀便作是念。光明忽照定是如来。令使出看乃见佛至。即便速返白难陀曰。世尊在门。闻此语已。即欲速出迎礼世尊。时孙陀罗便作是念。我若放去。世尊必定与其出家。遂捉衣牵不令出去。难陀曰。今可暂放。礼世尊已我即却回。孙陀罗曰。共作要期方随意去。以庄湿额而告之曰。此点未干即宜却至。若迟违者罚金钱五百。难陀曰。可尔。即至门首顶礼佛足。取如来钵却入宅中。盛满美食持至门首。世尊遂去即与阿难陀。世尊现相不令取钵。如来大师威严尊重不敢唤住。复更授与阿难陀。阿难陀问曰。汝向谁边取得此钵。答曰。于佛边取。阿难陀曰。宜授与佛。答曰。我今不敢轻触。大师默然随去。世尊至寺。洗手足已。就座而坐。难陀持钵以奉。世尊食已告曰。难陀。汝食我残不。答言。我食。佛即授与。难陀食已。世尊告曰。汝能出家不。答言出家。然佛世尊昔行菩萨道时。于父母师长及余尊者所有教令曾无违逆。故得今时言无违者。即告阿难陀曰。汝与难陀剃除须发。答曰。如世尊教。即觅剃发人。为其落发。难陀见已告彼人曰。汝今知不。我当不久作转轮王。汝若辄尔剃我发者。当截汝腕。彼便大怖裹收刀具。即欲辞出。时阿难陀便往白佛。佛便自去。诣难陀处问言。难陀汝不出家。答言。出家。是时世尊。自持瓶水灌其顶上。净人即剃。便作是念。我今敬奉世尊。旦为出家暮当归舍。既至日晚寻路有行。尔时世尊。于其行路化作大坑。见已便念孙陀罗斯成远矣。无缘得去。我今相忆或容致死。如其命在至晓方行。忆孙陀罗愁苦通夜。尔时世尊知彼意已。告阿难陀曰。汝今宜去告彼难陀。令作知事人即便往报。世尊令尔作知事人。问曰。云何名为知事人。欲作何事。答曰。可于寺中捡挍。众事。问曰。如何应作。答言。具寿凡知事者。若诸苾刍出乞食时。应可洒扫寺中田地。取新牛粪次第净涂。作意防守勿令失落。有平章事当为白僧。若有香花应行与众。夜闭门户至晓当开。大小行处常须洗拭。若于寺中有损坏处。即应修补。闻是教已。答言。大德如佛所言我皆当作。时诸苾刍于小食时执持衣钵。入劫比罗城为行乞食。于时难陀见寺无人。便作是念。我扫地了即可还家。遂便扫地。世尊观知。以神通力。令扫净处粪秽还满。复作是念。我除粪秽。方可言归。放帚收持粪秽无尽。复作是念。闭户而去。世尊即令闭一房竟更闭余户。彼户便开。遂生忧恼。复作是念。纵贼损寺此亦何伤。我当为王更作百千好寺倍过于是。我宜归舍。若行大路恐见世尊。作是思量即趣小径。佛知其念从小道来。既遥见佛不欲相遇。路傍有树枝荫低垂。即于其下隐身而住。佛令其树举枝高上其身露现。佛问难陀。汝何处来可随我去。情生羞耻从佛而行。佛作是念此于其妇深生恋着。宜令舍离。为引接故。出劫比罗城。诣室罗伐。既至彼已。住毗舍佉鹿子母园。佛念难陀愚痴染惑。尚忆其妻爱情不舍。应作方便令心止息。即告之曰。汝先曾见香醉山不。答言未见。若如是者捉我衣角。即就捉衣。于时世尊犹如鹅王。上升虚空至香醉山。将引难陀左右顾盼。于果树下见雌猕猴。又无一目即便举面直视世尊。佛告难陀曰。汝见此瞎猕猴不。白佛言见。佛言。于汝意云何。此瞎猕猴比孙陀罗谁为殊胜。答言。彼孙陀罗是释迦种。犹如天女。仪容第一举世无双。猕猴比之。千万亿分不及其一佛言。汝见天宫不答言未见。可更捉衣角。即便执衣还。若鹅王上虚空界至三十三天。告难陀曰。汝可观望天宫胜处。难陀即往欢喜园。婇身园粗身园交合园圆生树善法堂。如是等处诸天苑园花果浴池游戏之处。殊胜欢娱悉皆遍察。次入善见城中。复见种种鼓乐丝竹微妙音声。廊宇疏通床帷映设。处处皆有天妙婇女。共相娱乐。难陀遍观见一处所。唯有天女而无天子。便问天女曰。何因余处男女杂居受诸快乐。汝等何故唯有女人。不见男子。天女答曰。世尊有弟名曰难陀。投佛出家专修梵行。命终之后当生此间。我等于此相待。难陀闻已踊跃欢欣速还佛所。世尊问言。汝见诸天胜妙事不。答言已见。佛言。汝见何事。彼如所见具白世尊。佛告难陀。见。天女不。答言已见。此诸天女比孙陀罗。谁为殊妙。白言世尊。以孙陀罗比此天女。还如香醉山内以瞎猕猴比孙陀罗。百千万倍不及其一。佛告难陀修净行者有斯胜利。汝今宜可坚修梵行。当得生天受斯快乐。闻已欢喜默然而住。尔时世尊便与难陀。即于天没至逝多林。是时难陀思慕天宫而修梵行。佛知其意。告阿难陀曰。汝今可去告诸苾刍。不得一人与难陀同座而坐。不得同处经行。不得一竿置衣。不得一处安钵及着水瓶。不得同处读诵经典。阿难陀传佛言教告诸苾刍。苾刍奉行皆如圣旨。是时难陀既见诸人不共同聚。极生羞愧。后于一时。阿难陀与诸苾刍。在供侍堂中。缝补衣服。难陀见已便作是念。此诸苾刍。咸弃于我不同一处。此阿难陀既是我弟。岂可相嫌。即去同坐。时阿难陀速即起避。彼言。阿难陀。诸余苾刍事容见弃。汝是我弟何乃亦嫌。阿难陀曰。诚有斯理。然仁行别道。我遵异路。是故相避。答曰何谓我道云何尔路。答曰。仁乐生天而修梵行。我求圆寂而除欲染。闻是语已倍加忧戚

尔时世尊知其心念。告难陀曰。汝颇曾见捺洛迦不。答言未见。佛言。汝可捉我衣角。即便就执。佛便将去往地狱中。尔时世尊在一边立。告难陀曰。汝今可去观诸地狱。难陀即去。先见灰河。次至剑树粪屎火河。入彼观察。遂见众生受种种苦。或见以钳拔舌捩齿抉目。或时以锯[利-禾+皮]解其身。或复以斧斫。截手足。或以牟[矛*(替-曰+貝)]镵身。或以捧打槊刺。或以铁锤粉碎。或以镕铜灌口。或上刀山剑树碓捣石磨铜柱铁床受诸极苦。或见铁镬猛火沸腾热焰洪流煮有情类。见如是等受苦之事。复于一铁镬空煮炎热中无有情。睹此忧惶。问狱卒曰何因缘故。自余铁镬皆煮有情。唯此镬中空然沸涌。彼便报曰佛弟难陀。唯愿生天专修梵行。得生天上暂受快乐。彼命终后入此镬中。是故我今然镬相待。难陀闻已生大恐怖。身毛皆竖白汗流出。作如是念。此若知我是难陀者。生叉镬中。即便急走诣世尊处。佛言。汝见地狱不。难陀悲泣雨泪哽咽而言。出微细声白言已见。佛言汝见何物。即如所见具白世尊。佛告难陀。或愿人间或求天上勤修梵行有如是过。是故汝今当求涅槃。以修梵行勿乐生天而致勤苦。难陀闻已情怀愧耻默无所对。尔时世尊知其意已。从地狱出至逝多林。即告难陀及诸苾刍曰。内有三垢。谓是淫欲嗔恚愚痴。是可弃舍。是应远离。法当修学

尔时世尊。住逝多林未经多日。为欲随缘化众生故。与诸徒众往占波国。住揭伽池边。时彼难陀与五百苾刍。亦随佛至往世尊所。皆礼佛足在一面坐。时佛世尊见众坐定。告难陀曰。我有法要。初中后善文义巧妙。纯一圆满清白梵行。所谓入母胎经。汝当谛听。至极作意善思念之。我今为说。难陀言。唯然世尊。愿乐欲闻。佛告难陀。虽有母胎有入不入。云何受生入母胎中。若父母染心共为淫爱。其母腹净月期时至。中蕴现前。当知尔时名入母胎。此中蕴形有其二种。一者形色端正。二者容貌丑陋。地狱中有容貌丑陋。如烧杌木。傍生中有其色如烟。饿鬼中有其色如水。人天中有形如金色。色界中有形色鲜白。无色界天元无中有以无色故。中蕴有情。或有二手二足。或四足多足或复无足。随其先业应托生处。所感中有即如彼形。若天中有头便向上。人傍生鬼横行而去。地狱中有头直向下。凡诸中有皆具神通乘空而去。犹如天眼远观生处。言月期至者谓纳胎时。难陀有诸女人。或经三日。或经五日半月一月。或有待缘经久期水方至。若有女人身无威势。多受辛苦形容丑陋无好饮食。月期虽来速当止息。犹如干地洒水之时即便易燥。若有女人身有威势。常受安乐仪容端正得好饮食。所有月期不速止息。犹如润地水洒之时即便难燥。云何不入。父精出时母精不出。母精出时父精不出。若俱不出皆不受胎。若母不净父净。若父不净母净。若俱不净亦不受胎。若母阴处为风病所持。或有黄病痰癊。或有血气胎结。或为肉增。或为服药。或麦腹病蚁腰病。或产门如驼口。或中如多根树。或如犁头。或如车辕。或如藤条。或如树叶。或如麦芒。或腹下深。或有上深。或非胎器。或恒血出。或复水流。或如鸦口常开不合。或上下四边阔狭不等。或高下凹凸。或内有虫食烂坏不净。若母有此过者。并不受胎。或父母尊贵。中有卑贱。或中有尊贵。父母卑贱。如此等类亦不成胎。若父母及中有俱是尊贵。若业不和合亦不成胎。若其中有于前境处无男女二爱亦不受生

难陀云何中有得入母胎。若母腹净。中有现前见为欲事。无如上说众多过患。父母及子有相感业方入母胎。又彼中有欲入胎时心即颠倒。若是男者于母生爱于父生憎。若是女者于父生爱于母生憎。于过去生所造诸业。而起妄想作邪解心。生寒冷想大风大雨及云雾想。或闻大众闹声。作此想已。堕业优劣。复起十种虚妄之相。云何为十。我今入宅。我欲登楼。我升台殿。我升床座。我入草庵。我入叶舍。我入草丛。我入林内。我入墙孔。我入篱间。难陀其时中有作此念已。即入母胎。应知受生名羯罗蓝。父精母血非是余物。由父母精血和合因缘。为识所缘依止而住。譬如依酪瓶钻人功。动转不已得有酥出。异此不生。当知父母不净精血羯罗蓝身亦复如是

复次难陀。有四譬喻。汝当善听。如依青草虫乃得生。草非是虫虫非离草。然依于草因缘和合。虫乃得生身作青色。难陀当知。父精母血羯罗蓝身亦复如是。因缘和合大种根生。如依牛粪生虫。粪非是虫虫非离粪。然依于粪因缘和合。虫乃得生身作黄色。难陀当知。父精母血羯罗蓝身亦复如是。因缘和合大种根生。如依枣生虫。枣非是虫。虫非离枣。然依于枣因缘和合。虫乃得生身作赤色。难陀当知。父精母血羯罗蓝身亦复如是。因缘和合大种根生。如依酪生虫身作白色。广说乃至因缘和合大种根生。复次难陀依父母不净羯罗蓝故。地界现前坚鞕为性。水界现前湿润为性。火界现前温暖为性。风界现前轻动为性。难陀若父母不净羯罗蓝身。但有地界无水界者便即干燥悉皆分散。譬如手握干糗灰等。若但水界无地界者即便离散。如油渧水。由水界故地界不散。由地界故水界不流。难陀羯罗蓝身。有地水界无火界者。而便烂坏。譬如夏月阴处肉团。难陀羯罗蓝身但有地水火界无风界者。即便不能增长广大。此等皆由先业为因更互为缘。共相招感识乃得生。地界能持。水界能摄。火界能熟。风界能长。难陀又如有人若彼弟子熟调沙糖。即以气吹令其增广。于内虚空犹如藕根。内身大种地水火风业力增长亦复如是。难陀非父母不净有羯罗蓝体。亦非母腹。亦非是业。非因非缘。但由此等众缘和会。方始有胎。如新种子不被风日之所损坏。坚实无穴藏举合宜。下于良田并有润泽。因缘和合方有牙茎。枝叶花果次第增长。难陀此之种子。非离缘合牙等得生。如是应知非唯父母非但有业及以余缘而胎得生。要由父母精血因缘和合方有胎耳。难陀。如明眼人为求火故将日光珠置于日中。以干牛粪而置其上。方有火生。如是应知。依父母精血因缘合故方有胎生。父母不净成羯罗蓝号之为色。受想行识即是其名说为名色。此之蕴聚可恶名色托生诸有。乃至少分刹那我不赞叹。何以故。生诸有中是为大苦。譬如粪秽少亦是臭。如是应知生诸有中少亦名苦。此五取蕴色受想行识。皆有生住增长及以衰坏。生即是苦。住即是病。增长衰坏即是老死。是故难陀。谁于有海而生爱味。卧母胎中受斯剧苦

复次难陀。如是应知凡入胎者。大数言之有三十八七日。初七日时胎居母腹。如[打-丁+屑]如痈卧在粪秽如处锅中。身根及识同居一处。壮热煎熬极受辛苦名羯罗蓝。状如粥汁或如酪浆。于七日中内热煎煮。地界坚性水界湿性。火界暖性风界动性。方始现前

难陀第二七日胎居母腹。卧在粪秽如处锅中。身根及识同居一处。壮热煎熬极受辛苦。于母腹中。有风自起名为遍触。从先业生。触彼胎时名頞部陀。状如稠酪。或如凝酥。于七日中内热煎煮。四界现前。难陀。第三七日广说如前。于母腹中。有风名刀鞘口。从先业生。触彼胎时名曰闭尸。状如铁箸。或如蚯蚓。于七日中四界现前。难陀第四七日广说如前。于母腹中。有风名为内门。从先业生吹击胎箭名为健南。状如鞋楥。或如温石。于七日中四界现前。难陀第五七日广说如前。于母腹中。有风名曰摄持。此风触胎有五相现。所谓两臂两[月*坒]及头。譬如春时天降甘雨。树林郁茂增长枝条。此亦如是五相显现

难陀第六七日。于母腹中。有风名曰广大。此风触胎有四相现。谓两肘两膝。如春降雨荑草生枝。此亦如是四相显现。难陀。第七七日。于母腹中。有风名为旋转。此风触胎有四相现。谓两手两脚。犹如聚沫。或如水苔。有此四相。难陀。第八七日。于母腹中。有风名曰翻转。此风触胎有二十相现。谓手足十指。从此初出。犹如新雨树根始生。难陀。第九七日。于母腹中。有风名曰分散。此风触胎有九种相现。谓二眼二耳二鼻并口。及下二穴。难陀。第十七日。于母腹中。有风名曰坚鞕。令胎坚实。即此七日于母胎中。有风名曰普门。此风吹胀胎藏。犹如浮囊。以气吹满。难陀。第十一七日。于母胎中。有风名曰疏通。此风触胎令胎通彻。有九孔现。若母行立坐卧作事业时。彼风旋转虚通。渐令孔大。若风向上上孔便开。若向下时即通下穴。譬如锻师及彼弟子以槖扇时上下通气。风作事已即便隐灭

难陀。第十二七日。于母腹中。有风名曰曲口。此风吹胎。于左右边作大小肠犹如藕丝。如是依身交。络而住。即此七日。复有风名曰穿发。于彼胎内作一百三十节无有增减。复由风力作百一禁处。难陀。第十三七日。于母腹中。以前风力知有饥渴。母饮食时所有滋味。从脐而入藉以资身。难陀。第十四七日。于母腹中。有风名曰线口。其风令胎生一千筋。身前有二百五十。身后有二百五十。右边二百五十。左边二百五十。难陀。第十五七日。于母腹中。有风名曰莲花。能与胎子。作二十种脉。吸诸滋味。身前有五。身后有五。右边有五。左边有五。其脉有种种名及种种色。或名伴。或名力。或名势。色有青黄赤白豆苏油酪等色。更有多色共相和杂。难陀。其二十脉。别各有四十脉。以为眷属。合有八百吸气之脉。于身前后左右。各有二百。难陀。此八百脉。各有一百道脉眷属相连合有八万。前有二万。后有二万。右有二万。左有二万。难陀。此八万脉。复有众多孔穴。或一孔二孔。乃至七孔。一一各与毛孔相连。犹如藕根有多孔隙。难陀。第十六七日。于母腹中。有风名曰甘露行。此风能为方便。安置胎子二眼处所。如是两耳两鼻口咽胸臆。令食入得停贮之处。能令通过出入气息。譬如陶师及彼弟子。取好泥团安在轮上。随其器物形势安布令无差舛。此由业风能作如是。于眼等处随势安布。乃至能令通过出入气息。亦无爽失。难陀。第十七七日。于母腹中。有风名曰毛拂口。此风能于胎子眼耳鼻口咽喉胸臆食入之处。令其滑泽。通出入气息。安置处所。譬如巧匠若彼男女。取尘翳镜以油及灰。或以细土揩拭令净。此由业风能作如是。安布处所无有障碍。难陀。第十八七日。于母腹中。有风名曰无垢。能令胎子六处清净。如日月轮大云覆蔽。猛风忽起吹云四散。光轮清净。难陀。此业风力。令其胎子六根清净亦复如是。难陀。第十九七日。于母腹内。令其胎子成就四根眼耳鼻舌。入母腹时。先得三根。谓身命意。难陀。第二十七日。于母腹中。有风名曰坚固。此风依胎左脚生指节二十骨。右脚亦生二十骨。足跟四骨髆有二骨。膝有二骨。[月*坒]有二骨。腰髁有三骨。脊有十八骨。胁有二十四骨。复依左手生指节二十骨。复依右手亦生二十。腕有二骨。臂有四骨。胸有七骨。肩有七骨。项有四骨。颔有二骨。齿有三十二骨。髑髅四骨。难陀。譬如塑师或彼弟子先用鞕木作其相状。次以绳缠。后安诸泥。以成形像。此业风力安布诸骨亦复如是。此中大骨数有二百。除余小骨

难陀。第二十一七日。于母腹中。有风名曰生起。能令胎子身上生肉。譬如泥师先好调泥泥于墙壁。此风生肉亦复如是。难陀。第二十二七日。于母腹中。有风名曰浮流。此风能令胎子生血。难陀。第二十三七日于母腹内。有风名曰净持。此风能令胎子生皮。难陀。第二十四七日。于母腹中。有风名曰滋漫。此风能令胎子皮肤光悦。难陀。第二十五七日。于母腹中。有风名曰持城。此风能令胎子血肉滋润。难陀。第二十六七日。于母腹中。有风名曰生成。能令胎子身生发毛爪甲。此皆一一共脉相连。难陀。第二十七七日。于母腹中。有风名曰曲药。此风能令胎子发毛爪甲悉皆成就。难陀。由其胎子先造恶业悭涩吝惜。于诸财物坚固执着不肯惠施。不受父母师长言教。以身语意造不善业。日夜增长当受斯报。若生人间。所得果报皆不称意。若诸世人以长为好彼即短。若以短为好彼即长。以粗为好彼即细。若以细为好彼即粗。若支节相近为好。彼即相离。若相离为好彼即相近。若多为好彼即少。若少为好彼即多。爱肥便瘦。爱瘦便肥。爱怯便勇。爱勇便怯。爱白便黑。爱黑便白。难陀。又由恶业感得恶报。聋盲喑哑愚钝丑陋。所出音响人不乐闻。手足挛躄形如饿鬼。亲属皆憎不欲相见。况复余人。所有三业向人说时。他不信受不将在意。何以故。由彼先世造诸恶业。获如是报。难陀。由其胎子先修福业好施不悭怜愍贫乏。于诸财物无吝着心。所造善业日夜增长。当受胜报。若生人间。所受果报悉皆称意。若诸世人以长为好则长。若以短为好则短。粗细合度支节应宜。多少肥瘦勇怯颜色无不爱者。六根具足端正超伦。词辩分明音声和雅。人相皆具见者欢喜。所有三业向人说时。他皆信受敬念在心。何以故。由彼先世造诸善业。获如是报。难陀。胎若是男。在母右胁蹲居而坐。两手掩面向母脊住。若是女者在母左胁蹲居而坐。两手掩面向母腹住。在生藏下熟藏之上。生物下镇熟物上刺。如缚五处插在尖摽。若母多食或时少食。皆受苦恼。如是若食极腻或食干燥。极冷极热。咸淡苦醋。或太甘辛。食此等时皆受苦痛。若母行欲。或急行走。或时危坐。久坐久卧。跳踯之时悉皆受苦。难陀当知。处母胎中。有如是等种种诸苦。逼迫其身不可具说。于人趣中受如此苦。何况恶趣地狱之中苦难比喻。是故难陀。谁有智者。乐居生死无边苦海受斯厄难。难陀。第二十八七日。于母腹中。胎子便生八种颠倒之想。云何为八。所谓屋想。乘想。园想。楼阁想。树林想。床座想。河想。池想。实无此境妄生分别。难陀。第二十九七日。于母腹中。有风名曰花条。此风能吹胎子。令其形色鲜白净洁。或由业力令色黧黑。或复青色。更有种种杂类颜色。或令干燥无有滋润。白光黑光随色而出。难陀。第三十七日。于母腹中。有风名曰铁口。此风能吹胎子。发毛爪甲令得生长。白黑诸光皆随业现。如上所说。难陀。第三十一七日。于母腹中胎子渐大。如是三十二七。三十三七。三十四七日已来。增长广大。难陀。第三十五七日。子于母腹支体具足。难陀。第三十六七日。其子不乐住母腹中。难陀。第三十七七日。于母腹中。胎子便生三种不颠倒想。所谓不净想。臭秽想。黑暗想。依一分说。难陀。第三十八七日。于母腹中。有风名曰蓝花。此风能令胎子转身向下。长舒两臂趣向产门。次复有风名曰趣下。由业力故。风吹胎子。令头向下双脚向上。将出产门。难陀。若彼胎子。于前身中造众恶业。并堕人胎。由此因缘将欲出时。手脚横乱不能转侧。便于母腹以取命终。时有智慧女人。或善医者。以暖苏油。或榆皮汁及余滑物。涂其手上。即以中指夹薄刀子利若锋芒。内如粪厕黑闇臭秽可恶坑中。有无量千虫恒所居止。臭汁常流精血腐烂深可厌患。薄皮覆盖恶业身疮。于斯秽处。推手令入。以利刀子脔割儿身。片片抽出。其母由斯受不称意极痛辛苦。因此命终。设复得存与死无异。难陀。若彼胎子善业所感。假令颠倒不损其母。安隐生出不受辛苦。难陀。若是寻常无此厄者。至三十八七日。将欲产时母受大苦。性命几死方得出胎。难陀。汝可审观。当求出离

大宝积经卷第五十六大宝积经卷第五十七

        大唐三藏义净译

    佛说入胎藏会第十四之二

尔时世尊复告难陀。汝今既知胎苦生苦。应识凡受胎生者是极苦恼。初生之时。或男或女。堕人手内。或在衣等。安在日中。或在阴处。或置摇车。或居床席怀抱之内。由是因缘。皆受酸辛楚毒极苦。难陀。如牛剥皮近墙而住。被墙虫所食。若近树草树草虫食。若居空处诸虫唼食。皆受苦恼。初生亦尔。以暖水洗受大苦恼。如癞病人皮肤溃烂脓血横流。加之杖捶极受楚切。生身之后。饮母血垢而得长大。言血垢者。于圣法律中即乳汁是。难陀。既有如是种种极苦。无一可乐。谁有智者。于斯苦海而生爱恋。常为流转无有休息。生七日已。身内即有八万户虫。纵横啖食。难陀。有一尸虫名曰食发。依发根住常食其发。有二户虫。一名伏藏。二名粗头。依头而住常食其头。有一户虫。名曰绕眼。依眼而住常食于眼。有四户虫一名驱逐。二名奔走。三名屋宅。四名圆满。依脑而住常食于脑。有一户虫名曰稻叶。依耳食耳。有一户虫。名曰藏口。依鼻食鼻。有二户虫。一名遥掷。二名遍掷。依唇食唇。有一户虫。名曰蜜叶。依齿食齿。有一户虫。名曰木口。依齿根食齿根。有一户虫名曰针口。依舌食舌。有一户虫。名曰利口。依舌根食舌根。有一户虫。名曰手圆。依齶食齶。复有二户虫。一名手网。二名半屈。依手掌食手掌。有二户虫。一名短悬。二名长悬。依腕食腕。有二户虫。一名远臂。二名近臂。依臂食臂。有二户虫。一名欲吞。二名已吞。依喉食喉。有二户虫。一名有怨。二名大怨。依胸食胸。有二户虫。一名螺贝。二名螺口。依肉食肉。有二户虫。一名有色。二名有力。依血食血。有二户虫。一名勇健。二名香口。依筋食筋。有二户虫。一名不高。二名下口。依脊食脊。有二户虫。俱名脂色。依脂食脂。有一户虫。名曰黄色。依黄食黄。有一户虫。名曰真珠。依肾食肾。有一户虫。名曰大真珠。依腰食腰。有一户虫。名曰未至。依脾食脾。有四户虫。一名水命。二名大水命。三名针口。四名刀口。依肠食肠。有五户虫。一名月满。二名月面。三名晖曜。四名晖面。五名别住。依右胁食右胁。复有五虫。名同于上。依左胁食左胁。复有四虫。一名穿前。二名穿后。三名穿坚。四名穿住。依骨食骨。有四户虫。一名大白。二名小白。三名重云。四名臭气。依脉食脉。有四户虫。一名师子。二名备力。三名急箭。四名莲花。依生藏食生藏。有二户虫。一名安志。二名近志。依熟藏食熟藏。有四户虫。一名盐口。二名蕴口。三名网口。四名雀口。依小便道食尿而住。有四户虫。一名应作。二名大作。三名小形。四名小束。依大便道食粪而住。有二户虫。一名黑口。二名大口。依髀食髀。有二户虫。一名癞。二名小癞。依膝食膝。有一户虫。名曰愚根。依胫食胫。有一户虫。名曰黑项。依脚食脚。难陀。如此之身甚可厌患。如斯色类。常有八万户虫。日夜啖食。由此令身热恼羸瘦疲困饥渴。又复心有种种苦恼。忧愁闷绝众病现前。无有良医能为除疗。难陀。于大有海生死之中。有如是苦。云何于此而生爱乐。复为诸神病之所执持。所谓天神龙神八部所持及诸鬼神。乃至羯吒布单那。及余禽兽诸魅所持。或为日月星辰所厄。此等鬼神作诸病患。逼恼身心。难可具说

佛告难陀。谁于生死乐入母胎。受极辛苦。如是生成。如是增长。饮母乳血及诸饮食。妄生美想渐至长成。假令身得安乐无病。衣食恣情寿满百岁。于此生中睡眠减半。初为婴儿。次为童子。渐至成长。忧悲患难众病所逼。无量百苦触恼其身。难可说尽。身内诸苦难忍受时。不愿存生意便求死。如是之身苦多乐少。虽复暂住必当谢灭。难陀。生者皆死无有常存。假使药食资养寿命得延年岁。终归不免死王所杀送往空田。是故当知。生无可乐。来世资粮应勤积集。勿作放逸。精修梵行。莫为懒惰。于诸利行法行功德行纯善行。常乐修习。恒观自身善恶二业。系在于心。勿令后时生大追悔。一切所有爱乐之事。皆悉别离。随善恶业趣于后世。难陀。寿命百年有其十位。初谓婴儿位卧于襁褓。二谓童子乐为儿戏。三谓少年受诸欲乐。四谓少壮勇健多力。五谓盛年有智谈论。六谓成就能善思量巧为计策。七谓渐衰善知法式。八谓朽迈众事衰弱。九谓极老无所能为。十谓百年是当死位。难陀。梗概大位略说如是。计准四月以为一时。百年之中有三百时。于春夏冬各有其百。一年十二月总有一千二百月。若半月为数。总有二千四百半月。于三时中各有八百半月。总有三万六千昼夜。一日再食总有七万二千度食。虽有缘不食亦在其数。不食缘者。所谓嗔恨不食遭苦不食。或求索不得。睡眠持斋掉戏不食。事务不食。食与不食而共合集。数有尔许。并饮母乳。人命百年我已具说。年月昼夜及饮食数。汝应生厌。难陀。如是生成长大身有众病。所谓头目耳鼻舌齿咽喉胸腹手足疥癞癫狂水肿欬嗽风黄热癊众多疟病支节痛苦。难陀。人身有如是病苦。复有百一风病。百一黄病。百一痰癊病。百一总集病。总有四百四病。从内而生。难陀。身如痈箭。众病所成。无暂时停。念念不住。体是无常苦空无我。恒近于死败坏之法不可保爱。难陀。凡诸众生复有如是生受苦痛。谓截手足眼耳鼻舌头及支分。复受狱囚枷锁杻械鞭打拷楚饥渴困苦寒热雨雪蚊虻蚁子。风尘猛兽及诸恶触。种种诸恼无量无边难可具说。有情之类常在如是坚鞕苦中。爱乐沉没。诸有所欲苦为根本。不知弃舍更复追求。日夜煎迫身心被恼。内起烧然无有休息。如是生苦老苦。病苦死苦。爱别离苦。怨憎会苦。求不得苦。五取蕴苦。四威仪中行立坐卧。亦皆是苦。若常行时不立坐卧。即受苦无乐。若常立时不行坐卧。若坐不行立卧。若卧不行立坐。皆受极苦而无安乐。难陀。此等皆是舍苦求苦。唯是苦生。唯是苦灭。诸行因缘相续而起。如来了知故。说有情生死之法。诸行无常非真究竟。是变坏法不可保守。当求知足深生厌患勤求解脱。难陀。于善趣中。有情之类。生处不净苦剧如是。种种虚诳说不可尽。何况具说于三恶趣饿鬼傍生地狱有情所受楚毒难忍之苦

复次难陀。有其四种入于母胎。云何为四。一者有情正念入。正念住。正念出。二者正念入。正念住。不正念出。三者正念入。不正念住出。四者三皆不正念。谁是正念入住出。如有一类凡夫有情。性爱持戒。数习善品。乐为胜事。作诸福行。极善防护。恒思质直不为放逸。有大智慧临终无悔。即便受生。或是七生预流。或是家家。或是一来。或是一间。此人由先修善行故。临命过时虽苦来逼受诸痛恼。心不散乱正念而终。复还正念入母胎内。了知诸法由业而生。皆从因缘而得生起。常与诸魔作居止处。难陀应知。此身恒是一切不净窟宅。体非常住。是愚痴物诱诳迷人。此身以骨而作机关。筋脉相连通诸孔穴。脂肉骨髓共相缠缚。以皮覆上不见其过。于热窟中不净充满。发毛爪齿分位差别。执我我所故。恒被拘牵不得自在。常出涕唾秽污流污黄水痰癊烂坏脂腻肾胆肝肺大肠小肠屎尿可恶。及诸虫类周遍充满。上下诸孔常流臭秽。生熟二藏盖以薄皮是谓行厕。汝应观察。凡食啖时牙齿咀嚼。湿以涎唾咽入喉中。髓脑相和流津腹内。如犬咬枯骨妄生美想。食至脐间呕逆覆上还复却咽。难陀。此身元从羯罗蓝。頞部陀。闭尸。健南。钵罗奢佉。不净秽物。而得生长。婴儿流转乃至老死轮回系缚如黑闇坑。如臭坏井。常以咸淡苦辛酸等食味而为资养。又母腹火烧煮身根不净粪锅。常婴热苦。母若行立坐卧之时如被五缚。亦如火炙难可堪忍。无能为喻。难陀。彼胎虽在如是粪秽坑中众多苦切。由利根故心不散乱。复有一类薄福有情。在母腹内或横或倒。由其先业因缘力故。或由母食冷热碱酸甘辛苦味不善调故。或饮浆水过量。或多行淫欲。或饶疾病。或怀愁恼。或时倒地。或被打拍。由是等缘母身壮热。由身热故胎亦烧然。由烧然故受诸苦恼。由有苦故便即动转。由动转故。或身横覆不能得出。有善解女人。以苏油涂手。内母腹中。缓缓触胎令安本处。手触着时。胎子即便受大苦恼。难陀。譬如幼小男女人以利刀削破皮肉散灰于上。由斯便有大苦恼生。胎子楚毒亦复如是。虽受此痛。由利根故正念不散。难陀。此胎如是住母腹中。受如斯苦。又欲产时辛苦而出。由彼业风令手交合。支节拳缩受大剧苦。欲出母胎身体青瘀。犹如初肿难可触着。饥渴逼迫心悬热恼。由业因缘被风推出。既出胎已被外风触如割涂炭。手衣触时皆受极苦。虽受此苦。由上利根故正念不乱。于母腹中知入住出悉皆是苦。难陀。谁当乐入如是胎中。难陀。谁是于母腹正念入住不正念出。难陀。如有一类凡夫有情。性乐持戒修习善品。常为胜事作诸福行。其心质直不为放逸。少有智慧临终无悔。或是七生预流。或是家家。或是一来。或是一间。此人先修善行临命终时。虽苦来逼受诸痛恼。心不散乱。复还正念入母胎中。了知诸法由业而生。皆从因缘而得生起。广说如上。乃至出胎。虽受如是诸极苦楚。由是中利根故入住正念。不正念出。广说如上。乃至谁当乐入如是胎中

难陀。谁是正念入胎。不正住出。难陀。如有一类凡夫有情。性乐持戒修习善品。常为胜事作诸福行。广说如上。乃至临终无悔。或是七生预流等。临命终时众苦来逼。虽受痛恼心不散乱。复还正念入母胎中。由是下利根故。入胎时知住出不知。广说如上。乃至谁当乐入如是胎中

难陀。谁是入住出俱不正念。如有一类凡夫有情。乐毁净戒不修善品。常为恶事作诸恶行。心不质直多行放逸。无有智慧贪财悭吝。手常拳缩不能舒展。济惠于人恒有希望。心不调顺。见行颠倒。临终悔恨。诸不善业皆悉现前。当死之时猛利楚毒痛恼逼切。其心散乱。由诸苦恼。不自忆识我是何人。从何而来今何处去。难陀。是谓三时皆无正念。广说如上。难陀。此诸有情生在人中。虽有如是无量苦恼。然是胜处。于无量百千俱胝劫中。人身难得。若生天上常畏坠堕。有爱别离苦。命欲终时。余天告言。愿汝当生世间善趣。云何世间善趣。谓是人天。人趣难得。远离难处更复是难。云何恶趣。谓三恶道。地狱趣者。常受苦切极不如意。猛利楚毒难可譬喻。饿鬼趣者。性多嗔恚无柔软心。谄诳杀害以血涂手。无有慈悲形容丑陋见者恐怖。设近于人受饥渴苦。恒被障碍。傍生趣者。无量无边。作无义行无福行无法行无善行无淳质行。互相食啖。强者凌弱。有诸傍生。若生若长若死。皆在暗中不净粪尿垢秽之处。或时暂明。所谓蜂蝶蚊蚁蚤虱蛆虫之类。自余复有无量无边。生长常暗。由彼先世是愚痴人。不听经法恣身语意。贪着五欲。造众恶事。生此类中受愚迷苦。难陀。复有无量无边傍生有情。生长及死皆在水中。所谓鱼鳖鼋鼍蝉蛭蚌蛤虾蟆之类。由先世业身语意恶。如上广说。难陀。复有无量无边傍生有情。闻屎尿香。速往其处以为食饮。所谓猪羊鸡犬狐貉雕鹫乌蝇蜣螂禽兽之类。皆由先世恶业所招。受如是报。难陀。复有无量无边傍生之类。常以草木及诸不净。充其饮食。所谓象马驼牛驴骡之属。乃至命终由先恶业。受如是报

复次难陀。生死有海。苦哉痛哉。猛焰烧然极大炎热。无一众生不被烧煮。斯等皆由眼耳鼻舌身意炽盛猛火。贪求前境色声香味触法。难陀。云何名为炽盛猛火。谓是贪嗔痴火。生老病死火。忧悲苦恼毒害之火。常自烧然无一得免。难陀。懈怠之人多受众苦。烦恼婴缠作不善法。轮回不息生死无终。勤策之人多受安乐。发勇猛心。断除烦恼。修习善法。不舍善轭。无休息时。是故汝今应观此身。皮肉筋骨血脉及髓不久散坏。常当一心勿为懈怠。未证得者勤求证悟。如是应学。难陀。我不共世间作诸诤论。然而世间。于我强为诤论。所以者何。诸知法者不与他诤。离我我所共谁为论。由无见解起妄执故。我证正觉作如是语。我于诸法无不了知。难陀。我所言说有差异不。难陀言。不也世尊。如来说者无有差异。佛言善哉善哉。难陀。如来所说必无差异。如来是真语者。实语者。如语者。不异语者。不诳语者。欲令世间长夜安乐获大胜利。是知道者。是识道者。是说道者。是开道者。是大导师。如来应正等觉明行足善逝世间解无上士调御丈夫天人师佛世尊。世间之人无知无信。常与诸根而为奴仆。唯见掌中不观大利易事不修难者恒作。难陀。且止如斯智慧境界。汝今应以肉眼所见而观察之。知所见者皆是虚妄。即名解脱。难陀。汝莫信我莫随我欲。莫依我语莫观我相。莫随沙门所有见解。莫于沙门而生恭敬。莫作是语。沙门乔答摩是我大师。然而但可于我自证所得之法。独在静处思量观察。常多修习随于用心所观之法。即于彼法观想成就正念而住。自为洲渚。自为归处。法为洲渚。法为归处。无别洲渚。无别归处。难陀。云何苾刍自为洲渚。自为归处。法为洲渚。法为归处。无别洲渚。无别归处。如是难陀。若有苾刍。于自内身随观而住。勤勇系念得正解了。于诸世间所有恚恼。常思调伏。是谓随观内身是苦。若观外身及内外身。亦复如是。难陀。次于集法。观身而住。观灭而住。复于集灭二法。观身而住。即于此身。能为正念。或但有智。或但有见。或但有念无依而住。于此世间知无可取。如是难陀。是谓苾刍于自内身随观而住。外身内外身为观亦尔。次观内受外受及内外受而住。观内心外心及内外心而住。观内法外法及内外法而住。勤勇系念得正解了。于诸世间所有恚恼。常思调伏观集法住。观灭法住。复于集灭二法观法而住。即于此身能为正念。或但有智。或但有见。或但有念。于此世间知无可取。如是难陀。是谓苾刍自为洲渚。自为归处。法为洲渚。法为归处。无别洲渚。无别归处。难陀。若有丈夫禀性质直远离谄诳。于晨朝时来至我所。我以善法随机教示。彼至暮时自陈所得。暮以法教旦陈所得。难陀。我之善法现得证悟。能除热恼。善应时机。易为方便。是自觉法。善为覆护。亲对我前闻所说法。顺于寂静。能趣菩提。是我所知。是故汝今见有自利见有他利及二俱利。如是等法应常修学。于出家法谨慎行之。勿令空过。当获胜果无为安乐。受他供给衣食卧具病药等物。令其施主获大福利。得胜果报。尊贵广大。如是难陀。应当修学。复次难陀。未有一色是可爱乐。能于后时不变坏者无有是处。不起忧悲不生烦恼者。亦无是处。难陀。于汝意云何。此色是常。为是无常。大德。体是无常。难陀。体既无常为是苦不。大德。是苦若无常。苦即变坏法。我诸多闻圣弟子众。计色是我我有诸色。色属于我我在色中不。白言。不也世尊。于汝意云何。受想行识是常无常。大德。皆是无常。难陀。体既无常。为是苦不。大德。是苦若无常苦即变坏法。我诸多闻圣弟子众。计受等是我我有受等。受等属我我在受等中不。不也世尊。是故应知凡是诸色。若过去。若未来。若现在。若内若外。若粗若细。若胜若劣。若远若近。所有诸色皆非是我。我不有色。色不属我。我不在色中。如是应以正念正慧而审观察。受想行识。若过去。若未来。若现在。若内若外。若粗若细。若胜若劣。若远若近。此等亦非是我。我亦非有此等。我亦非在此中。如是应以正念正慧而审观察。若我多闻圣弟子众。如是观察于色厌患。复于受想行识亦生厌患。若厌患已即不染着。既无染着即得解脱。既解脱已自知解脱。作如是言。我生已尽。梵行已立。所作已办。不受后有。尔时世尊说此法已。时具寿难陀。远尘离垢得法眼净。五百苾刍于诸有漏心得解脱。尔时世尊重说伽他。告难陀曰

  若人无定心　　即无清净智
  不能断诸漏　　是故汝勤修
  汝常修妙观　　知诸蕴生灭
  清净若圆满　　诸天悉欣庆
  亲友共交欢　　往来相爱念
  贪名著利养　　难陀汝应舍
  勿亲近在家　　及于出家者
  念超生死海　　穷尽苦边际
  初从羯罗蓝　　次生于肉疱
  肉疱生闭尸　　闭尸生健南
  健南暂转变　　生头及四支
  众骨聚成身　　皆从业因有
  顶骨合九片　　颔车两骨连
  齿有三十二　　其根亦如是
  耳根及颈骨　　齶骨并鼻梁
  胸臆与咽喉　　总有十二骨
  眼眶有四骨　　肩偶亦两双
  两臂及指头　　总有五十骨
  项后有八骨　　脊梁三十二
  此各有根本　　其数亦四分
  右胁边肋骨　　相连有十三
  左胁相连生　　亦有十三骨
  此等诸骨锁　　三三相续连
  二二相钩牵　　其余不相续
  左右两腿足　　合有五十骨
  总三百十六　　支柱于身肉
  骨节相钩缀　　合成众生体
  实语者记说　　正觉之所知
  从足至于顶　　杂秽不坚牢
  由此共成身　　脆危如苇舍
  无梢唯骨立　　血肉遍涂治
  同机关木人　　亦如幻化像
  应观于此身　　筋脉更缠绕
  湿皮相裹覆　　九处有疮门
  周遍常流溢　　屎尿诸不净
  譬如仓与篅　　盛诸谷麦等
  此身亦如是　　杂秽满其中
  运动骨机关　　危脆非坚实
  愚夫常爱乐　　智者无染着
  洟唾污常流　　脓血恒充满
  黄脂杂乳汁　　脑满髑髅中
  胸鬲痰癊流　　内有生熟藏
  肪膏与皮膜　　五藏诸腹胃
  如是臭烂等　　诸不净同居
  罪身深可畏　　此即是怨家
  无识耽欲人　　愚痴常保护
  如是臭秽身　　犹如朽城郭
  日夜烦恼逼　　迁流无暂停
  身城骨墙壁　　血肉作涂泥
  画彩贪嗔痴　　随处而庄饰
  可恶骨身城　　血肉相连合
  常被恶知识　　内外苦相煎
  难陀汝当知　　如我之所说
  昼夜常系念　　勿思于欲境
  若欲远离者　　常作如是观
  勤求解脱处　　速超生死海

尔时世尊说是入胎经已。具寿难陀。及五百苾刍。皆大欢喜。信受奉行

难陀苾刍。越生死海险难之处。能至安隐究竟涅槃。获阿罗汉果。说自庆颂曰

  敬心奉澡浴　　净水及涂香
  并修诸福田　　获斯殊胜报

时诸大众闻是说已咸皆有疑。为断疑故请大师曰。大德。难陀苾刍先作何业。由彼报得金色之身。具三十相以自严饰。望世尊身但少四指。于淫欲境极生爱着。大师哀愍。于生死海强拔令出。方便安置究竟涅槃。惟愿为说。佛告诸大众难陀苾刍。先所作业果报成熟皆悉现前。广说如余。即说颂曰

  假使经百劫　　所作业不亡
  因缘会遇时　　果报还自受

汝等谛听。过去世时九十一劫。人寿八万岁。有毗钵尸佛如来应供正等觉明行足善逝世间解无上士调御丈夫天人师佛世尊出现于世。与六万二千苾刍。游行人间。至亲慧城王所都处。往亲慧林即于此住。时彼世尊有异母弟。于淫欲境极生爱着。其毗钵尸如来应正等觉。于生死海劝令出家。方便安置究竟涅槃。时彼国王名曰有亲。以法化世。人民炽盛丰乐安隐。无诸诈伪贼盗疾疫。牛羊稻蔗在处充满。王异母弟极耽淫染。王闻佛众住亲慧林。将诸王子亲侍大臣。及内宫女人民翊从。往诣佛所。顶礼佛足。退坐一面。尔时世尊。为彼王众宣扬妙法。示教利喜得殊胜解。其弟耽欲不肯出门。时大臣子及余知友抚尘之类。诣而告曰。善友知不。王及王子。并诸内宫大臣人众。往毗钵尸佛所。躬行礼敬。听受妙法。获殊胜解。人身难得汝已得之。如何今时耽着淫欲。不肯出门。彼闻责已心生愧耻。俯仰相随同行而去。时佛弟苾刍。见诸徒侣共行而去。问曰。何故君等将此一人共伴而去。时彼同伴。具以事白苾刍曰。我是佛弟。昔在家时。于诸欲境极生耽着。幸蒙大师强牵令出。安隐将趣究竟涅槃。更有如是愚痴之辈。与我相似。仁等慈悲强共将去。诚为大善。今可往诣无上大师。得至佛所必生深信。时彼同伴共至佛所。佛观彼类称根欲性而为说法。既得闻已。深起信心。从座而起。偏袒右肩。合掌向佛。白言世尊。唯愿大师及诸圣众。明至我家入温室澡浴。佛默然受。彼知受已。礼佛双足。奉辞而去。遂至王所。申恭敬已。白言大王。我诣佛所闻法生信。于淫欲境起厌离心。奉请佛僧明至我家入温室浴。如来大师慈悲为受。佛是人天所应供养。王今宜可洒扫街衢严饰城郭。王作是念。佛来入城。我当严饰。然我之弟耽欲难谏。佛今调伏实诚希有。答言甚善。汝今可去营办澡浴所须之物。我当随力严饰城隍。弟生大喜。辞王而去。王告诸臣曰。当可唱令普告诸人明日世尊。将入城内。诸旧住者。及远方来。汝等诸人。咸当随力严饰城郭洒扫街衢。持诸香花迎大师入。臣奉王教。普告令知。具宣王敕时诸人众。于彼城中。除去瓦砾。遍洒香水。烧诸妙香。悬众幡盖。散花供养。如天帝释欢喜之园。时彼王弟。办诸香汤及香油等。庄严浴室敷置床座。毗钵尸佛渐欲至城。王及诸臣太子后妃宫人婇女。及诸人众咸出奉迎。遥礼佛足随从入城。时彼王弟。引佛世尊入温室内。授香水等以充澡浴。见佛世尊身如金色三十二相八十种好周遍庄严。见已欢喜生深信心。洗浴既竟着衣服已。即便顶礼世尊双足。发是愿言。我今幸遇最上福田微申供养。愿此善因于未来世身得金色。与佛无异。如世尊弟。于欲境中深生耽着。强拔令出得趣安隐究竟涅槃。愿我当来得为佛弟。获金色身亦复如是。我于欲境生耽着时。强牵令出爱染深河。得趣涅槃安隐之处。汝等苾刍勿生异念。彼亲慧王耽欲之弟。即难陀苾刍是由于昔时请毗钵尸佛入浴室中香汤澡浴净心发愿。彼之善因。今为佛弟身作金色。我于耽着淫欲之境。强拔令出舍俗出家。究竟涅槃至安隐处

时诸大众更复有疑。请世尊曰。大德难陀苾刍曾作何业。今身感得三十大丈夫相。佛告诸大众。彼所作业广说如前。乃往过去于聚落中有一长者。大富多财资生无乏。有一苑园花果茂盛。流泉浴池林木森竦。堪出家人栖隐之处。时有独觉出现于世。哀愍众生处于闲静。世间无佛唯此福田。于时有一独觉尊者。游行人间至斯聚落。周旋观察届彼园中。其守园人既见尊者告言善来为解劳倦。尊者住此。即于中夜入火光定。园人见已作如是念。此之大德成斯胜行。即便夜起往就家尊。告言大家。宜于今者生庆喜心。于苑园中有一大德。来投我宿。成就妙行具足神通。放大光明遍照园内。长者闻已疾往园中。礼双足已作如是言。圣者仁为求食。我为福因幸住此园。我常施食。彼见殷勤即便为受。住此园内入胜妙定解脱之乐。复作是念。我此臭身轮回生死。所应作者并已获得。宜入圆寂永证无生。作是念已。即升虚空。入火光定。现诸神变。放大光明。上烛红辉下流清水。舍此身已神识不生。永证无余妙涅槃界。时彼长者取其尸骸焚以香木。复持乳汁而灭其火。收余身骨置新瓶中。造窣堵波。悬诸幡盖。深生敬信。洒三十种众妙香水。并发大愿求诸相好。汝等谛听勿生异念。往时长者即难陀是。由以胜妙供养敬信业故。今受果报感得三十殊妙胜相。时诸大众更有疑念。重请世尊。大德。难陀苾刍曾作何业。若不出家弃尘俗者。必当绍继力轮王位。佛告诸苾刍。难陀先世所造之业。果报熟时必当自受。广如上说。过去世时此贤劫中。人寿二万岁。有迦叶波佛出现世间。十号具足。在婆罗痆斯仙人堕处施鹿林中。依止而住。时彼城中王名讫栗枳。以法化世为大法王。广如上说。王有三子。谓大中小。彼迦叶波佛。施化事毕。犹如火尽入大涅槃。其王信敬取佛遗身。以诸香木栴檀沉水海岸牛头天木香等。焚烧既讫。灭以香乳。收其舍利置金宝瓶。造大窣堵波。皆用四宝。纵广正等一踰缮那。高半踰缮那安相轮。时王之中子亲上中盖。汝等苾刍勿生异念。时王中子者即难陀是。由于昔时敬心供养安置中盖斯之善业。于二千五百生中。常为力轮王。化一洲内。今此生中若不出家者。还作力轮王得大自在

时诸大众更复有疑。请问世尊。大德难陀苾刍曾作何业。于佛弟子善护根门最为第一。佛言。此由愿力。难陀苾刍。于迦叶波佛时。舍俗出家其亲教师。彼佛法中善护根门称为第一。尽其形寿梵行自持。然于现身竟无证悟。于命终时便发誓愿。我于佛所尽斯形寿梵行自持。然于现身竟无所证。愿我以此修行善根。此佛世尊记未来世有摩纳婆当成正觉号释迦牟尼。我于彼佛教法之中。出家离俗断诸烦恼。获阿罗汉如亲教师于斯佛所善护根门最为第一。我亦如是。于彼教中守护根门最为第一。由彼愿力。今于我所诸弟子中。善护根门最为第一。如是苾刍若纯黑业得纯黑报。若纯白业得纯白报。若杂业者当受杂报。是故汝等离纯黑杂业。修纯白业。如是应修

大宝积经卷第五十七大宝积经卷第五十八

        大唐于阗三藏实叉难陀译

    文殊师利授记会第十五之一

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众一千人俱。菩萨八万四千。文殊师利菩萨观世音菩萨。得大势菩萨。而为上首。复与七十二亿诸天众俱。悉皆趣向菩萨之道。复与四天大王释提桓因梵天王等及其眷属。各有五万二千众俱。亦皆趣于菩萨之道。有四阿修罗王。各与眷属无量众俱。复与七万二千大龙王俱。其名曰难陀龙王。优波难陀龙王。婆留那龙王。娑竭罗龙王。持大地龙王。无热恼龙王。高胜龙王。伏魔龙王。最胜龙王。月上龙王。如是等而为上首。复与无量夜叉王俱。其名曰金毗罗夜叉王。阿吒薄拘夜叉王。苏支路摩夜叉王。妙意夜叉王。妙慧夜叉王。妙相夜叉王。普色夜叉王。不动夜叉王。有力夜叉王。大力夜叉王。如是等而为上首。时王舍城国王大臣。及诸四众天龙夜叉人非人等。各以衣服饮食卧具医药种种资具。于如来所恭敬尊重而为供养

尔时世尊。于晨朝时着衣持钵。与诸比丘及于天人百千之众。前后围绕。向王舍城阿阇世宫。佛威神力。放百千种妙色光明。百千音乐同时俱奏。雨众妙花。优钵罗花。钵昙摩花。拘勿头花。芬陀利花。缤纷而下。是时如来以神通力。随所行处。涌出宝莲。大如车轮。白银为茎。真金为叶。毗琉璃宝以为其须。于花台中。有化菩萨。结加趺坐。是诸菩萨。与宝莲具绕王舍城。右旋七匝。而说颂曰

  释种应供大商主　　利乐含识令安隐
  具大威德寂静心　　为世依怙当入城
  若欲远离老死苦　　或乐游戏于天宫
  或有欲破诸魔军　　应近妙辩人中主
  难得闻名今出现　　经百千劫修众行
  以大悲心游世间　　如是之尊当入城
  曾行无量无边舍　　男女妻室及王位
  头目耳鼻并手足　　衣服饮食亦复然
  已修无量施功德　　证于无上一切智
  以施调心固其行　　戒净无缺大丈夫
  成就无量忍功德　　心恒恬怕当入城
  俱胝劫行胜精进　　念众生苦忘疲倦
  具足无量无比禅　　彼梵音者当入城
  智慧无量无伦匹　　犹若虚空无边际
  最胜人尊戒亦然　　备修众行智清净
  摧坏魔军能济拔　　得住无忧不动位
  无等法王转法轮　　彼释师子当入城
  若欲成佛出兴世　　三十二相以庄严
  应发无等菩提心　　于如来所兴供养
  若欲永舍贪恚痴　　及以远离诸烦恼
  速当亲近释师子　　施作种种诸供养
  若欲速成释梵王　　各千眷属常随从
  恒受天宫诸快乐　　彼应亲近释师子
  欲为四洲胜轮王　　所愿七宝皆成就
  最胜千子咸勇健　　应当供养彼胜尊
  欲为长者邑中主　　资财增广无有量
  眷属色相悉超伦　　彼应供养释师子
  已得解脱及当得　　皆由闻佛寂静法
  难可值遇彼胜尊　　应听甘露无忧句

尔时王舍城中男女长幼无量众生。闻此颂已即皆开悟。各齐香花宝盖幢幡无量音乐。诣如来所一心瞻仰。踊跃欢喜恭敬供养。于是世尊。将欲入城足蹈门阃。城中之地六种震动。雨众妙花及诸音乐。城中众生盲者得视。聋者得闻。狂者得心。裸者得服。饥者得食。贫者得财。时彼众生亦复不为贪欲嗔恚愚痴憍慢之所逼恼。慈心相向犹如父子。彼乐音中而说颂曰

  十力大丈夫　　最胜人师子
  利物入都城　　群生获安乐
  盲瞽得见色　　聋聩得闻声
  颠狂复本心　　裸露蒙衣服
  饥渴遇珍膳　　贫窭得资财
  又于虚空中　　诸天百千亿
  同为供养佛　　竞奏诸乐音
  具德十力尊　　今入此城内
  城中六种动　　所谓遍动等
  众生无怖想　　皆获大欢喜
  而今此城中　　一切诸众生
  不为贪恚痴　　悭嫉之所恼
  欣悦充遍身　　慈念而相向
  愿佛速入城　　安乐诸群品
  世尊入城时　　普放大光明
  人天咸奏乐　　悦畅于心意
  如是诸奇特　　种种无有量
  天人阿修罗　　莫不皆瞻奉

时王舍城。有菩萨长者之子。名摧过咎。于里巷中遥睹世尊相好奇特端严澄睟诸根湛寂观者无厌。住奢摩他最上调伏。防护诸根如善调象。正念不乱如净渊池。三十二相庄严其体。彼菩萨既见是已。生极尊重净信之心。便往佛所稽首双足。右绕三匝却住一面。复有无量百千众生。同诣佛所。无数诸天住虚空中。合掌恭敬尊重顶礼

是时摧过咎菩萨白佛言。世尊。菩萨成就几法。速得阿耨多罗三藐三菩提。随其所愿严净佛刹。于是世尊。为欲调伏诸众生故。为欲哀愍摧过咎故。往诣廛肆。于大众中而告之言。善男子。菩萨成就一法。速得阿耨多罗三藐三菩提。随其所愿严净佛刹。善男子。何谓一法。此菩萨于一切众生行大悲故。以胜志乐发菩提心。云何名为以胜志乐发菩提心。应作是说。若有已发菩提心者。乃至微恶终更不作。何所不作。谓贪嗔痴。及以在家威仪调戏悉皆远离。若出家已。不复悕望名利恭敬。安住出家所修行法。云何出家所修行法。谓如实悟入一切诸法。云何所悟一切诸法。谓蕴界处有为无为。云何悟入。谓观察五蕴寂灭如幻空无所有。如是悟时不见悟入。无觉无思。一切分别悉皆寂灭。若于诸蕴如是悟入。即为悟入一切诸法。是名出家所修行法。菩萨如是修此行时。亦不舍离一切众生。何以故。是菩萨如自所观为众生说。而亦不着法及众生。善男子。是为菩萨成就一法速得阿耨多罗三藐三菩提。亦令佛刹具足圆满。说此法时。摧过咎菩萨得无生忍。欢喜踊跃。上升虚空。高七多罗树。于彼众中。二千众生发菩提心。一万四千诸天及人。远尘离垢。于诸法中得法眼净。于是世尊熙怡微笑。从其面门放种种色光。照无量世界。照已还来。绕佛三匝。而从顶入。是时阿难即从座起。整理衣服。偏袒右肩。右膝着地。于世尊前。而说颂曰

  自在力导师　　到诸法彼岸
  一切智人尊　　何缘现微笑
  善逝十力尊　　能为诸利益
  三世悉明达　　何缘现微笑
  了众生心行　　上中下差别
  知诸想无碍　　愿佛为宣说
  亿那由诸天　　咸来顶礼佛
  愿发微妙音　　充济诸渴仰
  胜定到彼岸　　智慧亦复然
  远离于错谬　　何缘现微笑
  百千诸天众　　为法故来集
  无量诸比丘　　合掌皆愿闻
  奏种种音乐　　供养于如来
  善哉佛世尊　　愿决众疑惑

佛告阿难。汝今见此摧过咎菩萨升虚空不。阿难白言。唯然已见。佛言。善男子。此摧过咎却后过于六万二千阿僧祇劫。于此世界。当得成佛。号寂静调伏音声。劫名离热恼。彼佛刹土功德庄严。及以声闻菩萨之众。亦如不动如来妙喜世界。等无差别。是时世尊。与诸比丘到阿阇世王宫已。各随次第。敷座而坐。时王即以种种饮食。手自斟酌。供养世尊及比丘僧。悉令充足。复以上妙衣服。奉献如来。即于佛前。踞卑床座。而白佛言。世尊。忿恨嗔恼从何而生。愚痴无智由何而灭。佛告大王。忿恨嗔恼我我所生。若不能知功德过失及我我所。名为无智。若如实知彼我我所。此即非智非非智也。大王当知。一切诸行来无所从。去无所至。若无来去则无生灭。若无生灭。彼智无智亦复皆无。何以故。无有少法而能了知生与非生。若离能知。是为知也。时阿阇世王白佛言。世尊。希有如来应正等觉如是善说。我今宁可闻法中夭。不愿徒生寿命相续

尔时世尊。为阿阇世劝发开晓令欢喜已。从座而去。诣耆阇崛山。洗足已敷座而坐。入于三昧。是时如来为法施故。于晡时间。从三昧起。诸大菩萨及声闻众皆从定出。于是文殊师利与四万二千趣菩萨乘诸天子俱。弥勒菩萨与五千菩萨众俱。勇猛雷音菩萨与五百菩萨众俱。如是一切菩萨及诸声闻并阿阇世王。各将眷属前后围绕。诣如来所。顶礼佛足。退坐一面。时王舍城。复有无量百千众生。皆共往诣耆阇崛山。到如来所。顶礼佛足。退坐一面。于是舍利弗。承佛威神。从座而起。偏袒右肩。右膝着地。合掌恭敬。而白佛言。如来。前已于王舍城廛肆之内。为摧过咎。略说菩萨摩诃萨功德庄严清净佛刹。善哉世尊。唯愿广说。如诸菩萨行不退转菩提之行。息诸烦恼。严净佛刹。圆满大愿。具足修行诸波罗蜜。远离声闻辟支佛地。履践如来所行之迹。降伏众魔制诸外道。具一切智转妙法轮。如是菩萨。乃至未得一切种智。而能决定利益安乐无量众生。世尊。今此会中为求菩提。善男子善女人。闻是法已。欢喜修行。于时世尊。作是思惟。今我所说非但为此现前会众。是故宜应示现神变。作是念已。放百千亿妙色光明。一一光明普照十方百千亿土。彼诸佛土所有日月天龙摩尼电火光明映蔽不现。而彼一切大小围山须弥山王。及余诸山丛林树木。为佛光明之所鉴彻。无能现影。是时如来复现威德謦欬之声。其声遍闻十方世界。尔时东方去此八十四恒河沙等佛刹。有世界名普光明。彼现有佛号集吉祥王。而彼佛刹无有声闻辟支佛名。唯是菩萨充满其土。一一菩萨。各有百亿不退菩萨。而为眷属。时彼众中有一菩萨。名曰法上。以何义故。名为法上。谓彼菩萨于众会前闻说法已。上升虚空。高七多罗树。自隐其身。说菩萨藏法门。名陀罗尼金刚句。时彼会众咸作念言。一切诸法但有其声。何以故。即如法上菩萨。不见身相但闻其声。此声无体如彼身相。既离见闻则为法性。说此法时。会中无量得忍菩萨。遥见彼土法上菩萨。又见此刹佛放光明。及闻其声暨乎彼界。彼诸菩萨即时共诣集吉祥王如来所。顶礼佛足。却住一面。法上菩萨白佛言。世尊。以何因缘而现此瑞未曾有也。佛言。善男子。西方去此过八十四恒河沙等佛刹。有世界名娑婆。彼现有佛。号释迦牟尼。为欲召集十方世界诸菩萨故。一切毛孔放此光明及謦欬声。法上菩萨白佛言。世尊。我今欲往娑婆世界。礼觐供养释迦如来及诸菩萨。并欲听法。佛言可往今正是时

尔时法上菩萨。即作是念。今我以何神变。往彼礼觐释迦如来。作是念已。即入一切庄严身三昧。由是三昧威神力故。令此三千大千世界满中妙花积至于膝。百千音乐同时俱作宝幢幡盖种种庄严。复以妙香普熏此界。犹如他化自在天宫。是时法上菩萨。现神变已。即与六十三亿大菩萨众。前后围绕。譬如壮士屈伸臂顷。从彼土没现此界中。到如来所。头面礼足。右绕三匝。随所来方。以愿力故。化现莲花而坐其上

尔时南方去此过九十六亿那由他佛刹。有世界名离尘。彼现有佛。号师子勇猛奋迅。而为无量大菩萨众。恭敬围绕。于彼众中。有一菩萨。名曰宝掌。以何义故。名为宝掌。谓彼菩萨。于诸佛土。化众生时。欲以右手遍扪若干诸佛世界。即随所欲而能成办。从其手出佛法僧声。施戒忍进禅慧慈悲喜舍之声。出如是等百千亿那由他法宝之声。尔时宝掌菩萨。见大光明。闻謦欬声。诣彼佛所。白言。世尊。以何因缘而有此瑞。佛言。善男子。北方去此过九十六亿那由他佛刹。有世界名娑婆。佛号释迦牟尼。为欲演说佛刹功德庄严法门。集诸菩萨。令闻此法摄受功德故现斯瑞。宝掌菩萨白佛言。世尊。我等欲往娑婆世界。礼觐供养释迦如来及诸菩萨。并欲听法。佛言。善男子。宁用去为。何以故。彼娑婆世界具足三毒苦恼众生之所聚集。宝掌菩萨白佛言。世尊。彼释迦如来应正等觉。见何义利。舍严净刹。现秽土中。佛言。善男子。彼佛如来昔于长夜。作如是言。愿我速得成就大悲。常于弊恶众生之中。成等正觉转妙法轮。宝掌菩萨复白佛言。世尊。彼释迦如来。乃能往昔发是大悲难发之愿。现于如此恶世界中。如是慈尊甚为难遇。我今当往礼觐供养。佛言。可尔。今正是时。然善男子。汝诣彼土应当谨察无自毁伤。所以者何。生彼世界诸菩萨等虽为难遇。其余众生心行险诐难可调伏。宝掌白言。彼土虽有忿恨怨仇。无伤于我。假使一切众生尽未来际。嗔恨骂辱。乃至刀杖瓦石打掷。悉能受之终不加报。尔时师子勇猛奋迅如来。谓彼一切众菩萨言。诸善男子。汝等若能如宝掌者。可与俱行。说是语时。于彼会中。有七万二千菩萨。同声白言。我等共往娑婆世界。宝掌菩萨即作是念。今我以何神变。往彼礼觐释迦如来。复能安乐无量众生。作是念已。即以右手。覆此三千大千世界。雨诸饮食衣服车乘金银琉璃真珠珂贝珊瑚璧玉。随诸众生心所悕望。悉能充满。乐闻法者即令得闻。复使无量闻法众生证得真实。亦令无数病苦众生受胜妙乐。是时宝掌菩萨现神变已。与诸菩萨。于一念顷。从彼土没。现此界中。到如来所。顶礼佛足。右绕三匝。随所来方。以愿力故。化现莲花而坐其上。尔时西方去此过七十二亿那由他百千佛刹。有世界名摩尼藏。彼现有佛。号摩尼积王。其佛刹土清净琉璃之所成就。无有声闻及辟支佛。唯是清净大菩萨众。去来坐立于琉璃地。咸见如来分明显现。如明镜中睹其面像。是诸菩萨。于彼地中见佛世尊。亦复如是。见已请法。佛便为说往昔大愿。彼诸菩萨闻法得忍。尔时如来于眉间毫相摩尼宝中。放大光明遍照彼刹。其中所有日月光明映蔽不现。以华开合而为昼夜。于彼刹中。有一菩萨。名胜智愿。遇斯光已。便诣佛所。白佛言。世尊。以何因缘而有此瑞。佛言。善男子。东方去此过七十二亿那由他百千佛刹。有世界名娑婆。佛号释迦牟尼。为欲召集诸菩萨故而现斯瑞。时胜智愿闻是语已。白佛言。世尊。我等欲往娑婆世界礼觐供养释迦如来及诸菩萨。并欲听法。佛言。可往。今正是时。时胜智愿。作是念言。今我以何神变。往彼礼觐释迦如来。作是念已。即入三昧。令此三千大千世界三恶道苦悉皆消灭得无上乐。譬如比丘得诸禅定。是时一切诸天世人及以非人。不为贪恚愚痴诸见我慢忿恨怒害悭嫉憍谄覆藏之所逼恼。皆发慈心。尔时胜智愿菩萨。现神变已。与四万二千菩萨。于一念顷。从彼土没。现此界中。到如来所。头面礼足。随所来方。以愿力故。化现莲花而坐其上

尔时北方去此过六万三千佛刹。有世界名常庄严。彼现有佛号娑罗起王。其佛刹土。初未曾闻女人之称。一切皆是莲花化生。袈裟随体。时佛为彼诸菩萨众。说佛种性印法门。何等名为佛种性印。所谓最初发菩提心。从此即为具菩萨戒入菩萨藏。得陀罗尼心无散乱。不离于舍证入空性。正修无相无所愿求。性离贪染。于蕴界处而能证入。所作随觉乐求佛慧。于无生性真实了知。证于诸法而无分别。具足正见断于妄念。是故名为佛种性印。时彼众中有一菩萨。名相庄严星宿聚王。本愿殊胜。若有众生见其身者。必定当得三十二相。时彼菩萨。遇佛光明及闻其声。便诣佛所。顶礼双足。右绕三匝。白佛言。世尊。以何因缘而有此瑞。佛言。善男子。于此南方过六万三千佛刹。有世界名娑婆。佛号释迦牟尼。为欲召集诸菩萨故而现此瑞。彼菩萨言。何故名为娑婆世界。佛言。彼界堪忍贪恚愚痴及诸苦恼。是故名为娑婆世界。彼菩萨言。娑婆世界诸众生等皆能忍受恶骂捶打。诸恼乱耶。佛言。善男子。彼界众生少能成就若斯功德。而多随顺贪恚愚痴怨恨缠缚。彼菩萨言。若如是者。彼界不应名娑婆也。佛言。相庄严星宿聚王。彼佛刹土。亦有行菩萨乘诸善男子及善女人。已曾供养无量诸佛。成就忍辱。将护众生。善自调伏。若有众生以诸苦恼。而来加害悉能含忍。终不放逸贪恚愚痴。善男子。由有如此诸善丈夫。是故彼界名曰娑婆。又彼界中。亦有众生。具足众恶。少能悔过。其心粗猛而无愧耻。不敬佛。不重法。不爱僧。当堕地狱畜生饿鬼。彼释迦如来。于此下劣众生之中。悉能忍受骂辱嫌恨诽谤恼乱恶言恐胁。心如大地不可动摇无所违逆。若得供养及以不得。心无高下亦无憎爱。是故彼界名曰娑婆。尔时相庄严星宿聚王菩萨白佛言。世尊。我等今者得大善利。不生于彼弊恶下劣众生之中。佛言。善男子莫作是说。何以故。东北方有世界。名妙庄严忍。彼现有佛号大自在王。其土众生皆悉具足一向安乐。譬如比丘入于灭定。彼之安乐亦复如是。若有众生于彼佛土。亿百千岁修诸梵行。不如于此娑婆世界。一弹指顷于诸众生起慈悲心。所获功德尚多于彼。何况能于一日一夜住清净心。尔时相庄严星宿聚王菩萨白佛言。世尊。我等欲往娑婆世界。礼觐承事释迦如来及诸菩萨。并欲听法。佛言。可往。今正是时。尔时相庄严星宿聚王菩萨。即作是念。今我以何神通之力。往彼礼觐释迦如来。作是念已。于虚空中化成宝盖。覆此三千大千世界。百千万亿珠缨宝幡周匝垂布。于其盖中雨种种花。百千音乐自然而奏。复令此会比丘比丘尼。优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。各自见身具三十二相现宝盖中。尔时相庄严星宿聚王菩萨。现神变已。与十亿菩萨。于一念顷。从彼土没。现此界中。到如来所。顶礼双足。右绕三匝。随所来方。以愿力故。化现莲花。而坐其上。如是乃至遍于十方。各有无量阿僧祇佛刹中。无量阿僧祇百千亿菩萨。见大光明。闻謦欬声。问彼世尊。而来此土。顶礼佛足。各坐一面。亦复如是。又此界中。释梵护世。大威德天。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。皆见光明咸来佛所。顶礼双足。却坐一面

尔时世尊。现神变已。十方无量百千亿那由他佛刹。所有菩萨来集会者。皆见此土功德庄严并佛身量菩萨声闻及受用具。与自本刹悉皆同等。然知彼此刹无杂乱。尔时弥勒菩萨。即从座起。整理衣服。偏袒右肩。右膝着地。合掌向佛。而说颂曰

  名振十方智无量　　放大光明照世间
  一切众生共度量　　莫测人尊胜智慧
  十方无量亿菩萨　　为求法故咸来集
  而皆信乐诸法门　　愿佛演说令欢喜
  如来戒定及智慧　　名称普闻十方国
  演法无畏犹师子　　光遍虚空如日照
  一切天龙与罗刹　　及诸比丘比丘尼
  优婆塞众优婆夷　　合掌乐闻如来说
  过去未来及现在　　世尊于彼悉了知
  以胜解力拔群迷　　愿决疑惑令开晓
  云何菩萨智慧行　　严净佛刹令光洁
  云何诸愿速成满　　今请如来为宣说
  云何无悭戒无缺　　能忍骂辱诸难事
  精进修行无懈倦　　解脱无量苦众生
  专心乐入三昧门　　游止清净禅宫殿
  处世利益而无染　　譬如莲花不着水
  云何智慧出世间　　开阐甚深微妙法
  降伏一切诸魔众　　速能具足奢摩他

大宝积经卷第五十八大宝积经卷第五十九

        大唐于阗三藏实叉难陀译

    文殊师利授记会第十五之二

尔时世尊。告弥勒菩萨摩诃萨言。汝今为佛严办法座。我当升已。说往昔志乐所修诸行善巧出生诸佛刹土功德庄严趣向真实法门。尔时弥勒菩萨。即作是念。今者世尊以何义故。令我严座。不使阿难大目连等。如何弃舍彼诸声闻。将非唯为诸菩萨说。或彼声闻及辟支佛。于此法门而非器故。以是世尊令我敷座。尔时弥勒菩萨。即为如来以神通力。化作众宝师子之座。高四万由旬。周匝严丽柔软天衣以敷其上。从其座出种种光明。照此三千大千世界。尔时如来升其座已。令此世界六种震动

尔时世尊。告长老舍利弗。菩萨成就四法。能令所愿皆得满足。何等为四。一者发胜志乐。二者于诸众生起悲愍心。三者发起精进。四者承事善知识。复次舍利弗。菩萨成就一法。令愿不退严净佛刹。何谓一法。是菩萨应当乐学不动如来为菩萨时。本所修行立弘誓愿。我当所在生处初生之时。若不出家。则为欺诳十方诸佛。如是舍利弗。是诸菩萨应随顺学。若佛出世若不出世。一切生处皆悉决定舍家出家。何以故。而诸菩萨最胜利益。所谓出家。舍利弗。乐出家者。则能摄取十种功德。何等为十。一者不着诸欲。二者乐阿兰若。三者行佛所行。四者离凡夫行。五者不着妻子及以财产。六者离恶道因。七者修善趣法。八者宿世善根皆不损减。九者恒为诸天之所叹羡。十者一切鬼神恭敬守护。若菩萨常乐出家。获得如是十种功德。是故舍利弗。菩萨志求菩提。欲度众生。常当出家。是名菩萨成就一法

复次舍利弗。菩萨成就二法。令愿不退严净佛刹。何等为二。所谓菩萨不乐声闻地。不求声闻乘。不爱乐说声闻乘处。不亲近声闻乘者。不学声闻戒。不乐宣说共声闻乘相应之法。亦不劝他行声闻乘。于缘觉乘亦复如是唯为佛法劝发众生成就最上阿耨多罗三藐三菩提。是名为二。舍利弗。若有劝他趣入佛乘。此菩萨则能摄取十种功德。何等为十。一者得清净刹。无有声闻及辟支佛。二者得纯一清净诸菩萨众。三者诸佛世尊之所护念。四者常为诸佛称名赞叹而为说法。五者所发之心皆悉广大。六者若生天上。当作帝释或梵天王。七者若生人中。作转轮王。八者常见诸佛。九者为诸天人之所爱乐。十者摄取无量无边阿僧祇功德。何以故。舍利弗。若有能令三千大千世界所有众生。一切皆得阿罗汉果。或复置于缘觉之地。若复有能置一众生于佛菩提。此之功德甚多于彼。何以故。舍利弗。不由声闻缘觉出现。佛种不断。世若无佛则无声闻及辟支佛。舍利弗。以佛出现令佛种不断。亦复出生声闻缘觉。是故舍利弗。菩萨令他住佛乘中。得如是等十种功德。得清净刹。复次舍利弗。菩萨成就三法。令愿不退摄受佛刹功德庄严。何等为三。一者尊重爱乐住阿兰若。二者无所染着而行法施。三者坚固安住净戒律仪。舍利弗。菩萨坚住戒律。得十无畏。何等为十。一者入聚落无畏。二者众中说法无畏。三者饮食无畏。四者出聚落无畏。五者入寺无畏。六者大众中食无畏。七者教授无畏。八者亲近和上阿阇梨无畏。九者于自眷属慈心教诲无畏。十者受用衣服饮食卧具医药无畏。住戒律者所有言说令他信受。舍利弗。是为菩萨十种无畏。舍利弗。菩萨说法心无所著。则能摄受十种功德。何等为十。一者不生恶欲。二者不求他人识知。三者不起名闻心。四者于檀越家心不系着。五者不占护他家。六者于极下劣四事供养而生喜足。七者说法令他信受。八者善神守护。九者不生邪觉。十者起念佛心。是名为十。舍利弗。菩萨尊敬爱乐住阿兰若。成就十种功德利益。何等为十。一者远离世俗言论。二者专习闲静。三者心缘定境。四者舍诸营务。五者爱乐诸佛。六者恒受禅定喜乐。七者修梵行时无有障碍。八者少用功力而得三昧。九者所受教法未尝忘失。十者所闻法义皆悉了知。是名为十

复次舍利弗。菩萨成就四法。令愿不退严净佛刹。何等为四。一者如说能行如行能说。二者常自谦下。三者远离悭嫉。四者见他得利心生欢喜。是名为四。舍利弗。是菩萨如行能说。有四种利益。何等为四。一者口中常出青莲花香。二者语业清净言无错谬。三者一切世间所共信受。四者摄受诸佛圆满音声。是名为四。舍利弗。菩萨谦下。有四种利益。何等为四。一者远离恶趣畜生等身。二者受妙快乐。三者潜谋暴贼俱不能害。四者堪受人天恭敬礼拜。是名为四。舍利弗。菩萨远离悭嫉。有四种利益。何等为四。一者不忘施心。二者于饥馑时作大施主。三者见持戒者来承迎引纳。四者若受他施及施于他。无有一人而生嫉妒。是名为四。舍利弗。菩萨见他得利生欢喜心。有四种利益。何等为四。一者常生是心我摄众生应与利乐彼既自得故生欢喜。二者所有财物王难水火劫贼怨亲无能侵夺。三者随所生处财宝诸子皆悉具足王不嫉忌何况余人。四者蓄用资财俱无穷尽。是名为四。舍利弗。是菩萨成就四法

复次舍利弗。菩萨成就五法。令愿不退严净佛刹。何等为五。一者彼菩萨诣说法者而问之言。修何等行。能得佛刹清净庄严。若得闻已如说修行。二者菩萨清净持戒及愿力故生佛国中。生彼国已。观察彼土种种庄严众宝资具及诸声闻菩萨大众诸相微妙。于如来所恭敬尊重。白言。世尊。菩萨修何等行。得广大佛刹清净庄严。而彼如来知此菩萨志乐殊胜。即为宣说如是功德成就佛刹。彼得闻已如法修行。三者菩萨有智有行。应净其智应进其行。云何净智。谓于能缘及所缘法。远离声闻缘觉智故。云何进行。谓如所闻必定修行。离不行故。四者菩萨善知有因及知出离言。有因者谓不正思惟。是四颠倒之所依止为生死因故。言出离者谓正修行。于一切法不起分别为出离故。五者菩萨了知诸佛体性及刹土性。俱但有名名亦寂灭。如是了知不起知想。是名为五

复次舍利弗。菩萨成就六法。速得阿耨多罗三藐三菩提。亦能摄取一切世界最上佛刹。何等为六。一者此菩萨为大施主。所有珍玩可爱乐物。欢喜布施无所吝着。又作是念。我行大施圆满大乘。所谓求阿耨多罗三藐三菩提时。一切悉舍心无所著。具足成就菩提资粮。舍自身命尚不生悔。何况财产及妻子等。舍利弗。何故如来名一切智。谓行菩萨行时。于自所有一切皆舍。以是义故。得菩提已名一切智。二者若菩萨在家出家。宁舍身命终不破戒。以此持戒。共诸众生。回向阿耨多罗三藐三菩提。如是持戒自觉欢喜。乐修梵行昼夜安乐。益加求法住正修行。厌怖三界希求出离。虽见出要顾念众生。如我所苦彼亦皆然。我当荷兹重担摄取众生。置于涅槃安乐之处。如是持戒。自觉喜时获大悲心。乃至未得一切种智。不舍精进如救头然。三者菩萨被忍辱铠。离于高慢得大忍力。若遇骂辱及捶打时。忍心成就不生嗔恨。假使有棒如须弥山。有人执持。于亿劫中常见打骂。而亦不生怨恨之心。何以故。彼诸众生未随佛学。而我方将随佛修学。是故于彼所得打骂。便能增长尔所大悲。我当为诸众生被弘誓铠摄取众生。令得解脱入于涅槃。是故我今不应嗔恨。菩萨正住如是忍时。则得成就十种具足。何等为十。一者种姓。二者财产。三者眷属。四者色相。五者善舍。六者善友。七者得闻正法。八者如说修行。九者临命终时得见诸佛。十者既见佛已生净信心。是为十种功德具足。四者菩萨为欲成就善法。坚固自课发起精进。又为一一众生。尽未来际于生死中。次第修行诸精进行而不疲倦。以自课业及此大悲。为一切众生。于尔所时。流转生死不舍众生。舍利弗。若有菩萨十方各如恒沙世界。满中七宝。于念念中奉上如来。如是相续尽未来际。若有菩萨。发大悲心被精进铠。而此功德复多于彼。舍利弗。菩萨具此精进。得十种胜志乐法。何等为十。一者离凡愚行。二者摄受佛行。三者见生死过。四者住大悲心。五者不退本愿。六者少诸疾病。七者顺诸佛教。八者薄淫怒痴。九者随文了义。十者修行成就。是名为十。五者菩萨作是思惟。诸佛如来心常在定。未曾失念。我应随佛所行。若心散乱。终不能证佛所行处。是故应当舍离一切心所取着。亦舍一切利养恭敬聚落城邑饮食资生及诸亲友。为欲利益诸众生故。不舍众生。乐阿兰若住寂静处。独行无侣如犀一角。住静处已起大慈心。初遍一方渐至十方。普遍众生。慈心遍已得入禅定。舍利弗。若有在家菩萨。以一切乐具。于恒沙劫。供养一切恒沙诸佛及比丘众。若有出家菩萨。行于七步。向阿兰若寂静之处。而此福德甚多于彼。以能速得大菩提故。舍利弗。菩萨乐住寂静入禅定者。获十种功德利益。何等为十。一者得念。二者得慧。三者修行。四者迅辩。五者得陀罗尼。六者善知法生。七者善知法灭。八者戒聚无犯。九者诸天供养。十者不贪他好。是名为十。六者菩萨善知智慧等流。谓作是念。智慧以戒为首。白法增长以慧为首。是故菩萨应学智慧。世间所有难作难成。一切工巧。一切医药。皆悉遍学。而此智慧不能证入离欲寂灭。亦复不能趣向菩提。非向沙门。非婆罗门。非向涅槃。是故我今应更遍求法药工巧。以如是智。令我得彼究竟寂灭。彼菩萨求诸法本。不见少法能起于法。以不见故住于寂灭。住寂灭故则无热恼。无热恼故了知生死。为众生故而受彼生。令诸众生除灭苦故。是名为六

复次舍利弗。菩萨成就七法。令愿不退严净佛刹。何等为七。一者自舍一切而施不可得故。二者戒不缺犯不计着戒故。三者忍辱柔和而众生不可得故。四者发起精进身心不可得故。五者成就禅定不住禅故。六者智慧圆满无分别故。七者随念诸佛远离相故。是名为七

复次舍利弗。菩萨成就八法。令愿不退严净佛刹。何等为八。一者不乐涅槃。二者施庄严具。三者其心广大。四者尊敬法师。五者不行邪名。六者平等惠施。七者不自矜高。八者不凌蔑他。是名为八

复次舍利弗。菩萨成就九法。令愿不退严净佛刹。何等为九。一者具身律仪。二者具语律仪。三者具意律仪。四者灭诸贪欲。五者灭诸嗔恚。六者灭诸愚痴。七者不行欺诳。八者为坚固友。九者不轻慢善知识。是名为九

复次舍利弗。菩萨成就十法。令愿不退严净佛刹。何等为十。一者闻地狱苦。但起大悲不生怖畏。二者闻畜生苦。但起大悲不生怖畏。三者闻饿鬼苦。但起大悲不生怖畏。四者闻诸天衰恼。但起大悲不生怖畏。五者闻人中饥馑贼盗怨敌杀害。但起大悲不生怖畏。六者菩萨作如是念。我于此时当起精进。乃至未得清净佛刹终不懈慢。七者令我刹中饮食衣服随念即得。八者我佛刹中。诸众生等寿命无量。九者我佛刹中诸众生等无彼我心。十者我佛刹中。所有众生决定趣向无上菩提。是名为十

复次舍利弗。若菩萨执持妙花诣如来所。或佛塔所。兴供养时。作是愿言。如此妙花色香殊胜。见者欣悦。我成佛时。令我刹中如是种种妙花遍布。及众宝树周匝庄严。乃至末香涂香。衣服饮食。宝盖幢幡。金银琉璃。真珠等宝。用供养时。亦应如是。回向佛刹功德庄严。以彼菩萨住戒律故。随心所愿皆得成就

复次舍利弗。菩萨不求自乐喜他得乐。是故菩萨得菩提时。彼佛刹中所有众生。悉皆具足一向快乐

复次舍利弗。菩萨常应普皆摄取十善业道。悉以回向一切种智。是故菩萨得菩提时。彼佛刹中所有众生。初生即具十善业道。及出离智

复次舍利弗。菩萨随所至方劝诸众生。悉皆令趣无上菩提。唯赞佛乘。不说二乘及所共法。是故菩萨得菩提时。彼佛刹中所有众生。决定当得无上菩提。永离声闻及辟支佛。无量菩萨充满其国

复次舍利弗。菩萨于他利养终不遮断。见他得利常生欢喜。是故菩萨得菩提时。彼佛刹中所有众生。受用资具恒无断绝。具足获得大法光明

复次舍利弗。菩萨若见比丘比丘尼有过犯者。终不发扬。但自安住正法之中。是故菩萨得菩提时。彼佛刹中。一切无有过失之名。何以故。以彼大众皆得清净无过失法

复次舍利弗。菩萨乐法求法不生热恼。如所闻法正住修行。是故菩萨得菩提时。彼佛刹中众生生者。求法乐法皆无热恼。如所闻法随顺修行

复次舍利弗。菩萨弦歌鼓吹。种种音乐。供养佛塔。以此善根。回向佛刹功德庄严。是故菩萨得菩提时。彼佛刹中百千音乐不鼓自鸣

复次舍利弗。菩萨若见失念众生。令得正念。是故菩萨得菩提时。令诸弟子得禅悦食。舍利弗。如是佛刹功德。具足如来辩才。或一劫或过一劫说不能尽。舍利弗。然我今者随诸菩萨之所乐欲。如是略说。胜志乐者闻已趣向。当得圆满佛刹功德。舍利弗。菩萨成就三法。速得阿耨多罗三藐三菩提。所求佛刹皆得成就。何等为三。一者大愿殊胜。二者住不放逸。三者如所闻法起正修行。是名为三。尔时舍利弗。白佛言。世尊。如来希有善说此法。世尊住不放逸故得菩提分法。住修行故得大菩提。住胜愿故成就佛刹功德庄严

佛告舍利弗。如是如是。如汝所说。如我往昔以大愿力成就佛刹。不放逸故得成菩提。舍利弗。若但言说住于放逸而不修行。彼尚不能至声闻地。何况能得阿耨多罗三藐三菩提。是故菩萨若欲自知是真菩萨。如菩萨所学。应如是学。尔时会中四万菩萨。从座而起。合掌向佛。同声白言。如佛所说。菩萨学处。我当随学。住不放逸。修行成就。满足大愿。严净佛刹

尔时世尊。熙怡微笑。时舍利弗白佛言。世尊。以何因缘现此微笑。佛告舍利弗。汝见此诸善男子师子吼不。舍利弗言。唯然已见。佛言。舍利弗。此诸善男子。过百千劫。各于异刹。得阿耨多罗三藐三菩提。同号愿庄严。亦如当来师子佛等。其土清净如无量寿国。唯除寿量。舍利弗言。彼诸如来寿量几何。佛言。彼一一佛皆寿十劫。尔时师子勇猛雷音菩萨。即从座起。偏袒右肩。右膝着地。合掌向佛白言。是文殊师利童真菩萨。诸佛世尊常所称叹。久如当得阿耨多罗三藐三菩提。所得佛刹当复云何。佛言。善男子。汝当自问文殊师利。时师子勇猛。问文殊师利言。仁者何时当得阿耨多罗三藐三菩提。答言。善男子。何不问我趣菩提不。而乃问我成菩提耶。何以故。我于菩提尚不趣向。何况当得。问言。文殊师利。仁者岂不为利众生故。趣菩提耶答言不也。何以故。众生不可得故。若众生是有可为利益趣向菩提。而众生寿命及福伽罗皆无所有。是故我今不趣菩提。亦不退转。师子勇猛言。文殊师利。仁者趣向诸佛法不。答言不也。善男子。一切诸法皆趣向佛法。何以故。诸法无漏无系无形无相。为趣向佛。如趣向佛。诸法亦然。善男子。而汝所问趣向佛法。我今问汝随汝意答。于意云何。为色求菩提耶。为色本性求。为色如求。为色自体求。为色空求。为色离求。为色法性求菩提耶。善男子。于意云何。为色得菩提耶。乃至为色法性得菩提耶。答言不也文殊师利。色不求菩提。乃至色法性不求菩提。色不得菩提。乃至色法性亦不得菩提。文殊师利言。于意云何。受想行识求菩提。乃至识法性求菩提耶。识得菩提。乃至识法性得菩提耶。答言不也文殊师利。受想行识不求菩提。乃至识法性不求菩提。识不得菩提。乃至识法性不得菩提。文殊师利言。于意云何。离于五蕴。有我我所耶。答言不也。文殊师利言。如是如是。善男子。更以何法而求菩提及得菩提。师子勇猛言。文殊师利仁者所言众皆诚信。而今乃说不求菩提不得菩提。新发意菩萨闻此所说。必生惊怖。文殊师利言。善男子。一切诸法无有惊怖。于实际中亦无惊怖。如来为于无惊怖者而演说法。若惊怖者彼即生厌。若生厌者彼则离欲。若离欲者彼则解脱。若解脱者则无菩提。若无菩提是则无住。彼若无住是即无去。若无有去是则无来则无愿求。若无愿求则不退转。若不退转则为退转。退转何法。所谓执我众生命者及福伽罗。若断若常取相分别悉皆退转。彼若退转则不退转。不退何法。谓空无相无愿实际。及诸佛法皆不退转。何谓佛法。谓不离不着及无所缘。无入无出无有所行。亦无表示。但有其名。空无有生。无去无来。无染无净。无尘离尘。无我无分别。无和合无执取。平等无违。是为佛法。善男子。此诸佛法。非法非非法。何以故。以诸佛法无生处故。故彼新发意菩萨闻此说已。若生惊怖速得菩提。若起分别作如是念。而今我等所成菩提。随有发心住于现证。乃得菩提。若不发心终不能得。如是分别皆不生故。菩提及心俱不可得。不可得故则无分别。若无分别则无现证。何以故。现证所因不可得故。善男子。于意云何。虚空可得菩提耶。答言不也。又言。善男子。如来岂不证一切法同虚空耶。答言如是如是。又言。善男子。如虚空菩提亦尔。如菩提虚空亦然。虚空菩提无二无别。若菩萨知此平等。则无有知亦无不知亦无不见。说此法时一万四千比丘尽诸有漏心得解脱。十二那由他比丘远尘离垢于诸法中得法眼净九万六千众生发菩提心。五万二千菩萨得无生忍。尔时师子勇猛雷音菩萨。白文殊师利言。仁者发菩提心来为几时耶。文殊师利言。止善男子。莫生妄念。若有于无生法中。说如是言。我发菩提心。我行菩提行。为大邪见。善男子。我都不见有心发向菩提。以不见心及菩提故。是故无发。师子勇猛言。文殊师利。都不见心。是何句义。文殊师利言。善男子。是都不见说名平等。又问云何说为平等。答言善男子。如是平等以种种性皆无所有。彼彼诸法一味故说。一味说者。所谓离故无染无净。不断不常。不生不灭。无我无受。不取不舍。如是说法不念我说亦无分别。善男子。于此平等法中。了知修行。是名平等。复次善男子。若菩萨入此平等。都不见有种种界若一若多。于平等中不见平等。于相违中不见相违。以彼本来性清净故

尔时师子勇猛雷音菩萨白佛言。世尊。此文殊师利不肯自说发心久近。此诸大众皆乐欲闻。佛言。善男子。文殊师利是甚深忍者。于甚深忍中菩提及心皆不可得。以不可得是故不说。然善男子。我今当说文殊师利发心久近。善男子。过去久远过七十万阿僧祇恒河沙劫。有佛名雷音如来应正等觉。出现于世。在于东方。去此过七十二那由他佛刹。有世界名无生。彼雷音如来于中说法。诸声闻众。有八十四亿那由他。诸菩萨众二倍过前。善男子。彼时有王名曰普覆。七宝具足王四天下。正法理化为法轮王。而于八万四千岁中。以衣服饮食宫殿台观僮仆给侍一一殊妙。恭敬供养雷音如来及诸菩萨声闻大众。其王亲族中宫婇女王子大臣。唯务供养余无所作。虽经多岁初无疲倦。过是已后。其王独在静处思惟。我今已集广大善根。而犹未定所回向处。为求帝释大梵天王转轮王耶。为求声闻辟支佛耶。作是念已。空中诸天告言。大王勿起如是狭劣之心。何以故。王之所集福德甚多。当发阿耨多罗三藐三菩提心。善男子。时普覆王。闻是语已。欢喜念言。我今于此决定不退。何以故。天知我心而来告我。善男子。尔时彼王。与诸大众八十亿那由他百千众生。往诣雷音佛所。顶礼双足。右绕七匝。曲躬恭敬。合掌向佛。而说颂曰

  我今问最胜　　愿当为我说
  云何得成就　　最上人中尊
  世间所依止　　我已广供养
  以不决定心　　未知回向处
  已修广大福　　当何所回向
  为求梵天位　　帝释转轮王
  为求于声闻　　及以辟支佛
  我发此念时　　空中天告我
  大王汝勿起　　狭劣回向心
  为一切众生　　当兴广大愿
  利益世间故　　应发菩提心
  我今请世尊　　于法自在者
  愿说菩提心　　发起之方便
  发菩提心已　　当得如牟尼
  唯愿两足尊　　为我具宣说

尔时雷音如来。为普覆王。而说颂曰

  大王汝谛听　　我当次第说
  一切因缘法　　随根欲所行
  如其所有愿　　得如是果报
  我亦于往昔　　发起菩提心
  为诸众生故　　愿当作利益
  如我所作愿　　如昔所发心
  得不退菩提　　意愿速圆满
  大王应坚固　　修习于诸行
  汝当得广大　　无上佛菩提

时普覆王。闻佛所说。欢喜踊跃。得未曾有于众会前。大师子吼。而说颂曰

  今对一切众　　发大菩提心
  为一一众生　　誓尽未来际
  受无量生死　　而作大饶益
  备修菩萨行　　救诸众生苦
  从今若违誓　　起于贪欲心
  及悭嫉怨恨　　则诳十方佛
  又我从今日　　乃至成菩提
  常当学诸佛　　修行于梵行
  随顺净戒律　　远离诸过咎
  又我于菩提　　亦不愿速证
  当尽未来际　　广利诸群生
  严净诸佛刹　　无量不思议
  当令我名号　　普闻十方界
  我今自授记　　决定当成佛
  志乐胜清净　　于此固无疑
  我当净三业　　不令起诸恶
  我以此真实　　成佛人中尊
  若此心真实　　地当六种动
  若我语诚谛　　无有虚妄者
  当使虚空中　　音乐自然奏
  若我无谄曲　　及以怨恨心
  由此真实故　　当雨曼陀花

时普覆王。说此颂已。心诚实故。十方亿刹六种震动。于虚空中奏诸音乐。雨曼陀罗花。时二十亿众生随从王者。皆大欢喜而自庆言。我等当得最上菩提。即学彼王发菩提心。佛告大众。尔时普覆王者。岂异人乎。今文殊师利菩萨是也。彼于往昔过七十万阿僧祇恒河沙劫。初发菩提之心。次过六十四恒河沙劫。得无生法忍。能具足菩萨十地如来十力。佛地诸法悉皆圆满。而未曾起一念之心。我当得佛。善男子。尔时二十亿众生随逐彼王。于雷音佛所发菩提心者。皆由文殊师利劝发。令入布施持戒忍辱精进禅定智慧。今并证得阿耨多罗三藐三菩提。转大法轮。作佛事已。而般涅槃。文殊师利。皆悉供养彼诸如来。亦皆护持彼诸佛法。唯有一佛号地持山。在此下方过四十恒河沙刹土。其佛世界名曰地持。亦有无数诸声闻众。佛寿无量于今现在。说此文殊师利宿缘之时。众中七千众生。发阿耨多罗三藐三菩提心

大宝积经卷第五十九大宝积经卷第六十

        大唐于阗三藏实叉难陀译

    文殊师利授记会第十五之三

尔时师子勇猛雷音菩萨。白文殊师利言。仁者已满足十地及如来十力。一切佛法悉皆圆满。何故不成阿耨多罗三藐三菩提。文殊师利言。善男子。无有圆满诸佛法已更证菩提。何以故。已圆满故不应更证。师子勇猛言。云何圆满诸佛法耶。答言佛法圆满如真如圆满。真如圆满如虚空圆满。如是佛法真如虚空亦无有二。善男子。如汝所言。云何圆满诸佛法者。如色圆满乃至识圆满。佛法圆满亦复如是。师子勇猛言。何者是色等圆满。文殊师利言。善男子。于意云何。汝所见色是常耶。是无常耶。答言不也。文殊师利言。善男子。若法非常非无常。彼有增减耶。答言不也。文殊师利言。善男子。若法不增不减是名圆满。云何圆满。若于诸法不能了知则生分别。若能了知则无分别。若无分别则无增减。若无增减此则平等。是故善男子。若见色平等即是色圆满。受想行识及一切法圆满亦复如是

尔时师子勇猛雷音菩萨。白文殊师利言。仁者得法忍来。无一念心愿成正觉。而今何故乃劝余人令向菩提。文殊师利言。我实不曾劝一众生令趣菩提。何以故。众生无所有故。众生性自离故。若众生可得则令向菩提。既不可得故无所劝。何以故。平等无分别故。非以平等而求平等。亦无所起。是故常说。应观诸行。来无所从去无所至。是名平等。则是性空。于性空中而无所求。善男子。如汝问我得忍已来。无一念心当得菩提者。善男子。汝见彼心耶。而以此心得菩提耶。师子勇猛言。不也文殊师利。何以故。以心非色不可见故。菩提亦尔但是名想。若心名。若菩提名。皆无所有。文殊师利言。善男子。如汝说我不生一念得菩提者。是密意说。何以故。以心本来无有生故。是故无生。既无有生。何得何证。师子勇猛问言。云何名为平等证入答言。于诸法中无系著者名平等证。言证入者。彼微细智亦不生灭。与真如无异。无可分别。是名证入。若正见修行者于平等中无一法可得。离种种性亦不着一。是名证入。若以身证诸法无相明了彼相所谓无相。而于身心亦不执着。是则名为圆满证入。师子勇猛问言。云何名得。文殊师利言。善男子。以世间言说名之为得。诸圣所得非言能说。何以故。法无依止离言说故。复次善男子。以无得为得。亦非得非不得。说名为得

尔时师子勇猛雷音菩萨白佛言。世尊。善哉愿说文殊师利所得佛刹。佛言。善男子。汝当自问文殊师利。时彼菩萨白文殊言。仁者当得何等佛刹功德庄严。文殊师利言。善男子。若我求菩提。汝可问其所得佛刹。师子勇猛言。仁者岂不求菩提耶。文殊师利言。不也。何以故。若有所求则有染着。若有所染则有贪爱。若有所爱彼则有生。彼若有生是则有爱。若有所爱终不于中而有出离。善男子。我为是故不求菩提。何以故。菩提不可得故。以不可得是故不求。善男子。然汝问我何等佛刹。仁当得者。我不能说。何以故。对于如来一切智者。说自佛刹功德庄严。即为菩萨自赞己德。佛告文殊师利。汝可自说。以何等愿庄严佛刹。令诸菩萨闻已。决定成满此愿。时文殊师利受如来教。即从座起。偏袒右肩。右膝着地。合掌白佛言。世尊。我今承佛神力当为宣说。诸有欲求大菩提者皆应谛听。若闻此愿当如实学令得圆满。文殊师利。当以右膝着地之时。十方各恒河沙等诸佛刹土六种震动。时文殊师利复白佛言。我从往昔百千亿那由他阿僧祇劫已来。起如是愿。我以无碍天眼。所见十方无量无边诸佛刹中一切如来。若非是我劝发决定菩提之心教授教诫。令修布施持戒忍辱精进禅定智慧。乃至令得阿耨多罗三藐三菩提。我于菩提终不应证。而我要当满此所愿。然后乃证无上菩提。时彼众中诸菩萨等咸作是念。文殊师利无碍天眼见几如来。是时世尊知诸菩萨心之所念。即告师子勇猛雷音菩萨言。善男子。譬如以此三千大千世界碎为微尘。于意云何。此诸微尘。可以算计知其数不。答言不也世尊。佛言善男子。文殊师利无碍天眼。见于东方无量诸佛复过是数。南西北方四维上下亦复如是。时文殊师利白佛言。世尊。我有是愿以恒河沙等诸佛世界。为一佛刹。无量妙宝间错庄严。若不尔者我终不证无上菩提。复次世尊。我复有愿。令我刹中有菩提树。其量正等十大千界。彼树光明遍此佛刹。复次世尊。我复有愿。我坐菩提树已。证得阿耨多罗三藐三菩提乃至涅槃。于其中间不起此座。但以变化遍于十方无量无数诸佛刹土。为诸众生而演说法。复次世尊。我复有愿。令我刹中无女人名。纯菩萨众离烦恼垢具净梵行。初生之时袈裟随体结加趺坐忽然而现。如是菩萨遍满其刹。无有声闻辟支佛名。唯除如来之所变化。往诣十方。为诸众生说三乘法。尔时师子勇猛雷音菩萨白佛言。世尊。文殊师利。当来成佛名为何等。佛言善男子。此文殊师利成佛之时名为普见。以何义故而名普见。以彼如来于十方无量百千亿那由他诸佛刹中普皆令见。若诸众生见彼佛者。必定当得阿耨多罗三藐三菩提。普见如来虽未成佛。若我现在及灭度后有闻其名。亦皆必定当得阿耨多罗三藐三菩提。唯除已入离生之位及狭劣心者。文殊师利又白佛言。世尊。我复有愿。如阿弥陀佛刹以法喜为食。而我刹中菩萨初生起食念时。即便百味盈满于钵在右手中。寻作是念。若未供养十方诸佛。及施贫穷苦恼众生。饿鬼等类令其饱足。而我决定不应自食作此念时。得五神通乘空无碍。往于十方无量无数诸佛刹中。以食供养诸佛如来及声闻众。又于贫苦诸众生类亦皆周给。复为说法令离渴爱。于一念顷还至本处。复次世尊。我复有愿。于我刹中诸菩萨等。初生之时所须衣服。于其手中。随意皆出种种衣宝。鲜洁称体应沙门服。便作是念。若未供养十方诸佛。不应自用。于一念中。往诣十方无量佛刹。以此衣宝献诸佛已。还至本处方自受用。复次世尊。我复有愿。我佛刹中诸菩萨众。所得财宝及诸资具。要先分施诸佛声闻。遍供养已然后受用。又我刹中。远离八难及不善法。既无过咎亦无禁戒。无有苦恼诸不悦意。时师子勇猛白佛言。世尊。而彼佛刹。名为何等。佛言。彼刹名随愿积集清净圆满。师子勇猛言。世尊。彼佛世界在何方所。佛言。在于南方。此娑婆世界。亦当在彼佛刹之中。文殊师利。又白佛言。我复有愿。我佛刹中。积集无量妙宝所成。复以无量摩尼妙宝。间错庄严。其摩尼宝。于十方界。所未曾有甚为难得。如是宝名俱胝岁中说不能尽。随诸菩萨乐见彼刹金为体者。即见为金。乐见银体即见为银。然于见金未曾损减。乐见颇梨琉璃马瑙赤真珠等无量诸宝。各随所见皆不相碍。如是栴檀香体。阿伽罗香。乃至赤栴檀等。各随乐见亦复如是。又彼刹中。不以日月摩尼星火等光之所照见。彼诸菩萨皆以自身光明。照于千亿那由他刹。又彼刹中。以花开为昼。花合为夜。随诸菩萨所乐时节即皆应之。然无寒暑及老病死。若诸菩萨随其所乐。欲证菩提即往余刹。于兜率天寿尽降生而证菩提。此佛刹中无有涅槃。百千种乐。于虚空中。虽不现相。而闻其音。此乐不出顺贪爱声。但出诸波罗蜜佛法僧声。及菩萨藏法门之声。随诸菩萨所解妙法。皆悉得闻。又诸菩萨。若欲见佛随所诣处经行坐立。应念即睹普见如来坐菩提树。若诸菩萨于法有疑。但见彼佛不待解释。疑网皆断解了法义。尔时会中无量百千亿那由他诸菩萨众。同声说言。若有得闻普见佛名。彼人便得最上善利。何况生于彼佛土者。若有得闻此文殊师利授记法门。及闻文殊师利名者。是则名为面见诸佛。是时佛告诸菩萨言。如是如是。如汝所说。善男子。若有受持百千亿诸佛名号。若复有称文殊师利菩萨名者。福多于彼。何况称于普见佛名。何以故。彼百千亿那由他佛利益众生。不及文殊师利于一劫中所作饶益。尔时众中无量百千亿那由他。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。同声唱言。南无文殊师利童真菩萨。南无普见如来应正等觉。说此语已。八万四千亿那由他众生。发阿耨多罗三藐三菩提心。无量众生善根成熟。于三乘中得不退转。文殊师利。又白佛言。我复有愿。如我所见无量无数百千亿那由他诸佛世尊。而彼诸佛所有佛刹功德庄严。如是一切皆令置我一佛刹中。唯除二乘及五浊等。世尊。若我自说佛刹功德种种庄严。过恒沙劫亦不能尽。如我所愿。唯佛能知。佛言。如是文殊师利。如来知见于三世中无有限碍。尔时众中有诸菩萨。作如是念。文殊师利所得佛刹功德庄严。与阿弥陀佛刹。为等不耶。尔时世尊。知彼菩萨心之所念。即告师子勇猛言。善男子。譬如有人析一毛为百分。以一分毛于大海中取一滴水。此一滴水喻阿弥陀佛刹庄严。彼大海水喻普见如来佛刹庄严。复过于此。何以故。普见如来佛刹庄严不思议故。尔时师子勇猛白佛言。世尊。如是等类佛刹庄严。于三世佛刹颇更有不。佛言有。善男子。东方去此。过百亿恒河沙世界。有佛刹名住最上愿。彼中有佛。名普光常多功德海王。彼佛寿命无量无边。常为菩萨而演说法。善男子。彼佛刹土功德庄严。与普见佛刹等无有异。善男子。有四菩萨。被不思议弘誓之铠。而于此愿决定成满。亦当得此佛刹庄严如普见如来。时师子勇猛言。愿佛说彼菩萨名号及其住处。复愿示彼普光常多功德海王如来佛刹。令此大众多所利益。何以故。此诸菩萨若见闻已。于此所愿当得成满。佛言。善男子。汝等谛听当为汝说。善男子。彼一菩萨名光明幢。在于东方无忧德佛刹。次名智上。在于南方智王如来佛刹。次名诸根寂静。在于西方慧积如来佛刹。次名愿慧。在于北方那罗延如来佛刹。尔时世尊。以神通力。现普光常多功德海王如来佛刹。令此大会见彼如来及菩萨众。并其佛刹功德庄严。昔所未见。亦未曾闻。而彼一切皆不思议。无量百千亿那由他宝间错庄严。于一劫中说彼功德亦不能尽。众皆明见如观掌中庵摩勒果。彼菩萨身长四万二千由旬。佛身长八万四千由旬。光明洞照如阎浮檀金山。成就广大功德庄严。坐大菩提树下。诸菩萨众恭敬围绕。现百千亿诸变化事。往诣十方诸世界中。为诸众生而演说法。是时佛告诸菩萨言。善男子。汝等见彼如来佛刹庄严菩萨众耶。时诸大众同声白言。唯然已见。我等当学此菩萨行。如文殊师利之所修行。我等亦当成就如此庄严佛刹。尔时世尊。熙怡微笑。从其面门。放种种色光。照于无量无边世界。照已还来。绕佛三匝。从其顶入。尔时弥勒菩萨白佛言。世尊。以何因缘。现此微笑。佛告弥勒。此大众中八万四千菩萨。见彼佛刹庄严之事。虽皆发心当欲成就如是佛刹。然于其中。有十六善大丈夫。具胜志乐而发大心。彼能成满。如文殊师利所起大愿。余诸菩萨亦速当得阿耨多罗三藐三菩提。所得佛刹功德庄严。如阿弥陀佛刹。弥勒当知。诸菩萨等。志乐既胜。所成亦大。志乐胜者。言我成就如文殊师利庄严佛土。其余劣者。虽以信心亦作是语。以此语业。犹能弃舍六十亿百千那由他劫生死流转。亦得圆满五波罗蜜。尔时弥勒菩萨。见于四方光明幢等四大菩萨。各坐琉璃光明楼阁。有百千亿诸天围绕雨花奏乐现大神变。震动大地而来于此。时弥勒菩萨即白世尊。请问其事。佛言。善男子。此四菩萨为见我故。四方如来各令至此。时彼菩萨既到佛所。顶礼佛足右绕三匝。退坐一面。彼四菩萨光明遍照此之大会。尔时世尊告诸菩萨言。善男子。此四善大丈夫志愿所趣。皆不思议。应当尊重请其法要。而彼所愿。于诸菩萨最为殊胜。若有善男子。善女人得见之者。必定当得阿耨多罗三藐三菩提。弃舍二十亿劫生死流转。具足圆满五波罗蜜。若有女人闻此菩萨名者。速得舍离女人之身。于是世尊即摄神力。而彼佛刹忽然不现。文殊师利白佛言。世尊。一切诸法皆悉如幻。何以故。譬如幻师幻为隐现。诸法生灭亦复如是。而此生灭即无生灭。以无生灭是则平等。菩萨修此平等。便能证得无上菩提。智上菩萨白文殊师利言。于此菩提云何证得。文殊师利言。此菩提者非是可得。亦非可坏非可住着。智上白言。而此菩提非以住得。非不住得。何以故。以彼法性本来无生。非曾有。非当有。亦非可坏。是故无得。文殊师利谓智上等诸菩萨曰。云何名为说一相法门

弥勒菩萨曰。若有不见蕴界处。亦非不见。无所分别。亦不见集散。是名说一相法门

师子勇猛雷音菩萨曰。若不作种种分别此是凡夫法。此是二乘法。此则不违法性。入于一相。所谓无相。是名说一相法门

乐见菩萨曰。若有修真如行。而亦不作真如之想。于此甚深无所分别。是名说一相法门

无碍辩菩萨曰。若能究竟尽于诸法。亦以此法为他演说。是名说一相法门

善思菩萨曰。若以思议入不思议。此不思议亦不可得。是名说一相法门

妙离尘菩萨曰。若有不染一切相。亦非染非不染。无违无顺。亦无迷惑。非一非二亦非种种。不取不舍是名说一相法门

娑竭罗菩萨曰。若有能入如海难入甚深之法。而于此法亦不分别。虽为他说而无说想。是名说一相法门

月上菩萨曰。若于一切众生。心行平等。犹如满月。无众生想。是名说一相法门

离忧闇菩萨曰。云何拔众生忧箭。谓我我所。是彼忧根。若能住我我所平等。是名说一相法门

无所缘菩萨曰。若不攀缘欲界色界无色界声闻法缘觉法及诸佛法。是名说一相法门

普见菩萨曰。若说法时应说平等法。谓空法平等。亦无空想及平等想。是名说一相法门

净三轮菩萨曰。若说法时应净三轮。谓所为众生我不可得。亦不分别自为法师。于所说法而无住着。如是说法是名说一相法门

成就行菩萨曰。若有能说于一切法修平等行。所知如实非文字说。以一切法离言说故。是名说一相法门

深行菩萨曰。若有能说了达一切甚深之法。亦不见彼能说所说及与所为。是名说一相法门

如是无量诸菩萨等。各以辩才演说一相法门。说此法门时。三十七亿菩萨。得无生法忍。八万四千那由他百千众生。发阿耨多罗三藐三菩提心。七千比丘。不受诸法尽诸有漏心得解脱。九十六那由他诸天及人。于诸法中得法眼净

尔时师子勇猛雷音菩萨白佛言。世尊。此文殊师利。久如当得阿耨多罗三藐三菩提。彼佛寿命及菩萨众其数几何。佛言。善男子。汝当自问文殊师利。时师子勇猛白文殊师利言。仁者。久如当得菩提。文殊师利言。善男子。若虚空界为色身时。我乃当得无上菩提。若幻人得菩提。我乃当得。若漏尽阿罗汉即是菩提。我乃当得。若梦响光影及以化人得菩提时。我乃当得。若月照为昼。日照为夜。我乃当得阿耨多罗三藐三菩提。善男子。汝之所问应当问彼求菩提者。师子勇猛言。仁者。岂不求菩提耶。答言不也。何以故。文殊师利即是菩提。菩提即是文殊师利。所以者何。文殊师利但有名。菩提亦但有名。此名亦离无作故空。而彼空性即是菩提。尔时佛告师子勇猛言。汝颇见闻阿弥陀如来声闻菩萨诸众会耶。唯然闻见。佛言。其数几何。答言。非算数思议之所能及。佛言。善男子。如摩竭国量一斛油麻。举取一粒。喻阿弥陀佛国声闻菩萨。余不举者。喻文殊师利得菩提时菩萨众会。复过是数。善男子。如以三千大千世界微尘数劫。比普见如来寿量劫数。百分千分百千亿分乃至算数譬喻所不能及。应知彼普见如来寿命。无有算数亦无限量。如有一人以三千大千世界。碎为微尘。第二第三人亦碎大千世界以为微尘。复有一人。取彼微尘从此东行过尔所微尘数世界。乃下一尘。又过尔所微尘数世界。复下一尘。如是次第尽诸微尘。复有第二人。亦持尔所微尘。从此南行如前下尘。次第展转乃至尘尽。西方北方。四维上下各有一人。所下尘数亦复如是。善男子。是诸世界可知数不。答言不也。佛言。善男子。如是诸人。于彼十方所经世界。若着微尘及不著者。尽末为尘。于意云何。是诸微尘可以算计知其数不。答言。不也世尊。若有计量心则迷乱不能了知。佛言。善男子。诸佛如来悉能了知彼微尘数。设过于此如来亦知。时弥勒菩萨白佛言。世尊。诸菩萨等为求如是大智慧故。于大地狱。无量亿劫。受诸极苦。终不应舍如是大智。佛言。弥勒如是如是。如汝所说。何有于此大智慧中不生欲乐。唯除下劣及懈怠者。说此智时。一万众生发菩提心。是时佛告师子勇猛言。善男子。于意云何。如彼十人经十方界尽为微尘。文殊师利当于尔所微尘数劫。行菩萨道。何以故。文殊师利大愿不可思议。趣向亦不可思议。得菩提已寿量亦不可思议。菩萨众会亦不可思议。尔时师子勇猛白佛言。世尊。文殊师利发趣甚大。所修之行亦复广大。乃于尔所微尘数劫。不生疲倦文殊师利言。如是如是。善男子。如汝所说。于意云何。虚空界有如是念。度于昼夜时节岁月劫数等耶。答言不也。文殊师利言。如是善男子。若有觉一切法等于虚空。彼微细智无有分别。亦无是念。度于昼夜时节岁月诸劫数等。何以故。彼于诸法无想念故。善男子。如虚空界无有疲倦及热恼想。何以故。设过恒河沙劫。而虚空界亦无生起。亦无烧灭。非可破坏。何以故。以虚空界无所有故。如是善男子。若菩萨了一切法无所有已。亦无热恼及疲倦等。善男子。彼虚空名亦无烧灭热恼疲倦。亦不动摇。不生不老。不来不去。文殊师利名号亦尔。无有热恼及疲倦等。何以故。名字性离故。说此法时。四大天王。释提桓因。梵天王等。及余大威德诸天子等。同声唱言。是诸众生闻此法门获大善利。何况受持读诵。当知彼等所成善根极为广大。世尊。我等于此法门。受持读诵广宣流布。为欲护持此深法故。尔时师子勇猛白佛言。世尊。若有得闻如此法门。受持读诵思惟。及发如此功德庄严佛刹之心。得几所福。佛言。善男子。如来以无碍佛眼。所见诸佛及彼刹土。若有菩萨以妙七宝满彼诸刹。奉施供养一一如来。各尽未来际。令此菩萨安住净戒。于一切众生得平等心。若有菩萨。于此庄严功德佛刹法门。受持读诵复能发心。随文殊师利所学。行于七步。此二功德比前七宝布施功德。百分不及一。乃至算数譬喻所不能及。尔时弥勒菩萨白佛言。世尊。当何名此法门。我等云何奉持。佛言。此法门名为诸佛游戏。亦名诸愿究竟。亦名文殊师利功德庄严佛土。亦名令发菩提心菩萨欢喜。亦名文殊师利授记。如是受持。尔时十方诸来菩萨。为欲供养此法门故。而雨众花赞言。希有世尊。希有世尊。我等乃得闻是不思议文殊师利师子吼庄严法门。时诸菩萨说是语已。各还本土。说此法时。恒河沙等菩萨得不退转。无量众生善根成熟。尔时文殊师利。即入菩萨出生光明普照如幻三昧。入三昧已。令此众会普见十方无量无边诸佛刹中一切如来。一一佛前皆有文殊师利说自佛刹功德庄严。众会见已。于文殊师利殊胜大愿。生希有心。佛说是经已。彼一切菩萨。及诸比丘比丘尼。优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第六十大宝积经卷第六十一

        北齐三藏那连提耶舍译

    菩萨见实会第十六

    序品第一

如是我闻。一时佛在迦毗罗国尼居陀林。与大比丘众千二百五十人俱。其名曰优楼毗螺迦叶。伽耶迦叶。那提迦叶。摩诃迦叶。舍利弗大目犍连。一切皆是大阿罗汉。诸漏已尽。无复烦恼。其心自在。心善解脱。慧善解脱。如大龙象。所作已办。皆弃重担。逮得己利。尽诸有结。于正教中心得善解。于一切法心无所碍。到于彼岸自得解脱。解脱眷属自得调伏。调伏眷属自得寂定。寂定眷属自得度脱。度脱眷属已到彼岸。彼岸眷属已到陆地。陆地眷属自得安隐。安隐眷属自得寂灭。寂灭眷属自破烦恼。破烦恼眷属自得沙门。沙门眷属自得息恶。息恶眷属自婆罗门。婆罗门眷属自除恶法。除恶法眷属自了知诸法。了知诸法眷属自能得度。能度眷属自具诸德。具诸德眷属自无烦恼。无烦恼眷属自离五支。离五支眷属自得离障。离障眷属自得静意。静意眷属自具六通。具六通眷属自离憎爱解脱。离憎爱解脱眷属自守护一心。守护一心眷属自念门具足。念门具足眷属自依四依。四依眷属自离种种诸见。离种种诸见眷属自弃诸希望。弃诸希望眷属自得尽行。尽行眷属自得事讫。事讫眷属自修。自修眷属自无浊念。无浊念眷属自断有觉。断有觉眷属自倚身行。倚身行眷属自得乐不动。乐不动眷属自心善解脱心善解脱眷属自慧善解脱。慧善解脱眷属自得贤圣。贤圣眷属如是等比。得离枝叶除去皮肤。唯有心实坚固而住。尔时世尊于其后夜露地而坐。时比丘众四面围绕。尔时世尊默然而住。观比丘众告诸比丘。汝等诸人访觅一人堪能往化净饭王者。尔时慧命阿若憍陈如。即从坐起。偏袒右肩。右膝着地。合掌向佛。即便作礼。白佛言。世尊。我当往化净饭王耶。佛言。汝止憍陈如。汝今具足大师之德。不应往彼。时有慧命婆涩摸及大名耶输陀。优楼毗螺迦叶。摩诃迦叶。舍利弗。大目连等。各白佛言。世尊。我等堪能往化净饭王也。佛告摩诃目连。汝等且止。汝等皆悉具足大师尊重之法。不应往化。尔时大德摩诃目连。即作是念。世尊今者欲令谁往化净饭王耶。尔时目连即入如实三昧。以三昧力庄严其心。即得见佛意之所念。在于慧命迦卢陀夷。欲令往化净饭王耳。譬如重阁楼窗之中。日从东入光照西壁。如是目连见世尊心。专在迦卢陀夷欲令化王。亦复如是。尔时慧命目连即从定起。往迦卢陀夷所。到已白言。世尊心念知汝堪能往化净饭王。迦卢陀夷。汝今应当发大勇猛速往化王。目连作是语已。时慧命迦卢陀夷。白目连言。凡庶难化何况国王。何以故。刹利种姓灌顶大王。有自在力难可化故。大目连。譬如聚积众柴若二若三乃至千载如此柴聚经多年岁甚大干燥。于时有人。放火烧之。成大火聚。于意云何。此之火聚。宁为大不。目连言甚大。若复有人更以无量苏油溉灌此火增盛不。大目连言。转炽倍盛。于意云何。此火可近不。目连言难可得近。如是大目连。刹利种姓灌顶大王。难可教化不可得近。亦复如是。大目连。譬如狂象之牙可触以不。目连言不可触也。如是大目连。灌顶刹利难可教化亦复如是。时慧命目连。复白优陀夷言。世尊。心念知汝堪能往化净饭王也。优陀夷复白目连言。世尊。实垂顾念。谓我堪能往化净饭王耶。目连答言。世尊。实诚念汝。谓汝堪能教化父王。尔时世尊。自告优陀夷言。优陀夷。汝可入城教化父王。何以故。唯我与汝堪能教化净饭王耳。优陀夷。我诸声闻弟子之中。汝能教化诸邑聚落最为第一。尔时世尊。即以偈颂。告优陀夷言

  谛听优陀夷　　汝能善教导
  必令释种喜　　往化最胜王
  王今受悟时　　兼利诸天人
  必得到彼岸　　汝当速往化
  释种净饭王　　今怀恨乱浊
  住念惠不行　　犹如坠高崖
  恋惜子高位　　慧心尽迷没
  如商失重宝　　追念生大苦
  如天坠宫殿　　追恋五欲乐
  未知佛正法　　悲哀大恼乱
  自念失七宝　　及与人四道
  忆此圣王位　　口出非法言
  王时悲乱言　　不觉己及他
  如夺精魂鬼　　执持于人身
  犹在鸡罗山　　一切无所见
  如是恼恨障　　应见不复睹
  亦如睡眠死　　己心不自了
  忧恨迷惑障　　王不识自喜
  如妇夫婿亡　　悲泪生忧悔
  王今痴恼乱　　哀恋生大苦
  汝具巧方便　　往化净饭王
  摧倒邪慢憧　　当建正法灯
  更无有能化　　净饭大王者
  唯汝优陀夷　　过去曾同行
  优陀夷当知　　曾有大国王
  名曰增长实　　声名震十方
  如法作国主　　一切皆归化
  能以正法治　　王领四天下
  城邑悉满中　　花果香园苑
  多诸贤圣众　　无有杂恶人
  芳林甚稠密　　地净无棘刺
  多饶净妙等　　花池庄严好
  人民广殷盛　　弃恶常善住
  闭诸恶趣门　　必升妙天道
  彼王昔有子　　曾广供养佛
  备修诸善根　　具足诸功德
  名曰妙坚惠　　亿众所供养
  常见色欲过　　弃家乐闲静
  父王敕子言　　汝可受五欲
  婇女自娱乐　　游观宝宫池
  我今为汝办　　玩弄无乏少
  云何不爱乐　　汝当说其意
  知诸趣善妙　　汝爱宝宅中
  女宝常围绕　　妙境甚可乐
  诸仙处闲林　　犹舍退还家
  受诸色欲乐　　况汝无乏少
  婇女众围绕　　王臣皆随从
  台馆若天宫　　应受五欲乐
  诸女甚端正　　美丽若天人
  善奏歌舞乐　　可以自娱意
  目如优波叶　　唇赤若含丹
  面满广黛眉　　平额姝咽颈
  膺平缺骨满　　臂如象王鼻
  掌如莲花色　　指圆佣纤好
  舌薄广红赤　　美言若甘露
  齿素利齐密　　珠璎宝衣服
  脐深腹不现　　脊如金刚杵
  髀股佣圆直　　伊尼鹿王[跳-兆+專]
  行步如鹅王　　皆各瞻视汝
  盛年甚可爱　　堪能存后嗣
  汝及众丽人　　犹如春花开
  盛年色未退　　应当速受乐
  坚慧白父王　　王言非正理
  若有如法语　　所敕不敢违
  王听我今说　　乐善真实语
  乃至于梦中　　不起淫欲想
  父王今此言　　智者所不许
  愚者乐此事　　明人常所厌
  何故明目人　　而羡盲瞽导
  岂有岸上人　　反乐沉溺者
  何有解脱人　　而复乐牢狱
  岂有安乐人　　钦羡众苦者
  我意观父王　　如盲溺狱者
  如梦受五欲　　复为欲所溺
  父王如盲冥　　我目见殊胜
  王为欲所漂　　我今甚厌贱
  欲如毒药器　　亦如毒蛇头
  如利刀剑槊　　亦如大猛火
  王臣劝化时　　坚慧悉不许
  捐亲及国土　　弃欲而出家
  如蛇脱故皮　　亦如弃涕唾
  远离于过恶　　绝望永出家
  坚慧舍俗时　　臣子随出家
  其人名月施　　弃欲随坚慧
  童子出家已　　并及大臣子
  成就四梵住　　具足五神通
  深见五尘过　　超绝于欲界
  转正妙法轮　　直生梵天上
  童子出家已　　父王起嫌恨
  月施诣王所　　善化令王喜
  优陀夷当知　　昔时坚慧者
  远离于五欲　　今即我身是
  优陀夷当知　　彼时增实王
  岂为异人乎　　净饭王是也
  优陀夷当知　　随我出家者
  月施汝身是　　亦曾化增实
  是故优陀夷　　今应化父王
  必有大利益　　昔曾教化故

尔时慧命优陀夷受佛教已。默然许可。时优陀夷。过夜晓已至于食时。着衣持钵入迦毗城。时有释种一千余人。集在王门皆有所须。时净饭王。闻佛如来到迦毗城在尼居林。起嫌恨意。此儿出家退我种族。富贵大乐如其在家。应绍金轮王四天下如法统领。民无逆命七宝具足。其七者何。一曰轮宝二曰象宝。三曰马宝。四曰摩尼宝。五称女宝。六曰主藏臣宝。七称导师宝。具足千子。勇健难当。颜容美妙。能摧强敌。护四天下。不以刀杖料理国土。如法治正自然泰平。我得轮王自在快乐。彼应尊重供养于我。以儿出家故所应得者悉皆坠落。作是念已敕诸释种。一切不得至我儿所敬信听法。若有犯者当斩其首。时有释种名曰喜面。不在众中不闻王教。见优陀夷即往其所。稽首白言。善来尊者得平安耶。世尊安乐少病少恼起居轻利。在路不疲供馔不乏也。时优陀夷报喜面言。如来安乐少病少恼起居轻利。在路不疲饮食无乏。时有释种名曰善觉。见喜面共优陀夷在屏处语。亦诣其所。白言大德。自远而来比康吉耶。世尊起居安乐少病少恼。在路不疲供馔无乏耶。优陀夷答言。如来圣御安乐。在路不疲无所乏少。尔时复有二释种。一名无忧。二名离忧。见喜面善觉共优陀夷在于屏处。亦复弃众往诣其所。白优陀夷言。善来至此气力好耶。世尊起居安乐耶。远涉途路得无疲耶。优陀夷报言。如来圣御安乐涉路不疲。时二释种重白言。如来途路何故无乏也。优陀夷报言。以四天王及天帝释诸梵天王常来供养故无所乏。时诸释种俱白优陀夷言。我等今欲诣佛至世尊所供养听法。恐不获遂。何以故。净饭大王向有敕旨敕诸释种。悉皆不听至佛所供养听法。如有犯者当斩其首。虑王宪故不得礼拜供养听受正法。时优陀夷闻此语已。知其父王有大怨恨。我今作何方便至王所也。作是念已。我当举高七多罗树。于虚空中结加趺坐至于王所。尔时慧命优陀夷。即入如实三昧。以其三昧庄严其心。复以神力。举高七多罗树。于虚空中加趺而坐。飞空往诣净饭王所。时王遥见优陀夷以神通力于虚空中加趺而来。从座而起合掌恭敬。向优陀夷而说偈言

  染服大师从何来　　成就威仪难见者
  若有所须愿速说　　我今诚心必奉给

尔时慧命优陀夷。以偈答曰

  我是大王子之子　　大王即是我祖父
  我为如来行乞食　　得食奉送大善逝
  大王今日获善利　　王儿人天最尊上
  威德光明照十方　　犹如秋月日中时
  如日处空离云雾　　光明晃曜普皆照
  如是最胜王圣子　　威德光显闻十方
  犹如秋日初出时　　蔽诸萤火光普照
  如是最胜王圣子　　伏诸外道独显曜
  犹如日中盛隆炽　　凌于星辰故不现
  如是最胜王圣子　　降伏外道自光显
  犹如日中凌月明　　令月失光明不现
  是王圣子伏外道　　如日盛明月隐照
  如禽兽闻师子吼　　水陆空行散还穴
  惊奔逃走迷诸方　　以师子声难忍故
  大圣如来震吼时　　邪外道闻无我声
  假使无知至有顶　　闻此无我皆悉怖
  盲冥愚痴人天中　　有目如来示明炬
  为作明灯除愚闇　　兴举无上智光轮
  显示邪正等不等　　教导世间道非道
  为失路者示其路　　拔欲淤泥置岸上
  如兴云荫覆枯池　　注雨充足原隰满
  如是大王仙圣子　　兴建法雨润人天
  如水沾地及山川　　并诸百卉丛林树
  药草条茎及枝蔓　　诸花蓊蔚遍山好
  如是十力四无畏　　具足十八不共树
  一切智果花庄严　　王仙圣子微妙身
  如须弥山处大海　　严好不动天乐居
  如斯善逝大王子　　沙门海中最第一
  忉利天主舍脂夫　　于天众中奇特妙
  如斯世尊大王子　　沙门众中最殊妙
  吼说秘奥甚深法　　以悲鬘电遍一切
  如来龙王降法雨　　念处池水细注下
  持戒威德如日轮　　以三昧力除恼闇
  智慧光灭烦恼爱　　大牟尼日照世间
  具足念处摩尼宝　　戒定船筏渡彼岸
  觉支宝矿禅浩满　　复求毕叉入佛海
  清净戒根坚难动　　三昧树叶念处枝
  七觉华空坚树身　　无我坚固成佛树
  戒林中行大力者　　三昧调伏德山依
  三解脱门为境界　　佛十力牙是王子
  正见无著牟尼尊　　能降强敌胜牛王
  恐怖种种诸外道　　是大王子无畏吼
  尸罗德藏妙庄严　　禅定寂灭无量衣
  具智牟尼解脱境　　能施财物如长者
  远离诸恶集诸善　　灭诸烦恼善慧根
  慧施天人修罗等　　光明晃曜王圣子
  戒云空慧以为电　　八支细雨能润泽
  牟尼能与胜苗子　　王子犹如大龙雨

尔时净饭王。以偈问曰

  胜士得来安乐耶　　至于饮食无乏少
  身无疲劳床卧具　　如花在岸不蔫萎

尔时优陀夷。以偈答曰

  禅定境界具神力　　身心安乐遍充满
  牟尼神虑依寂止　　犹如金莲不枯燥

尔时净饭王。以偈问曰

  昔以旌鼓自惊悟　　美音筝笛及箫瑟
  妙好伎女以自娱　　今独林中不苦耶

尔时优陀夷。以偈对曰

  禅定寂定为境界　　巧能修学三昧乐
  行住坐卧依诸善　　心常喜乐无苦恼

尔时净饭王。以偈问曰

  无价宝床常安卧　　眠时美女众在侧
  周围广设明灯树　　如何闇卧不悒戚

尔时优陀夷。以偈答曰

  牟尼眠时卧圣床　　慈为毡褥悲乐枕
  佛住喜心常怡悦　　舍三有趣不悒戚

尔时净饭王。以偈问曰

  诸健释种常围绕　　博达多闻以为伴
  殿舍天宫中长养　　如何今日乐林间

尔时优陀夷。以偈对曰

  如法生子恒现前　　同修寂止在其侧
  心好闲林修诸定　　离畏导师乐山林

尔时净饭王。以偈问曰

  童子昔日在宫时　　以天浴池而澡沐
  亦用香泽涂其身　　今在林中谁为洗

尔时优陀夷。以偈对曰

  诸法池水戒善岸　　牟尼自浴并浴他
  己及诸子浮不湿　　自度以讫及群生

尔时净饭王。以偈问曰

  昔种种香常熏体　　金线真珠以严身
  常着天子妙衣服　　今在林间用何饰

尔时优陀夷。以偈对曰

  功德鬘严戒香熏　　禅定璎珞惭愧衣
  通明解脱自庄严　　光明威德曜林中

尔时净饭王。以偈问曰

  昔以刀剑弓箭矛　　健士执持常防卫
  亦用宝盖恒覆荫　　今独林中谁守护

尔时优陀夷。以偈对曰

  慈悲忍辱自防卫　　声闻弟子眷属力
  以功德法定无怖　　十力雄猛四无畏

尔时净饭大王。以偈赞曰

  善哉善说我子德　　久修善法不退转
  汝进食讫将饭去　　我亦往诣牟尼王

尔时优陀夷复白王言。大王。婆伽婆是大众师善御群生。是大仙人能善安住沙门众中。沙门中王光明普照。譬如十五日夜净月圆满众星围绕。光明甚盛照耀一切。世尊亦尔。在沙门众中光明照耀。亦复如是。譬如秋日在于空中无诸云翳。彼婆伽婆。亦复如是。在大众中光明照耀。亦复如是。譬如帝释天中之王坐善法堂。诸天之中光明显赫。彼婆伽婆在于众中。光明晃曜。亦复如是。譬如须夜摩天。兜率陀天王。化乐天王。他化自在天王。在天众中光明显耀威德独尊。彼婆伽婆。于沙门众中威德显赫亦复如是。犹如娑婆世界主大梵天王。与百亿梵众之所围绕。光明晃耀威德独尊。彼婆伽婆。在沙门众中光明显赫威德尊胜。亦复如是。尔时净饭王。闻说婆伽婆道德已。心作是念。此乃世尊声闻弟子。犹有如是大神通大威力大功德。何况如来。复念太子本生之时。大地六种十八相动。动遍动等遍动。踊遍踊等遍踊。吼遍吼等遍吼。震遍震等遍震。起遍起等遍起。觉遍觉等遍觉。放大光明无人扶持行于七步。空中二道流水注下洗浴其身。自然而有真金圣座。于虚空中化成天盖。诸天礼拜。乃至未出家时。不为五欲之所迷惑。凡有所作。决定不退。随说能作。一切时中坚固大力。不作妄语。不违信行。本作是言。我成阿耨多罗三藐三菩提。自度己讫。复当度王。时王念佛为菩萨时本誓愿故。说是偈言

  若有初生已　　明智言不虚
  所说事不异　　智者谁不信
  若有初生时　　世亲说无等
  必作天人尊　　智者谁不信
  若有不能惜　　宝聚如雪山
  离于贪吝者　　智者谁不信
  若能于梦中　　不作虚妄语
  如说如修行　　智者谁不信
  如刀剑之语　　不能恼令嗔
  离于忿怒事　　智者谁不信
  无有能欺者　　贪嗔亦不染
  具足智慧王　　智者谁不信
  一切妙五欲　　及以种种报
  无有能系缚　　智者谁不信
  种种希有事　　及以众妙物
  无有能怖畏　　智者谁不信
  以诸美妙言　　明人善巧说
  无有能惑缚　　智者谁不信
  以诸顺义语　　诸欲决定句
  于此不能缚　　智者谁不信
  以诸军驾力　　及以种种护
  能出于妙城　　智者谁不信
  弃舍妙欲乐　　为求甘露行
  悕望于菩提　　智者谁不信
  六年修苦行　　勇猛无能当
  求于胜菩提　　智者谁不信
  六年粗少食　　求于胜菩提
  利安诸世间　　智者谁不信
  六年为魔扰　　相续求短缺
  不能得其便　　智者谁不信
  远离五欲过　　不求于他物
  常利益世间　　智者谁不信
  不从他闻法　　自然成菩提
  寂定难可觉　　智者谁不信
  梵天自劝请　　勤求佛世尊
  如请而演说　　智者谁不信
  哀怜愍我故　　来到尼俱园
  为度诸释种　　智者谁不信
  如来自度已　　度我于有海
  忆念本誓愿　　智者谁不信
  今正得利时　　知佛一切智
  为怜愍我故　　智者谁不信
  我今当往诣　　见人导师身
  作是思念时　　自省是人王

尔时净饭王久思量已白慧命优陀夷言。比丘汝今至此更何所须。时优陀夷以偈答言

  本为利益大王故　　我今乘通来至此
  若于十力起一信　　男女皆得趣善道
  十力功德无边际　　大仙为诸释种来
  欣欣之事今方至　　人主应当发信心
  大王名称必增长　　遍满三千大千界
  汝子既是人王藏　　具足十力慈悲心
  游行十方心无碍　　如花在水不染着
  自度四流诸有已　　亦度人天四瀑河
  安置无畏洲岸上　　大王应当信导师
  拔去四流三毒箭　　亦降群生胜医师
  于众医中最尊上　　大王应当深敬信
  亦能降伏诸军众　　魔王眷属恶亲党
  证于寂灭妙菩提　　大王应当深敬信
  诸人天王咸劝请　　为度众生说妙法
  敷演无上甘露药　　人中牛王应当信
  隐蔽一切外道众　　转过称量妙法轮
  化度无量亿众生　　大雄人王应当信
  无明厚覆黑暗中　　自眼清净复净他
  说法能除诸盲翳　　大雄人王应当信
  老病死畏逼迫者　　说除老病不死法
  令世间众升善趣　　大雄人王应当信
  三火所烧世间众　　如地洞然以水灭
  说于八正圣为人　　大雄牛王应当信
  除断三秽吐诸恶　　能离世间三垢浊
  游行十方甚奇妙　　勇猛牛王应当信
  如父爱子愍世间　　十力大慈心普润
  起大悲愍度众生　　勇猛牛王应当信
  难调能调婆伽婆　　所应度者今悉度
  能灭炽然诸烦恼　　勇猛大王应当信
  众生堕于三有海　　犹如船舫能济渡
  十力大悲救世间　　勇猛牛王应当信
  无量功德端正身　　大悲游行化世间
  令久浊心得清净　　勇猛大王应当信
  如摩尼宝澄清水　　游行世间净众生
  除断群迷竞乱浊　　勇猛大王应当信
  如摩尼珠性清净　　能令智者心欢欣
  世尊离恶心皎洁　　令诸明人欣慕乐
  于世间最起信心　　能使天人离苦担
  舍诸有趣得寂灭　　勇猛大王应当信
  功德聚中说少分　　如在虚空鸟一迹
  佛功德岸我不知　　大王应当深敬信

尔时净饭王。闻慧命优陀夷善说世尊为菩萨时所修功德。即自念知如来本誓。我得度已必当度王。如是念已。深生敬信。复白慧命优陀夷言。比丘汝今即是我子之子。汝可食竟。速还佛所。将食奉佛。我今亦当往见世尊。尔时慧命优陀夷。知净饭王得于敬信。饭食已讫。即持肴馔。奉上如来。尔时佛告诸比丘言。优陀夷。教化净饭王。得于正信。诸比丘。今日诸天世人大得利益

尔时世尊。赞叹优陀夷言。善哉善哉。汝于今日。得大福德。以净饭王得敬信故。尔时佛告诸比丘言。迦卢陀夷化净饭王。所得功德若是色者。十方世界恒沙佛刹。所不容受。以功德聚广大无量故

大宝积经卷第六十一大宝积经卷第六十二

        北齐三藏那连提耶舍译

    菩萨见实会第十六之二净饭王诣佛品第二

尔时世尊。饭食澡手洗钵器已。现其瑞相。即时毗沙门天王。以无量那由他百千亿众夜叉围绕。譬如壮士屈申臂顷。一念之中从天宫没。佛前而现。头面礼足住立北方。于虚空中。夜叉大众前后围绕。合掌恭敬佛及众僧。提头赖吒天王。以无量百千那由他乾闼婆众前后围绕。亦如壮士屈申臂顷。从天宫没。于如来前。头面礼足。住在东方。于虚空中。恭敬世尊及比丘众。尔时毗楼勒叉天王。以无量百千那由他鸠槃茶众之所围绕。亦如壮士屈伸臂顷。从天宫没。在于佛前。头面礼足住于南方。在虚空中合掌恭敬如来及比丘众。尔时西方毗楼博叉天王。以无量百千那由他诸龙前后围绕。亦如壮士屈伸臂顷。从天宫没。于如来前。头面礼足。住在西方。于虚空中合掌恭敬如来及比丘众。释提桓因天王亦复如是。无量那由他百千围绕。从三十三天没。住于佛前。头面礼足于虚空中。恭敬如来及比丘众。夜摩天王。兜率陀天王。化乐天王。他化自在天王。娑婆世界主大梵天王。光音天王。遍净天王。广果天王。净居天王。各以无量百千那由他天众之所围绕。于彼天没。住于佛前。头面礼足。在虚空中。恭敬如来及比丘众。亦复如是。尔时毗摩质多阿修罗王。与六十那由他眷属前后围绕。犹如壮士屈伸臂顷。于自宫没。住于佛前头面礼足。现恭敬相。却住一面。金翅鸟王亦与八万六千迦楼罗众眷属围绕。于自宫没。住于佛前头面礼足。及诸外道其有八亿。从诸方来。而说偈言

  于净虚空中　　十五夜满月
  超过诸星众　　光明独显耀
  佛如净月轮　　灭闇除三垢
  能超诸外道　　犹如空中月
  秋日千光明　　能除诸暗冥
  超出明月光　　开布莲花池
  佛光过于日　　普照大千界
  如来能开现　　声闻莲花林
  天主憍尸迦　　住在善法堂
  出过诸大众　　金刚杵光耀
  十力功德山　　两足尊胜王
  超过诸外道　　犹如释天王
  须夜摩天王　　天众所供养
  住在天众中　　光赫坐宝座
  十力无边威　　超过恶道趣
  无畏光明德　　显说八正道
  如兜率天王　　在宫众围绕
  超过诸天众　　宿善而光耀
  调御天人师　　八部所供养
  超过诸世间　　无畏显说法
  如化乐天王　　在于天宫中
  超过诸天众　　功德独光显
  佛超诸世间　　离浊出三界
  能调未调王　　具十力光照
  如自在天王　　住居天宫中
  超过诸天众　　宿善而晃耀
  如是佛光明　　具足十力行
  超过天人众　　本善功德故
  如大梵天王　　超过诸梵众
  光耀说甜美　　显于八正路
  如来胜梵天　　沙门众中王
  光明照三界　　转于四谛法
  知见众集已　　天人龙听法
  人中最胜王　　吐宣八正语
  虚空可度量　　海可瓶量尽
  须弥山可称　　佛德难可知

尔时净饭王。白释种言。诸人者如日欲出先现瑞相。所谓明星出时。当知日出不久。迦卢陀夷亦复如是。于佛如来一切种智先现瑞相。比丘所说如来功德。即是一切智相诸仁者。速办好乘。我当往诣至如来所。时释种臣言。善哉大王。今正是时。所须之具。今悉已办。尔时大王敕诸臣言。从迦毗罗城乃至尼俱陀林。于其中间精治道路。以好软沙遍布其地。散种种花。悬诸缯彩。作唱伎乐种种歌舞。尔时大王乘好车乘。出迦毗罗城。诣尼俱园。于彼乘后。有八万白象。以种种宝。间错庄严。于其象上。各立七宝殿堂。甚奇微妙。于其象后。各严八万宝马。于其马上。各有金幢。其马及幢。各以七宝庄严。微妙第一。是时城中。有无量人。严饰车乘。诸所服饰青马青车青盖严饰。执持青刀。衣服皆青。鞍鞯鞦辔悉亦青色。各持青幢。一一车后。百青衣人之所围绕。复有释种等各各严饰种种好车。青黄白赤杂色庄严。杂色车马杂色严饰。一一车马皆有百人。杂色庄严。亦复如是。尔时世尊。遥见王来。告诸比丘。汝若欲见三十三天游戏众者。当观释种出迦毗罗城。何以故。释种游行与天无异故。尔时世尊。而说偈言

  其迦毗罗妙城中　　净饭大王及眷属
  最胜人王今方至　　谛听谛听我当说
  象马车乘过百千　　种种庄严甚殊妙
  从迦毗罗而引出　　人王宝藏及诸乘
  青马青车青庄严　　将从衣服悉青色
  靴帽刀拂咸亦青　　青鞭青辔青铃网
  青衣人持青幢盖　　人马皆青甚殊妙
  黄马黄车黄庄饰　　将从衣服悉黄色
  靴帽刀拂皆亦黄　　黄鞭黄辔黄铃网
  黄衣人持黄幢盖　　人马皆黄甚殊妙
  赤马赤车赤庄饰　　将从衣服悉赤色
  靴帽刀拂皆亦赤　　赤鞭赤辔赤铃网
  赤衣人持赤幢盖　　人马皆赤甚殊妙
  白马白车白庄严　　将从衣服悉白色
  靴帽刀拂皆亦白　　白鞭白辔白铃网
  白衣人持白幢盖　　人马皆白甚微妙
  杂色车马杂庄严　　将从衣服悉杂色
  靴帽刀拂皆亦杂　　杂色鞭辔杂铃网
  杂色衣人持幢盖　　人马皆杂甚微妙
  彼诸车后庄严象　　其数足满八十千
  金鞍金鞯金庄饰　　象背皆有七宝殿
  种种庄饰妙龙马　　其数亦满八十千
  七宝庄严甚奇丽　　众妙服饰从车后
  以诸妙花散御路　　用五种香熏其地
  悬诸瓶香并缯彩　　壮士戏人歌舞辈
  种种庄严遍其路　　作诸音乐从王后

尔时净饭王。及诸侍从。至尼俱树园。下车而入。步众导从前后围绕。尔时世尊。知父王心深生怨恨。为度王故。过于人上。在虚空中。自在游行。如来行时。娑婆世界主大梵天王在如来右。释提桓因在如来左。须夜摩天王。兜率陀天王。化乐天王。他化自在天王。各各执持种种天盖。供养如来。尔时毗沙门王提头赖吒天王。在佛东面。偏袒右肩。右膝着地。合掌向佛。现恭敬相。毗楼勒叉王。毗楼博叉王。在佛西面。亦偏袒右。肩右膝着地。合掌向佛。现恭敬相。尔时四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在诸天子等。在虚空中。雨天优钵罗花栴檀末香曼陀罗花。作天伎乐及以歌舞。复于虚空中雨诸香水。从昔以来未曾见闻。优钵罗华旃檀香末。供养如来。尔时世尊。示现神通。以通力故。令人见天差别之相。时净饭王。见诸天子供养如来。生希有心。复见严饰七宝重阁满虚空中。见已作是说言。如来本昔作童子时。不以四天下转轮圣王生于顾恋。何以故。今在三千大千世界中。为大法王统领天人富贵自在。今此世尊为正法王。我今于此为人围绕。世尊乃有天人侍卫。尔时净饭王。偏袒右肩。右膝着地。头面礼足。合掌向佛。而作是言。世尊初生之时无人扶持而行七步。观察十方而作是言。我于世间最尊最胜当得度脱老病死边。我于尔时头面礼世尊足。复于后时至于田村。阎浮树下坐于清凉。日虽西移影初不动。复有六天童子。合掌作礼在如来前。我于尔时头面作礼大牟尼足。我今第三复亦头面礼世尊足。尔时净饭王。而说偈言

  两足世尊初生时　　无人扶持行七步
  自说我于世最胜　　尔时我礼明智者
  牟尼踰城至田村　　阎浮树影荫不移
  六天童子修供养　　我时复礼世应供
  今是第三稽首礼　　恭敬怜愍世间尊
  堪受人天微妙供　　世无如佛何有胜
  世尊本号悉达多　　字为父母所喜乐
  始知如来名称实　　得愿满足获甘露

尔时欲界诸天。与世尊敷师子座。以天妙衣。敷在座上及尼俱园。复以天劫波树衣。弥覆虚空。尔时世尊。从空而下。在师子座加趺而坐。时净饭王。及诸眷属头面礼足退坐一面。欲色二界诸天子等。亦头面礼足。于虚空中退坐一面。尔时世尊。而说偈言

  净饭大王及眷属　　来诣世尊设供养
  从迦毗罗妙城出　　趣尼俱陀可乐园
  佛与无量众围绕　　阿修罗王及龙王
  鸠槃荼王金翅王　　乾闼婆王并眷属
  夜叉大王鬼神众　　紧那罗王悉皆集
  欲界天王并天子　　一切皆生欣喜心
  六欲诸天既如是　　梵辅梵身梵天众
  遍净诸天并眷属　　乃至广果净居天
  沙门大众婆罗门　　僧佉卫世尼干子
  及余一切诸外道　　修行种种异术士
  斯等诸方皆来集　　如来示现自神力
  令净饭王及释种　　获得信心欣喜成
  如来普为一切众　　以微妙语善义句
  世尊意在净饭王　　现化种种胜神力
  王本不许佛出家　　相师本昔相童子
  在家必作转轮王　　无量亿众所供养
  满足圣王七种宝　　亦复具有四神通
  如法正治护国土　　王四天下刹利王
  尔时菩萨发是言　　我昔无量那由劫
  于一切时常实语　　大王谛听我今说
  大王昔来于我所　　实自初无信敬心
  欲以轮王令我作　　以四天下生恋惜
  譬如本昔有通龟　　随海水潮在陆地
  其海潮水回还去　　龟便坠堕深井中
  井中旧鳖问海龟　　汝本何处今至此
  广智海龟答井鳖　　我遇海潮坠此井
  其海潮水还源时　　我行迟迟遂不及
  以斯我今失时节　　堕此小井共汝住
  井鳖复问海龟言　　其海多少井中水
  岂复宽广于此耶　　为大为小愿速说
  广智海龟答井鳖　　无智住人穿凿处
  我于大海水中居　　在彼经历多年载
  犹尚不知海处中　　况复了达其彼岸
  如是大王都不知　　我之神通威德力
  欲以轮王四天下　　世间势贵恋惜我
  我今现作法轮王　　统领三千大千界
  如法正治离刀仗　　得于八部最胜供
  我今称颂昔日言　　故来应现此大众
  以神通力修其心　　用慈悲念召集众
  一切诸有皆云会　　莫不为王得净信

    阿修罗王授记品第三

尔时世尊。现其瑞相以是相故。时毗摩质多阿修罗王。作是念言。我今最初供养世尊。时毗摩质多阿修罗王。与其徒众六十那由他。婇女眷属亦六十那由他。以其海中无价宝珠及余海中所无悉采供养。尔时阿修罗王。化作六十那由他七宝车。一一宝车复化六十那由他调顺之马。一一调马复化七宝铃网庄饰马上。复化真金铃钏以饰马脚。一一马亦复化作七宝缠髻[肆-聿+((稯-禾)-凶+(鬯-匕))]尾。一一调马复以真金鞦辔。彼诸调马皆以七宝为角。彼诸调马车上七宝庄严轩盖。皆用七宝在虚空中。随车行住。一一轩盖皆悬七宝旒苏铃带。一一轩盖皆化宝网弥覆其上。彼诸车马轩盖铃网。为风所吹出微妙音夺人视听。犹如善击百伎音乐出种种声。令人喜乐夺人心意。一一宝车在虚空中。去地六十由旬。一一车后作诸音乐。一一车上皆有阿修罗女。种种严饰在其车上。是诸女等。或有立舞。或有坐舞。或有唱歌。或身动转。或散栴檀末香。或散优钵罗末。或雨沉水末。或雨多摩罗拔。或雨天诸末香。或散阿修罗香末。或雨金末。或雨曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。波卢沙迦花。摩诃波卢沙迦花。迦迦罗婆花。摩诃迦迦罗婆花。波吒梨花。摩诃波吒梨花。质多罗波吒梨花。摩诃质多罗波吒梨花。悉皆化作用供养佛。或散金花。银花。毗琉璃花。颇梨花。赤真珠花。马瑙花。车磲花。或持七宝以散世尊。有散衣服。或以手环臂脚钾钏宝冠宝鬘庄严之具。金锁银锁真珠绳贯。或长或短。或有七宝项巾及诸璎珞金银耳珰。或以七宝盛发之袋以散于佛。或以顶鬘在臂铃钏动摇发声。或以七宝填鬘以金庄严。或以金填七宝庄严。有执金网。有捉金旒苏。有持摩尼旒苏。有持真珠旒苏。或持金盖银盖。或持毗琉璃盖。有持七宝盖者。或持种种宝幢。或持种种色幡。或雨香水者。皆为供养佛故。或有合掌说偈赞叹曰

  归命丈夫调御师　　归命丈夫最胜士
  归命丈夫两足尊　　归命丈夫无等伦
  归命明照世间者　　归命最上大智海
  归命具足功德林　　归命最胜微妙山
  归命具足功德聚　　归命灭除诸烦恼
  归命修诸净行师　　归命净行无断绝
  归命无依不怯弱　　归命无懈无悼动
  归命决定发精进　　归命决定满足者

尔时阿修罗王。亦复化作六十那由他七宝帐幕甚奇微妙杂色庄严。一一帐幕净游之下亦复化作六十那由他七宝大地。彼诸地上亦复化作六十那由他楼橹却敌。七宝合成微妙第一。一一却敌亦复化作六十那由他重阁殿堂。七宝庄严。一一堂殿复有六十那由他门户窗牖。七宝庄饰。一一门户金门银扇杂宝雕饰。其诸门阃一一皆用毗琉璃宝。一一门枢皆用车磲。复以车磲为柱。一一柱上以赤真珠以为栌栱。马瑙为地。其银门者悉用金扇。毗琉璃为阃。车磲雕镂马瑙为枢。赤珠为柱。白玉为栱。颇梨为地。毗琉璃门户。颇梨为扇。金为门阃。银为户枢。白玉为柱。马瑙为栱。赤真珠为地。颇梨门户。毗琉璃为扇。马瑙为阃。赤珠为枢。以金为柱。银为基栱。白玉为地。马瑙门户白玉庄饰。赤真珠宝以为阃扇。银为户枢。琉璃为柱。金为基栱。颇梨为地。赤真珠户马瑙庄饰。白玉阃扇。银为户枢。毗琉璃柱。颇梨基栱。黄金为地。白玉门户马瑙庄饰。金为阃扇。毗琉璃枢。白银为柱。颇梨为地。赤真珠宝以为基栱。彼诸门户。一一户中。化作六十那由他师子之座。七宝合成。以诸天人阿修罗衣。弥覆其上。或敷迦旃陵伽衣。或敷憍奢耶衣。其座两头置朱色枕。彼诸座前有七宝几。一一几上有于六亿阿修罗王种种衣服。所谓诸天树衣。刍摩罗衣。憍奢耶衣。迦尸迦衣。一一师子座上。各各皆有二修罗女众宝庄严。一一女人皆持七宝多罗树叶。以为其扇。一一座中皆有化修罗子。在于座上两女侠侍。持七宝扇。彼诸门户亦复化作六十那由他七宝幢盖。于金门户化作青幢黄柄颇梨间错。于银门户化作黄幢赤真珠柄白银间错。于毗琉璃门化作赤真珠幢。黄金为柄颇梨交错。颇梨门户化作杂色宝幢。黄金为柄白银交错。青幢黄头黄幢青头赤幢白头白幢赤头杂色幢者七宝为头。彼诸宝幕及诸殿堂于虚空中。绕佛三匝犹如三十三天。伊罗婆那龙象在空游行。俱持毗陀罗婆树梨耶多罗树。供养诸天。彼诸帐幕于虚空中。右绕三匝亦复如是。彼诸宝幕却敌之中。及以地上重阁殿堂。有诸门户师子之座庄严宝盖宝幢幡花。雨天真檀末香天优波罗末香沉水末香。复雨曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。迦迦罗婆花。摩诃迦迦罗婆花。波吒梨花。摩诃波吒梨花。质多罗波吒梨花。摩诃质多罗波吒梨花。金花银花。毗琉璃花。颇梨花。一切众宝花。雨金雨银雨天树衣。彼诸修罗王子手中悉持如是宝珠。以珠力故。随意所须皆能降雨。尔时迦毗罗城。四门之外。各各纵广六十由旬。以阿修罗王威神之力。放光遍照六十由旬。上照六万由旬周围遍满供养之具。彼诸浮游帐幕绕佛而住。时迦毗罗城中积曼陀罗花。举高七丈。天上香水成泥。以佛神力。令其香气遍满三千大千世界。于此三千大千世界中。所有住大乘者彼诸众生闻其香气。乃至初发阿耨多罗三藐三菩提心。得不退转。况复久修。时毗摩质多阿修罗王。乘七宝车绕佛三匝。以妙天真檀末以散佛上。而说赞曰

  我今归依婆伽婆　　能施天人无畏者
  归依最胜不可动　　悕望无上妙菩提
  我今归依婆伽婆　　心喜不堕三恶趣
  是故我今归依佛　　悕求无譬妙菩提
  我今归依婆伽婆　　能除生死大苦海
  能断旷野离恼净　　堪能引导众生师
  我今归依婆伽婆　　以此归依不求生
  老死所逼大苦恼　　世尊为诸天人归

尔时毗摩质多阿修罗王。以偈叹佛。右绕三匝。时彼诸马璎珞庄严。彼诸车庄严。彼诸阿修罗。阿修罗女庄严。彼诸幡幢宝盖铃网等。为风所吹。出深妙声。称心夺听。譬如具足百伎音乐。善巧奏击出深妙音。称意音声。甚可听采。夺人耳目。如是诸马庄严璎珞。乃至铃网。为风所吹。出微妙音。如巧奏击百种音声甚可爱乐。尔时毗摩阿修罗王。绕佛三匝。雨天真檀末香。优钵罗末。沉水末香。多摩罗末。种种阿修罗香末。从空而下。雨天曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。波卢沙迦花。摩诃波卢沙迦花。迦迦罗婆花。摩诃迦迦罗婆花。波吒梨花。摩诃波吒梨花。质多罗波吒梨花。摩诃质多罗波吒梨花。复有种种化花。雨金花银花毗琉璃花乃至七宝众花从空而下。雨天香水阿修罗香水。从空而下。以香水故。迦毗罗城内外。纵广六十由旬。悉成香泥。以其泥香遍满三千大千世界。所有菩萨闻其香者。于阿耨多罗三藐三菩提。得不退转。尔时毗摩质多阿修罗王。绕佛三匝。以佛神力于虚空中。作天伎乐及阿修罗音声。彼诸音乐以佛神力。其音遍满三千大千世界。皆悉闻知。所有住大乘者闻其声已。悉于阿耨多罗三藐三菩提。得不退转。无量百千阿修罗女或歌或舞。或奏音乐或身动转。又散天真檀末。优钵罗末。沉水末。多摩罗拔香。曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。波卢沙花。摩诃波卢沙花。迦迦罗婆花。摩诃迦迦罗婆花。波吒梨花。摩诃波吒梨花。质多罗树花。摩诃质多罗树花。金花银花。毗琉璃花。众宝杂花。又雨化花以散佛上。又散诸天衣服。臂脚铃钏以散佛上。腰璎珞。手臂璎珞。指环项巾。七宝之鬘。金锁银锁。真珠之贯。摩尼璎珞。半月珠璎于两肩上。七宝衣璎。种种宝璎。两耳珰磲盛发宝袋庄严顶冠种种旒苏。种种香旒苏。种种真珠旒苏。种种摩尼旒苏。或雨天种种宝盖金末香水。又阿修罗女。手把赤真珠以散佛上。又捉宝散者。又捉种种珠散者。皆为供养佛故。毗摩质多阿修罗王。与其眷属皆悉相顺而说偈言

  我常如是心　　值遇佛世尊
  归依如来故　　未来常供养

尔时波罗陀阿修罗王所设供养。亦如毗摩质多阿修罗王。等无有异。乘七宝车。右绕三匝。以偈赞佛

  我礼得实十力士　　亦礼离怖无畏者
  决定得于不共法　　归命导引诸世间
  我礼断除结缚者　　亦礼出离生死道
  我礼到岸住陆地　　将导贫乏众生师
  我礼深智不思议　　与众和合不悼动
  于诸趣中心解脱　　犹如莲花不着水
  牟尼本修诸空法　　离诸栋择得无相
  于一切处无所愿　　我礼如空无所依

尔时善臂阿修罗王。所设供养广大无量。如毗摩阿修罗王。等无有异。乘众宝辇。右绕三匝。散诸金粟以偈赞曰

  大牟尼尊无等伦　　天上天下亦无比
  佛知众生如阳焰　　非真实有唯想转
  于此无作无受者　　亦无士夫空无我
  离诸所作无体性　　说于一切寂定法
  于善逝法得信解　　观一切法悉平等
  彼当得作导师子　　顺佛言教如父说
  我今赞叹所得福　　唯佛智解能照知
  我以福德悉无余　　回施众生皆作佛

尔时复有跋墀毗卢遮那阿修罗王。所设供养。亦如毗摩质多阿修罗王。等无有异。乘七宝车。绕佛三匝。散以银花。说偈叹曰

  我今礼佛妙好相　　度生死海到彼岸
  自身得度复度他　　安置彼岸无畏处
  唯佛大慧知群生　　倒见丛林无智者
  迷惑焰水计为实　　无等悲心皆已知
  世尊妙人见众生　　如幻阳焰如光影
  牟尼如法生善子　　三有中行不染污
  大自在人知非实　　知诸法性彼此空
  愚痴如梦受欲乐　　佛子知已修诸行

尔时罗睺罗阿修罗王。所设供养。亦如毗摩质多阿修罗所设供养。乘七宝车。绕佛三匝。以质多罗波吒梨花。以散佛上。说偈赞曰

  大仙如来神妙身　　超过一切诸天人
  既如须弥比芥子　　复似大海譬牛迹
  如来颜容甚端正　　众相庄严第一最
  超过一切色中上　　如日出现萤息照
  世尊无量威德聚　　超过一切威德者
  令诸威德不能现　　如日出时萤光隐
  大圣世尊智慧海　　超过遍覆三有界
  蔽诸外道令不现　　如日盛明月光没

尔时睒婆利阿修罗王。所设供养。亦如毗摩质多阿修罗王。修供养已。乘七宝车。绕佛三匝。用摩诃波吒梨花。以散于佛。说偈赞曰

  乐奢摩他智慧者　　能除三毒贪嗔痴
  引导众生出世间　　犹如甘雨灭尘焰
  世尊炽然正法眼　　亦如苏投大盛火
  能断烦恼疑网尽　　亦如火烧大圹野
  颜容端正甚微妙　　众相庄严最第一
  超过一切诸妙色　　如日出时萤光隐
  如来秉持诸善根　　无量亿万那由劫
  能除烦恼及恶业　　如食甘露去身毒
  吹除一切无明冥　　如夜明炬照黑闇
  如来示现正法眼　　犹如珠师显宝价

尔时乐战阿修罗王。所设供养。亦如毗摩质多阿修罗王。设供养已。乘七宝车。绕佛三匝。散众宝花。以偈赞曰

  难调恶心佛能调　　如勇健士降胜敌
  善得柔软心自在　　我礼心调无畏者
  能调诸根离怨对　　离畏无畏得安隐
  世尊烦恼不更发　　消伏毒害悉无余
  那罗延力善修慈　　于爱憎中心平等
  如来知诸众生相　　不为六道之所摄
  离诸想心竭有爱　　放智慧光破诸闇
  于诸法中心不着　　牟尼超过无等伦

尔时善目阿修罗王。所设供养。亦如毗摩质多阿修罗王。修供养已。乘七宝车。绕佛三匝。奉众宝藏。以献于佛。说偈叹曰

  大雄久已知　　诸法真实相
  所谓法名者　　各各和合假
  一切诸法体　　种种求不得
  所言此法者　　说唯是假名
  离名名体性　　诸相亦如是
  无相亦无名　　已离三种法
  所言解说者　　实无可显说
  说者说亦无　　解者亦复然
  如是知于法　　无上牟尼子
  于诸法不着　　修行大名称

尔时伏三界阿修罗王。所设供养。亦如毗摩质多阿修罗王。修供养已。乘七宝车。绕佛三匝。用真珠璎珞。以奉如来。说偈叹曰

  我今叹佛离怨敌　　颜容端正戒智力
  一切世间无如佛　　以无比身伏仇对
  色力光明照三有　　修诸善业得端正
  以布施力得其相　　八十种好悉严净
  净持戒力无能动　　明人思量所不得
  佛持戒心清净故　　人中师子所作成
  如来智力更无比　　以无怖畏胜三界
  如师子王众中吼　　超过一切诸外道

尔时毗卢遮那阿修罗王。所设供养。亦如毗摩质多阿修罗王。设供养已。乘七宝车。绕佛三匝。手执众宝。以散如来。复以偈颂。而赞叹曰

  诸众皆集牟尼所　　净心瞻仰如来面
  一切现前睹世尊　　斯则如来不共相
  佛以一音演说法　　种种随心各皆解
  世尊说应众生机　　斯则如来不共相
  佛以一音演说法　　众生随类各得解
  称意所欲知其义　　斯则如来不共相
  佛以一音演说法　　或有修进或调伏
  或有获得无学果　　斯则如来不共法

尔时目真邻陀阿修罗王。所设供养。亦如毗摩质多阿修罗王。修供养已。乘七宝车。绕佛三匝。手执赤真珠。以散佛上。说偈赞曰

  欣喜净心敬信佛　　离于傲慢无邪见
  顺佛阿含不放逸　　是为修行无比子
  诸法自性不可得　　如梦行欲悉皆虚
  但随想起非实有　　世尊知法亦如是
  如秋时云水中月　　迷惑无智愚众生
  不能惑着明智人　　深乐佛法精进者
  妙人最妙不错悟　　于佛法中不放逸
  分别诸法悉如梦　　得见如实妙三昧

尔时毗摩质多阿修罗王等。有六十那由他阿修罗。设供养已。皆各合掌作礼而住。欣欣踊跃情意充满喜乐称心。菩提之心流注不绝

尔时世尊知彼诸阿修罗信心供养已。如诸佛法示现微笑相。从其面门。放无量色光。青黄赤白红紫颇梨。亦如金银及以杂色。从口出已。绕佛三匝还从顶入。尔时慧命马胜比丘。从坐而起。偏袒右肩。右膝着地。合掌向佛。为佛作礼。以偈问曰

  雄猛牟尼现瑞相　　愍世间者非无因
  人中最胜愿为说　　大仙所现之因缘
  怜愍世间现瑞应　　见诸修罗胜供养
  欲授修罗决定记　　令我等辈得欣欣
  朝有胜心无有疑　　此众中有发心者
  世尊知其信根已　　人中师子现此瑞
  朝日谁发清净心　　谁于人中生胜信
  世尊知其信根已　　现此最妙之瑞相
  今此大众皆有疑　　皆见如来现微笑
  谁复朝日降魔怨　　现此瑞相为此人
  善哉降怨大仙尊　　愿断大众心犹豫
  愿尊速说勿踟蹰　　断此大众之疑网

尔时世尊。以偈答马胜比丘曰

  善哉比丘所问义　　我所现瑞利世间
  我说果报无有余　　汝今一心善谛听
  诸阿修罗供养佛　　为求无上胜菩提
  修罗心意无所依　　如手在空不障碍
  此等供养世尊已　　阿修罗众心清净
  大智皆舍修罗道　　于人天中久受乐
  此等于其未来世　　值遇恒沙人师子
  于善名劫得成佛　　如来皆号为善名
  数满六十那由他　　名振十方照世间
  演说无依无著法　　广能度胜天人众
  彼诸佛土甚严净　　佛知世间离五浊
  净佛国土三千界　　满足六十那由他
  彼国无诸三恶趣　　以欣喜心土田净
  彼佛雄猛除诸难　　演说无上大乘法
  彼等诸佛得寿命　　住世六十那由劫
  演说无所依止法　　一一导师皆亦然
  彼诸如来灭度后　　世间智者尽皆灭
  满足六十那由劫　　彼佛正法住在世
  是诸如来各各度　　如恒河沙众生聚
  彼诸如来等无量　　土寿法住亦如是
  彼诸善逝能成熟　　六十那由众生数
  皆令安住大乘中　　各各绍继三宝种
  今此授记为修罗　　利世间者大仙说
  天人闻斯授记已　　身心踊跃得净信

大宝积经卷第六十二大宝积经卷第六十三

        北齐三藏那连提耶舍译

    菩萨见实会第十六之三本事品第四

尔时慧命摩诃迦叶。见诸阿修罗王供养佛已。生希有心。作是思惟。世尊本修菩萨行时。作何善根得是果报。时迦叶即入如实三昧。以其三昧严心力故。忆念过去阿僧祇阿僧祇劫。如来所修一切功德。于彼彼道彼彼生中所修善根。皆为满足无上菩提。以此善根得住不退转地。彼诸善根皆得念知。尔时迦叶忆念如来大善根时。作如是心。如佛所习善根广大。如来一一发心善根。如十方世界恒沙刹土。其中众生皆得人身。得人身已。众生如恒沙劫。供养善逝亦如修罗。一一众生如恒沙劫。供养如来已。不能报如来一发心善根。尔时慧命摩诃迦叶。从三昧起。以偈赞曰

  一一如来牟尼尊　　发心广大向菩提
  此修罗等所供养　　佛迦罗分不及一
  世尊应供人中上　　如须弥山真檀聚
  人天中胜所供养　　由度功德彼岸故
  人中师子应受供　　过诸恒河沙数等
  譬如大海满中水　　香水和合而供养
  具足功德应受供　　多于恒河沙数等
  积满花聚而供养　　犹如斫迦婆罗山
  自然大士应受供　　如须弥山灯明炷
  大海以为香油器　　以灯供养诸胜者
  应受供养大威势　　多于恒河沙数等
  造立塔庙而供养　　由度功德彼岸故
  人中坚固应受供　　以诸广大胜宝盖
  其盖遍覆三千界　　经于那由他劫数
  怜愍世间人中尊　　无边功德应受供
  以诸宝幢所供养　　遍满十方诸世界
  于不思议亿劫数　　以广大幡而供养
  满恒河沙诸世界　　经于无量亿劫数
  供养如来人师子　　起于分别作譬喻
  大论师中师子子　　谛听谛听诸天人
  我及诸来在此众　　若如恒河沙数等
  诸有十方世界众　　一切皆当得作佛
  具足十力人师子　　彼佛头数如恒沙
  一一皆有恒沙头　　于一一头如恒沙
  各各皆有恒沙口　　彼于一一无量口
  有于无量沙数舌　　以舌赞叹于如来
  彼诸如来说不尽　　功德彼岸不可到
  一切智智不可量　　由度功德彼岸故

尔时世尊。告诸比丘言。善哉善哉。诸比丘。我诸声闻端直而住。有智有法亦如梵天。乃能入我功德海中。何以故。如来具足无量功德。具足不思议功德。诸比丘。如来功德聚不可思议。诸比丘。如来功德聚若是色者。一一发心所得功德如恒河沙等世界中所不容受。何以故。诸比丘。如来一一发心功德。一切智所攀缘处。如洹沙等诸佛。如恒沙等劫。不能思量。说不可尽。何以故。如来本修菩萨行时。无一发心不为利益一切众生。众生所摄者无一发心不为一切众生。众生界无边际。其中众生亦无边际。所有众生界无边际。如来一一发心功德亦无边际。何以故。如众生界无边际。如众生界不可量。如来一一发心功德聚不可穷尽。皆为怜愍利益安乐一切众生故。是故发心。假使一切众生供养时。不能报如来一发心功德。何以故。彼诸众生供养如来。皆为悕望杂食世报故。菩萨本发心离于杂食求世报心。为利益安乐众生故。欲令众生背于生死趣向涅槃。如来本修菩萨行时。为利益安乐众生。离于杂食不求世报。佛告诸比丘。于过去世无量无边流转生死。阿僧祇不可思议无始世界。不可说劫中。有佛号曰因陀幢王。出现于世。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛婆伽婆。彼佛如来。以一一发心。如恒沙等世界中。曾为众生。作利益安乐思量发心。比丘。彼因陀幢如来作佛时。恒河沙世界同一佛刹。其因陀幢如来应供正遍知国土严净。离于恶趣及以八难。是因陀幢如来应供正遍知。其国土中所有众生住正定聚。其邪定众生。增上慢众生一向皆无。不净身业。不净口业。不净意业一切皆无。亦无恶趣烦恼作恶趣业。何以故。因陀幢如来教是众生。令其发心止一切恶。以其善法授令修学。是因陀幢如来国土中。曾得五种乐。所谓一得欲乐。二得出家乐。三得禅乐。四得三摩跋提乐。五得无上菩提乐。彼诸众生虽受其乐而不贪着。譬如蜜蜂但取其味不取花色。彼诸众生。亦复如是。虽受其乐而不取着。譬如飞鸟空中而行不着其空。如是众生虽受其乐而不取着。亦复如是。是因陀幢如来应供正遍知。其佛土中所有众生。无有忧苦唯有喜乐。亦无不苦不乐受。愚痴无故。唯有称心之乐。何以故。彼诸众生本修善故。由彼因陀幢如来本修菩萨行时。现诸相好。令彼众生不作一切恶。安置众生修习善法。彼等次第离诸恶道。安于善处。彼等于一切种不善业。一向悉无。其所作业得果报时。心不欣乐。生苦受者。无有是处。不作恶业不受苦果故。愚痴无故。不苦不乐受亦无。彼因陀幢如来佛土中。一切时恒无恶风暴雨。亦无毒热。彼诸众生时节变易苦。一切皆无。彼因陀幢如来本修菩萨行时。彼佛土中。其诸众生。一切身业智。上首智。顺转演说开示正显。如是一切口业智。上首智。顺转演说开示正显。如是一切意业智。上首智。顺转演说开示正显。如是彼诸众生从彼菩萨闻已。彼诸众生一切身业。一切口业。一切意业智上首智顺转回向。以善业故。愚痴报不生。以其愚痴故。受不苦不乐受。彼诸众生于彼佛土中。苦受不苦不乐受一向皆无。以离愚痴故。彼诸众生生彼国土时。其因陀幢如来教化已。于法敬重。若游行时。思量于法。爱欲于法。染着于法。彼等心生爱欲染着。于法游行时无有苦受。行住坐卧睡寤。乃至无有威仪之苦。彼诸众生在国土中。无恶可顺。以无恶故。无苦可生。于善无著。以是因缘。彼诸众生善顺无故变易苦无。于诸法中不生贪着。是故坏苦不生。亦无怨憎会苦。何以故。由彼众生于一切众生中得住平等心现前。是故无有怨憎会苦。亦无爱别离苦。何以故。由彼众生于一切法不着故。其爱别离苦从爱而生。是故无有爱别离苦。苦苦亦无。何以故。于乐受不生着故。唯有行苦。所谓无常苦。何以故。彼佛唯说第一义故。彼佛住世经恒沙劫。于彼佛刹。无一众生与佛竞论者来生其国。何以故。由彼如来本行菩萨时成熟众生故

佛告诸比丘于意云何。能以下善根。少善根。不善习善根。不善相应善根。非大精进善根。非善趣善根。非善发善根。非善回向善根。可能利益如是等众生能与乐除苦耶。可能净如是广大国土成熟如是多众生耶。诸比丘言。不也世尊。佛复告诸比丘言。于意云何。可以下心怯弱不善根相应心。非精进心。非善集根心。非善趣心。非善发善根心。非善回向心。可能利益如是等众生思惟与乐能除苦耶。可能严净如是广大佛刹成熟如是多众生耶。诸比丘言。不也世尊。佛复告诸比丘言。于意云何。可以下信少信。羸信怯弱信。不善相应信。非精进信。非善集善根信。非善趣信。非善发善根信。非善回向信。能利益如是等众生。除苦与乐耶。能严净如是广大佛刹。成熟如是多众生耶。诸比丘言。不也世尊。佛复告诸比丘。于意云何。可以下戒少戒羸戒。非精进戒。非善集善根戒。非善趣戒。非善发善根戒。非善回向戒。能利益如是等众生。除苦与乐耶。能严净如是广大佛刹。成熟如是多众生耶。诸比丘言。不也世尊。佛复告诸比丘言。于意云何。颇以下精进。少精进。羸精进。怯弱精进。非相应精进。非精进精进。非善集善根精进。非善趣精进。非善发善根精进。非善回向精进。能利益如是等众生。除苦与乐耶。及能严净如是广大佛刹。成熟如是多众生耶。诸比丘言。不也婆伽婆。佛复告诸比丘。于汝意云何。颇以下念少念。羸念怯弱念。非相应善根念。非精进念。非善集善根念。非善趣念。非善发善根念。非善回向念。能利益众生。及思惟与乐耶。及能严净如是广大佛刹。成熟多众生耶。诸比丘言。不也世尊。佛复告诸比丘言。于汝意云何。颇以下定少定。羸定怯弱定。非相应善根定。非精进定。非善集善根定。非善趣定。非善发善根定。非善回向定。能利益众生。思惟与乐耶。能严净如是广大佛刹。及能成熟如是多众生耶。诸比丘言。不也世尊。佛复告诸比丘言。于汝意云何。颇以下慧少慧。羸慧怯弱慧。非相应善根慧。非精进慧。非善集善根慧。非善趣慧。非善发善根慧。非善回向慧。能利益众生。思惟与乐耶。能严净如是广大佛刹。及能成熟如是多众生耶。诸比丘言。不也世尊。佛告诸比丘言。诸比丘实如是。不以少善根少戒少信少精进少念少定少慧。能利益众生。及思惟与乐离苦耶。能严净广大佛刹。成熟如是多众生耶

佛告诸比丘。于意云何。彼时因陀幢如来汝知谁也。如来问已。诸比丘默然不答。当于尔时。东方过如恒沙等诸佛世界。有世界名曰月光庄严。彼土有佛。号高威德王如来应供正遍知。今现住世。文殊师利在彼众中。即知释迦牟尼心念已。即白高威德王佛言。今释迦如来。在娑婆世界说法。世尊。我今往彼见释迦如来。礼拜听法供养恭敬。作是请已。时高威德王如来。告文殊师利。任意而去。今正是时。尔时文殊师利童子。从座而起。偏袒右肩。右膝着地。头面礼高威德王如来。右绕三匝。譬如壮士屈伸臂顷。时文殊师利。在彼月光庄严世界中没。释迦牟尼佛前出。头面接足敬礼如来。却坐一面。白佛言世尊。昔时因陀幢如来者。今即世尊是也。何以故。由是世尊具足不可思议诸善方便。能成熟众生净佛国土。恒不疲倦亦无厌足故。世尊。安置众生住菩萨乘亦无厌足。若有实语人作正语者。胜中之胜。胜中之妙。胜中上首。最胜中最胜言。佛如是者当知释迦牟尼佛真实无异。时文殊师利。而说偈言

  雄猛巧方便　　怜愍诸世间
  现大威神力　　成熟众生故
  已于过去世　　曾作八亿佛
  犹自有神力　　无心取正觉
  六十一三千　　清净佛国土
  浅识不知佛　　牟尼巧方便
  不舍初发心　　彼彼处处现
  更于未来世　　示现无量佛

    伽楼罗王授记品第五

尔时复有八亿六千万金翅鸟王。见诸阿修罗供养世尊及得授记已。于如来所生无等敬信。踊跃欣喜为供养故。化作八亿六千万殿堂。纯以诸天七宝庄饰甚奇微妙。一一殿堂七重钩栏四宝所成微妙第一。所谓金银琉璃颇梨金钩栏者金为寻梁。及作众柱。银为曲鞚。银钩栏者银为寻梁。及作众柱。金为曲棂。毗琉璃钩栏。以毗琉璃。而为梁柱。颇梨为棂。颇梨钩栏。颇梨梁柱。毗琉璃棂。彼诸殿堂。周匝四面。垂七宝铃。所谓金银琉璃颇梨真珠车磲马瑙。其宝精奇微妙第一。是诸殿堂。复以七宝罗网覆上。所谓金网银网毗琉璃网颇梨宝网赤真珠网车磲之网马瑙网等微妙第一。复更化作八亿六千万七宝之盖。微妙奇特。所谓金银乃至马瑙。复更化作八亿六千万七宝妙幢。所谓金银乃至马瑙。青幢黄头。黄幢青头。赤幢白头。白幢赤头。杂色之幢纯色为头。纯色之幢杂色为头。复更化作八亿六千万七宝妙幡。有种种色严净第一。复更化作八亿六千万七宝之帐。所谓金银乃至马瑙宝线织成微妙第一。尔时诸金翅鸟王。持是八亿六千万七宝殿堂。八亿六千万七宝之盖。八亿六千万七宝之幢。八亿六千万七宝之幡。八亿六千万七宝之帐。悉以奉献如来世尊。既奉献已。彼诸鸟王及供养具。于虚空中绕佛三匝。譬如咽罗婆那象王于三十三天。顶戴诸天乘空而游。诣波利质多罗树。彼诸鸟王。持是殿堂盖幢幡帐。飞腾虚空绕佛三匝亦复如是。尔时彼诸鸟王。敬绕佛已。却住一面。曲躬合掌。众共一音。以偈赞曰

  归命出离生死者　　归命救度生死人
  归命无等坚固士　　归命无上无等圣
  愿我当得坚固身　　三十二相自严饰
  复有八十随形好　　唯愿我等如导师
  愿我圆光具威德　　形颜功德皆成就
  愿得第一佛威仪　　令他心净证寂灭
  愿具持戒三摩提　　亦得诸佛上智慧
  愿悉作佛度群有　　如佛今作世导师
  世尊我愿具十力　　亦到十八不共岸
  成佛智慧过世间　　如今如来上中上
  亦知众生无体性　　如幻如梦无所依
  宣说如响如虚空　　如佛今日为众说

尔时世尊。知诸鸟王得敬信已。现微笑相。是时慧命马胜比丘。见佛微笑。以偈问曰

  人中无上胜导师　　非是无事现微笑
  愍世间者为我说　　现此微笑何因缘
  彼诸鸟王已供佛　　宝殿幢幡空中现
  令此天人生希奇　　愿两足尊说是义
  一切大众合掌住　　深心清净皆欣喜
  愿闻金翅未来果　　愿两足尊说此义
  人中最胜若说已　　一切大众皆无疑
  大众离疑得无畏　　如来智能令欣喜
  大众欣喜得无畏　　离诸过恶心清净
  彼众乐闻如来说　　犹如弟子受师言
  愿断大众心所疑　　愿佛摄受令欣跃
  大众欣喜皆来集　　愿说金翅当来果

尔时世尊。以偈答慧命马胜言

  十力真实超一切　　八枝梵声悉具足
  降伏诸根为马胜　　说于金翅未来果
  善哉马胜问是义　　我现微笑愍世间
  谛听彼报以悦意　　心当欣喜除疑网
  鸟王于我设妙供　　为求无上菩提果
  十种智力四无畏　　得彼法故成导师
  复求十八不共法　　此等金翅供善逝
  亦求坚固不坏身　　三十二相八十好
  求佛净戒三摩提　　诸佛境界大智慧
  成就净土度世间　　金翅求此供养我
  彼等信心供我已　　智者能离畜生趣
  当必得生于天上　　此是恶道最后身
  彼等后如恒沙劫　　常生人中及天上
  供养无量诸佛已　　当得作佛伏诸根
  彼佛国土无恶趣　　具足身相离八难
  彼佛同名普端正　　其劫名曰须弥幢
  八亿四千万岁中　　怜愍世间故住世
  彼时一切诸善逝　　住寿佛事皆悉同
  彼佛离热度烦恼　　一一诸佛八十会
  一一会中八亿人　　离于憍慢得自在
  以彼本有金色身　　大力常怀憍慢故
  后成佛时为众生　　除断憍慢转法轮
  彼等过去已曾为　　修极苦行仙人众
  其数八亿六千万　　凡所修行为神通
  彼诸仙人得通时　　叹己苦行为希有
  不犯禁戒具功德　　居住林中生憍慢
  以慢故生金翅中　　以通心故具神力
  戒清净故得见佛　　以慢故忘菩提心
  如是佛授菩提记　　及说金翅本所生
  大众闻已皆欣喜　　喜已皆成菩提器

    龙女授记品第六

尔时九亿六千万龙女。见诸阿修罗伽楼罗供养世尊及授记已。心生欣喜。彼得欣喜踊悦称心。于世尊所起心供养。化作九亿六千万盖。皆七宝成。毗琉璃网以覆其上。赤真珠宝以为网缘。金为盖茎。毗琉璃宝以为盖子。数有百千。杂宝旒苏垂下四面。化作九亿六千万马。青马青色青形青光。诸庄严具一切皆青。毗琉璃宝以为缰鞚。于上虚空中。化作大威德摩尼宝车。于其车上复有宝殿。纵广正等六十由旬。其殿遍覆诸来大众。其殿四面化作九亿六千万众宝旒苏。周遍垂下甚奇微妙。其诸光彩夺人心目。化作宝网弥覆殿上。复有宝铃悬殿四厢。化作七宝鸧鹄白鸽。以次飞行绕殿四面。又复化作九亿六千万种诸龙音乐。时诸龙女乘彼青马。各掷宝盖。于虚空中自然游行。是诸龙女各取乐器奏诸音声绕佛三匝。以天旃檀末。天沉水末。多摩罗叶末。天真金末。及诸龙花。并复化作种种之花而散佛上。复以优波罗花旒苏。种种杂色众花旒苏种种无量杂香旒苏。种种无量杂色之衣。种种无量杂色璎珞。以用散佛广设供养。亦如彼诸阿修罗王。尔时九亿六千万龙女。作音乐时。以佛神力。其声遍满三千大千佛之世界。其中众生闻是声者。于阿耨多罗三藐三菩提。得不退转。于大威德众宝殿中。及宝旒苏众鸟行间。诸宝铃网微风吹击出妙音声。其声和雅甚可爱乐。譬如百伎音乐善巧学人之所击作。所出音声和雅可爱。于彼大威德殿。乃至铃网所出之声亦复如是。此声亦遍三千大千佛之世界。其中众生若闻声者。于阿耨多罗三藐三菩提。亦不退转。尔时彼诸龙女。复更雨于种种天花种种天香。与水俱下。其香花气顺风逆风。不顺不逆皆悉能去。以香水故。于迦毗罗城。纵广正等六十由旬。皆成香泥。其香泥气。遍满三千大千世界。其中众生闻是香气。亦于阿耨多罗三藐三菩提。得不退转。尔时彼诸龙女供养佛已。及九亿六千万盖。九亿六千万马。九亿六千万音乐。一切众宝庄严供具。于虚空中。头面礼佛。右绕三匝。却住一面。曲躬合掌。以偈赞曰

  诸龙妇等有智慧　　心意踊悦生欣喜
  供养释迦牟尼佛　　愿求安隐大菩提
  化作九亿六千万　　宝盖及与妙庄严
  供养善逝善调心　　出离一切诸障碍
  复化九亿六千万　　妙马及与庄饰具
  马与庄严皆青色　　亦复更有青色幢
  彼马一切空中行　　诣于佛所作供养
  龙妇咸有信敬心　　头面顶礼如来足
  于龙宫中化音乐　　为供养故而持来
  来已奉上释迦文　　应受供养大导师
  善逝令彼音乐声　　遍满三千大千界
  无量众生得闻已　　皆悉不退菩提心
  彼诸龙女于空中　　化作一大众宝殿
  纵广由旬有六十　　遍覆十方一切众
  宝名威德炽然光　　普照十方大千界
  彼诸龙女大众前　　净心欣喜供养佛
  生于踊悦无等心　　为求安隐菩提果
  愿令我等当作佛　　利益一切众生故
  我等愿于无量众　　说法度诸烦恼缠
  亦如十力大导师　　现救苦恼众生等
  一切诸法如幻焰　　亦如水沫不坚实
  又如注雨所起泡　　当知诸法无有主
  众生如像亦如影　　如是观察世间已
  唯愿我等为众说　　法性真如及实际
  如佛无过善见法　　虚伪妄相诳愚者
  如幻庄严无有实　　唯能惑乱诸凡夫
  众生于法迷无智　　不知诸法如实性
  导师已见彼彼法　　复能令他众生解
  虚空兴云遍覆地　　见彼空云犹如影
  彼无体实无所依　　亦复如影无有实
  如是众生无体性　　唯能诳惑诸根门
  佛智如是见有趣　　但能诳惑无智者
  世间尊重以此业　　于智慧人作利益
  如来示现无体性　　一切众生真实故
  唯以实法悦预子　　生死泥中作桥梁
  愚痴实法非境界　　由于着声不求义
  以佛无边我归依　　具足示现真实者
  能与愚夫作亲救　　归趣舍宅善知识
  如是为求大菩提　　我等供养尊导师
  愿得作佛觉寤他　　我益世间犹如佛

尔时世尊。知诸龙女得深信已。现微笑相。尔时慧命马胜比丘。以偈问曰

  于世智中胜智者　　最胜导师现微笑
  尊重坚固德如山　　今现微笑非无因
  人中最上胜尊主　　愿为说此笑因缘
  天人龙鬼若得闻　　于佛皆生大欣喜
  世间导师于世闻　　常知一切因缘法
  无有一法佛不解　　因缘种类佛悉知
  唯愿善逝见为说　　如佛所知笑因缘
  一切大众若得闻　　皆生欣喜除疑网
  如来妙法有大利　　此等大众必当获
  大众若得寂定心　　由味妙法利益故
  佛力令断分别已　　唯乐菩提听佛说
  若得闻于笑因缘　　当必成就于佛道
  若人于法情有疑　　其心掉动生苦恼
  现今此会大众是　　不知微笑因缘故
  大众堪能断疑网　　唯愿导师令除灭
  速为众说度我等　　以何因缘现微笑
  谁于今日心清净　　谁于今日降魔怨
  谁于佛所生敬信　　谁于今日供养佛
  唯愿导师大众前　　演说谁有如是力
  我等闻已生喜心　　生喜心已得安乐
  此诸大众咸敬礼　　一切皆有疑网心
  愿说笑因生喜故　　唯愿世尊断众疑
  此诸天人得闻已　　大众当得无疑网
  若得闻于如来说　　一切当得欣喜心

尔时世尊。以偈答慧命马胜言

  善哉善哉慧马胜　　能问如来笑因缘
  见诸龙女供养已　　我愍世间故微笑
  我今为汝说彼果　　离诸过恶至心听
  我今所为现微笑　　汝马胜等听我语
  此诸龙女心无著　　求大菩提修进行
  以智慧修世间空　　决定安住菩提道
  于此无作无受者　　亦无生者养育者
  但有诸法无余事　　其法亦妄如焰像
  以知恩故供养我　　能以智慧知真实
  善哉佛解诸世间　　所谓能见空无主
  彼乐此空善修习　　虽设供养犹如幻
  于胜菩提所发愿　　观彼菩提亦无著
  此以无等供养佛　　亦观众生空寂已
  永离龙道恶趣身　　与彼帝释天中住
  在忉利天极受乐　　尽彼天子寿命已
  无能毁訾彼名称　　复得生彼夜摩天
  居止夜摩天宫时　　具受彼天胜妙乐
  诸佛子等住彼中　　乃至尽彼天寿量
  此诸佛子具受乐　　尽彼夜摩天寿已
  复得往生兜率天　　与彼处天同其类
  为诸天女常围绕　　具受彼天胜妙乐
  心无所著住善道　　譬如莲花水不污
  彼天能以大智慧　　观察一切世间空
  犹如画石字不灭　　彼念不失亦如是
  彼诸天子居彼天　　具受彼中胜妙乐
  于彼善道尽寿已　　当更往生化乐天
  彼得善名无能毁　　为诸天女胜供养
  虽住天宫心无著　　乃至尽彼天寿限
  于彼化乐天宫中　　具受彼天胜乐报
  彼智慧者命尽已　　于一切法得究竟
  往生他化自在天　　作大商主信清净
  住彼天中心无染　　如是住时爱乐法
  彼等居彼天宫殿　　受彼极妙五欲乐
  无愚痴者住善道　　乃至尽彼限寿量
  虽受天欲见其过　　乐求寂定及涅槃
  修习获得禅定已　　命终即生梵天中
  于梵宫中善知禅　　受彼禅果寂灭乐
  智慧无等住一劫　　愿求无上大菩提
  住彼梵宫一劫时　　善住威仪求智慧
  方便以利益世间　　广作无边无有量
  智住梵宫乐在禅　　于禅不着而寂灭
  知着禅乐亦是过　　诸根寂定求菩提
  于一切处心信解　　皆得安住菩萨行
  知诸禅定虚诳相　　唯求寂灭大涅槃
  彼诸佛子于彼中　　求于安隐菩提果
  在彼梵宫心清净　　思利世间善调心
  诸梵天等自然教　　彼说梵教非出世
  唯有诸佛菩提道　　究竟能得出世间
  梵天当时生信已　　发心安住于佛法
  知本梵天自然教　　非是究竟出世道
  于善逝法彼相应　　为于世间说是法
  如彼法眼所说果　　令彼闻者速能知
  彼等住彼梵宫时　　作诸利益世间已
  能令无量那由他　　亿众安住菩提道
  彼于无量那由劫　　当得供养一切佛
  后于未来星宿劫　　诸根寂静当作佛
  诸天人龙阿修罗　　金翅夜叉乾闼婆
  鸠槃茶鬼紧那罗　　一切大众皆欣喜
  彼等一切佛教化　　于佛法中得力已
  皆悉欣喜合指掌　　稽首顶礼于佛足

大宝积经卷第六十三大宝积经卷第六十四

        北齐三藏那连提耶舍译

    菩萨见实会第十六之四龙王授记品第七

尔时难陀优波难陀龙王等。九亿诸龙。见诸龙女设妙供养。及闻龙女得授记已。生希有心未曾有心。作是思惟。乃至如来世尊应正遍知希有未有。以是如来知诸众生机根深信如来。无有少分不见不闻不证如来正法。是其善说能令大众闻已现知无有时节。随机授法必令得果。令诸智者现得证知。乃至女人动转轻躁。智慧浅短。犹得解佛所说深法。况余智者善能安住如来法中诸弟子众。如诸女人欲心增上。嗔心增上。痴心增上。犹能得知如来所说。是故难陀优波难陀龙王。及诸龙等。于如来所生希有心。生未有心。为供养故。遍阎浮提诸山大海。兴云遍覆一切世间。普雨香水以成香泥。彼香泥气。充满三千大千佛刹。其中众生闻香气者。皆不退于阿耨多罗三藐三菩提。于迦毗罗城纵广正等六十由旬。雨赤真珠。遍覆其地。复以无价种种众宝。周匝遍覆尼拘陀园。复以龙华化成妙堂。纵广正等六十由旬。椽柱梁壁皆用七宝。复更化作无量乐器。为供养故击出妙音。于彼龙花微妙堂中。化作九亿种种杂色众花旒苏。悬于堂上。以毗琉璃网覆诸宝柱。以无价宝遍布堂下。其宝柔软。譬如三十三天般筹缄婆罗石。其石之色如毗琉璃。石触柔软如迦遮邻提迦衣。微妙可乐系人眼目。令诸天人爱恋系念。彼诸宝等亦复如是。彼诸种种摩尼宝中。或有出于凉冷光焰。有出青水。有出赤水。有出白水。有出黄水。或复有出杂色之水。或复有出凉乐之风。或有宝珠随诸众生所须之事皆悉出之。或复有宝出于腴泽。或有摩尼堪为明镜。一切大众皆现其中。于迦毗罗大城之中。所出人民随其多少皆现宝中。一切大众皆悉睹见佛及声闻。作此种种神通变化。以彼摩尼宝神力故。于其地中。出于种种杂色宝盖。及以种种杂色宝幢。亦有种种杂色宝幡。复出种种杂花旒苏。亦有种种杂香旒苏。复有种种杂宝旒苏。复出种种真珠旒苏。复出种种杂色龙幡。复出种种众宝铃网。复出种种杂色良马。诸所出者皆是龙力。尔时难陀优波难陀龙王。及九亿龙。驱彼良马随而步行右绕三匝。以妙迦遮邻提迦柔软之宝。而散世尊。于彼堂下地中所出。种种众宝上升虚空。雨于如来及声闻上。复以诸龙无量乐器。于虚空中自然出好微妙音声。供养于佛。尔时九亿诸龙绕佛三匝已。在于佛前合掌默然。念佛功德。瞻仰如来目不暂舍。乐佛功德。深心安住阿耨多罗三藐三菩提故。彼等少时合掌默然。念佛功德已。偏袒右肩。右膝着地。合掌向佛。五体投地。为佛作礼。众共一音。以偈赞曰

  久修威仪百福相　　悲心离垢行具足
  弃舍无尽众宝地　　世尊出于迦毗城
  于六年中修苦行　　如来不得甘露道
  善逝意犹不退闷　　以其久修智慧故
  如来真是天人师　　为世间故修苦行
  世人闻已尚不堪　　况复能以目亲睹
  牟尼过去舍头目　　如圣所集菩提心
  我等闻是不生乐　　由闻如来苦行故
  如佛本作忍辱仙　　为迦利王截手足
  及劓耳鼻不生恚　　我等闻是不能忍
  如佛以身上秤盘　　为鸟归投不舍弃
  我等闻已亦不乐　　如来过去甚勤苦
  何故我等心不乐　　以世尊行极苦故
  于如来所作恶者　　堕恶道时佛复悲
  具足圣慧大导师　　云何能行不害心
  修习道行无疮疣　　唯愿佛说安乐行
  今此龙众已发心　　求于善逝菩提行
  如佛所说悉能行　　唯愿速说菩提道
  此诸龙众甚渴仰　　唯求不死不生处
  愿说如来安隐行　　令此众生易受化

尔时世尊。见诸龙众设其供养。及闻发愿知深信已。佛于尔时现微笑相。诸佛法尔。若现微笑。即于面门。放种种色无量光明。其光遍照上至梵天。照已还来从佛顶入。尔时慧命马胜比丘。以偈问曰

  善哉沙门大牟尼　　非是无因现微笑
  慈悲导师唯愿说　　无等善慧笑因缘
  大众瞻仰求欲闻　　世尊无量功德行
  于笑生疑心不乐　　唯愿法王断众疑
  谁于释迦佛法中　　今生敬信心欣喜
  谁令今日魔波旬　　心意迷乱不欣乐
  谁于今日能恭事　　功德法父大导师
  谁作第一胜供养　　愿释师子上上说
  此诸大众合指掌　　皆悉对佛瞻仰住
  唯愿导师除疑网　　为众演说笑因缘
  大众闻已生欣喜　　能知世尊正法教
  大智世尊令众喜　　随顺正教善安住

尔时世尊。以偈答慧命马胜曰

  深广智慧大众师　　说时梵音具八种
  清净其心离秽浊　　谛听我说笑因缘
  此诸龙王敬信心　　于我设供超一切
  是等为求佛菩提　　利益一切世间故
  悲心增上观众生　　无有导师云何乐
  我云何得大菩提　　成熟众生不疲劳
  深乐寂定具智慧　　乘安乐乘心清净
  于空无相及无愿　　无量劫来久已修
  其心平等观世间　　如佛所得智慧相
  慈悲喜心皆平等　　为令世间安隐故
  第一悲心怜愍者　　当得作佛称其意
  彼等观察世间已　　当成导师号无怨
  彼等当得甘露时　　无有魔怨亦无余
  恒常演说无我法　　一向无有世俗说
  彼诸如来具大悲　　令诸众生入佛智
  是诸善逝说法时　　一切众生皆信解
  彼等世世修道时　　成熟众生不为难
  彼所成熟闻法已　　当得解脱证甘露
  诸闻法者悉解脱　　是诸众生皆端严
  一切众生皆能知　　彼诸如来所说法
  一切鬼神及畜生　　无有不解彼佛语
  一切皆得念法已　　能解如来甘露法
  无有众生闻佛说　　当时不生爱乐心
  爱乐彼佛所说者　　一切皆悉得甘露
  彼时所有受化者　　当得解脱生老病
  及解脱死忧悲苦　　闻佛说已心无垢
  如是释迦牟尼佛　　说诸龙意答佛子
  如彼坚智心中转　　为得无等菩提故
  如来授彼诸龙记　　大众闻已皆欣喜
  大众喜已归依佛　　一切皆悉心寂静

    鸠槃茶授记品第八

尔时复有诸鸠槃茶一亿八千万。见诸阿修罗伽楼罗龙女龙王等。供养如来闻授记已。称其心意。踊跃欣喜。生希有心。得未曾有。如来世尊功德智慧微妙殊胜。得如是等希有供养。不怪不喜。以佛智慧于诸智慧最尊胜故。譬如大海不增不减。何以故。以深广故。如是世尊。得胜供养心无增减。亦复如是。何以故。于一切法无所疑故。尔时一亿八千万鸠槃茶等为供养故。化作一亿八千万盖。皆是七宝之所成就。金线宝盖银线宝盖毗琉璃线众宝之盖。颇梨珠线众宝之盖。赤真珠线众宝之盖。马瑙珠线众宝之盖。车磲珠线众宝之盖。彼诸鸠槃茶于众宝盖悬宝旒苏。有种种色。金线宝盖银线旒苏。银线宝盖金线旒苏。毗琉璃盖颇梨旒苏。颇梨宝盖毗琉璃线以为旒苏。赤真珠盖车磲旒苏。车磲宝盖赤真珠线以为旒苏。马瑙宝盖颇梨旒苏。又复化作一亿八千万众宝之车。亦种种色甚奇微妙。所谓金银琉璃颇梨真珠车磲马瑙。于其车上。复更化作一亿八千万众宝之盖。与车相连。一一宝盖皆有百子。其诸盖茎皆用金银及以颇梨毗琉璃等。于彼宝盖。复化种种宝花旒苏。严饰其盖。所谓金花旒苏。银花旒苏。毗琉璃花以为旒苏。颇梨旒苏。赤宝旒苏。龙珠旒苏。赤真珠花以为旒苏。复以赤真珠网弥覆其上。又复化作鸠槃茶乐出种种声而用乐佛。复更化作一亿八千万众宝色马。调伏骏疾以驾其车。尔时鸠槃茶等各乘宝车。绕佛三匝。以七宝花而散佛上。尔时彼诸鸠槃茶等。从车而下来至佛前。头面礼已。复绕三匝。曲躬合掌。住立一面。以偈赞曰

  不增不减大牟尼　　譬如须弥诸山王
  受此无上供养者　　如来以得无畏故
  观诸众生但有名　　及但有用不取着
  导师以修寂灭定　　是故智者无贡高
  牟尼知世犹如幻　　亦如梦中受欲乐
  复似水月春时焰　　如是观察悉无余
  譬如干城无有实　　于十方求不可得
  其城无实但有名　　佛见世法悉如是
  一切人天所供养　　宝车宝盖及音乐
  幢花旒苏合掌等　　世尊观知如影响
  我等设是供养已　　愿我当来得作佛
  亦愿我知世如梦　　知已说法如世尊
  我等见诸苦恼者　　生老病死之所逼
  愿知无死佛菩提　　说令闻者得解脱
  于诸无智众生所　　愿得菩提为说法
  演说无有垢浊法　　无道众中为作导

尔时世尊知诸鸠槃茶等深生信已。现微笑相。尔时慧命马胜比丘。以偈问曰

  佛非无因现微笑　　不怪一切为希有
  如来不怪而现笑　　我今愿闻此因缘
  一切天人皆有疑　　见佛口中现微笑
  唯愿断除诸疑网　　演说世尊微笑事
  谁于正法得深信　　谁能如法见慈父
  谁佛所赞行供养　　人中胜者我愿闻
  今日谁于有为行　　见其过患能弃舍
  今日谁能住实际　　清净心者我愿闻
  谁能降魔及眷属　　谁能令佛心欣喜
  谁能得深有为底　　我愿得闻断疑心
  一切大众合掌住　　为闻如来笑因缘
  愿断一切众生疑　　两足尊者说彼记

尔时世尊以偈答慧命马胜言

  善哉马胜问是义　　汝于世间大利益
  以汝问笑因缘故　　谛听马胜我今说
  鸠槃茶众供养我　　于寂灭法心得住
  彼等见我不惊怪　　心生希有起愿求
  彼等今日供养我　　其心简择寂灭法
  以深心信起大悲　　于失道者能作道
  愍众生故供养我　　为失道者起慈心
  此等贤智作是已　　得舍鬼身生忉利
  天主恒以慈悲心　　在天数数教导彼
  彼于诸法得无疑　　得为帝释亲眷属
  彼于无量恒沙劫　　一一国土行佛行
  被大弘誓坚固铠　　供养具大正法者
  彼于无量诸国土　　心无疲倦令清净
  利益大众作导师　　当得作佛号不怪
  彼于诸国行行时　　是国人必知成佛
  以此方便未来世　　虽度众生无怪心
  为求无上安隐道　　净诸国土都不怪
  于所作事心无著　　于大菩提亦如是
  所问笑因我已答　　众生疑心皆得断
  大众离疑得欣喜　　以定得知彼供养

    乾闼婆授记品第九

尔时复有三亿六千万乾闼婆众。见诸阿修罗迦楼罗龙女龙王鸠槃茶等。供养世尊闻受记已。称其心意。欣喜踊悦。生希有心。得未曾有。叹言希有未曾有事。乃至如来所说法界无有变异。而示有作善根增长。虽无作者而示作业。彼乾闼婆等于此法中如是知已。于如来所心生尊重。发阿耨多罗三藐三菩提心。彼欣喜已为供佛故。化作三亿六千万头咽罗婆那大龙象王。皆有六牙。一一牙上化作七池。一一池中化七莲花。一一莲花化作千叶。一一叶上化七玉女。一一叶间化七侍女。以天诸宝为庄严具而用庄饰。复执天香而用供养。复于一一咽罗婆那象王头上。化作三亿六千万盖。七宝旒苏悬盖四边。七宝罗网以覆盖上。复于一一咽罗婆那象王头上。化作三亿六千万帐。皆是诸天妙香所成。缯彩旒苏悬帐四边。化作三亿六千万头咽罗婆那大象王已。彼乾闼婆等各乘其象鼓天音乐。于虚空中旋绕如来。三十六匝。以天旃檀末。天沉水末天多摩罗叶末。天真金末。曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。波楼沙花。摩诃波楼沙花。迦迦罗婆花。摩诃迦迦罗婆花。又复化作七宝之花而散佛上。彼乾闼婆等散香花时。是香花气。逆风顺风纵横皆去。复雨种种天妙香水。雨香水时。于迦毗罗城纵广正等六十由旬。皆成香泥。其香泥气。充满三千大千世界。其中众生闻香气者。皆悉不退阿耨多罗三藐三菩提。奏音乐时。其诸音声。遍满三千大千世界。其中众生闻此声者。亦得不退阿耨多罗三藐三菩提。如是一一诸乾闼婆。各于三亿六千万象王头上。设其供养。令诸玉女有作乐者。有作歌者。有作舞者。彼诸玉女作歌舞时。令诸大众一心观望。复有玉女动身手者。散旃檀末者。散沉水末者。广作供养如阿修罗所设之事等无异也。尔时乾闼婆等各乘咽罗婆那大象王头。于虚空中绕佛三十六匝已。各从象下复绕三匝。头面礼佛曲躬合掌。在一面住以偈赞曰

  世尊胜慧出有顶　　自既出已复度他
  一切世间无如佛　　相好光颜极端正
  人中最妙无边称　　示现世间不思议
  不见一法性相异　　而令众生住于善
  无有变异真如法　　但有言说无余义
  无有用事及用者　　虽然佛化诸群生
  不来不去亦不生　　佛能演说如是法
  虽说诸法体性空　　世雄而令修习道
  无有一法能自作　　世间明者说有作
  诸法各各不觉知　　世尊示现一切作
  如车多集众分支　　彼支不知自能作
  其车功用现可见　　佛说诸法亦如是
  诸法各各不相教　　亦不迭互相觉寤
  一切亦复不相依　　法本不生亦不死
  佛为世谛如是说　　世谛诸法不全无
  如世谛法体性住　　如是知已为众说
  世尊如是说诸法　　大悲所作甚奇特
  诸法体性不可见　　如来方便说其性
  我等愿作无边称　　具百福相大导师
  大悲利益诸世间　　愿作世亲如今佛
  我等愿于闇障者　　随顺贪駃欲流者
  渴爱所缠百苦者　　救济度脱如世尊
  我等愿于众苦者　　不见彼岸魔缚者
  走如猿猴轻躁者　　救济度脱如世尊
  我等愿于盲冥者　　六趣往来疲劳者
  于己自坏业果者　　救济度脱如世尊

尔时世尊知彼三亿六千万乾闼婆众深生信已。现微笑相。尔时慧命马胜比丘。以偈问曰

  无边威德现微笑　　导师如是非无因
  愿佛速说此因缘　　断除众生诸疑网
  今见世尊微笑已　　大众皆悉为疑网
  一切愿闻微笑义　　唯愿大悲断众疑
  谁于佛法生敬信　　能得离于诸疑网
  佛知众生深信已　　人天胜者故现笑
  谁有智慧能随顺　　如来所说真如法
  知其念慧解行已　　在大众中现微笑
  一切大众无异心　　唯欲乐闻雄猛说
  合十指掌在首顶　　一心瞻仰如来面
  离诸秽浊无忧虑　　世眼现在故欣喜
  为除一切心疑惑　　愿大悲说笑因缘

尔时世尊以偈答慧命马胜言

  我所现笑为世故　　善哉汝问正是时
  大众善根当增长　　为我微笑授记事
  马胜谛听我所说　　导师所现此微笑
  我今当正说彼义　　汝应欣喜听我说
  乾闼婆王敬信佛　　其心清净生欣喜
  依于实法入法已　　于佛正法生希奇
  诸法寂灭安不动　　此等大众趣实际
  如乾闼城如是入　　供养于我无有等
  如是诸法无有生　　一切亦复不尽灭
  大众思惟如幻住　　未能解了生疑惑
  不可说法方便说　　我以真实故如是
  彼等入我正法已　　乘大龙象供养佛
  观察菩提无生灭　　乾闼婆王供养我
  悲愍愚迷众生等　　是故求大一切智
  彼等发愿当作佛　　令诸愚迷失智者
  入真实法安住已　　使得不死寂灭句
  此等作是供养已　　舍离鬼身心喜悦
  定得往生天宫中　　恒与帝释相亲近
  得值多亿那由他　　供养无垢诸善逝
  从一佛刹至一刹　　于诸佛所得闻法
  彼等修净佛行已　　所得佛土亦清净
  化无量众发道心　　令其增长佛种子
  知诸世间性空已　　亦以此法教导他
  令众安住一切智　　住世无量那由劫
  彼佛同号无边慧　　一一诸佛住于世
  皆悉无量那由劫　　演说佛道令他闻
  如是释迦牟尼佛　　说乾闼婆供养报
  与其授记令得闻　　马胜所问笑因缘
  大众闻已皆欣喜　　知彼佛记甚可乐
  闻是无等佛记已　　皆悉归依释迦文

大宝积经卷第六十四大宝积经卷第六十五

        北齐三藏那连提耶舍译

    菩萨见实会第十六之五夜叉授记品第十

尔时复有八亿夜叉。见诸阿修罗伽楼罗龙女龙王鸠槃荼乾闼婆等。供养如来闻授记已。欣喜踊悦皆得称心。生希有心得未曾有。知佛世尊智慧无尽最尊最胜无所挂碍不可思议。复更得闻法门次第。于佛世尊作导师想。复于佛所作无尽慧想。彼诸夜叉知佛智慧无有尽已。于佛正法生爱乐心。彼于佛法甚爱乐已。为供养故。发勤精进。亦以偈赞曰

  我等今赞利世者　　以佛智力具足故
  无尽无量如大海　　故人师子身无等
  须弥可得知轻重　　虚空可得知广狭
  如来所有智慧力　　一切不能得测量
  知诸众生敬信心　　是故应受皆已度
  于其度者知所趣　　故佛无比亦无等
  随彼所修善恶界　　一切生处受其身
  知彼根信所应受　　故佛无比亦无等
  贪欲恶行嗔恚行　　及以痴行佛悉知
  憍慢嫉妒亦如是　　故佛无比亦无等
  众生于此多所失　　如来善知彼业道
  世尊知彼甚捷利　　故佛无比亦无等
  善逝善见诸世间　　随其方面所失者
  及以语言所丧失　　世尊见彼悉无余
  于六道中几时住　　随彼多少所受苦
  及其所受种种身　　世尊一切悉知见
  随其烦恼力所起　　造作方便及与业
  随业所受种种苦　　导师一切悉了知
  随其所求解脱道　　于佛法中已出家
  精勤修学圣道已　　尽诸烦恼佛悉知
  于佛法中有凡夫　　虽得出家不知义
  诽谤明人微妙法　　世尊亦复善见彼
  彼诸诽谤正法人　　业行所得众苦恼
  随其地狱久近住　　如来亦能具足知
  于佛深得敬信已　　出家受持正法藏
  观察诸法皆悉空　　断除一切诸有道
  不愿一切诸趣身　　观察此身犹如幻
  知诸音声亦如响　　坚住道者佛亦知
  赞叹无等大导师　　我今所得福德聚
  以此福德愿成佛　　亦愿众生成自然

尔时世尊知夜叉众深心信已。现微笑相。尔时慧命马胜比丘。以偈问曰

  人中师子所现笑　　唯愿说其笑因缘
  一切诸佛非无因　　而现微笑人中月
  今此大众皆怀疑　　以见导师微笑故
  唯愿世尊除其疑　　皆令此众得欣喜
  今于佛所得信者　　及知微妙正法者
  其心坚固不动者　　愿佛宣说令彼闻
  此诸大众皆怀疑　　一切瞻仰如来面
  今日当有何等事　　唯愿世尊断彼疑
  今日谁现大神力　　今日谁发大精进
  今日佛共谁亲友　　于此大众愿显现
  善哉牟尼愍世间　　唯愿断除诸疑惑
  天人大众若得闻　　今日必当大欣喜

尔时世尊以偈答慧命马胜曰

  善哉马胜汝所问　　今当大利诸世间
  由汝能问笑因缘　　故叹汝善解我意
  我今尽当答彼义　　汝当一心专谛听
  知诸夜叉心意已　　我为世间现微笑
  夜叉诸众心敬信　　以知菩提寂灭故
  叹佛真实功德已　　发心趣向大菩提
  为知诸法空寂故　　除遣一切所有相
  于诸趣中愿舍已　　发心趣向大菩提
  以禅定力知诸阴　　但是世谛不取着
  不着诸有如莲花　　发心趣向大菩提
  于诸有中障碍事　　彼见空故不为缚
  知佛菩提无上已　　彼等能修菩提行
  诸生老死皆悉空　　此即无上菩提道
  知法自性空寂已　　能得安隐大菩提
  知阴自性空寂已　　寂静菩提性亦难
  所修菩提行亦空　　此智能知非凡了
  能观智慧性自空　　所观境界皆寂灭
  知者亦空知是已　　是人能修菩提道
  当知空亦性自空　　相愿亦复无体性
  若有人能如是知　　是人能修真实行
  天人大众闻是已　　心生欣喜获利益
  一切于佛敬信已　　心住菩提寂静句
  今此殊胜供养已　　夜叉之众心清净
  此诸智者舍鬼道　　于善趣中久受乐
  彼于未来多亿佛　　以神通力一念中
  于多佛土修供养　　即于佛所获得忍
  于诸世界不起相　　智者能以神力往
  观此世间犹如化　　智者游行无所著
  此等勇猛供诸佛　　当得无上大菩提
  亦得无上净佛土　　其中当度无量众
  彼等当成世间解　　一切同号无边智
  名闻十方寿千劫　　寂灭智慧寿命等
  彼等所有声闻众　　犹如静夜诸星宿
  彼悉易得大菩提　　一切无有苦难事
  天人大众闻是已　　为于菩提心踊悦
  其心坚固发精勤　　以精进力持诸行

    紧那罗授记品第十一

尔时复有八亿紧那罗众。大树紧那罗王以为上首。见诸阿修罗伽楼罗龙女龙王鸠槃荼乾闼婆夜叉等。供养如来及闻授记已。甚生希有未曾有心。作是思量。此实希有未曾有事。以其众生不可得故。无命者故。无生者故。无有人故。无摩那婆故。无养育故。无寿者故。无有我故。亦无我所故。以诸阴故名为众生。一切诸阴亦不可得。以其界故名为众生。一切诸界亦不可得。以有入故名为众生。一切诸入亦不可得。以有业故得有果报。而彼行业亦不可得。无上菩提亦不可得。一切菩萨亦不可得。一切诸佛亦不可得。世尊虽尔而复与诸菩萨授记。以何义故。如来与诸菩萨授记示其名号。显现业报说其当来。菩萨大众复显诸佛神通之力。又复说于正法之力。亦复显现庄严佛土。宣说众生有业有报。又复说于清净佛刹。示显菩萨游诸佛国从一佛土至一佛土。复演菩萨往彼供养。亦说供养殊胜神变。又列供具微妙希有。又复说于经若干劫当得作佛。其佛住世经若干劫。其佛当有若干声闻。彼佛灭后正法住世经若干劫。何故如来舍诸众生入般涅槃。尔时大树紧那罗王。生此疑已。与八亿紧那罗众。从座而起偏袒右肩。右膝着地。合掌向佛。以偈问曰

  我等闻佛所记已　　甚生疑惑大智慧
  既说授记复言空　　我于二说不能解
  既说空寂离自性　　法界平等无变动
  而复如来受供养　　此事云何众中月
  佛既说于无有生　　而复说发菩提心
  于无量智二种说　　此言秘密我不解
  云何言灭不可得　　而人师子说有死
  唯愿如实为记说　　除断我疑令无余
  云何佛说犹如幻　　又复显示生天中
  于释师子如是说　　此秘密教我不解
  佛说诸法无所依　　而复说依善知识
  此是世尊秘密语　　我实不解人中雄
  云何说于无所堪　　复教众生修诸业
  降伏怨敌天中尊　　秘密之说我不解
  云何佛说性自空　　复言观空得解脱
  我今于此不能解　　愿无边智断我疑
  云何佛说事尽灭　　复说诸法性寂灭
  我今唯愿无等等　　开显此等秘密说
  云何端正修伽陀　　显示诸法如虚空
  而愚痴人毁谤法　　死必堕于大地狱
  大雄恒说诸天道　　又复说于诸余趣
  既言此等由作业　　复道无有作业者
  不可胜者所宣说　　种种差别不可知
  我今于此生疑惑　　唯愿世尊见除断
  既言善业无可集　　复说修行得菩提
  沙门法王如是说　　此亦我等不能解
  云何说法不可尽　　而言谤者罪可毕
  无量智慧愿开示　　我于是中大有疑
  如来既说真际法　　复言颠倒及施等
  无翳净眼灭罪者　　此义唯愿为我说
  余无有能为我等　　宣释如是所疑事
  唯有如来能断除　　是故我敬一切智

尔时世尊闻大树紧那罗王等问诸疑已。以偈答曰

  汝言说空复授记　　于此二事不能解
  诸法若是不空者　　佛不为其说授记
  以何因缘如是说　　诸法若有体性者
  一切常住不可转　　彼应不减亦不增
  诸法体性本自空　　犹如平正清净镜
  能现一切诸色像　　如是当知一切法
  法界无有变异相　　汝于一切供养物
  一一诸分当观察　　何等分中而有相
  法界常住无变异　　智者应当如是观
  诸凡夫人悉迷惑　　无智慧故不能解
  汝言佛说无有生　　复说发心为难解
  汝等今当一心听　　十力所说秘密义
  凡夫没溺生死河　　亦复系心着彼处
  心常怀于想颠倒　　故受生死诸苦恼
  从本已来未闻法　　我若为彼定说者
  凡夫愚人于此法　　转复增长诸疑惑
  彼闻菩提胜利益　　其心专注于彼果
  其心又复生味着　　自然胜智无能过
  汝言无灭复有死　　此二我今不能知
  于此一心应谛听　　我当为汝真实说
  为彼计常诸众生　　是故如来说于灭
  恒见诸有皆衰坏　　无有一法是常者
  汝言诸法犹如幻　　复言生天怀疑者
  学人凡夫善趣等　　是法不定故如幻
  如汝所言无有依　　复言依止善知识
  欲求弃舍依止故　　善友为说无所依
  汝言毕竟无堪能　　复言有作我不解
  当观车为众分成　　亦观车有所作事
  若复有人着于我　　亦复取于我所为
  我为是等说无堪　　虽复如是非无作
  汝言一切性自空　　复疑观空得解脱
  颠倒愚痴无智者　　不能了知体性空
  从于妄想分别生　　虚妄攀缘故被缚
  为化如是众生故　　善逝说于性非有
  如汝所说事尽灭　　一切诸法性亦灭
  迷惑无智诸众生　　妄分别故生渴爱
  譬如渴者见阳焰　　以忆想故增长渴
  愚人复为虚妄害　　于无所有起分别
  渴者妄生见水想　　阳焰之处水本无
  妄想所害诸众生　　于诸不净起净想
  愚痴凡夫爱所缚　　彼秽恶中性无净
  譬如阳焰似水相　　彼中体性实无水
  如是身中无净色　　身色亦复性非净
  愚痴凡夫颠倒见　　妄作净想而被缚
  虽说诸法如虚空　　亦说谤者堕地狱
  愚人闻之生怖畏　　智者虽闻心安隐
  世间体性自空寂　　愚痴无智起我想
  彼等若闻性空教　　怖畏不得更受生
  彼等毁谤妙空法　　皆由计着我见故
  如人系缚于虚空　　是无智人堕地狱
  我本所说诸善趣　　及为世间说余道
  说有作业而不失　　亦夺其执有作者
  一切诸趣犹如梦　　我为汝说如是知
  梦中无有去来相　　颠倒见者着去来
  我既演说有作业　　十方推求无作者
  譬如猛风吹诸树　　其树相触则火出
  其风及树不作念　　言谓我等能出火
  虽复如是而火生　　当知有业无作者
  汝言福德无积聚　　复云善得菩提果
  我今真实为汝说　　汝当专谛至心听
  譬如世人得长寿　　其命至于百余岁
  然彼岁数无聚积　　一切缘集亦如是
  汝言诸法无有尽　　复言我说业可毕
  观空法者无有穷　　随世法故业有尽
  我虽说有实际法　　颠倒亦非实际外
  颠倒愚痴众生辈　　不能了知真实际
  紧那罗王当谛听　　为具智慧勤进者
  一切诸相皆一相　　所谓无相应当知
  若能解入于一字　　我为智者说菩提
  一切诸法皆无作　　此说阿字总持门
  一切菩萨之所行　　无边之相我已说
  此亦能入一切法　　所谓阿字总持门
  一切诸法皆寂灭　　示阿字门令得入
  树紧那罗应当知　　此亦阿字总持门
  一切诸法无分别　　入此法门已宣说
  紧那罗王应当知　　此亦阿字总持门
  一切诸法无自性　　示阿字门令得入
  树紧那罗应当知　　此亦阿字总持门
  一切诸法无有边　　以阿字门说诸法
  紧那罗王应当知　　此亦阿字总持门
  尽无尽法我已说　　应说一切法无尽
  一切十方诸如来　　已说无尽总持门
  一切诸法无有门　　物无有故现非有
  此亦即是总持门　　由是能入阿字门
  于诸不可思议法　　诸佛依实能显示
  树紧那罗应当知　　此亦阿字陀罗尼
  一切诸法无所趣　　我为智者说菩提
  此亦即是总持门　　是阿字门应当入
  一切诸法无有来　　若不修者则不得
  此亦是其总持门　　是阿字门应当入
  诸法假名皆当有　　推其自性不可得
  此亦是其总持门　　是阿字门应当入
  一切诸法无自性　　推其自性不可得
  此亦是其总持门　　是陀罗尼佛所说
  一切诸法不可得　　以法自性无故然
  此亦是其总持门　　是阿字门应当入
  树紧那罗应当听　　一切诸法离思念
  此亦是其总持门　　是陀罗尼善逝说
  诸佛世尊已显示　　法无实故无障碍
  此亦是其总持门　　当入阿字陀罗尼
  一切诸法无障碍　　无有能障诸法者
  此亦是其总持门　　入阿字门我已说
  一切诸法无有生　　智者当知唯一相
  彼一切法无生者　　当知是法无有名
  一切诸法无有生　　其生本来不可得
  此亦是其总持门　　是阿字门应当入
  若法无实无生者　　不可睹见不可示
  诸法自性不可得　　是故无有能见者
  一切诸法无有比　　是故一相无有相
  譬如虚空无有等　　一切诸法亦复然
  一切诸法无增减　　非一非二非焦恼
  亦非是冷复非热　　以非有故不可见
  无有曲相及直相　　亦复无有明闇相
  亦无见闻诸相等　　是无所有陀罗尼
  非是谄曲非正直　　无有卷舒诸相等
  亦无嗔恚及欣喜　　复无起作与寂灭
  无有入相及出相　　无进无退无来往
  亦复无眠及无寤　　离觉知相应当知
  非是其眼复非盲　　无有能见及暗障
  亦无开相及闭相　　非是调伏非不调
  非是掉动及止息　　亦非世间非涅槃
  非是真实非虚妄　　如是当知佛境界
  为欲调伏世间故　　断除汝疑我无疑
  第一义中无人能　　除断一切他疑网

尔时大树紧那罗王。闻佛说于总持之门。心大欣喜。既欣喜已发勇猛心。即时化作八亿重阁。此诸重阁或在树上。或莲花上。或在山上。皆是七宝之所庄严。彼诸重阁。皆以种种众宝之盖种种宝幢。而用庄严。复以种种宝花旒苏。种种杂色缯彩旒苏。而为庄饰。尔时大树紧那罗王。并及八亿紧那罗众持香山中所有水陆一切诸花。以散佛上。既散佛已。一一各升七宝重阁。绕佛三匝。复以水陆所有诸花。重散如来复绕三匝。尔时大树紧那罗王。及与八亿紧那罗众。从重阁下复绕三匝。顶礼佛足一心合掌。瞻仰世尊目不暂舍。却住一面。思念如来过去现在无量功德。尔时世尊知大树紧那罗王及八亿众深心乐欲。现微笑相。尔时慧命马胜比丘。以偈问曰

  善逝非是无缘笑　　天人所供如实说
  众睹佛笑悉怀疑　　众见最胜如初月
  妙色世尊谁今日　　于无二法起胜慧
  我于今日怀疑惑　　唯愿人尊除我疑
  谁于佛法得净心　　如来由彼现微笑
  唯愿如来为记说　　言说中胜断我疑
  是时一切诸大众　　若闻佛说皆欣喜
  愿除彼等诸疑惑　　如佛所教皆能行
  是故最胜两足尊　　除断疑惑为记说
  愿为紧那罗王等　　及为一切诸众生

尔时世尊复以偈颂答马胜言

  善哉马胜知时问　　我今为汝分别说
  由汝问故我显示　　众人当得佛功德
  汝当清净专一心　　听希有事勿乱意
  所谓善逝最胜智　　无有障碍大知见
  紧那罗王设疑问　　为利一切诸众生
  我今说彼当来果　　谛听我当断汝疑
  树紧那罗八亿等　　王及臣民诸眷属
  是等于我供养已　　从此命终生天上
  从此已后九亿劫　　流转在于人天中
  具足修习五神通　　得智自在心自在
  彼于那由他佛刹　　是人师子遭化生
  身处天宫而不动　　恒受禅悦安隐乐
  彼于九十千万劫　　在于人天流转已
  各各自于佛刹中　　皆得成于无上道
  其劫号曰常照曜　　于彼劫中成佛道
  此皆一生补处人　　彼智慧者当得佛
  彼佛国土无一人　　非是修行成熟者
  皆是一生补处人　　无求声闻二乘者
  一切皆是大菩萨　　为世明者悉生彼
  悉是一生补处人　　后当皆得成佛道
  彼土诸大菩萨众　　安住弘誓大愿中
  我于无量诸佛刹　　皆悉修治令清净
  彼菩萨愿甚广大　　于长夜中善思量
  以其清净信乐心　　各自修治已佛刹
  彼诸佛土妙庄严　　远离一切诸烦恼
  其地遍有诸宫林　　解脱一切诸恶道
  所有诸过及八难　　彼佛国土悉皆无
  既修清净佛刹已　　众生便即易调伏
  如是世尊天中天　　为紧那罗说授记
  彼时一切诸大众　　闻已心皆大欣喜

大宝积经卷第六十五大宝积经卷第六十六

        北齐三藏那连提耶舍译

    菩萨见实会第十六之六虚空行天授记品第十二

尔时复有八万虚空行天。见阿修罗伽楼罗及龙女龙王鸠槃茶乾闼婆夜叉紧陀罗等。供养如来并闻授记。皆大欣喜踊跃无量。于佛法中深心爱乐。为供养佛故。起勇猛心。彼虚空行天。于迦毗罗城外。周遍八方六十由旬。雨曼陀罗花遍布其地。至于人膝。雨曼陀罗花遍布地已。持供养佛。绕佛三匝。即以偈颂。而赞佛言

  诸根寂静微笑面　　救护一切诸众生
  善逝具足大慈悲　　故为世尊人师子
  如来大众皆安住　　于佛法中及涅槃
  导师世尊胜妙足　　我今头面而顶礼
  如十五日月盛满　　世人皆礼星中月
  如是一切诸天众　　睹佛笑面咸敬礼
  积集无量大福聚　　亦复成就智慧身
  具足无量大威德　　故我顶礼世间亲
  具足十力功德山　　于谛无畏离三垢
  成就十八不共法　　明见无疑说中胜
  具足三十二种相　　八十种好而自严
  其心胜上如帝幢　　故我顶礼无等等
  已能究竟持戒力　　禅力决定不倾动
  执持最上智慧剑　　最胜勇健降天魔
  于智慧力到彼岸　　调御声闻心无吝
  其心寂静游诸方　　度脱一切诸天人
  世尊人中胜师子　　得于最上寂灭法
  惟然十力愿我等　　亦当得此胜妙法
  愿我亦当天人中　　为诸世间所信乐
  愿如世尊等无异　　了知众生心乐欲
  愿我得利诸世间　　以怜愍心大悲心
  堕生死海苦众生　　愿我皆能得度脱
  愿我于诸天人中　　得作无上大导师
  我当解脱诸有趣　　为百苦逼诸众生

尔时世尊知虚空行天深心信乐已。即便微笑。时马胜比丘。即以偈颂。而问佛言

  佛牟尼王非无缘　　三界照明现微笑
  唯愿十力为我说　　为何众生现喜相
  见佛如来最胜面　　现微笑相令众喜
  一切大众皆怀疑　　愿闻佛说笑因缘
  愿大导师速为说　　微笑因缘利益事
  愿为除断众疑网　　沙门中王为宣说
  孰能令佛现喜笑　　谁于佛所上供养
  令谁能达生死底　　愿人师子除我疑
  谁于今日动魔宫　　令魔狂乱心不安
  谁于今日令天众　　悉皆欣喜大踊跃
  唯愿为我速宣说　　除断一切世疑网
  大众若得闻佛说　　一切皆悉大欣喜

尔时世尊即以偈颂答马胜言

  马胜汝今请问我　　虚空行天受记事
  汝今问我大利益　　无量世间诸人天
  十力师子若无问　　不得为说佛子记
  汝于今日问如来　　广利一切世间故
  是空行天于我所　　以欣喜心供养我
  过于阿僧祇劫数　　灭除烦恼得成佛
  从于此间终没已　　便即生于天胜处
  于无量亿诸佛所　　悉知香花修供养
  于彼佛所发道心　　亦复增进菩提意
  以诸无量胜妙偈　　赞人师子自然智
  此等当于未来世　　无量无边诸佛所
  以胜香花而供养　　亦以妙偈而赞佛
  那罗延身菩萨等　　供养赞叹诸佛已
  于当来世欣喜劫　　得成最胜无上智
  其佛号曰花幢尊　　名称普闻无讥毁
  彼等八万天神众　　皆同一劫得作佛
  彼佛刹中无地狱　　亦无饿鬼及畜生
  彼土亦无修罗趣　　无有一切八难等
  此空行天成佛时　　彼土一切诸人民
  彼诸众生寿无量　　果报犹如忉利天
  其国不闻恶道名　　何况而有作恶者
  彼时众生皆如法　　一切悉是调伏众
  彼佛度人无量亿　　其数过于恒河沙
  为说无依无著法　　十力度脱彼众生
  彼佛入般涅槃已　　广布舍利起佛塔
  彼佛一一诸舍利　　于中皆现佛身相
  名称无毁诸身分　　为彼众生示神变
  无量亿数诸众生　　皆发无上菩提心
  导师如是智方便　　为彼空行天授记
  一切大众闻记已　　皆悉欣喜大踊跃

    四天王授记品第十三

尔时九万四天王天。见阿修罗伽楼罗龙女龙王鸠槃茶乾闼婆夜叉紧陀罗等。供养如来并闻授空行天记。皆大欣喜踊跃无量。于佛法中深心信乐。譬如有人乘于瓦船入于河中。心作是念。如此瓦船。不久当坏。未没以来。可速度岸以免水难。如是九万四天王天亦复如是。睹佛威神。为得佛法故。起深信乐。发勇猛心。供养如来。尔时四天王天并四天王。变化九万七宝妙帐。杂色种种端妙希奇广大严丽。其中多有赤真珠帐。火珠宝帐。琉璃宝帐。天金色帐。金刚珠帐。化作如是九万七宝帐已。于虚空中绕佛三匝。又复化作九万天乐。于虚空中亦复旋转绕佛三匝。又复化作曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。迦迦罗婆花。摩诃迦迦罗婆花。持此化花。而散佛上。复绕三匝。即以偈颂而赞佛言

  诸天有九亿　　悉于导师所
  皆一心合掌　　愿乐佛功德
  无掉亦无没　　无贪亦无悔
  无举亦无下　　故礼两足尊
  断除诸有种　　亦灭无明闇
  拔除烦恼刺　　能摧我慢山
  佛善拔毒箭　　能灭诸疮疣
  善修不逸行　　身圆满无减
  灭除诸烦恼　　解脱一切缚
  断除诸结使　　出离诸愦闹
  空及无相法　　是佛之所行
  一切诸有中　　其心无愿乐
  除断渴爱根　　弃舍无明闇
  于诸四颠倒　　悉皆能远离
  佛能知实际　　世间无知者
  凡夫闻生惧　　如鹿怖猎师
  堕身见众生　　于空不能知
  无明所覆蔽　　着世间系缚
  如实见真如　　观世犹空拳
  为世显实智　　由彼获净眼
  显示诸阴空　　名色亦复然
  界法体非有　　诸入亦如是
  此法及余法　　以名字而说
  此名字诸法　　佛说悉皆空
  譬如大幻师　　化作种种像
  无众生施设　　无命亦无人
  如是诸阴界　　诸根十二入
  皆从幻化生　　如来作是说
  譬如善画师　　画作白象身
  枝节皆相似　　高下亦复然
  实无高下相　　但惑愚者眼
  是法界平等　　愚者自迷惑
  佛皆为显示　　如掌庵罗果
  智者不迷惑　　善学诸佛教
  如来大智慧　　为世间智炬
  转于妙法轮　　教化诸群生
  当愿开觉我　　无上寂菩提
  转于妙法轮　　如佛今所转
  我等于世间　　迷失道路者
  当为说妙法　　如今佛所说

尔时世尊。知彼四天王天深心所念。即便微笑。其佛口中。出于种种五色光明。尔时马胜。即以偈颂。问如来言

  佛非无因缘　　而现微笑相
  大雄佛世尊　　愿为说笑缘
  睹佛现微笑　　一切诸会众
  悉怀大疑惑　　人尊应当知
  谁今坏魔众　　谁今得除疑
  谁于法决定　　唯愿人尊说
  谁今得供佛　　谁奉佛教行
  此众皆怀疑　　愿导师为说
  两足尊说记　　众生若闻已
  悉皆除疑网　　唯愿导师说
  复令诸众生　　依于种智道
  速逮得菩提　　是故应说记

尔时世尊。复以偈答马胜言

  善哉汝马胜　　为众故请佛
  其微笑因缘　　谛听为汝说
  为愍诸世间　　当一心专听
  诸天满九万　　悉皆住我前
  以清净信心　　已曾供养佛
  复以偈赞叹　　了知诸空法
  于法得决定　　安住我法中
  此等诸天众　　曾供八亿佛
  复于当来世　　无量亿佛所
  供养彼诸佛　　求于无上道
  于无量亿佛　　若不供养者
  彼于菩提树　　终不坐取证
  彼等当来世　　得成于佛道
  号名曰大持　　于世间最上
  彼诸世间灯　　各有声闻众
  八十众会集　　知见无障碍
  彼等成佛已　　彼土诸众生
  一切皆寿命　　具足八亿岁
  彼佛无量智　　无数亿比丘
  皆远尘离垢　　悉住最后身
  彼佛灭度后　　为彼功德者
  庄严彼佛刹　　遣作无量塔
  彼无量千众　　及百那由他
  供养彼塔庙　　利益世间人
  或发菩提心　　或有证涅槃
  彼佛灭度已　　正法久住世
  经于八亿岁　　无量那由他
  彼诸法王子　　受持护法故
  四天王天众　　彼佛授记已
  为利益世间　　成熟众生故
  大众得闻已　　心皆大欣喜
  踊跃无有量　　奉顺如来教

    三十三天授记品第十四

尔时复有八亿忉利诸天。其天帝释最为上首。见阿修罗伽楼罗龙女龙王鸠槃茶乾闼婆夜叉紧那罗虚空行天。乃至四天王天。供养如来及闻授记。皆大欣喜踊跃无量。于佛法中深心信乐。深信乐已。尔时帝释及忉利天。起勇猛心。供养如来。即便化作八亿七宝重阁。种种杂色端严殊特精妙希奇。皆悉垂布赤珠璎珞琉璃璎珞杂璎珞火珠宝璎珞。一一重阁皆有百级庄严幢门。一一级中。皆悉复有四小重阁。庄饰窗牖及师子座幢幡帐盖宝铃罗网。有天童女端严第一。侍重阁所及师子座。击诸天乐。又复化作八亿善调马车。天庄严具而严饰之。所谓宝幢幡盖及诸音乐。于一切迦毗罗大城。周遍纵广六十由旬。散曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。迦迦罗婆花。摩诃迦迦罗婆花。波卢使迦花。摩诃波卢使迦花。遍布其地。至于人膝。尔时帝释又复化作八亿伊罗龙象。一一龙象有八亿头。一一象头各有六牙。一一牙上有七花池。一一池中有七莲花。一一莲花皆有千叶。一一叶中有七天女。一一天女有七侍女。种种庄严。于重阁间安置龙象宝车随后供养如来。天重阁上雨天栴檀末。天沉水末。天真金末。雨天曼陀罗花。摩诃曼陀罗花。曼殊沙花。摩诃曼殊沙花。波卢沙花。摩诃波卢沙花。迦迦罗婆花。摩诃迦迦罗花金花银花。毗琉璃花。种种杂色波吒梨花如是化作一切种种胜妙宝花而散佛上。彼天童女或作音乐。或歌或舞。或动其身。如阿修罗中广说。又复化作八亿善调马王。种种庄严而乘其上。复以种种天诸供具。而散佛上。复有八亿诸天音乐。在虚空中自然而作。复于八亿宝车之上。一一各有一化天女。彼八亿天女或歌或舞。或作音乐。或动其身。如修罗中广说。彼伊罗龙王头中。所化天女悉作音乐。如阿修罗供养中广说。尔时八亿天女悉供养佛。尔时彼八亿天。作如是念。是化天女供养如来。一切诸法亦复如是。如佛所说。彼知一切法如幻化已。于诸法中无有疑网。彼诸法中得无疑已。绕佛三匝。顶礼佛足。却住一面。彼于诸法知如幻已。亦知自身同于幻化。知彼供养及以如来亦同于幻。佛所说法亦复如是。于诸幻法得无疑已。即以偈颂。而赞佛言

  此诸化人设供养　　一切诸人亦复然
  帝释天等及诸法　　一切悉皆如幻化
  如来导师亦如幻　　声闻众从法化生
  于佛所说悉无疑　　能解如来所说记
  如来世尊所说法　　愚痴凡夫不能了
  如来所说诸法等　　一切悉皆犹如幻
  若诸学人及无学　　佛弟子众调伏者
  此等亦复如幻化　　我于此法得无疑
  世尊若人乐寂默　　独一无恼如骐驎
  此等一切悉同幻　　我于此法亦无疑
  若行佛行菩萨行　　利益众生不放逸
  彼是菩萨如来子　　一切悉皆如幻化
  善逝导师自然智　　十力大悲智无量
  智慧自在世间最　　彼佛如是亦如幻
  如佛世尊所说法　　清凉寂静无所依
  得涅槃法及涅槃　　彼等亦复犹如幻
  善逝如法无所有　　一切犹如幻化性
  于此佛法及智慧　　我等于中悉无疑
  我等常愿得如佛　　见一切法亦如幻
  我等行此佛境界　　愿得成佛无有疑

尔时世尊。知八亿三十三天深心信乐已。即便微笑。尔时慧命马胜。即以偈颂。请问佛言

  名称无比具诸德　　如来现笑非无因
  如来今日为何笑　　唯愿为说除我疑
  众见如来现微笑　　见已众皆怀犹豫
  唯愿除彼众疑惑　　令众勿怀诸疑网
  彼诸天众皆欣喜　　赞叹如来及供养
  如来现笑今为谁　　愿佛为说令众喜
  诸德清净犹如月　　应供养者愿为说
  如来所说彼若闻　　此等欣喜得成佛
  如此诸天大众等　　知一切法犹如幻
  诸天修学无障碍　　唯愿十力说此事
  一切大众若除疑　　以欣喜心修菩提
  起增上欲不下劣　　众闻即发勇猛心

尔时世尊。以偈颂答马胜言

  马胜汝今问如来　　善合时机大利益
  佛知天众欣喜已　　我现笑缘今当说
  汝为天众问笑因　　今大利益诸众生
  我今为汝说笑因　　以清净心善谛听
  如是诸天大众等　　知一切法犹如幻
  无量无碍智见慧　　当来离闇得作佛
  过去流转生死中　　曾供诸佛如恒沙
  于彼佛所数修习　　一切诸法犹如幻
  今复于我设胜供　　亦知诸法同幻化
  此于佛法深信乐　　当来之世必成佛
  于此佛法所作福　　无有失坏及障碍
  天众于我供养已　　复知诸法犹如幻
  当来世近住劫中　　得成最胜说中胜
  彼胜福者皆同号　　名因陀罗幢王佛
  彼佛宣说如幻法　　度脱无量亿众生
  是故汝等舍放逸　　修一切法应如幻
  是不逸者我所化　　为满菩提分法故
  精进由如救头然　　速求寂灭胜菩提

    夜摩天授记品第十五

尔时复有四亿夜摩天众。见阿修罗伽楼罗龙女龙王鸠槃茶乾闼婆夜叉紧那罗虚空行天四天王天忉利天等。供养如来并闻授记。皆大欣喜踊跃无量。尔时夜摩天众。知佛如来以无碍智授彼记已。即于佛法起信乐心。起信乐已即作是念。如是佛法甚奇微妙。若证佛法者。无有不知无有不见。无不简择无有不证。于已生未生现生。或已灭当灭现灭。若业及报。皆如实知。甚奇如来能知世谛及第一义。善知此二更无有余。彼佛世尊于其空法善能知见。善知简择善证相应。故名萨波若。何谓世谛。一切世俗生死所行。于此诸法悉能晓知。第一义者无有言说。无有知者。非心所行。以无知故。无能说者。无显示者。无开说者。无有闻者。以无说故。亦无知者无生无示。无有见者。无有施设。无有取着。无有觉知。无有能到亦无所到。无能亲近。无能恻量。无有建立。无有弃舍。无有所作。亦无能作。无誉无毁无利无衰。无称无讥无苦无乐。非色非非色。非数非非数。非明非非明。非有烦恼非离烦恼。非世间非涅槃。非觉非观。非进非退。无动无作。无有戏论。过诸戏论。所说色相不可得。受想行识亦不可得。眼相不可得。耳鼻舌身意诸相亦复如是。色相不可得。声香味触法相不可得。眼识相不可得。耳鼻舌身意识亦不可得。眼触相不可得。耳鼻舌身及意触相亦复如是。眼触生受亦不可得。耳鼻舌身意触生受亦复如是。色思觉相亦不可得。乃至法思觉相亦复如是。意相不可得。空相不可得。地界水界火界风界识界亦不可得。欲界相不可得。色界相不可得。无色界相不可得。有为相不可得。无为相不可得。如是等若彼彼法言说无能说者。如是如是法名不可说法也。佛法最胜无闻。愚痴凡夫众生不能知故。闻已惊怖。彼于佛法心生怖畏。于一切智智便即退失。诸天世人应当怜愍。如此众生常处生死恒为苦切。尔时夜摩天。观诸世间烦恼众生已。为得佛法故。为供养如来故。起勇猛心所设供具。过忉利天而供养佛。供养佛已顶礼佛足。右绕三匝。却住一面。尔时夜摩天。即以偈颂。而叹佛言

  佛见诸阴皆空寂　　于其界入亦复然
  诸根聚积皆离相　　如来如实悉了知
  世间智者于实法　　不从他闻自然解
  所谓世谛及真谛　　离此更无第三法
  如来悲愍于一切　　为利世间说俗谛
  如来宣说于世间　　为诸众生显六趣
  地狱畜生及饿鬼　　人天之道及修罗
  下劣之家及胜家　　所有贫家及富家
  奴仆之属及婢使　　男女等类及二根
  所有世间诸六道　　佛无比身悉已说
  观于世谛诸法已　　佛为利世故宣说
  众生乐着于生死　　不能离于世八法
  所谓利衰及毁誉　　所有称讥及苦乐
  得利便即生欣喜　　失利心即生嗔恼
  余如所说应当知　　世间皆随此八法
  于俗谛中说真者　　彼颠倒慧应当知
  不净乐中说乐净　　于无我中说为我
  无常法中说为常　　住此相中而取着
  闻于如来所说教　　恐怖诽谤不信受
  诽谤如来实教已　　坠堕极苦地狱中
  凡愚贪求世乐故　　转受无边百种苦
  若有于其佛法中　　如实观察不颠倒
  弃舍诸有入涅槃　　犹如蛇脱其故皮
  一切诸法体性无　　空无有相第一义
  若闻此法生爱乐　　必得无上胜菩提
  如来如实说此法　　除断天众诸疑惑
  悉发无上菩提心　　为度一切众生故
  如此天众发心已　　皆悉欣喜心清净
  得闻最胜佛法已　　此诸天众皆成佛

尔时世尊。知彼四亿夜摩天众深心信乐。即便微笑。尔时马胜。即以偈颂。问如来曰

  佛为世间故现笑　　一切时众皆生疑
  唯愿世尊说笑因　　令此众会皆欣喜
  闻于诸天授记已　　一切皆悉大踊跃
  有智慧者发勇猛　　于佛法中如说行
  此佛如来诸胜众　　具足有佛功德器
  善哉宣说美妙言　　为摄如是大众故
  闻佛功德心喜乐　　此诸大众必当得
  闻于如来授记已　　如法当勤修精进
  善哉人尊说中胜　　于疑惑众二心者
  唯愿世尊速为说　　时众一心乐欲闻
  彼夜摩天授胜记　　愿人师子速为说
  此诸大众皆欣喜　　一切悉发菩提心

尔时世尊。即以偈颂答马胜曰

  为利世间故现笑　　马胜合时善咨问
  利益无量诸大众　　闻佛如来功德故
  乐着贪嗔诸众生　　于佛功德无乐惠
  其心愚痴所惑乱　　当没生死大海中
  若于佛法深信乐　　曾于先佛已请问
  与大悲心相应者　　是人能得佛功德
  若人见彼衰恼逼　　胜人于彼起悲心
  彼诸众生闻佛德　　顶受佛教如花鬘
  我诸众会大清净　　于先佛所曾修福
  彼于如来功德所　　顶受犹如婆师鬘
  夜摩天众先佛所　　曾修持戒除贪着
  厌离烦恼心清净　　于秽众生起悲心
  于无量佛曾亲近　　其数犹如恒河沙
  彼曾修习无量善　　为求无上菩提故
  知众生没烦恼已　　于苦众生起悲心
  于人师子利世者　　问诸法门无有量
  我今导师为彼说　　闻者悉得成佛道
  知彼众生烦恼钩　　为说最上胜妙法
  彼胜丈夫大导师　　为彼众生说空法
  彼闻诸佛所说已　　悉皆了知诸法空
  所谓空无诸法相　　说无自性无相法
  如是了知诸佛法　　悉皆安住佛功德
  此等胜妙供养我　　如法各自受记莂
  当于来世星宿劫　　悉皆得成无上道
  如是如来无增减　　其数满足四十亿
  其佛同号净智尊　　开悟无量诸众生
  大仙降伏诸怨者　　答于马胜所咨问
  满夜摩天所愿求　　大众天人皆欣喜

大宝积经卷第六十六　　大宝积经卷第六十七

        北齐三藏那连提耶舍译

    菩萨见实会第十六之七兜率陀天授记品第十六

尔时八亿兜率陀天。见诸阿修罗伽楼罗。乃至夜摩天等供养如来。闻授记已欣喜踊跃作如是念。于何等法。世尊。与授阿耨多罗三藐三菩提记。为色受记受想行识。得授阿耨多罗三藐三菩提记耶。彼等诸天复作是念非与色记。亦复非与受想行识阿耨多罗三藐三菩提记。何以故。色既不生菩提亦不生。云何无生色能寤无生菩提。如是乃至识亦不生。云何无生识能寤无生菩提。色既不灭菩提亦不灭。云何不灭色能寤不灭菩提。如是乃至识亦不灭。云何不灭识能寤不灭菩提。色无分别菩提亦无分别。云何无分别色能寤无分别菩提。如是乃至识亦无分别。云何无分别识能寤无分别菩提。色既无二菩提亦无二。云何无二色能寤无二菩提。如是乃至识亦无二。云何无二识能寤无二菩提。色既无作菩提亦无作。云何无作色能觉无作菩提。如是乃至识亦无作。云何无作识能觉无作菩提。色既不可得菩提亦不可得。云何不可得色能觉不可得菩提。如是乃至识阴不可得菩提亦不可得。云何不可得识能觉不可得菩提。如是于彼不可得诸法中。何者是佛。何者是菩提。何者是菩萨。何者是授记。色阴空受想行识亦复皆空。何以故。性自空故。如是佛空菩提空菩萨空授记空。何以故。自体空故。如是性空一切法中所言佛者但名但用。但是世谛但是言说。但是施设所言色阴受想行识亦但名用。世俗言说及以施设。智者于此不应取着。譬如有人于其梦中受五欲乐。彼人寤已不见彼乐。忆念不得五欲乐故便生苦恼。如是住于菩萨乘者。若有取着不会菩提。不证菩提故不得其味。以不得味故心生苦恼。何以故。如是诸法如梦不实。彼法义别愚痴凡夫。取解各异。一切诸法当如是知。何法是佛。何法是菩萨。何法是菩提。彼诸佛法皆不可得。凡夫不可得。凡夫法亦不可得。声闻不可得。声闻法亦不可得。辟支佛不可得。辟支佛法亦不可得。菩萨不可得。菩萨法亦不可得。佛不可得。佛法亦不可得。菩提不可得。涅槃亦不可得。我等于此诸法之中。解了无疑。尔时兜率陀天。于斯法中既无疑虑。于世尊所乐修供养。所作供养胜夜摩天。顶礼佛足。右绕三匝却住一面。即以偈颂赞世尊曰

  所有住佛功德者　　如来为其说行法
  彼得三种解脱门　　无等境界中修行
  无色亦无受想行　　无其受者亦无心
  斯则无碍智境界　　乐离欲阴人师子
  彼诸智慧妙丈夫　　不取发于菩提想
  离阴已获胜善根　　于佛功德无疑虑
  志愿无上大菩提　　然于菩提离取着
  是故内心无忧喜　　名为佛子修圣行
  同佛见法悉平等　　是故于法无所畏
  智者于此世间处　　求佛功德起修行
  简择色相无所著　　弃舍一切有相心
  于彼三有不起愿　　观察诸有悉皆空
  能知五阴各不生　　如来授记及菩提
  菩提心等亦无生　　作是说者非愚惑
  如来功德及生死　　此诸佛法悉无生
  如是知者人中胜　　是为真实如来子
  若能知是阴不灭　　界入及以如来法
  佛与菩提及授记　　斯等诸法皆不灭
  若为菩提修行者　　当知彼亦是不灭
  知诸世间不灭故　　彼求菩提不为难
  五阴界入与菩提　　佛及菩萨皆无作
  如是了知为佛子　　彼人能持佛正法
  阴界诸入皆无觉　　菩提与佛并菩萨
  及以授记悉无觉　　如是知者为佛子
  五阴界入性空寂　　佛与菩提及授记
  如来真子修行者　　斯等亦皆自性空
  阴界诸入悉虚妄　　两足世尊及菩提
  行者授记亦虚妄　　如是了知为佛子
  非是依止非不依　　亦非有法非无法
  非是有为非无为　　如是了知为佛子
  世尊如是见世间　　我等如是知佛心
  即为胜妙供养佛　　及以一切贤圣众
  我等赞佛所得福　　唯佛世尊能了知
  以斯功德施群生　　愿皆成佛具众相

尔时世尊。闻彼兜率诸天赞已。及知深信。即为天众而现微笑。尔时慧命马胜以偈问曰

  得大势力无上士　　以其因力现笑光
  愿佛说是微笑因　　令众得闻皆欣喜
  以见如来微笑故　　此诸大众悉怀疑
  众会殷勤普瞻仰　　咸皆一心欲听闻
  犹如世间有病人　　唯思医师及良药
  如是大众于佛所　　愿乐欲闻说授记
  斯等皆有深智慧　　志求菩提无所著
  一切恭敬悉瞻仰　　唯希如来为记莂
  世尊于此起大悲　　以佛智力断疑网
  是故大众得欣喜　　咸皆愿求佛功德
  世尊今正授记时　　唯愿除灭诸疑惑
  如来久已离怨敌　　愿断众邪外道论

尔时世尊。即以偈答慧命马胜言

  汝今启请如来义　　问其微笑正是时
  为利世间故致问　　必当饶益诸众生
  知诸天众心乐欲　　故我现是微笑光
  以知佛法胜妙故　　于我便作上供养
  彼皆如实见世间　　随顺圣教得证法
  已到三种解脱门　　非诸世间所能知
  过去已供无量佛　　亦曾问是深义趣
  于彼佛所久修空　　今故于斯显空义
  是故今者于此处　　便得值遇佛世尊
  以空赞叹无上士　　利益一切诸世间
  如斯世间悉无生　　诸佛菩提及授记
  所有修行菩提者　　彼等一切亦无生
  众生悉同有此法　　如是知已得菩提
  过去曾学菩提心　　彼于此义能解了
  如是世间亦不灭　　斯诸天众善通达
  明智照了悉无疑　　是故彼天皆作佛
  决定必得无依处　　于法不取离分别
  一切世间皆无作　　彼于斯义能了知
  一切法体离自性　　天众心净无疑惑
  菩提及与菩提心　　一切皆空无自性
  兜率诸天坚固慧　　皆悉安住无所依
  故得菩提不为难　　必当速成无上智
  于其未来星宿劫　　当得度脱无边众
  彼天一切皆成佛　　同号名曰择法王
  如来于此诸天众　　知其心乐为记说
  一切天人闻说已　　咸皆踊跃称心意

    化乐天授记品第十七

尔时化乐天王为首。与其眷属七亿化乐诸天众等。见诸阿修罗伽楼罗。乃至见诸兜率天等供养如来闻授记已。欣喜踊跃咸皆称心得住实际。于真如中无有疑惑。从坐而起偏袒右肩右膝着地头面作礼。向佛合掌。异口同音。而白佛言。世尊。如我解佛所说义。一切诸法是真实际无边际无碍际无住际无尽际不二际非际实际。世尊。所言实际者不颠倒故。无边际者无限量故。无碍际者离对治故。无住际者离自性故。无尽际者无有生故。不二际者谓一味故。言非际者是非有故。世尊。彼实际者遍一切处。无有一法而非实际。世尊。谓菩提者亦是实际。世尊。何者是菩提。一切法是菩提。离自性故。乃至五无间业亦是菩提。何以故。菩提无自性。五无间业亦无自性。是故无间业亦是菩提。世尊。言菩提者如无余涅槃性亦如无间业性。何以故。一切法即是无余涅槃性亦是无间业性。是故无余涅槃界即是菩提。世尊。若有众生住生死者可求涅槃。于实际中无住生死求涅槃者。何以故。实际无二故。世尊。我等于此解了无疑。若于此法无疑虑者。当知是人已曾过去于诸佛所。得授阿耨多罗三藐三菩提记

尔时世尊。闻化乐天王及诸七亿化乐天等说授记已。欲令大众心喜悦故。而现微笑。尔时慧命马胜以偈问曰

  怜愍世者现微笑　　而不说其笑因缘
  天人导师非无因　　现此奇特微笑相
  既见世尊笑光已　　今诸大众悉怀疑
  唯愿说其微笑因　　断除一切诸疑网
  斯等若蒙如来说　　闻已咸生希有心
  为彼众会净真路　　趣向菩提作因缘
  若有众生疑虑者　　是人难得妙菩提
  唯愿大智断疑惑　　精勤速证无上道
  世尊此诸大众等　　志求菩提离诸恶
  得闻诸天授记已　　决定当成大法王
  是故世尊愿怜愍　　除断一切疑惑心
  授此诸天菩提记　　令诸大众皆欣喜

尔时世尊。以偈答慧命马胜曰

  哀愍世间故现笑　　马胜汝今问我义
  我悉与彼天授记　　汝等咸各净心听
  此诸化乐天众等　　自说授记得菩提
  众中既作师子吼　　能坏外道诸邪见
  譬如空中雨众石　　必堕大地无有疑
  如是佛子离疑惑　　自知定当成佛道
  犹如日没至夜时　　当知日出必不久
  如是佛子备众行　　定知必当具十力
  又如日在正中时　　观诸色像皆明了
  如是佛子具众行　　自知必得萨婆若
  喻若日光至没时　　众人咸知日不见
  如是佛子皆自知　　决定当得最胜智
  譬如众流趣其下　　智者当知归大海
  如是佛子具明慧　　定知必得上菩提
  如人以石掷虚空　　决定堕地无疑虑
  如是佛子悉自知　　不久当得世间解
  智者法尔有此见　　以知法故不致疑
  自知分有佛功德　　必定近于自然智
  假使诸魔那由众　　现佛言汝不作佛
  不能沮坏其心意　　已自善解真法故
  决定于彼佛功德　　咸各自说得授记
  于斯诸天授记事　　如来悉生随喜心
  此天所修菩萨行　　悉自了知不由他
  彼等自说成善逝　　世尊于此皆随喜
  是故马胜若有人　　欲得无上菩提者
  可于此法应勤求　　必获最胜安隐处
  自成正觉寤斯理　　随义如实能了知
  亲近供养善知识　　彼证菩提不为难
  若有千劫修苦行　　皮膏血肉无恋惜
  若能解了斯义趣　　此福广大胜于彼
  过去所有一切佛　　未来怜愍众生者
  及以现在诸世尊　　悉依此法成佛道
  化天于我供养已　　咸皆善知第一义
  曾供过去诸如来　　寤斯义理当成佛
  诸佛所有胜三昧　　及以现在所住定
  彼天深得佛境界　　由本先世久修习
  马胜化乐天子等　　于彼三昧无有疑
  清净佛法既善学　　今于佛道现修行
  是故于理生信解　　当正勤求离苦边
  常应亲近多闻者　　必得无上大菩提
  闻佛所说妙法已　　化乐诸天众会等
  皆悉欣喜除疑网　　流注趣向大涅槃

    他化自在天授记品第十八

尔时他化自在天王为首。与其眷属八十那由他诸天众等。见诸阿修罗伽楼罗龙女龙王鸠槃茶乾闼婆夜叉紧那罗。诃罗伽阇天。四天王。忉利天。夜摩天。兜率陀天。化乐天等。供养如来闻授记已。欣喜踊悦。皆得称心。异口同声。而白佛言。世尊。化乐诸天所说实际者。我等尚不见实况复见际。何以故。世尊。若见实者可言见际。何以故。是人行于二处住如是乘者。若善男子善女人。应为彼说此二种法。此二法者非真境界。世尊。若善男子善女人于不二法不信不入。虽复如是此人发心望得菩提。当知是人行于非径。何以故。此于菩提非道行故。世尊。若有众生求菩提者。是人不见一法可觉。何以故。无有少法可得觉寤阿耨多罗三藐三菩提故。世尊。彼法非过去非未来非现在。非有为非无为。非有非无。非可识非可知非可舍非可修非可证。谓菩提者彼法非与余法作对治。余法亦不与彼法作对治。何以故。彼法非杂烦恼非离烦恼。法体不可得性自离故。此法不与彼法作对治。彼法亦不与此法作对治。何以故。一切诸法离诸相故。是故彼法非可知非可识。非可舍非可修非可证。世尊。色生者离生相故。彼亦非可知。乃至非可证。受想行识亦复如是。世尊。色灭者离色相故。彼亦非可知乃至非可证。受想行识亦复如是。世尊。过去者离过去相故。彼亦非可知乃至非可证。未来者离未来相故。彼亦非可知乃至非可证。现在者离现在相故。彼亦非可知乃至非可证。世尊。有为者离有为相故。彼亦非可知乃至非可证。无为者离无为相故。彼亦非可知非可识。非可舍非可修非可证。世尊。如是等乃至为阴所摄。或过去所摄。现在所摄。未来所摄。或有为所摄。无为所摄。此等诸法皆不可得。以不得故。是故彼法非可知非可识。非可舍非可修非可证。世尊。若有如是为求菩提发心修行。善男子善女人。彼皆名为住菩萨乘。尔时他化自在诸天。咸各说已所知法已。以偈赞曰

  世尊善说尽有边　　永不暂受六趣身
  世间无智畏生死　　发心欲度生死岸
  彼诸阴体不可得　　以阴性相本自空
  一切法空皆无相　　是故诸法离对治
  自体即空无有物　　无有可知及修舍
  亦复非是可证法　　如来说有即非有
  相求菩提不可得　　助道诸法亦如是
  取心求佛不可得　　菩萨相求亦不得
  坚着诸相愚痴辈　　彼等望得寤菩提
  颠倒境界取相行　　无智非行菩提道
  入佛境界离众相　　名为智者如法行
  远离诸相及无相　　亦离于空及不空
  彼能寤解无上道　　于诸外道非境界
  亦非声闻所能知　　又非缘觉之所趣
  心得解脱净无垢　　罗汉于法相应者
  及诸一切辟支佛　　非彼智慧之境界
  彼句非为相心知　　及修少空亦不解
  若有解空说空者　　亦说诸法无自性
  彼受佛教无毁訾　　是名善修空寂静
  能寤难寤菩提道　　世尊于彼真导师
  赞佛二足最尊已　　所获无量诸功德
  回施一切诸群生　　成佛觉寤未觉者

尔时世尊。知彼八十那由他他化自在天。及以天王等得深信已。欲令大众增益善根。故现微笑。尔时慧命马胜。以偈问曰

  二足世尊现微笑　　以知他化深信故
  未曾演说笑因缘　　唯愿如来为解释
  大圣今者非无因　　现是希有微笑相
  愿佛开显因缘义　　灭除大众诸疑惑
  由见世尊微笑故　　今此众会悉怀疑
  怜愍一切世间者　　唯愿敷演分别说
  此众咸皆背生死　　合掌恭敬求涅槃
  斯等靡不怀犹豫　　无碍说者愿断除
  悉皆正信善逝法　　心得开解离取着
  咸有净信尊重心　　善哉牟尼愿解说
  勇猛精进于佛法　　远离疑网登圣路
  一切诸佛游此道　　是故愿除大众疑

尔时世尊。以偈答慧命马胜曰

  汝为怜愍大众故　　以偈问我正是时
  具足辩才有巧便　　乃能问此微笑义
  以问如来现笑故　　必当利益无量众
  是故一切众会等　　皆得住于胜菩提
  知彼他化深信已　　故我现是微笑光
  一切随顺如来教　　为求菩提修妙行
  观察世法离诸相　　如见阳焰非真实
  愚者见焰谓是水　　欲求菩提勿同彼
  取相贪乐凡夫境　　无智常怖于无相
  愚痴执相舍正路　　离相能获妙菩提
  妄想思量虚伪法　　随所分别即被缚
  智者观相悉皆空　　得上寂灭陀罗尼
  执相凡愚住恶心　　彼皆无智归六趣
  轮回逼迫受众苦　　都由愚痴住相故
  着相众生见诸阴　　佛与菩提及菩萨
  智者离相见空已　　能得无上大菩提
  住相之类增烦恼　　能观无相得除结
  所谓结者即是相　　观结无相即断除
  若有分别求道者　　分别于道为障碍
  智者虽复行于欲　　彼欲即为无相行
  诸法无体不可得　　分别诸法说言空
  若离分别得无相　　彼即菩提更无余
  闻于善逝说是语　　大众除疑得无畏
  顶受牟尼所说法　　如智顶戴瞻卜花
  斯诸天众获无畏　　于我设供最无上
  亦知诸法佛境界　　当作世间大导师

    诸梵天等授记品第十九

尔时六千万诸梵众天。见诸阿修罗伽楼罗乃至他化自在天等供养如来闻授记已。欣喜踊跃。皆得称心。彼于世谛禅。以喜悦为食。亦于佛法中。得智慧明宿殖善根故。已曾亲承供养诸佛故。及深信清净故。于甚深法获得法忍。彼诸天等。知诸法无作非无作。非生非不生。非有非不有。非起非不起。非灭非不灭。非依非不依。非清非浊。非憎非爱。非贤非愚。非知非不知。非见非不见。非受非不受。非恻非不恻。非无非非无。非物非非物。非可得非不可得。非去非来。非趣非不趣。非空非不空。非相非不相。非愿非不愿。彼诸梵天。于一切法心无所著。亦无所住。于非用中不作非用想。于非不用中亦不作非不用想。于语言中无语言想。于非语言亦无非语言想。于有作中无其作想。于无作中亦无无作想。于凡夫不作凡夫想。于非凡夫亦不作非凡夫想。于凡夫法不作凡夫法想。于非凡夫法亦不作非凡夫法想。于声闻不作声闻想。于非声闻亦不作非声闻想。于声闻法不作声闻法想。于非声闻法亦不作非声闻法想。于缘觉不作缘觉想。于非缘觉亦不作非缘觉想。于缘觉法不作缘觉法想。于非缘觉法亦不作非缘觉法想。于菩萨不作菩萨想。于非菩萨亦不作非菩萨想。于菩萨法不作菩萨法想。于非菩萨法亦不作非菩萨法想。于佛不作佛想。于非佛亦不作非佛想。于佛法不作佛法想。于非佛法亦不作非佛法想。于涅槃不作涅槃想。于非涅槃亦不作非涅槃想。于生死不作生死想。于非生死亦不作非生死想。如是彼天一切皆悉离诸分别。定心清净。彼等既得清净心故。以寂灭法。说偈赞佛

  大圣甚深寂灭智　　修行寂灭到彼岸
  演说寂灭度众生　　亦自常行寂灭法
  菩提寂灭善清净　　斯法牟尼之境界
  速得寂灭胜甘露　　以是今得尽诸有
  恒说寂灭微妙道　　是彼智者所行处
  八正之路灭恼浊　　拔济一切诸群生
  善修寂灭证菩提　　乃是先佛之所行
  修彼能到安隐城　　过去诸佛所证知
  是诸如来修学法　　导师如是化世间
  若人能行有学法　　获得无学胜菩提
  一心趣向寂灭道　　诸根寂静久修习
  当得为佛世间解　　那罗延力度群生
  若知寂灭甘露者　　能尽一切诸有相
  是为真实如来子　　寂灭能除世间畏
  彼等所设供养佛　　胜上希有最殊特
  所说寂灭尽烦恼　　于诸无相最第一
  世间寂灭离诸相　　所谓寂灭即涅槃
  众生轮转受诸苦　　远离寂灭取相故
  牟尼诸法不思议　　即是菩提一切智
  已度淤泥到彼岸　　故佛于此无疑虑
  若有离阴得解脱　　于佛大乘不愿乐
  欲求菩提思灭度　　于其五阴生怖畏
  离欲净心求涅槃　　彼等如是简择智
  于法取相凡夫境　　是谓如来之所说
  若取寂灭即是缚　　以是不得一切智
  若有于其五阴相　　不生存执取着心
  彼能利益释迦法　　是名喜乐无相行
  能获无名安隐处　　逮得菩提佛境界
  降魔诤论灭烦恼　　速得成就一切智
  我等赞叹无上士　　所获寂灭诸功德
  唯佛大智能了知　　回施众生愿成佛

尔时娑婆世界主大梵天王。知诸梵天赞叹佛已对佛正立。以实功德。而赞颂言

  法王已知一切法　　不实虚诳如空拳
  亦如秋云及电光　　是故大圣离取心
  犹如梦中饥饿人　　餐食百味甘美膳
  梦人饥食皆不实　　如来见法亦如是
  又如梦中焦渴人　　得饮清净凉冷水
  梦渴饮水皆虚妄　　佛见诸法亦如是
  无作无受无众生　　无其作业及得报
  亦无得受果报者　　世尊于此无疑虑
  譬如美言得人爱　　然彼语言无可最
  亦无言说及听者　　大圣了知皆不实
  如闻箜篌美妙音　　其声亦无真实性
  世尊如是见诸阴　　知阴无体不可得
  犹如摩尼性自净　　系之衣上随色变
  诸法自体本清净　　虚妄分别增倒染
  譬如无垢鲜白衣　　随受染色种种变
  诸法如是性自净　　随所分别而染污
  犹如有人闻贝声　　寻其贝声从何来
  其声非自非他性　　大仙见法亦如是
  如人思美肴膳食　　其食众缘所合成
  观食各各无自性　　如来见法皆如是
  譬如众缘号为城　　推其城体无自性
  如是众缘皆悉空　　法王见法亦如斯
  喻若有人击鼓声　　虽能令人心欣喜
  声及众缘皆悉空　　大圣见法亦如是
  譬如有人打鼓时　　其声不从十方来
  声灭亦不向诸方　　世尊见法皆如是
  如是彼人击鼓已　　其鼓不生憎爱心
  亦不分别众缘性　　佛见诸法皆若斯
  又如彼人打妙鼓　　声不作心生他喜
  及以众缘皆亦然　　导师见法皆如是
  如人击彼妙鼓时　　鼓亦不生苦乐想
  亦不观察众缘性　　如来见法皆如是
  犹如有人击妙鼓　　声不即缘亦不离
  及彼伎缘亦复然　　牟尼见法皆如是

尔时世尊。知诸梵天大梵王等深心敬信。及以寂灭赞颂佛已。又见大众欲生善根。即便微笑。尔时慧命马胜。以偈问曰

  既见如来口中出　　离垢清净微笑光
  世间天人大众等　　一切咸生希有心
  以见世尊微笑故　　诸来大众普怀疑
  皆悉瞻仰如来面　　殷勤愿乐欲听闻
  愿佛开示笑因缘　　荡除大众疑惑心
  最胜牟尼非无因　　而现希有微笑相
  诸佛所现微笑光　　必为利益诸世间
  今者为谁现此笑　　唯愿敷演分别说
  大众得闻必欣喜　　由知微笑因缘故
  斯诸大众皆合掌　　一心瞻仰乐欲闻
  是故愿佛为解释　　必当断灭诸疑惑
  导师为彼诸来众　　愿垂演说微笑因
  众会若闻必喜悦　　以得洗除疑网故
  众心坚固皆清净　　专念希仰如来德
  大众瞻仰世尊颜　　犹如睹见初生月
  具八妙声如梵天　　一心渴仰愿速闻
  天人众等闻佛说　　必得除疑住正法
  梵音演说义相应　　得闻甚深出世法
  佛智善巧能悦豫　　故令大众增踊跃
  此众心净离疑结　　能乐如来一切智
  精进勇猛有力人　　乃能志求无上道
  是故导师愍世间　　唯愿解说令众喜
  善哉世尊平等心　　怜愍一切诸众生
  令诸大众增善根　　安心不动求佛智

尔时世尊。即以偈答慧命马胜曰

  怜愍一切诸世间　　故我现是微笑光
  汝当谛听说彼因　　其义甚深微妙句
  此诸众会若得闻　　发勤精进修善业
  当得利益诸众生　　于佛妙法起胜行
  斯诸梵众皆欣喜　　如来法中悉无疑
  那由他劫久修行　　犹如恒河沙劫数
  于诸境界悉不着　　心如虚空无障碍
  虽乐常修菩萨行　　而不速取菩提证
  此等复于未来世　　无量亿劫恒沙数
  天众清净无垢秽　　得大势力住世间
  然后当成一切智　　为大法王有威力
  具足功德尽诸有　　观诸世间悉空寂
  彼佛如本久修行　　寿命限量亦如是
  斯诸善逝住世时　　能于苦恼度众生
  彼佛国土无伦匹　　世界严净甚滋茂
  无量那由劫数中　　如来演说不可尽
  彼佛刹土严净事　　无量佛说亦不尽
  彼佛同号大智力　　国土皆悉名最胜
  为众演说不动法　　不可思议无所依
  彼佛世界众生等　　咸皆修治诸善根
  无一众生受后有　　生死之中重生者
  彼等当时有一苦　　于其世间便显现
  唯畏诸行皆无常　　令诸众生起厌离
  尔时彼国众生辈　　离老病死诸苦相
  一切依于一教法　　同厌无常修胜行
  彼诸众生当尔时　　耳更不闻余音声
  唯闻不净无常苦　　无我寂灭空无相
  甘露涅槃及菩提　　安隐清凉无上乐
  斯等如是胜妙音　　恒常数数而得闻
  尔时更无余声响　　若树若壁及露地
  或复空中及寺庙　　但闻如是微妙句
  闻已一切皆得道　　便于生死得解脱
  皆是如来神力故　　具八功德妙音声
  尔时无有杂毒心　　所谓离欲及嗔恚
  亦无愚痴出恶声　　粗言逼恼来经耳
  一切厌背于生死　　趣向涅槃大正路
  彼土一切悉当空　　佛及众生皆灭度
  斯是彼佛大神力　　发弘志愿不思议
  曾于过去那由劫　　为求菩提修道行
  彼国所有诸众生　　一切悉皆当作佛
  此诸梵天发广愿　　皆由观察寂灭句
  悉得证知甚深义　　解了如来吉祥路
  其所修学皆通达　　于诸世间为导师
  彼能观察众生空　　不生疲倦懈怠心
  是故巧入诸法性　　修集菩萨胜妙行

大宝积经卷第六十七　　大宝积经卷第六十八

        北齐三藏那连提耶舍译

    菩萨见实会第十六之八光音天得授记品第二十

尔时五十八千万光音诸天见诸阿修罗伽楼罗乃至梵天等供养如来。闻授记已。欣喜踊跃皆得称心。偏袒右肩右膝着地。向佛合掌恭敬作礼。白佛言世尊。有三昧名照耀一切法。若菩萨摩诃萨学是三昧。一切法中悉得光明。得入菩萨法门。菩萨摩诃萨解了知已。得无边辩无碍辩相续辩种种辩美妙辩真善辩相应辩解脱辩微细辩不共辩甚深辩。乃至得于如来之辩。世尊。何者名为照耀一切法三昧。菩萨入此诸法门故。念诸觉观知一切法无觉离觉。是无觉法遍一切处。无有一法能觉察者。何以故。性自离故。若法无性。云何能觉知一切法。无其觉已。入阿字门得上辩才。彼菩萨入阿字门已。得无边辩。阿字无边。阿字非普遍。阿字无作。阿字非有为。阿字非成就。阿字非事。阿字无所依。阿字无动转。阿字非略。阿字非广。阿字非分别。阿字非众事成。阿字不可穿。阿字非色。阿字不可示。阿字不可观。阿字无有能见者。阿字非可思。阿字不定住。阿字非可知。阿字非能知。阿字非可测。阿字不能自示现。阿字亦不能示他。阿字非思议。阿字不去阿字不来。阿字非近阿字非远。阿字非言说。阿字亦非可说法。阿字非名。阿字非用。阿字非现前。阿字非覆障。阿字非移转阿字非可改。阿字非差别。阿字无二。阿字非生。阿字非虚妄。阿字非真实。阿字不可说。阿字非生灭。阿字非清净。阿字亦非可净法。阿字非执持。阿字非摄他。阿字非弃舍。阿字不为他法作。阿字亦不作他法。阿字不生阿字不灭。阿字不能生他法。亦复不能灭诸法。阿字非生非不生。阿字不与生法作生因。亦复不作不生缘。阿字非依非不依。阿字非假非不假。阿字非却非不却。阿字非许非不许。阿字非可得亦非不可得。阿字非空非不空。阿字非分别非不分别。阿字非相非不相。阿字非愿非不愿。世尊。一切诸法皆如是相。所谓无相。一切诸法皆同一实。所谓无实。皆同一趣。所谓无趣。皆同一入。所谓无入。皆同一假。所谓无假。皆同一用。所谓无用。一切诸法皆同一说。所谓无说。世尊。诸法无起不可得故。诸法非有以无有故。诸法无生以不生故。诸法无灭以不灭故。无为法者无有作故。世尊。一切法皆同一如。当如是知。世尊。是诸不生法彼法事用云何得知。世尊。譬如有人梦中所作。当知诸法亦复如是。何以故。梦所作事不生不起亦非有故。梦虽不实非无假名。说有梦作。一切诸法皆亦如是。世尊。譬如响声唯有假名。诸法但假亦复如是。世尊。喻若幻人但是假名。当知诸法亦复如是。世尊。譬如阳炎但假名字。诸法假名亦复如是。世尊。如镜中像但有名用。当知诸法亦复如是。世尊。为悦豫凡愚说有梦事。梦中所作皆非真实。响幻炎影亦复如是。但有假名皆无实作。世尊。我等如是解知如来所说法义。尔时光音诸天。以偈赞佛

  世尊善知此法义　　及余种种无边法
  如来所有诸佛子　　得父资财常游戏
  世间少智莫能入　　由常计着我心故
  十方求我不可得　　我体本来性自空
  如空阳炎非实水　　愚痴见彼作水想
  都由无智生迷惑　　虚妄颠倒计我人
  彼痴愚惑如来教　　是故不解深义趣
  凡夫心识如炎水　　不能了知诸阴义
  心乐生死着苦箭　　诸根駃流所漂溺
  斯等毕竟无自性　　为痴覆蔽妄受苦
  彼皆失智心迷乱　　于诸苦中生乐想
  心常颠倒顺三毒　　是诸烦恼甚可怖
  贪欲嗔恚及愚痴　　斯诸结使常随逐
  深乐受故生渴爱　　愚痴不识故受苦
  无智随顺诸烦恼　　如人痴负怨家行
  闻佛所说空教门　　于空反畏失解脱
  譬如怯人执持刀　　应得安隐反生畏
  大智世尊所说法　　谓是微妙阿字门
  能生真实胜智慧　　犹如平地生大树
  降诸魔怨那由众　　能寤安隐妙菩提
  以彼八正大船筏　　于诸有海度群生
  世尊所有诸佛子　　了知如来胜教法
  速灭烦恼诸怨敌　　疾证无上大菩提
  既自解脱离毒心　　见余毒者施智药
  得到究竟彼岸果　　获大安乐无为处
  一切诸法皆悉空　　诸余外论妄分别
  明人弃恶就正路　　皆由本来久修学
  心无所著即解脱　　诸法体性自如是
  彼能如是了知者　　成佛大力那罗延
  无有系缚及缚者　　诸法性空皆亦无
  真如寂灭及非如　　非是垢秽亦非净
  烦恼无相亦无断　　以其本来性自空
  如是能知真实法　　彼人当得一切智
  自证解脱复度他　　此等不生亦不灭
  世间天人皆迷惑　　如春禽兽见炎水
  虚妄分别起渴心　　想见男女受苦恼
  以业种种生诸趣　　由心作故有差别
  造业有报及以受　　彼业无有能作者
  我等如是解佛法　　是诸如来妙境界
  是故如来心调伏　　诸根寂静能忍辱
  世尊如法得供养　　清净无垢尽诸秽
  具足众德离闇冥　　唯佛能施三界眼
  我今赞佛所获福　　唯有出世大导师
  二足世尊功德聚　　能知我等所得报
  以此微妙胜善根　　回施一切诸群生
  愿彼当于未来世　　悉得成就一切智

尔时世尊。知光音天深信心已。及知修行辩才具足。欲令大众功德善根当复渐渐胜进增长故。是时如来即现微笑。尔时慧命马胜。即以偈颂。问世尊曰

  大悲善逝非无因　　而现希有微笑相
  能利世间无上士　　正觉智慧超群生
  两足世尊功德聚　　怜愍众生愿演说
  为谁而现此微笑　　殊胜光显于世间
  一切众生若得闻　　心意决定大喜悦
  修行善业证佛果　　得离生死到涅槃
  斯诸世间天人众　　生死苦恼之所逼
  愿度群生于有海　　演说八正大船路
  如是得闻大仙说　　具八功德最胜道
  世间于是生欣喜　　乐修诸善愿成佛
  勇猛精进有大力　　内心清净离诸疑
  当传如来所说法　　是佛真子顺圣教
  此诸众会无余念　　一心瞻仰大瞿昙
  唯愿敷演授记事　　令其决断疑惑心
  合掌恭敬正意住　　咸皆愿乐欲听闻
  善哉愿说甘露味　　诸有渴法当得饮
  是等一切诸会众　　心净爱乐胜功德
  瞻仰如来最胜颜　　犹如婴儿观母面
  大慧愿授此天记　　开现微笑因缘事
  得闻如来授记已　　世间当获大利益
  谁于牟尼增善根　　及以发愿得满足
  克获微妙功德藏　　我今乐闻彼受记
  大众必生欣喜心　　闻佛所说授记故
  决定当具念慧力　　及得修行三昧定

尔时世尊。即以偈答慧命马胜言

  善哉马胜所问事　　辩才应机正是时
  斯即如来神通力　　以是汝今生智慧
  为利世间故增辩　　是故汝今能致问
  我今为彼说授记　　寂静诸根一心听
  此诸胜慧光音天　　过去已供无量佛
  见是世间孤无救　　发心安住欲作佛
  修治真实微妙行　　必定当成一切智
  为求佛道诸众生　　如迷失径教正路
  如是得闻世尊教　　其声最胜无等等
  乐佛功德智慧人　　必得究竟到彼岸
  彼有智力知善恶　　决定当获佛菩提
  欣喜已发菩提愿　　如妇生男称其心
  此天为求菩提者　　示其出世真正路
  于不可说那由劫　　修习菩萨胜妙行
  所化众生过众星　　安置于佛菩提已
  当来具足世间解　　自然成就一切智
  彼等妙土不可说　　世界宽广有百亿
  是诸妙刹甚清净　　无量种种胜庄严
  彼佛国土诸众生　　无三恶趣及八难
  一切皆发菩提心　　咸各得住不退转
  彼诸如来国土中　　亦复无有小乘法
  众生悉皆求佛道　　便得进趣不退地
  是诸刹土众生类　　一切寿命悉齐等
  经于十亿恒沙劫　　皆由值遇诸佛故
  若教那由刹众生　　悉得入于小涅槃
  若复有人化一人　　或男或女入大乘
  初福比此功德聚　　算数譬喻不能及
  是故若住大乘者　　应当转化于余人
  马胜以是因缘故　　如来出世甚为难
  犹如优昙极难值　　无边大智如是说
  以巧深智善知识　　善解方便示正路
  安隐无上胜菩提　　若人求者应亲近
  从佛口闻如是语　　具足微妙甚深义
  一切大众皆欣喜　　踊跃充满称心意
  那由诸天住空中　　皆散天衣旋转下
  欣喜赞声满虚空　　敬礼无比大神力
  清净妙智度世间　　能灭众生烦恼热
  佛说甘露灭三毒　　如阿伽陀消众毒
  得闻智慧断诸结　　世间迷惑多苦恼
  于其有趣当得脱　　从佛得闻胜法故

    遍净天授记品第二十一

尔时十二那由他遍净诸天等。见诸阿修罗伽楼罗。乃至光音天等。供养如来。闻授记已。欣喜踊跃皆得称心。自现威力。而白佛言世尊。有三昧名超过一切法。菩萨摩诃萨得是三昧已。于诸攀缘及一切事。皆生乐受不生苦受。假使于其地狱事中。受诸苦恼皆生乐想。或复于其畜生道中。受畜生报亦生乐想。或复饿鬼道中。受饥饿苦亦生乐想。或复于彼阿修罗道中亦生乐想。或复人中所受诸苦。亦起乐想不生苦想。假使截手及以截足割耳劓鼻。或复鞭打杖刺入身。或复牢狱系闭。或复倒悬。或复裁割犹如衣帛。或复裹系及以束缚。或复切脍。或复锤捣犹如甘蔗。或复蹉蹋破如芦苇。或复火烧如稣油炷。或复然身喻若明炬。或与师子虎狼为食。或复酽醋及以辛汁浇灌口鼻。或复蒸煮及以火炙。或与狂象践踏其身。或复挑目。或以鉾槊穿刺高举。假使嗔怒来截其首。如是一切悉生乐想。何以故。由彼菩萨于其长夜修菩萨行时发如是愿。若有众生施我食者。愿彼一切得涅槃乐。若有与我洗浴身体礼拜奉迎尊重供养。若有众生骂辱于我。复有人人赞叹于我。若有众生鞭打斫刺夺我身命。愿彼一切得涅槃乐。乃至觉寤无上菩提。彼菩萨成就如是心。具足如是业。亦复具足如是愿。于一切众生皆起乐想。常能修集无间不断。以是业报故。得一切法乐善取三昧。彼菩萨得此三昧时不为众魔之所动坏。亦不为魔事之所系缚。当知是菩萨得五种自在。何等为五。一者寿命自在。二者生自在。三者业自在。四者觉观自在。五者众具果报自在。彼菩萨摩诃萨。若欲过一生证阿耨多罗三藐三菩提者。以彼三昧力故即便能得。若不乐速证无上菩提。能住无量阿僧祇劫度脱众生。何以故。当知彼菩萨住于大乘。与诸菩萨常为导师。摄受一切诸余菩萨。是大菩萨厌离诸趣为众生故。亦复生于一切趣中。究竟一切菩萨所学。为般若波罗蜜之所摄受。具足一切巧方便力。知诸魔业得法究竟。彼诸菩萨承佛威神。于一切法皆得尽知。尔时遍净诸天。即以偈颂。赞世尊曰

  我等一切遍净天　　于诸佛法皆尽知
  头面归敬天人师　　诸根寂静知寂灭
  解了诸义智所供　　已度生死牟尼尊
  我今赞叹大导师　　能善导他非他导
  诸法性相非究竟　　亦复无有依住处
  如来善知妄想事　　犹如幻师知幻术
  智人解了语言音　　喻若深谷诸响声
  世尊如是善知见　　一切世间天人等
  无有众生及以命　　亦复无人无寿者
  大智观察一切想　　了达众想悉归空
  二足世尊慈无等　　恒常行慈不暂舍
  一切世间诸天人　　不能测知如来智
  导师演说缘众生　　所谓慈心是善修
  了知一切诸众生　　无有众生及命者
  我等于此无垢浊　　其心清净离疑惑
  是故于佛胜智慧　　应受供者令供养
  于其十方世界中　　求苦毕竟不可得
  如来无上天中天　　说于众生起慈心
  斯即是其世尊教　　我今得解亦如佛
  是故我于世间解　　今得供养应供者
  既无众生亦无苦　　是故无有可救度
  已得遣除心忧闷　　便获欣喜大踊悦
  如是佛教不思议　　我等已得如实知
  是故我今供养佛　　愿得如来无上智
  佛于诸趣不见苦　　涅槃亦复不可得
  增上弃舍于生死　　以此饶益诸世间
  无苦无趣无众生　　亦无涅槃而可依
  如是得知佛法已　　是故我等今供养
  佛具慈悲及喜舍　　转为世间常演说
  而复不见有众生　　得住于四无量心
  不见有其放逸者　　亦复不见不放逸
  如是知佛教法已　　我今供养大导师
  于身离身无上士　　观身毕竟不可得
  虽然亦非不有说　　而说有念失念者
  善逝常说修学念　　所谓观身正念处
  我等如是知佛法　　今得供养救度者
  世尊观受不可得　　以受无有体性故
  亦复观察于受者　　毕竟无其真实性
  又复观彼修念者　　究竟亦复不可得
  我等如是知佛性　　今得供养天人师
  观心及以心数法　　毕竟无体不可得
  亦复不见有修念　　及以正住念处者
  佛说念与心和合　　乐求解脱应修学
  我等如是知佛教　　今得供养正遍知
  如来不见有诸法　　亦复不见修法者
  大圣所说修习念　　彼念亦复性自空
  复说念与法和合　　欲求解脱应当修
  我等如是知佛法　　今得供养一切智
  念处一尚不可得　　何况而复有三四
  所谓于彼念住处　　彼诸念处皆悉无
  是故真求不可得　　毕竟无受苦乐者
  我等如是知圣教　　今得供养佛世尊
  牟尼所说四正勤　　若有比丘专修习
  斯即能为解脱路　　当得出于生死海
  而无解脱无缚者　　无佛无教及菩提
  然复不坏假名用　　是故我今供大圣
  佛说四种如意足　　胜妙安隐解脱道
  寂静诸根众生辈　　修行此道得涅槃
  如意及足修行者　　真实观察不可得
  而非断绝示有作　　智慧境界不可见
  如是世尊教法中　　我等于此皆悉知
  其心清净无垢秽　　皆得远离诸疑惑
  以斯即为上供养　　供养堪受胜供者
  是故妙智无伦匹　　我今悉得修供养
  世间解者说五根　　出世能趣解脱道
  慎莫放逸常勤修　　是为趣向涅槃路
  无根及以修根者　　亦无解脱及脱者
  我等于此悉无疑　　是故今得供养佛
  导师所说五种力　　非邪能趣涅槃城
  此能尽灭烦恼缚　　令诸缚者得解脱
  彼诸力体性自空　　烦恼及佛皆亦无
  我等于此无疑虑　　是故今得供如来
  大仙所说七种善　　菩提分法最胜道
  能解一切众生缚　　趣向涅槃大正路
  无有系缚及解脱　　亦无受缚得脱者
  我等于斯无疑惑　　是故今得供养佛
  世尊说此八正路　　显示一切诸群生
  是诸烦恼苦之本　　修学圣道能断除
  斯等二法离对治　　所谓圣路及烦恼
  诸天于此悉无疑　　故今供养应供者
  修奢摩他及舍那　　斯道能尽诸苦边
  令受诸苦习气垢　　世尊旷劫已荡除
  奢摩他及舍那果　　是等一切皆悉空
  天众于此离疑网　　是故我等今供养
  佛说不净治贪欲　　慈心对治于嗔恚
  毗婆舍那痴对治　　如来显示诸众生
  斯皆无作无暂停　　是故无垢亦无净
  我等于是悉无疑　　常乐供养大导师
  如来所说十不善　　斯等名之为业道
  杀生偷盗及邪淫　　妄语两舌与恶口
  绮语贪欲及嗔恚　　最后第十名邪见
  佛说此等为不善　　是诸众生恶业道
  既无众生亦无害　　自余九业亦如是
  无有对治诸善恶　　以彼自性空寂故
  然复非无十力教　　以其不坏法体性
  我于佛慧亦不疑　　是故今供无上智
  若有修此如来法　　是人即为真佛子
  彼人处处皆受乐　　恒常远离诸苦恼
  如是善逝胜智慧　　安隐引导诸群生
  我等于此离疑心　　今悉供养应供者

尔时遍净诸天偈赞佛已。咸皆默然却住一面。尔时世尊。见彼天众默然而住。及知彼天深信心已而现微笑。尔时慧命马胜。以偈问曰

  今佛世尊最胜智　　为利世间现微笑
  十力世雄超一切　　而能化伏诸大众
  善解诸法大导师　　所现微笑非无因
  心无所乏世间解　　唯愿解说微笑义
  此诸大众皆一心　　无其乱想住正念
  喜心瞻仰功德山　　唯乐听闻恭敬住
  于佛自在大论师　　若得闻说必欣喜
  善解诸法决定智　　当得作佛导群生
  若人于佛生净信　　必成大智世间最
  测知微妙甘露句　　是人能观于十方
  谁于未来世劫中　　当得作佛愍世间
  微妙言辞大导师　　唯愿说彼令众喜
  若于圣雄沙门所　　生其敬信尊重心
  亦住正法生信慧　　一切诸魔不能动
  若能生信得决定　　即是佛子从心生
  唯愿世尊演说彼　　以是大众得除疑
  若有于其众生所　　慈心普覆遍世间
  智慧坚固当成佛　　便得安住一切智
  百福庄严无上士　　唯愿开演除疑网
  谁欲受持世尊法　　如来为其现微笑
  愿得闻佛善巧说　　具八功德微妙音
  先自得趣于善道　　后能引导诸群生
  如是善逝微妙法　　佛子得住于彼中
  世尊佛种不断绝　　必得久住于世间

尔时世尊即以偈答慧命马胜言

  马胜汝今问笑光　　我为利益诸世间
  汝获福德称其心　　斯福无量不可尽
  妙士乃能应时问　　以是大利诸众生
  汝及一切大众等　　欣喜一心听我说
  斯等遍净诸天众　　于我法中悉无疑
  一切欣喜净信心　　以偈赞颂我功德
  此天曾于过去世　　供养千亿那由佛
  亦于彼佛问斯义　　一切法中得无疑
  由彼往昔因缘故　　今以偈颂赞叹我
  亦复净心当赞叹　　贤劫一切诸如来
  当于优波罗劫中　　成佛大力那罗延
  教化不思那由众　　引导入于涅槃城
  彼诸大仙成佛时　　所得名称甚微妙
  我今为汝说彼佛　　一心寂静善谛听
  同其劫中悉作佛　　号曰法幢等正觉
  咸皆救度不思议　　那由他众入涅槃
  彼诸如来灭度已　　焚身广布诸舍利
  以此舍利皆起塔　　遍满佛刹如散花
  尔时一切佛舍利　　各各皆悉广流布
  彼佛一一涅槃后　　咸皆饶益于世间
  不思那由众生辈　　供养彼佛舍利已
  当得甘露妙涅槃　　三世诸佛之所赞
  若有称彼诸佛名　　所获微妙胜善根
  当得成就有学道　　值佛转获殊胜果
  犹如无量难思众　　皆于我所种善根
  欣喜信乐清净心　　当得值遇弥勒佛
  如是彼佛声闻众　　从佛复至诸佛所
  常得值佛入众会　　皆由供养彼舍利
  得闻如斯佛语已　　一切大众生希有
  胜妙功德有威神　　遍净诸天清信士
  及诸大众普欣喜　　悉皆流注向菩提
  得知如来大势力　　咸各顶礼世尊足

大宝积经卷第六十八大宝积经卷第六十九

        北齐三藏那连提耶舍译

    菩萨见实会第十六之九广果天授记品第二十二

尔时八亿广果诸天。见诸阿修罗伽楼罗龙及龙女鸠槃茶乾闼婆夜叉紧那罗摩睺罗伽。诃罗伽阇天。四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵摩天。光音天。遍净天等。供养如来闻授记已。欣喜踊跃。皆得称心。入一一法门。从一一法门见无量法门。于一切法门。得无量辩不断辩相应辩解脱辩无著辩无碍辩微细辩甚深辩种种辩美妙辩相续辩。于诸辩才皆悉知已。于如来所敬信尊重。而作是言。世尊。有陀罗尼名无量门。若有菩萨修集是陀罗尼者。当知得彼不断辩等。于一切境界中心不迷惑。是诸境界无有一法非陀罗尼。是菩萨摩诃萨得是陀罗尼时。于诸法中悉得陀罗尼解辩才无碍。若菩萨住是无量法门陀罗尼时。于五阴入十二入入十八界。入于诸根。入四谛。入十二因缘。入于众生入及非众生。入于有入非有。入于取相入非取相。入于依入非依。入于空入于我。入于相入非相。入于愿入非愿。入于有为入无为。入如是一切处。得不坏辩才。是菩萨于阴入中得陀罗尼。所谓色阴者即非成就。何以故。无有少色法得成就者。何以故。地地界性非成就。如是水火风界性亦非成就。何以故。地性离故。若法无体性是名非成就。如是水火风性自离故。以法无体性。是故非成就。如是色非成就。以非成就故。不可说名过去现在及以未来。何以故。色非有法故。是故不可得。若色不生者即是不灭。以不生灭故。即不可说。复有如是说。所有过去色现在未来色。此等和合名为色阴。其色体性亦不可得。何有过去现在未来。是故色阴非是可说。受想行识亦复如是。是故阴入即是陀罗尼入。以陀罗尼入故。阴不可得。以阴不可得故。陀罗尼亦不可得。以陀罗尼入不可得。唯是但名但用但假。但是世俗。但是言说。但是施设。非阴非色亦非色入。亦非陀罗尼体性可得。何以故。所谓阴等非是作法。以非作法故。无有积聚。以积聚故。得名为阴。譬如世间多物积聚。假名城屋舍宅殿堂。重阁楼阙窗牖栏楯。城壁女墙却敌寮孔。周回具足名之为城。彼色性即不可得无有积聚。以无积聚故。即便无色亦无色阴。受想行识亦复如是。性不可得无有积聚。以无积聚故。即便无识亦无识阴。彼诸阴入应如是知。彼眼入者是谁入。谓苦入。何者是眼谓清净四大所造色名为眼。何等是四大。谓清净地界水火风界。彼净地界性自离故。以法体不可得。彼即非成就。如是清净水火风界体性自离。以法体不可得。彼即非成就。如是眼入非成就。是故不可说言过去现在未来。何以故。眼入非物。以非物故不生不灭。若不生灭者即是不可说。如是眼不生灭。入亦不生灭。以不生灭故。即是不可说。应当如是知。唯是但名但用但假。但是世俗但是言说。彼名名体亦离自性。何以故。无有一法得名为眼名为入名为苦。以名不可得。是故眼入亦不可得。以眼不可得即是陀罗尼入。是陀罗尼入亦不可得。何以故。性自离故。但名但用但假施设世俗言说。如是以眼入入得陀罗尼。得陀罗尼已便得辩才。当知耳鼻舌身意色声香味触法亦皆如是。于彼界入得陀罗尼眼。眼体不可得界体不可得。何以故。眼离眼性故。界离界性故。以法体不可得。彼即非物。以非物故即非成就。非成就者不生不灭。以不生灭故。彼即非过去非现在非未来。但名但用但假但世俗但言说但施设。彼名离名自性。乃至施设亦离施设自性。若法无自性不可得者。即是非物。以非物故即非成就。非成就者即非生灭。以不生灭故。彼即非过去非现在非未来。若于三世所不摄者。彼名即非相亦非想。非用非假。非有为非可说。非来非去。非可为他说非可显示。非可知非可识。非黑非白。非窟宅离窟宅故。非至非可至故。非得非可得故。非证非可证故。非凡夫亦非凡夫地。非声闻亦非声闻地。非缘觉亦非缘觉地。非菩萨亦非菩萨地。非佛亦非佛地。非地亦非非地。此即是真如不异如非非如。寂灭无相但用但假。谓如来者但世俗故说名如来。非第一义有如来也。何以故。彼法不可得故无如来。于彼界入。应当入如是眼耳鼻舌身意界法界意识界。如是一切余界亦应知。应当如是广入法界。世尊。彼法界说言阴时。而不坏彼法界本性。说言入时说言界时。说言四谛时。说言十二因缘时。亦不坏本法界体性。彼法界随所说处。一切诸法建立名字。皆不坏彼法界体性。世尊。譬如地界随其所在作异名字。而不坏彼本地界性。世尊。如是法界随其所在作异名字。亦复不坏法界本性。如是水火风界亦复如是。世尊。譬如虚空随其所在差别异用。而不坏彼虚空体性。世尊。如是法界随其所在差别名用。而不坏彼法界体性。世尊。入诸根时即是入法界。言诸根者。所谓眼根耳根鼻根舌根身根意根。男根女根命根。乐根苦根喜根忧根舍根。信根精进根念根定根慧根。未知欲知根。知根知己根。彼眼眼体不可得根。根体不可得。何以故。是眼离眼自性故。以法无体性彼即非物。以非物故即非成就。非成就者彼即不生。若不生者即是不灭。以不生灭故。不可说言彼是过去现在未来。若于三世中不生灭者。彼即非眼亦非眼根。云何有用应。如是知。世尊。譬如空拳虚诳无物。但有名字乃至言说。于第一义中空拳。亦无如是眼及眼根。犹如空拳虚妄非实而现虚相诳惑凡夫。但有名字乃至言说。于第一义。眼及眼根俱不可得。如是世尊得一切智已。为度众生故说名为根。彼等诸根于第一义。性自离故根体皆空。其法体空者用亦虚妄。非有非实诳惑凡愚。离自性故不生不灭。不生灭者不得说言彼是过去现在未来。若于三世中无者彼即无名无相。非可说非可为他说。非生非可生。非已知非当知。非已闻非当闻。非识非可识。非已证非当证。非已得非当得。非已见非当见。非已到非当到。何以故。彼非有故。世尊。譬如有人于其梦中受乐喜笑呓语游戏。是人尔时从寐寤已忆念梦中受乐游戏。念已求之不见不得。何以故。彼人梦中受乐喜笑呓语游戏。尚自无实何况寤时。若见若得无有是处。世尊。如是诸根犹如梦中受乐游戏实不可得。如是一切诸法体性亦不可得。以不可得故。不可说言彼是。过去现在未来。若于三世中不可得者。彼即不可说。一切诸根当如是知。世尊。若入法界即入一切法。入一切法即是入法界。世尊。入四谛法即是入法界。何等为四。谓苦集灭道。世尊。亦说一切诸法皆悉是空。非众生。非命。非福伽罗。非想非相。我等于此法中无有疑虑。世尊。以无众生故亦复无苦。何以故。众生无处苦谛亦无。以无苦故集谛亦无。何以故。无如是因而无果者

世尊。以无集故灭谛亦无。何以故。无集谛故亦无断集。以无灭故道谛亦无。何以故。无有是道不断集者

世尊。道果者谓是灭谛。彼烦恼不可得断。烦恼灭亦不可得。以灭不可得故道亦不可得。无有如是道而无其果。此四圣谛但是分别虚妄非有。以非有故。不可说言过去现在及以未来。若于三世中不可得者。彼即非生非灭。非相非想。非设非可设。非示非可示。非显非可显。非语言非可语言。非言辞非可言词。非说非可说。非见非可见。非知非可知。非识非可识。非测非可测。非达非可达。非到非可到。非得非可得。非闻非可闻。非见非可见。非对非可对。非证非可证。非白非黑。非明非暗。非去非来。非浅非深。非清非浊。非畏非安。非缚非解。非憎非爱。非烦恼非清净。非智非非智。非路非非路。非坏非非坏。非摄受非非摄受。非生死非非生死。非可得非不可得。非众生非非众生。非命非非命。非寿者非非寿者。非我非非我。非物非非物。非空非不空。非相非非相。非愿非不愿。非依非不依。非有为非无为。非断非常。非邪非正。非实非妄。非妄想非非妄想。非处非非处。非宅非非宅。非知非不知。非舍非修。非生死非涅槃。非觉非不觉。非凡夫境界。非声闻境界。非缘觉境界。非菩萨境界。非佛境界。非境界非非境界。非作非不作。如是入谛即是入法界。入法界已即得陀罗尼。得陀罗尼已即得辩才。入十二因缘即是入法界。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘渴爱。渴爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。是众苦大聚。如是无明灭则行灭。乃至忧悲苦恼灭众苦大聚灭。世尊。彼无明无明体不可得。何以故。性自离故。若法无体性彼即非物。以非物故即非成就。非成就者非生非灭。非生灭者即非过去非现在非未来。若于三世中不可得者。无名无形无相无想亦非差别。唯是但名但假但用但世俗但言说。为教化一切凡夫众生故。彼无明于第一义实不可得。不可得者即非差别用亦不可说。世尊。若是但名乃至但施设。彼即非实唯是虚妄。言说分别觉观非定。但是戏论。彼无明若无自性者。云何能生行。无明无故行亦不生。以不生故。彼即不老不病不死不流转即不生。何以故。若不生者云何有老。以无老故乃至不生。若不生不死者。即是一切过现未来诸佛菩提。但世俗名字非第一义。所言无明即是菩提。当知诸有支亦复如是。如是入十二因缘。当知即是入于法界。世尊。如来不生。一切诸法亦不生。是故一切法即是如来。如来不灭。一切诸法亦不灭。是故一切法即是如来。世尊。如来无相。一切诸法亦无相。是故一切法即是如来。略而言之。如是无相不可得。非垢非净非爱非憎。法界不可识。亦复不可知。世尊。真如者即是如来。一切诸法即是真如。是故一切法即是如来。世尊。实际者即是如来。一切诸法即是实际。是故一切法即是如来。世尊。随所法中即有如来。于其法中即有一切法。是故一切法即是如来。世尊。若有人言如来得阿耨多罗三藐三菩提者。彼诸众生是计着见。何以故。如来不二。菩提亦不二。不二者不能觉寤于不二。世尊。若复有人作如是言。如来转于无上法轮。彼诸众生是执着见。何以故。如来非进退。世尊。若复有人作如是言。如来灭度无量众生。彼等一切皆是执见。何以故。一切诸法实无众生。是故无有得灭度者。世尊。若复有人作如是言。如来利益无量众生。彼等一切是取着见。何以故。如来不为利益众生。亦复不为不利众生出现于世。世尊。若复有人于未来世作如是言。如来舍寿。彼诸众生皆是执见。何以故。法界无摄受亦无舍故。世尊。若复有人作如是言。如来入于无余涅槃界。彼诸众生是计着见。何以故。法界非生死亦非涅槃。世尊。若复有人于我所说法。能决定知者。彼诸众生于阿耨多罗三藐三菩提皆不退转。世尊。假使法界有其变异。是诸善男子善女人能如是信者。必定当觉无上菩提无有变退。尔时八亿广果诸天。于世尊所演说自己所证法已。头面礼足右绕三匝却住一面。合掌而立异口同声以偈赞佛

  敬礼善逝知法者　　那罗延力大导师
  怜愍一切胜牟尼　　方便示现于真实
  既自了知一切法　　如实显示诸世间
  稽首无量功德身　　智慧最胜无上士
  如是真实微妙法　　圣说相应无有异
  世尊无等大医王　　能令众生法眼净
  敷演八种真圣路　　为得无上大菩提
  归敬无量功德身　　智慧最胜无上士
  显示菩提正直道　　毕定趣向大涅槃
  获得无等胜菩提　　寂灭安隐最坚固
  度脱多亿那由他　　轮回生死苦众生
  顶礼无量功德身　　智慧最胜无上士
  观察五阴悉空无　　阴体毕竟不可得
  彼阴即体离诸观　　唯诳愚惑痴众生
  凡夫于此悉被缚　　犹如猕猴胶所粘
  智者于斯得解脱　　游行无碍如空风
  诸界即体性自空　　一切智人如是说
  彼空亦空无自性　　究竟求之不可得
  凡夫于此皆被缚　　都由不知真实性
  智者观察得解脱　　于其三界无所著
  诸入无体自空寂　　一切智人如是说
  犹如空拳虚非实　　诳惑愚痴众生辈
  凡夫妄起取着心　　皆由于法生疑惑
  坠落生死皆丧坏　　犹如商人没巨海
  彼等诸根性自空　　毕竟推求不可得
  譬如镜中现面像　　其像无实毕竟空
  凡愚无智于此着　　正由不知真实法
  犹如众鸟入罗网　　亦如渊中所钓鱼
  众生无体离生相　　依真求之不可得
  譬如壁上彩画像　　究竟无实众生性
  凡夫无智而取着　　皆由不知真实义
  智者观彼得解脱　　犹如卵生出于[穀-禾+卵]
  因缘生法悉无常　　皆悉空寂离攀缘
  譬如梦中所受乐　　非实诳惑痴凡夫
  愚无智慧为彼缚　　由不思量妄分别
  智人观察得解脱　　犹如飞鸟出笼网
  如佛功德不思议　　一切诸法亦如是
  诸法无相如牟尼　　法体寂灭如涅槃
  诸法无依如如来　　于其三界不取着
  是故所有成佛者　　皆由得知此义故
  诸法无怖如世尊　　不起自身及他想
  诸法难思如导师　　唯佛能知导群生
  法无分别如善逝　　非是凡夫心所行
  是诸如来妙境界　　唯佛大圣能了知
  若有无智作是言　　佛证无等大菩提
  若复有人作是言　　世尊已转妙法轮
  若复有人作是言　　善逝已度那由众
  彼悉为见之所缚　　皆由不知真实性
  若人谓佛如是说　　杀害行阴及与命
  若言十力入涅槃　　利益无量众生已
  彼人一切皆执见　　入于魔罗之所缚
  不能解知真如法　　以不知故不知佛
  若有善知是非者　　彼皆能知大导师
  当获无上功德聚　　成佛怜愍于世间
  斯即真如无变易　　一切诸法离疑惑
  人中无上最胜尊　　我等已知如是义
  如是广果诸天众　　咸皆于法得尽知
  对佛导师自演说　　现己内心净信解
  一切欣喜无疑虑　　各自见已当成佛
  此是如来微妙法　　彼即自受导师记

尔时世尊知广果诸天深信具足于佛法中决定无疑。欲令大众种善根故。而现微笑。尔时慧命马胜以偈问世尊言

  智慧导师功德山　　非是无因而现笑
  我从善逝亲自闻　　世尊现笑必有因
  如来示此微笑相　　令众皆受清凉乐
  天人修罗大导师　　唯愿演说笑因缘
  今见如来从面门　　所现微笑甚清凉
  此诸众会悉怀疑　　一心瞻仰如来面
  大悲最胜人中上　　愿说希有微笑因
  世间若得从佛闻　　决定必除疑惑心
  世尊彼等诸天众　　咸皆演说自授记
  以何功德获何果　　愿说成佛神通事
  开演微妙梵音声　　唯愿普断诸有疑
  一切大众闻佛说　　皆悉踊悦甚欣喜
  斯等合掌皆一心　　净信瞻仰恭敬住
  佛子天众各思惟　　悕求无上大菩提
  是诸众会有疑惑　　唯愿如来为除断
  必当得力知是非　　具足成就一切智
  得闻如来八种音　　天众靡不皆喜悦
  当得护持如来教　　随顺正法如说行
  观察知彼天心已　　无上大智愿解说
  以是大众生欣喜　　于佛法中得信解
  今于导师愿得闻　　天众过去所修行
  若蒙如来解说已　　所愿皆悉得满足
  广果诸天如法行　　必得成就一切智
  当度世间诸群生　　显示真如法体性

尔时世尊即以偈答慧命马胜曰

  善哉马胜汝知时　　今者问我正是宜
  我为广果诸天辈　　于此大众现微笑
  今当为汝分别说　　咸皆一心共谛听
  所现微笑因缘义　　汝及大众悉得闻
  如来具足一切智　　观察因缘有三种
  二足德聚正观已　　而现微笑示世间
  有乐住于涅槃者　　少智微浅愿声闻
  复有乐住默然者　　志求辟支佛菩提
  复有乐求世导师　　成佛大力那罗延
  我观彼等深信已　　随所乐欲而度脱
  为求声闻示现者　　当知是其最下笑
  应当知我中品笑　　为求辟支而示现
  马胜当知此上笑　　为诸天众授佛记
  我说此三解笑因　　所谓最下及中上
  善解世间胜导师　　而作微笑现瑞相
  佛知众生欲三乘　　愿乐求证于圣果
  为求声闻现笑者　　微笑光明从足没
  为求辟支所示现　　当知笑光入脐轮
  为受无上十力者　　其光从佛顶上入
  马胜汝今应当知　　微笑因缘有三种
  我向所现微笑光　　彼光于我顶上没
  当知先所现微笑　　悉为无上菩提记
  我今当更为汝说　　微笑复有三种因
  善哉马胜及大众　　一心静意俱谛听
  前现微笑为佛者　　其光即从顶上入
  有光少时住身腰　　须臾没者为辟支
  我现微笑放光明　　暂时在于足前住
  斯光随乘而变现　　当知此为声闻人
  今复更说微笑因　　马胜谛听有三种
  导师所放诸光明　　出已围绕于十力
  其光既出皆疏散　　还复速聚绕身腰
  渐渐转复更增广　　亦还右绕于如来
  有光初停后广大　　渐渐右绕于我身
  彼光悉遍世尊形　　与身俱等无有异
  其光庄严佛身相　　晖赫犹如真金聚
  牟尼所放微笑光　　当知此光记刹土
  有光出已犹如盖　　于上遍覆世尊身
  有光如花空中住　　其光照曜于导师
  彼光一切皆右旋　　三匝围绕如来身
  当知此光记寿命　　出世大智现斯瑞
  斯等三种微笑光　　善逝随根差别现
  马胜汝今应当知　　此是三种微笑因
  世间导师所现相　　善知众生深信乐
  今于如来教法中　　汝等闻此得除疑
  是诸广果天众等　　其数满足有八亿
  广说微妙正法门　　各于异刹得成佛
  寿命具足无有量　　经由多劫住于世
  是故如来现斯瑞　　广大光明五种色
  此诸天众于过去　　三十有六僧祇劫
  常得值遇诸世尊　　亲承供养习诸善
  又复经于三十六　　阿僧祇劫广修行
  斯等大士住世间　　供养如来未曾倦
  思惟救度众生故　　数数勤修供养佛
  供养世尊应其宜　　悕求无上大菩提
  彼诸天众未来世　　当得作佛那罗延
  成妙牟尼功德山　　其劫号曰胜金幢
  是诸如来各自住　　清净庄严国土中
  彼佛同号日光轮　　具足无量功德聚
  一一如来各住世　　经于无量那由劫
  此诸善逝所集众　　无量无边不可数
  一一导师成佛时　　所有声闻弟子辈
  十力住经那由劫　　算数彼众不可尽
  若有算师悉共聚　　亦算彼众不能尽
  当时所有诸菩萨　　倍多于彼声闻众
  皆悉发心住佛乘　　愿得当成一切智
  于其清净国土中　　悉当成佛具十力
  是诸菩萨所修行　　皆如本师无有异
  彼诸如来灭度后　　正法兴显久住世
  经于十二那由劫　　为诸佛子所护持
  此诸佛法炽盛时　　有发无上菩提心
  其数过于恒河沙　　皆悉勤修菩萨行
  彼诸善逝灭度已　　所有一切声闻众
  斯众皆悉得涅槃　　过于大海诸沙数
  如是彼诸佛正法　　具足兴显于世间
  饶益无量诸众生　　彼教如法大兴盛
  如是闻佛所说已　　一切大众皆信解
  必当得成佛世尊　　广能利益诸群生
  是时众会悉欣喜　　头面礼拜如来足
  无等恭敬于善逝　　如法供养天人师
  是故踊跃发精进　　犹如有人救头燃
  常应亲近善知识　　勤修般若波罗蜜
  此是见实胜进行　　汝等比丘应修习
  当成无上二足尊　　功德如山利世间

大宝积经卷第六十九大宝积经卷第七十

        北齐三藏那连提耶舍译

    菩萨见实会第十六净居天子赞偈品第二十三之一

尔时净居诸天子。知无量众生得住菩提。于佛法中无有疑虑已。称意踊悦。各以妙偈赞佛功德

尔时信施天子。以偈赞曰

  所爱妻子施　　并舍所重身
  乃至王位财　　我礼檀度者

尔时乐持戒天子。以偈赞曰

  如来本持戒　　一切无所著
  获果到彼岸　　我礼戒度者

尔时乐忍天子。以偈赞曰

  佛昔修忍辱　　堪受解支节
  初无悔恼心　　我礼忍度者

尔时乐精进天子。以偈赞曰

  不退勇健首　　精进有大力
  已得上菩提　　我礼进度者

尔时乐禅天子。以偈赞曰

  佛本修禅定　　世间所不知
  三际得平等　　我礼禅度者

尔时威德天子。以偈赞曰

  大雄于般若　　相续而修行
  获得无尽慧　　我礼智度者

尔时界慧天子。以偈赞曰

  布施及爱语　　利益与同事
  以此度众生　　我礼大导师

尔时净慧天子。以偈赞曰

  于大慈悲喜　　长夜常修习
  以是济群生　　归命大船师

尔时净心天子。以偈赞曰

  以度无诤行　　调心大牟尼
  能调未调者　　我礼调御师

尔时无垢慧天子。以偈赞曰

  广心柔软心　　心调及诸根
  知诸众生心　　我礼悉知者

尔时净意天子。以偈赞曰

  具足正念者　　安住坚慧中
  明达悉了知　　礼觉觉他者

尔时庄严心天子。以偈赞曰

  佛久心清净　　亦净佛国土
  及净群生慧　　我礼净法王

尔时无胜天子。以偈赞曰

  所愿无能坏　　降伏魔怨力
  满足诸大愿　　悦喻诸天众

尔时速营事天子。以偈赞曰

  如来速知法　　亦疾净众生
  已见难见法　　我礼速事者

尔时坚精进天子。以偈赞曰

  处处悉解脱　　离痴无诸漏
  已度彼岸住　　我礼坚固力

尔时乐威仪天子。以偈赞曰

  离欲无诸过　　除闇得漏尽
  为世胜福田　　我礼应供者

尔时善住天子。以偈赞曰

  世尊住正法　　三界所供养
  一道安隐行　　是故我敬礼

尔时无动天子。以偈赞曰

  佛如坚固山　　不为风所动
  毁誉常平等　　是故今敬礼

尔时得平等天子。以偈赞曰

  大雄色殊胜　　具三十二相
  有大深智慧　　我礼端正智

尔时深慧天子。以偈赞曰

  非身大身者　　安住真如法
  显说于实际　　世间无与等

尔时无等碍慧天子。以偈赞曰

  究竟同不二　　勇健能伏魔
  不疑于深义　　照法到彼岸

尔时喜意天子。以偈赞曰

  喜意本勇健　　所学皆通利
  弃舍此三界　　如蛇脱故皮

尔时定意天子。以偈赞曰

  譬如闇室灯　　油尽故明灭
  智者如是灭　　由闻佛法故

尔时住舍摩他天子。以偈赞曰

  如来普观察　　为欲所结缚
  佛能断彼罥　　由执智剑故

尔时多舍摩他天子。以偈赞曰

  定心及定行　　定威仪境界
  佛能灭烦恼　　我礼伏怨者

尔时无畏舍摩他天子。以偈赞曰

  学佛舍摩他　　菩萨得名称
  正定导引故　　成就定心佛

尔时定食天子。以偈赞曰

  寂灭一切法　　大雄所演说
  解彼大智者　　疾成于如来

尔时常观天子。以偈赞曰

  常观诸众生　　悉随如来学
  获得胜菩提　　满足大智慧

尔时持德天子。以偈赞曰

  如来智彼岸　　菩萨修学故
  成世大威德　　能见无量法

尔时造光天子。以偈赞曰

  彼得不思光　　当获无垢乐
  照世如来所　　得闻智境界

尔时无垢光天子。以偈赞曰

  诸法无分别　　以善方便故
  修习如是智　　故成妙丈夫

尔时无所住天子。以偈赞曰

  无住无触娆　　诸法无所觉
  不觉于自他　　佛依真实见

尔时宅慧天子。以偈赞曰

  诸法无窟宅　　导师如是见
  为众生说故　　随顺取法相

尔时无依慧天子。以偈赞曰

  诸法无所依　　远离于彼此
  如来显真实　　如掌庵罗果

尔时虚空行天子。以偈赞曰

  知法如虚空　　不生亦不灭
  佛见法如是　　故能离世间

尔时无积聚天子。以偈赞曰

  无求亦无慢　　无觉无不觉
  依真无自性　　是佛见世间

尔时修慧天子。以偈赞曰

  犹如巧幻师　　幻作种种事
  非实而见实　　故佛无与等

尔时喜悟天子。以偈赞曰

  譬如镜中像　　虽见非真实
  佛如是见法　　不迷于世间

尔时除疑天子。以偈赞曰

  佛如呼声响　　诸法亦复然
  说闻俱非实　　是佛见世间

尔时无碍辩天子。以偈赞曰

  安住正法者　　辩才深妙说
  世尊久证法　　故能具足辩

尔时无障智天子。以偈赞曰

  依真无自性　　一切法如是
  如来如实知　　故能除闇冥

尔时无忧天子。以偈赞曰

  无忧亦无恼　　无静无娆浊
  诸法无垢染　　佛见真实性

尔时行具足天子。以偈赞曰

  无来亦无去　　诸法无所有
  如来真实见　　如是为世说

尔时胜慧天子。以偈赞曰

  无染亦无净　　非愚亦非智
  诸法无能所　　佛依如实见

尔时得无碍天子。以偈赞曰

  非明亦非闇　　非色非非色
  非缚非解脱　　佛慧如实见

尔时勇目天子。以偈赞曰

  非局亦非遍　　非有亦非无
  如梦受五欲　　佛见法如实

尔时不瞬天子。以偈赞曰

  不生亦不灭　　亦不住中间
  迷彼无智者　　唯佛见真实

尔时住空天子。以偈赞曰

  非人非众生　　非用非世财
  随说故有用　　佛能真实见

尔时住无相天子。以偈赞曰

  所用一切法　　彼皆悉无相
  诸法性相离　　导师如是见

尔时无愿天子。以偈赞曰

  因法空无相　　以是不起愿
  假设有愿求　　唯佛如实知

尔时三昧流注天子。以偈赞曰

  已得解脱门　　无有解脱者
  烦恼本亦无　　佛见真实性

尔时无毁天子。以偈赞曰

  舍弃一切恶　　集诸功德聚
  故佛无毁訾　　亦无毁呰事

尔时电云天子。以偈赞曰

  犹如雷电云　　降雨充大地
  佛注正法雨　　充足诸群生

尔时不唐愿天子。以偈赞曰

  世尊辞无上　　能转正法轮
  明达深法理　　具足一切智

尔时具智慧天子。以偈赞曰

  无生亦无灭　　诸法自性尔
  如来善知故　　亦复转教他

尔时师子吼天子。以偈赞曰

  如来师子吼　　演说空法时
  外道皆怖畏　　如兽畏师子

尔时业无放逸天子。以偈赞曰

  现前无放逸　　佛修成菩提
  导师于正法　　无逸到彼岸

尔时住无放逸天子。以偈赞曰

  安住不放逸　　增益佛正法
  十力及余行　　佛法不思议

尔时无放逸生天子。以偈赞曰

  会于无放逸　　助道得生长
  以此济群生　　佛亦自解脱

尔时成无放逸天子。以偈赞曰

  无逸得成就　　诸有依解脱
  声闻及菩萨　　皆从如是学

尔时不逸行天子。以偈赞曰

  所有诸佛子　　常不放逸行
  能取一切智　　善观世间故

尔时无逸护天子。以偈赞曰

  佛修菩提时　　守护不放逸
  逮得胜菩提　　大悲庄严故

尔时住不放逸天子。以偈赞曰

  若住不放逸　　拣择一相法
  佛子大勇健　　当得父遗财

尔时乐不放逸天子。以偈赞曰

  勇健乐不逸　　能破烦恼山
  是等以佛智　　疾灭高慢聚

尔时坚持不放逸天子。以偈赞曰

  守护无放逸　　昔求一切智
  阿僧祇亿劫　　佛心无疲倦

尔时舍摩他现前天子。以偈赞曰

  法寂自性尔　　是诸佛境界
  智者依彼住　　能趣胜菩提

尔时依舍摩他天子。以偈赞曰

  诸佛依舍摩　　依而不取着
  众生烦恼灭　　如雨淹诸尘

尔时住舍摩他天子。以偈赞曰

  诸佛住舍摩　　不动如大山
  天魔不能坏　　心寂故归命

尔时舍摩他调伏天子。以偈赞曰

  舍摩所调伏　　佛子无讥毁
  亿魔不能动　　离欲如罗汉

尔时修舍摩他天子。以偈赞曰

  大雄昔修习　　舍摩他定时
  无有知佛心　　依何得禅定

尔时舍摩他上首天子。以偈赞曰

  佛转正法轮　　奋得舍摩他
  余法悉依彼　　以是获菩提

尔时留舍摩他天子。以偈赞曰

  佛说舍摩他　　是为心笼网
  众生堕迷狱　　佛教降伏心

尔时舍摩他境界天子。以偈赞曰

  诸佛妙境界　　是为舍摩他
  修此得无碍　　成就大导师

尔时满足舍摩他天子。以偈赞曰

  以禅充满心　　复更修集慧
  故佛得菩提　　复能安众生

尔时重舍摩他天子。以偈赞曰

  不见有余道　　唯在佛法中
  获得大智慧　　成就无上士

尔时欣毗婆舍那天子。以偈赞曰

  佛依毗舍那　　能视一切法
  菩萨随顺学　　成就自然智

尔时生毗婆舍那天子。以偈赞曰

  到智彼岸故　　成就大医王
  显示四真谛　　皆由毗舍那

尔时住毗婆舍那天子。以偈赞曰

  住毗婆舍那　　如实知诸法
  勇健证菩提　　能成大导师

尔时修尽毗婆舍那天子。以偈赞曰

  大士以智慧　　修习胜菩提
  不生识境界　　成就大导师

尔时乐毗婆舍那天子。以偈赞曰

  智者依真实　　观察如此法
  能获无等果　　成佛号导师

尔时勤习毗婆舍那天子。以偈赞曰

  勤修智慧故　　能立诸苦行
  彼成难降伏　　不为邪道坏

尔时毗婆舍那天子。以偈赞曰

  所有诸佛子　　观察法相故
  彼知法相已　　成就调御师

尔时修毗婆舍那天子。以偈赞曰

  如来于长夜　　修习胜智慧
  能成一切智　　度脱无量众

尔时殊胜行天子。以偈赞曰

  佛修一切智　　成就大导师
  以法济世间　　越渡駃流水

尔时住毗婆舍那天子。以偈赞曰

  住毗婆舍那　　观察一切法
  出生诸佛法　　地生尼拘树

尔时持毗婆舍那天子。以偈赞曰

  世尊诸佛子　　摄受胜智慧
  得上菩提已　　能度诸众生

尔时游戏毗婆舍那天子。以偈赞曰

  游戏于诸法　　得佛无所畏
  无怯亦无怖　　胜智大牟尼

尔时随顺毗婆舍那天子。以偈赞曰

  大雄于诸法　　皆会毗舍那
  观察无自性　　是即佛菩提

尔时毗婆舍那坚固天子。以偈赞曰

  诸佛智坚固　　于法无所畏
  观见群生苦　　能起大悲心

尔时毗婆舍那天子。以偈赞曰

  以智趣菩提　　有智能善学
  彼得胜菩提　　度脱诸众生

尔时修空天子。以偈赞曰

  修习于空法　　智者悟菩提
  能坏诸牢狱　　亦度结缚者

尔时解空天子。以偈赞曰

  世尊解空故　　不见于身命
  无缘无自性　　依是为世说

尔时空境界天子。以偈赞曰

  一切佛境界　　诸法性自空
  大雄于中学　　愍济众生故

尔时信空天子。以偈赞曰

  如来离臭秽　　怖畏亦久度
  不着于诸法　　如风无所依

尔时乐空天子。以偈赞曰

  修习空法者　　能乐佛境界
  彼即供养佛　　亦成无上供

尔时空建立天子。以偈赞曰

  修习空法故　　导师得建立
  通达空法已　　成就世间亲

尔时向空天子。以偈赞曰

  佛知无一法　　不是涅槃者
  诸法趣涅槃　　此是佛菩提

尔时空成就天子。以偈赞曰

  已得空寂定　　佛子得成就
  彼等供养佛　　是修空法者

尔时趣空天子。以偈赞曰

  所有归空者　　有智非愚痴
  无著断烦恼　　离垢得菩提

尔时满足空天子。以偈赞曰

  佛法得满足　　成就难降伏
  所有修空者　　能利益世间

尔时住空天子。以偈赞曰

  安住佛法中　　能修空智者
  无量诸魔众　　不能动彼等

尔时乐无相天子。以偈赞曰

  喜乐于无相　　不著有相中
  拣择诸法已　　佛能超世间

尔时无相行天子。以偈赞曰

  习行无相时　　清净寂灭行
  离相众生等　　魔不知彼趣

尔时无相境界天子。以偈赞曰

  无相佛境界　　如来于中修
  无相难证解　　我礼定行者

尔时渴乐无相天子。以偈赞曰

  此等一切众　　渴乐无相法
  悕求父资财　　供养天人师

尔时修无相行天子。以偈赞曰

  如来于无相　　昼夜常修行
  天人及鬼神　　不知佛所趣

尔时无相解脱天子。以偈赞曰

  大雄住无相　　思量一切法
  导师所修学　　是故我敬礼

尔时无相游戏天子。以偈赞曰

  大慈现游戏　　常依无相法
  成熟众生故　　住于佛智中

尔时无相成就天子。以偈赞曰

  善修离相者　　能得佛菩提
  亦能供养佛　　如子恭敬父

尔时久乐无相天子。以偈赞曰

  彼爱佛正法　　即是众生塔
  所有弃相者　　得住于师处

尔时无相道天子。以偈赞曰

  众生诸所归　　依道得济度
  无著寂灭行　　如来最无上

尔时信无相天子。以偈赞曰

  信解无相者　　寂灭离诸怨
  我礼一切佛　　自度度他者

尔时趣无愿天子。以偈赞曰

  世尊所有愿　　求之不可得
  彼等离所作　　是佛出世间

尔时修无愿天子。以偈赞曰

  于有不起愿　　修行寂灭心
  断除渴爱缚　　是佛离世间

尔时无愿生天子。以偈赞曰

  彼得大精进　　于有离爱染
  是等如来子　　悉礼自己父

尔时从无愿生天子。以偈赞曰

  彼等不起愿　　于有而坏有
  所能断爱者　　佛子离讥毁

尔时无愿解脱天子。以偈赞曰

  无愿得解脱　　不求离诸缚
  放舍不起愿　　佛子持威德

尔时出无愿天子。以偈赞曰

  出离忧旷野　　拔断爱染根
  彼等礼如来　　得除饥渴者

尔时必定无愿天子。以偈赞曰

  善知有苦者　　亦知世乐妄
  佛是彼等父　　彼为导师子

尔时向无愿天子。以偈赞曰

  于有见苦者　　彼人得调伏
  我礼善调伏　　破有调御师

尔时超无愿天子。以偈赞曰

  超度有旷野　　得住安隐处
  普礼大导师　　已伏烦恼怨

尔时被无愿铠天子。以偈赞曰

  战胜破怨敌　　最强难伏者
  降诸魔众已　　勇健不求有

尔时无愿力天子。以偈赞曰

  大力于解脱　　能断诸魔缚
  是诸佛子等　　观魔如网草

尔时观身天子。以偈赞曰

  诸有观此身　　彼能乐佛法
  无身无作者　　是等随顺法

尔时念身天子。以偈赞曰

  所有念此身　　秽恶不清净
  已知身如实　　敬礼大导师

尔时厌患身天子。以偈赞曰

  系念于内身　　观见不净相
  彼得离身苦　　调伏故敬礼

尔时舍身天子。以偈赞曰

  舍此脓血身　　如蛇脱故皮
  敬礼于非身　　是大如来身

尔时厌恶身天子。以偈赞曰

  厌恶脓血身　　不净甚臭秽
  舍此不净身　　归敬天人师

尔时患身疲劳天子。以偈赞曰

  所患烂坏身　　佛子求清净
  彼得悉礼佛　　所修正法身

尔时怖身天子。以偈赞曰

  观知此四大　　犹如恶毒蛇
  彼等超度身　　敬礼大导师

尔时见身过天子。以偈赞曰

  现前见身过　　是得智慧眼
  悉照此三有　　智者依佛慧

尔时不乐身天子。以偈赞曰

  所有不乐身　　不依法相住
  无著于诸结　　彼等礼调御

尔时于有起怨想天子。以偈赞曰

  于有如怨想　　修观坏诸有
  佛子如是学　　智生悟菩提

尔时坏有天子。以偈赞曰

  于有见过已　　能知灭无畏
  佛子勤求道　　获得父遗财

尔时弃有天子。以偈赞曰

  所修弃诸有　　乐住大涅槃
  心净离众结　　我礼大导师

尔时断有天子。以偈赞曰

  断除有根本　　照达三千界
  世尊诸子等　　所学悉通利

尔时度有天子。以偈赞曰

  已度于有海　　济拔孤独者
  于此三界中　　彼等不在数

尔时破有天子。以偈赞曰

  佛子修道者　　能破于三有
  彼是供养佛　　以化众生故

尔时于有解脱天子。以偈赞曰

  有流得解脱　　究竟住后际
  大雄出世间　　敬礼断有者

尔时灭有天子。以偈赞曰

  灭除有根本　　度有到彼岸
  已断于后际　　世间无如佛

尔时住后际天子。以偈赞曰

  如来后际住　　寂灭到彼岸
  度有一切智　　觉了未寤者

尔时于有住后际天子。以偈赞曰

  佛于后际住　　说彼三有因
  不见有诸结　　后能不生有

尔时得灭有天子。以偈赞曰

  知有空寂已　　能解三有因
  精进不怯弱　　我礼平等者

尔时度有到彼岸天子。以偈赞曰

  度有到彼岸　　拔除有根源
  救度诸群生　　导师愍一切

尔时于受无恼天子。以偈赞曰

  于受无贡高　　无思亦无虑
  禅事悉知解　　观受如水泡

尔时解受天子。以偈赞曰

  如来知诸受　　本来无自性
  凡夫所著处　　如梦受欲乐

尔时观受天子。以偈赞曰

  有智观诸受　　能取于善道
  不生未来受　　如是见导师

尔时离受天子。以偈赞曰

  受及所受者　　佛见无自性
  能即为众说　　难知甚深句

尔时决定知受天子。以偈赞曰

  诸受但世谛　　第一义中无
  如来说真实　　除断世间疑

尔时善解受天子。以偈赞曰

  世尊善知受　　犹如空中云
  谁迷无智者　　独佛能实解

尔时通达受天子。以偈赞曰

  如来达诸受　　解受到彼岸
  知受无我所　　说法最为上

尔时度受天子。以偈赞曰

  世尊已久度　　最难三受海
  舍离恶污泥　　佛智号无上

尔时断受天子。以偈赞曰

  导师于诸受　　了知出世间
  超离污染泥　　不着于诸有

尔时思受天子。以偈赞曰

  如来念诸受　　由受苦世间
  众生烦恼缚　　佛知真实性

尔时解心天子。以偈赞曰

  佛心伏烦恼　　亦降诸魔怨
  依真无所破　　故佛号牟尼

尔时识心天子。以偈赞曰

  佛久识心相　　犹如巧幻师
  幻作种种像　　故佛号应供

尔时心行天子。以偈赞曰

  大雄已修行　　能断心所缘
  亿劫阿僧祇　　心性不可得

尔时摄心天子。以偈赞曰

  躁动难调伏　　无体而住窟
  佛断速疾心　　故能受胜供

尔时拣择心天子。以偈赞曰

  佛已拣择心　　众生为心缚
  佛能真实知　　如幻师教子

尔时修心境界天子。以偈赞曰

  所行心境界　　导师决定见
  如梦受五欲　　迷彼愚痴者

尔时心自在天子。以偈赞曰

  调伏作业已　　心无分别事
  如来见心相　　世间所不知

尔时心勇天子。以偈赞曰

  所言心勇者　　能破魔军众
  以心见心者　　观心不疲倦

尔时建立天子。以偈赞曰

  如来观众生　　于法建立者
  以心能知心　　彼则真佛子

尔时定心天子。以偈赞曰

  所有伏心者　　彼能行寂灭
  是等离诸缚　　不为魔所恼

尔时柔软心天子。以偈赞曰

  勇健柔软心　　调伏众生辈
  所乐佛法者　　不着于诸欲

尔时净心天子。以偈赞曰

  善心乐清净　　审思而作业
  闻佛正法已　　无疑于深义

尔时住法天子。以偈赞曰

  所有向法心　　深乐不退没
  彼是真佛子　　已到调伏地

尔时思惟法天子。以偈赞曰

  思惟于法界　　境界无非一
  一切法界净　　诸佛所学处

尔时法界建立天子。以偈赞曰

  法界所建立　　是大慈悲心
  能住一相中　　彼是真佛子

尔时法界境界天子。以偈赞曰

  世尊说法界　　是为诸佛土
  大士所行处　　此智不思议

尔时法界生天子。以偈赞曰

  法界所出生　　是智难思议
  不疑深佛法　　亦知诸根性

尔时入法界天子。以偈赞曰

  入深法界者　　解法无与等
  是力不思议　　亦得诸妙愿

尔时法界无畏天子。以偈赞曰

  已得无畏法　　是住安隐处
  所有辩才力　　无能与等者

尔时善解法界天子。以偈赞曰

  如来解法界　　亦达一切智
  示现法界相　　如掌庵罗果

尔时住法界天子。以偈赞曰

  世尊住法界　　见法真实性
  不依亦不离　　不取复不舍

尔时法界行天子。以偈赞曰

  如来行法界　　寂静如虚空
  境界大牟尼　　敬礼慈悲父

尔时归法界天子。以偈赞曰

  随其种种门　　世尊说法界
  彼彼法门中　　无心亦无色

尔时法界精进天子。以偈赞曰

  世尊说精进　　能知于法界
  因修精进故　　觉智到彼岸

尔时法界充满天子。以偈赞曰

  大慈以正法　　充饱诸世间
  能知法界者　　彼得住菩提

尔时彻法界天子。以偈赞曰

  世尊彻深法　　故能观世间
  法界悉知已　　我礼天人师

尔时住智处天子。以偈赞曰

  是处人中上　　如来智所得
  法界及十方　　导师所行处

尔时住处天子。以偈赞曰

  法界是住处　　众智所行道
  诸有一切法　　悉作一相解

尔时知处天子。以偈赞曰

  世尊知法界　　已作一相修
  众生诸欲性　　佛亦悉了知

尔时出处天子。以偈赞曰

  能取一切智　　是谓诸佛子
  于此法界处　　惟智所能知

尔时学处天子。以偈赞曰

  所习法界者　　安住菩提中
  得达自然处　　疾成于如来

尔时非处学天子。以偈赞曰

  所见非处者　　能乐如来教
  千亿众魔军　　不能迷惑彼

尔时知非处天子。以偈赞曰

  所有知非处　　智者得欣喜
  我等修菩提　　亿魔不能动

尔时深密处天子。以偈赞曰

  善学深智处　　安住正法中
  能乘魔波旬　　如车驾调马

尔时善非处天子。以偈赞曰

  非处善法界　　习学于一相
  若魔能恼者　　佛说无是处

尔时住处天子。以偈赞曰

  是处及非处　　示现愚痴者
  如来自觉已　　复为众生说

尔时善取天子。以偈赞曰

  彼因所取事　　及昔所作业
  彼因修业处　　世尊皆悉知

尔时巧业天子。以偈赞曰

  贪欲及恚痴　　佛亦知因业
  为因为业者　　如来悉知彼

尔时知当来天子。以偈赞曰

  知彼当来世　　众生所作业
  彼因所作事　　是处佛悉知

尔时思现在天子。以偈赞曰

  普及十方界　　众生业与因
  处及因业事　　导师悉了知

尔时力境界天子。以偈赞曰

  若业若与因　　处所及出生
  如来无不知　　故称天人师

尔时乐力天子。以偈赞曰

  因业及处所　　三世果报中
  彼有所作事　　如来皆悉知

尔时力主天子。以偈赞曰

  因业所作事　　报因及因缘
  处所性自离　　是佛无有等

尔时力吉祥天子。以偈赞曰

  因业所作事　　处因缘世谛
  所受用果报　　佛知彼悉空

尔时力悦天子。以偈赞曰

  因业所作事　　俗谛因缘处
  佛自悉知已　　说彼无自性

尔时力游戏天子。以偈赞曰

  因缘所作事　　处因缘世谛
  不由自他生　　佛知从缘起

大宝积经卷第七十大宝积经卷第七十一

        北齐三藏那连提耶舍译

    菩萨见实会净居天子赞偈品第二十三之二

尔时力生天子。说偈赞曰

  若诸因缘业　　及所得果报
  此体性悉空　　佛说如师子

尔时随顺力天子。说偈赞曰

  若以业因缘　　增长于诸果
  两足尊能知　　是故佛无等

尔时顺行力天子。说偈赞曰

  修习如是界　　造作如是业
  当还获是报　　佛眼悉能知

尔时力起天子。说偈赞曰

  修习如是界　　成就如是性
  佛知诸众生　　如观手五指

尔时力行天子。说偈赞曰

  修习如是界　　还值如是友
  如是相亲近　　胜丈夫悉知

尔时力加天子。说偈赞曰

  加持于彼界　　导师能了知
  亲近于诸友　　人尊悉照见

尔时决定界天子。说偈赞曰

  彼界彼要期　　彼友彼相应
  佛悉决定知　　故能除疑惑

尔时正定界天子。说偈赞曰

  彼界彼相续　　随所住世间
  所行及诸趣　　胜人皆悉知

尔时学界天子。说偈赞曰

  于彼诸界中　　导师智能知
  彼智体性空　　胜智如是说

尔时乘界天子。说偈赞曰

  修习于彼界　　随机时住世
  佛悉如实知　　故号无比身

尔时随顺界天子。说偈赞曰

  修习于彼界　　随所得功德
  依因及果报　　佛知悉无余

尔时共界住天子。说偈赞曰

  随所修习界　　随其所向道
  佛悉知无余　　故为智所敬

尔时智行天子。说偈赞曰

  随所修习界　　随其所向道
  佛知众生行　　故号学智者

尔时行无畏天子。说偈赞曰

  正定及邪定　　及不定众生
  于此三聚中　　佛能决定知

尔时乘行天子。说偈赞曰

  若正定众生　　堪趣涅槃者
  佛为世间日　　于中智无碍

尔时解脱行天子。说偈赞曰

  若有诸众生　　住于不定聚
  堕于诸恶道　　亦为说涅槃

尔时力期会天子。说偈赞曰

  佛者但假名　　力智亦如是
  及四无畏等　　但随言说有

尔时见实天子。说偈赞曰

  无佛及佛法　　亦无余智聚
  显示第一义　　如来如实知

尔时力住天子。说偈赞曰

  住于佛法力　　因是得无畏
  自在随所欲　　悉是诸佛子

尔时法无畏天子。说偈赞曰

  世谛及真谛　　显示此二种
  彼于真谛中　　言说不可得

尔时智尊天子。说偈赞曰

  法言说各异　　法相亦复异
  是言说无相　　佛智是法相

尔时行精进天子。说偈赞曰

  非处不定众　　或向于异趣
  邪定一切处　　大牟尼悉知

尔时信力天子。说偈赞曰

  修习于彼界　　如起信乐心
  见贪以为净　　牟尼悉了知

尔时不净乘天子。说偈赞曰

  不实忘分别　　增长贪欲界
  信则行彼道　　牟尼如实知

尔时慈乘行天子。说偈赞曰

  不实妄分别　　增长嗔恚界
  信则乘彼道　　牟尼悉了知

尔时乘因缘道天子。说偈赞曰

  不实妄分别　　增长愚痴界
  信则乘彼道　　牟尼悉了知

尔时乘舍天子。说偈赞曰

  有不活畏者　　增长于嫉妒
  信彼则习行　　牟尼悉了知

尔时习近善知识天子。说偈赞曰

  近于善恶友　　还增彼恶界
  还成于彼信　　瞿昙悉了知

尔时识坚固天子。说偈赞曰

  流转于世间　　随所修习界
  随顺信于彼　　佛知悉无余

尔时行坚固天子。说偈赞曰

  流转于生死　　修习如是行
  随顺信于彼　　佛知悉无余

尔时信根天子。说偈赞曰

  若有诸众生　　随所修习界
  佛悉能了知　　故号无碍智

尔时根行天子。说偈赞曰

  佛了知诸根　　随其方便起
  攀缘及境界　　随所入如生

尔时乘根天子。说偈赞曰

  身苦所逼迫　　由贪着渴爱
  断灭诸渴爱　　唯佛智为胜

尔时根境界天子。说偈赞曰

  教下根众生　　远离于色爱
  教利者观察　　两足尊所说

尔时根胜天子。说偈赞曰

  下根住空闲　　能灭于贪欲
  正观于渴爱　　两足尊能知

尔时根决定天子。说偈赞曰

  于先起爱欲　　佛观无所得
  知无知寂灭　　故名为胜根

尔时不离根天子。说偈赞曰

  远离不忿怒　　是离嗔对治
  是下根所行　　佛知众生欲

尔时信根天子。说偈赞曰

  行慈除嗔恚　　能起众生智
  彼能灭恚界　　人尊悉能知

尔时求根天子。说偈赞曰

  不嗔无过恶　　慈行性寂灭
  净秽不可得　　故号人中尊

尔时根顺行天子。说偈赞曰

  行于邪分别　　为他说邪行
  惑重无方便　　佛见倒解脱

尔时智起天子。说偈赞曰

  贪嗔恚痴等　　取着于前事
  违彼得智明　　大名称悉知

尔时离智爱天子。说偈赞曰

  贪嗔及愚痴　　及明闇事中
  其性不可得　　两足尊悉知

尔时持威德天子。说偈赞曰

  众生所得智　　随得智多少
  随所成智器　　如来悉能知

尔时求根天子。说偈赞曰

  以智知于智　　远离诸烦恼
  天人师悉知　　故我稽首礼

尔时一向乐根天子。说偈赞曰

  国土及时节　　观察法方便
  烦恼秽及净　　如来悉知空

尔时智幢天子。说偈赞曰

  众生根欲信　　上中下差别
  缚解及智慧　　悉见无觉知

尔时根幢天子。说偈赞曰

  诸根上中下　　烦恼智及受
  调伏不调伏　　佛说悉无相

尔时修根天子。说偈赞曰

  禅解脱烦恼　　正受三摩提
  起清净众生　　如来悉能知

尔时力速疾天子。说偈赞曰

  得禅寂灭故　　于诸法自性
  悉皆能了知　　故号一切智

尔时力铠天子。说偈赞曰

  若法及自性　　能说于此法
  能如实正受　　故不着三世

尔时乐力天子。说偈赞曰

  烦恼邪分别　　起生于四种
  能知业所生　　故号无比人

尔时知力天子。说偈赞曰

  能知清净法　　对治于烦恼
  能宣说于业　　故号佛无比

尔时力士天子。说偈赞曰

  于禅解脱起　　三摩提正受
  烦恼及清净　　佛悉说虚假

尔时力生天子。说偈赞曰

  禅解脱清净　　三昧及正受
  彼从不逸生　　佛于此悉知

尔时力增长天子。说偈赞曰

  大雄于此中　　能于禅等转
  知入舍无碍　　如风行于空

尔时知前际天子。说偈赞曰

  于无数亿劫　　住于诸有中
  不为有过染　　故号胜丈夫

尔时住前际天子。说偈赞曰

  于无数亿佛　　已曾修供养
  为求无上道　　是故我归依

尔时见前际天子。说偈赞曰

  曾于过去世　　种种奉施佛
  于其种种辩　　人尊悉获得

尔时前际善巧天子。说偈赞曰

  昔流转世间　　如法学如行
  曾见无量佛　　故能深解法

尔时学前际天子。说偈赞曰

  诸佛法王所　　大雄昔修行
  于佛边学已　　故礼知众行

尔时本方便具足天子。说偈赞曰

  于无量亿劫　　无边诸佛行
  修行胜精进　　为求佛智故

尔时本方便决定天子。说偈赞曰

  一切法决定　　多亿劫观察
  一切法无入　　但说缘和合

尔时思前际天子。说偈赞曰

  于无量亿劫　　导师曾修行
  知于处非处　　故名解世间

尔时简择前际天子。说偈赞曰

  住于处非处　　观察于业因
  界根禅解脱　　佛悉能知彼

尔时观察前际天子。说偈赞曰

  过去曾观察　　增长智慧力
  十力大雄猛　　以智观世间

尔时前际境界天子。说偈赞曰

  大雄本修行　　知一切众生
  净行不净行　　故能治众生

尔时观察前际行天子。说偈赞曰

  先观于众生　　过去之所行
  信乐及与界　　然后治众生

尔时信力天子。说偈赞曰

  我今信如来　　不可思议劫
  观察本所行　　心悉无所著

尔时智信天子。说偈赞曰

  于无数亿劫　　思佛昔所行
  善男子无能　　测尽如来德

尔时观后际善巧天子。说偈赞曰

  如来以佛眼　　观十方众生
  初生及与死　　种种业相应

尔时学后际天子。说偈赞曰

  若因及以业　　随趣向佛道
  牟尼悉知彼　　故号一切智

尔时识生死天子。说偈赞曰

  若众生以界　　熏习造诸业
  众生及业习　　佛了知无觉

尔时知生死天子。说偈赞曰

  近如是朋友　　造作如是业
  趣向如是道　　牟尼悉了知

尔时所须善巧天子。说偈赞曰

  能知于所须　　随其如作业
  如是作业已　　如来悉了知

尔时事善巧天子。说偈赞曰

  依于如是事　　造作如是业
  佛悉能知彼　　皆是佛境界

尔时知事天子。说偈赞曰

  随所执着事　　能有所造作
  佛了诸根故　　悉能知彼业

尔时智善巧天子。说偈赞曰

  若智及与事　　佛知彼妄想
  随彼如执着　　佛亦知无余

尔时修作善巧天子。说偈赞曰

  随执着造业　　由于烦恼故
  佛悉能知彼　　故为世间归

尔时趣善巧天子。说偈赞曰

  随趣如造业　　随业得彼果
  随所缘作业　　佛眼悉了知

尔时攀缘善巧天子。说偈赞曰

  能知于所缘　　随缘业成熟
  于诸趣受报　　佛悉知无失

尔时习气善巧天子。说偈赞曰

  知恶业习气　　善业亦复然
  知过去所行　　众生趣趣中

尔时业善巧天子。说偈赞曰

  能知三种业　　现未及过去
  众生于趣中　　凡于中迷惑

尔时报善巧天子。说偈赞曰

  少作得多报　　多作得少报
  及知多少等　　外道于中惑

尔时学业天子。说偈赞曰

  知于现报业　　亦知生报业
  及以后报业　　佛眼悉能了

尔时知现法业天子。说偈赞曰

  若现世作业　　现在则受报
  佛悉能了知　　凡夫不能解

尔时知生报天子。说偈赞曰

  若作如是业　　于异生得报
  彼大智悉知　　众生不能了

尔时知后报天子。说偈赞曰

  若业多亿劫　　然后得受报
  或复过于彼　　如来悉了知

尔时知业不熟天子。说偈赞曰

  若所造作业　　其业缘未熟
  未得于果报　　如来悉了知

尔时观业未熟天子。说偈赞曰

  如来善观业　　若业相应时
  生于诸众生　　悉皆能善说

尔时善知业熟天子。说偈赞曰

  彼业若成熟　　能与当来报
  佛能如实知　　亦知彼智空

尔时业熟决定天子。说偈赞曰

  一切智了达　　轻业及以重
  能知众生欲　　故得为我尊

尔时知业轻重天子。说偈赞曰

  趣恶道众生　　随其业如见
  彼业若轻重　　智者悉了知

尔时知众生行天子。说偈赞曰

  见众生所行　　及轻重诸业
  雄猛随顺知　　外道不能了

尔时观众生行天子。说偈赞曰

  观于众生行　　宣说于业报
  如器恒河水　　投盐于一两

尔时学业天子。说偈赞曰

  若受于思业　　佛说业究竟
  亦学无学报　　胜仙已宣说

尔时乐佛智天子。说偈赞曰

  佛胜眼所见　　三界中愚智
  随业受于报　　见微细顶礼

尔时说业尽天子。说偈赞曰

  生死众生所　　世尊大导师
  悉了知无余　　故礼智无畏

尔时无所得天子。说偈赞曰

  若业生及死　　众生各趣趣
  彼报由如梦　　两足尊悉知

尔时求烦恼天子。说偈赞曰

  贪欲嗔恚痴　　两足尊悉尽
  犹如梦渴人　　饮于清冷水

尔时离分别天子。说偈赞曰

  从于分别生　　贪欲嗔恚痴
  犹如梦中戏　　归命胜说者

尔时灭分别天子。说偈赞曰

  若灭于分别　　则名尽烦恼
  如梦见云散　　人尊显现此

尔时观察漏尽天子。说偈赞曰

  如梦见天雨　　起漏亦如是
  大雄能显示　　起漏之因缘

尔时观察梦天子。说偈赞曰

  如梦见大雨　　起漏亦如是
  大雄能显示　　凡迷惑生漏

尔时观如梦天子。说偈赞曰

  如梦见天雨　　随顺起诸漏
  大雄能显示　　凡迷生诸漏

尔时如自性知天子。说偈赞曰

  如女梦生子　　生已还复死
  生喜亦生悲　　佛观世亦然

尔时思量梦天子。说偈赞曰

  如梦见斩首　　尽漏亦如是
  自解亦教他　　故礼悉解者

尔时修习慧天子。说偈赞曰

  见法能解了　　如梦遇爱事
  远离彼非实　　如是悦世间

尔时智心天子。说偈赞曰

  闻于如来法　　以空法自悦
  如梦中说梦　　如是晓世间

尔时欣喜意天子。说偈赞曰

  禅定者能令　　世间天人喜
  观察于诸趣　　犹如镜中像

尔时决定慧天子。说偈赞曰

  闻于如来法　　由如箜篌音
  渡人天疑海　　故礼人中王

尔时幻喜天子。说偈赞曰

  如人作幻化　　迷惑于愚人
  智者终不迷　　知幻不实故

尔时除相天子。说偈赞曰

  观于一切世　　犹如梦作幻
  我于中无疑　　以闻佛法故

尔时学幻天子。说偈赞曰

  如幻师作幻　　自于幻不迷
  以知幻虚故　　佛观世亦然

尔时观妄想天子。说偈赞曰

  妄想生世间　　大导师悉知
  如精进念佛　　梦中即见佛

尔时灭妄想天子。说偈赞曰

  非事能生欲　　皆由妄想起
  不实妄起欲　　人尊如实知

尔时识解天子。说偈赞曰

  犹如深谷声　　其响无有实
  是故不着世　　如是观世间

尔时说善巧天子。说偈赞曰

  彼声无有实　　而于中听闻
  人尊宣说此　　救拔诸凡愚

尔时如说行善巧天子。说偈赞曰

  于法别义中　　众生异妄取
  能行者知法　　于中除疑惑

尔时顺义行天子。说偈赞曰

  若义及法实　　无有能了者
  无说亦无证　　牟尼作是说

尔时法假名行天子。说偈赞曰

  烦恼垢漏习　　皆想妄分别
  秽污及清净　　但假名言说

尔时分别善巧天子。说偈赞曰

  一切但名字　　谓烦恼漏等
  秽污及清净　　大智之所说

尔时无依慧天子。说偈赞曰

  于三界不着　　其心如虚空
  离恶真福田　　顶礼心寂灭

尔时不下劣天子。说偈赞曰

  非色非非色　　非欲非涅槃
  佛心无所依　　其犹如虚空

尔时无欲天子。说偈赞曰

  离于欲界爱　　色无色亦然
  解脱于贪碍　　顶礼爱尽者

尔时远离爱天子。说偈赞曰

  于有无有中　　佛永断远离
  于三界无著　　顶礼牟尼王

尔时障爱天子。说偈赞曰

  障蔽于三界　　行于丈夫行
  能解脱众生　　归命救济者

尔时解脱渴爱天子。说偈赞曰

  远离于结使　　于后尽生灭
  身心皆清净　　顶礼无热亲

尔时知自性天子。说偈赞曰

  大雄解自在　　知法中无事
  无缚亦无解　　顶礼见实者

尔时出瘀泥天子。说偈赞曰

  远离爱欲泥　　亦离于诸有
  无取亦无舍　　顶礼尽后有

尔时吐弃资缘天子。说偈赞曰

  弃垢及资缘　　舍罪亦远爱
  亦离于诸盖　　归命大导师

尔时弃欲天子。说偈赞曰

  弃舍利不利　　无著行决定
  出离于魔网　　顶礼无著者

尔时乐利益天子。说偈赞曰

  若自及他道　　远离恼热者
  大雄见彼道　　顶礼无碍见

尔时得名称天子。说偈赞曰

  与佛智相应　　如说如观者
  彼能除烦恼　　顶礼解世间

尔时无畏天子。说偈赞曰

  于诸法决定　　无能当对者
  师子吼无畏　　智海吼亦然

尔时一切处无所畏天子。说偈赞曰

  善度一切处　　远离诸毒箭
  无畏不怯弱　　我礼最胜者

尔时无所希天子。说偈赞曰

  非天乾闼婆　　非魔及与梵
  能有难问者　　故佛如师子

尔时师子游步天子。说偈赞曰

  佛于法无畏　　晓了诸法故
  无碍故无著　　无能难问者

尔时无怖天子。说偈赞曰

  如山林师子　　无怖亦无畏
  摧伏诸禽兽　　林中而大吼
  世尊如是吼　　惊怖诸外道
  天龙乾闼婆　　不见敌对者

尔时一切处超胜天子。说偈赞曰

  一切三界中　　悉皆都无有
  力敌于佛者　　故为我归依

尔时师子慧天子。说偈赞曰

  大智见一切　　于诸法无畏
  世间无与等　　我礼无所畏

尔时称顺生天子。说偈赞曰

  自知是正觉　　如法无能难
  若有能难者　　世间悉无有

尔时持藏天子。说偈赞曰

  佛作师子吼　　开显诸法藏
  亿梵闻说已　　悉发菩提心

尔时顺威仪天子。说偈赞曰

  彼众得大利　　顺佛威仪者
  发菩提心已　　必作胜导师

尔时顺乐法天子。说偈赞曰

  彼世大众生　　得闻佛法已
  能发菩提心　　必成妙丈夫

尔时净心天子。说偈赞曰

  得闻佛说已　　世间无与比
  千亿众生等　　发胜菩提心

尔时清净流天子。说偈赞曰

  人王于长夜　　佛学善修习
  故佛身清净　　严相三十二

尔时无漏心天子。说偈赞曰

  佛得尽漏故　　而作师子吼
  得上智慧山　　无能难问者

尔时顺众生天子。说偈赞曰

  三界中悉无　　天人及修罗
  言佛漏不尽　　故佛具十力

尔时巧尽漏天子。说偈赞曰

  大胜沙门漏　　皆悉尽无余
  于是无能难　　故佛是我父

尔时常精进天子。说偈赞曰

  于人王能难　　言有余烦恼
  世间不可得　　故佛自在父

尔时寂灭行天子。说偈赞曰

  佛已断贪嗔　　愚痴及习气
  亦灭恶业行　　我礼寂灭者

尔时方便行天子。说偈赞曰

  若以方便观　　断尽诸烦恼
  彼佛满足智　　是故我顶礼

尔时方便解天子。说偈赞曰

  无量巧方便　　导师于中修
  断彼诸烦恼　　皆悉尽无余

尔时方便慧天子。说偈赞曰

  导师照世间　　巧慧无有尽
  故断诸烦恼　　及以习气等

尔时修寂灭天子。说偈赞曰

  断诸烦恼故　　习气悉无余
  于是佛大智　　不动无所畏

尔时观道理天子。说偈赞曰

  佛断烦恼尽　　及灭诸习气
  照明如佛者　　世间更无比

尔时断使天子。说偈赞曰

  佛断诸习气　　无有腥臭事
  故佛一切智　　天中最胜慧

尔时住边天子。说偈赞曰

  佛今最后身　　已断生因缘
  由尽诸漏故　　世亲得无畏

尔时无量智天子。说偈赞曰

  大雄断种子　　焚烧苦恼牙
  枯涸忧枝蔓　　我礼离恼者

尔时出坑涧天子。说偈赞曰

  世尊一切智　　已离无明坑
  佛行已得净　　故佛得无畏

尔时度有天子。说偈赞曰

  已度于有海　　导师所作办
  亦舍于彼岸　　自利得无畏

尔时入涅槃天子。说偈赞曰

  佛已得寂灭　　悉破诸烦恼
  乃至少习气　　世亲皆悉无

尔时法幢天子。说偈赞曰

  佛建正法幢　　摧折憍慢幢
  大雄已显示　　无量诸法行

尔时法性天子。说偈赞曰

  性与诸子本　　牟尼达诸法
  善友于群生　　我礼最胜海

尔时法充天子。说偈赞曰

  渴乐于佛法　　故得无所畏
  无著诸佛子　　而作师子吼

尔时求法天子。说偈赞曰

  为求诸法故　　佛子得发心
  及见佛无畏　　有知求菩提

尔时渴法天子。说偈赞曰

  渴乐佛法故　　多亿众生辈
  闻佛无畏已　　深发大精进

尔时法起天子。说偈赞曰

  见佛说法胜　　建立于正法
  无畏布施已　　佛子求菩提

尔时持法天子。说偈赞曰

  世尊所说法　　甚深难可见
  佛子得闻已　　求无上菩提

尔时无吝天子。说偈赞曰

  身命及余财　　佛子无吝惜
  闻佛师子吼　　悉求妙菩提

尔时无异慧天子。说偈赞曰

  闻佛说法已　　心思无有异
  于佛无畏所　　求法持律仪

尔时无异行天子。说偈赞曰

  闻法王吼已　　不趣于异路
  远离于二乘　　求无上菩提

尔时近住天子。说偈赞曰

  见佛师子吼　　诸子得闻已
  定得胜菩提　　当成如来身

尔时近辩天子。说偈赞曰

  于佛世尊所　　得闻辩才已
  如来妙法中　　深生喜乐心

尔时得辩才天子。说偈赞曰

  佛吼无畏时　　所说不可毁
  信乐心决定　　终无退转意

尔时常喜天子。说偈赞曰

  十力吼无畏　　所有诸佛子
  一切时欣喜　　心调求菩提

尔时无怯弱心天子。说偈赞曰

  常喜不怯弱　　世尊诸佛子
  乐求胜菩提　　以闻佛语故

尔时无碍心天子。说偈赞曰

  彼等求佛心　　终不有退转
  欣喜微妙心　　闻佛善说故

尔时巧知无边法天子。说偈赞曰

  以修正法故　　白法党不减
  导师知非处　　不生厌足心

尔时巧说法天子。说偈赞曰

  修行黑法党　　若不退减者
  世尊知非处　　故佛无所畏

尔时法性无畏天子。说偈赞曰

  黑法体性尔　　必当秽净法
  彼不污心者　　佛知彼非处

尔时巧相应天子。说偈赞曰

  黑法及白法　　二异不相合
  佛说于彼义　　故佛是我师

尔时巧知善不善天子。说偈赞曰

  大雄皆悉知　　诸法不杂聚
  妄想分别故　　于善法中退

尔时如说行满足天子。说偈赞曰

  行于烦恼者　　终不生白法
  不生白法故　　当知必退减

尔时乐解脱天子。说偈赞曰

  若乐解脱者　　修行于黑法
  佛说彼有障　　故佛一切智

尔时净心天子。说偈赞曰

  心乐解脱者　　须知烦恼事
  大雄说此法　　故佛应受供

尔时见烦恼天子。说偈赞曰

  行于烦恼中　　不识烦恼者
  彼不知正法　　善逝如是说
  若言行诸恶　　不退善法者
  于解脱非器　　两足尊所说

尔时调伏天子。说偈赞曰

  离欲及愦闹　　亦离嗔痴等
  如佛所说法　　应当如是修
  烦恼及白法　　愚痴不知者
  佛于彼非师　　大仙如是说

尔时勤修解脱天子。说偈赞曰

  佛说对治法　　为除烦恼故
  行彼不尽惑　　无能击难者

尔时向解脱天子。说偈赞曰

  佛说如是法　　为断烦恼故
  若修不灭惑　　无能击难者

尔时方便相应天子。说偈赞曰

  佛是说法者　　为诸声闻等
  若修不证者　　无能击难佛

尔时趣解脱天子。说偈赞曰

  佛说如是法　　为欲断烦恼
  若不灭惑者　　无能击难佛

尔时无畏功德天子。说偈赞曰

  为灭烦恼故　　佛说不净观
  若不尽灭者　　无能击难佛

尔时善发心必修天子。说偈赞曰

  慈能断嗔恚　　修慈若不断
  无能击难佛　　世尊得无畏

尔时净目天子。说偈赞曰

  佛说能修彼　　智慧除愚痴
  若彼不断者　　无能击难佛

尔时灭觉观天子。说偈赞曰

  为觉对治故　　说于安般念
  修彼不灭者　　无能击难佛

尔时尊重无相天子。说偈赞曰

  为断吾我故　　佛说空寂灭
  以彼不灭者　　于是无能难

尔时断我慢天子。说偈赞曰

  为断憍慢故　　佛说无相法
  若修不灭者　　不见能难佛

尔时净身天子。说偈赞曰

  深心信清净　　一切烦恼尽
  修彼不断者　　无能击难者

尔时深解想天子。说偈赞曰

  对治及朋党　　求于烦恼道
  无畏难佛者　　如来初不见

尔时解用天子。说偈赞曰

  世尊但名用　　此彼尽不尽
  无畏问难者　　彼亦但假名

尔时调伏身业天子。说偈赞曰

  以智善解已　　身业得流行
  世尊悉遍知　　故号一切智

尔时知身天子。说偈赞曰

  身业甚清净　　大雄悉无余
  怜愍群生者　　我礼世间亲

尔时身业简择天子。说偈赞曰

  善简择身业　　怜愍众生等
  照世而造作　　故号胜丈夫

尔时善见身业天子。说偈赞曰

  身业得清净　　导师悉观见
  怜愍诸群生　　故等一切智

尔时善观身天子。说偈赞曰

  善观得清净　　身业得相应
  怜愍群生故　　胜丈夫游行

尔时成就语言天子。说偈赞曰

  具甘美功德　　离于绮涩语
  智慧相围绕　　世亲而演说

尔时时语天子。说偈赞曰

  依时义相应　　远离无益事
  佛言无不忠　　众生悉受行

尔时成就智慧天子。说偈赞曰

  不恼愍众生　　成相应不浊
  不坏于因果　　佛本如是说

尔时不相违天子。说偈赞曰

  乃至为身命　　未曾有妄语
  是故佛功德　　于世无有碍

尔时实语天子。说偈赞曰

  佛行实语因　　以是世瞻仰
  至心乐听闻　　为得佛法故

尔时从实生天子。说偈赞曰

  世尊以实语　　渐备成菩提
  诸法真实性　　世尊皆悉知

尔时实精进天子。说偈赞曰

  于诸有为法　　如性真实见
  世尊皆悉知　　诸法真实相

尔时简择业天子。说偈赞曰

  于己及与他　　知身口意业
  以其智清净　　故号佛无等

尔时观察意业天子。说偈赞曰

  人王心意业　　所有思量事
  悲念于众生　　故礼愍世者

尔时巧觉观意天子。说偈赞曰

  世尊心缘处　　是心皆调柔
  悲念于众生　　故礼愍世者

尔时巧方便天子。说偈赞曰

  众生心所缘　　意业所起作
  种种智慧生　　世尊悉知彼

尔时解慧天子。说偈赞曰

  意业是佛地　　愍观众生故
  方便智清净　　佛智无体性

尔时巧知过去天子。说偈赞曰

  佛知过去世　　若人所行业
  戒忍精进智　　佛皆悉知彼

尔时观察过去天子。说偈赞曰

  观察过去行　　能知多亿佛
  过去所行处　　求胜菩提故

尔时本行具足天子。说偈赞曰

  忆念本行事　　亿劫阿僧祇
  佛心无所著　　佛本所行处

尔时观察本行天子。说偈赞曰

  阿僧祇亿佛　　导师悉曾问
  出生三昧方　　种种成佛法

尔时本行生天子。说偈赞曰

  无量阿僧祇　　导师三昧门
  过去诸佛所　　曾问亦修行

尔时观察本住天子。说偈赞曰

  生死中多过　　应供非应供
  观已化众生　　度脱于盲冥

尔时厌过去世天子。说偈赞曰

  彼此相食啖　　亦曾相戏乐
  迭互相杀害　　世尊皆悉知

尔时知未来境界天子。说偈赞曰

  导师未来时　　智慧无有碍
  众生信业报　　诸趣佛能知

尔时从本行来天子。说偈赞曰

  世尊于过去　　智慧无障碍
  善业三摩提　　离趣知诸趣

尔时巧知未来天子。说偈赞曰

  佛于未来时　　智慧无障碍
  终死及生处　　于业报亦尔

尔时离有法天子。说偈赞曰

  世尊王三界　　三世中说胜
  佛智常无碍　　善知有境界

尔时用行天子。说偈赞曰

  众生业行趣　　及受果报事
  此等但假名　　世尊如是说

尔时观察现在天子。说偈赞曰

  王尊王现在　　智慧终不碍
  于无数佛土　　牟尼皆悉知

尔时现在无畏天子。说偈赞曰

  世尊正观察　　三世悉平等
  究竟无所有　　迷惑凡夫智

尔时智无所住天子。说偈赞曰

  导师如是见　　三世无所住
  以依于法性　　诸法无事故

尔时教三世天子。说偈赞曰

  过去及未来　　阴生必败坏
  无事无自性　　导师所显说

尔时意无著天子。说偈赞曰

  世尊说三世　　皆悉无坚牢
  如幻亦如焰　　说言犹如响

尔时三世自在富天子。说偈赞曰

  世尊于三世　　常勤增智慧
  知诸行如幻　　诸根无所著

尔时欲到彼岸天子。说偈赞曰

  大雄于其夜　　得证上菩提
  世尊勤进欲　　至今不退减

尔时欲作精进天子。说偈赞曰

  世灯所有欲　　常不有退减
  世尊诸子等　　甚乐精进欲

尔时建立欲作天子。说偈赞曰

  世尊从欲起　　犹如水中莲
  不为世所染　　如莲处于水

尔时欲解脱天子。说偈赞曰

  欲及世间亲　　此二名法界
  不二无二体　　世尊皆悉见

尔时精进生天子。说偈赞曰

  以精进威德　　克证大菩提
  于其是非法　　终不舍精进

尔时念具足天子。说偈赞曰

  佛于一切处　　发心皆随顺
  于其善恶法　　佛念不损减

尔时摄心天子。说偈赞曰

  世亲常摄心　　知诸众生行
  随其所修行　　而为其说法

尔时敬重般若天子。说偈赞曰

  世尊智慧海　　边际不可得
  经亿僧祇劫　　佛说不可尽

尔时学解脱天子。说偈赞曰

  无等佛世尊　　解脱不损减
  解脱及脱者　　佛求不能得

尔时会解脱智天子。说偈赞曰

  世尊解脱者　　等解脱知见
  解真实不减　　以知无自性

尔时观察身天子。说偈赞曰

  佛于然灯始　　常修真实行
  三业无过失　　故叹号为佛

尔时深行天子。说偈赞曰

  世尊无过失　　不如余众生
  知诸法自性　　佛自性不惑

尔时大慧天子。说偈赞曰

  佛于一切种　　心念不迷惑
  其念常现前　　譬如油满钵

尔时心不散乱天子。说偈赞曰

  乃至少许时　　心念终不乱
  佛得不共法　　众生悉不知

尔时善解智慧天子。说偈赞曰

  若有思量舍　　善逝无此事
  世尊不共法　　其法不思议

尔时超一切天子。说偈赞曰

  于是三界中　　知其一切法
  一切无如佛　　故号难降伏

尔时坚持天子。说偈赞曰

  无上坚固士　　于法无所畏
  等同一切佛　　能觉未觉者

大宝积经卷第七十一大宝积经卷第七十二

        北齐三藏那连提耶舍译

    菩萨见实会遮罗迦波利婆罗阇迦外道品第二十四

尔时遮罗迦波利婆罗阇迦外道八千人。见诸阿修罗迦楼罗龙女及诸龙鸠槃茶乾闼婆夜叉紧那罗摩睺罗伽。空行诸天。四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵天。光音天。遍净天。广果天。净居天等。供养世尊。及闻赞叹生希有心。闻此法门便生疑虑。闻未曾法。彼外道等白佛言。瞿昙。我等闻此昔未闻法。闻已不乐遮罗迦波利婆罗阇迦外道。亦不乐在家。我于此法复生疑虑。不生敬信。都由昔来未闻此法。是故我于瞿昙沙门所亦有因缘。何以故。以沙门瞿昙作如是神通变化。作如是神通变化已。以其变化故。我等见此诸天等得微妙身。及见大众归伏瞿昙者至多。以知瞿昙善说法故。是故于瞿昙所复生微信。瞿昙复为广果天说如是法。言一切法是如来者。我等于此甚生疑虑。云何一切法名为如来。我等于瞿昙所如是生信。唯有瞿昙知我等意。如是如是。为我等说。令使我等解此所说义得离疑网。从坐而起。作是请已。世尊如是答于彼等。是以我今还问汝等。随汝意答。外道白佛。善哉瞿昙。瞿昙问我。我今当说。佛即问彼。汝等知不。云何胎入母腹。如是问已。外道答佛。瞿昙。我诸论中闻说三种因缘和合胎入母腹。父母相近生于贪染。思量欲事思故行欲。是故胎入。如是成胎。佛言。汝等外道于意云何。父母思时。彼贪为从母心起耶。外道言。不也瞿昙。佛言。可从于母思量起耶。外道言。不也瞿昙。佛言。彼贪可从父心起耶。外道言。不也瞿昙。佛言。为从于父思量起耶。外道言。不也瞿昙。佛言。于意云何。彼父贪欲可入母腹耶。外道言。不也瞿昙。佛言。于意云何。父心入母腹耶。外道言。不也瞿昙。佛言。于意云何。父分别入母腹耶。外道言。不也瞿昙。佛言。于意云何。彼胎从天终已来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎为从地狱终已来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎为从畜生终已来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎为从饿鬼终已来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎为从阿修罗终已来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎可非色来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。彼胎为是色来入母腹耶。外道言。不知也瞿昙。佛言。于意云何。受想行识来入母腹耶。外道言。不知也瞿昙。作是答已。佛告外道作如是言。外道。此法甚深。寂灭善说。微妙难测。非思量境界。难可显示。非汝所知。是诸外道。异见异忍异种乐欲。于非正处精进修行。于异见中决定趣向。佛言外道。若善男子善女人。遇如是善知识。于甚深法中得生眼目。外道。譬如有人患其眼根得遇良医治差眼目。以其净眼现身。能睹昔未见色。如是外道。若有善男子善女人。不具信等五根。遇善知识慧眼得净。以净慧眼得见深法。是故汝等诸外道辈。本昔长夜邪论诳惑。而作异见。于其非法取善法相。于非解脱取解脱相。于非出处生其出相。汝师自坏亦坏汝等。外道如人自盲复语余盲。我将汝去。智者当知。此等二人于其非路。必有坠落遭其辛苦。外道如是。若沙门。若婆罗门。实非导师。自称导师。实非正觉。言我正觉实不能知出世之道。言我能知。实不能见出世之道。言我能见。实不能知浅度之处。言我能知。实非教师言我是师。彼所教者是为邪教。自非正觉所教寤者亦是邪觉。实不解出言我能解。彼所教出者是为邪出。实不知道言我知道。其所示者皆是邪道。实不知浅处言我知处。其所度者反令困厄。外道。譬如牧牛人不知浅处。驱牛入水于深处而度。彼牛舍此未到彼岸。于其中流而受困厄无有救护。何以故。由牧牛人不知浅处。外道如是。汝等实非导师作导师想。其所化者反受困厄。外道。我是导师实堪化导。其所化者正化彼等。我是正觉所言不虚。我所寤者令其正寤。我是能出所言不虚。所教出者令其正出。我见出道复能示他。其所导者示其正路。我知浅处所言不虚。是以我所度者令其正度。我知教化法。是以能化他。我知佛法能觉寤他。我知出法令他得出。由我正见故。复能正示他。我知可度处故。能度于他。所将度者令得好道。汝等外道乐解脱者。我是导师今在现前。汝等应来。我能正寤具解出法。善见出道能作浅度处。汝等一心谛听善思。悉生乐愿正念现前心当流注发勤精进。为未证法令得证故。未逮得法令获得故。昔未行道令进路故。昔未到处令得到故。为未伏魔令降伏故。昔未求伴者令求伴侣故。为未得法方便令得方便故。外道。如我所说。三法和合而得受胎。我今当说。汝等外道一心谛听。当为汝等说受胎法门。外道。我言母者是其过去作业之缘我言父者。是其过去作业之因。我言乾闼婆者。谓是业招识。外道。我言迦罗罗者。谓是业安置。外道。我言母腹者。业安识依处所。识住腹已生得增长。渐渐广阔。外道。譬如药草丛林依于大地而得增长渐渐广阔。外道如是。彼识入母腹已增长广阔。亦复如是。彼母腹中婴孩成长。方得产生生已渐增。既得长大行宿时性。随终来处彼过所行。此现习起彼是智知。非愚能了共住交友。常恒观察方知其性。外道谛听。彼人若从地狱终来生人中者。当有是相。智者应知其声。嘶破骡声。匆急声。怖畏声。高声浅声。小心常怖。数数战悚。其毛数竖。梦中多见大火炽然。或见山走。或见火聚。或见釜镬沸涌。或见有人执杖而走。或见己身为鉾槊所刺。或见罗刹女。或见群狗。或见群象来逐己身。或见己身驰走四方而无归处。其心少信无有亲友。外道。有如是等无量众相。我今略说如是等相。是名从地狱终来生人间。此智所知非愚能恻。外道谛听。彼人若从畜生终来生人中者。当有是相。智者应知。闇钝少智懈怠多食。乐食泥土。其性怯弱。言语不辩。乐与痴人而为知友。喜黑闇处。爱乐浊水。喜啮草木。喜以脚指剜掘于地。喜乐动头驱遣蝇虻。常喜昂头欠呿空嚼。常喜拳脚随宜卧地不避秽污。常喜空嗅喜乐裸形。常喜虚诈异言异作。多喜绮语。梦泥涂身。或梦见己身于田野食草。或梦见己身为众蛇缠绕。或梦见己身入于山谷丛林之中。外道。有如是等无量众相。我今略说如是等相。是名从畜生终来生人间。智者能知非愚能恻。外道谛听。彼人若从饿鬼终来生人中者。当有是相。智者应知。其头发黄怒目直视。常喜饥渴悭贪嫉妒喜饶饮食。喜背说人。身体饶毛眼精光赤。多思众食贪乐积集不欲割舍。不乐见善人。所见财物其心欲盗。乃至得其少许财物即便欣喜。常求财利乐不净食。见他资产便生妒嫉。复于他财生己有想。见他受用便生吝惜。闻说好食心生不乐。乃至巷路见遗落果及以五谷。便生贪心采取收敛。外道。有如是等无量众相。我今略说如是等相。是名从饿鬼中终来生人间。智者能知非愚能测。外道谛听。若从阿修罗终生人中者。当有是相。智者应知。高心我慢常喜忿怒。好乐斗诤挟怨不忘起增上慢。其身洪壮眼白如犬。齿长多露。勇健大力常乐战阵。亦喜两舌破坏他人。疏齿高心轻蔑他人。所造书论他人虽知语巧微密。亦有智力及烦恼力乐自养身。外道。有如是等无量众相。我今略说如是等相。是名从阿修罗终来生人间。智者能知非愚所测。外道谛听。若从人终还生人中者。当有是相。智者应知。其人贤直。亲近善人。毁呰恶人。好惜门望。笃厚守信。乐好名闻及以称誉。爱乐工巧。敬重智慧。具惭羞耻。心性柔软识知恩养。于善友所心顺无违。好喜舍施。知人高下。善观前人有益无益善能答对领其言义。善能和合亦能乖离。善能作使宣传言语。于种种语能善通达忆持不忘。亦复能知是处非处外道。有如是等无量众相。我今略说如是等相。是名从人中终还生人间。智者能知非愚能测。外道谛听。若从天中终生人间者。当有是相。智者应知。为人端正乐好清净。喜着花鬘及以香熏。乐香涂身常喜洗浴。所乐五欲简择好者不喜于恶。喜乐音声及以歌舞。纯与上人而为交友。不与下人而为朋党。好喜楼阁高堂寝室。乐慈为道含笑不嗔。吐言柔美言语善巧令人喜悦。喜乐璎珞及好衣服严身之具。常乐出入行来畅步。所作精勤终不懈怠。外道。有如是等无量众相。我今略说如是等相。是名从天中终生于人间。此智能知非愚能测。外道。若善男子若善女人。欲超此相。应近善知识顺彼人意。彼所作者即随作之。彼善知识。令彼超度为其说法。外道。从地狱终生人间者。地狱已前作人身时。造诸过恶起嗔恚故便作杀害。以其彼业牵堕地狱。彼在地狱受种种苦。后生人间犹有习气。是人既知如是相已。必须自知我从地狱来生人间。是人为舍地狱因缘。应求善知识。遇知识已。彼善知识。为除嗔业故说慈悲。亦说慈悲相应助道。以此等行。能除彼人余残习气地狱因缘。彼善知识。或为是人说慈悲相应尸波罗蜜。断除彼人嗔恚过恶。是人修慈悲时。六波罗蜜。当得满足增长福德。外道。从畜生终来生人间者。畜生已前作人身时。修行积习愚痴之法。以习痴故便行恶业。由作彼业生畜生中。彼人本受畜生身时。与诸畜生久居住故。行畜生仪式。彼从畜生终已。由有习气畜生行法。是人得人身已。闻如是法。见己身行。应当自知。我本必从畜生中终来生人间。是人为舍畜生行故。应求知识。彼善知识。为除是人愚痴业故。说十二因缘。以是法故愚痴得除。彼善知识。或为彼人说般若波罗蜜。既闻般若波罗蜜故。彼人愚痴体性自离。作是观时便生智慧。外道。从饿鬼终生人间者。饿鬼已前作人身时。修行积习悭贪之法。是人修行悭贪法故。坚持不舍。彼业力故生饿鬼中。与诸饿鬼久居住故。行饿鬼业。彼从饿鬼终已。由有习气饿鬼行法。是人得人身已。闻如是法。见己身行。应当自知。我本必从饿鬼中终来生人间。是人为舍饿鬼行故。应求知识。彼善知识。为除彼人悭贪业故。为说布施。以是法故悭贪得除。彼善知识。或为彼说与施相应助菩提法。令其悭贪悉得断除。彼善知识。或为彼人说檀波罗蜜。是人修行檀波罗蜜故。六度得满。彼善知识。或为彼人说一切法皆悉平等。是人以修法平等故。般若波罗蜜得满。以修般若波罗蜜故。流注趣向一切智处。外道。于阿修罗中终生人间者。阿修罗已前作人身时。多作善根行于憍慢。彼以慢故而作诸业。修行积习憍慢业已。彼业力故生阿修罗中。与诸修罗久居住故。行阿修罗业。从修罗终已。由有习气修罗行法。是人得人身已。闻如是法。见己身行。当须自知。我本必从修罗中终来生人间。是人为舍修罗行故。应求知识。彼善知识为除彼人憍慢业故。为说圣住处。以是法故。令彼得除憍慢之业。或为彼人说空法门。以是空法。令其彼人慢业得除。亦除吾我得无我解。或为彼说因缘和合故有诸法。以和合故而有所作。若无和合亦无所作。作是观已。慢使及业悉得除断。或为彼人说诸法一相。修行彼故般若波罗蜜得满。修般若波罗蜜满已。速证一切智终不退转。外道。于人中终生人间者。彼人昔作人身之时。修行积习十善业道。作彼业已数数修行。以彼业力还生人中。昔作人时与人久居行人仪式。今归得人。由有习气。是人得闻如是法已。应当自知。我本必从人中终已还生人中。是人为超彼习气故。应求知识。彼善知识为其彼人说无常想。以无常想令除习气。彼善知识。或为是人。说生死过涅槃至乐。闻此法已。是人能得厌生死过欣涅槃乐。彼善知识。或为是人说六波罗蜜。既得闻已。能发无上菩提之心。彼善知识。或为是人说善方便。是人以此善方便故。即能坚持六波罗蜜。速证一切智终不退转。外道。从天中终生人间者。天身已前作人身时。所修梵行布施持戒。皆希来报。是人如是修行积习作业久讫。以是业力生于天上。得生天已。与天久居行天仪式。从天终已。由有习气诸天行法。是人得人身已闻如是法。见己身行。应当自知。我本必从天中终来生人间。彼人为超天中习气。应求知识。彼善知识。教其彼人修持梵行。不期来报说于求报。是其过恶但为显说。修净梵行无所依着。得福无量。教行布施。不期来报说于求报。是其过恶但为显说。行于布施无所依着。得福无量。教行持戒。不期来报说于求报。是其过恶但为显说。受持禁戒无所依着。功德无量。彼善知识。或为彼说善巧方便。是人以此善方便故。能行六波罗蜜。行六波罗蜜已。六波罗蜜渐得满足。速证一切智终不退转。外道。从地狱终得人身者。彼应依善知识。依知识已。应听三世佛平等法。闻平等法已。应发勤精进。依城邑聚落与大众共居。具四部处更互相于。论量佛法学问难答。三世法平等得现在前。解一切法无有自性。修此解故烦恼渐除。外道。从畜生中终生人间者。彼应依善知识亲近多闻。以近多闻断除愚痴。是人虽复求多闻人及诸经论。作非有想。是人观察非有想已。自然解证无自性法。是人以此三世法平等自然现前。速证一切智。终不退转。外道。从饿鬼终生人间者。彼应依善知识修行布施。除其悭贪作诸功德。以修舍故心不积聚。是人以此三世法平等自然现前。作一相解。所言一相即是无相。是人修此无相解故。速证一切智。终不退转。外道。从阿修罗终生人间者。彼应依善知识与烦恼魔战。何者是烦恼魔。所谓憍慢。是时彼人应当观察。何者是慢。是其谁慢。谁受是慢。谁以此慢起烦恼使。谁舍此慢。是人如是推求之时。无慢可得。亦不见有人摄受慢者。彼人如是观察义故。无慢可得。无起慢者。与慢相应境界。亦不可得。亦不见有人能舍慢者。如是观已无一法可得。复作是观。以恶摄受自诳己身。他亦如是。作是观时。能见诸法悉无自性。以见诸法无自性故。见法非有。以非有故知不成就。不成就故知即不生。若不生者知彼不灭。若不生不灭者。彼非可说。若解不可说者。则非过去非现在非未来。三世不可得。若法三世不可得者。当知未曾有得有失。外道当知此是一切法平等。以此一切法平等。当知一切法是真如不变不异。如来亦真如不变不异。以一切法即是真如。是故观慢得知。是人从人中终得生人间。以有憍慢习气力故。乃至从彼地狱中终得生人间。以慢习故得知此相。若无慢习。不可得说此从人来。乃至此从地狱中来。外道。此名离慢智慧。彼相要以具巧方便乃能得知。又为般若波罗蜜加持此人。方乃得知。尔时八千诸外道等。闻说此法得无生法忍。彼等得住无生忍已。从坐而起。顶礼佛足。却住一面。彼诸外道却住一面已。异口同音说偈赞曰

  导师智力所建立　　知诸道趣不由他
  知诸众生游诸趣　　如见掌中庵罗果
  由诸见趣浊世间　　譬如云雾障虚空
  以是群愚常流转　　譬如众盲失正路
  世间为常为无常　　复言有常亦无常
  又言非常非不常　　譬如盲象入城行
  言世有边复无边　　复言亦有亦无边
  又言非边非无边　　以是流转如笼鸟
  又言即身是神我　　又言离身有神我
  妄想分别所缠缚　　如鸟被网心生苦
  又言自在天所化　　有言非因之所生
  一切众生见取覆　　譬如云雾障于月
  由如笼中卵生鸟　　于诸孔中常欲出
  见取众生如是痴　　于不解脱如笼鸟
  又礼梵王及世主　　及礼童子并围纽
  又礼方海毗沙门　　如贼被捉求诸神
  犹如贫人遇债主　　求与债主立保证
  如是世间着见取　　愚痴求天希欲乐
  佛见众生依真实　　譬如见手掌五指
  于诸趣中受百苦　　譬如群贼入牢狱
  世尊于彼生慈悲　　修诸道行知诸趣
  世尊已说出狱法　　如王生子放大赦
  愍世不思僧祇劫　　修诸苦行得菩提
  见取所坏愚痴辈　　佛令彼等得解脱
  以是善逝人师子　　于诸法中得自在
  我等见取失正路　　佛于见取拔我等
  以是世尊具大力　　具足无畏无怨对
  众中大吼如师子　　我等亦愿得彼法
  以彼能动于三界　　亦以彼法普遍照
  以彼授记诸众生　　亦愿我等值遇彼

世尊知彼诸外道等得其深信。如作微笑现瑞光明。尔时慧命马胜比丘。以偈问佛

  佛愍世间现微笑　　以见此等外道众
  唯愿如来说彼因　　所现微笑有何义
  善解因者非无因　　而现微笑瑞光明
  善哉能现微笑光　　大众悉皆瞻仰佛
  世尊大众悉怀疑　　以见善逝现笑光
  悉皆犹如观满月　　瞻佛愿说微笑因
  谁于今日设胜供　　谁于今日悦慈父
  谁今得住佛功德　　善哉大智愿演说
  大众闻之必欣喜　　皆由外道得授记
  唯愿导师普为说　　于何乘中如得道
  善哉牟尼除心惑　　于其疑者断疑网
  以是大众得欣喜　　一向趣佛不退转

尔时世尊以偈答马胜曰

  善哉马胜巧知时　　能问如来降怨者
  怜愍世间作是说　　能问导师自然士
  我当说彼现笑事　　一心谛听所作因
  汝宜欣喜听我说　　今说笑义所为者
  此诸外道皆调伏　　舍诸恶见住善见
  睹是世间见取恼　　悉起悲心求菩提
  一切见取悉得舍　　以知不浊正见故
  从我得闻无碍记　　悉皆乐求一切智
  过去佛所得记已　　供养大慈两足尊
  具足二亿诸佛所　　以求无上菩提故
  佛所行檀亦不少　　亦净持戒修禅定
  净修智慧发精进　　于诸群生修忍辱
  常修习六波罗蜜　　简择智慧求菩提
  马胜请问降怨者　　发心乐求佛菩提
  彼诸苦恼由恶党　　依止有恶见取中
  彼等今见胜导师　　舍诸恶见悉无余
  以得真解如来教　　随顺佛法起深信
  彼于当来多亿佛　　皆悉供养求菩提
  于其未来星宿劫　　皆得作佛同一号
  号曰普闻高名称　　彼等大智度世间
  彼佛国土甚清净　　种种庄严无与等
  彼离恶见众生辈　　纯求菩提贤圣处
  彼国众生离恶趣　　是时亦无一切难
  彼等诸佛得寿命　　皆悉同寿八万岁
  众生闻彼佛名者　　皆悉不退上菩提
  若有众女闻佛名　　彼女皆悉得男身
  如是世尊降怨者　　与诸外道所授记
  一切天人闻记彼　　无不欣喜生敬信

大宝积经卷第七十二大宝积经卷第七十三

        北齐三藏那连提耶舍译

    菩萨见实会第十六之十三六界差别品第二十五之一

尔时净饭王及诸眷属。见阿修罗迦楼罗龙及龙女鸠槃荼乾闼婆夜叉紧那罗摩睺罗伽。呵罗竭阇天。四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵摩天。光音天。遍净天。乃至广果天。见彼供养及闻授记。又闻净居诸天说偈赞佛。复闻外道亦得授记净饭王作是思惟。是事希有不可思议。世尊如是善说。一切世间闻已咸皆欣喜。是时净饭王。以爱恋子故。情意殷勤。尔时世尊。告父王言。我所说法。初善中善后善。其义深邃其味亦善。淳净无杂。清白无染显说梵行法。何者梵行。所谓分别六界法门。王今谛听善思念之。当为王说。王言善哉。我今谛听。唯愿说之。佛言大王。何者为分别六界法门。大王。所言六界者即是丈夫。六触入亦是丈夫。十八意识境界亦是丈夫。大王。我所言六界即是丈夫者。我何故如是说。大王。何者是六界。所谓地界水界火界风界空界识界。大王。此名六界。所言六界是丈夫者。所谓此也。我言六触入名为丈夫。何故如是说。大王所言触入何者。谓眼触入见诸色故。如是耳鼻舌身亦如是。意触入为知法故。我言六触入是丈夫者谓此也。我言十八意识境界是丈夫者何故如是说。大王。此十八意识境界何者是。谓眼见可意色。以忆想分别而生思觉。见不可意色已。亦忆想分别而生思觉。见舍处色已。亦忆想分别而生思觉。耳鼻舌身亦如是。意知法可意处法知已思想分别不可意处法知已。亦思想分别。舍处法知已亦思想分别。大王。我言十八意识境界是丈夫者谓此也。大王。地界有二种。有内有外。大王。何者为内地界。谓自身内所有。彼彼身内所有。得有取坚者强者。所谓发毛爪齿尘垢。皮肉筋骨髓脾肾肝肚。大肠小肠。大便脬膜脑胲。大王。是等名为身内地界。大王。何者是身外地界。谓身外所有。不得不取坚者强者。大王。是名身外地界。大王。身内地界。生时无所从来。灭时无所去。大王。有时女人自分别我是女人。自分别我是女人已。见外丈夫复生分别。彼是丈夫是女人。分别彼是丈夫已。即生欲想。生欲想已乐欲和合。于彼男子而生染爱。彼男子亦作是分别。我是男子。自分别我是男子已。见外女人复生分别。彼是女人此男子。作是分别已。于彼女人而生染爱。是男子女人俱生染爱已。而便和合。以和合故而有歌罗罗。大王。彼丈夫分别及所分别事。二俱不可得。女人女人性亦不可得男子男子性亦不可得。以是不相续而生分别。彼分别亦自性不可得。如分别自性不可得。如是和合和合性亦不可得。如和合和合性不可得。如是歌罗罗歌罗罗性不可得。若自性不可得者。彼云何能生坚强。大王。当知因分别故而生有坚者强者。彼坚强生时。无所从来。大王。有时此身终为冢间死尸。彼死尸坚强想变坏时。不向东方。亦不向南西北方四维上下。大王。如是当知为内身地界。大王。有时世间居处悉皆空虚。复生梵天七宝宫殿。彼宫殿坚强相生时。无所从来。如是他化自在诸天。七宝宫殿坚强生时。无所从来。如是化乐天。兜率陀天。夜摩天。三十三天。四天王天。所有七宝宫殿坚相生时。无所从来。铁围山大铁围山。坚固牢实同一金刚坚强生时。无所从来。如是须弥山。尼民达山。育干达山。伊沙达山。佉提罗迦山。鞞达略山。毗那多迦山。阿叶波竭那山。铁围山大铁围山。苏达舍那山。摩诃苏达舍那山。优常伽罗山。雪山香山。诸余黑山。及三千大千世界。若成时彼一切坚强生时无所从来。此大地厚一百六十万由旬。生已而住。大王。彼坚强生时。无所从来。大王。又时此世界坏。是世界欲坏时。此大地或为火所烧。或为水所漂。或为风所吹悉皆散灭。彼地为火烧时。乃至烟灰都无所见。大王譬如苏油为火所烧无有遗余。大王如是此三千大千世界烧已灰烬不现。后为水所漂时。亦无遗余可见。大王。譬如以盐投水消灭无余。大王。如是如是。三千大千世界。为水漂已亦无遗余。大王。如是三千大千世界。风吹坏时无有遗余。大王。譬如毗岚猛风吹诸飞鸟。彼鸟散灭无有遗余。大王。如是如是。此三千大千世界。为毗岚猛风之所吹坏。一切散灭无有遗余。大王。彼地界成时。无所从来。坏时无所去。大王。如是如是。内身地界生时。亦无所从来。灭时亦无所去。大王。彼地界生时亦空。住时亦空。生住二时体性俱空。大王。彼水界亦有二种。有内有外。大王。是内身水界谓自身内所有。及余彼彼身内所得所摄。若水若水性若水体。若润若润性若润体。所谓此身中泪污洟唾脓血疮污肪膏髓乳胆小便。大王。如是等物。名身内水界。大王。何者是身外水界。身所不得不摄者。水及水性水体润及润性润体。大王。此名身外水界。大王。彼身内水界生时。无所从来。灭时无所去。大王。谓如见所爱人眼中流泪苦恼所逼亦复流泪。闻法敬信亦复流泪。若遇风寒亦复流泪。眼赤痛时亦复流泪。大王。彼泪出时。无所从来。灭时无所去。大王。又时身内水界增长。增长已益彼水界。能灭身内火界。彼火界灭时去无所至。大王。彼身内外界生时。亦无所从来。灭时亦无所去。大王。彼身内外界生时亦空。灭时亦空。其水界性自是空。大王。有时彼内火界增盛。增盛已能竭身内水界。彼水界烧竭之时。去无所至。大王。彼身内水界生时。无所从来。灭时亦无所去。大王。彼身内水界生时亦空。灭时亦空。体性自空。大王。又时此世界坏。大王。此世界欲坏时。于虚空中。兴三十二重云而住。遍兴三十二重云住已。遍覆三千大千世界。遍覆三千大千世界已。经五中劫。天降大雨流注不绝。如象王尿。其后复经五中劫。降粗大雨。当于尔时。其水积满上至梵天。大王。彼大水界初生之时。无所从来。大王。又时此世界居处坏时。此世界中第二日出。二日出时。小河泉源悉皆枯尽。大王。又时此世界第三日出。第三日出时。大池江河悉皆枯竭。大王。又时此世界第四日出。第四日出时。四大河本源亦悉枯尽。大王。世界又时第五日出。第五日出已。大海中水一由旬二由旬三由旬。四五乃至十由旬悉皆枯尽。二十三十四十五十由旬海水枯尽。一百由旬二百由旬。三百乃至千由旬亦皆枯尽二千三千四千。乃至一万由旬悉亦枯尽。二万三万。乃至四万四千由旬。大海水尽皆枯涸。大王。又时大海之中余残之水。四万由旬余残水在。三万二万一万由旬余残水在。后复渐尽。九千八千。乃至一千由旬。九百八百。乃至一百由旬。余残水在。九十由旬八十七十六十五十四十三十二十。乃至十由旬九由旬八由旬。乃至一由旬余残水在。五里下至十多罗树。九多罗乃至一多罗。十人乃至一人。余残水在于一人身齐咽。至腋至脐。至腰至跨。至[跳-兆+尃]至踝。余残水在。乃至牛迹水在。大王。当尔之时。大海之中唯有少湿相。如粗雨时乍湿乍干。大王。譬如粗雨渧渧。如有湿未周匝。大海之水亦复如是。大王。又时大海之中所有湿处。唯润一指面。大王。彼水界渐灭之时。去无所至。亦不诣于东西南北四维上下。大王。彼水界生时亦空。住时亦空。灭时亦空。如是大王。彼水界性不可得。唯有但用。然彼但用非男非女。大王。火界亦二种。一内二外。大王。何者是内火界。大王。身内所有。及他身内所有所取。火火体火相。热体热相。所谓能消饮食者。身中所有温暖蒸热。入于热数者。大王。此名身内火界。大王。何者为身外火界。身外所有不取不受者。所谓火火体火相。温暖蒸热。大王。此名身外火界。大王。又时迦罗罗胞胎中。身内火界增盛。水界渐微。是故迦罗罗渐稠渐坚。大王。譬如铁器煎煮饧餔。以火力故渐渐稠强。大王。如是如是。以火力故。迦罗罗渐稠渐坚。迦罗罗渐稠渐坚故。名遏浮陀。遏浮陀以火力成故。名为卑尸迦。卑尸迦以火力成故。名为坚固。坚固为火成故。生于五支。如是如是。大王。彼水界为火界成熟。如是如是。彼水界渐稠渐坚故。成于肉团。大王。彼火界生时。无所从来。而能烧灭于彼水界。大王。又时当有病人。身内火界悉皆灭尽。彼病人身内火界既灭尽已。所食之物不复消化。其彼病人不能消故。于后不复更能进食。不能食故。身内火界悉皆灭尽。以彼人不能进食身内火灭故。必当命终。大王。火界灭时不至东方南西北方四维上下。大王。彼火界生时亦空。灭时亦空。而彼火界从本已来。体性自空。大王。有时世界坏。世界坏时。身外火界增盛洞一。洞一已遍烧三千大千世界。大王。彼身外火界生时。无所从来。大王。又时彼大火聚。遍烧三千大千世界已。还复灭尽。大王。彼火灭时不至东方南西北方四维上下。大王彼身外火界生时亦空。灭时亦空。彼大火界体性自空。非有不可得。唯是但用。然彼但用非男非女。大王。风界亦二种。一内二外。大王。何者是身内风界。自己身内。及他身内所有风界。所受所取。风风体风名。速疾不速疾体速疾名。所谓住身四支者是风。住胃者是风。行五体者是风。行诸子支者亦皆是风。遍行大小支者亦是风。出入息者亦是风。略而言之。遍身行悉皆是风。大王。此名身内风界。大王。又时身内风界增盛集合。彼增盛集合时。能枯燥水界。亦能损减火界。于时枯燥水界。损减火界已。令人身无润泽亦无温暖。心腹鼓胀四支掘强。诸脉洪满筋节拘急。彼人尔时受大苦恼。或复命终。大王。彼身内风界生时。无所从来。大王。又时彼病人。遇值良医。医观彼病人已。应病处药。随病与药故。风病除愈。大王。彼风界灭时亦无所去。大王。彼身内风界生时亦空。灭时亦空。身内风界体性自空。大王。何者是身外风界。身外所有。身所不取不受者。风风体风名。速疾速疾体速疾名。大王。此是外风界。大王。又时彼外风界增盛。增盛故风界集合。集合时落叶折枝条。折树拔根。崩摧山峰倒坏大山。破析分段渐次散坏。乃至微尘。而此三千大千世界。为风所吹周回旋转。大王譬如陶师以杖转轮。三千大千世界为风所转。亦复如是。如少麦糗为风所吹。碎末为尘。难可得见。如是大王。此三千大千世界。为风所吹破析作末已。成于微尘。成微尘已亦不可见。大王。譬如大猛风轮起。以一把土随风散之。乃至微尘亦不可见。如是大王。此三千大千世界。为风所吹分析作末。分析作末已。乃至无一余残微尘可见。大王。彼外风界生时。无所从来。大王。又时夏初。彼外风界皆悉隐灭。隐灭故暑热无风。于草木上无露。以无露故。一切草木无有湿润。大王。彼外风界灭时亦无所去。大王。彼风界生时亦空。灭时亦空。彼风界体性自空。大王。彼内风界及外风界。二俱皆空。体性自离。相亦自离。性亦不可得。灭相亦离。何以故。彼风界非作无作者故。大王。何者是虚空界。虚空界亦二种。有内有外。大王。何者是内虚空界。若自身内。若他身内。所受所取。所谓虚空虚空体虚空名。此身内所生。入于阴数。亦入入数。亦入界数。所有空孔窍。大王。此名身内虚空界。大王。何者外虚空界。外所有非色者。乃至无有如毛等虚空处。名为虚空。大王。此名外虚空界。大王。又时由业因缘故生诸入。彼入等生已围绕空界。是时得名入内虚空界数。大王。如是一一法中推求。无一眼入可得。唯有但用。大王。何以故空。地界清净故。如地界清净空故。如是水火风界清净故空。彼无所从来。大王。又时一切诸色悉皆坏灭以为虚空。何以故。虚空界无尽故。大王。唯内虚空界安住不动。大王。譬如无为涅槃界安住不动。当知如是虚空界遍一切处。大王。譬如有人于空泽旷野掘作泉池陂井。大王。于意云何。彼诸虚空。从何而来。王言世尊。无所从来。佛言大王。若使彼人还以土填。大王。于意云何。彼虚空界去何所至。王言无所去也。何以故。世尊。彼虚空界无来无去。何以故。彼虚空界非男女故。佛言大王。外虚空界亦复不动。性无变易。虚空界空非是有法。何以故。虚空界非男非女故。大王。何者是识界。如眼为主攀缘于色。对色知故眼识生。或能知青黄赤白杂色。亦知长短粗细。如是一切所有色等物眼识所能睹者。名为眼识界。如是若知声若知香若知味若知触若知法。或知六根所缘所知。是名意识界。大王。又此识界不依诸根。亦不依界。何以故。大王。非地净色为眼入。非水火风净为眼入。何以故。非地界清净。及诸余法。以为眼入及具眼入者。如是乃至非水火风界清净色及诸余法。以为眼入具眼入者。何以故。诸法无知故。无了别故。无堪能故。非初非中非后故。非内非外亦非中间。大王。如此识界了前事已。即便谢灭不复更生。彼识生时无所从来。及其灭时亦无所至。大王。何谓为眼入。谓四大所成清净色。若使诸法体性自空。何者是清。何者是浊。于诸法中无有净秽。云何于中而见净秽。如是大王。是故当知。眼入之体性毕竟空寂。前际后际皆不可得。何以故。未来未至故不可得。过去已灭故不可得。未来未来事不可得。彼眼处亦不可得自性离故。若体性不可得者。亦无男女性可得。既无男女性。何有我我所。大王。若有我我所者。是魔境界。无我我所者。是名诸佛如来境界。何以故。一切诸法离我我所故。大王。如实了知眼入空眼入自性空。何以故。此眼入相不可得。是故此眼入体性空寂。此空离于眼入相。是名无相。于相无求故名无愿。大王是名于眼入中三空解脱门现在前

大王。何者是耳入界乃至身入。大王。此一切法对三解脱门现前决定。趣法界究竟遍虚空不可名。不可说。不可用。不可示。无有诤论。无有语言。不可测量。大王。以眼对色者名为颠倒。如是略说耳声鼻香舌味身触意法。是故诸法说名意境界。大王。眼入对色者往瞩取着。此眼三种碍。照瞩顺境生于爱想。若睹违境生于恚想。瞩中容境生于舍想。如是诸余耳鼻舌身皆亦如是。其意瞩法亦复如是。若缘顺境生于爱心。缘于违境则生嗔恚。于中容境生愚惑心。如是境界是意所行意遍行。故名意境界。大王。彼意行于顺色生于贪欲。行于违色则起恚怒。行中容色起于无明。如是声香味触意所缘法。亦行三事起贪嗔痴。谓意缘顺境意法生于贪欲。意缘违境意法生于嗔恚。意缘中容境。意法生于无明。起于愚痴。大王。应当如是知。于诸根犹如幻化。知彼境界其犹如梦。大王。如人梦中与诸婇女及众人等共相娱乐。是人觉已忆念梦中众人婇女。大王。于意云何。梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中所见众人婇女毕竟是无。亦不可得。何况共相娱乐。是人但自疲劳都无有实。佛言大王。如是愚痴无闻凡夫见可意色。眼见色已心生执着。生执着已。起于爱重。起爱重已生染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已。即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭生分识生。生分相续心种类不绝。大王。无有一法从于此世至于他世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受受体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无于相则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。犹如梦中与冤共斗。是人觉已忆念梦中而共冤斗。于意云何。梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无冤。何况斗战。是人徒自疲劳都无有实。佛言大王。如是愚痴无闻凡夫。眼见不爱之色。心不喜乐。于不喜乐而生执着。生执着已便生嗔恚。生嗔恚已其心浊乱造作嗔业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生恐怖。自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗处。或生天人中。前识既灭生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受受体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离诸相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。犹如有人于其梦中为鬼所娆心生恐怖。是人觉已。忆念梦中所梦之鬼。于意云何。梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中所见毕竟无鬼。何况怖也。是人但自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。眼睹色已。于舍处色妄生执着。生执着已作执着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至命根欲尽。临死之时最后识灭。见先所作心想中现。大王。是人见已心生怖惧。自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗处。或生天人中。前识既灭生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受受体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大宝积经卷第七十三大宝积经卷第七十四

        北齐三藏那连提耶舍译

    菩萨见实会第十六之十四六界差别品第二十五之二

大王。如人梦中见于国中。第一端正最胜女人。于彼女边。得闻微妙可爱音乐。彼人闻已。以彼乐音而自娱乐。受五欲乐。是人觉已。忆念梦中可爱音乐。于意云何。梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中所见最胜女人。可爱音乐毕竟是无。况五欲乐。是人但自疲劳都无有实。佛言大王。如是愚痴无闻凡夫。见最胜女人及以音乐。称可其意心生执着。生执着已起于爱乐。既爱乐已生染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生忙怖。自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗处。或生天人中。前识既灭生分识生。生分相续心种类不绝。大王。无有一法从于此世至于他世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受受体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。是无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。耳闻恶声生于恶心。大王。如人梦中亲爱别离。生大苦恼悲号啼哭。或离父母妻子所爱眷属。是人觉已。忆念梦中亲爱别离悲哭等事。于意云何。梦中所见是实有不。王言不也。佛言大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中所见亲爱别离毕竟是无。何况悲泣。是人徒自疲劳都无有实。佛言大王。如是愚痴无闻凡夫。见闻恶声而生执着。生执着已起不爱心。以不爱故生于嗔心。生嗔心故造作嗔业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生忧怖。自分业尽异业现前。大王如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受受体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。耳闻舍声起于舍相。大王。如人梦中闻不了句义声。是人觉已。忆念梦中所闻之声。于意云何。梦中闻声是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无有音声可得。何况当有了义及不了义句。是人空自疲劳都无有实。佛言。大王如是。愚痴无闻凡夫。闻于舍声而生执着。生执着已而生迷惑。生迷惑已造作痴业。所谓身三口四意三种业。造作业已便即谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业。乃至临死之时。最后识灭。见先所作心想中现。是人见已心生执着。自分业尽异业现前。大王。如似梦觉念彼梦中不了句义之声。大王如是。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时。名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切诸法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中以栴檀香。或多摩罗叶香。及诸种种余香用涂己身。是人觉已。忆念梦中栴檀之香。及多摩罗叶香。并余香等。于意云何。如梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无有诸香。况涂其身。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。触闻妙香便生爱着。生爱着已复更深乐。生深乐已起染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。如似梦觉忆念梦中所闻诸香。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时。名为死数。若初识生名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切诸法皆具三解脱门。与空共行涅槃先道。远离于相远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中梦见死蛇死狗死人等尸系着于颈。是人觉已。忆念梦中所见死蛇死狗死人之尸。心生怖畏。大王。于意云何。如是梦中。或以一尸系着于颈。是真实不。王言。不也世尊。佛言。是人执于梦中所见之尸。宁为智不。王言。不也世尊何以故。梦中毕竟无有死蛇死狗死人之尸。况将系颈。是人徒自疲劳都无有实。佛言。大王。如是无闻愚痴凡夫。既见臭恶而生执着。生执着已起不爱心。以不爱故生于嗔心。生嗔心故造作嗔业。所谓身三口四意三种业。造彼业已便即谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现大王。是人见已心生厌恶。自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时。名为死数。若初识生。名为生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是。作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中梦鼻根坏。是人觉已。忆念梦中所坏鼻根。于意云何。梦中所见是实有不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无有鼻根。况复坏也。是人徒自疲劳都无有实。佛言大王。如是愚痴无闻凡夫。见鼻根坏。便生执着。生执着已起于恐惧。既恐惧已生染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已。不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生忙怖。自分业尽异业现前。大王。如似梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘。生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王。当知一切诸法皆悉空寂。一切诸法空者。是空解脱门空无空相。名无相解脱门若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王。当知识根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中自身饥渴。得百味馔恣意而食。是人觉已忆念梦中百味饮食。于意云何。是人所梦是真食不。王言不也。佛言。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无有饮食。况复食也。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。见百种食已心生执着。生执着已起贪乐心。既贪乐已心生染着。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王是人见已心生贪乐。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报。皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王。当知一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王。当知诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中为饥所逼。遇得苦瓠并拘奢得子。及纴婆子等而便食之。是人觉已念于梦中所食苦瓠子等。于意云何。是人所梦是真食苦瓠以不。王言不也。大王。于意云何。是人所梦执谓为实便生嗔恚。是为智不。王言。不也世尊。何以故。梦中毕竟无有苦瓠及拘奢得子等。况复食也。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。梦为饥所逼心生执着。生执着已作执着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王是人见已心生妄想。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报。皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王。当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王。当知诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中梦舌根坏。是人觉已忆念梦中舌根毁败。于意云何。是人所梦是真坏不。王言。不也大王。于意云何是人所梦执谓实坏。是为智不。王言。不也世尊。何以故。梦中毕竟无有舌根。况复坏也。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。见舌根坏心生执着。生执着已生不爱心。生不爱已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生怖惧。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于此世至于他世而有生灭。见所作业及受异报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知大王。犹如梦中自睹国中最胜之女共相抱持。是人觉已忆念梦中所得细触。于意云何。是人所梦是真实不。王言。不也大王。于意云何。是人所梦执谓真实。是为智不。王言。不也世尊。何以故。梦中毕竟无有此女。况受细触。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫见可意色。眼见色已心生执着。生执着已起于爱欲。起爱欲已生染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生爱喜。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于此世至于他世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻境界如梦。一切譬喻当如是知

大宝积经卷第七十四大宝积经卷第七十五

        北齐三藏那连提耶舍译

    菩萨见实会第十六之十五六界差别品第二十五之三

大王。如人梦中自持热铜鍱缠被其身。是人觉已忆念梦中所被铜叶。于意云何。是人所梦是真实不。王言。不也大王。于意云何。是人所梦执谓真实。是为智不。王言。不也世尊。何以故。梦中毕竟无有铜叶。况以衣身。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。见恐惧事心生执着。生执着已起于怖畏。起怖畏已作怖畏业。谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生忙惧。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天中。或生人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中见身根坏不觉诸触。是人觉已忆念梦中败坏之相。于意云何。是人所梦是真实不。王言不也。大王。于意云何。是人所梦执谓为实。是为智不。王言。不也世尊。何以故。梦中毕竟无有身根。况败坏也。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。自见身根败坏心生执着。生执着已起恐怖心。起恐怖心已作恐怖业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生怖惧。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天中。或生人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。无有受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏无有作业者。无有受报者。但随世俗故有。非第一义也。大王。当知一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中梦见幻师幻作五欲。自见己身与彼围绕共相娱乐。是人觉已不见五欲。便忆梦中五欲之乐。于意云何。是人所梦是真实不。王言不也。大王。于意云何。是人所梦执谓真实。是为智不。王言。不也世尊。何以故。梦中毕竟无有幻师。况复幻作五欲递相娱乐。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。见是幻师幻作五欲。心生执着。生执着已起于爱重。起爱重已生染着心。生染着已作染着业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生爱着。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆悉不坏。无有作业者。无有受报者。但随世俗故有。非第一义。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中梦见大水漂荡。己身妻子眷属既见漂已。心生无量种种忧恼。是人觉已忆念梦中为水所漂忧苦之事。于意云何。是人所梦是真实不。王言不也。佛言。大王。是人所梦执谓真实。是为智不。王言。不也世尊。何以故。梦中毕竟无有大水。况复漂荡生大忧恼。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。见水漂荡心生执着。生执着已其心不喜。心不喜故作不喜业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时最后识灭见先所作心想中现。大王。是人见已心生忙怖。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天中人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏。无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。初识生时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗故有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

大王。如人梦中自见己身饮酒惛醉无所觉知。不识罪福善恶尊卑优劣。是人觉已忆念梦中饮酒迷乱。于意云何是人所梦是真实不。王言不也。大王。于意云何。是人所梦执谓真实是为智不。王言。不也世尊。何以故。梦中竟无有酒。况饮惛乱不识尊卑善恶优劣。是人徒自疲劳都无有实。佛言。大王。如是愚痴无闻凡夫。梦见饮酒惛醉心生执着。生执着已起染爱心。起染爱心已作染爱业。所谓身三口四意三种业。造彼业已即便谢灭。是业灭已不依东方而住。亦复不依南西北方四维上下而住。如是之业乃至临死之时。最后识灭。见先所作心想中现。大王。是人见已心生爱着。自分业尽异业现前。大王。如彼梦觉念梦中事。如是大王。最后识为主。彼业因缘故。以此二缘生分之中识心初起。或生地狱。或生畜生。或生阎魔罗界。或生阿修罗。或生天中人中。前识既灭受生分识生。生分相续心种类不绝。大王。无有一法从于今世至于后世而有生灭。见所作业及受果报皆不失坏无有作业者。亦无受报者。大王。彼后识灭时名入死数。若初识生名入生数。大王。彼后识起时无所从来。及其灭时亦无所至。其缘生时亦无所从来。灭时亦无所至。其业生时亦无所从来。灭时亦无所至。死时亦无所从来。灭时亦无所至。其生亦无所从来。灭时亦无所至。何以故。自性离故。彼后识后识体性空。缘缘体性空。业业体性空。死死体性空。初识初识体性空。受生受生体性空。世间世间体性空。涅槃涅槃体性空。起起体性空。坏坏体性空。大王。如是作业果报皆不失坏。无有作业者。无有受报者。但随世俗有。非第一义也。大王当知。一切诸法皆悉空寂。一切诸法空者。是空解脱门。空无空相。名无相解脱门。若无相者则无愿求。名无愿解脱门。如是大王。一切法皆具三解脱门。与空共行涅槃先道。远离于相。远离愿求。究竟涅槃界。决定如法界。周遍虚空际。大王当知。诸根如幻。境界如梦。一切譬喻当如是知

    四转轮王品第二十六之一

尔时佛告净饭王言。大王。如上所说之法。系心精勤当自观察。修行勿随于他。此法乃是过去未来现在诸佛菩提。能超一切世间自在。能除一切渴爱。降伏我慢灭除罪过。一切诸法而得平等。彼非凡夫地。一切声闻所不能到。一切辟支佛非其境界。一切菩萨之所修行。一切诸佛之所证得。大王。于此法中应当安意应作是念。我当云何于天人中得为眼目。得为灯明。得为大炬。得为船筏善知水路。得为导师。得为商主。得为导首。我当云何得自度已复能度他。自既解脱令他解脱。自得安隐令他安隐。自证涅槃令他涅槃。大王当知。不应观过去世际所经豪富自在。大王。诸根如幻无满足时。亦无能满者。境界如梦于色声香味触无有厌足。大王。过去之世有转轮王。名无边称大王。彼无边称王。具足无量众宝。辇舆军众象马。无碍轮宝七宝具足。所有军乘无能坏者。于先佛所殖诸善根。意力成就随念即办。大王。彼无量称王。有所忆念无不随意。何以故。具足成就善根力故。大王。尔时无量称王作如是念。我今自试福德之力。时无量称王即作是念。以我威力。令此四天下所有树木。常有花果用之无尽。大王。彼无量称王作是念已。于四天下所有树林。花果繁茂用无穷尽。大王。无量称王复作是念。令四天下所有人民。诸所欲愿随意无违。大王。彼无量称王作是念已。四天下中一切人民。一切所愿悉得充满。大王。无量称王复作是念。我当更试善根之力。若我有福。令四天下降注香水。作是念已。于四天下寻降香雨。大王。尔时无量称王复作是念。我今当更自试福力。大王。时无量称王即作是念。若我福力。令四天下普雨妙花。作是念时。于四天下寻雨妙花。大王。尔时无量称王复作是念。我今当更自试福力。若我有福。令四天下普雨妙衣。作是念已。于四天下。寻雨天上劫贝树衣。大王。彼无量称王复作是念。我今自试福力。若我有福。令四天下普雨银雨。作是念已。于四天下寻降银雨。大王。彼无量称王复作是念。我今当更自试福力。复作是念。若我有福。令四天下普雨金雨。作是念已。于四天下寻雨金雨。何以故。无量称王所愿从意。皆由过去于一切众生修共业善。大王。尔时此阎浮提地。纵广正等一万八千由旬。当尔之时。此阎浮提有六十千万诸大城郭。大王。尔时于此阎浮提中。置立隍城名宝庄严。其城纵广十二由旬。四面平正妙巧所成。街巷庄严界分分明。于其城外有多罗树七重行列。其多罗树四宝合成。所谓金银琉璃颇梨。庄饰端严甚可爱乐。其金树者。根茎枝条悉皆是金。其叶花果悉是白银。其银树者。根茎枝条悉皆是银。其叶花果皆是黄金。毗琉璃树。根茎枝条悉是琉璃。其叶花果皆是颇梨。其颇梨树。根茎枝条悉是颇梨。其叶花果皆毗琉璃。大王。尔时彼宝庄严城周匝七重悬宝铃网。种种庄严微妙第一。复以种种众宝罗网弥覆其上。于其城外有七重宝堑彼一一堑深半由旬广一由旬。其七重堑底岸平正。八功德水清净盈满众鸟易饮。复有诸花。所谓优钵罗花。拘物头花。波头摩花。分陀利花。弥满其中。底布金沙。其堑四边周匝阶道四宝庄严。所谓金银琉璃颇梨。种种微妙甚可爱乐。彼诸阶道四宝合成。黄金为阶白银为蹬白银为阶黄金为蹬。琉璃颇梨间错上下。交互庄饰周匝栏楯。七宝所成端严无比。一一阶道有七重宝门。种种庄严微妙最上。一一阶道于其两边金芭蕉树。其堑四边周匝阶道。于其两头一一皆有七宝妙座。彼诸所有种种庄严。皆悉是彼无量称王福德所致。其宝庄严城外周匝。而有八万园林。无量称王。作此园林不起爱着我所之心。悉施众生共同受乐。是一一园有八大池。一一大池纵广半由旬。于其池中有种种华。优钵罗花。波头摩花。拘物头花。分陀利花。如是众花弥覆其上。一一池边有八阶道。一一阶道四宝所成端严殊妙。其阶道头建七宝幢门。所谓金银琉璃及马瑙等。其阶两边阎浮檀金。为芭蕉树庄饰严丽。八功德水弥满池中众鸟堪饮。其池四边植诸妙花。所谓阿提目多伽花。薝卜花。阿输伽花。拘罗婆花。波吒梨花。迦腻迦罗花。婆拘罗花。婆利师迦花。末利迦花。苏摩那花。摩楼多花。池[少/(兔-、)]师迦花。如是等陆地生花。无量称王。为令诸人受适乐故。种植如是种种妙花。是诸人民游戏其中欢娱受乐。大王。彼宝庄严城所有宝铃罗网宝多罗树。微风吹动出和雅音。譬如有人善作五种微妙音乐。其声和雅甚可爱乐。彼无量称王。所有宫城铃网宝树园林乐具。所出妙音甚可爱乐。亦复如是。大王。尔时宝庄严王城中所有人民。以彼妙音娱乐受乐。时彼宝庄严城丰乐安隐。人民充满豪富自在。处处皆有优钵罗花。波头摩花。拘物头花。分陀利花。大王。彼无量称王。又于异时复作是念。我今当往西瞿陀尼。作是念已。王及四兵俱升虚空。往瞿陀尼。王既至彼。彼诸小王皆来奉迎。各以国土奉献。大王。时无量称王于彼止住。百千万岁于彼王领。大王。彼无量称王复作是念。我今当往东弗婆提。作是念已。即与四兵俱升虚空。往弗婆提。王既至彼。彼土小王亦皆奉迎。复以国土奉上。大王。无量称王于彼止住。百千万岁于彼王领。大王。彼无量称王。复于异时作是思惟。我当往彼北郁单越。作是念已。即与四兵上升虚空。诣郁单越。王既至彼。彼诸人民欢喜归化。王于彼住多百千岁。王领受乐教已眷属。大王。彼无量称王。于彼久时。复作是念。我曾闻有三十三天住须弥顶。我今宜往忉利天上。作是念已即乘龙象。复与四兵飞升虚空。上须弥山。大王。尔时无量称王。即问御臣。汝见须弥及以大海并四天下。其事云何。御臣答王。我见须弥及大海水四天下等。悉皆旋转。犹如陶师以杖转轮。我见须弥及四天下。悉皆旋转亦复如是。王告御臣。此龙象王大行未止。大王。尔时无量称王。复更前进问御臣言。汝见须弥大海及四天下。复更云何。御臣答言。我见须弥及大海水四天下等悉皆振动。王答臣言。今将欲到须弥山顶。此龙象王小行犹未止。大王。彼无量称王。复更前行问御臣言。汝见须弥及大海水并四天下相复云何。御臣答王。我见须弥及大海水四天下等不动不转。王告臣言。此龙象王。今已到彼须弥山顶。大王。尔时无量称王及与四兵。寻即到彼须弥山顶。大王。尔时帝释遥见无量称王。欢喜来迎而作是言。善来大王。即分半座命王令坐。王即就坐。在彼天上经无量岁。与彼天主分半而治。大王。尔时无量称王。复于久时。作如是念。我今宁可退彼天主。即住其中独为天王。作是念已。无量称王及以四兵。从彼三十三天。即便退落还阎浮提宝庄严城。堕七宝园中。尔时宝庄严城中人民。出于城外至宝箧园中。见无量称王及诸四兵。从天而堕在彼园中。众人见已速疾入城。告城中人。作如是言。今有天子并及四兵。从天而来在宝箧园中。尔时宝庄严城中。复有一王名曰作爱。秉执国事。彼作爱王。闻有天子并及四兵。从天而堕在宝箧园。闻已速疾严敕四兵驾御善乘。与诸城人从宝庄严城出诣宝箧园。王及城人见无量称王怪未曾有

尔时作爱王。寻敕速办种种香花。末香涂香。疾至无量称王所。偏袒右肩。右膝着地。合掌长跪。向无量称王而作是言。汝为是谁。王即答言。汝于昔来。颇曾闻本无量称王以不。时作爱王及诸臣民皆云。我昔曾从先旧人闻。本有大王名无量称。王四天下。与其四兵升忉利天。无量称王即答之言。如汝所闻。无量称王即我身是。尔时无量称王。初从天下。闻彼人间饮食精气。心不爱乐不能堪忍。身体沈惛。犹如醍醐投热沙中。寻即沉没不得暂停。无量称王。于阎浮提饮食诸味不生爱乐。身心沉没亦复如是。尔时作爱王见无量称王不堪人中香气饮食。身心顿弊不能止住。便作是语。无量称王有何善言。我于来世何所传说。大王。时无量称王告作爱王言。汝今当知无量称王从昔已来。王四天下威德自在。有所须念无不随意。树林花果及随意果。能除一切众生苦恼。随诸众生所须之具皆令如意。我复又能降天香。雨天衣天花。雨银雨金。王四天下豪富自在。升忉利天。帝释分坐共治天事。贪无厌故于天退没。下阎浮提遂便终没。时无量称王告作爱王言。如上众事。汝于未来当如是说。无量称王豪富自在。贪求无厌自取命终。作是语已即便命终。佛言。大王当知。勿作异观。莫生犹豫疑惑之心。尔时无量称王。岂异人乎。我身是也。大王。是故当知诸根如幻。境界如梦。大王。如是应当系心正观。勿信于他。尔时世尊。即说偈言

  常乐法自在　　数数策其心
  贪欲自在中　　智心应远离
  离欲自在已　　住法自在中
  若能降伏心　　则能伏烦恼
  若能降烦恼　　即得离业道
  若离业道已　　即为世间塔
  不为欲秽染　　显示烦恼过
  念饶益众生　　故号为支提
  闻贪欲过已　　便能离贪欲
  一切智净心　　故号为支提
  最胜大丈夫　　念灭众生恶
  解脱彼嗔恚　　故号为支提
  最胜大丈夫　　念灭众生痴
  脱彼愚痴心　　故号为支提
  调御天人师　　念灭众生慢
  净彼众生心　　故号为支提

大宝积经卷第七十五大宝积经卷第七十六

        北齐三藏那连提耶舍译

    菩萨见实会第十六之十六四转轮王品第二十六之二

大王。过去有王名曰地天。如法为王名为法王。七宝具足。所谓轮宝。象宝。马宝。明珠宝。玉女宝。长者宝。主兵宝。是名七宝。大王。彼地天王父名曰地生。彼地生王临命终时。其地天最为长子。其地生命终之后。辅相大臣。灌地天顶以为大王。即为刹利灌顶大王。时地天王。既为刹利灌顶王已。于十五日月盛圆满受斋之日。沐浴洗头。剪除须鬓。及以爪甲已。着新净衣。以诸花鬘。种种璎珞。天冠臂印。环钏耳磲。庄严其身。在高楼上婇女围绕。即于东方有金轮宝。千辐不减毂辋具足。光明照耀纵广七肘纯是真金。大王。时地天王。见是事已。即作是念。我昔曾闻先旧人说。若刹利灌顶王。于十五日月圆满时受斋之日。沐浴洗头。剪除须鬓及除爪甲。着不污衣。以诸花鬘种种璎珞。天冠臂印环钏铒磲。庄严其身。在高楼上婇女围绕。若于东方有金轮宝。毂辋具足千辐不减而来应者。当知是王定当得作转轮圣王。复作是念。我今岂可作轮王耶。我今当试。大王。尔时地天王即从坐起。偏袒右肩。整理衣服。右膝着地。对轮合掌。向彼天轮作如是言。宝轮可下在地而住。作是语已。彼天宝轮从空下地住在王前。时地天王。即以妙香用涂其手。胜妙好衣以拭轮宝。以其右手接取轮宝置左手中。复以右手摩拭其轮。作如是言。汝今应当降伏东方。作是语已。时金轮宝飞升虚空左右旋转。即往东方至彼往昔转轮王道。其道平正布散诸花甚可爱乐。轮所经处皆悉平正无有高下。以王福力。河池井泉枯竭之处。八功德水悉皆盈满。一切所有树林花果枯悴之者。悉皆敷荣。已敷荣者更增郁茂。大王。尔时地天转轮圣王。即与四兵随轮而去。轮宝若住王亦随住。王所至处所有国土。大小诸王与其臣民。各以金盘盛满银粟。或以银盘盛满金粟。奉迎大王各作是言。善哉大王善来大王。此诸国土安隐丰乐人民炽盛。唯愿大王。受此国土摄化人民。我等皆当奉给左右唯愿止住。尔时地天转轮圣王。告彼诸国王及臣民等。作如是言。我今不须国土宝物。汝自受用。汝今若欲随顺我者。应离杀生。亦莫偷盗。亦莫邪淫。亦莫妄语。亦莫两舌。亦勿恶口。亦莫绮语。亦莫贪欲。亦莫嗔恚。亦莫邪见。汝等应当自住十善。亦教他人。令住十善。我则知汝归从于我受我教敕。我观汝等犹如我子。汝等常应供养父母师长。及诸沙门婆罗门等。莫作非法不善恶行。亦劝他人令行善法。若能如是。我知汝等一切国土所有人民。悉皆归从降伏于我。又复告言。汝等常应孝养父母恭敬师长及诸沙门诸婆罗门。莫作非法不善恶行。亦劝他人令行善法。若能如是。我知汝等一切国土所有人民。悉皆归从降属于我。尔时圣王及诸四兵。如是渐渐度于大海。降弗婆提过尽人境轮宝乃住。如是乃至南西北方。及郁单越悉降伏已。度彼北海尽人境已。王及轮宝还阎浮提。本宫门上在虚空中停住不动。尔时地天转轮圣王。如是降伏四天下已。还阎浮提即便止住。地天大王及与轮宝还来至此阎浮提。时彼四天下变成七宝。端严姝特。何谓七宝所谓金银琉璃颇梨车磲赤珠马瑙。尔时轮宝于四天下。周回旋转已。一切地狱畜生饿鬼八难消灭。于四天下所有一切不善恶声悉皆除灭。况有造作诸恶业者。何以故。皆是地天圣王本愿力故。又复轮宝周旋转时。四天下中不假种植。处处皆生自然粳米。净无糠糩。又复轮宝天下中自然而生天树宝衣。又复轮宝周旋转时。四天下中一切病患。悉皆除愈。唯除三患。何等为三。一者求欲。二者段食。三者衰老。又复轮宝旋转之时。四天下中所有人民寿千万岁。又复轮宝周旋转时。四天下中一切人民。所有苦恼自然消灭。如是等无量无边。希有不可思议之事。出现于世。尔时地天大王。复于久时作如是念。我今于此受诸快乐。五欲众具颇更有处胜此以不。复自思念。我昔曾闻须弥顶上。有三十三天五欲资具。其事云何。尔时地天大王未除爱欲。厌恶人间所有五欲资财之具。欣彼天中上妙之乐。我今宁可往彼天上。尔时地天大王作是念已。王及四兵。忽然之顷至忉利天。尔时帝释。遥见地天大王。作如是言。善来大王。善哉大王。即分半座命王令坐。王即就坐。尔时地天在彼天上。经无量百千岁分位而治。尔时地天大王。复于久时生大贪心。作如是念。我今应当退彼天主独为天王。作是念已。即从帝释半座而堕。并及四兵。至阎浮提安隐城中。尔时地天大王。久在天上受胜妙乐心生耽乐。忽至人间不能堪受人中资具身心沉没犹如醍醐置热沙中。寻即消化莫知所在。地天大王。身心沉没不能堪忍。人中所有饮食精气亦复如是。尔时地天大王。身心疲顿。而说偈言

  诸王大自在　　不能除渴爱
  如干草遇火　　是故应舍欲
  常行于淫欲　　未曾满足时
  如渴饮碱水　　终不能除渴
  如众流归海　　终无有满足
  爱欲亦如是　　曾无满足时
  如火焚草木　　无有厌足时
  爱欲亦如是　　终无有满足
  犹如深谷响　　随声无休息
  闻声亦如是　　亦无休息时
  亦如盛香箧　　受香无简择
  嗅香亦如是　　亦无有厌足
  如杓挠美食　　终无知止足
  舌贪嗜美味　　亦无于止足
  如镜现面像　　亦无有厌足
  如是行欲人　　于欲无厌足
  如虚空受风　　未曾有厌足
  身常受诸触　　终无厌足时
  如梦中饮水　　终不能除渴
  意所受诸法　　亦无有厌足
  贪求爱欲人　　复增长爱欲
  观于诸境界　　爱无厌足时
  见欲增苦恼　　犹如火焚薪
  灭除诸爱欲　　亦如水灭火

佛言大王。汝知尔时地天大王。岂异人乎。大王当知。勿作异观。地天王者即我身是。大王当知。彼地天大王。往昔之时豪富自在。贪求无厌遂便命终。何以故。诸根无厌。境无能满。诸根如镜。境如光影。诸根如幻。境界如梦。大王。应当安心此法。深自观察勿随他教。大王。此法乃是过去未来现在诸佛世尊无上菩提。大王。应当远离一切豪贵。应当消竭一切渴海。倒憍慢山。远离一切衰祸。于一切法平等。非一切凡夫地。亦非声闻之所能行。又非一切缘觉境界。乃是一切菩萨所行。一切诸佛正觉所证。王当安心勿令散乱。应作是念。我当云何于未来世。一切世间天人之中。得为灯明。为炬为光。为船为导为师。得为商主为首为无上。自度度彼。自脱脱彼。自安安彼。自得涅槃。令他涅槃。大王。莫观先际所更豪富自在。大王当知。诸根如幻。无有厌足。无能满者。境界如梦。不能令满。佛言大王。过去有王名曰顶生。有大威德。有大神足。有大威势。从父乌哺沙王顶上而生。久积善根。曾见无量无数诸佛。修诸善根。于诸世尊。恭敬供养积集善本。于四天下豪贵自在。大王。时顶生王。灌顶受位七日已。得七宝具足为转轮王。何者为七。一者金轮宝。千辐不减毂辋具足。自然而有纵广七肘而来应之。二者白象宝。六牙具足七肢拄地。白如雪山自然而至。三者马宝。其色绀艳而来应之。此上象马从且至食。于四天下周遍八方。尽大海际还住本处。四者珠宝。大如人髀纯青琉璃其光照曜。周匝八方各一由旬。五者长者宝。丰饶财宝巨富无量。随王所念皆能办之自然而应。六者玉女宝。形容端正微妙第一。不长不短。不白不黑。身诸毛孔出栴檀香。口气净洁如青莲花。其舌广大出能覆面。形色细薄如赤铜鍱。身体柔软犹如无骨。冬温夏凉。其心慈悲常出软语。以手触王。即知王心所念之处。七者主兵宝。自然而出勇猛策谋武略第一。预知王心七日所念。善知四兵斗战之法。未集者令集。已集者令散。千子具足勇健端正能降怨敌。大王。尔时顶生转轮圣王。七宝具足王四天下如法化世。令四天下丰乐安隐人民炽盛。城邑聚落次第相近鸡飞相及。尔时大地一切无有沙砾荆棘。多饶众宝具足无量园林泉池。端严姝妙甚可爱乐。何以故。皆是顶生圣王安住法力。当尔之时若天若人。受欲乐中最为第一。大王。尔时顶生大王所住之城。名阿踰阇。其城东西十二由旬。南北长七由旬。其城七宝众宝罗网弥覆其上悬众宝铃。其城内外种种庄严悉皆如上。无量称王宝庄严城等无有异。亦如忉利得胜之堂。大王。顶生大王造三种殿。一名月出殿。于盛夏热时王居其中。其第二殿名毗琉璃藏。于春月时王居其中。其第三殿名日威德起。于冬寒时王居其中。尔时顶生。与玉女宝并诸婇女。前后围绕入月出殿。时身体清凉。犹如牛头栴檀涂其身体。王与眷属前后围绕。若入彼毗琉璃殿时。身心调适。犹如多摩罗叶香用涂其身。大王。其顶生大王。复与眷属婇女围绕。入彼日威德殿时。身体和暖。犹如沉水香用涂其身。入彼殿时。身体和暖亦复如是。大王。是顶生王随欲自在。令诸殿等随其时节而生乐触。随意出风。随意出雨。种种音乐随意而至。资生所须亦随意现。大王。尔时顶生。于其宫内。七日之中天雨金银。过七日已作如是念。甚奇希有不可思议。如此清净之业。所获果报随意而现充满我意。福德所致无差违也。谁有得见如是果报。于修福德而生知足。大王。顶生圣王。于阎浮提。经百千岁已。作如是念。我今于此阎浮大洲。安隐丰乐人民炽盛。悉皆归属。于我宫内七日雨宝。我今当往西瞿陀尼。作是念已。顶生大王。即与四兵上升虚空。从阎浮提渐次至彼西瞿陀尼。王既至彼。于无量百千岁。在彼王领。顶生大王。依报过人未得天报。大王。顶生圣王。于瞿陀尼。随意雨宝满其宫内。如阎浮提等无有异。大王。尔时顶生。复于后时。作如是念。我王阎浮提。丰乐安隐人民炽盛。又于宫内随意雨宝。此瞿陀尼。亦皆安隐丰乐人民炽盛。又于宫内随意雨宝。我今亦知东有大洲。名弗婆提。我今当往。作是念已。即与四兵俱升虚空。从瞿陀尼渐次而往东弗婆提。王既至彼。于弗婆提止住王领。无量千岁受五欲乐。依报过人未得天报。大王。顶生圣王。于弗婆提随意雨宝满其宫内。如阎浮提等无有异。大王。尔时顶生。复于后时作如是念。我阎浮提丰乐安隐人民炽盛。又于宫内随意雨宝。及瞿陀尼。亦皆安隐丰乐人民炽盛。亦于宫内随意雨宝。此弗婆提。皆悉安隐丰乐人民炽盛。亦于宫内随意雨宝。我今亦知北有大洲名郁单越。其中人民无我我所。虽复如此。我当往彼自试眷属。顶生大王作是念已。与其四兵俱升虚空。从弗婆提渐次而往北郁单越。王既至彼。于郁单越。无量千岁教诫眷属。复于久时作如是念。我阎浮提丰乐安隐已雨七宝。及瞿陀尼人民炽盛安隐雨宝。东弗婆提亦皆如是。随意雨宝。此郁单越悉亦安隐。我曾闻有三十三天住须弥顶。我今当往躬自观之。尔时顶生作是念已。即与四兵俱升虚空。住须弥山顶。当尔之时。释提桓因与三十三天。集善法堂论人天事。尔时帝释。遥见顶生从远而来。即出迎之。作如是言。善来大王。善来至此。即分半座命王令坐。王即就座。时顶生王坐半座时。即有十种胜事映蔽诸天何等为十。一者寿命胜天。二者容色胜天。三者名称胜天。四者受乐胜天。五者王领自在胜天。六者形貌胜天。七者音声胜天。八者香气胜天。九者食味胜天。十者细触胜天。大王。尔时顶生与彼帝释。形容相貌行动威仪等无差别。饮食衣服资生之具悉无有异。唯有视瞬为别异耳。而诸天等分别识知。天王人王二种之别。佛言大王。甚奇希有。帝释顶生人天既别。形容相貌等无有异。大王当知。福德之力其事如是。谁于福德而生足也。大王。尔时顶生在忉利天。无量千岁为增上自在。大王。尔时顶生。于四天下豪富自在。复于忉利天上豪富自在。帝释分治犹不厌足。复作是念。我今宁可独为天主。何用帝释宜应退之。大王。尔时顶生作是念已。从天退下还阎浮提。于阿踰阇城最上园中。王当下时。威光照曜遍阎浮提。一切诸方映蔽日光。亦如日出月无光明。日光在空无复光明。王光映蔽亦复如是。如日轮出映蔽月轮。顶生威光映彼日轮亦复如是。大王。尔时阿踰城人出城游观。见彼顶生并及四兵。从天而退堕其园中。彼人见已怪未曾有。即入城中遍告城人言。今有天子并及四兵。从空而下。堕彼王最上园中。大王。尔时城中王及臣民。办具种种歌舞伎乐。涂香末香。宝幢幡盖。花鬘璎珞。身体衣服悉皆清净。速疾出城诣彼园中。大王。尔时顶生从天堕时。一切大地六种震动。当尔之时。一切人中所有庄严。最胜妙香用涂其身。悉至园中顶生王所。尔时顶生。耽着天中上妙资产。不能堪忍人中资具所有香气。沈惛在地。喻如生苏醍醐投极热沙中不得停住。尔时顶生。沈惛不住亦复如是。尔时城中王及臣民内外人众。见顶生王在彼园中沈惛在地。即便问言。天为是谁。尔时顶生。即告彼王及诸人民言。汝昔曾闻有顶生大王不。尔时国王及诸人民咸皆答言。我昔曾从耆旧人所。闻有大王名曰顶生。不舍人身。将诸眷属并及四兵。而升天上。尔时顶生告诸人言。昔顶生者我身是也。我及四兵从天而堕。尔时国王。及城内外所有人众。即以偈颂。问顶生曰

  我从旧人所　　闻有威德王
  号名曰顶生　　极有大名称
  已身及四兵　　从此升天上
  并及诸眷属　　法王如法治
  人天胜王言　　无常力所害
  退天乐受苦　　顶生者我是
  诸人皆合掌　　顶礼大王足
  有何希有事　　未来当传说
  从天而退者　　受苦王说言
  汝听希有事　　欣乐莫放逸
  顶生大王者　　统领四天下
  受乐过天人　　欲无厌致死
  于其后宫内　　七日雨珍宝
  如法治天下　　欲无厌而死
  与彼天帝释　　分半座而坐
  恶觉所恼乱　　多欲故退堕
  于其生死海　　无智故沉没
  乐着五欲者　　天欲无厌死
  如渴梦饮水　　不能除其渴
  受五欲亦尔　　终无有厌足
  智慧诸众生　　断除愚痴闇
  彼智者知足　　正观诸有趣
  智观察有趣　　慧见老病死
  断除诸渴爱　　舍有趣无著
  观触如火烧　　便舍于渴爱
  观受亦如是　　知受是非善
  如击众音乐　　根境界亦然
  圣教中调伏　　能舍根自性
  一切五种入　　从于名色生
  识于中分别　　则生于思觉
  圣者作是观　　于趣有不着
  智者慧满足　　证灭如薪尽
  顶生向彼王　　臣民说是已
  示诸有无常　　即便取终没

佛告大王。汝知尔时顶生王者。岂异人乎。勿作异观。莫生疑惑。我身是也。我昔曾为顶生王时。统领人天豪贵自在。贪欲无厌而取终没。是故大王。应舍豪富憍漫自在住不放逸。若能住于不放逸行。是人即能修诸善根。大王。若不放逸者。复能入于法界平等。大王。若人能离放逸者。成就利益。大王。有为无为界。非男非女。非过去非未来非现在。大王。当于此法安住自心。勿随他教。大王。此法乃是过去未来现在诸佛世尊无上菩提。大王。应当远离一切豪贵。消竭一切渴海。倒憍慢山。远离一切衰祸。于一切平等。非一切凡夫地。亦非声闻之所能行。又非一切缘觉境界。乃是一切菩萨所行。一切诸佛正觉所证。王当安心。勿令散乱。应作是念。我当云何于未来世一切世间天人之中。得为灯明为炬为光为船为导为师。得为商主为首为无上。自度度彼。自脱脱彼。自安安彼。自得涅槃。令他涅槃。大王。观先际所经豪富自在。大王当知。诸根如幻。无有厌足。无能满者。境界如梦不能令满。大王。过去有王。名曰尼弥。了达诸法如法为王。重不放逸。若所作事离诸放逸。大王。是尼弥王。常观三世平等。又观一切诸法。犹如三世平等。观过去一切诸法。远离自性。观未来一切诸法。远离自性。观现在法亦复如是。远离自性。大王。彼尼弥王。观一切三世法平等已。于诸法不生取着。彼尼弥王。观一切世间。为四颠倒之所颠倒。于不净法中而起净想。于苦法中而生乐想。于无常法中而起常想。于无我法中而生我想。见世如是。便作是念。世间则坏甚大败坏。如此众生。一切诸法自性空寂而不觉知。大王。尔时尼弥王。复作如是念。我当以四摄法摄诸众生。若我四法摄众生者。是诸众生随顺于我受我言教。尔时尼弥大王。先作是方便已。即以四摄摄诸众生。摄诸众生已。尼弥大王。即教人民。一切诸法平等。作如是言。汝诸众生。一切诸法离于自性。若一切法离自性者。彼法亦非过去非未来非现在。何以故。彼法自性无实故。若法离自性者。彼法亦不可说是过去未来现在。大王。尔时彼尼弥王。于彼众生所。教是三世平等法已。彼诸众生。八十千万那由他无量百千众生。得无生法忍。大王。尔时三十三天在善法堂。聚集而坐作是议言。善哉善哉。鞞提呵国人大获善利是尼弥王。解了诸法如法为王。具足方便于颠倒众生所。以善方便示不颠倒法也。尔时释提桓因在于余处。去善法堂远。即以天耳闻彼天说。闻已寻来诣善法堂就座而坐。既就座已问彼天言。汝诸天等在善法堂。何所论说。作是问已。时诸天等报帝释言。唯然天主。听我所说。我等向来集善法堂所论之事。说彼鞞提呵国人善得利益。是尼弥王。解了诸法如法为王。具足方便。于颠倒众生所。以善方便示不颠倒法也。所谓显示诸法自性。彼诸天等作是语已。尔时帝释。报诸天子作如是言。是尼弥王。具足成就不可思议善巧方便。汝等在此忉利天上。欲得见彼尼弥王不。尔时诸天咸皆同声作如是言。唯然天主。我等在此欲得见彼尼弥大王。尔时帝释天主。即告御臣名摩多梨言。汝当前来。可疾严备诸天千马宝车。往阎浮提鞞提呵国尼弥王所。说如是言。此是诸天千调马车。遣来迎王唯愿大王。升此宝车勿生怖畏。三十三天悉皆愿乐欲见大王。若上车已作如是言。大王。我今将王从何道去。诣彼天上。为从住颠倒地众生道而去。为从住不颠倒地众生道而去也。尔时摩多梨答帝释言。唯然受教。闻此语已。即便严备千调马车。自升其上。从彼忉利下阎浮提。至鞞提呵国尼弥王所。语尼弥王。作如是言。忉利诸天今送千调马车。王可升车勿生怖畏。忉利诸天愿乐见王。尔时尼弥大王。以无畏心便即登之。既升车已。摩多梨作如是言。我今将王从何道去。为从住颠倒地众生道去。为从住不颠倒地众生道去。王即报言。汝可将我从彼二道中间而去。尔时摩多梨。即将尼弥王。从颠倒地众生所。不颠倒地众生所二处而去。大王。尔时尼弥王。语摩多梨言。汝可少时停车而住。我当观彼颠倒众生所住之处。时摩多梨。即受王教。暂止马车。尔时尼弥王。于少时间。令八十千万众生。安住见实三昧中。何以故。是王于少时间。令如是众住见实三昧中。此王善习不放逸行故。令此众生住三昧者。于后悉得无生法忍。是时摩多梨。都不觉知王所为作。尔时摩多梨。又复将王到须弥顶。尔时尼弥王。遥见青茂丛林。告摩多梨言。彼林定是不颠倒众生所居之处。摩多梨言。大王。此是忉利诸天善法之堂。彼忉利天众集在堂上欲得见王。惟愿大王。勿生怖畏。当升此堂。尔时尼弥王。心不恐惧便升堂上。尔时帝释。遥见尼弥王来。即作是言。善来大王。便分半座命王令座。时尼弥王。即就帝释半座而坐。尔时帝释。即以美言共相慰问言。大王。快获善利。能令佛法炽然增长。尔时帝释。向忉利天众。作如是言。此尼弥王。成就具足不可思议善巧方便。是王于少时间。能令八十千万众生住佛法中。然摩多梨都不觉知。尔时尼弥王。即为忉利诸天。广说种种胜妙之法。利益天众已白帝释言。我今欲得还阎浮提。何以故。于阎浮提为欲护持佛正法故。帝释报言。今正是时复敕御臣摩多梨言。汝可还驾千调马车送尼弥王还归阎浮。其尼弥王。到阎浮提已。成就大悲善巧方便。令无量众生安住佛法。大王。莫作异疑。勿生异观。昔尼弥王者。我身是也。大王。当观不放逸力难可思议。尼弥大王。升帝释座尚无贪着。是故大王。于佛法中。当勤精进修不放逸。大王。何谓佛法。大王。一切诸法皆是佛法。尔时净饭王。闻此语已。即白佛言。若一切法是佛法者。一切众生亦应是佛。佛言。若不颠倒见众生者。即是其佛。大王。所言佛者。如实见众生也。如实见众生者。即是见实际。实际者即是法界。大王。法界者不可显示。但名但俗。但是俗数。但有言说。但假施设应如是观。大王。一切法无生。此是陀罗尼门。何以故。此名陀罗尼门。于此一切法。无动无摇。无取无舍。是名陀罗尼门。大王。一切诸法不灭。是陀罗尼门。何以故。不灭是陀罗尼门。于中一切法无动无摇。无取无舍彼陀罗尼门。无有相貌。无有自性。无可施设。无作无造。无来无去。无众生无命。无人无养育。非对治。无形无状。无缠无离。无秽无净。无爱无憎。无缚无解。无命者。无出无退。无得无住。无定无乱。无知非无知。非见非不见。非戒非犯。非悔非不悔。非喜非不喜。非猗非不猗。非苦非乐。非定非不定。非实非倒。非涅槃非不涅槃。非爱非离爱。非见非不见。非解脱非不解脱。非智非不智。非视非不视。非业非不业。非道非不道。大王。应当以此六十七法门。入一切法。大王。是色自体。非曾有非当有非今有。如是受想行识体性。亦复如是。非曾有非当有非今有。大王。如镜中像。非有非无。是色体性。亦复如是。非曾有非当有非今有。受想行识。亦复如是。非曾有非当有非今有。大王。譬如响声。非曾有非当有非今有。大王。如是色体性。亦复如是。非曾有非当有非今有。受想行识。亦复如是。非曾有非当有非今有。大王。譬如阳焰。非曾有非当有非今有。是色体性。亦复如是。非曾有非当有非今有。大王。譬如聚沫无有坚实。非曾有非当有非今有。是色体性。亦复如是。非曾有非当有非今有。大王。如是受想行识体性。亦复如是。非曾有非当有非今有。大王。譬如梦中梦见国中最胜女人。是梦所见。亦非曾有非当有非今有。是色体性。亦复如是。非曾有非当有非今有。如是受想行识体性。亦复如是。非曾有非当有非今有。大王。譬如石女梦见生子。是梦所见。亦非曾有非当有非今有。是色体性。亦复如是。非曾有非当有非今有。如是受想行识。亦复如是。非曾有非当有非今有。大王。色无所依。乃至识亦无所依。大王。譬如虚空无所依。如是大王。色无所依。乃至识亦无所依。大王。色无有生。乃至识亦无有生。大王。色无有灭。乃至识亦无有灭。大王。如涅槃界无有生亦无有灭。大王。如是色亦无生无灭。乃至识亦无生无灭。大王。譬如法界亦无生无灭。大王。如是色亦无生无灭。乃至识亦无生无灭。如是大王。一切法是如来境界。不可思议亦是如来境界。不共法亦是如来境界。不共一切凡夫境界故。是故一切声闻缘觉。不毁不赞。不得不失。非觉非不觉。非知非不知。非识非不识。非舍非不舍。非修非不修。非说非不说。非证非不证。非显示非不显示。非可闻非不可闻。何以故。大王。彼法无有如是法。可得扶举。可得摧倒。何以故。一切诸法离自性故。大王。今可于此法中而安其心。深观此法勿信于他

尔时净饭王作是念。于诸法中无法可得。无有如是法。得证是法号为佛者。诸法实不可得。佛为众生但假言说。尔时世尊说是法时。净饭王等七万释种。得无生法忍。尔时世尊。知诸释种得深信已。而现微笑。尔时慧命马胜比丘。以偈问曰

  大雄尊导师　　为世现微笑
  惟愿世明炬　　演说微笑事
  十力一切智　　何因现微笑
  愿说彼笑因　　断世诸疑网
  佛为释众故　　而现微笑瑞
  为诸人天众　　速除诸疑网
  得闻大雄说　　世间离诸疑
  其心皆欣喜　　安住佛法中
  世尊诸子等　　得知微笑事
  坚固住誓愿　　智慧必通达
  唯愿尊导师　　断除大众疑
  众等除疑已　　必得广大乐

尔时世尊。以偈答马胜曰

  我现寂灭笑　　马胜当谛听
  我今如实说　　释种决定智
  诸法不可得　　释种皆得知
  是故于佛法　　决定心安住
  名称大释种　　依于无所得
  当得上菩提　　晓知一切法
  人中命终已　　此释种决定
  得生安乐国　　面奉无量寿
  住安乐国已　　无畏成菩提
  能趣十方界　　供养无量佛
  安住一佛土　　能供十方佛
  愍诸众生故　　而求无上道
  游历诸佛国　　供养彼佛等
  皆已神力到　　随佛所出处
  无量僧祇劫　　供养诸导师
  以种种妙供　　后当成佛道
  一一成佛已　　能度无量众
  令得成佛道　　复化诸众生
  彼国众生辈　　皆当成佛道
  彼诸世尊等　　不度声闻众
  一一诸佛等　　俱寿一劫岁
  彼佛正法住　　无量阿僧祇
  彼佛灭度后　　大智菩萨众
  持法化于世　　亿岁阿僧祇
  彼诸佛子等　　教化无量众
  置于无上道　　说法悉空寂
  令住不放逸　　修集空寂法
  能得一切智　　乐不放逸事
  闻是释种趣　　世尊所说者
  天人咸欣喜　　志求于佛道

尔时世尊。告慧命舍利弗。舍利弗。此是菩萨见真实三昧。汝当为阿毗跋智诸菩萨说之。何以故。舍利弗。此三昧不可得说。而如来于彼三昧中不得一法。若不得者。彼不可觉。若不可觉者。彼则不可说。若不可说者。彼则不可知。彼不可知者。即是过去未来现在诸佛之法。舍利弗。我今付嘱于汝。此是菩萨见实三昧。应当受持读诵广为显说。舍利弗。若有善男子善女人住大乘者。经历十劫修行五波罗蜜。离般若波罗蜜。若复有人得闻是菩萨见实三昧者。所得福德复过于彼。若复有善男子善女人。暂得闻菩萨见真实三昧。若复有人得闻是菩萨见真实三昧已。为一人说者。此人得福复胜于彼。若复善男子善女人。经历十劫闻已为他解说。若复有人。乃至一刹那间。修此菩萨见真实三昧者。所得福德复过于彼。是故舍利弗。汝应以此菩萨见真实三昧经。为诸菩萨说教示修行。舍利弗。若修此菩萨见实三昧者。当获无生法忍。舍利弗。于此会中。我所授记无上道中诸菩萨者。悉得安住此菩萨见真实三昧中。是时一切诸菩萨。声闻天人一切大众。阿修罗乾闼婆人非人等。闻佛所说。欣喜奉行

大宝积经卷第七十六大宝积经卷第七十七

        后秦三藏鸠摩罗什译

    富楼那会第十七之一

    菩萨行品第一

如是我闻。一时佛住王舍城竹园中。与大比丘众俱。及大菩萨摩诃萨。其数无量。尔时慧命富楼那弥多罗尼子。从坐而起。偏袒右肩。右膝着地。合掌向佛。白佛言世尊。我欲少有所问。唯愿如来垂愍听许。佛告富楼那。随意所问。吾当解说。令汝欢喜。富楼那言。我今为诸行上功德名闻高远。常为众生求安乐者。诸菩萨摩诃萨故。有所咨请。尔时富楼那。以偈颂曰

  行最上功德　　名称极高远
  净戒乐法者　　我问其所行
  云何修治心　　云何广行施
  云何度众生　　喜心常行道

富楼那白佛言。世尊。我今为是诸大士故。问如是事。菩萨云何修集多闻。犹如大海不可竭尽。云何能集多闻宝藏。能于诸法得决定义。于诸语言善了章句。而说偈言

  菩萨云何求　　多闻如大海
  于法得定义　　能善知佛道
  云何于一言　　而解无量义
  能以智慧力　　通达一切法
  多闻无穷尽　　问难心不动
  慈愍故说法　　以断众生疑

富楼那白佛言。世尊。我今随地智力请问如来。诸菩萨摩诃萨。云何能于阿耨多罗三藐三菩提不退转。而说偈言

  云何离众难　　得值遇诸佛
  得值诸佛已　　速得清净信
  得无上信已　　难舍而能舍
  弃舍一切已　　力行无碍道
  云何乐出家　　闲静修空智
  云何不逆法　　愿具答是事

富楼那白佛言。世尊。我等悉知佛已。具足一切智慧已。度一切神通彼岸。于三界中第一高尊。得无有比微妙大智。于诸法中行无障碍。是故我今请问是事。以偈赞曰

  佛住上功德　　已度神通岸
  得无障碍智　　我为勇猛问
  善学一切法　　功德最高胜
  破闇生慧明　　令众悉欢喜
  怨亲无憎爱　　无忧无欺诳
  大战胜死王　　摧破魔军众
  不执于刀杖　　降伏诸怨敌
  常有慈悲心　　坚住清净戒
  世尊无谄曲　　无慢无戏调
  得证明解脱　　功德中最胜
  如本所行道　　所得胜智慧
  愿今为我说　　云何行得佛

尔时。佛告富楼那言。善哉善哉。汝能咨问如来是事。谛听谛听善思念之。当为汝说诸菩萨发心所行。修集一切无量佛法。尔时世尊。以偈颂曰

  我今说菩萨　　初发菩提心
  常以勇猛力　　乐行菩萨道
  诸菩萨所行　　种种深心行
  于佛得受记　　是事当略说
  深心乐法心　　无量无有边
  种种现诸行　　不以一事成
  喜心内充满　　而行于布施
  施已心无悔　　其意益欢悦
  菩萨作是念　　众生常贫穷
  无有多闻财　　我当为求之
  众生常贫穷　　皆由于懈怠
  我当勤精进　　从是得菩提
  我当为众生　　加心行忍辱
  恶言骂捶打　　默受而不报
  当念谁骂我　　骂者不可得
  骂詈嗔恨者　　皆悉是空事
  如是思惟已　　心无有嗔恨
  常修行忍辱　　从是成佛道
  众生无善心　　当为作世灯
  令其得归趣　　无财足以财
  众生可愍伤　　皆共行邪道
  我当度脱之　　令住于涅槃
  众生皆贫穷　　无有智慧财
  我得一切智　　令其得充足
  如是诸菩萨　　为度众生故
  发心求菩提　　行如是等愿

佛告富楼那。诸菩萨摩诃萨。种种因缘示现其心。不住一法。所以者何。诸菩萨学一切法。然后得道。菩萨有四大希有事。不见余法胜此事者。何等四。菩萨能于懈怠众生勤行精进。是名希有。能于强梁嗔恚众中修行忍辱。是名希有。见诸众生行于邪道。自勤正道。是名希有。为度众生转生死故。而以深心发阿耨多罗三藐三菩提。是名希有。富楼那。此四希有。是名菩萨最大希有。尔时世尊。以偈颂曰

  见懈怠众生　　勤心发精进
  我不应效彼　　行诸非法事
  不应效嗔恚　　嗔恚非佛道
  常修慈悲心　　菩提从是生
  众生乐邪径　　依止于邪径
  菩萨求正道　　令众住正道
  见生死过患　　一心求佛智
  我得无上财　　当度诸众生
  如是希有事　　余更无胜者
  以是故当知　　得离障碍法
  设使烧身衣　　头然犹不救
  懈怠心若生　　即应速除灭

佛告富楼那。菩萨有四法能生喜心。何等四。见诸众生安处生死不能精进。自见其身在于佛道修行精进。便生喜心。见诸众生心常懈怠。自见其身在于佛法勤行精进。便生喜心。见诸众生嗔恨嫉妒。自见其身无有恚嫉常怀慈悲。便生喜心。不见余人勤行佛法与我等者。便生喜心。尔时世尊。以偈颂曰

  见众生懈怠　　已身行精进
  是故此菩萨　　自得欢喜心
  见生死过患　　而生厌离心
  怖畏三界狱　　勤心求舍离
  众生乐嗔恨　　自住慈悲心
  是故此菩萨　　生欢喜悦乐
  众生所可作　　皆所不应作
  是故我当求　　无有上佛道
  是名真实智　　诸佛所称叹
  我当学是智　　众生得归趣
  是故此菩萨　　常得欢喜心
  从有无空伪　　当生真实法

佛告富楼那。菩萨有四法得离诸难。值无难处值已不失。能修佛法何等四。一者菩萨谦逊其心柔软。凡见众生常言善来。和颜悦色先意问讯。与之共语言常含笑。二者一心求法常乐咨问。勤求善利无有厌足。三者当乐空闲远离独处。四者自身安住佛菩提道。亦化众生令住佛道。菩萨有是四法得离诸难。值无难处值已不失。能修佛法。尔时世尊以偈颂曰

  具足柔软心　　常乐行慈悲
  若与众生语　　谦下心和悦
  常求佛所叹　　甚深微妙法
  常持清净戒　　乐行头陀事
  虽行头陀法　　亦行深妙智
  是故此菩萨　　离难值无难
  常于诸佛所　　咨问诸深法
  是故智增长　　不生诸难处
  常乐在空闲　　清净行头陀
  是故此菩萨　　离难值无难
  诸有智慧者　　亲近此四法
  能离一切难　　得值遇诸佛
  得值诸佛已　　具足不坏信
  能发上精进　　以求于佛智
  是故求智者　　应当学正法
  若能学正法　　得佛道不难

    多闻品第二

佛告富楼那。菩萨有四法。则能修集多闻。犹如大海不可竭尽。常能修集多闻宝藏。能于诸法得决定义。于诸语言善了章句。何等四。菩萨求法。所谓十二部经。修多罗。祇夜。受记经。伽陀。忧陀那。尼陀那。如是诸经。本生经。方广经。未曾有经。阿波陀那。论议经。求已诵读。诵读已正忆念。正忆念已如所说行。富楼那。菩萨有此初法。则能修集多闻。犹如大海不可竭尽。常能修集多闻宝藏。能于诸法得决定义。于诸语言善了章句。复次富楼那。菩萨于一切法中无所依止。虽入禅定而无所依。无所依故。于诸法中得不住智。得不住智已。于诸法中得无碍知见。何以故。富楼那。无法可贪作障碍者。菩萨有此三法。则能修集多闻。犹如大海不可竭尽。能常修集多闻宝藏。能于诸法得决定义。于诸语言善了章句。复次富楼那。菩萨以法因缘。念佛及念佛法。是人以法因缘。念佛念佛法时。不见有法可贪受者。是人不贪受故。于一切法心无所著。是人于一切法无所著故。于诸问难。随所问答而无有碍。菩萨有此三法。则能修集多闻。犹如大海不可竭尽。能常修集多闻宝藏。能于诸法得决定义。于诸语言善了章句。复次富楼那。菩萨成就无所得慈于行无碍。无所得慈者不受诸事。何以故。富楼那。住此相者。或生贪欲。或生嗔恚。或生愚痴。住彼相者。亦或生贪欲。或生嗔恚。或生愚痴。住事相物相。阴相入相界相。法相非法相者。亦或生贪欲。或生嗔恚。或生愚痴。是故富楼那。所有受相皆名邪见。菩萨悉灭一切诸相。修集慈心。众生败坏故相亦败坏。相败坏故事亦败坏。事败坏故见亦败坏。菩萨尔时坏一切法修集于慈。如是慈者名为无所得慈。如是无所得慈名为法慈。如是法慈名为佛慈。富楼那。何名佛慈。无作无坏。是名佛慈。复次富楼那。如实通达一切诸法。是名佛慈。世尊。云何名为如实通达一切诸法。佛告富楼那。所通达者。不言是法不言非法。何以故。富楼那。若言有法即是非法。若有无法无有非法。则于其中无有戏论。若无戏论是名涅槃。汝具观之极远极近。富楼那言。不远不近。何以故。世尊。如是义者。无方无处无内无外。佛言。如是富楼那。于法作数。世尊。于何等法为之作数。富楼那。如诸凡夫所著之法。如来不得不修不证不通达。如是法者。为之作数。富楼那。是诸法数。不为分别法故。富楼那。今为汝说。如是第一寂灭法者。能摄佛道。富楼那。当来有人欣赴世利。若闻此经不乐听受。富楼那。我此菩提。汝等但以音声章句。少知之耳。其中义趣汝所不知。此义玄远不可言宣。唯有智者可以内知。尔时世尊。而说偈言

  不能知义者　　闻佛法忧苦
  若能知义者　　如来为作师
  若人佛为师　　是则求涅槃
  无有诤讼心　　能正思量法
  此中无法生　　亦无有法灭
  无生无有灭　　是诸法实相
  若法无有生　　即无有作起
  是非与一异　　此法中皆无
  是名为涅槃　　中无有灭者
  若言极远近　　是二俱为空
  若能知空者　　即名知涅槃
  若知涅槃者　　是名我弟子

富楼那。菩萨有此四法。则能修集多闻。犹如大海而不竭尽。能常修集多闻宝藏。能于诸法得决定义。于诸语言善了章句。尔时世尊以偈颂曰

  常欲求多闻　　诸佛所称叹
  能得定实义　　是故如大海
  能于一字中　　及与一句义
  于千万亿劫　　说之而不尽
  故当求正法　　求已正思量
  勿贪取法相　　不贪佛所赞
  忆念诸如来　　及念于正法
  不以贪竞心　　而求于导师
  常于诸众生　　修行慈愍心
  而不着众生　　散灭一切法
  大名称菩萨　　修习如是法
  疾得陀罗尼　　多闻从是生
  犹如虚空性　　无增无有减
  法性亦如是　　无增无有减
  我以智慧力　　无量劫说法
  所说无央数　　犹亦不名说
  尽诸众生性　　皆使得人身
  普共行出家　　多闻如阿难
  陀罗尼菩萨　　为是一切人
  千亿劫说法　　智慧犹不尽
  佛智慧无等　　同虚空无量
  虚空无生起　　智慧亦如是
  如龙不取水　　而能雨大水
  是水无住处　　所雨无穷尽
  菩萨亦如是　　得此陀罗尼
  诸法无住处　　是缘说不尽
  故应求多闻　　求已正思惟
  以法缘念佛　　多闻从是生
  慈普覆众生　　散灭众生相
  亦灭诸法相　　多闻从是生

    不退品第三

佛告富楼那。菩萨成就四法。能于阿耨多罗三藐三菩提不退转。何等四。菩萨闻未闻法思量义理不即言非。菩萨成就此初法者。则于阿耨多罗三藐三菩提不退转。尔时世尊以偈颂曰

  闻所未闻法　　其心逮不逆
  思量其义理　　不即言非法
  若闻于空法　　常求其义理
  是故智增长　　佛道从是生
  闻所未闻法　　应求其义理
  不退于菩提　　智慧得增长
  闻所未闻法　　不随恶慢心
  不生于谄曲　　生则非菩提
  闻所未闻法　　应求解其义
  先虽未曾闻　　一心应思念
  是人求法时　　能得闻正法
  常值遇诸佛　　不退失菩提
  得见诸佛已　　则能正问难
  声闻人得闻　　咸以为欢喜
  是人甚希有　　能作如是问
  我等尚无心　　况能闻是事
  声闻称希有　　天神皆欢喜
  诸佛称其名　　此是多闻果
  若有所问时　　佛答其所问
  无量诸大众　　皆得大饶益
  得闻是多闻　　菩萨所问答
  无量众皆得　　无上之法眼

佛告富楼那。以是因缘。当知菩萨闻未闻法。信受不逆。正心思量不即言非。则能饶益无量众生。富楼那。乃往过去无量无边不可思议阿僧祇劫。尔时有佛号一切功德光明王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。富楼那。是一切功德光明王佛。寿八十亿岁。其佛一会声闻弟子。不受诸法漏尽解脱。恒河沙数此不可计。是诸阿罗汉皆得共解脱。菩萨众数亦复如是。富楼那。其佛灭后法住六万岁欲涅槃时。百亿菩萨皆与神力。为护法故。悉遍百亿阎浮提内。一一阎浮提。各有一菩萨。富楼那。一切功德光明王佛灭度之后。诸弟子众渐皆懈怠。不复诵持如是深经。诸法空经。净戒头陀经。渐皆灭尽。以其不能读诵说故。其法广大有八百四万法藏。一一法藏。有六十八百万亿那由他修多罗。一一修多罗中。有三万六千忧陀那。一一忧陀那中。有七百六万亿偈。富楼那。最后末世法欲灭时。于此尔所佛法藏中。余但有一修多罗忧陀那。时有比丘法师名那罗延。于此阎浮提中。佛与神力。为护法故。是那罗延法师。多闻广博善能说法。严饰文辞义理明了。每常乐说所未闻法。当说法时。多有人众违逆毁破。那罗延法师。便作此念。是诸人众。所未闻法闻不能信不乐听受。若听不解心不随顺。闻已违逆破坏出过。而作是言。此非佛语非大师教。所以者何。我等未曾从师和上闻如是经。又诸长老比丘。亦复不言从师和上展转所闻。今诸比丘。唯有一余修多罗忧陀那。我今何不独处闲静。富楼那。那罗延法师。作是念已独入深山。尔时阎浮提中从劫初来。有六万八千大城。城长十二由旬。广七由旬。庄挍严饰街巷相当。人民充满丰乐安隐。其后续造八十四亿小城。有广七由旬或六五四三二由旬。其最小者。广一由旬。富楼那。尔时阎浮提中有一大城名为安乐。中有长者名为阇匿。有一子名摩诃耐摩陀。是长者子在空闲处。有一天来。为说偈言

  汝当勤求法　　求已正思惟
  功德王如来　　已记汝作佛

富楼那。天说偈已忽然不现。时长者子。即诣父所头面礼足。作如是言。我欲出家。于一切功德光明王佛法中。修习梵行。尔时阇匿长者。以偈答曰

  我家多财宝　　金银无有量
  阎浮提所无　　我家悉具有
  我所求财宝　　为子受欲乐
  云何行出家　　为世所轻贱

尔时长者子。偈答父言

  我乐常求法　　求已正思惟
  不乐受富乐　　当为世作佛
  不须家业宝　　我欲求少欲
  所出之法财　　今当行出家
  诸佛出世难　　佛说法亦难
  我今值佛法　　云何当舍离

富楼那。时长者子。头面礼父足。绕已而出。说此偈言

  设有一亿父　　及有百亿母
  犹尚不能遮　　今我出家心
  我舍身寿命　　父母亲族财
  唯不舍佛法　　当行出家求

富楼那。时长者子说此偈已。出家为道。即诣那罗延法师。求欲听法。时那罗延法师。即为演说所未闻经。时摩诃耐摩陀比丘。闻所未闻经已。问那罗延法师言。我于此经先所未闻。如是诸经。谁读谁诵谁受持者。从何处闻。那罗延言。我以宿命善根因缘故。亦以一切功德光明王佛威神力故。如是深经自然在心。富楼那。是摩陀比丘闻说此已。加心思念智力即生。以大智慧方便力故。难问那罗延法师。那罗延随义答已。而作是言。一切功德光明王佛时。有一比丘问佛是事。如汝今问佛如是答。时是比丘闻已欢喜。富楼那。是摩阿耐摩陀比丘。复问那罗延法师。那罗延言。一切功德光明王佛时。有一比丘问如是事。如汝今问佛如是答。时是比丘闻已欢喜。富楼那

时摩陀比丘。语那罗延法师言。正士。昔日从佛。闻如是几问答事。那罗延言。置此勿问。是事难信。余人身未证增上法。亦复难信。第二第三亦如是问。摩诃耐摩陀问言正士。昔日从佛闻是几问答事。那罗延言。置此勿问。不得已者。今当为汝譬喻解说。诸有智者譬喻得解。比丘。我于一切功德光明王佛所。得闻众生之性多于地种。比丘。假使一切三千大千世界众生。若有色若无色。若有想若无想。若非有想非无想皆尽其数。令得人身有智慧力。一一众生于弹指顷。能起恒河沙等问。然其所问各各不同。比丘。如是展转。乃至十方无余世界一切众生。若一劫若过一劫。起此诸问。复有一人。能弹指顷。起尔所人一切诸问。差别各异。如是一人。复尽一切无余众生。若一劫若减一劫。起种种问。于汝意云何。是所起问宁为多不。答言甚多。非是譬喻所能得及。那罗延语摩陀比丘言。我今明了告汝勿生疑悔。如彼一切无余众生。若于一劫若减一劫。所起疑问我从佛闻。一法门中所答多彼。如是二门三四五门十二十三四五十。乃至百千万亿门。比丘。我当略说一切所有算数名字。无量无尽不可思议。过是诸数我尽诵持。比丘。此诸答者。悉皆总在一法门中。我悉知之。所谓一切功德光明王如来。说是道句门句印句本事句金刚句重句不可动句难得底句。比丘。于一门中摄一切法。谓无作门。一切诸法一切诸句。是门为本皆入是门。一切修多罗忧陀那皆入门句。分别一字能入多字。比丘。如是能入七万八千诸陀罗尼。是中有九万二千诸根差别。是众生行门中。有八万亿形色。于诸道差别。是诸形色我知其名。一一色中我知百名。如是二百名字三百名字。乃至知千名字。皆在阎浮提中。又复过是十方佛国。其中所有各各缘各各名字我皆得知。举要言之。佛所有力。于诸法中各各差别。问答差别。我皆知之。皆是一切功德光明王如来威神之力。富楼那。时摩陀比丘。语那罗延法师言。唯愿正士。还诣聚落城邑。随转一切功德光明王如来法轮。愿受我请。我当卫护为受法者。那罗延言。且置勿说。今世比丘悉皆懈怠。集善法中无有深欲。摩陀复言。我从今日。当于善法深生欲心。为求是法不敢懈怠。富楼那。摩陀比丘即请那罗延。还入聚落令说正法。当随卫护咨听未闻。富楼那。尔时摩陀比丘。多为人众供养恭敬。时人皆谓持戒智慧多闻最上功德无量。时摩陀比丘。入城邑聚落。称赞那罗延法师。为令众生入于正法。又使佛法普得流布。富楼那。时摩陀比丘。多导人众。使供养法恭敬守护那罗延法师。为听法故。富楼那。其后那罗延法师。为摩陀比丘。所守护已。后入城邑聚落。种种广说一切功德光明王如来阿僧祇劫所修菩提。令普流布。如是富楼那。摩陀比丘于百岁中。常随那罗延法师。所问诸法。常是新异未曾重说。富楼那。那罗延法师。得是摩陀比丘所护助故。使无量众生住圣法中。无量众生住佛菩提。富楼那。汝谓尔时那罗延法师。守护法者善说法者。岂异人乎。即弥勒菩萨是。富楼那。摩陀比丘。守护法师佐助劝请。以是福德力。命终之后。即生下方第十世界上众佛所。于彼佛前问断一切众生疑经。佛时称赞百千善哉。即为演说断一切众生疑经。说是经时。无量众生。初发阿耨多罗三藐三菩提心。即入必定。富楼那。摩陀比丘命终之后。复值须弥山佛。于彼佛前。问摄出一切法经。时佛称赞百千善哉。即为广说摄出一切法门经。说是经时。无量众生。必定得阿耨多罗三藐三菩提。命终之后复值山王佛。于彼佛前问诸法门经。时佛称赞百千善哉。即为广说一切法门经。说是经时。无量众生。必定阿耨多罗三藐三菩提。命终之后复值梵音声佛。于彼佛前。问请摄一切法经。佛时称赞百千善哉。即为广说摄一切法经。说是经时。无量众生。必定阿耨多罗三藐三菩提。富楼那。摩陀比丘如是展转。所值诸佛值已问经。所度众生。令住阿耨多罗三藐三菩提。我若以劫若以过劫。说诸佛名。众生所住阿耨多罗三藐三菩提者不可得尽。富楼那。是摩陀比丘。凡所护持诸佛正法恒沙可数。是诸佛者。若现在世。若已灭度不可称计。是故富楼那。当知菩萨摩诃萨。闻未闻法思惟义理。得如是等大功德利。富楼那。汝谓尔时摩诃耐摩陀比丘于那罗延法师所。闻未闻法随其义趣者。岂异人乎。即桥越兜菩萨是。时摩诃耐摩陀比丘。守护正法闻所未闻。随其义趣不着言辞。以是因缘值无量佛。值已闻诸深妙经。以是往昔善根因缘。今于我所。亦问摄一切法大海法门经。我为说时。无量众生得大饶益。尔时世尊。欲重明此事。而说偈言

  菩萨闻未闻　　应思其义理
  不应作是言　　我昔未曾闻
  闻所未闻法　　正念思其义
  是故慧增长　　如海受众流
  多闻转增上　　智慧亦复尔
  能问诸佛事　　广利诸众生
  集多闻如海　　智慧不可尽
  善能知章句　　差别中第一
  是故应当闻　　所未曾闻法
  求所未闻法　　得如是果报

复次富楼那。菩萨摩诃萨。于求多闻深生欲心。于空闲处深生乐心。一心勤求阿耨多罗三藐三菩提。求已为断嗔恚修集慈观。为断贪欲修不净观。为断愚痴修因缘观。富楼那。何等是菩萨精进。菩萨云何修集精进。富楼那。若有菩萨。若于一劫若减一劫。若行若坐常发精进。富楼那。如是不名真实精进。有菩萨若于一劫若减一劫。修行净戒。苦行难行具足头陀。随所缘事深生欲心。而离诸法实相。如是不名真实精进。富楼那白佛言。世尊。何者是菩萨真实精进。诸佛所赞。世俗智者所不讥嫌

佛告富楼那。菩萨于所未闻。应深空法无有微相合第一义。如是深经不违不逆明了其义。勤发精进心不退没。听受读诵。为人解说。是名菩萨真实精进。谓闻深经通达其义不违不逆。如是精进诸佛所赞。世间智者所不能诃。是故富楼那。菩萨应发如是庄严。世间众生不能得底。我于此中当尽其底。世间众生所可没处。我于此中不应沉没。世间众生所可畏处。我于此中不应怖畏。所以者何。我发庄严不与世合。为离世法故而发庄严。不以行世法故而发庄严。为不行世法故而发庄严。不为随世法故而发庄严。为转世法故而发庄严。富楼那。是名菩萨摩诃萨真实精进。菩萨成就此第二法。则于阿耨多罗三藐三菩提不退转。尔时世尊。欲明了此义。而说偈言

  菩萨求深法　　常勤发精进
  思量其义理　　不随于音声
  菩萨不随言　　知皆是虚诳
  知诸法空故　　但求于善语
  若于千万亿　　无量诸劫数
  昼夜常行坐　　加心行苦行
  于所未闻经　　不信非精进
  能得深义底　　不名为懈怠
  如是精进者　　诸佛所称叹
  世间不得底　　菩萨得其底
  世间所畏没　　菩萨不畏没
  勤心常欲求　　空寂真妙法
  空法中无畏　　亦无有退没
  住我相法相　　故生怖畏没
  散坏一切法　　名为菩提道
  勤心发精进　　疾成多闻海

复次富楼那。菩萨善知五阴。善知十二入。善知十八界。善知十二因缘。善知五阴十二入十八界十二因缘故。则能成就无依止智。得无依止智故。则于一切法不念不分别。以不念不分别为众生说法。破一切见令拔身见。菩萨成就此第三法。则于阿耨多罗三藐三菩提不退转。尔时世尊。以偈颂曰

  菩萨知五阴　　十二入皆空
  分别十八界　　通达十二缘
  不随于五阴　　知身是虚诳
  于诸内外入　　悉知其性空
  如是知诸法　　知已为人说
  是故此菩萨　　智慧转高大

复次富楼那。菩萨摩诃萨。如所结戒。如所说戒。善能随学无所缺犯。何等是菩萨学戒。学一切法是菩萨学戒。何以故。富楼那。菩萨学一切法得一切法智。以是法智得无分别慧。以是无分别慧能知一切事。云何知一切事。菩萨悉知一切内事。一切外事。一切内外事。富楼那。何故名内。内名凡所有受可贪着处。谓是内身从十二因缘生。是中但有世俗假名。所谓此眼此耳此鼻此舌此身此意。富楼那。是名为内。是法凡夫所贪着故。名之为内。作是言。我当得如是眼。不作如是眼。得如是耳鼻舌身意。不作如是耳鼻舌身意。是中但以所起业缘。有果报生。是故名内。其中差别凡夫贪着。谓是眼是耳身鼻舌意。皆名为内。复次富楼那。内名为二。此事虚诳。诸凡夫人贪着受取而生诤讼。富楼那。如来于此从本已来。如实知之而不贪着。云何如来如实知之而不贪着。如来于此法中不作归。谁不作归。谓是爱结。此眼不作归。离眼不作归。耳鼻舌身意不作归。离意不作归。何以故。富楼那。如来于法不得内不得外。是故如来。于此法中不作归。如来是实语者。作是言。比丘眼非汝等亦非他人。何以故。本体不可得故。何法是眼。是眼属谁。何法是耳鼻舌身意。是意属谁。何以故。本体不可得故。富楼那。眼者今当推捡。耳鼻舌身意。今当推捡。于法无所贪受。何以故。若有受法则生苦恼。苦恼生故则无有乐。是故富楼那。于法有受皆受苦恼。若受苦恼则不离苦。富楼那。是名推捡眼。推捡耳鼻舌身意。无有入处。何以故。富楼那。若有入处则有出处。是故如来于经中说。眼是空无我无我所。本性自尔。耳鼻舌身意是空无我无我所。本性自尔。是性无性。如是无性无作无坏。富楼那。如是法性。若诸佛生若佛不生。是性常住。如来于诸法生知是不生。是故如来是实语者。作是言。若有佛生若佛不生。是性常住。富楼那。云何名无生。云何名无生智。富楼那。诸法平等名为无生。道名无生智。苦尽名无生。道名无生智。是名如来说有二谛。谓世谛第一义谛。富楼那。如来所说苦相。即是说无相。云何名苦相。谓是无为相。无为即是无相。智者知无为是无相。富楼那。智者云何知无为是无相。谓知无为法空。知是寂灭。知是归处。知第一利。知无热恼智者如是知无为。于是智中亦不生相。富楼那。智者离诸相得第一义利。无作无坏。富楼那。若人有作即是坏。若无作则无坏。无坏相是空。无坏相是无相。无坏相是无愿。富楼那。空法无有人作。无有人坏。无相无愿无有人作。无有人坏。富楼那。是名诸佛阿耨多罗三藐三菩提不坏相。何等是诸佛阿耨多罗三藐三菩提。谓诸如来所不得是。富楼那白佛言。世尊。何等法是诸如来所不得。佛言富楼那。一切法是诸如来所不得。世尊。以是故一切法是诸佛菩提耶。佛言如是。富楼那。一切法是诸佛菩提。而是菩提不名一切法。言一切法是诸佛菩提者。但是世俗假名言而说。不精进者难解难知。所以者何。不精进者。不能修习诸法平等。若不平等则与佛诤。富楼那。何人不能修行平等。富楼那。一切世间行不平等。诸佛菩提是中。无等亦无不等。富楼那。我以是道得阿耨多罗三藐三菩提。以是因缘我经中说。一切诸法于正位中皆入必定。是名必定入菩提门。是故富楼那。一切法皆是菩提。尔时富楼那白佛言。希有世尊。是诸佛阿耨多罗三藐三菩提。亦定亦不定。亦入文字。亦不入文字。亦入语言。亦不入语言。何以故。世尊。我今从佛闻说是经。于诸法中普得决定光明。世尊。我今如是于诸法中得决定光明。于一事中知一切事。知一切事中知一事。尔时佛赞富楼那言。善哉善哉。富楼那。汝能如是疾入诸佛一切法利。当知汝已曾于过去世。供养诸佛。种诸善根。亲近咨问富楼那。我念过去。于此土地虚空分中。汝已曾于六万八千诸佛所。得闻是经。以是善根功德因缘。汝于诸法普得决定光明。世尊。若我已于若千佛所得闻是经。我何故乃不以一念发阿耨多罗三藐三菩提。佛告富楼那。我念过去世。汝曾一劫。发阿耨多罗三藐三菩提心。不杂余心而还退失。以是福德因缘。我今说汝于诸法师为最第一。富楼那白佛言。世尊。我本作何罪障。于一劫中发阿耨多罗三藐三菩提心而还退失。佛言。富楼那。随逐依止恶知识故。又不能广流布法故。汝于阿耨多罗三藐三菩提心而还退失。富楼那。有四法。退失阿耨多罗三藐三菩提成声闻乘。何等四。菩萨亲近恶知识故。能于善根增恶远离。作是言。何用如是发菩提心。生死长远苦恼无量。往来五道。值无难难。值诸佛难。净信复难。虽得值佛出家复难。汝今得值无难。勿复还失。汝于诸佛。未受阿耨多罗三藐三菩提记。善根未定。不得涅槃。轮转五道。是人闻说是已心则退没。于菩提道懈怠不乐。富楼那。菩萨有是初法。退失菩提成声闻乘。复次富楼那。菩萨不闻应菩萨经。谓菩萨藏经。发菩萨心经。摄菩萨事经。应六波罗蜜经。以不闻故。不如说行。不如说学。是人不知菩萨何法应亲近。何法应远离。何法应受。何法不应受。何法是菩萨法。何法是声闻法。如是不知不分别故。应亲近法而不亲近。不应亲近法而反亲近。是人应亲近法而不亲近不应亲近法而亲近故。则便退失诸佛菩提。心弱懈厌废舍本愿。富楼那。菩萨有此二法。退失菩提成声闻乘。复次富楼那。菩萨计得诸法。贪着吾我。行于邪见。堕在边见。没在恶邪。难可拔出。得闻深经。应第一义。无有微相。违逆不信。不能通达。起破法罪。以是因缘。生在难处不得值佛。不得闻法。不值诸佛所教化法。不得善知识。是人不见佛故不闻法。不闻法故不值诸佛所教导法。不值诸佛所教导法故不得善知识。不得善知识故失无难处生在难处。在难处故离善知识。遇恶知识。与恶知识共从事故忘失本念。是人失本念故舍菩萨心。舍菩萨乘而便退转。永失菩提念。但行生死法。不能修习大乘行法。富楼那。菩萨有此第三法。退失菩提成声闻乘。复次富楼那。菩萨得闻如是等经。不能深心教化他人。其心退没但乐独行。悭吝惜法心不欲说。不能以法广摄人众。以是不善根因缘故失智慧念。失智慧念已。不共他人读诵经法。不能以法与他共同。是人转身。失菩萨心忘菩萨念。富楼那。菩萨有此第四法。退失菩提成声闻乘。尔时世尊。欲明了此事而说偈言

  亲近恶知识　　懈怠于菩提
  以是因缘故　　失上菩提心
  深生恶我见　　堕在边邪见
  而起破法罪　　生在于难处
  生于难处已　　则断菩提心
  忘失本忆念　　是故失菩提
  是人不得闻　　生菩提心法
  是心若增长　　能成于菩提
  得广大妙法　　悭吝不欲说
  以是因缘故　　退失于菩提
  求大乘菩萨　　应知是四法
  若知此四法　　菩提得以生
  是故应远离　　如此四恶法
  勤修行空法　　得近善知识
  得如是经已　　不应悭吝惜
  勤心为人说　　从是生菩提

佛告富楼那。菩萨成就四法。随回向菩提心不退失。随回向诸善根亦不退失。何等四。菩萨持戒清净忆念。成就有念安慧。勤心精进而不懈退。成就多闻生慧。富楼那。菩萨有此四法。随回向菩提心不退失。随回向诸善根亦不退失。尔时世尊。欲明了此义。而说偈言

  菩萨具持戒　　所忆念深远
  勤心当精进　　多闻庄严慧
  菩萨常亲近　　如是之四法
  随心所起事　　皆能得成就
  是故应常持　　净戒勤精进
  不断忆念法　　常勤求多闻
  持戒净生处　　忆念能净智
  精进净佛法　　多闻生大慧
  是故诸菩萨　　当学是上法
  学是上法已　　当转无上轮

复次富楼那。菩萨有四法。则能利益菩提。持戒则是利菩提法。忍辱则是利菩提法。精进则是利菩提法。多闻则是利菩提法。富楼那。是名四法利益菩提。尔时世尊。欲明了此义。而说偈言

  菩萨净持戒　　利益于菩提
  精进及忍辱　　多闻亦如是
  清净持戒者　　所愿皆得成
  戒净多利益　　菩提不为难
  菩萨行忍辱　　身相智慧成
  是故当行忍　　求佛相智慧
  精进亦复能　　多利益菩提
  常行精进者　　菩提则不难
  多闻亦能利　　闻已得近法
  远离于非法　　菩提则不难
  四法是种子　　从是生菩提
  是故诸菩萨　　应近是利法

复次富楼那。菩萨摩诃萨。成就四法。则得身色具足财物具足眷属具足。终常不生诸恶难处。常值诸佛诸佛所赞。何等四。菩萨行慈不嗔不恼一切众生。富楼那。何谓菩萨行慈不嗔不恼一切众生。菩萨行慈于诸众生起我救慈。见诸众生身苦心苦。当作是念。我当勤行精进度是众生。于生死苦是诸众生。我应与乐。我应拔济离生死苦于诸众生应发是心。发是心已勤行精进。修习六波罗蜜布施持戒忍辱精进禅定智慧。富楼那。菩萨因般若波罗蜜。得具足六波罗蜜。何等为菩萨般若波罗蜜。菩萨云何因般若波罗蜜勤发精进。富楼那。菩萨作是思量何法名我。何法名我所。如是思量时。不见法是我。不见法是我所。作是念。作是念已。于此法中无我法。无我所法。菩萨离我我所故知身空。身空故众生空。何以故。诸法中我我所尚空。何况众生。菩萨如是离我我所故知众生空。众生空故知色阴空。色阴空故受想行识阴空。菩萨如是离我我所故知身空。身空故知众生空。众生空故知诸阴空。诸阴空故知种亦空。谓地水火风虚空识种地种地种相空。水火风虚空识种识种相空。是种无作者无使作者。若无作者是法即空。富楼那。菩萨于此离我我所故知身空。身空故知众生空。众生空故知诸阴空。知诸阴空故知诸种空。诸种空故知诸入空诸入空故诸入相空。诸入无作者无使作者。若法无作者无使作者是法即空。富楼那。菩萨以是观一切法空。观一切法空时。不见。诸法本体可生嗔处。富楼那。是名菩萨摩诃萨大慈。知身空慈。众生空慈。阴入种空慈。菩萨若能行如是慈。是名行一切法空慈。富楼那。是名菩萨行于大慈。如是菩萨离我我所。心深生欲心。于阿耨多罗三藐三菩提生大悲心。于诸众生若有众生。不知如是诸法实相。为令知故发大庄严。是名菩萨行于大悲我救故名慈。我作故名悲。菩萨成就如是大慈。能为众生作救作归。作舍作洲。能作究竟。是故菩萨应如是修行大慈。不贪着众生。亦不生嗔恨。是名菩萨众生空慈无有嗔恚。富楼那。若菩萨因慈因离因空。能入一切诸法不生不灭。是名菩萨常行大慈。菩萨如是通达诸法。诸魔魔民及魔所使皆不能坏。菩萨成就是初法者。能断一切功德中缚。断功德缚故得平等波罗蜜。尔时世尊。欲明了此事。而说偈言

  菩萨常如是　　修慈而观空
  知阴入界离　　是中无有我
  我我所二法　　决定不可得
  为不得诸法　　而修行慈心
  不依止诸法　　亦非不依止
  是名诸佛道　　诸不依止法
  能得无上忍　　忍诸法实相
  诸法无生灭　　能善通其理
  诸有大智者　　亲近于是法
  常得妙身色　　亦得乐说辩
  常得值诸佛　　知诸法义利
  是故此菩萨　　得无为上道

复次富楼那。菩萨摩诃萨。精勤供养诸佛塔寺。敬心以好花香缨珞涂香末香幡盖妓乐种种供具而以供养。菩萨成就此第二法。能得具足一切功德。尔时世尊。欲明了此义。而说偈言

  菩萨以上妙　　供养上智塔
  花香及幡盖　　以求上智慧
  以此功德缘　　受身常端正
  饶财多宝珍　　眷属具成就
  必定于菩提　　常安住于法
  在在所生处　　功德转高增
  诸王所恭敬　　天龙神常念
  一切诸众生　　亦皆共恭敬
  若人供养佛　　现在若灭后
  所生得供养　　常在无难处

复次富楼那。菩萨摩诃萨。常当勤心供养于法云何名为法。云何名供养法。名四念处。四正勤。四如意足。四禅。五根。五力。七觉意。八圣道。止观明解脱。三解脱门。尽智。无生智。是名为法。云何供养。于是法中如所说行随顺不逆。生欲精进具足修习。是名供养法。复次富楼那。供养法法名。如是等经信解思惟。分别随顺心不违逆。是名供养法。菩萨成就此第三法。能得具足一切功德。尔时世尊。欲明了此义。而说偈言

  常勤供养法　　如所说中住
  闻深空妙法　　其心不违逆
  故身常端正　　亦得乐说辩
  如我所赞法　　以此转高增

复次富楼那。菩萨摩诃萨。勤心供养如来圣众。若花若香。若以璎珞。若以末香。若以涂香。若以幡盖衣服饮食卧具医药资生之物。若起僧坊。若立园林。若经行处。若以浴池。若以井泉。若以人使如是等余供养具。种种供养如是圣众。菩萨成就此第四法。能得具足一切功德。尔时世尊。欲明了此义。而说偈言

  无上供养具　　供养如来众
  以此功德缘　　所生多财宝
  身色常端正　　亦得乐说辩
  具足诸功德　　智慧转高增
  供养正直心　　无我我所者
  以此智因缘　　生处得供养
  诸佛所称赞　　四法常亲近
  所生常尊贵　　功德转高增

大宝积经卷第七十七大宝积经卷第七十八

        后秦三藏罗什译

    富楼那会第十七之二具善根品第四

尔时佛告富楼那。菩萨摩诃萨发于大乘。常当修习亲近四法。则能具摄一切善法。亦能具足一切善根。何等四法。富楼那。善男子善女人发大乘心。修习亲近行忍辱法。如是修行忍辱法时。如心平等故。则得平等波罗蜜。亦得一切众生平等波罗蜜。是菩萨成就心平等波罗蜜。智平等波罗蜜。若行若立。若坐若卧。若觉若睡。时有人来。若持屎瓶。若持毒瓶。若持沸汤瓶。若诸粪扫。若持火炭。若持屎尿。若持热灰。捶其头上。若捶其身。菩萨于此不应嗔恨。令心散乱而生忿恚。不应自言我有何罪。又不应以恶心视彼。但应一心求自利法。于所修事专心不舍。应当如是调伏其心。是人为以何因缘故。持此屎瓶毒瓶灰火来加我身。我身不以此物因缘而得痛恼。菩萨是时应如是观众因缘法。谁与此物此物异谁。以何物与。是人如是如实思惟不见有法。谁是与者。谁是受者。何者是法。如是正念思惟观时。此彼不可得故。一切诸法皆不可得。皆不可见。是菩萨不得不见一切法故不生嗔恨。富楼那。若菩萨如是思惟。犹有嗔恨心起。复应如是正念思惟。何触因缘使我身痛。是诸触者为触何处。为在于身。为在于心。若在身者。身如草木瓦石影像。无觉无知。非我非彼。若在心者。心无形色。念念生灭须臾不住。非我非彼。但以虚妄忆想分别。说言是苦是乐不苦不乐。我今不应生此虚妄忆想分别。我今应观平等实相。我当修习贤圣所作。不应随逐凡夫所作。何等为是贤圣所作。谓于诸法远离解脱。我为远离故学不为和合故学。如是虚妄忆想分别。是皆和合。为谁和合。为是贪欲和合。为是嗔恚愚痴和合。云何名为贪欲嗔恚愚痴和合。以身痴故。身见痴故。贪身见故。身受苦时嗔恚他人。是名嗔恚和合。有以身见痴故。贪身见故。不随意故嗔恚他人。是名愚痴和合。若人如是三毒所缚。或起如是罪业因缘。诸佛不救。何况余人。我应善观诸因缘法观于空法。菩萨如是随顺。正观诸因缘法。不见有法。谁与谁受。以何物与。尔时菩萨当作是念。一切诸法从众缘生。自性本空定不可得。我当云何于无所得虚妄法中。得法作业而生嗔恚。起行因缘。我今应生无嗔恨心。修行无作无起无生之法。当观空法不随我心。我今应观不作不起无生之法。不应依止起作之法。我应如实思惟诸法。我今不应于此虚妄无所有中。而强作法虚妄强作。谓是嗔恨。所以者何。依止法体则有嗔恨。诸法实相毕竟空中。无法本体可依止者。菩萨如是思惟诸法。其心寂然嗔恨不起。又是菩萨。若行若立。若坐若卧。若觉若睡。时有人来。以好美香末香涂香。以好名花散其身上。若以上妙香花璎珞。胆卜花。鬘婆梨师花。鬘众华璎珞。以覆其身。若以上妙细软衣服。谓加尸衣。若拘摄衣。若拘珍婆衣。若憍施耶衣。若刍摩衣。若劫贝衣。若细钦婆罗。若细缯衣。以如是等柔软细衣以覆其身。若以上妙缯盖幢幡张施其上。若以诸天名花香妙衣珍宝璎珞以覆其身。若以天上甘美饮食而以进上。菩萨于此种种供养。不应生爱令心贪着。不以此缘亲附其人。随顺其意往来问讯。不应偏心而起爱着。菩萨于此应以等心。通达一切诸法平等。应作是念。我于众生不应嗔恨。不应爱念。所以者何。憎爱二事俱是烦恼。我今于此不应生爱。应善通了诸法如实。所以者何。诸烦恼中爱缘所合此最为重。如是烦恼深彻骨髓。谓于能生结使法中爱心染着所以者何。所贪着事若不随意则生嗔恨。人皆自欲贪爱其身。有侵恼者则生嗔恨。是故当知。嗔恚则是染爱果报。贪着则是愚痴果报。我今当离染爱恶心。于诸法中无所贪着。我等不为贪欲故学。不为嗔恚故学。不为愚痴故学。我当广学诸法真实。于诸法相如实观之。随所说中当如实行。但应依止业报因缘。于诸供养苦恼事中。当知皆是宿业行缘。是故于诸随顺法中不生喜爱。违逆法中不生嗔恨。但应清净其心无所忿恚。不令随爱随嗔随痴恶法得生于心。富楼那。菩萨成就此初法者。能得具足一切功德。尔时世尊。欲明了此义。而说偈言

  我常赞智慧　　亦赞持戒者
  称扬行忍辱　　亦常赞多闻
  我赞行善法　　慈心爱语者
  为饶益众生　　随宜赞众德
  我常诃五欲　　嗔恨愚痴人
  嫉妒慢谄曲　　浊乱娆众生
  懈怠懒惰心　　儱戾难与语
  背恩无反复　　小事发大恚
  贪求于利养　　我当得利养
  不欲令人得　　是等我不赞
  小智于利养　　自欲嫉彼得
  于他家生苦　　是等我不赞
  为求得利养　　转易威仪行
  此命非清净　　离我法甚远
  不修行道者　　有此诸过咎
  是等恶道缘　　无一事可赞
  不断恶我见　　贪爱心则多
  贪爱心多故　　勤求于利养
  菩萨作是念　　行忍益众生
  摧伏刚强心　　疾得成佛道
  我当行慈心　　忍辱愍众生
  而知诸法空　　从缘无所属
  何缘有诸法　　是法兴于心
  妄想生嗔恚　　不念则皆空
  妄想生三界　　相续身不绝
  不分别妄想　　则无如是过
  常思量诸法　　知皆从缘生
  常观诸法空　　而能度一切
  离戒苦众生　　憍慢所伤害
  为说灭苦法　　多有所饶益
  若人从东来　　南西北四维
  执持屎毒瓶　　以捶其头上
  我不生嗔心　　谁与谁受者
  何法名为我　　观以勤精进
  不恶色视彼　　何罪而见加
  但发坚强思　　慈心覆于彼
  知是宿业缘　　今受此果报
  偿已更不作　　安住佛道中
  余人无有此　　轻毁苦恼事
  此必是业缘　　虽久而不失
  众生在世间　　常起善恶业
  我今受此苦　　当知是业缘
  若还以恶报　　后复受苦果
  宁可以恶事　　而加于彼人
  当求无上法　　求已为人说
  度脱众生类　　一切诸苦恼
  若人以香花　　璎珞供养我
  不应生爱心　　当习平等观
  憎爱则非道　　常应行舍心
  当正观诸法　　谁与谁受者
  空与空受耶　　内空外亦空
  空无与无受　　一切皆无我
  空无有贪离　　空无有烦恼
  亦无有清净　　离垢净是空
  空中无分别　　空中无诸性
  空常空无相　　是比清净道
  若使有人来　　段段解我身
  于中不生恚　　知从业缘有
  众生起善恶　　随业自受果
  我必先世恶　　今受此苦报
  今受此恶报　　观身如影像
  水沫幻化炎　　无空毕竟空
  若人支解身　　有人将养我
  当念报恩者　　不以为欢喜
  利养不以喜　　恶骂不嗔恨
  二皆是障碍　　非佛正真道
  当离诸一切　　贪爱嗔恚心
  常当修空寂　　悉断诸障碍
  忍辱十力本　　诸佛神通原
  无碍智大悲　　皆以忍为本
  四谛念正勤　　根力觉道分
  皆以忍为本　　何智不修忍
  我于波罗奈　　转无上法轮
  亦以忍为本　　诸佛常赞忍
  汝等亦应修　　空忍无生灭
  诸法相常尔　　乃得佛功德

复次富楼那。菩萨摩诃萨能离五欲。常乐出家心顺出家。趣向出家不贪五欲。得出家已离诸愦闹。远处山林不失善法。菩萨成就此第二法。则能具足一切功德。尔时世尊。以偈颂曰

  心常乐出家　　而能常出家
  常乐在山林　　增益功德处
  亲近在空闲　　即离五欲着
  此中无众闹　　失诸善法缘
  无有诸语言　　往来问讯事
  空闲寂然快　　诸佛所称赞
  是故诸菩萨　　所应常亲近
  勿贪乐聚落　　近生利养心
  若得利养喜　　失则生忧恼
  此人供养佛　　不名为供养
  欲除如是过　　当离诸利养
  远离在空闲　　修习于空法

复次富楼那。菩萨常学求法。求已读诵。谓求净戒头陀细法。不求多欲无厌足法。求灭贪欲不益贪欲。求破嗔恚不增嗔恚。求断愚痴不益愚痴。求破憍慢不求起慢。求破我慢不求长慢。求断我我所法。不求增我我所法。求无我法。不求依止我人众生寿命法。常求能得大智慧法。不求退失大智慧法。常求为得无等慧法。不为求得小慧法。求得具足一切诸法。不求不具足诸功德法。求如是法。求已读诵。思惟正观。如所说行。为人演说。不求世利。乃至不求称赞善哉。教多众生令住是法。富楼那。菩萨成就此第三法。能得具足一切功德。尔时世尊。以偈颂曰

  菩萨乐出家　　持戒行头陀
  以是增智慧　　智雨益终流
  得是深净法　　正念思其义
  于如所说中　　能如所闻行
  常以清净心　　为人广解说
  饶益诸众生　　心无所悕望
  得诸功德味　　自住是法中
  亦令余人住　　是故增佛法
  若于无量劫　　所集诸功德
  令皆现在前　　摄入菩萨道
  故应求深法　　佛所称赞者
  常为众生说　　功德从是生

富楼那。菩萨摩诃萨安住持戒头陀法中。能具一切善根福德。富楼那过去久远无量无边不可思议阿僧祇劫。尔时有佛。号弥楼揵驮如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。佛寿六十岁。一会说法。八十亿比丘得阿罗汉道。富楼那。弥楼揵驮佛灭后。法住五百岁。般涅槃后七日之中。诸大弟子。皆亦随佛入于涅槃。富楼那。是佛出于五浊恶世。如我今也诸大弟子灭度之后。多有众生皆作是念。沙门法中安隐快乐。我等何不各共出家。作是念已咸剃须发法服出家。出家之后唯行三事。一常周旋往来白衣舍。二唯贪着利养自活。三长肌肥无有福慧。行是三事不修余业。百岁之后诸大弟子皆悉灭尽。是等比丘多与白衣和合。佛诸深经持戒头陀细行妙法。多皆废舍不复读诵。富楼那。当尔之时诸比丘众。乐行五欲贪嗜饮食。尔时国王唯有一子。名陀摩尸利。王甚爱重。时于静处而作是念。弥楼揵驮佛为得何法。今诸弟子皆共放逸。与诸白衣所行无异。作是思惟疑时。有天神来至其所。隐身不现而作是言。王子。弥楼揵驮佛所得深法清净决定。尔时王子闻天所说。即作是言。弥楼揵驮佛所得深法清净决定。其事云何。答言。王子。是法无色无受想行识。无阴界入。无有五欲。亦无欲心。弥楼揵驮佛。得是深法清净决定。为众生说。尔时王子复问天言。我等可得闻。是法不可得。解知如说行不。天言。王子。汝能一心勤行精进得之不难。富楼那尔时王子即作是念。今是天神开悟我意我当出家求是深法。即诣父母。头面作礼。白父母言。我今欲于弥楼揵驮佛法中出家为道。父母报言。汝今何用舍我出家。今诸道人于佛法中白衣无异。尔时父母。以偈答言

  今诸比丘众　　放逸受五欲
  耕种行贩卖　　白衣无有异
  贫穷多苦恼　　不能自活者
  如是诸人等　　求活故出家
  汝今生王家　　富乐受五欲
  多诸珍宝物　　何用出家为

陀摩尸利王子。以偈答父母言

  我不求荣位　　若得当舍离
  我今唯欲求　　佛法深净戒
  有天开悟我　　劝进我出家
  佛所说深法　　我冀当得知
  我闻天所说　　心中大欢喜
  佛法今欲灭　　我当助护持

父母以偈答陀摩尸利言

  深经已灭尽　　无有持诵者
  汝今当何从　　得闻佛深法
  若于四众中　　有诵深义者
  汝先从彼受　　然后可出家

陀摩尸利。以偈答父母言

  我今勤精进　　净戒行头陀
  远处山林中　　求佛深净法

富楼那。陀摩尸利说此偈已。头面作礼辞行出家。父母默然不能制止。即诣比丘剃除须发着袈裟受戒。以恭敬心问诸比丘。弥楼揵驮佛云何说法教诸弟子。我得闻已当如说修行。富楼那。诸比丘语陀摩尸利比丘言。我等不闻佛所说法。但随和尚诸师所行。汝今亦应行如是法。尔时陀摩尸利比丘。答诸比丘言。汝等必从贫贱出家。是故今者但贵衣食。所行如是白衣无异。汝等今应与我共求佛深净法。时诸比丘以偈。答陀摩尸利比丘言

  我等所为者　　是事皆已得
  衣食极丰足　　免离王使役
  安隐甚快乐　　无敢轻慢者
  白衣时苦恼　　今皆无复有
  是即名涅槃　　第一快安乐
  过是事以外　　我皆不复用
  我等多衣钵　　汤药物甚多
  白衣常给施　　檀越家亦多

富楼那。尔时陀摩尸利比丘。闻诸比丘说此偈已。心则悲恼涕零啼泣。诣余精舍。复以是事问诸比丘。弥楼揵驮佛云何说法教诸弟子。我得闻已当如说行。诸比丘众亦如是答。尔时陀摩尸利比丘。即便舍离此诸比丘。独入山林幽远之处。精诚一心欲求深法。先时弥楼揵驮佛诸弟子中。有大弟子名为坚牢。修空闲行独住深山。少欲知足心乐远离。所作已办。六通三明。大阿罗汉。亦如我今摩诃迦叶。是坚牢比丘。所住深山石窟壁上。书此偈言

  生死不断绝　　贪欲嗜味故
  养怨入丘冢　　唐受诸辛苦
  身臭如死尸　　九孔流不净
  如厕虫乐粪　　愚贪身无异
  忆想妄分别　　则是五欲本
  智者不分别　　五欲则断灭
  邪念生贪着　　贪着生烦恼
  正念无贪着　　余烦恼亦尽

富楼那。坚牢比丘石窟壁上书此四偈。陀摩尸利比丘经历深山。见此石窟壁上四偈。见已读诵思惟其义。未久之间得五神通。至弥楼揵驮佛本所烧处。到已作礼围绕三匝。结跏趺坐发誓愿言。我不见佛不闻余法不起于此。富楼那。弥楼揵驮佛所说经名八百千门。释提桓因诵持是经。释提桓因知陀摩尸利比丘深心爱法。从忉利天上来下至其所。为说八百千门经。又与四多闻本句七种重句十四门句。陀摩尸利比丘闻已诵持。于诸法中得智慧明。弥楼揵驮佛所说清净应空应离。诸深妙经自然在心。又弥楼揵驮佛为现其身。及比丘众并所。住处。精舍床榻大会四众。天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切众会悉令得见。陀摩尸利比丘。于诸法中得智慧眼。从坐处起渐渐游行。还至本国到父母所。为说清净应空应离诸深妙经。称扬赞佛法众功德。富楼那。尔时陀摩尸利比丘。父母宫人大臣官属。闻是法已信心恭敬。语陀摩尸利比丘言。唯愿大德济度我等。得于弥楼揵驮佛法中出家。富楼那。尔时八万四千人俱。随逐国王及王夫人一时出家。出家之后。皆号陀摩尸利语诸比丘众。富楼那。是陀摩尸利比丘。还令弥楼揵驮佛法续复炽盛。使多众生得住其中。是其宿命大慈悲心愿护法故。于是陀摩尸利比丘。从一聚落至一聚落。从城至城从国至国。游行称赞弥楼揵驮佛及弟子功德。又以清净应空应离诸深经法。为诸众生广演解说。尔时陀摩尸利比丘。多为众人供养恭敬。尊重赞叹名闻流布。富楼那。陀摩尸利比丘。如是广益诸众生已后则命终。其诸弟子比丘比丘尼优婆塞优婆夷皆共和合。以一切香木为积供养烧身。共起塔庙纵广十里。以众花香末香涂香璎珞幡盖。供养恭敬尊重赞叹。富楼那。陀摩尸利比丘临命终时。愿还生此阎浮提内。即得随愿生在王家。名为得念。于弥楼揵驮佛后第三百岁法中出家。以其本愿宿命智故。诸门句陀罗尼句自然还得。以得陀罗尼力故。先未闻经能为众生敷演广说。不说前身曾所说者。富楼那。时诸陀摩尸利比丘众中。深智明利厚善根者。闻得念所说诸经。心皆随喜信受恭敬。供养守护得念比丘。其中比丘无有威德钝根者。顽钝闇塞薄善根者。闻得念比丘所说新法。不信不受违逆说过。作是言。如是等经。我等不从和上诸师所闻。本亦不从陀摩尸利大师所闻。富楼那。其中深智依止义者不随语言。以依义故心不违逆。不违逆故则护弥楼揵驮佛法。恭敬守护得念比丘。富楼那。尔时比丘比丘尼优婆塞优婆夷。有八十那由他人。随顺得念比丘所说经法。富楼那。时陀摩尸利诸弟子众。别为二部。一名陀摩尸利诸比丘众。二名得念诸比丘众。得念比丘。不说我是陀摩尸利。所以者何。陀摩尸利比丘。人皆谓得阿罗汉道非是菩萨。若自说者人则疑惑。得念比丘。人皆知是菩萨非阿罗汉。富楼那。得念比丘如是广利诸众生已后复命终。诸弟子众。以一切香木为积供养烧身。四众普集。为欲供养大师菩萨。共起塔庙纵广五里。以众香花末香涂香璎珞幡盖。供养恭敬尊重赞叹。富楼那。得念比丘临命终时。还复愿生此阎浮提。随愿得生大长者家。名为耶舍。以本愿故得识宿命。于弥楼揵驮佛第四百岁。始年七岁出家为道。得诸陀罗尼。陀罗尼力故。能为人说所未闻经。于是得念诸比丘众。陀摩尸利诸比丘众其中厚善根者。得闻耶舍所说诸法。心大欢喜皆得法乐。富楼那。是诸比丘。依止于义不随语言。是故闻耶舍比丘闻所未闻应空深经。合第一义信受不逆。能受持诵如所说行。富楼那。中有比丘。顽钝闇塞薄善根者。从耶舍比丘闻所未闻。所未合第一义应空深经。不信不受违逆毁坏。而作是言。如是法者。我等不从和尚诸师所闻。亦复不从得念菩萨大师所闻。富楼那。诸从耶舍比丘。闻法欢喜心信受者。皆为陀摩尸利比丘。得念比丘等。憎嫉轻慢不听住止。不共读诵讲说经法。反更谤言。此非佛法非大师教。富楼那。尔时耶舍比丘。广宣流布弥楼揵驮佛法。从一聚落至一聚落。为众生说多所饶益。教化八十亿那由他人。发阿耨多罗三藐三菩提心。耶舍比丘所饶益如是后复命终。其诸随逐耶舍比丘有七万人。为耶舍比丘起七万塔。以众香花涂香末香璎珞幡盖。供养恭敬尊重赞叹。富楼那。耶舍比丘临命终时。还复愿生此阎浮提。命终之后即得随愿复生王家。生时诸天发大声言。今王所生多益众生。即随此声字为导师。至年十四。于弥楼揵驮佛法第五百岁出家学道。是导师比丘广诵经书。多闻深入文词清辩善巧说法。富楼那。是导师比丘。从一聚落至一聚落。从城至城从国至国。流布弥楼揵驮佛法多所饶益。尔时陀摩尸利得念耶舍诸比丘众。皆来合集造诣导师欲共毁破。尔时导师比丘知诸比丘来。作是言。汝诸比丘问难何事。以何事问。云何而问。诸比丘等闻是语已。忧愁不乐默不能答。不能障碍导师比丘。富楼那。随此菩萨寿命在世佛法炽盛。随其终后佛法则灭。是导师比丘末后恶世法欲灭时。从一聚落至一聚落。从城至城从国至国。为多众生敷说清净应空深经。化八百万人。令发阿耨多罗三藐三菩提心。是人命终皆生天上。富楼那。是导师比丘所益如是。今夜命终明日夜法灭。富楼那。弥楼揵驮佛法灭故。诸深清净应空经法皆悉灭尽。富楼那。如是菩萨摩诃萨。以是深经守护佛法。能自具足善根福德。富楼那。是导师菩萨命终之后。即生彼土上方第十世界。时彼佛号善眼多陀阿伽陀阿罗诃三藐三佛陀。即复出家。宿世善根福德因缘。深慧明利辩才无尽捷利无碍。是导师比丘。于善眼佛法中。八万四千岁修诸善法。命终更生值第二佛。号日增肩。于是佛所出家修集善根。求阿耨多罗三藐三菩提。命终之后还生此土。复值后佛。号不空行多陀阿伽陀阿罗呵三藐三佛陀。于佛法中复行出家。七万岁中勤修善根。求阿耨多罗三藐三菩提。时名首罗不空行。佛授其记言。我灭之后。是首罗比丘当得作佛。号无碍眼多陀阿伽陀阿罗呵三藐三佛陀。富楼那。菩萨成就是第三法。能得具足一切功德。尔时世尊。欲明了此义。而说偈言

  菩萨闻甚深　　清净决定法
  身自能安住　　亦复教余人
  世间不得底　　菩萨而不没
  住于净戒中　　广利诸众生
  本事及譬喻　　示众以佛道
  诸佛之所说　　此是决定法
  菩萨能行利　　亦能利众生
  守护诸佛法　　教众以菩提
  众生如法事　　菩萨皆为作
  教众以佛道　　是则近菩提
  护持诸佛道　　亦广利众生
  诸天龙鬼神　　大人所敬养
  是故闻清净　　诸空深妙法
  一心应思求　　是则智增长

复次富楼那。菩萨摩诃萨具足诸行。诸行具故则能具足善根福德。何等为行。富楼那。菩萨亲近善知识。行布施持戒忍辱精进禅定智慧方便。何等为菩萨善知识。菩萨所从闻如是经。及教化方便。诸佛阿罗汉。及有深心求佛道菩萨。皆名菩萨善知识。菩萨成就此第四法。则能具足一切功德。尔时世尊。以偈颂曰

  我说诸菩萨　　所当应行法
  施已心欢喜　　无有诸悔恨
  云何为欢喜　　谓乐悉遍身
  常以此喜心　　而行菩萨道
  菩萨所布施　　回向于菩提
  饶益诸众生　　自利无有量
  若见有乞者　　心生于佛想
  念是人今来　　施遗我佛道
  我因于是人　　得净佛国土
  是人示我佛　　教化我佛道
  我今值此人　　快得大吉利
  欢乐遍满身　　更不乐余事
  若有人来诣　　遥见而问讯
  仁者须何物　　我当尽相与
  若言无所须　　菩萨亦欢喜
  为欲教化我　　故言无所须
  此贤以所乐　　少欲知足法
  今来开悟我　　使得菩提缘
  我今因此人　　复得教以法
  汝言无所须　　是语为善哉
  若言须此物　　以是可与我
  菩萨若有者　　欢喜言汝取
  若行布施已　　于后无所悔
  以念佛道故　　心常得欢喜
  布施已回向　　众生皆有分
  普令无所乏　　尽使得知足
  若行菩萨道　　众生闻我名
  自然知止足　　不生悭贪心
  今我国众生　　顺道皆知足
  舍诸五欲着　　皆乐行出家
  如是无量行　　以施而回向
  愿常行布施　　众生亦效我
  菩萨行布施　　以慈覆众生
  一切诸世间　　无有如是乐
  如大富长者　　多财饶珍宝
  唯正有一子　　积年久远行
  长者闻子还　　欢乐遍满身
  久别而今归　　便若如更生
  菩萨见乞人　　其心大欢喜
  长者欢喜分　　十六不及一
  若得施行已　　心则大欢喜
  慈心所生乐　　此乐无有比
  如王治罪人　　敕使支节解
  杀者将杀处　　举刀垂当下
  王恕赐荣位　　是人大欢喜
  犹不及菩萨　　施贫得欢乐
  菩萨行道时　　不求于福田
  有乞则便与　　故得大欢乐
  菩萨若值佛　　罗汉辟支佛
  敬心知难遇　　故往供养施
  菩萨有威德　　明利心调顺
  乐功德求道　　供养佛及众
  不以深恭敬　　奉事诸天神
  唯除于诸佛　　及诸佛弟子
  若有辟支佛　　自然得涅槃
  亦行而供养　　有是诸功德
  菩萨亦能知　　福田善不善
  世间诸智者　　不敬恶外道
  安住持戒品　　慈心覆众生
  精进无有比　　忍智多闻广
  行是诸功德　　于世为高尊
  能证佛菩提　　转无上法轮
  菩萨能修行　　如是上四法
  一切诸善根　　悉皆现在前
  无量亿数劫　　所修诸功德
  悉皆摄入此　　所行菩萨道
  是故诸菩萨　　应常修慈心
  出家处山林　　乐在空闲处
  常求诸清净　　甚深决定法
  具足菩萨行　　以此自增长

    神力品第五

尔时世尊。以神通力。从身一一毛孔。俱放百千万亿光明。又从一一毛孔。出如须弥山等大猛火炎。又从一一毛孔。出恒河沙等诸佛说法。时会大众普见如是大神通力。尔时世尊。现神力已还复如故。语富楼那言。汝见如来从诸毛孔出是神力不。已见世尊。富楼那。如来常有如是神力无有休废。今诸弟子但知如来在此说法。而我实于十方恒河沙等世界。常作佛事无有休息。亦于十方世界如是说法。富楼那。若人实语。何者是无等等无比人。两足福田极深难测。无边行者举足一步。一切众生不能得知不能思量。何心何行举足下足。当说我是富楼那一切众生不能思量。如来为以何思何心何行举足下足。尔时世尊。欲明了此义。而说偈言

  世尊以何思　　何行举下足
  动不动众生　　常不知此事
  神通力无量　　行处亦无量
  功德无量故　　第一极高尊
  大神慧无量　　无能尽知者
  假令一切人　　智慧神通力
  皆如舍利弗　　及与目揵连
  亦不能知我　　举足下足事
  正使一切人　　皆作辟支佛
  不知我一步　　况余深佛法
  假无量日月　　合为一日轮
  不能及如来　　一毛孔光明
  假使七万亿　　那由他世界
  日轮纵广等　　遍照无量土
  如是诸大日　　如十方恒沙
  合以为一日　　一光如须弥
  如是诸大日　　常照十方界
  比于佛光明　　不现如焦树
  是诸大日光　　不能彻树叶
  诸山河石壁　　皆悉能障碍
  如来光所照　　一切须弥山
  铁围金刚山　　彻过无有障
  光明神通力　　威德无有量
  谁见不发心　　唯除于不信
  众生见如是　　光明大神力
  多发无上心　　我等亦当得
  时佛则微笑　　阿难即问讯
  世尊何故笑　　无碍智愿答
  时佛答阿难　　众生今见我
  所现大神力　　发心愿作佛
  众中三万人　　愿护持是法
  我等于佛后　　赞诵如是经
  是人我灭后　　得闻是经法
  中时及后时　　闻已如说行
  发道心者难　　深乐佛法难
  后世能持诵　　是等经复难
  千万亿数劫　　诸佛出甚难
  于后末世中　　说是经复难

尔时佛告阿难。我以如是等经倍嘱累汝。所以者何。阎浮提内。随有如是菩萨藏经则有佛法。阿难。如是等深经灭故如说行法亦灭。如说行法灭故佛法则灭。阿难。汝今当以第一供养具供养于我。云何为弟子以第一供养具供养于我。汝心勿谓名花好香末香涂香。幡盖璎珞衣服妓乐。赞叹如来为上供养。阿难。如是不名第一供养。若人得闻如是等深经。受持读诵如所说行。是名以第一供养具供养恭敬尊重赞叹于佛。何以故。诸佛皆共供养恭敬尊重于法。不贵世间诸供养具。是故阿难。今以此经郑重殷勤嘱累于汝。何以故。阿难。我学如是等经。今得阿耨多罗三藐三菩提。转无上法轮。过去诸佛本行菩萨道时。亦学如是等经。得阿耨多罗三藐三菩提。转无上法轮。未来诸佛亦学如是等经。当得阿耨多罗三藐三菩提。转无上法轮。现在十方世界诸佛。本行菩萨道时。亦学如是等经。得阿耨多罗三藐三菩提。今转法轮。是故阿难。是菩萨藏经。名为转法轮经。当奉持之。我于波罗奈国梨师山鹿园中。与声闻弟子转于法轮。阿难。我今于此竹园中。转此菩萨藏经不退转轮断一切众生疑。阿难。过去诸佛。亦皆于此虚空地。分说是菩萨藏经。未来诸佛。亦皆于此虚空地。分说此菩萨藏经。我今得阿耨多罗三藐三菩提。亦于此虚空地。分说此菩萨藏经。是故当知。此地是佛大塔。天人世间所供养处。阿难。此地独有不共功德。所谓过去诸佛于此说诸深经。阿难。所有贪欲嗔恚愚痴众生。入此竹园不发贪欲嗔恚愚痴。阿难。如来虽住诸余精舍。而皆无有如是功德。何以故。阿难。今此迦兰陀竹林。畜生入者不发淫欲。众鸟入者非时不鸣。摩竭洴沙浇顶大王。昔初登位与诸婇女入此园中共相娱乐。入以自觉。心无淫欲娱乐戏事。诸淫女众亦皆自觉。心无有欲不乐。戏乐。时王欢喜每作是念。愿世有佛出于我国。我当得见见已心信信已供养。当以是园奉上于佛。佛于中住我当闻法。何以故可供养者应住此园。非五欲人所应得住。阿难。洴沙王入此竹园生是善心。皆以过去诸佛住此园中说此菩萨藏经。是故此园所有功德不与余共。一切世间天人阿修罗皆应礼敬。阿难。是园无有虺蛇蜈蚣蚊虻毒螫。若住其中无复毒心。亦是竹园不共功德。我若百岁称说此园所有功德犹不能尽。何以故。阿难。今此竹园精舍成就无量功德。余处不尔。阿难白佛言。我本不知竹园乃有如是功德。世尊。我本不欲为佛侍者。我今忏谢如是过罪。佛告阿难。汝初于法得法眼净。尔时已为除灭是罪也

大宝积经卷第七十八大宝积经卷第七十九

        后秦三藏罗什译

    富楼那会第十七之三大悲品第六

尔时大目揵连作是念。希有世尊。世尊成就如是大悲。善能解说诸菩萨事。所以者何。菩萨具足修集佛法。为无生灭示悟众生。尔时佛知目连所念。而告之曰。如是如是。目连。诸佛成就大悲之心。若我弟子闻说此悲具足义者。心则迷闷无所复乐。目连。且置如来大悲。若我具说为菩萨时所有大悲。汝亦迷闷无所复乐。尔时目连白佛言。善哉世尊。愿说本行菩萨道时大悲少分。佛告目连。汝今谛听善念持之。当为汝说本行菩萨道时大悲少分。当以譬喻解说其义。本行菩萨道时。所行大悲说不可尽。而是大悲依于四事。何等为四。是菩萨大悲。菩萨随所住悲能修佛法。名为大悲。目连。我本于众生有如是大悲。有如是大愿。所有众生于阿鼻大地狱受诸苦恼。黑绳大地狱。僧伽陀地狱。活地狱。叫唤地狱。大叫唤地狱。炙地狱。大炙地狱。我常代此众生。受诸大地狱中苦。乃至罪毕受诸苦时心无忧悔。目连。若可有是因缘得度众生。我能尽代。令诸众生出大地狱。我代受苦一入地狱。尽诸众生所作罪业。我于尔时心无忧悔。目连。我发如是大愿。精进咨问有智。所谓佛及弟子。可有如是道理因缘代受苦恼。令诸众生出地狱不。目连。智者闻已。但为我赞说多闻。深发道心。布施持戒忍辱精进。赞说亲近善知识。目连。我闻是已大发精进。为求法故深生欲心。求得成就诸佛大法。勤行精进具诸波罗蜜。深行忍辱。目连。我本云何深行忍辱。本为菩萨时发如是心。十方所有众生。若有色若无色。若有想若无想。若非有想若非无想。假使是诸众生。尽得人身来诣我所。作是言。仁者。发阿耨多罗三藐三菩提心。我等多所乏短。五欲乐具资生之物。汝若不能。悉与我者。不得阿耨多罗三藐三菩提。若是众生时皆恶口。苦切骂詈妄说过恶。不称意故。以刀杖瓦石加害我身。我于尔时不应生恚。不应悔退。我应如是调伏其心。是诸众生愚痴不知起愚痴业。若我于此愚痴众生起嗔恨者。与此何异。此不入道我入善道。我今于此众生忍受诸苦。不起嗔业。心当如地等受好丑。目连。我本深行如是忍辱。复次目连。我常长夜于一切众生如视一子。如大长者饶财巨富。多诸珍宝奴婢人使。行百种戒。求得一子深心爱念情无厌足。目连。是长者于子常求好事。常与好事。常与利益不与衰恼。如是目连。我常长夜于诸众生视如一子。我常长夜为诸众生求诸好事。而以饶益不与衰恼。目连。我于长夜失道众生邪道众生。示以正道令住正道。目连。以是因缘。当知如来长夜。于诸众生深心爱念视如一子。目连。于过去世有贾客众。夜行失道入于邪径。夜黑闇故不知所趣。皆作是言。我等失道。无救无归无所依止。谁诸众生。若天若龙。若夜叉神。若人非人。示导我等令得正道谁能怜愍饶益我等。于此夜闇邪隘道中。与我光明。目连。尔时空林泽中。有外道仙人草庵中住。于夜闇中闻诸贾客悲唤音声。而作是言。今诸贾客夜闇于此空林中失道。若我不救则为非理。是诸贾客。或为虎狼师子大象野牛诸恶兽等恼害夺命。目连。仙人即时。以大音声告诸贾客。汝等勿畏我今相救。当作光明示汝正道。尔时仙人安慰。告诸贾客已。即以叠衣缠裹两臂。以油遍灌以火然之。与诸贾客光明示道。目连。时诸贾客皆作是念。今此仙人甚为希有。为我等故不惜身命。目连。时是仙人。以臂光明。照示贾客道已。于诸众生。悲心转增。作是念。我得阿耨多罗三藐三菩提时。邪道众生为作法明示以正道。目连。我于尔时。虽然两臂身心不异。何以故。目连。深心菩萨于求他利不贪身命。以净心布施因缘。臂还平复无有疮瘢。诸贾客等即得正道。至天明旦见仙人两臂无有疮瘢。生希有心。今是仙人有大神力。能于竟夜然其两臂。为照我等使得正道。然其手臂都不烧然。必成大行。必有大德。目连。时诸贾客语仙人言。善哉仙人。能为第一难行苦行。今以是行欲愿何事。仙人答言。诸贾客。我以此事。愿得阿耨多罗三藐三菩提已。当度汝等。于生死苦邪道众生。为说正道。时诸贾客心大欢喜。皆作是言。我等当以何事报此仙人。仙人言。汝等当共专行善法慎勿放逸。诸贾客言。敬从所诲。诸贾客等恭敬欢喜于是别去。目连。汝谓尔时外道仙人。为诸贾客然臂照道。岂异人乎。勿作是念。即我身是。诸贾客者。今千二百五十比丘是。目连。如来长夜怖畏众生施以无畏。邪道众生示以正道。无眼众生令得净眼。病重众生能治令差。以是因缘。当知如来长夜。于诸众生深有大悲。复次目连。过去久远。于此阎浮提中。大病劫至。众生普为大病所恼。尔时阎浮提王。名摩醯斯那。有八万四千大城。王于此中威势自在。时王最大夫人怀妊。若以身手触诸众生病皆除差。月满产男生已即言。我能治诸病人。又亦生时。阎浮提内诸天鬼神皆共唱言。今王所生便是人药。以是音声普流闻故。字为人药。时人皆将病人示此王子。诸病人至王子手触。若以身触即皆得差安隐快乐。如是展转阎浮提内。皆将病人以示王子。王子手触病皆除差安隐快乐。目连。人药王子于千岁中。如是治病后则命终。命终之后诸病人来。闻其已死忧愁涕泣。谁复度我病痛苦恼。诸病人言。人药王子于何烧身。问知所在趣其烧处。出骨捣末以涂其身即皆得差。作是唱言。人药王子于今犹能治诸病人。目连。如是因缘治诸病人骨渐消尽。骨尽之后至然身处。取地灰炭各涂其身病皆得差。目连。如是人药王子。于大病劫。以是方便治诸病人。目连。汝谓尔时人药王子。岂异人乎。勿作是念。即我身是。我于多病苦恼众生无救无依。疗治其病。我今得阿耨多罗三藐三菩提。亦以大智慧药治诸众生。毕竟尽苦。目连。我为众生受身。随可饶益即便饶益。目连。以是因缘。当知故为众生受身而作饶益。复次目连。过去久远我曾独行。时有恶兽来夺我命欲啖我肉。我临死时心发是愿。我今死后。当生于此空林泽中作大畜身。若诸恶兽夺我命者。悉皆令得充足饱满。所以者何。是诸恶兽常害小虫以啖其肉。多起杀罪而不饱足。我时发愿。当生于此作大畜身。令诸啖肉饮血众生皆得饱足。即时死已于中化生作大畜身。令诸恶兽饮血啖肉皆得充足。如是展转百千万亿那由他世。故为受身饶益众生乃至一劫。目连。若我自说本行道时。饥渴众生以身血肉施令饱满。若以一劫若减一劫说不可尽。目连。我本如是于诸苦恼众生深生悲心。复次目连。过去久远我念本身。见诸苦恼众生即作是念。我今不应舍而不救。即至其所而问之言。汝有何苦何所须欲。答言仁者。我等今者甚大饥渴。我闻是已即语之言。汝等今须何等饮食。答言。我等唯欲饮血啖肉。若能以身血肉与我。我则快乐无复病痛。我即许之。便自割肉出血与诸众生。目连。我于尔时心无悔惜。不愁不没。但作是念。我今割肉亦灭尔所生死苦分。我常长夜乐如是施。如是施已深得欢乐。以是因缘当知如来。于诸众生深有大悲。目连。我念过去时世有王名为大力。有大德力厚种善根。时大力王而作是念。我今何不设大施会充满众生。作是念已设大施会恣所求欲。须食与食。须饮与饮。有须衣服卧具。金银宝物。车乘钱财。有须车磲马瑙颇梨琉璃珊瑚虎珀等宝。悉能与之。花香璎珞。涂香末香。缯彩幢盖。男女大小。奴婢人使。象马牛羊。田地产业。皆悉与之。目连。是大力王如是大施。尔时帝释而作是念。我今何不与此国王作障碍事令其不果。时即自化作婆罗门。往诣王所而问王言。今大会中何所布施。答言。婆罗门。我所有物悉以布施无所爱惜。婆罗门言。汝所志愿我今所乞能见与不。大力王言。我既发言所有尽与。婆罗门言。王如是者。我今须王身分。王便念言。是婆罗门不须财物。今来直欲破我大施。我若不以身分与者。我则自破大会施事。作是念已。语婆罗门言。与汝身分截取持去。婆罗门言。大王今者作如是语将无悔耶。大力王言。我心不悔。但以今者多有乞人四方来集。我皆应使悉得满足。婆罗门言。我今一人尚不充足。何论余人。目连。时大力王即以利刀。自割其臂与婆罗门。汝可取是一臂。目连。其大力王自割臂时。心无变异无有悔恨。如是一心布施故。能舍一切故臂还平复。时大力王。以刀割身分。与婆罗门。与已还生。目连。尔时帝释以是因缘。天福则尽心热苦恼大唤。现身即堕阿鼻大地狱中。目连。汝谓尔时大力国王以身施者。岂异人乎。勿作是念。即我身是。尔时帝释欲障碍我大施会者。岂异人乎。勿作是念。即调达是。目连。是时调达痴人生嫉恚心。欲障我施而不能坏。堕大地狱。我今得阿耨多罗三藐三菩提。设大法施。调达痴人犹生恚嫉。贪利养故谋合人众欲共杀我。我时经行在于耆阇崛山下。自上山上机关发石。自破善根于我生恶。自失利养豪尊势力。身堕阿鼻大地狱中。目连。我于调达痴人无有身口意恶。而于长夜以我为怨。世世障我修集善法。而亦不能障我行善。我常长夜慈悲覆润。而不能使以我为亲。目连。调达世世不识我恩。我今举手。如调达等。亦复不识天人世间阿修罗恩。如是等人入邪定位。目连。调达于后临入阿鼻大地狱时。于我乃生深实好心。此亦是如来威神之力。调达第一不知恩义。临入阿鼻大地狱时。闻大声言。痴人调达嗔恚于佛不可杀人。而欲横起杀害因缘。以是罪故。今堕阿鼻大地狱中。闻是大怖心即摧伏。而作是言。我今唯以肉骨一心归命于佛。心即得乐于佛生信。作大音声。即入阿鼻大地狱中。以是因缘后出地狱得生人中。出家学道得辟支佛。号曰骨髓。目连。我今授调达记。作辟支佛。则为已度于生死苦。目连。我度调达如我本愿。所以者何。我于先世要度调达。我当度汝余无度者。目连。调达但于我所种涅槃因缘。不于余种。调达从是已后。亦复不于余种善根。但于我所信心清净。言归命佛。以是善根因缘。后得辟支佛道。目连。我常长夜于诸众生如父母想。愍其孤穷无有财物。往来生死险难恶道。愚痴无智常盲无目。谁能示导。谁能救护。唯我一人应示应救。目连。我念是已。若有众生恶口骂我。我不还报。若切责我我亦不报。若嗔若打我终不报。所以者何。我应常与一切众生毕定安乐。应除一切苦恼衰患。今我不应与诸苦恼。是诸众生谁能忍者。唯我能忍。我今当学众生忍法。善寂灭法。柔和顺法。当如调伏大象。不如不调伏象。目连。譬如调伏大象入战阵时心不退缩。能忍鼓声螺声角声大叫唤声。闻如是等可畏音声不惊不畏。能忍寒热蚊虻毒虫风雨饥渴。能忍种种锋剑所伤。弓弩箭槊刀鉾戟剑铁轮鞭打。皆能忍受不惊不畏。直冲战阵不退不缩。目连。调伏大象不作是念。我于贼阵不能冲入。但作是念。我当胜此贼阵。目连。我本行菩萨道时。发大心愿亦复如是。于诸众生调伏其心。若诸众生恶口骂我。我不加报。于我有诤我亦不报。若以刀杖瓦石加我。及夺我命。我于尔时。心不退转于阿耨多罗三藐三菩提。亦不分别是则可受是不可受。是应亲近是不应近。于是事中。无忧无悔无有恚恨。于菩萨道心无厌离。不作是念。我今不能入大贼阵。但作是念。我能破是大恶贼阵。当得阿耨多罗三藐三菩提。度脱三界无量众生。目连。我本行菩萨道时所行忍辱。于诸众生所有慈悲。若以言说不可得尽。复次目连。过去久远有外道仙人。名为忍力。受如是法。我于众生不生嗔恨。尔时有魔名为恶意。而作是念。我今何不往诣仙人坏其忍法。令发起嗔恨退舍忍心。即遣巧骂千人前后围绕。恶口骂詈妄说其过。秽言鄙词苦切备至。行时亦骂。到聚落亦骂。入聚落亦骂。食时亦骂。食已亦骂。从座起亦骂。从聚落出亦骂。还至住处林树亦骂。立亦骂。坐亦骂。卧亦骂。经行时亦骂。乃至息入息出亦骂。常随逐骂。种种不净丑恶骂詈。无有休息。目连。尔时千人为魔所使。于八万四千岁。恶口骂詈忍力仙人。尔时恶意魔。于忍力仙人入聚落时。自以屎灌其头上。着钵中涂衣钵身。以粪扫洒其头上。时忍力仙人。八万四千岁。健骂千人恶口骂詈轻贱。心终不嗔恨。乃至不生退没之心。亦不自言我有何罪。终不生怨恨。八万四千岁。亦不以恶眼视恶意魔。亦不自言我有何罪。目连。是健骂千人骂于忍力仙人。过八万四千岁已知不可坏。生净信心忏悔除罪。作是言。汝以是事欲求何法。我亦愿得是法。目连。是健骂千人。于仙人所得清净心。供养恭敬尊重赞叹。仙人既受供养。而亦不生贪爱之心。目连。汝谓尔时忍力仙人。岂异人乎。勿作是念。则我身是。我时受是忍辱法。恶意魔所遣千人。恶口骂詈不休不息常轻于我。亦不能令我心异。目连。健骂千人。于忍力仙人生清净心已。忏悔骂罪。随学忍力仙人。发阿耨多罗三藐三菩提心。我时教化令住佛法。是千人具足是六波罗蜜。次第成佛。皆已入于无余涅槃。目连。汝谓尔时恶意魔。常遣千人骂詈我者。岂异人乎。勿作是念。即调达是。复次目连。我念过世。自以其身施与众生。为世间人而作奴仆。尔时众人种种使我。有人使我分除屎尿。有人使我作除粪人。有人使我除土。有人使我取草。有人使我取谷米乳酪苏油蜜。有人使我取薪炭火水。如是等种种事务皆使我取。目连。我不忆尔时生如是心。有人使我分除屎尿不随去者。有人使我取花香璎珞涂香末香饮食果芥。而便随去。目连。我不忆尔时所好作务随去。不好作务而不随去。目连。我不念尔时随刹利不随婆罗门。随婆罗门不随刹利。随逐毗舍不随首陀罗。随逐首陀罗不随毗舍。随逐刹利婆罗门。不随毗舍首陀罗。随逐毗舍首陀罗。不随刹利婆罗门。亦不念有如是差别。是人大是人小。随逐是人不随是人。目连。但随先唤我者。欢喜随去。目连。我念本行菩萨道时。不念有人以如法事使我令作。终无有力而不为作。目连。我念本行菩萨道时。无有为事而不究竟。无有作善而善不终讫。举要言之。我念本行菩萨道时。未曾贪身。何况财物。我行菩萨道时。于财物中不生我物想。我但以先业果报有财。于是财物生如是念。此物当与众生共用。于此物中我有分者众生亦有。目连。随我行菩萨道得近佛法。不作是念。于我物中言我有分。众生有分。但念所有物是众生物。我无有分。目连。随我得近佛法。则于其中乐不贪着。不摄不取。乐远离诸法。不乐受诸法。乐一切空法。不乐一切法有。乐一切法寂。不乐诸法事相。乐本性无所有。不乐本性有所有。目连。我念本行菩萨道时。无量百千万世。于夜闇中自然其身。失道众生照示道处。目连。我念本行菩萨道时。无量百千万世。啖肉众生割肉施与。目连。我念本行菩萨道时。无量百千万世。饮血众生刺血施与。令得饱满快乐。目连。举要言之。于世间中若诸财物资生所用。于诸众生终不贪惜。皆为不恼不害众生。智者所许。贤圣所赞。我常如是。长夜于诸众生深行悲心。复次目连。我念过去。作贾客主名为吉利。入于大海取大珍宝。安隐而出还达本国。是人入城到家门前。是时城中多有乞儿。围绕在前作如是言。善来安隐吉利大檀越。我等欲有所乞。若见许者我等当乞。目连。尔时吉利语诸乞人。汝等可乞我所有物。能以相与无所贪惜。时诸乞人语吉利言。汝从大海所得宝物尽以与我。我等若尔皆得吉利。如是目连。吉利即时以诸珍宝尽与乞儿。凡有八十亿摩尼珠。一一皆直百亿两金。目连。是吉利以是多物施已。心无有异不生疑悔。尔时吉利以多宝物。与乞人已不入其家。复还至海采取珍宝。入海之后倍得宝物。过八十岁还到本国。欲入城时。见犯罪人杀者执缚。打恶声鼓街巷唱令。将至杀处加以刑戮。时应死者遥见吉利。作是言。贾客主施我无畏。救我死罪与我寿命。汝是大檀越贤善好人。吉利闻已语应死者。咄人。我今施汝无畏。救汝死罪。即至杀者所。人人皆与一摩尼珠价直一亿两金。汝今小住。待我今者至王边还。尔时吉利疾至王所。白言大王。我欲以好珍宝买此人命。王答吉利。是人罪不可恕。不可得买。若必欲买。汝所有物尽以与我。并自伏死乃可得脱。目连。尔时吉利闻已欢喜。我得大利得满所愿。能救此人得称我意。即时吉利得救此人免于死罪。即以居家所有财物。及于大海所得珍宝。无量千亿金银宝物。皆送与王。白大王言。可放此人。我所有物尽现在此。王受物已语杀者言。将吉利杀。答言尔诺。受王命已即缚吉利。将至杀处。右手举刀。欲斫吉利。手直不下惊怪恐怖。即将吉利白王此事。目连。王闻此语。即自执刀欲杀吉利。举刀欲斫。其王即时两臂落地。得大衰恼发声而死。目连。汝谓尔时吉利贾客主。岂异人乎。勿作是念。即我身是。尔时王者。即调达痴人是。目连。尔时调达欲夺我命不能得夺。至于今世。我得阿耨多罗三藐三菩提。欲夺我命而亦不能。何以故。如来一切世间天人阿修罗中无能害者。何况调达痴人。调达于今谋集恶人来欲杀我。亦自方便欲得杀我。而失利养名闻势力。生身直入阿鼻地狱。目连。我本行菩萨道时。不见利益众生如调达者。而调达不知恩义。我本修菩萨道时。于众生中犹如父母。以是因缘当知如来。于诸众生悲心深厚。复次目连。过去久远雪山王边有五百群象。于中有一大象王为主。体貌可爱大力有智。时是象群宿出在山崄隘难之处。唯有一道。尔时猎师见此象群。即夜于崄道中大作坑陷。作是念。此诸群象当堕此中。得属于我随我所取。夜作坑已驱逐群象向崄道坑。群象欲出见有大坑不能得过。目连。时象群主以身横在坑上为桥。使五百群象于脊上过。群象过已作势踊跳。尔时山神。说是偈言

  恶人作深坑　　中有智象王
  度彼亦自度　　唐劳作深坑

目连。汝谓尔时象王利根大力者。岂异人乎。勿作是念。即我身是。时五百群象。今五百比丘为调达所坏者是。尔时猎者。调达等五百比丘是。所谓蹇陀达多。迦楼罗提舍三闻陀达多。拘迦梨提婆达多。目连。我常长夜见怖畏众生。施以无怖畏。见苦恼众生施与安乐。贫穷众生施以财物。堕邪道众生示以正道。病痛众生除其病苦。饥饿众生施以饮食。食肉饮血众生以身肉血施与。目连。我随所愿皆作不虚。我许众生不生懈怠。目连。我发阿耨多罗三藐三菩提。于其中间所有诚言终不有异。所作精进懈废休息。我不得阿耨多罗三藐三菩提耶。目连。我随语而行。随行而语

    答难品第七

尔时会中有一比丘。名曰象手。从座而起。偏袒右肩。右膝着地。合掌白佛言。世尊。我从如来闻此难事。身毛为竖涕泪流下。我今欲问一事。世尊自言。我为菩萨时。随语而行。随行而语。世尊。从初愿度一切众生若作是愿。于今所度众生未尽当入涅槃。如来灭后或有人来难诸比丘。汝等大师本愿。当度一切众生。众生未尽而自灭度。若有是难当云何答。佛告象手比丘。若有如是难者。应还问彼。汝以何法为众生。彼人若言阴入界是众生。应还问彼。为阴入界和合是众生。为离散是众生。彼人若言阴入界和合是众生。应还语彼。汝自答已所以者何。和合是众生。阴入界非众生。佛所说法为离散故。不为和合。世尊乐离散行。不乐和合。和合中无众生。彼人若言但阴入界是众生。应还问言。若尔者一切草木瓦石皆是众生。所以者何。汝说阴入界是众生。是中亦有阴入界。彼人答言。是中无心无心数法。故非众生者。应还问彼。若尔者一切众生应是一众生。何以故。如来不说阴入界有异。彼人若言。如来经中说有众生是故有众生。应还语彼。汝自答已。何以故。如来经说离有离无。彼人若言。若尔者无有道果。应还问彼。汝以何为果。彼人若言。我说决定第一义为果。应还问彼。决定第一义中无音声语言。无音声语言中。不得言决定有无。汝说决定第一义为果。是决定第一义中。无众生无众生名字。是故汝说有众生。此语自破。复次象手。如来经说于诸法中无有灭者但灭苦恼。我如是通达诸法实相。随所得法为众生说。为无贪取。为远离。为无戏论。为无作起。象手。若人如是知我法义。是人即能不为有无而起行业。若人不为有无而起行业。是人云何见有众生。见无众生。象手。是名常住诸法实相。是中无有忆想分别。无垢无净。无来无去。无道无道果。无长无短。无方无圆。无形无色。是故说诸法一门。谓是定门。象手。是名见法门。入是见法门。名为能见佛。象手。于意云何。随以何法见佛。是法已灭今灭当灭灭相耶。不也世尊。于意云何。随以何法见佛。是法已生今生当生生相耶。不也世尊。象手。若尔者如来不名为灭。如是世尊。象手。彼人若言所有身相我为。是故言如来灭入涅槃已。不复转还但见身相。不转还故名如来灭。应还问彼。汝说身相成就为如来耶。彼人若言。我说身相成就名为如来。应还答彼。如佛经中。不说身相名为如来。若说身相是如来者。一切瓦石山河草木皆是如来。彼人若言一切瓦石山河草木。无有三十二大人相名如来者。应答彼言。汝说有三十二相名如来者。转轮圣王则是如来。何以故。转轮圣王身有三十二相。彼人若言相入相法知相婆罗门说当作佛。是事为实。应答彼言。若有三十二相即应是佛。而汝自说相师见有三十二相记当得作佛。汝今说佛相。彼人若言。我说佛十力四无所畏。十八不共法。无漏根力觉道。禅定解脱三昧等是为佛相。应答彼言。汝说十力等是佛相者。今应说佛体性。彼人若言佛与是相异耶。应答彼言。汝自言是佛相佛相非佛。彼人若言更有无形无色法是佛十力等为相。应答彼言无形无色法。云何以有形有色为相。又汝若说无形无色法名为佛者。余无形无色法皆可是佛。若是等法。亦是佛者。是十力四无所畏。十八不共法。根力觉道。禅定解脱三昧等。亦应与是为相应。象手。我诸弟子。应当如是降伏痴人。复次象手。我本愿得阿耨多罗三藐三菩提。度脱一切众生。我坐道场。得阿耨多罗三藐三菩提已。不得众生。不得众生名字。我坐道场。但通达十二因缘法。是事有故是事有。是事无故是事无。何事有故有何事。何事无故无何事。所谓无明因缘故有诸行。诸行因缘故有识。识因缘故有名色。名色因缘故有六入。六入因缘故有触。触因缘故有受。受因缘故有爱。爱因缘故有取。取因缘故有有。有因缘故有生。生因缘故有老死。老死因缘故有忧悲苦恼。如是展转但是大苦聚集。无明灭故诸行灭。诸行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死灭。老死灭故忧悲苦恼灭。是中但是大苦聚灭。我于是中生眼智明觉。通达如是无中无后无坏解脱。如来通达是解脱故不得余法。但得众因缘生法。象手。如来是通达诸法。随以如是为众生说。象手。若诸佛生。若诸佛不生。诸法性相常住不异。谓名色不失。不相违背不生不起。象手。我常如是说法。汝等亦应随我意知。我为汝等说如是法。汝等但当勤修行之。象手。大师所应为弟子事事。我尽作已。汝等如所说行。于诸法中当得智明。尔时象手白佛言。世尊。若有人言。如来所说正法灭故谁当示导无说导。故名正法灭。正法灭故名如来灭。如是亦名不度一切众生。佛告象手。若人如是难问。应如是答。佛是一切智人皆知皆见。常待众生可度时节。虽入涅槃犹能有益。又佛今与未来世佛授记作佛。是则佛种相续不绝。一切佛法是一佛法。是故说名如来法。如来法者即是佛法。是故当知如来本行菩萨道时。随语而行随行而语。象手白佛言。希有世尊。如来善能通达推求一切诸法。善能通达一切法故。身口意业智慧为首。皆随智慧。世尊。本行菩萨道时。随语而行随行而语。佛告象手。如是如是。象手。如汝所说。我本行菩萨道时。随语而行随行而语。象手。若人实说谁不错谬。出于世间饶益众生安乐天人。一切大师说正道者。正智解脱无有戏论。到于彼岸度未度者。如来世尊当说我是是为实语者。象手。若人实语。谁是不诳者。知恩报恩者。当说我是是我为实语。若有众生小事于我是事不失。象手。我从初发阿耨多罗三藐三菩提心已来。于其中间心无退转。亦不忆念贪乐声闻辟支佛乘。我当得是法但一发心。欲教弟子求辟支佛。象手。过去久远我时作外道仙人。智慧明利多闻辩才得深法忍。时有五百年少婆罗门。见在居家五欲过患。见出家利出家学道。皆来诣我即为说法。得辟支佛道具六神通。心得自在具如意足。常以神力。飞入城邑聚落乞食。供养于我。我作是念。如是成就大净智人。我则不应受其供养。是诸仙人我教化故得如是法。而我不得为得是法。未证当证故勤行精进。象手。我勤精进为证是法。时净居天来现其身。而告我言。莫贪是智。汝应当得阿耨多罗三藐三菩提。应度无量无边众生。象手。我时闻已不复修道。心得第一欢喜快乐。半月静坐乐悉遍身。象手。菩萨成就四法。诸天开悟得欢喜心。自知当得阿耨多罗三藐三菩提。何等四。一者菩萨自深发阿耨多罗三藐三菩提心。亦教他人令深发心。二者见发大乘人心不生嫉。不作是念。阿耨多罗三藐三菩提唯我当得余不应得。三者众生所行随时而诲。好意共语将护其善。四者常自勤心广求诸法。为他人说无所悭吝。象手。菩萨摩诃萨成就此四法。诸天开悟知当作佛。尔时世尊。欲明了此事。而说偈言

  菩萨以坚心　　住于无上乘
  亦能化众生　　令住于此乘
  本行菩萨时　　常无嫉恚心
  勤行发精进　　喜心转增益
  见诸众生恶　　知时而化喻
  常以慈悲心　　而无有嗔恚
  常勤行求法　　流布与众生
  以法充一切　　如雨普流润
  行是四法者　　诸天所开悟
  汝当得作佛　　勿生疑惑心
  菩萨闻是已　　勇猛发精进
  是事必应实　　我定当作佛
  如是诸菩萨　　以精进及愿
  忆念智与慧　　而自转高大
  若有诸如来　　出现于世间
  是菩萨则有　　如是诸功德
  大人所恭敬　　诸王及臣民
  皆生欢喜心　　知是有道者
  经书章句义　　文颂算数事
  皆悉善通达　　众生中最上
  聪达有智慧　　造事不以力
  但以其策谋　　而能有所成
  摧伏诸战阵　　不以身手力
  但以智慧力　　自然而降伏
  诸王及臣民　　皆叹未曾有
  怜愍众生故　　生在于世间
  诸人佥皆知　　谓与天共语
  何故知如此　　以知我心故
  是菩萨常得　　值遇见诸佛
  往诣咨请问　　能大益众生
  诸佛答问已　　断了所疑惑
  能利诸众生　　皆使得欢喜
  佛示神通力　　受记当作佛
  是故此菩萨　　心得大欢喜
  所爱贵重物　　内外无贪惜
  是故大欢喜　　自知当作佛
  普慈覆一切　　常无嗔恨心
  是故大欢喜　　自知当作佛
  诸佛所称赞　　已得深妙忍
  是故大欢喜　　自知当作佛
  不依止诸法　　知法不可依
  得如是智慧　　身能飞虚空
  其心不在内　　亦复不在外
  出过一切想　　故得无上忍
  长夜以慈悲　　普念诸众生
  以是福德故　　得见无量佛
  一切身皆是　　佛身无差别
  能得如是忍　　以法自增长
  发心菩提者　　谁不随而学
  坚住于正法　　得如是功德
  是故求道者　　常应勤求法
  以法求自利　　增益于菩提

    富楼那品第八

尔时富楼那弥多罗尼子白佛言。希有世尊。世尊过去世行菩萨道时。善能坚住种种善法。佛言。如是如是。富楼那。我长夜行菩萨道时。坚住善法。尔时世尊。欲明了此事。而说偈言

  求法能得法　　是为佛道本
  常勤修习法　　远离于非法
  常行于正道　　远离诸邪道
  常修习诸佛　　所可亲近道
  是则离诸难　　能得无难处
  得无难处已　　精进必不虚
  在二最尊贵　　诸形色中上
  眷属具成就　　于诸一切胜
  坚心常安住　　戒品忍辱品
  亦住精进品　　增长于禅智
  于诸众生中　　常能为上首
  功德中亦胜　　了义无所畏

尔时富楼那白佛言。世尊。如是妙法谁当不学。但念我等本昔懈怠。不望佛智。不自信得如是佛慧。以声闻乘而自出度。世尊。我从今日示教利喜诸菩萨众令住佛法。何以故。诸佛世尊行难行者。世尊本行菩萨道时。为众生故常行如是甚难大事。如是事者一切阿罗汉辟支佛尚无。况余众生。世尊。如是甚难大事。唯诸菩萨摩诃萨等。怜愍饶益一切众生故。行菩萨道时。有如是等无量无边阿僧祇甚难大事。世尊。诸菩萨行如是甚难大事。得阿耨多罗三藐三菩提已。能转法轮度脱苦恼众生。佛言。如是如是。富楼那。如汝所说。诸菩萨摩诃萨。深发阿耨多罗三藐三菩提心。为一切众生求利安乐。于一切众生有大慈悲。为一切众生故。行菩萨道时。有如是等无量无边阿僧祇。甚深极难大愿大事。佛说经已。慧命富楼那。时会四众。天人龙神乾闼婆阿修罗等。皆大欢喜。信受佛语

大宝积经卷第七十九大宝积经卷第八十

        隋三藏法师阇那崛多译

    护国菩萨会第一十八之一

如是我闻。一时婆伽婆在王舍城耆阇崛山中。与大比丘众千二百五十人俱。菩萨摩诃萨五千人。一切皆得无碍辩才。大忍成就降伏魔怨。近于佛智一生补处。皆得陀罗尼无边辩才。力无所畏自在神通。乃至一切功德皆悉具足。其名曰普贤菩萨。普眼菩萨。普明菩萨。普光菩萨。圆光菩萨。上意菩萨。无边意菩萨。广意菩萨。无尽意菩萨。持地菩萨。持世菩萨。益意菩萨。咒手菩萨。文殊师利等六十不思议菩萨。贤护等十六菩萨。如是等菩萨摩诃萨五千人俱

复有娑婆世界主梵天王。及释提桓因。护世四王。功德天子。正意天子。一切天王。一切龙王。一切紧那罗王。一切乾闼婆王。一切夜叉王。一切阿修罗王。一切迦楼罗王。如是等王。

各各皆与百千眷属俱悉来集会

尔时世尊。坐功德藏师子宝座。于大众中色象显现如须弥山。普照世间如日天子。显现世界如月天子。其德寂静如梵天王。威德难瞻如天帝释。七菩提分皆悉具足如转轮王。宣说无相空无愿法。心无所畏如师子王。身光照耀如大火聚。又放光明犹如诸天。最胜无上摩尼宝珠。普照三千大千世界。以大梵音。令诸众生悉得欢喜。于一切法解其深义。于大众中而为说法。初中后善其义微妙。具足无杂清净梵行。尔时众中。有一菩萨摩诃萨名曰喜王。在众中坐睹见如来。坐师子座放大光明。如百千日普照一切。令天人光隐蔽不现。见是事已踊跃欢喜。遍满身心不能自胜。即从座起。合掌向佛。以偈赞曰

  世尊覆蔽此大众　　天龙修罗乾闼婆
  菩萨声闻无威德　　普照一切如金山
  犹如须弥诸天俱　　处于大海佛亦然
  世尊住于慈悲海　　放大光明百千种
  住于梵行犹梵王　　光明威德过诸天
  安住禅定解脱中　　照耀世间胜众生
  犹如帝释在天众　　色象光明最为胜
  佛过世间亦复然　　诸相庄严功德具
  犹如轮王典四域　　照耀世间说法时
  令诸众生入圣道　　世尊显现慈悲意
  光明障蔽火摩尼　　犹如秋日行虚空
  佛比千日最为胜　　佛日普照于世间
  如夜闇时秋满月　　佛光清净亦复然
  面部圆满犹如月　　覆翳一切天人光
  犹如山顶夜火聚　　清净显现无边界
  能灭一切无明闇　　世尊智慧光普照
  佛音遍满山谷中　　能伏外道犹师子
  宣说无我空无愿　　令诸外道皆恐怖
  威光犹如摩尼王　　映夺一切摩尼光
  如来躯体真金色　　普照世间胜诸光
  如来世间无与等　　况复有胜世尊者
  福智精进方便等　　一切功德无能过
  救护世间大丈夫　　我今睹见功德海
  令我欢喜生尊重　　是故顶礼世尊足
  我已赞叹胜调御　　功德圆满世间灯
  我今所有诸功德　　令诸众生证菩提

尔时喜王菩萨摩诃萨。偈赞佛已合十指掌。谛观佛身目不暂舍。观察法界甚深难解难行难入。不可思惟。难知寂静微细之法。不可思量诸佛境界。内心观察周遍法界。观如来智世尊境界无有等等。作是观已。入如来智不思议境方便行中。诸佛世尊同一法性而无有异。思惟观察诸佛世尊。无所染着犹如虚空。作是观时。入于实证真如体性。一切诸法性皆如是。生如是信。爱乐诸佛如来无碍解脱之门。知常乐我净。知佛之身。作是思惟。如来之身遍一切刹。现众生前。诸佛功德于无量劫说不可尽。喜王菩萨作是念已。默然而住观于法界。尔时有一慧命菩萨比丘。名曰护国。在舍婆提城。受夏安居三月过已。执持衣钵。共诸年少初学比丘。游行诸国。至王舍城耆阇崛山。尔时慧命护国菩萨。到世尊前。顶礼佛足。右绕三匝。却住一面。合掌向佛。以偈赞曰

  敬礼最胜放光者　　敬礼意如虚空者
  敬礼能决他疑网　　敬礼超过三界尊
  十方无数刹土中　　闻赞如来功德事
  彼国所有诸菩萨　　欢喜皆来供养佛
  菩萨如法供养已　　一心听佛所说法
  闻法欢喜还本土　　赞叹如来诸功德
  如来积行为众生　　经于无量无边劫
  为他求于菩提时　　其心初无有疲惓
  世尊行檀持戒坚　　羼提精进游诸禅
  智慧方便皆具足　　是故稽首大圣尊
  如来具足四如意　　诸根诸力诸解脱
  又知众生心意识　　是故顶礼大智海
  知诸众生心所念　　身口所作善恶业
  亦知解脱方便等　　世尊知已为说法
  贪欲恚痴迷众生　　能令入于三恶道
  如来知已教断除　　令彼众生生善趣
  过去一切诸世尊　　天人魔梵所恭敬
  未来功德具足者　　世尊皆悉了了知
  诸佛净土所生处　　菩萨声闻及缘觉
  天人眷属与种姓　　寿命长短皆悉知
  灭度已后正法住　　供养舍利起庙塔
  受法藏人若干种　　调御丈夫皆悉知
  十力智慧无障碍　　悉能了达三世事
  入于一切法智中　　故我稽首大智海
  佛无等等况有过　　诸相庄严如来身
  譬如星宿在虚空　　是故我礼胜丈夫
  如来妙色无与等　　映蔽大会天人光
  释梵威德在佛边　　一切隐没皆不现
  身如金山无垢秽　　绀发柔软而右旋
  佛顶显现如须弥　　无量功德光明聚
  眉间毫相放大光　　无量无边无有数
  佛眼修广如青莲　　以大慈悲视众生
  如秋满月行虚空　　如来面部亦复尔
  众生观者无厌足　　是故我礼面中王
  犹如师子鹅孔雀　　安行徐步如象王
  游止震动于大地　　敬礼十力大苦行
  手指佣纤无不爱　　网缦珊瑚赤铜色
  臂肘修长立过膝　　敬礼如来金色身
  足下轮相罗网具　　行时足迹犹采画
  若有顶礼世尊者　　佛光照耀得生天
  法王具足七财宝　　常以法施调伏心
  教照众生以法行　　我今顶礼于法王
  慈悲为铠念为刀　　持戒为弓智慧箭
  以此能破烦恼怨　　生死有爱增长种
  自度度他亿众生　　解脱一切诸系缚
  能示无畏安隐路　　令其得至常乐道
  行此乘者断生死　　无有恩爱别离苦
  得至微妙无为处　　慈心说法为众生
  赞叹最胜世尊已　　一切法中自在者
  以此赞叹胜善根　　令诸众生证菩提

尔时护国菩萨偈赞佛已。合十指掌。而白佛言。世尊。我心有疑。欲问如来。唯愿听许。尔时佛告护国菩萨比丘。恣汝所问。我当为汝分别解说断汝所疑令汝欢喜。尔时护国。既蒙听许。即白佛言。菩萨摩诃萨修行何等。于一切法增长功德。到究竟处而得自在。证捷疾智。得决定智。于法明了入一切智。教化众生能决疑网。解一切智。以巧方便济度众生。如言而行常宣真实。得念佛三昧。善能咨问一切深义。闻已能持。速疾证得一切种智。尔时护国菩萨。欲重宣此义。而说偈言

  菩萨行行常决定　　真实决定从何生
  智慧大海分别处　　愿胜丈夫为我说
  佛身微妙犹真金　　人天中胜大福聚
  慈愍我等大归依　　清净之行为我说
  云何而得无尽利　　觉道总持甘露生
  云何清净智慧海　　而断众生诸疑惑
  无量亿劫在生死　　而无疲倦悔厌心
  观诸众生逼切苦　　常为众生作利益
  清净刹土佛眷属　　最胜国土及寿命
  一切众事微妙处　　愿说清净菩提行
  降伏众魔破邪见　　枯竭爱海得解脱
  法行相续无绝断　　无上最胜为我说
  色力财宝及四辩　　哀愍软言令众喜
  慈悲云雨润一切　　愿为我说佛境界
  愿出迦陵频伽声　　大梵雷音破邪见
  众会渴仰为法来　　愿施解脱甘露浆
  我今欲成微妙道　　若不乐法则不请
  闻法时至恭敬待　　唯愿为说大法宝
  世尊我愿成菩提　　如来深知我志乐
  非为恼乱故问佛　　善哉愿说最胜行

尔时世尊。告护国菩萨言。善哉护国。汝今乃能问如是义。利益多人安乐天人。亦大饶益于未来世。摄诸菩萨。谛听谛受。当为汝说。护国白言。善哉世尊。愿为我说。佛言护国。菩萨有四法。能成如上清净之事。何等为四。一者真实心无谄曲。二者于诸众生行于平等。三者心念行空。四者如言而行。护国当知。如此四种能得菩萨清净之法。尔时世尊。欲重宣此义。而说偈曰

  若有菩萨心无谄　　而常不退菩提道
  亦无佷戾贡高意　　彼则名为无边智
  见诸众生无救护　　生老病死所逼切
  发心欲度于有海　　能为一切作法船
  调伏平等于众生　　观诸众生如一子
  皆当救度令解脱　　最胜丈夫发此心
  行住坐卧念空门　　寿者我想皆悉无
  一切世间都如幻　　众生愚痴所迷惑
  大智菩萨所言说　　依之行行无违失
  调伏寂静离诸过　　能求菩提名佛子

佛说偈已。告护国菩萨言。善男子。菩萨摩诃萨。复有四种无畏之法。何等为四。一者所谓得陀罗尼。二者值善知识。三者得深法忍。四者戒行清净。是名菩萨四无畏法。尔时世尊。欲重宣此义。而说偈言

  菩萨大名称　　由得总持故
  受持最妙法　　如来所宣说
  恒常无忘失　　增长于智慧
  彼等智无碍　　超过一切法
  常遇善知识　　增于助道法
  常说于菩提　　诸佛所行处
  恶知识如火　　畏烧故远离
  若闻空相法　　勇猛坚其心
  菩萨离我人　　一切诸见等
  持戒无缺漏　　其心调寂静
  教化诸众生　　安住于佛戒

佛说偈已。复告护国。诸菩萨众行圆满到究竟处。有四功德令心欢喜。何等为四。一者菩萨见佛而生欢喜。二者闻正法而生欢喜。三者舍一切而生欢喜。四者顺法忍而生欢喜。是为四法生于欢喜。尔时世尊。重说偈言

  菩萨所生处　　常见最胜人
  威光遍一切　　照曜于世间
  见已心恭敬　　如天奉帝释
  为度众生故　　求于菩提时
  从佛闻正法　　不怖而欢喜
  一心信敬已　　随顺于佛教
  闻于随顺法　　得忍心无疑
  诸法无众生　　我想亦复尔
  常观如是已　　舍相生欢喜
  既不取我相　　见乞心踊跃
  城邑与大地　　妻子及寿命
  一切布施时　　其心初无悔

佛说偈已。复告护国。菩萨作如是言。有四种法应当弃舍。何等为四。一者菩萨弃舍居家。二者既出家已不贪利养。三者离诸檀越。四者不惜身命。是为四法应当弃舍。尔时世尊。重说偈言

  菩萨见家过　　舍之而出家
  游止于山林　　无人寂静处
  远离男与女　　眷属及大众
  单己无等侣　　譬如犀一角
  专意求净道　　得失心无忧
  少欲及知足　　离谄除憍慢
  精进为众生　　布施调伏心
  苦行修禅定　　一心求佛智
  不惜身与命　　远离爱眷属
  坚心求菩提　　其志犹金刚
  若人来割截　　无有恚恨想
  勇猛心增长　　求于一切智

佛说偈已。复告护国。菩萨有四种无悔之法。何等为四。一者不破禁戒无悔之法。二者住阿兰若处无悔之法。三者行四圣种无悔之法。四者多闻无悔之法。是为四种无悔之法。尔时世尊。重说偈言

  持戒净无垢　　犹如摩尼珠
  不生贡高心　　言我能持戒
  复以此戒善　　转教于多人
  常怀如是望　　成就于佛戒
  彼等住空闲　　清净兰若处
  亦不生我想　　及以寿者想
  观察男女色　　犹如于草木
  不生男女想　　及以吾我想
  彼住四圣种　　无懈怠谄曲
  至心恒修行　　远离于放逸
  求多闻功德　　精勤常修习
  愿成一切智　　最上功德处
  众生处牢狱　　无有救护者
  轮转于生死　　求财以自给
  我当求法船　　济度彼生死
  烦恼海众生　　令其至彼岸
  众生无归依　　亦无救护者
  众生在有为　　无能令其出
  我当作导师　　救之令解脱
  是故我发心　　求于菩提道

佛说偈已。复告护国。菩萨有四种调伏之行。应当行之。何等为四。一者愿生善处常值诸佛。二者供养师长而不求报。三者常乐空闲弃舍利养。四者得无碍辩头陀忍法。是为四种调伏之法。尔时世尊。重说偈言

  菩萨勇猛乐山林　　常不从人求利养
  恒得深智无碍辩　　善能通达诸法相
  常当供养诸师长　　随顺师教无违背
  随所生处值诸佛　　供养恭敬求菩提
  常生胜处名高远　　若生天上天中尊
  又得成就菩提道　　教诸众生行十善
  念佛功德常欢喜　　我亦不久成佛道
  既成正觉功德满　　度脱众生生死苦

佛说偈已。复告护国。菩萨有四种法净菩萨行。何等为四。一者行菩提时心无嗔恨。二者弃舍眷属宫殿财宝乐处山林。亦不称说己之功德。三者虽行布施不求果报。四者精勤乐法不见师过。是为四法净菩提行。尔时世尊。重说偈言

  其心清净无怨恨　　亦不求人之过罪
  自不谄曲无染着　　行于大道求菩提
  深观居家是苦本　　亲近恶友无正念
  是故弃舍行出家　　处于山林求解脱
  游行空闲寂静乐　　永断眷属恩爱念
  不惜于身及寿命　　独步无畏犹师子
  乞食支身常知足　　犹如飞禽无储积
  不乐生天及人中　　唯求无上菩提道
  独行无侣唯一己　　恒不恐怖如师子
  畏诸烦恼如野兽　　若得利养心不喜
  观诸众生恒放逸　　慈悲誓愿为破之
  我为救护诸众生　　常当炽然勤精进
  凡所出言恒哀愍　　于憎爱人常含笑
  不着一切亦如风　　唯当求于丈夫行
  常乐行于空无相　　观有为法如幻化
  调伏诸根意广大　　行住常乐甘露法
  常依佛教行大道　　恒当清净于内心
  求陀罗尼及辩才　　荷负诸苦求菩提
  菩萨常观如是行　　见前利益生欢喜
  若不爱乐于菩提　　是人无恶而不造

佛说偈已。复告护国。菩萨有四种堕落之法。何等为四。一者不恭敬他。二者背恩谄曲。三者多求利养名闻。四者诈善扬德。是为四种堕落之法。尔时世尊。重说偈言

  彼于父母及师长　　常怀憍慢不恭敬
  违背恩养心谄曲　　诸根散乱多愚痴
  常念利养不休息　　谄曲诈现精进相
  自谓持戒及苦行　　一切无有如己者
  恶口粗言喜斗诤　　常求人过不休息
  彼恒违离沙门行　　营理田作及贩卖
  未来世中诸比丘　　弃舍功德及戒行
  以怀嫉妒斗诤故　　覆灭损坏我正法
  彼去菩提甚悬远　　亦复远离七圣财
  违背解脱八正路　　流转五道生死中

尔时世尊。说此偈已。复告护国。菩萨有四种障道之法。何等为四。一者懈怠。二者不信。三者我慢。四者嗔恚。是为四种障道之法。尔时世尊。重说偈言

  懈怠不信闇钝心　　常为我慢及嗔恚
  见有忍辱诸比丘　　驱逐傧出于塔寺
  若得利养心欢喜　　各言我是常住者
  恒作方便求人短　　何人有过我治罚
  如是等人去法远　　憎嫉功德坠三涂
  厌恶诸佛微妙法　　是人当入猛火中
  彼人造恶不休息　　必当具受苦中苦
  是故汝等求菩提　　无令后悔堕恶道
  无量亿劫佛乃出　　为诸众生作利益
  汝等既得善趣身　　应舍放逸求解脱

尔时世尊。说此偈已。复告护国。菩萨须舍四种福伽罗。不得亲近。何等为四。一者不得亲近恶知识。二者不得亲近执见之人。三者不得亲近谤法之人。四者不得亲近贪利养人。是谓四种之人不得亲近。尔时世尊。重说偈言

  能舍恶知识　　亲近善知识
  菩提道增长　　犹月渐圆满
  远离执见人　　及舍我寿等
  为求佛道故　　弃之如毒器
  诽谤于佛法　　寂静甘露味
  若欲求菩提　　应避如粪秽
  远离贪利养　　亦舍恶行人
  是等不应近　　犹如避火坑
  若欲降众魔　　转无上法轮
  欲求第一利　　速远恶知识
  舍爱及憎恶　　利誉亦嫉妒
  若求无上道　　常修于佛智

尔时世尊说此偈已。复告护国。菩萨有四种法受未来苦。何等为四。一者轻慢有智之人。二者常怀嫉妒之心。三者于一切法无有信心。四者于净智法常疑无忍而求利养。是谓四法受未来苦。尔时世尊重说偈言

  侍佛之人有智者　　一切天人应供养
  而反贡高怀憍慢　　是故彼受无边苦
  于净法中心无忍　　所求利养皆非法
  常怀憍慢而贡高　　见有智者不恭敬
  于佛法中无信解　　于贤圣众亦复然
  此人常游三恶道　　若在人中多愚痴
  彼舍人间寿命已　　在大地狱受剧苦
  若此劫尽生余方　　畜生饿鬼亦复然
  若欲求作世间灯　　能尽诸苦胜丈夫
  常当远离三涂业　　修诸功德成菩提

尔时世尊说此偈已。复告护国。菩萨有四系缚。何等为四。一者轻慢于他。是菩萨系缚。二者于世俗定其心乐着不求究竟。是菩萨系缚。三者不守自心智慧未成而行放逸。是菩萨系缚。四者为求利养而入他家。是菩萨系缚。护国。当知是谓菩萨四种系缚。尔时世尊重说偈言

  恒常轻慢他　　乐住世间善
  贪着诸见缠　　如象没深泥
  乐入白衣家　　常怀于放逸
  暗钝无智慧　　此行名系缚
  欲断诸有苦　　远离老病死
  当舍于憍慢　　常行菩萨道
  受于无边苦　　弃舍诸乐事
  亦离于憎爱　　成佛无染着

  汝等常应行六度　　诸地诸智诸力等
  一切功德若成就　　常得解脱死罗网
  我于往昔无量劫　　为诸众生求菩提
  常行布施以调伏　　舍离恩爱住正道
  恒不舍离阿兰若　　苦行羸瘦求菩提
  炽然精进无懈怠　　求于最胜丈夫智
  见诸众生在有狱　　轮转生死五道中
  慈念一切起大悲　　是故求于菩提道
  舍于爱子及妻妾　　亦舍资财七宝等
  寿命国土及大地　　为求菩提佛智故
  我昔处于胜山林　　时作仙人名忍辱
  为王歌利截鼻耳　　血变为乳无恚恨
  往昔亦曾作睒子　　慈孝供养于二亲
  时被迦夷箭所中　　尔时亦无嗔恚想
  不惜身命投高岩　　为求诸佛善言故
  尔时亦无身命想　　为成菩提大事故
  往昔慈愍于饥兽　　身肉充济于八虎
  尔时空中诸天众　　赞言善哉大丈夫
  往昔乐行大布施　　曾作净行婆罗门
  怜愍众生贫苦故　　入海求于如意珠
  还为海神所盗窃　　我时勇猛抒大海
  寻时得珠还阎浮　　用济贫苦诸群生
  亦曾作王名苏摩　　乃至失命不妄语
  诸王因我皆解脱　　名闻广流于十方
  我昔曾见贫穷人　　时我为王以身施
  令彼巨富多财宝　　是故号我一切施
  我昔曾为尸毗王　　有鸽恐怖来投我
  我以身肉代彼命　　令彼得离于恐怖
  我昔作王名师子　　身遇重病医授药
  时有病人乞此药　　我不爱命先施与
  我昔修行为众生　　曾作王子苏达拏
  时有人来乞妻子　　我不爱惜尽施与
  曾作菩萨名严炽　　为化才德国王故
  经于八万四千年　　勤行精进始受化
  亦作王子名净威　　于佛塔前自然身
  恭敬供养于十方　　无上最胜两足尊
  曾作国王名月光　　时有梵志名可畏
  从我求索于身首　　我无爱惜以头施
  又作国王名福德　　于诸聚落街巷中
  积满医药及饮食　　拟施一切诸众生
  曾作大王名日净　　端正伎女有千人
  七宝璎珞庄严体　　心不爱惜用布施
  又作国王名宝髻　　七宝天冠庄严首
  最妙花香而严饰　　亦用布施一切人
  又作国王名知足　　手脚柔软如兜罗
  色妙清净如莲花　　亦以布施众生等
  又作商主名师子　　有罗刹女欲害人
  能以方便驱遣彼　　安置商人于洲渚
  又作商主名善眼　　将众五百采七宝
  有诸罗刹像美女　　亦令商人脱彼难
  曾作王子名福焰　　妻妾妓女有数亿
  端正殊妙犹天女　　舍之出家无爱恋
  又作商主名金色　　时有如来号无垢
  于彼佛前然十指　　供养最胜两足尊
  又作国王号花眼　　一切瞻仰心无厌
  如是妙眼用布施　　怜愍一切众生故
  又作菩萨名多发　　见有妇人丧其夫
  昼夜思念不能舍　　缠绵裸形心发狂
  菩萨尔时生慈悲　　化作死女言丧妻
  渐渐教化彼狂妇　　还令醒悟得本心
  又作菩萨名普瞻　　见有一人病羸困
  我于尔时生慈悲　　以己血肉用施彼
  又作国王名花敷　　见有一人病困笃
  我于彼人起慈心　　破于骨髓疗彼病
  又作国王名成利　　见有一人甚贫穷
  施以一切诸财宝　　及舍爱命心无恋
  又作国王名信幢　　两手柔软具轮相
  时有人来乞我手　　为求菩提用施彼
  又作国王名普现　　有四天下多财宝
  丰乐安隐男女盛　　为求菩提用布施
  又作王女名智意　　其身白净甚柔软
  慈悲欢喜割股肉　　及以血施心无悔
  又作女人名银色　　金色城中有妇女
  新产饥渴欲食子　　我割两乳用施之
  又作国王名闻德　　多饶最胜诸璎珞
  金银七宝诸车乘　　世间难舍皆能施
  又作王子名知恩　　有人堕海名无恩
  无恩为宝坏我眼　　我于尔时心不恨
  又念过去作战夫　　在大阵中心无杀
  宁自丧身不害人　　乃至蚁子无杀想
  又念过去曾作雉　　恭敬供养于尊者
  同类老小皆给恤　　尔时亦无傲慢心
  又念过去作猿猴　　在山逢值于猎师
  诸猕猴众皆归我　　我怀慈心救彼命
  又念过去作象王　　时被国王所执缚
  我念父母盲无目　　分舍身命饥不餐
  又念过去受罴身　　有人失道我救养
  彼将猎师反害我　　我于尔时亦无恨
  又念过去作象王　　时被猎者箭所著
  我求菩提功德故　　以牙奉施于彼人
  又念过去作雉身　　在于旷野缺林里
  彼林为火所焚燎　　时我救林天雨花
  我昔曾作九色鹿　　饮水食草恒河边
  其水深广漂流急　　有人堕河我救之
  其人贪财受王募　　多将兵众来害我
  我求菩提行慈悲　　于彼人所亦无恨
  又念过去曾作龟　　济度商人令过海
  五百商人食我肉　　我时亦无嗔恨想
  我念过去行菩提　　曾作鱼身游水里
  怜愍一切舍身命　　百千众生来食我
  我见百千众生病　　化身为药犹如山
  欲令众生除病苦　　变作虫身名为月
  又念曾作师子王　　巨身大力仍有慈
  时被毒箭所中射　　于彼人所起慈愍
  又念过去作马王　　身色白净犹珂雪
  常在大海高山顶　　度诸商人罗刹难
  又念过去求菩提　　曾作国王名居邪
  见于五欲多诸患　　不随淫女谄诳言
  又念过去曾作兔　　常化诸兔以善事
  时与仙人同居处　　舍身投火救仙饥
  又念过去作鹦鹉　　常处多饶花果林
  报枯树恩不舍离　　释变枯树生花果
  又念曾作猕猴王　　见诸猕猴被龙害
  遂教猕猴竹筒饮　　猕猴悉免诸龙难
  又复重念作鹦鹉　　取人稻谷养二亲
  稻主执我生嗔恚　　云何盗我熟苗稼
  我即报言汝种时　　云施一切众生等
  我今取以养父母　　是故不名为偷盗
  稻主即时生欢喜　　我是禽兽汝为人
  善哉鹦鹉有智慧　　能怀孝养供父母
  我从今去以稻施　　任汝供养于二亲
  如是过去无量事　　无有苦行而不作
  未曾有怀疲倦意　　以求无上清净道
  若内若外所有物　　无有一种而不起
  持戒忍辱精进禅　　无量方便及智慧
  皮肉骨髓及以血　　以施一切诸众生
  往昔住于山林中　　勇猛精进身枯竭
  为求佛说大小乘　　教示众生令入道
  常乐在于头陀所　　曾所修行无弃舍
  如是一切难苦行　　我于往昔无不行
  我说未来众生等　　闻我此等生轻笑
  不信受行一句偈　　反更毁谤如是法
  斯由贪着衣食等　　心常觉观多睡眠
  谄曲毁法无惭愧　　破坏正教无功德
  闻此微妙寂静法　　各共相诤非佛语
  我师多闻犹如海　　能讲能说最第一
  彼亦不行如此法　　决定非是佛所说
  次前亦有耆老等　　从昔已来诸名德
  亦未受行如是法　　汝等勿求虚妄事
  于中无我无寿命　　亦不说有富伽罗
  唐自疲劳无福祐　　徒修精勤苦行等
  既言有法名大乘　　云何复言空无我
  以无众生无作者　　是故于中不须求
  此等文句假设作　　亦如外道邪意说
  如来不说如是事　　呵骂毁辱诸比丘
  此等不善无羞耻　　姧伪欺诳无不作
  来世于我教法中　　而作形相诸比丘
  内怀嫉妒慢覆心　　手足扰动失威仪
  袈裟恒常垂两角　　身被法服常在村
  游于俗间恒酒醉　　身着法衣亲俗人
  弃舍正教功德聚　　乐为俗人通信使
  畜养牛马诸畜等　　奴婢作人不净物
  种莳田园恒乱心　　心乐诸恶无善行
  亦不亲近善知识　　口恒不择于语言
  身中恶行无不作　　贪取佛塔众僧物
  何况己物而肯施　　见他持戒诸比丘
  谤毁言非真梵行　　不护禁戒无威德
  乐处俗家侵他妻　　白衣畜妇犹怀愧
  彼恶比丘贪转甚　　畜养妻子求不厌
  与诸俗人无有别　　若有檀越请供养
  施与衣食汤药等　　受他信施无善念
  唯增贪欲侵彼妻　　心常系念女色边
  随顺烦恼无圣行　　方便诱诳诸妇女
  教化俗人令断欲　　谓贪欲者堕恶道
  地狱及以畜生等　　然于自身不依教
  云何传欲教化他　　此人三业不如法
  所有眷属亦复尔　　昼夜聚语无休息
  唯论五欲诸世事　　受畜门徒唯驱使
  终无教诲以善道　　多受弟子自围绕
  显己德大招名利　　外现异相诈慈悲
  摄诸徒众不求利　　门徒眷属多疾患
  干枯病癞癣疮等　　唯是杂类下人辈
  终不教示圣种等　　戒闻定慧悉弃舍
  不行比丘所作事　　非道非俗无所名
  犹如烂坏腐朽木　　于诸律仪生轻贱
  布萨毗尼亦复然　　自在游行背师教
  唐突如象醉无钩　　或时诈现在山林
  心常念于聚落事　　三毒烦恼恒炽然
  暂时不能寂静住　　忘失诸佛教诫事
  及以头陀功德等　　我慢贡高满身中
  堕于可畏阿鼻狱　　昼夜恒论国土事
  亦复论说于贼盗　　身心专营亲缘事
  舍离禅定及智慧　　设有所作乐粗事
  心存自安故营造　　假使营理僧伽蓝
  贪着房舍眉恒蹴　　自身口意不调柔
  徒众相学亦复尔　　彼恶比丘设造寺
  专为己身及眷属　　若有比丘顺从彼
  即便安置摄受住　　若有持戒诸大德
  方便善能说法利　　自能调伏亦调他
  如是比丘终不受　　此房现今我受用
  余房是我弟子住　　自外己属诸同学
  汝去此中无处停　　现今所有床铺者
  各以付他有所属　　更无剩长可相容
  亦无衣食汝须去　　暂时所须尚不与
  况借房舍及诸物　　如是不行僧次法
  彼恶比丘如俗人　　多畜钱财眷属等
  我诸弟子如法者　　处处驱遣不听住
  彼时忆念我所说　　各怀悲伤入山林
  呜呼我师微妙法　　不久悉灭不复现
  现有比丘求多利　　身无法行疾有德
  设有具戒功德者　　为彼恶贱无利养
  皆自伤叹去城邑　　常住空静山林中
  痴慢贡高诸恶行　　常行斗诤两舌者
  欺诳世人得利养　　自谓与圣等无异
  我此法教功德藏　　具足一切妙功德
  来世破坏不复现　　以无持戒我慢故
  又如宝藏为他坏　　又如花池枯干竭
  犹如宝舆自摧折　　我法未来亦复然
  彼恶比丘难调伏　　灭我法行无有余
  未来如是恶世中　　破坏我法甚可畏
  如是乐喜诸恶者　　远离天人及善行
  从于此身舍命已　　堕于地狱畜生中
  于彼无量亿千岁　　具受一切诸苦恼
  于后假使得人身　　多苦秽恶恒不净
  若盲若聋若眼瞎　　恒常身体怀疾病
  颜色丑恶见不喜　　常怀畏惧承事他
  难得心意无亲爱　　所说语言无信受
  若有如是恶行者　　在所呵责驱出众
  彼人多饶诸病苦　　常被杖石打驱逐
  常为饥渴恼其身　　他人见者常轻贱
  若闻如是众多苦　　应舍诸恶心调伏
  于诸众生行善行　　勿令于后生悔心
  若有爱敬佛世尊　　圣众持戒头陀法
  汝应勤求如是行　　应舍眷属及名利
  此皆颠倒如幻化　　应观有为如泡梦
  恩爱合会必别离　　一切有为不久住
  莫舍正勤诸力等　　勤求诸地波罗蜜
  乃至未觉妙菩提　　常应修集一切行

尔时佛复告护国菩萨言。善男子。于未来世。行大乘菩萨富伽罗等有如是等过患。应自远离自不勤求。而与此人共相习近。不勤正行自行谄曲。亲近行谄曲者。自无智慧随顺无智慧者。贪求世利恒无厌足。悭惜他家嫉妒胜己。谄曲诈伪无羞无惭。诈现圣相自尊自重。徒众眷属各相誉赞以求名利。求利养故常入聚落。既不怜愍一切众生。亦不为教化诸众生故。常自说言我有平等。恒作是念。云何他知我是众生真善知识。知我多闻。实于佛法无恭敬心无求法心。犹如破器无所复用。如懈怠人无有成办。相求过失行于方便。无智懈怠唯恶觉观。各各论说破法等事。固执恶心至死不悔。多集悭贪。所畜眷属亦学是师。以自围绕在我法中。如是行者凡所作事。不问明哲不求佛法。以无精进行故生贫穷家。从贫穷家而得出家。于我教中得少利养。心生欢喜而无惭愧。彼等尚无忏悔之心。何能自觉胜智。彼等弃舍诸佛功德。而取现在名利。以得现在利故。自言我是沙门也。护国。我于如是富伽罗。如是人等。我不说其有随顺俗忍。何况能有诸佛大智。彼等远于人天道。况成佛道。护国。如是等人。我说有八种法障碍于菩提。何等为八。一者当生三恶道。二者当生边地下贱。三者当生贫穷。四者颜色不正。五者愚痴无智。六者常与恶知识相会。七者多诸病患。八者得大恶病以取命终。护国。此等八法是障碍菩提。所以者何。护国。我亦不说但以有言说而得菩提。我亦不说诈现圣者有清净行也。我亦不说有谄曲者有菩提行也。我亦不说多贪利养者有供养佛行也。我亦不说有我慢者有清净般若行也。我亦不说无智慧者能决他疑行也。我亦不说有妒嫉者有净心行也。我亦不说不精进者能得诸陀罗尼行也。我亦不说不乐功德者而得善道行也。我亦不说悭惜他家者有身心清净行也。我亦不说诈现威仪者能值遇佛会也。我亦不说乐在俗家者有清净口业行也。我亦不说不恭敬者有心清净行也。我亦不说有不知足者有乐法行也。我亦不说惜身命者有求法行也。护国。我虽呵骂毁呰六师。然彼诸外道在我法外。入我法中作诸恶业。我若毁辱过患倍彼六师。何以故。彼等但为自口言。我是比丘。而以无行欺诳一切天人世间故。尔时世尊。欲重宣此义。而说偈言

  威仪浊乱无恭敬　　唯增我慢贪名誉
  烦恼覆蔽心迷醉　　此等远离妙菩提
  耽著名利及懈怠　　懈怠增长失正念
  若无正念失持戒　　若无持戒失善道
  彼人生在贫穷家　　得出家已着利养
  如人弃舍于真金　　担负草秽以为宝
  为求名利住山林　　至彼更求诸等侣
  弃舍神通辩才智　　求现名利及眷属
  若彼命终堕恶道　　或生贫穷下贱中
  懈怠恶色无威德　　斯等皆由我慢受
  彼既远离诸善行　　亦由放逸失正念
  在于长远大恶道　　亿千劫中未能脱
  若求名利得菩提　　提婆达多应是佛
  毗岚猛风吹坏物　　懈怠无戒亦复然
  自无善行贪女色　　戒行不净失功德
  于我法中无所用　　无智犹如朽烂木
  若为菩提求佛法　　何得不依解脱行
  犹如黐胶缚猕猴　　我慢求道亦复然
  我昔为求一句法　　弃舍身命为菩提
  彼人懈怠舍我教　　如是无利于我法
  我昔为求善教故　　投身高崖及火聚
  我得闻已如法行　　弃舍一切爱憎等
  彼人闻我功德法　　曾不爱乐于一句
  无法云何得菩提　　犹如盲前说道路

大宝积经卷第八十大宝积经卷第八十一

        隋三藏法师阇那崛多译

    护国菩萨会第十八之二

尔时佛复告护国言。护国。我念往昔过无量阿僧祇劫。复过阿僧祇。不可称量。不可思惟。无有譬喻。不可计算。不可得说。是时有佛出世。名曰成利慧多陀阿伽度阿罗诃三藐三佛陀明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时有王名曰焰意。护国。彼焰意王治化之时。此阎浮提纵广一万六千由旬。护国。彼时此阎浮提内有二万诸城。彼一一城有千俱致家。护国。时彼焰意王自所住城名曰宝光明。东西十二由旬。南北七由旬。七宝所成。宝墙七重以为围绕。一一墙间相去八步牢固难坏。护国。彼国众生寿命十俱致那由他岁。护国。尔时彼焰意王。初生一子名曰福焰。端正殊特身色具足。世间无双瞻者无厌。护国。时彼王子初生之日。于其生处有七宝藏自然出现。其王宫内亦有七宝藏。自然出现上高七人。护国。彼王子生时。阎浮提内一切众生。皆大欢喜踊跃无量。若有众生被系闭牢狱。枷锁着身者自然解脱。护国。彼福焰王子世间所有工巧术艺。于七日内皆悉学成。护国。彼福焰王子于日初分。时有净居诸天。来告彼王子言。童子。汝莫放逸应善观无常。童子命不久停。至于后世如是速疾。恒须观察生大怖畏。造业必受如影随形。时净居诸天。复为童子说此偈言

  童子谨慎莫放逸　　亦莫随顺放逸者
  弃舍放逸佛所赞　　若受放逸诸佛诃
  常自调顺不放逸　　一切能施无妒嫉
  慈悲念于诸众生　　彼人不久当作佛

  过去无量佛　　现在及未来
  一切从善起　　住不放逸道
  饮食及衣服　　金银璎珞等
  俱致劫布施　　为求无上道
  手足耳鼻等　　求者欢喜施
  真心求功德　　不久得成佛
  王位威势力　　妻子及眷属
  有为如幻化　　速舍莫恋着
  寿命不久停　　如坏器易坏
  假借世不久　　此亦无常定
  父母及眷属　　恶道无能救
  众生造善恶　　如影恒逐形
  多求于欲海　　相害不为利
  而无济拔者　　虚受疲劳苦
  今欲作他利　　求寂无上道
  干枯皮肉髓　　汝莫以为苦
  诸佛出世难　　寂灭法难闻
  勤事善知识　　能破诸魔众
  舍离恶知识　　能住于正道
  遮蔽恶邪径　　善哉精进住
  汝莫惜身命　　持心如金刚
  正问诸师道　　莫舍正信意
  一切过去佛　　常乐阿兰若
  汝应顺彼学　　应乐在空闲
  弃舍于恩爱　　妻子眷属等
  己身及寿命　　以求广大智

尔时世尊复告护国菩萨言。善男子。其福焰王子从彼诸天闻此偈已。于十年内未曾睡眠未曾戏笑。未曾歌舞未曾喜乐。未曾踊跃未曾放逸。不入园苑。不乐眷属。不贪王位。于资财城郭不生乐心。如是一切内外诸物皆悉弃舍。唯入禅定住于静室而自思惟。一切法无常。无强无力。无有坚牢。暂现而灭。王位无味。无有自在。恩爱别离。怨憎相会。无可贪着。妄生爱乐皆由愚痴。虚妄诳惑无一实也。唯有解脱寂灭为乐。而诸凡夫愚痴所醉常乐处之横生优劣之相。我今在此凡愚众中。应住默然思不放逸。护国。尔时彼焰意大王。为此童子更别立城名胜喜乐。有七重宝墙以为围绕。其城南北有七百街巷。其街墙壁七宝所成。金铃罗网以覆其上。更以真珠众宝罗网重覆其上。一一巷首皆有八万四千宝柱。于诸宝柱上系六万宝绳共相钩连。诸宝绳间悬十四俱致宝多罗树。微风吹动出妙音声。犹如百千音乐不鼓自鸣。一一诸街巷首。安置五百童女。盛壮少年善解歌舞。为一切众生爱乐之故。其焰意王。复更告令一切。汝等诸人从今已去。昼夜莫作余事。唯作歌舞嬉戏。令诸众生欢喜受乐。四方来者悉令欢喜。乃至不听出一粗言。欲令王子心生爱乐。复于巷首安置种种布施之具。所谓衣服饮食璎珞床敷毡褥车乘辇舆象马牛羊。五行之具。金银琉璃。车磲马瑙珊瑚虎魄真珠等宝。涂香末香烧香薰香种种花鬘等。若须衣者与衣。须食与食。须饮与饮。须乘与乘。随其所须而施与之。更于处处安诸珍宝等聚。拟诸众人之所受用。又于城中造作宫殿。拟为王子游戏之处。其地皆以众宝间错。于其城上起大高楼众宝庄严。于城中央造一大殿。殿内安置千万床敷。于殿四边造诸园苑。其园苑内有诸树木。一切花果诸喜乐树具足充满。护国。彼园苑中造七宝池。其池四面有四宝阶道。何等为四。所谓金银琉璃颇梨。于一方面有二师子百宝所成。彼二师子各吐香水入彼池内。其池四边复各有二宝师子。各各引水而出其池。常有优钵罗花。波头摩花。俱物头花。奔陀利花。其池四岸宝树围绕。复有树木诸花果等周匝遍满。复有八百宝树。是诸宝树以诸宝绳共相连系。一一宝树各悬缯幡。其池四面。复有亿数宝多罗树。于其树间系以宝绳悬诸金铃。微风吹动出微妙音。如百千乐不鼓自鸣。恐诸埃尘以大宝网弥覆地上。于彼殿内安置千万七宝床敷。诸宝床上各敷五百种褥。于殿中间敷一高座。其座七宝所成高于七人。复于座上敷八万俱致微妙衣服。其高座前置宝香炉烧沉水香。夜三昼三散诸名花。以金罗网弥覆殿上。其罗网边悬金莲花。复以真珠罗网覆金网上。复有八万明净珍宝以为光明。于其园内又置九百万宝聚。一一宝聚高一由旬。出大光明照彼世界。护国。于彼园内复有诸鸟。所谓鹦鹉。鸲鹆鸿鹤。俱系罗鸟。孔雀鹅雁。及以鸳鸯。俱那罗鸟。迦陵频迦鸟。命命鸟。彼等诸鸟若欲鸣时皆作人声微妙和雅。犹如诸天欢喜园内诸鸟之音。凡所出声皆欲令王子生欢喜故。又复别为王子建立厨膳。日别办具五百种味以供王子。尔时大王。又敕国内诸城邑一切童子。普告令集童子之数。凡有八十俱致。其诸童子。或年始二十。或有过者。悉能善解一切工巧伎艺严饰鲜洁。皆令入于胜喜乐城。而彼童子等各有父母。复将千万俱致婇女。拟诸童子驱驰使役。童子眷属亦皆奉献千万童女以为给使。乃至国内大富长者及以人民。亦各送千万俱致婇女。是诸婇女年始十六。不长不短。不白不黑。不粗不细。皆悉端正世间无比。善解音乐及以歌舞。善於戏笑言语调柔颜色和悦。若老若少皆能慰喻。一切伎能悉善通达身相具足。其口香气如优钵罗花。身诸毛孔出栴檀香。微妙清洁犹如天女。福焰王子处此宫内。婇女众等常作音乐种种供养。尔时王子闻此音乐已作如是念。今者此等为我作大怨仇夺我善法。我应弃舍。王子尔时见诸乐事不喜不乐。譬如丈夫临被刑戮。虽见色欲不生欢喜。如是如是。福焰王子。在彼女众之时心无欢喜。在彼城内与诸眷属同会聚集亦不欢喜。从是已来经于十年。不取色相。不取声香味触等相。唯作是念。我今何时脱此怨仇。我于何时行不放逸当得解脱。尔时诸女。白焰意王言。大天。当知今此王子共我等聚。不相喜乐亦不受乐。佛言。护国。尔时焰意王。与八万小王前后围绕。诣向福焰王子所。到已流泪满面遍身。战掉不能自胜。忧愁苦恼迷闷躄地。须臾复起。起向福焰王子。而说偈言

  汝有最妙大果报　　有谁为汝作不善
  而不受于最胜乐　　汝不受乐我忧苦
  愿汝受乐施我喜　　若有触扰向我说
  我能与彼极重罪　　汝观此城妙莲花
  是我思惟为汝作　　世间所少速当说
  我能示现如帝释　　汝今面目如青莲
  云何颦眉不畅适　　今此婇女甚殊特
  微妙清净等诸天　　各各善解诸伎术
  歌舞音乐悉能通　　汝应与此相娱乐
  云何忧愁如毒箭　　汝今应当快受乐
  非是忧愁苦恼时　　园林池苑甚茂盛
  花果枝叶郁扶疏　　宽博如天妙果林
  汝今正是上年时　　颜色憔悴如枯花
  但应受乐莫忧苦　　流泉浴池犹如天
  微妙香水洗浴身　　诸花开敷群蜂绕
  汝今云何不爱乐　　鹅雁鹦鹉及鸿鹤
  命命俱那微妙声　　香山雪山无有异
  谁有见闻不爱乐　　众宝胜殿真珠网
  琉璃严净如天宫　　宝座庄严妙衣覆
  金铃罗网出妙音　　种种音声甚殊特
  街衢道路及巷首　　千数婇女作音乐
  犹如喜园天玉女　　何故迷乱不受乐
  童子婇女如天身　　为汝受乐故聚集
  父母为汝泣堕泪　　我如丧失所爱子
  愁忧怅快何可住

尔时福焰王子。以偈报父王言

  如彼具足功德者　　观诸有为生死苦
  厌离烦恼欲求脱　　弃舍一切世间欲
  见诸众生没死网　　常求解脱远欲乐
  思惟菩提最为胜　　唯愿父王听我说
  无人为我作恶事　　我自不乐诸欲乐
  一切恩爱如怨仇　　增长烦恼向恶趣
  此诸婇女愚人乐　　增长魔业系缚缠
  远离功德增不善　　又令未来堕恶趣
  诸圣呵责此五欲　　我今云何乐苦本
  如此婇女假外色　　唯有皮囊盛筋骨
  肉血屎尿内不净　　此真死尸云何乐
  歌舞音乐伎术等　　如幻如梦诳愚痴
  愚痴分别失正道　　我岂随顺作爱业
  园林花果至冬时　　枯瘁萎黄皆堕落
  无常散坏不久留　　寿命无定痴放逸
  心如大海不知足　　恩爱增长求无厌
  常为诸欲相残害　　我如须弥风不动
  父母兄弟姊妹等　　妻子朋友诸眷属
  王位百官及势力　　若堕恶道无能救
  我等今者如草露　　亦如电光不暂停
  心意散乱无定所　　思惟见是不放逸
  咄哉少年不久住　　咄哉寿命如浚流
  咄哉有为如浮云　　咄哉三界求王位
  智者来教莫放逸　　无有菩萨贪世间
  若欲作佛救拔他　　父王放逸不作佛
  若随诸欲为爱奴　　彼失功德无善路
  若于今身贪杀生　　如鸟在网欲求活
  境界犹如恶毒蛇　　诸阴犹如怨害贼
  其心著有无利益　　犹如空村无依怙
  父王园林如毒树　　无常瀑水悉漂没
  我今云何而可乐　　我见世间无正行
  犹如劫尽盛火燃　　众生于中受大苦
  我为是等解脱故　　当速成办如法船
  众生久睡无自觉　　病来长久我欲治
  为拔毒箭令安乐　　除彼邪径住正道
  系缚三界无能出　　我为说法令脱免
  众生贫穷无法财　　我施善教令其富
  恶趣道中迷没者　　我当教示以善导
  我欲摧拔诸爱树　　行诸慈悲燃智灯
  令见三界大火聚　　又兴慈悲起大云
  如波罗蜜普遍覆　　利益众生如电光
  道品总持以为雨　　清凉能灭热恼焰
  我为是故生王家　　在于有为不乐欲
  我为利益众生故　　随世受生求菩提
  一向不乐诸有乐　　父王我在怨仇中
  智者云何乐此路　　有眼不堕于高岸
  若求菩提舍放逸　　一切世间顺诸趣
  唯我当欲逆彼行　　大王我言终不虚
  唯愿父王还本宫　　愿舍世间王位等
  随彼须者所受用　　若受放逸贪王位
  亿数王位我不欲　　若处宫内无得道
  唯当寂静无畏处　　若乐五欲无能办
  我向山林处寂静　　至于彼所求菩提
  三世如来在兰若　　正觉菩提不在欲

尔时世尊说此偈已。告护国菩萨言。善男子。尔时彼福焰王子为父王说偈已。在于宫殿与诸婇女。相随经行而心不安。唯住三种威仪而住。何谓为三。所谓若行若住若坐而不眠卧。处在高楼第八重上。夜半时间于上空中。见净居诸天在空而行。赞佛功德乃至法僧功德。护国。时彼福焰王子。闻彼诸天赞叹佛已。身毛皆竖遍体战栗。合十指掌。以偈告彼诸天言

  善哉诸天辈　　怜愍我等苦
  莫生疲倦心　　我欲有所问
  汝行于虚空　　赞叹谁功德
  我闻此赞声　　心生大欢喜

佛告护国。尔时彼天以偈报福焰王子言

  童子汝不闻　　如来出兴世
  佛名吉利意　　无归为作归
  能知人心行　　福智具足满
  圣众具禅定　　百千那由他

尔时福焰王子。复以偈告彼诸天言

  我未睹彼色　　汝为我说相
  我若得见闻　　问彼菩提道
  云何化众生　　云何当来世
  于众生中尊　　为我解说之

尔时净居诸天。以偈报福焰王子言

  世尊发润泽　　右旋而青色
  顶高如雪山　　白毫等净日
  清净如琉璃　　妙色而右旋
  耳目甚修广　　色如青莲花
  方颊如师子　　唇如频婆果
  口齿甚齐密　　清净如珂雪
  具足满四十　　四牙甚锋利
  舌长能覆面　　威德大自在
  为诸众生等　　放亿数光明
  遍满三千界　　干竭诸恶道
  无上最胜尊　　妙声覆真实
  能令闻者喜　　满诸众生愿
  胜彼如意珠　　不缺减功德
  随顺于道分　　庄严于法鬘
  音声百千种　　演畅无虚说
  胜于一切天　　过诸梵天音
  他闻发欢喜　　胜诸紧陀罗
  迦陵俱翅罗　　鸳鸯及鸿鹤
  俱那罗梵声　　和合种种声
  音词不杂乱　　能令义显现
  妙净如琉璃　　能令智者乐
  教令发道心　　心净生踊跃
  随顺他心智　　能决疑者问
  彼尊法王者　　自在大世尊
  有是胜法音　　项直肩圆满
  肘臂佣过膝　　指掌缦网长
  七处皆平满　　慈悲举胜手
  安慰诸众生　　身色如真金
  一一毛右旋　　脐轮深且密
  阴藏如马王　　髀如象王鼻
  鹿王纤长膞　　足下莲花文
  千辐网具足　　回顾如象王
  游步如师子　　举身皆相称
  犹如释天杖　　空中雨天花
  于上变成盖　　去住恒随逐
  法王希有事　　若得利无利
  若得乐及苦　　若得名不名
  若赞若毁呰　　一切无染着
  犹如花在水　　亦如师子王
  众生中无比

尔时世尊告护国菩萨言。护国。尔时福焰王子。从彼诸天闻说叹佛功德乃至法僧功德已。欢喜踊跃不能自胜。护国。尔时福焰王子。复作是念。如是诸佛世尊。有如是大众。成就如是觉证最胜妙法。如是圣众弟子成就我不得见。我今值遇生死诸恶苦恼。如是生死无有义利。诸凡夫辈执着我见。在家多诸过患贪欲无厌。智者呵毁放逸无明黑暗之所覆蔽。如是诸行难可穿彻。如是识心甚难降伏。如是名色甚深难觉。如是六入而不自在。如是恶触果报受持。如是愚痴多诸过患。如是渴爱坚缚不舍。如是诸取甚难舍离。如是诸有无有圣道。如是生者甚难解脱。如是老者能坏少年。如是病者损减壮色。如是死者无有润泽。如是生者多诸衰恼。如是往来无有利益。如是微妙如来正教甚可爱乐。何可以爱好故。为诸烦恼迷惑其心。为诸恶觉浊乱不净。心常放逸。常与愚痴等辈而为朋友。不善思惟心常染着。烦恼生死乐恶知识。常与如是诸恶俱者。尚不能办世间净善。何况能得阿耨多罗三藐三菩提也。如我今者即于此楼东面投身而去。若从门出恐诸眷属为作障碍。佛告护国。尔时福焰王子。欲向吉利意如来边。即向彼如来方面绝身。复作是言。若彼如来是一切知见者亦应念我。护国。尔时吉利意如来阿罗呵三藐三佛陀。即伸右手放大光明。照福焰王子。即于光中出一莲花。大如车轮有百千叶。然彼莲花放百千光明。其光明盛照福焰王子身。尔时福焰王子。即自见身处彼莲花。既住花中合十指掌。曲躬向吉利意如来多陀阿伽度阿罗呵三藐三佛陀。口三唱言南无佛陀耶。南无佛陀耶。护国。尔时吉利意如来还摄光明。福焰王子。即乘佛光至如来前。举身投地如大树倒。礼彼如来一千拜已。护国。尔时福焰王子。以偈白世尊言

  我久得重病　　今值大医王
  于苦厄难中　　世尊济拔我
  愿尊为我说　　云何住法中
  当得大福利　　唯愿尊显说
  世尊我于先　　夜半诸天来
  教我莫放逸　　闻此天教已
  恐怖来此处　　今问大世尊
  云何不放逸　　我今失正道
  愿为作商主　　我今如生盲
  愿为我作眼　　我今临险岸
  愿尊救济度　　唯愿大慈悲
  令我生正信　　如病困笃者
  愿尊速疗治　　我今如贫人
  愿尊见摄受　　我今被系缚
  愿尊能为解　　我心大疑惑
  愿决我痴网　　示我修行处
  云何得菩提　　我今没大水
  愿示度济我　　我处大闇中
  愿燃大法炬　　我身有大疮
  愿治速令差　　我身有毒箭
  愿尊能为拔　　常堕诸恶道
  愿慈救济我　　诸有执著者
  回邪住正道　　我没忧戚河
  愿度至彼岸　　得住八圣道
  我寿命短促　　求善多障碍
  愿从今去后　　得住真如命
  我今身闲静　　已离于诸难
  作福必获报　　愿为我决疑
  世尊为我说　　菩萨不放逸
  而向无上道　　未来证菩提
  能解诸有缚

尔时佛告护国菩萨言。护国。尔时吉利意如来。知福焰王子心已。为其广说诸菩萨行。其福焰王子。闻此法已即得陀罗尼。名曰解脱。亦得五神通。即时上升虚空化作众花。以散佛上如是重散。护国。尔时福焰王子。从空下已。即以偈赞彼吉利意如来言

  敬礼金色尊　　面净如满月
  敬礼智无比　　离垢三界尊
  发净光润泽　　顶高如须弥
  观者无厌足　　眉间白毫相
  清净妙光明　　目如青莲花
  微妙甚殊特　　慈悲心哀愍
  观示诸世间　　如来广长舌
  软薄如赤铜　　出能遍覆面
  说法教道众　　敬礼微妙声
  齿白如珂雪　　坚实如金刚
  齐密具四十　　熙怡微笑时
  教化无量众　　敬礼美实言
  尊色世无比　　放光照诸刹
  梵天及护世　　彼光悉不现
  鹿王纤佣膊　　行步如象王
  亦复如师子　　安祥游步时
  地动诸山震　　世尊具身相
  皮肤软妙泽　　身如紫金色
  威光无与比　　观者无厌足
  苦行无数劫　　乐施无疲倦
  慈心向众生　　故礼大悲父
  尊常乐施戒　　坚住忍精进
  禅定及般若　　总持智无比
  是故我敬礼　　世尊说法时
  降伏诸外道　　处众如师子
  医王除三垢　　闻者皆欢喜
  是故我今礼　　身口意清净
  三界无染着　　如莲花处水
  尊声如梵天　　如迦陵伽音
  度过三界岸　　是故我敬礼
  尊观诸世间　　如幻亦如梦
  复如伎儿戏　　说诸法无我
  众生及命者　　亦如水中月
  空寂无生处　　如是知世已
  为彼作方便　　百千诸法门
  慈悲摄教众　　众生多诸患
  诸毒常炽然　　观察热恼已
  犹如大医王　　常行于世间
  拔济无数众　　生老病死苦
  爱离怨憎会　　忧悲苦恼等
  观世苦恼已　　慈悲能度脱
  常行于世间　　世界如车轮
  天人或畜生　　地狱饿鬼中
  迷惑无导师　　世尊为彼等
  示现最胜导　　过去有诸佛
  法王离世间　　亦说此圣道
  如今世尊说　　清净无秽浊
  胜于大梵天　　亦胜揵闼婆
  及与诸天女　　如是等诸音
  如来声最胜　　为世间解说
  真实润益忍　　种种方便说
  具足诸功德　　百千那由数
  诸众生闻已　　证三乘寂灭
  若有供养彼　　得胜上妙乐
  无量天人等　　当得正真道
  或得于人王　　大富长者等
  或领一天下　　二三四天下
  转轮圣帝王　　十善化众生
  七宝具足乐　　皆由供养佛
  或作释梵王　　四天大王处
  兜率化乐天　　他化须夜摩
  斯由供养佛　　来世作正觉
  如是供养佛　　或见或闻声
  无有空过者　　除多众生苦
  得证甘露处　　最妙无老病
  世尊知正道　　善说正道处
  能断诸恶道　　令住无畏路
  无垢大圣道　　能为众生依
  若人求福德　　须于佛边种
  以是因缘故　　当得无尽藏
  多数俱致劫　　彼福不可尽
  乃至未成佛　　当得清净刹
  微妙如他化　　得已大欢喜
  彼妙刹土中　　所有众生辈
  身口意清净　　如是等功德
  斯由供养佛　　若彼众生辈
  求天及涅槃　　及以人中乐
  福报等无量　　斯皆不可尽
  大名胜供养　　复于百刹中
  无量百千众　　当说大名称
  斯由叹佛德　　如来除热恼
  能令众解脱　　慈悲见欢喜
  诸根寂清净　　人中最胜王
  无量功德聚　　是故我顶礼
  我已得五通　　虚空能飞上
  听尊妙音声　　未来若作佛
  为众宣微妙　　度脱无量众
  我赞功德聚　　无垢清净福
  天人诸龙等　　夜叉乾闼婆
  杂类众生辈　　来世愿成佛

尔时世尊。说此偈已。复告护国菩萨言。护国。尔时焰意大王。过彼夜已。闻彼童子宫内哭声。闻已驰向胜喜乐城。到已问诸彩女辈言。汝等今者为何哭耶。时彼诸女。白大王言。大王当知。福焰王子于今夜中忽然不见。护国。尔时焰意王。闻此语已迷闷躄地如大树倒。须臾乃起大声悲泣啼哭懊恼。巡绕彼城经百千匝。护国。尔时彼处护城天神。告焰意王言。大王当知。东方去此。有佛世尊名曰成利慧。大王。王子今在彼处。顶礼承事供养彼佛世尊。尔时焰意王。闻天告已。即时与童子宫内诸彩女等及王部。从八万四千俱致百千那由他众。向于东方。往诣成利慧如来阿罗呵三藐三佛陀所。到已顶礼佛足。却住一面。以偈叹佛

  敬礼功德智慧海　　人中丈夫无等等
  三界最胜无有比　　天王修罗皆供养
  众中殊特最极尊　　观佛色相无厌足
  三十二相庄严身　　犹如须弥宝清净
  佛身微妙紫金色　　见者无厌我顶礼
  无量百千亿数劫　　如来苦行无厌倦
  无量劫数供养佛　　百千俱致不可数
  往昔布施难思议　　是故身光甚严净
  布施持戒禅定慧　　忍辱精进善方便
  世尊身色甚清净　　胜于日月摩尼光
  释梵光明隐不现　　佛现妙色为世间
  或现在于兜率天　　或复示现欲下生
  或现清净白象身　　梦中右胁入母胎
  佛身现处如虚空　　如影水月梦幻化
  佛身应现亦如是　　又复示现初生时
  或行七步示丈夫　　唱言天人我最上
  我能救脱诸苦众　　于诸法中无疑惑
  为众示现始学书　　成就禅定寂静处
  示现在于婇女中　　舍于父母及妻子
  眷属宗亲恋慕啼　　舍家处林恒独步
  俱致数天恒围绕　　恒常赞叹不生厌
  久已降伏四种魔　　此刹示现始降伏
  久已转于无始轮　　今以慈悲示初转
  观于世间着常想　　在众唱言我涅槃
  见诸世间乐生死　　世尊为说寂灭处
  福智方便无比喻　　身放光明照多刹
  诸方菩萨寻光来　　顶礼世尊不思议
  法王为说微妙法　　心生欢喜证清净
  为众现身同世间　　佛身无来亦无去
  如来住法如幻化　　是故顶礼大丈夫
  善哉世尊说妙道　　为众显于菩提路
  为我显示胜法门　　是故我今证此法
  如来为我所示现　　我证皆为众生说
  佛智无恼三界尊　　我今叹佛证功德
  愿共世间诸众生　　速证寂灭无上道

尔时世尊。说此偈已。复告护国菩萨言。护国。尔时彼成利慧如来。知焰意王深信心已。如应说法令住不退转地。于阿耨多罗三藐三菩提中。护国。尔时彼福焰王子。白成利慧如来言。世尊。我今欲请如来及比丘僧入我城内。唯愿世尊慈愍听许。尔时成利慧如来。怜愍王子故默然受请。护国。尔时福焰王子。知佛许已白其父母。告诸眷属并婇女等言。尊等当知。我今以胜喜乐城并庄严具。悉以奉施彼如来及比丘僧终无悔也。唯愿父母及诸眷属生随喜心。尔时父母眷属。一时同声唱言。善哉善哉。我皆随喜。护国。尔时福焰王子。即时更好庄严胜喜乐城奉施如来。尔时王子为佛及僧。日别办具五百种味上妙饮食。供佛及僧。复为比丘造僧伽蓝。皆以七宝庄严其房。舍内敷置杂色种种缯褥数百千重。又为比丘僧。日别造新净衣。布施众僧随意所乐。复更为造经行之处。皆以众宝庄严其地。上覆宝网经行两边。种诸树木花果种种诸花。谓忧钵花。波头摩花。分陀利等。一切众花无不具足。时彼王子。如是供养佛及众僧。经三亿俱致岁。于其中间未曾睡眠不爱身命。唯念供养佛及众僧。其间无贪欲心。无嗔害心。于王位处不生乐心。于一切处弃舍身命况复余物。复于如来有所说法。皆悉受持终无忘失。乃至一句未曾重问。如来于其时间亦不洗浴。亦不以苏油涂摩其身。亦不洗足。亦不坐卧。唯除食时及大小便利。乃至终无疲倦之想。而彼如来涅槃时。自取赤真檀为积聚。阇毗如来身。于阇毗如来身处。以种种上妙供具供养舍利。又于阎浮提内处处。以诸华鬘名香种种音乐。乃至旛盖宝幢供养舍利。如是供养已。为其舍利。复更别造九十九俱致宝塔。彼诸塔等七宝所成。复以杂宝真珠罗网以覆塔上。又为诸塔造七宝盖。彼一一塔奉施五百宝盖。又于一一塔所。奉施音乐数百千种。于阎浮提内处处。悉令种诸妙花树。于一一塔所前然百千灯。一一灯器盛千斛油。又复更以一切诸香。涂香末香烧香。及诸花鬘等供养彼塔。尔时福焰王子。如是供养经俱致岁已于后出家。既出家已唯畜三衣常行乞食。乐于头陀恒坐不卧。于余时间未曾睡眠。亦不从人有所求索。施与一切心不望报。常为他人解说正法。如是经四俱致岁。乃至若有以一善言赞叹者心尚不受。何况受人利养之物。若听法时无疲倦想。常有诸天承事供养。尔时彼国土内王与大臣夫人婇女。一切人民并诸眷属。悉皆随从学彼王子出家修道。护国。尔时净居诸天子等。见是事已作如是念。今此国内一切人民。并学王子出家。今此国内尽是三宝。我等今者应作檀越供养彼等。即是供养三宝利益世间。彼如来涅槃后。正法住世经六万四俱致岁。皆是福焰比丘之所住持。其福焰比丘。从此已来常如是供养。如是次第供养九十四俱致诸佛。彼一一佛悉皆如上供养之行。护国。于汝意云何。其焰意王。岂异人乎。莫作异见。则今无量寿如来是也。护国。于汝意云何。彼福焰王子。岂异人乎。莫作异见。则我身是也。尔时其守护城天神者。岂异人乎。则阿閦佛是也

尔时世尊。复告护国菩萨言。护国。是故若诸菩萨摩诃萨。若欲得阿耨多罗三藐三菩提者。应当学彼福焰王子。深心至诚所修诸行。能舍一切憎爱心。是故我常勤修如是苦行故。得成于阿耨多罗三藐三菩提。然未来世有诸比丘。爱重名利贪着眷属。于诸善法自然损减。常为我慢怨贼之所损害。甚可怜愍。以贪利故远离正法。虚然出家污沙门行。但有口言我是菩萨。然其内心纯行谄曲。身心昏浊没烦恼泥。才有形相违于本道。舍已誓愿。贪着衣服饮食。房舍卧具汤药等事。心无惭愧不避耻辱无有威仪。离佛境界心恒贪着。护国。若有得闻如是法者。应当觉知彼恶知识。恶知识者。求名贪利不应亲近。尔时世尊。欲重宣此义。以偈颂曰

  多行于放逸　　远离十力处
  心常贪利养　　及诸眷属等
  弃舍佛菩提　　千种诸功德
  诈圣求名利　　恶性无惭耻
  奸谄无羞愧　　彼专为利事
  入于佛法中　　随顺诸烦恼
  速疾堕恶趣　　口言我大德
  胜在阿兰若　　心恒念聚落
  彼等为贪故　　心多诸觉观
  彼人远解脱　　犹如天与地
  行者应远离　　如畏恶毒蛇
  彼不乐佛法　　并诸功德僧
  弃舍离善道　　常行于邪径
  失于无量善　　为诸有覆蔽
  闻我往昔行　　真实诚心信
  应当学我行　　多俱致劫数
  如是法难得　　应发大忍心
  我有所说处　　勤劬当奉行
  若当欲成佛　　妙胜大乘中
  应念彼王行　　诸功德无量
  思惟真实已　　应住彼教中
  如是菩提道　　当见如佛说
  深思诸功德　　圣人种性处
  当应如教行　　若舍如是教
  则失功德味　　当生恶趣中
  愚痴无有别　　生彼已当悔
  劝住山林者　　慎莫自赞誉
  亦勿毁他行　　宁常自呵责
  昔背亿数佛　　斯由我慢心
  莫惜已身命　　恩爱处悉舍
  如我说此经　　法中行敬心
  若能如说行　　菩提不为难
  此乘大仙说　　闻已莫生疑
  是故佛法中　　应住如圣教
  精勤舍身命　　如我教莫违
  若不信此教　　于后悔无益

尔时世尊。说此偈已。复告护国菩萨言。护国。若有菩萨常行五波罗蜜无有休息。若有菩萨于此经中。能如法行能如教住。复自唱言。我如教住我如教行。于前行五波罗蜜功德者。欲比此功德百分不及一。百千分不及一。百千俱致分不及一。算数过算数分不及一。哥罗分不及一。譬喻分不及一。忧波尼沙陀分不及一。佛说此经时。三十那由他天及人阿修罗等。未曾发阿耨多罗三藐三菩提心者。皆悉发心。得不退转于阿耨多罗三藐三菩提。复有七千比丘。尽诸有漏心得解脱。尔时长老护国菩萨白佛言。世尊。此法本有何名。我等云何奉持。作是请已。尔时佛告护国菩萨。善男子。言此法本名不空誓清净行。如是受持。亦名善丈夫游戏菩萨行决定毗尼。如是受持。亦名真实义具足。如是受持。亦名福焰菩萨大士往昔本行。如是受持。佛说是法已。长老护国菩萨。及诸天人。阿修罗乾闼婆等。闻佛所说。欢喜奉行

大宝积经卷第八十一大宝积经卷第八十二

        曹魏三藏法师康僧铠译

    郁伽长者会第十九

如是我闻。一时佛在舍卫国只陀林中。给孤穷精舍。与大比丘僧千二百五十人俱。菩萨五千人。弥勒菩萨。文殊师利菩萨。断正道菩萨。观世音菩萨。得大势菩萨。如是等而为上首。尔时世尊。与于无量百千大众。恭敬围绕而演说法。尔时郁伽长者。与五百眷属。出舍卫大城。诣只陀林给孤穷精舍。到已礼佛足。绕三匝已却坐一面。尔时复有法施(丹本爱敬)长者。名称长者。善与长者。耶奢达多长者。善财长者。爱行长者。给孤穷长者。龙德长者。实喜长者。是等各与五百长者。俱出舍卫大城。诣只陀林给孤穷精舍。到已礼佛足。绕三匝已却坐一面。是等一切及与眷属。皆向大乘厚种善根。决定至于无上正道。尔时郁伽长者。知诸长者皆悉集已。承佛神力向佛合掌。白佛言。世尊。欲有所问愿垂听许。说是语已。世尊告曰。长者。如来常听恣汝所问。随汝所疑我随汝问。而当演说悦可汝心。时郁伽长者。闻是语已。白佛言。世尊。若善男子善女人。发阿耨多罗三藐三菩提心。解向大乘。信于大乘。欲集大乘。欲乘大乘。知于大乘护诸众生。安慰抚喻一切众生。为欲安乐一切众生坚固庄严。我要当度于未度者脱未脱者。无安慰者当安慰之。未涅槃者当令涅槃。荷担一切作大桥船。闻无量佛智。欲修佛智。发大庄严。知生死中无量苦患。于无量阿僧祇劫心无忧恼。于无量劫流转生死而心无倦。世尊。是中若有住菩萨乘善男子善女人。或有出家修集法行。或有在家修集法行。善哉世尊。哀愍人天阿修罗。世尊。守护大乘不断三宝。为一切智久住世故。世尊。唯愿演说在家菩萨戒德行处。云何在家菩萨。住在家地如来所敕随顺修行而不损坏助菩提法。于现法中无缠覆业得增胜行。世尊。云何出家菩萨。舍所珍爱而行出家。当教是等。云何行法。云何修善。出家菩萨。云何可住。云何不住。如是请已。尔时世尊。告郁伽长者。善哉善哉。长者。如汝所问是汝等所宜。长者谛听。善思念之。今为汝说在家出家菩萨所住学得胜行。郁伽白言。如是世尊。受教而听。佛言长者。在家菩萨。应归依佛归依法归依僧。以此三宝功德。回向无上正真之道。长者。云何在家菩萨归依于佛。我要得成于佛身三十二相以自庄严。持此善根集三十二丈夫相。为集此故勤行精进。长者。是名在家菩萨归依于佛。长者。云何在家菩萨归依于法。长者。而是菩萨恭敬于法及说法者。为法欲法。乐法极乐。助法住法。持法护法。坚住于法。赞叹于法。住于法行。增法求法。以法为力。施法器仗。唯法为务。我成阿耨多罗三藐三菩提已。当以正法等施一切人天阿修罗。长者。是名在家菩萨归依于法。长者。云何在家菩萨归依于僧。长者。若是菩萨。见须陀洹。斯陀含。阿那含。阿罗汉。及与凡夫。若见声闻乘。皆悉敬顺速起承迎。好语善音右绕彼人。应当如是思念。我等得无上正真道时。为成声闻功德利故而演说法。虽生恭敬心不住中。长者。是名在家菩萨归依于僧。长者。在家菩萨成就四法归依于佛。何等四。不舍菩提心。不废劝发菩提之心。不舍大悲。于余乘中终不生心。长者。是名在家菩萨成就四法归依于佛。长者。在家菩萨成就四法归依于法。何等四。于法师人亲近依附。听闻法已。善思念之。如所闻法为人演说。以此说法功德回向无上正真之道。长者。是名在家菩萨成就四法归依于法。长者。在家菩萨成就四法归依于僧。若有未定入声闻乘。劝令发于一切智心。若以财摄若以法摄。依于不退菩萨之僧。不依声闻僧求声闻德。心不住中。长者。是名在家菩萨成就四法归依于僧。复次长者。在家菩萨见如来已修于念佛。是名归依佛。闻于法已修于念法。是名归依法。见于如来声闻僧已。而不忘失菩提之心。是名归依僧。复次长者。若菩萨愿常与佛俱而行于施。是名归依佛。守护正法而行于施。是名归依法。以此布施回向无上道。是名归依僧。复次长者。在家菩萨作善丈夫业。不作不善丈夫之业。长者。云何名为善丈夫业。非是不善丈夫之业。长者。是在家菩萨。如法集聚钱财封邑非不如法。平直正求非粗恶求不逼切他。如法得封起无常想。不生悭想喜舍无吝。给事父母妻子奴婢诸作使者。以如法财而给施之。所谓亲友眷属知识然后施法。复次长者。在家菩萨荷负重担发大精进。所谓一切诸众生等五阴重担。舍于声闻缘觉之担。教化众生而无疲倦。自舍己乐为众生故。利衰毁誉称讥苦乐。而不倾动超过世法。财富无量而无憍逸。失利名称无有忧戚。善观业行守护正行。见毁禁者而不生嗔。诸有所趣善住所觉。除去轻躁满足智慧。助成他务舍己所作。无所希望有所为作。而不中舍知恩念恩。善为所作施贫封禄。有势力者折大憍慢。于无势力而慰喻之。除他忧箭忍下劣者。除舍憍慢及增上慢。恭敬尊重亲近多闻。咨问明慧。所见正直。所行无为。无有幻惑。于诸众生无有作爱。修善无足多闻无厌。所作坚固与贤圣同。于非圣者生大悲心。亲友坚固怨亲同等。等心众生。于一切法无有吝惜。如闻开示思所闻义。于诸欲乐生无常想。不贪爱身观命如露。观于财物如幻云想。于男女所如闭狱想。于眷属所生于苦想。于在田宅生死尸想。于所求财毁善根想。于其家中生系闭想。于亲族所生狱卒想。于夜于昼生无异想。于不坚身生坚施想。于不坚命生坚命想。于不坚财生坚施想。彼云何名于不坚身生坚施想。他有所作悉皆为之作务使命。名不坚身生坚施想。不失本善增现善根。是不坚命生坚施想。降伏悭吝而行布施。是不坚财生坚施想。长者。是名在家菩萨。如是修集善丈夫行。于诸如来无一切过。名相应语。名为法语。无有异想向无上道。复次长者。在家菩萨应受善戒。所谓五戒。彼乐不杀。放舍刀杖。羞愧坚誓。不杀一切诸众生等。不恼一切。等心众生常行慈心。彼应不盗。自财知足。于他财物不生希望。除舍于贪不起愚痴。于他封禄不生贪着。乃至草叶不与不取。离彼邪淫自足妻色。不希他妻。不以染心视他女色。其心厌患一向苦恼心常背舍。若于自妻生欲觉想。应生不净惊怖之想。是结使力。是故为欲非我所为。常生无常想。苦无我想。不净之想。彼人应作如是思念。我当乃至不生欲念。况二和合体相摩触。应离妄语谛语实语。如说如作不诳于他。善心成就先思而行。随所见闻如实而说。守护于法。宁舍身命终不妄语。彼应离酒不醉不乱。不妄所说。不自轻躁。亦不嘲哗。不相牵掣。应住正念然后知之。若心欲舍一切财贿。须食与食。须饮施饮。若施他时应生是念。念是檀波罗蜜时。随彼所欲我当给施。又我当使求者满足。若施彼酒当摄是人。得于正念令无狂惑。何以故。悉满他欲。是檀波罗蜜。长者。是故菩萨以酒施人于佛无过。长者。若在家菩萨。以此受持五戒功德。回向阿耨多罗三藐三菩提。善护五戒。又复应当离于两舌。若有诤讼应当和合。离于恶言出爱软语。先语问讯不毁辱他。利益他语。法语。时语。实语。舍语。调伏语。不戏笑语。如说如作不生贪痴。常安一切心不毁坏。常修忍力以自庄严。常应正见离诸邪见。不礼余天今当供佛。复次长者。在家菩萨。若在村落。城邑郡县。人众中住。随所住处为众说法。不信众生劝导令信。不孝众生。不识父母。沙门婆罗门。不识长幼。不顺教诲。无所畏避。劝令孝顺。若少闻者劝令多闻。悭者劝施。毁禁劝戒。嗔者劝忍。懈怠劝进。乱念劝定。无慧劝慧。贫者给财。病者施药。无护作护。无归作归。无依作依。彼人应随如是诸处念行是法。不令一人堕于恶道。长者。如是菩萨一一劝导。乃至第七。欲令众生住于德行。随如是处不能令住。而是菩萨于此众生应生大悲。坚发一切智慧庄严。作如是言。我若不调是恶众生。我终不成无上正真道。何以故。我为是故发誓庄严。不为以调无谄无伪。具戒德行发大庄严。我当勤发如是精进。令所作不空。众生见我即得信敬。长者。若菩萨在如是城邑村落中住。不教众生令堕恶道。而是菩萨诸佛所诃。长者。是故菩萨应当如是庄严大庄严。我今应当修行是行。住诸城邑村落郡县。不令一人堕于恶道。长者。犹如城邑有善明医。令一众生病毒而死多众诃责。如是长者。若是菩萨随所住处。不教众生令堕恶道。而是菩萨则为诸佛之所诃责。复次长者。在家菩萨善修学行。所谓家者名杀善根。名不舍过害助善业。是故名家。云何名在。一切结使在中住故。故名为在。又复住于不善觉故。住不调伏。住无惭愧愚小凡夫。住不善行诸恶过咎。是故名家。又复在家。一切苦恼悉在中现。害先善根故名在家。又复家者。在是中住无恶不造。在是中住。则于父母沙门婆罗门不好敬顺。是名为家。又复家者。长爱枝条忧悲苦恼悉在中生。招集杀缚。呵打嗔骂。恶言出生。是故名家。未作善根掉动不造。已作善根悉令散灭。智者所呵。谓诸佛声闻若住是中堕于恶道。若住是中堕贪嗔痴。是故名家。若住是中。妨废戒聚。定聚。慧聚。解脱聚。解脱知见聚。是故名家。若住是中。父母妻息。姊妹亲友。眷属知识。贪爱所摄。常思念财贪欲无满。如海吞流终不满足。若在家住如火焚薪。思处无定如风不住。在家消身犹如服毒。一切众苦皆悉来归。是故应舍如离怨家。若住在家圣法作障。多起诤缘常相违逆。住在家中善恶缘杂多诸事务。在家无常不得久住。是不停法。在家极苦求守护故。多诸忧虑谓怨亲所。在家无我到计我所。在家诳惑无有实事现似如实。在家离别多人传处。在家如幻多容集聚无实众生。在家如梦。兴衰代故。在家如露。速破落故。家如蜜滴。须臾味故。家如刺网。贪着色声香味触故。家如针口虫。不善觉食故。家如毒蛇。互相侵故。家多希望。心踯躅故。在家多怖。王贼水火所劫夺故。家多论议。多过患故。如是长者。在家菩萨名善知家。复次长者。在家菩萨住在家中。善调伏施分别柔软。应作是观。若施彼已则是我有。余家中者非是我有。已施者坚余者不坚。已施后乐余者现乐。已施不护余者守护。若已施者非爱所缚余者增爱。若已施者非我所心余者我有。已施无怖余者怖畏。若已施者是道基柱余是魔柱。已施无尽余者有尽。已施者乐余守护苦。已施离结余者增结。已施大封余者非封。若已施者是丈夫业。其余在者非丈夫业。若已施者诸佛所赞。其余在者凡夫所赞。如是长者。在家菩萨应坚住施。复次长者。在家菩萨若见乞者应起三想。何等为三。善知识想。他世富想。菩提基想。复有三想。顺如来教想。欲果报想。降伏魔想。复有三想。于求者所起亲眷属想。于四摄法起摄取想。于无边生起出离想。应当如是生是三想。复有三想。何等为三。除贪欲想。除嗔恚想。除愚痴想。生是三想。何以故。长者。是人贪欲嗔恚愚痴俱得微薄。长者。云何三事俱得微薄。若施财时心无贪着。是名贪薄。于乞者所生于慈心。是名嗔薄。若布施已回向无上正真之道。是名痴薄。长者。是名施者贪嗔痴薄。复次长者。在家菩萨见乞者已。修趣满足六波罗蜜想。何等为六。若是菩萨随所有物无不施心。是名修趣满檀波罗蜜。依菩提心施。是名修趣满尸波罗蜜。于求者所不生嗔诃。是名修趣满忍波罗蜜。若布施时不生自己乏少之想。是名修趣满进波罗蜜。若布施已心不忧悔倍生欢喜。是名修趣满禅波罗蜜。若布施已。不得诸法不望果报。是明慧者不住诸法。随无所住向无上道。是名修趣满般若波罗蜜。是名菩萨见乞求者修趣满于六波罗蜜。复次长者。在家菩萨于世八法应生放舍。彼人于家财贿妻子不生忧喜。假使忘失不生忧愁。应如是观。有为如幻是妄想相。父母妻子。奴婢使人。亲友眷属。悉非我有。我不为是造不善业。此非我宜。是现伴侣非他世侣。是乐伴侣非苦伴侣。我非护彼我之所护。施调人慧进不放逸。助菩提法诸善根等此是我有。随我所至彼亦随去。何以故。父母妻子。男女亲属。知识作使。不能救我。非我归依。非我舍宅。非我洲渚。非我荫覆。非我我所。是阴界入非我我所。况父母妻子当是我所。父母妻子是业所为。我善恶业亦随受报。彼亦随业受善恶报。长者。而是菩萨去来坐起常观是事。不为父母妻子眷属奴婢作使。造身口意恶不善业犹如毛分。是故长者。在家菩萨于已妻所应起三想。何等三。无常想。变易想。坏败想。长者。是名在家菩萨于己妻所生于三想。在家菩萨于己妻所复生三想。何等三。是娱乐伴非他世伴。是饮食伴非业报伴。是乐时伴非苦时伴。长者。是名在家菩萨于己妻所生于三想。复生三想。何等三。不好想。臭秽想。可恶想。是名三。复生三想。何等三。怨家想。魁脍想。诈亲想。是名三。复生三想。何等三。罗刹想。毗舍遮想。鬼魅想。是名三。复生三想。何等三。非我所想。非摄受想。乞求想。是名三。复生三想。何等三。持身恶行想。持口恶行想。持意恶行想。是名三。复生三想。何等三。欲觉想。嗔觉想。害觉想。是名三。复生三想。何等三。黑闇想。污戒想。系缚想。是名三。复生三想。何等三。障戒想。障定想。障慧想。是名三。复生三想。何等三。谄曲想。罥网想。猫伺想。是名三。复生三想。何等三。灾患想。热恼想。病乱想。是名三。复生三想。何等三。妖媚想。作衰想。霜雹想。是名三。复生三想。何等三。病想。老想。死想。是名三。复生三想。魔想。魔女想。可畏想。是名三。复生三想。忧想。哭想。苦恼想。复生三想。大雌狼想。摩竭鱼想。大雌猫想。复生三想。黑蛇想。尸守鱼想。夺精气想。复生三想。无救想。无归想。无护想。复生三想。母想。姊想。妹想。复生三想。贼想。杀想。狱卒想。复生三想。瀑水想。波浪想。洄澓想。复生三想。淤泥想。溺泥想。混浊想。复生三想。盲想。杻想。械想。复生三想。火坑想。刀坑想。草炬想。复生三想。无利想。刺想。毒想。复生三想。系狱想。讁罚想。刀剑想。复生三想。斗诤想。言讼想。闭系想。复生三想。怨憎会想。爱别离想。病想。略说乃至一切斗诤想。一切滓浊想。一切不善根想。长者。在家菩萨于己妻所。应生如是相貌观念。复次长者。在家菩萨于自子所不应极爱。长者。若于子所生于极爱。非他人所则为自毁。应以三法而自呵责。何等三。菩提道是平等之心非不平等心。菩提道是正行所得非是邪行。菩提道是无异行得非杂行得。复应呵己心。于自子所。生怨家想。恶知识想。非善知识想。违逆佛智平等之慈害我善根。彼应随处自调于心。如爱其子一切亦然。如爱自身一切亦然。应修是观。我异处来。子异处来。何以故。一切众生曾为我子。我亦是彼诸众生子。终不生念。我子彼非。何以故。去至六趣而复为怨。或复为子。我其当作等亲非亲。我以何故。于其所亲倍生爱与。于非亲所一切不与。我若生于爱不爱心。不于非亲所一切不与。我若生于爱不爱心不能趣法。何以故。不等之行至不等处。行平等行至于等处。我不应行是不等行。我学等心一切众生疾至一切智。长者。在家菩萨于诸财物。不生我所想摄护想。不系于彼。不想不爱。不生结使。复次长者。在家菩萨若有乞者来至其所。有所求索随所施财应至心念。我所施财及不施财。俱当散灭不满所愿。必当归死。我不舍财。财当舍我。我今当舍令作坚财然后乃死。舍此财已死时无恨欢喜无悔。若不能施应以四事白于乞者。今我力劣善根未熟。于大乘中我是初行。其心未堪自在行施。我是着相住我我所。善大丈夫今向汝悔勿生嫌恨。我当如是勤行精进。满足一切众生所愿。长者。在家菩萨应当如是白于乞者。复次长者。在家菩萨闻过去佛语。若不值佛及与圣僧。彼应敬礼十方诸佛。诸佛本行乃至成佛悉生随喜。如是昼夜各三时。净身口意业。净于慈善。具足惭愧清净之服。所集善根以菩提心而生随喜。柔软善作恭敬断慢。修行三分诵三分法。专心悔过诸不善业更不造新一切福业悉生随喜。集满相好劝请诸佛转于法轮。于说悉受持一切法。愿佛久寿增长善根。令我国土亦复如是。复次长者。在家菩萨受持八戒修沙门行。应当亲近净戒德行沙门婆罗门。依止给使不见其过。若见沙门越于戒行不应不敬。又佛如来是应供正遍觉。戒行所勋。定慧解脱。解脱知见所勋。袈裟无有滓浊。一切结染皆悉舍离。仙圣之幢倍生恭敬。于彼比丘生大悲心。彼不应为如此恶行。诸佛世尊名寂调伏一切悉知。圣幢相服不寂不调。不伏不知。作此非法。如世尊说不轻未学。非是彼过是结使咎。以结使故现造是恶。此佛法中有于出法。是人能出则有是处。若解是结修行正观得至初果。定趣无上正真之道。何以故。智能害结。世尊又说。人则不应妄轻。量人则为自伤。如来所知非我所知。是故不应嗔嫌害彼。复次长者。在家菩萨若入僧坊在门而住。五体敬礼然后乃入。当如是观。此处即是空行之处。无相行处。无作行处。慈悲喜舍四梵行处。是正行正住所安之处。我当何时舍于家垢。我当何时住如是行。应生如是欲出家心无有在家。修集无上正觉之道。皆悉出家趣空闲林。修集得成无上正道。在家多尘污。出家妙好。在家具缚。出家无碍。在家多垢。出家舍离。在家恶摄。出家善摄。在家没于爱欲淤泥。出家远离爱欲淤泥。在家凡俱。出家智俱。在家邪命。出家净命。在家多垢。出家无垢。在家衰减。出家无减。在家处忧。出家欢喜。在家则是众恶梯蹬。出家离蹬。在家系缚。出家解脱。在家畏惧。出家无畏。在家谪罚。出家无罚。在家多患。出家无患。在家烦热。出家无热。在家多求苦。出家无求乐。在家掉动。出家无动。在家贫苦。出家无苦。在家怯弱。出家无怯。在家下贱。出家尊贵。在家炽然。出家寂静。在家利他。出家自利。在家之人无润精气。出家之人有大滋润。在家结乐。出家灭乐。在家增刺。出家无刺。在家成小法。出家成大法。在家不调。出家调伏。在家离戒。出家护戒。在家增长。泪乳血海。出家干竭。泪乳血海。在家之人诸佛声闻缘觉所呵。出家之人诸佛声闻缘觉所赞。在家无足。出家知足。在家魔喜。出家魔忧。在家不降伏。出家降伏。在家奴仆。出家为主。在家生死际。出家涅槃际。在家堕落。出家拔堕。在家闇冥。出家明昭。在家之人根不自在。出家之人诸根自在。在家狂逸。出家不逸。在家不相应。出家相应。在家下观。出家上观。在家多营。出家少营。在家少力。出家大力。在家谄曲。出家正直。在家多忧。出家无忧。在家箭俱。出家除箭。在家病患。出家无病。在家老法。出家壮法。在家放逸命。出家修慧命。在家诳诈。出家无诈。在家多作。出家无作。在家毒器。出家甘露器。在家灾患。出家无灾害。在家不舍。出家放舍。在家之人取于毒果。出家之人取无毒果。在家之人不爱相应。出家不与不爱相应。在家痴重。出家智轻。在家失方便。出家净方便。在家失正意。出家净正意。在家失至意。出家净至意。在家之人不能作救。出家作救。在家造穷劣。出家不造穷。在家非舍。出家作舍。在家非归。出家作归。在家多怒。出家多慈。在家负担。出家舍担。在家不尽一切诤讼。出家尽诤。在家有过。出家无过。在家匆务。出家闲务。在家热恼。出家离热。在家多仇。出家无仇。在家贮聚。出家无聚。在家财坚。出家德坚。在家忧俱。出家寂忧。在家损耗。出家增益。在家易得。出家之人亿劫难得。在家易作。出家难作。在家顺流。出家逆流。在家处流。出家船筏。在家结河。出家越度。在家此岸。出家彼岸。在家缠缚。出家离缠。在家嫌恨。出家寂恨。在家王法。出家佛法。在家爱染污。出家离染。在家生苦。出家生乐。在家浅近。出家深远。在家易伴。出家难伴。在家妻伴。出家心伴。在家匆务。出家离务。在家逼他苦。出家乐他。在家财施。出家法施。在家持魔幢。出家持佛幢。在家巢窟。出家离巢。在家非道。出家离非道。在家稠林。出家离林。如是长者。在家菩萨渐次思念。我恒河沙等设于大祀。为诸众生一日悉施。善调法中生出家心。是则坚实施已毕足。我今应当坚修戒闻彼入僧坊礼如来塔生于三想。我亦当得如是供养。我亦当得愍一切众生留于舍利。我如是学。如是行。如是精进。疾得阿耨多罗三藐三菩提。设作一切佛诸事已。如佛如来入于涅槃。是入僧坊观于一切诸比丘德。谁是多闻。谁是说法。谁是持律。谁持阿含。何等比丘持菩萨藏。谁阿练儿。何等比丘少欲乞食。着粪扫衣独处离欲。谁是修行。谁是坐禅。谁是营事。谁是寺主。悉观彼行随谁人欲不生讥呵。若在寺庙及往聚落。有所言说善护口业。若有比丘乏于衣钵病药所须。随应给与不令起嗔。何以故。诸天及人有妒嫉结应倍护彼。凡夫人心非阿罗汉。凡夫起过非阿罗汉。彼近多闻为修闻故。亲说法者修行决定。近持律者调伏结使不堕犯中。亲近持于菩萨藏人。于学修行六波罗蜜及修方便。近阿练儿修学独处。亲近修行修学端坐。若有比丘未定位者。须衣施衣。须钵施钵。劝彼比丘发无上心。何以故。此非胜处财法摄彼。如是长者。在家菩萨如是善知沙门之行。若有沙门斗讼诤竞而和合之。舍于身命守护正法。长者。在家菩萨见病比丘舍自肉血令彼病愈。长者。在家菩萨未开施心。不先请他施已心悔。一切善本以菩提心而为上首。长者。在家菩萨住在家地如佛教行。不忘不失助菩提法。现法无染得增胜法。尔时郁伽长者。及诸长者。一切同声欢喜赞叹。希有世尊。善说在家过患。而犹未知出家戒行出家功德。世尊。我等亦观在家多过出家德大。唯愿世尊。哀愍我等愿得出家。说是语已。佛告长者。出家甚难一向净行。时诸长者。白言。世尊。实如圣教。唯愿世尊。听我出家当如教行。尔时世尊。即听出家。告弥勒菩萨。一切净菩萨。汝善丈夫令是等出家。时弥勒等。令九千长者悉皆出家。是长者等受出家戒。是时复有千长者等。发阿耨多罗三藐三菩提心。尔时郁伽长者。白言。世尊。已说在家过患功德。善哉世尊。愿说出家菩萨戒闻功德之行。云何菩萨善妙法中调伏出家。礼拜起住去来进止。佛告长者。善思念之。当为汝说。出家菩萨应如是学如是住行。唯然世尊。受教而听。佛言长者。出家菩萨应如是学。我以何缘舍业出家。为修慧故勤加精进如救头然。应作是念。我今应住于四圣种乐行头陀。长者。云何出家菩萨修四圣种。是出家菩萨随所有衣应生知足。叹美知足不为衣故而行妄语。若不得衣不想不念不生忧恼。设令得衣心不生着。虽服着衣而无系着不贪不住。知其过咎知于出离随是知足。不自称誉不毁他人。长者。出家之人随所乞食随所敷具。亦当知足而生叹美。不为敷具而起妄语。不得不念不生忧恼。得不染着无染心畜不吝不系。知其过咎知出离行随是知足。终不自称毁于他人。乐断乐离乐于修习。于此乐断乐离乐修不自称誉。长者。是名出家菩萨住四圣种。复次长者。出家菩萨以十功德持着身衣。何等十。为惭耻故。为覆形故。为蚊虻故。为风暴故。不为软触不为好故。为于沙门表戒相故。此染色衣。令诸人天阿修罗等生塔想故而受持之。解脱而染非欲染衣。寂静所宜非结所宜。着此染衣。不起诸恶修诸善业。不为好故着染服衣。知圣道已我如是作。于一念顷不持染结。长者。是名出家菩萨十事功德持着身衣。复次长者。出家菩萨见十事故。尽其形寿不舍乞食。何等十。我今自活不由他活。若有众生施我食者。要令安住于三归处然后受食。若不施食于是众生生大悲心。为彼众生勤行精进。令是众生所作办已后食其食。又我不违佛所教敕。为殖满足根本因故。依降伏慢积集无见顶因缘故。不为女人丈夫男女。共和合故平等乞食。于诸众生生平等心。集一切智庄严具故。长者。出家菩萨见此十利。尽寿不舍于乞食法。若有至心敬信来请。尔时应去。若有请者不至心请。观有自利利彼因缘即便应去。复次长者。出家菩萨见十利故。终不舍于阿练儿处。何等十。自在除去故。无我持故。舍卧具爱故。寂无爱故。处无可利故。阿练儿处舍身命故。舍众闹故。如来法中所作作故。寂定适意故。专念无留难故。长者。是名出家菩萨见十德利尽寿不舍阿练儿处。长者。若阿练儿欲听法故。有和上阿阇梨因缘事故。为问病故至村聚中。当作是念。今夜还去。若为读诵在房舍住。应作是念。我今故在阿练若处。住阿练儿处与法相应。于一切物无有诤想。于一切法无障碍想集法无厌。长者。出家菩萨在阿练儿处。作如是观。我以何缘住阿练儿处。非但空处名为沙门。是中多有不调不寂。不坚不相应。亦住是中。所谓獐鹿猕猴。鸟兽师子虎狼。贼旃陀罗。是等无有沙门功德。是故我应具阿练儿行沙门义利。谓系念不乱。得陀罗尼。修大慈大悲。五通自在。满六波罗蜜。不舍一切智心。修行方便。常以法施摄取众生教化众生。不舍摄法。修行六念。勤进修闻。系念修集正相应行。不证果智。守护正法信于业报。是名正见。断于一切妄想分别。是正思惟随所解法而为演说。是名正语。除尽业满。是名正业。断除结习。是名正命。勤趣于定。是名正进。不忘诸法。是名正念。得一切智知。是名正定。解空不惊。无相不怖。无愿不怯。心不执有。依义不依语。依智不依识。依法不依人。依了义经不依不了义经。长者。是名出家菩萨住沙门法。复次长者。出家菩萨不应亲近多人众中。我应舍彼我之善根。终不舍于一切众生故修于善根。长者。出家菩萨有四亲近。如来所许。何等为四。长者。出家菩萨亲近听法。是佛所许。亲近成熟一切众生。是佛所许。供养如来。是佛所许。亲近不舍一切智心。是佛所许。长者。是名出家菩萨四种亲近如来所许。长者。亲近是四勿亲近余。复次长者。出家菩萨住阿练儿处。应如是念。我以何故来在此处。我来至此为怖何事。畏谁故来。畏众闹故。畏亲近故。畏贪嗔痴故。畏狂慢故。畏恼热故。畏悭贪故。畏于色声香味触故。畏于阴魔烦恼魔死魔天魔故。无常常畏。无我我畏。苦中乐畏。不净净畏。心意识畏。现在捶打畏。我见畏。我我所畏。恶知识畏。利养畏。非时语畏。不见言见畏。不闻言闻畏。一念言念畏。不识言识畏。沙门垢畏。欲界色界无色界畏。一切诸道生死处畏。地狱畏。畜生畏。饿鬼畏。我今怖惧如是等畏。来至于此阿练儿处。不住在家愦闹众中。若不修行不修念处则不相应。脱是畏故来至此处。过去无量菩萨摩诃萨。一切皆住阿练儿处。解脱诸畏得于无畏。得无畏阿耨多罗三藐三菩提。未来菩萨亦复如是。住阿练儿处脱一切畏。得于无畏无上正道。现在菩萨摩诃萨亦复如是。住阿练儿处修行无畏。得于无畏阿耨多罗三藐三菩提。脱一切畏。是故我今欲得无畏脱一切畏。住阿练儿处。复次长者。出家菩萨住阿练儿处。无怖无畏应如是学。若有畏者皆由着我。皆由执我。我为初首。皆由爱我。起我见我想我持我妄想。于我守护于我。若住阿练儿处不舍执我。是为失利。长者。若住阿练儿处。无有我想。是住阿练儿处。无有见着。是住阿练儿处。不住我我所。是住阿练儿处。长者当知。无涅槃想。是住阿练儿处。况烦恼想。长者。谓阿练儿处者。不依着于一切诸法。不住诸法。于诸法无碍。不依色声香味触住。住一切法平等无垢。住善调心。弃一切畏住于无畏。住脱一切结流大河。住于圣种。住于少欲。住于知足易满易养。住充满智。住如闻修行。住于解脱。观空无相无作门故。住解脱知见。断系缚故。住于边际。顺因缘故。住所住已办。究竟净故。长者。犹如空处药木丛林不怖不畏。如是长者。出家菩萨住阿练儿处。应自生心犹如草木墙壁等想。犹如幻想。是中谁畏谁怖。是以应以无畏观身。此身非我非我所。无众生。无寿命。无人。无丈夫。无少年。所言畏者。空名无实。我今不应以无实生畏。如彼空处药木丛林无主无护。应如是知一切法已。如是善住阿练儿处。何以故。断忧诤故名阿练儿。无生无护名阿练儿。复次长者。出家菩萨住阿练儿处。应如是学。渐顺戒聚。次修定聚。住阿练儿处。集于慧聚。住阿练儿处。习解脱聚。住阿练儿处。生解脱知见聚。住阿练儿处。敷助菩提法。住阿练儿处。集于十二头陀功德。住阿练儿处。谛方便故。住阿练儿处。善知阴故。住阿练儿处。等法界故。住阿练儿处。削除诸入故。住阿练儿处。不忘菩提心故。住阿练儿处。观空无畏。故住阿练儿处。不失一切诸善根故。住阿练儿处。佛所赞叹。住阿练儿处。菩萨所赞。住阿练儿处。诸圣所誉。住阿练儿处。欲解脱者之所依故。住阿练儿处。欲一切智者应住是处。复次长者。出家菩萨住阿练儿处。以少许事满六波罗蜜。何以故。住阿练儿处。不惜身命。是名出家菩萨住阿练儿处修习满于檀波罗蜜。长者。出家菩萨住头陀戒。身口意戒。是名出家菩萨住阿练儿处修习满于尸波罗蜜。长者。云何出家菩萨住阿练儿。修习满于忍波罗蜜。于诸众生无嗔恚心忍一切智。长者。是名出家菩萨住阿练儿处修习满于忍波罗蜜。长者。云何出家菩萨住阿练儿处修习满于进波罗蜜。而是菩萨应如是学。我不离是处。要当得于无生法忍。长者。是名出家菩萨住阿练儿处。修习满于进波罗蜜。长者。云何出家菩萨住阿练儿处。修习满于禅波罗蜜。长者。出家菩萨住阿练儿处。舍于禅定教化众生修诸善根。长者。是名出家菩萨住阿练儿处。修习满于禅波罗蜜。长者。云何出家菩萨住阿练儿处。修习满于般若波罗蜜。长者。是出家菩萨住阿练儿处。应如是学。如我此身空处亦尔。如我此身菩提亦尔。如如无妄想。如空无妄想。长者。是名出家菩萨住阿练儿处。修满般若波罗蜜。长者。出家菩萨住阿练儿处。如是修满六波罗蜜。长者。出家菩萨成就四法。知阿练儿处。何等四。净戒多闻思惟相应如法修行。是名出家菩萨知住阿练儿处。复次长者。出家菩萨若结增上不应亲彼。住阿练儿处。应摧伏结。复次长者。出家菩萨住阿练儿处。应修五通。为化天龙夜叉乾闼婆故。复次长者。出家菩萨应如佛教住阿练儿处。是中我应满于一切清净之善。善法所勋。后至城邑聚落说法。长者。是名出家菩萨如是四法住阿练儿处。复次长者。出家菩萨从阿练儿处起。受法读诵。诣于和上阿阇梨所。上中下坐是我福田。不应懈怠是我自业。不嫉于彼应为彼使。应如是观。如来应供正遍觉。一切天世魔梵。沙门婆罗门。供养福田。佛是一切众生之父。佛不生心求于给使。我今欲学。我亦当为一切众生作于给使。我不求他为我给使。何以故。长者。若有比丘重于给使失法功德。若以财摄彼当云何。欲使我作故以财摄我。非为法故自失己信。若财摄给使无大报利。若向和上阿阇梨所。知其心意应如所作。莫令和上阿阇梨。不信于我不敬爱我。彼舍身命为赞诵法故。称满其意为功德利。舍于利养赞叹于法。长者。若是菩萨。于他人所受持读诵一四句偈。施戒忍进定慧相应集菩提道。于是师所为法恭敬。如上诸师受持文字章句偈颂。于无量劫应为彼使。不生谄伪一切供养。长者当知。不报其恩况不敬法。长者。若信起善念。念佛法僧。念于无漏。念寂调伏。于无量劫给侍。使令供养和上。犹不报满和上之恩。长者应如是知。长者当知。若闻法已有无量报得无量智。我应无量供养和上。复次长者。出家菩萨如出家法住。长者。云何名为如出家法住。是出家菩萨闻净戒已。应如是学修四净戒。何等为四。谓住圣种乐于头陀。不亲近于在家出家。不谄曲住阿练儿处。复次长者。出家菩萨闻净戒已。复应如是学四净戒。何等四。谓身净戒亦不得身。谓口净戒亦不得口。离于诸见发一切智心。长者。是名四净戒。复次长者。出家菩萨闻净戒已。应如是学于四净戒。何等四。离于我想。弃于我所。远断常见。解因缘法。长者。是名四净戒。复次长者。出家菩萨闻净戒已。应如是学于四净戒。何等四。谓阴无所有。界如法界。入如空聚。不住假名。长者。是名四净戒。复次长者。出家菩萨闻净戒已。应如是学于四净戒。何等四。知我不得我。闻觉于他令心清净。心不乐住一切法等。无有动摇。长者。是名四净戒。复次长者。出家菩萨闻净戒已应如是学于四净戒。何等四。所谓解空。不畏无相。一切众生起于大悲。入于无我。长者。是名出家菩萨四种净戒。复次长者。出家菩萨闻净三昧已。应如是学。何等净三昧。谓一切法无所有。无有二心。正业心。一处心。无动摇心。无戏论心。无乱闹心。无依止心。于心自在无有驰散。不住心界见心如幻。观一切法等如法界。无行无住。又亦无起不得内外。三昧同等住。如是法说名三昧。如是长者。是名出家菩萨观净定聚。复次长者。出家菩萨闻净慧聚。闻已应观。何等名为清净慧聚。是菩萨应如是修学。知于缘法分别智。辩智。疾智。众生智。摄外众生智。如是长者。出家菩萨观净慧聚。复次长者。出家菩萨应如是学。所谓慧者名无系缚。以无身故无所执持。无动无住。无形无相。无生无行。如虚空故。长者。若如是观名为菩萨住于出家。说是法时。八千众生。发阿耨多罗三藐三菩提心。是诸长者。得无生法忍。三万二千众生远尘离垢得法眼净。尔时郁伽长者。欢喜踊跃。以价直百千衣奉上供佛。白言。世尊。以此善根普施一切诸众生等。令诸在家菩萨摩诃萨。成就如佛所教戒法。诸出家菩萨愿令满足。一切诸法亦令满足如佛所教。世尊。云何在家菩萨。住在家地学出家戒。如是问已。佛告长者。在家菩萨具足五法。住在家地学出家戒。何等为五。长者。菩萨住在家地中。不吝一切所有财物。与于一切智心相应不望果报。复次长者。在家菩萨住在家地具净梵行。不习欲想况二和合。复次长者。在家菩萨至于空处修习四禅。以方便力不入正位。复次长者。在家菩萨住在家地。应极精进学于智慧。一切众生以慈相应。复次长者。在家菩萨住在家地守护于法。亦劝他人。长者。是名在家菩萨住在家地。具足五法学出家戒。尔时郁伽长者白言。世尊。我在家中如世尊教。当如是住增广佛道。诸出家戒我亦当学。尔时世尊。即便微笑。诸佛常法。若微笑时。种种色光。青黄赤白。从面门出。遍照无量无边世界上过梵世蔽日月光。还绕身三匝入如来顶。尔时阿难。见佛微笑。从坐而起。整于衣服。偏袒右肩。右膝着地。而白佛言。大德世尊以何缘笑。诸佛世尊非无缘笑。佛告阿难。汝今见是郁伽长者供如来不。欲修行法作师子吼。阿难白言。已见世尊。已见善逝。阿难。是郁伽长者。住在家地。是贤劫中。如来应供正遍觉出现于世。常在家供养恭敬是诸如来护持正法。常在家中住出家戒。广闻如来无上菩提。尔时大德阿难。语郁伽长者。汝见何利乐在家中有圣智不。答言。大德。不成大悲不应自谓我是安乐。大德阿难。菩萨摩诃萨。忍一切苦不舍众生。说是语已佛告阿难。是郁伽长者。住在家地。是贤劫中多化众生。非出家菩萨百劫百千劫。何以故。阿难。百千出家菩萨所有功德。不如是郁伽长者所有功德。大德阿难。白佛言。世尊。此经何名。云何受持。佛告阿难。是经名郁伽长者所问。亦名在家出家菩萨戒。亦名殷重给事师长品。阿难。若有菩萨得闻是经。是大精进非下精进住于梵行。百千万倍所不能及也。是故阿难。欲自住进。欲劝他进。欲自住于一切功德。欲劝他住。应听此经受持读诵。广为人说如说修行。阿难。我以是法付嘱于汝。受持读诵。何以故。阿难。此法具足一切功德。阿难。若有菩萨与是法相应。则不离与如来相应。阿难。若有菩萨离于是法则为离佛。若有菩萨离于是法。离受持读诵如说修行。是离见于一切诸佛。何以故。阿难。佛出世事皆于此经而显示之。阿难。假令三千大千世界满中大火。应从中过为正觉故。往听此经受持读诵如说修行。阿难。若令三千大千世界。满中七宝恭敬奉施。为闻此法受持读诵如说修行。阿难。若为过去一切诸佛起七宝塔。以一切供而供养之。阿难。若现在佛及声闻僧。以诸乐具尽寿供养。阿难。未来诸佛及诸菩萨。悉为奴仆及为弟子而供养之。不闻是经。不受不持。不读不诵。不转不住。离是等法。不名供养诸佛如来。阿难。若有菩萨闻于是经。受持读诵为他广说如说修行。而是菩萨已为供养三世佛已。何以故。阿难。如说修行则是如来调伏之法。说是语已。大德阿难。郁伽长者。乾闼婆。世间天人。阿修罗等。闻佛所说。皆大欢喜

大宝积经卷第八十二大宝积经卷第八十三

        大唐三藏菩提流志奉　诏译

    无尽伏藏会第二十之一

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众一千人俱。皆悉成就殊胜功德能师子吼。菩萨摩诃萨五百人。一切皆得陀罗尼门。辩才无碍证无生忍。住不退转具诸三昧游戏神通。善知众生心行所趣。其名曰日幢菩萨。月幢菩萨。普光菩萨。月王菩萨。照高峰菩萨。毗卢遮那菩萨。师子慧菩萨。功德宝光菩萨。一切义成菩萨。成就宿缘菩萨。成就愿行菩萨。空慧菩萨。等心菩萨。喜爱菩萨。乐众菩萨。战胜菩萨。慧行菩萨。电得菩萨。胜辩菩萨。师子吼菩萨。妙言音菩萨。能警觉菩萨。巧转行菩萨。寂灭行菩萨。如是等菩萨摩诃萨而为上首。复有释提桓因。四大天王。娑婆世界主梵天王及大威德诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。如是等无量诸大众俱。尔时电得菩萨。见诸大众寂然清净。诸大龙象皆悉已集。即从座起偏袒右肩。右膝着地合掌向佛白言。世尊。我有少疑今欲咨问。唯愿如来见垂听许

尔时世尊。告电得菩萨言。如来应正等觉。恣汝所问当为汝说。电得菩萨。白佛言。世尊。菩萨摩诃萨成就何法。能满众生一切所欲。不为诸过之所染着。随其根性方便引导。令彼众生身坏命终不堕恶趣。决定当得证于平等。处世无染犹如莲花。不动法界游诸佛刹。常不离佛不见色身。住三解脱不入正位。随众生欲严净佛土。于刹那顷速能成就阿耨多罗三藐三菩提。尔时电得菩萨摩诃萨即于佛前。以偈问曰

  无上人中尊　　无边知见者
  安住于共法　　利益诸世间
  等心视众生　　为世所依怙
  示诸邪正道　　令毕竟安乐
  积集胜功德　　犹如众宝聚
  世间智慧日　　三界应供尊
  愿说最上乘　　成就菩萨道
  面相如满月　　具足奢摩他
  开示寂静法　　能灭诸烦恼
  愿说菩萨行　　饶益诸众生
  佛刹并寿命　　色身与眷属
  三业及诸法　　一切皆清净
  唯愿如来说　　清净菩萨行
  云何降伏魔　　云何而说法
  云何不忘失　　唯愿为宣说
  云何勇进者　　遍入于生死
  安住一相中　　于法常无动
  云何诸佛所　　亲近而供养
  常观佛色身　　毕竟离诸相
  虽证三解脱　　如鸟飞空界
  未具诸功德　　终不入涅槃
  知诸根性欲　　随顺无所畏
  亦不生染着　　成熟彼众生
  先施世间乐　　后令发净心
  具足殊胜智　　证无上菩提
  如是深妙义　　唯愿如来说

尔时世尊。告电得菩萨摩诃萨言。善哉善哉。善男子。乃能问佛如是之义。利益安乐无量众生。摄受现在世间天人。及未来世诸菩萨等。是故电得。应当谛听善思念之。当为汝说。电得菩萨言。唯然世尊。愿乐欲闻。佛告电得。菩萨摩诃萨。有五种伏藏。大伏藏。无尽伏藏。遍无尽伏藏。无边伏藏。菩萨具足如是伏藏永离贫穷。即能成就如上所说殊胜功德。以少功力速疾当得阿耨多罗三藐三菩提。云何为五。所谓贪行伏藏。嗔行伏藏。痴行伏藏。等分行伏藏。诸法伏藏。电得。云何名为菩萨摩诃萨贪行伏藏。谓诸众生贪行相应。颠倒系缚。随行诸相种种分别。于色声香味触法等诸境界中。执着坚固耽乐昏迷。菩萨于彼诸众生等种种心行应如实知。彼诸众生何所乐欲。于何境界染习增强。具足成就何等信解。往昔曾种何等善根。于何乘中当得发趣。所有善根久如成熟。菩萨为断诸众生等一切欲故。令彼善心常相续故。审谛观察而为疗治。电得当知。众生根行差别难识。一切声闻辟支佛所不能知。何况凡夫及诸外道。是故电得。或有众生虽着诸欲。亦能成熟阿耨多罗三藐三菩提。或有众生才触欲境。或以染心发于语言。便得成熟无上明脱。或有众生。睹诸妙色心生欲染。彼色变坏即便觉知。欲恼便息深念无常。则能成熟无上明脱。或有众生虽见女人不生贪着。于后思念方起染心。想彼形容而生爱恋。或有众生于其梦中见可意色。心生贪着系念追求。或有众生闻女人声便生贪爱。有时暂见离贪染心。便得成熟无上明脱。是故电得。菩萨于是种种贪病及以贪药善巧了知。而于法界无有二相。于此迷惑法界众生起大悲心。电得。若贪嗔痴若法界智。无有少法而可得者。菩萨作是念言。如我所见是诸众生。于此无相自性空寂。假名安立和合法中。起于贪欲嗔恚愚痴。我当于此如实观察。为彼迷惑贪欲众生。住于大悲成满昔愿。不动法界以无功用智而成熟之。若有丈夫于彼女人。妄生净想起重贪染。菩萨即便示现女身。端正殊妙色相具足。珍宝璎珞种种庄严犹如天女昔所未见。随彼众生令其爱着。极贪恋已量彼堪任。方便拔其贪欲毒箭。以自在力还变女身。现其人前而为说法。令彼众生通达法界便没不现。若有女人于彼丈夫心生爱染。菩萨便为现丈夫身。乃至拔其贪欲毒箭。而为说法令入法界便没不现。电得。是诸贪行二万一千。及彼诸行八万四千。菩萨无功用智。出生无量亿千法门。开晓众生悉令解脱。而亦不念我为众生如是说法。亦无众生得解脱者。电得。譬如无热龙王。以业力故于其宫内出四大河。为诸众生水陆住者。夏时热恼而作清凉。润泽花果滋实五谷。令诸众生安隐快乐。而彼龙王不作是念。我今令此河水流出。已出当出。然于四河常自泛满为众生用。菩萨亦复如是。成就昔愿以无功用智说四圣谛。灭除一切生死热恼。普施人天圣解脱乐。而是菩萨亦不念言。我今说法已说当说。任运住于大悲之心。观察众生随应说法

复次电得。譬如帝释有十二那由他诸天女等。以彼帝释自在力故现其多身。令诸天女于彼欲乐皆得满足。各自念言。我今独与帝释欢娱。而是帝释实无所染。菩萨亦复如是。于诸众生应可度者。随其意乐而成熟之。然是菩萨亦无染着。复次电得。譬如日轮出山峰时。光明普遍照阎浮提。所照之处青黄赤白。种种形色皆悉显现。而彼日轮一色一光无差别相。菩萨亦复如是。智慧日轮照于法界。出彼众生执着山峰。所缘一相随其意乐而为说法。然于法界无有二相。电得。是名菩萨摩诃萨贪行伏藏。菩萨证得此伏藏已。或于一劫或过一劫。随诸众生种种意乐现无量身。以种种言词而为说法。然于法界亦无二相。复次电得。譬如真金由工巧力。随意所作种种璎珞庄严之具。其相各异而彼金性无有差别。菩萨亦复如是。善观法界随诸众生。种种意乐现无量身。以种种言词而为说法。然于法界亦无二相。是为常入法界一相。菩萨获得如是伏藏。能为众生种种说法。彼闻法已具足富有无尽圣财。生死贫穷悉皆永断

复次电得。云何名为菩萨摩诃萨嗔行伏藏。谓诸众生憍慢相应。计我我所住自他相。从久远来不修慈忍。嗔恚热恼自坏其心。于佛法僧不生忆念。嗔毒所覆迷惑于法。菩萨于彼多嗔众生。终不起于损害伤恼。唯作是念。奇哉众生愚痴迷惑。乃于诸法本性寂静。无垢浊无和合无违诤远离法中。颠倒相应妄生嗔恨。如是念已。住大悲心常自恳恻。设有支解其身分者。为欲调伏嗔行众生安住忍辱。若彼无量嗔行众生。互相违背心怀恚恨。是业成已当堕毒蛇恶趣之中。住忍菩萨以慈念力化此众生。能令不受恶趣之报。决定当得证于平等。是名菩萨善巧方便。灭除众生嗔恚之行

复次电得。菩萨若见嗔恼众生。作是念言。一切诸法本性清净。此诸众生随相而行妄生分别。于此平等无违法中而起嗔心。彼诸众生于法界性不能了知。若此众生见法性者。终不于他而生忿害。以不了知法界本性是故生嗔。菩萨于彼多嗔众生。倍增慈愍住于大悲。成满昔愿以无功用智。为坏众生嗔恚行故。开示演说种种法门。而亦不念我为众生除嗔说法。何以故。菩萨善观法界相故。是为菩萨安住法界。无差别相灭烦恼行。电得。譬如不除黑闇得现光明。亦非无能除黑闇者。如是黑闇及光明性。皆如虚空无有差别。菩萨亦复如是。依此法界无差别智。善巧说法摧灭种种嗔行众生。不于法界而作差别。电得。譬如日轮所出光明。随所照处皆日轮摄。菩萨亦复如是。为欲调伏灭除嗔行。所有言说皆是法轮。不于法界而作差别。如是嗔行二万一千。及彼诸行八万四千菩萨。成就无功用智。随彼众生种种嗔行。而为说法不作是念。我为众生今现说法已说当说。是名菩萨摩诃萨嗔行伏藏。菩萨证得此伏藏已。若于一劫若过一劫。随诸众生种种意乐。以种种文字语言方便演说。不能得其嗔行边际。而是菩萨智慧辩才亦不可尽。是名菩萨善说法界无差别相。获得如是嗔行伏藏

复次电得。云何名为菩萨摩诃萨痴行伏藏。电得。诸菩萨等如是之行甚为难事。谓诸众生随惑行者。恼害他者。无明胎[穀-禾+卵]所缠裹者。如蚕处茧自系缚者。于法界中无方便者。不善观察所应行者。着我见者。行邪道者。住钝行者。难出离者。为如是等迷惑众生。从初发心起大加行。不生疲苦亦无懈怠。如是思惟。应以何缘何等胜解云何说法。令此众生入菩萨行而得解脱。菩萨往昔善观法界。以无功用智住于大悲。知彼众生迷法界已。随力所堪而为说法悉令调伏亦不念言我今说法已说当说。以彼往昔誓愿力故善观缘起自然演出百千法门。断除众生无明业行令得解脱。电得。譬如良医善疗众病。先善综习医方诸论。才见病相皆悉了知。咒药所施无不除愈。菩萨亦复如是。善观法界以无功用智。为彼积集痴行众生。随其根性开示演说。百千法门悉令明了。电得。是名菩萨摩诃萨痴行伏藏。菩萨证得此伏藏已善观缘起。为如是等痴行众生。若于一劫若过一劫。随其性欲以种种文字语言善巧演说。不能得其痴行边际。而是菩萨智慧辩才亦不可尽。是名菩萨于一切法无差别相善巧宣说。获得如是痴行伏藏。如是痴行二万一千。及彼诸行八万四千。菩萨为断如是行故。开示演说百千法门是名菩萨痴行伏藏

复次电得。云何名为菩萨摩诃萨等分行伏藏。譬如四面镜轮。清彻明净无诸垢翳。悬于四衢所对色像。皆于中现无有增减。而此明镜亦不念言。我能现此种种色像。然善磨莹此镜轮已。一切诸相自然而现。菩萨亦复如是。法界镜轮善磨莹已。住无功用三昧。随诸众生心行差别。开示演说百千法门。悉令了知皆得解脱。不起法相及众生相。何以故。菩萨善观法界相故。于此四行相应众生如实了知。随其根性而为说法。而于法界及众生界。如实观察无有二相。尔所法界及众生界。明见无二无差别故。电得。譬如虚空无有种种差别之相亦无建立。菩萨亦复如是。善观法界了一切法入于一相。亦由往昔誓愿力故。随众生行种种说法。而于法界无有差别。电得。此等分行二万一千及彼诸行八万四千。菩萨观察悉皆明了。譬如良医知病授药。以无功用智种种说法。是名菩萨摩诃萨等分行伏藏。菩萨证得此伏藏已。为诸众生若一劫若过一劫。随其志乐以种种言词善巧宣说。不能得其诸行边际。菩萨智慧辩才亦不可尽。是名菩萨善说法界无差别相。获得如是等分行伏藏

大宝积经卷第八十三大宝积经卷第八十四

        大唐三藏菩提流志奉　诏译

    无尽伏藏会第二十之二

复次电得。菩萨成就如是智已。于诸众生根行意乐。善巧了知。若见多贪众生。为欲调伏疗其病故。示同凡夫现受诸欲。具有妻子家业资生。犹如莲花而不染着。有诸众生痴无智慧。不知菩萨善巧方便而作是念。何有智者贪受诸欲不异凡夫。便谓菩萨远离菩提。如是众生心不净故。起大嗔忿不生敬信由此业故身坏命终堕大地狱。复以菩萨密化因缘罪报毕已。决定当得入于平等。电得。譬如猛火随投草木。一切炽然悉成于火。菩萨亦复如是。智火炽然。所有众生。若贪嗔痴。若善不善。菩萨于彼与之同行。一切炽然皆成智慧。是名菩萨不共之法。又如须弥山王不共之相。所谓四面四宝所成。随诸众生青黄赤白种种色相。彼若往诣琉璃面者。皆同一色如彼琉璃。诣金色面皆如金色。银颇梨色悉皆同等。菩萨亦复如是。得不共法。随诸众生若贪嗔痴。若善不善。至菩萨所与之同行。一切皆令入菩萨智。彼心不净自恶业故。或堕地狱饿鬼畜生阎摩罗界。以是菩萨不共功德。及愿力故罪报毕已。决定当得阿耨多罗三藐三菩提。电得。过去无量无边阿僧祇劫五浊世时。有佛出现号曰宝聚功德声如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。时世寿命百二十岁。如我今日。彼诸众生极重贪欲。嗔恚愚痴烦恼覆蔽违逆父母兄弟朋友。不顺和上及阿阇梨。不知恩德。常怀毒害奸诈贼心互相破坏非理而行。于佛法僧不生敬信。悭吝鄙弊行饿鬼法。彼佛刹中有如是等。诸恶众生难可调伏。时彼世尊。亦以往昔誓愿力故。于此恶世。得阿耨多罗三藐三菩提。其佛复有二万二千大声闻众。彼时有王名曰广授。自在王化统阎浮提。于佛法中信心清净。请彼如来及比丘众。于夏安居广设供养。尔时有一法师比丘。名为无垢。具足辩才善巧说法众所乐闻。开示众生常不疲倦。凡所说法无有希求。容相熙怡先言问讯。色力具足颜貌端严。为诸众生之所乐见。供养恭敬尊重赞叹。复有新学年少比丘。常随无垢出入王宫无有障碍。种种供养衣服饮食卧具医药。时彼众中多有比丘。不知修习身戒心慧。不敬佛法及以众僧。常见断见及我见等。谤于佛法轻躁难调。不摄诸根住于非法。无沙门行自称沙门。身口意业悉皆邪僻。时彼世尊。过安居已便入涅槃。其王广授。以赤栴檀阇维供养。造立八十俱胝宝塔。以赤栴檀而为栏楯。四面皆有金色莲花。无垢比丘。佛所记别。多闻第一。于佛灭后弘宣正法。随所游行城邑聚落。教化无量百千众生皆令住于阿耨多罗三藐三菩提。尔时多有诸恶比丘。不知修行。常怀嫉妒。为魔所惑。诣彼王所而作是言。王所师敬无垢比丘。出入王宫无有禁制。而彼比丘未离贪欲。非时而食香鬘严身。实非梵行不应供养。我为此事来告于王。莫于过后佛正法中而生不信。时有一魔名为极恶。即自变身作比丘像。复诣王所如前重说。时广授王数闻此语。即作是念。无垢比丘精勤有智我所尊重。若有此事终无是处。作是念已。尔时魔众。于虚空中便现半身。向彼王所而说偈言

  王应学伎艺　　善识于机宜
  广授不能知　　非是人王相
  佛罗汉弟子　　已具于大智
  如是语不依　　云何随断见
  比丘为利益　　告汝以诚言
  断见恶趣人　　实非修梵行
  彼人于宫内　　共采女娱乐
  王应与侍从　　亲睹离疑心
  王闻如是事　　心生大惊怖
  即便将侍从　　速疾诣宫中
  无垢时在宫　　演说第一义
  诸法自性空　　无我无寿者
  王与诸兵众　　俱为魔所惑
  见宫中婇女　　围绕于比丘
  嗔猛如醉象　　便敕旃陀罗
  比丘污我宫　　当治以苦法
  臣佐及眷属　　皆为魔所持
  于无罪比丘　　随忿而生害
  魁脍持刀进　　无垢便悲泣
  王语汝非法　　何故而复悲
  无垢白王言　　是事难自表
  且待须臾间　　我当有明证
  王闻比丘言　　即止于魁脍
  当试作何事　　汝应速宣说
  成就胜意乐　　行慈利世者
  合十指爪掌　　而发于誓言
  大王汝当知　　若实无此事
  愿地六种动　　空中雨妙花
  当发如是言　　大地六种动
  空界雨天花　　魔众怀忧恼
  王时生净信　　礼足求欢喜
  我当堕地狱　　无依愿覆护
  咄哉遇此恶　　如何起毒心
  无覆无所依　　所从唯恶友
  十方我无护　　唯有于大师
  我当舍王位　　尽寿归依住
  比丘知彼王　　及眷属志乐
  为说第一义　　王闻得正信
  与百亿眷属　　舍王位出家
  修习头陀行　　不受他人请
  时王后宫内　　婇女八万人
  闻说第一义　　皆住不退转
  王依于佛教　　二十四年中
  日夜常忏悔　　罪业犹不尽
  百俱胝眷属　　恶心向法师
  由此命终后　　堕于无间狱
  多亿年受苦　　罪毕遇如来
  以昔恐怖因　　余报常羸劣
  次第转修习　　供养千亿佛
  各于余国中　　悉皆成正觉
  俱同一名字　　号功德名称
  时彼广授王　　慈忍比丘所
  由起毒害意　　于多亿岁中
  受昔恶业对　　堕大叫地狱
  毕此业报已　　还得于人身
  值普眼如来　　亲近常供养
  由此转奉事　　八十俱胝佛
  然后成正觉　　今则我身是
  彼比丘欲害　　无罪法师者
  当来得作佛　　弥勒菩萨是
  时彼王宫内　　八万诸婇女
  净信植众德　　承事无量佛
  于今复发行　　大愿利众生
  当奉千亿佛　　各成等正觉
  我今告汝等　　一切勿生害
  修慈佛所赞　　速得大菩提

是故电得。于诸众生根性志乐不能善知。应一切时勿生害心。电得。譬如诸山须弥为最。如来智慧亦复如是。于诸智中最尊无上。譬如一切诸水之中海为最胜。如来智慧亦复如是。于诸智中最为深大。又如诸国王中转轮圣王最为尊上。如来智慧亦复如是。于诸智中为无上上。电得。如来成就如是智故。一切众生贪嗔痴行心心转变如来悉知。一弹指顷皆能摄受。电得。如来成就一切种智。如明眼人自观掌中五庵罗果。不用功力明了无疑。如来亦尔。了知一切众生心行。于大众中种种说法。无量无边佛世界中贪行相应诸众生等。为贪热恼昼夜寻思虚过于时。我悉知见。为贪热恼起于身口种种之业。我悉知见。嗔行众生嗔忿覆心互相憎嫉。以毒害故堕无间处。我悉知见。痴行相应诸众生等。无明闇迷惑执着乐随邪见。我悉了知。有堪任者。不堪任者。有增进者。有退失者。于如来乘种善根者。于缘觉乘种善根者。于声闻乘种善根者。我悉了知。如来成就如是智慧。处大众中能了众生心行差别。知非时故默然舍住。但作是念。此诸众生于法迷惑不能解了。如来具足殊胜根力。善知时故。堪调伏者。胜志乐者。能堪忍者。受善言者。我悉了知。如是知已于彼众生摄受利益。是故电得。初业菩萨未入正位。于诸众生胜志乐行不能善知。若在家若出家。皆不应起嫌害之心。勿于长夜自致衰恼。是故菩萨从初发心。当于一切住大乘者生于佛想。于余众生虽复见彼作诸恶业。而亦不起损害之心。何以故。如来常说。若诸众生于白净法有少缺减。终不能得入于涅槃。菩萨若见贪行众生。应作是念。彼为贪欲热恼所烧。是我过咎。见彼嗔恚及以愚痴热恼烧者。皆悉念言是我之罪。何以故。我见一切众生病苦。应为求药方便疗治。我先誓愿除众生病。而今舍置是我过咎。菩萨成就如是意乐。自省其过。于诸众生深起慈心。若遇杀害割截身分。于彼怨所生反报心。无有是处。电得。菩萨如是正修行时。过去所有不善之业永尽无余。未来不善终不更起。电得。乃往古昔无量阿僧祇劫然灯佛前。有佛名胜生如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。世界名光明。在安隐王城林中而住。尔时有旃陀罗名为可畏。凶险好杀安忍无慈。手涂于血见者皆惧。时旃陀罗。系牛其舍方入欲杀。牛见惊怖掣绳奔走。往于胜生如来林所。时旃陀罗持刀随逐。彼牛惶怖坠于深坑。其命将终楚痛号吼。时旃陀罗见是牛已更增忿怒。便入坑中持刀欲杀。未下之顷。尔时胜生如来。于彼林中。无量百千大众围绕。广为分别缘起法门。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是因缘一切皆是纯大苦集。电得。于此缘中无明于行无思无觉。行于无明亦无思无觉。乃至生于老死无思无觉。老死于生亦无思无觉。如是诸法性不可得。无行无念无我我所。本性清净各不相知。凡夫不闻如是法故。执色是我。我有诸色。色属于我。乃至受想行识亦复如是。由此执着我我所故。无常计常。苦计为乐。不净计净。无我计我。生四颠倒。颠倒见故无明迷惑不正思惟。随心染着不能破坏。有爱系缚生死轮回相续不断。智者善观法界相故。不见有少我人众生。乃至寿命生老病死。系缚杀害而可得者。电得。尔时可畏旃陀罗。于是时中遥闻如来说法之声。即便觉悟寻止杀心。弃所持刀从坑而出。往诣佛所顶礼双足却住一面。白言世尊。我今愿欲于佛法中出家为道。佛言可尔。善来比丘即成沙门得具足戒。尔时胜生如来。知彼意乐渐已成熟。广为演说诸菩萨行。可畏闻已证无生忍。于佛法中永不退转。彼牛得闻如来所说缘起法句。其声微妙心生喜悦。命终之后生兜率天。得见弥勒成就正信。如是电得。诸众生行甚深微密难识难知。是故电得。菩萨欲求阿耨多罗三藐三菩提者。应当善知众生根行。于一切众生中住平等心无碍之心。于一切法常无染着。舍诸所有。修持净戒。安住忍辱。发起精进。入诸禅定。如实观察一切法性。电得。菩萨圆满如是六法。速能证得阿耨多罗三藐三菩提。云何圆满。所谓依止一切智智而修行故。电得。何者是诸菩萨法伏藏。所谓菩萨见一切色如实了知。本来不生自性清净。菩萨于色得善巧故。则能成就四无碍辩。何等为四。所谓义无碍。法无碍。词无碍。乐说无碍。义无碍者。于诸色义无挂碍故。云何色义。谓第一义。云何第一义。谓色不可得故。成就如是第一义智。名义无碍。法无碍者。于诸色法如实观察。如实了知。名法无碍。词无碍者。谓于诸色以无碍智。善巧言词种种分别。名词无碍。乐说无碍者。谓于诸色随众生机开示演说。无染无著。名乐说无碍。菩萨成就如是智已。普于一切迷惑执着色法众生。随其性欲以无功用智如应说法。而于法界不作二相。广说乃至香味触法亦复如是。电得。是名诸菩萨摩诃萨法伏藏。菩萨证得此伏藏已。为欲调伏于如是等诸境界中迷惑众生。随其意乐于一一处。若一劫若过一劫。以种种言词善巧宣说。亦不能得诸处边际。菩萨智慧亦无损减。不离法界随顺无二无差别故。是名菩萨善巧演说一切诸法无差别相。获得如是法伏藏已。能为众生如应说法。令得具足无尽法财。生死贫穷悉令永断。电得。是名菩萨摩诃萨五种伏藏。大伏藏。无尽伏藏。遍无尽伏藏。无边伏藏。菩萨成就如是伏藏。圆满殊胜诸功德故少用功力。速得阿耨多罗三藐三菩提。说此伏藏法门时。电得菩萨得陀罗尼。五百菩萨得电光明三昧。三万六千天子。发阿耨多罗三藐三菩提心。尔时月幢菩萨白佛言。世尊。如佛所说无功用智。是义云何。佛告月幢。若有菩萨于善法中身心相应攀缘造作。是名功用。若有菩萨身心调柔无念无依离修行相。以彼成就往昔愿智。亿千佛刹所可施为种种示现。而于法界亦无所动。常演说法无少法相。以四摄法成熟众生。亦无众生而可度者。严净一切诸佛刹土。而亦不见不净佛刹。常念诸佛不观色相。游诸佛刹不离法界。是名菩萨无功用智。菩萨成就如是智故。满足众生一切希望。而于所作亦无染着。尔时世尊说此无功用智时。三千大千世界六种震动。释提桓因与忉利天。于上空中雨曼陀罗花。优钵罗花。拘物头花。波头摩花。分陀利花。栴檀末香而散佛上。天鼓自鸣。大光遍照。昔未曾见。众生遇者身得清凉。尔时世尊告电得菩萨言。过去如来应正等觉。皆于此处开示演说如是法门。未来诸佛当出于世。亦于此处开示演说如是法门。现在无量阿僧祇世界中诸佛如来。为此法门不断绝故。放大光明。尔时长老阿难。从座而起。偏袒右肩。右膝着地。合掌向佛白言。世尊。当何名此经。我当云何奉持。佛告阿难。此经名为无尽伏藏。亦名说一切法无差别相。以是名字汝当奉持。佛说此经已。电得菩萨。长老阿难。及诸四众。一切世间。天人阿修罗。乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第八十四大宝积经卷第八十五

        大唐三藏菩提流志奉　诏译

    授幻师跋陀罗记会第二十一

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众千二百五十人俱。皆阿罗汉众所知识。菩萨摩诃萨五十人。得大神通变现自在。证无生忍及陀罗尼。其名曰师子菩萨。师子慧菩萨。妙栴檀菩萨。调御菩萨。大调御菩萨。光胜菩萨。光现菩萨。光威菩萨。光严菩萨。明觉菩萨。众上菩萨。调御众生菩萨。及贤劫中一切菩萨。弥勒菩萨摩诃萨。文殊师利法王子等。而为上首。复有四大天王释提桓因。娑婆世界主大梵天王。并诸无量天龙夜叉阿修罗乾闼婆紧那罗摩睺罗伽等众所围绕。如来世尊大名称故普闻世间。所谓如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。一切知者。一切见者。成就十力四无所畏。四无碍解。十八不共法。大慈大悲。五眼具足。记说神变。教诲神变。神通神变。皆悉圆满。能以三千大千世界大地城邑草木丛林须弥山等大海江河诸天宫殿。置一毛端令住虚空。或经一劫。或过一劫。随念所期而不倾动。时王舍城国王大臣。婆罗门居士。一切人民。皆于如来深生尊重。以诸上妙饮食衣服卧具汤药恭敬供养。于彼城中有一幻师名跋陀罗。善闲异论工巧咒术。于诸幻师最为上首。摩竭提国。唯除见谛之人及于正信优婆塞优婆夷等。诸余愚人皆被幻惑无不归信。时彼幻师。闻于如来功德名称。便生是念。今此城中一切众生。悉皆于我生尊重心。唯有瞿昙沙门犹未信伏。我今应当往彼较试。彼若归我。摩竭提人必皆于我倍加恭敬。时彼幻师。宿殖善缘成熟时至。及由世尊威德力故。从王舍城往耆阇崛山。睹佛光明踰百千日。面轮严好犹如满月。身相圆满如尼拘陀树。毫相清净如摩尼光。其目绀色如青莲花。乃至梵天无能见顶。以六十种清净音声为众说法。而此幻师虽睹如来威德特尊犹怀邪慢。复更念言。我今应当试验于彼。若是一切知见之者应知我意。作是念已。前礼佛足。而作是言。愿于明日受我微供

尔时世尊观彼幻师及王舍城诸众生等根熟时至。为成熟故默然受请。时彼幻师。既见世尊受其请已。复作是念。今此瞿昙不识我意。定知非是一切智人。即便辞退作礼而去。尊者目连。时在会中既睹斯事。前白佛言。此跋陀罗欲于如来及比丘众有所欺诳。唯愿世尊勿受其请。佛告目连。莫作是念。然贪嗔痴能为诳惑。我于是事久已断灭。证得诸法本无生故。我于长劫安住正行。何有人能欺诳我者。汝今当知。彼之所作非真幻化。如来所作是真幻化。所以者何。现证诸法皆如幻故。假使一切诸众生类。皆成幻术如跋陀罗。比于如来百分千分。乃至算数譬喻所不能及。复告目连。于意云何。彼之幻师颇能变现三千大千所有世界令严饰不。答言不也。目连当知。我今能于一毛端中。变现庄严恒沙世界。犹未尽于如来神力。目连当知。有大风轮名为碎坏。彼能破坏三千世界。复有风轮名毗岚婆。能坏世界。复能成立。复有风轮名为鼓动。彼风常能旋转世界。复有风轮名为安住。彼风能行有顶之处。复有风轮名为飘散。彼能飘散须弥山王及黑山等。复有风轮名为猛焰。劫火烧时能飘猛焰上至梵天。复有风轮名为止息。劫火烧时彼能止息劫火所烧。复有风轮名为清凉。能使一云普覆三千大千世界。复有风轮名为遍霔。劫火烧时普于世界降霔大雨。复有风轮名为干竭。劫水漂时能令彼水悉皆枯涸。如是风轮我若具说穷劫不尽。目连当知。于意云何。此之幻师能于如是诸风轮中暂安住不。答言不也。佛言目连。如来能于如是风轮。行住坐卧得无摇动。又复能以如是风轮内芥子中。现诸风轮所作之事。然于芥子无增无损。而诸风轮不相妨碍。目连当知。如来成就幻术之法无有限极

尔时尊者大目干连。及诸大众。闻于如来作是说时。生希有心顶礼佛足。同声唱言。我等今者遇大威德神通导师获大饶益。若有得闻如来世尊如是神力深生信解。此人必当获大善利发于阿耨多罗三藐三菩提心。时彼幻师即于其夜。诣王舍城于最下劣秽恶之处。化作道场宽广平正。缯彩幡盖种种庄严。散诸花香覆以宝帐。复现八千诸宝行树。其宝树下一一皆有师子之座。无量敷具悉皆严好。为欲供养诸比丘故。而复化为百味饮食。并现五百给侍之人。服以白衣。饰以严具。作是化已。时四天王来至会中。告幻师言。汝于明日为供如来。化作如是无量严具。由是因缘获大功德。我今为欲助于汝故。供养如来。于此化为第二道场颇能听不。时彼幻师闻是语已。生奇特心即便听许。于是四王。即便变现无量殊妙庄严之具。倍于幻师幻化之事。时天帝释。复与三万诸天子等。来诣道场语幻师言。我今亦欲因汝供养庄严道场。幻师惊悚又便听许。于是天帝为如来故化作堂宇。犹如三十三天殊胜之殿。又复化作波利质多。俱鞞陀罗。天妙树等。次第行列。幻师尔时见斯事已。嗟叹惊悔欲摄所化。尽其咒术幻化之事宛然如故。便自思念。此为甚奇。我从昔来于所变化隐现从心。而于今时不能隐没。必由为彼如来故然。时天帝释知彼心念。告幻师言。汝于今者为如来故。庄严道场无能隐没。以是当知。若复有人于如来所。乃至发于一念之心。由斯善本。毕竟能作般涅槃因。彼闻天帝作如是说。心甚欢喜过夜分已。往如来所。白言世尊。我于今时营办已讫愿垂哀愍

尔时世尊于晨朝时着衣持钵。与诸大众恭敬围绕。入王舍城赴彼幻师道场之所。摩竭提国外道梵志婆罗门等。咸愿如来为于幻师之所幻惑。为欲见故皆来集会。诸比丘比丘尼。优婆塞优婆夷。乐欲见闻如来神变及师子吼。亦皆集会。尔时如来以佛神力。令彼幻师帝释四王。各见世尊在于已所庄严之处。彼时幻师既见是已舍于憍慢。前礼佛足。白言世尊。今于如来悔过发露。我先于佛妄生欺诳。幻化种种庄严之事。后虽渐悔无能隐没。尔时世尊告幻师言。一切众生及诸资具皆是幻化。谓由于业之所幻故。诸比丘众亦是幻化。谓由于法之所幻故。我身亦幻智所幻故。三千大千一切世界亦皆是幻。一切众生共所幻故。凡所有法无非是幻。因缘和合之所幻故。汝今应以幻化饮食随次而行。时彼幻师。与四天王释提桓因。并来眷属。及所幻化给侍人等。即持饮食施佛及僧。同会众人悉皆充足。尔时摩诃迦叶而说偈曰

  知食是幻化　　受者亦复然
  了此平等时　　乃名为净施

大目干连曰

  知座是幻化　　坐者亦复然
  了此平等时　　乃名为净施

舍利弗曰

  如化给侍人　　受者心亦然
  施者能如是　　乃名为净施

须菩提曰

  勿以施为施　　勿以受为受
  施者能如是　　乃名为净施

阿难陀曰

  所施如虚空　　受者不可得
  远离于身心　　其施最清净

光幢菩萨曰

  譬如彼幻师　　幻化庄严事
  诸法皆如是　　愚人不觉知

光严菩萨曰

  如座及诸树　　皆幻心所为
  幻心与虚空　　何有少差别

师子菩萨曰

  野干未曾闻　　师子所哮吼
  其心无所惧　　嗥叫林树间
  适闻师子声　　藏窜而无所
  幻师亦如是　　不对如来前
  常于外道中　　自赞超过佛
  幻师虽造作　　幻术有其边
  如来所成就　　幻术无穷尽
  一切诸天魔　　莫能知边际

师子慧菩萨曰

  了知给侍人　　饮食并食者
  一切皆幻化　　善施无过上

弥勒菩萨曰

  如火得苏油　　展转而增盛
  世尊对幻师　　幻化亦如是

文殊师利菩萨曰

  此会众善事　　如本未曾为
  一切法皆然　　常等于前际

尔时世尊为欲成熟彼幻师故。化一长者入于会中。谓幻师曰。汝今于此欲何所作。幻师答言。我为供养沙门瞿昙设诸饮食。长者告言。莫作是说。如来今者与诸比丘。在阇王宫受供而食。佛神力故。令彼幻师见于如来与诸比丘在彼而食。又复化作第二长者。谓幻师言。汝何所作。幻师答言。我为供养沙门瞿昙。长者复言。莫作是说。如来今者与诸比丘。在于梵志里巷之中巡行乞食。佛神力故。令彼幻师还见如来与诸圣众在里巷中巡行乞食。又复化作第三长者。告幻师言。如来今者在彼医王耆婆园中。为诸四众宣说妙法。佛神力故。令彼幻师皆见如是。次复化作释提桓因。来诣幻师而复告言。如来今在三十三天为众说法。彼时幻师复见如来。在天众中演诸法要。尔时幻师复于林树花叶之间。及诸一切师子座上。并王舍城里巷垣墙。室宅堂殿及诸胜处。皆见如来具诸相好。亦于一切诸如来所。自见己身悔过发露。彼时幻师。唯见佛身余无所见。欢喜踊跃。而便获于念佛三昧。从三昧起合掌向佛。而说偈言

  我昔于阎浮　　幻化无过上
  今比佛神通　　无能及少分
  由是方了知　　诸佛难思力
  随心能变现　　化佛如恒沙
  所见诸如来　　皆具于相好
  愿尊为显示　　何者是真佛
  于此诸如来　　我欲修供养
  愿尊为我说　　何者为胜果
  若人于佛所　　不生尊重心
  如是诸凡夫　　退失于安乐
  今于世尊前　　发露先所犯
  妄试如来罪　　永愿灭无余
  梵释并大众　　愿皆证知我
  为度诸群生　　今发菩提心
  以智慧光明　　觉悟于世间
  施与甘露法　　悉皆令充满
  若人于佛所　　见如是神变
  及闻悦意言　　胜行无碍智
  何有明慧者　　不发菩提心
  愿示菩提道　　及遍清净行
  何等为修行　　二乘不能入
  云何所行处　　尊重而供养
  云何具威仪　　及离诸疑悔
  云何于多闻　　无厌修坚实
  云何为人说　　令乐于正法
  无希利养心　　及善知恩报
  云何于众生　　常为不坏友
  云何近善友　　舍离恶知识
  云何值诸佛　　供养心无倦
  云何为学处　　尊重及清净
  云何定种姓　　成就如理心
  及舍不如理　　具足正思惟
  云何无怯弱　　不为魔所摄
  思惟于义理　　不舍诸众生
  云何不应舍　　不取而摄取
  得入于正行　　具足善方便
  云何修慈悲　　成就诸神通
  证于无碍辩　　及得陀罗尼
  云何获法忍　　清净之辩才
  当舍应舍法　　得入甚深义
  云何于誓愿　　一切皆圆满
  于诸波罗蜜　　而得不退转
  我于如是法　　当愿勤修行
  唯愿大悲尊　　为我广宣说

尔时世尊以偈答曰

  若了一切法　　皆同于幻化
  是人则能现　　百亿诸佛身
  往于俱胝刹　　度脱诸众生
  譬如跋陀罗　　无色现众色
  不生亦不灭　　无住无去来
  世尊变化身　　及与比丘众
  亦无有生灭　　乃至于涅槃
  此皆是如来　　不思议神变
  亦如幻化者　　现象马军阵
  迷惑诸众生　　妄见为真实
  如是象马军　　无性亦无生
  诸佛无色相　　无去亦无来
  住于我见人　　妄生于佛想
  不应以色相　　种族及生处
  乃至梵音声　　而欲观如来
  亦难以心识　　分别于诸佛
  诸佛法性身　　超过于三世
  自性离诸相　　不堕于法数
  所现诸如来　　自性无生起
  亦无蕴界处　　住于无所依
  如是佛法身　　非五眼能见
  若谓我见佛　　是则不能见
  以无见为见　　如空中鸟迹
  如汝所见佛　　及余未见者
  平等如虚空　　一相无差别
  戒定慧解脱　　及解脱知见
  一切诸如来　　功德无差别
  皆住于空性　　于法无所著
  一切皆幻化　　无性亦无生
  供养一如来　　则供于多佛
  诸佛之法身　　平等无差别
  如是一切佛　　咸能生福利
  普施诸如来　　皆获于大果
  同证于平等　　清净之法性
  是故诸如来　　无种种差别
  如汝先所问　　何者为真佛
  当舍散乱心　　谛听我宣说
  应住正念慧　　观察于诸法
  一切皆无生　　妄见为真实
  色相若有生　　则应亦有灭
  是故诸如来　　毕竟无有生
  彼亦非己生　　亦无有散灭
  由是观如来　　以无见为见
  如汝所见佛　　不依止方所
  一切诸凡夫　　皆依于五蕴
  应当于彼蕴　　如佛而观察
  诸佛及诸法　　乃至于众生
  以无相为相　　无有依止者
  若作是观察　　速证于菩提
  诸法皆非有　　由妄分别生
  因缘体性空　　离作者性故
  如是能了达　　因缘作者空
  彼则能了知　　离染清净法
  以清净法眼　　得见诸如来

时彼幻师闻是说已得顺法忍。五千众生发阿耨多罗三藐三菩提心。二百菩萨证无生忍。尔时世尊饭食已讫。欲满幻师所施愿故。复说偈言

  能于所施物　　施者及受人
  等无分别心　　是则施圆满

尔时阿难白佛言。世尊。我等愿于如来以佛神力加持幻师。今所施设庄严之事。于七日中令不隐没。是时如来为众请故。令彼幻师幻化道场。满足七日严饰如故。尔时如来与诸比丘及大菩萨。天龙夜叉乾闼婆等恭敬围绕。还耆阇崛山为众说法。尔时幻师复往佛所顶礼佛足。右绕三匝却住一面。而白佛言。世尊。愿为演说诸菩萨道。勤修行者速当得至菩提道场。佛言。谛听善思念之。当为汝说。幻师白言。唯然世尊。愿乐欲闻。佛言善男子。有四种法。是菩萨道。若能修行速当得至菩提道场。云何为四。一者于菩提心永不退失。二者于诸众生常无弃舍。三者一切善根求无厌足。四者护持正法起大精进。善男子。菩萨复有四法遍清净行。云何为四。一者律仪清净。二者意乐清净。三者智慧清净。四者受生清净。复有四法。唯菩萨行。非彼二乘之所能入。云何为四。一者修习禅定而不随生。二者于甚深义心能简择。三者于诸众生起大悲心。四者种种辩才演法无碍。复有四法所行之处。云何为四。一者乐住闲寂。二者厌于愦闹。三者于诸众生起大慈心。四者能了诸行无有去来。复有四法尊重供养。云何为四。一者不惜身命。二者心常欢悦。三者舍离憍慢。四者如说修行。复有四法威仪具足。一者知时。二者知处。三者寂静。四者真实

复有四法能离疑悔。云何为四。一者于恶作事应预防护。二者于诸智人当乐亲近。三者于所闻义常善思惟。四者不以慈心不举他过。复有四法多闻无厌。云何为四。一者增长自他正智慧故。二者于他疑惑能断除故。三者于佛正法能摄受故。四者于诸如来赞无尽故。复有四法多闻坚实。云何为四。一者闻正法已能善解了。二者闻正法已不作诸恶。三者闻正法已为他开示。四者闻正法已回向菩提。复有四法说法利益。云何为四。一者常受他人香味饮食。二者恒受衣服种种供养。三者令魔眷属势力羸弱。四者诸天护持魔不得便。复有四法令他信乐所说之法。云何为四。一者心少欲故。二者常知足故。三者语柔软故。四者身顺法故。复有四法能演正法无有希望。云何为四。一者于生死中恒怀怖畏。二者不求世间利养亲友。三者于诸众生常生拥护。四者于诸圣种而能修习。复有四法知恩报恩。云何为四。一者劝诸众生趣菩提故。二者知所作业不失坏故。三者慈爱众生如己身故。四者善能修行菩萨事故。复有四法于诸众生为不坏友。云何为四。一者能被忍辱大甲胄故。二者福利众生不求报故。三者于大悲心常不退故。四者虽多恼害亦不舍故。复有四法于诸善友应当亲近。云何为四。一者成就善巧方便。二者成就殊胜意乐。三者成就菩萨正行。四者成就劝赞菩提。复有四法于诸恶友应当舍离。云何为四。一者赞说二乘。二者令退菩提。三者增长恶法。四者损坏诸善。复有四法得值诸佛。云何为四。一者恒以一心专念佛故。二者称赞如来诸功德故。三者所受律仪遍清净故。四者以胜意乐发弘愿故。复有四法供养诸佛心无懈惓。云何为四。一者应自庆快我今供养最上福田。二者由我供养一切众生亦当供养。三者因供养已于菩提心当得坚固。四者睹于如来三十二相善根增长。复有四法于诸学处生尊重心。云何为四。一者超过恶道。二者得生善趣。三者尊重如来。四者圆满诸愿。复有四法所应学处。云何为四。一者于菩提心常不舍离。二者于诸众生心行平等。三者于波罗蜜精进修行。四者闻无量法不生恐怖。复有四法学处清净。云何为四。一者不造诸恶。二者深解空性。三者不谤诸佛。四者灭坏诸见。复有四法三昧种姓。云何为四。一者离愦闹故。二者乐寂静故。三者心无乱故。四者善根增故。复有四法如理之心应当成就。云何为四。一者所修善法回趣菩提。二者心常宴寂无有执着。三者于解脱门常勤修习。四者曾不求证二乘涅槃。复有四法不如理心应当舍离。云何为四。一者于诸生死有所怖畏。二者于所修行不生信受。三者于秘密教不求胜解。四者于诸善根而不修习。复有四法正思惟心应善修学。云何为四。一者菩萨乃至为一众生。于无量劫受生死苦。二者应先了知一切众生根性差别。而为说法令舍烦恼。三者应当断一切恶。修一切善。降伏魔军。证于阿耨多罗三藐三菩提。四者当为三千大千世界无量众生。以一梵音演诸法要。复有四法无怯弱心魔不能摧。云何为四。一者观一切法犹如幻化。二者常与如理正智相应。三者于一切法无所分别。四者于一切相无所执着。复有四法思惟于义。云何为四。一者知一切法从因缘生。二者知无少法名为起者。三者知缘生法彼即无起。四者知法无生亦无灭坏。复有四法不舍众生。云何为四。一者不舍弘愿。二者忍于疲苦。三者不惜身命。四者恒修四摄。复有四法不应舍离。云何为四。一者于诸布施而不舍离。二者成熟众生而不舍离。三者常自觉察而不舍离。四者增长他善而不舍离。复有四法常应摄受。云何为四。一者微少善根亦当修习。二者增长他善心无懈怠。三者闻说施戒则能信受。四者不求一切利养名誉。复有四法入于正行。云何为四。一者成就通智。二者住大三昧。三者修习空性。四者无所执着。复有四法善巧方便。云何为四。一者菩萨于诸发心。以菩提心而为上首。乃至烦恼犹令顺趣无上菩提。何况发起诸善心等。二者观诸众生乃至住于邪见之者皆为法器。三者了知诸法无有自性。四者修习解脱于三昧门无执着想。复有四法修大慈心。云何为四。一者修大慈心救护众生。二者修大慈心度脱众生。三者修大慈心觉悟众生。四者修大慈心为令众生入涅槃故。复有四法修大悲心。云何为四。一者修大悲心为令众生离诸恶道住善趣故。二者修大悲心为令众生舍诸恶行习善法故。三者修大悲心为令众生离于小乘入大乘故。四者修大悲心为令众生离于生死得涅槃故。复有四法成就神通。云何为四。一者不惜身命无爱恋故。二者了一切法如幻化故。三者于诸众生起尊重故。四者修奢摩他无散乱故。复有四法得无碍辩。云何为四。一者随顺于义不随于文。二者随顺于法不随于人。三者了达诸法离于文字。四者依了文字演说无尽。复有四法得陀罗尼。云何为四。一者于诸多闻无有厌足。二者于多闻者恭敬供养。三者以种种名说真实义。四者随秘密教能正趣入。复有四法能得法忍。云何为四。一者多修胜解。二者无有退转。三者资粮圆满。四者精勤无倦。复有四法得净辩才。云何为四。一者于说法人无所违逆。二者尊重法师恭敬听受。三者不以多闻而自憍慢。四者于少闻者不生轻贱。复有四法应当舍离。云何为四。一者于贪嗔痴应当舍离。二者于声闻乘应当舍离。三者于缘觉乘应当舍离。四者于善法相应当舍离。复有四法入甚深义。云何为四。一者于有为法深达缘起。二者于秘密义能正了知。三者于诸法性深生正解。四者于一切法了达空义。复有四法令愿圆满。云何为四。一者尸罗清净。二者净除恶业。三者无有谄诳。四者增长善根。复有四法。于诸波罗蜜而得不退转。云何为四。一者以善巧方便能于一波罗蜜遍通诸波罗蜜。二者以善巧方便随了一众生遍了一切众生。三者以善巧方便证于一法清净遍证一切诸法清净。四者以善巧方便了知一佛。遍能了知一切诸佛。何以故。由于法性无差别故

佛说如是。菩萨四法门时。幻师跋陀罗。证无生忍心怀踊悦。即升虚空其身去地七多罗量。尔时世尊熙怡微笑。从其面门放无量光。其光普照诸佛世界。还于如来顶上而没。尔时尊者阿难。作是念言。如来应正等觉。现此微笑非无因缘。即从座起。偏袒右肩。右膝着地。合掌向佛。以偈问曰

  普闻三界遍知尊　　威德智处难思者
  已达菩提功德岸　　今现微笑有何缘
  十方五趣诸众生　　心行种性上中下
  如来于彼悉能了　　今现微笑有何缘
  人天八部诸大众　　所出种种妙音声
  比于如来清净音　　乃至不及歌罗分
  世尊光明遍十方　　普照无量诸佛刹
  日月摩尼梵天光　　无有能比如来者
  已了性空甚深法　　无我无人及众生
  有无二边皆舍离　　善知三际如水月
  今谁趣于最上乘　　绍继如来法种性
  生于广大三宝中　　微笑因缘愿宣说
  如来所现微笑光　　为彼诸乘有差别
  于膝于肩而没者　　如斯为彼二乘人
  今者所放无量光　　此光入于如来顶
  天中胜者为何人　　于此佛乘当授记

尔时世尊告阿难言。汝今见是跋陀罗不。白言已见。佛告阿难。此善男子。过于九万二千劫。于大庄严土善化劫中。当得成佛。号曰神变王如来应正等觉。彼佛国土人民炽盛安隐丰乐。地平柔软如兜罗绵。花果诸树次第行列。幢幡宝盖以为庄严。众乐自鸣妙香充遍。所须饮食应念而至。诸所受用资生之具。如忉利天而无有异。彼国常现种种庄严。是故号为大庄严土。于彼国内一切人民。皆住大乘深信坚固。彼神变王如来。寿十千岁。正法住世满百亿年。临涅槃时。授名称菩萨阿耨多罗三藐三菩提记告言。汝于来世。次当作佛。号一切最胜如来应正等觉。时跋陀罗。闻于如来如是记已。从空而下顶礼佛足。而作是言。我今归命如来应正等觉及法比丘。如是殷勤无量俱胝数百千遍。复作是言。如佛世尊。以于真如无有异故。说一切法不异真如。乃至无有差别。无有缺减。无有分别。无生无作。我今归依亦复如是。尔时尊者阿难。谓跋陀罗言。汝若如佛所说真如而归依者。汝今岂于佛法性中有所得耶。幻师答言。我身即是如来法性。所以者何。我及如来无二无别。一切诸法皆真如故。言真如者。则一切法无差别性。一切众生亦复如是。尊者当知。言无二者无所分别。是为无二。何以故。遍知诸法但有名字是佛智故。尊者阿难前白佛言。奇哉世尊。此跋陀罗。乃有如是智慧辩才。昔以幻化惑乱世间。今时复以智慧惑乱。佛告跋陀罗言。善男子。汝实尔耶。跋陀罗言。如佛所作惑乱之事。我亦如是惑乱世间。所以者何。谓佛世尊于无我中说有众生及寿命者。此于世间是大惑乱。如于如来证菩提已不见少法是生死往来而说生死往来。如我意者唯有如来是大惑乱。佛言善男子。善哉善哉。如汝所说。诸佛如来于无我中乃至无有生死往来。而随世俗说众生等。亦无少法名为涅槃。然为证得涅槃法故说于涅槃。时跋陀罗闻是说已。前白佛言。我愿出家作于比丘。尔时世尊告弥勒菩萨摩诃萨言。汝当与是善男子剃除须发授具足戒。弥勒菩萨承佛教旨即与出家。受于具戒既出家已。复白佛言。世尊。此出家者唯形相耳非真出家。若诸菩萨真出家者。谓离诸相处于三界成熟众生。方可名为真出家也。说是语时五千众生发阿耨多罗三藐三菩提心。皆于诸漏心得解脱。尔时阿难白佛言。世尊。当何名此经。我等云何奉持。佛告阿难。此经名为授幻师跋陀罗记法门。亦名渐证菩提法门。若有众生于未来世欲见如来及为众生作佛事者。当于此经受持读诵广为人说。所以者何。是人则为已见如来。亦已为他施作佛事。是故阿难。若于此经受持读诵流通之者。则为哀愍利乐众生。若欲发趣无上菩提。亦于此经当勤修习。此经能出无上菩提。此经能生无上菩提。是故此经亦复名为出生菩提。若有受持此经典者。当知诸佛止住其身。何况于中如理修行。时跋陀罗复白佛言。世尊。此经亦名发觉善根。何以故。今于佛所得闻是经一切善根皆现前故。佛说是经已。尊者阿难及跋陀罗天人大众阿修罗乾闼婆等。闻佛所说皆大欢喜信受奉行

大宝积经卷第八十五大宝积经卷第八十六

        大唐三藏法师菩提流志奉　诏译

    大神变会第二十二之一

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人俱。菩萨摩诃萨八千人。文殊师利。与商主天子俱在会中。尔时商主天子白佛言。世尊。如来常以几种神变调伏众生。佛告天子。我以三种神变调伏众生。一者说法。二者教诫。三者神通。云何名为说法神变。所谓如来无碍大智。见未来世一切众生心行差别。于三宝所有信不信。及业果报皆悉了知。如佛所说。若现在世所行恶因当堕恶趣。随业受报决定无差。若彼众生善业因缘誓愿力故。从恶趣出生人天中。或以声闻辟支佛乘及以大乘。而得解脱。经尔所劫受苦受乐。当得涅槃。当得值遇若干诸佛。如是等业决定无差。若彼众生善业因缘誓愿力故。当生欲界色界无色界。经尔所劫。以如是乘而得解脱。以如是行当得见佛承事供养。如是一切上中下品善不善业。乃至一念。如来悉知而为说法。是名说法神变。云何名为教诫神变。若如是教诸持戒者。是应作是不应作。是应信是不应信。是应亲近是不应亲近。是法杂染是法清净。乃至摄受一切功德善道资粮。行如是道得声闻乘辟支佛乘。行如是道成就大乘。非法应离。如法应住。如佛所教决定无差。是地狱业是傍生业。是饿鬼业是人天业。不善应舍。善法应修。此是圣道应如是学。此等众生人天往返渐入涅槃。如是示教终不空过。是名教诫神变。云何名为神通神变。若为调伏憍慢众生。或现一身而作多身。或现多身而作一身。山崖墙壁出入无碍。身上出火身下出水。身下出火身上出水。入地如水履水如地。日月威德以手扪摩。或现大身至于梵世。乃至广大。遍覆三千大千世界。随所应现调伏众生。是名神通神变

尔时商主天子白佛言。世尊。颇有神变能过此耶。佛告天子。如来复有殊胜神变。即语文殊师利。汝可演说令诸菩萨得深法忍摧伏众魔。亦令如来菩提之法久住于世。文殊师利白佛言。世尊。如来若以三千世界四大海水置于掌中。水性众生无所娆动。如是神变未为殊胜。若如来于一切法不可言说。无名无相。无色无声。无行无作。无文字。无戏论。无表示。离心意识。一切语言道断寂静照明。而以文字语言分别显示。一切世间所不能解。沙门婆罗门闻者惊怖。是名诸佛最大神变。复次如来。若以三千大千世界。内于口中。于四天下无所障碍。日月光明亦不隐蔽。如本而住。其中众生。亦不觉知往来方所。世尊。如是神变未为殊胜。若如来于一切法不可说。无文字无名相。乃至离心意识。一切语言道断寂静照明。而以文字语言宣说显示。是名诸佛最大神变。复次如来不共之身神通力故。随诸众生种种示现。悉令欢喜。如是神变未为殊胜。所谓如来大神变者。无我说我。无众生说众生。无人说人。无养育说养育。无名说名。无色说色。无受想行识说受想行识。无处说处。无界说界。虽说眼空眼不言空。虽说色空色不言空。说眼识空识不言空。乃至意空及以法空。意识空等亦复如是。说如是等。无名无相无动无知无言之法。摧灭一切生灭之相。是则如来最大神变。如是神变。不与眼相应。不与色相应。不与眼识相应。不与耳声耳识。鼻香鼻识。舌味舌识。身触身识。意法意识相应。如是神变。不与身合。不与心合。无行无作离诸境界。一切世间所不能信。何以故。言世间者。名为五蕴。凡夫于此妄生执着。或说蕴常。或说无常。以是义故。一切世间妄见蕴常。闻说无常不能生信。妄见蕴乐。闻说蕴苦不能生信。妄见蕴我。闻说无我不能生信。妄见蕴净。闻说不净不能生信。计蕴我所。说无我所不能生信。计五蕴实。闻说不实不能生信。以是义故。如来神变出过心相。闻者不欣。一切世间所不能信。复次超眼境界非色法故。是名神变。超耳境界非声法故。乃至超意境界非意法故。不可显示非智所知。是名神变。复次空无相愿不可言说。而说于空无相无愿。是名神变。无起无作无性无相无生无灭。本来涅槃不可言说。而说涅槃。是名神变。复次布施清净净三轮故。是名神变。何等为三。谓离我相及众生相。不念菩提。持戒清净。是名神变。所谓身口意业无所作故。忍辱清净是名神变。刹那坏灭无所著故。精进清净是名神变。无去无来身心不动故。禅定清净是名神变。心无所依内外寂静故。智慧清净是名神变。照明诸法灭一切见故。复次法无出相说出离法。是名神变。法无差别文字分别。是名神变。法无所行说有修行。是名神变。法无来去说有来去。是名神变。于一道证建立诸果。是名神变。于一味法分别三乘。是名神变。一切诸佛唯是一佛。说无量佛是名神变。一切佛土唯一佛土。说无量土是名神变。无量众生即一众生。说无量众生是名神变。一切佛法唯一佛法。说无量法是名神变。法不可示显示诸法。是名神变。法无所得修习作证。是名神变

尔时商主天子。白文殊师利言。如我所解仁所说义。于一切法所有言说。悉名神变。文殊师利言。如是如是。一切言说实无所说。名大神变。说是法时。一万二千天子。发阿耨多罗三藐三菩提心。五百菩萨得无生法忍

尔时长老舍利弗。语商主天子言。汝闻此神变不惊怖耶。天子答言。我即神变云何惊怖。舍利弗言。天子以何密意而作是言。天曰。一切诸法。若善不善无动而动。名大神变。是故舍利弗。作善业者。生于天上有大威德。如是善业不可思议。一切众生往来生死。亦不可思议。不可思议者名大神变。如佛所说。四种境界不可思议。一者业境界不可思议。二者龙境界不可思议。三者禅境界不可思议。四者佛境界不可思议。以是义故。说一切法名大神变。不应惊怖。复次舍利弗。若如来说此神变。虚空界宁有怖耶。答言不也。天曰。若虚空不怖。云何问言汝不惊怖。舍利弗言。汝岂同虚空耶。天曰。如佛所说。若内空外空是虚空不。答言如是。天曰。是故一切众生是虚空性。舍利弗言。天子。如汝所说。不久亦当现此神变。何以故。超过一切境界。是大神变故

尔时舍利弗。白佛言。世尊。此商主天子。往昔供养诸佛世尊及文殊师利。乃能成就如是辩才。佛告舍利弗。如是如是。如汝所说。是文殊师利之所成熟。舍利弗。乃往古世过无量劫。有佛名等须弥如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。国名安乐。劫名欢喜。舍利弗。彼佛世界。一切众生具足安乐。乃至无有少苦恼声。彼佛国土四宝所成。金银琉璃及以颇梨。地平如掌。清净柔软如天妙衣。无诸难处。天人充满。安隐炽盛快乐无量。是故名为安乐世界。彼佛法中纯是菩萨。精进勇猛智慧光明。得修多罗王陀罗尼。辩才无尽善巧方便。分别说法神通智慧。摧破恶魔解脱无碍。成就定忍。善知根性应病与药。具大福德智慧资粮。为诸众生不请之友。以神通力遍游佛刹。入智行海。安住施戒智慧多闻。无边善根方便回向。住于十力四无所畏一切佛法。游戏三昧诸禅解脱。彼佛世尊。以如是等诸大菩萨而为眷属。于彼世界。有转轮王名净庄严。正法化世。王四天下。七宝具足。王有千子。悉发阿耨多罗三藐三菩提心。净庄严王及其后宫。亦皆已发阿耨多罗三藐三菩提心。彼等须弥如来寿七十俱胝岁。尔时净庄严王。于百千岁中。承事供养彼佛如来及菩萨众。衣服饮食一切乐具。王与千子及其后宫。得清净信。爱法欢喜更无异心。常于佛前手自供养。亲近听法过百千岁已。时王千子及以内宫。获得四念。何者为四。一者念佛菩萨。二者念施。三者念戒。四者不忘菩提之心。得此念故。若昼若夜常得见佛及诸菩萨。后于一时。净庄严王及其眷属。为听法故往至佛所。时彼如来。为欲教化诸菩萨故。于大众中现种种神变。尔时净庄严王。前白佛言。世尊。颇有神变能过此耶。佛告大王。如来复有殊胜神变。所谓了知过去已灭。现在不住。未来未生。无心心所。而说三世心心所法。于一味中说三解脱。于一灭证说四圣谛。开示诸法空无相愿。成熟颠倒苦恼众生。说无相无为。成就菩提。于不取不舍。说檀波罗蜜。于无住无作。说尸波罗蜜。于无我法。说羼提波罗蜜。身心寂静。说毗离耶波罗蜜。不乱不摄。说禅波罗蜜。离彼此岸。说般若波罗蜜。无所动念而行方便。离依怙相修习于慈。以无作法修习于悲。以离欣悦而修于喜。以不住法而修于舍。以无所见起于天眼。无所闻故起于天耳。无所攀缘起他心智。离于前际起宿命智。身心不动起于神足。不住于法修于念处。以无生灭修四正勤。非根说根。非力说力。诸法寂静说菩提分法。无差别修八圣道。不住寂静修奢摩他。远离法相修毗钵舍那。本来寂灭而说涅槃。彼佛世尊。为净庄严王千子眷属。说此神变法时。八万四千众生。发阿耨多罗三藐三菩提心。净庄严王及以千子证于法忍。以佛神力。即于佛前。以偈赞曰

  如须弥山　　映于大海　　如来威光
  蔽诸大众　　如日初出　　破一切闇
  世尊毫相　　遍照佛刹　　如月圆满
  光明炽盛　　佛德圆满　　慧光普照
  譬如莲花　　不着于水　　佛处于世
  无所染着　　如师子王　　吼于林野
  人中师子　　吼于性空　　说一切法
  非有非无　　令离边见　　名师子吼
  于一切相　　若生若灭　　说无生灭
  名师子吼　　分别此岸　　或示彼岸
  不住诸法　　名师子吼　　分别二相
  是染是净　　诸法性净　　名师子吼
  贪嗔痴行　　从分别生　　不起分别
  名师子吼　　说生死法　　无常无我
  从颠倒起　　名师子吼　　生死涅槃
  本来寂静　　是大菩提　　名师子吼
  诸见所缚　　流转世间　　开示性空
  名师子吼　　如来导师　　所现神变
  悉能开示　　名师子吼

  于一切违顺　　其心不倾动
  常住于平等　　名随顺法忍
  随顺佛所说　　甚深寂静法
  亦不于中证　　名随顺法忍
  远离诸过恶　　增长于善法
  于中无所著　　名随顺法忍
  说诸法空声　　及一切见声
  二俱无所著　　名随顺法忍
  无边佛法声　　种种烦恼声
  不起声分别　　名随顺法忍
  于施戒多闻　　精进及定慧
  如法而修行　　名随顺法忍
  不舍菩提心　　平等观一切
  清净菩提道　　名随顺法忍
  如来自意语　　开示诸佛法
  于此无疑惑　　名随顺法忍
  若我证菩提　　当大师子吼
  演说此神变　　如今佛所说
  我于不思议　　无上大福田
  已植于种子　　终无有退转
  假令大地坏　　大海悉枯竭
  我所种善根　　永无有退失
  了知众生心　　其性如虚空
  深植菩提种　　得无边福德
  如我今志乐　　唯佛能证知
  天人乾闼婆　　无有能知者
  我今终不求　　诸天胜妙报
  我当得智慧　　如佛人中尊
  我于百千岁　　亲近供养佛
  发趣菩提故　　修此无边业
  我今与千子　　及后宫眷属
  愿常供养佛　　为成熟菩提
  我今得善利　　善见于诸佛
  善得闻此法　　爱乐于菩提
  若爱乐菩提　　则为爱乐法
  怜愍众生故　　不舍于佛乘

尔时众中有菩萨名法速疾。语净庄严王言。大王。汝不随顺如来神变。亦非发趣无上菩提。何以故。大王。菩提者住于法界。不来不去无知无行非色非相不取不舍。如画虚空无所触碍。本性清净。大王。菩提者入一切处。诸法平等故。菩提无分别离诸相故。菩提寂静止息相故。菩提性净离计着故。菩提不动无杂乱故。大王。菩提者名心平等。无所起故。菩提者名众生平等。本无生故。菩提者名不生生。因缘无性故。菩提者不可显示。离心意识故。大王。菩提无所行。过诸境界故。菩提无戏论。离寻思相故。菩提为空性相空故。菩提无相离一切相故。菩提无愿无所住故。菩提无作。无业报故。菩提无为。离三相故。大王。菩提者性相如是。若于此法有所愿求。徒自疲劳。何以故。如菩提性菩萨应行。能如是行名为正行

尔时净庄严王。白法速疾菩萨言。愿为我说菩萨正行。法速疾言。大王。舍诸所有是菩萨行。众生平等无分别故。头陀学戒是菩萨行。戒性平等无所行故。离嗔热恼是菩萨行。忍性平等无心相故。坚固勇猛是菩萨行。精进平等离心行故。三昧解脱是菩萨行。禅定平等无所缘故。闻慧资粮。是菩萨行。慧性平等无所念故。生于梵住是菩萨行。染净平等二俱离故。起诸神通是菩萨行。神通平等不生念故。具足辩才是菩萨行。法义平等离心相故。成就胜解是菩萨行。法界平等无所动故。修七觉分是菩萨行。观照平等不懈怠故。起四摄法是菩萨行。诸法平等同其事故。等心众生是菩萨行。心性平等无分别故。庄严佛土是菩萨行。清净平等如虚空故。三十二相是菩萨行。观法无相入平等故。净身口意是菩萨行。离于三业性平等故。随喜众生是菩萨行。一切众生等无我故。不厌生死是菩萨行。了知如梦性平等故。常修善业是菩萨行。知业平等无业报故。坚固修行是菩萨行。观一切法如幻化故。安忍众苦是菩萨行。了知平等苦不生故。亲近善友是菩萨行。于友非友心平等故。勤修深心是菩萨行。果报平等无所求故。多闻无厌是菩萨行。说法听法俱平等故。不悭吝法是菩萨行。平等说法不希求故。摄受正法是菩萨行。平等成熟诸佛法故。常求实智是菩萨行。第一义谛性平等故。谦下其心是菩萨行。等心谦下诸众生故。普摄一切诸善功德是菩萨行。功德平等无所念故

尔时净庄严王。闻说如是诸菩萨行。欢喜踊跃生爱乐心。即脱衣服严身之具。与法速疾菩萨。时王千子亦各脱身庄严之具。用上菩萨。作如是言。愿令一切众生成菩萨行。得是辩才。我等今者快得善利。得见如是真善知识。恭敬供养。尔时速疾菩萨。告净庄严王。汝所供养甚为下劣。当知复有殊胜供养。时法速疾菩萨。以偈颂曰

  大千界众生　　皆发趣菩提
  假令尽一劫　　男女以奉施
  若人发道意　　以信而出家
  随佛而修学　　其福胜于彼
  过去未来世　　一切诸如来
  无有不舍家　　得成无上道
  三世一切佛　　称赞出家法
  若乐供养佛　　当依佛出家
  设满恒沙界　　珍宝供养佛
  不如一日中　　出家修寂静
  彼则近菩提　　摧破魔军众
  出家不放逸　　白法恒增长
  不坏众善根　　远离诸烦恼
  舍于家业累　　顺道圣所赞
  舍家离恼缚　　除恼离魔缚
  心解行无染　　不久证菩提

尔时净庄严王。闻此偈已。于自在王位一切爱欲。皆悉舍离。即白佛言。世尊。我愿于佛善法律中。出家受戒时。等须弥如来告言。大王。出家无患我常劝赞。乐着居家非我所许。汝于王位犹有爱者。我当教汝如法而住。尔时净庄严王告千子言。汝等谁能绍继王业。诸子咸言。我等亦乐出家。愿垂听许。父王告言。汝等若悉出家。此四天下国土人民谁当养育。若汝等大悲坚固。应为作王普令众生安住善法。时千子中有一王子。名念大悲。即以偈颂。答父王言

  父王于佛法　　所得诸功德
  我悲受王位　　亦当如是学
  我常修梵行　　尽形持八戒
  我当不饮酒　　不涂饰香花
  身去庄严具　　不卧金床座
  足不蹑金屣　　首不饰宝冠
  不着天妙衣　　不观诸妓乐
  不玩奇鸟兽　　不从宫女人
  周巡四天下　　宣行十善道
  呵责家过患　　赞叹出家法
  舍自在憍慢　　亲近佛法僧
  不退菩提心　　常厌于三界
  以施爱利益　　同事摄众生
  普令于大乘　　悉当得成熟
  昼夜六时分　　当往于佛所
  为听闻法故　　供养彼如来

尔时等须弥如来。赞念大悲王子言。善哉善哉。善男子。汝见平等法故。住于大悲出家正信。于在家菩萨最为殊胜。与出家功德等无有异。尔时净庄严王。即立念大悲绍于王位。与九百九十九王子。从佛出家。既出家已。等须弥如来。为说如是神变之法。于后不久获五神通。得念总持多闻智慧。时念大悲。于十五日受灌顶位。亦以是法。为四天下一切众生。宣示教化。九十二俱胝众生。发阿耨多罗三藐三菩提心。悉于等须弥如来法中。出家修道。住于大乘得不退转。舍利弗。汝观是法无量功德。成熟一切善根众生。舍利弗。彼净庄严王者。岂异人乎。今商主天子是也。法速疾菩萨者今文殊师利是也。彼千子者此贤劫中千佛是也。念大悲王子者我身是也。舍利弗。是诸菩萨深心正行不放逸故。得阿耨多罗三藐三菩提。说此往昔修行法时。三万二千天人。发阿耨多罗三藐三菩提心

尔时舍利弗。语文殊师利言。仁与商主天子。久修梵行。多供养佛种诸善根。文殊师利言。大德。夫梵行者名八圣道。是有为法。我即无为。是故我不久修梵行。夫梵行者名有所行。我无所行。是故我不久修梵行。又梵行者名为二相。我无二相。是故我不久修梵行。又梵行者名灭烦恼。我无烦恼亦无所灭。是故我不久修梵行。驰骋五欲。说于梵行。我于五欲本无所行。是故我不久修梵行。超过魔道名为梵行。我常安住诸魔道中。是故我不久修梵行。成就善法名为梵行。我于善恶都无所得。是故我不久修梵行。声闻缘觉所住正位。名为梵行。我无所证。是故我不久修梵行。修涅槃道名为梵行。我于涅槃无所愿求。是故我不久修梵行。复次舍利子。汝所说我多供养佛。汝谓如来可供养耶。所以者何。如来非色亦不可见。云何而得供养如来。如来非受息一切受。如来非想离一切结。如来非行毕竟无作。如来非识出过心意。云何可得供养如来。复次如来行于性空。非眼色界。住无相际非耳声界。离于二相非鼻香界。无可知相非舌味界。无障碍相非身触界。入于平等非意法界。云何可得供养如来。又如来者名为法界。名曰如如入于实际。住于大空。不动本性。断诸戏论。无所攀缘。不住于识。不依三界。亦不住于今世后世。常寂极寂。离身口意。无形无相。无毁无誉。无漏无失。犹如虚空遍一切处。云何可得供养如来。复次舍利弗。如汝所说种诸善根。此善根者非身见根。非贪嗔根。非颠倒根。非五蕴六入七识住根。非八邪九恼十不善根。彼善根者。非戒学根。非心学根。非慧学根。非正趣道根非明解脱根。非四谛六通根。非九次第定。十无学根。非五根五力。七菩提分。八圣道根。又善根者。非结使根。非障碍根。非恶作根。非生灭见根。非断常见根。非我见人见众生见寿者见根。非蕴魔烦恼魔死魔天魔根。彼善根者。非妄念根。非无明根。非行识名色六入触受爱取有生老死忧恼根。彼善根者。非欲界色界无色界根。非布施持戒忍辱精进禅定智慧根。非慈悲喜舍根。非声闻缘觉所证之根。菩萨善根者。所谓心无所住一切智根。无自作他作根。忍辱调伏根。庄严身口意根。大慈大悲根。成熟一切众生根。摄受一切法根。成就一切佛法根。不断三宝种根。舍一切所有不求果报根。积集众善不求释梵根。发大精进不乐小乘根。修习禅定不味着根。以无所舍行智慧根。遍入诸行修方便根。具足十力四无畏根。得陀罗尼无碍辩根。获神通力净佛土根。趣菩提树转法轮根。时文殊师利。说此三种决定义已。一切大众咸称善哉。以种种花。散于世尊及文殊师利上。作如是言。若佛刹中无文殊师利。佛不出世。非文殊师利。不能成熟一切众生广大善根。若有得闻文殊师利所说法门。不惊不怪。远离一切魔业障碍。于此大乘得清净光明

大宝积经卷第八十六大宝积经卷第八十七

        大唐三藏菩提流志奉　诏译

    大神变会第二十二之二

尔时世尊。于大众中。赞商主天子。善哉善哉。如汝所言。天子。汝闻文殊师利所说神变。而能了知于余神变。更无惊怖。何以故。一切世间大惊怖者。所谓于常想中说无常想。于乐想中说于苦想。于我想中说无我想。于净想中说不净想。于有想中说于无想。于诸见中而说空想。寂静想中说于无想。于三界中说无愿想。于我我所说无著想。若于是中不惊不怖。是则名为住正调伏。何以故。若生惊怖。则于是法不能受持。所谓执着于我及以我所。若无执着则无所住。无所住则无所动。无所动则无来去。无来去则无所受。无所受则无所取。无所取则无颠倒。无颠倒则无邪见。无邪见则无正信。无正信则无正见。无正见则无正定。无正定则无乱心。无乱心则无住处。无住处则无建立。无建立则无识相。无识相则无思惟。无思惟则无所得。无所得则无攀缘。无攀缘则无分别。无分别则不见自他。不见自他故则无相续。无相续故则无热恼。无热恼故则无烦恼因。无烦恼因故得见光明。见光明故则得智慧。得智慧故得广大心。得广大心故魔不得便。摧伏魔故则无障碍。无障碍故。则为现前得一切佛法。如是天子。于一切法无生无作。开示演说。是则名为说大神变

尔时舍利弗。白文殊师利言。如我所问。仁者皆以秘密说耶。文殊师利言。舍利弗。一切诸法。文字合集假名安立。文字无尽。随乐而说诸法无性。如应得解。舍利弗。一切法自性离。无积集无所见。但随乐欲如应演说。而此法者。无所从来亦无所去。不在方不离方。无集无散。若以文字说一切佛法一切众生法。不从身出不从心出。从因缘生。如彼文字无有积集。心心所法亦无积集。如心心所无有积集。一切烦恼障碍亦无积集。如烦恼障碍无有积集。智慧亦无所积集。是故烦恼智慧二俱舍离。烦恼智慧无所住故。是则名为说大神变

尔时商主天子。白文殊师利言。何等是菩萨智。文殊师利言。苦智不厌诸蕴故。集智积集善根故。灭智示有生故。道智离恶道故。因智所作不坏故。缘智断生死故。佛智令入证故。缘生智无所著故。蕴智除蕴魔故。界智法界平等故。处智善观空聚故。施智无非时故。戒智摄诸破戒故。忍智守护众生故。精进智作善业故。禅定智不离定心故。智慧智了知诸法故。方便智成熟众生故。慈智拔诸有故。悲智无疲倦故。喜智爱乐法故。舍智成就佛法故。观察智住念处故。正勤智顺平等故。神足智无作用故。信根力智离一切着故。精进根力智摧破一切烦恼故。念根力智不失念故。定根力智一切法平等故。慧根力智知诸根性故。菩提分智自然觉故。道智拔诸恶趣故。尽智善根无尽故。无生智得无生忍故。念佛智成就佛身故。念法智转法轮故。念僧智入平等众故。念舍智不舍一切众生故。念戒智圆满一切愿故。念天智离一切恶故。众生根智了知无量故。圆满智于戒无缺故。众生药智如实相应故。处非处智不见处故。十力智摄诸声闻缘觉故。无畏智了知障非障故。过去世无碍智无所著故。未来世无碍智一切法无所趣故。现在世无碍智无所住故。一切众生受无量身智从语言生故。一切众生言音差。别智从心生故。一切众生心所动智能觉了故。无过失智了知一切众生过失故。无卒暴智能息一切诸斗诤故。不失念智安住乱心众生故。摄众生智摄诸懈怠故。佛不共智知应化故。大方便智依般若故。天子。是名诸菩萨智。以是智故。当得如来无碍大智

尔时商主天子。白文殊师利言。希有希有。是菩萨智。于三界中最为殊胜。不可以少庄严而能成就。若能发生是智慧者。为大神变。文殊师利。云何菩萨。能于此法具足庄严。文殊师利言。天子。若闻一切众生本来寂灭。不生惊怖。是名菩萨具足庄严。天子言。文殊师利。云何名菩萨。答言。若行菩提而无所住是名菩萨。又问云何名摩诃萨。答曰。已度诸行圆满大智。为摩诃萨。又问云何说为殊胜众生。答曰。以智慧故不着于法。以方便力摄受一切。是故说为殊胜众生。又问云何名为清净众生。答曰。不与一切烦恼住故。为除众生烦恼病故。发大精进。是名清净众生。又问云何名为极清净众生。答言。若为度脱一切众生。净修道品。是名极清净众生。又问云何菩萨为世导师。答曰。若能安住所行之道。成熟无量无边众生。是名导师。又问云何菩萨住于调伏。答曰。若于所应调伏众生。能令安住究竟调伏。是名调伏。又问云何菩萨而得勇猛。答曰。若能成熟一切众生。摧破魔怨令出生死。是名勇猛。又问云何菩萨难可沮坏。答曰。若能成满往昔誓愿。不求声闻缘觉道证。是名菩萨难可沮坏。又问云何菩萨胜出一切。答曰。以智方便护持正法。成熟众生。一切天人靡不瞻仰。是名胜出。又问云何说法。答曰。依佛所说摧灭一切众邪异论。是名说法。又问云何说律。答曰。自住于戒。能断众生烦恼恶业。是名说律。又问云何具足利益众生。答曰。所集善根回向一切。是名具足利益众生。又问云何直心。答曰。于贪恚痴谄曲众生。不生恚碍。又问云何不谄。答曰。所言诚实。又问云何离诳。答曰。谛思后言。又问云何离慢。答曰。于一切众生不起贡高。又问云何大施。答曰。所集难得。无上菩提犹施众生。何况世间所有之物。又问云何具戒。答曰。乃至失命终不舍于菩提之心。又问云何为忍。答曰。能忍逼迫不逼恼他。又问云何精进。答曰。简择诸法无少可得。又问云何禅定。答曰不见欲界。又问云何智慧。答曰。无所分别。又问云何住慈。答曰。观众生界空无所有。云何住悲。答曰。知诸法空而不舍精进。云何住喜。答曰住大寂乐求法无厌。云何住舍。答曰。不染世法能救世间。云何身清净。答曰。随意生身。于一切众生平等示现。云何语清净。答曰。凡所说法终不空过。悉能满足一切众生。云何意清净。答曰。一切众生所有心念。于一心中悉能了知。云何天眼。答曰。能见一切色相光明。而无所著。云何天耳。答曰。闻一切声离诸声相。云何他心。答曰。了知诸心生灭流注。云何宿命。答曰。不动实际了知前际。云何神通。答曰不动魔业摧破诸魔。云何调伏。答曰。能调一切难调伏者。云何为护。答曰。不为诸根之所扰乱。云何调顺。答曰。一切诸法所不能动。云何寂静。答曰。处烦恼火而不为烧。度烦恼者而演说法。云何净信。答曰。若说佛身是色相法。终不信受不为所坏。云何菩萨善巧方便。答曰。若见众生烦恼过失。等于菩提。是名菩萨善巧方便。说此法时。万二千众生。发阿耨多罗三藐三菩提心。五百菩萨得无生法忍

尔时世尊赞言。善哉善哉。文殊师利。善能演说诸菩萨行。则为已摄一切菩萨无量功德

尔时商主天子。白文殊师利言。仁于往昔。恭敬供养几佛世尊得是辩才。文殊师利言。譬如幻人心数已灭。天曰众生心相尚不可得。何况幻人而有心灭。答曰。诸佛如来性相如是。我依是法供养如来。天曰。仁者行檀波罗蜜为久近耶。答曰。如佛所化人。若有问言久近行檀波罗蜜。当云何答。天曰。无可答也。文殊师利言。我亦如是。云何乃问久近行耶。天曰。汝住悭耶。答言。如是。又问汝意云何。答曰。我不舍佛法及一切众生。是故为悭。天曰。如文殊师利所说义者。亦破戒耶。答言如是。天曰。汝意云何。答曰。夫破戒者则堕恶趣。我为度脱苦众生故。入恶趣中。故名破戒。又问汝起害心耶。答言如是。天曰。汝意云何。答曰。夫害心者名为不爱。我于烦恼及以二乘。都无所爱故名害心。又问汝懈怠耶。答言如是又问汝意云何。答曰我不起身口意业。无所进求。不取不舍故名懈怠。又问汝散乱耶。答言如是。天曰汝意云何。答曰。夫散乱者。非谓不住解脱心耶。天曰如是。答曰。我为成熟一切众生。不住解脱。故名乱心。又问汝无智耶。答曰如是。又问汝意云何。答曰。夫无智者。同诸愚惑不怖生死。岂不尔耶。天曰如是。答曰。我于生死不惊不怖。为欲成熟愚惑众生。同其事业故名无智。天曰。汝为世间堪供养者。答曰。我于一切生杀害心。又问汝意云何。答曰。我杀害彼贪欲嗔痴故。为世间堪供养者。天曰。如汝所说。令诸世间悉当惊怖。答言。天子若实际惊怖则世间惊怖。何以故。一切世间即实际故。又问若复有人谤毁此说。当何所至。答曰。当至涅槃。又问以何意耶。答曰。圣解脱中无有文字。是故毁于言说。得至涅槃。以是义故一切诸法。本来解脱不复解脱。又问是义云何。答曰。已解脱者宁更解脱。又问谤正法者。岂不入地狱耶。答曰。若已解脱则离诸垢。云何趣地狱耶。天曰。文殊师利。如汝所说无赞助者。答曰。空无相愿中何所赞助。又问修空行者当何所住。答曰。当住于慈。所以者何。众生如幻自性空故。天曰。文殊师利。云何了知诸众生界。答曰。见一切众生。从因缘起不断不常。是故遍知众生界也。又问众生界者为何义耶。答曰。众生界者即是法界。又问云何法界。答曰。自性空界名为法界。又问何谓空界。答曰。超过一切境界是虚空界。又问何等是超过界。答曰。是佛境界。又问何谓佛境界。答曰。眼界是佛境界。然佛境界。非眼眼色眼识境界故。耳界是佛境界。然佛境界。非耳耳声耳识境界故。乃至意界是佛境界。然佛境界。非意意法意识境界故。色界是佛境界。然佛境界。非色境界故。受想行识界是佛境界。然佛境界。非受想行识境界故。无明界是佛境界。然佛境界非无明界故。乃至老病死界是佛境界。然佛境界。非老病死境界故。欲界是佛境界。无贪相故。色界是佛境界。非对除贪故。无色界是佛境界。非无明见故。无为界是佛境界。无二相故。有为界是佛境界。非三相故。天子。是名佛境界。如是境界入一切界。若边无边皆悉摄受。菩萨善入是境界故。常行世间一切境界。超过魔界。佛界魔界如实了知。寂静平等。是则名为最大神变。复次菩萨不住平等。以平等法成熟众生。云何平等及非平等。一切诸法自性空寂。如是了知名住平等。不能入于诸法性空。名非平等。菩萨成熟如是众生。而亦不住空平等故。一切诸法。无愿平等。无作平等。无生平等。无灭平等。离染平等。寂静平等。无性平等。灭平等。涅槃平等。彼不了知是平等法。菩萨成熟如是众生。而亦不住于平等故。是故菩萨不住平等。不离平等。是菩萨行

尔时商主天子。白文殊师利言。愿为我说诸菩萨行。文殊师利言。天子。菩萨行者。不可思议。天子言。云何菩萨行不可思议。文殊师利言。贪行是菩萨行。贪不可思议故。嗔行是菩萨行。嗔不可思议故。痴行是菩萨行。痴不可思议故。悭吝是菩萨行。无施想故。不毁戒是菩萨行。不取戒相故。不恚害是菩萨行。无忍想故。不懈怠是菩萨行。离精进念故。不散乱是菩萨行。不住定故。离愚痴是菩萨行。不作智想故。无烦恼是菩萨行。无所断故。无贪爱是菩萨行。离身相故。悲愍心是菩萨行。舍女人慈故。无染污是菩萨行。呵责五欲故。离非法是菩萨行。积集善根故。无吝惜是菩萨行。舍身命故。灭诸恶是菩萨行。无热恼故。无所著是菩萨行。离爱非爱故。无所坏是菩萨行。正观烦恼故不怖畏是菩萨行。入无边生死故。大精进是菩萨行。荷负一切众生故。不退转是菩萨行。成满昔愿故。众宝行是菩萨行。摄三宝故。一切行是菩萨行。勤修助道法故。无障碍是菩萨行。离二边故。无过失是菩萨行。智者所赞故。安住心是菩萨行。念一切众生故。无分别是菩萨行。等观一切故。善丈夫是菩萨行。荷担无倦故。勇猛是菩萨行。摧破一切烦恼故。坚固是菩萨行。所作不中废故。胜出是菩萨行。精进不退故。随顺是菩萨行。于诸同侣无违逆故。欢喜是菩萨行。于行恶者令欢喜故。信乐是菩萨行。见佛闻法事师欣悦故。金刚甲胄是菩萨行。不毁律仪故。庄严佛土是菩萨行。净其心故。超过一切是菩萨行。入最上乘故。知恩报恩是菩萨行。不断佛种故。智慧方便是菩萨行。摄受无断故。说此菩萨行时。五百菩萨得无生法忍

尔时商主天子。白文殊师利言。快哉。善说此菩萨行。若诸菩萨能如是行。则为已受如来记别

佛告天子。如是如是。汝如所言。我昔得此行时。然灯世尊与我授记。我时获得无生法忍。是名如来最大神变。若久成就清净业者。乃能修习此菩萨行

尔时商主天子。白佛言。世尊。云何名无生。云何当得此无生忍。佛言。无生者。非先有生后说无生。本自不生故名无生。非先有起后说无起。本来不起故名无起。非先有相后说无相。本来无相故名无相。非先有作后说无作。本自无作故名无作。非先有众生。后说于空。众生性空故说为空。如是了知无生无灭本无所染。是名无生。云何为忍。如是忍可。一切众生一切刹土本来不生。是名为忍。如是忍可。一切声闻辟支佛本来不生。是名为忍。如是忍可。一切菩萨一切诸佛本来不生。是名为忍。如是忍可。一切诸法本来不生。是名为忍。天子。以诸法不生故。刹那刹那空。以刹那空故名为无相。刹那无相故色刹那空。色刹那空故受想行识刹那空。识刹那空故界刹那空。界刹那空故处刹那空。若刹那空则无所有。无所有故则无所染。无所染故则自性离。自性离故。是名一切法本来寂静。能如是忍入于平等。是则名为得无生忍受菩提记。得此忍者为无所得。云何名为有所得者见我我所二相可得。名有所得。见众生寿者养育我人二相可得。名有所得。何谓无所得。见我自性及我所性。了知无二。名无所得。是则名为成就于忍。天子。菩萨于无数劫修行此忍。是名如来最大神变。说此忍时。三千大千世界六种震动。大光遍照一切世界。百千音乐不鼓自鸣。于虚空中雨众妙花。四万二千众生。皆发阿耨多罗三藐三菩提心。九万菩萨得随顺法忍。以佛神力。令此娑婆世界。如然灯佛入莲花城时。等无有异

尔时世尊。即便微笑。无量百千种种色光。从佛口出。遍照无量无边世界乃至梵世。日月光明悉不复现。绕佛三匝还从顶入

尔时慧命阿难。即从座起偏袒右肩。右膝着地合掌恭敬。即于佛前。而说偈言

  我问光庄严　　光明无与等
  破诸烦恼闇　　微笑何因缘
  摧破众魔怨　　降伏诸外道
  我问十力者　　何缘现微笑
  如来殊妙色　　具三十二相
  十方所尊敬　　微笑何因缘
  智海智慧树　　开导诸群生
  功德无有边　　何缘现微笑
  名称遍三世　　离垢具三明
  已度三解脱　　何缘现微笑
  破生死医王　　足下辋轮具
  金刚身不坏　　微笑何因缘
  谁能具此忍　　谁修此净行
  志求佛功德　　由是尊微笑
  导师所示现　　是必有因缘
  善哉演梵音　　令众咸欢喜

佛告阿难。我说此法门时。七万二千众生。发阿耨多罗三藐三菩提心。三万二千菩萨获无生忍。阿难。汝见是商主天子不。阿难白言。唯然已见。佛言。阿难。此商主天子。已曾供养无数诸佛。劝发无量众生。于阿耨多罗三藐三菩提。阿难。此商主天子。过三百阿僧祇劫。当得阿耨多罗三藐三菩提。号功德王光明如来应正等觉明行足善逝世间解无上士调御丈夫天人师佛世尊。国名清净。劫名无垢。其土皆以七宝所成。地平如掌。有八阶道宝网弥覆。种种庄严。彼佛刹土。无有声闻辟支佛名。及余外道勒迦波利罗婆若迦等。无诸魔事坏正法者。亦无八难及诸非法苦恼之声。随心所念饮食自然。彼土众生衣服珍玩。犹如他化自在诸天。身皆金色三十二相。住阿耨多罗三藐三菩提。是故名为清净世界。彼功德王光明如来。寿四十小劫。彼佛法中有六十二俱胝菩萨。以愿力故随佛涅槃。阿难。若有菩萨。发阿耨多罗三藐三菩提心。得如是忍。一切当生清净世界为功德王光明如来。授阿耨多罗三藐三菩提记

尔时会中。有天子名曰观察。以天曼陀罗花散如来上。作如是言。若功德王光明如来。成无上道时。我当生彼清净世界。为转轮王。承事供养彼佛世尊诸菩萨众。次补佛处。得阿耨多罗三藐三菩提

佛告阿难。此观察天子。当于彼功德王光明如来法中。作转轮王名曰善见。以无量供具。恭敬供养彼佛如来。具足圆满助菩提法。当于彼土成阿耨多罗三藐三菩提。号普光明如来应正等觉。阿难。彼善见王。立其长子绍王位已。于彼佛所出家修道。彼佛世尊临涅槃时。便与授记。此善见菩萨。于我灭后。次当得成阿耨多罗三藐三菩提。佛授记已便入涅槃

尔时舍利子。告商主天子言。如来已授汝菩提记。天子言。大德。如佛所化人而与授记。我亦如是。如真如性不增不减。如来授记。亦无增减

尔时世尊。告阿难言。如是法门。汝当受持广为人说。利益安乐无量众生。摄受未来诸菩萨故。阿难白佛言。世尊。我已顶受。当何名之。云何奉持。佛告阿难。此经名为说大神变。亦名文殊师利所说密语。亦名商主天子所问。如是受持。阿难。若善男子善女人能于此经信受读诵为他广说。则为已摄一切功德。佛说此经已。慧命阿难并余比丘商主天子。及无量无边阿僧祇那由他诸天子等。文殊师利。及无量阿僧祇十方世界诸来集会菩萨摩诃萨众。及一切世间天人阿修罗等。闻佛所说。欢喜奉行

大宝积经卷第八十七大宝积经卷第八十八

        元魏优禅尼国王子月婆首那译

    摩诃迦叶会第二十三之一

如是我闻。一时婆伽婆。在舍婆提城祇树给孤独园。与大比丘僧五千人俱。菩萨摩诃萨八千人俱

其名曰文殊师利菩萨。观世音菩萨。大势至菩萨。德藏菩萨。弥勒菩萨。如是等菩萨摩诃萨。而为上首

尔时世尊与百千大众。恭敬围绕而为说法。尔时摩诃迦叶在大众中。从坐而起。偏袒右肩。右膝着地合掌恭敬白佛言。世尊。我欲少问如来应正遍知。若佛听许乃敢咨问。佛告迦叶。恣汝所问。如来悉能为汝分别。断汝疑心令得欢喜

尔时摩诃迦叶白佛言。世尊。若有善男子善女人。欲求涅槃于正法中出家。当云何学。云何行。云何修观。尔时世尊。告摩诃迦叶。善哉善哉。迦叶。汝今善能问于如来如是之义。如汝所问。为利一切诸天世人令得安乐。汝今谛听善思念之。吾当为汝分别解说。尔时摩诃迦叶白佛言。世尊。如是愿乐欲闻。佛告迦叶。善男子善女人。欲求涅槃于正法中出家。应学净戒。具律仪戒。具正法教。于清净戒微细不犯。应如是学。随顺正法离谄曲心。远离贪欲具足惭愧。常畏生死乐求远离。厌离生死常念涅槃。若在树下。若山岩间。若在静室。若在窟中。初修正意。念于如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛婆伽婆。生具足种姓。具足善根。具足无量净戒。无量三昧。无量智慧。无量解脱。无量解脱知见。具足一切无边佛法不可思议。具足无等无边功德实语真语。所言无二不诳众生。为大医王能拔毒箭。为不请友具大慈悲。为大导师说甚深法。令入甚深。说寂灭法令得寂灭。空无众生。无相断相。无愿离愿。无有戏论离诸戏论。甚深难见难觉。其性远离。离于有无。无行断行。无说离说。无相平等。离垢清净。无取无舍。能灭诸苦。能断渴爱令至涅槃。迦叶。比丘如是一日若过一日。在于静室心念如来。作是思念。我得人身。得出家道。得比丘法。亲近如来。不应懈怠。所以者何。于此修戒当得道果。以是因缘于未来世。若佛出世当得见佛。佛出世难如优昙花。迦叶。比丘修行。应学慧命须菩提之所修行。迦叶如来应正遍知。难得见闻。于正法中而得出家。具比丘戒甚为希有。善男子善女人。于正法中出家者。为二事故。何等为二。一者为现得道果故。二者为见未来佛故。迦叶。有诸痴人。受着袈裟违背如来。自谓我得道果圣人。是人若在静室。若在窟中。贪心思念。一切施主施我衣钵。作如是念。如来不知我。不觉我。不见我。迦叶。比丘若在静室。若在窟中。若行若坐若卧。若念贪欲。若念嗔恚。及余种种诸恶觉观。随所住处。其中诸神。知彼比丘心生愁忧。作如是念。此诸比丘非法非宜。于正法中得出家已。思惟如是不善之法。迦叶。彼诸神等知彼比丘。各作方便令不安隐。迦叶。彼诸天神以少善根得少智慧。尚知他心。况复如来百千万亿阿僧祇劫。具行智慧。迦叶。如来无所不知。无所不见。无所不觉。无所不证。迦叶。如来具足无碍智慧。于三世法皆悉了知。是故迦叶。善男子善女人。于正法中得出家者。应作是念。诸佛如来悉知我心。十方世界现在诸佛亦知我心。莫于佛法作沙门贼。迦叶。云何名沙门贼。沙门贼有四种。何等为四。迦叶。若有比丘整理法服。似像比丘而破禁戒作不善法。是名第一沙门之贼。二者于日暮后。其心思惟不善之法。是名第二沙门之贼。三者未得圣果。自知凡夫。为利养故。自称我得阿罗汉果。是名第三沙门之贼。四者自赞毁他。是名第四沙门之贼。迦叶。是名四种沙门之贼。迦叶。譬如有人具大势力。于阎浮提一切众生。所有珍宝金银琉璃真珠珊瑚虎珀等宝。刀杖加害皆悉夺取。迦叶。于汝意云何。此人得罪宁为多不。迦叶白佛言。甚多。世尊。佛告迦叶。若有凡夫。未得圣果。自知凡夫。为利养故。自称我得须陀洹果。若受一食罪多于彼。尔时摩诃迦叶白佛言。希有世尊。如来说此律仪之法。谁闻此法。未得圣果自说得道。受一盏水。佛告迦叶。如是如是。如汝所说。若欲离生死者。应如是行如救头燃。迦叶。若复有人身具大力。于四天下众生资身之具。加以刀杖悉皆夺取。迦叶。于意云何。彼人以此劫夺因缘。得罪多不。迦叶白佛。甚多世尊。甚多善逝。佛告迦叶。若凡夫人未得圣果。为利养故。自称我得斯陀含果。受一食施罪多于彼。迦叶。若复有人于千世界所有众生一切资具。金银琉璃真珠珂贝虎珀珊瑚种种诸宝。无价宝衣骑乘宫殿。饮食之具。刀杖加害悉皆劫夺。迦叶。于意云何。彼人以是劫害因缘。得罪多不。迦叶白佛。甚多世尊。甚多善逝。佛告迦叶。若有众生未得圣果。自知凡夫。为利养故。自称我得阿那含果。受人信施乃至一食。罪多于彼。迦叶。若复有人身具大力。于中千世界一切众生。若天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切乐具。刀杖加害悉皆劫夺。迦叶。于意云何。彼人以是加害因缘。得罪多不。迦叶白佛。甚多世尊。甚多善逝。佛告迦叶。若有众生未得圣果。自知凡夫。为利养故。自称我得阿罗汉果。受人信施乃至一食。罪多于彼。迦叶。宁夺三千大千世界众生一切乐具。不应自称我得圣果。受人信施乃至一食。迦叶。我观沙门法中。更无有罪重于妄称得圣果者。迦叶。声闻之人有四恶欲。何等为四。一者求见未来世佛。二者求作转轮圣王。三者愿生刹利大姓。四者愿生婆罗门大姓。是名四种恶欲。若有所求乃至涅槃。亦名恶欲。是名如来秘密之说。迦叶。声闻之人有四种性。于一切时一切事。所不应作何等为四。一者着我。二者着人。三者犯戒。四者求未来佛法。此四种性。声闻之人。于一切时一切事。所不应作。迦叶。若有沙门婆罗门持净戒者。我为彼说阿耨多罗三藐三菩提。终不为彼恶欲人说。为持戒人心不谄曲。求涅槃者令其安隐。是故为说。迦叶。我今更说。令诸行者闻已欢喜。迦叶。若复有人以一切乐具。供养四天下一切众生。若一劫若减一劫。迦叶。若复有人。以一器水施于持戒正命之人。彼善男子善女人。所得功德胜前布施。无量无边。迦叶。是恶欲人。若受人施伤害于人。过于一切恶友怨敌。迦叶。出家之人微细烦恼。复有四种。具彼烦恼。如负重担入于地狱。何等为四。一者见他得利心生嫉妒。二者闻经禁戒而反毁犯。三者违反佛语覆藏不悔。四者自知犯戒受他信施。迦叶。是名四种微细烦恼。出家之人具此烦恼。如负重担入于地狱。迦叶。有四种相似沙门。何等为四。一者恶戒。二者我见。三者诽谤正法。四者断见。是名四种相似沙门。迦叶。出家之人有四放逸入于地狱。何等为四。一者多闻放逸自恃。多闻而生放逸。二者利养放逸。得利养故而生放逸。三者亲友放逸。依恃亲友而生放逸。四者头陀放逸。自恃头陀自高毁人。是则名曰四种放逸。迦叶。出家之人具四放逸堕于地狱

尔时摩诃迦叶白佛言。世尊。当来末世后五百岁。有相似沙门。身被袈裟。毁灭如来无量阿僧祇劫所修集阿耨多罗三藐三菩提。尔时世尊。告摩诃迦叶。汝莫以此问于如来。何以故。迦叶。彼愚痴人实有过恶。如来不说。以恶欲故。其心妄执邪行谄曲。一切魔事皆悉信受。彼愚痴人实有过恶。如来不说。尔时摩诃迦叶白佛言。世尊。唯愿如来。久住世间为我说法。佛告迦叶。如来不久当般涅槃。迦叶白佛言。世尊。唯愿世尊住世一劫。若减一劫守护正法。尔时世尊。告摩诃迦叶。彼诸痴人。假使千佛出兴于世。种种神通说法教化。彼愚痴人。于彼恶欲不可令息。迦叶。当来末世后五百岁。有诸众生。具足善根其心清净。能报佛恩守护我法。尔时摩诃迦叶白佛言。世尊。我宁顶戴四大天下一切众生。山河石壁城邑聚落。满于一劫若减一劫。不能闻彼愚痴众生不信之音。世尊。我宁坐于一胡麻上。满于一劫若减一劫。不能闻彼不信痴人破戒之音。世尊。我宁在于大劫火中。若行若立若坐若卧。百千亿岁不能闻彼不信痴人破戒之音。世尊。我宁受于一切众生嗔恚骂辱挝打加害。不能闻彼不信痴人偷法大贼毁禁之声。世尊。我修少行智慧微浅。如是重担我不能堪。世尊。唯有菩萨。堪能荷负如斯重担。世尊。我于此中欲说譬喻。世尊。譬如有人。年耆极老年百二十。身瘿长病卧在床席。不能起止。时有一人巨富饶财。赍持珍宝至病人所。而语之言。我有缘事当至他方。以宝相寄为我守护。或十年还。若二十年。待我还时汝当归我。彼老病人卧在床席。无有子息唯独一身。彼人去已未久之间。时彼病人困至命终。所寄财物悉皆散失。彼人行还求索无所。世尊。声闻之人亦复如是。智慧微浅修行甚少。又无伴侣。不能久住在于世间。若付正法不久散灭。尔时世尊。赞迦叶言。善哉善哉。迦叶。我已了知而故付汝。令彼痴人得闻此已。生于悔心。尔时摩诃迦叶白佛言。世尊。我今更欲说第二喻。世尊。譬如有人身力盛壮无诸患苦离一切病。寿命无量百千万岁。生大种姓具足财宝。善持净戒。有大慈悲。内怀欢喜。能舍一切众生烦恼。其心勇猛利益多人令得安乐。利益天人。时有一人。赍持宝物来至其所。而语之言。我有缘事当至他方。以宝相寄当好守护。若十年还。若二十年。待我来时当见相还。其人得宝藏积守护。彼人行还即便归之。世尊。菩萨摩诃萨亦复如是。若以法宝付诸菩萨。无量千亿那由他劫。终无失坏利益无量无边众生。不断佛种。不断法轮。僧宝具足。世尊。如是之事我不能持。唯有菩萨乃能堪受。世尊。此弥勒菩萨摩诃萨。俱在此会如来付之。于当来世后五百岁法欲灭时。如来无量阿僧祇劫。所集阿耨多罗三藐三菩提法。悉能守护流演广说。何以故。世尊。此弥勒菩萨摩诃萨。于当来世。当证如来阿耨多罗三藐三菩提。世尊。譬如国王第一太子灌顶受位。当为王事如法治世。王诸群臣悉皆朝宗。世尊。弥勒菩萨摩诃萨。亦复如是。治法王位守护正法。尔时世尊。赞摩诃迦叶。善哉善哉。如汝所说。尔时世尊。即申右手。犹如金色微妙光明。无量阿僧祇劫善根所集。其指掌色犹如莲花。以摩弥勒菩萨摩诃萨顶。作如是言。弥勒。我付嘱汝。当来末世后五百岁正法灭时。汝当守护佛法僧宝。莫令断绝。尔时如来。申金色手。摩弥勒菩萨顶时。于此三千大千世界六种震动。光明遍满三千大千世界。尔时地天及虚空天。上至阿迦腻吒天。悉皆合掌。白弥勒菩萨摩诃萨言。如来以法付嘱圣者。唯愿圣者。为利一切诸天人故。受此正法。尔时弥勒菩萨从坐而起。偏袒右肩。右膝着地。合掌恭敬白佛言。世尊。我为利益一一众生。尚受无量亿劫之苦。况复如来付我正法。而当不受。世尊。我今受持。于当来世。演说如来无量阿僧祇劫。所集阿耨多罗三藐三菩提。弥勒菩萨说此语时。三千大千世界六种震动。尔时弥勒菩萨摩诃萨。复白佛言。世尊。不应于余众生而起诤论及增上慢。何以故。世尊。正事业者。谓护正法。世尊。若声闻辟支佛。不能荷负菩萨重担。尔时世尊。赞弥勒菩萨摩诃萨言。善哉善哉。弥勒。如汝今日至于我前作师子吼。受持守护如来正法。如是恒河沙等。过去诸佛前诸大菩萨。亦复如是。作师子吼守护正法。尔时弥勒菩萨摩诃萨白佛言。世尊。唯愿世尊。说当来世愚痴人辈。自称菩萨。自称沙门。为名利故。恼乱施主知识亲属。唯愿世尊说其过恶。何以故。若世尊说其过恶。我得闻已。自摄心行。彼愚痴人闻如来说。或得信解。如来知我如来觉我。尔时世尊。告弥勒言。善哉谛听善思念之。当为汝说彼痴人过。弥勒。当来末世后五百岁。有诸众生。自称说言我是菩萨。彼诸恶欲我今说之。弥勒具四法者自称菩萨。何等为四。一者求利养。二者求名闻。三者谄曲。四者邪命。弥勒具此四法。是故自称我是菩萨。佛告弥勒。当来末世后五百岁。自称菩萨而行狗法。弥勒。譬如有狗。前至他家见后狗来。心生嗔嫉啀喍吠之。内心起想谓是我家。佛告弥勒。当来末世后五百岁。亦复如是。自称菩萨行于狗法。至他施主家中。生己家想。既起此想便生贪着。前至他家见后比丘。嗔目视之心生嫉恚。而起斗诤互相诽谤言。某甲比丘有如是过。某甲比丘有如是过。汝莫亲近某甲比丘。汝若亲近某甲比丘。则为众人之所轻贱。增长罪垢。如是之人心生嫉妒。行饿鬼因贫贱之因。为自活故。妄称己身以为菩萨。为衣食故。赞叹如来智慧功德。令余众生生于信仰。内自犯戒。恶欲恶行。佛告弥勒。汝观来世。有如是等大怖畏事。师子之兽。应师子吼作师子业。非野干鸣作野干业。赞叹能舍一切财物。而自悭吝不能离贪。赞叹慈愍自行嗔恚。赞叹忍辱自行不忍。赞叹四摄自不能行。布施爱语利益同事。但有言语。而不能学乐精进菩萨之行。弥勒。往昔过去无量无边不可称计不可思议阿僧祇劫。尔时有佛。号曰智上如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛婆伽婆。弥勒。彼佛出于五浊恶世时。佛法中有一菩萨比丘。名乐精进。具足念慧少欲知足。顺如来教游诸村邑。为人说法。国王大臣一切人民之所知识尊重恭敬。时彼比丘。欲入城邑先自观察。若得尊重爱语赞叹。然后入城。复游邪见不信之处。于彼不得善语供养。唯得嗔恚骂詈挝打。而彼比丘被忍辱铠。安住大悲不舍众生。亦不嗔恚不生悔心。弥勒。乐精进菩萨所化众生。悉为比丘而作施主。奉施衣食卧具汤药。佛告弥勒。于意云何。时彼比丘不至余家。有嫉妒不。弥勒白佛。不也世尊。佛告弥勒。汝观乐精进菩萨利益之心。少欲知足大悲观察。城邑聚落。不得食处则止不入。化邪见人。为余比丘而作檀越。更不重入。化诸邪见不信之处。令其正信。嗔恚打骂心不嗔恨。如是弥勒。过去之世。诸大菩萨入于村邑。为化众生不为自活。弥勒。莫作异观。尔时乐精进菩萨。岂异人乎。我身是也。弥勒。是故菩萨。若入村邑欲化众生。当学乐精进菩萨摩诃萨。复应学余大菩萨行。莫学狗法。佛告弥勒。当来末世后五百岁。有诸比丘自言菩萨。为衣食故入于聚落。不为教化众生入于聚落。唯为财物递相诽谤。自得便喜。见他得利愁忧嗔恚。自求不得便生愁忧。见他不得便生欢喜。弥勒。汝观彼人如是颠倒。为菩萨法。所有乐具。应悉舍与一切众生。何以故。以大悲心故发广大愿。令诸众生悉得乐故。弥勒。譬如长者居士。唯有一子颜貌端正。敬顺父命。爱之甚重。以少因缘系在牢狱。父时闻之亲自入狱。弥勒。于汝意云何。如是长者。入于牢狱为何事故。弥勒菩萨白佛言。世尊。为见子故。入于狱中求出解脱。佛告弥勒。言牢狱者即是生死。长者居士喻诸菩萨。言一子者。如诸菩萨摩诃萨。于诸众生如一子想。弥勒。如彼长者居士。入于牢狱为见其子愍而救之。菩萨摩诃萨亦复如是。入于聚落。不为饮食衣服卧具。为化众生令得解脱。佛告弥勒。当来末世后五百岁。有诸比丘。不修身。不修心。不修戒不修慧。彼诸比丘入于聚落。持诸香花与人作信。以求衣服卧具饮食。佛告弥勒。比丘之法。不应如是作不贱业入于村邑。若入村邑。应为求法求善知识。莫怀谄曲。莫起憍慢。应作法语。莫说世事。莫说田宅苦乐得失。王事贼事。城邑聚落军众之事。莫说男女婚会之事。唯应说法赞佛功德叹说正法。叹说圣僧。说于布施持戒忍辱精进禅定智慧之法。佛告弥勒。若满三千大千世界珍宝乐具。若善男子善女人。以此珍宝乐具。施诸众生。若有善男子善女人。为他人说一四句偈。令其得闻。彼善男子善女人所得功德胜前功德。无量无边阿僧祇数。佛告弥勒。观此比丘。入于村邑有大利益。弥勒。若入城邑。勿得远离赞叹三宝论说世事。何以故。弥勒。若金银琉璃真珠马瑙珊瑚诸宝。及诸乐具。不能令人离于生老病死忧悲苦恼。弥勒。唯有正法能大利益。离于生老病死忧悲苦恼。是名如来微密之法。尔时世尊。而说颂曰

  三千大千界　　珍宝满其中
  以此用布施　　所得功德少
  若说一偈法　　功德为甚多
  三界诸乐具　　尽持施一人
  不如一偈施　　功德为最胜
  此功德胜彼　　能离诸苦恼

佛告弥勒。若有菩萨摩诃萨。以满无边世界珍宝。施诸佛如来。若有菩萨。以大悲心为一众生说四句偈。功德胜彼。尔时世尊。而说颂曰

  若恒沙世界　　珍宝满其中
  以施诸如来　　不如一法施
  施宝福虽多　　不及一法施
  一偈福尚胜　　况多难思议

尔时世尊告弥勒菩萨言。弥勒。如来有光。名曰一切功德庄严。在右掌中。我以此光。能令三千大千世界。众生所须一切乐具。悉皆充足。须食与食须饮与饮。须衣与衣须乘与乘。须宝与宝。如是等事我悉能与。弥勒。一切众生虽得此乐。于生死中不能解脱。弥勒。是故如来。不施众生世间乐具。但与出世无上法宝。众生闻已毕竟离苦。是故弥勒。汝等悉应学于如来无上法施。莫重世间资生施也。弥勒。当来末世后五百岁正法灭时。有诸比丘自称菩萨。身作不善。口作不善。意作不善。身犯禁戒。口犯禁戒。意犯禁戒。造不善业。无沙门果。弥勒。我为发菩提心善男子善女人。说菩萨善根。不堕地狱畜生饿鬼及余难处。善男子善女人。应勤精进具足惭愧。常畏生死。诸有生处常怀怖畏。我当云何令诸三界六道众生。速得解脱。何以故。弥勒。菩萨摩诃萨。发愿许度三界六道一切众生。令得解脱。不安隐者令得安隐。未涅槃者令得涅槃。弥勒。我观一切世界。若天若人若魔若梵。若沙门婆罗门中。不见一人有能荷负如是重担如菩萨者。弥勒。譬如有人顶戴三千大千世界山河石壁。有人告言。善男子。汝今以此三千大千世界顶戴。一劫若减一劫。若百千劫。顶戴不息。弥勒。于汝意云何。如是之人为大力不。弥勒白佛言。世尊。甚大世尊。甚大善逝。佛告弥勒。菩萨摩诃萨精进之力。复胜于彼。菩萨发愿许度一切众生。皆令得住涅槃之乐。弥勒。譬如有人于三千大千世界。一切众生所有作业。彼人一时悉能成就。弥勒。于汝意云何。此人所作事业。宁为大不。弥勒白佛。甚大世尊。佛告弥勒。菩萨所作事业。复过于此。菩萨发言。三界众生受苦恼者。我令解脱。弥勒。譬如长者唯有一子。容颜端正年在幼稚。孝顺父母。长者及子妻妾眷属奴婢财物。悉入王狱。尔时大王语长者言。去此一百由旬。有城名某。汝去七日令至彼城。复行七日还至我所。汝能如是。舍汝妻子眷属财物。悉皆还汝及赐官物。若过七日。从于彼城不至此者。当断汝命及汝一子。亲属财物悉入于官。佛告弥勒。于意云何。如是长者勉力勤进。为爱自身为爱一子。为惜妻妾奴婢财物。而从彼城勤苦至此。弥勒菩萨白佛言。世尊。如我解佛所说义者。彼人不念饮食睡眠。唯念速行。何以故。世尊。如是之人自惜命故。是故速行。佛告弥勒。若一切众生勤行精进。悉如彼人。一切众生如是精进。欲比菩萨精进。百分不及一。千分不及一。百千分不及一。亿分不及一。百千亿分不及一。百千亿那由他乃至不可数分不及一。何以故。弥勒。一切众生顺生死流。菩萨逆生死流。令其住于不动涅槃。弥勒。譬如有人。勇猛大力转胜于前。取四大海及诸河水。悉还置于阿耨大池。弥勒。于意云何。是人所作为希有不。弥勒菩萨白佛言。世尊。如是之事甚为希有。佛告弥勒。菩萨精进。难作希有复过于此。菩萨以大悲心。化一切众生。令住阿耨多罗三藐三菩提。是事为难。若能信有佛法及僧。此事为难。若有能信善恶业果。此事为难。贪嗔痴起能令灭者。是事为难。能舍亲属发少欲心。而求出家行至七步。此事为难。身披袈裟于正法中。正信出家离于欲火。此事为难。不犯禁戒。此事为难。能离愦闹修远离行。此事为难。信诸法空。此事为难。于深法中得柔顺忍。此事为难。证三解脱门。此事为难。证须陀洹果乃至阿罗汉果。此事亦难何以故。弥勒。所谓难者。于正法中以信出家得沙门果。弥勒。当来末世后五百岁。有诸众生发菩萨心。于正法中出家学道。空无所得。舍菩萨业作凡愚行。弥勒。何等是菩萨业。弥勒。菩萨业者有二十法。若有菩萨。不成就此二十法者。则不能得坐于道场。何等二十。一者离悭心。二者修布施。三者离热恼。四者修净戒。五者离嗔恚。六者修忍辱。七者离懈怠。八者大精进。九者离乱心。十者念慧修无依定。十一者修甚深忍。十二者具足般若波罗蜜。十三者行无相行。十四者行空行。十五者行无愿行。十六者成无愿境界。十七者不舍一切众生。十八者修行大悲。十九者不念声闻缘觉之乘。二十者心乐成就如来智慧。是名菩萨摩诃萨二十种业。菩萨成就此二十业。能坐道场。弥勒。菩萨摩诃萨有四种毕定誓。何等为四。一者毕定成佛转于法轮。二者生死众生令得解脱。三者令无量众生住阿耨多罗三藐三菩提。四者舍自身乐。令诸众生得无漏乐。是名四种毕定之誓。佛告弥勒。譬如二人。善解医方。善解咒术。善别毒药。善识甘露。尔时一人。于大众中即取毒药。而自食之现希有相。食已受苦身不安隐。复求甘露咒术望除毒气。尔时彼人求不能得。毒气炽盛遂便命终。时第二人作如是言。我今不能食于毒药。不食毒药不须甘露。不欲处众作希有想。令身苦恼。弥勒。当来末世后五百岁。有诸在家出家菩萨。亦复如是。作如是言。如我说法能除诸罪。如是语已转集恶业。复作是言我还忏悔。我说彼人。于正法中名为死人。何故名死。谓于正法堕落退没。是名为死。弥勒。复有菩萨。其心清净。作如是言。我不作罪不须忏悔。我当忏悔过去未来一切诸罪。现在不作。亦如彼人不食毒药不须甘露。弥勒。所言毒者。于正法中犯于戒律。是名为毒。弥勒。汝等莫作食毒之人。佛告弥勒。复有四法。能令菩萨离萨婆若离声闻果。况萨婆若。何等为四。一者不知恩。二者谄曲。三者妄语。四者犯戒。弥勒。此四种法。能令菩萨离萨婆若。亦离声闻。况萨婆若。弥勒。复有四法。菩萨应急走舍离过百由旬。何等为四。一者利养。二者恶友。三者恶众。四者同在一处。或作戏笑。或嗔或斗。当速舍离过百由旬。菩萨于余菩萨不应恶心。弥勒。若有菩萨。打骂割截三千大千世界一切众生。弥勒。于汝意云何。菩萨以是打骂割截一切众生。得罪多不。弥勒菩萨白佛言。世尊。打一众生得罪尚多。何况三千大千世界一切众生。何以故。世尊。一切菩萨。于众生不应起于嗔恚之心。尔时世尊。告弥勒言。若有菩萨。打骂割截三千大千世界一切众生。得罪尚少。若有菩萨。于余菩萨起嗔恚心。退于菩提复尔所劫弥勒。譬如木柱。若以草土不能斩截。必以利斧乃能斩之。菩萨善根亦复如是余不能尽。若于菩萨起嗔恚心。能灭诸善。弥勒。是故菩萨应学恭敬。于初发心诸菩萨等。心生尊重如世尊想。尔时弥勒菩萨摩诃萨白佛言。世尊。我当修行尊重恭敬一切众生。何况菩萨。何以故。世尊。应舍嗔恚行于忍辱。离于谄曲行清净心。远离有为。行于无我无取之行。不贵财宝当重法行。不求衣食当求法财。舍离嫉妒。见人巨富心助欢喜。非唯求名以为沙门。当学沙门一切功德。我非口说当修实行。舍于利养少欲知足。求佛功德。不为财利入于聚落。念萨婆若入于聚落。不为衣食入于村邑行谄曲行。当行正行赞四圣种。不学凡夫下劣之心。当学佛行不观他过。但自调伏。修奢摩他毗婆舍那。离三业恶。常修三业清净之行离于破戒。当学波罗提木叉。不依佛法僧而自活命。赞叹如来真实功德。不为求施。为求法故。常赞正法修如法行。赞叹圣僧依不退僧。不依世间有为之僧。不求一切世间资身之具。唯求正法不求世事。求出世法离于谄曲。行真实行不乐一处。当如野鹿无所依止。离世间乐求佛功德。当离睡眠。初夜后夜读诵经典。舍于愦闹当行远离。于诸功德不生厌想。求诸功德心不暂息。当离狗法。当行师子所吼之法。为究竟友不应暂友。舍无反复当行报恩。不以财利而作亲友。当以净心而作亲友。舍虚诳心行真实行。舍下劣法。当求成就无上佛身。于如来所。当行恭敬。不起憍慢。舍于两舌心口相违。当行诚实无二之言。不作菩萨而行谄曲。当以净心行奢摩他毗婆舍那。舍于我慢当行恭敬。离不净食当净持戒。食人之施。当舍邪念念诸佛法。离于人见行于空行。离于妄觉行无相行。离身谄曲。当行三业清净之行。不求财利而演说法。以大悲心而说正法。不以财物而作亲友。以法亲友不为自利。为利他人令不损害。行阿兰若离于谄曲。不作谄曲而行乞食。不行谄曲着粪扫衣。所以者何。具十二头陀者。不求一切世间利养。尔时世尊。赞弥勒菩萨摩诃萨言。善哉善哉。弥勒。汝求佛功德心无厌足。作师子吼。已于过去佛所。种诸善根。能说此法。说此功德。尔时弥勒菩萨摩诃萨。说此法时。众中五百比丘从坐起去。尔时摩诃迦叶。问诸比丘今听说法。汝等比丘欲诣何所。诸比丘言。大德迦叶。如弥勒菩萨摩诃萨所说之法。甚深难得。我等作如是念。我等不能修得此法。欲还归俗。何以故。信施之食难可消故。尔时文殊师利菩萨。赞诸比丘。善哉善哉。善男子。是汝所应。若不能消信施之食。宁可一日百数归俗。不应破戒受人信施。尔时文殊师利白佛言。世尊。何等之人应受信施。尔时世尊。告文殊师利菩萨。善男子。若有修禅解脱者。我听彼人受信施食。尔时文殊师利。告五百比丘。汝等今者应速修行。佛世难值。当住佛法。尔时五百比丘。问文殊师利言。文殊师利。我等云何修行。文殊师利。告诸比丘言。汝等应如是观。无一法合。无一法散。无一法生。无一法灭。不受一法。不舍一法。不增一法。不减一法。若如是行于法无得无得则无去。无去故无来。无来则无去。比丘是名无来无去无住无不住。尔时文殊师利。说是法时。五百比丘。于诸漏中。心得解脱

大宝积经卷第八十八大宝积经卷第八十九

        元魏优禅国王子月婆首那译

    摩诃迦叶会第二十三之二

尔时摩诃迦叶白佛言。世尊。当来末世后五百岁。何等菩萨行于谄曲。尔时世尊告迦叶言。迦叶。多有众人行于谄曲。亲近恶友少读诵经为求衣食。尔时摩诃迦叶白佛言。善哉世尊。唯愿世尊。利益多人说彼谄曲。不勤修行菩萨之过。令彼菩萨闻此过已。自摄心行令得清净。尔时世尊。告摩诃迦叶言。迦叶。当来末世后五百岁。有诸菩萨。亲近恶友少读诵经。唯作供养舍利之业。以香花璎珞幡盖灯明。供养如来舍利塔庙。迦叶。我为在家无智众生。令种善根。说供养舍利。彼诸痴人不解我意。但作此业。迦叶。我于一切天人之中。常说此法。修奢摩他毗婆舍那。以自调伏。世间当有信乐婆罗门居士。供养舍利。迦叶。彼诸痴人舍于读诵修禅智慧。供养舍利因之活命。迦叶。若有菩萨以满三千大千世界上至梵天香花灯明。一一灯炷如须弥山。以如是等供养如来。若有菩萨。净心持戒于师尊所。受持读诵一四句偈。净心修行乃至七步。功德胜彼无量无边。迦叶。若有菩萨。以满三千大千世界花香末香。于百千岁。昼夜六时供养如来。若有菩萨。舍于愦闹深畏三界。为利众生发心趣向阿兰若处举足七步。胜前功德无量无边。迦叶。于意云何。如来化众生故作是说耶。迦叶。莫作此见如来实说。所以者何。如来现见明了知故。佛告迦叶。过去无量无边不可思议无数阿僧祇劫。尔时有佛。号妙华如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛婆伽婆。其劫亦名妙花。迦叶。妙花如来。有九十六亿百千声闻大众。尔时有转轮圣王。名曰尼弥。如法治世主四天下。迦叶。时尼弥大王千子具足。勇健威猛。迦叶。尔时大王具千子已。复有二子。结加趺坐忽然化生。一名达摩。二名善法。迦叶。尔时大王。请妙花如来及比丘僧。满八万四千岁。供养衣服卧具饮食汤药。舍诸家事唯修供养。七日之后一切比丘。各施新衣种种饮食。随心所乐。广造精舍随心乐住。一一比丘给使七人施百味食。迦叶。尔时大王。造立精舍方八十由旬。彩画微妙出过世间。妙花如来及比丘僧。坐彼精舍。从于地下出众妙花。令彼精舍华至于膝。迦叶。尔时大王。于不思议功德精舍。供养妙花如来。满八万四千岁。恭敬供养尊重赞叹。迦叶。尔时大王。供养如来。满八万四千岁已。最后一日。妙花如来饭食之后。达摩善法二子眷属。及诸四众。至妙花如来正遍知所。头面作礼白佛言。世尊。颇有布施功德善根。胜此尼弥大王功德善根者不。迦叶。时二王子礼如来时。大千世界。悉皆震动。迦叶。尔时妙花如来侍者弟子。名通达法。从坐而起。顶礼佛足白佛言。世尊。何因缘故。大地震动。以何因缘。此二王子礼佛而住

尔时妙花如来。告通达法。善男子。何用此问。若佛如来。说此王子净心深忍大悲之心。礼如来足。一切天人皆当迷没。迦叶。尔时妙花如来告一声闻神足弟子那罗延言。善男子。汝示神力起二童子。迦叶。尔时那罗延比丘。从坐而起。即以右手捉一童子。复以左手捉一童子。欲扶令起而不能动。时那罗延。尽大神通。扶二童子欲令其起。不能动彼。如分一毛为千万分不动一分。迦叶。尔时三千大千世界。地皆震动。山河石壁悉亦大动。而不能动彼二童子。迦叶。尔时那罗延。以妙花如来威神力故。令于下方恒河沙等诸佛世界悉皆震动。而亦不动彼二童子毛之一分。迦叶。尔时那罗延比丘。礼妙花佛白言。世尊。我将不失神通力耶。何以故。世尊。此二童子生来未久。在于佛前头面着地。我尽神力不能令起

尔时妙花如来。告那罗延比丘言。善男子。汝不失通。善男子。菩萨境界不可思议。一切声闻缘觉。所不能动不能思量。善男子。若满三千大千世界。一切众生具大神力。如汝不异。至于亿劫。不能动此二童子起。迦叶。尔时妙花如来说此语时。众中四百二十万众生发阿耨多罗三藐三菩提心。彼诸众生作如是念。菩萨神力甚为希有。未得一切智神力。乃尔大声闻神力不能令动。况成佛道。是故我等应行菩萨道。愿证如来无上智慧

迦叶。尔时四百二十万众生。作是念已。于无上菩提心得坚住。迦叶。尔时彼众有一菩萨。名曰善慧。在大众中从坐而起。偏袒右肩顶礼佛足。白妙花如来言。世尊。唯愿世尊。起二童子。如彼所问愿佛解说。佛告迦叶。尔时妙花如来。从虚空中出大音声。其声遍满乃至十方恒河沙等诸佛世界。声至之处世界地皆六种震动。放大光明遍照十方。迦叶。时二童子闻此声已。从地而起。迦叶。童子起时于此三千大千世界。人天伎乐不鼓自鸣。于虚空中雨众妙花。迦叶。时二童子从地起已至如来所。右绕三匝顶礼佛足。合掌恭敬瞻仰如来。迦叶。尔时妙花如来。告善慧菩萨言。善男子。此二童子礼我足已作如是问。世尊。颇有布施福德善根。胜此尼弥大王功德善根者。此二童子礼我足已发问而住。迦叶。尔时善慧菩萨。白妙花如来言。世尊。愿佛解说二童子问。令诸天人得安乐故

尔时妙花如来。告善慧菩萨。善男子。汝今谛听当为汝说。善男子。尼弥国王所作功德。若有菩萨。住阿兰若行远离行。少知诸法得无生忍。功德胜彼无量无边。善男子。若三千大千世界一切众生。一一众生所作功德。如尼弥王。如是三千大千世界一切众生。所有福德。不如菩萨修行远离住于净心。正念相应解诸法空。无来无去如是少忍。功德胜前功德。百分不及一。千分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千那由他亿分不及一。乃至算数不及其一。善男子。如恒河沙等。一切世界所有众生。一一众生悉作福德如尼弥王。彼诸众生所作福德。至恒河沙劫常修福德。善男子。于意云何。彼善男子得福多不。迦叶。尔时善慧菩萨。白妙花如来言。希有世尊。如来说喻不可思议。如此善根不可思议。迦叶。尔时妙花如来。告善慧菩萨。善男子。我今告汝有智慧人成就深忍。能信此语。彼一切众生所集善根。不如此二童子。以净心故礼如来足。胜前一切众生善根。百分不及一。千分不及一。百千分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千亿那由他分不及一。乃至算数譬喻所不能及。迦叶。尔时妙花如来大众之中。八万四千比丘同声发言。世尊。我等随喜彼人功德。成就深法忍。信诸法空。心乐远离。趣阿兰若。举足七步。发阿耨多罗三藐三菩提心。成就智慧。我等随喜。迦叶。尔时妙花如来。赞诸比丘。善哉善哉。诸善男子。汝等以此随喜之业不思议善根。当作恒河沙等转轮圣王。然后得成阿耨多罗三藐三菩提

尔时摩诃迦叶及诸大众。一时同声白佛言。世尊。我等随喜彼人发心。成就深忍信诸法空。远离寂灭自性清净。尔时世尊。告摩诃迦叶言。迦叶。尔时达摩善法二童子。白妙花如来言。世尊。菩萨具何等法。施不望报。不生嫉妒。心不悭吝。不生贪着。见人行施心不希望。成就如来无上之行。得深法忍成无上智。迦叶。尔时妙花如来。告善法二童子言。善男子。菩萨具足四法施。不望报不嫉妒。不悭吝不生贪。见人施不希望。成就如来无上之行。得甚深忍见无上智。何等为四。一者信诸法空。二者远离。三者深忍。四者正念。善男子。菩萨具此四法。施不望报心不嫉妒。不悭吝不生贪。见人施不悕望。成就如来无上之行。成就深忍具无上智。善男子。复有四法。若菩萨具此四法。施不望报心不嫉妒。不悭吝不生贪。见人施不希望。成就如来无上之行。成就深忍满无上智。何等为四。善男子。菩萨求多闻。得多闻已游于城邑聚落。说法无所希望。乃至不受一言善赞。心无所贪。诸佛所说一切施中法施第一。住第一施其心欢喜。不求世间财物布施。何以故。善男子。十方无数阿僧祇。诸佛世界。诸佛如来及比丘僧。不求世间资生之具。若有菩萨。住清净戒修于正法。具大悲心不求利养。一切诸佛之所忆念。若有能说一四句偈。说偈文字皆自性空。一切诸法亦复如是。皆自性空。此善男子。善根功德胜前善根百分不及一。千分不及一。百千分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千那由他亿分不及一。乃至阿僧祇分亦不及一。迦叶。尔时妙花如来。告二童子。善男子菩萨具足四法。得成如来无上之行。何等为四。一者行无上处。二者说无上法。三者施无上物。四者信无上法。善男子。是名四法。菩萨成就此四法者。得成如来无上之行。迦叶。时妙花如来。为二童子说是法时。彼二童子闻此法已。踊在空中高七多罗树。同声赞佛

  如来知诸行　　教众生行施
  而不着于施　　此施无上施
  能成无上忍　　此中无有我
  众生命及人　　希有大精进
  演说如是法　　成就甚深忍
  及得无上行　　得无上菩提
  永灭诸欲恼　　大智慧清净
  更不受后有　　说于远离行
  令住阿兰若　　修于空解脱
  亦不生分别　　常勤行布施
  不生于分别　　此是无垢际
  远离诸名字　　说清净尸罗
  令行寂灭处　　此是第一戒
  觉知寂灭处　　常修行于忍
  不分别众生　　此是清净忍
  离一切分别　　修坚固精进
  离一切有为　　佛说此精进
  能成远离法　　焚烧一切事
  断于诸有无　　此无分别禅
  不起诸烦恼　　非此亦非彼
  中间亦不住　　此第一智慧
  远离于三世　　修习寂灭想
  复观于此想　　此想何处生
  是故知无想　　赞叹佛功德
  演说第一法　　其心不异念
  听受于正法　　说名字无尽
  自性体不成　　观境界无实
  其心则解脱　　若起如是想
  我为说法者　　彼则被魔缚
  不知于法相　　若欲得菩提
  及求声闻者　　求缘觉菩提
  当修学此法　　说于一解脱
  智慧无边量　　勿作下劣愿
  当愿上菩提　　若求如是身
  相好自庄严　　如佛金色身
  当求上菩提　　作生一切法
  作者不可得　　诸法从缘生
  无自性自性

迦叶。时二童子。在虚空中说此偈时。尼弥大王从城而出。及诸地神虚空诸神。皆悉来集。尔时众中。八万四千众生。发阿耨多罗三藐三菩提心。阿僧祇众生种于善根。迦叶。尔时达摩善法二童子等。从空中下。诣妙花如来所白言。世尊。我等归依佛归依法归依僧。发阿耨多罗三藐三菩提心。以比丘形行菩萨道。世尊。真发心者信一切法无生。世尊。真发心者不着诸法。何以故。世尊。若有着则法不生。是故世尊。说离着心得彼无生。世尊。此无生亦不应说是无生。何以故。有言说者则有生灭。若具净智则无生灭。无生灭处是毕竟尽。是故世尊。以平等际。发阿耨多罗三藐三菩提心。不念于法。亦无法得。亦无不得。如是得平等。无得平等。何以故。一切诸法本性净故。迦叶。尔时妙花如来。为二童子说此法时。众中十千众生。得无生法忍。尼弥大王。并及千子五千大臣。悉发阿耨多罗三藐三菩提心。佛告迦叶。尔时妙花如来。饭食既讫澡洗钵已。于大众中告大王言。尼弥大王。我今说法。王及大众闻佛说法踊跃欢喜。迦叶。尔时达摩善法二童子。闻佛说法。以净信心离于欲火。欲求出家。从城而出来至佛所。至佛所已。而说颂曰

  一切诸如来　　赞叹出家法
  在家多垢秽　　坏灭白净法
  增长不善法　　毁灭于善法
  在家多过失　　出家离染污
  设使百亿劫　　受欲无厌足
  受欲无厌足　　在家而死灭
  如海受众流　　而无有厌足
  凡夫亦如是　　受欲无厌足
  如火烧干草　　而无厌足时
  凡夫亦如是　　受欲无厌足
  贪欲网所缚　　灭坏于世间
  是故应离缚　　为发出家故
  在家具众过　　不得无上道
  出家修远离　　尔乃得菩提
  过去诸如来　　已入于涅槃
  住阿兰若法　　获得大菩提
  是故学诸佛　　趣向阿兰若
  舍爱离居家　　然后得安隐
  一切三千界　　珍宝满其中
  以此珍宝聚　　在家施诸佛
  若以无恼心　　知于在家过
  学诸佛如来　　出家求智慧
  既求出家已　　远离诸欲火
  举足行七步　　胜以三千施
  三千之功德　　不如此一分
  是故出家者　　如来之所赞
  成就大智慧　　远离诸系缚
  离一切诸着　　乃证无上道
  速住寂静处　　断除诸欲爱
  一切毒炽心　　悉灭无有余
  学诸佛如来　　如实知诸法
  速远离在家　　住阿兰若法
  若欲求佛道　　修于远离行
  应学阿兰若　　不应乐在家
  此是诸佛境　　圣人所住处
  能住此道者　　则能得菩提
  欲等恼众生　　若求远离者
  应离在家法　　修习阿兰若
  欲证甘露法　　转无上法轮
  摧伏诸魔怨　　当习阿兰若

迦叶。尔时达摩善法二童子。说此颂已从城而出。往诣妙花如来所住之处。到已头面礼足右绕三匝白言。世尊。我等今者。于如来所欲求出家。唯愿世尊。哀愍听许令得出家。迦叶。尔时妙花如来。知二童子信心清净求出家法。是时如来。即听出家住比丘法。迦叶。尔时大王。闻二童子得出家已。即以太子令绍王位。王与九百九十九子。八万四千夫人。五千大臣及诸人民。以净信心离于欲火。舍家出家。一切俱往诣妙花佛。到已顶礼佛足。白妙花佛言。世尊。我等欲求出家。愿佛听许令得出家。迦叶。时妙花佛。知诸大众信心清净。悉听出家住比丘法。迦叶。尔时大王第一太子。登位七日内自思惟。我终不舍萨婆若心。何用如是王位宝财。为欲所缚。我终不舍无上菩提。作是念已发心出家。于十五日游四天下。说此偈言

  我父及亲属　　皆悉已出家
  无量亿众生　　为法亦出家
  我今乐出家　　不乐住五欲
  一心求出道　　欲诣导师所
  若发心出家　　离诸欲火者
  应速随我法　　离难甚难得
  不发出家心　　不远离欲火
  安心在居家　　安住于实法

迦叶。时彼童子说此偈时。四天下中。无一众生乐在家者。皆悉发心愿求出家。迦叶。时妙花如来。知诸众生心信清净求出家已。妙花如来于四天下一切城邑村落。悉作化佛及比丘僧。迦叶。时四天下一切众生。无有一人住在家者。以净信心离于欲火。悉得出家。彼诸众生既出家已。不须种殖其地自然生诸粳米。诸树自然生诸衣服。一切诸天供侍给使。迦叶。尔时达摩善法二比丘。勇猛精进。于其六十三亿岁中。不坐不卧。但勤精进求萨婆若。念萨婆若。于六十三亿岁。勤精进已。得遍至三昧所坐之地。名金刚处。其地皆是金刚所成。十方一切诸佛说法。悉闻受持。闻已复能为他解说。迦叶。时四天下一切众生。若有修学声闻乘者。无一众生凡身命终极懈怠者。得阿那含。从此命终生净居天。共彼同行求缘觉者。从此命终。当生他方无佛之处。生大种姓诸根具足。以过去世善根力故。离于欲火而行出家。七日之后成缘觉道。利益无量无边众生。入般涅槃。菩萨乘者。成就五通。具四无量无碍辩才。得陀罗尼。迦叶。莫作异念。尔时尼弥大王岂异人乎。则我身是。时太子者今弥勒菩萨是。迦叶。莫作异见。何以故。达摩童子今文殊师利是。善法童子者虚空藏菩萨是。迦叶。汝观彼佛国土清净。如是善根众生之所住处。尔时摩诃迦叶。白佛言。世尊。妙花如来。寿命几时。佛告迦叶。妙花如来。寿命八劫。迦叶。妙花如来。般涅槃后正法住世。满足一劫。一切诸天。供养舍利无在家人。迦叶。时二比丘少欲知足。不供舍利不礼佛塔。迦叶。尔时诸天新学比丘百千大众。各相谓言。此二比丘邪见。不信于佛舍利。不兴供养。不礼佛塔。迦叶。尔时诸天及诸比丘百千大众。说此语时达摩善法二比丘问众人言。于汝意云何。云何供养是真供养如来。以何事故。如来舍利而得供养。诸比丘言。修戒定智慧解脱解脱知见故。舍利得供养。二比丘言。修戒定慧解脱解脱知见。是真供养。非供舍利。诸比丘言。如是如是。如汝所言。云何戒相禅定智慧解脱解脱知见。复何等相。达摩善法二比丘言。无作相是戒相。乃至解脱知见无作相是知见相。迦叶。时二比丘语众人言。于意云何。无作能供养无作不。诸比丘言不也。达摩善法二比丘言。真供养者。无佛想无见佛。何况供养。若供养佛当供养自身。诸比丘言。云何供养自身。二比丘言。应如如来应正遍知。供养自身。一切众生之所供养。如佛所学。应如是学。护持禁戒集诸善法。思惟诸法莫取法相。若能如是自供养者。当得天人之所供养。若欲供养佛舍利者。当自供养。如佛如来具诸功德。舍利得供养。若能成就如是功德。名供养佛。不起想相名供养佛。若多若少不生分别。名供养佛。非后世去非今世来。非彼岸。非常非断。非取非舍。是则名曰供养如来。非增非减。非生非灭。非尽非不尽。是则名曰供养如来。非心非心数法。非忆想。非我非取非受。非诤论非不诤论。非毁非赞。非二非入是则名曰供养如来。亦非有为。亦非无为。是则名曰供养如来。身无所作。口无所作。意无所作。于身口意求不可得。是则名曰供养如来。无过去想。未来现在想不可得。无依无著。无所求想。亦不分别。是则名曰供养如来。无佛想。无法想。无僧想。无人无自无他想。是则名曰供养如来。真如来身。无生无相。不可以生而修供养。真如来身名无作相。不以作相而修供养。真如来身名无二相。不应二相而修供养。真如来身名无漏相。不以有漏而修供养。真如来身名曰空相。不以身见命见。断见常见。我见我所见。有见无见。供养如来。真如来身名无相相。不可以相而修供养。真如来身名无愿相。不可以愿而修供养。真如来身名无有相。不可以有而修供养。真如来身名不动相。不可动相而修供养。真如来身名无行相。不可以行而修供养。真如来身名离贪相。不可以贪而修供养。真如来身名离嗔相。不可以嗔而修供养。真如来身名离痴相。不可以痴而修供养。真如来身。具戒定慧解脱解脱知见。不可以破戒乱心愚痴而修供养。真如来身慈悲喜舍。不可以嗔心恼心妒心散心而修供养。真如来身。具施持戒忍辱精进禅定智慧。不可以悭破戒嗔恚懈怠乱痴而修供养。迦叶。达摩善法。于大众中说此法时。四百二十万众生。得无生法忍。八万四千众生。得清净智阿那含果。二百三十万众生。发阿耨多罗三藐三菩提心。迦叶。汝观达摩善法二比丘等如是净心。迦叶。汝应学彼正士甚深之忍及巧方便。迦叶。彼二比丘于大众中说此法时。诸比丘闻此法已。皆住深忍。悉行少欲知足之行。不供养舍利及佛塔庙。何以故。彼诸比丘悉乐深法。迦叶。彼七日后。一切佛塔悉皆隐没。及诸舍利所在器中。亦悉隐没。迦叶。汝应如是学彼正士甚深之忍。佛告迦叶。当知末世后五百岁。有诸菩萨及诸比丘。不修身不修心。不修戒不修慧。为活命故。供养佛塔及佛舍利。不为涅槃不为离欲。而修供养。自犯禁戒愚痴无智。如来舍利。具戒定慧解脱解脱知见之所勋修。为活命故供养尊重。具贪嗔痴。于佛如来应正遍知离贪嗔痴。所有舍利。为活命故而兴供养。自身具足悭贪嫉妒嗔恚懈怠乱心愚痴。若大施主正住一心。为活命故化令供养如来舍利。迦叶。我为教化初始发心诸善男子善女人等。以神通力留此舍利。令供养者受人天乐为未来因乃至涅槃。彼愚痴人于我法中。虽得出家不解我法。舍出家行。而但供养塔庙舍利。为自活故。为得衣钵。为利养故。为名闻故。为此事故。供养舍利。何等名为比丘之业。迦叶。如上所说沙门之业。则有二种。一者修禅。二者习诵。如是说者。为入道故非究竟说。迦叶。若有作业能尽业者。名沙门业。无作无诵无禅。无作无无作。无念无不念。无尽无生。证三脱门不住三界。无来无去。是沙门业。彼众生等离斯正业更习余业。彼福业者为化在家人。如是在家顺如来教。当得阿那含果。彼愚人辈。于我法中而行出家。尚不修行随顺之法。况复能得。若有得者无有是处。迦叶。于当来世后五百岁。有相似沙门。衣服形貌似像沙门。戒不相似。定不相似。慧不相似。迦叶。譬如有人善知医方及诸咒术。即以咒术咒一袈裟。与人令着。彼见生贪即便着之。若至七日若至八日。其身炽然犹如火聚。如彼咒已取之与人。彼人见已便生贪着。比丘亦尔。见好衣服受取而着。若至七日。若至八日。若在舍内。若在巷中。若在林中。彼所著衣炽然如火。烧人善根。迦叶。于汝意云何。彼着袈裟。有利益不。迦叶白佛言。世尊。无所益也。佛告迦叶。如是如是。我袈裟者戒定智慧解脱解脱知见。无量阿僧祇善根所集。迦叶。于当来世有愚痴人。着圣人衣似像沙门。入于村邑中。有信心婆罗门长者居士。见被法服谓为沙门。皆共尊重供养赞叹。彼愚痴人因袈裟故。而得供养便生欢喜。身坏命终堕于地狱。生地狱已。大热铁鍱以为衣服。吞啖铁丸。饮洋沸铁。坐热铁床。迦叶。汝观袈裟威德如是。彼愚痴人着于袈裟。受乐放逸自作恶业。身坏命终堕于地狱。迦叶。我常说言。宁以烧热铁鍱为衣。不以破戒之身而着袈裟。宁吞热铁。不以破戒之身食人信施。迦叶。汝观破戒之人食他信施。有如是过。是故汝等。应当修学清净戒法。迦叶。于汝意云何。若天若龙。若夜叉。若乾闼婆。若阿修罗。若迦楼罗。若紧那罗。若摩睺罗伽。若人若非人。能作如来色身像不。迦叶。白佛言。不也世尊。如来色像不可思议。无色像故。是故此等皆不能作。佛告迦叶。于当来世后五百岁。有诸比丘不修身不修心不修戒不修慧。若于叠上墙壁之下。造如来像因之自活。以此业故自高慢人。尔时摩诃迦叶。白佛言。世尊。波斯匿王。造如来像得福多不。佛言。迦叶。得福甚多。波斯匿王造如来像。施无价衣。不求衣服饭食之报。迦叶。彼愚痴人为活命故。造立形像。迦叶。若卖畜生犹尚不善。况彼痴人作如来像。于白衣前而炫卖之。以自活命。迦叶。譬如有人幼小无知。舍弃甘露而饮毒药。迦叶。彼愚痴人亦复如是。造如来像。为资生故而便卖之。是名为毒。迦叶。所言毒者。于正法中贪是其毒。迦叶。彼愚痴人以贪心故。而记嗔恚。递相斗诤。互相诽谤。各言我行供养。因彼诤论堕于地狱。迦叶。譬如有人无巧方便入敌战时。所持刀剑而反自伤。迦叶。愚痴之人亦复如是。无方便故。因于法故而堕地狱。迦叶。若有善男子善女人。以七宝造如来塔。庄严成就。一一宝塔高广严好。如须弥山。遍满恒沙诸佛世界。譬如甘蔗竹苇。迦叶。于汝意云何。彼善男子善女人。得福多不。迦叶。白佛言。世尊。造如来像。如四指者得福无量。况复造像如须弥山。所得功德不可思议。佛告迦叶。若有菩萨。内观佛身得深法忍功德胜彼无量无边。迦叶。若复有人住于净戒。以四句偈为他人说解其义趣。所得福德无量无边。迦叶。云何观于如来之身。迦叶。若菩萨欲观如来者。当学大精进菩萨。迦叶。乃往古昔无数阿僧祇劫。有佛世尊。号曰光明如来应供正遍知明行足善逝世间解无上士可化丈夫调御师天人师佛婆伽婆。迦叶。光明如来般涅槃后。有一菩萨名大精进。婆罗门种端正无比。迦叶。光明如来正法之中。有诸比丘。少欲知足住如法行。迦叶。彼诸比丘皆悉造立如来形像。尔时有一比丘。于白叠上画如来像。众彩庄严悉皆具足。持至大精进菩萨所。尔时大精进菩萨。见此画像。心大欢喜作如是言。如来形像妙好乃尔。况复如来正遍知身。愿我来世得成如是妙色之身。尔时大精进菩萨。作如是念。我今不能住在居家。若在家者。不能成就如是之身。迦叶。尔时大精进菩萨。年始十六诸根具足。至父母所头面敬礼。白父母言。我今欲于如来正法出家学道。愿为随喜。父母答言。莫作是说。何以故。我今年老唯汝一子。汝若出家我等当死。大精进言。我当方便令父母存。我得出家。父母问言。欲作何业。子白父母。我从今日。不食诸味。不升床坐。不食苏油。不饮浆水。若善若恶口不言说。乃至得出家。迦叶。大精进菩萨。如是誓已默然而住。如是默然一日不食。尔时父母。诵诸咒术持百味食而授与之。亦不肯食。亦不言说。迦叶。大精进菩萨。如是默然过第二日。尔时父母。与母知识五百人等。持百味食来至其所。诵诸咒术望其餐设。尚不顾视。况复食之。迦叶。时大精进。于第三日。父亲五百。持种种食劝之令食。亦复如是默然不语。不饮不食亦不顾视。于第四日。五百同友。持百味食诵诸咒术。令从己志。时大精进默然而住。于第五日。尔时父母。悉出宝藏金银琉璃种种宝物。及诸婇女八万四千上妙严饰。将至其所。父亲母亲及其同友。各五百人。劝大精进作如是言。汝当在家。以此财宝布施自恣作福。与诸婇女共相娱乐。时大精进于大众中。默然而住曾不瞻眄。于第六日。断诸忆想不起食念。如来应正遍知。迦叶。尔时父母及其知识。八万四千诸妙婇女。同时悲泣礼大精进。时大精进亦不顾视。迦叶。尔时大精进菩萨。所住之处有一宅神。于虚空中现大神力。而说颂曰

  精进心坚固　　难动如须弥
  不舍出家心　　为得菩提故
  大地可倾动　　火可在水居
  如是等可转　　菩萨不可动
  汝等莫勤苦　　而作不善业
  众生无慧眼　　久远处生死
  为利诸群生　　是故求菩提
  其心乐出离　　必成无上道
  不为世间报　　而行菩萨道
  愿成大觉智　　救济苦众生
  三千大千界　　珍宝满其中
  及诸上妙土　　其心不贪着
  汝等愚痴心　　所作不善业
  汝当自悔过　　菩萨不处俗

迦叶。时大精进菩萨。父母眷属知识及诸婇女。闻天神语悉皆悔过。告菩萨言。随意出家。汝当饮食勿令殒绝。迦叶。时大精进不食七日。光明晖悦颜色不变。唯心忆念正遍知身。一切诸天散花供养。时大精进过七日已。舍诸家业如弃涕唾。尔时父母同友知识。及诸婇女八万四千。皆悉悲泣随而送之。尔时大精进菩萨。持画叠像入于深山。寂静无人禽兽之间。开现画像取草为坐。在画像前结加趺坐。正身正念观于如来。谛观察已作如是念。如来如是希有微妙。画像尚尔端严微妙。况复如来正遍知身。复作是念云何观佛。尔时林神。知彼菩萨心之所念。白菩萨言。善男子。汝如是念云何观佛。若欲观佛当观画像。观此画像不异如来。是名观佛。如是观者名为善观。时大精进作如是念。我今云何观此画像与如来等。复作是念。如来像者非觉非知。一切诸法亦复如是。非觉非知。如是像者但有名字。一切诸法亦复如是。但有名字。如是名字自性空寂无所有。如来之身其相如是。如此画像非证非得非果。非证者。非得者。非得果者。非住者。非去非来。非生非灭。非垢非净。非色非非色。非贪尽。非嗔尽。非痴尽。非阴界入。非初非中非后。一切诸法亦复如是。如来身相亦复如是。如此画像非觉非作。一切诸法亦复如是。如来身相亦复如是。如此画像。非见非闻非嗅非尝非触非知。非出息非入息。一切诸法亦复如是。无有知者。如此画像非欲界摄。非色无色界摄。一切诸法亦复如是。如此画像非初非中非后。非此非彼。非行非非行。非取非舍。非作非诵。非实非虚。非生死非涅槃。一切诸法亦复如是。如来身相亦复如是。菩萨如是观如来身。结加趺坐经于日夜。成就五通。具足无量。得无碍辩。得普光三昧。具大光明。成就天眼过于人眼。以此天眼。见于东方阿僧祇佛。得净天耳。诸佛世尊所说之法。悉能听受。天耳净故。一一诸佛所说之法。听闻受持不相障碍。迦叶。时大精进。勤行精进满足七日。以智为食不食世供。一切诸天散花供养。迦叶。时大精进。不被袈裟。亦不见佛。不受禁戒。心但忆念学萨婆若。迦叶。菩萨应如是观如来身。非观非非观。迦叶。菩萨应如是观如来画像。如大精进菩萨摩诃萨观如来像。如是观已成大智慧。以此智慧。悉见十方阿僧祇佛。闻佛说法。迦叶。尔时大精进菩萨。从山而出来至村落。为人说法。一会说法二万众生。住阿耨多罗三藐三菩提。无量阿僧祇众生。住于声闻缘觉功德。父母亲属皆住不退阿耨多罗三藐三菩提。迦叶。莫作异念。尔时大精进菩萨摩诃萨者。岂异人乎。我身是也。迦叶。是故菩萨摩诃萨。应学大精进菩萨摩诃萨。亦应学余诸大菩萨。迦叶。当来末世后五百岁。有求菩萨诸善男子。无方便心。多诸贪着。于墙壁下。画如来像而求利养。彼作是说。我独供养人无供养。以修少善自高慢人因此供养以自活命。迦叶。彼时众生。不修三昧。不诵正典。但作此业。因此业故于施主边。获得衣服饮食卧具汤药。以自活命。迦叶。汝观彼破戒菩萨。住不净戒自称多闻。迦叶。彼破戒人不诵经典。供养形像因而自活。尔时摩诃迦叶。白佛言。世尊。希有世尊。希有善逝。世尊。广说愚痴凡夫谄曲之失。世尊。若有善男子善女人。闻如是说。何有不住清净之戒。世尊。愿于未来此法久住。令彼善男子善女人闻已惭愧。如来知我。如来觉我。所作邪法。永令休息。尔时世尊。告摩诃迦叶。如来所说为善男子。闻我此法修行离恶。我为此人说如是法。尔时世尊。说此经已。摩诃迦叶。弥帝隶菩萨。文殊师利童子。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜

大宝积经卷第八十九大宝积经卷第九十

        大唐三藏菩提流志奉　诏译

    优波离会第二十四

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人俱。菩萨摩诃萨五十万人。尔时世尊。如龙象王顾视观察。告诸菩萨摩诃萨言。善男子。汝等谁能于后末世护持正法。摄受如来百千万亿那由他阿僧祇劫所集阿耨多罗三藐三菩提法。安住秘密种种方便成熟众生。尔时弥勒菩萨从座起。偏袒右肩右膝着地。合掌白言。世尊。我能堪任于后世时护持如来百千万亿那由他阿僧祇劫所集阿耨多罗三藐三菩提法。师子慧菩萨曰。我能堪任安住秘密种种方便成熟众生。无尽意菩萨曰。我能堪任以广大愿度脱无尽诸众生界。跋陀罗菩萨曰。我能堪任令诸众生得闻我名皆悉成熟无空过者。妙德菩萨曰。我能堪任于诸众生随所愿求悉令满足。无畏菩萨曰。我能堪任摄受无边世界众生而作饶益。金刚菩萨曰。我能堪任于恶趣中度诸众生令得解脱。除障菩萨曰。我能堪忍解脱众生烦恼系缚。智幢菩萨曰。我能堪任灭除众生无明闇蔽。法幢菩萨曰。我能堪忍常行法施度脱众生。日幢菩萨曰。我能堪任恒以安乐成熟众生。月幢菩萨曰。我能堪忍以诸功德成熟众生。善眼菩萨曰。我能堪任与诸众生自性安乐。观自在菩萨曰。我能堪任于诸恶趣拔济众生。得大势菩萨曰。我能堪任度诸恶趣未度众生。普贤菩萨曰。我能堪忍令诸众生忆念过去经历受苦便得解脱。善数菩萨曰。我能堪任调伏一切难调众生。妙意菩萨曰。我能堪任乐小法者度令成熟。善顺菩萨曰。我能堪任成熟下劣少智众生。光积菩萨曰。我能堪任拔济堕于畜生趣者令得解脱。不思议菩萨曰。我能堪任愍念成熟饿鬼众生令得解脱。大威力菩萨曰。我能堪任为诸众生闭恶趣门。无诤论菩萨曰。我能堪任为诸众生示解脱道。贤吉祥菩萨曰。我能堪任究竟断除众生苦恼。月光菩萨曰。我能堪任与诸众生毕竟安乐。日光菩萨曰。我能堪任于诸众生未纯熟者令得成熟。无垢菩萨曰。我能堪任令诸众生所有志乐皆得圆满。断疑菩萨曰。我能堪任度脱一切下劣众生。无畏菩萨曰。我能堪任摄受众生称赞利益。慧胜菩萨曰。我能堪任随顺种种胜解众生皆得成熟。光明菩萨曰。我能堪任恒以正勤拔济众生。无量菩萨曰。我能堪任为诸众生于一切法。示无为道。无畏菩萨曰。我能堪任随诸众生种种志乐皆能示现。宝胜菩萨曰。我能堪任示诸众生妙珍宝聚。妙慧菩萨曰。我能堪任令诸众生见者欢喜皆得成熟。宝藏菩萨曰。我能堪任度脱众生离诸障碍。宝贤菩萨曰。我能堪任令诸众生自识宿命皆得成就。宝手菩萨曰。我能堪任以诸珍宝惠施众生令得安乐。胜意菩萨曰。我能堪任令诸众生永离贫穷。喜见菩萨曰。我能堪任施诸众生一切乐具。金刚菩萨曰。我能堪任为诸众生开示正道。福相菩萨曰。我能堪任悦可众生令得度脱。法超菩萨曰。我能堪任净除众垢而演说法。无垢菩萨曰。我能堪任爱护众生悉令成熟。法现菩萨曰。我能堪任常以正法度脱众生。空寂菩萨曰。我能堪任令诸众生灭烦恼毒。月胜菩萨曰。我能堪任为诸众生示法方所。师子意菩萨曰。我能堪任常以法施利益众生。童子光菩萨曰。我能堪任从卑下处拔出众生。觉吉祥菩萨曰。我能堪任开示正道闭恶趣门。金光菩萨曰。我能堪任示现身相成熟众生。吉祥菩萨曰。我能堪任与诸众生常作利益。持世菩萨曰。我能堪任为诸众生闭地狱门。甘露菩萨曰。我能堪任令诸众生超度生死。网明童子曰。我能堪任于后末世为诸众生示现光明灭除烦恼

尔时舍利弗闻诸菩萨作如是等勇猛弘誓。成熟众生。叹未曾有。白佛言。希有世尊。此诸菩萨摩诃萨不可思议。具足大悲方便善巧。勇猛精进而自庄严。一切众生无能测量。不可沮坏。所有光明无能障蔽。世尊。我当称赞是诸菩萨未曾有事。所谓堪任。有来求索头目耳鼻身体手足。一切诸物无所吝惜。世尊。我常思惟。若有人能逼迫如是诸菩萨等。从其求索。若内若外一切财物心无怯弱。当知皆是不可思议解脱菩萨。佛言舍利弗。如是如是。如汝所言。是诸菩萨智慧方便三昧境界。一切声闻及辟支佛所不能知。舍利弗。此诸菩萨摩诃萨。能现诸佛神通变化。满足众生诸所欲乐。而于诸法心无所动。若有众生乐为居士憍慢放逸。菩萨尔时为成熟故。现大居士威德之身。而为说法。若有众生恃大势力而自憍慢。菩萨尔时为调伏故。现那罗延大力之身。而为说法。若有众生志求涅槃。菩萨尔时为度脱故。现声闻身而为说法。若有众生乐观缘起。菩萨尔时为度脱故。现缘觉身而为说法。若有众生志求菩提。菩萨尔时为度脱故。即现佛身令入佛智。如是舍利弗。是诸菩萨种种方便成就众生。悉令安住于佛法中。所以者何。唯有如来智慧解脱究竟涅槃。更无余乘而得度脱。以是义故名为如来。如来如实觉了如故。名为如来。知诸众生种种欲乐。悉能示现故名如来。成就一切善法根本。断于一切不善根本。故名如来。能示众生解脱之道。故名如来。能令众生远离邪道住于正道。故名如来。演说诸法真实空义。故名如来。舍利弗。菩萨如是知诸众生种种志乐。随应说法令得解脱。为诸愚夫开示实智。不动法界能现种种幻化庄严。令诸众生次第当得趣涅槃岸

复次舍利弗。在家菩萨。住于慈愍不恼害心。应修二施。何者为二。一者法施。二者财施出家菩萨应修四施。何等为四。一者笔施。二者墨施。三者经本施。四者说法施。无生法忍菩萨。应住三施。何等为三。所谓王位布施。妻子布施。头目支分悉皆布施。如是施者名为大施。名极妙施。舍利弗白佛言。世尊。是诸菩萨于贪嗔痴不怖畏耶。佛言。舍利弗。一切菩萨有二犯戒。何等为二。一者嗔相应犯。二者痴相应犯。如是二犯名大破戒。舍利弗。因贪犯者。为过微细难可舍离。因嗔犯者。为过粗重易可舍离。因痴犯者。为过深重复难舍离。所以者何。贪结能为诸有种子。生死蔓莚连持不绝。以是义故微细难断。因嗔犯者。堕于恶趣可速除断。因痴犯者。当堕八种大地狱中难可解脱

复次舍利弗。若有菩萨犯波罗夷者。应对清净十比丘前以质直心殷重忏悔。犯僧残者。对五净僧殷重忏悔。若为女人染心所触。及因相顾而生爱着。应对一二清净僧前殷重忏悔。舍利弗。若诸菩萨成就五无间罪。犯波罗夷。或犯僧残戒。犯塔犯僧。及犯余罪。菩萨应当于三十五佛前昼夜独处殷重忏悔。应自称云我某甲。归依佛。归依法。归依僧

南无释迦牟尼佛　南无金刚不坏佛　南无宝光佛　南无龙尊王佛　南无精进军佛　南无精进喜佛　南无宝火佛　南无宝月光佛　南无现无愚佛　南无宝月佛　南无无垢佛　南无离垢佛　南无勇施佛　南无清净佛　南无清净施佛　南无娑留那佛　南无水天佛　南无坚德佛　南无栴檀功德佛　南无无量掬光佛　南无光德佛　南无无忧德佛　南无那罗延佛　南无功德花佛　南无莲花光游戏神通佛　南无财功德佛　南无德念佛　南无善名称功德佛　南无红炎帝幢王佛　南无善游步功德佛　南无斗战胜佛　南无善游步佛　南无周匝庄严功德佛　南无宝花游步佛　南无宝莲花善住娑罗树王佛

如是等一切世界诸佛世尊常住在世。是诸世尊当慈念我。若我此生。若我前生。从无始生死已来所作众罪。若自作若教他作。见作随喜。若塔若僧。若四方僧物。若自取。若教他取。见取随喜。五无间罪。若自作若教他作。见作随喜。十不善道。若自作若教他作。见作随喜。所作罪障。或有覆藏。或不覆藏。应堕地狱饿鬼畜生。诸余恶趣边地下贱及蔑戾车。如是等处所作罪障今皆忏悔

今诸佛世尊。当证知我。当忆念我。我复于诸佛世尊前作如是言。若我此生。若于余生曾行布施。或守净戒。乃至施与畜生一抟之食。或修净行。所有善根成就众生。所有善根修行菩提。所有善根及无上智。所有善根一切合集。校计筹量。皆悉回向阿耨多罗三藐三菩提。如过去未来现在诸佛所作回向。我亦如是回向

  众罪皆忏悔　　诸福尽随喜
  及请佛功德　　愿成无上智
  去来现在佛　　于众生最胜
  无量功德海　　我今归命礼

如是舍利弗。菩萨应当一心观此三十五佛而为上首。复应顶礼一切如来。应作如是清净忏悔。菩萨若能灭除此罪。尔时诸佛即现其身。为度一切诸众生故。示现如是种种之相。而于法界亦无所动。随诸众生种种乐欲。悉令圆满皆得解脱。复次舍利弗。菩萨若入大悲三昧。则能示现地狱畜生阎魔罗界成熟众生。菩萨若入大庄严三昧。则能示现长者之身成熟众生。若入殊胜三昧。则能示现转轮王身成熟众生。若入炽然威光三昧。则能示现帝释梵王殊妙色身成熟众生。菩萨若入一向三昧。则能示现声闻之身成熟众生。菩萨若入清净三昧。则能示现辟支佛身成熟众生。菩萨若入寂静三昧。则能示现诸佛色身成熟众生。菩萨如是入一切法自在三昧。随其志乐现种种身成熟众生。或现帝释身。或现梵王身。或现转轮圣王身。皆为成熟诸众生故。而于法界亦无所动。何以故。菩萨虽复随顺众生种种示现。不见身相及生相无所得故。舍利弗。于意云何。如师子王大哮吼时。诸小野干能堪任不。舍利弗言。不也世尊。又舍利弗。如大香象其所负重驴堪任不。不也世尊。又如帝释及梵天王威德自在。贫贱之人能堪任不。不也世尊。又如大力金翅鸟王翱翔运动。诸余小鸟能堪任不。不也世尊。佛言。舍利弗。是诸菩萨所有善根勇猛之力。依出离智。净诸罪垢。远离忧悔。得见诸佛及得三昧。亦复如是。如斯罪障。非诸凡夫声闻缘觉所能除灭。菩萨若能称彼佛名。昼夜常行是三种法。能灭诸罪远离忧悔得诸三昧

尔时优波离。从禅定起。往诣佛所顶礼佛足。右绕三匝却住一面。白佛言。世尊。我于静处独坐思惟。作如是念。世尊。所说波罗提木叉清净戒学为声闻缘觉菩萨乘者。作是说言。宁舍身命终不舍戒。世尊。若佛在世。若灭度后。云何名为声闻缘觉波罗提木叉。云何名为菩萨乘者波罗提木叉。世尊说我于持律中最为第一。我当云何能了毗尼善巧之义。若我从佛亲闻受持逮无所畏。然后乃能为他广说。今此大众诸来菩萨。及比丘僧悉皆集会。善哉世尊。唯愿广说决定毗尼断除疑悔

尔时世尊告优波离。汝今当知。声闻菩萨学清净戒。所发心所修行异。优波离。有声闻乘持清净戒。于菩萨乘名大破戒。有菩萨乘持清净戒。于声闻乘名大破戒。云何名为声闻乘人虽持净戒于菩萨乘名大破戒。优波离。声闻乘人。乃至不应起于一念更受后身。是名声闻持清净戒。然于菩萨名大破戒。云何菩萨持清净戒于声闻乘名大破戒。菩萨摩诃萨。修行大乘。能于无量阿僧祇劫。堪忍受身不生厌患。是名菩萨持清净戒。于声闻乘名大破戒。以是义故。为菩萨乘说不尽护戒。为声闻乘说尽护戒。为诸菩萨说开遮戒。为诸声闻说唯遮戒为菩萨乘说深心戒。为声闻乘说次第戒。云何菩萨持不尽护戒。声闻乘者持尽护戒。菩萨乘人虽持净戒。于诸众生应当随顺。声闻乘人不应随顺。是故菩萨持不尽护戒。声闻乘人持尽护戒。云何名为菩萨持开遮戒。声闻乘人持唯遮戒。若诸菩萨于大乘中发趣修行。日初分时有所犯戒。于日中分不离一切智心。如是菩萨戒身不坏。若日中分有所犯戒。于日后分不离一切智心。如是菩萨戒身不坏。若日后分有所犯戒。于夜初分不离一切智心。如是菩萨戒身不坏。若夜初分有所犯戒。于夜中分不离一切智心。如是菩萨戒身不坏。若夜中分有所犯戒。于夜后分不离一切智心。如是菩萨戒身不坏。若夜后分有所犯戒。于日初分不离一切智心。如是菩萨戒身不坏。以是义故。菩萨乘人持开遮戒。设有所犯不应失念妄生忧悔自恼其心。于声闻乘有所犯者。便为破坏声闻净戒。何以故。声闻持戒。断除烦恼如救头然。所有志乐但求涅槃。以是义故。名声闻乘持唯遮戒

复次优波离。云何菩萨持深入戒。声闻乘人持次第戒。菩萨乘人。于恒沙劫受五欲乐游戏自在。未曾舍离菩提之心。如是菩萨不名失戒。所以者何。菩萨善能守护安住菩提之心。乃至梦中一切结使。不为其患。而是菩萨所有烦恼渐渐当尽。不应一生便尽诸结。声闻乘者。成熟善根如救头然。乃至一念不喜受生。以是义故。大乘之人。持深入戒。说有开遮。名不尽护。声闻乘人持次第戒。名曰唯遮。名为尽护。何以故。优波离。求大乘者。于阿耨多罗三藐三菩提。甚为难得。具大庄严乃能成就。是故菩萨虽于无量阿僧祇劫往来生死。终不生于厌离之心。以是义故。如来观察为大乘人不应一向说厌离法。不应一向说于速证涅槃之法。应当为说慈喜相应甚深微妙无染之法。远离忧悔无系着法。无障无碍性空之法。菩萨闻已。于生死中而无厌倦。决定圆满无上菩提

尔时优波离白佛言。世尊。若有菩萨贪心相应而犯于戒。或有菩萨嗔心相应而犯于戒。或有菩萨痴心相应而犯于戒。世尊。如是菩萨于三犯中何者为重

尔时世尊告优波离言。若诸菩萨修行大乘如恒沙劫。贪心相应而犯戒者。其罪尚轻。若一嗔心而犯于戒。其罪甚重。何以故。因贪犯戒摄受众生。因嗔犯戒弃舍众生。优波离。所有诸结能摄众生。菩萨于此不应生畏。所有诸结能舍众生。菩萨于此应生怖畏。优波离。如佛所说。贪欲难舍为过微细。嗔恚易舍为过粗重。痴难舍离过复粗重。优波离。于烦恼中。若难舍离小犯之罪。是诸菩萨应当堪忍。若易舍离大犯之罪。如是烦恼。乃至梦中不应忍受。以是义故。大乘之人因贪犯戒。我说是人不名为犯。因嗔犯戒为大犯戒。名大过患。名大堕落。于佛法中是大留难。优波离。若诸菩萨于毗尼中无善方便。贪相应犯便生怖畏。嗔相应犯不生怖畏。若诸菩萨于毗尼中有善方便。贪相应犯不生怖畏。嗔相应犯生大怖畏

尔时文殊师利法王子在大众中白佛言。世尊。一切诸法毕竟毗尼。何所调伏。佛告文殊师利。若诸凡夫了知诸法究竟毗尼。如来终不说于调伏。以不知故。如来为令觉了诸法毕竟毗尼。渐次为说诸毗尼法

尔时优波离白佛言。世尊。如来说此决定毗尼。文殊师利。于是法中未有所说。善哉世尊。愿令文殊师利为少解说。佛告文殊师利。汝今当说究竟毗尼善巧之义。是优波离愿乐欲闻。尔时文殊师利法王子语优波离言。一切诸法毕竟寂灭。心寂灭故。名究竟毗尼。一切诸法我不可得。无染着故。名不悔毗尼。一切诸法本性清净。无颠倒故。名最胜毗尼。一切诸法如如实际离诸见故。名清净毗尼。一切诸法不来不去。无分别故。名不思议毗尼。一切诸法无住无著。念念灭故。名净诸趣毗尼。一切诸法住虚空际。离诸相故。名自性远离毗尼。一切诸法无去来今。不可得故。名三世平等毗尼。一切诸法不可安立。心平等故。名永断疑惑毗尼。优波离。是为法界究竟毗尼。诸佛世尊依此成道。若善男子。于是法中不善观察。则为远离如来净戒。时优波离白佛言。世尊。文殊师利所说诸法不可思议

尔时世尊告优波离言。文殊师利所说之法。依不可思议无碍解脱。以是义故。凡所说法离诸心相。谓心解脱。增上慢人令得离于增上慢故

优波离白佛言。世尊。云何声闻及菩萨乘增上慢者。佛告优波离。若有比丘。作是思惟我断贪欲。名增上慢。我断嗔恚及以愚痴。名增上慢。贪欲法异。诸佛法异。名增上慢。嗔恚法异。诸佛法异。名增上慢。愚痴法异。诸佛法异。名增上慢。谓有所得名增上慢。谓有所证名增上慢。谓有解脱名增上慢。见诸法空名增上慢。见于无相名增上慢。见于无愿名增上慢。见于无生名增上慢。见无所作名增上慢。见有诸法名增上慢。见法无常名增上慢。谓诸法空何用修习名增上慢。优波离。是名声闻乘人增上慢者。云何名为菩萨乘人增上慢者。若诸菩萨作是思惟。我当发心求一切智。名增上慢。我当修行六波罗蜜。名增上慢。唯依般若波罗蜜。而得解脱。更无余法而得出离。名增上慢。此法甚深。此非甚深。名增上慢。此法是净。此法非净。名增上慢。此诸佛法。此缘觉法。此声闻法。名增上慢。此法应作。此不应作。名增上慢。此是深法。此非深法。名增上慢。此是近法。此非近法。名增上慢。此是正道。此是邪道。名增上慢。我于阿耨多罗三藐三菩提。为疾得耶。不疾得耶。名增上慢。一切诸法不可思议无能知者我能了知。名增上慢。乃至于不可思议阿耨多罗三藐三菩提。而起思惟为大执着。是名菩萨增上慢者

尔时优波离白佛言。世尊。云何比丘离增上慢。佛告优波离。若于一切不思议法无所执着。是名究竟无增上慢。尔时世尊。欲重宣此义。而说偈言

  一切戏论从心起　　不应分别法非法
  如是见法不思议　　彼人处世常安乐
  凡夫迷惑随心转　　多劫轮回诸有中
  若知法性皆无性　　是名真实不思议
  若有比丘念诸佛　　非善思惟非正念
  于佛妄生分别想　　而此分别无真实
  若有思惟于空法　　如是凡夫住邪道
  但以文字说于空　　文字与空何可得
  若有思惟寂静法　　是心非有本无生
  心行觉观皆戏论　　无念名为见诸法
  一切诸法无思念　　有心有念尽皆空
  若人爱乐观察空　　于此无念勿生念
  法同草木无知觉　　若离于心不可得
  众生自性无所有　　一切诸法皆如是
  如因日光眼能见　　夜则缘离无所睹
  若眼自能见色者　　何故待缘方能了
  眼常因彼诸光明　　能见种种青黄色
  当知见性依众缘　　是故知眼不能见
  设有闻诸悦意声　　闻已即灭而无住
  推其去处不可得　　以分别故生声想
  一切诸法但言声　　文字于中假安立
  是声无有法非法　　凡愚不知妄生着
  我为世间叹布施　　而施根本不可得
  无所说中而演说　　是故佛法不思议
  我常叹说持净戒　　亦无众生破戒者
  破戒之性犹虚空　　清净持戒亦如是
  我说忍辱为最胜　　无见无生为忍性
  实无少法可嗔者　　由是说名殊胜忍
  我说昼夜常精进　　寤寐恒觉为无上
  虽经多劫勤修行　　然于所作无增减
  禅定解脱及三昧　　开示世间如实门
  法性本来无所动　　随顺假说诸禅定
  观察觉了名智慧　　了知诸法名智人
  诸法自性无所有　　亦无观察了知者
  我常叹说修苦行　　爱乐头陀寂静法
  能知诸法不可得　　是名清净知足人
  我说地狱诸苦事　　死入大怖恶道中
  无量众生起厌心　　实无恶趣可来往
  刀杖鉾槊众苦具　　亦无有能造作者
  由分别故而见有　　无量楚毒迫其身
  园林种种妙花敷　　宫殿众宝相辉映
  亦无有人能作者　　皆从分别妄心生
  虚伪之法诳世间　　凡夫系着生颠倒
  犹如分别诸幻焰　　于此取舍悉皆空
  我说发趣菩提心　　利益世间最殊胜
  而实菩提不可得　　亦无发趣菩提者
  心性清净常光明　　真实无伪无爱染
  凡夫分别生贪着　　而彼烦恼本来空
  诸法自性常寂静　　何有贪欲及嗔痴
  不见生贪离欲处　　尔乃名为得涅槃
  其心未曾生染着　　由是成就大菩提
  于无数劫修众行　　度脱无量诸众生
  众生自性不可得　　实无众生可度者
  譬如世间大幻师　　化作无边千亿众
  还复害此诸化人　　于此幻化无增损
  一切众生如幻化　　求其边际不可得
  若知如是无边性　　斯人处世无疲厌
  了知诸法如实相　　常行生死即涅槃
  于诸欲中实无染　　调伏众生言离欲
  大悲利益诸众生　　而实无人无寿者
  不见众生而利益　　当知此事甚为难
  如以空拳诱小儿　　示言有物令欢喜
  开手拳空无所见　　小儿于此复号啼
  如是诸佛难思议　　善巧调伏众生类
  了知法性无所有　　假名安立示世间
  以大慈悲劝说言　　于我法中最安乐
  汝应出家舍恩爱　　当得沙门殊胜果
  既已出家勤修习　　如所修行得涅槃
  复观诸法如实相　　实无诸果而可得
  果无所有而得证　　于此方生希有心
  快哉大悲人师子　　善说相应如实法
  一切诸法如虚空　　安立百千名句义
  或说名为禅解脱　　或名根力或菩提
  而此根力本无生　　禅定菩提亦非有
  无色无形不可取　　但以方便示众生
  我说修行有所证　　当知远离一切相
  若谓于中有所得　　是则非证沙门果
  诸法自性无所有　　当于何处言得证
  所说得证为无得　　如是了知乃名得
  众生得果名殊胜　　我说众生本不生
  尚无众生而可得　　云何当有得果者
  譬如良田无种子　　于中终不有牙生
  如是众生不可得　　当于何所而言证
  一切众生性寂灭　　无有得其根本者
  若能了知如是法　　斯人灭度永无余
  过去无数百千佛　　无有能度众生者
  若此众生真实有　　毕竟无能得涅槃
  一切诸法皆寂灭　　未曾有法可生者
  若能如是见诸法　　彼人已出于三界
  是则无碍佛菩提　　于中究竟无所有
  若能了知如是法　　我说名为离欲人

尔时世尊说此偈已。二百比丘增上慢者。诸漏永尽心得解脱。六万菩萨得无生忍。尔时优波离白佛言。世尊。当何名此经。我等云何奉持。佛告优波离。此经名为决定毗尼。亦名摧灭心识。汝应受持。佛说此经已。尊者优波离。诸比丘众。文殊师利。并诸菩萨摩诃萨。及一切世间天人阿修罗等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第九十大宝积经卷第九十一

        三藏法师菩提流志奉　诏译

    发胜志乐会第二十五之一

如是我闻。一时佛在波罗奈城仙人住处施鹿苑中。与大比丘众满足千人。复有五百诸菩萨众。是时众中多有菩萨。业障深重诸根闇钝。善法微少好于愦闹。谈说世事耽乐睡眠。多诸戏论广营众务。种种贪着为所不应。忘失正念修习邪慧。下劣精勤行迷惑行。尔时弥勒菩萨摩诃萨。在于会中见诸菩萨具足如是不善诸行。作是念言。此诸菩萨于无上菩提圆满道分。皆已退转。我今当令是诸菩萨。觉悟开晓生欢喜心。作是念已。即于晡时从禅定起。往到其所共相慰问。复以种种柔软言词。为说法要令其欢喜。因告之曰。诸仁者云何汝等于无上菩提圆满道分而得增长不退转耶。是诸菩萨同声白言。尊者。我等今于无上菩提圆满道分。无复增长唯有退转。何以故。我心常为疑惑所覆。于无上菩提不能解了。云何我等当作佛耶不作佛耶。于堕落法亦不能了。云何我等当堕落耶不堕落耶。以是因缘善法欲生。常为疑惑之所缠覆。尔时弥勒菩萨。而告之曰。诸仁者。可共往诣如来应供正遍知所。而彼如来。一切知者一切见者。具足成就无障碍智解脱知见。以方便力。善知一切众生所行。当为汝等随其根性种种说法。是时五百众中有六十菩萨。与弥勒菩萨。往诣佛所。五体投地顶礼佛足。悲感流泪不能自起。弥勒菩萨。修敬已毕退坐一面

尔时佛告诸菩萨言。善男子。汝等应起。勿复悲号生大热恼。汝于往昔造作恶业。于诸众生以畅悦心。嗔骂毁辱障恼损害。随自分别。不能了知业报差别。是故汝等。今为业障之所缠覆。于诸善法不能修行。时诸菩萨闻是语已从地而起。偏袒右肩右膝着地合掌恭敬。而白佛言。善哉世尊。愿为我等说此业障。我等知罪当自调伏。我从今日更不敢作。尔时佛告诸菩萨言。善男子。汝曾往昔于俱留孙如来法中。出家为道。自恃多闻修持净戒。常怀憍慢傲逸之心。又行头陀少欲知足。于是功德复生执着。尔时有二说法比丘。多诸亲友名闻利养。汝于是人以悭嫉心。妄言诽谤行淫欲事。是时法师亲友眷属。由汝离间说其重过。皆令疑惑不生信受。彼诸众生于是法师。无随顺心断诸善根。是故汝等由斯恶业。已于六十百千岁中。生阿鼻地狱。余业未尽。复于四十百千岁中。生等活地狱。余业未尽。复于二十百千岁中。生黑绳地狱。余业未尽。复于六十百千岁中。生烧热地狱。从彼殁已还得为人。五百世中生盲无目。以残业故。在在所生常多蒙钝。忘失正念障覆善根。福德微少形容丑缺。人不喜见。诽谤轻贱戏弄欺嫌。常生边地贫穷下劣。丧失财宝资生艰难。不为众人尊重敬爱。从此殁已。于后末世五百岁中法欲灭时。还于边地下劣家生。匮乏饥冻为人诽谤。忘失正念不修善法。设欲修行多诸留难。虽暂发起智慧光明。以业障故寻复还没。汝等从彼五百岁后。是诸业障尔乃消灭。于后得生阿弥陀佛极乐世界。是时彼佛当为汝等授阿耨多罗三藐三菩提记

尔时诸菩萨等。闻佛所说举身毛竖。深生忧悔便自抆泪。前白佛言。世尊。我今发露悔其过咎。我等常于菩萨乘人。轻慢嫉恚及余业障。今于佛前如罪忏悔。我等今日于世尊前发弘誓愿

世尊。我从今日至未来际。若于菩萨乘人。见有违犯举露其过。我等则为欺诳如来

世尊。我从今日至未来际。若于菩萨乘人。戏弄讥嫌恐惧轻贱。我等则为欺诳如来

世尊。我从今日至未来际。若见在家出家菩萨乘人。以五欲乐游戏欢娱。见受用时。终不于彼伺求其过。常生信敬起教师想。若不尔者。我等则为欺诳如来

世尊。我从今日至未来际。若于菩萨乘人。悭亲友家及诸利养。恼彼身心令其逼迫。我等则为欺诳如来

世尊。我从今日至未来际。若于菩萨乘人。以一粗言令其不悦。我等则为欺诳如来

世尊。我从今日至未来际。若于菩萨乘人。昼夜六时不勤礼事。我等则为欺诳如来。世尊。我从今日至未来际。为欲护持此弘誓故不惜身命。若不尔者。我等则为欺诳如来。世尊。我从今日至未来际。若于声闻及辟支佛。以轻慢心。谓于彼等不胜于我。我等则为欺诳如来。世尊。我从今日至未来际。若不善能摧伏其身。生下劣想。如旃陀罗及于狗犬。我等则为欺诳如来

世尊。我从今日至未来际。若自赞叹于他毁呰。我等则为欺诳如来

世尊。我从今日至未来际。若不怖畏斗诤之处。去百由旬如疾风吹。我等则为欺诳如来

世尊。我从今日至未来际。若于持戒多闻头陀。少欲知足一切功德。身自炫曜。我等则为欺诳如来

世尊。我从今日至未来际。所修善本不自矜伐。所行罪业惭愧发露。若不尔者。我等则为欺诳如来

尔时世尊赞诸菩萨。善哉善哉。善男子。善说如是觉悟之法。善发如是广大誓愿。能以如是决定之心。安住其中。一切业障皆悉消灭。无量善根亦当增长。佛复告弥勒菩萨摩诃萨言。弥勒。若有菩萨为欲清净诸业障者。当发如是广大誓愿

尔时弥勒菩萨白佛言。世尊。颇有善男子善女人等护持此愿。当得圆满不退转耶。佛告弥勒菩萨言。有善男子善女人等。行菩萨道护持此愿。宁舍身命终不缺减令其退转

尔时弥勒菩萨。复白佛言。世尊。若有菩萨。于后末世五百岁中法欲灭时。成就几法。安隐无恼而得解脱。佛告弥勒菩萨言。弥勒。若有菩萨于后末世五百岁中法欲灭时。当成就四法。安隐无恼而得解脱。何等为四。所谓于诸众生不求其过。见诸菩萨有所违犯终不举露。于诸亲友及施主家。不生执着。永断一切粗犷之言。弥勒。是为菩萨于后末世五百岁中法欲灭时成就四法安隐无恼而得解脱。尔时世尊。欲重宣此义。而说偈言

  不求他过失　　亦不举人罪
  离粗语悭吝　　是人当解脱

弥勒。复有菩萨于后末世五百岁中法欲灭时。当成就四法。安隐无恼而得解脱。何等为四。所谓不应亲近懈怠之人。舍离一切愦闹之众。独处闲静常勤精进。以善方便调伏其身。弥勒。是为菩萨于后末世五百岁中法欲灭时成就四法安隐无恼而得解脱。尔时世尊。欲重宣此义。而说偈言

  当舍于懈怠　　远离诸愦闹
  寂静常知足　　是人当解脱

尔时世尊说此偈已。告弥勒菩萨言。弥勒。是故菩萨于后末世五百岁时。欲自无恼而解脱者。除灭一切诸业障者。应当舍离愦闹之处。住阿兰若寂静林中。于不应修而修行者。及诸懒堕懈怠之属。皆当远离。但自观身不求他过。乐于恬默。勤行般若波罗蜜多相应之行。若欲于彼诸众生等。深生怜愍多所饶益。应以无希望心清净说法

复次弥勒。若菩萨以无希望心行法施时。不著名闻利养果报。以饶益事而为上首。常为众生广宣正法。当得成就二十种利。云何名为二十种利。所谓正念成就。智慧具足。有坚持力。住清净行。生觉悟心。得出世智。不为众魔之所得便。少于贪欲。无有嗔恚。亦不愚痴。诸佛世尊之所忆念。非人守护。无量诸天加其威德。眷属亲友无能沮坏。有所言说人必信受。不为冤家伺求其便。得无所畏。多诸快乐。为诸智人之所称叹。善能说法众人敬仰。弥勒。是为菩萨当得成就二十种利。不著名闻利养果报。行饶益事而为上首。常为众生以无希望心清净说法

复次弥勒。若菩萨以无希望心行法施时。不著名闻利养果报。以饶益事而为上首。常为众生广宣正法。又能成就二十种利。云何名为二十种利。所谓未生辩才而能得生。已生辩才终不忘失。常勤修习得陀罗尼。以少功用善能利益无量众生。以少功用令诸众生起增上心恭敬尊重。得身口意清净律仪。超过一切恶道怖畏。于命终时心得欢喜。显扬正法摧伏异论。一切豪贵威德尊严。犹自不能有所窥望。何况下劣少福众生。诸根成就无能映蔽。具足摄受殊胜意乐。得奢摩他毗婆舍那。难行之行皆得圆满。发起精进普护正法。速疾能超不退转地。一切行中随顺而住。弥勒。是为菩萨当得成就二十种利。不著名闻利养果报。行饶益事而为上首。常为众生以无希望心清净说法

佛告弥勒。汝观未来后五百岁。有诸菩萨甚为无智。行法施时。若有利养生欢喜心。若无利养不生欢喜。彼诸菩萨为人说法。作如是心。云何常令亲友檀越归属于我。复更念言。云何当令在家出家诸菩萨等。而于我所生净信心。恭敬供养衣服饭食卧具汤药。如是菩萨。以财利故为人说法若无利养心生疲厌。弥勒。譬如有人志乐清净。或为死蛇死狗死人等尸。脓血烂坏系着其颈。是人忧恼深生厌患。以违逆故迷闷不安。弥勒。当知于后末世五百岁中。说法之人亦复如是。于诸一切无利养处。不顺其心无有滋味。便生厌倦弃舍而去。彼诸法师作如是念。我于此中说法无益。何以故。是诸人等。于我所须衣服饮食卧具医药。不生忧念何缘于此徒自疲劳。弥勒。是诸法师。自求供养给侍尊重。摄受同住及于近住。不为于法及利益事。而摄受之。是诸法师自求饮食衣服卧具。诈现异相。入于王城国邑聚落。而实不为利益成熟于诸众生。弥勒。我不说言。有希求者为法施清净。何以故。若心有希求则法无平等。我不说言。贪污心者能成熟众生。何以故。自未成熟能成熟他无有是处。弥勒。我不说言。尊重供养安乐其身。贪着摄受不净物者。为利益事。何以故。为求自身安隐丰乐。摄受众会。不能令其安住正信。弥勒。我不说言。矫诈之人住阿兰若。薄福德者而为少欲。贪胜味者名易满足。多求美膳以为乞食。弥勒。我不说言。乞求种种上妙衣服。谓如是等持粪扫衣。弥勒。我不说言。在家出家无识知者为离愦闹。弥勒。我不说言。谄曲之人值佛兴世求他短者。为如理修行。多损害者名戒蕴清净。增上慢者为多闻第一。弥勒。我不说言。好朋党者名住律仪。心贡高者名尊敬法师。绮语轻弄为善说法。与俗交杂。能于僧众离诸过失。弥勒。我不说言。简胜福田为施不望报。求恩报者为善摄诸事。求恭敬利养为志乐清净。多妄计者以为出家。弥勒。我不说言。分别彼我名乐持戒。不尊敬者名为听法。乐着世典咒诅言论。以为受法。弥勒。我不说言。于诸空性无胜解者。能出离生死。多执著者为离诸行。弥勒。我不说言。于菩提分住有所得。名为证智。弥勒。我不说言。无势力者忍辱成就。无娆触者被忍辱甲。少烦恼者名律仪清净。邪方便者为如说修行。弥勒。我不说言。爱言说者为一心住。好营世务于法无损。志乐清净堕诸恶趣。修习智慧为愦闹行。弥勒。我不说言。方便相应名为谄曲。不求利养而为妄语。无执著者诽谤正法。护正法者而惜身命。所行下劣为无胜慢。如是弥勒。于后末世五百岁中。当有菩萨。钝根小智谄曲虚诳。住于贼行。汝应护之。尔时弥勒菩萨。白佛言。世尊。最后末世五百岁中。唯此六十诸菩萨等。业障所缠。为复更有余菩萨耶。佛告弥勒菩萨言。弥勒。于后末世五百岁中。有诸菩萨。多为业障之所缠覆。是诸业障。或有消灭。或复增长。弥勒。于此五百诸菩萨中。有二十菩萨。业障微少。后五百岁还来生此。城邑聚落廛闬山野。种姓尊豪有大威德。聪明智慧善巧方便。心意调柔常怀慈愍。多所饶益。颜貌端严辩才清妙。数术工巧皆能善知。自隐其德安住头陀功德之行。在在所生舍家为道。已于无量阿僧祇俱胝劫中。积集阿耨多罗三藐三菩提。护持正法不惜身命。住阿兰若空闲林中。常勤精进不求利养。善入一切众生心行。咒术言论悉能了知。于诸义理少闻多解。辩才智慧皆悉具足。彼诸菩萨于是法中。精勤修习得陀罗尼无碍辩才。于四众中宣说正法。以佛威德加被力故。于佛所说修多罗。祇夜。受记。伽陀。优陀那。尼陀那。阿波陀那。伊帝越多伽。阇多伽。毗佛略。阿浮陀达摩。优波提舍。皆得辩才无碍自在。弥勒。彼诸二十善巧菩萨。从于和上阿阇梨所。得闻无量百千契经。皆能受持。当说是言。我此法门。从某和上阿阇梨所。亲自听受无有疑惑。弥勒。于彼时中。当有在家出家诸菩萨等。无有智慧善巧方便。于此受持正法菩萨所说之法。却生讥笑轻毁谤言。如是之法。皆由汝等善巧言词。随意制造。实非如来之所宣说。我等于中。不能信乐发希有心。弥勒。当尔之时。无量众生于是法师皆生诽谤。舍之而去。互相谓言。是诸比丘无有轨范。多诸邪说。不依契经。不依戒律。犹如倡伎戏弄之法。汝等于中。莫生信乐发希有心。非正法也。弥勒。彼诸愚人为魔所持。于是法中不能解了。谓非如来之所演说。于是持法诸比丘所。生于诽谤。作坏法业。以是因缘。当堕恶道。是故弥勒。若诸智慧善巧菩萨。欲护正法当隐其德。于多分别诸众生所。应须护念。莫令于汝生不善心

尔时弥勒菩萨。而白佛言。希有世尊。于后末世五百岁中。有诸菩萨甚为无智。于大众中诽谤正法及持法者。复于其中。当于辩才及陀罗尼。而于是法不能信受

世尊。譬如有人渴乏须水。往诣泉池而欲饮之。是人先来。投诸粪秽于此水中。后不觉知欲饮其水。便取嗅之。既闻臭已不饮其水。彼之自污更说其过。乃至叹言。奇哉此水甚大臭秽。是人过失都不觉知。而于是水反生怨咎。世尊如泉池者。当知即是持法比丘。由佛神力。于此法眼善能解说。又复如彼愚痴之人。若于泉池自投粪秽。后不觉知欲饮水者。世尊。最后末世五百岁中。有诸无智诸菩萨等。亦复如是。于彼正法及持法者。生诽谤已。复于是人听受法味。彼人自失都不觉知。以疑惑过污染意根。彼持法者当被戏弄。或受讥笑。乃至叹言。奇哉此法。为诸过失之所染污。彼无智人。于此正法及是法师。不能听受。伺求其短谤言污辱。生厌离心舍之而去

尔时世尊。赞弥勒菩萨言。善哉善哉。弥勒。善能演说如是譬喻。无能伺求说其短者。弥勒。以是因缘。汝应当知有四辩才一切诸佛之所宣说。有四辩才一切诸佛之所遮止。云何名为有四辩才一切诸佛之所宣说。所谓利益相应。非不利益相应。与法相应。非不与法相应。烦恼灭尽相应。非与烦恼增长相应。涅槃功德相应。非与生死过漏相应。弥勒。是为一切诸佛之所宣说四种辩才

弥勒。若比丘比丘尼。优婆塞优婆夷。欲说法者。应当安住如是辩才。若善男子善女人等。有信顺心。当于是人而生佛想。作教师想。亦于是人听受其法。何以故。是人所说。当知皆是一切如来之所宣说。一切诸佛诚实之语。弥勒。若有诽谤此四辩才。言非佛说。不生尊重恭敬之心。是人以怨憎故。于彼一切诸佛如来所说辩才。皆生诽谤。诽谤法已作坏法业。作坏法已当堕恶道。是故弥勒。若有净信诸善男子。为欲解脱诽谤正法业因缘者。不以憎嫉人故而憎嫉于法。不以人过失故而于法生过。不以于人怨故而于法亦怨。弥勒。云何名为四种辩才一切诸佛之所遮止。所谓非利益相应。不与利益相应。非法相应。不与法相应。烦恼相应。不与烦恼灭尽相应。生死相应。不与涅槃功德相应。弥勒。是为一切诸佛之所遮止四种辩才

尔时弥勒菩萨。白佛言。世尊。如佛所说。若有辩才增长生死。非诸如来之所宣说。云何世尊。说诸烦恼。能为菩萨利益之事。又复称赞摄取生死。而能圆满菩提分法。如是等辩。岂非如来之所说耶。佛告弥勒菩萨摩诃萨言。弥勒。我今问汝随汝意答。若有说言。菩萨为欲圆满成就菩提分故。摄取生死。又复说言。以诸烦恼为利益事。如是说者。为与利益相应。非利益相应。为与法相应。非法相应。弥勒菩萨。白佛言。世尊。若正说者。则与义利相应。与法相应。能令菩萨菩提分法得圆满故。佛言。弥勒。若说菩萨为欲圆满菩提分故摄取生死。说诸烦恼能为菩萨利益之事。如是辩才诸佛如来之所宣说。何以故。弥勒。此诸菩萨得法自在。所起烦恼无有过失。是为菩萨善巧方便。非诸声闻缘觉境界。弥勒。若有烦恼。不能为他作利益事。亦不能满菩提分法。而发起者。不与义利相应。不与法相应。但为下劣善根因者。菩萨于中宁舍身命。亦不随彼烦恼而行。何以故。弥勒。有异菩萨得智力故。于诸烦恼现有攀缘。有异菩萨无智力故。于诸烦恼增上执着

尔时弥勒菩萨。白佛言。世尊。如我解佛所说义。若诸菩萨。于后末世五百岁中。乐欲离诸业障缠缚。自无损害而得解脱。是人当于菩萨行中深生信解。于他过失不生分别。志求如来真实功德。佛言。如是如是。弥勒。是故当于诸菩萨等方便行中。深生信解。何以故。慧行菩萨方便之行。难信解故。弥勒。譬如须陀洹人示凡夫行。如是凡夫。与须陀洹位各差别。凡夫愚人。以贪嗔痴之所缠故堕诸恶道。而须陀洹于贪嗔痴善能了达。终不堕落三恶道耳。弥勒。慧行菩萨亦复如是。于贪嗔痴习气未断。彼亦别余初业菩萨。何以故。其心不为烦恼所覆。不同初业诸菩萨等。钝行菩萨无有善巧。同诸凡夫不能出离。弥勒。慧行菩萨一切重罪。以智慧力悉能摧灭。亦不因彼堕于恶道。弥勒。譬如有人。于大火聚投以薪木数数添之。如是添已。其焰转炽弥更增明无有尽灭。弥勒。慧行菩萨亦复如是。以智慧火烧烦恼薪。数数添于烦恼薪木。如是添已。智慧之火转更增明无有尽灭。弥勒。如是如是。慧行菩萨智慧之力。善巧方便难可了知

大宝积经卷第九十一大宝积经卷第九十二

        大唐三藏法师菩提流志奉　诏译

    发胜志乐会第二十五之二

尔时弥勒菩萨摩诃萨。白佛言。世尊。初业菩萨既出家已。未得慧力而欲得者。当舍何法。当修何法。未生慧力能令出生已生慧力能令增长。佛告弥勒菩萨言。弥勒。初业菩萨既出家已。欲令慧力而得增长。当于利养知其过失。应须舍离。若好愦闹世俗言话。耽着睡眠广营众务。乐诸戏论。如是过失皆应远离。是故应舍利养。修于少欲。舍诸愦闹乐于寂静。舍诸世话观于实义。初夜后夜远离睡眠。观察思惟随行修习。舍于众务及诸戏论。修出世道慈念众生。弥勒。初业菩萨既出家已。未得慧力而欲得者。是法应舍。是法应修。何以故。弥勒。彼诸菩萨既出家已。未得慧力而欲得者。不舍利养。不修少欲。未生慧力当令出生。已生慧力能令增长。无有是处。不舍愦闹。不住寂静。未生慧力当令出生。已生慧力能令增长。亦无是处。不舍世话。不观实义。未生慧力当令出生。已生慧力能令增长。无有是处。初夜后夜。耽着睡眠曾不觉悟。系念思惟不舍众务。好诸戏论。于出世道不能修行。于诸众生不生慈念。未生慧力当令出生。已生慧力能令增长。亦无是处。弥勒。是故菩萨。未得慧力而欲得者。应舍诸法。当须舍离。应修诸法。当须修习。何以故。菩萨智慧从因缘生。若无因缘终不能生。因缘和合尔乃得生。尔时弥勒菩萨。白佛言。世尊。云何名为利养中过。若观察时。能令菩萨乐于少欲不生热恼。佛言弥勒。初业菩萨当观利养。生贪欲故。当观利养。坏失正念生嗔恚故。当观利养。念其得失生愚痴故。当观利养。能生高下嫉妒心故当观利养。于亲友家悭吝耽着生诳惑故。当观利养。成就爱味生谄曲故。当观利养。舍四圣种无惭愧故。当观利养。一切诸佛所不许可。数习憍逸生高慢故。当观利养。于胜福田起于轻慢为魔党故。当观利养。众恶根本诸善坏故。当观利养。多所贪着犹霜雹故。当观利养。于亲友家瞻候颜色生忧恼故。当观利养。爱物损坏忧心乱故。当观利养。于四念处多所忘失白法羸故。当观利养。于四正勤多有退失。能令一切他论胜故。当观利养。自言已得神通智慧违背生故。当观利养。先得后失怨憎生故。当观利养。互相嗔嫌说其过恶多觉观故。当观利养。为于活命营诸世业。计度思惟安乐减故。当观利养。乃至禅定解脱三昧三摩钵底。心如淫女能退失故。当观利养。舍离智断。堕于地狱。饿鬼畜生。阎摩罗界。诸恶道故。当观利养。与提婆达多乌陀洛迦同。于法住堕恶道故。弥勒。初业菩萨。如是观察利养过失。乐于少欲。不生热恼。何以故。弥勒。少欲菩萨。于一切过皆悉不生。堪为诸佛清净法器。而不系属在家出家。住于真实最胜意乐。不为卑下亦不惊怖。离诸恶道堕落畏故。无能映蔽舍耽味故。众魔境界得解脱故。一切诸佛之所称赞。诸天及人亦当爱羡。于诸禅定而不染着。住边际故。其心质直无有谄曲。于五欲中亦不放逸。见其过故。如说修行能住圣种。同梵行者亦当爱乐。弥勒。若有菩萨智慧聪敏。于此功德能如是知。以胜意乐当舍利养。以胜意乐住于少欲。为断贪爱而发起故。尔时弥勒菩萨。白佛言。世尊。云何名为愦闹中过。若观察时。菩萨独处闲静不生热恼。佛言。弥勒。初业菩萨应当观察。愦闹过失有二十种。若观察时。能令菩萨独处闲静不生热恼。弥勒。云何名为乐于愦闹二十种过。一者不护身业。二者不护语业。三者不护意业。四者多饶贪欲。五者增长愚痴。六者耽着世话。七者离出世语。八者于非法中尊重修习。九者舍离正法。十者天魔波旬而得其便。十一者于不放逸未曾修习。十二者于放逸行常怀染着。十三者多诸觉观。十四者损减多闻。十五者不得禅定。十六者无有智慧。十七者速疾而得非诸梵行。十八者不爱于佛。十九者不爱于法。二十者不爱于僧。弥勒。是为菩萨观于愦闹二十种过。尔时世尊。重说偈言

  舍离诸贪嗔　　不住于愦闹
  若有专住彼　　是过不应作
  憍慢及觉观　　皆由愦闹生
  坏行无戒人　　称叹于愦闹
  愚人乐世论　　退失第一义
  放逸多觉观　　是过不应作
  比丘舍多闻　　言论不如理
  损减诸禅定　　常思惟世间
  耽着思惟者　　何得于寂静
  其心常散逸　　永离于正观
  速得非梵行　　諠杂无仪捡
  亦不曾爱佛　　及爱于圣众
  弃舍离欲法　　耽着非法言
  我常舍千身　　支分及头目
  为求无上道　　闻法无厌足
  是诸非法人　　少闻便厌舍
  我昔作国王　　为求四句偈
  妻子及财宝　　悉皆能施与
  何有于智者　　而不勤听法
  我尝舍一切　　非法之戏论
  为于百千劫　　难得解脱故
  汝等应欣乐　　志求微妙法
  若乐于解脱　　最胜功德者
  世间诸事业　　皆所不应问
  衣食无胜利　　亦不证涅槃
  当称叹最胜　　善来诸比丘
  应敷座令坐　　互说诸法要
  人身甚难得　　随分行白法
  读诵及禅定　　汝应如是问
  如来入涅槃　　遗法当灭坏
  比丘多放逸　　乐众弃闲静
  为饮食利养　　昼夜谈世话
  愚人于梦中　　惊怖而漂溺
  自知多毁犯　　当堕三恶道
  应生欢喜心　　独处于闲寂
  若在阿兰若　　志求无上道
  不应见人过　　自谓最尊胜
  憍恣放逸本　　莫轻下劣人
  彼于遗法中　　渐次而解脱
  比丘虽破戒　　深信于三宝
  是则解脱因　　不应见其过
  摧伏贪嗔难　　勿惊于放逸
  余习法应尔　　是故不须说
  若清净比丘　　伺他人过失
  是最非真实　　不名修正法
  如理修行者　　当须自观察
  求道诸比丘　　舍离恶言论
  常以欢喜心　　独处于闲静

尔时弥勒菩萨。复白佛言。希有世尊。耽着愦闹。乃有如是无量过恶。退失功德无有利益。增长烦恼堕诸恶趣远离白法。何有菩萨求善法者。闻是过失而不乐于独处闲静。尔时弥勒菩萨。白佛言。世尊。云何名为世话中过。若观察时。菩萨应住决定之义。由观是义不生热恼

佛言弥勒。初业菩萨。应当观察世话过失有二十种。若观察时。能令菩萨住决定义。由观是义不生热恼。弥勒。云何名为乐于世话二十种过。一者心生憍恣不敬多闻。二者于诸诤论多起执着。三者失于正念如理作意。四者为所不应身多躁动。五者速疾高下坏于法忍。六者心常刚强禅定智慧曾不熏修。七者非时而语言论所缠。八者不能坚固证于圣智。九者不为天龙之所恭敬。十者为辩才者常怀轻贱。十一者为身证者之所呵责。十二者不住正信常怀悔恨。十三者心多疑惑摇动不安。十四者犹如倡伎随逐音声。十五者染着诸欲随境流转。十六者不观真实诽谤正法。十七者有所希求常不称遂。十八者其心不调为人弃舍。十九者不知法界随顺恶友。二十者不了诸根系属烦恼。弥勒。是为菩萨乐于世话二十种过。尔时世尊。重说偈言

  憍傲于多闻　　执着诸诤论
  失念不正知　　是名世话过
  远离正思惟　　身心不寂静
  退失于法忍　　是名世话过
  其心不调顺　　远离奢摩他
  及毗钵舍那　　是名世话过
  不尊敬师长　　爱乐于世论
  智慧不坚固　　是名世话过
  诸天不恭敬　　龙神亦复然
  退失于辩才　　是名世话过
  圣者常呵责　　如是耽着人
  唐捐于寿命　　是名世话过
  诸行皆缺减　　远离大菩提
  命终生忧苦　　是名世话过
  疑惑心动摇　　犹如风吹草
  智慧不坚固　　是名世话过
  譬如倡妓人　　赞说他勇健
  彼人亦复然　　是名世话过
  随逐世语言　　染着诸欲境
  常行于邪道　　是名世话过
  希求心不遂　　谄曲多诤论
  远离于圣行　　是名世话过
  愚人得少利　　其心常摇动
  如猿猴躁扰　　是名世话过
  智慧多退失　　无有觉悟心
  愚者所摄持　　是名世话过
  迷惑于眼耳　　乃至意亦然
  常与烦恼俱　　是名世话过
  愚人乐世话　　尽寿常空过
  不如思一义　　获利无有边
  譬如甘蔗味　　虽不离皮节
  亦不从皮节　　而得于胜味
  皮节如世话　　义理犹胜味
  是故舍虚言　　思惟于实义
  智慧诸菩萨　　能知世话过
  常爱乐思惟　　第一义功德
  法味及义味　　解脱第一味
  谁有智慧者　　心生不欣乐
  是故应弃舍　　无利诸言话
  常乐勤思惟　　殊胜第一义
  如是第一法　　诸佛所赞叹
  是故明智人　　当乐勤修习

尔时弥勒菩萨。复白佛言。希有世尊。乃能善说世话过失。思惟胜义利益功德。世尊。何有菩萨。求于如来真实智慧。而复乐于虚诳世话

尔时弥勒菩萨。而白佛言。世尊。云何名为睡眠中过。若观察时。菩萨应当发起精进不生热恼。佛言。弥勒。初业菩萨。应当观察睡眠过失有二十种。若观察时。能令菩萨发起精进意乐无倦。弥勒。云何名为乐于睡眠二十种过。一者懈怠懒惰。二者身体沉重。三者颜色憔悴。四者增诸疾病。五者火界羸弱。六者食不消化。七者体生疮疱。八者不勤修习。九者增长愚痴。十者智慧羸劣。十一者皮肤闇浊。十二者非人不敬。十三者为行愚钝。十四者烦恼缠缚。十五者随眠覆心。十六者不乐善法。十七者白法减损。十八者行下劣行。十九者憎嫌精进。二十者为人轻贱。弥勒。是为菩萨乐于睡眠二十种过。尔时世尊。重说偈言

  身重无仪捡　　懈怠少堪任
  颜色无光泽　　是乐睡眠过
  彼人常病恼　　风黄多积集
  四大互违反　　是乐睡眠过
  饮食不消化　　身体无光润
  声嘶不清彻　　是乐睡眠过
  其身生疮疱　　昼夜常昏睡
  诸虫生机关　　是乐睡眠过
  退失于精进　　乏少诸财宝
  多梦无觉悟　　是乐睡眠过
  痴网常增长　　乐着于诸见
  炽盛难疗治　　是乐睡眠过
  损减诸智慧　　增长于愚痴
  志意常下劣　　是乐睡眠过
  彼住阿兰若　　常怀懈怠心
  非人得其便　　是乐睡眠过
  蒙愦失正念　　讽诵不通利
  说法多废忘　　是乐睡眠过
  由痴起迷惑　　住于烦恼中
  其心不安乐　　是乐睡眠过
  功德皆损减　　常生忧悔心
  增长诸烦恼　　是乐睡眠过
  远离诸善友　　亦不求正法
  常行非法中　　是乐睡眠过
  不欣求法乐　　损减诸功德
  远离于白法　　是乐睡眠过
  彼人心怯弱　　恒少于欢喜
  支分多羸瘦　　是乐睡眠过
  自知身懈怠　　嫉妒精进者
  乐说其过恶　　是乐睡眠过
  智者了其过　　常离于睡眠
  愚人增见网　　无利损功德
  智者常精进　　勤修清净道
  离苦得安乐　　诸佛所称叹
  世间诸伎艺　　及出世工巧
  皆由精进力　　智者应修习
  若人趣菩提　　了知睡眠过
  安住精进力　　觉悟生惭愧
  是故诸智者　　常生精进心
  舍离于睡眠　　守护菩提种

尔时弥勒菩萨。而白佛言。希有世尊。乐着睡眠乃有如是无量过失。若有闻者。不生忧悔厌离之心。发起精进。当知是人甚大愚痴。若有菩萨。为欲志求阿耨多罗三藐三菩提者。闻说如是真实句义功德利益于诸善法而生懈怠。不起精进住菩提分。无有是处。尔时弥勒菩萨。白佛言。世尊。云何名为众务中过。若观察时。令诸菩萨不营众务勤修佛道。佛言弥勒。初业菩萨。应当观察乐营众务二十种过。若观察时。能令菩萨不营众务勤修佛道。弥勒。云何名为二十种过。一我耽着世间下劣之业。二者为诸读诵修行比丘之所轻贱。三者亦为勤修禅定比丘之所呵责。四者心常发起无始生死流转之业。五者虚食居士及婆罗门净心信施。六者于诸财物心怀取着。七者常乐广营世间事务。八者念其家业常怀忧叹。九者其性佷戾发言粗犷。十者心常忆念勤修家业。十一者爱着诸味增长贪欲。十二者无利养处不生欢喜。十三者多生恼害障碍之业。十四者常乐亲近诸优婆塞及优婆夷。十五者但念衣食而度昼夜。十六者数问世间所作事业。十七者常乐发起非法语言。十八者恃营众务而起憍慢。十九者但求人过不自观察。二十者于说法者心怀轻贱。弥勒。是为菩萨乐营众务二十种过。尔时世尊。重说偈言

  安住下劣业　　远离殊胜行
  退失大利益　　是名众务过
  乐读诵比丘　　及修禅定者
  一切皆呵责　　是名众务过
  常行生死业　　舍离解脱因
  虚受于信施　　是名众务过
  乐受诸财宝　　不得生忧恼
  住于下劣行　　是名众务过
  是人多爱染　　往来淫女家
  如鸟入樊龙　　是名众务过
  常忧叹家业　　恒怀热恼心
  出言人不信　　是名众务过
  不受尊者教　　违拒而轻贱
  毁犯清净戒　　是名众务过
  其心多忆想　　勤营于世业
  不能修智断　　是名众务过
  贪心恒炽盛　　乐着于诸味
  曾无知足心　　是名众务过
  得利生欢喜　　无利便忧恼
  贪吝无仁心　　是名众务过
  恼害无慈愍　　增长诸恶业
  爱蔓相缠缚　　是名众务过
  远离于师长　　亲近恶知识
  摈斥持戒人　　是名众务过
  昼夜无余想　　唯念求衣食
  不乐诸功德　　是名众务过
  常问世间智　　不乐出世言
  耽爱于邪说　　是名众务过
  自恃知众务　　轻慢诸比丘
  犹如狂醉人　　是名众务过
  常伺求他短　　不自见其过
  轻毁有德人　　是名众务过
  如是愚痴者　　无有善方便
  轻慢说法者　　是名众务过
  如是下劣业　　具足诸过失
  何有智慧人　　爱乐而修习
  清净殊胜业　　具足诸功德
  是故有智人　　爱乐常修习
  若乐下劣业　　智者当呵责
  如人舍多财　　贪求于少分
  是故明智人　　当舍下劣业
  应求胜上法　　诸佛常称叹

尔时弥勒菩萨。而白佛言。希有世尊。彼诸菩萨舍离殊胜精进之业。而乃发起下劣之事。当知是人。甚为少智觉慧微浅。佛告弥勒菩萨言。弥勒。我今实言告汝。若有菩萨不修诸行。不断烦恼。不习禅诵。不求多闻。我说是人非出家者。弥勒。若有勤修智断行者。智出生者。智成就者。不作世业营众务者。我说是人。住如来教。若有菩萨。乐作世业营于众务。为所不应。我说是人住于生死。是故菩萨不应亲近。弥勒。若有菩萨。多营众务造七宝塔。遍满三千大千世界。如是菩萨。不能令我而生欢喜。亦非供养恭敬于我。弥勒。若有菩萨。于波罗蜜相应之法。乃至受持一四句偈。读诵修行为人演说。是人乃为供养于我。何以故。诸佛菩提从多闻生。不从众务而得生也。弥勒。若有菩萨勤营众务。令彼读诵修行演说诸菩萨等营于众务。当知是人。增长业障无诸福利。何以故。如是所说三种福业。一切皆从智慧而生。是故弥勒。营事菩萨。于彼读诵修行演说诸菩萨所。不应障碍为作留难。读诵修行演说菩萨。于修禅定诸菩萨所。不应障碍为作留难。弥勒。若一阎浮提营事菩萨。于一读诵修行演说菩萨之所。应当亲近供养承事。若一阎浮提读诵修行演说诸菩萨等。于一勤修禅定菩萨。亦当亲近供养承事。如是善业。如来随喜如来悦可。若于勤修智慧菩萨。承事供养。当获无量福德之聚。何以故。智慧之业无上最胜。超过一切三界所行。是故弥勒。若有菩萨发起精进。于智慧中当勤修习

尔时弥勒菩萨。白佛言。世尊。如来善说初业菩萨乐于愦闹世话睡眠众务过失。世尊。云何名为戏论中过。若观察时菩萨当得住于寂静无诸诤论。佛言弥勒。初业菩萨戏论过失无量无边。我今略说有二十种。云何名为二十种过。一者于现在生多诸苦恼。二者增长嗔恚退失忍辱。三者为诸怨对之所恼害。四者魔及魔民皆生欢喜。五者未生善根皆悉不生。六者已生善根能令退失。七者增诸斗诤怨竞之心。八者造作地狱恶趣之业。九者当得丑陋不善之果。十者舌不柔软言词謇涩。十一者所受教法不能忆持。十二者于未闻经闻之不悟。十三者诸善知识皆悉舍离。十四者诸恶知识速当值遇。十五者修行于道难得出离。十六者不悦意语数数常闻。十七者在在所生多诸疑惑。十八者常生难处不闻正法。十九者修行白法多有障碍。二十者于所受用多诸怨嫉。弥勒。是为菩萨耽着戏论二十种过。尔时世尊。重说偈言

  现生常苦恼　　离忍多嗔恚
  怨仇生害心　　是名戏论过
  魔及魔眷属　　皆生欢喜心
  丧失诸善法　　是名戏论过
  未生善不生　　常住于斗诤
  造于恶趣业　　是名戏论过
  身体多丑陋　　生于下劣家
  发言常謇涩　　是名戏论过
  闻法不能持　　或闻不入耳
  常离诸善友　　是名戏论过
  值遇恶知识　　于道难出离
  常闻不顺语　　是名戏论过
  随彼所生处　　常怀疑惑心
  于法不能了　　是名戏论过
  常生八难中　　远离无难处
  具足无利益　　是名戏论过
  于善多障碍　　退失正思惟
  所受多怨嫉　　是名戏论过
  如是诸过失　　皆因戏论生
  是故有智人　　速疾当远离
  如是戏论者　　难证大菩提
  是故有智人　　亦应不亲近
  戏论诤论处　　多起诸烦恼
  智者应远离　　当去百由旬
  亦不近于彼　　造立诸舍宅
  是故出家人　　不应住诤论
  汝等无田宅　　妻子及僮仆
  乃至荣位等　　何缘兴诤论
  出家住寂静　　身被于法服
  诸仙咸敬事　　当修忍辱心
  如是戏论者　　增长毒害心
  当堕于恶趣　　是故应修忍
  囚禁及系缚　　刑害而捶楚
  如是等诸苦　　皆由诤论生
  如是戏论者　　常遇恶知识
  名称不增长　　曾无欢喜心
  若舍于诤论　　无能伺其便
  眷属不乖离　　当遇于善友
  于乘得清净　　业障尽无余
  摧伏于魔军　　勤修忍辱行
  诤论多诸过　　无诤具功德
  若有修行者　　当住于忍辱

尔时弥勒菩萨。复白佛言。希有世尊。乃能善说如是过失。令诸菩萨生觉悟心。世尊。于后末世五百岁中。颇有菩萨。闻说如是诤论过失。能生忧悔离烦恼不。佛告弥勒菩萨言。弥勒。于后末世五百岁中。少有菩萨。能生忧悔舍离烦恼。多有菩萨。其心刚强不相尊敬。怀增上慢互相是非。闻说如是甚深义趣殊胜功德。虽复受持读诵演说。由是菩萨业障深重。不能得生殊胜功德。便于是经疑惑不信。不复受持为人演说。时魔波旬见是事已。为诳惑故作比丘像。来到其所。说如是言。此诸经典皆是世俗。善文词者之所制造。非是如来之所宣说。何以故。此经所说功德利益汝皆不得。由魔波旬如是诳惑。于此空性义利相应甚深契经。心生疑惑起诸诤论。不复受持读诵演说。弥勒。彼诸愚人不能了知。由自业故。不能护彼殊胜功德。自业消已。决定当得如是功德。尔时弥勒菩萨。白佛言。世尊。如佛所说。阿弥陀佛极乐世界功德利益。若有众生发十种心。随一一心。专念向于阿弥陀佛。是人命终。当得往生彼佛世界。世尊。何等名为发十种心。由是心故。当得往生彼佛世界。佛告弥勒菩萨言。弥勒。如是十心。非诸凡愚不善丈夫具烦恼者之所能发。何等为十。一者于诸众生起于大慈无损害心。二者于诸众生起于大悲无逼恼心。三者于佛正法不惜身命乐守护心。四者于一切法发生胜忍无执着心。五者不贪利养恭敬尊重净意乐心。六者求佛种智于一切时无忘失心。七者于诸众生尊重恭敬无下劣心。八者不着世论于菩提分生决定心。九者种诸善根无有杂染清净之心。十者于诸如来舍离诸相起随念心。弥勒。是名菩萨发十种心。由是心故。当得往生阿弥陀佛极乐世界。弥勒。若人于此十种心中随成一心。乐欲往生彼佛世界。若不得生无有是处。尔时尊者阿难。白佛言。希有世尊。乃能开示演说如来真实功德。发起菩萨殊胜志乐。世尊。当何名此经。我等云何受持。佛告阿难言。此经名为发起菩萨殊胜志乐。亦名弥勒菩萨所问。以是名字汝当受持。佛说此经已。弥勒菩萨及诸声闻。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第九十二大宝积经卷第九十三

        后秦三藏法师罗什译

    善臂菩萨会第二十六之一

如是我闻。一时佛在王舍城迦兰陀竹园。尔时有菩萨摩诃萨善男子。名曰善臂。来至佛所头面礼佛足。礼已却坐一面。尔时世尊。告善臂菩萨言。善男子。是六波罗蜜。菩萨常当具足。何等六。檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。善男子。是六波罗蜜。菩萨常当具足。善臂。云何菩萨具足行檀波罗蜜。善臂。菩萨于诸聚落正命求财非邪命求。随顺不逆。不困逼众生。以求财物而行布施。非为恭敬供养名称等故而行布施。非羞畏故。非果报故。非生天故。非谀谄故。于持戒毁戒不起毁誉。或是所识。或非所识。而于其中以平等心。供养恭敬尊重赞叹。亦于持戒毁戒。若亲不亲所识不识。若怨非怨。恒以深重敬爱信乐。是菩萨随其所有。常应惠施。有少施少。有多施多。有粗施粗。有细施细。有妙施妙。有不妙施不妙。若以上馔甘馔饮食价直十万。持用施人。或分一钱为十六分。持一分用施。其心欢喜等无差别。善男子。是菩萨于诸乞食者。须食施食。为具足一切智力故。须饮施饮。为断众生渴爱力故。须衣施衣。为得无上惭愧衣故。须乘施乘。为得菩萨乘佛乘故。须香施香。为得正觉持戒香故。须华施华。为得如来七觉花故。须末香者施以末香。为得除灭一切众生不善香故。须涂香者施以涂香。为得无缺戒香身故。须盖施盖。为断众生烦恼火故。须革簁者施以革簁。为受无量智慧乐故。须床施床。为令众生得释梵圣床快乐力故。须坐处者施以坐处。为坐菩提树下。诸魔结使不能坏乱其坐处故。须舍施舍。为令众生得覆护处。无所怖畏得无我力故。以好园观奉施佛僧。为得无上寂静禅定力故。持妙供具种种庄严。施诸佛塔庙。为得三十二相八十种好大丈夫力故。若于佛塔及闇道中。然灯施明。为得无量佛眼明故。以种种伎乐供养三宝。为得无量天耳故。以衣钵施。为得无上端严持戒故。以扇澡盥持用施人。为令众生得凉清净故。以纸笔墨及高座施。为得无上大智慧故。施病者药。为除众生结使病故。以地施他。为令众生得三乘分甘露界故。造塔形像。为令众生听正法故。所有之物速以施人。为得神通捷疾力故。布施清净。为于无上道中不留难故。常施不绝。为得无断辩才力故。随意布施。为令众生得大悲故。不逼人求财持用布施。为令诸魔外道不能坏乱。自然得成无上道故。菩萨布施。应如上所说而行惠施。若菩萨欲作如上施者。或自无财当生心施。欲得开示无量无边一切众生。有力无力。如上布施。是我善行。我是妙胜。是我宝物。能令一切世间众生。所有快乐悉得成就。所谓得和合乐。能舍一切。无有狐疑。诸所有愿悉皆成就。得安乐行。若诸世间所有众生。悕望欲得所须之物。我当满足与之。珍宝金银衣服钱财。犹如山积。饮食之具如大巨海。无量无边。是菩萨于昼夜各三时中。以己所作财施法施所得果报。愿与一切众生共之。令过去未来现在一切有行众生。生妙国界及出世乐。是人虽作如是布施。终不悕望求其果报。开示如是方便。为化众生入于善法。是菩萨布施时。愿令一切众生得度得解脱。为得一切智具足一切佛法故。若布施布施已。亦愿众生得度得解脱。为得一切智具足一切佛法故。如此布施。若无有力。不能学之不能舍财。是菩萨应如是思惟。我今当勤加精进。时时渐渐。断除悭贪吝惜之垢。我当勤加精进。时时渐渐。学舍财施与。常令我施心增长广大。乃至生有终不懈怠。心常欢喜。如是菩萨。发菩提心。念菩提心。修菩提心。悕望菩提。愿求菩提。是名菩萨无量阿僧祇大施大舍大出。何以故。如是布施。于诸施中最胜第一。令我未来之世于一切世间所有众生中。雨法雨。雨甘露雨。施法雨。施甘露雨。出法雨。出甘露雨。善臂。菩萨摩诃萨如是行施。不以为难。以为喜乐。速疾具足檀波罗蜜。善男子。菩萨不能自以身体支节施于乞者。若自割。若教他割。何以故。若成是业。令彼乞者于大地狱受无量罪故。菩萨摩诃萨。不应自惜身体支节。所以者何。欲令乞者远离广大不善业故。若有乞士。来从菩萨乞索所须。是时菩萨若自无财。不应强逼父母妻子眷属亲戚奴婢取其财物。令其贫匮持以施人。何以故。菩萨摩诃萨。欲于一切众生中。行平等慈心故。若菩萨摩诃萨。不逼父母妻子眷属亲戚奴婢。财物持用惠施。菩萨尔时。于众生中得慈悲心。善男子。菩萨不应于他众生有悭吝心。以逼他众生取财惠施。诸佛世尊所不赞叹。何况自割支节施于他人。是名菩萨具足檀波罗蜜。善臂。云何菩萨摩诃萨具足尸波罗蜜。善臂。是菩萨于一切众生。乃至尽形。自不杀生。教他不杀愿不杀生。自不偷盗。教人不偷盗愿不偷盗。自不邪淫。教人不邪淫愿不邪淫。自不妄语。教人不妄语愿不妄语。乃至尽形。自不饮酒。教人不饮酒愿不饮酒。是菩萨于此五戒中。常坚持专念。不缓不缺勤加精进。如是恐怖他人系缚囚执鞭杖刑戮。于此事中永断远离。及两舌恶口妄语绮语。亦复如是。是菩萨如是思惟。我应于一切众生。生爱念心。犹如父母爱念一子。若我父母。以种种苦事弓箭刀杖。加害于我。我于是中终不生报。我于一切众生。应如父母爱念一子。譬如父母妻子别离既久。一旦相见其心欢喜踊跃无量。如是菩萨见一切众生。其心欢喜亦复如是。是菩萨持不杀戒。欲令众生得住无学不杀戒故。是菩萨持不盗戒。欲令众生得住无学不盗戒故。是菩萨持不邪淫戒。欲令众生得住无学不淫戒故。是菩萨持不妄语戒。欲令众生得住无学实语戒故。是菩萨持不饮酒戒。欲令众生得住无学不饮酒戒故。是菩萨持不恐怖戒。为得成就金刚定故。是菩萨持不系缚戒。欲令一切众生断结使缚故。是菩萨持不囚执戒。欲令众生出五道故。是菩萨持不鞭杖戒。为欲远离诸魔结使留难得法定故。是菩萨持不刑戮戒。为令身口意得不护业故。是菩萨持不两舌戒。为得不坏和合众故。是菩萨持不恶口戒。为得五种梵音声故。是菩萨持不绮语戒。为得发言说法无障碍故。是菩萨持求畏死众生戒。欲令一切众生脱生老病死忧愁悲恼恐怖断故。是菩萨爱护他物不令漏失戒。为得无上菩提觉定故。有他众生妇女妻子。或被拘录。尔时菩萨于中救脱。为得不缺法定故。是菩萨若劝他令放。为得心自在故。是菩萨若自放或劝他令放。为坐菩提树下破坏一切魔结使故。是菩萨若见系狱众生。若自放若劝他令放。为得心自在无障碍故。是菩萨若见众生当得鞭杖。若自放若劝他令放。为得四无所畏故。是菩萨若见众生当被刑戮。若自放若劝他令放。为得四种法身故。是菩萨持不诳戒。为坐菩提树下师子座处。一切魔结使不能留难。得法定故。是菩萨善和斗诤专生欢喜。为得不坏大圣众故。是菩萨持爱语戒。欲令一切众生耳闻好语。心得欢喜乐故。是菩萨随爱语说。欲令言不虚故。是菩萨持读佛文词戒。为得圣人威德成就大众故。是菩萨受持于三时中五体归命一切世间在在处处过去未来现在无量无边诸佛法僧菩萨戒。为得菩提树下师子座处不可破坏。专住信精进念定慧。得法定故。是菩萨受持于三时中扫洒绕塔戒。为得具足一切佛法故。是菩萨持赞法戒。为得转于无上法轮故。是菩萨持赞僧戒。为得大众围绕故。是菩萨持三时归依三宝戒。欲令一切众生得无上归依故。是菩萨受持于三时中愿使一切世间常有佛法僧菩萨不空者戒。为得无上菩提乐故。是菩萨受持于三时中劝请一切诸佛一切说法戒。为得十住雨法雨故。是菩萨受持于三时中忏悔诸罪舍出诸恶秽污戒。为得断灭一切爱习气故。是菩萨受持于三时中和合一切善根戒。为令一切波罗蜜满足故。是菩萨受持于三时中念一切世间在在处处过去未来现在诸佛声闻缘觉圣众菩萨下至六趣众生所有善根愿戒。为得无上菩提资用故。是菩萨受持于三时中愿求菩提戒。为得无上菩提正决定故。是菩萨于三时中受持一切善根无上道戒。为得毕定如来力无所畏故。是菩萨受持供给父母师长戒。为得无胜法定故。是菩萨若见恐畏贫穷之人。受持不恐怖供施戒。为得无破坏难论方便故。是菩萨受持救护县官盗贼水火戒。为得诸力波罗蜜故。是菩萨若见佛缘觉声闻菩萨神足变化随而持戒。为得无上神足力故。是菩萨受持护他心身口意业戒。为得如来无量知他心力故。是菩萨若见放逸失念者。所谓失现在未来三乘义者。愿起念持不失故。是菩萨持听法集法说法戒。为得具足四无碍辩故。是菩萨持一切身口意业善根摄受奉行。欲令一切众生得度得解脱。为得一切智具足一切佛法故。如是善根。愿为一切众生受行。为令众生得解脱。得一切智。具足一切佛法故。如是持戒不缺不破不荒。若无力势能修学者。是菩萨应如是思惟。今我当勤加精进。时时渐渐。远离杀害诸不善法。我复倍加精进。时时渐渐。善学持戒令增长满足。乃至生有终不懈怠。不生忧愁。善臂。如是菩萨摩诃萨。发起菩提心。念菩提心。修菩提道。悕望菩提。愿求菩提。是名无量无边持戒善根。何以故。如此持戒。一切善戒中最胜第一。受持是戒。欲令一切世间所有众生发起无漏戒。发起无学戒。生无漏戒。生无学戒。善臂。如是菩萨摩诃萨于此持戒。不以为难。以为喜乐。速疾具足尸波罗蜜

善臂。云何菩萨摩诃萨。具足羼提波罗蜜。是菩萨若自眷属若他众生。来夺菩萨命者。菩萨尔时于此事中。终不生于嗔报之心。或有他人。来夺菩萨财物乃至妻子。若说两舌恶口妄言绮语。若有恐怖系缚囚执鞭杖刑戮。以种种苦加于菩萨。菩萨尔时。亦复不生还报之心。若夺命根及一切物乃至妻子。若说两舌恶口妄言绮语。恐怖系缚囚执鞭杖刑戮。是菩萨思惟如是诸事。是我恶行不善业报自作自受。或过去世。或现在世。若先作已今受果报。我今云何于自果报而嗔于他。复次善臂。菩萨如是思惟。若有他人夺我命根及诸财物乃至妻子。若说两舌恶口妄言绮语。若有恐怖系缚囚执鞭杖刑戮。我于此中。不应嗔害加他系缚冤家。何以故。我今现世受少苦恼。尚不爱喜不可适意。云何生嗔加害于他。于当来世。受诸罪报。无量无边百千万亿苦恼甚多。不喜不爱不可适意诸果报也

复次善臂。菩萨如是思惟。有命根故断截命根。有财物故克夺财物。有妻子故夺其妻子。有耳根故。闻两舌恶口妄言绮语。有此身故。有恐怖系缚囚执鞭杖刑戮。今我自受命根耳根身受苦入。云何以嗔加害于他。复次善臂。菩萨摩诃萨如是思惟。眼根即是地大。即是自物。即是法界。即是自性。湿性水。热性火。动性风。即是己物。即是法界。即是自性。如是一切命。即是坏法灭法尽法。如是一切诸根。是苦法。是苦触法。是受苦法。一切身即是苦法。是苦触法。是受苦法。即是己物。即是法界。即是己性。我今此命。即是坏法灭法尽法苦法。此六根即是苦触法。即是恶触触。我今云何自于此命坏法灭法尽法。而生嗔恚侵害于他。系缚冤家。何以故。即是己物。即是法界。即是自性。复次善臂。菩萨摩诃萨如是思惟。内眼耳鼻舌身意。非我非我所。外眼耳鼻舌身意。亦非我非我所。云何明智之人。于此六根非我非我所中。庄严爱着。生于嗔恚加害他人。复次善臂。菩萨摩诃萨。如是思惟。人中苦少。饿鬼苦多。畜生中苦转复增多。地狱苦恼。无量无边不可计倍。人中少苦尚不欲受。何况于未来世中。受三恶道无量苦恼。是故我今不应生嗔加害于他。复次善臂。菩萨摩诃萨如是思惟。我今若能利益一人。尚不应嗔。加害于他系缚冤家。何况我当以甚深法义。利益一切世间无量众生。发大庄严。大庄严已。得受记别趣于大乘。而得具足无上佛法。是佛法中。不应不忍侵害于他憎嫉斗讼。此中应行忍辱利益于他。善和斗讼不怀嫉妒。善臂。若有善男子善女人。乃至阿鼻地狱受诸苦痛。于冤家许。尚不应生嗔加害侵毁。何况人中受少苦恼。当生嗔害于他。是善男子善女人。为他所嗔。骂詈诃责。诽谤轻毁。称扬恶名。如是诸恶悉应忍之。起慈悲心纯净无垢。欲得如来心故。是菩萨受诸鞭杖恐怖系缚囚执。于此事中。悉应忍之起慈悲心。为于一念中间破一切无明闇障[穀-禾+卵]故。是菩萨受行忍辱慈悲心。欲令一切众生断爱恚故。若割耳时。亦行忍辱起慈悲心。欲令一切众生闻法信故。若割鼻时。亦行忍辱起慈悲心。为受端严无上持戒香故。若截足时。亦行忍辱起慈悲心。为得如来四神足故。若截手时。亦行忍辱起慈悲心。为欲摄取一切众生得寂静故。若分解支节时。亦行忍辱起慈悲心。为令具足六波罗蜜故。若挑眼时。亦行忍辱起慈悲心。为得慧眼故。若斩首时。亦行忍辱起慈悲心。为得如来一切智首故。是菩萨如是忍辱趣向思惟。愿令一切众生得度得解脱。为得一切智具足一切佛法故。如是忍辱。我今趣向思惟已。愿令一切众生得度得解脱。为得一切智具足佛法故。如是忍辱。不破不缺不荒。若无力势不能学者。是时菩萨应如是思惟我今当勤加精进。时时渐渐。远离断灭不忍之法。今我勤加精进。时时渐渐勤学忍辱。令此忍辱增广具足。乃至生有。终不懈怠不生忧愁。如是菩萨摩诃萨。发菩提心。念菩提心。修菩提心。悕望菩提。愿求菩提。是菩萨发起正行。如是等无量无边阿僧祇善忍。欲令一切世间所有众生。发起无漏忍辱。发起无学忍辱。生无漏忍辱。生无学忍辱。善臂。如是菩萨摩诃萨行于忍辱。不以为难。以为喜乐。速疾具足羼提波罗蜜

善臂。云何菩萨摩诃萨。具足毗梨耶波罗蜜。善臂。是菩萨应如是思惟。今此十方一一方面。有无量世界。一一世界。有无量无边众生集聚。无有边际。我今当发庄严。令此众生得大利益。亦令得乐。复次观知无量众生利益快乐所缘之法故。发起善根法故。我于无量昼夜。若心放逸。或生余念。若睡眠时。常念念中增长福德。于一一念中。发起无量无边善根菩提资用。我今当知一一念中。发起增益无量善根故。成阿耨多罗三藐三菩提。则不为难。今我以此缘故。我见菩萨甚为易得。是故欲得无上道者。乃至尽形不应懈怠。复次善臂。菩萨摩诃萨如是思惟。若菩萨于无量无边世界众生中。能令一世界众生得离一切诸苦者。我尚于一一念中。发起增益无量善根。何况乃令无量无边世界众生。远离断除生老病死。恩爱别离。冤憎集会。三恶道苦。复次善臂。菩萨摩诃萨如是思惟。若菩萨摩诃萨于一念中。欲令无量无边世界所有众生。远离断除一切诸苦者。此菩萨亦于一念之中。得发起增益无量善根。况当欲令未来无量无边阿僧祇劫。无量无边世界众生。远离断除生老病死。恩爱别离。冤憎集会。三恶道苦。复次善臂。菩萨摩诃萨应如是思惟。若有人欲得声闻缘觉法。是人尚得于一一念中。发起增益无量无边善根。何况有善男子善女人。欲成就具足佛法无量无边威德力势者。善男子善女人。四因四缘四境界。于昼夜中。若心放逸。或生余念。若睡眠时。于一一念中。修集四无量无边善根。发起增益菩提资用。我今当知。一一念中。发起增益四无量善根。成阿耨多罗三藐三菩提。则不为难。以是缘故。我见菩提甚为易得。是故欲得菩提道者。乃至尽形不应懈怠譬如四大海。若南若北若上若下易得边际如是四无量善根大海。菩提资用。难得其边。我今何故。不于一一念中发起增益四无量善根大海菩提资用。是故欲成无上道者。乃至尽形不应懈怠。复次善臂。菩萨摩诃萨如是思惟若有师子狐狼。鹫鹊乌鸟。蛟虻蝇蚤。如是等类尚得无上道已。况我今者生于人中。而应懈怠。是故欲成无上道者。乃至尽形不应懈怠。复次善臂。菩萨摩诃萨如是思惟。乃至百人千人。犹尚得成无上道已。而我今者独不得成。况复十方如恒河沙等。现在未来诸佛世尊。已成当成。是故我今乃至尽形不应懈怠。是菩萨复应如是思惟。若有法是佛所说。若声闻说。若菩萨说。乃至狂愚人为佛故说。所谓檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。是菩萨为具足佛法欲成无上道。欲得一切智。于此法中。勤加精进如救头然。学持通利。思惟分别为他解说。智慧精进一心思惟。是菩萨若一切众生有说法之处。乃至刀杖之难。要至其所听其所说。或有众生修乐报业。若现世乐。若后世乐。菩萨尔时。即以善法妙义如法佐助于此善法亦复勤加精进。是菩萨自以己身施于众生。令得自在。譬如四大。一切众生于中自在随所须用。菩萨摩诃萨以身施人。令他自在亦复如是。智慧精进乃至刀杖之难。常于佛法僧中。及诸师长。羸老病苦。贫穷无护。增益供养恭敬。使令勤加精进如救头然。随众生心。布施爱语利益同事。随所摄之。欲得声闻乘者。调伏安置于声闻乘。欲得缘觉乘者。调伏安置于缘觉乘。欲得菩萨乘者。调伏安置于菩萨乘。智慧精进如救头然。是菩萨为善法故。六波罗蜜因缘故。不计寒热饥渴。蚊虻毒螫。风飘日曝。恶触诽谤骂詈。种种苦恼疲极睡眠。于此事中。乃至尽形终不忆念。智慧精进如救头然。乃至刀杖之难亦不懈怠。是菩萨为无上道因缘故。能受种种苦。所谓阿修罗人三恶道苦。不以为难。智慧精进如救头然。是菩萨牢强精进意勇坚固。欲出于世成佛无上精进之力。是菩萨欲得毗梨耶波罗蜜。趣向毗梨耶波罗蜜。愿令众生得度得解脱故。为得一切智具足一切佛法故。我今趣向毗梨耶波罗蜜已。愿令众生得度得解脱故。为得知一切智具足一切佛法故。如是精进。不破不缺不荒。若无力势不能具足学者。是菩萨如是思惟。我今当勤加精进。时时渐渐。断除懈怠懒惰。复当勤加精进。时时渐渐善学精进。令此精进增广具足。乃至生有。终不懈怠不生忧愁。如是菩萨。发起菩提心。念菩提心。修菩提心。悕望菩提。是名无量无边阿僧祇善精进波罗蜜。何以故。如是精进于余善法精进中。最胜第一。欲令一切世间。在在处处所有众生。发起无漏精进发起无学精进生无漏精进。生无学精进。善臂。如是菩萨摩诃萨行于精进。不以为难。以为喜乐。速疾具足毗梨耶波罗蜜

大宝积经卷第九十三大宝积经卷第九十四

        后秦三藏法师罗什译

    善臂菩萨会二十六之二

善臂。云何菩萨摩诃萨。具足行禅波罗蜜。菩萨。若眼见色不取其相。或时眼根为外缘所牵。应正行守护不令随缘。不留心于无明贪着世间。护持是戒。尔时具足得眼根戒。耳闻声。鼻嗅香。舌尝味。身觉触。意知法。亦如是。是菩萨若行住坐卧。若说法若默然。终不远离寂定之心。善护手足无有散乱。常怀惭愧善护口业。安详直视。心常寂静不喜戏笑。善御身口意业。令其寂静。若屏猥处及现露处。无有异心。于所须物衣服饮食卧具医药心常知足。易养易满易可使令。善行寂静远离愦闹。于利衰毁誉称讥苦乐。心无有异。不高不下。命及非命亦无异心。无嗔无爱。等视冤家犹如赤子。于忍不忍心常平等。圣声凡声寂声乱声。亦复如是。憎爱色中心不高下。离染嗔恚爱不爱者。声香味触法亦复如是。是菩萨观欲如骨璅。邪忆想故。发起此心。观欲如肉团多怨憎故。观欲如炬火。染着苦法远离乐故。观欲如树上果。多人爱着故。观欲如假借。不得自在故。观欲如梦。念念灭故。观欲如痈。于苦倒中生乐想故。观欲如钩。行诸恶法堕恶道故。观欲如灰河。增益欲染不知足故。是故菩萨如是观已。离欲恶不善法。有觉有观。离生喜乐。成初禅行。离觉观。内净信心在一处。无觉无观。定生喜乐。成二禅行。离喜行舍念。正智一心身行乐。诸圣人能行能舍。成三禅行。舍苦乐意。先灭忧喜。行舍念净。成四禅行。于一切众生思惟乐想。成就无量无边慈心。于众生中思惟苦想。成就无量无边悲心。于众生中思惟喜想。成就无量无边喜心。于众生中舍苦乐想。成就无量无边舍心。是菩萨不思惟色想。成就空处寂静行。不思惟空想。成就识处寂静行。不思惟识想。成就无所有处寂静行。不思惟无所有处想。成就非有想非无想处寂静行。是菩萨于入息出息。若随若住。长时知长。短时知短。成就入息出息寂静行。是菩萨思惟观身不净想。成就不净寂静行。是菩萨思惟无常想生老病过。成就无常想寂静行。思惟食中起无量过患想。成就食不净想寂净行。于诸世界城邑聚落种种严饰中。思惟分别必归坏败想。成就世间不可乐寂静行。是菩萨内有色想。外观色少。若好若丑取其相貌。成就初胜处行。是菩萨内有色想。外观色多。若好若丑取其相貌。成就二胜处行。是菩萨若死若烧风吹日曝。成为灰土。为水所漂。若碎灭磨灭。若断三有。是名内无色想观外色少。若好若丑取其相貌。成就第三胜处行。是菩萨内无色想外观色多。若好若丑取其相貌。成就第四胜处行。是菩萨内无色相。外观色青无量无边。爱乐取相。成就第五胜处行。是菩萨内无色想。外观色赤无量无边。爱乐取相。成就第六胜处行。是菩萨内无色相。外观色黄无量无边。爱乐取相。成就第七胜处行。是菩萨内无色相。外观色白无量无边。爱乐取相。成就第八胜处行。是菩萨入是无量无边地一切处。不念异相。成就初一切处行。是菩萨入无量无边水火风青黄赤白虚空识一切处。不念异相。成就十一切入处行。是菩萨入苦法时。心缘一切善根。所谓大慈大悲。摄持正法。不断三宝。庄严佛身。清净梵音。本昔誓愿教化众生。净佛世界。坐菩提树。转妙法轮。除断一切众生结使。其心所缘境界如是。是菩萨入禅定时。离四识住处。不依地大水大火大风大空大识大。亦不依止今世后世。入如是定都无所依。是菩萨入禅其心爱乐。为欲入于无上解脱定故。是菩萨修行禅定。愿令一切众生得度得解脱故。为得一切智具足一切佛法故。若思惟若思惟已。愿令一切众生得度得解脱故。为得一切智具足一切佛法故。于此禅定若无力能学。是菩萨应如是思惟。我今应时时渐渐。勤加精进远离乱心。时时渐渐。勤加精进学一心。令此一心增广具足。乃至生有。终不懈怠不生愁忧。是菩萨发起菩提心。念菩提心。修菩提心。悕望菩提。愿求菩提。是名菩萨摩诃萨无量无边善根禅定。欲令一切世间在在处处所有众生。发起无漏禅定。发起无学禅定。生无漏禅定。生无学禅定。菩萨摩诃萨行是禅定。不以为难。以为喜乐。速疾具足禅波罗蜜

善臂。云何菩萨摩诃萨。具足般若波罗蜜。善臂。若有聪明智慧之人。学已能持。闻已诵习。善学诸法甚深相义。亦能分别。如所闻法。闻已思义。有如是等者。菩萨尔时。则应亲近。恭敬供养尊重赞叹。乃至刀杖不应远离。是菩萨因学问故。因了义故。因思义故。供养恭敬师和上故。乃至近死。终不避难诸苦恼事。所谓饥渴寒热。蚊虻毒螫。风吹日曝。诸恶触等。骂詈诽谤。是菩萨于正法中起宝聚想。于说法者起宝藏想。于听法者起难遭想。于问义者起慧命想。于多学者断除无明起智慧想。于分别诸法起百千生。生慧眼想。是菩萨闻是诸法。受持修学。广分别已。知阴界入。四圣谛。十二因缘。三世三乘。得如是知。云何知界。知二界。有为界无为界。是名二界。云何有为界。若法生住灭者。是名有为界。云何无为界。若法无生住灭。是名无为界。是名知有为无为界。复次知三界。善界不善界无记界。云何善界。若不贪共不贪。若不恚共不恚。若不痴共不痴。是名善界。云何不善界。若贪共贪。若嗔共嗔。若痴共痴。是名不善界。云何无记界。除善不善。若有余法。是名无记界。复次知三界。所谓欲界色界无色界。云何欲界。地狱畜生饿鬼阿修罗。人四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。若于此中欲染贪着。嗔恚愚痴悕望。欲得心所作业。是名知欲界。云何色界。梵天。梵辅天。梵众天。大梵天。光天。少光天。无量光天。光音天。净天。少净天。无量净天。遍净天。果实天。少果天。广果天。无量果天。无想天。无热天。无恼天。善见天。好善见天。阿迦腻吒天。若于此中。色染愚痴悕望。欲得心所作业。是名色界。云何无色界。空处天。识处天。无所有处天。非有想非无想处天。若于此中。无色染污愚痴悕望。欲得心所作业是名无色界。是名三界。复次知四界。欲界。色界。无色界。无为界。是名知四界。复次知六界。所谓欲界。恚界。害界。出界。不恚界。不害界。是名知六界。复次知六界。所谓地水火风空识界。是名六界。观地大。无常变坏无坚无牢相。若无常即是苦。若是苦即无我。水火风空识大。无常变坏无坚牢相。若无常即苦。若苦即无我。是名知六界。是菩萨闻如是法已。受持修学广分别已。即知五阴。所谓色阴。受想行识阴。色如水沫。即是生灭不得久住。受如水泡。即是生灭不得久住。想如野马。即是生灭不得久住。行如芭蕉。即是生灭不得久住。识如幻化。即是生灭不得久住。是名知五阴。是菩萨闻是法已。受持修学广分别已。即知内入。所谓眼入。耳鼻舌身意入。是名内六入。眼入即是苦法老法死法。空无我无我所。炽然三毒。生老病死忧悲苦恼。亦能炽然诸苦恼法。耳鼻舌身意亦如是。炽然三毒乃至诸苦。是名知内六入。复次知外六入。眼所见色。是名外六入。耳所闻声。鼻所嗅香。舌所尝味。身所觉触。意所知法。是名外六入。眼所见色是外入。不坚牢性。无所依止。亦无势力。一切无常。如实非不如实如幻如化。耳所闻声。鼻所嗅香。舌所尝味。身所觉触。意所知法。亦如是。是名知外六入。是菩萨闻如是法已。受持修学广分别已。即知四圣谛。所谓苦圣谛。集圣谛。灭圣谛。道圣谛。是名四圣谛。云何苦圣谛。若五阴六界。内六入外六入。是名苦。此苦无常喻如怨贼。如痈如箭。如狱闭系。如器坏败。是不自在即是无我。得如是知已。是名知苦圣谛。云何集圣谛。所谓贪恚痴慢我慢专取于我。决定计我常住不坏。我即是色。我异于色。我即是想。我异于想。我是想非想。我异想非想。我即是阴。我异于阴。我中有阴。阴中有我。我即是界入。我异界入。我中有界入。界入中有我。我即是受。我异于受。我即是知。我异于知。我是无受。我异无受。我是色少。我异色少。我是色多。我异色多。我是常。我是无常。我是常无常。我是非常非无常。我是有边。我是无边。我是有边无边。我是非有边非无边。死后如去。死后不如去。死后亦如去亦不如去。死后非如去非不如去。命即是身。身即是命。此众生从何处来。去至何处。此诸众生。即是断灭非有相续。自作自受。他作他受。计有我者即有我所。有我所者即是有我。如是摄取我见身见。若结若使。若我我所。我受贪恚痴本。若总身口意业。若福业若罪业。若欲界业。若色无色界业。是名集圣谛。云何灭圣谛。若贪恚痴尽。我我所尽。受取有尽。是名灭圣谛。云何道圣谛。若见苦集尽。思惟一切有为过患。见涅槃寂静。所作已办。住如是法时。正见。正思惟。正语。正业。正命。正精进。正念。正定。是名道圣谛。如是知四圣谛。是菩萨分别思惟四圣谛时。见有为法。是苦是无常是空是无我。见无为法。能为覆护。是舍是依。虽作是观不证涅槃。如是知四圣谛。是菩萨闻如是法已。受持修学广分别已。即知十二因缘。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。是名十二因缘。若不知不见四圣谛十二因缘。是名无明。若有身口意业。若福业。若罪业。若欲界系。色无色界系。是名行。若有心意识。是名识。若有受想思触思惟。是名名。若有四大。四大所造色。从歌罗罗乃至化生。若作色非作色。是名色。名色合故名名色。若眼耳鼻舌身意。是名六入。若眼缘色生眼识。三法和合故生触。是名触。若有苦受乐受不苦不乐受。是名受。若有爱染。是名爱。若有爱见戒取。是名取。若有色受想行识。是名有。若此有发起。是名生。若此有衰变。是名老。若此有灭坏。是名死。菩萨如是。分别思惟十二因缘。见闻觉知。地非是我。不生爱着。我非地不生爱着。亦非悕望。水火风空识亦如是。见闻觉知。涅槃非我。不生爱着。我非涅槃不生爱着。亦非悕望。是菩萨见诸法从因缘起。知三解脱门。广修学见诸法空无相无作。是菩萨见诸法从因缘起。知寂灭乐。精勤修学广分别已。则无明灭。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死灭。如是菩萨。虽观十二因缘起灭。而不证于灭。菩萨如是知十二因缘。是菩萨闻是法已。一心受持修学。广分别已即知三世。所谓过去未来现在。云何过去世。若法生已灭。是名过去世。云何未来世。若法未生未起。是名未来世。云何现在世。若法生已未灭。是名现在世。是菩萨念过去世诸不善根。轻毁可恶背舍离之。未来不善根当受不善果报。不喜不爱不可适意。现在不善根。当令不起。是菩萨能摄护身口意业。及六情根。常起善业无有中间。于过去善根。是菩萨菩提心。专念菩提。悕望菩提。欲得菩提。以深重爱。乐愿一切众生得度得解脱。为得一切智。具足一切佛法故。未来世现在世亦如是。常不离是心。终不懈怠失念放逸。若过去世阴界入等。即是灭尽。不实不在。无我无我所。若未来世阴界入等。是未生未起。无我无我所。若现在阴界入。是念念不住。何以故。世法无有一念住者。若有一念。是一念中亦有生住灭。是生住灭亦复不住。如生住灭中有内外阴界入。是内外阴界入亦有生住灭。若如是不住者。即是非我非我所。若过去世灭尽。不实不在。非我非我所。若未来世未生未起。非我非我所。若现在念念不住。是非我非我所。若见三世。非我非我所。是名实智慧者。不见我我所。是我我所。是即于诸有行。无我无我所行。离欲想行。断想行灭想。虽作是行不证涅槃。是名知三世。是菩萨闻是法已受持修学。广分别已即知三乘。所谓天乘梵乘圣乘。云何天乘。初禅二禅三禅四禅。是名天乘。云何梵乘。慈悲喜舍是名梵乘。云何圣乘。正见。正思惟。正语。正业。正命。正精进。正念。正定。是名圣乘。是菩萨时时修集天乘梵乘圣乘。教化众生令住三乘。是时自身不证解脱。是名知三乘。复次知三乘。所谓声闻乘。缘觉乘。大乘。云何声闻乘软根解脱。于一念中离三有窟宅。乐欲出世欲得涅槃。见寂灭处。勤加精进如救头然。若其未解四圣谛者。欲以智箭射四谛的。欲证欲解以深欲精进。是名声闻乘。云何辟支佛乘中根解脱。欲得寂静独在一处。而自利益入寂静定。方便分别十二因缘。欲得缘觉道。欲证缘觉。是名缘觉乘。云何大乘上根解脱。欲令一切众生得度得解脱。为得一切智。具足一切佛法六波罗蜜。欲利益一切世界。欲断一切众生苦恼。于一切世界五欲乐中。心尚轻贱。何况世间无量诸苦。欲令众生持无上戒。欲得闻见大乘经典。受持修学思惟分别。读诵令利。勤加精进。若有菩萨。修四摄法应往亲近。欲令众生摄真智慧。安住四摄。常欲得闻诸深法要。受持分别。欲令一切入于禅定。自舍己乐利益众生。欲以自力随他所乐。令住三乘。虽作是化。常自安住无上道中。不坏不动心如金刚。常愿欲得无上菩提。愿求菩提是名大乘。是名知三乘。是菩萨闻是法已。受持修学广分别已。即知方便。于佛法僧五体投地。以此为业。于其所作愿无上道。如是归依发菩提心。若行若住若坐若卧。若饮食洗浴。于此事中更无余心。但愿无上菩提。常作如是广博修学。是菩萨若始入定。若入定已。常愿一切众生得度得解脱故。为得一切智。具足一切佛法故。欲于世界中尊。欲调伏一切众生。欲于一切众生中无能胜者。欲得最胜。欲教诫一切众生。欲令一切众生得寂灭。欲于一切法得成正觉。具学。是菩萨若一切所作善根。愿一切众生。无有恐怖。出三恶道灭无量苦。断诸烦恼。令现在未来欲得缘觉乘者。愿令具足。现在未来欲得大乘者。愿令具足。愿请一切世间所有现在未来诸佛世尊。住世一劫说法。令圣人众随佛在世而得和合。是菩萨如是思惟。若在在处处。所有众生所修善根。若欲生人中天上。若住声闻乘。若住辟支佛乘。若爱语布施利益同事。愿令具足。是菩萨以是法故于三时中。读诵通利思惟此法。所谓我今归依一切世间在在处处。所有诸佛佛法僧菩萨。头面礼敬。诸佛威德无能胜者。其相甚妙。菩萨常应作如是念。诸佛法僧。愿令世间在在处处无有空处。所在方面常有诸佛。令我劝请。留住一劫。说微妙法。呵责诸恶。若已作若今作我今已得离一切恶。乃至一念中间。当愿以一切善根。令诸众生寿命无量。住于一切诸善法中。如诸菩萨。速转法轮。令诸圣人得戒定慧解脱解脱知见。愿令佛法常住于世。利益众生。生五道者悉得善根乃至敬礼诸佛。常住是愿。是诸菩萨所有善愿。令他众生及其己身。得妙威德善妙威德。若未来现在。一切世间佛法僧宝。令住一劫无诸留难。及诸菩萨宝。速令具足六波罗蜜。疾成阿耨多罗三藐三菩提。亦无留难。欲令一切众生断除苦恼怖畏。行于喜乐。断一切不善根。成就一切善根。随如所愿成就三乘。速疾成就诸波罗蜜。寿命无量而得解脱。成无上道。乃至敬礼诸佛。常作是愿。是菩萨欲令一切众生断诸苦恼。若一切世间在在处处。所有诸佛乃至法身。愿我以身奉施彼佛。欲令一切众生得度成无上道。在所生处信敬三宝。以天香花。奉养恒河沙等诸佛世尊。亦供养法僧及诸菩萨。令所奉宝如须弥山。一切世间在在处处所有众生。若有所须。七宝房舍。衣服饮食。医药卧具。悉当给与令无所乏。若有乐于忍辱精进持戒者。我当随其所乐而为解说使成就胜法。令三宝具足修六波罗蜜疾成佛道。离诸恶法善行实义。身口意业。不退菩提乐于菩提。在在处处。见佛菩萨常学善根。安止众生于善法中。是菩萨自知及他所有善根。趣向智慧。思惟智慧。愿欲令一切众生得度得解脱故。为得一切智。具足一切佛法故。是菩萨趣向思惟已。愿令一切众生得度得解脱故。为得一切智。具足一切佛法故。是菩萨如是智慧。若无力能学。应如是思惟。我今当勤加精进。时时渐渐断于无明。我今复当倍加精进。时时渐渐学此智慧。令此智慧增广具足。乃至生有。终不懈怠生于忧愁。如是菩萨。发菩提心。念菩提心。修菩提心。悕望菩提心。是菩萨无量无边善智慧。何以故。此慧于余善慧中。最胜第一。令一切世间众生。发起无量智慧。发起无学智慧。生无漏智慧。生无学智慧。善臂。如是菩萨。行此智慧不以为难。以为喜乐。速疾具足般若波罗蜜。佛说是经已。善臂菩萨。欢喜赞言。善哉善哉。信受奉行

大宝积经卷第九十四大宝积经卷第九十五

        大唐三藏法师菩提流志奉　诏译

    善顺菩萨会第二十七

如是我闻。一时佛在舍卫国祇树给孤独园。与诸大众五百声闻十千菩萨。恭敬围绕。时舍卫城有一菩萨。名曰善顺。已于过去无量佛所。种诸善根。承事供养。于阿耨多罗三藐三菩提。得不退转。住于大慈心不嗔恚。住于大悲弘济无倦。住于大喜善安法界。住于大舍苦乐平等。节量时食少欲知足。常为众生之所乐见。恒以五戒及八斋法。于某城中怜愍教化。然后复劝。布施持戒。忍辱精进。禅定智慧。慈悲喜舍。清净梵行。尔时善顺菩萨。为令众生见佛闻法。与诸人众前后围绕。将诣佛所。时天帝释。以净天眼见此菩萨。住上精进行头陀行。具净尸罗弘济坚固。便自念言。今此善顺。于诸梵行曾不懈息。将不为求帝释处耶。或贪王位及欲乐耶。作是念已。即便化作四丈夫身。至菩萨前。种种恶言毁骂菩萨。复以刀杖及于瓦石。打掷加害。尔时菩萨。住慈忍力。皆忍受之曾无嗔恨。时天帝释。复更化作四大丈夫。来语菩萨。咄哉善顺。彼诸恶人以不善言骂辱于汝。及以瓦石刀杖之属横相打害。何不令我为汝仇报。我当为汝断彼命根

尔时菩萨告彼人言。善男子等莫作是语。若杀害者成就恶业。假使有人于我此身节节支解。犹如枣叶我终不生杀害之心。何以故。杀害之人堕于地狱饿鬼畜生。乃至虽得人身。所生父母犹不爱念。恒为众人之所憎恶。善男子。一切诸法凡有二种。一者善法。二者不善法。由不善法堕于恶趣。若依善法获于福利。尔时善顺菩萨。欲重宣此义。而说偈言

  善恶犹种植　　皆随业所生
  何有苦子因　　成熟甘果者
  现见法如是　　智者应思惟
  苦报酬恶缘　　为善常安乐

尔时天帝所化之人。闻是言已。自念不能令彼菩萨为杀害业。忽然不现。尔时天帝复更化作金银宝聚。令诸丈夫至菩萨所。作如是言。汝可方便取此珍宝随意所用

尔时菩萨告彼人言。诸善男子莫作是说。所以者何。夫盗业者能令众生贫穷下劣无依无怙。假使我贫命不存济。终不行于不与取法。诸君当知。凡夫愚冥贪求覆蔽。何有智人行不与取。尔时善顺菩萨。而说偈言

  积财虽千亿　　贪着心不舍
  智者说此人　　在世恒贫苦
  彼虽无一物　　安住舍离心
  智者说斯人　　世间最富贵
  智者离诸恶　　一切皆端严
  愚夫由作罪　　举身皆丑陋
  智者劝修善　　愚夫恒为恶
  宁受智毁骂　　不用愚称赞

时彼天帝所化之人。闻是言已怅然而去

尔时天帝。复自亲试持俱胝金。至菩萨所作如是言。我先于此舍卫大城。波斯匿王。与余丈夫有所诤论。须得一人为我曲证。汝能为我作证人者。当用此金而以相奉。尔时菩萨告帝释言。仁者当知。夫妄语者为不善业。既诳自身。亦诳天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。由于妄语。能为一切恶之根本。趣不善道。毁清净戒。能坏色身。口气常臭。所出言词为人恶贱。尔时菩萨。重说偈言

  妄语之人　　口气常臭　　入苦恶道
  无能救者　　夫妄语者　　诳于自身
  亦诳天龙　　摩睺罗等　　当知妄语
  为诸恶本　　毁清净戒　　死入三涂
  汝设与我　　满阎浮金　　我终不能
  作于妄语

时天帝释闻说是已。忽然不现

尔时天帝。复令舍支夫人日光夫人及于五髻诸夫人等往菩萨所重加试炼坏其禁戒。时舍支等即与五百盛年女人。以香涂身花妆藻饰。于后夜分至菩萨前而作是言。我等女人年色姝盛愿亲枕席相与为欢。尔时菩萨。以无染眼观彼诸女。告之言曰。地狱畜生阎罗王界。诸狂乱者。不正心者。耽昏臭秽脓血不净。爱恶罗刹是汝亲友。非诸天人清净眷属。尔时菩萨。重说偈言

  愚人昏迷念不净　　耽染臭秽脓血身
  诸欲迅灭归无常　　永沈地狱阎罗界
  假令变化如汝等　　色身殊胜满世间
  我无一念贪染心　　常生如梦如怨想

时舍支等虽尽变态。而彼菩萨曾无贪染。各还天宫白帝释言。我观善顺志愿坚固。当成正觉无有疑也。所以者何。彼于我等无少贪爱。俱生厌离。尔时帝释虽闻此言。犹怀忧恼如箭中身。恒作是念。彼人必当毁夺于我。无有疑惑。我今应往重加试之。于诸愿中的何所愿。作是思已至菩萨前。舍去憍慢头顶礼足。以偈问曰

  仁今勤修净梵行　　于诸欲愿何所求
  为求日月释梵天　　为求三有诸王位

尔时善顺菩萨。以偈答曰

  我观日月释梵天　　世间王位三有报
  一切无常不坚固　　何有智者为兹愿

尔时天帝闻此颂已。复白菩萨。若如所言为求何愿。于是菩萨。以偈答曰

  我本不贪世间乐　　但求不生不灭身
  勤修方便济群生　　愿同登彼菩提路

尔时天帝闻是颂已。心生安乐。必知菩萨不求释位。欢喜踊跃。以偈叹曰

  汝言弘济为群生　　此心广大无与等
  愿破魔军证甘露　　由斯恒转胜法轮

尔时天帝说是偈已。恭敬旋绕礼菩萨足。忽然不现。尔时善顺菩萨。于其晨朝。入舍卫城游化往来。得劫初时阎浮金铃。其铃价直过阎浮提

尔时菩萨持此金铃。于四衢中高声唱言。此舍卫城谁最贫穷。当以此铃而施与之。时有最胜耆旧长者。闻是语已奔走而来。白菩萨言。我于此城最为贫穷。可持此铃而施于我。尔时菩萨语长者言。汝非贫者。所以者何。于此城中。有善男子贫中最贫。应以此铃而施与之。长者问言。谁为此人。菩萨答言。波斯匿王于此城中最为贫者。时彼长者。谓菩萨言。莫作是说。何以故。波斯匿王。富贵多财库藏盈溢。珍奇贿货用无穷尽。云何乃言贫中最贫。尔时菩萨。于大众中。以偈答言

  设有伏藏千亿余　　以贪爱心无厌足
  犹如大海吞众流　　如斯愚人最为贫
  由此复令贪增长　　展转滋蔓相续生
  于现在世及未来　　彼无智者常贫匮

尔时善顺菩萨说此偈已。与诸大众。即便往诣波斯匿王。于时彼王。方与长者五百余人。算数校计库藏财宝。菩萨尔时前白王言。我于此城往来游化。得劫初时阎浮金铃。其铃价直过阎浮提。我于彼时窃作是念。于此城中有最贫者。当持此铃而施与之。复更思惟。城中最贫莫过王者。今赍此铃愿以相奉。王既贫穷为我受之。尔时菩萨。作是言已。重说偈言

  若人多贪求　　积财无厌足
  如是狂乱人　　名为最贫者
  王恒多赋税　　横罚无过人
  爱着于国城　　不观来世业
  于世得自在　　不能荫群生
  见诸贫苦人　　曾无怜愍念
  耽染于女人　　不惧于恶道
  邪乱未常觉　　岂非贫穷者
  若人知净信　　归依佛法僧
  于身及命财　　常念不坚固
  知不坚固已　　于彼不迷惑
  能于身命财　　永得常坚固
  若能勤念住　　乐于不放逸
  彼人名富贵　　善财常安乐
  如火焚烧时　　不厌于林树
  王今亦如是　　贪爱无厌足
  水不厌于云　　海不厌于水
  王今亦如是　　何有厌足时
  日月常巡历　　不厌于四方
  王今亦如是　　终命无休息
  如火焚烧时　　不厌于草木
  智人亦如是　　未尝不行善
  如水不厌云　　如海不厌水
  智人亦如是　　不厌善增长
  王位虽自在　　毕竟归无常
  一切皆不净　　智者应舍离

尔时波斯匿王闻斯语已。内怀惭愧。谓菩萨曰。善哉仁者。汝虽善劝我犹未信。今汝斯言。为汝自说为有证乎。菩萨答言。汝不闻耶。如来应正等觉。具一切智今者现与无量大人乾闼婆阿修罗等。在于舍卫大城祇树给孤独园。当证大王是贫穷人。王言。仁者。若如汝说。我愿相与往见如来。听闻教诲归依供养。菩萨答言。大王当知。如来境界非诸凡愚之所能测。破烦恼慢哀愍众生。已于圣智能知此世及于来世。若有善根胜意乐者。虽在极远佛常加护。若知我心。欲令大王于我生信。必当来此为我作证。尔时菩萨。即于王前偏袒一肩。右膝着地合掌恭敬。即以偈颂。请如来曰

  如来真实智　　悲愍诸群生
  愿知我深心　　垂哀为作证

尔时菩萨说偈请已。于彼大地忽然震裂。五百声闻十千菩萨。梵释诸天及于龙鬼。无量众生围绕如来。从地踊出。善顺菩萨。合掌恭敬。前白佛言。世尊。我先于此舍卫城中。游化往来。得劫初时阎浮金铃。其铃价直过阎浮提。我于尔时便作是念。若有众生于舍卫城最贫穷者。当以此铃而施与之。复自思惟。波斯匿王于此城中最为贫者。何以故。恃于王位。于诸众生未尝怜愍。残剥欺夺横加侵损。贪爱覆蔽不知厌足。我以此王为最贫者。欲将金铃而施与之。王问我言。谓我贫穷谁为证者。我又答云。如来大师应正等觉。舍离烦恼嗔垢无余。于诸众生悉皆平等。当为作证。唯愿世尊。示教利喜

尔时世尊。为欲调伏波斯匿王。而告之曰。大王当知。或有于法。善顺贫穷王为富贵。或有于法。王为贫穷善顺富贵。所以者何。身登王位于世自在。金银摩尼车磲珊瑚。库藏盈满。当于此时善顺贫穷。王为富贵。勤修梵行。乐净尸罗。舍家多闻。离诸放逸。八斋五戒。弘济无疲。有一于此。王实贫穷善顺富贵。王今应知憍萨罗国。一切众生财物库藏。比于善顺五戒八斋坚固清净。百分千分不及其一。至俱胝分亦不及一。尔时波斯匿王。亲闻如来真实教诲。舍所憍慢。合掌殷勤瞻仰善顺。而说偈言

  善哉摧伏我憍慢　　当得如来最胜身
  以此王位舍于汝　　愿恒为汝菩提众
  我实贫穷汝为富　　今知此说非妄言
  王位徒为众苦因　　背于白法生恶趣

尔时波斯匿王说是偈已。白佛言。世尊。我于今者。发于无上大菩提心。愿于众生安乐解脱生死系缚。我今愿以财物库藏金银之属。分为三分。一分奉施如来世尊及比丘众。一分施与舍卫城中贫穷苦恼无依怙者。一分财物留资国用。凡我所有园池花果。悉愿奉施最胜如来并比丘众。唯愿世尊。垂哀纳受

尔时憍萨罗国五百长者。睹斯事已。皆发无上大菩提心

尔时善顺菩萨白佛言。世尊。唯愿如来。为诸大众说于法要。令诸众生遇如来者。为不空过

尔时世尊。告众人言。善男子等。有三无量功德资粮。于诸如来。虽有称说犹不能尽。况于声闻诸三乘等。何者为三。一者护持正法。二者发菩提心。三者劝诸众生起无上愿。复有三十二法。若善男子若善女人。能勤修者。则为见于如来不空过也。一者于诸如来生不坏信。二者护持正法令得久住。三者于尊重僧而不轻慢。四者于应供人恭敬亲近。五者于爱于憎心常平等。六者恒于正法乐闻恭敬。七者安住寂静离于諠闹。八者于如来乘演说无倦。九者若说法时不为名利。十者志求真实如理勤修。十一舍施。十二持戒。十三忍辱。十四精进。十五禅定。十六正慧。十七于诸众生随乐护念。十八成熟众生不忘失法。十九恒于己身善自调伏。二十以善法要调伏于他。二十一不染烦恼。二十二常乐出家。二十三住阿兰若。二十四圣种喜足。二十五勤行头陀。二十六舍不善法。二十七弘誓坚固。二十八兰若无懈。二十九植众善本。三十常不放逸。三十一远二乘见。三十二赞叹大乘。于是五百比丘。闻斯法已。远尘离垢得法眼净。及万二千众生。同发阿耨多罗三藐三菩提心

尔时世尊。以法教化。令诸众生获善利已。与诸比丘并余来众。忽然不现。尔时波斯匿王。既睹斯事踊跃欢喜。便以二衣价直百千两金。而以施于善顺菩萨。作是言曰。善哉仁者。愿垂哀纳。善顺菩萨。告于王言。大王当知。我于此衣不应受之。所以者何。然我自有百衲之衣。恒挂树枝以为箱箧。一切众生无欺夺想。我既自身无悭吝心。亦令他人不生爱着。其有施者名清净施。时波斯匿王。复作是言。汝若不受愿当为我以足踏之。令我长夜安乐利益。菩萨尔时为于王故。即以双足踏此二衣。时波斯匿王。谓菩萨言。今此之衣。便于汝身为我受讫。我何所用。善顺菩萨。告于王言。汝持此衣。施于城中贫穷苦恼无依怙者。尔时波斯匿王。如菩萨教持此二衣。会诸贫人而施与之。时诸贫人触斯衣者。狂者得心。聋者得闻。盲者得见。根不具者悉得具足。由于菩萨威神力故。彼时众人俱发声言。我今以何报菩萨恩。尔时空中有声告曰。诸人当知。善顺菩萨不可以于花香饮食为报恩者。唯当速发菩提心耳。是时五百贫人。闻于空中有如是声。咸说偈言

  我等今者　　发菩提心　　当成正觉
  说诸胜法　　于诸众生　　施以安乐
  我乐菩提　　得佛法故

尔时波斯匿王白菩萨言。善哉仁者。汝若诣彼将见如来。愿时报我。我当随从。善顺菩萨言。大王当知。诸佛难值正法难闻。岂独大王而自往耶。当为众生作于善友。王应于此舍卫城中敕诸人民悉令随从。违王教者王法治之。所以者何。凡诸菩萨。犹有眷属围绕庄严。况于王乎

时波斯匿王。白菩萨言。谁者是于菩萨眷属。菩萨答言。劝菩提心。是菩萨眷属。令觉悟故。劝见如来是菩萨眷属。不虚妄故。劝闻正法是菩萨眷属。获多闻故。劝见圣众是菩萨眷属。得善友故。四摄是菩萨眷属。摄众生故。六波罗蜜是菩萨眷属。增长菩提故。三十七品是菩萨眷属。趣向道场故。菩萨有斯眷属。庄严侍卫。能摧魔军。至师子吼。登最胜处

尔时波斯匿王及诸大众。欢喜踊跃。九千众生离烦恼垢。得清净眼。佛说是经已。善顺菩萨。波斯匿王。及诸天人乾闼婆阿修罗等。闻佛所说。欢喜奉行

大宝积经卷第九十五大宝积经卷第九十六

        大唐三藏法师菩提流志奉　诏译

    勤授长者会第二十八

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人俱。皆是阿罗汉。诸漏已尽。无复烦恼得上调伏。犹如大龙。所作已办。弃诸重担。逮得己利。尽诸有结。正智解脱心得自在。最上应供。众所知识。唯有阿难。犹在学地。其名曰阿若憍陈如。摩诃迦叶。摩诃迦旃延。摩诃阿湿波。舍利弗。大目干连。摩诃劫宾那。摩诃拘絺罗。摩诃梵颇。罗睺罗。难陀。如是等而为上首。复有菩萨摩诃萨五百人俱。皆得三昧及陀罗尼。尔时舍卫大城。有一长者。名勇猛授。富有财宝仓库盈溢。金银琉璃车磲马瑙珊瑚虎珀摩尼真珠。象马牛羊。奴婢仆使商估等类一切众多。时勇猛授。与五百长者。游宴聚会作是议言。诸仁者。佛出世难。人身难得。时亦难遇。于佛法中以信出家。是事亦难。成比丘性亦复甚难。如法修行是亦为难。知恩报恩少恩不忘是人难得。能于佛法生信乐心是人难得。信乐成就是事复难。庄严佛法是事亦难。解脱生死倍复为难。我等为于声闻辟支佛乘而求灭度。为当发趣最上佛乘。咸复唱言。我等宁于无上佛道而趣涅槃。作是议已。前后围绕。出舍卫城向只陀林。诣如来所顶礼佛足。右绕三匝却坐一面。尔时世尊。知而故问。告长者言。汝等何缘今来我所。时勇猛授。与五百长者从座而起。偏袒右肩右膝着地。合掌向佛白言。世尊。我等诸人。同时集会作是议言。佛世难遇。人身难得。乃至解脱生死倍复为难。我等为于声闻辟支佛乘而求灭度。为当发趣最上佛乘。咸作是言。我等宁于无上佛道而趣涅槃。由此议故。今诣如来应正等觉。世尊。菩萨摩诃萨。志求阿耨多罗三藐三菩提者。应云何学。应云何住。云何修行。佛言。善哉善哉。汝等发趣阿耨多罗三藐三菩提。来诣我所。应当谛听善思念之。如诸菩萨。应学应住应所修行。当为汝说。时诸长者受教而听

佛告长者。菩萨摩诃萨。于阿耨多罗三藐三菩提。胜志乐者。当于一切众生起大悲心。应广修行。应勤熏习。是故菩萨。于身命财及以妻子仓库舍宅饮食衣服车乘卧具花鬘涂香一切乐具应无所著。何以故。以诸众生执着于身。而生恶业。由恶业故。堕地狱中。若于众生起大悲心。于身命财则不执着。便生善趣。是故菩萨摩诃萨。于阿耨多罗三藐三菩提。胜志乐者。于诸众生起慈悲已。应修大舍而不求报。不求报者应住戒律。三戒清净应具忍辱。能忍诸恶应起精进。不惜身命。应修一心安住禅定。应修智慧善巧方便。应于我人众生寿命皆悉舍离。为众生故。应行布施护持净戒。为众生故。应修忍辱发起精进。为众生故。应入禅定修习智慧善巧方便。时诸长者。复白佛言。世尊。我等于身及彼妻子一切财宝资生之具。心常爱惜。世尊。菩萨摩诃萨。云何观察。于身命财能无贪吝。尔时世尊。告长者言。善男子。菩萨摩诃萨。于阿耨多罗三藐三菩提。胜志乐者。应观此身无量过患。微尘积集生住异灭。念念迁流九漏疮门。犹如毒蛇所住窟穴。其中无主如空聚落。毕竟破坏如坏瓦瓶。恶露盈溢犹如秽器。受诸不净犹如圊厕。不可触动犹如恶疮。贪美为患如杂毒食。不识恩德如未生怨。欺误于人如恶知识。痴爱为害如友猕猴。断智慧命犹如杀者。夺诸善法犹如劫贼。常求人便犹如怨仇。无有慈心犹如魁脍。难可承事如暴恶人。如箭着身触之则痛。如朽腐舍常务修治。如老弱乘难可驱策。如毒蛇箧不可附近。如逆旅馆疲苦所集。如孤独舍无所摄属。如狱卒伺害。如王者忧国。如边城警畏。如恶国多灾。如破器难持。如祠火无厌。如阳焰虚诳。如幻化惑人。如析芭蕉中无坚实。如水聚沫不可执持。如水上泡速起速灭。如河岸树临危动摇。如驶河流终归死海。复告长者。次观此身前后因缘。初从欲爱和合而生。为长养故咽于搏食。至于生藏痰阴消之。次至黄藏将欲熟时。则变为酢。次至风藏风分汁滓。各别流行成大小便。汁变为血。血变为肉。肉处生脂。脂处为骨。骨中生髓。如是身缘前后不净。若诸菩萨作是观时。复应思惟。如此身者三百六十骨聚所成。如朽坏舍。诸节支持。以四细脉周匝弥布。五百分肉犹若泥涂。六脉相系。五百筋缠。七百细脉。以为编络。十六粗脉钩带相连。有二肉绳。长三寻半。于内缠结。十六肠胃绕生熟藏。二十五气脉犹如窗隙。一百七关穴如破碎器。八万毛孔如乱草覆。五根七窍不净盈满。七重皮裹六味长养。犹如祠火吞受无厌。如是之身一切臭秽自性溃烂。谁当于此爱重憍慢。唯应观察。如借他器。犹车运载。但为养育。至菩提故。尔时世尊。而说偈言

  是身众秽器　　犹如贮粪瓶
  凡夫无智慧　　恃色生憍慢
  鼻中洟恒流　　口气常臭秽
  眼眵虫遍身　　谁当生净想
  如人执持炭　　磨莹欲令白
  假使至尽时　　体色终无变
  设欲净其身　　倾河以自洗
  身尽莫能净　　其事亦如是

于时世尊说此偈已。复告五百诸长者言。若诸菩萨发胜志乐。趣于阿耨多罗三藐三菩提者。应观此身四十四种。何等名为四十四种。一者此身可厌性无和合故。二者此身臭秽脓血常流故。三者是身不坚毕竟败坏故。四者是身羸弱支节相持故。五者是身不净秽恶流溢故。六者是身如幻诳惑凡愚故。七者是身疮门九处常流故。八者是身火然欲火盛故。九者是身为火嗔火猛故。十者是身遍然痴火遍故。十一者是身盲冥贪嗔痴故。十二者是身堕网爱网覆故。十三者是身疮聚疮遍满故。十四者是身不安四百四病故。十五者诸虫住处八万户虫故。十六者是身无常毕竟归死故。十七者是身顽痴于法无知故。十八者犹如瓦器生住坏故。十九者是身逼迫多忧恼故。二十者无有救护必坏灭故。二十一者是身险恶谄诳难知故。二十二者如无底坑诸欲难满故。二十三者如火受薪贪色无厌故。二十四者身无厌足贪受五欲故。二十五者如被捶打随损害故。二十六者是身不定盛衰增减故。二十七者身随心转不正思惟故。二十八者身不知恩必弃冢间故。二十九者身为他食狐狼所啖故。三十者身如机关筋骨相持故。三十一者身不可观脓血粪秽故。三十二者身不自由依饮食生故。三十三者身妄缠裹终败坏故。三十四者身为恶友多逆害故。三十五者身为杀者自残害故。三十六者身为苦器苦所逼故。三十七者身为苦聚五蕴生故。三十八者身为无主众缘生故。三十九者是身无命离男女相故。四十者是身为空应观蕴界处故。四十一者是身虚妄如梦中故。四十二者是身不实如幻化故。四十三者身为幻惑如阳焰故。四十四者身为欺诳如影像故。是为四十四种。菩萨作是观时。所有身命爱欲执着。妻子舍宅饮食衣服。车乘香鬘一切乐具。皆悉厌离无所顾恋。速能成就六波罗蜜疾得阿耨多罗三藐三菩提。尔时世尊。而说偈言

  善得人身甚为难　　莫为此身造众恶
  毕竟冢间餧狐狼　　勿为恶见生贪爱
  凡愚迷惑痴狂故　　由爱此身造诸业
  此身亦复不知恩　　昼夜唯增众苦缘
  机关动转常疲困　　洟唾便利恒充满
  饥渴寒热相煎迫　　何有智者爱此身
  此身无厌如大坑　　徒能长养众怨害
  由此身故常作恶　　于无量劫受诸苦
  应念定死修胜福　　正信生于佛法中
  饮食衣服及涂香　　长养此身来已久
  谁能执持令不坏　　应知无益勿耽迷
  牟尼世尊难可遇　　无量劫中时出现
  当于佛法生净信　　恶道可畏勿随行
  设令寿命千亿岁　　犹惧无常生厌离
  何况须臾不可保　　为彼沉沦恶趣中
  或有恶友来相劝　　人身难得今已得
  多求财宝受娱乐　　及此盛年恣嬉游
  何有求财而乐者　　设得守护犹勤苦
  如此愚人徒妄言　　是故智者应观察
  财物如幻亦如梦　　愚痴众生被诳惑
  刹那时得刹那失　　何有智者生爱心
  譬如幻师幻化事　　乾闼婆城种种色
  财宝如是诳凡愚　　于虚妄中何有实
  种种苦恼求财利　　水火王贼常侵夺
  由此能为众苦因　　何有智者生爱乐
  有诸常怀贪爱者　　驰逐财利无厌时
  能于父母无慈心　　乃至亲属生怨害
  言语善顺心乖违　　造作种种欺诳缘
  或学邪论邪咒等　　夸炫伎艺如淫女
  或复谄诳现柔和　　或复刚强示威猛
  如是无量众恶业　　莫不皆由财利生
  珊瑚金玉摩尼珠　　是物本来如泡沫
  不能了知如幻化　　为此虚诳坠三涂
  弥勒世尊出现时　　一生次当补我处
  国界黄金而布地　　是等为从何所来
  劫尽世间悉烧坏　　须弥河海尽燋枯
  毕竟磨灭归虚空　　而此宝物何从去
  种种恶业求财物　　养育妻子谓欢娱
  临命终时苦逼身　　妻子无能相救者
  于彼三涂怖畏中　　不见妻子及亲识
  车马财宝属他人　　受苦谁能共分者
  父母兄弟及妻子　　朋友僮仆并珍财
  死去无一来相亲　　唯有黑业常随逐
  智人终不为亲爱　　作诸恶业入阿鼻
  唯除业尽方得出　　亲属无有能代者
  阎罗使者唯考业　　不问亲缘及友朋
  汝得人身不舍恶　　极苦今应甘忍受
  阎罗常告彼罪人　　无有少罪我能加
  汝自作罪今自来　　业报自招无代者
  父母妻子无能救　　唯当勤修出离因
  是故应舍枷锁业　　善知远离求安乐
  于家妻子应生怖　　恒依佛教正修行
  在家炽然为苦本　　犹如炎炉甚可畏
  身心燋热镇烧燃　　谁有智者生贪着
  爱乐修行诸佛教　　无所营求为快乐
  愚闇凡夫不觉知　　家为苦本横贪爱
  于彼皮筋骨肉中　　迷惑妄生夫妇想
  不能了知如幻化　　凡夫于此生贪着
  智者能知此过患　　世间欲乐皆捐弃
  乐法当如求药想　　应速舍离居家缚

尔时五百长者。闻此法已。得无生忍。欢喜踊跃。而说偈言

  庆哉获大利　　诸利中最上
  我等于佛法　　皆生欣乐心
  发趣于菩提　　利乐众生类
  以善而养命　　觉慧自安心
  怜愍诸众生　　愿当成佛道
  我等皆已发　　无上菩提心
  金色相庄严　　照明于世界
  乐菩提心者　　当得如来身
  大心菩提心　　诸心中最上
  解脱一切缚　　具足诸功德
  少福诸众生　　于此无欣乐
  不观生死过　　不乐菩提心
  菩提心功德　　若有色方分
  周遍虚空界　　无能容受者
  恒河沙数等　　诸佛刹土中
  假使布珍宝　　供养于诸佛
  有能一合掌　　回向菩提心
  其福过于彼　　边际不可得
  非唯供养福　　余福亦复然
  如是菩提心　　最胜仙所说
  菩提心最胜　　如阿伽陀药
  能除一切病　　与一切安乐
  我见诸众生　　三火所热恼
  智者无量劫　　勤苦常修习
  如医王勇猛　　具足菩提行
  救拔众生苦　　永离诸忧恼
  于一切生处　　终不舍是心
  勤修诸行愿　　勇猛求佛法
  我等得善利　　我等心欣乐
  今遇释师子　　当得如来身

尔时世尊即便微笑。从其面门放种种光。青黄赤白红紫颇黎。照于无量无边世界。乃至梵世日月威光皆悉隐蔽。还绕三匝从佛顶入。尔时尊者阿难即从座起。偏袒右肩右膝着地。合掌向佛白言。世尊。有何因缘现此微笑。如佛所现非无因缘。即于佛前。而说偈言

  诸佛最上之导师　　不以无因现微笑
  哀愍世间利益者　　愿说所为之因缘
  贫乏众生无法财　　应说最上大乘施
  能作世间盲冥眼　　愿说微笑之因缘

于时世尊告阿难曰。汝见此五百长者今于我所发阿耨多罗三藐三菩提心不。阿难白言。唯然已见。佛告阿难。此五百长者。已于往昔百千亿那由他诸佛所。承事供养种诸善根。今闻是法得无生忍。此诸长者。从是已后不生恶趣。于人天中常受快乐。复于来世弥勒佛所。供养恭敬尊重赞叹。及贤劫中一切诸佛。悉皆承事恭敬供养。于诸佛所听闻正法。受持读诵为他广说。过二十五劫。各于诸佛刹中成无上菩提。皆同一字号胜莲花藏如来应正等觉。尔时尊者阿难白佛言。世尊。希有世尊。希有善逝。当何名此广大法门。云何奉持。佛告阿难。是法门名菩萨瑜伽师地。亦名勇猛授长者所问。如是名号汝当受持。佛说此经已。尊者阿难。及诸比丘。五百长者。诸菩萨众。天人阿修罗等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第九十六大宝积经卷第九十七

        大唐三藏菩提流志奉　诏译

    优陀延王会第二十九

如是我闻。一时佛在拘睒弥国瞿师罗园。与大比丘众千二百五十人俱。尔时优陀延王。第一夫人。名曰舍摩。常于如来及诸圣众。深信恭敬亲近供养。及常称赞如来功德。时王复有第二夫人。名为帝女。常怀谄妒。往彼王所。妄说如来并诸弟子。于大夫人有所非法。王闻是语极生嗔怒。即以箭射舍摩夫人。尔时夫人哀愍王故入慈三昧。时所放箭遂即却还。至王顶上空中而住。其箭焰赫犹如火聚。甚可怖畏。乃至三发箭皆如是。尔时优陀延王。既睹斯事举身毛竖。惊忙悔恨谓夫人曰。汝为天女为龙女耶。为复夜叉乾闼婆女。毗舍遮女。罗刹女耶。夫人答言我非天女。乃至亦非罗刹之女。大王。当知我于佛所听闻正法。受持五戒作优婆夷。哀愍大王入慈三昧。王虽于我生不善心。由我慈愿得无伤损。因叹王言。善哉大王。当于如来应正遍知。归命顶礼必获安隐。优陀延王。便作是念。彼于佛所听闻正法作优婆夷。尚有如此威神之力。何况如来应正等觉。作是念已。即往佛所顶礼佛足。右绕三匝。白言世尊。我由欲染因缘。为彼女人虚妄言说之所诳惑。遂于如来及诸圣众。生毒害意。具陈上已。复白佛言。唯愿如来及诸圣众。施我欢喜。听我忏悔。如斯罪[億-音+(夫*夫)]令速消灭

尔时世尊告彼王言。如汝所说。谓于如来及诸圣众。如凡愚人有诸过患。遂于福田妄起嗔毒。汝今若能依圣法律。自悔其罪无覆藏心。尽未来世不复更犯。我当摄受令汝当来善法增长。优陀延王。复白佛言。世尊。我为女人之所迷倒。狂乱无知。因此发生粗猛嗔毒。由斯罪业当堕地狱。唯愿世尊。利益安乐诸众生故。慈悲开示女人谄曲虚诳过患。勿令我等亲近女人。当于长夜得免诸苦。佛言。且置斯事。何要问此不问余耶。王言世尊。我无异问。女人令我造地狱业。我于今者。唯为了知女人过患。女人谄曲虚诳邪媚。愿为开示。乃至三请亦如是说。佛言。王应先知丈夫过患。然后观察女人过失。优陀延王。唯然世尊。愿乐欲闻

佛言。一切丈夫。皆由四种不善愆过。为诸女人之所迷乱。何者为四。一者于诸欲染耽着无厌乐观女人而自纵逸。不知亲近沙门及婆罗门。具清净戒修福业者。以不亲近。如是等人。则于净信及净尸罗多闻施慧。悉皆退失。彼由无有信戒多闻施慧等法。非善丈夫。行饿鬼法。无有智慧。耽欲放逸。欲之所执。欲所系缚。欲所活命。亲近愚夫。远诸智者。恶友为伴。行非所宜。贪着女人不净境界。便为女人之所调伏。犹如奴仆。系属堕落诸女人所。无惭无愧亲近游止。诸疮漏门。脓血秽污洟唾常流。犹如冢间不净境界。至于父母违背恩养。舍离沙门及婆罗门。不生殷重恭敬供养。习行畜生所行之法。于佛法僧不生净信。于涅槃界永当退失。如是等人。当入众合乃至阿鼻诸大地狱。亦复当堕鬼界畜生。无有救护。虽闻我教。犹数思念邪恶女人歌舞戏笑。不生厌离。当知彼习愚人之法。不乐修行善丈夫事。大王。当知丈夫亲近女人之时。即是亲近恶道之法。此是丈夫第一过患。尔时世尊。而说偈言

  诸欲皆苦　　下劣秽恶　　脓血不净
  深可厌畏　　众多过患　　之所集处
  何有智人　　于此忻乐　　犹如厕中
  不净盈溢　　亦如死狗　　若死野干
  及尸陀林　　秽污充遍　　欲染之患
  可厌亦然　　诸愚痴辈　　爱恋女人
  如犬生子　　未尝舍离　　亦如蝇见
  所吐饮食　　又若群猪　　贪求粪秽
  女人能坏　　清净禁戒　　亦复退失
  功德名闻　　为地狱因　　障生天道
  何有智人　　于此忻乐　　又如有人
  服食毒药　　身心痛恼　　不能运动
  由是欲因　　能为苦本　　如身有毒
  愚不了知　　亦如不了　　幻化之法
  妄有寻求　　但自疲苦　　愚夫亦尔
  常于欲染　　疲苦贪求　　堕诸地狱
  或设饮食　　歌舞伎乐　　婚娶他女
  将为已妻　　积集众多　　无利苦法
  愚夫造此　　无利之业　　增长诸罪
  退失善根　　于无利中　　不惜身命
  由斯坠堕　　恶道深坑　　便招地狱
  猛焰铁丸　　锋刃刀山　　毒箭诸苦
  女人能集　　众多苦事　　假以花香
  而为严好　　愚人于此　　妄起贪求
  亲近称誉　　下劣之法　　退失智慧
  堕落三涂　　此由愚痴　　之所迷惑
  如海疲鸟　　迷于彼岸　　又如愚夫
  取于热铁　　置之颈项　　如牛被轭
  欲如诸酒　　狂乱于人　　如何愚夫
  不知苦本　　或于父母　　不识恩慈
  皆由欲染　　生此过患　　常于如是
  邪欲之法　　称赞习行　　无有惭愧
  彼由愚痴　　所迷乱故　　作是罪已
  当趣三涂　　耽重于欲　　惛醉之人
  父母之恩　　亦能弃舍　　若有贪染
  亲近欲者　　则为违背　　福德上田
  无量俱胝　　妄想烦扰　　展转逼恼
  从此而生　　或复悕求　　世间财位
  以是非法　　展转相劝　　由此现招
  捶打苦事　　死必当堕　　阿鼻地狱
  现见众苦　　皆来集身　　善友乖离
  天宫永失　　何有智人　　于此忻乐
  宁投铁狱　　驰走刀山　　眠卧焰炉
  不亲女色　　若常贪染　　邪欲之者
  退失众多　　诸利乐事　　女人能作
  众苦之因　　欲能灭坏　　一切安乐
  恶法积集　　善友乖离　　皆以耽求
  女人为本　　若有得闻　　我之所说
  能于女人　　深生厌离　　则为庄严
  清净天道　　亦当速证　　无上菩提

复次大王。夫父母者。皆愿利乐所生子故。难作能作。能忍一切难忍之事。假令种种不净秽恶皆能忍之。又欲令子色力之身速增长故。令见阎浮胜妙之事。乳餔养育无疲厌心。或为令子获诸妙乐。艰辛经求所得财物。供给营办资生所须。及往他家结求婚娶。既婚娶已。于他女人爱恋耽着。由耽着故惛醉缠心。或见父母渐将衰老。违逆轻欺。所有资财无惭费用。或令父母不住于家。如是皆由欲所迷倒。大王。当知以此因缘。于己父母弃背恩养。于他女人尊重承事。种种供给无疲厌心。即是成就地狱之本。此是丈夫第二过患。尔时世尊。而说偈言

  汝等当知　　尊重供养　　于父母者
  是人常有　　释梵护世　　之所扶持
  能令居家　　安隐快乐　　或因贸易
  大海远方　　安隐往来　　获诸财利
  此即说为　　无价大宝　　现能与果
  名最上田　　如是现世　　果报珍宝
  皆因供养　　父母而得　　复于来世
  当得远离　　驼驴等身　　负重驱役
  亦复不受　　尸粪灰河　　刀山锋刃
  镕铜等苦　　又于来世　　生在人中
  富有财宝　　丰饶谷帛　　妻子眷属
  悉皆和穆　　或复当来　　得生天上
  宫殿园苑　　音乐自然　　纵意欢娱
  受诸妙乐　　何有智者　　闻是法音
  于父母田　　不勤供养

复次大王。若诸丈夫由于邪见。不知自身速当坏灭。造作诸恶而自欺诳。彼愚痴人虚度长夜。犹如木石雕刻所成。虽形似人而无所识。习诸欲者。即是成就往恶趣业。此是丈夫第三过患。尔时世尊。而说偈言

  丈夫为欲　　之所迷乱　　由斯造作
  种种诸罪　　倒见闇障　　隐蔽其心
  乘此当生　　恶趣牢狱　　邪行之者
  当复远离　　一切贤圣　　亦不恭敬
  诸沙门等　　由颠倒见　　乃至归命
  山河邪魅　　为于贪欲　　或复杀害
  一切禽兽　　祭祀神祇　　倒见为因
  非法求福　　由斯永离　　一切安乐
  若于是中　　造恶之者　　不知净信
  凶险无惭　　如是之人　　永离贤圣
  彼必当堕　　[口*睪]叫地狱　　或为于欲
  逼恼于他　　当堕烧然　　极烧然狱
  复由倒见　　于佛法僧　　不能亲近
  恭敬供养　　正教法宝　　而不听闻
  远离贤圣　　堕诸恶趣　　是故智者
  既得人身　　勿复作斯　　颠倒妄见
  勤修布施　　及净尸罗　　当得生天
  证菩提道

复次大王。或有丈夫为于身命。极自劳苦积集珍财。后为女人所缠摄故。如彼僮仆敬事供承。由是因缘悭惜财宝。不施沙门及婆罗门。亦复堪忍王法治罚。轻毁凌辱悉能受之。或被女人捶打呵叱。或至怖惧屈意瞻奉。见其忧戚即自念言。我今云何令彼欢悦。当观此人是欲僮仆。于斯不净下劣之境。而生净想起于爱染亲近如是女人之时。即是圆满恶趣之业。此是丈夫第四过患。尔时世尊。而说偈言

  耽欲惛醉人　　彼实无安乐
  亲近恶法故　　不名善丈夫
  若人自纵逸　　无有禁戒者
  随心之所为　　失坏于福利
  彼无智慧人　　行于畜生法
  驰趣于女色　　犹猪乐粪秽
  愚者不能观　　欲染之过患
  妄生殷重想　　犹若盲冥人
  为色所系缚　　增长于欲爱
  犹如于野干　　不离尸冢间
  于声香味触　　而生爱着心
  轮转生死中　　如猕猴系柱
  无明缠覆故　　为女所迷乱
  如市求利人　　矫诈来亲附
  愚人亲近欲　　是入魔境界
  犹若翳茶迦　　耽嗜于粪秽
  亦如霔雹雨　　能损于稼穑
  窑师常近火　　多为所焚烧
  诸未见谛者　　为欲失白法
  如风吹微糠　　其义亦如是
  假如善丈夫　　为杀者所执
  宁受斯逼害　　不应亲女人
  若乐观女色　　贪求转复多
  取相之凡夫　　增长于欲爱
  如于炎夏时　　游行旷野中
  渴逼饮碱水　　饮已渴弥增
  未见真实者　　愚痴徒自活
  亲近于女人　　贪欲爱坚固
  若人触毒虫　　便为毒所害
  如是诸凡夫　　犯欲亦如是
  譬如彩画瓶　　内盛以恶毒
  是中实可畏　　外相现端严
  严饰于女人　　谓彼为姝妙
  是中甚秽恶　　如气满皮囊
  又如以缯彩　　缠里于利刀
  庄严彼女人　　其义亦如是
  如火满深坑　　无烟能烧害
  女人亦如是　　暴恶无哀愍
  如死狗死蛇　　秽恶而坏烂
  亦如烧粪秽　　人皆厌恶之
  死蛇粪狗等　　虽甚可厌恶
  如是诸女人　　可厌复过彼
  譬如劫坏时　　大地皆火起
  丛林诸草木　　一切悉燋然
  大身者所居　　海水尽干竭
  须弥等宝山　　世界遍烧坏
  如是劫烧时　　焚燎于山海
  无有诸众生　　能为救护者
  因兹女欲故　　烧害诸愚夫
  犹如劫火然　　一切皆烧尽
  不净常流注　　涎洟脓血身
  奈何彼愚夫　　于此而耽着
  骸骨相搘柱　　皮肉以覆之
  臭秽甚可恶　　如弃残宿食
  亦如仓廪门　　糠糗恒狼籍
  此身诸秽恶　　充满亦复然
  胃脾肾肝胆　　及肠肺粪秽
  并髓脑脓血　　八万户诸虫
  在中常唼食　　盲冥诸愚夫
  痴网自缠覆　　于是不能了
  杂食所余秽　　九孔常流注
  如是过患身　　由先不净业
  愚夫于女人　　系恋彼声色
  由斯生染着　　曾不如实知
  如蝇见于吐　　而生爱着心
  愚夫贪女人　　境界亦如是
  颠仆于女色　　恒自秽其身
  如何彼愚夫　　于此乐游止
  如鸟为求食　　不知避网罗
  贪爱于女人　　被害亦如是
  譬如水中鱼　　游泳网者前
  便为他所执　　岂非自损伤
  女若捕鱼人　　谄诳犹如网
  男子同于鱼　　被网亦如是
  杀者之利刀　　虽复甚可畏
  女人刀可畏　　伤害复过彼
  如蛾投灯炬　　及火烧屋时
  虫等被焚烧　　无依无救者
  迷醉于女人　　贪火所烧害
  由斯堕恶趣　　无依怙亦然
  邪行诸愚夫　　爱恋他妻室
  妄生欣悦想　　犹如于家鸡
  亦如旷野雉　　妄游杀害所
  损伤因自生　　而无救济者
  舍离于佛法　　亲近彼女人
  由是业因缘　　坠堕于恶道
  又如诸猕猴　　跳踯岩树间
  必致自损伤　　岂不由愚惑
  如是耽欲者　　于彼诸女人
  为痴网所罗　　数受生死苦
  如世之罪人　　处以尖摽苦
  耽醉淫欲者　　当悬剑树林
  譬如以猛火　　烧然彼镬汤
  投之以麻麦　　随沸而漂没
  如是耽欲人　　不识于善路
  死当堕恶道　　煎煮镬汤中
  镬汤之大数　　六十四俱胝
  诸造恶之人　　以彼为居处
  如是一一镬　　量各一由旬
  猛火遍烧然　　底及四周际
  或有满百年　　或二三四百
  受煎煮之苦　　皆由自业为
  狱卒以利钩　　时复举令出
  皮肉皆烂堕　　其骨白如珂
  于是诸狱卒　　复将置铁槽
  以杵而捣之　　无能救护者
  尔时诸骨髓　　尽碎末为尘
  由业风所吹　　死已复还活
  若有侵逼他　　妻妾童女等
  当缘铁刺树　　并受斧杵殃
  有三股铁叉　　或四五岐者
  侵扰他妻室　　当受此刑治
  复有铁嘴乌　　深啄于髓脑
  野干等诸兽　　竞来食啖之
  如是邪欲人　　当堕尸粪狱
  及走于锋刃　　亦复上刀山
  如是邪欲人　　颠坠炎热狱
  既被烧害已　　复趣于寒冰
  如是邪欲人　　亦堕极炎热
  [口*睪]叫及大叫　　并往黑绳中
  如是邪欲人　　当没碱热河
  复经历煻煨　　未至底便死
  地狱有蒺[卄/梨]　　五角极铦利
  彼为狗所逼　　忙怖走其中
  爱恋于女人　　堕于大怖处
  或吞于铁丸　　或饮洋铜汁
  有二热铁山　　彼此来相合
  昔时耽欲者　　于中受苦殃
  受斯苦楚时　　都无救护者
  得如是罪报　　皆由自业缘
  昔同欢爱者　　今于何所在
  我独受其殃　　而不来相救
  由于先世中　　自作如是业
  假令父母等　　无能相救者
  由于先世中　　自作如是业
  假令男女等　　无能相救者
  由于先世中　　自作如是业
  假令兄弟等　　无能相救者
  由于先世中　　自作如是业
  假令姊妹等　　无能相救者
  由于先世中　　自作如是业
  假令朋友等　　无能相救者
  愚夫为邪欲　　贪求于女人
  无间地狱中　　受如是诸苦
  说此不清净　　秽恶之女人
  愚夫所游行　　智者皆远离
  亲近彼女人　　最为极下劣
  是恶中之恶　　何足为欣乐
  耽着诸凡夫　　常抱于粪囊
  由此业因缘　　当受无量苦
  愚夫为女人　　受种种刑罚
  囚系及捶打　　而无厌离心
  愚夫为女人　　被种种烧害
  能忍受斯苦　　而无厌离心
  或置在尖标　　或杀或沉水
  或掷于大坑　　备受诸苦毒
  虽见如是苦　　犹于淫欲中
  称赞于女人　　曾不生厌离
  或有少智人　　知为众苦本
  见已还亲近　　如胡胶见火
  闻佛之所说　　虽复生信受
  仍多畜女人　　其众如群羊
  或闻诸佛教　　才兴厌悔心
  须臾贪复生　　如恶毒还发
  犹如被怖猪　　暂止须臾顷
  若见于粪秽　　贪爱还复生
  愚夫闻法已　　暂尔心惊怖
  后见诸欲色　　贪爱还复生
  犹如有丈夫　　从其自身首
  弃掷金花鬘　　翻戴于热铁
  愚夫耽欲故　　弃舍诸佛教
  贪求下劣法　　造作诸罪业
  迷醉诸欲者　　堕阎罗界中
  常吞热铁丸　　复饮洋铜汁
  迷醉于欲者　　背善而行非
  舍离于清净　　永趣阎罗界
  若有智慧人　　闻我说是法
  应舍一切欲　　速求于出离

尔时世尊说是偈已。优陀延王。即白佛言。今此所闻希有希有。如来应正等觉。善能说是诸欲过患。我今归依佛法僧宝。从今已往乃至尽形。归佛法僧作优婆塞。唯愿世尊。摄受于我。佛说此经已。优陀延王及诸大众。天人世间阿修罗乾闼婆等。闻佛所说。欢喜奉行

大宝积经卷第九十七大宝积经卷第九十八

        大唐三藏法师菩提流志奉　诏译

    妙慧童女会第三十

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众千二百五十人。菩萨摩诃萨十千人俱。时王舍城有长者女。名为妙慧。年始八岁。面貌端正容色姝好。诸相具足见者欢喜。曾于过去无量诸佛。亲近供养种诸善根。时彼女人诣如来所。顶礼佛足右绕三匝。长跪合掌而说偈言

  无上等正觉　　为世大明灯
  菩萨之所行　　唯愿听我问

佛告妙慧。今恣汝问。当为解说令断疑网。尔时妙慧。即于佛前。以偈问曰

  云何得端正　　大富尊贵身
  复以何因缘　　眷属难沮坏
  云何见己身　　而受于化生
  千叶莲花上　　面奉诸世尊
  云何能证得　　自在胜神通
  遍往无量刹　　礼敬于诸佛
  云何得无怨　　所言人信受
  净除于法障　　永离诸魔业
  云何命终时　　得见于诸佛
  闻说清净法　　不受于苦恼
  大悲无上尊　　唯愿为我说

尔时佛告妙慧童女言。善哉善哉。善能问此深妙之义。谛听谛听善思念之。当为汝说。妙慧白言。唯然世尊。愿乐欲闻。佛言妙慧。菩萨成就四法受端正身。何等为四。一者于恶友所不起嗔心。二者住于大慈。三者深乐正法。四者造佛形像。尔时世尊。而说偈言

  嗔坏善根勿增长　　慈心乐法造佛形
  当获具相庄严身　　一切众生常乐见

复次妙慧。菩萨成就四法得富贵身。何等为四。一者应时行施。二者无轻慢心。三者欢喜而与。四者不希果报。尔时世尊。而说偈言

  应时行施无轻慢　　欢喜授与不希求
  能于此业常勤修　　所生当获大财位

复次妙慧。菩萨成就四法得眷属不坏。何等为四。一者善能弃舍离间之语。二者邪见众生令住正见。三者正法将灭护令久住。四者教诸有情趣佛菩提。尔时世尊。而说偈言

  舍离间言及邪见　　正法将灭能护持
  安住众生大菩提　　当成不坏诸眷属

复次妙慧。菩萨成就四法。当于佛前得受化生处莲花座。何等为四。一者捧诸花果及细末香。散于如来及诸塔庙。二者终不于他妄加损害。三者造如来像安处莲花。四者于佛菩提深生净信。尔时世尊。而说偈言

  花香散佛及支提　　不害于他并造像
  于大菩提深信解　　得处莲花生佛前

复次妙慧。菩萨成就四法。从一佛土至一佛土。何等为四。一者见他修善不为障恼。二者他说法时未尝留碍。三者然灯供养如来之塔。四者于诸禅定常勤修习。尔时世尊。而说偈言

  见人修善说正法　　不生谤毁加留难
  如来塔庙施灯明　　修习诸禅游佛刹

复次妙慧。菩萨成就四法处世无怨。云何为四。一者以无谄心亲近善友。二者于他胜法无嫉妒心。三者他获名誉心常欢喜。四者于菩萨行无轻毁心。尔时世尊。而说偈言

  不以谀谄亲善友　　于人胜法无妒心
  他获名誉常欢喜　　不谤菩萨得无怨

复次妙慧。菩萨成就四法所言人信。何等为四。一者发言修行常使相应。二者于善友所不覆诸恶。三者于所闻法不求过失。四者于说法者不生恶心。尔时世尊。而说偈言

  发言修行常相应　　己罪不藏于善友
  闻经不求人法过　　所言一切皆信受

复次妙慧。菩萨成就四法。能离法障速得清净。何等为四。一者以深意乐摄三律仪。二者闻甚深经不生诽谤。三者见新发意菩萨生一切智心。四者于诸有情大慈平等。尔时世尊。而说偈言

  以深意乐摄律仪　　闻甚深经能信解
  敬初发心如佛想　　慈心普洽障消除

复次妙慧。菩萨成就四法能离诸魔。云何为四。一者了知法性平等。二者发起精进。三者常勤念佛。四者一切善根皆悉回向。尔时世尊。而说偈言

  能知诸法平等性　　常起精进念如来
  回向一切诸善根　　众魔不能得其便

复次妙慧。菩萨成就四法。临命终时诸佛现前。何等为四。一者他有所求施令满足。二者于诸善法深生信解。三者于诸菩萨施庄严具。四者于三宝所勤修供养。尔时世尊。而说偈言

  他有所求令满足　　信解深法舍严具
  三宝福田勤供养　　临命终时佛现前

尔时妙慧童女闻佛说已。白言。世尊。如佛所说菩萨诸行。我当奉行。世尊。若我于是四十行中。阙于一行而不修者。则违佛教欺诳如来。尔时尊者大目犍连告妙慧言。菩萨之行甚难可行。汝今发斯殊胜大愿。岂于是愿得自在耶。尔时妙慧白言尊者。若我弘愿真实不虚。能令诸行得圆满者。愿此三千大千世界六种震动。天雨妙花天鼓自鸣。说是语时。于虚空中花散如雨天鼓自鸣。三千大千世界六种震动。是时妙慧重白目连。以我如是真实言故。于未来世当得成佛。亦如今日释迦如来。于我国中无有魔事及以恶趣女人之名。若我此言非虚妄者。令斯大众身皆金色。说是语已众皆金色。尔时尊者大目犍连。即从坐起。偏袒右肩顶礼佛足。白言。世尊。我今先礼初发心菩萨及诸菩萨摩诃萨众

尔时文殊师利法王子告妙慧言。汝住何法发斯诚愿。妙慧答言。文殊师利。非所问也。何以故。于法界中无所住故。又问云何名为菩提。答曰。无分别法是名菩提。又问云何名为菩萨。答曰。一切诸法等虚空相。是名菩萨。又问云何名为菩提之行。答曰。犹如阳焰谷响之行。是菩提行。又问依何密意作如是说。答曰。我于此中不见少法密非密者。又问若如是者一切凡夫应即菩提。答曰。汝谓菩提异凡夫耶。莫作是见。何以故。此等皆同一法界相。非取非舍无成坏故。又问于此义中能解了者其数几何。答曰。如若干幻化心心所量。若干幻化众生能了斯义。文殊师利言。幻化本无。何有如是心心所法。答曰。法界亦尔非有非无。乃至如来亦复如是。尔时文殊师利白佛言。世尊。今此妙慧。甚为希有。乃能成就如是法忍。佛言。如是如是。诚如所言。然此童女。已于过去发菩提心。经三十劫。我乃发趣无上菩提。彼亦令汝住无生忍

尔时文殊师利。即从座起为其作礼。白妙慧言。我于往昔无量劫前。已曾供养。不谓今者还得亲近。妙慧告言。文殊师利。汝今莫起如是分别。何以故。以无分别得无生忍故。又问妙慧。汝今犹不转女身耶。妙慧答言。女人之相了不可得。今何所转。文殊师利。我当为汝除断疑惑。由我如是真实语故。于当来世。得阿耨多罗三藐三菩提时。于我法中诸比丘辈。闻命善来出家入道。我国土中。所有众生身皆金色。服用资具如第六天。饮食丰饶随念而至。无有魔事及诸恶趣。亦复无有女人之名。有七宝林上罗宝网。七宝莲花覆以宝帐。如文殊师利所成净刹装校严饰。等无有异。若我此言非虚妄者。令此大众身皆金色。我之女身变成男子。如三十岁知法比丘。说此语时。此诸大众皆作金色。妙慧菩萨转女成男。如三十岁知法比丘。是时地居天众展转赞言。大哉大哉。妙慧菩萨摩诃萨。能于来世得菩提时。严净佛刹功德如是。尔时佛告文殊师利。此妙慧菩萨。于当来世成等正觉。号殊胜功德宝藏如来。出现于世。佛说此经时三十俱胝众生。于阿耨多罗三藐三菩提。住不退转。八十俱胝众生。远尘离垢得法眼净。八千众生皆获智证。五千比丘行菩萨乘心欲退转。因见妙慧菩萨意乐善根威德殊胜故。各各脱身所著上服。以施如来。如是施已发弘誓言。我等以此善根。决定愿成阿耨多罗三藐三菩提。彼诸善男子等。以此善根回向无上菩提故。超九十劫生死之苦。不退转于阿耨多罗三藐三菩提。尔时世尊。即记之曰。汝等于当来世过千劫。后于无垢光明劫中。阳焰世界难忍佛刹。于一劫中。相次成佛皆同一字。号辩才庄严如来。出现于世。文殊师利。如是法门有大威德。能令菩萨摩诃萨及声闻乘者。获大利益。文殊师利。或有善男子善女人。为求菩提无方便善巧。行六波罗蜜足满千劫。若复有人经于半月。时一书写读诵此经。所获福聚比前功德。百分千分百千俱胝。乃至算数譬喻所不能及。是故文殊师利。如是微妙法门。即诸菩萨契经之本。我今付嘱于汝。汝当来世。受持读诵为人解说。譬如转轮圣王出现于世。所有七宝皆悉在前。王灭之后宝随隐没。如是微妙法门流行于世。即诸如来七菩提分等。法眼不灭。若不流行正法当灭。是故文殊师利。若善男子善女人等。为求菩提。应当发起精进。书写此经。受持读诵为人演说。此是我教。勿于后世生悔恨心。佛说此经已。妙慧菩萨。文殊师利菩萨。及诸大众天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

    恒河上优婆夷会第三十一

        大唐三藏菩提流志奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。时舍卫城有优婆夷。名恒河上。从其住处来诣佛所。顶礼佛足退坐一面

尔时世尊问恒河上。汝从何来。彼优婆夷。即白佛言。世尊。若问化人汝从何来。如是问者当云何答。世尊告言。夫化人者。无有往来。亦无生灭。云何当说有所从来。又问诸法岂不皆如化耶。佛言。如是如是。如汝所说。恒河上言。若一切法皆如化者。云何问言汝从何来。世尊告曰。是幻化人不往恶趣。不生天上。不证涅槃。恒河上。汝亦尔耶。白言。我若见身异于幻化。乃可说言。往善恶趣。证于涅槃。我不见身异于幻化。云何说言。往诸恶趣乃至涅槃

复次世尊。如涅槃性。毕竟不复生善恶趣及般涅槃。我观己身亦复如是。佛言。汝岂不趣涅槃界耶。恒河上言。如以此问问无生者。应云何答。佛言。无生者即涅槃也。恒河上言。诸法岂不皆同涅槃。佛言。如是如是。世尊。若一切法同涅槃者。云何问言。汝岂不趣涅槃界耶

复次世尊。譬如化人。谓化人曰。汝岂不趣涅槃界耶。彼于是问。当云何答。世尊告言。此所问者无有攀缘。恒河上言。如来岂以有所攀缘而致斯问。世尊告言。然我所问亦无攀缘。但为此会。有善男子及善女人。应可成熟故发斯问。何以故。如来于彼诸法。名字犹不可得。何有诸法及彼能趣般涅槃者。恒河上言。若如是者。云何为菩提故积集善根。若诸菩萨及彼善根。皆不可得。积集之时即无心故。非积集时亦复如是。恒河上言。所说无心欲明何义。世尊告曰。此法非思惟之所能知。亦非思惟之所能得。何以故。此中心尚不可得。何况心所生法。以心不可得。是即说名不思议处。此不思议处。无得无证非染非净。何以故。如来常说一切诸法。犹如虚空无挂碍故。恒河上言。若一切法如虚空者。云何世尊。说有诸色受想行识。及于界处十二因缘。有漏无漏。是染是净。生死涅槃佛告恒河上。譬如说我虽有言说。而实无有我相可得。我说诸色。实亦无有色相可得。乃至涅槃亦复如是。又如阳焰无水可得。我说诸色乃至涅槃。亦复如是。恒河上。于我法中修梵行者。见一切法皆无所得。乃可说名真修梵行。增上慢者说有所得。是则不名住真梵行。我说如是。增上慢人。闻此深法生大惊疑。不能解脱生老病死忧悲苦恼。恒河上。若我灭后。有能宣说如是甚深断流转法。有愚痴辈由恶见故。于是法师生嗔害心。以是因缘堕诸地狱。恒河上言。如佛所说断流转法。以何义故。名为断流转。世尊告言。断流转者。所谓实际不思议界。此法不可穿凿沮坏。是故说名断流转法

尔时世尊。凞怡微笑。从其面门放种种光。青黄赤白红颇梨色。其光普照无量国界。上至梵世还从如来顶上而入

尔时尊者阿难。见是事已心自念言。如来应正等觉。非无因缘而现微笑。作是念已。即从座起。偏袒右肩右膝着地。合掌向佛。而作是言。以何因缘现此微笑。佛言。我念往昔。有千如来。亦于此处说如是法。彼诸众会。各各亦有恒河上优婆夷。而为上首。彼优婆夷及诸大众。闻是法已皆悉出家。于无余涅槃而得灭度。阿难白佛言。当何名此经。我等云何受持。佛言。此经名为离垢清净。以是名字汝当受持。说此经时。七百比丘众。四百比丘尼众。诸漏永尽心得解脱

尔时欲界诸天子。化作种种天诸妙花而散佛上。作如是言。此优婆夷甚为希有。能与如来共相詶对。得无所畏。是人已曾无量佛所。亲近供养种诸善根。佛说是经已。恒河上优婆夷。及诸天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第九十八大宝积经卷第九十九

        元魏三藏法师佛陀扇多译

    无畏德菩萨会第三十二

如是我闻。一时婆伽婆住王舍大城耆阇崛山中。与五百比丘众俱。菩萨摩诃萨无量无边。复有八千菩萨摩诃萨而为上首。皆得三昧及陀罗尼。善入空无相无愿三解脱门。善巧诸通得无生法忍。所谓

弥楼菩萨。大弥楼菩萨。常入定菩萨。常精进菩萨。宝手菩萨。常喜根菩萨。跋陀波罗菩萨。宝相菩萨。罗睺菩萨。释天菩萨。水天菩萨。上意菩萨。胜意菩萨。增上意菩萨摩诃萨。八千人等而为上首

尔时婆伽婆。依王舍城住。若王王子。诸婆罗门。长者居士。尊重赞叹而供养佛。尔时世尊。具有无量百千万众。恭敬围绕而为说法

尔时尊者舍利弗。尊者大目犍连。尊者大迦叶。尊者须菩提。尊者富楼那弥多罗尼子。尊者离波多。尊者阿湿卑。尊者优波离。尊者罗睺罗。尊者阿难。如是等无量声闻。于其晨朝整衣持钵。入王舍城从家至家。如法乞食更无余缘。时诸声闻如是乞食。渐渐遂到阿阇世王所住宫殿。至王所已。却立一面默然而住。不言乞食及不乞食

尔时阿阇世王。有女名无畏德。端正无比。无匹无双无并无类。成就最胜殊妙功德。年始十二。在其父王堂阁之上。着金宝屐彼处而坐。时无畏德。见诸声闻不起不迎。默然而住。不共问答。不迎不礼不让床座。阿阇世王。见无畏德默然而住。即告之言。汝岂不知。此等皆是释迦如来上足弟子成就大法也。世间福田耶。以为愍念诸众生故。而作乞食。汝今既见。何故不起不迎不礼。不共相问彼不让坐。汝今者睹见何事故。而不起迎

尔时无畏德白父王言。不审大王。颇见颇闻。转轮圣王见诸小王。而起迎不。王言不也。复言大王。颇见颇闻。师子兽王见野干时。为起迎不。王言不也。复言大王。颇见颇闻帝释天王。迎余天不。大梵天王。有曾礼敬余天众不。王言不也。复言大王。颇见颇闻。大海之神礼敬江河池等神不。王言不也。复言大王颇见颇闻。须弥山王。礼敬诸余小山王不。王言不也。复言大王。颇见颇闻。日月光神。有曾礼敬萤火虫不。王言不也。女言大王。如是菩萨。发心趣向阿耨多罗三藐三菩提。转轮圣王。以大慈悲初发心已。云何礼敬离大慈悲小乘声闻。大王。颇见已求无上正真正觉之道。师子兽王。而礼小乘野干人耶

大王。颇有已求大梵道处。而发进者。而当亲近微少善根声闻人耶

大王。颇有欲到大智之海。欲求善知大法之聚。而求牛迹声闻人耶。以彼从他闻音声故。大王。颇有欲至佛须弥山。为求如来无边色身。而欲更求小芥子中空三昧力。诸声闻人而礼敬耶

大王。颇有得闻诸佛如来。功德智慧如日月光。如是闻已方乃礼敬诸声闻人萤火虫耶。以诸声闻唯能自润自照。从他闻声而得解故

大王。佛入涅槃。尚不礼敬诸声闻人。何况今者世尊在世。何以故。大王。若有亲近声闻人者。是人即发声闻之心。若人亲近缘觉人者。是人即发缘觉之心。若有亲近正真正觉。即发阿耨多罗三藐三菩提心。无畏德女。如是说已。以偈报父阿阇世言

  譬如人至海　　而取一文钱
  我见诸声闻　　所行亦如是
  至大法海已　　舍大乘宝聚
  而起狭劣心　　修行小乘道
  如人亲近王　　出入无障碍
  从王乞一钱　　彼人徒亲王
  敬心近轮王　　从乞百千财
  润无量贫穷　　是名善亲王
  如人求一钱　　声闻亦如是
  不求真解脱　　而取小涅槃
  若起狭劣心　　自度不度他
  犹如小医师　　唯自治己身
  譬如大医王　　疗治众多人
  善起慈悲心　　得恭敬名称
  彼医得世利　　以达医方故
  自度不度他　　智者不恭敬
  如善巧医王　　通达众方已
  救无量千亿　　病苦诸众生
  彼医得世间　　恭敬及名称
  发菩提心者　　普治烦恼病
  大王蓖麻林　　花香影不妙
  声闻如蓖麻　　不救世发心
  如至树王所　　多众得利益
  诸菩萨亦尔　　能益一切众
  不以秋阳焰　　能竭诸小水
  至于大海已　　能润无量众
  声闻道狭劣　　犹如牛蹄迹
  不能灭众生　　所有诸烦恼
  非上诸小山　　而现金色身
  唯升须弥山　　悉见金色身
  大王诸菩萨　　亦如须弥山
  以彼住世故　　世间得解脱
  皆是一色身　　一切智具足
  声闻智不尔　　其犹如朝露
  不能润于世　　以不证法故
  如地多增长　　润益无量众
  声闻如花露　　菩萨如大雨
  亲近得大法　　如海之润势
  犹如踯躅花　　无彼微妙香
  男女所不乐　　唯喜薝卜花
  如求青莲花　　花香甚奇妙
  踯躅如声闻　　彼智不润众
  犹如薝卜花　　诸菩萨亦尔
  愍念众生故　　能化众生众
  大王颇曾知　　何者大奇特
  一人在旷野　　如利多人是
  若欲善安隐　　度无量众生
  应发菩提心　　勿取二乘道
  世间旷野中　　能济失道众
  如彼善导师　　诸菩萨亦尔
  大王颇曾见　　小筏度大海
  唯乘彼大舶　　能度无量众
  大王声闻筏　　菩萨如大舶
  修道法薰已　　令渡饥渴海
  大王颇曾见　　乘驴堪入阵
  唯见乘象马　　斗战便得胜
  声闻如驴乘　　菩萨如龙象
  降魔坐道树　　度无量众生
  犹如夜虚空　　见诸星不现
  满月显现故　　能照阎浮提
  声闻如星宿　　菩萨如满月
  愍念众生故　　示现涅槃道
  不以萤火光　　能令有所作
  日光照阎浮　　令作种种事
  声闻如萤火　　不能多利益
  佛具解脱光　　愍念一切众
  不以野干声　　能令兽王恐
  唯有狮子王　　一吼飞鸟落
  大王诸声闻　　不发菩提心
  不为益众生　　除一切烦恼
  大王见此故　　不发声闻心
  既发大心已　　云何得发小
  大王善得身　　能发无上心
  救拔一切众　　弃舍小乘道
  善得世间身　　复得世间利
  善来在世间　　而发无上心
  悕求无上道　　救拔诸众生
  若能自他利　　彼人善可叹
  亦得世名称　　及得究竟道
  以是故我今　　不礼敬声闻

尔时阿阇世王。语无畏德女言。汝大我慢。云何而见诸大声闻。而不奉迎。女言大王。勿作此语。大王亦慢。云何不迎王舍城内诸贫穷者

王语女言。彼非我类我云何迎。女言大王。初心菩萨亦复如是。一切声闻缘觉非类。王语女言。汝岂不见诸菩萨等。皆悉礼敬一切众生。女言大王。菩萨为度憍慢嗔恼诸众生等。令彼得起回向之心。是故礼敬一切众生。为长众生诸善根本。是故菩萨礼敬众生。而诸声闻无嗔恨心。又复不能增长善根。大王。假使百千诸佛如来。为说妙法。而彼所得戒定三昧。无有增益。大王。声闻如琉璃。菩萨如宝器。大王。譬如瓶满。天降雨时而不受一滴。如是大王。诸声闻等。假使百千诸佛如来。为说妙法而无受润。不能增益戒定慧等。亦不能令众生发心至一切智。大王。譬如大海能受诸河及云雨等。何以故。以大海是无量器故。大王。诸大菩萨摩诃萨等。演说法时。随所闻者得大福利。增长一切诸善根本。何以故。以诸菩萨皆是无边言说器故

尔时阿阇世王。闻女语已默然而住。尔时尊者舍利弗。作如是念。此无畏德女。得大辩才而能如是无尽言说。我于今者前至其所。少少问之。我且问之。汝得忍不。作是念已前问女言。汝今为住声闻乘耶。答言不也。汝今为住缘觉乘耶。答言不也汝今为住大乘心耶。答言不也。舍利弗言。若如是者为住何乘。而能如是师子吼耶。女答尊者舍利弗言。若使我今有所住者。则不能作师子吼也。我无所住。是故我能作师子吼。而舍利弗作如是言。为住何乘。如舍利弗所证得法。彼法岂有乘分别耶。此是声闻缘觉之乘。至大乘耶。舍利弗言。汝听我说。我所证法。无乘非乘差别之相。以一相故。所谓无相。无畏女言。尊者舍利弗。若法无相。云何可求。舍利弗言。无畏德女。诸佛之法与凡夫法。有何胜负差别之相。女语尊者舍利弗言。空与寂静有何差别。舍利弗言。无差别也。无畏德言。舍利弗。如空寂静无有差别胜负之相。诸佛之法与凡夫法。无有胜负差别之相。又舍利弗。亦如虚空能受诸色而无差别。诸佛之法与凡夫法。无有差别亦无异相

尔时尊者大目犍连。语无畏德女言。汝见佛法与声闻法有何差别。而见如是诸大声闻。不起奉迎。不与詶对不让床坐。无畏德女。答目连言。假使星宿。遍满三千不能照了。声闻亦尔。以入定智而能照知。若不入定则不觉知。大目连言。若不入定则不能知众生之心。女言目连。佛不入定而于恒河沙等世界。如应说法度诸众生。善知心故。何况微少星宿光明诸声闻耶。此是诸佛如来胜事。又大目连。一切声闻。颇有能知几世界成几世界坏。大目连言。不能知也。女言目连。声闻颇知几数诸佛已入涅槃几数诸佛未来当入几数诸佛现在今入。目连答言。不能知也。女言目连。声闻颇知几数众生多贪欲者。几数众生多嗔恚者。几数众生多愚痴者。几数众生等分行者。目连答言。不能知也。女言目连。声闻颇知几数众生受声闻乘。几数众生受缘觉乘。几数众生受于佛乘。目连答言。不能知也。女言目连。声闻颇知几数众生声闻度之。几数众生缘觉度之。几数众生佛能度之。目连答言。不能知也。女言目连。声闻颇知几数众生。在于定聚。是正见者。几数众生住邪定聚。目连答言。不能知也。女言目连。唯有如来正真正觉。如实善知诸众生界。而为说法。如是之事非诸声闻缘觉境界。况余众生。目连。当知此是如来殊胜之事。如来具得一切智故。一切声闻缘觉所无

时无畏女。复语尊者大目连言。世尊常记大目犍连。于神通中最为第一。目连神通。能知能至香象世界。知彼世界一切诸树。皆出上妙栴檀香不。目连答言。今始得闻彼世界名。云何能往至彼世界。目连问女。彼佛何名。而在彼处世界说法。女即答言。彼佛号曰放香光明如来应正遍知。在彼说法。目连语女。今者云何得见彼佛。时无畏女。不起于座不动威仪。而作誓愿。若使菩萨初发心时。能过一切声闻缘觉。以此誓愿。愿彼放香光明如来现身于此。令诸声闻缘觉。见彼香象世界。及嗅上妙栴檀香树。时无畏女发此誓已。于是放香光明如来。从身放光。以放光故。时诸声闻。皆得见彼香象世界。及佛菩萨诸众围绕。罗网隐身为众说法。彼所说法此处悉闻。佛神力故。复得嗅彼诸树微妙栴檀之香。彼世界佛作如是言。如是如是。如无畏女之所说也。菩萨如是初发心时。已过声闻缘觉境界。说此法时。弥勒菩萨摩诃萨。白佛言。世尊。彼妙树香何因缘来。佛言弥勒。是无畏女共诸声闻。如法论议及发誓愿。彼佛知已。故以神力。现如是香及彼世界。而彼上妙栴檀之香。遍此三千大千世界。时无畏女语目连曰。若见如是不可思议诸胜功德。而能发起狭劣小乘声闻之心。唯自度者。当知善根甚为微少。谁见成就无量功德菩萨之事。而不发于菩提之心。目连。颇知彼佛世界去此几何。答言不知。女言目连。乘诸神通。经百千劫能知能见。彼佛世界无有是处。譬如一切竹苇丛林不可算数。过如是等诸佛世界。方乃有彼香象世界

尔时彼佛卷摄光明。既摄光已。香象世界及彼如来忽然不现

尔时尊者摩诃迦叶。谓无畏言。汝曾见彼香象世界及彼如来应正遍知耶。女即答言。大迦叶。如来可见不。如佛所说。若以色见我及以声求我。彼尽行邪道不能见如来。以诸如来体即是法身。佛法非可见闻。云何可知见。随何方便众生乐者。佛则示现无障碍身。住方便故。然大迦叶谓我言曰。见彼世界及见彼佛等正觉不。我见彼佛非肉眼见。以非肉眼所睹色故。非天眼见。以无受故。非慧眼见。以离想故。非法眼见。离诸行故。非佛眼见。离识睹故。大迦叶。我见如来。亦如尊者迦叶所见。以灭无明爱见心故。大迦叶。我见彼佛。亦如尊者迦叶所见。又复亦见我我所等。迦叶言女。若法永无。云何而起无明及爱及我我相。所有众生不可见故。女言大迦叶。如是一切诸法永无。彼云何见。大迦叶言。若一切佛法毕竟是无。云何可见。女言大迦叶。见诸佛法增长义不。大迦叶言。我尚不知诸凡夫法。何况佛法。无畏女言。是故尊者大迦叶。彼法不成就。云何有断续而不证者见。大迦叶。诸法永无不可示现。是故大迦叶。一切法皆无。若法本无。云何可见彼清净法界。大迦叶。若欲见净如来。彼善男子善女人。应净自心。时大迦叶。语无畏言。云何善净自心。女言大迦叶。如自身真如及一切法真如。若信彼者不作不失。如是见自心清净故。迦叶问言。自心以何为体。女言空为体。若证彼空信自身故。即信真如空。以一切法性寂静故

尔时尊者大迦叶。语无畏女言。汝从何佛闻如是法。而得正见。如佛所说发正见者。有二因缘。从他闻法。及内思惟。女言大迦叶。藉彼外声。闻外声故后内思惟。大迦叶。菩萨大士。不假他说不假音声。云何而言住于寂灭。迦叶言。女随所闻法而观察故。名为观行。时大迦叶。复问女言。菩萨云何内自思惟。女言大迦叶。若共诸菩萨说法同事。而不起众生相。菩萨如是内观。是故名为成就内观。大迦叶。一切诸法。具足本际及中后际。以一切法真如体故。一切法现在真如体故。若是观者是菩萨。名为成就内观应知。迦叶言女。云何安此诸法。女言大迦叶。如是应作。如彼真如见。无缚无解。大迦叶言。云何而见名曰正见。女言大迦叶。若离二边见故。不作非不作。如是见而不见。是名正见。大迦叶。法者唯有名字。而离名字故。以永不证故。时大迦叶。复问女言。云何得自见。无畏女言。如尊者大迦叶所见。大迦叶言。我不见自身及见我所。女语尊者大迦叶言。应当如是见一切法。以无我我所故。说此法时。尊者须菩提心大欢喜。语无畏女言。善得大利。而能成就如是辩才。时无畏女。即语尊者须菩提言。须菩提。法有可得有不可得。而可求耶。而语我言善得辩才。我有此辩。若我说无有所觉知。若内若外则有辩才。时须菩提。即语女言。汝何所证。何所得法。而有如是快妙辩才。女即答言。不自知故。不从他知。所得善法及不善法差别之相。如是知法。不见染净有漏无漏。有为无为。世间出世间。及凡夫法。以不见故。以彼法体是佛佛法。而得佛法而不见佛。须菩提。若如是者。无所觉见有此辩才。须菩提言。云何辩才。女言须菩提。如仁所得如是除灭。女语尊者舍利弗言。如彼法体无闻无得。而有所说。女语尊者须菩提言。法体可住不。复可增减不。而能有此辩才。时须菩提。即语女言。若证无漏及法。无有差别。及无辩说。以彼法体不可说故。女语尊者须菩提言。于一切法。云何而生如是念言。善得其利。得如是辩。须菩提言女。以得辩故说。为不得故说。女语尊者须菩提言。信如佛说一切诸法如响不耶。须菩提言。我信此事。女言。影响为有辩才无辩才耶。须菩提言。以内声故。而有外响。女言须菩提。以缘有声而有彼响。彼响为有何性相耶。然彼响声无有性相。何以故。若以缘生彼无生义。须菩提言。一切法缘生。无畏女言。一切诸法体性不生。须菩提言。若一切法体性如是毕竟无者。云何如来作如是说。恒河沙等诸佛当成正觉。女言。法界为可生不。须菩提言。不可生也。无畏女言。诸佛如来。一切皆是法界性相。须菩提言。不见一切诸法界也。无畏女言。诸有所说言语无漏。而说恒河沙等诸佛当得正觉。此言何趣。何以故。法界不生不灭故。一切说非说。以毕竟净故。以彼非事不可言说。离于实际。须菩提言。汝甚奇哉。既是在家。而能如是善巧说法。复有如是无尽辩才。无畏女言。须菩提。菩萨无有取以不取闻以不闻。若在家若出家而有辩才。何以故。以心净故而令智显。以智显故而显辩才。女语尊者须菩提言。今可善说菩萨之行。须菩提言。汝说我听。无畏女言。须菩提。菩萨成就八种法行故。不得言在家出家。何等八法。须菩提。一者菩萨。得身清净定信菩提。二者成就大慈大悲而不舍众生。三者成就大慈悲故。善巧世间一切诸事。四者能舍身命分。及成就方便善巧。五者善巧无量发愿。六者成就般若波罗蜜行。离一切见故。七者大勇猛精进。以修诸善业而无厌足故。八者得无障智。以得无生法忍故。须菩提。菩萨成就如是八法故。不得言在家出家。随何威仪住菩提中。无有障碍

尔时尊者罗睺罗。语无畏女言。此言乃是不净言说。汝蹈宝屐复坐高床。而能如是。共诸声闻往复论义。汝岂不闻。为不病者不得说法。及不得为高床座人。而说法耶。时无畏女。即语尊者罗睺罗言。颇如实知净不净耶。尊者罗睺罗。是世间净不。罗睺罗言。无净不净。无畏女言。如来制戒随而受行。而犯彼戒为净不净。若复有人不犯彼戒。非净不净。无畏女言。且止且止。勿作是说。若如说法。若如制戒而修行者。彼说不净。罗睺罗。以彼证得无漏法故。彼则无有犯。以不犯彼亦无有净与不净。何以故。以诸声闻。过诸说法。过诸制戒。如来为诸声闻学者。来于三界为彼故说。而彼声闻已过三界。以是义故说过不过。诸界如是。以彼不能觉知戒故。说净不净。而虚空者唯有言说。唯智力见。是故得说净不净也。罗睺罗言。净与不净有何差别。无畏女言。譬如真金远离诸垢。作庄严具及不作者。色何差别。罗睺罗言。无有差别。无畏女言。净与不净唯有名字。以为差别。无余差别。何以故。一切法性离一切垢。无染无著。女语尊者罗睺罗言。坐高广床不应说法。一切菩萨。坐于草敷胜坐高床。胜于声闻在于梵天。罗睺罗言以何义故。女言罗云。颇见菩萨。坐于何座而得菩提。罗睺罗言。坐于草座。女言。菩萨坐于草座。所有三千大千世界。释梵护世四天王等。及余天子。乃至阿迦尼吒天等。悉来礼拜合十指爪掌。至菩萨所礼菩萨足。罗睺罗言。如是如是。时无畏女。问罗云言。成就如是法。菩萨而坐草座。胜于坐彼高广大床。及胜声闻在于梵天

尔时阿阇世王。语无畏女言。汝可不知此是释迦如来之子。于学戒中最为第一耶。时无畏女。语父王言。且止大王。勿作是说。言罗睺罗是如来子。大王。颇见颇闻以不。师子之王生野干不。王言不见。女言大王。颇见颇闻。转轮圣王礼敬诸余小王以不。答言不见。女言大王。如是如来师子之王。转大法轮声闻围绕。大王。若依王法而说。何者是为如来真子。则应答言诸菩萨是。是故大王。不得说言。如来有子如来无子。若说如来有真子者。应言若发阿耨多罗三藐三菩提心者。是如来子。说此法门时。阿阇世王宫内二万诸女。发菩提心。二万天子满足彼法。闻此女师子吼已。发菩提心。王复语言。此是过去未来现在诸佛之子。离诸烦恼学声闻戒云何真子。尔时彼诸天子。以花散佛遍王舍城。以为供养。无畏女故。时无畏女下彼床已。然后礼敬诸大声闻。而施种种微妙饮食。若舐若嗅若唼。如法供养。彼诸声闻供养已讫。作如是言。不审尊者诸大声闻。何故晨朝离如来所而来至此。应听法已然后乞食。尊者且去。我正尔间须臾到彼。无畏德女。于晨朝时。共阿阇世王并女之母。及王舍城无量人众。导从围绕。至如来所礼如来足。却坐一面。彼诸声闻。亦至佛所礼佛足已。却坐一面

尔时尊者舍利弗。白佛言。世尊。此无畏德女。如是奇哉。得大福利。佛语尊者舍利弗言。此无畏女。已于过去九十亿佛。发菩提心。于彼佛所种诸善根。为求无上佛菩提故。舍利弗言。世尊。此女能转女身不耶。佛言舍利弗。汝见彼女。岂是女耶。汝今不应作如是见。何以故。以是菩萨发愿力故。示现女身为度众生。于是无畏德女。作是誓言。若一切法非男非女。令我今者现丈夫身。令一切大众悉皆睹见。说此语已。即灭女身现丈夫身。升于虚空高七多罗树。住而不下

尔时世尊。即语尊者舍利弗言。汝舍利弗。见彼无畏德菩萨不。在于虚空住而不下。舍利弗言。已见。世尊。佛言舍利弗。此无畏德菩萨。复过七千阿僧祇劫。得成正觉。号曰离垢如来应正遍知。彼佛世界名曰光明。佛寿百劫。正法十劫。纯菩萨僧三万。不退转菩萨。彼佛世界净琉璃地。八道庄严莲花所覆。无有一切诸恶道名。天人充满。舍利弗。如兜率天。受微妙乐及胜法味。彼诸天子受如是乐

尔时无畏德菩萨母。号日月光。与阿阇世王俱。合十指爪掌住至佛所。白言世尊。我得大利。我于九月怀娠此子。然此善男子。今作如是大师子吼。我今回此善根。向阿耨多罗三藐三菩提。过此已后。于彼离垢光世界。而成无上正真正觉。于是佛告尊者舍利弗言。舍利弗。汝今见不。答言已见。佛言舍利弗。此月光女。舍是身已。生忉利天号曰光明增上天子。若弥勒菩萨得菩提时。是彼见王上足之子。于彼供养弥勒佛已。便即出家。彼见王子。于弥勒佛所说之法。初中后说尽能忆持。次第皆见贤劫诸佛。悉得供养。如是渐次供养佛已。然后于彼离垢如来得菩提时。得作大王。具足七宝。号曰持地。彼见王子。供养如是诸如来已。亦乃得成阿耨多罗三藐三菩提。号曰遍光如来应正遍知。具足成就佛之世界。如上所说

尔时月光夫人。欢喜踊跃。即脱价直百千两金妙宝璎珞。而供养佛。语大王已。受五百正戒具修梵行

尔时无畏德菩萨。在如来前作如是言。以此誓愿因缘力故。令我未来得菩提时。诸菩萨亦皆被法服。一切化生。以此誓愿因缘故愿令如来犹如年少八腊比丘。无畏德菩萨。如是现身。说此语已。被正法服。即成比丘具足威仪

尔时无畏德菩萨。语自父王阿阇世言。大王。一切诸法皆如是。即时忽化生相。离诸分别所起之相。无诸颠倒。大王。还即此时复现女身。王见不也。王言已见。而我非以色身相见。我今现见比丘身已。复见女身。佛问王言。何者是实。大王。应当作如是学住一切法中。正见一切亦生烦恼所烧故。以不达法力故。以不达故。于非疑处而生疑悔。当应数数亲近如来及文殊师利童子菩萨。以彼菩萨威德力故。而令大王得受悔过

尔时世尊。告阿难言。汝受持此无畏德菩萨受记法门。读诵勿忘。阿难。若有善男子善女人等。具足七宝。施满三千大千世界诸佛如来。若复有人。能受持此无畏德菩萨受记法门一句一偈。闻已受持。得福过彼。何况具足若读若诵广为人说如法修行。如来说此无畏德菩萨受记法门时。月光夫人无畏德母。并诸天龙阿修罗等。闻佛说已皆大欢喜信受奉行

大宝积经卷第九十九大宝积经卷第一百

        西晋居士聂道真译

    无垢施菩萨应辩会

    第三十三序品第一

如是我闻。一时佛游舍卫国祇树给孤独园。与大比丘众千人俱。皆是阿罗汉。诸漏已尽无复烦恼。于诸法中皆得自在。所作已办舍于重担。逮得己利尽诸有结。得正智解脱。心得善解脱。慧得善解脱。其心调伏如大象王。心得自在到于彼岸。入八解脱。唯除阿难一人。复有诸菩萨摩诃萨。皆大庄严众所知识。逮不退转。尽一生补处

其名曰宝手菩萨。德藏菩萨。慧严菩萨。称意菩萨。观世音菩萨。文殊师利法王子。悦音法王子。不思议解脱行法王子。思惟诸法无障碍法王子。弥勒菩萨。施无忧菩萨。无痴见菩萨。离恶趣菩萨。无碍行菩萨。断幽冥菩萨。除诸盖菩萨。辩严菩萨。宝德智威菩萨。金花光明德菩萨。思无碍菩萨。如是等菩萨摩诃萨万二千人俱

尔时大德舍利弗。大德目犍连。大德摩诃迦叶。大德须菩提。大德富楼那弥多罗尼子。大德离越。大德阿那律。大德阿难。及文殊师利法王子。无痴见菩萨。宝相菩萨。离恶趣菩萨。除诸盖菩萨。观世音菩萨。辩严菩萨。无痴行菩萨。如是等八大菩萨及八大声闻。晨朝执持衣钵。欲入舍卫城乞食。时于道中。各作是念共论斯事

尔时大德舍利弗言。我当入如是定已。诣舍卫城乞食。愿令城中一切众生闻四圣谛。大德目犍连言。我当入如是定。诣舍卫城乞食。愿令城中一切众生无有魔事。摩诃迦叶言。我当入如是定。诣舍卫城乞食。愿令城中众生其施我者。令获无尽之报乃至泥洹。大德须菩提言。我当入如是定。诣舍卫城乞食。愿城中众生其见我者。以此因缘。令彼众生天上人中受诸快乐得尽苦际。大德富楼那弥多罗尼子言。我当入如是定。诣舍卫城乞食。愿令城中一切外道梵志尼揵子等悉得正见。大德离越言。我当入如是定。诣舍卫城乞食。愿令城中一切众生得无诤乐。大德阿那律言。我当入如是定。诣舍卫城乞食。愿令城中一切众生识宿业报。大德阿难言。我当入如是定。诣舍卫城乞食。愿令城中一切众生。先所闻法皆悉现前。文殊师利法王子。作是念言。我当令舍卫城中一切门户窗牖墙壁器物树木枝叶花果衣服璎珞。皆令出空无相无愿。无所有无我。无戏论。无性之声。无痴见菩萨。作是念言。我当令舍卫城中若有众生应得阿耨多罗三藐三菩提者。其所见物皆是如来像。又令决定于阿耨多罗三藐三菩提。宝相菩萨。作是念言。我当令舍卫城中一切族姓室宅之中。宝藏勇出具诸七宝。离恶趣菩萨。作是念言。我当令舍卫城中若有众生应堕恶趣者。尽使现世轻受速脱苦恼。除诸盖菩萨。作是念言。我当令舍卫城中众生尽除五盖。观世音菩萨。作是念言。我当令舍卫城中众生牢狱系闭速得解脱。临当死者即得济命。恐怖之者即得无畏。辩严菩萨。作是念言。我当令舍卫城中众生其见我者皆得辞辩。以诸妙偈互相问答。无痴行菩萨。作是念言。我当令舍卫城中若有众生其见我者得无痴见。决定于阿耨多罗三藐三菩提。如是等八大菩萨及八大声闻。共论上事。遂至舍卫城门

尔时城内波斯匿王女。名曰无垢施。始年八岁。颜貌端严世所希有。其女于二月八日佛(丹本沸)星现日。与五百婆罗门俱。持满瓶水。出至城外浴洗天像。尔时五百婆罗门。见诸比丘在门外立。见已皆为不吉。时婆罗门众中。最长宿者年百二十。名曰梵天。谓无垢施女言。今诸比丘在门外立。此事不吉。我等宜还入城不须见此。若见此已。于祀祠宜利吉祥等事。皆为不吉。尔时无垢施女。以偈答婆罗门言

  此等皆无受　　第一所应赞
  能为多众生　　洗除一切恶
  此等皆清净　　尽见四圣谛
  外道非清净　　为痴冥所覆
  两足尊福田　　施此报无量
  种于此中者　　于三有无尽
  戒行净具足　　出淤泥无著
  行世如良医　　治救病众生
  佛为世中胜　　是诸法之王
  此等是佛子　　成办阿罗汉
  如是行菩萨　　慧人云何离
  行此妙行者　　世人所应赞
  此等是慧人　　久远常行施
  梵志敬此者　　众事吉无疑
  赞此具相者　　心净良福田
  梵志若信者　　得喜无忧乐

尔时梵志。复以偈答无垢施女言

  勿随愚小心　　祠莫见沙门
  剃发被袈裟　　求乐者莫近
  汝父母不喜　　我等怀惭愧
  汝若欲行施　　其事亦不吉
  善哉勿恭敬　　此等诸比丘

尔时无垢施女。以偈报梵志言

  我若堕恶道　　父母诸眷属
  财宝及勇健　　尽所不能救
  除彼威德众　　谁能救我者
  敬佛法众故　　舍身及寿命
  除尊三宝已　　更无可依道

尔时梵志问无垢施女言。汝未曾见佛及僧。亦未曾闻法。何由有此信。无垢施女报梵志言。我初生七日时。处高殿上在金足床。见五百天子飞行虚空。以无量功德赞叹佛法僧。我时得闻。复有一天子。未曾见佛闻法及睹众僧。问诸天子言。佛者何似也。彼诸天子知我至心。并答一天子所问。为生喜悦故。而说偈言

  其发如绀青　　清净而右旋
  佛面如满月　　百叶莲花色
  毫相如珂雪　　右旋人乐观
  黑蜂绕青莲　　眉目亦如是
  颊车如师子　　眼眴如牛王
  唇如频婆果　　齿白密齐平
  其发如鹅行　　舌广而覆面
  畅音甚清净　　闻者皆欢喜
  孔雀鹅雁声　　音如琉璃琴
  紧那众铃声　　迦陵频伽音
  拘那罗鸟音　　命命拘吉罗
  及种种音乐　　佛声亦如是
  其吼如师子　　能破诸竞论
  除去诸垢恼　　实语断诸见
  处在于大众　　能尽诸问疑
  不谬而和柔　　悦可于众心
  去离于二边　　正说于中道
  恒说适意音　　闻音皆欢喜
  口行无谄曲　　随语各得解
  佛语慧庄严　　如杂妙花鬘
  项圆臂修直　　掌平轮相净
  手指纤长妙　　爪如赤铜色
  佛身坚平满　　细腰师子体
  深齐而圆好　　阴藏如马王
  其身如金山　　一孔一毛生
  右旋而上向　　其喻如龙象
  佣髀鹿[跳-兆+尃]肠　　踝平钩锁骨
  足平轮相现　　千辐具分明

梵志。尔时诸天子。在虚空中。以如此事赞叹如来。复次如来应供。度一切有。至于彼岸得大慈悲。如大医王护诸众生。憎爱不染如莲花在水。于世尊功德。我叹少分耳。梵志。我生适七日。闻世尊如是实功德。自尔已来恒无睡眠。亦无欲觉嗔恚觉恼觉。自是已来。我于父母兄弟姊妹亲属财宝璎珞衣服城邑园观及己身寿命。尽无恋爱之心。唯除念佛。如来在在处处。有所说法。系心往听悉皆受持。若文若义不失一句。梵志。我于日夜未尝不见诸佛世尊。梵志。我观佛无厌。听法无足。供众无倦。尔时无垢施女。如是种种赞佛法众。时梵天婆罗门等五百人。皆发阿耨多罗三藐三菩提心。时无垢施女即下车步。进诣诸菩萨声闻所。到已尽顶礼其足。以恭敬尊重心。诣大德舍利弗所。到已前立。谓舍利弗言。我是女人。智慧微浅多诸烦恼。又多放逸乐卑下事。为不顺思惟所牵。善哉大德舍利弗。为怜愍我故。说微妙法。我得闻已。长夜利益增长安乐。始论此事。王波斯匿来至其所。闻其所说。王命无垢施女言。汝诸快乐悉无所少。何为忧色而不睡眠。不乐世乐。时王波斯匿。即为其女。而说偈言

  端严如天女　　澡浴涂香服
  璎珞等具足　　何忧不睡眠
  国富多财宝　　父母得自由
  有何不可乐　　而不睡眠耶
  汝悦众亲意　　诸人悉敬望
  我种种庄严　　汝何为不乐
  汝见闻何事　　而怀此忧戚
  善哉何所愿　　汝语我此事

尔时无垢施女。以偈答父王言

  王不觉家中　　阴界入诸羸
  居世如幻妓　　人命无暂停
  饮毒谁能眠　　处死谁有欢
  坠岩何望活　　世相皆如是
  如人处蛇间　　何有睡与欲
  四大如毒蛇　　何有欢乐心
  为诸怨所绕　　如饥何有乐
  为诸怨国者　　父王何有乐
  自从见世尊　　发心愿成佛
  王我未见闻　　菩萨暂放逸

    声闻品第二

尔时无垢施女谓舍利弗言。大德。我欲少有所问。愿为解脱。以怜愍故。世尊记仁者。智慧中最为第一。此慧是有为耶。是无为耶。若是有为。虚诳非实法。若是无为。无为法者则无有生。无生之法则无有起。以无起故。大德智慧则无所有。舍利弗即便默然。大德目犍连谓舍利弗言。大德。何为不答无垢施女所问。舍利弗答目犍连言。此女不问有为之法。乃问第一义谛。第一义中则无言说。是故不可以言而答。时无垢施女谓目犍连言。世尊记大德。于神足人中最为第一。大德。乘神足时为众生想耶。为作法想耶。若住众生想者。众生无实。彼神足亦无实。若住法想者。法无变异。若无变异则无所得。若无所得则无分别。大德目犍连即便默然。摩诃迦叶谓目犍连言。大德。何为不答无垢施女所问。目犍连言。此女不问分别神足。诸如来菩提无作无分别。此则不可言说。时无垢施女谓摩诃迦叶言。世尊记大德。头陀人中最为第一。又复大德。怜愍众生故。入八解脱已而受施。乃至一念而受他施。以身报耶。以心报耶。若以身报。身性无记。喻如草木墙壁瓦砾等无异。是故不能必报施恩。若以心报。心念念不停。亦不能报。若除身心则无为法。若无为法谁能报者。摩诃迦叶即便默然。大德须菩提谓摩诃迦叶言。何为不答无垢施女所问。摩诃迦叶。答须菩提言。此女所问。问法真际。此理不可以言宣答。时无垢施女谓须菩提言。世尊记大德。于无诤人中最为第一。此无诤行。入有性耶。入如性耶。若入如性。如非生相如非灭相。若不生相若非灭相。则是平等。若是平等则是如尔。若是如尔则是无作。若是无作则无言说。若无言说则不可思议。若不可思议则不可宣表。若在有性。有性虚诳。若见虚诳。非圣所行。大德须菩提。即便默然。富楼那弥多罗尼子谓须菩提言。何不答无垢施女所问。须菩提答富楼那言。我于理不应有答。唯有默然是我乐处。此女所问问无戏论法。若有言说则生过患。法性无说是无诤行。时无垢施女谓富楼那言。世尊记大德。于说法人中最为第一。若说法时。说有境界法耶。无境界法耶。若说有境界法。则与凡夫等。所以者何。以凡夫说有境界法故。是以大德。不离凡夫法。若无境界则无所有。若无所有。何名说法人中最为第一。富楼那即便默然。大德离越谓富楼那言。大德。何为不答无垢施女所问。富楼那答离越言。此女不问有为。问第一义。第一义中则无言说。是故无理可答。时无垢施女谓离越言。世尊记大德。于行禅人中最为第一。大德禅时。依有心禅耶。无心禅耶。若依心入禅。心如幻化不实。此定亦复不实。若无心入禅。诸外法草木枝叶花果等亦应得禅。所以者何。以彼同无心故。大德离越即便默然。大德阿那律谓离越言。何不答无垢施女所问也。离越答阿那律言。此女所问诸佛行处。是非声闻所答。时无垢施女言。诸佛法声闻法有异耶。若是有异。无为有二耶。诸贤圣皆行无为。无为之法则无有生。若无有生则是无二。若是无二则是如尔。如尔无二。是故大德离越。何为作是说耶。时无垢施女谓阿那律言。世尊记大德。于诸天眼人中最为第一。大德。以天眼所见。为有物耶。为无物耶。若见有物则为见常。若见无物则为见断。若离二边则为无见。大德阿那律即便默然。大德阿难谓阿那律言。何为不答无垢施女所问。阿那律答阿难言。此女所问为坏假名。是故不可以假名而答。时无垢施女谓阿难言。世尊记大德。于多闻人中最为第一。此多闻法。为是实义耶。为是文字耶。若是实义。义不可说。若不可说法。则非耳识所知。若非耳识所知。复不可说。若以文字。世尊说言依于了义不依文字。是故大德阿难。亦非多闻亦非了义。大德阿难即便默然。文殊师利法王子谓大德阿难言。何为不答无垢施女所问也。阿难言。此女所问多闻离于文字。此则不可以音声而答。问于平等。平等非心。离心相故。此非学地人法。我何能答耶。此是诸如来法王至彼岸处

    菩萨品第三

尔时无垢施女谓文殊师利法王子言。世尊记汝。于深解菩萨中最为第一。汝为以十二因缘深为深耶。为以真深为深耶。若以十二因缘深为深。无有众生成十二因缘深者。所以者何。以十二因缘无来无去故。非眼识所知。非耳鼻舌身意识所知。此中十二因缘非是行法。若以真深为深。真深则非深。亦无得真深者。文殊师利答无垢施女言。以始际深故深。无垢施女问文殊师利言。始际则非际。是故汝知亦非知。文殊师利答无垢施女言。以无知得无得故。言始际耳。无垢施女问文殊师利言。无得之中无有言分。过言语道无有所说。文殊师利答无垢施女言。说假文字说耳。无垢施女语文殊师利言。诸佛菩提过字句言说。是故菩提则不可说。尔时无垢施女谓无痴见菩萨言。汝善男子作是言。我作是念。诣舍卫城。愿令城中众生必定应得阿耨多罗三藐三菩提者。其所见物尽是如来像。又令决定于阿耨多罗三藐三菩提。若见如来时。为色身观耶。为用法身观耶。若以色身观者则不见佛。如世尊说。若见我色身闻我音声者。彼人边见非为见我。若以法身法身不可见。所以者何。法身离见闻不可取故。是以不可见闻。时无痴见菩萨。即便默然。宝相菩萨谓无痴见菩萨言。善男子。何故不答无垢施女所问。无痴见菩萨言。无垢施女所问无性法。此无性法不可说。是故不答。无垢施女言。善男子。我不问无性法。无性法不可问。学已而答则无有碍。尔时无垢施女谓宝相菩萨言。善男子。汝言我当作是念。诣舍卫城。愿令城中一切种族居家。宝藏勇出具足七宝。汝施宝之心。为有染着耶。无染着耶。若有染着。则与凡愚同。所以者何。以凡夫有爱着故。若无爱着。无爱着中无有施宝。时宝相菩萨即便默然。时无垢施女谓离恶趣菩萨。善男子。汝言我作是念。诣舍卫城。愿令城中若有众生应堕恶趣者。尽使现世轻受速脱苦恼。如来说业不可思议。此不可思议业可速断耶。若可断者。则违如来所说。若不知云何而能轻受速断。若能断者。于无主法中汝则是主。若能断者亦当能不断。离恶趣菩萨答无垢施女言。我以愿力故能令轻受速断。无垢施女问离恶趣菩萨言。善男子。诸法如性。不可以愿力而受。时离恶趣菩萨即便默然。尔时无垢施女谓除诸盖菩萨。善男子。汝言我当作是念。愿令舍卫城中众生尽除五盖。汝作是念。入是定已能令众生不为五盖所覆。于此定中己自在耶。他自在耶。若己自在。无由及彼。一切诸法无至彼者。云何汝入禅定去他五盖。若他自在。则不能利益于他。除诸盖菩萨答无垢施女言。此行以慈为首。无垢施女问除诸盖菩萨言。诸佛皆行慈行。善男子。叵有佛因众生不以五盖为患者也。除诸盖菩萨即便默然。时无垢施女谓观世音菩萨。善男子。汝言我当作是念。愿令舍卫城中众生牢狱系闭速得解脱。临当死者即得济命。恐怖之者即得无畏。夫言畏者。是有取耶无取耶。若是有取者。凡愚之人亦复有取。是故不然。若是无取则无所施。无施法中何得有除。观世音菩萨即便默然。辩严菩萨谓观世音菩萨。善男子。何为不答无垢施女之所问耶。观世音菩萨言。此女不问生灭法。是故不可答。无垢施女问观世音菩萨言。叵有是无生无灭问耶。观世音答无垢施女曰。无生无灭中乃无文字言说。无垢施女问观世音言。诸智慧者。于无文字假说文字。然不著文字法性无碍。是故慧者不碍文字。时无垢施女谓辩严菩萨。善男子。汝言我当作是念。愿令舍卫城中众生其见我者皆得辞辩。以诸妙偈互相问答。善男子。汝此所施辞辩者。以觉起耶。若以觉起者。一切有为皆由觉观而起。是故非寂静。若以爱起者所施则虚。辩严菩萨答无垢施女言。此是我初发菩提心时。愿其见我者皆得辞辩。以诸妙偈互相问答。时无垢施女问辩严菩萨言。善男子。汝今即有发菩提心愿耶。若即有者则是常见。若今无者不可以施彼。是故所愿则虚。时辩严即便默然。尔时无垢施女谓无痴行菩萨。善男子。汝言我作是念。愿令舍卫城中若有众生其见我者。得无痴见。决定于阿耨多罗三藐三菩提。此菩提为是有耶。为是无耶。若是有者。是有为菩提执于边见。若是无者。则是虚妄亦堕边见。时无痴见菩萨答无垢施女言。此菩提者名之为智。无垢施女问无痴见菩萨言。此智名为生耶。为无生耶。若名为生则非是善顺思惟所生。是有为智凡愚所知。若名无生。无生中无所有。若无所有则无分别。菩萨声闻辟支佛诸如来菩提。无有分别。凡愚之人分别菩提。智慧之人则无分别。时无痴见菩萨即便默然。尔时大德须菩提谓诸大德声闻并诸大菩萨言。诸大德。我等宜还。不须入舍卫城乞食。所以者何。无垢施女所说即是智者法食。我等今日乐于法食。不须搏食。无垢施女问须菩提言。如说诸法无上无下。于此法中。当有何求而行乞耶。大德不戏论法是比丘所行。不可乐於戏论。此是无依之法。非依止者所行。贤圣所行无有退转。尔时八大声闻。八大菩萨。梵天等五百婆罗门。无垢施女。波斯匿王。及诸大众。俱诣佛所。到已顶礼佛足。右绕三匝却坐一面。无垢施女。别绕七匝。顶礼佛足。合掌而立。以偈问佛

  我问无等尊　　应供无量称
  施众甘露喜　　菩萨云何行
  云何在道树　　破魔降劳怨
  云何动天地　　山王及林薮
  云何放光明　　显发无量称
  愿大悲世尊　　说应菩提行
  云何得总持　　如来妙音声
  云何能修持　　清净妙胜定
  云何诸行人　　能得神足力
  今劝请世尊　　说诸人实行
  云何得专念　　及与坚固心
  云何得应辩　　微妙成具足
  云何得顺理　　含众义圆足
  美说微妙法　　慧者无所碍
  云何乐施慧　　净戒及忍辱
  善精进禅定　　智慧照世间
  云何忆宿命　　天眼明了见
  天耳他心智　　神足过诸刹
  云何不处胎　　化生莲花中
  恒于诸佛前　　说空无我法
  云何等怨亲　　断爱及荒秽
  志行无高下　　其犹如风地
  利衰及毁誉　　称讥与苦乐
  云何舍八法　　行世犹如日
  云何不谄诤　　除我舍憍慢
  寂静处禅定　　智者乐实义
  云何不爱乐　　妻子及财宝
  云何诸行人　　乐于闲静处
  云何如飞鸟　　亦如麟一角
  云何乐正法　　及乐喜悦心
  云何诸智人　　观地水火风
  无倾动分别　　处禅如虚空
  不行非法行　　不乐观他行
  宁舍于身命　　终不舍离法
  云何于菩提　　生想如世尊
  生世尊想已　　能发菩提愿
  云何得净土　　及与清净僧
  智者得长寿　　称名获安乐
  方便至彼岸　　见谛不取证
  能度无量众　　劝乐行善根
  云何得端正　　及得于化生
  智慧多财宝　　能知众生心
  云何忆宿命　　常与诸佛会
  于千万亿劫　　恒不生难处
  云何得种好　　及三十二相
  云何善辞辩　　及得于应辩
  云何修净土　　成就比丘众
  随所愿乐处　　能得生于彼
  导者作何行　　能得色名称
  得力精进等　　云何得不坏
  云何不犹豫　　能行菩萨道
  去离诸悼悔　　为众生说法
  于佛法众中　　云何得最胜
  宁舍己身命　　而不诽谤法
  世尊无不知　　今世及未来
  愿大智世尊　　次说菩萨行

    菩萨行品第四

尔时世尊。赞无垢施女言。善哉善哉。汝为多安乐利益诸众生故。怜愍世间诸天人故。问于如来诸菩萨摩诃萨如斯之行。谛听谛听善思念之。吾当为汝分别解说。时无垢施女。及诸大众皆称善哉。愿乐欲闻。尔时世尊。即便为说。菩萨成就四法能破诸魔。何等为四。于他利养不生憎嫉。去离两舌。劝多众生令种善根。于一切众生生慈愍心。无垢施女。是为菩萨成就四法能破诸魔。尔时世尊。欲重宣此义。而说偈言

  不生憎嫉心　　及以两舌语
  能教多众生　　种善法根栽
  能修广慈心　　普及于十方
  善行此行者　　能摧诸魔怨

无垢施女。若菩萨成就四法者。能放光明过无量佛土。何谓为四。能施灯明。法欲灭时护持正法。能为放逸及堕难处众生故。往其所而为说法。能以宝饰璎络施佛塔庙。是为菩萨成就四法能放光明过十方刹。尔时世尊。欲重宣此义。而说偈言

  若能施灯明　　法末中护法
  开导难放逸　　宝饰施佛庙
  是故诸菩萨　　能放净光明
  过无量佛土　　所照无边涯
  蒙光皆安乐　　即发无上心

无垢施女。若菩萨能成就四法者。能振动无量无边诸佛刹土。何谓为四。如所说行。得深法忍。坚持善法。化无量众生。行阿耨多罗三藐三菩提。是为菩萨成就四法。能震动无量无边诸佛刹土。尔时世尊。欲重明此义。而说偈言

  如所说修行　　善解深法忍
  欲得白净法　　坚持诸妙行
  能教无量众　　发于菩提心
  行此四法者　　能动无量刹

无垢施女。若菩萨成就四法者。得陀罗尼。何谓为四。能施净妙种种所须。庄严诸婇女须者便施与。常以种种法。赞叹诸如来。亲近多修习般若波罗蜜。是谓菩萨成就四法得诸陀罗尼。尔时世尊。欲重明此义。而说偈言

  若行种种施　　能得陀罗尼
  庄严好婇女　　随意之所须
  悉皆能充足　　常赞叹如来
  修诸实智慧　　世尊之所许
  以此四事者　　即得陀罗尼
  于百千亿劫　　所闻终不忘
  十方佛所说　　尽能受忆念

无垢施女。若菩萨成就四法者。能得三昧。何谓为四。多厌患生死。常乐闲静处。常勤精进。善能成就诸所作业。是为菩萨成就四法能得三昧。尔时世尊。欲重宣此义。而说偈言

  舍离诸有生　　独行如骐驎
  善男子勤行　　成就所作业
  慧者能成就　　此四胜妙法
  亲近于菩提　　求诸最胜法
  有寂静意者　　能得诸三昧
  觉了胜菩提　　诸佛之行处

无垢施女。若菩萨成就四法能得神足。何谓为四。身轻故。心轻故。于一切法中无依止故。受四界为空界故。是为菩萨成就四法能得神足。尔时世尊。欲重明此义。而说偈言

  身心轻亦尔　　智者不着法
  受此诸四界　　与空界同等
  具此四法者　　能得乘神足
  一念过亿刹　　供养尔所佛

无垢施女。若菩萨成就四法得殊妙端正。何谓为四。去诸荒秽不行嗔恚。乐净佛塔庙妙饰以供养。住威仪持戒。常先意问讯。不讥说法者恒生世尊想。是为菩萨成就四法得殊妙端正。尔时世尊。欲重宣此义。而说偈言

  不嗔恼他人　　去离荒秽行
  扫洒世尊庙　　恭敬献饰宝
  常持于净戒　　发意先问讯
  于法师无碍　　敬心如世尊
  行此四善事　　是谓勇健者
  殊妙最第一　　见者莫不欢

无垢施女。若菩萨成就四法能得化生。何谓为四。雕刻莲花。坐佛形像。以优钵罗花。钵头摩花。拘末头花。分陀利花。及余种种杂妙诸花。满掬以散如来及诸塔庙。志愿利益无量众生。恒行和敬不讥彼短。所种善根。为利益安乐多众生。脱生死苦恼。愿成阿耨多罗三藐三菩提故。是为菩萨成就四法能得化生。尔时世尊。欲重宣此义。而说偈言

  刻花坐尊像　　种种花供养
  利益不恼众　　化生诸佛刹
  恒发弘誓愿　　度十方众生
  以此四妙行　　恒生诸佛刹

无垢施女。若菩萨成就四法得大财富。何谓为四。乞者不逆。于所施物不生爱惜。恒愿众生获多财宝。舍离诸见。顺于正信。是为菩萨成就四法得大财富。尔时世尊。欲重明此义。而说偈言

  施心无所逆　　于财无吝惜
  信解诸佛法　　生生获财富
  信解无谄嫉　　不讼彼过患
  专心一向信　　是故得财宝

无垢施女。若菩萨成就四法得大智慧。何谓为四。于他法中。不生憎嫉。说除过法令无疑悔。勤精进者劝不令废。己身常乐多修空法。是为菩萨成就四法得大智慧。尔时世尊。欲重宣此义。而说偈言

  不嫉于正法　　教他除疑悔
  常将导众生　　修佛诸空行
  智者乐此法　　得智慧名称
  善解诸佛语　　速成两足尊

无垢施女。若菩萨成就四法忆识宿命。何谓为四。学问诵习有所忘失者。为作忆念忘者为说。恒出适意好声令人乐闻。常行法施不令有废。为脱生死。趣向泥洹故。愿如善财入禅方便。是为菩萨成就四法能忆宿命。尔时世尊。欲重宣此义。而说偈言

  废忘令忆念　　恒出适意音
  说法不疲倦　　常修诸定相
  以此四法者　　咸得识宿命
  能忆无量劫　　速悟佛行处

无垢施女。若菩萨成就四法常遇诸佛。何谓为四。宁舍身命不诽谤法。宁舍身命不谤菩萨。宁舍身命不亲近恶知识。忆念诸佛无有厌足。是为菩萨成就四法常遇诸佛。尔时世尊。欲重宣此义。而说偈言

  不谤于菩提　　亦不毁菩萨
  乐离恶知识　　念诸佛无厌
  大德行此行　　得值遇诸佛
  未成正觉顷　　恒与诸佛会

无垢施女。若菩萨成就四法得三十二相身。何谓为四。采诸珍宝散佛塔庙。以种种香油涂塔基座。以杂花鬘严饰塔庙。以种种伎乐。而以供养。常给侍贤圣初不违离。是为菩萨成就四法得三十二相。尔时世尊。欲重宣此义。而说偈言

  采宝散塔庙　　又以香油涂
  杂花众伎乐　　给侍适贤圣
  具相庄严身　　端妙殊特好
  以此得众相　　以严人中尊

无垢施女。若菩萨成就四法得八十随形好。何谓为四。脱众妙衣以敷法座。给侍一切终无疲厌。诣说法处无胜论心。恭敬大众但生世尊想。劝多众生发菩提心。是为菩萨成就四法得八十随形好。尔时世尊。欲重宣此义。而说偈言

  敷座众妙衣　　供养无疲厌
  不与持法竞　　劝众发道心
  能行此法者　　速得成众好
  菩萨亲近行　　具好八十种

无垢施女。若菩萨成就四法得善应辩。何谓为四。受持亲近菩萨法藏。昼夜六时诵三阴经。诸佛菩提无生无灭。世所难信。然能受持读诵。广为他说令得喜悦。不爱身命。是为菩萨成就四法得善应辩。尔时世尊。欲重宣此义。而说偈言

  护持菩萨藏　　勇猛诵三阴
  无生世相追　　方便说令喜
  不爱于身命　　持十力正法
  无疑虑而行　　最上胜菩提
  修此甚深法　　便能得应辩
  譬如杂花鬘　　天人所乐见

无垢施女。若菩萨成就四法得清净土。何谓为四。不嫉妒故。等心故。护菩提行故。不亲近四部众故。是为菩萨成就四法得清净土。尔时世尊。欲重宣此义。而说偈言

  不嫉于他人　　见彼得利喜
  等心行大慈　　化众无染着
  行此四无量　　智者善守护
  得净土无难　　速成无上道

无垢施女。若菩萨成就四法得清净众。何谓为四。不悕望他徒众故。不和合者摄令和解。学问诵习者给其所须。舍离两舌。是为菩萨成就四法得清净众。尔时世尊。欲重宣此义。而说偈言

  终不望他众　　离者能令合
  给学人所乏　　不离别众生
  能行此四事　　便得清净众
  为清众故行　　极苦亦不舍

无垢施女。若菩萨成就四法。所愿佛土随愿得生。何谓为四。于他名誉利养法中。不生憎嫉。专心修习六波罗蜜。于一切菩萨生世尊想。从初发心乃至道场常等心观。终不为利养名誉谄曲虚赞故。是为菩萨成就四法随所愿土即得往生。尔时世尊。欲重宣此义。而说偈言

  不憎他名利　　求清净六度
  等尊观菩萨　　终不谄求名
  菩萨行此善　　能见十方界
  随心之所愿　　即得生其中

尔时无垢施女。白佛言。世尊。如所说菩萨行。我当奉行之。如世尊所说。诸菩萨行。于此法中不行一法。则为欺诳十方现在说法诸佛。尔时大德目连。谓无垢施女言。汝敢于佛前大师子吼。菩萨难行岂不知耶。终不以女身而得阿耨多罗三藐三菩提。尔时无垢施女。答大德目连言。我今佛前作诚实愿。若于来世。必得成佛如来无所著等正觉乃至佛世尊天人师。以此诚实之愿。使此三千大千世界六变震动。于诸众生令无恼乱。如世尊所说。诸菩萨行。我尽形行者。以此实愿。于虚空中雨众天花。百千伎乐不鼓而鸣。使我变此女身。成十六童子。无垢施女。发此诚实愿已。即时三千大千世界六变震动。于虚空中雨众天花。百千天乐不鼓自鸣。无垢施女。即变女身成十六童子。时大德目连偏袒右肩右膝着地。合掌向佛而白佛言。世尊。我今面礼诸佛菩萨。从初发意乃至道场。世尊。此女人乃有如是大威德神足力。能发大愿。既发愿已随愿皆成。佛告目连。如是如是。如汝所言。菩萨从初发意乃至道场。天人所礼如佛塔庙。是诸声闻辟支佛无上福田。于时世尊。熙怡微笑。诸佛常法若微笑时。口中即出青黄赤白紫颇黎等种种色光。照于无量无边诸佛刹土。诸天魔宫日月精光皆不复明。还摄光明从顶上入。尔时大德阿难。即从坐起。更正衣服。偏袒右肩右膝着地。合掌向佛。以偈问曰

  天龙梵音师子吼　　迦陵频伽雷震声
  除贪嗔痴生喜悦　　愿十力海说笑缘
  六变震动无所娆　　雨天妙花悦众情
  世尊摧伏诸外道　　犹如师子伏野干
  唯愿世尊为我说　　所以微笑之因缘
  万亿日月珠电光　　天龙梵王诸光明
  释迦口出净光明　　遏诸光明佛光胜
  眉间毫相如珂月　　圆满柔软喻天衣
  白毫放光照无量　　愿说何故放斯光
  世尊齿净无垢秽　　方平齐密白如雪
  佛口应出杂色光　　青黄赤白紫颇黎
  假使界坏日月落　　地满虚空无居处
  水性可使变为火　　火性亦可变为水
  大海尽可令枯竭　　如来实语终不二
  生十方趣诸众生　　假令一时成缘觉
  一一缘觉集诸问　　百千万种经亿劫
  尽共集会如来前　　各以异音同时问
  如来即以一音报　　能断彼众无量疑
  成就智慧至彼岸　　一切智慧所庄严
  具三十二最胜尊　　大威德者愿解说
  世尊何缘而微笑　　授何众生菩提记
  诸天世人咸欲闻　　愿如来演微笑音

尔时佛告阿难。汝见是无垢施菩萨以诚实之愿动此三千大千世界不耶。阿难白佛言。世尊。唯然已见。佛言。此无垢施菩萨。发心已来八万阿僧祇劫。行阿耨多罗三藐三菩提行。此无垢施菩萨修菩萨行经六十劫。然后文殊师利法王子。乃发菩萨心。阿难如文殊师利等八万六千诸大菩萨所有功德庄严佛土。与尔所菩萨等无有异。尔时大德目连。谓无垢施菩萨言。善男子。汝已久发阿耨多罗三藐三菩提心。何以不转女人身也。无垢施菩萨。答目连言。世尊记大德。于神足人中最为第一。何为不转男子身也。大德目连。即便默然。无垢施菩萨。谓大德目连言。亦不以女身得阿耨多罗三藐三菩提。亦不以男身得阿耨多罗三藐三菩提。所以者何。菩提无生。是以不可得

    授记品第五

尔时文殊师利法王子白佛言。未曾有也。世尊。此无垢施菩萨。乃能善解甚深之法。以誓愿力成就诸愿。佛告文殊师利言。如是如是。如汝所言。此无垢施菩萨。曾于六十亿佛所。修空三昧。于八十亿佛所。修无生法忍。于三十亿佛所。问甚深法。曾以衣服饮食。供养八十亿诸佛。及问此分别辩印三昧。又文殊师利。若有善男子善女人。为菩提故。如恒河沙等诸佛刹土。满中珍宝持用布施。不如受持此经读诵通利广为人说。乃至但书持功德最上最胜。况如说修行。所以者何。以能受持诸菩萨菩提行法故。文殊师利白佛言。世尊。当何名斯经。云何奉持之。佛告文殊师利。当名为分别说应辩。亦名说三昧门。当如是奉持之。佛说是经时。八万亿众生诸天及人。皆发阿耨多罗三藐三菩提心。必定不退转。尔时辩严菩萨白佛言。世尊。此无垢施菩萨。何时当成阿耨多罗三藐三菩提。佛告辩严。善男子。此无垢施菩萨。过于数劫。供养过数佛已。当得成佛。号无垢光相王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界号曰无量德庄严。无声闻辟支佛。微妙严饰胜诸天处。无垢施菩萨。亲从如来闻受记名。心净踊跃。踊在虚空高八十亿多罗树。放大光明。照百千亿诸佛刹土。当世尊顶上。化作八万四千种种天宝庄严殊妙宝盖。即于空中以无量神足力。供养礼拜无量十方诸佛已。还至佛所。在一面立。尔时婆罗门梵天。及五百婆罗门。闻授无垢施菩萨记。及见神足变现。踊跃欢喜。一时同声。以偈赞佛

  能恭敬佛者　　得世第一利
  发心求菩提　　为佛第一智
  我等昔造恶　　今生邪见家
  得见佛及僧　　发口出恶言
  我今诚心悔　　恶口所犯罪
  见诸贤佛子　　谓为是不吉
  若不见如来　　两足中最尊
  唐受此人身　　唐食人所食
  我及无垢施　　出为祀祠故
  施女见佛子　　敬重而赞叹
  我等见赞叹　　即呵其可叹
  我等即问之　　汝曾见佛耶
  于时答我言　　我生适七日
  闻天叹佛名　　女赞叹如来
  真实无差异　　我等闻叹已
  即发最胜心　　求无上善根
  我闻佛名故　　于宿业得悟
  即来礼救世　　为求胜法故
  见佛礼敬心　　闻最无上法
  见人中尊仙　　永离诸苦际
  佛之所说法　　真实能度世
  我等于中学　　为无上法故
  闻菩萨所行　　为得佛法故
  我等亦应习　　为得佛道故
  说出要道门　　菩萨所应行
  我亦趣此门　　为世所敬礼
  佛知彼诚心　　熙怡而微笑
  阿难即白佛　　愿说笑因缘

尔时佛以偈。告阿难曰

  此诸婆罗门　　及梵志梵天
  同共一劫中　　次第成正觉
  曾于过去世　　具供五百佛
  从今以妙行　　当见亿数佛
  于八十亿劫　　终不堕难处
  于一一劫中　　当觐亿数佛
  然后乃当成　　最胜两足尊
  皆当同一号　　号曰梵光明
  寿命亦同等　　寿八十亿岁
  刹土皆同等　　各八十亿僧
  化度无量众　　利益众生已
  当入于泥洹　　证寂静灭度

佛说经已。无垢施菩萨摩诃萨。及诸大众梵天梵志等。五百菩萨大士。波斯匿王。诸大声闻弟子。诸天八部。人及非人。闻佛所说。皆大欢喜

大宝积经卷第一百大宝积经卷第一百一

        大唐三藏菩提流志奉　诏译

    功德宝花敷菩萨会第三十四

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众千二百五十人俱。复有无量诸菩萨众。尔时会中。有菩萨名开敷功德宝花。即从座起偏袒右肩。右膝着地合掌向佛。而作是言。世尊。我于如来。欲有咨问唯愿哀愍见垂听许。佛告功德花菩萨言。善男子。恣汝所问当为汝说。尔时功德花菩萨。白佛言世尊。十方世界。颇有现在诸佛如来。若善男子善女人等。受持名号。速能证得阿耨多罗三藐三菩提不。佛言。善哉善哉。功德花。汝今为欲利益安乐天人世间及未来世诸菩萨等。问于如来如是之义。谛听谛听。善思念之。当为汝说。功德花言。唯然世尊。愿乐欲闻

尔时佛告功德花菩萨言。善男子。东方有世界。名一切法功德庄严。劫名普集一切利益。彼现有佛。号无量功德宝庄严威德王如来。寿命无数。其佛众会无量无边。皆是清净诸大菩萨。若有净信善男子善女人。受持彼佛名者。即能灭除六十千劫生死之罪。转身得陀罗尼。名为乐说无碍。凡所说法。常为十俱胝刹诸佛世尊。授以辩才令得无畏。尔时世尊。而说偈言

  若人受持彼佛名　　当获如是诸功德
  亦能成就余胜法　　速证无上佛菩提

复次功德花。南方有世界名功德宝庄严。劫名广大功德。彼现有佛。号功德宝胜庄严威德王如来。若有净信善男子善女人。受持彼佛名者。转身当得日轮光明遍照三昧。于诸佛刹随愿往生。亦当摄受无量功德庄严佛土。生彼刹已。具三十二相。获无断辩才。转身当得阿耨多罗三藐三菩提。尔时世尊。而说偈言

  若人受持彼佛名　　转身当得难思定
  三十二相以庄严　　一生当证菩提果

复次功德花。西方有世界名离一切忧闇。劫名能胜王。彼现有佛。号一切法殊胜辩才庄严如来。若有净信善男子善女人。受持彼佛名者。毒不能害刀不能伤。火不能烧水不能溺。舍此身已当受化生。获陀罗尼名为百旋。尔时世尊。而说偈言

  若人受持彼佛名　　水火刀毒无能害
  转身当受化生报　　成就百旋陀罗尼

复次功德花。北方有世界名离尘闇。劫名持大名称。彼现有佛。号积集无量辩才智慧如来。若有净信善男子善女人。受持彼佛名者。则为奉事六十俱胝那由他佛。得遍一切处陀罗尼。无尽藏陀罗尼。乃至未成无上菩提。终不更入三恶趣中。常得往生诸佛刹土。修菩萨行。度脱无量恶趣众生。当于阿耨多罗三藐三菩提得不退转。尔时世尊。而说偈言

  若人受持彼佛名　　所获功德无有边
  决定当得陀罗尼　　成就无上菩提果

复次功德花。东南方有世界名胜妙庄严。劫名出生功德。彼现有佛。号千云雷吼声王如来。若有净信善男子善女人。受持彼佛名者。转身得佛四无所畏。四种神足。大慈大悲。十八不共法。所得国土功德庄严。亦如西方极乐世界。无有异也。若有女人能受持者。皆悉转为丈夫之身。尔时世尊。而说偈言

  若人受持彼佛名　　获不思议胜功德
  彼常见于无量佛　　女人当得丈夫身

复次功德花。西南方有世界名无量庄严。劫名能生妙法。彼现有佛。号最上妙色殊胜光明如来。若有净信善男子善女人。受持彼佛名者。则为奉事九十俱胝诸佛如来。得度脱一切众生三昧。何故名为度脱一切众生三昧。若善男子善女人。依此三昧演说法时。能令三千大千世界之中。恶趣众生悉皆解脱。得生人天普获安乐。决定当得阿耨多罗三藐三菩提。犹如悦意如来刹中。所有众生常受安乐。尔时世尊。而说偈言

  若人受持彼佛名　　所生常具大威德
  诸根色力皆殊胜　　智慧无边无所著

复次功德花。西北方有世界名为离垢。劫名广族。彼现有佛。号种种胜光明威德王如来。若有净信善男子善女人。受持彼佛名者。转身得无量辩才庄严陀罗尼。悉能受持八十俱胝如来所说之法。所得国土功德庄严。亦如西方极乐世界。无有异也。尔时世尊。而说偈言

  若人受持彼佛名　　国土犹如无量寿
  成就甚深诸法智　　一生当证佛菩提

复次功德花。东北方有世界名曰无忧。劫名辩才庄严。彼现有佛。号无数劫积集菩提如来。若有净信善男子善女人。受持彼佛名者。即为供养八十俱胝诸佛世尊。转身具足六十种言音辩才。尔时世尊。而说偈言

  若人受持彼佛名　　智慧无边到彼岸
  如供八十俱胝佛　　转生当证妙辩才

复次功德花。上方有世界。名无量功德庄严威德。劫名无量吼声。彼现有佛。号虚空吼声净妙庄严光明照如来。若有净信善男子善女人。受持彼佛名者。所生之处。种族尊豪识性聪慧。善能通达世俗文词。凡所发言人皆信受。于诸地中。具足清净戒定智慧及于解脱知见。获宿命智得五神通。亦当得佛十八不共速成阿耨多罗三藐三菩提。尔时世尊。而说偈言

  若人受持彼佛名　　所生未曾离诸佛
  具足八种梵音声　　速证无上菩提果

复次功德花。下方有世界名种种音声。劫名积集智慧。彼现有佛。号一切法门神变威德光明照耀如来。若有净信善男子善女人。受持彼佛名者。转身得陀罗尼。名成就正觉。当能受持九十俱胝诸佛如来所说之法。一生当得阿耨多罗三藐三菩提。尔时世尊。而说偈言

  若人受持彼佛名　　得成正觉陀罗尼
  受持无量诸佛法　　一生当证大菩提

尔时开敷功德宝花菩萨。及一切功德辩才音菩萨。得陀罗尼门。八万俱胝菩萨。皆悉趣向无上菩提。得不退转。三那由他诸天及人。发阿耨多罗三藐三菩提心。佛说此经已。功德花菩萨。及一切世间天人。阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

    大宝积经善德天子会第三十五

        大唐三藏菩提流志奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众一千人俱。菩萨摩诃萨十千人。并欲色界诸天子等。是时文殊师利菩萨摩诃萨。与善德天子俱在会中。尔时世尊。告文殊师利。汝当为此诸天大众及诸菩萨。演说诸佛甚深境界。文殊师利白佛言。唯然世尊。若善男子善女人。欲知佛境界者。当知非眼耳鼻舌身意境界。非色声香味触法境界。世尊。非境界是佛境界。以是义故。如佛所得阿耨多罗三藐三菩提。为何境界耶。佛言。空境界。诸见平等故。无相境界。一切相平等故。无愿境界。三界平等故。无作境界。有作平等故。无为境界。有为平等故。文殊师利言。世尊。何等是无为境界。佛言。无念是无为境界。文殊师利言。世尊。若无为等是佛境界。为无念者。依何而说。无所依故。则无所说。无所说故。则不可说。世尊。诸佛境界不可说也。佛言文殊师利。佛境界当于何求。曰于一切众生烦恼中求。何以故。众生烦恼性不可得。非声闻缘觉之所能知。是则名为诸佛境界。佛言文殊师利。佛境界有增减耶。曰无增减也。佛言。云何了知一切众生烦恼本性。曰如佛境界无有增减。烦恼本性亦无增减。佛言。云何名为烦恼本性。曰烦恼本性是佛界本性。世尊。若烦恼性异佛境界。则不说佛住一切法平等性中。以烦恼性即佛界性故。说如来住平等性。又问汝见如来住何平等。曰如我所解。众生现行贪嗔痴者。所住平等为如来住。佛言。众生现行三毒烦恼。住何平等。答曰住空无相无愿平等性中。佛言文殊。彼性空中。云何复有贪嗔痴耶。文殊师利言。于彼有中。有性空处。有贪嗔痴。佛言。于何有中说有性空。曰于文字语言中。说有性空。有性空故。有贪嗔痴。如佛所说诸比丘。有无生无为无作无起。若无生无为无作无起不有者。亦不可说有生有为有作有起。是故比丘。以有无生及无所起。由此得说有生有起。如是世尊。若无性空无相无愿。则不可说贪嗔痴等一切诸见。佛言文殊师利。以是义故。如汝所说。住烦恼者。是住性空。文殊师利言。世尊。若观行者。离于烦恼而求性空。则不相应。云何别有性空异于烦恼。若观烦恼即是性空。为正修行。佛言文殊师利。汝住烦恼离烦恼耶。文殊师利言。所有烦恼悉皆平等。如是平等。我正修行入此平等。则不离烦恼不住烦恼。若沙门婆罗门。自谓离欲见他烦恼。彼随二见。云何二见。谓有烦恼名为常见。谓无烦恼名为断见。世尊。正修行者。不见自他有无之相。何以故。明了一切法故。佛言文殊师利。依何正修行。曰正修行者为无所依。佛言。不依于道而修行耶。曰若有所依而修行者。则是有为。若行有为则非平等。所以者何。不离生住坏故。佛言文殊师利。无为中颇有数耶。文殊师利言。世尊。若无为有数即是有为非谓无为。佛言。若圣者得证无为。则有此法。宁无数耶。曰法无数故。圣远离数。为无数也。佛言文殊汝证圣法为不证耶。文殊师利言。世尊。若问化人。汝证圣法为不证者。彼云何答。佛言文殊。夫化人者。则不可说有证非证。文殊师利言。佛岂不说一切诸法皆如化耶。佛言。如是如是。曰若一切法皆如化者。云何问言。汝证圣法为不证也。佛言文殊。汝于三乘证何平等。曰佛界平等。我如是证。佛言。汝得佛境界耶。曰若世尊得者我亦当得。尔时尊者须菩提。语文殊师利言。如来不得佛境界耶。文殊师利言。汝于声闻境界有所得耶。须菩提言。圣者解脱非得非不得。曰如是如是。如来解脱亦非有境界。非无境界。须菩提言。文殊师利。汝不将护新发意菩萨。而演说法。文殊师利言。须菩提。于意云何。若有医人将护病者。不与辛酸苦涩等药。而彼医人于彼病者。为与其差为与死耶。须菩提言。是与死苦。非施安乐。文殊师利言。其说法者亦复如是。若将护于他。恐生惊怖。隐覆如是甚深之义。但以杂句绮饰文辞。而为演说。则授众生老病死苦。不与无病安乐涅槃。说此法时。五百比丘。不受诸法漏尽意解。八千天人远尘离垢。于诸法中得法眼净。七百天子。发阿耨多罗三藐三菩提心。作是愿言。我等于未来世。当如文殊师利得是辩才

尔时长老须菩提语文殊师利言。汝岂不以声闻乘法为声闻说耶。曰一切乘法是我所乘。须菩提言。汝为是声闻为辟支佛。为应正等觉耶。曰我为声闻。不因他声而生解故。我为辟支佛。不舍大悲无所畏故。我为应正等觉不舍本愿故。须菩提言。汝云何作声闻。曰彼诸众生未曾闻法。令得闻故我为声闻。又问汝云何为辟支佛。曰众生法界令信令觉。是故说我为辟支佛。又问汝云何为应正等觉。曰一切诸法法界平等如是了知。是故我为应正等觉。须菩提言。文殊师利。汝决定为住何地。曰住一切地。须菩提言。汝岂亦住凡夫地耶。文殊师利言。我亦决定住凡夫地。须菩提言。汝何密意作是说乎。曰一切诸法自性平等。故说如是。须菩提言。若一切法皆悉平等。当于何所建立诸法。此声闻地辟支佛地。菩萨佛地耶。文殊师利言。譬如十方虚空界中。说言此是东方虚空。南西北方四维上下。亦如是说。如是言说种种差别。非于虚空而有异也。是故仁者。依一切法毕竟空中。建立种种诸地之相。亦非空性而有差别。须菩提言。文殊师利。汝已证入正性离生耶。曰我已证入。而亦复出。须菩提言。云何证入而复还出。文殊师利言。仁者当知。此是菩萨智慧方便。于正性离生。如实证入。方便而出。须菩提。譬如有人善于射术。有一怨敌念欲害之。射师有子怜爱甚重。时彼爱子在旷野中。其父谬谓是所怨仇。放箭射之。子便大唤言。我无咎何为见害。时彼射师。有速疾力。急往子所。却取其箭。菩萨亦复如是。为调伏声闻辟支佛。故入正位还于彼出。不堕声闻辟支佛地。以是义故名为佛地。须菩提言。云何菩萨而得此地。文殊师利言。若诸菩萨住一切地而无所住为得此地。若一切地悉能演说。而不住于下劣之地。为得此地。若有修行。为尽一切众生烦恼。而法界无尽。虽住无为而行有为。于生死中如园观想。不求涅槃。为得此地。所有志愿悉令圆满。得无我忍成熟众生。为得此地。得佛智慧而不于彼无智人所生嗔恨心。为得此地。为求法者转于法轮。而于法界亦无差别。如是修行为得此地。复次若诸菩萨。摧伏魔怨而现作四魔。为得此地。须菩提言。文殊师利。此菩萨行一切世间甚为难信。文殊师利言。如是如是。如汝所说。是诸菩萨行于世间超过世法。须菩提言。文殊师利。当为说此超过世间。文殊师利言。夫世间者名为五蕴。于此蕴中。色聚沫性。受水泡性。想阳焰性。行芭蕉性。识幻性。如是当知世间本性。聚沫阳焰。泡幻芭蕉。是中无蕴无蕴名字。无众生无众生名字。无世间超过世间。若于五蕴如是正知名为胜解。若正胜解则本来解脱。若本来解脱则不着世法。若不着世法则超过世间。复次须菩提。五蕴本性空。若本性空则无我我所。若无我我所是则无二。若本无二则无取舍。无取舍故则无所著。无所著故则超过世间。复次须菩提。是五蕴者属于因缘若属因缘。则不属我不属众生。若不属我不属众生是则无主。无主则无取。无取则无诤。无诤论者是沙门法。如手画空无有触碍。修行如是空平等性超过世间。复次须菩提。五蕴法界同入法界。是则无界。若是无界则无地界水火风界。无我无众生无寿命。无欲界及色无色界。无有为无为生死涅槃界。入是界已则与世间俱而无所住。若无所住则超过世间。说此超过世间法时。二百比丘。不受诸法漏尽意解。各各脱郁多罗僧衣。以覆文殊师利。作如是言。若不于此法门生信解者。彼无所得亦无所证

尔时须菩提告彼诸比丘言。长老汝等少有所得有所证耶。诸比丘言。若增上慢者。则可说言有得有证。无增上慢沙门法者。无得无证。彼于何处生此动念。而自谓言。我如是得我如是证。若于其中有动念者则是魔业。须菩提言。长老如汝所解。何得何证作是说乎。诸比丘言。唯佛世尊。及文殊师利。知我所得。知我所证大德。如我所解。若不了知苦相。作是说言苦我应知。为增上慢。如是集应断。灭应证。道应修。为增上慢。彼不了知苦集灭道相故。作是说言。乃至道我已修。为增上慢。云何苦相。谓无生相。如是集灭道相。若无生相。即是无相无所得。于其中无有少苦可知。集可断。灭可证。道可修。若于此说圣谛义中。不惊不怖不畏者。非增上慢。若生惊怖为增上慢

尔时世尊赞彼诸比丘言。善哉善哉。告须菩提。此等比丘于迦叶佛法中曾闻文殊师利演说如是甚深之法。此等比丘往昔修行是深法故。今闻随顺速能了知。如是次第于我法中。闻是深法生信解者。一切当于弥勒法中得入众数

尔时善德天子白文殊师利言。仁者于此阎浮提中数数说法。我等愿请仁者往兜率陀天。彼诸天子亦有久殖广大善根。彼若闻法则应解了。以着乐故。不能来至佛所听法。而自损减。尔时文殊师利即现神变。令善德天子及一切众会。皆悉自谓入兜率陀天宫。见彼园林。宫殿楼观。栏楯窗牖。间错庄严。其诸宝台。层级高广至二十重。众宝网幔天花遍布。异类众鸟翔集和鸣。于虚空中有诸天女散曼陀罗花。歌咏赞叹游戏快乐。善德天子见是事已。白文殊师利言。希有文殊。云何我等如是速疾已到兜率陀天宫见此园林及诸天众。文殊师利愿为说法

尔时长老须菩提告善德言。天子。汝不离会中而往余处。是文殊师利神通变化。令汝自见入兜率天宫

尔时善德天子白佛言。希有世尊。文殊师利游戏三昧神通变化。于一刹那中示现此会悉入兜率天宫。佛言天子。汝于文殊师利神通变化。岂是见耶。如我所知。文殊师利。若欲以恒河沙等诸佛刹土功德庄严集一佛国。悉皆能现。或以指端举恒河沙诸佛刹土。过于上方如恒河沙诸佛土已置于虚空。又诸佛刹所有四大海水入一毛孔。水性众生亦不迫迮。而皆自见不离海中。所有世界诸须弥山王。皆悉置于芥子之内。依须弥住诸天子等。而皆自谓在其本宫。又诸佛刹所有五道众生悉皆安置于其掌中。众妙资具。犹如一切乐庄严国。咸令得见。又诸世界所有火聚。悉皆安置一兜罗中。复次诸佛世界所有日月。于一毛孔悉能覆蔽。随应所作咸皆作之

尔时恶魔化作比丘白佛言。世尊。我等欲见文殊师利。现前作此神通变化。何用如此虚诞之言。一切世间所不能信。尔时世尊告文殊师利言。汝当于此众会示现神变。尔时文殊师利。不起于座。入心自在一切法庄严三昧。于时如佛所说。神通变化皆悉示现。魔与众会及善德天子一切皆见。尔时大众见此神变叹未曾有。作如是言。善哉善哉。由佛出现有此正士。于世间中开是法门现诸神变。尔时恶魔以文殊师利威神力故。作如是言。希有世尊。文殊师利有此神通。今此众会亦为希有。于文殊师利神通变化而得信解。世尊。设有如恒河沙等诸魔。不能于此信解。善男子善女人。而作留难。我亦恶魔波旬。恒求佛便恼乱众生。我从今往自立誓愿。若于此法门流行之处。有生信解爱乐受持读诵演说。于四面百由旬外。不于中过。世尊。然我眷属。有欲断灭如来法故。令修行者其心散乱。我为降伏说陀罗尼。若善男子善女人。于此法门书写读诵为人演说。诸天魔众当得善利。令说法者。身心悦豫精勤修习。与无碍辩才。及陀罗尼。承事供给。衣服饮食卧具汤药。令无所乏。即说咒曰

怛侄他(一)阿末丽(二)毗末丽(三)替哆低(四)阿羯椑(五)是多设堵噜(六)誓曳杜野筏低(七)部多筏低伽米丽(八)[口*肩]低(九)苏普低(十)普普细(十一)地唎苏溪(十二)[怡-台+胃]提(十三)可诣(十四)米洗礼(十五)央矩丽跋丽(十六)呼卢忽[黍-禾+利](十七)索醯(十八)输戍米提地唎(十九)阿那筏低底底使咤泥(二十)吃唎多唎低(二十一)吃利多费低(二十二)[月*已]卢遮都费低漫怛啰悖驰那驰[口*路]迦(二十三)阿(去声)跋罗目多[目*壹]嚩苏唎耶(二十四)

世尊。若善男子善女人。专精受持此陀罗尼心不散乱。常为诸天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等之所守护。一切恶鬼无能得便。彼魔波旬说此咒时。三千大千世界六种震动。尔时世尊告魔波旬。善哉善哉。汝之辩才。当知是文殊师利神通境界。于是文殊师利现神通力。及魔波旬说咒之时。三万二千天人。发阿耨多罗三藐三菩提心。时文殊师利还摄神力。令此众会皆悉自见如本而住。尔时文殊师利告善德天子言。善男子。汝往兜率陀天遍告天众。我当来彼。时善德天子闻是语已。礼世尊足。并诸菩萨大德声闻。与其眷属恭敬围绕。于众会前忽然不现。须臾已至兜率陀天。尔时善德遍告诸天子言。汝等应知文殊师利怜愍汝故欲来至此。汝等应当舍诸欲乐。远离憍慢。恭敬尊重随顺听法。尔时善德天子。如所应办庄严道场。即便合掌作如是言。文殊师利。今正是时。于是文殊师利与一万菩萨五百声闻及天龙夜叉乾闼婆等。前后围绕。礼佛足已。于会中没现兜率陀天。与诸菩萨声闻大众。于彼道场随敷而坐。时诸大众悉闻四天王宫。三十三天。夜摩兜率及以化乐。他化自在诸天子等。魔众梵众。乃至有顶互相唱言。文殊师利今在兜率陀天方欲说法。诸天闻已。无数百千皆来集会。尽此欲界天宫所不容受。时文殊师利即以神力。令彼诸天自见宽广不相妨碍。尔时善德天子白文殊师利言。大众已集愿为说法。文殊师利告善德天子言。有四种法。菩萨住于不放逸者。则能摄取一切佛法。何等为四。一者住于戒律而具多闻。二者住于禅定而行智慧。三者住于神通而起大智。四者住于寂静而常观察。天子有八种法入于戒律。何等为八。一者身清净。二者语清净。三者意清净。四者见清净。五者头陀功德清净。六者命清净。七者舍离一切诈现异相以利求利清净。八者不舍一切智心清净。是名八法入于戒律。天子复有八法入于多闻。何等为八。一者尊重。二者下心。三者发起精进。四者不失正念。五者随闻受持。六者心善观察。七者如闻转教。八者不自赞毁他。是名八法入于多闻。天子复有八法。入于禅定。何等为八。一者寂静住阿兰若。二者舍离愦闹。三者不染境界。四者身心轻安。五者心缘定境。六者绝诸声相。七者减食支身。八者不取圣乐。是名八法入于禅定。天子复有八法入于智慧。何等为八。一者蕴善巧。二者界善巧。三者处善巧。四者缘起善巧。五者谛善巧。六者三世善巧。七者一切乘善巧。八者一切佛法善巧。是名八法入于智慧。天子。复有八法入于神通。何等为八。一者天眼通。见无障碍故。二者天耳通。闻无障碍故。三者他心通。观一切众生心故。四者宿命通。忆念前际故。五者神足通。示现一切神变故。六者漏尽通。尽一切众生漏故。七者不住烦恼不取解脱。方便力故。八者不依声闻解脱而入涅槃。是名八法入于神通。复有八法能入于智。何等为八。一者苦智。二者集智。三者灭智。四者道智。五者因智。六者缘智。七者三世智。八者一切智。是名八种。复有八法入于寂静。何等为八。一者内寂静。二者外寂静。三者爱寂静。四者取寂静。五者有寂静。六者生寂静。七者一切烦恼寂静。八者三界寂静。是名八法。复有八法入于观察。何等为八。一者戒。二者闻。三者禅定。四者智慧。五者神通。六者智。七者寂灭。八者不放逸。天子是名八法。菩萨安住不放逸故。诸佛菩提及菩提分法一切当得。是故天子应当依是不放逸住。汝等天子。依不放逸则三种乐常不损减。何等为三。一者天乐。二者禅乐。三者涅槃乐。复次诸天子依不放逸住者得离三苦。何等为三。所谓行苦苦苦坏苦。又不放逸者超三种畏。何等为三。所谓地狱饿鬼畜生。又不放逸者得超三有。何等为三。所谓欲有色有无色有。复次诸天子依不放逸住者得离三垢。何等为三。所谓贪垢嗔垢痴垢。又不放逸于三学处当得圆满。何等为三。所谓增上戒增上心增上慧。不放逸者常得亲近供养三宝。何等为三。所谓佛宝法宝僧宝。复次依不放逸住者。得离三种波罗蜜障。何等为三。一者自悭。二者于行施人心生憎嫉。三者随顺悭人自破戒。憎嫉持戒者。随顺破戒人。自嗔憎嫉忍辱者。随顺嗔恚人。自懈怠憎嫉精进者。随顺懈怠人。自散乱憎嫉禅定者。随顺散乱人。自无智慧憎嫉智慧者。随顺无智人。汝等诸天子。是名依不放逸住者当得远离三波罗蜜障。复次诸天子。依不放逸住者。当得三种波罗蜜伴助。何等为三。所谓施增长不求果报回向菩提。戒增长不求生天回向菩提。忍辱增长于一切众生不生害心回向菩提。精进增长种种善根无有厌足回向菩提。禅定增长心不散乱。回向菩提。智慧增长常修善业回向菩提。是名依不放逸住得此波罗蜜三伴助。是故诸天子。住不放逸增长一切善法。佛所印可。复次一切法如虚空。是四正勤。应当观察。何等为四。所谓诸法无作。未生不善法。为不生故发起精进。法性清净。已生不善法。为除灭故发起精进。诸法寂静。未生善法。令得生故发起精进。一切法无处无行。已生善法。住不失故发起精进。天子。是诸菩萨四正勤。佛所印可。复次诸天子。法性平等无生无灭。依此法性无所得故。不作诸恶。顺法性故。勤修众善。如是修者为无所修。复次于一切法不取不舍。是名正勤。复次诸天子。应观四念处。所谓无身住处。无受住处。无心住处。无法住处。无住处无建立处。是名念处。复次应观四如意足。一者身心不懈乐修善法故。二者为成就一切众生发起精进断贪欲故。三者一切法不可得而证诸佛法故。四者心如幻化法无所依超过一切取着故。复次应观五根。一者信根。决定安住于诸法中为上首故。二者精进根。遍修诸行成就佛身故。三者念根。具足诸法心善调柔无忘失故。四者定根。远离攀缘不随昏睡故。五者慧根。决断诸法正观现前不随他故。何谓诸力。所谓安住如是诸法性中。一切烦恼无能沮坏。是名为力。住是力故便得胜法。如实了知非异非如。说名觉分。若于诸法随顺觉了。由是道故。次第修行通达秘密。于法不动。说名圣道。是故诸天子。应如是修三十七品菩提分法。出过诸行无复障碍。智慧炽然究竟寂静。云何名为究竟寂静。谓诸法无起亦无所尽。无所尽故则无所作。无所作故。亦非无作无受无受者无施设。是名究竟寂静。说此法时。一万二千天子。于诸法中得法眼净

尔时善德天子白文殊师利言。菩萨云何修习于道。文殊师利言。天子若诸菩萨不舍生死。而令众生入于涅槃。不舍爱取。而拔出众生令立圣道。是名菩萨修习于道。复次天子。修习道者。善巧安住清净性空。何以故。菩萨以寂静心。见一切法自性清净。为诸众生乐着诸见。安住随眠无方便者。演说诸法自性空义。所以者何。是诸众生。于自性空中而生见故。是菩萨以无相无愿无所作。一切法自性不生。为诸凡夫久习烦恼生灭见者。于此无生令得信乐。而于生灭亦无所动。天子。是名菩萨修习于道。复次天子。应见菩萨去来之道。诸天子言。文殊师利。云何菩萨去来之道。文殊师利言。天子。菩萨证菩提而去。如应说法而来。得诸禅解脱而去。现生欲界中来。入于圣道故去。大悲成熟众生故来。得无生法忍而去。忍受众生故来。于一切法出离故去。拔出众生故来。誓愿坚固而去。誓愿无自性而来。三解脱门而去。故受生而来。菩提道场故去。为安立众生于菩提故来。天子。是名诸菩萨去来之道。说此菩萨道时。五百菩萨得无生法忍

尔时善德天子白文殊师利言。我等曾闻有世界名一切功德光明。为在何处。何等如来于中说法。文殊师利言。天子。彼一切功德光明世界。在于上方。过十二恒河沙佛刹。普贤如来于中说法。诸天子言。我等愿欲见彼世界及彼如来。尔时文殊师利。即入光明庄严三昧。以三昧力放大光明。过十二恒河沙佛刹。遍照一切功德光明世界。时彼菩萨问。此光明从何所来。彼佛告言。善男子。下方过十二恒河沙佛刹有世界名娑婆彼土有佛名释迦牟尼如来应正等觉。在世说法。彼有菩萨名文殊师利。入光明庄严三昧。放大光明遍照十方无量佛刹。是其光明来照此会。彼诸菩萨。即白普贤如来。我等愿见释迦牟尼世尊及文殊师利菩萨。时普贤如来放大光明。照十二恒河沙佛刹。至娑婆世界。令彼菩萨分明见此菩萨众会。时彼世尊告诸菩萨。谁能往彼娑婆世界。尔时持法炬菩萨摩诃萨白佛言。世尊。我能往彼娑婆世界。佛言。今正是时。尔时持法炬菩萨与十亿诸菩萨俱。于彼国没。现兜率陀天。放大光明遍照世界。时诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世诸天子等。及诸声闻菩萨大众。得未曾有。作如是言。此诸菩萨。游戏神通甚为希有。尔时众会因此光明。见一切功德光明世界。及见普贤如来国界庄严。于一劫中说不能尽。当此文殊师利现神变时。七那由他诸天子等。发阿耨多罗三藐三菩提心。尔时持法炬菩萨白文殊师利言。可共礼觐释迦如来。时文殊师利。于彼天子应可度者皆悉度已。与持法炬诸菩萨众。及大声闻天龙夜叉乾闼婆等。往诣佛所。到已顶礼佛足却住一面。尔时持法炬菩萨白佛言。世尊。普贤如来问讯。世尊。少病少恼起居轻利安乐行不。尔时世尊告彼诸菩萨言。善男子。此文殊师利。及持法炬正士。神通变化智慧光明。成熟众生奉事诸佛。一切菩萨。不能知其智慧方便深入边际。汝善男子。应当学此文殊师利。及持法炬正士并诸菩萨。所有神通辩才智慧。奉事诸佛成熟众生。此诸正士无数劫来。从一佛刹至一佛刹。常作佛事。若诸众生入此正士境界。当来不复堕于魔界。尔时世尊告长老阿难。汝善持此法门。不断三宝种故。尔时持法炬菩萨摩诃萨。从此会起。与其眷属还本佛刹。佛说此经已。善德天子长老阿难。一切世间天龙乾闼婆阿修罗等。闻佛所说。皆大欢喜

大宝积经卷第一百一大宝积经卷第一百二

        隋三藏达摩笈多译

    第三十六善住意天子会

    缘起品第一

如是我闻。一时婆伽婆。住王舍城耆阇崛山内。与大比丘众六万二千人俱。皆是大德具足神通。诸大声闻而为上首

尔时复有四万二千菩萨摩诃萨。其名曰文殊师利菩萨。师子幢菩萨。弥勒菩萨。观世音菩萨。大势至菩萨。大辩聚王菩萨。陀罗尼自在王菩萨。善丈夫菩萨。须弥顶菩萨。须弥幢菩萨。不可动菩萨。善思义菩萨。善思义意菩萨。善思惟菩萨。思心菩萨。勇意菩萨。善思菩萨。宝髻菩萨。山相击王菩萨。宝手菩萨。宝意菩萨。宝印手菩萨。常举手菩萨。常下手菩萨。常精进菩萨。度众生菩萨。上精进菩萨。如言行菩萨。上愿菩萨。灯手菩萨。心平等菩萨。除恶道菩萨。除诸忧暗菩萨。不舍重担菩萨。日藏菩萨。月藏菩萨。金刚步菩萨。无边步菩萨。无量步菩萨。不动行步菩萨。虚空藏菩萨。胜意菩萨。益意菩萨。增上意菩萨。成行菩萨。持地菩萨。月光菩萨。月幢菩萨。光德菩萨。明照菩萨。勇步菩萨。师子奋迅吼音菩萨。无碍辩菩萨。相应辩菩萨。捷疾辩菩萨。最胜菩萨。翳日月光菩萨。无攀缘菩萨。无著意菩萨。常笑菩萨。喜根菩萨。除诸障盖菩萨。转女身菩萨。摩尼珠菩萨。灯明菩萨。毗卢遮那菩萨。火焰菩萨。众胜王菩萨。深说者菩萨。如是等菩萨摩诃萨而为上首

尔时复有四天大王。忉利天王。娑婆世界主大梵天王。如是等而为上首。与六万诸天众俱。复有善住意天子。善德天子。大自在天子。如是等而为上首。与三万诸天众俱。于菩萨道皆已久住。复有二万阿修罗王。罗睺阿修罗王。须弥阿修罗王。如是等而为上首。亦皆已住于菩萨道。复有六万诸大龙王。阿那婆达多龙王。胜月龙王。如是等而为上首。亦皆已住于菩萨道。并余无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽亿百千众。乃至一切比丘比丘尼。优婆塞优婆夷。无量大众皆来集会

尔时世尊以如是等无量百千大众围绕于说法时。文殊师利菩萨摩诃萨。即于己室入彼无诤除心三昧寂然不动。于是文殊师利一心安详从三昧起。应时十方无量无边诸佛世界六种振动。时文殊师利起三昧已。作如是念。彼无量无边诸世界中。乃有一佛如来应供正遍觉。出兴于世。如优昙花希复现耳。如是诸如来应供正遍觉。世间希有出现甚难。所可说法尽诸有生寂灭涅槃不可思量。无有分别甚深无譬。难解难知。然以诸佛不出世故。不可得闻以不闻故诸众生苦难可穷尽。我今应当诣于如来正遍觉所咨问是义。问斯义故令诸众生成就善根。亦令一切行菩萨者于彼甚深不可思议诸佛法中无复疑惑。皆得成满佛菩提事。然此娑婆世界诸众生等。多有贪欲。具足嗔恚。成就愚痴。断除白法。顽钝诳诈。无有惭愧。我慢贡高。远离诸佛。违背法僧。令彼众生得闻如是甚深妙法获净智眼

尔时文殊师利复作是念。我今应当大集十方诸菩萨众。令皆得闻如来所说是妙法门证深法忍。尔时文殊师利如是念已。即入普光无垢庄严三昧。入此三昧已。放大光明照于东方如恒河沙等诸佛世界。普皆柔和润泽清净。明朗无垢微妙难称。而此光明遍照南西北方四维上下十方世界。其间所有一切暗冥幽隐之处。山崖树林大小诸山。目真邻陀山。摩诃目真邻陀山。铁围山大铁围山。及余黑山。须弥山大须弥山。如是一切光明。朗彻无有障碍

尔时十方恒河沙世界。所有诸佛现说法者。彼诸弟子各请其佛言。世尊。何因缘故。乃有如是大瑞光明现于世间。世尊。我从昔来初未闻见如是光明如是清净如是微妙。世尊。此何光明。而令我等大喜遍身心得清净。亦令众生无复贪欲嗔恚愚痴。烦恼众恶一切不行。世尊。今此光明谁之所作谁所加持而来现此。彼诸侍者如是请已。彼诸世尊默然无报。当尔之时十方世界一切所有诸种音声。所谓若天声。若龙声。若夜叉声。若乾闼婆声。若阿修罗声。若迦楼罗声。若紧那罗声。若摩睺罗伽声。若人声。若非人声。若象马声。若诸兽声。如是等声咸皆止息。若风声若火声若水声。若大海波声。若音乐声。若歌赞声。当尔之时如是诸声以佛力故。亦皆止息一切寂然。时彼十方诸佛侍者。复请彼佛言。世尊。惟愿大慈。怜愍一切诸天人故。安乐一切诸天人故。利益一切诸天人故。为我宣说如是光明所从来处。而能普照诸佛国土。尔时十方诸佛。即以十方恒河沙数世界。所有一切诸如来声。悉同梵音。如一如来口业所说。其所说事亦无差殊。用是妙声各皆报告己之侍者。当彼诸佛出声告时。一切佛刹悉皆振动。百千乐音一时皆作。乃至一切天人阿修罗。所有音乐不鼓自鸣。又彼乐音众声之中出诸法音。所谓无常声。苦声。无我声。空声。无相声。无愿声。离欲声。解脱声。法界声。如如声。实际声。檀波罗蜜声。尸波罗蜜声。羼提波罗蜜声。毗梨耶波罗蜜声。禅波罗蜜声。般若波罗蜜声。大慈声。大悲声。大喜声。大舍声。和合声。利益声。出离声。出如是等种种百千诸法之声。又彼种种诸声出时。无量阿僧祇亿那由他百千众生。皆得住于不退转阿耨多罗三藐三菩提。复有成就辟支佛者。成声闻者。乃至得成大梵天王天帝释转轮王等

尔时十方诸佛世尊。咸各告其侍者弟子言。诸善男子。汝今不应请问是事。何以故。此光明因缘。一切声闻辟支佛等。非其境界。我若说者。乃至世间天人阿修罗皆即迷没。是故不应请问斯事。诸佛如来若说如是光明因缘。乃是能生成就不可思议诸胜善根。亦缘如是不思议诸胜善根而得出生。所谓布施持戒忍辱精进禅定智慧诸度等行。如是诸行即是光明之所出生。亦为光明之所成就。是故我等诸佛如来。若于一劫若减一劫。赞说如是光明功德终不能尽。又以如是慈悲喜舍诸善根力共相熏修。令此光明能生欢喜。时彼十方诸佛侍者。各自殷勤再三启请白言。惟愿世尊。怜愍一切诸天人故。安乐一切诸天人故。利益一切诸天人故。成熟菩萨诸善根故。为我等说光明因缘。彼诸菩萨如是请已。于是十方诸佛世尊。复各告其侍者弟子言。诸善男子。汝宜谛听。吾为汝说。诸侍者言。唯然世尊。愿乐听闻。尔时彼佛各各告其侍者言。善男子。有世界名曰娑婆。其土有佛号释迦牟尼如来应供正遍觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出五浊世。彼土众生多有贪欲嗔恚愚痴众恼所迫。彼诸众生无有恭敬。不识惭耻都无羞愧。所为行业多诸不善。能于如是浊恶世中。成就阿耨多罗三藐三菩提。然今现在处众说法。善男子。彼世界中释迦如来。有一大弟子菩萨摩诃萨名文殊师利。有大功德。具足智慧精进勇猛。有大威神。能令菩萨咸得欢喜故。能令菩萨具足修行故。令诸菩萨增长威力故。令诸菩萨发勤勇猛故。能善分别一切法句故。能达无碍智慧彼岸故。能具足得无碍辩才故。又于诸陀罗尼得自在故。已具成满一切菩萨不思议功德故。令彼菩萨将欲请问释迦牟尼如来应供正遍觉甚深法门。为诸菩萨善根成就故。为行菩萨乘人。得满足彼不思议诸佛法故。善男子。又彼文殊师利放斯光明。欲令十方世界无量阿僧祇诸菩萨众大集故。令彼诸菩萨得胜法故。以是因缘。彼文殊师利放大光明照诸佛土。尔时十方世界诸佛侍者。复各请问彼诸佛言。世尊。彼文殊师利。住何三昧放此光明。尔时十方诸佛。咸各告其侍者弟子言。诸善男子。彼文殊师利。入普明无垢庄严三昧故。放斯光明。侍者菩萨复白诸佛言。世尊。我初未见如是光明。如是清净。如是能令身心欢喜。诸佛复告诸菩萨曰。彼将不欲教诸菩萨起修行耶。彼将不欲大集诸菩萨众耶。彼将不欲集诸菩萨宣说如斯妙经典耶

尔时十方无量不可思议恒河沙等诸佛世界。一一世界中有无量阿僧祇诸菩萨众。各自诣彼诸世尊所。顶礼佛足。礼已即复请白彼诸佛言。世尊。谁有是光谁有斯德。我等昔来未曾见闻。忽现是光照诸世界。时彼诸佛复告彼诸菩萨众曰。诸善男子。彼有世界名曰娑婆。其佛号释迦牟尼如来应供正遍觉。今现说法。彼有菩萨名文殊师利。具大威德。其为大集一切菩萨摩诃萨众故。放斯光明。时彼诸菩萨。复白彼诸佛言。世尊。我等今者愿诣娑婆世界。意欲奉见释迦如来。礼拜恭敬故。供养承事故。请问义理故。并欲见彼文殊师利。及余菩萨摩诃萨故。彼诸世尊。即便告彼诸菩萨言。诸善男子。欲往随意。汝应知时

尔时十方无量阿僧祇不思议不可计不可称不可量亿那由他百千频婆罗菩萨摩诃萨。各礼佛足已。犹如壮士屈伸臂顷。各于彼世界没。而来现此娑婆国土。是时十方诸来菩萨摩诃萨众。皆诣世尊释迦如来应供正遍觉所。其间或有能雨众香。所谓涂香末香及以香鬘。来诣世尊释迦如来应供正遍觉所。或有菩萨雨诸妙花。所谓优钵罗花。钵头摩花。拘物头花。分陀利花。瞻波迦花。波吒利花。陀奴迦利花。阿他目多迦花。苏摩那花。婆利师迦花。曼陀罗花。摩诃曼陀罗花。波卢沙花。摩诃波卢沙花。旃陀罗花。摩诃旃陀罗花。微妙旃陀罗花。斫迦罗花。摩诃斫迦罗花。最妙斫迦罗花。雨如是等种种花鬘。来诣世尊释迦如来应供正遍觉所。或有菩萨摩诃萨。能出百千上妙诸音。来诣世尊释迦如来应供正遍觉所。复有菩萨摩诃萨。能以一音。遍满三千大千世界。歌赞佛德。来诣世尊释迦如来应供正遍觉所。以如是等种种庄严。咸诣世尊释迦如来应供正遍觉所。时彼十方诸来菩萨摩诃萨众。大集于此娑婆世界。而此三千大千世界。所有众生地狱畜生饿鬼。若阎魔界。悉皆寂然身心安乐。无有贪欲嗔恚愚痴。远离众毒嫉妒谄诳我慢热恼。一切众生皆起慈心。具足欢喜。何以故。以彼十方诸大菩萨威神力故。其事若是。尔时十方无量百千亿那由他。诸大菩萨摩诃萨等。咸集世尊释迦如来应供正遍觉所。到佛所已。头面礼敬右绕三匝。住于虚空。即入菩萨隐身三昧。入三昧已。随意所生。无量百千种种妙色大莲花座。结加而坐。悉皆隐身令不复现。尔时尊者摩诃迦叶。见彼殊特希有瑞相大神通事。复见彼众大雨花香。亦见彼作无量乐音。又复见彼放大光明。又亦见此三千世界诸四天下。皆雨妙花积至于膝。又复见彼一切大众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。乃至所有比丘比丘尼优婆塞优婆夷等。一切皆悉具足成就金色相身。于是尊者摩诃迦叶。从座而起正持威仪。偏袒右臂右膝着地。合掌恭敬。以偈赞曰

  欢喜常与一切乐　　圆满无垢清净颜
  十力雄猛诸大人　　具足金刚百福相
  游于三界人天间　　一切无能如佛者
  不可思议难测度　　惟愿除断我疑心
  过那由他百千劫　　常行布施摄世间
  远离执着无所依　　净持禁戒无伦比
  具足修忍超世间　　一切力中十力最
  功德备满无过者　　唯愿永绝我疑心
  过百千劫修众行　　以见众生受诸苦
  勇猛精进终无疲　　常生欢喜无有量
  头目髓脑持与人　　弃舍男女及妻妾
  厌离国城及众具　　唯愿除解我疑网
  世尊往昔行施时　　象马辇舆不可数
  过那由他上衣服　　常以欢喜惠世间
  世尊常以先心施　　如是杂物及众珍
  饮食汤药并田宅　　是故今日我咨问
  往昔割身及耳鼻　　内心无垢不生嗔
  若他诘问如法言　　犹能巧说忍辱力
  以能通达深空法　　心意微妙难称量
  能施他乐功德人　　是故今我问无垢
  诸漏久尽患悉除　　深见众生没诸苦
  黑暗所覆愚痴者　　生于垢浊及我人
  怜愍诸有起慈心　　过百千劫勤修行
  开发正觉菩提岸　　唯愿除断我今疑
  善能出入神通门　　隐显自在巧行住
  证得无我破我相　　毁坏诸法亦非空
  佛于世中无染着　　真实正行及正思
  微妙寂灭离诸垢　　唯愿为我决此疑
  世尊昔日修行时　　施戒忍进无暂废
  禅定智慧亦常修　　利益群生无有比
  诸功德聚难思量　　深大如海无穷尽
  善能往来亦善住　　唯愿为我作归依
  往昔无垢修大慈　　怖鸽归投救不舍
  剜身割股血滂流　　称肉与鹰而代之
  全身上秤谓敌彼　　而鸽尚重身犹轻
  大明善巧以行慈　　唯愿为我决疑惑
  须弥动摇众星落　　诸天宫殿尽破亡
  四大海水一朝枯　　阿修罗宫处天上
  假使日轮坠于地　　明月处空忽瞑冥
  诸佛正觉两足尊　　所言真诚无有二

尔时尊者摩诃迦叶。说偈赞已。复白佛言。大德世尊。何因缘故。世间有是微妙光明。复何因缘。忽现如是未曾有瑞。众相明了。尔时世尊。告大迦叶言。迦叶。汝今不应咨问是事。何以故。如是境界。非诸声闻缘觉所知。若我说是光明义者一切世间天人阿修罗。皆当惊疑入迷没处。是故汝今不应问也。时大迦叶。复白佛言。世尊。唯愿大慈。怜愍一切诸天人故。利益一切诸天人故。安乐一切诸天人故。说此光明甚深因缘。令我开解。尔时世尊。告迦叶言。汝宜谛听善思念之。吾为汝说。大迦叶言。善哉世尊。愿乐欲闻。唯垂敷演。时佛复告大迦叶言。迦叶。今我文殊师利。入彼普明无垢庄严三昧。三昧力故放斯光明。遍照十方过恒沙等诸佛国土。为大集彼无量无边不可数不可量阿僧祇。诸大菩萨摩诃萨等。而来至此娑婆世界。彼等皆已顶礼我足。右绕三匝。处在虚空高一多罗树。皆各于彼大莲花座。结加而坐

尔时尊者大迦叶。复白佛言。世尊。今有何等菩萨摩诃萨威神德力。而雨如是微妙花香。复出如是百千音乐。不鼓自鸣。佛告大迦叶言。迦叶。是为十方诸菩萨等威神力故。而雨如是胜妙花香。乃至于上虚空之中。无量乐音皆自鸣也。迦叶复言。世尊。我于是中。乃至不见彼一菩萨。云何世尊。更言十方诸菩萨等。迦叶。一切声闻辟支佛等。终不能见彼诸菩萨摩诃萨众。何以故。迦叶。是中声闻辟支佛等。于大慈悲。非其所住故。若能住是慈悲地中。斯则能为利益他事。则亦能行布施持戒忍辱精进禅定智慧。诸波罗蜜等。若已受正位。终不能行此诸菩萨所行之处。迦叶。斯诸菩萨摩诃萨等。一切皆入隐身三昧。是故一切声闻辟支佛。不能见彼诸菩萨等。唯除诸佛及大菩萨。住斯地者乃能见耳。迦叶。初住大乘诸菩萨等。尚不能见。何况一切声闻辟支佛。而能得见。若得见者无有是处

尔时大迦叶复白佛言。世尊。菩萨摩诃萨。具足几法修何善根。获何功德。而能入是隐身三昧。佛言迦叶。菩萨摩诃萨。成就十法即能获是隐身三昧。何等为十。一者志性和柔深住正信。二者恒不舍离一切众生。三者毕竟成满大慈悲心。四者觉了一切不着众相。五者虽复思求一切佛法。终不妄取。六者亦不思想一切声闻辟支佛智。七者世间所有尽皆能舍。乃至身命尚无吝惜。岂况余物而不施者。八者虽行无量生死烦恼。而不染着诸有为行。九者常修无量布施持戒忍辱精进禅定智慧。而不分别诸波罗蜜。十者常生是心。我当安立一切众生于菩提已。然后方当坐佛树下。不取菩提及众生相。迦叶。是为菩萨摩诃萨具足十法。便能获得隐身三昧

尔时尊者大迦叶复白佛言。希有世尊。快说斯事。世尊。乃能作如是说。世尊。一切声闻辟支佛。尚皆未曾一发是心。我当安置一切众生于阿罗汉地。况佛法乎。佛言迦叶。如是如是。是故一切声闻辟支佛。悉无能入菩萨所行隐身三昧。此三昧名尚自不知。云何能入。若能入者无有是处

尔时尊者大迦叶复白佛言。世尊。我等今者。深愿见彼诸大菩萨摩诃萨等。所以者何。斯诸大士难可会遇。佛言迦叶。汝宜且住。当须待我文殊来者。彼诸菩萨当从定出。汝等然后乃见之耳。虽然迦叶。汝亦得是无量百千诸三昧门。今当摄心求彼菩萨摩诃萨等。为在何处。住何威仪。作何事业。时大迦叶蒙圣教已。承佛威神及己通力。即入二万诸三昧门。如是思求彼诸菩萨。今在何所住何威仪。为行步耶。而竟不见为住立耶。而亦不见为倚卧耶。而亦不见为端坐耶。而亦不见。乃至不知。以何语言作何事业。来何所从。去何所至。于是起定前白佛言。甚奇世尊。甚奇世尊。我已经历二万定门。求诸菩萨竟无所见。世尊。彼诸菩萨摩诃萨等。尚未证知萨婆若处。已得如是微妙三昧。何况当证无上菩提。世尊。诸善男子善女人。其有见闻如斯神变。而不疾发阿耨多罗三藐三菩提心者。无有是处。世尊。能得如是隐身三昧。菩萨摩诃萨。为欲度彼一切众生。被精进铠。然终不得离是妙定。佛告迦叶。如是如是。如汝所说。是中一切声闻辟支佛。尚非境界。况余众生

尔时尊者舍利弗。作如是念。世尊称我声闻人中智慧第一。我今宁可求诸菩萨。今在何所住何威仪。作何事业。若得睹见不亦善乎。时舍利弗如是念已。承佛威神及自力故。即入三万诸三昧门。周旋观察彼诸菩萨。今为何所住何威仪。乃至不知如毫厘相

尔时尊者须菩提。作如是念。我今亦当求诸菩萨。为何所在住何威仪。造作何事。若睹见者不亦善乎。时须菩提作是念已。承佛威神及自力故。即入四万诸三昧门。周遍推求彼诸菩萨。为何所在住何威仪。乃至不见行住坐卧。从何所来去何所至。然后出定前至佛所。头面礼足。白言世尊。世尊记我声闻人中无诤三昧最为第一。是三昧门我亦已得。如是世尊。我若入定。正使有人具大神力。能以百亿四天下为一大鼓。取须弥山为一大槌。于我定时。令一大人住在我前。执彼大槌挝击大鼓。无暂休废。乃至经劫。如是鼓声尚不入耳。何况乱心能令我出。若彼鼓声能为定患。牵我起者永无是处。世尊。我今所得无诤三昧。弘普若是。我向经历四万三昧。周遍推求彼诸菩萨。终不能见。乃至不睹一人暂时往来之相。如是世尊。有诸菩萨摩诃萨辈。念求如是不思议智。为一一众生。于恒河沙劫。生地狱中备受众苦。世尊。彼求菩萨道故。虽经众苦。而不舍离如是甚深不思议智。如是世尊。若我今日漏心未尽。未得解脱。于诸佛法有所未知者。令我当来常在生死。更不舍离彼不思议大妙乘也。于是世尊。赞须菩提言。善哉善哉。诚如汝言。汝以信故作如斯说。令汝此身不取涅槃者。以斯善根。于当来世过恒沙劫。汝当得作转轮圣王。正法治世。然后乃成阿耨多罗三藐三菩提。又须菩提。今此三千大千世界众生数类。宁为多不。须菩提言。甚多。世尊。甚多。世尊。佛言。如是如是。须菩提。是诸世界所有众生。成就智慧如舍利弗。解空第一如须菩提。苦行超伦如大迦叶。即令如是诸大声闻。共尽知见求彼菩萨。若于一劫。若于百劫。若于千劫。乃至无量恒河沙劫。亦不能见。若能见者。无有是处。何以故。须菩提。彼诸菩萨凡所为作。非是一切声闻辟支佛所行境界。是故二乘终不能见。说此法时。是众会中八万四千天人。皆发阿耨多罗三藐三菩提心。三千世界六种震动。尔时文殊师利。于己住室如是思惟。今此十万亿百千数诸大菩萨。皆已集会。吾当复召诸天大众。咸令云集。如是可乎。时文殊师利。既思惟已。即以神力。如意化成八万四千亿那由他妙宝莲花。大如车轮。纯金为茎白银为叶。胜藏罗网。毗琉璃宝。是诸花中。皆有化佛及诸菩萨。结加趺坐莲花台上。身紫金色。三十二相八十种好。威德巍巍光明普照。时彼莲花。上升四天王天三十三天。夜摩天兜率天。化乐天他化自在天。及诸梵天乃至有顶。如是略说遍此三千大千世界。乃至百亿须弥。百亿四天下。欲界天宫。色界天宫。彼化莲花无不遍至。是诸化处及菩萨众。出大音声遍告三千大千世界。而说偈言

  世尊明慧日　　希有出世间
  譬如忧昙花　　难遇复过是
  释师子人雄　　今者现于世
  班宣深妙法　　永拔众苦源
  诸天虽快乐　　谁能保长久
  任业还三涂　　复受众苦毒
  所习诸欲事　　贪爱独增长
  三界本无乐　　而愚耽着之
  已获最上难　　所谓诸佛出
  愚痴放逸人　　焉觉苦不断
  汝等当速求　　见佛闻正法
  若圣涅槃已　　虽悔难可追
  魔网深可怖　　汝等为放逸
  既被羁罗已　　宁有解脱期
  独有求佛法　　汝为众生资
  汝等但速求　　三十二妙相
  佛能救世间　　余无可依者
  世雄甚希有　　大慈难思量
  无量亿数劫　　所行不可量
  集功德智慧　　成就释师子
  阐扬微妙法　　甚深难觉知
  何处有众生　　及我人寿命
  如是破常见　　断已自无余
  放舍一切相　　为众生说此
  宣明真实际　　世间绝心行
  唯彼空无相　　无愿亦无作
  虚空本无形　　不起亦不灭
  无来亦无去　　智者之所说
  无尽无所生　　本净无所有
  无相貌可见　　无思想能说
  众生本无生　　云何得言死
  寂灭无众生　　众生在何处
  言音为说法　　法不住言音
  亦不可文字　　世尊如斯说
  诸处遍推求　　不见风水火
  地亦无分别　　慧眼之所宣
  色受及与想　　行识同虚空
  假言彼五阴　　其实无积聚
  眼耳鼻舌身　　心意等诸根
  虽说本性空　　空亦不可得
  色声香味触　　及以种种法
  斯由分别生　　分别体空寂
  欲界与色界　　及彼无色天
  皆说如幻化　　虚伪不真实
  如是诸世尊　　为众生说法
  欲求出众苦　　速归大导师

彼诸化佛。说此偈时。于是三千大千世界。咸得闻之。有九十六亿欲色诸天。远尘离垢得法眼净。二万天子。厌离众欲。三万二千天子。皆发阿耨多罗三藐三菩提心。一万行菩萨乘诸天子。得无生法忍。尔时彼化如来。所可劝召。无量无边阿僧祇亿那由他百千诸天大众。于须臾间悉皆云集。释迦如来应供正遍觉所。稽首足下。右绕三匝退住一面。以天花香。所谓优钵罗花。钵头摩花。拘物头花。分陀利花。曼陀罗花。摩诃曼陀罗花。及诸花鬘末香涂香。奉散世尊。及余供养。复以种种天妙乐音。歌咏称赞满彼虚空。时大集众。其数甚多难可称计。周遍充满此四天下。无有空地如一杖头而不遍者。是诸天人具大威德。所散诸花满四天下。积至于膝

大宝积经卷第一百二大宝积经卷第一百三

        隋天竺三藏达摩笈多译

    善住意天子会第三十六之二开实义品第二

尔时大集众中。有上首天。所谓善住意天子。善寂天子。惭愧天子。与如是等九十六亿诸天子俱。一切皆行菩萨之道。咸共往诣文殊师利所。至其门外右绕七匝。绕七匝已。然后雨天曼陀罗花。其所雨花遍覆虚空。高十由旬成花网台。形如宝塔。时文殊师利持此花台。供养世尊。供养已。即以神力。令此三千大千世界一切国土。虚空之中花网遍覆。是花光明。普照三千大千世界。皆大明盛。复雨天曼陀罗花。尔时文殊师利菩萨摩诃萨。闲雅安详从精舍出。更以神力。令所居地。自然而有七宝妙座。其座巍巍具足庄严。文殊师利敛容整服。升此宝座。时善住意天子。见文殊师利升宝座已。即以顶礼文殊师利足。退住一面。一切诸天。亦皆顶礼文殊师利足。尔时文殊师利。如是思惟。谁于今日。堪任与我在世尊前对扬深法。谁为法器。能受如是不思议句。甚难证句。无处所句。无所著句。无戏论句。不可得句。不可说句。甚深句。真实句。无碍句。不可坏句。空句。无相句。无愿句。如如句。实际句。法界句。无形貌句。不取句。不舍句。佛句法句僧句。智慧满足句。三界平等句。一切法无所得句。一切法无生句。师子句。勇猛句。无句句。如斯说已谁听者乎。于是文殊师利。复更思惟。今此唯有善住意天子。已于过去供养多佛。入深法忍具足辩才。当能与我处世尊前共谈实义。尔时文殊师利如是念已。即语善住意天子言。天子。汝今已得甚深法忍。又能具足无碍辩才。今当与我诣世尊所。对论如是深妙义乎。时善住意天子。报文殊师利言。大士我如是说。彼若于我无有语言。不为演说。不存咨问。亦无报答。无佛法众。断灭三乘。无生死无涅槃。不合不散。不启不发。不出声音。除诸文字。如是说者我当共谈。文殊师利语善住意天子言。天子。我如是说。彼能于我。无听无闻。无读无诵。无受不持。不思不念。不取不舍。不觉不知。不闻我言。不为他说。所以者何。诸佛菩提本无文字。无心离心。无有觉悟。虽假名说其名亦空。善住又言。大士。今者且为诸天子说。斯诸天子。于大士说乐欲听闻。文殊师利言。天子。我终不为乐听者说。又亦不为闻受者说。所以者何。凡有听受则为取着。云何取着。所谓我着。人着。众生着。寿命着。士夫着。以取着故便有听受。如是听受。当知彼住三种缚中。何谓三缚。一见我缚。二见众生缚。三见法缚。天子。若无如是三种见缚。而听法者。当知彼住三种净中。何谓三净。一不见自身。不分别。不思念。不证知。二不见说者。不分别。不思念。不证知。三不见所说。不分别。不思念。不证知。天子。是则名为三种净也。天子。若有能作如是听者。是平等听非不平等

尔时善住意天子赞文殊师利言。善哉善哉。快作斯说。大士。若有能作如是说者。当知即是不退转说。文殊师利言。且止天子。汝今不应妄想分别菩萨退转。何以故。若使菩萨有退转者。彼终不能成等正觉。所以者何。是菩提中无退法故。善住复言。大士。若如是者。当于何处有斯退转。文殊师利言。天子。当知从贪欲故有退转。从嗔恚故有退转。从愚痴故有退转。从有爱故有退转。从无明故有退转。乃至从十二有分生死所生故有退转。从因故有退转。从见故有退转。从名故有退转。从色故有退转。从欲界故有退转。从色界故有退转。从无色界故有退转。从声闻行故有退转。从辟支佛行故有退转。从分别故有退转。从执着故有退转。从相故有退转。从取相故有退转。从断见故有退转。从常见故有退转。从取故有退转。从舍故有退转。从我想故有退转。从众生想故有退转。从寿命想故有退转。从士夫想故有退转。从福伽罗想故有退转。从思想故有退转。从系缚故有退转。从颠倒故有退转。从我见故有退转。从我见为根本六十二见故有退转。从诸盖故有退转。从诸阴故有退转。从诸入故有退转。从诸界故有退转。从佛想故有退转。从法想故有退转。从僧想故有退转。如是乃至。我当成佛。我当说法。我度众生。我当破魔。我得智慧。从是诸想故有退转。如是天子。若能不分别如来十力。不分别四无所畏。不分别十八不共法。不分别一切根力觉道。不分别诸相好。不分别庄严佛国。不分别声闻。不分别菩萨。乃至不分别一切分别退转者。是名不退转

尔时善住意天子。复白文殊师利言。大士。若如是者当于何处得不退转。文殊师利言。天子当知。从通达佛慧故。得不退转。从空故不退转。从无相故不退转。从无愿故不退转。从如如故不退转。从法性故不退转。从实际故不退转。从平等故不退转。善住意言。大士。若如是说。一切诸分别无分别。二俱不异。所以者何。皆从思惟分别生故。是故得言彼有退转。又问如是退转为有法耶为无法乎。文殊师利言。非有非无如是退转。善住意言。大士若尔。何处退转。文殊师利言。若有若无。是虚妄取。是颠倒取。是不如取。彼则不取亦非不取。以是义故。得言退转。而彼退法不可说有。不可说无。何以故。若有无中有退转者。彼即为过。所以者何。若有法退转则堕常边。无法退转则堕断边。然世尊说不住常中。不住断中。非断非常。世尊所说。天子。若彼于先不真实想。而彼证知。则名非断非常。天子。是为菩萨退转法门。说是法时。十千天子得无生法忍

    文殊神变品第三

尔时善住意天子。白文殊师利言。大士。今可俱行诣如来所。奉见顶礼咨受未闻。亦因此时如法问难。文殊师利言。天子。汝莫分别取着如来。善住意言。大士。如来何在而言莫着。文殊师利言。即在现前。善住意言。若如是者我何不见文殊师利言。天子。汝今若能一切不见。是则名为真见如来。善住意言。若现前者。云何诫我莫取如来。文殊师利言。天子。汝谓今者现前何有。善住意言。有虚空界。文殊师利言。如是天子。言如来者即虚空界。何以故。诸法平等如虚空故。是故虚空即是如来。如来即是虚空。虚空如来无二无别。天子。以是义故。若人欲求见如来者。当作斯观。如实真际觉了。是中无有一物可分别者

尔时文殊师利菩萨摩诃萨复以神力。化作三十二所重阁宝堂。辇轩具足。四面正方。四角有柱。周匝栏楯。宝网交络。殊特妙好。高显巍巍。具足庄严甚可爱乐。诸堂阁内咸有胜床。众宝所成天衣覆上。其床各有化菩萨坐。具三十二大人之相。尔时文殊师利。普现如是庄严事已。遂更与彼莲花化佛。并化菩萨。及此宝辇重阁殿堂诸菩萨众。俱往佛所。绕佛七匝。并亦围绕比丘众已。踊在虚空。光明普照众会道场。四面而住。尔时文殊师利。后善住发。忽然在前。先至佛所。善住意天子反更后到。白言大士。吾发在前。更在后至。仁从何路乃至于斯。文殊师利言。天子。假使供养满恒河沙诸如来等。稽首为礼。终不见吾往来进止。尔时花台诸化菩萨。及宝堂中诸菩萨众。同声说偈赞叹如来

  已曾供养过恒河　　不可思议诸世尊
  炽然修行求菩提　　是故超出天人上
  光明妙色三界雄　　牟尼众相实奇特
  为众宣说甚深法　　无有寿命及人我
  世尊行施持净戒　　忍辱精进具修禅
  智慧清净三界表　　我礼彼岸最胜尊
  其有发意求菩提　　则受天人妙供养
  若于深空无疑惑　　当绍出世大法王
  过去诸佛等正觉　　现在一切两足尊
  常说如是诸法空　　本来无相亦无作
  众生体性不可得　　何有生者及死灭
  本既无来亦无去　　一切诸法如虚空
  如彼化人观众事　　虽复示现而无真
  世尊说法亦如是　　斯皆虚诳同幻梦
  恒沙世界满中宝　　持以布施一切人
  若能修忍善说空　　如是行施超于彼
  复于恒沙诸劫中　　供养诸佛天人上
  奉献香花及众具　　为求菩提离世间
  得闻如是甚深法　　无有众生及命人
  当知彼得明净忍　　是为供养十方佛
  于无数劫行布施　　衣食象马及众珍
  当知彼非解脱因　　以有我人众生想
  归命灭度人中尊　　救济众生无量数
  诸法皆空本清净　　如是解脱智庄严
  诸佛出世甚难值　　得闻正法生信难
  人身难得今已获　　善哉佛法汝顺行
  已得蠲除斯八难　　永绝迫窄处空闲
  于诸正法得信行　　应当勇猛发精进
  若闻法已应正思　　不可闻声即取着
  汝等常行阿兰若　　必当速疾成人雄
  近善知识及法师　　应速远离诸恶友
  汝于众生平等想　　慎勿妄起我人心
  常乐多闻持禁戒　　捐弃舍宅坐林间
  腐药治病莫诈善　　亦恒乞食受粪衣
  一切有为即无为　　等同一相如阳焰
  若了实际见真如　　疾成无上菩提道
  当观五阴犹如幻　　内外诸入如空舍
  世尊常说如斯法　　法等于彼莫生着
  贪欲嗔恚性自空　　愚痴我慢分别起
  彼法已灭今亦无　　如是知者得成佛

如是诸化菩萨。说是偈时。彼会众中二万二千众生。皆发阿耨多罗三藐三菩提心。五百比丘。漏尽意解心得解脱。三百比丘尼。远尘离垢得法眼净。七千优婆塞优婆夷。二万五千诸天子。亦离尘垢法眼清净。三百菩萨得无生法忍。于是三千大千世界大地六种振动。所谓动。遍动。等遍动。震。遍震。等遍震。涌。遍涌。等遍涌。乃至吼起觉等。亦复如是

    破魔品第四

尔时尊者舍利弗。白佛言世尊。今此瑞相谁之所为。能令如是三千大千世界大地六种振动。又是宝辇殿堂莲花座上诸菩萨等。放大光明照斯众会。演说如是微妙深法。复令如是无量亿数诸天子众皆来集会。复有亿数诸菩萨等。亦来集也

尔时佛告舍利弗。斯乃文殊师利威神之力。故现如是妙庄严事。亦令菩萨诸天云集。所以者何。舍利弗。是文殊师利与善住意天子。将诸大众欲来我所。请问如是。破散诸魔三昧法门。具足成就不思议甚深佛法故。时舍利弗复白佛言。世尊。若如是者。何因缘故我观此众。竟不见彼文殊师利。佛告舍利弗。汝宜且待。今文殊师利。已与一切魔王一切魔众一切魔宫。作大衰耗。所为神变极妙庄严。将至我所。汝当自见。于是文殊师利。即入破散诸魔三昧。三昧力故。即时三千大千世界百亿魔宫。朽故暗冥若将毁坏。其变已现无复威光。令一切魔不乐其所。各自见身。惛耄羸瘠柱杖而行。诸天女辈变成老母。一切众魔见是事故。心大忧愁身毛皆竖。惶怖思念是何变怪。令吾内外不祥若斯。将无死没时至。果报离散耶。为是世间将坏劫灾事乎。彼诸魔众如是念时。文殊师利复以神力。即现百亿天子住在魔前。告魔众曰。汝勿忧惧。此非汝灾亦非劫尽。所以者何。今此适有住不退转菩萨大士。名文殊师利有大威神道德超世。即时正入破散诸魔三昧法门。以彼大士三昧威神。其事若此。非有他也。诸化天子说是语时。一切魔王及诸魔众。闻诸化天说文殊师利大士名号。更增惶恐战悼不安。一切魔宫皆大震动。时诸魔王。答化天曰。唯愿仁慈救我危厄。诸化天子复语魔言。勿怖勿怖。汝等今宜速疾往诣释迦牟尼佛世尊所。所以者何。彼佛如来有大慈悲。若诸众生忧恐煎迫。但往归依。皆蒙安乐除诸忧苦。时诸化天如是语已。即于其处忽然不现。尔时一切魔王及诸魔众。闻化天教莫不欢欣。皆共同心。于须臾顷羸弊柱杖。皆来住于释迦牟尼佛前。同声白言。大德世尊。愿见救护愿见救护。免兹变怪困苦大厄。世尊。我等宁受百千万亿诸佛名号。不愿闻彼文殊师利一菩萨名。何以故。我即闻是文殊师利菩萨名时。便大惊恐。若丧自身

尔时世尊告诸魔言。波旬。汝今何忽发如是言。所以者何。是文殊大士。凡所开导利益众生。亿百千佛昔所未作。今亦不作当亦不作。唯此文殊师利去来现在。常为众生建斯大事。众生熟已置解脱中。是故汝等虽复闻彼百千佛名。不生苦恼亦无惊怖。云何而言。我今忽闻一文殊师利名。皆大惊恐。时彼魔众。白言世尊。我诚惭耻。此弊老身加以惶惧。发斯言耳。世尊。我等从今归依正觉唯愿哀愍复我本形。佛告之曰且待须臾。文殊师利亦既来已。自除汝耻。于是文殊师利从三昧起。遂与无量百千天众。复与无量百千诸大菩萨摩诃萨等。及无量百千诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。前后围绕。复作无量百千微妙乐音。复雨如是无量妙花。所谓优钵罗花。钵头摩花。拘物头花。分陀利花。具大庄严。有大神通威德无极。俱来佛所。头面礼敬右绕三匝。退住一面

尔时世尊。告文殊师利言。文殊师利。汝入如是破散诸魔三昧耶。文殊师利。白言世尊。唯然已入。佛言文殊师利。汝从何佛闻是三昧。修经几时而得成满。文殊师利言。世尊。我本未发菩提心时。从佛得闻如是三昧。又问文殊师利。彼佛世尊名号何等。说是三昧令汝得闻。文殊师利。白言世尊。我忆过去无量无边不可思议阿僧祇劫。尔时有佛。号曼陀罗花香如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现世时。宣说如是破散诸魔三昧。我于彼时初得听闻。佛告文殊师利。如是三昧云何修得。文殊师利。白言世尊。若菩萨摩诃萨。具足成就二十种法。则能得是破魔三昧。何等二十。所谓一者诃毁贪欲破坏贪心。二者诃毁嗔怒破坏嗔心。三者诃毁愚痴破坏痴心。四者诃毁嫉妒破坏妒心。五者诃毁憍慢破坏慢心。六者诃毁诸盖破坏盖心。七者诃毁热恼破坏恼心。八者诃毁想念破坏想心。九者诃毁诸见破坏见心。十者呵毁分别破分别心。十一呵毁取事破坏取心。十二诃毁执着破坏执心。十三诃毁诸相破坏相心。十四诃毁有法破坏有心。十五呵毁常法破坏常心。十六诃毁断法破坏断心。十七诃毁诸阴破坏阴心。十八诃毁诸入破坏入心。十九诃毁诸界破坏界心。二十诃毁三界坏三界心。世尊。是为菩萨摩诃萨具二十法。毕竟成就如是三昧。世尊。菩萨摩诃萨复有四法。具足修行得是三昧。何等为四。一者建立心行清净调柔。二者心性淳直无诸谄曲。三者心无攀缘入深法忍。四者外内所有一切能施。是为菩萨摩诃萨。具足四法成就三昧。世尊。菩萨摩诃萨复有四法。能得三昧。何等为四。一者毕竟深心。二者成就实语。三者常乐空闲。四者不取诸相。是为菩萨具足四法成就三昧。复有四法。菩萨成就得是三昧。何等为四。一者亲近善友。二者常知止足。三者独坐思惟。四者不乐諠猥。是为菩萨具足四法成就三昧。复有四法。菩萨成就得是三昧。何等为四。一者不破坏戒。二者不缺犯戒。三者无所依戒。四者不望报戒。是为菩萨具足四法成就三昧。复有四法。菩萨成就得是三昧。何等为四。一者舍声闻心。二者离缘觉心。三者住菩萨忍。四者不舍众生。是为菩萨具足四法成就三昧。复有四法。菩萨成就得是三昧。何等为四。一者修空舍我。二者无相离相。三者无愿除愿。四者舍诸所有。是为菩萨具足四法能得三昧。世尊。时彼曼陀罗花香如来应供正遍觉。说此破散诸魔法门。我从彼佛闻已初修。次复有佛。号一切宝电蔽日月光如来应供正遍觉。我时于彼具足成就。彼佛世尊说此法门时。彼众会中十千菩萨。皆得成就此三昧门

尔时尊者舍利弗白佛言。希有世尊。今此文殊师利。乃能久远成就如是降魔三昧。三昧力故。能令波旬及诸魔众。发白老耄形志俱衰。一至斯也。佛告舍利弗。于意云何。汝今言此文殊师利。独是三千大千世界。变此众魔如斯老耄耶。舍利弗。汝今不应作如是见。所以者何。舍利弗。今者十方如恒河沙等。诸佛世界所有诸魔。一切皆悉如是变坏。尽是文殊师利威力所为。于是世尊告文殊师利言。文殊师利。汝今当且摄汝神力。令彼众魔得复本形。尔时文殊师利受佛教已。告诸魔曰。众仁者实为厌患此身仪耶。诸魔报曰唯然大士。文殊师利言。若如是者。汝今亦当厌患贪欲。勿着三界。诸魔报曰。善哉大士。敬闻嘉诲岂敢有违。唯愿少假威神除此惭苦。文殊师利遂摄神力。令一切魔复彼天形。庄严如故。尔时文殊师利。告诸魔言。波旬。汝所有眼。何者为眼。何者眼想。如是何处是眼。着是眼相。是眼攀缘。是眼障碍。是眼思。是眼我。是眼依止。是眼喜乐。是眼戏论。是眼我所。是眼护。是眼念。是眼取。是眼舍。是眼分别。是眼思量。是眼成就。是眼生。是眼灭。乃至是眼来去。如是等法。为汝境界魔业障碍。如眼乃至身意亦如是。又如色乃至触法。为汝境界魔业障碍。亦复如是。汝等皆应如实了知。复次波旬。汝所有眼。即为非眼。亦为无眼。为无眼想。无眼着。无眼相。无眼攀缘。无眼障碍。无眼思。无眼我。无眼依止。无眼爱。无眼戏论。无眼我所。无眼护。无眼念。无眼取。无眼舍。无眼分别。无眼思量。无眼决定。无眼生。无眼灭。无眼去。无眼来。如是等法非汝境界。汝于是中不能为主。无法无力。不得自在。亦无取着。如眼乃至身意亦如是。又如色乃至触法亦如是。汝等皆应如实了知。文殊师利说是法时。众中一万魔王波旬。皆发阿耨多罗三藐三菩提心。八万四千诸魔眷属。远尘离垢。得法眼净

    菩萨身行品第五

尔时尊者摩诃迦叶白佛言。世尊。我等愿请文殊师利。令我睹见彼诸菩萨摩诃萨等。所以者何。世尊。斯诸大士难可值遇。尔时世尊即告文殊师利言。汝应当知。今此大众咸皆渴仰。思愿睹见十方所有诸来菩萨摩诃萨身。今正是时。汝应显现。于是文殊师利蒙圣教已。即便告彼法轮菩萨。月光菩萨。除魔菩萨。妙音菩萨。离垢菩萨。寂灭菩萨。选择菩萨。法王吼菩萨。如是等无量菩萨摩诃萨言。诸大士。汝等今宜各于宫殿自显其身。分明现汝本国形状也。文殊师利发斯语已。于是诸菩萨众从三昧起。各现本身令诸大众一切咸见。或有菩萨。其身高大若须弥山王。或有菩萨。身大八万四千由旬。或有身大百千由旬。或九十千。乃至五十四十三十二十千者。或有身大十千由旬。乃至或有五千四千三千二千者。或有身大一千由旬。乃至或有五百四百三百二百者。或有身大一百由旬。乃至或有五十四十三十二十者。或有身大十由旬者。乃至或有五四三二一由旬者。如是乃至或有菩萨。身量大小长短宽狭。如此娑婆世界人身无异。当尔之时。此三千大千世界。大众充满。无有空处如杖头许。其中所有诸大菩萨摩诃萨众。一切多是功德巍巍。智慧深远。具足威力成就神通。放大光明。遍照十方无量百千诸佛世界。乃至一切大威德天。及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。大小诸王皆悉充满。尔时文殊师利从座而起。整理衣服。偏袒右髆。右膝着地。合掌向佛白言世尊。我于今者。欲少咨问如来应供正遍觉所有心疑。未审世尊。见垂听不。佛告文殊师利。如来应供正遍觉。恣汝所问。当为汝释决汝所疑。令汝心喜。文殊师利言。唯然世尊。愿为宣说我当听受。文殊师利言。世尊。云何名为菩萨摩诃萨。言菩萨者义何谓也

佛告文殊师利。汝问云何为菩萨。菩萨有何义者。以能觉了一切法故。名为菩萨摩诃萨也。文殊师利。彼一切法菩萨觉者。所谓言说。文殊师利。菩萨云何觉一切法。所谓觉眼觉耳觉鼻觉舌觉身觉意。文殊师利。云何菩萨。觉眼觉耳。乃至觉意。文殊师利。所谓菩萨觉彼眼法本性空故。如是觉已。终不生念我能觉知。如是觉耳乃至觉意。皆本性空。如是觉已。亦不生念我能觉知。菩萨如是觉眼等已。复觉彼色本性自空。如是觉已。亦不分别我能觉知。如是觉声乃至觉法。皆本性空。亦不分别我能觉知。是为菩萨觉一切法也。复次文殊师利。云何菩萨觉彼五阴。所谓菩萨观见阴体本性自空。如斯觉故观无相。如斯觉故观无愿。如斯觉故观无欲。如斯觉故观寂静。如斯觉故观远离。如斯觉故观无所有。如斯觉故观无实。如斯觉故观无动。如斯觉故观无生。如斯觉故观无来。如斯觉故观无去。如斯觉故观无真。如斯觉故观无主。如斯觉故观无证。如斯觉故观无知。如斯觉故观无见。如斯觉故观无人。如斯觉故观无想。如斯觉故观不可说。如斯觉故。觉但有名。如斯觉故观无我。如斯觉故观分别起。如斯觉故观从缘生。如斯觉故观如幻。如斯觉故观如化。如斯觉故观如梦。如斯觉故观如镜像。如斯觉故观如声响。如斯觉故观如芭蕉。如斯觉故观不久住。如斯觉故观不牢固。如斯觉故观虚妄。如斯觉故观无物。如斯觉故。是为菩萨觉一切

法复次文殊师利。云何菩萨摩诃萨觉贪恚痴。所谓觉彼贪欲因分别起故。觉彼嗔恚因分别起故。觉彼愚痴因分别起故。而亦觉彼分别。空无所有。无物无戏论。不可说不可证故。是为菩萨觉一切法

复次文殊师利。云何菩萨摩诃萨觉于三界。所谓觉彼欲界无我人故。觉彼色界无所作故。觉无色界空无有故。觉彼三界皆远离故。是为菩萨觉一切法

复次文殊师利。云何菩萨摩诃萨觉众生行。所谓觉是众生贪欲行故。觉是众生嗔恚行故。觉是众生愚痴行故。觉是众生等分行故。如是觉已。如是证知。如是为说。如是教化众生。如是令得解脱。是为菩萨觉一切法

复次文殊师利。云何菩萨摩诃萨觉一切众生。所谓觉一切众生但有其名。离彼名已无别众生。是故一切众生即一众生。彼一众生即一切众生。如是众生即非众生。若能如是无分别者。是为菩萨摩诃萨觉一切法。又复云何。觉一切法。能如是觉菩萨道故。是为菩萨摩诃萨觉一切法。尔时世尊。重明此义。以偈颂曰

  觉眼及与耳　　自体常空寂
  不言我能觉　　是名为菩萨
  观鼻及与舌　　本性无所有
  不分别我觉　　是名为菩萨
  智慧观察身　　亦觉意自然
  觉已为他说　　是名为菩萨
  色声香味触　　意所乐诸尘
  觉知本性空　　是名为菩萨
  觉色及受想　　诸行与识心
  一切斯同幻　　是名为菩萨
  五阴聚如梦　　觉彼无一相
  不分别我知　　是名为菩萨
  不生亦不出　　无作复无言
  如是说唯名　　彼名亦非物
  觉贪欲嗔恚　　斯由分别起
  彼分别无体　　毕竟终自空
  痴亦分别生　　分别因缘生
  缘此生诸见　　诸见不可得
  觉察三界空　　一切无真实
  于彼不可动　　故名为菩萨
  欲界不成就　　皆缘分别起
  色有无色有　　一切不牢固
  众生之所行　　智者悉明了
  贪欲与嗔恚　　及彼愚痴等
  一切诸众生　　即彼一众生
  智者无所觉　　不念彼众生
  诸法之所起　　悉因颠倒生
  觉彼颠倒者　　知颠倒真相
  智慧甚微妙　　不取诸音声
  觉已无所著　　故名为菩萨
  能舍己肉身　　终亦无依止
  如是觉真实　　乃名为菩萨
  至持戒彼岸　　亦不念彼岸
  觉戒行法如　　无生亦无尽
  慈心遍众生　　不得众生相
  觉彼众生际　　但以假言宣
  勇猛大精进　　深心厌有为
  见三界空虚　　证无上等觉
  常入微妙禅　　无著无所依
  无住无攀缘　　智者定如是
  能以利智刀　　断除诸见缚
  观察法界性　　无割亦无伤
  若人真觉了　　一切法如实
  应时利众生　　乃名为菩萨

大宝积经卷第一百三大宝积经卷第一百四

        隋天竺三藏达摩笈多译

    善住意天子会第三十六之三破菩萨相品第六

尔时文殊师利白佛言。世尊。如佛所说。菩萨摩诃萨初发心者。以何义故名初发心。佛告文殊师利。若有菩萨。等观三界一切想生。如是得言最初发心。文殊师利。是名菩萨初发心也。文殊师利复白佛言。世尊。如我所解佛说义者。若有菩萨。贪欲心生是初发心。嗔恚心生是初发心。愚痴心生是初发心。世尊。所说将无谓是为初发心。尔时善住意天子问文殊师利言。大士。若诸菩萨。起贪恚痴名初发心者。所有一切具缚凡夫。皆即名为发心菩萨。所以者何。彼诸凡夫从昔至今。常发如是贪恚痴等三毒心故。文殊师利语善住意言。天子。汝言一切凡夫从昔已来常能发是三毒心者。是义不然。何以故。一切凡夫心力羸劣。不能发起是贪恚痴。唯有诸佛世尊。一切阿罗汉辟支佛。不退转地诸菩萨等。乃能发是贪恚痴耳。是故凡夫不能得发。善住意言。大士。仁今何故作如斯说。令此会众不识不知陷诸疑网。深可怖畏

尔时文殊师利语善住意言。天子。于意云何。如彼飞鸟往来空中。彼鸟足迹在虚空中。有发行乎无发行也。善住意言。非无发行。文殊师利言。如是如是。天子。以是义故。我作此说。若有能发贪欲恚痴。唯彼诸佛声闻缘觉不退菩萨。乃能发耳。天子当知。无有依处是名为发。无有取着是名为发。既无依处。又无取着。是即无句斯谓为发。是无分别句斯谓为发。是不可生句斯谓为发。是不实句斯谓为发。是非物句斯谓为发。是不来句斯谓为发。是不去句斯谓为发。是无生句斯谓为发。是无攀缘句斯谓为发。是无证句斯谓为发。是不诤句斯谓为发。是不思句斯谓为发。是不坏句斯谓为发。是无言句斯谓为发。是不破句斯谓为发。是无字句斯谓为发。是无执句斯谓为发。是无住句斯谓为发。是不取句斯谓为发。是不舍句斯谓为发。是不拔句斯谓为发。天子当知。是为菩萨初发心也。天子。发心菩萨。若于如是一切诸法。不爱着。不思想。不见不知。不闻不识。不取不舍。不生不灭。是则名为真发心也。天子。是菩萨摩诃萨。若能依止如是法界。如是平等。如是实际。如是方便。则彼贪欲嗔恚愚痴等发。又若决能如是依止。则彼眼耳及意等发。则彼色取乃至识取等发。如是则一切诸见发。无明有爱发。乃至十二因缘有分发。五欲众事发。爱着三界发。我见发。我所见发。我见为根本。六十二见发。佛想发。法想发。僧想发。自想发。他想发。地想发。水想发。火想发。风想发。空想发。识想发。四颠倒发。四识住发。五盖发。八邪发。九恼发。十恶业道发。天子当知。我今举要言之。一切分别。一切分别处。一切语言。一切诸相。一切进趣。一切希求。一切取着。一切思想。一切意念。一切障碍。菩萨皆当发。汝应如实知。天子。以是义故。汝今若能于此诸法。不爱着不思想者。是则名为真实发也。尔时世尊赞文殊师利言。善哉善哉。文殊师利。汝今乃能为诸菩萨。具宣如是初发心义。文殊师利。汝于往昔。已曾供养无量无边过恒沙数诸佛世尊。能说斯耳

尔时尊者舍利弗白佛言。世尊。今此文殊师利。所说菩萨最初发心。及获无生法忍。先后二事平等无差耶。佛告舍利弗。如是如是。如汝所说。舍利弗。昔然灯世尊。授我记言。摩那婆。汝于未来过阿僧祇劫。当得成佛号释迦牟尼如来应供正遍觉。舍利弗。我于彼时。亦不离此心得无生忍。如是舍利弗。汝当知彼一切菩萨初发心义。如文殊师利所言。无有异也。尔时文殊师利白佛言。世尊。如我解佛所说义者。皆是初发。何以故。如世尊说。一切初发皆是不发。其不发者。即是菩萨最初发心。说是法时。二万三千菩萨。证无生忍。五千比丘。于诸法中漏尽解脱。六十亿诸天子。远尘离垢得法眼净

尔时尊者大迦叶白佛言。世尊。今此文殊师利。乃更为斯能作难作。宣说如是甚深法门。令诸众生多所利益。文殊师利谓迦叶言。大德迦叶。我实不为难作之事。所以者何。一切诸法皆无所作。亦复无有已作今作当作。唯大迦叶。我于诸法。非作不作。其义亦尔。又大迦叶。我于众生。无有度脱。亦无系缚。所以者何。一切诸法无所有故。迦叶。云何于世尊前。发如是言能作难作。又大迦叶。我无所作。慎勿言我能作难作。又大迦叶。我实不作。非独我不作。如来亦不作。辟支佛亦不作。阿罗汉亦不作。又大迦叶有何等人。能作难作。若欲正言能作难作。但彼一切婴儿凡夫。如斯说者是名善说。所以者何。如诸如来。皆悉无有已得今得当得。乃至一切声闻辟支佛。亦无所得。唯彼凡夫一切皆得。时大迦叶。复白文殊师利言。大士。一切诸佛不得何等。文殊师利言。一切诸佛不得我。不得福伽罗。不得众生。不得寿命。不得士夫。不得断。不得常。不得诸阴。不得诸入。不得诸界。不得诸名色。不得欲界。不得色界。不得无色界。不得分别。不得思惟。不得念处。不得因生。不得颠倒。不得贪恚痴。不得此世。不得彼世。不得我。不得我所。乃至不得一切诸法。大德迦叶。如是一切诸法次第不得。亦复不失。不缚不解。不取不舍。不近不远。是故迦叶。应当觉了如是法门。若诸佛世尊皆不得者。则彼等非法无闻。凡夫一切斯得。是故凡夫能作难作。非诸佛作。非辟支佛作。非阿罗汉作。是乃名为凡夫作也。迦叶复问作何等也。文殊师利言。作断作常。作染著作依止。作忆念作取舍乃至作彼一切戏论。分别随顺高下等事。是故大德迦叶。如是诸法。诸佛世尊。皆无所作。无有已作今作当作。唯彼凡夫能作难作

尔时文殊师利复白佛言。世尊。所言无生忍者。云何名为无生忍也。世尊。复以何义。而更名为法无生忍。菩萨云何得斯忍法。佛告文殊师利言。实无有人于生法中得无生忍。所言得者。但有语言名字。何以故。以无生法不可得故。离攀缘故。不得法忍。得无所得无得无失。是故言得无生法忍。复次文殊师利。彼无生法忍者。所谓一切法无生如是忍故。一切法无来如是忍故。一切法无去如是忍故。一切法无我如是忍故。一切法无主如是忍故。一切法无取如是忍故。一切法无舍如是忍故。一切法无所有如是忍故。一切法无实如是忍故。一切法无等如是忍故。一切法无等等如是忍故。一切法无比如是忍故。一切法无染如虚空如是忍故。一切法无破坏如是忍故。一切法无断如是忍故。一切法无垢如是忍故。一切法无净如是忍故。一切法空如是忍故。一切法无相如是忍故。一切法无愿如是忍故。一切法离贪恚痴如是忍故。一切法如如如是忍故。一切法法性如是忍故。一切法实际如是忍故。如是一切法。无分别。无相应。无忆念。无戏论。无思惟。无作无力。羸劣虚诳。如幻如梦。如响如影。如镜像如芭蕉。如聚沫如水泡。如是忍故。所可忍者。亦无可忍。非法非非法。但以名字说斯法耳。然彼名字亦不可得。本性自离如是言忍。信解乐入。无惑无疑。无惊无怖。无动无没。遍满身已。正受而行。不得其身。亦无住处。文殊师利。是为菩萨摩诃萨于诸法中得无生忍。乃至不行一切想故

尔时文殊师利复白佛言。世尊。所谓忍者。云何为忍。乃至不为境界所坏。故名为忍。时彼善住意天子。问文殊师利言。大士何等不为境界所坏。文殊师利言。天子。所谓眼何法坏眼。谓彼善色恶色是能坏眼如色坏眼。彼声坏耳。乃至法坏意亦如是。天子。若菩萨眼见色。不取相不耽好。不分别不思惟。不爱不厌。知本性空。无有念想。不为众色之所伤败。乃至意法亦如是。天子。若其六情。无著无缚无坏无伤。如是菩萨住于法忍。住法忍故。于一切法无所分别。无生不生。无漏不漏。无善不善。无为不为。不念世法及出世法。不分别不思惟。是则名为无生法忍。说此法时。有六万三千众生。发阿耨多罗三藐三菩提心。一万二千菩萨。得无生法忍

尔时善住意天子。复白文殊师利言。大士云何。菩萨摩诃萨发起胜行。超越转增入诸地也。文殊师利言。天子。谁于其间能发胜行。而言诸地有超转者。善住意言。大士。仁岂不知诸菩萨等所行殊胜彼彼转增。乃至超越能满十地乎。文殊师利语善住意言。不然天子。我闻佛说一切诸法犹如幻化。汝不信耶。善住意言。大士。世尊诚言谁敢不信。文殊师利言。天子。如彼幻人及幻。岂有胜行超越转入。乃至具足十地耶。善住意言。不也大士。文殊师利言。如是天子。若使幻人及幻能有超行转入者。则吾等亦当如是超越转入。何以故。如世尊说。一切诸法皆如幻化故无转入。天子。是故若说诸地有转入者。即非转入。我亦不言地有转入。所以者何。一切诸法无转入故。是故法于法中不得转入。所谓色于受中不得转入。受于色中不得转入。想于行中不得转入。行于想中不得转入。识于色中不得转入。色于识中不得转入。天子。如是乃至于一切法。皆应如是作四句说

又眼不于耳中转入。耳不于眼中转入。鼻不于舌中转入。舌不于鼻中转入。身不于意中转入。意不于身中转入。所以者何。一切诸法。其性各异。行自境界。顽痴无知。无有觉识。亦如草木墙壁瓦石。如镜中像。如幻如化。不可证触。一相无相。以是义故。一切诸法无有超转。不出不入。无去无来。天子当知。若诸菩萨。如是解知彼一切法无超转者。不复更有诸地分别。亦无入道。无有舍地。亦无退转。于彼菩提超转之中。无有失灭。何以故。若人见彼阴界诸入是真实者。彼无超转。所以者何。以一切法性本净故。天子。是名菩萨超越道地。天子。譬如幻师化作十重辇舆宫阁。即令化人居处其内。天子。于意云何。彼人宫阁有定所不。善住意言。无也大士。文殊师利言。如是如是。天子。见菩萨地有超转者。其事若此

    破二乘相品第七之一

尔时善住意天子。复问文殊师利言。大士。或时有人至大士所求出家者。大士尔时当云何答。云何为说出家度法。云何授戒及教持戒。文殊师利言。天子。若其有人。来至我所求出家者。我当教彼如是言曰。诸善男子。汝今不应发出家心。汝若不发出家心者。我当教汝真出家法。所以者何。天子若求出家。则求欲界。亦求色界。求无色界。复求世间五欲之乐。及求未来果报诸事。若善男子有所求者。彼不证法。不证法故彼则见心。是故天子。若无所取。彼为证法。以证法故则不见心。不见心故则不出家。不出家故则无出家心。无出家心故彼则不发。以不发故则无有生。以无生故彼则尽苦。以尽苦故则毕竟尽。毕竟尽故彼则无尽。以无尽故则不可尽。不可尽者。则是虚空。天子。我时于彼善男子所。作如是教。复次天子。若复有人。来诣我所求出家者。我复教彼如是言曰。诸善男子。汝今莫发出家之心。所以者何。彼心无生不可得发。汝莫为异而保此心。复次天子。若更有人。来诣我所求出家者。我复教彼如是言曰。诸善男子。汝今若不断除须发。如是汝则真实出家

尔时善住意天子。复白文殊师利言。大士。以何义故作如斯说。文殊师利言。天子。世尊说法无所断除。善住意复问言。何等不断亦复不除。文殊师利言。天子色法不断亦不除。受想行识。不断亦不除。天子。若复有人作如是念。我除须发乃为出家。当知彼人则住我相。住我相故则不见平等。又见我故则见众生。见众生故则见须发。见须发故生剃除想。天子。彼若不见有我相者。则不见他相。无他相故则无我慢。无我慢故则无吾我。无吾我故则无分别。无分别故则无动摇。无动摇故则无戏论。无戏论故则无取舍。无取舍故无作不作。无断不断。无离无合。无减无增。无集无散。无思无念。无说无言。如是则名安住真实。善住意言。大士。实义云何。文殊师利言。天子。所言实者即是虚空。如是虚空得名为实。无起无尽。无减无增。以是故言虚空为实。性空为实。如如为实。法界为实。实际为实。如是实者。则亦不实。何以故。以彼实中不可得故。名为不实

尔时文殊师利语善住意言。天子。若复有人。来诣我所求出家者。我当教彼如是言曰。诸善男子。汝今若能不取着彼袈裟衣者。吾则以汝为真出家。善住意言。大士。以何义故复如斯说。文殊师利言。天子。诸佛世尊无有取法。凡所宣说不为取着。善住意言。不取何等。文殊师利言。天子。谓不取色若常无常。乃至不取识若常无常。不取眼若常无常。乃至不取意若常无常。不取色乃至不取法。不取贪欲不取嗔恚。不取愚痴不取颠倒。天子。如是乃至一切诸法。皆悉不取而亦不舍。不合不离。天子。若取袈裟。当知彼即大有见相。天子。是故我说不以取着袈裟。而得清净及得解脱。所以者何。天子。诸佛世尊。大菩提处无有袈裟。善住意言。大士。何法是袈裟。文殊师利言。天子。汝问何法为袈裟者。贪欲是袈裟。嗔恚是袈裟。愚痴是袈裟。因是袈裟。诸见是袈裟。名色是袈裟。妄想是袈裟。执着是袈裟。取相是袈裟。语言是袈裟。如是乃至戏论一切诸法。皆是袈裟。若知诸法无善不善。无思无念。是名无袈裟。若无袈裟则无所有。若无所有则无垢浊。若无垢浊则无障碍。无障碍故亦无有作。是谓思量。善住意言。大士。所言思量。思量者。以何义故名曰思量。文殊师利言。天子。彼思量者。于法平等无有增减。无作不作故言思量。天子。若能于法不作增减。如世尊说。不应复起想念分别。故言思量。善住意言。何等名为不作增减。文殊师利言。天子。过于平等。过平等已。法不可得。所谓过去不可得。未来不可得。现在不可得。彼法非如。无增减作。无吾我作。无有人作。无众生作。无寿命作。无有断作。无有常作。无有分别阴入界作。无有分别佛法僧作。亦无有念是持戒作。是破戒作。是烦恼作。是清净作。是得果作。是须陀洹作。是斯陀含作。是阿那含作。是阿罗汉作。是辟支佛作。乃至此是空作。是无相作。是无愿作。是明解脱作。是离欲作。如是天子。此皆为彼无闻凡夫。思量分别说斯法耳。汝应当知。此是最下痴人。求欲得法妄想取着。是故如来为断彼着。而演说是思量分别作不作事

于是善住意天子赞文殊师利言。善哉大士。快说如是甚深法门。尔时世尊亦复赞可。文殊师利言。善哉善哉。文殊师利。汝今乃能作如是说。尔时文殊师利复语善住意言。天子。若复有人来诣我所求出家者。我当教彼作如是言。诸善男子。汝今若能不受具戒。如是则名真出家也。善住意言。大士。以何义故。作如是语。文殊师利言。天子。如世尊说。唯有二种受具戒法。何等为二。一受正平等戒。二受邪不等戒。是中何者邪不等戒。谓堕我见堕人见堕众生见。堕寿命见堕士夫见。堕断见堕常见。堕邪见堕憍慢。堕贪欲堕嗔恚堕愚痴。堕欲界堕色界堕无色界。堕取着分别。天子。是为略说。堕于一切不善法中。堕逐恶知识。妄取一切法。堕不知出要解脱之处。天子当知。是名受邪不等戒也。天子。是处何者是受正平等戒。谓空是平等。无相是平等。无愿是平等。天子。若能如是入三解脱门。如实觉知。不分别不思念。于一切法无有退转。天子。是名受正平等戒也。复次天子。若贪欲发。若嗔恚发。若愚痴发。若爱无明发。我见发。我见为根本。六十二见发。三邪行发。四颠倒发。乃至八邪九恼十不善业道等发。故名受正戒也。天子。譬如一切种子草木树林。皆依大地而得生长。其地平等无心念作。如是天子。若佛法中正受戒故。具足成就。天子。譬如一切草木种子。依大地住而得增长。天子。当应如是具受正戒。所以者何。住于戒故道法增长。如彼种子戒亦复然。又如种子增长得名成就。如是住于戒故。所有一切助菩提分法。出生增长得名成就。天子。是为过去未来现在诸佛世尊一切声闻受正戒也。所谓入彼三解脱门一切戏论语言灭处。天子当知。若能如是受具戒者。是名受正非不正也。尔时文殊师利复语善住意天子言。天子。我今更于如是出家如是受具。如是教曰。诸善男子。汝今若能不持禁戒。如是则为真实持也。善住意言。大士。以何义故作如斯说。文殊师利言。天子。一切诸法悉无所取。故无可持。云何此戒而独有持。天子。戒若可持则持三界。天子。于汝意者以何为戒。善住意言。大士。若能具足波罗提木叉者。是名为戒。文殊师利言。天子。云何名为波罗提木叉。善住意言。大士。所谓持身及以口意三业具足。是则名为波罗提木叉也。文殊师利言。天子。于意云何。今是现前。何处有是身业可作。如是过去未来亦无有作。彼皆无作。无有像貌可得言有。或青或黄或赤或白及颇梨色耶。善住意言。不也大士。文殊师利言。天子。彼名何等云何而说。善住意言。彼名无为实不可说。如是乃至意作亦然。文殊师利言。天子。于意云何。彼无为者可作有为乎。善住意言。不也大士。文殊师利言。天子。以是义故我如斯说。彼若不持名真持戒。天子。若言增上戒学。增上心学增上慧学者。为学实际。当如是知。无所持故言增上戒学。无所知故言增上心学。无所见故言增上慧学。如是心不分别故。不忆念故。不生殊异故。名最上心学。如心学戒慧亦尔。天子。若不得心则不念戒。若不念戒则不思慧。若不思慧。则无复起一切疑惑。既无疑惑则不持戒。若不持戒。是则名为真持戒也。天子当知。彼持戒者则无所欲。无所欲故则无退还。无退还故彼则清净。彼清净故则得解脱。彼解脱故则得精进。彼精进故则无有漏。彼无漏故则住正行。住正行故则无像貌。无像貌故即是虚空。何以故。以彼虚空无形相故。是故天子。若有人能如是学者。则为不学。彼无学故则为真学。于何处学谓无处学。云何无处。谓空平等。天子若能正住空平等者。是则名为真住戒学

尔时文殊师利复语善住意天子言。天子。若人能作如是出家如是受具。我复教彼如是言曰。诸善男子。汝今若能受彼一切三千大千世界笃信檀越供养众具。而能于中不起分别不念报恩。是乃名为清净持戒。善住意言。大士。以何义故作如斯说。文殊师利言。天子。所谓若人取彼施者受者财物三事故。是为报恩。又若见彼是为报恩。若思惟彼是为报恩。若分别彼是为报恩。天子。若不见彼不取彼。不思惟彼不分别彼者。有何可报。何以故。以从本来毕竟清净。如是报故。天子彼若取若见。若思惟若分别及念报者。是谓凡夫。非阿罗汉。所以者何。是诸凡夫。于一切时常行取着。思量分别此受彼与。彼垢此净。以是分别故有报恩。云何报恩。谓诸凡夫。于生死有取后生身。是故于彼欲行报恩。天子。诸阿罗汉不受后有。毕竟不见。不思量不分别。无有此彼。更不受身。当于何处而报恩也。天子。若受彼施当行三净然后乃受。何谓三净。一不见己身即无施者。二不见他人即无受者。三不见财物即无施事。天子。如是三净则毕竟净。如斯净已复何用报。天子。以是义故我如是说。若受三千大千世界笃信檀越一切众具。不分别不念报者。是名世间真胜福田。是真出家。是净持戒

尔时文殊师利复语善住意天子言。天子。我与彼人如是出家。如是戒已。当复教言。诸善男子。汝今若能不行阿兰拏。不在聚落。不处近不住远。不独坐不众居。不多言不杜默。不乞食不受请。不事粪扫衣不受他衣钵。不多贪不少欲。不多求不知足。不树下不露地。不服腐烂药不受肉与苏。善男子。汝若能于一切头陀不起分别。如是行者。则名具足行头陀也。何以故。若以忆念分别行者。即是我慢心见诸相。天子。若如是行则如是念。我受粪扫衣。我行乞食。我住树下。我坐露地。我行阿兰拏。我服腐烂药。我少欲。我知足。我行头陀。天子。若正行者不生如是念。所以者何。为彼无有一切分别故。彼于尔时尚不见我。况当计有头陀功德。若见有者无有是处。天子。是故若有如是行头陀。不忆念不分别。我则说为真头陀也。何以故。天子若斯人者。拂去贪欲。拂去嗔恚。拂去愚痴。拂去三界。拂去五阴。拂去十二入。拂去十八界。如是我说为真头陀。何以故。以彼头陀。不取不舍。不思不念。不修不行。非法非非法。是故我说真头陀也

尔时文殊师利复语善住意天子言。天子。我与彼人如是出家。如是行已。当复教言。诸善男子。汝今若能不观四圣谛。不修四念处。不修四正勤。不修四如意足。不修五根。不修五力。不修七觉分。不修八圣道。不修三十七助菩提法。莫证三解脱门。何以故。天子。彼圣谛者入无生相。不可念知不可修证。所以者何。彼无生中云何言证。天子。是故我言夫念处者。非念非思。一切诸法故言念处。天子。若比丘不住欲界。不住色界。不住无色界。故言比丘。不住四念处。思修四念处。云何思修如彼。不思不修故言思修。如是次第。乃至三十七种助菩提法。应如是知。天子。若彼禅行比丘。于一切法悉无所得。无所得故不思念。不分别。不修不证。何以故。天子。彼诸法但有名。如三十七助菩提法。彼虽有名而不可得。唯以分别因缘故生。一相无相。以如是名故如是说。其说亦无。故彼虽复名字证知。终不可得。是则名为如实觉知三十七种助菩提法。时彼善住意天子。复白文殊师利言。大士。所言禅行比丘。何等名为禅行比丘耶。文殊师利言。天子。若彼比丘。于一切法但取一行。极随顺者。所谓无生。是为禅行。又复无有少法可取。是为禅行。又不取何法。所谓不取此世彼世。不取三界。乃至不取一切诸法。如是平等。是为禅行。天子。如禅行者。乃至无有一法相应。无合无散。是为禅行

尔时彼会大众。多有无量百千众生。咸有疑心。今此文殊师利。所说如是。云何得与圣说相应。所以者何。世尊恒说。若人能入三解脱门。名为涅槃。又如佛说。若有修行三十七种助菩提法。便证涅槃。然而今者。文殊师利。更如是说不应修。是助菩提行。亦莫入彼三解脱门。将非文殊师利虚妄说耶。于是文殊师利知诸比丘及以众会咸皆有疑。即语尊者舍利弗言。大德。汝于今者。最可证信世尊记。汝智慧第一。大德。汝于何时证离欲法。且当证法时。岂不见四谛耶。舍利弗言不也。岂不修三十七助菩提分法耶。曰不也。岂不入三解脱门耶。曰不也。大士。我于尔时乃至无有一法可见可除可修可证可选择者。所以者何。一切诸法。无为无生无言是空。若是空者。有何可证。说此法时。众中有三万比丘。于法漏尽心得解脱

大宝积经卷第一百四大宝积经卷第一百五

        隋天竺三藏达摩笈多译

    善住意天子会第三十六之四破二乘相品第七之二

尔时善住意天子赞文殊师利言。善哉善哉。大士。仁今真是聪辩利智。快说如斯甚深空忍。文殊师利言。天子。我非如是聪辩利智。夫利智者。则是一切婴儿凡夫。何以故。天子。一切凡夫是名利智。何等利智。所谓地狱利智。畜生利智。饿鬼利智。阎摩利智。乃至三界一切利智。如是取着相应得言利智。所以者何。不知生死烦恼先际故。天子。是故彼诸凡夫。着贪欲利。着嗔恚利。着愚痴利。乃至与彼诸见名色取着相应故言利智。非谓诸佛世尊及声闻缘觉得忍菩萨。有斯利智。是乃名为一切凡夫取相利智也。于是善住意天子复问文殊师利言。大士。仁今所说欲显智耶。文殊师利言不也。善住意言。欲随行耶。文殊师利言不也。善住意言。欲随句耶。文殊师利言。如是如是。天子。我由字句。善住意言。大士。仁今何故如斯说耶。文殊师利言。天子。若诸菩萨。于一字一句初不移动。然彼字句义门处所。近远浅深皆如实知。谓知空处。知无相处。知无愿处。知远离处。知无所有处。知无生处。知如如处。而于其间。无受无作。无解无知。是故得言唯字句耳。尔时世尊赞文殊师利言。善哉善哉。文殊师利。汝今已得陀罗尼故。乃能如是分别说也。文殊师利白佛言。世尊。我实不得彼陀罗尼。何以故。世尊。若有得是陀罗尼者。斯则名为愚痴凡夫。非佛世尊及诸菩萨得陀罗尼。所以者何。世尊。彼诸凡夫痴众生等。有取着故得陀罗尼。取着何等。所谓取着我故得陀罗尼。取着人故得陀罗尼。取着寿命故得陀罗尼。取着丈夫故得陀罗尼。取着断灭故得陀罗尼。取着常恒故得陀罗尼。取着贪欲故得陀罗尼。取着嗔恚故得陀罗尼。取着愚痴故得陀罗尼。取着无明故得陀罗尼。取著有爱故得陀罗尼。取着身见故得陀罗尼。取着五阴故得陀罗尼。取着十二入故得陀罗尼。取着十八界故得陀罗尼。取着忆念故得陀罗尼。取着分别故得陀罗尼。取着六十二见故得陀罗尼。如是乃至。取着一切诸行故得陀罗尼。是故凡夫得陀罗尼。所以者何。若法为彼愚痴取着。是则凡夫所得。非谓佛得。非声闻得。非辟支佛得。非菩萨得。以是义故。唯彼凡夫得陀罗尼。何以故。彼诸凡夫。以愚痴故言有取得。非佛世尊及菩萨等

尔时善住意天子。复白文殊师利言。大士。仁若不得陀罗尼者。将无堕彼顽钝位乎。文殊师利言。如是天子。我真顽钝。何以故。夫顽钝者。谓无所知。我所行处不可知故。是故一切诸佛世尊及诸声闻缘觉菩萨。皆堕顽钝。非诸凡夫。所以者何。一切凡夫在于数中。诸余智人尽入顽钝。如须陀洹障碍行故。贪欲心行尚堕数中。何况愚痴诸凡夫等而非数也。天子。是故得言我为顽钝。我实不得彼陀罗尼。何以故。乃至一法我无所得故。说是法时。彼大众中有五百比丘。闻此法门不能信受。生大恐怖起诽谤心。发恶心已弃舍而去。即自见身堕大

地狱尔时尊者舍利弗白文殊师利言。大士。仁今且住。勿说如此甚深经典。所以者何。今此会中五百比丘闻此法门。不能信受生大怖畏起诽谤心。即自见身已处地狱。文殊师利语舍利弗言。舍利弗。汝今不当妄起分别。何以故。乃至无有一法堕地狱者。所以者何。一切诸法无所生故。汝今云何忽发斯言。令我休止勿宣是法。舍利弗。若善男子善女人。依止我见。依止人见。依众生见。依寿者见。依诸见已。虽复供养恒沙如来应供正遍觉及比丘僧一切众具随须奉给。如是供养尽其形寿无有休废。若复有人闻我所说甚深法门。一切世间所不能信。谓空无相无愿无作。宽大寂静。无生无灭。无我无人。无众生无寿命。无常苦无我。如是诸法。闻已诽谤堕于地狱。然舍利弗。即此善男子善女人。得闻如是甚深法已。虽堕地狱。从地狱出速得涅槃。若善男子善女人。虽复供养恒沙数如来应供正遍觉。以取着我不闻如是甚深经法。终不解脱速证涅槃

尔时世尊赞文殊师利言。善哉善哉。文殊师利。如是如是。诚如汝言。若有得闻如是甚深微妙经典。与值佛出世等无有异。何以故。若有欲证须陀洹果。要由此经。欲证斯陀含。欲证阿那含及阿罗汉。要闻此经。所以者何。以不着我乃能证法。证此法时无有所见。无所得故。尔时世尊告尊者舍利弗言。舍利弗汝当知。此五百比丘。虽堕地狱后从狱出速证涅槃。非彼愚痴凡夫之人。没于见得堕坠疑心。供养如来能得解脱。舍利弗。是诸比丘还复因此乃至解脱速得涅槃。非是余人能速解脱。所以者何。以不闻此深法门故。舍利弗。若有善男子善女人。得闻如是甚深法门。一经于耳虽不信受堕于地狱然速解脱。其有堕见入地狱者未能解脱

    破凡夫相品第八

尔时善住意天子复白文殊师利言。大士。仁今许我修梵行乎。文殊师利言。如是天子。汝今若能不念作求。不思进趣。如是吾将许汝梵行。善住意言。大士。以何义故如斯说耶。文殊师利言。天子。若有为作可名梵行。若无为作何名梵行。又复天子。若有见得可名梵行。若无见得何名梵行。善住意言。大士。仁今宁当无梵行耶。文殊师利言。如是如是。天子。我无梵行。所以者何。夫梵行者则非梵行。非梵行故我名梵行。时善住意天子赞文殊师利言。善哉善哉。大士。仁以具足乐说辩才。能作如是无障碍说。文殊师利言。天子。若吾具足无碍辩者。即成障碍。何以故。凡是取着我及我所皆由分别。一切分别无非障碍故

尔时文殊师利复语善住意天子言。天子。汝今若能断除一切众生命根。然不执刀不持杖。不把棓不捉块。而行事者。吾当同汝修于梵行。善住意言。大士。复以何义如斯说耶。文殊师利言。天子。言众生者于意云何。善住意言。大士。我言众生。众生者乃至一切但有名字。皆想取故。文殊师利言。天子。是故我言汝今当须杀害我想。杀害人想。杀众生想。杀寿命想。乃至灭除名字等想。如斯杀也。善住意言。大士。当以何杀具而行杀乎。文殊师利言。天子。吾常用彼利智慧刀而行杀害。当行杀时。彼利智刀应如是执。当如是害。然亦无有执持之想及以害想。天子。以是义故。汝当善知杀害我想及众生想。是名真杀一切众生。如是吾当许汝梵行

尔时文殊师利复语善住意天子言。天子。我复语汝。汝若修行十恶业道。复能成就黑浊垢法。放损一切十善业道。破坏离散清白法者。我当共汝修于梵行。善住意言。大士。以何义故复如是说。文殊师利言。天子。所有一切染浊清白。皆悉平等。彼平等者。我得如此同汝梵行。天子。于意云何。汝以何法为染浊平等。善住意言。以不贪不作不退不堕。是谓染浊平等。文殊师利言。天子。复以何法为白净平等。善住意言。以如法性及与实际三解脱门。是谓白净平等。文殊师利言。天子。吾即令汝真法界中具足修行周旋往返。其事可乎。善住意言。不也大士。文殊师利言。天子。以是义故我作斯说。染浊清白一切等者。然后方可共修梵行

尔时文殊师利复语善住意天子言。天子。汝今若能取应死人。手执利刀斩其头者。吾当许汝如是梵行。善住意言。大士。以何义故复作此说。文殊师利言。天子。可杀者谁。何者是头。谁能行杀。天子。汝今当知。须杀贪欲。须杀嗔恚。须杀愚痴。如是乃至我慢嫉妒。欺诳谄曲。执着取相。及受想等。天子。是为可杀。天子。若人一心专精自守。贪欲心发。即应觉知。方便散除还令寂静。云何散除。应作是念。此是空此不净。求此欲心生处灭处。从何所来去至何所。是中谁染谁受染者谁为染法。如是观时。不见能染不见所染不见染事。以不见故则无有取。以不取故则无有舍。以不舍故则无有受。不舍不受。则名离欲寂灭涅槃。如是乃至。一切受心亦如是说。天子当知。如是杀法。即杀即生。是故得言彼行杀时先斩其头。是为真杀。以是义故我如此说

尔时文殊师利。复语善住意天子言。天子。汝今若能违背诸佛。毁谤法僧。吾将同汝如是梵行。善住意言。大士。仁今何故复如是说。文殊师利言。天子。如汝意者以何为佛。善住意言。大士。如如法界我言是佛。文殊师利言。天子。于意云何。如如法界可染着乎。善住意言。不也大士。文殊师利言。天子。以是义故我如是说。汝今若能毁谤诸佛。吾将同汝如是梵行。文殊师利言。天子。如汝意者以何为法。善住意言。大士。离欲寂静我名为法。文殊师利言。天子。于意云何。彼寂静法可染着乎。善住意言。不也大士。文殊师利言。如是天子。以此义故我如是说。汝今若能诽谤正法。吾将同汝如是梵行。文殊师利言。天子。如汝意者以何为僧。善住意言。大士。无为法者是名圣僧。如世尊说一切圣人以无为得名。故无为法名声闻僧。文殊师利言。天子。于意云何。是无为法可执着乎。善住意言。不也大士。文殊师利言。如是天子。以此义故我如是说。汝今若能破坏圣僧。吾将同汝如是梵行。文殊师利言。天子。若人见佛彼则着佛。若人见法彼则着法。若人见僧彼为着僧。何以故。以佛法僧非可得故。天子。若人不见佛不闻法不识僧者。彼为不背佛不谤法不破僧。何以故。以其不得佛法僧故。天子。若人爱佛爱法爱僧。彼为染着佛法及僧。天子当知。若人不着佛法僧者。是则名为离欲寂灭。天子。以此义故我如是说。汝今若能于佛法僧不染著者。我则同汝如是梵行

尔时善住意天子。复白文殊师利言。大士。希有希有。今日乃能宣说如是甚深义处。我于大士以何报恩。文殊师利言。天子。汝莫报恩。善住意言。大士。我今云何得不报也。文殊师利言。天子。汝莫报恩。所以者何。天子。汝能如是不报恩者。即为报也。善住意言。大士。仁今宁可无报恩乎。文殊师利言。天子。如是如是。我不报恩亦非不报。善住意言。大士。仁以何义更作是说。文殊师利言。天子。凡愚之人造种种法。起种种见。行种种行。以作如是种种见行。是故念言我当报恩。天子。此非正行善男子也。其有正行善男子者。乃至无有少作。或作不作。彼终不言我念报恩。又复天子。不报恩者。如佛世尊宣说平等。谓一切法悉无所作。无有作处。皆入平等。无有转还。亦无超越。非自非他。无作不作。是故我为无报恩也

尔时善住意天子。复白文殊师利言。大士。仁住何处作如是说。住忍说乎。住法说也。文殊师利言。天子。我所住者非忍非法。善住意言。大士。实住何处故如是说。文殊师利言。天子。我无所住。如化人身。我如是住。善住意言。大士。彼化人者复依何住。文殊师利言。天子。如如如住。化如是住。天子。若如是者。汝云何言住在何处。为忍为法。如斯问也。天子。是故我所言忍。但有其名名无住处。法亦如是无有住处。无有动转。亦无分别。天子当知。一切诸法悉无住处。而言住者。是谓如来为诸众生作如是说。所以者何。如佛所说。如来住彼如如法中。一切众生亦复如是。住于如如初不移动。如众生如即如来如。如来如即众生如。众生如来无二无别

尔时善住意天子。复白文殊师利言。大士。所言沙门那。沙门那者义何谓也。文殊师利言。天子。若非沙门。非婆罗门。是则名为真沙门也。所以者何。以彼不着欲界。不着色界。不着无色界。是故我言真沙门也。天子。若眼不漏。耳不漏。鼻不漏。舌不漏。身不漏。意不漏者。我复说为真沙门也。天子。若不依止说。不依止证。不依止处者。我复说为真沙门也。天子。若无去处无来处无伤无疮者。我复说为真沙门也。天子。是以彼句非沙门。非婆罗门。我乃说为真沙门也

尔时善住意天子。赞文殊师利言。善哉善哉。大士。实未曾有。仁者。志若金刚。其所宣说无有章句。亦无处所。心咸了达无所遗余。文殊师利言。天子。我心不刚。所以者何。吾自放意心安柔忍。是故不刚。善住意言。大士。是义云何。文殊师利言。天子。吾以恣心入声闻地处缘觉境。是谓放心。吾又恣心入诸尘劳生死之内。而亦不恶贪恚痴等烦恼过患。是谓放心。时善住意天子。复赞文殊师利言。善哉善哉。希有大士。仁由过去久供诸佛殖众德本。故能宣说妙若斯也。文殊师利言。天子。吾无供佛不殖善根。所以者何。吾初不见宿昔所更。又亦不知当来所作。虽有所作亦无有作。于诸佛法未曾建立。云何能有殖众德本

    神通证说品第九

尔时善住意天子。复白文殊师利言。大士。我昔曾闻如幻三昧。唯愿垂慈显此正受。文殊师利言。天子。汝欲见闻如幻三昧甚深境界乎。善住意言。大士。我诚愿见。时文殊师利。如言即入如幻三昧。应时十方如恒沙等诸佛国土。一切境界自然现前。于是善住意天子。悉见东方恒沙佛土。其中所有种种众事。或见比丘称扬宣说如是经典。或见比丘尼像。或见优婆塞优婆夷像。或见大梵天王天帝释四天大王。或见人间转轮圣王。或见一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。乃至或见一切鸟兽。种类若干形貌好丑。皆为说法。如此东方。南西北方四维上下一切十方。咸有如是恒河沙等诸佛国土所有事业。亦皆如是等无有异。尽是文殊师利威神力也。时善住意天子。既见如是十方佛土一切境界。欢喜踊跃不能自持。于是文殊师利从三昧起。善住意天子一心敬仰。白文殊师利言。大士。向见十方诸佛国土无量境界。佛事亦殊。而各宣说如斯经典

尔时文殊师利问善住意天子言。天子。于意云何。汝向所见。东方所有一切境界可谓实乎。善住意言。不也大士。文殊师利言。如此东方及余九方。如是十方所有境界。复为实乎。善住意言。大士。一切皆虚无有实也。所以者何。一切诸法本无有生。其犹幻化欺诳世间。一切诸法转变推移。无常存者皆是虚妄显现所为。穷其体实了不可得。不作不生不起不灭。于是文殊师利赞善住意言。善哉善哉。天子。诚如汝言

尔时会中有五百菩萨。已得四禅成就五通。然是菩萨依禅坐起。虽未得法忍亦不诽谤。时诸菩萨宿命通故。自见往昔所行恶业。或杀父杀母杀阿罗汉。或毁佛寺破塔坏僧。彼等明见如是余业。深生忧悔常不离心。于甚深法不能证入。我心分别彼罪未忘。是故不能获深法忍

尔时世尊为欲除彼五百菩萨分别心故。即以威神觉悟文殊师利。文殊师利承佛神力从座而起。整理衣服偏袒右髆。手执利剑直趣世尊。欲行逆害时。佛遽告文殊师利言。汝住汝住。不应造逆。勿得害我。我必被害为善被害。何以故。文殊师利从本已来。无我无人无有丈夫。但是内心见有我人。内心起时。彼已害我。即名为害。时诸菩萨闻佛说已。咸作是念。一切诸法悉如幻化。是中无我无人无众生无寿命。无丈夫。无摩奴阇。无摩那婆。无父无母。无阿罗汉。无佛无法无僧。无有是逆。无作逆者。岂有堕逆。所以者何。今此文殊师利。聪明圣达智慧超伦。诸佛世尊称赞。此等已得无碍甚深法忍。已曾供养无量百千亿那由他诸佛世尊。于诸佛法巧分别知。能说如是真实之法。于诸如来等念恭敬。而忽提剑欲逼如来。世尊遽告且住且住。文殊师利汝无害我。若必害者。应当善害。所以者何。是中若有一法和合集聚。决定成就。得名为佛名法名僧。名父名母名阿罗汉。定可取者。则不应尽。然而今此一切诸法。无体无实。非有非真。虚妄颠倒空如幻化。是故于中。无人得罪。无罪可得。谁为杀者而得受殃。彼诸菩萨如是观察明了知已。即时获得无生法忍。欢喜踊跃。身升虚空高七多罗树。以偈叹曰

  诸法如幻化　　斯由分别起
  是中无所有　　一切法皆空
  颠倒虚妄想　　愚痴取我心
  计念我昔愆　　所作业中甚
  过去为大逆　　杀父母良田
  杀罗汉比丘　　是为极重恶
  以彼恶业故　　我当受大苦
  没疑网众生　　闻法悔或除
  大名拔我毒　　破散我疑心
  我已觉法界　　众恶无所有
  诸佛巧方便　　善知我等意
  方便度众生　　为解诸疑缚
  何处有诸佛　　法僧亦复然
  父母本自无　　阿罗汉空寂
  是处无有杀　　云何有业果
  如幻无所生　　诸法性如是
  文殊大智人　　深达法源底
  自手握利剑　　驰逼如来身
  如剑佛亦尔　　一相无有二
  无相无所生　　是中云何杀

说此执剑妙法门时。十方如恒沙等诸佛世界。六种振动。时彼十方诸佛世界。一切诸佛现前说法。彼佛侍者。各于本国大众会中。从座而起。咸请其佛言。世尊。今此神变是谁威德而令世间大地振动。时十方诸佛各各告其弟子曰。诸善男子。今有世界名曰娑婆。彼土有佛号释迦牟尼如来应供正遍觉。现在说法。然彼世界有一上首菩萨摩诃萨名文殊师利。久已不退于阿耨多罗三藐三菩提。为欲破坏新学菩萨执着心故。躬秉利剑驰走趣彼释迦如来。显发深法。以是因缘故。令大地如是振动。彼佛世尊因智剑故说甚深法。复令无量无边阿僧祇众生。法眼清净心得解脱证深法忍安住菩提

尔时世尊建立如是大神变时。以方便力。令彼众中一切诸来新学菩萨。善根微少。未离分别取相众生。皆悉不睹彼执剑事。亦不得闻其所说法。尔时尊者舍利弗白文殊师利言。大士。仁今已造极猛恶业。欲害如是天人大师。是业若熟当于何受。时文殊师利告舍利弗言。如是大德如汝所说。我今唯能造作如是极重恶业。而实不知于何处受。然舍利弗。如吾见者。当若化人幻业熟时我如斯受。所以者何。彼幻化人无心分别无有念想。一切诸法皆幻化故。又舍利弗。我今问汝随汝意答。于意云何。如汝意者实见剑耶。舍利弗言不也。文殊师利曰。又定见彼恶业可得耶。舍利弗言不也。文殊师利曰。又定见彼受果报耶。舍利弗言不也。文殊师利言。如是舍利弗。彼剑既无复无业报。谁造斯业谁受报者。而反问我受报处乎。舍利弗言。大士。以何义故复如是说。文殊师利言。如我所见。实无有法业报熟者。所以者何。一切诸法无业无报。无业报熟故

尔时十方世界诸来菩萨摩诃萨等。同请佛言。世尊。唯愿世尊以威德力。加是文殊师利。令至十方诸佛世界说如斯法。令彼众生咸得听闻。如我无异。于是文殊师利菩萨摩诃萨语彼十方诸菩萨言。诸善男子。汝今宜各一心观察自佛世界也。时彼十方诸菩萨众。从文殊师利闻是语已。即各观本自佛世界。皆睹文殊师利处其佛前。为诸大众说如斯法。复各见彼皆有善住意天子问是法门。又各见彼十方佛国诸菩萨等悉皆大集。又皆见彼诸天子众。其数多少与此不殊。又各见彼佛界清净庄严微妙与此无异。彼诸菩萨摩诃萨众。如是见已生殊特心。得未曾有。同声赞言。甚奇甚特。今此文殊师利道德巍巍。处斯世界安住不动。而能普现十方佛前。尔时文殊师利告彼十方菩萨众言。诸善男子。汝今当听。譬如幻师既善学已不离本座而能幻作种种色像。菩萨摩诃萨亦复如是。既能善学般若波罗蜜如幻法已。即于一切如幻法中。随其十方诸佛国土。欲现形像作诸佛事。如意即能。所以者何。一切诸法皆如幻化。以是义故所作随心。譬如日月宫轮住虚空处。初不曾下入诸器中。其光普照靡不周遍。菩萨如是安住不动。随心普现十方佛前。或现声闻缘觉等身。或现梵王帝释等像。或现四天转轮王事。或现国主大臣政化。如是乃至示现一切恶趣众生形类。随意即能。而亦初无兴作之想

    称赞付法品第十

尔时世尊告文殊师利言。文殊师利。若有得闻此修多罗甚深法门。与值佛兴世等无有异。文殊师利。若闻此经。与证须陀洹无异。与证斯陀含无异。与证阿那含无异。与证阿罗汉无异。何以故。以彼如如无异故。文殊师利。又若闻此经心生信解。与彼后身菩萨菩提树下坐于道场必成正觉。一等无异。何以故。如斯法门。即是三世诸佛世尊之要道故。于是文殊师利白佛言。世尊。如是如是。如佛所说。如空无异如无相无异。如无愿无异。如如如无异。如法界无异。如实际无异。如平等无异。如解脱无异。如离欲无异

尔时文殊师利白佛言。世尊。唯愿如来护持如是甚深法门。于后末世五百岁时。当使此经于阎浮提遍行流布。令诸善男子善女人等咸得闻之。文殊师利作是请时。即令三千大千世界。一切音乐不鼓自鸣。一切诸树自然郁茂。一切众花咸悉开敷。又此三千大千世界六反振动。放大光明遍照三千大千世界。夺日月光令不复现。百千亿天欢喜踊跃。得未曾有。住于虚空雨天花香。种种诸花及诸花鬘。涂香末香如雨而下。香气氛馥充满十方。作天乐音其声和雅。一切咸共叉手合掌同声称赞。希有希有奇特法门。今此文殊师利大士所说。令我等闻。我为福会。从生至今。再遇阎浮转大法轮。有诸众生具足善根。然后乃得闻此深法。若诸众生闻已信行。当知是人已曾供养一切诸佛。亦为已得甚深法忍。若有众生闻此经典。不惊不怖不退不没深心爱乐。当知是人不经二乘善根中来

尔时文殊师利白佛言。世尊。今此奇瑞。将无为是法门。于未来世阎浮提中。遍行流布住持不灭耶。佛言。如是如是。向所现瑞。唯为是经于阎浮提遍行流布住持不灭故。文殊师利言。世尊。唯愿世尊更建诚实。令此经典后世流行炽然不灭。佛言。文殊师利。若三解脱门。能证涅槃是诚实者。于后末世五百岁时。此经法门弘阎浮提炽然不灭为诚实语。文殊师利。若苦无常。若空无我。是实言者。于后末世五百岁时。此经法门弘阎浮提炽然不灭为诚实语。文殊师利言。世尊。如世尊说。无我。无人。无众生。无寿命。无丈夫。无摩奴阇。无摩那婆。无烦恼。无清净。是实言者。于后末世五百岁时。此经法门弘阎浮提炽然不灭是诚实语。如世尊说。无生死无涅槃。无贪欲无嗔恚。无愚痴。无名无色。无因无果。无有无知。无身无身证。无心无心果。无念无念处。无发无发处。无色无受无想无行无识。无眼无色。无耳无声。无鼻无香。无舌无味。无身无触。无意无法。无欲界。无色界。无无色界。无断无常。如是等法。是实言者。于后末世五百岁时。此经法门弘阎浮提炽然不灭是诚实语。如世尊说。无须陀洹。无须陀洹果。无斯陀含。无斯陀含果。无阿那含。无阿那含果。无阿罗汉。无阿罗汉诸法。无辟支佛。无辟支佛诸法。无如来。无如来诸法。无证平等。无力无畏。无智果。无圣证。无空无无相无无愿。无离欲处。无得本性。无有平等。无有余处。无暗无明。无缚无解。无彼岸。无此岸。无中间。无念无觉。如此等法是实言者。于后末世五百岁时。此经法门弘阎浮提遍行流布炽然不灭是诚实语。如世尊说。于此法门。无有众生信解脱得果。相应不相应。不合不散。如是等法为实言者。于后末世五百岁时。此经法门弘阎浮提遍行流布炽然不灭是真实语。如世尊说。过去诸如来应供正遍觉。作如斯说。无有一法能令众生于生死中灭除烦恼解脱涅槃。亦无众生有法生灭。乃至无有过失。无出无动。如过去佛所说。如是未来现在所说亦然。若此等法是实言者。于后末世五百岁时。此经法门弘阎浮提遍行流布是真实语。又如世尊说此法时。无有菩萨得是三昧诸陀罗尼门。亦复无彼诸佛所说语言句义。乃至不说一文字句。无人听闻。无人得解。无人成佛。如此等法是实言者。于后末世五百岁时。此经法门弘阎浮提遍行流布炽然不灭是真实语。如世尊说。无有戒身。无有三昧。无有智慧。无有解脱。无有解脱知见。如此等法是实言者。于后末世五百岁时。此经法门弘阎浮提普宣流布炽然不灭是真实语。如世尊说。诸菩萨等。不行布施。不持禁戒。不修忍辱。不发精进。不入禅定。不得般若。不求菩提。不转诸地。不得佛道。不得诸力。不得无畏。不得诸相。不获诸辩。不转法轮。不度众生令取正觉。如此等法是实言者。于后末世五百岁时。此经法门弘阎浮提普宣流布炽然不灭为真实语。文殊师利宣此诚实誓时。三千大千世界大地六种振动

尔时弥勒菩萨摩诃萨白佛言。世尊。有何因缘。今此世界如是大动。佛告弥勒菩萨言。弥勒。汝今不应问如是事。所以者何。来世众生。钝根少信闻不能解。堕于疑慢长夜不安。于是弥勒菩萨复白佛言。世尊。唯愿说之。世尊若说。能多利益一切世间天人大众故。佛告弥勒。如是经典。往昔已有七十四亿百千那由他诸佛世尊。于此方所称扬赞说。皆因文殊师利及善住意天子等问答咨论也。弥勒菩萨复白佛言。世尊。是文殊师利及善住意天子。闻此法门其久近耶。佛告弥勒。乃往过七阿僧祇劫。有佛世尊号普花最上师子游步胜功德聚如来应供正遍觉所。是善男子等。从彼佛所初闻此经也。说是经时。众中有若干恒河沙众生。皆发阿耨多罗三藐三菩提心。复倍前数众生得住不退转忍。复倍前数众生远尘离垢得法眼净

尔时世尊说此经已。于是文殊师利与善住意天子。及彼十方诸菩萨众。及彼一切诸天子众。及尊者舍利弗。尊者摩诃迦叶。诸比丘众乃至所有天人阿修罗诸龙鬼神一切众等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第一百五大宝积经卷第一百六

        大唐三藏菩提流志奉　诏译

    阿阇世王子会第三十七

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众千二百五十人俱。尔时阿阇世王所爱之子名为师子。与其同友五百人俱。皆已趣向阿耨多罗三藐三菩提。各持种种幢幡宝盖。从王舍城往耆阇崛山。到如来所礼拜供养。于是王子。合掌恭敬。而白佛言。唯愿如来。为我宣说诸菩萨行。尔时王子。即说颂言

  云何得端正　　莲花中化生
  云何知宿命　　愿佛为宣说

尔时如来。了达诸行。究竟彼岸。随问而答。即说颂曰

  忍辱得端正　　施莲花化生
  法施知宿命　　汝当如是解

王子又问

  云何得成就　　三昧陀罗尼
  凡有所发言　　皆令人信受

世尊答曰

  修心得三昧　　忍获陀罗尼
  敬重于众生　　发言人信受

王子又问

  云何得正念　　具足智慧生
  如法而修行　　坚固不可坏

世尊答曰

  不谄得正念　　巧观智慧生
  尊重所修行　　护法心坚固

王子又问

  云何成妙相　　具足三十二
  八十随形好　　观者乐无厌

世尊答曰

  由施得诸相　　行慈获随好
  等心于众生　　观者无厌足

王子又问

  云何得梵音　　迦陵频伽声
  云何令世间　　见者皆欢喜

世尊答曰

  诚言获梵音　　迦陵由软语
  离绮言两舌　　见者皆欢喜

王子又问

  由何等业行　　得生诸佛前
  能请微妙义　　唯愿如来说

世尊答曰

  于诸法施中　　不曾为障碍
  因此故恒得　　值遇诸如来

王子又问

  云何离诸难　　而生于善趣
  云何世世中　　性常无放逸

世尊答曰

  净信离诸难　　持戒生善趣
  由修习于空　　所生无放逸

王子又问

  云何获神通　　及证宿命智
  能永尽诸漏　　愿佛为开演

世尊答曰

  施乘得神通　　教授成宿命
  舍离于二边　　由是尽诸漏

王子又问

  云何净业成　　魔网不能罥
  而于世世中　　为众之所爱

世尊答曰

  胜解成净业　　精进摧伏魔
  如说而修行　　所生令众爱

王子又问

  云何得长寿　　获少病之身
  感难坏眷属　　愿牟尼宣说

世尊答曰

  不害得长寿　　除他忧少病
  诤讼使和安　　得难坏眷属

王子又问

  云何得财富　　资具无损减
  于世世所生　　成就大威德

世尊答曰

  不嫉获财富　　无悭资具增
  谦下成尊贵　　有威德自在

王子又问

  云何获大力　　众魔不能害
  威势常超胜　　唯愿人尊说

世尊答曰

  恒施上味食　　恐怖令安隐
  由斯得大力　　威势常超胜

王子又问

  云何得成就　　天眼及天耳
  云何能了知　　种种众生心

世尊答曰

  施灯感天眼　　奉乐成天耳
  远离于二边　　故获他心智

王子又问

  云何得净土　　及以众圆满
  获随体圆光　　功德海当说

世尊答曰

  由愿得净土　　忍力众成就
  施众妙宝帐　　得周遍圆光

王子又问

  云何所生处　　菩提心不坏
  乃至于梦中　　亦无有忘失

世尊答曰

  凡所游行处　　城邑聚落中
  化众趣菩提　　菩提心不坏

王子又问

  云何大牟尼　　为众之所爱
  摄取一切法　　唯愿人尊说

世尊答曰

  胜志乐具足　　不退菩提心
  由此摄诸法　　为众之所爱

尔时王子与诸大众。闻是偈已咸作是言。如佛所说此诸妙行。我等从今尽当修学。是时如来即现微笑。放大光明遍照无量无边世界。于是弥勒菩萨白佛言。世尊。以何因缘现此微笑。愿为宣说断除疑惑。尔时佛告弥勒菩萨摩诃萨言。善男子。此王子等五百同友。皆于往昔为求无上正等菩提。恭敬供养十那由他八十亿诸佛。而我往在然灯佛时。作婆罗门子成熟于彼。然彼诸人于未来世弥勒佛等诸世尊前。恒受化生亲承供养。如是奉事十亿如来满三百劫。其最后佛号无边智善学诸法。时无边智佛。知彼诸人心之欲乐。各随所应。为授阿耨多罗三藐三菩提记。同于安乐光严劫中成等正觉。皆号智慧幢相。此诸佛刹所有庄严。亦如西方无量寿国等无差别。善男子。若有众生闻此所说而生信解。发愿当成大菩提者。应知是人所获功德。于三世中无有伦匹。善男子。若有人能六百劫中。恒以众宝遍于诸刹奉施如来。若复有人闻是经典。所生善根比前功德。算数校计所不能及。说是法时。众中八十亿众生。一时趣向阿耨多罗三藐三菩提。又此三千大千世界皆悉震动天雨妙花。尔时王子与五百同友。闻授记已欢喜踊跃。咸作念言。我等定当成无上觉。于是王子及诸同侣。既兴供养获五神通。即于佛前种种变现。出家为道。尔时诸菩萨摩诃萨及诸天人。所有趣向大菩提者。见彼王子与诸同友。随众所乐示现神变。皆大欢喜咸作是言。师子王子所问疑惑。如来法王悉为除断。如是世尊不可思议。如来正法及能信受。乃至果报不可思议。如来功德无量无边。于一切法靡不明达。为世导师度未度者。普能遍于十方世界。悉已了知三世诸法。谁有智者。得闻如是生安乐处功德之聚。而不发起猛利信乐趣求菩提。佛说是经已。师子王子等五百同友。欢喜奉行

    大宝积经大乘方便会第三十八之一

        东晋天竺居士竺难提译

如是我闻。一时佛在舍卫国祇树给孤独园精舍。与大比丘八千人俱。皆学无学大声闻众。菩萨摩诃萨万二千人。皆得神通众所知识得陀罗尼无碍辩才。得诸法忍。无量功德皆悉成就

尔时如来从三昧起。无量百千万亿众生。恭敬围绕而为说法。尔时众中有菩萨摩诃萨名曰智胜。即从座起。偏袒右肩。右膝着地。合掌向佛。而白佛言。世尊。欲问一事唯愿听许。若佛听者乃敢咨请。佛告智胜菩萨。善男子。恣汝所问。当为汝说断汝所疑。尔时智胜菩萨白佛言。世尊。所言方便。何等为菩萨方便。世尊。云何菩萨摩诃萨行于方便。如是问已。佛赞智胜菩萨言。善哉善哉。善男子。汝为诸菩萨摩诃萨故问方便义。多所利益多所安乐。愍念世间利益安乐。唯天世人。为摄未来诸菩萨智慧。及去来现在诸佛法故。善男子。当为汝说。谛听谛听。善思念之。智胜菩萨受教而听。善男子。行方便菩萨。以一抟食给施一切众生。何以故。行方便菩萨。以一抟食施与。下至畜生。愿求一切智。以是菩萨与一切众生共之。回向阿耨多罗三藐三菩提。以是二因缘摄取一切众生。所谓求一切智心及愿方便。善男子。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若见行施之人生随喜心。以此随喜善根。愿与一切众生共之。回向阿耨多罗三藐三菩提。是方便菩萨。亦愿施者受者不离一切智心。假令受者是二乘人。亦愿不离一切智心。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若见十方世界中。无主花树及种种香。合集愿以供养诸佛。若见十方世界中。有主花香若香若叶。风所吹者一切合集。愿以供养十方诸佛。以是善根若自为。若为一切众生具一切智心。以是善根因缘故。得无量戒定慧解脱解脱知见。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若见十方世界众生受诸乐报。见已作如是念。愿一切众生得一切智乐。若见十方世界众生受诸苦报。为诸众生忏悔诸罪作是大庄严。如是众生所受苦恼。我悉代受令彼得乐。以是善根愿成一切智除一切众生苦恼。以是因缘故。毕竟不受一切诸苦纯受诸乐。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若礼一佛恭敬供养尊重赞叹。作是念。一切如来。同一法界一法身。一戒一定一慧一解脱一解脱知见。作是念已。当知若礼一佛。恭敬供养尊重赞叹。即是礼拜供养恭敬尊重赞叹一切诸佛。若供养一佛。即是供养十方诸佛。如是供养十方佛已。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若钝根者不应自轻。乃至若能通利一四句偈。作是念。若解一四句偈义。即知一切佛法。一切佛法皆摄在此一偈义中。如是通达已心不懈怠。若至诸国城邑聚落。以慈悲心广为人说。不求利养名闻。赞叹作如是愿。此四句偈愿令他闻。以是善根因缘方便。愿已令一切众生多闻皆如阿难。及得如来辩。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若生贫穷家。是菩萨乃至乞食。若得一抟食用施僧。若施一人不以为愧。应作是念。如佛所说心增广大胜以财施。我财施虽少。以一切智心。愿是善根成一切智令诸众生悉得宝手犹如如来。以是缘故。具足施戒禅定福处。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。若见声闻缘觉。多得利养尊重赞叹。是菩萨自以二缘慰喻其心。何等为二。所谓因菩萨故有诸如来。因如来故有声闻缘觉。如是思惟。二乘之人虽得利养我犹胜彼。彼所食者是我父物。云何于中而生希望。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨行于方便。行施之时具六波罗蜜。何等为六。善男子。菩萨行方便时。若见乞儿除悭惜心。具足大施。是名檀波罗蜜。自持禁戒施持戒者。见破戒人劝令持戒。劝持戒已然后给施。是名尸波罗蜜。自除嗔恚行于慈愍。心无秽浊利益众生等心而施。是名羼提波罗蜜。若施饮食汤药。即时具足身心精进。去来进止屈伸俯仰。是名毗梨耶波罗蜜。若行施已其心得定。欢喜悦预专念不乱。是名禅波罗蜜。如是施已分别诸法。施者是谁。谁为受者。谁受报者。如是观已无有一法。名为施者若受施人及受报者。是名般若波罗蜜。善男子。是名菩萨摩诃萨行于方便具六波罗蜜。尔时智胜菩萨白佛言。世尊。未曾有也。菩萨摩诃萨行于方便。即于施时以此施故。摄一切佛法及诸众生。佛告智胜菩萨。善男子。如汝所说。菩萨摩诃萨行于方便。以方便力故虽行少施。所得福德无量无边阿僧祇。佛复告智胜菩萨。善男子。菩萨摩诃萨。虽至不退转地。亦以方便而行于施。是名菩萨行于方便。善男子。有时恶知识。教菩萨言。汝何用久处生死。可于此身早入涅槃。菩萨知已即应离之。我如是大庄严。教化一切众生。是人为我作诸留难。若我不在生死中者。何能教化无量众生。智胜菩萨。白佛言。世尊。若有众生以妄想故犯四重罪。佛告智胜菩萨。善男子。若出家菩萨以妄想故犯四重罪。行方便菩萨能尽除灭。我今亦说无有犯罪及受报者。智胜菩萨白佛言。世尊。云何菩萨犯罪。佛告智胜菩萨。善男子。菩萨虽行解脱戒。于百千劫中啖果食草。能忍众生善恶之语。若与声闻缘觉共思惟法。善男子。是名菩萨摩诃萨犯于重罪。善男子。如声闻人犯于重禁。非即此身得入涅槃。善男子。菩萨如是不除声闻缘觉共思惟法。不舍不悔者。终不得成阿耨多罗三藐三菩提。若得佛法无有是处。尔时尊者阿难白佛言。世尊。我今晨朝入舍卫城次第乞食。见众尊王菩萨。与一女人同一床坐。阿难说是语已。即时大地六种震动。众尊王菩萨于大众中。上升虚空高七多罗树。语阿难言。尊者。何有犯罪能住空耶。阿难。可以此事问于世尊。云何罪法。云何非罪。尔时阿难忧愁向佛。右膝着地手执佛足。世尊。我今悔过。如是大龙。我说犯罪。如是菩萨。我求其过。世尊。我今悔过。唯愿听许。佛告阿难。汝不应于大乘大士求觅其罪。阿难。汝声闻人。于障处行寂灭定。无有留难断一切结。阿难。行方便菩萨。如是成就一切智心。虽在中宫婇女共相娱乐。不起魔事及诸留难。而得阿耨多罗三藐三菩提。何以故。阿难。行方便菩萨无有受如是众生不以三宝劝化。若阿耨多罗三藐三菩提。阿难。若学大乘善男子善女人。不离一切智心。若见可意五欲。即便在中共相娱乐。阿难。汝应作是念。如此菩萨即是能成如来根本。佛告阿难。汝今谛听谛听。以何缘故。众尊王菩萨摩诃萨。与此女人同一床坐。阿难。彼女人者曾于过去五百世中。为众尊王菩萨作妇。彼女人本习气故。见众尊王菩萨。心生爱着系缚不舍。此众尊王菩萨。威德端正持戒力故。见已欢喜踊跃在一独处。生如是心。若众尊王菩萨能与我共一床坐者。我当发阿耨多罗三藐三菩提心。阿难。尔时众尊王菩萨。知彼女人心之所念。如是知已即于晨朝着衣持钵。入舍卫城次第乞食。至彼女家即入其舍。寻时思惟如是法门。若内地大若外地大是一地大。以地大心执女人手共一床坐。众尊王菩萨即于坐上而说偈言

  如来不赞叹　　凡夫所行欲
  离欲及贪爱　　乃成天人师

佛告阿难。时彼女人闻此偈已。心大欢喜踊跃无量。即从坐起。向众尊王菩萨。接足敬礼说是偈言

  我不贪爱欲　　贪欲佛所呵
  离欲及贪爱　　乃成天人师

说是偈已作如是言。我先所生恶欲之心。今当悔过即生善欲发菩提心。愿欲利益一切众生。佛告阿难。尔时众尊王菩萨。劝彼女人。令发阿耨多罗三藐三菩提心已。即从坐去。阿难。汝观是女人专心福报。我今以正遍知记彼女人。于此命终得转女身。当成男子。于将来世九十九劫。供养百千无量阿僧祇诸佛。具足一切佛法。得成为佛。号无垢烦恼如来应供正遍知。彼佛成道已。当是世时无有一人起不善心。阿难当知。行方便菩萨所摄眷属。终不堕三恶道。尔时众尊王菩萨。从空中下顶礼佛足。礼已白佛言。世尊。菩萨行于方便。若为一人起大悲心合集善法。若似犯罪若实犯罪。于百千劫堕大地狱。世尊。此菩萨堪受诸恶及地狱苦。以此善根愿不舍一人。尔时世尊。赞众尊王菩萨言。善哉善哉。善男子。菩萨成就如是悲心。虽受五欲不犯重罪。离于诸罪及远一切堕恶道业。善男子。我念过去阿僧祇劫复过是数。时有梵志名曰树提。于四十二亿岁在空林中常修梵行。彼时梵志过是岁已。从林中出入极乐城。入彼城已见有一女。彼时女人见此梵志仪容端严。即起欲心寻趣梵志。以手执足即时躄地。善男子。尔时梵志告女人曰。姊何所求。女曰。我求梵志。梵志言姊。我不行欲。女曰。若不从我我今当死。善男子。尔时树提梵志。如是思惟。此非我法亦非我时。我于四十二亿岁修净梵行。云何于今而当毁坏。彼时梵志强自顿抴得离七步。离七步已生哀愍心。如是思惟。我虽犯戒堕于恶道。我能堪忍地狱之苦。我今不忍见是女人受此苦恼。不令是人以我致死。善男子。尔时梵志又如是思惟已。还至女所以右手捉作如是言。姊起恣汝所欲。善男子。尔时梵志。于十二年中共为家室。过十二年已寻复出家。即时还具四无量心。具已命终生梵天中。善男子。汝勿有疑。尔时梵志即我身是。彼女人者今瞿夷是。善男子。我于尔时为彼女欲暂起悲心。即得超越十百千劫生死之苦。善男子。汝如是观若余众生。由爱欲故堕于地狱。行方便菩萨由生梵天。是名菩萨摩诃萨行于方便。佛复告智胜菩萨。善男子。若舍利弗。大目犍连等。行方便者。不令瞿伽离堕于地狱。何以故。善男子。我念过去世。鸠留孙佛时。有一比丘名曰无垢。在空林野止住窟中。去窟不远有五仙人。当尔之时。卒起大云而降大雨。时有贫女。道遇暴雨寒裸恐怖。即入无垢所住窟中。时雨既止。无垢比丘。共此女人从窟而出。时五仙人见此事已。心生荒秽。各相谓言。无垢比丘。心怀奸谄作不净行。时无垢比丘。知彼仙人心之所念。即踊身虚空高七多罗树。时五仙人见无垢比丘上升虚空。见已复相谓言。我等所见书记经论。若人作不净行。不能如是飞升虚空。若修净行则能如是。彼时仙人即向无垢。五体投地合掌悔过不敢覆藏。佛告智胜菩萨。善男子。尔时无垢比丘。若不作如是方便飞升虚空者。此五仙人即此生身入于地狱。善男子。尔时比丘岂异人乎。即弥勒菩萨是。善男子。汝今当知。舍利弗。目犍连。若作如是方便。飞升虚空者。瞿伽离比丘。不堕地狱。善男子。汝今当知。如诸菩萨摩诃萨所行方便。声闻缘觉之所无有。善男子。譬如淫女善知六十四态。为财宝故。媚言诱他诈许舍身。所重之物无所匮惜。后得彼物。得彼物已。驱逐令去不生悔心。善男子。行方便菩萨。能知随宜行于方便。如是教化一切众生。随其所欲而为现身。于所须物心无吝惜。乃至舍身。为众生故。爱乐善根不求果报。知诸众生作善根已。心无退转。即于尔时心生舍离。所现五欲永无恋着。善男子。譬如黑蜂在畜生中。于一切花虽经香味。而于其中无依止想无所爱着。于花叶茎香不持而去。善男子。菩萨摩诃萨行于方便亦得如是。为化众生处于五欲见法无常。不以常想而起于爱。又不自害亦不害他。善男子。如小种子虽生于牙。然其本色无所亏损不生异物。善男子。如是空无相无作。无我智慧。种子菩萨虽有烦恼。于五欲娱乐。不生三恶道牙。不损善根之色。亦不退转。善男子。譬如鱼师以食涂网投之深渊。既满所求即寻牵出。善男子。行方便菩萨亦复如是。以空无相无作无我智慧。勋修其心结以为网。一切智心以为涂食。虽投五欲污泥之中。如其所愿牵出欲界。命终之后生于梵世。善男子。譬如有人善知咒术。为官所执被五系缚。此人自以咒术力故。即断五缚随愿而去。善男子。如是菩萨摩诃萨行于方便。虽处五欲共相娱乐。为化众生如其所求。以一切智咒。断五欲缚生于梵世。善男子。譬如士夫善知战法。藏一利刀卫送行人。而彼众中无有一人能知此人密怀奇谋而反轻之。更生怜愍无敬重心。各相谓言。彼人既无器仗亦无伴党。此非健士复无势力。自身不救何能济人。此若坏贼无有是处。彼人必当受诸困厄。时彼士夫遂至空泽群贼俱发。尔时士夫牢自庄严。寻时即出所藏之刀。始一掷刀群贼丧命。诸贼既坏复还藏刀。善男子。行方便菩萨。善藏智刀。而以方便处于五欲共相娱乐。为化众生声闻见。此方便菩萨处于五欲共相娱乐。不知方便故生浊心。或复怜愍谓为放逸。如是之人尚不自度。况能救度一切众生。若能坏魔无有是处。尔时菩萨。善用方便智慧之刀。如其所求断诸烦恼尽令摧灭。以智慧刀至净佛土。无诸女人乃至无有一念欲想。尔时有菩萨名曰爱作。入舍卫城次第乞食。渐渐遂至一长者家。长者有女名曰德增。住高楼上。彼时女人闻菩萨声。寻持食出向爱作菩萨。女见菩萨取其形容相好音声。欲心即起为欲所烧。即时命终骨节解散。爱作菩萨见德增女。亦起恶觉淫欲之心。于时爱作菩萨。即自思惟。云何彼法。法者为着。云何彼眼。何者此眼。眼性非知。但是肉团。不爱不知。不思不觉。无所分别。其性本空。耳鼻舌身意法亦复如是。薄皮厚皮。血肉脂肪。发毛爪齿。骨髓筋脉。从足至顶。如是观已。若内若外。无有一法而可爱着。若嗔若痴。于一切法如实观。即离欲心得无生忍。得无生忍已。其心欢喜踊跃无量。即升虚空高一多罗树。绕舍卫城七匝。尔时世尊。见爱作菩萨飞腾虚空。犹如鹅王无所挂碍。佛见是已。告阿难言。阿难。汝见爱作菩萨飞腾虚空。犹如鹅王无所碍不。阿难言。唯然已见。佛告阿难。是爱作菩萨。因起欲心推求诸法。即坏魔众当转法轮。时德增女命终之后。生三十三天。转于女身得成男子。自然处于七宝宫殿。纵广正等十二由旬。有万四千诸天婇女。以为侍卫。是德增天子。得识宿命推先业行。以何业缘而来生此。如是思惟已。见舍卫城中作长者女。因见爱作菩萨。生淫欲心。欲心炽盛即身命终。便转女身得成男子。我以是事得无量神力。尔时德增天子。如是思惟。因起淫欲得如是报。今我于爱作菩萨。心甚清净礼敬供养。我今若住先受五欲。此非我宜。如是思惟已当诣如来。并欲见于爱作菩萨礼敬供养时。德增天子与其眷属。持天花香涂香末香。即于初夜来至佛所。自以光明普照祇洹。入觐世尊及见爱作。即以天花末香涂香。供养于佛。顶礼佛足。及爱作菩萨。一切大众。右绕三匝。合掌向佛。即说偈言

  天人之尊　　不可思议　　菩萨所行
  亦不可议　　如来之法　　不可思议
  大名称者　　亦不可议　　我昔舍卫
  曾为童女　　在长者家　　名曰德增
  其年幼少　　颜貌端正　　父母爱念
  为作遮护　　如来世尊　　无有轻戏
  有子爱作　　有大威德　　入舍卫城
  而行乞食　　渐到我父　　所止之舍
  我时闻其　　好妙音声　　心大欢喜
  即持食出　　寻时向于　　行大心者
  如来之子　　爱作菩萨　　见菩萨时
  已在我心　　观其净妙　　心生染欲
  我若不得　　内心所愿　　便当即时
  身命殒没　　我于尔时　　口不能言
  手所持食　　不能与之　　内心怀热
  而发淫欲　　是时身热　　寻便命终
  我时命终　　经一念顷　　寻得上生
  三十三天　　离于最下　　女人之身
  得成男子　　为人所赞　　胜妙宫殿
  自然而出　　种种妙宝　　人之所珍
  具足一万　　四千婇女　　如是眷属
  是我所有　　我以此缘　　寻观宿命
  而自思惟　　即知往因　　因发欲心
  得如是报　　我以染心　　视于爱作
  由见菩萨　　得喜光明　　我身所出
  光明之焰　　因彼业缘　　得如是报
  我终不愿　　求于二乘　　所愿之处
  唯佛知之　　淫欲之心　　得报尚尔
  何况能作　　善心供养　　如我于今
  向于世尊　　发如是愿　　求一切智
  假使所行　　劫如恒沙　　终不退转
  于佛智慧　　遇善知识　　爱作菩萨
  今我当以　　真法供养　　若余供养
  非为供养　　唯发菩提　　是真供养
  行于菩提　　最胜最尊　　更不以欲
  视诸女人　　我愿如是　　离于女身
  向诸佛说　　四无所畏　　我之父母
  寻晓见我　　身坏碎烂　　悲号啼哭
  父母谓之　　比丘所为　　称怨啼哭
  呵骂比丘　　佛之神力　　令彼天子
  至父母所　　呵责谏喻　　于此比丘
  勿生嗔恚　　莫于长夜　　受诸苦恼
  德增女人　　先命终已　　即得上生
  三十三天　　离于女身　　得成男子
  为天人身　　光明远照　　父母今当
  诣世尊所　　先不善心　　今应悔过
  若除如来　　诸佛世尊　　更无有人
  可归依者　　以无畏心　　劝喻父母
  即时父母　　得闻佛名　　寻共和合
  至于释迦　　牟尼佛所　　至佛所已
  头顶敬礼　　二足之尊　　今者悔过
  本嗔恚心　　恭敬尊重　　人中之尊
  今者应问　　如来自知　　云可供养
  佛法及僧　　云何修习　　行于善行
  如是所问　　愿为说之　　若得闻已
  专心修行　　佛知父母　　其心决定
  天人之师　　说如是言　　若欲供养
  一切诸佛　　专心坚固　　发菩提心
  德增父母　　及诸眷属　　其数具足
  满五百人　　闻天人师　　如是之言
  发菩提心　　而作大愿　　尔时佛告
  贤者阿难　　汝今善听　　我之所说
  菩萨所行　　不可思议　　无上智慧
  及以方便　　爱作菩萨　　数数发愿
  女人见我　　若发欲心　　寻时得离
  于女人身　　得成男子　　为人所尊
  阿难汝观　　德力如是　　若犯非法
  应堕恶道　　健士行之　　得坏魔众
  令彼生天　　得为天人　　今此天子
  供养于我　　其心恭敬　　正向菩提
  彼当供养　　无量世尊　　来世成佛
  号曰善见　　此五百人　　向菩提者
  亦当作佛　　为天人师　　佛有是德
  谁不供养　　是处深信　　得无量乐
  非一女人　　非二非三　　无量百千
  那由他亿　　见于爱作　　发淫欲心
  寻即命终　　得为男子　　大医药王
  有大名称　　如是菩萨　　谁不尊敬
  虽生欲心　　更得快乐　　况于菩萨
  生恭敬心

大宝积经卷第一百六大宝积经卷第一百七

        东晋天竺居士竺难提译

    大乘方便会第三十八之二

尔时尊者阿难白佛言。世尊。譬如须弥山。若诸杂色至其边者同一金色。世尊。若有众生至菩萨边者。若嗔心。若净心。若欲染心。如是一切悉皆同一萨婆若色。世尊。我从今日于诸菩萨。生尊重心如须弥山。世尊。如有药王名曰悉见。若有嗔心及清净心。服此药者皆得除愈。彼药能除一切诸毒。世尊。菩萨亦如是。若有嗔心净心至菩萨所者。菩萨悉能为除一切贪恚痴病。尔时世尊。赞阿难言。善哉善哉。如汝所说。尔时摩诃迦叶。白佛言。世尊。未曾有也。菩萨摩诃萨最尊第一。若菩萨摩诃萨修诸禅定。修禅定已还入欲界教化众生。虽行空无相无作用化众生。令成声闻缘觉。以大慈悲。自终不离萨婆若心。世尊。菩萨摩诃萨所行方便不可思议。如是虽受色声香味触缚。而于其中无所爱着。世尊。我今以乐说辩才。说诸菩萨少分功德。佛告迦叶。恣汝所说。世尊。譬如大饿空泽。有大高墙至无色界。彼大饿空泽唯有一门。而此泽中多有众生。去泽不远有一大城。丰乐炽盛端严净妙。若有众生入彼城中无老病死。向城之道唯广一尺。其路端直。彼泽众中有一智人。聪利睿智欻然起心。以大慈悲欲利益安乐一切众生。此人即于空泽之中高声唱言。诸人当知。去此不远有一大城。丰乐炽盛端严净妙。多有天人所居止处。若有众生入彼城中。无老病死。亦能说离老病死法。仁等可来当共诣彼。我与诸人作大导师。彼空泽中有下劣众生。生悕望心欲得求解。作如是言。若能令我住此泽中。我当受教。若欲令我出此泽者。则不能受。有上众生作如是言。我当共汝至所去处。此空泽中薄福众生。闻如是唱。闻已不信不随智人。世尊。尔时智人从空泽出。四向顾望见有一道。唯广一尺迫迮狭小。其道左右有大深坑深百千肘。其智慧人于道左右以板椑之。其人于此匍匐而进不视左右。怨贼在后随而怖之。其人尔时亦不顾后。其心勇锐不生怖畏。渐得过已遂见彼城。既见城已心无怖畏。入城之后无老病死。亦大利益无量众生。为说离老病死之法。世尊。大饿空泽者。是生死饿也。有大高墙至无色界者。是无明有爱也。而此泽中多有众生者。是一切生死凡夫人也。向城之道唯广一尺者。一支道也。彼泽众中有智人者。是菩萨摩诃萨也。下劣众生悕望欲解。于泽不动者。是声闻缘觉也。有上众生作如是言。我当共汝至所去处者。是余菩萨也。薄福众生闻不信者。是一切邪见外道及其弟子也。大空泽中出者。是勤修一切智心者也。一尺迮道者。是法性门也。其道左右有大深坑深百千肘者。是声闻缘觉乘也。于道左右以板椑之者。智慧方便也。匍匐而进者。是菩萨以四摄法摄一切众生也。怨贼在后而随怖者。是魔及魔民深起六十二见众生并轻谤菩萨者也。不顾后者。是忍辱波罗蜜专心具足也。不视左右者。是不赞声闻缘觉乘也。大城者。是一切智心也。渐得过已遂见彼城。既见城已心无怖畏者。是菩萨见佛及佛所行。一心敬佛智慧威德。善学般若波罗蜜。方便渐渐随宜附近一切众生。无有疑难也。入城无老病死者。是菩萨利益无量众生。离老病死也。说法者。是如来应供正遍知也。世尊。我今敬礼一切菩萨。说是语已。十千人天。发阿耨多罗三藐三菩提心。尔时世尊。赞摩诃迦叶言。善哉善哉。汝能劝发诸菩萨摩诃萨。汝能成就无量功德。菩萨摩诃萨。若业能自害及以害他。终不为之。若有言说。能自害害他亦所不为。尔时德增菩萨摩诃萨。白佛言。世尊。若业若言。能自害害他。一切菩萨所不为者。世尊。何故昔于迦叶佛时。行菩萨道余一生在。作大梵志名曰树提。作如是言。菩提之道甚为难得。何有秃人能办此事。我不欲见。世尊尔时作如是言。有何等义。佛告德增菩萨。善男子。汝于如来菩萨莫生疑也。何以故。佛及菩萨成就不可思议方便。佛及菩萨。住种种方便而教化众生。善男子。汝今谛听善思念之。有经名方便波罗蜜。今当为汝说之。尔时菩萨。从然灯佛来渐学方便今亦当为汝少开示分别。善男子。菩萨摩诃萨。见然灯佛时。即得无生法忍。从是已来无有错谬。戏笑失念无不定心。智慧不减。善男子。菩萨摩诃萨。如其本愿得无生忍。七日之后。便能得成阿耨多罗三藐三菩提。若欲百劫。亦能得成。菩萨摩诃萨。为众生故受一切有。随所在处以智力故。随其所求得毕所愿。而后乃成阿耨多罗三藐三菩提。善男子。菩萨摩诃萨。以方便力。无量亿劫住于世界。亦无忧愁为不厌离。是名菩萨摩诃萨行于方便。复次善男子。菩萨摩诃萨。所有禅定。若声闻入者。身心不动。心便自谓入涅槃已。若菩萨入者。身心精进无有懈怠。以四摄法摄取众生。大慈悲故。以六波罗蜜教化众生。是名菩萨摩诃萨行于方便。复次善男子。菩萨如其本愿。处兜术天宫。能得阿耨多罗三藐三菩提。转于法轮。非为不能。菩萨于兜术天上。如是思惟。阎浮提人不能至此。兜术天上听受法教。兜术天人能下阎浮提听法。是故菩萨舍兜术天。于阎浮提。成阿耨多罗三藐三菩提。是名菩萨摩诃萨行于方便。复次善男子。菩萨如其本愿。从兜术天来不入母胎。亦能即成阿耨多罗三藐三菩提。若不入者。诸众生或当生疑。作如是言。是菩萨从何处来。若天若龙。若鬼神。若乾闼婆。若变化作。如是疑已不能听法。不能修行断诸烦恼。是故菩萨摩诃萨。非不入母胎。成阿耨多罗三藐三菩提。是名菩萨摩诃萨行于方便。善男子。勿谓菩萨实处母胎。生如是见。何以故。菩萨摩诃萨。实不入母胎。所以者何。菩萨入无垢定。不起此定。从兜术天下。乃至坐于菩提树下。兜术天人作如是念。菩萨命终已更不还此。菩萨是时在兜术天实自不动。而现入胎受于五欲。若生出家及以苦行。一切众生以之为实。而于菩萨皆是变化。菩萨变化入胎受欲现自娱乐。出家苦行悉是菩萨变化所为。何以故。菩萨尔时所行清净更不入胎。久以厌离故。是名菩萨摩诃萨行于方便。以何缘故。身似白象示入母胎。善男子。于此三千大千世界菩萨最尊。成就白净法故。现似白象入于母胎。更无天人鬼神能作如是入母胎者。是名菩萨摩诃萨行于方便。以何缘故。菩萨处胎足满十月。然后乃出。善男子。有余众生。或生是心。若不满十月。此童子身或不具足。是故菩萨现处胎中满足十月。从初入胎至满十月。于其中间常有诸天。来在母边礼敬围绕。是时诸天见菩萨身。所处高楼纯以七宝庄严。非天所有。见是瑞已。有二万四千天子。发阿耨多罗三藐三菩提心。是名菩萨摩诃萨行于方便。以何缘故。菩萨从右胁入胎。善男子。或有众生作如是疑。谓菩萨从父母精和合而生。为断彼疑欲现化生故从胁入。既入胁已无有入处。而摩耶夫人。昔来未曾得也。如是身心快乐。是名菩萨摩诃萨行于方便。以何缘故。菩萨空闲处生。非于家中及以城内。善男子。菩萨先来常乐空闲处。赞叹空处。赞叹山林闲静之处。行于寂灭。菩萨若处家中生者。天龙鬼神乾闼婆等。不持花香末香涂香。诸天百千无量伎乐而来供养。时迦毗罗城所有人民。其心荒迷放逸自高。不能供养菩萨。是故菩萨在空闲处生。不于城内及以家中。是名菩萨摩诃萨行于方便。以何缘故。菩萨母仰攀绛赖叉树枝而生菩萨。善男子。有情生疑。摩耶夫人生菩萨时。受诸苦恼如余女人。示彼众生受快乐故。仰攀树枝而生菩萨。是名菩萨摩诃萨行于方便。以何缘故。菩萨以正念从右胁出非余身分。善男子。菩萨净行于三千大千世界最尊最胜。不因女根住。不因女根出。是一生菩萨示现如是。非余梵行人。是故菩萨从右胁出。既出生已亦无出处。如前后亦如是。是名菩萨摩诃萨行于方便。以何缘故。菩萨初生时。释提桓因以宝衣承取非余天人。善男子。释提桓因昔发此愿。菩萨若生。我当以宝衣承取。以菩萨善根妙故。增益余天信敬供养。是名菩萨摩诃萨行于方便。以何缘故菩萨生时。即行七步非六非八。善男子。必定菩萨有大神力勤精进大丈夫相。欲示现众生。余人不能如是示现。若以七步益余众生者。菩萨行于六步。若以八步益余众生者。则行七步。是故菩萨。无人扶持令行七步。非六非八。是名菩萨摩诃萨行于方便。以何缘故。菩萨行七步已。唱如是言。我于世界中最尊最胜离老病死。善男子。尔时众中释梵诸天。及诸天子心怀憍慢。自言。是世界中尊。彼诸天子傲慢自高心无恭敬。尔时菩萨作如是念。彼诸天子有是慢心。以慢心故长夜堕在三恶道中。是故菩萨说如是言。我于世界最尊最胜离老病死。菩萨尔时唱如是言。其音遍闻三千大千世界。或有诸天。菩萨生时未来集者。闻此声已皆悉来集。尔时欲色界天。合掌恭敬向菩萨礼。各相谓言。未曾有也。是故菩萨。行七步已作真实言。我于世中最尊最胜离老病死苦。是名菩萨摩诃萨行于方便。以何缘故行七步已而便大笑。善男子。菩萨不为欲故笑。不为慢故笑。不为轻故笑。尔时菩萨。如是思惟。是诸众生。如本有欲恚痴及诸烦恼。今亦如是。我本已劝。令发阿耨多罗三藐三菩提。我今已成。而彼众生懈怠懒惰。故在生死苦恼海中未断烦恼。如此众生与我同时发菩提心。我今已成阿耨多罗三藐三菩提。而彼众生懈怠懒惰。故在生死苦恼海中。是下劣众生为利养故。不勤精进求一切智。是诸众生今犹礼敬供养于我。我于尔时生大悲心。我今已满所愿。以是因缘菩萨大笑。是名菩萨摩诃萨行于方便。以何缘故。菩萨生时身体清净先无垢秽。释提桓因及梵天王洗浴菩萨。善男子。菩萨欲令释梵诸天兴供养故。亦以世法如初生婴儿应洗浴故。是故菩萨虽身无垢。而令释梵洗浴。是名菩萨摩诃萨行于方便。以何缘故。菩萨在空闲处。时不即至道场而还入宫。善男子。欲令诸根具足故。示处宫殿五欲自娱。然后舍四天下。而行出家。复为欲化余人令舍五欲。剃除须发法服出家。故作是示现。是故菩萨复还入家。不于空闲之处即诣道场。是名菩萨摩诃萨行于方便。以何缘故。菩萨适生七日。摩耶夫人寻便命终。善男子。此是摩耶夫人命根尽故。非菩萨咎也。菩萨先在兜术天时。以天眼观摩耶夫人命根。满十月已余有七日在。尔时菩萨。便从兜术天来。菩萨以方便。知摩耶夫人命根欲尽。故来下生非菩萨咎。是名菩萨摩诃萨行于方便。以何缘故。菩萨善学书论博弈射御军策计谋种种伎艺。善男子。学世法故。菩萨于三千大千世界中。无有一事而不知者。若偈。若辞辩。若应辩。若咒术。若戏笑。若歌舞作乐。若工巧。菩萨生时。已一切善知。是名菩萨摩诃萨行于方便。以何缘故。菩萨纳妃婇女眷属。善男子。菩萨不以欲故。何以故。菩萨是离欲丈夫。尔时菩萨。若不示现妻妇男女者。众生当谓菩萨非是男子。众生若作是疑得无量罪。欲断彼疑故取释种女。示现有罗睺罗。若人谓罗睺罗是父母和合生者。莫造斯观。而罗睺罗天上命终。来下入胎。非是父母和合故生。又罗睺罗有本愿故。若有一生补处菩萨。我当为作子。瞿夷本于然灯佛时。作如是言。从今已后愿为此梵志。乃至一生补处。常为我夫。我为其妻。尔时菩萨。即受七枝优钵罗花已。作如是言。我虽不受。今当满此善女人愿。作是愿已。不离七花善根。是故菩萨纳以为妃。复次一生菩萨成就示现处于宫殿婇女之中。尔时菩萨成就妙色。诸天供养成就出家。释种女悉见如是众事具足。其心专一作如是愿发菩提心。愿我具足如是众事。是故菩萨。为令瞿夷发此心故。纳以为妻。复次有大心众生处在居家。五欲财宝。僮仆眷属。种种受已。菩萨为彼众生。令舍居家五欲财宝僮仆眷属而行出家。故示是事。是故菩萨示处居家。五欲财宝僮仆眷属。舍而出家。众生见已如是思惟。菩萨所受五欲最妙无上。尚能舍之出家。何况我等而不出家。复次菩萨所有妻妇男女。皆是本行菩萨道时。以诸善法所可化者。此诸众生亦作是愿。若以此菩萨乃至一生。常当为作妻子眷属。亦欲增益如是诸人白净法故。是故菩萨处妻子眷属

复次菩萨处宫殿者。为欲教化四万二千婇女。令发阿耨多罗三藐三菩提心。亦令余人不堕恶道。是故菩萨处在宫殿妻子眷属。复次一切女人尽为欲火所烧。若见菩萨即离淫欲。复次菩萨变作诸身。颜貌修短与本无异。彼诸女人与化菩萨共相娱乐。各各自谓与实菩萨共相娱乐。彼时菩萨常在禅定修安乐行。如化菩萨受于五欲无有欲想。真实菩萨亦复如是。从然灯佛来。乃至一生已离淫欲。是名菩萨摩诃萨行于方便。车匿揵陟本愿亦复如是

以何缘故。菩萨在阎浮提树下思惟。善男子。为欲教化七亿诸天故。复次菩萨欲令父母知菩萨必定剃除须发法服出家。复次菩萨欲示现增益智慧。阎浮树随荫菩萨。欲令众生增益善根故。是故菩萨。在阎浮树下坐禅思惟。是名菩萨摩诃萨行于方便。以何缘故。菩萨不以五欲自乐而出城游观。善男子。欲示现见老病死人故。令诸眷属知菩萨畏老病死故出家学道。非为贡高损减眷属故出家。欲利益眷属故出家。菩萨见在家过患。是故出家。而此菩萨为示一切众生老病死苦。是故菩萨不乐五欲出城游观。是名菩萨摩诃萨行于方便。以何缘故。菩萨夜半出家。善男子。欲示现利益众生善根。菩萨随所住处增益众生善根。善男子。亦为白净法故舍离五欲。不告眷属而便出家。离诸欢乐终不离于白净之法。是故菩萨夜半出家。是名菩萨摩诃萨行于方便

以何缘故。菩萨以睡眠覆盖宫人伎女然后出家。善男子。欲令出家之过悉在诸天。故有眷属诸亲。或见菩萨出家。便生嗔愤之心。若菩萨如是思惟。是人有恶心。于我便当长夜受苦堕三恶道。彼眷属诸亲作如是知。此是诸天以睡眠覆故。开门引道升空而去。非菩萨过也。尔时诸人增益信心。于诸天所生不信心。是故菩萨见如是过。以睡眠覆盖宫人伎女。然后出家。是名菩萨摩诃萨行于方便。以何缘故。菩萨遣车匿白马。及宝衣璎珞而送还家。善男子。欲令眷属知菩萨不贪在家名衣上服及诸宝璎。复次菩萨如是观。我今作如是学。亦令诸人学我舍诸所有于佛法出家。诸人如是学已。远离一切所爱之物。持四圣种行。唯不听父母不放而得出家。是名菩萨摩诃萨行于方便

以何缘故。菩萨以刀自下其发。善男子。于三千大千世界中。无有天龙鬼神乾闼婆人非人能当近菩萨威德者。何况能与剃发。复次菩萨示现欲令众生深信菩萨欲出家故。自持刀下发。复次菩萨为净饭王故。尔时净饭王生于恶心。自恃豪族傲慢而言。谁剃我子发。我当诛戮。尔时净饭王。闻菩萨自持刀下发。王闻是已恶心即灭。是名菩萨摩诃萨行于方便

善男子。汝今善听。以何缘故。菩萨苦行六年。善男子。非是菩萨宿业余报受此苦也。欲令众生于一切恶业报中能生患心归向菩萨。复次善男子。昔迦叶佛时。菩萨尔时作如是言。我不欲见此秃头道人。何有秃人能得菩提。菩提之道甚深难得。如此之辈亦是菩萨示行方便。此所说者当知其义。以何缘故。菩萨作是粗恶之言。善男子。尔时迦叶佛出于世时。有婆罗门子名曰树提。有亲友五人皆是大婆罗门子。先学大乘。彼时五人久来亲近恶知识故。失菩提心。善男子。彼时五人于迦叶佛时。奉事外道不信佛法。解外道语不解佛语。解外道法不解佛法。彼时五人事外道师。彼师自言。我是佛世尊是一切智。我亦有菩提道。尔时树提梵志行于方便。欲诱引五人还成宝器故。欲转彼五人外道邪心。以方便故至瓦师所。作如是言。我今欲见秃头道人。何有秃人能得菩提。菩提之道甚深难得。善男子。说是语已复经少时。树提梵志与彼五人在一屏处。尔时瓦师便至其所。至其所已。即向树提梵志。赞迦叶佛如来应正遍知。复向树提作如是言。汝可与我共至佛所。善男子。尔时树提梵志如是思惟。此五人者善根未熟。若我当赞迦叶佛非外道师者。而此五人心当生疑。若至佛所无有是处。尔时树提自护本愿故。般若波罗蜜报行方便故。作如是言。我不欲见此秃头道人。何有秃人能得菩提。菩提之道甚深难得。云何般若波罗蜜报菩萨行。般若波罗蜜。无有菩提想。无有佛想。尔时不见佛。不见菩提。亦不于内见菩提。亦不于外见菩提。亦不于内外见菩提。如是悉知菩提空无有法。尔时树提知一切法无所有故行于方便。作如是言。我不欲见秃头道人。何有秃人能得菩提。菩提之道甚深难得。善男子。复于异时。树提梵志与彼五人至河水边。尔时瓦师承佛神力。为化五人故复至其所。向树提梵志作如是言。汝可共我至于佛所。礼拜供养恭敬尊重赞叹。诸佛世尊出世甚难。彼树提梵志。闻瓦师叹故不肯去。彼时瓦师寻前以手捉梵志发。强牵将去向于佛所。彼时五人倾心随逐。树提梵志遂至佛所。时国常法。若捉他发。设其告官。捉者应死。尔时五人生邪见。见树提梵志。他捉其发心倾随逐。彼如来法有何功德。乃令瓦师不计死罪。捉树提发将至佛所。礼拜供养恭敬尊重赞叹。尔时五人其心倾向至迦叶佛所。既得见佛。本愿还发生信敬心。生信敬心已。即于佛前呵责树提。如是世尊。有如是威德。如本闻已。何得心不信敬。善男子。尔时五人见迦叶佛威德。又闻辩才。还发阿耨多罗三藐三菩提心。尔时迦叶佛见五人已得专心。为说菩萨藏不退转轮陀罗尼金刚句。无生法忍次第而说。尔时五人即得无生法忍。善男子。我今已得具足佛智。彼时树提梵志。若当赞叹迦叶佛。不赞外道师。若彼五人到佛所者无有是处。况生信敬心耶。善男子。树提梵志为化五人学菩萨乘。故以般若波罗蜜果报行于方便。作如是言。我不欲见秃头道人。何有秃人能得菩提。菩提之道甚深难得。善男子。不退菩萨于佛无疑。于菩提无疑。于佛法无疑。是名菩萨摩诃萨行于方便。复次菩萨。为教化五人及自示业报。以业障故六年苦行。非如余众生不知不见。持戒沙门婆罗门故。说如是恶言。若知若不知。若解若不解。彼诸众生。长夜受诸苦恼。不得利益。堕三恶道。为彼众生自现作业亦现受报。是故如来现受是报。菩萨无有一切障碍业报。以有众生诽谤持戒沙门婆罗门。忧恼覆心不得解脱。不得道果。为除众生忧恼心故。现受如是业报。彼诸众生作如是念。一生菩萨诽谤迦叶佛。而彼菩萨尚得解脱。况我不知而作恶言。是故我今当自悔过。一切恶业更不得作。复次善男子。为调伏诸外道故六年苦行。非实业障碍。何以故。世间沙门婆罗门。日食一麻一米。谓得清净解脱。菩萨为调伏彼故。示现日食一麻一米。菩萨若食粗涩尚不能得圣道。何况清净解脱。是故菩萨作如是言。我不欲见秃头道人。何有秃人能得菩提。菩提之道甚深难得。是故菩萨以此缘故现六年苦行。为调伏五十二百千粗行诸天。及外道神仙。粗行菩萨。是名菩萨摩诃萨行于方便

大宝积经卷第一百七大宝积经卷第一百八

        东晋天竺居士竺难提译

    大乘方便会第三十八之三

以何缘故。菩萨食已得气力充足至菩提树。不以羸瘦至菩提树。善男子。菩萨能不饮食身体羸异。成阿耨多罗三藐三菩提。况食麻米耶。尔时菩萨为愍当来众生故。食此上妙食。何以故。众生善根未熟。不啖饮食而欲求道。彼诸众生饥渴苦故。不能得智慧。若安乐行能得智慧。照明诸法非苦行也。是故菩萨示众生行安乐行而得智慧。亦愍当来众生故。欲令众生效我食此妙食。是故食修舍佉尼食已。成三十七助菩提法。得阿耨多罗三藐三菩提。施食女人亦成就助菩提法。复次菩萨在一禅中生欢喜心。于百千劫不食能住。是名菩萨摩诃萨行于方便

以何缘故。菩萨从吉安天子求草敷座。善男子。过去诸佛敷解脱坐。不以綩綖妙物。亦欲成就吉安天子助菩提法。尔时吉安与菩萨草已。发阿耨多罗三藐三菩提心。善男子。今我当与受记。彼吉安天子。于未来世当得成佛。号曰无垢如来应正遍知。是名菩萨摩诃萨行于方便

以何缘故。菩萨坐菩提树下。使恶魔波旬至菩提树下。不欲令菩萨即成阿耨多罗三藐三菩提。善男子。魔本不能至菩提树下。若我不召而能来此者。无有是处。善男子。尔时菩萨坐菩提树下如是思惟。于四天下谁为最尊第一。此四天下今为属谁。菩萨即知恶魔波旬欲界最尊。今我与魔共斗。魔若不如。一切欲界所有众生悉皆不如。尔时当有诸天大众和合而来到菩提树下。到已必生信心。魔众天众诸龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。如是一切众来绕菩提树。彼诸众等见菩萨师子游戏。见已或发阿耨多罗三藐三菩提心。或发菩萨心。或生信心。彼人乃至见菩萨因缘故尽得解脱。善男子。菩萨如是思惟已。放眉间白毫相光。能令波旬宫殿黑闇。尔时三千大千世界。以光明照故普令大明。此光明中出如是声。彼释种子出家学道。今当成阿耨多罗三藐三菩提。过魔境界胜出魔众。减损当来一切魔众。今彼菩萨与魔共战。善男子。尔时波旬闻是声已。心大忧愁如箭入心。时魔波旬严四种兵。满三十六由旬。一切皆来围菩提树。欲为菩萨作大留难。尔时菩萨住大慈悲及大智慧。以智慧执金色之手而以拍地。拍已一切魔众寻时散坏。魔众坏已。八万四千亿天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽拘槃荼等。如是大众见菩萨威德身体微妙容颜端严威力勇健。发阿耨多罗三藐三菩提心。是名菩萨摩诃萨行于方便

以何缘故。如来于七日七夜。不舍结加趺坐。仰观菩提树目不暂眴。善男子。尔时有色界天行寂灭行。彼诸天等。见如来结加趺坐心生欢喜。生欢喜已如是思惟。今我当求沙门瞿昙。心何所依。彼诸天人于七日七夜作是求已。不得如来一念依处。彼时诸天倍增喜悦。有三万二千天子。发阿耨多罗三藐三菩提心。作如是愿。我等于未来世。当得如是寂灭之行。仰观菩提树。是故如来得成道已。于七日七夜结加趺坐。仰观菩提树目不暂眴。是名如来方便

以何缘故如来本行菩萨道时。修无量阿僧祇行愿。诸一切众生与解脱乐。何以方待梵王请然后说法。善男子。如来有如是知。多有天人归依梵王尊重梵王。彼诸众生作如是知。梵天王化生我等世界最尊。若除梵王更无有能造世界者。善男子。尔时如来如是知已。今我等待梵王劝请。若彼梵王一倾首者。诸可归依梵王众生悉皆归依。当相谓言。梵王劝请如来说法非为不请。善男子。如来有大威德故。梵王来至我所。劝请说法转于法轮。善男子。若我不以神力令梵王请者。然彼梵王先无有心能来请佛。善男子。由诸众生依梵王故。欲令众生离于梵王待其劝请。以梵王为证故。善男子。尔时梵王劝请如来转于法轮。彼时六十八百千梵天。发阿耨多罗三藐三菩提心。作如是言。此真是佛。于众生中最尊最胜。作如是愿言。我来世得成就如是智慧威德。是名如来方便

善男子。我先于说示现众生十业因缘。或是菩萨。或是如来。于此十中示现方便。唯有智者能知是义。善男子。不应生念。谓菩萨当有微细之罪。若菩萨成就如是微细不善之法坐于道场。成阿耨多罗三藐三菩提者。无有是处。何以故。善男子。如来成就一切善法。断一切不善法。无有生死业报习气若有遗余不断灭者。无有是处。何况有障碍业报。善男子。若有众生谓无业报不信业报为是众生示现业报因缘。如来实无业报。我是法王尚受业报。况余众生而不受耶。为彼众生作如是示现。是故如来自现业缘。善男子。如来无有一切业障。譬如书师善学书论教诸幼童。随诸幼童赞诸书章。非是书师于诸书章有障碍也。书师作如是念。彼诸幼童当随我学。善男子。彼书师非为不达故。作如是唱。善男子。如来亦复如是。于一切法善学已。如是说如是示。为余众生令行业清净故。善男子。譬如大药师。善能疗治一切诸病自无有病。见诸病人而于其前自服苦药。诸病人见是药师服苦药已。然后效服各得除病。善男子。如来亦复如是。自除一切烦恼病已。于一切法无有障碍。能示现一切法。以是不善业故。得如是报。现如是缘。欲令众生除一切身口意业障行于净行。善男子。譬如长者子。若居士子。父母爱念与其乳母。时此乳母无有病痛。为婴儿故自服苦药。欲令乳得清净。善男子。如来亦复如是。是一切世界之父。为教化不知业报众生故。如来无病而为众生示现作病。以是业故得如是报。以此业故得如是报。众生闻已心生惊畏。除诸恶业不作恶缘。佛复告智胜菩萨。善男子。乃往过去世遇然灯佛。时有五百贾人。为求珍宝入于大海。善男子。时贾人中有一恶人多怀奸伪。常行恶业初无悔心。善知兵法恒为寇贼。夺他财物以为产业。状如贾人共诸贾人同载一船。时彼恶人如是思惟。此诸贾人大得珍宝。我今当杀此诸贾人。取其珍宝还阎浮提。如是思惟已欲杀诸人。善男子。尔时有人名曰大悲。于彼众中作大导师。时彼导师于夜梦中。见海鬼神来作是言。汝此众中有一恶人。如是相貌恒为寇贼劫他财物。彼人今生如是恶心。我当杀此五百人已。取其财物还阎浮提。若此恶人得遂本心杀五百人者作大恶逆业。何以故。此五百人皆是向阿耨多罗三藐三菩提不退转菩萨。若此恶人杀诸菩萨。以此业缘障碍罪故。一一菩萨从初发心。乃至成阿耨多罗三藐三菩提。尔时恶人于其中间常在地狱。汝为导师可作方便。令彼恶人不堕地狱。彼五百菩萨。亦复可得全其身命。善男子。尔时大悲导师如是思惟。作何方便令彼恶人不堕地狱。五百菩萨全其身命。作如是思惟已。乃不向一人说是事也。尔时待风余有七日。当还阎浮提。七日过已如是思惟。更无方便唯有除此一恶人者。尔乃可令此五百人得全身命。复作是念。若我向余人说。此五百人当生恶心。生恶心已杀此恶人。彼诸人等当堕恶道。善男子。大悲导师如是思惟。我今当自杀之。我以杀此人故。虽百千劫堕恶道中受地狱苦。我能忍之。不令恶人害五百菩萨。作此恶缘受地狱苦。善男子。尔时大悲导师生哀愍心作是方便。吾护五百人故害此恶人。是时导师。即以[矛*(替-曰+貝)]牟刺杀恶人。令诸贾人安隐得还至阎浮提。善男子。汝勿有疑。尔时导师则我身是也。五百贾人此贤劫中五百菩萨是也。当于此劫中成阿耨多罗三藐三菩提。善男子。我于尔时行方便大悲故。即得超越百千劫生死之难。时彼恶人命终之后。生善道天上。善男子。汝今当知。勿谓菩萨有如是障碍业报。而得超越百千劫生死之难。即时是菩萨方便力也

善男子。如来为一切众生故。而作是方便。示现佉违罗刺。善男子。尔时佉违罗刺刺如来足。善男子。佛神力故令刺入足。何以故。如来金刚之身无能坏者。善男子。昔舍卫城中有二十人。皆是最后边身。彼二十人更有怨家二十人。各各思惟。我当为作亲友。而至其舍夺其命根。不向人说。善男子。彼时二十最后身者。及二十怨家人。以佛神力故共至佛所。善男子。如来尔时为调伏是四十人故。于大众中。告大目揵连言。今此地中出佉违罗刺。欲刺吾右足。未至足之间。此佉违罗刺即从地出长一肘。当出之时。目连白佛言。世尊。我今当取此刺掷着他方世界。佛告目连。非汝所能。此佉违罗刺今在此地。汝不能拔。尔时目连以大神力前拔此刺。于时三千大千世界皆大震动。一切世界随刺而举。不能动刺乃至一毛。善男子。尔时如来以神通力上四天王。彼佉违罗刺亦随佛去。尔时如来复至三十三天。夜摩天。兜术天。化乐天。他化自在天。刺亦随去。乃至梵天亦复如是。尔时如来从梵天还至阎浮提舍卫城中本所坐处。刺亦逐还至此地中竖向如来。尔时如来即以右手捉佉违罗刺。左手安地右脚踏之。尔时三千大千世界皆大震动。时尊者阿难。即从坐起。偏袒右肩。为佛作礼。合掌向佛。而作是言。世尊。往昔作何等业得如是报。佛告阿难。我过去世入大海中。持[矛*(替-曰+貝)]刺人断其命根。阿难。以此业缘得如是报。善男子。我说是业缘已。彼时二十怨贼欲害二十人者作是思惟。如来法王尚得如是恶业之报。况我等辈不受此报。是二十人即从座起。头面礼佛作如是言。我等今日向佛悔过不敢覆藏。世尊。我先恶心欲害彼人。今重悔过不敢覆藏。尔时世尊为彼人故。说作业缘及尽业缘。时二十人闻是法已即得正解。及四万人亦得正解。是故如来示佉违罗刺刺足。是名如来方便

以何缘故。如来先无诸病。而从耆域药王。索优钵罗花嗅之令下。善男子。尔时如来制解脱戒未久。时有五百比丘。是最后身常在余诸林中修道。彼诸比丘得如是病。陈故之药所不能治。彼诸比丘敬慎佛戒。不求余药不服余药。善男子。尔时如来如是思惟。作何方便听服余药。若我听者。彼诸比丘当求余药当服余药。何以故。若如来不听者。后诸人辈当犯圣法。是以如来行方便故。从耆域药师。求优钵罗花嗅之令下。时净居天即至彼比丘众中作如是言。大德可求余药。莫守病而死。比丘答言。我等不敢违世尊教。我等不得自在。我等宁死不违佛教。我等不求盈长好药。如是说已。净居天子语诸比丘言。大德如来法王。求余好药舍陈故药。诸大德可求余药。诸比丘闻语已。除去疑心更求余药。更服余药然后除病。除病已不过七日证阿罗汉果。善男子。若如来不求余药。彼诸比丘亦不求余药。若不求余药。能除诸病及断诸结。证于阿罗汉果者。无有是处。是名如来方便

以何缘故。如来入城乞食空钵而出。善男子。如来无有业障。尔时如来。矜愍护念当来比丘。或有比丘入于城邑聚落乞食。自无福德乞食不得。彼比丘当作是念。如来世尊功德成就。入城乞食空钵而出。何况我等善根微薄。我等不应以乞食不得而生忧恼热。是故如来示现入城乞食空钵而出。善男子。汝若谓恶魔波旬能覆蔽城中长者婆罗门心故。乃至不与一抟食者。善男子。莫作斯观。何以故。恶魔波旬。不能断绝如来食也。尔时佛神力故。令恶魔波旬覆蔽彼城中人。非是恶魔力之所能。我于尔时都无业障。为化彼众生故。示现空钵而出。尔时我及比丘僧不得食已。一切魔天及诸余天。作如是念。佛及众僧不得食已。颇有忧耶。即于其夜见佛及僧。乃至无有一念忧恼。心亦不高亦复不下。如前后亦如是。善男子。尔时有七千天子。倾向如来生信敬心。我于是时即为说法。于一切法得法眼净。善男子。彼时婆罗门长者。其后不久。又闻世尊有大威德。生渴仰心即至佛所。头面作礼向佛悔过。彼时如来。即为其说四圣谛法。一说法时有二万人。于一切法中得法眼净。是故如来。入城乞食空钵而出。是名如来方便

以何缘故。旃遮婆罗门女。以木杆系腹诽谤如来。而作是言。由沙门瞿昙令我妊身。应当与我衣被饮食。善男子。如来于此事中都无业障。若有业障。我能掷此旃遮婆罗门女。置恒河沙世界之外。如来以方便故现此业障。为化不知解众生故。何以故。当来之世有诸比丘。于我法中出家学道。尔时或为他人所谤。以是缘故心生惭愧。或不乐佛法舍戒还俗。彼诸比丘。若被谤已当念如来。如来成就一切善法具大威德。尚被诽谤。而况我等不被诽谤。思念是已则除惭愧。除惭愧已。当得修习净妙梵行。善男子。旃遮婆罗门女。常为恶业所覆故性多不信。今此女身于佛法中不得调伏。常为恶业之所覆蔽。乃至梦中亦生诽谤。觉已心喜。此女人中命终当堕地狱。善男子。我能以余方便。除此女人诸不善业。令度生死能为作救。善男子。或时如来不救余人。何以故。如来于一切众生无有偏心。是名如来方便

以何缘故。诸婆罗门。杀婆罗门女孙陀利。埋祇洹园堑中。善男子。如来是时知有是事舍而不说。如来成就一切智心无有障碍。能以神力。可令此刀不入女身。我于尔时知孙陀利女命根将尽必为他杀。以此方便令诸外道。不善彰露堕不如处。如此诸事唯佛知之安住是事。令多众生生清净心增益善根。尔时如来七日不入舍卫大城。不入城已。尔时调伏六十亿天。过七日已诸天世人。集会共来至于我所。尔时如来为四众说法。闻说法已。有八万四千人。于诸法中得法眼净。是名如来方便

以何缘故。如来及僧。在于婆罗门毗兰若聚落。三月之中食马麦耶。善男子。我于昔时知此婆罗门。必舍初始请佛僧心。不给饮食。而故往受请。何以故。为彼五百马故。此五百马于先世中。已学菩萨乘。已曾供养过去诸佛。近恶知识作恶业缘。恶业缘故堕畜生中。五百马中有一大马。名曰日藏。是大菩萨。是日藏菩萨。于过去世在人道中。已曾劝是五百小马。发菩提心。为欲度此五百马故现生马中。由大马威德故。令五百马自识宿命。本所失心而令还得。善男子。我愍彼五百菩萨堕马中者。欲令得脱离于畜生。是故如来知故受请。善男子。是时五百马减所食麦半持施僧。大马半分奉施如来。尔时大马为五百马。以马音声而为说法亦教悔过。今当礼佛及比丘僧。说此事已复作是言。汝等当以所食半分供养于僧。尔时五百马悔过已。于佛及僧生净信心。过三月已。其后不久是五百马命终生于兜术天上。彼五百天子。即从天来至于佛所供养如来。尔时如来即为说法。闻说法已。必定得成阿耨多罗三藐三菩提。彼时五百马子。善调伏其心。于将来世得辟支佛。彼日藏大马。于当来世供养无量诸佛。得成助菩提法。然后作佛号曰善调如来应供正遍知。善男子。无有世中上妙美味而如来不得。善男子。如来虽食草木土块瓦砾。三千大千世界中。无如是味似如来所食。草木土块瓦砾味者。何以故。善男子。如来大人得味中上味相。若如来以最粗食着口中已。其所得味胜天妙食。善男子。以是故知如来所食最是胜妙。善男子。尔时阿难心生忧恼。转轮圣王种出家学道。如下贱人食此马麦。我于尔时见阿难心。见阿难心已。即与阿难一粒麦。语阿难言。汝尝此麦味为何如。阿难尝已生希有心。白佛言世尊。我生王家长大王家。未曾得如是之味。阿难食此麦已。七日七夜更不饮食无饥渴想。善男子。是故当知。是如来方便。非是业障。善男子。有沙门婆罗门。持戒如我受他请已。而知请主荒迷不能供给。或不肯住。以是缘故。如来已所许处现必就请。及欲示现业报缘故。善男子。当知如来常法虽受他请不得供给。不令请主堕于恶道。善男子。若彼五百比丘共如来夏安居食马麦者。有四百比丘多见净故生贪欲心。彼诸比丘若食细食增益欲心。若食粗食心则不为贪欲所覆。彼诸比丘过三月已。离淫欲心证阿罗汉果。善男子。为调伏五百比丘度五百菩萨故。如来以方便力。受三月食马麦非是业报。是名如来方便

以何缘故。如来十五日说戒时。告长老迦叶。我今背痛。汝今说七觉支法。善男子。尔时有八千天子。以声闻法而自调伏。在彼众中和合共坐。善男子。彼诸天子于过去世。是大迦叶所教化者。于佛法僧而不放逸。彼诸天子。数闻迦叶比丘说七觉法。善男子。此诸天子。除迦叶比丘。若百千诸佛。为其说法不能令解。尔时迦叶。为诸天子广说七觉法。诸天子从迦叶比丘。闻七觉法已得法眼净。善男子。若有众生病苦缠身。不能得至于说法之处听法恭敬。彼诸人等当作是念。佛是法王尚听七觉法而得除病。何况我等不往听法不恭敬法。善男子。为调伏诸天除人苦患故。又示现敬重于法。是故如来作如是言。迦叶。我今背痛。汝当说七觉法。何以故。尊重法故。如来无有粗重四大之身。何况有病。是名如来方便

以何缘故。释种破时。如来自言我头痛耶。善男子。或有众生作如是言。世尊不能利益亲族。亦不矜愍。不欲安隐而出家已。种族意断不欲救护。是诸众生以不知故作如是言。善男子。如来于诸苦本已到其边。如来知是众生心所念故。坐舍耶树下自言头痛。善男子。吾于尔时寻向阿难说我头痛。时有断见三千天子。复有无量好杀生者。皆共集会。为彼断见天子及好杀者。示现业障故作是言。吾以眼见他杀生心随喜故。今得头痛。说是法已七千人天皆得调伏。是名如来方便

以何缘故。颇罗堕婆罗门以五百种骂詈佛。如来闻已能忍。善男子。如来能以神力。掷此婆罗门置余世界。亦能以神力。令婆罗门乃至不能出于一言骂詈之声。善男子。时彼众中多有人天。见如来能忍恶骂不说不答。生于舍身等心利益心堪忍心。前如后后如前。尔时有四千人发阿耨多罗三藐三菩提心。如来见如是义。又颇罗堕婆罗门。以五百种恶骂已。见佛世尊生于舍心。善男子。是婆罗门。见如是已生信敬心。归依佛法僧种解脱根。是名如来方便

善男子。提婆达多与菩萨。世世共生一处。此辈亦是菩萨方便。何以故。我因提婆达多故。具满六波罗蜜。亦多利益无量众生。云何知尔。善男子。尔时众生快乐。不知行施不知受者。菩萨尔时欲教行布施。是时提婆达多。起嫉妒心至菩萨所。求国城妻子及头目手足。尔时菩萨欢喜施与。时有无量众生。见菩萨施心生欢喜信解布施。作如是言。如菩萨施我亦如是。行于布施愿成菩萨。善男子。提婆达多或见菩萨持戒清净知已。欲破菩萨所持之戒。尔时菩萨不毁净戒。时有无量众生。见菩萨持戒亦效持戒。菩萨持戒。或为他人轻毁恶骂不生恶心。尔时具足羼提波罗蜜。有无量众生。见菩萨以忍调心。亦效菩萨行于忍辱。善男子。当知提婆达多。大利益菩萨。善男子。如今提婆达多。放大醉象欲害如来。亦于耆阇崛山推下大石。俱是如来方便示现非业报罪。何以故。由此方便利益无量众生。善男子。如来总说十业因缘。皆是如来方便示现非是业报。何以故。众生不知业因所得果报。为众生故如来示现如是业报。此业作已得如是报。彼业作已得如是报。作如是业得如是报。众生闻已作如是业离如是业。离不善业修习善业。善男子。今说方便已。示现方便已。此诸方便坚持秘藏。不应为下劣之人薄善根者说。何以故。此经非声闻辟支佛之所行处。况下劣凡夫能信解耶。何以故。此人不能学诸方便。所以者何。此方便经非其所用故。非余瓦器所能受持。唯有菩萨。于此方便法能说能学。善男子。譬如夜闇然大明灯。得见室中一切所有。善男子。菩萨闻如是诸方便已。即见一切菩萨所行之道。于此法中我所应学。于一切如来行及菩萨行已到彼岸。善行菩萨道者不以为难。善男子。我今当说。欲得菩提道诸善法者。所谓善男子善女人。闻过百千由旬。有说此方便经处。当往彼听。何以故。若菩萨闻此方便经已得光明行。一切法中除疑悔心。尔时四众及诸人天成宝器者。说此经时悉闻悉知。非宝器者。虽在此会不闻不知。于此经中耳尚不闻。况能口说。非宝器故。是以如来说是法时。不闻不知。不蒙佛神力故。说此经已。七万二千人。发阿耨多罗三藐三菩提心。尔时尊者阿难白佛言。世尊。当何名此经。云何奉持。佛告阿难。是经名为方便波罗蜜。亦名转方便品。亦名说方便调伏。如是奉持。佛说是已。智胜菩萨心生欢喜。及学声闻辟支佛乘。学菩萨乘。比丘比丘尼。优婆塞优婆夷。并诸天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻说是已。赞言善哉善哉。今说大乘方便经竟

大宝积经卷第一百八大宝积经卷第一百九

        隋天竺三藏阇那崛多译

    贤护长者会第三十九之一

如是我闻。一时佛在王舍大城。住迦兰陀长者竹园。与诸比丘众千二百五十人俱。所作已办不受后有。长老舍利弗。为众之首。时诸比丘。围绕世尊欲听受法。身心调顺无有睡眠。当于尔时。如来世尊面貌容色。犹如初日开敷莲花。端严显耀微笑熙怡。尔时彼诸比丘等作如是念。今婆伽婆。欲宣说何等法门。面相乃然如是光显。当于彼时。有一最大巨富商主长者之子。名跋陀罗波梨(隋言贤护)。与其一千眷属围绕。威力欲似震动大地。安详徐步向世尊前。尔时贤护长者之子。宿福因缘受天果报。身体柔软。犹如初出新嫩花枝。诣于佛所。到佛所已。观见如来最胜最妙容色。寂静澄定功德藏身。犹如金树光耀显赫遍满竹林。是时贤护。即于佛所生净信心。合十指掌作如是念。于世间中得大名闻。此不虚说谓言萨婆若多陀阿伽度阿罗。呵三藐三佛陀者。斯真实也。尔时贤护即便低头顶礼佛足。两膝着地一心举头。谛视世尊目未曾瞬。如是瞻仰如来之时。其身俨然不倾不动

尔时世尊。见跋陀罗波梨长者。内心如是生渴仰已。如来即更身放妙光。而彼光明出照之时。其跋陀罗波梨长者。即得无畏。从地而起绕佛三匝。复更顶礼佛世尊足。礼已长跪而白佛言。唯愿世尊哀愍于我。唯愿世尊教示于我。大圣世尊。我于佛边信心未久。是故世尊。但当为我随逐现事说一法门。我今渴仰欲闻诸法。以生死中烦恼所逼。多有疑惑心恒分别。以是义故。唯愿世尊慈悲怜愍。为我说法令我决疑。大圣世尊。我无正知故有迷惑。不知出离生老病死烦恼海津。唯大圣尊是一切智。世间希有犹如意珠。能与一切众生诸乐令成就故。又复世尊犹如父母。为令一切诸众生等得善果报。即是根本

尔时世尊。告跋陀罗波梨长者。作如是言。跋陀罗波梨。若有疑者。今恣汝问。我当为汝分别解说。尔时跋陀罗波梨长者。蒙佛印可内怀欢喜欲问心疑。即便起立却住一面。住一面已其身威光圆满具足。尔时长老阿难比丘。既见彼已即白佛言。希有世尊。此长者子跋陀罗波梨。身光德力胜诸王威。殊妙绝群端正可爱。于世间内独无有双

尔时世尊。告阿难言。长老阿难。汝今欲闻此跋陀罗波梨长者家中所有众乐事乎。乃至具足说其受于快乐果报。虽复忉利帝释天王犹不能及。况复人间。此阎浮提能得及者。无有是处。唯除一人长者童子。名苏摩浮帝(隋言真月)。尔时阿难即白佛言。唯然世尊。此跋陀罗婆梨长者家宅之中有何殊胜。世尊乃尔称誉

尔时佛告长老阿难。汝当至心谛听谛受。是长者子所有资财善根广大。我今为汝次第宣说。阿难。是长者子。凡有六万最大商主恒随其后。彼诸商主。各有无量奇异财宝种种富饶。其跋陀罗波梨家内。恒常铺设六万上妙六合床榻。杂色被褥以覆其上。复以真绯杂色缯彩用为倚枕。持来两边杂色妙衣憍奢耶等。一一之处皆有四具。又火浣布及以粗纻。诸是四方土地所出种种衣服众杂异物。皆悉具足庄严其家。彼之衣裳悉皆柔软。犹如手掌清洁光润。其宅处处周遍皆悬真珠璎珞。以为挍饰。复有六万婇女。端正殊绝身体柔软细滑。闲於戏笑善巧语言。姿态艳美承接人意。嗔恚见之自然欢喜。忧戚遇者便生欣慰。调谑音词开心悦目并皆孝顺。瞻仰己夫妇礼具足。于余男子远离欲心。或复有时自知惭愧羞耻。合掌低眉曲躬恭敬。专向其夫无复余顾。或复有时。各各为其夫婿别怜爱故。心生妒嫉争斗相嫌。皱眉蹙頞犹如深钩。假此为戏实无妒心。手爪纤长指节圆佣。踝腕细密以欲醉身。妖冶顾眄行步庠序进止逶迤。发彩绀青细润柔软。巧为结梳能惊惑人。在于如是等诸婇女之中或侍或凭。彼诸婇女皆专奉夫。清净名闻处处流布。然此婇女种姓最大。处其家中亦好名闻。并堪匹偶大家为嫡妇。有如是种种等庄严。长者贤护家中不可称量宅甚宽旷。又其长者欲食之时。则有六万杂种羹臛饭食微妙香美。犹若天厨无有异也。其饭悉是糠粮色味充盈具八功德。随意进啖入口便销。食已随顺无所妨碍。果报感致称心自然。又复食已身体光鲜无诸臭秽。又其长者家内。复有六万辇舆。各以种种珍奇庄严。真珠间错上下正等。悉有妙衣以覆其上。又以香花各各布散。水洒于地无有尘埃清净润泽。又其家内。复有种种最上音声。手打指弹及以气吹。其响微妙鸣亮入神。歌曲正得犹白鸽声心所乐闻。如此微妙庄严其家。又其家内园林树木扶疏茂盛。花卉交加红紫鲜洁。其树林间复有诸鸟。各各出好音声。其音和雅犹如天宫。约须弥山众宝合成。龙窟无异。又然种种灯明。其灯光明无风动摇处处洞彻。朗夜赫奕与昼不殊。又复其家所住国界有六万城。其城各有街巷相当。楼橹却敌悉皆具足。彼城处处诸国商人往来聚集。种种形状。种种语言。种种珍奇众。杂宝货。共相贸易填咽城市。百千万众不可胜计。又彼诸城周匝四边。园圃杂树数百千种。花果繁茂枝叶扶疏。蜂众竞来采其香味。又彼诸城多有象马及诸车乘。阿难。彼诸城内所有大富长者居士商主及以商人。恒常一心。皆共称叹跋陀罗波梨所有功德。合十指掌顶礼赞咏。况彼名闻心皆愿乐欲得睹见。又其国主波斯匿王。见跋陀罗波梨长者。资财富饶形势福德。自身卑愻犹如贫人羡其财宝

阿难。其彼真月长者童子。每一食时即有千种珍味。晨昏左右所须自然。又有五千婇女。围绕承奉以为娱乐。阿难。是真月长者童子所受快乐。比天帝释已胜千倍。匹于跋陀罗波梨。形貌颜色库藏资财受乐果报。百倍不及其一

复次阿难。是跋陀罗波梨长者。有一妙车名为夺意。奇巧精丽人间所无。而此车中有天宝座。其车纯以天诸杂宝雕饰间错。彼诸天宝马瑙金刚真珠珍贝。光明显曜如虚空星庄严。如是其车行时迅疾如风。阿难。跋陀罗波梨。意欲至于海内采珍宝时。坐彼车中如意即至。受快乐已若欲还家应念便至

尔时阿难。顶礼佛足。合掌恭敬而白佛言。希有世尊。此跋陀罗波梨长者。往昔造何等善根。今世乃尔受斯果报。尔时世尊告阿难言。长老阿难。汝欲知者应当谛听。此之因缘皆由过去于诸佛边种殖善根。今得如是胜上果报。阿难。我念往昔有一如来出现于世。名曰乐光多陀阿伽度阿罗诃三藐三佛陀。阿难。尔时此跋陀罗波梨长者。于彼佛边作声闻僧名为法髻。持戒不完多有毁缺。而善宣说诸佛教法开示未闻。是大法师。一闻总持修多罗藏。亦持律藏。为诸众生常说法要。博识辩聪义味甚深。音声朗彻令人乐闻。得听法者心生欢喜。永即不复堕诸恶道。阿难。彼以如是法施因缘。九十一劫恒生天人端正富贵。阿难。是长者子。所得妙车因缘报者。我更为汝次第解说。阿难。是跋陀罗波梨长者。于彼乐光佛世作法师时。见诸梵行持戒比丘。羸瘦顿乏力弱无堪。凡有所须悉皆布施。复造鞋袜靴履等物欢喜施与。藉此功德今感妙车如意果报

复次阿难。往昔有佛。号曰迦叶多陀阿伽度阿罗呵三藐三佛陀。尔时彼佛告长者言。于未来世有佛。名曰释迦牟尼多陀阿伽度阿罗呵三藐三佛陀。彼佛世尊当授汝记。阿难。此跋陀罗波梨长者。我须教之令其生解。尔时阿难重白佛言。希有世尊。此长者子如是富饶多蓄财产。而性柔和不生贡高。在于五欲不染其心。佛告阿难。汝今当知凡是智者。不以资财及诸五欲心生憍傲。阿难。此长者子以妙法因。多受种种无尽福报。尔时跋陀罗波梨长者。蒙佛许可欲问所疑。即便一心在于佛前。长跪合掌而白佛言。大慈世尊。摄受一切众生。哀愍众生。我今心中有疑欲问。唯愿世尊为我解说使得断疑。尔时佛告跋陀罗波梨长者子言。跋陀罗波梨。汝心有疑欲断除者。今正是时。恣汝所问。我当为汝分别解说

尔时跋陀罗波梨长者即白佛言。世尊。诸众生等知有神识。而是神识犹如宝箧未开之时。不知其中是何等宝。世尊。此之神识相貌云何。复何因缘名为神识。世尊。云何人死无手脚眼。命终之时诸根欲灭诸大欲分。而此神识云何从此身中而得移出。世尊。而此神识复云何色。复云何体。从于身中云何得离此识。云何舍于此身成就别身。云何舍此诸大诸入向于后世。云何成就各各别身。世尊。人今既死未来诸入云何随顺。云何此世作诸善根。于未来世受于果报。既是此世诸入阴等造作善根。其人云何更复于后别诸阴中受其果报。云何此识彼处得身。云何诸入体随彼处

尔时世尊赞长者言。善哉善哉。跋陀罗波梨。如是如是。如汝所问。汝今至心谛听谛受。我当为汝说神识去来移灭。跋陀罗波梨。犹如风大虽无形色不可睹见。然由因缘而现形色。现形色者其义云何。譬如风吹动诸树木。发起山壁水崖触已作声。以冷热因缘所生是故能受。然彼风体不可得见。手足目等亦复如是不可得见。于诸色上增益胜处。或黑或白。跋陀罗波梨。如是如是。此神识界亦复如是。不可以色得见。亦不至色体。但以所入行。作体而现色。此识界亦复然。当须知云何于彼处此识界。得名受触法界耶。复云何此识界。舍此身已后受爱触等。譬如风界能移香气。故知此花香从风吹来。而其风界实不持花香而来。亦非无风而花香能来。彼香无色彼风亦无色。其彼闻香根亦无色。跋陀罗波梨。如是如是。彼死人识欲移持触受等及诸界已。有于彼世以父母和合故。然后可知有识。其识有故即知有受有触和合而成。犹如胜人识强胜故有香根。香根胜故有胜香。复有二身胜故有二事胜可见。二事胜者所谓色触。其风多故花香亦多。如是如是。以识大故受亦大。受大故识亦大。识大故诸界亦大。然知此善此恶也。譬如画师既善成就板。随欲出向作即能为。善意解故随色能作。然彼画师若无色不可现色。如是如是。此识成就六色身。所谓因眼见色。所有识智因眼见色者实无有色。因耳闻声者亦无色。因鼻闻香者亦无色。因舌知味者亦无色。因身觉触者彼触亦无色。因意有诸大者彼亦无色。所有知者亦无色。当知彼境界内亦无有色。如是次第此识当知皆亦无色。当应如是观。而汝问此识云何舍此身至于彼世者。跋陀罗波梨。夫命终时此识以业持故。此业及命尽时。譬如入寂灭三昧人有识身体。此识身体灭已。然后入寂灭内住。如是如是。此识于死人边。舍身及以诸大。舍已唯有念力。如是知我是彼某甲。凡人舍身之时。有二种触正念。何等为二。一者正念。二者触。而彼人命终之时。于身有触二受。一身受二念受。死后念有触

复次汝问识者何义。然有子能生牙。从智生识即名为念。是故智及子故名为识。然后还受于触。苦乐智知故名为识。后复受善恶。亦能知善恶境界故名为识。犹如从子生牙。其身成就故名为识

复次跋陀罗波梨。汝又问言。此识云何舍身已移向彼者。譬如镜中照现身形。又如泥团模内铸出身形。又复如日出时能灭诸暗。其日没已还复生暗。然而彼暗无有常定。非无常定之处。然彼暗无色无受不可见。如是此识生身已。如暗离明身生亦然。其人不见此识。然识受此身。譬如妇人受胎然不知此我怀胎。为男为女。或黑或白。或诸根具以不具。或手足正等。以不然。彼在胎之者。或以热食触故觉已即动。如是如是。此识来去伸缩共眼开闭。昔所造诸业故。所有境界即笑语言等。诸有所生得色身内住识。然诸众生不知我身内所住识有何体。跋陀罗波梨。此识善成就故。流至于一切诸有。然诸有不染着。跋陀罗波梨。诸有及识六根境界。是六界处。有四大处。有五阴处。跋陀罗波梨。如是识等境界汝当知。跋陀罗波梨。譬如木人以一机关作一切诸事。走跳现种种诸伎。跋陀罗波梨。于汝意云何。彼木人有何因缘作如是事。跋陀罗波梨白佛言。世尊。如来所问非我境界。我无智能答。佛复言跋陀罗波梨。彼者由巧智慧力作种种事。而彼巧业无有色。以智所生。如是如是。此身人由识巧故生。而此种种身由识所作。此识造身故生。而此识无有可尽。犹法界修熏故。往昔诸身忆念意成就。犹如日光此识应须当见。譬如日光照于秽浊臭恶诸尸。亦不为其所染。而其臭秽不离日光所生。如是如是。此识欲初生在粪秽所食诸不净。又在猪狗等腹内受胎。然彼识不为臭秽所染

复次跋陀罗波梨。此识舍身已。随善恶所行。此义何也。此识舍此身体即受彼罪福。譬如风界从山首出至于瞻婆林。因触故受微妙香。至臭秽之处。或至诸尸臭处。跋陀罗波梨。彼风随至多处。而取多气至彼即多。犹如彼风界将彼香气过。而彼风界无有色。及彼香亦无色。如是如是。此识舍身已将善恶而移。如是次第而去。彼识欲移。犹如睡梦人知一切诸物。有身不移本处。如是如是。有福亦生。欲移识时。犹如梦见诸事。然此识不从咽喉出。亦不从诸孔出。其识出时亦复不求诸孔。尔时跋陀罗波梨顶礼佛足白佛言。世尊。云何或鸡卵鹅卵在[穀-禾+卵]内。其[穀-禾+卵]无孔云何知识别而[穀-禾+卵]不破。其识云何移徙。佛告跋陀罗波梨。譬如以瞻婆等诸花熏乌麻。善熟然后压取油。而言此是瞻婆等花油。如彼香不破坏乌麻而香气移徙。彼香不着乌麻。因麻及花共和合故香气相着。然后香气不从麻子边求孔然后入。因彼二故其香移徙。如是如是。此识不破坏卵[穀-禾+卵]。妙香移徙此识转移亦复如是。汝当如是知

复次此识不移徙。犹如日火摩尼宝等光明。应如是见。复次此识移徙。犹如种子所至地方种子。而彼种子掷置地内。生牙茎叶花果子。或白或赤或黑。各有自味力成熟。而彼地界是一水火风大亦然。如是如是。此识有一法界。一切诸有中成就身然后生。或黑或白或赤等色。或本性刚强。或本性调柔

复次跋陀罗波梨。命终之时此神识舍身已。成后身种子因。欲作手足等体。而当时未有身分。而彼舍地分取法界分。而彼诸界共念和合。然彼念以信敬力故。法界念和合。取识不离识。而法界可见。亦不离法界识有因。然彼识风为助。自余法界皆为微妙。所谓念界受界法界色界

尔时跋陀罗白佛言。世尊。彼识云何有色。佛告跋陀罗波梨。凡有二种色。一者内二者外。言内色者何。所谓眼也。外者是色。若有眼识彼名内色耳内声外。鼻内香外。舌内味外。身内触外。意内法外。跋陀罗波梨。譬如生盲之人夜睡眠中。梦见种种天妙诸色最胜最上。而彼人见已生最胜喜乐。睡眠觉已便即不见。及至天晓而向他说。诸人辈听我昨夜眠中梦也。我见最妙最上端正妇女之形。复见丈夫百千数众。复见园林。此中彼处我皆梦见。或有人身体柔软。手足端严臂膊佣长。身体纤细腰跨正等。而彼生盲梦中所见诸人。身体形容及庄严璎珞皆悉具说尔时彼生盲人。如是所说形体生识不见。于汝意云何。彼生盲之人。睡眠所梦云何得见

跋陀罗波梨白佛言。善哉世尊。唯愿为我解说。此事云何得见。佛告跋陀罗波梨。跛陀罗波梨汝当知。以内眼因智力。彼生盲人。在梦中见非实眼见。跋陀罗波梨。如梦中人见色少时正念其死。人见内色亦复如是。复次跋陀罗波梨。更为汝解。其死人神识如种子移。譬如种子散于地上受取四大。如是此识受正念已。受受已受善及不善。已舍身已然后移。跋陀罗波梨复问世尊。云何此识受善及不善识然后移。佛告跋陀罗波梨。譬如莲花色摩尼宝随色影变。若置黑影形即变黑。若置白中即变为白。随其影形所在之处。彼摩尼宝即同其色。所安置处随其地分色即随变。如是此识受善及恶。而即移去亦复如是

尔时跋陀罗波梨。复问佛言。世尊。此神识何体而现。佛告跋陀罗波梨。此神识无形。无聚处。无积贮处。毕竟不可得。不可得言。此神识有生有灭有恼亦不可言。跋陀罗波梨。譬如从子生牙。亦不可得烂子生牙。亦非坏子生牙。而彼好子乃生牙成就。跋陀罗波梨。于汝意云何。彼子牙住何处。或在茎或在叶或在根。为彼子在树枝。如是如是。此识于身体无处倚住。不在眼不在耳不在鼻。乃至亦不在意。犹如从子生牙。所生子牙者。以取受为本。彼处取故。即便受胎。受胎已即有触。如生牙已依时即有枝叶花。有枝叶花即有子。如是如是。此识先成就身体。身体成就已。其神识无处可住。亦不离神识有身。如彼种子从树熟已然后有子。非生果有子。如是如是。此身命终之时。从身体中此神识显现。以受和合。以爱相缚以念相执。善攀缘和合。或非善攀缘和合。以风界相持。智熏逐业缘。父母和合。然后此识显现。跋陀罗波梨。譬如善成就好明镜见面形。非无其面得见面形。亦非无明镜可有面形。如明镜及面两缘和合得有面形。而其面形无有色。亦无受亦无有识。但随身转动。其镜内形亦转动如身。言语移徙转动申缩俯仰。随所作者。其镜内面形。亦作如是事相显现。跋陀罗波梨。于汝意云何。其面形因何事故。而现形镜中。跋陀罗波梨白佛言。世尊。因人身体故现彼镜中。如是形随其身色。面亦有如是色。彼形亦如是色。或诸根具足。或不具足。彼面形于明镜中。亦复如是现其形相。跋陀罗波梨。如彼明镜成就面形。以有身故。彼明镜中现形。如是此身。因识有受有取有识有诸行。思念成就身体。言彼明镜者。彼缘父母和合。当知如身灭已。无有识形。如彼明镜现面形已。又清水中更见面形。如此识舍此身形已。至于彼复受余诸阴。譬如尼拘陀树子。或优昙婆罗等诸树子。虽复细小。而能生极大树枝。生大树枝已。舍彼形复更余处生。而彼子界舍树形已。随时干枯无复本味。其本味灭已。彼树便即干枯萎悴。如是此识。微细无定色形。生诸身已更复舍。更成就前别体。犹如大麦小麦乌麻小粒大粒等子。随所地方散处。于彼地方即便着根。如是如是。此识所有众生身内。移于彼处。即有取有受而住。或受福或受罪。从此世移至彼世。犹如蜜蜂见其味。于花内取其味香。而舍其花更移别花。或舍恶花移至好花。坐花上已乐着彼花取彼香味。如是如是。此神识以多善根。或受天身。受天身已。以恶果故。或复受地狱畜生饿鬼等身。受已复受别身。而此神识云何须观。譬如郁金香子。或红蓝花子。或分陀利花子。其体本随分色不定。而彼子内不可见牙亦无定色。而彼子入地得水润泽即便生牙。有牙已然后生花。而彼色不可以子得见。亦不离子有牙及色。如是如是。此识舍此身已欲成彼身。彼肉团内未有诸根。何况诸入。既无诸根及入。岂可有天眼天耳及香味触。体得有知理岂可知。我于彼时作如是诸业。我过去如是身体。但因识而受。譬如蚕虫以自身口出于丝缕作茧。缠绕其身于中即死。如是如是。此识自生身已还自造业。犹如蚕虫出丝缠绕。即自灭身移向于彼。譬如莲花生于水中。即有妙色香味。而彼花内无水正体而可得见。彼花灭已。所有地方置子于中。则有色香所住。如是如是。此识所移之处。诸根境界无共移者。受亦无移。其所移者唯有法界。譬如如意珠随所至之处。有须之物即随念得。犹如日天光明自随逐日而行。日所至处光亦至彼。如是如是。此神识所移至处。受想法界等相随不离

复次此识舍身已取一切诸有。聚集取已。无肉无骨来就后身。彼取色身有及诸触等事。以天眼观见善恶受取。譬如小枣千年枣。庵摩罗果。迦毗陀等果成就时。各有一味。或苦或酢。或甘或碱等诸六味。而彼诸果熟已。在所地方其味在内。子移彼处各自有味。如是如是。此识子所移之处。彼自有触随福及无福。以有及念自随而移

复次此识。舍身时作如是念。如我今舍此身故。名此念识。为识知善业不善业。知此业随我而行。知我随此业而行。如是等知故名为识

复次此身知造一切诸业故名为识。犹如风界或时冷或时热。或时随臭有气。或时因香有气故知为风。如是此识体无有色。以取因色故。或欲取因故。或见取因故。或持戒求报取因故。乃至有受受因故受身体色成就故言为识

尔时彼众中有一长者童子。名曰苏摩浮坻(音多尼反隋言真月)从座而起。合十指掌。而白佛言。世尊。其色云何须观取。云何须观欲取。云何须观见取。云何须观戒取。云何须观。佛告真月。凡有智者。欲知汝所问。当如是知。真月若有善色。若有非善色。从肉团时。须观筋血。脉及气脉。髑髅缝脑。大肠小肠。肺心肝肾脾胆诸藏。脂[月*冊]髓血。痰阴涕唾。不净臭秽非常可畏。毛发髭鬓皮肤裹覆聚集。聚已所有诸色皆为四大。所成四大者。取色以成身故名取色。苏摩坻彼身以父母和合成牢鞕者。彼即是地大。所有稀软者。彼名为水大。所有暖成熟者。彼名为火大。所有摇动屈伸者。彼名为风大。所有知者。彼名声香味触等界。所念知者故名为识

尔时苏摩浮坻。复白佛言。世尊。云何死时舍彼色界。云何彼识从彼身出。云何彼身舍已。作如是知。此是我身。佛报真月言。真月。受此身正住之时。身业既尽舍于诸大。譬如以乳和水以火煎煮。以得热气乳水各别。而彼乳所有脂腻味彼无有色。真月。如是如是。死人身别诸大亦有别。神识亦有别。然彼识取诸大。及取法界。已以法界熏念。取善及恶至于来世。譬如摩诃迦良那药苏(隋言大真乐苏)。取种种药味力煎。其内或有辛或有苦。或有醋或有碱。或有淡或有甜。取诸味已入体成熟。色香等味取已。彼苏体舍移而成药味。此识亦复如是。舍身已取善及恶。及取法界。此识移去。言彼苏味体者。即以喻身。言彼诸药和合聚集者。喻彼诸根。言诸药色香味触者。喻识移去故言识。诸味将去者。即是识移。应当如是观。言人色别异者。或善色或恶色。或入体大真药苏熟消。即是喻善业。当如是观。若言因彼大真苏食已出痿黄色。即是喻不善业。当如是观。如大摩诃迦良那药苏宝者。如是此识。应当观如摩诃迦良那药苏。取诸药色味。取已成大真药苏。而彼苏无有手足及诸根。但取彼味。如是如是。此诚舍身已及舍诸界。唯取法界。取受已取善及恶而去。真月。彼人舍身已。于来世得正念得天念。或见六欲诸天。或见十六大地狱。或见身体诸根具足。彼于尔时作如是知。此是我身也。彼人命终之时。彼念见种种相。或见微妙辇舆。或见微妙园林。其园林内有种种树木。新生蓊郁可爱。或有妙池。或见种种成就诸事。彼见如是等诸相。心生欢喜。生欢喜已。安隐如法取命终。而彼人神识。犹如乘马。应当如是观。言乘马者。譬如有人在战场内。身着好牢铠甲。善持马控辔速疾骗骑。如是此识。着攀缘铠甲善果报。速疾乘出入息。舍诸界诸入等。舍已取后生诸梵天。乃至阿迦腻吒等天微妙之处

大宝积经卷第一百九大宝积经卷第一百一十

        隋天竺三藏阇那崛多译

    贤护长者会第三十九之二

尔时会中。有月实胜上童真。从座而起。合掌白佛言。世尊。云何见色因。云何见欲因。云何见见因。云何见戒取因。佛告月实。智见智境。愚见愚境。智者见诸姝丽美色。了知秽恶。唯是肉段。筋骨脓血。大脉小脉。大肠小肠。[月*冊]液脑膜。肾心脾胆。肝肺肚胃。生藏熟藏。黄淡涕唾。发须毛爪。大小便利。薄皮裹之。不净污露。可畏可恶。凡所有色。皆四大生。是为色因。月实。如父母生身。身之坚鞕为地大。流润为水大。暖热为火大。飘动为风大。有所觉知。念及声香味触等界。斯皆为识。月实童真。复白佛言。世尊。将死之时。云何识舍于身。云何识迁于身。云何识知今舍此身。佛告月实。众生随业获报。识流相续持身不绝。期毕报终。识弃舍身。随业迁受。譬如水乳和煎。以火热力。乳水及腻各各分散如是月实。众生命尽以业力故。形骸与识及诸入界。各各分散。识为所依。以取法界及法界念。并善恶业迁受他报。月实。譬如大吉善苏。以众良药味力熟功。和合为之。大吉善苏弃凡苏性。持良药力。辛苦酸碱涩甘六味。以资人身。便与人身作色香味。识弃此身。持善恶业及法果等。迁受余报亦复如是。月实。苏质如身。诸药和合为大吉善。如诸法诸根和合为业。众药味触资成于苏。如业资识。服大吉善。悦泽充盛光色美好。安隐无患。如善资识获诸乐报。服苏违法。颜容变恶惨无血气。色死土白。如恶资识获诸苦报。月实。吉善宝苏无手足眼。能取良药色香味力。识亦如是。取法界受及诸善业。弃此身界受于中阴。得天妙念。见六欲天十六地狱。见己之身。手足端严诸根丽美。见所弃尸。云此是我前生之身。复见高胜妙相天宫。种种庄严花果卉木。藤蔓蒙覆光明赫丽。如新炼金众宝钿饰。彼见此已心大欢喜。因大喜爱识便托之。此善业人舍身受身。安乐无苦如乘马者。弃一乘一。譬如壮士武略备具。见敌兵至着坚甲胄。乘策骥骏所去无畏。识资善根。弃出入息舍界入身。迁受胜乐亦复如是。身梵身天爰至有顶生于其中。尔时会中大药王子。从座而起。合掌白佛言。世尊。识舍于身作何色像。佛言。善哉善哉。大药。汝今所问。是大甚深佛之境界。唯除如来更无能了。于是贤护胜上童真。白佛言。大药王子。所问甚深。其智微妙敏利明决。佛告贤护。此大药王子。已于毗婆尸佛所。植诸善根。曾于五百生中生外道家。为外道时常思识义。识者云何。云何为识。于五百生不能决了识之去来。莫知由绪。我于今日为破疑网。令得开解。于是贤护胜上童真。谓大药王子言。善哉善哉。仁今所问微妙甚深。月实之问其义浅狭。犹如婴儿。心游外境而不知内。正法希闻。诸佛难遇。佛圆广智无测深慧。至妙之理应专启请。时大药王子。见佛熙怡颜容舒悦。如秋莲开。踊跃欢喜。一心合掌。而白佛言。世尊。我爱深法渴仰深法。常恐如来入般涅槃。不闻正法而于末浊众生之中。愚无所知。不识善恶。于善不善熟与不熟不能觉了。迷惑轮转生死苦趣

佛告大药王子。如来正法难遇难得。我于往昔为半伽他。登山自坠。弃舍身命。为求正法。经历无量百千万亿种种苦难。大药。汝所希望。皆恣汝问。我当为汝分别解说。大药王子。白佛言。唯然奉教。世尊。识相云何愿垂开示。佛告大药。如人影像现之于水。此像不可执持。非有无辨。如刍洛迦形。如渴爱像。大药王子。白佛言。世尊。云何渴爱。佛言。如人对可意色眼根趣之。名为渴爱。犹持明镜视己面像。若去于镜面像不现。识之迁运亦复如是。善恶业形与识色像。皆不可见。如生盲人日出日没昼夜明闇皆悉不知。识莫能见亦复如是。身中渴爱受想与念皆不可见。身之诸大诸入诸阴。彼皆是识。诸有色体。眼耳鼻舌及身。色声香味触等。并无色体受苦乐心皆亦是识。大药。如人舌得食物。知甜苦辛酸碱涩等六味皆辨。舌与食物俱有形色而味无形。又因身骨髓肉血。觉知诸受。骨等有形受无形色。知识福非福果。亦复如是。时贤护胜上童真。礼佛双足。白佛言世尊。此识可知福非福耶。佛言善听。非未见谛而能见识。识不可视。譬如掌中阿摩勒果。识不在于眼等之中。若识在于眼等之中。剖破眼等应当见识。贤护。恒沙诸佛见识无色。我亦如是。见识无色。识非凡愚之所能见。但以譬喻而开显耳。贤护。欲知识之罪福。汝今当听。譬如有人为诸天神。或乾闼婆等。及塞建陀等鬼神所著。贤护。于意云何。其为天等鬼神所著。其着之体求于身中。可得见不。贤护白佛言。不也世尊。天等鬼神所著。其着之体无色无形。身内外求皆不可见。贤护。其为福胜。诸大天神之所著者。即须好香花烧众名香。香美饮食清净安置。祭解供具咸须香洁。如是此识为福资者。便获尊贵安乐之果。或为人王。或为辅相。或豪望贵重。或财富自在。或为诸长。或作大商主。或得天身受天胜果。由识为福资身获乐报。如彼福胜天神所著。得胜妙花香香美饮食。便即欢喜。病者安隐。今得尊贵豪富自在。当知皆是由福资识。身获乐果。贤护。其为富丹那等下恶鬼神之所著者。便爱粪垢腐败涕唾诸不净物。以此祭解欢喜病愈。其人以鬼神力。随鬼神欲。爱乐不净臭朽粪秽。识以罪资亦复如是。或生贫穷。或生饿鬼及诸食秽畜生之中种种恶趣。由罪资识身获苦果。贤护胜上。天神其着之体。无质无形。而受种种香洁供养。识福无形。受胜乐报亦复如是。富丹那等下恶鬼神。为彼著者。便受不净秽恶饮食。识资罪业。获识苦报亦复如是。贤护当知。识无形质。如天等鬼神所著之体。供具饮食所获好恶。如资罪福得苦乐报

大药王子。白佛言世尊。云何见欲因。佛言大药。互因生欲犹如钻燧。两木互因加之人功。而有火生。如是因识。及因男女色声香味触等。而有欲生。譬如因花生果。花中无果果生花灭。如是因身显识。循身求识识不可见。识业果生身便谢灭。身骨髓等不净诸物咸悉销散。又如种子。持将来果味色香触迁植而生。识弃此身。持善恶业受想作意。受来生报。亦复如是。又如男女爱欲欢会分离而去。识身和合恋结爱着味玩悭吝。报尽分离随业受报父母因缘中阴对之。以业力生识获身果。爱情及业俱无形质。欲色相因而生于欲。是为欲因

大药。云何见戒取因。戒谓师所制戒。不杀不盗不邪淫不妄语不饮酒等行。取谓执取是戒。作如是见。因是持戒。当得须陀洹果。斯陀含果。阿那含果。以是因故获于胜有。谓受人天等身。斯皆是有漏善非无漏善。无漏之善无阴熟果。今此戒取是有漏种。植之于识报善恶业。识不淳净烦恼因故受热恼苦。是为见戒取因

大药白佛言。云何识取天身乃至取地狱身。佛言大药。识与法界持微妙视。非肉眼所依以为见因。此微妙视与福境合。见于天宫欲乐嬉戏。见已欢喜识便系着。作如是念。我当往彼染爱恋念而为有因。见已故身。卧弃尸所。作如是念。此尸是我大善知识。由其积集诸善业故。令我今者获于天报。大药白佛言。世尊。此识于尸既有爱重。何不托止。佛言大药。譬如剪弃须发。虽见乌光香泽。宁可更植于身令重生不。大药白佛言。不也世尊。已弃须发。不可重植于身令其更生。佛言如是。大药。已弃之尸。识亦不可重托受报。大药复白佛言。世尊。此识冥寞玄微。无质可取。无状可寻。云何能持象等大身众生。纵身坚固犹若金刚。而能贯入壮夫之身。力敌九象而能持之。佛言大药。譬如风大无质无形。止于幽谷。或窍隙中其出暴猛。或摧倒须弥碎为尘粉。大药。须弥风大色相云何。大药白佛言。风大微妙无质无形。佛言大药。风大微妙无质无形。识亦如是妙无形质。大身小身咸悉能持。或受蚊身。或受象身。譬如明灯。其焰微妙置之于室。随室大小众闇咸除。识亦如是。随诸业因任持大小。大药白佛言。世尊。诸业相性彼复云何。以何因缘而得显现。佛言大药。生诸天宫食天妙馔。安宁快乐。斯皆业果之所致也。如人渴乏巡游旷野。一得清凉美水。一无所得受渴乏苦。得冷水者无人持与。受渴乏者。亦无遮障不许与水。各以业因受苦乐报。大药。应当以是见善恶业。如空中月白黑二分。又如生果。由火大增熟便色异。如是此身。由福增故生胜族家。资产丰盈金宝溢满。胜相显盛。或生诸天宫快乐自在。斯皆善业福相显现。譬如种子植之于地。果现树首。然其种子。不从枝入枝而至树首。割析树身亦不见子。无人持子置于枝上。树成根固求种不见。如是诸善恶业。咸依于身。求之于身亦不见业。如因种有花种中无花。因花有果花中无果。花果增进增进不见。因身有业因业有身。身中无业业中无身。亦复如是。如花熟落其果乃现。身熟谢殒业果方出。如有种子花果之因具有。如是有身善恶业因。备在彼业。无形亦无熟相。如人身影无质无碍。不可执持不系着人。进止往来随人运动。亦不见影从身而出。业身亦尔。有身有业而不见业。系着于身亦不离身。而能有业如辛苦涩殊味诸药。能涤净身除一切病。令身充悦颜色光泽。人见之者。知服良药药味可取。熟巧无形。视不可见。就不可得。而能资人肤容色泽。业无形质能资于身。亦复如是。善业资者。饮食衣服。内外诸资丰饶美丽。手足端正形容姝好。屋宅华侈。摩尼金银。众宝盈积。安宁快乐。欢娱适意。当知此为善业之相。生于下贱边地贫穷。资用阙乏希羡他乐。饮食粗恶或不得食。形容弊陋所止卑下。当知此为恶业之相。犹如明镜鉴面好丑。镜像无质取不可得。如是识资善不善业。生人天中。或生地狱畜生等中。大药。应当如是见业与识和合迁化。大药言世尊。云何微识能持诸根。能取大身。佛言大药。譬如猎者入于山林。持弓毒箭而射香象。箭毒沾血毒运象身。支体既废根境同丧。毒流要害身色青赤。犹如淤血毒杀象已便即迁化。于意云何。毒与象身多少大小。可得比不。大药白佛言。世尊。毒与象身多少大小。其量悬殊不可为对。犹如须弥比之芥子。大药。如是识弃此身以取诸根。弃此诸界随业迁化。亦复如是。大药复白佛言。世尊。云何微细之识。任持大身而不疲倦。佛言大药。须弥山王高八万四千由旬。难陀乌波难陀二大龙王。各绕三匝。二龙大息摇振须弥。内海中水咸变成毒。此二龙王长大力壮。和修吉龙德叉迦龙。二大龙王亦与之等。于意云何。四龙王识与蚊蚋识。宁有异不。大药言世尊。四龙蚊蚋其识无异。大药。如一小渧跋错那婆。入四龙口四龙便死。于意云何。小渧药毒龙口中毒。何毒为大。大药白佛言。龙口毒大。小渧药毒甚为微少。大药。大身众生力敌九象微妙之识无色无形。非分别量。随业任持亦复如是。如尼瞿陀子极微细。种之生树。婆娑广大枝条百千。于意云何。其子与树大小类不。大药言世尊。其子与树大小相悬。如藕丝孔比虚空界。如是大药。树于子中求不可得。若不因子树则不生。微细尼瞿陀子能生大树。微细之识能生大身。识中求身身不可得。若除于识身则无有。大药复白佛言。云何金刚坚固不可坏识。止于危脆速朽身内。佛言大药。譬如贫人得如意宝。以宝力故。高宇雕树妙丽宫室。园林郁茂花果敷荣。象马妓侍资用乐具自然而至。其人于后失如意宝。众资乐具咸悉销灭。如意神宝坚固贞牢。纵千金刚。不能毁坏所生资用。虚假无常速散速灭。识亦如是坚固不坏。所生之身速朽速灭。大药言世尊。柔妙之识云何穿入粗鞕色中。佛言大药。水体至柔激流悬泉能穿山石。于意云何。水石之质鞕软如何。大药言世尊。石实坚鞕犹若金刚。水质柔软为诸乐触。大药。识亦如是至妙至柔。能穿刚鞕大身之色迁入受报。大药复白佛言。世尊。众生舍身云何生诸天中。乃至云何生于地狱等中。佛言大药。众生临终之时。福业资者。弃本之视得天妙视。以天妙视见六欲天。爰及六趣见身摇动。见天宫殿及欢喜园杂花园等。又见诸天处莲花殿。丽妓侍绕笑谑嬉戏。众花饰耳服憍奢耶。臂印环钏种种庄严。花常开敷众具备设。见天天女心便染恋。欢喜适意姿颜舒悦。面若莲花视不错乱。鼻不亏曲。口气不臭。目色明鲜如青莲叶。身诸节际无有苦痛。眼耳鼻口又无血出。不失大小便利。不毛惊孔现。掌不死黄。甲不青黑。手足不乱亦不倦缩。好相显现。见虚空中有高大殿。彩柱百千雕丽列布。垂诸铃网和风吹拂清音悦美。种种香花庄严宝殿。诸天童子众宝严身。游戏殿内见已欢喜。微笑齿现如君图花。自不张开亦不合闭。语音和润身不极冷亦不极热。亲属围绕亦不忧苦。日初出时当舍其寿。所见明白无诸黑闇。异香芬馥四方而至。见佛尊仪欢喜敬重。见已亲爱欢喜离词。犹如暂行便即旋返。安慰亲知不令忧恼。有流法尔生必当死。勿以分别而生苦恼。大药。善业之人临命终时。好乐布施。种种伽他。种种颂叹。种种明因。重重称说正法之教。如睡不睡安隐舍寿。将舍寿时。天父天母同止一座。天母手中自然花出。天母见花顾谓天父。甚为福吉希奇胜果。天今当知。子庆之欢时将不久。天母遂以两手摇弄其花。弄花之时命便终尽。无相之识弃舍诸根。持诸境业弃舍诸界。持诸界事迁受异报。犹如乘马弃一乘一。如日爱引光。如木生火。又如月影现澄清水。识资善业迁受天报。如脉风移速托花内。天父天母同座视之。甘露欲风吹花七日。宝珰严身曜动炫焕。天童朗洁现天母手。大药白佛言。世尊。无形之识。云何假因缘力而生有形。云何有形止因缘内。佛言大药。如木和合相触生火。此火木中求不可得。若除于木亦不得火。因缘和合而生于火。因缘不具火即不生。木等之中寻火色相竟不可见。然咸见火从木中出。如是大药。识假父母因缘和合。生有形身。有形身中求识不得。离有形身亦无有识。大药。如火未出火相不现。亦无暖触诸相皆无。如是大药。若未有身识受想行皆悉不现。大药。如见日轮光明照曜。而诸凡夫不见日体。是黑是白黄白黄赤皆不能知。但以照热光明出没循还。诸作用事而知有日。识亦如是。以诸作用而知有识。大药白佛言。云何为识作用。佛言大药。受觉想行思忧苦恼。此为识之作用。复有善不善业。熏习为种作用显识。大药白佛言。云何识离于身便速受身。识舍故身新身未受。当尔之时识作何相。佛言大药。如有丈夫长臂勇健着坚甲胄。马疾如风乘以入阵。干戈既交心乱坠马武艺捷疾还即跳上。识弃于身速即受身亦复如是。又如怯人见敌怖惧乘马退走。识资善业见天父母同座而坐。速托生彼亦复如是。大药。如汝所问。识弃故身新身未受。当尔之时识作何相。大药。譬如人影现于水中无质可取。手足面目及诸形状与人不异。体质事业影中皆无。无冷无热及与诸触。亦无疲乏肉段诸大。无言声身声苦乐之声。识弃故身新身未受相亦如是。大药。是资善业生诸天者。大药白佛言。云何识生地狱。佛言大药。行恶业者入于地狱。汝当谛听。大药。此中众生积不善根。命终之时作如是念。我今于此身死。弃舍父母亲知所爱甚大忧苦。见诸地狱及见己身。应合入者见足在上头倒向下。又见一处地纯是血。见此血已心有味着。缘味着心便生地狱。腐败恶水臭秽因力识托其中。譬如粪秽臭处臭酪臭酒。诸臭因力虫生其中。入地狱者托臭物生亦复如是。贤护胜上童真。合掌白佛言。地狱众生作何色相。身复云何。佛言大药。其爱血地生地狱者。遍身血光身如血色。生汤隍者身如黑云。生乳汤河者。身点斑杂作种种色。体极软脆。犹如贵乐婴孩之身。其身长大过八肘量。须发身毛并长垂曳。手足面目亏曲不全。阎浮提人遥见便死。大药白佛言。地狱众生以何为食。佛言大药。地狱众生。食无少乐。惶惧驰走。遥见镕铜赤汁。意谓是血众奔趣之。又有声呼。诸有饥者可速来食。便走向彼。至已而住以手承口。狱卒以热铜汁写手掬中逼之令饮。铜汁入腹。骨节爆裂举身火起。大药。地狱众生所食之物。唯增苦痛无少安乐。地狱众生苦痛如是。识不舍之亦不毁坏。身如骨聚识止不离。非业报尽苦身不舍。饥渴苦逼便见园林。花果敷荣广博翠茂。见已喜笑互相谓言。此园翠茂清风凉美。众急入园须臾暂乐。树叶花果咸成刀剑斩截罪者。或中破身分为两段。或大叫呼四面驰走。狱卒群起执金刚棒。或执铁棒铁斧铁杖。啮唇嗔怒身出火焰。斫棒罪者遮不令出。斯皆已业见如是事。狱卒随罪者后。语罪者云。汝何处去。汝可住此勿复东西。欲何逃窜。今此园者。汝业庄严可得离不。如是大药。地狱众生受种种苦。七日而死还生地狱。以业力故。如游蜂采花还归本处。罪业众生应入地狱。初死之时见死使来系项驱逼。身心大苦入大黑闇。如被劫贼执捉将去。作如是言。诃诃祸哉苦哉。我今弃阎浮提。种种爱好亲属知友。入于地狱。我今不见天路。但见苦事。如蚕作丝自缠取死。我自作罪为业缠缚。罥索系项牵曳驱逼。将入地狱。贤护。罪业众生生地狱者。苦相如是。尔时贤护。与大药王子。闻说是已身惊毛竖。俱起合掌。作如是言。我等今者俱归依佛。诸垂救护愿今以此闻法功德。未脱有流。处生死轮。不落三涂入于地狱。贤护复白佛言。欲有请问唯愿听许。佛言。如汝希望恣汝处问。贤护白佛言。世尊。云何为积。云何为聚。云何为阴。云何为身不迁。佛言贤护。智界见界意界明界。以此四界和合成身。四界境识名之为积聚。谓六界六入六入境。三界二入因。即发须毛爪。皮肉脓血。涕唾黄痰。脂[月*冊]髓液。手足面目。大小支节和合崇聚。名之为聚。犹如谷豆麻麦。积集聚贮而成高大。谓之为聚。其地水火风空识。名为六界。眼耳鼻舌身意。名为六入。色声香味触法。名六入境。即贪嗔痴名三界因。又风黄痰亦名三因。二入者谓戒与信。又有二因谓舍与施。又有二因谓进与定。又有二因谓善不善。其受想行识。此四名无色阴。受谓领受苦乐等相。及不苦不乐之相。想谓知苦乐相。行谓现念作意及触。识者是身之主遍行诸体。身有所为莫不由识。不迁者谓身语意净证获道果。此人死已识弃有阴。不重受有不流诸趣。极乐而迁不复重迁。是名不迁。于是贤护。与大药王子。礼佛双足。白言世尊。佛一切智说此法聚。当于未来作大利益安乐众生。佛言。如来法聚常住非断。一切智者知而不为。我经无量勤苦。积集智光。今说此经此正法日。为诸众生作大明照。德誉普流一切智海。为能调心流注者说。此经所在之处读诵解说。皆天鬼神阿修罗摩睺罗伽。咸悉拥护皆来拜礼。水火王贼等怖。皆不能害。诸比丘从今已往。于不信前。勿说此经。求经过者慎勿示之。于尼干子尼干部众诸外道中亦勿说之。不恭敬渴请。亦勿为说。若违我教亏损法事。此人则为亏损如来。诸比丘若有礼拜供养此经典者。应当恭敬供养是人。斯人则为持如来藏。尔时世尊。而说偈言

  当勇超尘累　　勤修佛正教
  除灭死军众　　如象践苇芦
  持法奉禁戒　　专精勿亏怠
  以弃生流转　　尽诸苦有边

佛说此经已。贤护胜上童真。大药王子。并诸比丘菩萨摩诃萨。天人阿修罗乾闼婆等。普大会众。闻佛所说。欢喜奉行

大宝积经卷第一百一十

尔时众中。有一王子菩萨摩诃萨。名为大药。从座而起整理衣服。合掌向佛而白佛言。世尊。彼神识从此身移当有何色。佛赞彼大药菩萨言。善哉善哉。大药。如是如是。汝之所问此义。其义甚深。唯诸如来乃能知耳。然此识除于如来。更无有人而能知者。尔时跋陀罗波梨。白佛言世尊。希有此大药王子。能问甚深之事。最微最细甚深甚密。佛报跋陀罗波梨言。如是跋陀罗波梨。此大药王子。于往昔。已曾供养毗婆尸世尊。种善根故。跋陀罗波梨。此大药王子。昔五百世曾作外道。当于尔时尝问此识义。然此大药王子。当于尔时。于此识中亦不能了知。此识何来何去。此义不了。我今应当为其决了此义。尔时跋陀罗波梨长者子。赞大药王子言。大药。善哉善哉。仁者智慧广大无有边际。乃能问世尊甚深之义。我今劝请大药。愿问世尊。此义入一切难。智者巧解深意。勿令此苏摩浮坻娱乐少事。而先问佛。所以者何。其故数数恼乱不善问于世尊。但佛世尊出世甚难。世间如此法会聚集复难。是故汝今应当劝请世尊。解释甚深义处。尔时大药王子菩萨摩诃萨。瞻仰世尊而见世尊喜悦微笑。清净犹如初秋莲华始开。见已欢喜。尔时大药王子菩萨。白佛言世尊。我渴仰故乐闻正法。虑恐世尊不具与我显说法要不决我疑。又恐世尊不久当取涅槃。又恐诸众生不能了知善恶业报。恒受生死烦恼不能舍离。佛告大药言。大药。我于往昔故为此偈。从大山崖投身布施复行无量无边难行苦行百千亿等种种诸事。大药。汝所有疑但当问我莫以为难。我随汝意当分别说。尔时大药。复白佛言。世尊。此识何色。佛告大药言。大药。此识如幻师火。如人水内影。如风轮无定。无有定色。如众生眼见虚空如似爱。大药复问。其爱云何。佛言。犹如人射以有眼根见箭去时。如人执明净镜。于其镜内。见己面形。若除镜已形便不见。此识亦尔从人身移。其识界唯见罪福。譬如生盲人。不见日天出时中时后时。夜亦不见月天。出时闇时并皆不见。此神识亦复如是。于其身内不可得见。大药。此身内爱着及取及想。智者但有识。所有此身和合集聚。诸界诸入诸阴等所有色者。眼耳鼻舌及色等诸受。或苦或乐意等所有诸色者。是名为识。大药。如人以舌知味或苦或辛。而彼人舌有色彼味无色。此身内所有骨髓肉血是有色。所受者是无色。是名为识受罪福者。尔时跋陀罗波梨。顶礼佛足。而白佛言。世尊。受罪福者是谁。佛告跋陀罗波梨。汝谛听谛受。我为汝说。有见实者。彼见此识。而此识不可得。如庵婆罗果掌中可见。此识不住眼道。亦非以眼能得见。彼如恒河沙数如来见此识。我亦然无色可见。唯愚痴辈不知不见故。我为说但有识名。不可以见。跋陀罗波梨。此识如受罪福。我为汝说。汝当谛听。譬如有人着阴鬼。或羊颠鬼。或乾闼婆鬼。或天神。跋陀罗波梨。于汝意云何。彼人身内有彼诸鬼。或阴鬼等可见以不。跋陀罗波梨言。世尊。彼鬼在人身中。或内或外实不可见。但彼诸鬼在人身内亦无有色。跋陀罗波梨。如彼天神最胜。在人身中。取最妙香华涂香末香。并诸华鬘及以饮食。皆取最上殊胜。如是此身取最胜业时。以识故受。或取王位治化自在。或取富饶大长者家。或受天果报。如是此识受福如此最胜天神灵。在人身内受最胜祭祀。或受王位。或受富饶。润彼人身令使欢喜。如是此识受福果报亦复如是。跋陀罗波梨。如彼不净毗舍阇鬼神。倚在人身中。受不净诸物臭秽。或在圊屏内受诸祭祀。得祭祀已即生欢喜。而彼人被不净鬼神力故。常乐臭秽不净之处。心既爱乐得臭秽物便生欢喜。如是此识得恶果报生不净意。或生贫贱家。或生下劣家。或生饿鬼。恒食粪秽之物心生欢喜。然此识如是受恶果报。如彼胜天神灵。虽无色形。但受最胜最上祭祀。如是此识虽无有色。但受最胜最妙果报。随业受身。如彼无色富多那鬼。倚着人身恒乐食诸粪秽。如是此识。在不净业中。恒乐下贱之处。跋陀罗波梨。汝当知此不净识如是。跋陀罗波梨。如彼鬼形在人身中而无有色。此识受善不善果报。如彼鬼神。汝应当如是知见。尔时大药王子。白佛言世尊。凡受欲云何。佛答大药言。当见有人各各和合故生欲想。譬如以木钻火因人身力然后出火。欲受于欲因于男子。意感于触后生欲事。譬如因华成子。然彼华内初无有子。有华故然后结子。可见如是。此身生已。然后识可见。而此身内亦无识可见。以识故身内有骨髓肉血等不净之物。如彼种子种已生华。因华而受色香味等。既成果已还灭。如是此识成身已亦复还灭。但取善恶受心想意识至于彼世趣。彼男女和合生欢喜心。因彼交会相持出于不净。出不净已还各相离。而彼二人受欲乐时心生欢喜。既受欲已。无复欲想。还各相离或生厌离。欲想如是如是。此识因身攀缘生欢喜心增长受想。犹如人身因见女色。即生欲想各各着身。受欲讫已还复厌离而去。此识亦然。既受身已还复舍去生厌离想。复次因父母欲事来。中阴受身攀缘业。此识有从中入。欲因成就身。而彼业无色。其男子女人因亦无色。但因受攀缘故生欲想而即有色。是故言受欲想也。色受欲想故名为受欲。复次大药。因持戒攀缘故受后果报。此事云何。我为汝说。言持戒者。身断杀生不盗他物。不行邪淫。不妄言。不饮酒。斗乱谨慎不放逸。是为攀缘。欲受后世须陀洹果。斯陀含果。即受后有或天身或人身。而彼有善业。或有漏或无漏。成就诸阴等。润彼处识。受持或善或不善诸业。成就识等。受诸欲事已。还自厌离。是故名此因持戒故受后果报也。尔时大药王子。白佛言世尊。此识云何受天身。复云何受地狱身。佛告大药王子菩萨言。大药。汝今谛听。我当为汝解说此事。大药。此识以法界持。故生作天心见。而彼天见不在肉眼。彼见体所见即是受因。故名见受因也。而此人所见天见者。即是福攀缘善成就即见天宫。于欲天中受种种五欲乐事。如是见已便生欲心。因即如是起念智。我今应须至彼处耳。彼生如是欲心已。而发染着念。心取有相。复见其故身。弃在尸陀林内。彼如是见已。便作是念。是我天识也。此造善根已。我当欲向天上。尔时大药王子。复白佛言。世尊。彼识既如是着故尸。云何不即入故尸。佛告大药王子言。大药。譬如有人剃除须发。既见须发落地。作如是念。我此须发好黑香洁。愿我此发还着头上如旧。大药。于汝意云何。彼之头发还能更着头以不。大药言。不也世尊。佛言大药。如是如是。彼人神识舍其身已还欲入中更依住者。无有是处。尔时大药王子。复白佛言。世尊。此识既是微细。无有正色广大无边。云何能来就大白象身。复能破金刚之身。既无千象力。云何人生即能持千象力。佛告大药。譬如风界无色不可见住山谷间。而彼风从彼山谷出。已能摧折崩倒如须弥等高大之山使其破裂。大药。于汝意云何。彼风界有何色。彼山复何色也。大药白佛言。世尊。彼风柔弱复无色身。当如是见。佛复告大药言。大药。如彼风界软弱无色体。彼识亦复然。软弱复无色身。然其无妨能成就大身。能成就微细小身。而彼识蚊子及象一种不异。大药。譬如小灯烛光。或在壁或在室。能灭大黑闇分。此识亦复如是。虽复微小。能成大小形色。而皆因业受故。尔时大药。复白佛言。世尊。彼业有何色有何体。几种因应当可观。佛报大药言。诸业境界者。是微妙受快乐。受得天饮食。譬如有二人同共游行至于旷野。然彼二人。一人忽值凉冷清水而得饮之。一人饥渴命终。而彼水不能自入彼人之口。亦无于此一人不与饮者。但以因缘故。一人值水凉冷饮之。一人不值。如是如是。此善不善诸法亦复如是。如黑月白月。善不善应须当见。譬如生果熟已变成别色。然彼色以火力多故。令其成熟。如是如是。此身以福力故。生于大富长者家。多饶财宝现受快乐。在于天宫。显现受天快乐。然后失天自在势。即显现无福之势。犹如种子于地上种生树。以后其种子于树上不现。亦不从枝移枝。亦不在树内显现。亦无有人手执彼子置于树上。亦不从根移。彼种子可现。如是如是。此诸业若善若恶。倚住身内而不显现。如从种子然后有华。从华然后有子。其华不在于种子内。其子亦不在于华内。子华无有二别体。如是如是。此身内诸业。有从业有身。其身不在业内。可见业不在身内。可见如华成熟然后成子。如是身成熟已。诸业可现。如种子何地方。有彼地方即有华。有华然后有子。如是如是。此身所有生处。于彼之处。见善及恶便即有现。然彼诸业根无有色。如人因身有影。而彼影无定无色还随人而行。而彼影不倚住。于人亦不离身有影可现。如是此身内现善恶相随而不相离。身行之处随逐而行。其业处处随逐。其业不离身有。亦不离身业可有现。如诸药若辛若甜若苦等。人饮服已能除诸病。既除其身诸恶。成其柔软现好颜色。众人见者形相可知。此人身值甘药。然彼诸药等味及力无有色。其味力色不可得现。唯在人身形色端正可现耳。如是如是。此善业无色而至人身。以美饮食故。身着好服故。其人诸根具足故。身受快乐。复以金银珍宝庄严此身。有富贵形势。此皆是善业境界。其失势无有福业。贫穷困苦远离资财。恒常乏少规求他物。饮食粗涩行住坐卧悉皆下劣。无好福报养育身体。所生丑陋。此皆是不善业境界。犹如明镜。以其明故面形妍丑分明显现。而彼镜内影无有色。如是如是。由善恶力故。此识显现于人中。若地狱饿鬼畜生中。大药。此诸业随于此识。大药。应须如是知如是见。大药复白佛言。世尊。此识云何成就诸根受大身。云何舍诸根。佛告大药。譬如猎师入深山林手执强弓。即取毒药涂其箭镞以射大象。而彼毒滴虽少入皮至血。毒气移行遍满身中。至一切诸根境界。令根闭塞屈折诸节。令血变色遍诸身分遂即舍身。其毒还至本所入处自然出外。大药。其毒药一滴极甚微小。其象身极大。于汝意云何。大药报佛言。世尊。计毒药极微小。其象身如须弥山。毒药移行所以遍体。佛告大药。如是此神识舍身之时。舍诸根舍诸界。次第亦复如是如是。大药复白佛言。世尊。云何受如是广大身不曾畏难。佛告大药。譬如须弥山。高八万四千由旬。而彼山有二龙王。一名难陀。二名优波难陀。绕之三匝住持彼山。而彼龙王喘息之气海水不堪饮。彼龙王出入息时。彼须弥山。即动如彼龙王。身广大多力。彼婆修吉。德叉迦龙王亦复然。大药。于汝意云何。彼龙王等识。欲与蚊子识一等。以不汝勿别见。大药王子。白佛言。世尊。如我意所见。彼之龙王及蚊子识一等无异。佛复告大药。如有一毒。名婆蹉那婆。复有毒药名诃罗诃罗。将如芥子。与难陀波难陀等。食即速疾命终。大药。于汝意云何。龙毒。药毒何毒力大。为龙毒大为药毒大。大药报言。世尊。如我意见。其难陀波难陀毒多。其婆蹉那婆毒少。佛告大药。如是如是。虽有大身敌九千象力无妨。其识虽小无定色不可见。但此识因业缘成就大身。大药譬如尼拘陀子。其形虽小无妨能成就大树。枝条长广覆盖数百千地。大药。于汝意云何。其子形及树身二种。何者是大。大药报佛言。世尊。如以小孔比于虚空。佛复告大药。而彼树不可在子内见亦不离子而生于树。大药。如彼微细子有广大树。如是如是。无色识成就大色身。因识故现色身。不离识色身可见。尔时大药。复白佛言。世尊。其识牢固犹如金刚。云何成就羸弱之身。佛告大药。譬如有人贫穷不能自济。忽然值遇如意宝珠。彼人得珠。执已所造如意。即得称成楼观池台。城门坑堑周匝高门。园林华果枝叶蓊郁弥覆其上。及余资财诸物。皆悉如心自然化作。大药。彼等诸事悉皆羸弱。速疾破坏离散之法。然后彼人手执如意珠忽然失落。彼等乐事即灭不现。大药。如彼如意珠。千金刚破终不可坏。有此功能随意所念皆悉克果。如是如是。此识牢固犹如金刚。而受身者此不坚牢也。尔时大药。复问世尊。彼识既是软弱。云何破坏坚牢之身而移至彼世。佛告大药。譬如水流注下在于山内还穿山而出。大药。于汝意云何。彼水有何坚牢。大药报佛言。世尊。其山体是坚鞕牢如金刚。而彼水滴本性柔软。犹如梦为触者安药。如是如是。彼识本体柔软。能破大身即得出去。尔时大药。复问佛言。世尊。凡有众生从众生界。舍身命终之后。云何受诸天之身。云何复受诸趣之身。佛告大药言。大药汝谛听。我当为汝解说此事。大药。凡有众生舍众生体。命终之后以行福业之事以受身。还舍彼身。其识舍人身见得天身见。彼既得天眼已。即见六欲诸天。又见六欲天宫。而见彼人身破时。复见天上园林欢喜林坏乱林等。彼处有高座天衣覆上。处处台殿微妙树林。处处有端正玉女。聚而彼识见常有华。庄严诸事心喜见者。种种璎珞耳珰臂钏。而彼见座上有天童子。其玉女及天子二人欢喜共见。而彼天童子生已。复更见生天之童女。彼天童子。见童女已即生欲心。生欲心已即得欢喜。得欢喜已即得遍体心意欢喜。心意欢喜已。彼于尔时即变身色。而色犹如莲华。其人命终之时即得不颠倒。见鼻不喎綟口气不臭。彼人耳目似青莲华色。身分支节更不离解。彼亦不流血。亦不生粪尿。身诸毛孔亦不揩折。诸甲无复青色手无黄色。手脚不动亦不申缩而取命终。大药。彼人命终之时预有天相。所谓现前见辇舆。彼辇舆有千数柱。庄严悬诸铃网。其铃出好微妙音声。有种种微妙香华而散其上。又出好妙香气。复有种种璎珞庄严其上。复有无量诸天童子。彼见如是已。生大欢喜心。彼生欢喜心已。于身生相二齿。白净犹君陀华。显现其两目。不甚大开不甚大闭。其声微妙哀美。二足下犹如莲华色。而彼死尸命终之后。身心不冷不热。彼亡人有眷属不甚悲恋。而彼人欲依法取命终之时。其时正日初出诸方无有黑闇。了了睹见众色诸方。复有善妙香气遍满而来。其人临欲终时两目不闭。其所见诸方无有迷惑。若见如来像。即得信心发清净意。复见心所喜爱。诸眷属以欢喜心抱其身。犹如人死已还活。亦如远行人归慰喻诸眷属。作如是言。诸眷属等莫忧莫愁。一切诸有生者。皆有如是别离法也。大药。彼众生若福业强。若内发布施心。其辩才数数自赞叹歌咏布施功德。或种种功德因缘。而彼人作如是语已。意乐欲睡眠。身心得安乐遍满其体。安隐舍身命。舍身命时。上见诸天共同榻坐。见同坐已。其玉女将手置其身上。其玉女两手掬满香华。既掬华已白彼天言。大善大善。愿有吉利事。欲生天童子时至。而彼玉女作是语已。手即索华索已复索。索华之时。而彼众生即取命终。彼舍诸根共识。舍诸根境界。舍诸大时。四阴无定体无色。如人欲骑马。或如日天。或如明珠。或如火炎。或如水月。或如幻化。身攀缘善业。速疾如筒出气移去。而彼神识欲生彼处。因彼华见父母坐天榻上。见彼天和合其神识。于华内有形出。彼时有微妙风。甘露味和合而吹。而彼起已。彼识于七日内。头戴天冠生天童子。尔时大药菩萨。复白佛言。世尊。彼神识既无有色。云何为因缘而成就色。云何为因缘而现见。佛言大药。譬如二木和合各各相揩而出于火。而彼火不在木内可见。不离木而可得火。亦非一因而能生火。亦非无因而得出火。非是木上即得见色。以因故出出乃见色。亦非离木而别有色可得。如是如是。大药。彼识以父母和合故成就受身。其识亦不在身内可见。亦不离身而有彼识。大药。譬如火出已然后见色。亦非热故可见有色。亦非赤故可言见色。如是大药。彼神识以成就身故言有识。亦不由受故可见。亦不由诸行故可见。大药。譬如日天圆满光明照曜。大有威光显赫可见。而诸凡夫辈不见正色。或言黑色。或言白色。或言黄白色。或言绿色。大药。不可以身。不见神识或黑或白等。犹如日喻不可以暖可见光明。其可见者但出没行时如是须观。大药。此神识凡欲观时。但取其诸性。大药复白佛言。世尊。其识有何诸性也。佛言大药。彼性受性取性。诸行性。忧愁性。思惟性。恼性喜性。不喜性等。是识诸性应当如是观。复次神识有本性可观。何等为本。所谓善心不善心等为本。尔时大药。复白佛言。世尊。彼神识从此身出已。云何速疾而受彼生处。云何从此身出已。未至彼身受生之时。于何处住此之神识当云何观。佛答大药言。譬如有人其臂纤长。手足上下一切正等。乘微妙速疾骏马驰走入阵。入阵已被刀槊弓箭所伤。其心恼乱在彼阵内。其心迷闷堕马倒地。而彼人善解戎仗。倒地已速疾而起。手执其马即便骗上。譬如彼人倒地之时。速疾得马。得马已即乘彼马。如彼马速疾得速疾乘。彼神识亦如是。应当知如彼人被贼趁心生恐怖。乘彼马速疾而走。此神识初舍身欲至彼亦复然。欲生天即攀缘天念。见天父母在一座上。见已攀缘速疾即得受生。复次大药。汝问凡人初移识时其识未至。彼时在何处住。其性当云何观者。大药。譬如人影在于水中。虽复现色非人正形色。当如是观。大药。彼人影上下手足正等。成就色时在于水中。亦不作如是念言。我有热恼。我有寒冻。我身疲乏。彼无如是心言。我是真体如前在胎肉块。而彼影无有扰乱处。而彼人身影在水中之时。无有声出或苦声或乐声。大药。此神识从此身舍已未至彼身。有如是形有如是性。大药。凡有福神识。初欲取天身时作如是受。尔时大药菩萨。复白佛言。世尊。此神识欲取地狱生云何受。佛告大药。汝今谛听。如无福众生欲取地狱生者。我为汝说。大药。凡有众生若造不善业。以彼业攀缘所摄。而彼众生此处欲舍其身。舍身之时生如是念。我即是彼人从此地狱舍身。此是我父母。而彼人舍身之时。一等成就色身如本性有。成就彼人如本身体即见身分。而彼人初舍身被忧愁所流。即见种种地狱。彼神识初舍身已在彼地狱。即成就有业即见彼地狱。或有他方见如血洒。而彼即心生染着相。生染着相已即成地狱身。而彼神识犹如下湿。臭烂地因故生虫身。譬如屏臭秽烂故生虫。譬如酪内臭坏有诸虫生。大药。众生欲生地狱亦复如是。尔时跋陀罗波梨。合掌向佛而白佛言。世尊。诸众生辈在地狱其身有何色。云何而受身体。佛告跋陀罗波梨言。若有众生染着血处。彼等身体生血色。若有众生染着毗罗尼河。彼等身体即生不白不黑云色。若有众生染着灰河。彼等身体生斑驳色。而彼等诸众生于彼处身体柔软。犹如王子安乐养育其身。跋陀罗波梨。于彼处诸众生受身广大。长八肘半其髭鬓头发甚长。其足可畏反向于后。若有阎浮提人。欲往地狱观者。见彼地狱人即便怖死。复次跋陀罗波梨。地狱众生虽复有食无暂时乐。尔时大药。复白佛言。世尊。彼诸众生食时有何等食。佛报大药菩萨言。大药。彼众生辈在地狱游历时。遥见赤色或镕铜或镕鋀石。见已各相唱言。呜呼仁者谁欲得食。近来相共食此。闻是声已聚一处。向镕铜所会堂而住。已求食故张口欲食。而彼镕铜及以鋀石。炽盛放光作如是声。多吒多吒。入其口然其全身。大药。彼诸众生以为食故受如是苦事。复次大药。彼地狱中众生于彼时。其神识唯在骸骨内。而彼等神识不离骸骨。神识不离骸骨故不取命终。虽然而彼等众生犹尚饥恼。彼处亦无食事。于彼处有微妙园林。彼等眼见种种华果。种种树木蓊郁青色。亦见微妙广大地方。柔软青草所覆。彼等见如是园林地方微妙。各各欢喜微笑。各各起念各各相唤。汝等人辈如是园林微妙可受快乐。又有凉冷微风。彼等闻见此事已速来聚集。即共入彼园林之内。入已少时受乐。于彼树上所有华果及诸叶等悉皆成铁。彼众生等即被彼铁。枝叶华果擘裂其身。彼地狱众生被枝叶华果犹如竹根。擘裂身时口大叫唤处处驰走。如是之时其后有诸阎罗王人。手执利呋或执大铁杖。其目可畏牙齿极利头发火然。其炎高大全身烧然。手执种种器杖。罪人随业所生。彼人顺后趁逐。口唱是言。人等住住莫走。汝等自业所作。此园林何故苦走。不在此受斯业也。大药。彼诸众生在于地狱受如是苦恼。当如是观。复次大药。其地狱人过七日后。具足受地狱苦。犹如蜂采华造蜜。所以者何。种种诸有因故成神识。始受取地狱诸苦。而彼神识初舍身不自由。被诸苦所逼心中不乐。初见大黑闇至彼处。犹如有人被贼所逼牵挽。心作如是念。呜呼我今何故舍微妙阎浮提。弃所爱诸亲侣。向地狱速疾而行。今不见天上之路。其于彼时。犹如蚕虫被丝所缠。速疾求受生处彼不自由。被业所缠缚不能得住。大药。其地狱众生。有如是因缘。有受如是等诸苦恼之事。尔时大药王子。及跋陀罗波梨长者子。闻此事已身毛皆竖。合十指掌向佛归依。其大药王子等。发心作如是愿。藉此闻法因缘。在流转生死烦恼内。愿莫生恶道。愿莫受地狱苦也。尔时跋陀罗波梨。复白佛言。世尊。我更欲问佛前所心疑。佛告言。跋陀罗波梨。随汝所疑恣汝意问。跋陀罗波梨。白佛言。世尊。何者名聚何者名积。何者名阴何者名移。佛言。跋陀罗波梨。凡有四种法界成就此身。何者为四。诸界和合。智慧见意。无明。诸境界识。此是总义。我已说言。聚者即是六界诸入境。于六界内粗者三。一者入。复有二种取。其内有发髭须。众毛皮肉。脓血涕唾脂。五藏手足头面。身分支节。和合故名为聚。譬如诸谷积聚。或乌麻。或大小麦。或豆豌豆。以聚集故名积聚。如是如是。此身有身分有支节。聚集故名为积聚。言六界。何等为六。一地界。二水界。三火界。四风界。五空界。六识界。言六入者。何等为六。一眼。二耳。三鼻。四舌。五身。六意。言六入境界者。何等为六。一色。二声。三香。四味。五触。六法。此名为六入境界。言诸粗界本体三。何者为三。一者欲。二者恚。三者痴。彼等发起有三。何等为三。一者风。二者黄白痰。三者涕唾。言诸入取者有二。何等为二。一者持戒。二者信。复有六。何等为六。一者施。二者财。三者精进。四者禅定。五者善。六者非善。言阴者。云何名阴。一者受。二者想。三者诸行。四者识。此四阴是无色。言受者即是受用。言想者即是知别乐苦。言诸行者见闻触受。此名为识。为身作主。能得自在。一切诸物中自在故。言移者。善成就清净戒。身业口业意业。受根取命终时。于彼时彼识舍诸阴。更不受有生。更不回故一向受乐。故名为移是名为移。离此者不名为有移。如是次第别者不名为移。作如是语已。跋陀罗波梨。及大药菩萨。顶礼佛足而作是言。善哉世尊。善能为我。说如是义真实一切智。世尊。于未来世此法门。为诸迷惑愚痴众生当作润益。佛报彼二人言。跋陀罗波梨。此诸如来智者无有虚妄。非一切智亦不能知此真实体。我于过去行无量苦行。熏修此智光明。如今日所说无有异也。此是智光明法自处处流布。功德名闻一切智海藏。为诸众生教化故说。所在之处所说之处。于彼之处非人护持。及诸天修罗摩睺罗伽人非人等。来彼护持处。顶礼于彼之处无诸恐怖。县官不能作恶。劫贼当不能害。佛告诸比丘。汝等诸比丘。若知从今去此法门。不得无信人边说。亦不得觅过失人边说。亦不得外道尼干等边说。亦不得尼乾陀声闻边说。在阿兰若空闲者边亦不得说。亦不得不至心请人边说。所以者何。恐其求过失。如来实无过失。若有出家比丘或在家俗人。信受随顺此事者。彼人应须当顺彼人边。应须起慈悲心。一如如来一种。须发如是心。此人持诸佛库藏也。尔时世尊。而说偈言

  发心出家故　　应当行佛法
  降伏魔军众　　如象坏竹舍
  若能行此法　　谨慎放逸事
  灭生死烦恼　　当尽一切苦

佛说此经已。其跋陀罗长者子。大药王子菩萨。及大比丘众。天龙阿修罗乾闼婆等。闻佛所说欢喜奉行大宝积经卷第一百一十一

        大唐三藏菩提流志奉　诏译

    净信童女会第四十

如是我闻。一时佛在舍卫国。祇树给孤独园。与大比丘众五百人俱。菩萨摩诃萨八千人。一切皆是众所知识。得陀罗尼辩才无碍。具足诸忍降伏魔怨。逮诸如来所得之法。其名曰持世菩萨。持道菩萨。持地菩萨。持大地菩萨。乐慧菩萨。令信乐菩萨。妙色庄严菩萨。宝焰菩萨。宝幢菩萨。宝思菩萨。宝处菩萨。宝慧菩萨。宝德菩萨。宝光菩萨。复有贤劫诸菩萨等。弥勒菩萨而为上首。复有六十无等喻心诸菩萨等。文殊师利而为上首。复有十六大士。贤护菩萨而为上首。复有二万兜率天子俱在会中。是时世尊。处大庄严藏师子之座。无量百千大众围绕。光明照曜犹如日月。威德殊胜如释梵王。高出众表如须弥山。光焰猛盛犹大火炬。顾视安详如大象王。说法无畏如师子吼。盖诸大众如罗睺罗王。相好庄严威光炽盛。出梵音声遍满三千大千世界。为欲觉悟一切众生普令安住决定胜义。于大众中而演说法

时波斯匿王。所生爱女名曰净信。年在幼稚颜貌端严。为诸众生之所乐见。宿植善本修习大乘。与五百童女前后围绕。各持金鬘。出舍卫城诣只陀林。至如来所顶礼佛足。右绕三匝却住一面。即于佛前而说偈言

  久积福善清净业　　满足无边功德海
  令众信乐皆欢喜　　故我顶礼牟尼尊
  显现威光相奇特　　开示法门众宝处
  身光一寻常照曜　　我礼大慧清凉池
  功德大树福无尽　　人中最尊世所赞
  本愿戒行已圆满　　故我顶礼应供尊
  安住妙法常寂然　　等心世间如一子
  智慧善巧知诸行　　示平坦路如导师
  若有坚固勇进者　　慈悲利益众生类
  如是菩萨正修行　　唯愿如来为宣说
  云何当得坚固力　　安住生死降魔众
  云何当得平等法　　云何成熟诸众生
  云何如地如虚空　　如风如水亦如火
  云何得信住于法　　如彼须弥师子王
  云何远离憎爱心　　净意质直无谀谄
  云何出生施戒忍　　精进禅定及解脱
  智慧破诸烦恼闇　　而常安住大方便
  三昧总持无碍辩　　住四无量五神通
  云何得在诸佛前　　常受化生知宿命
  头陀无诤住兰若　　调伏其心灭烦恼
  持戒修习菩提道　　证甘露灭降魔怨
  施众安乐转法轮　　如是正道愿宣说

尔时世尊。告净信童女言。菩萨若能成就八力。于生死中坚固勇猛而无疲倦。何等为八。一志乐力无谄诳故。二胜解力离诸恶故。三加行力常修善故。四净信力深信业报故。五菩提心力不求小乘故。六大慈力不害众生故。七大悲力堪忍诸恶故。八善友力时时警觉故。童女。是名八力。菩萨成就如是力故。坚固勇猛于生死中无所染着。尔时世尊。重说偈言

  志乐勇猛　　离诸谄诳　　常行质直
  正趣菩提　　以胜解力　　远离众恶
  纯修善行　　住于正勤　　加行具足
  恒善观察　　精进坚固　　安乐众生
  净信力故　　了知业报　　信于佛智
  摄受世间　　菩提心力　　远离小乘
  不断佛种　　安住法性　　大慈力故
  等观众生　　无爱无憎　　不生恚害
  大悲力故　　堪忍众恶　　不染生死
  亦无疲厌　　以善友力　　常相警悟
  心不退没　　安住菩提　　彼勇进者
  得是八力　　当坐道场　　破诸魔众

复次童女。菩萨成就八种法故。住于平等。何等为八。一者一切众生平等本无我故。二者一切法平等诸法寂静故。三者一切刹平等入空界故。四者一切智平等平等说法故。五者一切行平等因缘无性故。六者一切乘平等等无为故。七者心平等心如幻故。八者诸魔平等烦恼为先不可得故。是为八法住于平等。尔时世尊。重说偈言

  众生本无我　　念念不可得
  住于平等者　　应当如是观
  一切法平等　　本性常空寂
  文字有分别　　诸法本无差
  十方诸刹土　　边际不可得
  其性如虚空　　佛国常平等
  三世诸如来　　住法界平等
  无边智解脱　　佛佛皆如是
  众生本缘起　　一切皆平等
  善知其所行　　如应为开悟
  众生若干种　　了知如幻化
  内外无所取　　自性常清净
  诸乘种种说　　无为性平等
  导师善方便　　分别说三乘
  现住烦恼魔　　烦恼无所有
  天魔及蕴死　　境界悉皆空

复次童女。菩萨成就八种法故。离诸憎爱。何者为八。一慈。二悲。三者常行利益。四者不染世法。五者不着自身。六者常修定心。七者舍离身命。八者观察烦恼。修此八法能离憎爱。尔时世尊。重说偈言

  坚被慈心铠　　哀悲于一切
  安住平等心　　则不生憎爱
  智人行利益　　常施他安乐
  得利不自高　　轻毁不生恨
  不为八风动　　则不生憎爱
  于己若于他　　不生憎爱想
  诸想悉舍离　　境界无所著
  常自观其身　　不惜于躯命
  智者于苦乐　　不动如虚空
  善观察烦恼　　我我所俱离
  持行恒如地　　则不生憎爱

复次童女。菩萨成就八种法故。于生死中无有疲倦。何等为八。一者善根广大故。二者观察众生故。三者常得见佛修供养故。四者得见无量诸佛刹故。五者常求佛智故。六者了知生死犹如梦故。七者于殊胜法无怯弱故。八者观察前际及以后际如实际故。尔时世尊。重说偈言

  若诸行道者　　修善无瑕垢
  如空月清净　　度脱苦众生
  摄诸功德故　　生死无疲倦
  观察众生性　　坚固行精进
  于无量佛刹　　恭敬供养佛
  是故十力者　　生死无疲倦
  无量无边世　　说不思议法
  不断三宝种　　当成于法王
  坚持禁戒者　　生死无疲倦
  了知生死性　　如梦如云电
  于法得解脱　　生死无疲倦
  安住于菩提　　喜心常悦豫
  度于方便岸　　生死无疲倦
  常修殊胜法　　如空月增长
  爱乐佛功德　　生死无疲倦
  生死无边际　　常住于实际
  一念慧相应　　生死无疲倦

复次童女。成就八法心界平等。何者为八。一者心如地故。二者心如水故。三者心如火故。四者心如风故。五者心如虚空故。六者心等法界故。七者心等解脱故。八者心等涅槃故。是名八种心界平等。尔时世尊重说偈言

  等心如地　　荷负一切　　于善于恶
  无所增减　　等心如水　　洗诸垢秽
  养育世间　　除烦恼渴　　等心如火
  烧灭烦恼　　大炬光明　　无所不燎
  等心如风　　无处无依　　飃戒闻香
  流遍三世　　等心如空　　离见清净
  遍入一切　　而不随魔　　等心法界
  善得安住　　不增不减　　常入平等
  声闻缘觉　　所得解脱　　无有缚者
  亦无解者　　生死涅槃　　无来无去
  安住寂静　　遍游三世

复次童女。有八种法。菩萨成就出生菩提。何等为八。一者施出生舍诸有故。二者戒出生无所犯故。三者忍出生无嗔恚故。四者精进出生不懈退故。五者禅出生行方便故。六者慧出生持戒多闻故。七者梵住出生解脱寂静故。八者神通出生常在定故。尔时世尊。重说偈言

  常修行施者　　离诸贪热恼
  不希求果报　　回向佛菩提
  持戒为大乘　　割截无嗔恨
  志求大安乐　　除习证真灭
  菩萨行精进　　多劫为众生
  忍苦游世间　　精进力增长
  修行禅定者　　远离诸戏论
  到诸禅彼岸　　而不随禅生
  大慧无等伦　　永离诸边见
  了知世空寂　　痴闇灭无余
  寂静修梵住　　净除诸恶道
  常为释梵王　　勤修诸义利
  神通游佛刹　　侍佛听闻法
  善知诸性欲　　说法度众生

复次童女。菩萨成就八种法故。得陀罗尼辩才无碍。何等为八。一者尊重法故。二者承事和上阿阇梨故。三者求法无厌故。四者如闻演说故。五者不悭吝法故。六者不扬他恶故。七者爱敬法师如和上故。八者不见他过劝离过故。是名八法。菩萨成就具足总持辩才无碍。尔时世尊。重说偈言

  志乐常求法　　事师亲善友
  远离恶知识　　得无尽藏持
  多闻无厌足　　勇猛勤求法
  如闻而演说　　不希求利养
  得清净辩才　　能令众欢喜
  欣乐行法施　　远离于悭嫉
  行法无所著　　获得陀罗尼
  护戒自观身　　不求他过失
  慈悲为依止　　发语不非时
  当得无碍辩　　度言说彼岸
  于善说法者　　爱敬如师想
  隐过劝离恶　　获无尽海持

复次童女。菩萨成就八种法故。于诸佛前莲花化生。何者为八。一者乃至失命不说他过。二者劝化众生令归三宝。三者安置一切于菩提心。四者梵行无染。五者造立佛像置莲花座。六者忧恼众生令除忧恼。七者于贡高人常自谦下。八者不恼他人。尔时世尊。重说偈言

  假令苦逼身　　终不说他过
  常称叹三宝　　化生诸佛前
  劝发菩提心　　令求一切智
  常修于梵行　　化生诸佛前
  黄金严佛像　　坐宝莲花座
  除众生忧恼　　化生诸佛前
  于彼憍慢人　　谦卑如弟子
  不令他生恼　　化生诸佛前

复次童女。有八种法。菩萨成就头陀功德。常乐住于阿兰若处。何等为八。一者少欲。二者知足。三者满足善法。四者以善自养。五者常持圣种。六者见生死患心常厌离。七者恒观无常苦空无我。八者深信坚固不随他教。尔时世尊。重说偈言

  少欲知足不放逸　　法喜众善为资养
  爱乐常修于圣种　　见生死患生怖心
  由是常乐行头陀　　如犀一角独无侣
  有为之法苦无我　　慧心深信住正勤
  自见于法不随他　　常处空闲佛所赞
  头陀远离无恼患　　无诸诤论众过失
  远离眷属绝称誉　　由是乐住阿兰若

复次童女。菩萨成就八种法故。摧伏魔怨。何等为八。一者入于性空。二者信于无相。三者信于无愿。四者了知无作。五者内无疑惑。六者忍于无生。七者决了无性。八者于一切法方便观察不坏于如。尔时世尊。重说偈言

  于空无相及无愿　　得三解脱降魔怨
  有为无为无二相　　证于无生得解脱
  诸法无生如是忍　　彼等降伏诸魔怨
  于此无生无灭中　　蕴界无我犹如幻
  决定了知法无性　　不坏于如巧方便
  分别诸法为魔业　　舍离分别则降魔
  智慧方便二俱行　　若有若空无所住
  修习如是殊胜法　　得善方便妙色身

复次童女菩萨成就八种法故。不离菩提。何者为八。一者正见。成熟邪见众生故。二者正念。悲愍邪念众生故。三者正语。愍诸邪语故。四者正业。摄诸邪业故。五者正精进。度邪勤者故。六者正命。不舍邪命众生故。七者正思惟。令离邪思惟故。八者正定。发起增进邪定者故。尔时世尊。重说偈言

  成就正见者　　化彼诸邪见
  常修行正念　　哀悲邪念者
  清净正言说　　愍诸邪语者
  安住于正业　　摄诸邪业者
  常修于正勤　　不舍邪勤者
  相应正净命　　摄诸邪命者
  智者正思惟　　哀愍邪思者
  常住于正定　　摄诸邪定者
  无上八正道　　安隐度暴流
  复渡漂流者　　是大菩提道
  声闻及缘觉　　草筏唯自渡
  菩萨广运济　　如彼大船师

复次童女。菩萨成就八种法故。证甘露道。何等为八。一者住于无诤之法。二者善守无障碍心。三者常观如实之义。四者住菩提心修习六念。五者精勤修习诸波罗蜜。六者积集善根成熟众生。七者住于大悲摄受正法。八者得无生忍住不退转。尔时世尊。重说偈言

  常修无诤行　　住大沙门法
  远离嗔恚过　　积集诸善根
  善观如实义　　得诸无尽辩
  安住菩提心　　常念于无念
  一切波罗蜜　　勤修无退转
  得诸方便力　　由是度众生
  能以法王财　　悲心施一切
  速证无生忍　　不退转菩提
  若能如是行　　佛法不难得
  不久降魔众　　证最上菩提

尔时净信童女闻是法已欢喜踊跃。白佛言。世尊。成熟几法能转女身。佛告童女。成就八法当转女身。何等为八。一者不嫉。二者不悭。三者不谄。四者不嗔。五者实语。六者不恶口。七者舍离贪欲。八者离诸邪见。童女。修此八法速转女身。尔时世尊。重说偈言

  不嫉妒他人　　离悭常乐法
  不行于谄诳　　厌患女人身
  慈心舍离嗔　　常修于实语
  除贪离恶口　　安住正见中
  若厌女人身　　应修如是法
  便当速得转　　受善丈夫身

复次童女成就八法能转女身。何者为八。一者尊重于佛深乐于法。二者恭敬供养戒忍多闻沙门婆罗门。三者于夫男女及以居家。不生爱着。四者受持禁戒无所缺犯。五者于一切人不生邪念。六者增上意乐厌离女身。七者住菩提心大丈夫法。八者观世家业如幻如梦。尔时世尊重说偈言

  敬佛深乐法　　尊重戒多闻
  不生贪爱心　　女身速当转
  持戒具惭愧　　不妄念他人
  安住菩提心　　不乐余乘法
  由是速能转　　不净女人身
  胜志得厌心　　一切皆如幻
  诸法本无动　　因缘性空寂
  勤修如实法　　速得丈夫身

尔时净信童女以所持金鬘散于佛上。于虚空中变成真金宫殿楼阁。于宫殿中有化如来坐于金座。时五百童女各各解身庄严之具散彼佛上。亦于空中变金楼阁。宝帐宝盖种种庄严。尔时五百童女见大神变。异口同音而说偈言

  世尊人中最殊胜　　哀愍利益诸众生
  我今已发菩提心　　志乐相应住调伏
  为世导师施安乐　　我当供养人中尊
  闻法已离于尘垢　　我等无复诸疑惑
  方离女身众染污　　永破烦恼降魔怨
  十方无量俱胝佛　　我当欢喜常供养
  安住施戒勤精进　　忍辱禅定善调心
  智慧方便摄众生　　当证最上菩提道
  利益无量人天众　　悉令发起大乘心
  我等当能师子吼　　我等当作人天师

尔时世尊便现微笑。诸佛常法种种色光。青黄赤白红紫颇梨从佛口出。遍照无量无边世界乃至梵世。绕佛三匝还从顶入。尔时长老阿难从座而起。白佛言。世尊。何因何缘现此微笑。佛告阿难。汝见净信童女不。阿难白言。唯然已见。佛言阿难。是净信等五百童女人中寿尽。当舍女身生兜率陀天。承事供养弥勒世尊。及贤劫中一切如来。是净信童女。过八万四千俱胝那由他劫。于电光世界。当得作佛。号光明庄严王如来。劫名常光。其佛寿命。如兜率陀天十二千岁。其国纯以无量无边大菩萨众而为眷属。是五百童女。于此众中最为上首。犹如我今六十菩萨。文殊师利而为上首。阿难。若有女人得闻此经。受持读诵。尽此女身后不复受。速证阿耨多罗三藐三菩提。佛说此经已。净信等五百童女。及一切世间天人阿修罗。闻佛所说皆大欢喜。信受奉行

    大宝积经弥勒菩萨问八法会第四十一

        元魏三藏菩提留支译

如是我闻。一时婆伽婆住王舍城耆阇崛山中。与大比丘众千二百五十人俱。并诸菩萨摩诃萨十千人等

尔时弥勒菩萨摩诃萨即从座起。偏袒右肩。右膝着地。合掌向佛白佛言。世尊。我今欲以少法问于如来应正遍知。不审世尊。听许以不。尔时世尊告弥勒菩萨摩诃萨言。弥勒。随汝心念。问于如来应正遍知。我当为汝分别解说令汝心喜。尔时弥勒菩萨摩诃萨白佛言。世尊。如是愿乐欲闻。世尊。诸菩萨摩诃萨毕竟成就几法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时。降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲倦。以心不疲倦故不依他智。速疾成就阿耨多罗三藐三菩提

尔时世尊告弥勒菩萨摩诃萨言。善哉善哉。弥勒。汝今乃能问于如来如是深义。佛复告弥勒菩萨摩诃萨言。汝今应当一心谛听。吾当为汝分别解说如是深义。即时弥勒菩萨摩诃萨。白佛言世尊。如是愿乐欲闻。佛复告弥勒菩萨摩诃萨言。弥勒。若诸菩萨摩诃萨毕竟成就八法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时。降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲倦。以心不疲倦故不依他智。速疾成就阿耨多罗三藐三菩提。何等为八。弥勒。所谓诸菩萨摩诃萨成就深心。成就行心。成就舍心。成就善知回向方便心。成就大慈心。成就大悲心。成就善知方便。成就般若波罗蜜。弥勒。云何诸菩萨摩诃萨成就深心。弥勒。若诸菩萨摩诃萨闻赞叹佛及毁呰佛。其心毕竟。于阿耨多罗三藐三菩提。坚固不动。闻赞叹法及毁呰法。其心毕竟。于阿耨多罗三藐三菩提。坚固不动。闻赞叹僧及毁呰僧。其心毕竟。于阿耨多罗三藐三菩提。坚固不动。弥勒。如是诸菩萨摩诃萨毕竟成就深心。弥勒。云何诸菩萨摩诃萨成就行心。弥勒。若诸菩萨摩诃萨。远离杀生。远离偷盗。远离邪淫。远离妄语。远离两舌。远离恶口。远离绮语。弥勒。如是诸菩萨摩诃萨。毕竟成就行心。弥勒。云何诸菩萨摩诃萨。成就舍心。弥勒。若诸菩萨摩诃萨。是能舍主。是施主。施诸沙门及婆罗门。贫穷乞丐下贱人等。衣食卧具随病汤药所须之物。弥勒。如是诸菩萨摩诃萨。毕竟成就舍心。弥勒。云何诸菩萨摩诃萨。成就善知回向方便心。弥勒。若诸菩萨摩诃萨。所修善根谓身口意业。皆悉回向阿耨多罗三藐三菩提。弥勒。如是诸菩萨摩诃萨。毕竟成就善知回向方便心。弥勒。云何诸菩萨摩诃萨。成就大慈心。弥勒。若诸菩萨摩诃萨。毕竟成就大慈身业。毕竟成就大慈口业。毕竟成就大慈意业。弥勒。如是诸菩萨摩诃萨。毕竟成就大慈心。弥勒。云何诸菩萨摩诃萨。成就大悲心。弥勒。若诸菩萨摩诃萨。毕竟成就不可讥呵身业。毕竟成就不可讥呵口业。毕竟成就不可讥呵意业。弥勒。如是诸菩萨摩诃萨。毕竟成就大悲心。弥勒。云何诸菩萨摩诃萨。成就善知方便。弥勒。若诸菩萨摩诃萨。善知世谛。善知第一义谛。善知二谛。弥勒。如是诸菩萨摩诃萨。毕竟成就善知方便

弥勒。云何诸菩萨摩诃萨。成就般若波罗蜜。弥勒。若诸菩萨摩诃萨。如是觉知。依此法有此法。依此法生此法。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是唯有大苦聚集。弥勒。此法无故此法无。此法灭故此法灭。所谓无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。如是唯有大苦聚集灭。弥勒。如是诸菩萨摩诃萨。毕竟成就般若波罗蜜。弥勒。是名诸菩萨摩诃萨毕竟成就八法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时。降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲倦。以心不疲倦故不依他智。速疾成就阿耨多罗三藐三菩提。佛说此经已。弥勒菩萨摩诃萨。及余诸菩萨摩诃萨。比丘比丘尼。优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切大众。闻佛所说。皆大欢喜。信受奉行

    大宝积经弥勒菩萨所问会第四十二

        大唐三藏菩提流志译

如是我闻。一时佛在波罗奈国施鹿林中。与大比丘众五百人俱。一切皆为众所知识。其名曰阿若憍陈如。摩诃迦叶。优楼频螺迦叶。伽耶迦叶。那提迦叶。舍利弗。大目揵连。阿难。罗睺罗等。而为上首。复有菩萨摩诃萨一万人俱。其名曰善意菩萨。增上意菩萨。坚固意菩萨。师子意菩萨。观世音菩萨。大势至菩萨。辩积菩萨。美音菩萨。胜幢菩萨。信慧菩萨。水天菩萨。帝胜菩萨。帝天菩萨。无攀缘菩萨。具辩才菩萨。神通妙华菩萨。弥勒菩萨。文殊师利法王子等。而为上首

尔时世尊。无量百千大众围绕。供养恭敬而为说法。是时弥勒菩萨摩诃萨。在众会中即从座起。偏袒右肩右膝着地。合掌顶礼而白佛言。世尊。我有少疑今欲咨问。唯愿如来见垂听许。佛告弥勒菩萨言。若有所疑今恣汝问。当为解说令得欢喜。尔时弥勒菩萨闻佛许已。欢喜踊跃而白佛言。世尊。菩萨成就几法。离诸恶道及恶知识。而能速证阿耨多罗三藐三菩提耶。佛告弥勒菩萨言。善哉善哉。弥勒。汝今为欲哀愍一切。利益安乐天人世间。能问如来如是深义。汝应谛听善思念之。吾当为汝分别解说。弥勒菩萨即白佛言。唯然世尊。愿乐欲闻。佛告弥勒言。菩萨成就一法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为一。所谓发胜意乐菩提之心。是名为一。弥勒。复有二法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为二。一者于奢摩他常勤修习。二者于毗钵舍那而得善巧。是名为二。弥勒。复有三法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为三。一者成就大悲。二者修习空法。三者于一切法不生分别。是名为三。弥勒。复有四法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为四。一者安住净戒。二者离诸疑网。三者乐阿兰若。四者起正见心。是名为四。弥勒。复有五法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为五。一者住于空法。二者不求他过。三者常自观察。四者爱乐正法。五者摄护于他。是名为五。弥勒。复有六法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为六。一者无有贪欲。二者不生嗔恚。三者不起愚痴。四者常离粗语。五者住于空性。六者心如虚空。是名为六。弥勒。复有七法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为七。一者住于正念。二者成就择法。三者发起精进。四者常生欢喜。五者身得轻安。六者住诸禅定。七者具足行舍。是名为七。弥勒。复有八法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为八。一者正见。二者正思惟。三者正语。四者正业。五者正命。六者正勤。七者正念。八者正定。是名为八。弥勒。复有九法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为九。一者速离诸欲恶不善法。安住初禅寻伺喜乐心一境性。二者远离寻伺。安住二禅内净喜乐心一境性。三者远离于喜。安住三禅舍念慧乐心一境性。四者远离忧苦及以喜乐。安住四禅舍念清净无苦无乐心一境性。五者超过色想无异攀缘。安住无边虚空处定。六者超过无边空处定已。而能安住无边识定。七者超过无边识处定已。而能安住无所有定。八者超过无所有处定已。安住非想非非想定。九者超过非想非非想处定已。而能安住灭受想定。是名为九。弥勒。复有十法。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。云何为十。一者善能成就金刚三昧。二者成就处非处相应三昧。三者成就方便行三昧。四者成就遍照明三昧。五者成就普光明三昧。六者成就普遍照明三昧。七者成就宝月三昧。八者成就月灯三昧。九者成就出离三昧。十者成就胜幢臂印三昧。是名为十。弥勒。菩萨成就如是法已。离诸恶道及恶知识。速能证得阿耨多罗三藐三菩提。尔时弥勒菩萨。得闻是法心大欢喜。偏袒右肩。右膝着地。合掌恭敬。即于佛前。以偈赞曰

  佛于过去劫　　舍所爱妻子
  头目及骨髓　　到于施彼岸
  佛常护禁戒　　如牦牛爱尾
  最胜无伦匹　　到于戒彼岸
  佛以忍辱力　　舍离于违诤
  不求人过恶　　到于忍彼岸
  佛以精进力　　得无上寂静
  究竟常安乐　　到于勤彼岸
  佛以禅定力　　能灭诸罪垢
  为天人导师　　到于定彼岸
  佛以智慧力　　善了知诸法
  自性无所有　　到于慧彼岸
  佛于菩提树　　降伏诸魔军
  具足最胜智　　成就无上道
  导师无畏力　　于波罗奈国
  转清净法轮　　摧破诸外道
  无上大智慧　　出过于世间
  能放净光明　　善说诸法要
  如来清净色　　智慧及功德
  超过诸世间　　能到于彼岸

尔时阿难白佛言。世尊。是弥勒菩萨甚为希有。而能成就无量辩才。随众生念平等说法。而于文字无所系着。佛告阿难。如是如是。如汝所说。阿难。弥勒菩萨。岂唯今日能于我前以偈赞佛。乃往过去十无数劫。尔时有佛号焰光游戏妙音自在王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时有一婆罗门子。名曰贤寿。诸相具足见者欢喜。从园苑出。见彼如来端正殊妙诸根寂静。得奢摩他。如清净池无诸垢秽。三十二相八十种好而自庄严。如娑罗树其花开敷。如须弥山出过一切。面貌熙怡如月盛满。威光赫奕如日显曜。形量周圆如尼俱陀树。是时贤寿。睹佛如来殊胜之相。心生净信作是思惟。希有世尊。乃能成就如是无量功德庄严。我亦愿于当来之世。成就如是功德之身。发是愿已投身于地。复自念言。若当来世得佛身者。唯愿如来足蹈我上。尔时彼佛知贤寿意。即以其足蹈贤寿身。当下足时得无生法忍。世尊回顾告诸比丘。汝等勿以足蹈贤寿。何以故。此是菩萨摩诃萨。今已证得无生法忍。复能成就天眼天耳他心宿住神境智通。尔时贤寿。即于佛前。以偈赞曰

  佛于十方界　　最尊无有上
  超过诸世间　　我今稽首礼
  如来大光明　　掩蔽于日月
  超过诸世间　　我今稽首礼
  譬如师子吼　　诸兽咸怖畏
  世尊大威德　　摧伏诸外道
  眉间白毫相　　犹如颇梨光
  普照于世间　　超过于一切
  世尊无与等　　足蹈千辐轮
  清净化世间　　能动于大地
  成就出离道　　超过烦恼海
  以诸功德财　　随意皆施与
  如来清净戒　　犹如于大地
  出生诸功德　　无有爱憎想
  以智慧力故　　了知诸法空
  众生及寿者　　分别不可得
  善了众生性　　心行及所趣
  为世作明灯　　饶益于一切
  世间苦逼迫　　漂溺于暴流
  常为诸众生　　起大精进力
  世尊离烦恼　　生老及病死
  处世如虚空　　一切无所染
  智慧大威光　　能破一切闇
  永离贪嗔痴　　我今稽首礼

佛告阿难。贤寿菩萨所获神通。从是已来不复退失。于意云何。尔时贤寿岂异人乎。今此会中弥勒菩萨摩诃萨是。阿难白佛言。世尊。若弥勒菩萨。久已证得无生法忍。何故不得阿耨多罗三藐三菩提耶。佛告阿难。菩萨有二种庄严二种摄取。所谓摄取众生。庄严众生。摄取佛国。庄严佛国。弥勒菩萨。于过去世修菩萨行。常乐摄取佛国。庄严佛国。我于往昔修菩萨行。常乐摄取众生。庄严众生。然彼弥勒。修菩萨行经四十劫。我时乃发阿耨多罗三藐三菩提心。由我勇猛精进力故。便超九劫。于贤劫中。得阿耨多罗三藐三菩提。阿难。我以十法得证菩提。云何为十。一者能施所爱之物。二者能施所爱之妻。三者能施所爱之子。四者能施所爱之头。五者能施所爱之眼。六者能施所爱王位。七者能施所爱珍宝。八者能施所爱血肉。九者能施所爱骨髓。十者能施所爱支分。是名为十。我行此法。能得阿耨多罗三藐三菩提

阿难。复有十法能证菩提。云何为十。一者获戒功德。二者成就忍力。三者发起精进。四者得诸禅定。五者有大智慧。六者于诸众生常不舍离。七者于诸众生起平等心。八者于诸空法而常修习。九者善能成就真实空性。十者善能成就无相无愿。是名为十。我行此法。能得阿耨多罗三藐三菩提。阿难。弥勒菩萨往昔行菩萨道时。不能舍施手足头目。但以善巧方便安乐之道。积集无上正等菩提。尔时阿难白佛言。世尊。云何弥勒。往昔行菩萨道时。但以善巧方便安乐之道。而能积集无上菩提。佛告阿难。弥勒往昔行菩萨道。昼夜六时。偏袒右肩。右膝着地。合掌顶礼。于诸佛前。说是偈言

  我今归命礼　　十方一切佛
  菩萨声闻众　　大仙天眼者
  亦礼菩提心　　远离诸恶道
  能得生天上　　乃至证涅槃
  若我作少罪　　随心之所生
  今对诸佛前　　忏悔令除灭
  我今身口意　　所集诸功德
  愿作菩提因　　当成无上道
  十方国土中　　供养如来者
  及佛无上智　　我今尽随喜
  有罪悉忏悔　　是福皆随喜
  我今礼诸佛　　愿成无上智
  十方大菩萨　　证于十地者
  我今稽首礼　　愿速证菩提
  得证菩提已　　摧伏于魔军
  转清净法轮　　饶益众生类
  常愿住世间　　无量俱胝劫
  击于大法鼓　　度脱苦众生
  我没于欲泥　　贪绳之所系
  种种多缠缚　　愿佛垂观察
  众生虽垢重　　诸佛不厌舍
  愿以大慈悲　　度脱生死海
  现在诸世尊　　过去未来佛
  所行菩萨道　　我今愿修学
  具足波罗蜜　　成就六神通
  度脱诸众生　　证于无上道
  了知诸法空　　无相无自性
  无住无表示　　不生亦不灭
  又如大仙尊　　善了于无我
  无补特伽罗　　乃至无寿者
  于诸布施事　　不执我我所
  为安乐众生　　施与无悭吝
  愿我所施物　　不假功用生
  观察了知空　　具施波罗蜜
  持戒无缺减　　得佛净尸罗
  以无所住故　　具戒波罗蜜
  忍辱如四大　　不生分别心
  以无嗔恚故　　具忍波罗蜜
  愿以身心力　　发起大精进
  坚固无懈怠　　具勤波罗蜜
  以如幻如化　　及勇猛精进
  金刚等三昧　　具禅波罗蜜
  愿证三明智　　入于三脱门
  了三世平等　　具慧波罗蜜
  诸佛妙色身　　光明大威德
  菩萨精进行　　愿我皆圆满
  弥勒名称者　　勤修如是行
  具六波罗蜜　　安住于十地

佛告阿难。弥勒菩萨安住如是善巧方便。积集阿耨多罗三藐三菩提。阿难。我昔求道受苦无量。乃能积集阿耨多罗三藐三菩提。何以故。乃往古昔时有太子。名见一切义。端正殊妙诸相具足见者欢喜。出游园苑见一病人受诸重苦。生悲愍心便问之言。汝今此病岂无有药能疗治耶。尔时病人。即以偈颂。白太子言

  我病药难求　　世间不可得
  国王亦无有　　何况病恼者
  通达于诸论　　善说医方者
  虽欲为疗治　　其药难可得

尔时太子。复以偈颂。告病人言

  金银摩尼珠　　乃至于象马
  所求皆当说　　为汝除忧恼

尔时病人。复以偈颂。白太子言

  若饮太子血　　我必得安乐
  愿生欢喜心　　施我无忧恼

尔时太子。复以偈颂。告病人言

  我为诸众生　　坠堕无间狱
  多劫犹能忍　　何况于身血

尔时太子。即取利刀刺身出血。令彼病人随意所用。不生一念悔恨之心。阿难当知。尔时太子见一切义者岂异人乎今我身是。四大海水犹可测量。我于往昔行菩萨道。舍已身血不可称计

佛告阿难。乃往古昔时有太子。名曰妙花。端正殊胜诸相具足见者欢喜。从园苑出见一病人身体羸瘦。生悲愍心便问之言。汝今此病岂无有药能疗治耶。尔时病人即以偈颂。白太子言

  世虽有良医　　无药疗我病
  唯愿生慈愍　　为我除忧恼

尔时太子。即以偈颂。告病人言

  我为利世间　　一切咸施与
  身分及珍宝　　须者皆当说

尔时病人。复以偈颂。白太子言

  譬如大药王　　随意疗众病
  亦如日月光　　普照诸世间
  若能出身髓　　遍涂于我身
  是病乃消除　　长夜得安乐

尔时太子。复以偈颂。告病人言

  若有诸众生　　碎我身出髓
  为利于世间　　心不生忧恼

尔时太子。即自碎身取其骨髓。与彼病人随意所用。不生一念悔恨之心。阿难当知。尔时妙花太子岂异人乎。今我身是。四大海水犹可测量。我于往昔行菩萨道。舍身骨髓不可称计。佛告阿难。乃往古昔时有国王。名为月光。端正殊妙诸相具足见者欢喜。从园苑出见一盲人贫穷乞丐。生悲愍心便问之言。汝何所须我当施汝。或饮食衣服庄严资具金银摩尼及诸珍宝。随汝所欲皆当与之。尔时盲人。即以偈颂。而白王言

  大王犹日月　　光明照世间
  具足胜功德　　不久生天上
  一切净妙色　　我今悉不见
  愿王起慈悲　　施我所爱眼

尔时大王。即以偈颂。告盲人言

  汝速来取眼　　令汝得安乐
  愿我当来世　　得佛清净眼
  我行菩萨道　　一切皆当舍
  若我不施汝　　是则违本愿

尔时月光王。即取利刀自挑其眼。与彼盲人随意所用。不生一念悔恨之心。阿难当知。尔时月光王者岂异人乎。即我身是。须弥山王犹可度量。我于往昔行菩萨道。舍所爱眼不可称计。阿难。弥勒菩萨。往修行菩萨道时。作是愿言。若有众生薄淫怒痴成就十善。我于尔时。乃成阿耨多罗三藐三菩提。阿难。于当来世有诸众生。薄淫怒痴成就十善。弥勒菩萨当尔之时。得阿耨多罗三藐三菩提。何以故。由彼菩萨本愿力故

佛告阿难。我于往昔行菩萨道。作如是言。愿我当于五浊恶世贪嗔垢重诸恶众生。不孝父母不敬师长。乃至眷属不相和睦。我于尔时。当成阿耨多罗三藐三菩提。阿难。以是愿故。我今所入城邑聚落。多有众生毁骂于我。以断常法招集众会。若行乞食坌以尘土。和诸杂毒与我令食。或以女人诽谤于我。阿难。我于今者以本愿力。为如是等诸恶众生。起大悲心而为说法

尔时阿难白佛言。世尊。如来应正等觉。能作难作。能忍难忍不调伏者悉令调伏。荷担如是罪垢众生而为说法。佛告阿难。如是如是。如汝所说。何以故。如来大悲之所摄故。尔时阿难白佛言。世尊。我闻如来坚固誓愿。身毛皆竖。世尊。当何名此经。我等云何受持。佛告阿难。是经名为弥勒所问。亦名往昔本愿因缘。以是名字汝当受持。佛说是经已。弥勒菩萨。尊者阿难。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

大宝积经卷第一百一十一大宝积经卷第一百一十二

        失译附秦录勘同编入

    普明菩萨会第四十三

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众八千人俱。菩萨摩诃萨万六千人。皆是阿惟越致。从诸佛土而来集会。悉皆一生当成无上正真大道。尔时世尊。告大迦叶。菩萨有四法退失智慧。何谓为四。不尊重法不敬法师。所受深法秘不说尽。有乐法者为作留难。说诸因缘沮坏其心。憍慢自高卑下他人。迦叶。是为菩萨四法退失智慧。复次迦叶。菩萨有四法得大智慧。何谓为四。常尊重法恭敬法师。随所闻法以清净心广为人说。不求一切名闻利养。知从多闻生于智慧。勤求不懈如救头然。闻经诵持乐如说行不随言说。迦叶。是为菩萨四法得大智慧。复次迦叶。菩萨有四法失菩提心。何谓为四。欺诳师长已受经法而不恭敬。无疑悔处令他疑悔。求大乘者诃骂诽谤广其恶名。以谄曲心与人从事。迦叶。是为菩萨四法失菩提心。复次迦叶。菩萨有四法。世世不失菩提之心。乃至道场自然现前。何谓为四。失命因缘不以妄语何况戏笑。常以直心与人从事离诸谄曲。于诸菩萨生世尊想。能于四方称扬其名。自不爱乐诸小乘法。所化众生皆悉令住无上菩提。迦叶。是为菩萨四法世世不失菩提之心。乃至道场自然现前。复次迦叶。菩萨有四法。所生善法灭不增长。何谓为四。以憍慢心读诵修学路伽耶经。贪利养心诣诸檀越增毁菩萨。所未闻经违逆不信。迦叶。是为菩萨四法所生善法灭不增长。复次迦叶。菩萨有四法。所生善法增长不失。何谓为四。舍离邪法求正经典六波罗蜜菩萨法藏。心无憍慢于诸众生谦卑下下。如法得施知量知足。离诸邪命安住圣种。不出他人罪过虚实不求人短。若于诸法心不通达作如是念。佛法无量随众所乐而为演说。唯佛所知非我所解。以佛为证不生违逆。迦叶。是为菩萨四法所生善法增长不失。复次迦叶。菩萨有四曲心。所应远离。何谓为四。于佛法中心生疑悔。于诸众生憍慢嗔恨。于他利养起嫉妒心。诃骂菩萨广其恶名。迦叶。是为菩萨四曲心所应远离。复次迦叶。菩萨有四直心之相。何谓为四。所犯众罪终不覆藏。向他发露心无盖缠。若失国界身命财利。如是急事终不妄语。亦不余言一切恶事。骂詈毁谤挝打系缚种种伤害。受是苦时但自咎责。自依业报不嗔恨他。安住信力。若闻甚深难信佛法。自心清净能悉受持。迦叶。是为菩萨有四直心之相。复次迦叶。菩萨有四败坏之相。何谓为四。读诵经典而生戏论。不随法行。不能奉顺恭敬师长。令心欢悦损他供养。自违本誓而受信施。见善菩萨轻慢不敬。迦叶。是为菩萨有四败坏之相。复次迦叶。菩萨有四善顺之相。何谓为四。所未闻经闻便信受如所说行。依止于法不依言说。随顺师教能知意旨。易与言语所作皆善。不失师意不退戒定。以调顺心而受供养。见善菩萨恭敬爱乐。随顺善人禀受德行。迦叶。是为菩萨有四善顺之相。复次迦叶。菩萨有四错谬。何谓为四。不可信人与之同意。是菩萨谬。非器众生说其深法。是菩萨谬。乐大乘者为赞小乘。是菩萨谬。若行施时但与持戒。供养善者不与恶人。是菩萨谬。迦叶。是为菩萨四谬。复次迦叶。菩萨有四正道。何谓为四。于诸众生其心平等。普化众生等以佛慧。于诸众生平等说法。普令众生等住正行。迦叶。是为菩萨有四正道。复次迦叶。菩萨有四非善知识非善等侣。何谓为四。求声闻者但欲自利。求缘觉者喜乐少事。读外经典路伽耶毗。文辞严饰所亲近者。但增世利不益法利。迦叶。是为菩萨有四非善知识非善等侣。复次迦叶。菩萨有四善知识四善等侣。何谓为四。诸来求者是善知识。佛道因缘故。能说法者是善知识。生智慧故。能教他人令出家者是善知识。增长善法故。诸佛世尊是善知识。增长一切诸佛法故。迦叶。是为菩萨四善知识四善等侣。复次迦叶。菩萨有四非菩萨而似菩萨。何谓为四。贪求利养而不求法。贪求名称不求福德。贪求自乐不救众生。以灭苦法乐聚徒众不乐远离。迦叶。是为四非菩萨而似菩萨。复次迦叶。菩萨有四真实菩萨。何谓为四。能信解空亦信业报。知一切法无有吾我。而于众生起大悲心。深乐涅槃而游生死。所作行施皆为众生不求果报。迦叶。是为四种真实菩萨福德。复次迦叶。菩萨有四大藏。何谓为四。若有菩萨值遇诸佛。能闻六波罗蜜及其义解。以无碍心视说法者。乐远离行心无懈怠。迦叶。是为菩萨有四大藏。复次迦叶。菩萨有四法能过魔事。何谓为四。常不舍离菩提之心。于诸众生心无恚碍。觉诸知见。心不轻贱一切众生。迦叶。是为菩萨四法能过魔事。复次迦叶。菩萨有四法摄诸善根。何谓为四。在空闲处离谄曲心。诸众生中行四摄法而不求报。为求法故不惜身命。修诸善根心无厌足。迦叶。是为菩萨四法摄诸善根。复次迦叶。菩萨有四无量福德庄严。何谓为四。以清净心而行法施。于破戒人生大悲心。于诸众生中称扬赞叹菩提之心。于诸下劣修习忍辱。迦叶。是为菩萨有四无量福德庄严。复次迦叶。名菩萨者。不但名字为菩萨也。能行善法行平等心。名为菩萨。略说成就三十二法名为菩萨何谓三十二法。常为众生深求安乐。皆令得住一切智中。心不憎恶他人智慧。破坏憍慢深乐佛道。爱敬无虚亲厚究竟。于怨亲中其心同等至于涅槃。言常含笑先意问讯。所为事业终不中息。普为众生等行大悲。心无疲倦多闻无厌。自求己过不说他短。以菩提心行诸威仪。所行惠施不求其报。不依生处而行持戒。诸众生中行无碍忍。为修一切诸善根故勤行精进。离生无色而起禅定。行方便慧。应四摄法。善恶众生慈心无畏。一心听法心住远离。心不乐着世间众事。不贪小乘。于大乘中常见大利。离恶知识。亲近善友。成四梵行。游戏五通。常依真智。于诸众生邪行正行俱不舍弃。言常决定贵真实法。一切所作菩提为首。如是迦叶。若人有此三十二法名为菩萨。复次迦叶。菩萨福德无量无边。当以譬喻因缘故知。迦叶。譬如一切大地众生所用。无分别心不求其报。菩萨亦尔。从初发心至坐道场。一切众生皆蒙利益。心无分别不求其报。迦叶。譬如一切水种百谷药木皆得增长。菩萨亦尔。自心净故慈悲普覆一切众生。皆令增长一切善法。迦叶。譬如一切火种皆能成熟百谷果实。菩萨智慧亦复如是。皆能成熟一切善法。迦叶。譬如一切风种。皆能成立一切世界。菩萨方便亦复如是。皆能成立一切佛法。迦叶。譬如月初生时。光明形色日日增长。菩萨净心亦复如是。一切善法日日增长。迦叶。譬如日之初出一时放光。普为一切众生照明。菩萨亦尔放智慧光。一时普照一切众生。迦叶。譬如师子兽王。随所至处不惊不畏。菩萨亦尔。清净持戒真实智慧。随所住处不惊不畏。迦叶。譬如善调象王。能办大事身不疲极。菩萨亦尔。善调心故。能为众生作大利益心无疲倦。迦叶。譬如有诸莲花。生于水中水不能着。菩萨亦尔。生于世间而世间法所不能污。迦叶。譬如有人伐树根在还生。菩萨亦尔。方便力故。虽断结使有善根爱还生三界。迦叶。譬如诸方流水。入大海已皆为一味。菩萨亦尔。以种种门集诸善根。回向阿耨多罗三藐三菩提皆为一味。迦叶。譬如须弥山王。忉利诸天及四天王皆依止住。菩萨菩提心亦复如是。为萨婆若所依止住。迦叶。譬如有大国王。以臣力故能办国事。菩萨智慧亦复如是。方便力故。皆能成办一切佛事。迦叶。譬如天晴明时。净无云翳必无雨相。寡闻菩萨无法雨相亦复如是。迦叶。譬如天阴云时。必能降雨充足众生。菩萨亦尔。从大悲云起大法雨利益众生。迦叶。譬如随转轮王。所出之处则有七宝。如是迦叶。菩萨出时三十七品现于世间。迦叶。譬如随摩尼珠所在之处。则有无量金银珍宝。菩萨亦尔。随所出处。则有无量百千声闻辟支佛宝。迦叶。譬如忉利诸天入同等园。所用之物皆悉同等。菩萨亦尔。真净心故于众生中平等教化。迦叶。譬如咒术药力毒不害人。菩萨结毒亦复如是。智慧力故不堕恶道。迦叶。譬如诸大城中所弃粪秽。若置甘蔗蒲桃田中则有利益。菩萨结使亦复如是。所有遗余皆是利益。萨婆若因缘故。如是迦叶。菩萨欲学是宝积经者应修习正观诸法。云何为正观。所谓真实思惟诸法。真实正观者。不观我人众生寿命。是名中道真实正观。复次迦叶。真实观者。观色非常亦非无常观。受想行识非常亦非无常。是名中道真实正观。复次迦叶。真实观者。观地种非常亦非无常。观水火风种非常亦非无常。是名中道真实正观。所以者何。以常是一边无常是一边。常无常是中无色无形无明无知。是名中道诸法实观。我是一边无我是一边。我无我是中。无色无形无明无知。是名中道诸法实观。复次迦叶。若心有实是为一边。若心非实是为一边。若无心识亦无心数法。是名中道诸法实观。如是善法不善法。世法出世法。有罪法无罪法。有漏法无漏法。有为法无为法。乃至有垢法无垢法亦复如是离于二边。而不可受亦不可说。是名中道诸法实观。复次迦叶。有是一边无是一边。有无中间无色无形无明无知。是名中道诸法实观。复次迦叶。我所说法十二因缘。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是因缘。但为集成是大苦聚。若无明灭则行灭。行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故如是老死忧悲众恼大苦皆灭。明与无明无二无别。如是知者。是名中道诸法实观。如是行及非行识及所识。名色可见及不可见。诸六入处及六神通。触及所触。受与受灭。爱与爱灭。取与取灭。有与有灭。生与生灭。老死与老死灭。是皆无二无别。如是知者。是名中道诸法实观。复次迦叶。真实观者。不以空故令诸法空。但法性自空。不以无相故令法无相。但法自无相。不以无愿令法无愿。但法自无愿。不以无起无生无我无取无性故。令法无起无取无性。但法自无起无取无性。如是观者是名实观。复次迦叶。非无人故名曰为空。但空自空。前际空。后际空。中际亦空。当依于空莫依于人。若以得空便依于空。是于佛法则为退堕。如是迦叶。宁起我见积若须弥。非以空见起增上慢。所以者何。一切诸见以空得脱。若起空见则不可除。迦叶。譬如医师授药令病扰动。是药在内而不出者。于意云何。如是病人宁得差不。不也世尊。是药不出其病转增。如是迦叶。一切诸见唯空能灭。若起空见则不可除。譬如有人怖畏虚空悲嗥椎胸。作如是言。我舍虚空。于意云何。是虚空者可舍离不。不也世尊。如是迦叶。若畏空法。我说是人狂乱失心。所以者何。常行空中而畏于空。譬如画师自手画作夜叉鬼像。见已怖畏迷闷躄地。一切凡夫亦复如是。自造色声香味触故。往来生死受诸苦恼而不自觉。譬如幻师作幻人已还自残食。行道比丘亦复如是。有所观法皆空皆寂无有坚固。是观亦空。迦叶。譬如两木相磨便有火生还烧是木。如是迦叶。真实观故生圣智慧。圣智生已还烧实观。譬如然灯一切黑闇皆自无有。无所从来去无所至。非东方来。去亦不至南西北方四维上下。不从彼来去亦不至。而此灯明无有是念。我能灭闇。但因灯明法自无闇。明闇俱空无作无取。如是迦叶。实智慧生无智便灭。智与无智二相俱空无作无取。迦叶。譬如千岁冥室未曾见明。若然灯时。于意云何。闇宁有念我久住此不欲去耶。不也世尊。若然灯时是闇无力。而不欲去必当磨灭。如是迦叶。百千万劫久习结业。以一实观即皆消灭。其灯明者圣智慧是。其黑闇者诸结业是。迦叶。譬如种在空中而能生长。从本已来无有是处。菩萨取证亦复如是。增长佛法终无是处。迦叶。譬如种在良田则能生长。如是迦叶。菩萨亦尔。有诸结使离世间法能长佛法。迦叶。譬如高原陆地不生莲花。菩萨亦复如是。于无为中不生佛法。迦叶。譬如卑湿淤泥中乃生莲花。菩萨亦尔。生死淤泥邪定众生能生佛法。迦叶。譬如有四大海满中生苏。菩萨有为善根甚多无量亦复如是。迦叶。譬如若破一毛以为百分。以一分毛取海一渧。一切声闻有为善根亦复如是。迦叶。譬如小芥子孔所有虚空。一切声闻有为智慧亦复如是。迦叶。譬如十方虚空无量无边。菩萨有为智慧甚多为力无量亦复如是。迦叶。譬如刹利大王有大夫人。与贫贱通怀妊生子。于意云何是王子不。不也世尊。如是迦叶。我声闻众亦复如是。虽为同证以法性生。不名如来真实佛子。迦叶。譬如刹利大王与使人通怀妊生子。虽出下姓得名王子。初发心菩萨亦复如是。虽未具足福德智慧。往来生死随其力势利益众生。是名如来真实佛子。迦叶。譬如转轮圣王而有千子。未有一人有圣王相。圣王于中不生子想。如来亦尔。虽有百千万亿声闻眷属围绕而无菩萨。如来于中不生子想。迦叶。譬如转轮圣王有大夫人。怀妊七日是子具有转轮王相。诸天尊重过余诸子具身力者。所以者何。是胎王子必绍尊位继圣王种。如是迦叶。初发心菩萨亦复如是。虽未具足诸菩萨根。如胎王子诸天神王深心尊重。过于八解大阿罗汉。所以者何。如是菩萨。名绍尊位不断佛种。迦叶。譬如一琉璃珠胜于水精。如须弥山。菩萨亦尔。从初发心便胜声闻辟支佛众。迦叶。譬如大王夫人生子之日。小王群臣皆来拜谒。菩萨亦尔。初发心时诸天世人皆当礼敬。迦叶。譬如雪山王中生诸药草。无有所属无所分别。随病所服皆能疗治。菩萨亦尔。所集智药无所分别。普为众生平等救护。迦叶。譬如月初生时。众人爱敬踰于满月。如是迦叶。信我语者。爱敬菩萨过于如来。所以者何。由诸菩萨生如来故。迦叶。譬如愚人舍月礼事星宿。智者不尔终不舍离。菩萨行者礼敬声闻。迦叶。譬如诸天及人。一切世间善治伪珠。不能令成琉璃宝珠。求声闻人亦复如是。一切持戒成就禅定。终不能得坐于道场成无上道。迦叶。譬如治琉璃珠。能出百千无量珍宝。如是教化成就菩萨。能出百千无量声闻辟支佛宝。尔时世尊复告大迦叶。菩萨常应求利众生。又正修习一切所有福德善根。等心施与一切众生。所得智药遍到十方。疗治众生皆令毕竟。云何名为毕竟智药。谓不净观治于贪淫。以慈心观治于嗔恚。以因缘观治于愚痴。以行空观治诸妄见。以无相观治诸忆想分别缘念。以无愿观治于一切出三界愿。以四颠倒治一切倒。以诸有为皆悉无常。治无常中计常颠倒。以有为苦治诸苦中计乐颠倒。以无我法治无我中计我颠倒。以涅槃寂治不净中计净颠倒。以四念处治诸依倚身受心法。行者观身顺身相观不堕我见。顺受相观不堕我见。顺心相观不堕我见。顺法相观不堕我见。是四念处能厌一切身受心法开涅槃门。以四正勤能断已生诸不善法。及不起未生诸不善法。未生善法悉能令生。已生善法能令增长。取要言之。能断一切诸不善法。成就一切诸善之法。以四如意足治身心重。坏身一相令得如意自在神通。以五根治无信懈怠失念乱心无慧众生。以五力障诸烦恼力。以七觉分治诸法中疑悔错谬。以八正道治堕邪道一切众生。迦叶。是为菩萨毕竟智药。菩萨常应勤修习行。又大迦叶。阎浮提内诸医师中。耆域医王最为第一。假令三千大千世界所有众生皆如耆域。若有人问心中结使烦恼邪见疑悔病药尚不能答。何况能治。菩萨于中应作是念。我终不以世药为足。我当求习出世智药。亦修一切善根福德。如是菩萨。得智药已遍到十方。毕竟疗治一切众生。何谓菩萨出世智药。谓知诸法从缘合生。信一切法无我无人。亦无众生寿命知见。无作无受。信解通达无我我所。于是空法无所得中不惊不畏。勤加精进而求心相。菩萨如是求心何等是心。若贪欲耶。若嗔恚耶。若愚痴耶。若过去未来现在耶。若心过去即是尽灭。若心未来未生未至。若心现在则无有住。是心非内非外亦非中间。是心无色。无形无对。无识无知。无住无处。如是心者。十方三世一切诸佛。不已见不今见不当见。若一切佛过去来今而所不见。云何当有。但以颠倒想故。心生诸法种种差别。是心如幻以忆想分别故。起种种业受种种身。又大迦叶。心去如风。不可捉故。心如流水。生灭不住故。心如灯焰。众缘有故。是心如电。念念灭故。心如虚空。客尘污故。心如猕猴。贪六欲故。心如画师。能起种种业因缘故。心不一定。随逐种种诸烦恼故。心如大王。一切诸法增上主故。心常独行无二无伴。无有二心能一时故。心如怨家。能与一切诸苦恼故。心如狂象。蹈诸土舍能坏一切诸善根故。心如吞钩。苦中生乐想故。是心如梦。于无我中生我想故。心如苍蝇。于不净中起净想故。心如恶贼。能与种种考掠苦故。心如恶鬼。求人便故。心常高下。贪恚所坏故。心如盗贼。劫一切善根故。心常贪色。如蛾投火。心常贪声。如军久行乐胜鼓音。心常贪香。如猪喜乐不净中卧。心常贪味。如小女人乐着美食。心常贪触。如蝇着油。如是迦叶。求是心相而不可得。若不可得则非过去未来现在。若非过去未来现在则出三世。若出三世非有非无。若非有非无即是不起。若不起者即是无性。若无性者即是无生。若无生者即是无灭。若无灭者则无所离。若无所离者则无来无去无退无生。若无来无去无退无生则无行业。若无行业则是无为。若无为者则是一切诸圣根本。是中无有持戒亦无破戒。若无持戒无破戒者。是则无行亦无非行。若无有行无非行者。是则无心无心数法。若无有心心数法者。则无有业亦无业报。若无有业无业报者则无苦乐。若无苦乐即是圣性。是中无业无起业者。无有身业亦无口业亦无意业。是中无有上中下差别。圣性平等如虚空故。是性无别一切诸法等一味故。是性远离。离身心相故。是性离一切法。随顺涅槃故。是性清净。远离一切烦恼垢故。是性无我。离我我所故。是性无高下。从平等生故。是性真谛。第一义谛故。是性无尽。毕竟不生故。是性常住。诸法常如故。是性安乐。涅槃为第一故。是性清净。离一切相故。是性无我。求我不可得故。是性真净。从本已来毕竟净故。又大迦叶。汝等当自观内莫外驰骋。如是大迦叶。当来比丘如犬逐块。云何比丘如犬逐块。譬如有人以块掷犬。犬即舍人而往逐之。如是迦叶。有沙门婆罗门。怖畏好色声香味触故。住空闲处独无等侣。离众愦闹身离五欲而心不舍。是人有时或念好色声香味触。贪心乐着而不观内。不知云何当得离色声香味触。以不知故有时来入城邑聚落在人众中。还为好色声香味触五欲所缚。以空闲处持俗戒故死得生天。又为天上五欲所缚。从天上没亦不得脱于四恶道地狱饿鬼畜生阿修罗道。是名比丘如犬逐块。又大迦叶。云何比丘不如犬逐块。若有比丘为人所骂而不报骂。打害嗔毁亦不报毁。但自内观求伏其心。作如是念。骂者为谁。受者为谁。打者害者。毁者嗔者。亦复为谁。是名比丘不如犬逐块。迦叶。譬如善调马师随马[怡-台+龍]悷即时能伏。行者亦尔。随心所向即时能摄不令放逸。迦叶。譬如咽塞病即能断命。如是迦叶。一切见中唯有我见。即时能断于智慧命。譬如有人随所缚处而求解脱。如是迦叶。随心所著应当求解。又大迦叶。出家之人有二不净心。何谓为二。一者读诵路伽耶等外道经书。二者多畜诸好衣钵。又出家人有二坚缚。何谓为二。一者见缚。二者利养缚。又出家人有二障法。何谓为二。一者亲近白衣。二者憎恶善人。又出家人有二种垢。何谓为二。一者忍受烦恼。二者贪诸檀越。又出家人有二雨雹坏诸善根。何谓为二。一者败逆正法。二者破戒受人信施。又出家人有二痈疮。何谓为二。一者求见他过。二者自覆其罪。又出家人有二烧法。何谓为二。一者垢心受着法衣。二者受他持戒善人供养。又出家人有二种病。何谓为二。一者怀增上慢而不伏心。二者坏他发大乘心。又大迦叶。谓沙门者。有四种沙门。何谓为四。一者形服沙门。二者威仪欺诳沙门。三者贪求名闻沙门。四者实行沙门。何谓形服沙门。有一沙门形服具足被僧伽梨。剃除须发执持应器。而便成就不净身业不净口业不净意业。不善护身悭嫉懈怠破戒为恶。是名形服沙门。何谓威仪欺诳沙门。有一沙门具足沙门身四威仪。行立坐卧一心安详。断诸美味修四圣种。远离众会。出家愦闹之众。言语柔软。行如是法皆为欺诳。不为善净而于空法有所见得。于无得法生恐畏心。如临深想。于空论比丘生怨贼想。是名威仪欺诳沙门。何谓名闻沙门。有一沙门以现因缘而行持戒。欲令人知自力读诵。欲令他人知为多闻。自力独处在于闲静。欲令人知为阿练若。少欲知足行远离行。但为人知不以厌离。不为善寂不为得道。不为沙门婆罗门果。不为涅槃。是为名闻沙门。复次迦叶。何谓实行沙门。有一沙门。不贪身命。何况利养。闻诸法空无相无愿。心达随顺如所说行。不为涅槃而修梵行。何况三界。尚不乐起空无我见。何况我见众生人见。离依止法而求解脱一切烦恼。见一切诸法本来无垢毕竟清净。而自依止亦不依他。以正法身尚不见佛。何况形色。以空远离尚不见法。何况贪着音声言说。以无为法尚不见僧。何况当见有和合众。而于诸法无所断除无所修行。不生生死不着涅槃。知一切法本来寂灭。不见有缚不求解脱。是名实行沙门。如是迦叶。汝等当习实行沙门法。莫为名字所坏。迦叶。譬如贫穷贱人假富贵名。于意云何。称此名不。不也世尊。如是迦叶。但名沙门婆罗门。而无沙门婆罗门实功德行。亦如贫人为名所坏。譬如有人漂没大水渴乏而死。如是迦叶。有诸沙门多读诵经。而不能止贪恚痴渴。法水漂没烦恼渴死堕诸恶道。譬如药师持药囊行而自身病不能疗治。多闻之人有烦恼病亦复如是。虽有多闻不止烦恼不能自利。譬如有人服王贵药。不能将适为药所害。多闻之人有烦恼病亦复如是。得好法药不能修善自害慧根。迦叶。譬如摩尼宝珠堕不净中不可复着。如是多闻贪着利养。便不复能利益天人。譬如死人着金璎珞。多闻破戒比丘。被服法衣受他供养亦复如是。如长者子剪除爪甲。净自洗浴涂赤栴檀。着新白衣头着华鬘中外相称。如是迦叶。多闻持戒被服法衣。受他供养亦复如是。又大迦叶。四种破戒比丘似善持戒。何谓为四。有一比丘具足持戒。大小罪中心常怖畏。所闻戒法皆能履行。身业清净口业清净。意业清净正命清净。而是比丘说有我论。是初破戒似善持戒。复次迦叶。有一比丘诵持戒律。随所说行身见不灭。是名第二破戒比丘似善持戒。复次迦叶。有一比丘具足持戒。取众生相而行慈心。闻一切法本来无生心大惊怖。是名第三破戒比丘似善持戒。复次迦叶。有一比丘具足修行。十二头陀见有所得。是名第四破戒比丘似善持戒。复次迦叶。善持戒者。无我无我所。无作无非作。无有所作。亦无作者。无行无非行。无色无名。无相无非相。无灭无非灭。无取无舍。无可取无可弃。无众生无众生名。无心无心名。无世间无非世间。无依止无非依止。不以戒自高不下他戒。亦不忆想分别此戒。是名诸圣所持戒行。无漏不系不受三界。远离一切诸依止法。尔时世尊。欲明了此义。而说偈言

  清净持戒者　　无垢无所有
  持戒无憍慢　　亦无所依止
  持戒无愚痴　　亦无有诸缚
  持戒无尘污　　亦无有违失
  持戒心善软　　毕竟常寂灭
  远离于一切　　忆想之分别
  解脱诸动念　　是净持佛戒
  不贪惜身命　　不用诸有生
  修习于正行　　安住正道中
  是名为佛法　　真实净持戒
  持戒不染世　　亦不依世法
  逮得智慧明　　无闇无所有
  无我无彼想　　已知见诸相
  是名为佛法　　真实净持戒
  无此无彼岸　　亦无有中间
  于无此彼中　　亦无有所著
  无缚无诸漏　　亦无有欺诳
  是名为佛法　　真实净持戒
  心不著名色　　不生我我所
  是名为安住　　真实净持戒
  虽行持诸戒　　其心不自高
  亦不以为上　　遇戒求圣道
  是名为真实　　清净持戒相
  不以戒为最　　亦不贵三昧
  过此二事已　　修习于智慧
  空寂无所有　　诸圣贤之性
  是清净持戒　　诸佛所称赞
  心解脱身见　　除灭我我所
  信解于诸佛　　所行空寂法
  如是持圣戒　　则为无有比
  依戒得三昧　　三昧能修慧
  依因所修慧　　逮得于净智
  已得净智者　　具足清净戒

说是语时。五百比丘不受诸法心得解脱。三万二千人远尘离垢得法眼净。五百比丘闻是深法心不信解。不能通达从坐起去。尔时大迦叶白佛言。世尊。是五百比丘皆得禅定。不能信解入深法故从坐起去。佛语迦叶。是诸比丘皆增上慢。闻是清净无漏戒相。不能信解不能通达。佛所说偈其义甚深。所以者何。诸佛菩提极甚深故。若不厚种善根。恶知识所守。信解力少难得信受。又大迦叶。是五百比丘。过去迦叶佛时。为外道弟子。到迦叶佛所欲求长短。闻佛说法得少信心。而自念言。是佛希有快善妙语。以是善心命终之后生忉利天。忉利天终生阎浮提。于我法中而得出家。是诸比丘深着诸见。闻说深法不能信解随顺通达。是诸比丘虽不通达。以闻深法因缘力故。得大利益不生恶道。当于现身得入涅槃。尔时佛语须菩提言。汝往将是诸比丘来。须菩提言。世尊。是人尚不能信佛语。况须菩提耶。佛即化作二比丘。随五百比丘所向道中。诸比丘见已。问化比丘。汝欲那去。答言。我等欲去独处修禅定乐。所以者何。佛所说法不能信解。诸比丘言。长老。我等闻佛说法亦不信解欲至独处修禅定行。时化比丘语诸比丘言。我等当离自高逆诤心。应求信解佛所说义。所以者何。无高无诤是沙门法。所说涅槃名为灭者为何所灭。是身之中有我灭耶。有人有作有受有命而可灭耶。诸比丘言。是身之中。无我无人。无作无受。无命而可灭者。但以贪欲嗔痴灭故名为涅槃。化比丘言。汝等贪欲嗔痴。为是定相可灭尽耶。诸比丘言。贪欲嗔痴。不在于内。亦不在外。不在中间。离诸忆想是则不生。化比丘言。是故汝等莫作忆想若使汝等不起忆想分别法者。即于诸法无染无离。无染无离者。是名寂灭。所有戒品。亦不往来亦不灭尽。定品慧品解脱品解脱知见品。亦不往来亦不灭尽。以是法故说为涅槃。是法皆空远离亦不可取。汝等舍离是涅槃想。莫随于想。莫随非想。莫以想舍想。莫以想观想。若以想舍想者。则为想所缚。汝等不应分别一切受想灭定。一切诸法无分别故。若有比丘灭诸受想得灭定者。则为满足更无有上。化比丘说是语时。五百比丘不受诸法心得解脱。来诣佛所头面礼足在一面立。尔时须菩提问诸比丘言。汝等去至何所今何从来。诸比丘言。佛所说法。无所从来去无所至。又问谁为汝师。答言。我师先来不生亦无有灭。又问。汝等从何闻法。答言。无有五阴十二入十八界从是闻法。又问。云何闻法。答言。不为缚故。不为解脱故。又问。汝等习行何法。答言。不为得故。不为断故。又问。谁调伏汝。答言。身无定相心无所行是调伏我。又问。何行心得解脱。答言。不断无明不生明故。又问。汝等为谁弟子。答言。无得无知者是彼弟子。又问。汝等已得几何当入涅槃。答言。犹如如来所化入涅槃者。我等当入。又问。汝等已得己利耶。答言。自利不可得故。又问。汝等所作已办耶。答言。所作不可得故。又问。汝等修梵行耶。答言。于三界不行亦非不行。是我梵行。又问。汝等烦恼尽耶。答言。一切诸法毕竟无尽相故。又问。汝等破魔耶。答言。阴魔不可得故。又问。汝等奉如来耶。答言。不以身心故。又问。汝等住福田耶。答言。无有住故。又问汝等断于生死往来耶。答言。无常无断故。又问。汝等随法行耶。答言。无碍解脱故。又问。汝等究竟当生何所。答言。随于如来化人所至。须菩提问诸比丘。时有五百比丘不受诸法心得解脱。三万二千人远尘离垢得法眼净。尔时会中有普明菩萨。白佛言。世尊。菩萨欲学是宝积经者。当云何住。当云何学。佛言。菩萨学是经所说皆无定相。而不可取亦不可着。随是行者有大利益。普明。譬如有乘杯船欲渡恒河。以何精进乘此船渡。答言世尊。以大精进乃可得渡。所以者何。恐中坏故。佛告普明。菩萨亦尔。欲修佛法当勤精进倍复过是。所以者何。是身无常无有决定坏败之相。不得久住终归磨灭。未得法利恐中坏故。我在大流为度众生断于四流故。当习法船乘此法船。往来生死度脱众生。云何菩萨所习法船。谓平等心一切众生为船因缘。习无量福以为牢厚清净戒板。行施及果以为庄严。净心佛道为诸材木。一切福德以为具足。坚固系缚忍辱柔软忆念为钉。诸菩提分坚强精进。最上妙善法林中出。不可思议无量禅定福德业成。善寂调心以为师匠。毕竟不坏大悲所摄。以四摄法广度致远。以智慧力防诸怨贼。善方便力种种合集。四大梵行以为端严。四正念处为金楼观。四正勤行四如意足以为疾风。五根善察离诸曲恶。五力强浮七觉觉悟能破魔贼。入八真正道随意到岸离外道济。止为调御观为利益不着二边。有因缘法以为安隐。大乘广博无尽辩才。广布名闻能济十方一切众生。而自唱言来上法船。从安隐道至于涅槃。度身见岸至佛道岸离一切见。如是普明。菩萨摩诃萨。应当修习如是法船。以是法船无量百千万亿阿僧祇劫。在生死中度脱漂没长流众生。又告普明。复有法行能令菩萨疾得成佛。谓诸所行真实不虚。厚习善法深心清净。不舍精进乐欲近明。修习一切诸善根故。常正忆念乐善法故。多闻无厌具足慧故。破坏憍慢增益智故。除灭戏论具福德故。乐住独处身心离故。不处愦闹离恶人故。深求于法依第一义故。求于智慧通达实相故。求于真谛得不坏法故。求于空法所行正故。求于远离得寂灭故。如是普明。是为菩萨疾成佛道。说是经时。普明菩萨。大迦叶等诸天阿修罗及世间人。皆大欢喜顶戴奉行

大宝积经卷第一百一十二大宝积经卷第一百一十三

        北梁沙门释道龚译

    宝梁聚会第四十四

    沙门品第一

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众八千人俱。菩萨摩诃萨万六千人。皆不退转于阿耨多罗三藐三菩提。尽是一生补处。悉从十方诸佛世界而来集会。尔时摩诃迦叶白佛言。世尊。所言沙门云何为沙门。佛告迦叶。所谓沙门者。寂灭故。调伏故。受教故。戒身净故。入禅定故。得智慧故。解如实义得解脱故。于三脱门无所疑故。安住圣人所行法故。善修四念处故。离一切不善法故。安住四正勤故。善修四如意足故。成就信根故。信佛法僧故。成就坚信于佛法僧故。不信余道法故。勤行离一切烦恼故。善修七菩提分离一切不善。如实修一切善法故。善知正念正智方便故。专念一切诸善法故。善知定慧方便故。成就五力故。不为一切烦恼之所乱故。善修七菩提分故。善知一切法中因缘方便故。善知圣道方便故。善知正见正定方便故。得四辩力不信外道故。依义不依语。依智不依识。依了义经不依不了义经。依法不依人故。离四魔故。善知五阴故。断一切烦恼故。得最后身故。离生死道故。离一切爱故。勤行知苦断集证灭修道故。善见四圣谛故。于佛法中不信余道故。所作已办故。断一切漏故。修八背舍故。释梵天王之所赞故。从本已来专心行道故。乐阿兰若处故。安住圣法中故。乐佛法仪式故。心不倾动故。不亲近出家在家众故。心乐独行如犀角故。畏于人众多恼乱故。乐住独处故。常怖畏三界故。得实沙门果故。离一切悕望故。离世八法故。所谓利衰毁誉称讥苦乐。坚心不动如地故。护彼我意无所犯故。不浊故。正行故。心行成就如虚空故。于诸形相心无染着。如虚空中动手无所碍故。迦叶。若能成就如是行法。是名沙门。尔时摩诃迦叶白佛言。世尊。未曾有也。如来善说沙门德行。世尊。若未来世有诸沙门。非实沙门自言我是沙门。非梵行人自言我有梵行。如是之人。即已侵损如来无量阿僧祇劫所修集阿耨多罗三藐三菩提。佛告迦叶。如是侵损如来菩提之罪。说不可尽。迦叶。我灭度后。汝及余大弟子等亦皆灭度。又此世界诸大菩萨。皆至他方诸佛世界。尔时于我法中。当有比丘。于诸所行心多谄曲。迦叶。我今当说沙门之垢沙门过罪。迦叶后末法中。当有比丘。不修身。不修戒。不修心。不修慧。痴如小儿向于闇冥而无所知。心不调伏成沙门垢。迦叶。云何沙门垢。迦叶。沙门垢有三十二出家之人所应远离。何等三十二。欲觉是沙门垢。嗔觉是沙门垢。恼觉是沙门垢。自赞是沙门垢。毁他是沙门垢。邪求利养是沙门垢。因利求利是沙门垢。损他施福是沙门垢。覆藏罪过是沙门垢。亲近在家人是沙门垢。亲近出家人是沙门垢。乐于众闹是沙门垢。未得利养作方便求是沙门垢。于他利养心生悕望是沙门垢。自于利养心不知足是沙门垢。于他利养中心生嫉妒是沙门垢。常求他过是沙门垢。不见己过是沙门垢。于解脱戒而不坚持是沙门垢。不知惭愧是沙门垢。无恭恪意心慢掉动无有羞耻是沙门垢。起诸结使是沙门垢。逆十二因缘是沙门垢。摄取边见是沙门垢。不寂灭不离欲是沙门垢。乐于生死不乐涅槃是沙门垢。好乐外典是沙门垢。五盖覆心起诸烦恼是沙门垢。不信业报是沙门垢。畏三脱门是沙门垢。谤深妙法不寂灭行是沙门垢。于三宝中心不尊敬是沙门垢。迦叶。是名沙门三十二垢若能离此诸垢是名沙门。迦叶。又有八法覆沙门行。何等八。一者不敬顺师长。二不尊敬法。三不善思惟。四所未闻法闻已诽谤。五闻无众生无我无命无人法已心生惊畏。六闻一切行本来无生已。而解有为法不解无为法。七闻说次第法已堕大深处。八闻一切法无生无性无出已而心迷没。迦叶。是名八法覆于沙门行。如是八法。出家沙门应当远离。迦叶。我不说剃头法服名为沙门。所谓有功德仪式具足者。乃名为沙门。迦叶。沙门身服袈裟。心应远离贪恚痴行。何以故。心无贪恚痴行。我乃听着袈裟。迦叶。若心有贪恚痴法。而身着袈裟。除专心持戒。余不持戒人。则为烧灭袈裟何以故。圣人表式随顺寂灭行慈悲心。离欲灭者之所应服。迦叶。汝今听我说。圣人表式有十二事。何等十二。迦叶。持戒是圣人表式。禅定是圣人表式。智慧是圣人表式。解脱是圣人表式。解脱知见是圣人表式。入四圣谛是圣人表式。能解十二因缘是圣人表式。行四无量心是圣人表式。行于四禅是圣人表式。行四无色定是圣人表式。入四向正定是圣人表式。断一切漏是圣人表式。迦叶。是名圣人十二表式迦叶。若有比丘不具足圣人十二表式身服袈裟者。我说此比丘是邪法行非寂灭行。离佛法行不近涅槃。顺生死行为魔所钩。不度生死于正法退而行邪法。迦叶。是故出家比丘身服袈裟时。若未得沙门果者。应以八法敬重袈裟。何等八。于身袈裟。应起塔想。世尊想。寂灭想。慈想。敬如佛想。惭想。愧想。令我来世离贪恚痴具沙门法想。迦叶。是名八法敬重袈裟。迦叶。若有于四圣种不行知足离沙门法。亦不以此八法敬重袈裟者。而彼别有似沙门数堕小地狱。迦叶。彼地狱中似沙门者于中受罪。衣钵支体皆悉炽然。坐卧之处凡有所用物。亦皆炽然如大火聚。似沙门者受如是罪。何以故。成就不净身口意业故堕是罪处。迦叶。若非沙门自言我是沙门非梵行者自言我有梵行。若有持戒功德具足人所。右绕恭敬尊重者。若破戒比丘。受其礼敬供养而不自知恶。彼恶比丘以是不善根故得八轻法。何等八。一作愚痴。二口喑哑。三受身矬陋。四颜貌丑恶。其面侧戾见者蚩笑。五转受女人身作贫穷婢使。六其形羸瘦夭损寿命。七人所不敬常有恶名。八不值佛世。迦叶。是破戒比丘。受持戒者礼敬供养。得如是八种法。迦叶。破戒比丘闻如是法已。应当不受持戒比丘礼敬供养。迦叶。若有非沙门自言我是沙门。非梵行自言我有梵行。于此大地乃至无有涕唾分处况举足下足去来屈伸。何以故。过去大王持此大地。施与持戒有行德者。令于中行道。迦叶是破戒比丘。举足下足处。一切信施不及此人。况僧坊及招提僧舍经行之处。若有房舍床敷园林。所有衣钵卧具医药。一切信施所不应受。迦叶。我今当说。若有非沙门自言我是沙门。非梵行自言我有梵行。不能必报信施如一毛端。何以故。圣众福田犹如大海最妙最胜。于中若有施主。净心信故。以施种子种福田中。如此施主起无量施想。迦叶。若有破戒比丘。如分一毛以为百分。若恶比丘受信施如一毛分。随所受毛分即损失施主。尔所大海福报之分不能毕报。迦叶。是故应净其心受他信施。迦叶。应如是学。尔时众中。有净行少欲离扼比丘二百人。闻说是已扪泪而白。世尊。我今当死。不欲以不得沙门果。受他信施乃至一食。佛言。善哉善哉。善男子。汝如是惭愧畏于后世。喻如金刚即是现世璎珞。善男子。我今当说。世有二人应受信施。何等二。一者勤行精进。二者得解脱者。佛告比丘。若有比丘得解脱者。行善法者。如我所说坚持戒者。观一切行无常苦一切法无我者。观涅槃寂灭愿求欲得。如是比丘。受他信施抟如须弥。必能报是信施之福。若有比丘受信施主施。令此施主得大利益得大果报。何以故。常生福德。有三种福。一常施食。二僧坊舍。三行慈心。此三福中慈心最胜。佛告比丘。若有比丘从施主受施。若衣钵卧具饮食汤药受已。若入无量定。令彼施主得无量福得无量报。迦叶。譬如三千大千世界。所有大海尚可竭尽。而此施主所得福报不可得尽。迦叶当知。破戒比丘损于施主尔所福德。若受施主施已。行于恶法损他信施。迦叶如是说沙门垢。沙门过罪。沙门谄曲。沙门中贼。迦叶。持戒比丘应当专念。远离如是一切恶法。迦叶。所谓沙门者。眼不流色中。耳鼻舌身意不流法中。是故谓之沙门。选择六入。了达六通。专念六念。安住六敬法。行六重法。是谓沙门

    比丘品第二

尔时佛告迦叶。所言比丘。比丘者能破烦恼故名比丘。破我想众生想人想男想女想。是谓比丘。复次迦叶。有修戒修慧是名比丘。复次迦叶。离恐畏故。度三有四流故。见有及流诸过患故。离一切有及流故。安处无畏道故。是名比丘。迦叶。若有比丘自知不成就。如是之法及余善法。又离是法行于余道。迦叶。彼比丘。非我弟子。我非彼师。迦叶。多有恶比丘坏我佛法。迦叶。非九十五种外道能坏我法。亦非诸余外道能坏我法。除我法中所有痴人。此痴人辈能坏我法。迦叶。譬如师子兽中之王若其死已。虎狼鸟兽无有能得食其肉者。迦叶。师子身中自生诸虫还食其肉。迦叶。于我法中出如是等诸恶比丘。贪惜利养为贪利所覆。不灭恶法。不修善法。不离妄语。迦叶。如是比丘能坏我法。迦叶。有四法成就。当知是恶比丘。何等四。贪恚痴及我慢者。是名恶比丘。复有四法成就。当知是恶比丘。何等四。傲慢自大。无惭无愧。不慎口过。是名恶比丘。复有四法成就。当知是恶比丘。何等四。掉动轻他。贪求利养。多行非法。是名恶比丘。复有四法成就。当知是恶比丘。何等四。多有奸伪。幻惑于人。多行邪命。多说恶言。是名恶比丘。复有四法成就。当知是恶比丘。何等四。现受他恩不知报之。小恩于他责望大报。先受他恩而不忆念。侵损亲友。是名恶比丘。复有四法成就。当知是恶比丘。何等四。受人信施失他福报。不善护戒。轻所受戒。不坚持律。是名恶比丘。复有四法成就。当知是恶比丘。何等四。有我论。有众生论。有命论。有人论。是名恶比丘。复有四法成就。当知是恶比丘。何等四。不敬佛。不敬法。不敬僧。不敬戒。是名恶比丘。复有四法成就。当知是恶比丘。何等四。若僧和合而心不悦。不乐独处。乐于众中。常论世俗所有言说。是名恶比丘。复有四法成就。当知是恶比丘。何等四。求于利养。求大名称。求多知识。不住圣种。是名恶比丘。复有四法成就。当知是恶比丘。何等四。系属于魔。为魔所害。多于睡眠。作善不喜。是名恶比丘。复有四法成就。当知是恶比丘。何等四。于佛法中朽败。心怀谀谄。为烦恼所害。离沙门果。是名恶比丘。复有四法成就。当知是恶比丘。何等四。为淫欲所烧。嗔恚所烧。愚痴所烧。亦为一切烦恼所烧。是名恶比丘。复有四法成就。当知是恶比丘。何等四。多游淫里不知过恶。不知知足。虽多学问不知知足。于所须物常怀嫉心不能施他。是名恶比丘。复有四法成就。当知是恶比丘。何等四。从闇入闇从痴入痴。不见圣谛多生疑惑。常为生死之所系缚。闭涅槃门。是名恶比丘。复有四法成就。当知是恶比丘。何等四。身多奸行。口多奸行。意多奸行。仪式多奸行。云何身多奸行。安详而行是身奸行。不左右视是身奸行。若左右视不过一寻。是身奸行。邪命着衣是身奸行。谀谄行于空闲之处。不求空闲所行之法。谀谄乞食不观乞食相。谀谄着粪扫衣。不知为惭愧故。谀谄行于山窟树下。不知分别十二缘行。谀谄服于陈故弃药。不求甘露法药。迦叶。是名身多奸行。迦叶。云何口多奸行。他识我他请我。如所求我已得。我不求利养。而他送与我细妙供养我皆得。多利养我亦得。我常行善法应受供养。我善问答。我能顺法相。我能逆法相。我于一切法解义非义。他若如是问我。我能如是答。答已伏彼令其默然。我说是已能令大众一切喜悦。亦令一切叹言善哉。令彼众人请我供养。得供养已复令施主请言数来。迦叶。若有不调伏口而有所说。一切所言皆非正言。是口多奸行。迦叶。是名口多奸行。迦叶。云何意多奸行。心所牵连贪求利养。衣钵卧具饮食医药。而口说言。一切利养我所不须。心实多求而诈言知足。是名意多奸行。尔时世尊。而说偈言

  心求利养　　口言知足　　邪命求利
  常无快乐　　其心多奸　　欺诳一切
  如此之心　　都不清净　　诸天龙神
  有天眼者　　诸佛世尊　　咸共知见

迦叶。如是恶比丘。离善法仪式。作邪命行。堕三恶道

    旃陀罗品第三

佛告迦叶。云何旃陀罗沙门。迦叶。譬如旃陀罗。常于冢间行求死尸。无慈悲心视于众生。得见死尸心大喜悦。迦叶。如是沙门旃陀罗常无慈心。至施主家行不善心。所求得已生贵重心。从施主家受利养已。不教施主佛法毗尼。为利养故亲近在家。不为法故亦无慈心常求利养。迦叶。是名沙门旃陀罗。迦叶。如旃陀罗为一切人之所舍离。所谓大臣长者及诸小王。刹利婆罗门并余庶民。乃至下贱之所远离。不欲共作知识。迦叶。如是沙门旃陀罗。亦为一切之所远离。所谓持戒有德人所敬者。比丘比丘尼。优婆塞优婆夷。天龙鬼神及乾闼婆。知其破戒行恶法故。迦叶。是名沙门旃陀罗。迦叶。如旃陀罗所有衣服饮食诸所用物。尽非好人之所爱乐亦不受用。迦叶。如是沙门旃陀罗。若有衣钵所用之物。皆是破戒非法。身口意业谀谄所得。持戒沙门婆罗门。舍不爱乐亦不受用。于此人所生哀愍心。迦叶。是名沙门旃陀罗。迦叶。如旃陀罗以愧耻心持所用器从他乞食。迦叶。如是沙门旃陀罗。以愧耻心入于房舍。及至他家。或到众中。亦以愧心至于佛所。亦以愧心礼如来塔。亦以愧心去来屈伸。亦以愧心行住坐卧。一切所行皆有愧心。覆藏恶法故。迦叶。我今当说。旃陀罗人所至之处不到善处。何以故。自行恶法故。迦叶。如是沙门旃陀罗所至之处。亦不到善道多作恶业。无遮恶道法故。迦叶。是名沙门旃陀罗。迦叶。云何沙门败坏。迦叶。譬如好酒香味具者是酒之醍醐。接取已尽下有糟滓。人所恶贱无所施用。迦叶。如是败坏沙门。离于法味取烦恼滓。人所恶贱无所施用。离持戒香嗅诸烦恼。若有至处不能自利亦不益他。迦叶。是名败坏沙门。迦叶。败坏者如有所食变为粪秽。臭恶不净人所厌离。迦叶。如是败坏沙门犹如粪秽。以身口意业不清净故。迦叶。是名败坏沙门。迦叶。譬如败种种大地中终不生牙实。迦叶。如是败坏沙门。虽在佛法不生善根。不得沙门果。迦叶。是名败坏沙门。迦叶。云何沙门箧。迦叶。譬如画箧巧工所成中盛嗅秽种种不净。迦叶。如是沙门箧。外现成就似沙门行。内有种种垢秽行诸恶业。迦叶。是名沙门箧。迦叶。云何沙门构栏荼。迦叶。譬如构栏荼华色貌鲜好。其体坚鞕犹如木石。其气嗅秽犹如粪涂。有智之人若见此华。不近不触远避而去。愚人若见不知过患近而嗅之。迦叶。如是沙门构栏荼。现似沙门行而有粗犷。傲慢自高臭秽不净。又作破戒无仪式行破于正见。迦叶。如是沙门构栏荼。智者不亲近不礼敬右绕。以恶人故而远离之。迦叶。若有痴如小儿。彼诸痴人之所亲近。礼敬右绕信受其语。如构栏荼华为痴人所捉。迦叶。是名沙门构栏荼。迦叶。云何沙门求利。迦叶。譬如谀谄之人。心常悭惜为贪所覆。若见他财物悕望欲得。畜利刀杖无惭愧心。无哀愍心常有害心。若行空泽山林聚落发如是心。于他财物希求欲得。常自藏身不令他见。迦叶。如是沙门求利。心常悭惜为贪所覆。于所得利心无知足。于他财物悕望欲得。有所至处聚落城邑。常为利养不为善法覆藏诸恶。谓善比丘知我破戒。知已若说戒时或驱我出。于善比丘但生恐畏。心常谀谄现行仪式。一切天龙鬼神有天眼者。知此比丘。来时贼来。去时贼去。行时贼行。坐时贼坐。卧时贼卧。取衣时贼取衣。着衣时贼着衣。入聚落时贼入聚落。出聚落时贼出聚落。食时贼食。饮时贼饮。剃发时贼剃发。迦叶。如是痴人去来仪式。皆为天龙鬼神之所知见。见已诃骂。如此恶人即为坏灭释迦牟尼佛法。作是诃责诸恶比丘。又彼诸天龙鬼神。见持戒梵行沙门婆罗门。增益信心礼敬尊重。此人于佛法中应受利养者。迦叶。此沙门求利。于佛法中出家。不能生一念寂灭离欲之心。况得沙门果。若有得者无有是处。迦叶。是名沙门求利。迦叶。云何稗沙门。迦叶。譬如麦田中生稗麦。其形似麦不可分别。尔时田夫作如是念。谓此稗麦尽是好麦。后见穟生尔乃知非。不得名言一切是麦。迦叶。如是稗沙门在于众中。似是持戒有德行者。施主见时谓尽是沙门。而彼痴人实非沙门言是沙门。非梵行人自言梵行。先来败坏离于持戒。亦不入众数。于佛法中无智慧命当堕恶道。犹如稗麦在好麦中。尔时天龙鬼神有天眼者。见彼痴人堕于地狱。见已各相谓言。此是痴人先似沙门行不善法。今当堕于大地狱中。从今已后终不能得沙门德行及沙门果。犹如稗麦在好麦中。迦叶。是名稗沙门。迦叶。云何逋生沙门。迦叶。譬如逋生稻苗。以不熟故名为逋生。以无实故风所吹去。无坚重力似稻非稻。迦叶。如是逋生沙门。形似沙门无人教呵。无有德力为魔风所吹。亦无血气持戒之力。离于多闻损失定力亦远于智。不能破坏诸烦恼贼。名如是人轻劣无力。系属于魔为魔所钩。没在一切烦恼之中。为魔风所吹如逋生稻。迦叶。逋生之稻不中为种亦不生牙。迦叶。如是逋生沙门。于佛法中无道种子。于贤圣法中不得解脱。迦叶。逋生沙门者。所谓破戒行恶。是名逋生沙门。迦叶。云何似沙门。迦叶。譬如巧工以金涂铜。其色似金价不同金。若揩磨时乃知非金。迦叶。如是似沙门者好自严饰。常澡浴身齐整着衣。沙门仪式一切具足。去来屈伸常正仪式。而彼常为贪恚痴所害。亦为利养礼敬赞叹所害。亦为我慢增上慢一切烦恼所害。虽为人所贵无贵重法。常勤严身悕望饮食。不求圣法不畏后世。现见尊重非将来尊重。但长肌肥依于利养非依于法。种种系缚勤作家业。顺在家心。亦随受。苦时受苦。乐时受乐。为爱憎所害。于沙门法无心欲行离诸仪式。必当堕于地狱饿鬼畜生。彼人无沙门实。无沙门称。不与沙门等。迦叶。是名似沙门。迦叶。云何失沙门血气。迦叶。譬如男子若女人。若童男若童女。非人饮其血气。彼人羸瘦无有色力。由失血气故。迦叶。如是之人失血气故。诸药咒术及诸刀杖。所不能治必至于死。迦叶。如是沙门无有持戒定慧解脱解脱知见血气。及慈悲喜舍血气。亦无行施调伏护身口意业血气。亦无安住四圣种血气。无有仪式血气。亦无净身口意血气。迦叶。是名沙门失于血气。迦叶。如失血气沙门。虽受如来法药不以自度。法药者。所谓若起淫欲应观不净。若起嗔恚应行慈心。若起愚痴应观十二因缘。于诸烦恼应正思惟。离于乐众舍我所有。出家三事应当爱护。三事者。所谓持戒清净。其心调伏。入定不乱。迦叶。如是法药我之所说我所听服。虽受此药不以自度。迦叶。又有出世法。所谓空观无相无作观。阴界入知。四圣谛及十二因缘。迦叶。如是法药。彼人亦复不以自度。迦叶。如是沙门臭秽不净。以破戒故。薄福德故。生极下处以憍慢故。于此命终不生余处。必当堕在大地狱中。如人失于血气必定至死。如是沙门于此命终必堕地狱。迦叶。是名失血气沙门。如是说已。五百比丘舍戒还俗。尔时有诸比丘。呵彼比丘言。若大德于佛法中退还家者。如是非善。如是非法。佛告诸比丘。莫作是语。何以故。若如是者名为顺法。若比丘不欲受人信施退还家者。是名顺法。彼诸比丘信解心多故生悔心。说此语时。彼得闻已作如是念。我等或能行不净行受他信施。应生悔心退而还家。迦叶。我今说此诸比丘等。于此命终生兜率天弥勒菩萨所。弥勒如来出于世时。彼诸比丘在初会数中

    营事比丘品第四

尔时摩诃迦叶白佛言。世尊。云何比丘能营众事。佛告迦叶。我听二种比丘得营众事。何等二。一者能净持戒。二者畏于后世喻如金刚。复有二种。何等二。一者识知业报。二者有诸惭愧及以悔心。复有二种。何等二。一者阿罗汉。二者能修八背舍者。迦叶。如是二种比丘。我听营事自无疮疣。何以故。迦叶。护他人意此事难故。迦叶。于佛法中种种出家。种种性。种种心。种种解脱。种种断结。或有阿兰若。或有乞食。或有乐住山林。或有乐近聚落清净持戒。或有能离四扼。或有勤修多闻。或有辩说诸法。或有善持戒律。或有善持毗尼仪式或有游诸城邑聚落为人说法。有如是等诸比丘僧。营事比丘善取如是诸人心相迦叶。若阿兰若比丘乐空闲处。营事比丘一切役使不应令作。有时阿兰若比丘。在比丘僧次役使。而营事比丘应当代作。若自不作应倩他人令代为之。不应役使阿兰若比丘。若非行道时可少令作。迦叶。若有乞食比丘。彼营事比丘。于乞食比丘应与好食。若有比丘能离四扼。营事比丘随所须物应当供给。所谓衣服饮食卧具医药。若离扼比丘所住之处。营事比丘于其住处。不应高声大唤。亦不令他高声大唤。欲防护离扼比丘故。营事比丘于离扼比丘。应生尊敬如世尊想。生如是念。如是比丘于佛法中能作法柱。当随所须而供给之。迦叶。若有勤修多闻比丘。营事比丘应当劝喻。作如是言。大德勤修多闻读诵令利。我当为诸大德供给使令。若诸大德勤修多闻。于比丘僧中是好璎珞。能升高座广说正法。亦自生智慧。营事比丘不应非时役使。应当拥护令修多闻。迦叶。若有说法比丘。营事比丘应事事供给。应将说法比丘至城邑聚落。劝喻诸人令就听法。说法之处亦应供给。为说法人敷好高座。若有比丘强自以力欲坏说法者。营事比丘应往和解。亦应数往说法人所称言善哉。迦叶。若有比丘善持戒律善持毗尼义。营事比丘应往其所数数问义。我云何营事令不得罪。自无所损不害于他。持毗尼义比丘。应观营事者心。随所营事而为说法。所谓是应作。是不应作。营事比丘于持律人所。一心生信礼敬供养。若比丘僧所有分物。应当随时供给于僧。不应藏举随僧所须。应当分与应与时与。不恶心与。不以非法与。非欲心与。非嗔心与。非痴心与。非畏心与。随僧法行。非随在家行。随僧制行。非自随制行。不于僧物生自在想。乃至小事与僧共断。非自在断。若所用物。所谓常住僧物。及与佛物。若招提僧物。彼营事比丘应当分别。常住僧物不应与招提僧。招提僧物不应与常住僧。常住僧物不应与招提僧物共杂。招提僧物不与常住僧物共杂。常住僧物。招提僧物。不与佛物共杂。佛物不与常住僧物招提僧物共杂。若常住僧物多。而招提僧有所须者。营事比丘应集僧行筹索欲。若僧和合应以常住僧物分与招提僧。迦叶。若如来塔或有所须。若欲败坏者。若常住僧物。若招提僧物多。营事比丘应集僧行筹索欲。作如是言。是佛塔坏今有所须。此常住僧物招提僧物多。大德僧听。若僧时到僧忍听。若僧不惜所得施物。若常住僧物。若招提僧物。我今持用修治佛塔。若僧和合。营事比丘应以僧物修治佛塔。若僧不和合。营事比丘应余劝化在家人辈。求索财物修治佛塔。迦叶。若佛物多者。营事比丘不得以佛物分与常住僧及招提僧。何以故。于此物中应生世尊想。佛所有物乃至一线。皆是施主信心施佛。是故诸天世人于此物中生佛塔想而况宝物。若于佛塔先以衣施。此衣于佛塔中。宁令风吹雨烂破尽。不应以此衣贸易宝物。何以故。如来塔物无人能与作价者。又佛无所须故。迦叶。有如是善净营事人者。三宝之物不应令杂。又于自利养心常知足。三宝物中不生我所有想。迦叶。营事比丘若生嗔心。而于持戒大德人所右绕礼敬之者。以自在故驱令役使。是故营事比丘。以嗔心缘故堕大地狱。若得为人作他奴仆。常为其主苦驱役使人所鞭打。复次迦叶。若营事比丘。以自在故更作重制。过僧常限讁罚比丘非时令作。是营事比丘。以此不善根故堕于多钉小地狱中。生此中已以百千钉钉挓其身。其身炽然出大火焰如大火聚。若于持戒有大德者。以重事怖之以嗔心语故。彼营事比丘生地狱中。其所得舌长五百由旬。以百千钉而钉其舌。一一钉中出大火焰。迦叶。若营事比丘。数得僧物悭惜藏举。或非时与僧。或复难与。或困苦与。或少与或不与。或有与者。或不与者。营事比丘以此不善根故。堕秽恶饿鬼常食粪丸。此人命终当生是中。尔时更有饿鬼。以食示之而复不与。此鬼尔时悕望欲得。谛视此食目不曾眴。受饥渴苦。于百千岁中常不得食。或时得食变为粪屎。或作脓血。何以故。有持戒人人所敬礼。僧所有物以自在故而难与之。迦叶。若营事比丘以常住僧物。若招提僧物。及以佛物。辄自杂用得大苦报。若受一劫若过一劫。何以故。以侵三宝物故。迦叶。若营事比丘闻如是罪。知如是罪。而故生嗔心于持戒者。我今说此。诸佛世尊所不能治。迦叶。是故营事比丘。闻如是非法罪已。应当善护身口意业。自护亦护他。迦叶。营事比丘宁自啖身肉。终不杂用三宝之物作衣钵饮食。尔时摩诃迦叶白佛言。世尊。未曾有也。如来自以慈心说如是法。为无惭愧者说无惭愧法。有惭愧者说惭愧法

大宝积经卷第一百一十三大宝积经卷第一百一十四

        北凉沙门释道龚译

    宝梁聚会第四十四阿兰若比丘品第五

尔时摩诃迦叶白佛言。世尊。若有比丘自言阿兰若比丘。世尊。齐几所名阿兰若比丘。齐几所名乞食比丘。齐几所名畜粪扫衣比丘。齐几所名树下比丘。齐几所名冢间比丘。齐几所名露处比丘。佛告迦叶。阿兰若比丘。必乐阿兰若处。住阿兰若处。迦叶。若阿兰若处。所谓无大声。无众闹声。离獐鹿虎狼及诸飞鸟。远诸贼盗及牧牛羊者。顺沙门行处如是阿兰若处。应于中修行。彼比丘若欲至阿兰若处。应当思惟八法。何等八。一者我当舍身。二者应当舍命。三者当舍利养。四者离于一切所爱乐处。五者于山间死当如鹿死。六者阿兰若处当受阿兰若行。七者当以法自活。八者非以烦恼自活。迦叶。是名八法。阿兰若比丘所应思惟。思惟已当至阿兰若处。迦叶。阿兰若比丘至阿兰若处已。行阿兰若法。以八行行慈。于一切众生生慈心。何等八。一者以慈利益。二者以慈乐。三者无恚慈。四者正慈。五者无异慈。六者顺慈。七者观一切法慈。八者净如虚空慈。迦叶。以如是八行于诸众生生慈心。迦叶。阿兰若比丘至阿兰若处已。应如是思惟。我虽至远处独无伴侣。若我行善若行不善无人教呵。复作是念。此有诸天龙鬼神诸佛世尊。知我专心彼为我证。我今在此行阿兰若法。我不善心不得自在。若我至此极远之处。独无伴侣无亲近者无我所有。我今当觉欲觉恚觉恼觉余不善法。亦应当觉。我今不应不异于乐众者。亦不应不异近聚落人。若如是不异。我即为诳诸天龙鬼神已。诸佛见我亦不欢悦。我今若如阿兰若法。则诸天龙鬼神不见呵责。诸佛见我即亦欢悦。迦叶。阿兰若比丘。住阿兰若处行阿兰若法。一心坚持解脱禁戒。善护戒众净身口意。无谀谄行净于正命。心向诸定如所闻法。应忆念之勤正思惟。趣向离欲寂灭涅槃。畏于生死观五阴如怨家。观四大如毒蛇。观六入如空聚。善知方便。观十二因缘离断常见。观无众生无我无人无命。解法空相行于无相。渐损所作而行无作。心常惊畏于三界行。常勤修行如救头然。常行精进终不退转观身实相。应生如是心观如是法。当知苦本。断一切集。证于灭尽。勤修于道。行于慈心安住四念处离不善法入善法门。安住四正勤。入四如意足。护五善根。于五力中而得自在。觉七菩提分。勤行八圣善道分。受持禅定。以慧分别诸法之相。迦叶。说如是法以严饰。阿兰若比丘。作是严饰已住于山林。初夜后夜勤修诸行不应睡眠。常念欲得出世之法。迦叶。阿兰若比丘。凡所住处常修行道。不自严身及诸衣服。拾干枯草以用敷坐自用坐具。离常住僧及招提僧物。于阿兰若处。衣服知足趣得覆身。为行圣道故。迦叶。阿兰若比丘。若为乞食至城邑聚落。应作是念。我从阿兰若处至是城邑聚落。若得食若不得心无忧喜。若不得食者。应生喜心念宿业报。我今当勤修习福业。又念如来乞食亦不得。彼阿兰若比丘。入于城邑聚落乞食。应以法庄严。法庄严已然后乞食。云何法庄严。若见适意色不应染着。见不适意色亦不生嗔。若闻适意声不适意声。若嗅适意香不适意香。适意味不适意味。适意触不适意触。适意法不适意法。心无染着亦不生嗔。摄护根门谛视一寻调伏其心。本所思法不令离心。不以食污心而行乞食。应次第乞食。若得食处不应生着。不得食处不应生嗔。若至十家若过十家。不得食者不应生忧。应作是心。此诸长者及婆罗门。多有诸缘不与我食。又此长者诸婆罗门。乃至未曾生心念我况与我食。迦叶。阿兰若比丘。若能如是于乞食中不生惊畏。迦叶。阿兰若比丘乞食时。若见众生若男若女。若童男童女乃至畜生。应于是中生慈悲心。我行如是精进。作如是愿。若众生见我及与我食者皆生天上。迦叶。阿兰若比丘。若得粗食若得细食。受是食已应观四方。此村邑中谁贫穷者。当减此食以施与之。若见贫人所可乞食即分半与。若不见贫者应生是心。我眼所不见众生。我所得食于中好者愿施与之。我为施主彼为受者。迦叶。阿兰若比丘乞食。得受食已持至阿兰若处净洗手足。净沙门仪式具一切净法。如法取草已结加趺坐。坐已而食心无爱着亦无贡高。无有嗔心无浊乱心。临欲食时如是思惟。今此身中有八万户虫。虫得此食皆悉安乐。我今以食摄此诸虫。我得阿耨多罗三藐三菩提时。以法摄取。迦叶。又时阿兰若比丘。食或不足应作是念。我今身轻能修忍辱。断除诸恶少大小便。得身轻已亦得心轻。又得少睡亦不起欲想。应作如是思惟。迦叶。阿兰若比丘。若乞食得多应生知足想。应于食中减取一抟置净石上如是思惟。有诸鸟兽能啖食者。我以施之彼为受者。迦叶。阿兰若比丘。食已洗钵漱口洗手。净涤应器手拭令干。举僧伽梨。依阿兰若处行。不离本所思惟法相。迦叶。阿兰若比丘行阿兰若行时。若是凡夫未得沙门果。或时虎狼来至其所。若见不应生畏。作如是念。我本来至阿兰若处时。已舍身命我不应惊畏。应修慈心离一切恶亦离怖畏。若诸虎狼断我命根啖我身肉。当生是念。我得大利以不坚身当得坚身。此诸虎狼我不与食。今啖我肉已身得安乐。迦叶。阿兰若比丘行阿兰若法。应如是舍身命。迦叶。阿兰若比丘行阿兰若法。若有非人或作好色。或作恶色来至其所。于此非人不生爱心不生嗔心。迦叶。或有曾见佛诸天来。至阿兰若所作诸问难。问难已。阿兰若比丘。随力所能随所学法为诸天说。或时诸天有深问难。阿兰若比丘若不能答。不应生于憍慢之心。应作是言。我不多闻汝莫轻我。我今当勤修学佛法。或时我得通佛法已能一切答。又应劝请诸天。汝等今当为我说法。我当听受。又应如是报谢言。愿勿嫌也。复次迦叶。阿兰若比丘。行阿兰若法善修阿兰若想。犹如草木瓦石。无主无我亦无所属。此身亦尔。无我无命无人。无众生无诤讼。此法皆从缘合而生。于此法中若善思惟。我当得断一切诸见。常应思惟空无相无作法。迦叶。阿兰若比丘行阿兰若法时。若草药草及诸树林。云何和合云何散灭。如此外物无主无我。无有我所亦无诤讼。自生自灭无生灭者。迦叶。如草木瓦石。无我无主亦无所属。此身亦尔。无我无命无人。无众生无诤讼。从众缘生缘离则灭。此如实中无有一法若生若灭。迦叶。如是法阿兰若比丘。至阿兰若处所应修行。迦叶。阿兰若比丘行如是法。若学声闻乘疾得沙门果。若有障法现世不得沙门果者。不过见一佛二佛三佛。必定得断一切诸漏。若学菩萨乘。现世得无生法忍得无障法。必见未来诸佛。疾成阿耨多罗三藐三菩提。说此阿兰若品时。有五百比丘。断一切漏心得解脱

    乞食比丘品第六

佛告迦叶。云何比丘乞食。迦叶。若有比丘先安住本誓。我依乞食出家。我今住先誓。彼比丘专念无有谀谄。离一切请食。离一切僧中供养坚自庄严。乞食比丘于一切味中不应生好味想。又于上妙食中自劝其心生如是想。我如旃陀罗。应净身心。不应净饮食。何以故。食好食已一切为粪。臭秽不净故。我不应求好食。如是调伏心已。若入城邑聚落次第乞食。不应生如是想男子与我食非女人。女人与我食非男子。童男与我食非童女。童女与我食非童男。应得细食非粗食。应得美食非不美食。时应故与食非不故。应易得食非不易。应速得食非不速。若入人村应得恭敬非不恭敬。应得新食非宿食。应得富家食非贫家食。男子女人众应来迎我。迦叶。乞食比丘。如是不善法不应思惟。迦叶。乞食比丘应如是自庄严。此是乞食常所行法。若乞食时得与不得无有忧喜。不应生于粗细食想。何以故。多有众生贪着美味。由着味故作诸恶业。恶业因缘故堕于地狱畜生饿鬼。若知足者不贪美味。应舍细食受取粗食。除舌着味其心知足。得极粗食亦当知足。彼若命终生于天上或生人中。生天上已食天美食。迦叶。如是乞食比丘。离于味爱以调伏心。若七日啖豆亦不生忧。何以故。趣活身故我今食已。足以修道以是故食。迦叶。乞食比丘。得此食分堕钵中者。如法所得如法利养。应与梵行比丘共食此食。迦叶。乞食比丘或时有病。无有使人不能乞食。此应如是调伏其心。我独无侣一身出家。法是我伴我应念法。今我病苦如世尊说。诸比丘应念于法。我所闻法应善思惟。云何善思惟如实观身。如实观身已。有智慧者。若独一心能得初禅。则有是处。得初禅乐。若一日若二日乃至七日。以禅为食其心欢悦。迦叶。乞食比丘行如是法若不得禅。应如是勤行安住善法中。有多人所知。诸天龙神送食与之。此是离扼报故。迦叶。或乞食比丘。值天大雨或大风尘不能乞食。尔时以慈为食而自庄严。于所行法安住思惟。若二夜三夜不得食者。应生是念。有多众生堕饿鬼中。作恶业故苦恼所切。乃至百岁不得一唾。我今安住诸法门中。应生是念。身心羸劣今我堪忍饥渴。勤修圣道不应退转。迦叶。乞食比丘不应亲近在家之人。男子女人童男童女。迦叶。若乞食比丘令在家人。择去食中诸不净物。于坐处坐应为说法。乃至食净还受食已从坐起去。迦叶。乞食比丘不应自现谀谄。云何自现谀谄。若为他人说如是言。我今乞得粗恶之食。又复不足与多众共食我食少。我今饥渴身力羸劣。迦叶。是名自现谀谄。迦叶。乞食比丘如是之事应当远离。迦叶。乞食比丘于一切事应生舍心。若食堕钵中。若粗若细。若少若多。若净若不净。一切应受心无忧喜。常应净心观诸法相。趣得活身为行圣道是故受食。迦叶。乞食比丘或时入于城邑聚落次第乞食。若不得食空钵而出。应念如来有大威德。舍转轮王位而行出家。断一切恶法成一切善法。入村乞食尚空钵出。况我薄福不种善根。不空钵还也。是故不应生忧。何以故。不种善根能得粗食细食。无有是处。我不得食。或自有魔或魔所使。或魔覆蔽诸婆罗门居士。令我乞食不得。我当勤修离于四魔。断一切烦恼。若我勤修如是道已。非魔波旬。非魔所使能作留难。迦叶。乞食比丘。应如是受持圣种

    粪扫衣比丘品第七

佛告迦叶。畜粪扫衣比丘。拾粪扫物作如是想。为惭愧故。非以衣自严饰故。为障风吹日曝蚊虻蟆子诸恶触故。安住佛教故。非求净好故。于粪扫中拾取弃物。取时应生二种想。何等二。一者知足想。二者易养想。复生二想。一者无慢想。二者持圣种想。复生二想。一者不以严身。二者令心净故。迦叶。畜粪扫衣比丘。于粪扫中拾取弃物时。若于是处见诸亲族知识。见已即止不取。而作是念。此诸人辈或呵责我言。汝是不净人。迦叶。我说是比丘不得净行。何以故。畜粪扫衣比丘。心坚如石外物不入。亦不能动故。迦叶。畜粪扫衣比丘。拾粪扫中物。应净浣濯令无垢腻。浣已好染。染已作僧伽梨。善合善缀善缝善受。受已应着莫令绽坏。迦叶。畜粪扫衣比丘。安住不净观中着粪扫衣。为离欲故。慈心着粪扫衣。为离嗔恚故。观十二因缘着粪扫衣。为离痴故。正思惟着粪扫衣。为断一切烦恼故。摄护诸根着粪扫衣。为知六入故。不谀谄着粪扫衣。为令诸天龙神喜悦故。迦叶。何故名粪扫衣。迦叶。譬如死灰人所不贪。不生我所心。法应除弃。迦叶。如是粪扫衣。非我非我所。是易得非邪命。不求他不观他颜色。舍弃之物粪扫无异亦无所属。是故名粪扫衣。迦叶。粪扫衣是法幢。以大仙人故。是姓以圣人故。是安住以圣种故。是专念以善法仪式故。是善护以戒众故。是向门以定众故。是安住以慧众故。是身以解脱众故。是顺法以解脱知见众故。迦叶。如是畜粪扫衣得大福德。无所希求无所贪着。能离慢心能舍重担。迦叶。若有比丘畜粪扫衣。以知足故。诸天龙鬼神贪乐欲见。迦叶。畜粪扫衣比丘若入禅定。释梵四天王。长跪合掌头面作礼。况余小天。迦叶。若有恶比丘。勤求衣服以严饰身。外现净行而内具足贪欲恚痴。虽作如是好严饰身。而诸天龙神不至其所礼敬供养。何以故。知此比丘勤求衣服以严饰身。不除心心数法垢。诸天知故则远舍去。迦叶。汝见周那沙弥拾不净臭秽粪扫中物。乞食已至阿耨大池欲浣濯之。尔时池边有常住诸天。皆远奉迎头面作礼。彼诸天等皆乐净洁。而取周那沙弥所捉不净粪扫衣。而为浣之令无垢秽。又取浣汁自以洗身。诸天知周那能持净戒。入诸禅定有大威德。是故奉迎恭敬作礼。迦叶。汝见须跋陀梵志。着净洁衣乞食已。欲至阿耨大池时。常住诸天于池四面面各五里。遥遮梵志不令近池。恐以不净食及以残食污此大池。迦叶。汝今现见此事。以圣人正行威德故得是果。周那沙弥。所有不净粪扫中物。而诸天取之为浣。亦以浣汁自洗其身。须跋陀梵志。去池五里不令近之。迦叶。谁闻是已于圣法中不勤修学。彼诸圣人诸天世人。皆来头面礼敬供养。迦叶。欲求如是圣德故。畜粪扫衣。迦叶。畜粪扫衣比丘。安住圣种不应生忧。于粪扫衣应生塔想。应生世尊想。应生出世想。应生无我无我所想。如是观已着粪扫衣。应如是调伏其心。由心净故得身净。非身净故得心净。迦叶。是故当净其心莫严饰身。何以故。由心净故。于佛法中得名梵行。迦叶。如是畜粪扫衣比丘。能如是学。则为学我。亦学于汝。迦叶。若汝能畜如是粗衣。则便知足行于圣种。迦叶。汝僧伽梨若着床上若在坐处。着忧多罗僧经行。则有千万诸天礼汝僧伽梨。此僧伽梨是戒定慧所薰者。覆身之衣。迦叶。当知汝衣尚得如是尊重礼敬。况汝身耶。迦叶。我舍转轮王位出家学道。先所著好上妙缯衣。头罗衣。好细叠衣。诸上妙衣。一切着已。我今知足行于圣种。为余人故。身舍好服畜冢间衣。若当来比丘。闻我此法即得学我。迦叶。汝本有金缕上衣。我从汝索。汝持与我。迦叶。我愍汝故即为汝受。非以贪故。非以严身故。迦叶。有恶比丘。不能学我亦不学汝为贪所覆。多畜衣钵积聚饮食藏举不舍。亦畜金银琉璃谷米牛羊鸡猪驴马车乘犁具。家业所须皆求畜之。迦叶。有智之人虽在于家能增善法。非痴人出家得是善分。云何智人在家能增长善法。迦叶。若有出家以袈裟绕项。无沙门行多有缘事。种种系缚求好衣食。着袈裟已在家人见礼敬给施衣服饮食卧具汤药来去迎送。迦叶。在家之人得如是善法。彼出家人无有是事。何以故。彼出家人多求所须。不能施他故。迦叶。当来有比丘。多畜衣钵多有诸物。时彼比丘。多为诸在家人。所见礼敬尊重赞叹。何以故。谓是比丘。多受他施或持与我。我有所须能时时与。迦叶。或有比丘持戒见世过患。勤修善法离一切漏如救头然。其心知足少诸缘事。勤修自利离于一切习恶缘者。而彼比丘无人往至其所无亲近者。无礼敬尊重赞叹者。何以故。彼在家人轻躁浅薄。见现世利不见后世利。彼在家人生如是心。此比丘边不得利益。用亲近为用礼敬尊重赞叹。为除贫穷人少善根者。宿缘应敬者。迦叶。如是人等亲近礼敬尊重赞叹。持戒比丘以为善知识。迦叶。如是说已称可二种人意。何等二。一者若见四圣谛。二者若见生死过患。复有二。一者勤行欲离四扼。二者欲得沙门果。复有二。一者专念业报。二者欲知诸法相义。迦叶。我今闭塞一切懈怠者门。所谓不知业不知业报者。离善仪式者。不见后世过恶。喻如金刚。见现世利不见后世利。不生一念向解脱门者。迦叶。我今说彼恶比丘不应希望。若说如是法。若遇如是法。闻如是法已自知所行。不解深法而诽谤之。谓非佛说。是论师作。或魔所说。用教余人。彼恶比丘。如是自害亦复害他。自染垢污亦垢污他。是恶比丘。不能自利亦不利他。尔时摩诃迦叶白佛言。世尊。如诸佛大悲故。说专行比丘于诸法中得自在者。如来于此经中已广说竟。世尊。若有众生闻此经已。信解读诵向如实法。当知是诸众生。已为诸佛之所摄取

尔时佛告阿难。若有受持是经者。已于先佛种诸善根故。今欲得此经读诵通利。欲得解脱。所谓善男子善女人。若出家学若在家学。此法门能断诸漏亦得涅槃。阿难白佛言。世尊。我欲受持此经。当何名此经。云何受持。佛告阿难。此经名选择一切法宝。亦名安住圣种仪式。亦名摄取持戒者。亦名节解破戒者。亦名宝梁。亦名宝取。亦名宝藏。亦名诸宝法门。摩诃迦叶。问大乘宝梁经竟。诸比丘众。闻佛所说欢喜奉行

大宝积经卷第一百一十四大宝积经卷第一百一十五

        大唐三藏菩提流志奉　诏译

    无尽慧菩萨会第四十五

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众千二百五十人俱。尔时复有一万菩萨摩诃萨俱。所谓慧幢菩萨。法幢菩萨。月幢菩萨。日幢菩萨。无边幢菩萨。复有十六在家菩萨。跋陀婆罗而为上首。复有六十无比喻心菩萨摩诃萨。文殊师利而为上首。复有贤劫中一切菩萨摩诃萨。弥勒菩萨而为上首。复有六万菩萨摩诃萨。无尽慧菩萨而为上首

尔时无尽慧菩萨。即从坐起。偏袒右肩。右膝着地。合掌向佛。头面礼敬。以众宝华奉散于佛。而白佛言。世尊。所言菩提心者。以何义故说菩提心。菩萨复以几法成就菩提心。云何是菩提心。菩提中心不可得。心中菩提亦不可得。离菩提心不可得。离心菩提亦不可得。菩提者无色无相。不可言说。心亦无色无相不可显示。众生亦尔。皆不可得。世尊诸法如是。当依何义而得修行。佛言善男子。汝今谛听我说。菩提者本无名字言说。何以故。于菩提中。名字言说不可得故。心及众生亦复如是。若如是知名菩提心。菩提者非过去未来现在心及众生。亦非过去未来现在。若知此义是名菩萨。然于其中亦不可得。于一切法都无所得。是名得菩提心。如阿罗汉得阿罗汉果。而于此中都无所得。唯除随俗说言得果。于一切法皆无所得。得菩提心亦复如是。为欲引摄初业菩萨故说菩提心。然于其中无心无心名。无菩提无菩提名。无众生无众生名。无声闻无声闻名。无独觉无独觉名。无菩萨无菩萨名。无如来无如来名。无有为无有为名。无无为无无为名。无现得无当得。善男子。我今依言说如是敷演。若有诸众生。善根广大超诸众生。如须弥山出过一切。是初发心为施波罗蜜因。犹如大地善能安住一切事业。是第二发心为戒波罗蜜因。志意勇猛安受烦恼。如师子王威伏众兽身无怖畏。是第三发心为忍波罗蜜因。势力雄迅能伏烦恼。如那罗延摧伏异众。是第四发心为精进波罗蜜因。功德善根种种开发。如波利质多。俱鞞陀罗树其华开敷。是第五发心为禅波罗蜜因。除去痴暗。犹如日轮光明无边。是第六发心为般若波罗蜜因。功德意乐一切庄严皆得圆满。如大商主丰足财物。能以巧便拔众险难。是第七发心为方便波罗蜜因。障碍除灭意乐具足如净满月。是第八发心为力波罗蜜因。佛土众生皆悉严净。善法备足所作成办。譬如贫人得无尽藏所愿圆满。是第九发心为愿波罗蜜因。福智无边犹如虚空。于法自在如转轮王已受灌顶。是第十发心为智波罗蜜因。善男子。若此十种发心修习成就名为菩萨。名为最胜众生。无障碍众生非下劣众生。然以实义不可得故。故于其中无众生无心无菩提

复次善男子。菩萨行施波罗蜜。以十法为首。一者信根。二者信力。三者意乐。四者增上意乐。五者饶益众生。六者大慈。七者大悲。八者行四摄法。九者爱乐佛法。十者求一切智。是为十。善男子。菩萨行戒波罗蜜。以十法为首。一者身业清净。二者语业清净。三者意业清净。四者无怨害心。五者净除恶趣。六者远离八难。七者超诸声闻辟支佛地。八者安住佛功德。九者满诸希望。十者成就大愿。是为十。善男子。菩萨行忍波罗蜜。以十法为首。一者舍离嗔恚。二者不计其身。三者不计其命。四者信解。五者成熟众生。六者慈力。七者随顺法忍。八者甚深法忍。九者广大胜忍。十者破无明暗。是为十。善男子。菩萨行精进波罗蜜。以十法为首。一者随诸众生所作而作。二者身口意业常生随喜。三者无懈怠。四者务进趣。五者修正勤。六者修念处。七者破烦恼怨。八者观察诸法。九者成熟一切众生。十者求一切智。是为十。善男子。菩萨行禅波罗蜜。以十法为首。一者安住善法。二者心缘一境。三者缘境等至。四者正定。五者禅解脱。六者定根。七者定力。八者坏烦恼怨。九者定聚圆满。十者护法三昧。是为十。善男子。菩萨行般若波罗蜜。以十法为首。一者善观察诸阴。二者善观察界处。三者正见。四者正念。五者了知圣谛。六者舍离诸见。七者慧根。八者无生法忍。九者慧力。十者无障碍智。是为十。善男子。菩萨行方便波罗蜜。以十法为首。一者入诸众生心行欲乐。二者以力加诸众生。三者大慈大悲。四者成熟众生而无厌倦。五者舍离声闻辟支佛地。六者殊胜智见。七者修习诸波罗蜜。八者如实观诸法。九者摄不思议力。十者不退转地。是为十。善男子。菩萨行力波罗蜜。以十法为首。一者知一切众生心行稠林。二者知一切众生烦恼行稠林。三者知一切众生意乐胜解行稠林。四者知一切众生根行稠林。五者知一切众生种种界行稠林。六者知一切众生随烦恼行稠林。七者知一切众生死生行稠林。八者知一切众生三世业报行稠林。九者知一切众生习气烦恼行稠林。十者以无疲倦心成熟众生诸根行稠林。是为十。善男子菩萨行愿波罗蜜。以十法为首。一者知一切法无生。二者知一切法无相。三者知一切法无灭。四者知一切法无所有。五者于一切法无执着。六者知一切法无来。七者知一切法无去。八者知一切法无自性。九者知一切法无初中后平等。十者于一切法初中后无分别。是为十。善男子菩萨行智波罗蜜。以十法为首。一者于一切法善能了知决择。二者善能圆满白法。三者积习菩萨无量资粮四者成就广大福智资粮。五者大悲圆满。六者入种种差别世界。七者入一切众生诸烦恼行。八者作意入如来境界。九者趣入十力无畏不共佛法殊胜境界。十者受灌顶位成就一切智最胜之相。是为十。善男子。是为诸菩萨摩诃萨行十波罗蜜皆以十法为首

复次善男子。云何为波罗蜜义。所谓明示超过一切声闻独觉所行故。广大圆满如来智故。于有为无为不执着故。如实了知生死过故。诸未觉者悉令觉故。得如来无尽法藏故。得无碍解脱故。以布施度脱诸众生故。以持戒圆满本誓愿故。以忍辱具足端严相故。以精进究竟诸佛法故。以禅定出生四无量故。以般若灭除诸烦恼故。以方便积集诸佛法故。以愿能令佛法圆满故。以力能令众生净信故。以智具足如来一切智故。得无生法忍故。得不退转地故。净治佛刹故。成熟众生故。于菩提道场圆满一切如来智故。降伏众魔故。游四神足故。于生死涅槃俱无住故。超过一切声闻独觉菩萨功德故。摧伏一切诸异论故。成就十力四无所畏不共佛法故。证得无上正等觉故。转十二种法轮故。如是一切是波罗蜜义

复次善男子。菩萨摩诃萨将住初欢喜地先有是相。见三千大千世界中。所有百千亿那由他众宝伏藏。菩萨将住第二离垢地先有是相。见三千大千世界地平如掌。无量百千亿那由他。众宝莲花清净严饰。菩萨将住第三明地先有是相。见于自身被甲持杖勇猛坚固摧伏怨敌。菩萨将住第四焰地先有是相。见四方风吹种种名华布散于地。菩萨将住第五难胜地先有是相。见于女人首戴阿提目多华鬘。婆利师迦华鬘。瞻卜迦华鬘。身佩种种众庄严具。菩萨将住第六现前地先有是相。见于华池八功德水。澄净盈满。底布金沙。宝阶四道。又于池中有优钵罗花。波头摩花。拘勿头花。复见分陀利花而为庄严。复见自身于中游戏。菩萨将住第七远行地先有是相。见于自身左右两边皆有地狱。从彼超过无所伤害。菩萨将住第八不动地先有是相。见自身两肩被师子王相。一切诸兽悉皆怖畏。菩萨将住第九善慧地。先有是相。见于自身为转轮王以正法教化。为无量百千亿那由他诸王之所围绕。种种宝严鲜白之盖盖菩萨上。菩萨将住第十法云地先有是相。见于自身为真金色。具足如来三十二种大丈夫相圆光一寻。安处高广师子之座。无量百千亿那由他梵天前后围绕。恭敬供养而听说法。善男子。菩萨摩诃萨以三昧力。显现如是十地先相。复次善男子。初地菩萨圆满施波罗蜜。二地菩萨圆满戒波罗蜜。三地菩萨圆满忍波罗蜜。四地菩萨圆满精进波罗蜜。五地菩萨圆满禅波罗蜜。六地菩萨圆满般若波罗蜜。七地菩萨圆满方便波罗蜜。八地菩萨圆满力波罗蜜。九地菩萨圆满愿波罗蜜。十地菩萨圆满智波罗蜜

复次善男子。菩萨初发心得现宝三昧。第二发心得善住三昧。第三发心得不动三昧。第四发心得不退转三昧。第五发心得宝花三昧。第六发心得日轮光明三昧。第七发心得成就一切义三昧。第八发心得智炬三昧。第九发心得现证佛法三昧。第十发心得首楞严三昧

复次善男子。菩萨于初地中得殊胜加持陀罗尼。第二地中得无能胜陀罗尼。第三地中得善住陀罗尼。第四地中得不可坏陀罗尼。第五地中得无垢陀罗尼。第六地中得智轮灯陀罗尼。第七地中得殊胜行陀罗尼。第八地中得清净分别陀罗尼。第九地中得示现无边法门陀罗尼。第十地中得无尽法藏陀罗尼

尔时会中有一天子。名无碍光明师子幢。从坐而起。偏袒右肩。右膝着地。合掌向佛。白佛言。希有世尊。希有善逝。如是法门甚深广大。而能含摄一切佛法。于是佛告无碍光明师子幢言。如是如是。如汝所说。善男子。若有菩萨于此法门暂能听受。必不退转阿耨多罗三藐三菩提。何以故。彼善男子善女人。曾种诸善根故。成熟诸善根故。得闻如是经典。为是经典之所印故。善男子。若有男子女人闻此经典。所种善根悉皆清净。当得不舍离。见佛闻法供养众僧成熟众生。得不舍离海印陀罗尼。得不舍离出现无尽陀罗尼。得不舍离入众生欲乐心行陀罗尼。得不舍离清净日光幢陀罗尼。得不舍离无垢月光幢陀罗尼。得不舍离息一切结陀罗尼。得不舍离摧灭无边坚如金刚山烦恼陀罗尼。得不舍离入平等法性言说陀罗尼。得不舍离入真实语言音声陀罗尼。得不舍离如虚空显现无边清净印所印陀罗尼。得不舍离成就显现无边佛身陀罗尼。善男子。若菩萨成就如是诸陀罗尼。能于十方一切刹土。变现佛身教化众生。然于法性而无来去。亦复无有教化众生。于所说法不著文字平等无动。虽现身生死而无起灭。亦无少法有去来者。了知诸行本来寂静安住佛法。何以故。彼一切诸法无分别故。说是法时。众中三万菩萨。得无生法忍。无量菩萨。于阿耨多罗三藐三菩提。获不退转。无量众生。发菩提心。无量比丘。得法眼净。佛说此经已。无尽慧菩萨。及诸比丘。世间天人。阿修罗乾闼婆等。皆大欢喜。信受奉行

    大宝积经文殊说般若会第四十六之一

        梁三藏曼陀罗仙译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘僧满足千人。菩萨摩诃萨十千人俱以大庄严而自庄严。皆悉已住不退转地。其名曰弥勒菩萨。文殊师利菩萨。无碍辩菩萨。不舍担菩萨。与如是等大菩萨俱。文殊师利童真菩萨摩诃萨。明相现时从其住处。来诣佛所在外而立。尔时尊者舍利弗。富楼那弥多罗尼子。大目揵连。摩诃迦叶。摩诃迦栴延。摩诃拘絺罗。如是等诸大声闻。各从住处俱诣佛所在外而立。佛知众会皆悉集已。尔时如来从住处出敷座而坐。告舍利弗。汝今何故于晨朝时在门外立。舍利弗。白佛言世尊。文殊师利童真菩萨。先已至此住门外立。我实于后晚来到耳。尔时世尊。问文殊师利。汝实先来到此住处。欲见如来耶。文殊师利。即白佛言。如是世尊。我实来此欲见如来。何以故。我乐正观利益众生。我观如来如如相不异相。不动相不作相。无生相无灭相。不有相不无相。不在方不离方。非三世非不三世。非二相非不二相。非垢相非净相。以如是等正观如来利益众生。佛告文殊师利。若能如是见于如来。心无所取亦无不取。非积聚非不积聚。尔时舍利弗。语文殊师利言。若能如是。如汝所说。见如来者甚为希有。为一切众生故见于如来。而心不取众生之相。化一切众生向于涅槃。而亦不取向于涅槃相。为一切众生发大庄严。而心不见庄严之相。尔时文殊师利童真菩萨摩诃萨。语舍利弗言。如是如是。如汝所说。虽为一切众生发大庄严。心恒不见有众生相。为一切众生发大庄严。而众生界亦不增不减。假使一佛住世。若一劫若过一劫。如此一佛世界。复有无量无边恒河沙诸佛。如是一一佛。若一劫若过一劫。昼夜说法心不暂息。各各度于无量恒河沙众生皆入涅槃。而众生界亦不增不减。乃至十方诸佛世界亦复如是。一一诸佛说法教化。各度无量恒河沙众生皆入涅槃。于众生界亦不增不减。何以故。众生定相不可得故。是故众生界不增不减。舍利弗。复语文殊师利言。若众生界不增不减。何以故。菩萨为诸众生。求阿耨多罗三藐三菩提。常行说法。文殊师利白佛言。若诸众生悉空相者。亦无菩萨求阿耨多罗三藐三菩提。亦无众生而为说法。何以故。我说法中无有一法当可得故。尔时佛告文殊师利。若无众生云何说有众生及众生界。文殊师利言。众生界相如诸佛界。又问。众生界者是有量耶答曰。众生界量如佛界量。又问。众生界量有处所不。答曰。众生界量不可思议。又问。众生界相为有住不。答曰。众生无住。犹如空住。佛告文殊师利。如是修般若波罗蜜时。当云何住般若波罗蜜。文殊师利言。以不住法为住般若波罗蜜。佛复问文殊师利。云何不住法名住般若波罗蜜。文殊师利言。以无住相即住般若波罗蜜。佛复告文殊师利。如是住般若波罗蜜时。是诸善根云何增长云何损减。文殊师利言。若能如是住般若波罗蜜。于诸善根无增无减。于一切法亦无增无减。是般若波罗蜜性相亦无增无减。世尊。如是修般若波罗蜜。则不舍凡夫法。亦不取贤圣法。何以故。般若波罗蜜不见有法可取可舍。如是修般若波罗蜜。亦不见涅槃可乐生死可厌。何以故。不见生死况复厌离。不见涅槃何况乐着。如是修般若波罗蜜。不见垢恼可舍。亦不见功德可取。于一切法心无增减。何以故。不见法界有增减故。世尊。若能如是。是名修般若波罗蜜。世尊。不见诸法有生有灭。是修般若波罗蜜。世尊。不见诸法有增有减。是修般若波罗蜜。世尊。心无悕取。不见法相有可取者。是修般若波罗蜜。世尊。不见好丑。不生高下。不作取舍。何以故。法无好丑。离诸相故。法无高下。等法性故。法无取舍。住实际故。是修般若波罗蜜。佛告文殊师利。是诸佛法得不胜乎。文殊师利言。我不见诸法有胜如相。如来自觉一切法空是可证知。佛告文殊师利。如是如是。如来正觉自证空法。文殊师利。白佛言世尊。是空法中当有胜如而可得耶。佛言。善哉善哉。文殊师利。如汝所说是真法乎。谓文殊师利言。阿耨多罗是名佛法。文殊师利言。如佛所说。阿耨多罗是名佛法。何以故。无法可得名阿耨多罗。文殊师利言。如是修般若波罗蜜。不名法器非化凡夫法。亦非佛法非增长法。是修般若波罗蜜。复次世尊。修般若波罗蜜时。不见有法可分别思惟

佛告文殊师利。汝于佛法不思惟耶。文殊师利言。不也世尊。如我思惟不见佛法。亦不可分别。是凡夫法。是声闻法。是辟支佛法。如是名为无上佛法。复次修般若波罗蜜时。不见凡夫相。不见佛法相。不见诸法有决定相。是为修般若波罗蜜。复次修般若波罗蜜时。不见欲界。不见色界。不见无色界。不见寂灭界。何以故。不见有法是尽灭相。是修般若波罗蜜。复次修般若波罗蜜时。不见作恩者。不见报恩者。思惟二相心无分别。是修般若波罗蜜。复次修般若波罗蜜时。不见般若波罗蜜。复次修般若波罗蜜时。不见是佛法可取。不见是凡夫法可舍。是修般若波罗蜜。复次修般若波罗蜜时。不见凡夫法可灭。亦不见佛法而心证知。是修般若波罗蜜

佛告文殊师利。善哉善哉。汝能如是善说甚深般若波罗蜜相。是诸菩萨摩诃萨所学法印。乃至声闻缘觉学无学人。亦当不离是印而修道果。佛告文殊师利。若人得闻是法。不惊不畏者。不从千佛所种诸善根。乃至百千万亿佛所久殖德本。乃能于是甚深般若波罗蜜。不惊不怖。文殊师利。白佛言世尊。我今更说般若波罗蜜义。佛言便说。世尊。修般若波罗蜜时。不见法是应住是不应住。亦不见境界可取舍相。何以故。如诸如来不见一切法境界相故。乃至不见诸佛境界。况取声闻缘觉凡夫境界。不取思议相。亦不取不思议相。不见诸法有若干相。自证空法不可思议。如是菩萨摩诃萨。皆已供养无量百千万亿诸佛种诸善根。乃能于是甚深般若波罗蜜不惊不怖。复次修行般若波罗蜜时。不见缚不见解。而于凡夫乃至三乘不见差别相。是修般若波罗蜜

佛告文殊师利。汝已供养几所诸佛。文殊师利言。我及诸佛如幻化相。不见供养及与受者。佛告文殊师利。汝今可不住佛乘耶。文殊师利言。如我思惟不见一法。云何当得住于佛乘。佛言。文殊师利。汝不得佛乘乎。文殊师利言。如佛乘者但有名字。非可得亦不可见。我云何得。佛言。文殊师利。汝得无碍智乎。文殊师利言。我即无碍。云何以无碍而得无碍。佛言。汝坐道场乎。文殊师利言。一切如来不坐道场。我今云何独坐道场。何以故。现见诸法住实际故。佛言。云何名实际。文殊师利言。身见等是实际。佛言。云何身见是实际。文殊师利言。身见如相。非实非不实。不来不去。亦身非身。是名实际。舍利弗。白佛言世尊。若于斯义谛了决定。是名菩萨摩诃萨。何以故。能闻如是甚深般若波罗蜜相。心不惊不怖不没不悔弥勒菩萨。白佛言世尊。得闻如是般若波罗蜜。具足法相。是即近于佛坐。何以故。如来现觉此法相故。文殊师利。白佛言世尊。得闻甚深般若波罗蜜。能不惊不怖不没不悔。当知此人即是见佛。尔时复有无相优婆夷。白佛言世尊。凡夫法。声闻法。辟支佛法。佛法。是诸法皆无相。是故于所从闻般若波罗蜜。皆不惊不怖不没不悔。何以故。一切诸法本无相故。佛告舍利弗。善男子善女人。若闻如是甚深般若波罗蜜。心得决定不惊不怖不没不悔。当知是人即住不退转地。若人闻是甚深般若波罗蜜。不惊不怖信乐听受欢欣不厌。是即具足檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。亦能为他显示分别如说修行

佛告文殊师利。汝观何义。为得阿耨多罗三藐三菩提。住阿耨多罗三藐三菩提。文殊师利言。我无得阿耨多罗三藐三菩提。我不住佛乘。云何当得阿耨多罗三藐三菩提。如我所说即菩提相。佛赞文殊师利言。善哉善哉。汝能于是甚深法中。巧说斯义。汝于先佛久种善根。以无相法净修梵行。文殊师利言。若见有相则言无相。我今不见有相。亦不见无相。云何而言以无相法净修梵行

佛告文殊师利。汝见声闻戒耶。答曰见。佛言。汝云何见。文殊师利言。我不作凡夫见。不作圣人见。不作学见。不作无学见。不作大见。不作小见。不作调伏见。不作不调伏见。非见非不见。舍利弗。语文殊师利言。汝今如是观声闻乘。若观佛乘当复云何。文殊师利言。不见菩萨法。不见修行菩提及证菩提者。舍利弗。语文殊师利言。云何名佛。云何观佛。文殊师利言。云何为我。舍利弗言。我者但有名字。名字相空。文殊师利言。如是如是。如我但有名字。佛亦但有名字名字相空即是菩提。不以名字而求菩提。菩提之相无言无说。何以故。言说菩提二俱空故。复次舍利弗。汝问云何名佛。云何观佛者。不生不灭。不来不去。非名非相。是名为佛。如自观身实相。观佛亦然。唯有智者。乃能知耳。是名观佛

大宝积经卷第一百一十五大宝积经卷第一百一十六

        梁三藏曼陀罗仙译

    文殊师利说般若会第四十六之二

尔时舍利弗。白佛言世尊。如文殊师利所说般若波罗蜜。非初学菩萨所能了知。文殊师利言。非但初学菩萨所不能知。及诸二乘所作已办者。亦未能了知。如是说法无能知者。何以故。菩提之相。实无有法而可知故。无见无闻。无得无念。无生无灭。无说无听。如是菩提性相空寂。无证无知。无形无相。云何当有得菩提者。舍利弗语文殊师利言。佛于法界不证阿耨多罗三藐三菩提耶。文殊师利言。不也舍利弗。何以故。世尊即是法界。若以法界证法界者。即是诤论。舍利弗。法界之相即是菩提。何以故。是法界中无众生相故。一切法空故。一切法空即是菩提。无二无分别故。舍利弗。无分别中则无知者。若无知者。即无言无说。无言说相。即非有非无。非知非不知。一切诸法亦复如是。何以故。一切诸法不见处所。决定性故。如逆罪相不可思议。何以故。诸法实相不可坏故。如是逆罪亦无本性。不生天上不堕地狱。亦不入涅槃。何以故。一切业缘皆住实际。不来不去。非因果非不因果。何以故。法界无边无前无后故。是故舍利弗。若见犯重比丘不堕地狱。清净行者不入涅槃。如是比丘。非应供非不应供。非尽漏非不尽漏。何以故。于诸法中住平等故。舍利弗言。云何名不退法忍。文殊师利言。不见少法有生灭相。名不退法忍。舍利弗言。云何复名不调比丘。文殊师利言。漏尽阿罗汉是名不调。何以故。诸结已尽更无所调。故名不调。若过心行名为凡夫。何以故。凡夫众生不顺法界。是故名过。舍利弗言。善哉善哉。汝今为我善解漏尽阿罗汉义。文殊师利言。如是如是。我即漏尽真阿罗汉。何以故。断求声闻欲及辟支佛欲。以是因缘故。名漏尽得阿罗汉

佛告文殊师利诸菩萨等。坐道场时。觉悟阿耨多罗三藐三菩提不。文殊师利言。菩萨坐于道场。无有觉悟阿耨多罗三藐三菩提。何以故。如菩提相。无有少法而可得者。名阿耨多罗三藐三菩提。无相菩提。谁能坐者亦无起者。以是因缘。不见菩萨坐于道场。亦不觉证阿耨多罗三藐三菩提。文殊师利。白佛言世尊。菩提即五逆。五逆即菩提。何以故。菩提五逆无二相故。无觉无觉者。无见无见者。无知无知者。无分别无分别者。如是之相名为菩提。见五逆相亦复如是。若言见有菩提而取证者。当知此辈即是增上慢人。尔时世尊。告文殊师利。汝言我是如来。亦谓我为如来乎。文殊师利言。不也世尊。我不谓如来为如来耶。无有如相可名为如。亦无如来智能知于如。何以故。如来及智无二相故。空为如来。但有名字。我当云何谓是如来

佛告文殊师利。汝疑如来耶。文殊师利言。不也世尊。我观如来无决定性。无生无灭故无所疑。佛告文殊师利。汝今不谓如来出现于世耶。文殊师利言。若有如来出现世者。一切法界亦应出现。佛告文殊师利。汝谓恒沙诸佛入涅槃耶。文殊师利言。诸佛一相不可思议。佛语文殊师利。如是如是。佛是一相不思议相。文殊师利。白佛言世尊。佛今住世耶。佛语文殊师利。如是如是。文殊师利言。若佛住世。恒沙诸佛亦应住世。何以故。一切诸佛。皆同一相不思议相。不思议相者无生无灭。若未来诸佛出兴于世。一切诸佛亦皆出世。何以故。不思议中。无过去未来现在相。但众生取着谓有出世。谓佛灭度。佛语文殊师利。此是如来。阿罗汉。阿鞞跋致菩萨所解。何以故。是三种人闻甚深法。能不诽谤亦不赞叹。文殊师利。白佛言世尊。如是不思议。谁当诽谤。谁当赞叹

佛告文殊师利。如来不思议凡夫亦不思议。文殊师利。白佛言世尊。凡夫亦不思议耶。佛言。亦不思议。何以故。一切心相皆不思议。文殊师利言。若如是说如来不思议。凡夫亦不思议。今无数诸佛。求于涅槃徒自疲劳。何以故。不思议法即是涅槃。等无异故。文殊师利言。如是凡夫不思议。诸佛不思议。若善男子善女人。久习善根近善知识。乃能了知。佛告文殊师利。汝欲使如来于诸众生为最胜耶。文殊师利言。我欲使如来于诸众生为最第一。但众生相亦不可得。佛言。汝欲使如来得不思议法耶。文殊师利言。欲使如来得不思议法。而于诸法无成就者。佛告文殊师利。欲使如来说法教化耶。文殊师利白佛言。欲使如来说法教化。而是说及听者皆不可得。何以故。住法界故。法界众生无差别相。佛告文殊师利。汝欲使如来为无上福田耶。文殊师利言。如来是无尽福田是无尽相。无尽相即无上福田。非福田非不福田。是名福田。无有明闇生灭等相。是名福田。若能如是解福田相。深殖善种。亦无增无减。佛告文殊师利。云何殖种不增不减。文殊师利言。福田之相不可思议。若人于中如法修善。亦不可思议。如是殖种名无增无减。亦是无上最胜福田。尔时大地以佛神力。六种振动现无常相。一万六千人皆得无生法忍。七百比丘。三千优婆塞。四万亿优婆夷。六千亿那由他六欲诸天。远尘离垢。于诸法中得法眼净。尔时阿难从坐而起。偏袒右肩右膝着地。白佛言世尊。何因缘故。如是大地六种振动。佛告阿难。我说福田无差别相。故现斯瑞。往昔诸佛。亦于此处作如是说。福田之相利益众生。一切世界六种振动。舍利弗。白佛言世尊。文殊师利是不可思议。何以故。所说法相不可思议。佛告文殊师利。如是如是。如舍利弗言。汝之所说实不思议。文殊师利。白佛言世尊。不思议不可说。思议亦不可说。如是思议不思议性。俱不可说。一切声相非思议。亦非不可思议。佛言。汝入不思议三昧耶。文殊师利言。不也世尊。我即不思议。不见有心能思议者。云何而言入不思议三昧。我初发心欲入是定。而今思惟。实无心相而入三昧。如人学射久习则巧。后虽无心以久习故箭发皆中。我亦如是。初学不思议三昧。系心一缘。若久习成就。更无心想恒与定俱。舍利弗。语文殊师利言。更有胜妙寂灭定不。文殊师利言。若有不思议定者。汝可问言。更有寂灭定不。如我意解。不可思议定尚不可得。云何问有寂灭定乎。舍利弗言。不思议定不可得耶。文殊师利言。思议定者是可得相。不思议定者不可得相。一切众生实成就不思议定。何以故。一切心相即非心故。是名不思议定。是故一切众生相及不思议三昧相。等无分别。佛赞文殊师利言。善哉善哉。汝于诸佛。久殖善根净修梵行。乃能演说甚深三昧。汝今安住如是般若波罗蜜中。文殊师利言。若我住般若波罗蜜中。能作是说。即是有想便住我想。若住有想我想中者。般若波罗蜜。便有处所。般若波罗蜜。若住于无。亦是我想亦名处所。离此二处。住无所住。如诸佛住。安处寂灭非思议境界。如是不思议。名般若波罗蜜住处。般若波罗蜜。处一切法无相一切法无作。般若波罗蜜即不思议。不思议即法界。法界即无相。无相即不思议。不思议即般若波罗蜜。般若波罗蜜即法界。无二无别。无二无别即法界。法界即无相。无相即般若波罗蜜界。般若波罗蜜界即不思议界。不思议界即无生无灭界。无生无灭界即不思议界。文殊师利言。如来界及我界即不二相。如是修般若波罗蜜者。则不求菩提。何以故。菩提相离。即是般若波罗蜜故。世尊。若知我相而不可着。无知无著。是佛所知不可思议。无知无著即佛所知。何以故。知体本性无所有相。云何能转法界。若知本性无体无著者。即名无物。若无有物。是无处所无依无住。无依无住即无生无灭。无生无灭即是有为无为功德。若如是知则无心想。无心想者。云何当知有为无为功德。无知即不思议。不思议者是佛所知。亦无取无不取。不见三世去来等相。不取生灭及诸起作。亦不断不常。如是知者。是名正智不思议智。如虚空无此无彼不可比类。无好恶无等等。无相无貌。佛告文殊师利。若如是知名不退智。文殊师利言。无作智名不退智。犹如金矿先加锤打方知好恶。若不治打无能知者。不退智相亦复如是。要行境界。不念不着。无起无作。具足不动不生不灭。尔乃显现。尔时佛告文殊师利言。如诸如来。自说己智。谁当能信。文殊师利言。如是智者。非涅槃法非生死法。是寂灭行是无动行。不断贪欲嗔恚愚痴。亦非不断。何以故无尽无灭。不离生死。亦非不离。不修道非不修道。作是解者名为正信。佛告文殊师利言。善哉善哉。如汝所说。深解斯义。尔时摩诃迦叶。白佛言世尊。于当来世。若说如是甚深正法。谁能信解如闻受行

佛告迦叶。今此会中比丘比丘尼。优婆塞优婆夷。得闻此经者。如是人等于未来世。若闻是法必能信解。于甚深般若波罗蜜。乃能读诵信解受持。亦能为他人分别演说。譬如长者失摩尼宝忧愁苦恼。后若还得心甚欢喜。如是迦叶。比丘比丘尼优婆塞优婆夷等。亦复如是。有信乐心。若不闻法则生苦恼。若得闻时信解受持。常乐读诵甚大欢喜。当知此人即是见佛。亦即亲近供养诸佛。佛告迦叶。譬如忉利天上波利质多罗树疱初出时。是中诸天见是树已皆大欢喜。此树不久必当开敷。若比丘比丘尼优婆塞优婆夷。得闻般若波罗蜜。能生信解。亦复如是。此人不久。亦当开敷一切佛法。于当来世。有比丘比丘尼优婆塞优婆夷。闻般若波罗蜜。信受读诵心不悔没。当知是人已从此会听受是经。亦能为人聚落城邑广说流布。当知是人佛所护念。如是甚深般若波罗蜜中。有能信乐心无疑惑者。是善男子善女人。于过去诸佛。久已修学殖诸善根。譬如有人以手穿珠。忽遇无上真摩尼宝。心大欢喜。当知是人必已曾见。如是迦叶。若善男子善女人。修学余法。忽然得闻甚深般若波罗蜜。能生欢喜亦复如是。当知此人已曾闻故。若有众生。得闻甚深般若波罗蜜。心能信受生大欢喜。如是人等。亦曾亲近无数诸佛。从闻般若波罗蜜已修学故。譬如有人先所遥见城邑聚落。后若闻人赞叹彼城所有园苑种种池泉花果林树。男女人民皆可爱乐。是人闻已即大欢喜。更劝令说是城园苑众好严饰。杂花池泉多诸甘果。种种珍妙一切爱乐。是人得闻重甚欢喜。如是之人皆曾见故。若善男子善女人。有闻般若波罗蜜。信心听受能生欢喜。乐闻不厌而更劝说。当知此辈。已从文殊师利。曾闻如是深般若波罗蜜故。迦叶。白佛言世尊。若将来世善男子善女人。得闻是甚深般若波罗蜜。信乐听受以是相故。当知此人亦于过去佛所。曾闻修学。文殊师利。白佛言世尊。佛说诸法无作无相第一寂灭。若善男子善女人有能如是谛了斯义如闻而说。为诸如来之所赞叹。不违法相。是即佛说亦是炽然。般若波罗蜜相。亦名炽然。具足佛法通达实相不可思议

佛告文殊师利。我本行菩萨道时修诸善根。欲住阿鞞跋致地。当学般若波罗蜜。欲成阿耨多罗三藐三菩提。当学般若波罗蜜。若善男子善女人。欲解一切法相。欲知一切众生心界。皆悉同等当学般若波罗蜜。文殊师利。欲学一切佛法具足无碍。当学般若波罗蜜。欲学一切佛成阿耨多罗三藐三菩提时。相好威仪无量法式。当学般若波罗蜜。欲知一切佛不成阿耨多罗三藐三菩提。一切法式及诸威仪。当学般若波罗蜜。何以故。是空法中。不见诸佛菩提等故。若善男子善女人。欲知如是等相无疑惑者。当学般若波罗蜜。何以故。般若波罗蜜。不见诸法若生若灭若垢若净。是故善男子善女人应作如是学般若波罗蜜。欲知一切法无过去未来现在等相。当学般若波罗蜜。何以故。法界性相无三世故。欲知一切法同入法界心无挂碍。当学般若波罗蜜。欲得三转十二行法轮。亦自证知而不取着。当学般若波罗蜜。欲得慈心遍覆一切众生而无限齐。亦不作念有众生相。当学般若波罗蜜。欲得于一切众生不起诤论。亦复不取无诤论相。当学般若波罗蜜。欲知是处非处十力无畏。住佛智慧得无碍辩。当学般若波罗蜜。尔时文殊师利。白佛言世尊。我观正法无为无相。无得无利。无生无灭。无来无去。无知者。无见者。无作者。不见般若波罗蜜。亦不见般若波罗蜜境界。非证非不证。不作戏论无有分别。一切法无尽离尽。无凡夫法。无声闻法。无辟支佛法。佛法非得非不得。不舍生死不证涅槃。非思议非不思议。非作非不作。法相如是。不知云何。当学般若波罗蜜

尔时佛告文殊师利。若能如是知诸法相。是名学般若波罗蜜。菩萨摩诃萨若欲学菩提自在三昧。得是三昧已。照明一切甚深佛法及知一切诸佛名字。亦悉了达诸佛世界无有障碍。当如文殊师利所说般若波罗蜜中学

文殊师利。白佛言世尊。何故名般若波罗蜜。佛言。般若波罗蜜。无边无际。无名无相。非思量。无归依。无洲无渚。无犯无福。无晦无明。如法界无有分齐。亦无限数。是名般若波罗蜜。亦名菩萨摩诃萨行处。非行处非不行处。悉入一乘名非行处。何以故。无念无作故。文殊师利。白佛言世尊。当云何行能速得阿耨多罗三藐三菩提。佛言文殊师利。如般若波罗蜜中所说行。能速得阿耨多罗三藐三菩提。复有一行三昧。若善男子善女人。修是三昧者。亦速得阿耨多罗三藐三菩提。文殊师利言。世尊。云何名一行三昧。佛言。法界一相系缘法界。是名一行三昧。若善男子善女人。欲入一行三昧。当先闻般若波罗蜜如说修学。然后能入一行三昧。如法界缘。不退不坏。不思议无碍无相。善男子善女人。欲入一行三昧。应处空闲舍诸乱意不取相貌。系心一佛专称名字。随佛方所端身正向。能于一佛念念相续。即是念中。能见过去未来现在诸佛。何以故。念一佛功德无量无边。亦与无量诸佛功德无二。不思议佛法等无分别。皆乘一如成最正觉。悉具无量功德无量辩才。如是入一行三昧者。尽知恒沙诸佛法界无差别相。阿难。所闻佛法。得念总持辩才智慧。于声闻中虽为最胜。犹住量数则有限碍。若得一行三昧。诸经法门一一分别。皆悉了知决定无碍。昼夜常说智慧辩才终不断绝。若比阿难多闻辩才。百千等分不及其一。菩萨摩诃萨应作是念。我当云何逮得一行三昧不可思议功德无量名称。佛言。菩萨摩诃萨。当念一行三昧。常勤精进而不懈怠。如是次第渐渐修学。则能得入一行三昧。不可思议功德作证。除谤正法不信恶业重罪障者。所不能入。复次文殊师利。譬如有人得摩尼珠示其珠师。珠师答言此是无价真摩尼宝。即求师言。为我治磨勿失光色。珠师治已。随其磨时。珠色光明映彻表里。文殊师利。若有善男子善女人。修学一行三昧不可思议功德无量名称。随修学时知诸法相。明达无碍功德增长。亦复如是。文殊师利。譬如日轮光明遍满无有灭相。若得一行三昧。悉能具足一切功德无有缺少。亦复如是。照明佛法如日轮光。文殊师利。我所说法皆是一味离味解脱味寂灭味。若善男子善女人。得是一行三昧者。其所演说亦是一味离味解脱味寂灭味。随顺正法无错谬相。文殊师利。若菩萨摩诃萨。得是一行三昧。皆悉满足助道之法。速得阿耨多罗三藐三菩提。复次文殊师利。菩萨摩诃萨。不见法界有分别相及以一相。速得阿耨多罗三藐三菩提相不可思议。是菩提中亦无得佛。如是知者。速得阿耨多罗三藐三菩提。若信一切法悉是佛法。不生惊怖亦不疑惑。如是忍者。速得阿耨多罗三藐三菩提。文殊师利。白佛言世尊。以如是因。速得阿耨多罗三藐三菩提耶。佛言。得阿耨多罗三藐三菩提。不以因得不以非因得。何以故。不思议界。不以因得不以非因得。若善男子善女人。闻如是说不生懈怠。当知是人已于先佛种诸善根。是故比丘比丘尼。闻说是甚深般若波罗蜜。不生惊怖。即是从佛出家。若优婆塞优婆夷。得闻如是甚深般若波罗蜜。心不惊怖。即是成就真归依处。文殊师利。若善男子善女人。不习甚深般若波罗蜜。即是不修佛乘。譬如大地一切药木皆依地生长。文殊师利。菩萨摩诃萨亦复如是。一切善根。皆依般若波罗蜜而得增长。于阿耨多罗三藐三菩提。不相违背。尔时文殊师利。白佛言世尊。此阎浮提城邑聚落。当于何处演说如是甚深般若波罗蜜。佛告文殊师利。今此会中若有人闻般若波罗蜜。皆发誓言。于未来世常得与般若波罗蜜相应。从是信解未来世中能听是经。当知是人不从余小善根中来。所能堪受闻已欢喜。文殊师利。若复有人从汝听是般若波罗蜜。应作是言。此般若波罗蜜中。无声闻辟支佛法佛法。亦无凡夫生灭等法。文殊师利。白佛言世尊。若比丘比丘尼优婆塞优婆夷。来问我言。云何如来。说般若波罗蜜。我当答言。一切说法无诤论相。云何如来。当说般若波罗蜜。何以故。不见有法可与诤论。亦无众生心识能知。复次世尊。我当更说究竟实际。何以故。一切法相同入实际。阿罗汉无别胜法。何以故。阿罗汉法凡夫法。不一不异故。复次世尊。如是说法。无有众生已得涅槃今得当得。何以故。无有决定众生相故。文殊师利言。若人欲闻般若波罗蜜。我当作如是说。其有听者。不念不着。无闻无得。当如幻人无所分别。如是说者是真说法。是故听者莫作二相。不舍诸见而修佛法。不取佛法不舍凡夫法。何以故。佛及凡夫二法相空。无取舍故。若人问我。当作是说。如是安慰如是建立。善男子善女人。应如是问作如是住心不退没。当知法相随顺般若波罗蜜说

尔时世尊。赞叹文殊师利。善哉善哉如汝所说。若善男子善女人欲见诸佛。应学如是般若波罗蜜。欲亲近诸佛如法供养。应学如是般若波罗蜜。若欲言如来是我世尊。应学如是般若波罗蜜。若言如来非我世尊。亦应学如是般若波罗蜜。若欲成阿耨多罗三藐三菩提。亦应学如是般若波罗蜜。若欲不成阿耨多罗三藐三菩提。亦应学如是般若波罗蜜。若欲成就一切三昧。应学如是般若波罗蜜。若欲不成就一切三昧。亦应学如是般若波罗蜜。何以故。无作三昧无异相故。一切法无生无出故。若欲知一切法假名。应学如是般若波罗蜜。若欲知一切众生。修菩提道。不求菩提相。心不退没。应学如是般若波罗蜜。何以故。一切法皆菩提相故。若欲知一切众生行非行相。非行即菩提。菩提即法界。法界即实际。心不退没。应学如是般若波罗蜜。若欲知一切如来。神通变化无相无碍。亦无方所。应学如是般若波罗蜜

佛告文殊师利。若比丘比丘尼。优婆塞优婆夷。欲得不堕恶趣。当学般若波罗蜜。一四句偈受持读诵。为他解说随顺实相。如是善男子善女人。当知决定得阿耨多罗三藐三菩提。则住佛国。若闻如是般若波罗蜜。不惊不畏心生信解。当知此辈佛所印可。是佛所行大乘法印。若善男子善女人。学此法印超过恶趣。不入声闻辟支佛道。以超过故。尔时帝释三十三天。以天妙花优钵罗花。拘物头花。分陀利花。天曼陀罗花等。天栴檀香。及余末香。种种金宝。作天伎乐。为供养般若波罗蜜并诸如来及文殊师利。以散其上。作是供养已。愿我常闻般若波罗蜜法印。释提桓因。复作是愿。愿阎浮提善男子善女人。常使得闻是经。决定佛法皆令信解。受持读诵为人演说。一切诸天为作拥护

尔时佛告释提桓因言。憍尸迦。如是如是。善男子善女人。当得决定诸佛菩提。文殊师利。白佛言世尊。如是受持善男子善女人。得大利益功德无量。尔时以佛神力。一切大地六反震动。佛时微笑。放大光明遍照三千大千世界。文殊师利。白佛言世尊。即是如来。印般若波罗蜜相。佛言文殊师利。如是如是。说般若波罗蜜已皆现此瑞。为印般若波罗蜜故。使人受持令无赞毁。何以故。无相法印不可赞毁。我今以是法印。令诸天魔不能得便。佛说是经已。尔时诸大菩萨及四部众。闻说般若波罗蜜。欢喜奉行

大宝积经卷第一百一十六大宝积经卷第一百一十七

        西晋三藏竺法护译

    宝髻菩萨会第四十七之一

闻如是。一时佛在罗阅只灵鹫山。与大比丘众四万二千。菩萨八万四千俱。各从十方诸佛世界。而来集会。皆已通达。一生补处。得无所著无所挂碍。从勇猛伏三昧出生。获上莲花三昧。金刚道场三昧。善坚住三昧。淳淑修三昧。幢英王三昧。金刚三昧。净德事三昧。分别权行。皆得亲近诸佛之法。在佛树下多所降伏。度诸魔界。而得建立诸佛之土。逮成无尽所说总持。得知众生一切根原。以妙辩才可悦诸心。为师子步猛无所畏。若入众会。应顺时宜宣文字句。成就诸行。则以威相而自严饰。舍于世财弃诸外道。功勋显布声彻十方。诸佛咨嗟德不可量。悉从布施持戒忍辱精进一心智慧而成。从无数劫百千那术。修治道业。睹见一切众生之疾。应病与药皆令瘳愈。入于深妙明缘起法。以舍断灭有常之事。其行清净志无瑕秽。心性鲜明开化群生。各各摄护令得其所。晓了教诲意得自在。势力坚强不毁慈心。信戒闻施惭愧智慧。具足七财欲化众生。以善方便现处闲居。所用修力。善誓诸愿。圣德无量心如虚空。其名曰光观菩萨。常明曜菩萨。光世音菩萨。大势至菩萨。师子意菩萨。师子步菩萨。师子雷音菩萨。尊意菩萨。金刚意菩萨。金刚步菩萨。金刚幢菩萨。金刚志菩萨。步不动迹菩萨。独步世菩萨。善明菩萨。莲花目菩萨。莲花净菩萨。宝净菩萨。钩锁菩萨。宝幢菩萨。宝事菩萨。宝印手菩萨。德曜王菩萨。净王菩萨。执离意王菩萨。电光严菩萨。虚空藏菩萨。濡音菩萨。雨音菩萨。不离音菩萨。意净菩萨。电音菩萨。解缚菩萨等。十六正士溥首之等。六十圣士众香首等。三十有二清净行士慈氏之等。皆是贤劫诸菩萨也。降魔天子。净复净天子。善妙天子。贤护天子。获胜天子。意胜天子。寂化音天子。善思天子。等类二万皆悉大乘。四天王天帝释忍迹梵天。魔子导师。濡美天子。并余诸天龙神。揵沓和阿须伦迦留罗真陀罗摩睺勒等及人非人。不可称计。彼时世尊。与无央数百千之众眷属围绕。而为说经。坐大清净师子之床。勇猛无畏为师子吼。如日普照若月盛明。如火消冥。其座晖赫威光巍巍。超踰释梵。佛身特显。犹须弥山现于大海。所说经典上中意语靡不妙善。义美具足究竟清净。常修梵行广演恩慈。宣菩萨行讲菩萨法。所当遵修名曰净行。尔时东方去此佛国。九百二十万佛土。世界名善变。其佛号净住如来至真等正觉。现在说法。时佛左右有一菩萨。名罗陀邻那朱(晋曰宝髻)与八千菩萨俱。于其佛土忽然不现。至此忍界住于梵天。以一宝盖覆斯三千大千忍土。普雨天华其色若干。在于梵天。而说颂曰

  诸天人民获善利　　心愿见佛释师子
  为消恼热诸俗事　　心愿坚固志佛道
  无数菩萨如江沙　　以精进力行超越
  降伏魔众亿百千　　得成佛道离垢忧
  吾从东方而发来　　其世界名曰善变
  在彼净住佛左右　　欲得稽首释师子
  假使有人欲听法　　若睹十方诸菩萨
  设欲归礼彼世尊　　速疾来到灵鹫山
  诸导师众难得遇　　经典之要甚难值
  人身难得及闲暇　　笃信禁戒诚亦难
  假使今时造德本　　则见众生处邪冥
  便能开心令灭度　　速行俱诣于最胜
  若欲解弃三恶道　　获致安隐天人处
  逮得无为消生死　　则当往诣无等伦
  为良医王施甘露　　尊犹导师示正路
  彼为法王执尊宝　　降伏一切众生趣

于时宝髻。说斯颂已。以此颂音。告于三千大千世界。贤者舍利弗。闻说斯颂。前白佛言。唯然世尊。此妙颂义为从何出。佛言。东方去此。九百二十万佛界名善变。佛号净住如来至真等正觉。现在说法。其佛左右有菩萨名宝髻。与八千菩萨俱。到此忍界欲来见佛。稽首问讯咨受经典。并欲见十方诸会菩萨。故住梵天说此颂耳。斯颂之音。普闻三千大千世界。令无央数众生之类殖众德本。俱来诣佛。于是宝髻与八千菩萨及无央数诸天子众。周匝围绕。鼓百千伎。雨诸妙花。演大光明动三千界。往诣佛所稽首足下。各绕七匝正住佛前。八千菩萨亦复如是。诸天子众悉皆侍从。宝髻菩萨。前白佛言。唯然世尊。净住如来敬问无量。所志康宁。住于轻便势力安乎。蒙天中天鄙身诣此。愿垂恩慈。为诸菩萨大士之众。班宣道教所当应行。菩萨住此。得究竟成具足清净。而普被服一切德铠。积累众善平等之行。净修其身。皆见一切群生所念。观其相行。而随开化则以智慧。为淫怒痴。而讲说法令致妙行。若有众人住于邪法。便为演示平等之教。为诸如来所见覆盖。众生之类皆得蒙赖。一切诸魔不能得便。逮睹诸佛无所挂碍。敢可遵修皆成如来清净之行。如此之义何因致乎

佛告宝髻。善哉善哉。族姓子。乃问如来如此之义。谛听谛听善思念之。吾当解说。诸菩萨等所行清净。宝髻菩萨。与诸大众受教而听。佛告族姓子。菩萨有四事法所行清净。何谓为四。一曰行度无极。二曰常当遵修诸佛道品。三曰具足神通。四曰开化众生。是为四。行度无极。所可劝助。靡不周普入众德本。道品法者。游于大慈。晓了应时慧之所入。具神通者。分别人民心念所行善恶之业。化众生者。大哀坚固。明识志性之所归趣

佛告族姓子。何谓菩萨施度无极所行清净。谓所可习悭贪之心。皆弃捐之习布施心。已能放舍坏于贪懿瑕秽之事。兴劝布施。一切所有惠而不吝。彼行施已。而于四事不造若干。何谓为四。一曰众生之类无有若干。二曰一切经法不各各异。三曰所可劝助亦无差别。四曰志性所施亦无若干。彼何谓于诸众生无有若干。不兴此念吾当施某不施于甲。施某福多施甲福少。厚施于某薄施于甲。好供施某趣施于甲。常当施某时一施甲。亲自斟酌授与于某。不自劳身授与于甲。尽用施某粗施于甲。此人奉戒斯人毁禁。此人众祐斯人寡祐。此人能毕众祐之德。斯人不能。此人修正斯人行邪。此人奉行平等之业。斯人堕落反邪之业。佛言。如是族姓子。菩萨布施。皆当弃捐如是辈心。修平等志不怀若干。常念众生等心应之。而以开化平意识戒。慈悲喜护无所遗忘。所谓等者。犹如虚空都无增减。是谓众生无有若干。佛告宝髻。何谓诸法不各各异。假使说法而宣平等。亦不念言。奉修法者吾当与经。不能顺法则不授也。若使普备一切法者。吾当与之。不能具法吾不与也。欲兴道教行法施者。施于凡夫不谓损耗。施于圣贤不谓长益。又计诸法本悉清净等无差特。以是之故所施当等。是于诸法不各各异。彼所施与供养之具。有所劝助亦无若干。若布施时不作此念。吾当获福望于帝释梵天人位。不愿国主豪尊长者。亦不慕求色声香味细滑之法。不志饶财珍宝重货眷属侍从。亦不贪羡五趣生死。所周旋处。不求声闻缘觉之乘。敢可所施则用志求无上正真之道。是谓劝助而不差别。诸可放舍。志性在道无差特心。合会别离初无增减。不望相报。唯欲开度诸不及者越于彼岸。其心质朴而无谀谄。怀抱笃信内性淳淑。未曾悔变。施所珍爱其心欢喜。若有来求意能惠与。益用悦豫。是族姓子。志性所施亦不别异。斯谓菩萨施度无极无有若干

佛言。复有八事。弃捐邪径行布施业。何谓为八。不见吾我。不见有人。不见有寿。不见断灭。不睹有常。不住三处。不见无处。若布施者。则当严净于是八事。菩萨布施弃四住业。何谓为四。一曰舍于非法。则以经典开化凡夫。二曰舍声闻意志于大道。三曰舍缘觉法修于平等。四曰远于止处诸所倚着。是为四。当复离于四事思想。何谓为四。一曰常想。二曰安想。三曰净想。四曰我想。是为四。复有四事。为清净施。何谓为四。一曰身净。二曰言净。三曰心净。四曰性净。是为四。复有三事施。越诸挂碍。何谓为三。一曰舍于悕望。二曰弃捐怀恨。三曰离于小乘。是为三。复有三事。舍于应施离诸恐惧。何谓为三。一曰贡高。二曰轻慢。三曰魔业。是为三。复有四施以法见印。何谓为四。一曰内空。二曰外空。三曰人空。四曰道空。是为四。复有四施专惟精进。何谓为四。一曰饱满众生。二曰具足诸佛之法。三曰备悉成就相好严容。四曰净治佛土。是为四事。复有四施心常不舍。何谓为四。一曰意常念道。二曰常欲见佛。三曰修于大慈。四曰灭除众生尘劳之秽。是为四。复有三施严净道场。何谓为三。一曰净我。二曰净人。三曰至道场净。是为三。复有四施所与清净。何谓为四。一曰以慧布施。二曰则能可悦众生之心。三曰晓了劝助。四曰明解观察经典。是为四。佛告族姓子。是为菩萨所可修法施度无极致清净行

佛告族姓子。菩萨行戒度无极。有一事致于清净。何谓为一。解菩萨心而无等伦。其心超过一切世间。最尊无比。越诸声闻缘觉之意。心能降伏一切诸魔。入于众生。所至名德为无量宝诸遵习法。普有所护心未曾忘。是为一。复有二事。戒度无极为清净行。何谓为二。一曰常怀慈愍无害众生。二曰心志于道调柔性行。是为二。复有三事戒无极净。何谓为三。一曰身净。净身三事戒无阙漏究竟备悉。二曰言净。一切所说无有谀谄。三曰意净。蠲除诸秽贪欲危害。是为三。复有四事戒无极净。何谓为四。一曰其戒清净。二曰奉禁不毁。三曰以此戒法教化众生。四曰见持戒人敬之如佛。是为四。复有五事戒无极净。何谓为五。一曰不叹己身。二曰不毁他人。三曰舍声闻志。四曰离缘觉意。五曰无所贪着。是为五。复有六事戒无极净。何谓为六。一曰常念于佛不毁禁戒。二曰常念经法顺修其行。三曰常念圣众不违佛教。四曰常念于施普舍尘欲。五曰常念禁戒。不复贪慕一切五趣。六曰常念诸天宣众德本。是为六。复有七事戒无极净。何谓为七。一曰笃信乐诸佛法。二曰常自念惭为众重任。三曰念愧思道品法而不自大。四曰仁和不恼彼我。五曰无害畏于后世殃罪之患。六曰不烦扰人止心忧戚。七曰见诸众生在苦恼者。而愍哀之。是为七。复有八事戒无极净。何谓为八。一曰无有谀谄。二曰无希冀心。三曰不贪利养。四曰舍于悭懿无所依倚。五曰己身所有而知止足。六曰行贤圣禅具足澹怕。七曰处于闲居不惜身命。八曰乐于独处远离众会好于道法。畏惧三界不取无为。是为八。复有九事戒无极净。何谓为九。一曰无所趣律。教化众生而令得度。二曰稍渐习定修治其原。三曰令心究竟不怀恼热。四曰求于静漠止心所念。五曰习行威仪礼节之正。六曰超度禁戒不见己身。七曰未曾欺惑。愍哀群生具足大乘。八曰究竟成就戒法之业。使不缺漏。九曰心常怀念劝助德本。是为九。复有十事戒无极净。何谓为十。一曰净身三事。二曰净口四事。三曰净意三事。四曰念弃谀谄。志性质直而不细碎。五曰心性普入靡不蒙度。六曰一切所觉而知节限。愍哀为本悉解诸结。七曰心无刚鞕。教化众生悉调和业。八曰常修己身。见诸等类恂恂恭敬。九曰于诸众祐劝示法事。十曰奉以衣食使离世业。是为十。复有二事戒无极净。何谓为二。一曰有毁辱者。宁失身命终不毁戒。不兴想念。不慕财业。二曰无所周旋亦不贪求。一切诸法戒空无像。复有二事。何谓为二。一曰内净。除诸衰入。二曰外净。舍诸境界。是为二。复有二事。一曰净其道心解自然相故。二曰戒品清净无诸相故。佛告族姓子。是为菩萨戒度无极清净之行。佛告族姓子。何谓菩萨忍度无极所行清净。若骂詈者默而不报。是口清净。若挝捶者受而不校。是身清净。若嗔恚者哀而不愠。是心清净。若毁辱者而不怀恨。是性清净。又若闻人发粗犷辞。以护众生不兴忿恨。设有刀杖加身瓦石打掷。护于后世而不怀害。节节解身不以忧戚。将顺道故。见人求乞不起嗔恚。济四恩故发于慈心。不恼恚者。亲佛道故。造悲哀心具足愿故。功勋流布莫不奉命。多所愍故。仁心德称所可布施。为道法行弃魔天故。又念佛道而行忍辱。成佛身故。若念觉意而行忍辱。具十力故。若念于惠而行忍辱。欲备三达无挂碍故。设念愍伤而行忍辱。成大慈故。念度虚妄而行忍辱。究大哀故。念如师子。无恐惧者。而行忍辱。无所畏故。念无见顶而行忍辱。处于众生不自大故。念具相好而行忍辱。普欲救济一切世故。具诸佛法而行忍辱。成通慧故。佛告族姓子。有二事法净忍辱力。一曰精修道业。二曰合集义力。彼所可言。若能忍辱身心无倚。是集义力。于一切法而无所著。行忍辱者。是修道义。有净忍者能忍众生。了知无人堪任诸法。悉为澹怕。是为净忍。所以者何。于彼亦无可忍及与非忍。于一切法无所逮得。乃名曰忍。计于忍者亦不可获。于一切法无所著者。乃名曰忍。其无所倚忍无处所。不受诸法。是曰为忍。不以所取为忍辱也。其有不计我人寿命之法。是曰忍辱。不着身命。察如墙壁瓦石之数。乃曰为忍也。佛告族姓子。菩萨有二忍。一曰晓了身分散事。二曰明识诸法皆悉本无乃成忍辱。是为菩萨忍。度无极行清净也

佛告族姓子。何谓菩萨进度无极为清净行。不舍道心。所可兴业未曾怯弱。常遵勤修而不睡寐。不离德本积累功德。不以退还于度无极。若造行者方便求法。堪任为人讲说经典。护于正法多所度脱。不厌大慧开化众生。严净佛土度于小乘。具足本愿究竟圣慧。未曾违失施戒博闻。亲近权慧已至福家。当以何意勉济群生令无憍慢。是谓精进。彼何谓净。若晓了身犹如影响。所言柔软识不以倦。其慧究竟而心净寂。明于所行永不可尽。分别诸灭以慧消化。而成一心慧无所起。彼以三事离于精进。一曰倚着因缘。二曰行颠倒事。三曰望想之灭。若于三界无所倚着。是为精进。复有三事。何谓为三。眼无所著。不倚于色不贪于识。耳声识。鼻香识。舌味识。身暖识。意法识。亦复如是悉无所著。彼无所受亦无所习。故曰精进。无施不悭。无戒不犯。无忍不诤。无进不殆。无禅不乱。无智不愚。不造德本亦无不善。不求佛道。不得声闻缘觉之地。其无所行亦无不行。则便逮成二精进净。何谓二。一曰内无所住兴诸因缘。二曰舍于外见众想诸识。是为二精进。复有二净。何谓二净。一曰于内寂定。二曰不游于外亦无放逸。是为二净。其根精进于诸所行而无所行。亦不轻戏。是为菩萨进度无极清净之行

佛告族姓子。何谓菩萨寂度无极清净之行。殷勤合集一心之事。观所应察而以正受。彼若一心禅不着色。弃捐痛痒思想生死识。彼若禅者。不着眼耳鼻舌身意识。彼若禅者。不贪色声香味细软法。彼若禅者。不着地水火风空。不着帝释日月梵天尊豪之位。不着欲色无色之界。不倚今世及与后世。不住于身亦无所处。不倚言辞心不疲懈。悉无所住无卒无暴。不住边际得无所念。彼若禅者。不计有身。不兴诸见。不贪我人寿命。不见微妙可不可事。不见断灭不睹无常。不见生灭有处无处。彼若禅者。亦不永尽众漏之源。不着诸佛。不入寂灭果证之迹。亦不长处于无所行。若行禅者。一心解空不以空为证。求于无相无愿。不以无相无愿为证。被大德铠行无极慈。住于大哀。一切具足奉行空事。何谓具足行空。不想布施持戒忍辱精进一心智慧。不想善权诸所开化。不想慈悲喜护。亦不悕望入于圣慧。不想道心有所观察。不想志性意有所应。不想四恩慧施仁爱。利人等利一切救济。不想其意安详而有所存。不想意止。意断神足。根力觉意。及八由行。不想寂默而观察法。不想调定柔濡之行。不想惭愧有所羞耻。常住佛道未曾断绝。随法眼教执于炬曜。从圣众戒常修鲜洁。立观众生成就佛身。以德庄严而从世雄。闻具足音奉佛三昧。获于正觉神足之辩。受十种力住无所畏。逮于微妙十八不共诸佛之法。不与声闻缘觉合同。拔去止处诸欲尘秽。不离神通开导众生。四分别辩精进明了。现世度世之法。教化众生。与众超异质直出家。度于驶水而过泛流。断诸所有所可住处。自然静寞法教澹怕。观于身法无所贪爱。志于佛法了自然想。越诸住行默口言辞。有所说者常宣佛语。以此至诚消灭常然。开化众生。是曰具足行空。佛告族姓子。譬若三千大千世界。所有人民悉为画师。各有所习巧能不同。所善不等。或工画屋宅不工画体。或便摸者不能博彩。或工于手足巧于耳目。或头首不端身形姝好。或有不能。所习各异。或能可人或不可人。所知殊别容貌不同。王尽召画师。应时皆至。王令画作三界诸形而告之曰。各自画像以持示吾。皆合众师聚于一处。各各画形。一师最上悉得其体。族姓子。所忆云何。为能普备诸所能不。答曰唯能。佛言。借引为喻。当解斯义。如一画师悉图诸形。各各得体不失其旨。其学此法亦复如是。殷勤精进净修梵行。逮成佛法。以一正行悉具众事。由此之故。具足空行靡所不达。便得成就一切佛道。皆除尘欲颠倒众想。贡高自大不乐放逸。虽处众秽不与合同。是谓菩萨具足空行。说是语时。八千菩萨普备空行。逮得法忍。是为菩萨寂度无极清净之行。佛告族姓子。何谓菩萨智度无极清净之行。有十二事为清净行。何等十二。见于过去慧无挂碍。见于当来慧无挂碍。见于现在慧无挂碍。有为无为皆能晓了。一切世间所有术艺。当可造业明解度世。分别说于真谛之义。知其所习宣其本末。一切众生诸根所趣。柔劣明达中容之人。去来之慧无所挂碍。其圣巍巍超逾世智。悉见众生志性所行。形色变异。难解难逮深奥之义。消化诸见。离于众邪诸所住处挂碍之事。入于圣慧普周众生入于法慧。明解圣藏义之所归。了真所入。其明所照无所错乱。亦无所碍。观察时节所乐无量。所见诸事咸皆了了。无所违失。觉识诚谛实不灭尽。彼所观察一切无拒。以用一行而无所行。皆见众生之所奉行。威仪礼节。世间人民心志所趣。菩萨悉见。不离于世而皆超度诸世境界。尚未成就佛之土地。皆越一切所作因缘。开化众生。过于诸行而普究竟众德之行。广度一切因缘心行。皆见众生心之所念。护世间法莫不周遍。不舍世俗所行信入众生之念。计其智慧无有卒暴。不犯巇崄诸根寂定。未曾疲懈不以为乱。永观圣慧常与德合。诣于佛树而坐道场。降伏众魔舍于外道。行有所受圣曜普彻。亦无所取。大圣所逮。得诸佛住可悦众生。悉见定慧普入众义。一切诸法皆为同味。执权方便智度无极。越于彼岸不可限量。此乃名曰智度无极。皆能晓了一切因缘。所兴众想。瑞应怪变。心行所念。令得过度。是则名曰度于彼岸。又计此慧有二清净。一曰无碍慧想清净之行。二曰严净。莫能有人当其慧相。复有二净。一曰净除颠倒。二曰净去诸见。又彼菩萨所行智慧靡不普入。圣明备悉。晓了众生达识经典。其菩萨者。以此智慧解无所有。皆入劳尘亲化爱欲。在诸所生处于诸界。建立智慧游诸境土。皆了境界。诚谛智慧。不度彼此不处中间。其慧普入。见于十方无所挂碍。用无荫蔽致无边际。见诚谛慧。明晓一切诸法本末部党时节。已能识别真谛智慧义之所归。无应不应。无合无别。无懈无进。不双不只。计于诸法亦无应合。又族姓子。菩萨若行智慧事者。以慧为舍则成福堂。笃信名德道法之室。住于总持。分别智辩。一切备悉具足慧事。是族姓子。菩萨奉修智度无极清净之行。说此语已。彼时会中二万二千人。皆发无上正真道意。八千菩萨。逮得无所从生法忍。五千比丘漏尽意解。一万天子。远尘离垢诸法眼净。时诸天子举声叹曰。若有众生。逮得闻是诸度无极清净之行道法门者。则为诸佛所见授记。何况有闻能奉受持讽读诵。行如上教乎。佛告宝髻。何谓菩萨佛道品法清净之行。自观其身知本无身。是为意止。则以二事而立其志。何谓为二。一曰察于荒秽。二曰观清净行。何谓荒秽。此身无常积满不净。是身薄力劣而无势。是身化立如倾危屋。何谓观净。吾当以此不净之身精勤解空。得如来身法身。法身巍巍德身无限。为诸众生示现色像悦可一切。是族姓子。观身二事以立其意。又族姓子。菩萨观身了无身已。得净二法。何谓为二。一见无常。二察有常。是身无常不得久立。老病俱合会当归死。已达此义。不用身故而造邪业。以不会身则修坚要。行三坚法。一曰身要。二曰命要。三曰财要。此身无常。一切众生以为贵重。何所益乎。当行愍伤。何谓身要。身不犯恶谦卑恭顺稽首博智。何谓命要。归命三宝。奉修十德六度四等。何谓财要。捐已布施给诸贫乏。身非我有。口之所言皆多有失。从致谀谄粗辞不正。用是之故。悉弃此行不复为非。已见无身不保寿命。假使被害不犯恶事。晓身非常为分离法。不犯非宜。一切所有施无所贪。已解无身。所获善德功勋显著。不可称限。何谓有常。设使观身了无身者。以时摄取心所了慧。劝一切智不违佛教。不失法言不坏圣众。劝化群黎执御人民。是谓有常。所以言常不可尽故。所言无尽谓无为也。与道合同。无终无始玄妙永存。此谓无为。其无为者乃为常耳。菩萨在彼以诸德本。观诸通慧至于无为。是谓有常。所以言常。以空无相无愿之故。修菩萨道常奉空行。观于无相不着无愿。普具一切精进之行。是谓有常。所言常者谓如虚空。菩萨等心。如空无异无有思想。如是行者乃为菩萨。是谓有常无上正真

佛告族姓子。菩萨观身了本无身。则曰意止。一切人身皆悉本空。以解身空意无所著。观众生身立在佛身。当作是观。若如来身无有诸漏。吾身亦然。察于诸法奉行道义。不失佛教。得无漏身而观众生。分别诸相以无漏身。无漏清净本际亦净。如其德本。兴立诸行劝助德本。亦无诸漏。以能逮成无漏法者。能住诸漏。何谓诸漏。一曰欲漏。二曰有漏。三曰见漏。彼断欲漏。设生欲界开化众生。若断有漏。游在生死。于诸所受教授人民。又见漏者。则是无明痴冥之漏。菩萨于彼精进不懈。究竟精进拔其根原。彼若观身奉修意止。超度往古诸不应行。离于众秽而遵澹怕。乃为观身便无所度。亦无所生则无所为。乃为观身。假使观已不见有身。亦无所察。舍于贪身不计吾我。已无吾我则无所贪。已无所贪则无所诤。已无所诤则无殃衅。已无殃衅逮得法忍。已得法忍则无所归。已无所归则无卒暴。已无卒暴不住自大。则住于法。已住法者不行非法。顺法行者常与法俱。修道法者则逮法慈。已受法慈则闻法音。已行法音不闻界音。已寂界音便逮三昧。而已正受则观审谛。已观审谛则无所想。已无所想则无所作。已无所作则无非作。已于诸作无作非作。致正真法便等诸法。已等诸法。便逮通慧一切之智。是族姓子。菩萨观身了本无身。意止行净

佛告族姓子。何谓菩萨痛痒意止。谓观痛痒本无痛痒。乃为意止。睹诸苦痛。皆见众生诸在患难。为之雨泪逮成大哀。作是惟念。众人在恼。若得安者乃无痛痒。则为断除一切危害。乃致观痛知本无痛。意止所行已灭痛痒。为诸群生被大德铠。先自消身非法之行。亦不想念灭已痛痒。若有遭痛。普为一切执御大哀。为示永安长消众患。为贪欲人兴发大哀。先除己贪不为欲缚。设身遇苦不以为难。为嗔恚人兴发大哀。断己恚结。彼则观见不苦不乐之痛痒也。为愚行人兴发大哀。灭已痴缚。彼观痛乐则无所著。消坏诸结而自由安。若得苦痛不以忧戚。舍诸有为。则能遵修令无苦乐。以坏愚痴。若遇乐痛无所积聚。若遭众患了身非常。观苦痛痒察痛无我。彼观乐痛修行安隐。其观苦痛则为疮病。以是之故。名曰不乐不苦。设使观见诸所有安皆归无常。其有众苦。计于苦者不苦不乐。则亦无我。菩萨若见诸安乐事。明识一切本则无安。是观痛痒。知痛无本适起寻灭。晓了诸法不得久存。察于万物焰生忽没。视一切法所生如影。从何所来而寻散灭。观诸法本如瞻手掌。从何所来去至何所。即便了之。无所从来去无所至。以观诸法不以为患。普见一切笃信休息。因此成道以成于道。亦无所得不复退还。所以者何。以能逮见一切众人。根本所兴则求灭尽。不为己身而求灭也。是族姓子。菩萨大士。善权方便执御大哀。观于痛痒。了本无痛意止之行。消诸所见。明识于此。不以遇于三界诸痛。灭取证际也。彼于众痛观佛叹本。晓了诸痛寂默恬澹。本无所有。亦无遭患永无遭患。诸法皆空离于吾我。徒见合会依于因缘。悉无有主亦无吾我。舍诸所见无所长育。彼观如是。则真谛见。因缘所合皆不可得。已不可得。便作是察如因缘空。从是兴立诸法亦空。已达空义。乃为观痛本无痛痒。为意止也。所谓寂寞身澹怕故。选择诸义道圣慧。是族姓子菩萨观身痛痒了本无痛。意止净行。佛告族姓子。菩萨观心了本无心。为意止行。立于道心以得立心。以己意慧求其心本。不见内心不见外心。不住内外。察其心本不见五阴。无诸种无诸入。其心寂定。求其持处从何所起。则更思惟心从缘起。寻复思惟。其心为异。因缘异乎。即复自了。设因缘异其心异者。则有二心。设使因缘是心。心是因缘。以是之故心不见心。计于心者非不见心。犹如虚伪。无实诸尘住于虚空。利刀伤指本时为疮。指疮已差无所患苦。如是族姓子。心亦如是。由是之故心不见心。心所见者则无所见。应观如是心所住处亦不起罪不见断灭。不念常存亦无有身。身如墙壁。因缘不乱不离愍伤。亦不有是亦不有异。是为心也。持心如是。心动为法。心无所住亦无所行。心不可见心相自然。作是晓了。所见若兹不离所见。其心寂然明识无本。是为菩萨观心无心为意止也。又族姓子。设心不起而不可见。则无有想无应不应。亦无轻慢则不放逸。是为观心。知本无心为意止也。又如心无色。其因缘合及与辩才。亦复如是。德本无色。如心无为。德亦无色。所劝道心亦复无色。设使道心及与劝助无有形色。道亦如是悉无所有。是故言曰。如其心者行亦如之。计若劝助道心亦如。如其道心人心本净。亦复如是。道心本净。一切诸法亦复如斯。如此心者晓了普入。是为菩萨观心无心为意止也。众患所恼未曾停住。犹如猕猴及河驶水。亦若油灯光曜所出忽然远游。无有身形而易退转。贪吝诸界六情之患。以为屋宅。须臾变异各随所应。心无有处而独游行。无有坚要亦无不要。寂然独观。是谓观心无心意止清净。心所入慧心之法界。慧心所住其明本净。鲜洁无秽。知心真谛心了现在目之所见心法平等。慧亦如心心等三世。已能平等便知真正。心慧自然无能护持。观不可见。是谓观心无心为意止也。计其本净则为自然。心亦本净了众生心。以心净故开化人民为其说法。以能解知己心自然。一切众生亦复自然。若能分别心如是者。见其心相而为说法。如心相自然众生心相自然如此。若能达斯相者。为其说法。己心则空。众生之心亦复为空。已解此空为其说法。等御己心。若能等御而为说法。己身则等。已等己心则等众生。已等众生则等诸法。已等诸法则等诸佛。晓此真谛。不令其心离于贪欲。不处于欲。心已止者。则入法界趣于自然。心无所住于法无动。是谓菩萨观心无心意止清净

佛告族姓子。菩萨观法知本无法。为意止行。即自念言。法起则起法灭则灭。计于本末亦无我身。人寿有命人与非人生老病死。终没所趣。于此诸法诸法合会。因其合会而为习俗。设无缘合则无有此。从其习乐因成缘会。则兴善本及与恶本。以归无常无有缘会。不从无习而起诸法。彼观如是晓了诸法。见所归趣亦无所有。空无相无愿。所作功德及无功德。彼诸所行如幻无常。当奉精进。设兴因缘。有十尊行极上无盖。除去因缘志于大法。何谓为十身净无秽。诸相种好无能见顶。超度一切诸所侵枉。志性清净。具足十事。其心清净具足正行。六十亿音口之所说。可悦众生。其心净者常怀慈仁。愍念一切无所加害。其意常定未曾有乱。辩才清净有所讲说应于法义。辩不可尽。大慈清净。劝化众生。一切令乐泥洹之界。大哀清净。无央数劫不厌生死。净十种力。晓了众生根原所念各各不同。清净无畏分别执御。无央数法众生积聚。欲具诸佛不共之法。去来今慧三世无碍。诸佛法净用能自在。归圣慧故。是为十。彼已逮此尊妙极上无盖大法十事之行。称量思惟不以厌倦。积累功勋。而不毁堕无德之行殷勤精进。何谓诸法根原所来令无处所。度于所住诸宿尘劳。已晓万物一切无常。便能兴成无常三昧。得是定者无坚要想。不乱三昧。从其本愿示所向生。来有所入而复出生。则以班宣功德之行。开化众生。是族姓子。菩萨大士善权方便。普说经典观于诸法。达本无法为意止也。其有致道遵修经典。若能晓了道品之法。不作众善不见有常。亦无所著不除恶法。道心所见所在无断。亦不计常不堕断灭。若有菩萨。弃捐见常断灭之事。执心平等而无所住。处于中间。何谓中间。不应念行无明众冥。悉除去此。是谓中间。无有教令无可诲授。无言无说。是谓中间。取要言之。无明行识名色六入触痛爱取有生老病死忧戚之患恼。无可会皆已除尽。是谓中间。其所教者无有智慧。亦无处所。是谓中间。其中间者。无有驿使亦无遣者。如是宿处。计彼所有。无有教令无训诲者。计是本末不可决了。未有所处不可捉持。则无所著。寂寞澹怕忽然已灭。是谓中间。譬族姓子。呼响所出无有处所。其趣亲近音生于对。若见谛者堕于真伪。是为中间。无言无说。彼则无见亦无所处。如是族姓子。所因兴发。识色之事。及所教令。所因合成从二缘对。其中间者无教无说。是谓中间。因缘合成不用义理。其义理者则不可得。其不可得则不重来。其不重来是谓中间。又计我者。则了无我灭寂于此。于我不我自然清净。是处中间计人寿命。于人寿命而无所见。清净自然。是谓中间。于想无想而无想乐。是谓中间。所兴颠倒所得之事。而无所有。是为中间。虚妄愚痴至诚之教。悉不可得。是谓中间。此岸彼际消化己身。令无所著。有为无为不行诸习。是谓中间。蠲除生死而去泥洹。悉无言教。是处中间

佛告族姓子。其观于法了法本无。为意止者。不坏法界其意自然。而得意止。彼导法界晓了诸法。计其法界及与人界。于彼法界。亦无所坏不毁人界。人界法界此二事者。等如空界。彼以一界普见诸法。以慧眼见。则用法界观佛所行。假使有人不选择法。彼则无见。以是之故。诸法若干见无本法。不观若干。若以观法见本无者。不肉眼见不天眼见。不慧眼见。所以者何。计使眼者。不受于想。不肉眼见。彼眼不堕生死之行。若以天眼无所见者。不用彼眼行于放逸。若以慧眼无所见者。彼为观法了法本无。普见诸法无有处所。法无所住。已见诸法无所住者。则行法意。便不违失往古所誓。是为菩萨。随诸佛教而自立意。敢可观察深妙之法不舍道心诸通慧矣。是为族姓子菩萨大士观本无法意止净行

佛告族姓子。是四意止行。四精进何谓为四。观身无身。弃捐计实不净为净颠倒之想。观痛无痛。弃苦为乐颠倒之想。观心无心。蠲除无常计有常想。观法无法。舍远无我为我想者。于四颠倒而修平等。则无所著。菩萨若能行平等者。则能清净一切诸行菩萨奉此平等清净微妙行者。便逮法忍。名四意断。亦得法忍。何谓意断清净。行者讲说道法。以此因缘。善本法行自然随顺。不从恶本不发瑕秽。诸不善本。萌牙未生不令兴起。为奉精进。诸恶适起非法之事。寻便灭之。为修精进。诸善法事未兴起者。劝令发生。以兴善法益加精进。令其具足不使忘失。为行精进。又复菩萨。本行净业能自制护。不失善法得自在住。渐稍长育显扬善法。善法已兴不复忘失。彼族姓子。如是行净。此四意断。其菩萨行。心得自在不乱精进。其净垢浊不与俱合。清净无垢不违佛慧。则从道教行于大哀。心心相见睹其所念。不失精进已行平等。曰得意断。所以者何。从等安祥不用反邪。以因安祥不从反邪。便逮意断平等三昧。已得三昧。名曰平等四意断也

佛告族姓子。若能修行此四意断。则能奉行具四神足。断除贪欲奉行精进。则令道心静然无秽。所思薄鲜。已去非法则逮轻便。致成大哀精进轻举。获权方便已诫轻举。因是之故。成四神足升于道堂。得四自在。何谓为四于寿自在。已得长命。由已无限在短命中。具无量寿劝化众生。在长命中听省说法。或有厌倦现于短命。使渴仰法殷勤求义。在在诸生天上人间。各得自在于其寿命。是为第一逮得自在。又族姓子。身口自在。其人身口。逮致由己心不倚身。逮意现形。随其容貌而示色像。因其众生威仪礼节。体之好丑长短善恶。思惟正定。以何律仪而可开化。菩萨即从变其形貌。坐起进止发意之顷。化一切人。蚑行喘息人物之士。身形颜色皆为一类。而为说法。是为第二而得自在。又复于法而得自在。在于三界执御度世之正典。不行俗法则随习俗。普现变化。亦不舍远度世之慧。亦无所失。至无碍慧深奥之道。十二缘起因缘之法。而见迷惑。若生天上及与世间。随其语言。令无数人皆随律教。从其所好上中下愿。各得其所。所得自在巍巍如斯。是为第三而得自在。又有菩萨。建立其心使得由已。其自在者。摄三千大千世界诸有大海。合入一海而建立之。亦无往来而现变化。三千世界诸须弥山。立为一山。使四天王及忉利天。不知合散去来所趣。因而现变三千世界。而为建立诸有民人。计皆知数树木华实。令虚空中满其水火。或化众宝。从其所变而建立之。已能建立。发意之顷靡不蒙度。忽然如故。是为第四而得自在。又族姓子。菩萨以是四神足行而自修立。与十方佛共俱言谈。坐起经行不离左右。与诸释梵及四天王天龙鬼神。揵沓和阿须伦迦留罗真陀罗摩休勒。人与非人一切众生。俱共相随谈言说事。坐起行步。所以者何。菩萨神足微妙巍巍卓然有异。往古修行善法之义。无有缺漏因获致此。何谓神足往古修行善法之义。轻便其身恭敬尊长。奉事众祐趋走给使。不以为难。谦卑下意不怀自大。口说善言悦可众人。莫不敬爱。自归稽首礼节备悉。言行相应其心轻便。不怀慢恣无危害意。彼修谦恭自伏其意。听受尊言顺教跪拜。执心柔软而制其志。精进修行未曾舍离。其人具足戒之礼节。身所造行与众殊特。心不懈慢亦不放逸。从其贪欲而起瑕秽。嗔恚愚痴身。蠲除此已无有贪嫉。饕餮自除。志性不起则病瘳愈。度于众事。所负重担。由因羸劣而致此患。阴盖众事为去其担。五事所受施以恩惠。依桥道度。以大船度四渎具。度一切众生之类。越于泛流。有所开化超然有异。乱者正之。逸者定之。癖者立之。毁者笑之。不碍回波决诸狐疑。所说殊异安诸动摇。救念诸界觉诸不寤。所可爱重每以惠施。后无所悔。将济众生劝助道意。若见他人积累德本。代其欢喜。未曾叹己为身获安。见他人安欢悦善之。易养知足不望他利。爱乐出家劝人出学。修大弘慈常怀道心。等怨亲友乐如虚空。见疲极者设以车乘。则以无畏加于众生。见学问者敬之如佛。其未学者不以轻慢。其贫匮者施以财业。若疾病者。救以医药令得济命。见救护者为行恩报而以孝顺。行禁戒者能自修慎。供养事之不失其意。无恭恪者。劝救济之度于世法所经游行不犯诸恶。于诸世事而无所著。奉行诸德。是族姓子。修诸神足微妙巍巍。持行如是不失神足。常与其俱至成佛道。是为菩萨神足净行

大宝积经卷第一百一十七大宝积经卷第一百一十八

        西晋三藏竺法护译

    宝髻菩萨会第四十七之二

佛告族姓子。何谓菩萨五根净行。不受诸法而修道义。是为信根愿度彼岸。不须御人为精进根。不舍道意为一切故。是为意根。执御大哀欲济危厄。是为定根。若能奉受一切诸法而修寂寞。是智慧根。又族姓子。笃信一切诸佛之法。顺从道迹。是为信根。奉诸佛法未曾懈倦。是精进根。念诸佛法。圣义存心未曾忘舍。是为意根。修习佛定初不懈废。是为定根。能除一切众生疑结。无所念愿。是为慧根。又慕佛道不怀犹豫。是为信根。其性调柔。顺修精进无有退还。是精进根。劝助德本长而无损。是为意根。等演光明照于众生。救脱愦乱。是为定根。分别一切人之原本而为说法。是为慧根。超越一切诸所挂碍。而无所著。是为信根。解众生结令无诸缚。是精进根。志所奉行而无所著。独步三界卓然有异。是为意根。知诸挂碍因缘所由。是为定根。了诸着猗智靡不达。是为慧根。又使所遵而无所惑。是为信根。化人不惑。舍于非时常怀悦豫。是精进根。所从法教常行清澄。微妙之法不迷众秽。不忘道义日日增修。是为意根。其心清净奉行平等。而以正受圣慧均平而得度矣。是为定根。若于法界了无所碍。去诸非时住解明法。是智慧根。灭除一切诸非善本。修行众德。是为信根。遵诸善本顺从经典。是精进根。积累众善不违失法。是为意根。定意欢悦不贪乐安。分别众生诸德之本。是为定根。奉行众善从其方便。等修道法。是为慧根。又信勤修舍诸懈废。意无所求无所忘失。将护定意令不迷惑。奉行智慧开化愚痴。又行信者弃捐邪法。行精进者放舍吾我。其心专一度于贪身。以能行定。裂坏诸网六十二见。其慧智者。蠲除一切猗着恩爱。是族姓子。菩萨所修五根净行

佛告族姓子。何谓菩萨行五力净。若计于此能立五根。奉行不舍降弃四魔。不从声闻缘觉之乘。从于大乘未曾退还。消众爱欲尘劳之秽。其愿坚固心得自在。志存勇猛。其身康宁强而有势。诸根澹泊不坏笃信。是族姓子。名曰信力。所不当作而不为之。制御其性而令均调。是精进力。所当修者而皆行之。其意势强。是为意力。所造道业未曾忘失。以度一切。是为定力。不为色声香味细滑众念所危。超度一切犹豫众结。意之所住。是为慧力。又信力者。不从他教而有所受。精进力者。所当执持而不忘舍。其意力者。逮得总持不共道意。其定力者。说法平等不从偏党。其慧力者。决诸狐疑。解散众生结网之缚。又信力者。则能具足诚信之势。精进力者。解脱坚强度未度者。其意力者。具足解慧度知见力。其定力者。具足究竟志性之力。其慧力者。具足一切众行之原。又信力者。能制悭贪垢秽之难。精进力者。皆能放舍一切所有。其意力者。所显德本劝助道心。其定力者。等心遵行舍诸所求。其慧力者。诸可修行未曾望报。又信力者。释除一切毁戒之聚。精进力者。殷勤修禁未曾违失。其意力者。具足道心令不阙漏。其定力者。辄得归趣仁和之地。其慧力者。于诸所行皆断生死。又信力者。离于诤讼嗔恚之本。精进力者。正念所行遵修忍辱。其意力者。具足道行亦不毁法。其定力者。先自制心令不放逸。拥护一切众生之类。其慧力者。不计吾我亦无人想。又信力者。弃捐懈怠众秽尘垢。精进力者。皆得超度一切因缘。不为恶事之所见迷。其意力者。修行于道而令具足。其定力者。身得休息能谐降魔。其慧力者。于诸所作无不作。又信力者。消化诸垢众邪之行。精进力者。合会众生而开化之。其意力者。常一其志而劝助之。其定力者。常行静寂未曾愦乱。其慧力者。晓了诸人所行之法。又信力者。弃于诸见所识众垢。精进力者。常勤修行求于博闻。其意力者。严净思念所行如应。其定力者。心无所生乃能逮得。其慧力者。精学堪任令致成就。又信力者。常得至诚七财之货。精进力者。晓了分别致七觉意。其意力者。心常整齐未曾愦乱。其定力者。则致超度七识之住。其慧力者。过于八邪而无著也。无能破坏心常清净。是为信力。奉行清净而不退还。无净不净。无应不应。是精进力。清净其意合集群类道品之法。无意无念。是为意力。其心精进修于寂寞。乃为正受。是为定力。若能清净。不为诸见之所迷惑。奉诸德本。是为慧力。是族姓子。菩萨所行五力清净

佛告族姓子。何谓菩萨七觉品净。彼以发显。意觉品者。而得自在不共道慧。法觉品者。观察所行。则随应时而无所著。精进觉品。所勤修行至无挂碍。欢悦觉品者。心成无所乐。信觉品者。身意休息得至究竟。定觉品者。离于志味而得达至。观觉品者。所可造业而悉成办。又求道心。亦无所得亦无所失。是意觉品。若将护法精进日新。是法觉品。开化众生不以厌倦。是精进觉品。设乐法乐殷勤思议。是悦觉品。若化人民。灭除尘劳建立于道。是信觉品。若住等意心不怀乱。是定觉品。若能察行圣贤之慧。建立众人。是观觉品。无忧不念若如师子。过于声闻缘觉之乘。是意觉品。一切诸法皆悉清净。晓了此者。是法觉品。其行清净。护身口意而无所犯。是精进觉品。净无所著离于危害。是悦觉品。严修所行。所当为者而悉成办。是信觉品。未曾顺从世之同尘。平等色像。是定觉品。未曾住于二法之行。离于漂流。常见将护救于众生。是观觉品

佛告族姓子。所以名曰觉品者何。了了晓诸法靡所不达。分别称量识知所趣。解其威仪礼节所归。开化众生。彼所住处。己身勤修广行道义。除去结缚诸所拘缀。是意觉品。斯则为是贤圣之行。非是愚夫所修。说其圣行非魔所行。非是贡高自大所行。圣贤行者此则非是。外道异学之所及逮。贤圣所行。不行色声香味细滑之法。贤圣行者。则无众想因缘之着。贤圣行者。便无选择处所方面。有所忘失。贤圣行者。无心意识念言之行。贤圣行者。离于见闻念知识法。贤圣行者。无有泥洹造念思想。于一切法无所行者。是贤圣行。修于经典。一切无有应与不应念与不念。亦无他想。是贤圣行。于一切法悉无所住。不慕尊处所。是贤者行。于一切法而不错乱。顺行正义各令得所。是贤圣行。于一切法未曾诤讼。和同止住。是贤圣行。奉行诸法无诸法想。不失道意。是贤圣行。此族姓子。修七觉品圣贤净之行。佛告族姓子。何谓菩萨修八道法清净之行。所谓八道行者。一曰正见。何谓正见。若能奉行一切诸法。于我不我不住空观。所以者何。察身吾我等无差特。亦复不住观身人空。所以者何。身人及空亦复等耳。亦复不住观人寿命与空别也。所以者何。人寿命空观心平等。亦复不观所有生死。离于终始空无之义。所以者何。所有生死及终始患。所见空者悉亦等耳。不住观空断灭常见。有吾有我。所以者何。断灭常见悉亦等矣。亦不计身及所观空。亦不住此。所以者何。身吾我空悉亦等耳。亦复不住见佛法众观空之行。所以者何。见佛法众及所观空。悉亦等矣。是族姓子。有彼此见观至灭度。是为正见见佛法众。其邪见者不离颠倒也。若于诸见无所想念。上妙中间。是谓正见。所以者何。如彼等观则亦无邪。以何为见。其见者当观平等。见凡夫法以为卑贱。所学法者以为尊高。如是观者则为邪观。见凡夫法秽行未消。菩萨法者无有尘劳。如是观者则为邪见。见凡夫法以为是漏。无所学法以为无漏。如是观者则为邪见。见凡夫法有求衣食。缘觉之法不望供养。如是观者则为邪见。见有小意有所悕望。菩萨之意无所悕望。如是观者则为邪见。见凡夫法以为放逸。菩萨之法以为无欲。如是观者则为邪见。见凡夫法悉有为事。佛之正法是无为道。如是观者则为邪见

佛告族姓子。有能察凡夫法。一切法皆本净。其学法亦本净。观诸法悉自然乃为正见也。凡夫法所学法亦空。了学法空。乃为正见。凡夫法者等于因缘。晓了如此缘觉之法。因缘亦等。乃为正见。凡夫法者则为静默。菩萨之法亦为澹泊。乃为正见。凡夫之法无所成就。诸佛之法亦无究竟。乃为正见。其正见者。心不入二不见二者。人亦无二不见吾我。则为正见。无若干见。不以若干为异见者。为平等观。则不想念。一切诸法有上中下。于一切法无所想见。乃为正见。其正见者。无若干见亦无所见。无所见者乃为正见。所可察者无有形色。以见诸法无形色者。乃为正见。是族姓子。观一切法晓如是者。斯乃名曰班宣法律。说是语时。五百比丘漏尽意解

佛告宝髻菩萨。所谓正念。蠲除诸念与不念俱。合集寂然。而观智德至澹泊法。晓了所观见于诸法。所念信者。何谓为法。何谓非法。解知诸法各各别异。不相亲近。以晓了是不念平等。况于信邪未之有也。于一切念无念不念。无所复思无应不应。是为正念。佛告族姓子。所谓正言。其所说者不自见身。不见他人不着彼我。不危己身亦不危他。是谓正言。又正言者。等解诸法。知一切法至于灭尽。知一切法归贤圣法及与解脱。是谓正言。奉行慈心重加愍哀。亲仇无别。正言亦空等演诸法。无相不愿悉无所作。不生不起。诸法言等。一切诸法无常苦空非身之教。其正言者。一切诸法无人寿命。等说诸法从意缘起。如其所种各得其实。菩萨等示众生宣其经法。令行佛道。其正言净。则为一切十方诸佛之所拥护。是为正言

佛告族姓子。所谓正业。消化一切诸所造业。未曾复作诸所原基。所修业者灭众苦恼。诸可常业悉令立虚。不兴邪业。离于尘劳无有秽浊。是谓正业。若有菩萨。晓了此业及与诸法。于诸善本而无所造。以修德行。是谓无作则为造行。为虚无要空虚之宅。是谓菩萨行上尊道为正业也

佛告族姓子。所谓正命。不计有我不计有人。是谓正命。其正命者。亦不积聚一切尘劳。菩萨正命。则能净修众生志性。已净志性不自计身。亦无寿命等。为彼我及与法故。行清净义。是谓正命。佛告族姓子。所谓正便。于此不为非法之事。心不舍德。所作方便安无怯弱。修于正行淳淑近之。是谓正便。其正便者不为邪便。所作方便如其所言。不计诸法等与不等。无作不作。如诸法住。顺其所行而设方便。计如此法。诸佛之法亦复如是。如其寂然因为方便。诸法平等无有差特。所行亦等。为诸众生除其邪便。则以劝助于诸通慧。是为菩萨所行正便。佛告族姓子。所谓正意。谓忆佛道。念施持戒忍辱精进一心智慧慈悲喜护。是谓正意。念于殷勤。不听一切尘劳之秽。不从魔便。其所念者。在所向生不堕邪见。工御其意制其所念。如监门者知闭开时。除去一切诸不善念所思想。不听邪念。是谓正意。菩萨已处于此正意。不于此中寂灭道性

而取果证。是为菩萨正意净行佛告族姓子。所谓菩萨正定。随贤圣行。知于苦谛。断集谛种。证尽谛种。奉道谛种。是为正定。彼若正受。等于己身亦等诸法。己身清净诸法亦净。己身则空诸法亦空定意正受能如是者。则入平等不堕灭尽。是为菩萨正定净行。发心之顷所行平等。具足智慧一切圣福觉了诸法。是为菩萨正定净行。佛说是正定觉时。千六百天与人弟子行者。好乐小乘已入其法。改发无上正真道意

佛告族姓子。何谓菩萨护觉意。将养其心令不起生。除淫怒痴去于色着。痛想行识。在于三处而无所著。独步三界过三脱门。至三达智。睹去来今无所挂碍。开度众生除诸秽垢。犹如日明无所不曜。善权智慧随时示现。游于三世如水莲花。开化一切使发道意。是为菩萨护觉道意清净之行。佛告宝髻。何谓菩萨成就神通为清净行。又以五事具备彻视。何谓为五。逮得光明名曰天眼。普照十方消尽窈冥。靡不睹耀见一切佛所可开化。多所度脱。故曰天眼。遥睹众生终始所趣。庄严其志。名曰天眼。皆见十方一切形色像貌种类好丑长短。其天眼者无所挂碍。意念寂灭其相无为。过诸天龙神及揵沓和声闻缘觉。见其本末靡所不达。是族姓子。如是比类致五神通。逮此天眼为菩萨眼。是为菩萨天眼之净

佛告族姓子。复以五事。成其彻听靡所不闻。何谓为五。闻于人声。亦复彻闻非人之声。亦闻地狱饿鬼畜生辛苦之音。一切十方诸佛说法悉亦闻之。一切十方诸有言语音辞不同。各各别异亿万种音。皆能听了。是为五事菩萨神通彻听清净

佛告族姓子。复以五事知人心念。何谓为五。悉能逮知诸天人民地狱饿鬼畜生之类。本末所因心念善恶。方当来世若更受身。知去来今心念所趣。决定来处归于邪业。众生心念善恶所行。皆了知之。察其心意。或怀贪淫嗔恚愚痴。随其本行如应说法。是为菩萨知诸心念清净之行

佛告族姓子。何谓菩萨知过去神通清净。谓以五事了知古世。其有受于淫怒痴者。悉自然受不熟思惟致此事耳。复解己身无央数世便更专。惟布施持戒忍辱精进一心智慧慈悲喜护。缘其定意而逮得此。亦从已致其受。吾我念心因缘诸相之观。其相因缘。亦从已为而自然受。思惟其心自观其志。其入痴门亦自然受。念识此已。随其色像眷属势力名称豪贵贫贱苦乐。亦己身为。皆自然行而受此患。是为菩萨知往心念清净神通。佛告族姓子。何谓菩萨具备神足。则以五事而逮神足。何谓为五。示现色身神通自在。神识音响神足悉达。心意所行神足普周。一切众生心所娱乐。神足皆别。亲近所见神足咸至。坐见十方无数国土。周遍一切诸佛境界。随其习俗现其形体。身遍一切十方众生。为其说法。令得开解发大道意。是族姓子。菩萨所行神足清净

佛告族姓子。菩萨慧眼具天眼净。其天眼者。住于神识亦无所著。则致天耳本末清净。住无挂碍。寻即知众生心念。靡不通达。悉知过去当来处所。悉能证明。住无所行。皆尽诸漏生死之行。便净神足诸通明彻。所谓神通。则诸漏尽圣慧之门。菩萨于彼。以此五通而自娱乐。其心不住尽诸漏慧。佛告族姓子。譬如去于居邑。百千俞旬玄回之路。有大国城。其路艰险众难难计。阻邃曲隘寇贼抄掠。师子虎狼还相食啖。若出此路能到彼国。入大城者悉脱众患。安隐无量。时有一人。闻彼国城恩德功勋。快乐远着。其人生年唯有一子。甚爱重念视之无厌。闻彼国名舍子而往。尽力勤行。忍诸艰苦众难之患。昼夜不懈。得值阴凉。六艺备体执持五兵。便得越度。到其城门住门捆上。稍复进前至第二门。开其城门而独住立。即便忆念。所生一子独不得来。以子恩情不入大城。寻更还反将其子来。共至乐国。佛告族姓子。菩萨如是被无极铠。以大精进坚固志性。精诚所致显发大道。净治心业淳淑之行。诸漏得尽兴大哀心。开化众生为其说法。慧断生死。得至无漏究竟成就。哀愍众生欲救护故。则复来还现凡夫地。佛告族姓子。其城者喻圣慧巍巍。诸漏已尽涉难远行百千俞旬。玄迥路者。谓游无量生死诸难。救脱众生不以为拘。盗贼虎狼者。谓众魔邪见非法之难。相食啖者。谓三界中阴衰之患。值阴凉者。谓平等行。六艺五兵。谓六度无极五神通也。其人者菩萨也。到其城住门捆上。从外门稍复进至中门。住不前者。谓菩萨而从有为至于无为。诸漏已尽其心明彻。不舍本愿欲度十方。如念一子也。不入城还反者。菩萨愍伤一切众生。中心念之如一子父。灭除生死诸漏之难。超住法顶虽出生死。不尽诸漏寻复来还。在于五趣开化众生。是为菩萨善权方便大哀之行。尔时宝髻菩萨前白佛言。至未曾有天中天。菩萨大士。志怀大哀不乐解脱。欲度众生如观己掌。反还生死而不恶厌。复问佛言。菩萨遵修何法不厌生死。佛告族姓子。菩萨有二十事不厌生死。何谓二十事。奉行德本至无极慈。执持大慈以摄大危。怀抱大哀摄不弘愍。开化众生度脱一切。常以精进摄诸怯劣。以和调性摄诸怀结。以权方便摄不知节。则以智慧摄诸愚冥。而以一心摄诸放逸。能以神通摄诸不畅。能以圣明摄诸闇塞。能以随时摄诸无义。其意专惟摄诸烦愦。遵奉道心摄诸不学。而行四恩摄诸无护。以布施摄贫穷。以敬戒摄无礼。以博闻摄少智。以总持摄喜忘。以辩才摄顽讷。以上德摄少福。由是之故乃成大慧。是族姓子。菩萨所行二十事不厌生死也。宝髻菩萨复问佛言。何谓菩萨宜于生死。为无数人而有加益。佛告族姓子。若使菩萨。以德庄严宜于生死。以福润泽穷乏危厄。博闻庄严宜于生死。则以辩才多所饶益。能执其意而不忽忘。逮得总持宜于生死。令一切人各各闻慧。逮得宝掌以好布施。而自庄严财不耗减。用此财宝多所饶益。又不放逸宜于生死讲法不倦。多所饶益于一切人。又等集诸相宜于生死。修慧庄严于诸众生。言行相应宜于生死。所为应时不失其节。多所饶益于诸众生。一切所有施而不吝。宜于生死。随时开化各得其所。施度无极。多所饶益于诸众生。奉清净戒宜于生死。庄严持戒。多所饶益于诸众生。忍辱精进一心智慧。宜于生死。六度无极。多所饶益于诸众生

佛告族姓子。乃去往古无央数劫。长远无量。尔时有佛。名普坏世如来至真等正觉明行成为善逝世间解无上士道法御天人师。号佛世尊。世界名曰天观。劫名欣豫。何故其劫名曰欣豫。于彼劫中六万佛兴。时净居天闻无数音班宣佛德。于是劫中有六万佛。时天世人皆共歌颂。此咨嗟声其有闻之。靡不欢喜善心生焉。以是之故。劫名欣豫。佛告族姓子。其佛世界安隐快乐。其德巍巍。诸天人民观之无厌。以故世界名曰天观。其土微妙至诚庄严。以杂种香而成其地。堪任执本于千世界。又其佛土所出香熏。则能周遍十方无量无数之国。栴檀烟阴于其土地。自然生起无极莲花。名光明曜。其莲花光。常以大晖照彼世界。人民大小皆有神足。宿德所居香为楼观。讲堂精舍。轩户窗牖床榻茵蓐。微妙綩綖。其佛之土。亦无国邑郡县村落。又彼人民。悉得神通经行虚空。楼阁讲堂亦处于空。坐斯楼堂。专精念道讽诵讲论。彼无女人亦无胞胎。人皆化生不闻女名。亦无三涂恶趣之名。又无众恼勤苦之患。一切众人。禅定欢悦以为饮食。笃信微妙志求大乘。彼无异乘声闻缘觉之名也。其土人民皆着冠帻衣服。颜色犹如天人。假使出学。尘劳爱欲寻皆舍离。无有忧累。又彼如来。亦不敕告诸菩萨等使被法服。所以者何。其人不生秽浊心故。而彼如来。形体威颜现如梵天。诸菩萨众。威仪礼节靡不备悉。坐起安详讲说经道。设使十方诸佛之土。有无极变神通菩萨。诣天观世界者。通过诸国来觐如来。稽首归命听说经典。见彼佛土无有伦匹。其德超殊巍巍无量。怪未曾有举声嗟叹。尔乃舍去。佛告族姓子。若彼如来。为诸菩萨班宣道化。踊升虚空。去地六十六丈。坐于微妙清净庄严师子之座。为诸菩萨。论上法教粗举其要。不广分别屡练中义。如吾于此多说殷勤。所以者何。斯诸正士悉入圣慧。以一章句。辄能解入百千之义。是故如来。约宣经教不以多言。其佛为说四清净行。度无极净。道品法净。神通行净。化众生净。是为四也

佛告宝髻。时彼佛土。有一菩萨名曰珍宝。即自启问坏世如来。何谓菩萨宜在生死多所饶益于诸众生。于时如来便为菩萨。广分别说此两句义。于斯大慧道莫能当。菩萨所行恒在生死。逮得慧曜多所润益。佛适说是。六万菩萨得柔顺忍。佛告宝髻。珍宝菩萨。复问何谓菩萨严净道场坐于佛树。坏世如来。告珍宝曰。以无放逸严净道场坐于佛树。于彼何谓无放逸者。其佛告曰。奉行经典。又问何谓奉行经典。告曰言行相应是无放逸。又无放逸不自驰骋。修于无量大德之铠。不与阴合越于五阴。布施无量不可尽故。持戒无量为未学故。忍辱无量堪众苦故。精进无量正士业故。禅定无量无退落故。智慧无量无挂碍故。慈心无量。开化众生不可限故。悲哀无量。愍伤众生济匮乏故。行喜无量。以法欢悦众生之故。行护无量。救济将养群生之故。生死无量。长育一切佛道法故。化无量人安彼我故。正法无量。将顺随时坚精进故。德慧无量。执权方便等应时故。奉无量佛具足慧故。求无量闻智卓然故。心入无量。睹见众生志性行故。节德无量。志存闲静有限之故。闲居无量将顺心故。寂默无量。所察广普速疾具成诸通慧故

佛告珍宝。是无放逸所当遵法。菩萨行此无放逸者。严净道场坐于佛树。则其义也。又族姓子。其无放逸诸道品法所立之本。致无放逸圣慧之原。逮坚要法以无放逸积累德本能不放逸。未曾忘失往古久远所听闻法。普能执怀一切经典。消化尘劳无量阴盖。于诸道义无所挂碍。无放逸者。则能烧尽旷野积聚愚痴之冥。悉能将护一切经法。灭除众相抑制诸根。无放逸者。退舍邪径奉行众善。力势超殊具足十力。力如虚空而无等双。无放逸者。得无所畏。具足成就一切佛法。归其原顶。无放逸者。便能获致佛诸通慧。佛告族姓子。彼佛说此无放逸时。万二千菩萨。逮得无所从生法忍。于族姓子。所忆云何。时珍宝菩萨岂异人乎。莫作是观。所以者何。则汝身是。由斯缘故。当作此观。若使菩萨无放逸者。乃为应宜严净道场坐佛树下入如来道不可限量

佛复告宝髻菩萨。所谓菩萨开化众生。若菩萨行清净者。见众生行心怀善恶。便能开化无量难限不可思议众生之类。各使奉行无极之法。其菩萨者。志性调柔入于审详。自在开化几何人民。彼族姓子。人根不同所见各异。是故菩萨。随时示现而诱进之。或能有人坚正禁戒乃成开化。或从毁戒因得受教。或以衣物往来交接。缘受道化。或以柔软。或以粗犷。或怀毒心。或以恐怖。或以苦恼。或以安隐而受开化。或在言语。或从得胜。或从因生。或从志性。或从逼恼。或从顺意。或从所有。或从无所有。或从兴盛。或从所受。或无所受。或从财业治生。或从静然无所易取。或从贪慕求妙颜容。或从恶色。或从色声香味细滑之法。而致开化。或从嗔骂臭气恶味粗坚秽法。而得开解。或从共居宿止受化。或从往来数数相见。或从闻佛法圣众。或从欢喜。或从忧戚。或从无我。或从寂音。或从布施持戒忍辱精进一心智慧之音。而受开化。或从众生有为之恼。或从听闻天上世间所遭安隐。而受开化。或听声闻所说乘教或缘觉乘。或闻大乘而受开化。或从常喜不以忧恼。或从愁戚不因欣豫。或从货利。或从踊跃不见爱敬。或从得利。或因衰耗。或复有人而从四恩因而开化。或从内业。或从外业。或从眼耳鼻口身体手足。而受开化。或以娱乐歌戏。或以花香而受开化。或从其身专遭苦患。或从常乐而受开化。或从其心得静方便。或从化作比丘形像。或复变现比丘尼优婆塞优婆夷像。而受开化。或复现作佛像容貌。而开化之。或如释梵转轮圣王像貌。而开化之。佛告族姓子。若使不现若干种变。观其性行行其心念。而开化者不能度之。当晓了知众生性行。应病与药所度乃广。设令菩萨行度无极。则能奉受佛道品法。亦能明了神通之慧。然后寂然开化众生。菩萨有四事法。开化众生。何谓为四。一曰不厌终始之患导示未及。二曰不贪安己愿安一切。三曰常以时宜宣示道教。四曰分别众类心性所行。是为四。复有四。一曰所说柔和言辞可敬。二曰奉戒清净。犹如日明。三曰颜色常悦未曾怀恨。四曰常怀慈心。复有四。一曰心不怀害。二曰志于大哀。三曰意多愍伤。四曰常调其心。复有四。一曰性行清净。二曰无有谀谄。三曰精进坚强。四曰忍于苦乐善恶。是为菩萨四法开化众生。当作此观。乃能堪任救济一切

佛告族姓子。往昔过去无央数劫。长远无量不可思议。尔时有佛。名离垢光如来至真等正觉明行成为善逝世间解无上士道法御天人师。号佛世尊。世界曰寂然。劫名爱敬。寂然世界丰乐安隐。五谷平贱快乐难量。天人孳盛。离垢光佛。其声闻众九十六亿。菩萨八万四千。其佛寿三十三万六千岁。时有梵志为大国王。王有太子名曰业首。端正姝好见者无厌。厥年十六。惑于颜貌迷于豪贵。荒乱自大。不肯往诣离垢光佛。不修恭敬稽首为礼。佛心念言。太子业首。云何忽失无上正真道意。劝助德本。不识宿本而计吾我。荒迷容色财业豪贵。及怀自大不数诣佛。既来至此不肯归命。违失礼节。设为殷勤宣其本行者。必识宿命。数诣如来稽首受教。于时离垢光如来。皆悉请会八万四千菩萨。使行法筹谁能堪任诣太子业首所。八万四千岁教化说法者。而不患厌一切苦恼所见逼迫。虽往教彼不见接待。座席言谈。但得骂詈毁辱诽谤耳。佛告族姓子。时虽行此筹。八万四千诸菩萨中。无一菩萨肯受法筹。时彼会中有一菩萨。名极妙精进。即从坐起。偏露右肩长跪叉手。前白佛言。我能堪任八万四千岁。往来太子业首数数相见。舍一切安皆忍众苦虽遭诸厄不以为患。极妙精进适发此言。三千大千世界。应时六反震动。百千天人住于虚空。举声叹曰。善哉善哉。无极精进。被弘誓铠。于时极妙精进菩萨。往诣业首太子门前而住。太子方见。骂詈毁辱嗔恚诽谤。言语冲口无有其限。撮土坌之。瓦石打之。刀杖加之。于时菩萨被辱如是。不怀嗔恚。不以为恨。亦不悔还。遂坚其心被精进铠。智力益增。兴发大哀而愍伤之。如是千岁。乃得自前入第一门。从所苦困轻毁之难。不以患厌至千万岁。转复进至王宫第一之庭。又二万岁至第二庭。如是之比。八万四千岁至第七庭。七日七夜。太子业首。时复见之。寻便质问。比丘何来诣此所求。菩萨答曰。故来相诣相称名勋。于时太子心自念言。怪未曾有。今此比丘戒德难量无能逮者。被诸毁辱未曾懈耻。极妙精进欢悦业首。寻说颂曰

  太子吾今无所求　　不用饮食及衣服
  宜当显发无怖心　　吾以法来故至此
  人中尊号离垢光　　大圣现世多所益
  讲说经法除苦患　　若有人闻逮甘露
  诸佛兴出甚难值　　无数千劫难可遇
  执御众人令受法　　则为世间之炬曜
  反以欲得而放逸　　贪于财色自娱乐
  迷荒豪贵及王位　　不肯往诣见法王
  财业无常命难保　　佛说人寿如朝露
  太子自察亦常然　　云何闻佛复放逸
  仁者以曾志佛道　　召请众生欲度脱
  于今何因为欲使　　放逸安可度众生
  吾且欲还诣最胜　　当降伏心灭尘欲
  仁兴精进愍一切　　将无后恨怀忧恼
  时国王子闻斯颂　　即自下意发恭敬
  礼极精进稽首足　　吾今自悔辱仁罪
  我当弃舍一切士　　不慕豪贵贪国土
  吾当往至安住所　　弃捐瑕秽求见益
  即与一亿八万人　　各执众花擎诸香
  俱往诣于最胜所　　见离垢光人中上
  已皆悉到安住所　　前稽首足而供养
  退在一面住佛边　　于时太子说此言
  极妙精进是我师　　心不患厌和颜劝
  此之恩德无以加　　如是供养不足报
  归悔首过救护世　　违失法王之教命
  我今都悉自归诚　　愿佛纳受所首情
  于是发意悉求佛　　用一切故兴愍伤
  不复造邪为放逸　　今我立德成佛道
  尔时太子弃荣位　　与人一亿八万四
  于最胜所作沙门　　发意志求于佛道
  时佛知其所志愿　　为说最上佛道业
  诸闻净法逮柔顺　　诸高士住无我法

佛告宝髻菩萨。欲知尔时极妙精进。我身是。太子业首。弥勒是。族姓子。过去菩萨。开化众生不以懈倦。威德巍巍无量如此。所学日深精进无侣。是故菩萨欲度众生。当念修学。如彼往世极妙精进菩萨之德

佛告族姓子。菩萨有四业而得自在。以此四业摄取诸佛道法。何谓为四。一曰超越诸魔靡不归伏。二曰念净佛土令修净教。三曰严身口意顺开士本。四曰合集一切诸佛道品。是为四法自在之业。复有四事为菩萨业。何谓为四。一曰其慧晓了所入志性。二曰普见众生根原所归。三曰分别一切诸趣所由。应病与药。四曰明识一切径路所行。令得寂寞不怀嗔恚。是为四事菩萨所行自在道业。于是宝髻菩萨。从无数劫殖于难限百千德本。髻中明月珠。其价当此三千佛土。以奉如来口宣此言。以顶上宝贡献如来。因是德本。致无能睹其顶相者。逮成诸佛不可思议圣慧之顶。佛即时笑。五色光明从其口出。照无央数诸佛国土。寻即来还。绕佛三匝。忽没顶上。于是会中有菩萨。名曰捷辩。从坐而起。偏露右肩长跪叉手。赞叹世尊。以颂问曰

  最尊无等伦　　超世俗之上
  无垢以离秽　　三界称其德
  其慈无俦匹　　超越须弥山
  今者何欣笑　　愿慧为我说
  真谛戒调定　　执性人敬言
  令我志趣安　　善修快寂然
  天人尊在此　　其志甚坚妙
  为以何感应　　哀愍而今笑
  十方总势强　　光明福曜威
  勇师子坏冥　　游众无所畏
  三界无有侣　　何能有殊者
  法宅为解说　　何故而欣笑
  离垢性游安　　颜色常和悦
  名德通虚空　　驰逸不可限
  消除诸窈冥　　光明靡不照
  安住唯为解　　何故而欣笑
  修德心清净　　愿如金宝山
  常训诲不及　　世人普供养
  则为最良田　　众祐圣超世
  释师子现要　　所演如虚空
  诸天及人民　　无与妙等者
  等心甚坚强　　惭愧祥丰盛
  巍巍德百千　　相如花茂盛
  最胜能仁笑　　愿为发遣之
  其慧无挂碍　　流布于三世
  处若干身意　　其心无所著
  一时悉晓了　　如应当行化
  仁师子属笑　　其义为何义
  诸天住空中　　意内怀悦豫
  地上诸人民　　叉手而自归
  能仁胜唯说　　殊特甘露味
  诸天神人闻　　消灭尘劳冥

佛告捷辩菩萨。汝为岂见宝髻不乎。以此宝髻珠奉上如来。志愿无上正真道意。则为供养佛之原慧。对曰唯然。已见世尊。佛言。是族姓子。宝髻菩萨。于恒河沙劫。供养恒沙如来至真。常修梵行。开化无数众生之类。立于三乘。过十阿僧祇劫。当得作佛。号曰宝成如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界名离垢光。劫曰无垢。其离垢光世界。七宝合成咸出光明。照于十方无量佛土。其光紫金。假使众生值此光者。一切尘劳悉蒙消灭。其土丰乐。皆诸菩萨悉无所著。无有异学相发起者。普修道宝。以故如来名曰宝成。此诸菩萨。皆得神通咸有辩才。其土诸天人民。悉当淳淑遵平等觉。无有不及无智之名。其土亦无君主。唯以世尊为无上法王。诸天人民自然化生。无有女人无爱欲名。其土人民皆殖德本。无无福者诸根悉具。皆以相好庄严其身。尔时如来。诸菩萨众不可称数。佛寿十四劫。初无异谈。所说唯宣菩萨之慧诸度无极。辩才大哀淳一品教。是诸菩萨皆曾被训。诸根明达。能以一句普入一切诸佛之道。如来为说总持言教。慈心如地。何谓总持言教。以一绝句普入诸章。何谓一句。谓妙圣句不可究尽道品之法。何谓无尽句。谓于佛道不可穷尽。何谓无尽。论于无者。谓无尽句。已能入无普入文字。是为一句。一切文字而不可尽。复有二字本所未闻亦未行也。而宣说言出于一字。其一字者。不与二字而同势也。是以一字而宣训诲。设使宣布斯训诲者。无念不念。无应不应。此句无念亦无不念。以无念句而成开化。是为族姓子入总持教。宝成如来。为诸菩萨说总持言句。于彼学入此一句者。便得普入一切佛意。我于一劫若复过劫。分别咨嗟离垢光世界功德之称。不能究尽得其边际。宝成如来讲说经道德称之慧。不可思议亦不可赐。其佛大德国土清净。巍巍超绝上不可及。宝髻菩萨闻佛授决。欢喜踊跃。以颂赞佛

  普知悉能见　　度诸法无极
  如来皆超越　　一切诸瑕秽
  大慧未曾有　　皆知我往古
  供养诸佛数　　佛悉具说之
  去来今现在　　本末为如是
  复知鄙末世　　及与一切人
  为佛所授决　　不复怀狐疑
  开化度世间　　诸根之本末
  于是一切地　　日月尚可堕
  佛口所可宣　　终不有改变
  佛出至诚言　　所演无有虚
  授以尊觉道　　成佛人中上
  如我志所愿　　严净于佛土
  所言亦如是　　悉知我心念
  彼闻此教已　　悦颜无犹豫
  所修行为尊　　欲度众生故
  如我之所行　　当复增无量
  严治其本际　　我身奉净行
  兴发行得佛　　度诸法无极
  勤力无怯弱　　由从精进至
  堪任所布施　　皆知我往古
  未曾舍精进　　至大哀如来
  为以诸众生　　本末为如是
  吾当悉开化　　得佛度异学

宝髻菩萨说此偈时。七万二千人皆发无上正真道意。悉愿生彼离垢光世界。同时发声俱说是言。宝成如来得佛道时。普令吾等生彼佛土。佛皆记说当生其国

尔时世尊告贤者阿难。受是经典持讽诵说。广为众人宣传其旨。殷勤劝助是经典要。天上世间之所归伏而共供养。所以者何。其闻此经我悉授决。其不信者本宿德薄。其受是经德本非凡。趣闻此经世世值佛。何况闻持而奉行说。功勋无限。族姓子族姓女。若以七宝满此三千大千世界。随时布施。如是比类于百千岁。其闻此经欢喜信持。功德踰彼。阿难白佛。此经名何云何奉持。佛言。名曰菩萨净行宝髻所问。当奉持之。佛说如是。宝髻及十方诸会菩萨。贤者阿难。天龙鬼神揵沓和阿须伦世人。闻佛所说莫不欢喜

大宝积经卷第一百一十八大宝积经卷第一百一十九

        大唐三藏菩提流志奉　诏译

    胜鬘夫人会第四十八

如是我闻。一时佛在舍卫国祇树给孤独园。时憍萨罗波斯匿王及末利夫人。初证法已。共相谓言。我女胜鬘。慈晤聪愍多闻智慧。若见如来。于甚深法速能解了无诸疑惑。我今应当令善谕者发其诚信。作是议已。王及夫人即便作书。称扬如来真实功德。时遣一使名真提罗。奉持王书诣无斗城。授胜鬘夫人。时胜鬘夫人。发书寻绎。顶受忻庆生希有心。向真提罗而说偈言

  我闻如来声　　世间颇难遇
  斯言若真实　　当赐汝衣服
  若彼佛世尊　　为利世间现
  必应见哀愍　　令我睹真相
  言念须臾顷　　佛于虚空中
  现不思议身　　普放大光明
  胜鬘及眷属　　皆悉来集会
  合掌瞻仰礼　　称赞大导师
  如来妙色身　　世间无与等
  无比不思议　　是故今敬礼
  如来色无尽　　智慧亦复然
  一切法常住　　是故我归依
  善调心过恶　　及与身四种
  到不思议地　　故我今敬礼
  知诸尔炎法　　智身无挂碍
  于法无忘失　　故我今敬礼
  稽首过称量　　稽首无伦等
  稽首法自在　　稽首超思惟
  哀愍覆护我　　令法种增长
  逮及最后身　　常在如来前
  我所修福业　　此世及余生
  由斯善根力　　愿佛恒摄受

时胜鬘夫人说此偈已。及诸眷属一切大众。顶礼佛足。尔时世尊。即为胜鬘而说偈言

  我昔为菩提　　曾已开示汝
  今复值遇我　　及来世亦然

说此偈已。即于会中。授胜鬘夫人阿耨多罗三藐三菩提记。汝今称叹如来殊胜功德。以此善根。当于无量阿僧祇劫天人之中为自在王。诸所受用皆悉具足。所生之处常得遇我。现前称叹如今无异。复当供养无量无数诸佛世尊。过二万阿僧祇劫。当得作佛号曰普光如来应正等觉。彼佛国土无诸恶趣衰老病苦。亦无不善恶业道名。其中众生形色端严。具五妙境纯受快乐。蔽于他化自在诸天。彼诸众生皆趣大乘。诸有如是学大乘者。悉来生彼。时胜鬘夫人得授记已。无量天人心怀踊跃。咸愿往生彼佛世界。是时世尊。皆与授记当生彼国。时胜鬘夫人闻佛记已。于如来前合掌而立。发十弘誓。作如是言。世尊我从今日乃至菩提。于诸受戒不起犯心。世尊。我从今日乃至菩提。于诸师长不起慢心。世尊。我从今日乃至菩提。于诸众生不起恚心。世尊。我从今日乃至菩提。于诸胜已及诸胜事。不起妒心。世尊。我从今日乃至菩提。虽有少食不起悭心。世尊。我从今日乃至菩提。不自为己受畜财物。凡有所受为济贫苦有情之类。世尊。我从今日乃至菩提。不求恩报行四摄事。无贪利心。无厌足心。无限碍心。摄受众生。世尊。我从今日乃至菩提。见诸众生无有依怙。幽系疾恼种种危厄。终不舍离必愿安隐。以善饶益令免众苦。世尊。我从今日乃至菩提。若见一切诸恶律仪。毁犯如来清净禁戒。凡我所摄城邑聚落。应调伏者而调伏之。应摄受者而摄受之。何以故。以调伏摄受故。则正法久住。正法久住故。天人充满恶道减少。能令如来法轮常转。世尊。我从今日乃至菩提。摄受正法终不忘失。何以故。忘失正法则忘大乘。忘大乘者则忘波罗蜜。忘波罗蜜者则舍大乘。若诸菩萨。有于大乘不决定者。摄受正法则不坚固。便不堪任超凡夫境。则为大失。世尊。现在未来。摄受正法诸菩萨等。具足无边广大利益。发斯弘誓。圣主世尊虽复证知。而诸有情善根微薄。或起疑网。以十弘誓难成就故。彼或长夜习不善法。受诸苦恼。为欲利益如斯众生。今于佛前发诚实誓。世尊。我今发此十弘誓愿。若实不虚。于大众上。当雨天花出天妙音。胜鬘夫人。于如来前作斯言已。时虚空中即雨天花出天妙音。叹言善哉胜鬘夫人。如汝所说真实无异。尔时众会既睹斯瑞。无诸疑惑生大欢喜。同声唱言。愿与胜鬘夫人。所生之处同其愿行。时佛世尊。悉记大众如其所愿。尔时胜鬘夫人。复于佛前发三弘愿。以兹愿力。利益无边诸有情类。第一愿者。以我善根。于一切生得正法智。第二愿者。若我所生得正智已。为诸众生演说无倦。第三愿者。我为摄受护持正法。于所生身不惜躯命。尔时世尊闻斯愿已。告胜鬘言。如一切色悉入空界。如是菩萨恒沙诸愿悉入兹愿。此三愿者真实广大。尔时胜鬘夫人复白佛言。世尊。今当承佛威神辩才之力。欲说大愿。幸垂听许。佛言胜鬘。恣汝所说。胜鬘夫人言。菩萨所有恒沙诸愿。一切皆入一大愿中。一大愿者。所谓摄受如来正法。如是摄受正法。真实广大。佛言。善哉胜鬘。汝久修习。智慧方便甚深微妙。有能解了汝所说义。彼于长夜植诸善本。如汝所说摄受正法。皆是过去未来现在诸佛。已说今说当说。我得无上正等菩提。亦复常以种种相说摄受正法。如是称扬摄受正法。所有功德无有边际。如来智慧亦无边际。何以故。是摄受正法有大功德。有大利益。时胜鬘夫人复白佛言。世尊。我当承佛威神之力。更复演说摄受正法广大之义。佛言听汝所说。胜鬘夫人言。摄受正法广大义者。为得无量一切佛法。乃至能摄八万行蕴。譬如劫初兴诸色云雨众宝雨。如是摄受正法善根之云。能雨无量福报之雨。世尊。又如劫初大水之中能生三千大千界藏及四百亿种种类洲。如是摄受正法。出生大乘无量界藏。并诸菩萨神通之力。种种法门。一切世间及出世间。安乐具足。一切天人所未曾有。又如大地荷四重担。何等为四。一者大海。二者诸山。三者草木。四者众生。如是摄受正法。诸善男子及善女人。堪能荷负四种重任逾彼大地。何等为四。谓离善友无闻非法。诸有情类。以人天善根而成熟之。求声闻者授声闻乘。求独觉者授独觉乘。求大乘者授以大乘。是名摄受正法。诸善男子及善女人。堪能荷负四种重任逾彼大地。世尊。如是摄受正法。善男子善女人等。建立大地。堪能荷负四种重任。普为众生作不请友。大悲利益哀愍有情为世法母。又如大地是四种宝所生之处。何等为四。一者无价。二者上价。三者中价。四者下价。如是摄受正法。善男子善女人。建立大地有情遇已获四大宝。一切宝中最为殊胜。何等为四。谓诸有情遇斯善友。或有获得人天善根。有证声闻及辟支佛或无上乘善根功德。是名摄受正法善男子善女人。建立大地有情遇已。便能获得四种大宝。世尊。出大宝者。名为真实摄受正法。世尊。言摄受正法者。谓无异正法无异摄受正法。正法即是摄受正法。世尊。无异波罗蜜。无异摄受正法。摄受正法即是波罗蜜多。何以故。摄受正法善男子善女人。应以施成熟者以施成熟。乃至舍身随顺彼意而成熟之。令彼有情安住正法。是名施波罗蜜。应以戒成熟者。守护六根净身语意乃至威仪。随顺彼意而成熟之。令彼有情安住正法是名戒波罗蜜。应以忍成熟者。若彼有情骂詈毁辱诽谤扰乱。以无恚心及利益心最上忍力。乃至颜色亦不变异。随顺彼意而成熟之。令彼有情安住正法。是名忍波罗蜜。应以精进而成熟者。于彼有情不起懈怠下劣之心。起大乐欲最上精进。于四威仪随顺彼意而成熟之。令彼有情安住正法。是名精进波罗蜜。应以静虑而成熟者。于彼有情以无散乱成就正念。曾所作事终不忘失。随顺彼意而成熟之。令彼有情安住正法。是名静虑波罗蜜。应以智慧而成熟者。彼诸有情为利益故。问诸法义以无倦心。而为演说一切诸论一切明处乃至种种工巧之处。令得究竟随顺彼意而成熟之。令彼有情安住正法。是名智慧波罗蜜。是故世尊。无异波罗蜜。无异摄受正法。摄受正法即是波罗蜜。时胜鬘夫人复白佛言。世尊。我今承佛威神辩才之力。复说大义。佛言云何大义。世尊。摄受正法者。无异摄受正法。无异摄受正法者。摄受正法善男子善女人。则是摄受正法。何以故。若摄受正法善男子善女人为正法故舍身命财。如是人等以舍身故。证生死后际。远离老病得不坏常。无有变易究竟寂静。不可思议如来法身。以舍命故。证生死后际。永离于死得无边常。成就不可思议诸善功德。安住一切佛法神变。以舍财故。证生死后际。超过有情。无尽无减果报圆满。具不思议功德庄严。为诸有情尊重供养。世尊。舍身命财摄受正法善男子善女人等。为诸如来之所授记。世尊。若善男子善女人正法欲灭。有诸比丘比丘尼优婆塞优婆夷。互相朋党起诸诤讼。以不谄曲不欺诳心。爱乐正法摄受正法。入善朋中。入善朋者。必为诸佛之所授记。世尊。我见摄受正法有斯大力。如来以此为眼为法根本。为引导法为通达法

尔时世尊。闻胜鬘夫人所说摄受正法有大威力。叹言如是如是。善哉胜鬘。如汝所说摄受正法大威德力。如大力士。微触末摩生大苦痛。更增重病。如是胜鬘。假令少分摄受正法。令魔波旬痛切愁恼悲号叹息。亦复如是。胜鬘。我常不见余一善法令魔愁恼。犹如少分摄受正法。胜鬘。譬如牛王形色端正。身量殊特蔽于诸牛。如是胜鬘。修大乘者。设令少分摄受正法。即能蔽于声闻独觉一切善法。胜鬘。又如须弥山王高广严丽蔽于众山。如是胜鬘。初趣大乘。以饶益心不顾身命。摄受正法便能超过。顾其身命。久住大乘一切善根。是故胜鬘。当以摄受正法开示教化一切有情。如是胜鬘。摄受正法。获大福利及大果报。胜鬘。我于无数阿僧祇劫。称赞如是摄受正法所有功德。不得边际。是故摄受正法。成就如是无量功德。佛告胜鬘。汝今复应演我所说摄受正法。一切诸佛共所爱乐。胜鬘白言。善哉世尊。摄受正法者则名大乘。何以故。大乘者出生一切声闻独觉。世出世间所有善法。如阿耨达池出八大河。如是大乘。出生一切声闻独觉。世出世间所有善法。世尊。又如一切种子草木丛林。皆依大地而得生长。如是一切声闻独觉。世出世间所有善法。皆依大乘而得生长。是故世尊。住于大乘摄受大乘。即住摄受声闻独觉。世出世间所有善法。如佛世尊所说六处。谓正法住。正法灭。别解脱。毗奈耶。正出家。受具足。为大乘故说此六处。所以者何。正法住者为大乘说。大乘住者即正法住。正法灭者为大乘说。大乘灭者即正法灭。别解脱毗奈耶。此之二法。义一名异。毗奈耶者即大乘学。所以者何。为佛出家而受具足。是故大乘戒蕴是毗奈耶。是正出家是受具足。世尊。阿罗汉者。无有出家及受具足。何以故。阿罗汉。不为如来出家受具足故。阿罗汉。有怖畏想归依如来。何以故。阿罗汉。于一切行住怖畏想。如人执剑欲来害己。是故阿罗汉。不证出离究竟安乐。世尊。依不求依。如诸众生无有归依彼彼恐怖。为安隐故求于归依。世尊。如是阿罗汉。有恐怖故归依如来。是故阿罗汉及辟支佛。生法有余。梵行未立。所作未办。当有所断未究竟故。去涅槃远。何以故。唯有如来应正等觉。证得涅槃。成就无量不可思议一切功德。所应断者皆悉已断。究竟清净。为诸有情之所瞻仰。超过二乘菩萨境界。阿罗汉等则不如是。言得涅槃佛之方便。是故阿罗汉等去涅槃远。世尊。说阿罗汉及辟支佛。观察解脱四智究竟得苏息者。皆是如来随他意语不了义说。何以故。有二种死。何等为二。一者分段。二者变易。分段死者。谓相续有情。变易死者。谓阿罗汉及辟支佛自在菩萨。随意生身乃至菩提。二种死中。以分段死说阿罗汉及辟支佛。生于我生已尽之智。由能证得有余果故。生于梵行已立之智。一切愚夫所不能作。七种学人未能成办。相续烦恼究竟断故。生于所作已办之智。世尊。说生不受后有智者。谓阿罗汉及辟支佛。不能断于一切烦恼。不了一切受生之智。何以故。是阿罗汉及辟支佛。有余烦恼不断尽故。不能了知一切受生。烦恼有二。谓住地烦恼。及起烦恼。住地有四。何等为四。谓见一处住地。欲爱住地。色爱住地。有爱住地。世尊。此四住地。能生一切遍起烦恼。起烦恼者。刹那刹那与心相应。世尊。无明住地。无始时来心不相应。世尊。四住地力。能作遍起烦恼所依。比无明地。算数譬喻所不能及。世尊。如是无明住地。于有爱住地。其力最大。譬如魔王色力威德及众眷属。蔽于他化自在诸天。如是无明住地蔽四住地。过恒沙数烦恼所依。亦令四种烦恼久住。声闻独觉智不能断。唯有如来智所能断。世尊。如是如是。无明住地其力最大。世尊。如取为缘有漏业因而生三有。如是无明住地为缘无漏业因能生阿罗汉及辟支佛。大力菩萨随意生身。此之三地随意生身及无漏业。皆以无明住地为所依处。彼虽有缘亦能为缘。世尊。是故三种随意生身及无漏业。皆以无明住地为缘。同于有爱。世尊。有爱住地。不与无明住地业同。无明住地异四住地。异四住地唯佛能断。何以故。阿罗汉辟支佛。断四住地。于漏尽力不得自在。不能现证。何以故。世尊。言漏尽之增语。是故阿罗汉辟支佛。及最后有诸菩萨等。为无明地所覆蔽故。于彼彼法不知不见。以不知见于彼彼法。应断不断。应尽不尽。于彼彼法不断不尽故。得有余解脱。非一切解脱。得有余清净。非一切清净。得有余功德。非一切功德。世尊。以得有余解脱非一切解脱。乃至有余功德非一切功德故。知有余苦。断有余集。证有余灭。修有余道

尔时胜鬘夫人复白佛言。世尊。若复知有余苦。断有余集。证有余灭。修有余道。是名少分灭度。证少分涅槃向涅槃界。若知一切苦。断一切集。证一切灭。修一切道。彼于无常败坏世间。得证常寂清凉涅槃。世尊彼于无护无依世间。为护为依。何以故。于诸法中。见高下者不证涅槃。智平等者。解脱等者。清净等者。乃证涅槃。是故涅槃名等一味。云何一味谓解脱味。世尊。若无明地不断不尽。不得涅槃一味等味。何以故。无明住地不断不尽故。过恒沙等一切过法。应断不断。应尽不尽。过恒沙等一切过法。不断不尽故。过恒沙等诸功德法。不了不证。是故无明住地。与于一切所应断法诸随烦恼为生处故。从于彼生。障心烦恼。障止烦恼。障观烦恼。障静虑烦恼。如是乃至障三摩钵底。加行智果证力无畏。所有过恒沙等一切烦恼。如来菩提。佛金刚智之所能断。诸起烦恼。一切皆依无明住地。无明住地为因缘故。世尊。此起烦恼。刹那刹那与心相应。世尊。无明住地从无始来心不相应。世尊。若复过恒河沙如来菩提。佛金刚智所应断法。一切皆是无明住地。依持建立。譬如一切种子丛林。皆依大地之所生长。若地坏者彼亦随坏。如是过恒沙等如来菩提。佛金刚智所应断法。一切皆依无明住地之所生长。若彼无明住地断者。过恒沙等如来菩提。佛金刚智所应断法。皆亦随断。如是过恒沙等所应断法。一切烦恼及起烦恼。皆已断故。便能证得过恒沙等不可思议诸佛之法。于一切法。而能证得无碍神通。得诸智见离一切过。得诸功德为大法王。于法自在。证一切法自在之地。正师子吼。我生已尽。梵行已立。所作已办。不受后有。是故世尊。以师子吼。依于了义一向记说。世尊。不受后有智有二种。何谓为二。一者谓诸如来以调御力。摧伏四魔超诸世间。一切有情之所瞻仰。证不思议清净法身。于所知地得法自在。最胜无上更无所作。不见更有所证之地。具足十力。登于最胜无畏之地。于一切法无碍观察。正师子吼。不受后有。二者谓阿罗汉及辟支佛。得度无量生死怖畏。受解脱乐。作如是念。我今已离生死怖畏。不受诸苦。世尊。阿罗汉辟支佛。如是观察谓不受后有。不证第一苏息涅槃。彼等于未证地不遇法故。能自解了。我今证得有余依地。决定当证阿耨多罗三藐三菩提。何以故。声闻独觉皆入大乘。而大乘者即是佛乘。是故三乘即是一乘证一乘者得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提者即是涅槃。言涅槃者即是如来清净法身。证法身者即是一乘。无异如来。无异法身。言如来者即是法身。证究竟法身者即究竟一乘。究竟一乘者即离相续。何以故。世尊。如来住时无有限量。等于后际。如来能以无限大悲无限誓愿。利益世间。作是说者是名善说。若复说言如来是常是无尽法一切世间究竟依者。亦名善说。是故能于无护世间无依世间。与等后际。作无尽归依常住归依究竟归依者。谓如来应正等觉。法者是一乘道。僧者是三乘众。此二归依非究竟依。名少分依。何以故。说一乘道证究竟法身。于后更无说一乘道。三乘众者有恐怖故。归依如来求出修学。有所作故。向阿耨多罗三藐三菩提故。二依非究竟依。是有限依。若诸有情。如来调伏归依如来。得法津润。由信乐心。归依于法及比丘僧。是二归依。由法津润信入归依。如来者非法津润信入归依。言如来者是真实依。此二归依以真实义。即名究竟归依如来。何以故。如来不异此二归依。是故如来即三归依何以故。说一乘道。如来最胜具四无畏。正师子吼。若诸如来。随彼所欲而以方便。说于二乘即是大乘。以第一义无有二乘。二乘者同入一乘。一乘者即胜义乘。世尊。声闻独觉初证圣谛。非以一智断诸住地。亦非一智证四遍知诸功德等。亦非以法能善了知此四法义。世尊。于出世智。无有四智渐至渐缘。世尊。出世间智无渐至法。如金刚喻。世尊。声闻独觉。以于种种圣谛之智。断诸住地。无有出世第一义智。唯有如来应正遍知。非诸声闻独觉境界。以不思议空性之智。能破一切诸烦恼[穀-禾+卵]。世尊。破烦恼[穀-禾+卵]究竟之智。是名出世第一义智。初圣谛智非究竟智。是于趣向阿耨多罗三藐三菩提智。世尊。真圣义者即非二乘。何以故。声闻独觉。唯能成就少分功德。名之为圣。世尊。言圣谛者。非诸声闻独觉之谛及彼功德。而此谛者唯有如来应正等觉。初始了知。然后为彼无明[穀-禾+卵]藏世间众生。开示演说故名圣谛。世尊。此圣谛者。甚深微妙难见难了。不可分别。非思量境。一切世间所不能信。唯有如来应正等觉之所能知。何以故。此说甚深如来之藏。如来藏者。是佛境界。非诸声闻独觉所行。于如来藏说圣谛义。此如来藏甚深微妙。所说圣谛亦复深妙。难见难了不可分别。非思量境。一切世间所不能信。唯有如来应正等觉之所能知。若于无量烦恼所缠如来之藏。不疑惑者。于出一切烦恼之藏。如来法身亦无疑惑。世尊。若有于此如来之藏及佛法身。不可思议佛秘密境。心得究竟。于彼所说二圣谛义。能信能了能生胜解。何等名为二圣谛义。所谓有作及以无作。作圣谛者。是不圆满四圣谛义。何以故。由他护故。而不能得知一切苦断一切集证一切灭修一切道。是故不知有为无为及于涅槃。世尊。无作谛者。是说圆满四圣谛义。何以故。能自护故。知一切苦。断一切集。证一切灭。修一切道。如是所说八圣谛义。如来但以四圣谛说。于此无作四圣谛义。唯有如来应正等觉作事究竟。非阿罗汉及辟支佛力所能及。何以故。非诸胜劣下中上法能证涅槃。云何如来。于无作谛得事究竟。谓诸如来应正等觉。遍知诸苦。断诸烦恼。及超烦恼所摄苦集。能证一切意生身蕴所有苦灭。及修一切苦灭之道。世尊。非坏法故。名为苦灭。何以故。言苦灭者。无始无作。无起无尽。常住不动。本性清净。出烦恼[穀-禾+卵]。世尊。如来成就过于恒沙具解脱智不思议法。说名法身。世尊。如是法身不离烦恼。名如来藏。世尊。如来藏者。即是如来空性之智。如来藏者。一切声闻独觉所未曾见。亦未曾得。唯佛了知及能作证。世尊。此如来藏空性之智。复有二种。何等为二。谓空如来藏。所谓离于不解脱智一切烦恼。世尊。不空如来藏。具过恒沙佛解脱智不思议法。世尊。此二空智诸大声闻。由信能入。世尊。如是一切声闻独觉空性之智。于四倒境攀缘而转。是故一切声闻独觉。所未曾见亦未曾证。一切苦灭唯佛现证。坏诸烦恼修苦灭道。世尊。此四谛中。三谛无常。一谛是常。何以故。如是三谛入有为相。有为相者。则是无常。言无常者是破坏法。破坏法者非谛非常非归依处。是故三谛以第一义。非谛非常非归依处。世尊。一苦灭谛离有为相。离有为相则性常住。性常住者非破坏法。非破坏者是谛是常。是归依处。世尊。是故苦灭圣谛以胜义故。是谛是常是归依处。世尊。此苦灭谛是不思议。过诸有情心识境界。亦非一切声闻独觉智所能及。譬如生盲不见众色。七日婴儿不见日轮。苦灭谛者亦复如是。非诸凡夫心识所缘。亦非一切声闻独觉智之境界。凡夫识者。谓二边见。一切声闻独觉智者。名为净智。言边见者。于五取蕴执着为我。生异分别。边见有二。何者为二。所谓常见及以断见。世尊。若复有见生死无常涅槃是常。非断常见。是名正见。何以故。诸计度者见身诸根。受者思者。现法灭坏。于有相续不能了知。盲无慧目起于断见。于心相续刹那灭坏。愚闇不了意识境界。起于常见。世尊。然彼彼义。过诸分别及下劣见。由诸愚夫妄生异想颠倒执着。谓断谓常。世尊。颠倒有情。于五取蕴。无常常想。苦为乐想。无我我想。不净净想。声闻独觉所有净智。于如来境及佛法身。所未曾见。或有众生信如来故。于如来所。起于常想乐想我想及于净想。非颠倒见即是正见。何以故。如来法身是常波罗蜜。乐波罗蜜。我波罗蜜。净波罗蜜。若诸有情作如是见。是名正见。若正见者名真佛子。从佛口生。从正法生。从法化生。得佛法分。世尊。言净智者。则是一切声闻独觉智波罗蜜。此之净智。于苦灭谛尚非境界。况苦灭谛。是四入流智之所行。何以故。三乘初业。不愚法者。能于彼义当证当了。世尊。为何义故说四入流。世尊。此四入流是世间法。世尊。能一入流。于诸入流为最为上。以第一义是为入流。是为归依。是苦灭谛。世尊。生死者依如来藏。以如来藏故。说前际不可了知。世尊。有如来藏故得有生死。是名善说。世尊。生死者。诸受根灭无间相续。未受根起名为生死。世尊。生死二法是如来藏。于世俗法名为生死。世尊。死者诸受根灭。生者诸受根起。如来藏者则不生不死。不升不坠离有为相。世尊。如来藏者常恒不坏。是故世尊。如来藏者。与不离解脱智藏。是依是持。是为建立。亦与外离不解脱智诸有为法。依持建立。世尊。若无如来藏者。应无厌苦乐求涅槃。何以故。于此六识及以所知如是七法。刹那不住不受众苦。不堪厌离愿求涅槃。如来藏者。无有前际无生无灭。法受诸苦。彼为厌苦愿求涅槃。世尊。如来藏者。非有我人众生寿者。如来藏者。身见有情。颠倒有情。空见有情。非所行境。世尊。如来藏者是法界藏。是法身藏。出世间藏。性清净藏。此本性净。如来藏者如我所解。纵为客尘烦恼所染。犹是不可思议如来境界。何以故。世尊。刹那刹那善不善心。客尘烦恼所不能染。何以故。烦恼不触心。心不触烦恼。云何不触法而能得染心。世尊。由有烦恼有随染心。随烦恼染难解难了。唯佛世尊为眼为智为法根本为尊为导。为正法依。如实知见

尔时世尊叹胜鬘夫人言。善哉善哉。如汝所说。性清净心随烦恼染。难可了知。复次胜鬘。有二种法难可了知。何等为二。谓性清净心难可了知。彼心为烦恼染。亦难了知。如此二法。汝及成就大法菩萨。乃能听受。诸余声闻由信能解。胜鬘。若我弟子增上信者。随顺法智。于此法中而得究竟。顺法智者。观根识境。观察业报。观罗汉眠观心自在爱乐禅乐。观声闻独觉圣神变通。由成就此五善巧观。现在未来声闻弟子。因增上信随顺法智。善能解了性清净心。烦恼所染而得究竟。胜鬘。是究竟者为大乘因。汝今当知信如来者。于甚深法不生诽谤。尔时胜鬘夫人白佛言。世尊。复有余义能多利益。我当承佛威神之力。演说斯事。佛言善哉。今恣汝说胜鬘夫人言。有三种善男子善女人。于甚深法离自毁伤。生多功德入大乘道。何等为三。若善男子善女人等。能自成就甚深法智。或有成就随顺法智。或有于此甚深法中不能解了。仰推如来。唯佛所知非我境界。除此三种善男子善女人已。诸余有情于甚深法。随己所取执着妄说。违背正法习诸外道。腐败种子。设在余方应往除灭。彼腐败者。一切天人应共摧伏。胜鬘夫人说是语已。与诸眷属顶礼佛足。时佛世尊赞言。善哉。胜鬘。于甚深法方便守护。降伏怨敌善能通达。汝已亲近百千俱胝诸佛如来。能说此义。尔时世尊放胜光明普照大众。身升虚空高七多罗量。以神通力足步虚空。还舍卫城。时胜鬘夫人与诸眷属。瞻仰世尊目不暂舍。过眼境已欢喜踊跃。递共称叹如来功德。一心念佛还无斗城。劝友称王建立大乘。城中女人七岁已上。化以大乘。友称大王亦以大乘。化诸男子七岁已上。举国人民无不学者

尔时世尊入逝多林。告尊者阿难及念天帝。时天帝释与诸眷属。应念而至住于佛前。尔时世尊告帝释言。憍尸迦。汝当受持此经演说开示。为三十三天得安乐故。复告阿难。汝亦受持。为诸四众分别演说。时天帝释白佛言。世尊。当何名斯经。云何奉持。佛告天帝。此经成就无边功德。一切声闻独觉力不能及。况余有情。憍尸迦当知。此经甚深微妙大功德聚。今当为汝略说其名。谛听谛听善思念之。时天帝释及尊者阿难白言。善哉世尊。唯然受教。佛言。此经赞叹如来真实功德。应如是持。说不思议十种弘誓。应如是持。以一大愿摄一切愿。应如是持。说不思议摄受正法。应如是持。说入一乘。应如是持。说无边谛。应如是持。说如来藏。应如是持。说佛法身。应如是持。说空性义隐覆真实。应如是持。说一谛义。应如是持。说常住不动寂静一依。应如是持。说颠倒真实。应如是持。说自性清净心烦恼隐覆。应如是持。说如来真子。应如是持。说胜鬘夫人正师子吼。应如是持。复次憍尸迦。此经所说断一切疑。决定了义入一乘道。憍尸迦。今以所说胜鬘夫人师子吼经。付嘱于汝。乃至法住。于十方界开示演说。天帝释言。善哉世尊。唯然受教。时天帝释尊者阿难。及诸大会天人阿修罗健闼婆等。闻佛所说。皆大欢喜信受奉行

大宝积经卷第一百一十九大宝积经卷第一百二十

        大唐三藏菩提流志奉　诏译

    广博仙人会第四十九

如是我闻。一时佛在无斗战城恒河岸上。时有无量诸比丘众尊者阿难。摩诃迦叶。舍利弗。薄拘罗。离婆多。阿若憍陈如等。所作已办离诸尘染。诸漏已尽不复退转。禅诵经行无暂懈息。或如群雁游止寂静。或在林间常处禅定。安住如来光明教门。调伏诸根得无所畏。时娑罗鸡林枝叶繁茂。香花布地。拘枳罗鸟。迦陵伽鸟。鹅王群蜂。栖集和鸣。能令众生离诸昏堕。尔时如来。告诸比丘。汝等应当勤作所作。以于戒仪而自荫覆

是时西方忽然辉耀。如日轮光。尊者阿难未离欲故。白言世尊。今此光明是何之相。佛言阿难。是五通仙最胜上者黑香之子。名曰广博。节食羸瘦身无光润。与其同行五百人俱。所谓不白仙人。天人仙人。苫波野那仙人。丹荼野那仙人。迦摩野那仙人。迷佉那斯仙人。疑味仙人。度罗仙人等。前后围绕当来诣我。尔时广博仙人。遥睹世尊。身意寂静处在林薮。为诸比丘之所侍卫。即自思惟。奇哉尊贵。一切智处色相具足。舍去群臣转轮王位六万彩女。如弃毒食。苦行山林离诸欲乐。名称普闻诚不虚也。时彼众中有一仙人。字那刺陀。遥瞻如来心生欢喜。即说颂曰

  瞻彼青花树林下　　犹紫金聚者何人
  弥楼妙宝流焰光　　亦如秋月无氛翳

尔时诸仙皆怀悦豫。合掌恭敬渐诣佛所。于时世尊告诸比丘。汝等观彼阎浮洲中诸仙人等。蓬发上靡。栖止林莽涂灰却粒。或月半月节食羸瘦。鹿皮树皮以充衣服。不剪发爪蹲处露地。或如烟炭黑蜂之色。咒术祭火以为吉祥。空地树下随处而居。或坠高岩或投深水。炎火赫日炙身苦体。恃其种姓离无上智。比丘当知。此诸仙人。见不清净耽着诸有。轮回生死不能出离。时诸比丘。闻佛世尊作是说已。同声白言。我等今者。由依如来勤修梵行。于诸有中永当出离

尔时广博仙人与其同类渐至佛所。睹诸罗汉威德尊严。内怀倾悚曲躬低视。各结散发。身佩白绳。颜容黑暗。两目黄绿。头发枯燥。执三拒木。身形卑陋。或行虚空。或谈俗典。至如来前。白言世尊。今此众会愿佛知时。佛言广博。我已了知诸有受生及于自性。时阿难陀。白言世尊。此何仙人众所围绕。词慧通敏顶发上靡。佛言阿难。此是广博。作围陀典。奉持习行赊羯罗教。造诸种种世俗文字。尔时诸罗汉等共相谓言。而此仙人有何所得苦行如是。于生死中而不解脱。复自思惟。此仙人众今来佛所。当何所问。为因缘耶。为无我耶。尔时广博仙人合掌向佛白言。世尊。佛出现难众会亦难。我于今者有少疑问。愿垂哀愍。佛言大仙。恣汝所问当为解说。广博仙言。云何为施何者施义。云何施主施主何义。云何施者不名施主。云何施主不名施者。云何行施于受施者而获福报。云何施已。若现在世。若命终后。施福随行为积为聚。世尊。如来灭后供养塔庙。谁为受者获于福报。佛言大仙。汝今所问甚为希有。为欲觉悟新发意者。时舍利弗。在于众中发白面皱。以其右手抬眉顾视。久而言曰。我昔曾闻。广博仙人世所称赞。云何今者。不知言问如小童子。云何不问因缘无我深妙之义。而乃问于施之果报。尊者阿难。前礼佛足。白言世尊。彼之仙人于施贪着。我愿为彼解说施义。佛言阿难。若问如来声闻答者。非如来教。时舍利弗。复白佛言。今此仙人有彼彼疑。我愿解说。佛言不尔。汝于声闻最为上首。若于我前有所解说。令诸众生堕于恶趣。谤云如来非决定智。或云如来觉性了已犹有我慢

尔时诸比丘闻佛世尊作是说已。生净信心。白言世尊。广博仙人有所疑问愿为除断。尔时佛告广博仙言。汝今谛听。施之果报及业差别。若诸受者。能令施主生于果报。是为施义。若有众生发清净心以己财宝。令执事人随所施者。其财宝主名为施主。其执事人名为施者。若复有人自持己物净心施者。得为施主。亦名施者。复次大仙。三十二种不净之施。汝今谛听。若复有人。倒见施者不名净施。因报恩者不名净施。不哀愍者不名净施。为色欲者不名净施。若施火中不名净施。掷水中者不名净施。恐怖施者不名净施。施五家者不名净施。以毒施者不名净施。施刀杖者不名净施。杀害施者不名净施。为摄他故不名净施。为称誉者不名净施。为倡伎者不名净施。因占相者不名净施。求饰好者不名净施。结朋友者不名净施。于庄宅中鸟兽来吃。不欢欣者不名净施。学工巧者不名净施。因病施医不名净施。先因打骂后施财物不名净施。若怀疑惑言我今施。为有报耶为无报耶。如此施者不名净施。若舍施已内怀热恼。悭恋悔恨不名净施。若言受者后当为我作牛畜者。不名净施。若言福报我自受者。不名净施。若人少壮无净信心。后遭病苦或临死路。楚毒在身肢节分解。阎罗使者调弄于前。亲属平生悲泣相视。如此之时方始施者。不名净施。或有念言。令余城邑知我施者。不名净施。若怀嫉妒增上施者。不名净施。慕他豪族为求婚姻。持诸金银缯彩衣服而施与者。不名净施。若求男女及余杂缘而施与者。不名净施。若有念言。我于今施来世受报。不名净施。见贫穷者不生哀愍。翻持钱财施富贵人。不名净施。或贪花果而施与者。不名净施。善男子。此三十二爱染之施。犹如有人携持种子。于荒秽田随所种殖。然彼种子依大地界。遇天雨润决定生牙。至于花实少得收获。尔时广博仙人复白佛言。如何施与。持戒毁戒而不灭坏。佛言大仙。若复有人净信因果发欢喜心。为诸众生无有悔吝。亦不分别持戒破戒。复次善男子。有五种施名为大施。何者为五。一者时施。二者道行之者。三者病人及看病者。四者说正法人。五者诣他国者。复有五种。一者法施。二者食施。三者居住。四者灯明。五者香花。广博复言。何等清净。佛言。若发信心。为诸众生内怀哀愍。回向菩提遍净解脱。得为清净。复有五种无上之施。何者为五。一者施于如来。其施无上。二者施于众僧。其施无上。三者施说法者。其施无上。四者施父。其施无上。五者施母。其施无上。复有施者名为大施。所谓失位国王名为大施。若为县官之所逼迫。无所依怙及为疾病之所痛恼。施如此人名为大施。若为王者所弃。临刑之时及余命难。舍己之命救于彼命。名为大施。或于疾病之人施与医药。亦名大施。或于具戒众僧以时而施。亦名大施。或施求智慧者。亦名大施。或于傍生之俦虾蟆蛭乌及余鸟兽。而施与者。亦名大施。或于乏劣之者施令充足。亦名大施。若复有人。劝他净施及余随喜。亦名大施。复次大仙。汝先所问。于我灭后云何种植获福报者。善男子。诸如来者。皆是法身非是色身。若复在世。或复灭后。所有供养福无有异。如转轮王于其大地。唱如是言。我之国界。不应有人杀害众生及于妄语。其国之人。虽未见王兼亲侍卫。但闻教敕即便遵奉。王于是人必生欢喜。是人由王不杀害故。获生天报。其有违者堕于恶趣。如是大仙。虽有众生见我色身。不护其戒何所得耶。如提婆达多。虽遇于我犹堕地狱。若复有人。于来世中勤修我教。则为希有。如见我身无有异也

复次大仙。如汝所问。福德因缘为积聚者。如萩苇中因烧出焰。而此光焰。不可得言为积为聚。如是施主。积集资粮犹影随形。而无见者。亦如蒲萄甘蔗未押之时汁不可见。彼于一节二节之中求汁积聚了无见者。然于彼汁不从外得。福德果报亦复如是。不在施主手中心中及于身中。亦不相离。亦如尼拘陀子未成熟时牙不可见。譬于商人持少财物往诣大城。有所贸易广获财利。福报亦尔。如蜂采花不损其色。云涵雨润谁见积聚。于其出生必自成办

尔时广博仙人。白言世尊。施之差别我已了知。云何此识住于身中有所爱着。佛言大仙。犹如国王住于城中。惧他军来预作濠堑。积聚粮贮教养战士。建诸幡旗调习醉象。严诫众兵唱言警备着于衣甲专情斗战。执利刀仗露刀而住。王福尽故。他军强盛遂即灭坏。如是识王住于身城。见于六处无常侵害。穿信濠堑。被正念甲。御醉法象。调习意马。告六处云。今有无常威力军来。宜应速疾被于施甲持于智刃。办惭愧弩。安戒堤防。时彼六处。为无常军渐相逼迫。尔时彼识。如福尽王弃城而走。别住城国。广博仙人。复白佛言。云何了知是福德城非福德城。我当舍之。佛言大仙。犹如有人乘大舟船欲渡大海。时遇风涛鼓涌飘荡。鼋鼍鲸鲵互为崄害。是人因船遂达彼岸。既得无畏。绕船三匝恭敬祭祀。唱言善哉。我由此船得渡大海。如是大仙。有福众生命终之后。作是思惟。我今此身善趣天上。所得人身为不空过。乘此身船渡恶趣海。善哉前生甚可恭敬。若复有人堕恶趣者。犹如渡海乘朽烂船。于大海中或沈或浮。摇扬倾覆。是人残命虽至岸上。复遇师子虎狼充满。骂言咄哉。此朽故船。倒行大海令我怖畏。见如此苦。堕恶趣识亦复如是。毁骂其身。我徒养育遭此恶报。我久于世担负秽草。如蚕作茧徒自缠缚。如何令我沉溺若此

尔时彼识。于第二身适住母胎。才七日中能作是念。我从彼灭而来生此。由善业者其心欢喜。能令彼母有三种相。所谓母面熙怡颜容端妙。无诸皯[黑*黽]。右脚压地倍重常时。复以其手数摩右胁。被白色衣增加姝丽。造恶业识。亦七日中作是忆念。我从某城曾作某罪。作是念已便生悲恼。能令其母现诸恶相。所谓身体臭秽羸瘦萎黄。常怀悲愁数数变吐。祸横盈门灾难逼迫。饶诸疾病。将产之时。或损母命或复自死尔时广博仙人。复白佛言。世尊。彼识初入胎时得何念慧。佛言。而此之识亦入胎已。见阎浮洲园苑树林。宫殿池沼遍满庄饰。亲族聚会情极慕乐。复以天慧光明。随念忆知无量百千彼彼生处。彼是我母。曾五百世生育于我。作是念已生厌离心。唱言咄哉。于此世间生死足矣。劬劳诸有永愿休息。时广博仙人。复白佛言。世尊。彼识既能如是厌离。岂不出离生死中耶。佛言不也。大仙。彼识无出离之相。能得解脱无有是处。而彼识界。于生死中虽尔厌离。能出离者不应受生。若不尔者。或有修福及于造罪。一切皆应趣向涅槃。如汝所言。识思惟者。是识增上非智增上。所以者何。识能分别。智能了知。识智和合乃如汝说。尔时世尊。欲重宣此义。而说偈言

  能防诸怨贼　　积集烦恼者
  了智与无智　　及慧共愚痴
  见慢并无明　　如是等一切
  无有少离智　　由识能了知
  识智不相离　　和合我常说
  一轮不为车　　二轮亦不成
  亦不由于余　　要假人与牛
  并具于辐辖　　二辋相资备
  辕轭兼络绳　　尔乃得名车
  身车亦如是　　诸界和合生
  诸根悉备具　　由识能牵挽
  肢节相缀连　　筋脉恒遍满
  髑髅皮发覆　　肠肺并心脾
  肝胃众和合　　建立假为身
  识王处其中　　非身为调御
  了知诸体性　　是名智识俱

复次大仙。此识微细不可色见。无有诸根亦不相离。若诸丈夫有所怯弱。或生恐怖或起寻思。皆识增上非智作用。尔时广博仙人。复白佛言。世尊。云何观察一切众生从地狱趣而来生者。乃至人趣而来生者。何业差别。生于天人傍生饿鬼及于地狱。佛言大仙。众生本性。没此生彼。是佛境界。非五通仙之所能知。亦非天人魔梵色究竟等。并余声闻之所觉了。大仙。若于我法获离三垢。得初果时所有境界。尚非帝释那罗延天。汝诸仙等之所能知。尔时如来作是说已。广博仙人。便自思惟。此轮回中圣智境界未曾会遇。礼佛双足。白言世尊。我于今者。衰朽失念不能获果。无任负荷住持菩提。归依佛法及离垢僧。我从今日与诸弟子及于眷属。归佛法僧。唯愿世尊。示教利喜以圣智日。常住世间除烦恼。翳善哉世尊。愿为演说一切众生从天坠者。佛言谛听。今正是时。若有众生坚固成就施香花鬘。此人必当生持鬘天。临终之时身发妙香及感鲜华。而复自见种种色华来散其上。或有见于楼阁宫殿。悬诸铃[糸*(乃/木)]杂华严饰。百千天女而处其中。命终之后见持鬘天。父母和合如赡部人。便为爱风飘入胎藏。时彼天母怀妊七日。于右胁下遂诞其子。彼适生已。于其胸前天悦意花自然为鬘。具七种色。所谓白黑黄赤天绀红莲。及如火铜光明炫耀。香气因风遍一由旬。故号彼天谓为持鬘。宫中有树其汁香美犹如甘露。园苑果实有八上味。大如频螺。彼天所食皆是甘果。非余抟食。凡有饥想果自现树。所履之地无诸荆棘。鲜花柔草周布清净。或有宫殿如白花聚。或以黄金为屋鸱吻。彼之天女光容藻饰。眺望轩槛相与娱乐。其所寿命天二百年。将终殁时有二种相。所居之树。其叶凋悴枝条垂下。其花香气自然隐没。所著花鬘忽然萎黄。清凉之风变为毒热。最胜天城弃舍而去。时诸天女见此衰相围绕悲号。叹言咄哉。何彼无常无少慈悲。今于我等爱重之者。制不由己。将舍我等在于须臾。时彼天子。渐为热病之所逼迫。遍体火现。炎焰虽加而无热恼。心犹快乐。从彼而没。人间受生在于胎中。能令其母爱香花鬘及诸果实。又于梦中常见城邑场肆严饰遍垂花璎。亦既生已。形容光润白服花鬘。常所眷爱。好游亲属耽着欲乐。情恋女人往来轻躁。名衣上服及诸园林。靡不贪乐。见富贵者倍生喜悦

复次大仙。四天王天趣向之者。若有众生以怜愍心。见贫穷者施于衣食。及诸病人随与医药。或造井泉。或施池沼。其人将终形不羸瘦。容色无变身无垢汗。声不[斯/瓦]破。亦不遗沥大小便利。六尘充足诸根无损。能见自身在天众中。命既终已。色如红莲口出妙香。复有清风。吹妙花香拂其尸上。于是彼识见四天界。父母欢游耽醉情欲。时彼天父。以其右手摩天母背。即于母髀而得受胎。经七日已遂即诞生天饰具足。大仙当知。四天王天所居之地。纵广八万四千由旬。黄金白银雌黄雄黄。间错庄饰。百千天女充满其中。百千花果如人形像。于彼园苑。天摩尼光常所明照。树林枝茎。垂劫波衣及妙缯彩。其树滑润见者欣悦。于其龛室常悬乐具。箫笛之俦自然发声。彼天童子抟食为力。香美粳稻色如红莲。味逾甘露。其所食器具于二种。一者金器。二者银器。随意所乐色香美味。皆于中现。复有天浆名为花酒。香冷殊特。设有嗅者亦自然醉。彼之天人各有寝殿。名曰初秋。遍垂花条。金银杂宝娑兰鸡树。数有百千合覆其上。复有种种坐卧敷具。六万天女颜容殊妙被服光鲜。其声寥亮韵合天乐。为诸欲神之所造化。歌舞倡妓言笑往来。能令见者增其染爱。其宫殿前树以刹柱。金银间错缯彩庄严。悬诸宝幡随风摇扬

有四天王。一曰持国。二曰增长。三曰威目。四曰多闻。此四天王于彼天界。吟啸歌舞宴会嬉游具足安乐。时彼众中诸天童子。力艺殊胜具天妙身。垂臂往来犹如醉象。身香郁烈遍一由旬。其所寿命天五百年。无中夭者。园苑林树荣色光洁。迦潭婆花而以庄严。咸悉芬馥无诸臭秽。四面阶道杂宝所成。百千天女常为歌伎。诸宝器中出妙音声。善男子。彼等天人寿欲尽时。有三种相。一者身光隐没。二者花无香气。三者不闻天女奏诸伎乐。常所欢游园林宫苑鸟声和雅。是喜好处皆不爱乐。花鬘萎悴天女悲号。衣生垢秽。瞻视昔来欣玩之具。复增闷绝。身上汗流眼变枯燥。如取水鱼置夏日中。热恼所逼宛转于地。时诸女等。见彼天男愁苦如此。皆来围绕同声号哭。唱言。苦哉苦哉。我所爱者奈何如是。所好喜事翻为愁苦。今之云何。舍我等辈及游宴处。时天女等以偈叹曰

  种种妙庄严　　仁者所游宴
  最上福德城　　四面具楼阁
  天女恒充满　　园林镇荣茂
  云何舍欢爱　　苦哉此无常

尔时诸天女等。说此偈已相视哽咽。各以右手取诸杂花遥散其上。复作是言。仁者。汝具福故当生人间。彼是福地应以信心植诸善种。尔时彼天。见诸女等皆已背舍。重增热恼身心炽然。如以苏滴置炎铁上。欻自销灭余微灰烬。复为业风之所吹散。如邻虚尘为千亿分更不可见。于是彼识从天降下见受生处。父母和合心怀喜悦。便入胎藏。才处胎时。母即相现。饮食增多不啖血肉。乐着绯衣爱聚会处。于诸亲属倍加眷念。虽怀其子曾无痛恼。口无流涎身不沉重。亦既生已人相端严。其眼绀色如天青宝众所乐见。闻于上界四天王事。自然欣悦常乐舍施。爱妙香衣性好数食。常喜歌舞园林女色。靡不留恋

复次大仙。若有众生以净信心。远离杀害及于偷盗。持诸饮食上妙资具衣服财宝。而行舍施。勤诚散花礼拜佛塔。寿命尽时。身无疾苦垢腻臭秽。念所习业曾不忘失。面如金色。鼻不陷曲。心不惊恼。喉不闭塞。亦不喘息。不为风刀之所解截。声不[斯/瓦]破。寝膳安宁。大仙当知。如斯之人。毒不能害饮食消化。折伤夭枉皆所远离。其人命终以天识故。见三十三天百千楼阁。金摩竭鱼庄饰门柱。蛇胜栴檀香水涂洒。其地柔洁白逾霜雪净如颈珠。黄檀香树。天宝灯烛杂错行列。天诸男女。游戏园林耽染狂醉。既睹斯已遂生欢乐。犹如贯珠为人将取。入天母手以为胎藏。时母手掌。因即生花持示天父。共相庆悦。复以两手摩捼其华子即诞孕。时彼天母告天父曰。我于今日诞一童子。增长胜种便会亲族以为欢贺。生满七日天相具足。忆念前生。从某处灭今来生此。某是我父某是我母。曾修某善。作是念时耸然欢欣。便于诸欲而生痴爱。于天界中宫苑园林。自然了见贪喜爱着。尔时童子垂臂佣长犹如象鼻。其胸峻实如师子臆。腰腹圆细无有垂皱。背脊端平无高下骨。两髀圆相如芭蕉茎。肌肉光洁无诸黧皯。无有耏毛及杂臭秽。上妙香气从身流出。花鬘璎珞天衣轻密。不假外求自然被体。时宫殿中所有天女无天男者。见此童子共来围绕。咸作是言。善来仁者。此之宫殿皆是汝有。我等诸女先无依怙。愿相侍从。其中或云此辈盛年。乳如金瓶面犹红莲。此园苑中。如是天树拘毗罗林垂覆荣好。六万天女前后周遍。善哉仁者。可与我等永以娱乐。如云中电不常而有。或有宫殿。箫鼓琵琶诸杂天乐自然发声。上妙敷具及师子座。严饰珠璎垂以缯彩。而诸缯彩。非是茧蚕之所作者。时彼童子睹斯珍饰。如灌顶王升座而坐。既升座已。诸所珍玩咸出声言。此善业人。从阎浮洲修天福故。而来生此。诸人应当来此承事歌舞娱乐。令此福人欢喜无厌。出此声已。园林宫殿。六万彩女。捧持天花被服光耀。身所发香。如蒲萄酒蜜酒花酒。闻其香者令人昏醉。同声唱言。汝积天福愿时充奉。于是童子与群天女。游欢喜林。及杂花林。黄毯石林。极光严林。日宫园苑。泉声园苑。音乐园苑。丛花园苑。游如是等上妙林苑。悦乐清凉无诸恶风。花香芬馥。青摩尼宝以为灯明。诸蜂鸟王出微妙音。其鸟毛羽犹如杂宝。天吠琉璃以为其嘴。飞翔群嬉遍满林树

复次大仙。彼界有池随月增减。具八功德。悦意无垢清冷澄澈。百叶香花开敷其内。岸树行列杂花充遍。而彼池中众多天女。游戏娱乐。诸宝器等随意而现。色香妙食名天甘露。如拘摩花白逾珂雪。甘香具足亦易消化。无诸苦涩杂恶等味

复次大仙。有诸天人报不纯者。虽同器食。或感赤色。或感苍色。乃至黄黑诸杂等色。天容无别唯食有异。大仙当知。彼诸众生先虽舍施。后复悔恨。由斯报故获果如是。复有园苑名曰合棔。枝条花叶杂糅庄饰。百千丛林清净柔软。犹如水精花果常茂。其林树间。诸寂静身离欲牟尼。是所栖集。天之男女常所入者。皆不为于贪爱欲乐

大仙当知。我之弟子最上声闻。骄梵钵提。是婆罗门清净族子。住于禅定慈悲之心。以彼等持开敷慈眼入三摩地。每经七日。方乃一度现出入息。彼入定时。有随意风应念而至。假使劫火烧于大地成一炎焰。于彼禅身无能损害如芥子分。而彼支体如弥楼山常所镇压。难陀龙王。及跋难陀。有大力势鼓气猛烈。弥楼山王。为之摇动。鼓作呼噏。四大海水变为碱味。骄梵钵提入定之时。彼二龙王。尽其威力无能娆乱。我此弟子在合棔林。而诸天女虽耽欲爱。睹斯尊者发清净心。以曼陀花及诸莲花。而散其上。合掌恭敬。三十三天诸童子等。亦来围绕。持天甘露资给供养。而此尊者。常为诸天于合棔林。说修多罗。及未曾有。无问自说。本事本生。因缘方广。讽诵论议。重颂授记。譬喻等经。时诸天人闻斯法要。莫不殷勤恭敬尊重。复次大仙。三十三天有聚会堂。其堂有柱八万四千。皆以金银跋阇罗宝马瑙美玉并栴檀心。结构所成。悬铃垂铎出微妙声。列诸天衣建诸幡幢。箫笛琵琶箜篌琴瑟。鞞铙螺鼓妙声振发。天之男女互相爱敬。和颜慈悦恒所聚会。于彼堂中以摩尼宝而严饰之。绿润琉璃净滑如镜。涂香末香杂花周遍。亦无飃风。及诸炎热毒蛇蚊虻。皆所远离。其所居者。无有惛睡懈怠之想。微风清和遍入林观。其诸楼阁。幰网垂覆。悬妙宝璎散诸花香。百千天女。虽则爱染。而无嫉妒及于斗诤。面貌端正犹如满月。花鬘宝珠严饰身首。妙歌清净往来不辍

复次大仙。彼天会堂周回方整。长廊宽广高树周密。犹如阴云。其堂四面复有园苑。皆百由旬。间错种种金莲杂花。出妙歌声闻者欣悦。拘迦那陀树。波梨野多树。拘毗陀罗树。以为丛林。大仙善法会堂资玩之具。皆是金银诸宝玉等。积聚琉璃以为台榭。珍奇宝物充满库藏。宫殿百千庄饰园苑。邻接远近常闻安乐。无诸疾苦及余祸患。彼之天人于诸园林游戏既已。还集此堂受于娱乐

复次大仙。三十三天。复有别殿名曰善见。皎如白日。净犹明镜。四面周匝。皆以花[糸*(乃/木)]悬布庄严。有千天女。藻缀杂花辉耀珠铎。金翠网旒以为冠饰。象马车乘践踏往来。飞扬金尘处处黄色。而于彼殿有六万柱。栌栱重叠递相辉映。间错奇珍绘以丹彩。栴檀沉水及苏合香。氛氲郁烈用涂其地。释提桓因。持金刚杵。与百千女前后围绕。来升宝殿娱玩欢乐。大仙当知。三十三天中有天王名因陀罗。其力勇健敌九千象。垂臂纤好如天象鼻。体如净金。筋肉坚密骨脉不露。臆如师子。肚不凸垂。其腰束细。金线贯璎以为头饰。珠珰晃耀天服修委。天之声明久已通达。撰造书论。饮食甘露。往来常乘伊跋罗象

复次大仙。彼之天帝然其色身非诸骨肉。纯花所成。喉声清美。身香殊特。假令狂象闻其香气。皆自调善。形貌端严犹如佛身。其所辉艳映诸金聚。夺其精光皆令黑闇。广博仙言。如来今者。赞美天帝甚为希有

尔时世尊告广博曰。彼天帝者。是无常身下劣之身。如脆草器。如假剪花。亦如画师图饰彩绘。亦如工人刻木形像。又如结花不久散灭。何足称叹。复次大仙。我之弟子。有神通者名阿那律。但以父母所生之身。节节支体。一分之力犹过帝释。时阿那律在于座中。闻于如来说如是言。便作是念。今者世尊觉悟于我。即入三昧。身光赫奕如天新金。戴殊胜冠珠光辉映。其面润泽过于醍醐。其眼绀青如吠琉璃。摩尼马瑙及日光珠。以为臂饰。身光香熏普遍辉耀

时广博仙。既睹斯相心大惊愕。即从坐起。合掌瞻仰生希有心。高声唱言。奇哉善哉。我得人身为不唐捐。今遇世尊发挥聚会。昔所未睹今乃得见。尔时世尊告广博言。彼帝释身与阿那律。谁为胜劣。广博仙言。彼帝释身比阿那律。假使百分不及其一。乃至千分亦不及一。佛言大仙。于如是身不足希有。获福德者。随其所愿身相成就

尔时众会生欢喜心。咸白佛言。唯愿世尊。更为我等说于天趣。佛言。三十三天。彼之天帝。最大夫人名曰舍支。住欢喜园。天之婇女。百千围绕。容色姝妙犹花开敷。颊如红莲。面如金色。着诸鲜明细软衣服。嬉游园苑。天妙宝花以为首饰。珠璎环佩动出妙声。额广平正垂金旒锁。其眼纤长如花将开。坚诚倾注在于天帝。曾无嗔恚斗诤颦妒。亦复离诸怀胎之患。大仙当知。彼之夫人。耽爱垢重倍余天女。志意骄倨。犹于弥楼及漫陀山幽邃难仰。不肥不瘦。不长不短。体质香洁无诸秽恶。风送妙花结而成盖。而此夫人。常能发挥如来种性

复次大仙。三十三天无杂患累。而恒游戏楼阁宫殿。其所寿命天一千岁。寿将终时有五恶相。一者清冷池沼。净如颇胝。有所触者令人欣悦。微风轻摇杂花晖映。如此池中将欲洗沐变成脂腻。时彼天人见此相已心生怖惧。从水跳出奔走林中。时诸天女见彼惶遽。亦疾随从止一树下心生忧恼。喉中哽噎。同声告言。仁者。如何速舍我等孤居若此。时彼天男声渐哀切作如是言。我从昔来未曾有此垢腻现身。作是言已。其两腋下忽然流汗。彼诸天女见此衰相皆即远离。于是彼天见诸女去。忧恼喘息内增热毒。头上花鬘飒便萎悴。所著天衣忽复垢腻。天之床敷杂玩等物。皆不爱乐

彼诸天女睹如是相。知必定死恶闻秽气。但遥相视发声恋泣哽噎酸楚。叹言苦哉。此细软身。昔与我等游行宴乐于天池中。犹如鸳鸯。于善法堂犹如鹅王。欢喜园中如迦兰鸟。游漫陀河同于香象。在波耶园及拘罗园。犹如蜂王。处杂树林如天花冠。今者云何为五衰相之所加害。舍离我等将何处去。时彼天人闻是悲叹复增恚恼。生大怖畏。便为热病之所缠摄。举身枯悴眼目慞惶。犹如商人失其徒侣。犹如涉海舟船破坏。亦如有人失如意珠。又如危峰朽坏之树。为彼猛风摇动吹击。复如龙子为金翅鸟之所衔喙。回惶战惧。合掌告彼诸彩女言。汝等进来。愿能以手摩触于我令少苏息。虽作是语。而诸女等。但遥悲泣无有进者。各执树枝遥掷心上。作如是言。汝天福尽。当速生彼阎浮提中

于是彼天闻是言已。知被弃舍。发声怨唱。奇哉奈何。我于此中种种资具园苑宫殿。与诸女等眷属缠缚。今时命终将行死路。乃何遥立但谓我言。当于阎浮而受生耶。尔时彼天作是语已。复睹常时所游之处。念念思惟恌举哀叹。发大声言。呜呼善法堂。呜呼欢喜园。呜呼杂树园。呜呼黄毯石园。呜呼波露沙园。呜呼波梨耶园。呜呼光胜园等。呜呼缦陀大河及诸宫殿堂室楼阁。我于今时制不由己。奄相舍离从此坠落。忧叹未终。复见诸女。惊惶去来以手拭泪。歔欷咨嗟容颜怖惧。复伤怨言。呜呼爱者。呜呼亲者。如何见我将行死路。曾不与语。我今临兹生死长路。不垂执别。我与汝曹不复见矣。呜呼我今福业尽故。见此住居。谓如黑闇飒然空旷。呜呼天乐为不奏耶。如何我今寂无所闻。呜呼天中最为悦乐。一切诸天及乾闼婆所侍卫处。妙色坚固持金刚者。呜呼我今岂复得见。千眼之相在众中耶。呜呼波利耶花。拘毗罗花。在我头上。何故萎悴。时诸天众睹斯天人悲恼如是。悉皆忧叹

尔时妙耳珰者。释提桓因与诸天众百千围绕。并舍支夫人诸余婇女。及乾闼婆等。奏美音乐随从游行。见于彼天。为五衰相之所逼害。将趣死路。皆生哀怜同声叹言。呜呼奇哉。彼之无常无少悲愍。暴恶毒害。释提桓因。以梵音声告彼天言。止止。天子。我等皆当同归斯路。勿生恋着堕于恶趣。时诸天众亦同告言。仁者。应当具作诸善往生人间。一切众生修福业地。于是彼天闻如是言。便自思惟。我于今时决定坠落。合掌向彼诸来天言。汝等诸人。住天中者与我欢喜。而我于今坠落时至。作是言已。长叹瞻视。复现二相。一者眼如赤莲花。二者身庄严具忽皆隐没。其余诸天见此之相。各持天花而散其上。及奏天乐。时临死者见余天众。鼓乐幡花以为赠送。并相劝往。即便乐生阎浮提中。涕泪哀感自此而绝(自此已后是毗耶娑问经下文)。命尽死已。伽阿那风吹彼死天。彼风善香吹之令散。如是散已即时远离三十三天。不知所在无有处所不能生他。若想若知彼既退已。生于人间在胎藏中。母则相现喜笑歌舞。心喜染欲心常欢喜。喜乐华果树林之处。乐着种种杂色衣服常喜饮食。虽住藏内母胁不苦。不乐邪欲心喜善香华鬘庄严。卧则善梦非颠倒见。大仙当知。三十三天退生此时。住母藏中有如是相。大仙当知。其母尔时一切藏过。皆悉远离后则出生。大仙当知。彼时童子既出生已。身分平正掌文成就可喜柔软。腰细齿密身体柔软。其心爱乐胜功德欲。性爱欲事心爱细衣。乐林戏处身有胜香。大富丰财金宝具足。大姓种族常行施戒。欲心多者则生贫家。心喜布施不黑不白手足齐平。一切见者皆悉爱敬。性爱论议其心柔软少于嗔心。乐行他妻于自妻妾不生爱乐。于诸亲旧兄弟眷属心不爱恋。大仙当知。三十三天退生人中。本性如是

世尊说已。毗耶娑仙(即新经中广博仙也唐梵二音方言异耳)一切仙众。心生欢喜叹言善哉。(比因披读睹斯文阙三藏泥洹询疑无所遂捡旧藏经内获得毗耶娑经与此梵本是同先后译异两文对勘二理无殊故以旧文续斯新阙后寻览者幸无惑焉开元戊辰岁西京崇福寺沙门智升述记)

大宝积经卷第一百二十


大乘显识经卷上

    No. 347 [No. 310(39)]

大乘显识经卷上

        中天竺国沙门地婆诃罗奉　诏译

如是我闻。一时薄伽梵。在王舍城迦兰陀竹林。与大比丘众千二百五十人俱。皆阿罗汉诸漏已尽。无复烦恼逮得自在。心善解脱慧善解脱。于去来今照了无碍。是大那伽如佛之教。所作已办弃大重担。获于己利。已断流转生死有苦。以正智力。善知众生心之所趣。如是大声闻众。长老舍利弗而为上首。复有无量菩萨摩诃萨众。俱在会集。尔时诸比丘在世尊所。多有疲睡。失容阿委不能自持。于是世尊。面门晖发如莲花开时诸比丘。咸悉醒悟各自严正。作如是念。今佛世尊。颜容晖焕面光照朗。欲开何法眼作大饶益。尔时贤护胜上童真。修容丰美柔和光泽色相具足。六万商主前后围绕。侍从轰郁声如地震。来诣佛所。见佛世尊寂静安隐众德之藏。巍巍赫朗如大金树。深心信重合掌思惟。作如是念。众共称赞。佛一切智普见一切。是如来阿罗诃正等觉。诚实不虚。顶礼佛足谛视而住。佛见贤护。举身放光流照贤护。贤护尔时便获无畏。绕佛三匝顶礼佛足。而白佛言。唯愿世尊。悲愍教授我今始于佛所得净信心。心悕妙法欲有所问。而我久处生死。溺烦恼苦乱念纷杂。于戒等业无作冥资。虽心奇重我今不知。于此愚惑疑网之中。如何超出得度生死。世尊。是一切智普见一切。佛出甚难希有逢遇。如如意珠施众生乐。佛是大如意宝。一切众生咸由依佛。得大安乐是大父母。众生善本。因佛父母得见正路。唯愿悲愍开晓疑闇。佛告贤护。汝有所疑恣汝意问。我当为汝分别解说。尔时贤护。蒙佛听许。心专请问在一面住。时长老阿难。见贤护童真姿容晖泽色相具足。白佛言世尊。未曾有也。此贤护童真。有大福德光色丰盛。诸王威相咸蔽不现。佛告阿难。此贤护胜上童真。福业所致虽处人间受天胜果。安宁适乐欢娱嬉戏。畅悦恣心犹如帝释。阎浮提中。唯除月实童真。更无比者。阿难白佛言。贤护童真。果报资用宿植善根。唯愿为说。佛告阿难。贤护现受乐报资用广大。及宿胜因汝今当听。阿难。此贤护童真。六万商主资产丰饶金宝盈积。恭敬受教。随逐奉事。六万床座敷设卧具。毡褥缯绮并倚枕等。杂色晖发妙丽庄严。俱罗帷幕及憍奢耶。火浣币帛支那安输。周匝施布众宝雕间。相宣焕烂交错如画。六万妓女被服安输众色间杂。金宝璎饰鲜华[示*玄]丽光彩耀目其触细软如天迦遮。轻重随心适称情意。戏容笑语歌唱相娱。闲婉严洁柔敬事主。于他人所心绝爱欲。惭耻低首或覆头为容。肌肤平满柔软细滑。手足支节踝等骨脉。咸悉不现。齿白齐密发绀右旋。如削蜡成如工画作。氏族华望名誉流远。如是妇人而为侍从。又有六万供食妇人。饭饼诸物种种异色。香味调美如天肴膳。饮具八德见令心悦。宁身适意不劳而熟。是福之食应心而至。涤净拥秽去诸病恶。庭宇台楼具足六万摩尼真珠琉璃诸珍罗布垂饰。众宝间钿行列端美。绮彩蒙悬缀以铃铎。随风飖扬铿锵和发地若琉璃现众影像。杂花散布清凉快乐。遨游栖息畅心适志。又有细腰般拏。箜篌长笛铜钹清歌。种种音声数凡六万。美声调润响亮闻远。喧嚣杂作震警方域。福业所致欢乐不绝。鸽等诸鸟飞翔游集。异声间和畅心悦耳。藤蔓众花萦缘台阁。鲜葩标秀蓊郁晖焕。铃铎乐器响若天宫。房廊昭晰如须弥窟神药流照。有六万城高墙峻峙楼橹备设。街街布列四衢三达。美丽填溢诸方凑集。种种服饰种种言语。法制万差殊容异状。奇货列肆商侣百千。交易嚣喧声震城域。园林郁茂大树小树。藤蔓卉药众花竞发。清波环映间错光鲜粲如舒锦。象马车乘其众百千。往还不绝充遍城邑。阿难。六万城中名德高人。及诸豪富并诸商主。日日称赞贤护童真。播扬声德。虔恭合掌礼拜修敬。娇萨罗国波斯匿王福力富盛。比之贤护状类贫下。月实童真。无量百千妓从侍绕。恭敬奉事爱悦欢戏众乐所依。虽天帝释百千万倍不及月实。贤护童真。容色丰美富有自在安宁适乐亦百千万倍。不及月实。斯皆宿福所感非力致也。阿难。贤护童真。又有如意宝辂天宝雕严。光晖赫烂天金金刚光玉日受。种种诸宝钿厕间错丽若观星。运速如风如金翅飞。乘此宝辂。宝洲等所应念而至。身不疲劳戏乐而返。是时阿难。顶礼佛足而白佛言。贤护童真。种何善根修何福业。资产广大受大乐报。宫室妙丽宝辂奇特。佛告阿难。贤护童真。由先于佛法中修植福业。故今获此广大乐报。过去有佛名曰乐光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。贤护。尔时于彼佛法之中出家作比丘。名曰法髻。多亏戒行。然善讲说修多罗阿毗达摩毗奈耶等。三藏深教咸悉明达。常为众生宣畅敷演。法施不绝美音深重。正直高亮剖析明辩。听者欢喜闻所说法思惟修行。脱恶趣者其数无量。阿难。法髻比丘以法施功德。于九十劫受天人报。又见清净持戒比丘身羸瘦瘠。恒施饮食及屣履等。殷重诚彻净心布施。故今获此大富乐报胜妙宫室奇特宝辂。又遇迦叶如来示教指诲而告之曰。汝于未来释迦牟尼佛所。当得授记。故今见我。我为说法而成熟之。阿难白佛言。世尊。贤护胜上童真。如是财富金宝盈积豪盛自在。谦柔卑下无憍骜心。甚为奇特。佛言阿难。大智不于财宝欲乐而生矜骜。贤护。久修善行。善法所资常食福果。贤护。蒙佛阿难共称叹已。恭敬合掌顶礼佛足。白佛言世尊。怜愍摄护一切众生。欲少请问愿垂听许。佛告贤护。我先听汝。汝有所疑今恣汝问。我当为汝分别解说。贤护白佛言。世尊。众生虽知有识。如宝闭在箧中不显不知。世尊。不知此识作何形状。何故名识。众生死时手足乱动。眼色变异制不自由。诸根丧灭诸大乖离。识迁于身去至何所。自性如何作何色相。云何舍离此身更受余身。云何身分弃之于此。而牵诸入获当来报。受种种身差别不同。世尊。云何众生身谢灭已更生诸入。云何今生积聚福业来生得之。今身为福当来身食。云何识能滋长于身。云何识入随身转变。佛言。善哉善哉贤护。善哉善问。谛听谛听善思念之。当为汝说。贤护白佛言。世尊。唯然奉教。佛告贤护。识之运转迁灭往来。犹如风大。无色无形不可显现。而能发动万物示众殊状。或摇振林木摧折破裂出大音声。或为冷为热触众生身。作苦作乐。风无手足面目形容。亦无黑白黄赤诸色。贤护。识界亦尔。无色无形无光明显现。以因缘故显示种种功用殊异。当知受觉法界亦复如是无色无形。以因缘故显发功用。贤护。众生死此。受觉法界识界皆舍离身。识运受觉法界。受余身者。譬如风大吹众妙花。花住于此香流至远。风体不取妙花之香。香体风体及与身根俱无形色。而非风力香不远至。贤护。众生身死。识持受觉法界以至他生。因父母缘而识托之。受觉法界。皆随于识亦复如是。如从花胜力而鼻有嗅。从嗅胜力而得香境。又如从风身胜力。得风色触。因风力香得至远。如是从识有受。从受有觉。从觉有法。遂能了知善与不善。贤护。又如画工料理壁板。诸所画处如法端洁。随意所为图绘众像。则工之识智俱无形色。而为种种奇容异状。如是识智无形而生六色。谓因眼见色眼识无形。因耳闻声声无形色。因鼻知香香无形色。因舌知味味无形色。因身知触触无形色。法入诸境皆悉无形。识无形色亦复如是

贤护。识弃此身受他生者。众生死时识为业障所缠。报尽命终犹如灭定阿罗汉识。如阿罗汉入灭尽定。其阿罗汉识从身灭转。如是死者之识弃身及界。乘于念力而作。是知彼如是。我某乙生平所作事业。临终咸现忆念明了。身之与心二受逼切。贤护。识是何义。识名为种。能生众类杂报身牙。知觉想念同苞于识。知苦知乐知恶知善及善恶境。故名为识。如汝所问。云何识离此身而受余报。贤护。识之迁身。如面之像现之于镜。如印之文显之于泥。譬如日出光之所及众闇咸除。日没光谢闇便如故。闇无形质非常无常能得其处。识亦如是。无质无形因受想显。识在于身如闇之体。视不可见不可执持。如母怀子不能自知是男是女。黑白黄色根具不具。手足耳目类与不类。饮食热刺其子便动觉知苦痛。众生来去屈伸视瞬。语笑谈说担运负重。作诸事业识相具显。而不能知识之所在。止于身中不知其状。贤护。识之自性遍入诸处。不为诸处之所染污。六根六境五烦恼阴。识遍止之不为其染。由此而显识之事用。贤护。如木机关系执一所作种种业。或行走腾跃或跳掷戏舞。于意云何。机关所作是谁之力。贤护白佛言。智慧狭浅非能决了。佛告贤护。当知皆是作业之力。作业无形但智运耳。如是身之机关。以识之力作诸事业。仙通乾闼婆龙神人天阿修罗等。种种趣业咸悉依之。识能生身。如工作机关。识无形质普持法界智力具足。乃至能知宿命之事。譬如日光。恶业众生及诸不净。死尸臭秽无偏等照。不为诸恶之所污染。识亦如是。虽处猪狗食不净类诸恶趣身。而不为彼之所染污。贤护。识舍此身随善恶业迁受余报。譬如风大出深山邃谷。入于薝卜众香之林。其风便香。经于粪秽死尸臭恶秽污之所。其风便臭。若风香臭俱至。风则香臭并兼盛者先显。风无形质香臭无形。然风持香臭迁之于远。识弃此身持善恶业。迁受余报亦复如是。犹彼风大持物香臭致于他所。又如人梦见众色像种种事业。而不自知安眠而卧。福德之人命尽识迁。亦复如是安隐不觉。如梦迁化无所恐惧。识之迁出不由喉口及诸窍穴。莫测所从莫知径户。尔时贤护胜上童真。顶礼佛足。白佛言世尊。鸡鹅等子其卵未熟。周匝细密识从何入。子死卵中卵壳不破。无隙无窍识从何出。佛言贤护。譬如乌麻薝卜花熏。其油香美名薝卜油。与凡麻油好恶殊隔。油先无香以花熏种油遂成香。香不破麻而入。亦不破麻而出。复无形质留止油内。但以因缘力故。香迁油内油成香泽。鸡鹅子识入出于卵。亦复如是。如薝卜香迁于油内。识之迁运。如日流光。如摩尼照。如木生火。又如种子。种之于地体化地中。芽苗茎叶备显于外。生白不白赤等杂色种种之花。种种力味成熟。所为种种差别。同一大地等资四大。各随其种所生便异。如是一识法界。生于一切生死之身。或黑或白或黄赤等。淳和嗔暴种种殊品。贤护。识无手足无支节言语。由法界中念力强大。众生死时识弃此身。识与念力为来生种。即离于识不得法界。离于法界亦不得识。识与风大微妙念界。受界法界和合而迁。贤护白佛言。若如是者。云何世尊。说识无色。佛言贤护。色有二种。一内二外。内谓眼识眼则为外。如是耳识为内。耳则为外。鼻识为内。鼻则为外。舌识为内。舌则为外。身识为内。身则为外。贤护。如生盲人梦见美色。手足面目形容姝丽。便于梦中生大爱悦。及睡觉已冥无所见夜尽昼明人众聚会。盲者遂说梦中乐事。我见丽人姿容殊绝园观华茂人众百千。严饰嬉戏肌肤光泽肩髆紧满。臂长而圆犹如象鼻。我于梦中获大快乐适心喜叹。贤护。此生盲人未曾见物。云何梦中而能见色。贤护白佛言。唯愿开示。佛告贤护。梦中见者名内眼所。是慧分别非肉眼见。其内眼所。以念力故盲者梦中须臾而现。复以念力觉而忆之。识之内色亦复如是

复次贤护。身死识迁。犹如种子弃在地中。四大摄持。苗茎枝叶渐次迁化。识为念受善不善等四法摄持。弃身迁化亦复如是。贤护白佛言。世尊。云何善不善法摄持于识。佛言贤护。譬如妙颇梨宝。随所处物若黑若白。宝色随物成白成黑。善不善法摄持于识亦复如是。随所摄持成善不善迁化受报。贤护复白佛言。此身云何禀受于识。佛言贤护。此识无积无聚亦无生长。譬如牙生。非种不变而生。亦非种坏而生。然牙生时种则变毁。贤护。于意云何。其牙所在止于何处。子耶枝耶。茎柯叶耶。止树头耶。贤护白佛言。不也世尊。牙无所止。如是贤护。识之在身止无处所。非眼非耳鼻舌身等。种生牙时。如识微觉。乃至花结合时。如识有受含。开花发时至结果如识有身。识之生身遍身支体。求识所止莫得其所。若除于识身则不生。如树果熟。堪为将来树之种子。非不熟者。如是报熟身死。识种便现。因识有受因受有爱。系着于爱便生于念。识摄取念随善恶业。与风大并知念父母。因缘合对识便托之。如人面影现之于镜。非净非明面像不现。镜明面对影像乃现。镜中之像无受无念。而随人身屈伸俯仰。开口谈谑。行来进止。种种运动。贤护。影像现谁之力也。贤护白佛言。是人之力由有面故而有面影。影像之色如面之色。根具不具咸悉如面。佛言。面为影因。镜为影缘。因缘和合故有影现。由识因故。有受想行及诸心所。父母为缘。因缘和合而有身现。如彼身镜。镜中之影身去影灭。身持影像。或别现于水等之中。识弃此身持善恶业。迁受余报亦复如是。又如尼瞿陀乌昙婆等种子。虽小能生大树。树复生子。子弃故树。更生新树。故树经久质力衰微。味液销竭干枯腐朽。如是诸小生类。其识弃身乘己之业。或受种种诸类大身。又如大麦小麦乌麻菉豆及摩沙等。种种子实皆以种故。牙茎花实生长成熟。如是由有识故。随迁生类即便有觉。由觉有受。持善恶业受种种身。又如蜂止花爱乐恋着。唼吮花味以自资养。蜂弃此花更处余花。或弃香入臭。或弃臭入香。随其所在莫不自爱恋结贪着。识亦如是以福业故获诸天身受胜乐果。或弃天身。以恶业故获地狱报受众苦果。轮回迁转为种种身。识如郁金红蓝芬陀利等其子皆白。破其子中不见牙花不见异色。种之于地以水润液。便有牙等。顺时滋长花果敷荣。或赤或白种种之色。色与牙等不在子中。然离于子皆不得生。识弃身已。肉身容貌诸根诸入。识中不见因缘和合。识以妙视妙闻。声触味法及以念入。知已所造善恶等业以取身报。如蚕作茧。自作自缠。于中迁化识亦如是。识自生身还自缠裹。自弃舍身更受余报。由有种故有色香味。识弃舍身随其所迁。诸根境界受及法界。皆悉随之。如如意珠随其所在乐具皆随。如日所在光明皆随。识亦如是。随其所迁受觉与想。及法界等皆悉随之。识弃舍身摄一切性。色因为身。无骨肉身。有诸根故。有受妙念知取善恶。知枣石榴庵罗庵勒鼻螺渴竖劫必他等种种之果。或辛或苦或酸或甜或碱或涩。味力各别消熟所资其功不一。及果坏已。味力随种迁化而生。如是识种随其所迁。受念善恶咸悉随之。知弃此身受余报身。故名为识。知善恶业知业随我。知我持业迁化受报。故名为识。身之所为咸悉知之。故名为识。譬如风大。无形可取无质可持。以因缘故作诸事业。表有风大持冷持热。运香运臭摇振林木。或鼓扇摧击。如是识无形质。非视听所取。以因缘故识相具显。由识持身身知苦乐。光色充盛行来进止。言笑欢忧事业照着。当知有识(右大唐永隆元年三藏地婆诃罗于东太原寺译出大周录)

大乘显识经卷上大乘显识经卷下

        中天竺国沙门地婆诃罗奉　诏译

尔时会中有月实胜上童真。从座而起合掌白佛言。世尊。云何见色因。云何见欲因。云何见见因。云何见戒取因。佛告月实。智见智境。愚见愚境。智者见诸姝丽美色。了知秽恶。唯是肉段筋骨脓血。大脉小脉大肠小肠。[月*冊]液脑膜肾心脾胆。肝肺肚胃生藏熟藏。黄痰涕唾发须毛爪。大小便利薄皮裹之。不净污露可畏可恶。凡所有色皆四大生。是为色因。月实。如父母生身。身之坚硬为地大。流润为水大。暖熟为火大。飘动为风大。有所觉知念及声香味触等界。斯皆为识。月实童真。复白佛言世尊。将死之时。云何识舍于身。云何识迁于身。云何识知今舍此身。佛告月实。众生随业获报。识流相续持身不绝。期毕报终识弃舍身。随业迁受。譬如水乳和。煎以火热力。乳水及腻各各分散。如是月实。众生命尽以业力散。形骸与识及诸入界。各各分散识为所依。以取法界及法界念并善恶业迁受他报。月实。譬如大吉善苏。以众良药味力。熟功和合。为之大吉善苏。弃凡苏性持良药力。辛苦酸碱涩甘六味。以资人身。便与人身作色香味。识弃此身持善恶业及法界等迁受余报亦复如是。月实。苏质如身。诸药和合为大吉善。如诸法诸根和合为业。众药味触资成于苏。如业资识。服大吉善悦泽充盛。光色美好安隐无患。如善资识获诸乐报。服苏违法颜容变恶。惨无血气色死士白。如恶资识获诸苦报。月实。吉善宝苏无手足眼。能取良药色香味力。识亦如是。取法界受及诸善业。弃此身界受于中阴得天妙念。见六欲天十六地狱。见己之身。手足端严诸根丽美。见所弃尸云此是我前生之身。复见高胜妙相天宫种种庄严。花果卉木藤蔓蒙覆。光明赫丽如新炼金众宝钿饰。彼见此已心大欢喜。因大喜爱识便托之。此善业人舍身受身安乐无苦。如乘马者弃一乘一。譬如壮士武略备具。见敌兵至着坚甲胄。乘策骥骏所去无畏。识资善根弃出入息。舍界入身迁受胜乐。亦复如是。自梵身天爰至有顶生于其中。尔时会中大药王子。从座而起合掌。白佛言世尊。识舍于身作何色像。佛言善哉善哉。大药。汝今所问是大甚深佛之境界。唯除如来更无能了。于是贤护胜上童真白佛言。大药王子。所问甚深其智微妙敏利明决。佛告贤护。此大药王子。已于毗婆尸佛所。植诸善根。曾于五百生中生外道家。为外道时常思识义。识者云何。云何为识。于五百生不能决了。识之去来莫知由绪。我于今日为破疑网令得开解。于是贤护胜上童真。谓大药王子言。善哉善哉。仁今所问微妙甚深。月实之问其义浅狭。犹如婴儿。心游外境而不知内。正法希闻诸佛难遇。佛圆广智无测深慧至妙之理应专启请。时大药王子。见佛熙怡颜容舒悦如秋莲开。踊跃欢喜一心合掌。而白佛言世尊。我爱深法渴仰深法。常恐如来入般涅槃。不闻正法。而于五浊众生之中。愚无所知不识善恶。于善不善熟与不熟不能觉了。迷惑轮转生死苦趣

佛告大药王子。如来正法难遇难得。我于往昔为半伽他。登山自坠弃舍身命为求正法。经历无量百千万亿种种苦难。大药。汝所悕望皆恣汝问。我当为汝分别解说。大药王子。白佛言。唯然奉教。世尊。识相云何。愿垂开示。佛告大药。如人影像现之于水。此像不可执持。非有无辨。如刍洛迦形。如渴爱像。大药王子。白佛言世尊。云何渴爱。佛言。如人对可意色眼根趣之。名为渴爱。犹持明镜视己面像。若去于镜面像不见。识之迁运亦复如是。善恶业形与识色像皆不可见。如生盲人日出日没昼夜明闇皆悉不知。识莫能见亦复如是。身中渴爱受想不可见。身之诸大诸入诸阴。彼皆是识。诸有色体眼耳鼻舌。及身色声香味触等。并无色体受苦乐心皆亦是识。大药。如人舌得食物知甜苦辛酸碱涩等。六味皆辨。舌与食物俱有形色而味无形。又因身骨髓肉血觉知诸受。骨等有形。受无形色。知识福非福果亦复如是。时贤护胜上童真。礼佛双足白佛言世尊。此识可知福非福耶。佛言善听。非未见谛而能见识。识不可视。非如掌中阿摩勒果。识不在于眼等之中。若识在于眼等之中。剖破眼等应当见识。贤护。恒沙诸佛见识无色。我亦如是见识无色。识非凡愚之所能见。但以譬喻而开显耳。贤护。欲知识之罪福。汝今当听。譬如有人为诸天神或乾闼婆等。及塞建陀等鬼神所著。贤护于意云何。其为天等鬼神所著。其着之体求于身中可得见不。贤护。白佛言。不也世尊。天等鬼神所著。其着之体无色无形。身内外求皆不可见。贤护。其为福胜诸大天神之所著者。即须好香花烧众名香。香美饮食清净安置。祭解供具咸须华洁。如是此识为福资者。便获尊贵安乐之果。或为人王。或为辅相或豪望贵重。或财富自在。或为诸长。或作大商主。或得天身受天胜果。由识为福资身获乐报。如彼福胜天神所著。得胜妙花香香美饮食。便即欢喜病者安隐。今得尊贵豪富自在。当知皆是由福资识身获乐果。贤护。其为富丹那等下恶鬼神之所著者。便爱粪垢腐败涕唾诸不净物。以此祭解欢喜病愈。其人以鬼神力随鬼神欲。爱乐不净臭朽粪秽。识以罪资亦复如是。或生贫穷。或生饿鬼及诸食秽畜生之中种种恶趣。由罪资识身获苦果。贤护。胜上天神其着之体无质无形。而受种种香洁供养。识福无形受胜乐报亦复如是富丹那等下恶鬼神。为彼著者。便受不净秽恶饮食。识资罪业获诸苦报亦复如是。贤护。当知识无形质。如天等鬼神所著之体。供具饮食所获好恶。如资罪福得苦乐报

大药王子。白佛言世尊。云何见欲因。佛言大药。互因生欲。犹如钻燧两木互因。加之人功而有火生。如是因识。及因男女色声香味触等。而有欲生。譬如因花生果。花中无果果生花灭。如是因身显识。循身求识。识不可见。识业果生身便谢灭。身骨髓等不净诸物咸悉销散。又如种子持将来果味色香触。迁植而生。识弃此身持善恶业。受想作意。受来生报亦复如是。又如男女爱欲欢会分离而去。识业和合恋结爱着味玩贪吝。报尽分离随业受报。父母因缘中阴对之。以业力生识获身果。爱情及业。俱无形质。欲色相因而生于欲。是为欲因

大药。云何见戒取因。戒谓师所制戒。不杀不盗不邪淫不妄语不饮酒等行。取谓执取。是戒作如是见。因是持戒。当得须陀洹果。斯陀含果。阿那含果。以是因故获于胜有。谓受人天等身。斯皆是有漏善非无漏善。无漏之善无阴熟果。今此戒取是有漏种植之。于识执善恶业识不淳净。烦恼因故受热恼苦。是为见戒取因

大药白佛言。云何识取天身乃至取地狱身。佛言大药。识与法界持微妙视。非肉眼所依以为见因。此微妙视与福境合。见于天宫欲乐嬉戏。见已欢喜识便系着。作如是念我当往彼。染爱恋念而为有因。见已故身卧弃尸所。作如是念此尸是我大善知识。由其积集诸善业故。令我今者获于天报。大药白佛言世尊。此识于尸既有爱重何不托止。佛言大药。譬如剪弃须发。虽见乌光香泽。宁不更植于身令重生不。大药白佛言。不也世尊。已弃须发。不可重植于身令其更生。佛言。如是大药。已弃之尸识亦不可重托受报。大药复白佛言。世尊。此识冥寞玄微。无质可取无状可寻。云何能持象等大身众生。纵身坚固犹若金刚。而能贯入壮夫之身。力敌九象而能持之。佛言大药。譬如风大无质无形。止于幽谷或窍隙中。其出暴猛。或摧倒须弥碎为尘粉。大药。须弥风大色相云何。大药白佛言。风大微妙无质无形。佛言大药。风大微妙无质无形。识亦如是。妙无形质大身小身咸悉能持。或受蚊身或受象身。譬如明灯。其焰微妙置之于室。随室大小众闇咸除。识亦如是。随诸业因任持大小。大药白佛言世尊。诸业相性彼复云何。以何因缘而得显现。佛言大药。生诸天宫食天妙膳安宁快乐。斯皆业果之所致也。如人渴乏巡游旷野。一得清凉美水。一无所得受渴乏苦。得冷水者无人持与。受渴乏者。亦无遮障不许与水。各以业因受苦乐报。大药。应当以是见善恶业。如空中月白黑二分。又如生果由火大增熟便色异。如是此身由福增故生胜族家。资产丰盈金宝溢满胜相显盛。或生诸天宫快乐自在。斯皆善业福相显现。譬如种子植之于地。果现树首。然其种子不从枝入枝而至树首。割析树身亦不见子。无人持子置于枝上。树成根固求种不见。如是诸善恶业咸依于身。求之于身亦不见业。如因种有花种中无花。因花有果花中无果。花果增进增进不见。因身有业因业有身。身中无业业中无身。亦复如是。如花熟落其果乃现。身熟谢殒业果方出。如有种子花果之因具有。如是有身。善恶业因备在。彼业无形亦无熟相。如人身影无质无碍。不可执持不系着人。进止往来随人运动。亦不见影从身而出。业身亦尔有身有业而不见业。系着于身亦不离身而能有业。如辛苦涩殊味诸药。能涤净除一切病。令身充悦颜色光泽。人见之者知服良药。药味可取熟功无形。视不可见执不可得。而能资人肤容色泽。业无形质能资于身。亦复如是善业资者。饮食衣服内外诸资。丰饶羡丽手足端正。形容姝好屋室华侈。摩尼金银众宝盈积。安宁快乐欢娱适意。当知此为善业之相。生于下贱边地贫穷。资用阙乏悕羡他乐。饮食粗恶或不得食。形容弊陋所止卑下。当知此为恶业之相。犹如明镜鉴面好丑。镜像无质取不可得。如是识资善不善业。生人天中或生地狱畜生等中。大药。应当如是见业与识和合迁化。大药言。世尊。云何微识能持诸根能取大身。佛言大药。譬如猎者。入于山林持弓毒箭而射香象。箭毒沾血毒运象身。支体既废根境同丧。毒流要害身色青赤犹如淤血。毒杀象已便即迁化。于意云何毒与象身多少大小。可得比不。大药白佛言。世尊。毒与象身多少大小。其量悬殊不可为对。犹如须弥比之芥子。大药。如是识弃此身以取诸根。弃此诸界随业迁化。亦复如是。大药复白佛言。世尊。云何微细之识任持大身而不疲倦。佛言大药。须弥山王高八万四千由旬。难陀乌波难陀。二大龙王各绕三匝。二龙大息摇振须弥。内海中水咸变成毒。此二龙王长大力壮。和修吉龙。德叉迦龙。二大龙王亦与之等。于意云何。四龙王识与蚊蚋识宁有异不。大药言。世尊。四龙蚊蚋其识无异。大药。如一小渧跋错那婆。入四龙口四龙便死。于意云何。小渧药毒。龙口中毒何毒为大。大药白佛言。龙口毒大。小渧药毒甚为微少。大药。大身众生力敌九象。微妙之识无色无形。非分别量随业任持亦复如是。如尼瞿陀子极微细。种之生树婆娑广大枝条百千。于意云何。其子与树大小类不。大药言。世尊。其子与树大小相悬。如藕丝孔比虚空界。如是大药。树于子中求不可得。若不因子树则不生。微细尼瞿陀子能生大树。微细之识能生大身。识中求身身不可得。若除于识身则无有。大药复白佛言。云何金刚坚固不可坏识。止于危脆速朽身内。佛言大药。譬如贫人得如意宝。以宝力故高宇雕镂。妙丽宫室园林郁茂。花果敷荣象马妓侍。资用乐具自然而至。其人于后失如意宝。众资乐具咸悉销灭。如意神宝坚固真牢纵千金刚不能毁坏。所生资用虚假无常速散速灭。识亦如是坚固不坏。所生之身速朽速灭。大药言。世尊。柔妙之识。云何穿入粗鞕色中。佛言大药。水体至柔激。流悬泉能穿山石。于意云何。水石之质鞕软如何。大药言。世尊。石质坚鞕犹若金刚。水质柔软为诸乐触。大药。识亦如是至妙至柔。能穿刚鞕大身之色。迁入受报。大药复白佛言。世尊。众生舍身云何生诸天中。乃至云何生于地狱等中。佛言大药。众生临终之时福业资者。弃本之视得天妙视。以天妙视见六欲天。爰及六趣见身摇动。见天宫殿及欢喜园杂花园等。又见诸天处莲花殿。丽妓侍绕笑谑嬉戏。众花饰耳服憍奢耶。臂印环钏种种庄严。花常开敷众具备设。见天天女。心便染恋欢喜适意。姿颜舒悦面若莲花。视不错乱。鼻不亏曲口气不臭。目色明鲜如青莲叶。身诸节际无有苦痛。眼耳鼻口又无血出。不失大小便利。不毛惊孔现。掌不死黄甲不青黑。手足不乱亦不卷缩好相显现。见虚空中有高大殿。彩柱百千雕丽列布。垂诸铃网和风吹拂清音悦美。种种香花庄严宝殿。诸天童子众宝严身。游戏殿内。见已欢喜微笑齿现如君图花。目不张开亦不合闭。语音和润身不极冷亦不极热。亲属围绕亦不忧苦。日初出时当舍其寿。所见明白无诸黑闇。异香芬馥四方而至。见佛尊仪欢喜敬重。见已亲爱欢喜离辞犹如暂行。便即旋返安慰亲知。不令忧恼有流法尔。生必当死勿以分别而生苦恼。大药。善业之人临命终时。好乐布施。种种伽他种种颂叹。种种明白种种称说正法之教。如睡不睡安隐舍寿。将舍寿时。天父天母同止一座。天母手中自然花出。天母见花顾谓天父。甚为福吉希奇胜果。天今当知子庆之欢时将不久。天母遂以两手摇弄其花。弄花之时命便终尽。无相之识弃舍诸根。持诸境业弃舍诸界。持诸界事迁受异报。犹如乘马弃一乘一。如日爱引光。如木生火。又如月影现澄清水。识资善业迁受天报。如脉风移速托花内。天父天母同座视之。甘露欲风吹花七日。宝珰严身曜动炫焕。天童朗洁现天母手。大药白佛言。世尊。无形之识。云何假因缘力而生有形。云何有形止因缘内。佛言大药。如木和合相触生火。此火木中求不可得。若除于木亦不得火。因缘和合而生于火。因缘不具火即不生。木等之中寻火色相竟不可见。然咸见火从木中出。如是大药。识假父母因缘和合生有形身。有形身中求识不得。离有形身亦无有识。大药。如火未出火相不现。亦无暖触诸相皆无。如是大药。若未有身。识受想行皆悉不现。大药。如见日轮光明照曜。而诸凡夫不见日体。是黑是白黄白黄赤皆不。能知但以照热光明出没环运。诸作用事而知有日。识亦如是。以诸作用而知有识。大药白佛言。云何为识作用。佛言大药。受觉想行思忧苦恼。此为识之作用。复有善不善业。熏习为种。作用显识。大药白佛言。云何识离于身便速受身。识舍故身新身未受。当尔之时识作何相。佛言大药。如有丈夫长臂勇健着坚甲胄。马疾如风乘以入阵。干戈既交心乱坠马。武艺捷习还即跳上。识弃于身速即受身。亦复如是。又如怯人见敌怖惧乘马退走。识资善业。见天父母同座而坐。速托生彼亦复如是。大药。如汝所问。识弃故身新身未受。当尔之时识作何相。大药。譬如人影现于水中无质可取。手足面目及诸形状与人不异。体质事业影中皆无。无冷无热及与诸触。亦无疲乏肉段诸大。无言声身声苦乐之声。识弃故身新身未受。相亦如是。大药。是资善业生诸天者。大药白佛言。云何识生地狱。佛言大药。行恶业者入于地狱。汝当谛听。大药。此中众生积不善根。命终之时作如是念。我今于此身死。弃舍父母亲知所爱。甚大忧苦。见诸地狱及见己身应合入者。见足在上头倒向下。又见一处地纯是血。见此血已心有味着。缘味着心便生地狱。腐败恶水臭秽因力识托其中。譬如粪秽臭处。臭酪臭酒诸臭因力。虫生其中。入地狱者托臭物生。亦复如是。贤护胜上童真合掌白佛言。地狱众生作何色相。身复云何。佛言大药。其爱血地生地狱者。遍身血光身如血色。生汤隍者身如黑云。生乳汤河者。身点斑杂作种种色体极软脆。犹如贵乐婴孩之身。其身长大过八肘量。须发身毛并长垂曳。手足面目亏曲不全。阎浮提人遥见便死。大药白佛言。地狱众生以何为食。佛言大药。地狱众生食无少乐。惶惧驰走。遥见镕铜赤汁。意谓是血众奔趣之。又有声呼。诸有饥者可速来食。便走向彼至已而住以手承口。狱卒以热铜汁写手掬中。逼之令饮铜汁入腹。骨节爆裂举身火起。大药。地狱众生所食之物。唯增苦痛无少安乐。地狱众生苦痛如是。识不舍之亦不毁坏。身如骨聚识止不离。非业报尽苦身不舍。饥渴苦逼。便见园林花果敷荣广博翠茂。见已喜笑互相谓言。此园翠茂清风凉美。众急入园须臾暂乐。树叶花果咸成刀剑斩截罪者。或中破身分为两段。或大叫呼四面驰走。狱卒群起执金刚棒。或执铁棒铁斧铁杖。啮唇嗔怒身出火焰。斫棒罪者遮不令出。斯皆己业见如是事。狱卒随罪者后。语罪者云。汝何处去。汝可住此。勿复东西欲何逃窜。今此园者汝业庄严。可得离不。如是大药。地狱众生受种种苦。七日而死还生地狱。以业力故如游蜂采花还归本处。罪业众生应入地狱。初死之时见死使来。系项驱逼身心大苦入大黑闇。如被劫贼执捉将去。作如是言。诃诃祸哉苦哉。我今弃阎浮提种种爱好亲属知友。入于地狱。我今不见天路但见苦事。如蚕作丝自缠取死。我自作罪为业缠缚。罥索系项牵曳驱逼将入地狱。贤护。罪业众生生地狱者苦相如是。尔时贤护与大药王子。闻说是已。身惊毛竖。俱起合掌作如是言。我等今者俱归依佛请垂救护。愿今以此闻法功德。未脱有流处生死轮。不落三涂入于地狱。贤护复白佛言。欲有所请唯愿听许。佛言。如汝悕望恣汝所问。贤护白佛言。世尊。云何为积。云何为聚。云何为阴。云何为身不迁。佛言贤护。智界见界意界明界。以此四界和合成身。四界境识名之为积。聚谓六界六入。六入境三界因二入因。即须发毛爪皮肉脓血。涕唾黄痰脂[月*冊]髓液。手足面目大小支节。和合崇聚名之为聚。犹如谷豆麻麦。积集聚贮而成高大。谓之为聚。其地水火风空识。名为六界。眼耳鼻舌身意。名为六入。色声香味触法。名六入境。即贪嗔痴名三界因。又风黄痰亦名三因。二入因者谓戒与信。又有二因谓舍与施。又有二因谓进与定。又有二因谓善不善。其受想行识此四名无色阴。受谓领受苦乐等相及不苦不乐之相。想谓知苦乐相。行谓现念作意及触。识者是身之主。遍行诸体身有所为莫不由识不迁者。谓身语意净证获道果。此人死已识弃有阴不重受有不流诸趣极乐而迁。不复重迁是名不迁。于是贤护与大药王子。礼佛双足白言。世尊。佛一切智说此法聚。当于未来作大利益安乐众生。佛言。如来法聚常住非断。一切智者知而不为。我经无量勤苦积集智光。今说此经。此正法日为诸众生作大明照。德誉普流一切智海。为能调心流注者。说此经所在之处请诵解说。诸天鬼神阿修罗摩睺罗伽。咸悉拥护皆来拜礼。水火王贼等怖皆不能害。诸比丘。从今已往于不信前勿说此经。求经过者慎勿示之。于尼干子尼干部众诸外道中。亦勿说之。不恭敬渴请亦勿为说。若违我教亏损法事。此人则为亏损如来。诸比丘。若有礼拜供养此经典者。应当恭敬供养是人。斯人则为持如来藏。尔时世尊而说偈言

  当勇超尘累　　勤修佛正教
  除灭死军众　　如象践苇芦
  持法奉禁戒　　专精勿亏怠
  以弃生流转　　尽诸苦有边

佛说此经已。贤护胜上童真。大药王子。并诸比丘菩萨摩诃萨。天人阿修罗乾闼婆等。普大会众。闻佛所说欢喜奉行

大乘显识经卷下(右大唐永隆元年三藏地婆诃罗于东太原寺译出大周录)


大方广三戒经卷上

    No. 311 [No. 310(1)]

大方广三戒经卷上

        北凉天竺三藏昙无谶译

如是我闻。一时佛住王舍城只阇崛山。而是山王高峻广博持众杂谷。犹如大地生杂种华。紧那罗乾闼婆众。常所游止。有种种诸众。天龙夜叉罗刹毗舍遮。止住其中。多种杂类。所谓师子虎犳。象马骐驎。熊罴獐鹿。青牛水牛。羖羝猕猴。是等众兽止住其中。有无量众鸟。所谓孔雀鹦鹉。鹦鹆命命鸲[只*鳥]凫雁鸳鸯。鹅鸭黑雁。山鸡鹖鸡。乌雉鸠鸽。雕鹫雀遮沙。如是众鸟依止而住。是诸众生以佛力故。不为贪欲嗔痴所恼。不相茹食。共相亲爱如母如子。是时山王中。稠林郁茂枝条无折。多众杂树。天木树。毕利叉树。马耳树。毕钵罗树。紧柷加树。呵梨勒树。呵摩勒树。毗醯勒树。多罗树。迦尼迦树。庵婆罗树。阎浮树。木芥蒲桃桃杏梨奈婆隆伽树胡桃安石留镇头迦树。尼驹罗树。松柏豫樟波奢树。勋陆栴檀沉水苏合。是等诸树无不备有。是山王中。水陆众华悉皆具足。谓阿提目多华。瞻婆华。波吒罗华。婆师华。须曼华。修乾陀华。由提迦华。迦腻迦华。牛蕀百叶曼殊沙华。是等众华遍布其地光饰山王。又有水华。青黄赤白杂色莲华。皆悉具足。是山王中。常于夜半兴起大云。天龙微云降于八味细微香雨。一[穀-禾+牛]牛顷。此雨着润只阇崛山。后夜清明无诸云翳。微风清凉悦适身心。是山王中所住众生。及诸草木充润光泽。犹如华鬘以水洒之。光色鲜净遂倍增胜。只阇崛山生柔软草。色香味具青缥右旋。众杂妙色如孔雀项。其香犹如婆师罗华。其触犹如迦陵迦衣。其地柔软。下足之时足陷四指举足还复。是山王中多诸池流。清冷水满生诸莲华青黄赤白红紫等色。大如车轮。若取华时。香气普熏满一由旬。是山王顶。出生大妙莲华之座。无降伏宝。青琉璃为茎。阎浮檀金为叶。坚黑栴檀为台。马瑙宝王以为其须。纵广如海。百亿阿修罗王常所执持。百亿杂色宝王网以覆其上。百亿龙王雨妙香雨。百亿金翅鸟王口衔缯彩。百亿紧那罗王欢喜瞻察。百亿摩睺罗王而观视之。百亿乾闼婆王歌咏赞叹。百亿天王雨末香衣服。雨香华鬘幢幡盖雨。百亿梵王在上空中合掌而侍。百亿净居天众合掌礼敬。百亿转轮人王七宝侍从来至其所。百亿海王从大海出而敬礼之。百亿大珠宝王以为照明。百亿净摩尼宝王以间错之。百亿遍悦宝王为华子实。百亿光明德宝王以为照明。百亿杂色摩尼宝王以为照明。阎浮幢宝王为善安持。百亿金刚师子宝王不坏庄严。百亿日藏宝王以杂庄严。百亿杂色不可思议宝王出杂种色。百亿如意宝王出无尽庄严。是大莲华从于如来出世善根之所出生。菩萨志意之所护持遍现诸方。从如幻法出善法业生。从无诤法眼之所庄严如梦法生。从无行起从无碍道来。充遍满于十方法界。是佛境界功德所致。若于无量阿僧祇劫。叹其功德不可穷尽。尔时世尊。于是华上结加趺坐。与大比丘众八千人俱。其名曰阿若憍陈如。大德曷尸波阇。大德婆宾。大德摩诃男。大德优陀耶。大德耶奢。大德富那。大德无垢。大德憍梵钵提。大德善臂。大德优楼频螺迦叶。伽耶迦叶。那提迦叶。摩诃迦叶。大德迦栴延。大德舍利弗。大德大目干连。大德阿那律。须菩提。离波多。富娄那。弥多罗尼子。优波离。罗睺罗。难陀。大德阿难等。如是上首八千人俱。悉皆谛了如实之性观察实际。度于法性度诸有海。行于如来虚空之行。结缚永断无巢窟碍。行空寂静永断疑网。信佛智海度到彼岸。益利世间作不请友。欲护一切所有众生。慈心不舍一切众生。善能演出一切佛行。守护佛法誓护佛法。善趣佛种向一切智。复有菩萨摩诃萨八千人俱。普贤菩萨。文殊师利等而为上首。无上智菩萨。无上宝智菩萨。无碍智菩萨。华上智菩萨。日上智菩萨。月上智菩萨。无垢上智菩萨。金刚智菩萨。远尘智菩萨。遍说智菩萨。光幢菩萨。山幢菩萨。宝幢菩萨。无碍幢菩萨。华幢菩萨。净幢菩萨。日幢菩萨。欲乐幢菩萨。离垢幢菩萨。遍悦幢菩萨。地威德菩萨。宝威德菩萨。大威德菩萨。金刚智威德菩萨。无垢威德菩萨。日威德菩萨。月威德菩萨。山威德菩萨。智照威德菩萨。遍威德菩萨。地藏菩萨。虚空藏菩萨。莲华藏菩萨。宝藏菩萨。日藏菩萨。净德藏菩萨。法海藏菩萨。遍悦藏菩萨。船藏菩萨。莲华德藏菩萨。日眼菩萨净眼菩萨。无垢眼菩萨。无碍眼菩萨。遍见眼菩萨。善利智眼菩萨。金刚眼菩萨。宝眼菩萨。虚空眼菩萨。普眼菩萨。天冠菩萨。照法界志冠菩萨。道场珠冠菩萨。悦诸方冠菩萨。一切佛现在藏冠菩萨。超一切世间冠菩萨。遍悦一切冠菩萨。无毁冠菩萨。覆一切如来师子座冠菩萨。照一切法界虚空冠菩萨。龙主髻菩萨。梵主髻菩萨。离一切佛法慢髻菩萨。道场髻菩萨。出一切愿海音珠髻菩萨。放一切如来光场珠髻菩萨。一切虚空无坏语宝髻菩萨。诸佛神通遍照幢宝珠网覆髻菩萨。出一切如来法论声髻菩萨。出一切三世名声髻菩萨。大光菩萨。净光菩萨。宝光菩萨。离垢光菩萨。月光菩萨。法光菩萨。寂光菩萨。日光菩萨。神通光菩萨。天光菩萨。德相菩萨。智相菩萨。法相菩萨。无坏相菩萨。光相菩萨。华相菩萨。珠相菩萨。佛相菩萨。梵相菩萨。遍超相菩萨。梵音菩萨。海音菩萨。地音菩萨。世音菩萨。石山音菩萨。遍法界音菩萨。出一切法海雷音菩萨。摧一切魔场音菩萨。出大悲道雷音菩萨。灭一切世苦恼音菩萨。法勇菩萨。增勇菩萨。智勇菩萨。德山勇菩萨。德增勇菩萨。名称勇菩萨。普照勇菩萨。大慈勇菩萨。智照勇菩萨。如来种性勇菩萨。光德菩萨。胜德菩萨。法勇德菩萨。遍光德菩萨。法德菩萨。月德菩萨。虚空德菩萨。宝德菩萨。相德菩萨。智德菩萨。婆罗王德菩萨。法主王菩萨。世主王菩萨。梵主王菩萨。石山主王菩萨。众主王菩萨。天主王菩萨。寂主王菩萨。不动主王菩萨。化主王菩萨。菩提胜主王菩萨。寂声菩萨。无碍声菩萨。地声菩萨。大海声菩萨。雷声菩萨。照法声菩萨。虚空声菩萨。一切声菩萨。善眼雷声菩萨。发本愿声菩萨。灭一切魔场觉菩萨。智山觉菩萨。虚空觉菩萨。无碍觉菩萨。寤音觉菩萨。照三世觉菩萨。宝觉菩萨。无畏觉菩萨。遍照觉菩萨。法界眼照觉菩萨。如是等菩萨摩诃萨八千人俱。悉皆具足普贤愿行所行无碍。遍诸佛刹现无量身。悉能往至一切佛所。眼界清净所见无量。悉能现佛一切神通所缘无量。一切如来有成佛处。悉往其所无有疲惓。智光普照一切法海。无量亿劫叹德叵尽。乐说清净量同虚空。智行清净无所依倚。随众所乐而为现形无有障碍。解无众生无我等界。慧如虚空如智光网。普照一切所有法界。其心毕竟寂静无乱。一切陀罗尼智种境界。三昧无畏所往无碍。住于法界百亿眼目。行一切法得无所畏观无量智海禅波罗蜜到于彼岸。得般若波罗蜜神通波罗蜜。过诸世间三昧波罗蜜善得自在。复有五百比丘尼。其名曰摩诃波阇波提比丘尼。安隐比丘尼。莲华比丘尼。极苦瞿昙弥比丘尼。罗睺罗母耶输陀罗比丘尼。是等上首五百比丘尼俱。复有五百优婆塞。其名曰善威德优婆塞。天威德优婆塞。慧光优婆塞。名称威德优婆塞。过名称威德优婆塞。善志优婆塞。月德优婆塞。月欢喜优婆塞。大欢喜优婆塞。罗睺跋陀优婆塞。大贤优婆塞。如是上首五百优婆塞。复有五百优婆斯。大光优婆斯。善光优婆斯。善身优婆斯。可乐身优婆斯。贤优婆斯。贤德优婆斯。月光优婆斯。相光优婆斯。德光优婆斯。善眼优婆斯。是等上首五百优婆斯。及余天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。恭敬围绕于佛世尊。尔时世尊而演说法。名曰三戒。广分别说一切诸佛如来境界菩萨所行。能悉普照一切法界。明照一切诸法界场。入净庄严一切法界。摧灭一切诸外道等降诸魔怨。普悦一切诸众生界。能知一切诸众生等迷惑之心。随众生心而为演说。善能照了转众生根而为显示。是时大德摩诃迦叶。从座而起整衣服。偏袒右肩右膝着地。合掌向佛白佛言。世尊。若诸众生求于佛法力无所畏。如是等人当集何法。当以何法护是众生。当以何法令不退转无上正道。如是请已。佛告迦叶。善哉善哉。迦叶。汝今所问多所安乐。安隐世间利益天人。乃能问佛如是之事。迦叶。汝今谛听善思念之。吾当为汝分别解说。大德迦叶及诸大众受教而听。佛告迦叶。若有众生求佛智慧佛力无畏。迦叶。是等众生于一切法。应无所得无所依倚生诸善根。迦叶。若有菩萨求于无上正真道时。若有相着。或于佛法起有为相。或于佛法起无为相。或于佛法而起妄想。自作是相我知佛法。于是相中坚执不舍。当说是人不名为向于无上道。何以故。悕欲佛法则为着我。当作是修。若数执我则不能断。若不能断则有悕望。所悕望处乃悕望法。便为所害。若为所害便起驰骋。若起驰骋则有流转。若已流转则有贯穿。若已贯穿则有妄想。若已妄想则有分别。若已分别增益妄想。若增妄想则有思觉。若已思觉则有坚着。若已坚着则有随逐。若有随逐则有迷惑。若已迷惑则便为失。云何为失。谓失安隐。云何安隐。谓无分别。若起分别则便有常。若已有常则有对碍。若有对碍则便有住。若已有住则有相续。若已相续则有相违。若已相违则重相违。若重相违则有虚错。若已虚错则有狂乱。若已狂乱则有虚诳。若已虚诳则有忧恼。若已忧恼则有悔恨。若已悔恨则有所害。善不善法随所爱着。然实无有定法可着。但以想转为想所缚。是名想缚。贪无定处。嗔无定处。痴无定处。起于妄想分别之心不能度得无上正道。迦叶。是名爱处。何故名之为爱处。无有定法名之为爱。无可爱法无可爱处。但坚着爱唯空坚着。谓坚着我坚着众生。坚着净不净。迦叶。一切法空妄想为物。若无物物想。则以菩提为物。若以菩提为物则是我想。若有我想。是则不名为菩萨也。何故名之为我想也。虽有所想想无所得。想无所得名为我想。是故不真实句名为我想。若众生实则菩提实。云何为菩提。谓见诸法皆悉如幻。云何如幻。谓不说我想命想众生想。若有无想在于心者。是人则着想及非想。若着想非想是则狂醉。若已狂醉则为一切众苦所追。若为一切众苦所追。如来说名为住狂谄。何以名谄。住于狂乱有妄思惟。若妄思惟则有我我所。若有我我所则有言说。若有言说。如来说名为无言说。彼为言说言说所持。是故说言一切诸法从思惟有悉是我实。迦叶。犹如空中有云聚起。而是云聚不从东西南北四维上下而来。如来实说不从十方方所而来。解如是已如实而说。随义演说相应实说。而是云聚则非是聚。说名云聚。何故说名云聚也。起众杂色种种杂色。从虚妄起。是中无定名为云雾。见云雾起。虽见云雾无有定想。是中毕竟无云雾实。迦叶。犹如有人语余人言。相与共往至荫处坐。智慧之人作如是言。我今不往。是人答言。不说有我但说有荫。智者有言。汝若说荫则为非荫。迦叶。汝观是人。于少言说尚不系着如是。迦叶。若解如来法性道者。于大众中正师子吼。迦叶。如来尚欲于不善法行于善法。若世众生有我想者。于如来所是第一义。何以故。如来解如是我想者则为非想。余小凡夫不知如来随宜所说。与如来诤。是故我说世间与我诤。我不与世间诤。云何世间。世间者名曰众生。云何名为众生世间。如来了知世间如如。是故名曰众生世间。诸凡夫等自生是知。是生是灭互相残害。是彼言说欲得出世。何以故。此得大闇住着世故。若住着世则便有贪。若贪则嗔。若嗔则痴。若痴则有诤。若诤则相违。与谁相违。谓与如来及声闻僧。若相违则贪。若其有贪则重相违。若重相违便取于有。若取于有则便求有。若已求有便不知足。若不知足则便多作。若已多作便有多欲。若有多欲。则住欲界色无色界。若住三界则便执着。若已执着则无逆流。若无逆流则常受死。若常受死不至涅槃。若不至涅槃。至叵至处。至叵至处。谓至地狱如是。迦叶。修行不吉名为不修。若不正修则有嗔恚。若有嗔恚则无推求。若不推求则不识我想。若不识我想则同一聚同为一物。谓我我所。云何名我。执着不实作种种妄想。造作诸业。若作种种妄想。造作诸业则着于我。云何我所。无有智故名为我所。又是身者。诸物和合名之为身。名戒聚果。以嗔恚心轻于他人。以嗔恚故生于我慢。如聚生谷摄受守护。是名我所。若有我所则有狂惑。若有狂惑则便有痴。若已有痴便有诽谤。若有诽谤则便有嗔。若已有嗔便有贪取。则为所烧。为所烧者为想所烧。所谓男想女想命想。此是我许。是名我所。有我所者彼骂我所。骂我所者谓是凡夫。是凡夫道之所依止。是名我所。迦叶。若不闻此法。知于菩提。知菩萨行。此知于行。迦叶。是菩萨行都无有行。名菩萨行。又迦叶。菩萨行满决定清净极为清净。无有是处。若有精进斯说大法。此以诸法如虚空聚不取法聚。是人所说。大法相应非不相应。斯有功德不住恶处。是有德行非是德行。是能持法。如是受持不着持法。何以故。如来所说。最为第一应供中最。众生问道。我应当以胜法而答。云何胜法。所谓一切诸法无想。迦叶。如是菩萨名净持戒。心不起恶不作障碍。不谤比丘尼。不亲近白衣。不杀不盗不邪淫不妄语不两舌不恶口不绮语不贪嗔不邪见。不自恼不恼他。不亲近欲不贪欲于欲。不毁呰不调戏。不自作不教他作。不至淫舍。不至寡妇。不至童女。不近捕鸟网鱼猎师。不近魁脍旃陀罗人。不近他妻饮酒之人。乃至不以手执其手而共诤竞。如避恶狗。远此亦尔。舍远此时乃至不生一念恶心。住于慈心。舍二十事。何等二十。舍离女人终不共戏与其粗语。不共论议起于斗诤。离不恭敬供养父母。离不恭敬佛法僧。若女减少无二十众不为说法。除有男子。若比丘尼。聚会说法不往其所。终不问讯于比丘尼。不与女人书。亦不为作。亲族别请不受其请。终不欲心住女人前。乃至不宜共同道行。若有比丘尼而戏弄之后不还报。一切时中。终不受着比丘尼衣。除在四众演说法时有施衣者。生心如地然后受之不面前受。一切时中若有比丘尼劝道施衣终不受取。一切时中设令病苦若尼劝食终不食之。况复无病。一切时中寡妇请食。若僧数不满终不受之。一切时中不入于比丘尼寺。一切时中亦不请唤于比丘尼。请唤拱手仰头弃舍背去。若说法时。有比丘尼来礼其足。至心合掌目不异视不动其足。非为身健名大丈夫。若心勇健正念一处名曰丈夫。于一切物不生爱心。于一切时终不生嗔。常当专念于一切智。闻是法已。应当修学而增长之。迦叶。向菩萨乘善男子善女人。闻法已不能修学。是终不得无上正道。何以故。迦叶。由修学故得无上道。非不修学得无上道。迦叶。若不修学得无上道。兔马猫狸亦当得成于无上道。何以故。不正行者无菩提故。迦叶。若以音声得阿耨多罗三藐三菩提。作如是言我当作佛我当作佛。而成佛者。无边众生亦当作佛。迦叶。但是众生具是行难。乃至一日一夜尚不能专。况复一劫乃至千劫。是故如来出世甚难。迦叶。三千大千世界之中一切众生。若一劫若十劫。若百劫若千劫。若百千劫若万亿劫。皆共同声唱。一切众生汝当作佛汝当作佛。是诸人等如是不懈常作是言。汝当作佛汝当作佛。口业不息。不能令其起菩提心。若得作佛无有是处。迦叶。我灭度后末世之时。及与汝等般涅槃后。诸天不护。尔时虽有闻我所说发菩提心。有诸比丘发菩提心。当住二十法。何等二十。谓当亲近于比丘尼。食不净食着揣食受尼劝食。迦叶。犹如今时多闻比丘。空闲静处若在众会勤修集法。如是迦叶。当于尔时。诸比丘等。若在聚落若闲静处。与比丘尼而共和集勤问于法。当重生于淫欲心不生法心。是比丘尼多生欲心少生法心。迦叶。汝观是人得菩提名。当堕大恶可畏道中。迦叶汝观。尔时诈以为法共相亲近。若相见时欲火所烧出不净言。相亲近时用为弟子。初以师法和南礼敬。自是之后当渐遣使。若遣使时胜达名字。既达名已私窃为妻共道入出。后闻他问是谁所有云何族亲。呼为姊妹数数相见。数相见故则堕非处。互生欲心渐现欲相。以言说之遂为不净行。习阎罗王法。失于菩提生天涅槃。舍于如来及舍远法亦无僧利。住于一处生欲觉嗔觉恼觉害觉。菩萨行业四净梵行。是人无有如余菩萨勤四梵行。是人勤行欲嗔等觉。亦复如是。迦叶。当于尔时。是恶人住。有是贼住。有斗诤住。迦叶。尔时禁制悉皆毁坏。闻是等经便生轻毁。本所持戒本行檀施。生于欢喜发菩提心。后闻是经而毁谤之。迦叶。当于尔时有是印相。闻如是经而生诽谤。若有净戒持法比丘应如是知如经句来。应当舍离如是之人。以其无有爱法心故。复次迦叶当于尔时。是诸人等自唱是言。我行菩萨道生于狂逸。以狂逸故。自称我是大阿罗汉我是缘觉。彼不可治不可复住向于恶趣。复次迦叶。尔时无有作善业者。令多众生毁呰菩提。迦叶。当于尔时粗有形相。复次迦叶。当尔之时。有一人行相似波罗蜜。是为后世粗有形相。复次迦叶。当于尔时。如是等经说真实者当被谤毁。当见舍弃云邪见说。迦叶。时痴人不知此经禁制破戒。迦叶。当于尔时。悉为恶贼自不见法无恼菩提。愚默靖思谤无菩提

复次迦叶。当于是时。无和合僧粗有形相。复次迦叶。当于是时多不知恩勇健为恶。作何等恶数数言说。称佛名号以致供养。复次迦叶。当于是时。呵解脱戒不护口业。不护口业故。不护威仪住不净处。住不净处而演说法。我法是时渐当薄贱

大方广三戒经卷上大方广三戒经卷中

        北凉天竺三藏昙无谶译

如是渐渐多有女人。弃舍其夫游诸僧坊。入僧坊已。为一女人而独说法示解脱法。迦叶。我见尔时纯是非法。五百非法门。五百烦恼门。不修行人。当于尔时。悉是无戒在家无异。迦叶。当于尔时戒法极恶。若希望利益求菩提者。不应亲近于比丘尼。不住是处离不亲近更勿亲近。舍世利养依乞食行。舍爱衣服受粪扫衣。舍离台观床卧敷具。依止山林坑涧窟舍。舍离一切甘美病药。依陈弃药。于诸众生生亲爱想修行慈心。当忍一切毁骂挝打。舍离一切知识亲族。修业自活。不应同彼在家之人。说解脱戒当随顺行。迦叶。若违解脱戒。便违如来力无所畏等。则违过去未来现在诸佛菩萨。如是罪报。若三千大千世界。所有一切众生悉堕地狱。是等众生所受苦痛。比是苦痛百分不及一。千分百千分。百千亿。乃至算数譬喻所不能及。若欲得离如是等苦。应当舍离是痴恶人百千由旬。若闻其声犹应当离。况复见闻而不离之。应亲近一法。云何一法。一切诸法悉无所有。若忍诸法悉无所有。应当远离如是恶人而不亲近。又复应当亲近二法。何等二法。一切诸法悉无所有。求集诸法不着集心。云何为集。如所集者都不可得。不可得中而不生心。如离邪见舍离三有。亦复如是行菩萨行。离诸相心行菩萨行。行菩萨行时舍离如上所说。舍离是已值弥勒佛。离诸怖畏作如是言。快哉安乐快哉得离于魔伴侣。快哉得离远于恶道。迦叶。若闻是经已不怖不惊。自见己身生能持心。如来悉知是人能持于我法藏。迦叶。犹如长者多财封禄。是长者子。所见诸物起父财想。初始见时此是我物。后持此物随所至处处处藏举。如是迦叶。尔时比丘闻。是等经作是念言。此是如来软妙梵音之所演说。复有比丘闻是法已而起诽谤。是持法比丘作如是言。此是佛说最为真实。少于伴侣是人劣弱。居处不恶日处藏举。迦叶。我后世护法城者甚为极少。我持是等委付弥勒为其伴侣。是等当修行于大舍。若有善男子。闻是法已如教而作。是当在于弥勒初会修行梵行。正见众生当护法城。迦叶。我不见有乃至一人不值于我。后五百岁法欲灭时。闻是法已而不诽谤。能受持读诵。无有是处。若已见我亲近恭敬。于后末世五百岁时闻如是经。能受能持能读能诵。如是人等不待我读诵斯。自当有一切智心。念于我已生于欢喜。作如是言。奇哉奇哉释迦牟尼世尊。能受我法守护于我。是故迦叶当学此法。学此法者。随所欲乐必成无难。尔时。摩诃迦叶白言。世尊。如我今者。永无希望失于无上正真之道。世尊。若令我具一切智者。甚用欢喜。若我得无上道者。得希有色身。佛告迦叶。我不导汝。我因汝故说于是等。令少疑惑速成无上正真之道。复次迦叶。若有众生渴法成就修集成就。是等渐渐成无上道。普断一切所有。盖缠而为说法。迦叶。菩萨应当成就四法。何等四。菩萨应当发大精进。云何精进。精进者谓不求色受想行识。集无漏法。云何无漏法者。无地大不说地大。无水火风大。不说水火风大。一切言说皆是不实。是菩萨取言说彼岸。迦叶白言。世尊。设有人问。如来亦以言语说法可不实耶。世尊。如是之人当云何答。我今欲从如来应供正遍觉闻

佛告迦叶。未来当有诸恶比丘。不修身不修戒不修心不修慧。嗔恚勇盛口业勇健。不受不持不读不诵如是等经。何以故。是生起色受想行识。如是等经言说之法。尔时。世间当有比丘。生起于色受想行识。彼时比丘当如是住犹如在家。终不推求于第一义。迦叶。如生盲人着金华鬘是不自知。迦叶。将来比丘亦复如是。闻是等经不能持文。况能推求解第一义。迦叶。如有男女为他丈夫之所呵诘。而是男女更于异时。若复闻说是丈夫名惊恐怖畏。如是迦叶。后末世时诸比丘等。闻是经说如实过恶贪于衣服。知己有过惊恐怖畏。迦叶。犹如猕猴为枷锁系。而是猕猴目不欲见如是枷锁。如是迦叶。后比丘等亦复如是。闻是等经目不喜见背而舍去。迦叶。犹如有狗驰逐野干。而是野干走趣冢间孔穴深坑。如是迦叶。未来比丘闻是经已。如野干走。野干驰走谓犯禁戒。闻是等经而生诽谤。迦叶。如野干走趣于冢间。如是迦叶。未来比丘闻是法已。驰趣还家驰趣色欲驰趣女人。趣于斗诤趣于医术趣于断事。住是诸处设犯禁戒。我说是等喻趣冢间。迦叶。如野干趣于孔穴。如是迦叶。尔时比丘。身坏命终趣于地狱。我说是等名趣孔穴。迦叶。如野干走趣于深坑。未来比丘亦复如是。身坏命终生刺地狱。迦叶。我说是等名趣深坑。迦叶。同如野干。诸比丘等。不能推求如是等经解其义趣。但能如是毁谤扬恶。身坏命终堕在恶道。迦叶。若有比丘作如是言。汝说之法悉是不实。如来言说为是真实为不真实智。比丘言。大德今者为执何事。为执于空为执言说。答言。我执言说。问曰。汝即是佛。何以故。汝今亦以言说故。答言我执于空。问曰。此当分别。何以故。不可分别名之为空。汝之空者即是言说。又汝空者。为是我空为我所空。为众生空故空。又复问言。比丘汝意云何。汝喜一切法空不也。答曰。我都不喜一切法空。又问。大德久失沙门释子之法。何以故。是佛世尊说一切法空。不说有我众生寿命。不说有人。答曰。我今喜乐一切法空。问曰。大德尚喜一切法空。况复如来应供正遍觉。大德于意云何。眼是如来不。耳鼻舌身意是如来不。答曰。眼是如来。耳鼻舌身意是如来。问曰。此当分别。若其尔者大德便为亦是如来。答曰。眼是言说非是如来。耳鼻舌身意是言说非是如来。问曰。此当分别若眼非如来。耳鼻舌身意非是如来。大德先说。如来即是言说。今者何故说言非也。答言。眼非如来。非离眼是如来。乃至意非如来。不离意是如来。问曰。如来说十二入是众生。此当分别。大德眼色是如来不。乃至意法是如来不。答曰。眼色是如来。乃至意法是如来。问曰。如汝言者。一切众生即是如来。一切诸地一切诸山。树林草木悉是如来。答曰。眼非如来乃至意非如来。问曰。若其尔者。则说如来是法非法。答曰。色非如来。乃至法非如来。问曰。大德法非如来也。答曰。法非如来。问曰。若其尔者。有诸众生。说无父母无沙门婆罗门不净种性。杀盗邪淫妄言两舌恶口绮语贪嗔邪见。如汝所言皆是如来。答曰。非是不善名为如来。问曰。若其尔者。如汝所说。法非如来。非法非如来。若非法非非法。则无言说。如大德言。无有言说名为如来。迦叶。应当如是数数折伏是诸恶人。迦叶。我不见世间人天魔梵。能与如是如法说者而共语论。唯除嗔痴不堪忍者。无因缘者毁呰空法弃舍而去。是故迦叶。汝等当持如是比经。迦叶。未来世有持是法者。当有三名。何等三。谓说断灭。谓说无物。说无阴聚。无有恭敬。迦叶。当尔之时。如是等经当被诽谤。迦叶汝观。尔时不恭敬佛。不恭敬法。不恭敬僧。若不恭敬佛法僧已。何僧名住。但依言说依于名字。虽唱佛名于众显说。而不能见何者是佛。虽口说法而不能知。如来世尊云何说法。虽作是言四向四得。是佛世尊声闻之僧。俱知于名而不能知依名实德。为于衣服饮食卧具病药缘故。毁谤于法。菩萨是中应勤精进。于是等经生希欲乐。应当受持而读诵之。何以故。是人来世当护法城。何以故。九十一劫不闻演说是空法故。迦叶。我今惟念过世千劫。尔时有佛出现于世。号曰寂灭。寿命八万四千岁。守护菩萨利益世间。复有如来号曰离垢。寿命二十一劫。行菩萨道然后乃成于无上道。迦叶。汝观如来作几难行摄诸众生。迦叶。劫浊尽时不应呵是。何以故。迦叶。劫浊尽时若有一人能信此法。甚为希有。当于尔时。持是法者。不被刀杖瓦石所害。甚为希有。何以故。迦叶。此法是大善丈夫法。谓说一切行是非行。若着我见众生见命见人见有见者等。所不能解。及依见者。谓依戒见佛见法见僧见涅槃见。若有起于涅槃见者。如来悉知是为邪见。何以故。迦叶。如来不有涅槃。不得涅槃。迦叶。若有涅槃得涅槃者。如来悉说名为邪见。若邪见者说名无智。若为无智之所害者。是愚凡夫。若愚凡夫生天尚难。况佛菩提。迦叶。未来世中当有比丘。年二十三十四十五十六十七十八十。乃至百岁。老耄无智庄严衣服剃发毁形。痴老之人无有威德起于邪业。是临终时。复更造恶作毁戒法。斯以三事作于奸诈。何等三。示现威仪。示现持戒。行善人相。举指现相以如此法。用显己德是堕大慢。以痴悔心而取命终。身坏命终堕于地狱。是故迦叶。我今唱令我为汝等真是知识。我教汝等欲利汝等怜愍汝等。不令于后受大热恼。迦叶。我终不听着见众生而得出家。着我见者众生见者命见者。着人见者而得出家。我实不听强在我法而便出家食重信施。无有真实持戒功德。迦叶。人宁六日断于饮食。非着我见众生见命见人见乃至涅槃见受食信施。菩萨是中应勤精进不着我见至涅槃见。迦叶。我是等经。付嘱如是诸善丈夫。何以故。是等所行如我行故。如是之人即是我侣即是我伴。尔时世尊而说偈言

  诸苦恼众生　　都无有救护
  唯除世导师　　无有戏论者
  诸苦恼众生　　依止下道者
  渐增长诸欲　　由是堕恶道
  无导无利益　　住在崄旷处
  趣向不正路　　终无有安隐
  犹如持财宝　　求利行旷野
  彼有群贼起　　一切悉劫夺
  失财已还归　　失利增苦恼
  从他所贷财　　以此倍增苦
  是等亦如是　　造业已未还
  本所造白业　　还来食此财
  依止劫夺者　　凡夫堕见者
  执着于我见　　命见及人见
  说空法比丘　　依我人见者
  于是生谤心　　速疾堕恶道
  生起造嗔恚　　更互相轻毁
  诽谤说不实　　于此惭愧者
  身恶及口恶　　意业极奸谄
  坚执着诸见　　斯趣极恶处
  作于恶业已　　速疾至恶处
  多受众苦恼　　无有救护者
  未来世当有　　嗔恚勇盛人
  苦切逼比丘　　趣向菩提者
  于如是等经　　无慈者当毁
  而不生信敬　　于释师子法
  更互生诤讼　　速起大忿诤
  更互相谤毁　　扬恶遍诸方
  造种种诽谤　　加彼惭愧者
  恶友得势力　　柔软者弱劣
  知正法劣弱　　恶法增势力
  是比丘当去　　我之所爱子
  当去至何方　　得于安隐处
  众恶者除放　　于此无悲心
  我如是等经　　常当思念之
  导师如是说　　以是自娱乐
  我当至此处　　佛所称誉者
  今法毁坏时　　柔和者难得
  或有作是言　　当速离是处
  当至大仙人　　得无上道处
  复有作是言　　善哉说是语
  导师如是说　　当游礼诸塔
  宁当至是处　　可乐菩提树
  非彼嫉妒者　　嗔恚忿诤处
  是比丘便去　　我所说应行
  见是余住处　　谓佛所住处
  经行及坐处　　若石及空处
  集趣是处已　　数相对啼泣
  此是大仙处　　经行受用处
  佛本在是处　　见处不见佛
  此无上仙人　　所说无上法
  我等今不见　　有为悉无常
  人及诸非人　　天龙悉等来
  善说令欢悦　　我等今不见
  至是所住处　　谓菩提树下
  既集至此已　　正念善思惟
  尔时世导师　　得无上菩提
  惊怖魔王众　　犹如小野干
  此本道场地　　如来所坐处
  过去未来佛　　悉在是坐处
  此是勇健者　　亿天所恭敬
  加趺坐七日　　观视此树王
  是人供养已　　复诣说法处
  是处转法轮　　声闻于梵世
  是比丘往彼　　数数而啼泣
  勇健者来此　　调伏是五人
  五人见佛已　　即生起忧恼
  而共计议恶　　皆悉勿为起
  是大悲世尊　　于众起悲心
  为五比丘说　　转甘露法句
  礼法轮处已　　复数数啼泣
  复至涅槃处　　见佛最后处
  尔时世导师　　利益多众生
  碎末破己身　　佛此入灭度
  咄哉佛世尊　　释师子能仁
  今唯闻其名　　而不睹其形
  是无上仙人　　善贤最在后
  大智知是已　　此是我最后
  或游行命终　　或住处命终
  游行竟命终　　悉往生善处
  于后末世时　　是广大佛法
  斯当得涅槃　　诸住净戒者
  若毁戒比丘　　普亦得供养
  服食重供已　　速往至恶道
  观此诸比丘　　有如是差降
  智者于后终　　速疾得生天
  是等照世灯　　怜愍世间者
  大智慧菩萨　　慈心利众生
  当住营事人　　踊跃欢喜心
  我当得作佛　　亦得值弥勒
  当供彼世尊　　在一切众前
  一切智记我　　如我之所念
  是有大势力　　我说如是义
  虽不见于佛　　当知如面对
  我当安慰此　　亦复当如是
  修行菩提分　　悉礼一切佛
  若有诸女人　　向无上菩提
  我亦安慰是　　及无量如来
  舍是女身已　　速成男子身
  得见于弥勒　　是当供养之
  一切所求索　　悉皆如其意
  随学是智者　　生殷重坚欲
  有于坚欲已　　持戒广多闻
  斯为弥勒佛　　得受于记别
  是故闻是利　　生起贤善信
  坚信而趣向　　摄一切众生
  谁有求是处　　而有不得者
  有慧及精进　　菩提不难得
  不作谄曲心　　修习行慈心
  常住闲静处　　此名菩提行
  舍弃如是处　　但说菩提处
  此是大贪贼　　一切诸远离
  若为于饮食　　及诸利养事
  诈现执正法　　更互共演说
  斯不净活命　　以痴用自活
  为众恶所害　　恶道所侵逼
  是一味法门　　但假比丘名
  毁谤如此法　　及与解脱戒
  若有持戒者　　我说禁戒法
  像比丘当谤　　彼不至贤处
  一切天世间　　悉皆弃舍离
  一切智世尊　　亦倍离是人
  若身无恶业　　口业亦无恶
  意业悉清净　　速疾至涅槃

迦叶。如来灭后后末世时有诸比丘。于先佛所种善根者悉般涅槃。纯善众生命终去尽。有后五百岁时当有比丘。贪求无厌嗔恚别离。粗涩毒恶嗔面颦蹙。住于三法。何等三。专修医道。住于贩卖。亲近女人。住是三法当失四法。何等四。失于戒聚。失于善道。失得果证。失如实见法。是人有于此四法已复增炽四法。何等四法。嫉妒炽盛。嗔恚炽盛。贪他家炽盛。贪着利养贮聚炽盛。贪爱衣服造作箱箧。以此为业空无所有。无沙门法。闻是法已当堕四法。何等四。堕在谤法。不知时言。独为女人而演说法。渐毁犯戒。闻是等法已堕在灾祸。迦叶。犹如恶狗打触其鼻。迦叶。于意云何。是狗为当倍恶不。白言如是。当倍增恶。佛言迦叶。是等恶人如彼恶狗。如毗舍遮。若净意比丘。持是等法说是等法。真实少欲叹说少欲。是等闻已惊怪不信。沉没怯弱生于恼热。复增嗔恚当住何业。是时未至我今预说。彼闻此经当生诽谤。如被牟刺生大嗔怒。作如是言此非佛说。毁少欲者作如是言。当名是人为多欲者非是少欲。迦叶。我常种种叹少欲者。叹知足者善布萨者。易共住者行头陀者。阿练儿处者净活命者。汝等莫共是杂恶行者而共是同。何以故。此是在家法。莫以是法侵欺于人。是在家法汝等不应起大嗔忿。汝等莫大多集财物当舍财贿。汝等慎勿显现异相叹誉己德。汝等应当无所系恋勿多贮积。汝等勿畜驼马牛驴。汝等不应懈怠懒惰。当勤精进断不善法修集善法。迦叶。我常种种因缘。赞叹阿练儿处。清净寂静离亲近家。后末世时违我此法。违我法已。欲造众患毁谤正法。迦叶。犹如有人热时服苏。服已患渴。语余人言。汝与我水。是人答言。善大丈夫汝勿求水以服苏故。汝莫因此而便致死。是人嗔忿毁骂此人。不顺他故饮已命终。如是迦叶。未来比丘著有见者。住于诸恶持。是比丘作如是言。此事应住此不应住。反生嗔恚毁谤骂詈。谤是等经如来教法。是故迦叶。如是等人反与如来而共诤竞。迦叶。汝且观是贤护比丘。如来制戒。诸比丘僧一坐而食。闻已嗔恚。于三月中不至我所。迦叶。尔时梵行清净完具。尚能如是。况灭度后贪着饮食。贪着衣钵卧具病药。为睡眠所覆嗔恚勇盛。闻是等经。尚不恭敬于佛如来。况余比丘如法行者。迦叶。若是等法已隐灭者。极为不善甚为不善。迦叶。若善男子。欲求善利信我是法。后末世时浊恶灾变。我法末时末世滓秽。嗔恚盛时善人难得。时若有闻信是等深经。当信是人作于相应非不相应。当言信受非不信受。迦叶。我今亦说。名为相应非不相应。非是不信。迦叶。犹如恶马与善调马而共同驾。若安静无声尚不调顺。况当吹贝椎钟鸣鼓能堪忍之。无有是处。如是迦叶。破戒比丘。若能堪忍善丈夫法。无有是处。迦叶。犹如恶马以鞭一策是马惊畏。如是迦叶。若闻一说无我空法。着我想者惊畏怖恐而起诤讼。况复广说。迦叶应当发起大精进根发大庄严。降伏百千万亿诸魔。令其毕竟不起诤讼。云何起精进根。无欲是精进根。头陀功德是精进根。无贪是精进根。无痴无嗔是精进根。无嫉是精进根。离欲是精进根。独无伴侣是精进根。离于睡眠是精进根。于一切时不起一切诸恶之心是精进根。于一切时不起欲心是精进根。不起疑心起大精进离一切疑。离一切疑大庄严已。发菩提心无所依倚。况复当起于我想也。是终不应起于我想众生之想命想人想男想女想。不起地大水大火大风大之想。不起欲界想色无色界想。不起戒想犯戒之想。不起空想。悉不应起一切诸想。至涅槃想亦不应起。云何名为不起诸想。如是诸想是中颇得。迦叶。若贪欲不实。知灭欲者亦复不实。迦叶。欲无定处但虚妄说。是故如来如实而说。此欲非我如是之法。是寂灭法。云何寂灭法。若执无著。是则着想如须弥山。若人着想。当知是人败失圣法。彼不能起于沙门法。不住沙门法。是则名为痴人痴者。永不能起沙门法。何以故。是着想者。无量劫中为无间狱之所摄故。迦叶。如观拘迦离比丘。提婆达多比丘。碎财比丘。黑丘舍比丘。海与比丘。迦叶。马师比丘。满宿比丘。善星比丘。是我给侍面闻我说。见我经行见我端坐。见我神通经行虚空。见我降伏百千外道。如是等人尚于我所不生好心。以足下虫与我相违自致恶道。若有实说如来功德。应栴檀末如须弥山。以散其上作大宝盖。如三千界。于是人上虚空中侍。何以故。迦叶能有信心称佛名号。实信者少。况有信已从佛出家。远离欲秽修无著禅。甚为希有。迦叶。若众生能持于我所说禁戒。信解如是甘露之法。倍为希有。迦叶。犹如大众聚集祠处作一革箱。形容极妙彩画众色。盛以粪秽。若复有人。以上衣裹持行示人。中有见知其不实者。背而舍之。如是迦叶。若有比丘。见于如来功德法祠。中有比丘有于我想。迦叶。若有我想则起于欲。若有他相则起于欲。迦叶。无我想者。闻是等经不生嗔恚。何以故。毁呰他者此为不善。以是事故。闻此法已得于好心。若有染着于我相者是为邪见。若邪见者闻于是等真实教诲。则生嗔恚。何以故。迦叶。有我相者则起嗔恚。迦叶。若比丘比丘尼优婆塞优婆夷。闻是等法若起嗔恚诽谤之者。是人但有沙门形名。我非彼师彼非我弟子。何以故。其妄语者非我弟子。我亦非是妄语者师。何以故。迦叶。如来世尊是实语者。如来说言一切法空。迦叶。如来世尊坏一切我。是故是人与如来诤。若有与佛如来诤者。说名为魔。如来不听魔党出家受具足戒。迦叶。若说小马从龙象生。迦叶于意云何。是人语者为可信不。迦叶白言。不也世尊。迦叶。是语相应不。不也世尊。迦叶。若有众生着我想众生想命想人想。乃至涅槃想。称我为师倍不相应。迦叶。若有人来作如是言。金翅鸟王从乌而生。迦叶汝意云何。如是之言为可信不。不也世尊。迦叶如是言语为是相应为不相应。迦叶白言。是不相应。迦叶。若有着我乃至有着于涅槃者。名我为师倍不相应。迦叶。若使有人作如是言。有荧火虫负须弥去。迦叶。汝意云何。如是之语为可信不。不也世尊。迦叶。是相应不。不也世尊。迦叶。诸恶人等。着于我见众生见。至涅槃见。名我为师倍不相应。迦叶。犹如大王有给使人。更有余人人不识者。假依此使虚传王令至大富家。王作是令王语某甲作如是事。时诸大臣及诸富人。见是异人乘自在处。答是人言。我当作是。时诸富人往至王所为活命故。如是迦叶。如来福力具足自在。如王安乐无有怨敌。王居大地饮食具足。如来僧众亦复如是无有怨敌。住佛国界法食丰足。有一异人无有请者来入众中。自说我见至涅槃见。作如是言如来说是如来说是。此应作此不应作。诸如来所有信心者不违佛教。闻是说已。自割衣食及妻子。分上妙好者而给与之。信恭敬与信敬而与至未识时。如是之人如彼异人。是食供已乐喜众闹。论说王事贼事。论说饮食论说淫女。论说医事作如是言。月蚀日蚀诸王来去论说王家。复作是言。是处得食是处不得。作如是等种种论说。以是尽日夜还住处。二宿三宿乃至六宿。随所宿处论说诸事。种种嫉慢种种戏笑。言语杂合唌唾流出乱想睡眠。随所想处卧则梦见。梦见自身往至彼处承迎恭敬。既睡寤已互相说梦。大德。我夜梦汝往于是处得如是物。彼作是言。此梦吉祥宜应速往。是便往诣城邑人间。眼目视瞻摇动眉目。心多所期逼恼生热。心不专一威仪轻躁。诸根不谛心乱调动。至他家已毁犯禁戒。与一女人共独说法。因缘戏笑渐现欲相。以其利养。得利养已爱乐贪染。耽重或着常居止住。若违本意啼泣而去。趣于二处浓厚之处及赞叹处。若不浓厚骂是施主。复相聚集互相问言。谁施于众众何所得。为得几许汝食几许。迦叶。有如是等不相应行乃至于死。迦叶。是等复有不相应行。谓谤正法。迦叶当知。应当于是恶比丘所生于悲心。何以故。是等当获大苦报故。尔时世尊。欲重宣此义而说颂曰

  凡夫王给使　　为欲活命故
  游历于诸家　　王作如是令
  彼闻敕令已　　莫嗔谪罚我
  愚凡以此势　　常用自活命
  何况佛最胜　　于百千亿劫
  布施于手足　　多造众苦行
  此非我法王　　令住是谪罚
  亦无有问者　　为当作不作
  在家施比丘　　上妙美饮食
  衣服中妙者　　一切恭敬与
  自己不服食　　又不与子息
  聚集上妙色　　以施持戒者
  不相应行者　　食已速舍去
  共集于一处　　相问乐食不
  说王及贼事　　又说关逻事
  亦说饮食事　　云何佛聚集
  或说日月蚀　　问王去来事
  彼当得于胜　　亦说当尽灭
  是不相应语　　数数恒演说
  此是羊应缺(诸藏皆少一句)
  速往于彼家　　是多富有处
  是家极悭吝　　不得上美食
  生如是觉想　　百种思虑已
  恶行不知者　　犹驴负重担
  于是夜梦中　　见本所忆事
  寤已相向说　　种种而解释
  无忧大喜笑　　汝当得安乐
  速往成此事　　勿迟后致悔
  往诣村城邑　　如是不正行
  邪视动眉目　　犹若如猕猴
  是入城邑已　　为女人说法
  弃舍于佛经　　及与解脱戒
  既至是处已　　云何设粗恶
  毁骂是施主　　及所知识者
  复共相聚集　　更互共相问
  汝得何等食　　所得食妙不
  比说如是事　　经于百千岁
  如是所思觉　　以是为自活
  是起于诤讼　　聚酒及香花
  当以此为药　　则便少病痛
  佛当奈是何　　纵令有百佛
  是舍所修行　　习近在家法
  我见及常见　　起见已爱着
  彼当修是行　　以致至恶道
  斯当受呰苦　　诸谤正法者
  凡夫少觉知　　修集在家行
  诸是释师子　　实行诸声闻
  不以活命故　　而毁犯禁戒
  智者不贪食　　起于动摇想
  于食修不净　　定坐报施恩
  断诸欲漏结　　修集于诸想
  彼修行方便　　从佛法出家
  知于无诤法　　诸所说空法
  数数而修集　　中不得贤实
  勇健智慧人　　知于空道者
  魔及众怖畏　　是报信施恩
  此终无有爱　　亦不毁败空
  是勇健佛子　　二足中福田
  正法不久住　　多有恶人故
  柔软比丘少　　不放逸利者
  智者作是虑　　不久速至死
  我夜当云何　　昼亦如是尽
  世更无救护　　唯除二足尊
  诸学及无学　　皆悉当灭度
  此不知如是　　随宜所说法
  欺不恭敬佛　　及无上正法
  正法欲毁灭　　应当勤精进
  未久当得闻　　乃至于少许

大方广三戒经卷中大方广三戒经卷下

        北凉天竺三藏昙无谶译

尔时大德迦叶白佛言。奇哉世尊闻是等经。乃能不生爱惜之心。佛告迦叶。众生成就四法。闻是等经不生爱惜心。何等四。多诸放逸。不信业报。不信大地狱。不信我当死。迦叶。是名四法不生爱惜心。迦叶。众生复有四法。不生爱惜心。自怙强壮。自怙有力。染着五欲耽荒嗜酒。不起善心。是名四法不生爱惜心。迦叶。比丘成就四法。谤佛菩提。何等四。本造众恶毁乱正法现造恶业谤比丘尼。彼有和上阿阇梨多人所敬然谤菩提。是亦随学谤于菩提。少于闻见以嫉妒故谤佛菩提。迦叶。是名四法谤佛菩提。迦叶。又有一法沙门婆罗门之所应作。何等一法。于一切法心无所住。是为一法沙门婆罗门之所应作。迦叶。犹如有人堕高山顶。其心迷闷无所觉知。不识地处不识树处悉作空想。出入气息断绝不续。如是迦叶。彼执一切法。执着眼想。执着眼相。作非沙门法非婆罗门法。如是执着耳鼻舌身意想。执着耳鼻舌身意相。作非沙门法非婆罗门法。执着色受想行识想。执着色受想行识相。作非沙门法非婆罗门法。执着净持戒。执着持戒相。求于菩提。执着多闻。执着多闻相。求于菩提。执着惭愧。执着去来。作非沙门法非婆罗门法。若有执着则为所害。云何为害。为贪所害。嗔痴所害。执着眼想是执着眼相。为眼所害。爱不受色。如是执着耳鼻舌身意。以执着故为意所害。谓可意法不可意法。若为所害则为所欺。所谓地狱饿鬼畜生。及与人天诸所害者。皆由着故为其所害。是中云何名为想着。谓想着我想。着我所想。着地大水火风大想。着骨想坏想青想虫想血涂想脆想解脱想。而是解脱当有何想而犹执着。谓执于此当得解脱。执着过去无量生处。执着我当忆念是处。执着未来。及着现在起如是想。我是过去我是现在。随在在处皆起想着。乃至涅槃亦起想着。作是念言我当得涅槃。起是想着。迦叶。略说乃至随所意想皆名为着。乃至空想皆名想着。如是皆悉非沙门法。非婆罗门法。非沙门行。非婆罗门行沙门婆罗门法。如来所说。迦叶。犹如虚空及与大地。不作是念我是虚空我是大地。如是迦叶。沙门婆罗门不作是念。我是沙门我是婆罗门所作之法。以何缘故。名沙门我是婆罗门。迦叶。若无意念。是名沙门婆罗门所作之法。以何缘故。名沙门婆罗门所作之法。沙门婆罗门不作是念。我当作是我不作是。沙门婆罗门。终不作于如是之念。迦叶。犹如有人于夜闇中。以其两手扪摸虚空摇动口鼻。作如是言。我弄世间我弄世间。迦叶于意云何。为弄于谁。迦叶白佛言。世尊。是人自弄。何以故。是黑闇中无人见故。无可弄故。佛言。如是迦叶。若有比丘至阿练儿处。或至树下若至露处空处。作是想念眼是无常。耳鼻舌身意悉是无常。作是思惟。思惟色是无常。声香味触法悉是无常。作是想念。我趣涅槃则为自诳非沙门行。何以故。先着于眼后修无常。后行无常。作是恶执。先执着耳鼻舌身意。后修无常。后行无常。而是三处俱不可得。执着三处随所想着。当于何处而得一心。迦叶。诸佛菩提极为甚深。难得难到生死难过。迦叶。云何名一心。推求法时不见一法不得眼实。不得耳鼻舌身意实。虽言一切诸法不实。亦复不得。何以故。本性如是本性若尔终不生心。言一切法不实叵得不得是心。若过去世未来现在无念无行是名无行。云何名无行无新无故故名无行。是中无过去心解脱。无未来心解脱。无现在心解脱。若不得心是名一心。是名说一心。迦叶。未来当有自名比丘比丘尼优婆塞优婆夷。是等当作破坏言说。彼有阴想。如来所说五阴如梦。是等尔时说阴是实。此梦是有有梦言说。梦若无者。我等何由于是生想。有此说故我等于中而生梦想。定有此阴是故说言阴犹如梦。若无有阴则不应说阴犹如梦。是诸痴人复于此梦而生实想。闻是等经而生诽谤。有比丘尼往施主家唱如是言。某是罗汉某是罗汉。是比丘等依止浅智。比丘尼住妨废善事造不善业。是中优婆塞优婆夷。闻于少戒乃至少偈闻已便去。迦叶。当尔之时。诸比丘等有二十腊至三十腊。住阿练儿处。有优婆塞初信一日所解佛经等无差别。迦叶。当尔时世互唱空名。此空此净此空此净。时有比丘。闻是法已共相聚集。闻已不畏作如是言。此经不与出家相应。非在家相应。共舍弃之。非导师说。何以故。此非我同又不汝同。若有闻说甚深大法。在家出家悉当诽谤。何以故。迦叶。今者梵行极为纯净信者尚少。况复尔时。如是智者渐已灭度。好者转少好者转少。迦叶。当于是时。千比丘中求一比丘正入正解犹尚难得。设有一人轻笑不学。乃至三千比丘众。欲索一人正入正解亦当难得。迦叶。当尔之时。在家出家互相诽谤。迦叶。未来若有诸比丘等勤行精进。为断一切诸不善法。成就善法。初夜后夜离于睡眠。是诸恶人当夺其命。轻贱呵毁舍而弃之。迦叶。当尔之时。佛法毁坏比丘毁坏。是中智者信甚深者无染著者。应好恭敬应好爱念。共相聚集住空闲处。尔时世尊而说偈言

  我此所说法　　为明第一义
  说阴无坚实　　观之犹如梦
  尔时诸比丘　　更互共斗诤
  彼此无有异　　是得于有相
  比丘作是说　　彼报言如是
  如此之法眼　　当无有差别
  比丘语在家　　汝甚为希有
  能解此菩提　　汝逮得初果
  彼自谓见法　　来亲是比丘
  持最上供养　　数数而奉施
  如此比丘说　　真实无有异
  与我所知同　　见法而语我
  施主及比丘　　不住于正法
  破坏佛菩提　　是出时未久
  勿亲彼近我　　我是说道者
  汝当速疾得　　如我之速得
  此是第一句　　更互说寂静
  和合为一侣　　毁坏于我法
  犹如大恶贼　　杀害诸聚落
  令聚落空荒　　及与诸城邑
  比丘当如是　　无智闇钝者
  无慧毁禁戒　　依着我命人
  我所说应离　　而反依于眼
  自说是罗汉　　实是增上慢
  自和合聚集　　我是最上僧
  有名无有智　　一人尚难得
  若复有比丘　　有恶往如实
  尚说其恶名　　云非佛声闻
  毁谤于菩提　　法王之所有
  诸天极忧苦　　数数而啼泣
  闷绝坠于地　　有信诸天等
  云此释师子　　胜法今毁坏
  奇哉佛世尊　　奇哉离染法
  奇哉福田僧　　佛之所爱子
  我更不复闻　　法王之所说
  当有大痴闇　　能仁法毁坏
  发起大音声　　地天及中间
  唱令告诸天　　法炬今欲灭
  莫后诸天龙　　而致大悔恨
  仁自闻佛法　　今当更不闻
  是佛无数劫　　若自及与他
  堪忍是众生　　何时当成佛
  是佛世导师　　为一切众生
  所演说正法　　今当灭永尽
  今法坏乱起　　极造大暴恶
  魔使极恶魔　　少欲者劣弱
  诈伪无智慧　　幻伪小凡夫
  炽盛生嗔恚　　谤毁善逝法
  闻地天声已　　上天生惊怪
  四大天王等　　闻已生愁闷
  夜叉众来集　　聚在旷野城
  悉皆同愁泪　　发大呼哭声
  大音甚悲切　　诸天悉来集
  更互共相语　　心中所念者
  诸庄严城邑　　众宝之所成
  一切无光色　　犹若如土聚
  是城无威德　　无须臾可乐
  是城无威德　　如本可爱乐
  我本所生处　　诸天众来至
  见已闷躄地　　当作如是报
  诸天下至地　　往至可畏处
  如此真实法　　今者悉毁坏
  下至阎浮提　　见大毁坏事
  佛子见逼恼　　逃窜至异处
  胜成七日中　　无诸威德色
  是诸天七日　　数数而啼泣
  咄哉勇健佛　　我等面睹见
  今者永不见　　佛法复灭尽
  舍卫所住处　　来至恭敬已
  于是住处地　　数数而啼泣
  此是佛所坐　　人尊所坐处
  演说四圣谛　　我等面自闻
  世间还黑闇　　互不相恭敬
  作恶已当往　　堕于恶道中
  多有诸天宫　　皆悉当复空
  众生无救护　　阎浮提如是
  此是经行处　　空荒悉毁坏
  世间不可乐　　法王灭度后
  帝释自在主　　三十三天中
  忧愁受苦恼　　发起大音声
  诸三十三天　　举手而号哭
  如所闻诸国　　在中而驰走
  当有诸天等　　数数论说佛
  导师舍离我　　能多说法者
  诸天更不食　　无诸歌笑声
  帝释天六月　　心中甚忧恼
  阿修罗等闻　　佛法无光明
  我等今当往　　至三十三天
  阎浮提诸王　　当坏佛塔寺
  天阿修罗集　　尔时当有是
  有诸比丘等　　当堕在恶道
  有诸比丘尼　　亦堕于恶道
  在家毁戒者　　住家优婆塞
  发大恶声已　　当趣于恶道
  有诸恶女人　　是亦至恶处
  世界悉动摇　　尔时有是事
  有逃至聚落　　有走至山林
  众生悉驰骋　　少有存活者
  多有诸贼盗　　及与诸饥馑
  种五谷不获　　蟥虫作灾患
  时谷米勇贵　　人有命终者
  死后堕饿鬼　　于是受众苦
  诸有塔寺处　　四方招提僧
  尔时诸比丘　　当共分取之
  如是等众苦　　于我灭度后
  宜当速疾作　　莫观见是时
  诸凡夫无智　　诸凡夫无慧
  造凡夫行已　　速疾堕恶道
  应当勤读诵　　从慧者来处
  以慧教众生　　速至于善道
  以慧光照明　　应当学如我
  舍一切烦恼　　速疾至涅槃
  正法不久住　　应坚勤精进
  我如是戒敕　　应当正修行
  于我灭后持　　六十小劫中
  有闻佛名号　　谁当有爱者
  互共来集会　　为饥所逼切
  食母食子肉　　互展转为是
  诸有生小儿　　不令至余家
  儿自在于室　　犹生大恐畏
  有见闻此者　　生死苦如是
  谁生于贪欲　　欲想是女人
  生无知慧根　　欲本是女人
  生起众苦根　　是故应舍苦
  若有痴众生　　亲近欲女人
  若有智慧人　　速至于涅槃
  不正造业苦　　果报来应现
  此果是有漏　　是故堕恶道
  若诸无漏法　　空为无所有
  不坚寂静者　　速应修行道

迦叶。是名比丘成就初法。若有欲乐无漏法心。应不住于一切诸法说一切法。复次迦叶。菩萨应当坚作坚住。云何坚作云何坚住。应坚其心应坚精进。是中云何。名曰坚心名曰坚进。迦叶。坚心者。菩萨应生如是之心。供养恒河沙等诸佛。然后乃发于一念心。如是恒河沙等劫中无一佛出。如是复起恒沙等心。得一人身。得于是恒沙等身。闻一句法。增长此慧至无上道。是菩萨生如是之心。是菩萨念。我今应当修行如是难行苦行。精进勤修于佛智慧。我今应当如是推求。迦叶。菩萨应当如是坚心。迦叶。我引是喻。诸有智者以喻解耳。迦叶。若如是苦行得于菩提。恒河沙劫不应懈怠。勤学不懈勤学不息。恒沙等劫学于菩提。菩萨念。我今应生坚势坚欲。我终不舍无上正道。迦叶。菩萨如是应坚其心。迦叶。若有菩萨。如是坚心为取何等。谓不取处不取非处。云何不取处不取非处。若处非处悉无所有。不障碍于阿耨多罗三藐三菩提。速疾得成。迦叶。若使三千大千世界。满中七宝持用布施。若于如来今所演说如是等经。趣向菩提正眼之处。推求索之依附依住。是人福聚倍多胜彼。迦叶。菩萨应当如是坚心。亦复不得于是坚心。然不休息。云何初业多殖初业。云何多殖。不谓一心能知多业。何以故。是法不可以言说故。恒于是中多种初业。所谓坚心。尔时世尊而说颂曰

  非心作心相　　常有大怖畏
  我当成不成　　是事当云何
  是常起疑觉　　住在于一切
  修造作方便　　云何得菩提
  彼是懈怠想　　非是菩提想
  斯有一切疑　　若佛及声闻
  悕望而不及　　善贤诸佛法
  不以音声故　　能获值安乐
  斯有信欲乐　　能集极胜妙
  非但小思惟　　能获得胜道
  于一切法中　　当住于一法
  觉智增益已　　修行为得道

迦叶。说是法时。若有菩萨成就此行不值于佛。而自说言。我当作佛如来应供正遍觉。迦叶。在家菩萨应如是作。云何修行能得菩提。迦叶。在家菩萨有三种业求于菩提。何等三。生极欲心。于一切智不着本作。应持五戒。具是三分趣于六法。何等六。得于圣法。诸根完具。不盲聋哑。不粗恶色。速得信心不畏深法。闻已速解疾得不退。应当具足如是六法。五障法应当善知。何等五。知于两舌。终不妄语。菩萨之人应见。是悭是菩萨障应当不悭。若着于欲是菩萨障终不作欲。如是五法能作障碍。又复应当作于三法。何等三常恒有于欲出家心。于净持戒沙门婆罗门所。殷重恭敬从受教诲。诸有着相演说法者应常远离。何以故。是菩萨所不应学故。菩萨不应担不实草。何以故。是非菩提故。若担不实是学障碍。不学集法。复次迦叶。菩萨当学于三法。何等三。心常专念趣向作佛。应当精勤修习读诵。常于众生修行慈心。应当修集如是三法。又复应当亲近三法。何等三。离搏捶打。不说他人云是卑贱。怖畏众生而为作救。应当亲近如是三法。而说偈言

  不亲近下人　　见不正直者
  见已当远离　　犹远恶毒蛇
  不应学于彼　　亦不礼敬是
  应当极远离　　犹如见恶狗
  是人堕恶道　　诸有着相者
  若修是学者　　此亦同彼去
  不疑于空法　　闻于佛法已
  及乐空比丘　　此所生恭敬
  是中增多闻　　亦生利智慧
  得近菩提道　　为一切所礼
  速疾受斋戒　　速受已读诵
  斯增益智慧　　犹水青莲华
  速疾受斋戒　　多听受于法
  斯增益智慧　　以断诸漏结
  大智大精进　　大威德无畏
  作利以益己　　及利益于他
  终不打搏他　　应当乐如是
  进助菩提分　　是人法无减
  是人少病患　　有最上妙色
  为众生所爱　　爱利益已法
  修行于慈心　　住在家菩萨
  舍一切恶道　　速疾得生天
  是得天名已　　五欲自娱乐
  从天命终已　　终不生恶道
  生在人道中　　种族豪贵家
  形色极殊妙　　无有能欺者
  无能所守护　　是人修行法
  得见于胜处　　一切众生爱
  善得安隐眠　　寤已欢喜乐
  终不生怖畏　　是亦天所护
  犹如粪秽法　　彼有是观相
  居家亦如是　　广及余亦尔
  当为诸善人　　所称誉赞叹
  怖者施无畏　　诸在家菩萨
  更不事余天　　亦不见余天
  此道极正直　　诸慧者所集
  是以此善根　　舍一切恶道
  一切智三明　　善学三戒故
  如所作功德　　如其所礼事
  斯亦当见礼　　诸众生独故
  如所作功德　　如其所礼事
  当为众生上　　如佛见礼事
  住于在家地　　起作菩提心
  此所称赞法　　及余法今听

迦叶。在家菩萨应成三法。何等三。应当远离悕望吉祥。是菩萨应修治舍宅。除诸妨碍。勤修多闻。菩萨当具足三法。复起三法。何等三。不应断绝说法师辩。应当勤请于说法。者应当常然灯烛众明。应当修行如是三法。复次迦叶。在家菩萨。应当终竟不造三法作女人行。何等三。不留难母令不听法。不留难母不往比丘所。不遮固妻至比丘所。欲听法者不作障碍。于女人所不舍正道而犯非道。如是三法一切不作。若造此业便堕女人。而说颂曰

  应当然灯明　　数数以信心
  得无尘垢眼　　及获得佛眼
  导师以此眼　　能知于一切
  若知如此智　　则知于实智
  知过去世法　　现在亦如是
  不意想未来　　不造作三相
  若有是三相　　三亦应当舍
  悉同为一义　　相即为非相
  佛所说诸根　　然法无有根
  以彼不分别　　菩提最为上
  净修佛眼已　　悉皆现了知
  是句即菩提　　如上之所说
  如是所说法　　亦不毁坏法
  一切法是空　　是故名为说
  诸外道邪见　　为在家说法
  如作于明灯　　有眼者能知
  不断他说法　　于释师子法
  莫速至恶道　　疾作生盲者
  数数而劝请　　演说善逝法
  以此之善根　　转无上法轮
  不应作留难　　若母欲听法
  作极恶女人　　盲偻极丑恶
  不见睹众色　　亦不闻妙声
  在于黑闇处　　犹若如蛇住
  作于障碍已　　贪嫉为妻故
  速疾命终已　　作弊恶女人
  黄头而青眼　　黑恶难可看
  疽恶脚缭戾　　聋騃无所知
  于如是等处　　无慈者速受
  为嫉妒男子　　数数造欲因

复次迦叶。在家菩萨不应作三法。何等三。不请女人为欲因缘。施苏醍醐及诸恶施。若欲出家不作留难。未出家者劝令出家。造如来塔作营事人劝助示导。不应侵夺取于是物。如是三法。在家菩萨所不应作。而说颂曰

  不施他女人　　不造作非法
  无婚过难来　　故一切不施
  有言者往彼　　合掌而作礼
  与已复当与　　以善欢喜心
  若彼僧中少　　为僧给使人
  若有请取是　　应佐少人者
  勿触水令浊　　若有依此者
  于斯无嫌害　　生心起嗔恶
  若有欲出家　　自子及亲属
  菩萨于是中　　终不作留难
  令诸众生乐　　得证于灭度
  此是我本欲　　说于无上法
  知是诸过已　　自不造诸妒
  莫长夜常忧　　为烦恼所染

迦叶在家菩萨复有三法。不应修集何等三。不买男子。不买女人。不施毒药。若有作者亦勿亲近而说颂曰

  离买男子业　　亦离买女人
  不施与毒药　　若与者远离
  天亦呵是法　　众生得苦恼
  随趣诸方面　　忧恼箭所害
  此长夜忧恼　　多获众苦恼
  亦绝便命终　　是故不应作
  是过及余过　　我知是所作
  今说其少分　　为于菩提故

迦叶。在家菩萨不应造三法。何等三。不至淫女家。若男若女不犯非道。若屠牛处不在边住。如是三法。在家菩萨所不应作。而说颂曰

  不至淫女家　　秽恶为欲者
  速致不恭敬　　由近下欲故
  师见去至此　　为彼之所轻
  速疾致疾患　　以是致命终
  若男女非道　　二俱不亲近
  是女所不喜　　云何当犯是
  若有屠牛处　　一切不往彼
  此非我所宜　　菩萨法如是
  如是诸过患　　佛悉皆知之
  是故不正行　　今为如实说
  佛如是少说　　我声闻能知
  斯于佛面前　　云何所后虚
  众生信圣者　　欲疾至涅槃
  为是故我说　　不为难教者

复次迦叶。在家菩萨应成就三法。何等三。居住家中犹如客使不起我想。若已施者起集聚想。其未施者远离于我千由旬想。不为子息作于藏举宝藏之想。迦叶。在家菩萨应当成就如是三想。而说颂曰

  当修习死想　　我不久命终
  是故诸所藏　　此财应修坚
  为别男女事　　终不为利是
  速疾求坚法　　身命及财物
  殷重欲菩提　　所作不轻躁
  为求法利故　　一切时摧伏
  犹如小女戏　　亦如光渐现
  不乐着于味　　欲法者如是
  读诵不休息　　善好法庄严
  其难可修集　　于种种诸众
  如是相似法　　迦叶我已说
  其有聪利者　　我悉知是人
  彼知已解了　　自怜愍于己
  是人于彼时　　数数与我对

复次迦叶在家菩萨成就三法。不退阿耨多罗三藐三菩提。何等三。父母不信化令住信。父母毁戒劝令住戒。父母悭贪劝令住舍。叹无上道在大众中而演说法。是名初法在家菩萨不退无上正真之道。复次迦叶。在家菩萨应当善知可供养者及不可供。若知是已。诸可供者而设供食。不可供者而不设供。于是人所应修慈心。迦叶。是名第二法在家菩萨不退无上正真之道。复次迦叶。在家菩萨所有财物勤苦集聚。是不应失不令尽失。不施于他。坚藏牢举施住净戒沙门婆罗门。平等封邑财封无系一切净行。迦叶。是名第三法在家菩萨不退无上正真之道。而说颂曰

  若在家菩萨　　集无上菩提
  生起三种慧　　以学无上道
  若父及与母　　恶慧无有信
  劝之令生信　　令趣向胜法
  悭犯住戒舍　　无慧者信慧
  向无上菩提　　劝令至是处
  若去至四方　　求善说法者
  应行于法施　　以增益智慧
  犯戒教住戒　　无信者教信
  无慧者教慧　　是人终不退
  若见慧比丘　　持戒多闻者
  恭敬信近之　　数数而咨问
  所以近比丘　　数数为咨问
  速疾受其法　　是故不退转
  彼觉智增益　　闻处及智者
  觉智增益已　　舍己肉供养
  是有信解相　　如我之所说
  不以不信心　　能趣向菩提
  渐渐见增益　　速疾得增长
  于是诸增益　　彼得不为难
  知是增益已　　若自及与他
  心喜而趣向　　是人增益智
  随所有财封　　本所聚集者
  诸有持戒人　　一切以置前
  是无有异语　　终不说异言
  健勇进坚施　　是能成如来
  柔和易共住　　勇健者得慈
  欢喜而坚舍　　如先后亦然
  勇健上施主　　不从他所求
  众施中最健　　一切无不舍
  若金银及钱　　本生亦曾施
  悕望于上法　　甚深最上句
  一切天及世　　相应专供养
  若求于法者　　悉应供是人
  勇健者集法　　以法而活命
  有智慧胜法　　当为救世者

复次迦叶。在家菩萨有三法。发阿耨多罗三藐三菩提已。疾堕声闻而般涅槃。何等三。若暂一发菩提心已。怖畏地狱饿鬼畜生。于是菩提道起重担想求诸善根。不专思念不好善求。是人为于心意所害生起苦想。迦叶。是名初法在家菩萨退无上道疾堕声闻而般涅槃。复次迦叶。在家菩萨。若暂一发菩提心已。若行施时嗔恚而与。与已生悔。是人不能至于佛智。迦叶。是为二法在家菩萨退菩提心疾堕声闻而般涅槃。复次迦叶。在家菩萨。若暂一发菩提心已。不勤精进集于多闻。是人以是少许善根速入涅槃。迦叶。是名三法在家菩萨退菩提心。而说颂曰

  发菩提心已　　而不修正行
  毁坏于佛乘　　堕在声闻乘
  菩提非不信　　及懈怠者得
  悭贪无智慧　　是等作障碍
  知恩住净戒　　心常乐行舍
  舍时心欢喜　　菩提不难得
  心造作诸恶　　心亦能行施
  是众生心坚　　当作世间塔
  若不舍是法　　心趣向菩提
  当作佛出世　　为世作福田

迦叶在家菩萨有三法退菩提心。堕缘觉涅槃而般涅槃。何等三。是在家菩萨。一发心已吝惜秘法。迦叶是名在家菩萨初法退菩提心堕缘觉涅槃而般涅槃。复次迦叶。在家菩萨一发心已。悕望良时求觅吉日。迦叶。是名在家菩萨二法退菩提心。堕缘觉涅槃而般涅槃。复次迦叶。在家菩萨懈怠懒惰。不勤求助菩提之法。迦叶。是名在家菩萨三法退菩提心。堕缘觉涅槃而般涅槃。而说颂曰

  悭吝惜秘法　　不教诲他人
  当堕缘觉地　　是退失菩提
  是退堕于三　　失利有苦来
  去已而现在　　是疑于菩提
  思惟大乘已　　速悕望吉祥
  此非信解相　　佛不亲近是
  若有极专心　　坚求菩提道
  此不礼事余　　唯除世间塔
  若有是信心　　不得其余天
  是成就最上　　名为天中天
  生菩提心已　　是不礼事余
  是有最上色　　在在所生处

迦叶。在家菩萨有三法得身极黑。何等三法。断佛塔中所然灯明。他有斗诤生嗔恚心。不豫己事代他诤讼。见黑色人而形呰之。迦叶。是名在家菩萨三法其身极黑。而说颂曰

  塔中然灯明　　断取是光明
  其身极甚黑　　犹如黑漆盘
  见黑人形呰　　我白汝极黑
  是轻毁他已　　受身黑如炭
  善守护口业　　作业终不失
  随如所作业　　当有如是器

迦叶。在家菩萨。有三法生工巧家。何等三。迦叶。在家菩萨自受五戒。若有知识从远而来与酒令饮。或请余人饮之以酒。迦叶。是名在家菩萨初法生工巧家。复次迦叶。在家菩萨自持净行。和合他人令行欲秽。以此业故生工巧家。迦叶。是名在家菩萨二法生工巧家。复次迦叶。在家菩萨。若见他人营造法事勤读诵者。然是人者欲造天舍。而是菩萨语此人言。汝舍读诵营造所作作已还读。以是业故生工巧家。而说颂曰

  以酒请他人　　及与己知识
  以酒为上供　　是业堕工巧
  不能作刀针　　及诸工巧事
  唯能坐地已　　手执捉排囊
  自己舍女人　　向他赞淫欲
  以是业报故　　生堕工巧家
  不能作刀针　　不知鼓排囊
  教令执捉椎　　以锻于钉铁
  以此障碍法　　令他舍法故
  堕在工巧家　　此人生是家
  彼不见排囊　　亦不见椎钳
  悉破坏众器　　其业报如是
  迦叶护口业　　亦护慎心业
  一切不善法　　不向他人说
  生死受众苦　　生已增长爱
  是故勤行法　　舍诸不善法

迦叶。在家菩萨成就三法。生在王家颜色姝特端正可爱。鲜净红白而不懒惰聪黠明了。何等三。迦叶。在家菩萨。睹未曾见沙门婆罗门。若其见已生信敬心。此是福田。此应供养此应礼敬。此是福田生信敬已。请与衣服饮食卧具及诸病药。迦叶。是名初法在家菩萨生在王家。复次迦叶。在家菩萨坚住本誓。住本誓时如说而住。终不妄语。迦叶。是名二法在家菩萨生在王家。复次迦叶。在家菩萨于住净戒沙门婆罗门所。亲近咨受修于坚法。迦叶。是名在家菩萨三法生大王家。而说颂曰

  慧者见已知　　净戒多闻者
  是起如是心　　往彼请命之
  彼既请命已　　如实而施作
  是不为涅槃　　所施无所害
  是取于坚法　　如所亲近者
  种种智增益　　速疾获难得
  如斯之信心　　趣向菩提者
  得菩提不难　　如智者行处
  最上活命已　　舍最上财封
  集聚上妙法　　证于最上灭
  是人生上族　　是有上妙色
  服上妙衣服　　获最上涅槃
  知于如是法　　有智聪慧人
  修行无怯弱　　如佛之所说
  志趣向胜乘　　是人到胜乘
  灭一切结使　　如彼最上果
  如所造作业　　果报亦如是
  终始不败亡　　经百千亿劫

迦叶。在家菩萨。住在家地成就三法。种是善根。终不受于五欲之乐。乃至得于无上正道。迦叶。是在家菩萨受持五戒。不向他人赞五欲乐。不诱引女人勤修自业。起如是心我今不当亲近女人。此终不欲五欲之乐。乃至得成无上正道。迦叶。是名在家菩萨初法。终不受于五欲之乐。乃至得成无上正道。复次迦叶。在家菩萨。若闻是等甚深经典净信修习。迦叶。若是深经至于非器彼应劝进。迦叶。若善男子。能令他人舍离疑心。而是菩萨以此善根。得无碍辩得不系辩。生及命终速得见佛。既命终已得生天上。不久当得阿耨多罗三藐三菩提。迦叶。是名在家菩萨三法。乃至得成无上正道。不受五欲。复次迦叶。在家菩萨所有善根。皆悉回向无上正道。不乐色声香味触法。不乐财封不乐自在不乐眷属。无漏之心无漏果报。速成阿耨多罗三藐三菩提。不受五欲乐。迦叶。是名在家菩萨三法。不贪受于五欲之乐。乃至得成无上正道。而说颂曰

  在家持五戒　　护持善守护
  离亲近女人　　轻毁斯下处
  如是相似法　　修集无漏足
  若有疑惑者　　教令速解了
  一切诸善根　　悉回向菩提
  以此诸善根　　速舍五欲乐
  常有于多闻　　为众生说法
  生起大悲心　　求于菩提道
  是故闻是已　　生贤善妙欲
  终不亲近欲　　速疾转法轮

尔时大迦叶白佛言。世尊。今此经法以何名之。我等当共而奉持之。佛告迦叶。是经名曰演说三戒。亦名曰说菩萨禁戒。亦名曰集一切佛法。佛说此经已。大德摩诃迦叶及诸大众。天人阿修罗乾闼婆。闻佛所说。皆大欢喜

大方广三戒经卷下


大圣文殊师利菩萨佛刹功德庄严经卷上

    No. 319 [Nos. 310(15), 318]

大圣文殊师利菩萨佛刹功德庄严经卷上

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

如是我闻。一时薄伽梵。住王舍城鹫峰山中。与大苾刍众一千人俱。菩萨八万四千。皆于无上正等菩提。得不退转。所谓慈氏菩萨。文殊师利菩萨。观自在菩萨。得大势菩萨。而为上首。复有七十二俱胝诸天众俱。皆悉住于菩萨之乘。复有天帝释。娑诃世界主大梵天王。与其眷属四万天众俱。亦皆住于菩萨之乘

复有四阿苏罗王。所谓毗摩质多罗阿苏罗王。末利阿苏罗王。驴肩阿苏罗王。欢喜阿苏罗王。与百千阿苏罗眷属俱

复有六万二千诸大龙王。所谓难陀龙王。邬波难陀龙王。水天龙王。摩那斯龙王。地持龙王。无热恼龙王。苏迷卢龙王。伏魔龙王。月上龙王。如是等而为上首。复有四大天王。所谓持国天王。增长天王。广目天王。多闻天王。与百千药叉眷属俱。所谓金毗罗大药叉。阿吒嚩俱大药叉。针毛大药叉。妙慧大药叉。形相大药叉。遍形药叉。不动药叉。如是等而为上首

时王舍城国王大臣。及诸四众。天龙药叉人非人等。各以衣服饮食卧具医药种种资具。于如来所恭敬尊重而为奉献

尔时世尊受王请食。于晨朝时着衣持钵。与诸苾刍及于天人百千之众前后围绕。向王舍城未生怨王宫。以佛威神力故。大神境通放百千种妙色光明。百千音乐同时俱奏。雨众妙华。乌钵罗华。钵头摩华。俱勿头华芬陀利华。缤纷而下是时如来以神通力。随按足处涌宝莲华大如车轮。白银为茎黄金为叶。吠琉璃宝以为其须。于华台中有化菩萨结加趺坐。是诸菩萨。与宝莲华俱绕王舍城。右旋七匝而说颂言

  商主利益世间者　　拔济有情为福田
  释雄寂静大威德　　世尊今当入此城
  若有乐求生天众　　解脱生老病死苦
  欲求摧伏魔罗军　　应当供养释师子
  牟尼名号甚难闻　　多俱胝劫行精进
  悲愍世间作利益　　大仙今入此王城
  无量无边劫行施　　饮食衣服及车乘
  所爱男女并妻子　　及舍王位入于城
  能施手足与眼耳　　舍头及鼻诸支分
  由具一切舍功德　　获于殊胜萨婆若
  善学檀那净律仪　　于戒无缺人中胜
  具足忍辱胜功德　　寂静心意今入城
  修习精进俱胝劫　　厌离悲愍观世间
  入于禅定住寂静　　是大梵音今入城
  无量智慧无等伦　　犹若虚空无有际
  善忍功德戒亦然　　如是胜行皆清净
  勤勇摧伏魔罗众　　获不动慧无忧恼
  微妙法轮依教转　　大法自在今入城
  其有乐求我善逝　　三十二相以庄严
  彼菩提心行愿成　　应往亲近而供养
  断欲嗔痴诸烦恼　　乃余觉观恶思欲
  速办无量供养具　　应当亲近于大师
  若人欲求梵天位　　释提桓因大自在
  以妙供具诸天乐　　应当奉献大牟尼
  欲求轮王王四洲　　获得七宝愿成就
  具足千子皆勇猛　　应当供养人中尊
  欲求长者及小王　　获得资财无有尽
  颜貌端严胜眷属　　应速往供于牟尼
  若有修行解脱者　　乐闻殊胜大仙法
  是故汝当速往听　　于此难闻今得闻

尔时王舍大城。及百千村邑聚落。闻此颂警觉已。其中男女童男童女。各赍华香烧香涂香末香华鬘。并金银花幢幡商佉鼓角弦管种种音乐。一心思惟愿佛摄受。踊跃欢喜恭敬供养。于是世尊将入城时。即举右足按城门阃。城中之地六种震动。诸天及人百千音乐不鼓自鸣。雨天妙花。城中有情盲者得视。聋者得闻。狂者得本心。裸者得衣服。饥者得饮食。贫者得资财。当此之时。亦复不为贪欲嗔恚愚痴悭吝嫉妒忿慢之所逼恼。慈心相向犹如父子。彼乐音中而说颂曰

  世尊十力入于城　　是大丈夫释师子
  刹那皆获大安乐　　盲者得视聋得闻
  狂者复心无散乱　　裸露之者获衣服
  所有饥渴得饮食　　贫穷之人获财宝
  无量诸天在虚空　　恭敬礼拜而赞叹
  雨花供养如来月　　鼓角商佉诸乐音
  以佛入城悉皆奏　　其城中地六种动
  见者奇特怀悦意　　贪爱嗔痴而不逼
  悭嫉慢等悉皆除　　慈心相向如父子
  如来十力入城时　　人民安乐悉欢喜
  音乐不鼓皆自鸣　　获得非常极喜悦
  皆以如来威神故　　天人苏罗世间众
  如是多种俱时现　　奇特殊胜不思议
  当于世尊入城时　　广作多人利益事

尔时世尊入王舍城。时有居家菩萨摩诃萨。是豪姓长者之子名摧过咎。于里巷中遥睹世尊。相好奇特端严澄睟。诸根寂静观者无厌。住奢摩他最上调伏。防护诸根如善调象。正念不乱如净泉池。三十二相八十随好。庄严其身。时彼菩萨。见如来色相端严成就。极生尊重净信之心。便往佛所稽首双足。右绕三匝却住一面。时推过咎菩萨摩诃萨。于世尊前合掌恭敬而白佛言。世尊菩萨成就几法。速得阿耨多罗三藐三菩提心。随所悕求。净佛国界严净佛刹

于是世尊。为欲哀愍推过咎故。知化缘将至。于衢路中住。时有无量百千俱胝人众。皆诣佛所稽首佛足合掌而住。于虚空中。复有无量百千诸天。礼敬世尊。时薄伽梵。告推过咎菩萨摩诃萨言。菩萨成就一法。速疾证得无上菩提。随其意乐获净佛刹。云何一法。善男子菩萨摩诃萨。于一切有情起大悲愍。增上意乐应发无上菩提之心。云何增上意乐。善男子增上意乐者。若发菩提心已。不应起少不善法行。云何少不善法行。谓不行贪爱。不行嗔恚不行愚痴。若住居家。威仪不应行调戏行。若出家者。不应求恭敬利养。善住出家所修行法。谓一切法如实通达。云何一切法如实通达。善男子一切法者。谓蕴处界。云何通达五蕴。应观五蕴如幻远离空性无所缘。寂静不生不灭。作如是通达。亦不见通达者。亦无所见无知无思。亦无分别及所分别。一切分别寂灭通达。名为菩萨摩诃萨正行不舍有情。何以故彼自知其法。如是为他有情。演说有情及法皆不可得。善男子由一法成就故。速证无上正等菩提。则能圆满净佛刹土。说此佛刹功德庄严成就法门时。摧过咎菩萨。得无生法忍。欢喜踊跃上升虚空。高七多罗树。于彼众中二千有情发菩提心。一万四千诸天及人。远尘离垢于诸法中得法眼净。于是世尊熙怡微笑。从其面门放青黄赤白红紫等光。照无量无边世界。照已还来绕佛三匝而从顶入。是时具寿阿难陀。即从座起整现衣服。偏袒右肩右膝着地。于世尊前说伽陀曰

  诸法自在到彼岸　　十力导师最胜尊
  一切智者世普闻　　唯愿今说现微笑
  牟尼云何觉过去　　云何未来悉觉悟
  现在云何而觉知　　唯愿演说现微笑
  一切有情之心行　　下中最上之差别
  解脱诸想到彼岸　　唯愿调御说笑因
  亿那庾多诸天来　　礼敬世尊而合掌
  于大众中生渴仰　　唯愿牟尼说妙法

  智到于彼岸　　愆过不可得
  知一切胜行　　何缘而现笑
  如是忆俱胝　　求法诸天众
  无量诸苾刍　　皆来听正法
  供养发愿故　　无量种音声
  一切皆渴仰　　愿佛除疑惑

佛告具寿阿难陀。汝今见此摧过咎菩萨摩诃萨上升虚空。高七多罗树不。阿难陀白佛言。世尊已见修伽陀已见。佛言阿难陀此摧过咎菩萨。却后过于六十二阿僧企耶百千劫。于此三千大千世界离热恼劫中。当得成阿耨多罗三藐三菩提。号寂静调伏音声如来应正等觉。阿难陀彼寂静调伏音声如来。佛刹功德庄严。及以声闻菩萨之众。亦如不动如来妙喜世界。而无异也。是时世尊说是法已从于彼处渐次而往未生怨王宫。到已与苾刍众。各随次第敷座而坐。时未生怨王。知其世尊并苾刍僧坐已。即以种种饮食色香美味。手自斟酌供供世尊及苾刍僧。悉令充足。复以上妙衣服。奉上如来及苾刍众。为佛及僧躬自披擐。披擐已讫为佛作礼。即于佛前。退就一面处于卑座而白佛言。世尊忿恨及覆并诸过咎。及以无知从何而生从何而灭

佛告大王。忿恨及覆并诸过咎。皆从我我所生。我我所者。于无处建立。若不知功德及以过患名为无知。若如实知我我所者。智与非智不能施设。是故大王应如是学。一切有为法。本无来去亦无言说。大王法无来去。无来去法不生不灭。无生灭者则名为智。而是无智亦名为智。何以故诸法入出互不相知。若无所知名之为智

尔时未生怨王白佛言。世尊甚奇甚特。如来应正等觉如是善说。我今宁可闻法中天。不愿不闻寿命长远。是时大王。复诸世尊晡时说法。尔时世尊。即便听许饭食已讫。而收衣钵往灵鹫山。洗足敷座入三摩地。于时世尊为欲说法。于其晡时从三摩地起。时具寿舍利子及诸大声闻皆从定起。时文殊师利童真菩萨。亦从定起与四万天子俱。慈氏菩萨与五千菩萨众俱。师子勇猛雷音菩萨与五百菩萨众俱。皆从定起。领诸眷属前后围绕。诣灵鹫山头面礼佛。各各敷座退坐一面

时未生怨王。与诸眷属前后围绕。往灵鹫山诣如来所。稽首佛足退坐一面。时王舍城。复有无量百千有情。悉皆共往鹫峰山中。至如来所稽首佛足退坐一面

尔时舍利子。以佛威神力故。从座而起。偏袒右肩右膝着地。合掌向佛而白佛言。世尊如来。适于王舍大城四衢路中。已为摧过咎菩萨摩诃萨。略说菩萨摩诃萨圆满佛刹功德庄严。善哉世尊唯愿广说。如诸菩萨行菩萨行。勿令退转无上菩提。获一切智摧伏魔罗。降诸外道净诸烦恼严净佛刹满其愿已。起善巧慧离于佛地。住于声闻及缘觉地。善转法轮修诸波罗蜜。令其获得萨婆若智。现为菩萨与无量无数有情作大利益。于此会中有求菩提。善男子善女人。得亲从佛闻说妙法欢喜踊跃。彼欢喜已如说修行。尔时世尊作是思惟。我今现起如是神通。由此神通现行境界。普遍十方即放多百千光明。一一光明。于多佛刹作那庾多百千光明。照曜于彼诸刹土中。映蔽日月。是其光明映夺眼根。所有诸天龙药叉摩尼电火等光。悉不复现。亦无地狱色相及余有情光明。乃至十方诸世界中轮。围山大轮围山。目真邻陀山大目真邻陀山苏。迷庐山王。及余黑山墙壁树林。以佛光明而照曜。故悉皆透彻

尔时世尊。于斯光已作謦欬声。警觉十方无量世界。是时东方去此世界。过八十四殑伽沙数诸佛刹土。有世界名普遍。彼土有佛。号吉祥积王如来应正等觉。今现住世。彼佛刹中不闻声闻缘觉之名。唯有清净大菩萨众充满其国。一一菩萨各有百俱胝不退转菩萨摩诃萨。前后围绕而为眷属。彼世界中有一菩萨摩诃萨。名为法勇。以何义故名为法勇。彼吉祥积王如来处众说法。法勇菩萨闻说法已。上升虚空高七多罗树。自隐其身为众说法。所谓菩萨藏法门陀罗尼金刚句。时彼众会咸作念言。一切诸法唯有其声。善男子何以故。不见其身而闻其声。出如是声色成就不现。如色声亦尔。如声一切法亦尔。无量菩萨而获得忍。以是义故名为法勇。时法勇菩萨摩诃萨。见大光明闻謦欬声。即时往诣吉祥积王如来所。头面礼足退住一面白佛言。世尊以何因缘。于世间中有大光明。及闻大謦欬声。昔未曾有。时吉祥积王如来告言。善男子西方去此。过八十四殑伽沙数佛刹。有世界名娑诃。佛号释迦牟尼如来应正等觉。今现住世。为欲召集十方世界俱胝那庾多诸菩萨故。而令听法一切毛孔放此光明及謦欬声。法勇菩萨。即白吉祥积王如来言。世尊我今欲往娑诃世界。礼拜瞻睹供养承事释迦牟尼如来应正等觉。兼欲见彼诸菩萨众及听法故。佛言可往今正是时。法勇菩萨即与六十俱胝大菩萨众。前后围绕从彼土没。犹如壮士屈伸臂顷。现此界中。是时法勇菩萨摩诃萨。作是思惟。今我作何神境通故。往彼礼拜亲觐供养释迦牟尼如来。作是念已即入一切庄严三摩地。由是三摩地神境通威力故。令此三千大千世界。满中妙花积至于膝。百千音乐同时俱作宝幢旛盖种种庄严。复以妙香普薰此界。犹如他化自在天宫。是时法勇菩萨现神通已。与诸菩萨诣释迦牟尼如来所。头面礼足右绕三匝。随所来方以愿力故。化现莲花而坐其上

尔时南方去此。过九十六俱胝那庾多佛刹。有世界名离尘。彼现有佛号师子勇猛奋迅如来应正等觉。而为无量大菩萨众恭敬围绕。彼世界中有一菩萨摩诃萨名曰宝手。以何义故名为宝手。谓彼菩萨于诸佛土化有情时。即以右手遍扪若干诸佛世界。即随所欲而能成办。从其手出佛法僧声施戒忍进禅定智慧慈悲喜舍之声。及余种种百千俱胝那庾多法宝之声。以是义故名为宝手

尔时宝手菩萨摩诃萨。见大光明闻謦欬声。昔所未闻昔所未见。即诣师子勇猛奋迅如来所。头面礼足白佛言。世尊以何因缘而有此瑞现大光明。及闻如是大謦欬声。佛言善男子北方去此。过九十六俱胝那庾多佛刹。有此界名娑诃。佛号释迦牟尼如来应正等觉。今现住彼于一切毛孔放大光明。作謦欬声为欲演说佛刹功德庄严。今无数菩萨。各取本愿佛刹庄严故现斯瑞。尔时宝手菩萨。又白师子勇猛奋迅如来言。我今欲往娑诃世界礼拜亲觐供养承事释迦牟尼如来。并见诸菩萨及听法故。佛言何用往彼杂染世界。宝手菩萨白佛言。世尊释迦牟尼如来应正等觉。见何义利取彼杂染世界。而乃不取净佛国土。佛言善男子。彼佛世尊。昔于长夜作如是言。愿我速得成就大悲。常于蔽恶有情之中。成无上正觉转妙法轮。宝手菩萨复白师子勇猛奋迅如来言。世尊彼释迦牟尼如来。乃能往昔发是大悲难发之愿。现于如此恶世界中。如是慈尊甚为难遇。我今当往礼拜亲觐。佛言可往今正是时。然汝诣彼应善谨察无自毁伤彼佛菩萨虽为难遇。其余有情心行险诐难可调伏。宝手菩萨复白佛言。彼土虽有忿恨怨仇无伤于我。假使一切有情尽未来际。于俱胝劫嗔恨骂辱。乃至刀杖瓦石打掷。悉能受之终不加报。时师子勇猛奋迅如来。告一切众菩萨言。诸善男子汝等若能如宝手菩萨被忍辱甲胄者。可与俱往娑诃世界。师子勇猛奋迅如来说是语已。宝手菩萨一心一意与彼会中无量菩萨前后围绕。于彼刹没现此界中。时宝手菩萨即作是念。今我以何神通境界。礼拜释迦牟尼如来。云何安乐无量有情。作是念已即作神通现行境界。而以右手覆此三千大千世界。从于手中雨诸饮食衣服车乘金银琉璃真珠珂贝珊瑚璧玉。随诸有情心所悕愿。悉能充满。乐闻法者即从手中而得闻法。复使无量闻法有情现证真实。亦令无数有情受胜妙乐。是时宝手菩萨摩诃萨。作如是神通境界已。与诸菩萨往诣释迦牟尼如来所。头面礼足。右绕三匝。随所来方以愿力故。化现莲华而坐其上

尔时西方去此。过九十俱胝那庾多百千佛刹。有世界名宝藏。彼土有佛号宝积王如来应正等觉。今现住彼。其佛刹土。清净琉璃之所成就。无有声闻缘觉。唯是清净大菩萨众。去来坐立于琉璃地皆见宝积王如来。分明显现犹如清净明镜睹其面像。诸是菩萨于彼地中见佛世尊。亦复如是见已请法。佛便为说往昔本愿。彼诸菩萨闻法得忍。彼宝积王如来。常于眉间毫相摩尼宝中放大光明。遍照彼刹日月光明。悉皆映蔽不办昼夜。以花开合方办昼夜。时彼宝积王如来刹中。有一菩萨摩诃萨名殊胜愿慧。遇释迦牟尼如来光明照触。闻謦欬声。便诣宝积王如来所。头面礼足退住一面白佛言。世尊以何因缘于世间中。有如是謦欬之声及大光明。佛言善男子东方去此。过九十俱胝那庾多百千佛刹。有世界名娑诃。佛号释迦牟尼如来应正等觉。为欲召集十方世界俱胝那庾多菩萨。令其闻法。遍于毛孔放大光明。作謦欬声。时殊胜愿慧菩萨摩诃萨。闻是语已又白佛言。世尊我今欲往娑诃世界。礼拜亲觐供养承事释迦牟尼如来应正等觉。并见彼诸菩萨及听法故。佛言可往今正是时。尔时殊胜愿慧菩萨摩诃萨。即与诸菩萨。于刹那顷来到娑诃世界。时殊胜愿慧菩萨。即作是念。今我以何神变。往彼亲觐释迦牟尼如来。作是念已入三摩地。由此三摩地神境通故。令此三千大千世界傍生焰魔界苦。悉皆停息。于刹那顷获得无上殊胜安乐。及地狱火悉皆殄灭饿鬼畜生及焰魔界有情。所有饥渴皆获饱满。于刹那间便得安乐。犹如苾刍入初静处。当于是时。无一有情而为贪恚愚痴忿恨恼害悭慢嫉妒矫诳覆藏之所逼恼。一切诸趣有情。互起慈心及利益心。是时殊胜愿慧菩萨。现如是神境通已。与诸菩萨诣释迦牟尼如来所。头面礼足右绕三匝。随所来方以愿力故。化现莲花而坐其上

尔时北方去此。过六万三千佛刹。有世界名常庄严。彼现有佛号生娑罗帝王。彼世界中无有在家衣俗服者。一切菩萨皆服袈裟。而彼世界尚不闻有女人之名况胎生者。一切皆着袈裟之服。结加趺坐莲花化生。彼佛世尊为诸菩萨。常说性印法门。云何名为性印法门。所谓发菩提心。即为满足菩萨律仪。即入菩萨藏陀罗尼根本处。心不散动能行舍故即入空性三摩地。住于正行故即入无相三摩地。无所悕望故即入无愿三摩地。性离贪欲故通达蕴处界。于悕望事而得觉悟。而于佛智正愿无生。乃至通达一切法。于一切法分别无分别。悉皆断除。由于彼等作如是见。是故名为性印法门。于彼会中有一菩萨摩诃萨。名相庄严星宿积王本愿殊胜。若有众生见其身者。必定当得三十二相。时彼菩萨遇佛光明闻謦欬声。便诣生娑罗帝王如来所。顶礼双足右绕三匝。退住一面白言。世尊以何因缘。有大光明及謦欬声。彼佛告言。善男子于此南方。过六万三千佛刹。有世界名娑诃。佛号释迦牟尼如来应正等觉。于一切毛孔放此光明作謦欬声。为欲召集十方无数世界诸大菩萨令听法故。相庄严星宿积王菩萨言。以何因缘名为娑诃世界。佛言彼之世界。能忍贪恚愚痴及诸苦恼。是故名为娑诃世界。相庄严星宿积王菩萨言。彼娑诃世界诸有情等。毁骂捶打皆能忍受耶。佛言。善男子。彼佛世界诸有情等。少能成办如斯功德。而多随顺贪恚愚痴怨恨缠缚。彼菩萨言。若如是者。彼之世界不应名娑诃也。佛言相庄严星宿积王。彼佛刹土亦有行菩萨乘。诸善男子及善女人。已曾供养无量诸佛成就忍辱。将护有情善自调伏。若诸有情以众苦具。而来加害悉能含忍。终不放逸贪恚愚痴。善男子由有如此诸善丈夫。是故彼界名曰娑诃。又彼释迦牟尼如来。世界之中亦有有情具足众恶。少能悔过其心粗犷而无愧耻。不敬佛不重法不爱憎。当堕地狱傍生饿鬼。彼释迦牟尼如来。于此下劣有情之中。悉能忍受骂辱嫌恨诽谤恼乱恶言怨憎心。如大地不可动摇无所违逆。若得供养及以不得心无高下亦无憎爱。是故彼界名为娑诃

尔时相庄严星宿积王菩萨。又白佛言。世尊我等今者得大善利。不生于彼蔽恶下劣有情之中。佛言善男子莫作是说。何以故。东北方有世界名千庄严。彼现有佛号大自在王如来应正等觉。其土有情皆悉具足一向安乐。譬如苾刍入灭尽定。彼之安乐亦复如是。若诸有情于彼佛刹。百俱胝岁修诸梵行。不如于此娑诃世界。一弹指顷于诸有情起慈悲心。所获功德尚多于彼。何况能于一日一夜住清净心。尔时相庄严星宿积王菩萨白佛言。世尊我等欲往娑诃世界。礼拜亲觐供养承事释迦牟尼如来应正等觉并见彼诸菩萨及听法故。佛言可往今正是时。尔时相庄严星宿积王菩萨摩诃萨。与百俱胝菩萨从彼土没。于刹那顷到娑诃世界。即时相庄严星宿积王菩萨。便作是念。今我以何神通之力。供养礼觐释迦牟尼如来。作是念已以自神境通。于虚空中化成宝盖。覆此三千大千世界。百千万亿珠璎宝幡周匝垂布。于其盖中雨种种华。百千音乐不鼓自鸣。复令此会苾刍苾刍尼邬波索迦邬波斯迦天龙药叉健达嚩阿苏罗[卄/(阿-可+辛)/木]路荼紧捺[口*洛]摩呼罗伽人非人等。各自见身具三十二相。现宝盖中。尔时相庄严星宿积王菩萨。作如是神境通已。与诸菩萨诣释迦牟尼如来所。顶礼双足右绕三匝。随所来方以愿力故。化现莲华而坐其上。如是乃至遍于十方。各有无量阿僧祇佛刹中无量阿僧祇百千亿菩萨。见大光明闻声欬声。皆问彼世尊而来此土。头面礼佛各坐一面。亦复如是。又此三千大千世界。天龙药叉健达嚩阿苏罗[卄/(阿-可+辛)/木]路荼紧捺[口*洛]摩呼罗伽。乃至释梵护世及余大威德诸天等。皆见光明闻謦欬声。咸来佛所顶礼双足却坐一面

尔时世尊。作如是神通现行已。十方阿僧祇俱胝无量无边。百千那庾多佛刹。所有菩萨来集会者。皆见此土功德庄严。并佛身量菩萨声闻。及受用具名与自刹悉皆同等。一一诸菩萨。各各知自己身在于其中。尔时慈氏菩萨即从座起。整理衣服。偏袒右肩右膝着地。合掌向佛而说颂言

  无边智慧十方闻　　大光普照人天界
  一切有情共度量　　无有能测于佛智
  十方无量诸菩萨　　为求法故咸来集
  住此悉皆瞻敬佛　　而皆渴仰大牟尼
  如来具戒定慧者　　瑞严无畏如师子
  慧光如日照虚空　　名称普闻诸佛国
  诸天龙神与士女　　并及苾刍苾刍尼
  皆悉合掌而恭敬　　愿佛哀愍为说法
  过现未来可度者　　决定了知是法器
  如来善达诸有情　　唯愿演说除疑惑
  云何修行诸佛子　　获得净刹离尘垢
  云何成就于大愿　　如来为我广宣说
  云何不染于悭吝　　云何不坏于尸罗
  云何陵辱而能度　　毁骂诽谤皆堪忍
  云何勇猛勤精进　　修行无倦俱胝劫
  无量苦恼诸有情　　悉令获得大安乐
  云何专注常等引　　住三摩地清净心
  而能不染于诸境　　犹如莲华不着水
  云何能说甚深法　　通达出世之智慧
  云何降伏魔罗军　　究竟证于无上觉

大圣文殊师利菩萨佛刹功德庄严经卷上大圣文殊师利菩萨佛刹功德庄严经卷中

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时如来。告慈氏菩萨摩诃萨言。汝今为佛严办法座。我当升已。说往昔意乐所修诸行。善巧出生诸佛刹土功德庄严。趣向正行法门。时慈氏菩萨。即作是念。今者世尊以何义故。令我严座。不使阿难陀大目揵连等。云何弃舍彼诸声闻缘觉。将非唯为清净诸菩萨说。或彼声闻缘觉。于此法门而非器故。为菩萨故令我敷座

尔时慈氏菩萨摩诃萨。即作神通现行境界。由此通故化师子座。高四万踰缮那。以无量宝周匝钿饰。以天妙衣而敷其上。其衣柔软而触之者。获得安乐从其座。出种种光明照此三千大千世界。是时如来。从本座起而升此座。三千大千世界。六种振动有异于常

尔时世尊。告具寿舍利子。菩萨成就四法。能令所愿皆得满足。云何为四。一者发趣菩提意乐。二者于诸有情起悲愍心。三者发起精进。四者近善知识菩萨由成就此四法故。圆满大愿。复次舍利子。菩萨成就一法。不退大愿净刹成就。云何一法是菩萨应当学。不动如来为菩萨时。本所修行发弘誓愿言。我当所在生处。若不出家。则为欺诳十方诸佛。世尊。如是舍利子。是诸菩萨应随顺学。若佛出世若不出世。一切生处皆悉决定。舍家趣于非家。何以故而诸菩萨最胜利益者。所谓出家。舍利子菩萨摩诃萨。乐出家者。则能摄取十种功德。云何为十。一者不着诸欲。二者乐阿兰若。三者行佛所行。四者不着妻子贪爱财利。五者离恶趣行法。六者习善趣行法。七者而能获得善根成就。八者积集善根而不退失。九者恒为诸天之所叹美。十者常为非人之所拥护。舍利子乐出家者。则能摄取如是十种功德。是故舍利子菩萨摩诃萨。欲求正觉者欲解脱有情者。是故常乐出家。如是舍利子是名一法获得成就不退大愿。得随意乐清净佛刹。复次舍利子。菩萨成就二法不退大愿。随其意乐净佛刹土。云何为二。所谓菩萨。不乐求声闻。不乐求声闻乘。不爱乐声闻所说法。不乐亲近声闻乘者。不学声闻律仪戒。不乐宣说共声闻乘相应之法。亦不劝他行声闻乘。于缘觉乘亦复如是。唯为劝发有情成就最上阿耨多罗三藐三菩提。是名为二。舍利子。若有劝他趣入佛乘。而此菩萨则能摄取十种功德。云何为十。一者摄取无声闻缘觉佛刹。二者得纯一清净大菩萨众。三者诸佛世尊之所护念。四者常为诸佛称名赞叹而为说法。五者于一切事生广大心。六者若生天上。当作帝释或梵天王。七者若生人中作转轮圣王。八者常见诸佛世尊而不远离。九者为诸天人之所爱乐。十者获得不坏眷属及无量福聚。何以故。舍利子。若有能令三千大千世界诸有情类。一切皆得阿罗汉果或缘觉地。若复有能置一有情于佛菩提。此之功德甚多于彼。何以故舍利子。若声闻缘觉出现于世。则不能令佛种不断。若佛如来不出于世。亦无声闻及以缘觉。舍利子。以佛世尊出现于世。是故能令佛种不断则有声闻缘觉施设。舍利子。由此劝他住菩提心。获得如是十种功德。不退大愿得随意乐清净佛刹。复次舍利子。菩萨成就三法不退大愿。摄取佛刹功德庄严。云何为三。一者尊重住阿兰若。二者无所悕望而行法施。三者安住净戒律仪。舍利子。菩萨安住净戒律仪。即能获得十种无畏。云何为十。一者入聚落无畏。二者众中说法无畏。三者食饮无畏。四者出聚落无畏。五者入寺无畏。六者入僧众无畏。七者安坐无畏。八者诣和尚阿阇梨无畏。九者教诫大众住慈心无畏。十者受用衣服饮食卧具医药资缘之具无畏

舍利子。所谓安住净戒律仪。获得如是十种无畏

又舍利子。菩萨说法心不悕望。复能摄取十种功德。云何为十。一者不为多欲。二者不求他人识知。三者不求名称。四者于施主家心不系着。五者不占悕贵族门徒。六者于粗于细而生知足。七者诸天来诣不生骄慢。八者而不退于观佛作意。九者所说言教为他信受。十者起念佛心。舍利子。菩萨法施心不悕望。获得如是十种功德

又舍利子。菩萨尊敬住阿兰若。复能成就十种功德。云何为十。一者远离无益谈话。二者乐于寂静。三者心缘定境。四者不营诸务。五者爱敬诸佛。六者不舍禅定喜乐。七者修梵行时无有障碍。八者少加功用证三摩地。九者所受教法名句文身未曾忘失。十者所闻法义皆悉了知。舍利子。菩萨尊重住阿兰若。获得如是十种功德。若菩萨成就三法。不退大愿得随所乐净佛刹土

复次舍利子。菩萨成就四法不退大愿。获随所乐净佛刹土。云何为四。一者实语如说修行。二者常自谦下剪除我慢。三者远离悭嫉。四者见他荣盛心生欢喜。如是名为成就四法。又舍利子。菩萨实语有四种功德。云何为四。一者口中常出青莲华香。二者语业清净言辞无碍。三者人天之中以为准绳。四者摄取诸佛圆满音声。舍利子。菩萨实语。获得如是四种功德

又舍利子。菩萨谦下有四种功德。云何为四。一者远离恶趣不受驰驴牛马狗等诸傍生身。二者不被轻毁。三者恶友怨敌不能淩突。四者常为人天恭敬礼拜。舍利子。是为菩萨谦下获得如是四种功德

又舍利子。菩萨远离悭嫉有四种功德。云何为四。一者不忘舍心。二者于饥馑时作大施主。三者常不闭户。四者见律仪者。于施于受不生嫉妒。舍利子。是为菩萨远离悭嫉获得如是四种功德

又舍利子。菩萨见他荣盛心生欢喜。有四种功德。云何为四。一者常起是心。为彼有情被此甲胄。令彼快乐。彼等既以自福及以己力。获得财宝而受安乐。而令于我倍生欢喜。二者所有财物王难水火。劫贼恶友无能侵夺。三者随所生处。财宝男女及其眷属。皆悉具足。帝王欢喜。何况余人。四者财宝广大受用无穷。舍利子。是为菩萨见他荣盛。心生欢喜获得如是四种功德

复次舍利子。菩萨成就五法。不退大愿得随所乐净佛刹土。云何为五。一者菩萨为净佛刹。成就庄严而应求法。从彼闻法应当咨问菩萨云何。成就如是功德庄严。既得闻已如说修行。即应求证真如实相

又舍利子。二者菩萨。欲发愿生净佛国土。应当清净持净律仪。由律仪净故。随其所愿决定得生。既得生于净佛刹已。即应观察彼土取其相状。种种庄严声闻菩萨。大众受用资具既得相已。深生恭敬而为合掌诣佛问法

又舍利子。三者菩萨。取彼广大佛刹功德庄严。彼佛世尊知其增上意乐。即便为说由佛说故。即能成就广大佛刹功德庄严。彼闻法已如说修行

又舍利子。四者菩萨。于事于智而令清净。远离非法。云何事云何智。于能缘所缘远离声闻缘觉智故。名之为智。谓所闻法皆当修行名之为事

又舍利子。五者菩萨。知佛自性知刹土自性。云何佛自性云何刹土自性。佛及刹土唯有其名。知其名清净。如是知故不生执着。如是舍利子。是为菩萨成就五法。不退大愿获随意乐清净佛刹

复次舍利子。菩萨成就六法。速得阿耨多罗三藐三菩提。超越一切世间取净佛刹。云何为六。一者此菩萨为大施主而行舍施。所有爱乐恋着珍玩物等而生愧耻。悉能舍施踊跃欢喜。作是思惟。我行大施圆满大乘。我当满足无上菩提。又作是念。不应以斯少分而能获得无上正觉。如是思惟已。所有荣盛尽皆舍施。乃至身命应当舍施。况余财产妻子男女而不施耶。何以故。舍利子。萨婆若者。谓何句义。舍利子菩萨摩诃萨。行菩萨行时。于自所有一切皆舍。以是义故。获得菩提名一切智。又舍利子。二者在家菩萨出家菩萨。若安住净戒律仪。设为活命终不毁犯净戒学处所持律仪。要期功德回向一切有情。成阿耨多罗三藐三菩提生大欢喜。我是持戒者。于净戒律仪深生爱乐。昼夜专修梵行安乐。即佛法现前与理相应得实相观。住实相观故得甚深忍。证深忍故即得正见。由正见故则正修行。由住正修行故厌恶三界。由厌三界故便生怖畏。由怖畏故即求出离。由怀出离见故作是念言。我既有如是苦恼。一切有情亦应如是。我应为彼有情荷兹重担。令彼获得究竟安乐。作于如是观察之时即得大悲。既住大悲发大精进。犹如救于头衣之燃不舍精进。即能获得萨婆若智

又舍利子。三者菩萨。应被忍辱甲胄离于憍慢得大忍力。若遇骂辱及捶打时。忍辱成就不生嗔恨。作是思惟。假使有棒如苏迷卢山有人执持。而见捶打尽俱胝劫常见恶骂。而我不应起嗔恨心。何以故。彼诸有情未随佛学。而我欲于佛菩萨学。是故若彼所有打骂。便能增长尔所大悲。我当为彼有情被弘誓甲胄摄取有情令得解脱离于生死入于涅槃。是故我今不应嗔恨。若被如是忍辱甲胄。即能获得十种成就。云何为十。一者族姓成就。二者财产成就。三者眷属成就。四者色相成就。五者舍施成就。六者善友成就。七者得闻正法成就。八者如说修行成就。九者临命终时。得见诸佛承事成就。十者既见佛已生净信心成就。舍利子。是为菩萨十种成就。又舍利子。四者菩萨。发大精进坚固要期。成就善法。被于如是。精进甲胄。作是思惟。为一一有情尽未来际。于生死中次第修行诸精进行而不疲倦。以善要期为一切有情。于尔所劫流转生死。发是精进不舍有情。舍利子。若有菩萨。以十方各如殑伽沙数世界满中七宝。于念念中奉上如来。如是相续尽未来际。若有菩萨。内怀增上意乐住大悲心。以如是心被精进甲胄。而此功德复多于彼。舍利子。菩萨具此精进得十种功德。云何为十。一者离凡愚行。二者摄取佛行。三者于生死中作过患想。四者由此摄取大悲。五者不退住昔本愿。六者少诸疾病。七者不违越三世诸如来故。八者薄淫怒痴。九者随其所闻于名句文皆悉通达。十者修行成就。舍利子。发精进者获得如是十种功德

又舍利子。五者菩萨。忆念诸佛。世尊由此心得专注。观于如来常恒得定静念成就。作是思惟。我应行如来行。若心散动失念。则不能得殊胜之处所谓佛智。是故应当舍离心所摄受一切之物。亦舍一切利养恭敬聚落城邑饮食资生及诸亲友。为欲利益诸有情故不舍有情。乐阿兰若住寂静处。独行无侣如犀一角。住阿兰若寂静处已起大慈心。初遍一方二三四方。乃至十方普遍有情。住于慈心。住已则得名为住禅那者。舍利子。若有菩萨以一切乐具。于殑伽沙劫供养一切殑伽沙诸佛。及苾刍僧并诸眷属。若有出家菩萨求于寂静。往阿兰若而行七步。如此福德甚多于彼。何以故以能速得大菩提故。舍利子。乐于寂静住禅那者。则能获得十种功德。云何为十。一者得念。二者得慧。三者得正修行。四者坚志勇猛。五者得迅疾辩。六者得陀罗尼。七者于生于死而得善巧。八者于戒蕴等处而不动摇。九者诸天奉事。十者于他荣盛而不贪羡。舍利子。乐于寂静住禅那者。获得如是十种功德

又舍利子。六者菩萨。善应了知慧所流出而作是念。慧从何生。谓从净戒律仪处生。而是慧者能令一切白法增长。是故菩萨应学一切世间智慧。工巧咒术医方难作难成悉皆遍学。如是学已。复作是念。而今此慧。不能证入离欲寂灭。亦复不能趣向神通及以正觉。非向沙门。非向婆罗门。非向涅槃。是故我今应更遍求法药工巧。以如是慧令我得彼究竟寂灭。而彼菩萨求诸法本。不见少法能起于法。以不见故住于寂灭。住寂灭故则无热恼。无热恼故了知生死。为于有情而作利益。令诸情灭除众苦。舍利子。是为菩萨成就六法。不退大愿得随意乐净佛刹土

复次舍利子。菩萨成就七法。不退大愿。得随所乐净佛刹土。云何为七。一者自己所有一切皆舍所舍不可得故。二者于戒不缺不思惟戒故。三者忍辱柔和有情不可得故。四者发起精进于身口意不可得。五者成就静虑不住静虑故。六者智慧圆满无分别故。七者随念诸佛远离相故。舍利子菩萨。如是成就七法。不退大愿获得一切净佛刹土种种庄严

复次舍利子。菩萨成就八法。不退大愿得随所乐净佛刹土。云何为八。一者心不嫉妒。二者施庄严具。三者其心广大。四者尊敬法师。五者不行邪命。六者平等惠施。七者不自矜高。八者不轻懱他。舍利子。是为菩萨成就八法。不退大愿得随意乐净佛刹土

复次舍利子。菩萨成就九法。不退大愿得随所乐净佛刹土。云何为九。一者具身律仪。二者具语律仪。三者具意律仪。四者令贪欲衰谢。五者令嗔恚衰谢。六者令愚痴衰谢。七者不行欺诳。八者为坚固善友。九者不轻慢善友。舍利子。菩萨如是成就九法。不退大愿得随意乐净佛刹土

复次舍利子。菩萨成就十法。不退大愿得随意乐净佛刹土。云何为十。一者菩萨执持妙花。诣如来所或窣堵波兴供养时。作是愿言。如此妙花色香殊胜。见者欣悦。我成佛时。令我刹中种种妙花遍布其地。及众宝树周匝庄严。乃至烧香末香涂香。衣服饮食宝盖幢幡。金银琉璃真珠车磲。珊瑚等宝用奉献时。亦应如是回向佛刹功德庄严。菩萨应当住净律仪。若住戒者随心所愿皆得成就

复次舍利子。二者菩萨。观察自受乐时。作是愿言。兼他同受如是之乐。是故菩萨成正觉时。其佛刹中所是有情。悉皆具足一向安乐

复次舍利子。三者菩萨。不于他发不喜悦言辞。常出善巧语言。作如是愿得菩提时。我佛刹中勿令有情闻不悦声。常使得闻悦意之声

复次舍利子。四者菩萨。常劝有情修十善道。所有善根共诸有情。回向萨婆若智得菩提时。我佛刹中悉令成就十善业道

复次舍利子。五者菩萨。随所至方眼所见者。有情男女童男童女。一切皆劝令修无上正等菩提。终不赞扬二乘果故。是故菩萨得菩提时。彼佛刹中所生有情。一切皆悉发于无上菩提之心。远离声闻缘觉之意。获得如是清净刹土。诸菩萨众充满其中

复次舍利子。六者菩萨。于他利养终不遮断。见他得利常生欢喜。是故菩萨得菩提时。彼佛刹中所是有情。受用资具恒无断绝。获得如是大法光明

复次舍利子。七者菩萨。若见苾刍苾刍尼。有犯过者终不发扬。但自安住正法之中。是故菩萨得菩提时。彼佛刹中一切无有过失之声。何以故。以彼大众皆得清净无过失法故

复次舍利子。八者菩萨。乐法求法不生热恼。凡所闻法正住修行。得菩提时彼佛刹中。有情乐法皆无热恼。如所闻法随顺修行

复次舍利子。九者菩萨。以商佉鼓角弦管种种音乐。奉献如来窣堵波时。以此善根回向成就佛刹庄严。是故菩萨得菩提时。彼佛刹中百千音乐不鼓自鸣

复次舍利子。十者菩萨。若见失念有情作是愿言。令得正念。是故菩萨得菩提时。彼佛刹中一切有情得禅悦食。舍利子。如是佛刹具足功德。设使如来辩才。或于一劫或过一劫说不能尽。舍利子。然我今者随诸菩萨之所乐欲。如是略说。令增上意乐者闻已趣向。当获圆满佛刹功德

复次舍利子。菩萨成就三法。速得无上正等菩提。所求佛刹皆得成就。云何三法。一者住不放逸。二者如所闻法起正修行。三者发殊胜大愿

舍利子。若菩萨成就此三法者。速证无上正等菩提。随其所乐净佛刹土皆得圆满

尔时具寿舍利子。白佛言世尊。希有如来善说此法。世尊由住不放逸故。获得一切菩提分法。住正修行故得大菩提以大愿殊胜故成就佛刹

佛告舍利子。如是如是如汝所说。由不放逸故得菩提分法。由住正修行故得大菩提。由发殊胜大愿故得净佛刹圆满庄严。舍利子。如我往昔依胜愿故成如是刹。舍利子。我由往不放逸故满其本愿。由正修行故得大菩提。舍利子。若但言说而不修行。尚不能至声闻之地。何况能得无上菩提。是故舍利子。菩萨应当要期真实如说修行。于诸学处应如是学

尔时会中四万菩萨。从座而起合掌向佛。异口同声白言。世尊如佛所说。菩萨学处我当随学。住不放逸成就修行。满其大愿严净佛刹。如是之行我当行之。若诸菩萨随其所愿我当满足

尔时世尊熙怡微笑。时舍利子。白佛言世尊以何因缘现此微笑。佛告舍利子。汝见此诸善男子作师子吼不。舍利子言。唯然已见。佛言舍利子。此诸善男子过百千劫。各于异刹得阿耨多罗三藐三菩提。同号愿庄严。亦如当来师子佛等。其国清净与无量寿如来刹土不增不减。唯除寿量。舍利子言。彼诸如来寿量几何。佛言彼一一佛皆寿十劫

尔时师子勇猛雷音菩萨。即从座起偏袒右肩右膝着地合掌向佛白言。世尊。是文殊师利童真菩萨。诸佛如来常所称赞。是文殊师利。久如当得无上菩提所得佛刹。当复云何

佛告师子勇猛雷音菩萨摩诃萨言。善男子汝当自问文殊师利童真菩萨。师子勇猛雷音菩萨。问文殊师利言。汝于何时当得阿耨多罗三藐三菩提。答言善男子汝何不问我云何住于无上菩提。而乃问我成菩提也。何以故。我于菩提尚犹不住。云何令我证菩提耶。菩提之法不住不证。而我云何有所证住。师子勇猛言。文殊师利。汝岂不为利一切有情证菩提耶。答言不也善男子。何以故。有情不可得故。若有情可得。我当为彼有情证于菩提而住菩提。有情寿命及补特伽罗皆无所有。是故我今不住菩提亦不退转。师子勇猛言。文殊师利。汝岂不住于佛法耶。不也善男子。一切诸法住于佛法。凡所有法无漏无际无相无形。是故佛住于如如。佛所住一切诸法亦复如是。师子勇猛复言。善男子今汝所言。我不住于佛法。我今当问如是之义。应当忍许而为我说。答言善男子于意云何。为色求菩提耶。为色本性。为色如如。为色自性。为色空性。为色远离。为色法性求菩提耶。善男子于意云何。若色是菩提色岂证菩提耶。色本性。色如如。色自性。色空性。色远离。色法性。证菩提耶。答言不也。文殊师利。色不求菩提。菩提无色。本性无色。如如无色。自性无色。空性无色。远离无色。法性无色。而证菩提。乃至广说色法性亦不证菩提

文殊师利言。善男子于意云何。受想行识求菩提耶。善男子。受想行识证菩提耶。乃至识法性证菩提耶。答言不也文殊师利。受想行识不求菩提不证菩提。乃至识法性。不求菩提不证菩提。文殊师利言。善男子于意云何。离于五蕴有我我所施设耶。答言不也。文殊师利言。善男子。云何二法而证菩提。师子勇猛言。文殊师利。初发心菩萨。闻如是语对文殊师利皆生惊怖。以文殊师利此语。便为定量此诸菩萨。而作是言。我不求菩提不证菩提。文殊师利言。善男子。一切诸法无有惊怖。于实际中亦无惊怖。佛为无惊怖者而演说法。若惊怖者彼则生厌。若生厌者彼则离欲。若离欲者彼则解脱。若解脱者则无菩提。若无菩提是则不着。彼若无著是则无去。若无有去是则无来。若无有来则无愿求。若无愿求则无所求。若无所求则不退转。若不退转从何而退从我执退耶。从有情寿命及补特伽罗。若断若常取相分别而生退耶。彼若退转无退转者。云何而退。从空性无相无愿实际及诸佛法退耶。从何佛法而退转耶。谓不离佛法不究竟佛法。无所观无所出入。无所行亦无表示。唯有其名空无生无灭无去无来。远离清净杂染。无尘离尘不平不等。远离作意无尽无执着。无等无非等。是为佛法。善男子。所有佛法此法无法。何以故。其处不可得故。若如是佛法。生者善男子。新发意菩萨。闻此说已心生惊怖。速证菩提。若不惊怖不证菩提。师子勇猛言。文殊师利云何如是密意而说。答言善男子。若惊怖若分别。彼等咸皆证于菩提。如是发心若不发心。为于正觉所求之者。皆证菩提。复次不发心者彼不得菩提。亦不思惟。彼菩提心实无所得。亦不分别。若不分别不证正觉。以何因缘不证正觉。彼不得菩提亦不证菩提。何以故。善男子。虚空界岂证菩提耶。答言不也。文殊师利言。善男子。如来岂不说一切法同虚空耶。答言如是如是。文殊师利言如虚空菩提亦尔。如菩提虚空亦然。虚空菩提无二无别。若菩萨知此平等。则无所知亦无不知。说此法时一万四千苾刍。尽诸有漏心得解脱。十二那庾多苾刍。远尘离垢。于诸法中得法眼净。九万六千有情。昔未曾发无上菩提之心。今皆已发。五万菩萨得无生法忍

尔时师子勇猛雷音菩萨。白文殊师利言。汝发无上菩提心来。为几时耶。文殊师利言止善男子。莫于无生法中而起分别。善男子若有作如是言。我发菩提心我为菩提行。彼等是大邪见者。善男子。我不见彼心为菩提发故。我以心不可见故。是故不为菩提发心。师子勇猛言。文殊师利是何句义。文殊师利言。善男子。若无所见是名平等如向所说。师子勇猛言。文殊师利云何名为平等。善男子。平等者无种种相。由此平等说一切法一味。一味者说一性。说一性者寂静性。则无杂染亦无清净。如是说法不断不常不生不灭。无我无摄受不取不舍。如是说法。说已无所思亦无所分别。善男子于此平等法中。起修行智名为平等。复次善男子。菩萨入于如是法性。不见异不见一名为平等。其平等者离不平等。于不平等中及以平等本来清净

尔时师子勇猛雷音菩萨白佛言世尊。今文殊师利。不肯自说我于无上菩提发心远近。大众皆欲乐闻。佛言善男子。文殊师利是甚深忍者。乃至甚深忍亦不可得。菩提不可得。心亦不可得。以心不可得故。是故不说发心远近。善男子汝应善听。我今当说。文殊师利童真菩萨。久已发于无上菩提之心。善男子过去久远。过七十万阿僧企耶百千殑伽沙劫。彼时有佛。号雷音如来应正等觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。在于东方去此过七十二那庾多佛刹。有世界名无生。彼雷音如来于中说法。诸声闻众有八十四俱胝那庾多。诸菩萨众二倍过前。善男子。彼时有王名曰虚空七宝具足王。四天下正法理化为法轮王。善男子。彼虚空王。于雷音如来会中。八万四千岁以种种乐具衣服饮食宫殿台观。僮仆给侍一一殊妙。恭敬供养承事雷音如来及诸菩萨声闻大众。其王亲族中宫彩女王子大臣唯务供养。余无所作虽经多岁。初无疲倦过八万四千岁。后其王是时独居无侣。作是思惟。我已积集无量善根。我今回向如是善根欲求何愿。为求帝释为梵王耶。为转轮圣王耶。为求声闻缘觉耶。善男子。彼虚空王作是念已。空中诸天告言。大王止止勿起如是下劣之心。何以故。王之所集福聚甚多。大王应发无上菩提之心。善男子。时虚空王闻是语已。欢喜念言我今于此决定不退。何以故。天知我心而来告我。善男子

尔时虚空王即与八十俱胝那庾多百千有情。往诣雷音如来所。顶礼双足右绕七匝退坐一面。又善男子。彼虚空王向雷音如来合掌说伽他曰

  我问最胜法　　唯愿人尊说
  云何得最胜　　丈夫人中尊
  对于世尊前　　我以广供养
  以心无所依　　未曾发回向
  独处生是念　　一缘系此心
  已作广大福　　云何而回向
  为求于释梵　　及以转轮王
  为求于声闻　　并及于缘觉
  心中作是念　　诸天告我言
  若发下劣心　　其福当损坏
  大王发胜愿　　作诸有情利
  为度世间故　　应发菩提心
  我问于遍觉　　诸法自在者
  云何发是心　　成于等正觉
  以何获此处　　为我而显示
  应发菩提念　　等同于牟尼
  从空闻是语　　故白于如来
  大王汝当知　　我今次第说
  诸法属因缘　　乐欲为根本
  如彼所希愿　　获果亦如是
  我昔于过去　　亦曾发此心
  利益诸有情　　发如是胜愿
  由彼胜愿故　　而获殊胜果
  我证大菩提　　满足胜希愿
  大王应勇猛　　当发如是心
  而行此妙行　　汝必成正觉
  从佛闻是语　　其王大欢喜
  而作师子吼　　世间皆振动
  乃至本初际　　及尽生死边
  利益诸有情　　我行无边行
  对于大众前　　我发菩提心
  誓度诸群生　　皆离于众苦
  愿从今已后　　若我有染污
  嗔恚嫉妒心　　并我慢贪爱
  是欺诳十方　　及现在诸佛
  从此而已后　　乃至证菩提
  誓行于梵行　　我舍贪欲罪
  随佛而修学　　净戒柔和忍
  不以匆遽心　　速求成正觉
  我尽未来际　　于一一有情
  净于佛刹土　　无量不思议
  称扬彼名号　　普闻十方国
  我今自授记　　成佛不应疑
  对于导师前　　我净于意业
  及净于身业　　乃至于语业
  悉皆令清净　　不应起不善
  以我真实行　　得佛利世间
  由斯诚实言　　地当六种动
  我若不实语　　四大互迁易
  以言诚实故　　当有诸音乐
  空中而自奏　　以我实无矫
  亦无诸结使　　以斯诚实故
  愿雨天妙花　　由说不妄语
  真实惊觉故　　于十方无量
  俱胝刹振动　　刹那于虚空
  俱胝音乐奏　　雨妙曼陀花
  高七迷卢山　　二十俱胝人
  随彼王而学　　皆出微妙音
  我等当成佛　　如二十俱胝
  一切人亦尔　　学王求正觉

善男子。彼时虚空王者莫作异观。今文殊师利童真菩萨是也。童真菩萨。当彼之时为虚空王。过七十万阿僧企耶百千殑伽沙劫。最初发于菩提之心。又过六十殑伽沙劫。得无生法忍。从此已后满足十地具足十力。亦满一切如来之地。亦满足一切佛法。亦不曾于一念起如是心。我证无上正等菩提。复次善男子。彼时二十俱胝人同与被王。于雷音如来所发菩提心者。皆已证于无上菩提转不退法轮。为阿僧祇有情而作佛事。作佛事已。以佛涅槃而般涅槃。彼等皆是文殊师利之所劝发。于施戒忍进定及慧悉皆次第承事。彼等诸佛所有教法皆悉护持。余有一佛在此下方。过四十殑伽沙佛土。世界名地佛号地天。寿命无量。今现住世有无量声闻之所围绕。说此文殊师利往昔事。时众中七千有情。皆发无上正等大菩提心

大圣文殊师利菩萨佛刹功德庄严经卷中大圣文殊师利菩萨佛刹功德庄严经卷下

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时师子勇猛雷音菩萨。白文殊师利言。仁者已满足如来十力及以十地。一切佛法悉皆圆满。何故不证无上菩提。文殊师利言。善男子岂有圆满诸佛法已更证菩提何以故。已圆满故更何所证。师子勇猛复言文殊师利。云何圆满诸佛法耶。答言真如圆满。由真如圆满。故一切佛法圆满。由一切佛法圆满。故虚空圆满。虚空真如。一切佛法无二无别。复次善男子。如汝所言佛法圆满。佛法圆满者。色圆满受想行识圆满。佛法圆满。亦复如是。师子勇猛言。文殊师利云何色圆满。云何受想行识圆满。文殊师利言。善男子汝所见色是常耶。为无常耶。答言不也。文殊师利言。善男子若法不增不减是名圆满。以何因缘知法圆满。转如是智则生分别智。若不转则不分别。亦无所分别亦不增不减。若不增不减则名平等。是故善男子。若见色平等者则是色圆满。若见受想行识平等者则是受想行识圆满

尔时师子勇猛雷音菩萨。白文殊师利言。汝久已得甚深忍。而不起心作如是解。我证菩提。今文殊师利岂不欲觉悟有情而劝发耶。答言善男子。我不曾觉悟有情及以劝发。何以故。有情无所有故。有情远离故。有情无所得故。若菩提可得是则觉悟有情而有劝发。善男子我及菩提有情俱不可得。是故我觉悟有情劝发平等。不令求于无上菩提亦不退转。何以故无所分别。性平等故。了知于行无来无去。名为平等亦名空性句。空性句者则无所求。善男子若如是者。云何言久而获得忍。既无所得。我岂有心证菩提耶。善男子汝见心与智得耶。答言不也。文殊师利言。其心非色无名。乃至菩提以名施设。是菩提及心亦不空名亦不空。师子勇猛言。善男子。莫作如是密意而说。文殊师利言。心无所生我云何得菩提耶。心既不生。云何为现证耶。师子勇猛言。云何名现证。文殊师利言。善男子。随觉一切法思惟平等名为现证。作是随觉无少起想亦不灭想名为现证。如是真如非真如不起分别。名为现证。若住正见于法平等。无所得故。以无所得。不作一不作异不思一不思异名为现证。若于身证一相知一切法。所谓无相。若知一切法无相者。不于身心而有染著名现证得。云何名得。文殊师利言善男子。无所行句是名为得。无所行者不于三界中行三界。言说所不能说。何以故。正法无阿赖耶。亦无所行。故不能言说

复次善男子。无声言说亦无法可得。以无所得是故名得

尔时师子勇猛雷音菩萨。白佛言世尊。善哉愿说文殊师利童真菩萨所得佛刹。佛言善男子。汝当自问文殊师利童真菩萨。时师子勇猛雷音菩萨摩诃萨。白文殊师利言。云何是仁者佛刹庄严。答言善男子。若乐菩提者汝可当问。师子勇猛言。汝岂不乐菩提耶。文殊师利言。不也。善男子。若有乐求则有厌离。若有厌离则有贪爱。若有贪爱则无出离。善男子我为是故。而不忻乐亦无厌离

复次善男子。汝言云何成就佛刹庄严。我不能自赞。何以故。对于如来一切智前。说自佛刹功德庄严。即为菩萨自赞已德

佛告文殊师利。汝可当说自愿佛刹功德庄严。何以故。令诸菩萨从汝闻已。决定成满此之愿故。文殊师利言。我不敢违于如来教命。承佛威力我今说之

尔时文殊师利童真菩萨。从座而起偏袒右肩。右膝着地向佛作礼。而白佛言世尊。我今当说若有求菩提善男子善女人。应当谛听若得闻已。令其满足真实之行由。文殊师利右膝着地之时。于刹那间十方大地殑伽沙数诸佛世界六种震动。文殊师利白佛言。我愿若不于无量俱胝那庾多百千劫积集菩提。我终不证无上正觉。世尊。我以无碍天眼。见于十方乃至无量无边世界所有诸佛。世尊若非是我劝发无上菩提之心。修菩提行劝学施戒忍进禅慧。令彼成就六波罗蜜。我既劝已教授教诫。悉令满足无上正觉。世尊彼时我以无碍天眼。观察十方作佛事已。然后我证无上菩提

尔时众中或有菩萨作是念言。云何文殊师利童真菩萨。见如是等诸佛世尊。是时如来知诸菩萨作是思惟。告师子勇猛雷音菩萨言。善男子譬如有一丈夫。以此三千大千世界。碎如微尘于意云何。彼微尘若算师。算师弟子。算知其数是百是千是俱胝那庾多百千不。不也世尊。佛言善男子。如是文殊师利童真菩萨。以无碍天眼观察十方。一一世界见于如是无量无数诸佛世尊。尔时文殊师利又白佛言。世尊我有如是愿。以殑伽沙数广大世界成一佛刹。其佛刹中墙壁高大。至于有顶无量百千众宝庄严。复以无量妙宝间错钿饰。若不尔者我终不证无上菩提

复次世尊我复有愿。令我刹中菩提之树。其量正等万大千界。彼树光明遍照一切诸佛刹土

复次世尊我复有愿。坐菩提树已。于其中夜成等正觉。乃至般涅槃夜于其中间不起于座。但以化身遍于十方无量无数俱胝那庾多诸佛刹土。为诸有情而演说法

复次世尊我复有愿。今我刹中无有声闻缘觉之名。唯有清净大菩萨众。离一切过及诸惑等。皆是清净梵行之者满此佛刹。其佛刹中无女人名。一切菩萨唯是化生。悉被袈裟结加趺坐。如是菩萨充满其国。唯除如来之所变化。往诣十方为诸有情。随其意乐说三乘法

尔时师子勇猛雷音菩萨。白佛言世尊。文殊师利当来成佛名。字何等。佛言善男子。此文殊师利成佛之时。名为普见。善男子。以何因缘。称彼如来号为普见。善男子。普见如来。普使十方无量阿僧祇俱胝那庾多百千世界中。普令见故名为普见。彼诸有情见彼佛者。决定当得无上菩提。普见如来虽未成佛。若我现在及灭度后。有闻其名亦皆决定。当得阿耨多罗三藐三菩提。唯除已入声闻尼夜摩位及下劣胜解之者

复次文殊师利。白佛言世尊。我复有愿如无量寿如来刹中。以法喜为食。而我刹中菩萨初生起食想时。即便百味饮食盈满于钵。在右手中寻作是念。若未供养十方诸佛。及施贫穷苦恼有情并饿鬼趣于其千岁。乃至不得涕唾食者。若不惠施令其饱足。我终不食于刹那顷。获五神通有大威德。乘空无碍如风不着。即往十方无量无数诸佛刹中。以食供献诸佛世尊并声闻众。及施贫匮苦恼有情并饿鬼趣。令其充满离乎饥渴。即为说法既说法已。于刹那顷还至本土

复次世尊我复有愿。得菩提已于我刹中。若诸菩萨初生之时。所须衣服随其意念。即于手中而出清净沙门所宜衣服。是衣出已便作是念。若不以此宝衣先当供献十方诸佛。而我不应便自受用。才发是念。即时往诣无数世界。以此宝衣奉献诸佛。还复本处然自被擐

复次世尊于我刹中。诸菩萨众所有受用之具。先皆奉献诸佛世尊并声闻众。然自受用。又我刹中远离八难及不善声。愿于我刹中远离众苦。无有毁犯净戒律仪。于色声香味触无不悦意

尔时师子勇猛雷音菩萨。白佛言世尊。而彼世界名号何等。普见如来成佛出现。复在何处。佛言善男子。彼佛世界名如愿圆满积集离尘清净。其佛刹土在此南方娑诃世界亦在其中

复次文殊师利童真菩萨。白佛言我复有愿。于我刹中。积集无量百千众宝无量摩尼互相影现。所有大宝十方刹土之所难得亦未曾见。彼所积集摩尼宝等所有名号。于百千俱胝岁说不能尽。世尊彼世界中菩萨乐见彼刹。而为金者即现于金。乐见银者即现于银。然于见金未曾损减。乐见吠琉璃颇胝迦赤珠玛瑙牟萨罗宝无量诸宝。各随所乐见种种相。并及彼沉水香。多蘖罗香。多摩罗跋香。龙坚香。栴檀香。各随所欲悉皆得见。非彼世界宝相变异。彼佛刹中不假日月星宿摩尼火光之所照见。皆从菩提树。自然出光而作照明。彼诸菩萨意所欲乐。以此光明照彼俱胝那庾多百千世界无有昼夜。以花开合辨其昼夜。随诸菩萨所乐时节即皆应之。亦无寒暑及老病死。若诸菩萨随其所乐欲证菩提。即往余刹于睹史多天。寿尽降生而成正觉。于彼佛刹空中常奏俱胝那庾多百千种乐。虽不现相而闻其声于彼乐中无有贪染相应之声。唯出诸波罗蜜声佛声法声僧声诸菩萨藏法教之声。悉皆得闻。彼中菩萨渴仰于佛随所诸处经行坐立。应念即见普见如来应正等觉坐菩提树。若诸菩萨于法有疑。但见彼佛不待解说。疑网皆断解了法义

尔时会中无量俱胝那庾多百千诸菩萨众。异口同音而说是言。今此世尊名义相称。所谓名号普见如来。若有得闻其名号者。快哉获得殊胜之利。何况得生彼佛刹中。若有得闻如是授记所说法要。及闻文殊师利童真菩萨名号。经于耳者。是则名为面见诸佛说是语已

尔时世尊告诸菩萨言。如是如是如汝所说。善男子。若有受持俱胝那庾多百千如来名号。若复有称文殊师利童真菩萨名者。福多于彼。何况称于普见佛名。何以故。彼俱胝那庾多百千如来。利益有情不及文殊师利。于一劫中所作利益

尔时俱胝那庾多百千。天龙药叉健达嚩阿苏罗蘖路荼紧那罗摩呼罗伽人非人等。同声唱言。那谟文殊师利童真菩萨。那谟普见如来应正等觉。众多天龙说是语已。八十俱胝那庾多百千有情。发无上正等大菩提心。无量有情成熟善根。于无上菩提得不退转。文殊师利复白佛言世尊我复有愿。如我所见十方无量无数俱胝那庾多百千诸佛世尊。而彼诸佛所有佛刹功德庄严行相之类。如是一切皆令置我一佛刹中。唯除而为声闻现化所庄严刹及五浊之世。若我自赞佛刹功德庄严。过尔所殑伽沙劫说不能尽。世尊如我所愿唯佛世尊应正等觉。余不能知。佛言如是如是。文殊师利。如来知见于三世中无有限碍

尔时众中。或有菩萨作如是念。文殊师利所说佛刹功德庄严。与无量寿如来刹土为等不耶。是时世尊如彼菩萨心之所念。即告师子勇猛雷音菩萨言。善男子。譬如丈夫而析一毛。以为百分以一分毛。于大海中取一滴水。善男子彼一毛水多大海水多。师子勇猛白佛言世尊。一毛水少大海水多。佛言善男子。彼丈夫所举一毛端水如无量寿佛刹功德庄严。余大海水如普见如来佛刹功德庄严应如是见

尔时师子勇猛。白佛言世尊。过去现在及以未来。颇有如是佛刹功德庄严已不。佛答言有善男子。东方去此过八十俱胝百千殑伽沙世界。彼有佛刹名愿住高踊。是中有佛号普光常多功德海王如来。今现住彼。佛寿无量无边。复有无量大菩萨众围绕说法。善男子。彼佛刹土功德庄严与普见如来佛刹不增不减。有四菩萨被不退甲胄住如是行。善男子。彼诸菩萨亦当得此普见如来佛刹庄严。师子勇猛言。唯愿说彼菩萨名号及其住处。并说普光常多功德海王如来佛刹。为我示现彼佛菩萨。令诸菩萨取彼佛刹。佛言善男子。汝等谛听我今当说。善男子第一菩萨名光明幢在于东方无忧吉祥如来佛刹

第二菩萨名为智上。在于南方智王如来佛刹

第三菩萨名为寂根。在于西方慧积如来佛刹

第四菩萨名为愿慧。在于北方那罗延如来佛刹

尔时世尊。以神境通现普光常多功德海王如来佛刹。令此大会见彼如来及菩萨众。并其佛刹功德庄严。昔所未见亦未曾闻。不可思议众相成就。彼此世界互得相见。犹观掌中阿摩勒果。彼佛世尊。普光常多功德海王如来身量八万四千踰缮那。金色光明端严照曜如苏迷卢山王。与四万二千踰缮那身量菩萨摩诃萨前后围绕。于无量功德庄严菩萨树下坐师子座。往俱胝那庾多世界。为诸有情而演说法。尔时世尊告诸菩萨言善男子。汝等见彼如来佛刹功德庄严菩萨众不。时诸大众异口同声。白言世尊唯然已见。我等当学此菩萨行。如文殊师利童真菩萨之所修行。我等亦当成就如此庄严佛刹

尔时世尊。熙怡微笑从其面门放种种光。所谓青黄赤白红紫等光。照曜无量无边世界。照已还来绕佛三匝入于佛顶

尔时慈氏菩萨摩诃萨。白佛言世尊。以何因缘现此微笑。佛告慈氏。由现彼佛世界功德庄严。时此大众中八万四千菩萨。见彼佛刹庄严之事。如文殊师利童真佛刹。于彼众中唯有十六正士。而能成就增上意乐。作是愿言如文殊师利国土庄严。愿令我等亦当如是。除十六正士。余无能发如是大愿。乐速疾证无上菩提。所求佛国如无量寿庄严功德。慈氏汝今见不意乐成就菩萨而能作大利益。由增上意乐故发是胜愿。是故得彼佛刹如文殊师利。其诸菩萨少有信心志愿下劣。由羸劣业过六十俱胝那庾多百千劫。然始得满五波罗蜜。尔时光明幢智上寂根愿慧等。四大菩萨从四方来而现于此。各于无量吠琉璃光明楼阁中坐。有俱胝那庾多百千天众围绕。震动诸刹。以种种神通。散俱胝那庾多百千花及奏音乐。是时慈氏菩萨摩诃萨。白佛言世尊。以何因缘于此世界大地震动。四方复有四楼阁现。佛言慈氏是四菩萨。由佛警觉而来亲觐于佛世尊。所言未讫于刹那顷。此四菩萨从楼阁下。往诣佛所头面礼足。绕佛三匝退坐一面。彼菩萨光从四方来普照大众

尔时世尊告诸菩萨言。善男子此四正士住不思议旨趣。汝等于彼正士应发殊胜恭敬之心。当问法要。善男子。汝等当听彼正士愿。彼正士愿者所有菩萨乘。善男子善女人。若有得见彼四菩萨。于无上菩提得不退转。超二十俱胝劫流转生死。具足圆满五波罗蜜。若有女人闻其名者。速得舍离女人之身。是时世尊现彼刹已还摄神力。而彼世界忽然不现

尔时文殊师利。白佛言世尊。一切法如幻。譬如幻师化作幻事。幻而复隐。世尊如是一切法生已复灭。亦无生灭此则平等。世尊若学平等疾证无上正等菩提

尔时智上菩萨。白文殊师利童真菩萨言。云何而证无上菩提。文殊师利言。善男子法无所得亦无所坏。于无无所著于有无所得。智上菩萨言。文殊师利为于有故获于菩提。为于无耶。答言善男子。法本无生。无已有。无今有。无当有。究竟无所得。智上菩萨言文殊师利以何一相而说于法。文殊师利言。善男子云何所说一相法耶。智上菩萨答曰。文殊师利不见蕴及处界。亦非无见亦非有见。于法无分别亦无所分别。又不于法而见积集。亦不于法而见散失。是即名为一相法门

师子勇猛雷音菩萨曰。若于法性不违法性不作种种分别。是凡夫法。是声闻法。是缘觉法。是如来法。入于一相。谓远离相。是即名为一相法门

喜见菩萨曰。若修行真如。而于真如无所思惟。亦不分别此是甚深。是即名为一相法门

无尽辩菩萨曰。诸法皆尽。究竟尽者乃曰无尽。说一切法不可尽者。是即名为一相法门

善思惟菩萨曰。若于思惟入不思惟。彼无所思亦不可得。是即名为一相法门

离尘菩萨曰。若究竟不染。于一切相染无所染。亦不爱不恚不痴。不作一不作异亦非作亦非不作不取不舍。是即名为一相法门

娑蘖罗菩萨曰。若入甚深法难测如大海。而于正法亦不分别。如是住如是说。于自无所思于他无所说。是即名为一相法门

月上童真菩萨曰。若思惟一切有情。平等如月。而亦不思我及有情。如是说者。是即名为一相法门

摧一切忧闇菩萨曰。若遇忧戚而无所忧。而于忧箭亦不疲厌。云何有情起于忧根。所谓于我若有于我住平等者。是即名为一相法门

无所缘菩萨曰。若不缘欲界。不缘色无色界。不缘声闻独觉之法。不缘佛法。如是说者。是即名为一相法门

普见菩萨曰。若说法者应平等说。其平等者所谓空性。不于空性思惟。平等。于平等法亦无所得。如是说者。是即名为一相法门

三轮清净菩萨曰。夫所说法不违三轮。云何为三。于我无所得。于闻不分别。于法无所取。如此名为三轮清净。如是所说者。是即名为一相法门

成就行菩萨曰。若知一切法不着。如是知如是说。亦不说一字。所谓离言说故。若如是说一切法者。是即名为一相法门

深行菩萨曰。若乐瑜伽知一切法则。于诸法而无所见。于彼若说若无说者于法无二。是即名为一相法门

如是无量大威德诸菩萨等。各各以自辩才说一相法。说此一相法门时。七十俱胝菩萨得无生法忍。八万那庾多百千有情发无上正等菩提之心。七千苾刍尽诸有漏心得解脱。九十六那庾多人天得法眼净

尔时师子勇猛雷音菩萨摩诃萨。白佛言世尊。彼普见如来。有几何大菩萨众而为眷属。寿量几何却后几时。文殊师利成等正觉。佛言善男子。如是之义当问文殊师利童真菩萨

尔时师子勇猛雷音菩萨摩诃萨问文殊师利童真菩萨言。汝却后几时当得菩提。文殊师利言善男子。若虚空界而为色相。我乃证于无上菩提。若幻师所幻丈夫证菩提。我乃当证无上菩提。若漏尽阿罗汉证菩提。我乃当证无上菩提。若梦中丈夫若光影若响应。如是变化证菩提。我乃当证无上菩提。若以日光成夜。月光成昼。我乃当证无上菩提

善男子。汝可当问求菩提者。师子勇猛言。文殊师利岂不求菩提耶。答言善男子不也。何以故。文殊师利即是菩提。菩提即是文殊师利。何以故。但有名字名字亦空。文殊师利。乃至菩提名亦远离。无所有空。空者即是菩提

尔时佛告师子勇猛雷音菩萨言。汝颇见闻无量寿如来声闻菩萨诸众会耶。唯然世尊我已见闻。善男子于意云何。答言非是算数思议之所能及。佛言善男子。如摩伽陀国量一婆诃胡麻。取一粒喻无量寿佛国声闻菩萨众会。余况文殊师利童真菩萨得菩提时。菩萨众会应如是知。善男子。如以三千大千世界末为微尘一尘一劫。若比普见如来寿量劫数。百分千分百千俱胝分。乃至算数譬喻所不能及。善男子以算数计校筹量。应知普见如来寿命无量无边。善男子。譬如三千大千世界。析为微尘。或有一丈夫。取一微尘乃至众多微尘。过三千大千世界。乃下一尘。彼之丈夫。如是东行下尽尘数。如是十方一一丈夫。准前下尽彼微尘数。善男子于意云何。彼三千大千世界。是百是千是俱胝那庾多百千。知其量不。答言不也世尊。善男子如是十丈夫。各过三千大千世界。又下微尘。彼一切世界。已下未下尽末为尘。善男子于意云何。岂能算计是百是千是俱胝那庾多百千数不。答言不也世尊。佛言善男子。乃至十方十丈夫。复过三千大千世界。所下微尘及所未下微尘之处。又末为尘。善男子于意云何。岂能算计彼之微尘是百是千是俱胝那庾多百千。乃至仰蘖罗。泯末罗。阿閦婆等。世尊若人闻此算数心则迷乱。彼不可知其数量。佛言善男子。如来悉知彼之微尘是百是千是俱胝那庾多百千。乃至仰蘖罗泯末罗阿閦婆等。善男子。如是如来。悉知复过彼量

尔时慈氏菩萨摩诃萨。白佛言世尊。若有菩萨。求于如是了色之无尽智。宁于无量劫中受泥[黍-禾+利]苦。而是菩萨于如是色大智中终不弃舍。佛言慈氏如是如是如汝所说。岂有于佛无尽大智不起悕望。唯除下劣胜解及懈怠者。说此如来大智之时。一万有情发菩提心

佛告师子勇猛言。善男子如是十方世界微尘。彼十丈夫下微尘数。过如是等微尘数劫。善男子文殊师利童真菩萨。于彼多劫示现行于菩萨之行。何以故。善男子文殊师利不可思议。愿亦不可思议。趣向亦不可思议。证菩提已寿命亦不可思议。菩萨众会亦不可思议

尔时师子勇猛雷音菩萨摩诃萨。白佛言世尊。希有文殊师利发趣甚大。所修行大。所谓文殊师利童真。乃于尔所微尘数劫不生疲倦。文殊师利言。善男子。于意云何。虚空有如是念于昼夜半月月时岁劫百劫千劫俱胝那庾多百千劫不。答言不也文殊师利。何以故。虚空界无分别故。文殊师利言。善男子若如虚空等悟一切法。随悟如是亦不分别无所分别。于彼昼夜半月月时岁等。如先所说无有少想于法起者。善男子如虚空界大火炽然。过无量殑伽沙劫。而虚空界不曾生起。亦不烧坏。何以故。虚空界无自性故。如是善男子。若菩萨知一切法无性亦无热恼疲倦。如虚空不烧不生疲倦及以热恼。而不动摇亦不生不朽不死不迁不起无去无来如是如是。善男子。文殊师利名号亦尔。而不烧坏亦不疲倦亦无热恼亦不动摇不生不朽不死不迁不起无去无来。何以故。名字究竟远离故。说是法时。四大天王释提桓因大梵天王。及余大威德诸天子等。异口同音唱如是言。若诸有情闻此法门获大善利。何况受持读诵。当知不以少善根而能成就。世尊我等于此法门。受持读诵广宣流布。为获持正法故

尔时师子勇猛雷音菩萨。白佛言世尊。善男子善女人。于此法门受持读诵。为他宣说如是法要。佛刹庄严成就发如是心。如文殊师利所得功德。为几许耶。佛言善男子。如来以无障碍眼所见世界。若有菩萨以七宝满此世界。于一一佛奉献供养。乃至尽未来际俱胝劫中舍施。令此菩萨。安住净戒律仪。于一切有情得平等心。若有菩萨于此佛刹功德庄严法门受持读诵。复能发心随文殊师利所学行。于七步功德之聚。比前福聚。百分千分迦罗分百千俱胝分。乃至算数所不能及

尔时文殊师利菩萨。入菩萨平等照曜如幻相三摩地。入已。由文殊师利三摩地故。乃至众会菩萨等。近见十方无量无边诸佛世界。一一佛前皆有文殊师利。说自佛刹功德庄严。众会见已。于文殊师利胜愿三摩地智而生奇特。如文殊师利童真菩萨法王之子。于百千俱胝那庾多愿我等咸见

尔时慈氏菩萨。白佛言世尊。当何名此法门。云何受持。佛告慈氏。今此法门名为诸佛游戏。汝当受持。亦名不思议愿。汝当受持。亦名说佛刹功德庄严。汝当受持。亦名发菩提心令欢喜。汝当奉持

尔时十方无量菩萨众集会者。于佛及法作大供养。雨众天花。头面礼足绕佛三匝。各还本土作是赞言。奇哉世尊奇哉世尊。令我等闻是不思议法。及文殊师利童真菩萨。大师子吼说是法已。殑伽沙数菩萨。于无上菩提得不退转。无量有情成就善根。佛说是经已。文殊师利童真菩萨摩诃萨。师子勇猛雷音菩萨摩诃萨。所有诸大声闻梵释护世。天龙药叉健达嚩阿苏罗蘖路荼紧那罗摩呼罗伽人非人等。皆大欢喜信受奉行

大圣文殊师利菩萨佛刹功德庄严经卷下


得无垢女经(一名论义辩才法门)

    No. 339 [Nos. 310(33), 338]

得无垢女经(一名论义辩才法门)

        元魏婆罗门瞿昙般若流支译

如是我闻。一时婆伽婆。住舍婆提城只陀树林给孤独园。与大比丘众千二百五十人俱。皆是阿罗汉诸漏已尽。无复烦恼。心得自在。善得心解脱。善得慧解脱。人中大龙。应作者作。所作已办。离诸重担。逮得己利。尽诸有结。善得正智心解脱一切。心得自在。到第一彼岸。唯除一人尊者阿难。余者悉是大阿罗汉。诸大菩萨十千人俱皆不退转。唯一生缚其名曰

宝明菩萨。慧聚菩萨。胜藏菩萨。名称意菩萨。辩聚菩萨。观世自在菩萨。得大势菩萨。弥勒菩萨。得无忧菩萨。文殊师利童子菩萨。不迷行菩萨。不迷见菩萨。除恶菩萨。坏一切悲闇菩萨。功德宝华庄严菩萨。金缨光德菩萨。障一切罪菩萨。不坏思惟菩萨。如是等上首十千菩萨俱

尔时尊者舍利弗。尊者大目揵连。尊者摩诃迦叶。尊者须菩提。尊者富楼那弥多罗尼子。尊者离波多。尊者阿泥楼大。尊者阿难陀。此如是等八大声闻。文殊师利童子菩萨。除恶菩萨。宝幢菩萨。不迷见菩萨。障一切罪菩萨。观世自在菩萨。辩聚菩萨。不迷行菩萨。此八菩萨摩诃萨等。并大声闻。于晨朝时。着衣持钵被服袈裟。相与欲入舍婆提城为乞食故。未到彼城。于路中间。共相谓言。我等心住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民得闻圣谛

尊者舍利弗曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民于圣谛中。得无碍慧不破坏慧。彼慧不闇。尊者大目揵连曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民无有魔业。尊者大迦叶曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切妇人。一切丈夫。若男若女。与我饮食。一切皆得无尽福报乃至涅槃。尊者须菩提曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民得阿兰若。尊者富楼那弥多罗尼子曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民皆得三昧。尊者离波多曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切外道。遮罗迦婆离婆罗阇迦尼。揵陀阿只毗迦。婆罗门居士。得不恶见。尊者阿泥楼大曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民得不嫉乐。尊者阿难陀曰。我心安住如色三昧。入舍婆提大城乞食。如是若入舍婆提城。一切人民闻法即解。文殊师利童子曰。我心安住观察如色。如是若入舍婆提城。门户窗壁器庄严具。树叶花果袈裟等中。出空无相无愿等声。出不生声。亦出生声。出无我声。除恶菩萨曰。我心安住观察如色。如是若入舍婆提城。若彼众生有恶业行。应受报者。彼见法故现世轻受。宝幢菩萨曰。我心安住观察如色。如是若入舍婆提城。一切善宝满藏悉开。不迷见菩萨曰。我心安住观察如色。如是若入舍婆提城。何等众生堪任菩提。妇女丈夫若男若女。眼见我者。皆见我身。如佛身色。决定当得阿耨多罗三藐三菩提。障一切罪菩萨曰。我心安住观察如色。如是若入舍婆提城。一切人民五盖不障。观世自在菩萨曰。我心安住观察如色。如是若入舍婆提城。何等众生系缚。执掌欲被杀者皆得解脱。无有怖畏。辩聚菩萨曰。我心安住观察如色。如是若入舍婆提城。一切人民。何等恶心众生。慈心相向递共赞咏。音声语说皆得辩才。不迷行菩萨曰。我心安住观察如色。如是若入舍婆提城。随何众生。眼见我者。一切不退阿耨多罗三藐三菩提。尔时彼大声闻彼诸菩萨。依如是法。如是行说。相与进向舍婆提城。时憍萨罗。波斯匿王有女。名得无垢。已曾亲近无量诸佛。久种善根。供养多佛。解甚深法。得五神通。天眼远见。清净过人。彼诸菩萨彼大声闻。在道语说皆悉遥闻。彼女端正姿媚少双。甚可爱乐。妙色具足。父母意念。一切婇女一切人民皆悉乐见。年始十二。二月八日。弗沙星日意乐出游。以求吉相。父母即听。从婆罗门。有五百人赍持苏酪。华草符[土*瓦]相随而出。为欲解奏。彼婆罗门。见诸菩萨大声闻已。即住念曰。我今见此吉相好人。时彼侍从婆罗门中。有一长老大婆罗门。厥名梵天谓得无垢。作如是言。女今当知。我此所见是不吉相。前有如是诸比丘住。可回入城。见如是相。所作不吉。以此因缘。或解或奏。不吉不成。即于尔时。得无垢女偈对梵天婆罗门曰

  见此无障胜　　能却多人恶
  此见净四谛　　正念信解脱
  二足上福田　　施彼愿生天
  得甘露果报　　施者不得恶
  第一持戒人　　离浊无恶念
  行世间治病　　疗救苦众生
  佛世间最胜　　第一之法主
  此是彼佛子　　无有尘垢染
  此诸大菩萨　　远离何等法
  恶法皆远离　　常谨慎不越
  持戒世间最　　好人见者胜
  作尘许供养　　彼得如法财
  此满足胜相　　此善心净田
  婆罗门得信　　获多福生人

尔时梵天婆罗门。为得无垢女。而说偈言

  莫随痴心言　　斋时观比丘
  如着衣剃发　　求吉不用见
  尊朝不喜汝　　我当必被笑
  不得持斋戒　　愿勿观比丘
  若不观比丘　　则是大善哉

尔时得无垢女。为梵天婆罗门。而说偈言

  非于今朝日　　能救我父母
  非诸亲非财　　亦复非严饰
  此之功德人　　入于有为行
  此人能救我　　亦救我父母
  我于今朝日　　舍身复舍命
  甚爱乐佛法　　不欲世富乐
  更无异归依　　能救护众生
  唯有佛法僧　　三宝能救护

尔时梵天婆罗门。语得无垢女言。汝大不是。汝于昔来。未曾见佛。未曾闻法。未供养僧。汝何处闻。云何信佛。得无垢女作如是言。我生七日。时婆罗门。安置我身。在栴檀殿金宝床上。五百天子。在于我上空中行过。我时得见。时彼五百诸天子中。有一天子。曾见如来种种赞叹。说佛功德。赞叹法僧。我时得闻五百天子。皆共问之。作如是言。君见佛来。佛状云何。云何得知。时彼天子。知我心信。为生五百天子信故。而说偈言

  无垢欲染发　　清净软靡旋
  面犹百叶花　　如夜空满月
  毫色雪颇梨　　眉间甚可喜
  诸眷属中胜　　佛语甚微妙
  人主师子颊　　眼目极殊妙
  齐平四十齿　　众生中心胜
  彼复广长舌　　善净圆满面
  利益善语言　　离恶口两舌
  无有无义语　　佛不毁誉语
  利益诸众生　　无数众生信
  项相犹如贝　　人生臂指长
  譬如象王鼻　　希净斋却入
  阴如象王藏　　亦复如日光
  身毛皆上靡　　鹿[跳-兆+尃]足下平
  离垢恶实语　　一切牟尼王
  已破坏恶见　　恶见悉已灭
  众生亿问难　　正答令欢喜
  远离彼二边　　说于中道法
  随何人闻者　　第一寂灭乐
  直不曲胜语　　一切欢喜爱
  法云普遍覆　　平等雨法雨
  如来既自度　　亦度彼众生
  归救中第一　　观世间相应
  余无量功德　　我不能具说
  彼天子闻已　　心开净信佛

尔时得无垢女。说此偈已。即语梵天婆罗门言。大婆罗门。我生七日。便得闻此佛法功德。从是已来不曾少时有痴覆心。不着诸欲。不着嫉妒。不着贪心。不起盗心。心不思量。亦不忆念。不知爱着。或父或母。或兄或弟。姊妹亲属。不知爱着。严饰之事。不知爱着。王都城邑。聚落身命。不爱着生。大婆罗门。我忆异相。所谓佛相。大婆罗门。我心恒常忆念三种。何等为三。随何方面。如来行处。我问如来。若佛说法。如是一切我悉摄取。不失一字不失一义。不失一语无有一夜。或于一日随在何处。我常见佛非是不见。我常闻法常供养僧。大婆罗门。如是见佛。如是闻法供养众僧。我无厌足

尔时梵天大婆罗门。敕一同伴小婆罗门。作如是言。汝摩那婆。今速还去如得无垢向来所说。悉为大王及王夫人。说如是法。时摩那婆受教而去。如所见闻。悉为大王及王夫人。说如是法

尔时得无垢女。如佛功德为诸人说。如法功德为诸人说。如僧功德为诸人说。时彼五百诸婆罗门。闻已皆发阿耨多罗三藐三菩提心

尔时得无垢女。从舆而下。与诸侍从婆罗门俱。前诣菩萨大声闻所。到已礼拜恭敬尊重。住在尊者舍利弗前。合掌而立。问于尊者舍利弗言。大德舍利弗。一切女人。智慧甚少染欲极多。专行放逸心意狭劣。不念善法多念恶法。善哉大德。唯愿垂哀悲心念我。如应说法。令我长夜得大利益安隐快乐。此语未讫。时憍萨罗。波斯匿王。闻婆罗门摩那婆语。速疾急到。诣大声闻诸菩萨所。见女在坐。于自己女。如大声闻如大菩萨。作如是言。在家甚乐。何故在坐说如是言。我从是来。不为痴覆。不着戏乐。不曾起心。时憍萨罗。波斯匿王。即自为女。而说偈言

  汝端正如天　　姿媚如庄已
  何故起恶见　　说言皆不着
  王国土丰乐　　汝母随汝心
  女何所忆念　　言不着身乐
  一切贵敬汝　　见汝者皆爱
  百功德庄严　　何以不着乐
  女何所见闻　　于乐生忧怖
  好心向我说　　汝有何所愿

尔时得无垢女。即为父王而说偈言

  王不觉家恶　　危脆诸阴中
  有为所止宿　　如妓儿戏场
  毒蛇所居处　　命少时不停
  无有安乐心　　云何得睡眠
  四大如毒蛇　　三有何处乐
  多怨恶斗诤　　到旷野险处
  烦恼怨围绕　　云何得安乐
  何者是戏乐　　云何而着乐
  饮毒云何睡　　敕杀云何喜
  崄岸云何安　　人命亦如是
  如来说譬喻　　有聚如须弥
  尔许颠倒意　　谁信无常劫
  父母兄弟等　　一切贼境界
  善知识儿子　　亲友皆围绕
  犹如镜中像　　一切皆无常
  有何等人辈　　能信此不实
  初见自然智　　即发菩提心
  从发心已来　　未失菩萨行
  何处菩萨行　　贪着世间乐
  我见彼如来　　不思议功德
  闻善逝说法　　见此佛子人
  是故不忆念　　着世五欲乐

尔时憍萨罗国。波斯匿王。既闻女说默然不言。尔时得无垢女。知父默然。即语尊者舍利弗言。大德舍利弗。我欲问难愿慈念我。佛说大德。智慧人中最为第一。大德。何者智慧。彼智慧者。为常无常。若是常者。如佛所说。一切诸法皆悉无常。佛如是说。则是妄说迷惑说法。若是无常。彼法不生。若法不生彼法则无。为何所说。则不忆念说智慧法。以何义故。佛说大德智慧人中最为第一。尊者舍利弗。默然不答。尔时尊者大目犍连。问于尊者舍利弗言。何故默然不答女难。尊者舍利弗言。女不问我无常之法。问不生法。故我不答。尔时得无垢女。问于尊者大目连言。大德目连佛说大德神通人中最为第一。大德为住众生想故。示现神通。为住法想示现神通。若住众生想示现神通者。众生既无。云何大德示现神通。若住法想示现神通。法无分别。大德亦尔无所分别。既无分别。云何大德示现神通。尊者目连。默然不答。尔时尊者。富楼那弥多罗尼子。问于尊者大目连言。何故默然不答女难。尊者目连言。女不问我分别。我无分别。不取不分别如来菩提道。是故我不答

尔时得无垢女。问于尊者富楼那弥多罗尼子言。大德富楼那。佛说大德说法人中最为第一。大德为受持说法。为不受持说法。若受持说法。则与一切愚痴凡夫等无有异。何以故。一切愚痴凡夫受持。大德。如是不离一切愚痴凡夫法。若不受持说法。法既无物。云何大德说法人中最为第一。尊者富楼那弥多罗尼子。默然不答。尔时尊者摩诃迦叶。问于尊者富楼那弥多罗尼子言。何故默然不答女难。尊者富楼那弥多罗尼子言。女不问我世谛之义。问我真谛。故我不答。尔时得无垢女。问于尊者大迦叶言。大德摩诃迦叶。大德入八解脱。入已复出为人说法。于何人边乃至微少受一瓢食。彼诸施者。皆得生天。彼于大德。云何而施。为身净施。为心净施。为身心净施。若身净施身则无知无觉不动。如草如木如壁如土。彼身如是不能净施。若心净施心则如幻不暂时住不能净施。若彼身心内外俱净。如是身心不得净施。身心无物云何净施。尊者大迦叶。默然不答。尔时尊者须菩提。问于尊者大迦叶言。何故默然不答女难。尊者大迦叶言。女不问我取法。问我不取法。是故我不答。女问我实际。是故我不答

尔时得无垢女。问于尊者须菩提言。大德须菩提。佛说大德阿兰若行最为第一。大德阿兰若者。为有物修。为有法修。若有物修则是无常。若有法修法无生相。法无灭相。法若不生不灭相者。彼则平等。彼若平等则非平等。彼若真如则非真如不动不转。若不动转彼不得说。若不得说彼不思议。若不思议彼不可说。若不可说彼则无物。若无物者彼则无实。若无实者圣人不说。尊者须菩提。默然不答。尔时尊者离波多。问于尊者须菩提言。何故默然不答女难。尊者须菩提言。乃至无有少法可说。默然为乐。女问如是不戏论法。诸有言说皆是不善。不言说界是阿兰若行

尔时得无垢女。问于尊者离波多言。大德离波多。佛说大德坐禅人中最为第一。大德为心依止禅。为心不依止禅。若心依止禅。心则如幻不实分别。若当如是不实。分别则不实。依止禅三昧则不实。若无心念禅。一切死人亦得欢喜。诸草木壁波罗赊树。皆应三昧。何以故。以彼诸物皆无心故。尊者离波多。默然不答。尔时尊者阿泥楼大。问于尊者离波多言。何故默然不答女难。尊者离波多言。得无垢女。问佛境界彼非声闻之所能答。得无垢曰。于意云何。如来法界声闻法界。有别异耶。若异法界则坏法界。若法界坏法界则二。法界不二得言真如。如是真如得言不二。如是真如如是不二。不得言胜。大德何以作如是说。尔时得无垢女。问于尊者阿泥楼大言。大德阿泥楼大。佛说大德天眼人中最为第一。大德天眼为有物见为无物见。若有物见则堕常见。若无物见则堕断见。尊者阿泥楼大。默然不答。尔时尊者阿难陀问于尊者阿泥楼大言。何故默然不答女难。尊者阿泥楼大言。女怀智慧问。是故我不答。尔时得无垢女。问于尊者阿难陀言。大德阿难陀。佛说大德于多闻中最为第一。大德何物得言多闻。为有义知。为究竟知。若有义知义无言语。不可言说。非耳识知。彼非可见。若究竟知。然世尊说当听于义。莫听文字如是不听。大德阿难云何多闻。尊者阿难。默然不答。尔时文殊师利童子。问于尊者阿难陀言。何故默然不答女难。尊者阿难陀言。一切文字性离如响。女问我字故我不答。女问平等无心离心。此义乃非学人境界。云何得说。仁者。当问如来法王

尔时得无垢女。问于童子文殊师利言。文殊师利。佛说仁者善解如来甚深解脱。如是菩萨摩诃萨中最为第一。彼因缘法云何甚深为深故甚深。为自体甚深。若彼因缘深故甚深。则彼因缘。无人和合。何以故。如是因缘。不去不来非眼识见。乃至非是意识所知。不二和合因缘而生。若自体甚深彼甚深体。则非可示。文殊师利言。实际之义甚深甚深。得无垢言。文殊师利以彼实际非实际故如是。彼智则非是智。文殊师利言。无有言语得实际者。得无垢言。文殊师利。若无所得则无言语。出过言语故无所得。文殊师利言。若尔云何为他人语。得无垢言。文殊师利。如来菩提出过言语。彼不可说。文殊师利。默然不言

尔时得无垢女。问不迷见菩萨言。善男子。如不迷见如是说言我心安住观察如色。如是若入舍婆提城。何等众生堪任菩提。妇女丈夫。若男若女。眼见我者皆见我身如佛身色。此事云何。仁者为示如来色身。为示法身。若示色身。彼诸众生不见佛身。若见佛身则违佛语。佛说偈言

  若以色见我　　若以声求我
  彼人行邪道　　则不能见我

若示法身。而佛法身非可示现。何以故。如来法身出过眼识。彼不能见。不迷见菩萨。默然不答。尔时宝幢菩萨。问不迷见菩萨言。何故默然不答女难。不迷见菩萨言。女问我无物。是故我不答。得无垢曰。我非无物问。无物不得问。我说学法应如是知。不迷见菩萨。默然不言

尔时得无垢女。问宝幢菩萨言。善男子。仁如是说。我心安住观察如色。如是若入舍婆提城。一切善宝满藏悉开。此事云何。仁者如是何所忆念。为当有心希望福德。为当无心希望福德。若当有心希望福德。仁者则与愚痴凡夫等无有异。何以故。愚痴凡夫皆有希望爱着心故。若当无心希望福德。是则无心希望积聚。宝幢菩萨。默然不答。

尔时得无垢女。问除恶菩萨言。善男子。仁如是说我心安住观察如色。如是若入舍婆提城。若彼众生有恶业行应受报者。彼见法故。现世轻受。此事云何。如佛所说业不思议。仁说不能违佛所言。若仁不能思议业者。云何得知未来重业。现世轻受。一切诸法皆空无主。仁今云何。言得法王。若仁能令重业作轻则违佛语。除恶菩萨言。我以愿力能令如是重受之业作轻受业。得无垢曰。无有人能愿力回轮。若能转者。一一如来本皆有愿。一切众生。我皆悉令得大涅槃。非愿力成此门。应知如是愿力不能回转。除恶菩萨。默然不言。尔时得无垢女。问障一切罪菩萨言。善男子。仁如是说。我心安住观察如色。如是若入舍婆提城。一切人民五盖不障。此事云何。若仁禅定。能令众生诸盖不障。一切诸法皆空无主。如是仁不是仁我不是我。云何能与他人作恩。障一切罪菩萨言。先修慈心。得无垢言。一切诸佛大慈心行。有佛土中诸众生等。盖缚所恼。障一切罪菩萨。默然不言。尔时得无垢女。问于圣者观世自在菩萨言。善男子。仁如是说。我心安住观察如色。如是若入舍婆提城。随何众生系缚执掌。欲被杀者即得解脱。无有怖畏得无所畏。此事云何。仁为取修。为不取修。若取修者。愚痴人取是则不可。若不取修。则非无常。若非无常则不可取。观世自在菩萨。默然不答。尔时辩聚菩萨。问观世自在菩萨言。何故默然不答女难。观世自在菩萨言。女不问我生法。不问我灭法。问我不生不灭法。是故我不答。得无垢曰。观世自在。仁何不问何处不生不灭。观世自在菩萨言。得无垢女。何处不生不灭。无少字转行。得无垢曰。若不转行。则一切法无有少字。非黠慧人字转行说。不著名字。法界无障碍。故彼心不着。观世自在菩萨默然不言。尔时得无垢女。问辩聚菩萨言。善男子。仁如是说。我心安住。观察如色。如是若入舍婆提城。何等恶心众生。慈心相向递共赞咏。音声语说皆得辩才。此事云何。仁此辩才起。为有因缘起。为无因缘起。若有因缘起。一切无常皆因缘起。若如是者不得寂静。若无因缘起。如是无实则不得言有辩才起。辩聚菩萨言。我从初发菩提心来。常作是愿。若诸众生得见我者皆得辩才。得无垢曰。善男子。仁为有心辩才。为无心辩才。若有心辩才则堕常过。若无心辩才。彼诸言语仁云何说仁不实语。辩聚菩萨。默然不言。尔时得无垢女。问不迷行菩萨言。善男子。仁如是说。我心安住观察如色。如是若入舍婆提城。随何众生。眼见我者。一切不退阿耨多罗三藐三菩提。此事云何。何者菩提。彼菩提者。为有为无。若言有者。仁则着常。不迷行菩萨曰。言菩提者。智者言语说言菩提。得无垢曰。彼智云何。为当生体。为寂静体。若彼生体生皆无常。若皆无常则不正念。若皆无常是正念者。一切痴人皆应正念。若寂静体彼无所得。若无所得彼不分别。此或佛说。或菩萨说。或阿罗汉说。或凡夫说。何以故。菩提道者则无分别。愚痴凡夫则有分别。有分别者非是黠慧。不迷行菩萨。默然不言

尔时。尊者须菩提等诸大声闻。彼诸菩萨。如是说言。我今回还。不须入彼舍婆提城而行乞食。何以故。朝日已得妙好法食。即尔满足。我既从彼得无垢女闻胜妙法。我于朝日得法食足。尔时得无垢女语尊者须菩提言。大德须菩提。不取不舍是声闻法。仁等今者为何所求。何所忆念。大德须菩提。无戏论者是声闻法。若着戏论非声闻法。大德须菩提。无依止者是声闻法。圣人境界非是依止。非依止着不发动摇

尔时彼大声闻彼诸菩萨。及彼五百诸婆罗门。得无垢女。憍萨罗国波斯匿王。并诸侍从无量人众。皆悉往诣只陀树林给孤独园。到世尊所。头面礼足。围绕三匝于一面坐。得无垢女绕佛千匝绕千匝已。右膝着地合掌向佛。以妙声偈问如来曰

  我今问善逝　　无上无等智
  无量无垢名　　三界之尊主
  能以甘露法　　慈爱令人得
  云何菩萨行　　能坐树王下
  破坏魔王军　　成无上菩提
  云何动大地　　乃至动龙宫
  云何放光明　　普照无量处
  说菩提法行　　云何得总持
  云何菩萨行　　而能得佛财
  云何修寂静　　第一三摩提
  云何神通力　　丈夫云何说
  众生中胜行　　得何等意行
  云何得净辩　　同合净美语
  云何诸菩萨　　而得善眷属
  云何大丈夫　　而得宿命智
  得无垢天眼　　天耳他心智
  大神通光明　　行无量世界
  云何念檀舍　　戒净常行忍
  云何精进禅　　云何行般若
  云何常远离　　胎藏生宿处
  更不受胎生　　过化生彼岸
  云何佛前住　　口说无我空
  云何爱不爱　　彼二心平等
  灭一切染恶　　心坚不高下
  世间法不动　　犹如须弥山
  得失及毁誉　　称讥苦乐等
  此世间诸法　　云何过如月
  无主不谄诳　　无染云何慢
  舍离自高心　　无有如是意
  寂静胜寂静　　不舍奢摩他
  第一智慧人　　云何得有缚
  不爱妻子财　　云何而得有
  定爱犹如鸟　　常如月无异
  其心既如是　　云何有法爱
  云何有智人　　如地水火风
  不动云何常　　爱平等如空
  云何不舍法　　常不舍佛法
  宁自舍身命　　不舍第一法
  云何住菩提　　证无尘垢法
  众生中医想　　佛国土庄严
  云何住净僧　　净僧云何有
  三世法云何　　闻有众生乐
  云何爱灭坏　　见四谛罗汉
  云何戒具足　　云何百众生
  令安住菩提　　行有常爱着
  谁能得端正　　何谁有化生
  云何大富乐　　云何大智慧
  一切智道行　　何谁能具足
  得三十二相　　八十种妙好
  一切善福德　　无斯辩才生
  云何有净僧　　比丘受具足
  何处有此愿　　云何百有生
  宿命云何有　　常与佛和合
  于千亿劫中　　不作恶行善
  心不着端正　　云何有医师
  力精进忍辱　　云何而有胜
  云何归依佛　　归依于法僧
  自舍于身命　　不是舍佛法
  云何诸众生　　净行菩提行
  一切悔放舍　　为众生说法
  不是少许痴　　一切知大寂
  若行法众生　　次第得授记

得无垢女。如是说已。世尊即告得无垢言。善哉善哉。得无垢女。汝甚善哉。汝今善能问于如来如是之义。汝今谛听善思念之。我为汝说。得无垢言。善哉世尊。愿乐欲闻。佛即告言。得无垢女。诸菩萨摩诃萨。成就四法能坏魔王。何等为四。一者供养他人心不嫉妒。二者舍离恶语。三者常生多人善根。四者无尽修慈。得无垢女。诸菩萨摩诃萨。若能成就如是四法。能坏魔王。尔时世尊而说偈言

  心莫怀嫉妒　　口勿说恶言
  教多人行善　　不尽修慈心
  菩萨能修行　　如是四种法
  十方破魔王　　证无上菩提

得无垢女。诸菩萨摩诃萨。成就四法。能动无量诸佛世界。何等为四。一者如说而行。二者信甚深法。三者坚固教化。四者能教多人菩提。得无垢女。诸菩萨摩诃萨。若能成就如是四法。能动无量诸佛世界。尔时世尊而说偈言

  能如说而行　　知甚深法忍
  欲得白净法　　坚固教化人
  常为多人说　　无上菩提道
  智人如是法　　能动亿世界

得无垢女。诸菩萨摩诃萨。成就四法。能放光明普照无量诸佛世界。何等为四。一者施佛灯明。二者守护正法。三者能入八难恶众生中而为说法。四者以宝罗网覆如来塔。得无垢女。诸菩萨摩诃萨。若能成就如是四法。能放光明普照无量诸佛世界。尔时世尊而说偈言

  以灯明施佛　　则得净光明
  能守护正法　　如正法受持
  为放逸之人　　说不放逸法
  以妙宝罗网　　覆于如来塔
  如是诸菩萨　　放光照世界
  遍不可思议　　亿世界中行
  此光触众生　　遇者皆得乐
  发心求菩提　　无上大智慧

得无垢女。诸菩萨摩诃萨。成就四法得陀罗尼。何等为四。一者种种布施。二者庄严女人与来求者。三者赞叹如来功德。四者多行般若。得无垢女。诸菩萨摩诃萨。若能成就如是四法得陀罗尼。尔时世尊而说偈言

  修行种种施　　则得陀罗尼
  种种庄严女　　以施来求者
  常赞佛功德　　修行佛般若
  行如是四法　　彼得陀罗尼
  能于百千劫　　闻持而不失
  十方佛说法　　忆念力能取

得无垢女。诸菩萨摩诃萨。成就四法则得三昧。何等为四。一者常说有为多苦。二者乐独无侣。三者发勤精进。四者究竟善业。得无垢女。诸菩萨摩诃萨。若能成就如是四法则得三昧。尔时世尊而说偈言

  说有为多苦　　乐独行如犀
  勤进常有智　　究竟行善业
  行如是四法　　求于菩提行
  得寂静三昧　　速觉佛菩提

得无垢女。诸菩萨摩诃萨。成就四法得神通力。何等为四。一者身轻。二者心轻。三者受持一切佛法。四者四界空界平等受持。得无垢女。诸菩萨摩诃萨。若能成就如是四法得神通力。尔时世尊而说偈言

  身轻如心轻　　法中无依止
  空界我无量　　四界等受持
  思量此四法　　得无量神通
  以此三昧力　　行一切世界
  一念普周遍　　见多千亿佛

得无垢女。诸菩萨摩诃萨。成就四法端正殊特。何等为四。一者不嗔。二者扫如来塔。障恶风雨。作已欢喜。三者戒净具足护持。四者常一切时先意问讯。见诸法器不欲破坏。心如金刚。得无垢女。诸菩萨摩诃萨。若能成就如是四法端正殊特。尔时世尊而说偈言

  于他无嗔垢　　障佛塔风雨
  净扫治庄严　　常恭敬供养
  净戒常护持　　常先意问讯
  尽心于法器　　如金刚须弥

得无垢女。诸菩萨摩诃萨。成就四法。是故化生常在佛所。何等为四。一者作莲华坐如来之像。二者满掬忧钵罗华。拘物头华。分陀利华。或散佛身。或散浮图。三者安乐有多信才。于持戒人。心不破坏一切善根。四者愿与一切众生安乐令得佛道。得无垢女。诸菩萨摩诃萨。若能成就如是四法。是故化生常在佛所。尔时世尊而说偈言

  作胜莲华坐　　如来之形像
  水华满掬施　　为利益他人
  于他不恶说　　不取他恶说
  念十方众生　　愿与安隐乐
  修行如是等　　四种胜功德
  是故得化生　　常在于佛所

得无垢女。诸菩萨摩诃萨。成就四法得大富乐。何等为四。一者平等心施。二者施不望报。三者心开多信。四者能知众生心行。得无垢女。诸菩萨摩诃萨。若能成就如是四法得大富乐。尔时世尊而说偈言

  平等心施与　　所有皆不吝
  深信佛智慧　　数得大富乐
  有信不谄诳　　不取恶他人
  信法正直见　　彼得善富乐

得无垢女。诸菩萨摩诃萨。成就四法得大智慧。何等为四。一者于法不生嫉妒。二者能除他人疑悔。三者如闻而说。四者多修空行。得无垢女。诸菩萨摩诃萨。若能成就如是四法得大智慧。尔时世尊而说偈言

  智人不怀嫉　　能除他疑悔
  如所闻而说　　说如来行空
  行如是四法　　如来所随喜
  如佛教而学　　得佛二足尊

得无垢女。诸菩萨摩诃萨。成就四法得宿命智。何等为四。一者能为久忘法者说应闻法。令得忆念不忘句义。二者令他信欲所谓语说。令他欢喜。为他说法。三者欲令出离有为诸苦入于涅槃。四者知幻三昧与愿相应。得无垢女。诸菩萨摩诃萨。若能成就如是四法。得宿命智。尔时世尊而说偈言

  久读诵忘者　　教示令忆念
  常说乐闻语　　不倦为他说
  令出有为苦　　舍相修三昧
  行如是四法　　得宿命大人
  亿无量千劫　　速成第一医

得无垢女。诸菩萨摩诃萨。成就四法常亲近佛。何等为四。一者乃至失命因缘不舍佛法。二者乃至失命因缘。终不称说法师罪过。三者乃至失命因缘。终不亲近不善知识。四者常修念佛三昧。得无垢女。诸菩萨摩诃萨。若能成就如是四法常亲近佛。尔时世尊而说偈言

  常不舍佛道　　不毁誓法师
  不近恶知识　　常勤心念佛
  行如是四法　　得亲近如来
  在在所生处　　彼处常有佛
  乃至未证得　　无上菩提道
  一切所生处　　常得亲近佛

得无垢女。诸菩萨摩诃萨。成就四法。得三十二大丈夫相。何等为四。一者把金散佛。或散浮图。二者常以香油涂如来塔。三者种种华香伎乐布施。四者眷属相随。供养和上阿阇梨等。得无垢女。诸菩萨摩诃萨。若能成就如是四法。得三十二大丈夫相。尔时世尊而说偈言

  把金散浮图　　香油涂佛塔
  施以香华乐　　敬心供养师
  行如是四法　　得三十二相
  端正甚奇妙　　一切功德具
  此法有妙相　　佛第一智慧

得无垢女。诸菩萨摩诃萨。成就四法得八十好。何等为四。一者种种妙衣庄严法坐。二者供养他人心不生倦。三者于法师所不作斗乱。四者教诸众生佛菩提行。得无垢女。诸菩萨摩诃萨。若能成就如是四法得八十好。尔时世尊而说偈言

  妙衣严法坐　　供养他不倦
  教众生菩提　　易得八十好
  菩萨修行此　　四种功德故
  常于一切时　　有胜相庄严

得无垢女。诸菩萨摩诃萨。成就四法得净辩才。何等为四。一者持菩萨藏。二者昼夜读诵三聚法门。三者为他人说离因缘法。以佛菩提不生不灭离因缘故。四者欢喜受持。不惜身命及以财宝。得无垢女。诸菩萨摩诃萨。若能成就如是四法得净辩才。尔时世尊而说偈言

  昼夜常读诵　　坚持菩萨藏
  诸世间相违　　受持此佛法
  不惜身命财　　惜彼菩提道
  行如是四法　　得辩才增长
  如着种种鬘　　他人见者喜
  一切诸世间　　人天等众生
  见彼菩萨者　　欢喜亦如是

得无垢女。诸菩萨摩诃萨。成就四法得净佛土。何等为四。一者于他不嫉。二者等心自他。三者见诸众生心常欢喜。四者不亲诸恶眷属。得无垢女。诸菩萨摩诃萨。若能成就如是四法。得净佛土。尔时世尊。而说偈言

  心不怀嫉妒　　不取他人利
  见众生欢喜　　等心于一切
  不伴恶眷属　　如是等四法
  具足修行者　　得清净佛土

得无垢女。诸菩萨摩诃萨。成就四法得僧具足。何等为四。一者不念他人眷属。二者和合破坏眷属。三者于说法处受持读诵为他人说。四者舍离恶语。得无垢女。诸菩萨摩诃萨。若能成就如是四法得僧具足。尔时世尊而说偈言

  不念他眷属　　和合破坏者
  说法处教人　　不说破坏语
  行如是四法　　得第一净僧
  欲得净僧者　　黠慧修此法

得无垢女。诸菩萨摩诃萨。成就四法随心所愿生佛国土。何等为四。一者于他亲友心不生嫉。二者常求六波罗蜜欲令满足。三者心信清净坚固。四者于诸菩萨常起师想。乃至初发菩提心者。皆生师想而供养之。而不偏着亲友因缘。得无垢女。诸菩萨摩诃萨。若能成就如是四法。随其所愿生佛国土。尔时世尊而说偈言

  不嫉他利养　　求波罗蜜善
  常净坚固心　　于菩萨师想
  不谄求乐缘　　欲令亲得乐
  常修此功德　　速得近如来
  随心之所愿　　得生佛世界
  既生彼世界　　随忆念皆得

尔时得无垢女白佛言。世尊。如佛为我所说法门。若我不信不取此法不修不行。是则破坏一切十方。于今现在现命现住。诸佛世尊。尔时尊者大目犍连。语得无垢。作如是言。汝甚希有。若如是说菩提难得。彼菩提行难得修行。女能修行甚为希有。得无垢女即发誓言。大德目连。我未来世当成如来应正遍知。如今世尊等无有异。若实不虚。令此三千大千世界六种震动无一众生有怖畏者。我今实语。若我堪能如佛所说具足修行。今当雨华天诸妓乐自然出声。我妇女身转为丈夫。得无垢女。如是说已。即时三千大千世界六种震动。天诸妓乐自然出声。雨众天华。得无垢女。转妇女身即成丈夫。如年十六端正童子。一切皆见。尔时尊者大目犍连白如来曰。希有世尊。如我意解。菩萨从初发心乃至道场。此得无垢。如是神通最为第一。如是大力。如是大体。如实住持。此如是等。所见因缘。异异具足。如是说已。佛言。如是如是。目连如汝所说。菩萨从初发心乃至道场。彼是世间天人福田。出过一切声闻缘觉。时佛微笑。诸佛常法若微笑时。则有若干无量种色。种种异色。青黄赤白红紫颇梨。金宝色光从口中出。普照无量无数世界乃至梵世。照已还摄入如来顶。尔时尊者阿难从座而起。整服左肩右膝着地。合掌向佛偈赞问曰

  天王紧那罗　　娑婆世界主
  大梵天王声　　命命之音声
  音乐诸天声　　贪嗔痴寂静
  世界皆生爱　　无垢人王月
  力功德如海　　何故放光明
  复六种动地　　大地不倾覆
  空中雨天华　　见者心爱乐
  犹如师子王　　破坏小野干
  如来能摧坏　　一切诸外道
  唯愿牟尼尊　　今日为我说
  佛念何因缘　　何人得大利
  亿那由他数　　日月珠光明
  帝释娑婆主　　乃至梵天光
  从世尊面门　　出无垢净光
  彼十方光明　　一切皆不现
  额中满如月　　眉间净无垢
  明若秋日月　　分陀华无异
  犹如电光发　　萤火星不现
  释迦牟尼尊　　映蔽诸外道
  如来今放光　　何人得利益

尊者阿难。如是说已。佛言阿难。此得无垢如实住持。转女人身得成男子。汝为见不。阿难答言。已见世尊。佛言阿难。此得无垢菩萨。于八十千阿僧祇劫。行菩提行。求阿耨多罗三藐三菩提。于六十千阿僧祇佛所。行菩提行。文殊师利童子菩萨。尔乃于后发菩提心。如文殊师利等八十千菩萨。若佛世界功德庄严。如得无垢菩萨一佛世界功德庄严。尔时尊者大目揵连。语得无垢菩萨言。善男子。若仁如是久远已来行菩提行。求阿耨多罗三藐三菩提。如是女身何以不转。得无垢言。大德目连。菩提觉者非女人身非男子身。何以故。菩提不生非身心觉

尔时文殊师利童子作如是言。希有世尊。此得无垢菩萨摩诃萨。乃能解此甚深解脱。佛言。文殊师利。如得无垢菩萨。六十亿佛所。行于梵行。修空三昧。满八十千阿僧祇劫。修无生忍。于三十亿佛所。难问彼佛已。说得无垢菩萨甚深解脱。诸菩萨中最为第一。衣食供养八十亿佛。问此论义辩才法门。文殊师利。若善男子若善女人。闻此法门。受持读诵为他广说。彼人如是得福甚多。何以故。此法门者得入菩提具足因缘

尔时文殊师利白佛言。世尊。当以何名名此法门。我当云何而奉持之

佛言。文殊师利。此法门者名论义辩才。如是受持。名得无垢法门。如是受持。佛说是时。有八十亿那由他众生。诸天人等一切不退。决定当得阿耨多罗三藐三菩提

尔时辩聚菩萨摩诃萨白佛言。世尊世尊。得无垢菩萨摩诃萨。几时当得阿耨多罗三藐三菩提觉。佛言。善男子。是得无垢菩萨摩诃萨。过不可数百千阿僧祇劫。当得作佛号无垢笑忆念幢王如来应正遍知。世界名曰无量净妙功德庄严。彼国无有声闻缘觉过天富乐

尔时得无垢菩萨摩诃萨。于世尊前。闻授记已欢喜踊跃。上升虚空高八十亿多罗树。住虚空中放大光明。其光遍照千佛世界世尊顶上。八十四千由旬宝华中住。为供养佛如鸟飞下。绕佛千匝。合掌向佛于一面坐。尔时彼五百婆罗门并梵天婆罗门。见得无垢菩萨前胜神通。身毛肃然得净心信深生爱敬。合掌向佛而说偈言

  若恭敬如来　　彼利是大利
  令何人决定　　作佛法因缘
  我婆罗门种　　前造作恶事
  见大声闻师　　口说不善语
  今忏悔此罪　　愿后不受殃
  见佛子恶说　　非是贤人语
  非善得人身　　虚损他饮食
  我若不见佛　　胜妙功德王
  则与得无垢　　相随解奏去
  以见彼佛子　　恭敬须臾间
  我问彼言曰　　何处时见佛
  彼言生七日　　尔时闻佛名
  彼说佛功德　　实体不异闻
  我闻彼佛名　　深生净信心
  一切皆欲去　　向无上菩提
  我前福因缘　　得闻佛名称
  来向释师子　　头面礼佛足
  求见佛礼拜　　闻于无上法
  见此二足尊　　得脱一切苦
  若佛释师子　　实语人说法
  我学彼佛法　　得佛法因缘
  女闻佛法故　　得无上菩提
  我今入实法　　菩萨行道门
  我信入佛法　　当得世间胜
  彼坚固心知　　忆念牟尼尊
  圣知阿难问　　授一切人记

尔时世尊。而说偈言

  此等五百人　　梵天婆罗门
  彼一切同时　　当得成佛道
  于八十亿劫　　不作诸恶行
  于一一劫中　　得见亿如来
  过去已供养　　满足五百佛
  此后复得见　　亿佛坐菩提
  供养僧福田　　八十亿比丘
  广为诸众生　　说如是法门
  次第一切得　　寂静涅槃乐

佛说此经已。辩聚菩萨摩诃萨。得无垢菩萨摩诃萨等一切菩萨。彼诸声闻。彼婆罗门波斯匿王憍萨罗主及诸天人。并阿修罗乾闼婆等。闻世尊说欢喜奉行

得无垢女经


度一切诸佛境界智严经

    No. 358 [Nos. 357, 359]

度一切诸佛境界智严经

        梁扶南三藏僧伽婆罗等译

如是我闻。一时佛住王舍城耆阇崛山顶法界宫殿上。与大比丘众二万五千人。皆是阿罗汉。诸漏已尽无复烦恼。心善解脱慧善解脱。调伏诸根摩诃那伽。所作已办可作已办。舍于重担已得自事义。有结已尽心得自在。其名曰阿若憍陈如等。及八大声闻。复有七十二亿那由他菩萨摩诃萨。其名曰文殊师利菩萨。行吉菩萨。佛吉菩萨。药王菩萨。常起菩萨摩诃萨等。能转不退法轮。善问无比宝顶修多罗等。住法云地。智慧如须弥山。常修行空无相无作无生无体深法光明。功德圆满威仪具足。无数那由他世界如来所遣。有大神通住无性相。尔时世尊作是思惟。是诸菩萨摩诃萨。从恒河沙等世界而来至此。我当为其说法令得大力。当现神通相放大光明。以诸菩萨当问我故

尔时世尊放大光明。普照十方无量不可思议三千大千微尘世界。尔时十方一一方面十佛世界。有不可说千万亿那由他微尘等诸菩萨。各从本界乘不可思议无量神通。而来集此。复以不可思议供具供养如来。随意所造莲华座于佛前坐。瞻仰世尊目不暂舍。是时于法界宫殿上。起大宝莲华师子藏座。纵广无量亿由旬。无量光明摩尼珠所成。电灯摩尼珠为交络。不可思议力摩尼珠为竿。以无譬喻摩尼珠为眷属。过诸譬喻摩尼珠所庄严。以自在王摩尼珠为盖。以杂摩尼宝厕填。悬种种色幡。彼大摩尼珠围绕。出十种无量亿那由他光明。遍照十方世界。尔时不可说百千万亿那由他微尘等数。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释梵四天王。从十方十佛世界来集于此。复有诸天乘宝顶宫殿。无数不可思议天女。作百千万亿那由他妓乐。亦来集此。复有诸天乘宝华宫殿。龙宝栴檀神珠宫殿。真珠宫殿。宝衣宫殿。金光明摩尼珠宫殿。阎浮提金宫殿。无量光明摩尼珠宫殿。自在王摩尼珠宫殿。如意摩尼珠宫殿。覆帝释摩尼珠宫殿。大海聚清净宝庄严。普光明大摩尼珠意顶宫殿。与无数不可思议千万亿那由他天女。作诸妓乐而来集此。咸以无数不可思议供具。供养于佛。供养佛已。各随意坐。瞻仰世尊目不暂舍。是时。三千大千世界。皆作阎浮提金色。以种种摩尼珠为树。天华树。宝衣树。龙宝栴檀树所庄严。日月电灯等。摩尼珠为交络。遍覆世界悬种种幡。无数千万亿那由他天女。持种种璎珞种种宝华。尔时从大宝莲华师子座。出此伽陀

  汝等今安坐　　我当说真实
  人王师子座　　如来功德造
  我今日愿满　　供养两足尊
  世尊今当坐　　七宝莲华座
  当放大光明　　照我及一切
  说无上妙法　　利益诸天人
  众生闻法者　　当坐师子座
  如是大光明　　从如来身出
  照无量世界　　令一切欢喜
  导师天中天　　今当摄受我
  我昔于此处　　已值八亿佛
  唯愿今世尊　　必哀愍摄受

尔时世尊从光明座起。坐宝莲华藏师子座。结加趺坐。观诸菩萨众皆悉已集。为发起诸菩萨故。当说空法。尔时诸菩萨作是思惟。此文殊师利童子菩萨。当问如来不生不灭。我等从久远来不闻此法。是时文殊。已知如来欲说法相。及诸菩萨心所思惟。即白佛言。世尊。无生无灭法者。其相云何。文殊师利说此祇夜

  无生无灭　　云何可知　　大牟尼尊
  当说譬喻　　此诸大众　　皆已来集
  乐闻此义　　愿佛解说　　今诸菩萨
  诸佛所遣　　亦皆乐闻　　微妙法相

佛告文殊师利。善哉善哉汝今所问。能大利益一切世间。令诸菩萨得作佛事。文殊师利。汝当谛听勿起惊疑。文殊师利。不生不灭即是如来。文殊师利。譬如大地琉璃所成。帝释毗阇延宫殿。供具等影现其中。阎浮提人。见琉璃地诸宫殿影。合掌供养烧香散华。愿我得生如是宫殿。我当游戏如帝释等。彼诸众生不知此地是宫殿影。乃布施持戒修诸功德。为得如此宫殿果报。文殊师利。如此宫殿实无生灭。以地净故影现其中。彼宫殿影。亦有亦无不生不灭。文殊师利。众生见佛亦复如是。以其心净故见佛身。佛身无为。不生不起不尽不灭。非色非非色。不可见非不可见。非世间非非世间。非心非非心。以众生心净见如来身。散华烧香种种供养。愿我当得如是色身。布施持戒作诸功德。为得如来微妙身故。如是文殊师利。如来神力出现世间。令诸众生得大利益。如影如像随众生见。尔时世尊说此祇夜

  如来常住　　不生不灭　　非心非色
  非有非无　　如琉璃地　　见宫殿影
  此影非有　　亦复非无　　众生心净
  见如来身　　非有非无　　亦复如是

文殊师利。如日初出先照高山。次及中山后照下地。如来亦尔。无心意识无相离相。断一切相。不着彼不着此。不住此岸不住彼岸。不住中流不可思议。非思惟所及。不高不下。无系缚无解脱。非有智非无智。非烦恼非不烦恼。不真实不虚妄。非智非非智。不可思议非不可思议。非行非不行。非念非不念。非心非不心。非意非不意。非名非不名。非色非无色。无取无不取。非说非不说。非可说非不可说。非可见非不可见。非导师非非导师。非得果非不得果。如是文殊师利。如来慧日光明照于三界。先照菩萨如照高山。次照乐缘觉声闻人。后照乐善根人。乃至邪定众生。为增长善法。为起未来因缘。文殊师利。如来平等无上中下。常行舍心。文殊师利。如来不作是思惟。如是众生我为说胜法。如是众生说不胜法。亦不思惟。此众生大意。此众生中意。此众生小意。此乐善法。此乐恶法。此人正定。此人邪定。如来智光明无如是分别。已断一切分别想故。以众生有种种善根故。如来智慧故有种种。文殊师利。如大海中有摩尼珠。名满一切众生所愿。安置幢上随众生所须。彼摩尼珠无心意识如来无心意识。亦复如是。不可测量。不可到。不可得。不可说。除过患。除无明。不实不虚。非常非不常。非光明非不光明。非世间非非世间。无觉无观。不生不灭。不可思议无心无体。不动不行无量无边。不可说无言语。无喜无不喜。无数离数。无去无来。无行处断诸趣。不可见不可执。无挍计。非空非不空。非和合非不和合。不可思议不可觉知。非秽非净非名非色。非业非果。非过去非未来非现在。无所有无声无相离一切相。非内非外亦非中间。如是文殊师利。如来清净住大慈悲幢。随众生所乐。现种种身说种种法。文殊师利。如因声生响。非内非外亦非中间。不生不灭不断不常。文殊师利。如来亦尔。非内非外亦非中间。不生不灭无名无相。随诸众生种种示现。文殊师利。如诸草木依地增长。彼地平等离诸分别。如是一切众生善根。依如来增长。声闻乘缘觉乘菩萨乘。乃至裸形尼干子等。一切外道善根。亦依如来增长。如来平等无有分别。亦复如是。文殊师利。如虚空平等无下中上。如来平等亦复如是。众生自见有下中上。文殊师利。如来不作是念。此众生下意当现下身。此中上意现中上身。此众生下意当说下乘。此众生中意说缘觉声闻乘。此众生上意为说大乘。文殊师利。如来无如是意。此众生乐施。我当说施。戒忍精进定慧亦如是。何以故。如来法身平等。离心意识无分别故。文殊师利。一切诸法悉皆平等。平等故无住。无住故无动。无动故无依。无依故无处。无处故不生。不生故不灭。若能如是见者。心不颠倒。不颠倒故如实。如实故无所行。无所行故无来。无来故无去。无去故如如。如如故随法性。随法性故不动。若随法性不动。则得法性。若得法性。则无悕望。何以故。已得道故。若得道则不住一切诸法。不住一切诸法故。不生不灭无名无相。文殊师利。若众生着一切法。则起烦恼。起烦恼故不得菩提。文殊师利白佛言。世尊。云何得菩提。佛告文殊师利。无根无处。是如来得菩提。文殊师利白佛言。云何为根。云何为处。佛告文殊师利。身见为根。不真实思惟为处。文殊师利。如来智慧与菩提等。与一切诸法等。是故无根无处。是得菩提。文殊师利。菩提者寂静。云何寂静。内寂静外寂静。何以故。眼即是空。非我非我所。耳鼻舌身意空。非我非我所。以知眼空于色不行。是谓寂静。如是以知耳空于声不行。是谓寂静。知鼻乃至意空亦如是。文殊师利。菩提者。不动不行。不动者不取一切诸法。不行者不舍一切诸法。文殊师利。如来不动。则如如实。如如实者。不见此岸不见彼岸。不见此彼故。则见一切法。以见一切法故。称为如来。文殊师利。菩提者。无相无缘。云何无相。云何无缘。不得眼识是无相。不见色是无缘。不得耳识是无相。不闻声是无缘。乃至意法亦如是。文殊师利。菩提者。非过去未来现在三世等。断三世流转。文殊师利。云何断流转。以于过去心不起未来识。不行现在意。不动不住。不思惟不觉不分别故。文殊师利。菩提者无形相无为。云何无形相不可以六识识故。云何无为。无生住灭故。是谓断三世流转。文殊师利。菩提者。是不破句。云何不破。云何句。无相是不破。如实是句。无住处是不破。法界是句。不动是不破。空性是句。不得是不破。无相是句。不觉是不破。不作是句。不悕望是不破。无自性是句。众生无自性是不破。虚空是句。不可得是不破。不生是句。不灭是不破。无为是句。不行是不破。菩提是句。寂静是不破。涅槃是句。不更生是不破。不生是句。文殊师利。菩提者。不可以身觉。不可以心觉。何以故。身是无知。如草木故。心者虚诳。不真实故。文殊师利。若谓菩提身心所觉。是依假名非真实义。何以故。菩提不身不心。不虚不实故。文殊师利。菩提者。非语言可说。何以故。如虚空无处所。不生不灭无名字故。文殊师利。一切法真实不可说。何以故。一切法非真实。无语言。不生不灭故。文殊师利。菩提者。不可取无处。云何不可取无处。眼识不可取。不得色为无处。耳识不可取。不得声为无处。鼻乃至意法亦如是。菩提者。不可觉以眼不取故不得色。不得色故识无住处。耳不取故不得声。不得声故识无住处。乃至意法亦如是。文殊师利。菩提者。是说空。以空一切诸法故。空是如来所知。空是如来所觉。文殊师利。不从空有。空为如来所觉。何以故。以无相故。复次文殊师利。菩提因智亦是空性。何以故。以无相故。文殊师利。空及菩提悉无所有。无二无数无名无相。离心意识。不生不灭。无行无处。非声非说。文殊师利。但以名字说。实不可说。文殊师利。如来悉知一切诸法从本以来。不生不起不尽不灭。无名无相离心意识。如是知故如是解脱。亦不系缚亦不解脱。文殊师利。菩提者。与虚空等虚空者。不平等非不平等。菩提者。亦不平等非不平等。如是法相如来所觉。文殊师利。如阿[少/兔]微尘。不等非不等。一切诸法亦如是。以真实智能如是知。文殊师利。云何真实智知诸法。未生者生。生已即灭。彼一切诸法无生。无所摄故。文殊师利。菩提者如实句。如实句者。如菩提相不离如实。色受想行识不离如实。如菩提相地界不离如实。水火风界不离如实。如菩提相眼界色界眼识界不离如实。乃至意界法界意识界。亦不离如实。此谓如实句。文殊师利。菩提者。以行入无行。文殊师利。云何行。云何无行。行者缘一切善法。无行者不得一切善法。行者心不住。无行者无相解脱。行者可称量。无行者不可量。云何不可量。无可识故。文殊师利。菩提者。无漏无取。无漏者灭四流故。云何为四。欲流有流见流无明流。不着此四流。是谓灭四流。无取者灭四种取。云何四取。欲取见取戒取我语取。此谓四取。此一切取。无明所闇。渴爱所欺。以展转相生故。文殊师利。以如实智断我语取根。取根断故身得清净。身清净者是无生灭。文殊师利。无生灭者。不起心意识。不思惟分别。若有分别则成无明。不起此无明则无十二因缘。无十二因缘即是不生。不生即是道。道是了义。了义是第一义。第一义是无我义。无我义是不可说义。不可说义是十二因缘义。十二因缘义是法义。法义是如来义。是故我说。若见十二因缘即是见法。见法即是见佛。如是见无所见。文殊师利。菩提者。清净无垢无烦恼。文殊师利。空是清净。无相是无垢。无作是无烦恼。复次不生是清净。无为是无垢。不灭是无烦恼。复次自性是清净。清净是无垢。无垢是无烦恼。复次无分别是清净。不分别是无垢。灭分别是无烦恼。如实是清净。法界是无垢。真实观是无烦恼。虚空是清净。虚空是无垢。虚空是无烦恼。内身智是清净。内行是无垢。不得内外是无烦恼。知阴是清净。界自性是无垢。不舍诸入是无烦恼。于过去尽智是清净。于未来不生智是无垢。现在法界智是无烦恼。文殊师利。此谓清净无垢无烦恼。此即寂静。寂静者内外寂静。内外寂静者。是大寂静。大寂静故说名牟尼。文殊师利。如虚空是菩提。如菩提是诸法。如诸法是一切众生。如一切众生是境界如境界是泥洹。文殊师利。一切诸法与泥洹等。最上无边故无有对治。无对治故本来清净。本来无垢。本无烦恼。文殊师利。如是如来觉一切诸法已。观诸众生起大慈悲。令众生游戏清净无垢无烦恼处。文殊师利。云何诸菩萨行菩萨行。文殊师利。菩萨不思惟。不为灭不为生。是为行菩萨行。复次文殊师利。菩萨过去心已灭不行。未来心未到不行。现在心虽有亦不行。何以故。不着过去未来现在故。文殊师利。是名菩萨行菩萨行。文殊师利。布施及如来。无有二相。是菩萨所行。如是戒忍精进定慧。及如来无二。是菩萨所行。文殊师利。若菩萨不行色空是菩萨行。不行色不空是菩萨行。何以故。以色自性空故。如是菩萨不行受想行识空不空。是菩萨行。何以故。心意识不可得故。文殊师利。一切无所有法。当修当作证。若证则无烦恼生。无烦恼灭。文殊师利。生灭者。是假名字说。于实相中无起无灭。文殊师利。假使六趣四生众生。若有色无色有想无想。二足四足多足无足。悉得人身。得人身故发菩提心。发菩提心已。一一菩萨供养恒河沙等诸佛。及诸菩萨缘觉声闻。饮食衣服卧具医药一切乐具。经恒河沙劫。乃至入涅槃后。起七宝塔高百由旬。宝盖覆上悬摩尼宝珠以为庄校悬种种幡盖。自在王摩尼珠以为交络。若有菩萨以清净心。闻此度一切诸佛境界智严经。闻已欢喜受持信解。乃至为他说一偈一句。胜前功德。百分千分万分亿分。乃至算数譬喻所不能及。何以故。此经广说不可思议清净无相微妙法身故。文殊师利。若恒河沙等无数诸菩萨。若恒河沙无数诸佛世界。悉阎浮金所造。乃至树木华果皆阎浮金。及以天衣庄严其树。一切光明摩尼珠网以覆其上。自在王摩尼珠以为宫殿。电光摩尼珠以为基陛。悬众宝幡。日日以此供养恒河沙等无数诸佛。如是经无数劫。若有菩萨正念此经。或宣说一句。以前菩萨布施功德。比此功德百分不及一。百千万亿分乃至算数譬喻所不能及。如是其余一切功德。比此经功德无有及者。尔时世尊说此祇夜

  若有受持此　　微妙法身经
  所得功德利　　不可得称量
  假使诸众生　　皆悉生人道
  并发菩提心　　为求一切智
  如是诸菩萨　　皆作大施主
  以种种供具　　供养无数佛
  并及诸菩萨　　缘觉与声闻
  乃至入灭度　　各起七宝塔
  高至百由旬　　种种宝严饰
  若人持此经　　或说一句偈
  出过此功德　　无量无有边
  以此经所说　　无相法身故
  是故有智者　　应当念受持
  读诵及书写　　以华香供养
  所得功德果　　不可得思议
  不久诣道场　　降魔成正觉
  如是修妒路　　诸佛所称扬
  即是妙法身　　无相无言语
  是故受持者　　功德不可量

佛说此经已。文殊师利等一切菩萨。无量缘觉及声闻众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众闻佛所说欢喜奉行

度一切诸佛境界智严经


发觉净心经卷上

    No. 327 [No. 310(25)]

发觉净心经卷上

        隋北印度健陀罗国三藏阇那崛多隋言志德　译

尔时婆伽婆复于一时。游波罗奈城诸仙住处鹿野苑中。与大比丘众足满千人。复有五百诸菩萨众。于其众中。多有诸根未成熟者。有减少善根者。有诸业障者。尔时彼处诸菩萨中。复有诸菩萨。乐多世事。乐于谈话。乐于睡眠。乐于杂业。乐於戏论。乐于染着。种种文词散乱之业不合禅行。于诸善事懒惰懈怠。破精进行忘失正念。无所能知常行乱行

尔时众中有一菩萨摩诃萨名曰弥勒。在彼会坐。知彼众中诸菩萨等有如是行已。即作是念。此诸菩萨减损道分。然我今者。应当发觉此菩萨等。令彼忆念发起道意。尔时弥勒菩萨摩诃萨作是念已。于日晡时从禅定起。往诣诸诸菩萨所。到已与彼诸菩萨。共相慰喻为作欢喜。令彼乐欲求闻法故。因而告彼诸菩萨言。长老汝等。颇于菩提分中不损减乎。弥勒菩萨作是语已。彼诸菩萨。语弥勒菩萨言。长老弥勒。我等道分唯有损减无有增长。何以故。然我等辈取住疑心。我等为当得作佛耶。不得佛耶。我等为当堕落法耶。不堕落耶。于诸善根为欲生耶。为不生耶。作于恶心。我等住取是相。作是语已。弥勒菩萨告彼菩萨众言。汝长老辈。今可共往诣佛世尊如来应供等正觉所。然彼世尊。一切智见无碍解脱知见具足。巧知一切众生心行。彼佛世尊量汝等行当为说法。时彼众中六十菩萨。共弥勒菩萨往诣佛所。到已五体头面礼佛足已。于地未起悲啼雨泪。其弥勒菩萨。顶礼佛足却坐一面

尔时世尊告诸菩萨言。诸善男子。汝等应起莫啼莫叹勿生热恼。汝等过去作此业障。汝等于时欢喜踊跃。骂詈毁辱破坏他人。不信业报不能分别业障缠绕不合善故尔时彼六十菩萨。偏袒右肩。右膝着地。向佛合掌而作是言。善哉世尊。我等业障愿分别说。令我等辈自清净心勿复更造。时彼菩萨作是语已。佛告彼菩萨言。诸善男子。汝等过去。于拘留孙如来教中出家学道。既出家已。住于禁戒于戒放逸。住于多闻于多闻放逸。于头陀功德皆悉损减。于时有二法师比丘。汝于彼所诽谤淫欲。为多利养名闻因缘。于彼亲友施主之家嫉妒悭贪。于二法师所亲友檀越。汝复破坏离散。两舌毁辱令生疑惑。不生信心信不具足说非善事。时二法师所有众生。心生敬信随顺之者。令彼等辈断诸善根作诸障碍。汝等以此业障缘故遂于六十二百千岁。堕于阿鼻大地狱中。复于四万岁。堕于活地狱中。复于二万岁中。堕黑绳地狱。复于八百千岁。堕热地狱。复于彼处舍命已后还得人身。于五百世中生盲无目。以业障故所生之处一切闇钝。忘失本心善根闭塞少于威力。众皆弃舍恒被欺陵。为人憎恶毁呰诽谤。常生边地贫贱之处下种姓家。少利养少名闻。不为他人恭敬供养。亦不尊重。人所不喜众所厌恶。汝等从此舍身命已。于后五百岁中正法灭时。还生于恶国恶人之处下种姓家。贫穷下贱被他诽谤。忘失本心不欲善根常有障碍。虽暂遇明还被翳闇。汝等于彼五百岁后。一切业障尔乃灭尽。于后得生阿弥陀国极乐世界。时彼如来方授汝等阿耨多罗三藐三菩提记

尔时彼等六十菩萨乘富伽罗等。既闻此已扪泪恐怖毛竖。合掌向佛而作是言。世尊。我等从今若于菩萨乘富伽罗所。若生嗔恚过失。而复更造自余业障。我等今日于世尊前皆悉忏悔。世尊。我等今者于如来前发实誓愿

世尊。我等从今日已。若于菩萨乘富伽罗辈。于犯罪之中发觉言说。我等则为欺诳如来。世尊。我等从今日已。若于行菩萨乘富伽罗所。戏弄恶贱而轻慢者。我等则为欺诳如来。世尊。我等从今日已。若于行菩萨乘富伽罗所。而起我慢说彼恶事若实若虚。我等则为欺诳如来

世尊。我等从今日已。见菩萨乘富伽罗者。若在家若出家。受五欲果报富乐游戏娱乐。见是事已生不信心。取彼过失不生敬心不作师想者。我等则为欺诳如来

世尊。我等从今日已。于亲友家乞丐家因缘。行菩萨乘富伽罗所。若逼切身心者。我等则为欺诳如来

世尊。我等从今日已。行菩萨乘富伽罗所。出不喜声及骂詈声。我等则为欺诳如来

世尊。我等从今日已。于昼三时及夜三时。一切菩萨乘富伽罗所不礼拜者。我等则为欺诳如来

世尊。我等从今日已。为护此受故若身若命而不舍者。我等则为欺诳如来

世尊。我等从今日已。若声闻乘若辟支佛乘富伽罗所。若起胜念自大非彼。我等则为欺诳如来

世尊。我等从今日已。于游行时。若不作卑下心。如旃陀罗及如狗犬。若不作如是行者。我等则为欺诳如来

世尊。我等从今日已。若自称誉毁谤于他。我等则为欺诳如来

世尊。我等从今日已怖嗔斗故。若不离彼去百由旬犹如风吹者。我等则为欺诳如来

世尊。我等从今日已。于持戒者我应敬念。若多闻者。若头陀功德及省事者。并余功德若不赞说。我等则为欺诳如来

世尊。我等从今日已。若不覆藏己之功德开示己恶。我等则为欺诳如来

尔时世尊。赞彼六十行菩萨乘富伽罗言。善哉善哉。诸善男子。汝等善说此诸誓愿。能自发觉善作是愿。汝等如是住者。当尽一切业障。当得善根净

尔时世尊复告弥勒菩萨摩诃萨言。弥勒。若有菩萨欲净业障当作是愿

尔时弥勒菩萨摩诃萨。复白佛言。世尊。颇有善男子等护持此愿。当得满足不退转不。佛告弥勒。有诸菩萨受行是愿。彼善男子善女人。宁舍身命不缺此行亦不退舍。尔时弥勒菩萨复白佛言。世尊。行菩萨乘富伽罗等。具足几法。于后五百岁法欲坏时。无损无害而得免脱。尔时佛告弥勒菩萨言。其具足有四种法。于后五百岁法欲坏时。不损不害而得免脱。何等为四。不求他过。于菩萨乘富伽罗所。有犯罪处而不发觉。于善友家及施主家。不生吝惜舍离恶言弥勒。是为行菩萨乘富伽罗等具足四法。于后未来五百岁时。不损不害当得免脱。尔时世尊欲重宣此义。而说偈言

  莫于他边见过失　　勿说他人是与非
  不着他家净活命　　诸所恶言当弃舍

复有四法。行菩萨乘富伽罗等。后五百岁法欲坏时。比丘坏时。无损无害而得免脱。何等为四。所谓不相应众生应当弃舍。远离大众。常修兰若。降伏己身与此相应弥勒。行菩萨乘富伽罗等具四法者。于彼后时五百岁中法欲灭时。能于自身不损不害安隐解脱。尔时世尊而说偈言

  弃舍众闹极远离　　无法比丘勿亲近
  当修兰若佛所赞　　不着利故得涅槃

是故弥勒。菩萨于后五百岁时。欲自不损不害。而得解脱一切业障。欲得免者勿亲秽闹。应住兰若空闲园林。离不相应诸众生等。常自省察莫求他过。爱乐默然当与般若波罗蜜相应。于诸众生起慈愍心。而为说法勿求恩报

尔时世尊复告弥勒菩萨言。善男子。法施有二十功德。不求果报。不着利养及与名闻。而为说法。何等二十。得正忆念。得胜妙趣。得好正意。得强志力。得多智慧。觉悟出世般若波罗蜜。当得少欲。当灭嗔恚。当灭愚痴。一切诸魔不得其便。诸佛护念。非人守护。诸天与力。一切冤家不得其便。凡所亲友无人能坏。凡所出言人必信受。得无所畏。凡有行处恒常欢喜。智者赞叹。所行法施恒为他念。弥勒。是为法施不求果报得二十功德。弃舍利养及与名闻。衣服饮食无所希望。饶益为首常行法施

复次弥勒。菩萨复有二十种功德不求果报。菩萨为他行法施时。不着利养名闻。饶益为首数行法施。何者二十。彼未生辩才则能令生。生已不失。得陀罗尼。当得密动。不用多力广益群生。少用功力多所利益。于众生边恭敬尊重常应供养。当得身密。当得口密。当得意密。超越恶道及诸恐怖。于命终时心得欢欣。如法正说能伏他论。具大威德胜人敬仰。况余凡庶。诸根成就无能及者。深心具足得舍摩他毗婆舍那。能行难行精进不减。守护正法速能超度不退转地。一切行中得随顺住。弥勒。是名复有二十种功德。菩萨法施不求果报。不着利养及与名闻衣服饮食。饶益为先数行法施。弥勒。汝观未来后五百岁中。有几所无智菩萨乘富伽罗等。行法施时望报欢喜非不望报。彼作是心为他说法。增多亲友及乞丐所故行于法施。又作是念。云何当令出家在家生净信心。供养于我衣服饮食卧具汤药所须。以是缘故为他说法。弥勒。譬如死蛇死狗及死人等。其实臭秽可恶脓烂不净。众人厌恶舍离远去。如是如是。弥勒。于后末世诸法师等。唯求果报为他说法。若无财利厌恶生苦。疲倦舍去我等无利。如此法施无有利润。既不与我衣服饮食卧具床铺。作如是念。我何因缘于中疲苦。彼人为重供养承事己身。畜于侍者及弟子等而不为法。都无利益他人之事。而口诈现如是慰喻教导众人。我有慈悲如法摄众。不为财利为利益故。至彼城邑聚落王家。为成熟众生故。彼虽作是语。心常唯为衣服饮食卧具汤药等事。弥勒。我不说彼求财物者法施清净。何以故。夫求报者法不平等。弥勒。我不说彼希望报者成熟众生。何以故。若自未成熟能成熟他无有是处。弥勒。我不说重承事爱供养身。摄取种种物者为利益他事。何以故。为承事者唯为身乐故。不能摄众建立修行故。弥勒。我不说诈称善者为住兰若。弥勒。我不说薄福人者为少欲行。弥勒。我不说追求好饮食者为行乞食。弥勒。我不说少利养者为知足行。我不说求好衣服者为持粪扫衣。我不说道俗不识而独住者为不杂行。我不说好谄曲者值佛兴世。我不说求他短者能与法合。我不说多嗔怒者为戒聚清净。我不说我慢贡高者为多闻。我不说好朋党者为持律师。我不说威仪浊者为善敬说法。我不说多绮语调弄者为善说法师。我不说染着家者为清净梵行导师。我不说求福田施者为不希报。我不说求报恩者以为善摄事。我不说求利养名闻者为内心清净。我不说无信多分别者以为出家。我不说信他教者为好持戒。我不说不尊重者以为听法。我不说着世典咒咀者以为爱法。我不说不信空者而得解脱。我不说染著者以为修行净。我不说染着行者为满菩提分。我不说住所得者以为证智。我不说羸弱者为忍辱满足。我不说无人触者为忍力铠。我不说本性少烦恼者为戒清净。我不说多语者为依教行。我不说乐言语者以为一心。我不说乐作世业者为法不减少。我不说内心净者当堕恶趣。我不说依智行者以为杂行。我不说方便相应行者以为谄曲。我不说不求名利者以为妄语。我不说无戏论者以为谤法。我不说喜护正法者为爱身命。我不说恐怖行者为发精进。弥勒。如是等种种诸过谄曲颠倒贪恣等。于未来世五百年后。菩萨乘辈住此恶行当须护之。尔时弥勒菩萨摩诃萨白佛言。世尊。唯此六十菩萨。于未来世五百岁后有诸业障。为当更有其余菩萨耶。佛言弥勒于五百岁后更有其余菩萨。当为业障所缠。其中亦有能尽业障或增长者。复次弥勒。于彼时此五百菩萨众中。当有二十菩萨。于未来世能少有业障微细业障。后五百岁。当生村落城邑险难国土大豪姓家。聪明多智巧解方便。心意调柔多有润泽。利益弘广端正可喜。巧妙辩才覆藏己德。住在头陀功德之行。已于无数亿劫阿僧祇。集聚阿耨多罗三藐三菩提。护持正法弃舍身命。在兰若处远离聚落。不求名利常乐精勤。入众生行善能言论。通达世典少闻多解。于毗婆舍那悉能巧知。具得辩才善能分别。随问能答与义相应。得无碍辩才。或复有得无尽陀罗尼者。为四部众演说法时。佛威神力故佛住持故。于如来所说修多罗。祇夜。受记。伽陀。忧陀那。尼陀那阿波陀那。伊帝越多伽。阇多迦。毗佛略。阿浮陀达摩。优波提舍。能自辩说。弥勒。彼时二十巧方便菩萨。从阿阇梨和上等边。受此法本无量百千修多罗句。皆悉诵持解说。以诵持此法本故。彼善男子。于诸辩才心无疑悔。摄受而住。复次弥勒。于彼时中复有无方便菩萨。若在家俗人若出家入。于彼持正法者教法行者。真实行者。彼诸法师边所说法教。悉不受持欺诳调弄。汝等自造此法。所说法句非如来说。汝等随自意集作此文饰。迭相系缚。我等于此法中不生敬重。不生信乐难遭之想。弥勒。于彼时中多有众生。诽谤此法破坏此法不受此法。犹如伎儿调戏之法与彼同行。是诸比丘不依修多罗。不依毗尼演说法句。汝等莫生敬信希有之心。此非正法也。弥勒。彼等痴人。不知所有一切善言皆是如来所说。彼诸人等为魔所持。当生诽谤彼诸法师所说之法。当作谤法业因缘。以作谤法业因缘故当堕恶道。是故弥勒。若欲护正法菩萨。当作方便覆藏己德。于种种有行众生应须护持。勿令彼等生障碍想

尔时弥勒菩萨摩诃萨白佛言。希有世尊婆伽婆。于彼时中菩萨乘人。无有智慧不求辩才。而于人法不能生信。乃于谁边求生善根。当求陀罗尼以自护。若不如是。于彼持法诸法师边。起于诽谤生于秽污。世尊。譬如有人渴欲饮水。若至泉池若陂若井。未饮其水先掷粪秽置中。掷粪置已还欲饮水。闻水臭秽憎恶不饮。不说自污因缘反说彼过。奇哉此水甚大臭秽。自过不晓而与彼水作其过咎。如是如是。世尊。彼痴人辈长夜求法欲察法行。先于人法求其过已。还从闻法憎恶法师及所说法。如彼痴人嫌恶泉池陂井泊等。持法比丘应如是知。若复有人能说是法。当知皆是佛威神力。如是世尊。于五百岁后有无智菩萨。而污彼法及持法比丘已。还于其边欲饮法味。彼不自觉己之过恶。当复调弄彼等法师。于众人前说其过咎。起染污已觅其过失。生厌想已便欲舍离

尔时世尊赞叹弥勒菩萨言。善哉善哉。弥勒汝善说此言。若能不求他过失短者。当知己不离一切过恶。弥勒有四因缘一切辩才。诸佛所说应如是知。弥勒。复有四因缘当知四辩。即一切诸佛如来所说。毁呰一切诸佛而不许可。弥勒。何者四辩因缘。当知诸佛所说。弥勒。其辩者义具足非不义具足。法具足非不法具足。当尽烦恼不增烦恼。说涅槃功德示生死过恶。弥勒。是为四辩。当知诸佛所说。弥勒。若有比丘比丘尼。优婆塞优婆夷。与此四辩和合相应能辩说者。若善男子若善女人。于彼人边当如佛想。作教师想而听法义。何以故。弥勒。彼所有说者。当知皆是如来所说应如是见。弥勒。若有谤此四辩言非佛说。不生尊重恭敬之心。憎嫉人故彼即诽谤一切诸佛所说辩才。诽谤法已作灭法过业。作灭法行已堕于恶趣。是故弥勒。若有信心善男子等。欲得远离灭法业障因缘者。不可以憎嫉人故而憎嫉于法。不可以不爱人故于彼法边不生爱心。弥勒。何者辩说。为诸佛毁呰而不许可。弥勒。或有辩说。无有利益。不依实法。增长烦恼。不尽烦恼。增长生死。不赞涅槃功德利益。弥勒。如此辩者。一切诸佛之所呵责。一切诸佛而不许可

尔时弥勒菩萨白佛言。世尊。若有辩说增长生死非佛辩才。云何世尊说诸烦恼。为诸菩萨而作利益。亦复赞说生死流转。满足菩提分法耶。世尊。如是辩者岂非如来说乎

佛告弥勒言。于汝意云何。此烦恼为满菩提分故。为作利益诸菩萨故说者。复当说赞叹受生死流转。然此事为当合义。为当不合义。为当合法。为当不合法。答言世尊。若有正言者言合义合法。若有此语者是名正言。佛言弥勒。以是义故。汝当知一切佛所说皆是佛辩。应如是见。若有所说言诸烦恼。满足菩提分故。为菩萨说当作利益。赞叹取生死流转者。为利益菩萨故。所以者何。弥勒。被烦恼菩萨应如是见。此菩萨不犯此烦恼罪。以于义自在。以于法亦得自在故。此是诸菩萨善巧方便。于彼处非是声闻辟支佛地。弥勒。若有烦恼无有利益。不满菩提分因缘。不为善根门因。于中彼菩萨不应惜身命。亦不得随彼烦恼。所以者何。弥勒。得智力菩萨别有攀缘者。见有烦恼别著有为者。弥勒菩萨复白佛言。世尊。如我解佛所说义。若有菩萨。不欲造业障欲尽业障。不缺不损欲解脱者。彼于未来世三摩耶时。应当信菩萨行。当须思惟。莫求他过。常求功德之事。求真正处。佛告言。如是如是。弥勒。其菩萨于后世时应当思惟。于菩萨行应知方便。所以者何。方便智行菩萨。善巧方便难可得知。弥勒。譬如须陀洹人。于凡夫行中现其须陀洹地。别于凡夫别患。彼欲过嗔痴诸凡夫等当堕恶道。还彼诸过恶诸圣声闻不堕恶道。如彼证知故。弥勒。如是如是。智行菩萨污染习迷未尽故彼别有地。初行菩萨别有地。所以者何。其心不住于诸使。而诸凡夫染着诸使。愚痴因缘不能巧知解脱之处。弥勒。智行菩萨虽有重罪。以智力故当尽如灰。亦不因彼堕于恶道。弥勒。譬如炽火将大木薪掷置其中。如是数数掷中。其火转增炽盛不灭。如是如是。弥勒。智行菩萨智火炽盛时。将有为烦恼掷智火中。如是智火炽盛而不能灭。以智力故。弥勒。以是汝应当知。智行诸菩萨其行难知。尔时弥勒菩萨白佛言。世尊。初行菩萨未得智力者。舍家出家者。何等诸法当须舍离。何等诸法当须亲近。若亲近彼菩萨未生智力令生。已生者令增长不减。佛言弥勒。其初行菩萨舍家出家未得智力者。虽舍资财供养之事。应须观利养名闻诸患。应疾须舍世间言话。须观世间言话过患。应舍乐多说。应观多说过患。应舍乐睡眠。应观睡眠过患。应舍乐作诸业。应观世间诸业过患。应舍乐戏。应观乐戏过患。然彼舍利养名闻已。应须行少欲知足。应须亲近少欲知足者。舍世言话已。应须亲近乐独行者。舍多言话已。应须观真实义。舍睡眠已。初夜后夜长须惊觉。舍乐造业已。当须亲近出世之法。舍戏乐已。应须修习乐无众生慈。弥勒。初行菩萨舍家出家。未得智力者欲得智力。如是等诸法应须舍离。如是等诸法当须亲近。弥勒。彼初行菩萨舍家出家。未到智力者。未舍利养名闻时。未亲近少欲知足时。若未生智力能令生。若已生能令增长者无有是处。未离世间话。未亲近独行。不舍离乐睡眠。初夜后夜不近惊觉乐习作业。于此时中不能修习出世间法。不舍嬉戏。不亲近无众生慈想。未生智力令生。生者令增长无有是处。弥勒。是故若有菩萨欲生智力。彼菩萨应舍诸法当舍者。应须修习诸法当习近者。所以者何。弥勒。智从因生。无因智不可生。因不和合不可易得生。尔时弥勒菩萨白佛言。世尊。云何菩萨。当观利养名闻过患。何者是利养名闻诸患。菩萨观时。当乐知足而无有悔。佛告弥勒。菩萨于中当观利养不令生欲。作如是观。因利养故生欲损自己行。心生嗔恨诸患。应当观利养生痴愚生我慢故。当观利养生妒嫉故。当观利养生妖幻成就爱味故。当观利养生谄曲故。当观利养离四圣种故。当观利养无所羞愧。一切诸佛不许可故。当观利养生于我慢贡高。尊者边不生爱敬。一切人所不记录故。当观利养是助众魔。一向放逸根本故。当观利养摧折诸善根。犹如雨雹故。当观利养多诸杂秽故。当观利养失知识朋友家故。当观利养能生爱憎及忧恼故。当观利养乱正念处多污染故。当观利养令白法羸弱缺正勤故。当观利养最有障碍不得诸神通故。当观利养欺誷。各说不善事故。当观利养多有分别思量造业故。当观利养远离诸乐。失禅定三摩跋提故。当观利养犹如淫女。智慧寂靖远离故。当观利养堕地狱饿鬼畜生等恶道。如提婆达多优陀罗迦闻行故。弥勒。菩萨应当如是观察利养。观察利养已。如是观时。意乐少欲能无有悔。所以者何。弥勒。少欲菩萨无有如是等诸过患。当为诸佛法器。不随出家及在家之所欺慢。能无恐畏得清净信。一切恶道皆无恐怖不被降伏。远离一切爱味。离诸魔境当得解脱。一切诸佛所叹。天人所爱念。不染着诸禅定亲近故。当生欢喜离于谄曲。当不放逸观五欲诸患。如出言不异住于诸圣种性梵行者常观。弥勒。智者菩萨观如是诸功德。当应须远离利养名闻。正心住于知足。应当灭一切贪欲。作是语已。弥勒菩萨白佛言。世尊。菩萨云何观于世间言说过患。何者是世间言说诸患。然菩萨观已乐独行然无有悔。佛答言弥勒。世间言说有二十种诸患。应当须观。菩萨观时乐独行。何者二十。不护身行。不护口行。不护意行。当有杂欲行。多有嗔恚。多有愚痴。彼于世间多有言说。于出世间减损言说。亲近不敬法。远离正法。魔得其便。当行放逸。令向放逸。多有分别。观减于多闻。当不得奢摩他毗婆舍那。当速成非梵行。于信佛中减。于信法僧减。弥勒。此等二十诸患世间言说。若菩萨观如是等已。乐独行而不疲倦。尔时世尊。欲重宣此义。而说偈言

  舍戒远离于寂静　　若有喜乐世间话
  彼杂染着向破戒　　复有如是诸过患
  调戏多笑及分别　　彼有如是世间话
  当有杂行无摄捡　　若作世间亲近话
  愚痴世间乐智法　　无智损减上谈话
  增长放逸饶分别　　若作世间亲近话
  此亦不增于多闻　　不合言说彼生乐
  恒常减损诸禅定　　独坐世间心思惟
  世间思惟何有定　　不得寂定无正观
  是故彼无胜梵行　　若作亲近世间话
  彼于佛边无敬心　　亦于圣僧不崇仰
  舍彼最上最胜法　　若当亲近世间话
  我昔舍身数千分　　为求无上菩提缘
  不曾厌离闻正法　　彼等当舍不勤劬
  不乐男女及妇妾　　我昔舍位及资财
  为于一偈四句故　　智者何故不闻法
  一切一切处当舍　　亦不和合染语言
  彼于胜法无娱乐　　难得百劫成就者
  欲当解脱修功德　　莫问世间所作者
  不为自利无涅槃　　若有所问为衣食
  以此为胜可称赞　　若见比丘言善来
  为汝设座汝来坐　　各各当话于法事
  善得难得人身已　　汝颇增长白法不
  读诵及诸禅定中　　比丘应作如是问
  如来涅槃去已后　　当有法教破坏毁
  有诸比丘无威仪　　爱乐众中舍兰若
  利养钱财衣服等　　昼夜恒常共论说
  睡眠不动于梦中　　见于耕犁及苗稼
  此等凡夫知失已　　向于恶道三趣生
  当生欢喜踊跃已　　应住树林如犀牛
  住于兰若求乐故　　于时勿见他过失
  我是最胜众第一　　应当莫生如是心
  此是憍慢放逸本　　如是比丘莫轻贱
  次第于此法教中　　不可一时即解脱
  虽见比丘破禁戒　　但信诸佛法及僧
  于彼莫求他过患　　此为彼作解脱因
  难摄诸欲及嗔恚　　于中自在莫放逸
  诸法熏修未得时　　莫以破戒弃舍彼
  若息勤心不精进　　此最名为不进者
  修勤不见他过失　　思惟正道脱苦故
  是故比丘欲求德　　应须当舍非法语
  勤劬欢喜踊跃已　　犹如犀牛住空闲

发觉净心经卷上发觉净心经卷下

        隋北印度健陀罗国三藏阇那崛多译

尔时弥勒菩萨白佛言。希有世尊。世间人聚集言话。乃有如此多浊过患。无有功德和合。此世间言话者。但增长诸烦恼。于白法中当作虚妄。世尊。何有智者菩萨求功德者。闻此世间过患语已。当不乐独行。世尊。云何菩萨乐于多言复观诸患。菩萨若观时。乐择真义后更无悔。佛言弥勒。于中菩萨当观二十种诸患乐多言者。何等为二十。弥勒。乐多话者当无敬心以多闻故我慢放逸。于语言思惟当染着。当失本念无有自正念。所作事当不正威仪不能伏身心。所行之处身不周正。失于法忍身心刚强难可回屈。远离于奢摩他毗婆舍那。所作语言不知时节。语言秽浊当贪饮食不得圣智。诸天龙等所不敬重。所得辩者常恒轻贱后当常悔。不住于正行当轻躁。不能灭断诸疑行。行之时犹如那吒唯随逐声。当顺诸欲功德识随顺流谤正法以不观如实故。所望之处数数发起动处不动不动处动。应得供养而复不得以心不调伏故。随他所牵以不穿法界故。随诸烦恼所牵诸根不调伏故。弥勒。乐多言菩萨。有此等二十诸患。唯信知音声不观正义者。尔时世尊。欲重宣此义。而说偈言

  多闻如醉无敬心　　劳乱言语依倚住
  忘失正念无正智　　乐于多言如是患
  于内思惟甚为远　　身无寂定心亦然
  行动俯仰不屈伸　　乐于多言如是患
  正法思惟忘失意　　唯有干鞕无润心
  禅定止观皆远离　　乐于多言如是患
  尊者胜边无敬意　　恒常乐于诤竞言
  住处不坚颠倒意　　乐于多言如是患
  于诸天众不恭敬　　诸龙夜叉不念彼
  于后无有诸辩才　　乐于多言如是患
  有诸智者恒呵责　　所有应当证身者
  彼寿虚然无有利　　乐于多言如是患
  彼痴命终时有悔　　我被虚诳今何言
  彼当记说有众苦　　乐于多言如是患
  轻躁犹如风吹草　　有诸疑心不能决
  彼无坚意不能定　　乐于多言如是患
  犹如那吒在戏场　　说他猛健诸功德
  彼时亦复如那吒　　乐于多言如是患
  彼于耳闻乐染心　　彼爱音声离正智
  如有思惟不正道　　乐于多言如是患
  彼当谄曲最无望　　数数还发诤竞事
  于诸圣行最为远　　乐于多言如是患
  动作有为念无势　　他问圣德恒轻动
  犹如猕猴躁扰心　　乐于多言如是患
  彼人痴者被他使　　自智无有正定意
  被诸烦恼随顺助　　乐于多言如是患
  彼当乱眼及耳鼻　　舌身及意亦复乱
  诸根一切皆乱行　　乐于多言如是患
  无智虽求多言语　　求于诸法意不倦
  彼当不受喜乐法　　然心不喜于一念
  甘蔗茎干皮不坚　　然彼心中味最上
  不以压皮令有味　　其味不离于甘蔗
  如皮多言既如是　　如汁思义亦复然
  是故多言乐远离　　思惟正义莫放逸
  义味法味胜于众　　解脱之味亦为妙
  此是味中最上味　　何故智者不独行
  如是多言觉知已　　如是最胜义功德
  若有智者欲学道　　于彼真义应思惟
  是故远离无利言　　欲求真如胜义者
  应须亲近最胜法　　当住于此证胜道

尔时弥勒菩萨白佛言。希有世尊。乃能善说多言过患。世尊。思惟正义有大功德。世尊。若欲求坚义者。菩萨欲着刀铠甲仗。于虚伪语言应不乐习。世尊。菩萨云何乐于睡眠当观诸患。菩萨观时应舍睡眠。勤发精进不生疲倦。弥勒作如是语已。佛告弥勒菩萨云。弥勒。于中菩萨当观二十种睡眠诸患。何等为二十。弥勒。夫有菩萨当乐睡眠者。当有懒堕。身体沉重。肤皮不净。皮肉粗涩。诸大秽浊。威德薄少。饮食不消。体生创疱。多有懈怠增长痴网。知慧羸弱。善欲疲倦。当趣黑闇。人不恭敬。禀质愚痴。多诸烦恼心向诸使。于善法中而不生欲。一切白法能令减少。恒行惊怖之中。见精进者而毁辱之。至于大众被他轻贱。弥勒。菩萨乐于睡眠。有如是等二十诸患。若菩萨观时当乐发精进。尔时世尊。欲重宣此义。而说偈言

  身体沉重无寂定　　懒堕懈怠形不端
  皮肤秽恶不清净　　若乐睡眠随顺行
  涕唾风等及黄癊　　彼于身体多饶有
  诸界撩乱不平等　　若乐睡眠随顺行
  彼食饮食不成熟　　身体粗大无光泽
  彼于音声而嘶破　　若乐睡眠随顺行
  身体多有诸疮疱　　昼夜随顺睡眠者
  其于身体多生苦　　若乐睡眠随顺行
  多有懈怠离精进　　诸乐甚远无财分
  恒常睡醉无正意　　若乐睡眠随顺行
  恒常增长痴罗网　　诸见颠倒甚难治
  彼无正念意所夺　　若乐睡眠随顺行
  彼有智慧甚羸弱　　诸法损减无禅定
  远离智慧及正住　　若乐睡眠随顺行
  知彼懈怠不勤学　　恒为非人夺威德
  住在兰若常恐怖　　若乐睡眠随顺行
  恒常蒙愦失正念　　彼有读诵不能住
  所说正法常忘失　　若乐睡眠随顺行
  彼常护助烦恼等　　恒乱迷惑性轻躁
  彼于后时生悔心　　若乐睡眠随顺行
  彼有多业灭尽者　　追忆求时生恼悔
  增是诸使烦恼地　　若乐睡眠随顺行
  于诸善事无求欲　　于诸法中无求心
  数数行于非法中　　若乐睡眠随顺行
  即是远离菩提道　　一切功德悉减少
  灭于白净至黑闇　　若乐睡眠随顺行
  无有无畏严炽心　　彼不尝生欢喜念
  睡眠所执宽慢行　　若乐睡眠随顺行
  彼自知己懈怠处　　妒他住于精进力
  彼于精进说非善　　若乐睡眠随顺行
  智者若见如是患　　谁当喜乐共睡眠
  一向生痴多见网　　无欲正法灭功德
  智者谁不乐精进　　若能灭苦净诸闇
  未来恶道皆悉尽　　诸乐根本得甘露
  世间所有诸才艺　　及出世间诸能处
  能发精进不为难　　智者何不力精进
  若欲真住胜菩提　　彼等当知睡眠患
  精进无怠不放逸　　我于如是发觉彼
  故无放逸与恐怖　　发于精进禅定心
  舍于诸患离睡眠　　守护菩提及种子

尔时弥勒菩萨白佛言。世尊。如来为诸菩萨应当见。若闻如是多睡眠诸患已。然当不能断亦不能生厌离心。世尊。何者菩萨欲当学信心。当欲成阿耨多罗三藐三菩提而生懈怠。为求善法故于如是多功德中。虽复闻已不能发于精进已行。当欲满足菩提分故。如来已善说多睡眠诸患。及发精进诸功德。世尊。云何菩萨当观乐造诸业诸患。菩萨若观已当少欲知足。佛告弥勒。于中菩萨于乐作业。当观二十种诸患。何等为二十。弥勒。所谓凡菩萨乐作诸业。当乐欲世间法。即住一切最下业中。所有读诵勤劬者当被他轻贱。所有独行禅定勤劬者。当被他戏弄。乃至无际生死流转以来当发造业不休。所有信心诸长者。不能为作福田。常有贪欲爱诸物心向行于中。以勤劬力常忧家业。违他善法。施以法教而不顺从。多有思念染着诸味。所得精妙之事即不爱乐。常造作相害恶业。向诸知识新旧恒常忆念饮食。恒常乐知他人是非长短之事。恒常乐不合语议。诸梵行者所教不受。常观他过不观于己速被他轻贱。合真议语中恒常减少。弥勒。若菩萨乐造诸业者。当有如是等二十诸恶过患。尔时世尊。欲重宣此义。而说偈言

  恒常住于下贱业　　胜上之业彼最远
  此教法中无广大　　营事业者有斯患
  好乐读诵诸比丘　　为彼轻贱不欣仰
  禅定之人去舍彼　　营事业者有斯患
  生死业中常勤劳　　解脱处远住诸缚
  凡所受食不净食　　营事业者有斯患
  恒常趣于诸业等　　受取诸物无不乐
  于诸受物常贪欲　　营事业者有斯患
  贪着朋友同行者　　杂行共亲更相染
  犹如飞鸟被笼罩　　营事业者有斯患
  于诸家业恒常忧　　心意愁戚未曾乐
  凡所出言无人受　　营事业者有斯患
  有人教德不随顺　　顺法教者而不受
  彼有戒行不具足　　营事业者有斯患
  恒常忧愁心不安　　于诸俗业勤劳意
  智慧寂静彼不欲　　营事业者有斯患
  彼恒多有诸业事　　杂种诸味为彼缚
  在在处处不知足　　营事业者有斯患
  于他集聚恒欢欣　　智者不乐共言语
  爱乐猥浊犹如驴　　营事业者有斯患
  心常嗔恨无润泽　　增长诸业常无尽
  被彼爱染坚系缠　　营事业者有斯患
  彼不依倚诸尊者　　依倚俗家相佐助
  见有住戒者诽谤　　营事业者有斯患
  昼夜无有别思念　　饮食衣服及卧具
  略说功德不欲受　　营事业者有斯患
  好问世间业功德　　勤营语业彼欢欣
  勤劳胜德彼不恭　　营事业者有斯患
  耽着营作共亲友　　用己力势调伏彼
  所有恶业彼便作　　营事业者有斯患
  恒常好观他过失　　己所过恶不自知
  见彼德者常调弄　　营事业者有斯患
  每至被他所轻贱　　来者请法为我说
  意智不周无方便　　营事业者有斯患
  如是诸患当观已　　诸有菩萨乐是业
  应当作彼最胜业　　所作诸业皆无失
  舍于千钱取一钱　　有智之者应呵责
  如是之者被他嫌　　若乐作彼贱业者
  是故智者有方便　　下贱之业弃舍已
  智者知已作上业　　一切诸佛所赞叹

尔时弥勒菩萨白佛言。世尊。彼诸菩萨。缺少智慧心意狭劣。正等勤劳舍最胜法而作小业。佛言。弥勒我今告汝我今敕汝。彼等菩萨不依佛教出家故。即不能灭。无禅定无有读诵不求多闻。复次弥勒。诸如来教灭智行作智智。具足勤劳故能辩知。不可以俗业校量而知。此非勤劳者。乐闻生死流转者。所谓检挍世间所造作世间财购。于中菩萨不得慕羡。弥勒。假使检挍勤劳菩萨。作七宝塔满此三千大千世界。不能令我欢欣。非供养我非承事我。弥勒。若有菩萨。乃至一四句偈。受持诵习与波罗蜜相应者。彼当令我欢欣。当供养我当承事我。所以者何。弥勒。以多闻故。诸如来菩提不取诸物故。弥勒。若有菩萨勤劳事业者。于勤修读诵菩萨之所而为恼乱者。令修事业多致罪障无有福聚。所以者何。三种胜福皆因智起。以是故勤劳事业菩萨。于勤读诵诸菩萨等不应障碍。弥勒。譬如阎浮提营事业者皆满于中。其数无量。于勤诵念一菩萨所应勤给事。譬如阎浮提勤诵念诸菩萨等皆满其中。应当给事一禅定者。我如是说彼等菩萨善能给事。彼人已作无量福聚。所以者何。是最为得所谓第一义智慧相应。证知无有上故一切世间最上最胜最高。弥勒。以是故欲取当禅定精进者。应习智业应当求生般若住处

尔时弥勒菩萨白佛言。世尊。已为诸菩萨。说乐世间言话诸患。乐多言话乐多睡眠。乐造多业诸患。世尊。菩萨当云何观乐戏论。如所观已。当趣寂静行。佛言弥勒。其戏论者。略说有二十种过应当观察。若广说者则有无边。何等二十。弥勒。多戏论菩萨现见法中多不乐行。于忍辱中而复减少。熏习嗔恚。未生善根能令不生。已生善根能令减损。当有诤斗怨仇。当得短命趣不端正言语吃涩。若他教法于心不住。未说经法而不现前。诸善知识皆悉远离。于恶知识当速和合。当入苦道于一切时闻不戏言。所生之处恒堕疑网近于八难。白净法中勤求学处多有障碍。弥勒。如是等比说二十种诸患。为多戏论菩萨。尔时世尊欲重宣此义。而说偈言

  现法得苦心不乐　　远于忍辱助嗔恚
  彼彼怨家常欢欣　　行戏论者有斯患
  恶黑魔罗为彼喜　　魔家眷属亦复然
  所有善处皆弃舍　　行戏论者有斯患
  所欲作彼诸善行　　彼以放逸故不住
  彼以放逸向恶道　　行戏论者有斯患
  以无信故心难伏　　生下贱家常被轻
  彼之舌根常蹇吃　　行戏论者有斯患
  为其说法而不住　　是故彼法不现前
  诸善知识皆离彼　　行戏论者有斯患
  于诸恶业恒和合　　于诸乘中极难净
  闻于法言意不乐　　行戏论者有斯患
  彼于诸善多障碍　　于诸行中多怨仇
  彼发勤时多有障　　行戏论者有斯患
  如是诸患智者知　　一切戏论应当舍
  戏论行者道难得　　是故不应住戏论
  走避由旬复由旬　　所有戏论及诤竞
  我今不能独住此　　须臾之间烦恼处
  我今出家求利德　　莫作诤竞生恶心
  无有田地及商估　　为何事故起诤斗
  妻与儿子及奴婢　　无有家宅诸财等
  彼无奴仆自在处　　既出家已莫诤竞
  既着袈裟衣服已　　寂静诸仙所印可
  汝等具足是功德　　舍於戏论当生忍
  心如毒蛇及罗刹　　当生地狱鬼畜生
  戏论行者得不难　　故于解脱生精进
  所有诸苦害缚处　　怨仇呵责打缚等
  和合聚集相诤论　　世间所有皆住此
  若有和合怨难得　　和合之者增名闻
  和合之者得相爱　　何有智者不和合
  伺求过者不得便　　眷属不曾相破坏
  彼诸朋友不离散　　远离戏论得顺教
  安乐乘中当得净　　得脱业障无有余
  降伏魔罗及军众　　被他诽毁当生忍
  若有戏论多诸患　　无戏论者德难量
  我能示现如是等　　欲得菩提当生忍

尔时弥勒菩萨白佛言。希有世尊。乃至如来。说此发觉诸烦恼。世尊。颇有此等诸菩萨。于后闻此如是发觉诸烦恼。当作厌以不。于烦恼行中当能断以不。佛告弥勒菩萨言。弥勒。于未来世当少有菩萨乘行富伽罗。若于后五百世时。当断烦恼行。多有刚强心体无敬我慢自高。作诸分别不能修习。是故魔波旬作比丘形来。在彼等前作如是破坏。此等修多罗他家文章。非是如来所说。所以者何。于此修多罗所说诸功德无有彼我。然彼徒众被破已。如来所说诸修多罗中。当作疑惑当起诤竞。不肯受持亦不为他说亦不修习。然彼等痴人不作如是知。此是诸业果报。我等当不能证如是功德。尔时弥勒菩萨白佛言。世尊。如来叹阿弥多如来十种发心。于中各随念发。若念当欲生彼当即得生彼。世尊。何者是十种发心于彼处生。佛告弥勒言。彼等发心非少智者。有彼发心是大事者。所有欲生阿弥陀刹中者。当为一切众生发慈悲心不生嗔恨。当生阿弥陀如来佛刹。为一切众生生慈悲心故当生彼处。离于杀害受持正法。发此心故当生彼处。舍于身命发心。不着一切诸法故当生于彼处。发甚深忍行清净信。发此心故当生彼处。不染名闻利养一切智宝。发此心故当生彼处。为一切众生生贵敬。发心不忘失故当生彼处。不惊不怖不爱凡言语。发此心故当生彼处。入菩提分种种善根。发此心故当生彼处。然不离念佛。发此心故当生彼处。远离诸相故。弥勒。此十种发心。若菩萨各发念一具足者。当往生彼阿弥陀佛刹中。若不生者无有是处。尔时长老阿难白佛言。希有世尊。乃至如来说此法本为诸菩萨发觉。尔时世尊。赞长老阿难言。善哉善哉。阿难。是故菩萨于此法本发觉当如是持。佛说此经时。弥勒菩萨及长老阿难。欢喜踊跃。彼六十菩萨乘行诸善男子等。皆悉灭彼业障。欢喜奉行作礼而去

发觉净心经卷下


法镜经

    No. 322 [Nos. 310(19), 323]

    法镜经序

夫心者众法之原。臧否之根。同出异名。祸福分流。以身为车。以家为国。周旋十方。禀无倦息。家欲难足。由海吞流。火之获新。六邪之残。已甚于蒺[卄/梨]田之贼鱼矣。女人佞等三魅。其善为而信置。斯家之为祸也。尊邪[病-丙+歲]。贱清真。连丛琐。谤圣贤。兴狱讼。丧九亲。家之所由矣。是以上士。耻其秽浊其广。为之慑慑如也。默思遁迈。由明哲之避无道矣。鬄发毁容。法服弥为。靖处庙堂。练情攘[病-丙+歲]。怀道宣德。开导聋瞽。或有隐处山泽。枕石漱流。专心涤垢。神与道俱。志寂齐平。无名明化用也。群生贤圣竞于清净。称斯道曰大明。故曰法镜。骑都尉安玄。临淮严浮调。斯二贤者。年在束龀弘志圣业。钩深致远。穷神达幽。愍世蒙惑。不睹大雅。竭思释传。斯经景摸。都尉口陈。严调笔受。言既稽古。义文微妙。然时于戈未戢。志士莫敢或遑。天道陵迟。内学者寡。会睹其景化。可以缘涂炭之尤崄。然义拥而不达。因闲竭愚。为之法义。丧师历载。莫由重质。心愤口悱。亭笔怆如。追远慕圣。涕泗并流。今记识阙疑。俟后明哲。庶有畅成。以显三宝矣

法镜经

        后汉安息国骑都尉安玄译

闻如是。一时众祐。游于闻物国胜氏之树给孤独聚园。与大众除馑千二百五十人俱。及五百开士。慈氏。敬首。始弃。窥音。开士之上首者也。彼时若干百众。围累侧塞。众祐而为说经。尔时闻物城中有理家名甚。与五百众。从闻物城中出。往到胜树给孤独聚园。诣众祐所。到以首礼众祐足。便就座而坐。及理家有字爱遇。有字乃遇。有字善授。有字大威。有字给孤独聚。有字龙威。有字谛思。斯一切五百众等。共往诣佛所。到以首礼众祐足。皆于众祐前就座而坐。其诸理家。一切以发求大道。皆与其众共造德本。有决于无上正真道。惟给孤独聚不耳。于是甚理家以见大众理家集会坐定。避坐而起。整衣服稽首长跪。叉手白言。已欲有所问。要者众祐岂有闲暇。数演己所问。众祐报甚理家言。如来常为理家有闲暇。敷演所问。理家汝便问。恣汝所求索于如来应仪正真道。吾当相为敷演所问趣得汝意。甚理家问佛言。于是要者众祐。若族姓男女。发意求无上正真道。好喜大道。发行大道。欲致大道。欲下大道。欲知大道。请命一切众生。安慰众生救护众生。其誓曰。未度者吾当度之。未脱者吾当脱之。不安隐者当慰安之。未灭度者吾当灭度之。为受一切众生重任。欲救护众生故。而自誓发斯弘大之誓。知生死若干多恶恶意如不倦。生死无数劫意而不邂。彼要者众祐。或有开士。去家为道。以致道品之法。或有居家者。善哉要者众祐。愍伤众生亦加惠。此大道者。以兴隆三宝。亦使一切敏典籍久在故。如来愿说开士居家者学德之法。何谓要者众祐。开士居家。而承用如来教诲者。以不亏亦不损。其本所愿。所谓无上正真道也。亦现世有无罪之行。后世往殊胜之道。亦被要者众祐。开士去家为道者。捐弃憎受。除鬄须发。被服法衣。在家有信。离家为道。示其教诲。法式正式德式具现之。要者众祐。开士去家为道者。及居家者。修之云何。于是众祐。叹甚理家曰。善哉善哉理家。今汝乃知。问如来居家去家开士之所施行。是以理家且听我所说。勉进善思念之。开士居家为道者。修学德善之行。甚理家受教而听。众祐言。于是理家。开士居家为道者。当以自归于佛。自归于法。自归于众。彼以自归之德本。变为无上正真道。理家。自归于佛法众者。云何我当以成就佛身。三十二大士之相以自严饰。亦以其诸德本。而致三十二大士之相。以致彼诸德本。便而精进行之。开士居家者。自归于佛。为如是也。自归于法者云何。谓为恭敬法。求法欲法。乐法之乐。法隆法依。法护法慎。如法住。随法术。为法典。为法力。为求法财。为法静治。为造法事。我亦当天上世间分布是法。开士居家者。自归于法为如是也。自归于众者云何。若开士居家。或见沟港。或见频来。或见不还。或见应仪。或见凡人求弟子道者。为恭敬彼。承事供养。师之尊之。以礼待之。若以承事彼正法正术者。而以得是志。亦我当得无上正真道。以讲授经。成就弟子之德。而为恭敬彼。不亦而羡彼。开士居家者。自归于众。为如是也

又复理家。开士以修治四法为自归于佛。何谓四。一曰道意者终而不离。二曰所受者终而不犯。三曰大悲哀者终而不断。四曰异道者终而不为也。是为四法。开士居家者。自归于佛为如是也。又复理家。修治四法为自归于法。何谓四。一曰诸法言之士。以承事追随之。二曰所闻法以恭敬之。三曰已闻法本末思惟之。四曰如其所闻法。随其能为人分别说之。是为四法。开士居家者。自归于法为如是也。又复理家。修治四法为自归于众。何谓四。一曰末下要生弟子之道。而意以喜一切敏。二曰亦以为积聚物以法积聚而化之。三曰以有依恃有决之众。而不依恃弟子之众。四曰求索弟子之德。不以其德度而度也。是为四法。开士居家者。自归于众为如是也。又复理家。在家修道。以见如来则行思念佛。是为自归于佛。已闻法则已思念法。是为自归于法。若已见如来圣众。犹思念其道意者。是为自归于众

又复理家。在家修道。发求遭遇佛而以布施。为自归于佛。若以拥护正法而已布施。是为自归于法。若已其布施。为致无上正真道。为自归于僧。又复理家。在家修道者。若修贤夫之行。行不以凡夫之行。彼是贤夫之行也。而以法求财。不以非法。以正不以邪。亦而为正命。不以娆固人以法致之。财多行非常想。以受其宝。是以恒隆。施而供养。父母知识。臣下毗弟。亲属为以敬之。奴客侍者。瞻视调均。亦以教化。斯殊法亦以受重任。是谓众生重任也。精进而不懈。不受之重任。而以不受之。谓是弟子各佛智之事。成就众生而不倦。不慕身之乐。为致众生乐。利衰毁誉称讥苦乐不以倾动。以殊趣世间法。富有财不喜悦。又于三道。无利无称。无誉声

无赏。所行为熟虑。受正为喜悦。邪受见知。要意而有正行称誉之两。以除解已。得其所誓。以忧人事。不自忽其事。有恩在人。讫终不望其报。作恩施若干。知恩知反。复为造行恩德。贫者为施财。诸恐畏者为安隐之。忧戚者宽解其忧。无力者忍默之。诸豪强者损憍慢。以弃殊过慢尤。慢以恭敬尊长。承事多闻者。能问明知者。所现以直不虚饰。众人而有方便。行德而可求哉。为多闻不厌无足。正修勤力。固与圣人相遭。追随圣人而尊敬之。多闻者为事之。知者为问之。所以现直不师。秘众经如其所闻。为现之所闻。而晓其义。一切欲之嬉乐。为计非常。不慕惜身。以自观其寿如朝露之渧。计财产所有如幻云也。家属人客计为怨。妻子男女。计为无择之地狱。以其所有者。计为一切苦。田地舍宅万物所业者。常以计为疵也。所求致之德。为不败坏想家居者为危想。知识臣下毗弟亲属者。为地狱主者想。终日夜者为之同想。以不实之身。为以受实想。以不实之寿。为受实寿。以不实之财。为受实之想。彼若以礼节众事敬事人者。是以不实之身。为受实也。若昔众德之本而不毁。又复增殊者。是以不实之命。以为受实也。是若以制悭。而布恩施德者。是以不实之财。为以受实也是为开士居家修道者。为贤夫之行。为事。如是而无罪也。为如来言说为法说也。亦不毁而不损其本誓。是谓无上正真之道也。乃现世有无罪之行。后世亦堕殊胜之道也。又复理家。开士居家修道者。当以自奉持戒事。谓是奉持五戒事也。是以为不好杀生。不加刀杖蠕动之类。不以娆固人。是以不好盗窃人物。自有财而知足。他人财不以思。至于几微草[病-丙+歲]之属。不与终而不取。是以为不好欲之邪行。自有妻而知足。他妇女不喜眼视也。意常以自患已。思念欲都为苦。如使生欲念。自于其妻。则以观恶露。以恐怖之念。劳为欲之事。以无畏不苦。以慕恋不常。净乐想达志。乃如是我当以自修。若以思想欲。我以不为之。何况数数有。是以为不当好妄言。以谛言诚言。以不伪诈性。以不败心如有诚。如其所见闻而说之。慎护经法。不用躯命。故以不妄言。是以不当好饮酒。以不醉不迷惑不急疾。以无罚而顺化。强志以正知。如使复兴布施意可。所有一切吾当与人。求食与食。求饮与饮。求车与车。求衣与衣。是以与人酒以建志。如是布施度无极。为是时若有人所索。则而为与。时我能以酒施。令从彼化志。如以自知为行不迷惑。所以然者何。夫开士者。为众生周满其所愿。布施度无极。一已如是。开士居家者以酒施人。而为不获罪。是以理家。开士以其所修学之德本。变为无上正真道。若以善修慎护斯五戒矣。又当有殊者。不当以相谗众人。纷诤者而以和协之。以为不粗言。以柔软之言。恒先与人言。亦不以绮语。为义说。为法说。为时说。为如事说。亦不有痴网。而以安隐加施众生。意为不败乱。恒以忍辱力而自严。以为用正见。去离邪见。犹为稽首诸佛众祐。不为他天神也。又复理家。居家修道者。或在墟聚郡县国邑下。当于彼拥护经法。拥护经者为之奈何。夫不信者以信教化之。悭贪者以施教化之。恶戒者以戒教化之。乱意者以忍事教化之。懈怠者以精进教化之。失志者以思惟教化之。邪知以智事教化之。贫财者以富之。诸病者以药施之。孤独者以为家属。无归者以为归。无依者以为依。为彼一切国邑坏者。拥护经法为若此

理家。或彼开士。至一至二。至三至于百。教诲人民。皆使修众德之法。彼开士便以悲哀加于众生。以强其一切繁誓之。誓其辞曰。至于斯难化之人民未得成就者。吾终不取无上正真道。所以者何。今我以为斯故。以誓自誓也。吾不为质直者。不以不佞谄者。不以不为诈者。不以守者。不以诫有德者。诸此人故。以誓而自誓也。但为欲使斯人以闻经法者。以经化。余用此故。以誓而自誓也。我当恒以强其精进行所。我方便为不唐苦也。若人有见者。莫不以好信。若理家。至于开士所在家居。止其不嗟一切之人民堕殊异之恶道者。彼为开士之咎。理家譬如乡亭鄹邑郡县国下。至于有良医者。假使彼若有一人不以其寿命而终者。众人皆为咎彼医。如是理家。至于开士所居。止不嗟一切之人皆堕殊异之恶道者。如来应仪正真觉者。为咎彼开士也。理家。是故居家开士为自誓如此也。设使我所往国邑下痴者相事。如不使一人有堕恶道者也。又复理家。居家修道者。当晓家之恶。在于家者。为害一切众善之本。以家犹无出要。以害清净之法。是故谓为家也。居家者。谓为居于一切众劳。为居众恶之念。为居众恶之行。不化不自守。愚凡人者为共居。与不谛人集会。是故谓为家也。家者为是名也。已在于彼。莫不作不轨之事者。以在于彼。则不恭敬。自于父母息心逝心尊长众圣者。是故谓为家也。县官牢狱考掠搒笞骂詈数勉至于死焉皆为由彼。是故谓为家也。以在于彼为入恶道。以在彼为堕诸欲。为堕嗔恚。为在诸畏。为在愚痴。是谓为家也。以不慎护彼戒事。远离为定事。以不修慧之事。不得度之事。以不生度知见之事。是故谓为家也。以在于彼。即有父母爱。兄弟爱姊妹爱。妇爱子爱。舍宅爱财产爱。儿客爱所有爱。不厌财求之爱。是故谓为家也。斯居家者难满哉。譬若大海众流归之。斯居家者不知厌哉。譬若火以得薪。斯居家者。多念无住息哉。譬若风以为无住止。犹为沉没哉。若美饮食为糅毒。所有一切苦哉。譬若仇怨。为似知识。误人之行哉。非圣经之所施行。为造变争哉。更相因缘恒不和。为多疵哉。以行善恶之行。因缘之所在。恒为人所嫌疑。非人有哉。以为所有颠倒故。犹不善哉。虽善有权诈。犹见其性行。似如倡体哉。以速转变故。似若幻师哉。初至者人为聚会其行为不诚。似若梦哉。一切成败终始故。似若朝露哉。以速离故。似若蜜渧哉。以为少味故。似若蒺[卄/梨]网哉。色声香味细滑以为所害故。似若针孔虫哉。以非善念为食故。譬若违命者哉。为转相欺故。恒怀恐怖哉。为意以乱故。为多共哉。以县官盗贼怨家弊恶王者为害也。斯居家者。少味乐哉。以为多恶失。理家。开士居家者。为晓家之恶若此。又复理家。居家修道者。以布施为宝施。若已施为我有。若在家非我有。若已施是为宝。若在家是为非宝。若已施为富财。若在家为无财。若已施为劳解。其在家为劳增。若已施为不我。若在家已为我。若已施为不有。若在家以为有。若以施为无尽。若在家为非常。若已施不复护。若在家为斯护。若已施为贤夫行。若在家为凡夫之意。若已施为依度道。若在家为依邪部。若已施为佛所称。若在家为愚人所称。理家。开士居家修道者。以布施为宝若此。是以见人来有所求索者。为生三想。何谓三。善友想。依度道想。勉生富财想。为生是三想。为复造三想。何谓三。尊如来教诫想。降伏邪想。以不望福德想。所以者何。若此开士。若诸来有所索者。贪淫嗔恚愚痴则以为薄。薄者为之奈何。若所有物。一切不惜。而以布施。斯为贪淫薄。若于彼来求物者。以慈哀加之。斯为嗔恚薄。若以布施变为此一切敏。谓为愚痴薄。又复理家。已见来求物者。不久为成六度无极之行。又成彼者云何。若有来人从人索物。能不爱惜者。是为布施度无极。若意在道而布施者。是为以戒度无极。若不恚怒之。是为忍度无极。假令犹自思念。何用为食。自强其意。不释其行。是为精进度无极。若欲施若已施。而不郁毒无有悔者。是为思惟度无极。若已施不望其福德者。是为以慧度无极。理家。开士以布施为成六度无极行若此。又复理家。居在家者。是以为去离顺随忿乱以亲别离法。若以得产。得财米谷。得男女。不以为喜悦。若一切败亡。不以下意为愁戚。已观如是万物如幻。为不住止想也。斯幻之行。以致是。是以父母妻子奴婢儿客。是非我之有。我亦不是有。亦我是不有。我不应是有。以不我是有。今我为彼故。而为作罪恶。但现世是有。非是为后世。是昔之有。非是我当护。又夫我之有。彼我当以护。何谓我之有。谓是布施教化。恬淡自守道之根原。亦藏隐之德本。是为我有也。至于我所住。是则为追我。彼亦不用躯命。不为男女妻子故。为造恶行也。是以居在家。自有妇者。当造三想。何谓三。非常想。不久想。别离想。是三想当为造想。当复造三想。何谓三。若在喜乐为求后世在苦。若在饮食为求在殃罪。若在乐者为求在苦。当为造是三想。当复造三想。何谓三。重累想。费耗想。俗所有想。当为造是三想。当复造三想。何谓三。为入地狱想。入畜生想。入神鬼想。当为造是三想。当复造三想。何谓三。魑魅想。臼注想。色像想。为造是三想。当复造三想。何谓三。不我想。无主想。假借喻想。当为造是三想。理家思念。若此众事想。开士居家者。当自观身其妻若此也。是以不当爱其子。设使无生子爱。不加于天下人。是以当以三数谏。自谏其意。何等为三。等意者为道。不以邪意也。正行者为道。不以邪行。不多行者为道。多行者非矣。是以三数谏。自数谏其意。自造其子怨仇想。是我怨仇非我友。所以者何。我以由彼违失慈哀佛之教诫。使我甚益生彼爱。人自磋切其意。如爱在其子。以爱加众生。若其自爱身。以慈哀加众生。是以当观其本末。斯所从来异。我所从来亦异。众生先世亦曾为我子。吾亦曾为众生子。是生死之愆。无可适莫者。所以者何。所往来道。辄有离行。转复为仇怨。我今当自修。都使我无友。亦我无怨仇。所以然者何。以造有知识。为复欲多作以造有怨仇。都以欲为恶。一切众生彼非我。汝意不可以可。不可之意可。以悉通众经。所以者何。正行者得正道。邪行者得邪道。今我不有邪行。于众生有正意行。乃可得一切敏故

理家。开士居家者。都物无可恋。无可慕。无可适。无可爱。无可可。为若此也。又复理家。居家者。设使人来有所索。假使为不欲与彼物。犹当以自谏数其意。假令我不以是物施者。我会当与此物离也。若欲不欲至于死时。是物亦当捐弃我。我亦当捐弃是。其施宝而终。我而施是物。死时意除止。设使思惟若此。而不能施彼物者。是以四辞谢。辞谢来索物者。何谓四。我以无力众德未成就。我在大道为初始。布施意而不自由。我有受见。在于我余之行。且相假原贤者勿相逼迫。我所施行能奉行之。如其所受。尔乃能满卿所愿。及天下人辞谢彼来索物者。为若此也。又复理家。居家修道者。假使为离师者之教诲。时世无佛。无见经者。不与圣众相遭遇。是以当稽首十方诸佛。亦彼前世求道所行。志愿之弘。愿者其一切成就佛法之德。以思念之以代其喜。于是昼三亦夜三。以论三品经事。一切前世所施行恶。以自首诲。改往修来。为求哀于一切佛。以法故愍伤之。亦以无央数无极之法愍伤之。又复理家。居家修道者。当以晓息心之仪式。是以若见除馑殊越息心之仪式。当为敬其法衣。彼为众祐如来应仪正真佛戒定慧所行之法服也。以无恶为离一切恶。彼是众圣仙者之表式也。是以又当为敬彼也。亦当加愍伤于彼除馑。斯非贤为此不轨行。至于被服。斯名静者调者神通者。如来者表识而为不调净之行。又如来复曰。未学者不当忽易。非此彼遇劳过也。以从斯劳为有失。若此彼亦见佛宪教之要。如所谓事次应有之。若此捐弃是劳。观其本末为护第一德。必为在正以知乎将断劳之智。如众祐。所谓又士不可以相忽蔑。是非时如来有。是知非我有。是以不嗔不怒不恚为加彼。若以入庙者。以住庙门外。以五体而稽首。乃却入庙。彼是空庙之居。彼是慈哀喜护庙之居。彼是正住在正次者之居。为彼得斯。使我得庙居。为若此以远去官位家者。为彼得斯。我以斋戒罪。乃禁制制以若此。为与去家之意。未曾有开士在家为得道者。皆去家入山泽。以往山泽为得道。以讥家居者。夫去家智者所称誉。如江河沙。我一日之祠礼。一切彼布施以去家之意为殊胜。所以者何。以施下劣故。何况布施不信无反复。盗贼弊恶。王者及大臣。非彼布施以为实以得。足以我有戒闻之行。是以入庙者。当以观视一切除馑之众所施行。何等除馑为多闻。何为明经者。何为奉律者。何为奉使者。何为开士奉藏者。何为山泽者。何为行受供者。何为思惟者。何为道行者。何为开士道者。何为佐助者。何为主事者。以观视彼一切余馑之众所施行。如其所施行行。以随效为之为行。不当转相嫉。若于虚聚言有及庙。若于庙言及虚聚。是以当慎守言行。不当以庙中言说于虚聚。亦不当以虚聚言说于庙也。是以承事多闻者。以为修治闻。奉事明经者。为解经之决事。承事奉律者。为解度殃罪之事。承事开士奉奥藏者。为明六度无极方便之事。若有除馑者。为乏应器。或乏法衣者。当以给施之。莫使生嫉于人也。所以者何。夫人以嫉妒为结。是以当力护凡人不应仪者。所以者何。凡人者为有失。应仪者为无失。若有除馑者。未下正道。或积聚法衣。或积聚应器。是以彼除馑。用无上正真道开导之。所以者何。其事有应。是以积聚物为致道。积若息心有不和者。当和解之。若正法欲衰微者。自危殆其身命。以营护正法。若见除馑疾苦者。以血肉使其病者得除愈。理家。若居家开士。若不布施。不以禁止人。若以施终不悔恨。若有众德本。以是意为端首。理家。若此诸事诸类诸应。开士居家修道者。为若此也。又众祐当说此居家开士所施行教诲法宪时。有千人皆发意求无上正真道。复有天与人二千人。远尘离垢诸法法眼生。于是甚理家。白众祐言。要者众祐。如来以敷演居家开士者家善恶之地。亦布施持戒忍辱精进思惟智慧。于是大道当所施行。要者众祐。去家修道开士者之所施行。愿复几微现之为善。要者众祐。开士去家者。为之奈何。其所施行亦云何。众祐告甚理家曰。善哉理家。今汝乃以问如来开士去家修道者之所施行。善哉理家。当为汝说开士去家之事。其所施行。汝勉进善思念之。甚理家受教。从众祐而听。众祐曰。理家。开士去家修道者。若头烧然。譬若铠为精进以求智。去家者其初始为若此。次修治为圣典。又何谓去家者之圣典。所谓趣得一衣为足。亦以善之。一食一床。病瘦一医药为足。亦以善之。是为圣典。何以故谓之为圣典。以为修治彼一切道品法。是故谓之为圣典。又开士去家修道者。为有十知足之德。身以服法衣。何等为十。以为羞惭故。身服法衣。以避风暑故。身服法衣。以辟蚊虻蟆子故。身服法衣。欲以见息心形状故。身服法衣。亦是法衣之神为十方之神故。身以服法衣。以患离淫乐。是以不乐淫之乐。以乐安得净。是以除断众劳之乐。不以肥[月*由]。为是道行。行在圣道重任。我亦以自修。如以一时有法衣。如被服法衣故。以是十德。自观至于寿终。闲居静处。以不行丐。何等为十。我自以我业而为命。不以非异业。若有人来施我者。以先修治三宝。后乃而受其施。我若欲从人乞丐。若不欲施人者。以非哀加彼己也。我当自食所修行之食。以为不违如来之言诲。以得成知足重任之本。以降憍慢。以得成无见顶之德本。我亦见布施。亦如以自教。若往行乞丐。我亦不得有所适莫于男女。以我等意。于天下人。以得成一切敏智之重任。是理家十德。去家开士者。以自观至于寿终。闲居静处。以不行丐。若有人来请者所住处。其人志意信喜道者。我不宜当彼往。设使往食若能以自益。亦能益人者。可往受施。我教开士可彼索。是为十德。以自观可以处于树下坐宿止。何等为十。以其自由为往彼。以不名有彼床卧。以不闭门。于山泽以去离爱为彼居。以少欲少事为成德。捐弃躯命以不自惜。乐独静以远离恋聚会。以行修身不食。以定意为安静一意。闲处思惟为无益。是理家十德。以自观开士去家者。为可处于树下居止。又复理家。或彼开士去家。修道游于山泽者。若欲修治经。若用诵利经。故为入庙。若居庙者。意向以山泽为居。是犹为彼山泽居也。求法之行者。为一切物不我想。一切诸法。为他人有想。又开士去家修道者。若游在山泽。当自省察。我今何以游此山泽中。不但以山泽居。谓之息心也。所以者何。此间多有不化不守不度不应不修行者。皆游山泽。所谓禽兽众鸟。猕猴[狂-王+加]玃。恶人贼盗。皆游于山泽。亦不谓彼为息心也。至于我所求山泽居者。当以成我彼所求为是息心求。亦又何故开士息心。所谓志以为不乱。为以得是。持周满达事故。以闻为无足。以得辩辞。以慈心不亏大哀。以不离专由于五通。兴隆六度无极却。一切敏之。意不择舍。为行权谋之慧。以法施合聚人民。成就人民四合聚之事。为不择舍六可思念之。以闻精进不亏损。为择法本末正度之道因缘。智亦不入正道之事。为护正法之事。以信罪福为正见。思虑所务以亏断为正思。随所喜为说法为正言。随行尽之备足为正业。瘕疵之续以除断为正命。以道臻到为正方便。以不忘忽为正志。一切敏智之臻到为正定。若以空为不想之行喜。若以得不顾为断俗。所有依其义不以文。依其法不以人。依其智不以识。本文演义归。不以末叙义。斯理家谓为开士去家者息心求也。又去家修道者。不当以多从事。若此思惟其本末故。当为一切众生不与之从事。明哲不但与一人不从事也。又有四。是去家开士者之从事也。如来之所教。何谓四。一曰与讲经者从事。二曰与就人者从事。三曰与供养如来者从事。四曰与发一切敏意不乱者从事。离彼不当以多从事。又开士游于山泽者。当自揆察。我为何故来至于此。彼是思惟。我以恐畏来至此。何谓恐畏此群聚。恐畏与人从事淫怒痴憍慢自恣。恐畏恶友。恐畏嫉悭。恐畏色声香味细滑。恐畏功称恭敬利。恐畏不见言见。不闻言闻。不知言知。不解言解。恐畏息心垢。恐畏更相嫉妒。恐畏生死五道往来所堕。恐畏欲界色界无色界。恐畏阴耶死耶。劳耶天子耶。恐畏恶道地狱畜生鬼神。恐畏仓卒一切是众恶之念。我来到此不可以此居在于家。若在群聚之中。行不应道之行。不得免彼众恐之事。亦彼昔开士得免度众畏者。彼一切已居山泽之力势。得臻到无畏。是谓自然。是故我以恐畏。欲越度众畏。为居山泽矣。又一切是畏皆由身之生。以慕恋身以修身。以是身以爱身。以盛身以思身。以见身以处身。以想身以护身之所生也。假使由于山泽居。为以有由身之意。慕恋身修身。是身爱身。思身见身。处身想身。有身护身之意者。我空为居山泽耳。又居山泽者。为无身想。居山泽者无异想。居山泽者。不见论义。不修自见身。无在颠倒。无有无为想。何况有劳想。居山泽者。名曰一切诸法寂然哉。诸法无所著哉。诸乐亦无所著哉。诸想以不爱哉。色声香味细滑不与错忤哉。诸定不以怙哉。意以自整不乱哉。以下诸重担之畏哉。以度夫汪洋之泽哉。夫圣之典以造哉。奸恶之属悉知足哉。为重任少欲哉。以智慧知足哉。为知足哉。为知足哉。为重任少欲哉。为应哉。本末行以解哉。为一切狱断所修事讫哉。以为永解除。理家。譬如山泽中有树木草秽之属。都无可畏。都无可恐。如是理家。开士游于山泽者。执志当如草木墙石之喻。身以受行之。彼谁畏者。彼以恐怖思惟身本末。我都无身。非人非命。非丈夫非类。非女非先。无先无造者。无教造者。无与者。无兴起者。诸是之畏。但以不成之想。有是畏耳。今我宜不造不成之想。有是畏耳。今我不宜造不成之想。当如树木草秽之属。亦为若此。无响以解一切。彼法以具行之。以响断山泽居。去离淫尘。无诸响山泽居。非我非有物者。又游于山泽者。以复思惟。是通达道品之法者。以居山泽。居山泽者。为合聚十二精。居山泽者解诸谛。居山泽者知诸阴。以滑制诸情。以禽诸进入。不忘忽道之意。诸佛所赞。众圣所称誉。欲度世者所事也。居山泽者。以解一切敏智之方术也又游于山泽者。以为不久周满六度无极之行。得彼者云何游于山泽者。若不自惜其躯命者。是为布施度无极。若以依精之德。为成三慎者。是为戒度无极。若意不乱。亦可是一切敏不异道者。是为忍辱度无极行。至于未得忍终而不起者。是为精进度无极。若以得一心不以从致敏哉。但以隆德本。是为一心度无极。若见如山泽道亦为若此。以分别众事者。是为以智慧度无极。开示以道得。又复理家。修治四法。我以教开士居山泽。何谓四。或有开士。多闻明于法决者。若以其闻行在本末法。可居于山泽。又开士以得五通。欲以成就天龙鬼神者。可居于山泽。或有开士劳盛者。彼以不从事劳即为薄。可居于山泽。亦欲抑制劳。以自劝励。是以皆由闻。夫游彼者。以得周满一切清净法。乃后以下墟聚。郡县国邑。下为众人。讲授法。修治法。若此也。理家。我教开士居山泽也。又去家修道者。游于山泽。以修治经。诵习经故。入众者以执恭敬亦谦逊。夫师友讲授者。伥中少年者。为以尊之。不以懈怠自所修。以不废人所修。亦不以求承事恭敬。若此当以观察。如来应仪正真佛者。为诸梵释天人众生所供养。为天上天下尊者福田。彼尚不求人承事也。自作事不欲烦人。何况余者。未以学甫欲学。反欲人承事耶。又我当为天下人养者。我当以供养人。都不我从人求供养。所以者何。以供养重者。理家。除馑者不得法之助供养故。为助我不以法故。夫欲以为法助人者。以为若此。以是供养故。为助我不以法故。彼以自怀已正信。以为有供养。彼即与世物杂。为不是大祐人者。是以若欲往诣佛师友者。所以身意行有决。乃可往慕。我教者师友。以异之行无过。以不诃问讽起诵习。为教诲之积聚。是以欲讽起经。为不用躯命。慕乐法随顺师意。以求法利。不为求一切恭敬称誉之利。若以从师受几微四句之颂。以讽诵之。若以在布施持戒忍辱精进思惟智慧。而以彼供养师者。如其所修。四句颂之字数。为劫之数。以供养彼师者。尚未为卒师之敬。亦以质直不虚饰不佞谄。一切行之供养。岂复谓法之敬。又理家。若斯意念生。以有德之意。有佛亦法之意。有自患离淫之意。有寂静之意。若以修治四句之颂。遵而行之。如其劫数。彼以供养其师者。尚未为卒法之敬。理家。当以知此之事。若此也。法之福德如无数。获智亦无量。是故开士。欲以择上法。犹以无数为敬正法。若彼思惟。若此以闻净戒事。何谓是净戒事。去家开士者。有四净戒事。一曰造圣之典。二曰慕乐精进德。三曰不与家居去家者从事。四曰不谀谄山泽居。是为去家开士者四净戒事也。复有四净戒事。何谓四。以守慎身身无挂碍。以守慎言言无挂碍。以守慎心心无挂碍。去离邪疑造一切敏意。是为去家开士者四净戒事。复有四净戒事。何等为四。一曰以自识知。二曰以不自贡高。三曰以不形相人。四曰以不谤毁人。是为去家开士者四净戒事也。复有四净戒事。何谓四。一曰已可诸阴为幻法。二曰以可诸情为法情。三曰以可诸入为虚聚。四曰不随方俗之仪式。是为理家去家开士者四净戒事。复有四净戒事。何等四。一曰以不自计我。二曰远离是我有。三曰断绝常在除。四曰以下因缘法是为去家开士者四净戒事。复有四净戒事。何谓四。一曰以解空。二曰以无想不怖。三曰以大悲众人。四曰以为可非身。是为去家开士者四净戒事。彼以为常闻净定以故。以若此观之。何谓此净定。以通一切法。不为余事意行。为有决意。为一端意。为不错忤意。为以不住意。为不驰意。为自身住止意。不与情欲从事意。为以观幻之法。我若幻法情亦然。以无复行。便无可存。已履彼正。是谓正定。若法在如法。若此亦谓定。为观若此。彼常闻净慧。何谓斯慧者。诸法之择智。谓彼为慧也。不受之相无相行。不造之相无存矣。无为之相不驰骋矣。是以理家。以观法若此者。是谓去家开士之所施行也。又以说是经时。有五百人。造记无上正真之道意。又甚理家及其等。同出声言未曾有。要者众祐。至于如来之善言乃如是。亦家之恶德重任之行。亦去家诸德善斯。尊者众祐。已为明彼居家人多恶德。至于去家无数之德善已。宁可得从众祐。受去家之诫。就除馑之行。众祐报言。去家者理家难堪。能究畅淳德善。奉持教诲。理家复白佛言。众祐。去家者虽难堪任。如来犹当可己等去家为道也。众祐。便使慈氏开士。及一切行净开士听。举彼理家等慈氏开士。举二百理家。一切行净开士。举三百理家。去家修道。尔时贤者阿难。谓甚理家言。卿何见居国居家。有能乐于法去家之圣道者。甚理家报阿难曰。我不以为贪慕身乐。欲致众生乐故。我以居家耳。又如来者自明我。彼以所受坚固而居家。彼时众祐。告阿难言。阿难汝已见甚理家。如是众祐。见甚理家。阿难。于是贤劫中。以所成就人多于去家开士者。以百劫中不若此。所以者何。阿难。又去家修道开士者。千人之中不能有德乃尔。此理家者而有是德。尔时阿难白佛言。要者众祐。当何名斯经法。亦当以何奉持之。众祐言。是故汝阿难。斯经法名为居家去家之变奉持之。亦名为内性德之变奉持之。亦名为甚所问奉持之。及以闻此经法者。阿难。为周满法精进殊强。于一切威仪下精进行道者。不若此也。是故阿难。若欲以兴精进者。若欲劝励者。欲立一功德者。欲造立人众德者。由当以斯经法。以闻之以受之以行之。我以属累汝阿难。此经法数用布见众人。所以者何。众德法之正行也。阿难。斯经法者正应也。众祐。以说是。阿难欢喜。及甚理家。天与人。亦质谅王。众祐说已。皆思惟也

法镜经

    法镜经后序

序曰。夫不照明镜。不见己之形。不赞圣经。不见己之情。情有真伪。性有柔刚。志有纯猛。意有闇明。识有浅深。不能一同。不睹圣典。无以自明。佛故着经。名曰法镜。以授某等。开士之上。传教天下。有识贤良。学者通达。行者志正。疾得无上之圣。康氏谷德。博达心聪。为作注解。敷演义方。辞语雅美。粲然焕炳。遗诲后进。以开童蒙。于学有益。以为献呈。乘意绸缪。诚可嘉也。然夫上圣之妙旨。厥趣幽奥。难可究息。余察其大义。颇有乖异。惧晚学者。以此为真。而失于正义。彼此俱获其愆矣。余反覆历思。理其阙者。有七十八事。谨引众经。比定其义。庶令合应。不为疣腨。又经本字句。多渐灭除去。改易其字。而令句读不偶。音声不比。义理乖错。不相连继。甚失其宜也。夫圣上制经。言要义正。以为具备。无所玷玦。不可复增减矣。犹人之四体受之二亲。长短好丑各宿本耳。岂可复改更乎。所谓增之为疣腨。减之为槃疮者也。且夫世俗诗书礼乐。古之遗字。虽非正体。后学之徒。莫敢改易。皆尊敬古典。转相承顺矣。况乎斯经之昭昭。神圣之所制。天上天下群圣仙者。靡不稽首奉受以为明式。学者益智。行者得度。其无数焉。而斯末俗晚学之人。见闻未广。而以其私意。毁损正言。违戾经典。岂不快哉。名言学佛。而违佛教。斯复何求也。昔惟卫佛时。有人反佛名一字。后获其罪。五百世盲。蒙蒙冥冥。其[仁-二+出]久也。至释迦文佛。时其人闻圣德。故来自归。謶得救济。佛遥见呼之。其目即开。投身悔过。乞得除愈。佛言汝罪毕矣。今无他尤。观之不可不慎哉。夫人若能复心首悔。改往修来。斯亦贤者之意焉

法镜经后序


佛说阿阇贳王女阿术达菩萨经

    No. 337 [No. 310(32)]

佛说阿阇贳王女阿术达菩萨经

        西晋月氏国三藏竺法护译

闻如是。一时佛在罗阅只耆阇崛山中。与摩诃比丘僧五百人。菩萨八千。一一尊复尊。悉得陀怜尼法。在所闻知。如大海无所挂碍。悉得五旬深入微妙沤和拘舍罗。总持空法藏门。不舍志意行无色想。从法行无所归依。亦不造行。说经法无所著。为一切故自观本法。以得忍凡行十事

是时有菩萨名须弥山。复有菩萨名大须弥山。复有菩萨名须弥山顶。复有菩萨名师子。复有菩萨名和呵未。复有菩萨名常举手。复有菩萨名常下手。复有菩萨名常精进行。复有菩萨名常欢喜。复有菩萨名常忧念一切人。复有菩萨名珍宝念。复有菩萨名珍宝手。复有菩萨名宝印手。复有菩萨名执御。复有菩萨名大御。复有菩萨名常持至诚。复有菩萨名弥勒。如是等十七人。颰陀和等八人。皆如颰陀和类

颰陀和菩萨。宝满菩萨。福日兜菩萨。因提达菩萨。和伦调菩萨。常念菩萨。念益于世间菩萨。增益世间功德菩萨。如是等八人

尔时佛与八千菩萨俱。在罗阅只去城不远。为国王大臣。所敬偶所遵奉所称誉。视若如父婆罗门迦罗越所尊重。尔时佛于无央数大众中说经法。所说上语亦善。中语亦善。下语亦善。所说莫不开发。上中下皆晓了。悉具足无沾污。精进无量于时舍利弗摩诃目揵连。摩诃迦叶。须菩提。邠耨。罗云。蠡越。安波臾。忧波离。阿难。如是复异方不可计是辈。大比丘僧不可计。平旦正衣服持钵。入罗阅大城分卫。是尊比丘诣城中顺街里行分卫。次至王阿阇贳宫。宫人官属俱一处默然从乞丐。是时王阿阇贳有女。名阿术达(汉言无愁忧)。年十二端正好洁。光色第一于前世。佛所作功德有神猛之行。供养无央数佛。于阿耨多罗三耶三菩心。不转于父王正殿金床上坐。安无愁忧见此尊比丘。不转于父王正殿。今来于坐不起不迎不为作礼。亦不请令坐。亦不与分卫具。诸尊比丘。亦默然观此女。是王阿阇贳见女无愁忧。不恭敬礼是尊比丘。王顾谓女。汝不知耶。是怛萨阿竭阿罗呵三耶三佛尊比丘。以得阿罗汉无所复畏。所作事胜。以弃重担。生死以断深入微妙。其供养是者福不可量。为师为父慈念兴福施于一切。汝见何故。于坐不起默而视之。汝有何异利不礼此上尊女无愁忧白言。王曾见师子。当为小小禽兽作礼迎逆坐不。王答女言。不见。女复白。王曾闻遮迦越王当为小国王。起迎逆作礼共坐不。释提桓因宁为诸天。起迎逆作礼不。梵三钵宁礼诸梵不。答言不见。女复白。王曾见大海神为小小陂池沟渠泉流作礼不。须弥山宁为众小山作礼不。日月之光明与萤火之明等不。女复言。如是大王发意。求阿耨多罗三耶三菩心。欲度一切。被僧那僧涅之大铠。持大悲大哀。如师子吼。云何当为恐畏。比丘而无大悲大慈大哀。离师子吼中。云何当礼信欢喜。王曾见大法王转经论教一切。令发阿耨多罗三耶三菩心。当为是比丘少智者恭敬作礼不。女白王。如大海水不可量不可度不可见边际。大智若此。犹复受泉流如牛迹中水。自谓以满足。宁可方之于大海。是畏生死比丘。志在灭度。发阿耨多罗三藐三菩心。宁当迎逆作礼不。王曾见大智。如须弥山最尊高。怛萨阿竭法为尊雄。岂况智如芥子比丘迎逆作礼不。王宁见日月光。其明所照不可计量。怛萨阿竭法光明智慧功德名闻。过是千亿万倍。宁比萤火之明自照其身。不及一切人。志小比丘自度其身。大智之法明于三界。宁迎逆作礼。女白王。佛般泥洹后。尚不为是辈比丘作礼。何况佛今现在而为法则。所以者何。礼彼比丘为习此法。其亲近三耶三佛法。得三耶三菩行。王告女无愁忧。汝有抵突之心。见是大比丘。不恭敬迎逆以坐席为宾主。而广引众喻不念设饭食。汝何志求。女白王。大王宁有抵突之心耶。女谓王言。王何故见国中羸劣下贱乞丐者不为作礼。王答女言不。尔此非吾类。女答王亦如是。王发意菩萨声闻辟支佛非其类。王告女。吾闻行菩萨法。悉弃强梁嗔恚之心。以调顺软弱为一切人下屈。汝岂无软弱之心。女白王言。世间人愚痴。常怀毒恶之心故。菩萨摩诃萨以慈悲。护彼人欲除众毒故。此大比丘诸垢以除。是辈比丘。见善无所增。见恶亦不减。女白王。当来十方佛。设为是比丘等。说深妙之法。不能复增精进。所以者何。用闭塞生死道故。譬以瓶盛满水置露地。天雨瓶中一渧不受。渧亦不得入。所以者何。其瓶以满故。女白王。是比丘等如是。若十方佛为现神足。变化说经法。不能逮及如来三昧。于功德无所增益。女白王。譬如大海万水四流皆归于海。所以者何。其海广长所受不可计量。如是大王。菩萨摩诃萨说经法。当作是见多所饶益。发摩诃衍心。多所容受。所以者何。菩萨摩诃萨器所受。不可计不可数不可量。是时女无愁忧。为王阿阇贳说偈言

  无愁忧以名得　　为王阿阇贳女
  有五百比丘来　　我不为起作礼
  应时为王所呵　　不恭敬比丘僧
  我不知是福地　　佛子离彼中迹
  无忧愁诵偈言　　听我说至诚言
  见比丘不为起　　意不生欲作礼
  人欲乘船入海　　取一钱破百分
  百分中取一分　　入法海还为取
  若有人从王乞　　若飞行遮迦越
  乞丐者求一钱　　为不足从王乞
  智慧者令王喜　　从王乞千亿宝
  愿施贫使安隐　　如是人为晓了
  譬如人求贱宝　　如是人为不黠
  声闻法亦如是　　入海宝自取少
  譬如人财为富　　菩萨黠为珍宝
  愿供养于法王　　自致佛度人民
  譬如医自治身　　不能愈一切人
  若有医多治人　　是乃为名医师
  发意者智慧师　　自脱身弃余人
  为黠人所不敬　　譬医能自治身
  若黠师知药名　　便能治巨亿人
  为天下人所敬　　发意菩萨如是
  譬如树无叶果　　无益于世间人
  阿罗汉如是树　　为无益于世间
  譬如树栴檀香　　有益于一切人
  菩萨法亦如是　　以经法开甘露
  不可以牛迹水　　澡洗人除垢热
  恒水净无数人　　恒水流满大海
  声闻法牛迹水　　不能除世间热
  菩萨法如恒水　　能饱满大千刹
  譬如时雨珍宝　　愚于宝取一钱
  若有黠益取多　　能使贫至大富
  佛者譬雨珍宝　　声闻法取一钱
  菩萨采饱满人　　菩萨施广如此
  如有人近须弥　　皆随山作金色
  若其余土石山　　不能以色变形
  菩萨法须弥山　　菩萨恩生天上
  得离生死苦恼　　声闻不能度人
  暴露在草不多　　露不能熟五谷
  大雨水润泽多　　从润泽得丰熟
  声闻法暴露草　　菩萨法如大雨
  大千中诸来者　　法所雨润一切
  迦随华无有香　　为世人所不取
  私夷华人乐取　　优昙钵及莲华
  声闻法迦随华　　声闻香闻不远
  菩萨法私夷华　　度一切至泥洹
  如怯人行空泽　　不足以为大难
  人中道为大难　　将一切度生死
  声闻法行空泽　　菩萨法人道中
  度生死迷乱者　　导一切恐畏人
  缚筏浮度不多　　筏不能度往还
  譬如人造大船　　度无数得往还
  声闻法如缚筏　　菩萨法如大船
  持七觉度一切　　脱爱欲过大海
  若如被铠乘驴　　不可入大众中
  被铠人乘马象　　行斗战得胜怨
  声闻法如乘驴　　菩萨法乘马象
  坐树下降魔官　　救天上世间人
  虚空中满星宿　　星宿众夜不明
  月独出为大明　　男女见大欢喜
  声闻法如星宿　　菩萨法月独明
  菩萨恩致安隐　　皆令发萨云若
  夜之冥萤火明　　人不以是为明
  日出光为大明　　有益于阎浮地
  声闻法如萤火　　菩萨慧如日月
  生死海行度人　　悉现明一切人

尔时王阿阇贳闻女无愁忧说是偈默然。不识是何言。舍利弗心念。是语甚可怪。所说无挂碍黠慧乃尔。我欲试之知能欢喜而忍不。舍利弗谓女无愁忧。卿于三乘志欲何求。女报言。乘大悲大慈于所求。舍利弗报言。欲求摩诃衍三跋致耶。女答言不。舍利弗复问。女行欲何求乃作师子吼。女答舍利弗。于所求无所求。有所求则不为师子吼。无所住止能作师子吼。卿舍利弗以法取证宁有声闻辟支佛法摩诃衍法不。舍利弗答言。无诸法相一耳。空无所有。女问舍利弗。诸法空作何行法而设三乘。舍利弗答女言。无所行。舍利弗复问女。有佛法无有佛法。有异无。女答尊者舍利弗。近空及远空有异无。舍利弗答言。无异。女问舍利弗。譬内空外空有异无。答言无异。如是舍利弗得佛法未得道法。适等无异。女为舍利弗种种说空空法。舍利弗默然。无异辩才折答此言

尔时尊者摩诃目揵连。谓女无愁忧。见如来何异。要言声闻辟支佛所不能及知。女报尊者目揵连。能知三千大千世界星宿数不。目揵连报女言。我当禅定三昧观本际。女谓目揵连。怛萨阿竭一一持三昧。视见恒沙中数人民意念所趣向。何况是星宿。以是故知怛萨阿竭于诸法而有持。是故声闻辟支佛所不及知。尊者目揵连。宁知十方佛刹中几何天地当败坏。几何天地当合成。答女言。不知。女复问目揵连。宁知几佛以过去。几佛甫当来。几佛今见在。答女言。不知。女复问目揵连。世间贪淫有几人。喜嗔恚有几人。愚痴者有几人。尽行三事有几人。不行三事有几人。答言。不知。女复问尊者摩诃目揵连。世间有几人求声闻道。几人求辟支佛道。几人求摩诃衍。答女言。不知。女复问目揵连。世间有几人求佛道。几人不信佛道。几人信九十六种道。几人不信九十六种道。适无所信为有几人。答言。不知。女报目揵连。怛萨阿竭悉知是事。复过于此不可计无有限。声闻辟支佛所不能及知。是故怛萨阿竭于诸法而有持。尊者目揵连。为怛萨阿竭所称誉神足第一。宁曾至揵陀呵刹土(汉言香洁国)。是刹中有树以七宝而挍饰。以众宝为树栴檀为华香。摩诃目揵连报女言。本所不闻本所不见今乃闻。是刹土名字未曾所见闻愿闻是刹中怛萨阿竭阿罗诃三耶三佛名字。今现在说经法不。女报言。彼刹佛名香洁放光明怛萨阿竭阿罗呵三耶三佛。在彼刹说经法。女无愁忧于坐不起作瑞应三昧。念菩萨初发意。求阿耨多罗三耶三佛。过声闻辟支佛上如我。至心愿我香洁放光明怛萨阿竭阿罗呵三耶三佛。现光明使诸声闻见其刹土。使国中栴檀香香闻是间刹土。女无愁忧立是愿。于是香洁放光明怛萨阿竭阿罗呵三耶三佛。寻时放身相光明。是刹诸声闻。皆见彼刹土香洁放光明怛萨阿竭阿罗呵三耶三佛。于大众中菩萨说经法。诸声闻自于其处所。闻彼佛所说法皆佛威神之恩。彼香洁怛萨阿竭阿罗呵三耶三佛持六十种音说。如女无愁忧所说无异。初发意求阿耨多罗三耶三菩。是辈之人。过声闻辟支佛上。说是时。弥勒菩萨。白佛言。是栴檀香从何刹土来。至是间香乃如是。佛语弥勒菩萨。女无愁忧与诸大声闻。共师子吼有此善瑞故。现彼香洁放光明佛刹刹中栴檀香满沙呵刹中。无愁忧女。语尊者目揵连。菩萨现功德变化。如是者。有何当志于小道。女复问目揵连。宁知揵陀刹去是远近不。目揵连答曰。不知。女谓目揵连。如目连等满是三千大千刹中。譬如芦苇干柘竹稻草木。令目连其数如此。时过一劫计彼佛刹无能计知其处。乃过尔所佛刹。乃可得香洁放光明佛所治。尔时香洁放光明佛。即回光还归本土。于是佛刹不复现。目揵连见此变异。默然无所言趣。尊者摩诃迦叶。谓女无愁忧。宁见前释迦文怛萨阿竭阿罗呵三耶三菩不耶。可得见佛色身使佛有所说。云何

  见我色者　　闻我声者　　愚痴不信
  是人不见　　以法见佛　　佛者法身
  法者难晓　　以是叵见

尔时尊者摩诃迦叶作是念。女曾见释迦文怛萨阿竭阿罗呵三耶三佛不。女答迦叶言然。我见怛萨阿竭阿罗呵三耶三佛。不持肉眼见不色见。不无色见。亦不持天眼见。亦不持痛痛思想生死识眼见。亦不智慧眼见。亦不想识见。亦不法眼见。亦不身见。亦不佛眼见。亦不命见。摩诃迦叶。我见怛萨阿竭。如尊者摩诃迦叶者。为无大明乐世间生。自谓有身。缘一觉行。念欲见道。摩诃迦叶谓女。设是法无有主。愚痴者乃乐生。自谓是我身。一切万物是我所有法想。不于中边得见。从何而化生。女谓摩诃迦叶。诸法不可得见。是故法无形。如是不可得见。如何生。摩诃迦叶谓女。佛法亦空无所有。女复谓摩诃迦叶。欲得见无上正真法者当如法。摩诃迦叶报女。白衣法我欲闻。况佛道不欲闻。女谓摩诃迦叶。法不见有亦不见无。摩诃迦叶谓女。是法无。女复谓摩诃迦叶。诸法皆空无有形。不可从谛得见。若善男子善女人。欲见佛身相。自净其行于行清净。得见诸净是则纯熟。摩诃迦叶谓女。云何自净其行纯熟者。女谓摩诃迦叶。能自观身空者悉入诸法空。诸法亦不减亦不增。是为自见诸净。摩诃迦叶谓女。何等谓身空。女报。空尽空是。是身为空。诸法空亦如是。摩诃迦叶。复问女无愁忧。从何闻是法乃能信谛。佛有二事因缘得信。闻他人善自念其行。女报迦叶。他人智说可闻。尔乃自观身造行。女报摩诃迦叶。若自智慧。复观一切智。以明为师。摩诃迦叶报女。云何自知身行善。女答言。闻法观善。身行善则见善造行。摩诃迦叶报女。云何菩萨自观身行善。女答摩诃迦叶。菩萨法与一切天下人共合适不疏远。是则菩萨身行善。女复报摩诃迦叶。当来法过去法今现在法。意无增减是为行菩萨法。摩诃迦叶问女。云何见法无所增无所减。女报摩诃迦叶。有二事。有法无法。不增不减。作是念。是为自见身意行。见身意行则为无所见知。摩诃迦叶。自见其身。迦叶谓女。云何自见其身。女报言。如摩诃迦叶。自度身不见一切人。摩诃迦叶答言。我无所见。女报摩诃迦叶。诸法适无所舍亦无所著。摩诃迦叶默然。无以加报。尔时尊者须菩提。闻是语。为甚难甚难大欢喜。问女无愁忧。从何得大利乃有此辩。女报须菩提。亦无得利亦无不得利。慧亦不见法法亦不见慧。亦不内观亦不外观。是则慧。所以者何。须菩提言有法者则非法。如尊者须菩提。第一乐空闲处。法为有处有说。为有慧无有慧慧无所说。须菩提报女言。不持空闲处。有法处得慧。是法见不是可说不可出。女报须菩提。一切法悉如是。无从见无从取。云何得大利而有慧。须菩提报女言。设空无有慧。何从有是语。女问须菩提。宁闻山中大呼有响声来应不。一切法悉如是。信不言信是响。有慧无慧本无慧。是响因声而合成。女问须菩提。是响出为有响像无。报女言。响无形像响因空而有名。一切法如响因空而出生。女报须菩提。一切法法所说从空生。须菩提问女言。若一切法从空生。何以故。佛说世间当来佛如恒沙数。女报须菩提。欲得知法所生处耶。答言欲知。所生处无所生。无所生是生处。须菩提。恒沙等。不见从如来去。亦无所至。所以作佛者。何法不从。发意亦不止意。须菩提报女言。是说为第一未生未起。女报须菩提。所说皆第一。若说若不说亦第一。一切无所生不可说。不可说不离佛法。须菩提报女言。甚难居家为道。乃有此辩。博览众要深入微妙。女报须菩提。菩萨亦无居家。亦无出家。亦无沙门。亦无不沙门。所以者何。以心意为行。行者以智为上。以黠为善。须菩提问。菩萨有几处止。愿闻其说。女报须菩提。菩萨持八法住。是故止处在所止。无所不止。声闻中第一。何等为八法。往菩萨常行善意。至心求佛无转诲。一以大慈救护天上天下人。二不舍大哀离世间法于身命无所著。三行沤和拘舍罗不可计智皆发意求佛。四常行勇猛不厌见闻求诸法五悉知菩萨行处。六悉救一切人意。七其智不从他人受一切法自证得忍。八如是。须菩提。持是八法行在所止处。过诸罗汉辟支佛上。于是须菩提默然。尔时尊者罗云问无愁忧女。乃作是解。晓了众要总持智慧。何故。自坐金床秽浊。无谦卑恭敬之心。自处高床。与大比丘难说经法。吾曾闻佛说。人无疾病不得处高床及卧听而说经法。女报尊者罗云。宁知世间以何为净何等不净。罗云报女言。世间有持戒信受不犯者是则为净。若有犯者则为不净。女报罗云。且止未晓未了所以者何。罗云。持戒信受不犯者是则不净。其犯戒者是为净。所以者何。不倚净慧则有净不净。本无无净不净。诸阿罗汉所见如是。其犯戒者为净。所以者何。罗云。以离于戒不复学可至无极慧。远离恶道过于世间。是故谓为离戒。罗云报女。其人立愿不立愿有异无。女报言。尊者罗云。譬如紫磨黄金。持作众物。珠环璎锁。已作未作。前色后色有异无。报言无异。如是罗云。何故嫌处高床不恭敬谦。苦者意行是本。罗云。昔菩萨以草蓐于地为坐。过于声闻坐梵天坐。罗云复问。云何坐得过声闻坐于梵天。仁者罗云。菩萨于树下以草为坐。三千世界刹土释梵四天王及世间。上至三十三天。其中人民大鬼神皆来问讯。菩萨中有头面礼菩萨足者。有跪拜者。有揖让者。中有叉手者。为尔不罗云。罗云答言。有是有是。罗云当知菩萨处意高下非谓床坐。是故过声闻坐梵天。当作是知。尔时王阿阇贳。告女无愁忧。汝不知耶。尊者罗云。是遮迦越王种尊第一。信用道德故少小弃家行作沙门。弃遮迦越国。是佛释迦文子。持戒第一。汝云何反轻戏不以礼敬。女白王。止莫说是语。宁可以神丹之珠比之于水精。王曾见师子当生虫狐。遮迦王子岂当为小国王。王言不尔。女复白王当知是因缘。彼罗云不从怛萨阿竭。为父母胞胎生。怛萨阿竭师子行。皆降伏九十六种道。神通之智。悉具足为大圣猛。一切诸法悉了知。无所挂碍。等知一切人心所念。知当来过去今在悉晓知。为大医王疗人苦痛。常劝助一切转法轮。舍利弗摩诃目揵连。摩诃迦叶。须菩提。蠡越。罗云。阿难。如是辈闻法皆奉行。犹非是佛之子。尔时诸尊声闻在大众中。女为说经法。女白王。过去阿僧祇劫有佛名提和竭罗。时婆罗门女。字须罗陀(汉言鲜洁辩)。复有婆罗门子。字鞞多卫提和竭罗怛萨阿竭。时持华五茎散佛上。时卖华女发心愿。欲世世为夫妇。乃至于得佛。复发心求摩诃衍。乃尔时过去阿僧祇劫作功德。发愿世世相随。欲救诸下劣。是故从佛求愿。从佛求愿终无有空。俱夷者释种女。大乐发阿耨多罗三藐三菩心。沤和拘舍罗行劝一切菩萨。示现有妻子男女奴婢象马金银珍宝摩尼珠。所以者何。护九十六种道。不欲使诽谤菩萨。非男子王为生黄门。世有何特而言忍勤苦。设作是念当堕泥犁中。昼夜苦痛不可言。菩萨乃从提和竭罗怛萨阿竭阿罗呵三藐三佛以来。菩萨受别无有色思想。女白王。尔时婆罗门子鞞多卫。从提和竭罗怛萨阿竭阿罗诃三耶三佛。得慧明六万三昧门逮得无尽明恒沙数陀怜尼法。受是别时。前所愿所为尽悉弃除。从得忍有言。罗云是佛之子。从父母胞胎中生者。是为谤如来菩萨。于妻子国城不以乐色故。菩萨离爱欲。于世间法无所沾污。女白王。大海中求火尚可得。菩萨贪淫嗔恚不可得。王当知是法。尊者罗云为化生。不从父母胞胎生。所化现皆佛威神。菩萨随习俗而教化。护一切痴意。如幻现形。一切所作常不离三昧。自现在小儿中。现白衣居士中。现菩萨声闻中天上人中人非人等尊劣长幼下贱伎乐宫女。酒食随所欲度而往生。如是所示现处不可计不可数。众会中有发心念。谁为适是怛萨阿竭种姓真子者。等知正见不断三宝。护七觉意随所乐而化。是曹之人真佛之子。若善男子善女人。欲为佛作真子。当发阿耨多罗三耶三菩心。说是语时。王后宫列女二十五人。皆发阿耨多罗三耶三菩心。时千天子。闻女无愁忧师子吼。皆发阿耨多罗三耶三菩心。同时发声言。我是当来佛过去佛之上子。发心已雨于天华。遍覆罗阅只大城中。以供养女无愁忧。时无愁忧于金床下。前趣诸尊声闻。无愁忧女问诸尊声闻。为晓分卫法不。诸尊声闻。答女言。以晓云何晓。答曰身有四神从因缘生。常覆盖顺化惧有坏败。以故当饭食之。是身以饭食得立。无饭食则不得安隐。是身譬如弊坏之车。须脂膏而得所安。所以时食欲护身故。不自贡高行乞。不以为色相。不以为贪。亦以欲破贪故。女无愁忧。闻诸尊声闻各各说是事。闻所说亦不喜亦不忧。如是身为灾患勤苦若此。即以时请诸声闻。供养以百味饭。具饭食讫。竟皆揖让。便还耆阇崛山中。听怛萨阿竭说法。我曹亦俱当往无愁忧女。食后与父母兄弟宗亲后宫列女群臣人民俱。出城到耆阇崛山中。前以头面着地为佛作礼。绕佛三匝却坐一面。诸尊声闻从禅觉亦皆悉来。为佛作礼坐一面。舍利弗从坐起。正衣服下右膝叉手白佛言。是女无愁忧。所说甚难入深法要。以权行立人不可胜数。所问种种悉能报答。佛告舍利弗是女无愁忧。以供养九十二亿佛。作功德常不离沤和拘舍罗。舍利弗白佛。是女何故不弃女人。佛告舍利弗。若诸声闻谓此无愁忧是女人耶。若等不深入般若波罗蜜不见人根观本迹。然便等视于所行。菩萨咨所乐喜以权道示现。有男女其限无所挂碍。欲度男女故。无愁忧女欲决舍利弗之狐疑。现身立愿。使大众中悉见我是男子。作是念已。即诸大众见无愁忧身为男子不复见女人像。无愁忧于时踊在虚空中。去地七十丈住止空中。佛告舍利弗。见是无愁忧为男子踊在虚空中去地七十丈。若见不。舍利弗白佛。唯然已见。佛告舍利弗。是无愁忧。却后七百阿僧祇劫当作佛。佛名鞞竭俞(汉言离愁)怛萨阿竭阿罗诃三耶三佛。刹名鞞末拘辽害(汉言无垢浊光炎)。其寿十万劫。佛般泥洹后。经法留止十劫不断绝。是刹中地皆如细琉璃。其刹土八方方有一道。是佛所游行处。以七宝为树。以众宝为栏楯。以天缯为华盖。以名香而香之。无秽恶石沙瓦砾。纯以珠宝为万物。刹中无有泥犁禽兽薜荔。但有菩萨及天与人。譬如忉利天王所居宫。尔时大众及王阿阇贳欢喜踊跃皆言善哉善哉。王阿阇贳正殿夫人。字旃罗廅(汉言月明照)。于坐起叉手自嗟叹心。白佛言。既得为人难我复怀养。是菩萨益倍踊跃。因是功德发心求阿耨多罗三耶三佛。发心立愿。今佛授无愁忧菩萨慧。却后当作佛劫尽。愿令我乘其第得作佛于彼刹土中。尔时佛知王妇月明心所愿。佛告舍利弗。见王妇月明不。舍利弗言。见王妇月明。持是功德所作。当弃女人身得男子已。当生忉利天上作天名宝第一。弥勒佛来下有国王。名呵当为作太子。字终好。当供养弥勒尽寿命。却后当为弥勒作沙门。上法亦持中法亦持下法亦持。总供养是颰陀劫中怛萨阿竭阿罗呵三耶三佛。又行菩萨法。是离愁怛萨阿竭得作佛已。宝第一。当于是刹作遮迦越王。名宝丰。当供养承事怛萨阿竭。尽形寿当承其佛第得作佛。名普明怛萨阿竭阿罗呵三耶三佛。当教授是无垢浊炎明刹土本刹故。事如离忧怛萨阿竭所治处等无有异。王妇月明。闻佛说是别。益倍踊跃自嗟叹。其身以珠摩尼直百万两金用上佛。从王阿闇贳。求持五戒别治一处。离淫欲之行。令一切皆修清净。无愁忧菩萨。始从虚空中来下。叉手住佛前。愿我作佛时令我刹中诸菩萨。自然化生长大法座。袈裟自然着身等无老少。如年二十之容色。今自愿身为沙门。自然被法衣。寻时作彼示现。无愁忧菩萨白王。法无坚固从空而立从空而坐。于念不念于中立意不散。无所录在所作为无所属。王见是不。是一日之中我为女人变为男子形。复现比丘僧。何者审为谛。是处余处人身中有三毒。以三药疗焦尽诸毒。知是法故。大王不当作非法行。当数数诣佛。文殊师利童男菩萨。所能除人垢增益功德。度不度者。王国中多事欲去随意。佛告阿难。无愁忧菩萨受别解谛能持能说。当为一切广说经法。若有善男子善女人欲求佛道。正使是三千大千刹土持七宝满其中。持施怛萨阿竭阿罗呵三耶三佛。不如闻是经信不诽谤其功德不可计。何况奉行尽形寿。供养缯华幢盖旗幡。其功德无能计数者。诸比丘受教。无愁忧菩萨欢喜。王阿阇贳。王妇月明。阿难尊比丘。一切大众诸天龙神阿须伦。闻佛说经皆欢喜。前以头面着地。为佛作礼而去

佛说阿阇贳王女阿术达菩萨经


佛说阿弥陀经

    No. 366 [No. 367]

佛说阿弥陀经

        姚秦龟兹三藏鸠摩罗什译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘僧千二百五十人俱。皆是大阿罗汉。众所知识。长老舍利弗。摩诃目干连。摩诃迦叶。摩诃迦栴延。摩诃拘絺罗。离婆多。周梨槃陀迦。难陀。阿难陀。罗睺罗。憍梵波提。宾头卢颇罗堕。迦留陀夷。摩诃劫宾那。薄俱罗。阿[少/兔]楼驮。如是等诸大弟子。并诸菩萨摩诃萨。文殊师利法王子。阿逸多菩萨。乾陀诃提菩萨。常精进菩萨。与如是等诸大菩萨。及释提桓因等。无量诸天大众俱

尔时佛告长老舍利弗。从是西方过十万亿佛土。有世界名曰极乐。其土有佛号阿弥陀。今现在说法。舍利弗。彼土何故名为极乐。其国众生无有众苦。但受诸乐故名极乐。又舍利弗。极乐国土。七重栏楯七重罗网七重行树。皆是四宝周匝围绕。是故彼国名曰极乐。又舍利弗。极乐国土有七宝池。八功德水充满其中。池底纯以金沙布地。四边阶道。金银琉璃颇梨合成。上有楼阁。亦以金银琉璃颇梨车磲赤珠马瑙而严饰之。池中莲花大如车轮。青色青光。黄色黄光。赤色赤光。白色白光微妙香洁。舍利弗。极乐国土成就如是功德庄严

又舍利弗。彼佛国土常作天乐。黄金为地。昼夜六时天雨曼陀罗华。其国众生常以清旦各以衣裓盛众妙华。供养他方十万亿佛。即以食时还到本国。饭食经行。舍利弗。极乐国土成就如是功德庄严

复次舍利弗。彼国常有种种奇妙杂色之鸟。白鹄孔雀鹦鹉舍利迦陵频伽共命之鸟。是诸众鸟。昼夜六时出和雅音。其音演畅五根五力七菩提分八圣道分如是等法。其土众生闻是音已。皆悉念佛念法念僧。舍利弗。汝勿谓此鸟实是罪报所生。所以者何。彼佛国土无三恶趣。舍利弗。其佛国土尚无三恶道之名。何况有实。是诸众鸟。皆是阿弥陀佛。欲令法音宣流变化所作。舍利弗。彼佛国土。微风吹动诸宝行树及宝罗网出微妙音。譬如百千种乐同时俱作。闻是音者皆自然生念佛念法念僧之心。舍利弗。其佛国土成就如是功德庄严

舍利弗。于汝意云何。彼佛何故号阿弥陀。舍利弗。彼佛光明无量。照十方国无所障碍。是故号为阿弥陀。又舍利弗。彼佛寿命。及其人民无量无边阿僧祇劫。故名阿弥陀。舍利弗。阿弥陀佛成佛已来于今十劫。又舍利弗。彼佛有无量无边声闻弟子。皆阿罗汉。非是算数之所能知。诸菩萨亦复如是。舍利弗。彼佛国土成就如是功德庄严

又舍利弗。极乐国土众生生者皆是阿鞞跋致。其中多有一生补处。其数甚多。非是算数所能知之。但可以无量无边阿僧祇劫说。舍利弗。众生闻者。应当发愿愿生彼国。所以者何。得与如是诸上善人俱会一处。舍利弗。不可以少善根福德因缘得生彼国。舍利弗。若有善男子善女人。闻说阿弥陀佛。执持名号。若一日。若二日。若三日。若四日。若五日。若六日。若七日。一心不乱。其人临命终时。阿弥陀佛与诸圣众。现在其前。是人终时心不颠倒。即得往生阿弥陀佛极乐国土。舍利弗。我见是利故说此言。若有众生闻是说者。应当发愿生彼国土

舍利弗。如我今者赞叹阿弥陀佛不可思议功德。东方亦有阿閦鞞佛。须弥相佛。大须弥佛。须弥光佛。妙音佛。如是等恒河沙数诸佛。各于其国出广长舌相。遍覆三千大千世界说诚实言。汝等众生当信是称赞不可思议功德一切诸佛所护念经

舍利弗。南方世界有日月灯佛。名闻光佛。大焰肩佛。须弥灯佛。无量精进佛。如是等恒河沙数诸佛。各于其国出广长舌相。遍覆三千大千世界说诚实言。汝等众生当信是称赞不可思议功德一切诸佛所护念经

舍利弗。西方世界有无量寿佛。无量相佛。无量幢佛。大光佛。大明佛。宝相佛。净光佛。如是等恒河沙数诸佛。各于其国出广长舌相。遍覆三千大千世界说诚实言。汝等众生。当信是称赞不可思议功德一切诸佛所护念经

舍利弗。北方世界有焰肩佛。最胜音佛。难沮佛。日生佛。网明佛。如是等恒河沙数诸佛。各于其国出广长舌相遍覆三千大千世界说诚实言。汝等众生。当信是称赞不可思议功德一切诸佛所护念经

舍利弗。下方世界有师子佛。名闻佛。名光佛。达摩佛。法幢佛。持法佛。如是等恒河沙数诸佛。各于其国出广长舌相。遍覆三千大千世界说诚实言。汝等众生。当信是称赞不可思议功德一切诸佛所护念经

舍利弗。上方世界有梵音佛。宿王佛。香上佛。香光佛。大焰肩佛。杂色宝华严身佛。娑罗树王佛。宝华德佛。见一切义佛。如须弥山佛。如是等恒河沙数诸佛。各于其国。出广长舌相。遍覆三千大千世界说诚实言。汝等众生。当信是称赞不可思议功德一切诸佛所护念经

舍利弗。于汝意云何。何故名为一切诸佛所护念经。舍利弗。若有善男子善女人。闻是经受持者。及闻诸佛名者。是诸善男子善女人。皆为一切诸佛共所护念。皆得不退转于阿耨多罗三藐三菩提。是故舍利弗。汝等皆当信受我语及诸佛所说

舍利弗。若有人已发愿。今发愿。当发愿。欲生阿弥陀佛国者。是诸人等。皆得不退转于阿耨多罗三藐三菩提。于彼国土若已生。若今生。若当生。是故舍利弗。诸善男子善女人。若有信者。应当发愿生彼国土

舍利弗。如我今者称赞诸佛不可思议功德。彼诸佛等。亦称说我不可思议功德。而作是言。释迦牟尼佛能为甚难希有之事。能于娑婆国土五浊恶世。劫浊。见浊。烦恼浊。众生浊。命浊中。得阿耨多罗三藐三菩提。为诸众生。说是一切世间难信之法。舍利弗当知。我于五浊恶世。行此难事。得阿耨多罗三藐三菩提。为一切世间。说此难信之法。是为甚难。佛说此经已。舍利弗及诸比丘。一切世间天人阿修罗等。闻佛所说欢喜信受。作礼而去

佛说阿弥陀经

无量寿佛　说往生净土咒　南无阿弥多婆夜　哆他伽哆夜　哆地夜他　阿弥唎(上声)都婆毗　阿弥唎哆　悉耽婆毗　阿弥唎哆　毗迦兰哆　伽弥腻　伽伽那抧多迦隶莎婆诃

诵此咒者阿弥陀佛常住其顶命终之后任运往生

龙树菩萨愿生安养梦感此咒

耶舍三藏诵此咒　天平等锈法师从耶舍三藏口受此咒其人云经本外国不来受持咒法日夜六时各诵三七遍晨夜藻漱嚼扬枝然香火于形象前跪合掌诵三七遍日日恒尔即灭四重五逆十恶谤方等罪悉得除灭现在不为一切诸邪鬼神之所恼乱命终之后任运往生阿弥陀国何况昼夜受持诵读功德不可思议佛说阿弥陀经卷第一


佛说阿弥陀三耶三佛萨楼佛檀过度人道经

    No. 362 [Nos. 360, 361, 363, 364]

佛说阿弥陀三耶三佛萨楼佛檀过度人道经卷上

        吴月支国居士支谦译

佛在罗阅只耆阇崛山中。时有摩诃比丘僧万二千人。皆净洁一种类。皆阿罗汉。贤者拘邻。贤者拔智致。贤者摩诃那弥。贤者合尸。贤者须满日。贤者维末坻。贤者不乃。贤者迦为拔坻。贤者忧为迦叶。贤者那履迦叶。贤者那翼迦叶。贤者舍利弗。贤者摩诃目揵连。贤者摩诃迦叶。贤者摩诃迦旃延。贤者摩诃揭质。贤者摩诃拘私。贤者摩诃梵提。贤者邠提文陀弗。贤者阿难律。贤者难提。贤者[(膘-示+土)*瓦]脾坻。贤者须枫。贤者蠡越。贤者摩诃罗倪。贤者摩诃波罗延。贤者波鸠蠡。贤者难持。贤者满枫蠡。贤者蔡揭。贤者厉越。如是诸比丘僧甚众多。数千亿万人。悉诸菩萨阿罗汉。无央数不可复计。都共大会坐。皆贤者也。时佛坐息思念正道。面有九色光。数千百变光。色甚大明。阿难。即起更被袈裟。前以头面着佛足。即长跪叉手。问佛言。今日佛面光色。何以时时更变明乃尔乎。今佛面光精数千百色。上下明好乃如是。我侍佛已来。未曾见佛面有如今日色者。我未曾见三耶三佛光明威神乃尔。独当有意。愿欲闻之。佛言贤者阿难。有诸天神教汝。若诸佛教汝。今问我者耶。汝自从善意出问佛耶。阿难白佛言。无有诸天神教我亦无诸佛教我令问佛也。我自从善心知佛意问佛尔。每佛坐起行来出入。所欲至到当所作为。诸所教敕者。我辄如佛意。今佛独当念。诸已过去佛。诸当来佛。若他方佛国。今现在佛。独展转相思念故。佛面色光明乃尔耳。佛言。善哉善哉。贤者阿难。汝所问者甚深大快多所度脱。若问佛者。胜于供养一天下阿罗汉辟支佛。布施诸天人民及蜎飞蠕动之类。累劫百千亿万倍也。佛言阿难。今诸天世间帝王人民。及蜎飞蠕动之类。汝皆度脱之。佛言。佛威神甚重难当也。汝所问者甚深。汝乃慈心于佛所哀诸天帝王人民。若比丘僧比丘尼优婆塞优婆夷。大善当尔。皆过度之。佛语阿难。如世间有优昙树。但有实无有华也。天下有佛。乃有华出耳。世间有佛。甚难得值也。今我出于天下作佛。若有大德圣明善心豫知佛意。若不妄在佛边侍佛也。佛告阿难。前已过去事。摩诃僧祇已来。其劫无央数不可复计。乃尔时有过去佛。名提和竭罗。次复有佛。名旃陀倚。已过去。次复有佛。名须摩扶劫波萨多。已过去。次复有佛。名维末楼。已过去。次复有佛。名阿难那利。已过去。次复有佛。名那竭脾。已过去。次复有佛。名者梨俱遰波罗夜蔡。已过去。次复有佛。名弥离俱楼。已过去。次复有佛。名軷陀尼。已过去。次复有佛。名朱蹄波。已过去。次复有佛。名凡扶坻。已过去。次复有佛。名堕楼勒耶。已过去。次复有佛。名旃陀扈斯。已过去。次复有佛。名须耶惟于沙。已过去。次复有佛。名拘还弥钵摩耆。已过去。次复有佛。名尸利滑攱。已过去。次复有佛。名摩诃那提已过去。次复有佛。名耆头摩提。已过去。次复有佛。名罗邻只离。已过去。次复有佛。名俞楼俱路蔡。已过去。次复有佛。名满呼群尼钵宾[侯*頁]。已过去。次复有佛。名旃陀速臾拔和沙。已过去。次复有佛。名旃陀蔡拘岑。已过去。次复有佛。名潘波蠡频尼。已过去。次复有佛。名軷波和斯。已过去。次复有佛。名阿术只陀揭蠡。已过去。次复有佛。名勿署提。已过去。次复有佛。名质夜蔡。已过去。次复有佛。名昙摩和提。已过去。次复有佛。名筛耶维[侯*頁]质。已过去。次复有佛。名楼耶带。已过去。次复有佛。名僧迦罗弥楼迦带。已过去。次复有佛。名昙昧摩提阿维难提。已过去。佛告阿难。次复有佛。名楼夷亘罗。在世间教授。寿四十二劫。乃尔时世有大国王。王闻佛经道。心即欢喜开解。便弃国捐王。行作沙门。字昙摩迦。作菩萨道。为人高才。智慧勇猛。与世人绝异。往到楼夷亘罗佛所。前为佛作礼。却长跪叉手。白佛言。我欲求佛为菩萨道。令我后作佛时。于八方上下诸无央数佛中。最尊智慧勇猛。头中光明如佛光明所焰照无极。所居国土。自然七宝极自软好。令我后作佛时。教授名字。皆闻八方上下无央数佛国。莫不闻知我名字者。诸无央数天人民。及蜎飞蠕动之类。诸来生我国者。悉皆令作菩萨。阿罗汉无央数都胜诸佛国。如是者宁可得不。佛语阿难。其楼夷亘罗佛。知其高明所愿快善。即为昙摩迦菩萨说经言。譬如天下大海水。一人斗量之。一劫不止。尚可枯尽令空得其底埿。人至心求道。可如当不可得乎求索精进不休止。会当得心中所欲愿尔。昙摩迦菩萨。闻楼夷亘罗佛说经如是。即大欢喜踊跃。其佛即选择二百一十亿佛国土中。诸天人民之善恶。国土之好丑。为选择心中所欲愿。夷亘罗佛说经竟。昙摩迦便一其心。即得天眼彻视。悉自见二百一十亿诸佛国中诸天人民之善恶。国土之好丑。即选择心中所愿。便结得是二十四愿经。则奉行之。精进勇猛勤苦求索。如是无央数劫。所师事供养。诸已过去佛。亦无央数。其昙摩迦菩萨至其然后。自致得作佛。名阿弥陀佛。最尊智慧勇猛光明无比。今现在所居国土甚快善。在他方异佛国。教授八方上下诸无央数天人民。及蜎飞蠕动之类。莫不得过度解脱忧苦。佛语阿难。阿弥陀佛为菩萨时。常奉行是二十四愿。珍宝爱重。保持恭慎。精禅从之。与众超绝。卓然有异。皆无有能及者。佛言。何为二十四愿。第一愿。使某作佛时。令我国中。无有泥犁禽兽薜荔蜎飞蠕动之类。得是愿乃作佛。不得是愿终不作佛

第二愿。使某作佛时。令我国中。无有妇人女人。欲来生我国中者。即作男子。诸无央数天人民。蜎飞蠕动之类。来生我国者。皆于七宝水池莲华中化生。长大皆作菩萨。阿罗汉都无央数。得是愿乃作佛。不得是愿终不作佛

第三愿。使某作佛时。令我国土。自然七宝。广纵甚大旷荡。无极自软好。所居舍宅。被服饮食。都皆自然。皆如第六天王所居处。得是愿乃作佛。不得是愿终不作佛

第四愿。使某作佛时。令我名字。皆闻八方上下无央数佛国。皆令诸佛。各于比丘僧大坐中。说我功德国土之善。诸天人民。蜎飞蠕动之类闻我名字。莫不慈心欢喜踊跃者。皆令来生我国。得是愿乃作佛。不得是愿终不作佛

第五愿。使某作佛时。令八方上下。诸无央数天人民。及蜎飞蠕动之类。若前世作恶。闻我名字。欲来生我国者。即便反政自悔过。为道作善。便持经戒。愿欲生我国不断绝。寿终皆令不复泥犁禽兽薜荔。即生我国。在心所愿。得是愿乃作佛。不得是愿终不作佛

第六愿。使某作佛时。令八方上下。无央数佛国。诸天人民。若善男子善女人。欲来生我国。用我故益作善。若分檀布施。绕塔烧香。散花然灯。悬杂缯彩。饭食沙门。起塔作寺。断爱欲。来生我国作菩萨。得是愿乃作佛。不得是愿终不作佛

第七愿。使某作佛时。令八方上下。无央数佛国。诸天人民。若善男子善女人。有作菩萨道。奉行六波罗蜜经。若作沙门不毁经戒。断爱欲斋戒清净。一心念欲生我国。昼夜不断绝。若其人寿欲终时。我即与诸菩萨阿罗汉。共飞行迎之。即来生我国。则作阿惟越致菩萨。智慧勇猛。得是愿乃作佛。不得是愿终不作佛

第八愿。使某作佛时。令我国中诸菩萨。欲到他方佛国生。皆令不更泥犁禽兽薜荔。皆令得佛道。得是愿乃作佛。不得是愿终不作佛

第九愿。使某作佛时。令我国中。诸菩萨阿罗汉。面目皆端正。净洁姝好。悉同一色。都一种类。皆如第六天人。得是愿乃作佛。不得是愿终不作佛

第十愿使某作佛时。令我国中。诸菩萨阿罗汉。皆同一心。所念所欲。言者豫相知意。得是愿乃作佛。不得是愿终不作佛

第十一愿。使某作佛时。令我国中。诸菩萨阿罗汉。皆无有淫泆之心。终无念妇女意。终无有嗔怒愚痴者。得是愿乃作佛。不得是愿终不作佛

第十二愿。使某作佛时。令我国中。诸菩萨阿罗汉。皆令心相敬爱。终无相嫉憎者。得是愿乃作佛。不得是愿终不作佛

第十三愿。使某作佛时。令我国中诸菩萨。欲共供养八方上下。无央数诸佛。皆令飞行。即到欲得自然万种之物。即皆在前。持用供养诸佛。悉皆遍已后。日未中时。即飞行还我国。得是愿乃作佛。不得是愿终不作佛

第十四愿。使某作佛时。令我国中。诸菩萨阿罗汉欲饭时。即皆自然七宝钵中。有自然百味饭食在前。食已自然去。得是愿乃作佛。不得是愿终不作佛

第十五愿。使某作佛时。令我国中。诸菩萨身。皆紫磨金色。三十二相。八十种好。皆令如佛。得是愿乃作佛。不得是愿终不作佛

第十六愿。使某作佛时。令我国中。诸菩萨阿罗汉。语者如三百钟声。说经行道皆如佛。得是愿乃作佛。不得是愿终不作佛

第十七愿。使某作佛时。令我洞视彻听。飞行十倍。胜于诸佛。得是愿乃作佛。不得是愿终不作佛

第十八愿。使某作佛时。令我智慧说经行道。十倍于诸佛。得是愿乃作佛。不得是愿终不作佛

第十九愿。使某作佛时。令八方上下。无央数佛国。诸天人民。蜎飞蠕动之类。皆令得人道。悉作辟支佛阿罗汉。皆坐禅一心。共欲计数。知我年寿。几千亿万劫岁数。皆令无有能极知寿者。得是愿乃作佛。不得是愿终不作佛

第二十愿者。使某作佛时。令八方上下。各千亿佛国中。诸天人民。蜎飞蠕动之类。皆令作辟支佛阿罗汉。皆坐禅一心。共欲计数。我国中诸菩萨阿罗汉。知有几千亿万人。皆令无有能知数者。得是愿乃作佛。不得是愿终不作佛

第二十一愿。使某作佛时。令我国中。诸菩萨阿罗汉寿命无央数劫。得是愿乃作佛。不得是愿终不作佛

第二十二愿。使某作佛时。令我国中。诸菩萨阿罗汉。皆智慧勇猛。自知前世亿万劫时。宿命所作。善恶却知。无极皆洞视彻。知十方去来现在之事。得是愿乃作佛。不得是愿终不作佛

第二十三愿。使某作佛时。令我国中。诸菩萨阿罗汉。皆智慧勇猛。顶中皆有光明。得是愿乃作佛。不得是愿终不作佛

第二十四愿。使某作佛时。令我顶中。光明绝好。胜于日月之明。百千亿万倍。绝胜诸佛。光明焰照。诸无央数天下。幽冥之处。皆当大明。诸天人民。蜎飞蠕动之类。见我光明。莫不慈心作善者。皆令来生我国。得是愿乃作佛。不得是愿终不作佛

佛告阿难。阿弥陀为菩萨时。常奉行是二十四愿。分檀布施不犯道禁。忍辱精进一心智慧。志愿常勇猛。不毁经法。求索不懈。每独弃国捐王。绝去财色。精明求愿无所适莫。积功累德无央数劫。今自致作佛。悉皆得之。不亡其功也。佛言。阿弥陀佛。光明最尊第一无比。诸佛光明。皆所不及也。八方上下。无央数诸佛中。有佛顶中光明照七丈。有佛顶中光明照一里。有佛顶中光明照二里。有佛顶中光明照五里。有佛顶中光明照十里。有佛顶中光明照二十里。有佛顶中光明照四十里。有佛顶中光明照八十里。有佛顶中光明照百六十里。有佛顶中光明照三百二十里。有佛顶中光明照六百四十里。有佛顶中光明照千三百里。有佛顶中光明照二千六百里。有佛顶中光明照五千二百里。有佛顶中光明照万四百里。有佛顶中光明照二万一千里。有佛顶中光明照四万二千里。有佛顶中光明照八万四千里。有佛顶中光明照十七万里。有佛顶中光明照三十五万里。有佛顶中光明照七十万里。有佛顶中光明照百五十万里。有佛顶中光明照三百万里。有佛顶中光明照六百万里。有佛顶中光明照一佛国。有佛顶中光明照两佛国。有佛顶中光明照四佛国。有佛顶中光明照八佛国。有佛顶中光明照十五佛国。有佛顶中光明照三十佛国。有佛顶中光明照六十佛国。有佛顶中光明照百二十佛国。有佛顶中光明照二百四十佛国。有佛顶中光明照五百佛国。有佛顶中光明照千佛国。有佛顶中光明照二千佛国。有佛顶中光明照四千佛国。有佛顶中光明照八千佛国。有佛顶中光明照万六千佛国。有佛顶中光明照三万二千佛国。有佛顶中光明照六万四千佛国。有佛顶中光明照十三万佛国。有佛顶中光明照二十六万佛国。有佛顶中光明照五十万佛国。有佛顶中光明照百万佛国。有佛顶中光明照二百万佛国。佛言。诸八方上下。无央数佛顶中光明所焰照皆如是也。阿弥陀佛顶中光明所焰照。千万佛国。所以诸佛光明所照有近远者何。本其前世宿命求道。为菩萨时。所愿功德。各自有大小。至其然后作佛时。各自得之。是故。令光明转不同等。诸佛威神同等尔。自在意所欲作为不豫计。阿弥陀佛光明。所照最大。诸佛光明。皆所不能及也

佛称誉阿弥陀佛光明极善。阿弥陀佛光明极善。善中明好。甚快无比。绝殊无极也。阿弥陀佛光明。清洁无瑕秽。无缺减也。阿弥陀佛光明姝好。胜于日月之明。百千亿万倍。诸佛光明中之极明也。光明中之极好也。光明中之极雄杰也。光明中之快善也。诸佛中之王也。光明中之极尊也。光明中之最明无极也。焰照诸无数天下。幽冥之处。皆常大明。诸有人民。蜎飞蠕动之类。莫不见阿弥陀佛光明也。见者莫不慈心欢喜者。世间诸有淫泆嗔怒愚痴者。见阿弥陀佛光明。莫不作善也。诸在泥犁禽兽薜荔。考掠勤苦之处。见阿弥陀佛光明至。皆休止不复治。死后莫不得解脱忧苦者也。阿弥陀佛光明。名闻八方上下。无穷无极。无央数诸佛国。诸天人民。莫不闻知。闻知者莫不度脱也。佛言。不独我称誉阿弥陀佛光明也。八方上下。无央数佛。辟支佛菩萨阿罗汉。所称誉皆如是。佛言。其有人民。善男子善女人。闻阿弥陀佛声。称誉光明。朝暮常称誉其光明好。至心不断绝。在心所愿。往生阿弥陀佛国。可得为众菩萨阿罗汉所尊敬。若其然后作佛者。亦当复为八方上下诸无央数佛。辟支佛菩萨阿罗汉。所称誉光明如是也。即众比丘僧。诸菩萨阿罗汉。诸天帝王人民。闻之皆欢喜踊跃。莫不赞叹者。佛言。我道阿弥陀佛光明。姝好巍巍。称誉快善。昼夜一劫。尚未竟也。我但为若曹小说之耳

佛说阿弥陀佛为菩萨。求索得是二十四愿。时阿闇世王太子。与五百长者迦罗越子。各持一金华盖。俱到佛所。前为作礼佛。以头面着佛足。皆持金华盖。前上佛已。悉却坐一面听经。阿闇世王太子。及五百长者子。闻阿弥陀佛二十四愿。皆大欢喜踊跃。心中俱愿言。令我等后作佛时。皆如阿弥陀佛。佛即知之。告诸比丘僧。是阿阇世王太子。及五百长者子。却后无数劫。皆当作佛如阿弥陀佛。佛言。是阿阇世王太子。及五百长者子。住菩萨道已来。无央数劫。皆各供养四百亿佛已。今复来供养我。阿阇世王太子。及五百长者子。皆前世迦叶佛时。为我作弟子。今皆复会是共相值也。则诸比丘僧。闻佛言皆踊跃。莫不代之欢喜者

佛告阿难。阿弥陀作佛已来。凡十小劫。所居国土。名须摩题。正在西方。去是阎浮提地界。千亿万须弥山佛国。其国地皆自然七宝。其一宝者白银。二宝者黄金。三宝者水精。四宝者琉璃。五宝者珊瑚。六宝者琥珀。七宝者车渠。是为七宝。皆以自共为地。旷荡甚大无极。皆自相参。转相入中。各自焜煌参明。极自软好。甚姝无比。其七宝地。诸八方上下。众宝中精味。自然合会。其化生耳。其宝皆比第六天上之七宝也。其国中无有须弥山。其日月星辰。第一四天王。第二忉利天。皆在虚空中。其国土无有大海。亦无有小海水。亦无江河恒水也。亦无有山林溪谷。无有幽冥之处。其国七宝地皆平正。无有泥犁禽兽薜荔。蜎飞蠕动之类。无有阿须伦诸龙鬼神。终无天雨时。亦无有春夏秋冬。亦无大寒。亦无大热。常和调中适。甚快善无比。皆有自然万种之物。百味饭食。意欲有所得。即自然在前。所不用者。即自然去。比如第六天上自然之物。恣若自然即皆随意。其国中悉诸菩萨阿罗汉。无有妇女。寿命无央数劫。女人往生。即化作男子。但有诸菩萨阿罗汉无央数。悉皆洞视彻听。悉遥相见。遥相瞻望。遥相闻语声。悉皆求道善者。同一种类。无有异人。其诸菩萨阿罗汉。面目皆端正。净洁绝好。悉同一色。无有偏丑恶者也。诸菩萨阿罗汉。皆才猛黠慧。皆衣自然之衣。心中所念道德。其欲语言。皆豫相知意所念。言常说正事。所语辄说经道。不说他余之恶。其语言音响。如三百钟声。皆相敬爱。无相嫉憎者。皆以长幼上下。先后言之。以义如礼。转相敬事如兄如弟。以仁履义。不妄动作言语。如诫转相教。令不相违戾。转相承受。皆心净洁。无所贪慕。终无嗔怒淫泆之心。愚痴之态。无有邪心念妇女意。悉皆智慧勇猛。和心欢乐好喜经道。自知前世所从来生亿万劫时。宿命善恶存亡。现在却知无极。阿弥陀佛所可教授。讲堂精舍。皆复自然七宝。金银水精琉璃白玉虎珀车磲。自共相成甚姝明。好绝无比。亦无作者。不知所从来。亦无持来者。亦无所从去。阿弥陀佛所愿德重。其人作善故。论经语义。说经行道。讲会其中。自然化生尔。其讲堂精舍。皆复有七宝楼观栏楯。复以金银水精琉璃白玉虎珀车磲为璎珞。复以白珠明月珠摩尼珠为交露。覆盖其上。皆自作五音声。甚好无比。诸菩萨阿罗汉所居舍宅。皆复以七宝金银水精琉璃珊瑚虎珀车磲码瑙化生。转共相成其舍宅。悉各有七宝楼观栏楯。复以金银水精琉璃白玉虎珀车磲为璎珞。复以白珠明月珠摩尼珠为交露。覆盖其上。皆各复自作五音声。阿弥陀佛讲堂精舍。及诸菩萨阿罗汉。所居舍宅中。内外处处。皆复有自然流泉浴池。皆与自然七宝俱生。金银水精琉璃虎珀车渠。转共相成。淳金池者。其水底沙白银也。淳白银池者。其水底沙黄金也。淳水精池者。其水底沙琉璃也。淳琉璃池者。其水底沙水精也。淳珊瑚池者。其水底沙虎珀也。淳虎珀池者。其水底沙珊瑚也。淳车渠池者。其水底沙马瑙也。淳马瑙池者。其水底沙车渠也。淳白玉池者。其水底沙紫磨金也。淳紫磨金池者。其水底沙白玉也。中复有两宝共作一池者。其水底沙金银也。中复有三宝共作一池者。其水底沙金银水精也。中复有四宝共作一池者。其水底沙金银水精琉璃也。中有五宝共作一池者。其水底沙金银水精琉璃珊瑚也。中有六宝共作一池者。其水底沙金银水精琉璃珊瑚虎珀也。中有七宝共作一池者。其水底沙金银水精琉璃珊瑚虎珀车渠也。中有浴池长四十里者。有长八十里者。有长百六十里者。有长三百二十里者。有长六百四十里者。有长千二百八十里者。有长二千五百六十里者。有长五千一百二十里者。有长万二百四十里者。有长二万四百八十里者。其池纵广适等是池者皆诸菩萨阿罗汉。常所可浴池。佛言。弥陀佛浴池长四万八千里。广亦四万八千里。其池皆以七宝转共相成。其水底沙白珠明月珠摩尼珠也。阿弥陀佛及诸菩萨阿罗汉。浴池中水皆清香洁。池中皆有香华。悉自然生百种华。种种异色。色异香华。枝皆千叶甚香无比也。香不可言。其华者亦非世间之华。复非天上之华。此华香都八方上下。众华香中精也。自然化生耳。其池中水流行。转相灌注。其水流行。亦不迟不駃。皆复作五音声佛言。八方上下。无央数佛国。诸天人民。及蜎飞蠕动之类。诸生阿弥陀佛国者。皆于七宝水池莲华中化生。便自然长大。亦无乳养之者。皆食自然之饮食。其身体亦非世间人之身体。亦非天上人之身体。皆积众善之德。悉受自然虚无之身。无极之体。甚姝好无比。佛语阿难。如世间贫穷乞丐人。令在帝王边住者。其面目形状宁类帝王面目形类颜色不。阿难言。假使王子在帝王边住者。其面目形状甚丑恶不好。不如帝王。百千亿万倍也。所以者何。乞人贫穷困极。饮食常恶。未常有美食时。既恶食不能得饱食。食才支命。骨节相撑拄。无以自给。常乏无有储饥饿寒冻。怔忪愁苦。但坐前世。为人愚痴。无智悭贪。不肯慈哀。为善博爱施与。但欲唐得贪惜饮食独食嗜美。不信施贷后得报偿。复不信作善后世当得其福。蒙悾抵佷益作众恶。如是寿终财物尽索。素无恩德无所恃怙。入恶道中坐之适苦。然后得出解脱。今生为人。作于下贱。为贫家作子。强像人形状类甚丑。衣被弊坏单空独立。不蔽形体乞丐生耳。饥寒困苦面目羸劣不类人色。坐其前世身之所作。受其殃罚。示众见之莫谁哀者。弃捐市道曝露痟瘦。黑丑恶极不及人耳。所以帝王人中独尊最好者何。皆其前世为人时。作善信受经道。布恩施德。博爱顺义。慈仁喜与。不贪饮食与众共之。无所匮惜都无违争。得其善福寿终德随不更恶道。今生为人得生王家。自然尊贵独王典主揽制人民为其雄杰。面目洁白和颜好色。身体端正众共敬事。美食好衣随心恣意。若乐所欲自然在前都无违争。于人中姝好。无忧快乐面目光泽。故乃尔耳。佛告阿难。若言是也。帝王虽于人中好无比者。当令在遮迦越王边住者。其面形类甚丑恶不好。比如乞人在帝王边住耳。其帝王面目。尚复不如遮迦越王面色姝好。百千亿万倍。如遮迦越王于天下绝好无比。当令在第二天王边住者。其面甚丑不好。尚复不如帝释面类端正姝好。百千亿万倍。如天帝释。令在第六天王边住者。其面类甚丑不好。尚复不如第六天王面类端正姝好。百千亿万倍。如第六天王。令在阿弥陀佛国中诸菩萨阿罗汉边住者。其面甚丑。尚复不如阿弥陀佛国中。菩萨阿罗汉面类端正姝好。百千亿万倍。佛言。阿弥陀佛国诸菩萨阿罗汉面类。悉皆端正绝好无比。次于泥洹之道。阿弥陀佛及诸菩萨阿罗汉。讲堂精舍所居处舍宅中。内外浴池上。皆有七宝树。中有淳金树。淳银树。淳水精树。淳琉璃树。淳白玉树。淳珊瑚树。淳琥珀树。淳车磲树。种种各自异行。中有两宝共作一树者。银树。银根金茎。银枝金叶。银华金实。金树者。金根银茎。金枝银叶。金华银实。水精树者。水精根琉璃茎。水精枝琉璃叶。水精华琉璃实。琉璃树者。琉璃根水精茎。琉璃枝水精叶。琉璃华水精实。是二宝共作一树。中复有四宝共作一树者。水精树。水精根琉璃茎。金枝银叶。水精华琉璃实。琉璃树者。琉璃根水精茎。金枝银叶。水精华琉璃实。是四宝树转共相成。各自异行。中复有五宝共作一树者。银根金茎。水精枝琉璃叶。银华金实。金树者。金根银茎。水精枝琉璃叶。珊瑚华银实。水精树者。水精根琉璃茎。珊瑚枝银叶。金华琉璃实。琉璃树者。琉璃根珊瑚茎。水精枝金叶。银华珊瑚实。珊瑚树者。珊瑚根琉璃茎。水精枝金叶。银华琉璃实。是五宝共作一树。各自异行。中有六宝共作一树者。银树。银根金茎。水精枝琉璃叶。珊瑚华虎珀实。金树者。金根银茎。水精枝琉璃叶。虎珀华珊瑚实。水精树者。水精根琉璃茎。珊瑚枝虎珀叶。银华金实。琉璃树者。琉璃根珊瑚茎。虎珀枝水精叶。金华银实。是六宝树转共相成。各自异行。中复有七宝共作一树者。银树。银根金茎。水精枝琉璃叶。珊瑚华虎珀实。金树者。金根水精茎。琉璃枝珊瑚叶。虎珀华银实。水精树者。水精根琉璃茎。珊瑚枝虎珀叶。车磲华白玉实。珊瑚树者。珊瑚根虎珀茎。白玉枝琉璃叶。车磲华明月珠实。虎珀树者。虎珀根白玉茎。珊瑚枝琉璃叶。水精华金实。白玉树者。白玉根车磲茎。珊瑚枝虎珀叶。金华摩尼殊实。是七宝树转共相成。种种各自异。行行相值。茎茎自相准。枝枝自相值。叶叶自相向。华华自相望。实实自相当。佛言。阿弥陀佛。当讲堂精舍中。内外七宝浴池绕边。上诸七宝树。及诸菩萨阿罗汉。七宝舍宅中。内外七宝浴池。绕池边诸七宝树。数千百重行。皆各如是。各自作五音声。音声甚好无比也。佛告阿难。如世间帝王有百种伎乐音声。不如遮迦越王诸伎乐音声好。百千亿万倍。如遮迦越王万种伎乐音声。尚复不如第二忉利天上诸伎乐一音声。百千亿万倍。如忉利天上万种伎乐之声。尚复不如第六天上一音声好。百千亿万倍。如第六天上万种音乐之声。尚复不如阿弥陀佛国中七宝树一音声好。百千亿万倍。阿弥陀佛国中。亦有万种自然伎乐。甚乐无极。阿弥陀佛。及诸菩萨阿罗汉欲浴时。便各自可入其七宝池中浴。诸菩萨阿罗汉意欲令水没足。水即没足。意欲令水至膝。水即至膝。意欲令水至腰。水即至腰。意欲令水至腋。水即至腋。意欲令水至颈。水即至颈。意欲令水自灌身上。水即自灌身上。意欲令水还复如故。水即还复如故。恣若随意所欲好喜。佛言。阿弥陀及诸菩萨阿罗汉皆浴已。悉自于一大莲华上坐。即四方自然乱风起。其乱风者。亦非世间之风。亦非天上之风。都八方上下众风中精。自然合会化生耳。不寒不热。常和调中适。甚清凉好无比也。徐起不迟不駃。适得中宜。吹七宝树。皆作五音声。以七宝树华。悉覆其国中。皆散佛及诸菩萨阿罗汉上。华随堕地。皆厚四寸。极自软好无比。即自然乱风吹萎华。悉自然去。即复四方自然乱风吹七宝树。树皆复作五音声。树华皆自然散佛及诸菩萨阿罗汉上。华小萎堕地。即自然去。即复四方乱风起吹七宝树。如是四反。诸菩萨阿罗汉。中有但欲闻经者。中有但欲闻音乐者。中有但欲闻华香者。有不欲闻经者。有不欲闻音乐声者。有不欲闻华香者。其所欲闻者。辄即独闻之。不欲闻者。则独不闻。随意所欲喜乐。不违其愿也。浴讫各自去。行道中有在地讲经者。诵经者。说经者。口受经者。听经者。念经者。思道者。坐禅者。经行者。中有在虚空中讲经者。诵经者。说经者。口受经者。听经者。念经者。思道者。坐禅一心者。经行者。未得须陀洹道者。即得须陀洹道。未得斯陀含道者。即得斯陀含道。未得阿那含道者。即得阿那含道。未得阿罗汉道者。即得阿罗汉道。未得阿惟越致菩萨者。即得阿惟越致。各自说经行道。悉皆得道。莫不欢喜踊跃者也。诸菩萨中。有意欲供养八方上下无央数诸佛。即皆俱前为佛作礼。白佛辞行。供养八方上下无央数佛。佛即然可之。即使行诸菩萨皆大欢喜。数千亿万人无央数不可复计。皆当智慧勇猛。各自幡辈飞相追。俱共散飞。则到八方上下无央数诸佛所。皆前为诸佛作礼。即便供养。意欲得万种自然之物。在前即自然。百种杂色华。百种杂缯彩。百种劫波育衣。七宝灯火。万种伎乐。悉皆在前。其华香万种自然之物。亦非世间之物。亦非天上之物也。是万种物。都八方上下。众自然合会化生耳。意欲得者。即自然化生。意不用者。即化去。诸菩萨便共持。供养诸佛及诸菩萨阿罗汉。边傍前后回绕周匝。在意所欲即辄皆至。当是之时。快乐不可言也。诸菩萨意。各欲得四十里华。即自然在前。便于虚空中。共持散诸佛及菩萨阿罗汉上。皆在虚空中下向。华甚香好。小萎堕地。即自然乱风吹。萎华悉自然去。诸菩萨意。各复欲得八十里华。即自然在前。共持散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。小萎堕地。即自然乱风吹。萎华悉自然去。诸菩萨意。各复欲得百六十里华。即自然在前。便于虚空中。共持散诸佛及诸菩萨阿罗汉上。华皆复于虚空中下向。小萎堕地。即自然乱风吹。萎华悉自然去。诸菩萨意。各复欲得三百二十里华。即自然在前。复于虚空中。持散诸佛及诸菩萨阿罗汉上。华于虚空中下向。小萎堕地。即自然乱风吹。萎华悉自然去。诸菩萨意。各复欲得六百四十里华。即自然在前。复以散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风自然吹萎华去。诸菩萨意。各复欲得千二百八十里华。即自然在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风自然吹。萎华悉自然去。诸菩萨意。各复欲得二千五百六十里华。即自然在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得五千一百二十里华。即自然在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得万二百四十里华。即皆自然在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得二万四百八十里华。即皆在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得五万里华。即皆在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得十万里华。即皆在前。诸菩萨复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得二十万里华。即皆在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得四十万里华。即皆在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各复欲得八十万里华。即皆在前。复于虚空中。共持散诸佛及诸菩萨阿罗汉上。皆在虚空中下向。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各欲得百六十万里华。即皆在前。共持散诸佛及诸菩萨阿罗汉上。小萎堕地。乱风吹萎华悉自然去。诸菩萨意。各欲得三百万里华。即皆在前。共持散诸佛及诸菩萨阿罗汉上。小萎堕地。乱风吹萎华自然去。诸菩萨意。各欲得六百万里华。即皆在前。共持散诸佛及诸菩萨阿罗汉上。华都自然合为一华。华正端圆周匝各适等。华转倍前。华极自软好。胜于前华数千百倍。色色异。香香不可言。诸菩萨皆大欢喜。俱于虚空中。大共作众音自然伎乐。乐诸佛及诸菩萨阿罗汉。当此之时。快乐不可言。诸菩萨皆悉却坐听经。听经竟即悉讽诵通。重知经道。益明智慧。即诸佛国中。从第一四天上。至三十三天上。诸天人皆共持天上万种自然之物来下。供养诸菩萨阿罗汉。天人皆复于虚空中。大共作众音伎乐。诸天人前来者。转去避后来者。后来者转复供养如前。更相开避。诸天人欢喜听经。大共作音乐。当是时快乐无极。诸菩萨供养听经讫竟。便皆起为佛作礼而去。即复飞到八方上下。无央数诸佛所。供养听经。皆各如前。悉遍已后。日未中时。各飞还其国。为阿弥陀佛作礼。皆却坐听经竟大欢喜。佛言。阿弥陀佛及诸菩萨阿罗汉欲食时。即自然七宝机。劫波育罽叠以为座。佛及菩萨皆坐前。悉有自然七宝。钵中有百味饮食。饮食者亦不类世间。亦非天上。此百味饮食。八方上下。众自然饮食中精味。甚香美无比。自然化生耳。欲得甜酢在所欲得。诸菩萨阿罗汉中。有欲得金钵者。有欲得银钵者。有欲得水精钵者。有欲得珊瑚钵者。有欲得虎珀钵者。有欲得白玉钵者。有欲得车磲钵者。有欲得马瑙钵者。有欲得明月珠钵者。有欲得摩尼珠钵者。有欲得紫磨金钵者。随意即至。亦无所从来。亦无供养者。自然化生耳。诸菩萨阿罗汉皆食。食亦不多亦不少悉平等。亦不言美恶。亦不以美故喜。食讫诸饭具钵机座。皆自然化去。欲食时乃复化生耳。诸菩萨阿罗汉。皆心净洁。所饮食但用作气力尔。皆自然消散摩尽化去

佛告阿难。阿弥陀佛。为诸菩萨阿罗汉说经时。都悉大会讲堂上。诸菩萨阿罗汉。及诸天人民无央数。都不可复计。皆飞到阿弥陀佛所。为佛作礼却坐听经。其佛广说道智大经。皆悉闻知。莫不欢喜踊跃心开解者。即四方自然乱风起。吹七宝树。皆作五音声。七宝树华。覆盖其国。皆在虚空中下向。其华之香遍一国中。皆散阿弥陀佛。及诸菩萨阿罗汉上。华堕地皆厚四寸。小萎即乱风吹。萎华自然去。四方乱风。吹七宝树华。如是四反。即第一四天王。第二忉利天上。至三十二天上。诸天人皆持天上万种自然之物。百种杂色华。百种杂香。百种杂缯彩。百种劫波育叠衣。万种伎乐转倍好相胜。各持来下。为阿弥陀佛作礼。供养佛及诸菩萨阿罗汉。诸天人皆复大作伎乐。乐阿弥陀佛及诸菩萨阿罗汉。当是时。快乐不可言。诸天更相开避后来者。转复供养如前。即东方无央数佛国。其数不可复计。如恒水边流沙。一沙一佛其数如是。诸佛各遣诸菩萨无央数。不可复计。皆飞到阿弥陀佛所。作礼听经。皆大欢喜。悉起为作礼如去。西方北方南方四角诸佛。其数各如恒水边流沙。各遣诸菩萨无央数。飞到阿弥陀佛所。作礼听经亦复如是。即下方上方诸佛。其数各如恒水边流沙。皆遣诸菩萨。都不可复计。飞到阿弥陀佛所。作礼听经。更相开避。如是终无休绝时也。佛言。所以诸佛以恒水边流沙为数者。八方上下无央数佛。甚大众多。都各不可复计。故以恒水边流沙为数耳

佛语阿难。阿弥陀佛。为诸菩萨阿罗汉说经竟。诸天人民中。有未得道者。即得道。未得须陀洹者。即得须陀洹。未得斯陀含者。即得斯陀含。未得阿那含者。即得阿那含。未得阿罗汉者。即得阿罗汉。未得阿惟越致菩萨者。即得阿惟越致菩萨。阿弥陀佛。辄随其宿命时。求道心所喜愿。大小随意。为说经授与之即令疾开解得。皆悉明慧。各自好喜。所愿经道。莫不喜乐。诵习之者。自讽诵通利。无厌无极。诸菩萨阿罗汉中。有诵经者。其音如三百钟声。中有说经者。如疾风暴雨时。如是尽一劫竟。终无懈倦时。皆悉智慧勇猛。身体轻便。终无痛痒。极时行步坐起。悉皆才健勇猛。如师子中王。在深山中。有所趣向。时无有敢当者。无有疑难之意。在心所作。为不可豫计。百千亿万倍。是猛师子中王。百千亿万倍。尚复不如我第二弟子摩诃目揵连勇猛。百千亿万倍。如摩诃目揵连。于诸国菩萨阿罗汉中。最为无比。飞行进止。智慧勇猛。洞视彻听。知八方上下去来现在之事。百千亿万倍。共合为一智慧。当令在阿弥陀佛国中诸罗汉边。其德尚复不及。百千亿万倍。阿逸菩萨。即起前长跪叉手。问佛言。阿弥陀佛国中。诸阿罗汉。宁颇有般泥洹去者无。愿欲闻之。佛言。若欲知者。如是四天下星。若见之不。阿逸菩萨言。唯然见之。佛言。如我第二弟子。摩诃目揵连。飞上天上一昼一夜。遍数知星有几枚。此四天下星甚众多。不可得计尚复百千亿万倍是星也。如天下大海水减去一渧。宁能令海水为减。知少不耶。对曰。减去百千亿万斗石。尚不能令减知少也。佛言。阿弥陀佛国。诸阿罗汉中。虽有般泥洹去者。如大海减一渧水尔。不能令在诸阿罗汉为减知少也。佛言。大海减去一溪水。宁令减少不。对曰。减去百千亿万溪水。尚不能减知少也。佛言。减大海一恒水。宁能令减知少不。对曰。减去百千亿万恒水。不能令减知少也。佛言。阿弥陀佛国。诸阿罗汉。般泥洹去者无央数。其在者新得道者亦无央数。都不为增减也。佛言。令天下诸水。都流入大海水中。宁能令海水增多不。对曰。不能令增多也。所以者何。是大海为天下诸水众善中王。故能尔耳。佛言。阿弥陀佛国亦如是。悉令八方上下。无央数佛国。诸无央数天人民。蜎飞蠕动之类都往生。甚大众多不可复计。阿弥陀佛国。诸菩萨阿罗汉众比丘僧。故如常一法不异为增多。所以者何。阿弥陀佛国为最快。八方上下无央数。诸佛国中众善之王。诸佛国中之雄。诸佛国中之宝。诸佛国中寿之极长久也。诸佛国中之众杰也。诸佛国中之广大也。诸佛国中之都。自然之无为。最快明好甚乐之无极。所以者何。阿弥陀佛本为菩萨时。所愿勇猛。精进不懈。累德所致。故能尔耳。阿逸菩萨即大欢喜。长跪叉手言。佛说阿弥陀佛国土。快善明好最姝无比。乃独尔乎。佛言。阿弥陀佛国。诸菩萨阿罗汉所居。七宝舍宅中。有在虚空中者。有在地者。中有欲令舍宅最高者。舍宅即高中。有欲令舍宅最大者。舍宅即大中。有欲令舍宅在虚空中者。舍宅即在虚空中。皆自然随意在所作为。中有殊不能令舍宅随意者。所以者何。中有能令舍宅随意者。皆是前世宿命求道时。慈心精进。益作诸善。德重所致。中有殊不能者。皆是前世宿命求道时。不慈心精进益作诸善。德薄所致。其所衣被饭食。俱自然平等。德有大小。别知其勇猛。令众见之耳。佛言。若见第六天王所居处不。唯然见之。佛言。阿弥陀佛国讲堂舍宅。都复胜第六天王所居处。百千亿万倍。诸菩萨阿罗汉。悉皆洞视彻听。见知八方上下去来现在之事。复无数天上天下人民。及蜎飞蠕动之类。心意所念善恶。口所欲言。皆知当何岁何劫。得度脱得人道。往生阿弥陀佛国。知当作菩萨阿罗汉。皆豫知之。诸菩萨阿罗汉顶中。皆悉自有光明。所照有大小。诸菩萨中。有最尊两菩萨。常在佛左右坐侍正论。佛常与是两菩萨共对坐。议八方上下去来现在之事。若欲使是两菩萨。到八方上下无央数诸佛所。即便飞行。随心所欲至到飞行。使疾如佛。勇猛无比。其一菩萨名盖楼亘。其一菩萨名摩诃那钵。光明智慧最第一。顶中光明各焰照他方。千须弥山佛国中常大明。其诸菩萨顶中光明各照千亿万里。诸阿罗汉顶中光明。各照七丈。佛言。世间人民。若善男子善女人。若有急恐怖县官事者。但自归命是盖楼亘菩萨摩诃那钵菩萨所。无不得解脱者

佛告阿逸菩萨。阿弥陀佛顶中光明。极大光明。其日月星辰。皆在虚空中住止。不可复回转运行。亦无有精光。其明皆蔽不复见。佛光明照国中。及焰照他方佛国常大明。终无有冥时。其国无有一日二日。亦为五日十日。亦无十五日一月。亦无五月十月五岁十岁。亦无百岁千岁。亦无万岁亿万岁。无百千亿万岁。无有一劫十劫百劫千劫。无万劫百万劫。无千万劫百亿万劫。阿弥陀佛光明。明无有极。却后无数劫。无数劫重复无数劫。无数劫无央数。终无有当冥时。国土及诸天。终无坏败时。所以者何。阿弥陀佛寿命极长。国土甚好。故能尔耳。其佛尊寿。却后无数劫。重复无数劫。尚未央般泥洹也。于世间教授。意欲过度八方上下。诸无央数佛国。诸天人民。及蜎飞蠕动之类。皆欲使往生其国。悉令得泥洹之道。其作菩萨者。皆欲令悉作佛。作佛已。转复教授。八方上下。诸天人民。及蜎飞蠕动之类。皆复欲令作佛。作佛已。复教授诸无央数天人民。蜎飞蠕动之类。皆令得泥洹道去。诸可教授弟子者。展转复相教授。转相度脱。至令得须陀洹。斯陀含。阿那含。阿罗汉。辟支佛道。转相度脱。皆得泥洹之道悉如是。尚未欲般泥洹。阿弥陀佛所度脱。展转如是。复住止无数劫。无数劫不可复计劫。终无般泥洹时。八方上下。诸无央数天人民。蜎飞蠕动之类。其生阿弥陀佛国。当作佛者。不可复胜数。诸作阿罗汉。得泥洹道者。亦无央数。都不可复计。阿弥陀佛恩德。诸所布施。八方上下。无穷无极。甚深无量。快善不可言。其智慧教授所出经道。布告八方上下。诸无央数天上天下。甚不原也。其经卷数甚众多。不可复计。都无有极。佛告阿逸菩萨。若欲知阿弥陀佛寿命无极时不。对曰。愿皆欲闻知之。佛言。明听。悉令八方上下。诸无央数佛国中。诸天人民。蜎飞蠕动之类。皆使得入道。悉令作辟支佛阿罗汉。共坐禅一心。都合其智慧为一勇猛。共欲计知阿弥陀佛寿命。几千亿万劫岁数。皆无有能计知者。复令他方面各千须弥山佛国中。诸天人民。蜎飞蠕动之类。皆复使得入道。悉令作辟支佛阿罗汉。皆令坐禅一心。合其智慧为一勇猛。共欲数阿弥陀佛国中。诸菩萨阿罗汉。知有几千亿万人。皆无有能知数者。阿弥陀年寿甚长久。浩浩照照。明善甚深。无极无底谁当能知信其者。独佛自信知尔。阿逸菩萨闻佛言大欢喜。长跪叉手言。佛说阿弥陀佛寿命甚长。威神尊大。智慧光明巍巍快善。乃独如是。佛言。阿弥陀佛。至其然后。般泥洹者。其盖楼亘菩萨。便当作佛。总领道智。典主教授。世间及八方上下。所过度诸天人民。蜎飞蠕动之类。皆令得佛泥洹之道。其善福德。当复如大师阿弥陀佛。住止无央数劫。无央数劫不可复计劫。准法大师。尔乃般泥洹。其次摩诃那钵菩萨。当复作佛。典主智慧。总领教授。所过度福德。当复如大师阿弥陀佛。止住无央数劫。尚复不般泥洹。展转相承受。经道甚明。国土极善。其法如是。终无有断绝。不可极也

阿难长跪叉手。问佛言。阿弥陀佛国中。无有须弥山。其第一四天。第二忉利天。皆依因何等住止。愿欲闻之。佛告阿难。若有疑意于佛所耶。八方上下。无穷无极。无边无量。诸天下大海水。一人斗量之。尚可枯尽得其底泥。佛智不如是。佛言。我所见知。诸已过去佛。如我名字释迦文佛者。复如恒水边流沙。一沙一佛。诸当来佛。如我名字。亦如恒水边流沙。甫始欲求作佛者。如我名字。亦如恒水边流沙。佛正坐直南向。视见南方。今现在佛。如我名字者。复如恒水边流沙。八方上下。去来现在诸佛。如我名字者。各如十恒水边流沙。一沙一佛。其数如是。佛皆悉豫见知之。佛言。往昔过去无数劫已来。一劫十劫。百劫千劫。万劫亿劫。亿万亿劫中有佛。诸已过去佛。一佛十佛百佛千佛。万佛亿佛。亿万亿佛。各自有名字不同。无有如我名字者。甫始当来劫。一劫十劫。百劫千劫。万劫亿劫。亿万亿劫。劫中有佛。一佛十佛。百佛千佛。万佛亿佛。亿万亿佛。各各自有名字不同。时时乃有一佛如我名字耳。诸八方上下。无央数佛国。今现在佛。次他方异国。一佛国十佛国。百佛国千佛国。万佛国亿佛国。亿万亿佛国中有佛。各自有名字。多多复不同。无如我名字者。八方上下。无央数诸佛中。时时乃有如我名字尔。八方上下。去来现在。其中间旷绝甚远。悠悠迢迢。无穷无极。佛智亘然甚明。探古知今。前知无穷却睹未然。豫知无极。都不可复计。甚无央数佛。威神尊明。皆悉知之。佛智慧道德合明。都无能问佛经道穷极者。佛智慧终不可称量尽也。阿难闻佛言。即大恐怖衣毛皆起。白佛言。我不敢有疑意于佛所。所以问佛者。他方佛国。皆有须弥山。第一四天。第二忉利天。皆依因之住止。我恐佛般泥洹后。傥有诸天人民。若比丘僧比丘尼优婆塞优婆夷来问我。阿弥陀佛国。何以独无有须弥山。其第一四天王。第二忉利天。皆依因何等住止。我当应答之。今不问佛者。佛去后。当持何等语报答之。独佛自知之尔。余人无有能为我解者。以是故问佛耳。佛言阿难。是第三焰天。第四兜术天上。至第七梵天。皆依因何等住止乎。阿难言。是诸天皆自然在虚空中住在。虚空中住止。无所依因。佛威神甚重。自然所欲作为。意欲有所作。为不豫计。是诸天皆尚在虚空中住止。何况佛威神尊重。欲有所作为耶。阿难闻佛言。即大欢喜。长跪叉手言。佛智慧知八方上下去来现在之事。无穷无极无有边幅甚高大妙绝快善。极明好甚无比。威神尊重不可当

阿弥陀经卷上佛说阿弥陀经卷下

        吴月支国居士支谦译

佛告阿逸菩萨。其世间人民。若善男子善女人。愿欲往生阿弥陀佛国者有三辈。作德有大小转不相及。佛言。何等为三辈。最上第一辈者。当去家舍妻子断爱欲。行作沙门。就无为之道。当作菩萨道。奉行六波罗蜜经者。作沙门不亏经戒。慈心精进不当嗔怒。不当与女人交通。斋戒清净。心无所贪慕。至诚愿欲往生阿弥陀佛国。常念至心不断绝者。其人便于今世求道时。即自然于其卧止梦中。见阿弥陀佛及诸菩萨阿罗汉。其人寿命欲终时。阿弥陀佛即自与诸菩萨阿罗汉。共翻飞行迎之。则往生阿弥陀佛国。便于七宝水池莲华中化生。即自然受身长大。则作阿惟越致菩萨。便即与诸菩萨。共翻辈飞行。供养八方上下诸无央数佛。即逮智慧勇猛。乐听经道。其心欢乐。所居七宝舍宅。在虚空中。恣随其意。在所欲作为。去阿弥陀佛近。佛言。诸欲往生阿弥陀佛国者。当精进持经戒。奉行如是上法者。则得往生阿弥陀佛国。可得为众所尊敬。是为上第一辈

佛言。其中辈者。其人愿欲往生阿弥陀佛国。虽不能去家舍妻子断爱欲行作沙门者。当持经戒无得亏失。益作分檀布施。常信受佛经语。深当作至诚中信。饭食诸沙门。作佛寺起塔。散华烧香然灯。悬杂缯彩。如是法者。无所适莫。不当嗔怒。斋戒清净。慈心精进。断爱欲念。欲往生阿弥陀佛国。一日一夜不断绝者。其人便于今世。亦复于卧止梦中。见阿弥陀佛。其人寿命欲终时。阿弥陀佛即化。令其人目自见阿弥陀佛及其国土。往至阿弥陀佛国者。可得智慧勇猛。佛言。其人奉行施与如是者。若其人然后复中悔。心中狐疑。不信分檀布施作诸善后世得其福。不信有弥陀佛国。不信有往生其国。虽尔者。其人续念不绝。暂信暂不信。意志犹豫无所专据。续其善愿为本故得往生。其人寿命病欲终时。阿弥陀佛。即自化作形像。令其人目自见之。口不能复言。但心中欢喜踊跃意念言。我悔不知益斋戒作善。今当往生阿弥陀佛国。其人即心自悔过。悔过者小差少无所复及。其人寿命终尽。即往生阿弥陀佛国。不能得前至阿弥陀佛所。便道见阿弥陀佛国界边自然七宝城中。心便大欢喜。便止其城中。即于七宝水池莲华中化生。则受身自然长大在城中。于是间五百岁。其城广纵各二千里。城中亦有七宝舍宅。中外内皆有七宝浴池。浴池中亦有自然华香绕。浴池上亦有七宝树重行。亦皆复作五音声。其欲饭食时。前有自然食。具百味饮食。在所欲得应意皆至。其人于城中亦快乐。其城中比如第二忉利天上自然之物。虽尔其人城中不能得出。复不能得见阿弥陀佛。但见其光明。心自悔责。踊跃喜耳。亦复不能得闻经。亦复不能得见诸比丘僧。亦复不能得见知阿弥陀佛国中诸菩萨阿罗汉状貌何等类。其人愁苦。如是比如小适耳。佛亦不使尔身行所作自然得之。皆心自趣向道。入其城中。其人本宿命求道时。心口各异。言念无诚信。狐疑佛经。复不信向之。当自然入恶道中。阿弥陀佛哀愍。威神引之去尔。其人于城中。五百岁乃得出。往至阿弥陀佛所闻经。心不开解。亦复不得在诸菩萨阿罗汉比丘僧中听经。以去所居处舍宅在地。不能令舍宅随意高大在虚空中。复去阿弥陀佛甚大远。不能得近附阿弥陀佛。其人智慧不明。知经复少。心不欢喜。意不开解。其人久久。亦自当智慧开解知经。明健勇猛。心当欢喜。次当复如上第一辈。所以者何。其人但坐前世宿命求道时。不大持斋戒。毁失经法。意志狐疑。不信佛语。不信佛经深。不信分檀布施作。善后世当得其福。复坐中悔。不信往生阿弥陀佛国。作德不至心。用是故尔。是为第二中辈

佛言。其三辈者。其人愿欲往生阿弥陀佛国。若无所用分檀布施。亦不能烧香散华然灯。悬杂缯彩。作佛寺起塔。饭食诸沙门者。当断爱欲无所贪慕。得经疾慈心精进。不当嗔怒。斋戒清净。如是法者。当一心念欲往生阿弥陀佛国。昼夜十日不断绝者。寿命终即往生阿弥陀佛国。可得尊敬。智慧勇猛。佛言。其人作是以后。若复中悔。心意狐疑。不信作善后世当得其福。不信往生阿弥陀佛国。其人虽尔。续得往生。其人寿命病欲终时。阿弥陀佛。即令其人。于卧止梦中。见阿弥陀佛土。心中大欢喜。意自念言。我悔不知益作诸善。今当往生阿弥陀佛国。其人但念是。口不能复言。即自悔过。悔过者差减少悔无所复及。其人命终。即生阿弥陀佛国。不能得前至。便道见二千里七宝城中。心独欢喜。便止其中。亦复于七宝浴池莲华中化生。即自然受身长大。其城亦复如前城法。比如第二忉利天上自然之物。其人亦复于城中。五百岁竟乃得出。至阿弥陀佛所。心中大喜。其人听闻经。心不开解。意不欢乐。智慧不明。知经复少。所居舍宅在地。不能令舍宅随意高大在虚空中。复去阿弥陀佛大远。不能得近附阿弥陀佛。亦复如是。第二中辈狐疑者也。其人久久。亦当智慧开解。知经勇猛。心当欢乐。次如上第一辈也。所以者何。皆坐前世宿命求道时。中悔狐疑。暂信暂不信。不信作善得其福德。皆自然得之尔。随其功德有所铉不铉。各自然趣向。说经行道。卓亿万超绝不相及。佛言。其欲求作菩萨道生阿弥陀佛国者。其人然后。皆当得阿惟越致菩萨。阿惟越致菩萨者。皆当有三十二相紫磨金色八十种好。皆当作佛。随所愿在所求欲。于他方佛国作佛。终不复更泥犁禽兽薜荔。随其精进求道。早晚之事同等尔。求道不休会当得之。不失其所欲愿也

佛告阿逸菩萨等。诸天帝王人民。我皆语汝曹。诸欲往生阿弥陀佛国者。虽不能大精进禅定持经戒者。大要当作善。一者不得杀生。二者不得盗窃。三者不得淫泆奸爱他人妇女。四者不得调欺。五者不得饮酒。六者不得两舌。七者不得恶口。八者不得妄言。九者不得嫉妒。十者不得贪餮。不得心中有所悭惜。不得嗔怒。不得愚痴。不得随心嗜欲。不得心中悔。不得狐疑。当作孝顺。当作至诚忠信。当信受佛经语。深当信作善后世得其福。奉持如是。其法不亏失者。在心所愿。可得往生阿弥陀佛国。至要当斋戒一心清净。昼夜常念。欲往生阿弥陀佛国。十日十夜不断绝。我皆慈哀之。悉令生阿弥陀佛国。佛言。世间人以欲慕及贤明。居家修善为道者。与妻子共居在恩好爱欲之中。忧念苦多家事匆务。不暇大斋一心清净。虽不能得去家弃欲。有空闲时。自端心意。念身作善专精行道。十日十夜者。殊使不能尔自思惟熟挍计。欲度脱身者。下当绝念去忧。勿念家事。莫与妇人同床。自端正身心断于爱欲。一心斋戒清净。至意念生阿弥陀佛国。一日一夜不断绝者。寿终皆往生其国。在七宝浴池华莲中化生。可得智慧勇猛。所居七宝舍宅。自在意所欲作为。可次如上第一辈。佛语阿逸菩萨言。诸八方上下。无央数诸天人民。比丘僧比丘尼优婆塞优婆夷。往生阿弥陀佛国。众等大会。皆共于七宝浴池水中。都共人人。悉自于一大莲华上坐。皆悉自陈道德行善。人人各自说其前世宿命求道时。持戒所作善法。所从来生本末。其所好喜经道。知经智慧。所施行功德。从上次下转皆遍已。知经有明不明。智有深浅大小。德有优劣厚薄。自然之道别知。才能智慧健猛。众相观照。礼义和顺。皆自欢喜踊跃。智慧有勇猛。各不相属逮。佛言。其人殊不豫作德。为善轻戏。不信使然。徒倚懈怠。为用可尔。至时都集说经道。自然迫促。应答迟晚。道智卓殊超绝。才能高猛。独于边羸。临事乃悔。悔者已出。其后当复何益。但心中悷悢。慕及等尔

佛言。阿弥陀佛国。诸菩萨阿罗汉众等。大聚会自然都集。拘心制意。端身正行。游戏洞达。俱相随飞行。翻辈出入。供养无极。欢心喜乐。共观经行道。和好久习。才猛智慧。志若虚空。精进求愿。心终不复中徊。意终不复转。终无有懈极时。虽求道。外若迟缓。内独急疾。容容虚空。适得其中。中表相应。自然严整。捡敛端直。身心清洁。无有爱欲。无所适贪。无有众恶瑕秽。其志愿皆各安定殊好。无增缺减。求道和正。不误倾邪。准望道法。随经约令不敢违蹉跌。若于八方上下。无有边幅。自在所欲。至到无穷无极。咸然为道。恢廓及旷荡。念道无他之念。无有忧思。自然无为。虚无空立。恢安无欲。作得善愿。尽心求索。含哀慈愍。精进中表。礼义都合。通洞无违。和顺副称。褒罗表里。过度解脱。能升入泥洹。长与道德合明。自然相保守。快意之滋真滋。真了洁白。志愿无上。清净之安定。静乐之无有极。善好无有比。巍巍之耀照。耀照亘开达明彻。自然中自然相。然之有根本。自然成五光。五光至九色。九色参徊转。数百千更变。郁单之自然。自然成七宝。横揽成万物。光精参明俱出好。甚姝无有极。其国土甚若此。何不力为善。念道之自然。着于无上下。洞达无边幅。捐志虚空中。何不各精进。努力自求索。可得超绝去。往生阿弥陀佛国。横截于五恶道。自然闭塞。升道之无极。易往无有人。其国土不逆违。自然之随牵。何不弃世事。行求道德。可得极长生。寿无有极。何为着世事。譊譊共忧思无常。世人薄俗。共诤不急之事。共于是处剧恶极苦之中。勤身治生。用相给活。无尊无卑。无富无贫。无老无少。无男无女。皆当共忧钱财。有无同然。忧思适等。屏营愁苦。累念思虑。为心使走。无有安时。有田忧田。有宅忧宅。有牛忧牛。有马忧马。有六畜忧六畜。有奴婢忧奴婢。有衣被钱财金银宝物。复共忧之。重思累息。忧念愁恐。横为非常。水火盗贼。怨主债家。所漂烧系唐突没溺。忧毒忪忪无有解时。结愤胸中蓄气恚怒。病在胸腹忧苦不离。心坚意固适无纵舍。或坐摧藏终身亡命。弃捐之去莫谁随者。尊卑豪贵贫富。有是忧惧。勤苦此。结众寒热与痛共居。小家贫者穷困苦乏。无田亦忧欲有田。无宅亦忧欲有宅。无牛亦忧欲有牛。无马亦忧欲有马。无六畜亦忧欲有六畜。无奴婢亦忧欲有奴婢。无衣被钱财什物饮食之属。亦忧欲有之。适有一复少一。有是少是思有齐等。适小具有便复赐尽。如是苦生。当复求索。思想无益不能时得。身心俱劳坐起不安。忧意相随勤苦如此。焦心不离恚恨独怒。亦结众寒热与痛同居。或时坐之终身夭命。亦不肯作善为道。寿命终尽死。皆当独远去。有所趣向。善恶之道莫能知之。或时世人父子兄弟。夫妇家室中外亲属。居天地之间。当相敬爱。不当相憎。有无当相给与。不当有贪惜。言色当和。莫相违戾。或傥心诤有所恚怒。今世恨意微相嫉憎。后世转剧致成大怨。所以者何。如今之事更欲相害。虽不临时应急相破。然之愁毒结愤精神。自然克识不得相离。皆当对相生。值更相报复。人在世间爱欲之中。独往独来独死独生。当行至苦乐之处。身自当之无有代者。善恶变化。殃咎恶处。宿豫严待。当独升入远到他处。莫能见去在何所。善恶自然追逐行生。窈窈冥冥别离久长。道路不同会见无期。甚难得复相值。何不弃家事。各曼强健时。努力为善。力精进求度世。可得极长寿。殊不肯求于道。复欲须待欲何乐乎。如是世人。不信作善得善。不信为道得道。不信死后世复生。不信施与得其福德。都不信之。尔以谓不然。终无有是但坐。是故且自见之。更相代闻。前后相续。转相承受。父余教令。先人祖父。素不作善。本不为道。身愚神闇。心塞意闭。不见大道。殊无有能。见人死生。有所趣向。亦莫能知者。适无有见善恶之道。复无语者。为用作善恶福德。殃咎祸罚。各自竞作为之用。殊无有怪也。至于死生之道。转相续立。或子哭父。或父哭子。或弟哭兄。或兄哭弟。或妇哭夫。或夫哭妇。颠倒上下无常根本。皆当过去。不可常得。教语开导。信道者少。皆当死生。无有休止。如是曹人。朦冥抵突。不信经语。各欲快意。心不计虑。愚痴于爱欲。不解于道德。迷惑于嗔怒。贪狼于财色。坐之不得道。当更勤苦。极在恶处生。终不得止休。息痛之甚可伤。或时家室中外。父子兄弟夫妇。至于死生之义。更相哭泣转相思慕。忧念愤结恩爱绕续。心意着痛对相顾恋。昼夜缚碍无有解时。教视道德心不开明。思想恩好情欲不离。闭塞蒙瞑交错覆蔽。不能思计。心自端正决断世事。专精行道便旋至竟。寿终命尽不能得道。无可那何。总猥愦譊皆贪爱欲。如是之法。不解道者多。得道者少。世间匆匆。无可聊赖。尊卑上下。豪贵贫富。男女大小。各自匆务。勤苦躬身怀杀毒。恶气窈冥。莫不惆怅。为妄作事。恶逆天地。不从人心。道德非恶。先随与之。恣听所为。其寿未至。便顿夺之。下入恶道。累世勤苦。展转愁毒。数千万亿岁。无有止期。痛不可言。甚可怜愍

佛告阿逸菩萨等诸天帝王人民。我皆语汝。造世间之事人。用是故坐不得道。汝曹熟思惟之。恶者当纵舍远离之去。从其善者。当坚持勿妄为非。益作诸善。大小多少爱欲之荣。皆不可常得。由当别离无可乐者。曼佛世时。其有信受佛经语深。奉行道德。皆是我小弟也。其欲有甫学佛经戒者。皆是我弟子。其有欲出身去家舍妻子。绝去财色。欲作沙门为佛作比丘者。皆是我子孙。我世甚难得值。其有愿欲生阿弥陀佛国者。可得智慧勇猛。为众所尊敬。勿得随心所欲。亏负经戒。在于人后。傥有疑意不解经者。复前问佛。为汝解之。阿逸菩萨长跪叉手言。佛威神尊重。所说经快善。我曹听经语。皆心贯之。世人实尔。如佛所语无有异。今佛慈哀我曹。开示大道教语生路。耳目聪明长得度脱。今若得更生。我曹听佛经语。莫不慈心欢喜踊跃开解者。及诸天帝王人民。蜎飞蠕动之类皆蒙恩。无不解脱忧苦者。佛语教戒甚深善。无极无底。佛智慧所见知。八方上下。去来现在之事。无上无下。无边无幅。佛甚难得闻。我曹比慈心于佛所。令我曹得度脱者。皆是佛前世求道时。勤苦学问。精明所致。恩德普覆。所施行福德。相禄巍巍。光明彻照。洞虚无极。贯入泥洹。教授揽典。制威消化。改动八方上下。无穷无极。佛为师法尊绝群圣。都无能及佛者。佛为八方上下。诸天帝王人民作师。随其心所欲愿。大小皆令得道。今我曹得与佛相见。得闻阿弥陀佛声。我曹甚喜。莫不得黠慧开明者。佛告阿逸菩萨。若言是实当尔。若有慈心于佛所者大喜。实当念佛。天下久久。乃复有佛耳。今我于苦世作佛。所出经道。教授洞达。截断狐疑。端心正行。拔诸爱欲。绝众恶根本。游步无拘。典总智慧。众道表里。揽持维纲。照然分明开视五道。决正生死泥洹之道。佛言。若曹从无数劫以来。不可复计劫。若曹作菩萨道。欲过度诸天人民及蜎飞蠕动之类。已来甚久远。人从若得道度者无央数。至得泥洹之道者亦无央数。若曹及八方上下。诸天帝王人民。若比丘比丘尼。优婆塞优婆夷。若曹宿命。从无数劫已来。展转是五道中。死生呼嗟。更相哭泪。转相贪慕。忧思愁毒。痛苦不可言。至今世死生不绝。乃今日与佛相见共会值。是乃闻阿弥陀佛声甚快善。我助汝曹喜。亦可自厌死生痛痒。生时甚痛甚苦甚极。至年长大亦苦亦极。死时亦痛亦苦亦极。甚恶臭处不净。洁了无有可者。佛故悉语若曹。若曹亦可自决断臭处恶露。若曹亦可端心正身。益作诸善。于是常端中外。洁净身体。洗除心垢。自相约捡。表里相应。言行忠信。人能自度脱。转相扶接。拔诸爱欲。精明至心。求愿不转。结其善道根本。虽精苦一世。须臾间耳。今世为善。后世生阿弥陀佛国。快乐甚无极。长与道德合明。然善相保守。长去离恶道痛痒之忧恼。拔勤苦诸恶根本。断诸爱欲恩好。长生阿弥陀佛国。亦无有诸痛痒。亦无复有诸恶臭处。亦无复有勤苦。亦无淫泆嗔怒愚痴。亦无有忧思愁毒。生于阿弥陀佛国。欲寿一劫十劫。百劫千劫万亿劫。自恣意欲住止寿无央数劫。不可复计数劫。恣汝随意皆可得之。欲食不食。恣若其意。都悉自然。皆可得之。次于泥洹之道。皆各自精明求索。心所欲愿。勿得狐疑心中悔。欲往生者。无得坐其过失。在阿弥陀佛国界边。自然七宝城中。讁五百岁。阿逸菩萨言。受佛严明重教。皆当精进一心求索。请奉行之不敢疑怠

佛告阿逸菩萨等。若曹于是世。能自制心正意。身不作恶者。是为大德善。都有一辈。为八方上下。最无有比。所以者何。八方上下。无央数佛国中。诸天人民。皆自然作善。不大为恶易教化。今我于是世间作佛。为于五恶五痛五烧之中作佛。为最剧教语人民。令纵舍五恶。令去五痛。令去五烧之中。降化其心。令持五善。得其福德度世长寿泥洹之道。佛言。何等为五恶。何等为五痛。何等为五烧中者。何等为消化五恶。令得五善者。何等为持五善。得其福德长寿。度世泥洹之道。佛言。其一恶者。天人民下至禽兽。蜎飞蠕动之属欲为众恶。强者服弱转相克贼。自相杀伤更相食啖。不知作善。恶逆不道。受其殃罚道之自然。当往趣向神明记识。犯之不贳转相承续。故有贫穷下贱乞丐孤独。故有聋盲喑哑愚痴憋恶。下有尪狂不及逮之属。故有尊卑豪贵高才明达智慧勇猛。皆其前世宿命。为善慈孝布施恩德。故有官事王法牢狱。不肯畏慎作恶入法。受其过讁重罚致剧。求望解脱难得度出。今世有是目前现在。寿终有处入其窈冥受身更生。比若王法剧苦极刑。故有自然泥犁禽兽薜荔。蜎飞蠕动之类。转贸身形改恶易道。寿命短长魂神精识。自然入趣受形寄胎。当独值向相从共生。转相报偿当相还复。殃恶祸罚。众事未尽。终不得离展转其中。世世累劫无有出期。难得解脱痛不可言。天地之间自然有是。虽不临时卒暴应时。但取自然之道。皆当善恶归之。是为一大恶。为一痛。为一烧。勤苦如是。愁毒呼嗟。比若剧火起烧人身。人能自于其中。一心制意端身正行。独作诸善不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为一大善。佛言。其二恶者。世间帝王长吏人民。父子兄弟家室夫妇略无义理。不从正令奢淫憍慢。各欲快意恣心自在。更相欺调殊不惧死。心口各异。言念无实。佞谄不忠谀媚巧辞。行不端绪更相嫉憎转相谗恶陷人冤枉。主上不明心不察照任用臣下。臣下存在践度能行。知其形施在位不正。为其所调妄损忠良贤善。不当天心甚违道理。臣欺其君子欺其父。弟欺其兄妇欺其夫。家室中外知识相讼。各怀贪淫心毒嗔怒。蒙聋愚痴欲益。无有尊卑上下。无男无女无大无小。心俱同然欲自厚己。破家亡身不顾念前后。家室亲属坐之破族。或时家中内外知识朋友。乡党市里愚民野人。转更从事共相利害。诤财斗讼怒忿成仇转诤胜负。悭富焦心不肯施与。祝祝守爱保贪惜。坐之思念心劳身苦。如是至竟无所恃怙。独来独去无一随者。善恶福德殃祸讁罚。追命所生或在乐处或入毒苦。然后乃悔当复何及或时世人愚心少智。见善诽谤恚之不肯慕及。但欲为妄作不道。但欲盗窃常怀毒心。欲得他人财物用自供给。消散靡尽赐复求索。邪心不正常独恐怖畏人有色。临时不计事至乃悔。今世现在长吏牢狱。自然趣向受其殃咎。世间贫穷乞丐孤独。但坐前世宿命。不信道德不肯为善。今世为恶天神别籍。寿终入恶道。故有自然泥犁禽兽薜荔。蜎飞蠕动之属。展转其中。世世累劫无有出期。难得解脱痛不可言。是为二大恶。为二痛。为二烧。勤苦如是。比若火起剧于烧人身。人能自于其中。一心制意端身正行。独作诸善不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为二大善

佛言。其三恶者。诸世间人民寄生相因。共依居天地之间。处年寿命无能几岁。至有豪贵长者贤明善人。下有贫贱尪羸愚者。中有不良之人。但怀念毒恶身心不正。常念淫泆烦满胸中。爱欲交错坐起不安。贪意悭惜欲横唐得。眄睐细色恶态淫泆。有妇厌憎私妄出入。持家所有相给为非。聚会饮食专共作恶。兴兵作贼攻城格斗。劫杀截断强夺不道。取人财物偷窃趣得不肯治生。所当求者不肯为之。恶心在外不能专作。欲系成事恐势迫胁。持归给家共相生活。恣心快意极行作乐。行乱他人妇女。或于其亲属不避。尊卑长老众共憎恶。家室中外患而恚之。亦复不畏县官法令无所避录。如是之恶自然牢狱。日月照识神明记取诸神摄录。故有自然泥犁禽兽薜荔。蜎飞蠕动之属。展转其中。世世累劫无有出期。难得解脱痛不可言。是为三大恶。为三痛。为三烧。勤苦如是。比若火起烧人身。人能自于其中。一心制意端身正行。独作诸善不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为三大善

佛言。其四恶者。诸人不能作善自相坏败。转相教令共作众恶。主为传言但欲两舌恶口骂詈妄语。相嫉更相斗乱。憎嫉善人败坏贤善。于旁快之。复不孝顺供养父母。轻易师友知识。无信难得诚实。自大尊贵。有道横行威武加权力势。侵克易人不能自知。为恶不自羞惭自用顽健。欲令人承事畏敬之。复不畏敬天地神明日月。亦不可教令作善。不可降化。自用偃蹇常当尔。亦复无忧哀心。不知恐惧之意。憍慢如是天神记之。赖其前世宿命颇作福德。小善扶接营护助之。今世作恶尽儩诸善日去。见恶追之。身独空立无所复依受重殃讁。寿命终身众恶绕归。自然迫促当往追逐不得止息。自然众恶共趣顿乏。有其名籍在神明所。殃咎引牵当值相得。自然趣向受过讁罚。身心摧碎神形苦极不得离却。但得前行入其火镬。当是之时悔复何益。当复何及。天道自然不得蹉跌。故有自然泥犁禽兽薜荔。蜎飞蠕动之属。展转其中。世世累劫无有出期。难得解脱痛不可言。是为四大恶。为四痛。为四烧。勤苦如是。比若火起烧人身。人能自于其中。一心制意端身正行。独作诸善不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为四大善

佛言。其五恶者。世人徒倚懈惰。不肯作善不念治生。妻子饥寒父母俱然。欲呵教其子其子恶心。嗔目应怒言令不从。违戾反逆剧于野人。比若怨家不如无子。妄遍假贷众共患厌。尤无复有报偿之心。穷贫困乏不能复得。辜较谐声放纵游散。串数唐得自用赈给不畏防禁。饮食无极吃酒嗜美。出入无有期度鲁扈抵突。不知人情壮吁强制。见人有喜憎妒恚之。无义无礼自用识当不可谏晓。亦复不忧念父母妻子有无。又复不念卒报父母之德。亦复不念师之恩好。心常念恶。口常言恶。身常行恶。日不成就。不信道德。不信有贤明先圣。不信作善为道可得度世。不信世间有佛。欲杀罗汉。斗比丘僧。常欲杀人。欲杀父母兄弟妻子宗亲朋友。父母兄弟妻子宗亲朋友。憎恶见之欲使之死。不信佛经语。不信人寿命终尽死后世复生。不信作善得善。不信作恶得恶。如是曹人男子女人。心意俱然违戾反逆。愚痴蒙笼嗔怒嗜欲无所识知。自用快善大为智慧。亦不知所从来生死所趣向。不肯慈孝恶逆天地。于其中间望求侥幸。欲得长生射呼不死。会当归就生死勤苦善恶之道。身所作恶殃咎众趣不得度脱。亦不可降化令作善。慈心教语开导死苦。善恶所趣向有是复不信之。然苦心与语欲令度脱无益其人。心中闭塞意不开解。大命将至至时皆悔。其后乃悔当复何及。不豫计作善临穷何益。天地之间五道各明。恢旷窈窕浩浩汗汗。转相承受善恶毒痛。身自当之无有代者。道之自然随其所行。追命所生不得纵舍。善人行善慈孝。从乐入乐。从明入明。恶人行恶。从苦从冥。谁能知者。独佛见知耳。教语人民信用者少。死生不休。恶道不绝。如是世人不可悉道说。故有自然泥犁禽兽薜荔。蜎飞蠕动之属。展转其中。世世累劫无有出期。难得解脱痛不可言。是为五大恶。五痛五烧为勤苦如是。比若火起烧人身。人能自于其中。一心制意端身正行。言行相副所作至诚。所语如语心口不转。独作诸善不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为五大善。佛告阿逸菩萨等。我皆语若曹。是世五恶勤苦如是。令起五痛。令起五烧。展转相生。世间人民不肯为善。欲作众恶敢欲犯此诸恶事者。皆悉自然当具更历入恶道中。或其今世先被病殃。死生不得示众见之。寿终趣入至极大苦愁忧酷毒。自相焦然转相烧灭。至其然后共作怨家更相伤杀。从小微起至大困剧。皆从贪淫财色。不肯忍辱施与各欲自快。无复曲直欲得健名。为痴欲所迫随心思想。不能复得结愤胸中。财色缚束无有解脱不知厌足。厚己诤欲无所省录。富贵荣华当时忍辱不知施善。威势无几随恶名焦。身坐劳苦久后大剧。自然随逐无有解已。王法施张自然纠举。上下相应罗网纲纪。[煢-(冗-几)][煢-(冗-几)]忪忪当入其中。古今有是痛哉可伤。都无义理不知正道。佛语阿逸菩萨等。若世有是佛。皆慈愍哀之威神摧动。众恶诸事皆消化之。令得去恶就善弃捐所思。奉持经戒莫不承受。施行经法不敢违失。度世无为泥洹之道快善极乐。佛言。若曹诸天帝王人民。及后世人。得佛经语熟思惟之。能自于其中端心正行。其主上为善率化捡御其下。教众转相敕令。转共为善转相度脱。各自端守慈仁愍哀。终身不怠尊圣敬孝通洞博爱。佛语教令无敢亏负。当忧度世泥洹之道。当忧断截死生痛痒拔恶根本。当忧断绝泥犁禽兽薜荔。蜎飞蠕动恶苦之道。当曼佛世坚持经道无敢违失。佛言。若曹当信者。云何第一急。当自端身。当自端心。当自端目当自端耳。当自端鼻。当自端口。当自端手。当自端足。能自捡敛莫妄动作。身心净洁俱善相应。中外约束勿随嗜欲。不犯诸恶言色当和身行当专。行步坐起所作当安。作事所为。当先熟思虑计之。揆度才能视瞻圆规。安定徐作为之。作事仓卒不豫计熟。为之不谛亡其功夫。败悔在后唐苦亡身。至诚忠信得道绝去。佛言。若曹于是益作诸善。布恩施德能不犯道禁忌。忍辱精进一心智慧。展转复相教化作善为德。如是经法。慈心专一斋戒清净一日一夜者。胜于在阿弥陀佛国作善百岁。所以者何。阿弥陀佛国皆积德众善。无为自然在所求索。无有诸恶大如毛发。佛言。于是作善十日十夜者。其德胜于他方佛国中人民作善千岁。所以者何。他方佛国皆悉作善。作善者多为恶者少。皆有自然之物。不行求作便自得之。是间为恶者多作善者少。不行求作不能令得。世人能自端制作善至心求道。故能尔耳。是间无有自然不能自给。当行求索勤苦治生。转相欺殆调诈好恶。得其财物归给妻子。饮食毒劳心身苦。如是至竟。心意不专[怡-台+(公/心)]恫不安。人能自安静。为善精进德。故能尔耳。佛言。我皆哀若曹及诸天帝王人民。皆教令作诸善。不为众恶。随其所能辄授与道。教戒开导悉奉行之。即君率化为善。教令臣下。父教其子。兄教其弟。夫教其妇。家室内外亲属朋友转相教语。作善为道奉经持戒。各自端守上下相捡。无尊无卑无男无女。斋戒清净莫不欢喜。和顺义理。欢乐慈孝。自相约捡。其有得佛经语。悉持思之。不当所作而犯为之。即自悔过去恶就善。弃邪为正朝闻夕改。奉持经戒剧愚得宝。佛所行处所在郡国。辄授与经戒。诸天日月星辰诸神。国王旁臣长吏人民。诸龙鬼神。泥犁禽兽薜荔。蜎飞蠕动之属。莫不慈心开解者。皆悉敬事。从佛稽受经道。承奉行之。即君改化为善。斋戒精思净自湔洗。端心正行居位严栗。教敕率众为善。奉行道禁令言令正。臣孝其君。忠直受令不敢违负。父子言令孝顺承受。兄弟夫妇宗亲朋友。上下相令顺言和理。尊卑大小转相敬事。以礼如义不相违负。莫不改往修来。洗心易行端正中表。自然作善所愿辄得。咸善降化自然之道。求欲不死。即可得长寿。求欲度世。即可得泥洹之道。佛言。佛威神尊德重。消恶化善莫不度脱。今我出于天下。在是恶中。于苦世作佛。慈愍哀伤教语开导。诸天帝王。旁臣左右。长吏人民。随其心所愿乐。皆令得道。佛诸所行处。所经过历郡国县邑丘聚市里莫不丰熟。天下太平。日月运照。倍益明好。风雨时节。人民安宁。强不临弱。各得其所。无恶岁疾疫。无病瘦者。兵革不起。国无盗贼。无有冤抂。无有拘闭者。君臣人民莫不喜踊。忠慈至诚各自端守皆自守国。雍和孝顺莫不欢喜。有无相与布恩施德。心欢乐与皆敬爱。推让义谦逊。前后以礼敬事。如父如子。如兄如弟。莫不仁贤。和顺礼节都无违诤。快善无极。佛言。我哀若曹子欲度脱之。剧父母念子。今八方上下。诸天帝王人民。及蜎飞蠕动之类。得佛经戒奉行佛道。皆得明慧心悉开解。莫不得过度解脱忧苦者。今我作佛。在于五恶五痛五烧之中。降化五恶。消尽五痛。绝灭五烧。以善攻恶拔去毒苦。令得五道。令得五善明好。烧恶不起。我般泥洹去后。经道稍断绝。人民谀谄。稍复为众恶。不复作善。五烧复起。五痛剧苦。复如前法。自然还复。久后转剧不可悉说。我但为若曹小道之耳。佛告阿逸菩萨等。若曹各思持之。展转相教戒。如佛经法无敢违犯。阿逸菩萨长跪叉手言。佛道记甚苦痛。世人为恶。甚剧如是。佛皆慈哀悉度脱之。皆言受佛重教。请展转相教。不敢违犯

佛告阿难。我哀若曹。令悉见阿弥陀佛。及诸菩萨阿罗汉所居国土。若欲见之不。阿难即大欢喜长跪叉手言。愿皆欲见之。佛言。若起更被袈裟西向拜。当日所没处。为阿弥陀佛作礼。以头脑着地言。南无阿弥陀三耶三佛檀。阿难言。诺受教。即起更被袈裟西向拜。当日所没处。为弥陀佛作礼。以头脑着地言。南无阿弥陀三耶三佛檀。阿难未起。阿弥陀佛。便大放光明威神。则遍八方上下。诸无央数佛国。诸无央数诸天地。即皆为大震动。诸无央数天地。须弥山罗宝。摩诃须弥大山罗宝。诸天地大界小界。其中诸大泥犁小泥犁。诸山林溪谷幽冥之处。即皆大明悉大开辟。即时阿难诸菩萨阿罗汉等。诸天帝王人民。悉皆见阿弥陀佛及诸菩萨阿罗汉国土七宝已。心大欢喜踊跃。悉起为阿弥陀佛作礼。以头脑着地。皆言南无阿弥陀三耶三佛檀。阿弥陀佛国放光明威神。以诸无央数天人民。及蜎飞蠕动之类。皆悉见阿弥陀佛光明。莫不慈心欢喜者。诸有泥犁禽兽薜荔诸有考治勤苦之处。即皆休止不复治。莫不解脱忧苦者。诸有盲者即皆得视。诸有聋者即皆得听。诸有喑者即皆能语。诸有偻者即得申。诸跛癖蹇者即皆走行。诸有病者即皆愈起。诸尪者即皆强健。诸愚痴者即更黠慧。诸有淫者皆是梵行。诸嗔怒者悉皆慈心作善。诸有被毒者毒皆不行。钟磬琴瑟箜篌乐器诸伎。不鼓皆自作五音声。妇女珠环皆自作声。百鸟畜狩皆自悲鸣。当是时。莫不欢喜善乐得过度者。即尔时诸佛国中诸天人民。莫不持天上华香来下。于虚空中悉皆供养。散诸佛及阿弥陀佛上。诸天各共大作万种自然伎乐。乐诸佛及诸菩萨阿罗汉。当是之时。其快乐不可言。佛告阿难。阿逸菩萨等。我说阿弥陀佛及诸菩萨阿罗汉国土自然七宝。傥无有异乎。阿难长跪叉手言。佛说阿弥陀佛国土快善。如佛所言无有一异。佛言。我说阿弥陀佛功德国土快善。昼夜尽一劫。尚复未竟。我但为若曹小说之尔。阿逸菩萨即长跪叉手问佛言。今佛国土。从是间当有几何。阿惟越致菩萨。往生阿弥陀佛国。愿欲闻之。佛言。汝欲知者。明听着心中。阿逸菩萨言受教。佛言。从我国当有七百二十亿。阿惟越致菩萨。皆当往生阿弥陀佛国。一阿惟越致菩萨者。前后供养无央数诸佛。以次如弥勒皆当作佛。及其余诸小菩萨辈者无央数。不可复计。皆当往生阿弥陀佛国。佛告阿逸菩萨。不但我国中诸菩萨当往生阿弥陀佛国。他方异国复有佛。亦复如是。第一佛名头楼和斯。其国有百八十亿菩萨。皆当往生阿弥陀佛国。他方异国。第二佛名罗邻那阿竭。其国有九十亿菩萨。皆当往生阿弥陀佛国。他方异国。第三佛名朱蹄彼会。其国有二百二十亿菩萨。皆当往生阿弥陀佛国。他方异国。第四佛名阿蜜蔡罗萨。其国有二百五十亿菩萨。皆当往生阿弥陀佛国。他方异国。第五佛名楼波黎波蔡[跳-兆+蔡]。其国有六百亿菩萨。皆当往生阿弥陀佛国。他方异国。第六佛名那惟于蔡。其国有万四千菩萨。皆当往生阿弥陀佛国。他方异国。第七佛名维黎波罗潘蔡[跳-兆+蔡]。其国有十五菩萨。皆当往生阿弥陀佛国。他方异国。第八佛名和阿蔡。其国有八菩萨。皆当往生阿弥陀佛国。他方异国。第九佛名尸利群蔡。其国有八百一十亿菩萨。皆当往生阿弥陀佛国。他方异国。第十佛名那他蔡。其国有万亿菩萨。皆当往生阿弥陀佛国。他方异国。第十一佛名和罗那惟于蔡[跳-兆+蔡]。其国有万二千菩萨。皆当往生阿弥陀佛国。他方异国。第十二佛名沸霸图耶蔡。其国有诸菩萨。无央数不可复计。皆阿惟越致。皆智慧勇猛。各供养无央数诸佛。以一时俱心愿欲往。皆当生阿弥陀佛国。他方异国。第十三佛名随呵阅只波多蔡。其国有七百九十亿菩萨。皆当往生阿弥陀佛国。佛言。是诸菩萨皆阿惟越致。诸比丘僧中。及小菩萨辈无央数。皆当往生阿弥陀佛国。不独是十四佛国中诸菩萨当往生也。都八方上下无央数佛国诸菩萨辈。各各是皆当往生阿弥陀佛国。甚无央数。都共往会阿弥陀佛国。大众多不可计。我但说八方上下无央数诸佛名字。昼夜一劫尚未竟。我但复说诸佛国诸比丘僧众菩萨。当往生阿弥陀佛国人数。说之一劫不休止尚未竟。我但为若曹。总揽都小说之尔。佛语阿难。阿逸菩萨等。其世间帝王人民。善男子善女人。前世宿命作善所致相禄巍巍。乃当闻阿弥陀佛声者。甚快善哉代之喜。佛言。其有善男子善女人。闻阿弥陀佛声。慈心欢喜。一时踊跃。心意净洁衣毛为起。泪即出者。皆前世宿命作佛道。若他方佛故。菩萨非凡人。其有人民男子女人。闻弥陀佛声。不信有者。不信经佛语。不信有比丘僧。心中狐疑都无所信者。皆故从恶道中来生。愚痴不解宿命。殃恶未尽。尚未当度脱故。心中狐疑不信向尔。佛言。我语若曹。若曹所当作善法。皆当奉行信之。无得疑。我般泥洹去后。汝曹及后世人。无得复言。我不信有阿弥陀佛国。我故令若曹悉见阿弥陀佛国土。所当为者各求之。我具为若曹道说经戒慎法。若曹当如佛法持之。无得毁失。我持是经以累若曹。若曹当坚持之。无得为妄增减是经法。我般泥洹去后。经道留止千岁。千岁后经道断绝。我皆慈哀。持留是经法。止住百岁。百岁中竟。乃休止断绝。在心所愿皆可得道。佛言。师开导人耳目。智慧明达度脱人。令得善合泥洹之道。常当孝慈于佛父母。常当念师恩。常念不绝即得道疾。佛言。天下有佛者甚难值。若有沙门。若师为人说经者甚难值。佛说是经时。即万二千亿诸天人民。皆得天眼彻视。悉一心皆为菩萨道。即二百亿诸天人民。皆得阿那含道。即八百沙门。皆得阿罗汉道。即四十亿菩萨。皆得阿惟越致。佛说经已。诸菩萨阿罗汉。诸天帝王人民。皆大欢喜。起为佛作礼绕三匝。前以头面着佛足而去

阿弥陀经卷下


佛说胞胎经

    No. 317 [No. 310(13)]

佛说胞胎经

        西晋月氏国三藏竺法护奉　制译

闻如是。一时佛游舍卫国祇树给孤独园。于时贤者难陀。燕坐思惟即起诣佛。及五百比丘俱共诣佛所。稽首足下住坐一面。佛告难陀及诸比丘。当为汝说经。初语亦善。中语亦善。竟语亦善。分别其义。微妙具足净修梵行。当为汝说。人遇母生受胞胎时。谛听善思念之。唯然世尊。贤者难陀受教而听。佛告难陀。何故母不受胎。于是父母起尘染心。因缘合会。母有佳善心志于存乐神。来者至前母有所失精。或父有所失母无所失。或父清净母不清洁。或母洁净父不洁净。或母尔时藏所究竟即不受胎。如是究竟或有成寒。或时声近有灭其精。或有满。或如药。或如果中央。或如荜茇中子。或如生果子。或如鸟目。或如懿沙目。或如舍竭目。或如祝伽目。或如眼瞳子。或如树叶。或合聚如垢。于是或深。或上深。或无器胎。或近音声。或坚核如珠。或为虫所食。或近左或近右。或大清。或卒暴。或不调均。当左反右。或如水瓶。或如果子。或如狼唐。或有众瑕。或诸寒俱。或有热多。或父母务来神卑贱。或来神贵父母卑贱。是故不相过生。等行等志。俱贵俱贱心同不异则入母胎。何故母不受胎。无前诸杂错事不和调事。等意同行。俱贵俱贱。宿命因缘当应生子。来神应遇父母而当为子。于时精神或怀二心所念各异。如是之事则不和合不得入胎。佛告阿难。云何得入处母胞胎。其薄福者则自生念。有水冷风于今天雨。有大众来欲捶害我。我当走入大[卄/積]草下。或入叶[卄/積]诸草众聚。或入溪涧深谷。或登高峻。无能得。我得脱冷风及大雨。大众于是入屋福厚得势心自念言。今有冷风而天大雨及诸大众。我当入屋上大讲堂。当在平阁升于床榻。佛语阿难。神入母胎所念若干各异不同

佛语阿难。神入彼胎则便成藏。其成胎者。父母不净精亦不离。父母不净又假依倚。因缘和合而受胞胎。以故非是父母不离父母。譬如阿难。酪瓶如器盛酪以乳着中。因缘盛酪或为生苏。假使独尔不成为苏。不从酪出苏亦不离酪。因缘和合乃得为苏。如是阿难。不从父母不净成身。亦不离父母成身。因父母为缘而成胞胎。佛告阿难。譬如生草菜因之生虫。虫不从草菜出。亦不离草菜依生草菜。以为因缘和合生虫。缘是之中虫蠡自然。如是阿难。不从父母不净。不离父母不净成身。因父母为缘而成胞胎。譬如阿难。因小麦出虫。虫不出小麦。亦不离小麦。因小麦为缘而得生虫。因是和合自然生虫。如是阿难。不从父母不净。不离父母不净成身。因父母为缘而成胞胎。得立诸根及与四大。譬如阿难。因波达果而生虫。虫不从波达果出。亦不离波达果。因波达果为缘自然得生。如是阿难。不从父母不净。不离父母不净成身。因父母为缘而成胞胎。得立诸根及与四大。譬如阿难。因酪生虫。虫不从酪出。亦不离酪。以酪为缘自然生虫。如是阿难。不从父母不净。不离父母不净成身。因父母为缘而成胞胎。得立诸根及与四大。因父母缘则立地种。谓诸坚者。软湿水种。热暖火种。气息风种。假使阿难。因父母故成胞胎者而为地种。水种令烂。譬如糗中及若肌肤得对便烂。假使因父母成胞胎。便为水种不为地种。用薄如湿故也。譬如油及水。又阿难。水种依地种不烂坏也。地种依水种而无所著。假使阿难。父母因缘成胞胎者。地种则为水种。火种不得依也。则坏枯腐。譬如夏五月盛暑时。肉中因火种。尘垢秽臭烂坏则就臭腐。如是阿难。假使因父母胎成地种者。及水种者。其于火种不腐坏败而没尽也。假使阿难。因父母胎成地种及水种者。当成火种无有风种。风种不立不得长大则不成就。又阿难神处于内缘其罪福得成四大。地水火风究竟摄持。水种分别。火种因号。风种则得长大因而成就

佛告阿难。譬如莲藕生于池中。清净具足花合未开。风吹开花令其长大而得成就。如是阿难。神处于内因其罪福得成四大。成就地种摄持水种分别火种因号。风种而得长大。稍稍成就。非是父母胞胎之缘。人神过生也非父母福。亦非父体亦非母体。因缘得合也。非空因缘亦非众缘。亦非他缘。又有俱施同其志愿。而得合会成胚里胞胎

譬如阿难。五谷草木之种完具不腐不虫耕覆摩地肥地。下种生茂好。于阿难意云何。其种独立因地水号。成其根茎枝叶花实。阿难白佛。不也天中天。佛言如是。阿难。不从父母构精。如成胞里。不独父母遗体。亦不自空因缘也。有因缘合成。四大等合因缘等现。得佛胞里而为胚胎

譬如阿难。有目明眼之人。若摩尼珠阳燧向日盛明。正中之时以燥牛粪。若艾若布。寻时出火则成光焰。计彼火者不从日出。不从摩尼珠。阳燧艾生亦不离彼。又阿难。因缘合会因缘俱至。等不增减而火得生。胚胎如是。不从父母不离父母。又缘父母不净之精。得成胞里因此成色。痛痒思想生死之识因得号字。缘是得名由本成色。以此之故号之名色。又阿难。所从缘起吾不称叹往返终始

佛告阿难。譬如少所疮病臭处非人所乐。岂况多乎。少所穿漏瑕秽。何况多乎。如是阿难。少所周旋在于终始。非吾所叹何况久长。所以者何。所有终没周旋诸患。甚为勤苦谁当乐乎。欣悦臭处。入母胚胎耶

佛告阿难。彼始七时受母胎里。云何自然而得成胎。始卧未成就时。其胎自然亦复如是。七日处彼停住而不增减。转稍而热。转向坚固则立地种。其软湿者则为水种。其中暖者则为火种。关通其中则为风种。第二七日有风名展转。而徐起吹之。向在左胁或在右胁。而向其身聚为胞里。犹如酪上肥。其精转坚亦复如是。彼于七日转化如熟。其中坚者。则立地种。其软湿者则为水种。其熅燸者则为火种。间关其间则为风种

佛告阿难。第三七日其胎之内于母腹中。有风名声门。而起吹之。令其胎里转就凝坚。凝坚何类。如指着息疮息肉坏。精变如是。住中七日转化成熟。彼其坚者则为地种。软湿者则为水种。其熅燸者则为火种。间关其内则为风种

佛告阿难。第四七日。其胎之内母藏起风名曰饮食。起吹胎里令其转坚。其坚何类。譬如含血之类有子。名曰不注(晋曰觐)内骨无信其坚如是。住彼七日转化成熟。彼其坚者则为地种。软湿则为水种。熅燸则为火种。间关其内则为风种

佛告阿难。第五七日。其胎之内于母腹中藏。次有风起名曰导御。吹其坚精变为体形。成五处应瑞。两膑两肩一头。譬如春时天降于雨。雨从空中堕长养树叶枝。其胎如是。其母藏内化成五应。两膑两肩及其头

佛告阿难。第六七日。其胎在内于母腹藏。自然化风名曰为水。吹其胎里令其身变化。成四应瑞。两膝处两肘处。佛告阿难。第七七日。其胎里内于母腹藏。自然化风名曰回转。吹之令变更成四应瑞。两手曼两臂曼。稍稍自长柔濡软弱。譬如聚沫干燥时。其胚里内四应如是。两手两足诸曼现处。佛告阿难。第八七日。其胎里内于母腹藏。自然化风名曰退转。吹其胎里现二十应处。十足指处十手指处。譬如天雨从空中堕。流澍觚枝使转茂盛。时胚胎内于腹藏起二十脔。足十指处手十指处

佛告阿难。第九七日。其胞里内于母腹藏。自然风起吹变九孔。两眼两耳。两鼻孔口处。及下两孔

佛告阿难。第十七日。其胞里内于母腹藏。自然风起名曰痤短。吹其胎里急病暴卒。而甚坚强在中七日。其夜七日自然风起名曰普门。整理其体。犹如坚强具足音声

佛告阿难。第十一七日。胞内于母腹藏。自然化风名曰理坏。吹其胎里整理其形安正诸散。令母驰走不安。烦躁扰动举动柔迟。好笑喜语戏笑歌舞。风起泪出。如是如坐母胞胎。成时喜申手脚。其胎转向。成时诸散合立。有风名柱转。趣头顶散其顶上令其倒转。譬如锻师排囊吹从上转之。如是阿难。其柱转风上至其项。于项上散转复往反。其风在项上旋。开其咽口及身中脐。诸曼之指令其穿漏。其侵转令成就

佛告阿难。第十二七日。其胞里内于母腹藏。自然化风名曰肤面。吹其胎里令成肠胃左右之形。譬如莲华根着地。其肠成就。依倚于身亦复如是。为十八空经缕沟坑。于其七日自然化风名曰弃毛。吹生其舌及开其眼。成身百节令具足成就。不减依倚生万一千节

佛告阿难。第十三七日。其胞里内于母腹藏。觉身体羸又觉饥渴。母所食饮入儿体中。儿在胎中。母所食饮。儿因母大长养身

佛告阿难。第十四七日。其胞里内于母腹藏。自然有风名曰经缕门。吹其精体生九万筋。二万二千五百在身前。二万二千五百在背。二万二千五百在左胁。二万二千五百在右胁

佛告阿难。第十五七日。其胞里内于母腹藏。自然化风名红莲花。名曰波昙。吹其儿体令安二十脉。五脉引在身前。五脉引在背。五脉引在左胁五脉引在右胁。其脉之中。有无央数不可称计若干种色。各各有名现目。次名力势。又名住立又名坚强。又一种色。或有青色白色。白色为赤赤色为白。或有白色为黄。或缥变色。苏色酪油色。生热杂错熟热杂错。其二十脉。一一有四十眷属。合八百脉。二百在身前。二百在背。二百在左。二百在右。二百二力二尊二力势。佛语阿难。其八百脉。一一之脉有万眷属。合为八万脉。二万在胸腹。二万在背。二万在左。二万在右。其八万脉。有无数空不可计。有一空。次二次三至于七。譬如莲华茎多有众孔。次第生一孔二孔三孔至于七孔。如是阿难。其八万脉亦复如是。有无数根空不可称计。有一次二次三至于七。佛告阿难。其诸脉与毛孔转相依因

佛告阿难。第十六七日。其胞里内于母腹藏。自然化风名曰无量。吹其儿体。正其骨节。各安其处。开通两目两耳鼻孔口门及其项颈。周匝定心令其食饮流通无碍。有所立处诸孔流出流入。逆顺随体令不差错。设使具足无所拘滞。譬如陶家作瓦器师。若其弟子和泥调好。以作坏形捶拍令正。补治上下令不缺漏安着其处。如是阿难。罪福因缘自然有风。变其形体。开其眼精耳鼻口精咽喉项颈。开其心根令所食饮皆使得通。诸孔出入无挂安其食饮

佛告阿难。第十七七日。其胎里内于母腹藏。自然有风名耗牛面。吹其儿体开其眼精。令使净洁使有光曜。及耳二精鼻口门。皆令清洁光曜无瑕。譬如阿难。如摩镜师弟子。取不净镜刮治揩摩。以油发明去其瑕秽光彻内外。如是阿难。罪福因缘自然化风。开其眼耳鼻口。令其清净开通无瑕。佛告阿难。第十八七日。其胎里内于母腹藏。除若干瑕悉使清净。譬如月城郭若人宫殿。有风名曰大坚强。其风极大旋吹宫殿擎持游行。自然清净究竟无瑕。其胎如是。母之腹藏诸入之精。为风所吹自然鲜明究竟具足。佛告阿难。第十九七日。在胚胎中即得四根。眼根耳根鼻根舌根。初在母腹即获三根。身根心根命根

佛告阿难。第二十七日。在其胞里于母腹藏。自然化风名[革*卬][革*亢]。吹小儿体。在其左足。令生骨节。倚其右足而吹成骨。四骨处膝。二骨在膑。三骨在项。十八骨在背。十八骨在胁。十三骨在掌。各有二十骨。在左右足。四骨在时处。二骨在非处。二骨在肩。十八骨在颈。三骨在轮耳。三十二骨在口齿。四骨在头。譬如阿难。机关木师。若画师作木人。合诸关节。先治材木。合集令安。绳连关木。及作经押。以绳关连。因成形像。与人无异。如是阿难。罪福所化自然有风。吹成色貌。变为骨节。因缘化成。在此二十七日中。于其腹中应时在身。生二百微细骨与肉杂合

佛告阿难。第二十一七日。在其胞里于母腹藏。自然化风名曰所有。吹其儿体令出肌肉。譬如阿难。工巧陶师作妙瓦器罂瓮盆瓨令具足成。阿难。其所有风吹其儿身令肌肉生亦复如是

佛告阿难。二十二七日。在其胞里于母腹藏。自然有风名曰度恶。吹其儿体令生音声

佛告阿难。第二十三七日。在其胞里于母腹藏。自然有风名曰针孔清净。吹其儿身令其生革稍稍具足

佛告阿难。第二十四七日。在其胞里于母腹藏。自然有风名曰坚持。吹其儿身申布其革令其调均

佛告阿难。第二十五七日。在其胞里于母腹藏。自然化风名曰闻在持。吹其儿体扫除其肌皆令滑泽

佛告阿难。第二十六七日。在其胞里于母腹藏。自然化风吹其儿体。假使前世有恶罪行诸殃来现。于诸十恶或复悭贪爱惜财物不能施与。不受先圣师父之教。其应清净长大更成短小。其应粗大则更尪细。应清净长大更粗大。当多清净反更得少。当应少者反成为多。当应清洁反得垢浊。当应垢浊反得净洁。当应雄反成非雄。所不乐雄反为贼雄。当所求者反不得之。志所不乐而自然至。当应为黑而反成黄。当应黄而反成黑。佛告阿难。如其本宿所种诸恶自然得之。或复为盲聋喑哑患痴。身生瘢疮。生无眼目。口不能言。诸门隔闭。跛蹇秃瘘。本自所作自然得之。父母所憎违失法义。所以者何。如是阿难。宿命所种非法之行

佛告阿难。假使其人前世奉行众德。不犯诸恶诸善来趣。谓十德行。喜于惠施无悭垢心奉受先圣师父之命。身中诸节。应当长者即清净长。当应鲜洁自然鲜洁。应粗清净即粗清净。应当细小即多细小。应多清净即多清净。应少清净即少清净。应滑鲜洁即滑鲜洁。应当忍少即便忍少。应当为雄即成为雄。所乐好声即得好声。所乐璎珞即得宝璎。应当为黑即成为黑。所乐言语即得所乐。如是阿难。随宿所种功德。诸为善自然。为众生所喜见。端正好洁色像第一。其身口意所求所作所愿。则得如意。所以者何。是故阿难。宿命所种自然得之

佛告阿难。假使有男即趣母右胁累趺坐。两手掌着面背外。面向其母。生藏之下熟藏之上。五系自缚如在革囊。假使是女在母腹左胁累趺坐。手掌博面。生藏之下熟藏之上。五系自缚如在革囊。假使母多食其儿不安。食太少其儿不安。食多腻其儿不安。食无腻其儿不安。大热大冷。欲得利不利。甜醋粗细。其食如是。或多少而不调均。儿则不安。习色欲过差。儿则不安。在风过差。儿则不安。或多行来驰走有所度越。或上树木。儿则不安

佛告阿难。儿在母腹勤苦燠恼。众患诸难乃如是乎。俗人自谓生在安处其若如是。何况恶趣勤剧之患。诸苦艰难不可譬喻。谁当乐在母胞胎乎

佛告阿难。第二十八七日。在其胞里于母腹藏。即起八念。乘骑想。园观想。楼阁间想。游观想。床榻想。流河想。泉水想。浴池想

佛告阿难。第二十九七日。在其胞里于母腹藏。中自然有风名曰髓中间。持其皮肤使其净洁。颜色固然随其宿行。宿作黑行色现为黑形体如漆。宿作不白不黑行。色现不白不黑。体像一貌。宿行素无光润。色现素无光润。普身一等。宿行白色面貌正白。普体亦然。宿行黄色面貌黄色。普体亦然。阿难。是世间人有是六色。随本所种自然获之

佛告阿难。第三十七日。在其胞里于母腹藏。自然风起吹其儿体令生毛发。随宿所行。或令其儿毛发正黑妙好无量。或生发黄人所不喜

佛告阿难。第三十一七日。在其胞里于母腹藏。儿身转大具足。第三十二七日。在其胞里于母腹藏。儿身自成无所乏少。等三十三七日。等三十四七日。第三十五七日。第三十六七日。儿身成满骨节坚实在于胞里不以为乐

佛告阿难。第三十七七日。在其胞里于母腹藏。自然生念如在罗网欲得走出。为不净想。瑕秽之想。牢狱之想。幽冥之想。不以为乐

佛告阿难。第三十八七日。在其胞里于母腹藏。自然有华风名曰何所垂趣。吹转儿身令应所在。下其两手当来向生。从其缘果吹其儿身。脚上头下向于生门。假使前世作诸恶行。临当生时脚便转退反其手足。困于其母或失身命。其母懊恼患痛无量。假使前世作德善行终其长寿。则不回还命不中尽。其母缘此不遭苦恼无数之患。彼于三十八七日。则遭大苦无极之患愁忧不乐

佛告阿难。生死之苦甚为勤剧。人生若男或生女。这生堕地痛不可言。甚不善哉。懊恼辛酸。或以衣受触其形体。若以衾受卧着所处。或在床上或置于地。或覆或露或在暑热或寒冷。因是之故遭其苦患酷剧难称。譬如阿难。蛇虺牛之皮所悬着处。若在壁上即化为虫还食其皮。若使树木苗草陂水设复在虚空中所倚。即自生虫还食其形。在所依倚则亦生虫还食其形。儿始生时则以手受。苦痛懊恼不可称限。或以衣受触如前。其形体或稍以长大饥渴寒热。其母小心推燥居湿。养育除其不净。所谓先圣法律。正是其母乳哺之恩

佛告阿难。如是勤苦谁当乐处父母胚胎。儿生未久揣饭养身。身即生八万种虫。周遍绕动食儿身体。发本虫名曰舌舐。依于发根食其发。虫名在修行道地中。一名舌舐。二名重舐。三种在头上。名曰坚固伤损毁害

佛告阿难。人身苦恼如是。八万种虫晨夜食其形体。令人羸疲少气疲极。令身得病或成寒热。众患苦恼不可数也。烦躁苦极。饥亦极行复极住亦极。设身有病复求医药欲除其病。在母胎时苦不可言。既生为人极寿百岁或长或短。百岁之中凡更百春百夏百秋百冬。百岁之中更千二百月春更三月。夏更三月。秋更三月。冬更三月。百岁之中分其明白青冥部。凡更二千四百十五日。春更六百十五日。夏更六百十五日。秋更六百十五日。冬更六百十五日。百岁之中。凡更七万二千饭。春更万八千食。夏更万八千食。秋更万八千食。冬更万八千食。或懅不食时。或嗔不食时。或食穷乏时。或有所作不食时。醉放逸不食时。或斋不食时。皆在七万二千饭中。如是阿难。勤苦厄恼。谁当乐处母胚胎。如是众患匆匆未曾得安。众缘所缚。或眼痛病。或耳鼻口舌齿痛。膑脚咽喉短气腰脊臂肘卷腕。诸百节病痛诸患。风寒诸热疥癞虚痔恶疮痈疽黄疸咳逆颠狂盲聋喑哑痴憃疣癃[病-丙+秋]百节烦疼胪胀[病-丙+帶]下身体浮肿。如是阿难。地水火风。一增则生百病。风适多则百病生。热多则生百病。寒多则生百病。食多则增百病。三事合会风寒热聚。四百四病同时俱起。何况其余不可计患。或截手或截脚耳鼻。或斩头。或锁系鞭杖搒笞。闭在牢狱拷掠加刑。或畏于人或畏非人地狱饿鬼畜生之难。勤苦旷野蚊虻虱蚤蜂螫之难。虎狼师子蛇虺之惧。如是计之苦不可言。有多所求种勤苦根。不得则忧。有所志乐不如意。既所得当复守护。生业勤苦有所获得。志愿无厌。尘劳之恼多所妨碍。佛语阿难。取要言之。五阴则苦。诸入诸衰思想多念由此生苦。因斯起其憍慢自贡高。自在心走不安。一一诸义当观自然。譬如车轮不在一处卧起。在床在地歌舞戏笑。当观苦想。假使经行坐起行步常当思苦。懊恼众患不可称数。无有一可快。所经行处不起安想。心顿坐而不行不在床榻。亦当知之勤苦。阿难言。勿起安想

佛告阿难。设在威仪而不休息。则有若干无量苦。与心自想念谓安不苦。如是阿难。生死难乐。计有二患。自观身苦。为他人苦。观此二义当自察之。吾虽出家何因致慧。得报果实安隐无患。所从受食衣被床卧。病瘦医药。令其主人得大果报。获大光焰无极普义

佛告阿难。当学如此。于阿难意云何。色为有常无常。阿难答曰无常。天中天。设无常为苦不苦。阿难白佛。甚苦天中天。又无常事。当复离别法不常在。贤圣弟子闻讲此义。宁当发念有吾有我是我所不。阿难白佛。不也天中天。色痛痒生死识有常无常。答曰无常。曰假使为无常。为苦为安。贤圣弟子闻讲说此。宁有吾有我是我所不。答曰。不也天中天。是故阿难。计一切色过去当来今现在者。内外粗细微妙瑕秽。若远若近无我无彼亦非我身。明达智者即观如平等不耶。假使阿难。贤圣弟子。厌于色者痛痒思想生死识者。设使能厌则离尘垢。离尘垢则度。设志于度至度。见慧尽于生死。称扬梵行身所作则办。则度彼岸示在此际。佛说是经时。贤者阿难得诸法眼生。其五百比丘漏尽意解。贤者阿难五百弟子诸天龙神。闻经欢喜

佛说胞胎经


佛说宝积三昧文殊师利菩萨问法身经

    No. 356

佛说宝积三昧文殊师利菩萨问法身经

        后汉安息三藏安世高译

闻如是。一时佛至罗阅只耆阇崛山中。与千二百五十比丘俱。文殊菩萨往到佛所在门外住。所以者何。佛坐三昧未久。佛觉见文殊。便请入。作礼而住。佛言且坐。文殊问佛。属坐三昧名曰何等。佛言宝积。文殊复问。何故名宝积。佛言。譬如摩尼珠。本自净好。复以水洗置其平地。转更明彻。无不见者。属所入三昧。见东方无央数阿僧祇刹土及佛。以复悉不现。住是三昧中。无不见诸法本际。其有信者。以为得印。所语如言。摩尼宝舍有四角。从一角视悉见诸角。无所缺减。是故见诸本际。佛问文殊。知本际不。则言知。何所是。报言。我所处是为本际。诸所欲人异际。在是际者。亦不在法。亦不在善恶。诸法亦如是。其知是者。审以知之。凡之知者。以无所知。从本传习。莫有作者。是故无有底。佛问文殊。何谓是慧。审是慧者。是故慧。复问何所道。念名曰道。报言。所念道无念。是故道。佛语文殊。以有念言无念。当以何法教新学。若男子女人。文殊言。亦无所出。亦无解。淫怒痴无有极。以是法教一切。以故无有根。是故不可出不可解。其言我能坏本际。以不能。其言我能断生是亦不能。不舍俗事。不念近道。作是者。乃可教于凡人。文殊问佛。持何法教学。佛言。我所教不坏色痛庠思想死生识。无所坏。亦不教坏淫怒痴。令得不可计数法。以是法教作佛道者。我用是故自致得佛。佛语文殊。无所坏法故致佛。无所得法能成佛。佛者则法身。诸种力无所畏。悉法身之所入。所以者何。莫能分一身者。而为法身。法身无有数。何以故。不言是凡人是不凡人。法身等无差特无所散。身是为法身。譬如四渎悉归于海合为一味。若干名法为一法身。诸所有种各各有名。合会聚之名曰谷。若俗事道事。悉合为一法身。所以者何。不可指示。是为俗事。道事亦不可说。是俗事身是为法身。亦不可见视。如我所说法身。其有信二。知者所作众恶悉以除尽。文殊言。于法身亦不见。生天上亦不见。在人间亦不见。在三道。亦不在泥洹。佛语文殊。今若所说乃尔。若有人问汝者。佛现说有五道。当何以解之。文殊言。譬若如人卧中。见入泥犁。若作禽兽薜荔。上在天上若在人中。觉则无所见。其法身无所著。所以者何。但有数故。数者堕俗。若罗汉辟支佛。上至佛俱等一法身。所以者何。不可分别故。譬如若干种宝可别知。法身而不别。所以者何。不可别故。无生无死故。法身无所生无所灭。所以者何。常住故。亦无有垢。亦无有净。所以者何。无有过者。亦无脱亦无所脱。佛者无所不知。复问文殊。知法身不。文殊言。若得者可知。佛问文殊。乃知世间所在处不。则言知。佛言何所是。文殊言。其化人处世。在是世间者。但有名求如毛际。而无为我说者。其世亦不离法身。佛复问。世所在何所。文殊言。譬如云所在无所在。亦不羸亦不强。是则世世之相。佛问文殊。汝谓我灭不。文殊言不。何以故。法身无有生。若有生乃有灭。法身者不生故。知佛而不灭。佛问文殊。若闻已过去恒边沙佛悉般泥洹。汝信不。则言信。佛言。云何信。文殊言。其佛者悉佛所化。化般泥洹故。而信之。佛问文殊。汝见人临死时。知所趣向。则答言。而人不可知。何况所趣向。佛语文殊。乃可聚会说法。文殊言。谁欲听。佛言。欲听聚会者。文殊白佛。当因何法有所说。佛言说法身。则言不见法身。当何以说之。佛语文殊。若所说法身不可见。其在会中未晓者。闻其所言其心恐惧。文殊言。若恐惧其本际已恐惧。佛言本际无恐惧。未晓者亦不恐惧。文殊言。诸法无有恐惧者。若金刚。佛问。何谓金刚。答言无能截断者。以故名曰金刚。佛不可议。诸法亦不可议。以是为金刚。佛言。何所为金刚者。文殊言。胜诸法故。佛者法法之审故。是为金刚佛。以何因为金刚。则答言。所有无所有。一一求之无所有。故曰空。空者是佛。以是为金刚。一切诸法皆佛。依无所依是故金刚。何缘是为金刚。则言无所依者无所近。是故为金刚。佛语文殊。今我欲作感应。令阿难来。所以者何。为一切受法故。文殊问佛。属所说法。无所见无所得。阿难来者当取何法。佛言善哉善哉。如文殊所说。佛言我见东方无央数阿僧祇刹土诸佛皆悉说是。舍利弗出其所止处。到文殊所。见而不在。便至佛所。于门外住。佛谓文殊言。呼舍利弗入。文殊问佛。本际法身有中有外有内。当从何所得。佛言不可得。答言。本际以无际。复言。舍利弗者亦在法身中。不而所从来。当所入。佛语文殊。若为苦。舍利弗为不苦。譬如诸声闻在内与我俱语。而若在外住。不用时入。是不为烦。答言。虽在外住亦不苦亦不烦。佛问。若以何故。不苦不烦。文殊言。佛为声闻说法。我亦如是故不苦不烦。所以者何。诸佛所离法身故。文殊言。譬如恒边沙劫不见佛。亦不得入。亦不苦不烦。所以故。佛所说法亦无增无减。所以者何。诸法无有主。以是故无苦无烦。诸所有名。佛因是而教人。所以者何。佛以是教故。佛遥问舍利弗。汝悉闻文殊所语不。舍利弗言惟。佛勿以自劳。愿乐于是往听其法。文殊白佛。可令舍利弗来入。佛遥谓舍利弗前。前已作礼就坐。文殊谓舍利弗。于是法中何所而尊。欲入听之闻说尊法。爱乐欲闻故入欲听。文殊言。审如若所说。是法实尊甚深甚深。何以故。是法无有二心故。所以者何。非若所知。不在其中。诸罗汉辟支佛。亦复如是。及求佛道者。何以故。不可得故。亦不从悕望得。以是故无能在其中。本清净故。诸法亦清净。舍利弗问文殊。所以罗汉不在其中。文殊言。淫怒尽是为罗汉。无所住无所成。当在何所中。舍利弗言。故到人处不见。以是故来至闻。但欲闻深法故。舍利弗言。我从佛若从人闻其法。诚无厌极。时文殊言。于法无厌极。如舍利弗所语。文殊问。法身能有所受法不。何故而无厌极。舍利弗言。法身无所受。其本际有所受不。舍利弗言。无所受。文殊答舍利弗。本际无所受故。而若无厌极。文殊言。若本际受法。汝有厌极。舍利弗言。除佛所说。我之所说无有与等。文殊言。汝能自信其法至泥洹。若自信不至泥洹。舍利弗言。从本以悉般泥洹。文殊言。宁自信。常于是不动转。舍利弗言信。复问从何所信。则答言。法身无所生无所灭。故知无所动转。复问。信罗汉尽无有余无所复知不。舍利弗言信。从何所信。其知以无所复有故无所知。无所知者无所止。故曰尽。文殊言。罗汉尽故如是。何以故。舍利弗言。悉舍诸法无所得故。文殊问。汝信以恒边沙佛般泥洹以不般泥洹。舍利弗言信。从何所信。法身不生不死故。不般泥洹。文殊问。信诸佛为一佛不。舍利弗言信。从何所信之。答曰。一法身无有二故。文殊问。信诸所有刹土为一刹土不。舍利弗言信。从何所信。答言所有尽故。文殊复问。能信一切法。无所识无所脱。无所念无有证。舍利弗言信。从何所信。无自然而知自然者。故无所识无所脱。无所念无有证。亦不生不灭。亦不见亦不有见。本际无处。所以故信。文殊复问。信法身住。无所生无所灭无所止。舍利弗言信。从何所信之亦不是法。有所生有所灭有所止。以故信。文殊问。能信不可计法身所从出。能知处不。舍利弗言信。从何所信。答言。法身者亦无淫怒痴故。信之而无处。复问舍利弗。乃信诸法依佛依无所依等不。答言信之。从何所信。答言。无所止。无所止者。谓不可见之所依。文殊言。善哉善哉。舍利弗。如若之境界。我悉问之。若皆答其所知。舍利弗语文殊。今我所闻者。以念不复忘。佛谓舍利弗。若有男子女人。闻是法持讽诵读。为一切人广说。为解其义。疾得所欲。文殊语舍利弗。今佛所说无有异。舍利弗白佛。以供养前佛者。所以彼者来悉得是印。是法名曰何等。当云何行。名曰问法身宝积。持本际持无所处。所持持一切诸法。无所挂碍。其从若闻是者。便因是法悉逮得。其闻者复教诏余人。展转相开导。所以者何。文少而解多。佛说是经。舍利弗罗汉。文殊师利菩萨。诸天人世间人民。龙鬼神。一切欢喜。作礼而去

佛说宝积三昧文殊问法身经


佛说大乘方等要慧经

    No. 348 [No. 310(41)]

佛说大乘方等要慧经

        后汉安息国三藏安世高译

闻如是。一时佛游于舍卫国。尔时弥勒菩萨叉手白佛言

世尊。我欲小有所问。若世尊听所问者乃敢陈之。佛言。若有所疑便问。吾当为汝解说使意欢喜。弥勒问言。云何菩萨摩诃萨不退转法。于大乘有进而不耗减。行菩萨道并降伏魔怨。如其状貌。悉还教知诸法根之相。不厌于生死。自有正慧不从他受。疾成无上一切智地。世尊赞曰。善哉善哉所问随顺。甚善大佳吾当为汝解说。菩萨所得之行踰于所问。谛听善思念之。于是弥勒受教。一心静听。佛告弥勒。菩萨有八法具足。疾逮得无上一切智地。何谓为八。一者内性清净。二者所行成就。三者所施成就。四者所愿成就。五者慈成就。六者悲成就。七者善权成就。八者智慧成就。是为八事。菩萨疾逮得无上一切智。弥勒菩萨及诸会皆欢喜

大乘方等要慧经


佛说大乘菩萨藏正法经卷第一

    No. 316 [No. 310(12)]

佛说大乘菩萨藏正法经卷第一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    长者贤护品第一之一

如是我闻。一时世尊。在舍卫国坐夏安居。满三月已。出行访其裁制成办衣服之者。与大苾刍众千二百五十人俱。并余苾刍苾刍尼优婆塞优婆夷国王大臣。沙门婆罗门长者及诸外道。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。于佛世尊。尊重恭信志诚供养。世尊受世供利。与世福田。所谓饮食衣服坐卧之具。病缘医药及余广多受用等物。以佛世尊名称善誉殊胜高显超出世间。如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊十号具足。于天人阿修罗沙门婆罗门。若魔若梵一切世间大众之中。以自通力而证圣果。随所游止宣说正法。初善中善后善。文义深远纯一无杂。圆满清白梵行之相

尔时世尊徐缓。而至摩伽陀国。次第经行至王舍大城。到已止于鹫峰山中。是时王舍城中。有一长者其名贤护。宿植善本于先佛所广作佛事。具大财富广多主宰受用之物。积以金银财谷库藏。增集摩尼真珠砗磲珊瑚吠琉璃等。及诸象马牛羊奴婢侍从并营作人。时贤护长者。闻沙门瞿昙从王宫出净信出家。与大苾刍众。千二百五十人俱。经游摩伽陀国。次第至于王舍大城。止其鹫峰山中。而彼沙门瞿昙。具足广大色相功德。名称善誉超出世间。成正觉果如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。随其所应宣说正法。初善中善后善。文义深远纯一无杂。圆满清白梵行之相。长者即作是念。我今宜应诣彼沙门瞿昙之所亲近瞻礼。彼佛如来应供正等正觉。色相功德斯为甚善。时贤护长者作是念已。即与五百长者俱。出王舍大城诣佛瞻礼

尔时世尊。日初分时着衣持钵。与苾刍众恭信围绕。入王舍大城次第乞食。而佛世尊威仪严肃履步调寂。清净光明普照世间。进止屈伸端直清净。时贤护等五百长者。遥见世尊徐徐而来。威容相好清净端严。诸根调柔意念寂静。胜善调伏如大龙王。复类泉流清净无染。有无数天人大众导从围绕。身相巍巍犹紫金色。三十二相八十种好庄严具足。天雨众花广大殊妙。其所雨花周遍稠密。复有千俱胝叶七宝莲花随足而蹈。世尊具足无数百千威仪功德。自远而来。时诸长者于其路左如是见已。于佛世尊深生净信。以清净心前诣佛所。到佛所已头面礼足。肃躬恭信住立佛前。时贤护等五百长者。俱白佛言。世尊瞿昙。于大众中相好增胜。世尊瞿昙于大众中威德增胜。世尊瞿昙于大众中名称增胜。世尊瞿昙。于大众中光明增胜。世尊瞿昙真金色相最上增胜。世尊身相如古金仙。世尊身相妙无等等。世尊诸相具希有法。世尊瞿昙。一切世间无与等者。我见世尊具足如是威相功德。以何缘故舍家出家

尔时贤护长者。即以偈词而伸赞叹

  如我昔闻佛世尊　　名称吉祥及威德
  最上妙相我今观　　殊胜光明具如是
  清净妙好真金相　　金色高胜众所观
  离尘无染处众中　　如众星中妙月现
  我昔归命人中尊　　如须弥山极高胜
  犹天妙盖顶相严　　周遍次第而普覆
  顶骨首发软复滑　　同彼帝青妙色相
  颈相犹如孔雀王　　右旋宛转而柔软
  额广平正复洁白　　双眉犹如帝释弓
  眉间毫相净复明　　如星中王善照曜
  两目善妙喜爱相　　睹者咸生欢悦意
  谛观不起厌足心　　顶礼世尊清净目
  我睹人中尊鼻相　　隆高修直如金山
  唇如琥珀类频婆　　清净复如净珠宝
  齿相明净复洁白　　如乳如藕及如鸭
  坚牢清净密复齐　　随所动转而善爱
  大小诸齿密不厚　　四牙锋利而无垢
  犹如鹅王处鹅群　　光莹清净白中白
  面如初日净光照　　赤优钵罗及铜色
  舌相净妙而广长　　遍覆面门悉清净
  我于天人梵世中　　未尝见佛妙相好
  耳轮犹如师子王　　具师子相善无畏
  我观喉相具威德　　善纳众味净光明
  正直颈项无曲邪　　常得味中之上味
  容仪敦肃而殊妙　　七处平满世所闻
  最胜吉祥人中尊　　如日光明现峰顶
  七处平满其所谓　　二手足心及二肩
  一颈平满七处同　　圆具清净而明焕
  双臂修直复佣圆　　其犹龙王妙清净
  无高无下二臂同　　双垂二臂立过膝
  上半身如师子王　　如尼拘陀身圆满
  犹那罗延不坏身　　大力忍力皆具足
  身毛上靡而柔软　　彼一一毛皆右旋
  尘翳不染净妙身　　譬彼莲花不着水
  阴藏隐覆而复密　　犹如调善妙马王
  双髀其犹软草同　　双腨次第而安住
  足跟平满趺相称　　手足皆具网鞔相
  复如鹅王指纤长　　手足数周二十指
  手指纤长赤铜甲　　诸指柔毛而下覆
  足下圆具千辐轮　　踝骨不粗而不现
  履步平满无高下　　行时离地及四指
  世间最胜妙相圆　　按地宝莲随足蹈
  世尊行步大无畏　　如师子王无高下
  不迟不速处中平　　游戏自在无恐畏
  诸天雨众微妙花　　空中竞奏妙音乐
  非人供养启恭虔　　此佛神通希有相
  色相超越毗沙门　　威光胜踰百千日
  天人魔梵诸众中　　悉无如是胜功德
  今我内心起疑念　　佛具最上神通力
  复见何等功德门　　故佛出家成圣果

尔时世尊告贤护等诸长者言。诸长者。我见十种诸娆乱法世间合集。斯苦甚大。何等为十。一者生为娆乱。二者老为娆乱。三者病为娆乱。四者死为娆乱。五者忧为娆乱。六者悲为娆乱。七者苦为娆乱。八者烦恼为娆乱。九者愁叹为娆乱。十者轮回为娆乱。如是十种诸娆乱法。世间合集我见是已。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊欲重宣此义而说偈言

  诸愚夫异生　　轮回网羁绊
  生娆乱愁叹　　老病旋逼逐
  忧悲故苦恼　　死法来吞食
  若救度出离　　解脱三有网

复次长者。嗔之一法互相损害世间合集。斯苦甚大。损害有十。何等为十。一者以我心故。过去已作诸损害事。二者生起思念。现在今作诸损害事。三者生起思念。未来当作诸损害事。四者我所爱者生起思念。而不已作诸损害事。五者我所爱者生起思念。而不今作诸损害事。六者我所爱者生起思念。而不当作诸损害事。七者非我爱者生起思念。过去已作诸损害事。八者非我爱者生起思念。现在今作诸损害事。九者非我爱者生起思念。未来当作诸损害事。十者生起思念。作无义利损害过失。如是十种诸损害事世间合集。我见是已。为令离彼诸损害故。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊重说偈言

  众生嗔最大　　各各互相害
  已现当损害　　成十损害事
  爱者不生害　　已作及当作
  现作亦复然　　不成损害法
  于我非友爱　　作诸损害事
  已现当亦然　　生损害罪业
  并无义过失　　十损害缠缚
  我见损害法　　乃净信出家

复次长者。种种见中诸险恶见。世间合集斯苦甚大。险恶见者。有其十种。何等为十。一者于我见中起险恶见。二者众生见中起险恶见。三者寿者见中起险恶见。四者于人见中起险恶见。五者于断见中起险恶见。六者于常见中起险恶见。七者无作见中起险恶见。八者无因见中起险恶见。九者不平等见中起险恶见。十者于邪见中起险恶见。如是十种诸险恶见。我见是已。为欲普令破诸见故。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊重说偈言

  我人众生见　　寿者见亦然
  诸愚夫异生　　险恶见所覆
  断常及无作　　邪无因不平
  令安立正见　　是故我出家
  我于阿僧祇　　那庾多百千
  俱胝劫数中　　为众生利乐

复次长者。有大病箭世间合集。斯苦甚大。大病箭者有其十种。何等为十。一者爱箭。二者无明箭。三者欲箭。四者贪箭。五者嗔箭。六者痴箭。七者慢箭。八者见箭。九者成箭。十者坏箭。如是十种诸大病箭。我欲普令悉得拔除。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊重说偈言

  爱箭故贪积　　无智故暗冥
  无明痴暗覆　　旋趣于他蕴
  欲箭随射激　　贪箭故吞食
  嗔箭起昏迷　　痴箭都所覆
  见箭起违背　　慢成坏亦然
  诸愚夫异生　　乃互相毁呰
  此妄止真实　　互相兴违诤
  破世间病箭　　唯佛无生法
  世间诸众生　　常为箭所射
  为救护拔除　　悉令离诸苦

佛说大乘菩萨藏正法经卷第一佛说大乘菩萨藏正法经卷第二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    长者贤护品第一之二

复次长者。爱等诸法建立根本世间合集。斯苦甚大。爱根本法有其十种。何等为十。一者以爱缘故而起追求。二者追求缘故乃生贪着。三者以贪缘故而兴我见。四者我见缘故计为决定五者决定缘故乃生欲贪。六者欲贪缘故即起计着。七者计着缘故而生悭吝。八者悭吝缘故而为执取。九者执取缘故即不防护。十者不防护缘而生众苦。以不护故执持刀杖斗战诤讼。由此因故兴两舌等多种罪业不善之法。如是十种爱根本法世间合集。我见是已。欲令安立无根本法。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊。重说偈言

  众生爱所吞　　于此彼追求
  得利贪我见　　所受为决定
  此事我当作　　乃欲贪增长
  欲贪增长已　　计着生悭吝
  世间悭过失　　坚固而执着
  以执故不护　　起罪咎相续
  愚者以不护　　执刀杖损害
  广作诸罪业　　其后苦增长
  爱缘增长已　　乃生于众苦
  我证胜菩提　　令住无根本

复次长者。邪定聚法世间合集。斯苦甚大。邪法有十。何等为十。一者邪见。二者邪思惟。三者邪语。四者邪业。五者邪命。六者邪勤。七者邪念。八者邪定。九者邪解脱。十者邪智。如是十种邪定聚法。世间合集斯苦甚大。我见是已。普令超越一切邪法。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊。重说偈言

  邪见所含藏　　邪思惟境界
  谈说邪语言　　起作诸邪业
  邪命及邪勤　　邪念与邪定
  起彼邪解脱　　一向生邪智
  此诸邪定聚　　诸愚者安立
  令翻邪入正　　是故我出家

复次长者。恶道深险世间合集。斯苦甚大。渐向恶趣增长恶趣广开恶趣。谓不善业有其十种。何等为十。一者杀生。二者偷盗。三者邪染。四者妄言。五者绮语。六者两舌。七者恶口。八者贪。九者嗔。十者邪见。如是十种不善业道。渐向恶趣增长恶趣广开恶趣。我见是已。为令出离诸险恶道。是故我乃净信出家。

趣证阿耨多罗三藐三菩提果

尔时世尊。重说偈言

  众生起杀命　　侵取他财物
  欲邪行遍行　　速堕于地狱
  两舌及恶口　　妄言无决定
  愚者绮饰语　　异生烦恼缚
  贪心乐他富　　嗔起诸过失
  邪见破坏多　　当堕于恶趣
  身有三种罪　　语四种应知
  意三罪亦然　　作者堕恶趣
  若造诸罪者　　定堕于恶趣
  若离此三罪　　必不堕恶趣

复次长者。烦恼随烦恼。诸杂染垢世间合集。斯苦甚大。杂染有十。何等为十。一者悭吝垢杂染。二者毁戒垢杂染。三者嗔恚垢杂染。四者懈怠垢杂染。五者散乱垢杂染。六者恶慧垢杂染。七者无闻垢杂染。八者疑惑垢杂染。九者无信解垢杂染。十者不尊重垢杂染。如是十种诸杂染法世间合集。我见是已。普令安住无杂染法。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊。重说偈言

  世间相续法　　十杂染逼迫
  著有为杂染　　暂时无疲懈
  诸愚夫异生　　悭垢所染污
  戒学摄众生　　破坏而不具
  愚者背忍辱　　懈怠劣精进
  不能安定心　　恶慧而痴钝
  父母及尊长　　师尊皆远离
  不见世光明　　恶慧起疑念
  佛说甚深法　　而生于毁谤
  痴暗法所覆　　圣法不尊重
  见杂染法已　　不着于有为
  无为无染污　　令众生寂灭

复次长者。生死怖畏世间合集。斯苦甚大。此有十种。何等为十。一者悭之与嫉覆盖成结。斯苦甚大。二者无明分法常所萦缠。斯苦甚大。三者欲海泛溢。斯苦甚大。四者欲中艰苦支节摧坏。斯苦甚大。五者亲爱缠缚欲箭所射。斯苦甚大。六者忿恨烟尘蓬[火*孛]充塞发明炽焰。斯苦甚大。七者贪火烧然。斯苦甚大。八者嗔毒隐覆。斯苦甚大。九者痴障如刺。斯苦甚大。十者生死旷野险难怖畏缠缚随逐。斯苦甚大。我见如是十种法已。欲令除断。是故我乃净信出家。趣证阿耨多罗三藐三菩提果

尔时世尊。总以前义。重说偈言

  生及壮年老吞食　　色相坏为非色相
  无念无慧损减门　　此法能坏世间相
  病能吞食于色力　　势分精进悉摧毁
  而复损减于诸根　　负劣力而无依怙
  死怖其犹罗刹吼　　常时随逐群生类
  时来命尽无爱心　　坏灭世间诸寿命
  老病死法极猛恶　　娆乱世间诸众生
  不老不死安乐门　　我出家为勤求故
  三火烧然于世间　　不见世间救护者
  我起救护世间心　　愿洒甘雨息诸火
  世间正道皆破坏　　无目昏冥复痴暗
  愿开净目施众生　　出家显示于正道
  众生疑惑心所起　　乃为诸障所障覆
  我愿当除恶作心　　故出家已宣正法
  众生互相起违背　　伺求过失而断坏
  故我出家利世间　　普愿众生息嗔恚
  世间父母极亲爱　　众生慢心不尊重
  欲令摧折我慢幢　　是故出家为救护
  我见众生贪所覆　　由财物缘致坠堕
  若能获得七圣财　　当令世间离贫苦
  众生互相起违害　　以无义利已资养
  决定破坏于自身　　是故我令离三有
  愚人不了于义利　　如是遍满三界中
  我欲利益故出家　　当示世间正义法
  众生耽湎于地狱　　我见极受诸苦恼
  种种恶毒广无边　　我出家故令解脱
  众生互相起杀害　　旋复畜生诸趣中
  起悲愿故我出家　　无依众生作依怙
  我见饿鬼趣众生　　极受饥渴诸苦恼
  我证无上大菩提　　普施最上甘露食
  人中追求为大苦　　天中谢灭苦极增
  了知三界诸苦深　　故我出家为救拔
  世间有诸无惭者　　为欲迷乱恶众生
  不择眷属及尊亲　　欲染吞食犹猪犬
  着欲系属于女人　　我见众生为所缚
  起无义利憍醉心　　故我出家为救护
  众生破坏不自在　　恐怖至死不解脱
  我出家已得菩提　　普令觉悟皆自在
  白衣舍中无义利　　我见百千种过失
  我今转此诸地方　　皆令出离生死际

尔时贤护等五百长者。闻佛所说发希有心。咸作是言。佛菩提者斯为广大。我等方知佛为真觉

时诸长者异口同音。而说偈言

  我等五百诸长者　　以老怖故来投佛
  愿说无上胜法门　　出离老死苦边际
  世尊圆净相清净　　已离三有得解脱
  救度三有成坏门　　离三有舍令自在
  离贪解脱无所畏　　离尘无垢清净心
  无上善调大导师　　开明无上甘露法
  无上丈夫住胜相　　天人世间无与等
  无等等者世间尊　　演上中上大悲法
  尽诸过失三垢断　　具清净目离昏冥
  尘暗痴网悉蠲除　　宣说无边离尘法
  悲愍世间无依怙　　三有流中为提拔
  悲心中起大慈心　　速令出离善安住
  憍慢痴恶生死海　　病苦违害如潮流
  无救沉溺诸众生　　佛悲愍故为救度
  佛身清净如金山　　圆具百种胜威光
  甘美最上大梵音　　妙宝语言宣胜法
  诸法自性皆清净　　本来明亮净亦然
  无作作受亦不亡　　为无闻者善开示
  无边名称所行善　　十力无畏自然智
  意等虚空智无边　　善说沙门誓愿法

尔时世尊即起是念。此五百长者善根成熟。我今应当随其所宜为说正法。令此地方转白衣舍成出家相。尽诸有漏作证边际

尔时世尊即于空中加趺而坐。是时五百长者。于佛世尊深生爱乐净信尊重。种种施作善妙亲近

尔时世尊告五百长者言。汝诸长者。世间所有生老病死。忧悲苦恼愁叹轮回。如是十种诸娆乱法。汝等各欲求解脱邪

又复世间已作现作及彼当作。爱非爱中起无义利。如是十种诸损害事。汝等各欲求解脱邪

又复世间种种见中诸险恶见。所谓我人众生寿者断常无作无因不平及彼邪见。如是十种诸险恶见。汝等各欲求解脱邪

又复世间十大病箭。所谓爱无明欲贪嗔痴慢见及成坏。如是十种诸大病箭。汝等各欲求解脱邪

又复世间爱根本法。所谓爱故追求。追求故贪。贪故我见。我见故决定。决定故欲贪。欲贪故计着。计着故悭吝悭吝故执取。执取故不防护。不防护故生苦。如是十种爱根本法。汝等各欲求解脱邪

又复世间邪定聚法。所谓邪见邪思惟邪语邪业邪命邪勤邪念邪定邪解脱邪智。如是十种邪定聚法汝等各欲求解脱邪

佛说大乘菩萨藏正法经卷第二佛说大乘菩萨藏正法经卷第三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    长者贤护品第一之三

复次长者。又复世间十不善业。所谓杀生偷盗邪染妄言绮语两舌恶口贪嗔邪见。如是十种不善业道。汝等各欲求解脱邪。又复世间十杂染法。所谓悭吝杂染。毁戒杂染。嗔恚杂染。懈怠杂染。散乱杂染。恶慧杂染。无闻杂染。疑惑杂染。无信解杂染。不尊重杂染。如是十种杂染之法。汝等各欲求解脱邪。又复世间有其十种生死怖畏。所谓悭嫉覆盖。无明萦缠。欲海泛溢。欲中艰苦。欲箭所射。忿恨烟塞。贪火烧然。嗔毒隐覆。痴障如刺。生死旷野险难怖畏。如是十种生死怖畏。汝等各欲求解脱邪

尔时五百长者。异口同音前白佛言。世尊。我等各欲解脱。十种娆乱之法总略而言。乃至十种生死怖畏彼彼十法。我等各欲悉求解脱

尔时世尊。告五百长者言。汝等各欲求解脱者。而彼解脱从何所求。诸长者。眼不欲解脱。何以故。眼本无转亦复无作。眼无所思亦无了知。是故应知。眼本不从我之建立。诸长者。耳鼻舌身意不欲解脱。何以故。耳鼻舌身意。本无转亦复无作。意无所思。亦无了知。是故应知。意本不从我之建立。诸长者。色不欲解脱。何以故。色无所转亦复无作。色无所思亦无了知。是故应知。色本不从我之建立。声香味触法不欲解脱。何以故。法无所转亦复无作。法无所思亦无了知。是故应知。法本不从我之建立

又复长者。色蕴不欲解脱。何以故。色蕴无转亦复无作。色蕴无思亦无了知。是故应知。色蕴不从我之建立。受蕴想蕴行蕴识蕴不欲解脱。何以故。识蕴无转亦复无作。识蕴无思亦无了知。是故应知。识蕴不从我之建立

又复长者。地界不欲解脱。何以故。地界无转亦复无作。地界无思亦无了知。是故应知。地界不从我之建立。水火风空识界不欲解脱。何以故。识界无转亦无所作。识界无思亦无了知。是故应知。识界不从我之建立

诸长者。当知一切法皆从虚妄分别所起。系属于缘无力劣弱。从缘而转。若有缘法而彼诸法即可施设。缘法若无。诸法亦复无所施设。然于一切法所施设中。无有少法而可了知。亦无少法若生若灭若起若尽。复无别法为断为常。汝诸长者。以是缘故应如是知。彼一切法皆从虚妄分别所起。系属于缘无力劣弱。从缘而转。若有缘故而彼诸法即可施设。缘法若无。诸法亦复无所施设。然于一切法所施设中。亦无少法而可了知。亦无少法若生若灭若起若尽。复无别法为断为常。汝等当知。若有虚妄分别。不如理作意即可施设。若无虚妄分别。不如理作意无所施设。若有不如理作意。而彼无明即可施设。若无不如理作意。无明亦复无所施设。无明有故行有施设。无明无故行无施设。诸行有故识有施设。诸行无故识无施设。识法有故。而彼名色即可施设。识法无故。名色亦复无所施设。名色有故。而彼六处即可施设。名色无故。六处亦复无所施设。六处有故触可施设。六处无故。触法亦复无所施设。触法有故受可施设。触法无故。受法亦复无所施设。受法有故爱可施设。受法无故。爱法亦复无所施设。爱法有故取可施设。爱法无故。取法亦复无所施设。取法有故有可施设。取法无故。有法亦复无所施设。有法有故生可施设。有法无故。生法亦复无所施设。生法有故。而彼老死即可施设。生法无故。老死亦复无所施设。此中应知何名为老。谓状貌衰变喘息呻吟。策杖而行诸根熟异。寿命减没行相朽旧。如是所说故名为老。何名为死。谓终殁时至灭所灭相。诸蕴离散身坠于地。彼众同分坏谢变异。如是所说故名为死。此是老相。此是死相。总而言之名为老死。生法有故。而彼老死即可施设。生法无故。老死亦复无所施设。何名为生。谓发生遍起出胎成立。五蕴起聚六处圆具。彼众同分次第合集。如是所说故名为生。有法有故生可施设。有法无故。生法亦复无所施设。何名为有。谓欲有色有无色有。此名为有。取法有故有可施设。取法无故。有法亦复无所施设。何名为取。谓欲取见取戒禁取我语取。如是所说故名为取。爱法有故取可施设。爱法无故取法亦复无所施设。何名为爱。谓色爱声爱香爱味爱触爱法爱。如是所说故名为爱。受法有故爱可施设。受法无故。爱法亦复无所施设。何名为受。谓眼触为缘所生诸受。耳触为缘所生诸受。鼻触为缘所生诸受。舌触为缘所生诸受。身触为缘所生诸受。意触为缘所生诸受。如是所说故名为受。触法有故受可施设。触法无故受法亦复无所施设。何名为触。谓眼触耳触鼻触舌触身触意触。如是所说故名为触。六处有故触可施设。六处无故触法亦复无所施设。何名六处。谓眼处耳处鼻处舌处身处意处。如是所说故名六处。名色有故而彼六处即可施设。名色无故六处亦复无所施设。何谓名色。谓受想行号之为名。受触作意及彼四大。四大所造号之为色总而言之故曰名色。识法有故而彼名色即可施设。识法无故名色亦复无所施设。何名为识。谓眼识耳识鼻识舌识身识意识。如是所说故名为识。行法有故识可施设。行法无故识法亦复无所施设。何名为行。谓色遍思声遍思。香遍思味遍思。触遍思法遍思。如是所说故名为行。无明有故行可施设。无明无故诸行亦复无所施设。何名无明。谓不知先际。不知后际。不知先后际。不知内不知外。不知中间。不知苦集灭道四圣谛法。不知于缘。不知缘生法中若黑若白。不知缘与非缘。不知对碍非对碍。不知有罪无罪。不知所应亲近不应亲近。于诸法中不知不见。不能觉了现前三昧。如是所说故名无明。不如理作意有故。而彼无明即可施设。不如理作意无故。无明亦复无所施设。何名不如理作意。谓我于先世为有为无。我于先世已过去邪。未过去邪。我于先世为类何等。我于未来世当复何得为有为无。未来世中当在何处。我于未来世复类何等。于内法中其复云何有我无我。而生疑惑为有为无。何者是生何者不生。若有所生复类何等。由起如是不如理作意故。于其六见及余见中有所生起。即起有我之见无我之见。于我我所中。不能平等如理而观。以不平等如理观故。如是乃有诸见生起。是故有我及有世间。即有缘法。其缘法者。无常无强无力无坚。是不究竟变坏之法。于不究竟法中。计为正住及正安立。此见成已。是故说名不如理作意。虚妄分别有故。不如理作意即可施设。虚妄分别无故。不如理作意无所施设。何名虚妄分别。谓我人众生寿者补特伽罗儒童意生作者受者。此名虚妄愚夫异生无闻之者。于我人众生寿者等中。而生遍计。此名分别。总而言之故名虚妄分别。此虚妄分别有故。不如理作意即可施设。虚妄分别无故。不如理作意无所施设。此虚妄分别及不如理作意有故。无明即可施设。二法无故。无明亦复无所施设。无明有故。而彼诸行即可施设。无明无故。诸行亦复无所施设。总略而言。乃至生法有故。而彼老死即可施设。生法无故。老死亦复无所施设。诸长者。当知一切法皆是虚妄分别所起系属于缘。其缘法者无常无强无力无坚。从缘而转缘法有故。而彼诸法即可施设。缘法无故。诸法亦复无所施设。然于一切法所施设中。亦无少法而可了知。亦无少法若生若灭若起若尽。亦无别法为断为常。诸长者。譬如池中大水流注。有诸虫鱼栖止其内。于汝意云何。而彼诸鱼依何力邪。长者白佛言。世尊。依水为力。佛言长者。于汝意云何。水实有力邪。长者白佛言。不也世尊。不也善逝。佛言长者。水本无思其何有力。长者白佛言。无力世尊。无力善逝。佛言长者。虚妄分别所起诸法。亦复如是。无力无坚从缘所转。缘法有故。而彼诸法即可施设缘法无故。诸法亦复无所施设。然于一切法所施设中。亦无少法而可了知。亦无少法若生若灭若起若尽。复无别法为断为常。诸长者。而彼缘法若或如理伺察之时。实不可信。不可信故。即生惊怖。由惊怖故四向驰走。又复谛诚如理伺察。云何是此法。云何是彼法。以伺察故。即不见有惊怖驰走。又复如理伺察之时。即无有法。以无法故。云何驰走。何以故。诸长者。以一切法无所得故。一切心意亦无所得。又复诸长者。一切法无我。以离尘垢故。一切法无众生。以离我故。一切法无寿者。超越一切生老病死忧悲苦恼愁叹等法故。一切法无人。三世断故。一切法无文字。一切音声语言离故。一切法本来无尘。无所缘故。一切法寂静。近寂相故。一切法一切处通达。如虚空自性故。一切法依止于空。无决定对现故。一切法无动。无依止故。一切法安住实际。无住无动相应故。一切法无言说。离语言波浪故。一切法无色相。离形显色及对碍所行故。一切法无等。离我相故。一切法无所了知。离心意识故。一切法无含藏。超越眼之境界道故。一切法不可信。超越耳鼻舌身意境界道故

佛说大乘菩萨藏正法经卷第三佛说大乘菩萨藏正法经卷第四

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    长者贤护品第一之四

复次佛告诸长者言。一切法无观无不观。何以故。离生住灭故。一切法无转无作。离心意识故。一切法系属于缘。自性无力故

又诸长者。眼者四大所造。无常无强而不究竟。无坚无力速朽之法。斯不可信。多苦多恼众病所集。是故诸长者。眼无依止亦无造作。耳鼻舌身意。亦复如是。四大所造。无常无强而不究竟。无坚无力速朽之法。斯不可信。多苦多恼众病所集。是故诸长者。意无依止亦无造作。诸长者。是等诸法应如是学。此眼如聚沫不可撮摩。眼如浮泡不得久立。眼如阳焰。从业烦恼渴爱所生。眼如芭蕉自体无实。眼如幻化从颠倒起。眼如梦寐为虚妄见。眼如其响系属于缘。眼如影像由业对现。眼如浮云刹那离相。眼如电光须臾变灭。此限无主为如地。此眼无我为如水。此眼无众生为如火。此眼无寿为如风。此眼无人犹如虚空。此眼不实四大为家。此眼性空离我我所。此眼无知如草木瓦砾。此眼无作风力所转。此眼为空不净充满。此眼虚伪。虽复治事莹饰终归散灭。此眼如丘井为老所逼。此眼毕竟无边际处。后当归死。诸长者。汝等当知。眼既如是。耳鼻舌身意其义亦然。总略乃至彼一切法应如是知。诸愚夫异空。于彼一切所欲法中。而生爱着。谓眼耳鼻舌身意。色声香味触法

又复于彼色蕴受蕴想蕴行蕴识蕴。眼界色界眼识界。乃至意界法界意识界

地界水界火界风界空界识界。此等法中所欲爱着。乃至一切有为无为名相法中所欲爱着。是故诸长者。汝等当于所欲法中勿生爱着。谓妻子舍宅财宝等法。勿生贪取。当发净信舍家出家。得出家已不生乐欲。无乐欲故圆具净戒。修持清净波罗提木叉之法。圆满洁白法式仪范。乃至小罪犹怀大惧。诸长者若如是学。即得戒蕴具足。戒具足故。耳鼻舌身意。色声香味触法。而无所取

色蕴受蕴想蕴行蕴识蕴。而无所取。眼界色界眼识界。乃至意界法界意识界。而无所取

地界水界火界风界空界识界。而无所取。总略而言。彼一切法都无所取。以无取故即无减失。何法无减失。谓眼耳鼻舌身意。色声香味触法无减失

色蕴受蕴想蕴行蕴识蕴无减失

眼界色界眼识界。乃至意界法界意识界无减失

地界水界火界风界空界识界无减失。此等诸法。若无减失即无染污。无染污故即速得轻安。何法轻安。谓无所见。若无所见即一切所向。无有少法而作障碍。若无障碍即自无所害。他无所害。自他无所害。由无害故心无所坏。即能趣入彼无余依清净涅盘

又诸长者。所言入者。何所入邪。谓非眼所入。非耳鼻舌身意所入。又诸长者。若执眼从缘成。此即着我我所离于涅盘。云何离涅盘。谓贪故离涅盘。嗔故离涅盘。痴故离涅盘。无智故离涅盘。诸长者。无智者不离过去。不离未来。不离现在。决定无智离智所生。何名为智所谓尽智。何名尽智。谓即过去无尽智。未来无尽智。现在无尽智。缘法无智离智所生。彼无智离智。即眼从缘离智所生。眼者无我。若无我即无取。若无取即无舍。若无舍即解脱。云何解脱。谓我执解脱。众生执解脱。寿者执解脱。人执解脱。断常执解脱。一切执解脱。分别执解脱。彼无分别已。即无能分别所分别。法无分别亦不离分别。云何无分别。谓我我所俱无分别。若我无分别即无取舍。若无取舍即所入解脱。若法离系。若法非离系皆得出离。何所离邪。谓离一切苦。诸长者。当求如是出离之法。然于是中无法可取。何以故。若有所取即生怖畏

尔时世尊。欲重宣明如是等义。说伽陀曰

  以取法故即生怖　　由怖当堕恶趣中
  若见如是怖起因　　识法有故而生取
  若能如理观正道　　慧光明见破诸暗
  见故即得胜慧明　　当知异性无所得
  应当审观诸空处　　运动虚假而不实
  此中勿作安乐门　　渴爱虚诳世间故
  如实了知于空法　　知诸法空皆无实
  我得安乐离忧门　　亦得无动最上乐
  若能如是正了知　　即知一切法皆空
  由斯解脱诸苦因　　是故诤讼无所立
  因诸所欲生执着　　执故而生诸娆恼
  执者即是取之名　　因取故生于三有
  有故有生即轮转　　三有止息即不生
  老病死法亦随无　　毕竟不受无常苦
  当知无欲即无取　　以无取故无三有
  有若止息即无生　　老病死苦皆不受
  是故汝等诸长者　　同发舍离取着心
  弃诸眷属所爱因　　速当圆具苾刍相
  知识财利诸所欲　　应当互生于喜足
  随处谦恭起下心　　所向为他增善利
  勿起意谓自守戒　　勿观他为破戒者
  于其戒相持犯中　　勿非毁他为犯者
  譬如野鹿投绳网　　当知彼为自损害
  魔索缚心害亦然　　毁他生害亦如是
  愚人生诸损害意　　自赞毁他深为咎
  毁戒尚息于谤言　　何况梵行持戒者
  具学仙众勇智者　　常修远离寂静行
  弃舍身命无爱心　　勤求解脱寂静法
  诸外道辈及典章　　无利根本皆远离
  爱乐甚深正法门　　彼法宣说真空理
  心根本处此当知　　所谓内外十二处
  从彼生起诸业因　　业久住处谓思法
  眼根色境二种缘　　眼识生缘为三事
  若不和合破散时　　如无薪火义如是
  如是所生一切法　　互相和合故有生
  作者受者二俱无　　正道常现诸所作
  内外诸法所成身　　是中应知我空法
  愚人颠倒执着心　　于我我所不知故
  眼内无法而可有　　于外亦复无所得
  无我无作寿者无　　应知诸法亦如是
  非眼遍思欲解脱　　耳鼻舌身意亦然
  色等无转无作门　　当观诸法亦如是
  如大海水起聚时　　暂生泡沫而无实
  谛观眼等亦复然　　无坚无力如泡沫
  五蕴自性假和合　　如彼聚沫无坚力
  解脱一切娆恼门　　及彼生老等忧恼
  汝于我教出家已　　了知一切法如幻
  不虚受彼信施心　　复能普供十方佛

尔时五百长者。闻佛宣说甚深正法。即于如是中路方处。远尘离垢得法眼净。譬如白衣不杂尘黑易受染色。此五百长者。于是方处远离尘垢法眼清净。亦复如是

尔时世尊。复为五百长者。宣说法要示教利喜。佛言诸长者眼极炽焰。云何炽焰。谓贪火嗔火痴火炽焰。生老病死忧悲苦恼等火炽焰。我说此法自受苦恼。耳鼻舌身意炽焰亦然。云何炽焰。谓贪火嗔火痴火炽焰。生老病死忧悲苦恼等火炽焰。我说此法自受苦恼色尘炽焰。云何炽焰。谓贪火嗔火痴火炽焰。声香味触法尘诸火炽焰。亦复如是

又诸长者。色蕴炽焰。云何炽焰。谓贪火嗔火痴火炽焰。受蕴想蕴行蕴识蕴诸火炽焰。亦复如是。十八界法其义亦然

又诸长者。地界炽焰。谓贪火嗔火痴火炽焰。水界火界风界空界识界炽焰。亦复如是。谓贪火嗔火痴火炽焰。生老病死忧悲苦恼炽焰亦然。我说此法自受苦恼

复次长者。眼无所取应如是学。耳鼻舌身意亦无所取。色无所取声香味触法亦无所取。应如是学

又诸长者。色蕴无所取。受蕴想蕴行蕴识蕴。及十八界皆无所取。应如是学。又诸长者。地界无所取。水界火界风界空界识界亦无所取。应如是学

又诸长者。此界无所取。他界无所取。应如是学

复次诸长者。若眼耳鼻舌身意无所取故。即无依止。色声香味触法无所取故。即于诸处中得无依止

又诸长者。色蕴受蕴想蕴行蕴识蕴。及十八界无所取故。即于蕴界中得无依止

又诸长者。地界水界火界风界空界识界无所取故。即于六界中得无依止。又诸长者。此界他界无所取故。即于一切世界之中得无依止

又诸长者。若一切法无所取故。即于一切法中得无依止。诸长者。一切法无所得亦非无得。若能了知无得非无得。即能解脱生老病死忧悲苦恼。我说此为解脱诸苦

尔时世尊。欲重宣明如是等义。说伽陀曰

  此诸世间极炽焰　　生死二火镇烧然
  无救娆恼诸愚夫　　唯圣道法常不灭
  何法世间作光明　　有佛如来今出现
  刹那善观正道门　　发起精进常坚固
  常观诸法无依止　　慧光明见破诸暗
  见故即得胜慧明　　应知异性无所得
  若能观察无依止　　了知一切法皆空
  如是了知空法门　　菩提心空无所有
  当知贪嗔痴等法　　此三炽焰极猛恶
  世间寿命普烧然　　久处睡眠愚不觉
  所有生老及病死　　忧悲苦恼常逼迫
  当知娆恼诸世间　　彼一切法无依止

尔时五百长者。闻佛所说如是正法。心开意解。前白佛言。世尊。我等今者快得善利。于佛法中净信出家。复于佛所圆具净戒

尔时佛言。善来诸苾刍。即时诸长者。须发自落袈裟着身。成苾刍相

尔时世尊。说伽陀曰

  汝念受持袈裟衣　　须发自落皆清净
  执持应器善相圆　　一切皆成阿罗汉
  既证果已依师法　　各说清净嗢陀南
  于诸天人大众前　　圆满清净苾刍相
  往昔曾于诸佛所　　皆修广大布施行
  一呼善来欢喜生　　处处广修诸善法
  今得见我出世间　　发清净心复增胜
  由彼增胜清净心　　听说最上清净法
  闻佛语已证圣果　　远离我见诸执着
  现前空法悟圆成　　我生已尽皆解脱

佛说大乘菩萨藏正法经卷第四佛说大乘菩萨藏正法经卷第五

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    无怖夜叉品第二

尔时世尊。于其中路。化度五百诸长者已。即于是处安然详审。将入王舍大城

尔时王舍大城诸贤圣中。有大夜叉。名曰无怖。即作是念。值佛世尊斯极难得。我今应以胜妙饮食奉上世尊。时无怖夜叉。即以色香味触清净具足上妙饮食。恭奉世尊

尔时世尊。为悲愍彼无怖夜叉故。受所施食。佛受食讫。即时空中有六万八千诸夜叉众。作是赞言。善哉善哉。随喜赞声遍闻空界

时无怖夜叉。告自会中诸夜叉众言。我已持奉如来清净上妙饮食。汝等诸众。宜应奉施诸苾刍众清净饮食。当令汝等施长夜中利益安乐

时诸夜叉。即皆奉施诸苾刍众最上饮食。时苾刍众。为悲愍故悉受其食。尔时世尊及苾刍众。受其食已。渐次进诣王舍大城。是时即有无数千天众。无数千龙众。夜叉众。乾闼婆众。阿修罗众。迦楼罗众。紧那罗众。摩睺罗伽众。人众非人众。及彼无数百千俱胝那庾多诸众生众。咸悉围绕随从世尊

尔时世尊。未至王舍大城。先诣一处广大地方。到已敷设胜妙之座。佛处其座。时无怖夜叉。即以天妙曼陀罗花。优钵罗花。钵讷摩花。俱母陀花。奔拏利迦花。及彼天妙栴檀香末。散于佛上而伸供养。普散遍散周广而散。散已合掌住立佛前

尔时世尊。如无怖夜叉及诸夜叉众深心清净已。即时放大殊妙光明。法尔已来诸佛世尊所放光明。具无数色及种种色。从口门出。所谓青黄赤白红紫碧绿。光明普照无边世界。映蔽日月威光不现。其光照耀下至地狱上至梵世。光相旋还至于佛所。右绕七匝。而彼光明从佛顶隐。或从肩隐。或从膝隐。法尔已来诸佛世尊。若为地狱众生授记。光即从佛双足而隐。若为傍生授记。光从背隐。若为饿鬼众生授记。光从前隐。若为人趣授记。光从左隐。若为天趣授记。光从右隐。若为声闻授记。光从膝隐。若为缘觉授记。光从肩隐。若诸佛世尊为诸菩萨。授阿耨多罗三藐三菩提记。光从顶隐

尔时尊者阿难。见佛世尊所放广大净光明已。偏袒右肩右膝着地。合掌向佛。说伽陀曰

  世尊今日以何因　　放大光明普照耀
  广作利益诸世间　　现斯光相何所为
  何人今日植圣种　　闻佛菩提广大因
  何人授记在今时　　何人安住解脱果
  大智放光非无因　　为调伏故现光相
  所放光相作开明　　牟尼圣尊光何现

尔时世尊。说伽陀曰

  有一夜叉名无怖　　信向佛故施饮食
  彼发最上清净心　　故我今时现光相
  而是夜叉此界灭　　即当往生忉利天
  于彼天中寿终时　　后当生于夜摩天
  夜摩灭已生兜率　　以欲尘故造染业
  还复堕生于人间　　当得为王具神力
  作转轮王人中主　　统四大洲而自在
  人间灭已复得生　　彼梵世中受胜报
  后经二十俱胝劫　　常为一切所恭信
  于彼天上及人间　　数数往来受诸乐
  其后弃舍于王位　　净信舍家而出家
  于彼缘觉妙菩提　　如是毕竟当获得
  经于三十千生中　　而数灭彼夜叉身
  后复还生忉利天　　恭敬于佛作佛事
  弥勒尊佛当见已　　而彼夜叉即获得
  阿罗汉果证圆成　　随佛大师伸供养
  后满一千夜叉生　　安立无上大菩提
  以彼彼生诸善根　　永不复堕诸恶趣
  或复值遇于千佛　　尊重恭敬人中尊
  为求无上大菩提　　利益一切众生故
  或二三千夜叉生　　以花鬘等作供养
  为佛菩提最上因　　千俱胝生供养佛
  次复清净观己身　　后复尊敬佛菩提
  夜叉有子名大山　　受夜叉身具神力
  大山夜叉发净心　　愿我当得成佛果
  后常恭敬佛世尊　　于一切处发洪愿
  今见我已伸供养　　发起最胜菩提心
  即当以此众善根　　永离三涂诸恶趣
  当见弥勒尊佛已　　施佛俱胝妙宝盖
  施宝盖已复净心　　施佛俱胝妙衣服
  如是广大供施已　　然后发心求出家
  五百岁中起精勤　　清净修持于梵行
  为求无上大菩提　　利益一切众生故
  彼以如是胜上缘　　普修布施持戒行
  如彼殑伽沙数量　　若干劫中广修行
  若干劫数我所知　　如所知见而宣说
  此后修行经劫数　　非我所知不可说
  如先所说譬喻中　　殑伽河沙等数量
  彼见若干佛世尊　　于彼彼佛咸尊敬
  奇哉胜智大智心　　即彼大心无有上
  广伸供养于诸佛　　普利众生数莫知
  后当成佛大圣尊　　一切世间无有上
  大山夜叉当成佛　　名称医王为佛号
  七十俱胝岁数中　　广为众生宣正法
  名称医王佛会中　　二十俱胝大众会
  而彼众会所发心　　一切当修布施行
  其后复增苾刍众　　数满二十一俱胝
  于彼广大众会中　　具有无量声闻众
  彼会所有声闻众　　而悉趣向大菩提
  彼佛利益诸众生　　化事周圆当入灭
  彼时正法住于世　　当满百千岁数中
  五百劫中得具圆　　有佛及彼苾刍众
  其后或复经一劫　　或复经彼一千劫
  智者出现化世间　　使令亲近于佛法
  说彼极善乐欲意　　深固多闻为最上
  不深固心悉灭除　　常当深固善观察
  宣说诸有多闻者　　彼能增长于胜慧
  四根本法正义门　　为诸菩萨所归向
  所谓施戒闻舍等　　于菩萨道极贤善
  宣说菩提正道门　　最胜乘中而无上
  其有宣说声闻道　　除断疑网复贤善
  广为利益诸众生　　我放光明普照耀
  佛出世为大光明　　当知最上极难得
  宣说甚深妙法门　　普利一切世间故

尔时大山夜叉即作是念。世尊今时往诣王舍大城鹫峰山中。我今宜应于世尊所少植善根。即时告语彼自会中夜叉众言。诸仁者。汝等当知。世尊将诣王舍大城鹫峰山中。汝等宜应发勤勇心各随力能为佛世尊作供养事

时大山夜叉言已。即与自会眷属。从王舍大城乃至鹫峰山中。所经道路皆悉除去土石砂砾。如净圆镜。于道路中以净香水周匝遍洒。复以妙衣于其道中相续布设。复于道中处处安施。等人分量诸殊妙花。幢幡宝盖种种庄严。复置殊妙涂香宝瓶及诸妙香。宝绳交络垂诸花璎。以为严饰。复于空中奏妙音乐。又复敷置尽一箭道。优钵罗花。俱母陀花。奔拏利迦花等。复有异鸟翔鸣道中。金绳交络有七宝网。及以金网弥覆其上

尔时大山夜叉。于其道中广庄严已。即自化身并其众会。身喜心喜清净悦意。发欢喜心。极纯善心。柔软心清净心。无障碍心悦乐心。向佛心向法心向僧心。菩提无动心。无恐畏心无等等心。一切三界最胜心。慈愍一切众生心。悲心喜心舍心。成诸佛法大器之心。真实心坚固心。不破坏心增胜心。于声闻缘觉地中生弃舍心。于菩萨地中起成办心。发如是等清净之心。来诣佛所。到已头面顶礼佛足。右绕三匝住立一面。合掌向佛说伽陀曰

  我今为佛广施设　　最上最胜诸供养
  愿我当得佛圣果　　宣说最上微妙法
  愿我当圆于十力　　欢喜善住四无畏
  广大利益诸众生　　如佛世尊诸所作
  具三十二胜妙相　　八十种好众庄严
  当作世间大光明　　如佛世尊普照耀
  转彼清净妙法轮　　十二行相而最上
  宣说甘露正法门　　普为众生作利益
  广现神通变化事　　如佛世尊现亦然
  善作利益诸群生　　乃至无数俱胝众
  世尊出现大光明　　如大龙王无所畏
  如是正道广宣扬　　开觉菩提而无上
  为舍亦复为归救　　为趣摄化诸众生
  愿我当得亦复然　　利众生事皆圆满
  五趣所生诸群品　　愿我当为作主宰
  悉令解脱诸苦因　　如佛世尊所解脱
  为二足尊作供养　　无边威德光明照
  天主龙及阿修罗　　普供世间无等比
  我作最上胜事业　　愿我当如大法主
  三十二种胜相圆　　天上人间为最上

尔时世尊。为大山夜叉说伽陀曰

  如佛世尊所说教　　修作无上正法因
  众生当得胜法门　　无上菩提不难得
  世间光明大圣主　　作供养已佛光照
  诸天龙神人众中　　所应受彼诸供养
  成证无上大菩提　　安坐树王众集会
  摧伏大恶诸魔军　　广为众生宣正法

尔时世尊即与无数百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。并余无数百千俱胝那庾多诸众生类。恭敬围绕。而佛世尊具大威德。有大神力起大变化。广大施作放大威光。振动刹土雨大莲花。鼓百千种殊妙音乐。有妙莲花大若车轮。随足而蹈。世尊从彼大山夜叉妙巧施作庄严道路。往诣鹫峰山中。世尊到已。即告尊者阿难言。汝可为佛施设殊妙之座。所谓法座最上之座。三界胜座及妙宝座。如来登其座已。摄受一切众生。称扬演说彼菩萨藏甚深正法。成办一切菩萨胜行。除去一切众生诸有疑惑。开明正慧断诸疑网。如来说此甚深经典。广为悲愍利益安乐天人世间一切众生

尔时尊者阿难受佛敕已。乃为如来施设胜座。是时即有六十八俱胝天众。各各为佛施设宝座。而为献奉。请佛如来登斯座已。即于佛前。异口同音说伽陀曰

  我今为佛广敷设　　殊胜宝座及妙衣
  愿佛悲愍诸天人　　如其所应登宝座
  若佛如来登座已　　宣说正法趣彼岸
  六种振动于世间　　一切皆生大欢喜
  佛光普照诸大众　　焕明佛刹及山王
  普得见佛大圣尊　　开生清净诸法欲
  所有天龙及人众　　八部一切诸品类
  互相得见彼彼身　　是中一切无障碍
  所有俱胝那庾多　　百千天人大众等
  各得见佛大圣尊　　宣说难得妙法句
  是时频婆娑罗王　　与诸臣佐并眷属
  刹那来至佛会中　　亲近圣尊为听法
  佛知众座悉已定　　普遍四方善观察
  一切众会及天人　　广为众生作利益
  世尊普告诸大众　　疑者当问二足尊
  随诸所问我开明　　普令除断诸疑惑

尔时三千大千世界一切众生。及天人世间诸众会等。咸悉恭敬瞻仰世尊。起清净心。屏息外闻。专注听受如来宣说甚深正法

尔时世尊即告尊者大目干连言。汝勿就座。应当观彼诸苾刍众。其有未来赴斯会者。汝今往彼雪山南面大迦叶所。召来赴会

时尊者大目干连受佛敕已。即运神力。往诣雪山南面大迦叶所。到已白言。尊者当知。世尊如来今在鹫峰山中。与沙门婆罗门人天大众。集会说法。佛遣我来呼召尊者。唯愿尊者。如佛教命往赴佛会。无令互得隐法之罪。尔时尊者大迦叶谓尊者大目干连言。汝宜先往。我即随当往诣佛所

是时尊者大迦叶。即于座中运自所有神通化用。四众围绕。于刹那间即到鹫峰山中佛世尊所。到已头面顶礼佛足。去佛不远于一面坐

时尊者大目干连。以神通力旋至佛所。见尊者大迦叶先至佛会在一面坐。见已白言。尊者大迦叶。神力具足先至佛会。其何速邪。尊者大迦叶即谓大目干连言。如佛说汝神通第一。何故今时徐缓如是

佛说大乘菩萨藏正法经卷第五佛说大乘菩萨藏正法经卷第六

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    菩萨观察品第三之一

尔时尊者舍利子即从座起。偏袒右肩右膝着地合掌向佛而白佛言。世尊。我有少疑欲当请问。惟愿如来应供正等正觉。善为宣说。若佛世尊听许所请。我即当问。佛言舍利子。恣汝所问。如来应供正等正觉。随有问者即当为说。使其皆得开释疑心

尔时尊者舍利子即白佛言。世尊菩萨摩诃萨成就几法。即得身业无诸过失。语业无诸过失。意业无诸过失。身业清净语业清净意业清净。身业无动语业无动意业无动。天魔外道力不能制。然后深发一切智心。地位诸善次第得成。能为一切众生作所归向。作光明炬。作大河流。作大桥梁。作大船筏济渡一切到于彼岸。为舍为救为归为趣。于一切智心而无动转。尔时尊者舍利子。为欲称扬如是义故。以偈问佛

  以何义故勇智者　　而能安住大菩提
  宣扬功德妙法门　　成证无上菩提果
  诸勇智者何所行　　利益一切诸群品
  又复观察何法门　　而能成佛无上道
  复以何法降魔众　　安处菩提大道场
  振动俱胝刹土中　　圆证菩提胜妙果
  以何义故名菩萨　　如是之句复云何
  此中愿说菩提门　　一切佛法中最上
  于诸世间何所行　　而能广利诸众生
  离诸染着如莲花　　解脱俱胝诸群品
  云何应受彼供养　　诸天诸龙及智者
  乃至一切人非人　　今问斯义愿宣说

尔时世尊告尊者舍利子言。舍利子。汝今当知。菩萨若能成就一法。于一处于多处。普能摄受无量佛法。何者一法。所谓发起深固大菩提心。此即是为菩萨成就一法于一处于多处。普能摄受无量佛法。舍利子白佛言。世尊。云何名深固。云何名菩提心。佛告舍利子言。深固者。即是真实不破坏故。坚固无动故。无动即无退屈故。无退屈即善安住故。善安住即无退转故。无退转即善观察众生故。善观察众生即大悲根本故。大悲根本即广大心故。广大心即善知成熟众生法式故。善知成熟众生法式即自在妙乐故。自在妙乐即无种类故。无种类即无爱着故。无爱着即摄受众生故。摄受众生即善能观察劣弱众生故。善能观察劣弱众生即为救为归不起恚心故。不起恚心即善观视故。善观视即无所得故。无所得即善意乐故。善意乐即无所有故。无所有即善清净故。善清净即自洁白故。自洁白即内无垢故。内无垢即外清净故。舍利子。此如是等。从真实不破坏至内无垢外清净。斯诸法门乃名深固。又舍利子。菩提心者。谓即彼心无诸过失。一切烦恼不能随逐。彼心不乐余乘。彼心坚固不为一切邪外语言之所坏乱。彼心不破。一切魔众而不能动。彼心决定。长养一切善根本行。彼心不动。爱乐佛法故。彼心善住。登菩萨地故。彼心无上。无对治故。彼心如金刚。一切佛法善决择故。彼心平等。无高下故。彼心于一切众生意乐清净。自性无染故。彼心无垢。慧光照故。彼心广大。容受一切众生故。彼心无染。如虚空故。彼心无障碍。观无碍智故。彼心于一切处随应了知。大悲无断故。彼心现证。清净称赞故。彼心成就一切智种子。圆满一切佛法故。彼心安住普施一切乐事。誓愿最胜故。彼心圆具净戒。无缺犯故。彼心修持忍辱。离诸恚故。彼心精进。不懈怠故。彼心禅定。近寂静故。彼心无害。具慧行故。又复彼心是真实根本。成就如来戒蕴定蕴慧蕴解脱蕴解脱知见蕴。彼心是真实根本。圆满如来十力四无所畏十八不共法故

又舍利子。菩提所成之心。名菩提心。而此萨埵求菩提心深固具足。是故得名菩提萨埵。此亦说名广大众生最上众生三界最胜众生。此即身业无诸过失。语业无诸过失。意业无诸过失。身业清净语业清净意业清净。身业无动语业无动意业无动。不为一切天魔外道而能动转。深发一切智心。地位诸善次第当得。一切世法不能染污。能为一切众生善作调伏。作遍调伏。作所归向。作光明炬。作大河流。作大桥梁。作大船筏。济渡一切到于彼岸。为舍为救为归为趣。深发一切智心。不为天魔外道之所动转。此菩萨于阿耨多罗三藐三菩提心。净信深固广多清净。乐见诸圣乐闻深法。心无悭惜广行施舍。常乐出离心无障碍。于一切众生无杂乱心。无退堕心无流散心。有业有报净信无疑。诸所施作悉离疑惑。于善恶法不坏果报。此如是等善了知已。于身命缘不造罪业。远离杀生偷盗邪染妄言绮语两舌恶口贪嗔邪见。如是十不善业皆悉断除。十善之业常所修集净信谛理。于沙门婆罗门中。常修正道具戒清净。广多听受一切善法。闻已勤行深固作意。而善调伏遍寂近寂。离诸诤讼无非爱语。心意纯善无不善意。勤行善法离不善法。无高无下亦不轻动。离诸赞毁安住正念。妙等引心断三有缚。拔除毒箭去诸重担。乐住寂静度诸疑悔不受后有。常于诸佛世尊菩萨摩诃萨及沙门婆罗门所。亲近恭敬随顺奉事无相违背。而常不离诸善知识。摄受正法宣正法门示教利喜。谓布施大富持戒生天。多闻大慧修习相应如是宣说。此是布施得布施果。此是悭吝得悭吝果。此是持戒得持戒果。此是犯戒得犯戒果。此是忍辱得忍辱果。此是嗔恚得嗔恚果。此是精进得精进果。此是懈怠得懈怠果。此是禅定得禅定果。此是散乱得散乱果。此是智慧得智慧果。此是愚痴得愚痴果。此身善所行得身善所行果。此身恶所行得身恶所行果。此语善所行得语善所行果。此语恶所行得语恶所行果。此意善所行得意善所行果。此意恶所行得意恶所行果。此是善此是不善。此所应作。此不应作。此所施作。于长夜中利益安乐一切众生。此所施作于长夜中。而不利乐一切众生。此如是等。于善知识所。宣说正法示教利喜。知是大法器者。即当宣说甚深法门谓空解脱门。无相解脱门。无愿解脱门。无造无作无生无起无我无人无众生无寿者。及说甚深缘生之法。所谓有法。有故有生。即无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是即一大苦蕴集。以不有故。即无所生。无生即灭。谓无明灭即行灭。行灭即识灭。识灭即名色灭。名色灭即六处灭。六处灭即触灭。触灭即受灭。受灭即爱灭。爱灭即取灭。取灭即有灭。有灭即生灭。生灭即老死忧悲苦恼灭如是即一大苦蕴灭。然于是中无有少法若生若灭而实可得。何以故。一切法缘生故。无主宰无作者无受者。因缘所转。是故此中无法可转。亦非无转亦非随转。无实所生三界施设。从烦恼转。从苦所转故有施设。一切皆是无实所生。若于此中如实观察。即无有少法而为作者。若无作者即无所作。于胜义谛中都无所得。如是所说无法可转。亦非无转。菩萨摩诃萨于如是等甚深之法闻已信解不生疑悔。入一切法无碍智门。是故不着色受想行识。不着眼耳鼻舌身意色声香味触法。不着眼界色界眼识界乃至意界法界意识界。如是信解一切法自性皆空。舍利子。菩萨若住如是信解即不减失。常见诸佛亦不减失。常闻正法复不减失。常承事众。世世所生不离见佛不离闻法不离承事清净之众。现前值遇诸佛出世。在在所生发大精进勤求善法。所发精进不为无义利事。谓舍宅居止无义利事。妻子眷属财宝受用。及奴婢等无义利事。及余一切欲乐游戏取着过失无义利事。善能弃舍。于佛如来正法之中净信出家。以彼清净出家心故。近善知识而常不坏。思惟善法得善意乐。所闻善法真实修行。不著文字所成胜慧。深心具足乐法无厌。勤求多闻如所闻法。为他广说无爱着心。不为悕求名闻利养。为他说法不背自语。为他说法如其所闻如其所住一一随应为他广说。如所闻法。起大慈心。不越一切众生大悲之心。为多闻故不惜身命。少欲喜足乐寂静处。离诸愦闹善能资养。随所闻法善观察义。摄受正义不着于文。随所摄受。于一切世间天人阿修罗众中。不独行于自利益事。但为勤求无上大乘。利乐一切众生。所谓佛智无等等智。一切三界最胜智。于他所作而不放逸

佛说大乘菩萨藏正法经卷第六佛说大乘菩萨藏正法经卷第七

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    菩萨观察品第三之余

复次佛告舍利子言。云何名为不放逸法。所谓常当摄护诸根。云何名为摄护诸根。谓眼见色已不执其相。亦复不执随形妙好。亦不爱箸色等诸味。如实了知出离之法。如是耳闻其声。鼻嗅其香。舌了其味。身觉其触。意知其法。皆不执相。亦复不执随形妙好。亦不爱箸诸法等味。如实了知出离之法。如是所说名不放逸

又舍利子。不放逸者。谓自调心已善护他心。去除烦恼现证法乐。无所伺察。欲寻嗔寻害寻无所伺察。贪不善根嗔不善根痴不善根无所伺察。身业恶行语业恶行意业恶行。无所伺察。不深固作意。无所伺察。总略乃至一切罪业不善诸法。皆无伺察。如是所说名不放逸

又舍利子不放逸。菩萨深固作意勤行相应。若法是有如实知有。若法是无如实知无。云何是有。云何是无。所谓正道勤行能生信解即有。邪道勤行能生信解即无。诸业有报即有。诸业无报即无。眼即是有。彼眼实性即无。耳鼻舌身意即是有。耳鼻舌身意实性即无。色是无常是苦。是不究竟。是不坚牢。是散坏法即有。计色是常是乐。是究竟是坚牢。是不散坏法即无。受想行识。是无常是苦。是不究竟。是不坚牢。是散坏法即有。计受想行识。是常是乐。是究竟是坚牢。是不散坏法即无

复次无明缘行等诸法中。不实无明缘行。乃至生缘老死即有。定实无明缘行。乃至生缘老死即无。行布施者能感大富即有。行布施者返招贫匮即无。持戒生天即有。破戒生天即无。多闻大慧即有。愚痴大慧即无。修习相应即有。修习不相应即无。深固作意相应即有。不深固作意相应即无。发勤精进菩萨得菩提果即有。懈怠菩萨得菩提果即无。无增上慢人作出家事即有。增上慢人证涅槃即无。于一切处通达空性即有。计执我人众生寿者即无

复次舍利子。是故当知。不放逸菩萨。能深固作意勤行相应。即普遍世间。有诸智者广为开示。普遍世间。若无智者即不能开示。于世俗谛。不知其有。不知其无。何能随顺诸佛世尊所说实义。舍利子。诸佛如来总略以其四种法印。摄一切法。何等为四。一者诸行无常。二者诸行是苦。三者诸法无我。四者涅槃寂静。而一切众生于诸行无常中。计有常想。若诸众生断除常想。此即是为如来所说。又诸众生于诸行苦中。计为乐想。若诸众生断除乐想。此即是为如来所说。又诸众生于一切法无我中。计为我想。若诸众生断除我想。此即是为如来所说。又诸众生于涅槃寂静理中。起有所得颠倒之心。若诸众生断除有所得颠倒心者。此即是为如来所说。又舍利子。若能了知诸行无常。即能解入空无常性。若能了知诸行是苦。即能离诸愿求。若能了知诸法无我。即能观想空三摩地解脱法门。若能了知涅槃寂静。即能于诸相中有所修作。亦不非时取证实际。舍利子。如是等法。若诸菩萨勤行相应。即不减失一切善法。速能圆满一切佛法

    如来不思议品弟四之一

尔时佛告舍利子言。信心住菩萨。于佛如来应供正等正觉十种不思议法中。信解清净超越分别。离诸疑悔。后复生起身喜心喜适悦之相。发希有想。何等为十。一者于佛如来最胜身相不可思议。信解清净乃至适悦之相发希有想。二者于佛如来妙好音声不可思议。信解清净乃至发希有想。三者于佛如来最上大智不可思议。信解清净乃至发希有想。四者于佛如来微妙光明不可思议。信解清净乃至发希有想。五者于佛如来圆满戒定不可思议。信解清净乃至发希有想。六者于佛如来广大神足不可思议。信解清净乃至发希有想。七者于佛如来十种智力不可思议。信解清净乃至发希有想。八者于佛如来四无所畏不可思议。信解清净乃至发希有想。九者于佛如来大悲之心不可思议。信解清净乃至发希有想。十者于佛如来不共佛法不可思议。信解清净乃至发希有想。如是十种如来应供正等正觉不可思议希有之法。住信菩萨精进勤求。不怖不懈心无动转。乃至身肉皮骨筋脉血髓干枯焦瘁。若未能得如来十种不思议法。于其中间不生疲倦。精进勤求必当获得。舍利子。住信菩萨于佛如来如是十种不思议法。应当如是信解清净。乃至发希有想

尔时世尊。重明斯义说伽陀曰

  如来身相不思议　　应观微妙净法身
  无相亦无对碍门　　菩萨能生于信解
  乃至诸趣广分别　　音声惟佛不思议
  于一切处宝法门　　应当信解佛境界
  所有一切众生类　　上中下根有差别
  惟佛胜智普能知　　信解智力不思议
  诸佛无边大光明　　净光明网不思议
  广大照曜于十法　　无边刹海皆洞彻
  牟尼出世净妙戒　　而不依止世间法
  住信菩萨净信心　　信佛神足不思议
  诸佛神通境界门　　而诸菩萨不能知
  诸佛常住等引心　　佛解脱门不思议
  法界广大无分别　　惟佛胜力悉能知
  具足智力大仙尊　　无边无际虚空等
  假使一切众生类　　互发问端辞犹海
  随问遍答生喜心　　如来无畏不思议
  为一众生作利益　　无边众生亦复然
  普令安住调伏心　　如来大悲不思议
  如来诸相皆具足　　而能觉了一切法
  不共佛法功德门　　于一切处智显示
  如是十种不思议　　摄诸佛法入法性
  若能遍起信解心　　菩萨善住于净信

复次舍利子。云何名为住信菩萨于佛如来最胜身相。信解清净乃至发希有想。谓佛如来其身清净。于彼一切不善法中。普能除断。复于一切善法之中。皆悉具足。如来身者。已离一切不净秽恶筋骨血肉流散漏失诸染污法。如来身者。自性明亮清净莹洁。永离一切烦恼垢染。超出世间。不为一切世法所染。如来身者。积集无量福智妙行。长养众生。修习无量戒定慧解脱解脱知见等诸善法。严具一切胜功德花。如大圆镜现众色像。复如清净水月影现。又如来身者。如虚空界普摄一切。复如法界最上最胜。佛身无漏诸漏已尽。佛身无为不堕诸数。如虚空身。无等等身。一切三界量胜之身。又如来身者。不可喻身。无所喻身。清净无垢离诸染污。自性光明非先际可观。非后际可观。非现在可观。非种族可观。非色可观。非相可观。非随形妙好可观。非心可观非意可观。非识可观。非见可观。非闻可观。非念可观。非表了可观。非蕴可观。非处可观。非界可观。非生可观。非住可观。非灭可观。非取可观。非舍可观。非出离可观。非行可观。非显色可观。非状貌可观。非形色可观。非来可观。非去可观。非戒可观。非定可观。非慧可观。非解脱可观。非解脱知见可观。非有相可观。非离相可观。非法相可观。非诸相成办可观。非无所畏可观。非无碍解可观。非神通可观。非大悲可观。非不共佛法成办可观。诸佛出现如幻如焰如水中月。自性妙身。空无相无愿无际岸身。无种类身。无积聚身。无分别身。无依止身。无别异身。已得善住不动转身。无色非色自性身。无受非受无想非想无行非行无识非识自性身。无实无生非大种身。未曾有未曾有业身。非眼所生不从色中出。亦非在外。非耳依止不从声中出。亦非在外。非鼻所嗅不从香中出亦非在外。非舌了别不从味中出。亦非在外。非身和合不从触中出。亦非在外。非心所转。非意所转。非识所转。亦非不转亦非随转。得安住无动等虚空身。法界最上混入虚空界。舍利子。如是等法。住信菩萨。能于如来不可思议净妙身相。信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义。说伽陀曰

  无量俱胝那庾多　　历劫广修菩萨行
  身业三种善净中　　勤求无等善逝身
  十方世界起慈意　　广以身命行布施
  常离欲邪行染心　　勤求无上虚空身
  清净微妙上衣饰　　无量劫中行布施
  施波罗蜜妙行圆　　广施最上诸佛子
  牦牛爱尾犹护戒　　能舍身命忍无怨
  愿求佛身无懈心　　广修精进波罗蜜
  乐观诸佛定境界　　内心乐起慧方便
  法界最上善逝身　　愿我如是当获得
  诸佛善行广作已　　得菩提果人中上
  当获广大虚空身　　善离尘染净无垢
  离我人相自性空　　无相无言无所得
  出过诸眼境界门　　大牟尼身如是得
  离色离声意清净　　无生无作本来空
  当得如来无动身　　十力善逝亦如是
  如幻化出种种身　　诸象马等及人相
  愚痴虚妄颠倒心　　佛十力尊色相见
  过去无量诸善逝　　未来诸佛亦复然
  同一无等法性身　　法界最上虚空等

舍利子。彼住信菩萨。于如是等诸佛如来最胜身相不可思议。信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

复次舍利子。云何名为住信菩萨。于佛如来妙好音声不可思议。信解清净乃至发希有想。舍利子。谓佛如来于彼一切众会之中。所出音声皆为调伏。随顺作诸善利。所有十方世界一切众生。普遍意乐悉令生喜。然佛如来不作是念。我能为此苾刍众会宣说诸法。为此苾刍尼众会。优婆塞优婆夷。婆罗门刹帝利。长者居士梵众会等。为其说法。又佛如来随宜宣说契经讽颂记别应颂自说譬喻缘起本事本生方广希法论议。如是等法。普为一切众会乃至梵众。如应宣说。所有上中下根。种种差别诸众生类。悉闻法句。而彼法句。皆从如来口门而出。随诸根性各得解了。于其中间亦无语言互相违碍。各各于法明了知解。此即如来宿福果报现转妙音。令诸众生随转解入

又舍利子。如来声者。所出细滑悦意可乐。清净无垢美妙乐闻。复善明了不粗不恶。闻者身喜心无厌倦。闻者心喜喜乐随生。分明解了咸生爱乐。心意调适如师子音声。云雷音声。海潮音声。迦陵频伽微妙音声。清梵音声。太鼓音声。吉祥音声。柔软音声。振响音声。令彼众生诸根适悦净妙音声。一切众会忻乐音声。诸相具足最胜音声。诸佛如来若此若彼。皆悉具足无量功德清净音声。舍利子。此如是等。是为住信菩萨于佛如来妙好音声不可思议信解清净乃至发希有想

尔时世尊。重明斯义。说伽陀曰

  如来梵音妙声相　　所出音声善调伏
  梵众不及佛音声　　如是诸法皆具足
  佛声能与慈相应　　广大悲心复高胜
  喜舍相应亦复然　　牟尼圣尊妙音出
  闻声能息众生类　　贪火嗔毒诸不善
  愚痴暗冥亦消除　　如是音声皆具足
  种种方处诸人众　　普遍一切人类中
  乃至极此阎浮提　　种种语言佛善了
  众生随闻佛音声　　地居空居诸天众
  得闻牟尼妙音声　　随佛音声能解入
  二足四足及多足　　无足等类闻佛声
  随触随闻寂意生　　彼一切处随声转
  三千大千世界中　　开明调伏众生类
  普摄上中下诸根　　随佛音声而善转
  应调伏者闻解脱　　离诸分别非分别
  等引心说圣谛门　　是中无执亦无缚
  无边众生闻佛声　　闻已息除诸烦恼
  志诚归命佛法僧　　闻已戒忍皆具足
  如来最上妙音声　　是声深广无边量
  音声无边智无边　　菩萨智信无疑悔

佛说大乘菩萨藏正法经卷第七佛说大乘菩萨藏正法经卷第八

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    如来不思议品弟四之二

复次舍利子。云何名为住信菩萨于佛如来最上大智不可思议。信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想。舍利子。诸佛如来以无碍知见转一切法

复次舍利子。我今为汝譬喻宣说发明如来智波罗蜜多。令彼住信菩萨。信解清净乃至发希有想。舍利子。譬如殑伽沙等诸世界中。一切草木枝叶茎干。总取为四指分量。中或有人摄聚一处。聚一处已用火焚之。焚已一切悉成灰烬。散掷于彼殑伽沙数一切世界大海之中。其灰在海经百千岁分布。而有如来智力圆满具足。能于彼彼大海之中。取彼彼灰。分布于彼一切世界。谓若干灰。若干世界。若干根本。若干蕴聚。若干枝叶。悉布在于若干方处。而无减失。何以故。诸佛如来。于法界中善觉了故。以其觉了而悉能知。如是若干一切世界广大所作。如来应供正等正觉。具大威德有大神通广大名称世间若有诸善男子善女人等。于佛如来最上大智。信解清净离分别者。皆是如来慈心建立。现证一切善根边际。而复作尽诸苦边际。何以故。诸佛如来于法界中善觉了故。若有能于佛如来所发生一念信解心者。所获功德而不坏失

又舍利子。我今复说譬喻显明斯义。或有智人于我喻说而能解了。譬如有人寿限百岁。或于一时取以一毛端量一渧之水。析作百分持诣佛所。作是白言。世尊。我今持此水渧寄置佛所。后复来取。佛当与我。佛即受之。以其水渧置在殑伽河中。随流泛溢次弟入于大海之中。尔时彼人过百岁已。来诣佛所作是白言。世尊。我昔以水渧寄佛所。愿佛今时还当授我。舍利子。如来应供正等正觉最上大智圆满具足。即于大海之中。取彼先寄一毛端量析百分者一渧之水。授与彼人。其一渧水。不为海水损触坏失。舍利子。我所说喻表示分明。况复有人能见是义。如是水渧经久时中。以如来智力而不能坏。如来应供正等正觉。亦复如是。若善男子善女人。能于如来如是大智。信解清净离分别者。皆是如来慈心建立。缘佛功德空中雨华。现证一切善根边际。而复作尽诸苦边际。何以故。诸佛如来于法界中善觉了故。若有能于佛如来所发生一念信解心者。所获功德而不坏失

尔时尊者舍利子白佛言。世尊。诸佛如来离如来智能转诸法不。佛言。不也舍利子。是时舍利子复白佛言。当何名为智。何名为识。舍利子。当知识者住于四处。一者识随色住色缘色住。而常亲近。增长坚牢广大所成。二者识随受住受缘受住。而常亲近。增长坚牢广大所成。三者识随想住想缘想住。而常亲近。增长坚牢广大所成。四者识随行住行缘行住。而常亲近。增长坚牢广大所成。此说名识。何名为智。谓住五取蕴中智蕴了知。此说名智。若复地界水界火界风界空界。识各了知住于识界。此说名识。若复识于法界有所分别。此说名智。若复眼所了知色中施设。耳所了知声中施设。鼻所了知香中施设。舌所了知味中施设。身所了知触中施设。意所了知法中施设。此说名识。若复内心寂静外无所行。以智收摄。无有少法而可分别。亦不离分别。此说名智。若复所缘识生。作意识生。分别识生。此说名识。若复无所执。无所取。无所缘。无表了。此说名智。若复有为所行法中识有所住。识于有为中行。此说名识。若于无为法中无识可行。若无为智即说名智。若是识于生住灭法中。了别无生无灭无住。此说名识。舍利子。于如是等诸法之中。如是名识。如是名智。是故当知如来大智不可思议。住信菩萨信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义。说伽陀曰

  所有殑伽沙数等　　十方世界诸草木
  若人焚爇悉成灰　　置大海中百千岁
  佛十力尊微妙智　　后复能取海中灰
  若干根种及诸方　　而悉分布无减失
  心持十方众生界　　贪嗔痴行悉了知
  一切意乐及所行　　无增无减皆悟解
  大智十力世间尊　　十方乃至遍法界
  调御不生分别心　　一切佛子皆信解

复次舍利子。云何名为如来微妙光明不可思议。住信菩萨信解清净超越分别离诸疑悔后复生起身喜心喜适悦之相。发希有想。谓佛如来应供正等正觉。于法界中善能觉了。所有光明广大微妙。而此三千大千世界。总摄一切。普遍光明炎赫照曜。如无云覆翳日光高出。如来应供正等正觉。亦复如是。于此三千大千世界。广大光明炎赫照曜。映蔽大地所有一切星宿山石药木灯光及大火聚。超出最胜广大微妙明焰炽盛。至于日月光明。及四大王天。所化宫殿。身庄严具等诸光明。三十三天夜摩天兜率天化乐天他化自在天。所化宫殿。身庄严具等诸光明。彼梵众天梵辅天梵会天大梵天所化宫殿。身庄严具等诸光明。超出最胜广大微妙明焰炽盛。彼少光天无量光天光音天。少净天无量净天遍净天。无云天福生天广果天无想天无烦天无热天善见天善现天色究竟天。所化宫殿。身庄严具诸光明中。如来应供正等正觉清净光明。超出最胜广大微妙明焰炽盛。何以故。如来圆满广大无量戒定慧解脱解脱知见故。舍利子。若此三千大千世界。一切光明施设表示。比佛如来所有光明。百分不及一。乃至乌波尼杀昙分皆不及一。譬如世间常等真金。置于阎浮檀金聚中。而彼常金无有光明。亦不炎赫不能照曜。而此三千大千世界。所有一切光明施设表示。于佛如来最上光中。悉无光明炎赫照曜。如来光者。无有过上广大最胜。亦无分限。极善业报现前随转。于此三千大千世界之中。广大照曜。不以日月昼夜时分所照为明。如来悲愍世间一切众生。普令安住净圆光中。如来应供正等正觉。乃于阿僧祇世界之中。广大照曜。何以故。如来已得最上波罗蜜多及般若波罗蜜多故

舍利子。我今复说譬喻以明斯义。譬如有人取此三千大千世界大地诸土。尽末为尘持诣东方。过一世界下一尘点。第二世界复下一点。如是乃至南西北方。各各世界悉下尘点。舍利子。于汝意云何。而彼尘末于诸世界尽边际不。舍利子言。不也世尊。不也善逝。佛言。舍利子。如来应供正等正觉。亦复如是。于彼一切世界之中。以净光明广大照曜。而诸光明比佛光明。百分不及一。乃至乌波尼杀昙分。皆不及一。何以故。如来应供正等正觉。已得最上波罗蜜多及般若波罗蜜多故

又舍利子。大地所有草木树林铁围诸山。乃至须弥山王。皆是如来大光明力所任持故乃于三千大千世界。广大照曜。然其下劣众生不能信解。或有众生。不能瞻见如来圆光。或有众生。于圆光中广大瞻睹。或有一俱卢舍见佛光者。或有一由旬内见佛光者。或有三千大千世界之内见佛光者。又舍利子。如来光明何人能于百千世界悉瞻睹者。谓诸登地菩萨。能于无边一切世界见佛光明。如来悲愍一切众生。尽虚空界及众生界。以净光明普遍照曜。彼住信菩萨闻是说已。信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义。说伽陀曰

  所有日月诸光明　　帝释梵王光明等
  乃至色究竟天光　　而悉不及佛光相
  色究竟天等诸光　　乃至三千大千界
  比佛一毛孔中光　　十六分中不及一
  虚空光明为广大　　众生广大亦复然
  若睹如来净光明　　无边无际虚空等
  应化度者见佛光　　不比世间生盲类
  彼不能见日光明　　返谓日光无所有
  下劣众生亦如是　　佛以光明常照曜
  自不能睹净光明　　返谓佛光无所有
  诸有见佛圆光者　　或俱卢舍或由旬
  或复三千世界中　　而能睹佛光明相
  八地九地及十地　　已登地位诸菩萨
  悉能安住大地中　　睹佛光明具大慧
  菩萨趣向佛大慧　　依止无边光明轮
  作诸佛事利众生　　诸佛刹土不思议
  诸佛如来不思议　　不思议光亦复然
  不思议开净信心　　诸福蕴门不思议

复次舍利子。云何名为如来圆满戒定不可思议。住信菩萨信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想。舍利子。如来正实之语作如是说。世间所生一切众生。若净戒蕴清净身业。清净语业。清净意业。而诸众生于世间生。于世间老。不染世法。得婆罗门离罪之法。复得沙门寂静观想三摩地法。当得最上波罗蜜多。如来又以正实之语作如是说。我不见有世间一切若魔若梵。若沙门婆罗门。天人阿修罗等。而能清净戒蕴定蕴。同佛如来无量清净戒定蕴者。何以故。如来应供正等正觉。已得最上波罗蜜多。已得戒定波罗蜜多

舍利子。我今复说譬喻以明斯义。可乐闻不。舍利子白佛言。世尊。今正是时愿佛为说。若诸苾刍得闻如来清净戒定。波罗蜜多法者。随所闻已信奉受持

佛说大乘菩萨藏正法经卷第八佛说大乘菩萨藏正法经卷第九

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    如来不思议品弟四之三

复次佛告舍利子言。于汝意云何。地界与众生界孰为多邪。舍利子白佛言。世尊。地界非多众生界多。佛言。舍利子。如是如是。众生界多。舍利子。假使三千大千世界。所有一切众生若卵生若胎生。若湿生若化生。若有色若无色。若有想若无想。若非有想非无想。乃至普及诸有情界。于一刹那一腊缚一须臾顷。无前无后。悉得人身。即彼如上得人身者一切众生于一刹那一腊缚一须臾顷。悉证阿耨多罗三藐三菩提果。即彼一切所成诸佛如来。一一如来现前所化各有千头。而一一头各有千面。其一一面各有千舌。是诸如来。具足如来十力四无所畏四无碍解无碍辩才。舍利子。而彼如来。同共称赞如来所有戒波罗蜜多及戒蕴功德。经俱胝那庾多劫。而悉不能得其边际。又舍利子。一佛如来戒蕴功德无有边际。如是诸佛如来戒蕴功德。无上大慧解入辩才。乃至入大涅盘。于其中间皆悉同等。何以故。于无性中起有性思议。是故如来戒蕴功德无上大慧最胜辩才。无量无数无有边际与虚空等。舍利子。且置如上所说一三千大千世界。乃至东西南北四维上下。普遍十方殑伽沙数等诸世界。一切众生于一刹那一腊缚一须臾顷。悉得人身。乃至悉证阿耨多罗三藐三菩提果。总略广说。乃至于无性中起有性思议。是故如来戒蕴功德无上大慧最胜辩才。无量无数无有边际与虚空等。何以故。如来已得最上波罗蜜多。圆满清净戒波罗蜜多故

复次舍利子。我今复以显明事相。宣说如来定波罗蜜多。汝乐闻不。舍利子白佛言。世尊。今正是时愿佛为说。令诸苾刍闻所说已信奉受持。佛言。舍利子。后时后分当有七日出现世间。于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。具有十种希有之法现彼地方。何等为十。一者地平如掌。是为第一希有之法。二者于彼时中。三千大千世界。炎炽遍炎炽。极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。悉无荆棘涌出金宝。是为第二希有之法。三者于彼三千大千世界炎炽遍炎炽极遍炎炽。都一焰聚。彼时如来若行若住若坐若卧。其地广阔如来受用。是为第三希有之法。四者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。自生异草青润柔软右旋宛转。如迦唧邻那宝。复有妙香。是为第四希有之法。五者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。自然涌出八功德水。所谓一冷二轻三软四香五美六清七饮时无厌八多饮无患。如是具足八功德水。是为第五希有之法。六者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。有清凉风自然吹触。舍利子。譬如夏月盛热之时。人极疲倦时。或有人往诣殑伽河岸。承彼清凉渐入河中。澡沐身体去除热恼。乃得轻安调畅适悦。出河在岸往复经行。其去不远见大树林。青润蓊郁枝叶扶疏。影癊清虚周匝垂覆。其中殊丽。宛如珠宝间错严饰。是人即时诣彼林所安详而坐。四面凉风散来吹触。舍利子。如来亦复如是。以宿善业果报。焕明清净凉风自然吹触。是为第六希有之法。七者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。自然而有水生诸华。所谓优钵罗华。钵讷摩华。俱母陀华。奔拏利迦华等。是为第七希有之法。八者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中自然而有陆生诸华。所谓阿帝目讫多华。瞻波迦华苏摩那华。嚩利尸迦华。阿输迦华。波吒罗华。迦兰尼迦华。多啰尼华等。如是等华色香具足。是为第八希有之法。九者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中如金刚所成。坚固牢实而无破坏。是为第九希有之法。十者于彼时中。三千大千世界。炎炽遍炎炽极遍炎炽都一焰聚。彼时如来。若行若住若坐若卧。彼地方中。见有殊妙宝塔出现。一切天人。若魔若梵。沙门婆罗门等。瞻礼供养。是为第十希有之法。舍利子。如是十种希有之法。于彼地方次第出现。以其如来应供正等正觉于法界性善觉了故。随其色相入三摩地。住等引心纯一乐受。经殑伽沙数等劫。谓如食顷。如来于三摩地无所坏失。舍利子。如来在定住。经一劫或百劫。千劫百千劫。一俱胝劫百俱胝劫。千俱胝劫百千俱胝劫。百千俱胝那庾多劫。后从定起。何以故。如来应供正等正觉。已得最上波罗蜜多故。而彼最上波罗蜜多者。具大神通。有大威德。得大自在。是故如来圆满具足。舍利子。如彼非想非非想天中天子生已缘一境住。谓识所缘。经八万四千劫。而识不于余识所转。乃至寿限尽时即当趣灭。舍利子。如来始于初夜分中。证成阿耨多罗三藐三菩提果。于中夜分入大涅盘。于其中间而不坏灭三摩地法。如来在定无心可转。无心所行。无心伺察。无心遍行。无心可增。无心可减。无心散乱。无心可高。无心可下。无心摄护。无心隐密。无心随顺。无心违背。无心沉下。无心动转。无心喜悦。无心爱箸。无心分别。无心离分别。无心计度。无心随识流转。无心依止眼耳鼻舌身意。无心依止色声香味触法。无心于彼法中行。无心于彼智中行。无心于彼过去观察。无心于彼未来观察。无心于彼现在观察。如来应供正等正觉。如是安住三摩地中。心无少法而可生起。然于一切法中。以无碍知见。而常随转都无发悟。如来离心意识。于定分位亦不减失。复常施作一切佛事。然无发悟

尔时世尊。重明斯义。说伽陀曰

  佛于无量百千劫　　遍三有中修道行
  戒闻定忍无散心　　圆成无上菩提果
  佛善业果报如是　　超胜世间戒清净
  无戏论垢净如空　　十力净戒虚空等
  佛于初夜成正觉　　后于中夜入涅盘
  佛无心行无遍行　　于诸寂定无减失
  十力戒蕴亦无减　　神力解脱分亦然
  百千劫中住一心　　佛无分别离分别
  佛于如空定境界　　三义转佛无碍智
  心意伺察不遣除　　佛子信解佛十力

舍利子。如是等法。住信菩萨应于如来戒定法中。信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

复次舍利子。云何名为住信菩萨于佛如来神足通力信解清净乃至发希有想。舍利子。如来应供正等正觉。常所宣说。尊者大目干连于声闻苾刍众中神通第一。于彼菩萨众中。若以声闻神通同等较量。我不见有声闻神通与菩萨等者。若以菩萨神通与佛神通同等较量。我不见有菩萨神通与如来神通而相等者。彼诸菩萨常作是念。如来神通不可思议。我等发勤精进。愿求成办如来神力。复次舍利子。我今复以喻说。发明如来神通智力。汝乐闻不。舍利子白佛言。世尊。今正是时愿佛为说。令诸苾刍闻所说已信奉受持。佛言。舍利子。于汝意云何。大目干连有大神通邪。舍利子白佛言。世尊。我亲闻佛说亲所听受。大目干连于声闻苾刍众中神通第一佛言。舍利子。假使三千大千世界满中。一切声闻彼彼神力。皆与大目干连神力同等。犹如稻麻竹[竺-二+韋]甘蔗丛林。如是同等如是色相。所有一切声闻功德威势精进力。能神通变化随所表示。比佛如来。百分不及一。千分不及一。百千分不及一。一俱胝分不及一。百俱胝分不及一。千俱胝分不及一。百千俱胝分不及一。算分数分及譬喻分。乃至乌波尼杀昙分。皆不及一。何以故。如来应供正等正觉。已得最上波罗蜜多故。舍利子。如来以神通力。于此地中置一芥子。以佛如来加持力故。彼诸声闻一切威势神通力能而悉不能举彼芥子。复不能动一毛端量。何以故。如来应供正等正觉。已得最上波罗蜜多及神通波罗蜜多故。舍利子。且置上说。此三千大千世界。乃至东西南北四维上下。普遍十方殑伽沙等一切世界。所有一切众生之类。若卵生若胎生若湿生若化生。若有色若无色。若有想若无想。若非有想非无想。彼诸众生。一时皆得声闻之果具大神通。悉如大目干连。彼诸声闻同以威势力能神通变化。而悉不能举动芥子一毛端量。何以故。如来应供正等正觉。已得最上波罗蜜多及神通波罗蜜多故。具大威德。有大神通。得大自在。尔时世尊。复告尊者舍利子言。汝昔曾闻。风灾劫时有大风起。名毗蓝婆。振吼吹击此三千大千世界。须弥山王。铁围诸山。大铁围山等。及四大洲。至八万洲。彼彼大海吹鼓高起。流散周遍一由旬量。舍利子白佛言。世尊。我昔亲闻如来宣说如是等事。佛言。舍利子。风灾劫时大风吹击此三千大千世界。须弥山王。及诸山大海。吹鼓高起破坏流散周遍一切。乃至无数百千由旬分量。地居诸天。亦悉飘鼓流散周遍。尘尚不见。况山石等。所有夜摩天中诸宫殿等。飘鼓破坏流散周遍。尘尚不见。何况宫殿。彼兜率天化乐天他化自在天。梵众天梵辅天梵会天大梵天少光天无量光天光音天。少净天无量净天遍净天。如是等天诸宫殿等。飘鼓破坏流散周遍。尘尚不见。何况宫殿。舍利子。如是大风飘鼓吹击。尔时如来。所有妙衣不能损动一毛端量。况复衣角。所以者何。以佛如来不思议神力不思议缘不思议所行不思议大悲悉具足故。舍利子。当彼大风飘鼓之时。东西南北四维上下。周遍十方殑伽沙等。一切世界大风不止。是时如来。举以指端指大风轮。即时大风皆悉止息。此是如来神通智力。无所减失不思议故。舍利子。彼住信菩萨应于如来神通智力信解清净超越分别离诸疑悔。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义。说伽陀曰

  所有三界诸众生　　皆作声闻具智慧
  与大目连智皆同　　悉具神通波罗蜜
  如来于此地方中　　置一芥子极微小
  彼彼一切现神通　　而悉不能为举动
  所有殑伽沙数等　　十方一切世界中
  毗蓝婆风振击时　　普遍诸方皆吹鼓
  当彼如是大风起　　佛上妙衣悉举示
  不能动其一毛端　　由佛神力不思议
  大风吹击极猛恶　　牟尼举一毛端量
  神力能止大风轮　　无边广大虚空等

舍利子。住信菩萨应于如来如是神力。信解清净乃至发希有想

佛说大乘菩萨藏正法经卷第九佛说大乘菩萨藏正法经卷第十

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来不思议品第四之四

复次舍利子。住信菩萨于佛如来十种智力不可思议。闻已净信超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想。如来以具十智力故了知胜处。于天人世间能师子吼转妙梵轮。所有一切天人魔梵悉不能转。无与如来同其法者。云何十力。一者处非处智力。二者业报智力。三者种种信解智力。四者种种界智力。五者根胜劣智力。六者至处道智力。七者禅定解脱等持等至染净智力。八者宿住随念作证智力。九者天眼作证智力。十者漏尽作证智力。舍利子。如是名为如来十种智力。如来以具十智力故了知胜处。于大众中能师子吼转妙梵轮。乃至一切世间无与如来同其法者

云何如来处非处智力。谓佛如来以其无上最胜智力。于处非处如实了知。何者是处。何者非处。舍利子。所言非处者。谓不容受。身作恶者。语作恶者。意作恶者。能感悦意光泽可爱果报。若如此者无有是处。而或可容受者。谓身语意造作诸恶。不能招感悦意光泽可爱果报。斯有是处。又非处者。谓身语意业造作诸善。而能招感不悦意光泽可爱果报。无有是处。可容受者。谓身语意造作诸善。而能招感悦意光泽可爱果报。斯有是处。又非处者。谓悭吝人感大富果。无有是处。若悭吝人感贫穷果。斯有是处。又非处者。谓行施人感贫穷果。无有是处。若行施人感大富果。斯有是处。又非处者。谓破戒人得生天人。无有是处。若破戒人当堕地狱饿鬼傍生趣中。斯有是处。又非处者。谓持戒人返堕地狱饿鬼傍生趣中。无有是处。若持戒人生天人中。斯有是处。又非处者。谓嗔恚人感端正果。无有是处。若嗔恚人感丑陋果。斯有是处。又非处者。谓忍辱人感丑陋果。无有是处。若忍辱人感端正果。斯有是处。又非处者。谓懈怠人而能获得现前三昧。无有是处。若懈怠人。不得现前三昧。斯有是处。又非处者。谓精进人不得现前三昧。无有是处。若精进人而能获得现前三昧。斯有是处。又非处者。谓散乱心人得出离道。无有是处。若散乱心人不能获得出离之道。斯有是处。又非处者。谓能安住心一境性之人。不能获得彼出离道。无有是处。若能安住心一境性之人得出离道。斯有是处。又非处者。谓无慧人而能除断一切种子习气。无有是处。若无慧人不能除断一切种子习气。斯有是处。又非处者。谓有慧人不能除断一切种子习气。无有是处。若有慧人能断一切种子习气。斯有是处。又非处者。谓杀生人起杀害因感长寿果。无有是处。若杀生人感短寿果。斯有是处。又非处者。谓离杀生之人感短寿果。无有是处。若离杀生之人感长寿果。斯有是处。又非处者。谓偷盗之人感大富果。无有是处。若偷盗之人感贫穷果。斯有是处。又非处者谓离偷盗之人感贫穷果。无有是处。若离偷盗人感大富果。斯有是处。又非处者。谓邪染之人得有子妻室。无有是处。若邪染之人不得有子妻室。斯有是处。又非处者。谓离邪染人不得有子妻室。无有是处。若离邪染之人得有子妻室。斯有是处。又非处者。谓妄语之人不招毁谤。无有是处。招其谤者斯有是处。又非处者。谓离妄语之人返招毁谤。无有是处。不招谤者斯有是处。又非处者。谓两舌之人眷属不离。无有是处。若眷属分离。斯有是处。又非处者。谓离两舌之人眷属分离。无有是处。若眷属不离。斯有是处。又非处者。谓恶口之人常闻悦意语言。无有是处。若其不闻悦意语言。斯有是处。又非处者。谓离恶口之人不闻悦意语言。无有是处。若其闻者斯有是处。又非处者。谓绮语之人得决定辩才。无有是处。若其不得斯有是处。又非处者。谓离绮语之人不得决定辩才。无有是处。若其得者斯有是处。又非处者谓多贪人得大富者。无有是处。若其不得斯有是处。又非处者。谓离贪人大富断续。无有是处。若不断续斯有是处。又非处者。谓嗔恚心人不堕地狱。无有是处。若其堕者斯有是处。又非处者。谓离嗔人不于善趣天界中生。无有是处。若其生者斯有是处。又非处者。谓邪见人积集邪见之因能得圣道。无有是处。若邪见人积集邪见之因不得圣道。斯有是处。又非处者。谓正见人积集正见因故不得圣道。无有是处。若正见人积集正见因故获得圣道。斯有是处。又非处者。谓修施行之人若不得净心分位。无有是处。若其得者斯有是处。又非处者。谓持净戒人。不得净心分位无有是处。若其得者。斯有是处。又非处者。若起有所得见之人获顺忍者。无有是处。若其不得斯有是处。又非处者。若证空解脱人不得顺忍者。无有是处。若其得者斯有是处。又非处者。谓恶作之人得住轻安心者。无有是处。若其不得斯有是处。又非处者。谓恶作之人。得心调伏及轻安者。无有是处。若其不得斯有是处。又非处者。若诸女人成转轮圣王。无有是处。若男子得成斯有是处。又非处者。若诸女人成帝释天主。无有是处。若男子得成斯有是处。又非处者。若诸女人成梵王者。无有是处。若男子得成。斯有是处。又非处者。若诸女人现成佛果者。无有是处。若八人地次第得果。斯有是处。又非处者。谓须陀洹人。现转证成第八位者。无有是处。若于此蕴中趣涅盘者。斯有是处。又非处者。若斯陀含人。现转第三位者。无有是处。若于此蕴中趣涅槃者。斯有是处。又非处者。若阿那含人还来人间。无有是处于此蕴中趣涅盘者。斯有是处。又非处者。若阿罗汉人有结习者。无有是处。若其无者斯有是处。又非处者谓诸圣人。趣求异类师尊教授。异义所生法者。无有是处。若不然者斯有是处。又非处者。若得无生法忍之人有退转者。无有是处。乃至得证菩提。斯有是处。又非处者。若诸菩萨坐菩提场已。而不证成菩提果者。无有是处。若诸菩萨坐菩提场已。决定证成阿耨多罗三藐三菩提果。然后起座。斯有是处。又非处者。谓诸佛如来于种子习气有所表现者。无有是处。若佛如来所有一切种子习气悉能除断。斯有是处。又非处者。谓佛如来智有障碍。无有是处。若佛如来智无障碍。斯有是处。又非处者。谓能观见诸佛如来最胜顶相。无有是处。若不能见佛顶相者。斯有是处。又非处者。谓能知佛心所行者。无有是处。若不能知诸佛如来心所行者。斯有是处。又非处者。谓佛如来住等引心有所得相者。无有是处。若佛如来常住等引心者。斯有是处。又非处者。若谓如来语言虚妄不决定者。无有是处。若佛如来言无虚妄。斯有是处。又非处者。若谓如来有其过失。无有是处。诸佛如来离诸过失。斯有是处

舍利子。如是等法。如四无所畏十八不共法中广说

复次舍利子。若谓诸佛如来于现在世中若知若见有障碍者。无有是处。若诸佛如来于现在世中。若知若见。无障碍者。斯有是处。舍利子。如是所说。如来所有处非处智力无有边际。若欲知其边际之者。譬如虚空。所可知耶。若其虚空不知边际。如来应供正等正觉处非处智力边际亦然。诸住信菩萨得闻如来不可思议处非处智力。已发生净信超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义说伽陀曰

  十方虚空无边量　　处非处智力亦然
  智力真实遍世间　　广说最上真实法
  若人圆具解脱器　　知彼所行为说法
  彼圆法器诸众生　　知处非处住舍行
  虚空大地尚可动　　佛说果报无虚妄
  处非处智若圆成　　世出世间十力具

舍利子。此是如来第一智力。如来应供正等正觉。以具如是胜智力故。了知胜处。于大众中。能师子吼转妙梵轮。乃至世间无与如来同其法者

复次舍利子。云何名为如来业报智力。谓佛如来以无上智。于过去未来现在。一切众生所作诸业。积集因处位。若身根因通眼根分位。如是诸根因及分位。如来悉如实知。若诸众生有布施根性修持戒行。如来了知自他根故。即为宣说布施之法。若诸众生有持戒根性修布施行。如来了知自他根故。即为宣说持戒之法。若诸众生有忍辱根性修精进行。如来了知自他根故。即为宣说忍辱之法。若诸众生有精进根性修忍辱行。如来了知自他根故。即为宣说精进之法。若诸众生有禅定根性修胜慧行。如来了知自他根故。即为宣说禅定之法若诸众生有胜慧根性修禅定行如来了知自他根故即为宣说胜慧之法。总略乃至诸菩提分法亦如是说。若诸众生具声闻根性。修缘觉乘行。如来了知自他根故。即为宣说声闻乘法。若诸众生具缘觉根性。修声闻乘行。如来了知自他根故。即为宣说缘觉乘法。若诸众生具大乘根性。而修声闻缘觉乘行。如来了知自他根故。即为宣说大乘之法。若诸众生具最上乘根性。修大乘行。如来了知。实了知。若诸众生。于现在世积集乐因。未来世中感其苦报。如来决定如实了知。若诸众生。于现在世积集苦因。未来世中感其苦报。如来决定如实了知。若诸众生。于现在世积集乐因。未来世中感其乐报。如来决定如实了知。舍利子。如来于过去未来现在世中。一切众生所有诸业若因若果。如来真实无异无别。决定一一如实了知。如来随所知已如其所应。皆为说法。舍利子。如来应供正等正觉。于过去未来现在。一切众生诸业果报。积集因处皆如实知。如来智力无有边际。若欲知其边际之者。譬如虚空所可知耶。若其虚空不知边际。如来应供正等正觉业报智力边际亦然。诸住信菩萨。得闻如来不可思议业报智力已。发生净信超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义说伽陀曰

  佛善了知诸因果　　业法智眼悉能观
  无碍智遍三世中　　诸众生行悉明达
  苦乐诸因及所愿　　遍诸众生五趣中
  轮转一切诸苦因　　善逝决定皆明了
  所有黑白诸业报　　因果愿求亦复然
  能仁真实悉了知　　犹观掌中如意宝
  若诸业法修因少　　当来果报获无量
  若因无量果还微　　善逝真实皆晓了
  修声闻行果如愿　　缘觉菩提因愿同
  无上智果愿亦然　　善逝如实皆晓了
  若于先业修苦因　　后复当招于乐果
  若于诸业修乐因　　后复当招于苦果
  苦因苦果如是法　　乐因乐果亦复然
  自业自果和合因　　善逝如实皆晓了
  诸有苦法三世转　　遍诸众生五趣中
  真实无断无异门　　佛无上智皆明了

舍利子。此是如来。第二智力。如来以具胜智力故。了知胜处。于大众中。能师子吼转妙梵轮。一切世间天人魔梵。皆不能转。乃至无与如来同其法者

佛说大乘菩萨藏正法经卷第十

诸果报等。皆如实知。云何了知。舍利子。谓诸如来应供正等正觉。于诸众生过去诸业。所集善因离诸不善。于未来世与其善果。如来一一如实了知。若诸众生造不善业。集不善因离诸善法。于未来世获不善果。如来一一如实了知。若诸众生积集业因。于未来世感下劣分位。如来决定如实了知。若诸众生积集业因。于现在世感殊胜分位。于未来世亦感殊胜分位。如来决定如实了知。若诸众生积集业因。于过去世起下劣行。未来世中起广大行。如来决定如实了知。若诸众生积集业因少分发起。当感广大殊胜分位。如来决定如实了知。若诸众生积集业因广大发起。当感少分殊胜分位。如来决定如实了知。若诸众生修声闻行感声闻果。如来决定如实了知。若诸众生修缘觉行感缘觉果。如来决定如实了知。若诸众生修佛智因感佛智果。如来决定如实了知。若诸众生于现在世积集苦因。未来世中感其乐报。如来决定如佛说大乘菩萨藏正法经卷第十一

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来不思议品第四之五

复次舍利子。云何名为如来种种信解智力。谓佛如来于诸众生诸补特伽罗。所有信解种种差别。如来一一如实了知。若诸众生本住贪爱。于嗔起解。广如经说。若诸众生本住着痴。于嗔起解。如来一一如实了知。若诸众生本住不善之法。于不善法起解。如来一一如实了知。若诸众生本住善法。于善法起解。如来一一如实了知。若诸众生修下劣行。于殊胜法而起信解。如来悉如实知。若诸众生修殊胜行。于下劣法而起信解。如来悉如实知。若诸众生修下劣行。于殊胜分位而起信解。如来悉如实知。若诸众生修殊胜行起下劣解。如来悉如实知。若诸众生于邪定聚。而起信解取彼定法。如来悉如实知。若诸众生于正定聚。而起信解取彼定法。如来悉如实知。若诸众生于正定聚取彼解脱。如来悉如实知。若诸众生信解欲界定法。从欲界入。如来悉如实知。若诸众生信解色界定法。从色界入。如来悉如实知。若诸众生信解无色界定法。从无色界入。如来悉如实知。若诸众生信解三界定法。遍三界入。如来悉如实知。若诸众生。本住下劣分位。而得殊胜之法。如来悉如实知。若诸众生本住殊胜分位。而得下劣之法。如来悉如实知。若诸众生起种种信解种种色相。种种受用种种领纳。如来悉如实知。若诸众生信解以先业故当感坠堕。如来悉如实知。若诸众生信解脱之法。取彼解脱。如来悉如实知。如来如是如实知已。随其所应即为说法

舍利子。此是如来信解智力。无有边际与虚空等。若诸住信菩萨。于佛如来种种信解最胜智力。闻已净信。超越分别。离诸疑惑。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义说伽陀曰

  世间种种信解法　　过未现在无限量
  即彼信解如所思　　佛人中尊皆晓了
  若于贪法起信解　　而本住着嗔分位
  若嗔若痴义亦然　　佛随信解皆明了
  住贪住痴等诸法　　随心所持难思度
  相续无间遍所行　　能仁胜智皆明了
  若诸众生下劣行　　还复信解广大法
  行胜解劣义亦然　　佛调御尊皆明了
  若众生取邪定聚　　来还所起亦复然
  所有三界解脱门　　佛随信解皆明了
  所生色相种种异　　受用差别亦复然
  随先业故报无差　　二足胜尊皆明了
  随其信解了知已　　如其所应为说法
  第三胜解智力门　　佛子当生清净信

舍利子。如是如来第三信解智力。如来应供正等正觉以具胜智力故。了知胜处。于大众中能师子吼转妙梵轮。一切世间天人魔梵悉不能转。无与如来同其法者

复次舍利子。云何如来种种界智力。谓佛如来。于种种界如实了知。若诸众生于诸世间。以诸福行而为长养。如来悉能如实了知。若诸众生以非福行而为长养。如来悉如实知。若诸众生以不动行而为长养。如来悉如实知。若诸众生修出离行。如来悉如实知。又舍利子。如来如实了知眼界色界眼识界。云何能知。谓佛了知内空外空内外空故。乃至意界法界意识界悉如实知。云何能知。谓佛了知内空外空内外空故。又舍利子。如来了知地界水界火界风界及虚空界。悉如实知。云何能知。谓如虚空故亦然了知。如来悉知欲界色界及无色界分别所起。知有为界是造作相。知无为界是无造作相。知杂染界是客尘烦恼相。知清净界是自性明亮相。知诸行界是不如理作意无明相。知涅槃界是如理作意明智相

又舍利子。若诸界依止诸界安住。诸界随顺。诸界建立。诸界作用。诸界意趣。诸界寂定。诸界住着。如来一一如实了知。随所知已即为说法。舍利子。此是如来种种界智力。如是胜力无有边际。若诸住信菩萨。于佛如来如是智力。闻已净信。超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义说伽陀曰

  一切世间诸众生　　以种种界为依止
  随转界趣义亦然　　佛无上尊皆明了
  福非福及不动行　　诸出离界义亦然
  随诸界趣安住心　　涅槃无动常寂静
  所有眼界及色界　　彼眼识界亦复然
  耳鼻舌身意界中　　如来如实皆明了
  于其法界了知已　　彼意识界亦复然
  了知诸法内外空　　此即能仁大智力
  地界水界及火界　　而彼风界亦复然
  如是诸界遍了知　　犹如虚空等无异
  所有欲界及色界　　彼无色界亦复然
  如来如是遍了知　　及彼分别所起等
  而彼虚空无边际　　诸界无边亦复然
  佛于一切虽遍知　　不起我心能了解
  了知诸界无所生　　亦知诸界无所灭
  如是诸界寂静心　　无上丈夫皆明了
  如其虚空无边际　　佛智无边亦复然
  以无碍智悉了知　　种种信解皆解脱
  知心所起信解已　　俱胝众生悉调伏
  如来第四力圆成　　佛子当生清净信

舍利子。如是如来第四智力。广说乃至无与如来同其法者

复次舍利子。云何名为如来根胜劣智力。谓诸众生所有根性若胜若劣。如来一一如实了知。云何能知。谓下根中根及彼利根。亦复遍知殊胜诸根乃至积集。分别从贪所起诸业根性。从嗔所起诸业根性。从痴所起诸业根性。如来悉如实知。如是分别诸业虚妄所起贪嗔痴等。皆如实知。如是分别诸根从贪嗔痴少分所起者。如来悉如实知。分别诸根从贪嗔痴广大所起者。亦如实知。分别诸根从贪嗔痴执着所起者。亦如实知。若善因根性。若不善因根性。若不动因根性。若出离因根性。如来悉如实知

又舍利子。如来遍知一切众生眼根耳根鼻根舌根身根意根。女根男根命根。苦根乐根忧根喜根舍根。信根精进根念根定根慧根。未知当知根已知根具知根。如是二十二根。如来悉如实知。又诸根中。若眼根因通耳根分位。非鼻根舌根身根。如来悉如实知。若耳根因通鼻根分位。若鼻根因通舌根分位。若舌根因通身根分位。若身根因通眼根分位。如是诸根因及分位。如来悉如实知。若诸众生有布施根性修持戒行。如来了知自他根故。即为宣说布施之法。若诸众生有持戒根性修布施行。如来了知自他根故。即为宣说持戒之法。若诸众生有忍辱根性修精进行如来了知自他根故。即为宣说忍辱之法。若诸众生有精进根性修忍辱行。如来了知自他根故。即为宣说精进之法。若诸众生有禅定根性修胜慧行。如来了知自他根故。即为宣说禅定之法。若诸众生有胜慧根性修禅定行。如来了知自他根故。即为宣说胜慧之法。总略乃至诸菩提分法。亦如是说。若诸众生具声闻根性。修缘觉乘行。如来了知自他根故。即为宣说声闻乘法。若诸众生具缘觉根性。修声闻乘行。如来了知自他根故。即为宣说缘觉乘法。若诸众生具大乘根性。而修声闻缘觉乘行。如来了知自他根故。即为宣说大乘之法。若诸众生具最上乘根性。修大乘行。如来了知自他根故。即为宣说最上乘法。若诸众生具不堪任非法器根性。如来了知无所堪任非法器已。即当捐弃。若诸众生有所堪任。是法器者。如来即为宣说正法。舍利子。如来于一切众生中。若观察诸根而悉了知。不观察诸根亦悉了知。若出离根者而悉了知。不出离根者亦悉了知。随诸众生何等根性。若诸行法。若意乐因。若缘若障若究竟处。若最后根。如来一一皆如实知

尔时世尊。重明斯义说伽陀曰

  趣向彼岸诸根性　　知众生性及意乐
  世间诸根遍了知　　人中师子宣正法
  普观下中上根器　　未曾有智而遍转
  知解脱器诸众生　　智宣胜法令开晓
  决定烦恼诸所起　　随众生根少或多
  如诸根性遍了知　　随顺宣说智行法
  若诸众生具善根　　或具不善诸根者
  眼耳鼻舌身意根　　苦乐忧喜舍根性
  信进念定慧根等　　男女命根亦复然
  如其宣说彼信根　　余根胜义亦如是
  根性所行及诸相　　随众生意而遍转
  应根宣说胜法门　　智善明了诸苦法
  声闻诸根难解脱　　唯佛菩提善出离
  声闻不知佛智因　　为说菩提最胜力

舍利子。此是如来第五智力。广说乃至无与如来同其法者

复次舍利子。云何名为如来至处道智力。谓佛如来遍一切处所向之道。皆如实知。云何能知。若众生界住正定聚者。住不定聚者。住邪定聚者。一一了知。若住正定聚众生界者。所有因力及彼先行。而悉具足开明利根。如来知彼有所堪任是解脱器。随昔因力而为说法。若住不定聚众生界者。以彼缘力成熟相故。随其所应说法教授即得解脱。若缘力未熟即不解脱。如来俟其因缘和合。值佛出世即为说法。彼于佛所得闻法已。深固勤行乃得胜果。若住邪定聚众生界者。不修正业。根性痴暗非其正器。如来不为说法。以其无所堪任非解脱器。如来知已即当损弃。是故诸菩萨应当勤行被精进铠。又舍利子。如来了知三种贪处。谓有贪处善相所起。复有贪处边际相所起。复有贪处先因所起。如来了知三种嗔处。谓有嗔处恼害相所起。复有嗔处贪不满意所起。复有嗔处宿习所起。如来了知三种痴处。谓有痴处无明因所起。复有痴处有身见因所起。复有痴处疑惑因所起。如来一一如实了知。又舍利子。如来于诸苦处。以迅速神通而能了知。以其利根故。或于苦处以迟缓神通而能了知。以其柔软根故。又复如来于诸乐处。以迅速神通而能了知。以其利根故。或于乐处。以迟缓神通而能了知。以其柔软根故。又于迟缓处。以迟缓神通而能了知。以障道故。于迟缓处以迅速神通而能了知。令得轻安故。于迅速处以迟缓神通而能了知。以无毕竟安隐故。于迅速处以迅速神通而能了知。以无别异故。又复有处。得决择力圆满非修习力。有得修习力圆满非决择力。有修习力及决择力皆得圆满。有修习力及决择力皆不圆满。如来一一如实了知。又复有处。意乐具足行不具足。有行具足意乐不具足。有意乐具足行亦具足。有意乐不具足行亦不具足。如来一一如实了知。又复有处。身业清净非语非心。又复有处。心业清净非身非语。又复有处。身语心业皆不清净。又复有处。身语心业皆悉清净。如来一一如实了知

舍利子。所有一切众生于一切处。所作因业若动若寂。如来以无碍智。随众生转。舍利子。如是如来至处道智力。无其边际与虚空等。诸住信菩萨。闻已净信。超越分别。离诸疑惑。后复生起身喜心喜适悦之相。发希有想

佛说大乘菩萨藏正法经卷第十一佛说大乘菩萨藏正法经卷第十二

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来不思议品弟四之六

尔时世尊重明斯义说伽陀曰

  佛善了知至处力　　诸正定聚知彼因
  及不定聚诸众生　　彼成熟相皆明了
  三种贪处佛善了　　嗔痴三种亦复然
  三种烦恼差别门　　佛悉了知因缘处
  苦处了知利根性　　迟缓神通柔软根
  乐处利根亦复然　　佛悉了知迟缓相
  有迟缓处迟缓力　　或迟缓处利根性
  缓或迅速处迟根　　迅速神通无异相
  有决择力无修力　　或有修力决择无
  决择修力或俱圆　　二种俱无皆明了
  有处意乐或圆具　　而复行业未能圆
  俱有俱无二种门　　佛能遍观皆明了
  有处身业得清净　　非语非心净亦然
  或复语身清净时　　非心清净义如是
  或有清净于心业　　非语非身义亦然
  或复语心清净时　　非身清净义如是
  身语心业皆清净　　佛遍观察悉能知
  如其所成寂静门　　此佛弟六胜智力

舍利子。此是如来第六至处道智力。如来以具胜智力故了知胜处。乃至世间无与如来同其法者

复次舍利子。云何名为如来禅定。解脱等持等至染净所起智力。谓佛如来于自于他。所有禅定解脱等持等至染净等法。悉如实知。云何能知。所有一切众生诸杂染法若因若缘。悉如实知。及彼众生诸清净法。若因若缘亦如实知。云何是因。云何是缘。谓即一切众生诸杂染中。不如理作意是因。无明是缘。无明为因行为缘。行为因识为缘。识为因名色为缘。名色为因六处为缘。六处为因触为缘。触为因受为缘。受为因爱为缘。爱为因取为缘。取为因有为缘。有为因生为缘。生为因所缘为缘。烦恼为因业为缘。见为因爱为缘。随眠为因所起为缘。一切众生诸杂染处。此如是因。此如是缘。如来一一皆如实知。又因缘者。所有一切众生。于清净法中有二因二缘。若诸众生闻他随顺语言音声。即能各各深固作意。于三摩地能善观想。善住心一境性。又二因二缘者。谓所起智及未起智。又二因二缘者。谓伺察生法不证涅盘。又二因二缘者。谓明行具足取证解脱。又二因二缘者。谓修习解脱门自性解脱智。又二因二缘者。谓尽智无生智。又二因二缘者。谓真实觉了。真实所得。如是一切众生于清净法中。有如是因有如是缘。如来一一皆如实知。又舍利子。所有一切众生有其多种。清净所缘杂染所缘。有取清净所缘者。如实伺察故。有取杂染所缘者。如实伺察故。有杂染所缘中取清净所缘者。如实伺察故。有清净所缘中取杂染所缘者。增上慢所执故。舍利子。如来胜智广大无边。而能遍转如实遍知。所谓离诸罪业寻伺善法。入离生喜乐初禅定门。从初禅定入至灭受想定起。乃至从灭受想定入还至初禅定起。八解脱者。谓顺入逆入及逆顺入。何等为八。一者有色观诸色解脱。二者内无色想观外诸色解脱。三者净解脱身作证具足住。四者空无边处解脱。五者识无边处解脱。六者无所有处解脱。七者非想非非想处解脱。八者灭受想解脱。此八解脱。若顺若逆。等持等至及三昧耶皆能观想。然佛如来。于三摩地悉无分别。亦无所缘及彼所入。如来于一三摩地中。遍入一切三摩地门。从一定起。诸定亦然。如来于等引心。无相续转。无所得心。无能观心。所有一切缘觉三摩地。出过声闻三摩地。菩萨三摩地。出过缘觉三摩地。诸佛三摩地。出过菩萨三摩地。何以故。如来增上胜智悉遍转故。若发声闻心者。诸有语言及教授法。如来悉知。若发缘觉心者。若发菩萨心者。亦如实知。随其所应说法教授。舍利子。此是如来弟七禅定解脱等持等至染净所起智力。无边无际与虚空等。诸住信菩萨。闻已净信。超越分别。离诸疑惑后复生起身喜心喜适悦之相。发希有想

尔时世尊。重明斯义说伽陀曰

  诸有众生杂染性　　及诸众生清净因
  大无畏尊悉了知　　知已随应为说法
  而诸烦恼所因者　　从彼无明缘所生
  无明为因行为缘　　乃至有支生诸苦
  一切烦恼诸根本　　源由不如理作意
  从是因缘生有支　　佛善了故为开晓
  诸业根本所谓行　　无明及识而为缘
  乃至诸苦有支生　　随他音声起诸法
  深固作意而内观　　审知二因及二缘
  众生如实觉了因　　以彼因故能寂止
  众生若求解脱因　　应当善观诸缘法
  调御圣尊悉了知　　深固安住戒清净
  如应审谛观空法　　而善修习解脱门
  解脱三有苦难中　　如实清净善开晓
  众生信佛清净法　　空无相愿解脱门
  三摩钵底复善宣　　声闻缘觉诸禅定
  众生备具诸烦恼　　佛说禅定解脱门
  无染弟七力圆成　　能调难调佛善说

舍利子。如是如来第七智力。如来以具胜智力故。了知胜处。乃至无与如来同其法者

复次舍利子。云何名为如来宿住随念智力。谓佛如来以无上智。若自若他。无数多种诸宿住事。随念了知。若一生若二生。三四五生。若十二十三四五十。百生千生及百千生。乃至无数俱胝那庾多百千生事。随念悉知。若成劫若坏劫。若成坏劫。乃至无数成坏劫中。于某方某处。往昔世中诸有众生。如是名字。如是种族。如是姓氏。如是状貌。如是色相。如是形体。如是寿量。如是久住。如是苦受。如是乐受。于某处灭。于某处生。复于某处灭已。复某处生。若有表示。若无表示。若自若他。有无数多种宿住随念等事。若诸众生有如是因。由彼因故。诸所从来。如来一一如实了知。知已为说法要。所有一切众生过去心行。如来悉能任持了知。若心相续。若心所缘。若心生起。于所缘心不坏不灭。舍利子。如来于一众生。心相续知故。乃至于何等心。而悉相续。如实了知。从某心起。设经殑伽沙数等劫说不能尽。是故应知。诸佛如来了知一切众生心行。无其边际。经俱胝劫说不能尽。如来无上胜智亦无边际。舍利子。如是如来宿住随念。作证智力不可思议。无有等比无其限量。不可算数不可记说。于诸众生无边际处。以佛神通智力随念能知。若诸众生随所生起种诸善根。若佛乘。若缘觉乘。若声闻乘。若诸善法。如来随念而悉能知。如来以大威力。随诸众生善根所缘。即为说法。令彼众生不退转于阿耨多罗三藐三菩提果。如其信解皆得出离。若发声闻乘心。若发缘觉乘心。若发无上正等菩提之心。舍利子。此是如来弟八宿住随念作证智力。无其边际与虚空等。诸住信菩萨。闻已净信。超越分别离诸疑惑。乃至发希有想

尔时世尊。重明斯义说伽陀曰

  百俱胝劫无边际　　佛世灯照宿住事
  遍知自他五类心　　如观掌中庵摩果
  寿量劫数及色相　　生灭众生所起因
  具法器者亦悉知　　过去无边无际等
  世间众生心心所　　相续所生无间断
  圣尊大智遍了知　　过去无量诸心法
  一众生心佛知已　　殑伽沙数等亦然
  三有无际复无边　　乃至后际不可尽
  如是所行智无尽　　无数亦复无限量
  世尊智海广无边　　悉知众生善意乐
  尊重能仁具无量　　神通智力悉广大
  如昔所修善法因　　以威神力能思念
  如是无量大福事　　三种智通善思念
  安住不退转大心　　已修胜行解脱道
  善逝正智无边量　　能知一切众生心
  第八智力广无边　　佛子当生清净信

舍利子。如是如来弟八智力。如来以具胜智力故。了知胜处。乃至无与如来同其法者

复次舍利子。云何名为如来天眼随念作证智力。谓佛如来以无上智清净天眼过于肉眼。观见世间一切众生。生时灭时。尊贵卑贱。善相恶相。趣向善趣趣向恶趣。随诸众生业报成熟所受其果。如来悉知。又若众生身语意业作诸不善。毁谤贤圣起诸邪见。以其积集邪见因故。身坏命终堕于恶趣地狱饿鬼傍生趣中。若诸众生身语意业作诸善行。不谤贤圣起于正见。以其积集正见因故。身坏命终生天界中。又复如来清净天眼。遍观十方一切佛刹。如虚空界无其边际。亦如法界无有限量。不可记说所有十方殑伽沙数等一切佛刹。如来智光而悉照现。或见一切大火炎炽。或见一切成坏等相。或见众生光明中来。或见众生生时灭时。或见菩萨光明中现。或见菩萨从兜率天没来生人间降神母胎。菩萨生已即行七步。所有菩萨住胎入胎悉能观见。或见诸佛世尊光明中现。或见菩萨成正觉果。或见诸佛转大法轮。或见诸佛厌舍寿命所有缘行入大涅盘。或见诸声闻众光明中现。又见声闻趣证涅盘。或见诸缘觉众光明中现。又见缘觉现诸神通作大清净。或有众生不能乘佛光明来者。谓外道众及五通仙众。不与声闻缘觉菩萨相等。是故不能乘光而来。以佛清净最上天眼智力光明。亦悉乘光而来。或复如来现车轮量广大光明。有诸众生乘光而来。如是乃至三千大千世界。无量无边遍众生界。一切天人悉于如来智光中现

又舍利子。如来清净天眼。遍观一切佛刹诸众生界。何等众生所应化度。随其观已有应度者。佛即为现其前而化度之。是彼众生既得度已。余诸众生亦悉不知。舍利子。此是如来第九天眼作证智力。无其边际与虚空等。诸住信菩萨闻已净信。广说乃至发希有想

尔时世尊。重明斯义说伽陀曰

  善逝天眼净无垢　　俱胝劫集善业因
  佛眼观照遍十方　　佛刹广大不思议
  若成若坏诸事相　　或见炎炽大火鬘
  或见多界浑然空　　佛自然智皆明照
  广大难思众生界　　若色无色亦复然
  或堕善趣恶趣中　　佛自然智皆明照
  现在俱胝诸如来　　及已涅盘诸圣尊
  并诸缘觉与声闻　　佛自然智皆明照
  菩萨为欲利众生　　诸所修行菩提行
  觉智明达无摄藏　　佛自然智皆明照
  如是善逝无垢眼　　众生微细悉能观
  第九智眼力难思　　佛子应当生净信

舍利子。如是如来第九智力。如来以具胜智力故。了知胜处。乃至无与如来同其法者

复次舍利子。云何名为如来漏尽作证智力。谓佛如来以无上智力。诸漏悉尽非漏随增。心善解脱慧善解脱。证自通已随诸所行。我生已尽梵行已立所作已办不受后有。如来以是漏尽智力。清净明亮悉断一切种子习气。不与一切声闻缘觉而相等比。声闻漏尽者。有其限量不断习气。缘觉漏尽者。亦有限量舍离大悲及离辩才。如来漏尽者。诸相具足一切种子习气皆悉除断。大悲摄受无畏辩才深善伺察。一切世间无胜过者。住一心相和合所成。何以故。如来已无业种子故。无烦恼种故。于威仪道无过失故。其犹虚空清净澄莹。烟云尘雾悉不能染。如来漏尽智力亦复如是。一切烦恼种子悉不能染。如来安住如是清净漏尽智力。已尽诸漏说漏尽法。亦复宣说断取着法。令诸众生了知一切。虚妄分别诸所取着。而悉不起。普令众生如实伺察。如来以善方便说譬喻法。令诸众生于彼诸漏不实法中如实知已。于一切法无少法可取。于诸取着而悉寂止。舍利子。如来了知一切众生诸漏所集。诸漏灭法诸漏向灭之道。如来如实知已。随其所应为说法要。诸住信菩萨。于佛如来漏尽作证智力。闻已净信。超越分别离诸疑惑。乃至发希有想

尔时世尊。重朋斯义说伽陀曰

  漏尽智力佛圆具　　广大无量净无障
  成满十力胜智门　　趣证无上菩提果
  不同声闻漏尽智　　种习限量结缚障
  人中最上最胜尊　　蠲除种习及限量
  所有缘觉漏尽智　　捐舍大悲及辩才
  世尊漏尽智圆成　　大悲辩才皆无量
  佛善安住漏尽智　　悉知世间漏不实
  于一切法虚妄中　　此理如应皆善了
  悲念世间极苦恼　　说法无我空无常
  虚假不实诸相中　　应观最上寂静地
  无我无人无众生　　作者受者悉皆无
  于一切法虚妄中　　佛悲心观解脱道
  如来已离诸疲懈　　实智亦无忘失法
  能仁常住相应门　　广利世间宣正法
  十力能摧于他法　　十力无边等虚空
  善能安住十力尊　　转最上轮无等比

舍利子。如是如来十种智力。如来以具十智力故了知胜处。于天人世间能师子吼。转妙梵轮。所有一切天人魔梵悉不能转。无与如来同其法者。诸住信菩萨。于佛如来不可思议最胜智力。应当净信。超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想

佛说大乘菩萨藏正法经卷弟十二佛说大乘菩萨藏正法经卷第十三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    如来不思议品弟四之七

复次舍利子。云何名为如来四无所畏不可思议。诸住信菩萨。应发净信超越分别离诸疑惑。乃至发希有想。舍利子。如来无所畏法。其有四种。如来由具四无畏故了知胜处。于大众中能狮子吼转妙梵轮。余诸沙门婆罗门悉不能转。一切世间天人魔梵。无与如来同其法者。舍利子。何等是为四无所畏。一者一切智无畏。谓佛如来已能圆具无上胜智。于大众中作如是言。我成无上正等正觉。此法唯佛自所证知。余诸天人世间。不能与佛同其法语。如来以此法故成等正觉。云何说名如来成等正觉。谓佛如来以一切法平等故。而成正觉。于诸法中无高无下。若异生法。若圣人法。若诸佛法。若有学法。若无学法。若缘觉法。若菩萨法。若世间法。若出世间法。若有罪法。若无罪法。若有漏法。若无漏法若有为法。若无为法。于如是等一切法中。如来悉平等故。此名如来现成正觉。此中云何名为平等。谓空平等见自性故。无相平等相自性故。无愿平等三界自性故。无生平等生自性故。无作平等作自性故。无起平等起自性故。无含藏平等含藏自性故。如所说平等三世自性故。明解脱平等无明有爱自性故。涅槃平等诸行自性故。舍利子。以如是等诸法平等。是故如来现成正觉。如来于大众中。得无所畏。以如是法教示众会。令诸众会咸生欢喜。身得喜故心极信顺。复令众会适悦快乐。如来大悲相应具真实故。平等性故。如实性故。无异性故。无种类性故。无所观性故。无生性故。无离性故。无所取性故。如来所具无畏法中。实无少法可取。亦非无取。如来无畏法中亦无虚诳。如实故平等。法界平等。于是平等法中。普尽一切世界。舒坦无碍如来如实之法。甚深微妙难解难知。如来起大悲心。即以是法起种种方便。为诸众生。广大宣说圣出离法。能尽诸苦。如来以大愿力。一切众生无师范者。为作师范。未成正觉者。令成正觉。所有一切众生。驰流诸境断见等者。如来以无畏法。悉令清净。舍利子。如来无所畏法。无边无际与虚空等。若欲知其虚空边际。即知如来无畏边际。诸住信菩萨闻是法已。应生净信超越分别离诸疑惑。乃至发希有想。此说是名如来第一无畏

复次舍利子。二者漏尽无畏。谓佛如来具足无上胜智。于大众中作如是言。我尽诸漏得无所畏。而彼一切天人世间。无能与佛同法语者。此复云何如来已尽诸漏。谓佛如来欲漏已尽。心得解脱。断灭一切贪行种子。如来有漏已尽心得解脱。断灭一切嗔行种子。如来无明漏已尽心得解脱。断灭一切痴行种子。如来见漏已尽心得解脱。断灭一切烦恼所行种子。此等是名如来诸漏已尽。如是所说皆世俗所成非胜义谛。胜义谛者谓最上圣智慧中。若知若断若修若证。而无少法可住。何以故。如所说尽。彼实知。若诸众生修出离行。如来悉如实知。又舍利子。如来如实了知眼界色界眼识界。云何能知。谓佛了知内空外空内外空故。乃至意界法界意识界悉如实知。云何能知。谓佛了知内空外空内外空故。又舍利子。如来了知地界水界火界风界及虚空界。悉如实知。云何能知。谓如虚空故亦然了知。如来悉知欲界色界及无色界分别所起。知有为界是造作相。知无为界是无造作相。知杂染界是客尘烦恼相。知清净界是自性明亮相。知诸行界是不如理作意无明相。知涅槃界是如理作意明智相

又舍利子。若诸界依止。诸界安住。诸界随顺。诸界建立。诸界作用。诸界意趣。诸界寂定。诸界住着。如来一一如实了知。随所知已即为说法。舍利子。此是如来种种界智力。如是胜力无有边际。若诸住信菩萨于佛如来如是智力。闻已净信。超越分别离诸疑惑。后复生起身喜心喜适悦之相。发希有想

如来无畏边际。诸住信菩萨闻是法已。应生净信超越分别离诸疑惑。乃至发希有想。此说是名如来第二无所畏法。如来由具无所畏故。一切天人世间。无与如来同其法者

复次舍利子。三者说障道无畏。谓佛如来具足无上胜智。于大众中作如是言。我说诸障道法能障圣道。乃至一切天人世间。无能与佛同法语者。云何名为障道之法。有其一法能障圣道。何等为一。谓诸众生心不清净。二法能障圣道。谓无惭无愧。三法能障圣道。谓身恶作语恶作意恶作。四法能障圣道。其四种法皆堕恶趣。谓贪欲当堕恶趣。嗔恚当堕恶趣。愚痴当堕恶趣。怖畏当堕恶趣。五法能障圣道。谓杀生偷盗邪染妄语饮酒。六法能障圣道。谓不尊重佛。不尊重法。不尊重僧不尊重戒学。不尊重定学。不尊重修头陀行者。七法能障圣道。谓慢过慢慢过慢。我慢邪慢。增上慢卑慢。八法能障圣道。谓邪见邪思惟。邪语邪业。邪命邪勤。邪念邪定。九法能障圣道。谓于我身作无义利。生起害心。已作现作当作。于我所爱作无义利。生起害心。已作现作当作。于我非爱作无义利。生起害心。已作现作当作。十法能障圣道。谓杀生偷盗邪染。妄言绮语。两舌恶口。贪嗔邪见。舍利子。如是等法能障圣道。乃至不如理作意。相应所生结使。此法无味。是不可观是不可行。由颠倒勤行故不出离。生起一切爱见。取着于身语意业。爱着增炽。如味了知诸法能障圣道。知已如实为诸众生。广大宣说障道之法。令诸众生寂止近止。说除断法普为教示。令诸众会咸生欢喜。身得喜故心极信顺。复令众会适悦快乐。如来大悲相应具真实。故平等性故。如实性故。无异性故。无种类性故。无所观性故。无生性故。无离性故。无所取性故。如来所具无畏法中。实无少法可取。亦非无取。如来无畏法中亦无虚诳。如实故平等。法界平等。于是平等法中。普尽一切世界。舒坦无碍。此如是等不可思议无量无数甚深正法。如来悉具足已。大悲之心所逼切故。为诸众生。说断障道之法。普令一切寂止近止。舍利子。如来无所畏法。无边无际与虚空等。若欲知其虚空边际。即知如来无畏边际。诸住信菩萨闻是法已。应生净信超越分别离诸疑惑。乃至发希有想。此是如来第三无所畏法。如来由具无所畏故。一切天人世间。无与如来同其法者。复次舍利子。四者尽苦道无畏。谓佛如来具足无上胜智。于大众中作如是言。我说圣出离法能尽苦道。乃至一切天人世间。无能与佛同法语者。云何名为圣出离法能尽苦道。其有一法。是圣出离道。何等为一。谓诸众生心悉清净。二法是圣出离道。谓奢摩他毗钵舍那。三法是圣出离道。谓空无相无愿。四法是圣出离道。谓身念处受念处。心念处法念处。五法是圣出离道。谓信根精进根。念根定根慧根。六法是圣出离道。谓念佛念法念僧。念戒念施念天。七法是圣出离道。谓择法觉支精进觉支。喜觉支轻安觉支。舍觉支念觉支定觉支。八法是圣出离道。谓正见正思惟。正语正业。正命正精进。正念正定。九种欢喜根本法。是圣出离道。谓观喜适悦。轻安快乐。等持如实知见。寂静离染解脱。十法是圣出离道。谓远离杀生。远离偷盗。远离邪染。远离妄言。远离绮语。远离两舌。远离恶口。远离贪欲。远离嗔恚。能具正见。舍利子。如是所说诸圣出离法。能尽苦道。乃至诸善菩提分法。戒蕴相应。定蕴相应。慧蕴相应。解脱蕴相应。解脱知见蕴相应。四圣谛法相应。此等所说。皆名圣出离道。复有圣出离道。谓正所行。此正所行。彼即无法可行。亦非无行。无入无出。无取无舍。何以故。若已行。若当行。二法皆离彼一切法。无二亦然。此如实知见。是圣出离道。如来于此圣出离道。自了知已。为诸众生广大宣说。令诸众会咸生欢喜。身得喜故心极信顺。复令众会适悦快乐。如来大悲相应具真实故。平等性故。如实性故。无异性故。无种类性故。无所观性故。无生性故。无离性故。无所取性故。如来所具无畏法中。实无少法可取。亦非无取。如来无畏法中亦无虚诳。如实故平等。法界平等。于是平等法中。普尽一切世界。舒坦无碍。此如是等不可思议无量无数甚深正法。如来悉具足已。大悲之心所逼切故。为诸众生。广大宣说圣出离法。令诸众生咸悉觉了尽苦边际。舍利子。此是如来第四无所畏法。如来由具四无所畏故。了知胜处。于大众中作狮子吼。转妙梵轮。余诸沙门婆罗门悉不能转。乃至一切世间天人魔梵。无与如来同其法者。舍利子。如来如是四无所畏。无边无际与虚空等。若欲知其虚空边际。即知如来无畏边际。诸住信菩萨得闻如来如是不可思议无畏之法。应生净信超越分别离诸疑惑。后复生起身喜心喜。发希有想

尔时世尊。重明斯义。说伽陀曰

  彼一切法皆平等　　佛自然智随觉了
  由是现证佛菩提　　如来平等普观视
  世间一切异生法　　与诸佛法悉平等
  有学无学诸法门　　及缘觉法亦如是
  所有世间一切法　　及彼出世胜法门
  善恶无动法亦然　　与涅盘道皆同等
  所有空法无相法　　彼无愿法亦复然
  无生无作诸法中　　如来平等同观照
  此平等法了知已　　佛为众生广宣说
  化众生归解脱门　　牟尼第一无所畏
  解脱世间三种法　　为众生说解脱门
  佛大无畏人中尊　　此名第二无畏法
  虽知诸佛演正法　　何故亲近不解脱
  心不清净惭愧无　　由斯一二为障碍
  复由身语意三业　　不遵戒法而恶作
  贪嗔痴怖起四愆　　彼诸杀害并偷盗
  邪染妄言饮酒五　　六不尊重七慢生
  八种邪法旋复兴　　彼九恼处多过失
  后起十种不善业　　于解脱道为障碍
  深固作意不了知　　为痴暗道所覆蔽
  取着虚妄及迷醉　　颠倒勤行了知已
  乃复亲近正法门　　此名第三无畏法
  清净法门无限量　　近正法故证菩提
  唯佛智知寂静门　　知已广施甘露法
  佛最称赞菩提分　　乃至广多诸善法
  习近故为解脱门　　佛十力尊善宣说
  深固勤行离诸染　　于其善法悉相应
  是法非法无著心　　寂静解脱离忧怖
  如实了知诸善法　　如空寥廓而无碍
  无执着法亦复然　　彼能出离三有海
  三有海中迷著者　　十方尊说业所生
  佛令解脱悲愍心　　四无畏法虚空等

舍利子。如是所说如来四无畏法不可思议。诸住信菩萨闻是法已。应生净信超越分别离诸疑惑。乃至发希有想

佛说大乘菩萨藏正法经卷弟十三

即无生无生即无尽。于毕竟尽中无所对治此说名尽。如所说尽。亦复无有尽法可尽。即是无为。无为即无灭无住。若说有生如来即无生。法性常住法界常住。诸法亦复随智所行。然其所行悉无所行。亦非无行。亦复无漏法可得虽复如是。如来安住大悲心已。亦为众生广大宣说。断除诸漏之法。如来于大众中得无所畏。以如是法教示众会。令诸众会咸生欢喜。身得喜故心极信顺。复令众会适悦快乐。如来大悲相应具真实故。平等性故。如实性故。无异性故。无种类性故。无所观性故。无生性故。无离性故。无所取性故。如来所具无畏法中。实无少法可取。亦非无取。如来无畏法中亦无虚诳。如实故。平等法界平等。于是平等法中。普尽一切世界。舒坦无碍。此如是等不可思议无量无数甚深正法。如来悉具足已。大悲之心所逼切故。为诸众生广大宣说如是之法。舍利子。如来无所畏法无边无际与虚空等。若欲知其虚空边际。即知佛说大乘菩萨藏正法经卷第十四

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    如来不思议品第四之八

复次舍利子。云何名为如来大悲之心不可思议。诸住信菩萨闻是说已。应生净信超越分别离诸疑惑。乃至发希有想

舍利子。如来大悲心者。所谓不舍一切众生。常行悲愍为成熟故。随悲心转而无不转。是故当知。如来大悲之心。无有限量不可思议。复无等比。亦无数量。不可称说。最为甚深。如其语业不能宣说。何以故。随佛如来所证菩提亦然。如是为诸众生起大悲心。随如是菩提即如是大悲。舍利子。云何如来得证菩提。如来无根本无所住故。乃证菩提。云何名根本。复何名住。谓有身见为根本。依虚妄分别而住。如来以其菩提平等故。平等了知。二法亦悉平等。是故说名无住无根本。如来由是现成正等菩提。而诸众生于无住无根本法。不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者寂静近寂。由如是故我成正觉。何名寂静何名近寂。内谓寂静外谓近寂。所以者何。谓眼空故我我所无自性。此名寂静。如是耳鼻舌身意空故。我我所无自性。此名近寂。知眼空已色无所取。此名寂静。乃至知意空已法无所取。此名近寂。而诸众生于此菩提寂静等法。不能了知。如来为令一切众生悉觉了故。乃于众生。转大悲心

又舍利子。菩提者自性明亮。由如是故。我成正觉。云何名为自性明亮谓由自性无所染故。与虚空等。虚空自性周遍一切。以虚空平等故。一切法平等。毕竟自性如是明亮。此明亮性所应觉了。诸愚夫异生。以客尘烦恼之所染故。于此自性明亮法中。不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者无出无入。由如是故我成正觉。何名无出。以无相故无出又无出者。一切法无舍故。无入者。一切法无取故。如来于是无出无入法中。平等观照。如来无此无彼。一切法离彼此故。是故如来现成正觉。如是无出无入法中。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者无相无所缘。由如是故我成正觉。何名无相何名无所缘。谓眼识无所得。名为无相色无所观。名无所缘。乃至意识无所得。名为无相。法无所观。名无所缘。舍利子。此无相无所缘法。是诸圣境界。何名圣境界。谓即三界是圣境界。若诸圣境界。彼即无境界。而愚夫异生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者非过去未来现在。三世平等三轮清净。由如是故我成正觉。何名三轮清净。谓过去心无转。未来识无觉了。现在意无动。而心意识都无所住。过去无分别。未来无领纳。现在无戏论。此三平等三轮清净之法。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心。又舍利子。菩提者是无为。由如是故我成正觉。谓非眼识所知。乃至非意识所知。此名无为。无为即无生无灭无住。此说亦名三轮清净。是即无为。然于有为之法亦悉了知。何以故。一切法自性彼即无性。无性即无二。无为之法。亦非身证。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者是无差别句。由如是故我成正觉。何名无差别。复何名句。谓如所说名句。无住名无差别。法界名句。无种种性名无差别。实际名句。无动性名无差别。空名为句。无所得名无差别。无相名句。无寻伺名无差别。无愿名句。无分位名无差别。无众生名句。无众生自性名无差别。虚空名句。无所得名无差别。无生名句。无灭名无差别。无为名句。无所行名无差别。菩提名句。近寂名无差别。涅盘名句。无所转名无差别。舍利子。此如是等。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者非身心可证。何以故。是身无知无作无转。如草木瓦砾。是心如幻如水月阳焰。应当觉了。身心若然即是菩提。此乃世俗所行。亦非菩提有少法可说。若身若心。若法若非法。若真实若不真实。若诚若妄。悉无言说。何以故。菩提无言说故。彼一切法亦无分位可容言说。犹如虚空了无分位。无言说故。菩提亦然了无分位亦无言说。舍利子。若其如实审伺察时。彼一切法本无言说。法无言说亦非无说。此诸法理。而诸众生不能觉知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提无取亦无含藏。何名无取何名无含藏。谓知眼故名为无取。色无所观名无含藏。乃至了知意故名为无取。法无所得名无含藏。舍利子。如来以无所取无含藏故。现成正觉。又眼无所取。色无含藏。识无所住。乃至意无所取。法无含藏。识无所住。彼无住识。于彼一切众生心住。此云何知。谓有四种法。于一切众生心住。何等为四。谓色中住受想行中一切众生心住。如是四法众生心住。然其所住亦即无住。如来了知如是无住之法真实之际。而诸众生不能觉了。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提是空增语。以其空故菩提亦空。诸法亦空。如来以其诸法空故。现成正觉。亦非空故空有所证。若空若菩提同一理智而无有二。以空及菩提本无二故即无种类之法。以其诸法无二无种类故。即无名无相无行。毕竟无行无集法中。此说名空。是中悉离执见取着。而于胜义谛中。无有少法可得。以如是故。乃说名空。此所说空如虚空故。即此虚空欲说为空。而亦无言可说为空。空亦无言而可说故。于是空中若解入者。乃一切法假名施设。然其名字而不在方亦不离方。如其假名不在方不离方故。由是诸法假名施设。一切法亦然。而不在方亦不离方。如来如实了知。本来如是无生无起。如实知已。自性解脱无缚无解。而愚夫异生于如是法不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提如虚空故。而悉平等无高无下。菩提亦然等无高下。若知诸法毕竟都无。亦复无高无下可说。舍利子。如来以一切法无高无下故。现成正觉。虽有所成亦无微尘许法。若高若下而可施作。如实智知无此彼法。何名如实智。谓无根本法虽有所生而无摄受。亦无主宰。以无主宰无摄受故。若生不生随缘所转。然于是中无法可转。亦非无转。如来于法而亦不说断灭之相。如是无断灭法。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心。又舍利子。菩提是如所说句。何名如所说句。如其菩提。色法亦然。而不难真如。如其菩提。受想行识亦然。亦不离真如。如其菩提。地界水界火界风界空界亦然。亦不离真如。如其菩提。眼界色界眼识界乃至意界法界意识界亦然亦不离真如。由是施设。此如是等诸圣法门。所谓蕴处界等。如来以如实法故现证菩提。以无颠倒法故现证菩提。如其先说中后亦然。先际无生后际无去中际性离。如是如所说句中。如说一法多法亦然。如说多法一法亦然。如其所说若一若多都无所得。如是如所说句。而诸众生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提入相入无相。何名为相何名无相。此说相者。谓即所起一切善法。无相者即一切法都无所得。又相者。谓心无所住分位。无相者即无相三摩地法。又相者即思惟称量算数伺察。无相者即出过称量。云何出过称量。谓识业无故。又相者谓有为伺察。无相者即无为作证。此相无相法。愚夫异生不能解入亦复不知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提者无漏无取。何名无漏何名无取。此说无漏者。谓离四种漏法。一离欲漏二离有漏。三离无明漏。四离见漏。无取者谓离四取。一离欲取。二离我语取。三离见取。四离戒禁取。如是四取。一切皆由无明覆蔽。爱水滋润。我见执取蕴处界法。如来了知彼我语取为根本故。得我清净已。一切众生亦悉清净。若其清净即无少法而可分别。若无分别即能深固作意若深固作意相应。即无明不能起发。由其无明不起发故。即十二有支亦复不起。彼即无生彼即决定。若其决定即调伏义。是即胜义。胜义谛中即无补特伽罗义若无补特伽罗义。即是不可说义。若不可说义即缘生义。若缘生义即正法义。若正法义即如来义。由如是故。当观诸法皆从缘生。若能见法即见如来。如其所见若如实伺察。即无少法可见。若无法可见。即见无相及无所缘。若如是见即真实见。如来由此法故现成正觉。平等故平等。如是无漏无取之法。愚夫异生不能了知。如来为令一切众生悉觉了故。乃于众生转大悲心

又舍利子。菩提清净无垢无著。何名清净何名无垢何名无著。谓空是清净。无相是无垢。无愿是无著。无生是清净。无作是无垢。无起是无著。自性是清净。圆净是无垢。明亮是无著。无戏论是清净。离戏论是无垢。戏论近寂是无著。真如是清净。法界是无垢。实际是无著。虚空是清净。寥廓是无垢。广大是无著。知内是清净。外无所行是无垢。内外无所得是无著。知蕴是清净。界自性是无垢。处离诸业是无著。过去尽智是清净。未来无生智是无垢。现在法界安住智是无著。舍利子。此清净无垢无著。有其一法而能普摄。谓寂静句。若寂静即遍寂。若遍寂即近寂。若近寂即无寂。此是牟尼圣尊所说

又舍利子。如虚空故菩提亦然。如菩提故诸法亦然。如诸法故众生亦然。刹土亦然。涅盘亦然。此即名为涅盘平等。是一切法毕竟边际清净正因。无所对治离对治因。本来清净。本来无垢。本来无著如来了知彼一切法若色无色本如是故。现成正觉。观诸众生界清净无垢无著故。即起游戏神通。乃于众生转大悲心。舍利子当知。如来大悲之心清净无垢无著。于诸众生常所运行。然无发悟。无所生起。无所观瞩。普尽十方一切世界。舒坦无碍。舍利子。如来大悲无边无际与虚空等。若欲知其虚空边际。即知如来大悲边际。诸住信菩萨得闻如来不可思议大悲心已。应生净信超越分别离诸疑惑。乃至发希有想

尔时世尊。重明斯义。说伽陀曰

  以无根本无住法　　现证菩提佛所宣
  如所觉了亦复然　　为诸众生广宣说
  知内眼根名为空　　知外色法空亦然
  寂静近寂妙法门　　佛证菩提如是说
  彼诸众生不觉了　　毗钵舍那奢摩他
  开觉句义为众生　　佛大悲心方便转
  诸法自性本明亮　　菩提清净等虚空
  为彼众生不了知　　佛大悲心方便转
  一切众生多执取　　不能如理而相应
  无入无出妙法门　　佛证菩提如是说
  为诸众生不了故　　如来乃起大悲心
  诸法无相无所缘　　此是诸圣之境界
  诸愚夫为非境界　　佛证菩提方便宣
  而诸异生不了知　　为开觉故由斯说
  如来为诸众生故　　随应所起大悲心
  无为自性妙法门　　本来不生亦不灭
  当知彼法无所住　　时中三种相应相
  而诸愚夫不了知　　诸法有为自性故
  随应所起大悲心　　为令了知此理法
  菩提非身所觉知　　非心觉故亦如是
  身本自性无知觉　　心如幻法亦复然
  而彼愚夫不了知　　如是身心自性故
  随应所起大悲心　　为令了知此理法
  佛证最上胜菩提　　自然智尊坐道树
  坐已普观众生界　　旋转种种恶趣中
  佛见极生哀愍心　　生死轮中大悲转
  憍慢等法所迷着　　见网缠覆苦计乐
  无常不净我众生　　此等颠倒而计执
  佛见极生哀愍故　　于取着中大悲转
  痴盖遍覆三有中　　暗冥悉无光明照
  如日光明云所覆　　无垢智光悉隐蔽
  佛见极生哀愍心　　生死轮中大悲转
  贪爱故生诸恶趣　　破坏正道而极坏
  地狱傍生饿鬼中　　众生业故皆堕落
  如先佛说诸正道　　开明显示为众生
  佛见极生悲愍心　　生死轮中大悲转
  了知诸法如实性　　廓然明照等虚空
  如佛所说诸世间　　不知最上清净法

舍利子。如是所说。是为如来不可思议大悲之法。诸住信菩萨闻是法已。应生净信超越分别离诸疑惑。后复生起身喜心喜发希有想

佛说大乘菩萨藏正法经卷第十四佛说大乘菩萨藏正法经卷第十五

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    如来不思议品第四之九

复次舍利子。如来所有十八不共佛法。诸住信菩萨闻是说已。应生净信超越分别离诸疑惑。乃至发希有想。而是十八种法。如来以具足故了知胜处。于大众中作师子吼转妙梵轮。余诸沙门婆罗门悉不能转。所有一切世间天人魔梵。无与如来同其法者。云何名为如来十八种法。一者如来三业无诸过失。所谓身无过失故。若智若愚无与如来同法语者何以故。佛世尊者身业清净无诸过失。如来身相端直。诸威仪道进止可观。若向若背若屈若伸都无缺失。被僧伽梨执持应器。而僧伽梨衣离地四指。毗蓝婆风不能吹鼓举足下足行住坐卧威仪如法。于城邑聚落。若入若出下足按地。而不损触千幅轮相。于虚空中。雨众莲华及诸妙香。又复如来足按地时。傍生趣中诸众生类。于七夜中悉得快乐。命终之后得生天界。佛身光明普遍照耀。下至阿鼻地狱。彼诸众生蒙光照触皆获乐受。此名如来身无过失。又复如来语无过失。此语无过失者。若智若愚无与如来同法语者。何以故。舍利子。如来所出语言悉知时故。是如实语。诚谛语。平等语。如说能行语。无众杂语。令诸众生欢喜语。无重复语。善文善义妙庄严语。以一语言音声。随诸众生种种意乐。咸生欢喜语。此名如来语无过失。又复如来心无过失。此心无过失者。若智若愚无与如来同法语者。何以故。舍利子。如来虽常住等引心。而不舍离一切佛事。常所施作心无所观。于一切法。无碍知见而常运转。此名如来心无过失。即以如是心无过失之法。为诸众生亦然宣说。普令断除诸心过失。此等是名如来第一不共佛法

舍利子。如来心无爱着。所有一切魔及魔众。并余邪异外道。于佛如来伺不得便。何以故。如来若顺若逆若尊重若损害。皆已离故。一切众生若起尊重。心亦不高。若不尊重。心亦不恚。如来诸所作事已作见作。悉无流散不起爱着。亦复不与世间相违。以如来心无爱着故。修无诤行。如来无我无执无取离诸结缚。是故如来无所爱着。以其无故。为诸众生亦然宣说断爱着法。此是如来第二不共佛法。复次舍利子。如来无失念。若有失念即有痴暗以其如来无痴暗故。即于禅定解脱等持等至。悉无障碍。所有一切众生心行动转。普观察已。即为如应宣说法要。由无忘失故。于诸法义乐说辩才。及无碍解皆无忘失。如来于过去未来现在。具无碍智见故。自解了已即为众生。广大宣说过去未来现在无碍智见无忘失法。此是如来第三不共佛法

复次舍利子。如来常住三摩呬多。若行若住若坐若卧若食。食已或复默然。心无所得。如来已得甚深三摩地法及最上波罗蜜多。能观所观悉无障碍。所有一切众生及众生聚中。悉不能观如来之心。唯除如来加持力故。如来常住三摩呬多心已。即为众生。如应宣说三摩地中清净舍法。此是如来第四不共佛法

复次舍利子。如来无种种想。不于种种想及诸境界而住其心。何以故。如来于刹土中。无种种想。刹土如虚空。无有尽故。于众生中无种种想。众生自性无种种故。于诸佛中无种种想。法界无差别平等智故。于诸法中无种种想。离贪法故。如来于众生中。见具戒者不起敬心。见毁戒者不起慢心。不饶益者现起饶益。无不饶益普饶益故。不调伏者平等调伏。邪定聚者亦不轻慢。如来于一切法中。起平等行。此名如来无种种想。即以此法为诸众生。宣说断除种种之想。此是如来第五不共佛法

复次舍利子。如来于诸舍法无不决择。何以故。如来于修道者而行舍法。非修道者亦不弃舍。于修心者而行舍法。非修心者亦不弃舍。于修戒者而行舍法。非修戒者亦不弃舍。于修慧者而行舍法。非修慧者亦不弃舍。于智行舍不弃愚痴。舍出世间不弃世间。于圣出离者而行舍法。非圣出离者亦不弃舍。如来转妙梵轮而行舍法。于诸众生亦不舍离大悲之心。如来自所证成平等舍法。不假对治而能随顺。舍利子。又复如来于舍法中无高无下。亦无所住。已得不动离于二法。无出无入。依时而舍不越于时。无动摇无别异无分别无所观。无和合无表示。无实无虚。无诚无妄。亦无领纳。如是如来舍法具足。即以是法为诸众生。广大宣说令舍法圆满。此是如来第六不共佛法

复次舍利子。如来所欲无减。何名为欲。谓善法欲。复何名无。谓即如来大慈心欲无减。大悲心欲无减。说法欲无减。化度众生欲无减。成熟众生欲无减。伺察欲无减。教示菩萨欲无减。令三宝种不断欲无减。如来所欲所向智为先导。如是等如来所欲。皆为令彼一切众生。圆满无上一切智果。如其所应宣说法要。此是如来第七不共佛法

复次舍利子。如来精进无减。以其如来精进力故。普为化度一切众生不舍精进。令听法者不生疲倦。如来于听法者亦无所得观其法器。如来随应为说法要。不生疲懈亦无中止。当说法时不念饮食。于其中间不舍众生。如来过度殑伽沙数等诸佛刹。其中若有一众生未化度者。如来身语心业悉无疲倦。三业轻安发起精进。如理勤行令诸众生得圣解脱。是为如来为诸众生大精进力。此是如来第八不共佛法

复次舍利子。如来于一切处。一切种诸念无减。如来正念悉无忘失。何以故。诸佛如来相续现证阿耨多罗三藐三菩提果。所有一切众生。过去未来现在诸心。如来悉能任持观察。如来于诸念中。毕竟不复有所忘失。随诸众生一切心行。而悉了知。如来不复思想观视。正念无减。住三聚法了众生根。解入众生一切意乐。观众生行。如来亦无思惟伺察。说法无断。所以者何。随其如来念无减故。念即寂静悉无忘失。即以是法为诸众生广大宣说。此是如来第九不共佛法

复次舍利子。如来等持无减。所有如来等持之法。即是一切法平等。如其所说诸法平等。何名如来等持无减。谓若真如平等即等持平等。若等持平等即诸如来平等。若入是平等法门。此即说名三摩呬多。若贪际平等。即离贪际平等。若嗔际平等。即离嗔际平等。若痴际平等。即离痴际平等。若有为际平等。即无为际平等。若生死际平等。即涅盘际平等。若入是平等法门。即名如来等持无减。何以故。由等持无减故即毕竟无减。又复如来等持之法。非眼相应。非耳鼻舌身意相应如来于其诸根无所缺坏。不依止地界。亦不依止水火风界。不依止欲界色界无色界。不依止此界他界。以无依止故即无所减。是为毕竟无减。以其如来等持无减故。即以此法为诸众生广大宣说。普令众生获得如来等持法门。此是如来第十不共佛法

复次舍利子。如来慧无减。如来胜慧云何能知。谓一切法不随他信智。无众生寿者补特伽罗于法有所得智。无尽无碍解善巧之智。分别句义智。于一句中入百千劫加持宣说智。随诸所问各各宣说断疑惑智。于一切处无障碍智。建立三乘善宣说智。八万四千心行悉了知智。八万四千法蕴随应说智。如是如来最上胜慧。无边无际说不能尽。如其如来胜慧无减。即为众生广大宣说慧无尽法。此是如来第十一不共佛法

复次舍利子。如来解脱无减。何名如来解脱无减。所谓随应悉令解脱。诸声闻众闻声解脱。诸缘觉众。觉悟缘生而得解脱诸佛世尊离诸障碍二取解脱。此说解脱者。先际诸佛已往。后际诸佛未至。现在诸佛不住。由是眼色二取解脱。耳声鼻香舌味身触二取解脱。无取无著无依止解脱。心自性明亮故。智亦复然。此说名为一心相中相应胜慧如来由是。现证阿耨多罗三藐三菩提果。如其所证即以此法。为诸众生广大宣说。此是如来第十二不共佛法

复次舍利子。如来一切身业智为先导。随智所行。以其如来身业具足故。一切众生见佛身者悉得调伏。闻佛说法者悉得调伏。观佛默然者悉得调伏。睹佛受食者悉得调伏。见佛威仪者悉得调伏。瞻佛众相者悉得调伏。观佛妙好者悉得调伏。瞻佛不可见顶相及放光者。悉得调伏。见佛举足下足于城邑聚落若入若出者。悉得调伏。诸佛如来于四威仪道中。而无不为众生作调伏事。此名如来身业智为先导随智慧行。此是如来第十三不共佛法。复次舍利子。如来一切语业智为先导随智慧行。何以故。诸佛世尊不说虚假之法。说无断法。善乐说法。如来诸有语言。未知者令知。无高无下无纡烦语。无屈曲语。无粗涩语。无恶戾语。无巇崄语。善柔软语。无衰朽语。无轻动语。无娆恼语。无迅速语。无迟缓语。善分明语。善演说语。善了知语。妙说相妙音声。无破缺无过失。极甘美广大殊妙。无尘离尘。无垢无暗。显焕无碍。和合明亮。神通无劣。音响不破。能生妙乐。身得欢喜。心极信顺。息除贪爱。息除嗔恚。息除愚痴。降伏恶魔。制诸罪业。息邪异语。止不了语。如击鼓音声。如迦陵频伽声。如帝释声。如梵王声。如海潮声。如云雷声。如地振声。如雁王声。如孔雀王游戏声。如拘枳罗声。如命命鸟声。如鹿王声。如箜篌声。分明解了声。悦意乐闻声。甚深清亮无喑哑声。生妙乐声。生善根声。文句不断声。文句乐说声。义句和合声。法句和合声。知时声。顺时声。不越时声。知自他根善演说声。布施庄严声。持戒清净声。忍辱柔和声。精进勇悍声。禅定妙乐声。智慧毕竟声。大慈和合声。大悲无倦声。大喜明亮声。大舍究竟声。建立三乘声。令三宝种不断声。安立三聚分位声。三解脱门清净声。观四谛声。观察智声。不毁智者声。诸圣称赞声。随知虚空无量声。诸相具足声。舍利子。此如是等。是名如来一切语业智为先导随智慧行。此是如来第十四不共佛法

复次舍利子。如来意业智为先导随智慧行。何以故。如来心法而不可说。如来意法识法。不可以智慧辩才而能测度。如来智慧随知一切众生心。随入一切众生意。通达一切众生智。诸法决定。诸等持法亦无他信。超越所缘离诸缘生。息除三友及诸恶趣。越诸魔法诸魔异。解脱诸谄幻法而悉远离。舍我我所。去除无明痴暗覆蔽。修八正道离诸疑惑。与虚空等。法界平等而无差别。舍利子。如是等法。是为如来所有意业智为先导随智慧行。此是如来第十五不共佛法

佛说大乘菩萨藏正法经卷弟十五佛说大乘菩萨藏正法经卷第十六

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来不思议品第四之余

复次舍利子。如来于过去世中。以无著无碍智见。随转所转。云何舍利子。谓过去世诸佛刹中。若成若坏彼一切事。如来以算数方便而悉能知。又佛刹中所有一切药草树林而悉能知。又佛刹中所有一切众生众类众生施设。而悉能知。又佛刹中所有一切众生。种种性行种种色相周遍广大。而悉能知。又佛刹中诸佛出世作诸化事。乃至一一广为众生宣说正法。或有众生以声闻法得化度者。或有众生以缘觉法得化度者。或有众生以大乘法得化度者。乃至佛刹广大。诸苾刍众广大。寿量广大。正法住世广大。久近众生饮食受用等事。乃至众生出息入息。如是所有一切众生。过去世中一切诸相。若生若灭诸趣受生。种种根性种种意乐。佛悉能知。如来以无著心。任持了知彼一切法。诸心无边诸心所起。如来以算数方便皆悉能知。如来以现量智。如实观察过去世中诸众生心。如是如来最上胜智。曾无间断。为诸众生如应说法。舍利子。此是如来第十六不共佛法

复次舍利子。如来于未来世中。以无著无碍智见。随转所转。云何谓未来世中诸佛如来当出于世。佛悉能知。乃至未来劫火洞然。大水漂溺。猛风吹鼓。或复诸佛刹土安然不动。至于诸佛刹中一切地界。碎若微尘及彼一切药草树林。至于一切星宿相状。至于周遍诸佛刹中。诸佛出世。缘觉出世。声闻出世。菩萨成证。至于众生出息入息饮食受用等事。若行若住。乃至一切众生周遍广大。一一众生各趣解脱。或声闻乘或缘觉乘。或复大乘得解脱者。而彼一切如来悉知。又复诸佛刹中周遍一切。一一众生诸所生处。及心心所诸所生起。而彼一切如来悉知。虽如是知。亦非如来未来世中于诸众生有所任持。但于未来世中如应观察。为诸众生宣说正法。舍利子。此是如来第十七不共佛法

复次舍利子。如来于现在世中。以无著无碍智见随转所转。云何所谓现在十方一切诸佛刹土。如来以三种算数方便而悉能知。所有现在一切诸佛一切菩萨。一切缘觉一切声闻。如来悉知。至于现在一切星宿相状亦复遍知。及彼现在一切药草树林亦悉了知。至于十方一切地界。碎若微尘。以算数方便而悉能知。又复十方一切水界。如毛端量水滴上涌。又复十方一切火界迅速起灭。又复十方一切风界百种相状周遍吹击。以算数方便而悉能知。又复十方一切空界。假使聚如毛端之量。以算数方便亦悉能知。又复现在三种众生界而悉能知。又复现在所有一切地狱众生界趣。彼所生因及所起因而悉能知。又复现在所有一切畜生界趣。彼所生因及所起因而悉能知。又复现在所有一切饿鬼界趣。彼所生因及所起因而悉能知。又复现在一切人趣。彼所生因及所灭因而悉能知。又复现在诸天界趣。彼所生因及所灭因而悉能知。又复现在一切众生。及众生心所应任持。若有烦恼若离烦恼而悉能知。又复现在一切众生随其根性。所应化度不应化度如来悉知。然佛如来亦无二种随流识转。如来以其入无二理最上法门。为诸众生说。舍利子。此是如来第十八不共佛法

复次舍利子。如是十八不共佛法。如来以具足故。周遍十方一切世界。于大众中光明显照。圆具一切威光名称最上吉祥希有之法

又舍利子。如来十八不共佛法。犹若虚空无有边际。若能知其虚空边际。即知如来不共佛法所有边际。是故诸菩萨摩诃萨。得闻如来如是十八不共佛法。闻已净信超越分别。离诸疑惑。后复生起身喜心喜。发希有想。尔时世尊。欲重明斯义。说伽陀曰

  调伏圣者无过失　　身语意业悉无动
  如应说法利众生　　此是胜尊不共法
  佛心无高亦无下　　一切违顺皆止息
  修无诤行解脱心　　此是胜尊不共法
  佛调伏尊无失念　　解脱行法悉了知
  四无碍解已圆明　　此是胜尊不共法
  如来行住及坐卧　　一切皆住等引心
  无众生想无乱心　　此是胜尊不共法
  善逝已无种种想　　诸佛刹土及众生
  起平等行大名称　　此是胜尊不共法
  佛心无不决择舍　　决定正道善观察
  分别离分别都无　　此是胜尊不共法
  能仁不减善法欲　　悲方便门常所行
  调伏无量诸群生　　此是胜尊不共法
  精进曾无少减缺　　调伏诸见广无边
  善调身语意亦然　　此是胜尊不共法
  如来不减于正念　　觉了菩提诣道场
  于法觉了无觉心　　此是胜尊不共法
  佛无分别离分别　　平等安住等持心
  诸法决定无所依　　此是胜尊不共法
  佛慧刹那悉决了　　诸众生行而悉知
  随其意乐阐法门　　此是胜尊不共法
  随声悟解曰声闻　　想缘生法名缘觉
  离着无垢等虚空　　此大舍心不思议
  宿昔安住无觉心　　自性解脱心任持
  彼解脱法随应宣　　此是胜尊不共法
  现威仪道众所瞻　　直身端视入城邑
  相好庄严众威光　　众生睹者皆调伏
  众生睹佛真实光　　多俱胝众获妙乐
  蒙光照触调伏生　　此是胜尊不共法
  佛以一音演说法　　随众生意悉能闻
  如声对响理相应　　此是胜尊不共法
  善逝心业本无有　　智所作业悉不忘
  圣智随入众生心　　此是胜尊不共法
  禅定等持善相应　　一切戏论无所行
  平等行法等虚空　　此是胜尊不共法
  如来悉知过去世　　转一切法无障碍
  解脱智了诸趣中　　此是胜尊不共法
  所有世间未来法　　当有所得或无得
  众生刹土及如来　　佛悉了知无懈倦
  佛心曾无诸散乱　　未来世中随观察
  众生及法知亦然　　此是胜尊不共法
  现在世中诸所转　　如来悉知无所著
  佛调御者等虚空　　此是胜尊不共法
  如来所有不共法　　而十八种不思议
  如实开明若虚空　　菩萨应当生净信

舍利子。如来以具足如是十八不共佛法故。如来应供正等正觉了知胜处。于大众中作师子吼转妙梵轮。余诸沙门婆罗门天人魔梵悉不能转。无与如来同其法者

舍利子。诸住信菩萨得闻如来如是不思议法。闻已当生清净信乐。超越分别离诸疑惑。后复生起身喜心喜。发希有想

    慈悲喜舍品第五之一

复次舍利子。彼住信菩萨。诸佛世尊审知其器堪可任持菩萨藏正法之器。是诸佛法器。如是知已即诣其所。随应为说菩提道法

舍利子。以是缘故。当知住信菩萨是大法器

舍利子。我念过去世阿僧祇劫前。复过无量不思议阿僧祇劫数。尔时有佛出现世间。其名大蕴如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛于其世间天人阿修罗沙门婆罗门等诸大众中。以自通力圆证圣果。为诸大众宣说正法。初善中善后善。文义深远纯一无杂。圆满清白梵行之相。舍利子。彼大蕴如来应供正等。正觉。诸众会中有七十二那庾多声闻大众。皆是阿罗汉。诸漏已尽无复烦恼。心得自在到于彼岸。彼时有国名最胜幢。有大国王名最胜寿。正法治化。国土广大安隐丰乐。人民炽盛。其王有子名精进行。色相端严人所乐观。宿种善根。已曾亲近过去百千那庾多俱胝诸佛如来。恭敬供养

是时太子与自官属。止一殊妙大园苑中。尔时大蕴如来应供正等正觉。知其精进行太子是佛法器。堪可任持菩萨藏正法之器。如是知已即诣园苑。到已尔时处于空中。为精进行太子说菩提道法。彼佛告言。太子此中何名为菩提道。谓于一切众生起慈波罗蜜多。随转摄法。此即名为菩提道

复何名为一切众生慈波罗蜜多。太子所谓菩萨于众生界。行广大慈。彼众生界如虚空界。譬如虚空寥廓广大。菩萨慈心亦复如是。于众生界及众生聚中。无不广大慈心周遍。太子当知。如众生界无有限量。菩萨慈观亦复无量。又如虚空无边际故。而众生界亦无边际。以其众生无边际故。慈心亦复无其边际。太子当知。彼众生界其数广多。非同地界水火风界。今说譬喻以明斯义。显众生界广多无量。太子。譬如东方殑伽沙数等诸世界。南西北方四维上下。周遍十方殑伽沙数等诸世界。而彼一切同一大海。大水充满同一源流。以彼如是十方一切殑伽沙等诸世界中诸众生聚。破为百分。乃至如彼一毛端量举一水滴。次复如前以其殑伽沙等众生数量。为半百分。乃至如彼一毛端量举一水滴。次复如前以其殑伽沙等众生数量。复破半百。乃至如彼一毛端量。太子。如前所说彼大水蕴。以其算数方便。不能比等众生界数无量无边。而众生界无量无边故。菩萨慈心亦复如是。太子。于汝意云何。所有菩萨慈观善根汝可知其量不。太子白言。不也世尊。不也善逝。佛言太子。菩萨摩诃萨慈观善根无量无边亦复如是

复次太子。菩萨慈心能自随护。作他利益。以慈心故于他无嗔亦无懈倦。离诸忿恚息诸过失。不见违顺。表示清净灭诸垢秽。于身语心常生妙乐。蠲除杂染息诸怖畏。善护恚恶起清净意。灭诸斗战不执刀杖。向解脱门离诸损害。所有一切谄曲心意。杂乱词句虚假语言。皆悉远离。顺善财利资养身命。帝释梵王常所恭敬。威德庄严智者称赞。护诸愚者。护持梵行不着欲界。解脱道等一切出生。而善摄受。非所爱乐诸有福行。亦不积集一切胜上诸有福行。而常增长。三十二相八十种好。以为庄严。一切下劣残缺诸根。亦悉遣除。顺向善趣涅盘正道。一切恶趣刹那止息。一切法爱而自喜乐。诸欲受用大富王位。增上适悦悉无爱着。于诸众生起平等心。而行布施离诸异想。一切戒学顺向修习。诸毁戒者善为作护。现忍辱力远离恶魔憍慢等事。发勤精进出离正行。于禅定解脱等持等至。根本烦恼以决定心而求出离。胜慧净因。出生一切慈闻总持。自分他分悉无违害。息除一切魔烦恼分。行住坐卧增长一切妙乐和合。除荡一切不善自性及诸作意。惭愧妙香而常涂饰。消灭一切恶趣障难及烦恼等。常起慈心救护世间。以大慈心弃舍己乐。随与他乐

复次太子。诸声闻人所起慈心但唯自利。菩萨慈心。而常利益一切众生。又复当知。初发心菩萨行众生缘慈。修行位菩萨行法缘慈。得忍菩萨行无缘慈。太子。如是所说皆是菩萨摩诃萨行大慈心。若诸菩萨住慈心者。即能为诸众生行广大慈

佛说大乘菩萨藏正法经卷第十六佛说大乘菩萨藏正法经卷第十七

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    慈悲喜舍品第五之余

复次大蕴如来。告精进行太子言。云何名为菩萨大悲之心。所谓菩萨求彼阿耨多罗三藐三菩提时。以大悲心而为先导。譬如士夫所有命根。以出入息而为先导。积集大乘菩萨。以大悲心为其先导亦复如是。又如转轮圣王以其轮宝而为先导。即能获得诸宝。圆具菩萨大悲为先导故。即能获得一切佛法。是故当知。菩萨大悲于一切众生而不弃舍

复次太子。云何是菩萨于诸众生转大悲心。所谓菩萨观见世间一切众生。坚固执着诸有身见。彼所随逐乃至诸见。而为缠缚。菩萨为说断除执着之法。是为菩萨于诸众生转大悲心。又复菩萨观见世间一切众生。住颠倒处。以无常法计为常想。苦为乐想。无我我想。不净净想。菩萨为说断除颠倒之法。是为菩萨于诸众生转大悲心。又复菩萨观见世间一切众生。颠倒取着诸染欲事。于所生母及诸姊妹起贪染心。菩萨作是思惟。怪哉世间罪业众生。爱着欲境非圣所行。邪行充满。原其所生。居母胎藏次由母产。云何于今反生欲意。姊妹同体出一母胎。岂以染缘共期和合。坏极破坏最极破坏。恣贪嗔痴破毁身心。无智所坏摧灭正法。建立非法行险难法。趣入地狱饿鬼畜生境界。譬如狐群于其夜分入弃尸林中。起恚恶相伺其所食。世间颠倒染着众生亦复如是。又如世间生盲之人。不能瞻视诸有色相堕险恶处。染着众生亦复如是。又如猪群食其残弃不净之物。染着众生亦复如是。以颠倒染缘为染污所坏。入魔境界魔索系缚。欲泥陷没。菩萨为说断除染爱之法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。为五盖所覆。欲箭所射处处爱着。眼见色已着所爱境。耳闻其声。鼻嗅其香。舌了其味。身觉其触。随诸所爱而生取着。苦哉众生违害处多。亲附恶友互求财利。与彼恶友同其知解。得无义利互为损恼。多诸惛沉睡眠恶法。懈倦迷闷。无智随逐起诸恶作。此等众生为客尘烦恼。染污其心起诸疑惑。此等众生不能决定获得最上甚深佛法。菩萨为说断除盖障等法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。起诸慢心。谓慢过慢慢过慢。我慢增上慢卑慢邪慢。如是七慢。一者于劣计胜。二者于胜计等。三者于胜计胜。四者恃所执我。五者计己多德。于增上功德法而起慢心。六者计己少分劣他。七者谓己有德。以慢心故所应称赞而不称赞。所应礼奉而不礼奉。不敬耆宿。于师尊所不能听受。于智者所不能请问。何者是善。何者不善。何者所应亲近。何者不应亲近何者应作。何者不应作。何者有罪。何者无罪。何者是正道。何者是三摩地。何者是解脱。如是等法不能请问。菩萨为说断除一切魔障之法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。爱绳所缚。所谓爱乐男女妻妾财利等事。以爱着故。是即爱乐生死险难三涂恶趣。三有缠缚拘束身心不得自在。以不自在故造诸罪业。菩萨为令彼悉趣向涅盘圣道。宣说正法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。离善知识近恶知识。以近恶故染着十种不善之法。谓杀生偷盗邪染妄言绮语两舌恶口贪欲嗔恚邪见。菩萨欲令一切众生为善知识之所摄受。息除一切不善之业。积集清净十善业道。宣说正法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。痴所覆障。无明黑暗而常随逐。执着我人众生寿者补特伽罗作者受者我我所等。菩萨为令如是一切众生。慧眼清净诸见断灭。宣说正法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。沉没生死不能解脱。五蕴杀者常所杀害。菩萨为令解脱五蕴。超越轮回旷野险难。出离三界。宣说正法。是为菩萨于诸众生转大悲心

又复菩萨观见世间一切众生。作诸不善。如棘刺树虽生无成。造不善业亦复如是。此世他世五趣轮回。不能顺向涅盘圣道。菩萨为其开涅盘门使令趣入。宣说正法。是为菩萨于诸众生转大悲心

复次太子。菩萨如是观察世间诸众生故。以十种相转大悲心。何等为十。一者无谄诳心转。虚空出离故。二者深固心转。能善出离故。三者无虚假神通转。正道出离故。四者无屈曲心转。止诸曲心善出离故。五者真实心转。于一切众生悉无高下平等出离故。六者随护他转。自心清净善出离故。七者坚固慧心转。离动静心而常安住善出离故。八者弃舍己乐转。无爱着出离故。九者随授他乐转。利他出离故。十者荷负众生极重檐转。坚固精进善出离故。菩萨摩诃萨以如是等十种胜相。于诸众生转大悲心。又复菩萨或有众生。应以大乘法得出离者。即起悲心而为出离。此说是为菩萨大悲

又复众生应修布施净戒安忍精进静虑胜慧法者。即起悲心随应出离。此说是为菩萨大悲

又复众生应修念处正勤。神足根力觉道。欢喜根本最胜事业。及次第诸定。乃至十善业道广大章句。随应为转。从悲心起佛自然智。而为饮食资养慧命。此说是为菩萨大悲

又复菩萨自诸所行极善所作。起大悲心。随诸众生应何所作。悉能圆满众生意乐。此说是为菩萨大悲。若诸菩萨摩诃萨。具足如是大悲心者。即能观察众生。悉令获得如是等法。此乃菩萨思惟愍念起大悲心

复次太子。云何是为菩萨喜心。所谓菩萨于诸善法。随所思念适悦欢喜。闻诸善法。不惊不惧不生懈倦。蠲除一切别异心意。安然爱乐一切法乐。心喜身顺。自心清净欢喜意生。睹如来身相好庄严。勤求爱乐增上适悦。听法无倦。依法修行欢喜爱乐。诸来恶语欢喜忍受。随所生起诸欢喜法。于一切众生起无碍心。广为宣说令生胜解。无秘惜心摄伏悭吝。随所求者欢喜而施。面常熙怡摄护毁戒。尊敬持戒常生清净。自所修行得清净已。超越一切恶趣怖畏。欢喜安慰一切众生。诸来恶语起触娆者欢喜忍受。施诸眼目及身分时。欢喜甘忍。心无间断常生悦乐起欢喜心。尊重师长。尊胜己者不生轻慢。面常熙怡含笑先言。离诸颦蹙谄曲心意。杂乱语言欢喜悉除。喜心爱乐诸出离法。仰敬师尊如诸菩萨。顶重正法犹护己身。尊奉如来如惜其命。钦承师范如其父母。爱念一切众生如所生子。遵轨范师如护眼目。敬修行者如护头顶。信受诸波罗蜜多如固手足。重说法师如爱妙宝。勤求正法如重良药。赞奉医王如水上善。太子。如是所说是为菩萨喜心。若住喜心菩萨摩诃萨。于一切时常得欢喜。勤求正法曾无懈倦。起欢喜心修菩萨行

复次太子。云何是为菩萨舍心。所谓舍者。有其三种。何等为三。一烦恼舍。二自他随护舍。三时随时舍。云何名烦恼舍。谓恭敬不高。不恭敬不下。得利无领纳。失利无恼恚。见诸持戒及毁戒者平等其心。称赞不喜。讥谤不恚。毁辱能安。誉美无动。于诸苦法善能决择。于诸乐法常所伺察。随顺不着违害不断。于善恶友住平等心。善作恶作亦复无二。爱非爱境平等而舍。多闻无闻悉无领受。善说恶说都无违顺。安慰过失二俱平等。等心爱念自他众生不惜身命。于上中下一切众生平等照明。于美恶相住平等法。于真妄中自实清净。太子如是所说。菩萨自无种类舍心清净。此说是为诸烦恼舍。云何名为自他随护舍。所谓菩萨当段取身肉。行布施时住于舍心悉无所求。身无所作。语无所作。中亦无动。无眼相无色相。乃至无意相无法相。一切无动。此名为舍。恶作无害亦名为舍。善作无动亦名为舍。自他俱忍亦名为舍。诸所饶益及不饶益住平等心。亦名为舍。无诸诤讼名最上舍。自心决定。亦名为舍。伺察自他悉无所害。菩萨住等引心而行于舍。然菩萨舍。不同诸佛世尊所行舍法。何以故。菩萨摩诃萨。于其舍法现前了知常所修作。于诸善法而常勤求。知时随时而行舍故。云何名为时随时舍。所谓菩萨观见众生非法器者。无闻之者悉住舍心。又于衰毁讥苦一切众生亦住舍心。又于声闻乘法。决定超越而舍。于布施时行持戒舍。于忍辱时。行布施持戒忍辱精进舍。于精进时行持戒舍。于禅定时行布施舍。于智慧时行五波罗蜜多悉圆满舍。此说是为时随时舍。诸所应作及不应作。彼一切法悉住平等。亦名为舍。诸住舍行菩萨摩诃萨。乃至于彼诸善法分悉名为舍。太子。如是所说。皆名菩萨摩诃萨于一切众生起慈悲喜舍之心

尔时世尊释迦牟尼如来。告舍利子言。彼时大蕴如来。为彼精进行太子。说慈悲喜舍法已。即复宣说六波罗蜜多。何等为六。所谓布施波罗蜜多。持戒波罗蜜多。忍辱波罗蜜多。精进波罗蜜多。禅定波罗蜜多。胜慧波罗蜜多。如是宣说诸波罗蜜多。令彼精进行太子。发勤精进如理修行

    布施波罗蜜多品第六之一

复次佛告舍利子。云何名为于波罗蜜多发勤精进。舍利子。若于六波罗蜜多勤精进者。此说是为修菩萨行。其六波罗蜜多者。谓布施波罗蜜多。持戒波罗蜜多。忍辱波罗蜜多。精进波罗蜜多。禅定波罗蜜多。胜慧波罗蜜多。舍利子。诸菩萨摩诃萨。见彼沙门婆罗门贫穷孤露来乞丐者。随诸所欲而悉施与。或乞饮食衣服涂香花鬘及栖止处。或乞病缘医药灯明音乐。妻子奴婢园林台观。金银琉璃砗磲玛瑙珊瑚琥珀摩尼真珠。及余妙宝象马车乘财谷库藏。乃至四大洲主轮王富乐嬉戏等事。至于手足耳鼻眼目身分血肉骨髓。世间所有无不施者

复次舍利子。有十种法。菩萨若能具足清净。当行布施。何等为十。一者菩萨不求艰难受用施。二者菩萨不逼恼众生施。三者菩萨不惊怖他施。四者菩萨无不舍所请施。五者菩萨无现相施。六者菩萨于诸众生无异想施。七者菩萨无损害施。八者菩萨无境土差别施。九者菩萨所施众生而无作意。(少第十法梵本元阙)

舍利子。如是十种法。菩萨若能清净。当行布施

复有十法。菩萨若能具足清净。当行布施。何等为十。一者菩萨不违业报施。二者菩萨无邪意乐施。三者菩萨无不胜解施。四者菩萨无懈倦施。五者菩萨无见面施。六者菩萨无恼害施。七者菩萨无退屈施。八者菩萨无赞誉持戒施。九者菩萨无轻慢毁戒施。十者菩萨不求果报施。如是十种法。菩萨若能清净。当行布施

复有十法。菩萨若能具足清净。当行布施。何等为十。一者菩萨无毁谤施。二者菩萨无违背施。三者菩萨无瑕疵施。四者菩萨无忿怒施。五者菩萨无憎嫉施。六者菩萨无嗔恚施。七者菩萨无不恭敬施。八者菩萨无不自手施。九者菩萨随应止其下劣心施。十者菩萨于所生处无悕望施。如是十种法。菩萨若能清净。当行布施

复有十法。菩萨若能具足清净。当行布施。何等为十。一者菩萨无不坚牢施。二者菩萨无边际施。三者菩萨无分段施。四者菩萨无他信施。五者菩萨不着下劣心施。六者菩萨不求色相受用富贵欢喜施。七者菩萨不求梵王帝释护世诸天等施。八者菩萨不求声闻缘觉地施。九者菩萨不毁谤智者施。十者菩萨所作善利无不回向一切智施。如是十种法。菩萨若能清净。当行布施

佛说大乘菩萨藏正法经卷第十七佛说大乘菩萨藏正法经卷第十八

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    布施波罗蜜多品第六之余

复次舍利子。有十种称赞之法。菩萨若能具足清净。当行布施。此称赞法者。谓即有为出离故得有为果。菩萨应当如是布施。即得十种称赞之法。何等为十。一者施食。获得长寿。二者施饮。息除一切渴爱烦恼。三者施诸乘舆。即能获得诸利乐事。四者施妙衣服。即起惭愧之心如获金盖。五者施诸涂香华鬘。即得戒闻等持妙香涂饰。六者施诸妙香末香。即得身支柔软妙香馥郁。七者施诸美味。即得味中上味。及能圆具人中妙相。八者施依止处。即能当与一切众生为舍为洲为救为归为所趣向。九者施诸病缘医药。即得不老不死甘露妙乐圆满具足。十者若施种种资具。即得菩提分法胜妙资具圆满具足。如是十种布施称赞之法。菩萨求菩提时。当得一切称赞摄受

复有十种称赞之法。菩萨若能清净。当行布施。何等为十。一者若施灯明。即得如来五眼清净。二者若施殊妙歌音。即得天耳清净。三者若施金银琉璃砗磲玛瑙珊瑚琥珀摩尼真珠及余珍宝。即得如来三十二种大丈夫相。四者若施种种妙宝种种妙华。即得如来八十种好。五者若施象马车乘。即得广多人众充满围绕。六者若施殊妙园林。即得禅定解脱等持等至圆满具足。七者若施财谷库藏。即得诸法宝藏圆满具足。八者若施奴婢及营作人。即得所作自在。如佛自然智圆满具足。九者若施妻子眷属。即得最胜可爱无上正等正觉圆满具足。十者若施四大洲主富乐之位。即得菩萨一切善法成一切智圆满具足。如是十种布施称赞之法。菩萨求菩提时。当得一切称赞摄受

复有十种称赞之法。菩萨若能清净。当行布施。何等为十。一者若施五欲妙乐。即得戒定慧解脱解脱知见诸蕴清净。及于一切嬉戏娱乐等事悉得如意。二者若施双足。即得法义足圆具诣菩提场。三者若施二手。即得法手常授于他圆满具足。四者若施其耳。即得诸根圆具无所缺坏。五者若施其鼻。亦得诸根圆具。六者若施身诸支分。即得无过失身如佛身清净。七者若施其眼。即得法眼清净。八者若施血肉。即得一切众生真实身命真实布施善资其命。九者若施其髓。即得金刚坚固不坏之身。十者若施上分头顶菩萨摩诃萨。即得安住三界最胜无上。现证一切智智圆满具足。舍利子。菩萨摩诃萨求菩提时。应如是布施。如是等诸相乃能圆满一切佛法。称赞摄受

舍利子。智者菩萨以其甚深胜慧。不乐世间所乐财物。但为勤求阿耨多罗三藐三菩提。求甘露法。求大觉智。求寂静涅盘。菩萨于其世间一切所乐之物及诸妙乐。无不舍者。一切皆为依止阿耨多罗三藐三菩提故。舍利子。譬如世间耕植之人首欲耘田。先依坚木次设众具。牛以导前。于本上中作耕耘事。营力既成资养身命。彼耕植人以身命存故。金银诸宝亦能成办。至于财谷衣服等物悉能成办。何以故。财不如谷。谷为本故菩萨摩诃萨亦复如是。若依时依处。以世间所乐财物行布施者。即能依止阿耨多罗三藐三菩提。舍利子。又如群生先食青草。次复饮其温凉之水。水食既调。即成其乳。次成其酪。后成生酥。后成熟酥。如是次第悉有所成。菩萨摩诃萨亦复如是。先以世间所乐财物行于布施。即能依止阿耨多罗三藐三菩提。随所乐欲悉能成办。或得成彼转轮圣王。或复成办三种胜相。谓菩萨十地如来十力四无所畏。又复成办千种事业。即得十八不共佛法。又复成办千种事业。得佛六十种清净妙音。又复成办百种事业。即得如来一大人相。又复成办二百种事业。即得如来最上清净乌瑟腻沙顶相。又复成办百种功德妙相。即能圆具如来所有大法螺音。又复成办百种俱胝功德妙相。即得如来鲜白齐密上妙齿相。舍利子。是故当知。如来胜业果报菩萨悉能成办。若能发起一念慈心。诸乞丐者随应布施。即与发彼殑伽沙数等心无异。即能成办佛三摩地。当知诸佛从三摩地起已。如来应供正等正觉于一一毛孔。悉能化现百三摩地所化自在。舍利子。如是如来所有一切神通事业佛法胜相。皆是菩萨宿修大行。以世间所乐财物。奉施如来。以摄受故。求甘露法求寂静涅盘。舍利子。以是缘故菩萨摩诃萨。以世间所乐财物行布施者。即能依止成就阿耨多罗三藐三菩提果

复次舍利子。我念过去世阿僧祇劫前。复过无量无数不思议劫。尔时有佛出现世间。其名福生如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛寿量千岁。佛会之中有百千大苾刍众。皆是大阿罗汉。诸漏已尽无复烦恼。心得自在到于彼岸。是时有一纺线之人。色相端严人所乐见。其人所居。去佛世尊游止方处而复不远。其人于自舍中营自所业。功力办已。于日后分常所出时。即出自舍。前诣世尊福生如来所。到佛所已发清净心。持以一线奉上世尊。作是白言。我今以此一线献奉世尊。愿佛哀愍受我所施。愿我以此善根。未来世中获诸摄法。是时世尊即为摄受。其纺线人从是已后。乃至成佛。如是次第总以线数五百。而奉世尊。由是十五劫中不堕恶趣。又复以此善根。千俱胝生作转轮圣王。又此善根千俱胝生作帝释天主。又此善根当得身分柔软人相可爱。最初修作胜上事业。亲近供养千俱胝佛。尊重恭敬。以香华灯涂饮食衣服幢幡宝盖医药缘具。伸供养已。最后复过阿僧祇劫。当证阿耨多罗三藐三菩提果。名善摄受如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛世尊住寿二十俱胝岁。佛会之中有二十俱胝那庾多大苾刍众。皆是阿罗汉。诸漏已尽无复烦恼。心得自在到于彼岸。有五俱胝大菩萨众。皆悉安住阿耨多罗三藐三菩提。宣说正法。广度无量无数众生。作利乐已入大涅盘。彼佛世尊入涅盘后。正法住世满一千岁。广作佛事。如我今时当入涅盘等无有异。舍利子。汝见如是纺线之人发清净心。以一条线奉施如来。如是次第成办佛法。谓由清净心广大故。舍利子。是故当知。若心不广大复不精勤。即不能得殊胜果报。若心清净以其世间所乐财物而为依止。随力少施。即得一切可爱乐果。又复智者菩萨以增上智力多作胜利。何以故。力广大故。所作无量回向力故

尔时世尊。欲重明斯义。说伽陀曰

  布施不求于色相　　不求受用及富饶
  但求无上佛菩提　　以少施故获多利
  不求名称及善誉　　世间快乐亦无求
  于诸起灭绝悕望　　求佛大果无余法
  饮食衣服及众具　　于一切处悉无求
  如毛端量发施心　　求甘露门常开廓
  凡所行施无高下　　亦无谄曲悭吝心
  是中懈怠悉蠲除　　勇发世间利益事
  若财若谷资身命　　及余一切悉行施
  施已广大欢喜生　　菩提解脱不难得
  父母妻子诸所爱　　来乞丐者皆施之
  所施亦无憎嫉心　　是修最上菩提行
  凡诸所见无忿恚　　恶友常同善友观
  诸怖畏者施慰安　　于诸事法无执着
  不求王位生法欲　　常宣出离正法门
  法施普及诸众生　　利益世间常不舍
  不求天中诸妙乐　　唯求无上佛菩提
  不悕布施大名称　　弃舍己身及余法
  唯佛菩提常不舍　　非眼识色相所求
  亦复不求生诸天　　但求涅盘最上乐
  诸所施作无依止　　若成若坏悉无求
  智者常生正智心　　明了一切正道法

复次舍利子。是故当知。诸菩萨摩诃萨勤行修习布施波罗蜜多。是即广修菩萨胜行

    持戒波罗蜜多品第七之一

复次佛告舍利子言。云何名为诸菩萨摩诃萨修习持戒波罗蜜多是即广修菩萨胜行。舍利子。菩萨有三种法常善所行。何等为三。谓身语意皆善所行。云何身善所行。而菩萨者远离杀生偷盗邪染。此名身业善行。又复菩萨远离妄言绮语两舌恶口。此名语业善行。又复菩萨无贪无嗔正见。此名意业善行。菩萨作是思惟。云何此身语意常善所行。若身不作业。即无杀生偷盗邪染。此名身善行。若语不作业。即无妄言绮语两舌恶口。此名语善行。若意不作业。即无贪嗔邪见。此名意善行。菩萨又复如实伺察。若身语意无作业者。即于诸法何能表了。于身语意何所施设。若青黄赤白红紫碧绿。当何显示。即无眼识表了。无耳鼻舌身意识表了。何以故。以无能生所生能起所起故。若其无者。诸作业中何能施设。菩萨作是思惟已。了知戒相现前无所作。若无所作有何表示。若无表示亦无取着。如是乃名菩萨善行。于其戒相亦无所观。若于戒相无趣向故。即无所观。若如是观即有身见不能生起。若有身见不起。即于持戒毁戒如理伺察而悉不见。若如是观即于戒法轨范境界无所了知。如是持戒于自于他悉无所得。亦无所行。若于自他无所行故。即于戒无毁缺亦无所取。若自他无所得戒亦无所得。若戒无所得即戒学无缺犯。若戒学无缺犯即戒亦无缺犯。如是即戒无所取。何故无取。以一切法无所取故。是故一切法无自亦无他。于无我中当云何取

尔时世尊。欲重明斯义。说伽陀曰

  身业清净语亦尔　　意常清净修净行
  禁戒清净复常行　　此名菩萨持净戒
  十善业道贤复胜　　菩萨智者善所观
  于身语意悉无修　　此名智者持净戒
  无修无胜亦无授　　形色显色而复无
  若无形显色相观　　诸境何能见彰表
  戒若无为无修作　　眼于色境不能观
  耳鼻舌身意亦然　　诸境无能为表示
  根识若无相引发　　悲心应作如是观
  于戒清净戒亦无　　戒中无得而无住
  如是解了无我想　　戒无所护善护戒
  无戒想无戒中修　　菩提行中离诸见
  若于诸见无所观　　无见亦复无知解
  即此无见处亦无　　是中持犯无领受
  若入无护正法理　　戒中轨范不思议
  善能了知真护门　　无戒亦复无所得
  无我想故戒无得　　无我亦复戒中无
  所说常生离怖心　　净戒是为无我语
  戒无领解即无我　　戒所依止亦复无
  无戒无求无我言　　无持无犯无所取
  戒无我故无所起　　无我即能无戒想
  菩提行乃深慧门　　如是戒相得无畏
  诸有缺犯亦无得　　持者皆由圣力增
  诸法无得亦复然　　为愚痴者说持犯
  大哉净戒善护者　　于戒胜果无缚解
  诸见断故罪不生　　三恶趣中皆不堕
  戒无所持无所受　　我见不生即不堕
  于中如是戒了知　　此即无持亦无犯
  若于我法不能见　　于三有中亦无观
  况复持犯有所行　　如是见者善持戒

复次舍利子。菩萨十种善法。从彼清净心意中出。从彼精进胜行中出。从彼最极善欲广大业报信解中出。于圣者所亲近承事。于师尊所不起分别。若圣若师听受正法。勤求无著。志求菩提。不惜身命。舍利子。持戒菩萨。如是十种胜法。皆从菩萨内心中出。若能安住如是十种法者。即能积集一切善法

大乘菩萨藏正法经卷第十八佛说大乘菩萨藏正法经卷第十九

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之二

佛言舍利子。云何名为善法。当知善法厥有三种。谓身语意善所行故。诸菩萨摩诃萨。如是安住善所行者。能于菩萨藏正法。勤求修习即得菩提。而常随逐

尔时世尊。欲重明斯义。说伽陀曰

  身业常当善修作　　此是诸佛所宣说
  随处亲近阿阇梨　　即得多闻善境界
  补特伽罗胜义者　　当起慈心利众生
  语言妙乐无爱憎　　所说闻者生乐欲
  随诸相法无恚恶　　极善意乐悉平等
  修习不生罪欲心　　慈心观察常尊重
  得闻如来净教已　　应当尊重于正法
  由其尊重正法因　　速得成证菩提果

如是十种善法。菩萨能安住已。即于菩萨藏正法勤求修习。亲近承事诸阿阇梨。随诸所作。总略乃至给奉水瓶。复次舍利子。菩萨有十种发心。何等为十。一者菩萨发如是心。痛哉世间一切众生疾恼之身。四蛇奋毒牙相违害。积集诸苦生多过失。痈疽疮癣风癀痰癊起众疾状。眼等诸病历多艰苦。极增违害速疾破坏。是不坚实。羸劣衰朽速趣命终。弃于林中无一可乐。我当令一切众生厌此不坚实身。悕取坚固真实之身

舍利子。此是菩萨第一发心。由发心已。能于菩萨藏正法勤求修习。亲近承事诸阿阇梨随诸所作。总略乃至给奉水瓶

尔时世尊。欲重明斯义。说伽陀曰

  诸界如蛇毒猛恶　　四种互相为依止
  各各咸兴恚害多　　于身广生大病恼
  眼耳二处生诸病　　鼻舌所生病亦然
  唇齿生病苦复深　　及余疾患偏身起
  痈疽初起生疼苦　　疮癣旋生痛剧增
  余诸疾患起多门　　由此于身遍缠绕
  此身既生诸病恼　　积集诸苦在其身
  无义无利损害多　　速疾销亡身谢灭
  一弃林中何所有　　无常迅速不坚牢
  谛观如是臭秽身　　与诸病苦为依聚
  应修贤善诸事业　　当来回作佛身因
  捐弃如是众恶身　　破毁衰残而迅速
  佛身成办圆众德　　不可思议大法身
  回观如是众苦身　　诸漏遍增不可乐
  当知别无诸漏法　　即以此身为漏因
  暂居炎热欲清凉　　或处凝寒思庇覆
  痛哉此身何所乐　　老死常萦损害多
  厌寒怖热恼其心　　一切堕落皆破坏
  智者应修士夫业　　愿得最上真实身
  堪任亲近阿阇梨　　厌弃此身虚幻体

舍利子。此是菩萨第一发心

复次舍利子。二者菩萨发如是心。痛哉世间一切众生不坚实身。断灭摧毁破坏离散。舍利子。譬如世间工巧窑师。造诸瓶器随量大小。虽有所成即归破坏。世间众生虚幻所成不坚实身亦复如是。又如大树枝叶扶疏花果茂盛。虽可爱乐即归堕落。世间众生不坚实身。如成熟果亦复如是。又如清夜露滴草头。日光照触旋有即无。世间众生不坚实身。不久暂停亦复如是。又如世间大海江河流注不断。水中聚沫旋有即无。世间众生身如聚沫不可撮摩亦复如是。又如天雨水滴成泡。旋灭旋生不能暂住。世间众生不坚实身自性劣弱亦复如是。舍利子。菩萨欲令众生厌弃如是不坚实身。悕取坚固真实之身。此是菩萨第二发心

尔时世尊。欲重明斯义。说伽陀曰

  如世巧匠造瓶盆　　杖轮埿等共成器
  一切同归破坏门　　众生寿命亦如是
  又如大树盘根广　　枝叶扶疏花果繁
  一切同归堕落门　　众生寿命亦如是
  又如草端承露水　　日光照灼倏然无
  眼境不停须臾间　　众生寿命亦如是
  又如大海江河水　　水中聚沫劣无坚
  众生虚幻羸弱身　　等彼聚沫皆无实
  又如天雨广流注　　水中旋复起浮泡
  刹那观境即空无　　不坚实身亦如是
  不坚实身生实想　　实中还起不实心
  彼人不入真实门　　此邪思惟妄境界
  实中若作真实想　　不实当生不实心
  彼人得入真实门　　此正思惟真境界
  若起真实心想已　　承事师尊奉水鉼
  回此虚幻不实身　　常得坚固真实体

舍利子。此是菩萨第二发心

复次舍利子。三者菩萨发如是心。痛哉世间一切众生。不能如是思念。我于生死长夜之中。远离善知识。亲近恶知识。发起懈怠下劣精进。邪见所覆痴冥疲乏。无施无爱无诸善作。唯造恶业果报成熟。感诸不善当得身相。贪爱增剧羸瘦憔悴。或生饿鬼趣中。不能活命以火为食。经多百岁多千岁多百千岁不闻水声。何况得饮。我今回发是心。愿当亲近习行善法近善知识。由如是故当得人身。善能活命行诸布施。乃至损弃躯命。亲近承事诸阿阇梨。于菩萨藏正法。勤求修习随诸所作。总略乃至给奉水瓶。此是菩萨第三发心

尔时世尊。欲重明斯义。说伽陀曰

  世间所有善知识　　应当往彼常亲近
  不能数数近善因　　由是不生诸善行
  以其亲近恶友故　　即常远离贤善人
  懈怠下劣精进心　　悭疾谄诳生过失
  不行布施无爱乐　　一切善法不能行
  果熟当招瘦弱身　　或生饿鬼诸境界
  长夜眠伏于生死　　蕴报痴冥怖畏多
  饮食俱无饥渴增　　备受广多诸苦恼
  经历多百千岁中　　渴苦不闻水之声
  布施善道不复观　　不得世间诸善相
  我今回发如是心　　世间人身极难得
  誓愿亲近阿阇梨　　速获圆满诸善行
  常当远离恶知识　　常得亲近贤善人
  捐弃身命不为难　　愿作菩提胜根本
  于阿阇梨起尊重　　恭信发生清净心
  顶奉承事我所行　　愿作菩提胜根本

舍利子。此是菩萨第三发心

复次舍利子。四者菩萨发如是心。世间众生应如是念。我于长夜中。远离善知识亲近恶知识。发起懈怠下劣精进。痴冥疲乏无忍无爱。无诸善相。心困身倦如被打击。众苦逼迫娆乱众生。若无彼缘宁招罪至。由是广造诸不善业。以其不善之业果报成熟。当堕牛畜驼驴趣中。不能活命。于彼趣中以草为食。咀嚼[齒*齊]啮捶打怖畏负重困苦。远离一切施等善相。我今回发是心。亲近善友当得人身。不惜躯命广行布施。作诸善业。亲近承事诸阿阇梨。于菩萨藏正法。勤求修习随诸所作。总略乃至给奉水瓶。此是菩萨第四发心

尔时世尊。欲重明斯义。说伽陀曰

  众生长夜居险恶　　于诸圣道不了知
  驼驴畜类趣中生　　备受广多诸苦恼
  当来若得人身相　　广作贤善诸事业
  趣向菩提正道门　　此是智者之胜相
  我当发起尊重彼　　已能善住佛法者
  奉阿阇梨教诲言　　愿作菩提胜根本
  过去不思议劫中　　于生死轮循环转
  遍历无义无利门　　不能修作布施行
  处世不能自活命　　懈堕远离善知识
  常随恶友教诲言　　随转还归恶趣地
  相续驼驴中杻械　　系缚拘絷捶打身
  远离善友果报成　　牛畜趣中业不坏
  驼驴趣类受生已　　连环执缚苦恶深
  杖木鞭笞负重多　　善友尔时难亲近
  人身最极为难得　　善友亲近亦复难
  刹那亲近善功成　　历久能扳诸艰苦
  若能善修身语业　　精进远离诸过失
  心安命活众所行　　我乃亲近善知识
  奉阿阇梨无谄曲　　从是我发菩提心
  菩提圣道广宣扬　　遵仰师尊常爱重
  涂香种种妙香等　　众妙衣服及末香
  异品庄严宝花鬘　　二足圣尊伸供养
  十方现住一切佛　　开示胜义利众生
  普放金色大光明　　无边色相为供养
  如佛所放妙光已　　广供人中调御尊
  菩提正道清净因　　诣菩提场愿证果

舍利子。此是菩萨第四发心

复次舍利子。五者菩萨发如是心。世间众生应如是念。我于长夜中。远离善知识亲近恶知识。发起懈怠下劣精进。痴冥疲乏无忍无爱。无诸善相都无所念。痛哉世间一切众生不能思念。一切物命同一身肉。若存若坏其肉无异。食啖之者。谓之无罪亦无罪相。谓之无福亦无福相。乃至海岸边极辽夐之方。诸有众生其见无异。无罪无福。由此缘故。若罪若福不能了知。以不知故。近恶见者增长痴暗。不知善道唯造罪业。以其广造不善业故。果报成熟得下劣身相。乃至堕在地狱趣中。受地狱苦吞热铁丸。考掠捶打。杻缚悬吊。将趣死边业还令活。经多千岁不闻乐声。何况乐触。斯由不知罪福不造施因。智者应念。我今回发是心。亲近善友。当得人身。不惜躯命。广行布施作诸善业。亲近承事诸阿阇梨。于菩萨藏正法。勤求修习随诸所作。总略乃至给奉水瓶。此是菩萨第五发心

尔时世尊。欲重明斯义。说伽陀曰

  为由亲近诸恶友　　恶心欺诳于他人
  罪业邪见为所依　　故我广兴于罪业
  边极辽夐众生类　　恣啖饮食无足心
  皆谓罪福悉无因　　亦无苦楚诸报应
  此等如是罪业见　　数数亲近于恶友
  一向艰恶罪殃深　　由斯速堕于地狱
  纵得人身经千转　　旋堕三种恶趣中
  不见正等正觉尊　　出现世间堪归向
  所有世间善知识　　极善名称悉不闻
  我若当来得人身　　广修贤善诸事业
  世间人身最难得　　众生寿命亦复难
  如来正法极难闻　　诸佛出世实难值
  纵得人身斯难者　　速得圣道转复难
  我若值佛出兴时　　遵一切智清净教
  所有身语意三业　　发起一切诸过罪
  于不究竟苦果中　　誓愿不复还修作
  若复内心清净故　　罪业因果亦复然
  于不究竟苦果中　　如彼内心皆清净
  所有极善身语意　　世间无智诚难作
  唯除亲近阿阇梨　　愿作菩提胜根本
  当知正道名圣道　　如其意乐善宣说
  当入无诳精进门　　作佛菩提胜根本
  菩萨如是发心已　　顶重师尊给水瓶
  智慧方便即圆成　　是为菩萨广大行

舍利子。此是菩萨第五发心

复次舍利子。六者菩萨发如是心。世间众生应如是念。我于长夜中。远离善知识亲近恶知识。无善乐欲。于师尊智者。不能谦下恭信百种称赞亲近礼奉诚谛合掌作诸善业。但以慢心增长。造多不善。由其所作不善业因果报成熟。纵得人身。羸瘦憔悴不能活命。不能行施。虽生人中其性悭吝。加复贫困。或作奴仆。为他所使他所系属。如耽欲飞禽于空中行。随所住处惊怖艰险。邪见众生亦复如是。破毁净戒。而常习行三不善根。在四趣中。五盖所覆。常行六种。不能尊重师长之法。于其七种善妙正法。不能遵奉。起八邪法入邪定聚。于九恼处常起恼害。常行十种不善业道。于非道中坚猛而入。向地狱门背生天道。远善知识近恶知识。顺魔意乐舍离善法。行不善法。打击怖畏艰苦随生。施作种种不饶益事。以是缘故不能爱乐行布施等。我今回发是心。亲近善友当得人身。不惜躯命广行布施。作诸善业。于菩萨藏正法。勤求修习随诸所作。总略乃至给奉水瓶。此是菩萨第六发心

尔时世尊。欲重明斯义。说伽陀曰

  近恶友故增憍慢　　亲近还经多劫海
  人中若受奴仆身　　长夜轮回于三有
  难得人身历艰苦　　最上身相极难得
  善妙色相亦复难　　诸佛出世极难值
  我当亲近贤善友　　显示菩萨正行道
  菩提心宝广大增　　多俱胝劫愿获得
  身不坚牢如泡沫　　复如幻化歌戏等
  如其所见在梦中　　觉了无实悉虚假
  寿数将尽命促少　　犹如云电不久停
  刹那命尽转蕴时　　舍不实身求实体
  时分转易迅速住　　当须摧堕憍慢山
  虚假和合三世中　　漂流不思议劫海
  弃舍于身离诸爱　　于其寿命亦无惜
  蠲除憍倨我慢心　　顶重师尊常承事
  世间师尊极胜上　　如其父母等无差
  息除憍倨我慢心　　尊重精勤奉诸作
  菩萨无上菩提分　　菩萨胜行同分者
  爱乐尊重坚固心　　愿诸所作皆勤勇
  慢爱行时慢增长　　除断慢法不能知
  由智金刚碎无余　　大憍慢山皆摧堕
  令他修胜菩提行　　最胜安处菩提场
  正法摧伏诸魔军　　救度四生烦恼众
  十方一切病苦者　　不能自厌不净身
  我当发起慈悲心　　愿作三世所归趣
  广行布施波罗蜜　　复能学佛戒功德
  谛观忍辱行周圆　　我发精进最上道
  圆具禅定波罗蜜　　随心所起善安住
  胜慧方便亦复然　　愿奉师尊修施行
  增长此诸福威力　　不可思议智慧善
  自他意乐悉尊高　　修学圆成真法器

舍利子。此是菩萨第六发心

佛说大乘菩萨藏正法经卷第十九佛说大乘菩萨藏正法经卷第二十

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之三

复次舍利子。菩萨发如是心。世间众生应如是念。我于长夜中。远离善知识亲近恶知识。发起懈怠下劣精进。痴冥疲乏如喑哑人。无见无忍亦无善爱。无恶业恶报。无善业善报。无杂业杂报。既不自知。亦复不能请问沙门婆罗门诸阿阇梨。何者是善。何者不善。何者有罪。何者无罪。何者所应亲近。何者不应亲近。何者所应作。何者不应作。何者作已。于长夜中无义无利。生诸苦恼。由是我慢增长。不能了知善业根本。唯造一切不善之业。纵得人身诸根残缺。又于人中不能活命。不能行于布施。又于人中。盲聋喑哑无诸色相。善说恶说悉不能知。由如是故不乐布施。我今应当回发是心。亲近善知识。若得人身诸根完具。能活其命。习行布施不惜躯命。具诸色力。善说恶说悉能了知。复能请问师尊智者。何者是善。何者不善。何者有罪。何者无罪。何者所应亲近。何者不应亲近。何者诸所作时。违背声闻缘觉之法。顺向菩萨藏义。亲近承事诸阿阇梨。随诸所作。厌此不真实身。悕取坚固真实之身。总略乃至给奉水瓶。此是菩萨第七发心

尔时世尊。欲重明斯义说伽陀曰

  欲近善友作利益　　我乃远离多百劫
  不能请问善恶门　　有罪无罪果报等
  增上慢心堕地狱　　傍生饿鬼诸趣中
  亲近罪业诸友朋　　多劫历苦而无尽
  纵得人身根残缺　　多千劫中受轮回
  不能了知善恶门　　有罪无罪果报等
  若得人身离艰苦　　诸根完具善相圆
  人相完具离难时　　如一眼龟值浮木
  得睹世间灯照曜　　佛教中闻无染法
  尔时请问世间尊　　诸善不善果报等
  悭者云何所趣向　　何不悭者能行施
  贪谄毁戒复云何　　又何不破净戒者
  云何恚恶心无动　　云何懈怠散乱心
  精进禅定乐云何　　恶慧痴冥何所为
  云何得彼真实慧　　云何菩提行方便
  六种贤行竟云何　　慈心广大世间胜
  恶趣众生云何救　　云何乐法心无厌
  菩提行藏广勤求　　十方刹中善安住
  云何亲诣世间尊　　云何礼奉营诸福
  普贤行门复云何　　如我今时善亲近
  云何请问阿阇梨　　愿闻师尊尊重事
  生阿阇梨欢喜心　　此心生已真佛子
  福力智力为增上　　是中所成广大智
  智力增强发胜心　　给奉水瓶生欢喜

舍利子。此是菩萨第七发心

复次舍利子。菩萨发如是心。世间众生应如是念。我于长夜中。远离善知识亲近恶知识。发起懈怠下劣精进。痴冥疲乏如喑哑人。所有世间一切文句。与义句合。与法句合。法句合故。住于寂静与离贪合。寂灭正智。与沙门婆罗门涅盘同住。于一切处所。作我乃弃舍。不能了知文义句合。乃至不与涅盘同住。亦复不能受持读诵。亦复无力。又无精进无士夫力用。无士夫势。无士夫勤勇。无最上精进。无因无缘。诸众生烦恼亦无因无缘。众生杂染无因无缘。众生清净无因无缘。此等无因依止诸见。不能了知所作善业。唯造恶业。纵得人身诸根残缺。又于人中不能活命不能行施。痴迷所覆盲聋喑哑无诸色力。不能了知文义句合。乃至不与涅槃同住。亦复不能受持读诵。由如是故不能亲近习行善法。我今应当回发是心亲近善法。乃至不惜躯命了知文义句合。于出离道涅槃同住。于菩萨藏正法。勤求修习受持读诵。发勤精进。亲近承事诸阿阇梨。于菩萨藏正法。受持读诵厌此不真实身。悕取坚固真实之身。福智胜力当得圆具。以福智力得圆具故所作惯习。而能积集菩萨藏正法。亲近承事诸阿阇梨。随诸所作。总略乃至给奉水瓶。此是菩萨第八发心

尔时世尊。欲重明斯义。说伽陀曰

  所有法义相应故　　于正道分修道行
  寂灭理中作证门　　而涅槃道得真实
  若于此法远离者　　即于诸法无所利
  无义利句设相应　　不能亲近彼正法
  无力亦复无精进　　士夫势用悉皆无
  无他勤勇亦复然　　于一切处无所得
  即见无佛亦无法　　无父无母及宗亲
  由斯善恶业皆无　　一切皆无诸报应
  此诸如是罪业见　　数数亲近罪根深
  一向艰恶日增多　　堕地狱中经久远
  地狱出受傍生报　　饿鬼趣中罪复深
  其后纵得人中生　　聋騃痴冥而无舌
  余业复受喑哑报　　痴暗缺漏苦还增
  而复重受地狱殃　　由不了故当坠堕
  经历久时后当得　　人身具足善相圆
  诸根既具胜力增　　依时净住而思忖
  若于诸法义相应　　即得同归出离道
  修菩提道证菩提　　我当思惟如是事
  所有诸大菩萨藏　　和合甚深正法义
  经历俱胝千劫中　　发生净信极难得
  若此若余广多数　　诸佛妙法不思议
  随诸修作能受持　　为佛菩提胜根本
  我当亲近及承事　　尊重信奉阿阇梨
  诸佛菩萨亦复然　　即得最上清净信
  发生如是净心已　　即是菩萨广大心
  胜慧方便悉圆成　　给奉水瓶常精进

舍利子。此是菩萨第八发心

复次舍利子。菩萨发如是心。痛哉世间一切众生。以其爱着于身命故。常为一切无义利行颠倒随逐。何者名为无义利行。谓彼众生爱着身命。不能爱乐菩提分法。以其我见而为先导。执着心坚痴冥所覆。摧毁破坏众事随逐。此说是名无义利行。又复众生爱身命故。以其我见而为先导。爱恋妻室男女知识以爱着心隐覆痴暗。远离诸饶益事。此说是名无义利行。又复众生爱身命故。以其我见而为先导。顾惜奴婢作事人等詹视防护。此说名为无义利行。复次世间一切众生有义利行。常所随逐者。谓若众生不惜身命。爱乐菩提分法。以菩提心而为先导。善修身语意业。此说名为有义利行。又复众生不惜身命而常爱乐菩提分法。以菩提心而为先导。积集布施波罗蜜多。乃至积集般若波罗蜜多。此说名为有义利行。又复众生不惜身命。而常爱乐菩提分法。以菩提心而为先导。行布施爱语利行同事。普摄一切众生。此说名为有义利行。又复众生不惜身命。而常爱乐。菩提分法。以菩提心而为先导。修习念处正勤神足根力觉道胜菩提分。此说名为有义利行。又复众生不惜身命。而常爱乐菩提分法。以菩提心而为先导。听受父母及阿阇梨诸有教诲。礼拜赞叹恭信合掌奉诸所作。此说名为有义利行。又复众生不惜身命。而常爱乐菩提分法。以菩提心而为先导。常以净心营三宝事。此说名为有义利行。又复众生作如是念。我以惜身命故。无义利事常随逐我。我当发勤精进。亲近承事诸阿阇梨不惜身命随诸所作。厌此不真实身。悕取坚固真实之身。福智胜力当得圆具。以圆具故。所作惯习悉能成办。诣菩提场当证圣果

舍利子。此是菩萨第九发心

尔时世尊。欲重明斯义。说伽陀曰

  若人爱惜身命故　　菩提分法不爱乐
  三不善业造圆成　　此乃愚夫异生类
  爱乐己身及妻室　　并诸男女眷属等
  此无义利执着心　　旋转三界愚痴者
  又于奴婢作业人　　不觉了心常顾恋
  此无义利爱着深　　资生蓄养四足等
  广多聚积诸财谷　　不自受用不与人
  此无义利爱着深　　秘护伏藏不彰显
  此无义利染着故　　彼愚夫心常爱惜
  返于菩萨善意中　　弃舍不能生爱乐
  若能不惜于身命　　爱乐菩提胜分法
  三种善业造圆成　　此即名为有义利
  施戒忍辱及精进　　禅定胜慧亦复然
  与彼方便行相应　　此即名为有义利
  承事父母为先导　　遵奉师尊亦复然
  审谛思惟三宝门　　此即名为有义利
  诸大菩萨甚深藏　　普摄一切胜法门
  受持诵念广宣扬　　此即名为有义利
  此有义利诸胜行　　乃是诸佛亲所宣
  如其所说义相应　　是名佛子广大行
  发生如是大心已　　复起清净谛信心
  亲近承事阿阇梨　　给奉水瓶随诸作

舍利子。此是菩萨第九发心

复次舍利子。菩萨发如是心。痛哉世间一切众生。不能如理调伏心意。违背阿阇梨所有教诲。彼人不得阿阇梨财。何者名为阿阇梨财。所谓信财戒财闻财舍财慧财惭财愧财。如是七法名阿阇梨财。由其不得如是财故。当受贫苦逼恼其心。智者应当善调伏心。随顺阿阇梨所有教诲。习行布施作诸善行。何以故。若能善调伏心。随顺教诲。修布施行。彼人即得阿阇梨财此复何名阿阇梨财。谓得菩萨藏正法。普摄一切菩萨胜行善调伏法。如是知已。当于菩萨藏正法。勤求修习广为他人宣布演说。若能安住菩萨藏者。即得毕竟断除贫苦。趣向阿耨多罗三藐三菩提。如是发心已。即能随顺阿阇梨教。行布施等。厌此不真实身。悕取坚固真实之身。亲近承事诸阿阇梨。随诸所作。总略乃至给奉水瓶

舍利子。此是菩萨第十发心

尔时世尊。欲重明斯义说伽陀曰

  所有难调诸众生　　内心谄诳复险恶
  违背师尊教诲言　　不能堪任谛忍受
  此难调伏既知已　　应当随顺师教诲
  如其教令所宣扬　　即得大仙圣财宝
  所谓信财及戒财　　闻财舍财亦复然
  其中最胜曰慧财　　惭愧等财为七种
  了知如是圣财已　　七种伏藏用无尽
  其中若或不能知　　此即名为非法器
  若是法器众生者　　彼即圆具诸佛法
  无谄善调可称扬　　发勤精进修施行
  胜妙法欲心尊重　　损弃身命不为难
  修佛菩提法器成　　知已修持常无间
  法界平等无差别　　佛调御尊亲所宣
  此菩萨藏正法门　　能于菩提善安住
  如其所说广大法　　即是诸佛真实财
  为一切法无我门　　无相亦复无空相
  无其寿命无作者　　亦无戏论无含藏
  于一切法自性中　　无生无相本如是
  诸法无成亦无坏　　谛观诸法本无相
  善调伏者如教行　　随诸教令善修作
  若得见佛自然智　　随自境入解脱门
  如其信财及戒财　　闻舍惭愧慧等七
  如是圣财无上宝　　七法圆成用无尽
  闻其法藏广施门　　善调心意皆随顺
  于诸善友常亲近　　一切善行常修作
  顶重无上大菩提　　勤行诸法亦如是
  发生如是胜心已　　如渴思饮而无懈
  清水盈满净器中　　广大爱乐心献奉

舍利子。此是菩萨第十发心。由发心已。即于菩萨藏正法勤求修习。亲近承事诸阿阇梨。随诸所作。总略乃至给奉水瓶。由此最胜善根力故。修菩萨行者。得四种法。何等为四。一者如阿阇梨所说。速得一切善法。二者随顺阿阇梨言。三者修行速得成办。四者圆满修行法因

复次舍利子。修菩萨行者。生于人间得四种法。何等为四。一者教授多人。一切善法随能安住。二者居岩窟处。得彼多人众皆欢喜。三者以广大心。于昼夜中多人咸诣。四者无所发起。趣命终已得生天界

复次舍利子。修菩萨行者。生于天中得四种法。何等为四。一者得彼天众与最上座。二者一切所向得彼天众观其面相。三者随有所说领受解了。四者时诣帝释天主之处。请决所疑而不诣彼余天众处。天中得彼宫殿受用。舍利子。修菩萨行者。生彼天中得如是等四种之法。若生人中亦得无量百千法门

尔时世尊。欲重明斯义。说伽他曰

  天中得彼高胜座　　复得天众常恭信
  一切天众所观詹　　如是常闻善说法
  一切所作皆智者　　问法帝释无吝心
  殊妙宫殿得彼天　　天中没已来人界
  复得人中胜生处　　作转轮王统四洲
  人中没已即还生　　于彼天中受胜乐
  天界不复经苦受　　顶重师尊此为因
  如是四种胜妙门　　常得如是广大事
  由起如是无著心　　顶奉师尊善所作
  以清净心给水瓶　　爱乐尊重常无倦
  又得一切天人龙　　所应供养常尊奉
  于彼所生天界中　　亦复得其四种法
  云何名为四种法　　先所作业悉能知
  积集善行及善因　　现生所作常无减
  又复由其善法故　　而悉了知生灭处
  现生无动亦能知　　是故了知诸法行
  能为诸天广宣说　　依法显示及教诲
  广作利喜胜行门　　然后还从天界没

复次舍利子。修菩萨行者。得四种法(此中文标四法只有一二阙其二四梵本元无不可添足)何等为四。一者天中没已来于人间。同禁戒者同分中生。二者生人中已于现生中得五种悲法。何等为五。一者现生得于善法中生。二者现生仪相具足。三者现生净戒圆满。四者现生眷属广多。五者现生于诸众生起慈心观

又复当得五种不破坏法。何等为五。一者善友知识常不破坏。二者身不速坏。三者富乐受用常不破坏。四者所发菩提心坚不能坏。五者于饥馑时法乐丰熟

又复当得五种希有之法。何等为五。一者以空瓶器置于一处。自然有其清净水满。水中盈积诸妙珍宝。二者渴须水时自然有其八功德水出现于前。三者身中离诸灾难。所谓若毒若刀若火若水若饮伏威光若吞啖怖畏。四者若值刀兵劫时。疾疫劫时。饥馑劫时。火灾劫时。水灾劫时。风灾劫时。渴乏劫时。灾热劫时。夜叉难时。现生阎浮提中者。即得天界中生受诸快乐。所受妙乐如金刚嬉戏。此是希有之法

佛说大乘菩萨藏正法经卷第二十佛说大乘菩萨藏正法经卷第二十一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之四

复次舍利子。五者修菩萨行者。以此善根于现生中离诸障难。于现生中不堕恶趣。恶作不能扰动其心。速得出离。如是五种希有之法。修菩萨行者。以善根力故皆得圆满

复次舍利子。以此善根力故。又复获得四种不离等引之法。何等为四。一者菩萨同其见者。于诸苦恼众生咸起大悲之心。二者所有男女眷属皆生尊重爱乐之心。三者老相逼来渐加衰迈。然其善力势分还增。四者所得财利百倍渐增一至于三

又复获得三种无损害法。何等为三。一者贪无损害。二者嗔无损害。三者痴无损害。又复获得四种安乐之法。何等为四。一者长时离诸病恼。二者身不枯悴。三者受用无诸阙乏。四者不为王难及盗贼难并余诸难而来逼恼

又复获得四种尊重之法。何等为四。一者为转轮王统四大洲。正法治化七宝具足。七宝所谓轮宝象宝马宝珠宝女宝主藏臣宝主兵臣宝。千子围绕各各勇健。悉具无畏最上色相。能伏他军。而四大洲所行所作。皆顺王化。辅弼大臣及诸小王。乃至国城民庶。咸悉尊重而皆信奉。二者于其七欲乐中不极耽爱。五欲所谓眼观色。耳听声。鼻嗅香。舌了味。身觉触。于斯五境受而无著。发净信心爱乐出家。速疾获得五种神通。得人非人常起尊重。三者在在所生。一切最胜。智胜慧胜王神通胜。此由过去世中修诸善行具大名称得转轮王最上之座。辅弼臣佐国城民众。于一切处常起尊重。四者乃至证成阿耨多罗三藐三菩提果最尊最上。于其一切天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽人非人等大众之中。而为高胜。修习戒定慧解脱解脱知见。如是法中亦复高胜。又能成就戒定慧解脱解脱知见法中高胜。如是四种尊重之法。谓由尊奉阿阇梨师长。随诸所作给奉水瓶。积集此等无量功德。以其摄受法故。成法利故。若来若去。如其所说不生违背

又复以此善根。获得四种缘具之法。何等为四。一者得王缘具。王缘具者即是仙中缘具。二者弃舍欲乐。发生净信爱乐出家。此说即是法之缘具。三者修菩萨行者。在在所生。若此生若他生及一切生。悉得宿命智通。而常不舍大菩提心。此说即是念缘具。四者乃至证成阿耨多罗三藐三菩提果。四众围绕尊重恭信。乃至一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。而常围绕尊重恭信

又复修菩萨行者。于阿阇梨所。乃至受得一四句偈。如阿阇梨指诲。言来即来。言去即去。此是善根。此是不善根。此是有罪。此是无罪。此所应亲近。此不应亲近。此所作时为无义利生诸苦恼。此所作时利益安乐。如其所说不善不作。善法当作。无诸障碍亦无违背。以此善根得圆具者。获得四种高胜之法。何等为四。一者净戒高胜。二者身相高胜。三者身相圆满。四者得大慧根。得速疾慧猛利慧极迅速慧甚深慧善决择慧。身坏命终得生天界

又复获得四种不可观法。何等为四。一者获得内藏秘密。二者以善根力故。所有父母及余知识。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。以清净心。而悉不能观见修菩萨行者所有顶相。三者以善根力故。随诸所作。所有父母知识乃至人非人等。以清净心或不清净心。而悉不能观见修菩萨行者。所有面门及二足门。何以故。彼不能观者。谓以菩萨希有相故。具士夫相故。士夫语言故。四者修菩萨行者。以具善根力故。菩萨生时不假扶持。即自于地安然伫立。遍观四方得最上智。何以故。谓以菩萨于先世中。历修无谄多闻圣道。得无谄眼根无谄眼境。乃至遍观三千大千世界。皆悉睹见而无障碍。天眼清净超过人眼。菩萨已得速疾大智。以其大智得圆具故。菩萨于一切众生所爱乐心。悉能了知。所以者何。以其菩萨先世所作善能摄受一切心故。尊重犹如圣妙药想诸珍宝想极难得想。如所说善道诸众生想。正法出生而善闻持。是故菩萨获得如是善决择智。由其具此决择智故。菩萨与一切众生净戒同等。乃至闻定慧解脱解脱知见同等。戒和合同等。乃至闻定慧解脱解脱知见和合同等。一切众生戒无动同等。乃至闻定慧解脱解脱知见无动同等。以一切众生戒无动同等故。即一切众生戒无动增长亦复同等。乃至闻定慧解脱解脱知见无动增长同等。一切众生威仪道行修行精进同等故。即一切众生互相推求。而一切众生所有戒闻定慧解脱解脱知见和合。所有一切众生戒等无动。一切众生戒等无动增长。一切众生威仪道行修行精进。总摄一切福蕴。于一切处诚谛推求平等。平等亦无平等可见

又复于其一切最极根本之处。一切众生互相推求所有我相平等。平等亦无平等可见。由是修菩萨行者。于刹那间速得一切业报。成就智生。于弹指顷。了知一切众生千种心行。如是一切推求我相而悉平等。平等亦无平等可见。住最上处了知我空。是故菩萨。如师子如大龙。初生履地即行七步。发菩提场胜果报故。一心清净肃恭住已。作如是言。我于天上人间最胜最上。我能为诸众生宣说极尽生老病死毕竟边际逼恼之法。舍利子。然后若诸菩萨若诸如来。即于三千大千世界。出净妙音显示一切。尔时大地普遍震动。皆生惊怖身毛喜竖相续自然天鼓音乐。而彼地方菩萨立时菩萨行时。皆悉震动光明出现。妙色相身乘光而住。凝然不动。而彼一切悉能瞻见。乃至成证阿耨多罗三藐三菩提果。一切众生悉不能见。此是第四不可见法。如是四种不可见法。皆由菩萨昔于阿阇梨所谛受诲言。若往若来随诸所作。以是善根力故。获得如来四种迅速之法。何等为四。一者随顺听受诸佛世尊。无虚假言宣说正法。二者以善根力故。佛自宣言。善来苾刍。即时须发自落袈裟着身。执持应器成苾刍相。三者以善根力故。如来于三时中了知一切众生心意。四者智起善解。胜妙方药拔除一切众生病苦

又复以其善根力故。获得四种无过失法。何等为四。若言如来有其火风刀毒四种难者。无有是处。又复获得四种无过失法。何等为四。一者若言如来能使无闻众生而听正法。及痴闇众生受法句者无有是处。二者不住等引心者。能令一念发心。无有是处。三者如来常住等引心中。若言不行慈悲喜舍。无有是处。四者若言如来普能摄受一切众生身色相者。无有是处

又复获得如来五种胜无量法。何等为五。一者如来戒闻无量。二者定无量。三者慧无量。四者解脱无量。五者解脱知见无量

又复获得四种愿智之法。何等为四。一者过去世中诸佛世尊无著无碍知见随转。二者未来世中诸佛世尊无著无碍知见随转。三者现在世中诸佛世尊无著无碍知见随转。四者如来不思议门之所成办。以不思议门故即具三世平等正等正觉之智。而正等觉智者不系属他。以是不思议智如来悉能了知诸法。若具如是不思议智。即能了知世间一切风雨等事。世间有风名曰顺次。其风吹鼓世间众生。是风高起三俱卢舍。盘旋空中。又复有风名曰如云。吹鼓世间。是风高起五俱卢舍。盘旋空中又复有风名曰痴冥吹鼓世间。是风高起十踰膳那。盘旋空中。又复有风名虚空相。吹鼓世间。是风高起三十踰膳那盘旋空中。又复有风名曰如来。吹鼓世间。是风高起四十踰膳那。盘旋空中。舍利子。如来应供正等正觉慧所摄故。能知六十八千俱胝风轮事相。西方有风名曰周广。吹鼓世间。是风高起六十八千踰膳那。住于大地水轮之中。从水轮起。复高六十八千踰膳那。舍利子。如前所说。过是算数三千大千世界。大蕴如来应供正等正觉。现住说法教化众生。其佛寿量三十俱胝岁。有三十俱胝那庾多大声闻众。皆是阿罗汉。诸漏已尽无复烦恼。乃至心得自在到于彼岸。有百俱胝大菩萨众。皆是已得住菩萨藏者。解决定义宣说多闻甚深法海者。善修空无相无愿。胜行之者。佛住千岁之后。入大涅盘。佛涅盘后正法住世经百千岁。其后所得如来舍利。广大流布。如我今时涅盘之后。舍利流布亦复如是。舍利子。如来无碍圣智最上无量。如来智风曼拏罗广大圆满。诸佛刹土亦悉圆满。舍利子。上方有世界。今无佛出世。彼有千缘觉众。现住教化众生。于彼种植善根智所摄故。舍利子。智所摄故如来不独了知。上方殑伽沙数等如来应供正等正觉现在说法者。所有十方无量不可数不思议无等比。如来应供正等正觉。现住说法者而悉能知

尔时。尊者舍利子前白佛言。世尊。修菩萨行者。植何等善根。而能圆具如来应供正等正觉如是无障碍智。佛言。舍利子修菩萨行者。若能善调伏心。起尊重想。从法出生圣妙药想。大珍宝想。极难得想。胜善根想。如所说想。极尊重想。摄受正法想。应当如是勤勇修进。舍利子。如来广多胜智。最上最胜无所断智。无量无数不思议无等比不可说。于一弹指顷。所有十方殑伽沙数诸佛刹土。若来若去若行若住。悉得解脱。舍利子。我所得解脱从闻持故速得解脱。极解脱者谓善解脱。何所解脱。谓解脱一切苦故。舍利子。若人闻是所说起尊重心。是人于所闻间。即能发生清净信心。如闻所住常得不离诸佛正法。随何等相名句文义。此等正法即能受持。以此善根殊胜力故即得四种胜慧之法。何等为四一者获得大慧。二者以胜慧故。而得见佛亲近摄受。三者以胜慧故净信出家。四者以胜慧故成证阿耨多罗三藐三菩提果。此是四种胜慧之法

又复获得四种无碍之法。何等为四。一者得生人中而无障碍。二者值佛出世亲近信奉而无障碍。三者净信出家而无障碍。四者成证阿耨多罗三藐三菩提果而无障碍。如是四种无碍之法

又复获得四圣分法。何等为四。一者得转轮王具胜金轮。二者得大梵王统于梵世。三者得帝释天主。四者成证阿耨多罗三藐三菩提果。而得圆满了知神通境界天上人间得真实眼

佛说大乘菩萨藏正法经卷第二十一佛说大乘菩萨藏正法经卷第二十二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之五

尔时世尊。说是义已。复增教示诸大菩萨摩诃萨众。说伽陀曰

  应观世间能救护　　一切有情最胜因
  诸无边智悉了知　　获得涅盘无量乐
  往来殊胜获妙果　　永断世间诸苦因
  遍善调伏生天中　　刹那远离诸恶趣
  我今速得见诸佛　　远离一切苦难因
  世间伏藏无有边　　随意自在悉获得
  一切资财与珍宝　　随念应现于世间
  八功德水亦复然　　河沙池沼悉澄湛
  免离种种丑陋因　　一切不生诸苦恼
  聋盲癞病等因缘　　善调伏者获妙果
  所有世间诸患者　　若完若缺众生类
  背伛癵躄矬陋形　　诸染着故悉减没
  远离一切异类相　　当获最上殊胜报
  面貌具足悉圆美　　善调伏者得妙果
  色相端严大名称　　诸天咸来伸供养
  八部皆生恭敬心　　一切有情亦如是

复次善调伏者得此果利。除灭一切诸恶趣已。然后得生诸天界中。速疾成就大菩提果。善调伏者得此果利。善解一切诸有情心。善能通达诸有情行。行七步已。于诸世间发大音声。于诸识中获大智慧最胜解脱。皆得成就最上智慧。与诸有情皆悉明了。于智慧中善能安立。最胜智慧皆悉清净。于诸佛所皆悉成就。于诸体性智慧明了。于自他中皆悉成就。若诸有情具智慧力。于诸作用皆悉成就。善能如是宣说此义。少欲有情悉无愿力。多贪有情皆悉迷着。罪业因缘皆悉增上。积集恶业无量无边。于诸正法不能信受。若有有情诸少欲者。于正法中不生尊重。于诸有情不生恭敬极嗔恚相生染污心。自谓已得阿罗汉果。所有世间衰老病者诸大苦恼悉集其身。彼人获得如是果报。所有一切诸不善相。虚受应供诸饮食等。作不善业当堕地狱。不能持彼清净戒行。何况复得阿罗汉果。若生信解造诸塔庙。发恭敬心得生善处。如是持戒修行业已。舍利子。诸菩萨摩诃萨。求趣大乘正法藏者。应当亲近诸轨范师。而常获得无量善法。如是如是称赞功德。皆悉获得诸善果报。然后转增无量无边不可思不可量不可数无边功德。如是成已。舍利子。菩萨摩诃萨。安住菩萨藏者。得善调伏清净戒行圆满具足。诸菩萨行皆悉成办。云何名为戒行清净悉得圆满。舍利子。菩萨摩诃萨有十种行相。何等为十。一者一切有情于菩萨所不生娆害。二者菩萨于诸有情所有财宝不生贪着。三者菩萨远离一切诸有眷属。四者菩萨于诸有情不生欺诳。五者菩萨于诸有情及自眷属。不起离间诸恶语言。六者菩萨于无量劫。以柔软语化利有情。七者菩萨于诸有情不发绮语。八者菩萨于诸有情资生之具不生贪爱。九者菩萨于诸有情不生嗔恚。所有诽谤皆能忍受。十者菩萨远离邪见。亦不归依诸天趣故。舍利子。此十种法。皆是菩萨摩诃萨清净戒行具足之相

复次舍利子。菩萨摩诃萨。复有十种清净戒行。何等为十。一者菩萨于诸戒行坚持不破。不被无明之所侵娆。二者菩萨坚持戒行绝诸瑕玼。于诸险难而不生故。三者菩萨坚持禁戒。于诸烦恼杂染等事悉皆远离。四者菩萨持戒清净。于洁白法常不远离。五者菩萨持诸禁戒。常行平等随心自在。六者菩萨坚持禁戒。于诸智者不生毁谤而得安隐。七者菩萨坚持禁戒。而皆远离一切过失。八者菩萨坚持禁戒密护诸根令不起故。九者菩萨坚持禁戒。防护诸根初中后时皆悉成就。十者菩萨坚持禁戒。于正念中普尽无余皆悉圆满。舍利子。此十种法。菩萨摩诃萨皆悉成就

复次舍利子。菩萨摩诃萨。复有十种持戒行相。何等为十。一者菩萨坚持禁戒。于诸饮食少欲知足。二者菩萨坚持禁戒。断贪嗔痴生喜足故。三者菩萨坚持禁戒。于其身心不生贪爱。四者菩萨坚持禁戒。远离一切诸女人故。行住坐卧居旷野中。五者菩萨坚持禁戒。行头陀行常不忘失诸功德故。六者菩萨坚持禁戒。自在成办诸善根故。七者菩萨坚持禁戒。于胜种族常生欢喜。亦不正视余诸相好。八者菩萨坚持禁戒。言行相应于人天中不生欺诳。九者菩萨坚持禁戒。于自身中常行伺察。自心决定不生过失。于他过失亦不起见常行庇护。十者菩萨坚持禁戒。以四摄法化利有情常不弃舍。舍利子。如是十法。菩萨摩诃萨。皆能圆满清净戒行

复次舍利子。菩萨摩诃萨。复有十种清净圆满戒行之相。何等为十。一者菩萨坚持禁戒。于佛信解不生退屈。二者菩萨坚持禁戒。于正法中常能拥护。三者菩萨坚持禁戒。于大众中常生尊重。四者菩萨坚持禁戒。趣求菩提志意柔和。于无上果心不暂舍。五者菩萨坚持禁戒。于诸善友常能亲近。复能积集诸善功德。六者菩萨坚持禁戒。于诸恶友而常远离。于不善法皆能弃舍。七者菩萨坚持禁戒。于诸有情常起慈心而生愍念。八者菩萨坚持禁戒。于诸有情常起悲心。于险难中而常救护。九者菩萨坚持禁戒。爱乐正法如游园观生大喜乐。十者菩萨坚持禁戒。于违顺境心常舍离皆悉平等。舍利子。此十种戒行之相。菩萨摩诃萨。皆能如是清净圆满

复次舍利子。菩萨摩诃萨。复有十种清净行相。何等为十。一者菩萨坚持禁戒。于诸施度善能调伏一切有情。二者菩萨坚持禁戒。常行忍辱于自己心而常防护。三者菩萨坚持禁戒。于诸善法精进不退。四者菩萨坚持禁戒于诸定聚而常加行不生散乱。五者菩萨坚持禁戒。于胜慧中常乐多闻而无厌足。六者菩萨坚持禁戒。于菩萨藏而求正法。常修闻慧坚固无懈。七者菩萨坚持禁戒。而常伺察诸无常法。志求菩提不惜身命。八者菩萨坚持禁戒。于自寿命而常伺察如梦如幻刹那生灭。九者菩萨坚持禁戒。于自意愿及诸有情。一切善行清净圆满。十者菩萨坚持禁戒。以持戒力愿于当来生佛会中。及诸有情悉同圆满清净戒行。舍利子。菩萨摩诃萨。皆能圆满如是十种清净戒相。舍利子。菩萨摩诃萨。如是圆满清净戒行。当获天上及于人间种种吉祥殊胜妙果。菩萨于诸世间种种事业。悉皆明了。菩萨于诸世间种种妙欲悉能施与。一切有情而不自着。菩萨行慈行时。与诸有情等行慈行。互相怜愍而无损害。菩萨行菩萨行时。深信正法而无虚妄。复于一切有情。皆生父母之想。复于一切有情。亲近随顺而生信爱。于有为法。念念而生无常之想。于有为行皆生觉悟。于自身命而能弃舍故。得圆满清净戒行。尔时世尊。为诸菩萨说伽陀曰

  色相光明妙无比　　宣说诸佛正法门
  清净禁戒坚护持　　法身上妙当获得
  远离愚盲诸苦恼　　癃残百疾不能侵
  清净禁戒坚护持　　当获诸根悉圆满
  势力广大无与等　　威德炽盛亦复然
  智慧猛利超世间　　降伏一切诸魔障
  以慧爱力摄群动　　能破一切诸疑网
  天龙八部咸归依　　国王王属皆供养
  能离一切诸恐怖　　安住禁戒无退转
  不堕一切恶趣中　　行大法故具名称
  一切有情着睡眠　　菩萨而能常警觉
  复能游往遍四方　　为利有情求善法
  最上珍宝及妻妾　　离我执故悉能舍
  为求无上大菩提　　安住圆满清净戒
  为求无上正法故　　于诸佛教生尊重
  常作世间人中师　　能广供养于塔庙
  能除一切嗔恚心　　于诸恶作悉能忍
  以忍辱力而自安　　一切诽谤皆不动
  能于言行悉相应　　一切时中无虚妄
  当坐菩提大道场　　三千世界悉震动
  而能尽求诸佛法　　亦不归依诸天趣
  弃舍外道邪见心　　无上菩提誓成就
  一切器杖及毒药　　有情持以互相害
  菩萨救护于其中　　是故名为大智者
  我于俱胝多劫中　　愍念一切含生类
  若见受其苦恼时　　委身代彼无懈倦
  一切有情多虚诳　　来菩萨所欲侵夺
  造诸恶业阎浮中　　唯佛正法能除断
  能施一切诸珍宝　　而常亲近诸善友
  若诸有情侵害时　　终不起于恚恶意
  一切有情身边处　　而常弃舍愚夫法
  诸佛妙行获圆成　　清净戒足常不舍
  而常善住诸佛法　　亦能于法皆随转
  菩提行愿悉能行　　得成正觉菩提果
  净证三明甘露法　　亦常善住于戒蕴
  一切法习悉能成　　天上人间获妙供
  为求一切无上法　　于诸事业悉明了
  善解有情取舍心　　堪受人天诸供养
  宣说最上甘露法　　于戒蕴中常清净
  悟了无上菩提因　　一切魔障悉远离
  诣菩提树安坐已　　譬如日月照世间
  具大威德炽盛光　　于世间中为最上
  慧眼最上出世间　　于无畏语先成就
  示正道已悉圆成　　当施有情诸无畏
  菩萨不起爱乐心　　于身命财能弃舍
  世间珍宝无所贪　　当证无上菩提果
  众等不舍菩提道　　具足持戒常精进
  而能安住正法中　　远离一切诸谄诳
  菩萨安住戒蕴中　　世间或有谄诳者
  来菩萨所伸语言　　以真实语而教示
  或有常持衣钵者　　多行谄诳而不实
  欲施菩萨而无施　　菩萨正念无所动

复次舍利子。如是菩萨摩诃萨。圆满清净诸戒行已。于诸世间有为法中不生爱乐。于诸有情常生母想。于五欲中生无著想。了知世法悉皆无相。心行平等无诸险恶。现前成办菩萨之行。何以故。菩萨摩诃萨。行平等心时。不离涅槃。若染污心而生执着。令诸险恶转生增胜。眼着色故。菩萨了知从识心生。烦恼虚假。离自性故而皆断灭。于诸攀缘而生计执。非真实法而为善法。菩萨知是虚妄自内心起。而生胜解。于诸烦恼尽得解脱。身亦解脱。于贪嗔痴悉皆尽故。何以故。此之贪法刹那尽故。若或别有贪法。若或别有尽法。悉皆真实。如是贪法真实了知。真实尽故

复次舍利子。然此贪法非于内心真实所起。是遍计故。彼人于法。若生分别亦非真实。若于真实知非真实。于诸苦恼而皆解脱。若离苦恼名真实者。彼真实无诸苦恼。性本清净是涅盘义。本非贪法。何以故。是涅盘中非想念故。彼贪尽处而是涅盘。若见贪尽而非贪尽。若见涅盘而非涅盘。而乃是名真实涅盘。何以故。贪及涅盘自性无异。本性和合。智者于此。知彼自性而求涅盘。若非真实而皆虚假。彼虚假中自性空故。云何名空。为其计执我我所故。而或计执我性常故。而或计执我性断故。而或计执一切诸法悉无变异。若无我人及无寿者。毕竟不生贪嗔痴法。彼法若生此法定有。是故复生我我所故。于我我所而皆复起一切行故。舍利子。起一切行者。由其四种积集之行。何等为四。一者身积集行。二者语积集行。为于寻伺发粗恶语。所作行业娆恼他故。三者心积集行。四者想积集行。为于自他计执想念故。诸有情悉被缠缚。(此上文标四行内二有解二阙解文梵本元无不可添足)

复次舍利子。菩萨摩诃萨。见诸有情。如是色相。如是计想。如是颠倒。而皆不能与诸菩萨同修胜行。而生解了。何以故。菩萨摩诃萨。若与有情同修行时。恐彼损减。而我常求无畏法故。舍利子。菩萨摩诃萨如是缘故。于一切有情而生信重无有疑惑。舍利子。云何菩萨而生信重。菩萨摩诃萨。于一切有情如父母想。舍利子。菩萨摩诃萨。于一切有情无有遗余。而于无边世界。无始时来一切有情。皆悉曾为我之父母眷属。时彼有情。以贪爱故而生忘失。不记曾为父母眷属。复起嗔恙心时亦皆忘失曾为父母眷属。遂生弃舍。舍利子。菩萨摩诃萨。以此缘故而为譬喻。应当了知。菩萨摩诃萨于一切有情。常生眷属之想。舍利子。于过去无量无数阿僧祇劫。复于不可说不可说无边广大不可思议世。时于彼世中有佛。名为最上众如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。住于世间九十俱胝岁有九十俱胝那踰多大声闻众。诸菩萨摩诃萨。悉来集会。时彼会中有一菩萨摩诃萨。得正念住。而生王宫胜种族中。当初生已。其王及后。各令八万四千采女而为侍卫。于是太子色相殊妙。身体端直洁白圆满。诸相具足人所乐见。由是外族眷属。见是太子威严色相。而皆来集亲近侍卫。舍利子。时彼太子有三善友。共营所居殊妙楼阁。谓于热时雨时寒时。于三时中而为娱乐。游往安住各遂其宜。复有千万人众。悉来随时。各奏音乐而共嬉戏。亲近承事供给。普遍发诸妙声。皆悉和合。时彼太子忽然思念生灭之法。息其音乐。寻思乐声从何而来。从何发生。何处是灭。云何是生。云何是灭。昼夜思念曾无睡眠。惟念无常厌离生灭。舍利子。此菩萨摩诃萨。得正念已。于四万岁心常厌离音乐之声。复于四万岁中。不乐世间所有诸欲。时彼菩萨未出家时。常勤修习四禅诸定。而得成办五种神通。从自舍宅腾空。往诣最上众如来之所。亲近瞻仰礼拜供养。欲问世尊诸善法要。舍利子。是时最上众如来已般涅盘。时彼菩萨而伸请问。诸大比丘及善男子。最上众如来已涅盘邪。善男子。我最上众如来已般涅盘菩萨闻是语已悲啼号泣闷绝躄地。良久乃苏。时彼菩萨忆念如来说伽陀曰

  我佛明照于世间　　超一切法登彼岸
  诸放逸行已远离　　清净妙果得成就
  我于百千俱胝劫　　难值如来出世间
  不逢供养染障深　　自舍如来谁救护
  世间慈母非善友　　亦不称赞于如来
  多生正法未曾闻　　于佛世尊难值遇
  世间慈父非善友　　令我耽着于五欲
  随顺五欲增染心　　使我不见如来相
  我佛六十种妙音　　未尝得闻于佛所
  故于善恶不能知　　令我永没生死海
  复于多劫不遇佛　　于诸世间生愍念
  发。愍念中悉能行　　了一切法到彼岸
  我于俱胝多劫中　　不曾亲近供养佛
  以放逸故历多生　　由是深障不见佛
  我闻如来出于世　　到佛所已般涅盘
  父母恩爱为所缠　　令我不得见调御
  若值如来久住世　　我必得聆于正法
  广修供养亲近时　　六十妙音闻具足
  六十妙音本清净　　三世如来咸具足
  我虽生住于世间　　不得亲闻梵音响
  我生缘业多重障　　佛灭度已而来此
  诸佛正法藏甚深　　无能开示于我等

佛说大乘菩萨藏正法经卷第二十二佛说大乘菩萨藏正法经卷第二十三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之六

复次舍利子。时彼菩萨摩诃萨说是偈已。而更前诣最上众佛般涅盘所。头面礼竟涕泪交流。绕百千匝却住一面。复说伽陀曰

  如来于诸有情中　　善说最上真实法
  我今发起真实心　　愿求无上菩提果
  佛具大智真实身　　今灭度已我不见
  志发誓愿等如来　　当获殊妙诸相好
  我昔曾于俗舍中　　于如来法不恭敬
  现招劣弱深钝根　　致诸魔障来娆恼
  今我未得闻正法　　无量苦恼常逼迫
  愿得亲睹调御师　　发起宿植善根本
  我今发是诚实语　　对诸八部天龙众
  证明我此真实心　　愿获当来真实果
  愿我当承善根力　　得见最上人中尊
  闻正法已获神通　　如大龙故注甘雨
  愿我不堕八难中　　远离一切诸欲染
  于佛常生谛仰心　　恶魔重障无能缚
  愿我常于诸佛所　　亲得闻持正法藏
  洁白之业速圆成　　无边佛慧皆通达
  愿我速获真实语　　以真实故得成佛
  当坐菩提大道场　　说真实法利含识
  愿我早同最上众　　振神通力大千界
  俱胝天众围绕时　　获利益者心欢喜
  佛神通力难思议　　住虚空中复难见
  愿以赞叹功德因　　放净光明照我等
  佛神通力无有量　　愍念有情常显现
  以上妙法令我闻　　亿千万偈叹无尽

复次菩萨摩诃萨。心生欢喜转复增进。说伽陀曰

  若我往昔承记别　　现生当得成佛道
  一切有情随我心　　所修供养皆圆满
  真净境界不思议　　求菩提者当趣入
  众生若发如是心　　无量如来常再见

复次舍利子。是菩萨摩诃萨。昔曾于诸佛所。深种善根亲近供养。皆悉成办无量根力。于此没已得生天界。二十俱胝劫不堕恶趣。二十俱胝劫不耽五欲之乐。复于往昔。亲近供养七千如来。于一一如来所。广大成办诸供养事。为求无上正等正觉。于一切时常修梵行。以是往昔善根力故。得成阿耨多罗三藐三菩提。号曰娑罗树王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。十号具足出现于世。彼佛会中有诸声闻皆来集会。复有二十俱胝比丘。与大阿罗汉四万人俱。诸漏已尽无复烦恼。逮得己利尽诸有结。心得自在到于彼岸。舍利子。彼娑罗树王如来寿命二十俱胝岁。般涅盘后正法住世满一万岁。像法住世亦复如是。全身舍利流布世间。普遍供养广作佛事。尔时世尊说伽陀曰

  我于二十俱胝劫　　不曾堕于诸恶趣
  二十俱胝劫数中　　亦不耽着于五欲
  七千如来当住世　　于彼时中般涅盘
  修梵行故得成就　　常与有情获法欲
  今我得成菩提道　　故号娑罗王如来
  二十俱胝劫数中　　安立有情菩提果
  觉悟菩提最上因　　饶益一切有情故
  二十俱胝岁数中　　当为有情常说法
  常与四十俱胝众　　同坐道场宣正法
  诸漏已尽悉无余　　获得涅盘殊妙果
  三世如来身舍利　　我尝建塔六十千
  复立俱胝数宝幢　　于万年中伸供养
  正法住世一万岁　　诸有智者获利益
  清净妙音宣演时　　普获闻者心欢喜

复次舍利子。菩萨摩诃萨圆满清净戒行。于一切有情而生对治。于父母所不生贪爱。于诸有情发起对治。于诸欲境不生耽着。菩萨摩诃萨云何是欲法。云何对治法。欲法者。谓眼观色欲。耳听声欲。鼻嗅香欲。舌了味欲。身着触欲。而生和合。于此和合而生耽着。是名欲法。既生耽着而被缠缚。于诸缠缚生决定想。此缠缚法毕竟虚假。由贪迷故深乐缠缚。此缠缚法总有三种。谓浅深极深。诸有情等应当远离此缠缚法。又色是缠缚。声香味触皆是缠缚。云何色是缠缚。所谓成就身命色故。生于我想。补特伽罗想。寿者想。常想。不坏想。决定不变想。尘境物想。萨伽罗想。五蕴想。此等皆是色法缠缚。又色是缠缚。成就身命色法故。所谓世间诸有欲法。爱着身命妻孥眷属。是名色法缠缚。乃至触欲皆是缠缚。诸有染缘而渐成就。诸不善业而皆积集。耽着诸欲不能暂舍。舍利子。云何是欲无过失。谓洁白清净欲无过失。然于恶趣不生爱着。云何于恶趣中不生爱着。谓欲无过失。舍利子。诸有情等。于诸欲事而常亲近。无有少分不曾暂舍。由此业报遍受苦果。舍利子。于千世界次第伺察。遍观察已。诸恶朋友。无有一人可比于妻。何以故。舍利子。一切有情由愚痴故。诸有智者而常毁弃。是故当知显现正法。诸无智者而常摄受。是故当知显现非法诸有为法。男女妻妾互相耽着而生爱乐。邪道摄受男女妻妾数数爱取。障难出离。障难持戒。障难修定。障难生天。障难涅盘障难一切洁白之法。又复摄受奴婢眷属。以要言之。又或摄受恶友。为地狱饿鬼畜生之所摄受。又复摄受男女妻妾。即彼摄受一切杂染诸不善根。又复摄受男女妻妾乃至饮食。尽其边际而为障碍。欲见如来而为障碍。欲闻正法而为障碍。欲近圣众而为障碍。佛之知见。清净洁白之法。一切圣众。由障碍故皆不能见。于时分中欲求成就。而为障碍。求七圣财而为障碍。于不正信法返生摄受。乃至破戒悭吝恶慧无惭无愧。皆悉摄受。于非七圣财返生摄受。又复摄受男女妻妾。即彼摄受疾病疮疣疼痛猛火毒蛇诸苦。又复摄受男女妻妾所住舍宅。犹如冢间。于其冢间发悲号声。无诸亲友乃至听受。增长痴迷。是虚幻法。于诸善法而为障碍。以要言之。舍利子。破戒之人诸有恶法。如世霜雹毁一切物。破坏善法亦复如是。又复耽着男女妻妾。如贪味人。舐于利剑。食热铁团诸不净物。又身垢秽以贪着故。用香花灯涂而自供养。如地狱中极大苦器而自严饰。又复于诸奴婢摄受驱使。又复摄受黑瘦恶人种种毁弃。又复摄受驼驴猪狗种种畜类。即是摄受一切苦恼。又复摄受男女妻妾者。舍利子。决定宁入千踰缮那极大猛焰热铁城中。不应摄受父母男女妻妾。常起如是染爱之心即便堕落。何况领受诸触境事。何以故。诸苦所因。以贪染法为诸根本。损害善法根本。忧悲苦恼根本。系缚善法根本。秽恶根本。生盲根本。而非慧眼洁白根本。如常履践热铁地上。悉令是人堕落邪道。以何因缘。说名为妻妻所作为。如负重担而能忍受。又甘领纳任持重担。长时不舍受诸苦恼。逼迫身心为其损害。如是因缘。说名为妻。如是有情。由起爱故返为奴仆。由耽着故不得自在。被诸打缚皆悉信伏。倍生钦仰随诸走使。如是因缘说名为妻。若具足说广大无量。舍利子又重担者。所谓五蕴色受想行识。而此五蕴名大重担。不能弃舍男女妻妾。宿因缘故而为眷属。舍利子。此为破戒缘。坏正行缘。不正见缘。乐饮食缘。地狱饿鬼畜生缘。作胜慧障。闭涅盘门。以是因缘集一切苦。说此名为宿因眷属。又舍利子。母之种族亦多过失。说此种族无量无边。幻化等事。有人随顺则生过失。诸有魔事如在掌中。波旬眷属及诸魔女。种种幻惑多种过失。以轻掉心侮戏心。颠狂心猿猴心。善能显现如是幻惑。以是因缘故。说名为母之种族。舍利子。又此幻惑亦名聚落。而建王城四衢道陌。人民世界。广大无量不可思议。以是因缘故。说名为幻惑聚落。舍利子。如是幻惑诸欲过失。应堕恶趣。舍利子。譬如幻师作幻惑事。而于众中备诸幻具。广能显现种种幻事。女人幻惑亦复如是。舍利子。世间有情见彼女人。而被缠缚。或时闻声。或时手触。或时歌舞起心爱着。或时和合起诸幻惑。或时啼泣。行住坐卧于一切处悉被缠缚。供给走使返为奴仆。舍利子。譬如世间成熟苗稼。遭大雨雹之所损坏。舍利子。母之种族亦复如是。而能损坏夫之种族。亦能损坏一切洁白之法。舍利子。诸欲过失应堕恶趣。一切愚夫不能了知。而返摄受妻妾眷属。舍利子。此诸菩萨于诸欲过失无义利事。以方便力而能远离。云何一切愚夫异生。弃背正法返生愚痴。非丈夫想。应于一切佛菩萨摩诃萨所。作大丈夫想。应当弃舍非丈夫想。不应生诸嗔恚之想。于诸善趣作大丈夫。起诸正行。不于恶趣作非丈夫起诸邪行。不于地狱饿鬼畜生起诸趣向。不于破戒起诸趣向。不乐于破戒众中而暂安住。唯乐于最上最胜一切无上正法无障无碍佛慧而起趣向。而乐对治诸不善法起诸趣向。愿我当来作师子吼。不乐随顺诸不善法作异兽吼。愿我当来如佛显现金色之身。不作异生凡夫之身。常为世间导善之首。又于人中无诸险难。安然寝膳无所乏少。常得清净诸妙饮食。皆悉丰足。亦不厌舍世间粗粝饮食。常愿于寂静处修习禅定。速得成就最上最胜妙三摩地。专注一境远离动乱诸惑障染。常得游戏诸佛定门。亦复远离声闻缘觉诸有定门。不乐依止一切愚夫异生诸有定门。亦不乐着色受想行识五蕴而住。不乐依止地水火风空识而住。不乐依止欲界色界无色界而住。亦不乐于此界他界而住。虽复于彼见闻觉知妙触境界。及所证得寂静思惟。亦复不乐依止而住。愿常依止如实静虑之者。虽乐修定于自他身常无损害。愿常圆满佛之智慧。所有欲界诸有为事。悉不愿乐。舍利子。菩萨摩诃萨。智者有四种出离法。何等为四。一者出离欲界。二者出离一切有情界。三者出离知恩不报而不亲近。四者出离一切苦行。应当发起此之四种出离之法。舍利子。菩萨摩诃萨住恶趣中。见诸殊妙母之种族。亦不发起贪爱之心。应当发起四种之想。何等为四。一者损减想。二者险难想。三者便利不净想。四者脓血秽污想。舍利子。菩萨摩诃萨住恶趣中。又应发起三种之想。何等为三。一者如母想。二者如妹想。三者亲女想。应当发起此三种想。如是舍利子。菩萨摩诃萨。而常善说修习思惟。及诸经典悉应信受。我观世间。无有一人于无量劫来。非母能生。非父能育。至于一切有情循环养育。一切有情亦悉曾为我之父母。或于往昔曾名为母。至于今生返名为妇。彼诸行人应当修学。与诸愚夫异生。我当住于不相违行。如是行相随顺于此。贪爱为心。内心专注作是思惟。所谓贪爱之心。彼云何见生与未生。若或贪爱眼中诸色。彼诸行人内心坚固。应当伺察。于自眼中而生爱着。云何眼中而生见见云何自性而见自性。云何自眼而见自眼。如是自眼四大所成。仗众缘故而非自性。既非自性而生爱着。爱着之心亦非自性。何以故。彼性非有此心亦无由差别故而生爱着。诸愚夫异生由不了故住无分别。我今乐住有分别中而生进求。何以故。如是色相非功德法。是欲思惟。尔时世尊说伽陀曰

  互相和合为一义　　此中无有义差别
  亦非内心坚固生　　由贪爱故名积聚
  云何真实中真实　　而于四大生爱着
  此法犹如于瓦木　　是中不生爱乐心
  由我执故生遍计　　从不真实为积聚
  不真实中贪爱生　　真实贪爱不可得
  设于十方遍寻求　　真实贪性不可得
  于不真实计执已　　贪爱心生还积聚
  彼若如是生伺察　　循环于此遍推穷
  随诸增胜推穷时　　真实贪爱不可得

佛说大乘菩萨藏正法经卷第二十三佛说大乘菩萨藏正法经卷第二十四

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持戒波罗蜜多品第七之余

尔时世尊说是偈已。告舍利子言。我今所说于诸契经。展转增胜随顺根力应当信解。舍利子。又此眼等譬如泡沫不可撮摩。于泡沫中无我无人。无众生无寿者。无补特伽罗。无意生无儒童。无作者亦无受者。如是了知诸法不生。离一切相。此中何有贪爱之者。又此眼等譬如阳焰。一切烦恼贪爱集生。前际后际无我无人无众生无寿者无补特伽罗无意生无儒童无作者亦无受者。如是了知诸行不转。离一切相。此中何有贪爱之者。又此眼等譬如芭蕉。体不实故。于芭蕉中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等譬如幻化。颠倒集生此幻化中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如梦中。见诸色相非真实故。于此梦中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如谷响。由缘生故。于谷响中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如影像。随诸业惑之所显现。此影像中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等譬如浮云。聚散无定体非究竟。此浮云中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等譬如电光。刹那变灭。此电光中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如虚空。离我我所。于空法中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如愚聋。无所觉知。又如草木墙壁瓦砾诸非情物无所觉知。而此愚聋非情法中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如诸行。皆流转故。亦如风鸢假缘和合。此诸行中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等皆是虚假。一切不净之所积聚。此虚假法无我无人。乃至离一切相。此中何有贪爱之者。又此眼等如镜中像。随物显现旋有旋无。是破坏法。此镜像中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等犹如苦井。老病死苦四蛇二鼠交相侵迫。此苦井中无我无人。乃至离一切相。此中何有贪爱之者。又此眼等无实边际。浮尘之根死法所侵。乃见边际。此边际中无我无人。无众生无寿者。无补特伽罗。无意生无儒童无作者亦无受者。如是了知离一切相。此中何有贪爱之者。舍利子。蕴处界法亦复如是。若菩萨摩诃萨。内心坚固真实相应。永不堕于贪爱法中。若堕贪爱。无有是处。于贪爱法真实厌离。舍利子。是名菩萨摩诃萨戒行清净。又菩萨摩诃萨如是圆满清净戒行。于诸有情不生损害。至于微细有情悉能饶益。亦复不惜躯命。普于一切无所不舍。或受佗恩而能还报。自佗受用悉令圆满。又菩萨摩诃萨于一切处。宁丧身命远离种种邪欲之行。宁丧身命不以妄语及以两舌虚诳有情。于自眷属常生喜足。宁丧身命远离绮语。常出慈爱柔顺之语决定正直之语。常自护身。于佗尘境不生贪爱。宁丧身命不生嗔恚。人所毁呰终不倾动。而能忍受诸恶语言。宁丧身命不生邪见。何以故。归依诸佛心不退转。常持禁戒无所毁犯。亦复不乐世智辩聪。唯学佛慧。坚持禁戒常无过失。远离险恶诸杂染法。坚持禁戒远离诸恶烦恼积习。常得成就洁白胜行。增长往昔普施饮食。坚持禁戒随心所欲。自在而行安乐吉祥。持诸禁戒于诸智者不生毁谤。初中后时正念无失。于持戒中离诸讥谤。诸有过失皆悉不生。于诸根门而常密护。于持戒中具大名称。诸有善法而常摄受。少欲知足于诸应供而常知分。欢喜持戒断诸攀缘。常行正直。持诸禁戒于三业中而常伺察。乐居旷野。坚持禁戒于诸女人常生厌离。而常爱乐诸圣种族。坚持禁戒誓愿不观世间美境。于头陀行而无缺漏。持诸禁戒于自善根不由他起。言行相应。持诸禁戒于诸人天不生虚诳。常生慈心而复增胜。于诸有情无损害意起大悲心。常持禁戒忍受一切诸苦恼事。欢喜持戒爱乐诸法。而无执着常修舍行。持诸禁戒于逆顺境常行平等。于自过失常能伺察。随顺他心而常守护。善能调伏一切有情。持诸禁戒而能圆满檀波罗蜜。持诸禁戒而能圆满戒波罗蜜。坚持之心无人能胜。持诸禁戒而能圆满忍辱波罗蜜。于诸善法而为究竟。持诸禁戒而能圆满精进波罗蜜。于静虑中不生懈倦。持诸禁戒而能圆满禅波罗蜜。修习闻慧常无间断。持诸禁戒而能圆满胜慧波罗蜜。志乐亲近诸善知识。持诸禁戒坚固积集菩提分法。远离恶友。持诸禁戒常得远离诸险苦难。于自身分常生厌离。持诸禁戒于无常想而能伺察。于自寿命复能弃舍。持诸禁戒而常不乐久住于世。唯常远离诸相违行。持诸禁戒于自心意。常极清净离诸热恼。持诸禁戒远离贪爱。不自贡高而能谦下。持诸禁戒纯直无谄。柔和软语如实相应。持诸禁戒获大名称。普遍一切而自调伏。持诸禁戒常无嗔恚。好乐寂静。以善语言化利有情。持诸禁戒如实而说悉无违背。以四摄法摄受有情。持诸禁戒常护正法。于自法财而无匮乏。诸有智者于此戒蕴悉皆具足。而能行诸菩萨之行。舍利子。菩萨摩诃萨。以是持戒波罗蜜多故。而能发起勇猛之心。所有魔事及魔眷属。悉皆隐蔽诸娆恼事。亦复不现

    忍辱波罗蜜多品第八之余

舍利子。云何菩萨摩诃萨忍辱波罗蜜多。是菩萨摩诃萨。为护禁戒发起勇猛。修行具足忍辱波罗蜜多。修是行时。世间所有一切娆恼不饶益事。皆能忍受。若寒热饥渴暴风酷日。若蚊虻水蛭毒虫之类。共来触恼悉能安受。若诸众生以恶语言互来毁谤。及欲损害菩萨身命。菩萨尔时心无恐怖。不生恚恼亦无怨结。已生现生当生悉能忍耐。舍利子。是名菩萨摩诃萨修行具足。忍辱波罗蜜多。又舍利子。我于往昔长夜之中。常修如是忍辱观法。若一切有情固来毁骂。加诸嗔恚而行捶打。以粗恶语种种诽谤。我于尔时不生忿恚。不生嫉妒不生恼害。亦不以其不饶益事反相加害。舍利子。我自成就忍辱观已。常起悲心愍念有情。增长忿怒嗔恚嫉妒。堕烦恼中。复以善巧种种方便而觉悟之。令得出离获妙果报。若诸有情弃背菩萨。不从善化返增恶行。于一切处常获丑陋不如意报。何以故。嗔恚行业是丑陋因。是不善业。是杂染业是下劣业。非正士业。非善友业。此不应作。当知嗔恚诸不善业。能令引趣堕三恶道。能令引趣焰魔罗界。能令引趣随地狱道生畜生中。于焰魔罗界以为眷属。如是嗔恚诸恶行业。能令引趣无财下劣夜叉趣中。能令引趣无财下劣饿鬼趣中。如是嗔恚诸恶行业。能令引趣贫穷下贱丑陋人中。舍利子。我自往昔不曾修作如是行相。菩萨摩诃萨亦应不修如是行相。又舍利子。此中云何是别异法。云何种种别异修作。我等所修善法相应。彼等所修非善法相应是别异法别异修作。舍利子。菩萨摩诃萨。应当如是随我修学。何以故。菩萨摩诃萨当修学时。或有有情来相娆恼。不起忿怒嗔恚之心。于诸行相亦不作意。常自思惟作忍辱观。成熟有情诸善根本。舍利子。假使有人以金银琉璃砗磲码瑙珊瑚琥珀末尼珠等。满四大洲以用布施。不如行此忍辱波罗蜜多。何以故。菩萨摩诃萨。以忍辱故能令有情不堕轮回。趣无漏道

复次舍利子。菩萨摩诃萨。应当不起嗔恚之心。而常作意念佛念法念僧。何以故。以是归命功德之力。当得成就无量善根。亦令有情皆悉念佛念法念僧。作是念时常得觉悟。我与有情何善何恶。若不思念佛法僧宝。即被忿怒嗔恚。恶行常相缠缚。菩萨作是思惟。若起嗔恚即非正理。若能忍辱即是正理。菩萨应当远离一切嗔恚业行。当行忍辱波罗蜜多时。应先思念佛法僧宝。是三宝力。能令一切有情同行是行。舍利子。我已成就如是行相。得成阿耨多罗三藐三菩提。为诸有情转妙法轮。愿诸如来摄受于我。善男子。当发阿耨多罗三藐三菩提心时。为诸有情转妙法轮。当获诸佛胜无碍解无量知见。菩萨修是忍辱波罗蜜多。如是行相。对治忿怒嗔恚恶行。亦当忆念东方有殑伽沙等世界。彼有殑伽沙等如来应供正等正觉。现住说法利益有情。时诸菩萨为彼如来之所授记。善男子。我亦已发如是阿耨多罗三藐三菩提心。为诸有情说法教化。如是南西北方四维上下亦有殑伽沙等世界。彼有殑伽沙等如来应供正等正觉。现住说法利益有情。时诸菩萨为彼如来之所授记。善男子。我亦已发如是阿耨多罗三藐三菩提心。为诸有情说法教化。常乐称赞忍辱波罗蜜多。作师子吼。永得远离忿怒嗔恚诸恶行法。若诸有情或乐修作种种利益。菩萨尔时。见诸有情如是修作。我亦随顺作诸义利。云何此中种种难作易作

复次舍利子。菩萨摩诃萨与一切有情。应当如是修学忍辱波罗蜜多。若不随顺如是修学。非我善友。若能随顺作义利事。是名善友。是故了知无所侵害。是义利事。我当深乐。不舍有情作诸义利。尔时世尊。说伽陀曰

  我于俱胝亿劫中　　荷负有情不义利
  见诸有情受苦时　　不曾暂舍而安住
  有情种性本义利　　互相教示为善友
  设遇诸恶侵娆时　　为义利故常忍受
  遍满一切阎浮提　　于佛刹中亦如是
  一切珍宝悉充盈　　为善友故皆能施
  若或有人持利剑　　欲来割截我支体
  以忍辱故生慈心　　永无怖畏诸苦恼
  或有忿怒嗔恚者　　坚持苦毒来侵娆
  以忍辱力而称扬　　安住忍苦曾无恼
  有持刀杖及毒药　　以嗔恚相欲加害
  为利有情诸善根　　于诸恶法能忍受
  我今不学诸愚夫　　亦不习彼下劣行
  广修殊胜饶益因　　当趣涅盘无上果

复次舍利子。菩萨摩诃萨应当如是修学忍辱波罗蜜多。于百千万俱胝那由他劫。假使有人将诸杖木瓦石种种器仗。而打击之。于少时间闷绝躄地。命将欲尽良久乃苏。菩萨尔时作是思惟。叹未曾有。我今于此再得寿命。然后应当如是修学最上最胜忍辱波罗蜜多。假使有人来于我所。须我头目及其骨髓身肉手足。如殑伽沙数满一大劫。我当尔时终无吝惜。亦复不起忿怒嗔恚诸恶行法。何以故。若起忿怒嗔恚诸恶行法。我于百千劫中所集善根。应当散坏。我今转复坚固积集。百千劫中所植善根。无令失坏。而为修习难得阿耨多罗三藐三菩提法。何以故。我等诸菩萨众。以忍辱力而为甲胄。舍利子。菩萨摩诃萨于大乘心。不应退转使魔得便。不能成就难得阿耨多罗三藐三菩提。于菩提心不应退转。使心散乱。今其魔事作诸障碍。云何魔事。所谓耽着自分饮食。是为魔事。耽着三衣。是为魔事。分别教化。是为魔事。为利养故使人赞叹。是为魔事。乐自利行。是为魔事。断灭多种洁白之法。是为魔事。乃至断人静住。障修福慧。障人亲近诸轨范师。断人修习菩提行法。是为魔事。舍利子。菩萨摩诃萨。若于菩提道而生退转。起散乱意。一切恶魔即得其便。何以故。诸有魔障。于长夜中伺求其便。入菩萨心能令增长忿怒嗔恚。舍利子。我于往昔坚持禁戒。修行忍辱波罗蜜多时。通达善法。其名仙人。于彼时中有大魔王。化五百丈夫众。皆以勇猛作大嗔怒。于五百年中。行住坐卧昼夜相逐作大嗔怒。或于道路井邑聚落及白衣舍。或旷野中。常以嗔恚虚诳不实幻惑有情。舍利子。是彼魔众于五百年中。常于我边作大嗔怒生诸过失。我于尔时谛察思念。以怜愍故发大慈心。为诸魔众广说妙法。时彼魔众得闻法已。诸恶行业皆悉殒灭。舍利子。我于尔时。为彼魔众说是法已。令诸有情成熟善根。当得阿耨多罗三藐三菩提。又复为彼谄曲破戒乐不善法难调有情。及诸多贪多嗔多痴有情。作善缘故。令得成熟阿耨多罗三藐三菩提。愿我当来成等正觉。最初度脱诸有情类。令得涅盘。舍利子。我于彼时。除诸妄念常生正念。具足饶益有情善行。而于三际不曾暂舍。舍利子。若菩萨摩诃萨。进求阿耨多罗三藐三菩提时。应当具足忍辱波罗蜜多。若菩萨于自身中。已生未生种种恶病极重苦恼。乃至死苦。菩萨尔时。具足忍辱波罗蜜多。皆能忍受。舍利子。菩萨摩诃萨。应当坚固安住菩萨忍辱波罗蜜多。所谓应当了知不忿怒。是名菩萨忍辱不损害。是名菩萨忍辱无诤语。是名菩萨忍辱不杀害。是名菩萨忍辱护自身命。是名菩萨忍辱护他身命。是名菩萨忍辱常护身语意业。是名菩萨忍辱内心谛察修忍辱行。是名菩萨忍辱远离贪爱。是名菩萨忍辱随顺业报。是名菩萨忍辱清净身语意业。是名菩萨忍辱以忍辱力。而复获得人间天上胜妙快乐。是名菩萨忍辱而复获得菩萨圆满殊胜相好。是名菩萨忍辱而复获得如来深妙清净梵音。菩萨积集坚固善行。是名菩萨忍辱远离一切世间娆恼。是名菩萨忍辱。或有伺求一切过失。菩萨于彼不生损害。是名菩萨忍辱。以要言之。乃至获得如来十力十八不共法大慈大悲大喜大舍一切胜法悉皆圆满。应当了知。是菩萨摩诃萨安住忍辱波罗蜜多。舍利子。菩萨摩诃萨修忍辱行时。或有人来嗔怒恼害。菩萨尔时了知虚幻。如对谷响而不加报。乃至打击杀害。菩萨于彼谛察。皆悉了知如幻如化。亦不加报。或有人来种种称赞。不以为喜。何以故。菩萨以自分圆满真实功德。而为眷属。于世间法亦不耽着。于自过失而能悔谢。于他过失不生毁呰。为能圆满菩提分法。作大佛事。而复思念。已作罪业悉皆虚假。诸相违行无义利事。悉能弃舍。舍利子。是名菩萨摩诃萨忍辱波罗蜜多

佛说大乘菩萨藏正法经卷第二十四佛说大乘菩萨藏正法经卷第二十五

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    忍辱波罗蜜多品第八之余

复次舍利子。菩萨摩诃萨忍辱波罗蜜多。所谓自身毕竟忍辱。有我等相非究竟忍。何以故。若他嗔恚来娆恼时及能忍受。于心境中俱不可得。而菩萨作是思惟。何者为嗔何者为忍。于法数中。云何眼等处而有嗔恚。又复伺察。于十二处忍辱亦不可得。展转入解有情等相悉无所得。又此忍辱非实究竟。至于忍辱名字如空谷响。是名苦空无常无我。于忍辱等作如是解。又此忍辱亦非究竟。谓于是法我无颠倒。彼是颠倒。于忍辱行起高下相。又此忍辱非实究竟。谓于是法我能解脱。彼非解脱。于忍辱行而非相应。又此忍辱亦非究竟。谓于是法我居正道。彼非正道。于忍辱行生二种相。又此忍辱非实究竟。谓于是法于空能忍。于见非忍。于无相中而能忍受。于有相中而不能忍。若于无愿无求而皆能忍。于有愿有求而不能忍。若于无积集攀缘而能忍受。于有积集攀缘而不能忍。若于烦恼尽处而能忍受。于烦恼处而不能忍。又于善处而能忍受。于不善处而不能忍。若于无过失处而能忍受。于有过失处而不能忍。若于无漏法而能忍受。于有漏法而不能忍。若于出世间法而能忍受。于世间法而不能忍。若于清净法而能忍受。于杂染法而不能忍。若于涅盘法而能忍受。于生死法而不能忍。此等忍辱有对治故非实究竟。云何名为究竟忍辱。若能随顺空性。于见非见中。非有非无。若能随顺空性。于有愿有求及无愿无求。非有非无。若能随顺空性。于积集攀缘中。非有非无。若能随顺空性。于清净法及杂染法。非有非无。若能随顺空性。于善不善法。非有非无。若能随顺空性。于诸过失及非过失。非有非无。若能随顺空性。于诸行中及涅盘法。非有非无。是名究竟忍辱。何以故。谓过去未来见在诸法皆不生故。众缘无尽忍辱无尽。若于是法。非有为非无为。亦非和合。亦不增减亦无成坏。亦非作者亦非养者。彼不生故。是名无尽。说此是为真实忍辱。舍利子。如是菩萨能行是行者。是名诸大菩萨摩诃萨忍辱波罗蜜多。若彼菩萨摩诃萨。能行是菩萨相应行时。一切魔王及魔眷属。作诸魔事及诤讼等。皆悉不现。是名菩萨摩诃萨成就最上忍辱波罗蜜多

    精进波罗蜜多品第九之一

复次舍利子。云何名为菩萨摩诃萨精进波罗蜜多。佛言舍利子。菩萨摩诃萨修精进波罗蜜多相应行时。先令魔事隐没不现。次当发起不退具足勇猛精进。不惜身命坚固勇悍志求修习。此菩萨藏正法明文。复能书写受持听闻读诵。解其义趣为人解说。又菩萨摩诃萨于诸契经。亦复教人听闻书写受持读诵。解其义趣为他人说。舍利子。譬如有人行真实行。执持种种金刚器仗。与百人战而无怯惧。勇捍敌众不惜身命。菩萨摩诃萨。行精进行亦复如是。应当坚固发起最上精进。志求菩萨藏正法曾无弃舍。发胜解行不退精进

复次舍利子。若菩萨摩诃萨行坚固精进行时。不惜身命。所有三千大千世界中。卵生胎生湿生化生。有色无色有想无想。非有想非无想。乃至堕于有情数者。于一刹那一腊缚一牟呼栗多。如是展转满一劫已。往昔已来未曾受生。今始受生获得人身。亦当精进读诵受持。乃至为人演说。令他受持。舍利子。我今乐说譬喻以明斯义。譬如有人行真正行。执持利剑能御恶友。及断身命而得全胜。舍利子。彼菩萨摩诃萨亦复如是。一心发起勇猛精进无怖畏心。于菩萨藏正法悉能受持。舍利子。菩萨摩诃萨。而能具足不退转地精进之行。复能速疾具足无量精进之力。所谓净心勇猛。持戒勇猛。忍辱勇猛。精进勇猛。三摩地勇猛。胜慧勇猛。胜行勇猛。舍利子。菩萨摩诃萨虽能如是起诸勇猛。曾无一念起杀害意。非如恶友起勇猛心而能杀害

复次舍利子。我说此菩萨摩诃萨。犹如梵王如天帝释如妙高山。而无动摇。大慈大悲及善胜解。复能通达不退转地神通境界。善知有情种种心行。心如大地一切平等。如水火风及虚空等。心皆平等。复能除灭贪嗔痴等一切过失

复次舍利子。菩萨摩诃萨。譬如殑伽沙数世界满中七宝持用布施。不如闻是大乘菩萨藏正法。精进思惟而能修行。得成阿耨多罗三藐三菩提果。诸菩萨摩诃萨等。应当寂静思惟如是修学。舍利子。菩萨摩诃萨。若能如是广大随顺修学。即得圆满无量广大善根。由闻如是精进波罗蜜多。而能成就最胜妙果。何以故。舍利子。决定爱乐阿耨多罗三藐三菩提故。舍利子。菩萨摩诃萨于菩萨藏正法中。为由听闻读诵书写受持。为人演说。应当发起勇猛精进。如是展转于诸险难。亦当固往而无劳苦。云何难去能去。所谓妙趣涅盘令魔波旬不能得便。说是菩萨正士修相应行者。勇猛精进为求如是三乘涅盘之道。于三恶趣。令诸有情于杂染法而能断除。于持戒忍辱诸波罗蜜多。多闻修习而求出离。若有有情行非善业及诸懈怠。应生怜愍皆悉令发勇猛精进。舍利子。菩萨摩诃萨诸智增者。于懈怠有情或当远离。于精进有情或当共住。何以故。舍利子。唯求涅盘最上第一清净解脱。舍利子。又菩萨摩诃萨行精进波罗蜜多时。亦令一切有情而共行之。复能利乐一切有情。善说正行普令觉悟。为令引入无上道故。尔时世尊。说伽陀曰

  勇猛精进悉无碍　　常得尊高无与等
  于菩萨藏正法中　　称为任持大智者
  思惟无上正法义　　得不思议智慧门
  复于正法求出离　　当获如来亲授记
  勇猛修习大胜慧　　坐菩提树正思惟
  令诸魔怖悉退伏　　由持智慧精进力
  普现一切戒清净　　世间事业尽能习
  复能利乐诸有情　　具足精进无损减

佛告舍利子。我灭度后后五百岁。若有有情行是行时。于诸契经爱乐受持。当得无量胜慧福聚富贵尊严。及得如来十力四无所畏。四正断法慈悲喜舍。佛十八不共法。乃至一切佛法。总略而聚各各明了。心得清净除遣魔事。令诸有情。尽生死苦向涅盘道。复于彼时。诸违顺境一切弃舍。舍利子。若于彼时诸有情类。智慧相应善巧方便。求进阿耨多罗三藐三菩提。修持净戒常乐多闻习诸禅定。修智慧业及胜解脱解脱知见。进求佛法。及乐利乐一切有情。断除邪见乐求正见。出离轮回。修行圣道演说正法。复于彼时破诸魔障。令贪嗔痴悉皆除灭。断无明暗令生明慧。舍利子。如是之法若能听受。即能生长一切善根。积集成就最上精进。若能如是听闻正法魔不得便。而于一切佛法之中不生疑惑。舍利子。时彼有情。福力具足内心正行。当得阿耨多罗三藐三菩提。又此有情。于诸契经而能听诵。爱乐受持极大欢喜。于菩萨藏正法。受持读诵修行成办甚大欢喜。亦复如是。我说是人能于一切如来教中。而得成就。设复有人不专读诵。以因缘故暂来听受。作意爱乐生大欢喜。亦复获得最上第一坚固精进。乃至如是于菩萨藏正法真实微妙行相。能以少分为他人说。舍利子。譬如大海水中有成熟果。色香具足漂浮水上。有一丈夫见如是果。起大勇猛精进胜行。入大海中。见水暴涌不顾沉溺。复以二手持取其果。或一或二或取三果。而出大海。然后诣彼寂静之处。观看是果乃尝其味。复自念言。我于往昔未识是果。色香美味亦复不知。又作是念。发大勇猛复往大海再取其果。果乃不现。但见海水波涛暴涌。而生苦恼于时退还。然念是果色香美味殊妙可爱。我于先时悔不多取。舍利子。我灭度后后五百岁。法欲灭时。若有有情于布施持戒胜慧精进。少能信解亦复如是。以是因缘于诸契经。听闻称赞受持读诵。为人演说乃至一四句偈。为魔波旬之所娆恼。不能建立受持读诵。兴显供养种种称赞。由如是故悉皆弃舍。又复展转少分听闻读诵称赞受持于寂静处思惟修习。为魔得便。于一切处常令退屈。时彼行人作如是言。苦哉苦哉。我于如来无上法中。为减没者。于真实法。不令我等听闻受持。乃至于牟呼栗多时。思念如来正等正觉。尚不能得

复次舍利子。又苾刍众为魔所持。于诸契经不能听闻读诵。时魔波旬现大众前。种种毁訾。此诸契经非佛所说。但是世间虚假文饰。舍利子。彼大众中有诸苾刍。闻是语已。于一切处魔力所加。悉不听受

尔时世尊。说伽陀曰

  若人闻是正法已　　令诸魔众悉远离
  而于一切佛法中　　决定信解除疑惑
  若或薄福诸有情　　于此正法不能听
  为彼有情薄福故　　闻亦不能生信解
  或有具足福力者　　听闻受持生信解
  于此正法少听闻　　能遣一切诸魔事
  如是薄福诸有情　　于此正法不生信
  以不信故堕恶趣　　犹如生盲无所见
  若有具足福力者　　于此正法深信解
  以深信故生善趣　　速疾犹若酥投水
  一类少福诸有情　　闻法展转生烦恼
  彼人长夜受苦恼　　为愚痴故不解脱
  于佛菩提悉弃舍　　速疾堕落恶趣中

舍利子。如来有清净洁白智慧之法。舍利子。于四众中。若有一类苾刍苾刍尼优婆塞优婆夷。于如来灭后法欲灭时。于诸契经。听闻读诵爱乐受持者。若有一类有情。于一切处不能爱乐受持读诵者。如来于彼一一了知。又诸有情于此契经若能听已。发起正行如理修行。当获四种具足清净洁白无障碍法。何等为四。一者获得具足清净洁白戒波罗蜜多无障碍法。二者获得常遇如来。见诸妙相具足清净洁白无障碍法。三者得见慈氏如来。获得具足清净洁白无障碍法。四者获得如理相应诸善根力。具足清净洁白无障碍法。舍利子。获得如是四种具足清净洁白无障碍法。舍利子。若我灭后法欲灭时。于大乘行如是行相。修相应行者。发起殊胜精进之行。复于契经受持读诵。为人演说展转听受。时彼有情复有十种魔事。智者应当悉皆了知。于此魔事不应随顺。转复发起勇猛精进。成办佛事。何等名为十种魔事。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。时魔波旬而来娆恼。此是第一魔事。智者应当于此了知。不应随顺。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。时魔波旬而来娆恼。令诸眼目生诸疾病。此是第二魔事。智者应当于此了知。不应退屈。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。时魔波旬而来娆恼。令其身分生诸病苦。此是第三魔事。智者应当于此了知。不应退屈。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。令心散乱不乐本住。此是第四魔事。智者应当于此了知。不应随顺。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。令其发起极忿怒心互相诤竞。令诸契经不能安立。此是第五魔事。智者应当于此了知。不应随顺。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。令其互相执持斗诤俱陷王难。起恶语言。利如毒箭更相损害。如是行相。令诸契经不得流通。由斗诤业速疾退转。此是第六魔事。智者应当于此了知。不应随顺。舍利子。若有苾刍于诸契经。发起乐欲受持读诵。时魔波旬而来诲诱住白衣舍。复令发起种种斗诤。如是行相。于诸契经不能受持。令生诽谤。由斗讼业速疾破坏。此是第七魔事。智者应当于此了知不应随顺。舍利子。于彼时分法欲灭时。或有少年诸苾刍众。于此法中出家未久。于诸契经爱乐受持坚固信解。发阿耨多罗三藐三菩提心。时彼苾刍闻是经已。得大欢喜。彼亲教师乃语少年诸苾刍言。此非佛菩提非佛法律。不应受持。时诸苾刍闻是语已。于少时间。于佛菩提而不信受。又彼苾刍互相谓言。我昔修习佛菩提法。今令我等不乐修习。所有往昔诸善根力使当断灭。返令如是堕染法中。乃至命终生诸恶趣。受大苦恼。舍利子。应知此等是魔所说。如是积集诸地狱业。诸有情等毁谤三宝不顺佛言。如来于三世中悉能了知。又诸有情发起精进修大乘行。如来于此亦能了知。舍利子。我今又令诸菩萨等起四种想。何等为四。一者于自身业而善调伏。二者于善修作而妙观察。三者于他所作不乐观察。于诸有情起大悲心。四者于空寂处行住坐卧。于自他心随顺防护。如是名为起四种想

佛说大乘菩萨藏正法经卷第二十五佛说大乘菩萨藏正法经卷第二十六

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之二

复次舍利子。时彼有情多起邪见横生计执。说法苾刍亦复减少。为人轻贱不生尊重。亦不恭敬亲近供养。有诸苾刍非法说法。于其正法不乐亲近。设见有人于诸契经。而生恭敬尊重供养。有大力能种种称赞者。共生侮慢。舍利子。时彼苾刍得离欲者。爱乐受持。未离欲者。于诸契经不乐受持。于大众前随顺魔众。此是第八魔事。智者于此应当了知。不应随顺。舍利子。若有苾刍于诸契经。虽生爱乐受持读诵解说书写。为利养故随顺世间。诸有情等起偷盗业。于三种事数数作意。何等为三。所谓贪着衣服饮食及诸卧具。于此三事而多追求。此是第九魔事。智者于此应当了知。不应随顺。舍利子。若有苾刍于此大乘诸契经中。行相应行。而能发起最上精进。书写受持爱乐读诵。广为人说。时彼苾刍为魔所持。业烦恼障之所覆蔽。于杂染法随顺爱乐。戏论语言而常相应。耽着睡眠。于睡眠中亦乐耽着诸杂染法。又复耽着炫惑女事。深乐随顺如是行相。于诸契经。不乐书写受持读诵广为人说。舍利子。时彼苾刍。于如来教生爱乐者。不欲断灭如来圣教。不爱乐者。恶业苾刍为魔所著。欲令佛法速疾断灭。此是第十魔事。舍利子。如是十法诸有智者。应当于此一一了知。不应随顺。尔时世尊。说伽陀曰

  时彼所有一切处　　由彼业故魔障生
  于诸白法悉弃舍　　不乐思择诸义利
  胜慧减少恶慧增　　于正法中不安住
  乐闻非法悉能行　　堕恶趣中为境界
  如是展转命终时　　覆藏瑕玼为救护
  尊重亲教阿阇梨　　一时俱堕于恶趣
  我于俱胝千劫中　　为利世间修苦行
  常于有情思善巧　　悉令远离三毒火
  我时证得大菩提　　能转清净妙法轮
  于人天中无与等　　世出世间称第一
  我今不应当弃舍　　世间有情极难得
  令彼魔众悉退散　　皆能离苦获安乐
  又令痴闇道路中　　持六度等真善行
  于诸佛教悉相应　　而能获得菩提道
  于如是法听受已　　复能演说真实空
  令彼安住正信中　　是故得离诸魔众
  于此最上真实中　　若有弃背真实法
  非真实相作真实　　不能远离诸魔众
  若有有情于佛所　　欢喜坚固生尊重
  听闻如是正法时　　获得吉祥胜义利
  正信有情欢喜已　　诸有魔众生苦恼
  于一切处作善时　　魔众竞来为恐怖
  时魔假作苾刍相　　巧出语言相诳惑
  于众迅疾生动乱　　谓菩提道非真实
  自言我法真实因　　汝应坚固求安住
  发生如是戏论已　　然后轻侮复毁谤
  时彼苾刍魔所著　　信魔语故生放逸
  谓言此法非佛乘　　因是弃舍涅盘道
  复背正觉合诸尘　　而于佛法不信受
  由执我见粗重已　　速疾堕落恶趣中
  纵有少分诸苾刍　　而复爱乐非真实
  各于大乘空法中　　互相伺求诸过失
  纵遇最上真实法　　以杂乱故不听习
  复于义理生恐怖　　舍正法故无所归
  彼时无有说法者　　不信解人而复众
  如是纵有说法师　　悉皆弃舍不听受
  若于世尊末法中　　复能利乐诸有情
  彼时多有魔障侵　　于此勿应生退屈
  未来若有苾刍众　　决定于法生信解
  宁丧身命坚护持　　速获证悟圆常果

尔时舍利子。及诸大苾刍等。于大众中闻是修习大乘行者。于诸险难能行正法。各各发起广大无量坚固勇猛精进之力。如是行相。于此大乘菩萨藏正法。听闻读诵书写受持展转教示广为人说。又复说是善巧譬喻。譬若有人善能守护祖宗库藏。今见财宝渐欲减没而生忧恼。如我今见释迦如来。于无量百千俱胝那由他阿僧祇劫。修行是难得阿耨多罗三藐三菩提法渐将减没。我等苾刍亦复如是。共生忧恼。宜各发起广大无量勇猛精进。坚持守护大乘菩萨正法宝藏。又苾刍言。譬如有人。有一亲子端正殊妙。父母见时适悦其心。观视子相目不暂舍。其子忽然于险难处堕落其中。有大飞禽捉持而去。又复堕落那落迦边高险之处。时彼父母。发勇悍力持取而还。如我今者佛灭度后。若有正士于无上法宝生大信敬。欲求出离。而于彼时受持读诵如说修行。我以如来无上法宝共相付嘱。精进守护亦复如是。无令为彼诸恶人辈之所侵坏。又苾刍言。譬如世间聚集兵众。行列阵势欲相斗战。是时众中少分有情。见彼军众心无怯弱。安住其前。护诸兵众无令斗战。又复众中有多勇悍。见是兵众心无怯弱。安住其前。如是展转乃立战功。如我今者佛灭度后法欲灭时。若有有情。内心坚固护持正法。亲近善友乐求出离。被坚固铠发起广大精进之力。破魔军众。如是行相于法宝中。若有少分精妙思择亦复如是。乃至一四句偈为人演说。令他随喜。信受佛语不生疑谤。亦复告示令多有情随喜称赞过去未来现在诸佛无上妙法。令其安住。时诸苾刍乃至广说无量譬喻。佛告舍利子。如实行相。我说是人所得福聚。犹如虚空无有限量。说不能尽。又舍利子。佛灭度后是人难得。我说名为是殊胜丈夫。是最上丈夫。是勇猛丈夫。是大丈夫。得佛法分。不乐自利小乘静住。唯行坚固大乘正行。又复不乐赞叹自他名誉。唯乐赞叹大乘功德。舍利子。乃至临命终时。于此正法亦复受持读诵。于真实空决定胜解

复次舍利子。于后末世破戒苾刍。亦复增盛毁谤正法。于诸世间外道经典。多乐修习。舍利子。于此劫浊烦恼浊众生浊见浊命浊恶世之中。若有苾刍。能以勇锐破诸斗诤而得安住。常愿不离诸佛菩提。于三时中。应作观想善能安住。尔时世尊说伽陀曰

  亲近如来正法藏　　能破一切老死苦
  于自利行非相应　　常乐利乐诸有情
  于我所说正法中　　恭敬爱乐能建立
  彼堪我为调御师　　即是如来真弟子
  若于正法不乐闻　　又复不能善安住
  彼人堕落恶趣中　　如轮于海速沉没
  于千俱胝劫数中　　遇佛出世极难得
  彼人为魔之所著　　纵得遇佛生厌怠

复次舍利子。过去九十一劫。彼时分中有佛出世。号毗婆尸如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛法中有六群苾刍。一名善见。二者妙利。三名作喜。四名贤吉。五名名称。六名利牙。而生计执我人众生寿者断常等见。常行侮慢。共相呼集诣旷野中。而常议论差别恶行。如是各各而自谓言。行百种善。而复召集一十二十乃至五十。以为群类。自所行法展转教示。复立誓言。若违我教必遭损害。说是行已分首而去。或入聚落或抵城邑。或自他舍乃至王城。时彼一人抵一聚落。还集种类。复各教示增损佛语。舍利子。云何作意增损佛语。时彼种类坚固执有我人众生寿者。若无我者谁为往来。谁为坐卧。谁为语默。谁为施者。谁为受者。谁为饮食。谁苦谁乐。乃至一痒一痛。谁为觉触等者。时彼众中或有一人。作如是言。若说无有我人众生寿者。非我善友。舍利子。时彼聚落男子女人童男童女闻如是语。皆乐于彼执我见者。而为善友互相谓曰。我于往昔。有诸智者如实了知。真善友者。说无我人众生寿者。我今于彼先所尊者。不应亲近恭敬供养。舍利子。时彼六群苾刍。后半月分还集一处。中有一苾刍谓言。我已展转教化五百种族。以为眷属

复次舍利子。时毗婆尸如来应正等觉。有一声闻苾刍。诸漏已尽无复烦恼。得阿罗汉果。既知是已。入彼五百聚落。为诸男子女人童男童女。而说是言。彼所说法是粗恶语。不真实语无义利语。时阿罗汉。于彼众中说伽陀曰

  若于正法不了知　　彼人即昧真圣道
  汝于邪法坚执着　　决定当堕诸恶趣

说是偈已。时彼六群苾刍众等。生大恚怒不乐信受。时阿罗汉。生大愍念赞叹佛已。复说伽陀曰

  我佛所说真实法　　一切有为悉无常
  于诸法中皆无我　　是不坚固非常住
  又复诸行皆造作　　体不实故空复空
  愚夫痴迷坚执着　　于幻法中生动乱

说是偈已。又语彼苾刍等众。诸佛如来所说法中。悉皆无有我人众生寿者。时阿罗汉。知彼苾刍等众不乐信受。复说伽陀曰

  若于施受生见执　　复认觉触分别有
  于无我法不信从　　彼皆堕落诸恶趣

舍利子。时彼有情于虚妄法。男子女人童男童女。所有语言而生信受。当有六万八千人。以邪见故身坏命终。皆堕无间大地狱中。身受极苦在地狱中。复生多舌。舌如广大千叶莲华。于其舌上。复以铁犁耕破其舌。复有狱卒持百利杵击刺罪人。复于空中雨热铁丸。其丸猛炽击罪人身。又其铁丸变成火聚。其焰极猛。罪人各见猛火烧身。毕是罪已从地狱出。当复堕于千头鱼中。尔时世尊说伽陀曰

  时诸有情堕地狱　　无量百千火聚中
  空中震电复雨火　　罪人身受极苦恼
  一身复受一切苦　　猛焰器仗从空下
  百踰缮那皆充满　　各见身满地狱中
  各各复见于舌上　　锋铓利箭猛来射
  利刀分舌叚叚裂　　始觉苦中极重苦
  由随恶友虚妄者　　数数亲近而爱敬
  弃舍持戒清净众　　是故堕此极苦中

复次舍利子。彼六群苾刍众。以虚妄不实故。亦复当堕阿鼻大地狱中。其地狱量百踰缮那。各各自见身满狱中。彼一一身复有千口。一一口中复生二舌。每舌纵广四踰缮那。一一舌上。五百铁犁耕破其舌。复以热铁取舌烧烙。罪人痛苦口不能言。复于头上百千俱胝种种苦具而来捶打。如是受罪满百千俱胝那由他岁。毕是罪已。复入别别诸地狱中受诸罪苦亦复如是。何以故。彼人为于诸佛教中常生毁谤。获如是罪

复次舍利子。彼佛世时。复有长者住白衣舍。名为安乐。其家富乐财宝。丰盛随意受用。复有祖宗昔所积聚金银琉璃砗磲码瑙。真珠珊瑚如是等宝皆悉具足。诸有库藏亦皆丰盈。奴婢仆从城邑人众。随所驱使称意无乏。是时长者爱乐承事离系外道。修习邪法而生邪见。时长者妻名尾瑟钵底。色相殊妙端正洁白。身相具足人所乐见。而生一子。端严殊特面貌圆满。身体洁白人所爱乐。其子往昔曾于无量百千俱胝那由他佛所。种诸善根。其子初生三开口笑。作如是言。我今何故于此邪见种族中生。其母闻子作是语已。惊怖惶骇身毛皆竖。弃舍其子周慞闷走。时有众女见是事已。悉来集会共相询问。闻说其子有如是言。是时众女复生惊怖。而各狂走。去已复来观察议论。各相谓曰。此初生子为复是天。为复是龙。为复是药叉罗刹。阿苏啰。誐噜拏。紧那啰。莫呼啰誐。鸠盘茶。必舍佐。人非人等。生是疑已。时初生子谓众女曰。汝等吉祥具足人相。何故舍我惊怖狂走。尔时童子。对诸女众说伽陀曰

  汝众女等胜吉祥　　何于恶道不生怖
  我今令汝悟真实　　悉能远离诸险难
  我之父母并眷属　　于我悉皆非善友
  我今为彼除邪见　　不生险难诸恶道

舍利子。时彼童子父母并诸会众。闻是童子说伽陀已。共诣其所。尔时童子于父母前。复说伽陀曰

  所有库藏诸财宝　　五谷舍宅并供具
  速疾舍我将布施　　投佛出家作沙门
  毗婆尸佛见住世　　于三界中无与等
  彼佛慧日照世间　　我愿出家为弟子
  于佛正法得开示　　利乐一切诸有情
  彼佛慧日照世间　　我愿出家为弟子
  我佛具足三十二　　大丈夫相悉庄严
  彼佛慧日照世间　　我愿出家为弟子
  假使千俱胝劫中　　未尝闻是佛名字
  如优昙花难值遇　　我愿出家为弟子

舍利子。时彼父母语童子言。汝能如是发清净心投佛出家。我今所有祖宗库藏二十俱胝金银珍宝悉施于汝。令汝展转自行布施。时彼父母说伽陀曰

  我今所有诸财宝　　悉皆付汝将布施
  由汝发起清净心　　随处利乐诸有情
  所有金银诸珍宝　　五谷舍宅并资具
  由汝发起清净心　　速疾舍施利有情
  床褥卧具诸受用　　涂香花鬘末香等
  由汝发起清净心　　随处速疾行布施
  佛宝法宝并僧宝　　此为最上良福田
  于彼广行布施心　　真实利乐于一切

时彼童子复为父母说伽陀曰

  我欲往诣于佛所　　大毗婆尸世尊前
  广作无量诸供养　　利乐一切诸有情
  若天若人诸众等　　乐求一切快乐事
  我今往诣世尊前　　愿众应当同诣彼

时彼童子说此偈已。作是思惟遍观四方白父母言。我今往诣毗婆尸如来应正等觉所。时彼众等闻是事已。各生惊疑共相谓曰。云何童子生于一日。能与父母如是议论。而复双足举步能行。彼时乃有八万四千俱胝等众皆来集会。各各思惟互相谓曰。今此童子为复是天。为复是龙。为复是药叉罗刹揵闼缚阿苏啰紧那啰摩呼啰誐人非人等。时彼童子与诸众等俱时共诣毗婆尸如来应正等觉所。尔时童子领众行已。于虚空中有十千盖而覆其上。又于空中高声唱言。无令为彼寒热风雨之所损害。又复空中现金色网弥覆其上。又于空中雨天妙花种种末香诸妙香等。复有清凉微风飘散此香。又于行路香水洒地雨天宝衣。所雨天花积过于膝又于行路八功德水无量池沼自然出现。一一池沼各有无量优昙钵罗花俱物头花奔拏利迦花等。而为供养。复有七宝殊妙台树自然出现。又于行时种种角贝不鼓自鸣。出微妙音歌咏赞叹。于其左右。无量珍宝自然庄严。时彼童子才举步时。各现一花而为履蹈。随履蹈已隐没不现。尔时童子于道路中。须臾之间回顾观察。说伽陀曰

  世有正理非正理　　我今所行最上道
  于非正道而不行　　是故往诣正理尊
  我于那庾多劫中　　或时获得人中身
  复遇如来出世间　　具足信解智慧力

舍利子。时彼童子说是偈已。于虚空中有八万四千天人。咸共赞叹说伽陀曰

  善哉善哉大智者　　能说最上第一义
  于诸非理悉弃舍　　是故能行真正道

舍利子。时彼童子对诸天众。复说伽陀曰

  诸有能行正道者　　广说获得和合义
  于非正道坚执着　　云何获得相应理

佛说大乘菩萨藏正法经卷第二十六佛说大乘菩萨藏正法经卷第二十七

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之三

复次舍利子。时诸天众对彼童子。复说伽陀曰

  诸有贪者于欲乐　　一切境界无出离
  由愚痴故非正理　　当堕地狱恶趣中
  若于正道求出家　　应舍受用诸欲境
  彼能开示诸正理　　是名世间相应者

舍利子。时彼童子对诸天众。复说伽陀曰

  我今为汝天众说　　汝于正道未能知
  如是相应真正理　　当说令汝悉解了

尔时童子说是偈已。与诸大众俱时往诣毗婆尸如来所。到已头面礼足。右绕三匝却住一面。瞻仰毗婆尸如来。目不暂舍。是时童子心大欢喜。说伽陀曰

  具足三明施甘露　　能为世间作善利
  稽首龙象师子王　　是故我今常赞礼
  佛智光明甚希有　　犹如日月照世间
  亦如优昙花出现　　坚固安住妙色相
  世间有情多重障　　于佛圣道不能知
  犹若生盲愚痴人　　不觉堕于险恶道
  愿我当来成正觉　　犹如毗婆尸世尊
  令诸有情离众苦　　灭三毒火得清凉
  又令无量诸有情　　随我广发如是愿
  闻佛演说最上乘　　悉得开示菩提道

尔时童子说是偈已。又作是言。南无毗婆尸如来应正等觉。善说法要。时八万四千俱胝人众亦作是言。南无毗婆尸如来应正等觉善说法要。如是三叹终而复始。愿我当来皆得成就正等正觉。如毗婆尸如来善说法要。尔时毗婆尸如来。知彼童子及八万四千俱胝人众堪任授记。即现神变。于其面门放大光明名决定胜。其光复有无量种种色相。所谓青黄赤白红颇胝迦金色等。如是色相普遍无量世界。洞然照耀上彻梵世至色边际。日月光明。悉皆映蔽。其光复来至佛顶上。右旋宛转绕百千匝。忽然不现。舍利子。时毗婆尸如来有一亲侍苾刍。见佛神变光明事已。即从坐起整衣服。遍袒右肩右膝着地。合掌向佛瞻仰尊颜。以偈问曰

  毗婆尸佛大希有　　于诸圣中量尊圣
  我今启问善逝尊　　何因缘故现光明

尔时苾刍复白佛言。世尊。以何因缘现大神变放是光明。唯愿如来。大慈哀愍。为我除疑敷演斯事。复有无量百千人众。现住佛前愿乐欲闻。我等志心殷勤谛听。为诸有情慈悲开示。如来大悲。为世间眼救护一切。如诸舍宅覆荫一切。唯愿如来。大慈怜愍。断除疑网而诸有情过去未来现在。所行想念一切行业及诸疑惑。如来于彼无不了知。又诸佛刹所有有情。于三世中一切智慧言语差别。如来于彼无不通达。如来为诸法王。具足八种言音。于说法中皆得自在。以何因缘现大神通放是光明。唯愿如来。断除我等一切疑网及一切忧悲苦恼悉皆断灭。我等今者如是三请。一心专注合掌恭敬。愿乐欲闻。舍利子。时毗婆尸如来。语彼亲侍苾刍言。汝见此童子于我前住合掌立不。唯然善逝。我今已见。佛言苾刍。今此童子。于往昔时已曾亲近称赞恭敬礼拜。复以衣服卧具种种汤药。供养八万四千俱胝那由他佛。种诸善根。为求成就正等菩提。常修梵行。佛言苾刍。汝又见是八万四千俱胝人众于我前住合掌立不。唯然善逝。我今已见。佛言。彼诸人众于过去世。皆悉曾为童子父母。生生无不从之教化发心。于后后世。愿皆不受女人之身。皆能随顺修习。同发阿耨多罗三藐三菩提心。我今为彼授作佛记。以是因缘现大神通放是光明。尔时毗婆尸如来。为彼亲侍苾刍及诸人等。说伽陀曰

  汝见现前诸大众　　随于童子悉来集
  八万四千俱胝数　　一心专注听我说
  佛说法中得自在　　我今亲语汝苾刍
  我知童子多劫中　　亲近供养于诸佛
  复于无量诸佛所　　志心坚固求出家
  修持最上清净行　　复能利乐天人众
  又此现前诸大众　　八万四千俱胝数
  生生昔曾为父母　　教化欢喜常无间
  复于往昔无数劫　　广发无边诸大愿
  世世悉皆为父母　　同求无上大菩提
  如是安住离生死　　应当随我共修学
  志求无上妙菩提　　我今为彼亲授记
  彼等决定成正觉　　是故我现大神通
  我能尽令汝心中　　行住坐卧无疑惑
  汝等天龙及人众　　那由他数在我前
  同闻为彼亲授记　　不久当成二足尊

舍利子。时彼童子闻佛授记。欢喜踊跃速疾往诣。到父母前发诚实语。说伽陀曰

  如是八万四千众　　往昔皆为我父母
  俱时同发菩提心　　今日父母复如何

舍利子。时彼父母。而为童子说伽陀曰

  如汝所说诸人众　　各各已发菩提心
  我今归依一切智　　与汝发愿无有异
  如是进求究竟道　　汝今身是我所生
  与汝同发真实心　　愿得菩提果成就

舍利子。时彼童子。为自父母复说伽陀曰

  我若最先得成佛　　誓与一切悉开示
  愿我父母诸人众　　共成无上大菩提

复次舍利子。时毗婆尸如来为彼童子及诸人众。发如是言。我今为汝授作佛记。勿生疑惑。善自安慰勿复异见。所以者何。汝于往昔为大自在天子。我于彼时。已曾为汝授作佛记。过是已后经俱胝那由他劫不堕恶趣。又过俱胝那由他劫。于彼转轮圣王族姓中生。得成为佛。名曰大悲如来阿罗诃三藐三佛陀。具大名称。父名净饭。离诸暗钝。母名摩耶。离诸忧恼。其子尔时亦如我子。字罗睺罗。出现世已。求成阿耨多罗三藐三菩提。于菩提道既成就已。其佛寿命满十万岁。彼佛光明普能照耀十万踰缮那国土。彼世界中一切有情。有缘无缘悉皆承佛光明照触。时佛光中有百俱胝。那由陀俱胝。百千那由他俱胝。大声闻众皆来集会。复有一俱胝众。皆是大阿罗汉。具足白法诸漏已尽。无复烦恼心得自在。具八解脱得六神通。舍利子。如是大阿罗汉皆来集会。复有无量大菩萨众皆来集会。复有彼佛往昔一切父母亦来集会。时大悲如来说法教化。无量阿僧祇有情。皆住不退转地。于诸有情作善利已。即于是时入般涅盘。正法住世一俱胝岁。彼佛舍利。于诸世间广大流布。如我灭后流布舍利等无有异。舍利子。说是语时诸有正士。发起勇猛广大精进。而起寻伺观察世间。利乐有情心无退转。复有菩萨摩诃萨发起正念。转复增胜心无间断。志求阿耨多罗三藐三菩提。如是经于无量阿僧祇劫。愿于生死流转之中。化利有情求佛菩提。舍利子。我于彼时亦发是愿。尽生死际被精进铠。化利有情圆满一劫精进行愿。勇猛精进心无退转。愿成菩提。复次舍利子。云何菩萨摩诃萨不退勇猛精进。若菩萨摩诃萨。行不退勇猛精进行时。设见三千大千世界满中火聚。为求如来正等菩提。应当发起勇猛精进。入是火中而能安忍不生懈倦。彼诸菩萨闻是法时。即得超越圆满一劫精进行愿。又诸菩萨闻是法时。于不退转勇猛精进。即得增长无量善根。复次舍利子。若菩萨摩诃萨。行不退转勇猛精进时。而为利益一切有情求证涅盘。纯一无杂常住坚固。于善不善起大悲愍。于诸有情行相应行。复次舍利子。菩萨摩诃萨。当行勇猛精进悉无懈怠。于一切处举足下足。常不离于菩提之心。观诸三宝常在目前。亦不弃舍一切有情。亦不随顺一切烦恼

复次舍利子。菩萨摩诃萨。当行勇猛精进悉无懈怠。于已生未生诸善根力。悉令回向菩提正道复令善根增长无尽。舍利子。譬如百川流注大海其水无尽。今此善根回向菩提。亦复如是无有穷尽。是故说名不退勇猛精进。复次舍利子。菩萨摩诃萨当行不退勇猛精进之时。悉无懈怠。于诸正行一切智智积集善根。复能利乐一切有情。是故说名不退勇猛精进

复次舍利子。我今略说菩萨摩诃萨乃至一切有情所获福蕴。乃至有学无学声闻缘觉所获福蕴。不及如来一毛端量所获福蕴。何况如来遍身毛孔所有福蕴。为由如来于无量劫积集修行广大福蕴。设有广大积集福蕴。如实行相百分千分。不及如来一大人相。何况如来一切相好。又诸福蕴。不及如来眉间白毫一珂月相。何况百千匝中所有功德。又诸福蕴。不及如来一无见顶相。何况如来大丈夫相。乃至乌瑟腻沙诸根相好出生百千俱胝所有功德。又诸福蕴。不及如来大法螺音一说法相。何况如来广大法音。普能遍满无量世界。令诸有情诸根调适皆生欢喜。随其胜解得善调伏。于如是难得阿耨多罗三藐三菩提应生知解。如是菩萨于无量世界随学。如来发大音声。普令有情悉皆得闻。被精进铠发坚固意。乐习菩萨不退勇猛精进之行

复次舍利子。菩萨摩诃萨修精进行时。而无退屈。假使普令三千大千世界一切有情。具足成就胜解智力。若诸有情于此菩萨藏正法。随顺成就具足智力。比前功德。百分千分百千万亿分。乃至乌波尼杀昙分。不及其一。以要言之。如是三千大千世界一切有情。悉令获得须陀洹智力。斯陀含智力。阿那含智力。阿罗汉智力。又令获得十信十住十行十回向不退转地智力。一生补处菩萨之位。乃至广说无量世界一切有情。普令获得一生补处菩萨智力。若诸有情。于如来无分别及有分别智力等。如是听已。不惊不怖。当于彼时次第乐欲甚深智力。比前功德。百分千分百千万亿分阿僧祇分。乃至乌波尼杀昙分。不及其一。而菩萨乐欲发起勇猛精进。宁弃身命头目髓脑一切支分。于如来智力。不乐暂时间断修习。如是弃舍勇猛精进。我说是名菩萨不退精进之行。复次舍利子。菩萨摩诃萨。应当如是修学。不退转地乃至发起一心。遍入过去未来现在一切有情无量无边心行差别。若诸有情具足充满贪嗔痴等一切烦恼而复回入菩萨之心。是时菩萨以智慧力。譬喻言辞种种推求。如是发起勇猛精进。见是色相一切有情贪嗔痴等之所烧煮。是时菩萨以诸方便。普令止息一切苦恼。如彼灰烬散灭无余。复令修习趣涅盘道。我说是名菩萨不退精进之行

复次舍利子。菩萨摩诃萨修不退精进行时。所谓身作业善。语作业善。意作业善。乃至所有一切精进波罗蜜多。皆悉不离身语意业之所修习。然于三业发生精进意为最胜。云何意业精进最胜。谓无分别及有分别。云何无分别谓菩提心。云何有分别。谓于一切有情起大悲心。云何无分别。谓于忍智悟无我理。云何有分别。谓能摄受一切有情。云何无分别。谓虽能摄受一切有情而无取相。云何有分别。谓厌离轮回。无分别者。谓于三界都无所得。有分别者。谓诸有财宝随乐舍施。无分别者。谓于布施无取于相。有分别者。谓于持戒有所积集。无分别者。谓于持戒不取于相。有分别者。谓安受苦忍。无分别者。谓于刹那心无所住。有分别者。谓能发起诸善根法。无分别者。谓常静虑。有分别者。谓于禅定有所积集。无分别者。谓心常决定安住不动。有分别者。谓修闻慧而无厌足。无分别者。谓于内心专注善巧。有分别者。谓于闻慧广说诸法。无分别者。谓于法性都无记念。有分别者。谓于智慧有所修作。无分别者。谓于诸法离诸戏论。有分别者。谓于诸梵行积集修作。无分别者。谓于诸慧性悉能弃舍。有分别者。谓于五神通而能圆满。无分别者。谓尽诸有漏。有分别者。谓于观想而常思惟。无分别者。谓于内心而常正念。有分别者。谓于四正断悉能巧妙。无分别者。谓能超越一切善根。有分别者。谓著文字相欲求出离。无分别者。谓于广大福报普遍无相。有分别者。谓于诸有情善达根宜。无分别者。谓善能观察诸善根法。而无所得。有分别者。谓于诸力有所修习。无分别者。谓于是处无所损坏。有分别者。谓能出生菩提分法。无分别者。谓于诸法离分别智。有分别者。谓于正道而能求进。无分别者。观诸神变犹如虚空。有分别者。谓于定门而能积集。无分别者。谓住奢摩他而唯一境。有分别者。谓于毗钵舍那而有积集。无分别者。谓善入法性。有分别者。善能入解诸因缘法。无分别者。谓善能了知非因缘法。有分别者。谓着胜义声故。无分别者。谓行正法行故。有分别者。谓庄严法身。无分别者。谓于法身离诸庄严。有分别者。谓庄严语言。无分别者。谓依诸圣能常寂默。有分别者。谓依三解脱门而生乐欲。无分别者。谓无增上我故。有分别者。谓能远离四种魔事。无分别者。谓能弃舍烦恼习气种故。有分别者。谓能善解巧方便故。无分别者。谓于智慧如实知见。有分别者。谓离攀缘有所见故。无分别者。谓离超越见故。有分别者。谓有想念见。无分别者。谓意业见。此说名为意业精进。于精进中最为殊胜。我说是名菩萨摩诃萨修不退转精进之行

复次舍利子。如是菩萨摩诃萨行不退转精进行时。行是五种最上极妙之法。速疾证得无上正等菩提。云何五种最上极妙之法。一者而常思念佛出于世。二者而能亲近诸善知识。三者而常值遇好时。四者而常积集诸善根法。常令坚固。五者随学菩萨摩诃萨具足戒品。而得圆满。是名五种最上极妙之法。由是菩萨。速疾获得阿耨多罗三藐三菩提。尔时尊者舍利子。重白佛言。世尊。若诸菩萨离此五种最上极妙之法。得成阿耨多罗三藐三菩提不。佛言。舍利子。若诸菩萨。不常思念佛出于世。不能亲近诸善知识。若不值遇好时。不能积集诸善根法。不令坚固。不能随学诸菩萨摩诃萨。具足戒品而不圆满。如是远离五种最上极妙之法。不能速疾获得阿耨多罗三藐三菩提。违而得者。无有是处。舍利子。云何在家菩萨远离五种之法。所谓如王家臣。住大众中。恃其威势。恐怖多人。又语众言。我能为汝作种种事。但以欺诳而实不作。乃至如是安住虚诳语言等事。舍利子。由是虚诳不能得生诸天善趣。如是行相。亦不能得值遇好时。舍利子。又此行相在家菩萨。唯自具足资养等事。不能利他。亦复不能值佛出世。乃至不能速疾得成阿耨多罗三藐三菩提

复次舍利子。又在家菩萨住城邑中。有诸障难而常娆恼。云何城邑有诸障难。舍利子。有诸如来出世成等正觉。为诸天人阿修罗等说法教化。初中后善其义深远。其语巧妙。具足清白梵行之相。及四部众围绕恭敬。虽复亲近供养礼拜苾刍苾刍尼优婆塞优婆夷。然彼聚落城邑巷陌。舍宅人民国王大臣长者居士。悉住其中。由是因缘不能具足清净戒蕴。我说是名城中障难。若在家菩萨如是乐着五欲。不能思念佛出于世。乃至不能速疾得成无上正等正觉

复次舍利子。在家菩萨而自宣说现行法律。复多障难。所谓父母男女妻妾奴婢姊妹兄弟朋友眷属。于长夜中而为障难。舍利子。如是之法。能为在家菩萨作诸障难。亦复不乐佛出于世。乃至不能速疾得成阿耨多罗三藐三菩提

佛说大乘菩萨藏正法经卷第二十七佛说大乘菩萨藏正法经卷第二十八

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之四

复次舍利子。在家菩萨于诸如来所设契经如实行相。虽复听已不乐多闻。于少欲行不乐修习。及于同类诸契经等。亦不信受。于彼如来大乘教中。复生毁谤。而皆堕于诸恶趣中。云何名为诸恶趣中。所谓焰魔罗界饿鬼畜生。又复边地诸恶律仪。纵得为人身不具足。垢秽障重具诸邪见。舍利子。如是所呵厌处。诸佛菩萨。皆悉远离不乐生彼。乃至不能疾得阿耨多罗三藐三菩提

复次舍利子。在家菩萨于有大势力坚乐依止。所谓国王大臣及诸人民。大富豪杰增诸嗔恚。所出言辞多生谄伪。积集恶事诳惑于人。复生侮慢。是人以不善语故。堕恶趣中。身体羸瘦具诸恶相。舍利子。此名在家菩萨五种之法。以是因缘。不能值遇诸佛出世。亦复不能亲近善友。不能值遇好时。所集善根悉皆毁坏。于持戒菩萨摩诃萨等。不能随学。乃至不能疾得阿耨多罗三藐三菩提。尔时世尊。欲重明斯义。说伽陀曰

  若人行是五种法　　于此胜慧不增长
  而复远离调御尊　　不能速疾成正觉
  虚诳一切有情故　　如王家臣诸仆使
  悉断一切善根力　　不能值遇佛出世
  又或惊怖诸有情　　语令捉缚加捶打
  如是作诸恶业已　　于无上尊常远离
  复于苾刍苾刍尼　　破他净戒生病苦
  刹那不得值好时　　于诸佛所常远离
  父母妻孥诸眷属　　于非法行常无间
  而于正法不乐闻　　堕痴迷中难出离
  设逢佛世求亲近　　于刹那间不能得
  或复爱乐出家时　　彼等竞来为障难
  或时听是正法已　　随处演说真实空
  彼等竞生嗔恚心　　乃说此为非正法
  如是种种诸障难　　十六分中未及一
  由是毁谤正法因　　世世生盲无所见
  彼不能见正觉尊　　纵见不生清净信
  当获人身不具足　　后堕一切傍生中
  若人归向佛菩提　　及于菩萨生爱乐
  一切障难悉蠲除　　善能修习真正行
  所有父母并眷属　　及余一切有情类
  数数引导令出家　　速能摄受归正道
  唯母最初引导已　　复能赞叹令出家
  即当往诣善逝尊　　发心开悟大菩提

复次舍利子。出家菩萨复有如是五种之法。于诸善友亦复远离。诸佛出世于刹那时不能值遇如是积集诸善根力亦皆破坏。而于持戒菩萨摩诃萨。不能随学。乃至不能疾得阿耨多罗三藐三菩提。云何五法。一者以邪思故破诸净戒。二者以不信故毁谤正法。三者耽着利养及乐名闻。四者执着我见入诸险难。五者于他善行而生嫉妒。舍利子。而出家菩萨。具足如是五种之法。于诸善友亦复远离。不能值遇诸佛出世。以要言之。乃至不能速疾得成阿耨多罗三藐三菩提。舍利子。以是义故。譬如饿犬羸瘦憔悴皮骨连立。匆见枯骨而生食想。复于静处以力舐啮。自伤其口血涂骨上。不自觉知妄生贪爱。于其饱满终无所得。时有刹帝利婆罗门长者居士。自远而来。见是饿犬啮彼枯骨。极生嗟念。是时饿犬复自思惟。彼所来者夺我美味。时犬乃作恶声恶眼[齒*(崖-山)][齒*來]号吠。舍利子。于意云何。彼诸人众见是枯骨悉无血肉为侵夺不。舍利子言。不也世尊。不也善逝。佛告舍利子。云何彼犬作如是相。舍利子白佛言。世尊。由犬饿故。啮彼枯骨如甘露味。妄生贪爱故。现如是恶声恶眼[齒*(崖-山)][齒*來]号吠。恐彼人众之所侵夺。佛告舍利子。如我灭后有诸苾刍。于种族中乃至便利不净。深生爱着之所缠缚。如是行相。于刹那时成就佛事亦不能得。彼诸苾刍我今所说。于佛法中如彼饿犬。匪惟如来作是诃毁。若诸有情见彼苾刍如是行相。亦复诽谤如彼饿犬。舍利子。复有菩萨摩诃萨。广为利乐一切有情。求佛智慧。于自身命亦复弃舍。何况于他善业而生憎嫉

复次舍利子。复有世间愚痴之人。以自活命爱乐世间财宝饮食。身为奴仆。为彼系缚责役驱使。于他族中亲近诳妄。以贪求故。复于他人而生嫉妒。舍利子。如彼苾刍为贪利养。先在彼族见后来者。而复发起憎嫉之心。谓后来者而作是言。我先住此。汝等诸人从何所来。今此族中诸长者等。先发愿言。所有衣服饮食卧具医药决定施我。作如是言。彼后来者云何当得。因是发生三种过失。何等为三。一者乐着住处。二者不乐本住。三者于世间法而能解了。出世间法不能解了。又彼苾刍于此长者族中不乐安住。而彼苾刍又发是言。住处有三。一者爱乐处住。二者和合处住。三者如实处住。汝诸长者多行过失。应当于我深生恭敬。于我法中称扬赞叹。舍利子。由是种族生憎嫉过。于洁白法悉皆减没

复次舍利子。复有种族多诸嫉妒虚妄不实。或有持戒不持戒者。于菩萨摩诃萨所。悉皆远离而不随学。如是譬喻应当了知。复次舍利子。于过去无量无边广大不可思议阿僧祇劫。彼时彼分有佛出世。号胜高如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛住世九十俱胝岁。彼佛会中复有九十那踰多大声闻众。皆阿罗汉。诸漏已尽。无复烦恼。逮得己利。心得自在。到于彼岸。彼时复有长者名曰善集。其家巨富眷属广大。多诸财宝。金银琉璃砗磲玛瑙珊瑚琥珀真珠等宝。皆悉具足受用广大。复有奴婢仆从象马车乘。及诸仓库悉皆盈溢。时彼长者生其二子。一名净住。二名净持。面貌端正身相具足。人所乐见。忽于一时登大楼阁经行游戏。尔时佛告舍利子。彼胜高如来应供正等正觉。于晨朝时着衣持钵。与大苾刍众前后围绕。入彼大城次第乞食。其佛相好犹若金山。又如广大妙好金幢。最上第一。住奢摩他诸根隐密行。如龙象极妙清净。如大池沼离诸尘秽。又如大海珍宝充满。如帝释天主诸天围绕。如大梵天王寂静严饰。具足圆满清净洁白。心意调畅诸根寂静。彼二童子。即于是时。见彼胜高如来多陀阿伽度阿罗诃三藐三佛陀。是二童子乃赞如来自远而至。佛身相好无量无边圆满具足。瞻仰世尊心无厌足。舍利子。时净住童子往昔已曾得见胜高如来应供正等正觉。乃语净持童子言。汝曾往昔得见胜高如来不。此佛功德无有边际。于一切有情中为大慈父。时净持童子言。我于往昔未曾得见此佛世尊相好具足威德特尊。时净住童子言。我于昔时。已曾见此胜高如来。愿我当来一如此佛等无有异。舍利子。时彼净住童子说伽陀曰

  愿我当来如世尊　　有诸苾刍众围绕
  我若得似如来相　　复名如是最上尊
  今将饮食诸供养　　为求无上菩提故
  所有舍宅悉弃舍　　愿我当来成正觉
  譬如众星月为胜　　此谁见已不清凉
  于有情中佛最尊　　谁不舍家求出离

舍利子。时彼净持童子闻是语已。复说伽陀曰

  汝今莫作如是语　　亦勿高声报四方
  汝今听我诚实言　　云何速得菩提道

舍利子。时彼净住童子闻是语已。复说伽陀曰

  汝于此道不爱乐　　亦复莫起憎嫉心
  我今所出善语言　　是故当得菩提道
  汝于世间诸财宝　　亦莫辄生悭吝心
  我于身命尚能舍　　是故语汝悉知解
  与汝如是诸舍宅　　及有一切财宝等
  我今往诣于佛所　　出家求授菩提记
  三十二种殊胜相　　谁人见已不爱乐
  无上菩提谁不行　　于此莫生劣弱见
  我于舍宅并财宝　　父母眷属诸亲友
  于此一切皆能舍　　为求往诣于佛所
  假使俱胝千劫中　　闻佛出世甚难得
  佛为世间大光明　　遇佛光者亦复难
  佛来王城行化行　　大苾刍众皆围绕
  犹若晴空清净月　　普遍照耀于世间
  又如出现千日光　　四衢道陌皆晃耀
  佛于城中行化行　　普放光明亦如是
  譬如须弥山中王　　亦如出现殊妙宝
  佛于苾刍大众中　　清净尊严亦如是
  炽盛光明大威德　　普能照耀诸有情
  如来殊胜二足尊　　圆满如是诸色相
  佛入王城行化行　　显现无量大神变
  诸天龙神及有情　　见者爱乐咸恭敬
  三十二种殊胜相　　见已谁不求正法
  若于小乘乐修习　　是名愚夫劣弱见
  我见无上人中尊　　相好端严世希有
  我今往诣善逝尊　　为求无上菩提道

舍利子。时彼净持童子闻是语已。复说伽陀曰

  我于小乘非爱乐　　亦能往诣于佛所
  今于此大楼阁中　　誓欲弃掷于身命
  又我想身皆虚幻　　于其身命即能舍
  为求无上大智慧　　亦当往诣于佛所
  父母恩爱极最重　　舍宅财物诸欲境
  我今悉能皆弃舍　　誓当往诣于佛所
  若我愿得如世尊　　蒙佛称赞为摄受
  一切所有弃舍已　　投佛出家为弟子

舍利子。时净住童子从大楼阁安详而下。即时往诣胜高如来应供正等正觉所。时净持童子复于大楼阁中发勇猛心。不顾身命迅速而下。以精进故先诣胜高如来应供正等正觉所。舍利子。时净住童子到佛所已。持以上妙法服价值阎浮檀金一俱胝数。奉献如来。说伽陀曰

  我今所献上妙服　　不求端严诸色相
  愿我当来如世尊　　最上最尊称第一
  具足清净大智慧　　于精进力善安住
  三十二相妙庄严　　愿得果如二足尊
  又复成就十智力　　四无所畏善安住
  愿我当来如世尊　　最上最尊称第一
  愿我于佛正法中　　如佛安住光明聚
  演说诸法施有情　　普令一切皆觉悟
  我今所献上妙服　　不求端严诸色相
  愿成清净大菩提　　广度无边人天众
  又我所献上妙服　　为求如来无上慧
  安住不二正法门　　降伏一切诸外道
  又愿利乐诸有情　　令贪嗔痴悉远离
  无明爱有等皆除　　获得无为甘露法
  又说如来清净法　　普皆利乐诸有情
  令离生老病死等　　及灭忧悲诸苦恼
  又愿说法利一切　　天龙人等及非人
  有想无想诸有情　　自觉觉他咸恭敬
  愿我如住诸佛刹　　普放光明照十方
  于大黑闇热恼中　　作彼清凉甘露味
  欲界色界无色界　　皆令一切无所著
  于憎爱境悉远离　　常说如来清净法

舍利子。时彼净持童子既到佛已。复以上妙革屣。持以奉佛。殷勤施已。说伽陀曰

  愿我如佛众中尊　　如大舍宅为救护
  令诸有情离恶趣　　复能演说真正道
  世间所有诸爱欲　　此名愚夫粗境界
  一切有为悉远离　　愿佛出世常值遇
  见佛光明照世间　　于二足尊应供养
  为利一切诸有情　　誓求无上菩提果
  复以最胜香花等　　种种幢幡及宝盖
  为利一切诸有情　　将持供养大觉尊
  上妙衣服及饮食　　床褥卧具诸汤药
  为利一切诸有情　　持此供养于如来
  又持鼓具诸乐器　　歌咏赞叹妙音声
  为利一切诸有情　　供养出世光明尊
  又持珍妙诸饮膳　　世间所有最上味
  为利一切诸有情　　愿将供养佛世尊
  作是广大供养已　　于佛如来求出家
  为利一切诸有情　　誓行一切清净行
  又愿一切有情等　　不生邪道幻惑中
  悉令俱胝数有情　　安隐皆住八正道
  愿我不生此欲界　　极劣边地诃厌处
  远离一切放逸已　　常得亲近不放逸
  又愿不生诸恶趣　　常愿生于信族中
  生已当发最上心　　愿见如来常亲近
  见已发此清净心　　及以花鬘涂香等
  众鼓伎乐诸供养　　当求胜解利一切
  愿于俱胝多劫中　　常作广大供养事
  出家远离诸欲境　　当行一切清净行

舍利子。彼二童子。于胜高如来应正等觉所。以种种伎乐伽陀歌咏赞叹供养佛已。即于地方所发清净心。以赤旃檀造立精舍。纵广四踰缮那高半踰缮那。如是造已奉献世尊。复作是言。唯愿如来哀愍纳受。彼二童子。于胜高如来应正等觉所。劝请世尊。说伽陀曰

  愿佛安住我精舍　　过去诸佛所称赞
  我今发此净施心　　愿佛哀愍亲纳受
  若佛常住我精舍　　了知俱胝有情数
  过现未来三世心　　愿我当来亦如是
  佛依精舍到彼岸　　获得正断及神足
  四种胜行各了知　　我施精舍亦如是
  唯愿胜高如来佛　　及与一切苾刍众
  受此精舍半月中　　供养尊重常恭敬
  我今于是如来所　　亲近恭敬供养已
  发是信心求出家　　剃除顶发被法服
  如是舍家出家已　　于诸利乐遍希求
  常当修作善相应　　爱乐如是真实法

时二童子。说是伽陀已。彼净住童子白佛言。世尊。愿我当来速成正觉。放大光明如佛世尊等无有异。时净持童子又白佛言。世尊。愿我当于险难恶道常为导师。舍利子。时彼净持童子于胜高如来前。住立一面恭敬合掌。又发誓言。愿我于佛法中。无复坐卧常离睡眠。为利有情求无上道。而常远离一切懈怠。宁以身命一切弃舍。乃至筋皮血肉皆悉枯悴。亦复远离一切懈怠。当发广大勇猛精进。求菩提道。舍利子。尔时净住菩萨摩诃萨。为彼净持菩萨摩诃萨。说伽陀曰

  我共汝发平等心　　修行无上菩提行
  我今亦发精进力　　为利一切诸有情
  远离诸欲及身命　　血肉枯干无所辞
  愿于千劫尽修习　　精进志乐菩提道
  常思安住旷野中　　及乐山间寂静处
  为求无上大智慧　　于法清净得自在

舍利子。时彼净持菩萨于千岁中。一弹指顷曾无睡眠及诸懈怠。况复梦想。又于千岁不求安坐。除诸便利。乃至一弹指顷亦不胡跪。何况坐卧。恃彼菩萨。又千岁中。食时持钵游行乞食。于彼施者。亦不观视是男是女童子童女。化利有情心行平等。却诣本住三观世间然后乃食。如是食已于非食时。不生一念饥渴之想。乃至不生甜酸咸淡苦辣之想。又千岁中。于非食时亦不乞食。时彼菩萨又千岁中住于树下。一心精进求菩提道。亦不观视是何等树。又于千藏所被法服。未尝暂时而有更换。时彼菩萨。又于千岁。而于诸欲不起寻伺。于诸损害亦复如是。又于千岁。于自父母兄弟姊妹及诸眷属。于日月等数不曾发起一念寻伺。又于千岁于其舍宅。曾无一念爱乐依止。又千岁中于日月星宿等。曾无一念起瞻视意。又千岁中未尝依止墙堵树木而于中住。又于千岁。未曾以诸酥油涂身。又千岁中于其自身。乃至一念曾无懈怠。又于千岁于其一念曾无疲倦。又千岁中乃至酥油亦复不受唯乐一心精进。求证阿耨多罗三藐三菩提故。时彼菩萨。又千岁中于其身心亦不懈倦。又于千岁修精进行。不起一念剃除须发。时四大天王来于顶上。以手摩触顶发自落。时四天王又持此发。于清净地起窣堵波。又千岁中四大天王。知彼菩萨于善所作悉来成办。时彼菩萨。又于千岁若值热时。亦复不乐于树荫中。又于千岁若值寒时。亦复不乐以衣覆身。又于千岁亦复不共世间有情语言戏论

复次舍利子。时有魔王忽然出现。名曰痴念。时痴念魔王敕诸波旬。为彼净住净持二菩萨。造作剑林及剑桥道已。时彼魔王及魔波旬。狂乱往来高声唱言。我今造作此名剑林。时彼魔王发是语时。三千大千世界中。上至魔宫下彻地界。有百千俱胝魔王波旬诸天眷属。皆得闻知悉来集会。共生恐怖。欲相谋害。舍利子。时彼菩萨一心精进安住不动

佛说大乘菩萨藏正法经卷第二十八佛说大乘菩萨藏正法经卷第二十九

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之五

复次舍利子。尔时净持菩萨摩诃萨。于彼剑林桥道。亦不经行心不随顺。彼诸天魔作大恶声。于菩萨所恐怖娆恼。时净持净住二菩萨摩诃萨。皆悉不听。又诸天子于虚空中赞如是言。彼二菩萨。具足能行如是正行。如是大悲如是勇猛。彼二菩萨于千岁中。唯专想佛。是时胜高如来化行已毕。入般涅盘。空中诸天见彼如来般涅盘后告言。善男子。彼胜高如来已般涅盘。时二菩萨闻是语已即时往诣胜高如来般涅盘所安置床座。到已合掌恭敬住立一面。以悲恋故忆念如来。于七日中目不暂舍。尊重赞叹。时二菩萨。勇猛精进行菩萨行。利乐有情如负重担。亦于是时。佛前住立如般涅盘。上生梵世生梵天已。复来诣彼胜高如来应正等觉窣堵波所。于四万岁中。旋绕礼拜作诸供养。又于七万岁中。持诸幡盖供养恭敬。复以上妙香花饮食。供养塔庙。彼二菩萨于梵天中尽其寿命。而复下生阎浮提中。于转轮王胜族家生得宿命智。既诞生已互相谓言。应当修习不放逸行。是时菩萨说伽陀曰

  我等生王胜族中　　获大神通免诸难
  当愿常行不放逸　　亲近无上菩提道
  尊贵富饶诸欲乐　　是法速朽不可信
  智者应当悉了知　　希求最上大菩提
  若人求是菩提道　　应舍富饶诸欲乐
  为利有情求出家　　修持最上清净行
  我于往昔无量劫　　与诸有情多贪求
  于五欲乐猛炽然　　谓言受用常无足
  我今觉悟诸欲乐　　尊贵富饶及眷属
  悉能弃舍誓出家　　精进为求菩提道
  我昔俱时十六岁　　舍家出家求出离
  剃除顶发被法服　　于千岁中行梵行
  又于是时俱入灭　　而复往生梵世天
  于其梵世复舍寿　　生此阎浮胜族中

复次舍利子。彼时复有佛出。名号最上勇猛如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼二菩萨诣彼佛所。亲近供养。尊重赞叹。发净信心舍家出家。剃除顶发而被法服。于俱胝劫修行梵行。舍利子。彼二菩萨于无量世时。已曾值遇百千诸佛亲近供养。于一一佛所具修梵行。尊重赞叹恭敬供养。舍利子。时净持菩萨过是已后。先成阿耨多罗三藐三菩提。号曰勇猛精进如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛住世九十俱胝岁。彼佛有九十俱胝那踰多大声闻众。悉来集会。舍利子。彼时净住菩萨。于彼勇猛精进如来世时作转轮圣王。于彼佛所尊重赞叹。复以上妙衣服饮食卧具医药种种供养。于三月中供养彼佛及苾刍众。舍利子。时彼转轮圣王作供养已。彼勇猛精进如来应正等觉。欲令转轮圣王生大觉悟。说伽陀曰

  若行最上精进行　　一切佛法乐希求
  若诸有情耽欲乐　　一切义利极难得
  若于欲乐不远离　　损自利故及损他
  于此应当悉弃舍　　而求最上诸佛法
  我今令汝亦复然　　往昔眷属皆弃舍
  及发无边大誓愿　　速求成就菩提果
  汝见我已成佛道　　鹿野苑中转法轮
  若于诸欲生爱着　　不能速成大菩提
  诸佛皆说离诸欲　　于放逸法不复生
  智者于此善信随　　即能远离诸业障
  汝于恶慧持重檐　　无义利法何安住
  若于诸欲不觉悟　　佛说皆为诸苦因

尔时世尊。说是伽陀已。时转轮圣王生大觉悟。于诸世间国城妻子。父母眷属臣佐仆从。诸小国邑一切吏民。财宝库藏。悉皆弃舍。住立佛前说伽陀曰

  假使身肉皆枯竭　　至于殒灭旷野中
  誓舍国邑诸宫殿　　希求最上佛菩提
  又复发起大精进　　利乐一切诸有情
  于大旷野辽迥处　　舍家出家乐修行
  永愿弃舍诸欲乐　　远离罪业及痴迷
  若于诸染而执着　　应当弃背菩提道
  所有诸欲及王位　　一切誓将皆弃舍
  我于世尊教法中　　愿乐出家行正行
  智者远离诸欲境　　于菩提道志修行
  应发精进勇猛心　　若耽杂染背佛道
  我今于彼诸欲境　　王位欲乐已弃捐
  勤于佛法求出离　　精进愿速成菩提

时转轮圣王。说是伽陀已。即于彼佛亲近供养。发大信敬舍家出家。剃除须发而被法服。王出家已。彼时复有六十百千俱胝那踰多人。亦复发大信敬舍家出家。彼勇猛精进如来化行已毕。复于是时入般涅盘。时转轮圣王。见佛灭度悲感懊恼。收取舍利作供养已。亦复命终上生兜率陀天。彼天没已。而复下生阎浮提中。于彼时分乃得成佛。号曰善行如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛住世一俱胝岁。复有俱胝那踰多大声闻众皆来集会。皆是大阿罗汉。诸漏已尽。无复烦恼。逮得己利。心得自在。到于彼岸。复有十万菩萨摩诃萨众。得不退转住不退地。誓求阿耨多罗三藐三菩提。乃至彼佛说法教化无量阿僧祇有情。作善利已而般涅盘。彼佛灭后正法住世满一劫已。然后分布其佛舍利。供养恭敬。如我灭后分布舍利。等无有异。舍利子。彼净住菩萨摩诃萨。于菩萨精进波罗蜜多之行。而常随学然无懈惓。由于往昔依止一类造作宝锁。有情而住起嫉妒故。舍利子。若菩萨摩诃萨求菩提道时。于他种族发起嫉妒。应知彼时有三种怖。何等为三。一者于非理处而行乞食。二者不应语言而共语言。三者见余苾刍而生嫉妒。如是等处一向增长嫉妒过失。以是因缘。于地狱道如己舍宅。如是于彼行精进者。犹若盲人于诸险难边地。邪见之所受生为彼摄受。舍利子。又见余苾刍心生忿怒。亦不顾视。起嫉妒心令他忿诤。作极恶相出粗犷言。以是因缘。堕地狱道如己舍宅。于彼受生建立种子。纵得人身生诸险难边地邪见。为彼摄受。心无慈愍乐多损害。于他谄曲乐多随顺。舍利子。时彼菩萨摩诃萨。于他种族生嫉妒时。应当思念如是三种怖畏。如是言已。尊者舍利子白佛言。希有世尊。菩萨摩诃萨乃能听闻如来如是行相。于彼种族不生嫉妒。得大善利而得出离。又舍利子言。善哉世尊。我等诸声闻众亦愿闻是法要。云何于彼种族不生嫉妒。而得出离于地狱道及诸生盲险难恶道。皆得解脱。佛告舍利子。无因缘故且止是事。舍利子言。我等云何离诸诽谤不生邪见。常生中国。见佛闻法修声闻行。如是语已。佛告舍利子。善哉善哉。汝能问于如来如是法义。舍利子。若诸有情乐习世间外道典籍。不应为说。若于佛法恭敬信解。志乐修学即当为说。何以故。舍利子。若于世俗外道典籍而不远离。我则说为斗诤根本是佛法难。舍利子。若菩萨摩诃萨。坚固信解不生放逸。于长夜中寻伺观察。于诸有情心生救护。乃能往诣如来咨问法义。闻是法已。欢喜爱乐如说修行

复次舍利子。若诸有情劣弱精进。而求涅盘者不惟难得。亦复转增三种过失。所谓利养尊重名称。而复乐于朋友种族。及诸眷属为自资养。而常贪求作不义利。由此三事而追求故。于三恶道不能解脱。以是劣弱精进故。堕于地狱饿鬼畜生。焰魔罗界障生天道。又复于饿鬼趣中常生斗诤。舍利子。彼诸有情于诸善法不肯信受。而常亲近诸恶朋友。于寂静处不乐本住。而复乐住诸白衣舍。闻诸长者发如是言。若此安住。我愿供给饮食衣服卧具医药。亲近供养。是时苾刍。与彼长者互相谓言。若住旷野谁复亲近。我今于彼爱乐恭敬。苾刍因是深生贪着。住白衣舍。既久住已。与诸种族及彼眷属。互生贪爱。忽有苾刍远方而来。诣彼族中。时旧住苾刍以贪着故。而生嫉妒。谓彼言曰。我本清净亦复多闻。自谓我是须陀洹斯陀含阿那含阿罗汉果。发生如是虚妄谄曲诸恶语言

复次舍利子。时余苾刍亦作是言。我今于此白衣舍中不求久住。彼旧住苾刍互相憎嫉作不义利。舍利子复有一类。于大乘法出恶语言互相诤竞。于诸契经如实行相互相毁谤

复次舍利子。于佛如来所说契经声名句文如是正法。暂时听已得胜解者。于彼有情复生毁谤。如是行相决定堕于恶趣之中。舍利子。又复于彼不退转精进菩萨摩诃萨。而生憎嫉。如是行相亦堕恶趣

尔时舍利子及诸有情。闻此说已。于诸善作不生嫉妒。舍利子。如是菩萨摩诃萨。于精进波罗蜜多。行不退转精进行时。于诸有情生救度想。一切有情为三种病常所烧煮。何等为三。谓贪嗔痴。我当于彼有情。以佛正法积集和合。为大良药。治诸有情此贪嗔痴诸热恼病。我说是名菩萨摩诃萨行不退转精进波罗蜜多之行。又舍利子。一切有情常生热恼。何以故。谓三毒病无时增长。若生天上及在人中。乃至地狱饿鬼畜生焰摩罗界。咸悉为其贪嗔痴毒之所烧煮。菩萨摩诃萨见彼有情热恼所苦。发救度想。又复思惟彼三种病世间药饵无能医疗。云何除灭是三种病。唯佛如来获大法身为大医王。救疗一切有情三毒热恼重病。诸菩萨摩诃萨亦复如是。身为法药为大医王。悉能救疗一切有情。三毒热恼皆令除灭。舍利子。若彼世间种种医药。于三毒病终不能疗。唯是如来及大菩萨。为大医王施大法药。于诸有情三毒热恼。皆能息除。舍利子。白佛言。世尊。如我善解如来所说诸有情界。于意云何。非如地水火风空界唯有情界无量无边。佛告舍利子。如是如是如汝所说。舍利子。彼诸有情众同分界。亦非声闻缘觉之所能见。唯佛天眼悉能遍照。舍利子。所有三千大千世界天人阿修罗。乃至无量无边卵胎湿化。有色无色。有想无想。非有想非无想。如是建立诸有情界。尽佛天眼所能照处。或一刹那一腊缚一牟呼栗多。于此时分不获人身。今乃方得。舍利子。如是人等。设使皆如活命医王善治众病。欲疗一人贪嗔痴毒诸热恼病。终不能得。又复而能和合种种最大良药。量高须弥。欲差一人贪嗔痴病。亦不能得。正使皆如活命医王。各住世间寿命一劫。捣筛和合诸大良药。量过须弥。皆悉疲极。于其一人贪嗔痴病。欲差少分尚不能得。舍利子。唯是如来具足方便清净法药。与三毒病随所相应。若诸有情贪热恼病。如来为说不净观法。和合为药。能疗如是无量百千俱胝那踰多阿僧祇乃至不可说不可记数有情所有贪热恼病。皆悉除愈。又诸有情嗔热恼病。如来为说大慈之法。和合为药。能疗如是无量乃至不可说不可记数有情嗔热恼病。皆悉除愈。又诸有情痴热恼病。如来又说诸缘生法。和合为药。能疗如是无量。乃至不可说不可记数有情痴热恼病。皆悉除愈。以此譬喻应当了知。菩萨摩诃萨。能以如来如是法药。救疗无量无边乃至不可说不可记数有情三毒热恼。皆悉除灭。即是成就如来法身。舍利子。如是住法身菩萨摩诃萨。复以法身加持力故。令无量无边乃至不可说不可记数有情三毒热恼皆悉除灭不复更生。皆悉除灭不复更生。佛言舍利子。我于往昔无量无边阿僧祇劫。于如是法皆悉了知。复于彼时有佛出世。号曰燃灯如来应供正等正觉。彼佛如来与我授记。汝过无量阿僧祇劫。得成为佛。号曰释迦牟尼如来应供正等正觉

佛说大乘菩萨藏正法经卷第二十九佛说大乘菩萨藏正法经卷第三十

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之六

复次舍利子。我于然灯如来应供正等正觉所。获得具足法身。生三十三天。号光明天子为烁迦罗主。有大威德具大神通。名称普闻自在无碍。复于彼时。阎浮提洲有八万四千大城。复有众多城邑聚落。彼诸聚落。有百千俱胝那庾多诸有情类。充满其中。又于彼时疾疫劫起。恶业有情病缘成熟。疥癞[病-丙+(雍-〦)]疽体生疮癣。风黄痰癊积集其身。彼时复有百千医王。和合良药治诸有情。疾病除愈

复次舍利子。时彼有情无归无救。未得愈者高声唱言。若天龙夜叉乾闼婆罗刹婆人非人等耶。能令我病一切苦恼得解脱耶。一切财物悉能舍施。愿为奴仆随意所作供给走使。舍利子。彼无见者。我以天眼清净出过于人。诸有疾病疥癞[病-丙+(雍-〦)]疽体生疮癣。风黄痰癊寒热等病。积集成熟充满其身。乃能见故。无有闻者。彼诸有情高声唱言。我以彼天耳界清净出过于人。乃能闻故。于彼有情起大悲心极生怜愍。我发是念。于无归者为作归依。于无救者为作救护。于未愈者为令除愈。当护安乐。舍利子。我于彼时隐烁迦罗形。去俱卢大城不远。忽然化生成有情相。名曰苏牟。复住空中。为阎浮提诸疾病者。说伽陀曰

  于彼俱卢城不远　　化有情相名苏牟
  彼若来食肢分者　　一切疾病皆除愈
  汝诸有情勿惊怖　　如是食者生欢喜
  彼无嫌恨嗔已除　　此阎浮洲大良药

舍利子。此八万四千大城郡邑聚落。于其中间一切有情闻是声已。即时奔诣俱卢大城。到苏牟所。取彼身肢少分而食。然其身肢都无损减。是时苏牟说伽陀曰

  由菩提道实不虚　　获得无尽智慧蕴
  彼言真实不欺诳　　令我身肢亦无尽

舍利子。时阎浮提洲诸有病者。集苏牟所。取以身肢少分而食。由无尽智如是断已。断已复生。然于肢体旋复生已。无损减故

复次舍利子。诸有病者。于苏牟所食肢分时。诸病除愈安隐快乐得无疾报。如是满阎浮提洲诸有病者。皆悉除愈安隐快乐得无疾报

尔时阎浮提洲诸有情类。若男若女童子童女咸发是言。如我惟忖。今食苏牟疾病除愈安隐快乐。我等应当亲近供养。一时集会诣苏牟所。众共围绕说伽陀曰

  能于我等作归救　　汝是医王及良药
  我等今时何所为　　愿施供养无有吝

舍利子。我于是时。知此有情得安隐已现大烁迦罗形。住众人前而作是言。我今不用王城国土。郡邑聚落舍宅财物。金银琉璃[王*車]璖马瑙珊瑚琥珀诸妙珍宝。象马牛羊辇舆车乘男子女人。童子童女奴婢仆从。饮食衣服床敷卧具。汤药资缘园林池沼。如是玩好悉不复用。我唯教汝。当断杀生永不复作。当断偷盗永不复作。当断邪欲永不复作。当断妄语永不复作。当断两舌永不复作。当断绮语永不复作。以要言之。当断恶口贪嗔邪见。永不复作。时彼大烁迦罗为诸人等。说伽陀曰

  多俱胝数诸财宝　　分量犹如须弥山
  饮食衣服妙天女　　如是等施皆不用
  汝若作是诸供养　　不如修习十善道
  各各共起慈悲心　　于一切时常守护
  菩萨不乐于财利　　唯能护持十善业
  汝等若能共修行　　我说此名真供养
  饮食衣服及卧具　　象马车乘诸珍宝
  如是乃至妙天女　　一切我今皆不受
  汝今听我诚实语　　应修清净十善道
  互相发起慈悲心　　于一切处常守护
  若能摄受如是法　　十善业道常清净

说是伽陀已。告舍利子言。我于彼时于大众中。宣说法要。清净无杂示教利喜。说是法已隐身不现。时阎浮提洲男子女人童男童女。食苏牟者乃至命终。无有一人堕于恶趣。一时皆得生于三十三天。于妙众中受诸快乐。舍利子。彼诸人众生彼天中。闻是法已示教利喜。于彼三乘得决定解。所谓声闻乘缘觉乘无上一切智乘。于彼天中。或复当入涅盘。未入涅盘。现入涅盘。佛言舍利子。汝观菩萨摩诃萨安住法身。云何名为得大神通具大威德名称普闻。我于彼时。唯我一人能舍身命。成熟一切有情三乘涅盘。如是言已。尊者舍利子白佛言。世尊。云何名为菩萨摩诃萨具足法身。佛言舍利子。菩萨摩诃萨法身坚固。犹如金刚无破坏相。殊妙真实不生不灭。又复法身。为度有情不惜躯命。以是缘故。火不能烧物不能坏。又复坚固犹如金刚无破坏相。舍利子。菩萨摩诃萨行不退转精进波罗蜜多行时。如是安住具足法身。成熟有情不惜躯命。亦无言说分别遍计。又知此身犹如虚空。离种种相。身离相故。随能入解一切诸法。离种种相。由离相故。亦不分别是身是法。若于相中身既离相。于一切法亦复如是。若能自身离一种相。即能入解一切有情身离相故。一切有情身离相故。即能入解法界离相。法界离相故。于一切法离相。应如是学。乃至极微细法皆不可得。由彼自身真如。即能随解一切有情身真如。由彼一切有情身真如。即能随解自身真如。由自身真如。即能随解一切法真如。由一切法真如。即能随解自身真如。由自身真如。亦能通解一切佛真如。由一切佛真如。即能通解自身真如。由自身真如。亦能随解过去未来现在真如。由过去未来现在真如。即能随解自身真如。又过去真如与未来真如而无相违。过去真如与现在真如亦无相违。现在真如与过去真如而无相违。未来真如与过去真如亦无相违。又过去真如与未来真如而无相违。未来真如与现在真如亦无相违。现在真如与未来真如而无相违。未来真如与现在真如亦无相违。由现在真如与过去真如而无相违。由过去真如与现在真如亦无相违。又过去真如与未来现在真如亦复如是。又彼蕴处界真如此蕴处界真如。彼染净真如此染净真如。彼涅槃轮回真如此涅槃轮回真如。彼行真如此行真如。一切行真如亦复如是。

复次舍利子。如所说故无别异故。非远离故非影像故。乃至真如无少分相。何以故。真如无相彼说即如来相。如是摄受因果真如。彼说亦如来相。彼菩萨见如是诸相无所造作。即如来相见非违诤。一切色相彼无所动即如来相非真如智。于如来身何可观察。于如来身平等观察。即自身平等。由自身平等观察。即一切身非身平等。由一切身非身平等观察。即于是身而能观察。是故了知一切身相。皆缘生故。于此知己法身决定不可破坏。于诸法身亦复如是。彼得如是法身而能了别非蕴处界。于诸有情见闻觉知乃可化度。作诸义利。舍利子。譬如活命医王。积集和合诸大良药。施众病者。造作童女色相殊妙。犹如最上清净池沼。具足庄严极妙安住。时非时分行住坐卧。复能作彼胜妙事业。复于是时最上最胜大种豪族长者居士。皆来见彼造药童女。时活命医王。普能施与如是触已。诸有病者快乐轻安得无病恼。舍利子。应知唯一活命医王。能令有情疾病除愈。余诸医师不能有故。舍利子。了知法身菩萨摩诃萨亦复如是。乃至有情男子女人童男童女。为贪嗔痴之所烧煮。于彼有情身遍触已。是诸疾病皆悉除愈。而得远离一切热恼。如是菩萨。往昔愿力得清净故

复次舍利子。菩萨摩诃萨不为资身财物饮食等事。然于法身一切取舍无不通达。而或怜愍有情摄受饮食。于其身命亦不弃舍。于法身力亦不取舍亦不损减

复次舍利子。菩萨摩诃萨。然于法身无生无灭。由能示现有生灭故。又能成熟有情。于诸行法了知生灭。又知诸法亦无合集。生处灭处悉皆了知。于彼法身。法食法力常依止法。心无所表。是名往昔愿力成熟有情不退转精进波罗蜜多

尔时世尊。重明此义说伽陀曰

  今乃得成金刚身　　不坏不散佛知故
  刀不能伤火不焚　　度有情时岂超越
  度脱有情猛火害　　若获最上清凉药
  如是有情知见已　　复如得食诸饮膳
  乃至法界无分别　　唯一法身无余身
  无人无我无儒童　　了达诸法缘生故
  观察如能行苦行　　息灭缘故断苦缘
  色蕴非坚水上泡　　受蕴如同于聚沫
  想如渴爱炎时现　　观行芭蕉中不实
  复如幻化诸伎艺　　种种刹那俱离相
  诸有智者所施愿　　了识造作不坚实
  所生资具如电光　　亦如高山流瀑水
  财欲又复同影像　　迅速猛于弓箭势
  了知变易若浮云　　诸有智者无所乐
  不于三界天人所　　受用饮食诸妙乐
  后堕地狱极苦中　　见已不乐于天趣
  彼无依止如傍类　　是人依止离生死
  菩萨当获大法身　　设复成坏无生灭

复次舍利子。菩萨摩诃萨行不退转精进波罗蜜多行时。当如是学。世闻诸不善法皆悉充满。彼对治法亦复如是而不了知。如世有情具三大病。谓贪大病。嗔大病。痴大病。皆不了知。彼诸有情三种大病。三大良药亦复不知。何等为三。贪大病者。以不净观为大良药。嗔大病者。以慈悲观为大良药。痴大病者。以缘起观为大良药。皆不了知。设有医王医余疾病。虽暂除愈而非究竟。于一切病不能除愈。诸有智者不应如是随顺修学。于佛世尊所对治法应当修学。为大医王通达一切无上善法。令诸疾病净尽除愈。是为究竟。于余世间所习医王。乃至少分不应随学。应当积集捣筛和合最上法药。若闻声已。彼贪大病彼嗔大病彼痴大病。皆悉除愈。舍利子。是名菩萨摩诃萨行不退转精进波罗蜜多行时。如是积集捣筛和合大法良药。彼诸声闻缘觉悉不能有。唯如来无上应供正等正觉。为大医王集诸善根。捣筛和合为大法药。吹大法螺出深妙声。普遍三千大千世界使得闻知。能令无量无边百千俱胝那庾多矜羯罗。以要言之。乃至不可说不可说诸有情类。此贪嗔痴三种大病。皆悉除愈。舍利子。譬如雪山林中有大药树王。名离诸毒。能令百庾缮那所住有情闻彼香者。悉除诸毒。舍利子。以离诸毒大药树王。涂之螺鼓吹击其声。若诸有情设有虫毒。药毒气毒及一切毒。闻是声已悉除诸毒。舍利子。此离诸毒大药树王。一切医师悉不能知。唯活命医王独能知解。舍利子。于菩萨摩诃萨大正法药。而能积集捣筛和合。声闻缘觉亦不能有。唯如来能有是故。通达一切善法。为大医王。能令一切有情诸病除愈。于此法药而能积集捣筛和合。吹大法螺出深妙声。普遍三千大千世界使得闻知。能令无量无边百千俱胝那庾多矜羯罗。以要言之。乃至不可说不可说诸有情类。闻是声已。彼贪嗔痴皆悉除灭。云何菩萨摩诃萨积集法财。于何等处而为施用。若菩萨摩诃萨施用法财。唯于菩萨藏正法而为积集。舍利子。菩萨摩诃萨行不退转精进波罗蜜多行时。于菩萨藏正法。受持读诵解说其义。若自书若使人书。乃至广为人说。应如是学。复次舍利子。乃往过去如是展转。广大不可思议阿僧祇劫于彼时分。有佛名莲华超胜如来多陀阿伽度阿罗诃三藐三佛陀。彼佛有八十俱胝大声闻众俱来集会。皆阿罗汉。诸漏已尽无复烦恼。心得自在到于彼岸。彼佛寿量具八万岁。正法住世具五百岁。像法亦尔。彼莲华超胜如来般涅盘后。所有舍利如我灭后等无有异。舍利子。时莲花超胜如来般涅盘已。于百岁后有一菩萨。从他方没来生王家。尔时为母发如是言。我今何缘于此非法种族中生。我今亦依彼正法行。而修行之。由是缘故名正法行

佛说大乘菩萨藏正法经卷第三十佛说大乘菩萨藏正法经卷第三十一

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    精进波罗蜜多品第九之七

尔时舍利子。彼正法行童子为成熟善根故。于二十岁发生净信。舍家出家成苾刍相。受具足戒。住阿兰若大树林中而为宴坐。于虚空中有诸贤圣。潜来教示如是义利。语苾刍言。汝于菩萨藏正法。得不退转精进之行。有大名称当得作佛。时彼苾刍于贤圣所。闻是语已生大欢喜。得未曾有。乃于城邑聚落国土王宫在在处处一切人民。如是寻求菩萨藏正法。又复往诣僧伽蓝中。恭敬礼问苾刍苾刍尼众。云何名为菩萨藏正法。菩萨于阿阇梨及佛法中。复何承事亲近修学。我今欲于诸尊者所寻求菩萨藏正法。若名若字而来听受。彼苾刍等答如是言。非我所知。又窃作是念。彼贤圣言应无虚妄。我于菩萨藏正法未曾听受。于不退精进复何修行。转复问言。具寿尊者。彼莲花超胜如来住何方所。愿赐开示。答言苾刍。莲花超胜如来住是方所。即时往诣所示方所。到已右绕三匝头面礼足。住立佛前发如是言。我今于此结加敷坐。于莲花超胜如来。不得闻是菩萨藏正法。于是方所誓不起立。舍利子。此苾刍七昼夜中。于地方所不退精进。如是坚固过七昼夜。以佛神力。乃见东方世界宝藏如来应供正等正觉。闻彼开演八种法门。此八种法门。能于菩萨藏正法。随顺修学。时彼苾刍。具足闻是不可思议八种法门无有过上。即于方所从坐而起。亦能于菩萨藏正法。开演不退转精进之行。复于城邑聚落国土王宫。满六十年教化无量俱胝天人。令住三乘。时彼苾刍临命终时。作是愿言。生诸佛刹人同分中。于彼没已。生阎浮提洲长者族中。如是生已。乃发是言行正法行。以是因缘。同彼往昔名正法行。发生净信舍家出家。成苾刍相受具足戒。出家未久。复于菩萨藏正法。现前安住。于六万岁。城邑聚落国土王宫。及能开演菩萨藏正法之行。教化无量俱胝天人。成熟三乘。所谓声闻乘缘觉乘无上大乘。临命终时复发誓言。由彼愿力。于阎浮提洲得获人身。王族中生。刹那生已。于虚空中贤圣告言。汝有情界超越诸法。以是缘故立彼名字。为超越诸法成熟有情。于二十年中。发生正信舍家出家。为苾刍相受具足戒。超越诸法正念缘力。于菩萨藏正法。现前安住。舍利子。此超越诸法苾刍。于菩萨藏正法。断诸疑惑。于城邑聚落国土王宫。复能开演。满六万岁。过是数已。令无量俱胝天人阿修罗等。发阿耨多罗三藐三菩提心。临命终时复发愿言。得获人身。于阎浮提洲大娑罗长者种族中生。刹那生已。空中有声。贤圣告言。汝有情界得获正念。以是缘故。立彼名字。为得正念。成熟有情。于二十年中。发生正信舍家出家。成苾刍相受具足戒。由彼往昔如实思念。最上最胜成就多闻。六十年中说法教化。于城邑聚落国土王宫。今诸有情。于菩萨藏正法。复能开演断诸疑惑。又过是数。教化四俱胝天人阿修罗等。成熟三乘。所谓声闻乘缘觉乘无上智佛乘。舍利子。此正法行苾刍。发是愿已即时命终。生于往昔彼地方所宝藏如来佛刹之中。舍利子。彼菩萨摩诃萨。令六十俱胝天人阿修罗等。成熟三乘悉得圆满。舍利子。彼菩萨摩诃萨。中无间隔。于宝藏如来佛刹之中。得不思议最上最胜多闻具足。于彼命终。即时得生莲花超胜如来世界王族之中。往昔教化六十俱胝天人阿修罗等。悉同生彼而为眷属。复于彼时有佛出世。号最上行如来应供正等正觉。彼佛具足寿量八十俱胝岁。彼国人民寿命亦等。彼佛有八十俱胝大声闻众。俱来集会。皆阿罗汉。一一声闻。各有八十俱胝大声闻众。皆是清净大阿罗汉。复于彼时。名勇猛受王童子。多闻成就智慧明达。舍利子。时彼童子。与自眷属八十俱胝。同时往诣最上行如来应供正等正觉所。到已头面礼足。围绕世尊却住一面。时最上行如来。知彼童子往昔因缘心之所念。而为说法

尔时世尊告舍利子言。彼勇猛受王童子。得闻如是往昔相应所修之行。生大欢喜。与自眷属八十俱胝。同发净信舍家出家。成苾刍相受具足戒。尽其形寿常修梵行。求菩提道。时最上行如来告诸大众。此勇猛受王菩萨摩诃萨。我灭度后。次当作佛出现世间。号大精进如来应供正等正觉。彼最上行如来般涅盘后。所有舍利作供养已。受持正法。然后得成阿耨多罗三藐三菩提果。舍利子。彼大精进如来寿量半劫。有无量大声闻众。一一复有二十那踰多。皆是清净大阿罗汉。俱来集会。舍利子。此不退转精进菩萨摩诃萨。行精进波罗蜜多行时。于菩萨藏正法。闻已次第受持读诵。为他人说。乃至生彼大精进如来世界之中。舍利子。若善男子善女人。安住大乘。速疾得成阿耨多罗三藐三菩提不退精进行时。于菩萨藏正法。决定听闻受持读诵。乃至广为人说。何以故。舍利子。此诸菩萨摩诃萨。唯能于菩萨藏正法。如是进求不退转精进之行。舍利子。是名菩萨摩诃萨精进波罗蜜多

    禅定波罗蜜多品第十之一

复次舍利子。云何菩萨摩诃萨。修行进趣菩萨禅定波罗蜜多之行。舍利子。菩萨摩诃萨。应先远离染欲过失诸不善法。于彼寻伺发生喜乐。是名入解初禅定行。舍利子。菩萨摩诃萨。次当远离寻伺于内引生清净洁白心一境性。于彼等持发生喜乐。是名入解二禅定行。舍利子。菩萨摩诃萨。次当舍离贪爱行念正知。唯妙乐受身虽正知。如彼圣人观察舍念离喜妙乐行故。是名入解三禅定行。舍利子。菩萨摩诃萨。次当如是先断苦乐适悦烦恼。无苦无乐舍念清净。是名入解四禅定行。彼如实得圆满清净纯一无杂。正等引心。无余支分及随烦恼不离等持。而能作彼禅定事业。而复圆满五种神通及彼智业。云何名为五种神通。一者天眼二者天耳三者他心四者宿住五者神境。此说名为五种神通。又复云何菩萨于彼天眼乃至神境。而能圆满最上正行神通智业。舍利子。此菩萨如实安住。正等引心圆满清净。纯一无杂及随烦恼。于诸有情心无所欲。而能发起神境等通。此说名为神通智业。又天眼清净出过于人。而能观察诸有情等。初生退没好丑等相。善趣恶趣胜妙下劣。乃至知诸有情业行差别。身语意中具足恶行。起彼邪见诽谤圣贤。而复积集邪见业因。身谢命终。堕于恶趣那落迦中。又复知彼诸有情等身语意中具足善行。起彼正见称赞圣贤。而复积集正见业因。身谢命终。生于善趣或生天界。舍利子。以清净天眼出过于人。于诸有情积集恶业。悉能了知。舍利子。此菩萨摩诃萨清净天眼。于诸有情而为最胜。色相明了悉无障碍。一切天龙夜叉乾闼婆阿修罗。有学无学大阿罗汉辟支佛众。悉胜于彼。最上最胜最极明了无有过上。又此天眼。于彼一切出离道中。最胜出离。而诸菩萨有是天眼。于十方世界无量有情。若粗若细若胜若劣若远若近。而此天眼诸有色相。于彼了知悉无对碍。又此天眼见色究竟。除无色界。所有十方世界无量有情。若生若灭。及彼业因一切根因。若增若减若胜若劣。悉能了知。又彼所有十方世界诸佛刹土功德庄严。一切悉见。清净戒蕴。安住成就胜妙果报。亦皆了知。又彼清净天眼出过于人。诸佛世尊及菩萨众。一切悉见。及彼正士正念正知。通达境界威仪道行。及解脱法得总持门。安住智慧善巧方便。而能入解一切圆满。彼眼无碍诸色无见。彼眼无著诸色无染。彼眼解脱谓离诸见。彼眼清净自体光洁。眼无依止离诸境界。眼无所取离诸烦恼。眼无翳障离诸疑惑。眼不起念离对碍法。眼得光明照烛诸法。眼随智慧离识境界。彼眼无著离难调伏及彼痴冥一切烦恼。眼能决择诸根幻化。又复眼相彼无能胜。于诸有情平等观瞩。彼眼清净离杂思惟。彼眼无垢体性光莹。又彼天眼随其心意。而能现前成熟佛眼。眼无贪嗔离诸违顺。又彼天眼。于义境界修行法式如实相应。又于有情安住大悲。又彼天眼。来求丐者而无不与。见破戒者亦无嗔怒。于堕落者而常守护。于懈怠者而常勤策。为散乱者现禅定分。为恶慧者示正慧眼。为邪道者开悟正道。劣胜解者。导以最上佛之知见。又彼天眼。于一切智智。最上神通。于菩提道。专注一境决定现前。舍利子。此名菩萨摩诃萨而能圆满彼天眼通及智事业

复次舍利子。云何名菩萨摩诃萨得天耳通。及能圆满最上正行神通智业。舍利子。此菩萨摩诃萨。天耳清净出过于人。能闻十方无量世界人非人声。所谓天声龙声夜叉声。乾闼婆声阿修罗声[薩/女]噜拏声紧那罗声摩睺罗声。人非人声。圣人声声闻声缘觉声。菩萨声佛声。是名诸菩萨摩诃萨天耳清净。又复得闻诸罪业声。地狱声傍生声。焰摩罗界声。乃至微细边际。蝴蝶蜂虿蚊蚋等声。及诸有情所发语业。或攀缘心善不善等。一切了知。所发语业善不善根。彼因及果。悉皆了知。若语业贪随染爱所表。若语业嗔随恶骂所表。又语业痴亦随贪嗔所表。皆能了知。即语业痴亦随恶骂所表。若语业唯恶骂所表。即嗔随恶骂所表。彼语业痴。亦即随痴冥所表。悉能了知。又天耳通智。如实了知发生善巧破。彼语业随顺清净由能对破。语业清净。即能对破一切贪嗔痴等。悉令清净。又彼天耳。于圣人非圣人声悉听闻。如是听已。于圣人声不生住着。于非圣人声不着对破。又于圣人声获得大慈。于非圣人声发起大悲。于一切声无前后际。以决定智如实了知。又彼天耳。于十方无余一切世界。得闻如是诸佛世尊所说妙法。闻已念彼所度根器。不生痴冥一切摄受。亦无失念。如彼有情根器入解。了知诸法平等一味。又复不于一佛二佛所说之法。得听声已。不作互相障碍差别事相

佛说大乘菩萨藏正法经卷三十一佛说大乘菩萨藏正法经卷第三十二

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    禅定波罗蜜多品第十之二

复次舍利子。诸佛世尊说彼往昔任持之行。由今善根听闻声故。于时非时分中。获彼所说。若众会时。或说法时。及非时说。而别解行听已能说。又说法时。或众会时。或一苾刍。为彼说法如实记别。于他损害而不为说。又不如实记别择彼相应义理。善巧方便摄受于他。以自心清净洁白。而为彼说。若于色相等声。决定听闻而生欢喜。彼如色相等声。为令听闻决定劝喜。又若处众说法。以天耳识加持彼声。令诸有情而能解了。然彼有情听闻是法。或能解了。又若有情听闻是法。或未解了。彼于是处得法界清净。即耳界智界亦得清净。我以耳界既获清净。而此有情亦获清净。于彼耳界得善出离。如其所说文字义理。及诸有情巧妙言辞。令五趣有情闻说法声。悉令悟入。又能于此天耳界中。而得成就如来天耳。复于此中无杂乱意。此说名为菩萨摩诃萨得天耳通智业圆满。复次舍利子。云何菩萨摩诃萨他心智通及彼正行智业圆满。舍利子。此菩萨摩诃萨。于十方无余一切世界诸有情类。往昔边际心能了知。及彼现在心亦了知。又复过去有情心智。粗因细因种种心智。皆能了知。或此有情最上心因。或此有情中分心因。或此有情最下心因。又此有情根性以布施相应。此有情根性以净戒相应。此有情根性以忍辱相应。此有情根性以精进相应。此有情根性以禅定相应。此有情根性以胜慧相应。又此有情根性以大慈为因。此有情根性以大悲为因。此有情根性以大喜为因。此有情根性以大舍为因。又此有情根性以大乘为因。此有情根性以缘觉乘为因。此有情根性以声闻乘为因。又此有情诸善因力具足成就。又此有情诸善缘力具足成就。若复有情不善因缘力成就故。即此有情。以彼因缘力相应生下劣种族。若复有情善因缘力成就具足。即此有情。以彼因缘力相应生高贵种族。或复有情意中清净。非工巧清净。若或有情工巧清净。非意中清净。若或有情工巧清净亦意中清净。若或有情非意中清净。亦非工巧清净。舍利子。此诸有情往昔根因心所行智。如我相应说法之智。此说名为菩萨摩诃萨他心智力。又复入解他心智力。而此有情行布施因。于未来世得布施果。又此有情行净戒因。于未来世得净戒果。又此有情行忍辱因。于未来世得忍辱果。又此有情行精进因。于未来世得精进果。又此有情行禅定因。于未来世得禅定果。又此有情行胜慧因。于未来世得胜慧果。又此有情行大乘因。于未来世得大乘果。又此有情行缘觉因。于未来世得缘觉果。又此有情行声闻因。于未来世得声闻果。又此有情行世间因。于未来世得世间果。舍利子。若此因缘若彼因缘。于未来世。此诸有情得是根性。如实了知。于彼有情。而能成熟不生厌倦。乃至以智了解。是心根本。若正法器说此正法。又于说法复何所得。为令不作余法余业。若诸有情现在世中。于诸法行广大寻伺。然彼一切皆如实知。又彼着贪心。即如实了知彼着贪心。彼离贪心。亦如实知彼离贪心。彼着嗔心。如实了知彼着嗔心。彼离嗔心。亦如实知彼离嗔心。彼着痴心。如实了知彼着痴心。彼离痴心。亦如实知彼离痴心。若此若彼。有情杂染及障碍心。一切皆能如实了知。如实知已而为说法。欲令彼彼出离烦恼。若复往诣众中如是观察。一切众会若彼若此。于诸有情遍观察已。而为说法。舍利子。此诸有情前际后际。彼根性智一切了知。而菩萨摩诃萨自心无所住着。及彼他心亦无所住。何以故。此菩萨摩诃萨。由智了故心无所住。由念了故心无所住。由慧了故心无所住。由趣向了故心无所住。由胜慧了故心无所住。由觉了故心无所住。由断习气及诸随眠生涩烦恼。离垢光洁无诸过失。于一切法分明了解。于一切有情心行差别。极能入解心无所住。舍利子。于如是行相。入解有情心智。此说是名菩萨摩诃萨得他心通智业圆满

复次舍利子。云何名为菩萨摩诃萨宿住念通及彼正行智业圆满。舍利子。如是菩萨摩诃萨。于十方无余一切世界一切有情。具无量种宿住念通。若一日二日三四五日。若十二十乃至五十日。百生千生百千生无量百千生。乃至百成坏劫千成坏劫百千成坏劫。无量百千成坏劫。诸有情类。于彼往昔。如是名字如是种族如是姓氏。如是色相如是形状。如是住处如是饮食。如是久住如是苦乐。彼彼生灭及于寿量。彼没此生。皆悉了知。又知自身及诸有情。此宿住念非唯一种。自身前际及他补特伽罗前际。此宿住念非唯一种。又自宿因善根念力。及他宿因善根念力。又自善根成熟菩提。令他有情念彼善根发菩提心。又若往昔苦及乐因。皆是随顺无常苦无我等。彼既随顺无常苦无我等。即不乐色相。不乐受用。不乐眷属。不乐富饶。不乐为转轮圣王。不乐为帝释天主。不乐为大梵天王。不乐为护世天王。一切生处自在王位及诸欲乐。皆不爱乐。彼正思惟。是处不为成熟有情。而受轮回。彼唯随顺无常苦无我等。往昔诸烦恼行之所招集。极生追悔起大厌离。及现在事诸不善业。乃至命根厌不复作。往昔善根令于阿耨多罗三藐三菩提根广大成熟。又能积集现在善根。除灭一切险难境界。成熟佛法僧种子。相续不断。成熟一切智智正念缘力。又此正念。以自加持法界加持。不倾动故而无所娆。成熟定业亦无娆恼。于奢摩他。以自加持心无迷乱。于毗钵舍那而为摄受。以现量智无怯弱故。以正忆念无忘失故。受大快乐。积集诸行不由他悟。积集行故趣于彼岸。一切能到积集行故。以正念缘力。过去现在无忘失法。此说是名菩萨摩诃萨宿住念通智业圆满

复次舍利子。云何菩萨摩诃萨于神境通及彼正行智业圆满。舍利子。此菩萨摩诃萨断除诸行。而能具足修习欲神足定。断除诸行。具足修习勤勇神足定。断除诸行。具足修习心神足定。断除诸行。具足修习观神足定。彼欲勤心观摄受诸法。而能修习成出离故。又此四神足数数修习。即于现前获神境通。而得受用。彼无量种神通变化。又此神变。而常观瞩一切有情。一一神变。皆能调伏一切有情。又此神变普能显现。若身若力或复加持。又彼如是一一身相。能往调伏诸有情类。又彼如是一一身相。复能显现。或佛身相。或缘觉身相。或声闻身相。或帝释天身相。或大梵王身相。或护世天身相。或转轮王身相。又彼所现一一身相。而复显现如是身相。能往调伏一切有情。及能[怡-台+龍]悷诸旁生类。又彼所现如是身相。为诸有情演说正法。又复能现如是势力。普为摧伏一切有情极重嗔慢。谓大庄士力。乃至四分那罗延力。乃至半那罗延力。乃至那罗延力。乃至如是诸力。以手二指举须弥山。高六十百千庾缮那。又掷彼山。远八万四千庾缮那。譬如举一庵摩罗果。从此掷置他方世界。而神境通菩萨摩诃萨力。都无动作。又能以三千大千世界。如是广大下从水际至色究竟天。其间有情置于掌中。住经劫数。一切道行普能显现。而菩萨摩诃萨。为彼慢过慢极重忿怒诸有情类。成就力能可伏慢过慢忿怒等。而为说法。又依彼神足得加持智。于加持智。即得如是诸加持法。或以加持大海为牛迹量。复以牛迹为大海量。又或时加持火聚为彼水聚。复以加持水聚而为火聚。以要言之。于上中下法。一切互相加持。亦复获得如是成就世间所有。天人魔梵沙门婆罗门诸有来者。皆无有能振动变易及能出没。又复世间。此加持法无有共者。唯佛世尊能有是故。又以工巧加持缘力。为彼慢过慢极重忿怒诸有情类。广说妙法极令欢喜。又彼修神足者。于魔境界天魔眷属及诸烦恼。而无堕灭。超越自在于佛境界而能入解。于诸有情。乃至少分无有损害。一切善根相应随顺。此说是名菩萨摩诃萨于神境通智业圆满。舍利子。又云何名为菩萨摩诃萨神通。复何名智。以彼天眼正观色相。此说名为神通。彼幻法智不作正行。此说名智。又舍利子。若于一切有情实有所闻。此说名为神通。而于前际过失俱不可得。此说名智。又舍利子。若彼了知一切心行。此说名为神通。于心灭智不灭正行。此说名智。又舍利子。而于前际念彼无碍。此说名为神通。若于三世智都无碍。此说名智。又舍利子。于一切刹土随意往来。此说名为神通。于虚空刹土智都无碍。此说名智。又舍利子。立法分位。此说名为神通。于法观察。此说名智。又舍利子。于诸世间善巧化导。此说名为神通。于诸世间都无系着。此说名智。又舍利子。出过一切释梵护世。此说名为神通。出过一切声闻缘觉。此说名智

复次舍利子。如是所说。是名神通智业圆满。又舍利子。所有烦恼散乱。菩萨摩诃萨定分行心。及加持智。乃至一切有情染心散乱。及菩萨摩诃萨定分行等。应知积集。舍利子。此菩萨摩诃萨。普遍积集而得安住。此说名为三摩呬多。又此一切有情。是名三摩呬多。心常平等。是名三摩呬多。意常平等。是名三摩呬多。善巧平等。是名三摩呬多。意中极深平等。是名三摩呬多。布施平等。是名三摩呬多。持戒平等。是名三摩呬多。忍辱平等。是名三摩呬多。精进平等。是名三摩呬多。禅定平等。是名三摩呬多。胜慧平等。是名三摩呬多。彼一切法平等。是名三摩呬多。若于一切法平等。即一切有情平等。及一切菩提平等。如是普遍入解。此说名为三摩钵那。又若普遍入解诸法如虚空等。此说名为三摩钵那。又若普遍平等入解无相无愿无积集行。此说名为三摩钵那。又若普遍入解诸法音声。此说名为三摩钵那。又于一切饶益不饶益等处。心平等如地。心平等如水。心平等如火。心平等如风。心平等如空。高离掉举。下无昏沉。而善安住。一切道行而得不动。名三摩呬多。于道行自体而无分别。名三摩钵那。虽言辞充满无口过失。无高无下亦无动乱。相应顺成一切世间法义时分。然于世间八法。而能超越。一切烦恼悉无所著。远离愦闹寻伺境界。如是法行名三摩呬多。又于一切世间。工巧造作悉能显现。于彼事相亦不弃舍。而菩萨摩诃萨。于禅定波罗蜜多平等入解。而复出生智慧方便。不为大悲心缘之所随缚。观察有情平等入解。方便寂静极寂静等。是名智慧。令佛智慧不现在前。是名方便。又若平等入解诸法不为随缚。是名智慧。又一切法都无取舍。是名方便。于彼法界无计度念。是名智慧。若于佛身平等入解。不生现前作证。是名方便。于彼法身念无所住。是名智慧。若于佛声相平等入解。于妙梵音具足领悟。是为方便。又复思念法无可说。是为智慧。又于金刚心时平等入解。而能极胜安住。是为方便。于彼正念念无散乱。是为智慧。又于往昔愿是平等入解。而能成熟有情极胜安住。是为方便。于一切有情念无实我。是为智慧。念彼善根证无所证。是为方便。又念彼无根及无住着。是为智慧。又于佛刹平等入解。而使现前清净。是为方便。念彼刹土如虚空等。是为智慧。又念于菩提道场平等入解。而使现前庄严。是为方便。又念彼止息或诸染法。是为智慧。若于转法轮中平等入解。而能普应机缘。是为方便。又念彼转无所转。是为智慧。乃至菩提分行平等入解。而能现前舍离。是为方便。乃至念彼。于一切法而非相应。及诸随惑。以如来智慧禅定妙乐无诸热恼。于相无相一切攀缘降伏。悉皆了知。彼一切菩萨摩诃萨。定非定位以善出离。如是相应。是为智慧。而诸菩萨摩诃萨。获得无尽禅定波罗蜜多。诸有魔事皆不得便。得善安住诸佛法器。舍利子。如是所说智慧方便。彼菩萨摩诃萨。于禅定波罗蜜多。而能出离

佛说大乘菩萨藏正法经卷第三十二佛说大乘菩萨藏正法经卷第三十三

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    禅定波罗蜜多品第十之三

复次舍利子。菩萨摩诃萨得不退转神通。或以意想或以事业。皆是所作游戏神通。复于处处广大安住。现诸所作。彼有所作。神通智力世间最上。于所作事。虽具诸相善能决择。而复现证世出世间第一之法。菩萨神通示无尽相。犹若虚空遍一切处。菩萨神通。现一切相色无色等。复能随顺入一切声。然于前际音声平等。菩萨神通。观察一切有情心行。于其体性随缘显现。于诸劫中随其思念。前际后际无有间断。一切唯现神境变化。决定现前无别行相。菩萨神通达漏尽智。观时分已而无超越。胜出世间决择诸法。所有一切声闻缘觉之所难测。菩萨神通其义甚深。慑坏群魔制伏外道。于菩提场。而能总持一切佛法。志求正觉。随其种类转正法轮。而善调伏一切有情。至灌顶位得法自在

舍利子。此不退转神通菩萨摩诃萨。所作事业悉无我慢。其心清净正善调伏。光洁自在。离诸染欲及随烦恼。微妙寂静所有善业。而悉成就。于禅定解脱三摩地三摩钵底。起正思惟于生死中都无系缚。所以者何。谓彼生业。诸烦恼缚颠倒执着。皆悉解脱。是故于生死中都无系缚。而复不坏大乘成证一切佛法。然彼佛法。十方谛求了不可得。又一切法皆顺佛法。是故佛法即一切法。若一切法如实寻求亦不可得。于算数道及非算数。平等超越无有少分。此说无法亦无非法。若能于法非法遍能了知。是故于此都无住着。又诸法义亦非住着。若着于义非大义利。若复于义非义悉无所住。设见于义而智无碍。若智无碍则无遍计。若无遍计则无有对。若无有对则无所住。若无所住则无间断。若无间断则无虚作。若无虚作则无迷乱。若无迷乱则无我我所。若无我我所则无诤论。若无诤论是沙门法。若无诤论是沙门法。则喻彼虚空。亦如平掌。若喻虚空亦如平掌。彼则不堕欲界色界及无色界。若一切处而无所堕。则无形色。及无显色。亦无分位。若无形色无显色及无分位。彼则如是随顺觉悟。若能如是随顺觉悟。彼则如是随所觉悟。云何说此随顺觉悟及所觉悟。谓若了知彼极微法皆不可得。说此是为随顺觉悟及所觉悟。应当于此平等入解。即能成就菩萨摩诃萨希有之法。云何菩萨摩诃萨希有之法。所谓于慈无我悲无众生。喜无寿者。舍无补特伽罗。布施无彼悔与心持戒生彼寂静心。忍辱发彼无尽心。精进发彼最上心。禅定离彼散乱心。胜慧无彼戏论心。念处无念处作意心。正断随彼生灭心。神足离彼嬉戏心。于信进念定慧。起彼无碍自然平等入解心。如是五根五力。起彼无能损坏屈伏心。于七觉支。起彼分别菩提心。于八圣道。起彼观察正解心。于奢摩他。起彼平等心。于毗钵舍那。发起观察圣谛希有遍知心。成熟有情。发彼本清净心。于彼法界摄受正法。无杂乱心。于无生法忍。起不可得心。于不退转地。起转无转心。于相所获。起无相心。庄严菩提道场。起彼顺三界心。制伏群魔。起彼摄受有情心。于诸法自性菩提。起彼顺觉悟心。于转法轮。起彼无所转心。于大涅盘。起彼随现轮回自性平等心。舍利子。如是所说。是为菩萨摩诃萨于随顺觉悟及所觉悟而能成就希有之法

复次舍利子。云何禅定。谓诸菩萨于彼禅定无所耽着。能于如来三摩地而得圆满。又复不乐禅悦之味。诸菩萨虽复于身适悦。而无取着。复于禅定常乐大悲。以是缘故留诸惑染。又于禅定不退等持。以是缘故厌离欲界。复于禅定修神通业。以是缘故。了知一切有情心行。又于禅定通达实际。以是缘故得心智自在。复于禅定得等至智。以是缘故。普遍一切色无色界。又于禅定至极寂静。以是缘故。于声闻缘觉三摩钵底。而求增长。复于禅定而无动乱。以是缘故住极究竟。又于禅定常行对治。以是缘故。而不住彼相续习气。复于禅定得最胜慧。以是缘故。于诸世间而为第一。又于禅定。而先通解有情心意。以是缘故。诸有情中而为最上。复于禅定。而常自在随乐三宝。以是缘故。获得如来无尽功德。又于禅定得极高胜。以是缘故常住三摩呬多。复于禅定得自在转。以是缘故。而能圆满一切事业。又于禅定悉无所受。以是缘故得大智慧。舍利子。是为菩萨摩诃萨禅定

复次舍利子。禅定波罗蜜多以何为先。所谓决定心为先。一境心为先。不散乱心为先。安住心为先。奢摩他心为先。三摩地心为先。根等持为先。力等持为先。正等等持为先。定解脱为先。九次第定为先。不相违为先。善法为先。降伏烦恼怨贼为先。圆满三摩地蕴为先。菩萨三摩地为先。佛三摩地为先。舍利子。如是寂静之法。是名菩萨摩诃萨所行之行于禅定波罗蜜多为先

尔时世尊欲重宣此义说伽陀曰

  禅定解脱波罗蜜　　常于多劫行是行
  彼世间法意无著　　是名寂照三摩地
  若诸通达波罗蜜　　如电庄严胜高显
  以能勇猛离诸垢　　是名月光三摩地
  成就无忧戒德光　　于诸法中自在转
  斯法高勇若须弥　　是名法光三摩地
  于彼法宝庄严地　　正法总持妙清净
  是心能伺于他心　　名正法智自在转
  定能摧断诸烦恼　　如幢珠网无障碍
  于十力中胜解脱　　名破魔力三摩地
  胜无能胜须弥灯　　彼号智光清净眼
  谓能合掌赞善言　　妙住持地三摩地
  以能入解空无相　　无愿寂静地亦然
  法念功德智自在　　诸佛无边三摩地
  苏难陀龙师子王　　若来若去常安静
  清净眼力无瞬动　　定名远离种种想
  金刚定如金刚地　　高显不动量须弥
  清净音声普遍转　　远离烦恼三摩地
  广大一切功德相　　犹若虚空无边际
  具足增长智慧念　　辩才宣说悉无尽
  观察有情令善作　　无边无尽无损坏
  慈能调柔悲善根　　喜入极喜舍二障
  解脱坚固生欢喜　　如胜莲华金刚幢
  智海智光俱不动　　是名法义三摩地
  无边解脱光明海　　如来定慧愿庄严
  无上正觉妙寂静　　定名不动调伏法
  光明愿得庄严刹　　令有情意悉欢喜
  于正觉道常随顺　　庄严宝髻波罗蜜
  迅速如风无分限　　亦如海藏持众宝
  施真甘露解脱门　　开七觉华三摩地
  大神通义妙摄受　　通达无边悉圆满
  普现如是佛境界　　是名积石山王定
  若修禅定波罗蜜　　安住等引定境界
  菩萨无量功德门　　是名寂静三摩地
  于等引中随作意　　所发言音皆轨范
  乃至行坐威仪中　　如是悉常无放逸
  又此诸法最寂静　　无我无人无寿者
  亦无分别非分别　　唯此无余登彼岸
  若修禅定波罗蜜　　所获无边功德海
  诸有智者菩萨众　　应当怜愍诸有情

    胜慧波罗蜜多品第十一之一

尔时佛告舍利子。云何诸菩萨摩诃萨胜慧波罗蜜多。舍利子。若诸菩萨行不退转菩萨行时。于此菩萨藏正法殊胜义利。毕竟受持读诵听闻广大开示。为他人说。得胜慧相。又彼胜慧。云何是相。云何入解。谓于胜慧所闻之相。随意入解。又复云何是所闻相。所谓乐欲相。意愿相。善和合相。善知识相。变化相。回向相。高贵相。尊重相。右旋相。极自在相。亲近相。不听外境相。承事相。作意相。不散乱相。如求宝相。如求医相。灭一切病苦相。念器相。通达菩提相。对治觉悟相。入佛智相。听无厌相。集法施相。施已无悔相。乐近多闻相。善作欢喜领纳相。大喜遍身相。心大适悦相。听无疲倦相。乐闻正法相。乐闻正行相。乐闻不触无智相。乐闻波罗蜜多相。乐闻菩萨藏正法相。乐闻摄事相。乐闻方便善巧相。乐闻梵行相。乐闻神通相。乐闻四念处相。乐闻四正断相。乐闻四神足相。乐闻十二缘生相。乐闻无常苦无我寂静相。乐闻空无相。无愿解脱相。乐闻不积集不善根行相。乐闻积集善根行相。乐闻单已相。乐闻转法轮相。于杂染中无散乱想相。调伏一切烦恼想相。归向智者相。亲近贤圣相。远离不律仪相。乐闻圣人相。乐闻五根相。乐闻随念观察相。乐闻七觉支相。乐闻八圣道相。乐闻如来十力四无所畏四无量十八不共佛法相

舍利子。而于是中即闻修慧。所以者何。谓于菩萨藏正法。而生乐欲。彼听闻已而能了知。知已能修。若于菩萨藏正法中。意愿听闻。起善和合近善知识。若变化若摄受右旋。若极自在。若亲近多闻不听外境。安住多闻勤勇作意。如求宝想。如求医想。灭贪嗔痴想受持想。若于诸法通达旨趣。及于意乐令智增长。听受无厌。闻布施已能勇悍施。闻说戒已能护净戒。闻说忍已而能忍辱。闻说精进而无懈怠。闻说禅定而不散乱。闻说胜慧心起尽漏。乐胜多闻。及闻法已身心适悦。闻大乘已而生胜欲。闻摄受事心行摄受。闻四念处而身受心法念住。闻四正断。则已生不善而令除灭。未生不善而能弃舍。已生善根而令增长。未生善法而能发起闻说离诤。而身心欲俱获轻安。闻说禅定而心行决定。闻四无量已。于一切有情而起大慈。于彼乐着而起大悲。于诸正法而起大喜。于不善处而起大舍。闻五根已。于信进念定慧而心能行。闻七觉支。于一切法心生觉了。闻八圣道。而能起心趣向涅盘。若于如来十力四无所畏四无量十八不共法。乃至无量佛法。如是当学发阿耨多罗三藐三菩提心。彼听闻已而能了知。知已能修。舍利子。如是所说种种所闻之相。随意入解是为菩萨摩诃萨胜慧波罗蜜多之行

复次舍利子。菩萨行胜慧波罗蜜多行时。而能于此菩萨藏正法殊胜义利。受持读诵听闻广大开示。为他人说。得诸法正行。云何是为诸法正行。谓于是法。如其所说安立正行。舍利子。法正行者。谓若随顺摄受诸法。所以者何。谓法无执着是即正行。若住执着无有是处。于补特伽罗法中。而求出离。亦无是处。若于补特伽罗法。无所执着是名正行。得无疑惑。斯有是处。是故诸修行者。于此正法随顺摄受。而无障碍即为正行

复次舍利子。若于诸法及尊重法。无执无取无生无灭。及于诸法设顺正理。亦应无取。如是所说即为正行。如我今说无有少分。亦无所见。如是无见无取是诸法相。云何为相。所谓有相无相。所以者何。此相无相。说名无相。又此相者。于一切法都无觉了。此无相者无见无取。如是所说即为正行。是故于此正行。应当修习现证诸法得无障碍

尔时世尊。欲重宣此义说伽陀曰

  若于菩萨藏　　不应生决定
  如是诸智者　　得安住正行
  又若于是法　　而或行执取
  及起边执故　　此非为正行
  法虽不可得　　勿作于空解
  况此正妙法　　不同于虚空
  若法同虚空　　世间无领解
  由无领解故　　此非为正行
  又此正妙法　　无取无不取
  是故法非法　　不应生执取
  由无执取故　　此即为法相
  如是行相中　　说名为正行
  又此正妙法　　曾无有住着
  随顺而了知　　无能得损害
  由无所害故　　智都无所解
  如是行相中　　说名为正行
  又复诸智者　　住少欲功德
  于此正法中　　相应善修作
  若诸善安住　　行威仪正行
  而于所向方　　随应得清净
  以所向清净　　知如是正法
  则能于处处　　了有情心意
  又复诸智者　　了彼心意已
  如是行相中　　而能宣正法
  又此甚深法　　通达胜义谛
  于如是义中　　而常获决定
  又复诸智者　　多闻如大海
  以是最深广　　行无量功德
  不假文与义　　能通达正理
  于无量文义　　获坚固不动

复次舍利子。菩萨摩诃萨。行胜慧波罗蜜多行时。于此菩萨藏正法殊胜义利。闻已乃至广为人说。而能获得胜慧光明。于诸法中。无明黑暗盲瞑翳障。悉能除灭。于胜慧光速获成就。善不善法如实了知。乃至命终诸不善法。毕竟断除。闻诸善法如所觉悟。于善寂默而能宣说

尔时世尊欲重宣此义说伽陀曰

  譬如入暗处　　现前诸色相
  彼眼不可见　　以火能破瞑
  如是现在劫　　彼有生死人
  于善不善法　　不听而不知
  由听是法故　　于罪不应作
  及除非义利　　速能趣涅盘
  乐亲近师友　　增长于闻慧
  彼慧清净故　　获得妙乐义
  彼闻义智者　　见非法出离
  于净法勇猛　　得殊胜妙乐
  若于菩萨藏　　闻已住法性
  光明照世间　　真行菩提行

佛说大乘菩萨藏正法经卷第三十三佛说大乘菩萨藏正法经卷第三十四

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之二

复次舍利子。若菩萨摩诃萨。行胜慧波罗蜜多行时。于菩萨藏正法殊胜义利。清净乐欲。而于受持读诵正法者。应当发起善知识想。勇猛精进正摄受心。为欲发彼正愿及四正断。于一切法相应得无障碍

尔时世尊。欲重宣此义。说伽陀曰

  尊重善知识　　得为说法师
  作彼听法众　　常住于正行
  不惜其身命　　精勤而最上
  安住实智中　　得胜慧清净
  自了知正法　　净信无不达
  由觉出离故　　如佛广开示
  亦如诸智者　　善达文句义
  常修清净行　　得预诸学位
  所有染净分　　皆悉无所著
  以无所著故　　于法而无减
  由精进乐欲　　身速获轻安
  听闻是法已　　智增无失念
  常住于智念　　了善不善法
  由学最上乘　　通达念慧力
  知彼有情意　　如我于长夜
  以学是法故　　得胜慧清净
  了有情意已　　为开示正法

复次舍利子。菩萨摩诃萨。于胜慧波罗蜜多微妙清净光明法门。及诸圣者发起正见。如佛所说而修行之。以二因缘。当如是学。何等为二。一者获他言音。二者谓自作意。若诸菩萨。于相应行菩萨藏正法。不能听闻。听已于深法律三摩地门。而得少分欢喜知足者。应知彼是怀增上慢堕魔网中。于生老病死忧悲苦恼及随烦恼。着五欲乐轮回相续。如来以是说彼有情。随顺有漏无能解脱。舍利子。若有亲近法师。于此正法听已了知。而不作罪远非义利。增长闻慧见妙涅盘。清净勇猛得胜妙乐。如是菩萨摩诃萨。当知是为于此菩萨藏正法希有法律殊胜义利。受持读诵乃至听闻广大开示。为他人说得相应行

复次舍利子。若菩萨摩诃萨。于此菩萨藏正法。若不听闻。无能获得彼相应意。而与圣道极相违故。如来以是说彼有情。于老死解脱而常作意。云何是相应意。谓此菩萨摩诃萨。远离相应及不相应。是相应意。于相应意得无增语。又菩萨相应意。谓于音响无能发起。诸阿罗汉亦无能发。然彼所出音响了不可得。于前际后际随所伺察。当云何生至何所灭。若通达过去所说音响。则过去已灭。若通达未来所说音响。则未来未至。若通达现在所说音响。则现在不住。如是已说未说当说。遍一切处寻求俱不可得。于相应意当如是学

舍利子。若菩萨相应意如是学者。云何观察。谓此菩萨。观一切法自性本灭。观一切法自体本寂。观一切法自性平等。观一切法毕竟不生。观一切法毕竟不起。观一切法毕竟不集。观一切法毕竟无灭。于此时分。说如实观亦非所观。如是非所观非不所观。说此是名为观察意。当如是学。若有菩萨于此正法。疑惑痴瞑无能入解。谓言是法非解脱门。断诸勤勇不起通达。而于彼意悉不相应。又复于此诸法正见。即如如见。云何诸法即如如见。所谓无见。如是无见即不生增语。不生增语则不积集。云何不积集。谓于增语而无有对。如来以是所说。观察诸行无生无作。于正见中。由是获得正出离行。又复正出离行以何为因。谓一切法即为佛法。是故欲求正出离行。应当于此菩萨藏正法殊胜义利。受持读诵听闻。为他人说。乃至于此正法得相应意。是名正出离行

复次舍利子。若菩萨行胜慧波罗蜜多行时。于此微妙清净光明法门。正善觉悟。于意处观察生入解意。何等意处云何入解。谓此菩萨。于三摩地加持处。毗钵舍那寻伺处。最上希望处。心乐欲处。相续不断处。无常处。因缘处。缘生处。无我无人无寿者处。无住无不住无去无不去处。不集不坏因果处。空无相无愿惯习处。非空无相无愿所取处。三摩地三摩钵底所取处。非依三摩地三摩钵底发生处。神通智所取处。非漏尽处。观察无生处。非出离行处。观察一切有情无我处。不舍大悲处。见一切生恐怖处。有执心处。出离贪处。不离现行贪法处。舍五欲乐处。不舍法乐处。离一切戏论处。不舍善巧方便处。如是诸法皆生入解。舍利子。说此是为意处入解

复次舍利子。于彼意处。云何说为正理道。所谓以意是道。以门是道。以面门是道。以因是道。以合集是道。以不相违是道。以无诤论是道。以舍是道。无入无不入是道。无戏论是道。无毁呰是道。不增是道。不减是道。不生是道。无所转易是道。无所对治是道。真如是道。实际是道。如来是道。无别异是道。如如是道。三世平等是道。分别不住色受想行识是道。不住眼界色界眼识界是道。不住耳界声界耳识界是道。不住鼻界香界鼻识界是道。不住舌界味界舌识界是道。不住身界触界身识界是道。不住意界法界意识界是道。随顺胜义是道。随顺正智是道。随顺了义契经是道。随顺正法是道。舍利子。说此是名为正理道。又菩萨摩诃萨。以入解意于正理道。由是观察即无所观。如是非观察非不观察。说此是名为观察意

舍利子。若菩萨摩诃萨以相应意。于此正法而有痴瞑。谓言是法非解脱门。断诸勤勇不起增胜。无所通达。而于彼意悉不相应。又诸有情。如是正见即如如见。又复云何为如如见。所谓无见。无见则不生增语。乃至无所对名。如前广说。于此菩萨藏胜慧波罗蜜多之行。当如是学

又复于意无我。于一切法无我亦然。若一切法无我。则于诸有情无我亦然。如是观察。是观察意。又轮回界与涅槃界。平等相应。如是烦恼体性与一切法体性相应。彼相应与不相应。都无所著。于观察意而得胜解。乃至菩萨所有相应无余。加持一切有情而不弃舍。加持正法而无相违。舍利子。说此是为菩萨摩诃萨获相应意所闻之相。于意入解如是观察。彼如如见胜慧不动

复次舍利子。菩萨摩诃萨。行胜慧波罗蜜多行时。得胜慧住。于一切有为法而不共故。所谓无明乃至老死。悉不共住。又于萨迦耶见。乃至本末六十二见。悉不共住。世间八法若毁若誉。悉不共住。五蕴十二处十八界。乃至一切攀缘。悉不共住。又于慢。增上慢邪慢。乃至二十随烦恼。悉不共住。又于上中下品。若粗若细。乃至一切烦恼。悉不共住。又于痴闇盲瞑翳障。系絷等处。乃至一切下劣分法。悉不共住。又于烦恼魔蕴魔天魔死魔。乃至一切魔业。悉不共住。又于我人众生。寿者养者。士夫补特伽罗。意生儒童。乃至一切我见。悉不共住。又于业障烦恼障法障见障报障智障。乃至一切相续习气。悉不共住。又于相障思惟分别。见闻觉知诸所缠缚。悉不共住。又于悭贪布施。毁戒持戒。嗔恚忍辱。懈怠精进。散乱禅定。恶慧胜慧。乃至一切波罗蜜多有无对治。是智非智。悉不共住。又于一切僻报。常与无常。善与不善。有罪无罪。轮回涅盘。乃至一切邪对治法。悉不共住。又于种种佛法。种种刹土。种种有情。悉不共住。又于世俗胜义。有智无智。乃至一切有情作意相等。悉不共住。又于胜慧胜行。有为体相。乃至一切住心意识所造作者。悉不共住。舍利子。是为菩萨摩诃萨胜慧波罗蜜多之行。于如是无量有为行法。悉不共住

复次舍利子。菩萨摩诃萨。行胜慧波罗蜜多行时。于菩萨藏而能安住。于一切法以胜慧决择。而能获得十种善巧。何等为十。一者蕴善巧。二者界善巧。三者处善巧。四者谛善巧。五者正知善巧。六者随顺善巧。七者智识善巧。八者菩提分善巧。九者圣道善巧。十者缘生善巧。云何名蕴善巧。谓此五蕴如聚沫。如水上泡。如阳焰。如芭蕉。如幻如梦。如空谷响。如影。如浮云。如境中像。谓色蕴者犹如聚沫。彼聚沫中。无我无人无众生。无寿者无士夫。无意生无儒童。若世间体性如是。则色蕴体性亦复如是。说此是为色蕴善巧。谓受蕴者如水上泡。彼水泡中。无有我人众者寿者士夫意生儒童。若世间体性如是。则受蕴体性亦复如是。说此是为受蕴善巧。谓想蕴者犹如阳焰。彼阳焰中。无有我人众生寿者。乃至说此是为想蕴善巧。谓行蕴者犹如芭蕉。彼芭蕉中。无有我人众生寿者。乃至说此是为行蕴善巧。谓识蕴者如幻。于彼幻中。无有我人众生寿者。乃至说此是为识蕴善巧

又复说此五蕴。是彼世间刹那变异坏灭之相。若此世间体性如是。则彼世间体性亦然。云何体性。所谓苦无常性。彼蕴体性亦复如是。舍利子。说此是为菩萨摩诃萨于胜慧波罗蜜多之行。而能获得诸蕴善巧

又复云何名界善巧。所谓地界即法界。法界无粗涩相。水界即法界。法界无柔软相。火界即法界。法界无温热相。风界即法界。法界无动转相。眼识界即法界。法界无瞻视相。耳识界即法界。法界无对表声相。鼻识界即法界。法界无能嗅香相。舌识界即法界。法界无能了味相。身识界即法界。法界无能觉触相。意识界即法界。法界无能观察相。如是自体界与法界。无二无别。又复欲界色界无色界。无二无别。轮回界涅盘界。无二无别。此空界一切法界。无二无别。由性空故离分别故。无二无别。以入解有为界。则入解无为界。乃至说无量界。如是决择入解。舍利子。说此是为菩萨摩诃萨。于胜慧波罗蜜多之行。而能获得诸界善巧

又复云何名处善巧。谓此眼处本空。及耳鼻舌身意处本空。彼无有我亦无我所。彼菩萨如是于眼体性。乃至于意体性。如实了知。则无处决择。无种种决择。无善决择。于善不善法无二相转。说此是名为处善巧

又此处善巧。谓眼处色处。如是眼见于色而生厌离。如是厌离则非正行。又彼耳处声处。鼻处香处。舌处味处。身处触处。意处法处。如是乃至意识而生厌离。如是厌离则非正行。又复菩萨于圣道处非圣道处。皆应积集成证大悲。于诸险难非圣道处诸有情类。令住正道。于其道处亦不弃舍。舍利子。说此是为菩萨摩诃萨胜慧波罗蜜多之行。而能获得诸处善巧

又复云何名入解谛善巧。此谛善巧复有四种。所谓苦智集智灭智道智。云何苦智谓不起蕴故。是为苦智。云何集智。谓离爱集故。是为集智。云何灭智。谓灭已不生故。是为灭智。云何道智。谓于平等法。无平等可得故。是名道智。若菩萨于此四谛如是智慧。而不作证成熟有情。说此是为谛善巧

又谛善巧复有三种。所谓世俗谛。胜义谛。相谛。云何世俗谛。谓诸想像音声。语言文字。乃至世间所行。是为世俗谛。云何胜义谛。谓心无所缘。况复文字。是为胜义谛。云何相谛。谓诸相一相。一相无相。是为相谛。彼菩萨。于世俗谛说无疲倦。于胜义谛不失正行。于相谛中随顺无相。是真实相。说此是为菩萨于谛善巧。又复一谛此无二种。所谓寂谛此实一谛。于诸平等及不平等。而能随转真妙作用。而能获得于谛善巧

佛说大乘菩萨藏正法经卷第三十四佛说大乘菩萨藏正法经卷第三十五

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之三

复次舍利子。菩萨摩诃萨。获得如是于谛善巧。由此了知五蕴是苦。若令五蕴苦相止息。犹如虚空。是苦圣谛。又此五蕴随惑爱见。若令执取爱见等因。不起合集。为集圣谛。又此五蕴毕竟灭尽。若令前际不生。后际不起。现在不住。为灭圣谛。若于苦智集智灭智。而能证达以智相续。能善调伏引趣正行。为道圣谛。又复于此诸谛现观。而能寻伺遍尽观察。是为菩萨摩诃萨于谛善巧。又复了知。诸受是苦。乃至受所引摄。诸决择智。是为苦圣谛。若因于受引生于合集。如实了知。是为集圣谛。又若于受而得轻安。则于受非受。而复观察非受是灭。获证于灭。是为灭圣谛。又若受所引道。如彼世间积集进求。非受非道。令彼苦灭引趣正行。是为道圣谛。若见如是四谛平等。毕竟无见。是为清净。是名菩萨摩诃萨于谛善巧。又复于灭而起现证。复能于苦不生观察。是为苦智。若有缘生于有离有。是为集智。了知一切生本不生。灭无所灭。是为灭智。于如是道随其种类。寻求伺察令入其智。是为道智。若能安住如是谛智。说此是为菩萨摩诃萨于胜慧波罗蜜多之行获谛善巧

舍利子。又复菩萨摩诃萨。获得四种正知善巧。何等为四。一者义正知。二者法正知。三者世间典籍正知。四者辩才正知。云何义正知。谓若于法诸胜义句相续。因智缘智集智。通达无边智。入解缘起智。分别法界智。随顺入解真如智。不住实际智。如实法空智。伺察无相智。于愿无愿智。于行无行智。入一正理智。入解无我智。解无众生智。了无寿者智。无补特伽罗胜义智。于过去世无障碍智。于未来世无限量智。于现在世遍一切处智。于蕴幻化智。于处决定空智。于界度量智。内身寂静智。外无遍行智。出离尘境智。念无所住智。达无所入智。胜慧观察智。通达四谛智。诸苦为有智。诸集为行智。诸灭无相智。诸道出离智。分别一切法句智。善解诸根智。诸力无能屈伏智。奢摩他加持智。毗钵舍那光明智。于诸幻化起变灭智。于诸阳焰无迷乱智。于诸梦境无实见智。于诸谷响了缘生智。于诸影像无合集智。于种种相唯一相智。于正和合无所合智。于诸轻安无所得智。于声闻乘达言音智。于缘觉乘解缘生智。于最上乘积集一切善根智。如是所说。是为菩萨于义正知。又复义正知者。若于义随顺则诸法随顺。彼所随义即诸法性。所以者何。以诸法义毕竟如空。若义如空。则诸法义毕竟无相。若义无相。则诸法义毕竟无愿。若义无愿。则彼法义无所趣证。若义无所证。则一切法义毕竟无寿者。无补特伽罗。若义无补特伽罗。则于是义通达法相。若说于义无住无尽。于所说义而获证知。诸佛世尊随喜印可。于彼胜慧如实正知。若于胜慧如实正知。则一切处无有过失。说此是为菩萨于义正知。云何名法正知。谓于正法入解之智。若善不善。有过无过。有漏无漏。世间出世间。有为无为。染分净分。轮回涅盘。法界智界。本自平等无所觉悟。说此是为菩萨于法正知。又复法正知者。于彼贪行心能正知。所谓虚假贪行。坚固贪行。微细贪行。广大贪行。过去贪行。无边观察现在贪行。随缘入解。或复有情内贪而非外贪。或复外贪而非内贪。或复内贪亦外贪。或非内贪亦非外贪。或复色贪非声贪。声贪非色贪。色贪亦声贪。色声俱非贪。色贪非香贪。声贪非香贪。香贪非味贪。味贪非触贪。乃至绮互。于色声香味触贪行等。如是非义利门入解。二万一千贪行。二万一千嗔行。二万一千痴行。如是贪嗔痴。二万一千众等分行如是所说入解。八万四千心行之智。如其所说相应行相智。不增不减智。越百欲界智。殊胜法器智。真实言说智。说此是为菩萨于法正知。云何世间典籍正知。谓若入解一切声智。天声龙声夜叉声。乾闼婆声。阿修罗声。迦楼罗声。紧那罗声。摩睺罗伽声。人声非人声。而能入解。五趣有情粗细高下。说法连环相续不断。音声文字。彼或说一说二说多。男声女声。非男非女声。广说略说。鄙陋说巧妙说。过去说未来说现在说。一字相应多字相应。皆悉了知。说此是为世间典籍正知。又复世间典籍正知者。成熟于文。明了于义。离诸恐畏复无过失。于世俗胜义。以自心知见。甚深巧妙种种庄严。令诸有情咸生欢喜。说此是为菩萨于世间典籍正知。云何菩萨辩才正知。所谓言说无住无断。真实记别迅速辩才。决定获果辩才。如其所问辩才。无减失辩才。无断灭辩才。无诤论辩才。乐善法辩才。住忍辩才。甚深辩才。善巧辩才。世俗胜义辩才。建立一切布施持戒忍辱精进禅定胜慧辩才。建立念处正断神足根力觉支圣道。奢摩他毗钵舍那辩才。入解一切谛智定解脱三摩地三摩钵底辩才。悟一切乘辩才。解一切有情心行辩才。无謇吃语言辩才。无生涩语言辩才。无杂乱语言辩才。润泽语言辩才。清净语言辩才。解脱语言辩才。无障语言辩才。尊重语言辩才。慈爱语言辩才。相应语言辩才。无缺漏语言辩才。甘美语言辩才。细滑语言辩才。无毁呰语言辩才。称赞诸圣语言辩才。通达无边刹土有情。能以妙梵音声随一诠表。如是辩才于他有情补特伽罗。能善说法佛乃印可。彼若说法无出离者。云何能得尽诸苦际。成就正行。舍利子。说此是为菩萨摩诃萨于胜慧波罗蜜多之行。而能获得辩才善巧。云何菩萨随顺善巧。复有四种。何等为四。一者随义不随于文。二者随智不随于识。三者随了义经。不随不了义经。四者随法不随于人。何等为义。云何为文。谓若入解出世法行。此说为义。达世间法。此说为文。若于整肃施以妙乐。此说为义。于无戏论调伏制止。此说为文。若于轮回遍能称说。此说为义。于无所得广大开示。此说为文。若能普遍赞涅槃德。此说为义。于涅槃法体无分别。此说为文。若于三乘分位如其开演。此说为义。智唯通达一种教理。此说为文。于诸有情开演布施。此说为义。三轮清净。此说为文。若能宣演三业威仪。积集一切头陀功德。此说为义。于身语意清净胜行。皆不可得。此说为文。若能宣说坚固忍受忿恨恼嫉倨傲憍慢。此说为义。得无生忍。此说为文。若能开演。于诸善根踊跃精进。此说为义。于彼精进不入不住。此说为文。若能开演静虑解脱等持等至。此说为义。灭等至智。此说为文。于诸慧根多闻总持。此说为义。义不可说。此说为文。若能开示三十七品菩提分法。此说为义。若菩提分现证行果。此说为文。若能开示苦集道谛。此说为义。现证灭谛。此说为文。若正开示无明为先。乃至老死。此说为义。若无明灭。乃至老死灭。此说为文。若说积集止观。此说为义。明解脱智。此说为文。若能分别贪嗔痴等分类行法。此说为义。若于解脱心无所动。此说为文。若能开示诸障碍法。此说为义。若证解脱无障碍智。此说为文。若正开示。善能称赞无量三宝。此说为义。若离贪法性。及无为功德。此说为文。若说菩萨最初发心习学功德。乃至菩提道场。此说为义。说一心相与一切智智。无上正觉。乃至总略八万四千法蕴相应。此说为文。又若一切音声语言文字。乃至不可说义。俱说为义。云何不了义经。谓所说文如其所说。广大了知。此说是为不了义经。云何了义经。谓所说义如其所说广大通达。此说是为了义经。又说随顺补特伽罗无能出离。是不了义。如所说法即能出离。是为了义。如是菩萨摩诃萨。于胜慧波罗蜜多之行。得随顺善巧。云何菩萨文句善巧。谓诸菩萨于此二法。善能修行胜慧波罗蜜多。云何二法。一者善识。二者善智。何者为识。依四种住。何等为四。一者识依色住。二者识依受住。三者识依想住。四者识依行住。此说为识。何者为智。谓若了知所取五蕴。此说为智。又若了知地界水界火界风界。此说为识。若复安住四种法界。于其法界善能分别。此说为智。舍利子。复说于识。谓眼观色为表。耳闻声为表。鼻嗅香为表。舌了味为表。身觉触为表。意知法为表。此说为识。若复内身寂静外无遍行。智能随顺法无所取。此说为智。又若发起遍计执取。此说为识。无执无取及表无嗔。此说为智。又复了知识住生灭有为行法。此说为识。无为无有识遍行故。又智无为不住生灭。此说为智。云何了义不了义经。谓若所说引趣于道。是不了义。引趣于果。是为了义。说世俗行。是不了义。宣说胜义。是为了义。引趣业行。是不了义。尽业烦恼。是为了义。又复染分。是不了义。若说净分。是为了义。于彼轮回而作厌离。是不了义。于轮回涅盘悟不二法。是为了义。善巧文句。是不了义。甚深难解。是为了义。于诸文句心喜乐欲。是不了义。于少文句而生决定。是为了义。又复我人士夫命者。意生儒童作者受者。种种语言。或有主宰及无主宰。是不了义。于空无相无愿三解脱门。不起我人士夫乃至补特伽罗。是为了义。云何补特伽罗及法。谓若于所有法。安住补特伽罗见。由起彼见。而复安住法智法界。此说是为补特伽罗及法。又复补特伽罗者。谓异生补特伽罗。善异生补特伽罗。顺信补特伽罗。顺法补特伽罗。八辈补特伽罗。入流补特伽罗。一来补特伽罗。不还补特伽罗。应供补特伽罗。缘觉补特伽罗。菩萨补特伽罗。若一补特伽罗出现世间。犹能引生多种妙乐。于彼世间天人众会。极深怜愍作诸善利。何况如来应供正等。正觉安住世俗。为一切补特伽罗。令诸有情依如来所说音声。入解义利。佛言此说是。为于法各各随顺乐欲。引趣有情于义安住。云何名法。所谓无作无不作。无住无不住。于一切处。本自平等悉同依止。又诸法相自性本空。无有平等及不平等。离诸分别无所攀缘。而皆出离。此说于其法性。能随顺行得无退转。是故于此正理法门。而得入解一切法性。此说是为菩萨摩诃萨于胜慧波罗蜜多。而得成就四种随顺善巧。云何菩萨福智善巧。菩萨行门有其二种。何等为二。一者福行。二者智行。云何福行。所谓布施福行。持戒福行。修观福行。住等慈心大悲相。应令诸有情悔诸过咎。普令发起一切善根

佛说大乘菩萨藏正法经卷第三十五佛说大乘菩萨藏正法经卷第三十六

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之四

复次舍利子。一切有学阿那含辟支佛。于此福行。应先发起如是胜心。得不退转一生补处。次当作佛。菩萨摩诃萨亦应于此发随喜心。过去未来现在诸佛世尊。此福行中一切善根亦皆随喜。劝请诸佛转妙法轮。此福行中以一切菩提善根。悉共回向。未发菩提心者。语令发起。已发菩提心者。诸菩萨为说回向。以利养摄诸贫穷。以医药施诸疾病。于诸怯弱。亦当亲近为作怜愍。于诸毁戒以法覆护。出离罪报令住涅槃。于和尚阿阇梨。尊重供养如佛世尊。于讲法处精进勇猛。求诸法师设百由旬。亦应故往乐闻正法而无厌足。于说法者无所希望。常当亲近恭敬供养。如己父母不生疲厌。又福行中。于身口意不生动乱。离诸过失。住佛塔庙。摄受梵福集诸善本。圆满相好庄严化身。离诸口过庄严。语业。决定胜解庄严一心。游戏神通庄严佛刹。以清净智庄严法相。闻彼正法离诸障碍。得无障碍。于说法者欢喜称赞。于所说法不生执着。亦无损坏如是庄严解脱法门。以诸园林施佛及僧。如是庄严佛菩提树。植诸善本怜愍一切。业惑清净得无生灭。如是庄严菩提道场。发无尽愿施诸玩好。获得圆满无尽宝手。远离颦蹙平等如掌乐施一切。而先获得面目端严。彼诸有情共喜乐见。光净严饰施诸有情。而获光明普照一切。赞美言辞非由积习。戒福德藏悉皆清净。生人天中。十善道业亦复清净。神通变化亦不唐捐。顺诸佛教不起分别。深心清净平等开化。为诸有情之所爱敬。于最上法及胜解行。随力为说。而能摄受一切福行。又当发起一切智心具七圣财信为先行。一切世间之所爱敬。是故决定最先开导。而能圆满一切佛法及诸善法。此说是为菩萨摩诃萨福行善巧。云何诸菩萨智行善巧。谓于因缘发生智解。云何因缘。谓深心乐欲随知法会。勤求善友住于佛智。不依声闻辟支佛智。于论议师极生信乐。其说法者。知彼器已内心具足。于其智慧无有悭惜。相续为说甚深妙法。彼闻法者为作如是求法相应。则能于此智行相应。云何求法相应。谓于法师得是少义。而于初夜后夜思择称量。此等云何是理非理展转研究。乃至心无所得。离诸障碍。及无垢染。得出离智发真实行。于此甚深法。广大法无边法。胜外道法。智解通彻常放光明。最极高显踰于山峰。勇猛精进不舍重担。行殊胜行心唯一境。富乐作意不舍杜多。常乐法乐不持世行。求出世法忆念不忘。随为宣说。圣族弟子咸皆欢喜。开导胜缘。奉持禁戒惭愧庄严。趣向佛道无明暗蔽。诸无智者。悉自远离而得慧眼清净。广大觉悟深妙觉悟极妙觉悟。以观察智。复能分别自他功德。而使纯熟圆满清净业报。是为菩萨摩诃萨智行善巧。复次求智菩萨。于法师所行四种施。何等为四。谓桦皮纸笔墨等及妙法座。一切利养法集偈赞。是为四种。于智行中而得成办。又智行中于法师所。应当成就四种守护。何等为四。一者守护身。二者守护善。三者守护处所。四者守护所化徒众。是名为四。又智行中。而复成就四种重担。何等为四。所谓法智财物及与菩提。是为四种。又智行中成就五力。一者信力于法胜解。二者精进力勤求多闻。三者念力于菩提心而无忘失。四者定力于一切法决定平等。五者胜慧力复乐多闻。是为五种。于智行中而得圆满。又智行中成就四戒。何等为四。谓真实法戒。勤求法戒。决定法戒。向菩提戒。是名为四。又诸勤求法者。于智行中成就四忍。何等为四。一者敝恶人来毁生骂辱。不应加报。善言悔谢。二者风日寒热及饥渴等。悉能忍受。三者于和尚阿阇梨。随转给侍。四者于空无相无愿三解脱门。住大法忍。是为四种。又复成就四种精进。何等为四。所谓多闻精进。总持精进。辩说精进。正行精进。是为四种。又智行中。而复成就四种胜定。何等为四。所谓离相寂静。心一境性。入神通定。悟佛知见。是名为四。又智行中成就四法。云何为四。谓诸有不住。非自然性四缘生灭是无主宰。唯一信解。是名四法。又复成就四种方便。何等为四。一者随转世间。二者随转契经。三者随转于法。四者随转于智。是为四种。于智行中而得具足。又复成就四无碍道。何等为四。所谓波罗蜜多。七菩提分。八圣道支。及一切智智。是为四种无障碍道。又复成就四种无厌。何等为四。谓多闻无厌。辩说无厌。寻伺无厌。智慧无厌。是名四种。又智行中如是知见。而复随顺一切有情一切刹土。即布施持戒忍辱精进禅定胜慧慈悲喜舍。所以者何。舍利子。乃至诸菩萨。决定于诸智中。以是知见而为先行。彼若安住是智。而得通达一切智行。诸佛威神之所护念。诸有魔等皆不得便。普为集会一切智智。舍利子。是为菩萨摩诃萨于胜慧波罗蜜多得智行善巧。云何诸菩萨念处善巧。菩萨念处此有四种。何等为四。一者以身观身念处。二者以受观受念处。三者以心观心念处。四者以法观法念处。云何以身观身念处。舍利子。此诸菩萨修身观时。观身前际观身后际。观身现在。而此身者从颠倒生。随因缘灭。无动无作无自性无执取。譬如诸外山林药草种等。从因缘生。亦无自性及无执取。又此身者如墙壁瓦砾草木影像。谓蕴处界。是无执是空。是无我我所。是无常是速朽灭。是不精实。是颠倒法。是可厌离。是不坚固诸菩萨摩诃萨应如是观。当乐勤求坚固之身。所以者何。谓如来身。如来身者。即法界身金刚身。不可坏身坚固身。于三界一切最胜妙身。修是观时。当知凡夫粗重秽恶具诸过患。彼复能离一切过患。得获如来最妙身相。又当观念诸有情身。由何所造相续不断。谓四大种及阿赖耶识。造作执持。薰习功能有无量力。譬如地界水界火界风界。外四大种有种种门种种处种种名种种相种种物。由是一切有情任持命根。身四大种集起。亦复如是。有种种门种种处种种名种种相种种物。由是一切有情。于其命根亦复任持。以别相观身无常。而不厌离生死。以别相观身是苦。而不乐住涅槃。以别相观身无我。而不远离化度有情。以别相观身空寂。而无毕竟寂灭。以别相观身远离而不舍善法。彼能如是以身观身者。应当了知。是不坚固是不可爱。观内身者。而知烦恼不能容受。观外身者。了诸烦恼不共合集。而得成就清净身业。及得清净庄严身相。为诸天人之所赞仰。舍利子。是为菩萨摩诃萨得以身观身念处。云何诸菩萨以受观受念处。谓诸菩萨于彼一切苦乐等受。应以智慧方便善可了知。于诸乐受无贪惜意。若见诸恶道受苦触时。起大悲心无缘息意。于苦乐受触。无无明意随念了知。如是苦乐非苦非乐。得出离见。而诸菩萨以智慧方便。于诸有情。或为成就或为远离。然此有情于受出离。无所知解。于此乐受随乐施与。于彼苦受随为除灭。于非苦乐受。随顺一切智智。得获轻安。以大方便善巧。而摄受之为说妙法。令诸有情亦获轻安。何等因缘说如是受。谓于善成就而有乐受。于不善成就乃有苦受。复于是处。我人众生寿者。起种种受。所谓执受。取受。颠倒受。遍计受。恶见受。眼想受乃至意想受。色想受乃至法想受。乃至眼触为缘所生诸受。以要言之。乃至于内外法。意触为缘所生诸受。是中或苦或乐。非苦非乐。说名为受

复次于总聚中。或有一受。谓一心所表。二受。谓内外所表。三受。谓过去未来现在所表。四受。谓四大所表。五受。谓五蕴作意。六受。谓六处遍计。七受。谓七识住处。八受。谓八邪相应。九受。谓九有情居。十受。谓十善业道。乃至总略诸受。种种作意。是故应知有情无量。受亦无量。又诸菩萨观乐受时。见诸有情住生死际。令发智慧。为彼开示善不善受。舍利子。是为菩萨摩诃萨以受观受念处。云何诸菩萨以心观心念处。谓诸菩萨秘密守护正念不动。观察此心速疾生灭。无有状貌及无住处。亦不在内亦不在外。不在中间。知初发心最极微量。远离心相。于其方分了不能得。是心所集一切善根。最极微量亦皆远离。及无方分。又于是心回向菩提。于自体相。无心所了。无心所观。无心所入。佛言。是故得成阿耨多罗三藐三菩提。何以故。谓菩提心与彼善心。于其作用而不共行。又善根心与菩提心。亦不共行。又善根心与回向心。亦不共行。又回向心与菩提心及善根心。悉不共行。应当如是观察。不生惊怖。次复获得甚深缘起。不坏因果。然法性心即有情自性。如是还属诸法因缘。无动无作及无主宰。彼如覆障不共相应。是故应知。此法性心亦不共行。云何法性及覆障心。法性心者。谓于是处悉无所施。若复以一切所有。回向遍覆庄严佛刹。是心覆障。如彼幻化。于刹那顷最极寂净。名法性心。若复集诸禁戒。回向一切迅疾神通。是心覆障。犹如梦想。毕竟尽尽无余。名法性心。若复乐忍辱力。乃至回向遍覆庄严。是心覆障。犹如阳焰。毕竟离身心相。名法性心。若复发起一切精进。回向圆满一切佛法。是心覆障。如水中月无执无见。名法性心。若复以一切禅定解脱三摩地三摩钵底。回向诸佛三昧。是为覆障。无色无见无对无表。名法性心。若复以智分别。宣说一切清净句义。回向圆满诸佛智慧。是为覆障。种种施设。名法性心。若复于诸善根有所间断。是为覆障。心无因生。名法性心。若复因菩提分法所起。是为覆障。解脱六境。名法性心。若复于佛境界有所断灭。是为覆障。舍利子。菩萨摩诃萨。如是行以观心行时。安住神通。得彼神通于一心中。而能了知一切有情心之所趣。知已随其本性而为说法。又复安住大悲。得彼大悲而能化度一切有情。无有疲倦。于此观行加持是心。无尽无灭。设复入生死际断诸系缚而于此心念智不起。超诸行法。一切声闻辟支佛所不能及。而得安住。是心乃至圆满一切佛法。是心于刹那顷。能与胜慧平等相应。决定成就阿耨多罗三藐三菩提果。舍利子。是名菩萨摩诃萨以心观心念处

佛说大乘菩萨藏正法经卷第三十六佛说大乘菩萨藏正法经卷第三十七

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之五

佛告舍利子。云何诸菩萨以法观法念处。谓诸菩萨以圣慧眼得见诸法。于中入解。乃至菩提道场。观诸法性。如微尘许悉无所见。若空解脱即无相解脱。无愿解脱。不起解脱。无生解脱。无作解脱。无性解脱。缘生解脱。而诸菩萨于一切法。应如是观。云何名法。谓无我义无人义。无众生义无寿者义。是名为法。云何非法。谓我见人见。众生见寿者见。常见断见。有见无见。是名非法。又舍利子。此法非法。即摄一切法及非法。所以者何。谓空无相无愿三解脱门。遍能了知。即是诸法。于我见等深心系着。即诸非法。是故菩萨修法观时。最极微量悉无所见。于解脱法及菩提道。悉皆出离得无障碍。于诸有情不起爱见大悲之想。彼无烦恼及随烦恼。所以者何。如其了义平等入解。人法俱空。无有烦恼之所积集。而能觉悟彼烦恼自性即菩提性。此菩提自性即烦恼性。如是念处诸法平等。犹如虚空。又诸菩萨修法观时。于诸佛法而能对治。观诸有情尽彼生智。证彼无为离无生智。于无生际无所弃舍。如是通达法观念处。即得安住一切法念。于一切声闻辟支佛法。不起爱乐。决定安住诸佛念处。常不忘失。及无痴迷。乃至最后边际法观念处。能说无量不共境界。平等入解一切佛法。令诸有情心生欢喜。一切魔法自然知解。此说是名以法观法念处。舍利子。诸菩萨摩诃萨于胜慧波罗蜜多。获得如是四种念处善巧。云何诸菩萨菩提分善巧。菩提分法此有七种。何等为七。一者念菩提分。二者择法菩提分。三者精进菩提分。四者乐菩提分。五者适悦菩提分。六者三摩地菩提分。七者舍菩提分。是名为七。云何念菩提分。谓念所悟法。观察分别条析拣择。及与开解。又应念彼法自体相。随顺觉悟。如诸法空随念了知。此说是名念菩提分。云何择法菩提分。谓于八万四千法总聚中。以智思择。如法择已。彼是了义即是了义。彼非了义即非了义。彼是世俗即是世俗。彼是胜义即是胜义。彼是秘密即是秘密。彼是决定即是决定。如其思择。此说是名择法菩提分。云何精进菩提分。谓于法思择舍离知解。乐修禅定寂静轻安。应当以勤勇力摧伏彼执。于菩提道乐欲不退。不舍重担。此说是名精进菩提分。云何乐菩提分。谓乐闻法音。其心清净不生疲厌。离诸攀缘及烦恼缚。志诚渴仰。乃至身毛喜竖得大法乐。此说是名乐菩提分。云何适悦菩提分。谓于三摩地。离诸障碍惛掉等性。令彼身心俱获轻安。此说是名适悦菩提分。云何三摩地菩提分。谓于等引心。了诸法智安住甚深。观诸法性悉皆平等。此说是名三摩地菩提分。云何舍菩提分。谓于忧喜分法心无所动。于世间法亦不增减。随顺圣道。于自他共无住无动及无损恼。此说是名舍菩提分。舍利子。诸菩萨摩诃萨。于胜慧波罗蜜多。获得如是七种菩提分善巧。云何诸菩萨圣道善巧。此有八种。何等为八。一者正见。二者正分别。三者正语。四者正业。五者正命。六者正勤。七者正念。八者正定。是名为八。云何正见。谓于是见超诸世间。不从我见人见众生见寿者见之所发生。亦不从常见断见有见无见善不善见乃至涅槃见之所发生。是名正见。云何正分别。谓分别贪嗔痴等及诸烦恼。令不发起。分别戒定慧。解脱解脱知见。令得安住。是名正分别。云何正语。谓于自他善友。言无彼此。具足相应入平等道。是名正语。云何正业。谓于黑业报使无造作。令彼尽尽。于白业报自类和合。令善纯熟。是名正业。云何正命。谓圣族弟子。荷负重担为圣道故。增长圆满资养身命。不以杂乱欺诳恶求多求。他所得利不生悔恼。于自利养。随其所得不生喜乐。是名正命。云何正勤。谓于邪行贪嗔痴等及随烦恼。不起勤勇。入圣谛道趣涅槃果。而能随顺起大勤勇。是名正勤。云何正念。谓于是念安住正道。离诸谄曲轮回过失。乃至见涅槃道。于如是念亦当远离。而于圣道无有迷乱。是名正念。云何正定。谓正达平等即诸法平等安住等持于彼正达而能超越。又复菩萨安住等持。能令解脱一切有情。于前正达亦能超越。是名正定。又过现未来诸佛世尊。为诸菩萨于八圣道。平等开示无尽圣道。舍利子。菩萨摩诃萨于圣道善巧。应当修习助道之法。云何助道。谓奢摩他及毗钵舍那。是名助道。云何奢摩他。谓令心淡泊。寂静极静至极寂静。摄护诸根不动不摇。无有高下。口唯慎密亦无谄诈。心一境性。远离愦闹及诸险难。乐处空闲。于其身命清净调适。威仪道行而常谨密。乃至具足资养。知时知分及知数量。设闻诽谤亦应安忍。转复深心常乐宴坐。是故定分作意。于慈悲喜舍。以方便无碍安住修观。从初禅定乃至第八禅定。于奢摩他。应先修习我说。于此复有无量奢摩他行。于是行中亦当随顺。是名奢摩他。云何毗钵舍那。谓于智慧分观诸法空。无有我人众生寿者。观彼五蕴犹如幻化。观十八界即法界性。观十二处如空聚落。观眼等根随境别转。观诸缘起不相违背。观众生见毕竟远离。又复观因必招果报。观果如现前证得。观诸正达转复超越。又毗钵舍那者。谓于诸法如空所见。无相无愿而无别异。观无有因无起灭处。见无所得得无所观。于无所观。更复谛察观无所观。知能观者亦复如是。如是观者即如实观。于如实观。而能获得真实善巧毗钵舍那。是诸菩萨。于此行中而无堕落。于诸善根亦无住着。舍利子。是为菩萨摩诃萨于胜慧波罗蜜多获得如是助道之法。又诸菩萨。于正道善巧有四种相。何等为四。一者未生罪业诸不善法。欲令不起。二者已生罪业诸不善法。欲令除断。三者未生善法。欲令发起。四者已生善法。欲令久住无所损坏。修诸观行使无忘失。发精进心摄受正愿。向来所说诸不善法。欲令不起。深心作意悉是增语。发精进心摄受正愿。深心观察亦复增语。所以者何。谓法无合集深心解脱。是名善法。云何名不善法。谓于戒定慧有所对治。云何于戒对治。谓于戒名字及所作法。毁犯堕落。云何于定对治。谓于三摩地蕴起散乱心。破坏圣行。云何于慧对治。谓于所有法数数起见。作诸碍解。于胜慧蕴有所趣向。损坏无见。是名于戒定慧有所对治。向来所说。已生罪业诸不善法。如是行相深心作意。欲令除断。发精进心摄受正愿。此不善法以心覆护。不应开示。一切善法心常集行。于所对治贪嗔痴等。悉应了知因攀缘生。以不净观对除贪欲。以慈悲观对除嗔恚。以缘生观对除痴闇。净诸烦恼斯为解脱。又复所有不应普断。于一切法而生观察。此说是名初二正断。又如是说。未生善法欲令发起。发精进心摄受正愿。此有无量。所以者何。谓诸菩萨植诸善本。精进乐欲摄受胜行。如是积集无量善法。此说是名第三正断。又正断者。已生善法。欲令久住无所损坏。使无忘失。发精进心摄受正愿。若以此善根回向菩提。则是增语。所以者何。无有菩提可回向故。于此善根则无破坏。何以故。如其发心不出三界故。若出三界。于此善根即应尽尽。所以者何。如其发心出三界故。若不出三界。而能回向一切智智。于此善根则无有尽。此说是名第四正断。舍利子。是为菩萨摩诃萨于胜慧波罗蜜多之行获得四种正道善巧

复次诸菩萨于正道善巧。有五种相。何等为五。一者信根。二者精进根。三者念根。四者三摩地根。五者胜慧根。云何信根。信有四法。何等为四。谓起正见。信有世间及轮回行。获彼业报而为对治。由彼命根不造罪业。信菩萨行如彼修行。资身之具不生乐着。于甚深胜义及诸了义。发生正解。于有情行。信一切法空无相相。于诸见造作。不乐信解。于诸佛法力无畏等。闻已离诸爱着。及余言说彼诸佛法。悉皆积集。此说是名信根。云何精进根。谓信是法发起精进。此说是名精进根。由此精进积集诸法。于其念根无所破坏。是名念根。由此念根无所破坏。而于诸法三摩地根。唯一境性。是名三摩地根。由此三摩地根唯一境性。以彼慧根观察诸法。而能了知。是名慧根。如是于此五根积集系属。即得圆满一切佛法。至授记地。譬如外五神通不受胎藏。乃至获得出离界女等根。如诸佛世尊及诸菩萨。于此五根而得成就。此说是名菩萨摩诃萨于胜慧波罗蜜多获得五种正道善巧。舍利子。又菩萨正道有五种相。何等为五。一者信力。二者精进力。三者念力。四者三摩地力。五者胜慧力。云何信力。谓于法信解。设魔波旬化作佛身。而来亲近为说别法。以信力故。于此正法。一尘沙数莫能破坏。以智伺察悉为除断。又魔所说此非佛法。于四大种及诸业报。颠倒积集。而诸菩萨以信解力。深心伺察皆不信受。此说是名菩萨信力。云何菩萨精进力。谓能发起勇猛精进。入解善法。在在处处得坚固力。若天若人彼所有力。乃至菩萨所住之处。无能倾动。是名菩萨精进力。云何菩萨念力。谓于法念处其心安住。彼彼烦恼不能娆乱。以念力故破诸烦恼。而复得此清净正念。是名菩萨念力。云何菩萨三摩地力。谓独处闲静离诸愦闹。一切语言音声悉皆远离。无有攀缘对治。名最初禅定。于善寻伺得无障碍。名第二禅定。于喜乐行得无障碍。名第三禅定。于摄受正法化度有情。得无弃舍无有障碍。名第四禅定。于四禅行。彼对治法不能破坏。于彼定处亦不远离。于三摩地不生爱着。是名菩萨三摩地力。云何菩萨胜慧力。谓于刹那。而能了知世出世法。于如是智无能破坏。一切工巧。乃至世间种种技艺。若近若远难作能作。而诸菩萨现前获得出世间法。谓智慧高显胜诸世间。一切天人阿修罗等。无能破坏。是名菩萨胜慧力。舍利子。菩萨摩诃萨。于胜慧波罗蜜多。获得如是五种正道善巧

佛说大乘菩萨藏正法经卷第三十七佛说大乘菩萨藏正法经卷第三十八

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之六

复次舍利子。略说菩萨一种圣道。谓是菩萨于阿耨多罗三藐三菩提。单己无二。以自勇猛大精进力。深心摄受。不藉他缘及他开示。而自成办极大力用。能被如是坚固甲胄。而诸有情难得能得。诸新发意住菩萨乘。未得今得。又复一切难施能施。持戒忍辱精进禅定胜慧。亦复如是。又于波罗蜜多无能建立者。而是菩萨。于诸波罗蜜多悉能建立。以要言之。乃至广大觉悟种诸善根。无能及者。于是法行单己无二。诣菩提场坐金刚座。摧伏魔力。一刹那顷胜慧相应。于阿耨多罗三藐三菩提果。决定平等无复退转。舍利子。是名菩萨摩诃萨于胜慧波罗蜜多获得菩萨圣道善巧

云何菩萨缘生善巧。谓此菩萨于昼夜中。独处宴坐发善寻伺。蕴由何起当由何力。谓由如是不如理作意。发生无明。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。及随烦恼方便集起。又复由如是法。无体无作及无主宰。谓善因恶因无记因。一切缘生。又诸有情各有分量。谓根因增上根因业因果因。有无边际究竟等因。一切集生而皆了知。此说是名缘生善巧。又复蕴灭。当云何灭。谓不如理作意灭。则无明灭。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。而于此中得如是智。又缘生善巧者。谓一切法系属因缘之所和合。即能加持。无我无人无众生无寿者。于如是等得无计度。而诸菩萨于此缘生。复能建立一切佛法及菩提相。于有尽灭应妙观察。于无尽灭摄化有情。舍利子。菩萨摩诃萨于胜慧波罗蜜多。获得如是缘生善巧

云何菩萨一切法善巧。一切法者。谓有为无为。而诸菩萨于有为无为善巧。应如是知。有为善巧者。谓身语意所有善行。观察有为菩提向一切智。是名有为善巧。又有为善巧者。谓积集布施持戒忍辱精进禅定五种波罗蜜多。若复于胜慧波罗蜜多得无为智。于五波罗蜜多亦无弃舍。善求一切波罗蜜多。信解无漏菩提向一切智。是名无为善巧。又有为善巧者。谓于有情行四摄事无所对遣。虽复摄受有情。而实摄受无我无人。于摄事善巧亦无所取。信解无为菩提向一切智。是名无为善巧。又复有为善巧者。谓断诸行相续系缚。即断轮回及烦恼缚。于菩提相。有所任持相续系缚。微细方分而不集行。此说是名有为善巧。若复于空无相无愿。以智伺察善解诸法因缘。修菩提行而不取证无为。是名无为善巧。又复虽行三界。而不为三界烦恼之所系着。是名有为善巧。若以智了知出离三界。而不离三界。亦无堕落。是名无为善巧。若说一切法善巧。即一切智悉是增语。若于一切智。通达圆满无所损减。说此胜慧善巧。是即名为一切法善巧。舍利子。诸菩萨摩诃萨安住胜慧波罗蜜多行时。于胜慧分。获得如是十种善巧

佛告舍利子。云何胜慧。云何波罗蜜多。胜慧者。谓观察了知善不善法。是名胜慧。分别无量如实法门。是名胜慧。通达诸见得无碍法。是名胜慧。安住一切正愿。而实舍诸愿求。是名胜慧。离诸热恼而得轻安。是名胜慧。断诸攀缘得大法乐。是名胜慧。随义观察。是名胜慧。得住一切菩提分法。是名胜慧于相无相如实了知。是名胜慧。以智照解诸法体性。是名胜慧。超诸险难获无障碍。是名胜慧。摄受正达。是名胜慧。于诸善法使得清净。是名胜慧。断烦恼习。是名胜慧。由先修证一切善法。是名胜慧。于自然生等。而起觉悟引导远离。是名胜慧。不着三界。是名胜慧。于诸圣愿相续不断。是名胜慧。以诸无相伏除遍计。对治清净。是名胜慧。离诸闇钝。成就一切相应行地。是名胜慧。于一切智智住光明道。是名胜慧。于无明闇蔽作诸明眼。是名胜慧。如是信解得无漏眼根。是名胜慧。于眼境道超诸胜义。是名胜慧。真实出离不动调伏。是名胜慧。照智慧门无有穷尽。是名胜慧。遍一切处无有相违。是名胜慧。于解脱道而常高显。是名胜慧。离诸烦恼及障碍法。悉不共住。是名胜慧。舍利子。诸菩萨以如是胜慧。而能入解一切有情心之所趣。业行差别诸尘劳门。乃至以如是慧。于执持门。而能遍知一切声闻辟支佛三藐三佛陀。此说是名胜慧。而诸菩萨。于是句义一切当学。又舍利子。波罗蜜多者。谓是胜慧了知一切善不善法。名波罗蜜多。以要言之。乃至于是句义一切当学。名波罗蜜多。又复于菩萨行殊胜圆满。名波罗蜜多。一切智智圆满。名波罗蜜多。于有为无为法悉无所著。名波罗蜜多。为令觉悟轮回过失。名波罗蜜多。普能显示无尽法藏。名波罗蜜多。离诸攀缘解脱圆满。名波罗蜜多。于布施持戒。忍辱精进禅定胜慧。普令觉悟。名波罗蜜多。究竟善巧。于有情界引导一切。为令圆满无生法忍。至不退地。名波罗蜜多圆满佛刹化度有情。至菩提场除诸魔怨。获得圆满一切佛法。名波罗蜜多。又能如是建立大乘菩萨藏正法。名波罗蜜多。舍利子。而诸菩萨于正法藏。如是学已得至彼岸。是故于此大乘一切波罗蜜多。当如是学

又舍利子。若善男子善女人。于此菩萨藏正法。受持读诵广大开示。为他人说。而能获得十种称赞功德。何等为十。一者过是生已。而得通达一切事业。二者得生圣族。三者具大名称。四者所说言辞人喜信受。五者得大富饶。六者人天爱敬。七者获转轮王。八者得生梵世。九者(梵本元阙)十者遍一切处。得菩提心无有退失。又复获得十种称赞功德。何等为十。一者与尼乾陀等。得不共住。二者不起我见。三者不起人见。四者不起众生见。五者不起寿者见。六者不起常见。七者不起断见。八者舍诸玩好。九者发净信心常乐出家。十者于名句文速得悟入。又复获得十种称赞功德。何等为十。一者正念。二者聪利。三者总持。四者胜慧。五者刹那具足。六者得宿住念。七者性少贪欲。八者性少嗔恚。九者性少愚痴。十者不为炽然三毒之所烧煮。又复获得十种称赞功德。何等为十。一者希有胜慧。二者轻捷胜慧。三者猛利胜慧。四者极迅速胜慧。五者广大胜慧。六者甚深胜慧。七者决择胜慧。八者无碍胜慧。九者现前得见如来。能以伽陀歌咏赞叹。十者复与如来深心问答。又复获得十种称赞功德。何等为十。一者谓能将护诸恶知识。二者解诸魔缚。三者破诸魔军。四者断诸惑染。五者于诸行中除伏憍慢。六者趣诸善道。七者向涅槃门。八者布施受施超诸轮转。九者于菩萨道一切随学。十者随顺诸佛一切教敕。舍利子。于菩萨藏正法。应当受持读诵广大开示。为他人说。悉获如是称赞功德。尔时世尊。欲重明斯义。说伽陀曰

  诸有大智者　　善了文句义
  持此经中王　　获无量胜慧
  彼比丘法师　　常行是法施
  持此经中王　　最胜生欢喜
  为诸听法者　　宣说如是法
  持此经中王　　获叹美功德
  得是胜慧已　　于法无损减
  复于胜念力　　能演无上句
  善说法要者　　常赞佛教敕
  持此经中王　　多闻常具足
  闻已受持者　　不着于文字
  随义常观察　　增长佛智慧
  由智慧无边　　深达胜义谛
  宣布诣十方　　闻是获称赞
  又令贪恚痴　　由斯皆渐少
  最上清净心　　闻是获称赞
  受用资具中　　称量如实义
  晓了非真实　　舍家求解脱
  乐住空闲处　　闻法常无厌
  咨问世尊所　　法施无有吝
  令智慧增长　　清白无减失

尔时世尊。说是偈已。告舍利子。此诸菩萨于胜慧波罗蜜多之行。应当勇猛以四摄事。于长夜中摄受有情。何等为四。所谓布施爱语利行同事。是名四种。云何布施。谓财施法施及无畏施。云何爱语。谓于闻法者出柔顺语。云何利行。谓于自他意乐圆满。云何同事。谓于是智起功德想。摄受有情安住是法。又布施者。谓于一切来求丐者意极清净。爱语者。断诸合集。利行者。使无退屈。同事者。回向大乘。又布施者。随转大慈心无遗惜。爱语者。随心喜舍。利行者。为诸有情身心勇悍被大甲胄。同事者。心舍高下向一切智。又布施者。如法追求舍诸资具。爱语者。导以正法。利行者。自利利他悉起平等。同事者。利诸有情。咸共发起一切智心。又布施者。自舍一切若内外法。爱语者。于诸法行功德智慧善权称赞。利行者。弃自所利随转利他。同事者。成熟菩提。譬彼掌中庵摩勒果。普施一切得无怯弱

复次舍利子。法施者。谓如其所闻为他人说。爱语者。谓正开示无所希望。利行者。为他演说不生疲厌。同事者。于一切智。乐甚深法心无弃舍。又法施者。于来听法者说无散乱。爱语者。远至他方演说诸法。利行者。为法义故于诸法师。以饮食衣服卧具医药。乃至以身覆护一切给侍。同事者。为令薰习安住种性。又法施者。于诸施中无有过上。爱语者。分别义利。利行者。谓随于义不随文句。同事者。为令圆满一切佛法。又布施者。是即布施波罗蜜多。爱语者。是即持戒忍辱波罗蜜多。利行者。是即精进波罗蜜多。同事者。是即禅定胜慧波罗蜜多。又布施者。是即最初发心菩萨。爱语者。是即行胜解行菩萨。利行者。是即不退转地菩萨。同事者是即一生补处菩萨。又布施者。是即住菩提根。爱语者。是即长菩提芽。利行者。是即开菩提花。同事者。是即结菩提果

舍利子。是故诸菩萨摩诃萨于长夜中。以四摄事摄受有情。于菩提行诸波罗蜜多而能随转。于此复有无量无边诸摄事等

尔时佛告舍利子。彼大蕴如来应供正等正觉。为精进行太子。于菩提道悉正开示。及过去未来现在诸佛世尊之所称赞。时精进行太子。于彼佛所。得闻如是菩提正道。及闻三世诸佛世尊之所称赞。快得善利发大欢喜。复于彼佛及诸大声闻众。于九十九俱胝岁。以饮食衣服卧具医药。供养恭敬尊重赞叹。舍利子。彼大蕴如来应供正等正觉。即时与授阿耨多罗三藐三菩提记

佛说大乘菩萨藏正法经卷第三十八佛说大乘菩萨藏正法经卷第三十九

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之七

尔时佛告舍利子。汝等勿谓精进行太子得授记已。起于异见而生疑惑。所以者何。是精进行太子。已于过去九十九俱胝岁。亲近供养尊重赞叹。大蕴如来及声闻众。亦以饮食衣服卧具医药。精勤给侍悉令充足。以本愿故彼佛世尊。与授阿耨多罗三藐三菩提记。于未来世过阿僧祇劫当得作佛。号曰宝身如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛有八十那庾多大声闻众。皆阿罗汉。诸漏已尽无复烦恼。心得自在到于彼岸。舍利子。复于彼时。有王出世名曰善现。其王唯以善法化治人民。转正法轮行精进行。四兵严卫七宝具足。所谓轮宝象宝马宝摩尼宝女宝主兵宝主藏宝。如是七宝殊胜无比。复有大城名阎浮檀金。其城东西修广十二踰缮那。南北亦等七踰缮那。其国人民离诸艰苦。所须如意。有大神通受胜妙乐。如是有情充满其中。有大长者名曰善慧。珍宝具足受用无乏。其诸库藏悉皆充溢。于诸佛所植众善本。而为诸佛之所印可。舍利子。尔时宝身如来应供正等正觉。观彼善慧长者。审知其器堪可任持。菩萨藏正法之器。是诸佛法器。如是知已。即诣其所现大神力。于虚空中结跏趺坐。随应为说菩萨道法。而复称赞三世诸佛。舍利子。时彼长者闻说法已。深心爱乐信解清净。生大欢喜。于千岁中。即以饮食衣服卧具医药种种所须。礼拜供养尊重赞叹宝身如来及声闻众。满千岁已而无懈倦。作是誓言。愿我当成阿耨多罗三藐三菩提。时彼如来闻是誓已。即为授记。舍利子。汝勿谓善慧长者得授记已。起于异见而生疑惑。我于彼时愿求菩提。亦以饮食衣服卧具医药。于千岁中。供养恭敬尊重赞叹宝身如来及声闻众。彼佛世尊。不与我授阿耨多罗三藐三菩提记

尔时宝身如来告善慧言。汝于未来世过阿僧祇劫当得作佛。号曰然灯如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛法中。有王名阿阇世。其王有城名莲华具足。彼国人民离诸苦难。多所安隐随意成就。舍利子。复于彼时。有王名大娑罗。其王有子名具足灯。威德自在面貌端正。众相具足人所爱乐。库藏充满受用无乏。时阿阇世王。即以半国委付其政。时具足灯。既即位已亦以善法化治人民。舍利子。是具足灯。乃于后时诞生太子。色相端严最胜圆满。清净莹澈犹如池沼。具三十二大人之相。威光晃耀犹如日轮。其王即时心生欢喜。乃与立字名曰然灯。尔时其王。召婆罗门占相其子。时婆罗门而白王言。今太子者宿植善本。当证阿耨多罗三藐三菩提。必定不久得大神通。尔时净居天子。于色究竟天忽然没已。诣太子所头面礼足右绕三匝。为彼太子说伽陀曰

  往昔于因中　　积集诸功德
  悟无上菩提　　犹如胜仙幢
  盛年具威势　　迁谢疾如风
  壮色老所侵　　世间不可乐
  以衰老所逼　　厌苦求解脱
  应当善思惟　　光景不久住
  善哉大智者　　速疾求出离
  于此菩提道　　坚固持净戒

尔时净居天子说伽陀已。已初夜分即为太子。警觉开示令生信解。舍家出家。当得阿耨多罗三藐三菩提。具大威德名称远闻。时彼太子既授其教。于佛法中精勤信解。随顺修学阿耨多罗三藐三菩提法。舍利子。尔时具足灯王。闻是太子舍家出家得阿耨多罗三藐三菩提已。即遣使者往诣然灯佛所。具宣教敕。唯愿大慈怜愍于我。愿时速还。若不时来即严四兵我当自往。舍利子。时具足灯王。复召群臣共议斯事。即时严驾奉迎世尊。见佛身相端严殊特。叹未曾有。各起恭敬头面礼足。而白佛言。唯愿世尊。于阿阇世王。深心怜愍饶益我等。舍利子。尔时然灯如来受王请已。其王即与二十俱胝王诸眷属及四兵众。随佛世尊。前后围绕。往诣王宫。而王即以衣服饮食床褥汤药一切乐具。悉令充足。随所爱乐而用供养。时佛世尊。为说法要。多所度脱。顶礼佛足右绕三匝。涕泪悲泣深怀恋慕。尔时然灯如来。复与二十俱胝大阿罗汉。即时往诣阿阇世王莲华具足大城。舍利子。尔时阿阇世王。闻佛然灯至其城已。即敕人民。于其城中四衢巷陌咸使清净。瓦砾荆棘悉令屏除。香水洒地无诸尘坌。散众名华积至于膝。宝瓶香炉其烟弥布。种种宝衣处处垂下。击鼓角贝其声相续。涂香华鬘充满其中。胜妙庄严昔所未有。彼国人民随自供养。无诸贸易咸所乐观。舍利子。尔时阿阇世王。复以种种华香璎珞。烧香粖香。衣服缯盖幢幡伎乐。歌颂赞叹奉迎如来。于自宫中礼拜供养。时王即得胜欢喜心。妙吉祥心。无障碍心。离热恼心。安隐而住。舍利子。复有长者居士婆罗门等。亦以如上种种供养。往诣佛所。头面礼足瞻仰世尊。尔时有一梵志名曰妙宝。与其徒众五百人俱住呬末河侧。常持三种曼多啰法。所谓儞揵吒法。该吒婆法。恶刹啰钵捺法。时彼徒众。悉能通达此三种法。彼自记别。诵是文句世间最胜。是大丈夫为轨范师。舍利子。彼时复有宝云梵志。亦与徒众五百人俱。于彼学习自谓究竟。是时宝云而白师言。我于本法已得通达。今欲还诣本所生处。当求五百金钱用酬教诲。是时宝云。渐次经历国邑聚落。至莲华具足大城。见彼城中庄严殊妙。即时往问。今此城中作何胜事。彼共告言。仁者当知。今佛世尊然灯如来。与八十俱胝大阿罗汉。八万四千大菩萨众。见处王宫。演说正法度脱一切。其国人民庄严乃尔。是时宝云闻是事已。发清净心生大欢喜。作是思惟。佛世难遇。如优昙钵华时一现耳。我今当以所求金钱。持用买华以散佛上。渐次游行见一童女。手持七枝优钵罗华。是时宝云告童女言。此华殊妙从何所得。我今欲以五百金钱贸易此华。作妙华鬘。持以奉献然灯如来。尔时童女闻佛名已。宿善根力而作是言。今我此身堕生死中。宜自开寤。宝云闻已即告童女。汝适何言。童女答云。我于往昔阿僧祇劫。于佛法中积集善利。或以真珠琉璃金银珂贝。象马牛羊辇舆车乘。婇女眷属。头目髓脑身肉手足。若内若外。一切财物悉皆布施。深净信解。舍家出家行菩萨道。于一切法离诸障碍。无芥子许不舍身命。汝何于我而生轻侮。是时童女。即持优钵罗华。往诣然灯佛所。持以上佛。佛即受之

尔时世尊。复有百千俱胝那由陀众恭敬围绕。佛于其中。威德巍巍广大清净。而是童女叹未曾有。即时发起最上胜心。增长爱乐。舍利子。时宝云梵志亦诣佛所。发净信心顶礼双足。瞻仰尊颜目不暂舍。见彼人众悉以上妙法服。奉献然灯如来。时彼宝云作是思惟。我今何有殊妙法服而为供养。即以所著鹿皮之衣。持用上佛。时会人众见是事已。即生毁呰。作是语时彼鹿皮衣。忽然变作七宝所成。是时宝云心大欢喜踊跃无量。即以奉献然灯如来。而作是言唯见哀愍愿垂纳受。是时如来即为受之。复以五枝优钵罗华。供散佛上普及众会

尔时复有无数天子。持天曼陀罗华摩诃曼陀罗华。曼殊沙华摩诃曼殊沙华。而散佛上。于虚空中作天伎乐。歌咏赞叹。以神通力复现无数优钵罗华。其华千叶异香弥布。旋覆空中化成华盖。以为供养。舍利子。尔时宝云梵志。即于然灯佛所。经十二岁净心奉事。由胜进力以本愿故。获金色髻。而作是言。唯愿世尊安慰于我。令我坚固早成阿耨多罗三藐三菩提记

佛说大乘菩萨藏正法经卷第三十九佛说大乘菩萨藏正法经卷第四十

        西天译经三藏银青光禄大夫试光禄卿慈觉传梵大师赐紫沙门臣法护等奉　诏译

    胜慧波罗蜜多品第十一之八

复次舍利子。彼然灯如来应正等觉。于三世中普以慧眼。悉能了知。时宝云梵志如是知已。以金色髻布散于地。请佛声闻及余比丘右旋履蹈。所以者何。佛告诸比丘。宝云梵志。过无量阿僧祇劫。当得作佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。舍利子。时彼梵志闻佛记已。欢喜踊跃现大神通。于虚空中即时证得无量百千俱胝那庾多不可说三摩地门。以神通智力。超越东方殑伽沙世界。诸佛世尊咸与授记。汝于未来世过无量阿僧祇劫。当得作佛号释迦牟尼。如是南西北方四维上下。诸佛世尊亦复如是。舍利子。是宝云梵志。复闻诸佛同授记已。获大安慰从空中下。即时往诣然灯佛所。发净信心。舍家出家常修梵行。舍利子。汝于宝云梵志。莫起异见。勿生疑惑。所以者何。彼梵志者。即我身是。我于尔时。以五枝优钵罗华散佛顶上。复于菩萨藏正法乐欲听闻。受持读诵广大开示。为人演说具足正行。谓无相行。是故疾得阿耨多罗三藐三菩提记。舍利子。若我于彼清净法行。不以神通智力种种成办。彼佛世尊。即不与我授菩提记。尔时我于菩萨藏正法。如其所闻安立正行。谓无相行。不可得行。及见彼佛。于一切行平等超越。我于彼佛知一切法自性不生。随顺诸法起平等见。而能获得最上法忍。得是忍者何所忍耶。所谓色忍受忍想忍行忍识忍。乃至蕴处界种种法忍。虽复得是法忍如彼增语。所以者何。非世间法积集行故。非异生法。非无学法非缘觉法。非菩萨法非诸佛法。积集行故。于一切法皆不可得。无所集故。说此是名得诸法忍。又彼忍者。于一切相一切攀缘。一刹那顷亦得是忍。谓非眼界非眼境界尽。乃至非耳鼻舌身意境界尽。于彼忍境亦无所至。舍利子。得是忍者。由我于菩萨藏正法。乐欲听闻。受持读诵广大开示。为人演说。具足正行。谓无相行。不可得行。是故我于然灯佛所。速得受记。说是语时。会中有长者子名曰仁授。闻佛说菩萨藏正法诸佛功德及菩萨行。即从坐起。整衣服偏袒右肩。右膝着地合掌恭敬。而白佛言。世尊。我于尊者阿[少/(兔-、)]楼驮。昔常随学入解阿罗汉法。尽老死际住空寂舍。我今忽闻菩萨藏正法诸佛功德及菩萨行。所谓大乘。是最上乘。第一深妙。无有过上。是为阿耨多罗三藐三菩提法。而我亲闻佛说。亲所听受。于此正法发生无量深妙胜解。复于是法。无所称量无所执着不作圣解。若谓是法第一深妙无有过上。是即于彼积集退转。世尊。此菩萨藏正法。于诸佛乘乃至所有一切乘中。最在其上第一开示。多所怜愍多所饶益。安乐天人度脱一切。于学无学如应所得至菩萨地。其谁不发阿耨多罗三藐三菩提心。尔时长者子仁授。重白佛言。世尊。于苦集中。而难成就阿耨多罗三藐三菩提耶。佛言仁授。如是如是。世尊如其行相于阿耨多罗三藐三菩提心。不退转积集精进。如佛世尊。于殑伽沙数一一佛所。发菩提心。复能平等安住如是精进证菩提果。复能安隐诸菩萨道。所以者何。诸佛智慧无量无边。不可思议不可称量。世尊。若于是法不善修作。分别挂碍。虽百千俱胝那庾多劫。于菩提果甚为难得。尔时仁授长者子。即于佛前说伽陀曰

  于千俱胝劫　　我发菩提心
  见懈怠众生　　沉沦诸苦恼
  假使施头目　　量积过须弥
  如是一心中　　精勤无懈退
  若我住佛道　　利乐诸有情
  由依如来故　　得是精进力
  此乘名大乘　　是佛最上说
  乐欲菩提者　　毕竟无见取
  救护诸苦恼　　解脱于恶趣
  此正觉义利　　唯如来所说

时仁授长者子。说是偈已。于佛法中起大信解。不着世乐妻子眷属。向佛世尊。头面礼足右绕三匝。于刹那顷诣本住处。与自眷属七妻七男七女七奴七婢。各持上妙细[疊*毛]价直千万。并诸伎乐五百人俱。出王舍大城欲诣佛所。时彼人众见是事已。即时往问。时长者子白言。仁等当知。如来现在耆阇崛山。与无量无数百千大众恭敬围绕。广大开示无量善法。佛之智慧不可思议不可称量。我及眷属欲往诣彼乐闻如来深妙法义以善根力决诸疑网。为欲摄受阿耨多罗三藐三菩提。仁等亦宜亲近彼佛植诸善本。时彼人民闻是语已。生大欢喜咸悉随从。尔时长者子。与自眷属五百伎乐及千人众。到佛所已。即以花香缨珞。涂香粖香缯盖幢幡。伎乐歌咏作诸供养。及上妙细[疊*毛]价直百千以散佛上。即于佛前说伽陀曰

  往昔多劫中　　勤修菩提行
  于法得自在　　利乐诸有情
  如是我今当　　故此伸供养
  见两足世尊　　常处清净行
  现证无上道　　故此伸供养
  我诸眷属等　　所将千人众
  咸亲近如来　　一切归命礼

尔时长者子说偈赞已。而白佛言。世尊。我及眷属所将人众。来诣佛所。一切皆住阿耨多罗三藐三菩提心。植众善本。于无上道誓不退转。作是语已俱发声言。世尊。我等归佛归法及比丘僧诸优婆塞。唯见摄受我等尽其形寿。远离杀害趣清净门。一时皆发无上道心。惟愿世尊。为我等故说微妙法。于如是众勿应弃舍。及未来世苦恼众生。愿为济度。如是二请

尔时世尊。极怜愍故现大神通。即升虚空跏趺而坐。时长者子等。见是事已叹未曾有。彼佛世尊。威神力故。持诸大众皆处虚空。尔时长者子与自眷属五百伎乐等发大欢喜。于虚空中起立合掌。右绕三匝头面礼足。作众伎乐歌咏佛德。普及时会。如是遍满无量百千踰缮那。佛神力故忽于空中。复化大比丘众千二百五十人。与其眷属六万人俱。从东方来乐欲听法。时佛世尊见彼大众。即以神力化五楼阁。众妙庄严甚为希有。一一楼阁皆出梵音演说妙法。复有百千俱胝诸天子众。持天曼陀罗华以散佛上。偏覆空中。佛神力故成华楼阁。尔时长者子及诸大众。睹如是等广大神变清净庄严。发生无量亲近爱乐。佛知是已即摄神力。还复东方本相如故。尔时阿难见是事已。偏袒右肩合掌恭敬。而白佛言。世尊。以何因缘现是神变。惟愿世尊为我等说

佛告阿难。我今当为仁授长者子。与自眷属及众伎乐。供养于我。是人于千俱胝劫不堕恶趣。常生人天受胜妙乐。过是劫已。亦复尊重供养道行如来应正等觉。于二十五俱胝劫不复轮转。是七妻等舍是身已。当转女身成丈夫相。复与仁授菩萨。于一劫中修菩萨行。阿难。彼仁授菩萨。当得作佛号曰等心如来十号具足。与自眷属。转次授记皆得作佛。时彼伎乐五百人众。由供养佛。以是缘故。于阿僧祇劫不堕恶趣。千俱胝劫常作转轮圣王。过是数已。供养尊重十千如来。于一劫中皆当作佛。尽同一号。余千人众于慈氏如来般涅盘后。过殑伽沙劫于千俱胝佛所尊重供养。当得作佛号曰希胜如来十号具足

尔时佛告具寿舍利子言。彼阿阇世王与具足灯婆罗门及千人等。正法灭已过刀兵劫。于未来世有佛出世。名曰慈氏。时彼有情寿命长远具八万岁。复有千辟支佛出现世间。复于彼时。亲近供养尊重赞叹。亦复尊重供养慈氏如来。于二十五俱胝那庾多劫。无复退转种诸善根。舍家出家成菩提果。及见彼千人同时发阿耨多罗三藐三菩提心。时六十那庾多天人。远尘离垢得法眼净

佛告阿难。而诸愚夫不能于佛发生爱乐。清净信解尊重赞叹者。所以者何。是诸人等。于少善根尚不能得。何况如来大涅盘证。尔时世尊。欲重明斯义。说伽陀曰

  尊重诸佛故　　得是胜吉祥
  供养调御师　　获最上大果
  诸佛灭度后　　得睹佛舍利
  犹如芥子量　　应广妙修设
  又佛灭度后　　供养舍利者
  应生平等心　　若如来住世
  由发是心故　　供养无上尊
  悟平等菩提　　果报亦如是
  为善逝摄受　　远离于恶道
  是人趣涅盘　　不以为难得
  能示佛禁戒　　最上三摩地
  及清净胜解　　得佛无上果
  作是供养已　　疾趣善修习
  获无上正觉　　宣说第一法
  若人欲了知　　亲近诸佛法
  乐欲获多闻　　深心无厌怠
  自在转轮王　　及净行胜族
  具福相庄严　　应时获出离

尔时世尊说是偈已。告具寿舍利子言。若善男子善女人。安住大乘。欲速成阿耨多罗三藐三菩提者。应于菩萨藏正法殊胜义利。乐欲多闻受持读诵。乃至广大开示。为他人说。即得绍隆三宝使不断绝。得不退转四无量心。六波罗蜜。四摄事等。饶益有情悉相应故。又舍利子。此菩萨藏正法即菩提道。所以者何。是菩萨藏正法。摄受阿耨多罗三藐三菩提故。即诸菩萨资粮。应如是学无令断绝。舍利子。所谓得成阿耨多罗三藐三菩提一切波罗蜜多。能于如来一切波罗蜜多善作出离。于无量地。随得如来一切轻安。乃至随得如来之地。若于如是波罗蜜多。即得安住一切波罗蜜多。尔时世尊。欲重明斯义。说伽陀曰

  诸有智发生　　说一切有为
  由智及无明　　故有为诸苦
  于业及业报　　应当如是知
  若非业非报　　现前获出离

尔时世尊说伽陀已。时具寿舍利子。诸大菩萨摩诃萨。及诸比丘众。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

佛说大乘菩萨藏正法经卷第四十


佛说大乘日子王所问经

    No. 333 [Nos. 310(29), 332]

佛说大乘日子王所问经

        西天中印度摩伽陀国那烂陀寺三藏传教大师赐紫沙门臣法天奉　诏译

如是我闻。一时佛在憍闪弥瞿尸罗林。与大苾刍众五百人俱。及诸菩萨摩诃萨众。是时无比摩建儞迦女。而起嗔恚。憎嫉舍摩嚩底妃后。于日子王边说言。天子知耶。舍摩嚩底妃后等。五百女。共其沙门而行淫欲。我今告言。要天子知实难容恕。是时日子王闻无比摩建儞迦女说已。嗔怒至极意不可忍。拟杀舍摩嚩底夫人。遂以手执弓放箭便射。是时舍摩嚩底夫人入慈心定。王所放箭上虚空中发生火焰。其焰炽盛。其箭却回。奔日子王前于左边而住。佛为密护箭不着身。亦无损动。是时日子王心生惊怖。身毛皆竖而便倒地。又复还起。问舍摩嚩底夫人。而说偈言

  汝复为天女　　鬼女罗刹女
  巘驮婆女等　　我问如是说
  汝持云何行　　未见未曾闻
  亦复不曾知　　未曾有女人
  器仗不能伤　　我有精进力
  善学于弓箭　　我箭不空发
  未曾虚放箭　　如我所要射
  猕猴及飞禽　　人身兼射垛
  而未无所中　　如我今放箭
  却回面前住　　不伤损我身
  我今归命汝　　愿救我苦恼
  审听诚实言　　我欲故杀汝
  舍过勿生嗔　　汝念为好事
  令我离苦恼　　永不复如是

尔时舍摩嚩底夫人答日子王。即说偈言

  我非是天女　　亦非健闼女
  非鬼非罗刹　　是舍摩嚩底
  我作佛弟子　　为彼大慈悲
  故我心行善　　发心世尊处
  俱胝百千劫　　观彼善慈悲
  故我行慈行　　女色所缚人
  见彼如实者　　若苗稼成熟
  而被雷雹壤　　若离女色染
  我彼俱爱乐　　一切诸世尊
  远离于淫欲　　又闻世尊说
  佛与菩萨众　　缘觉及声闻
  悉皆离女色　　愚者不能知
  普被魔罗降　　离女色染污
  能得身安乐　　究竟得解脱
  无智诸众生　　爱欲无远离
  作罪业无边　　堕落三恶道
  无底欲火坑　　猛焰炽不灭
  有智乐解脱　　不为女色染
  见已便缠缚　　诈言虚适悦
  坠堕于众生　　死入崄恶道
  勿听女人言　　亦不忿怒我
  意愿生欢喜　　发心世尊处
  汝欲求见佛　　我与大王去
  到彼汝谛听　　必说微妙法

尔时日子王告舍摩嚩底夫人。正当是时。汝意速疾诣世尊所。王及臣民侍从围绕见大牟尼巍巍堂堂如大金山光明焰赫吉祥庄严。又见菩萨摩诃萨及诸苾刍苾刍尼坞波斯迦坞波索迦。天龙药叉犍闼婆阿素啰[薜/女]噜茶紧那啰摩护啰誐人非人等围绕世尊

尔时大王头面作礼。而白佛言。世尊。我有未曾有事。先未闻见。今诣佛所。世尊慈悲与我解说。世尊告言。大王汝说未曾有事。王复白言。今日我宫有淫欲因缘。无比摩建尔迦女。生毁谤心。言舍摩嚩底夫人与声闻沙门而行淫事。我闻此言嗔恨至极。杀舍摩嚩底夫人以箭便射。于其箭上。而出火焰赫奕炽盛。却回我身左边而住。亦不伤损我身。舍摩嚩底夫人。礼世尊足说如是言。彼王问我。为复天女龙女犍闼婆女比舍际女鬼女罗刹女。汝修持何行而乃如是。而答王言。我是大王夫人。非是天女龙女健闼婆女比舍际女罗刹女。世尊。如来应供正等正觉弟子。心善纯净为如彼天。是时舍摩嚩底夫人。称赞世尊功德。我佛如来有如是应正等觉。有如是大慈大悲。具大福慧。成大威德。得大自在。何以故。如来应正等觉为天人师。愿鉴斯诚。尔时日子王。对佛及苾刍众前。忏悔发露。我等由如愚童。如心迷乱。如在黑暗。如无善根。我念如来声闻。而生毁谤。善哉世尊。愿解疑悔。我等受持。世尊说言。汝发起慈心受持戒行。广利有情。日子王即从坐起合掌恭敬。佛言大王。汝但安坐。于时日子王头面作礼却坐一面。日子王白佛言。世尊。我心勇猛。听女人言造罪业苦。知自命终堕于地狱。善哉世尊。女人之过唯愿说之。世尊告言。女人行业有其多种。惑乱有情诈现异相。谄媚虚诳心不真实。颠倒思惟谄曲诈伪。举动施为强求亲近。牵系有情恒行邪行。汝须省觉。王言世尊。愿赐慈悲。愿听所说。如我此后不近女人。亦不由女人而造罪业。既不造罪不堕地狱。世尊如我长夜利益安乐一切众生。佛言。如是如是

复次日子王白言。世尊。我于佛边闻斯欲义。实由女人得其恶报。佛言大王。女色深固。生冤家之父母。生暴恶之父母。若起爱乐堕于地狱。是故女人有如是之过。佛言大王。若较量丈夫淫欲之过。汝后世父母眷属。亦有其过。日子王白佛言。世尊。善哉善哉。丈夫之过与我解说。云何丈夫之过。父母眷属亦有其过。佛言大王。谛听谛听善思念之。我为汝说。世尊告言。大王。若丈夫之过有其四种。大王问言。四过云何。世尊答言。大王。若丈夫耽着淫欲被淫欲迷醉。由迷醉故。情意颠倒由颠倒故。于其女人深生爱乐。于苾刍众中有持戒德行沙门婆罗门。不欲见闻。由不欲见闻持戒德行沙门婆罗门故。亦不亲近。亦不归依。亦不供养。于无戒无行沙门婆罗门。亦复远离。又无信根。不修德行。不行布施。全无智慧。寡闻薄德我慢贡高行鬼神行。又复亲近无智贪着恶法。乐着臭秽远离善友。纵生天上人间。于自身命恒时呵毁。于沙门婆罗门。不作护摩。于佛法僧。而复远离。于涅盘果德。而所弃背长时忆念。女人倡妓歌舞饮酒谈笑。如是缠缚而复命终。堕在众合黑绳等活号叫大号叫炎热极炎热阿鼻地狱。受种种苦。从地狱出生焰魔罗界畜趣中生为师子虎狼诸恶禽兽。乃至[薜/女]路茶身止铁叉树。大王。若丈夫如是行愚法行。获斯恶报。此是丈夫初过

尔时世尊而说偈言

  淫欲臭秽根不净　　过后常增业苦深
  聪慧法师呵欲染　　当生父母亦无益
  譬如广大不净坑　　满盛粪壤多臭秽
  亦似冢间胮胀尸　　淫欲之人亦如是
  复似蝇虫[口*(一/巾)]疮肿　　驴马奔眠粪秽中
  猪狗食啖臭鱼等　　耽爱女人亦如是
  破坏善名兼德行　　恒行毁禁具无惭
  不生天道堕阿鼻　　是故法师呵爱欲
  如人误饮恶毒药　　迷乱猖狂遍体疼
  不觉无常毒所中　　耽欲之人亦如是
  乐着美味便珍馔　　爱听歌音恋色声
  家事不思多忘失　　唯作轮回集苦因
  贪着淫欲常称赞　　不了愚迷粪袋身
  昼夜恒行下劣行　　薄福沈轮于恶趣
  赞美淫欲行非行　　多饶嗔恚长愚痴
  如履颠巍大崄崖　　不觉须臾致失命
  既别人世阎浮界　　死堕无边业海中
  五峰围绕铁山间　　日月灯光全不见
  如风狂乱无知解　　往返纵横失路岐
  如是经生常住此　　一切世间无所重
  种种善业亦不生　　设有女男无孝敬
  弃背尊亲行五逆　　和合妻女倍殷勤
  张罗罪网无思虑　　堕落贪痴欲乐中
  父母远离无返复　　罔思育养报艰辛
  放逸耽淫着戏弄　　互相烦恼倍增多
  破坏修行疑种种　　不逢贤圣作良因
  乐行邪行受极苦　　不顾刑罚耻辱侵
  斗诤欺抄致杀伤　　隳张财贿离善友
  不生天道兼人趣　　死入阿鼻地狱中
  铁林青色攒锋刃　　猛焰煻煨烈火城
  剑树刀山遍地中　　洋铜热铁为浆馔
  如斯大苦因淫欲　　隐没菩提智慧根
  汝向女人生恐怖　　勿令亲近起攀缘
  人天善道若相应　　不久菩提自获得

复次大王。若父母生产儿子。其事甚难世所共知。处胎之时怀担十月。苦恼疼痛种种多般。起坐艰辛餐饮节度。纵获生产如宰猪羊。不顾自身唯忧儿子。乳哺养育岂离怀抱。大小便痢须自洗濯。后渐长大而以诚实之言种种诱训。令彼修学。阎浮提内工巧伎艺。书疏算计。经商买卖种种事业。又复令彼身心安乐。广与财帛富贵授用。选拣亲姻娉聚妻妾。比望孝顺父母供敬侍养。而复心意颠狂一向迷乱。深着色欲都不省悟。又于别族姓家。私娶妻妾互相贪爱。于其父母返成不孝。亦不敬重。其父后时耆年老迈。身体羸瘦眼耳聋暗。起坐艰难要人扶持。而却憎恶轻弃嫌厌。种种逼迫趁父出舍。娶其外族妻子于家。聚会种种欢乐

佛告大王。若是丈夫行此邪行。弃背父母。决定命终入阿鼻地狱。求出无期。为第二过。若善男子。弃背女色心意清洁。供养父母行孝敬行。命终之后不堕恶趣。而生诸天受福快乐。天上福尽下生人间。亦不受贫穷下贱。富贵吉祥

尔时世尊而说偈言

  离欲行慈孝　　命终生天趣
  梵王帝释身　　恒受于快乐
  供养老父母　　后生人世中
  入海为商贾　　安乐获珍宝
  供养老父母　　一切最上德
  田种果成熟　　较量福不尽
  供养老父母　　永不檐重担
  常得驴马负　　刀刃不能害
  供养老父母　　不度碱水河
  猛火与刀兵　　亦复不能近
  供养老父母　　常得善妻男
  谷麦与资财　　琉璃及金宝
  供养老父母　　常得天宫住
  无数欢喜园　　四面恒围绕
  供养老父母　　常闻佛法音
  具相色端严　　谁人不敬重

复次大王。若彼丈夫行非法业。心不真实恒多邪见。于善不知妄生颠倒。多得愚痴之人常所称赞。有智慧者恒生忿怒。罪业转深永失大利。于其佛世永不值遇。我慢贡高贫穷下贱。众不爱乐。此是丈夫第三过失

尔时世尊而说偈言

  丈夫行淫欲　　颠倒分别我
  愚迷罪业深　　轮回堕恶道
  远离佛功德　　无智慧拣择
  虚妄求安乐　　如河觅卢迦
  愚痴爱欲人　　谄曲多虚诳
  望求非法乐　　返成地狱苦
  着欲见颠倒　　下劣自无知
  如夜黑暗中　　不分道非道
  无惭愧信根　　唯耽声色味
  菩萨与声闻　　未曾行供养
  设遇正行者　　广演微妙音
  轻法而不听　　沉沦于地狱
  永不复人身　　断除檀等行
  迷没不修行　　菩提最上失

复次大王。若诸男子自为活命及着淫欲痴愚障闭。作诸工巧种种事业。书疏算计赞咏谈论。亲近王臣行非法行。谪罚有情种种虚诳。广求财利作诸恶业。又复自为活命故。行不律仪行。货易牛驴驼马猪羊鸡犬。乃至咒龙罝兔魁脍等事。或复经商。不择道路游行崄恶之道。臭秽之道。贼徒刀剑之道。乃至泛大溟海。寒热饥渴种种苦恼。而求财利。又于沙门婆罗门。悭贪不肯布施。一向着欲。又被女人降伏驱使。犹如奴仆长时同处。未曾舍离。起坐谈话。互相攀顾深生爱着。是故畜养女人。命终之后同入地狱。为第四过

尔时世尊。而说偈言

  追求着欲人　　迷醉何曾乐
  下劣妄追寻　　云何得安乐
  非真丈夫业　　自作不知非
  无耻若驼驴　　不堪极秽恶
  斯人少智慧　　不悟罪根深
  奔竞向女人　　如狗便粪秽
  臭秽不可乐　　愚痴所爱重
  不知淫欲过　　如盲不见色
  愚痴着淫欲　　如犬奔粪秽
  声香味触法　　贪着亦如是
  愚痴着欲人　　轮回于诸趣
  如橛系猕猴　　永不出三界
  愚迷着欲人　　如乌恋臭肉
  常被恶魔牵　　堕在于恶趣
  愚人贪爱味　　于美起缠缚
  何异厕中虫　　宁知是不净
  智者得解脱　　女色不可染
  见彼生惊怖　　弃舍如坏尸
  愚痴怀散乱　　着欲而无舍
  如热路艰辛　　困渴饮碱水
  如是见饮者　　愚痴迷失命
  坚牢着欲人　　过患亦如是
  实为此女人　　如身患疮癞
  生虫自[口*(一/巾)]食　　贪淫亦如是
  若装饰女人　　如画瓮盛粪
  但观诸外相　　谁知里不净
  又如油洗衣　　挂搭于身上
  庄严于女人　　染污亦如是
  如衣盖刀剑　　似火覆经灰
  严饰于女人　　违损亦如是
  又如劫火起　　大地皆洞燃
  草木不见生　　河海干枯尽
  部多所住处　　须弥及铁围
  六欲与初禅　　破坏谁能救
  如是耽女色　　淫火大炽燃
  焚烧于有情　　违损不可救
  人身速不净　　秽恶诸物成
  指爪与发毛　　涎唾并结矃
  垢汗大小便　　肪膏及脑膜
  皮肉兼骨髓　　脓血筋脉连
  脾肾心共肺　　肠胃胆与肝
  生藏对熟藏　　赤痰共白痰
  又复八万户　　微细虫[口*(一/巾)]食
  常住于身中　　愚人那知觉
  于身起贪爱　　如蝇慕脓血
  臭气觉馨香　　苦中而为乐
  如是耽欲人　　执杖相驱击
  欲火竞来烧　　迷醉谁能悟
  愚痴着乐味　　如狗在空房
  亦似底啰声　　究竟成妄想
  又如于猿猴　　攀缘常在树
  乃至到无常　　不离于树上
  如是贪欲人　　追求于色境
  坠堕恶趣中　　不离生死苦
  愚痴淫欲人　　彼处命终后
  掷在铁镬中　　如是住一劫
  浮沉如煮豆　　其镬大小量
  六十四俱胝　　众生所依彼
  一一堕落者　　较量不能知
  煎煮于镬中　　受苦满百劫
  或二三四劫　　随彼业轻重
  皮肉俱烂坏　　骨现似白螺
  又随自业力　　手捉尖利钩
  掷在炎铁槽　　死已而还活
  又被于狱卒　　手执铁杵捣
  骨髓皆成粖　　风吹而却活
  或以铁棒打　　劈裂如斧斫
  铁兽三四五　　随后而咬啮
  又复为铁乌　　铁狗及豺狗
  牙嘴利如剑　　食罪人脑髓
  若人造罪业　　堕落于粪河
  或落刀剑上　　一切皆臭秽
  若人造罪业　　堕在极炎热
  号叫大号叫　　黑绳及烧燃
  若人造罪业　　堕在于灰河
  重重入由增　　痛苦不可忍
  若人造罪业　　死堕地狱中
  饥吞热铁丸　　渴复饮铜汁
  若人造罪业　　堕在铁山间
  众山一时合　　拶碎身如粉
  若人造罪业　　恒受于苦恼
  获得如是果　　无有能救者
  此处非安乐　　先世业所招
  父母与妻儿　　何能相救济
  下劣淫欲行　　直往于无间
  受苦不可当　　三世佛皆说
  是故下劣人　　与女人同处
  如担于粪袋　　愚痴到处行
  丈夫为女人　　缠缚如枷锁
  地狱火燃身　　无能得安乐
  刹那智慧生　　如是闻佛法
  离一切淫欲　　出家得解脱

佛告大王。若丈夫行淫欲行。当堕地狱受斯大苦。是故大王。恒常念佛念法。观察身心勿令起过。日子王言。如是世尊。于如来处。发深信心。白言世尊。甚为希有。如来应正等觉。善说女人丈夫之过。我当受持。归佛归法归苾刍众。今后弃舍淫欲刀杖等过。愍念饶益一切众生。说此语时。会中日子王。及诸苾刍菩萨摩诃萨。天龙药叉阿素啰[薛/女]路茶健闼婆莫呼落迦人非人等。闻佛所说。皆大欢喜。作礼而去

佛说大乘日子王所问经


佛说大乘入诸佛境界智光明庄严经卷第一

    No. 359 [Nos. 357, 358]

佛说大乘入诸佛境界智光明庄严经卷第一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

如是我闻。一时世尊。在王舍城鹫峰山半月妙峰法界殿中。与大苾刍众二万五千人俱。皆阿罗汉。一切漏尽离诸烦恼。心善解脱慧善解脱。如大龙王。诸所应作修作已办。去除重担逮得己利。尽诸有结心智解脱。诸心自在到于彼岸。阿若憍陈如等十八大声闻。而为上首。复有七百二十万俱胝那庾多菩萨摩诃萨众。其名曰妙吉祥童真菩萨摩诃萨。财吉祥菩萨摩诃萨。觉吉祥菩萨摩诃萨。药王菩萨摩诃萨。药上菩萨摩诃萨等。是诸菩萨。皆悉善转不退转法轮。悉于宝积方广正法而善请问。住法云地其慧高广犹若须弥。善能观察一切法空无相无愿。无生无起无性照明广大。甚深法理善威仪道。而诸菩萨皆是各各世界百千俱胝那庾多诸佛如来遣来至此。悉能出生诸神通事。安住诸法自性清净

尔时世尊即作是念。此诸菩萨摩诃萨众。具大威德为求法故。从殑伽沙数等大威德世界。迅疾如风来此集会。我今应为开明宣说广大正法。或现光相广大照曜。复令此诸菩萨摩诃萨众。于此会中闻所说法请问其义。尔时世尊即放光明。遍照十方不可思议如微尘等三千大千世界。即时十方一一方分。各有十佛刹不可说如微尘等。百千俱胝那庾多菩萨摩诃萨众来此集会。一一菩萨各现不可思议菩萨所有神通。而来到佛会已。各以不可思议妙色供养而供养佛。各各处自愿力出生莲花座中瞻仰世尊。是时法界殿中自然出现大宝莲花藏师子之座。纵广正等阿僧祇俱胝由旬次第高显。以众光明摩尼宝所成。以电光明摩尼宝而为界道。不思议光明摩尼宝为莲花茎。无比喻摩尼宝而为间错。超越譬喻光明摩尼宝作殊妙鬘。自在王摩尼宝网垂覆其上。竖立种种光明摩尼宝盖及宝幢幡。而彼大摩尼宝莲花藏师子座上。普遍出现十阿僧祇百千俱胝那庾多光明。其光普照十方世界。是时十方一一方分。有十佛刹不可说微尘数等。百千俱胝那庾多天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。帝释梵王护世天等。皆来集会。是中或有处宝楼阁与不思议百千俱胝那庾多天女众等奏妙音乐。或处妙花所成楼阁。或处龙坚栴檀香所成楼阁。或处真珠所成楼阁。或处大金刚宝所成楼阁。或处金刚光明摩尼宝所成楼阁。或处浑金所成楼阁。或处一切光明积集摩尼宝王所成楼阁。或处自在王摩尼宝所成楼阁。或处如意宝所成楼阁。或处帝青摩尼宝所成楼阁。或处大海之中清净庄严普遍光明大摩尼宝所成楼阁。皆有阿僧祇不思议百千俱胝那庾多天女众等。奏妙音乐乘空而来。到佛会已。皆以不思议无等比超越分量诸妙供养。供养佛已。各各于自愿力出生座中瞻仰世尊。时此三千大千世界。悉成阎浮檀金殊妙色相。自然出现种种摩尼宝庄严树。妙衣服树。龙坚旃檀香树。妙宝所成电光明摩尼宝网垂覆其上。竖立宝盖及宝幢幡。其诸树间皆有阿僧祇百千俱胝那庾多天女。执持半身真珠璎珞。或复执持摩尼宝鬘

时彼大摩尼宝莲花藏师子座中。自然有声说伽陀曰

  人中王来就此座　　本从福力所出生
  普令众愿悉圆成　　胜二足尊愿摄受
  此我身相宝所成　　中一宝谓莲花座
  随其意乐人中尊　　能满诸愿救世者
  今此宝成莲花座　　于此世间最殊妙
  为俱胝众说法门　　闻者皆令得此座
  汝身出现千光相　　普遍照曜诸世间
  我观此相欢喜生　　愿佛今就我此座
  速就座已摄受我　　此座数有八俱胝
  今自然智牟尼尊　　登座普摄诸群品

尔时世尊从本座起。即于宝莲花藏师子座上。加趺而坐。普遍观察一切菩萨人天大众。为诸菩萨欲当宣说最上妙法

尔时一切大菩萨众咸作是念。若我今时得闻妙吉祥童真菩萨请问如来应供正等正觉不生不灭甚深正法。斯为庆幸

尔时妙吉祥童真菩萨先在会中。知诸菩萨摩诃萨众心之所念。即从座起。前白佛言。世尊。如佛所说不生不灭。此所宣说当是世尊。何法增语。即说伽陀而伸请问

  不生与不灭　　此是佛所说
  大慧相云何　　于此中宣演
  若法不生灭　　即无见无因
  佛大牟尼尊　　复云何宣说
  此十方菩萨　　诸佛故遣来
  求大智法门　　愿尊说正法

尔时世尊。赞妙吉祥童真菩萨摩诃萨言。善哉善哉妙吉祥。汝今善能请问如来如是义理。如汝意者。广为多人作大利益。悲愍世间令其修行普得安乐。复能利乐诸天人众。今此所来诸大菩萨摩诃萨众。为得佛地故不生恐怖。是处施作亦无所畏复无惊悚妙吉祥。彼等皆得实智所摄。如来今此说如是法。所谓不生不灭。妙吉祥。不生灭者。此说即是如来增语。譬如吠琉璃宝成大地相。于彼所成大地相中。而有忉利天中帝释天主所居之处大广胜殿。而彼天主常处其中。受天五欲胜妙快乐嬉戏自在。彼诸天众呼彼阎浮提中若男若女童男童女一切人众。谓言善来。汝等且观帝释天主大广胜殿。天主于中受胜妙乐。汝等来此广行布施。修作福事积集戒行。汝等当知。今此帝释天主所居大广胜殿神通具足。汝等宜应修作福事。愿当获报如彼天主。安处天宫受胜妙乐。是时阎浮提中若男若女童男童女一切人众。见此吠琉璃宝所成大地帝释天主大广胜殿。见已合掌执持香花向空散掷。作如是言。愿我等当来亦获是相。如帝释天主居广胜殿。受胜妙乐嬉戏目在。然彼人众而悉不知影像对现琉璃大地。忉利天中帝释天主。大广胜殿清净所成犹如影像。妙吉祥。彼帝释天主以广行布施。修作福事积集戒行。宿善根力广成熟故。感彼天中胜妙宫殿。妙吉祥。而彼吠琉璃地本无所有。忉利诸天及彼帝释天主所居大广胜殿亦无所有。皆是清净所成影像对现而亦常在。而实不生亦复不灭。妙吉祥。一切众生亦复如是。以清净心如实观想。如来即为对现身相。复以如来威神力故。令诸众生得见如来。然本无实不生不灭。无性非无性。无见非无见。非世间非非世间。无状貌非无状貌。妙吉祥。一切众生但以如来对现影像而为所缘。散掷香花衣服妙宝而为供养。作如是言。愿我当来获胜妙报。同彼如来应供正等正觉。彼诸众生求佛智故广行布施。修作福事积集戒行。回向愿当得如来智

复次妙吉祥。又如吠琉璃宝所成大地。帝释天主对现影像。无动转无领受无戏论。无分别不离分别。无计度不离计度。非思惟作意。寂静清凉无生无灭。无见无闻无嗅无味无触无想。无施设无表了。妙吉祥。如来应供正等正觉亦复如是。无动转无领受无戏论。无分别不离分别。无计度不离计度。非思惟作意。寂静清凉无生无灭。无见无闻无嗅无味无触无想。无施设无表了。如是等如来无所生趣向。诸所对现皆如影像。随诸众生信解差别。现诸色相寿量分限。但为成熟信解力故。是菩提器彼众生者即为对现。随其意乐随其信解。令诸众生得闻法要。如所乐欲知三乘相。如所乐欲悉得解脱。妙吉祥。又如忉利天中帝释天主。以福力成办故。有大法鼓出妙法音。处虚空中大广胜殿上。彼诸天子极目彻视。不能观见。妙吉祥。彼大法鼓。若或忉利天中诸天子众。耽媔嬉戏五欲自娱心生放逸。而不乐入善法堂中歌咏法音。或时帝释天主五欲娱乐。亦复放逸不处法座为众说法。彼大法鼓处虚空中极目彻视。超眼境界不可观见。自然出声令诸天子开明警觉。谓言。诸仁者。色声香味触是无常法。汝等今时勿生放逸。无令速疾离失宫殿。诸行是苦诸行皆空。诸法无我勿生放逸。此苦蕴灭佗趣复生。汝诸仁者。宜当精勤歌咏正法。游戏法园求法真实爱乐正法。于正法中随念作意。即得不离天中五欲娱乐。妙吉祥。然彼大法鼓。无分别无离分别。超眼境界不生不灭。出语言道离心意识。其大法鼓所出法音令彼天众常所开觉惊怖迷乱。即入善法堂中歌咏正法。游戏法园求法真实爱乐正法。于正法中随念作意。天趣殁已胜处受生。又复帝释天主。入善法堂处于法座。为诸天众宣说法要。若时与彼阿修罗众。而共斗战天众或负。彼大法鼓自然出声。阿修罗众惊怖迷乱驰走而去。妙吉祥。然彼法鼓亦无我相。复无言说自然隐殁。大法鼓者无所观瞩。住于真实无心无思。无相无色无声无性。亦复无二超眼境界。妙吉祥。以彼忉利天中诸天子众宿善业故。有大法鼓出妙法音。令彼天众一切娆乱随烦恼等皆悉寂止。彼大法鼓而亦常在。然其无心亦无所思。无相无色无声无性亦复无二。如来应供正等正觉亦复如是。无见无观然亦常在。而无我相无心无思。无相无色无声无性超眼境界。但随众生宿善业报。随其信解为说法音。令其开晓闻法音故。使诸众生一切娆乱随烦恼等皆得寂止。彼法音声当知即是如来音声。妙吉祥。是法音声而无其实。如来但为一切世间权巧施设。随诸众生宿善业报。如来乃为出法音声。随诸众生各各意乐而生解了。为令一切众生皆得安乐。诸放逸者咸皆警悟。妙吉祥。一切众生闻法音已。皆愿当得如来身相。彼新发意菩萨及诸愚夫异生。但以如来善法出生而为所缘。令其得闻如来法音。妙吉祥。如来应供正等正觉所说。不生不灭甚深法理应如是知

佛说大乘入诸佛境界智光明庄严经卷第一佛说大乘入诸佛境界智光明庄严经卷第二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

复次妙吉祥。譬如炎夏向残雨际初月时景方来。以诸众生宿业报故。此大地中一切种子。禾稼药草树林而悉成长。时虚空中大风吹击大水流注。是时大地而悉滋养。阎浮提中一切人众。见是相已咸生欢喜。其心适悦想此世间有大云起。妙吉祥。而此空中有大水蕴流注大地。是时阎浮提中一切人众。即作是念。今此大地大水流注。岂非此中有大云起。作是念已咸发是言。奇哉大云降注大水充满大地。妙吉祥。而彼大水非云所有非云施设。但以大风吹击。故有大水充满大地。即彼水蕴以其众生宿业报力。随时隐没。风所摄持风所破散。如云注水。妙吉祥。但由众生宿业报故。乃于空中大水流注。非云所有非云施设。云无所生非从心入。离于来去彼善根成熟。诸菩萨摩诃萨及声闻缘觉诸异生等亦复如是。谓由彼等随智所乐。积集胜行种善根故。如来应供正等正觉出现世间。为诸众生示涅槃道对现无碍。如来处于天人众中。诸有所说名字建立悉无别异。妙吉祥应知。如来于天人众中所出音声。而无其实都无所有。妙吉祥。如来无相离诸相故。无方处不离方处。无实所成无生无灭。如来为诸天人世间。随宜对现广说正法悉充足已。而彼新发意菩萨及诸愚夫异生。以宿善业报乐涅槃法而化度者。不见如来有所对现。皆谓如来入大涅槃。妙吉祥。如来若生若灭悉无所有。以佛如来不生灭故。如来应供正等正觉本来寂静。如来无实如其大水。所缘无实云亦无实。无生无灭云无实故。乃于世间假施设有。如来诸有说法所缘。亦复如是而无其实。不生不灭本来如是。如来应供正等正觉。于是无生法中。为诸世间假名安立。妙吉祥。又如大梵天王胜中最胜。于十三千大千世界。百三千大千世界中。而得自在。日日观察一切天众。下至四大王天乃为边际。以其大梵天王。遍于诸天常观察故。彼彼一切诸天子众。各各天中五欲娱乐。彼娱乐已鼓吹歌音。复止息已舍诸乐事。各各合掌尊重恭敬。瞻仰梵王目不暂舍。诸天子众各各愿求大梵王出现世间成熟善根。是时大梵天王。于须臾顷即为出现。若此大梵天王天报灭时。别有大梵天王安立宫殿。若十若百三千大千世界之中。以宿愿力故而得自在。彼诸天子亦以宿世善根成熟故。感彼大梵天王日日观察一切天众。乃至大梵天王于须臾顷即为出现。妙吉祥。彼大梵天王都无所有无处所。无动转悉空无实。无文字无音声。无说无性无思无相。离心意识无生无灭。为彼诸天子众随宜对现。以其大梵天王宿世善根愿力所建立故。诸天子众宿世善根亦成熟故。然彼诸天子众。亦不作是念。今此大梵天王诸所化现于空自在。无有实无文字。无音声无说。无性无相状。非思惟离心意识。无生无灭。妙吉祥。如来应供正等正觉亦复如是。于空自在。无有实无文字。无音声无说。无性无相状。非思惟离心意识。无生无灭。如来应供正等正觉。但以宿昔菩萨行愿力等所建立故。又以彼诸新发意菩萨。及一切声闻缘觉诸愚夫异生等。宿昔善根成熟建立故。如来乃以百千种相。而为庄严出现世间。皆如影像。无处所无动转。亦无新发意菩萨。无一切声闻缘觉愚夫异生。亦无如来于空自在。无有实无文字。无音声无说。无性无相状。非思惟离心意识。无生无灭。妙吉祥。以诸法空故。如来身相乃有百千种相而为庄严。现起如来诸威仪道设诸法用。随诸众生种种信解说广大法。其所说法令诸众生一切娆乱随烦恼等皆得寂止。如来平等于一切处住平等舍。离诸疑惑亦无差别。妙吉祥。以是缘故当知不生不灭。皆是如来方便增语

尔时世尊说伽陀曰

  如来无生法本常　　一切法与善逝等
  有所执相乃愚痴　　无实法于世间转
  如来所成如影像　　一切善法皆无漏
  一切皆遍佛真如　　三种影像世间现

复次妙吉祥。如日光明行阎浮提。从东方出。先照须弥山王。次照铁围山大铁围山。次照余诸大山。次照黑山。次照一切高显地方。次照一切此阎浮提低下地方。然彼日光悉无分别不离分别。非思惟非不思惟。离心意识。又日光明无生无灭。无诸相状以离相故。复无作意离作意故。无诸戏论离戏论故。无诸损恼离损恼故。非此非彼。非高非下。非缚非解。非有智非无智。非有烦恼非离烦恼。非真实语非虚妄语。非此岸非彼岸。非平非不平。非水非陆。非寻伺非离寻伺。非色非非色。妙吉祥。为由大地有高下中容故。光明照亦下中上影像差别。如来应供正等正觉亦复如是。无生无灭。无诸相状以离相故。复无作意离作意故。无诸戏论离戏论故。无诸损恼离损恼故。非此非彼。非高非下。非缚非解。非有智非无智。非有烦恼非离烦恼。非真实语非虚妄语。非此岸非彼岸。非平非不平。非水非陆。非一切智非非一切智。非寻伺非离寻伺。非积集非不积集。非有念非无念。非思惟非离思惟。非意生非非意生。非名非非名。非色非非色。非说非非说。非表了非无表了。非见非无见。非眼境非非眼境。非开导非不开导。非得果非不得果。非分别非不分别。非离分别非不离分别。妙吉祥。如来日轮光明。于三界中普遍照曜。所照亦无中边障碍。如来所放智日光明。先照菩萨深固大山。次照住缘觉乘诸众生等。次照住声闻乘诸众生等。次照善根深固信解众生。次照着边执者。及邪定聚众生。如来所放智日光明。但为成熟长养诸众生故。出生未来因故。增长善法语故。如来平等于一切处住平等舍。离诸疑惑亦无差别。妙吉祥。如来智日光明不作是念。此众生类具大信解。我当为说广大之法。此众生类不为说法亦不分别。此类众生具菩萨信解。此类众生具缘觉信解。此类众生具声闻信解。此类众生有善意乐。此类众生下劣邪意。又复不作如是思惟。此大信解众生。我当为说菩萨之法。此中信解众生。我当为说缘觉之法。此下信解众生。我当为说声闻之法。此善意乐及正见众生。我当为彼清净意乐。乃至住邪定聚诸众生等。随其所乐当为说法。如来智日光明不生如是种种分别。何以故。如来智日光明照破一切分别遍计及分别所起。妙吉祥。当知为诸众生种种意乐有差别故。如来智日光明所照亦复差别

复次妙吉祥。又如大海之中。有能圆满一切意乐大摩尼宝。置高幢上。随诸众生所有意乐。自然有声令其知觉随意皆得。然彼大摩尼宝。都无分别不离分别。非心非离心。非思惟非不思惟。离心意识。妙吉祥。如来亦复如是。无分别不离分别。非心非离心。非思惟非不思惟。离心意识。无能取无所取。无当得无已得。无差别谛。无贪无嗔无痴。无实无虚。非常非无常。无光明非无光明。非世间非非世间。无寻无伺。无生无灭。非思惟非离思惟。无自性无自性空。无出无入。无性可取。无言说言说断故。无喜爱无离喜爱喜爱断故。无数量离数量故。无趣类无趣类所向诸趣断故。一切所行而悉断故。无见无观无所取。非容受非不容受。非和合非不和合。无分别无计度。无障碍无表示。非染非净。无名无色相。无业无业报。无过去无未来无现在。无少法可得。无文字无音声。离诸音声故。无相状离诸相故。非内非外亦非中间。而有所得。妙吉祥。如来智宝深心清净。安置大悲最上胜幢。随诸众生意乐信解。出妙音声随宜说法。令诸众生咸得解了。如来平等于一切处住平等舍。离诸疑惑亦无差别

复次妙吉祥。如响应声。随彼响声众生知觉。是声无实。非过去非未来非现在。非内非外亦非中间。而有所得。无生无灭非断非常。非有智非无智。非有慧非无慧。非明非非明。非解脱非不解脱。非有罪非无罪。非念非无念。非有住非无住。非坐非不坐。非地界非水火风界。非有为非无为。非戏论非离戏论。非有造作非无造作。非见非无见。无文字无音声。超越音声故。非称量出过称量故。无相状离诸相故。非寂静非不寂静。非长非短。非思非无思。非状貌非无状貌。非世间非非世间。诸见自性空。无念无作意。无寻无伺。离心意识一切处平等。离诸分别出过三世。妙吉祥。如来所出种种音声。皆如响应。但随一切众生种种意乐。乃出音声随宜施设。令诸众生皆得解了。如来亦然。非过去未来现在。非内非外亦非中间。而有所得。不生不灭不断不常。非有智非无智。非有慧非无慧。非明非非明。非解脱非不解脱。非有罪非无罪。非念非无念。非有住非无住。非坐非不坐。非地界非水火风界。非有为非无为。非戏论非离戏论。非见非无见。无文字无音声。超越音声故。非称量出过称量故。无相状离诸相故。非寂静非不寂静。非长非短。非思非无思。非状貌非无状貌。非世间非非世间。诸见自性空。无念无作意。无寻无伺。离心意识。一切处平等离诸分别出过三世。妙吉祥。如来随诸众生种种信解种种意乐。出妙音声随宜说法。令诸众生咸得解了。譬如世间依止于地由地安立一切树林药草悉得生成广多增长。然彼大地都无分别不离分别。一切处平等无差别分别离心意识。一切众生亦复如是。依止如来皆由如来之所安立。一切善根悉得生成广多增长。所谓声闻乘缘觉乘菩萨乘。及余外道梵志尼乾陀等。一切邪外总略。乃至邪定聚众生。彼彼所有善根。皆悉依止如来安立。悉得生成广多增长。然佛如来都无分别不离分别。一切分别非分别所缘。作意皆悉断故。妙吉祥。如来应供正等正觉。离心意识。无寻伺无观示。无思惟无作意。于一切处住平等舍悉无差别。譬如虚空于一切处。无高无下。亦无差别无生无灭。非过去未来现在。无色相无戏论。无表示无系着无称量无比喻。无安立无所取。超眼境界离心意识。乃至超越诸语言道。于一切处悉无所住

佛说大乘入诸佛境界智光明庄严经卷第二佛说大乘入诸佛境界智光明庄严经卷第三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉诏译

复次妙吉祥。众生相状有下中上故。乃谓虚空有下中上。如来应供正等正觉亦复如是。一切处平等无差别分别。无生无灭。非过去未来现在。无色相无戏论。无表示无施设。无觉触无系着。无称量过诸称量。无比喻超越比喻。无住无取超眼境界。离心意识无状貌。无文字无音声。无作意无出无入。无高无下超言境界。于一切处随知随入。但为众生有下中上性。故见如来有下中上。妙吉祥。如来亦不作是念。今此一类下品信解众生。我当为现下品身相。此之一类中品信解众生。我当为现中品身相。此之一类上品信解众生。我当为现上品身相。如来说法亦复如是。但以一音为众生说。随众生类各得解了。如来又复不作是念。此类众生下品信解。我当为说声闻乘法。此类众生中品信解。我当为说缘觉乘法。此类众生上品信解。我当为说菩萨乘法。如来又复不作是念。此类众生信解布施。我当为说布施波罗蜜多法。此类众生信解持戒忍辱精进禅定智慧。我当为说彼等诸波罗蜜多法。如来于诸法中不生分别。何以故。如来法身毕竟无生。如来以无生故。不以名色宣说随识而转。如来于刹那间暂无分别。如来具无尽相。尽际实际皆决定故。是即一切法平等际。如来应供正等正觉。一切处平等。无下中上差别分别。一切法平等。无下中上差别分别。亦复如是。何以故。以一切法无所得故。妙吉祥。若一切法无所得。即一切法平等。若法平等即法常住。若常住即无动。若无动即无依。若一切法无所依止。即心无所住。心无住故。即无生而生。若如是观即心心所转而不颠倒。彼不颠倒心即如说而得。若如说而得即无戏论。若无戏论即无所行。若无所行即无流散。若无流散即无聚集。若法无流散即法性无违。若法性无违即一切处而悉随顺。若一切处随顺即法自性无动。若法自性无动即法自性乃有所得。若法自性有所得者。即无有少法而可决择。何以故。当知因缘所生性故。若因缘生性即毕竟无生。若毕竟无生即得寂静。若得寂静即一切法作意悉同无依。若一切法作意悉同无依即都无依止。若无依止即无得无非得。若无得无非得即得法常住。若得法常住即深固法相应。若深固法相应即无有少法可住。亦无佛法。何以故。觉了空性故。若觉了空性即是菩提。如是空无相无愿无造作。无著无生无取无依。悉觉了故。即是菩提。菩提者与深固法相应。相应之名由是建立。是故无高无下法相应。无作非无作相应。无缚无解相应。无一性无多性相应。无来无去相应。是即深固法相应。若深固法相应。彼即无所相应亦无所断复无果证。何以故。心法本来自性明亮。但为客尘烦恼之所坌污。而实不能染污自性。若自性明亮即无烦恼。若无烦恼即无对治。谓以对治烦恼皆悉断故。所以者何。无已净。无当净不离清净本来如是。若清净即无生。若无生即无动。若无动即断诸喜悦。一切所爱皆亦断灭。若诸爱灭彼即无生。若法无生即是菩提。若菩提即平等。若平等即真如。若真如即一切有为无为法而悉无住。若真如中无彼有为及无为法即无二施设。若有为无为法无二施设彼即真如。若彼真如即无异真如。若无异真如。无种类真如。若无种类真如即无来真如。若无来真如即无去真如。若无去真如即如所说真如。若如所说真如即无生真如。若无生真如即无染无净。若无染无净即无生无灭。若无生无灭即涅槃平等。若涅槃平等即无生死亦无涅槃。若无生死亦无涅槃。即无过去未来现在。若无过去未来现在。即无下中上法。若无下中上法。彼即是真如。真如之名由是建立。此说真如。亦名实性。此说实性。亦名如性。此说如性。亦即真如。真如与我而本无二。亦无种类。无二义者即是菩提。菩提者觉了义。此所说义。即是证入三解脱门之智。宣说一切法智。解入一切法三世平等。一切法无破坏义。此所说义即是无义。无音声无记说。无诠表及诠表所起。此说名智。所谓义随知智识随知智。此说智义。即是如性智义。识随知智义。如是胜义即是法性。彼法性义即是义随知智识随知智。胜义随知智。如其法性即如其义。若法性即法住性。法寂静性。彼法寂静即无所转。若法无转。即文与义而悉平等。若文义平等。即无二之义平等。若彼义平等义识亦平等。此即是为入无二门平等之智。由是世俗胜义而悉平等。世俗义平等故。即空义平等性平等。若空性义平等故。即补特伽罗平等性平等。若补特伽罗平等故。即法平等性平等。若法平等故。即信解平等性平等。若信解平等彼觉了故。即是菩提。妙吉祥。若于色平等性有著有碍者。即于眼有碍。以色及眼自性智无所碍故。若于诸见有著有碍者。即于身有碍。以诸见趣身中自性空智无所碍故。若于不深固作意有著有碍者。即于法光明有碍。以深固作意伺察诸法自性空智无所碍故。若于疑惑垢染有著有碍者。即于解脱有碍。以信解解脱如实之智无所碍故。若于懈怠垢染有著有碍者。即于现证坚固精进有碍。以如所说法觉了之性无所碍故。若于诸障有著有碍者。即于七觉支法有碍。以无障解脱智无所碍故。应知一切法自性清净。但由因缘和合而转。而诸菩萨当善了知一切法中染因净因。若染因若净因。皆清净已即无所住。谓我所起及见所起是染因。入无我法忍辱是净因。我我所见是染因。于内寂静外无所行是净因。欲嗔害寻是染因。慈悲喜舍入伺察法忍辱是净因。四颠倒是染因。四念处是净因。五盖是染因。五根是净因。六处是染因。六念是净因。七不正法是染因。七觉支法是净因。八邪法是染因。八正法是净因。九恼处是染因。九次第定是净因。十不善业道是染因。十善业道是净因。总要而言。一切不善作意皆是染因。一切善作意皆是净因。若染因若净因。彼一切法自性皆空。无众生无寿者。无养者无补特伽罗。无主宰。无摄受无所作。如幻无相内心寂静。若内寂静是即遍寂。若遍寂即自性。若法自性即无所得。若无所得即无依止。若无依止即如虚空。当知染净。彼一切法与虚空等。然彼虚空亦不坏法性。何以故。妙吉祥。是中无有少法可得若生若灭。妙吉祥白佛言。世尊。若尔者如来取证菩提。皆谓何乎。佛言。妙吉祥。如来以无根本无住故得菩提。妙吉祥言。何名根本复何名住。佛言。妙吉祥。有身为根本。依虚妄分别而住。诸佛如来以菩提平等故。即是一切法平等智。是故说名无根本无住。如来以如是故现成正觉。妙吉祥。当知诸法寂静近寂。何名寂静何名近寂。内谓寂静外谓近寂。何以故。以眼空故我我所自性亦空。此名寂静。知眼空已色无所取。此名近寂。以耳空故我我所自性亦空。此名寂静。知耳空已声无所取。此名近寂。以鼻空故我我所自性亦空。此名寂静。知鼻空已香无所取。此名近寂。以舌空故我我所自性亦空。此名寂静。知舌空已味无所取。此名近寂。以身空故我我所自性亦空。此名寂静。知身空已触无所取。此名近寂。以意空故我我所自性亦空。此名寂静。知意空已法无所取。此名近寂。妙吉祥。菩提自性明亮。心自性明亮。以何因故。说自性明亮。谓即自性无染污故与虚空等。虚空自性而悉周遍。如虚空性。毕竟自性本明亮故。又妙吉祥。菩提无入无出。何名无入无出。谓无摄取故名无入。谓无弃舍故名无出。如来证解无入无出。如所证解即同真如。无此无彼以一切法离彼此故。是故如来现成正觉。又妙吉祥。菩提无相亦无所缘。何名无相及无所缘。谓眼识无所得此名无相。色无所观此名无所缘。耳识无所得此名无相。声无所闻此名无所缘。鼻识无所得此名无相。香无所嗅此名无所缘。舌识无所得此名无相。味无所尝此名无所缘。身识无所得此名无相。触无所觉此名无所缘。意识无所得此名无相。法无所分别此名无所缘。妙吉祥。此等皆是诸圣境界。所有三界非圣境界。由是应行圣境界故。又妙吉祥。菩提非过去未来现在。三世平等故。三轮断故。三轮者。谓过去心不转。未来识无取。现在意无动。彼心意识设有所住。而无分别不离分别。无计度不离计度。无过去已作。无未来领纳。无现在戏论。又妙吉祥。菩提非身得。无所为故。非身得者。谓即眼识无所了知。耳鼻舌身意识无所了知。以非心意识所了知故。即是无为。此说无为。谓即无生无住无灭三轮清净。如其无为。于有为法应如是知。何以故。一切法无自性故。以法无自性。即法无有二。又妙吉祥。菩提是无差别句。何名无差别。复何名句。谓无想是无差别。真如是句。无住是无差别。法界是句。无种种性是无差别。实际是句。无所缘是无差别。无动是句。空是无差别。无相是句。无寻伺是无差别。无想是句。无求愿是无差别。无众生是句。众生无自性是无差别。虚空是句。无所得是无差别。无生是句。无灭是无差别。无为是句。无所行是无差别。菩提是句。寂止是无差别。涅槃是句。无所取是无差别。无生是句。又妙吉祥。菩提者非身可证。何以故。身虽有生无思无动。如草木瓦砾。其心如幻。空虚不实无所造作。妙吉祥。若于身心如实觉了。即是菩提。世俗所行非胜义谛。何以故。胜义谛中无身无心无法无非法。无实无不实。无真无妄。无语言无非语言。一切法是菩提。所以者何。菩提无处所。非语言诠表。犹如虚空无处所故。亦无造作无生无灭。非语言诠表。如来以菩提无处所。无造作无生灭。无诠表故。如实如理审伺察时。彼一切法悉无言说。菩提亦复如是。如实伺察时亦无言说。何以故。语言无实故无生灭故又妙吉祥。菩提无所取无含藏。何名无所取。何名无含藏。了知眼故名无所取。色无所得名无含藏。了知耳故名无所取。声无所得名无含藏。了知鼻故名无所取。香无所得名无含藏。了知舌故名无所取。味无所得名无含藏。了知身故名无所取。触无所得名无含藏。了知意故名无所取。法无所得名无含藏。如来以是无所取无含藏故。现证菩提证菩提已。于眼无所取色无所得眼识无住。耳无所取声无所得耳识无住。鼻无所取香无所得鼻识无住。舌无所取味无所得舌识无住。身无所取触无所得身识无住。意无所取法无所得意识无住。以识无住故。乃名如来应供正等正觉。又妙吉祥当知。众生有四种法而住于心。何等为四。谓色受想行一切众生而住其心。谓以众生于四法中心有住故。如来乃说。不生不灭无所了知。建立菩提名之为空。以菩提空故。即一切法空如来亦空。以是空故现成正觉。妙吉祥。非为空故取证菩提亦空。当知法中有一理智。所谓空性。以菩提不空故即菩提无二。是故菩提及空悉无种类。何以故。彼一切法本无二故。无状貌无种类。无名无相离心意识。无生无灭无行无不行。亦无积集无文字无忘失。由如是故。乃说诸法空无所取。此中所说非胜义谛。谓胜义谛中无法可得乃说名空。妙吉祥。譬如虚空故。此说虚空者。谓无言故名为虚空。妙吉祥。空亦复如是。此所说空。谓无言故名之为空。若如是解入即一切法无名。以无名故彼一切法假名施设。妙吉祥。名者不在方不离方。如名不在方不离方故。于法名字乃有所说。其所说法亦不在方不离方。彼一切法亦复如是。如来了知本来如是。不生不灭无起无相。离心意识无文字无音声。如所了知亦然解脱如吉祥。当知一切法无缚无解

佛说大乘入诸佛境界智光明庄严经卷第三佛说大乘入诸佛境界智光明庄严经卷第四

        译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣惟净等奉　诏译

佛言。妙吉祥。菩提者与虚空等。谓以虚空无高无下。菩提亦然无高无下。由是如来成等正觉。虽成正觉。亦无少法如微尘许若高若下诸所施作。此如是法若如是知即是实智。妙吉祥。以何义故名为实智。谓一切法了无根本无生无灭。彼无实性亦无所得。若有实性即是灭法。彼虽有生而无主宰复无摄受。妙吉祥。若无主宰无摄受法即是灭法。此等诸法若生若灭。当知皆是缘法所转。亦非此中有少法可转。然佛如来不于诸法说断灭相

复次妙吉祥。菩提者即是如说句。以何义故名如说句。如说句者即是菩提。如其菩提色受想行识亦然。而不离真如。如其菩提眼耳鼻舌身意。色声香味触法处亦然。而不离真如。如其菩提眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界亦然。而不离真如。如其菩提地界水界火界风界亦然。而不离真如。此等诸法如是施设。其所施设谓蕴处界。由是如来成等正觉。所成正觉离颠倒法。如其先法后法亦然中法亦然。前际不生后际不去中际性离。此如是法是即名为如所说句。如其一法多法亦然。如其多法一法亦然。妙吉祥。若一性若多性皆无所得。若有相若无相无入无住。何名为相何名无相。所言相者。谓即生起一切善法。言无相者。谓一切法无所得故。又相者谓即心无所住分位。无相者即无相三摩地解脱法门。又相者即一切法思惟称量算数伺察。无相者谓出过称量。何名出过称量。谓识法无故。又相者即有为伺察。无相者即无为伺察

复次妙吉祥。菩提者即是无漏无取。何名无漏。何名无取。无漏者。谓离四种有漏之法。何等为四。一者欲漏。二者有漏。三者无明漏。四者见漏。无取者。谓离四种取着之法。何等为四。一者欲取。二者见取。三者戒禁取。四者我语取。如是四取。悉由无明暗蔽爱法滋润互相取着。妙吉祥。若或本初于我语取根本。能了知者即我清净。我清净已。随知一切众生清净。由我清净故即彼一切众生清净。若一切众生清净即法无二无二种类。彼无二义即无生无灭。妙吉祥。若无生无灭即无心意识可转。若无心意识可转即无分别。若无分别即深固作意相应无明不能发起。若彼无明不发起者。即十二有支亦不生长。若十二有支不生长者即法无生。若法无生即法决定。若法决定即调伏义。若调伏义即是胜义。若其胜义即离补特伽罗义。若离补特伽罗义即不可说义。若不可说义即缘生义。若缘生义即是法义。若法义即如来义。如是所说。若见缘生即能见法。若能见法即见如来。彼诸所见。若其如理审伺察时。是中亦无少法可见。妙吉祥。何名少法。谓心所缘。若无心所缘即无所见。由如是法故如来成等正觉。平等故平等

复次妙吉祥。菩提者。是清净义。无垢义。无著义。何名清净。何名无垢。何名无著。谓空解脱门即是清净。无相解脱门即是无垢。无愿解脱门即是无著。无生是清净。无作意是无垢。无起是无著。自性是清净。圆净是无垢。明亮是无著。无戏论是清净。离戏论是无垢。戏论寂止是无著。真如是清净。法界是无垢。实际是无著。虚空是清净。寥廓是无垢。广大是无著。了知内法是清净。外无所行是无垢。内外无所得是无著。了知蕴法是清净。界法自性是无垢。离诸处法是无著。过去尽智是清净。未来无生智是无垢。现在法界安住智是无著。妙吉祥。此如是等。清净无垢无著诸义。于一句中普能摄入。谓寂静句。若寂静即遍寂。若遍寂即近寂。若近寂即寂止。若寂止此说即是大牟尼法

复次妙吉祥。如其虚空菩提亦然。如其菩提诸法亦然。如其诸法众生亦然。如其众生刹土亦然。如其刹土涅盘亦然。妙吉祥。此说即是涅盘平等。为一切法毕竟边际清净之因。无对治离对治因。本来清净。本来无垢。本来无著。如来了知彼一切法。如是相故现成正觉。然后观察诸众生界。建立清净无垢无著游戏法门。以是名字于诸众生大悲心转

复次妙吉祥。云何是菩萨所行菩萨胜行。谓若菩萨无尽无不尽。无生无不生。于毕竟尽相无所领受。然亦不坏毕竟无生。妙吉祥。菩萨若如是行。是为菩萨胜行

复次妙吉祥。菩萨于过去心已尽此无所行。未来心未至此无所行。现在心无住此无所行。菩萨于其过去未来现在诸心悉无所著。菩萨若如是行。是为菩萨胜行

又复布施之法。诸佛如来与诸菩萨。而无其二无二种类。菩萨若如是行。是为菩萨胜行。持戒忍辱精进禅定智慧亦复如是。诸佛如来与诸菩萨。而无其二无二种类。菩萨若如是行。是为菩萨胜行

又妙吉祥。菩萨不行色空。不行色不空。菩萨若如是行。是为菩萨胜行。何以故。色即是空色自性空。受想行识亦复如是。是故不行识空。不行识不空。菩萨若如是行。是为菩萨胜行。何以故。谓心意识无所得故。妙吉祥。此中无少法可有若知若断若修若证。悉无所有由如是故。此说名尽。如是乃为毕竟尽相。若毕竟尽即无所尽。无尽亦无尽。何以故。如所说尽故。若如所说尽彼即无法可尽。若无法可尽即是无为。若无为即无生亦无灭。若佛出世若不出世法性常住。以法住故即是法界。如法界住故智无所转亦非无转。以智无转非无转故。如是法理若悟入者。即得无漏无生无灭。此名漏尽。妙吉祥。是故当知虽复世俗音声文字总聚施设。是中无有少法若生若灭

尔时妙吉祥童真菩萨摩诃萨即从座起。偏袒右肩右膝着地向佛合掌。以妙伽陀伸赞叹曰

  无形显色无状貌　　是中无灭亦无生
  无住亦复根本无　　无所缘尊今赞礼
  以无住故无出入　　亦复无彼诸分位
  已能解脱六处长　　无所缘尊今赞礼
  一切法中无所住　　有性无性皆远离
  诸行平等得圆成　　无所缘尊今赞礼
  已能出离于三界　　虚空平等性中住
  世间诸欲不染心　　无所缘尊今赞礼
  三摩呬多常安处　　行住坐卧亦复然
  诸威仪事妙肃成　　无所缘尊今赞礼
  平等而来平等去　　平等性中妙安住
  不坏平等性法门　　无所缘尊今赞礼
  大圣善入平等性　　诸法皆住等引心
  遍入无相妙法门　　无所缘尊今赞礼
  大圣无住无所缘　　定中高积慧峰峻
  普遍诸法得圆成　　无所缘尊今赞礼
  众生威仪及色相　　语言音声亦复然
  普能示现刹那间　　无所缘尊今赞礼
  大圣已离于名色　　于蕴界法亦普断
  复能善入无相门　　无所缘尊今赞礼
  大圣善离于诸相　　诸相境界亦远离
  已能善入无相门　　无所缘尊今赞礼
  无所思惟无分别　　净意亦复无所住
  无诸作意无念生　　无所缘尊今赞礼
  譬如虚空无含藏　　已离戏论无所著
  其心平等复如空　　无所缘尊今赞礼
  譬如虚空无中边　　诸佛法性亦如是
  已能超越三世门　　无所缘尊今赞礼
  诸佛犹如虚空相　　即此虚空亦无相
  已能解脱事及因　　无所缘尊今赞礼
  一切法中无依止　　如水中月无所取
  无我相亦无音声　　无所缘尊今赞礼
  大圣不依止蕴法　　界处诸法亦复然
  已能解脱颠倒心　　无所缘尊今赞礼
  大圣已离于二边　　亦复断除于我见
  法界平等得圆成　　无所缘尊今赞礼
  色相名数已解脱　　亦复远离不正法
  无取无舍平等心　　无所缘尊今赞礼
  已能超越诸魔法　　一切法中悉通达
  妙入无障碍法门　　无所缘尊今赞礼
  正智不说诸法有　　亦复不说诸法无
  无语言道无发生　　无所缘尊今赞礼
  圣不依止于二法　　久已摧折我慢幢
  解脱二无二法门　　无所缘尊今赞礼
  所有身语意过失　　大圣久已普除断
  不可譬喻不可思　　无所缘尊今赞礼
  大圣无转无发悟　　一切过失悉远离
  智为先导遍所行　　无所缘尊今赞礼
  无漏净念最微妙　　实不实法悉了知
  亦无系着无思惟　　无所缘尊今赞礼
  大圣于心无所缘　　而能遍知一切心
  亦无自他想念生　　无所缘尊今赞礼
  无所缘中有所缘　　于一切心不迷着
  无障碍法已圆明　　无所缘尊今赞礼
  大圣于心无所缘　　亦复自性无所有
  无心平等得圆成　　无所缘尊今赞礼
  大圣不依于智法　　而能遍观诸刹土
  一切众生行亦然　　无所缘尊今赞礼
  智者于心无所得　　是中亦复毕竟无
  于一切法正遍知　　无所缘尊今赞礼
  知一切法皆如幻　　即此幻亦无所有
  已能解脱幻法门　　无所缘尊今赞礼
  正觉虽行于世间　　亦不依止于世法
  复无世间分别心　　无所缘尊今赞礼
  大圣于彼空中行　　由空所成空境界
  空与非空圣所宣　　无所缘尊今赞礼
  现大神通起化事　　悉依如幻三摩地
  离种种性遍入门　　无所缘尊今赞礼
  了知非一非多性　　若近若远无所转
  无高无下平等心　　无所缘尊今赞礼
  金刚喻定现在前　　一刹那中成正觉
  遍入无对碍法门　　无所缘尊今赞礼
  虽知涅盘无所动　　亦于三世善调伏
  具足种种方便门　　无所缘尊今赞礼
  于彼一切众生类　　善解智慧及方便
  然亦不动涅盘门　　无所缘尊今赞礼
  大圣无相无发悟　　已离戏论无对碍
  无我故无对碍心　　无所缘尊今赞礼
  已离疑惑无过失　　无我我所亦复然
  于一切处正遍知　　无所缘尊今赞礼

佛说大乘入诸佛境界智光明庄严经卷第四佛说大乘入诸佛境界智光明庄严经卷第五

        译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣惟净等奉　诏译

  稽首十力度烦恼　　稽首广大施无畏
  善住不共诸法中　　稽首世间尊胜者
  稽首能断众结缚　　稽首已住于彼岸
  稽首救世诸苦尊　　稽首不住于生死
  普遍通达众生行　　于一切处离意念
  如莲不着于水中　　净空寂默常亲近
  圣师种种无上句　　稽首无缘度染海
  普遍善观诸相门　　于诸愿求无所有
  佛大威力不思议　　犹如虚空无依止
  稽首广持胜德门　　稽首犹如妙高胜

尔时世尊赞妙吉祥童真菩萨摩诃萨言。善哉善哉妙吉祥。如是如是妙吉祥。勿于诸佛起色相见。勿于诸法谓其无相。勿谓诸佛独居法界。亦勿谓佛处大众中。当知诸佛无见无闻。无所供养无供养者。诸佛如来无有少法若一性若多性而可施作。亦勿谓佛得菩提果。亦勿谓佛有法可现。无见无闻无念无知。佛亦无言已说现说当说诸法。亦非诸佛现成正觉。亦无有法能成正觉。亦非诸佛断染证净。设有所作离见闻觉知。何以故。妙吉祥当知。一切法本来清净故

复次妙吉祥。汝等当知此经功德不可思议。若有菩萨以三千大千世界微尘等数一切众生。普令建立成缘觉果。然于此正法不生信解。若有菩萨于此正法生信解者。其所获福比前福蕴广多无量。何况自书或教人书。所得福蕴倍复增胜

又妙吉祥。若复有人以三千大千世界所有一切众生之类。若卵生若胎生。若湿生若化生。若有色若无色。若有想若无想。若非有想若非无想。若二足若四足。若无足若多足。彼如是等诸众生类。普令建立皆得人身。得人身已悉令发起大菩提心。发大菩提心已一一菩萨。于不可思议殑伽沙数佛刹土中。为微尘等诸佛菩萨并声闻众。以饮食衣服坐卧之物。病缘医药及诸乐具。供给供养经殑伽沙劫。彼彼诸佛入涅盘后。造七宝塔广一由旬高百由旬众宝界道。摩尼真珠殊妙严饰。竖立种种宝幢幡盖。自在王宝妙网垂覆种种庄严。若复有人深心清净。能于如是入诸佛境界智光明庄严甚深正法。闻已信解或复悟入。起清净心少略乃至一四句偈为人演说。此所获福不可称数。现证佛智成办福行殊胜事业。比前菩萨布施福蕴。百分不及一。千分不及一。百千分不及一。千俱胝分不及一。百千俱胝分不及一。算分数分及譬喻分。乃至乌波尼杀昙分。皆不及一。又妙吉祥。若有在家菩萨于阿僧祇殑伽沙数诸佛菩萨及声闻所。以其饮食衣服坐卧之具病缘医药。经阿僧祇殑伽沙劫供给供养。或有出家菩萨戒行清净深心具足。于其一切牛畜聚中。少略乃至施以一食。此获福蕴比前福蕴。百分不及一。千分不及一。百千分不及一。千俱胝分不及一。百千俱胝分不及一。算分数分及譬喻分。乃至乌波尼杀昙分。皆不及一

又妙吉祥。若三千大千世界如微尘等出家菩萨。若行具足深心清净者。一一菩萨于十方世界阿僧祇殑伽沙数诸佛菩萨及声闻所。以其饮食衣服坐卧之具病缘医药。经阿僧祇殑伽沙数劫中供给供养。彼诸菩萨所获福蕴其数无量。若有菩萨或在家者或出家者。戒行具足深心清净。于此正法闻已信解。若自书写或教人书。此所获福比前菩萨布施福蕴倍复增胜。百分不及一。千分不及一。百千俱胝算数譬喻。皆不及一

又妙吉祥。若有菩萨以三千大千世界满中七宝。经三千大千世界微尘数劫。布施供养佛菩萨等。若有菩萨于此正法。少略乃至一四句偈。能解入者此所获福。比前福蕴百分不及一。千分不及一。百千俱胝算数譬喻。皆不及一

妙吉祥。且置如上经三千大千世界微尘数劫布施福行。妙吉祥。假使阿僧祇殑伽沙数等诸菩萨。一一菩萨皆于阿僧祇殑伽沙数佛刹土中。以阎浮檀金所成诸妙宝树及殊妙衣服。普遍光明真珠摩尼宝网垂覆。自在王摩尼宝所成楼阁。以电光明摩尼宝。而为界道。竖立殊妙幢幡宝盖。圆满作已。普为阿僧祇殑伽沙数佛世尊等日日供养。如是经于阿僧祇殑伽沙劫修布施行。或有菩萨于此最上甚深正法生信解已。少略乃至一四句偈。为余菩萨如理宣说令其解入。此获福蕴比前菩萨布施福蕴。百分不及一。千分不及一。百千俱胝算数譬喻。皆不及一

又妙吉祥。正使三界成已。所有一切地狱饿鬼畜生趣中诸众生类。若有在家菩萨为彼地狱饿鬼畜生趣中一切众生普令救拔。得出离已皆悉建立成缘觉果。若有出家菩萨于诸牛畜聚中。少略乃至施以一食。此所获福无有称量

又妙吉祥。正使十方所有一切佛刹土中。不可说俱胝那庾多百千如微尘等出家菩萨。一一菩萨于十方世界一一方分皆有十佛刹不可说俱胝那庾多百千如微尘等诸佛世尊。彼一一佛并诸菩萨声闻大众。经十佛刹不可说俱胝那庾多百千微尘数劫。以饮食衣服坐卧之具病缘医药。为彼一一诸佛如来。于日日中以十佛刹不可说俱胝那庾多百千如微尘等世界充满自在王摩尼妙宝布施供养。若有菩萨于此正法生信解已。于其牛畜聚中少略乃至施以一食。此所获福比前菩萨布施福蕴。百分不及一。千分不及一。百千俱胝算数譬喻。皆不及一。何以故。今此正法若得闻者。即得不退转。诸大菩萨大智印故

又妙吉祥。若有菩萨能为十方一切世界一切众生。悉令建立皆住随信行地。若有菩萨为一众生建立令住随义行地。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生建立令住随义行地。若有菩萨为一众生建立令住随法行地。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住随法行地。若有菩萨为一众生建立令住须陀洹果。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住须陀洹果。若有菩萨为一众生建立令住斯陀含果。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住斯陀含果。若有菩萨为一众生建立令住阿那含果。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住阿那含果。若有菩萨为一众生建立令住阿罗汉果。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住阿罗汉果。若有菩萨为一众生建立令住缘觉之果。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令住缘觉之果。若有菩萨为一众生建立令发大菩提心。此所获福无有称量

又妙吉祥。若有菩萨能为十方一切世界一切众生。建立令发菩提心已。若有菩萨为一众生建立令住不退转位。此所获福无有称量

又妙吉祥。正使菩萨普为一切众生。建立皆住不退转位。若有菩萨发清净心。于此最上甚深正法。正信解已。能自书写若教人书。或复为他广大宣说。少略乃至令一众生于此最上甚深正法信解悟入者。所获福蕴无量无数不可称计

尔时世尊。普为大众说伽陀曰

  若有诸菩萨　　供十俱胝佛
  受持正法门　　极尽时边际
  复于甚深典　　爱乐而听受
  此福广无边　　果报中最胜
  若有诸菩萨　　神力往十方
  十俱胝佛所　　亲近而供养
  遍礼人中尊　　最上诸正士
  悲愍诸众生　　增长众利乐
  今此甚深经　　诸佛共宣说
  若能为他人　　须臾敷演者
  是即佛教中　　善开发净信
  彼所获福果　　广大复最胜
  诸佛大悲愍　　宣示此正法
  如广大灯明　　普照人天界
  中有猛利慧　　及具大力者
  能发信解心　　速得成佛果
  如是善逝教　　若有得闻者
  闻已复为他　　展转而宣演
  如为彼诸佛　　最上人中尊
  入大无余依　　清净涅盘已
  能建立宝塔　　增耸复殊妙
  众宝所庄严　　高踰有顶际
  竖立胜幡盖　　宝铃出妙声
  上彻有顶天　　严好而广大
  若有诸菩萨　　爱乐此经典
  于如是相中　　闻已发净信
  于彼清净处　　安布是正法
  此所获福蕴　　广大而最胜
  若有诸菩萨　　受持此正法
  广为他流通　　涤除吝法垢
  此所获福蕴　　功德胜无量
  趣求大菩提　　随愿而获得
  此甚深经典　　诸佛之所宣
  诸大菩萨众　　多受持宣演
  十方一切佛　　悉于虚空界
  普现诸佛身　　令一切瞻仰

佛说此经已。妙吉祥菩萨摩诃萨。并余无数不思议不可说诸菩萨众。及大声闻。一切世间天人阿修罗乾闼婆等。闻佛所说皆大欢喜。信受奉行

佛说大乘入诸佛境界智光明庄严经卷第五


佛说大乘十法经

    No. 314 [No. 310(9)]

佛说大乘十法经

        梁扶南三藏僧伽婆罗译

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘五千人俱。无量菩萨众。尔时彼大菩萨众中。有菩萨摩诃萨。名曰净无垢妙净宝月王光。集彼菩萨大众中。尔时净无垢妙净宝月王光菩萨摩诃萨。即从坐起舍莲花台往至佛所。偏袒右肩右膝着地。合掌白佛言。世尊。世尊大乘比丘住大乘比丘者。何故名住大乘比丘。复以何义故此大乘名曰大乘。尔时世尊告净无垢妙净宝月王光菩萨摩诃萨言。善哉善哉。净无垢妙净宝月王光。汝能问如来此甚深妙义。善男子。善思念之。吾当为汝分别解说。尔时净无垢妙净宝月王光菩萨白佛言。世尊。如尊教。尔时世尊告净无垢妙净宝月王光菩萨言。善男子。菩萨摩诃萨成就十法。名住大乘。何等为十。所谓成就正信。成就行。成就性。乐菩提心。乐法。乐观正法。行于正法及顺法。远离慢我慢等事。善好通达诸微密语。不乐声闻及缘觉等。善男子。菩萨摩诃萨成就如是十法。名住大乘。善男子。菩萨摩诃萨。成就不谄曲柔和行。柔和行彼能信诸佛如来正真正觉无上菩提。善能信一念中三世诸佛智。信如来藏不断常不老死不可尽。亦信实际法界一切种智一切种智相诸力无畏不共佛法。复信诸佛如来不可灌顶。亦信三十二大人之相八十妙好圆光等法。复信声闻所说或缘觉所说菩萨及余所说。亦信世间及出世间。复信正行行者顺行等沙门及婆罗门。亦信诸善根业报最胜上爱果若天天王若人人王。复信不善业报最下恶。不可乐闻不爱甚重粗过。或地狱畜生饿鬼等处。彼如是信已远离三法。何等为三。所谓疑惑不决等事。善男子。菩萨成就如是诸法名为正信。尔时世尊。欲重宣此义。而说偈言

  信为最上乘　　以是成正觉
  是故信等事　　智者敬亲近
  信为最世间　　信者无穷乏
  是以信等法　　智者正亲近
  不信善男子　　不生诸白法
  犹如焦种子　　不生于根芽

善男子。云何菩萨摩诃萨成就诸行。善男子。菩萨摩诃萨剃除须发以被正服。殷重信心舍家出家。出家已习学菩萨威仪戒等诸行。或复声闻威仪戒等诸行。亦学缘觉威仪等行。彼如是或以所有身口意等同习烦恼。彼一切同灭。是中何者身所有同习烦恼。所谓杀生偷盗恶欲邪淫。刀杖瓦石等执悭吝。于他动手足等。往来逃走等事。是名身有同习烦恼。是中何者口家同习烦恼。所谓妄语两舌恶口绮语。恒说恶语毁谤甚深诸典。于诸尊长修梵行中广说恶名。是名口同习烦恼。是中何者意家同习烦恼。所谓悭贪邪见嫉妒。乐著名闻利养。亲族姓慢。色慢。幼年慢。无患慢。长寿多闻慢思惟慢。欲觉妄想觉恶觉亲觉土觉。饮食衣服卧具医药资用等觉。着处着乘着床。着诸饮食。妻子男女。营作犁耧奴婢等。钱财谷麦仓库贮积等事。乃至着种种资用之具。彼如是吝着已。所说事中。若失一事。便生其忧苦恼妄想等事。彼如是远离爱润心已生于思惟。善男子。略说意业。犹如世间轮转。故说意业同习气烦恼。彼如是离身口意业同习烦恼已。于和上所起其尊想。其阿阇梨所起和上想。于同梵行若老若少。起殷重恭敬。彼独在空闲之处。作如是思惟。我不应作如是。我为度一切众生。为解一切众生。为令安调伏静定众生故发诸行。然我自不调伏不隐诸根。未为寂灭。我必修正行。令有见我者必得成受调伏。亦顺诸佛微妙等教。复令欢喜诸天神龙夜叉乾闼婆等。善男子。此名为菩萨惭。彼作如是思惟。勿有令我若道若俗于诸威仪行中取诸过失。所谓行戒行不正中。或见形或威仪行。或行资用寿命行等。彼如是惭愧已。日夜之中六时观于持戒等法。彼善持戒已无复疑悔。令入住如来佛法中。无有休息。善男子。此之名为菩萨愧。善男子。是名菩萨成就如是诸行。尔时世尊。欲重宣此义。而说偈言

  诸佛行为本　　及声闻弟子
  是故智者修　　行行常坚固
  诸菩萨大智　　行诸无畏行
  令证离垢道　　诸佛所赞叹

善男子。云何菩萨成就性。佛子菩萨性成。少欲嗔恚愚痴等。不妒不吝不恼。不说粗言。不欲嗔调戏。不轻动。调和柔。已软近亲可性。能成就上妙供具供养诸佛。所谓资用等财。惠施与他。具足成就手足头目等。若见如来或如来弟子。见已即生恭敬欢喜之心。善男子。菩萨如是名为性成就。尔时世尊。欲重宣此义。而说偈言

  相烟即知火　　鸳鸯以显水
  复相知诸性　　菩萨大名称
  柔和不谄曲　　舍离悭嫉妒
  愍念一切众　　名之为菩萨

善男子。云何菩萨摩诃萨喜乐菩提心。若有菩萨摩诃萨。体性微发菩提心时。值佛菩萨或声闻缘觉等。教化劝发而生阿耨多罗三藐三菩提心。是名喜乐初发菩提相。彼闻菩提及菩提功德已。即发阿耨多罗三藐三菩提心。是名第二喜乐菩提相。彼菩萨见诸众生无能救护。无所归依。孤独无能济拔。无覆护。无舍宅。无有洲已。即起悲愍心。彼发心已作如是念。我今为诸众生。作救护归依济拔覆护舍宅洲等。为彼因缘故发无上菩提心。是名第三喜乐发菩提心。彼若见如来或菩萨声闻缘觉等满足诸行。见已心生欢喜爱敬安心。以是因缘发阿耨多罗三藐三菩提心。是名第四发菩提心。彼菩萨为诸众生利益安乐故行。布施持戒修忍发精进行思禅定修正慧。云何菩萨行布施。所谓须饮与饮。须食与食。须乘给乘。须床榻敷具者。给床榻敷具等。须衣施衣。须金银宝冠环钏等诸庄严具。乃至己身皮肉润益众生。彼如是行于布施已。然彼布施回向发阿耨多罗三藐三菩提。虽施而不生我慢等心。云何持戒。成就身口意业。彼舍离身口意业等已。善离能防无碍无漏。纯一无杂奉持禁戒。然彼持戒回向阿耨多罗三藐三菩提。虽行持戒然不起我慢等心。善男子。云何菩萨修忍。彼嗔骂说枷锁系闭切割挝打。若道若俗能忍能容。不起诸习等烦恼。如是修忍已然彼回向阿耨多罗三藐三菩提。虽修忍然不起我慢等心。善男子。云何菩萨发精进心。彼作如是念。犹如虚空界无量无边。众生界亦无量无边。然此众生界我独无二。令安无余涅槃界中。是以为彼因缘故发行精进。身不离身念观受。彼观受已观心心行。彼观心心已顺观诸法。彼如是善忆念观已。为未生诸不善恶法令不生故。起欲修勤精进。持心等正行。为未生诸善法令生故。起欲修勤精进。直心等正行。已生诸不善法为令灭故。起欲修勤精进。持心等正行。已生诸善法为令久住故。复令增长思故。起欲修勤精进持心等正行。彼发精进已。令成初如意足分。如是第二第三乃至成第四如意足分。彼成就如意分。能令住一劫若减一劫。或具足行令满精进波罗蜜。如是发精进已。然彼精进回向阿耨多罗三藐三菩提。虽发如是精进然心不生憍慢。善男子。云何菩萨思禅定行。离意欲离意灭离欲静。不依内不依外。不依色不依受想不依识。不依欲色无色界。不依空无相无愿。不依世间出世间。不依布施持戒忍辱精进等。善男子。乃至略说一切有想系缚等名为禅。如是修诸禅。然彼禅回向阿耨多罗三藐三菩提。虽思修此禅。然不起我慢等心。善男子。云何菩萨修智。彼作如是念。无量无边众生界令入涅槃。然无一众生可入涅槃。何以故。如佛所说一切法法无我无众生无命无寿无富伽罗。如是修观智。然彼智回向阿耨多罗三藐三菩提。虽观修般若然不起我慢等心。善男子。如是菩萨摩诃萨乐菩提心。尔时世尊欲重宣此义。而说偈言

  犹如摩尼珠　　显于宝藏中
  师以加功用　　倍明于本色
  成就如是性　　求正菩提心
  二边既寂静　　令魔不得便

善男子。云何菩萨乐法成就。善男子。若菩萨性乐法喜法爱法。彼若见沙门若婆罗门。所有资用命具饮食等事。彼能奉上。彼世间所有受用等。根茎枝叶华果等。彼收已施诸众生。持诸法者。令往礼拜恭敬合掌迎接已殷重敬纳。心有所疑处问于正义。是以持法者随所闻义善能解释。彼于闻法者起世尊想善知识想。起同世间诸海想。起和上想阿阇梨想。久失导时世间旷野生难中。能访觅起访觅想。久远愚者闇闭目开故。令起觉悟想。坠没世间烦恼泥中。而起济拔之想。久远失正路为作导师故。而起导师之想。久伏在世间牢狱能解故。而起解者想。久远着患疗治故。而起良医之想。以烦恼火焦灭身。令住灭故。而起大云雨想。彼为法为法因故。能忍寒热风雨蚊虻等。亦忍饥渴。或见他人受乐报者。不起悕求乐心。然作如是念。唯我世间独乐。而我能闻正法。彼为是事故。为彼因彼缘故。不生忧悲苦恼恨等。彼如是离忧悲苦恼等已。发如是心。我堪能荷负如来所说一法句故。在阿鼻地狱住一劫若减一劫。彼如是无疲倦心已。自然不行诸行。而得一切种智。未得诸佛法而令速得。善男子。以是义故菩萨名为乐着诸法。尔时世尊。欲重宣此义。而说偈言

  大智乐诸法　　而成诸佛子
  亲近正妙法　　而不生疲倦
  敬心求正法　　诸深心佛子
  及以心忆持　　亦显正妙行

善男子。云何菩萨摩诃萨正观诸法。善男子。若菩萨作如是观。一切诸法犹如幻。迷惑凡夫故。一切诸法如梦。不实故。一切诸法如水中月。非事故。一切诸法如响。非众生故。一切诸法如影。计妄想故。一切诸法如响。声生灭坏故。一切诸法生灭坏。缘假成故。一切诸法本不生不移。同真如体故。一切诸法不灭。本不生故。一切诸法无作。无作者故。一切诸法如虚空。不可染故。一切诸法定寂灭。性不染故。一切诸法无垢。离一切诸垢故。一切诸法性灭。离烦恼故。一切诸法非色。不可见故。一切诸法离心境界。无体性故。一切诸法不住。灭诸毒故。一切诸法不可求。灭爱憎等心故。一切诸法无著。离烦恼境界故。一切诸法如毒蛇。离善巧方便故。一切诸法如芭蕉。无坚实故。一切诸法如水沫。体性弱故。善男子。菩萨如是观名为正观诸法

尔时世尊。欲重宣此义。而说偈言

  一切法如幻　　迷惑愚迷者
  虚危犹如梦　　汝等如是持
  法如水中月　　亦如响等事
  复如影像等　　智者诸不觉

善男子。云何菩萨摩诃萨行法顺法等。善男子。若菩萨摩诃萨。观色无常。而不厌离色。欲证于法已。正智助法界。同用等法善自观入。善持彼者诸相。善思善记。彼记此相善持善修善记已。自然行法界等行。受想行识亦观无常。然不厌离识等之。入法界已。正智助同。法界等法善自观达。亦记彼相善持善修善记已。自然入法界等行。如无常苦空无我亦尔。彼观色无常已。于色中不生恐怖惊等。何以故。色是妄想颠倒所起。然彼如实知。观受想行识无常。乃至于识中。不恐不怖不惊。何以故。识者妄想颠倒所起故。然彼如实知。善男子。譬如善巧幻师或幻师弟子。化作种种幻事象兵马兵车兵步兵。彼智者见已不生恐怖惊等。何以故。彼如实知是幻师所作不实。未曾有虚诳作。菩萨亦如是。观色无常已。于色中不生恐怖惊等。何以故。色是妄想颠倒所起。然彼如实知。观受想行识无常已。乃至于识中不生恐怖惊等。何以故。识者妄想颠倒所起故。然彼如实知。尔时净无垢妙净宝月王光菩萨白佛言。世尊。云何菩萨观诸色无常。然不厌离色。而证法界已。正智观入助法界等法。尔时世尊。告净无垢妙净宝月王光菩萨言。善男子。吾当为汝分别说喻。善男子。譬如有智男子。常事诸毒。善持善覆善惜。起我相已种种庄严具贸易。然是不食彼毒。勿令我因此事断其正命。菩萨亦如是。向涅槃心。润向涅槃。顺向涅槃。近取涅槃。然不证彼涅槃。何以故。勿令我因于此事退菩提行。善男子。譬如有人事其火神。然彼人日夜香华等供养恭敬尊重赞叹亲侍。然彼人不作是念。我以事火供养恭敬尊重赞叹。亲近已我以二手接取之。何以故。勿令我因此事于身有苦于心有恼。菩萨如是。向涅槃心。润向涅槃。顺向涅槃。及取涅槃。然彼不证涅槃。何以故。勿令我因此事退菩提行。尔时净无垢妙净宝月王光菩萨白佛言。世尊。如我知世尊所说意趣。菩萨者应住世间。佛言。如是如是。善男子。菩萨应住世间。问曰世尊。云何菩萨住世间。而不以世间诸患所染。佛言。善男子。为此事故略说一喻。善男子。譬如咒术之人。以大咒术力故。诸恶毒蝄蛇等弄戏。然彼人不以此事断其命根。何以故。以彼人善通达咒术力故。菩萨亦如是。行世间住世间。住世间已。大智方便咒力故。共诸烦恼毒蛇而居戏暴。亦弄行住坐卧。菩萨不以此事故于菩提而有退还。何以故。彼成就大智方便咒力故。尔时净无垢妙净宝月王光菩萨言。世尊。希有希有。彼诸菩萨而能不证涅槃。复不以世间烦恼毒之所染。世尊。我今归依诸大菩萨。世尊。是诸众生成就诸善根。闻此法已而生一欢喜心。世尊。彼善男子善女人。诸佛已记。若能闻此法门。佛言。善男子。说此法时。五百比丘。未证无漏而得解脱。彼得解脱已即从坐起。偏袒右肩右膝着地。合掌向佛。白佛言。世尊。诸菩萨者。可敬可礼拜。佛语诸比丘。如是如是。如汝所说。尔时世尊。欲重宣此义。而说偈言

  敬礼诸大智　　敬礼得无畏
  敬礼净诸目　　敬礼亲佛子
  方便善巧故　　及以胜妙智
  菩萨大名称　　能过二乘地
  如实知诸阴　　谓生灭识等
  见世间渴仰　　故不证涅槃

善男子。云何菩萨摩诃萨离慢及增上慢等。善男子。慢者。我自亦可。若家若姓若色。或复异事。金银等资用。象兵马兵步兵车兵。如是心所有高下者名曰慢。我慢者。生我身高想。若家若姓若色等。或金银财物仓库。象兵马兵步兵车兵。如是心喜高意不下诸他者。名曰增上慢。菩萨舍如是等法。名曰离慢及增上慢。尔时世尊。欲重宣此义。而说偈言

  离慢增上慢　　常以慈心念
  及常怀悲心　　恒怖世间中
  常以行乞食　　善说人天益

善男子。云何菩萨摩诃萨善巧秘密语。善男子。若菩萨摩诃萨。如来所说诸甚深经中秘密之教。彼不随说取。何者是秘密之教。如来记诸声闻。于阿耨多罗三藐三菩提者。非如所说。佛语阿难。吾患背痛不随说取。退老患朽败为我访觅。侍者不随说而取。汝目连往至耆婆医王所。取诸妙药。不应如说取。如来共诸外道尼揵子等。诤其诸伎。不应如说取。如来佉陀罗刺刺足者。是事不应如说而取。提婆达多是如来久远害者怨家。不应随说而取。如来入舍梨耶婆罗门村。空钵而出。不应如说而取。旃遮及孙陀利谤佛者。不应随说而取。须那国毗罗若婆罗门。请佛至已食麦。亦不应如说而取。尔时净无垢妙净宝月王光菩萨白佛言。世尊。世尊云何记诸声闻当得阿耨多罗三藐三菩提。佛言。善男子。吾记诸声闻得无上正真正道者。以有性故。净无垢妙净宝月王光菩萨白佛言。世尊。云何诸无漏声闻断诸有习烦恼。设有性而成阿耨多罗三藐三菩提。佛言。善男子。吾今说喻。譬如灌顶转轮圣王有子。彼欲学一切技艺等事。然是中根复非利根。彼应后学是先学。应前学彼后学。善男子。于汝意云何。彼以此事故。可说非王子也。答曰。不也世尊。是善王子。善男子。菩萨亦尔。已成就中根性故修道门。先除诸烦恼障。后成阿耨多罗三藐三菩提。善男子。于汝意云何。彼以此事故可说不成正觉。答曰世尊。我不见有众生若天若魔若梵若沙门若婆罗门人天阿修罗众中说言不成正觉者。除一阐提。佛言。善男子。复听一喻。善男子。十地菩萨为断诸烦恼坐于道场。为不断。答曰世尊。以断故。善男子。于汝意云何。彼以此岂不成正觉。答曰世尊。此名为成。佛言。善男子。此亦如是。净无垢妙净宝月王光菩萨白佛言。世尊。云何告阿难比丘。吾患背痛。佛言。善男子。吾愍念后世众生故说此言。金刚身诸佛尚患背痛。况其余者。然彼愚痴众生随教而取。彼既自坏亦坏于他。吾朽败老退患。为我访觅侍者。善男子。我此言亦为后世所说。于我灭后后世无弟子故说沙门婆罗门朽败老退患者。如是以侍者所加身故。彼以佛听故不生之意。为此故说如来朽败老退患耳。世尊。云何可取。汝目连。往至耆婆大医王所取药。善男子。我此言亦为后世故说。吾诸声闻必须诸药。知佛听故而无有乏。为此事故如来所说。彼诸愚痴众生如所说取。如来是患身。目连比丘往至耆婆所。而不礼拜及不生恭敬。速疾之意闻已。匆匆说其药。善男子。此亦说诸欲等患。证见法者尚忘。何况凡夫。世尊。云何所取。如来共诸外道尼干子等。诤其诸伎者。我为后世众生故说此言。如来尚有怨家。况于我等。然彼愚痴众生如实说取。如来有怨家等。转轮圣王微善根故。尚无诸患况如来也。成就诸功德藏。云何所取。佉陀罗刺刺如来足。如来亦说过去业报。如来尚受过去业报。况余凡夫众生为是事故。为彼因彼缘故。示于恶业。为此义故而示其业果报事。然彼愚痴众生。如实所取。佉陀罗刺刺如来足。世尊。云何可取。提婆达多是善知识。复是如来久远亲近是怨家者。善男子。若无提婆达多善知识者。不显如来诸佛功德。善男子。是以提婆达多善知识。共如来诤伎等道德。示怨家等事。然是显如来诸大智功德。善男子。若提婆达多承王教已。于大众中放护财大象。此象若往堪害如来。而如来力令降伏善调。尔时无量人众见彼象调伏已。生希有希有心。即归依三宝。所谓佛宝法宝僧宝。是名提婆达多善知识之相。然有愚痴之人如说而取。提婆达多者是如来怨家。如是五百世中现菩萨行。是提婆达多所示现者。显如来道德。然愚痴众生随教而取。提婆达多者是如来怨家害者。以是因缘。舍身堕阿鼻地狱饿鬼畜生之处。何以故。善男子。提婆达多者善集诸行。善集诸善根。以曾供养无量诸佛。于诸佛所种诸善根及大乘行。正学菩提。顺向菩提。不退于大菩提。近阿耨多罗三藐三菩提。是诸众生偏起恶故。于命终后堕阿鼻地狱饿鬼畜生之中历受诸苦。善男子。云何所取。如来入舍梨耶婆罗门村。善男子。我为愍后世故行示此教。何以故。无有业报而对如来。然我护后世故。所有乞食比丘入聚落村邑城郭王都等。以薄福力故不得其食。彼尔时正忆于我。是其佛世尊具足一切功德。空钵而出。何况我等微薄善根。我等以是故心不应生退。为此事故如来入村空钵而出。然复所说言。魔波旬治诸婆罗门令不给如来食。不应随说而取。何以故。魔无如是神力堪障施如来食。尔时诸佛神力故。令魔处处治诸婆罗门及居士等。而如来无有过咎。为显彼众生故。如来示现此方便善巧等事。尔时如来及诸声闻。断食之后魔及魔民并诸余天。观如来心。是沙门瞿昙及诸声闻弟子为忧恼不。彼日观如来及诸弟子无有意恨忧恼心。已亦不高不下。如前后亦如是。尔时彼众中七千诸天子。以心欢喜归依于佛。如来为彼善化说妙法。彼闻法已。于如来法中得法眼净。如是如来观后世事佛无业报。世尊。云何可取。旃遮孙陀利等以木器置腹上而谤如来。答曰。善男子。如来无有业患果报。如来成就诸神通力。令旃遮孙陀利。过无量恒河沙等世界。令安彼人。然是如来方便力故。示现业报诸谤等事。于我法中出家者。彼被虚谤。既闻谤已而生忧愁疑悔。彼作如是说。是如来成就一切诸白法。对面被谤。何况我等而不被谤。彼尔时忍其诸谤。行清净梵行而不成退。旃遮孙陀利者。以恶业所牵。乃至梦中谤其如来。谤已舍身堕于恶趣。若如来知是可救者。便应救之。何以故。如来无有众生而是可舍者。世尊。云何可取。如来于修罗婆国毗兰若婆罗门所。请三月安居已。唯食其麦。答曰。如来知诸婆罗门居士等请已而不供养。如来知已故往至彼。何以故。所有五百匹马者。如来并诸比丘众食麦。彼一切尽修菩萨行。亲近过去诸佛。是以值恶知识故造诸恶业。以此事生畜生中。彼五百马能调伏教者。名曰金刚藏菩萨。以愿力故生于彼处。是诸马者。以日藏菩萨所化发菩提心。为化彼故应生彼处。以彼调伏马师力故。彼一切诸马忆本宿命而彼现其菩提心。善男子。如来愍彼五百马故。往至彼处调伏马师。麦者分半施佛。五百马所有麦亦分半施诸比丘。彼马师以马音声。令彼五百马。令能悔过及礼拜佛僧等。尔时彼三说后。彼诸马舍身已生兜率陀天中。彼复生天中而供养如来。如来为彼善教化说法。闻法已即不退阿耨多罗三藐三菩提。彼五百马所调伏护者。如来亦记彼。当成辟支佛。号曰善调伏心。然复善男子。如来无慈不备不常者。善男子。设使如来食土木瓦石等。无三千大千世界中。有如是味及如是上味。是诸土木瓦石等。何以故。如来得上妙味中之味。大人之相故。善男子。以此义故应如是知。如来一切诸食皆上妙味。善男子。阿难比丘生怜愍心。如来舍转轮王位今既食麦。如来知阿难心已。施其一麦。故语阿难言。汝知是何味。彼食已生奇特异相。语我言。世尊。我生王家长养。未曾尝如是上味。以此上味力故。阿难比丘。七日受上妙快乐。而不复食。善男子。以此义故。应如是知。如来无有诸业果报。若有众生净持诸戒。若沙门及婆罗门。不随本请奉施者。为彼众生说不虚故。如来示此业果报事。善男子。汝观如来诸身等法。是彼婆罗门请如来而不施设。如来亦说彼令不退转。然善男子所说。彼五百比丘。如来记令不退者。复次善男子。所有彼五百比丘。共如来夏坐安居中。有四十比丘。多念于欲结。静念彼若得美食者。欲想欲觉便令炽盛。彼以恶食因缘故。欲想欲觉亦微。既微已。彼七日七夜得阿罗汉果。善男子。若能如是解如来所说语者。彼名为正解。善男子。菩萨摩诃萨成就如是。名为善巧解如来秘密说教。尔时世尊。欲重宣此义。而说偈言

  所说渐义教　　及以顿说者
  大智诸菩萨　　秘密故正解
  善巧诸密语　　舍利报说教
  通达正说法　　诸佛之所说

善男子。云何菩萨摩诃萨不喜乐声闻辟支佛乘。善男子。若菩萨摩诃萨。或以地狱苦。饿鬼畜生等受诸重恶。而不喜乐求声闻涅槃。复不念云何得厌离世间心。令速得自在。亦不求少欲少作等。复不求少欲少作等行因。彼所见诸众生修诸善业者。菩萨佐助令成。及劝诸众生赞叹正说正示。向阿耨多罗三藐三菩提。善男子。菩萨摩诃萨成就如是诸功德。不喜乐声闻辟支佛乘。尔时世尊。欲重宣此义。而说偈言

  化众无疲倦　　不退于菩提
  持心如山王　　行慈心等法

尔时净无垢妙净宝月王光菩萨白佛言。世尊。如来已说诸法。菩萨成就诸法已名为住大乘。然如来不说。以何义故。名为大乘。尔时世尊。告净无垢妙净宝月王光菩萨言。善男子。吾今问汝。随汝意说。善男子。于汝意云何。转轮圣王并四兵众随所行者。彼道以何说耶。答曰世尊。名曰王道。亦名大道。名无畏道。名无障碍道。名为寂静道。佛言。善男子。如来亦尔。随所乘乘至阿耨多罗三藐三菩提。彼乘名为大乘。名为上乘。名为妙乘。名微妙乘。名曰胜乘。名无上乘。名无恶乘。名无比乘。名无等乘。名无等等乘。善男子。以此义故名为大乘。答曰。善哉大乘。世尊。善哉大乘。尔时魔王波旬。作如是念。此沙门瞿昙过吾境界。亦令余者能过境界。若我集四兵众共往恼乱。及不说此法故。至沙门瞿昙所。尔时魔王波旬。将领四部兵众。至王舍大城耆阇崛山。尔时净无垢妙净宝月王光菩萨。遥见魔王波旬将领四部兵众来。欲为此法令作妨故。见已作如是神力。现神力已。魔王波旬至王舍大城巷衢四道之处。作如是声。汝等往至王舍大城。诸仁者。若知是如来在耆阇崛山中。为四部众说法初善中善后善。其义巧妙满足白净说行梵行。是故汝等应往如来所。是以汝等于长夜。而成饶益快乐。尔时王舍城中诸婆罗门刹利长者居士等。被魔劝已。持诸香华涂香末香烧香缯幡宝盖衣服等。从王舍大城出已。至耆阇崛山。于如来所头面礼佛。尊重赞叹供养恭敬已。却住一面。魔王波旬及四兵众。出王舍大城耆阇崛山中。至如来所已。化作天曼陀罗华而散佛上。散已及四部兵众却坐一面。尔时净无垢妙净宝月王光菩萨。见魔波旬却坐一面。而告之言。波旬。汝何故将四兵众至如来所。魔言。吾至此为令灭此法故。及恼乱如来故。净无垢妙净宝月王光菩萨。语魔波旬言。波旬。何容烦乱如来。及以此法。汝波旬。于如来前今可悔过。勿于长夜成无利益苦报。净无垢妙净宝月王光菩萨。所顺说法已。魔即从坐起偏袒右肩。叉手合掌礼佛足已。于如来前而起悔过。愿世尊受我悔过。我以愚痴无智慧不善巧不能自知。而如来前起恶心。及欲灭如是等经。善哉世尊。为我正受悔过等法。佛语魔王波旬言。吾法中增长善根。所谓。若善男子善女人。为欲清净法故今能悔过。尔时魔王波旬。从坐起已在佛前立。而白佛言。世尊。先制一切诸恼恶口等不善业道。佛语波旬。如是如是。波旬问曰。如来法主。何故以波旬名而唤于我。佛言波旬。吾今说喻。譬如长者及居士大富财钱无穷。然彼人唯有一子爱念深重。以彼继命为活。然彼一子不善调伏心谄曲。彼长者及居士若手若杖若卷等治。或恶言及苦语恶治。为令息彼恶故。波旬。于汝意云何。是长者居士嗔恨情治彼一子不。答曰世尊。唯为成彼一子故。佛言。如是波旬。如来亦尔。善知众生心心数法。以苦恼语调伏者。为说苦恼语。应以坛治者。即以坛治。应以摄取者。即说摄取言。应以色身度者。即以色身度之。应以声香味触法等度者。即乃至法等度之。尔时魔王波旬。从佛闻此法欢喜踊跃。复更礼佛足。礼已白佛言。世尊。若有村邑聚落中说是法者。我为听此法故往至彼处及护此经。亦念益法师故。是中多有如是瑞相。众则寂定。离调戏懈怠等。得上胜听法之者。若读若诵若受持若解说。身不生疲倦。心不起厌足。随所说此法。若听或为他广说。如是彼转生欢喜踊跃心。尔时彼众中有诸外道尼干子等。彼见闻此魔王所说语已。于如来所即生欢喜踊跃之心。尔时尊者阿难白佛言。世尊。何因何缘故。此诸外道闻说此法而得证忍。佛语阿难。过去此王舍城耆阇崛山中。有佛名曰善胜调伏多陀阿伽度阿罗诃三藐三佛陀。说法。彼佛说法已。有诸外道为恼故来。彼至已闻此法即唱善哉。而于佛所不生敬重心。彼诸外道以此因缘力故。六万劫不生地狱饿鬼畜生之中。唯生人天之处。彼诸外道以不敬如来故。所生之处不值善知识。阿难。于汝意云何。尔时彼诸外道等岂异人乎。阿难汝不应异意取。何以故。善男子。此诸外道尼干子等。阿难。今此诸外道于如来所。生欢喜恭敬踊跃心。以此因故如来今记。得阿耨多罗三藐三菩提。尔时彼诸外道尼干子等。闻受记已心大踊跃。即得无生法忍。说此法时万二千人远尘离垢得法眼净。二万众生未曾发阿耨多罗三藐三菩提心。而发道意。尔时尊者阿难白佛言。世尊。若有善男子善女人。闻此法读诵受持广为人说。得几福德。佛言。若善男子善女人。一切无余众生界。令安阿耨多罗三藐三菩提者。若复善男子善女人。读诵受持及广为人说此经。是人倍得福德。何以故。阿难。此法能令得阿耨多罗三藐三菩提一切种智。世尊。若善男子善女人。于此法及法师起恶心。世尊。彼善男子善女人。得几不饶益。佛言。善男子。若善男子善女人挑拔一切众生目。若复有人于此法及法师起恶心。是人因此事得恶。复倍于前。何以故。阿难。此法于一切众生能作光明。阿难白佛言。世尊。此法不应不信心善男子善女人前说。何以故。世尊。应护后世诸众生故。勿说此法。谤法业报故堕诸地狱中。佛语阿难。应说此法。何以故。彼诸众生于阿耨多罗三藐三菩提。即以此为因。阿难白佛言。世尊。此经以何名。云何受持。佛语阿难。此经名为十法。如是受持。净无垢妙净宝月王光菩萨所问。如是受持。如来说此法时。尊者阿难及净无垢妙净宝月王光菩萨。并诸菩萨众比丘众。及诸天人龙王阿修罗迦楼罗紧那罗摩睺罗伽等。闻佛所说欢喜奉行

佛说大乘十法经


佛说大乘无量寿庄严经

    No. 363 [Nos. 360-362, 364]

佛说大乘无量寿庄严经卷上

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众三万二千人俱。皆得阿罗汉。具大神通。其名曰尊者阿若憍陈如。尊者马胜。尊者么瑟比拏。尊者大名。尊者跋多婆。尊者称天。尊者离垢。尊者妙臂。尊者布阑拏枳曩。尊者憍梵波提。尊者优楼频螺迦叶。尊者那提迦叶。尊者舍利子。尊者大目干连。尊者摩诃迦旃延。尊者摩诃俱絺罗。尊者劫宾那。尊者摩诃[利-禾+尊]那。尊者弥多罗尼子。尊者阿那律。尊者喜。尊者紧鼻哩拏。尊者须菩提。尊者哩嚩帝。尊者佉襧啰嚩儞枳曩。尊者摩贺啰倪。尊者波啰野尼枳曩。尊者嚩拘隶曩。尊者阿难陀。尊者罗睺罗。尊者善来。如是等三万二千人俱

尔时尊者阿难。即从座起偏袒右肩。右膝着地合掌顶礼。白佛言。世尊。如来应正等觉。诸根清净。面色圆满。宝刹庄严。如是功德得未曾有。云何所行广大妙行。及过去未来诸佛所行。愿为宣说。佛告阿难。善哉善哉。汝为利益一切众生。怀慈愍心。能问如来微妙之义。汝今谛听善思念之。如来应供正遍知。今为汝说

佛告阿难。如过去无量无边不可思议阿僧祇劫。尔时有佛世尊出现于世。名曰然灯如来应正等觉。彼然灯佛前。复有世尊出现世间。名钵啰多波野输如来。又彼佛前有佛出世。名发光如来。又彼佛前有佛出世。名赞那曩誐啰护如来。又彼佛前有佛出世。名须弥劫如来。又彼佛前有佛出世。名月面如来。又彼佛前有佛出世。名无垢面如来。又彼佛前有佛出世。名无著如来。又彼佛前有佛出世。名龙主如来。又彼佛前有佛出世。名日面如来。又彼佛前有佛出世。名山响音王如来。又彼佛前有佛出世。名须弥峰如来。又彼佛前有佛出世。名金藏如来。又彼佛前有佛出世。名火光如来。又彼佛前有佛出世。名不动地如来。又彼佛前有佛出世。名琉璃光如来。又彼佛前有佛出世。名月王如来。又彼佛前有佛出世。名日音如来。又彼佛前有佛出世。名散华庄严如来。又彼佛前有佛出世。名吉祥峰如来。又彼佛前有佛出世。名持海慧自在通王如来。又彼佛前有佛出世。名施光如来。又彼佛前有佛出世。名大香象光如来。又彼佛前有佛出世。名离一切垢如来。又彼佛前有佛出世。名勇猛峰如来。又彼佛前有佛出世。名宝光如来。又彼佛前有佛出世。名持多德得通如来。又彼佛前有佛出世。名过日月光如来。又彼佛前有佛出世。名最上琉璃光如来。又彼佛前有佛出世。名慧花开心行出生如来。又彼佛前有佛出世。名大华林通王如来。又彼佛前有佛出世。名一月光如来。又彼佛前有佛出世。名破无明黑暗如来。又彼佛前有佛出世。名真珠珊瑚盖如来又彼佛前有佛出世。名三乘法自在王如来。又彼佛前有佛出世。名师子海峰自在王如来。又彼佛前有佛出世。名梵音声自在王如来。又彼佛前有佛出世。名世自在王如来应正等觉明行足善逝世间解无上士调御丈夫天人师佛世尊。而于法中。有一苾刍。名曰作法。信解第一。明记第一。修行第一。精进第一。智慧第一。大乘第一。尔时苾刍。离自本处来诣佛前。头面礼足于一面立。即以伽他叹佛面色端严。复发广大誓愿。颂曰

  如来微妙色端严　　一切世间无有等
  光明无量照十方　　日月火珠皆匿曜
  愿我得佛清净声　　法音普及无边界
  宣扬戒定精进门　　通达甚深微妙法
  智慧广大深如海　　内心清净绝尘劳
  超过无边恶趣门　　速到菩提究竟岸
  亦如过去无量佛　　威光普照众生界
  为彼群生大导师　　度脱老死令安隐
  常行布施及戒忍　　精进定慧六波罗
  未度有情令得度　　已度之者使成佛
  我以一切伸供养　　百千俱胝那由他
  恒河沙数佛世尊　　令我成就寂灭果
  复有十方诸佛刹　　恒放光明照一切
  殊胜庄严无等伦　　愿我成就利群品
  所有无边世界中　　轮回诸趣众生类
  速生我刹受快乐　　不久俱成无上道
  愿我精进恒决定　　常运慈心拔有情
  度尽阿鼻苦众生　　所发弘誓永不断

尔时世尊告阿难言。彼作法苾刍说是偈已。白世自在王如来。我今发阿耨多罗三藐三菩提心。乐求无上正等正觉。唯愿世尊。说诸佛刹功德庄严。若我得闻。恒自修持严土之行。尔时世自在王如来。告作法苾刍言。汝自思惟。修何方便。而能成就佛刹庄严。苾刍白言。我智慧微浅。不能了知严刹之行。如来应正遍知。愿为宣说诸佛刹土庄严之事。时世自在王如来。即为宣说八十四百千俱胝那由佛刹功德庄严广大圆满之相。经于一劫方可究竟。尔时阿难闻是事已。白佛言。世尊。彼世自在王佛寿量长短云何说土经于一劫。佛告阿难。彼佛寿命满四十劫。阿难。彼作法苾刍。闻佛所说八十四百千俱胝那由他佛刹功德庄严之事。明了通达如一佛刹。即时会中头面礼足。辞佛而退。往一静处独坐思惟。修习功德庄严佛刹。发大誓愿经于五劫。尔时作法苾刍。复诣世自在王如来所。五体投地礼世尊足。礼已合掌。白佛言。世尊。如是八十四百千俱胝那由他佛刹。功德庄严所行行愿。我今成就。时世自在王如来告苾刍言。善哉善哉。汝之行愿思惟究竟。今正是时为众解说。时诸菩萨。闻是法已得大善利。能于佛刹修习庄严

尔时作法苾刍。闻佛圣旨。偏袒右肩右膝着地。合掌向佛即为宣说。世尊。我发誓言。愿如世尊证得阿耨多罗三藐三菩提。所居佛刹。具足无量不可思议功德庄严。所有一切众生。及焰摩罗界。三恶道中地狱饿鬼畜生。皆生我刹受我法化。不久悉成阿耨多罗三藐三菩提。一切皆得身真金色

世尊。我得菩提成正觉已。十方世界所有众生。令生我刹如诸佛土。人天之众。远离分别诸根寂静。悉皆令得阿罗多罗三藐三菩提。世尊。我得菩提成正觉已。十方世界所有众生。令生我刹得大神通。经一念中周遍巡历百千俱胝那由他佛刹。供养诸佛深植善本。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。一切皆得宿命通。能善观察百千俱胝那由他劫过去之事。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提。成正觉已。所有众生令生我刹。一切皆得清净天眼。能见百千俱胝那由他世界粗细色相。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。一切皆得他心通。善能了知百千俱胝那由他众心心所法。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。一切皆得住正信位。离颠倒想坚固修习。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。所修正行善根无量。遍圆寂界而无间断。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。虽住声闻缘觉之位。往百千俱胝那由他宝刹之内。遍作佛事。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。一切皆得无边光明。而能照曜百千俱胝那由他诸佛刹土。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。命不中夭。寿百千俱胝那由他劫。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。无不善名。闻无量无数诸佛刹土。无名无号无相无形。无所称赞。而无疑谤身心不动。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生求生我刹。念吾名号发志诚心坚固不退。彼命终时。我令无数苾刍现前围绕来迎彼人。经须臾间得生我刹。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方无量无边。无数世界一切众生。闻吾名号发菩提心。种诸善根随意求生。诸佛刹土无不得生。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。皆具三十二种大丈夫相。一生令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。若有大愿未欲成佛为菩萨者。我以威力。令彼教化一切众生。皆发信心。修菩提行。普贤行。寂灭行。净梵行最胜行。及一切善行。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生令生我刹。于一切处承事供养无量百千俱胝那由他诸佛。种诸善根。随意所求无不满愿。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我刹土中所有菩萨。皆得成就一切智慧。善谈诸法秘要之义。不久速成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。发勇猛心运大神通。往无量无边无数世界诸佛刹中。以真珠璎珞。宝盖幢幡。衣服卧具。饮食汤药。香华伎乐。供养承事回求菩提。速得成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。发大道心。欲以真珠璎珞。宝盖幢幡衣服卧具。饮食汤药。香华伎乐。承事供养他方世界无量无边诸佛世尊。而不能往。我于尔时以宿愿力。令彼他方诸佛世尊。各舒手臂至我刹中受是供养。令彼速成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。随自意乐不离此界。欲以真珠璎珞。宝盖幢幡。衣服卧具。饮食汤药。香华伎乐。供养他方无量诸佛。又复思惟。如佛展臂至此受供。劬劳诸佛令我无益。作是念时。我以神力。令此供具自至他方诸佛面前。一一供养。尔时菩萨。不久悉成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。身长十六由旬。得那罗延力。身相端严光明照曜。善根具足。成就阿耨多罗三藐三菩提。世尊我得菩提成正觉已。我居宝刹所有菩萨。为诸众生通达法藏。安立无边一切智慧断尽诸结悉得证成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。以百千俱胝那由他种种珍宝造作香炉。下从地际上至空界。常以无价栴檀之香。普薰供养十方诸佛。令得速成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所居佛刹广博严净光莹如镜。悉能照见无量无边一切佛刹。众生睹者生希有心。不久速成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。我居宝刹所有菩萨。昼夜六时恒受快乐。过于诸天。入平等总持门。身光普照无边世界。不久得成阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方无量无边。无数世界一切女人。若有厌离女身者。闻我名号发清净心归依顶礼。彼人命终即生我刹成男子身。悉皆令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方无量无边。无数佛刹声闻缘觉。闻我名号修持净戒。坚固不退速坐道场。成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方无量无边。不可思议无等佛刹一切菩萨。闻我名号五体投地礼拜归命。复得天上人间一切有情。尊重恭敬亲近侍奉增益功德。成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有众生发净信心。为诸沙门婆罗门。染衣洗衣裁衣缝衣修作僧服。或自手作或使人作。作已回向。是人所感。八十一生得最上衣随身丰足。于最后身来生我刹。成就阿耨多罗三藐三菩提

佛说大乘无量寿庄严经卷上佛说大乘无量寿庄严经卷中

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

尔时作法苾刍白世尊言。我得菩提成正觉已。所有一切众生。闻我名号永离热恼心得清凉。行正信行得生我刹。坐宝树下证无生忍。成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方一切佛刹诸菩萨众。闻我名号应时证得寂静三摩地。住是定已。于一念中。得见无量无边不可思议诸佛世尊。承事供养。成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方一切佛刹声闻菩萨。闻我名号证无生忍。成就一切平等善根。住无功用离加行故。不久令得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方一切佛刹诸菩萨众。闻我名已生希有心。是人即得普遍菩萨三摩地。住此定已。于一念中。得至无量无数不可思议诸佛刹中。恭敬尊重供养诸佛。成就阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。于我刹中所有菩萨。或乐说法或乐听法。或现神足或往他方。随意修习无不圆满。皆令证得阿耨多罗三藐三菩提。世尊。我得菩提成正觉已。所有十方一切佛刹闻我名者。应时即得初忍二忍乃至无生法忍。成就阿耨多罗三藐三菩提。尔时作法苾刍。向彼佛前发如是愿已。承佛威神即说颂曰

  我今对佛前　　而发诚实愿
  获佛十力身　　威德无等等
  复为大国王　　富豪而自在
  广以诸财宝　　普施于贫苦
  令彼诸群生　　长夜无忧恼
  出生众善根　　成就菩提果
  我若成正觉　　立名无量寿
  众生闻此号　　俱来我刹中
  如佛金色身　　妙相悉圆满
  亦以大慈心　　利益诸群品
  愿我智慧光　　广照十方刹
  除灭诸有情　　贪嗔烦恼闇
  地狱鬼畜生　　悉舍三涂苦
  亦生我刹中　　修习清净行
  获彼光明身　　如佛普照曜
  日月珠宝光　　其明不可比
  愿我未来世　　常作天人师
  百亿世界中　　而作师子吼
  如彼过去佛　　所行慈愍行
  广无量无边　　俱胝诸有情
  圆满昔所愿　　一切皆成佛
  发是大愿时　　三千大千界
  震动遍十方　　天人空界中
  散雨一切花　　栴檀及沉水
  称赞大苾刍　　愿力甚希有
  决定当作佛　　广利众生界

复次阿难。时作法苾刍。对世自在王如来。及天人魔梵沙门婆罗门阿修罗等。发是愿已住真实慧。勇猛精进。修习无量功德。庄严佛刹入三摩地。历大阿僧祇劫。修菩萨行。不生悭贪心嗔恚心愚痴心。亦无欲想嗔想痴想色声香味触想。心不迷乱。口不喑哑。身不懈怠。但乐忆念过去诸佛所修善根行寂静行。远离虚妄坚守律仪。常以爱语饶益众生。于佛法僧信重恭敬调顺柔软。依真谛门植众德本。了空无相无愿无为无生无灭。善护口业不讥他过。善护身业不失律仪。善护意业清净无染。所有国城聚落。男女奴眷属。金银珍宝。乃至色声香味触等。都无所著。恒以布施持戒忍辱精进禅定智慧六度之行。利乐众生。轨范具足善根圆满。所生之处。有无量无数百千俱胝那由他珍宝之藏。从地涌出。摄受无量无数百千俱胝那由他众生。发阿耨多罗三藐三菩提心。如是之行无量无边说不能尽。复次阿难。作法苾刍行菩萨行时。于诸佛所尊重恭敬。承事供养未曾间断。为四大天王恒诣佛所。恭敬礼拜承事供养。为忉利天王恒诣佛所。恭敬礼拜承事供养。为夜摩天王。兜率天王。化乐天王。他化自在天王。乃至大梵天王等。恒诣佛所。恭敬礼拜承事供养。复次阿难。处阎浮提。为转轮王受灌顶位。及大臣官族等。恒诣佛所。恭敬礼拜承事供养。为刹帝利婆罗门等。恒诣佛所。恭敬礼拜承事供养。如是经无量无数百千万亿劫。亲近诸佛植众德本。所集阿耨多罗三藐三菩提

复次阿难。作法苾刍行菩萨行时。口中常出栴檀之香。身诸毛孔出优钵罗华香。其香普薰无量无边不可思议那由他百千由旬。有情闻此香者。皆发阿耨多罗三藐三菩提心。复次阿难。作法苾刍行菩萨行时。色相端严。三十二相八十种好。悉皆具足。复以一切珍宝庄严两臂。手中恒出一切衣服。一切饮食。一切幢幡。一切伞盖。一切音乐。乃至一切最上所须之物。利乐一切众生。令发阿耨多罗三藐三菩提心

尔时阿难。闻佛说彼作法苾刍菩萨之行。白世尊言。作法苾刍。为是过去佛耶。未来佛耶。现在佛耶。世尊告言。彼佛如来。来无所来。去无所去。无生无灭。非过现未来。但以酬愿度生。现在西方。去阎浮提百千俱胝那由他佛刹。有世界名曰极乐。佛名无量寿。成佛已来于今十劫。有无量无数菩萨摩诃萨。及无量无数声闻之众。恭敬围绕而为说法。彼佛光明。照于东方恒河沙数百千俱胝那由他不可称量佛刹。如是南西北方四维上下。亦复如是。复次阿难彼佛无量寿。若化圆光。或一由旬二由旬三由旬。或百由旬千由旬百千由旬。或俱胝那由他百千由旬。乃至遍满无量无边无数佛刹。复次阿难。今此光明名无量光。无碍光。常照光。不空光。利益光。爱乐光。安隐光。解脱光。无等光。不思议光。过日月光。夺一切世间光。无垢清净光。如是光明。普照十方一切世界。天龙药叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。见此光明发菩提心获利乐故。佛告阿难。我住一劫。说此光明功德利益。亦不能尽。复次阿难。无量寿如来。有如是百千万十万百万。一俱胝百俱胝千俱胝。紧迦啰数。频婆啰数。那由他数。阿由他数。毗婆诃数。嚩娑那数。穰伽数。阿僧祇数。十阿僧祇数。百阿僧祇数。千阿僧祇数。百千阿僧祇数。阿摩儞野数。不可思议数。如是无量无数声闻之众。譬喻算数数不能及。阿难。彼大目干连神通第一。三千大千世界所有一切童男童女。于一昼夜悉知其数。假使百千俱胝声闻神通之力。皆如大目干连。又一一声闻。寿百千俱胝那由他岁。尽其寿命数。彼声闻百分之中。不及一分。复次阿难。譬如大海。深八万四千由旬。广阔无边。假使有人出身一毛。碎为百俱胝细如微尘。以一一尘投海出水。水在尘上形量亦尔。如是投尽毛尘。于意云何。毛尘水多海中水多。阿难白佛言。世尊。毛尘出水未及半合。海水无量。佛言阿难。彼目干连等声闻之众。尽其形寿。数知数者如毛尘之水。数未尽者如海中水。如是彼佛。有如是无量不可算数声闻弟子。又彼佛国土大富无量。唯受快乐无有众苦。无地狱饿鬼畜生焰魔罗界及八难之报。唯有清净菩萨摩诃萨及声闻之众复次阿难。彼佛国土。有种种宝柱。皆以百千珍宝。而用庄严。所谓金柱银柱。琉璃柱。颇梨柱。真珠柱。砗磲柱。玛瑙柱。复有金银二宝柱。金银琉璃三宝柱。金银琉璃颇梨四宝柱。金银琉璃颇梨真珠五宝柱。金银琉璃颇梨真珠砗磲六宝柱。金银琉璃颇梨真珠砗磲玛瑙七宝柱。复次阿难。彼佛国土。复有种种宝树。根茎枝干黄金所成。华叶果实白银化作。亦有宝树。根茎枝干白银所成。花叶果实琉璃化作。亦有宝树。根茎枝干琉璃所成。华叶果实颇梨化作。亦有宝树。根茎枝叶颇梨所成。华叶果实真珠化作。亦有宝树。根茎枝干真珠所成。华叶果实砗磲化作。亦有宝树。根茎枝干砗磲所成。花叶果实璃瑙化作。亦有宝树。根茎枝干玛瑙所成。花叶果实黄金化作。亦有宝树。黄金为根。白银为身。琉璃为枝。颇梨为梢。真珠为叶。砗磲为花。玛瑙为果。亦有宝树。白银为根。琉璃为身。颇梨为枝。真珠为梢。砗磲为叶。玛瑙为花。黄金为果。亦有宝树。琉璃为根。颇梨为身。真珠为枝。砗磲为梢。玛瑙为叶。黄金为花。白银为果。亦有宝树。颇梨为根。真珠为身。砗磲为枝。玛瑙为梢。黄金为叶。白银为花。琉璃为果。亦有宝树。真珠为根。砗磲为身。玛瑙为枝。黄金为梢。白银为叶。琉璃为花。颇梨为果。亦有宝树。砗磲为根。玛瑙为身。黄金为枝。白银为梢。琉璃为叶。颇梨为花。真珠为果。亦有宝树。玛瑙为根。黄金为身。白银为枝。琉璃为梢。颇梨为叶。真珠为花。砗磲为果。如是极乐世界。七宝行树。复次阿难。彼佛国土清净严饰宽广平正。无有丘陵坑坎荆棘沙砾土石等山。黑山雪山宝山金山须弥山铁围山大铁围山。唯以黄金为地

尔时阿难。闻是语已。白世尊言。四大王天忉利天。依须弥山王住。夜摩天等当依何住。佛告阿难。夜摩兜率乃至色无色界一切诸天。皆依空界而住。阿难白言。空界无碍云何依住。业因果报不可思议。佛告阿难。汝身果报亦不可思议。众生业报亦不可思议。诸佛圣力不可思议。彼佛国土虽无大海。而有泉河处处交流。其水或阔十由旬。二十由旬。三十由旬。乃至百千由旬。深十二由旬。其水清净具八功德出微妙声。譬如百千万种音乐之声。遍诸佛刹。一切众生闻者适悦得大快乐。又水两岸。复有无数栴檀香树。吉祥果树。花卉恒芳光明照耀。若彼众生过此水时。要至足者。要至膝者。乃至要至项者。或要冷者温者。急流者慢流者。其水一一随众生意令受快乐。又于水中出种种声。佛声法声僧声。止息声无性声波罗蜜声。力声无畏声。通达声。无行声。无生声。无灭声。寂静声。大慈声。大悲声。喜舍声。灌顶声。出如是种种微妙音声。众生闻已发清净心无诸分别。正直平等成熟善根。永不退于阿耨多罗三藐三菩提心。又彼佛刹其中生者。不闻地狱声。饿鬼声。畜生声。夜叉声。斗诤声。恶口声。两舌声。杀生声。偷盗声。一切恶声。而彼众生。色相端严福德无量。智慧明了神通自在。宫殿楼阁。园林池沼。衣服卧具。如他化自在天。最上快乐之具。一切丰足。复次阿难。彼土众生。思香花等欲供诸佛。作是念时。花香璎珞。涂香末香。幢幡伞盖。及诸伎乐。随意即至满佛刹中。若思饮食汤药。衣服卧具。头冠耳环。真珠罗网等。随念即至亦遍佛刹。又复思念摩尼宝等。庄严宫殿楼阁堂宇房合。或大或小或高或下。如是念时。随意现前无不具足

复次阿难。譬如有人少有财宝。对受灌顶位刹帝利王所有威势悉皆不现。又刹帝利对天帝释前。所有威势悉皆不现。又天帝释对他化自在天。所有威势悉皆不现。又他化自在天等。及色无色界一切威势。对无量寿如来极乐国土。悉皆不现。如是彼土功德庄严不可思议

复次阿难。彼佛国土每于食时。香风自起吹动宝树。树相掁触出微妙音。演说苦空无常无我诸波罗蜜。复吹树花落于地上。周遍佛刹高七人量。平正庄严柔软光洁。行人往来足蹑其地深四指量。如迦邻那触身安乐。过食时后。是诸宝花隐地不现。经须臾间复有风生。吹树落花布地面上。如前无异。初夜后夜亦复如是

复次阿难。彼佛国土无其黑闇。无其星曜。无其日月。无其昼夜。无其取舍。无其分别。纯一无杂。唯受清净最上快乐。若有善男子善女人。若已生若当生。是人决定证于阿耨多罗三藐三菩提。于意云何。彼佛刹中无三种失。一心无虚妄。二位无退转。三善无唐捐

复次阿难。东方有恒河沙数世界。诸佛如来出广长舌相。放无量光说诚实言。称赞无量寿佛不可思议功德。南方亦有恒河沙数世界。诸佛如来出广长舌相。放无量光说诚实言。称赞无量寿佛不可思议功德。西方亦有恒河沙数世界。诸佛如来出广长舌相。放无量光说诚实言。称赞无量寿佛不可思议功德。北方亦有恒河沙数世界。诸佛如来出广长舌相。放无量光说诚实言。称赞无量寿佛不可思议功德。如是四维上下。恒河沙数世界。诸佛如来出广长舌相。放无量光说诚实言。称赞无量寿佛不可思议功德。阿难。于意云何。欲令众生闻彼佛名。发清净心忆念受持。归依供养求生彼土。是人命终。皆得往生极乐世界。不退转于阿耨多罗三藐三菩提

复次阿难。若有善男子善女人。闻此经典受持读诵书写供养。昼夜相续求生彼刹。是人临终。无量寿如来与诸圣众现在其前。经须臾间。即得往生极乐世界。不退转于阿耨多罗三藐三菩提

复次阿难。若有善男子善女人。发菩提心已。持诸禁戒坚守不犯。饶益有情。所作善根悉施与之。令得安乐。忆念西方无量寿如来及彼国土。是人命终。如佛色相种种庄严。生宝刹中贤圣围绕。速得闻法永不退转于阿耨多罗三藐三菩提

复次阿难。若有善男子善女人。发十种心。所谓一不偷盗。二不杀生。三不淫欲。四不妄言。五不绮语。六不恶口。七不两舌。八不贪。九不嗔。十不痴。如是昼夜思惟极乐世界无量寿佛。种种功德种种庄严。志心归依顶礼供养。是人临终。不惊不怖心不颠倒。即得往生彼佛国土。有无量无数诸佛世尊。称赞无量寿佛功德名号。闻是法已。永不退于阿耨多罗三藐三菩提

佛说大乘无量寿庄严经卷中佛说大乘无量寿庄严经卷下

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

复次阿难。东方恒河沙数佛刹。一一刹中。有无量无数菩萨摩诃萨。及无量无数声闻之众。以诸香花幢幡宝盖。持用供养极乐世界无量寿佛。南方恒河沙数佛刹。一一刹中。亦有无量无数菩萨摩诃萨。及无量无数声闻之众。以诸香花幢幡宝盖。持用供养极乐世界无量寿佛。西方恒河沙数世界。一一佛刹。亦有无量无数菩萨摩诃萨。及无量无数声闻之众。以诸香花幢幡宝盖。持用供养极乐世界无量寿佛。北方恒河沙数佛刹。一一佛刹。亦有无量无数菩萨摩诃萨。及无量无数声闻之众。以诸香花幢幡宝盖。持用供养极乐世界无量寿佛。四维上下亦复如是。各礼佛足。称赞佛土功德庄严。尔时世尊即说颂曰

  东方世界恒河沙　　一一刹中无数量
  菩萨声闻发胜心　　各以香花宝盖等
  持至庄严佛刹中　　供养如来无量寿
  供已礼足而称赞　　最上希有大福田
  如是西南及北方　　四维上下恒沙界
  声闻菩萨数亦然　　皆以香花伸供养
  礼足旋绕怀敬爱　　复赞如来宿愿深
  积集功德普庄严　　无量无边极乐国
  诸佛国界虽严饰　　难比如来宝刹中
  复以天花供养佛　　花散虚空为伞盖
  纵广量等百由旬　　色相庄严无有比
  遍覆如来宝刹中　　互相庆慰生欢喜
  曾于过去百千劫　　积集无量众善根
  舍彼轮回三有身　　令至解脱清净刹
  尔时彼佛无量寿　　化导他方菩萨心
  密用神通化大光　　其光从彼面门出
  三十六亿那由他　　普照俱胝千佛刹
  如是人天普照已　　即入如来顶髻中
  时会一切诸众生　　敬叹佛光未曾有
  各各俱发菩提心　　愿出尘劳登彼岸

尔时世尊。说此偈已。会中有观自在菩萨。即从座起合掌向佛。而作是言。世尊。以何因缘。无量寿佛于其面门。放无量光照诸佛刹。唯愿世尊方便解说。令诸众生及他方菩萨。闻是语已生希有心。于佛菩提志乐趣求入不退位

尔时世尊告观自在菩萨言。汝今谛听吾为汝说。彼佛如来。于过去无量无边阿僧祇劫前。为菩萨时发大誓言。我于未来成正觉时。若有十方世界无量众生。闻我名号或顶礼忆念。或称赞归依。或香花供养等。如是众生速生我刹。见此光明即得解脱。若诸菩萨见此光明即得受记证不退位。手持香花及诸供具。往十方界无边净刹。供养诸佛而作佛事增益功德。经须臾间复还本土受诸快乐。是故光明而入佛顶

复次阿难。无量寿佛应正等觉。所有菩提之树。高一千六百由旬。四布枝叶八百由旬。根入土际五百由旬花果敷荣。作无量百千珍宝之色。于其树上。复以月光摩尼宝。帝释摩尼宝。如意摩尼宝。持海摩尼宝。大绿宝。莎悉帝迦宝。爱宝璎珞。大绿宝璎珞。红真珠璎珞。青真珠璎珞。及金银宝网等种种庄严

复次阿难。每于辰时香风自起吹此宝树。树相敦触出微妙音。其声普闻无量世界。众生闻者无其耳病。乃至成就阿耨多罗三藐三菩提。若有众生见此树者。乃至成佛。于其中间不生眼病。若有众生闻树香者。乃至成佛。于其中间不生鼻病。若有众生食树果者。乃至成佛。于其中间舌亦无病。若有众生树光照者。乃至成佛。于其中间身亦无病。若有众生观想树者。乃至成佛。于其中间心得清净。远离贪等烦恼之病。佛告阿难。如是佛刹花果树木。与诸众生而作佛事。皆是彼佛过去大愿之所摄受

复次阿难。彼佛刹中所有现在及未来生。一切菩萨摩诃萨。一生令得阿耨多罗三藐三菩提。若有菩萨。以宿愿故入生死界。作师子吼利益有情。我令随意而作佛事

复次阿难。彼佛刹中。一切菩萨及诸声闻。身相端严圆光炽盛。周回照耀百千由旬。有二菩萨。身光远照三千大千世界。阿难白言。此二菩萨有大身光。其名云何。佛告阿难。二菩萨者。一名观自在。二名大精进。现居此界作大利乐。命终之后当生彼国

复次阿难。彼佛刹中一切菩萨。容貌柔和相好具足。禅定智慧通达无碍。神通威德无不圆满。深入法门得无生忍。诸佛秘藏究竟明了。调伏诸根身心柔软。安住寂静大乘涅盘。深入正慧无复余习。依佛所行七觉圣道。修行五眼照真达俗。辩才总持自在无碍。善解世间无边方便。所言诚谛深入义味。度诸有情演说正法。三界平等离诸分别。无相无为无因无果。无取无舍无缚无脱。远离颠倒坚固不动如须弥山。智慧明了如日月朗。广大如海出功德宝。炽盛如火烧烦恼薪。忍辱如地一切平等。清净如水洗诸尘垢。如虚空无边。不障一切故。如莲花出水。离一切染故。如雷震响。出法音故。如云叆叇。降法雨故。如风动树。发菩提芽故。如牛王声。异众牛故。如龙象威。难可测故。如良马行。乘无失故。如师子坐。离怖畏故。如尼拘树。覆荫大故。如须弥山。八风不动故。如金刚杵。破邪山故。如梵王身。生梵众故。如金翅鸟。食毒龙故。如空中禽。无住处故。如慈氏观。法界等故。如是菩萨遍满佛刹。吹法螺。竖法幢。击法鼓。然法灯。离过清净无迷无失。手中出生花鬘璎珞涂香粖香一切供具。持往百千俱胝那由他佛刹。供养诸佛。复于手中别出宝花。散虚空中化成宝盖广十由旬。或二十由旬。乃至百千由旬。遍诸佛刹。经须臾间还来本国。无爱无著。无取无舍。身心寂静

佛告阿难。此诸菩萨。我土五浊之所无有。经百千俱胝劫说不能尽

佛告阿难。吾今此土。所有菩萨摩诃萨。已曾供养无量诸佛植众德本。命终之后。皆得生于极乐世界。阿难。汝起合掌面西顶礼。尔时阿难。即从座起合掌面西。顶礼之间忽然得见极乐世界无量寿佛。容颜广大色相端严如黄金山。又闻十方世界诸佛如来。称扬赞叹无量寿佛种种功德。阿难白言。彼佛净刹得未曾有。我亦愿乐生于彼土。世尊告言。其中生者菩萨摩诃萨。已曾亲近无量诸佛植众德本。汝欲生彼。应当一心归依瞻仰。作是语时。无量寿佛于手掌中。放无量光照于东方百千俱胝那由他佛刹。于此世界。所有黑山雪山。金山宝山。目真邻陀山。摩诃目真邻陀山。须弥山。铁围山。大铁围山。大海江河丛林树木。及天人宫殿。一切境界无不照见。譬如日出明照世间。亦复如是。尔时会中。苾刍苾刍尼优婆塞优婆夷。天龙药叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆见极乐世界种种庄严。及见无量寿如来。声闻菩萨围绕恭敬。譬如须弥山王出于大海。尔时极乐世界。过于西方百千俱胝那由他国。以佛威力如对目前。又见彼土清净平正。譬如海面无有丘陵山崄草木杂秽。唯是众宝庄严。圣贤共住

复次阿难。又彼无量寿佛。与诸菩萨声闻之众。亦皆得见我身及娑婆世界菩萨声闻。人天之众

尔时世尊。告慈氏菩萨言。汝见极乐世界功德庄严宫殿楼阁园林台观流泉浴池不。慈氏汝见欲界诸天。上至色究竟天。雨种种香花遍满佛刹。作庄严不。汝见菩萨声闻净行之众。而作佛声演说妙法。一切佛刹皆得闻声。获利乐不。汝见百千俱胝众生。游处虚空宫殿随身不。慈氏菩萨白佛言。世尊。如佛所说一一皆见。慈氏白言。云何此界一类众生。虽亦修善而不求生。佛告慈氏。此等众生智慧微浅。分别西方不及天界。是以非乐不求生彼。慈氏白言。此等众生虚妄分别。不求佛刹何免轮回。佛言慈氏。极乐国中有胎生不。慈氏白言。不也世尊。其中生者。譬如欲界诸天。居五百由旬宫殿。自在游戏。何有胎生。世尊。此界众生。何因何缘而处胎生。佛言慈氏。此等众生。所种善根不能离相。不求佛慧妄生分别。深着世乐人间福报是故胎生。若有众生。以无相智慧植众德本。身心清净远离分别。求生净刹趣佛菩提。是人命终。刹那之间于佛净土坐宝莲花身相具足。何有胎生。慈氏汝见愚痴之人不种善根。但以世智聪辩。妄生分别增益邪心。云何出离生死大难。复有众生。虽种善根供养三宝作大福田。取相分别情执深重。求出轮回终不能得。佛告慈氏。譬如受灌顶位刹帝利王。置一大狱。于其狱内。安置殿堂楼阁钩栏窗牖床榻座具。皆以珍宝严饰所须衣服饮食无不丰足。尔时灌顶王。驱逐太子禁闭狱中。复与钱财珍宝罗纨匹帛。恣意受用

佛告慈氏。于意云何。彼太子得快乐不。慈氏白言。不也世尊。彼中虽有堂殿楼阁饮食衣服钱帛金宝随意受用。身闭牢狱心不自在。唯求出离。佛告慈氏。若灌顶王不舍其过。彼诸大臣长者居士等。可令太子免禁狱不。慈氏白言。王既不舍云何得出。佛言。如是如是。彼诸众生。虽复修福供养三宝。虚妄分别求人天果。得报之时。所居器界宫殿楼阁。衣服卧具饮食汤药。一切所须悉皆丰足。而未能出三界狱中。常处轮回而不自在。假使父母妻子男女眷属欲相救免。终不能出邪见业。王无能舍离。若诸众生断妄分别。植诸善本无相无著。当生佛刹永得解脱。慈氏菩萨白佛言。世尊。今此娑婆世界及诸佛刹。有几多菩萨摩诃萨。得生极乐世界。见无量寿佛。成就阿耨多罗三藐三菩提

佛言慈氏。我此娑婆世界。有七十二俱胝那由他菩萨摩诃萨。已曾供养无量诸佛植众德本。当生彼国亲近供养无量寿佛。成就阿耨多罗三藐三菩提

复次阿难。难忍佛刹。有十八俱胝那由他菩萨摩诃萨。生彼国土。宝藏佛刹。有九十俱胝那由他菩萨摩诃萨。生彼国土。火光佛刹。有二十二俱胝那由他菩萨摩诃萨。生彼国土。无量光佛刹。有二十五俱胝那由他菩萨摩诃萨。生彼国土。世灯佛刹。有六十俱胝那由他菩萨摩诃萨。生彼国土。龙树佛刹。有一千四百菩萨摩诃萨。生彼国土。无垢光佛刹。有二十五俱胝那由他菩萨摩诃萨。生彼国土。师子佛刹。有一千八百菩萨摩诃萨。生彼国土。吉祥峰佛刹。有二千一百俱胝那由他菩萨摩诃萨。生彼国土。仁王佛刹。有一千俱胝那由他菩萨摩诃萨。生彼国土。花幢佛刹。有一俱胝菩萨摩诃萨。生彼国土。光明王佛刹。有十二俱胝菩萨摩诃萨。生彼国土。得无畏佛刹。有六十九俱胝那由他菩萨摩诃萨。生彼国土。悉皆亲近供养无量寿佛。不久当成阿耨多罗三藐三菩提。佛言慈氏。如是功德庄严极乐国土。满彼算数无量之劫。说不能尽。若有善男子善女人。得闻无量寿佛名号。发一念信心。归依瞻礼。当知此人非是小乘。于我法中得名第一弟子

佛告慈氏。若有苾刍苾刍尼优婆塞优婆夷天龙药叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。于此经典书写供养受持读诵。为他演说。乃至于一昼夜。思惟彼刹及佛身功德。此人命终速得生彼。成就阿耨多罗三藐三菩提

复次慈氏。今此经典甚深微妙广利众生。若有众生。于此正法受持读诵书写供养。彼人临终。假使三千大千世界满中大火。亦能超过生彼国土。是人已曾值过去佛受菩提记。一切如来同所称赞。无上菩提随意成就。佛言慈氏。佛世难值正法难闻。如来所行亦应随行。于此经典作大守护。为诸有情长夜利益。莫令众生堕在五趣庄严狱中。令诸有情种修福善求生净刹。尔时世尊而说颂曰

  若不往昔修福慧　　于此正法不能闻
  已曾供养诸如来　　是故汝等闻斯义
  闻已受持及书写　　读诵赞演并供养
  如是一心求净方　　决定往生极乐国
  假使大火满三千　　及彼庄严诸牢狱
  如是诸难悉能超　　皆是如来威德力
  彼佛利乐诸功德　　唯佛与佛乃能知
  声闻缘觉满世间　　尽其神力莫能测
  假使长寿诸有情　　命住无数俱胝劫
  称赞如来功德身　　尽其形寿赞无尽
  大圣法王所说法　　利益一切诸群生
  若有受持恭敬者　　佛说此人真善友

尔时世尊。说此法时。有十二俱胝那由他人。远尘离垢得法眼净。八百苾刍。漏尽意解心得解脱。天人众中。有二十二俱胝那由他人。证阿那含果。复有二十五俱胝人。得法忍不退。复有四十俱胝百千那由他人。发阿耨多罗三藐三菩提心。种诸善根皆愿往生极乐世界见无量寿佛。复有十方佛刹。若现在生及未来生。见无量寿佛者。各有八万俱胝那由他人。得然灯佛记。名妙音如来。当得阿耨多罗三藐三菩提。彼诸有情。皆是无量寿佛宿愿因缘。俱得往生极乐世界。佛说是语时。三千大千世界六种震动。雨诸香花积至于膝。复有诸天于虚空中。作妙音乐出随喜声。乃至色界诸天。悉皆得闻叹未曾有。尔时尊者阿难及慈氏菩萨等。并天龙八部一切大众。闻佛所说皆大欢喜信受奉行

佛说大乘无量寿庄严经卷下


佛说大方广善巧方便经卷第一

    No. 346 [Nos. 310(38), 345]

佛说大方广善巧方便经卷第一

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。与大苾刍众八千人。菩萨一万六千人俱。是诸菩萨智慧方便神通具足。辩才无碍得大总持

尔时世尊处大法座。与如是等无数百千大众。恭敬围绕听受说法。彼时会中有一菩萨摩诃萨名曰智上。从座而起偏袒右肩。右膝着地礼佛双足。礼已合掌前白佛言。世尊。我有少法欲伸请问。如来应供正等正觉。非愍我故愿赐听许。佛告智上菩萨摩诃萨言。善男子。恣汝所问今正是时。诸佛如来随有问者。各各为其如应演说。令彼闻已心生欢喜。时智上菩萨摩诃萨。即白佛言。世尊。云何是菩萨摩诃萨善巧方便。愿佛世尊广分别说。佛告智上菩萨摩诃萨言。善男子。汝今当知。具善巧方便菩萨摩诃萨。以一方便普令一切众生如理修行。何以故。具善巧方便菩萨摩诃萨。乃至于彼傍生异类诸恶趣中。菩萨亦以平等一切智心。施其方便。即以如是善根。回向一切众生。令诸众生修行二法。何等为二。所谓一切智心回向心。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。于诸众生所有善根。不念破坏。常所爱乐生随喜心。即以如是随喜善根。回向一切众生。复以一切智心。广施一切众生。虽起施心。悉无所取。亦无所得。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。若时往彼十方世界。乃至一切方处。或见一切微妙可爱香树华树。菩萨见已不生一念希取之心。作是思惟。此香树华树非我所取。当献十方一切诸佛。即以如是善根。回向一切智。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。随所向处。或见一切众生受诸快乐。菩萨尔时生随喜心。即以如是随喜善根。回向一切智。又若菩萨随所向处。或见一切众生受诸苦恼。菩萨尔时起悲愍心。被精进铠即作是言。一切众生所有苦恼我当代受。普愿众生得安隐乐。即以如是善根。回向无上菩提。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。随诸方处若礼一佛如来。即同礼彼诸佛如来。何以故。诸佛如来同一法性。同一戒品定品慧品解脱品解脱知见品。亦复同一最上心意。菩萨如是了知已。乃至恭敬供养一佛如来。即同恭敬供养诸佛如来。菩萨以广大心普摄一切。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。或时见有修大乘者于大乘法生退没心。菩萨尔时知彼心已即作是念。我应为彼称赞一四句偈。令彼如是如理修学使不退没。念已即言。诸有修大乘者。若能于此一四句偈。解了其义。即能于彼一切语言。通达义趣。如所解了不生退没。又复我此所说一四句偈。若有能听受者。是人即得诸佛辩才。我当以是善根。普施一切众生。悉愿得彼多闻具足。诸佛无碍辩才所摄。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。或时往彼贫穷乞丐人所。菩萨尔时心生悲愍。即自念言。他业所作受决定报。我今于此欢喜和合。随其所欲而悉施与。如佛所说。于一施中有四行相。所谓施大心大等。今我此中所施虽少。一切智心而复无量。若我以是一切智心施此乞人。即以如是善根力故。当以宝手常出珍宝。普施一切众生。如是布施此乞丐人。乃能与彼现在佛世尊所布施持戒修禅定者。所作福行等无有异。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。若时与彼声闻缘觉同所居止。菩萨尔时于彼二乘但生恭敬。若彼声闻缘觉。或以二事而生我相。何等为二。一者菩萨出生诸佛世尊。二者诸佛出生声闻缘觉。彼以是事而自念言。我于此中是为最上。何能于彼生恭敬心。而此菩萨虽闻是说。以方便故心无异想。善男子。如是名为菩萨摩诃萨善巧方便

复次善男子。具善巧方便菩萨摩诃萨。能于一施行中。成就六波罗蜜多。是相云何。所谓菩萨随诸方处见来求者。菩萨尔时摄伏悭心。随其所欲而悉施与。此即名为菩萨成就布施波罗蜜多。如是施时。菩萨自持戒行。复能摄彼诸破戒者。普令安住清净戒地。此即名为菩萨成就持戒波罗蜜多。如是施时。菩萨以其慈心为首。复起不破坏心救护心等住心。起是心时。此即名为菩萨成就忍辱波罗蜜多。如是施时。若饮若食及诸所欲随其所施。菩萨来去住止。于身语心位不生懈倦。此即名为菩萨成就精进波罗蜜多。如是施时。随所施处。菩萨心住一境不起散乱。此即名为菩萨成就禅定波罗蜜多。如是施时。菩萨悉知如是施者如是受者得何果报。如是知已。称量较计皆悉平等。是中无有少法可得。此即名为菩萨成就智慧波罗蜜多。善男子。如是名为善巧方便菩萨摩诃萨。于一施行中成就六波罗蜜多

尔时智上菩萨摩诃萨复白佛言。希有世尊。菩萨摩诃萨布施行中。乃有如是善巧方便。以是方便。而能解脱一切众生轮回苦恼。普摄一切诸佛法藏。佛言智上。如汝所说如是如是。诸菩萨摩诃萨具善巧方便故。而能于其一施行中成就无量利益胜行。尔时世尊。复告智上菩萨摩诃萨言。善男子。汝今当知。具善巧方便菩萨摩诃萨。设于异时有极重罪。而彼菩萨亦不坏善根。云何不坏。所谓菩萨或时值遇彼恶知识。劝令退失无上道意得极重罪。菩萨尔时即自思惟。我今若或即于此身。取证涅盘断后边际。不复堪任被精进铠。何能度脱一切众生轮回苦恼。我今不应以此因缘自坏其心。何以故。我欲于轮回中度脱一切众生。设有极重罪亦不断善根。善男子。如是名为菩萨摩诃萨善巧方便。又善男子。若出家菩萨有分别心生别异作意。彼所得罪过四根本。是菩萨若具善巧方便者随起即悔。善男子。我说彼菩萨为无罪者。

尔时智上菩萨摩诃萨白佛言。世尊。云何菩萨亦有罪耶。佛告智上菩萨摩诃萨言。善男子。若言菩萨无有罪者。云何菩萨于百千劫中。学波罗提木叉戒。有破根本果者。善男子。汝今当知。是等菩萨虽于一切众生善言恶言皆悉能忍。但为于彼声闻缘觉法中相应作意。是故我说彼所得罪过四根本。如彼声闻乘人犯根本罪已。无所堪任取证涅盘。出家菩萨亦复如是。起是罪已不即悔舍。声闻缘觉相应作意。亦复无所堪任。不能趣证大涅盘界

尔时尊者阿难。在大会中前白佛言。世尊。舍卫大城有一菩萨名光聚王。我于一时入城乞食。于其城中不见彼菩萨。是时光聚王菩萨别在一聚落中。与一女人同坐一处说非法语。我往见已彼不覆藏。而复别说彼梵行法。世尊。我佛如来。是一切众生大师。无所不知。无所不见。无不解了。我见是相其事云何。愿佛开示。尊者阿难发是言时。而此佛会地大震动

尔时光聚王菩萨。现身虚空高一多罗树。即于空中问阿难言。尊者阿难。于汝意云何。犯非法者。岂能如是住虚空耶。是时尊者阿难。对如来前向空问言。光聚王菩萨如我向者所见事相。云何菩萨有此非法耶。尊者阿难作是言时。世尊即为垂足按地。是时他方世界有佛世尊。现虚空中发是声言。菩萨已离非法。我知是事我证是事。彼佛言已隐空不现

尔时世尊告阿难言。汝不应于住大乘者菩萨正士生过失想。阿难。譬如声闻乘中初二果人求无漏道不以为难。具善巧方便菩萨摩诃萨亦复如是。求一切智不以为难。何以故。菩萨已离眷属缠缚故。已能安住佛法僧宝不坏净信。不退转于阿耨多罗三藐三菩提。阿难。当知若有住菩萨乘者。不离一切智心。设于五欲法嬉戏而行亦无过失。所有诸佛如来。得五根具足。其义如是。阿难。如汝所见光聚王菩萨其事因缘。我今为汝如实宣说。阿难。汝今当知。光聚王菩萨向于聚落同处坐者。而彼女人于过去世二百生前。与此菩萨曾为夫妇。是故今时而此女人。见光聚王菩萨吉祥威光戒力具足。女人见已。由宿习故生粗重想。以善根力复作是念。我若得此光聚王菩萨来我舍中共坐一处。彼能令我发生阿耨多罗三藐三菩提心。阿难。时光聚王菩萨。知彼女人心所念已。即于夜分往诣彼舍。与其女人共坐一处。广为宣说无数法门。时女人舍。内外平正广博严净。时光聚王菩萨既同坐已。即复执彼女人右手。说伽陀曰

  佛不称赞染欲法　　愚痴迷着而所行
  若能断除欲爱心　　佛说斯人为最上

阿难。时彼女人闻是伽陀已心大欢喜。即从座起合掌恭敬。礼彼光聚王菩萨足。说伽陀曰

  我本无心实求欲　　我知欲法佛不赞
  若能断除欲爱心　　佛说斯人为最上

说是伽陀已。复说伽陀曰

  当知如我心所思　　所说真实而无异
  若人乐求佛菩提　　一切众生获利乐

阿难。时彼女人。得光聚王菩萨善巧方便为开导故。即时女人发阿耨多罗三藐三菩提心。时彼菩萨即从座起出离彼舍。阿难。汝今当知。我观彼女人深心清净勇猛最胜。我今为彼授菩提记。阿难。彼女人从此命终已。当转女身得成男子。从是已后过九十九百千阿僧祇劫。当得成佛号曰近事如来应供正等正觉出现世间。阿难。以是缘故。当知菩萨摩诃萨已离眷属恩爱缠缚。一切非法永不复生

尔时光聚王菩萨摩诃萨。闻佛世尊如是说已。从空中下头面着地礼世尊足。礼已合掌前白佛言。世尊。具善巧方便菩萨摩诃萨。住大悲行常所利益。世尊。我今亦得是行。又复世尊。若有菩萨能为一众生发一善根者。于诸色爱不起罪心。若如所起罪垢心者。当于百千劫中受地狱苦。世尊。若彼菩萨起是罪心受斯地狱苦者。当知是菩萨即舍离众生所发善根。令彼善根不能成就

尔时世尊赞光聚王菩萨言。善哉善哉。菩萨正士。如汝所说如是如是。若住大悲心者。能为一切众生断除一切罪垢。善男子。我念过去阿僧祇劫前。有一摩拏嚩迦。名曰光明。于四万二千岁中。修持梵行离诸过失。过是四万二千岁已。而于一时以因缘故。入一王城其名神通。于彼城中见一女人名曰伽吒。时彼女人。见是摩拏嚩迦色相端正。女人见已生欲爱心。来诣其前作礼而住。光聚王。尔时摩拏嚩迦。即问彼女人言。今汝女人有何所求。女人答言。我今求汝摩拏嚩迦共为夫妇。摩拏嚩迦言。我不于女人而生欲想。女人又言。我于今时若不得汝为夫妇者。我当不久而趣命终。尔时摩拏嚩迦作是思惟。我于四万二千岁中。修持梵行不犯禁戒。我于今时不应受是染爱非法。而此女人我宜远离。作是念已。离彼女人而行七步。过七步已还复小住。为其女人起大悲心。作是念言。我于今时发勇悍心。设犯禁戒宁当忍受地狱苦报。不应远离令彼失命。尔时女人闻是言已心生快乐。适本所愿不至命终。光聚王。时彼光明摩拏嚩迦。即执彼伽吒女人手。作如是言。如汝所欲。今我与汝随所应作。如是光明摩拏嚩迦与伽吒女人。于十二年中共为夫妇。彼摩拏嚩迦。过是十二年已。又复精进修持梵行。从是殁已生梵天界。光聚王。汝今当知。彼时光明摩拏嚩迦者。勿起异见。今我身是。彼时伽吒女人者。今耶输陀罗是。所以者何。我于尔时。但能一念起大悲心。又复还修梵行得生梵界。如是我于十千劫中受轮回身。虽受是身不生厌倦。光聚王。诸有众生不具善巧方便者。于轮回中受地狱苦。菩萨以能具足善巧方便。是故得生于梵天界。光聚王。假使舍利子。目干连。大阿罗汉。虽复神通智慧于声闻中而为第一。亦未能具善巧方便。光聚王。今我法中有一苾刍名俱迦梨俱。堕地狱中其事云何。光聚王。我念过去拘留孙佛法中。有一苾刍名曰无垢。时彼苾刍。修阿兰那行独止一岩。其岩不远有五通仙人别止一处。忽于一时布大黑云降霔大雨。时彼近住五通仙人。往诣无垢苾刍岩所。欲生恼害破彼梵行。是时仙人正入。苾刍方出。仙人见已起过失心。妄生轻谤作是思惟。此无垢苾刍。退失梵行欲造非法。尔时苾刍知彼仙人心所念已。即踊身虚空高七多罗树。仙人见是苾刍住在空中。仙人告言。我持利刀来此岩中破汝梵行。汝今何复住空中耶。仙人言已。苾刍即时从空而下。礼彼仙人不复踊身。是时仙人于须臾间。全身堕彼大地狱中。光聚王。于汝意云何。彼时无垢苾刍者。勿起异见。即今慈氏菩萨是彼五通仙人者。即俱迦梨俱苾刍是。光聚王。此因缘者当知非彼声闻缘觉境界。皆是菩萨摩诃萨善巧方便智慧所行。光聚王。又如世间有誐尼迦人。六十四种艺能具足。是人爱乐财宝。随所向处以艺能故。一切所用皆悉能得。于彼彼人所得财利已。后复忘恩心生弃舍。具善巧方便菩萨亦复如是。于一切处设诸方便救度众生。彼彼所向于诸众生无所希取。见彼众生所有善根。劝令增进。由彼所作善根力故。普令众生出生胜行。菩萨亦复无所取着。乃至戏乐等事。虽复顺行而已舍离。不复于心有所系缚。光聚王。又如世间傍生异类。或见妙华色香具足。时彼傍生不能生起一念爱乐。具善巧方便菩萨亦复如是。虽受一切戏乐等事。未尝暂起一念爱乐。无自作无他作。一切无著。光聚王。又如世间肥坏地中植诸种子。决定得生芽茎果实。具善巧方便菩萨亦复如是。修空无相无愿解脱法门。决定已能离诸染法。虽受一切戏乐等事。而亦不坏修行。佛所称赞功德成就。光聚王。又如世间渔捕之人。于大池中张以大网。捕取其鱼随彼所欲。皆悉能取不坠水中。具善巧方便菩萨摩诃萨亦复如是。修空无相无愿解脱法门。一切智心坚固所护。毕竟不堕生死泥中。随彼彼处。灭此身已生梵天界

佛说大方广善巧方便经卷第一佛说大方广善巧方便经卷第二

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

复次光聚王。又如持明人善修瑜伽悉地法门。于秘密五种缚中而受系缚。随所作法不越三昧。是人以一大明句力。悉能断除彼一切缚。而获安住秘密行门。虽在系缚中常不离三昧。具善巧方便菩萨摩诃萨亦复如是。于五欲境中嬉戏顺行。随其所作不坏正行。是菩萨以一智慧明力。悉能清净一切染法。于一切智心而能安住。虽受五欲乐。常生梵天界。光聚王。又如世间善用剑者。于其剑法巧妙精熟。是人一时隐覆利剑。独行旷野险难之处。于其中路忽见一人。单己无伴复无器仗。时用剑人见彼人已。生悲愍心即相附近。而谓言曰。汝今独行一无伴侣。又无器仗将何护身。汝今同我随其所往。终不令汝有所阙失。若忽值遇盗贼等事。我当为汝作大救护。言已同行。于其中路忽逢贼众。时同行人不知此人先隐利剑。见是贼已即生怖畏。时用剑人发勇猛心无所怯惧。即出其剑与彼贼众而共斗敌。时彼贼众皆悉断命。其用剑人自护身已。复能防护彼同行者。咸得安隐过斯险难。具善巧方便菩萨摩诃萨亦复如是。而能具足种种方便执智慧剑。虽于五欲境嬉戏顺行。终不暂令身根起放逸事。能为身根作大防护。设于异时遇烦恼魔。菩萨亦复无所动转。被精进铠不生怖畏。以智慧剑断烦恼网悉令清净。菩萨常生清净佛土

尔时会中有一菩萨名曰作爱。于其食时。入舍卫大城。而行乞食。时彼菩萨次第行至一长者舍。住立门侧发声乞食。长者有女名曰上财。颜貌端正人所爱乐。是时彼女闻菩萨声。即持饮食出施菩萨。授其食已。即于菩萨生爱乐心。若色相若音声而生取着。由此因缘起贪染心。作爱菩萨见是女已。即知其念。菩萨尔时于贪染法无所作意。即自思惟于须臾间。若起一念贪染心者。是大过失。何以故。今此女人我于何处而生可爱。若彼眼根为可爱者。眼是无常败坏不净肉团。彼自性空何所爱乐。若于耳鼻舌身意根为可爱者。彼彼诸根亦复如是。自性皆空无有实法。何所爱乐。如是从足至顶乃至内外中间。一一如实审谛观察。是中无有少法可得。我今如是如实观已。于一切法悉无所有。法无有故即法无生。菩萨作是思惟时。即得无生法忍。菩萨得是利已心大欢喜。即于是处踊身虚空。高一多罗树。于其城中右绕七匝出舍卫大城。乘空往诣佛世尊所

尔时世尊。见彼作爱菩萨。威德巍巍犹如鹅王。乘空自在徐缓而来。世尊见已。谓阿难言。阿难。汝见此作爱菩萨从空来不。阿难白佛言。世尊。唯然已见。佛告阿难言。汝今当知。此菩萨者。于一切法离贪爱心。证法无生悉无所得。而能降伏一切魔军。广为众生转正法轮。时佛言已。而彼菩萨即住空中听佛说法

是时彼上财女人。于长者舍忽然命终。生三十三天。转女人相得天子身。彼天子生时。有七宝庄严微妙宫殿同时出现。纵广十二由旬。复有一万四千天女眷属同时而生。是诸天女于须臾间。自有智生咸作是念。我等今时以何善根得生于此。即知先世舍卫城中有长者女。于一菩萨起染爱心。以是因缘于彼命终生此天中。转女人相而为天子。彼得无量胜报神通。我等由是天子胜因缘故亦得生此。作是念已欢喜而住

尔时彼新生天子即作是念。我昔人间生染爱心。而何今时得是胜报。此因缘者。乃是作爱菩萨增上善力为开导故。我今宜应往诣佛所。恭敬供养彼佛世尊。及欲瞻礼作爱菩萨

尔时彼天子作是念已。即时与诸天女眷属。持以种种殊妙香华。从彼天界来诣佛所。到已头面礼世尊足。即于佛前合掌向空。遥伸敬礼作爱菩萨。然后以彼所持众香华等。尊重恭敬供养世尊。作供养已右绕三匝。合掌向佛说伽陀曰

  不可思议人中尊　　不可思议大菩提
  不可思议诸佛行　　不可思议诸佛法
  我舍卫城长者女　　父本立名为上财
  色相端严众所钦　　父母宗亲亦爱念
  于一时中有佛子　　具大威德名作爱
  舍卫城中乞食行　　次第来至于我舍
  我时闻彼美音声　　适悦欢喜即取食
  持食诣彼作爱前　　以尊重心施佛子
  我时见彼妙色相　　心生爱染欲和合
  彼因缘故不能成　　我于刹那而命断
  我今不能具宣说　　作爱佛子大因缘
  于染爱法不相应　　令我灭已生胜处
  世尊我虽舍前报　　快哉断我女人相
  转成男子大威光　　又复得生于天界
  与我同生诸天女　　一万四千为眷属
  复有最上七宝严　　微妙宫殿同时现
  我时发生如是心　　此为不可思议事
  我以染爱心为因　　云何得此清净报
  作爱佛子甚希有　　亦名作喜作光明
  我身炽盛大威光　　由彼胜因获如是
  染因能成如是果　　声闻缘觉不能知
  而彼乘中无此法　　唯善逝智而能转
  假使殑伽沙数劫　　不能修学诸佛智
  我今无余所乐心　　唯求无上菩提果
  作爱佛子大威德　　是我最上善知识
  我因彼故得见佛　　安住菩提无退转
  我知修行菩提者　　于染爱心无所著
  如我所转女人相　　普愿一切为男子
  我前世中命终后　　父母亲族怀悲恼
  恩爱极苦所缠心　　返于沙门生忿恚
  我今以佛威神力　　于刹那间诣父所
  隐身住空而白言　　勿于沙门生忿恚
  起忿恚者大过失　　于长夜中受苦恼
  上财女者今我是　　已生三十三天中
  转彼女人前报相　　得大威光天子身
  父母今诣于佛所　　应当忏彼忿恚心
  佛是众生大慈父　　一切众生所归趣
  父母闻说佛声已　　即起广大增胜心
  尔时父母承佛力　　应声即诣于佛所
  到已头面礼佛足　　忏悔先起忿恚心
  白言我今归依佛　　合掌又复伸问言
  佛法僧宝最尊胜　　当云何作供养事
  唯佛能知我心意　　如我所问愿佛说
  发是言已谛诚住　　一心渴仰而听受
  佛告上财父母言　　汝今谛听我所说
  若欲供养诸佛者　　应当发起菩提心
  当知汝女上财者　　五百生中种善根
  今转女身为天子　　为汝父母善开导
  父母闻佛如是语　　即发无上菩提心
  欢喜称赞作是言　　人中大仙如实语
  尔时佛告阿难言　　汝今证知如是事
  菩萨方便不思议　　于染心中得净报
  如上财女所转相　　一切众生亦如是
  阿难如是胜功德　　能令众生皆离苦
  今此天子胜福报　　于染爱心常清净
  而能恭敬佛世尊　　尊重无上菩提故
  多劫已曾供养佛　　于诸佛所种善根
  坚固安住菩提心　　决定当得菩提果

尔时尊者阿难白佛言。世尊。如我意者。譬如须弥山王众宝所成。虽种种宝有种种色。彼黄金色而为最上。菩萨摩诃萨亦复如是。若清净心若染污心。若住法心若隐法心。虽种种心如是差别。彼一切智心而为最上。世尊。诸菩萨摩诃萨最初安住一切智心。于诸染法悉能清净。又如有药名曰善现。能治世间一切病苦。菩萨摩诃萨亦复如是。住一切智心已。能断除贪嗔痴等诸烦恼病

尔时世尊赞尊者阿难言。善哉阿难。如汝所说如是如是

尔时尊者大迦叶。前白佛言。希有世尊。菩萨摩诃萨能行最上寂静之行。能于一切众生。起悲愍心常所利益。又复能修空无相无愿解脱法门。不乐声闻缘觉之法。于一切处不离一切智心。具不可思议善巧方便。世尊。诸菩萨摩诃萨。一切所行无著无碍。于色声香味触境中。行而不取亦无起作。世尊。我今乐说譬喻明菩萨行。愿佛世尊听许我说。佛言大迦叶。乐说当说今正是时。大迦叶言。世尊。譬如世间有无数百千人众。于其旷野险难之处见有一门。而彼人众尔时各各从其门入。过是门已次见道路。其路悬旷险恶多难。彼诸人众见是路已。咸生怖畏。是时有一智人具善方便。欲为多人利益安乐。即告众言。汝等当知。去此不远有一大城。其城广阔严丽清净。人民炽盛安隐丰饶。入彼城者适悦快乐。谁当爱乐入其城中。即能远离险难怖畏。时彼众中有一类人。闻是语已即时发言。我今乐入。入是城已。见其丰饶安隐快乐。生希有想爱着不舍。即于彼住不复乐出。有一类人。闻说其城即时发言。我亦随顺入彼城中。是人虽入不乐彼住后复还出。又复众中有一类人。虽闻是语不能前诣入彼城中。世尊。彼有智人过此城已。又复行于旷野险路。出是路已见一道径。其径狭小可一尺量。径之左面有一大坑深百千肘。径之右面复一大坑深百千肘。若或有人堕是坑者不能出离。彼径四向有一类人发是声言。我于此处生大怖畏。又复去彼狭径不远有四衢道。一类人众游履其道。随其所向。彼彼皆能见有大城。如如所见。彼彼随应而生爱乐。时彼智人见是狭径已。即行其径到安隐处。世尊。世间无数百千人者。当知即是诸愚异生

一门者。当知即是取一有身。彼旷野险难中见道路者。当知即是生死险难之路。其路悬旷者。当知即是无明有爱为因受果。极悬远故。彼有智人能唱导者。当知即是具善巧方便菩萨摩诃萨。彼大城者。即是二乘所证涅盘。有一类人入彼大城。爱乐安住不求出者。当知即是声闻缘觉下劣信解生止息想。彼一类人亦欲随顺入其城中不乐安住后还出者。当知即是余诸菩萨。成就最上信解心故。彼一类人虽闻是语。不能前诣入其城者。当知即是少福无智诸外道辈。彼有智人过此城已。又复出彼旷野路者。当知即是具善巧方便菩萨摩诃萨。精进波罗蜜多故。彼一尺量狭径路者。当知即是最上法界。左面坑者。当知即是彼声闻地。右面坑者。当知即是彼缘觉地。彼径四面有一类人发怖畏声者。当知即是诸天魔王及魔眷属。彼四衢道者。即是四摄法门。随其所向彼彼皆能见大城者。当知即是彼二乘人。随其所应见佛功德见佛所行。及佛智慧生爱乐故。时彼智人到安隐处者。当知即是到一切智地。世尊。如是等譬喻说者。当知皆是菩萨摩诃萨善巧方便引导众生。是为菩萨最上胜行。以是义故。我于菩萨摩诃萨所应敬礼

尔时世尊赞尊者大迦叶言。善哉善哉。汝大迦叶。善说此语。当佛如是赞迦叶时。会中有万二千众生。得天人身。皆发阿耨多罗三藐三菩提心。佛告大迦叶言。汝今当知。菩萨摩诃萨具善巧方便者。已能成就无量功德。于一切时虽有所作。不复起彼诸不善业。于自于他远离过失

尔时智上菩萨摩诃萨。于佛会中见如是事。闻如是法。又复恭敬。前白佛言。云何世尊。往昔为一生补处菩萨时。于彼迦叶如来法中。曾作是语。何故剃须发。云何求菩提。而此菩提最上难得。昔作是语当有何义。愿佛于今为我宣说。佛告智上菩萨摩诃萨言。止善男子勿作是语。当知菩萨摩诃萨随其所行。随有所说非无利益。何以故。具不可思议方便菩萨。见彼彼正士随所应住。于彼彼众生如应调伏。一切所行。当知不离菩萨摩诃萨善巧方便

复次智上。我今为汝广说菩萨摩诃萨善巧方便甚深正法。汝应谛听如善作意。善男子。如我往昔为菩萨时。于燃灯佛所。成就不可思议方便。尔时我于彼佛法中。证得无生法忍。从是已后。我为得忍菩萨。为菩提故转复精进。若一劫若百劫。未尝懈倦。未尝厌舍。未尝失念。数数来此轮回趣中。以善方便救度众生。以自慧力随诸所作悉得成就。于后边际不作住想。为利众生无有休息。当知此是菩萨摩诃萨善巧方便

复次善男子。我为菩萨时。为菩提故虽入声闻寂静三摩地。乃至入菩萨三摩地。若身若心无出没想。虽得寂静乐而不住着。虽在三摩地而精进不懈。以六波罗蜜多四摄法门。教化众生。诸有所作未尝懈息。当知此是菩萨摩诃萨善巧方便。又善男子。我为菩萨时已得一生补处。将欲成道转大法轮。即于兜率天宫如实观察。我今为当于此天中成等正觉转法轮耶。为人间耶。如是观察又复思惟。我若即于天中作此利者。阎浮提人不得闻法。若于阎浮提中作此利者。而此诸天不得闻法。我今随其所宜。但应下降阎浮提中成等正觉。而此诸天亦可利益。又复菩萨思惟观察。我若从此兜率天宫没已。下生人间。不入胎藏现受生相。于须臾间便成正觉者。彼阎浮提所有众生。当起疑念。此释迦菩萨从何所来。天中来耶。乾闼婆中来耶。变化来耶。以是缘故从天中没下降阎浮。随顺世间入母胎藏。当知此是菩萨摩诃萨善巧方便

复次善男子。菩萨虽住胎藏。世间众生不应于此作实住想。何以故。菩萨本从无垢寂静三摩地安详而起。从天中没。下降人间。处胎受生。出家苦行。乃至坐菩提场。成等正觉。降伏魔众。转大法轮。如是一切所作。菩萨于中清净无染。无动无转不出不没。以是义故。应知清净行菩萨不实住胎藏。当知此是菩萨摩诃萨善巧方便。又复何缘。菩萨但现胎生。不现余生耶。所谓菩萨于一切众生中最上最胜。是洁白分纯一无杂。以如是相现处胎生。当知此是菩萨摩诃萨善巧方便。又复菩萨初入母胎。其相云何。所谓。菩萨入母胎时内外清净。安隐无难不苦不恼。如昔天中所受快乐。菩萨入母胎时。乐受相应亦复如是。不同世人揽彼父母羯逻蓝等秽污不净。为入胎相。又复何缘。菩萨于母胎中。住满十月不增减耶。所谓菩萨不同世人住母胎藏。日月数量有增有减。以增减故胎藏不圆诸根缺减。是故菩萨。满足十月胎藏圆满。诸根具足无所增减。当知此是菩萨摩诃萨善巧方便。又复何缘。菩萨不乐宫殿。而返于其园林中生。所谓菩萨于其长时。远离愦闹乐寂静处修寂静行。有诸天龙夜叉乾闼婆等常所卫护。菩萨欲令迦毗罗城一切人民。以诸香华随喜供养各得瞻睹。以是因缘。菩萨于其园林中生。又复何缘。菩萨之母攀其树枝生菩萨耶。谓菩萨母不同世间所有母人。当产生时苦受相应得大苦恼。摩耶夫人生菩萨时。乐受相应得大快乐。以是因缘。菩萨之母攀彼树枝而生菩萨。又复何缘。菩萨于母胎中。能念能知彼三世事。乃至菩萨入胎住胎等事悉能知耶。所谓清净行菩萨于三界中最上最胜。正念现前于一切法无所忘失。是故菩萨虽住胎中。能念能知彼一切事。又复何缘。菩萨生时。唯帝释天主而来卫护。菩萨生已即为捧接。尔时无复余天人耶。所谓。帝释天主先发大愿。菩萨生时为作守护。以彼往昔善根力故。是故菩萨生时唯帝释天主而来卫护。又复何缘。菩萨生已即于四方各行七步。不减至六不增八耶。所谓菩萨正士。神通变化随宜方便。其相如是。由此因缘但行七步无所增减。又复何缘。行七步已即发是言。我于世间最尊最胜。已能解脱老病死法。谓此梵界诸天子众。闻菩萨生。悉来瞻礼。各各随应得其利益。菩萨尔时即自思惟。但此梵界诸天子众得知是事。我今欲令一切普得闻知。作是念已。乃发声言。我于世间最尊最胜。已能解脱老病死法。发是言时。所有三千大千世界。诸天子众及诸梵众。闻是声已于须臾间。一切皆来至菩萨所。合掌恭敬随喜称赞。以是因缘乃唱是言。我于世间最尊最胜

佛说大方广善巧方便经卷第二佛说大方广善巧方便经卷第三

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

复次善男子。何缘菩萨生已现大笑相。岂非菩萨以掉举故现是相耶。所谓菩萨生已作是思惟。我欲普令一切众生。悉能同我发菩提心。我当得菩提已。广度众生出轮回苦。我于是事无懈怠想。我观一类众生。起下劣心迷乱作意。于解脱道。不能发起广大精进。此复云何。所谓具大悲心者能起精进。彼类众生无如是行。我欲令彼成就如是广大精进。得最上解脱。是故我取一切智果。由此因缘心生欢喜。以其喜因现大笑相。而非菩萨掉举相故。又复何缘。菩萨身本无垢而沐浴耶。所谓菩萨无量劫来虽离垢染。今此现生。随顺世间沐浴其身。又复何缘。菩萨生已而不便从园中诣菩提场成等正觉。复入王宫其事云何。所谓菩萨身相圆满威德具足。人所瞻者皆获利益。菩萨乃入王宫。令彼宫嫔一切眷属咸得瞻睹。又欲于其宫中随顺世间作嬉戏事受诸快乐。虽同有作而无其实。乃至一切所有及转轮王位皆悉弃舍。出家修道由此因缘。是故菩萨复入王宫。又复何缘。摩耶夫人生菩萨已七日命终。岂非菩萨咎耶。所谓菩萨于兜率天。将欲下降入母胎藏。先以天眼审谛观察。见摩耶夫人所有寿量满足十月。余复七日即当命尽。菩萨如是观已。乃入胎藏住经十月。由此因缘。摩耶夫人七日命终。寿量尽故非菩萨咎。又复菩萨未出家时。遍学世间一切艺能。所谓书算咒术工巧歌舞。乃至弓箭器仗等事。如是学者其义云何。所谓菩萨为欲调伏世间显最胜故。所以者何。而此三千大千世界中。无有一人所学艺能胜菩萨者。以是缘故。菩萨未出家时学如是事。又复何缘。菩萨未出家时纳妻有子。而复广有宫嫔婇女诸眷属等。岂非菩萨生贪爱耶。所谓菩萨虽同世间起如是相。而非菩萨生贪爱心。何以故。菩萨正士已离贪爱。于贪爱中随所施作。而无其实所有。菩萨纳耶输陀罗而为妻者。菩萨为欲令耶输陀罗满宿愿故。彼耶输陀罗。往昔曾于燃灯佛所。发是愿言。愿我当于释迦牟尼佛法中为释种女种诸善根。以彼宿世无虚妄言。是故我今纳以为妻。令彼速得善根成就。随世间相虽复如是。而菩萨心不生过失。后当弃舍出家修道。所有生罗睺罗子者。谓世间人作是谤言。若无子息生育相继者。彼非丈夫。菩萨息是谤故。乃令耶输陀罗释种之女即时产生罗睺罗子。而此罗睺罗者。不从父母羯逻蓝等秽污所生。当知从天中没化相生此。所有广集宫嫔婇女诸眷属者。菩萨为欲各各随应教化开导。悉令获得最上善利。后当弃舍出家修道。菩萨于其宫中。以阿耨多罗三藐三菩提法。教化开导四万二千宫嫔婇女。悉令种是菩提善根。余诸宫女但能信心清净安住正见。是故当知诸菩萨摩诃萨修菩萨行者。随世间相虽处王宫纳妻有子。广集宫嫔诸眷属等。乃至于五欲乐嬉戏顺行。诸有所作皆无其实。清净洁白离诸垢染。无爱无著无动无转。菩萨但为教化一切众生。圆满宿愿成熟善根故。即以不可思议善巧方便神通愿力。变化所生变化所作。于其神通游戏法中。得三摩地寂静快乐。随应所作皆悉利益。菩萨处王宫时。虽受一切象马奴婢。而彼一一皆是宿世殊胜愿力。菩萨为成就故而乃摄受。以是因缘。当知菩萨纳妻等相非贪爱心。又复何缘。菩萨一时往阎浮树下结加趺坐。彼时日光虽转树影不移。其相云何。所谓菩萨欲令七俱胝天人获利益故。其相如是。又复何缘。菩萨出游园林。见老病死生怖畏耶。所谓菩萨已离老病死怖。见是相时现恐怖者。欲令众生起厌畏故。又复何缘。菩萨于中夜分踰城出家。而不于彼昼日分耶。所谓菩萨取夜分者。欲令迦毗罗城一切人民皆不见故。又为菩萨令自善根而得增长。白法清净圆满具足。弃舍一切所有乐事。是故菩萨于中夜分踰城出家。又复菩萨出王宫已。至苦行处自手截发。菩萨之父净饭大王。闻如是事心不生信。云何我子便截发耶。后知其实心生苦恼。是相云何。所谓菩萨以所截发。欲令三千大千世界一切天龙夜叉乾闼婆人非人等。见佛吉祥威光最胜发髻。瞻礼恭敬获大利益。以是因缘而自截发。又复菩萨所有迦蹉迦马王。种种庄严驭人餐那善能控驭。菩萨当乘出王宫时。而彼马王欢喜而行后乃弃舍。是相云何。所谓菩萨一切所爱欢喜弃舍无所恋着。欲令末世一切众生。如我今时离诸爱着于我法中如是修学。又复令末世中诸出家者。以彼正命出家学道。以是缘故弃舍马王。又复何缘。菩萨于寂静处。六年苦行历诸难事。岂非菩萨余业障故感是报耶。所谓菩萨。诸障已尽无有苦报。诸所作事但是菩萨善巧方便。善男子。汝前所问我为一生补处菩萨时曾发是言。何故剃须发。云何求菩提。而此菩提最上难得。此因缘者非无利益。今当为汝如实宣说。我念往昔于迦叶如来法中。而为菩萨名曰护明。我时以善巧方便。于诸众生随其所宜为作利益。彼时有五婆罗门是大族姓子。先于菩萨乘中修诸梵行。后因值遇彼恶知识。使令妄失大菩提心。彼五婆罗门即于一时起如是心。我等已能得菩提法。起是心者异见相应。我于尔时观知彼心。即以方便欲为开导。乃于彼前发如是言。何故剃须发。云何求菩提。而此菩提最上难得。彼五婆罗门闻是语时。咸作是念。何故护明菩萨发如是言。我知其念。又复告言。何故剃须发。云何求菩提。而此菩提最上难得。我时言已安住真实平等法门。即与五婆罗门同住一处。时有二人。一名竭致迦啰。二名贡婆迦啰。来诣于我及五婆罗门所。先广称赞迦叶如来最上功德。后复谓我及五婆罗门言。今可往诣迦叶如来应供正等正觉所。我于尔时作是思惟。此五婆罗门善根未熟。若今同诣迦叶佛所。我或称赞迦叶如来最上功德。彼五婆罗门不能称赞。作是思惟已。告彼二人言。我自知时作是言已。我即于般若波罗蜜多。住无所住。以般若波罗蜜多力所护故。从是出生善巧方便。即谓五婆罗门言。我向语汝。何故剃须发。云何求菩提。而此菩提最上难得。于如是义汝等未解。今为汝说。以何义故菩提难得。所谓菩萨若于般若波罗蜜多。无所行想无所住想。即于菩提无智无得。如实而观悉无所得。又菩提者。不在内不在外不在中间。不可以身得。不可以心得。毕竟空中一切无得。是故我向谓汝等言。何故剃须发。云何求菩提。而此菩提最上难得。当知此说是真实说。时五婆罗门闻是法已心得开悟。还复安住大乘法中。我作是说已。住一切法无所得心。即离是处。又复别诣于一方所。彼五婆罗门尔时亦复同于彼住。是时竭致迦啰。贡婆迦啰。二人承佛威神力故。复诣彼处方便劝导。五婆罗门令彼同往迦叶佛所。我时观彼五婆罗门根缘已熟。即时与彼五婆罗门及其二人。同诣迦叶如来应供正等正觉所。到佛所已各礼佛足。时彼二人以宿世善根力故。见佛相好。尔时各各心得清净。彼五婆罗门得见如来色相光明吉祥威德。心生欢喜。各以宿世善根力故。还发阿耨多罗三藐三菩提心。我时白佛言。此五婆罗门。善根成熟愿佛化度

尔时迦叶如来应供正等正觉。即为宣说菩萨藏法。随其所应而能解了。即时皆得无生法忍。迦叶如来即为我授阿耨多罗三藐三菩提记。我得记已。即白迦叶佛言。以如来应供正等正觉。摄受此五婆罗门故。而令得见如来。复为宣说菩萨藏法。教化开导皆为得忍。菩萨求佛菩提。不复退转

复次智上。我昔于彼迦叶如来法中。为一生补处菩萨时。先所发言。何故剃须发。云何求菩提。而此菩提最上难得。作此说者为开导故。由是因缘彼获利益。是故当知诸所言说非无义利。皆是菩萨摩诃萨善巧方便。而非过咎非不善法。若有众生少知少见者。或于持戒清净沙门婆罗门所。发无义语。所谓以智为非智。作是语者不能长夜利益安乐。但能与彼苦受相应。此等众生作不善业是过咎者。菩萨摩诃萨即不如是。一切障累悉已清净。无复少分业障可得。但为众生灭诸恶法。普令堪任趣证解脱。智上。如昔因缘当如是知。又我所有六年苦行历诸难事。但为降伏诸外道故。又欲令诸众生起精进故。一麻一麦为所食者。欲令身器得清净故。由此因缘于六年中修诸苦行。而非余业所感报应。我昔如是于六年中修苦行时。有五百万天众仙众。皆得智通三昧。是故当知我修此行以善巧方便为利益故。又复菩萨先受乳糜食已。增益势力方乃行诣菩提场中而取正觉。何不但令其身瘦悴。往彼道场成正觉耶。所谓菩萨悲愍末世一切众生。先受乳糜食已方成正觉。何以故。末世众生皆以饮食而为资助。有诸众生求道果者。若无饮食资身。彼不能增进。咸生退屈。若得饮食为资助者皆获安隐。以安隐故。于诸善法而悉记念。乃能增进趣求道果。我欲令彼末世众生如是学。我先受饮食后方进道。又为令彼献乳糜者牧牛女人圆满施因成就菩提分法。我时食已。安坐道场得菩提果。能于一三摩地中住经千劫。皆由段食力所资故。以是因缘受彼乳糜。又复菩萨既处菩提树下金刚座上。何不速证阿耨多罗三藐三菩提果。而先降伏诸魔军耶。所谓无处可能容受诸恶魔众。菩萨若不以善巧方便而容受者。彼诸恶魔即当娆乱一切众生。是故菩萨处其座已作是思惟。我于今日成等正觉。而此三千大千世界诸众生中。有何等众生心不喜乐。念已观察知诸恶魔心不喜乐。欲于菩萨而生娆害。菩萨尔时又复思惟。我今不应与魔斗战。但以神通作变化事使彼降伏。又令一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等众。得见菩萨师子游戏。神通相已。发于阿耨多罗三藐三菩提心。以是因故普令当得最上涅盘。尔时菩萨作是念已。即于眉间放大光明。其光普照三千大千世界。一切魔宫皆悉映蔽。于其光中发是声言。今此释迦种族净饭王子。舍转轮王位出家修道。诣菩提场取证阿耨多罗三藐三菩提。发是声时复有无数天人四众。来菩萨所瞻礼恭敬。是时一切魔王及魔眷属。见是事已四散驰走惊怖战掉。忧箭入心生大苦恼。时恶魔众忿恚转增。于须臾间化四兵众。绕菩提场面百由旬。种种变现而为娆乱。菩萨尔时住大慈心。虽见是相而无动转。菩萨即以宝网鬘手作降魔相。是时诸魔即皆降伏。尔时有八十四俱胝。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆发阿耨多罗三藐三菩提心。以是缘故菩萨先现降魔相。当知皆是善巧方便。又复何缘。如来得阿耨多罗三藐三菩提已。于七昼夜中结加趺坐。观彼树王寂然不动。所谓色界有诸天子修寂静行者。见如来应供正等正觉加趺而坐。心大欢喜作是思惟。如来于七昼夜中依止一心寂静而住。是心不可得。作是念时。有三万二千色界天子发阿耨多罗三藐三菩提心。我为欲令未来世中诸修道者。悉能如是修寂静行。以是因缘如来得菩提已。于七昼夜观彼树王寂然不动。又复如来得菩提已。何故最初梵王劝请转法轮耶。此因缘者。所谓有诸梵众劝请梵王随应说法。何以故。彼诸梵众谓能依止梵王。复谓梵王能生梵众。于此世间无复最先过梵王者。尔时梵王作是思惟。如来大师为世间尊。随应悉能知众生根。是故我应劝请说法。作是念已诣菩提场。劝请世尊转正法轮。当彼梵王如是劝请。时有六百八十万梵众发阿耨多罗三藐三菩提心。以是缘故。梵王最初劝请转正法轮。复次智上。如来大圆镜智。悉能显照一切众生语言心行。一切所作无不容受。照见众生最初边际。有具善根者。有不具善根者。彼彼众生彼彼业报。大圆镜中皆悉显现。乃至诸佛如来所作报应亦于中现。菩萨诣菩提场成等正觉。圆满一切白法最胜功德。如来已断一切不善之法。已能清净一切障累。已能远离一切过失。如是功德大圆镜智皆悉显照。复次智上。如来从大悲心起善巧方便。普为救度一切众生。譬如医师善解医药。诸有病者随其所宣。甘苦辛味和合妙药。应病而授皆得除愈。如来大师亦复如是。具足种种善巧方便。为大医王善疗众病。随观众生有何等病。如其所应以善巧方便。而为救疗皆令解脱。又如世间彼初生子。慈母乳哺恩育爱怜。不令有少病苦所侵。若后有病慈母即为拣择良药。授与令服。子既服已而得安乐。如来大师亦复如是。为一切世间之父。观诸众生如其子想。不令众生有苦恼者。若见众生造彼彼业得彼彼报。如来随应即以善巧方便。而为救度令得解脱。智上。如是所说当知是为善巧方便

佛说大方广善巧方便经卷第三佛说大方广善巧方便经卷第四

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

复次智上。我念过去世。时有五百商人入海求宝。是时别有一商人。其性刚强猛利暴恶。于海中路而忽相逢彼一商人即生恶心欲谋珍宝彼自思惟。我今宜应设其方便悉断彼诸商人命已。当取珍宝还阎浮洲自受快乐。是时五百商人众中有一商主。名曰善御。其性慈和于一切人常生悲愍。商主一时止息而卧。忽于梦中见大海神出现其相。谓商主言。汝今当知诸商众外。别有一人其性暴恶。如是色相如是名字。彼人起贼害心欲谋珍宝。彼作是念应当速断诸商人命。取其珍宝还阎浮洲自受快乐。是故我今如彼所念而先语汝。汝可思惟作何方便。令此恶人不造杀业免地狱报。又复商众得全其命。何以故。此五百商人。皆于阿耨多罗三藐三菩提已住不退转。而彼恶人于如是住菩萨法者。若造杀业永堕地狱无有出期。是故汝今宜设方便善为救度。尔时善御商主。从梦觉已即作是念。我于今时有何方便。令此恶人不造杀业免地狱报。得诸商人各全其命。于一日中如是思惟。求善方便而未能得。乃至七日审谛思惟亦不能得。过七日已即作是念。我今无复方便可得。但当于彼兴杀心者先与断命。彼断命故不造杀业免地狱报。又令余众得全其命。如是念已而复筹量。我若与此五百商人共断其命。而五百人皆堕地狱。我今宜应起大悲心为救护故。自手当杀。此杀因者。设于百千劫中获地狱报亦当忍受。但能今时以如是大悲方便。令此恶人不造杀业当免地狱无量劫苦。又令住菩萨法者。诸商人众安隐无难。尔时商主作是念已。即设方便乃断其命。时彼恶人既此命终得生天界。智上。彼五百商人者。当知即是此贤劫中五百如来。是时众中为商主者。即我身是。我于百千劫在轮回中。以大悲心出生善巧方便。如是种种救度众生。于汝意。云何。菩萨摩诃萨虽经百千劫在轮回中。皆为以方便智救度众生。勿谓菩萨摩诃萨有业障可得。是故当知诸佛菩萨诸所作业皆悉清净。无复少分障累可得。智上。又复当知如来应供正等正觉。是金刚不坏之身。乃至举足下足皆以神通方便作大利益。是时舍卫城中有二十人。忽与二十极恶知识而相值遇。是诸人等互起恶心欲相谋杀。各各伺求彼彼方便。时四十人承佛威神力故俱诣佛所。到佛所已住立一面。尔时如来应供正等正觉。为欲化度彼四十人。故于刹那间化一大人在佛会中。即白大目干连言。尊者当知今此大地。不久出现诸草木相。而彼大人作是言。时世尊即为垂其右足。于须臾间。而此大地即生草木各一尺量。时尊者大目干连白佛言。世尊今所出现草木之相。我于余方可能见不。佛言不能。尊者大目干连而即随取少分草木。乃自执持。时三千大千世界皆悉震动。于是如来应供正等正觉。以神通力现自身相出过梵界。而此草木亦复随从出过梵界。又复如来以神通力现大海中。而此草木亦随彼住。又复如来以神通力入大山间。而此草木亦随彼住。尔时如来还本座已即收右足。而此草木亦安住不动

尔时尊者阿难白佛言。世尊如来。往昔有何因缘今现是相。佛言阿难。我于往昔为大商主。入海求宝逢恶知识。我时以大悲心而断其命。昔因缘故今有是相。尔时世尊说伽陀曰

  今此所现如是相　　不住虚空及山海
  乃至不住诸地方　　以宿因故如是住

尔时彼四十人咸作是念。如来是大法王。无实业障可得。我等互起恶心自相谋害。今对佛前宜应忏悔。作是念已。俱白佛言世尊。我等先起恶心互欲杀害。是故今时各各忏悔。尔时世尊。即为如应宣说法要。彼四十人皆得智证三昧。是时有三百二十万众生。远尘离垢得法眼净。智上。以此因缘。当知诸佛如来。举足下足皆是神通方便作大利益。实无少分业障可得。又复如来已离诸病。何故一时。遣诸苾刍诣耆婆所。求青莲华蕊汁要当何用。所谓我于一时与五百苾刍。结夏未久住于林间。是时有修左啰摩婆尾迦行者。住彼林侧。是人忽有病生。不能进止不能调伏。即于我所求以妙药而救其苦。我时作是思惟今不应知是病所宜。何以故。我若知其病所宜者。后末世中破坏圣心。于今设何方便得药与疗。但当令此诸苾刍众为求其药。作是念已。即令诸苾刍诣耆婆所。求青莲华蕊汁与疗其病。是诸苾刍虽承佛旨。而未即行。尔时净居天子。见诸苾刍已白言。尊者。汝等当如佛旨求如是药。为作救疗勿求别药。令彼服已而趣命终。诸苾刍言。我等若行求药违佛戒法。我等宁自丧命。终不违佛戒法而行。净居天子复白诸苾刍言。如来是大法王。以利益心犹故现相服药除病。汝等今时何不如教。当行求药当行求药。净居天子如是三白已。时诸苾刍息疑悔心。即诣耆婆所求如是药。得是药已授彼病人服已除差。智上。以是因缘我为利益故。乃遣苾刍求如是药。而非如来有诸病恼。又复如来诸福蕴中最上最胜。何故最先执持应器。入城乞食。所谓如来已离诸障无叚食想。但为愍念后末世中有诸苾刍少福德者。虽入王城聚落持钵乞食。而不能得乃生退屈。不能长时勤行乞食。为令此等苾刍当于尔时作是思惟。如来大师。于诸世间福聚最胜。犹尚随宜持钵乞食。况复我今末世苾刍。薄福德故乞食所难不应生苦。但当行乞虽复少得而亦为足。智上。如来在世行乞食者。又为随顺作利益故。所谓令诸婆罗门长者居士乃至一切人民。以佛威神所加持故。于现世中饮食丰足。不值饥馑之苦。何以故。如来在世不令诸魔作饥馑难。是故如来以善方便随顺世间。虽受叚食不生爱着。不令婆罗门长者乃至一切人民及余诸天子众等。起如是念。沙门瞿昙于其叚食爱乐作意。如来为令彼等不生念故。于昼夜中与苾刍众。常住三昧依止一心。寂而无动无高无下。前引于后后如于前。正念相应于一时中我住三昧。有七万天子发清净心礼敬于我。我即从三昧出为其如应宣说法要。彼诸天子于诸法中得法眼净。由此因缘。是故当知。诸佛如来现行乞食。但以善巧方便作利益故。又复一时有赞左摩拏嚩迦。于佛如来而生恶意当堕地狱。佛为救护其事云何。所谓如来怨亲平等无复少分障累可得。但为众生安乐利益。我于尔时为欲救护彼赞左摩拏嚩迦。故以我威神力令其得见。兢伽沙数世界诸佛如来。是诸如来大圆镜智中现彼所作业。以诸如来神通力故。令此摩拏嚩迦见自业已。即生悔心作如是言。今于此中真实显现。乃自思惟如来一切白法具足。云何我今但造恶业。于白法分而不能得。彼摩拏嚩迦。作是念时。即得清净正白梵行。于其梦中见佛现身。所有先起恶意之罪皆悉销灭。命终已后免地狱报。当知皆是如来神力而为救护。何以故。所谓如来。以大悲方便不舍众生故。又复一时有孙那利梵志。于只陀林中彼以因缘而断其命。佛时不知云何名为一切智耶。所谓如来无碍正智皆悉具足无不知见。如来随诸色相神通等事。皆以威神建立。今此孙那利梵志者。佛观是人寿量已尽决定命终。亦非如来不能了知。又欲以是因缘令诸外道摄伏其心止息自罪

尔时如来以加持力。于七夜中不入聚落。是时有六十俱胝天人。过七夜已往诣佛所。到佛所已乃为随应宣说法要。即时各得智证三昧。又复何缘。如来昔曾于三月中食马麦耶。所谓如来欲令婆罗门长者等生希有心。又为成就利益事故。所以者何。我于一时与五百苾刍见五百马。我观彼马宿世善根今已成熟。何以故。此五百马于前前世。已曾为人亲近供养先佛如来。于先佛所发菩提心。后因值遇彼恶知识。破坏善法造诸恶业。以是报应今受马身。又复此五百马。往昔曾于日藏菩萨所发大誓愿。以其宿世大愿力故。今复值遇日藏菩萨。以菩提法方便教化令得度脱。是五百马以菩萨威力及自愿力故。各能思念宿生中事。智上。我观彼马有是因缘。生悲愍心欲为化度。乃与苾刍往彼马所。以所食麦即取食之。我自食已而复授彼五百苾刍。时五百马以宿善根力故。见佛及苾刍众食是马麦。即时礼佛及诸苾刍。彼五百马过三月已。皆悉命终生兜率天。即从彼天来诣佛所。恭敬尊重瞻礼供养。佛即随应为说法要。是诸天子悉于阿耨多罗三藐三菩提。住不退转。如来为令此五百马成就如是大利益事故食马麦。智上。当知所有一切饮食。如来食者皆为最上食。假使三千大千世界土及乳糖。如来食者于是二种。等无差别皆成上味。何以故。如来舌根常得上味。是大人相以是缘故。当知诸佛如来凡所受食皆为最上食。我时谓阿难言。汝舍转轮王位出家修道。于诸众生起悲愍心。汝今食此马麦而得何味。阿难白佛言世尊。今此马麦甚为希有。我虽生于王宫昔未曾得此最上味。是时阿难食马麦已。于七日中得大喜乐。智上。我时与彼五百苾刍。夏安居已各还所止。是时五百苾刍众中有四十苾刍。食是马麦虽于其味作清净想。还复思念诸苦粝食。如是思念已于七夜中。各得阿罗汉果。智上。当知如来虽食马麦实非宿障报应之事。但为众生作大利益。又令诸修净戒沙门婆罗门生希有心。复令一切众生如说能行。当知如来一切最胜。诸所施作不坏法行。又复何缘。如来一时谓迦叶言。我患背痛汝可为我说七觉支法。此因缘者。所谓尔时有八千天子而共集会。是诸天子先于佛法僧宝未生净信。当于尔时暂闻迦叶说七觉支法。而彼信心渐能开悟。即诣迦叶所。迦叶重复广为分别七觉支法。是八千天子。即时各得智证三昧。乃自思惟众生有病不能听法。若闻法者病得销除。如来是大法王犹故现病。令大迦叶说七觉支法。我等云何不乐听法。彼诸天子作是思惟已即于佛法心得清净。以是利益因故。如来乃现背痛。令大迦叶说七觉支法。当知皆是善巧方便。实非宿障报应之事。又复何缘。昔有庄严幢婆罗门。于一时中向佛世尊发不善语。佛于尔时不生恚碍。所谓如来于天人四众大集会中。已得忍力具足随观诸境不生恚碍。如来尔时于诸众生。住平等心救护心安住心柔软心勇猛心。如来住是诸心时。有四千众生发阿耨多罗三藐三菩提心。以是利益因故。如来乃于庄严幢婆罗门不生恚碍。当知皆是如来善巧方便。实非宿障报应之事。复次智上。我念昔为菩萨时。彼提婆达多在在处处常随于我。何以故。彼提婆达多虽来我所伺求娆害。而能令我圆满六波罗蜜多。能令无量众生得大利益。所谓若时欲令众生得大快乐。我不能行布施摄法。提婆达多即来我所。乞妻子奴婢头目手足。我于尔时皆悉能舍。以能舍故彼作是言。如是名为难行之行。能令众生起发善根。我作是施时。有无量众生起爱乐心。于布施行得净信解。又复若时我以菩提愿力住净戒行。提婆达多来诣我所欲破净戒。我于尔时坚固不动不坏戒行。有无量众生见是事已悉住清净戒地。又复若时提婆达多。于我起其忿恚打骂。我于尔时不生嗔恨住忍辱心。有无量众生见是事已皆住忍行。所有精进禅定智慧等行。以提婆达多故我皆圆满。及令无量众生得大利益。智上。当知彼提婆达多虽于我所欲生娆害。而能令我增长善法。为诸众生作利益事。是故应知诸佛如来以善巧方便故。于诸众生随所施作。皆令不坏所有报应。又复如来。于众生界普遍观察。有某众生造如是因得如是报。随所观已设诸方便而为化度。智上。如我上说种种法门。皆是最胜善巧方便。如是法门不应于彼下劣善根众生前说。所以者何。所有众生虽种声闻缘觉相应善根。而亦不能于此最胜善巧方便中如理修学。何以故。非法器故。但当为彼修菩萨法者如实宣说。譬如盲人于夜分中虽有光明亦不能见一切境相。若有目人于其夜分得彼光明。而为照耀一切境相悉能观见。菩萨摩诃萨亦复如是。已修菩萨最胜行法。又能具足善巧方便。所有诸佛胜行。解脱法门悉能通达。智上。若有志求无上菩提诸善男子善女人。爱乐法故纵在百千由旬之外。若有宣说如是善巧方便法门处。而亦不怖遥远即来听受。何以故。若人闻是法已。即得广大光明所行清净。于佛法中离诸疑悔。是故当知所有天人四众之中。是法器者。即能爱乐听受此法。非法器者。虽复得闻不生爱乐。佛说是法时。有七万二千众生。发阿耨多罗三藐三菩提心

尔时尊者阿难。白佛言世尊。此经何名。我等云何受持。佛言阿难。此名善巧方便波罗蜜多正法。亦名一切秘密最上波罗蜜多正法。如是名字汝当受持。于后末世宣通流布。令诸众生得大利益

佛说此经已。阿难等诸声闻。智上等诸菩萨摩诃萨。乃至世间天人阿修罗乾闼婆等一切大众。闻佛所说皆大欢喜信受奉行

佛说大方广善巧方便经卷第四


佛说大迦叶问大宝积正法经卷第一

    No. 352 [Nos. 310(43), 350, 351]

佛说大迦叶问大宝积正法经卷第一

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大比丘众八千人俱。菩萨一万六千。及一生获得无上正等正觉。种种佛刹皆来集会

尔时尊者大迦叶波。在大众中安详而坐

尔时世尊。告迦叶言。有四种法。破坏菩萨智慧。迦叶白言。四种法者。其义云何。四种法者。一者于佛教法而生轻慢。二者于法师处憎嫉法师。三者隐藏正法令不见闻。四者他欲乐法数数障碍。嗔恚断善覆盖不说。诳赚他人唯自求利。迦叶。如是四种。是名坏灭菩萨智慧。我今于此。重说颂曰

  若人慢佛法　　憎嫉法师处
  乐法作隐藏　　求法而障碍
  嗔怒断善根　　覆法不为说
  爱乐诳赚他　　恒行自求利
  我说此四法　　断灭菩萨慧
  四法如是故　　汝等应当知

佛告迦叶波。有四最上法观。增长菩萨大智。迦叶白言。是义云何。此四法者。一者于佛教法深生尊重。二者于法师处勿生轻慢。三者如闻得法为他解说。起正直心不求一切利养。四者称赞多闻增长智慧。一向正心如闻受持。行真实行而不妄语。迦叶。此四种法。增长菩萨大智慧故。我今于此。重说颂曰

  尊重于佛法　　及彼法师处
  如闻为他说　　不求于利养
  亦不要称扬　　一向而求闻
  多闻生智慧　　如闻受持法
  持已依法行　　称法真实故
  是彼法师行　　口意无虚妄
  四法可为师　　得佛大智慧

佛告大迦叶。有四法具足。迷障菩萨菩提心。迦叶白言。云何四法迷障菩提心。此四法者。一者所有阿阇梨师及诸善友。行德尊重反生毁谤。二者他善增盛于彼破灭。三者若诸众生行大乘行。而不称赞妄言谤毁。四者弃背正心邪妄分别。如是迦叶。此四种法迷障菩萨菩提心我今于此。重说颂曰

  阇梨师善友　　行德俱尊重
  不行恭敬心　　反生于轻毁
  他善增炽盛　　破坏灭除他
  菩提大行人　　谤毁行轻慢
  弃背正真心　　邪妄而分别
  如斯四恶行　　迷障佛菩提
  是故此四法　　远离无上觉
  无此四过者　　最上得菩提

佛告迦叶波。有四法具足。令诸菩萨一切生处。出生菩提心。直至菩提而坐道场而无障碍。迦叶白言。云何四法。一者不为身命而行邪见妄言绮语。二者去除一切众生虚妄分别。三者为其佛使发起一切菩提种相。如实名称流遍四方。四者所有一切众生教化令得阿耨多罗三藐三菩提。各说今得。迦叶。如是四法具足菩萨。一切生处出生菩提心。中间无迷。直至菩提坐道场座。我今于此。重说颂曰

  不为自身命　　邪说及妄语
  心恒愍众生　　除妄及懈怠
  能作如来使　　及为众生师
  显发行菩提　　名闻遍四方
  教化诸众生　　令成无上觉
  安住此法中　　菩提心不退

佛告迦叶波。有四法具足。令诸菩萨已生未生善法皆令灭尽永不增长。迦叶白言。云何四法。一者世间所有深着我见。二者观察种族住着利养行咒力事。三者嗔恨菩萨偏赞佛教不普称赞。四者未闻难见经法闻之疑谤。如是迦叶。具此四法。令诸菩萨已生未生善法皆悉灭尽永不增长。我今于此。重说颂曰

  由此着我见　　皆令善法尽
  观察于种族　　咒术求利养
  毁于菩萨教　　而不普称赞
  未闻甚深经　　闻之生疑谤
  具行此四法　　不久善法尽
  是故诸菩萨　　行此四法者
  远离佛菩提　　譬如天与地

佛告迦叶波。有四法具足。令诸菩萨善法不灭得法增胜。迦叶白言。云何四法。一者愿闻其善不愿闻恶。求行六波罗蜜及菩萨藏。二者除去我见心行平等。令一切众生得法利欢喜。三者远离邪命得圣族欢喜。不说他人实不实罪。亦不见他过犯。四者若此深法自智不见。而不谤毁彼佛如来。如是而见如是而知。我不能知佛智无边种种无碍。如来为诸众生演说此法。如是迦叶。具此四法。令诸菩萨善法不尽得法增胜。我今于此。重说颂曰

  常愿闻其善　　非愿闻诸恶
  恒行六波罗　　而求菩萨藏
  断除于我见　　而行平等心
  普令诸众生　　得彼法利喜
  活住清净命　　复值圣种族
  他罪实不实　　终不而言说
  设睹诸过犯　　如同不见闻
  此法甚深奥　　少智不能知
  唯佛自明了　　而不生疑谤
  佛智广无边　　如来为众说
  行此四法者　　胜智法无尽
  安住此法中　　菩提不难得

佛告迦叶波。有四种法。生不正心离菩萨行。迦叶白言。云何四法。一者疑惑佛法心不爱乐。二者我见贡高嗔恚有情。三者他得利养贪爱憎嫉。四者于佛菩萨不生信敬。亦不称赞而复毁谤。迦叶如是四法。生不正心离菩萨行。我今于此。重说颂曰

  疑惑诸佛法　　作意不爱乐
  贡高我见增　　嗔恚众生故
  他所得利养　　贪爱起憎嫉
  于佛菩萨众　　心不生信受
  此四不正心　　远离菩萨行

佛告迦叶波。有四种法。令诸菩萨得柔软相。迦叶白言。云何四法。一者所得阿钵罗谛。得已发露终不覆藏远离过失。二者彼须真实所言诚谛。宁可尽于王位破坏富贵。散灭财利舍于身命。终不妄语所言真实。亦不令他言说虚妄。三者不发恶言毁谤蔑无一切众生。乃至善与不善斗诤相打禁系枷锁。如是之过亦不言说。恐自成罪得业果报。四者依彼信行深信一切诸佛法教心意清净。迦叶如是四法。令诸菩萨得柔软相。我今于此。重说颂曰

  所获阿钵罗　　恐成于过罪
  不敢自覆藏　　洗心而发露
  用意要真实　　所言须诚谛
  宁尽国王位　　舍命破资财
  不发妄语言　　弃背真实行
  亦不教他人　　令作虚妄事
  又不行毁谤　　蔑无一切众
  善与不善者　　乃至斗诤等
  终不说视他　　恐招自业果
  心住清净行　　信乐佛菩提
  此四佛宣扬　　众生宜亲近

佛告迦叶波。有四种法。令诸菩萨心意刚强。迦叶白言。云何四法。一者所闻最上胜法心不乐行。二者于法非法虽知净染。净法不行而行非法。三者不亲近阿阇梨及师法等。信受妄语不知食处。四者见诸菩萨具其胜德。都无恭敬我见轻慢。迦叶如是四法。令诸菩萨心意刚强。我今于此。重说颂曰

  闻彼最上法　　心意不乐行
  净法而不修　　非法生爱乐
  弃背阿阇梨　　不敬于师法
  受食处不知　　信行于妄语
  菩萨有胜德　　不生于尊重
  下劣我见增　　刚强心轻慢
  此四佛自宣　　我常亦远离

佛告迦叶波。有四种法。令于菩萨知见明了。迦叶白言。云何四法。一者闻善乐行闻恶乐止。知法真实弃背邪伪受行正道。二者远离毁谤纯善相应。美言流布众所爱敬。三者亲近师教知彼食处。调伏诸根戒定不间。四者自得菩提不舍众生。行实慈愍令彼爱乐广大真德。迦叶。如是四法。令于菩萨知见明了。我今于此。重说颂曰

  闻善乐欲行　　闻恶心欲止
  业背邪伪因　　受行八正道
  毁谤恒远离　　善业得相应
  流布善言音　　令众生爱重
  亲近于师教　　知彼食来处
  制伏取境根　　安住于戒定
  虽得佛菩提　　不舍有情界
  行彼真实慈　　令求无上德
  此四佛所宣　　速得善逝果

佛告迦叶波。菩萨有四种违犯。迦叶白言。云何四种。一者众生信根未熟而往化他。菩萨违犯。二者下劣邪见众生广说佛法。菩萨违犯。三者为小乘众生说大乘法。菩萨违犯。四者轻慢正行持戒众生。摄受犯戒邪行众生。迦叶。如是四种。菩萨违犯。我今于此。重说颂曰

  众生信未熟　　而往化于彼
  下劣邪有情　　为彼广说法
  于彼声闻处　　分别大乘法
  轻慢正行人　　摄受破戒者
  知此四违犯　　菩萨须远离
  依此四法行　　菩提不成就

佛告迦叶波。有四种法成菩萨道。迦叶白言。云何四法。一者于一切众生心行平等。二者于一切众生用佛智教化。三者于一切众生演说妙法。四者于一切众生行正方便。迦叶。如是四法。成菩萨道。我今于此。重说颂曰

  于彼群生类　　恒行平等心
  教导诸有情　　令入如来智
  常演微妙法　　救度一切人
  安住真实中　　是名正方便
  此四平等法　　佛自恒宣说
  依教彼恒行　　成就菩萨道

佛告迦叶波。有四种法。为菩萨怨而不可行。迦叶白言。云何四法。一者乐修小乘自利之行。二者行辟支佛乘浅近理法。三者随顺世间咒术伎艺。四者用世智聪辩。集彼世间虚妄无利之法。迦叶。如是四法。为菩萨冤不可同行。我今于此。重说颂曰

  若行声闻乘　　出家自利行
  及彼辟支迦　　证悟浅理行
  耽着世间艺　　伎术禁咒等
  复用世智辩　　虚集无利法
  诳赚于众生　　不到真实际
  此四菩萨行　　善根皆灭尽
  冤家不同行　　佛言宜远离

佛告迦叶波。有四种法为菩萨善友。迦叶白言。云何四法。一者所有求菩提道者。为菩萨善友。二者作大法师。为菩萨善友。三者以闻思修慧。出生一切善根者。为菩萨善友。四者于佛世尊求一切佛法者。为菩萨善友。迦叶如是四法。为菩萨善友。我今于此。重说颂曰

  求成菩提者　　佛子亲善友
  作大说法师　　显发闻思慧
  教化诸众生　　出生五善根
  恒为善逝子　　当获正觉道
  佛说此四法　　不迷于正行
  令得大菩提　　是名真善友

佛告迦叶波。有四种法。为菩萨影像。迦叶白言。云何四法。一者为利养不为法。二者为要称赞不为戒德。三者自利求安不利苦恼众生。四者于实德能不生分别乐欲。迦叶。如是四法。为菩萨影像。我今于此。重说颂曰

  广求于利养　　不为听受法
  爱乐人赞扬　　弃舍于德业
  一向求自安　　不愍众生苦
  于彼实德能　　无乐无分别
  如是四种法　　佛说为影像
  汝诸菩萨众　　各各宜远离

佛告迦叶波。有四种法。为菩萨实德。迦叶白言。云何四法。一者入空解脱门。信业报无性。二者入无我无愿门。虽得涅槃。恒起大悲乐度众生。三者于大轮回巧施方便。四者于诸有情虽行给施不求果报。迦叶。如是四法。为菩萨实德。我今于此。重说颂曰

  入彼空解脱　　信观业无性
  无我无愿门　　安住慈愍行
  虽证涅槃空　　乐度众生故
  于彼轮回中　　巧设诸方便
  广济于群生　　不希于福报

佛告迦叶波。有四种法。为菩萨大藏。迦叶白言。云何四法。一者于诸佛所恭敬供养。二者恒行六度大波罗蜜多。三者尊重法师心不退动。四者乐居林野心无杂乱。迦叶。如是四法。为菩萨大藏。我今于此。重说颂曰

  于彼诸佛所　　供养一切佛
  大乘六度中　　所行波罗蜜
  尊重说法师　　承事心无退
  常居林野中　　清净无杂乱
  此四善逝说　　佛子大法藏

佛告迦叶波。有四种法。远离菩萨魔道。迦叶白言。云何四法。一者所行诸行不离菩提心。二者于一切众生心无恼害。三者于一切法明了通达。四者于一切众生不生轻慢。迦叶。如是四法。远离菩萨魔道。我今于此。重说颂曰

  所行众善行　　不离菩提心
  于彼诸群生　　恒时无恼害
  诸法善通达　　于生绝轻慢
  此四善逝说　　远离诸魔道
  是人依此行　　得彼真空际

佛告迦叶波。有四种法。集菩萨一切善根。迦叶白言。四法云何。一者乐住林间寂静宴默。二者布施爱语利行同事摄诸众生。三者乐求妙法弃舍身命。四者闻义不足集诸善根勤行精进。迦叶。如是四法。能集菩萨一切善根。我今于此。重说颂曰

  乐住闲寂处　　宴默离喧烦
  四摄御众生　　令登于觉路
  勤求于妙法　　弃舍于身命
  精进集善根　　闻法心无足
  佛说此四行　　出生无边善

佛告迦叶波。有四种法。生菩萨无量福德。迦叶白言。云何四法。一者恒行法施心无吝惜。二者起大悲心救护破戒众生。三者化诸有情发菩提心。四者于下劣恶人忍辱救护。迦叶。如是四法。出生菩萨无量福德。我今于此。重说颂曰

  广说诸妙法　　清净心无吝
  毁禁诸有情　　救护垂慈愍
  令彼众生类　　发于净觉心
  种种劣恶人　　救护行忍辱
  菩萨及诸佛　　同行此四行

佛告迦叶波。有四种法。能破菩萨意地无明烦恼。迦叶白言。云何四法。一者所行戒行具足无犯。二者受持妙法身心无倦。三者随其意解传施法灯。四者礼敬投诚称扬佛德。迦叶如是四法。能破菩萨意地无明烦恼。我今于此。重说颂曰

  坚持具足戒　　意地无缺犯
  妙法恒受持　　昼夜心无倦
  所解诸佛教　　随意施法灯
  称赞一切佛　　投诚恭敬礼
  智者行此四　　能断无明地
  一切诸佛心　　依此得菩提

佛告迦叶波。有四种法。生菩萨无碍智。迦叶白言。云何四法。一者所有法施。二者受持妙法。三者不害他人。四者亦不轻慢。迦叶如是四法。生菩萨无碍智。我今于此。重说颂曰

  所行妙法施　　令彼得受持
  不嫉众生学　　尊重于持戒
  四法除宿罪　　获成最上觉
  依此得菩提　　出生无碍智
  复别十二行　　智者得菩提
  成就甘露味　　所有诸众生
  而具深法眼　　解说读诵持
  佛说于彼人　　获福无有量
  所有恒河沙　　俱胝佛刹土
  满中盛七宝　　供养一切佛
  彼福亦无量　　若人念此法
  四句伽他经　　福德胜于彼
  复次迦叶波　　若持此四句
  未名菩萨者　　得名为菩萨
  说此四法中　　具足十善行
  依法平等心　　是故名菩萨

大迦叶问大宝积正法经卷第一佛说大迦叶问大宝积正法经卷第二

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

佛告迦叶波。若诸菩萨。具足三十二法。名为菩萨。迦叶白言。云何三十二法。所为利益一切众生。一切智智种子。不量贵贱令得智慧。为一切众生低心离我。真实愍念其意不退。善友恶友心行平等。虽到涅槃思念爱语。先意问讯愍见重担。于诸众生恒起悲心。常求妙法。心无疲厌。闻法无足。常省己过不说他犯。具诸威仪恒发大心。修诸胜业不求果报。所生戒德灭诸轮回。令诸有情道心增进。一切善根皆悉集行。虽行忍辱精进。如入无色禅定。智慧方便善解总持。恒以四摄巧便受行。持戒犯戒慈心不二。常处山林乐问深法。世间所有种种厌离。爱乐出世无为果德。远离小乘正行大行。弃舍恶友亲近善友。于四无量及五神通。皆悉通达已净无知。不着邪正如实依师。发菩提心纯一无杂。迦叶。如是具足三十二法。是则名为菩萨。我今于此。重说颂曰

  利益诸众生　　欲行清净行
  令生一切智　　不择于贵贱
  同入如来慧　　真实愍众生
  心意不退转　　善友及恶友
  平等观于彼　　虽到于涅槃
  爱语先问讯　　忧愍于重担
  及彼诸众生　　不断于大悲
  求法心无苦　　闻义常不足
  恒省自身非　　不讥他人犯
  具修众威仪　　而起大乘行
  不求于果报　　所持诸戒德
  断灭于轮回　　令彼诸有情
  远害增道意　　忍辱集善根
  精进修诸行　　如入无色定
  智慧诸方便　　总持而善解
  四摄恒受行　　持犯二俱愍
  常处于林间　　恒乐闻深法
  厌离于世间　　爱敬无上果
  远离声闻乘　　而修大乘行
  弃舍于恶朋　　亲近于善友
  五通四无量　　智慧悉通达
  清净绝无知　　不着于邪正
  依师究真实　　纯一无杂行
  佛说观行法　　先发菩提心
  若此三十二　　善逝当演说
  菩萨具足行　　得佛甘露味

佛告迦叶波。我为菩萨。说譬喻法。令彼知见为菩萨德。迦叶白言。其义云何。迦叶。譬如地大与一切众生。为其所依令彼长养。而彼地大于其众生无求无爱。菩萨亦然。从初发心直至道场。坐得成菩提。于其中间。运度一切众生无爱无求。亦复如是。我今于此。而说颂曰

  譬如地大　　与诸众生　　依止长养
  于彼众生　　无求无爱　　菩萨亦尔
  从初发心　　直至道场　　成无上觉
  运度有情　　无求无爱　　无冤无亲
  平等摄受　　令得菩提

佛告迦叶波。譬如水界润益一切药草树木。而彼水界于其草木无爱无求。迦叶。菩萨亦然。以清净慈心。遍行一切众生。润益有情白法种子。令得增长无爱无求。我今于此。而说颂曰

  譬如水界　　润益一切　　药草树木
  令得生长　　无爱无求　　菩萨亦尔
  以净慈心　　遍及有情　　次第普润
  净种增长　　破大力魔　　得佛菩提

佛告迦叶。譬如火界成熟一切谷麦苗稼。火界于彼无爱无求。迦叶。菩萨亦尔。以大智慧成熟一切众生善芽。我今于此。而说颂曰

  譬如火界　　成熟一切　　五谷苗稼
  而彼火界　　于其苗稼　　无求无爱
  菩萨亦尔　　以智慧火　　成熟一切
  众生善芽　　菩萨于彼　　无求无爱

佛告迦叶。譬如风界遍满一切诸佛刹土。迦叶。菩萨亦尔。以善方便遍众生界令解佛法。我今于此。而说颂曰

  譬如风界　　随自势力　　普遍佛刹
  诸菩萨众　　亦复如是　　以善方便
  为其佛子　　说最上法

佛告迦叶。譬如魔冤领四军兵。欲界诸天不能降彼。迦叶。菩萨亦尔。得意清净一切众魔不能惑乱。我今于此。而说颂曰

  譬如魔冤　　领四军兵　　欲界诸天
  不能降彼　　菩萨亦尔　　得意清净
  一切众魔　　不可惑乱

佛告迦叶。譬如白月渐渐增长乃至圆满。迦叶。菩萨亦尔。以无染心求一切法乃至圆满。我今于此。而说颂曰

  譬如白月　　渐渐增长　　直至圆满
  菩萨亦尔　　以无染心　　求修诸善
  渐渐增进　　白法圆满

佛告迦叶。譬如日出放大光明。照彼世间无不朗然。迦叶。菩萨亦尔。放智慧光照诸众生。无不开悟。我今于此。而说颂曰

  譬如日出　　照彼世间　　一切物像
  无不朗然　　菩萨亦尔　　放智慧光
  照诸有情　　无不开解

佛告迦叶。譬如师子兽王有大威德。于彼一切所行之处不惊不怖。迦叶。菩萨亦尔。安住多闻戒德。如是一切所往之处不惊不怖。我今于此。而说颂曰

  师子兽王　　威德勇猛　　所行之处
  心无惊怖　　菩萨亦尔　　安住多闻
  持戒智慧　　于彼世间　　所行之处
  离诸怖畏

佛告迦叶。譬如龙象有大势力。担负一切重物而无疲苦。迦叶。菩萨亦尔。担负一切众生五蕴诸苦。不得其苦。我今于此。而说颂曰

  譬如龙象　　有大势力　　身负重物
  而不疲苦　　菩萨亦尔　　担负众生
  五蕴诸苦　　亦无疲苦

佛告迦叶。譬如莲华生长水中淤泥浊水而不能染。迦叶。菩萨亦尔。虽生世间。世间杂染终不能着。我今于此。而说颂曰

  譬如莲华　　出生水中　　浊水淤泥
  而不可染　　菩萨亦尔　　虽生世间
  种种杂染　　而不能着

佛告迦叶。譬如有人方便断树不断树根。而于后时复生大地。迦叶。菩萨亦尔。以方便力断彼烦恼。不断彼种以大悲善根复生三界。我今于此。而说颂曰

  譬如有人　　以其方便　　而断树身
  不断树根　　如是后时　　复生大地
  菩萨亦尔　　以善方便　　断彼烦恼
  不断彼种　　以大悲故　　复生三界

佛告迦叶。譬如诸方所流河水。皆归大海同一碱味。迦叶。菩萨亦尔。所有一切善根。种种利益回向菩提。与彼涅槃同归一味。我今于此。而说颂曰

  譬如一切　　江河诸水　　皆入大海
  同一碱味　　菩萨亦尔　　所有一切
  善根利益　　回向菩提　　及彼真际
  同归一味

佛告迦叶。譬如四大天王及忉利天众。要彼安住妙高之山。迦叶。菩萨亦尔。为一切智所修善法。要彼安住菩提大心。我今于此。而说颂曰

  譬如四王　　及帝释众　　要彼安住
  妙高之山　　菩萨亦尔　　为一切智
  所修善法　　安住菩提

佛告迦叶。譬如国王欲行王事须假宰臣。迦叶。菩萨亦尔。欲为佛事。须假智慧方便。我今于彼。而说颂曰

  譬如国王　　欲行王事　　须仗宰臣
  而得成就　　菩萨亦尔　　欲为佛事
  假方便慧　　决定成就

佛告迦叶。譬如晴天无其云雾。于彼世间终无降雨之相。迦叶。菩萨亦尔。寡闻小智于诸有情。终无说法之相。我今于此。而说颂曰

  譬如虚空　　晴无云雾　　于彼世间
  终不降雨　　菩萨亦尔　　寡闻少智
  于其有情　　无说法相

佛告迦叶。譬如虚空起大云雷。必降甘雨成熟苗稼。迦叶。菩萨亦尔。于其世间起慈悲云。降妙法雨成熟众生。我今于此。而说颂曰

  譬如虚空　　云雷忽起　　必降甘泽
  成熟苗稼　　菩萨亦尔　　普覆慈云
  降霔法雨　　成熟有情

佛告迦叶。譬如转轮圣王有其七宝恒随王行。迦叶。菩萨亦尔。有七觉支恒随菩萨。我今于此。而说颂曰

  譬如世间　　转轮圣王　　所有七宝
  恒随王行　　菩萨亦尔　　有七觉支
  所到之处　　随逐菩萨

佛告迦叶。譬如摩尼宝珠得多富贵。价直迦哩沙波拏。百千富贵。迦叶。菩萨亦尔。得多富贵价直声闻缘觉百千富贵。我今于此。而说颂曰

  譬如摩尼宝　　富贵广得多
  迦哩沙波拏　　百千不可比
  菩萨亦如是　　富贵倍弘多
  辟支及声闻　　百千亦难比

佛告迦叶。譬如忉利天众。若住杂林者。受用富贵平等无二。迦叶。菩萨亦尔。若住清净心者。为一切众生正直方便平等无二。我今于此。而说颂曰

  譬如忉利天　　住彼杂林者
  受用于富贵　　平等无有二
  菩萨亦如是　　住心清净者
  正直为群生　　方便亦无二

佛告迦叶。譬如有人妙解禁咒善知毒药。一切毒药不能为害。迦叶。菩萨亦尔。具大智慧善行方便。一切烦恼不能为害。我今于此。而说颂曰

  譬如世间人　　善知药禁咒
  一切毒药等　　不能为损害
  菩萨亦如是　　若具方便慧
  一切烦恼毒　　不能为损害

佛告迦叶。譬如世间粪壤之地。能生肥盛甘蔗。迦叶。菩萨亦尔。若处烦恼粪地。能生一切智种。我今于此。而说颂曰

  譬如粪壤地　　出生于甘蔗
  倍常而肥盛　　菩萨处烦恼
  出生一切智　　其义亦如是

佛告迦叶。譬如有人不学武艺。若执器仗宁解施设。迦叶。菩萨亦尔。先未闻法寡识机药。若执智见何辩邪正。佛告迦叶。譬如[穴/(采-木+田)]师欲烧瓦器须用大火。迦叶。菩萨亦尔。欲为愚迷众生开发智慧。须用佛法智火。迦叶。是故此大宝积正法。令菩萨修学受持得解法行

迦叶白言。菩萨云何受持见正法行。迦叶。如自观身无我无人无众生无寿命无名无相。无观行故。迦叶。如此说名正观影像中法。复次迦叶。如实正观影像中法。迦叶。云何影像中法。如正观色。观彼无常亦非无常。如是受想行识。常与无常无定无不定。迦叶。此说如实观察影像中法

复次迦叶。如实观察影像中法。所有地界。常与无常无定无不定。如是水界火界风界空界识界。亦复如是无定无不定。迦叶。此说如实观察影像中法

复次迦叶。所有眼处常无常性无定无不定。如是耳处鼻处舌处身处意处常无常性。无定无不定。迦叶。此说影像中法如实观察

复次迦叶。此定一法。此不定二法。若彼二法于是色中。不见不住无微无识亦无相故。迦叶。此说影像中法如实观察

复次迦叶。我见一法无我二法。若彼二法于是色中。不见不住无微无识。亦无相故。迦叶。此说影像中法如实观察

复次迦叶。此真实心一法。此不实心二法。迦叶。二法所在无心无觉无意无识。迦叶。此说影像中法如实观察

复次迦叶。善不善。世间出世间。有罪无罪。有漏无漏。有为无为。有烦恼无烦恼。如是一切法。迦叶。此生法一此灭法二。若二法中无集无散不可求得。迦叶。此说影像中法如实观察

复次迦叶。此有法一此无法二。若此二法于是色中。不见不住无微无识亦无相故。迦叶。此说影像中法如实观察

复次迦叶。此轮回一法。此涅槃二法。若彼二法于是色中。不见不住无微无识。迦叶。此说影像中法如实观察

复次迦叶。我说汝等。无明缘生行。行缘生识。识缘生名色。名色缘生六入。六入缘生触。触缘生受。受缘生爱。爱缘生取。取缘生有。有缘生老死。老死缘生忧悲苦恼。迦叶。如是集得此一大苦蕴。所有无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死灭。老死灭忧悲苦恼得灭。如是得此一大苦蕴灭。迦叶。若以智观明无明等无此二相。迦叶。此影像中法如实观察

复次迦叶。如是行行灭。如是识识灭。如是名色名色灭。如是六入六入灭。如是触触灭。如是受受灭。如是爱爱灭。如是取取灭。如是有有灭。如是生生灭。如是老死老死灭。如是智观生性灭。性无二相故。迦叶。离此二相。此说影像中法如实观察

复次迦叶。应当正观影像中法。彼法非空。亦非不空。如是空法无法相非无法相。法相即空相。空相即无相。无相即无愿。所以者何。无所愿作故。无相即空相。如是行者若法未生不生。法未生故。如彼法生。彼亦不生。生已谢故。如是无生生离取故。法无自性。无性即空。如是正观此说影像中法

复次迦叶。补特伽罗非破坏空。即体是空。本非有故。非前际空非后际空。现在即空。迦叶白言。彼补特迦罗。我今觉悟知彼是空。破坏我故。一切皆空此法如是。佛言。迦叶汝言非也。迦叶宁可见彼补特迦罗如须弥山量。勿得离我而见彼空。何以故。破我断空执一切空。我则说为大病。而不可救

佛告迦叶。譬如人病其病深重。而下良药令彼服行。药虽入腹病终不差。迦叶。此人得免疾不。迦叶白言。不也世尊。佛言。于意云何。世尊此人病重故。不可疗也。佛言。迦叶彼着空者。亦复如是。于一切处深着空见我即不医。我今于此而说颂曰

  譬如重病者　　令彼服良药
  虽服病不退　　彼人不可疗
  着空亦如是　　于彼一切处
  深着于空见　　我说不可医

佛告迦叶。譬如愚人观彼虚空。而生怕怖捶胸悲哭。所以者何。恐虚空落地损害于身。佛言。迦叶彼虚空能落地不。迦叶云不也。佛言迦叶。若彼愚迷沙门婆罗门亦复如是。彼闻空法心生惊怖。所以者何。若空我大心依何行用。我今于此而说颂曰

  譬如愚迷人　　于空生怕怖
  悲哭而远行　　恐虚空落地
  虚空无所碍　　不损于众生
  此人自愚迷　　妄生于惊怖
  沙门婆罗门　　愚见亦如是
  闻彼诸法空　　心生于怖畏
  若空破坏我　　依何生受用

佛告迦叶。譬如画师自画丑恶夜叉。画已惊怖迷闷仆倒。迦叶。彼凡夫众生亦复如是。自作色声香味触法。作已迷彼堕落轮回。我今于此而说颂曰

  譬如工画师　　画彼恶夜叉
  于彼自惊怖　　迷闷仆倒地
  凡夫亦复然　　自着于声色
  迷彼不觉知　　堕落轮回道

佛告迦叶。譬如幻士变作幻化。是彼幻化能变幻士。迦叶。相应行比丘亦复如是。而自发意。如是说一切皆空。彼虚空无实亦能如是说。我今于此而说颂曰

  譬如于幻士　　能变于幻化
  而彼幻化人　　亦能变幻士
  相应行比丘　　发意亦如是
  说彼一切空　　无实空亦说

佛告迦叶。譬如二木相钻风吹出火。火既生已烧彼二木。迦叶如实正观亦复如是。于正见道生彼慧根。慧根既生烧彼正观。我今于此而说颂曰

  譬如钻二木　　风吹生彼火
  火生刹那间　　而复烧二木
  正观亦如是　　能生于慧根
  生彼一刹那　　还复烧正观

佛说大迦叶问大宝积正法经卷第二佛说大迦叶问大宝积正法经卷第三

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

尔时世尊复以譬喻更明斯义

佛告迦叶。譬如灯光能破一切黑暗。而彼黑暗从何而去。非东方去。非南方去。非西方去。非北方去。去亦非去。来亦非来

迦叶。复次灯光亦非我。能破得黑暗。又若非黑暗何显灯光。迦叶。灯光黑暗本无自性。此二皆空无得无舍。迦叶。如是智慧亦复如是。有智若生无智即舍。而彼无智归于何去。非东方去。非南方去。非西方去。非北方去。去既非去。来亦非来

迦叶。复次有智若生无智即舍。非彼有智我能破坏无智。又若无智本无有智何显。迦叶有智无智俱无自性。此二皆空无得无舍。我今于此而说颂曰

  譬如于灯光　　能破于黑暗
  彼暗灭谢时　　诸方无所去
  若复此灯光　　非暗不能显
  二俱无自性　　无性二俱空
  智慧亦如是　　有智若生时
  无智而自舍　　此二若空花
  俱无有自性　　取舍不可得

佛告迦叶。譬如空舍无其户牖。经百千年无其人物。其室冥暗忽有天人。于彼舍中燃其灯明。迦叶于意云何。如是黑暗我经百千年住此。我今不去有此事不。迦叶答云。不也世尊。彼黑暗无力灯光若生决定须去。佛言迦叶。彼业烦恼亦复如是。经百千劫住彼识中。或彼行人于一昼夜。正观相应生彼慧灯。迦叶如是圣者慧根。若生此业烦恼定无所有。我今于此而说颂曰

  如舍百千年　　无人无户牖
  忽有天及人　　于彼烧灯火
  如是久住暗　　刹那而灭谢
  是彼舍黑暗　　不言我久住
  于此而不去　　业识烦恼集
  其义亦如是　　虽住百千劫
  本性不真实　　行人昼夜中
  正入如实观　　慧灯晃耀生
  彼等烦恼集　　刹那不可住

佛告迦叶。譬如虚空不住种子。迦叶如是。若彼行者坚着断见。过去已灭未来非有。何住佛法种子。我今于此而说颂曰

  譬如太虚空　　无涯无有量
  若人于空中　　何处植种子
  断见亦如是　　过去不可有
  未来亦不生　　现无佛法种

佛告迦叶。譬如粪满大地。可种一切种子。迦叶。如是业烦恼粪满于世间。可种一切佛法种子。我今于此而说颂曰

  譬如大地粪　　随处可种植
  众生烦恼粪　　周遍于世间
  佛子若亲近　　可下佛法种

佛告迦叶。譬如碱卤陆地不可种于莲华。迦叶。如是无行性者本自非有。未来不生何得菩提之种。我今于此而说颂曰

  譬如碱陆地　　不可出莲华
  于彼泥水中　　出生甚氛馥
  无性亦如是　　过未本来无
  终不生佛种

佛告迦叶。譬如粪壤之地可生莲华。迦叶。如是烦恼邪行众生亦可生其佛法种智。我今于此而说颂曰

  譬如泥粪地　　而可生莲华
  邪行业众生　　亦生佛法种

佛告迦叶。譬如四大海水弥满无边。迦叶。如是见彼菩萨所作善根能遍法界。我今于此而说颂曰

  譬如四大海　　弥满广无边
  菩萨亦如是　　善根遍法界

佛告迦叶。譬如天人以一毛端百分取一。于彼毛头滴微细水。欲成俱胝四大海。迦叶。如是见彼声闻。所作微善而求无上。我今于此而说颂曰

  譬如人毛端　　百分而取一
  于彼滴微水　　欲成俱胝海
  声闻亦如是　　以己微浅智
  所作自善根　　求成无上觉

佛告迦叶。譬如芥子内虫食彼芥子。见芥子内谓若虚空。迦叶。如是声闻所修小智。见彼生空亦复如是。我今于此而说颂曰

  譬如芥子内　　而有食芥虫
  于里无碍处　　见彼谓虚空
  声闻所修智　　证彼一分空
  所见而不大　　其义亦如是

佛告迦叶。譬如有人见十方世界虚空无边。迦叶。如是菩萨无碍大智所见法界亦无边际。我今于此而说颂曰

  譬如虚空界　　十方无有涯
  一切诸世间　　依彼无障碍
  菩萨亦如是　　所起最上智
  照见法界空　　无边无所得

佛告迦叶。譬如刹帝利受灌顶王。彼王皇后私于庶人后生其子。迦叶于意云何。彼所生之子得名灌顶王子不。迦叶白言不也。世尊告言。迦叶。彼得无生法界声闻。我是如来灌顶之子如是亦然。我今于此而说颂曰

  刹帝王皇后　　而私于庶人
  彼后生其男　　不名灌顶子
  声闻亦如是　　离欲证无生
  唯行于自利　　非是于如来
  灌顶法王子　　佛子行二利

佛告迦叶。譬如刹帝利受灌顶王。有近侍婢王所爱幸。彼后生子。迦叶于意云何。此婢生之子得名王子不。迦叶答云。此是王子。迦叶如是初发心菩萨。虽道力微劣化彼众生。未免轮回亦得名为如来之子。我今于此而说颂曰

  譬如轮王婢　　为王之爱幸
  而后生其男　　亦是刹帝子
  菩萨亦如是　　初发菩提心
  德行而羸劣　　方便化众生
  虽未出三界　　所作称佛心
  得名真佛子

佛告迦叶。譬如轮王生其千子。大力勇猛辩才端正。须得轮王相具足。彼所童子内。若无一子具有轮王相者。彼转轮王不作亲子之想。迦叶。如是如来会下有百千俱胝声闻围绕。若无一菩萨相者。如来亦不作子想。我今于此而说颂曰

  譬如转轮王　　所生千太子
  若无一童子　　具彼轮王相
  此乃无王分　　王无自子想
  佛子亦如是　　虽有千俱胝
  声闻众围绕　　无一菩萨相
  善逝观彼人　　不为佛子想

佛告迦叶。譬如转轮圣王。所有皇后怀娠七夜必生童子。具轮王相。彼在胎藏迦罗罗大。未有根形。虽未成形而有天人发心爱重。非爱彼子勇猛大力。于意云何。重彼轮王王种不断。迦叶。亦复如是。初发心菩萨根虽未熟未免轮回。乐行佛法。彼过去佛见生其爱重。于彼正观八解脱阿罗汉。而不爱重。何以故。为彼初心菩萨佛种不断故。我今于此而说颂曰

  譬如转轮王　　皇后怀娠妊
  七日未成形　　天人生爱护
  非重勇猛力　　而重轮王种
  菩萨亦如是　　初发菩提心
  欲度轮回故　　过去诸如来
  于彼而恭敬　　此人绍佛事
  于诸声闻众　　正观八解者
  不生于敬爱　　无彼成佛分

佛告迦叶。譬如假摩尼琉璃珠。聚如妙高山。不及一真摩尼琉璃宝。迦叶。如是假使一切声闻辟支佛。不能及一初发菩提心菩萨。我今于此而说颂曰

  譬如假琉璃　　及彼摩尼珠
  积聚如须弥　　不及真摩尼
  琉璃之一宝　　菩萨亦如是
  假使于声闻　　及彼缘觉众
  其数如微尘　　不及初发心
  求彼菩提者　　菩萨之一人

佛告迦叶。譬如迦陵频伽鸟。住彼卵中之时。早能与彼一切飞禽而皆不同。迦叶于意云何。当发一切美妙音声故。迦叶。如是彼初发心菩萨虽住业烦恼无明藏中。早与一切声闻辟支佛而不可同。迦叶于意云何。彼有回向善根说法方便故。我今于此而说颂曰

  譬如频伽鸟　　住彼卵子中
  虽未见身形　　而与诸禽异
  当发美妙音　　令人常爱乐
  佛子亦如是　　初发菩提心
  未出烦恼藏　　一切辟支佛
  及彼声闻众　　亦复不能比
  回向大安乐　　方便利有情
  无垢慈悲意　　能宣微妙音

佛告迦叶。譬如轮王皇后。所生王子具足轮王福相。一切国王及诸人民悉皆归伏。迦叶。如是初发心菩萨。天上人间一切有情悉皆归伏。我今于此而说颂曰

  譬如转轮王　　皇后所生子
  虽为童子身　　具足王福相
  国王及臣民　　一切皆归向
  菩萨亦如是　　初发菩提心
  佛子相具足　　一切诸世间
  天人众生类　　清净心归向

佛告迦叶。譬如大雪山王出生上好药草。能治一切诸病。修合服食。无复心疑决定得差。迦叶。如是若彼菩萨所有智药能疗一切众生烦恼诸病。菩萨以平等心普施一切有情。服者无复疑惑病即除愈。我今于此而说颂曰

  譬如大雪山　　出生上妙药
  疗治一切病　　若有服之者
  获差勿复疑　　佛子亦如是
  出生妙智药　　能疗一切人
  烦恼生老病　　平等而赐之
  所有服食者　　无疑决定差

佛告迦叶。譬如有人归依初月。如是圆月而不归依。迦叶。如是我子有其信力。归命菩萨不归命如来。所以者何。为彼如来从菩萨生。若声闻辟支佛从如来生。非如菩萨故。我今于此而说颂曰

  譬如此有情　　归命于初月
  如是圆满月　　而彼不归依
  我子亦如是　　归依于菩萨
  不归向世尊　　为具大智力
  出生如来身　　非彼声闻类
  智慧微劣故　　依彼如来生

佛告迦叶。譬如文字之母。具能包含一切义论等事。迦叶。如是初发心菩萨具能绾摄一切诸佛。化行无上智因。我今于此而说颂曰

  譬如文字母　　人间与天上
  义论及辩才　　皆因此建立
  菩萨亦如是　　初发菩提心
  具足佛地智　　及诸方便行

佛告迦叶。譬如世人未有舍离明月归命星像。迦叶。如是无有受我戒者。舍离菩萨归命声闻。我今于此。而说颂曰

  譬如世间人　　于月而舍离
  而欲归依星　　此事未曾有
  如是我弟子　　其义亦复然
  若受我戒者　　不归于菩萨
  而欲向声闻　　其事甚希有

佛告迦叶。譬如假琉璃珠于彼天人世间终无利用。若真琉璃珠摩尼宝于其世间有大利用。迦叶如是。若彼声闻具足戒学。具一切头陀行三摩地门。终不能得坐菩提道场成阿耨多罗三藐三菩提。我今于此而说颂曰

  譬如假琉璃　　见彼体清净
  于天人世间　　为事无利用
  若彼真琉璃　　及彼摩尼宝
  体性有其殊　　为事具大用
  如是彼声闻　　虽具头陀行
  持戒及多闻　　一切三摩地
  不能降四魔　　而坐菩提座
  得成于善逝　　非如菩萨故

佛告迦叶。譬如真琉璃摩尼宝作事用时价直百千迦哩沙波拏。迦叶。如是若彼菩萨所植众德。作事用时多彼声闻辟支佛百千迦哩沙波拏之数。我今于此而说颂曰

  譬如真琉璃　　及彼摩尼宝
  作彼事用时　　价直百千数
  迦哩沙波拏　　佛子亦如是
  植众德本行　　事用利众生
  多彼声闻人　　及彼辟支佛
  迦哩沙波拏　　其数亦如是

尔时世尊。复次说言。尊者大迦叶。所有国土孛星现时头黑偃寐。令彼国土灾难竞起得于苦恼。迦叶。若彼国土如有菩萨。是诸灾难速得消除无复苦恼。是故迦叶。菩萨之行。广集一切善根。为利众生故。又彼菩萨。所有智药流通四方。医彼一切众生烦恼等病。真实不虚。迦叶白言。以何等药医何等病。迦叶。众生所有贪嗔痴病皆自缘生。以无缘慈观彼一切惑业相。有理无本自无生今亦无相。欲界色界及无色界寂灭亦然。又灭一切颠倒。何等颠倒。即四颠倒。一者为彼有情于彼无常而计常故。令想一切皆是无常。二者于其苦处而计为乐。令想一切皆是其苦。三者无我计我。令想一切法皆无我故。四者不净计净。令想一切皆非净故。唯此涅槃具彼四德。又复施设四念处。令彼有情观身无其所有。能破我见。观受无受所得。破彼我见。观心无心可得。亦除我见执故。观法无法可得。破彼法我执故。以四正断于修断事。修善勤修。断恶勤断以四神足成就通力。以五根五力。治彼不信懈怠失念散乱痴等。以七觉支治一切愚痴。以八圣道。治彼一切无知八邪等过。迦叶。此说名为真实医法。迦叶观此菩萨。于阎浮提内。医病人中最为第一。迦叶。所有三千大千世界众生。为护自命。见彼菩萨如见医王。迦叶白言。如是住邪见者以何药疗。唯愿解说令彼了知。迦叶。彼菩萨救疗众生。非用世间之药。以出世间一切善根无漏智药传流四方。医彼一切众生妄想之病。真实不虚。迦叶白言。云何名为出世间智。迦叶。彼智从因缘种生离诸分别。无我无人无众生无寿命。如是智法于空无著。迦叶。汝等正求心莫惊怖发精进心。彼如是求如是住心。云何住心。云何不住心。有过去未来现在于何而住。迦叶。过去已灭。未来未至。现在无住。迦叶。又此心法非在内。非在外。亦非中间。迦叶又此心法离众色相。无住无著而不可见。迦叶。过去一切佛不见。未来一切佛不见。现在一切佛不见。迦叶白言。若过去未来现在一切佛不见者。云何彼心有种种行相。迦叶。彼心无实从妄想生。譬如幻化。种种得生为虚妄见。迦叶白言。虚妄不实。其喻云何。佛言迦叶。心如浮泡生灭不住。心如风行而不可收。心如灯光因缘和合。心如虚空得虚妄烦恼。心如掣电刹那不住。心如猿猴攀缘境界。心如画师作种种像。心念念不住生一切烦恼。心行体一。无二心用故。心如其王。自在缘一切法故。心如恶友。发生一切苦故。心如大海。漂溺一切善根故。心如钓鱼之人。于苦生乐想故。心如梦幻。妄计我故。心如青蝇。于其不净生净想故。心如鬼魅。作种种不善事故。心如药叉。贪着境界饮人精气故。心如冤家。恒求过失故。心不静住。或高或下进退不定故。心如狂贼。坏一切功德善财故。心如蛾眼。恒贪灯焰色故。心着于声。如贪战鼓声故。心如猪犬。于其不净贪香美故。心如贱婢。贪食残味故。心能贪触。如蝇着膻器故。迦叶。心不可求求不能得。过去非有。未来亦无。现在不得。若过去未来现在不可得者。三世断故。若三世断故彼即无有。若彼无有彼即不生。若彼不生是即无性。若彼无性无生无灭。若无生灭亦无往来。若无往来而无主宰。若无主宰无假无实。是即圣性。迦叶。若彼圣性。无得戒非无戒。无净行无秽行。无因行无果行。亦无心意之法。若无心意之法彼无业亦无业报。若无业报亦无苦乐。若无苦乐彼圣者性。若彼圣性无其上下中间。身口意等不可住着。何以故。性遍虚空。平等无分别故无分别故下此处元少一叶梵文

佛说大迦叶问大宝积正法经卷第三佛说大迦叶问大宝积正法经卷第四

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

佛告迦叶。譬如有人善解习马。其马性恶难以制伏。此人调习自然良善。迦叶。如是相应比丘能守禁律。心识嚣驰难以制伏。被此比丘调伏制御。离嗔恚等如如不动。我今于此而说颂曰

  譬如恶性马　　遇彼调习人
  种种被制伏　　不久而调善
  相应行比丘　　善持于禁律
  调伏于识心　　令彼净安住

佛告迦叶。譬如有人于其咽喉而患瘿病。致坏命根得其苦恼。迦叶。如是若复有人深着我想于自身命后得大苦。我今于此而说颂曰

  譬如瘿病人　　苦恼于身命
  于其昼夜中　　无暂得安乐
  着我之众生　　其义亦如是
  见倒坏其身　　于后生诸苦

佛告迦叶。譬如有人身被缠缚。巧设方便而得解免。迦叶。如是若彼有情作善相应。制止心猿令得离缚。我今于此而说颂曰

  譬如缠缚人　　能设巧方便
  解彼身边缚　　令身得自在
  相应善有情　　禁止于心识
  令彼离缠缚　　其义亦如是

佛告迦叶。譬如虚空本自廓然。彼有二物可以盖覆。何等二物。是彼云雾。迦叶。如是出家之人。本自寂静而求世间咒术之法。又于衣钵财利畜积受用。此为覆障。我今于此而说颂曰

  譬如于云雾　　覆障于虚空
  比丘亦复然　　行彼世间法
  习学于咒术　　积聚于衣钵
  此二障行人　　菩萨须远离

佛告迦叶。此出家人有二种缠缚。云何二种。迦叶。一为利养缠缚。二为名称缠缚。彼出家人宜各远离。我今于此而说颂曰

  若彼出家人　　贪着于利养
  及爱好名闻　　此二重缠缚
  亦障圣解脱　　出家须远离

佛告迦叶。有二种法灭出家德。云何二法。一亲近在家。二憎嫌圣者。我今于此而说颂曰

  亲近在家人　　憎嫌于圣者
  此二非道法　　灭彼出家德
  出家菩萨人　　彼宜速速离

佛告迦叶。有二种法为出家垢染。云何二法。一心多烦恼。二弃舍善友摄受恶友。我今于此而说颂曰

  若彼出家人　　心多于烦恼
  弃背善良朋　　亲近于恶友
  佛说于此人　　为彼出家垢
  一切菩萨众　　各各宜远离

佛告迦叶。有二种法于出家人如临崖险。云何二种。一轻慢妙法。二信乐破戒。我今于此而说颂曰

  若彼出家人　　轻慢于妙法
  信重破戒者　　如登于崖险
  坠堕在须臾　　此二非律仪
  一切诸佛子　　彼二须远离

佛告迦叶。有二种法为出家过恶。云何二种一见他过失。二盖覆自过。我今于此而说颂曰

  若有出家者　　恒见他人过
  覆藏于自罪　　此二大过失
  损恼毒如火　　智者须远离

佛告迦叶。有二种法增出家热恼。云何二种。一受持袈裟心怀不净。二恃己戒德诃责非行。我今于此而说颂曰

  虽复披袈裟　　心行不净行
  设身有戒德　　而用于恶言
  催伏非行者　　此二须远离

佛告迦叶。有二种法医出家人病。云何二法。一行大乘者见心决定。二为诸众生不断佛法。我今于此而说颂曰

  若有出家者　　行彼大乘行
  见心恒决定　　不断于佛法
  此二出家人　　佛说名无病

佛告迦叶。有二种法为出家人长病。云何二种。一得阿波谛重罪。二不能发露忏悔。我今于此而说颂曰

  出家比丘众　　犯彼阿波谛
  不能忏灭罪　　愚迷不重戒
  刹那刹那实　　此恶长为病

佛告迦叶。此有沙门为沙门名。迦叶白言。云何沙门为沙门名。迦叶。此有四种沙门。云何四种。一行色相沙门。二密行虚诳沙门。三求名闻称赞沙门。四实行沙门。迦叶此是四种沙门。迦叶白言。云何名行色相沙门。迦叶。此一沙门。虽复剃除须发着佛袈裟受持钵器色相具足。而身不清净。口不清净。意不清净。不自调伏粗恶不善。广贪财利命不清净。得破戒罪法。迦叶。此名行色相沙门

迦叶白言云何名密行虚诳沙门。迦叶。此一沙门。虽知行业亦具威仪。吃粗恶饮食。诈欢诈喜。于行住坐卧。恒构虚诳。又不亲近在家出家四圣种族。诈默无言诳赚有情。心无清净亦无调伏。亦不息念虚妄推度。住着我人之相。若遇空法而生怖畏如登崖险。若见比丘善谈空者如遇冤家。迦叶。此说名为密行虚诳沙门

迦叶白言。云何名为求名闻称赞沙门。迦叶。此一沙门。为求名闻称赞诈行持戒。惑乱他人恃炫多闻要他称赞。或居山野。或处林间。诈现少欲无贪。假行清净之行。于其心内无其离欲。无其寂静无其息虑。无证菩提亦不为沙门。亦不为婆罗门。亦不为涅槃。而求称赞名闻。迦叶。此名求名闻称赞沙门

迦叶白言。云何名实行沙门。迦叶此一沙门。不为身命而行外事。亦不言论名闻利养。唯行空无相无愿。若闻一切法已。正意思惟涅槃实际。恒修梵行不求世报。亦不论量三界喜乐之事。唯见性空不得事法。亦不议论我人众生寿者及补特伽罗。见正法位离诸虚妄。于解脱道断诸烦恼。达一切法自性清净。内外不着。无集无散。于彼法身如来明了通达。无其见取。亦不言论色身离欲。亦不见色相。亦不见三业造作。亦不执凡圣之众法无所有。断诸分别自性凝然。不得轮回不得涅槃。无缚无解无来无去。知一切法寂静湛然。迦叶。此说名为实行沙门。作相应行非求名闻故。我今于此而说颂曰

  所有身口意　　三业不清净
  贪爱不调伏　　粗恶行不密
  圆顶服三衣　　执持于应器
  佛说此沙门　　恒行于色相
  虽然依彼行　　虚诳而不实
  诈现四威仪　　示同于圣者
  远离和合处　　恒餐粗恶食
  无彼清净行　　密行于虚诳
  或彼为求名　　要他行称赞
  诈修于戒定　　示炫行头陀
  内意不调伏　　诳赚于信施
  不行离欲善　　亦不息攀缘
  见说法相空　　怖同登山险
  或居山野间　　而无真实意
  佛说此沙门　　为求名闻故
  若彼实行者　　不为于身命
  妄求名利养　　亦无求快乐
  唯修正解脱　　救拔诸恶趣
  虽知深法空　　不得于寂静
  亦无非寂静　　不住于涅槃
  不得于生死　　不着于圣人
  不舍于凡夫　　本自无所来
  今亦无所去　　一切法寂然
  佛说于此人　　是名实行者

佛告迦叶。譬如贫人家无财利。自发其言告众人曰。我家之内有大库藏财物盈满。迦叶。于意云何。此贫人言是事实不。迦叶白言。不也世尊。佛言。迦叶亦复如是。彼沙门婆罗门自无戒德而复发言。我身具大德业。此言不实是事难信。我今于此而说颂曰

  譬如贫穷人　　言自有库藏
  盈满七珍财　　彼语不相应
  沙门婆罗门　　虚妄亦如是
  三业无清净　　自言具戒德

佛告迦叶。譬如有人入大水内而不专心。恣意戏水不觉溺死。迦叶。亦复如是。此沙门婆罗门多知乐法。入大法海不能制心。好行贪嗔痴。被烦恼贪引生恶趣。我今于此而说颂曰

  譬如戏水人　　入于大水内
  不自用其心　　被水溺其命
  沙门婆罗门　　贪入大法海
  恣行贪嗔痴　　沉坠于恶趣

佛告迦叶。譬如医人修合汤药将往四方欲疗众病。忽自得疾而不能救。迦叶。如是若彼比丘修彼多闻。欲化有情忽尔之间。自起烦恼而不能伏。我今于此而说颂曰

  譬如良医人　　修合诸汤药
  持往于四方　　治彼众生病
  自忽有疾苦　　不能自医疗
  比丘亦如是　　修学于多闻
  欲行于化导　　自忽烦恼生
  不能善制止　　虚施于辛苦

佛告迦叶。譬如有人身有重病。服彼上好名药不免命终。迦叶。如是若彼有情具烦恼病。而欲多闻修行亦不免坠堕。我今于此而说颂曰

  譬如重病人　　久患而不差
  设服于良药　　终不免无常
  众生亦如是　　恒染烦恼病
  设乐修多闻　　不免于坠堕

佛告迦叶。譬如摩尼宝珠堕落不净之中。其珠体触不堪使用。迦叶。如是若彼比丘虽具多闻。堕落不净利养之中。诸天人民不生敬爱。我今于此而说颂曰

  譬如摩尼宝　　堕落不净中
  染污得其触　　使用而不堪
  比丘亦如是　　虽复具多闻
  坠堕于不净　　名闻利养中
  诸天及人民　　而不生爱敬

佛告迦叶。譬如有人忽尔命终。以其金冠花鬘庄严头面。迦叶。如是若彼比丘破尽戒律。而以袈裟庄严其身有何所益。我今于此而说颂曰

  譬如命终人　　以其好花鬘
  及用金宝冠　　严饰尸首上
  彼人无所用　　比丘亦如是
  而以破戒身　　被挂于袈裟
  严饰作威仪　　终无于利益

佛告迦叶。譬如有人洗浴清净以其香油涂润身上及头髻指甲。身着白衣戴瞻卜花鬘为上族子。迦叶。如是若彼比丘多闻智慧。身被法服仪相具足为佛弟子。我今于此而说颂曰

  譬如世间人　　洗浴身清净
  涂润好香油　　头以华鬘饰
  身着于白衣　　而称上族子
  比丘亦如是　　多闻具总持
  戒德恒清净　　被挂于法服
  仪相而具足　　此名真佛子

佛告迦叶。有四种破戒比丘喻持戒影像。迦叶白言。云何四种破戒。迦叶。有一比丘具足受持别解脱戒。善知禁律于微细罪深生怕怖。恒依学处说戒清净。身口意业具足无犯。食离邪命此有其过。所以者何。执自功能成戒取故。迦叶。此是第一破戒喻持戒影像

复次迦叶。有一比丘善知禁律常持戒行。密用三业。彼有身见。执情不舍故。迦叶。此是第二破戒喻持戒影像

复次迦叶。有一比丘恒行慈心悲愍有情。具足慈善闻一切法无生。心生惊怕。迦叶。此是第三破戒喻持戒影像

复次迦叶。有一比丘行彼十二头陀大行具足无缺。而有我心住着我人之相。迦叶。此是第四破戒喻持戒影像。迦叶。此四种破戒喻持戒影像

复次迦叶。若说此戒。无人无我无众生无寿命。无行亦无不行。无作亦无不作。非犯非非犯。无名无色非无名色。无相非无相。无息念非无息念。无取无舍非无取舍。非受非不受。无识无心非无识心。无世间亦无出世间。无所住亦非无住。无自持戒无他持戒。于此戒中离诸毁谤。无迷无执。迦叶。此说

圣着无漏正戒。远离三界一切住处。尔时世尊而说颂曰

  所持离垢戒　　非住我人相
  无犯亦无持　　无缚亦无解
  微妙甚深善　　远离于疑惑
  迦叶此戒相　　如来真实说
  所持无垢戒　　而于彼世间
  非为自身命　　普济诸群生
  同入真如际　　迦叶此戒相
  如来真实说

  所持离垢戒　　于彼我人中
  无染亦无净　　无暗亦无明
  无得亦无失　　不住于此岸
  不到于彼岸　　亦非于中流
  缚脱而平等　　无住如虚空
  非相非非相　　迦叶此戒相
  如来真实说

  所持无垢戒　　不着于名色
  不住于等引　　恒以净妙心
  离我有无相　　于彼别解脱
  远离持犯等　　无戒无不戒
  无定亦无散　　依此而行道
  智观无二取　　此戒净微妙
  安住三摩地　　三摩地生观
  智慧自清净　　是名具足戒

佛说大迦叶问大宝积正法经卷第四佛说大迦叶问大宝积正法经卷第五

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

尔时世尊说此伽他法时。八百苾刍漏尽意解心得解脱。三十亿人远尘离垢得法眼净。五百苾刍得三摩地。闻此甚深微妙戒法。难解难入不信不学。从座而起速离佛会。是时尊者大迦叶白世尊言。此五百苾刍虽得三摩地。云何闻此甚深之法难解难入不信不学。即从座起速便而退。佛言。迦叶。彼等五百苾刍我见未除。于此无漏清净戒法闻已难解难入。心生惊怖所以不信不行。迦叶。此伽他戒法甚深微妙。三佛菩提皆从此出。彼等罪友于此解脱妙善而不能入。复次告言。迦叶。彼五百苾刍于如来教中是外道声闻。如是迦叶。彼于如来本意执求一事法故。若闻一法决定信受。依教修学如是伽他之法。言教玄妙是故惊怖

又复告言。迦叶。彼比丘意于如来应供正遍知觉。为求一法发心修行。于命终后求生忉利天宫。为如是事于佛教中而求出家。迦叶。此五百苾刍身见未舍。闻甚深法而生惊怖不信不学。此等命终必堕恶趣

是时世尊告尊者须菩提言。汝往五百苾刍所。以善方便而为教导。须菩提言。世尊。如是说法诲喻闻已不信不行。我自小智言论寡识。云何化彼。是时五百苾刍已在中路

尔时世尊即以神力化二苾刍于中路中逆往五百苾刍而即问言。尊者。欲往何处。苾刍答言。我等今者欲诣林间。彼处寂静自得定乐而当住处。化苾刍问言。欲住林野于意云何。彼等苾刍而即答言。世尊说法我昔未闻。今既闻已难解难入。心生惊怖不可信学。是以乐归林野安处禅定而取安乐。化苾刍言。尊者。世尊说法而为难解。心生惊怖不信不学不行。而归林野以定为涅槃。是彼所执汝等不知。尊者。沙门之法非合论诘。今问尊者。云何名涅槃法。若于自身得涅槃者则得补特伽罗。我人众生寿者何得涅槃。夫涅槃法。非相非非相。彼苾刍言。涅槃既尔云何证得。化苾刍言。除断贪嗔痴法。彼苾刍言。贪嗔痴法云何除断。化苾刍言。贪嗔痴法非在内非在外非在中间。本自无生今亦非灭。化苾刍言。尊者。不得执亦不得疑。若尊者不执不疑。即非护非不护。非乐非不乐。彼说为涅槃。尊者。此清净戒相不生不灭。从三摩地生。从智慧生。从解脱生。从解脱知见生。离有离无。非相非无相。尊者。如是戒相即真涅槃。如是涅槃无解脱可得。无烦恼可舍。尊者。汝以情想求圆寂者。此得妄想非涅槃也。若想中生想非是涅槃。被想缠缚。如是若灭受想得真三摩钵底。尊者行者。若行更无有上。是时化者说此正法之时。彼五百苾刍闻此法已漏尽意解心得解脱。如是五百苾刍复诣佛所到已头面礼足。绕佛三匝于一面坐

尔时长老须菩提即从座起问彼苾刍尊者。汝于何去今从何来。彼言。本非所去今亦不来。长老须菩提即以问佛。世尊。此所说法其义云何。佛言。无生无灭。须菩提言。汝等尊者云何闻法。彼苾刍言。无缚无脱。须菩提言。谁化汝等。彼苾刍言。无身无心。须菩提言。汝等云何修行。彼苾刍言。无无明灭亦无无明生。须菩提言。云何汝为声闻。彼苾刍言。不得声闻亦不成佛。须菩提言。云何汝之梵行。彼苾刍言。不住三界。须菩提言。汝于何时而入涅槃。彼苾刍言。如来入涅槃时我即涅槃。须菩提言。汝等所作已办。彼苾刍言。了知我人。须菩提言。汝烦恼已尽。彼苾刍言。一切法亦尽。须菩提言。汝等善破魔王。彼苾刍言。蕴身尚不得何有魔王破。须菩提言。汝知师耶。彼苾刍言。非身非口非心。须菩提言。汝得清净胜地。彼苾刍言。无取无舍。须菩提言。汝出轮回今到彼岸。彼苾刍言。不到彼岸亦不得轮回。须菩提言。汝信胜地。彼苾刍言。一切执解脱。须菩提言。汝何所去。彼苾刍言。如来去处去化。苾刍言。尊者须菩提汝令彼去。说是法时众中有八百苾刍发声闻意心得解脱。三十二亿众生远尘离垢得法眼净

尔时会中有菩萨摩诃萨。名曰普光。即从座起合掌向佛而白佛言。世尊。此大宝积正法令诸菩萨。应云何学应云何住。佛告善男子。所说正法真实戒行。汝等受持应如是住。于此正法得大善利。善男子。譬如有人乘彼土船欲过深广大河。善男子。于意云何。彼人乘此土船作何方便。速得到于彼岸。普光言。世尊。须是用大气力勇猛精进方达彼岸。佛言普光。有何所以要施勤力。世尊。彼河中流深而复广令人忧怕。若不勤力必见沉没。佛告普光菩萨。如是若诸菩萨修学正法欲度生死。四流大河须发勇猛精进之力通达佛法。若不精进修学决定退堕。又复思惟此身无强无常速朽之法四流浩渺。云何得度彼诸众生。恒处此岸。汝等。今者受持妙法大船。运度一切众生。过轮回河至菩提岸。普光菩萨复白佛言。世尊。菩萨云何受持妙法大船。善男子。所有布施持戒忍辱慈心。所集无边福德。起平等心庄严一切众生。于七菩提分善而不忘失。精进受持心生决定。以巧方便深达实相。以大悲心拔众生苦。以四摄法护诸有情。以四无量饶益众生。以四念处恒自思惟。以四正断勤断勤修。以四神足奋迅神通。以其五根令生众善。以其五力坚固不退。以八圣道远离魔怨不住邪道。于奢摩他毗钵舍那无相无著。菩萨令此广大法行名闻十方。使诸众生来入微妙。正法大船过彼生死四流大河。得至涅槃安乐彼岸。得无所畏永离诸见。善男子。汝等当知。如是菩萨以妙法大船经无量百千俱胝那由他劫。运度一切众生。过彼四流大河不得疲苦。汝如是受持应如是住

佛告普光菩萨。汝今速运真实方便。起大悲心令一切众生。心意清净勇猛精进。种诸善根令生不退。恒乐出家闻法无倦。植众德本求最上道。圆满智慧身心寂静。安处林野远离恶友。于第一义明了通达。行正方便于真俗谛。理智无二平等一空息诸妄念。善男子。菩萨为诸有情应如是受持应如是住

尔时尊者大迦叶闻是法已而白佛言。世尊。如是大宝积正法。为求大乘者说昔未曾有。世尊。若善男子善女人。于此大宝积正法。受持解说一句一偈所得福德其义云何

佛告迦叶。应如是知。若有善男子善女人。于此大宝积正法。受持一句一偈所得福德。善男子。譬如有人以恒河沙数世界满中七宝供养恒河沙等如来。每一一如来而各以一恒河沙数世界七宝布施。又每一一如来各造一恒河沙佛寺精舍。又一一如来各有无量声闻之众。以一切乐具经一恒河沙劫而以供养。又彼诸如来及声闻弟子入涅槃后。复以七宝各起塔庙。善男子如是福德无量无边。不如有人于此宝积正法受持解说一句一偈功德胜彼。若复有人为其父母解说此经。彼人命终不堕恶趣。其母后身转成男子

佛言。所在之处。若复有人于此大宝积经典。书写受持读诵解说。而于此处一切世间。天人阿修罗。恭敬供养如佛塔庙。若有法师闻此宝积正法经典。发尊重心受持读诵书写供养。若有善男子善女人。于彼法师如佛供养。尊重恭敬顶礼赞叹。彼人现世佛与授记。当得阿耨多罗三藐三菩提。临命终时得见如来。又彼法师复得十种身业清净。何等为十。一者临命终时不受众苦。二者眼识明朗不睹恶相。三者手臂安定不摸虚空。四者脚足安隐而不蹴踏。五者大小便利而不漏失。六者身体诸根而不臭秽。七者腹肠宛然而不胮胀。八者舌相舒展而不弯缩。九者眼目俨然而不丑恶。十者身虽入灭形色如生。如是得此十种身业清净

复有十种口业清净。何等为十。一者言音美好。二者所言慈善。三者言说殊妙。四者言发爱语。五者其言柔软。六者所言诚谛。七者先言问讯。八者言堪听受。九者天人爱乐。十者如佛说言。如是十种口业清净

复有十种意业清净。何等为十。一者意无嗔恚。二者不生嫉妒。三者不自恃怙。四者无诸冤恼。五者离其过失。六者无颠倒想。七者无下劣想。八者无犯戒想。九者正意系心思惟佛土。十者远离我人得三摩地成就诸佛教法。如是得十种意业清净。我今于此而说颂曰

  临终不受苦　　非见诸恶相
  手不摸虚空　　脚足无蹴踏
  便利绝漏失　　身根不臭秽
  腹藏无胮胀　　舌红不弯缩
  眼目相俨然　　命终颜不改
  如是身十种　　福善清净相
  言音得美妙　　出语而慈善
  所说自殊常　　发语人爱乐
  复有柔软声　　所言而诚谛
  方便能问讯　　堪令人听受
  天龙众亦钦　　清响如佛语
  如是口十种　　口业得清净
  心意虽嗔恚　　嫉妒而不生
  于自无恃怙　　冤恼亦自除
  得离众过失　　颠倒想不生
  不作于下劣　　禁戒勿令亏
  正意而系念　　远离于我人
  复得三摩地　　通达诸佛法
  如是意十种　　心业清净相

佛告大迦叶。若善男子善女人。汝等应以香花伎乐缯盖幢幡饮食衣服一切乐具。供养此大宝积正法。志心归命受持读诵。所以者何。迦叶。如是一切诸佛如来应正等觉。皆从此出。应以最上供养而供养之

佛说此经已。尊者大迦叶一心顶戴。菩萨摩诃萨及诸比丘天龙药叉乾闼婆阿修罗等一切大众。皆大欢喜信受奉行

佛说大迦叶问大宝积正法经卷第五


佛说观无量寿佛经

    No. 365

    御制无量寿佛赞

  西方极乐世界尊　　无量寿佛世希有
  能灭无始亿劫业　　令彼苦恼悉消除
  若人能以微妙心　　尝以极乐为观想
  广与众生分别说　　举目即见阿弥陀
  佛身色相显光明　　阎浮檀金无与等
  其高无比由旬数　　六十万亿那由他
  眉间白毫五须弥　　绀眼弘澄四大海
  光明演出诸毛孔　　一孔遍含诸大千
  一界中有一河沙　　沙有八万四千相
  一一相中复如是　　作者观者随现前
  以观佛身见佛心　　众生忆想见化佛
  从相入得无生忍　　以三昧受无边慈
  佛身无量广无边　　化导以彼宿愿力
  有忆想者得成就　　神通如意满虚空
  众生三种具三心　　精进勇猛无退转
  即得如来手接引　　七宝宫殿大光明
  其身踊跃金刚台　　随从佛后弹指顷
  行大乘解第一义　　即生七宝莲池中
  阿弥陀佛大慈悲　　十力威德难赞说
  称名一声起一念　　八十亿劫罪皆除
  以是济拔无有穷　　是以名为无量寿
  昔世尊居耆阇崛　　与大众说妙因缘
  离忧恼与阎浮提　　超脱一切诸苦趣
  净妙国即极乐界　　修三福发菩提心
  作是念者住坚专　　故说无量寿佛观
  如是功德不可说　　不可说者妙光明
  无量清净平等施　　五浊众生咸作佛
  断彼一切颠倒想　　犹如以水投海中
  湿性混合无不同　　虽有圣智难分别
  人人皆为无量寿　　稽首瞻礼即西方

佛说观无量寿佛经

        宋西域三藏畺良耶舍译

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众千二百五十人俱。菩萨三万二千。文殊师利法王子。而为上首。尔时王舍大城有一太子。名阿阇世。随顺调达恶友之教。收执父王频婆娑罗。幽闭置于七重室内。制诸群臣一不得往。国大夫人名韦提希。恭敬大王。澡浴清净。以酥蜜和糗用涂其身。诸璎珞中盛葡萄浆密以上王。尔时大王。食糗饮浆。求水漱口。漱口毕已。合掌恭敬。向耆阇崛山遥礼世尊。而作是言。大目干连是吾亲友。愿兴慈悲授我八戒。时目干连如鹰隼飞疾至王所。日日如是授王八戒。世尊亦遣尊者富楼那。为王说法。如是时间经三七日。王食糗蜜得闻法故。颜色和悦。时阿阇世问守门人。父王今者犹存在耶。时守门者白言。大王。国大夫人身涂糗蜜。璎珞盛浆持用上王。沙门目连及富楼那。从空而来为王说法。不可禁制。时阿阇世闻此语已。怒其母曰。我母是贼。与贼为伴。沙门恶人。幻惑咒术。令此恶王多日不死。即执利剑欲害其母。时有一臣名曰月光。聪明多智。及与耆婆。为王作礼。白言大王。臣闻毗陀论经说。劫初已来。有诸恶王贪国位故。杀害其父一万八千。未曾闻有无道害母。王今为此杀逆之事。污刹利种。臣不忍闻。是栴陀罗。我等不宜复住于此。时二大臣说此语竟。以手按剑却行而退。时阿阇世惊怖惶惧。告耆婆言。汝不为我耶。耆婆白言。大王。慎莫害母。王闻此语忏悔求救。即便舍剑止不害母。敕语内官。闭置深宫不令复出。时韦提希被幽闭已。愁忧憔悴。遥向耆阇崛山。为佛作礼而作是言。如来世尊在昔之时。恒遣阿难来慰问我。我今愁忧。世尊威重无由得见。愿遣目连尊者阿难。与我相见。作是语已。悲泣雨泪遥向佛礼。未举头顷。尔时世尊在耆阇崛山。知韦提希心之所念。即敕大目揵连及以阿难。从空而来。佛从耆阇崛山没。于王宫出。时韦提希礼已举头。见世尊释迦牟尼佛。身紫金色坐百宝莲华。目连侍左。阿难在右。释梵护世诸天在虚空中。普雨天华持用供养。时韦提希见佛世尊。自绝璎珞举身投地。号泣向佛白言。世尊。我宿何罪生此恶子。世尊复有何等因缘。与提婆达多共为眷属。唯愿世尊。为我广说无忧恼处。我当往生。不乐阎浮提浊恶世也。此浊恶处。地狱饿鬼畜生盈满。多不善聚。愿我未来不闻恶声。不见恶人。今向世尊五体投地。求哀忏悔。唯愿佛日教我观于清净业处。尔时世尊放眉间光。其光金色。遍照十方无量世界。还住佛顶。化为金台如须弥山。十方诸佛净妙国土。皆于中现。或有国土七宝合成。复有国土纯是莲花。复有国土如自在天宫。复有国土如颇梨镜。十方国土皆于中现。有如是等无量诸佛国土严显可观。令韦提希见。时韦提希白佛言。世尊。是诸佛土。虽复清净皆有光明。我今乐生极乐世界阿弥陀佛所。唯愿世尊。教我思惟教我正受。尔时世尊即便微笑。有五色光从佛口出。一一光照频婆娑罗王顶。尔时大王虽在幽闭。心眼无障遥见世尊。头面作礼。自然增进成阿那含。尔时世尊告韦提希。汝今知不。阿弥陀佛去此不远。汝当系念谛观彼国净业成者。我今为汝广说众譬。亦令未来世一切凡夫欲修净业者得生西方极乐国土。欲生彼国者。当修三福。一者孝养父母。奉事师长。慈心不杀。修十善业。二者受持三归。具足众戒。不犯威仪。三者发菩提心。深信因果。读诵大乘。劝进行者。如此三事名为净业。佛告韦提希。汝今知不。此三种业乃是过去未来现在。三世诸佛净业正因

佛告阿难及韦提希。谛听谛听善思念之。如来今者。为未来世一切众生为烦恼贼之所害者。说清净业。善哉韦提希快问此事。阿难。汝当受持广为多众宣说佛语。如来今者。教韦提希及未来世一切众生观于西方极乐世界。以佛力故。当得见彼清净国土。如执明镜自见面像。见彼国土极妙乐事。心欢喜故。应时即得无生法忍。佛告韦提希。汝是凡夫心想羸劣。未得天眼。不能远观。诸佛如来有异方便。令汝得见。时韦提希白佛言。世尊。如我今者以佛力故见彼国土。若佛灭后诸众生等。浊恶不善五苦所逼。云何当见阿弥陀佛极乐世界。佛告韦提希。汝及众生。应当专心。系念一处。想于西方。云何作想。凡作想者。一切众生自非生盲。有目之徒皆见日没。当起想念。正坐西向谛观于日。令心坚住。专想不移。见日欲没状如悬鼓。既见日已。闭目开目皆令明了。是为日想。名曰初观。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。初观成已。次作水想。想见西方一切皆是大水。见水澄清。亦令明了。无分散意。既见水已当起冰想。见冰映彻作琉璃想。此想成已。见琉璃地内外映彻。下有金刚七宝金幢。擎琉璃地。其幢八方八楞具足。一一方面百宝所成。一一宝珠有千光明。一光明八万四千色。映琉璃地。如亿千日不可具见。琉璃地上。以黄金绳杂厕间错。以七宝界分齐分明。一一宝中有五百色光。其光如花。又似星月。悬处虚空成光明台。楼阁千万百宝合成。于台两边各有百亿花幢无量乐器。以为庄严。八种清风从光明出。鼓此乐器。演说苦空无常无我之音。是为水想。名第二观。此想成时。一一观之极令了了。闭目开目不令散失。唯除食时。恒忆此事。作此观者名为正观。若他观者名为邪观。佛告阿难及韦提希。水想成已。名为粗见极乐国地。若得三昧。见彼国地了了分明。不可具说。是为地想。名第三观

佛告阿难。汝持佛语。为未来世一切大众欲脱苦者。说是观地法。若观是地者。除八十亿劫生死之罪。舍身他世必生净国。心得无疑。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。地想成已。次观宝树。观宝树者。一一观之作七重行树想。一一树高八千由旬。其诸宝树七宝花叶无不具足。一一华叶作异宝色。琉璃色中出金色光。颇梨色中出红色光。马脑色中出车磲光。车磲色中出绿真珠光。珊瑚琥珀一切众宝以为映饰。妙真珠网弥覆树上。一一树上有七重网。一一网间有五百亿妙华宫殿。如梵王宫。诸天童子自然在中。一一童子有五百亿释迦毗楞伽摩尼宝以为璎珞。其摩尼光照百由旬。犹如和合百亿日月。不可具名。众宝间错色中上者。此诸宝树行行相当。叶叶相次。于众叶间生诸妙花。花上自然有七宝果。一一树叶。纵广正等二十五由旬。其叶千色有百种画。如天缨珞。有众妙华作阎浮檀金色。如旋火轮。宛转叶间踊生诸果。如帝释瓶。有大光明。化成幢幡无量宝盖。是宝盖中。映现三千大千世界一切佛事。十方佛国亦于中现。见此树已。亦当次第一一观之。观见树茎枝叶华果。皆令分明。是为树想。名第四观。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。树想成已。次当想水。欲想水者。极乐国土有八池水。一一池水七宝所成。其宝柔软从如意珠王生。分为十四支。一一支作七宝色。黄金为渠。渠下皆以杂色金刚以为底沙。一一水中有六十亿七宝莲花。一一莲华团圆正等十二由旬。其摩尼水流注华间寻树上下。其声微妙演说苦空无常无我诸波罗蜜。复有赞叹诸佛相好者。从如意珠王踊出金色微妙光明。其光化为百宝色鸟。和鸣哀雅。常赞念佛念法念僧。是为八功德水想。名第五观。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。众宝国土。一一界上有五百亿宝楼。其楼阁中有无量诸天。作天伎乐。又有乐器悬处虚空。如天宝幢不鼓自鸣。此众音中。皆说念佛念法念比丘僧。此想成已。名为粗见极乐世界宝树宝地宝池。是为总观想。名第六观。若见此者。除无量亿劫极重恶业。命终之后必生彼国。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。谛听谛听善思念之。吾当为汝分别解说除苦恼法。汝等忆持。广为大众分别解说。说是语时。无量寿佛住立空中。观世音大势至。是二大士侍立左右。光明炽盛不可具见。百千阎浮檀金色不得为比。时韦提希见无量寿佛已。接足作礼。白佛言。世尊。我今因佛力故。得见无量寿佛及二菩萨。未来众生。当云何观无量寿佛及二菩萨。佛告韦提希。欲观彼佛者。当起想念。于七宝地上作莲花想。令其莲花一一叶作百宝色。有八万四千脉。犹如天画一一脉有八万四千光。了了分明皆令得见。华叶小者纵广二百五十由旬。如是莲华有八万四千大叶。一一叶间。有百亿摩尼珠王。以为映饰。一一摩尼珠放千光明。其光如盖七宝合成。遍覆地上。释迦毗楞伽摩尼宝以为其台。此莲花台。八万金刚甄叔迦宝。梵摩尼宝妙真珠网。以为交饰。于其台上。自然而有四柱宝幢。一一宝幢如百千万亿须弥山。幢上宝缦如夜摩天宫。复有五百亿微妙宝珠。以为映饰。一一宝珠有八万四千光。一一光作八万四千异种金色。一一金色遍其宝土。处处变化各作异相。或为金刚台。或作真珠网。或作杂花云。于十方面随意变现施作佛事。是为花座想。名第七观

佛告阿难。如此妙花。是本法藏比丘愿力所成。若欲念彼佛者。当先作此妙花座想。作此想时不得杂观。皆应一一观之。一一叶。一一珠。一一光。一一台。一一幢皆令分明。如于镜中自见面像。此想成者。灭除五百亿劫生死之罪。必定当生极乐世界。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。见此事已。次当想佛。所以者何。诸佛如来是法界身。遍入一切众生心想中。是故汝等心想佛时。是心即是三十二相八十随形好。是心作佛是心是佛。诸佛正遍知海从心想生。是故应当一心系念谛观彼佛多陀阿伽度阿罗呵三藐三佛陀。想彼佛者。先当想像。闭目开目见一宝像如阎浮檀金色坐彼华上。像既坐已。心眼得开。了了分明。见极乐国七宝庄严宝地宝池宝树行列。诸天宝缦弥覆树上。众宝罗网满虚空中。见如此事极令明了如观掌中。见此事已。复当更作一大莲华左佛左边。如前莲华等无有异。复作一大莲华在佛右边。想一观世音菩萨像坐左华座。亦放金光如前无异。想一大势至菩萨像坐右华座。此想成时。佛菩萨像皆放妙光。其光金色照诸宝树。一一树下亦有三莲华。诸莲华上各有一佛二菩萨像。遍满彼国。此想成时。行者当闻水流光明及诸宝树凫雁鸳鸯皆说妙法。出定入定恒闻妙法。行者所闻。出定之时忆持不舍。令与修多罗合。若不合者名为妄想。若与合者。名为粗想见极乐世界。是为想像。名第八观。作是观者。除无量亿劫生死之罪。于现身中得念佛三昧。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。此想成已。次当更观无量寿佛身相光明。阿难当知。无量寿佛身。如百千万亿夜摩天阎浮檀金色。佛身高六十万亿那由他恒河沙由旬。眉间白毫右旋宛转如五须弥山。佛眼清净如四大海水清白分明。身诸毛孔演出光明如须弥山。彼佛圆光如百亿三千大千世界。于圆光中。有百万亿那由他恒河沙化佛。一一化佛。亦有众多无数化菩萨。以为侍者。无量寿佛有八万四千相。一一相中。各有八万四千随形好。一一好中复有八万四千光明。一一光明遍照十方世界。念佛众生摄取不舍。其光相好及与化佛。不可具说。但当忆想令心明见。见此事者。即见十方一切诸佛。以见诸佛故名念佛三昧。作是观者。名观一切佛身。以观佛身故亦见佛心。诸佛心者大慈悲是。以无缘慈摄诸众生。作此观者。舍身他世生诸佛前。得无生忍。是故智者应当系心谛观无量寿佛。观无量寿佛者。从一相好入。但观眉间白毫极令明了。见眉间白毫相者。八万四千相好自然当见。见无量寿佛者。即见十方无量诸佛。得见无量诸佛故。诸佛现前受记。是为遍观一切色想。名第九观。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。见无量寿佛了了分明已。次亦应观观世音菩萨。此菩萨身长八十亿那由他恒河沙由旬。身紫金色。顶有肉髻。项有圆光。面各百千由旬。其圆光中有五百化佛。如释迦牟尼。一一化佛。有五百菩萨无量诸天。以为侍者。举身光中五道众生。一切色相皆于中现。顶上毗楞伽摩尼妙宝。以为天冠。其天冠中有一立化佛。高二十五由旬。观世音菩萨面如阎浮檀金色。眉间毫相备七宝色。流出八万四千种光明。一一光明。有无量无数百千化佛。一一化佛。无数化菩萨以为侍者。变现自在满十方界。臂如红莲花色。有八十亿微妙光明。以为璎珞。其璎珞中。普现一切诸庄严事。手掌作五百亿杂莲华色。手十指端。一一指端有八万四千画。犹如印文。一一画有八万四千色。一一色有八万四千光。其光柔软普照一切。以此宝手接引众生。举足时。足下有千辐轮相。自然化成五百亿光明台。下足时。有金刚摩尼花。布散一切莫不弥满。其余身相众好具足。如佛无异。唯顶上肉髻及无见顶相。不及世尊。是为观观世音菩萨真实色身想。名第十观

佛告阿难。若欲观观世音菩萨当作是观。作是观者不遇诸祸。净除业障。除无数劫生死之罪。如此菩萨。但闻其名获无量福。何况谛观。若有欲观观世音菩萨者。当先观顶上肉髻。次观天冠。其余众相亦次第观之。悉令明了如观掌中。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。次观大势至菩萨。此菩萨身量大小亦如观世音。圆光面各二百二十五由旬。照二百五十由旬。举身光明照十方国。作紫金色。有缘众生皆悉得见。但见此菩萨一毛孔光。即见十方无量诸佛净妙光明。是故号此菩萨名无边光。以智慧光普照一切。令离三涂得无上力。是故号此菩萨名大势至。此菩萨天冠有五百宝莲华。一一宝华有五百宝台。一一台中。十方诸佛净妙国土广长之相。皆于中现。顶上肉髻如钵头摩花。于肉髻上有一宝瓶。盛诸光明普现佛事。余诸身相如观世音等无有异。此菩萨行时。十方世界一切震动。当地动处各有五百亿宝花。一一宝花庄严高显。如极乐世界。此菩萨坐时。七宝国土一时动摇。从下方金光佛刹。乃至上方光明王佛刹。于其中间无量尘数分身无量寿佛分身观世音大势至。皆悉云集极乐国土。侧塞空中坐莲华座。演说妙法度苦众生。作此观者。名为观见大势至菩萨。是为观大势至色身相。观此菩萨者名第十一观。除无数劫阿僧祇生死之罪。作是观者不处胞胎。常游诸佛净妙国土。此观成已。名为具足观观世音及大势至。作是观者名为正观。若他观者名为邪观。佛告阿难及韦提希。见此事时当起想作心自见生于西方极乐世界。于莲华中结跏趺坐。作莲华合想。作莲华开想。莲华开时。有五百色光来照身想。眼目开想。见佛菩萨满虚空中。水鸟树林及与诸佛。所出音声皆演妙法。与十二部经合。若出定时忆持不失。见此事已。名见无量寿佛极乐世界。是为普观想。名第十二观。无量寿佛化身无数。与观世音及大势至。常来至此行人之所。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。若欲至心生西方者。先当观于一丈六像在池水上。如先所说。无量寿佛身量无边。非是凡夫心力所及。然彼如来宿愿力故。有忆想者必得成就。但想佛像得无量福。况复观佛具足身相。阿弥陀佛神通如意。于十方国变现自在。或现大身满虚空中。或现小身丈六八尺。所现之形皆真金色。圆光化佛及宝莲花。如上所说。观世音菩萨及大势至。于一切处身同。众生但观首相。知是观世音。知是大势至。此二菩萨助阿弥陀佛。普化一切。是为杂想观。名第十三观。作是观者名为正观。若他观者名为邪观

佛告阿难。及韦提希。凡生西方有九品人。上品上生者。若有众生愿生彼国者。发三种心即便往生。何等为三。一者至诚心。二者深心。三者回向发愿心。具三心者必生彼国。复有三种众生。当得往生。何等为三。一者慈心不杀具诸戒行。二者读诵大乘方等经典。三者修行六念回向发愿生彼佛国。具此功德。一日乃至七日。即得往生。生彼国时。此人精进勇猛故。阿弥陀如来与观世音及大势至无数化佛百千比丘声闻大众无量诸天。七宝宫殿。观世音菩萨执金刚台。与大势至菩萨至行者前。阿弥陀佛放大光明照行者身。与诸菩萨授手迎接。观世音大势至与无数菩萨。赞叹行者劝进其心。行者见已欢喜踊跃。自见其身乘金刚台。随从佛后。如弹指顷往生彼国。生彼国已。见佛色身众相具足。见诸菩萨色相具足。光明宝林演说妙法。闻已即悟无生法忍。经须臾间历事诸佛。遍十方界。于诸佛前次第受记。还至本国。得无量百千陀罗尼门。是名上品上生者。上品中生者。不必受持读诵方等经典。善解义趣。于第一义心不惊动。深信因果不谤大乘。以此功德。回向愿求生极乐国。行此行者命欲终时。阿弥陀佛与观世音及大势至。无量大众眷属围绕。持紫金台至行者前赞言。法子。汝行大乘解第一义。是故我今来迎接汝。与千化佛一时授手。行者自见坐紫金台。合掌叉手赞叹诸佛。如一念顷。即生彼国七宝池中。此紫金台如大宝花。经宿即开。行者身作紫磨金色。足下亦有七宝莲华。佛及菩萨俱放光明。照行者身目即开明。因前宿习普闻众声。纯说甚深第一义谛。即下金台礼佛合掌赞叹世尊。经于七日。应时即于阿耨多罗三藐三菩提。得不退转。应时即能飞至十方。历事诸佛。于诸佛所修诸三昧。经一小劫得无生法忍现前受记。是名上品中生者。上品下生者。亦信因果不谤大乘。但发无上道心。以此功德。回向愿求生极乐国。彼行者命欲终时。阿弥陀佛及观世音并大势至。与诸眷属持金莲华。化作五百化佛来迎此人。五百化佛一时授手。赞言。法子。汝今清净发无上道心。我来迎汝。见此事时。即自见身坐金莲花。坐已华合。随世尊后即得往生七宝池中。一日一夜莲花乃开。七日之中乃得见佛。虽见佛身于众相好心不明了。于三七日后乃了了见。闻众音声皆演妙法。游历十方供养诸佛。于诸佛前闻甚深法。经三小劫得百法明门。住欢喜地。是名上品下生者。是名上辈生想。名第十四观。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。中品上生者。若有众生受持五戒。持八戒斋。修行诸戒。不造五逆。无众过恶。以此善根。回向愿求生于西方极乐世界。行者临命终时。阿弥陀佛与诸比丘眷属围绕。放金色光至其人所。演说苦空无常无我。赞叹出家得离众苦。行者见已心大欢喜。自见己身坐莲花台。长跪合掌为佛作礼。未举头顷即得往生极乐世界。莲花寻开。当华敷时。闻众音声赞叹四谛。应时即得阿罗汉道。三明六通具八解脱。是名中品上生者。中品中生者。若有众生。若一日一夜持八戒斋。若一日一夜持沙弥戒。若一日一夜持具足戒。威仪无缺。以此功德。回向愿求生极乐国。戒香薰修。如此行者命欲终时。见阿弥陀佛与诸眷属放金色光。持七宝莲花至行者前。行者自闻空中有声。赞言。善男子。如汝善人。随顺三世诸佛教故。我来迎汝。行者自见坐莲花上。莲花即合。生于西方极乐世界。在宝池中。经于七日莲花乃敷。花既敷已。开目合掌赞叹世尊。闻法欢喜得须陀洹。经半劫已成阿罗汉。是名中品中生者。中品下生者。若有善男子善女人。孝养父母行世仁义。此人命欲终时遇善知识。为其广说阿弥陀佛国土乐事。亦说法藏比丘四十八大愿。闻此事已寻即命终。譬如壮士屈伸臂顷。即生西方极乐世界。生经七日遇观世音及大势至。闻法欢喜得须陀洹。过一小劫成阿罗汉。是名中品下生者。是名中辈生想。名第十五观。作是观者名为正观。若他观者名为邪观

佛告阿难及韦提希。下品上生者。或有众生作众恶业。虽不诽谤方等经典。如此愚人。多造恶法无有惭愧。命欲终时遇善知识。为赞大乘十二部经首题名字。以闻如是诸经名故。除却千劫极重恶业。智者复教合掌叉手。称南无阿弥陀佛。称佛名故。除五十亿劫生死之罪。尔时彼佛。即遣化佛化观世音化大势至。至行者前。赞言善哉善男子。汝称佛名故诸罪消灭。我来迎汝。作是语已。行者即见化佛光明遍满其室。见已欢喜即便命终。乘宝莲花。随化佛后生宝池中。经七七日莲花乃敷。当花敷时。大悲观世音菩萨。及大势至菩萨。放大光明住其人前。为说甚深十二部经。闻已信解发无上道心。经十小劫。具百法明门。得入初地。是名下品上生者。得闻佛名法名及闻僧名。闻三宝名即得往生。佛告阿难及韦提希。下品中生者。或有众生。毁犯五戒八戒及具足戒。如此愚人。偷僧祇物盗现前僧物。不净说法无有惭愧。以诸恶法而自庄严。如此罪人。以恶业故应堕地狱。命欲终时。地狱众火一时俱至。遇善知识以大慈悲。即为赞说阿弥陀佛十力威德。广赞彼佛光明神力。亦赞戒定慧解脱解脱知见。此人闻已除八十亿劫生死之罪。地狱猛火化为凉风。吹诸天华。华上皆有化佛菩萨。迎接此人。如一念顷。即得往生七宝池中莲花之内。经于六劫莲花乃敷当华敷时。观世音大势至。以梵音声安慰彼人。为说大乘甚深经典。闻此法已。应时即发无上道心。是名下品中生者。佛告阿难及韦提希。下品下生者。或有众生作不善业五逆十恶。具诸不善。如此愚人以恶业故。应堕恶道经历多劫受苦无穷。如此愚人临命终时。遇善知识种种安慰为说妙法教令念佛。彼人苦逼不遑念佛。善友告言。汝若不能念彼佛者。应称归命无量寿佛。如是至心令声不绝。具足十念称南无阿弥陀佛。称佛名故。于念念中。除八十亿劫生死之罪。命终之时见金莲花犹如日轮住其人前。如一念顷即得往生极乐世界。于莲花中满十二大劫。莲花方开当花敷时。观世音大势至以大悲音声。即为其人广说实相除灭罪法。闻已欢喜。应时即发菩提之心。是名下品下生者。是名下辈生想。名第十六观

尔时世尊说是语时。韦提希与五百侍女。闻佛所说。应时即见极乐世界广长之相。得见佛身及二菩萨。心生欢喜叹未曾有。豁然大悟得无生忍。五百侍女发阿耨多罗三藐三菩提心。愿生彼国。世尊悉记皆当往生。生彼国已。获得诸佛现前三昧。无量诸天发无上道心

尔时阿难。即从座起前白佛言。世尊。当何名此经。此法之要当云何受持。佛告阿难。此经名观极乐国土无量寿佛观世音菩萨大势至菩萨。亦名净除业障生诸佛前。汝等受持无令忘失。行此三昧者。现身得见无量寿佛及二大士。若善男子及善女人。但闻佛名二菩萨名。除无量劫生死之罪。何况忆念。若念佛者。当知此人即是人中芬陀利花。观世音菩萨大势至菩萨。为其胜友。当坐道场生诸佛家

佛告阿难。汝好持是语。持是语者即是持无量寿佛名。佛说此语时。尊者目连。尊者阿难。及韦提希等。闻佛所说。皆大欢喜

尔时世尊。足步虚空还耆阇崛山。尔时阿难。广为大众说如上事。无量人天龙神夜叉。闻佛所说皆大欢喜礼佛而退

佛说观无量寿佛经


佛说护国尊者所问大乘经卷第一

    No. 321 [No. 310(18)]

佛说护国尊者所问大乘经卷第一

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众千二百五十人俱。复有菩萨摩诃萨众五千人俱。得大忍辱无碍辩才。降伏魔怨制诸外道。发大道心得三摩地。总持自在具四无碍智。通达四摄及最上甚深波罗蜜多。乃至一切佛法。无量无边诸善功德。其名曰普贤菩萨。普眼菩萨。普观菩萨。普光菩萨。普照菩萨。上意菩萨。增意菩萨。无边意菩萨。广意菩萨。无尽意菩萨。持地菩萨。世上菩萨。胜意菩萨。最上意菩萨。总持自在王菩萨。文殊师利菩萨摩诃萨等。复有贤护菩萨摩诃萨等十六人俱。复有娑婆世界主大梵天王。及帝释天主。护世四大天王。复有苏尸弥天子。安意天子。及诸天王。龙王紧那啰王。巘驮哩嚩王。药叉王。誐[日*魯]拏王等。各与若干百千眷属俱来会坐

尔时世尊。坐于吉祥藏师子之座。四众围绕。逾于须弥。光明炽盛。譬如日月普照一切世间。威仪具足梵行寂静。譬如帝释于诸天中威仪最胜。亦如轮王七宝具足离诸怖畏。如师子王善能谈说诸法空义。如大火聚破诸幽暗。如摩尼宝王远照一切。如是佛光照于三千大千一切世界。于其光中出妙梵音告诸众生。我今所得一切诸法最上波罗蜜。说真实义。初善中善后善。文义殊胜纯白圆满。梵行清净纯一无杂

尔时喜王菩萨摩诃萨。在大众中安详而坐瞻仰世尊。于师子座放大光明。譬如千日照耀一切。心大欢喜深信恭敬。即从座起合掌向佛。以颂赞曰

  佛身晃曜如金山　　利益世间甚希有
  菩萨声闻缘觉僧　　天龙八部皆围绕
  譬如须弥诸天居　　出于大海而高显
  悲愍众生而现身　　放百千光常照曜
  行梵天行即梵天　　于彼梵天复为王
  行禅解脱三摩地　　光照上位诸菩萨
  亦如帝释为天主　　威德仪容诸相异
  牟尼光明照世间　　相好庄严功德异
  金轮四洲得自在　　能善调伏诸有情
  引彼众生出苦轮　　我佛慈悲亦如是
  所有火光摩尼光　　日月光等诸光明
  如是百千日等光　　不及佛日恒照曜
  如月夜分放光明　　普照世间悉清净
  佛面端严如满月　　映蔽一切光不现
  譬如高山燃大火　　能破夜暗显诸方
  大仙所有智慧光　　破尽黑暗离诸有
  如大师子旷野吼　　众兽闻之悉惊怖
  佛说法空无我义　　诸魔闻之亦如是
  摩尼宝王放光明　　诸余摩尼光不现
  佛身晃曜真金色　　映蔽一切世间光
  一切世间贤圣中　　无有最上与佛等
  具福精进方便智　　一切功德不可量
  瞻仰大师功德海　　威光普照诸群生
  一心恭敬慕尊颜　　是故我今头面礼
  我所赞佛归敬心　　世间功德无等等
  尽将回向法界中　　一切世间成佛道

尔时喜王菩萨摩诃萨。赞叹佛已合掌向佛。瞻仰尊颜目不暂舍。心观法界其义甚深难知难见。离言分别绝诸戏论。微妙难解不可思议。如是观想一切法界。唯佛如来观智摄受现量证知。佛之境界无有等等。如是观见所有如来不可思议方便境界。皆摄一相法界性中。譬如虚空无有住处。即众生界亦如自性。一切诸法亦复如是。无碍解脱究竟寂静。诸佛世尊以善方便。身变佛刹遍满一切现众生前。诸如来身。经无数俱胝劫而不可得。时喜王菩萨摩诃萨。如是观佛功德已默然而住

尔时有一尊者。名曰护国。于舍卫大城安居三月。过是夏已着衣持钵。与诸苾刍及初出家者。初发心者出舍卫国。诣王舍城鹫峰山中。到彼山已。即时护国尊者。往诣佛所头面礼足。右绕三匝住立一面。合掌恭敬。而说此颂。赞叹佛曰

  稽首最上佛光明　　稽首如空无碍意
  稽首能断诸结缚　　稽首永超三有海
  我佛无边真色相　　普遍俱胝刹土中
  菩萨闻已欢喜来　　恭敬供养佛功德
  作此最上供养已　　听牟尼法离诸尘
  各生欢喜还本土　　称赞世尊所说法
  广历俱胝无数劫　　利乐一切诸有情
  如是身心不疲倦　　为求无上佛菩提
  恒行布施持戒行　　忍辱精进禅定门
  智慧方便到涅盘　　是故我礼大觉尊
  成就六通四神足　　诸根十力解脱门
  以此行及诸众生　　我今礼佛无等智
  能知一切世间心　　所行所作所成业
  所有身口及言说　　无上世尊悉观见
  贪痴过失不能断　　众生因彼堕三有
  因佛得成善逝业　　能知世间诸善恶
  所有过去诸佛事　　及彼现在天人师
  乃至未来功德海　　一切诸法悉能知
  清净刹土众围绕　　菩萨缘觉与声闻
  乃至诸佛寿较量　　我佛一切悉能知
  所有一切生灭法　　所有供养作佛事
  所有受持法藏法　　我佛一切悉能知
  佛有十力无碍智　　现在常住于三世
  如是一切方便法　　我礼世尊智慧海
  大觉世尊无等等　　相好庄严大吉祥
  如夜众星现空中　　我礼牟尼最上尊
  色相端严无与等　　光照诸天及世间
  帝释梵王究竟天　　对彼佛前俱不现
  无垢不动如金山　　右旋螺髻绀滋润
  佛顶高显如金山　　光明远照生诸福
  光遍俱胝那由他　　显现眉间白毫相
  目若青莲恒适悦　　观照世间运慈心
  清净满月虚空中　　佛面圆明亦如是
  一切见者无厌足　　我礼如来圆满相
  行如鹅王及鹿王　　亦如牛王行步稳
  振动大地无暂止　　我礼如来坚固力
  手指纤长网缦相　　指甲清净如赤铜
  平立垂手过于膝　　我礼金色大觉尊
  佛行大地现好相　　具足显现千辐轮
  足放光明照群生　　蒙光悉得生天界
  大圣法王施七财　　能为施主心平等
  调御世间依法行　　我礼法王无上觉
  慈悲法念心为剑　　持戒方便智慧弓
  能断烦恼诸群贼　　生灭轮回无有增
  自利果满复利他　　令彼众生亦解脱
  究竟安乐出尘劳　　得入善逝寂静宗
  无生无灭无诸苦　　亦无生老爱别离
  如是无为最上乘　　佛为众生慈愍说
  我赞最上大牟尼　　摄尽一切诸佛法
  如是所有诸功德　　愿诸众生证菩提

尔时尊者护国。颂赞佛已。偏袒右肩右膝着地。合掌向佛。恭敬顶礼白佛言。世尊。如来应正等觉。我有所问。唯愿世尊慈悲听许

尔时世尊。告尊者护国言。如汝所问我为汝说。满所求愿令生欢喜。时尊者护国。闻佛语已。身心适悦而发声言。世尊有何等法为菩萨行法具足。能得一切最上功德。无碍大智决定辩才明了性相。入一切智教化众生。断彼无明妄想烦恼。决定真实入一切智。发真实语。令彼有情依言所作。离诸愚暗念佛方便。乐闻一切甚深梵义。受持诸法。速得证于无上正智

尔时尊者护国即于佛前。而说颂曰

  菩萨所行决定行　　彼行必有真实法
  真法从佛智海生　　最上如来为我说
  佛身光明黄金相　　最上无边大福聚
  救度六趣诸众生　　为说菩萨无垢行
  何得无尽大觉智　　总持甘露生菩提
  何得清净智慧海　　彼慧能断众生疑
  俱胝多劫轮回苦　　众生迷没意无疲
  睹此愚迷苦恼侵　　为彼云何修十善
  刹土清净众会满　　实刹无边寿命长
  为众恒宣微妙言　　愿说菩提无垢行
  降伏邪魔生正见　　枯彼爱河证解脱
  清净法眼照愚盲　　令诸有情行上行
  端严富贵大辩才　　言辞柔软闻欢喜
  譬如甘露润世间　　愿说甚深微妙法
  梵音深妙断诸恶　　其声和雅如频伽
  求法之众佛所集　　愿说甘露济群生
  众有菩提最上根　　及彼声闻缘觉性
  愿佛随根方便说　　师资遇会正是时
  我今乐闻最上乘　　唯佛知我菩提性
  于此小乘不乐求　　愿说如来第一法

尔时尊者护国。说此颂已。佛言。善哉善哉。尊者能问如来最上之义。利益多人令得安乐。摄受未来诸菩萨摩诃萨。汝今谛听善思念之。我当为说。时尊者护国白言。善哉世尊。我今乐听唯愿说之

尔时世尊。告尊者护国言。有四种法具足清净。是名菩萨摩诃萨。何等四法。一内二外三心四意。如是四法称理真实。见诸众生其心平等。犹若虚空。无所分别依言所行。是名菩萨摩诃萨四种之法获得清净

尔时世尊。重说颂曰

  心意内外常清净　　不退菩提正道心
  所作之善无唐捐　　能得菩萨无边智
  观彼众生苦无我　　生老病死悉来侵
  如是三有大海中　　广运法船救群品
  见诸众生心平等　　观彼世间如一子
  愿令一切俱解脱　　悉向菩提心不退
  常谈空义依空行　　亦无人我无众生
  譬如梦幻等无实　　令彼愚迷生智慧
  如所宣说大觉智　　依智而行所作事
  调伏过失心寂静　　求证菩提为佛子

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨令心安慰。何等四法。一者于总持法门志求修学。二者常近善友威仪无缺。三者求证甚深无生法忍。四者精进修行持戒清净。如是四法。令彼菩萨安慰其心进修不退。复说颂曰

  若人爱敬总持法　　名闻远响众所归
  能持无上妙法门　　一切如来同所说
  智慧增明无忘失　　如是速得无碍智
  通达一切最上法　　成就无为解脱门
  皆因善友证菩提　　出生七觉能修断
  增长八正作佛事　　远离恶友如怖火
  闻甚深法证无生　　能了诸法毕竟空
  无我无人无众生　　如是求离一切见
  律仪出生诸善本　　坚持守护离破犯
  彼行能成寂静心　　佛为众生亲演说

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨在轮回中令心爱乐。何等四法。一者令诸菩萨爱乐见佛。二者令诸菩萨爱乐说法。三者令诸菩萨爱乐能舍一切所有。四者令诸菩萨爱乐忍印无相深法。如是四法。于诸菩萨在轮回中深生爱乐。复说颂曰

  菩萨得见二足尊　　一切生中行正行
  能善调伏诸世间　　光明普照除愚暗
  如是供养人中尊　　深生爱乐常尊重
  救度一切诸众生　　令入菩提无上道
  若闻诸佛所说法　　身心寂静生爱乐
  如是坚固心无退　　依行速证佛菩提
  能舍一切心无吝　　见来求者生欢喜
  国城妻子及身命　　给施众生作佛因
  若闻无相甚深法　　性离分别本来空
  无我无人无众生　　如是于斯生爱乐

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨不得爱乐。何等四法。一者于其在家不得爱乐。二者既出家已不得爱乐利养。三者不得爱乐上族中生。四者不得爱乐小乘之人。如是四法。于诸菩萨不得爱乐。复说颂曰

  在家无边大过失　　舍离令心无所著
  常乐山野寂诸根　　勇猛勤修大智德
  独行清净如利剑　　能断愚痴诸垢染
  于彼种种大利养　　常乐远离无爱着
  弃舍高贵上种族　　观如幻化阳焰等
  普为群生行布施　　持戒忍辱等诸行
  不惜身命及眷属　　志求正觉到彼岸
  于小乘法无所著　　于最上乘恒坚固
  乃至割截于身体　　其心不坏如金刚

尔时世尊。说此颂已。告尊者护国言。复有四种法。于诸菩萨而有损减。何等四法。一者破犯戒律。二者不住山野而趣寂静。三者不依四乘之教邪妄推求。四者虽乐多闻全无所得。如是四法。于诸菩萨而有损减。复说颂曰

  戒相清净如摩尼　　能引众生到彼岸
  菩萨于斯破律仪　　迷没不成无上觉
  住持山野寂静处　　我人分别自然除
  男女眷属及己身　　观如草木无情爱
  四乘教理无虚诳　　一心清净奉教行
  必得具足众功德　　成就佛智大丈夫
  观彼轮回诸有情　　常处生死忧悲苦
  恒运最上妙法船　　度彼有情出苦海
  若无救度彼众生　　迷没沉沦无有尽
  是故小乘非究竟　　为生令发菩提心

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨明了修习。何等四法。一者发生诸佛平等之心而求善逝。二者承事法师尊重供养于卧具等而不爱着。三者不贪利养亦无所求。四者于甚深法忍具足成就。如是四法明了修习。复说颂曰

  彼有善逝大丈夫　　天上人间无有等
  平等导引诸群生　　如是修习行十善
  尊重承事于法师　　依师授教而修学
  作大供养求佛智　　无边诸佛亦此生
  常住深山无所畏　　于斯利养不生贪
  善能成就无碍智　　通达深法离诸尘
  闻佛功德深欢喜　　如是行法坚固修
  证彼寂静无生忍　　广度众生无量苦

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨行法清净。何等四法。一者身心决定志求菩提行法清净。二者离诸虚妄乐住深山行法清净。三者一切能舍不求果报行法清净。四者常随法师昼夜求法行法清净。如是四法。于诸菩萨行法清净。复说颂曰

  贪嗔痴垢心皆尽　　懈怠虚妄亦复无
  一切过失令不生　　决定求证菩提道
  厌离本舍忧根断　　舍彼俗尘求出家
  诸恶朋友不相逢　　行住深山趣解脱
  于彼山中修净行　　能成如来无碍智
  于身命财无所著　　自在无畏如师子
  见彼有情生欢喜　　譬如飞鸟聚还离
  观彼世间非久居　　如是求大菩提道
  身心清净如虚空　　所舍一切无惊怖
  于彼利养无爱着　　如鹿心惊不住地
  世间恒处大崄难　　难发身心求解脱
  睹此虚妄无真实　　是故我行寂静行
  恒以软语诱群生　　怨亲平等无分别
  无著无住亦如风　　是求菩萨最上行
  无相解脱空无愿　　了彼有为如幻化
  常行清净广大心　　饮甘露味常欢喜
  志求道法依师学　　彼人五蕴恒清净
  众苦逼迫无疲劳　　如是证入总持门
  解此所修菩萨行　　成就所求令彼喜
  若人不求于菩提　　彼即少智百生失

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨而为难法。何等四法。一者心不尊重多行轻慢。二者心无孝行懈怠背逆。三者心贪利养少于知足。四者心乐虚妄邪求财利。如是四法为菩萨难法。复说颂曰

  佛法本师及父母　　全无信重多轻慢
  不行孝敬心懈怠　　常以愚痴行散乱
  一向贪心于利养　　复行虚妄为邪利
  自赞德业诬他人　　我能持戒及修行
  互相斗诤无慈愍　　覆藏己过见他非
  复行农业及经营　　如是沙门无功德
  末法之时人散乱　　斗诤相杀心嫉妒
  沙门隐灭如来法　　诸善苾刍皆远离
  菩提妙道永不逢　　五趣轮回无有穷

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨宜应远离。何等四法。一者懈怠。二者不信。三者嫉妒。四者憎见他人。如是四法宜应远离。复说颂曰

  无信懈怠心愚迷　　心怀嫉妒常嗔恚
  见有沙门持忍辱　　却行驱摈出伽蓝
  于彼世间贵贱人　　都无分别善恶事
  一向只行于是非　　如是过失从嗔得
  远离佛法诸功德　　堕入恶趣大火坑
  如是所行恶趣行　　不依教法获斯苦
  是故常行菩提道　　无令沦没恶趣生
  利益有情大金仙　　多劫俱胝方出世
  今时暂得遇牟尼　　速舍诸过求解脱

尔时世尊。说此颂已。告尊者护国言。有四种法。于诸菩萨不应行。何等四法。一者恶友补特伽罗不应行。二者有见补特伽罗不应行。三者舍一切善法补特伽罗不应行。四者乐着财利补特伽罗不应行。如是四种补特伽罗不应行。复说颂曰

  若人远离诸恶友　　常得善友来亲近
  如夜圆月现当空　　除暗明显菩提道
  凡有所见常不断　　于己身命偏养育
  如是毒气能远离　　彼人成佛大智慧
  若舍最上微妙法　　不乐寂静甘露味
  如是名为不净器　　远离求证大菩提
  贪求财利衣钵等　　复与在家同营事
  如是远离此火坑　　而能成就最上道
  常乐降伏诸魔怨　　恒转法轮度群品
  如是广作大利益　　常逢善友得菩提
  视疏毁赞常平等　　利养嫉妒亦复然
  如是无上诸佛智　　彼人不久悉成就

尔时世尊说此颂已。告尊者护国言。复有四种法。于诸菩萨为苦报法。何等四法。一者轻慢教法。二者执着我人。三者心无信解。四者于不净境具足印持。如是四法。为菩萨苦报法。复说颂曰

  若有受持微妙法　　堪受世间诸供养
  于彼轻慢无大智　　当受无边众恶苦
  于佛本师及父母　　常怀人我不恭敬
  如是大福心不求　　当得不净无知处
  三宝最上良福田　　而无信解行归敬
  纯以虚诳昧世间　　如是当获罪恶苦
  女人即是恶趣门　　流浪生死无穷尽
  无智愚痴作彼业　　永沈地狱及畜趣
  若人尊重向诸佛　　能灭众苦得无畏
  复闭一切恶趣门　　开引众生得佛道

佛说护国尊者所问大乘经卷第一佛说护国尊者所问经卷第二

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

尔时世尊。告尊者护国言。有四种法。于诸菩萨而为缚法。何等四法。一者轻慢他人。二者于世间事方便趣求。三者散乱用心如行崄难。四者于其眷属一心贪着。如是四法。为菩萨缚。复说颂曰

  若行轻慢于他人　　方便唯求世间事
  散乱如行崄道中　　如象陷身深泥里
  于自眷属生爱着　　常怀贪恋如迷醉
  如是种种被缠缚　　增长愚痴覆大智
  若人怖苦厌生死　　求出沉沦趣解脱
  舍于轻慢世间等　　是名菩萨所行道
  灭尽无边诸苦已　　及彼烦恼诸眷属
  究竟安乐无所求　　圆满菩提寂静道
  所行六种波罗蜜　　三身五智十力等
  一切功德悉具足　　如是永离无边苦
  过去修行无量劫　　为众生故求菩提
  一切众善悉皆修　　远离诸恶眷属等
  恒乐深山寂静处　　远离声色想真空
  如是精进不间修　　获大丈夫圆满慧
  见彼世间众生行　　五趣轮回无有穷
  我于过去发慈心　　舍自身命及妻子
  国城大地及珍宝　　如是求佛无数劫
  我昔居山行忍辱　　花果池沼悉清净
  歌利王来截手足　　心生慈忍无嗔恚
  昔住深山名阇摩　　我为仙人婆啰多
  时有天子射我身　　亦无嗔恨生其恶
  不惜身命如顽石　　志求菩提心不退
  我昔曾为萨埵时　　见彼饿虎欲食子
  投崖舍命济彼饥　　天人称赞大精进
  常乐布施救众生　　不吝身命及财宝
  我昔曾为摩曩缚　　广行布施尽宝海
  舍大摩尼令富他　　如是求证菩提果
  往昔作大苏摩王　　名称普闻我修行
  尔时入缚为他人　　于彼百王得解脱
  我昔曾为能舍王　　一切所求皆充足
  乃至身命及珍财　　令他大富离贫苦
  昔有飞鸽来投我　　即割身肉济彼命
  如是持刀割肉时　　无惊无怖心安隐
  亦于过去舍王位　　尽世行彼波罗蜜
  复自化身为妙药　　舍己身命济群品
  又昔曾为师子王　　常为世间行利乐
  弃舍王位及眷属　　一心志求无上道
  又昔曾为妙牙王　　当时获寿于千岁
  八十四年修苦行　　发大精进施珍财
  于佛塔前燃己身　　志心恭敬作供养
  又昔曾为无垢王　　时有恶眼婆罗门
  来诣深宫乞我头　　即便舍头而施与
  又昔曾为月光王　　普救众生作善利
  一切城隍聚落中　　四衢道路施良药
  千女端严妙色相　　金宝真珠广庄严
  舍彼千女自修行　　如是所作福无等
  又昔曾为输婆王　　所戴宝冠世希有
  香花众宝共庄严　　舍施他人无所吝
  又昔曾为宝髻王　　手足柔软如兜罗
  细滑微妙色如莲　　舍自手足利众生
  又昔曾为安意王　　时有商主名星贺
  领诸商客泛海中　　忽然漂堕罗刹国
  彼有百千夜叉女　　无惭大恶唯食人
  商客不识夜叉女　　见此端正生爱心
  五百商旅将被食　　我亲救度俱脱难
  又昔曾为妙眼王　　四兆女人常围绕
  端正殊妙如天女　　舍彼出家求佛道
  又昔曾为福光王　　无垢清净黄金色
  手指纤长世所希　　舍此手指利群品
  又昔曾为法财王　　绀目清净如青莲
  于身所爱最难舍　　人来求者亦与之
  又昔曾为莲目王　　愍见众生在苦恼
  时有女人怀忧病　　我行悲愍令解脱
  又昔曾为大医王　　常救病苦诸众生
  或出身血及髓脑　　救疗疾病令除愈
  如是勇猛精进心　　未曾暂舍于情物
  又昔曾为成利王　　以自所爱如莲目
  施诸众生疗彼疾　　一心为求无上道
  又昔为王名普现　　慈愍有情行救度
  尔时舍彼四大洲　　国土人民及众宝
  乃至割身血肉等　　施与众生心欢喜
  又为王女称大智　　身严金色体柔软
  时有一女名色相　　此是商人所生女
  饥羸困苦无饮食　　我舍双乳济彼命
  又昔为王号多闻　　所有珍宝妙衣服
  象马车乘财帛等　　如是布施无有数
  复见商人漂海浪　　我于海内救得彼
  背恩复乞我眼睛　　我亦施之无嗔恚
  弃舍大地诸眷属　　观彼不着如蚁子
  如是往昔济群生　　心无退动生疲苦
  复睹孤老贫穷人　　给足所须而承事
  恒行敬爱无慢心　　亦无惭赧无人我
  又昔曾作猿猴身　　与彼同类共游行
  时遇猎师缚彼身　　我即替他令脱命
  如是以我奉国王　　王令后宫縻系我
  思念父母年孤老　　所有饮馔无心食
  如是忍苦怀慈孝　　是故得脱王宫难
  又昔曾作大熊身　　常处深山行慈忍
  忽逢樵士遭大雨　　引彼山岩令回避
  过是七日至天晴　　告彼樵人莫说我
  尔时樵士安隐归　　招引猎师来杀害
  如是背恩杀我身　　亦无嗔恨生慈忍
  又昔曾为白象王　　求佛菩提行十善
  时有猎师射我身　　我即舍牙心欢喜
  昔有恶人帝哩子　　以火焚烧大山野
  我见此火运慈心　　天雨香花火自灭
  又昔曾为大鹿王　　金宝庄严体殊妙
  入彼河中救溺人　　令得安隐全身命
  告言勿说我居山　　恐彼恶人来猎我
  时彼溺人背其恩　　指告国王令采捕
  指已两手俱堕地　　我时无有少嗔恚
  昔有五百商人众　　为求珍宝泛海中
  商主所有资粮竭　　商众饥羸无饮食
  是时我作大龟王　　舍身济彼商人命
  以我慈心利他故　　俱得安然到海岸
  我昔变身为药虫　　此虫名曰俱苏摩
  一切疾病食我身　　俱获安隐无诸患
  我昔复为师子王　　大力无畏行慈愍
  有大猎师射我身　　亦无嗔恨无忿怒
  我昔亦作白马王　　常行菩萨慈悲行
  救彼商人罗刹难　　担负众人出海中
  昔作飞鸟军拏罗　　远离色欲无散乱
  令彼同类众飞禽　　亦复而行清净行
  又昔因中作兔王　　与诸群兔宣法行
  见一仙人饥无食　　即舍自身济彼命
  又昔曾作鹦鹉身　　常居花果树林中
  时有恶人毁此林　　以我力故复繁盛
  又昔复作猕猴王　　与众猕猴而游行
  时有国王来采捕　　我救彼难现王前
  又昔复为鹦鹉身　　父母俱老无力飞
  我于田中衔稻谷　　养育二亲行孝敬
  于是田主怀嗔怒　　捉彼鹦鹉而诃责
  云何偷于我稻谷　　此时须见汝舍命
  鹦鹉告彼田主言　　汝所种田济一切
  我持少分供二亲　　汝何言我为偷盗
  尔时田主闻是语　　倍与稻谷生欢喜
  我作禽类汝为人　　如是孝养未曾有
  往昔所行菩萨行　　经历无数微尘劫
  求趣佛果大菩提　　未有少时生疲倦
  如是舍施内外财　　国城妻子及珠珍
  头目髓脑及身命　　持戒忍辱精进禅
  智慧方便愿力等　　如是诸度广修习
  未曾暂废菩萨行　　一切众善悉无遗
  如佛所说头陀行　　彼行亦为趣佛因
  如是一一尽修习　　精进而行无缺犯
  于后末世诸众生　　虽作苾刍无僧行
  常生我慢懈怠心　　贪着声色及财利
  闻此大行胜妙因　　返生诽谤不信受
  轻笑言教告诸人　　此之所说非佛教
  我闻过去有一人　　多闻学识立名海
  闻佛所说不信受　　以此法言问本师
  彼师耆年亦多闻　　于此佛言亦不信
  展转如是告他人　　无我无人无众生
  此法非为真实教　　虚受勤劳求出离
  设尔持戒学威仪　　如是修习何所为
  既无众生无我人　　父母宗亲亦不有
  此是邪见外道言　　非是真实解脱法
  复次末世诸苾刍　　而造诸过无惭愧
  我慢贡高心散乱　　憎嫉贪爱如火烧
  三衣不整垂手行　　拖拽袈裟入聚落
  纵情放逸而饮酒　　种种而行粗恶行
  身被法服为佛使　　不依戒律近王侯
  驰骋书信往四方　　恃官势力求财利
  退失如来功德林　　堕彼三涂诸恶趣
  或有经营于市肆　　或有耕种住村坊
  佛言此类非沙门　　清净苾刍勿同事
  常住供养财物等　　如己所有非法用
  见有具德诸苾刍　　而起慢心行诽谤
  罔昧贤善破律仪　　密于俗舍染邪行
  畜养妻男种种为　　恣行粗恶俗无异
  如是广造恶业因　　非是沙门出家行
  当堕三涂恶趣中　　永劫沉沦受众苦
  于自诸根不调伏　　贪着饮食及色欲
  当被他人生轻贱　　所学徒弟亦复然
  未曾诲示修行法　　亦无师资恭敬心
  人前谈己为慈悲　　非要学徒行承事
  或有风瘨及癞病　　六根不具丑恶人
  如是摄受令出家　　亦非沙门佛弟子
  无戒无行无其德　　彼等非俗非沙门
  譬如负柴烧臭尸　　清净之者宜远离
  性本嚣浮多散乱　　亦如狂象失调伏
  设处深山心不宁　　贪火焚烧无暂住
  忘失一切佛功德　　方便智慧头陀行
  如是诸善悉不行　　堕大阿鼻无有出
  常谈国城聚落中　　官事贼事眷属事
  如是昼夜恒思惟　　未曾时暂行三昧
  复于精舍起贪心　　广修院宇及房屋
  全无持诵及焚修　　但为眷属兼徒弟
  若有苾刍依附我　　我即与汝同居止
  若欲持戒奉律仪　　非我所为须远离
  所有卧具床榻等　　什物受用及饮食
  藏隐深房映蔽之　　言无所有令他去
  如是末世愚痴人　　令佛教法不久灭
  贪求利养断善根　　此等苾刍极甚多
  若有清净智慧者　　远离彼等住深山
  末法苾刍无戒德　　不乐深山寂静居
  常处王城聚落中　　唯务是非及斗诤
  反为王法所禁制　　叱诃驱摈受惭耻
  诸佛法教功德海　　因此破戒悉枯竭
  譬如宝海水清净　　或被淤泥而浑浊
  亦如莲花满池开　　或被狂风而摧坏
  如是末法破戒人　　损灭佛教亦如是
  若有净修梵行者　　逢斯恶友常远离
  彼人命尽堕阿鼻　　受苦百千无数劫
  从此地狱受罪已　　或生畜趣或为人
  贫穷下贱及聋哑　　眇目矬陋多疾病
  手足诸根不完具　　见者悉皆生惊怖
  无信无行无善根　　昼夜饥寒常忧苦
  复被众人生嗔恨　　以其瓦石而捶打
  如是三苦常缠缚　　一切罪业应远离
  常须亲近佛法僧　　净持戒律头陀行
  如是名利并眷属　　如幻如化如影像
  有为之法暂时间　　不久乖离即散坏
  唯有无上佛菩提　　妙地十力波罗蜜
  坚固修习勿生疑　　未来究竟大安乐

尔时世尊说此颂已。告尊者护国言。若有补特伽罗。于菩萨乘不依法行。有是过失者。当得不依法者而来敬爱。懈怠者得懈怠人敬爱。无智者得无智人敬爱。如是互相敬爱。贪着利养。嫉妒贵族。懈怠狂乱。绮语两舌。谄佞他人。虚诳父母及自师长。或入王城及诸聚落。不为利益众生化诸群品。一向妄言。我是大智多闻博识。诳惑有情唯求财利。轻弃善法都无所获。犹如破器无堪贮用。于彼众人多生怨恶。听信邪言虚妄推度。是法说非非法说是。于佛正法无心爱乐。生于下族贫贱之家。为见少利来投佛法希求出家。及得为僧行非梵行。于佛法教全无所成。何况大智。佛告尊者如是补特伽罗。不应说法。人天之善尚不能续。何况菩提而得成就

尔时世尊复告尊者护国言。有八种补特伽罗。远离菩提。不得为说殊妙之法。护国白言。何等八种补特伽罗。唯愿说之。佛言。一者蔑戾车处于彼受生。二者贫穷之家于彼受生。三者下贱之家于彼受生。四者纵得人身丑陋痴钝。五者具足盖缠。身心忧戚。六者弃背贤善亲近恶友。七者长有疾病身体尪羸。八者众苦逼迫直至命终。如是八种补特伽罗。远离菩提。不得说法。于是护国复白佛言。不应说法更有何义。佛言护国。若有补特伽罗无决定者。我不说菩提。于虚妄者。我不说清净行。于懈怠者。我不说菩萨行。于悭吝者。我不说供佛行。于我慢者。我不说波罗蜜清净。于无慧者。我不说断疑法。于嫉妒者。我不说心清净。于无信根者。我不说总持法。于无德者。我不说善逝法。于贪亲爱者。我不说身清净。于不善律仪者。我不说谤佛有过失法。于妄言者。我不说语清净。于我慢者。我不说恭敬法。于无识者。我不说修学法。于为身命者。我不说求于道法。如是补特伽罗。不应说法。时护国白言。于意云何。佛言护国。为此有情愚痴迷惑。心识颠倒虚妄分别。不依法教。乃至天上人间不应为说。尔时世尊而说颂曰

  不定诸有情　　补特伽罗等
  我慢自贡高　　贪着于利养
  恒行不律仪　　深着于五欲
  增长诸烦恼　　远离佛菩提
  退失于善法　　懈怠不修习
  犹豫多散乱　　于其戒法言
  而不生信受　　因为贫穷逼
  方便求出家　　设得作苾刍
  轻舍于道法　　如弃金宝担
  荷负于麻担　　虽欲入深山
  到彼寂静处　　无意乐修禅
  邪思而散乱　　障碍于辩才
  沉没大智慧　　坠堕恶趣中
  设复得人身　　丑陋不具足
  懈怠性愚痴　　不行众善法
  诸根常暗钝　　堕大崄难中
  经彼俱胝劫　　迷没不解脱
  若行邪利济　　得证佛菩提
  调达不正知　　应成善逝果
  若人贪利养　　坠堕于众生
  如空大风力　　能堕诸飞鸟
  邪福势尽时　　其义亦如是
  无信破戒者　　见善如盲人
  譬如焚尸柴　　不吉人嫌弃
  虽复发善心　　无彼广大智
  谤法不信故　　解脱非究竟
  譬如画无胶　　庄严色不久
  我慢自贡高　　其义亦如是
  若求佛菩提　　不惜于身命
  于法甚深言　　勇猛勤习学
  舍善行非法　　所行增过失
  堕于大火坑　　若闻如是法
  依法而受行　　断除贪爱心
  修植众德本　　乃至于一句
  通达悉明了　　如是积功德
  成就最上道　　永离于愚盲

尔时世尊说此颂已。告尊者护国言。我于过去无量无边不可说不可说阿僧祇劫。时有佛出世。号曰成义意如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时有大国王。名曰发光。主阎浮提。其地广阔一万六千由旬。其中州城数满二万。其发光王所居城邑。名曰宝光。其城东西长十二由旬。南北阔七由旬。城有七重七宝所作。彼王善行八正之道。种族豪盛有千俱胝。其国人民寿十俱胝岁。王有太子。名曰福光。诸根具足色相端严殊妙第一。太子生时有千宝藏从地涌出。内有一藏现王殿前。满中七宝高七人量。复令一切众生所作如意。乃至禁缚之者俱得解脱。又彼大子生得七日。一切伎艺工巧算术皆悉明了。乃至世出世间一切事业无不通解。于夜分中有净光天子来为说法。告太子言。福光谛听。汝须息心不应散乱。于诸尘境常当远离。昼夜思惟有为之法当观无常。寿命尽时谁是救者。于诸非法而生怖畏

佛说护国尊者所问大乘经卷第二佛说护国尊者所问大乘经卷第三

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

尔时净光天子而说颂曰

  太子汝当知　　莫着于迷醉
  于此崄难中　　勤求于出离
  如佛所说言　　若离迷醉者
  此人大勇猛　　善行于律仪
  清净无瑕秽　　所见诸众生
  心生慈愍行　　成佛当不久
  过去一切佛　　现在及未来
  皆从众善生　　远离贪嗔痴
  饮食及衣服　　金银摩尼宝
  种种庄严具　　舍施利众生
  广历俱胝劫　　一心求菩提
  未曾有疲懈　　或舍于身分
  头目手足等　　于彼求乞人
  心生大欢喜　　以此积功德
  而成佛菩提　　设处国王位
  豪贵而最上　　美女及眷属
  昼夜常围绕　　宫殿及国城
  悉皆如幻化　　譬如坏器等
  阳焰水沫泡　　其体不坚牢
  非实非久住　　如是无常法
  虚妄汝当知　　父母与妻男
  谁能相救济　　所作善恶业
  是人随业行　　如是无数劫
  常沉生死海　　亦如无目人
  于境而不了　　虚受于勤劳
  终堕崄恶趣　　菩提最上路
  勇猛精进行　　乃至于命终
  不生三恶道　　佛世人难值
  正法难得闻　　降伏烦恼怨
  亲近于善友　　恒修入正道
  安住菩提心　　不退于佛道
  如是行方便　　世间无有上
  过去一切佛　　舍离于亲爱
  常处于深山　　正念自思惟
  坚固如金刚　　志求无上道

尔时佛告尊者护国言。净光天子说此颂已。彼福光太子年至十岁。智慧明达而无戏论。于世所有园林花卉流泉浴池歌舞作乐而不爱着。乃至国城宫殿象马车乘金银财宝。一切所欲之事。悉皆远离。一心思惟。我身虚幻四大假合无有坚实。大地诸天悉非究竟。凡夫众生常行非法。愚痴迷惑分别亲疏。耽着欲乐无有厌足。永处轮回无解脱时。我于如是愚迷人中而乃受生。作是念已。志意系心专求解脱

尔时世尊复告尊者护国言。彼发光王为其太子。选择最上净妙福地。建置一城名曰爱乐。其城七重于其城中有七百街道。纯以七宝铃铎真珠罗网遍覆其上。复有六十众宝妙盖八万宝幢。于诸街巷次第行布。一一宝幢有六万宝索。一一宝索有十四俱胝乐器。如是乐器微风吹动。出妙音声如百千天乐。又于此城街巷衢路处处各住五百童女。是诸童女身相端严颜貌和悦。于诸音乐歌舞作倡一切悉能。时发光王敕告之曰。令诸童女昼夜作乐不得间断。所有四方一切人民来入此城。见斯音乐快乐之事奔聚看玩。令其太子心生乐着。又复王言。所有众生。求饮食者施以饮食。求衣服者施以衣服。求花鬘涂香者施以花鬘涂香。求床榻卧具者。施以床榻卧具。乃至以金银摩尼砗磲码瑙珊瑚真珠吠琉璃等。如是诸宝处处堆积。复有象马车乘。皆以众宝种种庄严。令一切众生随意受用

尔时发光王。复为太子。于此城中修建一宫广一由旬。造四门楼户牖轩窗。皆以七宝种种庄严。于此宫中置一大殿。用百千珍宝周匝庄校。于殿中间安四俱胝众宝床榻及以卧具。复于城中置一大园。花果树木其数甚多。蓊蔚开敷世所希有。于其中间排一切宝树。光明照曜无不爱乐。又于园中有七宝池。于池四边有四界道四宝所成。所谓金银吠琉璃玻璃于池周匝。置一百八师子口水从彼入。复置一百八师子口水从彼出。其中复生钵讷摩花。乌怛钵攞花。俱母那花。奔拏哩迦花等。种种名花恒时开敷于池周匝。复有八百宝树。一一宝树各悬宝索。一一索上有俱胝数乐器。微风吹动出妙音声。令诸众生闻者爱乐。复次宝树悬挂八十百千珍宝妙幡。又于池上置大宝网。而以为盖覆太子身令离尘坌

尔时发光王。复令殿内以其七宝造四俱胝宝座。一一宝座各以五百上妙之衣敷于座上。于其中间置一大座高七人量。以八十俱胝上妙宝衣敷设其上。此是福光太子所登之座。于诸座前各置香炉纯金所成。于炉周匝悬金铃铎及金莲花。摩尼宝网四面严饰光明照耀。昼夜三时恒爇沉香及散妙花。复于园内有九十九百千摩尼宝。一一摩尼宝广一由旬。有大光明照一切世界

尔时世尊复告护国言。福光太子园苑之内。有种种飞鸟。鹦鹉鸲鹆。鸳鸯鹅鸭。孔雀舍利。俱枳罗鸟俱拏罗鸟。迦陵频伽。命命鸟等。如是众鸟俱善人言。每群飞时作微妙声。如众音乐而无有异。亦如天帝欢喜之园。令诸天人受妙快乐。彼发光天子。复为太子修馔上味饮食。逐日供给五百千车。复令使命于诸城邑聚落。选取童女年十六岁至二十岁者。色相端严诸根具足。不长不短不肥不瘦不白不黑。身出白檀香口出优钵罗花香。言词美善。心意纯直而无妒忌。善解博奕歌舞戏乐。乃至一切世间。工巧伎艺无不悉解。如是童女。得八十俱胝来入王城

尔时发光天子。以此八十俱胝童女赐于太子。王自宫中所有童女。复赐一俱胝王诸亲眷。亦以一俱胝童女奉上太子。宰辅重臣亦以一俱胝童女奉上太子。国城庶民亦以一俱胝童女奉上太子。如是八十四俱胝童女。俱令侍从承事及歌舞作乐悦乐太子

佛告尊者护国言。尔时福光太子。见是事已。于其国城宫殿楼阁。园林池沼象马珍宝。及诸童女歌舞唱妓。种种作乐之事都不爱着。而自思惟。此诸女等于我身分为大恶友。断我善根增诸烦恼。常处轮回。无有自在。譬如有人处于禁缚终不能出。尔时太子。见此过失。于十年中。于色声香味触五尘诸境而不爱着。一心思惟。诸恶友众云何舍离。而自修行得其解脱。作是念已。彼诸童女即诣王宫。白父王言。其福光太子。于诸婇女戏乐歌舞都不顾视。独坐思惟远离声色。尔时发光天子。闻是事已。心忽惊愕怪未曾有。即时统领八万小王及诸臣从。来入太子所住宫中。见彼太子。孤处宫殿仪貌寂然。涕泪悲泣心大苦恼。迷闷躄地良久乃苏。从地而起即说颂曰

  子为最上宝　　云何不观我
  忧恼心惶乱　　云何舍所爱
  种种富乐事　　此城妙庄严
  众宝为严饰　　宫殿妙楼阁
  园林及浴池　　象马七珍财
  衣服及饮馔　　如是无量数
  而以供给之　　复有诸童女
  容颜甚奇妙　　端正广庄严
  如彼天女相　　心性善纯直
  通达诸伎艺　　歌舞及音乐
  人间无有比　　所为适悦汝
  令其心快乐　　云何无所著
  于斯而舍离　　独处于深宫
  颜貌甚寂澹　　令诸童女等
  各各怀忧恼　　如彼莲花萎
  俱来而白我　　太子汝当知
  如是诸童女　　端正俱年少
  口出优钵香　　身有栴檀气
  两目绀如莲　　善知人心意
  令于昼夜中　　亲近作戏乐
  今汝正是时　　于此而厌弃
  于汝意云何　　为我速宣说
  又向园林中　　安置摩尼宝
  九十九百千　　各广一由旬
  光明普照耀　　宝树悬宝幡
  其数有八万　　花果皆茂盛
  具有众飞鸟　　孔雀及鹅鸭
  迦陵频迦等　　皆出微妙音
  复于诸树间　　各垂于宝索
  一一宝索中　　皆有妙乐器
  微风吹动时　　出于妙音声
  清响如天乐　　云何而不恋
  又此诸宫殿　　皆以众宝成
  金银摩尼珠　　砗磲与码瑙
  琉璃真珠等　　庄严甚微妙
  于此宝殿中　　安置金香炉
  四面垂珠网　　俱胝细妙衣
  以用庄严上　　昼夜三时中
  长爇栴檀香　　如彼天帝宫
  善法堂无异　　汝今不爱乐
  违背于父母　　都无孝敬心
  令我增苦恼　　言已而悲泣
  为我速宣说　　太子见所问
  稽首白父王　　世间五欲境
  坠堕于众生　　缠缚于有情
  增长大过失　　永处于轮回
  无有得出离　　我今求解脱
  发大菩提心　　远离诸尘染
  一切女人身　　众恶不净本
  我观如怨家　　贪嗔镇相随
  流浪于生死　　牵系诸众生
  常处大崄路　　又此女色相
  皮肤裹不净　　血肉与骨髓
  肠胃大小便　　[目*(山/虫)]泪洟唾等
  如是秽恶身　　云何令爱乐
  譬如毒药树　　开花众所爱
  采花毒入身　　不觉殒其命
  国城与宫殿　　音乐及歌舞
  究竟不坚牢　　如梦如幻化
  亦如春树木　　滋茂叶芬芳
  才至冬月时　　凋落悉枯悴
  女人及富饶　　不久亦如是
  愚痴狂乱心　　常没贪欲海
  斗诤起憎嫉　　互相行杀害
  父王及眷属　　妻子并男女
  于彼恶趣中　　谁能行救济
  菩萨大智人　　身心常寂静
  观彼如草木　　不动如须弥
  常乐处深山　　一心求正道
  浮世不久住　　如山水急流
  人命若浮云　　须臾即散灭
  坠堕三有中　　迷没于生死
  我不着愚迷　　远离于虚妄
  色声五欲尘　　非是菩萨境
  福尽无福生　　业尽复生业
  如鸟禁笼中　　长不得自在
  六尘如毒蛇　　损恼于众生
  四大不坚实　　犹如空聚落
  父王今当知　　速舍虚妄境
  归趣真解脱　　常运妙法船
  度脱于三有　　迷者令觉悟
  禁缚得解脱　　患苦使获安
  盲者与开目　　贫穷赐珍财
  悉令离忧苦　　复为众有情
  枯竭贪爱河　　照烛黑暗路
  广布于云雷　　降霔甘露雨
  除热得清凉　　成就最上智
  父王今当知　　何人怀慈忍
  而欲作怨家　　何人具智慧
  怖见佛法僧　　何人有眼目
  入于崄路行　　何人得菩提
  而欲作散乱　　如斯有智人
  必不行邪道　　我宁上须弥
  投身入大海　　于此五欲尘
  终不生染着　　所有诸婇女
  并及于眷属　　请王速将归
  于此勿久住　　在家多过失
  障蔽佛菩提　　我舍于国城
  及诸眷属等　　行诣于深山
  修习清净行　　志求无上道

尔时佛告尊者护国言。彼福光太子处于宝殿。是诸童女围绕侍从。太子观之深生厌离。于三威仪中行住坐时。求断一切烦恼。于月初八日于地而坐。正意思惟离诸尘染。作是观已于中夜时。忽闻空中净光天子赞佛赞法及苾刍众。如是闻已。身毛皆竖悲喜交并合掌向空以颂问曰

  虚空诸天大慈愍　　发声称赞赞何人
  我要归依求出离　　愿乐听闻为开演

尔时净光天子。于虚空中闻彼所问。而为太子说所赞事。以颂答曰

  我今称赞大沙门　　彼佛名曰成义意
  常以十善化群迷　　救济孤独诸有苦
  方便智慧最为上　　功德神力无有比
  常有十千那由他　　苾刍之众恒恭敬
  太子复问净光天　　有何功德及相好
  彼佛所行菩提行　　重为宣说我乐闻

尔时净光天子。复为太子说佛功德相好。以颂答曰

  佛顶如须弥　　出众而高显
  螺发而绀青　　右旋俱齐整
  眉间白毫光　　照耀如千日
  目绀净分明　　犹如青莲叶
  颔臆如师子　　唇色胜频婆
  齿密无缺减　　白类如珂雪
  脐轮广右旋　　如净颇璃宝
  舌色如红莲　　广长而薄净
  舒展覆面轮　　此相最微妙
  梵音而清响　　美妙出世间
  一切诸天人　　闻者皆欢喜
  假使百千乐　　莫等佛音声
  功德广无边　　能断众生惑
  令行菩提行　　复次诸飞鸟
  名曰紧那啰　　鸳鸯俱枳罗
  嚩哩呬拏鹅　　具沙俱拏罗
  迦陵频伽等　　各有色相严
  佛相好亦然　　佛以一言辞
  随众各得解　　近远平等闻
  如来法自在　　项颈长细妙
  量等于身分　　臂膊而佣圆
  垂手过于膝　　如是妙端严
  七处皆平满　　双肱如象鼻
  两腨胜鹿王　　阴相而藏隐
  犹如龙马王　　身毛绀右旋
  无畏如师子　　佛顶如天盖
  严饰金色身　　行步同牛王
  足现千辐轮　　莎悉帝迦相
  如是广端严　　世间甚希有
  汝今若亲近　　有德与无德
  有福及无福　　一一自当知
  若有称佛名　　赞毁俱不着
  如莲在水中　　淤泥不可染
  我佛大导师　　世间无有上

佛说护国尊者所问大乘经卷第三佛说护国尊者所问大乘经卷第四

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

佛告尊者护国言。尔时福光太子。闻虚空中净光天子赞佛法僧无量功德相好庄严之事。心大欢喜正意系心端坐思惟。彼佛世尊具足功德。所说妙法真实无谬。声闻弟子梵行清白。又复思惟轮回大苦。一切众生愚痴障蔽不觉不知。常以身见起诸惑染广增过失。生死轮回相续不绝。诸有智者应当远离。又复思惟愚痴迷暗。起三种思动发身语。造善恶业熏识成种。如是名色六入触受苦报相续。爱取缠润增长有支。如是结生老死谁免。我观生死少味多苦。逼迫身心是可厌患。速宜亲近彼佛如来微妙之法。断诸烦恼求出轮回。若近恶友耽着欲乐。人天之报尚不能得。何况阿耨多罗三藐三菩提

尔时福光太子。作是念已。于此宫城深生厌离。我今于此终不解脱。宜应速舍别求静处修习梵行。时彼太子发此志已。即便离殿欲往门出。又虑亲眷而为留难。遂却上殿面东而立。遥告佛曰。成义如来应正等觉。具一切智神力广大。愿赐慈悲救护于我。我于此处掷身出外。欲求解脱。作是语已即便掷身。佛以神足舒其右手。放大光明照太子身。其光化为千叶莲花承太子足。又此莲花复出百千微妙光明。照于太子令心适悦。经须臾间将至佛前。佛摄光明莲花不现。尔时太子如山而下。即到佛前合掌恭敬。旋绕世尊志心称念。南无成义意如来应正等觉所说妙法。及苾刍众我悉归依。作是语已。五体投地礼佛千拜即以伽陀赞叹佛曰

  稽首无上大医王　　我身大患久未除
  愿佛慈愍垂救度　　少赐如来妙法药
  昼夜独坐自思惟　　一心求离五欲境
  空界天人发声言　　劝导归依来佛所
  佛为出世大导师　　何得众生造过失
  于大难中垂救护　　令彼盲迷开智眼
  我今虽发信佛心　　贫乏如来功德宝
  求出缠缚趣解脱　　愿佛慈悲垂摄受
  于其暗室燃慧灯　　破我疑惑无明等
  宣扬清净妙法门　　如佛所行菩提道
  稽首无比大医王　　满我意愿除诸病
  一切妄想悉消除　　抛离恶趣到彼岸
  永出烦恼大海中　　常行如来八正道
  如是真实为我说　　如佛所说我行之
  志求无上大菩提　　修习菩萨真实行
  成就福德无尽报　　舍于世寿为法寿
  一切缠缚永断除　　究竟圆满菩提道

佛告尊者护国言。尔时成义意如来。见彼太子信心清净善根纯熟。即为宣说菩萨行法。福光太子闻是法已。得总持门证妙解脱。成就五通踊身空中散花供养。作供养已从虚空中下。合掌向佛赞叹如来。即说颂曰

  稽首我佛真金色　　相好最上面如月
  功德智慧无等伦　　永离三有常清净
  牟尼螺髻绀青色　　高显清净如须弥
  我观无等无边佛　　眉间毫光普照耀
  如军那花及朗月　　过于珂雪与砗磲
  如是皎洁大光明　　除灭众生诸罪暗
  目净辉朗如青莲　　常以慈颜顾我等
  怨亲无二平等观　　有情无情俱获益
  舌如赤铜而广长　　或覆面轮或大千
  应机流演大小乘　　普救世间诸有苦
  我今顶礼如来齿　　四十齐密白如珂
  四牙锋利若金刚　　俱发光明济群品
  我今礼佛真实语　　离诸虚诳绮言辞
  通达性相甚深文　　破暗除迷百千刹
  梵王帝释护世主　　龙天八部及三涂
  如是蒙光苦恼除　　俱出轮回生死海
  我佛双腨如鹿王　　行似牛王举步稳
  下足登涉地面时　　山川大地俱震动
  我佛身相妙端严　　皮肤柔软真金色
  一切世间无有比　　众生见者无厌足
  佛于过去百千劫　　能舍一切利众生
  俱令离苦出烦笼　　我今归礼大慈父
  佛以法财施一切　　持戒忍辱精进修
  禅定智慧悉圆明　　我今礼佛无等智
  我佛无畏大师子　　能破无边烦恼魔
  善疗众病悉消除　　我今顶礼灭三毒
  身口意业无尘染　　三界无著出水莲
  梵音深妙如梵天　　迦陵频伽声莫比
  我今礼佛出三有　　常观世界如幻化
  如梦如电非久停　　无人无我无众生
  法本空寂无有生　　不能知悟随轮转
  垂慈广为诸众生　　方便随机宣妙法
  大圣医王众所归　　恒治老死忧悲恼
  如是普利诸众生　　各令善逝人天路
  如是慈悲牟尼主　　常愍轮回六道中
  如蚁循环无了期　　引彼愚盲得正路
  如是依法证菩提　　具法自在利世间
  如佛所说八正道　　闻者适悦生敬爱
  佛声微妙过梵天　　巘达哩嚩紧那啰
  及诸天女美妙音　　非似佛声多方便
  清净语音功德普　　众生随类各得闻
  如是为乘趣菩提　　一一离凡得解脱
  种种上妙物供佛　　获得最上人天福
  或为帝主或宰臣　　常受大富大快乐
  或作金轮王四洲　　具足千子及七宝
  恒行十善利世间　　一切众生皆随顺
  或为护世或忉利　　或处夜摩睹史陀
  及至他化与梵天　　皆因供养诸佛得
  如是见佛及听法　　俱能出离诸苦恼
  令彼不堕恶道中　　安乐寂静无尘染
  佛能安住诸世间　　求福之者皆令福
  如是获福长相续　　俱胝多劫不可尽
  最上微妙庄严刹　　众生生者无尘垢
  身光照耀胜天人　　身口意业俱清净
  成就种种功德相　　名闻流布诸世间
  天上人间俱敬爱　　彼人供养诸佛得
  我佛久离诸苦恼　　十方佛刹皆称赞
  一切徒众悉归依　　无不爱乐慈悲相
  我今稽首人中尊　　湛然不动无为相
  令我获证五神通　　住立虚空伸赞佛
  稽首无畏佛世尊　　无垢清净出世间
  所有称赞诸功德　　回施人天成正觉

佛告尊者护国言。尔时发光天子。于其中夜忽闻福光太子宫城之内有大哭声惊愕忧惶。莫知凶吉。即时将诸臣从及其眷属。来诣太子宫中问诸宫人。汝等云何夜来啼哭。时彼宫人即奏王言。福光太子。忽尔离宫莫知所止。忧惧悲痛是以啼哭。尔时发光天子。闻是语已足如蹋险。忽然躄地良久乃稣。从地而起心生忧恼。涕泪悲泣欲往千城处处寻觅。时爱乐城中护城圣贤。告于王言。彼福光太子往诣东方。礼觐供养成义意佛。时发光天子闻是语已。即将八十四俱胝宫人婇女。及百千那由他侍从眷属。周匝围绕往诣东方。至成义意如来处。到已。五体投地。礼世尊足。住立一面合掌向佛。以颂赞曰

  稽首归依功德海　　妙湛总持无等尊
  天龙八部众所归　　一切观佛无厌足
  三十二相妙端严　　七宝严身世希有
  巍巍赫赫妙金山　　超出世间归命礼
  过去难思俱胝劫　　修行供养俱胝佛
  深植德本广无边　　成就佛身妙色相
  布施持戒忍辱行　　精进禅定善巧便
  如是历修胜行成　　色相圆明光照耀
  日月闪电摩尼宝　　帝释梵王身色光
  如是等光对佛光　　一时隐没俱不现
  佛身如现水中月　　变化随机亦复然
  托梦乘象入母胎　　舍于睹史天王位
  佛身无相如虚空　　示生人世救群品
  初生七步帝释随　　天上人中为最上
  彼佛无法不了知　　亦无师学书自解
  而成寂静三摩地　　救拔众苦令解脱
  舍离父母及亲眷　　出彼王城入深山
  俱胝天众围绕佛　　降伏四魔成正觉
  观彼世间不究竟　　众生沉溺处轮回
  垂慈为彼转法轮　　令离无常出苦难
  佛证寂灭清净法　　成就福智及方便
  牟尼起化现身光　　如是佛相悉具足
  我礼牟尼无边智　　我礼究尽法界法
  虽知幻化无去来　　垂慈普救诸含识
  善哉佛说菩提道　　引彼众生得菩提
  如是正法我所求　　正法能度世间苦
  我佛常处三有中　　救疗一切烦恼病
  以我称赞佛功德　　回向菩提及众生

尔时佛告尊者护国言。彼成义意如来。见此发光天子归依赞叹信心坚固。求趣解脱。即随王意而为说法。时发光天子闻佛所说。即于阿耨多罗三藐三菩提。得不退转

尔时福光太子。见是父王归依彼佛心生信敬。即诣佛前。合掌向佛而白佛言。如来应供正遍知。唯愿世尊。往爱乐城受我饮食供养。时成义意如来。默然许之。受太子请时。福光太子。即告父王及诸眷属。我今请佛。所有宫殿园苑及一切珍宝庄严之具。施佛供养。汝诸眷属勿为障吝。异口同音起随喜心。尔时父王及诸眷属俱发声言。愿舍所有施佛供养我皆随喜

尔时成义意如来。与诸苾刍恭敬围绕。入爱乐城受彼供养。时福光太子。以五百千车上妙饮食。供养世尊及苾刍众。复次福光太子。为佛及众广以七宝造僧伽蓝。用无数摩尼宝网及伞盖等四面严饰。复置百千床榻卧具。以妙衣服敷设其上。又于精舍左右。行布花果树木流泉浴池。于其池中生奔拏哩迦花及优钵罗花等。复次于一一苾刍前。头面作礼献僧伽梨衣。日日三时亦复如是。经三俱胝岁昼夜焚修。亦不眠卧亦无疲倦。亦不沐浴洗濯香鬘涂饰。亦无嗔恚贪爱。乃至为法不惜身命。何况外财如佛所说如说而行。乃至成义意如来入于涅槃。尔时太子。以赤栴檀茶毗如来。于阎浮提内所有一切上妙名花。及诸花鬘。涂香粖香种种伎乐。于茶毗处供养舍利。尔时阎浮提内一切众生。俱以香花饮食皆来供养。如是经百千岁

尔时福光太子。收佛舍利。以其七宝造九十四俱胝塔。俱以真珠罗网周匝严饰。又诸塔前竖立五百七宝伞盖花果树木及百千音乐。又一一塔前置百千灯盆。每一一盆中燃百千灯。如是供养至一俱胝岁。然后太子出家剃发。为苾刍相。行头陀行。持钵乞食伏断烦恼。常行法施满四俱胝岁。如佛所行无有疲倦。时爱乐城中护城贤圣。一切小王宫嫔眷属及诸众生。皆学太子出家剃发修清净行。时净光天子。互相告言。一切小王及诸人民等悉皆出家。我等往彼承事太子。如供养三宝。尔时成义意如来所说。六十四俱胝法藏。福光苾刍悉皆受持通达无碍。如是福光苾刍已曾亲近九十四俱胝百千那由他佛。于诸佛所一一供养无空过者。皆如成义意如来而无有异。尔时发光天子者。岂异人乎。今无量寿如来是。尔时福光太子者。岂异人乎。今我身是。尔时爱乐城中护城贤圣者。岂异人乎。今阿閦如来是。佛告尊者护国言。一切菩萨摩诃萨。欲求阿耨多罗三藐三菩提者。应当学彼福光苾刍。远离贪爱亲近善友。修寂静行勤供诸佛。不久当得阿耨多罗三藐三菩提。佛言护国。若复有人贪着利养。饮食衣服卧具医药。尊重称赞。彼人愚痴则为我慢。破犯戒律虚妄不实。毁谤沙门远离佛法。于身口意而不相应。唯有外相心不寂静。无惭无愧。远离佛刹远离菩提。是故护国闻如是法。应如是知应如是学应如是行。不得亲近恶友及利养等。尔时世尊而说颂曰

  若人贪爱于利养　　远离真实清净行
  因斯退失佛菩提　　永劫沉沦生死道
  无惭无愧无知足　　常爱常贪恒系缚
  不惧三涂苦恼侵　　犹言我具诸德行
  诈现寂静住山间　　心于名利常牵系
  众人远离如毒蛇　　长处轮回无解脱
  若人不乐如来法　　轻贱具德苾刍僧
  永离天界堕恶道　　纵生人世堕八难
  俱胝劫数难值佛　　所说正法亦难闻
  刹那暂遇若依行　　彼人必证菩提果
  佛乘妙行德难思　　一切如来从此出
  若人厌离乐尘劳　　永失菩提无上道
  若人智慧及方便　　远离一切诸过非
  愍救五趣诸众生　　是人所行同佛行
  虽处深山寂静处　　诈现清高为自身
  掩他行业谈己能　　我常日诵俱胝佛
  若于行法生尊重　　不吝身命一心求
  如我所说真实行　　是人非远证菩提
  大仙正法最上乘　　永得消除于热恼
  如闻所行精进修　　毕竟速证无上道

尔时世尊说此颂已。告尊者护国言。若诸菩萨于阿僧祇劫行五波罗蜜。不如有人于此正法暂得听闻信解受持。如是功德胜前功德。百分不及一。千分不及一。百千俱胝分不及一。算数分不及一。乃至譬喻分亦不及一。佛说是经时。会中有三十那由他天人发阿耨多罗三藐三菩提心得不退转。七千苾刍断尽诸漏得无生忍。尔时尊者护国而白佛言。今此经典甚为希有。云何受持当何名之。佛言护国。此经名为大乘正法。亦名广大清净不空誓愿福光居士欢喜菩萨行。如是受持佛说此经已。尊者护国及天人阿苏啰巘达哩嚩等。闻佛所说皆大欢喜。信受奉行

佛说护国尊者所问大乘经卷第四


佛说幻士仁贤经

    No. 324 [No. 310(21)]

佛说幻士仁贤经

        西晋月氏国三藏竺法护译

闻如是。一时佛在王舍城灵鸟山。与大比丘众千二百五十菩萨五千俱。皆神通菩萨。一切大圣悉得总持辩才无碍。其名曰师子菩萨。师子意菩萨。诚乐菩萨。道御菩萨。大御菩萨。光首菩萨。光净菩萨。寂意菩萨。人明菩萨。开化人菩萨。常应菩萨。慈氏菩萨。文殊师利六十贤者。一切五千菩萨。皆此上首者也。焚王帝释。四王诸天。龙王神无央数。于时国王大臣长者居士群臣僚属。供奉世尊衣被饮食医药床卧之具。世尊名称普闻远至。是为如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。诸神通慧普见所睹无余。如来十力四无所畏十八法不共。不舍大慈不废大哀。慧眼佛眼具足变化无极。神足变化。说本变化。教授变化得无极。发意之顷。能使三千大千世界州城河海。须弥众山龙神天宫。铁围山川。沟坑树木。国邑墟聚。在一毛孔。从劫复过一劫。是时王舍大城中。有一幻士名曰颰陀(晋言仁贤)。明经解术晓了幻伎。所作巧黠多所喜悦。所兴如意名闻于远。其摩竭国诸余幻者皆所不及。所至到处最上第一。除诸见谛清净士女得法忍者。一切人民莫不倾侧。如所言者无不迷惑。随未曾有法。而以此幻邪行之术。得众利养。幻士仁贤。闻佛世尊名称普徽如来至真等正觉。闻已自念。我身转化摩竭人民及诸州城。莫不受教。唯未化沙门瞿昙。亦未曾试及诸弟子。我宁可试知可惑不。假能惑者。摩竭人民皆共同心来供事我。于是仁贤。缘本功德承佛威神。出王舍城至灵鸟山。见佛世尊。光踰日月百千亿倍。明净无垢光炎远照。髻相之耀灼若摩尼。晔如莲华清净。超梵八部音说法广度。见佛色身具足严妙。意甚踊跃心自念言。我欲试佛诸通之慧审普见不。便行趣佛。稽首作礼。用试佛故。缘此请佛。设知我意当不受请。若不知者必受无疑。佛知其意。愍伤仁贤及王舍城一切人民。欲度之故默然受请并比丘众。时仁贤念。沙门瞿昙。无诸通慧亦不普见。以不见故今当晓试。是时仁贤。稽首作礼绕佛三匝而退。贤者大目揵连白佛言。幻士仁贤内怀诳诈。请佛及僧云何受之。佛告目连。汝且安默。如来深究一切群民长夜迷惑。因化立之以平等行。天上世间无能施秽欺惑佛者。如来以断淫怒痴乱。无余瑕垢灭诸缚着。离八十垢得不起法忍。以故三界无能惑者。一小幻士何所能谐。如来解畅一切法幻。自致最正觉。使诸人界及其本原。皆使巧妙幻过。仁贤终不能与佛幻术等。百倍千倍无数亿倍。不可假托以为比喻

佛告目连。于意云何。幻士仁贤。宁能庄严化三千大千世界令净好不。对曰唯然。此幻不能。佛言。如来发意之顷。能使三千大千世界严净入一毛孔。佛之幻术终不惑。正使十方佛国。有风名随岚及断截风。飘坏三千大千世界。还复如故。有风名追逐风住止风。旋转世间。有风名曰波栗屠那。回行三十二天。有风名曰摧破崩坏须弥。有风名曰拘那。起大火上至三十二天。有风名曰常来。起劫烧天地。有风名曰炽火。使三千大千世界一时俱然。有风名曰浇洒。起大雨。有风名曰枯竭。除尽水灾之变。佛告目连。今我粗说是诸风名。从劫过劫无有竟时。云何目连。宁有人能止虚空。坐诸风之中作四器行。使此诸风入一芥子。其于芥子无所挂碍亦无毁害。令诸天人安隐娱乐而不惊怖。如来幻法而复过是无有极也。非弟子缘一觉地之所能及。于时目连在众会前。稽首作礼白佛言。唯然世尊。我等为得善利。所以者何。世尊威神巍巍如是大尊无极。其人民闻佛如来此变化者。欢喜踊跃逮得善利。便发无上正真道意。一时欣然功德无量。于是幻士仁贤。入王舍城还归到家。即其日夜。于城内秽恶流聚最不净处。化于其中作大讲堂。悬缯华盖而起幢幡。现地平正树木茂盛。瓶罃珍器香炉镫锭。散众华香。于讲堂傍殖八千宝树。枝叶华实众色馚馥。一一树下为诸比丘敷师子座。于讲堂中央。特为如来设师子座。众宝为足挍饰无量。高四丈九尺。于座四面化四宝树。作百味之馔若干种食。其为供者合五百人。端正皎洁宝璎珞身。幻士仁贤化作是已。时四天王。往诣幻士所化作讲堂。谓仁贤言。甚善仁者。乃请如来。于此讲堂而供养佛。宁可听我次助所乏。欲造宫室以奉如来。于是仁贤。益用踊跃得未曾有。报听天王宜知是时。四天王即化作立宫室极妙姝好。仁贤所建厌蔽不现。时天帝释。与三万二千夫人。俱到幻士讲堂。谓仁贤言。善哉快乎。真得善利。乃请如来于化饰讲堂以供养佛。宁可听吾给助所乏。欲造宫殿以奉如来。于是仁贤。倍复踊跃得未曾有。私自疑怪。报听帝释宜知是时。天帝即化作大殿馆。踰于忉利最胜之宫。化殖宝树。超乎已质拘者之树姝好。厌蔽仁贤四王所立。讲堂宫室所校诸树。仁贤则自念言。世尊非凡。乃有如是神妙尊天及诸天子。兴大供养奉事如来。今我宁可没灭我之所建。大为迷谬。岂忍以此举向上尊乎。于是仁贤。欲没所幻而不能灭。遍作诸术亦不可灭。幻食供助讲堂严饰师子之座。永为真实而不可变。仁贤惊怪心自念言。往昔所言。幻现则现欲没即没。今为如来变作化供而不能改。于是天帝知仁贤所念。便告言。如卿为佛化作严净供具。不能变复使如本。故其见如来发欢喜心。常得安隐至泥洹道。尔时仁贤踊悦怡怿。晨旦白佛。饭时已到愿可自屈。于是世尊。着衣持钵。与诸菩萨及比丘僧眷属围绕。往诣仁贤庄校讲堂。佛时变化。使仁贤知坐所为立师子之座。四天王亦见如来坐所造宫师子之座。帝释自念。如来坐我所化庄严之座。时王舍城诸不信法众邪异道。弃自贡高及嗔怒心。一切共诣庄严讲堂。今日共观瞿昙所现感应。其边道法清净士女。悉共喜踊往诣讲堂。今日我等当见如来至真等正觉。听师子吼睹其变化。于是仁贤。蠲除自大稽首佛足。白世尊言。唯愿如来。原我罪过本愚所作。欲乱如来化作此食。助供侍使。师子诸座亦皆化作。心中念悔饮得灭没所可化现。佛为圣尊矜恕为意。诸所施造令不复变。于是佛告仁贤。一切人民及其所有皆如幻化。诸坐比丘亦如幻化。如我之身亦是慧幻。此三千大千世界则复为化。因缘罪福一切诸法亦如幻化。皆由因缘各在合会。便持所化饭食之具分布施设。于是幻士仁贤。梵王帝释四天王。诸助供者。擎化食供养世尊及比丘众

于是贤者大迦叶说偈言

  如今所设座　　及其处上者
  定意为平等　　善哉施无上

舍利弗颂曰

  如今供具心　　及其受者意
  如是常等觉　　是疾毕信施

须菩提颂曰

  是施无所施　　受者无所受
  其有应是行　　是为毕信施

阿难颂曰

  是施为尊乘　　食者无有心
  其身意无著　　是为世众祐

于是光英菩萨曰

  譬如彼幻士　　仁贤现此化
  一切世亦然　　愚者不及解

光造菩萨曰

  譬如坐树下　　悉以幻化作
  所有幻亦空　　适等无差异

师子菩萨曰

  不闻师子吼　　小兽树间鸣
  师子适震吼　　驰走窜十方
  仁贤卿有恨　　以幻惑人民
  如来所现幻　　众魔不能当

师子意菩萨曰

  是饭食化作　　供助者亦幻
  食饭者皆化　　善哉祠无上

慈氏菩萨曰

  油醍醐浇火　　其明益炽盛
  仁贤幻如是　　佛幻为普现

软首童子曰

  譬如本此处　　一切皆化造
  仁贤所兴幻　　欺诳惑众人
  一切法如是　　本为悉平等
  不觉了当来　　愚痴行生死

于是世尊。欲劝化幻士仁贤。则于讲堂之东化造殿舍。长者处其中。谓仁贤曰。今何所作。答曰。我供养沙门瞿昙及比丘僧。长者答幻士勿说是言。今者世尊。在王阿阇世宫而食。及比丘众。时仁贤承佛威神。见佛及僧在王宫食。时佛复化作长者来入讲堂。问仁贤曰。今何所作。答曰今供佛及僧。长者答曰。勿说是言。今佛及僧游于异道分卫。时仁贤承佛威神。见佛之众于异道分卫。复有长者到仁贤所曰。今何所作。答曰供佛及众。长者答曰勿说是言。今世尊在耆域医王后园。为四部众讲说经道。仁贤承佛威神。见佛在耆域后园。为四部众讲法。时天帝释。谓仁贤曰。今何所作。答曰我供佛及众。帝释答曰勿说是言。今者如来。在忉利天昼夜树下为诸天人讲法。仁贤承佛威神。见佛在忉利天为天人说法。幻士仁贤见诸树上。枝叶花实皆有宝座。如来相好具足僧众围绕。在诸化师子座上。四天王帝释梵王。而化师子座皆见坐如来。并王舍城诸街里巷馆宇。皆见如来。遍诸佛世尊前。皆见仁贤悔过自韪。时仁贤目之所睹。不复见余但见如来。幻士喜踊即生善心。用欢喜故得佛意三昧。从定意起叉手于佛前。以颂问佛曰

  今我睹见　　如来神足　　发意之顷
  化若干佛　　其数百千　　复过是限
  若江河沙　　诸佛如是　　我本自谓
  广学幻术　　于阎浮利　　无与等者
  今日观见　　佛之神足　　计挍譬喻
  不可为比　　今我目睹　　不复见余
  普见诸佛　　相好庄严　　是故今我
  欲问法王　　何许是佛　　唯愿尊说
  奉事何佛　　为第一供　　施何所佛
  功德最大　　何所清净　　受施众祐
  愿为说是　　平等普见　　我今首过
  一切所犯　　身所试佛　　世雄导师
  其于尊人　　不行恭敬　　是为自弃
  不得所愿　　诸天已闻　　及与帝释
  于是众会　　一切普达　　我今为发
  菩萨之心　　用一切故　　今悉度脱
  今我为请　　一切众生　　皆使饱满
  甘露安隐　　令睡瞑者　　疾得觉悟
  逮得奇特　　智慧灯明　　谁能化变
  如是所现　　闻其所言　　安定柔软
  其慧无碍　　导行最上　　彼不生心
  道意最尊　　愿为我说　　微妙道行
  为奉何尊　　疾逮佛道　　云何如是
  为具足行　　一切弟子　　所不能及
  无行之行　　德为何类　　正义云何
  而谛听闻　　何谓所乐　　礼节经行
  云何而发　　所生无疑　　云何精进
  闻受无厌　　何时逮得　　坚固听闻
  云如之何　　讲说法教　　何谓光耀
  法皆照人　　云何施道　　而得慈行
  云何得立　　无异之心　　何谓祠祀
  所在充备　　于众人民　　为坚固慈
  云何善师　　当奉习效　　云何恶友
  而当远离　　云何得往　　见佛世尊
  已得见值　　云何供养　　当学何学
  得为上尊　　云何精学　　而得智慧
  云何于戒　　而为清净　　云何逮得
  三昧定意　　何所施设　　成严净行
  云何舍离　　非法之义　　云何于道
  而伏其意　　示现降魔　　欲尘系缚
  云何听受　　思惟经义　　其心不舍
  一切众生　　云何教化　　人物群黎
  坚固奉德　　无所行处　　云何于人
  而不舍行　　善权慈心　　仁爱之迹
  云何神通　　而得具足　　何谓意志
  道心尊特　　云何一切　　得成所愿
  逮得分别　　总持法忍　　辩才清净
  行不退转　　深奥之意　　解义第一
  云何于是　　得极过度　　已得道证
  微妙晓了　　一切皆知　　是佛道行
  于道坚住　　而不动转　　唯愿说是
  上妙之义　　诸通之慧　　明智如海
  世尊愍伤　　愿为我说　　我思逮得
  坚固奉行

于是佛为幻士仁贤。说偈曰

  其能解知　　一切法化　　彼则能化
  亿百千佛　　亦能化至　　亿千佛国
  所至到处　　度亿群生　　如卿仁贤
  以无形色　　能示现色　　睹无央数
  彼无有起　　亦无有灭　　不见有来
  亦无去处　　如是仁贤　　其佛正士
  化现佛身　　及比丘僧　　无所从来
  不见住处　　智不思议　　是佛神足
  譬如所幻　　因缘等一　　现有象马
  车步行人　　无有坐者　　亦无所至
  是颠倒事　　人谓为正　　诸佛如是
  无有色身　　亦无形像　　不行无处
  自见身者　　求索处所　　寤不觉者
  除去众想　　佛无色貌　　离于相好
  不起种姓　　观不可见　　无有音声
  及以言说　　无心意识　　离所思念
  如佛所觉　　实为以来　　三世悉空
  想无所起　　常不生想　　已见本净
  彼无有法　　其德皆吉　　佛之所生
  本净无数　　无有四大　　亦无荫盖
  彼之所住　　不动无著　　不能晓了
  智慧之眼　　如我所觉　　为得见佛
  其人未曾　　得见世尊　　见无所见
  为睹导师　　譬如举手　　探捉虚空
  如卿仁贤　　所见诸佛　　悉为一义
  当平等定　　我亦如是　　余佛无异
  一切正慧　　其相平等　　其戒清净
  三昧平等　　定意智慧　　解脱平等
  于是慧等　　度知见事　　一切诸力
  佛之名德　　空义平等　　及道行迹
  一切诸法　　所住无碍　　一切如幻
  本净解脱　　无所成就　　所起严净
  仁贤当知　　供一佛已　　为已奉事
  十方诸佛　　于此如是　　法平等故
  求索若干　　终不可得　　一切能净
  人之信施　　一切所施　　皆大德果
  一切清净　　起法平等　　佛无若干
  亦无差特　　一切皆悉　　审为是佛
  有颠倒行　　则不见佛　　今是诸佛
  所示形像　　一切皆尽　　平等无处
  如卿仁贤　　念所见佛　　譬若如仁
  所造化作　　喻观五阴　　亦当如是
  凡着诸盖　　及与愚痴　　其是无生
  不实无有　　于此无处　　亦无所立
  是不可见　　亦无有色　　谛观是已
  不得久住　　五阴自然　　于是如幻
  众生诤讼　　自贪身相　　无相之相
  所可现相　　正觉佛道　　远如复远
  虚妄之法　　起众想处　　生众因缘
  无形之树　　造发众事　　若干种意
  断诸受想　　是为本无　　其知因缘
  及所作为　　彼即了法　　逮得离欲
  离欲法已　　即识知如　　即得见道
  其眼清净

佛说此偈时。幻士仁贤。得柔顺法忍。五千人未曾发心。皆发无上正真道意。二百天人。远尘离垢诸法眼净。于是佛食化饭已。欲增益仁贤信施之德。便说偈言

  如是不想报　　所与者得净
  一切施等具　　仁贤德满足

贤者大目揵连白佛言。唯愿世尊。令化讲堂得住。昼夜七日使不灭没。佛即以威神。令化讲堂昼夜七日住立不灭庄严如故。时佛从坐起。与比丘及诸菩萨。天龙鬼揵沓和。往诣佛所听受经法。于是仁贤往到佛所。稽首礼足绕佛三匝。却叉手住白佛言。唯世尊。菩萨有几道行所可住处。得至道场晓了正义。于是佛告仁贤。谛听善思念之。吾当为汝解说菩萨道场。于是仁贤。与诸大众受教而听。佛言。菩萨有四事。住于道得至道场一曰心常习诸通慧。二曰不舍一切人。三曰求功德无有厌。四曰护诸法常行精进。是为四。得至道场。复有四清净行得至道场。一曰护戒清净。二曰意性清净。三曰慧清净。四曰所生清净。是为四。复有四事法。弟子缘觉所不能及。一曰其行过于四禅。二曰其心多所入。三曰行大哀于众生。四曰辩才之音若干种。是为四。复有四威仪行。一曰乐于闲居远离众闹。二曰往于彼行慈念众生。三曰无谀谄邪行无所至到。四曰求于道行。是为四。复有四所问无碍无能断截。一曰不惜身命。二曰心常欢悦。三曰弃贡高。四曰常奉行法。是为四。复有四事所行具足。一曰常知时节。二曰随人所喜而现教。三曰常知羞惭。四曰知止足。是为四。复有四事意行平等。一曰随人所应而恭敬教授。二曰所愿大智慧所应教授。三曰不说他人长短。四曰见说短者慈心向之不怀结怨。是为四。复有四事名德具足莫不闻知。一曰自学深慧并施教他人。二曰有来问事悉遣彼疑。三曰常护正法。四曰佛之意力而不可尽。是为四。复有四事博闻坚强。一曰闻法则解所归。二曰所闻法乐不贪家怀居。三曰闻已广宣咸为人说。四曰已闻起贤圣解说向佛道法是为四。复有四事。讲说经法名德流行。一曰先办众事后受以卫之食。二曰得利养衣被饭食床卧医药降伏魔力。三曰昼夜乐法为诸天所护。四曰不轻娆他人。是为四。复有四事。光辉众会身得自在。一曰少于所欲。二曰知止足。三曰微妙柔软。四曰身自奉法。是为四。复有四事。得明慧利说法无异。一曰拔济生死之惧。二曰不希求世供养之利。三曰常护他人。四曰常住道愿。是为四。复有四事法。有反复知报善恶。一曰劝化人使发道意。二曰不失所成立之功。三曰自敬念迎当来慈。四曰常诣正士法师。是为四。复有四事。不坏慈。一曰具足忍力。二曰不诱娆他人眷属。三曰不舍大哀。四曰求脱罪福因缘志在于道。是为四。复有四事。习于慈行。一曰常合和人。二曰性行柔顺。三曰其行具足。四曰所有稍稍近道。是为四。复有四事知是恶师。一曰教人为小道。二曰教人坏菩萨意。三曰教求名闻增益不善之法。四曰教远离功德善法。是为四。复有四事。与世尊诸佛共会。一曰常一其心。二曰常说诸佛世尊功德。三曰奉清净之戒。四曰志性不舍本愿。是为四。复有四事法。称其德行。供养菩萨及如来尊。不以懈倦。一曰所供养佛最尊众祐。二曰其有见我亦当效行。三曰见如来道意得坚固。四曰得见三十二大人之相其功德本。使成善权。是为四。复有四事。观经义学菩萨戒行得至尊上。一曰过度恶道。二曰常劝立善道。三曰恭敬如来。四曰具足所愿。是为四。复有四事学。一曰不舍道意。二曰等于一切。三曰求度无极。四曰护无数诸佛法使不断绝。是为四复有四事。行清净戒一曰奉行少事。二曰解了空行。三曰不犯邪见狐疑。四曰无犹豫心。是为四。复有四事。三昧种性。一曰不习土地语言。二曰心清净无著。三曰成功德本。四曰稍近佛道。是为四。复有四事。应清白行。一曰兴诸善本。二曰其心宴寂行无所著。三曰所见随其脱门。四曰寂定于道义。是为四。复有四事。弃瑕秽心。一曰恐畏生死常专其行。二曰欲求解脱功德之本。三曰于安隐无所造立。四曰心无所起。是为四。复有四事降伏其心。一曰以一人之故。当来亿百千数游在生死。二曰知一切人心所念。为断尘劳随其本愿而为说法。三曰悉弃捐诸不善法。奉行众善坐于道场降伏魔兵。逮得无上正真之道。四曰声告三千大千世界为其说法。是为四。复有四事降伏魔怨。一曰观视幻法清净之行。二曰逮得不起法忍。三曰截断诸无慧之事。四曰已离生死奉修正行。是为四。复有四事思惟经义。一曰因缘法起不为无缘。二曰兴立深法而无有人。三曰观视空法而无所起。四曰自然无想悉为处寂。是为四。复有四事心不舍菩萨法。一曰不舍本愿。二曰忍于苦恼。三曰不惜身命。四曰不舍四恩行。是为四。复有四事法开化人。一曰衣食布施应为说法。二曰数数劝使坚固。三曰自在安隐之业。四曰立他人善本。是为四。复有四事安谛受法而摄奉行。一曰善本虽少心不轻念。二曰常奉行安隐行。三曰布施调意修善具足。四曰奉承经义使一切归趣安隐。是为四。复有四事得入道行。一曰逮得神通。二曰成就正慧。三曰在大道心深入无量。四曰一切所造但习空行不着解脱。是为四。复有四事奉修慈心。一曰救护幻化之人。二曰常开导人使持法。三曰度脱幻者。四曰使得无为。是为四。复有四事奉修哀心。一曰为恶道故而作亲友。使得入道而为兴哀。二曰使离恶罪教令修善。三曰教求小道者劝发大乘。四曰设行哀者。为一切众生而摄此哀。是为四。复有四事行善权方便。一曰一切心向道意在前。二曰不舍尘劳心。况善权方便心。三曰观一切人及众邪见悉为法器。四曰见一切法悉为佛法。自然得最正觉。念行诸三昧逮得善解脱。是为四。复有四事逮神通行。一曰常轻其身及本净意。二曰轻心自然如幻。三曰所作唯造立法。四曰寂然一心而无愦乱。是为四。复有四事得分别法句。一曰念成慧义不为严饰。二曰唯求取法而不取人。不起无所灭。三曰知一切无尽不可尽。四曰所说于文字无著无缚。是为四。复有四事逮得总持。一曰不厌博闻常敬法师。二曰常行精进为人说经。三曰晓近一切法句而不失义。四曰又使入如来之法。是为四。复有四事逮得法忍。一曰度不度者。二曰解未脱者。三曰一切乐法。四曰不断善行。是为四。复有四事逮得辩才。一曰见他法师所说不求其短。二曰听采法义不以贡高。三曰不自称誉。四曰见少智未学不以轻易。是为四。复有四事行不退转。一曰不退于淫怒痴。二曰于众生之行不退转。三曰于一切不善法而不退转。四曰解最正觉而不退转。是为四。复有四事解深义。一曰晓十二因缘。二曰自然解得佛道为正谛觉。三曰一切法一义其义悉空。四曰悉解佛道。是为四。复有四事得成所愿。一曰戒忍清净。二曰净除恶道。三曰质朴无有谀谄。四曰如善权方便随其本行。是为四。复有四事得成诸度无极不退转法。一曰以一波罗蜜悉入诸度无极。二曰善权使一切人皆入一切人亦无有。三曰见一切法悉为一法离诸所欲。四曰见一切佛悉为一佛以法身故。是为四。得成诸度无极不退转法。佛说四事句时。幻士仁贤得不起法忍。欢喜踊跃在虚空。去地四丈九尺。时佛见幻士仁贤心所念便笑。贤者阿难。以偈赞佛而问曰

  差特无量威　　慧事踰日月
  三世悉闻名　　德称度无极
  所知了三达　　佛以逮自在
  今佛何故笑　　唯愿为解说
  一切众生类　　住立若所立
  已见诸人心　　人尊无所著
  其于下中上　　如是为悉净
  今佛所笑者　　唯愿解说之
  诸天闻其声　　真陀人亦然
  帝释阿须伦　　乾陀摩睺勒
  梵天亦如是　　其声寂清净
  彼诸所有音　　终不与佛等
  月所出光明　　及日摩尼珠
  其帝释光明　　一切光及梵
  其明悉蔽歇　　为尽不复现
  佛出光明时　　悉照诸佛国
  已解诸深法　　静然为空寂
  其无有吾我　　亦无有寿命
  不有亦不无　　悉损是二事
  尊皆令世吉　　所游如月光
  于此唯发心　　立意遵妙道
  今谁于佛道　　安定住正法
  所以得受身　　归命佛宝尊
  善哉唯愿说　　今日所笑意
  佛说义清净　　为诸弟子故
  佛尊为安隐　　其光普日照
  为异学故说　　辟支诸佛义
  若为求佛者　　志尊上妙法
  总持等无疑　　于是天中天
  唯愿为解说　　所应得佛道
  此色佛光炎　　清净灭垢秽
  还来绕佛身　　顶上没不现

尔时佛告贤者阿难。宁见幻士仁贤乎踊在虚空。对曰已见世尊。佛言阿难。族姓子仁贤。却后九万二千劫当得作佛。名严净王如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界名曰大净。劫曰幻化。其严净王如来大净世界。人民众多安隐快乐五谷丰贱。其土平博无有丘墟。日月光照种种树木皆以庄严。众香具足常悬幢幡。其国人民如意所愿。皆见佛土严净所有自然。譬如第二忉利天上七宝宫殿。其国人民皆见国土安雅。生彼佛国者皆求上愿志于大乘。严净王如来住世万岁。般泥洹后行法住亿岁。临佛灭度有菩萨名曰闻称。佛授其决。我灭度后是闻称菩萨当得作佛。名曰普达如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。时族姓子仁贤。从虚空下稽首佛足白佛言。佛是我师导御善道。唯世尊。我与无数亿百千人。归命等正觉及法比丘僧。若如来本无。诸佛本无无异。其如者无坏。如者无动。如者无想念。如者无所起。如者无行。如者无二。如来本无亦复如是。我因是成就。于是贤者阿难。问族姓子仁贤。于如来法为何所得。乃说如来本无。今卿远离于本无事。答曰一切法皆弃离尔乃兴如来法。于阿难意云何。如来皆了本无致等正觉。以故如来本无无坏者。我亦得之。一切人亦逮本无。唯贤者意云何。如来法为有二乎。唯阿难法无二无二。有想者其识若干。所以者何。捐舍众想乃成佛慧。尔时阿难白佛言。唯世尊。族姓子仁贤。宁当复持本所幻化。迷惑诸天人不耶。佛告阿难。于是仁贤。入法智慧之幻。所以者何。用明智辩才故也。时世尊告族姓子仁贤。卿宁能化或诸天世人。对曰唯然。如佛所惑化。我亦如是。所以者何。解无我者是为大行。号有人名无寿命。无有人而言有人。如来无字亦不处道场。何所法中有去没去。而说法有去来教法。无般泥洹而现泥洹法。是故世尊说平等行。便能化惑诸天世人。为说如来功德平等。时佛赞族姓子仁贤。善哉善哉。仁贤。如卿所说。为大化惑说无音声法。时仁贤从佛求出家。佛告弥勒菩萨。汝下幻士鬓发令作沙门。弥勒受教。即使仁贤为出家志已还白佛言。唯然世尊。是非菩萨形貌色像。亦非沙门。所以者何。其有菩萨成诸通慧。处于三界教化群生。是为菩萨出家也。说是语时。五千人发无上正真道意。二百比丘漏尽意解

尔时贤者阿难。白佛言。当何名斯经以何奉行之

佛告阿难。是经名授幻士仁贤决。又名稍入至佛道。佛言阿难。其有菩萨欲得见佛。为一切故当受是经持讽诵读。当旷其志为他人说。所以者何。其于是法菩萨求道。是为大乘平等经法。以故是经名曰稍入道义。佛告阿难。我以是经嘱累汝。心念口讽执持经卷。若闻奉行众恶反趣。当知其人曾见五百佛然后得佛道。时族姓子仁贤白佛言。其受是经皆本功德。唯然世尊。我本亦学。所以者何。闻是经者。皆前善本善权。我心如是。佛说经已。族姓子仁贤。比丘贤者阿难。一切众会。诸天龙神阿须伦世间人民。闻经欢喜稽首而退

佛说幻士仁贤经


佛说决定毗尼经

    No. 325 [No. 310(24)]

佛说决定毗尼经

        群录皆云炖煌三藏译

如是我闻。一时佛在舍卫国只陀林中给孤独精舍。与大比丘众千二百五十。菩萨万人。尔时世尊。如龙王视观察大众。观大众已告诸菩萨。仁者谁能于后恶世。堪忍护持正法。以诸方便成就众生。尔时弥勒菩萨即从坐起。偏袒右肩右膝着地。白佛言。世尊。我能堪忍于后世时。受持如来百千万亿那由他阿僧祇劫所集。阿耨多罗三藐三菩提。多所利益无量众生。师子菩萨白佛言。世尊。我能堪忍成就众生。金刚菩萨白佛言。世尊。我能堪忍怜愍守护诸恶众生。文殊师利法王子白佛言。世尊。我能堪忍充足众生诸所悕望。智胜菩萨。白佛言世尊。我能堪忍令诸众生除去无明。法胜菩萨。白佛言世尊。我能堪忍令诸众生离诸非法。月胜菩萨。白佛言世尊。我能堪忍令诸众生常得远离非功德法。日胜菩萨。白佛言世尊。我能堪忍以安乐乘。令诸众生皆得度脱。无畏菩萨。白佛言世尊。我能堪忍成就饶益无边众生。魃陀婆罗菩萨。白佛言世尊。我能堪忍说无痴法。令诸众生皆得闻知成就智慧。无尽意菩萨。白佛言世尊。我能堪忍兴发大愿。令无尽众生皆得成就。月光菩萨言。我能堪忍令诸众生常行给事。妙目菩萨言。我能堪忍与诸众生安乐根本。观世音菩萨言。我能堪忍刚强恶趣诸众生等为作归依。得大势菩萨言。我能堪忍不度恶趣众生皆令得度。善数菩萨言。我能堪忍令诸众生不调伏者令得调伏。妙意(丹云妙音)菩萨言。我能堪忍喜乐小法诸众生等令得度脱。喜乐菩萨言。我能堪忍卑下弊恶杂秽众生皆令成就。光积菩萨言。我能堪忍成就解脱畜生众生。入无诤菩萨言。我能堪忍示现正道成就众生。爱见菩萨言。我能堪忍安乐利益给施众生求实智慧。不思议菩萨言。我能堪忍愍念成就饿鬼众生。日光菩萨言。我能堪忍未淳熟众生能令成熟。毗摩罗鞊菩萨言。我能堪忍充满众生一切所愿。大气力菩萨言。我能堪忍为诸众生闭恶道门。断疑菩萨言。我能堪忍乐小法众生令得度脱。住无畏菩萨言。我能堪忍常以赞叹饶益众生。吉胜智菩萨言。我能堪忍随诸众生种种所乐而度脱之。住无量菩萨言。我能堪忍为诸众生说无为道。住一切法无畏菩萨言。我能堪忍乐种种乘诸众生等。随其所乐而能示现。妙意菩萨言。我能堪忍常示众生所喜乐事而成就之。无垢炎菩萨言。我能堪忍爱念众生而为守护令得成就。摩尼光菩萨言。我能堪忍令诸众生自识宿命。光德菩萨言。我能堪忍而以正勤拔济众生。贤德菩萨言。我能堪忍究竟断除众生苦恼。宝手菩萨言。我能堪忍以诸珍宝给施众生令得安乐。最胜意菩萨言。我能堪忍贫穷众生令离贫苦。断诸缠菩萨言。我能堪忍令诸众生常得远离烦恼怖畏。金刚光菩萨言。我能堪忍为诸众生示现正道。现德色像菩萨言。我能堪忍多求众生随其所求皆能给足。法出曜菩萨言。我能堪忍常说清净诸法之行。金刚体菩萨言。我能堪忍除诸众生一切障碍。法益菩萨言。我能堪忍常以正法度脱众生。无少有(丹云少为)菩萨言。我能堪忍为诸众生灭除诸毒。月上菩萨言。我能堪忍为诸众生示现说法。师子意菩萨言。我能堪忍常以法施饶益众生。意(丹作童)子光菩萨言。我能堪忍度卑下处诸众生等。佛功德菩萨言。我能堪忍示现正道断诸恶趣。金刚光菩萨言。我能堪忍现身色像度脱众生。德吉胜菩萨言。我能堪忍令损减众生为作增益。持势菩萨言。我能堪忍闭地狱门。持甘露菩萨言。我能堪忍令诸众生得度生死。网明菩萨言。我能堪忍为诸众生常现光明灭一切结

尔时舍利弗闻诸菩萨作如是等。成就众生以自庄严得未曾有。前白佛言。未曾有也世尊。是诸菩萨不可思议有大悲心。种种方便坚固精进而自庄严。乃至一切众生。不能沮坏不能筹量。不能及逮不能摧伏。所有光明不可障蔽。世尊。我常称赞是诸菩萨未曾有事。所谓有人。故从求索头目耳鼻身体手足一切诸物。求索之时无所吝惜不生悔心。世尊。我常思惟每作是念。或有逼迫是诸菩萨。从其求索若内若外所有诸物。当知皆是住不思议解脱菩萨。佛告舍利弗。如是如是。如汝所言。此诸菩萨所有禅定。方便智慧境界之事。非诸凡夫一切声闻及辟支佛所能思量。又舍利弗。是诸菩萨虽见诸佛神通变化。而于诸法心不动转。常满众生诸所欲愿。又舍利弗。若有众生乐居士法现居士形为成就故。若有众生乐大威势。现作诸王有大威力而调伏之。若有众生志求涅槃。以声闻乘而度脱之。求辟支佛者现辟支佛形。为度脱故。求大乘道者现作佛身。为建诸佛法故。如是舍利弗。是诸菩萨种种方便成就众生。皆悉令得住于佛法。所以者何。舍利弗。若除如来智慧。更无余乘而得度脱到于涅槃。以是义故名为如来。所以者何。如如来说如如之法。即如觉知此法名为如来。知诸众生种种欲乐而悉示现名为如来。成就一切诸善根本。断于一切不善根本名为如来。能示众生解脱之道名为如来。能令众生远离邪道示现圣道名为如来。说诸空法显现空义名为如来。一切众生有种种识种种欲乐。随其所乐示解脱道名为如来。诸凡夫等妄想疑惑。能使觉知非真实法。诸菩萨等于诸法界不生动转。如幻众生皆令解脱。次第当到趣于道场

又舍利弗。在家菩萨应修二施。云何为二。一者财施。二者法施。又舍利弗。出家菩萨柔和无嗔应修四施。何等为四。一者纸。二者墨。三者笔。四者法。如是四施。出家之人所应修行。得无生忍诸菩萨等。当应修习三种布施。何等为三。王位布施。妻子布施。头目布施。如是三种名为大施名极妙施。得无生忍诸菩萨等。应修如是三种布施

舍利弗白佛言。世尊。菩萨不应畏欲恚痴。佛告舍利弗。菩萨有二大犯。何等为二。因于嗔恚愚痴犯戒名为大犯。因欲犯者名为小犯难得除却。因嗔犯者名为大犯易可除却。因痴犯者亦名大犯亦难除却。以何等故爱为小犯难得除却爱能增长生死枝条亦为种子。以是义故小而难却。因嗔犯者堕于地狱畜生恶道。速疾能为心作障碍易得除却。因痴犯者堕八大地狱诸大苦处难可解脱。又舍利弗。若有菩萨犯于初戒。于十众前以正直心殷重忏悔。故犯戒者于五众前。以正直心殷重忏悔。手捉女人眼见恶心。或一人或二人前。以正直心殷重忏悔

若有菩萨成就五无间罪。犯于女人或犯男子。或故犯犯塔犯僧。如是等余犯。菩萨应当三十五佛边。所犯重罪昼夜独处至心忏悔。忏悔法者。归依佛归依法归依僧

南无释迦牟尼佛　南无金刚不坏佛　南无宝光佛　南无龙尊王佛　南无精进军佛南无精进喜佛　南无宝火佛　南无宝月光佛　南无现无愚佛　南无宝月佛　南无无垢佛　南无离垢佛　南无勇施佛　南无清净佛　南无清净施佛　南无婆留那佛　南无水天佛　南无坚德佛　南无栴檀功德佛　南无无量掬光佛　南无光德佛　南无无忧德佛　南无那罗延佛　南无功德华佛　南无莲华光游戏神通佛　南无财功德佛　南无德念佛　南无善名称功德如来　南无红炎幢王如来　南无善游步功德如来　南无斗战胜如来　南无善游步如来　南无周匝庄严功德如来　南无宝华游步如来　南无宝莲华善住娑罗树王如来

如是等一切世界。诸佛世尊常住在世。愿诸世尊慈哀念我。若我此生若我前生。从无始生死已来所作众罪。若自作若教他作见作随喜。若塔若僧若四方僧物。若自取若教他取见取随喜。五无间罪。若自作若教他作见作随喜。十不善道。若自作若教他作见作随喜。所作罪障。或有覆藏或不覆藏。应堕地狱饿鬼畜生诸余恶道。边地下贱及弥戾车。如是等处所作罪障今皆忏悔。诸佛世尊当证知我当忆念我

复于诸世尊前作如是言。若我此生若于余生。曾行布施或守净戒。乃至施与畜生一揣之食。或修净行所有善根。成就众生所有善根。修行菩提所有善根。及无上智所有善根。一切合集挍计筹量。皆悉回向阿耨多罗三藐三菩提。如过去未来现在诸佛所作回向。我亦如是回向

  众罪皆忏悔　　诸福尽随喜
  及请佛功德　　愿成无上智
  去来现在佛　　于众生最胜
  无量功德海　　归依合掌礼

如是舍利弗。菩萨如是观此三十五佛如在目前。思惟如来所有功德。应作如是清净忏悔。菩萨若能净此罪已。尔时诸佛为其现身。为度众生亦说种种诸行。成就愚惑诸众生故。菩萨于诸法界心不动摇。而诸众生等有种种欲乐。随其所乐皆能度脱满其所愿。菩萨若入大悲三昧。能示现入地狱畜生诸余恶道。菩萨若入大庄严三昧。现居士身成就众生。菩萨若入妙胜三昧。能现转轮王身成就众生。菩萨若入晃曜三昧。能现释梵上妙色身成就众生。菩萨若入一心三昧。现声闻形成就众生。菩萨若入清净不二三昧。现辟支佛形成就众生。菩萨若入寂静三昧。能示佛身成就众生。菩萨若入诸法自在三昧。随诸众生种种欲乐。现种种形而成就之。又彼菩萨或现释身。或现梵身。或时示现转轮王身。皆为成就诸众生故。然此菩萨于诸法界而不动转。所以者何。虽随众生种种欲乐现种种形。而此菩萨不得己身及与众生。而随众生现种种身

又舍利弗。师子兽王大吼之时。其余小虫能堪忍不。不也世尊。又如香象其所负重。诸驴骡等能堪忍不。不也世尊。又如释梵所有威德光明色像。贫穷之人能堪忍不。不也世尊。又舍利弗于意云何。如金翅鸟王所有势力。鹫鸽等鸟能堪忍不。不也世尊。如是舍利弗。菩萨所有其心勇健善根势力。所有之罪依出离智。得见诸佛及得三昧。非一切众生声闻缘觉。所有犯罪忧悔之事而能得除。菩萨若能称彼诸佛所有名号。常于昼夜行三事者。得离犯罪及诸忧悔并得三昧。

尔时优波离从禅定起诣世尊所。到已头面礼足却坐一面。白佛言。世尊。向于静处独坐思惟生如是念如来说此波罗提木叉清净之戒。应当善学。为声闻缘觉菩萨乘故说如是言。宁舍身命不舍于戒。世尊。若佛在世及涅槃后云何名为声闻乘人波罗提木叉云何名为菩萨乘人波罗提木叉。世尊说我于持律中最为第一。我当云何为他广说。今从世尊面闻受持逮无所畏。然后能为他人广说。我于静处独坐思惟生如是念。我今应当诣世尊所问比尼中决定之义。今此大众诸菩萨等。及比丘僧悉皆集会。善哉世尊唯愿说之

尔时世尊告优波离。汝今当知。声闻乘人有异方便有异深心持清净戒。菩萨乘人有异方便有异深心持清净戒。所以者何。声闻乘人有异方便有异深心。菩萨乘人有异方便有异深心。优波离。声闻乘人虽净持戒。于菩萨乘不名净戒。菩萨乘人虽净持戒。于声闻乘不名净戒。优波离。云何名为声闻乘人虽净持戒。于菩萨乘不名净戒。优波离。声闻乘人不应乃至起于一念欲更受身。是则名为声闻乘人清净持戒。于菩萨乘最大破戒名不清净。云何名为菩萨乘人。虽净持戒。于声闻乘。不名净戒。优波离。菩萨乘人于无量劫。堪忍受身不生厌患。是则名为菩萨乘人清净持戒。于声闻乘人最大破戒不名清净。又优波离。菩萨乘人持不尽护戒。声闻乘人持尽护戒。菩萨乘人持开通戒。声闻乘人持不开通戒。菩萨乘人持深入戒。声闻乘人持次第戒。优波离。云何名为菩萨乘人持不尽护戒声闻乘人持尽护戒。菩萨乘人持戒之时。于诸众生及与他人应当随顺。声闻乘人不应随顺。优波离。以是义故菩萨乘人持不尽护戒。声闻乘人持尽护戒。优波离。云何名为菩萨乘人持开通戒。声闻乘人持不开通戒。优波离。菩萨乘人。以日初分有所犯戒。于日中分思惟。当得一切种智。菩萨尔时不破戒身。以日中分有所犯戒于日后分思惟。当得一切种智菩萨尔时不破戒身。以日后分有所犯戒。于夜初分思惟。当得一切种智。菩萨尔时不破戒身。以夜初分有所犯戒。于夜中分思惟。当得一切种智。菩萨尔时不破戒身。以夜中分有所犯戒。于夜后分思惟。当得一切种智。菩萨尔时不破戒身。以夜后分有所犯戒。于日初分思惟。当得一切种智。菩萨尔时不破戒身。以是义故。菩萨乘人持开通戒。声闻乘人持不开通戒。菩萨不应生大惭愧。亦复不应生于悔缠。优波离。声闻乘人数数犯罪。即时破失声闻戒身。所以者何。声闻乘人应当持戒断一切结如救头燃。所有深心为涅槃故。优波离。以是义故。声闻乘人名持不开通戒。优波离。云何菩萨乘人持深入戒。声闻乘人持次第戒。菩萨乘人于恒河沙劫。受五欲乐游戏自在。受诸乐已。未曾捐舍发菩提心。菩萨尔时不名失戒。所以者何。菩萨乘人有于后时。善能护持菩提之心。乃至梦中一切结使不为其患。菩萨乘人不应一时于一身中尽一切结。应当渐渐尽一切结善根成就非不成熟。声闻乘人如救头然。乃至一念受身不应生喜。以是义故。大乘之人持深入戒。声闻乘人持次第戒。菩萨乘人持开通戒持不尽护戒。声闻乘人持不开通戒持尽护戒。所以者何。阿耨多罗三藐三菩提甚为难得。具大庄严乃可得成。大乘之人于无量劫往来生死。不应生于厌离之心。优波离。如来观察筹量。为大乘人不应一向说厌离法。不应一向说离欲法。不应一向说速疾法。常当为说发欢喜心相应诸法。常应为说甚深无难无悔缠法。常应为说无聚无碍空无之法。闻此法已常乐生死不生忧悔。亦能满足菩提之行

优波离白佛言世尊。或有欲相应心而犯于戒或有嗔相应心而犯于戒。或有痴相应心而犯于戒。世尊。菩萨犯戒。于欲相应心。嗔相应心。痴相应心。何者为重。尔时世尊告优波离。若有菩萨如恒河沙。欲相应心而犯于戒。或有菩萨因一嗔心而犯于戒。等住菩萨大乘之道。因嗔犯者当知最重。所以者何。因嗔恚故能舍众生。因贪欲故于诸众生而生亲爱。优波离。所有诸结能生亲爱。菩萨于此不应生畏。所有诸结能舍众生。菩萨于此应生大畏

优波离。如来先说欲难舍离为小犯。嗔易得离名为大犯。优波离。所有诸结犯小难离。大乘之人应当忍受所有诸结犯大易离。大乘之人乃至梦中不应忍受。以是义故。大乘之人因欲犯者。我说是人不名为犯。因嗔犯者我说是人名为大犯。名大过患名大堕落。于佛法中是大留难。优波离。若有菩萨无有方便。欲相应心而犯于戒生于怖畏。于嗔犯戒不生怖畏。若有菩萨而有方便。恚相应心而犯于戒生于怖畏。欲相应心而犯于戒不生怖畏

尔时文殊师利在大众中。前白佛言。世尊。一切诸法究竟比尼谁受比尼。佛告文殊。若诸凡夫悉能了知。一切诸法究竟比尼。如来终不演说比尼。以不知故。如来尔时为令觉知一切诸法究竟比尼。渐次为说诸比尼法

尔时优波离白佛言。世尊。此文殊师利。于此解说比尼决定之义而无所说。尔时世尊告文殊师利。汝今应当解说究竟比尼之法。此优波离。欲得闻于比尼之义。尔时文殊师利。语优波离言。一切诸法究竟无垢能自调心乃能得见究竟比尼。一切诸法无有诸缠净其本性。乃能得见究竟比尼。一切诸法无有染污我不可得。乃能得见无悔比尼。如如真实亿万法门欣乐修学。乃能得见清净学戒。一切诸法无有分别。无缚无解不作思惟。乃能得见无有缚着。一切诸法无住无染不作留住。乃能得见诸法清净。一切诸法住虚空际离诸处所。乃能得见所作清净。一切诸法逮无斗诤。前际后际不可得故。乃能得见三世平等一切诸法离诸施设心无所行。乃能得见断于疑结。优波离。是则名为究竟比尼法界。诸佛世尊从此得道。若能筹量观察此法。是名善学逮最胜戒若不观此法。是则不名深入如来所学之戒

尔时优波离白佛言。世尊。此文殊师利所说之法。皆是不可思议。尔时世尊告优波离。文殊师利所说之法依于解脱。所依解脱心无去来。是故文殊师利。说一切法心无去来。于心解脱生增上慢者。为除彼人增上慢故。尔时优波离白佛言。世尊。比丘行何法故名增上慢。佛告优波离。若有比丘作是思惟。欲断贪欲名增上慢。作是思惟欲断嗔恚名增上慢。作是思惟欲断愚痴名增上慢。贪欲法异诸佛法异。作是思惟名增上慢。嗔恚法异诸佛法异。作是思惟名增上慢。愚痴法异诸佛法异。作是思惟名增上慢。作是思惟见有所得名增上慢。作是思惟见有所证名增上慢。作是思惟见有解脱名增上慢。作是思惟见诸法空名增上慢。作是思惟见于无相名增上慢。作是思惟见于无作是名增上慢。作是思惟见有诸行名增上慢。作是思惟见有诸法名增上慢。一切诸法不可思议。作是思惟不应思议名增上慢。诸法空无何用精进。作是思惟名增上慢。是名声闻住增上慢。云何名为菩萨增上慢。佛乘最胜作是思惟。我当于中发菩提心名增上慢。行六波罗蜜当得作佛。作是思惟名增上慢。般若波罗蜜能得出离。更无余法而得出离。作是思惟名增上慢。于甚深法应作方便不因世法。作是思惟名增上慢。此法甚深此非甚深。作是思惟名增上慢。此法是净此法非净。作是思惟名增上慢。此是佛法此是辟支佛法。此是声闻法。作是思惟名增上慢。此法应作此法不应作。作是思惟名增上慢。此是近法此非近法。作是思惟名增上慢。此是正道此是邪道。作是思惟名增上慢。疾当得阿耨多罗三藐三菩提。不疾当得阿耨多罗三藐三菩提。作是思惟名增上慢。一切佛法不可思议。未曾有人能觉之者。作是思惟名增上慢。阿耨多罗三藐三菩提不可思议。彼不应思议。此非是见然是过患。是名菩萨住增上慢。

尔时优波离白佛言。世尊。云何比丘离增上慢。佛告优波离。若有比丘思惟诸心。思惟心时不着思惟。是名最胜离增上慢。尔时世尊欲广分别思惟法故。而说偈言

  不应分别法非法　　戏论诸心不应住
  不思议法而能知　　名一切时受乐人
  若有欲知无有法　　作是思惟非真实
  随逐邪心凡夫人　　受诸有苦百千亿
  若有比丘常念佛　　此则非真非正念
  常知佛从分别起　　实不可取亦不生
  若有思惟诸空法　　则住邪道凡夫人
  虽因名字说空法　　而实无有名字说
  闲居寂静思惟法　　世所称叹寂静人
  心住觉观是戏论　　是故无思能解法
  心心诸法名为思　　若有所思必有着
  若能远离是着法　　于诸所思无复思
  法同草木无所知　　而因诸缘得生起
  无有众生而可得　　能起空无诸缘法
  因日光明眼得见　　夜则不见离众缘
  若眼自能见色者　　何故无缘而不见
  眼常因于诸光明　　得见种种可意色
  常知见性众缘生　　是故知眼不能见
  若有所闻诸好声　　生已即灭无有闻
  推其去处不可得　　因分别故起声想
  一切诸法同音声　　施设说有诸数相
  未曾能生法非法　　为凡夫故而示现
  我为世间叹布施　　而实悭法不可得
  佛所说法难思议　　虽不可得而演说
  我常叹说持净戒　　破戒之相如执空
  诸破戒相如虚空　　清净持戒亦如是
  我说忍辱为妙胜　　嗔恚之性实不生
  于诸法中无触恼　　而佛开示忍辱者
  常说昼夜无疲倦　　觉悟精进为最上
  虽复勤行于百劫　　然其所作无增减
  禅定解脱为最胜　　如来开示说诸门
  而实诸法无散乱　　世尊现说诸禅定
  智慧之性能觉了　　能知诸法为慧人
  然其自性不有生　　佛能示现为解说
  我常叹说清苦法　　欢喜乐行头陀者
  推求贪法不可得　　名为最上不贪者
  常为众生百千众　　现说地狱怖畏事
  未曾有去堕恶道　　死入无间地狱者
  无有能作地狱者　　亦无能作鉾槊等
  因分别故而见有　　刀剑之害伤己身
  杂色庄严花果树　　金色宫殿而晃曜
  彼亦未曾有作者　　皆从妄想分别起
  虚伪之法诳世间　　着想回旋凡夫人
  于取不取无自性　　犹如分别幻化炎
  说于诸行最胜者　　能为众生发道心
  菩提之道不可得　　当知求者亦非实
  其心本性常清净　　无有染着诸苦恼
  凡夫分别诸恶心　　自生贪爱诸染着
  诸法妙胜常寂静　　而实无有爱恚痴
  法性解脱离染爱　　逮到安隐无处所
  我知诸法如虚空　　游诸世间不生畏
  其意未曾有染着　　是故不住于邪道
  我于多劫修诸行　　度脱无边诸众生
  而诸众生生不尽　　亦未曾有增减时
  譬如世有大幻师　　能化无边百千众
  即时皆害诸化人　　而于幻者无增损
  一切众生如幻相　　其边未曾而可得
  若有能观不思议　　当知彼人不厌生
  观世寂静名勇猛　　知法实相亦复然
  受五欲利常修行　　不生染着度众生
  无有众生及寿命　　世尊怜愍兴慈悲
  勤修精进大苦行　　虽无众生作利益
  如以空卷诱小儿　　诳惑其心令染着
  然后开手示空卷　　小儿即时大啼哭
  如是难思佛世尊　　于诸法相净觉意
  已解远离空无法　　而能示现于世间
  于我法中甚可乐　　舍离俗服能出家
  其后当得最胜果　　大慈悲人之所说
  已能出家舍俗务　　复闻当得逮诸果
  观察诸法真实相　　无有诸果而可得
  已于诸法无得果　　转复生于未曾有
  快哉大悲人师子　　善入相应诸法相
  一切诸法如虚空　　能立名字百千万
  此名为根禅解脱　　亦名为力七觉技
  诸根无有生灭相　　觉力等法亦复然
  非是色性不可取　　以智力现示世间
  我说众生有所得　　皆是远离诸性相
  若有计我有所得　　不名为得沙门果
  若法无生亦无灭　　谁有于中而得者
  说众生得即无得　　能觉此法名为得
  众生得果名最胜　　我说众生非众生
  未曾有得众生者　　是故不应有得果
  譬如良田无种子　　彼中不应而生牙
  如是众生不可得　　云何当有逮寂静
  一切众生性寂静　　未曾有得其根本
  若有能观此法者　　我说永寂无有余
  过去诸佛百千万　　度诸众生无有尽
  而此众生无真实　　究竟寂静更不生
  一切诸法皆灭相　　未曾能有得生者
  若有能观如是法　　彼人不着于三界
  我说诸道无障碍　　能离诸着甚可乐
  于百千劫甚难得　　乃从往昔然灯佛
  能起最胜无生忍　　永断障碍无有余
  得清净命以为命　　永离一切诸非见
  彼无恶趣常安乐　　勇猛能知无碍法
  不着诸行得解脱　　于百千经不生畏
  能得诸辩亦不难　　无边百千陀罗尼
  解陀罗尼诸义趣　　速能觉知无碍法

说是偈已。二百比丘增上慢者。不受诸法心得解脱。六十(丹本六千)菩萨得无生忍

尔时优波离白佛言。世尊。当何名斯经云何奉持。佛告优波离。此经名为决定比尼。亦名坏一切心识。当奉持之。尔时优波离文殊师利一切大会。诸天世人阿修罗等闻佛所说。皆大欢喜为佛作礼

佛说决定毗尼经


佛说离垢施女经

    No. 338 [Nos. 310(33), 339]

佛说离垢施女经

        西晋月氏国三藏竺法护译

闻如是。一时佛在舍卫国祇树给孤独园。与大比丘众俱。比丘千人皆阿罗汉。诸漏已尽逮得已办。无复尘垢而得自在。弃捐重担逮得己利。尽除终始诸所结缚。度以聪慧通达明智悉为仁贤。犹如大龙心得自在。其大人贤者阿难。菩萨万人。皆成大阿罗汉。皆一切圣达神通己畅。悉不退转法轮。菩萨其名宝光菩萨。智积菩萨。名首菩萨辩积菩萨。首咸菩萨。光世音菩萨。贤首菩萨。喜王菩萨。行无思议脱门菩萨。念诸法无盖菩萨。慈氏菩萨。入志性菩萨。弃诸恶趣菩萨。除众忧冥菩萨。超欲无虚迹菩萨。无虚见菩萨。德宝校饰菩萨。金宝曜首菩萨。舍诸盖菩萨。无害心菩萨。如是等菩萨具足万人。尔时贤者舍利弗。大目揵连。大迦叶。须菩提。邠耨文陀弗。离越。阿那律。阿难等。溥首童真。不虚见。宝英。弃诸恶趣。弃诸阴盖。光世音辩积。超度。无虚迹。时此八菩萨及八弟子。明旦着衣持钵入城分卫。斯等俱行相与共议各各发愿。舍利弗曰。当如是像三昧正受入城分卫。令其中人普使一切闻四圣谛。大目连曰。愿城中人皆使一切无有须臾兴施魔事。大迦叶曰。愿城中人施我食者。一切皆使得无尽福至无为度。须菩提曰。愿城中人敢睹光明以是缘报皆得生天及在人间。然后逮得无为之法。邠耨曰。愿其城中诸外异学梵志长者。悉得正见。离越曰。愿其城中一切众人无有罪殃。悉获安隐。阿那律曰。愿其城中一切众人悉得天眼。阿难曰。愿其城中一切众人。悉使识念往古所可曾闻经法。文殊师利曰。化其城中门户窗牖重阁精舍器物璎珞树木枝叶华实衣服之饰。皆使宣出空无相无愿无所逮得不起不灭无有放逸无所著声无有形类无吾我声。无虚见曰。化其城中一切人民男女大小目所睹者。悉见佛形。至后究竟。逮得无上正真之道。宝英曰。化其城中一切居家所有诸藏。皆满众宝。弃诸恶趣曰。化其城中所居众民。敢有犯作地狱之罪。现在之法。使罪微轻忽然虚尽。弃诸阴盖曰。化其城中人弃捐五盖不使增长。光世音曰。化其中人闭牢狱者使得解脱。诸有系囚令得解散。诸恐惧者得无所畏辩积曰。化其中人敢见我等皆得辩才。使诸伎乐转共谈语。超度无虚迹曰。令其中人吾等目见皆使究竟至于无上正真之道。时八菩萨八大弟子。各各如是悉共议已。到其城门。于时城中王波斯匿。有女名曰维摩罗达(晋言离垢施)。厥年十二端正殊妙。见者咸悦。第一洁白色如妙华。于月八日明星之时。与五百侍女平旦乘驾。五百梵志皆从其后。出行游观而诣祠坛。欲大祠祀。时诸梵志这见比丘。心中念言以为不吉。诸梵志中有一梵志。年尊老耄。名曰梵天。谓离垢施女。当知今日不祥。见诸比丘住于城门。止不须出。当还入城。见此等辈求诸利义必不如意。时离垢施女。则为梵志而说颂曰

  斯等志行　　教化功德　　于诸祠祀
  为最吉安　　梵志若能　　供养此等
  一切吉利　　终无有异　　则以梵戒
  调定憺怕　　越度诸恶　　无秽众尘
  此等所行　　为上良医　　慰劳疗治
  众生久疾　　是无瑕秽　　第一师则
  为无数人　　去众恶事　　于诸四见
  为已鲜明　　梵志卿来　　值上清净
  佛在世间　　最胜法王　　斯等是子
  罗汉成就　　今诸菩萨　　为最尊师
  熟有智者　　而舍之去　　两足之尊
  上福之田　　欲得生天　　施此众祐
  若惠与者　　果报无量　　所可游处
  终不损耗　　顺斯等教　　具足相好
  是善福田　　志性清净　　假使梵志
  发欢悦心　　则当逮得　　安隐离俗
  遵修道教　　志未曾乱　　而行分卫
  常观精进　　所可游居　　善护诸根
  诸根寂定　　斯众如海　　江海之水
  尚可升量　　十方土地　　亦可步度
  若有布施　　人中之王　　一切所行
  不可称量　　劫烧之时　　须弥山坏
  江海枯竭　　及所有地　　其有奉施
  众人尊王　　劫虽被灾　　福不可烧

于是梵志。为离垢施。而报颂曰

  无得自恣　　从愚憃心　　莫祠祀时
  愿乐比丘　　斯等髡头　　而被袈裟
  若志安解　　不习此党　　恐女父母
  不以欢悦　　吾等当启　　于大明王
  女所祠祀　　则亦不祥　　善哉尊女
  莫受比丘

于是离垢施。以偈报梵志曰

  若堕恶趣　　生死之难　　虽有父母
  不能救济　　亦无余人　　及财神咒
  独斯等类　　乃能救脱　　吾弃捐身
  散在四方　　钦乐爱敬　　自归于佛
  终不希望　　余人之救　　唯当依附
  三尊宝耳　　譬如失目　　面瞻明镜
  外道异学　　若斯无益　　梵志犹如
  须弥山烧　　博闻如是　　力脱为要
  未曾乏少　　于博闻慧　　所可闻者
  悉为备具　　若能听闻　　即奉行者
  此乃为持　　一切难及

于是梵志谓离垢施女。初未曾见于尊佛及比丘众。从何因缘而生欢悦。女即答曰。梵志欲知我初生时。母以我着金宝床上上虚空中。五百天子而共飞行。我这见之以无数事。叹佛功德及法圣众。这闻音声。时于众中有一天子。初未曾见如来至真。问诸天子所叹如来德何所类。时诸天子察我心念。志怀笃信。即说此偈而赞叹佛

  头发绀青色　　净好而右旋
  如水百叶莲　　犹月满盛明
  白毛眉中回　　犹如雪之光
  胜眼如青莲　　若蜂中之王
  人中尊师子　　唇像若赤朱
  眉睫甚细妙　　平正而善姝
  广长舌覆面　　乃至于发际
  其教清和悦　　充可智者意
  其声如钟鼓　　箜篌笳笛笙
  其音和且雅　　犹如琴瑟筝
  哀鸾真陀乐　　莺鸟及鹍鸡
  赤[此/束]鸣于林　　最胜音超彼
  辞若师子吼　　妙声坏众病
  已离诸垢秽　　言诚断诸见
  行游若坐众　　闻者悉解释
  所言无缺漏　　可悦一切人
  胜己舍中边　　犹如寂灭度
  言辞无慢恣　　形体甚奇妙
  辞质无谄饰　　皆为众说行
  如集华为鬘　　佛慧音如是
  诸念悉丰满　　胜臂过于膝
  其掌正且均　　手指纤长好
  巍巍身坚固　　宝容若紫金
  佛体显如日　　远现悉闻音
  毛软亦绀色　　一一生上旋
  佣髀犹龙象　　而膝平博好
  安平足如画　　于下生相轮
  称佛德如是　　我时粗听闻
  在世无所慕　　度于诸有处
  大哀上良医　　救济众生务
  断除诸系缚　　无著如莲华
  梵志我从天　　闻叹佛若此

离垢施女谓梵志。我从诸天闻如是比叹佛功德。从是以来不自识念而复睡眠。亦复无有淫怒愚痴危害之想。从是以来不自识念贪着父母兄弟姊妹。亲属知识亦不爱念。璎珞衣服及身寿命。国城游观唯独恭恪。念佛大圣。梵志当知。以是之故。如来所在广说经法。吾悉听之。不失一句义理严妙。我常昼夜恒观睹佛。无不见时。吾以昼夜见佛正觉。欲听闻法。奉敬圣众而无厌极。时离垢施。嗟叹于佛听众之德。梵天梵志。五百群众闻之欣然。皆发无上正真道意。女即下车。趣诸菩萨及大弟子。普为稽首一一礼足。一心恭恪而叉手住。时舍利弗。观离垢施女。离垢施女问舍利弗。唯贤者为女人身处于二识。尘欲如火多有放逸。所可好喜心不顺念。不志解脱而自放逸。善哉贤者。唯为我等如应说法。哀矜长夜安隐无难。说于此语这欲竟时。王波斯匿与诸群臣。寻到彼间。王闻斯言。谓离垢施女。遗习乐何故勤劳颜色憔悴而游此间。从生以来未曾步行。初不眠寐卒发心行而不戏乐。无以自娱。于是王波斯匿。为离垢施。而说颂曰

  颜貌净妙　　犹天玉女　　璎珞仪式
  香熏衣服　　如今女身　　何所患厌
  汝既无有　　睡眠之解　　处在国土
  仓库盈富　　女之父母　　常得自由
  何所不乐　　今得自在　　其心何故
  不好在家　　又女父母　　而相可悦
  一切众入　　之所恭敬　　何故不乐
  游坐此间　　若干璎珞　　自严其身
  汝岂闻耶　　若见之乎　　所以恐怖
  心怀懈倦　　女当为吾　　宣畅此意
  今女所誓　　欲求何愿

时离垢施。则为父王。而说颂曰

  大王不觉　　生死之难　　诸阴之患
  危脆之身　　贪欲之想　　所行如化
  人命在世　　不住须臾　　大父当了
  我处毒蛇　　安得睡眠　　及诸所欲
  于今计此　　四毒之蛇　　心自念言
  何所悦乐　　为诸仇敌　　所见逼迫
  处在众苦　　云何得安　　尘劳之怨
  所见唐突　　吾当云何　　游于娱乐
  堕毒中者　　谁得睡眠　　未舍怨家
  云何欢喜　　堕大坑堑　　何所恃怙
  尊王当知　　处世如是　　如今睹察
  最胜自在　　寻时发心　　令我得佛
  王听我言　　未曾见闻　　为菩萨者
  而怀放逸　　畏于弊兽　　而驰迸走
  仇敌执杖　　举刀逐人　　而复饥渴
  入于空聚　　畏生死贼　　谁当乐者

  今此画箧身　　计之亦如是
  而常怀受斯　　依兽四害蛇
  无量之阴盖　　怨贼之患难
  孰乐于旷野　　畏惧之境界

于是离垢施。谓舍利弗。唯问贤者。智慧之事当以答我。所言智慧。叹于耆年智慧最尊。其智慧者。为有为乎。若无为耶。假使有为。则为起生灭坏之事虚伪之法。设无为者离于三相。以是之故。为无所起。设无所起。则无合会其智慧者。悉无所有。时舍利弗。默无以报。大目连曰。仁舍利弗。当时发遣离垢施问。舍利弗答曰。女所寤者不问有为及与无为。讲无所起。不可言声以答发遣

离垢施女问大目连。世尊叹贤者。神足为最耆年。云何立众人想现神足乎。为法想耶。若立人想现神足者。人虚无实神足亦空。欲以法想法无所造。其无所造彼无所获。以无所获则无所想。大目揵连。默无言报。大迦叶曰。仁大目连。以时发遣女人所问。目连答曰。女之所问。不以想念无有想说。无作无念。唯诸如来众菩萨等乃能发遣

离垢施女问大迦叶。佛叹耆年知足第一。云何迦叶假使住于八思议门。而禅三昧愍哀众人。起行分卫所受食者。若一杓供此人之等。悉当生天为以身事毕众祐乎。若以心了设以身者。身则属外不可以身而了事矣。有计身者。譬如草木墙壁瓦石。以是之故。不可了别。设用心者。心无所住以故不了。设以身心。在于外者则无所有不可用了。迦叶默然。须菩提曰。唯大迦叶。当时发遣女人所问。迦叶答曰。今女所问悉无所受则应本际。以是之故。不可发遣

离垢施女问须菩提。佛叹耆年在于闲居行空第一。其空法者为有所说叹有形乎。设欲说法法无起相。亦无灭相。其有不起不灭相者。彼则平等。其平等者则为调定。其调定者则为无本。其无本者亦无所作。无所作者则无言说。已无言说则无心念。其无心念则无真实。设无所有则无有实。其不有实则是圣贤之所叹咏。须菩提默无以加报。邠耨曰。须菩提以时发遣女之所问。须菩提曰。不当于此有所说也。默然为安。所以者何。女之所问无放逸事。有所说者则堕短乏有计法界。无有言说斯归于空

离垢施女问邠耨曰。佛叹贤者讲法最尊耆年。以何因缘说法。设无因缘则无所益。若以因缘讲说法者。则与愚痴凡夫同等。所以者何。愚痴凡夫与因缘俱。是故贤者不离愚痴凡夫之法。设无因缘无有形类。云何说法无缘对故。邠耨默然。离越曰。贤者以时发遣女之所问。邠耨答曰。今女所问不用习俗问究竟度。究竟度者则无言趣亦不可说

离垢施女问离越曰。佛叹耆年行禅最尊。为以何心依猗于禅。为不用心。设用心者心则如幻虚无所有。其三昧定亦无所有。设以无心一切水处。诸屋宫殿草木枝叶悉得三昧。所以者何。斯物无心。离越默然。阿那律曰。贤者以时发遣女问。离越答曰。女之所讲问佛境界。则非弟子之所发遣。女问离越。云何贤者声闻法异如来异乎。设以差别。其无为者则当殊别一切贤圣悉无为矣。其无为者则无所生。其无所生则无有二。其无二者不可名二。何故说此寂无以报

离垢施女问阿那律。佛叹耆年天眼最尊。云何贤者因以天眼有所见乎为无见耶。设有所见则为有常。设无所见则堕断灭。所见无形为有别耶。阿那律默。阿难言曰。贤者以时发遣女问。阿那律曰。女之所问除猛智慧则不可以言说答之。默然为安

离垢施女问阿难曰。佛叹贤者博闻最尊。今仁博闻斯为何谓义。何所趣为用严饰。设以义者义无言说。其无言说不以耳识而分别之。耳无所识不能分别。不能别者则无有言。假以严饰如世尊言。当归正义莫取严饰。是故贤者不以博闻而为要也。阿难默然。文殊师利曰。仁者阿难。以时发遣女之所问。阿难答曰。今女所问呵文字说而为博闻不可发遣。问于要义要义无心。无心无处。非是学者所可言谊。唯如法王及度无极

离垢施女问文殊师利。佛叹仁者。于诸菩萨信解深妙最第一尊。以十二缘深故深乎。为以自然深故深耶。设以缘起为深妙者。又其缘起则无所行。所以者何。其缘起者无来无去。不可别知眼之所识。不可别知耳鼻口身意识所趣。唯缘起者无所习行。假使自然深故。深者则其自然无有自然。达自然者。亦无有所。文殊答曰。本际深妙故曰为深。其女报曰。本际无际。以是之故。其二慧者为无有慧。文殊师利曰。若无智者则为颠倒。其本际者。假有言耳。其女报曰。其无智者亦无颠倒此之谓也。度于言说亦不可得而无颠倒。文殊师利曰。吾以假言而说此耳。其女报曰。如来菩萨超出言说。不可以言而有所畅

离垢施女问不虚见。向族姓子而自说言。令城中人悉得无上正真之道。男女大小其有以眼见光明者。睹如来究竟正觉。云何如来有色身乎为法身耶。说法身者则无形像。若使有见如色身者则不见佛。如世尊云

  其有见我色　　若以音声听
  斯为愚邪见　　此人不见佛

设以法身。法身不可见。所以者何。其法身者。以舍眼识无所造作。习俗之事不可得见。不虚见默然。宝英曰。以时发遣女之所问。不虚见曰。女问无类不可发遣。女报不虚见。我不问类亦不问无类。时不虚见。以此言辞寂无所对。离垢施女问宝英曰。如今向者族姓子云。令其城中往古诸藏。悉自然现满中众宝。仁如是者持宝来乎。此为何致而至是。见法无衣食。设猗衣食则与愚痴凡夫俱同。所以愚痴凡夫常猗衣食。设无衣食者。不猗世间所有众珍宝。宝英默然

离垢施女问弃诸恶趣曰。向族姓子作是言曰。令其城中一切众人犯地狱罪。悉使其人令现在世殃衅轻微弃捐诸恶不可思议。如佛所言人所犯罪。会当受之不可得脱。若不可脱。云何欲令无智使罪轻微。诸法无主欲令有主。自有所作欲令无作。弃诸恶趣曰。当以誓愿令罪微轻。其女报曰。又族姓子。诸法平等不可以愿而使动转。假使能者一一诸人所兴誓愿心自念言。我皆当度一切众生至般泥洹。设使所愿必能成者。则当能制令其所愿而不退转。弃诸恶趣默无言报。离垢施女问弃诸阴盖曰。向族姓子与此念言。令城中人悉无尘劳众结之缚。除五阴盖。仁所三昧可定意者。欲使众人不增五盖。于意云何。三昧属己属他人耶。设使属己一切诸法皆悉无为。亦无合会。云何仁者。以三昧定。令一切人不着五盖。设属他人不能于他而造恩德。弃诸阴盖曰。当以慈心而疗治此。其女报曰。一切诸佛皆行慈心。亦有佛土一切众生故长不尽。弃诸阴盖默无言也。离垢施女问光世音曰。向族姓子而发此言。令其城中所居人民。闭在牢狱使得解脱。诸有系囚自然得出。诸有恐惧得无所畏。所疗治者有阴受乎为无所受。设有所受则属愚夫以故。不应无有受阴也。若无所受则无所作。其无所作不能成就。光世音默。辩积曰。以时发遣女之所问。光世音曰。女之所问不起不灭。以是之故不可发遣。女又报曰。于光世音所之云何不起不灭。宁有问乎。答曰不起不灭彼无文说。女又报曰。无文字说则为智者。因示文字而有所讲。不著文字无所挂碍。无所挂碍则为法界。以是之故。晓了法者便无所著

离垢施女问辩积曰。向族姓子而发此言。令其城中一切人民。目睹我者又我所见。悉得辩才。使诸伎乐转共谈语。仁之辩才巍巍若斯。以何等念而兴立乎。为于是立而起生乎。设以生念而兴立者。一切众生皆兴立念。以是之故。不至寂然。若以所生得成就者则虚妄矣。若不兴念则无所作。无所作者无寂不定。辩积答曰。我属所愿为初发心众人之故。示愿之矣。假使有人来见我者。悉得辩才。女又报曰。族姓子。其初发心有行处耶设使有者则为常见。若无所有不当谓之为导御矣。悉离诸行。辩积默然

离垢施女问超度无虚迹曰。向族姓子。而自谓言。令其城中所有人民。我自所睹敢察我者。见不虚妄至于无上正真之道。云何佛道为有为无。假使有者则是有为便可爱取。设无为者无实不谛不可受持。超度无虚迹曰。所谓道者慧圣之辞。女又报曰。其圣慧者有所起耶。而复为行寂然事乎。假有所起是为思惟不顺之事。则当成于有为慧矣。行有为慧便成愚痴冥冥之识。所可分别。若以寂然则无颠倒。则无反覆。以无反覆。是则菩萨弟子缘觉如来至真。无有思想。愚騃之夫乃想道耳。不谓智者。超度无虚迹默然无言

于是贤者须菩提。谓大弟子及诸菩萨。便从是还不须入城复行分卫。所以者何。是应分卫饮食供馔。离垢施女向者说法我等听受。今日则当以法为食。时女答曰。唯须菩提向者所说无举无下。仁者云何有所志愿而怀想念欲诣精舍而处游居。唯须菩提。沙门之行出所止处。无有放逸不乐自恣。沙门之法而无所著。其无所著。则无恚恨。不怀恨者则无所行。无所行者贤圣之谓。八大弟子及八菩萨五百梵志。离垢施女王波斯匿及余大众。往诣佛所稽首足下。绕佛三匝却在前坐。离垢施女绕佛七匝。住世尊前。以偈歌颂。而问事矣

  我问于世尊　　无著难得伦
  清净无所倚　　名称不可量
  救济于众生　　施以甘露悦
  云何为菩萨　　而成就其行

于是离垢施。长跪叉手问世尊曰。何谓菩萨在于树下降魔官属。何谓菩萨震动一切诸佛之土。何谓菩萨演光普照无量佛国。何谓菩萨而从诸佛逮总持法。何谓菩萨寂然定意而成三昧。何谓菩萨究竟众行而获神足。何谓菩萨而常端正。何谓菩萨而得化生。何谓菩萨大富饶财。何谓菩萨得大智慧。何谓菩萨常识宿命。何谓菩萨与诸佛会。何谓菩萨而致逮得三十二相。何谓菩萨而能成就八十种好。何谓菩萨而得辩才。何谓菩萨得致福田。何谓菩萨眷属常和。何谓菩萨所愿佛土寻如意生。佛告离垢施女。善哉善哉。乃能发问如此之义。为诸菩萨摩诃萨施多所安隐。多所哀念愍伤。诸天及十方人谛听谛听善思念之。吾当解说。唯然世尊愿乐欲闻。离垢施及与众会受教而听。佛告离垢施。菩萨有四事法。在于树下降魔官属。何谓为四。未曾贪着他人利养。志常不乐绮饰之言。劝无数人令顺本德。以无盖慈向于众生。是为四。佛时颂曰

  未曾怀嫉妒　　离于绮饰丽
  劝化无数人　　使行众德本
  常遵修慈心　　向于十方人
  而降魔怨敌　　自在所游居

佛告离垢施。菩萨有四事法。震动一切诸佛之土。何谓为四。言行相覆入深法忍。志愿坚固于善正法。劝化无量一切人民。令志无上正真之道。使善爱乐微妙之慧。是为四。佛时颂曰

  言行常相应　　晓了深妙义
  所愿常坚固　　逮得清白法
  劝化无数人　　使志无上道
  以是四法故　　能动亿佛土

佛告离垢施。菩萨有四事法。演光普照无量佛国。何谓为四。常于冥处而然灯火。于末乱世亦护经典。而为诸乱处处不闲。因说经道显法光明。以宝香华供散佛寺。是为四。佛时颂曰

  常施以灯火　　清净之光明
  最后穷冥世　　而护于经典
  为放逸众人　　而讲说经法
  以奇珍之宝　　而供养塔寺
  菩萨由是故　　演放其光明
  照曜无央数　　亿千诸佛土
  众人得蒙晖　　悉致于大安
  则便发志求　　无上之佛道

佛告离垢施。菩萨有四法事。而从诸佛逮得此法。何谓为四。以若干种而与各各奇异布施。一切璎珞庄严玉女。惠诸求者。昼夜殷勤咨嗟宣畅如来之德。既有所行。志多在于般若波罗蜜。是为四。佛时颂曰

  用若干之慧　　逮得于总持
  庄严以璎珞　　殊妙玉女施
  常咨嗟佛德　　殷勤精修务
  求智度无极　　诸佛之圣慧
  由是之福报　　逮得于总持
  而行加精进　　百千劫不坐
  其十方诸佛　　所可讲说法
  强识之达士　　一切悉得受

佛告离垢施。菩萨有四事法。寂然定意而成三昧。何谓为四。患厌生死诸所可作。不乐居家志常欲舍。奉行精进弃捐多事。所可兴造尊崇洪业。是为四。佛时颂曰

  弃捐一切周旋处　　彼修一心如虚空
  志无放逸行精进　　所可修业能究竟
  意达行此四德事　　遵修佛道斯寂妙
  便得三昧心憺怕　　则成正觉佛道行

佛告离垢施。菩萨有四事法。究竟众行而获神足。何谓为四。常轻便身心不懈废。于一切法而无所著。察于四大如虚空界。是为四。佛时颂曰

  常轻便其身　　心柔和无懈
  而于一切法　　未曾有所著
  一心立其志　　观察于四大
  而常以平等　　瞻之如虚空
  于此诸四法　　何因得兴行
  聪达以是故　　逮无量神足
  则以须臾间　　至百千佛土
  见无数诸佛　　稽首为作礼

佛告离垢施。菩萨有四事法。而常端正何谓为四。未曾嗔恚。离于诤讼瑕秽之结。礼佛塔寺信悦伏身。笃于庄严建立禁戒。善言应人不以蔽碍。观于法师如奉世尊。是为四。佛时颂曰

  不造嗔恚向他人　　舍于厌秽蠲除垢
  常殊胜心念于道　　当以恭敬扫佛寺
  奉修法禁护诸戒　　而以善言应对人
  为菩萨者不怀结　　观于法师如世尊
  以能习此妙法者　　菩萨欢悦意勇猛
  因此端正睹者欣　　无数百人共瞻察

佛告离垢施。菩萨有四事法。而得化生。何谓为四作佛形像坐莲华上。又以青红黄白莲华捣末如尘。具足擎行供养如来。若散塔寺。多所愍伤于一切人。坚执禁戒未曾求取他人瑕阙。是为四。佛时颂曰

  作佛形像坐莲华　　细捣众华具施寺
  不求他阙怀愍伤　　则得化生莲华中
  识念十方诸群黎　　劝助众德令解脱
  若能习是德称行　　则得化生尊导前

佛告离垢施。菩萨有四事法。大富饶财。何谓为四。常行恭敬施不慢恣。以好被服而惠与人。常怀笃信喜乐淳淑。释置邪见。是为四。佛时颂曰

  其人若布施　　恭敬无慢恣
  于一切众物　　未曾有猗着
  以能笃信乐　　诸佛之教诫
  便能常自在　　致大富饶财
  心专怀恭吝　　无谄无嫉妒
  未曾求人短　　无有刚强行
  志性常质朴　　所见修正直
  以是行之故　　每富多财宝

佛告离垢施。菩萨有四事法。得大智慧。何谓为四。未曾爱惜嫉于经典。若有犹豫辄为决疑。若修行者如应分别。设有所说晓了空事。身遵众行。是为四。佛时颂曰

  不为他人爱惜法　　则能为众决狐疑
  常以教化劝诲人　　思惟空事诸佛行
  若有士尊习是法　　得大智慧名称普
  皆能顺从诸佛教　　还成是寂通达句

佛告离垢施。菩萨有四事法。常识宿命。何谓为四。讽诵经典常行精进。久可忘者而习得之。念故达新可所讽诵。识念句义分别了说。心口相应。以柔软辞为他人讲。立无量行而以殷勤修设法施。常护生死众苦恼者。嗟叹泥洹宣示安隐。方便晓了遵三昧行喜劝助人。是为四。佛时颂曰

  讽诵经典念所忘　　以可意悦为说空
  修行经典未曾倦　　专念三昧无众想
  以能奉行此四法　　得知宿命大巍巍
  识念千劫不可议　　疾得成佛众导师

佛告离垢施。菩萨有四事法。与诸佛会。何谓为四。宁失身命不诽经道。尽其形寿不谤菩萨。假使被害初未曾与恶友相随。常念诸佛奉行三昧。是为四。佛时颂曰

  未曾谤毁佛经道　　亦不敢讪菩萨短
  弃捐远于恶亲友　　而常心念诸佛行
  玩习于此圣道德　　以故得与如来会
  为诸最胜所见受　　乃至成佛无上道

佛告离垢施。菩萨有四事法。而致逮得三十二相。何谓为四。割己珍宝则以供散如来塔寺。以种种香合作香油而涂熏之。若复然灯散种种华。顺敬贤圣而行道教。是为四。佛时颂曰

  珍奇异宝供佛寺　　须曼油香然灯熏
  若干种华而散施　　尊悦意行不失义
  致身奇相三十二　　端正巍巍众德备
  以是法故成就相　　因致最胜人中尊

佛告离垢施。菩萨有四事法。而能成就八十种好。何谓为四。常以敷设若干法座。供事他人谦愻无厌。数数往诣奉见法师。劝化众生使入佛道。是为四。佛时颂曰

  若干种衣敷设座　　奉事于人未曾懈
  为众人故常慕法　　缘是得致八十好
  劝化群萌入佛慧　　若行此法道无难
  菩萨习是功德已　　缘此得致八十好

佛告离垢施。菩萨有四事法。而得辩才。何谓为四。导利菩萨之妙箧藏。诵习三品诸佛经典。昼夜各三思惟觉寤。一切世间悉保信之。诸佛之道不起不灭。执持止足分别观察。能奉行说不惜身命。是为四。佛时颂曰

  谨慎将护菩萨藏　　昼夜奉行三品法
  得无从生不贪世　　开化解说诸佛教
  欢喜悦故顺道化　　执持所诲十力义
  未曾爱惜身寿命　　以佛法故察诸行
  则能奉修此四德　　辄因顺俗妙辩才
  为天世人所奉事　　而持奇异饰华鬘

佛告离垢施。菩萨有四事法。得致佛土。何谓为四。不怀异心意常平等。将顺佛道不违四辈。是为四。佛时颂曰

  见闻他人得供养　　未曾怀嫉妒于彼
  常行等慈志无我　　离于供事乐如空
  以此四法不可量　　而常将护怀慈心
  得清净土妙庄严　　速疾逮成致正觉

佛告离垢施。菩萨有四事法。眷属常和。何谓为四。未曾破坏他人眷属。若有诤讼劝令和合。讽诵经法开导于人。而舍两舌谗言之中。常赞叙人。是为四。佛时颂曰

  未曾破坏他眷属　　若有斗诤劝使和
  讽诵经法为人说　　初不两舌别乱人
  设能奉行斯四法　　致得眷属不离散
  由是群从顺清净　　缘此四法得备悉

佛告离垢施。菩萨有四事法。所愿佛土寻如意生。何谓为四。若见他人逮成智慧不怀嫉妒心。常能修习六波罗蜜。见诸菩萨视之如佛。发意菩萨及坐道场。等心供顺无谀谄也。未曾求于虚伪之德。便能致得供养之利。是为四。佛时颂曰

  见德供养不嫉妒　　志慕清净波罗蜜
  见诸菩萨念如佛　　不以利养怀谀谄
  菩萨若能习是德　　则能到见十方佛
  从意所愿见佛土　　辄如心念得往生

于是离垢施。重白佛言。向者世尊所设教诲。假使我身不奉此法而有毁漏。则为违欺于今现在十方诸佛无极大圣。时大目连。谓离垢施。此事甚妙勿得轻易。道法玄微汝未晓了。诸菩萨行甚亦难办。不可趣尔女人之身。逮得无上正真之道成最正觉。离垢施女报目连曰。如我所言至诚不虚。吾将来世得成如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。此三千大千世界六反震动。勿令众生有退还者。天雨众华箜篌乐器不鼓自鸣。我转女像得为男子。而年八岁这立斯誓愿。应时三千大千世界六反震动。箜篌乐器不鼓自鸣。离垢施女。身变为男形八岁童子。时大目连即从坐起。更整衣服右膝着地。叉手白佛。唯天中天从今已往归诸菩萨及初发意。为之作礼谦逊顺教至诚佛道。所以者何。今小女子。乃能兴发兹道变化。威神无极巍巍尊妙。所可建立至诚之愿。一切悉现真谛瑞应。当具足成果如所言。佛言如是。目连如汝所云。从初发意修菩萨行。至坐佛树则为天上世间众祐。过诸声闻及与缘觉。时佛欣笑。诸佛之法。若欣笑时。有五色光而从口出。照十方界。极于上界三十三天。还绕三匝从顶上入。贤者阿难便从坐起。更整衣服叉手白佛。以偈叹曰

  其声如大梵　　诸天龙鬼音
  如哀鸾悲鸣　　微妙甚弘雅
  响若雷震雨　　咸悦众人心
  假使欣笑时　　多所而踊跃
  愿大德之海　　十力笑何因
  唯为分别说　　令疑者得解
  他六反震动　　普土莫不曜
  雨柔软众花　　堕诸天人上
  化制外异学　　如狮子御兽
  愿为我分别　　何故而欣笑
  日月亿千垓　　明珠电火焰
  诸天龙神明　　梵天王威德
  能仁若出光　　清净无垢尘
  十方明悉蔽　　佛光独显现
  白毛眉间生　　洁白如妙珂
  细滑若好衣　　美泽犹真珠
  圣光如云气　　照百千佛土
  众所之戴仰　　愿说何故笑
  调定其心意　　眉相哀世俗
  细微超乳色　　如山雪远现
  青黄赤白黑　　复如紫红相
  若干千光明　　从能仁口出
  照遍三千国　　悉蔽日月明
  乃至通虚空　　照一切众生
  令火灭水竭　　大海尚枯涸
  佛所说至诚　　未曾有差异
  假使十方人　　悉成为缘觉
  一一致智慧　　寿百亿垓劫
  皆来住佛前　　一时启问义
  能仁等同时　　一音悉决疑
  普慧度无极　　靡所不晓了
  大福威唯说　　奇相三十二
  何因而欣笑　　云何说道慧
  诸天世间人　　闻美软密教

佛告贤者阿难。见离垢施。志求佛道立至诚愿。三千大千世界六反震动变成男子。阿难言见。佛言。是离垢施菩萨发无上正真道造行已来。八十百千阿僧祇劫。然后文殊师利乃发道意。女成佛时。复次如文殊师利。四十八万诸菩萨等。佛土清净为一佛土。时大目连问。离垢施汝族姓子。建立于慧。发无上正真道意以来久远。何以不转于女人身。离垢答曰。世尊叹仁神足最尊。卿何以故不转男子。目连默然。离垢施曰。不以女身及男子形。逮成正觉。所以者何。道无所起。无有能成无上正觉。文殊师利白佛难及世尊。离垢施菩萨深入微妙巍巍乃尔。佛告文殊。离垢施菩萨从六十亿诸佛世尊。行空三昧。从八十亿佛启受奉行不起法忍。从三十亿佛启问深妙菩萨道品。供养奉事八十亿佛。饮食肴膳衣服钵器是为究竟。决了无疑欲有所了。开化一切故。问印三昧。佛语文殊。若有族姓子女。受此经法。广为他人分别说者德不可量。假使有人恒沙佛土满中七宝。兴设布施。不如受持讽说此经。福过于彼不可称计。是诸菩萨因之报法当须饮食。从得成就。文殊师利问佛。是经名何云何奉行。佛言是经名分别辩才普达悉周。离垢施问当奉持之。说是经时八十亿天与人。究竟决了无上正真道意。时辩积菩萨。白世尊曰。离垢施菩萨久如当成无上正真之道。为最正觉。佛言族姓子。过恒沙等百千阿僧祇劫。当得佛道。号名离垢光英王如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。劫名无量德。自由诸声闻菩萨。所居服食犹如天上。时离垢施菩萨。闻佛授决。踊在空中去地八十亿七尺。放身光明照百千亿诸佛国土。在世尊上化现八万四千琦宝之盖以供养佛。则于虚空示无央数神足变化。礼于十方不可称计如来至真。供养毕讫寻复来还。住于佛前。于时梵天梵志及五百众闻佛授与离垢施决。及见变化益用欢喜踊跃自庆善心生焉。同合一声。以偈叹曰

  其有奉敬佛　　是等大福利
  若稽首正觉　　便逮平等法
  宿世犯罪衅　　生于梵志家
  见世尊弟子　　口宣言不祥
  唯今自悔过　　坐说此言故
  睹见诸佛子　　所语不顺义
  其不见世尊　　人中之尊王
  得人身无益　　不宜受饮食
  离垢施知之　　吾等虚妄祠
  睹见佛诸子　　恭敬为稽首
  善为我等说　　吾初生堕地
  得见于导师　　便逮闻佛名
  彼叹圣功德　　正真无虚妄
  吾等辈一切　　闻之愿道意
  是我本余福　　还得闻佛音
  来到导师所　　听省经典义
  见礼于世尊　　闻察无上法
  蒙见导师故　　解脱众苦恼
  世护多所安　　用说此法故
  吾等当学是　　因成诸佛法
  闻行于正道　　缘致诸佛法
  以愍伤我故　　宣畅真谛行
  讲说道之门　　菩萨所当奉
  是平等之行　　令成世明道
  见此等心已　　佛即时欣笑
  阿难问世尊　　人中上愿说
  五百诸梵志　　在此前立者
  皆当同一劫　　逮得佛导师
  前世已曾更　　供养五百佛
  于此寿终已　　当见亿垓佛
  于八十亿劫　　未曾归恶趣
  于一一劫中　　当见亿垓佛
  从是异劫中　　当成两足尊
  号名曰梵志　　皆共同一劫
  寿命悉一等　　各八十亿劫
  尊土圣众同　　比丘八十亿
  导利于群生　　开化亿人民
  稍稍所游居　　寂然无所著

佛说如是离垢施。诸菩萨大会之众。梵天梵志等五百人。王波斯匿诸比丘僧。天龙揵沓和阿须伦人民。闻经欢喜作礼而去

离垢施女经


佛说摩诃衍宝严经(一名大迦叶品

    No. 351 [Nos. 310(43), 350, 352]

佛说摩诃衍宝严经(一名大迦叶品)

        晋代译失三藏名

闻如是。一时佛游王舍城耆阇崛山中。与大比丘众八千人俱。菩萨万六千人。从诸佛国而来集此。悉志无上正真之道。尔时世尊告尊者大迦叶曰。菩萨有四法。失般若波罗蜜云何为四。一者不尊法不敬法师。二者为法师者悭惜吝法。三者欲得法者为法作碍。呵责轻易不为说法。四者憎慢贡高自大誉毁他。是谓迦叶。菩萨有四法失般若波罗蜜。复次迦叶。菩萨有四法。得般若波罗蜜。云何四。一者尊法敬重法师。二者随受闻法广为他说。心无爱着亦无所求。为般若波罗蜜故。舍一切财物。求多学问如救头然。三者闻已受持。四者行法不着言说。是谓迦叶。菩萨有四法得般若波罗蜜

复次迦叶。菩萨成就四法忘菩萨心。云何为四。一者欺诳师尊长老。二者他无恶事说有所犯。三者摩诃衍者毁呰诽谤。四者谄伪心无至诚。是谓迦叶。菩萨成就四法忘菩萨心

复次迦叶。菩萨成就四法。一切始生至于道场。菩萨之心常现在前终不忘失。云何为四。一者宁死终不妄语。二者一切菩萨起世尊想四方称说。三者无有谄伪其心至诚。四者不乐小乘。是谓迦叶。菩萨成就四法一切始生至于道场。菩萨之心常现在前终不忘失

复次迦叶。菩萨成就四法。生善法则灭善不增长。云何为四。一者贡高憍慢学世经典。二者贪着财物数至国家。三者嫉妒诽谤。四者未曾闻经闻说诽谤。是谓迦叶。菩萨成就四法生善则灭善不增长

复次迦叶。菩萨成就四法善不衰退增长善法。云何为四。一者乐闻善法不乐闻非法。乐六度无极菩萨箧藏。二者下意不慢众生。三者以法知足除去邪慢。他犯不犯不说其过。不求他人误失之短。四者所不知法不说是非。以如来证。如来无量境界随众生根。佛所说法我不能达。是谓迦叶。菩萨成就四法善不衰退增长善法。复次迦叶。心有四曲菩萨当除。云何为四。一者犹豫疑于佛法。二者憍慢不语恚怒众生。三者他所得利心生悭愱。四者毁呰诽谤不称誉菩萨。是谓迦叶。心有四曲菩萨当除

复次迦叶。菩萨有四顺相。云何为四。一者所犯发露而不覆藏。心无缠垢。二者真言致死终不违真。三者所说而不相夺一切侵欺呵骂轻易挝捶缚害。一切是我宿命所作。不起恚他不生使缠。四者坚住不信他说。至信佛法亦不信之。内清净故。是谓迦叶。菩萨有四顺相

复次迦叶。菩萨有四恶。云何为四。一者多闻调譺行不如法。不顺教诫。二者离于正法不敬师长。不消信施。三者失戒定慧痴惘受施。四者见于调御智慧菩萨。不敬。贡高而轻慢之。是谓迦叶。菩萨有四恶

复次迦叶。菩萨有四智。一者未闻者闻行如法。二者依义不以文饰。三者顺教戒善语。所作皆善孝顺师尊。得戒定慧而食信施。四者见于调御智慧菩萨。兴善敬心。是谓迦叶。菩萨四智

复次迦叶。菩萨有四差违。云何为四。一者未悉众生便谓亲厚。菩萨差违。二者众生不能堪受微妙佛法而为说之。菩萨差违。三者爱乐上妙为说下乘。菩萨差违。四者众生正行皆得妙法。而相违反。菩萨差违。是谓迦叶。菩萨有四差违

复次迦叶。菩萨有四道。云何为四。一者等心为一切众生。二者劝一切众生学佛智慧。三者为一切众生而说正法。四者令一切众生顺于正行。是谓迦叶。菩萨四道

复次迦叶。菩萨有四恶知识。云何为四。一者声闻但自饶益。二者缘觉少义少事。三者世俗师典专在言辩。四者习彼但得世法不获正法。是谓迦叶。菩萨四恶知识

复次迦叶。菩萨有四善知识。云何为四。来乞求者是菩萨知识长养道故。为法师者。是菩萨知识多闻。长养般若波罗蜜故。劝出家学道者。是菩萨善知识。长养一切诸善根故。诸佛世尊是菩萨善知识。长养一切诸佛法故。是谓迦叶菩萨四善知识

复次迦叶。有四像菩萨。云何为四。一者贪利不求功德。二者但自求乐不为众生。三者但自除苦不为众生。四者欲得眷属不乐远离。是谓迦叶。四像菩萨

复次迦叶。菩萨有四真功德。云何为四。一者解空而信行报。二者解无吾我大慈众生。三者虽乐泥洹不舍生死。四者行布施欲化众生。不望其报。是谓迦叶。菩萨四真功德

复次迦叶。菩萨摩诃萨有四大藏。云何为四。一者值佛出现于世。二者闻说六度无极。三者见法师心中无碍。四者不放逸乐住山林。是谓迦叶。菩萨有四大藏

复次迦叶。菩萨有四法越度众魔。云何为四。一者不舍菩萨心。二者心不碍一切众生。三者不染着一切诸见。四者不轻慢一切众生是谓迦叶。菩萨四法越度众魔

复次迦叶。菩萨摩诃萨有四法。摄受一切善法。云何为四。一者常止山泽心无欺诈。二者有恩无恩心常忍辱。三者念报四恩弃舍身命为众生故。四者求法而无厌足。具一切善根故。是谓迦叶。菩萨摩诃萨四法摄受一切善。复次迦叶。菩萨摩诃萨有四无量福行。云何为四。一者法施心无悕望。二者见有犯戒兴大悲心。三者愿一切众生乐菩萨心。四者见有羸劣不舍忍辱。是谓迦叶。菩萨四无量福行

复次迦叶。非以菩萨名故称为菩萨。行法行等行禅分别故。乃称菩萨

复次迦叶。菩萨摩诃萨成就三十二法得称菩萨。云何为三十二。一者至心饶益众生。二者欲逮萨芸若智。三者自谦不毁他智。四者不慢一切众生。五者信心一切众生。六者爱念一切众生。七者至竟慈愍众生。八者等心怨亲。九者众生求于泥洹益以无量福。十者见众生欢喜与语。十一者已许无悔。十二者大悲普遍一切众生。十三者求法多闻无厌。十四者己之所犯知以为过。十五者见他所犯谏而不怒。十六者修行一切威仪礼节。十七者施不望报。十八者忍辱无碍。十九者精进求一切善根。二十者修习禅定出过无色。二十一者以权摄慧。二十二者四恩摄权。二十三者有戒无戒等以慈心。二十四者至心闻法二十五者专止山泽。二十六者不乐世荣。二十七者不乐小乘乐大乘功德。二十八者远恶知识亲善知识。二十九者成就四梵居止。三十者依猗智慧。三十一者众生有行无行终不舍离。三十二者所说无二敬重真言。菩萨之心最为在前。是谓迦叶。菩萨摩诃萨成就三十二法得称菩萨。复次迦叶。我当为汝说喻。智者以喻得知。菩萨功德。譬如地界为一切众生而无有二。如是迦叶。菩萨从初发意以来至于道场。为一切众生亦无有二。譬如水界生于百谷诸药草木。如是迦叶。菩萨至诚清净慈心覆育一切。为诸众生起青白之德。譬如火界成熟百谷诸药草木如是迦叶。菩萨以般若波罗蜜。成就一切众生。譬如风界庄严一切诸佛国土。如是迦叶。菩萨善权庄严一切诸佛国土。譬如月初日日增长。如是迦叶。菩萨至诚清净增长一切白净之法。譬如日出照诸众生。如是迦叶。菩萨以一般若波罗蜜。照一切众生。譬如师子鹿王随其所行。一切无有恐怖。如是迦叶。菩萨住戒功德随其所行。一切无有恐怖。譬如象王堪诸重担终无疲厌。如是迦叶。菩萨善调御心为一切众生。堪任重担而无厌惓。譬如莲花生在淤泥而不着水。如是菩萨生在世间不着世法。譬如伐树虽截其枝。而不伐根复生如故。如是迦叶。菩萨以善权心。虽断结缚犹生三界。譬如诸方江河之水。入于大海悉为一味。如是迦叶。菩萨作若干种善愿功德。当作佛道悉为一味。譬如四天王三十三天住须弥山。如是迦叶。菩萨善根心中。譬如国王大臣所助。乃具成办一切国事。如是迦叶。菩萨般若波罗蜜善根所助。乃具成办一切佛事。譬如迦叶天无云者雨不可得。如是菩萨。不多闻者法雨不可得。譬如迦叶天有云者雨泽可得。菩萨如是有大慈云能降法雨。譬如圣王出者七宝可得。如是迦叶。菩萨出者三十七品道宝可得。譬如有摩尼珠者。彼中无量百千种珠悉皆可得。如是迦叶。有菩萨心者。彼中无量百千声闻缘觉之法悉皆可得。譬如三十三天游杂园观。一切乐具皆悉同等。如是迦叶。菩萨至诚清净。为一切众生方便同等。悉无差降。譬如有毒因咒药故不能为害。如是迦叶菩萨结毒因智乐故不能为害。譬如城邑有诸粪壤饶益田用。如是迦叶。菩萨因结学萨芸若用。是故迦叶。菩萨欲学此宝严经者。当正观诸法。云何为正观。谓真实观诸法。云何为真实观诸法。谓不观我人寿命。是谓中道真实观法

复次迦叶。真实观者。谓不观色有常无常。亦不观痛想行识有常无常。是谓中道真实观法。复次迦叶。云何为真实观诸法。谓不观地有常无常。亦不观水火风界有常无常。是谓中道。真实观法

复次迦叶。有常是一边。无常为二边。此二中间无色。不可见亦不可得。是谓中道真实观法。有我是一边。无我为二边。此二中间无色。不可见亦不可得。是谓中道真实观法。有真实心者。是谓一边。无真实心者。是为二边。无心无思无意无识。是谓中道真实观法。如是不善法。世间法。有诤法。有漏法。有为法。有秽污法。是谓一边。如是善法。出世间法。无诤法。无漏法。无为法。白净之法。是为二边。此二中间。无所有亦不可得。是谓中道真实观法。有者是一边。无者为二边。此二中间。无所有亦不可得。是谓中道真实观法

复次迦叶。我为汝说。无明缘行。行缘识。识缘名色。名色缘六入。六入缘更乐。更乐缘痛。痛缘爱。爱缘取。取缘有。有缘生。生缘老死苦恼忧悲啼泣。如是生大苦阴。无明已尽则行尽。行尽则识尽。识尽则名色尽。名色尽则六入尽。六入尽则更乐尽。更乐尽则痛尽。痛尽则爱尽。爱尽则取尽。取尽则有尽。有尽则生尽。生尽则老死苦恼忧悲皆尽。如是灭大苦阴。无有此二。亦无二行。中间可知。是谓中道真实观法。如是行行尽。识名色六入更乐痛爱取有生老死老死尽。无有此二。亦无二行。中间可知。如是迦叶。是谓中道真实观诸法也

复次迦叶。中道真实观诸法者。不以空三昧观诸法空。诸法自空故。不以无想三昧观诸法无想。诸法自无想故。不以无愿三昧观诸法无愿。诸法自无愿故。不以无行观诸法无行。诸法自无行故。不以无起观诸法无起。诸法自无起故。不以无生观诸法无生。诸法自无生故。不以如观诸法如。诸法自如故。是谓中道真实观法。不以无人观诸法空。诸法自空故。如是本空末空。现在世空。当令依空莫依于人。若有依空。倚此空者。我说是人远离此法。如是迦叶。宁猗我见积若须弥。不以憍慢。亦不多闻而猗空见者。我所不治。譬如良医应病与药。病去药存。于迦叶意所趣云何。此人苦患宁尽不耶。答曰。不也世尊。所以者何。药在体故。如是迦叶。空断一切见。若有猗空见者。我所不治。亦复如是。譬如有人畏于虚空啼泣而说。今当为我去此虚空。于迦叶意所趣云何。宁能去不。答曰不也世尊。如是迦叶。若畏空者。我说此人甚为狂惑。所以者何。众生造空而彼畏之。譬如画师作鬼神像即自恐惧。如是迦叶。诸凡愚人自造色声香味细滑之法。轮转生死不知此法。亦复如是。譬如幻师化作幻人。而食幻师无有真实。如是迦叶。修行比丘。随所思惟一切虚伪。而不真实无有坚固。亦复如是。譬如二木因之更生火而烧彼木。如是迦叶。因真实观生无漏慧根。而彼即烧于真实观。亦复如是。譬如然灯诸冥悉除。此闇无所从来亦无所至。不从东方南方西方北方而来。亦不至彼。如是迦叶。智慧已生无智即灭。此无智者。无所从来亦无所至。如是迦叶。灯无此念我当除冥。而灯然者诸冥即除。灯闇俱空。不可获持无作无造。亦复如是。譬如迦叶百岁冥室若然灯者。彼闇颇有是念。我当住此而不去耶。答曰不也世尊。此闇必灭。如是迦叶。若有众生百千劫中造作结行。以一正观无漏智灯即得除尽亦复如是。譬如空中不生五谷。菩萨如是不从无为而生佛法。譬如大地众秽杂糅而生五谷。菩萨如是于世杂糅结缚之中。乃生佛法。譬如陆地不生莲花。菩萨如是不从无为出生佛法。譬如淤泥之水生杂莲花。菩萨如是从邪众生结缚之中。乃生佛法。譬如醍醐满于四海。当知菩萨造作善根。亦复如是。譬如一毛破为百分。以一分毛取四大海一渧之水。当知声闻造作善根。亦复如是。譬如迦叶芥子中空。当知声闻造作善根。亦复如是。譬如十方虚空。当知菩萨造作善根。亦复如是。譬如刹利顶生。皇后贱人共会。若后生子。于意云何。当言此子是王子耶。答曰非也世尊。如是迦叶。此诸声闻从我法界生。然彼一切非世尊子。譬如刹利顶生大王贱女共会。若后生子。于意云何。贱人所生当言此子非王子耶。答曰不也世尊。此是王子。如是迦叶。虽从贱生而是王子。菩萨如是初发道心。住于生死教化众生。而彼一切是如来子。譬如圣王虽有千子无圣王相。圣王之意。起无子想。如是迦叶。如来虽有百千声闻弟子之众。无菩萨者。如来之意。起无子想。譬如迦叶圣王皇后持斋七日。生一童子。具圣王相。三十三天咸共叹之。而不称说其余大者。所以者何。童子虽小而不断于圣王种故。菩萨如是初发道心。诸根未具彼诸天众。曾见佛者咸共叹之。而不称说诸阿罗汉具八解脱。所以者何。虽初发菩萨心诸根未具。不断诸佛如来种故。譬如有小摩尼真珠。胜于水精如须弥山。菩萨如是初发道心。出过一切声闻之上。譬如迦叶圣王皇后初生童子。一切臣属皆为作礼。菩萨如是初发道心。一切天人皆为作礼。譬如须弥山王。出诸良药。为一切人疗治苦患。无所适莫。菩萨如是。学智慧药为一切人疗生死患。亦无适莫。譬如礼敬初生之月。非后盛满。如是迦叶。礼初发意菩萨者。胜非复得成如来至真等正觉也。所以者何。诸佛如来从菩萨生故。譬如迦叶无有舍月礼星宿者。如是无有舍具戒德智慧菩萨。而礼声闻。譬如迦叶一切天人不能以水精为摩尼真珠。声闻如是成就一切戒清净行。不能坐佛树下成于无上正真之道。譬如得摩尼真珠者。获余无量百千财宝。菩萨如是出于世者。则有无量声闻缘觉现于世间。于是世尊。告尊者大迦叶曰。菩萨为一切众生。求修诸善根具众智药。往至四方随病所应如实治之。迦叶。云何为如实治。谓以恶露不净治欲。慈心治恚。缘起治痴。空治一切见。无想治一切四相。无愿治一切欲界色无色界。四非颠倒治四颠倒一切行。无常治非常有常想一切行。苦治苦有乐想。无我治无我有我想。不净想治不净有净想。四意止者。治计着身痛心法身。身观者不起观身我见痛。痛观者不起观痛我见心。心观者不起观心我见法。法观者不起观法我见。四意断者。悉断一切不善之法。习一切善法。四神足者。舍身心真想。五根五力治不信懈怠乱念无智。七觉者治诸法无智。圣八道者此慧所治一切邪道。是谓迦叶。随病所应如实治之。如此迦叶。菩萨当作是学

复次迦叶。假令三千大千国土诸有识者。悉如耆域医王。有人问之。以何方药治彼病者。终无能答。唯有菩萨能悉答之。是故迦叶。菩萨当作是念我不应求世间之药。当求出世间药修一切善根。是众智药。往至四方。随众生病如实治之

复次迦叶。云何为出世智药。谓因缘智无我人寿命智。解一切诸法空无恐怖之心。彼作是观。何者心欲。何者怒痴。为过去耶。为未来现在耶。若过去者去心以灭。若未来者来心未起。若现在者现心不住。如是迦叶。心未来不在内亦不在外。亦不在两中间。心者非色不可见。亦无对无见无知无住无余倚。迦叶。心者一切诸佛。不已见不当见不今见。若一切诸佛。不已见不当见不今见者。云何知有所行。但以颠倒想故有诸法行。诸法者如幻化之法。受种种生故。是心如风远行不可持故。心如流水不可住故。心如灯炎缘相续故。心如电光时不住故。是心如雾外事秽故。心如猕猴贪一切境界故。心如画师造种种行故。心不得住随众结故。心独无侣常乐驰走故。是心如王一切法之首故。是心如母生一切苦故。是心如炎聚散一切诸善根故。是心如鱼钩苦有乐想故。是心如梦无我有我想故。是心如蝇不净有净想故。是心如怨家所作不可故。是心如罗刹常乐求便故。是心如憎嫉常乐求过故。是心不可爱恩爱痴故。是心如贼断一切善根故。是心着色如蛾投火故。是心爱声如军乐战鼓音故。是心爱香如豕乐臭秽故。是心着味如使人乐余食故。是心爱更乐如蝇乐膻故。求心无有亦不可得。设无不可得者。则无过去未来现在。设无过去未来现在者则过三世。设过三世者。是则不有亦不无。若不有不无者是为不生。若不生者是为无性。若无性者是为无起。若不起者是亦不灭。若不灭者则无败坏。若无败坏者则无来无去。若无来去者则无有生死。若无去来无生死者是则无行。若无行者则是无为。若无为者则是圣贤之性。若圣性者则无戒不戒。若无戒不戒者则无威仪行亦无不威仪。若无行无威仪不威仪者。是则无心无心数法。若无心心数法者则无业无报。若无报者则无苦无乐。若无苦乐者是圣贤之性。若圣贤性者则无业无作。如此性中无作身业。亦无作口意业。此性平等无上中下。亦无差别。一切诸法悉平等故。如是迦叶。此性远离舍身口故。此性无为顺涅槃故。此性清净离于一切诸结垢故。此性无我离我作故。此性平等离虚实故。此性真出要第一义故。此性无不尽至竟不起常如法故。此性乐无为悉同等故。此性清洁至竟无垢故。此性非我求我不可得故。此性洁白至竟净故。汝等迦叶。当应求内反去求外。当来之世。当有比丘驰走如犬。云何比丘驰走如犬。譬如有犬搏掷令怖。反走逐之不趣掷者。如是迦叶。当有沙门婆罗门畏色声香味细滑法。而反乐中不观于内。不知何由得离色声香味细滑法。不知不觉遂入人间。复为色声香味细滑法而得其便。彼在山泽而命终者。因持俗戒得生天中。复为天上色声香味细滑法而得便也。身坏命终生四恶趣。云何为四。地狱畜生饿鬼阿须罗中。是谓迦叶。比丘驰走亦复如犬。云何比丘不走如犬。若人挝骂默受不报。呵责嗔怒比丘不报怒。但观内身骂谁打谁。谁受恚责。是谓迦叶。如此比丘不走如犬。譬如御者。若马放逸即能制之。修行比丘亦复如是。若心驰散即随制止令顺不乱。譬如绞人必断其命。如是迦叶。一切诸见有计我者必断慧命。譬如有人随其所缚则悉解之。比丘如是随心所缚当即除之。如是迦叶。出家学道有二重缚。云何为二。一者学世经典。二者执持衣钵而不精进

复次迦叶。出家学道有二坚缚。云何为二。一者见缚。二者贪财名誉所缚。复次迦叶。出家学道有二法障碍。云何为二。一者狎习白衣。二者憎嫉师友。出家学者复有二垢。云何为二。一者任取二结。二者诣知友家而从乞食。复次迦叶。出家学道有二雹雨。云何为二。一者诽谤正法。二者犯戒而食信施。出家学者复有二疮。云何为二。一者观他短。二者自覆己短

复次迦叶。出家学者有二烦热。云何为二。一者藏浊持袈裟。二者欲令有戒行者承顺于己。出家学者复有二病。云何为二。一者憍慢不观其心。二者毁呰学摩诃衍者

复次迦叶。沙门称说沙门者。云何沙门称说沙门有四沙门。云何为四。一者色像沙门二者诈威仪沙门。三者名誉沙门。四者真实沙门。云何色像沙门。若有沙门成就色像。剔除须发被着法服手持应器。彼身恶行口意恶行。不习调御亦不守护。犯戒作恶贪不精进。是谓迦叶色像沙门。云何诈威仪沙门。若有沙门成就礼节。游步正智。食知止足。行四圣种。不乐众聚道俗之会。少言少睡。然彼威仪诈不真实不期净心。不习止息而有见想。于空便起如坑之想。诸有比丘习行空者。发怨家想。是谓迦叶诈威仪沙门。云何名誉沙门。若有沙门奉持禁戒。欲令他人知奉持戒。精进学问欲令他人知精进学。住止山泽中欲令他人知住山泽。少欲知足精勤独住欲令他知。不厌至死。不求离欲。不乐尽止。不欲求道。息心梵行。不为泥洹。是谓迦叶名誉沙门。云何为真实沙门。若有沙门不为身命。况复贪财着于名誉。乐听空无相无愿之法。闻则欢喜修行如法。不为涅槃而修梵行。况为三界不作空见。况见我人寿命依法求道。离结解脱不求外道。观诸法性皆悉究竟清净无秽。而自照察不由于他。如法者。不见如来况有色身。不见无欲法况有文饰。不想无为况有众德。不习断法不学修法。不住生死不乐涅槃。不求解脱亦不求缚。知一切法究竟清净不生不灭。是谓迦叶真实沙门。是故迦叶。当学真实沙门。莫习名誉沙门。譬如贫人外有富名。于意云何。彼名有实不。答曰。不也世尊。如是迦叶。有沙门名无沙门德。我说此人是为极贫。譬如有人大水所漂渴乏而死。如是迦叶。有沙门梵志习学多法。而不能除淫怒痴渴。彼为法水所漂结渴而死。生恶趣中亦复如是。譬如医师持种种药疗他人病而不自治。如是迦叶。有沙门梵志。多讽诵法而不自除淫怒痴病。亦复如是。譬如病人服王妙药。不自将节而致终没。如是迦叶。多有沙门梵志。行不如法起诸结病。终生恶趣亦复如是。譬如摩尼珠堕不净中无所复直。如是迦叶。多有沙门梵志贪着财利。当知亦如摩尼珠堕不净中无所复直。譬如死人着金花鬘。如是迦叶。人不持戒被着袈裟。亦复如是。譬如长者子净自澡浴。被白净衣着薝卜华鬘。如是迦叶。多闻持戒被着袈裟。亦复如是

复次迦叶。有四不持戒似如持戒。云何为四。若有比丘护持禁戒成就威仪。至微小事当畏惧之。持比丘净戒。成就威仪礼节。身口意行正令清净。而计吾我。是谓迦叶一不持戒似如持戒。复次比丘。诵律通利察住律法不断身见。是谓迦叶二不持戒似如持戒。复次比丘。行慈众生闻说诸法不起不灭。而怀恐怖。是谓迦叶三不持戒似如持戒

复次比丘。行十二法净功德行。而起见我有我所。是谓迦叶四不持戒似如持戒。如是迦叶。戒称戒者。谓无我亦无我所。无作不作。无事非事。亦无威仪无行不行。无名色相。亦无非相。无息不息。无取无舍。无可取者。亦无不可舍。不施设众生。亦不施设无众生。无有口行无不口行。无心不心。无倚不倚。无戒不戒。是谓迦叶无漏圣戒。而无所堕。出于三界离一切倚。于是世尊。说此颂曰

  持戒不有亦无垢　　持戒无憍而不倚
  持戒不闇无所缚　　持戒无尘无污秽
  究竟止息无上寂　　无想不想亦无秽
  诸恸众倚一切断　　是为迦叶持佛戒
  不着身口不倚命　　不贪一切受生死
  以正去来住正道　　是为迦叶持佛戒
  不着世间不倚世　　得明无闇无所有
  无有己想无他想　　断一切想得清净
  无此彼岸无中间　　于此彼岸亦不着
  无缚无诈无诸漏　　是为迦叶持佛戒
  谓名及色意不着　　禅定正念调御心
  无有吾我无我所　　是为迦叶称住戒
  不倚禁戒得解脱　　不叩持戒为欢喜
  于此上求八正道　　是谓持戒清净相
  不期持戒不依定　　谓修习此得智慧
  无有无得是圣性　　清净圣戒佛所称
  谓己身见心解脱　　我是我所终不起
  心能解空佛境界　　如是持戒莫能胜
  善住净戒得禅定　　已获禅定修智慧
  已修智慧便得脱　　已逮解脱平等戒

说此偈已。八百比丘逮得漏尽。三万二千人远尘离垢。诸法眼生。五百比丘昔已得定。闻佛说此甚深之法。不能解了从座起去。于是大迦叶。白世尊曰。此五百比丘昔已得定。闻是深法不能解了即便起去。世尊告大迦叶曰。此五百比丘贡高慢故。不能解此无漏净戒。是所说法甚深微妙。诸佛之道极甚深妙。非是未种善根与恶知识共相随者所能解了。此五百比丘。昔迦叶如来兴出世时。悉为异学弟子。闻迦叶如来说法时。计著有故。一闻说法心得欢喜。以是因缘。身坏命终生忉利天。从彼命终还生人间。于我法中出家学道。此诸比丘为见所坏。闻是深法不能解了。今始造缘不复生于恶趣之中。此身终已当得灭度。于是世尊。告尊者须菩提曰。汝去化彼五百比丘。须菩提白佛言。唯世尊。此五百比丘不受佛教。何况我耶。于是世尊。化作比丘在彼道中。五百比丘见已。往诣化比丘所。问化比丘曰。诸贤。欲何所至。化比丘曰。欲诣山泽游住安乐。所以者何。向闻世尊所可说法。我不能解了故。即言诸贤。我等亦闻世尊说法不能解了而有恐怖。欲诣山泽游住安乐。化比丘曰。诸贤。且来当共谊计。莫得有诤非沙门法。诸贤。称说般泥洹者。为何等法般泥洹耶。是身中何者众生。何者我人寿命。谓般泥洹。何所法尽便得般泥洹。五百比丘曰。淫怒痴尽便得般泥洹。化比丘问曰。诸贤。有淫怒痴尽耶。而言此尽便得般泥洹。五百比丘答曰。诸贤。淫怒痴者。不在于内而不在外。亦不在两中间。亦非无思想而有也。化比丘曰。是故诸贤。不当思想亦莫反想。若不思想不反想者。则无染不染。若无染不染者。是说息寂。诸贤当知。所有戒身。亦不生亦不般泥洹。定慧解脱度知见身亦不生亦不般泥洹。诸贤。因此五分法身说泥洹者。是法远离空无所有。无取无断。如是诸贤。云何可想般泥洹耶。是故诸贤。莫想于想莫想于无想。亦莫断想及与无想。若断想无想者。是为大缘。诸贤。若入想知灭定者。于是似有所作。说此法时。五百比丘诸漏永尽心得解脱。即诣佛所稽首佛足却坐一面。于是尊者。须菩提。问诸比丘曰。诸贤。向去何所今从何来。诸比丘曰。尊者须菩提。佛所说法无去无来。须菩提。复问诸贤。师为是谁。诸比丘曰。谓不生不灭是。须菩提复问。云何知法。答曰。无缚无解。须菩提复问。诸贤。云何解脱。答曰。无明灭而明生也。须菩提复问。诸贤。谁弟子耶。答曰。谓如是得如是正智。须菩提复问。诸贤。何时当灭度耶。答曰。如来所化般泥洹。须菩提复问。诸贤。所作已办耶。答曰。吾我所作悉皆已断。须菩提复问。诸贤。谁同梵行。答曰。不行三界。须菩提复问。诸贤。结已尽耶。答曰。诸法至竟灭。须菩提复问。诸贤。降伏魔耶。答曰。诸阴不可得。须菩提复问。诸贤。顺尊教耶。答曰。无身口意。须菩提复问。诸贤。清净福田耶。答曰。无受亦无所受。须菩提复问。诸贤。度生死耶。答曰。无常无断。须菩提复问。诸贤。向福田地耶。答曰。一切诸着悉已解脱。须菩提复问。诸贤。趣何所耶。答曰。随如来之所化也。如是尊者须菩提问。五百比丘答。时彼大众闻已。八百比丘诸漏永尽心得解脱。三万二千人远尘离垢诸法眼生。于是尊者须菩提。白世尊曰。甚奇甚特此宝严经。饶益发起趣摩诃衍诸族姓子族姓女。须菩提复问。世尊。诸族姓子族姓女。说此宝严经者。得几所福。世尊答曰。若族姓子族姓女。说此宝严经教授他人。书写经卷在所著处。是为天上天下最妙塔寺。若从法师闻受持读诵。书写经卷者。当敬法师为如如来。若敬法师供养奉持者。我记彼人必得无上正真道。命终之时要见如来。是人当得十种身清净。云何为十。一者死时欢喜无厌。二者眼目不乱。三者手不扰乱。四者心不扰乱。五者身不烦扰。六者不失大小不净。七者心不污秽。八者心不错乱。九者手不摸空。十者随其坐命终。是谓十种身清净也

复次迦叶。当得十种口清净。云何为十。一者善音。二者软音。三者乐音。四者爱音。五者柔和音。六者无碍音。七者敬音。八者受音。九者天所受音。十者佛所受音。是谓十种口清净也

复次迦叶。当得十种意清净。云何为十。一者无恚不怒他人。二者无恨不语。三者不求短。四者无结缚。五者无颠倒想。六者心无懈怠。七者戒不放逸。八者意乐布施欢喜受。九者离贡高慢。十者得三昧定。获一切佛法。是为十种意清净也

复次迦叶。若有恒沙国土满中七宝。供养如恒沙等诸佛如来等正觉及弟子众。如恒沙劫一切施安。至般泥洹后起七宝塔。不如是族姓子族姓女闻此宝严经。受持讽诵为他人说不诽谤也。若有女人说此经者。是女人终不堕恶趣。亦不复受女人身也。

复次迦叶。若有族姓欲以一切珍妙供养此经典者。当受持读诵书写经卷为他人说。是为供养此经典已。若有受持讽诵书写为人说者。则为供养诸佛如来。佛说此经时。尊者大迦叶。一切天龙鬼神世间人民。闻佛说已。欢喜奉行

佛说摩诃衍宝严经


佛说菩萨修行经

    No. 330 [Nos. 310(28), 311]

佛说菩萨修行经(亦名威施长者问观身行经)

        西晋河内沙门白法祖译

闻如是。一时佛游舍卫国祇树给孤独精舍。与大比丘千二百五十及众菩萨五千人俱。皆尊菩萨神通[叡-├+〡]达权慧变化。游三千世界普利一切莫不蒙济。于时舍卫国大城之中。有豪长者名比罗达(晋言威施)。与其城中诸大长者五百人等。宿意同念。俱从舍卫大城中。出往诣祇树给孤独精舍。前至佛所即皆稽首。绕佛三匝。问讯世尊却坐一面。于时世尊。以无限达。因问威施及诸长者族姓子等。发何志乎诣如来耶。是时威施并诸长者。即白佛言。吾等世尊。集坐静处竞有念言。佛世难值人身由然。得脱离世同亦甚难。吾等窃议。为用何乘而至泥洹。当以声闻缘一觉乘取泥洹耶。大乘普智泥洹脱乎。时吾等举心便发言曰。志愿无上乘泥曰。身不以声闻缘觉脱也。吾等世尊。志愿发心无上独尊正意。以斯法故。来奉如来。云何世尊菩萨大士。内性常欲应于无上平等正真尊觉。当学何法而应行住。唯愿如来垂慧普慈。以无极哀散示疑结

尔时世尊。告威施曰。善哉善哉。诸大长者乃能改俗。舍世之荣乐。发无上正真道意。觐诣如来又威施等。勤听思念。当演说之菩萨大士行。得无上等最正觉。志作所应及其觉法。长者威施。并五百人即皆叉手受教而听。时佛告曰。是诸长者。菩萨大士发行。欲应无上正真等最觉者。心向众生。当建弘普无极大慈。志习念行勤执无舍。进学无忘。是乃应于无上觉道。又诸长者。若有众生。分其所受身口意恶。彼行非故。命终堕狱故。诸长者。天地聚合集以众苦。向诸网见众生之类。存心大慈勤志大悲。守习学行专精如斯。其身不着衣被饮食。于诸利养意亦不贪。以诸所珍乐尽施惠。念彼众生。慎行戒具忍进定智。如是长者。菩萨大士。欲发无上正真道者。当习观法乃应身行。尔时。威施及诸长者。吾等世尊。当修身三口四意三念法。菩萨大士。云何应观身行法耶。尔时世尊。告威施等。如是长者。菩萨大士。有四十二事而以观身。作是观已。离想结缠身心意识。缚着吾我贪身寿命。浊乱诸非应便除尽。是时威施及诸长者。受教而听。佛言。菩萨大士。观身污秽本为不净。观身臭处纯积腐烂。观身危脆要当毁坏。观身无强当归碎散。观身如幻诸大变化。观身恶露九孔诸漏。观身盛然淫欲火炽。观身燋烧兴恚毒火。观身愚冥痴蒙毒盛。观身罗网恩爱结缚。观身如疮众患缠绕。观身可患四百四病。观身秽宅受诸虫种。观身无常逝归尘土。观身顽愚不达体法。观身危陋毁落不久。观身无赖常怀多忧。观身无坚老至苦极。观身无倚饰伪纯诈。观身难满受盛无厌。观身巢屈受众色爱。观身贪惑迷着五乐。观身昧冥意怀喜悦。观身无住生死种异。观身识念怀想众贱。观身无友极养会离。观身众食狐吞狼争。观身机关展转无数。观身系属饮食所盛。观身叵视脓血臭满。观身毁灭趣非常法。观身如仇恒多怨害。观身热恼常怀忧结。观身聚殃五阴所误。观身苦器生死剧痛。观身非我众缘积聚。观身无命男女会散。观身为空根受诸情。观身无实譬之如幻。观身虚伪其现若梦。观身伪惑为如野马。观身诈欺其喻响像。是谓长者菩萨大士四十二事观身行法。其不观者或贪身。心神意识由之起灭。其有菩萨如是观已。爱着身命贪爱吾我。疑垢倒谬及诸欲乐。有常之计皆悉除尽。遵志守一不惜年寿。如是速具六度无极。斯谓长者菩萨大士。以满六德权化流布。疾得无上成最正觉。于是世尊。重加弘演说身行法。而叹颂曰

  得为人甚难值　　无以身造恶行
  要会死弃丘冢　　狐狼食或烂坏
  伪欺我愚常惑　　专兴念贪色欲
  是身求无反复　　昼夜受诸苦痛
  因众苦以成恼　　身痈满盛不净
  常困极于饥渴　　夫智者岂贪命
  常受身终无厌　　强畜养剧亲厚
  为见色犯众罪　　彼缘是受狱痛
  身不能如金刚　　无以是造恶业
  虽久存会归死　　时兴信念佛世
  假长久养育身　　甘肴膳及香华
  会饥渴不恒常　　虽勉励当何益
  更劫数因还值　　人雄尊佛之世
  常发信莫犯罪　　或堕三受苦毒
  其极寿亿千载　　勤自勉如救火
  况其寿百岁者　　憍纵身造狱殃
  若有念想吾我　　得人身甚为难
  常极意恣五乐　　且自娱焉知后
  斯之乐不永久　　诸苦毒至不远
  当速离诸悭贪　　可得应大福祚
  财非财譬如梦　　强以此伪众生
  时一有或便尽　　明智者不吝财
  若如幻化色惑　　现虚伪花鲜彩
  是欲财谁欺身　　愚浊惑堕颠倒
  以众苦致福财　　用身故念与想
  财非财五家事　　有何智为财惑
  谬顺随妻与子　　王势强夺聚财
  觉无常了如此　　终无意乐利家
  恩爱聚致苦恼　　无贪惑着家狱
  父母财身妻子　　皆留在行自当
  有贪惜不自觉　　唯恐财随我灭
  愚顽者力求财　　有智虑信无贪
  悭不信不可从　　极自卑如儿仆
  外燋贪内热谄　　诸圣贤所不咏
  谈书籍或诗颂　　以惑众若淫女
  意粗犷性暴弊　　诸悭人多妒嫉
  贪狼性无亲友　　现卑谦强亲人
  唯为财习追苦　　智虑者莫信之
  顺财故与此事　　乃造起毒害心
  是故智当省察　　弃离悭妒邪事
  金珠宝诸珍奇　　因福祚得致之
  为斯故兴诤讼　　制是意整以法
  时可值人雄尊　　慈氏佛上如来
  乃当有金宝地　　焉知复在向生
  欲五乐纯虚伪　　愚迷惑欺诈意
  欲若如夏盛热　　坐野马因疲劳
  贪目色欲惑己　　淫发醉失意志
  从习欲随颠倒　　当何时值佛世
  从九十一劫中　　世乃有佛尊觉
  山须弥烧坏灭　　后何缘当得值
  海陂池枯竭干　　天地燋永无余
  欲炽然亦如是　　有何智当着欲
  诸聪达明智士　　当察知居寂灭
  有何贪奚可乐　　解是义不入网
  观行习法之最　　莫恋尸冢囚狱
  着恩爱贪浊意　　不能免狱苦殃
  有妻子贪离别　　所作行当自受
  便独趣随苦毒　　彼无有代痛者
  斯三界恼之甚　　莫若如妻与子
  本爱时规与乐　　反成忧罪恼根
  缘受三恶道苦　　毒辛酸惨痛生
  若当被诸恼根　　妻及子无伐者
  勿以父造恶行　　及与母诸亲属
  阿鼻痛无免救　　且莫如身行者
  阎罗王狱卒地　　彼不问父母事
  兄弟妻子亲友　　惟结却身善恶
  以得致身人身　　遭遇值不念恶
  断灭众殃罪行　　除改前不善事
  已浊污自防覆　　莫信作无报应
  彼法王当散说　　分别了行清净
  身种作行自当　　纵放意随堕恼
  身所造即获殃　　譬喻之影随形
  当其受苦痛时　　父母亲不能免
  及善厚无代者　　是故智无恋欲
  其欲脱狱楚毒　　及众缚枷锁械
  当勤念舍离欲　　速行法世雄教
  家大炽多恼根　　火之起而常然
  何慧达而乐是　　揩大火恐难中
  在家者忧利时　　居俗业营妻子
  有是众万端虑　　何智慧不舍家
  十力教甚可乐　　无种栽取若根
  騃痴子无是志　　但惑家堕地狱
  天地间专惑者　　兴念想我妻子
  愚顽意谓常存　　不知之幻化身

当佛世尊说是法时。威施之等五百长者。应时逮得柔顺法忍。从得忍已神通备具达知去来。圣智弘妙慧无挂碍。明晓众生意志所趣欲。发起众一切会者观心之故。即说偈曰

  快哉为大利　　众利之最上
  其有发心行　　求佛菩萨者
  大乘心可乐　　但欲安众生
  为人修桥梁　　志乐大乘者
  众生爱乐彼　　颜像众欣睹
  其有兴发心　　志求菩萨道
  诸发菩提心　　种德于福田
  深乐菩萨者　　得为三界明
  隆圣菩萨心　　踰越诸众意
  一切悉备足　　能度诸众生
  吾等快得利　　爱乐兴斯心
  值佛能仁世　　师子最正觉
  得逮闻是法　　菩萨观身法
  志即乐大乘　　获致于柔顺

时佛便笑。世尊笑时。五色光出从口中。奋辉晖晃昱色色各异。遂至无数光明普遍十方诸土。威景覆蔽一切释梵日月天魔宫殿之明。当其佛笑及覆光时。诸天龙神并世人民七万二千。见佛神耀暐晔之变。亦皆自觉被如来明安育其体。各于座上忽然悉得无所从生法乐之忍。其余无数皆发无上正真道意。然其焰还绕身三匝。而其威光忽从顶入。尔时贤者阿难。白佛。诸佛如来出现于世。安度众生道教洋洋终不妄笑。今者何因兴发威颜而欣笑耶。善哉世尊如来降德。愍念一切无量诸天及世人民。皆使得安畜生禽兽蜎飞蠕动莫不蒙度。愿佛开解敷演笑意。尔时世尊告阿难曰。汝见长者威施之等五百人不。唯然已见。世尊告曰。是诸长者。在过去诸佛植众德本。从发无上正真道意。如是阿难。长者威施五百人等。却后当更七十六劫不堕三苦。然后成佛当同一劫。劫名勇猛皆同一字。其号名曰华吉藏王如来无所著平等正觉道法御天人师。为佛世尊。各各所度极至无量。是时阿难重白佛言。唯然世尊。甚深妙哉未曾有也。如来散说是之弘奥无极要法。是经名何云何奉持。佛言阿难。是经名曰菩萨修行。亦名大士威施所问观身行经。又斯阿难。是观要法。过去当来今现在诸佛。致道弘化无不由之。吾今成佛。有身相好化于生死。亦因此法当善书持讽诵读说开示一切。佛说经已。贤者阿难大士。威施五百人等。诸天龙神及世人民。闻经欢喜。皆起叉手。为佛作礼

佛说菩萨修行经


佛说普门品经a

    No. 315 [No. 310(10)]

佛说普门品经

        西晋月氏国三藏竺法护译

闻如是。一时佛游王舍城灵鹫山中。与大比丘众俱。比丘八百。菩萨四万二千。得诸总持。神通已达。圣智弘畅。辩才无碍。三昧已定。无所不博。时有菩萨名离垢藏。与九万二千菩萨。从普华如来国来。其世界名曰净行。今游在此。欲诣忍界灵鹫山有所咨受。时佛遥见即笑。口中光焰乃有殊特。异色光明普照十方。内外明彻无不通达。尔时大士溥首僮真菩萨。即于大众会中。起整衣服。偏袒右肩。长跪叉手白佛言。世尊。何笑耶。笑乃有咨泽。非世所明。非菩萨大士之所能堪。怜愇乃如此。唯所尊笑当有意。愿示不及咸亦乐闻。于是世尊。告溥首菩萨。乃东方去此无量无数不可计会阿僧祇百千垓数。有世界名净行。其佛号普华如来。常与无数亿亿百千菩萨摩诃萨围绕。共讲不退转不思议之法。有尊菩萨。名离垢藏。与无数千诸菩萨大士眷属围绕。幡飞游步虚空。佛心念斯离垢藏。简别由路远步诸国。宣普华如来至真等正觉命来。受普门品。今寻当还会诣菩萨众。于时大圣。即如其像。显扬其教。示现咸应。令无数无限世界诸菩萨众寻时悉来。至斯忍土。往于大梵天。是故我笑耳。言适竟。彼离垢藏菩萨与诸大众。忽然以别。到此灵鹫山。眷属围绕行到佛所。稽首足下。却住一面。此灵鹫山中诸菩萨众。闲居燕者悉来集会。礼毕竟却就坐。时离垢藏菩萨。应时化作七宝莲花。其叶有千。持诣能仁如来至真等正觉。稽首奉上白曰。普华如来至真等正觉。净行世界圣尊敬问。无量游步康强势力轻利。起居安隐。多所救济。今见遣来。宣敬诲启。受普门品等不可思议清净之品。为开士说。时离垢藏菩萨大士。问讯周毕。退在虚空结加趺坐。与诸开士。坐宝莲花上。尔时溥首僮真。便于大众会中。起更整衣服。偏袒右肩前长跪叉手。而白佛言。善哉世尊。愿说普门品不可思议道品法。原为菩萨分别演之。忆念往古过久远世时。从普证明如来至真等正觉。闻斯经典。兴立八十四万百千亿垓三昧。又还七十七亿百千诸垓总持门行。唯愿世尊。愍诸菩萨重宣扬之。佛告溥首僮真。谛听善思念之。吾当为汝具说普门内藏不可思议秘宝中心之事。于是溥首菩萨并其大众。咸共答曰。唯世尊。愿乐欲闻。尔时溥首僮真与诸菩萨。一心受教而听。佛告溥首。若有菩萨摩诃萨。欲学普门品所入之法。等游于色。等游音声。等游臭香。等游众味。等游细滑。等游心界。等游女人。等游男子。等游僮女。等游童子。等游诸天。等游诸龙。等游诸鬼神。等游揵沓和。等游阿须伦。等游迦楼罗。等游真陀罗。等游摩睺勒。等游地狱。等游饿鬼。等游畜生。等游贪淫。等游嗔恚。等游愚痴。等游诸善。等游众德本。等游诸有为。等游诸无为。如是溥首。诸开士所可周旋为若此。一切悉等。以居平等。具足至道不转。普入法要。深微一密。空无寂静。是为学入普门定门之法

佛告溥首僮真。何谓菩萨等游于色者。晓了解色如水之沫。而不可得。不可护持。无有坚固。则为等意观无有色。是谓菩萨等游于色。又告溥首。何谓菩萨等游音声。如人呼声而有向应。寻即消灭则无形像。不知所至。一切无有若干之事。而无差特亦无有相。已了无相。人所言者虚无无实。已晓诸音深山向报。则能等观。是为菩萨等游音声也。又告溥首。何谓菩萨等游臭香。周旋往返百亿劫数。鼻之所嗅而无有厌。众香来趣剧于风雨。皆集归身如大海渊无有充满。其香之像无常百变。变化如幻无有根原。或乱道德而不可拥。如此则为虚伪法也。无有真谛。设求审试。亦无合会处。由是伦之。斯无所有而不可持。虚无无实恍惚若空。如幻如化亦无本形。影想识着缘起成形。若能分别虚无无实。是为菩萨等观则游于臭香。又告溥首。何谓菩萨等游众味。至于喉咽不知碱味。亦无不味。从因缘分别。但舌之所甘耳。由缘合会百千种味。斯为幻化。地之所生滋同一味。无若干也。晓了觉知。无想不念一切同甘。是为菩萨等观游于众味

又告溥首。何谓菩萨等游细滑者。志有所存缘起求之。身服华蒻加荣好色。珍宝异奇。其柔软者。而不可得。已都斯缘。细滑[革*卬][革*亢]无所适住亦无所著。计于细滑无益已。世之欲愚恶所贪。立生死本皆由斯起。明智大士。则知其衅不与从事。永世无患。一切所有地之所载。有形之属一等无二也。但闻色所造。横作人民。使作种种异色。已被服之。迷乱道德不亲贤众。达者觉知不与从事也。隐居被褐怀智作愚。外若夷人内怀明珠。千亿万劫与道同躯。远离吾我亦无我想。细滑与我二者同。无虚无实如幻如化。亦无所依。亦无住处。因着被服乃有所猗。达士睹之觉无所有。是为菩萨等观游于细滑。又告溥首。何谓菩萨等游心法。心法者三界人之护也。安慰劝乐悉令集会。安之以德劝之以权。受之以慧。普修梵行于三界澹然。立在一处亦无合离。使永执心莫知所存。不见形像音声往来。亦无犹豫。所应如心众无合散。不知住处。亦无所适。若现若干种色。色色各异。于内亦无处。处亦无有住。如幻如化。虚无处无处无所处。达士睹之了无所有。便自执心无念无求。见若不见。闻若不闻。澹然自守。是为菩萨等观游于心法。又告溥首。何谓菩萨等游于意。意游女人。察于四大则无女人。志痴惑者。悉于爱欲荒于虚无。其体一等无可毁者。计有女者犹如幻士化作人像低昂鞊曲随人意起。因彼所行从其所乐。女人如幻起色欲意。彼无有女也。人同一等。痴者所惑。意者从欲。欲便致爱。爱致乐此不可犹放。急宜调之羁靽。明者达之分别如空。空无寂静而无有形。缘起因对无对无起也。若能分别如斯者。是为菩萨等观游于女人意法。又告溥首。何谓菩萨等游净法也。净为如男子。如令男子等自发意。其心如金刚。专意独雄猛兴。念斯女人。欲心为无色。其实不可获。亦不现女像等。惟诸色欲发起女人想。设欲所思想。斯男斯女人等如野马水中月。如是观者则无男女。了无男形女人俱然。虚伪而立如无久存。但化幻示现慌现便灭。以能分别觉知男意女意。此两者空无所有也。已能平等则能现女。复化成男。是为菩萨等观游于男子净法

又告溥首。何谓菩萨等游僮女也。如拔树根萌终不复生。心不复起从是则止。其明智者不于求果。果亦不可得。若有种姓之家詪詪之子。聪达别议晓发一切勇猛想无念。如枯树不生花实。如枯竭江河水不流。斯等于僮女女子。如此所现平等。如空无无实。观彼女人本亦清净。观彼男子本亦清净。观彼泥洹本亦清净。如是等者则为等观游于僮女

又告溥首。何谓菩萨等游僮男。若如树木。设无有萌牙则无根茎。设无有根茎则无华实。设无华实则无果名字也。女人如是。设无女人则无男子。等于男女则无吾我。缘号立字想于无知。觉女无生不有子性。解一切人无。无则为等则平等。是为等观菩萨如是游于僮男

又告溥首。何谓菩萨游于诸天。诸天严净功德自然。其意鲜洁心净口净无有瑕秽。宫殿绮饰无造立者。心树妙华亦无种者。福德自然若如幻化。生无思议净光琉璃。械度净了。亦无尸爽。虚无成立天为伪体。自然生形恍惚而现。胜说平等现诸天像。是为虚无。无借外之喻。案内观历三十二天宫殿楼阁自然之数。无有见者。唯得道人乃知之耳。是以菩萨深观内外平等无异。是为菩萨等游诸天

又告溥首。何谓菩萨等游诸龙也。见无水兴云。七日雨所露润。无不澹浴。不在外内。遍阎浮利渐归大海。所满水所由来。众生如是学。若干缘缘此多。求起灭致忧。现无数罪种种不同。案内观历嗔怒何从。龙反鲛惊。人人皆然。崩天破地。皆从龙兴。内龙不反外龙不从。福无自然众生无有。愚冥之子以虚为实。菩萨大士睹龙平等。内外相应慈同一等。是为菩萨等游于龙

又告溥首。何谓菩萨等游鬼神。心如门开。与色有像。其身高大。为不可及。诸念一会百千之众。亦无形像音响为应。譬如饮毒自害其已。其心一类无可畏者。皆由放恣游盗自纵。因难所禁会有恐惧。此法无有实也。众想并来归。其想不可议。无实为空说。案内观历。鬼神从何兴也。其内鬼神若干百千之众。其外亦然。内不发恐惧外则无畏。其内不悲哀外则不泪出。内发鬼神之想。外有若干百千鬼神之众。皆来归之缘此致病。或至死亡受无数苦。皆由邪心不正故也。菩萨大士。觉知虚无无鬼神一切从心意起。则能平等心净意寂平等不邪。是以无有娆害菩萨者。若现鬼像种种变化。内自观察了无鬼神。外者寻灭此之谓也。是为菩萨等游鬼神

又告溥首。何谓菩萨等游揵沓和。其法无性而音说。往晓无往来亦无还返。如空无形随声如立。若有菩萨大士。内观察之。若无想识则无揵沓和。揵沓和者鬼神之导首也。内不起想外无邪念。何缘致此众病。要集揵沓和者。有名无形。音响往返无有见者。等说之要了无所有。揵沓和者虚无无实。菩萨等观斯由幻化。是为菩萨等游揵沓和

又告溥首。何谓菩萨等游阿须伦。以事有证因。阿须伦心。等无起无灭无生无尽。而现平等一切嗔怒毒意。皆由阿伦。阿伦者龙神也。多嫉妒心而现平等。是为菩萨等观游于阿须伦为意法

又告溥首。何谓菩萨等游迦楼罗。告受立辞名号。设无名色。名色由舌。从舌致祸立罪根本。菩萨大士学深智远。觉之为空无。如斯幻化从意生形。无有见者。音声往返因羸弱耶。心不政者。如是变化亿百千众。案内观历。二者俱空无所有也。菩萨等观无迦楼罗。是为菩萨等观游于迦楼罗

又告溥首。何谓菩萨等游真陀罗也。法无作而作。无作不作。亦能有所立。复能有坏。飞行于虚空无有及者。立号真陀罗。一切皆由手。手执诸作事。意生手则动。动则犯大乘。是使有狱苦。皆由真陀罗。若菩萨分别无所生众离于作事。手自不动摇。何因有真陀罗也。案内观历。不动则不摇。不起则不灭。不生则不死。内动则外发。意走手则作事。事便堕苦。堕苦则有病。病者皆有鬼神。鬼神者则真陀罗也。菩萨大士晓了于空。空而复空。无空无实。等观真陀罗。一切皆由化。无有正法形。平等诸作事。则无真陀罗。是为菩萨等观游于真陀罗

又告溥首。何谓菩萨等游摩睺勒。其法所名。立若干人种种受形莫不由之。人之本类随其种数。现若干法。一切立形其名故。法无所有。职号如是。在形为胸臆。离形为摩睺勒。所想为虚无。道成于胸臆。胸臆执大禄。心正得成道。分别诸想识。诸念亦俱止。无想致自然。但说平等音。一切为断决疑故现摩睺勒。是为菩萨深入等观。案内观历。内无所起外无所造。是则无摩睺勒之名字也。是为菩萨等观游于摩睺勒

又告溥首。何谓菩萨等游地狱也。法无无地狱。想识成形。地狱无主。求者自然。如呼声响应蝇投灯火。言然之数无可救者。所以者何。身口招之自然对至。空无造者。从己想与想无所有。空返往空返。厄难之缘自从己起。己自贤敕病无从入。身口无犯亦无死者。地狱清净鲜洁无垢。菩萨大士所以不畏生死者。无地狱之缘。所以者何。不犯禁故知觉如幻亦无所有。虽立诸相相无不着相。亦无不相。相无所有。幻化成象。其见相者无不喜悦。喜悦至慈因登大愿。别如虚空平等寂然。而现地狱诸苦恼患。案内观历。口致身怨。口为狱户但入不出。入便消尽出为泥土。如是勤苦当更亿数。是以菩萨闭口不语。不以咨口有所食啖。亦无言说澹而自守。不入众会不称为己。口无二言忍诸所作。菩萨如是则无地狱。地狱之缘但由口言出罪入无离此患。菩萨守口不择其味。慈同一等无有细软。食啖充躯支形而已。是为菩萨等观游于地狱。

又告溥首。何谓菩萨等游饿鬼也。饿鬼无形亦无有名。本无处所亦无所止。因悭而立。贪欲致之。悭亦无所住。不解所有。不知大法。计有吾我不睹无常。香闻亿万。老之甫甚。从悭致贪。从贪致欲。从欲致爱。从爱致乐。从乐致忧。从忧致苦。从苦致痛。从痛致结。从结致病。病致死处。在三难之中不得衣食。身裸饥乏不得水浆。立号为字名曰饿鬼。菩萨大士知悉本无。了无饿鬼寂静如空。所以者何。菩萨常行平等。掼鼻不嗅众香。一无所慕乐。悭从鼻入致斯大殃。鼻为心壹混沦之精。亦无所入亦无所出。不受香色则无所贪。设无所贪则无悭惜。是为菩萨等观饿鬼

又告溥首。何谓菩萨等游畜生。法无畜生从因缘起。如云雾像现若干色。色各不同见之悦喜。便致想生死起灭。恚从中起。起想念识十二连着。闭结不解招致畜生。彼则无根悉无所有。心思虚无皆由诸色。色则德根驰走五道。宛转生死受形无数。或为飞鸟或为走兽。空无常名因形立字。等如阴雾种种色像。畜生志性罪福如幻。迷惑虚妄而说畜形。菩萨大士计无吾我。了无名字。目初视色意不贪色。心不念色身不利色。菩萨以是四等心。亦观内色外色。飞行十方窈冥之处无不通达。皆从眼出入。眼者日月之精有二名。入色为金翅鸟。出色为文殊师利。案内观历。一切诸名皆从眼入。动生死根本横有所造。皆由金翅鸟故号畜生。畜生群萌之类。蠕动喘息[立*奇]行之属。一切变化皆号畜生。菩萨等观人身中。都计合之。亦为三千大千国土。国有百亿之数。如是不可一一计之。上有三十三天。下至金刚刹土。其中间有大泥犁十八之难。诸天人民所居处各有宫殿及非人鬼神龙飞鸟走兽。下及树木草茅。其有形之属皆在人身中。其数这停等。一物不等者。其人便其短。物物相应无差特者。其人便聪明有黠慧。若人盗贼。虎狼毒兽。若堕沟坑树木所拒。蛇犬所害。皆从发外。乃有应崩身碎体。当责现在之事。不可倚着前世宿仇。当自内外思惟。[號-虎+毛]来之生灭。自投盲冥地。内众生外众生。内形外形等等无异。人人皆如是。内起恶意。外寻来应。内有反臣外臣便反。害便人身。愚痴之人。不能自知。坐怨鬼神。一切由色。入眼之物。眼为心候。主名百凶。快心之欢必有后患一切由之。致斯畜生等说寂声。是为菩萨等游畜生

又告溥首。何谓菩萨等游贪淫也。法无贪淫。从因缘起。缘起致贪。贪爱欲欲从想起。所想无有想。如虚空空无处所。因欲致惑贼乱本性立忧患本。贪淫如空处不可得。随形如影。随声如响。无实无像。获不可得。愚类颠倒思想尘劳。法无尘垢空无寂静。欲虚如空无能救尽者。至于十方求不可见。贪淫无形愚冥所贪。贪欲自丧亡失人形。惧不安隐在藏匿处。与世悼别长不复会。若如走兽常怀畏懅。譬如丈夫向敌心怀怖惧走。弃舍驰走得无见我也。我者亦空。奔走疲极亦无追者唐自苦体。执劳如斯。居家恩爱是亦复空。然人慈慕用贪欲故。欲为系闭牢狱之忧。欲为猛志。存恤群生。无著淫泆。一切无患中恶之兆。普得安隐。一切皆空而无所有。空复遂空未之有也。彼无解脱。愚痴颠倒。反告想闇冥。不解法如虚空。无存无亡。去来今佛解诸贪欲。贪欲无脱结在众难。爱欲悉空。虚无无实。其讥贪淫则求脱欲。欲脱欲者不起二念。斯皆无本本无有本。本自然净无有沾污。如佛道场平等无想。睹淫泆者不离殃衅。从如寂者彼慕离欲。所想皆空乃离诸想。如所发念念无所念。侥脱贪淫谓当度欲想无所求。不怀本际。贪欲无思。本净如斯。则不想脱。假令度欲则谓为净。贪欲空无计此无二。愚冥不解便作二想。法无男女平等一体。天之为父地之为母。天地所生有何异者。菩萨等行则无男女之求。如幻如化本末如斯。睹男女别者是为离本。则失议句。发诸想念众网来然。贪欲无起不兴想念。则无众网不烧诸结。众网不解。解贪淫者假号爱欲无染着。诸名无碍。知欲无无得睹真究竟。不怀静修。等志内外无假见。贪欲者知不得脱。贪欲佛法等如泥洹。解贪欲除。等离吾我。知贪欲寂。等术澹泊。案内观历。诸欲从耳。耳与意通。转相承受。勇猛无能当者。一切无不降伏。有二名入。欲为师子王。出欲为维摩诘。于三界犹出。无所不入。无所不出。是以菩萨等于净秽。耳不受五音。为十方天上天下之导。造成大导不以劳惓。要闻法者当先食。十方内外三千大千国土。其中人物类数。日月虽明由不能照。人虽有眼目。不能见远远之事。耳处在闲居之地不睹光。目颜色之数而为第一。十方上下内外细微之事。先来归耳。耳者无所慕乐。是号无垢之称。等观诸法。以法为食。耳之先闻。闻法者为先食也。所以菩萨得不饥渴。但以无闻为食。无见为浆。少语言以为百味。平等欲净。欲如虚空。空无尘埃。如泥洹而澹泊。于诸见如幻化。是为菩萨平等观于诸法游于贪淫

又告溥首。何谓菩萨等游嗔恚也。法无嗔恚因缘。溥首。恚从对起无对不起。因倚生对。无我号我立无量事。如树木生。先从萌类结恨急毒。声自然空无想无念。如闲居树坐自想揩火然还烧其树。因缘虽散各归本生。火灭不现。虚无起身。鹿声亦然。因欲称量二者俱空。智者解之不兴恚怒。缘从声起。不处内身不从外来。不由空从他缘起。因对而立。各各分别。种种类数。引胜负者。菩萨等观则无嗔恚。如风种过。有恨有慢。若知方便因想立缘。秽声如是。恚因空生恚还自烧。无有代者。而色其身。放逸自可。由己恶言。坐自纵恣不能自禁。福尽祸至。如然灯生麻油以尽还烧其炷。无有救者。嗔恚如是。能分别嗔怒者。竟无形像。平等察声听。嗔怒恨本际。等无本无持。分别法界则睹平等。意由四惧揽竟第一嗔怒。嗔怒横有所造。意者空无。寻生便灭。而无究竟。恍惚之间意不可咨。咨之乱德。剬意无念则无贪淫。贪淫之欲皆从意起。无贪淫者嗔怒何从来。意动心起毒龙因作便致嗔怒口开罪入。如江河投海。如揵烧天地。无形不尽。案内观历。无可嗔恚者。所以者何。十方同共等无三涂。等意者无嗔恚。无嗔恚者无三毒。无三毒者何缘等有病也。其有病者当毁。三界众生从意生形。因嗔怒入此病。不自悔责。七十五日七十五夜。日日三自叹责。今在现世立形从意所作。犯三界人民。及非飞禽走兽射猎鱼网。或笼系飞鸟。伤剜身体或逝四支。至今蹇跘手足不任。加痛于彼而对欢喜。愚痴之人不知己还害己身。旬岁之中身被重病。如其所害。处所不掖。若起嗔恚毒意。一作意勇怫郁。或以刀兵。或持弓矢欲相挌射。或以镰斧欲斩人头首。举意如是斯为犯三界众生已。若有菩萨摩诃萨。身体病痛。小病大病一等无异。当知犯三界众生。随其痛处呼。三界众生名字。深自考责。投身散发堕泪。自忏悔三尊。三尊者内有六事。名曰六度无极治内病。外有三尊。亦有六事。名曰六度无极治外病。溥首复问。何等为三尊内六事也答曰。内三尊者。第一心尊。于内三界安慰众生。开示大明悉令安隐。名曰无上正真之信。亦号如来等正觉。第二耳尊。常居寂静之地而无缚饰。飞行周旋往返十方。天上天下窈冥之处悉到其中。无所不闻。无所不知。而无言说澹泊无为。惟往来周旋以情归心。一一告说初无异言。名无垢称。二名普持律。三名广开度。四名大忍辱。五名诸佛信。六名如来心。七名净复净。八名不动转。九名无所不乐。十名惟那离大城无所不容受。如是十德之行与如来同躯。第三眼尊。常居色欲之地不自贡高。将导一切非。飞行十方。内外明了无有见者。亦有十德之行。一名曰文殊师利。二名无所不入。三名净秽悉除。四名常清净。五名日月精。六名开导一切非。七名无能沾污者。八名将导十方人。九名诸漏已尽无有众秽。十名如来信将护一切。是为内三尊。常行大慈大悲忧念生死苦。当知三界中群萌之类而不可毁。毁者为毁三尊已。复有三尊。常当归命忏悔惭愧。何谓三尊。第一意净名波旬。第二欲净名师子王。第三色净名金翅鸟。又问曰。如是三尊为应何谓法也。答曰。意断者无嗔怒。众魔皆降伏。意为身神名曰波旬。晋言众想心随护为善者。师子王者耳神。耳不受众尘埃。于三界独忍一切诸想不与校会。故名曰师子王。晋言一切无畏。常为十方为导当作佛者。为作座席而不患厌。金翅鸟者眼神也。眼入众色色则断。飞行十方莫能知者。降伏诸魔。践踏众龙。龙神欲反兴嗔怒意。金翅鸟在海上影现水中。诸龙恐怖不敢出外。波旬兴龙欲有所受。眼阴以断。金翅鸟在上。常以百千种色惧如金光。不能等于明月之精。明月之精不能当金翅鸟之毛。是使金翅鸟。于三界独尊雄。其有为导当作佛者。我皆当在上以身金毛照之。使令身皆黄金色。一切相见之莫不欢喜。佛言。是三尊六人者。是内事六度无极。是以菩萨行六度。不坏色无常。亲痛痒。思想生死痛痒。思想生死识者。则无六度无极。若菩萨摩诃萨身躯不安隐者。当知与内六度无极违错不顺其教。当思上头所语滓自綶形。勿以自可用。刚强之性自言无罪。若不詪詪至心忏悔者。杀身不久。此事非良医所能治也。溥首复问佛言。何谓外三尊六事也。答曰。第一佛尊。第二法尊。第三比丘僧尊。是复有三尊。何等为三。第一净尊。第二色尊。第三欲尊。溥首复问曰。此三尊皆何应也。佛言。舍欲布施身得其福。是为施度无极。二曰。舍色持戒身得清净。是为戒度无极。三曰。舍诸尘劳行大忍辱而离众想得清净慧。是为忍度无极。四曰。知比丘僧清净舍诸因起灭因缘之事。而建精进得至道场住清净地。是为进度无极。五曰。知法清净舍诸邪念者。想之缘而定一心。身得安隐知去来今。是为禅度无极。六曰。知佛清净悉舍诸着。适无所住深入要法。空无想念泥洹之事一切本无。是为智度无极。佛言。是为外六度无极也。如是内外法十二事解者。便为开十二门。虽解由不制因对起想。游于恣意不能忍辱。放心口意嗔恚恶言。便为十二因缘。随俗三流不离五趣。菩萨大士等。于内外亦无所讥。一切无碍如水月形。平等察声无嗔怒音恨。本际等无本无际。分别法界则睹平等。是菩萨等游嗔恚为意法也

又告溥首。何谓菩萨等游愚痴也。愚从无起。察痴无有。设无所有愚痴本无。永无狂冥。人无弊愿。无碍如空。为虚澹泊。想碍求空。方面造愚。立虚为实而起忿恨。愚痴所行。求名达字。行清白名。欣欣难获。诸法无明。因想为尘想为碍。惭虚无形。譬如丈夫欲度虚空亦无羽翅。行不合道不入于空亿劫不得也。能会不能知空本末。愚痴亦如是。本际无思议。蔽冥不生。尘无所志而成满。如住于虚空不知方面处。亦无具足人。无能出度者。如百千亿劫垓习乐闇蔽者。彼亦无厌足。常饥无饱满。如僮子者。好色如吹胞。满中气短。解脱口中无所有。罪福如空胞。求胜真高亦然。卑忑清净亦然。习于愚者求不可得。空来空去怀抱罪欲。喜亦行恶亦不舍。见善不习专入倒见如是行者。谓愚无底也断根无根形。无根无住。故不可尽。设愚不可尽。痴亦不可得。犹如众生如幻如化。斯不可赐。设有造喻。三界众生类日度一切令得泥洹。佛寿住世亿劫难计。济脱梨度人不可尽。因遇立种人界无想。痴冥如幻是不可得。佛净与愚痴等观斯无二。设能等观则能念道。痴慧一等无诸蔽碍。众生群萌等无思议。痴不可计思念意迹。其心无无有边际。愚冥无限由不可得。空着无名。因倚有形。无有见者。永不可持。志性无明了无所有。何从致起而有嗔恚也。计无吾我。痴已不起闇冥何类。如痴无处佛道亦尔。了无崖底诸法无二。别声平等等察痴响。了云一等愚冥如云。分别平等则晓定意。是为菩萨等游愚痴

又告溥首。何谓菩萨等游不善。欲行无形。嗔行无处。不行痴行。知众平等诸尘亦等。诸生灭悉等。等解虚无空无所有。了净如是。是菩萨等游不善也

又告溥首。何谓菩萨等游诸善德本。众生修善心行若干。诸行一等无不等行。一行而行无碍现行。了行无二则能平等。以知平等众行如幻。色声一等则了语音。语音无二由如影响。往来周旋亦无处所。德本亦然如幻化。是为菩萨等游众善德本

又告溥首。何谓菩萨等游有为也。所有无有一切从念。念者空念。计不可量。无量难计。无边无际。所起为想。想从念缘。是之数亦不可尽。晓平等者了无央数。无行无像。解说等寂睹一切安。已安已荣不计无常。是等菩萨等游有为

又告溥首。何谓菩萨等游无为。本净法寂亦无合会。无明之形假声。等察音声无言无教皆了无为。众着言声等观如是。是为菩萨等游无为

又告溥首。何谓菩萨等游平等。处有为中不住有为。诸行平等如空无碍不住三界。三界本无何求泥洹。泥洹寂静不出不入。无言无说。乃至大安度脱众生。解无若干。法身如空不合不散。亦无往来亦无还返。如空寂寞。是为菩萨等游于平等。于是世尊。说斯章句。至未曾有。顺如应行不可思议世之希有。时有万二千菩萨皆得不起法忍。七十二亿百千天人皆发无上正真道意。二百六十万比丘漏尽意解。有六千比丘尼。皆发无上正真道意。有二千二百清信士。千八百清信女。亦皆发无上正真道意

尔时溥首僮真。复白世尊曰。唯愿大圣。演是三昧号。菩萨由斯而致至德诸根明了。闻三昧所因名号。则当获得一切法。明靡不通达。而悉降伏一切迷惑邪见之众。乐一文字。分别晓了一切诸文。以一切文而了一文。辩才之慧不可限量。为诸群生讲说经法。分别晓了缘应法忍。以一切行入于一相。逮得无量无限之议。晓了识议四分别辩。于是世尊。告溥首僮真。谛听善思念之。今当为仁分别本末溥首答曰。甚善愿乐欲闻。佛言。有三昧名离无量垢。假使菩萨逮得斯定。普见一切诸色清净。佛告溥首。有三昧名坏若干。假使菩萨逮得斯定。智慧光明覆蔽一切日月之明。有三昧名成具光明。假使菩萨逮得斯定。威曜覆蔽帝释梵王三界之宝。悉蒙安隐。诸天光曜忽不复现。有三昧名舍界。假使菩萨逮得斯定。处于众会蠲除一切淫怒痴病。有三昧名莫能当。假使菩萨逮得斯定。照明一切八方上下诸佛国土。有三昧名诸法无所生。假使菩萨逮得斯定。总揽诸佛经典训诲一切。为众会分别要义。敷演微妙无著之业。有三昧名无念雷音。假使菩萨逮得斯定。言语音声畅于梵天。十方所演无能过者。窈冥蔽碍无不闻者。有三昧名晓了一切应心所乐。假使菩萨逮得斯定。悦可众生随其所乐。而令脱拘碍解之缘。一切众会普得安隐。有三昧名无会现悦精进。假使菩萨逮得斯定。睹见无为无有限数终始之惑。所闻所见莫不通达。一切所入莫能过也。有三昧名无念宝德乐于世界。假使菩萨逮得斯定者。放诸神足施化众生。有三昧名诸音缘会。假使菩萨逮斯定者。觉诸言音以无数字了一文字。以一文字说无数字。以了内字外字。悲了于内不达外亦不了。内外相应无有异文。有三昧名积众善德。假使菩萨逮斯定者。分别罪福兴显平等。多所悦可一切众生。使闻佛音法音。众声闻音。缘觉音。菩萨音。度无极音。一切智音。彼有所说亦无音声。一切了知深要之业。有三昧名起诸总持为一切王。假使菩萨逮得斯定者。分别一切无量总持。众慧之要无碍之法悉令明了。有三昧名净诸辩才无为之行。假使菩萨逮斯定者。寂除一切音声言说。皆无言教亦无响应。无言无教亦无所有

于是溥首白世尊。唯然大圣。鄙身宁应讲斯典训之功德乎。告曰宜讲。溥首白佛。假使菩萨闻斯经典而不狐疑。发心受持而讽诵讲读。其人现在得妙辩才。聪明辩。欣豫辩。深妙辩。无合会常行慈心加诸众生。无毁复意。所以者何。设使忧念所作趣。奉行其行。知谛随身未曾舍离

尔时世尊。赞溥首曰。善哉善哉。快说此言。诚如之意。譬如布施获致大富而不虚假。持戒生天亦不虚假。令斯经典亦复如兹。学致辩才亦不虚假。悉得本志。犹如日光出照天下众冥悉除。斯经如是。讽诵学者。怀来辩才靡不通达。喻如菩萨坐于道场。于佛树下还得无上真正之道成最正觉。菩萨如是。学诵斯经必得辩才除诸狐疑。是故溥首。假使菩萨现欲兴辩晓练诸法。闻斯经典心不犹豫。即当受持讲说讽诵为诸众会广演其义

尔时是离垢藏菩萨。前白佛言。灭度后。其有受持讽诵讲说斯经法者。为众会敷演其义。鄙亲当为宣解所归使不狐疑。疾得辩才。于时弊魔愁毒垂泪。来诣佛所。白世尊曰。唯无建立于斯经。如来至真等正觉。常怀大哀。其有苦患施以大安。幸哉大圣。愿除吾惑。如昔世尊初坐树下处于道场。演此典法。今复重加说斯经典。我今忧郁心怀懊恼。其于如来始得佛道所救济时。我之反侧不能自胜。一切皆当得不退转逮无上正真之道。成最正觉。其有黎庶耳闻斯经。听音服名。悉当得道至于灭度。空我境界虚魔宫殿。大圣抚育兴建大悲唯见矜济。佛告魔曰。波旬莫恐勿怖勿懅。一切众生不悉灭度。如来亦不建立斯经。魔闻佛教踊跃欢喜。善心生矣忽然不现。溥首白佛。何故为魔而说斯教。佛告溥首。斯经典者住无所住。是故为魔而说斯言。吾不建立斯经典也。至诚不虚。一切诸法住无所住。不可逮得无有言教。离于二事本际平等。当谛无本。法界如称平若虚空。无适无莫真正无异。今经流布斯阎浮提。于天下当有瑞应。世尊适建诚谛之教。自然空中音普广闻。诚如佛言至诚不虚。佛告阿难。受斯普门品经之要。持讽诵读宣示同学。又言阿难。是经八万四千法品之藏。计比斯典等无差特。所以者何。此经一句普入无量之慧门法界诸要。唯如来分别晓了。众生解斯经典而成佛道然后讲说八万四千诸经品藏。是故阿难。当受斯经消息。将慎谛持讽诵为众人。说此已。离垢藏菩萨。溥首僮真。贤者阿难诸天世人。揵沓和阿须伦。闻经欢喜稽首作礼而退

佛说普门品


佛说普门品经b

佛说普门品经

        西晋竺法护译

闻如是。一时佛游王舍城灵鹫山。与大比丘众比丘八百菩萨四万二千。得诸总持神通已达。圣智弘畅辩才无碍。三昧已定无所不博。时有菩萨名离垢藏。与九万二千菩萨。从普华如来国。其世界名净行。游诣忍界灵鹫山。世尊遥见离垢藏菩萨与无数千大士眷属围绕游步虚空。佛心念曰。斯离垢藏。间别由路远步诸国。宣普华如来至真等正觉命来。受普门品。今当聚会诸菩萨众。于时大圣即如其像。显扬言教示现感应。令无央数无限世界诸菩萨众寻时悉来。至斯忍土诣灵鹫山。行到佛所稽首足下却住一面。灵鹫山中诸菩萨众。闲居宴者悉来集会。礼毕却坐。离垢藏菩萨。应时化作七宝莲华。其叶有千。持诣能仁如来至真等正觉。稽首奉上。启曰。普华如来至真等正觉。净行世界圣尊。敬问无量游步康强。力势轻履。起居安隐。多所救济。今见遣来宣承敬诣。启受普门不可思议清净之品。为开士说。时离垢藏菩萨大士问讯。问讯毕退在虚空结跏趺坐。与诸开士坐宝莲华。尔时溥首童真于会中起。更整衣服偏袒右肩。长跪叉手而白佛言。善哉世尊。愿说普门不可思议道品法源。为诸菩萨分别演之。忆念往古过去久远世时。从普门如来至真等正觉。闻斯经典。兴立八十四万百千亿垓三昧。久逮七十七亿百千诸垓总持门行。唯愿世尊。愍诸菩萨重宣扬之。佛告溥首童真。谛听善思念之。答曰。唯然世尊。愿乐欲闻。溥首与诸菩萨受教而听。佛告溥首。若有菩萨。欲学普门所入之法等意分别。游入于色等意分别。游入音声等意分别。游入臭香等意分别。游入众味等意分别。游入细滑等意分别。游入心性等意分别。游入女人等意分别。游入男子等意分别。游入童女等意分别。游入童子等意分别。游入诸天等意分别。游入诸龙等意分别。游入鬼神等意分别。游揵沓和等意分别。游阿须伦等意分别。游迦楼罗等意分别。游真陀罗等意分别。游摩休勒等意分别。游入地狱等意分别。游入饿鬼等意分别。游入畜生等意分别。游入贪淫等意分别。游入嗔怒等意分别。游入愚痴等意分别。游诸不善等意分别。游诸德本等意分别。游诸有为等意分别。游诸无为等意分别。溥首。诸开士所可周游。一切悉备。游居平等具足至道。是为学入普门定法。佛告溥首童真。何谓菩萨等意分别游入于色。晓了解色。如水之沫而不可得。不可护持无有坚固。则为等意观无有色。是谓菩萨等游于色。又告溥首。何谓菩萨等意分别游入音声。如人呼声而有响应寻即消灭。则无形像不知所生。一切无有若干之事。而无差特亦无有相。已了无相。人所言者虚无无实。已晓诸音。深山响报。则乃等观。是为等观游入诸音声。又告溥首。何谓菩萨等意分别游入臭香。周游往返百亿劫数。鼻之所嗅而无有厌。如大海渊无有充满。其香之像而不可获。为虚伪法无有真谛。设求审诚无合会处。斯无所有而不可持。鼻处无实。慌惚若空如幻士化。假使分明。则无等观游入嗅香。又告溥首。何谓菩萨等意分别游入众味。至于喉咽不知碱味。亦无不味。从因缘别。其舌所甘犹缘会合。晓觉无念则为等观游入众味。又告溥首。何谓菩萨等意分别游入细滑。其细滑者。志有所存缘求服之。其柔软者而不可得。已睹斯缘细滑[革*卬][革*亢]无所适住。计于细滑则无有成。亦无所有所依。因着被服乃有所倚。斯为等观游入细滑。又告溥首。何谓菩萨等意分别游入心法。假三界人悉令集会立在一处使求执心。莫知所在不见形像。亦无犹豫。亦无合散不知所住。现若干色。于内无处处无所住。如幻士化虚而不实。则为等观游入心法。又告溥首。何谓菩萨等意分别游入女人。察于四大则无女人。识痴惑者迷于爱欲。荒于虚无。计女人者犹如幻士化现女像。因彼所行。从其所乐。女人如幻起色欲意。彼无有女痴者惑之。能别如斯诸女无相。解脱平等。而现女色。则为等观游入女人。又告溥首。何谓菩萨等意分别游入男子。如令男子等自发意吾为雄夫。兴念斯为女人。欲心无色无实可获。不见女像。等惟诸色发起女想。设所思想。斯男斯女。等如野马水月则无男女。了男无形虚伪而立。已能平等则能现女。则为等观游入男子。又告溥首。何谓菩萨等意分别游入童男。若如树木。设无有芽则无根茎。设无根茎则无华实。设无女人则无童子。缘号童子想于无知。觉女无生不有子性。解一切无。则为等观游入童子。又告溥首。何谓菩萨等意分别游入童女。如彼拔树根终不生。其明智者不于求果。丑达别谊。晓发一切勇猛无想。枯竭众流斯为童女。了女如此。所现平等。则为等观游入童女。又告溥首。何谓菩萨等意分别游入诸天。诸天严净功德自然。其意鲜洁宫殿绮饰无造立者。心树妙华无下种者。福苶幻化。生无思议净光流离灭度净。了天虚伪成立慌惚。胜说平等现诸天像。是为菩萨游入诸天。又告溥首。何为菩萨等意分别游入诸龙。见无求生。兴云七日。雨所沾润不在内外。遍阎浮提渐归大海。所满水所由来。众生如是学若干缘现种种罪福。自然众生无所有。愚冥之人以虚为实。睹龙平等。是为菩萨等游诸龙。又告溥首。何谓菩萨等意分别游入鬼神。心如门开。与色有像。其身高大。心为一类。心不可畏难。因会有恐惧。见法无有实。众想不可议。无实为空。说平等寂而现鬼像是为菩萨等游鬼神。又告溥首。何谓菩萨等意分别游入揵沓和。其法无往而音说往。晓无往来等说揵沓和。是为菩萨等观游入揵沓和。又告溥首。何谓菩萨等意分别游入阿须伦。不以事因。阿须伦心。等无起无灭无生而现平等。是为菩萨等观游入于阿须伦。又告溥首。何谓菩萨等意分别游入迦留罗。造受无受。立辞名号。设无名色等。观迦留罗。是为菩萨游入迦留罗。又告溥首。何谓菩萨等意分别游入真陀罗。法无作而作。则立真陀罗。分别无所生。平等真陀罗。是为菩萨等观游入于真陀罗。又告溥首。何谓菩萨等意分别游入摩休勒。其法所名。立若干人法。无有所相。为虚分别。诸想无想。自然说平等音现摩休勒。是为菩萨等观游入于摩休勒。又告溥首。何谓菩萨等意分别游入地狱。地狱无主空无造者从己想。想无兴所有地狱清净鲜洁无垢。智觉如幻。本无所有无相。无相无所有。别如虚空。平等寂然而现地狱。是为菩萨等游地狱。又告溥首。何谓菩萨等意分别游入饿鬼。饿鬼无形无名本无处所。因悭致之悭无所住。不解所有计吾我人。知悉无本了无饿鬼。是为菩萨等游饿鬼。又告溥首。何谓菩萨等意分别游入畜生。如云雾像现若干色。彼则无貌悉无所有。心思虚无等如阴雾。种种色像。畜生志性。罪福如幻迷惑虚妄。而说畜形等说寂声。是为菩萨等游畜生。又告溥首。何谓菩萨等意分别游入贪淫。欲从想起。所想无有无实无像无貌无住。处不可得。贪淫如空。愚痴颠倒思想尘劳。法无尘垢。欲虚如空。至于十方求不可见。贪淫无形。愚冥贪惧不得安隐无难怀惧。譬如丈夫无获怀惧怖舍驰走。得无见空一切皆空。彼无解脱愚痴颠倒反造逆想。闇冥不解法如虚空。去来今佛解诸贪欲。贪欲无脱。爱想悉空。其讥贪淫则求脱欲。斯皆无本本自然净。见佛道场平等无想。睹众如者彼慕离欲。所想虚危乃离诸想。如所发念侥脱贪淫。谓当度欲。想无所求不坏本际。贪欲无思本净如斯。则不想脱。假令度欲则谓为净。贪欲空无。计此无二。愚冥相二。行者深观如幻是则失句。发诸想念。贪欲无起。假号爱欲。无染著名。诸名无碍知欲无得。睹真究空不怀贪欲。不知见脱。贪欲佛法等如泥洹。解贪欲阴等离吾我。知贪欲寂等御憺怕。平等欲阴见如幻化。是为菩萨等游贪淫。又告溥首。何谓菩萨等意分别游入嗔恚。恚从对起。因缘生对。无我号我立无量事。如树木生。结恨急毒。声自然空无想无有。如闲居树。相揩火然。因缘离散火灭不现。虚无起身。粗声亦尔。因欲称量。则不兴恚。不从声起。不虚内身。亦不外来。所由因空。从他缘起。因对而立各各分别。则无嗔恚。如风种过。有恨为慢。若知方便。因想立缘。秽声如是。恚因空生。恚还自烧而危其身。别嗔怒想竟无形像。平等察声听嗔怒音。恨本际等无本无持。分别法界则睹平等。是为菩萨等游嗔怒。又告溥首。何谓菩萨等意分别游入愚痴。愚从无起。察痴无有。设无所有。狂无狂冥。人无蔽愿无碍。求空方面。造愚为虚。愚痴人所行最行难获。诸法无明因想为尘。譬如丈夫欲度虚空亿劫不得。知空本末。愚亦如是。本际无愚议。蔽冥不生尘。无所成满。如度虚空不知方面。亦无具足无能步度。如百千劫。习乐闇蔽。彼无厌足不以饱满。譬如童子吹气满胞。旋解口察无所有。罪福如空胞。而习于愚。求不可得。怀来欲谓愚无底。断根无形无根无住。故不可尽。设愚难尽斯不可得。犹是众生。如幻不赐。设有造喻。三界生类。日度一切令得泥洹。佛寿住世亿劫难计。济脱黎庶。人不可尽。因愚立种。人界无想。痴冥如幻是不可得。佛与愚等。观斯无二。设能等观则能念道。痴慧一等无诸蔽碍。众生群萌等无愚议。痴不可计。思念意迹。其心无念无有边际。愚冥无限。由是叵得志性无明何从有起。痴已不起闇冥何类。如痴无处佛道亦尔。了无涯底诸法无二。别声平等等察痴响。了空一等愚冥如云。分别平等则晓定意。是为菩萨等游愚痴。又告溥首。何谓菩萨等意分别游入不善。欲行无形。嗔行无处。不行痴行。知众平等诸尘悉平。得解虚无所有了净。如是是为菩萨等意游入于诸不善。又告溥首。何谓菩萨等意游入诸善德本。众生修善心行若干。诸行一行常了平等。已知平等众行如幻。别声一等则了语音。是为菩萨等游众德。又告溥首。何谓菩萨等意分别游入有为。所有无有计不可量。无量难计。常晓平等了无央数。无行无像。解脱等寂睹一切安。是为菩萨等游有为。又告溥首。何谓菩萨等意分别游入无为。本净法寂。亦无合会无明假声。等察音声无言无教皆了无为。众着言声。等观如是。是为菩萨等游无为。又告溥首。何谓菩萨等意分别游于平等。不处有为不住无为。诸行平等如空无碍。三界无本何求泥洹。不出不入乃至大安。度脱众生。解不若干。法身如空不合不散。是为菩萨等游平等。世尊说斯章句之颂。顺如应时不可思议。九万九千菩萨。得不起法忍。七十二亿百千天人。皆发无上正真道意。三百六十万比丘。漏尽意解。六千比丘尼。皆发无上正真道意。二千二百清信士。千八百清信女。皆发无上正真道意。尔时溥首童真。白世尊曰。唯愿大圣。演三昧号。菩萨由斯而致至德诸根明了。闻是三昧所因名号。则当获得一切法。明靡不通达。而悉降伏一切迷惑邪见之众。乐一文字。分别晓了一切诸文。以一切文而了一文。辩才之慧不可限量。为诸群生讲说经法。分别晓了缘应法忍。以一切行入于一相。逮无量无限之义。晓了识义四分别辩。于是世尊。告溥首童真。谛听善思念之。今当为仁分别本末。答曰。甚善愿乐欲闻。佛言。有三昧名离无量垢。假使菩萨逮得斯定。普见一切诸色清净。佛告溥首。有三昧名怀若干。假使菩萨逮得斯定。智慧光明。覆蔽一切日月之明。有三昧名成具光明。假使菩萨逮得斯定。威耀覆蔽帝释梵王。三界之冥悉蒙安隐。诸天光耀忽不复现。有三昧名舍界。假使菩萨逮得斯定。处于众会蠲除一切淫怒痴病。有三昧名莫能当。假使菩萨逮得斯定。照明一切八方上下诸佛国土。有三昧名诸法无所生。假使菩萨逮得斯定。总揽诸佛经语训典。为众会分别敷演。有三昧名念雷音。假使菩萨逮斯定者。言语音声畅于梵天。有三昧名晓了一切应心所乐。假使菩萨逮斯定者。悦可众生随其所乐而令解脱。有三昧名无会现悦精进。假使菩萨逮斯定者。现见无为无有限数。终始之惑所闻所见莫不通达。有三昧名无念宝德乐于世界。假使菩萨逮斯定者。放诸神足施化众生。有三昧名诸音缘会。假使菩萨逮斯定者。觉诸言音。以无数字了一文字。以一文字说无数字。有三昧名积众善德。假使菩萨逮斯定者。分别罪福兴显平等。多所悦可一切众生。便闻佛音法音众音。声闻音缘觉音。菩萨音度无极音。彼有所说亦无音声。有三昧名起诸总持为一切王。假使菩萨逮得斯定。分别一切无量总持。有三昧名净诸辩才。假使菩萨逮斯定者。寂除一切音声言说。皆无言教亦无响应。无言无教亦无所有。于是溥首。白世尊曰。唯然大圣。鄙身宁应讲斯典之功德乎。告曰宜讲。溥首白佛。假使菩萨闻斯经典而不狐疑。发心受持而讽诵读。其人现在得妙辩才。聪明辩。欣豫辩。深妙辩。无合会辩。常行慈心加诸众生无毁伤意。所以者何。设使忧念所作所趣。奉行智谛。随身未曾舍离。尔时世尊。赞溥首曰。善哉善哉。快说此言。诚如之意。譬如布施获致大富而不虚假。持戒生天亦不虚假。今斯经典亦复如兹。学致辩才亦不虚设。悉得本志。犹如日光出照天下众冥悉除。斯经如是。讽诵学者怀来辩才靡不通达。喻如菩萨坐于道场。于佛树下。逮得无上正真之道。成最正觉。菩萨如是。学诵斯经必得辩才除诸狐疑。是故溥首。假使菩萨现欲兴辩晓练诸法。闻斯经典心不犹豫。即当受持讲说讽诵。为诸众会广演其谊。于是离垢藏菩萨。前白佛言。佛灭度后。其有受持讽诵讲说斯经法者。广为众会敷演其谊。鄙亲当为寡解所归。使不狐疑疾得辩才。于时弊魔愁毒垂泪。来诣佛所白世尊曰。唯无建立于斯经也。如来至真等正觉。常怀大哀。其有苦患施以大安。善哉大圣。愿除我戚。如昔世尊初坐树下处于道场。今复重加说斯经典。我今忧郁心怀懊恼。甚于如来始得佛道所投济时。我之反侧不能自胜。一切皆当得不退转。逮无上正真之道成最正觉。其有黎庶耳闻斯经。听音伏名悉当得道至于灭度。空我境界虚魔宫殿。大圣抚育安住垂安。兴建大悲唯见矜济。佛告魔曰。波旬。莫恐勿怀怖惧。一切众生不悉灭度。如来亦不建立斯经。魔闻佛告。踊跃欢喜善心生矣忽然不现。溥首白佛。何故为魔而说断教。佛告溥首。斯经典者。住无所住。是故为魔而说斯言。吾不建立斯经典也。至诚不虚。一切诸法住无所住。不可逮得。无有言教。离于二事本际平等。审谛无本。法界如称平若虚空。无适无莫真正无异。今经流布斯阎浮提。于此天下当有瑞应。世尊适建诚谛之教。自然空中音普广闻。诚如佛言至诚不虚。佛告阿难。受斯普门品经之要。持讽诵读宣示同学。又言阿难。八十万四千法品之藏。计比斯经典。等无差特。所以者何。无量之门法界诸要。如来分别晓了。众生解斯经典而成佛道。然后讲说八万四千诸经品藏。是故阿难。当受斯经消息。将顺谛持讽诵为众人说。佛说此已。离垢藏菩萨。溥首童真。贤者阿难。诸天世人。揵沓和阿须伦。闻经欢喜稽首而退

佛说普门品经


佛说如幻三昧经

    No. 342 [Nos. 310(36), 341]

佛说如幻三昧经卷上

        西晋月氏国三藏竺法护译

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。比丘六万二千。一切圣智神通已达而悉耆年。菩萨四万二千。溥首童真之等类也。其名曰师子英菩萨。慈氏菩萨。光世音菩萨。得大势菩萨。辩积菩萨。建立远菩萨。山顶菩萨。山幢菩萨。无动菩萨。善思议菩萨。所思善议菩萨。心勇菩萨。心志菩萨。善心菩萨。珠积菩萨。石磨王菩萨。宝掌菩萨。宝印手菩萨。常举手菩萨。常下手菩萨。常精进菩萨。御众菩萨。笃进菩萨。住言行相应菩萨。超愿菩萨。立报答菩萨。等思菩萨。弃诸恶趣菩萨。度无量菩萨。度无动菩萨。虚空藏菩萨。上意菩萨。持意菩萨。增意菩萨。术详菩萨。执诵菩萨。月光菩萨。月英菩萨。光英菩萨。光首菩萨。还若干光菩萨。师子步雷音菩萨。辩无碍菩萨。妙辩菩萨。应辩菩萨。度意菩萨。显日月光菩萨。空无菩萨。质游菩萨。常笑菩萨。根喜菩萨。除诸盖菩萨。转女菩萨。转男菩萨。转胎菩萨。被德铠菩萨。大慧菩萨。光[火*僉]菩萨。照明菩萨。无受菩萨。受音王菩萨。深藏菩萨。众香手菩萨。解缚之等八正士俱。如是等类四万二千。四天王。天帝释梵忍王。此及余天六万人俱。须深天子。善住意天子。大神妙天。善意天。大乐天。如斯之等三万人俱皆志大乘。燕居阿须伦与二万亿阿须伦俱。有海龙王与六万诸龙俱从海出。此及他方无数天龙鬼神。阿须伦。迦留罗。真陀罗。摩睺勒。不可称限百千亿载。比丘比丘尼。薰士薰女。不可计会皆悉来集。如来垂哀。与无数众眷属围绕而为说法。尔时文殊师利自在其室独游宴坐。以空无心离心三昧而为正受。文殊即时从三昧起。适安隐兴。震动十方无量佛土。文殊师利心自念言。如来至真平等觉者。今为所在。于世求之甚难得值。犹灵瑞华时时而出耳。其所现方难及难当。非心所思非言所畅。深妙超绝巍巍无量。佛现于世终不虚妄。因得闻法。所听经典未曾唐举。犹是众生灭除苦患。如斯真正非为无益。吾今宁可诣如来所应时启闻。随其所质令诸德本一切备悉。假使有人学菩萨乘。令不疑惑深妙佛法。成就道谊悉蔽魔宫。此忍界中众生之类。其淫怒痴甚为兴盛。离清白法但行无义。愚戆抵突心怀憍慢而无恭恪。所可修业多所违失舍佛法众。当令众生闻如此法净智慧眼

于时文殊复更念言。当诣十方诸佛世界。请召无量百千菩萨。使集佛所听受经典。其身证明此深法忍。文殊师利。以离垢光严净三昧而为正受。适三昧已寻时东方亿江沙等诸佛世界。普为大明。润泽柔软离垢显曜。清净光照东西南北四维上下十方佛土。光明所照悉遍若斯等无殊特。其于十方幽隐闇冥蔽翳方城。山石墙壁树木华实。铁围大铁围。目邻山大目邻山。雪山黑山及须弥山。而悉蒙照。靡不显曜无所蔽碍。时于十方诸佛世界。一一江沙亿数佛土。诸佛世尊现在说法。此诸佛边一一侍者。各问其佛。以何因缘忽有大光普遍世界从昔已来未曾见闻如此光明。润泽和雅靡不蒙济。今佛光明众身安隐令心清彻。皆见拔擢顺时无违。无复犯行淫怒愚痴。此之瑞应为谁圣旨之所建立。所演光曜晖赫若兹。是诸佛世尊。睹诸侍者之所启问。默然不应。其彼世界天龙神声。阿须伦迦留罗。及金翅鸟揵沓和声。人非人声。飞鸟鹿声。风雨水声。大海中声。歌妓乐声。斯等之类。蒙佛威神悉亦寂然无畅音者。一切诸响悉为憺怕。其诸侍者启问诸佛如是至三。世尊愿说。多所哀念多所安隐。怜愍诸天及世间人。为谁威神出是辈声。其大光明普诸佛土。于时诸佛亿江沙数。各从刹土同时一声。各集其音柔软了了。悉从一佛出若干教。口之所演如是像音。同时报告诸侍者曰。诸佛世尊适宣音已。一切佛土皆为之动。百千妓乐不鼓自鸣。诸天人民阿须伦乐亦复如是。其音亦演非常苦空非身之声。空无相愿虚无恍惚本无之声。本际之声。舍淫怒痴无三界声。如审谛声。施戒忍进禅智之声。常惭愧声。慈悲喜护声。遵修奉行无放逸声。如是若干。常宣百千法谊之声。此所讲法。令不可计无央数人亿百千众立不退转。志于无上正真道意。开化声闻及缘觉法。释梵之位成转轮王其亦若兹

于是诸佛告诸侍者。诸族姓子。汝等默然专问是为。此非声闻缘觉之地所能及者。诸天世人及阿须伦。闻此迷荒如来咨嗟颂宣斯光明德。其功德勋不可思议。所积功祚无能惟察。所学精进智慧之业。乃能致此究竟光明。若于一劫过劫之余。咨嗟光明不能畅尽得其原际。此光明曜所兴慈悲巍巍如斯。诸佛侍者。再三闻此所叹咨嗟。益以饥虚。重复启白。唯诸大圣以时宣畅。多所哀念多所安隐。愍伤诸天及十方人。并诸菩萨大乘学众令成德本。于时诸佛告众侍者言。族姓子。有一刹土名曰忍界。于彼有佛。名释迦文如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。兴于愦乱五浊之世。其土众生淫怒痴盛慢无肃恭。弃于净志清和之德而离惭愧。专为误失众恶之业。如是等类下土之党。诸愚騃子修众恶行。故生彼土逮成无上正真之道。为最正觉而说经法。彼有菩萨名曰文殊。其力广大圣慧无极精进无比威变若兹。劝化开示诸菩萨众。使入高德无极大乘。为诸菩萨之父母也。晓了随时解一切法。分别章句智慧无碍。度于彼岸辩才无际。还得总持。晓了一切众生根本。从所明识而为流布。功勋之德不可思议。故往启问如来至真。所当行业。使诸菩萨成就德本。进诸菩萨。令其究畅务念佛法。是族姓子。文殊师利请诸菩萨。故演真妙随宜时光。使诸十方无央数亿诸菩萨会。当令听受此佛所说法。所以由是显其光明普遍佛土。侍者白问。其三昧定名曰何等。佛言号离垢光严净。文殊师利住斯定意。所演巍巍神妙光明遐照如此。时诸侍者复白佛言。吾等昔来未曾见遇如是比像。柔软清和音声志愿光明妙响。缘是之故以无尽哀随时演光。快哉如是道德超殊不思议曜。令人踊跃乃如此乎。佛言族姓子。时时乃奋斯大洪曜。会诸菩萨讲宣经典开示大道

尔时十方无数难计不可思议。八方上下面面各各十亿江沙诸佛之土。各有无量不可思议诸菩萨众。皆诣佛所稽首足下前白佛言。唯愿大圣。此何光明。自从昔来未曾见闻。此何先应。于时诸佛告诸菩萨。有族姓子。世界名忍。有佛号曰释迦文如来至真等正觉。现在说法。彼有菩萨名曰溥首。演布如斯光明之曜。其光名曰。请诸菩萨悉令集会。是其瑞应。时诸菩萨各白佛言。我等欲诣至于忍界奉见能仁如来至真。稽首请问咨受所闻。亦欲亲觐文殊师利及余菩萨。其佛答曰。往族姓子。今正应时。于时十方不可思议无数菩萨。亿百千垓如尘之数。犹若壮士屈伸臂顷。各从所在诸佛国土忽然不见住于忍界。彼有菩萨。而雨众华往诸佛所。或雨杂香华鬘涂香。青莲红黄白华。信脱思夷梧桐须蔓。柔软大柔软。普念大普念音华。月大月悦乐月华。雨如是辈若干种华。以供养尊往至佛所。或有菩萨。以一音响告语三千大千世界。咨嗟如来无量功勋。往诣佛所。或帝释眷属。或梵营从。或四天王辈类。或如天龙鬼神犍沓和等玉女作乐诸眷属也。若干种变殊别各异。往诣佛所适到其前。此忍世界三千大千诸有地狱饿鬼畜生。悉为消除。寂寞无患致最欢悦。皆诸菩萨威神所感。其菩萨众不可称载百千亿数。无能思察计其限者。诣释迦文佛。稽首足下绕佛三匝住于虚空。则习此意普身三昧而为正受。因自然生七寻莲花。其色无量。则升其上结加趺坐。于时耆年大迦叶。即从座起偏出右肩右膝着地叉手赞佛。而说颂曰

  善施于欢悦　　功勋谛离垢
  十方超众人　　得寂心澹泊
  觉了诸所行　　尊为无等匹
  开道显示我　　无量不思议
  善遵行布施　　奉戒亿垓劫
  所行无等伦　　三界无所著
  忍力势无极　　其力凡有十
  难逮乐功勋　　为我断疑网
  见众生患难　　故行苦于劫
  所行不厌倦　　精进益无量
  广施无所爱　　男女及妻妾
  国土之所有　　乐施皆能惠
  已断我狐疑　　本施象马乘
  头目不逆人　　衣服亿载数
  诸所当光饰　　能仁授饮食
  常乐于布施　　故欲问安住
  截身令段段　　离垢不怀恚
  忍力舍诸慢　　愿说此意趣
  修习于空行　　意常善思惟
  施安乐功勋　　故问灭尘劳
  已断贪欲怒　　众生邪见恼
  尽愚痴瞑冥　　不乐吾我想
  弃捐诸有处　　修行百千劫
  显道之原际　　令我得自归
  慧神度彼岸　　善行所当修
  晓了吾我想　　好乐习空法
  处人无所著　　心善无所猗
  禅定无思议　　决疑舍尘垢
  往昔修习行　　施戒忍精进
  已入禅智慧　　行慈无双比
  奉德无能计　　犹如江海水
  颜色殊妙好　　愿为我救护
  其归命世尊　　离垢不弃捐
  若节节解身　　等观体无色
  尊志思道术　　悦众决疑网
  如山不可动　　安住无恋慕
  若在天行定　　不着众玉女
  在在所游居　　未曾见阴盖
  胜性无变异　　口所宣亦然
  德普如虚空　　稽首无上尊

于是耆年大迦叶。以此偈赞佛已。唯然世尊。于今何缘。有此大光明靡不遍。加复现斯殊妙难及未曾有法。佛告迦叶。用为专心而问此谊。非彼声闻诸缘觉乘之所能及。诸天世人在中迷荒将无惑乱。假使如来答此所问。一切罔然不知所趣。迦叶又问。愿佛说之。多所愍伤多所安隐。救济诸天及十方人。佛告迦叶。谛听善思当为汝说。迦叶白佛。唯诺世尊愿乐欲闻。佛告迦叶。文殊师利有三昧。名普光离垢严净。以此定意而为正受。由是之故演其光明。照于十方亿江沙等诸佛国土靡不蒙曜。十方一一诸佛国土无数无量不可思议亿百千垓诸菩萨众。为此光明所见请召。悉来集会于斯忍界。故来亲近诣吾目下。绕佛三匝去地七寻。于虚空中化作若干众妙莲华。身处其上。迦叶白佛。因是圣旨雨斯众华。百千妓乐不鼓自鸣。一切众会现金色乎。佛言。如是迦叶。是菩萨威神之所感动。迦叶又白。唯然大圣。我永不见诸菩萨众之所在也。佛告迦叶。一切声闻缘觉之乘不堪任见。所以者何。其声闻众及缘觉乘。未曾在彼修如是像无极大哀大慈之行。现无际谊。布施持戒忍辱精进一心智慧亦复如是。遵修志性无及菩萨。此诸菩萨已遍入诸三昧正受各现诸身。是身像貌声闻缘觉所不能睹唯有如来乃见之耳。得是定者亦能见矣。若有菩萨。习此道地存在大乘。此族姓子尚不能见。况声闻缘觉岂能睹乎。未有此谊。迦叶白佛。菩萨有几事究畅斯行。用何德本逮得遍入诸身三昧。佛告迦叶。菩萨有十法。而得遍入诸身三昧。何等为十。志性清和所建通达(一)。不舍一切众生之类(二)。而不违远无极大哀(三)。常悉晓了众想之着。宣诸佛法性不卒暴(四)。若有所讲不念轻慢不演声闻缘觉地缺。不慕彼学志于大乘(五)。一切所有施而不吝。放舍所爱贪身寿命。何况余事无益己者(六)。将护无量生死之难。心不怀念汲汲懈倦(七)。所修布施持戒忍辱精进一心智慧。无限欲具足此诸度无极(八)。于度无极亦无妄想(九)。我当劝立一切众生令存佛法。然后乃诣坐佛树下(十)。又计佛道无有众生。是为十法。菩萨所行逮得遍入诸身三昧。迦叶白佛。至未曾有一切声闻诸缘觉乘。所未能发一心行也。假使众生一切皆住阿罗汉地尚不能及。况当逮知诸佛法名此三昧乎。安能正受未之有也。迦叶复白。愿乐欲见此诸菩萨。所以者何。若得亲睹如此像类诸正士等为大欣庆。佛告迦叶。且默须待。文殊今来当从三昧起。诸菩萨等然后汝身乃得见之。于今迦叶。假使兴设百千方便三昧思求此诸菩萨。不能知处所可游居威仪礼节也。于时迦叶。闻说此谊寻承佛威神。因己神足专惟定力。入二万定而为正受。复更兴志。欲得见此诸菩萨所行礼仪。为何等类永不能见所可游居。不知进退往来周旋住立经行。何所讲说何所开化度众生耶。冥然不睹。从三昧起。复前白佛。难及世尊。甚可惊怪。吾时向者入二万定而为正受。求诸菩萨不知所存。未成普智诸通之慧。何能逮得如斯寂然三昧定意。甫当获致无上正真最正觉乎。若族姓子族姓女。谁见此变不发无上正真道心。唯天中天。若有菩萨求此通入诸身三昧。被戒德铠以誓自誓。心不当远斯三昧定。佛告迦叶。如是如是。如汝所云。此三昧者非诸声闻缘觉乘地所能及者。况余凡夫众生类耶

于是贤者舍利弗心自念言。如来所叹于众智中称吾为最尊。我宁可求此诸菩萨所游居处为何如乎。时舍利弗入三万三昧而为正受。察诸菩萨为何所在。都不能见亦不能知影响形像。其所瑞应为何等貌

尊者须菩提心自念言。我宁可复求诸菩萨住在何所。以三昧力承佛圣旨。入四万定奉修正受。欲得见之而不能睹。不知进退往来经行坐立所在。时须菩提从三昧起。前到佛所投身足下而自白言。如来叹我行空第一。尚不能逮斯三昧定。政使三千世界成为大鼓。有丈夫来力势甚大取须弥山。我三昧定而住其前。举须弥山以挝大鼓。一劫不休不能乱之令心微动。我神通行空巍巍若兹。鼓声极高彻闻十方。一劫不懈尚无所动。声不向耳。岂当令吾从三昧起。未有此义。所行空事殊绝乃尔。而反向者四万三昧周遍定意。心中欲察诸菩萨众永不能睹。唯愿世尊。本假使知诸菩萨慧。道德超绝光光若此。一一人故江河沙劫。在大地狱而见烧者。忍此苦患求菩萨道。不舍违远。巍巍如是无思议慧。身设不逮漏尽意解者。于无数劫能忍处在生死劳苦。终不远离如是比像无极大慧。于时佛赞须菩提曰。善哉善哉。诚如卿言。志性温仁咨嗟此辞。假使汝今不以此身取灭度者。因斯德本。恒边沙等为转轮王治以正法。当成无上正真之道为最正觉。又须菩提。三千大千世界众生之类宁多不乎。须菩提。言。甚多甚多。天中天。佛言。皆使众生智慧备足如舍利弗。行空第一如须菩提。如是等类诸大声闻。亿百千数不可称载。若欲得见此诸菩萨亦不能睹。所以者何。声闻缘觉不能修行如此法教。如诸菩萨大士之等。举动进止。非是小节劣乘所逮。说是法时。八万四千诸天世人。皆发无上正真道意。三千大千世界皆大震动。文殊师利自在其室。心兴念言。今诸菩萨皆来大会。其限无数亿百千垓。吾当复令诸天之众悉来云集

于是文殊即如其像。三昧正受而显神足。寻如所念。应时化成八万四千亿百千数宝红莲华。大如车盖。紫金为叶白银为茎。首藏琉璃及马瑙宝而以杂厕。瑰琦诸珍车磲为子。化诸菩萨皆坐其上。体紫金色三十二相。姿艳端正威神晖赫。又莲华光诸化菩萨。照四王天忉利天。盐天兜术天。无憍乐天化自在天。梵天大梵天。梵迦夷天梵满天。至一善天。普及三千大千世界。欲行天色行天所有宫殿。诸菩萨等坐众莲华上。靡不周流十方。悉畅法音多所开化。此诸菩萨皆游告此三千大千世界。而叹颂曰

  诸佛超日月　　久远乃现世
  犹如灵瑞花　　难值复过是
  释师子人尊　　今显出于世
  以时讲经典　　尽灭一切苦
  天上之快乐　　安能得久如
  复还堕地狱　　因更无量恼
  若习于贪欲　　恩爱转炽盛
  三界无安乐　　勿志生死渊
  智者得开眼　　佛世难可遇
  放逸不觉了　　不能灭众患
  当往见正觉　　听受无上法
  人尊灭度已　　将无坏忧戚
  驰骋自恣者　　有魔网之难
  安能得解脱　　迷惑失正路
  若人宿有福　　可为说此义
  佛观其原际　　妙相三十二
  余人不堪任　　亦无能将护
  唯有佛世雄　　其慈无思议
  百千劫造行　　无量不可议
  积累尊圣慧　　释师子巍巍
  今讲最尊法　　其义深难逮
  众生不可得　　无寿亦无人
  当弃于计常　　断灭亦如之
  舍一切诸想　　为众颁宣法
  演示真本际　　于世无所著
  斯空无有想　　不兴造诸愿
  无形无所猗　　不起无所灭
  所来无从来　　明眼说法然
  无相无所生　　本净无形貌
  无见无瑞应　　不念有所说
  计众生不生　　亦无有死者
  人本无所起　　亦无有灭度
  以音说经法　　法无积聚处
  因文字号法　　导师之所说
  其不着风者　　亦不依水火
  不想念于地　　明眼之所叹
  色痛痒思想　　生死行亦然
  说识亦复空　　五阴无处所
  其眼耳鼻者　　若口并身意
  分别本净空　　其空不可得
  色声味众香　　细滑意所乐
  从想念而生　　想亦空自然
  欲界及色界　　无色亦如是
  分别犹如幻　　无实亦无形
  正觉为若兹　　为人讲说法
  灭除众苦患　　当速诣导师

诸化菩萨。于三千大千世界。宣此颂已悉得闻之。有九十六亿欲行天人色行天人。远尘离垢诸法法眼净。二万人皆得离欲。三十三天子宿殖德本。逮得无所从生法忍。当尔之时。诸化菩萨。所可劝发。无央数亿百千那术诸天子等。寻往诣佛。稽首足下。绕佛三匝却住一面。以天青莲红黄白华诸天意华。散如来上烧众名香。在于虚空鼓天妓乐。时诸天子集会甚多不可称计。周遍圆满此四方域。东弗于逮南阎浮提西拘耶尼北郁单曰。中不容间。若上投杖而不堕地。此诸天人威神尊重志在高节于四方界积众华香高至于膝。时善住意天子名离垢天怀耻天。此等三天。与九十六亿诸天眷属皆志大乘。诣文殊师利住于室外。文殊师利自在其室。悉取诸华供养如来。令大千国虚空之中成华交露。此众华光皆照佛国靡不周至

文殊师利志安和雅从三昧兴。即出其室退住一面因复弹指。此弹指声。六反震动三千大千世界。即时其地出大高座。无央数宝而杂挍成。不可计衣而布其上。又斯高座光威巍巍。照于荒域百千由旬。蔽诸天子令明暗冥。文殊师利便处其坐

时善住意天子见文殊坐。稽首足下退住一面。一切诸天亦复如之。文殊师利心自念言。吾当与谁于世尊前难问讲议。当令通畅不可思议章句应器难解之迹。无所有迹无所著迹。无所弃迹不可得迹。无所说迹。深妙之迹真谛之迹。诚信之迹无挂碍迷。无所坏迹。空无之迹无想之迹。无所愿迹本无之迹。于一切法无所住迹。颁宣道教无极之迹。本际之迹尊上之迹。无所入迹法界之迹。无形像迹无比类迹。证虚空迹无所举迹。无所下迹佛法教迹。逮圣众迹慧具足迹。在于三界无俦匹迹。游一切法讲无起迹。于诸道法无所致迹。诸释梵迹修勇猛迹。于一切法无阴盖迹。句无句迹度诸句迹。越声闻器。文殊师利复更兴念。善住意天子。于过去佛。已造立行殖众德本。入深法忍辩才无碍。今当与此在世尊前难问讲谈。于时文殊谓善住意天子曰。于今仁者入深法忍。欲与仁俱谈言说事。善住意天子白文殊师利。我与仁者共谈耳。设无有言不演谈语不怀报应。若不咨问佛法圣众。不声闻不缘觉不佛道。不终始不生死不泥洹。不善非不善。无罪无不罪。无漏无不漏。无现世无度世。不合不散不启不发。不演文字不可畅意声。文殊师利谓善住意天子。吾所讲说当如斯耳。若使仁者都不以闻。亦不好乐不受不诵。不念不知亦不分别。不取不舍亦无所听。不为他宣不讲说法。不令众生处于生死若至灭度。所以者何。诸佛世尊以无文字逮成无上正真之道。为最正觉。虽曰有心则无有心。不显吾我其名无处。天子又问文殊师利。仁者讲说当听受之。唯文殊师利。以时颁宣令心欢悦。诸天子欲闻尊者演法宣于本际。文殊师利复谓善住意。吾所宣法不令谛听不令启受。所以者何。其欲听法则受吾我。着人寿命故欲闻法。假使天子。从颠倒念受于虚伪。计吾有我贪身计有。便有此念。彼说我听。因此猗故有三着碍。何谓为三。一怀颠倒着于吾我。二不顺教计有他人。三念受法欲有所得。是为三碍。假使天子不计吾我净于三场。乃谓听法。不想报。不思念。不思察。何谓三场。一不得人亦不想报。二不有法无所悕望。三无吾我无所思慕。若使天子听法如此。是为等听。不为邪闻。善住意天子赞文殊曰。善哉善哉快说斯言。所住说者而不退转。文殊答曰。且止天子。勿得想念菩萨退转。所以者何。若有菩萨。成最正觉时亦不得道。天子又问。心不坚者何所退转。文殊答曰。淫怒痴转故曰为转。为报应转。六十二疑邪见所转。无明所转欲界色界无色界所转。声闻缘觉土地所转。应与不应众想所转。为诸受取妄想见转。诸处进退妄见所转。为诸计常断灭见转。为进不进合散所转。我人寿命之所见转。可意悦乐求慕见转。有常清净安隐我身颠倒见转。为是诸念挂碍所转。贪身众习众观所转。六十二见诸盖迷冥。贪欲嗔恚睡寤调戏。狐疑所转。阴种诸入四大所转想转想佛法众我当成佛故曰退转。吾当说法度脱众生逮得圣慧。由是想转假使奉修。而想十力十八不共诸佛之法。亦想根力及七觉意。亦着相好。亦复妄想严净佛土成声闻众。是为退转。一切诸应与不应。想与不想。设使天子。其行菩萨于此诸退而不退转。问曰。何所不转。答曰。通达佛慧则不退转。空无想愿则不退转。于本无行则不退转。亦于法界了其本际则不退转。所以者何。用平等行故不退转

善住意天子复问。文殊师利。如仁所说。设于诸法应与不应想及无想。着于佛道与魔俱同。所以者何计有法故。又问。菩萨为有退转为无退乎。文殊答曰。不以有转不为无转。又问何所退转。答曰皆由一切受虚伪故。其受虚伪因是故受。若于诸受不受不舍不以患厌。则能退信一切诸法。颁宣经道不有不无说亦不住。所以者何。假使退念。此有此无则堕缺漏。若言有者则为计常。若言无者则堕断灭。如来至真等正觉若说经法。不宣断灭不演有常不想诸法。说是法时。一万天子逮得无所从生法忍

时善住意天子白文殊曰。当共俱往诣如来所。奉见稽首咨受所问。所以者何。如来至真断诸疑结。文殊师利答天子曰。且待须臾勿有妄想。于今如是当见如来。又问当于何待。答曰今住在前。又问何所住前。答曰虚空也。善住意问文殊如来所在。答曰今故在前。又问文殊。吾今不见于如来也。文殊答曰。见诸如来当作此观。若有问者谁在前立。则当报答虚空界也。立在前耳。察于如来如虚空界。所以者何。一切诸法等如虚空。如来晓了此诸正慧。故为人说如来如虚空。虚空如来则无二矣。是故天子欲见如来。当了本际莫怀妄想。善住意天子复谓文殊。吾续欲往诣如来所。答曰天子。往续在此住勿得进发。善住意天子。于时则与无数诸天往到佛所。文殊师利。寻时化作三十二部交络重阁。方圆自副四角有柱。姝好殊特轩窗备悉。威神巍巍嵩高显远睹莫不欢。阁交络中化作众宝诸床榻具。布以天衣。一一床上化菩萨坐。三十二相庄严其身。于时文殊。则如其像建立神曜。妙色莲华上诸坐菩萨。及三千大千世界可游行者。并诸棚阁交络床坐。普诣佛所绕佛七匝。及诸圣众踊住空中其光照曜众会场地却住四方。文殊师利。忽然速疾已至佛所。善住意天子反从后至。时善住意至彼见之。即问之曰。仁从何路前至于斯。我发在前反从后至。文殊答曰。假使供养江河沙等如来而真稽首为礼。不能见吾去来进退。文殊师利现未曾现。诸来会者还自诣室。时莲华上诸坐菩萨。并交络中皆一音声同时发音住于佛前。则以此偈赞世尊曰

  为已曾供养　　无央数亿佛
  犹如江河沙　　无能计谊者
  以用志佛道　　殊特尊上慧
  人尊无所著　　胜是故巍巍
  颜容尊难及　　圣威照三世
  能仁众相好　　若干种变异
  若颁宣经道　　导师从其愿
  其所分别者　　永无人寿命
  律开导众人　　布施行禁戒
  忍辱习精进　　禅定之智慧
  三处无所著　　以慧度彼岸
  归命礼最胜　　奉敬诸正觉
  随一切诸佛　　奉敬三界将
  为诸法之王　　天人所供养
  笃信于空无　　坚固难可及
  因此得逮成　　世间人中圣
  其有本往古　　过去诸如来
  有今现在者　　人中之尊上
  斯等悉奉行　　常解空净慧
  亦无有想愿　　察之不有相
  究竟推极之　　本净无众生
  又无有生者　　亦无有死者
  复无有求者　　亦无往生者
  一切诸法事　　譬若如虚空
  如我本所现　　正士之所为
  察于三事身　　悉为无所有
  安住所说法　　其义为若兹
  睹之如幻化　　亦如梦所见
  诸佛之世界　　过如江沙等
  若人满中物　　以用布施者
  假使有行忍　　是法亦复空
  此所兴布施　　殊特为第一
  犹如江河沙　　劫限有若干
  供养诸斯等　　人中最尊上
  众华及名香　　饮食为若斯
  若有菩萨学　　志求佛道义
  若闻此经典　　如是诸训教
  若晓了无入　　寿命含血类
  速逮得法忍　　清净成显曜
  此人则供养　　人中无上尊
  于无数亿劫　　常行布施事
  饮食诸供养　　车马众居业
  亦不用此行　　疾成于佛道
  反怀众妄想　　而计有人故
  其有人中上　　已归灭度者
  曾度于众生　　所济无央数
  其法本清净　　察之无所有
  解脱明慧等　　所学为若兹
  值遇佛兴世　　久久时可得
  若说经典时　　信尊亦复然
  得来成人身　　亦复甚难矣
  善哉修精进　　顺从最胜教
  常当蠲除去　　八懅无闲难
  应时不再遇　　闲暇时希有
  当兴行笃信　　咨启佛教诲
  当殷勤力务　　勇猛常奉行
  若得逮闻法　　速疾修谨敕
  大音无极声　　已度于彼岸
  常当自将养　　精习于闲居
  从人中之上　　稽颡不违命
  从就善知识　　通达法器者
  心常弃于非　　伪行恶知识
  一切修平顺　　等心方便随
  虽在于众生　　慎莫怀妄想
  奉承禁戒者　　博闻之徒类
  等察于他人　　常行而乞食
  数数当调习　　亲近坐树下
  秽药以疗身　　第一无怀疑
  一切诸有为　　计是亦无为
  悉亦同等相　　譬之若野马
  若能晓了者　　是第一本际
  则疾成佛道　　为逮无等伦
  佛解了五阴　　犹如幻师化
  自察其内已　　又观外所有
  安住所分别　　是则为空聚
  慎莫怀恋恨　　于彼依猗之
  其淫怒痴者　　本净如虚空
  騃冥嗔恚事　　悉亦从想生
  又计其想念　　亦不得所在
  诸导师之众　　所晓了若此
  是故有智者　　人中为明目
  假使欲究尽　　诸佛之道慧
  弃捐诸挂碍　　有为之迷惑
  此等勇猛士　　必成尊佛道

尔时诸化菩萨说是偈已。彼众会中诸来听者二万二千人。皆发无上正真道意。五百比丘得无起余漏尽意解。三百比丘尼得法眼净。七千优婆塞七千优婆夷。二万五千诸天子远尘离垢诸法法眼净。三百菩萨逮无所从生法忍。此三千大千世界六反震动。其大光明普照十方。耆年舍利弗前白佛言。唯愿大圣。此谁威德。使此三千大千世界六反震动。诸化菩萨在交络阁莲华上坐。演深妙法其义殊特。斯光普照诸来会者。无央数亿众菩萨集。诸天子等不可称载。佛告舍利弗。文殊师利。威神所感悉令集会。所以者何。是故文殊启问如来。毁伏魔场三昧之要。具足成就不可思议诸佛之法。名寂然空行。与善住意天子俱。舍利弗白佛言。文殊师利不来会乎。何故不现。佛告舍利弗。文殊师利。降毁诸魔三昧正受。蔽魔宫殿兴大威变诣如来所。于是文殊。降毁魔场三昧正受。应时三千大千世界百亿魔宫一时皆蔽不乐其处各各怀懅时魔波旬。自见老耄羸顿少气拄杖而行。所有宫人婇女之等亦复羸老。又见宫殿而复崩坏。暗暗冥冥不知东西。时魔波旬。即怀恐惧衣毛为竖。心自念言。此何变怪。令吾宫殿委顿乃尔。将死罪至归命寿终。天地遇灾劫被烧耶。时魔波旬。弃除贡高舍恶思想。时文殊师利所化百亿天子。在交络者住诸魔前。谓魔波旬莫怀恐惧。汝等之身终无患难。有不退转菩萨大士。名文殊师利。威德殊绝总摄十方。德过须弥智超江海慧越虚空。于今以是降毁魔场三昧正受。是其威神。诸天子等适宣此言。诸魔闻之。益怀恐惧畏于文殊。诸魔宫殿寻时震动。诸魔波旬。报化菩萨愿见救济。答曰。且安勿怀恐惧。仁等当往至释迦文佛所。如来至真。有无尽哀畅无极慈。假使众生有大恐惧。慰沷仁慈令无所畏。诸化菩萨适说此言忽没不现。众魔忻然。与诸交络化座菩萨。佥共同心往诣佛所。羸老拄杖一时发音。前白佛言。唯愿大圣。救护我等令得济脱如此大患。宁得值遇百千亿佛功德名称。不为独一文殊师利所见逼迫。所以者何。我等属者闻文殊名。寻即恐惧不能自安。畏亡身命。佛告诸魔。如仁所言。亿百千佛所益众生。不及文殊之所开化。各各劝导无央数众令得解脱。所以者何。汝等未闻亿百千佛功德名号。虽遭恼患心怀恐惧。因一文殊之所兴变。所难益甚。诸魔白佛。我等羞惭此羸老身。今从世尊自归加哀。愿复本形挍饰天服。佛告诸魔。且待须臾。文殊师利如是来至。当脱斯等如此众难。于是文殊安隐庠序。与无央数诸天子等。百千那术眷属围绕。不可称计天龙鬼神。阿须伦。迦留罗。真陀罗。摩睺勒。亿百兆载无量菩萨。其数无限前后导从。鼓百千乐雨众名香。青莲红黄白华。清净庄严无极威变见莫不欢。俱往诣佛稽首足下。绕佛三匝退坐一面。于时世尊告文殊曰。仁且正受以降毁魔而三昧矣。文殊白佛。唯当从教。世尊又问。以何方宜而从如来听受此定。又何久如成此三昧。文殊白曰。唯然大圣。我未发无上正真道意时闻此定名。寻时则成是三昧矣。又问文殊。所从闻是三昧定者。其号何等如来。文殊白佛。乃往过去久远世时。越过江河沙不可计会阿僧祇劫。尔时有佛。号意华香如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。彼时演斯三昧行品。我身尔时。从得闻是降毁魔场三昧慧音。佛问文殊。何谓三昧慧音。其意华香如来所宣。文殊白佛。菩萨有二十事。而用逮得降毁魔场三昧定意。何谓二十。文殊白佛。于是菩萨。一毁贪淫灭其欲心。二毁嗔恚除瑕秽心。三毁愚痴去暗冥心。四毁憍慢而舍怀恨。五毁嗔怒不怀恼热。六舍众想及诸邪见。七弃多念所生受事及与放舍。八离所有及无所有。九越断灭计常。十毁阴种诸入四大。十一其心不着三界。十二远声闻心。十三释缘觉意。十四刈嫉妒贪余。十五远毁戒违禁之难。十六断斗诤不可之事。十七翦懈怠犹豫。十八拔诸放逸愦乱之意。十九勖勉邪智不正之事。二十降伏尘劳爱欲结网。是二十事菩萨所行逮是三昧

文殊白佛。菩萨复有四事逮是三昧。何谓四。一所行立心清净调和。二志性柔软而无谄饰。三入深法忍心不起灭。四所有施未曾爱吝。是为四。复有四法逮是三昧。何谓四。一行至诚不怀欺诈。二习闲居寂寞之行。三启受经典讽诵诸法。四究竟诸行弃捐非义。是为四。菩萨复有四事何谓四。一亲近善友。二限知止足。三精思独处。四不在愦闹。是为四。菩萨复有四事逮是三昧。何谓为四。一心不乐声闻。二舍缘觉意。三志菩萨道。四逮得法忍。是为四。复有四法逮是三昧。何谓为四。一修空法不计有人。二尊无想舍众悕望。三无放逸除诸所愿。四知足悦弃一切有。是为四。复有四法逮是三昧。何谓为四。一周旋无量生死之难。二等疗一切众生之类。三常一心唯念应时。四无驰骋度于彼岸。唯愿世尊。意华香如来至真等正觉。说是三昧行音。尔时从彼闻是三昧。其佛去后。次复有佛。号明珠日月光曜。因其如来成是三昧。说是毁伏魔场三昧时。彼众会中一万菩萨。如是色像感动变化。悉得无所从生法忍。于舍利弗所志云何。于是三千大千世界。独有是变降诸魔乎。勿作斯观。所以者何。十方一切江河沙等诸佛刹土。诸魔波旬求人便者。皆遇此难不得自在。悉文殊师利之所建立。尔时世尊告文殊曰。仁当舍置所建威神。当使诸魔还复本形天上服饰。尔时文殊告诸魔曰。诸贤者等。实为恶秽此身服乎。报曰实尔。文殊答曰。汝等宜当厌贪欲事不住三界。诸魔报曰。唯当从命。善哉文殊。愿加威神。令我等脱如是形类威仪服饰。文殊师利寻舍威变。疗诸天人及诸玉女。使其形体平复如故。衣被光泽威神巍巍。文殊师利告于诸魔。诸仁欲知其眼受。而怀思想。眼有所著则为眼根。因思想眼言是我所。依猗于眼因生于眼。眼之所趣目为心候还护其眼。举眼下眼则是汝等之境界也。为造魔业。耳鼻口身意亦复如是。假使有眼而无所著耳无所听。鼻香口味身更心法悉无所著。非汝部界。不同劳侣无力不乐。则无魔业亦无影响。又复卿等自计吾我。随念有身缘趣此患。卿等何因处于众会。欲得寂然未之有也。文殊师利。应时于彼。为魔眷属解说经典。使一万魔。皆发无上正真道意。八万四千魔远尘离垢。诸女得法眼净。其余众魔各归宫殿。皆共举声悉称万岁。吾等已脱于大恐惧

于是文殊师利。告逮法忍诸魔眷属。卿等何故不各归宫。诸魔报曰。吾等于今忽然不复见己身宅。何况当复见魔宫殿自然常住。又问。汝等宫殿为在何所。诸魔报曰。一切诸法无主无念。是为诸法之宫殿。空无想愿诸法恍惚乃为宫殿。于彼无往亦无来者

耆年迦叶前白佛言。文殊师利彼殿来乎。我等欲见所从菩萨。所以者何。此正士等难可值遇。佛告文殊。汝当现此十方世界诸来菩萨会忍土者。今诸众会皆共渴仰欲得见之。文殊师利。应时告诸法伦菩萨。法住菩萨。若干辩菩萨。得大势菩萨。柔软音菩萨。灭众恶菩萨。寂然菩萨。选择菩萨。法王菩萨。怀音菩萨。悉告此等诸菩萨众。汝族姓子一切菩萨。各当自现其身宫殿。各自显示所处佛土本之形体。文殊师利适发此言。诸菩萨众寻时奉命。从三昧起各现本体。或有菩萨其身高大如须弥山。或有菩萨其身高长三百二十万里。或二百八十万里。或二百四十万里。或二百万里。或百六十万里。或百二十万里。或八十万里。或四十万里。或三十六万里。或三十二万里。或二十八万里。或二十四万里。或二十万里。或十六万里。或十二万里。或八万里。或四万里。或三万六千里。或三万二千里。或二万八千里。或二万四千里。或二万里。或万六千里。或万二千里。或八千里。或四千里。或三千六百里。或三千二百里。或二千八百里。或二千四百里。或二千里。或千六百里。或千二百里。或八百里。或七百六十里。或七百二十里。或六百八十里。或六百四十里或六百里。或三百六十里。或三百二十里。或二百八十里。或二百四十里。或二百里。或百六十里。或百二十里。或八十里。或四十里。或三十六里。或三十二里。或二十八里。或二十四里。或二十里。或十六里。或十二里。或八里。或四里。或有身长短如此忍界人身无异。诸菩萨等其身如是。高广长短各各别异。尔时于此三千大千世界。诸会充满无如毛厘空缺之处。诸尊神妙高节慧明。菩萨大士卓然有异。功德巍巍无以为喻。其诸菩萨身所演光。彻照十方不可计数百千佛土。尔时世尊以佛庄严三昧正受。适兴此定。寻时忍界自然变现不可称数若干华盖。以其无限百千妓乐各唱其音。挍饰幢幡缯彩无量庄严佛土。靡不煌煌如日如月。诸菩萨众。从紫金刹来至此者。睹是佛刹如黄金色。其从白银佛刹来者。悉现银色。其从水精佛刹来者。见此佛土悉水精色。其从琉璃佛刹来者。睹此忍界悉琉璃色。其从车磲佛刹来者。见此忍土悉车磲色。其从马瑙佛刹来者。见是佛土悉马瑙色。其从名香佛刹来者。见是佛土悉香合成。其从好华佛刹来者但见诸华。从宝刹来者但见众宝。或从七宝。或从六宝。或从五宝。或从四宝。或从三宝。或从二宝世界来者。诣此忍土见此佛土。长广短狭众宝琦异。强劣好丑如本佛土。时诸菩萨各自忆念住本佛土。是等一切见释迦文如来至真形像被服。各如本土诸佛像貌。威仪礼节教授法则饮食等无差特。彼一菩萨。不见他菩萨土地庄严。但睹本刹。举声称曰。此土紫金。二菩萨曰。此土白银。各各所游清净之行。各自惊喜怪未曾有。磬扬大音而嗟叹之。诸佛世界难及难及而不可逮。德遍十方永不可逮。文殊师利应时告曰。诸族姓子。此事无奇。所以者何。一切诸佛皆为一佛。一切诸刹皆为一刹。一切众生悉为一神。一切诸法悉为一法。是一定故故名曰一。亦非定一亦非若干。文殊师利。举其要义不以多言。即从座起偏出右肩右膝着地叉手白佛。愿欲所问。若见听者乃敢自陈。佛言。恣所欲问。如来当决所怀疑结令心欢然。文殊则问。何谓菩萨义所归乎。佛告文殊。晓了诸法靡不通畅故曰菩萨。又问。何谓菩萨晓了诸法。佛言。菩萨晓了眼耳鼻口身心无有弊碍。何谓晓了六情事者。晓了于眼则本净空。耳鼻口身意亦复如是悉空本净。不自想念我晓了之。色声香味细滑之法悉空本净。不想晓了。又文殊师利。若有菩萨了五盛阴。何谓晓了。了空无想无愿。离欲恍惚寂无所有。归于澹泊悉无所生无来无往。犹如野马幻化水月芭蕉梦中所见。不得久存而无坚固虚无无处。若能晓了如斯义者是谓菩萨。又文殊师利。解淫怒痴五阴六衰因想而生。其贪欲者悉从想生。其想亦空虚无无形。无有言辞亦无教化。其淫怒痴于无本法。无能染污不迷不惑。佛言文殊师利。菩萨晓了众生之行。此人多欲。斯人多嗔。此人多痴。其多欲者恩爱隆崇。犹如五谷草木茂盛种类布散不适一处。其多嗔者怒恨炽盛。如野火燃烧炙草木。城郭屋宅。靡不被害。其痴多者暗暗冥冥如无日明。若其屋中覆盖在罂。迷惑穷极不识东西。菩萨大士晓了本行。从其心意聪明暗塞。原际所趣诸根优劣。而为说法。各令入律而度脱之。佛语文殊师利。菩萨晓了一切众生。云何晓了一切众生。皆假号耳。若真谛观其假号者亦无处所。其众生者悉一神耳。计于众生无有众生。晓了斯义无想著者是谓菩萨。于是觉了寤诸不觉解度彼岸是谓菩萨。诸不达者悉令通畅故曰菩萨。当所观者悉见本末起灭因缘。根原所趣靡不周备。前知无穷却了无极故曰菩萨。因其假号随方俗言而有此名。于此众事而无所著故曰菩萨。时佛叹颂曰

  晓了其眼耳　　是空为自然
  达者无想念　　乃谓为菩萨
  晓了鼻口者　　本净无形像
  智者不妄想　　乃谓为菩萨
  智者晓了身　　其意如虚空
  能分别本净　　菩萨为聪明
  色声及香味　　细滑可意物
  若能了如幻　　一切分别空
  亦不求妄想　　乃曰为菩萨
  若晓了色空　　痛痒亦如是
  生死之所识　　一切犹若幻
  心不怀妄想　　乃谓为菩萨
  五阴若如梦　　一相无有相
  明者不妄想　　乃谓为菩萨
  不生无所起　　无言则无为
  假名托于号　　其名无形类
  晓了贪嗔恚　　分别诸想念
  其想无真谛　　究竟无处所
  想愚不亦真　　因作多思念
  缘诸邪见起　　正直无所见
  当怀贪欲怒　　诸法悉平等
  彼无染无秽　　法亦无惑妄
  识别如是念　　菩萨无贪欲
  寂除一切法　　乃谓为菩萨
  晓了诸三界　　是空无真实
  于彼无度者　　乃谓为菩萨
  欲界无成就　　因颠倒而兴
  是色无有无　　此亦比虚伪
  众生所作行　　慧者悉晓知
  贪淫行嗔恚　　同归于愚痴
  一切假名人　　人亦不可得
  明者成就此　　不妄想众生
  一切是诸法　　能知为颠倒
  若识知反覆　　斯亦无有想
  方便随诸法　　不着一切碍
  若逮无所著　　乃曰为解脱
  能施其身肉　　不习诸所猗
  觉了如审谛　　乃谓为菩萨
  禁戒常清净　　亦不想自大
  佛戒随顺义　　无起无所有
  我本所修业　　身口及意念
  是谓为禁戒　　彼无由居处
  普慈愍众生　　亦不得众生
  知之为恍惚　　因假而有号
  其所行精进　　灭一切诸苦
  察了三界空　　能成最上道
  超殊修禅思　　亦复无所著
  无住无所得　　智者了如是
  智慧刀割截　　尘劳诸恶见
  睹见诸法界　　不断无所坏
  如觉了诸法　　应时化群黎
  菩萨晓如是　　乃谓为菩萨

于是文殊师利复白佛言。唯然大圣。所可言谓初发意者。何谓初发为菩萨意也。佛语文殊。假使菩萨普念三界是初发意。所发心者平等如地。其菩萨者无所起发。亦不想念净与不净。其所知者无卒无暴坚住不动。无在不在安无能摇。忍于苦乐越世八法。无所破坏悉无所为。所可发心。适发意已。皆得启受一切功勋。亦不自念我有名德。是谓初发成菩萨意。文殊师利前白佛言。如我听省大圣说义。其有菩萨发淫怒痴乃初发意。时善住意问文殊师利。起淫怒痴乃应初发成菩萨者。一切愚戆凡夫之士皆应初发。所以者何。斯等之类起淫怒痴故不去三毒也。文殊师利告善住意天子。愚戆凡夫不能堪任起淫怒痴。所以者何。谓佛世尊缘觉声闻诸不退转菩萨之党。乃能发是淫怒痴耳。凡夫不能。善住意天子报文殊曰。今者所说甚可畏。此众会者心怀疑网。因闻仁者演此义故。不能晓了其心冥然。文殊师利谓善住意天子。于意云何。譬如飞鸟飞行虚空。岂畏为径通过有依碍乎。答曰经过不畏虚空也。文殊报曰。如是天子。道无所起。有所憎恶则为不发。无所憎恶乃为发意若无所著不怀憎恶无所依猗乃谓发耳。所谓为发兴无想念。无所生者是名不发。无自然者乃曰为发。无有句迹乃曰为发。无去来迹乃曰为发。空身慧迹无所念迹乃曰为发。无所受迹无所逮迹乃曰为发。无所坏迹无所获迹是谓为发。无文字迹无所慕迹是谓为发。不进不殆不双不只是谓为发。不求救护亦无有归是谓为发。是故天子。名于菩萨为初发心。其于是法。不念不依不思不想。不知不见不闻不识。不受不舍不起不灭。是故天子。名诸菩萨以是因缘。因此法故由斯平等。如是本际善权方便。发淫怒痴发眼所依。耳鼻口身意亦复如是。发色所著亦复显于痛想行识不当生色报应。诸见无明有爱。当兴十二缘起之法。吾诸所欲依猗三界。亦当显发所依吾我贪身计已。六十二见。亦当显发五盖之患。四倒八邪十恶之业令其反原。取要言之一切净不净应不应众想言辞一切处所所受依猗。思想诸念恋慕挂碍。所可言曰发泥洹想。菩萨大士皆显发此是故天子当作斯观。其于诸法有所依猗。无所憎爱是谓为发。文殊师利说是法语初发意时。此三千大千世界六反震动万二千菩萨得无所从生法忍

佛说如幻三昧经卷上佛说如幻三昧经卷下

        西晋月氏国三藏竺法护译

尔时世尊赞文殊师利曰。善哉善哉。乃能讲论发意菩萨。仁已曾奉江河沙等诸佛世尊。故能畅此无极道慧。时舍利弗前白佛言。向者文殊颁宣咨嗟。诸初发意菩萨之事。若有逮得无所从生法忍。计此二者其意等乎。佛言。如是舍利弗。诚如所云。锭光佛时授我要决。当成无上正真之道为最正觉。于当来世无央数劫得成为佛。号释迦文如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。因彼发心无所违失。应时逮得无所从生法忍。是舍利弗。文殊师利向者所讲初发意菩萨。文殊白佛。我身省察大圣说法义之所归。一切菩萨其发心者名初发意。所以者何。唯然世尊。其诸发意皆无所生。其无所生则是菩萨初发意也。说是语时。二万三千人立不退转地。当成无上正真之道。五千比丘得无起余漏尽意解。六万天子远尘离垢诸法眼净

于是耆年大迦叶。前白佛言。文殊师利所为甚难甚难。今说经典开化饶益若干众生。文殊师利谓大迦叶。我之所作不为甚难。所以者何。一切诸法皆无所作。非作非不作。唯大迦叶。我于诸法无作不作亦无所舍。不度众生亦无所缚。所以者何。众生之党本无明故。成为众生故非甚难。向者迦叶宣言甚难。吾身所作无有甚难亦无不难。非如来非缘觉非声闻。迦叶。欲知谈说甚难。欲宣至谊。凡夫所作乃为奇异名之甚难。所以者何。唯然迦叶。一切诸佛威神之力未曾违废。亦不可得声闻缘觉。诸佛势力无获无得。独凡夫士乃逮此力。大迦叶曰。于文殊意所察云何。诸佛所得无得不得非声闻非缘觉。文殊师利报大迦叶。不得我身无人无寿。无形无终含血有志。不得断灭有常之计。阴种诸入名色三界。应与不应想与无想。兴发报应现世后世。贪淫怒痴悉不得是。迦叶当解。取要言之。一切诸法无得不得。无所依猗无受无舍。不放施无所教。亦无近无所授无所解。是故迦叶。当晓了此诸凡夫士。不闻谊者乃有所得。诸佛世尊实无所得。是故所作不为甚难。诸佛声闻悉无造作。凡夫所为而不可及。为何所作。为断灭为计常多所猗着。殷勤求愿心怀众念。作与不作或举或下。分别讲说妄想猗着。愁戚悒悒而念免害。稽首自归诸佛世尊。不作不为亦无所著。愚唯为此。是故所作不以为难。文殊师利前白佛言。所谓无所生。其谊云何为何谓乎。云何菩萨逮得无所从生法忍。佛告文殊。计于诸法无能逮得。所以者何。有所得者则堕颠倒。无所得者乃逮无所从生法忍。是故无所得者乃谓为得。无得无著无依无猗。心如虚空[火*霍]然无迹。是乃名曰无所从生法忍。一切诸法无所生者。诸法无主乃曰法忍。于一切法无所依猗。无求无望。诸法无进无退无双无只。乃曰法忍。诸法无形离于自然。无坏无断无识无尘。无言无辞空无想愿。乃曰法忍。诸法离欲寂然憺怕。法界无本立在本际。无应不应无想不想。无念无说无惟无思无作无力。悉以羸劣虚无恍惚。无固无永无净不净。非常苦空无我寂然。犹如幻化梦中所见。影响野马芭蕉聚沫水中之泡。忍解诸法为若兹也。所可忍者亦无所忍。一切诸法无法非法。无有异法亦无他趣。照曜诸法所解如是。观此诸法名本净。恍惚知之空无。是谓为忍。笃无信乐度于氾流。不怀狐疑不恐不惧。亦无所畏修身正行。永不得身不见空宅是。文殊师利。菩萨所逮无所从生法忍。未曾废舍一切诸想。文殊师利复白佛言。所谓忍者。无所毁伤乃曰法忍。善住意天子问文殊师利。何谓毁伤法。文殊答曰。天子。欲知眼所毁伤可不可色。耳声鼻香舌味身更。意所思念可不可法。假使天子。若有菩萨。眼见色者永无想受。不别好丑不怀思想。无应不应无增无损。晓了本净而达空慧。不念晓了不为众色之所毁伤。耳鼻口身意亦复如是。而于六情无所毁伤悉无所著。此菩萨者立于法忍。于诸生法不有妄想。于无生法亦不无想。于诸漏法亦不怀想。于无漏法亦不无想。不想罪法。不想无罪。不念有为法。不想无为法。不念世法。不念度世法。于此诸法无想念者。是为逮得无所从生法忍。说是法时。六万三千人皆发无上正真道意。万二千菩萨逮得无所从生法忍

于是善住意天子问文殊师利。所谓学道入道地者为何谓乎。文殊师利告天子曰。今仁者问入道地乎。天子报曰。愿欲闻知菩萨道地。文殊常说有十道地。无此谊耶。文殊又报。向者问入道地乎。天子答曰。菩萨不入十道地也。文殊报曰。不闻世尊说一切法犹如幻化。为信此不。答曰信耳。文殊报曰。幻师所化岂有道地具十住乎。天子答曰不也。设幻师化有所至到有所入者。吾亦当住世尊颁宣一切诸法悉如幻化故无所入。假使天子。欲得讲说入道地者。当说无入无所至到。所以者何。一切诸法皆无所入。法不至法。色不入痛。痛不入色。想不入行。行不入想。识不入色。色不入识。取要言之。皆是四种四大所成。眼不入耳。耳不入眼。鼻口身意亦复如是。身不入意。意不入身。所以者何。是诸法者所趣各异境界殊别。愚騃无想无所识别瑕秽态碍。譬如草木瓦石墙壁影响之数。而无言辞。则一种相故无所入。无来无去。天子当知。若有菩萨解法如此。则于诸法无入不入。无想不想。不见入道。不舍道地。于无上正真道而不退转。无所入者住无失法。所以者何。阴种诸入皆为自然。不失一切众生真正清净。是为菩萨入于道地。譬如幻师化作十重交络棚阁。其时幻师化作化人遍处其上。于天子意所志云何。岂为有人处在重阁若入者不。答曰无也。文殊师利报天子曰。菩萨十地当作是观亦如幻化。善住意天子问文殊师利曰。假使人来欲得出家为沙门者。当何以化何除须发何受具戒。云何教授令自谨慎。文殊师利报善住意天子。设使有人来诣我所为沙门者。夫族姓子。若不发心欲得出家。我乃令卿作沙门耳。所以者何。其有建志欲出家者。心无所归。其无所归亦无有来。其无从来则无往者。住一切法无所断绝则住无本。其住无本游于法界而不动转。其于法界无所动者则不得心。其不得心不愿出家。其不愿出家则不发心为沙门也。其不发心为沙门者则无所生。其无所生则尽众苦。其尽众苦则究竟尽。其究竟尽则无所尽。无所尽者则不可尽。其不可尽此无所行。天子解是。当为其人解如此义。其诣我所求欲出家。语族姓子勿得发心作沙门也。所以者何。心本无起便离闇冥。文殊师利复谓善住意。假使有人来诣我所求欲出家。吾当为说。卿族姓子不除须发。乃为善备沙门之业。善住意问文殊师利。所言何谓。文殊答曰。如来说法无所除去亦无所坏。又问。何所不除。答曰。不除于色亦无所坏。不除痛想行识亦无所坏。假使念言。我除须发则住吾我计己有身。不计吾我不自贪身则平等见也。贪着己身乃计须发则成众生。想念除去其不得我不得他人。不我不彼则无吾我。其无吾我不计有身。则除须发无思无想。其无思想。无应不应不住若干。其不住若干则无言教。其无言教。无进不进无双无只。不贪己身不被袈裟。其袈裟者(晋言无秽垢)。其无秽垢则无所有。其无所有则无所住。其无所住则为旷然。其旷然者乃为出家

善住意天子复问文殊。所言思念。其思念者为何谓也。文殊答曰。等于诸法无形无名。愚戆凡夫之所兴念多所望想。故世尊曰。其于诸法无所兴造亦无损耗。是谓思念。又问。何所兴造。答曰。天子当平等度以度平等。其于诸法无得不得亦无所逮。不审不行亦无不行。于此诸法不兴等住不想吾我。亦复不着人寿命识。众生可意断灭计常。阴种诸入想佛法众。亦复不念是戒是毁。尘劳颠倒造立果证望想求度道迹往来不还无著。望想缘觉猗着正觉。是善是恶是罪是福。是为穿漏是无有漏。是为俗业是度世业。是则有为是则无为是则为空无想无愿。是明无明是为解脱。是为离欲是为生为死。是为灭度。兴造如此若干种想。如是行法修道。若斯愚戆凡夫之所念也。贡高自大痴夫所为也。是等为魔及与官属所见阴盖。是故如来。为此党类演出言辞。令除须发去于五阴。奉修五品戒定慧解度知见品

于是善住意天子赞文殊师利。善哉善哉快说此言。如仁者教。文殊师利复谓善住意。假使有人来求出家。吾当谓言。若族姓子不受具戒。尔乃是卿善备出家。又问文殊。此言何谓。答曰。于善住意所趣云何。何谓具戒。具戒有二。一正真戒二邪伪戒。何谓邪伪。若堕颠倒。何谓颠倒。受吾我人倚于寿命。缚着断灭而计有常。或堕邪见荒淫怒痴。贪欲贡高而怀自大。或于欲界色无色界。而念所受驰逸望想。随于起灭证明邪迹。不别善恶宜便之法演狂悖言不识所趣。堕于无明住众邪见。如是法教。皆于正律名之为邪。所以者何。道空平等。其平等者。菩萨所行尚不为退。假使天子。不堕恶友不解所归坚固之要。于诸所受受不当受。而行驰骋。是谓邪戒。若问年岁及所修行。而反从人受信施食。又从异人出家为沙门者。求其迎逆稽首礼节。不能除灭淫怒痴冥。是为邪戒。何谓正戒。假使修正不想平等是谓正戒。一切诸法解之如空无想无愿。是谓正戒。于三脱门而不造证奉行审谛。无想不想无应不应。是谓正戒

文殊师利告善住意。设使处淫怒痴无明恩爱。堕于贪身六十二见。或四颠倒。三品恶行。八邪九恼。九神止处。十不善业。虽在其中而无所著。是谓正戒。譬如一切万物百谷草木众药所生。皆因地出而得长养。其地坦然无所念置。亦不念言我所茂盛。如是天子。敢可成就至于大化皆由戒立。具足成就建立道法三十七品。行者无想法无所置。不念戒具其因成就与不成也。不着欲界色无色界。其不迷惑倚三界者是谓具戒。若立禁戒为成等法信为种法忍。志性清和长育成道。建行如是立笃信戒。便得成就三十七品道法之要也。是去来今现在佛声闻缘觉之具戒也。至三脱门度诸出家而超越去。善住意曰。甚善难及。文殊师利快说具戒。能如是受具足戒者则为正禁非为邪业。文殊师利复谓善住意天子。出家如是具戒。若此教授所施备足如斯。设族姓子不发起戒。是为学戒。天子问曰。此语何谓。文殊答曰。一切诸法悉无所起亦无所受。其有受戒则受吾我。亦着三界故生其中。于天子意所志云何。何谓为戒。答曰。将护沙门二百五十。又问。以何将护。答曰。守身口意名曰将护。二百五十备悉具禁。不为身行亦无所作亦无当作宁可恕当有处所乎。青黄白黑红紫色耶。所向方面。答曰无也。又问。何故。无所有故。由是之故不可恕当。问曰何故。答曰。无所行故。文殊又问。其无所有可名说乎。物如是不。报曰不能。文殊答曰。是故天子当作斯观。所号禁戒不可奉受。此曰乐禁为备戒德。其心清和智慧通达如是行者悉无所有。无能动者永无所趣。戒无所获是真谛戒。不得心处是曰净心。不逮智慧是真智慧心无所作不怀想念。其无所生是谓护心。戒具备悉如是。奉戒智慧若斯。不得心处不念禁戒不逮智慧。若能晓了智慧无处。一切调和无有众疑。识解道教。不见诸法不善之义。其于诸法不见不善则不受戒。其不受戒亦不毁禁。其欲学戒彼则须戒。其须戒者则不退还。其不退者彼名解脱。其解脱者则不合会。其不合会者彼则无漏。其无漏者则行平等。平等行者则无所得。亦不受戒。是故诸法等如虚空了虚无故。所以者何。其虚空者则无所行。是故天子。学戒如此则无禁戒。彼所戒者何所为戒。其不学戒学戒当尔。则学于空。何谓为空。不乐身口不慕其意。无染不染是贤圣戒。如是住者则无所住。其无所住学平等戒。天子又听。如是出家为沙门者。具戒若此禁戒之谓。其人假使饮食衣服三千大千世界。其中所有皆能净毕。所食之功多所救护终不唐举。皆由如是净戒所致。天子又问。今者文殊为谁说此。文殊答曰。为受者施。能亲顺者。彼则毕净能逮此义。尔乃净毕。其不亲不受不逮此义。不念不修不惟。谁受谁为亲近谁能净毕。尔乃正净。此应咨嗟为真众祐。一切诸法究竟悉空无所生慧。是为尽畅清净众祐。凡夫之士能毕众祐罗汉不能。所以者何。凡夫之士能受亲近还致识别惟念精思。吾曾咨受惟察奉行。能施能慕则能净毕。云何净毕。周旋往来没复还生。所生之处净洗诸根。阿罗汉者无有阴种诸入之义。不能周旋何能净毕谁净毕者。其受分卫福布施主。净三品场然后受食。何谓三品。一不得我亦无受者。二不得施者亦无所授。三不得周旋生死处所及净毕竟。是为三。如是净者无所净毕。是故天子吾说斯言。饮食被服三千大千世界所有。皆能净毕无微翳碍。是为处世真正众祐。乃为出家名曰沙门。文殊师利复谓善住意。求出家者吾当告语。若欲出家为沙门者。仁族姓子。不处闲居不在人间。无远无近不起不灭。不独一己不处大众。不在会中。不处屏处。不行乞丐不就人请。不着弊衣五纳之服。不着居家白衣之服。不处旷野不在居室。不慕少求亦不多求。不知止足亦无不足。亦无有行。亦无不行。不在限节亦无中适。不智不愚不慧不闇。行空如此乃曰备悉。其计我身举动进退。若处闲居当行分卫。察己聪慧不离于明。如是天子。此辈伴党。不达正真睹空慧义。是为发起心有所存。所以者何。于彼如此希求望想多所著念。尚无有身何况他人。诸法归空慧了无生。安复欲得限节功勋独处致耶。未之有也。是故天子。其能如是节限平等所修行者不求望想。吾乃谓彼知大限节。若使天子节淫怒痴。了于三界五阴四大诸种众。入此无极节。而知止足不受不舍。不以修行亦无不行。无调不调不寂然。不令尽其能限节。如是法者不与三界而合同尘。彼乃名曰知限节者。所止清净。为无所处悉无所著。复次天子。如来具戒。若有人来欲备禁者吾当为说。若族姓子。不知苦谛。不断习谛。不证尽谛。不奉行道。如是行者能正谛见。所以者何。真正谛者。无有苦谛无有断习。无习不习亦无有尽。不为尽证亦无有道无所由行。设族姓子。不奉四意止乃为平等。所以者何。计无有意亦无所念。不求诸法是为己身。所建意止其无有意。无所念者彼无身痛。无心无法。当何所畏有异难乎。若不奉行四意止者。是为备成清白之法。所以者何。清白法者。无有不善处在其前。亦无善法不断不起。不断不起者是为名曰平等真正安谛之义。其逮平等。尔乃名曰平等之行。若族姓子。不行四神足无有放逸。行四等心五根五力及七觉意八种道者。若等奉行三十七品道义之法。不举不下无言无说。是谓行道。若族姓子。志三十七道品之法。于诸音声从贤圣教不随水流。若能精修遵其所行。不知诸法亦不造证。所以者何。所可言曰三十七品道类之法。假有字耳。观其假名因望想生。计其相者亦无有相。为水所漂因致周旋。其周旋者无所施害。除此名已则无所得。犹如观察此三十七道品之法亦无所除。天子复问文殊师利。何谓比丘慕于修行而独宴处。文殊答曰。假使分别诸法一等一种门相者。譬如虚空。悉无所行皆无众生。是谓修行。又修行者。不处今世不由后世。在于三世皆无所行。至一切法亦无所行。悉了诸法虚伪无实。是谓修行。其修行者。则于诸法无双无只无应不应。是谓修行。时彼众会无央数人。心怀沉吟悉生疑结。此为何谓。当奉何行。何因申畅。如来至真等正觉。演三脱门得至泥洹若能造证三十七道品之法致灭度矣。文殊师利。今者所说。将无倒教乱法之兆。文殊师利。寻时皆知此诸比丘一切众会心所怀疑。告舍利弗。唯卿仁者。为众重任咸共信之。最大智慧如来所叹。又贤者。身离欲尘法而以造证。仁者。久如逮成四谛得造证乎三十七品及三脱门也。舍利弗曰不也。我不得法。当可造立思惟其义及修行者。所以者何。一切诸法悉无所受亦无所生。空无言教空不证空说是语时。三万比丘漏尽意解

善住意天子。赞文殊师利。审如仁者。执慧颁宣深妙法忍兴隆空行。文殊答曰。吾不执慧。一切愚戆凡夫之士执求智慧。所以者何。斯等之类。执持令转集会二品所执。堕于地狱饿鬼畜生诸天人间。所见牵连。假使天子为诸三界。展转牵连轮转无际。所向非一。所生受身各各别异。是为牵连随其宛转。如是牵连展转无休。由是之故不知本际。在于生死乐苦恼根。复次天子。愚騃无智凡夫。不闻与欲俱合怒痴亦然。报应诸见名色同尘。诸佛声闻缘觉菩萨。及逮法忍无所牵连亦无宛转。所以者何。如斯党类其身口心未曾起立。所展转者不得三界何所宛转。是故斯等牵连智慧。若更受身无所弃舍。是执智慧。天子又问。仁者所说毁坏慧乎。答曰不也。又问。何故毁坏令无所除。是等学者是毁坏慧。若不毁坏无所除者不灭寂慧。又问文殊仁无此乎。答曰不也。又问何故。答曰。其有将去覆还。有往来者。则有此事。其无有往无有还者。晓了诸法而无周旋。则无将去亦无覆来。又问文殊。何所章句为最元首。答曰。如是句者我是元首。又问何谓。文殊答曰。若有菩萨。于一文字一章句义而不动者。章句犹归分别四义。何谓为四解章句。一常如审谛。二了空义知为恍忽。三分别无形悉无所生。四于诸所知不以为知不以为患。不造二事。是诸章句最为元首。时佛嗟叹文殊师利。善哉善哉。乃能班宣逮总持义。文殊白佛。我无总持。所以者何。无所得故无可执持。愚騃凡夫乃逮总持。诸佛菩萨无所获致。所以者何。其迷惑者多所执持。何所持乎。依于吾我着人寿命。执持断灭及计有常。执坏贪淫嗔恚愚痴。亲抱所有恩爱贪身。自见五阴四大及诸入。思想多念而反求望。堕若干见六十二疑。有所获致而急执持。是故世尊。愚戆凡夫逮得总持。所以者何。愚夫怀法在心念者。诸佛世尊悉无所持。声闻缘觉诸菩萨等亦复若兹。是故愚夫逮得总持

于是善住意天子问文殊师利。如向者说不得总持。当以何意化于五趣。答曰。其五趣者无所为作。所以者何。吾以消除五趣终始。令其所趣不知处所。诸佛缘觉声闻所趣。愚戆凡夫所不能趣。所以者何。愚夫比数堕于生死。诸明智者消除诸趣。道迹亦然不离生死。况于愚戆凡夫士乎。是故吾身消除诸趣不得总持。所以者何。无所获致当何持也。说是语时。彼众会中五百比丘。诽谤此经而舍驰去。则以现身堕大地狱。时舍利弗报文殊师利。且止勿复演此深法。五百比丘闻之狐疑不肯顺入。自恣骂詈。自谓尊豪而舍驰走。诽谤心乱弘雅之典。则以现身堕大地狱。文殊报曰。唯舍利弗。莫有斯言勿怀疑网。有计是非勿怀犹预。不见有法堕地狱者。惟察诸法无诽谤者。所以者何。一切诸法悉无所生。属舍利弗而宣此辞。令吾休止不说经典。假使族姓子族姓女。依着吾我想人寿命。若江沙劫供养如来承事圣众。随其所安皆给所乏。尽其形寿而不懈休。若有闻此如是像法深妙难解。一切世间所可希闻空无相愿憺怕寂寞归于消灭。无起无灭无人寿命。无常苦空非身之谊。若能得闻如是辈经。闻之诽谤。其族姓子及族姓女。堕大地狱。在大地狱忽闻此经。寻便得出。辄信深经而得解脱。胜善男子善女人江河沙劫奉敬如来供养圣众。着吾我人及计寿命不得至道。闻是法者疾得解脱。佛赞文殊师利。善哉善哉。诚如所言。斯经尊妙。若现于世与佛兴出等无有异。道迹往来不逮无著。于缘觉乘菩萨大乘而见授决。此为最尊等无若干。所以者何。不着吾我。所修平等亦无所得。至于泥洹亦复若兹设有念知言有所得则堕颠倒。佛告舍利弗。此诸比丘五百人等。在于地狱速得灭度。胜于是间愚惑百年护戒。悉知止足堕于颠倒六十二见。所何以何。未曾得闻此深妙法无解脱相也。是族姓子若族姓女。闻此深经入耳思惟疾逮无上正真之道。胜疑余经迷堕颠倒。发意顷须臾乐信此深经者疾得解脱

善住意天子问文殊师利。仁者。乐我净修梵行无沾污乎。文殊报曰。如是天子。则修梵行。设使卿身不劝梵行不修梵行乃为可耳。问曰何谓。答曰。其有所受彼乃修行。其不受者何所行乎。可名行耶。天子又问。如今仁者不修梵行乎。文殊答曰不也。又问。不净行耶。答曰。不修净行。如天子言。以何等故不修净行。无家居不梵行不受不惑。亦无所行亦无不梵行。假使学者清和梵行。悉无所行亦无非行。尔乃名曰大净梵行。其行天子淫怒痴行乃曰正行。游于欲界色无色界。是曰清行。愍伤众生。其不习行淫怒痴事。不游三界。彼不清修。亦无所行。乃谓为行。善住意曰。善哉善哉。文殊师利。所畅辩才而无挂碍。文殊答曰。使卿辩才亦无挂碍。得无碍辩可得处乎。所以者何。计是我故有所倚着则为挂碍

文殊师利复告善住意。欲以是像求净梵行者。设使仁者不执刀剑。贼害一切众生身命。不捉矛戟瓦石大棒。自然危者乃为慈心。天子又问。此言何谓。文殊答曰。所谓众生含血之类义所趣乎。天子报曰。假有名耳。计有吾我乃有众生。含血之类受思想故。故曰众生。依倚颠倒贪计有身故曰众生。所以者何。是故天子。贪见吾我想人寿命。因有假号而演名字。吾当以利智慧剑而危害之。常以此义将养护之令不见缚。当使[火*霍]然不知诸受之所归趣。无所断除。是故天子。当解此义除吾我想。则害众生一切望想。不堕杀生心不怀害。文殊师利复谓善住意。欲使卿身净修梵行。若能奉犯十恶之业。亦慎一切黑冥品事。又复不修诸清白业。善住意又问。斯言何谓。文殊答曰。等黑冥品等诸清白亦复若此。又问文殊。黑冥品事以何为等。答曰以无所作而不退没故曰等矣。一切诸法黑冥亦如。如黑冥等清白亦等。无想念故。文殊又问。以何缘信清白法乎。善住意答曰。所以信之。用其法界无本之故。于善住意所趣云何。可使无本及与法界。修行处所往周旋乎。答曰不也。文殊报曰。是故我言。设能等行黑冥品事不修清白。尔乃相可净修梵行。复谓天子。若剑击头害杀斯人乃修梵行。问曰何谓也。答曰害淫怒痴。自大贡高。贪嫉谀谄。多妒自恣。而受希望痛痒思想。是为天子。名曰伤害。若有修行精进自守。贪欲心起寻便灭除。除不与合寂灭远离。是谓为空不入诸逆。晓了欲心。解如真谛本无所有。此心何生。何所从灭。谁来染污。谁染污者。岂沾污乎。复更思察欲不可得。不见污者亦无被染。则无所得。其无所得则无所生。其无所生则无所舍。其无所舍则无所受。其无所受则无所习。无所习者则曰成就。色痛想行识亦复如是。五阴六衰。十二因缘。不染污心。其有兴发如是伤害。此乃名曰杀人害伤。挝击坏首是为归义。文殊师利告善住意。是故我言。当如是害净修梵行。亦当离佛及法圣众。善住意又问。斯言何谓。文殊答曰。为道慧故。又问令当所信。答曰。当信无本及与法界。又问善住意。宁可捉持无本法界。答曰不也。是故我言离于佛法。何谓圣众。答曰。因缘合故名曰圣众。其圣众者无有集会。为佛弟子故曰圣众。又问。于天子意所趣云何。其无为者无有合会。可离欲乎。答曰不也。文殊师利曰。是故我言。若离圣众乐修梵行。又复善住。其得佛者则名著。得佛圣众则名曰着。不为离欲。其舍众会则为离欲。所谓离欲为法界迹。善住意天子启文殊师利。难及难及至未曾有。文殊又曰。天子当习无反复事勿得孝顺。又问。何谓为不孝顺。文殊答曰。如是善住意。吾无反复亦不无反复。善住意又问。此言何谓。文殊答曰。其有所作。若毁伤者各各兴造若干种事。各归异趣受身不同各得报应。愚戆孝顺各有所作寻受报应。着无量色愚人所作。为身来患或致伤毁。所受诸见各异殊别。或着不着取舍进退。是名反复。为无反复。如佛世尊所演平等。谓一切法各无所作。悉无所作亦无招来。等于平等无所超度。亦无他受不造他作。是则名曰为无反复。善住又问。今文殊师利住于何所。乃能说此立何法忍。文殊答曰。不住法忍。又问文殊。于何所住所宣乃尔。文殊答曰。住幻士处身亦在彼。又问。幻士所住如何。答曰。如无本住幻士住彼。如向者问住于何所。而有所宣在忍法耶。所言法忍但假号耳。何有住处诸法亦然。悉无所作亦无想念。彼无有住及与处所。如是住者乃为众生颂宣道教。如来所住亦复如是而说经义。所以者何。住如无本乃有所宣。一切众生亦复在彼。住于无本而有所说。如来无本无本无异。一切众生而不动转。无本亦如亦不动转。犹若如来所应无本。众生无本其亦若兹。皆一无本而无有二。而无若干故曰无本也

善住意天子。又问文殊师利。所言沙门为何谓乎。文殊答曰。非沙门非梵志乃为沙门。所以者何。不着欲界。不倚色界。不处无色。吾乃谓此为沙门耳。若眼耳鼻口身意不穿漏者乃为沙门。其无志性不与情合。无有因缘亦无不缘。乃为沙门。又复天子。其不着法不着非法。其行寂然无是非心忽然无迹。是谓沙门。何者然耶。其因缘法报应之宜妄从是生。是诸法者亦复虚伪。其不著者无缚无脱是谓沙门。其无有往亦不还反。无进无退无疮无瘢无伤无完。是则名曰净修梵行。是故我言。非沙门非梵志乃为沙门。善住意赞曰。至未曾有志意坚强。所颁宣者无名游迹亦无章句。其意悉达而不忽忘。文殊答曰。吾意不强。所以者何。身自放意意弱不强。天子又问。斯言何谓。答曰。吾以恣意在声闻地住缘觉界。是故放意又复恣意。处诸尘劳。不恶爱欲众冥之患。是故放意。善住意赞曰。善哉善哉文殊师利。悉由宿世供养诸佛众行备悉。宣如来命所说如是。答曰。吾不供养过去诸佛。何者然乎。吾未曾得宿世所历。亦无当来。不从诸佛建立法行。无作不作。是故所作而无有作。不备众行。善住意又问。文殊师利。吾本曾闻如幻三昧。愿显定意示所正受。文殊又问。欲得睹见如幻三昧之境界乎。答曰愿乐欲见。文殊师利。寻时如言幻意三昧而正受矣。应时十方各江沙等诸佛刹土悉自然现。善住意天子自睹东方江河沙等诸佛刹土。其所现者悉是文殊。或以现形若比丘像讲说经典。或复有现比丘尼像优婆塞优婆夷像。如释如梵如四天王。如转轮王色像而现。其体或如天龙鬼神揵沓和阿须伦迦留罗真陀罗摩休勒色像。而现其身。或复显示禽兽飞鸟若干种色。各各现形无量像貌好丑殊别。而为说法。十方一一诸江沙等所现佛土。其亦俱然等无有异为说经典。善住意见此。忻然大悦不能自胜。文殊师利从三昧起。善住意恭恪归命。白文殊曰。向者睹见诸佛国土不可称限。形像无量各各殊别而说经典。文殊问曰。于天子意所解云何。东方所现为审实乎。八方上下有所见者为实虚耶。十方所见何方审谛。善住意答曰。悉虚不实。所以者何。一切诸法皆无所生。由如幻化如幻士相。一切诸法退无常存。自在所作示现变化。推极本末不生不起亦无所灭。文殊师利寻则赞曰。善哉善哉。讲法当然诚如所言。说是语时。彼众会中五百菩萨。以得四禅逮五神通识其宿命。往古世时所作善恶寻自已睹。皆复识命曾更所作。逆害父母。杀罗汉。乱圣众。坏佛寺。斯等罪业本所犯恶余殃未尽。念伤害心倍怀忧结志在疑网。由是之故。不能逮了此深法要。计有吾我所据微翳。卒不肯舍不逮法忍。于时世尊。欲得开化五百菩萨。则以威神现示文殊。文殊师利即从坐起。偏出右肩右手捉剑走到佛所。佛告文殊。且止且止。勿得造逆当以善害。所以者何。皆从心发因心生害。心已起顷便成为杀。时无央数诸菩萨众各心念言。斯一切法悉如幻耳。彼无吾我及人寿命。其意所念察其本末。无有父母无佛法众。亦无作者亦无受者。无行不行亦无果报。意自贪身而堕颠倒。愚戆凡夫悉不能解。心反处颠倒计我父母。所以者何。文殊师利聪明圣达。诸佛世尊所叹。功勋不可思议。道德超殊不可逮及。巍巍煌煌无以为喻。深入法忍了其本际。供养无数江河沙等诸佛大圣。而宣道教。于过去佛所作已办。晓了诸法慧无俦匹。其所说法靡不应时。见诸如来。常怀恭恪稽首自归。今执利剑走向如来。佛告之曰。且止且止。文殊师利勿造逆害当以善害。若分别此察其本际。不可分别何所佛名及法圣众。父母罗汉及庙寺名。其受虚无则无归趣。亦无报应。设一切法虚无不实。所受诸法亦复虚妄。幻譬如空亦如芭蕉梦影野马。离欲虚妄而无坚固。以是之故彼无有罪亦无害者。谁有杀者何谓受殃。如是观察惟念本末。则能了知一切诸法。本悉清净皆无所生。五百菩萨闻是亘然。寻时逮得无所从生法忍。有千比丘远尘离垢得法眼净。五百菩萨欣然大悦善心生焉。心戢静思踊在虚空。去地四丈九尺。以偈赞佛

  诸法悉如幻　　从想而横起
  成形无所有　　诸法悉为空
  反自发望想　　有我而危身
  已识其宿命　　所作罪甚重
  往者怀大逆　　自图其父母
  害罗汉比丘　　犯殃衅甚剧
  由此重罪故　　更苦不可计
  今堕于疑网　　得听空法谊
  圣尊裂结网　　弃捐忧结创
  觉了于法界　　寂无有尘劳
  诸佛权方便　　随流接度人
  趣欲济众生　　决除所沉吟
  无佛无经法　　亦不得圣众
  彼亦无父母　　悉空而自然
  则无吾我人　　无寿亦无命
  无常不断灭　　诸法如虚空
  无罪无报应　　无作无不作
  莫贪身见我　　更历受苦恼
  彼无有生者　　亦无有死者
  所生如幻化　　是为诸法相
  文殊大智慧　　诸法度无极
  手自执利剑　　驰走向如来
  佛亦如利剑　　二事同一相
  无生无所有　　亦无有害者
  两足尊见之　　众生所作罪
  令知殃福业　　亦悉是空耳
  其能达空者　　三世无寿命
  因缘而合成　　解乃无从生
  无罪无报应　　亦复无苦乐
  吾我亦常空　　倚想求安隐
  众生处颠倒　　亦能如本际
  非常苦悉空　　非身无所有
  其能晓如斯　　则免三恶趣
  诸佛无作业　　觉者无所造
  计罪佛亦如　　是故名曰佛
  如佛所解达　　明审了若此
  识别虚无生　　由是畅圣慧
  住于虚空义　　演说无所住
  其身如虚空　　二事俱自然
  若欲求佛慧　　彼法无挂碍
  以知此本际　　成佛无上道
  于世致大圣　　度众生苦恼
  尽除因缘报　　奉修佛大道
  当成为法王　　明眼乃灭度

五百菩萨。宣是执剑经典之时。十方江河沙等佛土。六反震动。其大光明普照世间。其于十方诸佛大圣边。诸侍者各自问佛。此何威德地大震动光靡不照。于时诸佛各告侍者。族姓子知。有界名忍。佛号能仁。颂宣经道。彼有菩萨。名文殊师利。成不退转。手执利剑驰走向佛。欲得开化不达菩萨。因是之故。时佛大圣手执慧刀断生死原。如应说法。劝无央数众生之类。使眼清净心得解脱。逮成法忍学住大道。于是大世尊。以方便随建立神化于彼众会有新学人。德本鲜薄多怀妄想。不见执剑不闻说法。佛之圣旨故令其然。时舍利弗问文殊师利。仁于向者所作凶逆。以何为信。乃能执剑驰走向佛。文殊师利答舍利弗。如卿所言。汝所作逆不可称载。用不能达此报偿故。唯舍利弗。解此义者。知如幻师所造逆事。其幻化者宁有逆乎。报偿亦如。所以者何。其幻师化无有想念。诸法亦然。唯舍利弗。吾欲相问。以诚相反有此剑者乎。答曰不也。为有罪耶。答曰不也。唯舍利弗。罪业虚无。报亦虚无。罪业报应悉虚无者。云何复欲知其处所。舍利弗言。如文殊师利今者所说。无罪无报。一切诸法悉无罪报。此言何谓。文殊师利言。于意云何。唯舍利弗。吾所执剑。何所锻师推成之乎。谁捉持来以相授耶舍利弗言。无作此剑。无执来者以相授也。文殊师利所化现耳。文殊又问。仁能见得化人处乎。刀剑所在如来所言。一切诸法悉如幻化。其相无相不可得处也。唯舍利弗当解斯义。如来至真亦如利剑。文殊及舍利弗。亦如无本。众生亦如。诸法亦如。无本所住。亦复若兹。唯舍利弗。如一切法悉无根本。吾所兴罪报应执剑其亦如也。所积殃衅亦无本也。报应亦如也。向舍利弗复更问言。卿何以故手执刀剑欲与佛诤。譬如修行在于闲居。勤向世尊心念不离乃得解脱。舍利弗又问静思修行。云何世尊。名曰何等。文殊答曰。贪欲妄想则是精思修行。世尊。嗔恚愚戆欲。除此三永令无余。寂然憺怕尔乃亘然。不能蠲除一切尘劳。不为世尊。灭淫怒痴爱欲之难。乃为世尊。贪欲意生。执此欲意一心念佛。欲即消灭。恚痴亦然而得解脱。是故舍利弗。如执利剑驰向世尊。如幻无害。怀三毒者驰心念佛。尘劳悉除。亦如修行闲居专精。一心念佛乃得解脱。舍利弗言。善哉善哉。快说此言。诚如所云。尔时十方诸会菩萨启请世尊。唯然大圣。劝文殊师利愿垂屈意。顾眄我等诸佛刹土。于诸刹土颁宣经道。皆令众生解是意义。文殊师利报诸菩萨。仁等各自察其佛土。诸族姓子寻时受教。各观本土十方处所。各各皆见文殊师利。在于十方诸佛边住讲说经道。善住意天子咨问。启受。宣此如幻所行意义经典之要。诸菩萨等聚会亦然不可称计。诸天子会多少无异。彼诸佛国皆若干种。清净庄严巍巍无量。亦如忍土等无差特。遥见如斯莫不忻然。各各举声而称扬言。以为忻庆。文殊师利道德殊绝。威神光明智无俦匹。威德殊邈过于日月。住此忍土而不移转。普现十方诸佛国土。文殊师利于时引喻。如族姓子幻士善学幻术绝世而无俦匹。不起于坐。所在幻化现若干形。菩萨如是。真学晓了般若波罗蜜。分别法幻悉通其旨。在于此土初不移转。十方佛土诸欲见者。辄现其身于其佛界。所以者何。一切诸法皆如幻故。由是之故所现无难。由如月殿游行虚空。不下人间不念往来。其光所照靡所不遍。虽有所照亦无想念。菩萨如是在于本际未曾移转。普现十方诸佛之土。为现佛身声闻缘觉。为现转轮释梵四王。或为豪贵贫贱困厄身。或入三恶勤苦恼事。或为儒林帝王大臣。或在外道谤佛云云。或入深山学为仙人。所现无限。一切依因。悉令得至无上正真。所现虽尔亦无想念。尔时世尊。告文殊师利。假使有人。值遇此法而得闻者。如佛兴世等无有异。若有菩萨。坐于树下当成佛道。其闻是经福等无殊。亦等道迹往来不还无著。所以者何。是为去来现在诸佛要道。文殊白佛。诚如圣教。安住所化无不受教。如空无想无愿平均。法等亦然。又如无本本际平等。亦如离欲定意平等。是法平等亦复若斯。文殊师利复白佛言。大圣垂恩建立此法。使于后世残末五浊悖乱之俗。若族姓子及族姓女。学菩萨意求大乘者。耳闻此法令诸众生求灭度者。悉当蒙是道德法明各使得所。佛默然可。应时三千大千世界。六反震动。箜篌乐器不鼓自鸣。诸华果树及诸枯树皆生华实其大光明普照世间。皆蔽日月令无光曜。亿百千天住于虚空。欢喜踊跃而雨众华。烧诸名香。复雨杂香捣香。其香芬馥翳于十方。鼓天妓乐其声清和。悉共叉手异口同音举声歌颂。妙哉妙哉。此法难遇。文殊所讲。我等侥幸得闻大化。今日再值转法轮矣。阎浮利人为蒙大庆得闻是经。斯等德本终不唐举。速近受决当成佛道多所开化。于是世尊。赞诸菩萨及诸天子。善哉善哉。如卿等言。其闻是法。佛明此等当成佛道以入灭度。闻之不恐亦不怀懅。笃信爱乐不在生死亦不灭度。文殊师利白佛言。世尊。所建于斯经典。今现感动为先瑞应。然于后世普流十方。佛言如是。文殊师利。今所瑞应皆是建立。此法威恩如来弘慈。圣旨令然一切蒙济。佛语文殊。当复重显斯深经典。佛言至诚终不虚妄。此三脱门多所救济。当令此法后世普流。文殊师利复白佛言。我亦堪任建立此法演真章句。无我无人无寿无命无意无可。不堕断灭不堕计常。无有尘劳亦无诤讼。则为光显于此经典。如我至诚所言不虚。然后将来五浊之世。令普流布。吾今要誓不具成佛。无法圣众。无罪报应。无去无来以此至言。令是要法于将来世皆遍流布。有了是经。而不受欲亦不离欲。无有恚痴而有慈心。无有智慧。无名无色。无缘无见。不兴生死。无身不生身。无心不生念。不惟法不意止。无五阴无四大。无诸入眼色耳声鼻香口味身更心法亦复如是。不处欲界色无色界。心等如地而无憎爱。诸法不损亦无增长。则宣此经。如斯经典后世普流。不在至诚。不睹审实。不赞说道。不至道果。亦无道迹。不往来。无不还。不无著。不缘觉。无诸果证。不如来。无佛法。不无畏。无慧不慧。不圣不空不寿。不想不无想。不愿不无愿。不得果证。无见不见。不至道。无明无冥亦无解脱。不度不无度。不彼际。不此岸。不中流。无名无不名。如是真言。当令此经后益流布。又计是经。不应不脱。不精进无所懈。不勤力。不殆废。以此至诚法当普流。往本所生。无去无来。过去无人。不度众生。亦无灭度。人不可得。法无有超。亦无所灭。无有作者。亦无坏者。无将无反。不往不还。无举无下。无当来佛。如是像法无所照曜。无现在佛亦不畅法。以是之故法当普流。是经所说不戒不犯。不定不乱。不慧不愚。不解不缚。不慧见不无慧。此正真言令经普流。不施不悭。不戒不毁。不忍不诤。不进不殆。不禅不乱。不智慧不愚闇。菩萨大士。此真谛言令法普流。无凡夫无学者。无罗汉无缘觉无佛道。不因缘不无缘。当令此法普流世间。不坐佛树。不转法轮。不叹佛。佛不现在。不众生。不灭度。不如来。所以者何。一切诸法永至灭度。当令此经普流世间。文殊师利。宣是建立经典要时。此三千大千世界六反震动。其大光明普照十方。虚空中唱无极音。善哉善哉。文殊师利。实如要誓。假使江河沙等诸魔官属。欲求方便毁坏此经。欲令毁散终不能乱。此微妙法令不流通。所以建立是要法者。若族姓子及族姓女。受此经典受持讽诵。闻之信乐。一切皆脱诸魔事业。入佛道慧。于是弥勒菩萨前白佛言。今日何缘地大震动。光明遍照空中畅音。佛告弥勒。何用问为。所以者何。志小下士不识大义堕于憍慢。斯等长夜不得安隐。弥勒白佛。唯圣说之。多所愍哀多所安隐。必当慈念诸天人民共信乐之。佛告弥勒。斯经典者。四十七亿百千那术诸佛。于此地上建立说之。皆亦文殊之所发问。善住意天子与共咨启。弥勒来世当成无上正真之道最正觉时复说此经。其余贤劫诸兴如来亦俱同然。弥勒复问佛言。文殊师利善住意天子。从来久如闻此经典。佛告弥勒。文殊师利善住意天子。闻是法来七百万阿僧祇劫。从普华超师子步德王光首如来至真等正觉所闻。其于空中唱大音声。净居诸天闻讲此法。各各劝助咨嗟而行。是故地动。弥勒菩萨复白佛言。若族姓子及族姓女受是经者。持讽诵读为他人说得何功报。佛告弥勒。于意云何。过去当来今现在佛。戒定慧解度知见品。广兴布施持戒忍辱精进一心智慧。使成无上正真道慧。已成当成现在成者。合此德本功祚福勋宁多不。弥勒曰。多矣世尊。不可思议。一如来德其福难计。况一切佛。假使德本有形像者。十方佛土不能悉受。佛告弥勒。我故嘱累殷勤相喻。其族姓子及族姓女。闻是经典受持讽诵。为他人说福多于彼何况奉行。所以者何。过去当来今现在佛之所咨讲悉由是生。佛说是经时。江河沙等众生之类发菩萨心复倍是数。逮不退转成得法忍法眼净者各复倍倍。如是十方悉来会者一切菩萨忻然大悦善心生焉。稽首佛足歌叹此法。侥再得闻无以为喻。忽然不现各归本土

贤者阿难前白佛言。此经名何。云何奉持。佛告阿难。是经名曰于一切法无起不灭三昧要品。又名降毁魔场。当怀持之。又名普遍十方定意要慧文殊师利之所讲说。又名如幻所说。当奉持之。是经典者能调化人。阿难当受持讽诵读为他人说。佛说如是。比丘菩萨。文殊师利。善住意天子。弥勒菩萨。贤者阿难。诸天龙神。阿须伦。世间人。闻经莫不欢喜

佛说如幻三昧经卷下


佛说如幻三摩地无量印法门经

    No. 372 [No. 321]

佛说如幻三摩地无量印法门经卷上

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

如是我闻。一时世尊。在波罗奈国仙人堕处鹿野园中。与大苾刍众二万人俱。菩萨摩诃萨一万二千。其名曰师子菩萨摩诃萨。师子意菩萨摩诃萨。善住意菩萨摩诃萨。胜思惟菩萨摩诃萨。持世菩萨摩诃萨。人授菩萨摩诃萨。水天菩萨摩诃萨。宝积菩萨摩诃萨。隐密菩萨摩诃萨。贤护菩萨摩诃萨。电天菩萨摩诃萨。遍照菩萨摩诃萨。智积菩萨摩诃萨。不休息菩萨摩诃萨。不空见菩萨摩诃萨。慈氏菩萨摩诃萨。妙吉祥童真菩萨摩诃萨等。复有二万天子。所谓善道天子。安意天子等。是诸天子。皆悉安住大乘法中。并余无数百千大众。咸悉恭敬围绕世尊。听受说法

尔时会中有一菩萨摩诃萨。名胜华藏。从座而起偏袒右肩。右膝着地。合掌顶礼前白佛言。世尊。我有所问。惟愿如来应供正等正觉。哀愍听许。略为宣说。佛言。胜华藏。如来应供正等正觉。随有问者。即为开晓。今恣汝问。当为汝说

尔时胜华藏菩萨摩诃萨白佛言。世尊。菩萨摩诃萨云何得不退转于阿耨多罗三藐三菩提。成就五神通。得如幻三摩地。得是三摩地已。诸有众生善根成熟。即以自神力。如应现化。随诸众生所起信解。即为说法。而令速证阿耨多罗三藐三菩提

佛告胜华藏菩萨摩诃萨言。善哉善哉。胜华藏。汝今善问如是等义。汝于过去。已曾亲近俱胝那庾多百千诸佛。于诸佛所。深种善根。而复能为一切众生。起悲愍心。汝应善听。极善作意。今为汝说于是胜华藏菩萨受教而听。佛言。胜华藏。当知有一法若菩萨摩诃萨能具足者。即得如幻三摩地。得是三摩地已。诸有众生善根成熟。即以自神力如应现化。随诸众生所起信解。即为说法。而令速证阿耨多罗三藐三菩提。胜华藏。所言一法者。谓无依止法。若菩萨摩诃萨成就此法已。乃至遍三界中不作依止想。若内若外悉无依止。由如是故。即具正见。以正见故。得正相应及正所行。是故获得无障碍慧慧无碍故。心亦无碍。于无碍心中即起正行。胜华藏。云何菩萨能起正行。谓了一切法悉从缘生。于缘生法中。无有少法而实积聚。何以故。以彼诸缘皆不实故。是中云何有法可生。若法缘生。即是无生。是故一切法皆悉无生。菩萨若能如实了知一切法无生。即得成就诸菩萨道。所有一切众生根欲及事。能以悲心而悉随入。得深信解。了知一切法悉如幻化。乃至分别一切法。皆是化事。以彼分别毕竟空故。而一切法亦复皆空。如是知已。即得如幻三摩地。得是三摩地已。乃至能令众生速证阿耨多罗三藐三菩提。胜华藏菩萨复白佛言。世尊。今此会中。有几许菩萨摩诃萨。得是如幻三摩地。佛言。胜华藏。今此会中。有慈氏菩萨。妙吉祥童真菩萨等。六十大士。皆已被于不思议铠。得是如幻三摩地法门。胜华藏言。余世界中。亦有菩萨大士得是三摩地邪。佛言。胜华藏。西方过此百千俱胝佛刹。有世界名极乐。有佛号无量光如来应供正等正觉。现住说法。教化众生。彼佛刹中。有菩萨名观自在。复有菩萨名大势至。彼二菩萨得是三摩地。于七夜中。为余菩萨说是法门。诸菩萨闻已。亦得是三摩地。胜华藏菩萨复白佛言。世尊。彼佛刹中所有菩萨。得如幻三摩地者。应多于此。何以故。此佛刹中诸菩萨等。于慈氏菩萨。妙吉祥童真菩萨。所不能专勤请问听受如是法门。是故少有得此三摩地者。佛言。胜华藏。如是如是。如汝所说。彼佛刹中所有菩萨。安住如幻三摩地者。无量无数不可称计

尔时胜华藏菩萨摩诃萨复白佛言。世尊。惟愿如来应供正等正觉。如其所应现神通相。使彼佛刹二大士等。来此娑婆世界。复令此会大众得见极乐世界。瞻睹无量光如来应供正等正觉。所以者何。此佛刹中诸善男子善女人。若得见彼无量光如来。即能发起阿耨多罗三藐三菩提心。各各愿生于彼佛刹。普得不退转于阿耨多罗三藐三菩提。又若彼二大上来此刹中。所有此土修菩萨乘诸善男子善女人。善根增长或复于彼二大士所闻说法已。即令获得如幻三摩地

尔时世尊受胜华藏菩萨摩诃萨请已。即从眉间放大光明。其光金色。于此三千大千世界普遍照耀。其中所有须弥山目真邻陀山。摩诃目真邻陀山。雪山轮围山。大轮围山等。乃至极余世界边际。一切山石丛林暗暝等处。此金色光而悉照破。世间所有日月光明广大炽盛。以佛光明所映蔽故。犹如眼光其量微小。是时光明金色晃耀。照彻西方百千俱胝佛刹。乃至极乐世界无量光如来所。其光旋环绕佛七匝。普照耀已。于彼佛前隐而不现。是时极乐世界所有菩萨声闻。及余众生之类。乘前光明。悉能见此娑婆世界。及见释迦牟尼如来。菩萨声闻大众围绕。如观掌中庵摩勒果。皆生欢喜爱乐之心。咸作是言。南无世尊释迦牟尼如来应供正等正觉。时此娑婆世界释迦牟尼如来。会中所有诸菩萨摩诃萨。苾刍苾刍尼。优婆塞优婆夷。梵王帝释护世四王。并余天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。人非人等。悉能见彼极乐世界。及见无量光如来菩萨声闻大众围绕。光明炽盛如妙高山。映彻照耀遍此刹中。如明眼人于一搩手地量之中。观余面轮而不劳力。此彼互见亦复如是。时此会众。得见彼佛及彼世界无数百千俱胝那庾多功德圆满庄严事已。皆生欢喜爱乐之心。咸作是言。南无世尊无量光如来应供正等正觉。作是言时。会中有八万四千众生。皆发阿耨多罗三藐三菩提心。以此善根当得生于极乐世界

尔时彼世界中所有菩萨声闻大众。又复生希有心。合掌恭敬。遥向世尊释迦牟尼如来。而伸顶礼重作是言。南无世尊释迦牟尼如来应供正等正觉。发是言时。彼极乐世界六种震动。所谓震遍震等遍震。动遍动等遍动。击遍击等遍击。涌遍涌等遍涌。爆遍爆等遍爆。吼遍吼等遍吼。现如是相已。时彼会中观自在菩萨。大势至菩萨。俱白无量光如来言。希有世尊。希有善逝。彼释迦牟尼如来所有名字。称念中间。能令大地六种震动。彼佛告言。善男子。不但此佛刹中。称扬释迦牟尼如来名字之时有如是相。别余无量佛刹之中。亦悉称扬彼佛名字。而诸佛刹蒙光照触。彼彼皆悉六种震动。是诸刹中无量无数众生之类。若得闻是释迦牟尼如来名已。悉得善根增长。不退转于阿耨多罗三藐三菩提

复次彼会菩萨众中。有四十俱胝菩萨。得闻释迦牟尼如来名已。咸起是愿。普集所有一切善根。悉以回向阿耨多罗三藐三菩提。即时观自在菩萨。大势至菩萨。前诣无量光如来所。各各头面礼彼佛足。肃恭瞻仰。退住一面。俱白佛言。世尊。彼释迦牟尼如来前所放光。昔未闻见。甚为希有。何因缘故。现是光相。若无因缘。彼佛世尊不放光明。其事云何。愿佛为说。彼佛告言。善男子。如是如是。如汝所说。释迦牟尼如来所放光明非无因缘。彼佛世尊。将欲宣说菩萨安住三摩地宝最上法门。为说法故先现是相。时观自在菩萨大势至菩萨。复白彼佛言。世尊。我等今者。乐欲往彼娑婆世界。瞻礼亲近世尊释迦牟尼如来应供正等正觉。听其说法。惟垂哀许。佛言。善男子。汝等可往。今正是时。汝等往故。转复发起彼佛世尊。宣说法要。时二菩萨蒙佛许已。即于诸菩萨摩诃萨众中。顾谓八十四俱胝菩萨言。诸善男子。我等今往娑婆世界。瞻礼亲近释迦牟尼如来。听其说法。所以者何。彼佛世尊。最上希有。能为难事。舍余清净严好佛土。乐于娑婆世界秽恶土中。以大悲愿力教化众生。彼诸众生多起下劣信解。勇发贪嗔痴等诸业烦恼。而佛世尊。能于其中成就阿耨多罗三藐三菩提果。是为难事。汝等宜应随我往彼。时诸菩萨欢喜随顺

复次会中有诸大声闻。异口同音前白佛言。世尊。彼释迦牟尼如来所有名字。若暂闻者尚得善利。何况亲往现前瞻礼。使瞻礼者肉眼清净。我等欲往愿佛听许。佛言可往。今正是时。尔时八十四俱胝菩萨。并诸大声闻。恭敬围绕观自在菩萨。大势至菩萨。来诣娑婆世界。菩萨行时。如其所应。现诸色相神通事业。时八十四俱胝菩萨。各各化现八十四俱胝殊妙楼阁。一一楼阁高十二由旬。广八由旬。四方四隅周遍妙好。是诸楼阁。有以金银。吠琉璃。颇胝迦。赤珠码瑙。琥珀等七宝合成。有以金银所成。有以金银吠琉璃成。有以金银吠琉璃码瑙所成。有以金银吠琉璃码瑙颇胝迦成。有以金银吠琉璃颇胝迦琥珀赤珠所成。有以赤栴檀香。龙实栴檀香。沉水栴檀香成。有以众妙栴檀香等所共合成。有以优钵罗华。钵讷摩华。俱母陀华奔拏利迦华所成。有以须摩那华。婆利师迦华。瞻波迦华。波吒罗华。阿提目多迦华成。有以驮努瑟迦华所成。有以曼陀罗华摩诃曼陀罗华成。有以曼殊沙华摩诃曼殊沙华。噜左华摩诃噜左华。作讫啰华摩诃作讫啰华。苏啰毗作讫啰华摩诃苏啰毗作讫啰华。赞捺啰华摩诃赞捺啰华。苏啰毗赞捺啰华。赞讷卢怛摩华。萨他罗华摩诃萨他罗华。苏啰毗萨他罗华等。所共合成。有以一切妙华庄严所成。有以无数百千殊妙色相庄严所成。如是一一楼阁之中。皆悉出现八万四千清净光明

佛说如幻三摩地无量印法门经卷上佛说如幻三摩地无量印法门经卷中

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

复次彼彼楼阁周匝。或有天女执众乐器。所谓琵琶筚篥琴笙箜篌螺鼓小鼓拍板等类。作妙音乐。或有天女捧赤栴檀香末。或有天女。捧龙实栴檀香末。或有天女捧沉水栴檀香末。或有天女。捧黑沈栴檀香末。或有天女。捧众妙栴檀香末。或有天女。执优钵罗华俱母陀华奔拏利迦华。或有天女。执曼陀罗华摩诃曼陀罗华。或有天女。执播噜沙迦华摩诃播噜沙迦华。或有天女。执曼殊沙华摩诃曼殊沙华。或有天女。执噜左华摩诃噜左华。或有天女。执作讫啰华摩诃作讫啰华。三满多作讫啰华。苏噜唧啰作讫啰华。或有天女。执赞捺啰华摩诃赞奈啰华。苏噜唧啰赞奈啰华。或有天女。执萨他罗华摩诃萨他罗华。苏噜唧啰萨他罗华。或有天女。捧天妙衣。及妙华妙香。涂香末香等。随处而住。而彼一一楼阁之中。各各有大妙宝庄严师子之座。化如来像。安处其上。三十二相庄严具足。又复一一楼阁之中。化出八万四千真珠璎珞。其珠三色。谓青白赤。又复一一楼阁之中。化出八万四千殊妙宝幢。以诸金铃网覆其上。天衣垂下而为严饰。又复一一楼阁之中。化出八万四千宝瓶。盛诸妙香。又复一一楼阁之中。化出八万四千上妙宝盖。以百千种极妙彩绘。而为严饰。又复一一楼阁之中。化出八万四千多罗行树。及八万四千七宝行树。一一皆以宝绳交络。又复一一楼阁之中。化出八万四千悬铃宝网。微风吹动出和雅音。如百千种妙音乐声。又复一一楼阁之中。化出宝池是池纯以金沙布底。七宝界道。琉璃水精周匝庄饰。八功德水充满其中。池中出生优钵罗华。钵讷摩华。俱母陀华。奔拏利迦华等。其池复有凫雁鸳鸯异鸟和鸣。八万四千妙宝行树。周匝围绕。上以八万四千宝绳。交络而为严饰。又复一一楼阁之中。出大光明。广照八万四千由。尔时观自在菩萨摩诃萨。大势至菩萨摩诃萨。及彼所来诸菩萨众。以是殊妙庄严一切楼阁。一时置在一楼阁中。诸庄严事互不相碍。譬如力士屈伸臂顷。到此娑婆世界。而诸菩萨。以神通力故。各以所现八十四俱胝功德庄严殊妙楼阁。置于佛会。如其所应神通威力。令此娑婆世界地平如掌。而佛会中亦不迫窄。是诸楼阁出大光明。照此三千大千世界。是时彼二菩萨。前诣佛所。头面礼足。右绕三匝退住一面。俱白佛言。无量光如来应供正等正觉。致问世尊释迦牟尼如来少病少恼动止轻利安乐行不。彼二菩萨复白佛言。我等菩萨声闻。于极乐世界见佛世尊。故来瞻觐。时此娑婆世界佛会之中。所有菩萨声闻大众。见此世界清净严饰。及见无数广大楼阁已。咸起是念。如来何故现是威力。而能令彼诸大菩萨来至于此

尔时胜华藏菩萨。承佛威神。从座而起前白佛言。希有世尊。希有善逝。今此娑婆世界如是严饰。及现楼阁。为是如来威神力邪。为是彼二菩萨威力所变。愿佛为说

佛告胜华藏菩萨摩诃萨言。胜华藏。此非如来威神之力。乃是观自在菩萨摩诃萨。大势至菩萨摩诃萨。威力所变。故现是相。胜华藏复白佛言。希有世尊。希有善逝。此二大士。已得不可思议愿力清净善根洁白。乃能有是神通威力。佛言胜华藏。如是如是。如汝所说。此二大士已于俱胝百千那庾多劫。积集善根清净洁白。又复已得如幻三摩地法门。从是三摩地中。能现如是种种色相神通等事

复次胜华藏。且置是事。汝观东方为有何相。胜华藏菩萨承佛圣旨。即以无碍清净天眼。观见东方殑伽沙数佛刹之中。有殑伽沙数诸佛世尊。彼一一佛前。皆有观自在菩萨摩诃萨。大势至菩萨摩诃萨。各礼佛足。又闻其言。无量光如来应供正等正觉致问世尊少病少恼动止轻利安乐行不。及见无量广大楼阁妙宝严饰。如是南西北方。四维上下。一一皆见殑伽沙数佛刹之中。有殑伽沙数诸佛世尊。彼一一佛前皆有二大士各礼佛足。又闻其言无量光如来应供正等正觉。致问世尊少病少恼动止轻利安乐行不。及见无量广大楼阁妙宝严饰。时胜华藏菩萨见是相已。复白佛言。希有世尊。希有善逝。此二大士真实已得最胜如幻三摩地门。能于十方诸佛刹中。悉现其身神通威力不可思议

尔时世尊。观察众会。如其所应现神通相。即时会中一切大众。以佛威神力故。皆如胜华藏菩萨。亦能见彼十方世界如殑伽沙数诸佛刹土。彼彼刹中佛世尊前。皆有二大士。各礼佛足。乃至见彼广大楼阁妙宝严饰。当此众会见是相时。会中有三万二千众生发阿耨多罗三藐三菩提心

尔时胜华藏菩萨摩诃萨。复白佛言。世尊。此二大士。于何佛所发阿耨多罗三藐三菩提心。而所发心为久近邪。其佛如来。名字何等。惟愿世尊。善为宣说。令余菩萨知其所修。如其所行。毕竟皆得行愿圆满。佛告胜华藏菩萨言。汝应善听。极善作意。今为汝说。是时胜华藏菩萨受教而听

佛言胜华藏。乃往过去阿僧祇阿僧祇劫前。又经广大无量无边不可思议劫数。过是劫已。将此三千大千世界。碎为微尘。一尘一劫。过是微尘劫数之前。时有世界。名无量功德宝庄严普现妙乐。有佛出世。号师子游戏金光王如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛刹中。所有功德庄严等事。广大无量。胜华藏于汝意云何。彼无量光如来应供正等正觉。极乐世界中所有功德庄严。是为多不。胜华藏言。甚多世尊。无量无边不可思议。佛言胜华藏。我以譬喻略明斯义。譬如有人。取彼一毛。折为百分。将其一分于大海中取一滴水。胜华藏。于汝意云何。彼毛端水是为多邪。余大海水而为多邪。胜华藏白佛言。世尊。毛端之水。极为微少。余大海水深广无量。佛言胜华藏。汝今当知无量光如来极乐世界。所有功德庄严等事。如毛端水。师子游戏金光王如来无量功德宝庄严普现妙乐世界所有功德庄严等事。如大海水。又师子游戏金光王如来会中所有菩萨声闻之众。比无量光如来会中菩萨声闻多百千倍。彼佛世尊。随应演说三乘之法。胜华藏。以要言之。彼师子游戏金光王如来刹土之中所有功德庄严。及妙乐事。假使我于殑伽沙数劫中。广以辩才。而亦不能说其边际

复次胜华藏。彼师子游戏金光王如来法中。有王名胜威。其王于千世界中。自在特尊。广大富盛。正法化世。有七万六千最上园苑。王所受用。其王诸子。各有一万园林受用。胜华藏菩萨白佛言。世尊。彼佛刹中有女人不。佛言不也。善男子。彼佛刹中。尚无女人名字可闻。况有女人邪。其中生者。皆是化生清净洁白。咸修梵行。一切众生。皆以法喜禅悦为食。不受一切粗恶叚食。胜华藏。其王与子。于八万四千俱胝岁中。尊重供养师子游戏金光王如来。彼佛世尊。知王深心起净信已。即为宣说无量印善巧法门。胜华藏。何等名为无量印善巧法门邪。谓诸菩萨摩诃萨所起诸行。未尝于限量法中而有趣求。何以故。以诸菩萨行无量布施。无量持戒。无量忍辱。无量精进。无量禅定。无量智慧。于无量生死中随入。于无量众生中慈愍。无量刹土庄严。无量声闻庄严。无量色相成就。具足无量音声。及无量辩才。胜华藏。诸菩萨乃至一发心所有善根。尚起无量广大之心。回向一切。况复积集无量行愿。普用回向一切众生。使诸众生悉证无生。如佛涅槃而得涅槃。善男子。此即名为无量回向。以是回向故。即空无相无愿而悉无量。真如实际法界。亦复无量。解脱无生离诸系着。善男子。以要言之。无量义者。即一切法无量。何故说一切法为无量邪。以一切法无生无灭故无量。若法无量即无生无灭。若法无生无灭即无量。是名无量印法门。胜华藏。尔时彼师子游戏金光王如来。为彼胜威王。如是宣说无量印善巧法门时。其王于一切法而得觉了

复次胜华藏。彼胜威王。于佛法中修禅定行。后于一时安处禅定。其王忽然左右二胁。生二莲华殊妙可爱。清净犹如龙实栴檀香。于其华中生二童子。跏趺而坐。其王见已叹未曾有。即向童子说伽陀曰

  汝或是天或是龙　　或复夜叉罗刹类
  若人非人若神仙　　汝等何名为我说

时右胁生者童子。即说伽陀。答彼王曰

  于一切法空性中　　汝今问我何名字
  然彼诸法本无名　　何故以名而见问
  法空性中无天龙　　亦无夜叉罗刹类
  人与非人若神仙　　彼等一切无所有

时左胁生者童子。亦说伽陀。答彼王曰

  名与名体二皆空　　能名所名俱无有
  于一切法无名中　　但以强名而表示
  当知真实名自性　　是中非见亦非闻
  本来无灭复无生　　何故以名而见问
  诸所作事所有名　　既以假名而表示
  是故我今亦假名　　一名宝严二宝上

彼二童子说伽陀已。宿善力故得五神通。即与胜威王。同诣师子游戏金光王如来所。到已头面各礼佛足。右绕三匝。退住一面。彼二童子。合掌向佛异口同音。说伽陀曰

  我今当以何等物　　供养正觉二足尊
  此事愿佛开我心　　令我闻已心安定
  我今无华亦无香　　复无饮食及衣服
  诸妙供养悉皆无　　将何供养最胜者

尔时彼佛。为二童子。说伽陀曰

  若能一发菩提心　　广为众生作利乐
  此即名为真供养　　正觉三十二相者
  若人以彼殑伽沙　　是等数量诸佛刹
  满中胜上诸妙华　　供养世尊救世者
  若人至心但合掌　　发起无上菩提心
  是人所获胜福门　　倍多于前无有量
  异此何名真供养　　异此何名胜依止
  若人能发菩提心　　我说名为上智者

佛说如幻三摩地无量印法门经卷中佛说如幻三摩地无量印法门经卷下

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

复次胜华藏。尔时彼二童子。向佛世尊复说伽陀曰

  能仁作大师子吼　　天人一切普得闻
  我等今对世尊前　　各发诚实最上愿
  我等乃至未来际　　愿我所行经多劫
  随入生死轮回中　　救度无数众生类
  我等今者以此缘　　尽未来际悉思念
  普为利乐诸众生　　于无边劫行无懈
  我等从今日已去　　永灭贪嗔痴等垢
  十方现在佛世尊　　证我所说诚无妄
  我等今发菩提心　　不乐声闻缘觉果
  我等若有乐小心　　决定当招妄语报
  我所不乐二乘果　　但以悲心为众生
  纵经俱胝多劫中　　愿我常行而不懈
  如佛世尊所成就　　如应佛刹广庄严
  愿我当来得佛时　　刹土倍多俱胝数
  又愿当来佛刹中　　无有声闻缘觉众
  纯一菩萨所庄严　　广集无量诸智聚
  愿我得是庄严已　　当令众生得离垢
  从诸佛法所出生　　普使当持佛法藏
  若我今时诸所说　　真实无妄无别异
  愿此大海及山川　　乃至大地皆震动
  当发如是愿言时　　大地即时皆震动
  不鼓音乐自然鸣　　出微妙音遍十方
  天雨众华众妙香　　殊丽严好极可爱
  俱胝百千妙天衣　　周遍缤纷而散布

尔时彼二童子。各发阿耨多罗三藐三菩提心。胜华藏于汝意云何。彼时胜威王者岂异人乎。即今无量光如来应供正等正觉是。彼时宝严童子者。今观自在菩萨摩诃萨是。宝上童子者。今大势至菩萨摩诃萨是。是二菩萨。于彼师子游戏金光王如来所。首发阿耨多罗三藐三菩提心

复次胜华藏菩萨前白佛言。世尊。此二大士甚为希有。如是名字难可得闻。而复具足甚深信解。所发菩提心无与等比。世尊。此二大士于师子游戏金光王如来之后。又复供养几许诸佛。佛言。善男子。所有殑伽河沙尚可知其边际数量。此二大士于彼佛后其所供养诸佛如来。我亦不能知其边际。何以故。此二大士悉已被于不思议铠。具足无量殊胜功德。是故不能知其边际

尔时胜华藏菩萨摩诃萨复白佛言。世尊。彼无量功德宝庄严普现妙乐世界。在何方处。佛言。善男子。今此西方极乐世界。即是彼往昔时无量功德宝庄严普现妙乐世界。胜华藏言。此二大士。当于何时成就阿耨多罗三藐三菩提果。当得何等佛刹功德庄严。而佛寿量其数几何。复有几许菩萨之众。惟愿如来应供正等正觉。广为悲愍利乐一切世间天人宣说此二大士。当成佛事。令余菩萨闻已悉得大愿圆满。佛言。胜华藏。汝应善听。极善作意。今为汝说。是时胜华藏菩萨受教而听。佛言。善男子。当知西方无量光如来寿命无量。极不可计。假使俱胝那庾多百千劫中。亦复不能说其边际。其佛正法住世。八万四千那庾多劫。佛涅槃后。以诸众生善根力故。亦得值遇余佛出世。而诸菩萨安住念佛三昧常得见佛中无间缺。善男子。又复无量光如来涅槃之后。其说法处。七宝庄严妙莲华树。自然演出微妙法音。经于一夜至明旦时。观自在菩萨摩诃萨。即于众宝庄严菩提树下。安处其座。成等正觉。成正觉已号曰普明高显吉祥峰王如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。胜华藏。彼佛刹土功德庄严等事。假使我于殑伽沙数劫中。巧以譬喻言词。而亦不能说其少分。又善男子。如是佛刹功德庄严。若以师子游戏金光王如来刹土功德庄严而较量者。即前百分不及一分。千分百千分。亦不及一。数分喻分乃至乌波尼杀昙分。皆不及一。又彼刹中无有声闻缘觉名字纯一清净大菩萨众。又善男子。总以无量光如来会中一切声闻缘觉菩萨。合集较量。而普明高显吉祥峰王如来会中菩萨之众。亦复倍多。其佛寿命。九十六俱胝那庾多百千劫。正法住世。六十俱胝劫。胜华藏菩萨白佛言。世尊。彼佛世界岂不亦以极乐为名邪。佛言不也。善男子。彼世界名众宝普严。彼佛如来。随其所应作诸利乐。而此大势至菩萨摩诃萨于彼法中随佛寿量住世久近。承事供养。乃至彼佛入涅槃后。奉持佛法令法久住。至于最后法欲灭时。大势至菩萨于其刹中。得成阿耨多罗三藐三菩提果。成正觉已号曰善住功德宝峰王如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛刹中所有功德庄严等事。菩萨大众皆悉具足。其佛寿命及正法住世。与普明高显吉祥峰行如来皆悉同等。一切圆满不增不减

复次佛告胜华藏菩萨摩诃萨言。汝今当知普明高显吉祥峰王如来。善住功德宝峰王如来。如是名字。若善男子善女人暂得闻者。是人当得不退转于阿耨多罗三藐三菩提。又胜华藏。若善男子善女人。得闻过去师子游戏金光王如来及彼未来普明高显吉祥峰王如来。善住功德宝峰王如来名字之者。随彼聚落族氏之中。一切女人皆转女身而成男子。四十俱胝劫中。背于生死。转生当得清净出家。常得见佛闻法。承事僧伽。世世所生具宿命智。及得总持无碍辩才。不退转于阿耨多罗三藐三菩提

尔时世尊作是说时。会中有九十六俱胝天人。异口同音作如是言。南无十方三世一切诸佛及未来世普明高显吉祥峰王如来。善住功德宝峰王如来。普集一切诸佛。一切善利。我皆随喜。我等悉发阿耨多罗三藐三菩提心。即时诸佛咸为记言。汝等当得不退转于阿耨多罗三藐三菩提。尔时会中有七千菩萨得无生法忍。八十四那庾多众生远尘离垢得法眼净。八千苾刍无复诸漏得心解脱。尔时观自在菩萨摩诃萨。大势至菩萨摩诃萨。于此会中如其所应现诸色相神通事已。一切众会皆悉得见。是时十方无量阿僧祇诸佛世尊见如是相。及闻宣说彼二菩萨当成佛事已。咸共赞言。希有世尊释迦牟尼如来。能善护念是二菩萨。我等诸佛亦共称赞

复次胜华藏菩萨摩诃萨白佛言。世尊。佛所宣说如是甚深微妙经典。若善男子善女人。有能受持读诵为他广说者。得几所福。佛言止止。善男子。勿致斯问。何以故。诸有劣信解者。于佛所说如是深经。不能生信。故我不说。胜华藏菩萨白佛言。世尊。今此会中亦有广大具深信解诸善男子善女人等。惟愿如来略为宣说受持功德。与后末世一切众生作大明照

佛言胜华藏。谛听谛听。今为汝说。时胜华藏菩萨受教而听

佛言。善男子。假使有人。有大势力。福德具足。悉能了知众生界分。作如是言。如佛所说世界无边众生无尽。我能于彼一切众生顶肩荷负。经无量无边俱胝劫数。复能以其饮食衣服一切乐具。周遍供给一切众生。胜华藏。于汝意云何。此人以是因缘得福多不。胜华藏白佛言。甚多世尊。若有人经一弹指间。于一众生起慈心者得福尚多。况如是邪。佛言。胜华藏。我今实言告汝。若有善男子善女人于此深经自能生信劝令他信者。其所得福倍多于彼。又若有人于此深经能受持读诵为他广说者。当知是人。以菩提心而为依止

尔时胜华藏菩萨摩诃萨白佛言。世尊。如来所说如是深经。若佛现在若涅槃后。我当受持读诵为他广说宣通流布使不断绝。胜华藏菩萨发是言时。会中有九十六俱胝菩萨异口同音作如是言。世尊。我等于佛所说深经亦当受持读诵。为他说广

尔时娑婆世界主大梵天王。帝释天主护世四王。及余无数诸天子众。各以天曼陀罗华散于佛上。及以天华散诸菩萨。复作百千俱胝种天妙音乐而为供养。又发是言。一切众生得闻如是甚深正法。光明普照得大善利。我等于此法门咸当受持宣通流布

佛言。如是如是。诸善男子。如汝所说。今此正法不可思议。若人曾于十千佛所深种善根。是人方得此经堕手。况复有能受持读诵。生信解邪

复次佛告胜华藏菩萨摩诃萨言。今此正法若得闻者。随彼方处一切女人转成男子。唯除二种。谓悭嫉者。即时会中有一女人。名曰离尘。心生信解。从座而起。前白佛言。世尊。我今内心已灭悭嫉。我发阿耨多罗三藐三菩提心。若我发心真实无妄当得成佛。及如佛所言闻此法时随处即得转女人相。是事实者愿我转身得成男子。尔时彼女发如是言已即得转成男子之身。时佛为授不退转阿耨多罗三藐三菩提记。当得成佛号除一切烦恼如来应供正等正觉

佛说此经已。胜华藏等诸菩萨摩诃萨。并诸苾刍众。乃至世间天人阿修罗等。一切大会闻佛所说皆大欢喜。信受奉行

佛说如幻三摩地无量印法门经卷下


佛说如来不思议秘密大乘经卷第一

    No. 312 [No. 310(3)]

佛说如来不思议秘密大乘经卷第一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    菩萨身密品第一之一

如是我闻。一时世尊。在王舍城鹫峰山中。与大苾刍众四万二千人俱。菩萨八万四千。皆是已得神通妙智。诸大菩萨摩诃萨众悉从他方诸佛刹中来此集会。已得忍不退转一生补处。获诸总持及三摩地。具无碍辩。能善超度无边佛刹。善于十方无边一切诸佛刹中。建立示现以神通智游戏自在。降伏众魔制诸异论。了知一切众生心意所行。复以胜智善别他根。解入一切波罗蜜多理教法门。具善巧方便。到于究竟最上彼岸。为一切佛共所称赞。于无量无边百千俱胝那庾多劫中。积集毕竟菩提道行。其心平等如地水火风缘虚空无边。善修慈观如理相应。所起一切住着障碍悉能超越。获那罗延妙好身相。具金刚坚固不坏之身。能师子吼宣演法音。善于一切大众会中。得胜无畏。有大光明映蔽日月。已得诸法如其所说三世平等。以决定智善说最上甚深法要。深入一切缘生法门。远离断常二种边见。于禅定解脱三摩地三摩钵底。若入若起而悉能知。功德智慧。名闻十方。任持最上正法宝王。能使不断三宝圣种。如是等积集无量福智胜行。其名曰宝上菩萨。月幢菩萨。清凉幢菩萨。光幢菩萨。吉祥光菩萨。吉祥峰菩萨。吉祥密菩萨。那罗延天菩萨。龙喜菩萨。龙上菩萨。龙树菩萨。持妙色菩萨。高天菩萨。德光王菩萨。光明手菩萨。常举手菩萨。常下手菩萨。宝印手菩萨。宝手菩萨。普光菩萨。星王菩萨。金刚手菩萨。金刚慧菩萨。金刚大慧菩萨。金刚步菩萨。不动迹步菩萨。三界迹步菩萨。无边步菩萨。无边慧菩萨。精妙慧菩萨。坚固慧菩萨。天慧菩萨。炎炽慧菩萨。最胜慧菩萨。增长慧菩萨。常惨菩萨。常喜菩萨。喜根菩萨。灭恶趣菩萨。除盖障菩萨。自相持无垢光菩萨。勇猛精进菩萨。慧积菩萨。常观察菩萨。观自在菩萨。得大势菩萨。高峰菩萨。虚空藏菩萨。不瞬菩萨。无悕望菩萨。宝上菩萨。宝思惟菩萨。善思惟菩萨。善思义菩萨。决定义菩萨。总持自在王菩萨。持地菩萨。庄严王菩萨。刹土庄严菩萨。宝积菩萨。秘密岩菩萨。帝释天菩萨。水天菩萨。梵网菩萨。明网菩萨。天冠菩萨。妙臂菩萨。妙眼菩萨。香象菩萨。象中香象菩萨。师子幢菩萨。成义慧菩萨。海慧菩萨。善调御菩萨。寂慧菩萨。慈氏菩萨。妙吉祥童真菩萨。如是等八万四千诸大菩萨摩诃萨众。及此三千大千世界。梵王帝释护世天等。并余大威德诸天王众。或龙王众。夜叉王众。阿修罗王众。迦楼罗王众。紧那罗王众。摩睺罗伽王众。乾闼婆王众。如是等众悉来集会。所谓阿那婆达多龙王。娑伽罗龙王。嚩噜拏龙王。摩那斯龙王。得叉迦龙王。金色龙王。无边色龙王。苏尸摩龙王。是等龙王。与多百千诸龙眷属。来此集会。亲近世尊瞻礼听法

复次阿修罗王众。所谓罗睺阿修罗王。毗摩质多罗阿修罗王。妙臂阿修罗王。娑罗阿修罗王。多罗阿修罗王。净戒阿修罗王。大笑阿修罗王。广腹阿修罗王。尽边阿修罗王。是等阿修罗王。与多百千诸阿修罗眷属。来此集会。亲近世尊瞻礼听法

尔时摩伽陀国主阿阇世王。与宫嫔眷属来此会中。亲近世尊瞻礼听法。并余四众。苾刍苾刍尼。优婆塞优婆夷等。皆来集会

复有地居诸天。欲色界天。净居天等。诸天子众亦悉来会。亲近世尊瞻礼听法

尔时世尊处大会中。有无数百千天人大众。恭敬围绕听受说法。佛告大众。我有正法。名普摄诸菩萨摩诃萨最上胜行清净妙门。此能圆满一切行故。谓若菩萨修布施行。即能成熟一切有情。若诸菩萨修持戒行。即得一切胜愿圆满。若诸菩萨修忍辱行。即得一切相好具足。若诸菩萨修精进行。即能圆满一切佛法。若诸菩萨修禅定行。能令一切调伏其心。若诸菩萨修智慧行。即能断除一切烦恼。若诸菩萨修说法行。即能成就无碍辩才。若诸菩萨修胜福行。即能长养一切有情。若诸菩萨修妙智行。即能成就无碍之智。若诸菩萨修奢摩他行。即能令彼心业调畅。若诸菩萨修妙观行。即能远离一切分别。若诸菩萨修于慈行。即得一切心无障碍。若诸菩萨修于悲行。即得身心俱无懈倦。若诸菩萨修于喜行。即能游戏法喜园苑。若诸菩萨修于舍行。即能断除违顺二法。若诸菩萨修听法行。即能断除一切障累。若诸菩萨修出离行。即能捐弃一切取着。若诸菩萨修住阿兰若行。即得所作善法皆无坏失。若诸菩萨修于念行。即能获得诸总持门。若诸菩萨修于慧行。即获胜慧善别诸法。若诸菩萨修于住行。即得一切无能胜心。若诸菩萨修趣向行。即能随知一切义趣。若诸菩萨修四念处行。即能伺察身受心法。若诸菩萨修四正断行。即能断除诸不善法。圆满一切善法。若诸菩萨修四神足行。即得身心清净轻安。若诸菩萨修五根行。即能善知自他根性。若诸菩萨修五力行。即得不为一切烦恼之所屈伏。若诸菩萨修七觉支行。即于诸法如实觉了。若诸菩萨修八正道行。即能超越一切邪道。若诸菩萨修四谛行。即能成就无动转法。若诸菩萨修四无碍解行。即能断除一切有情疑惑之心。若诸菩萨修归趣行。即得自在之智。若诸菩萨修善知识行。即能积集一切功德。若诸菩萨修意乐行。即与一切世间不相违背。若诸菩萨修深心行。即得一切所向最胜。若诸菩萨修相应行。即能勤勇救拔出离。若诸菩萨修住僧坊行。即得随所闻法而无坏失。若诸菩萨修四摄法行。即能摄受一切有情。若诸菩萨修摄受正法之行。即能不断三宝圣种。若诸菩萨善修回向之行。即能严净佛土。若诸菩萨修善巧方便之行。即能圆满一切智智

世尊如是宣说。普摄诸菩萨摩诃萨最上胜行清净妙门广大正法。当佛世尊说是法时。金刚手大秘密主菩萨摩诃萨。现威神力侍佛之右。是时金刚手菩萨摩诃萨。前白佛言。希有世尊。如来善说普摄诸菩萨摩诃萨最上胜行清净妙门广大正法。世尊。如我解佛所说义趣。如我所得诸菩萨摩诃萨一切胜行。皆从福智二行中出。当知随入福智二行。何以故。诸菩萨修福行故。能令一切有情离诸障碍。若修智行。能为一切有情善说法要令生喜悦。世尊。是故诸菩萨摩诃萨。福行智行二应和合。何以故。菩萨修福行故。即能圆满善巧方便波罗蜜多。修智行故。即能圆满般若波罗蜜多。故此二行即是菩萨二种圣道。普摄一切道行。菩萨住是道者。即能降伏难降伏者诸业魔众。菩萨已能超出诸恶魔道。不退转于阿耨多罗三藐三菩提。即此不退转菩萨。能善开明诸佛如来甚深秘密使不隐覆

尔时会中寂慧菩萨摩诃萨。前白金刚手大秘密主菩萨摩诃萨言。大秘密主。汝常近侍诸佛如来。汝能乐说如来所有秘密之法。愿为发起此。非声闻缘觉所入境界。况余凡夫。如是言已。时金刚手大秘密主菩萨摩诃萨默然而住

尔时寂慧菩萨。知是事已。前白佛言。惟愿世尊。敕金刚手大秘密主菩萨摩诃萨。为此众会发明如来秘密之法。令诸菩萨摩诃萨众。闻已欢喜。广大积集菩提分法。成就如来秘密之法。如理而行

尔时世尊告金刚手大秘密主菩萨摩诃萨言。我今劝请于汝。汝应善为此会大众。宣说菩萨秘密。如来秘密真实之法。此会大众而悉乐闻

时金刚手大秘密主菩萨。承佛圣旨。前白佛言。世尊。如佛教敕。我今宣说菩萨秘密如来秘密真实之法。然此会中若有少能悟入之者。皆是世尊威神建立譬如夜中冥暗所覆。灯光发明普能照现一切色像。今此众会亦复如是。于菩萨秘密如来秘密真实法中。若有闻已少悟入者。当知皆是如来威神之所建立

尔时金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。善男子。今此众会于菩萨秘密如来秘密真实法中。若能闻已不惊怖者。斯为甚善

时寂慧菩萨摩诃萨。普告在会诸大众言。诸仁者。如佛所说。有其四种不可思议。何等为四。一者业不可思议。二者龙不可思议。三者定不可思议。四者佛不可思议。仁者当知。于此四中唯佛如来不可思议最上第一。所有诸佛阿耨多罗三藐三菩提法。由此四种不可思议共所成立。是故汝诸仁者。于诸菩萨不思议法。如来不思议法。闻已不惊不怖不生畏怯。应生最上广大清净喜悦之心。是时寂慧菩萨以佛威神加持力故。能知此会一切大众。悉于诸佛菩萨秘密法中信乐听受。即时广大散布天花。雨集于膝普伸供养

尔时金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。汝应谛听。我今且说菩萨秘密真实之法。寂慧当知。今我世尊。昔于然灯如来法中居菩萨位。从彼佛所得授阿耨多罗三藐三菩提记。从是以来我常随逐释迦菩萨。而是菩萨所有身业曾无异作。亦不见有邪曲之相。语无异作。亦不曾闻虚妄之言。心无异作。亦不曾知爱着之失。随其身业现威仪相。但为成熟一切有情不自称誉。由彼菩萨身威仪相无其边际。乃至一切有情诸威仪事。悉入菩萨威仪相中。而菩萨不假勤力。亦无发悟安然而住。所谓应以禅定可度者诸有情类。即现禅定而为化度。应以鼓乐弦歌可度者。即现鼓乐弦歌而为化度。应以童男身可度者。即现其身而为化度。应以童女身可度者。即现其身而为化度。应以男子身可度者。即现其身而为化度。应以女人身可度者。即现其身而为化度。应以少年身可度者。即现其身而为化度。应以中年身可度者。即现其身而为化度。应以老年身可度者。即现其身而为化度。应以卑劣身可度者。即现其身而为化度。应以屠脍身可度者。即现其身而为化度。应以喑哑身可度者。即现其身而为化度。应以盲聋身可度者。即现其身而为化度。应以三恶趣相及人。趣身可度者。即皆现之而为化度。应以天身可度者。即现其身而为化度。应以龙及夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等身可度者。即皆现之而为化度。应以帝释身可度者。即现其身而为化度。应以梵王身可度者。即现其身而为化度。应以护世身可度者。即现其身而为化度。应以转轮王身可度者。即现其身而为化度。应以苾刍苾刍尼优婆塞优婆夷身可度者。即皆现之而为化度。应以声闻身可度者。即现其身而为化度。应以缘觉身可度者。即现其身而为化度。应以菩萨身可度者。即现其身而为化度。应以如来身可度者。即现其身而为化度。非可现者谓除无色

佛说如来不思议秘密大乘经卷第一佛说如来不思议秘密大乘经卷第二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    菩萨身密品第一之二

复次寂慧。所有一切有情色相威仪。即于菩萨色相威仪中住。而菩萨曾无发悟亦无分别。以彼菩萨无所分别平等舍心。即随其身现身威仪。然菩萨身法尔不动。以不动故现起身业。虽身离相。而亦不坏菩萨身清净。已发现光明普照地狱。一切有情令得安乐。又复菩萨。普为一切有情不惜身命。若诸有情各各来求菩萨身肉而啖食者。菩萨悉现其前。断肉授之。乃至骨血精髓而悉随与。寂慧当知。菩萨随诸有情须身肉等而悉与者。由彼菩萨知身无量。即能随知法界无量。无量即无尽身无尽门。即是缘生无尽法门。菩萨随所现身。但为成熟一切有情。若或有人贪染心者。爱着殊妙端严色相。菩萨即于其前。为现端严女人之相。随彼男子染爱之心。悉如其意。时彼女人以染着故。形容枯悴即趣命终。根门败坏臭秽不净。时彼男子。以无智故厌恶而去。即其女人死灭之身。自然出声为说法要。令彼男子心生开悟。不退转于阿耨多罗三藐三菩提心

复次寂慧菩萨。于此三千大千世界现广大身。或宝盖中或现指端。乃至劫火洞然炎炽能以手指而悉覆之。而菩萨身都无所坏。又复能现身相。普为诸佛世尊作供养事。积妙华盖如须弥量。复聚宝花高若山峰。悉以供养诸佛如来。又复以此三千大千世界为一大器。满贮香油等须弥山。布其灯炷然以灯明广大炽盛。为诸如来作供养事。又复积以殑伽沙等数量广大灯明。普遍炽盛供养如来。又复菩萨以所著衣覆自肢体。灌注酥油用然灯明。普为如来作供养事。其灯炽盛有大光明。广大照耀殑伽沙等诸佛刹土。彼彼有情互得观见。菩萨所现神通化事。如是见已。无量无数有情悉发阿耨多罗三藐三菩提心。其中所有憍慢贡高诸有情类。菩萨即现大力那罗延身。或金刚手菩萨可畏之相。彼等有情见已惊怖。即向菩萨折伏其心。归命顶礼求哀听法。又复菩萨于大国城及诸弃尸林中。见彼无数百千有情普遍充满。而是菩萨以广大身现死灭相。令彼先堕畜生趣中诸有情类畜报尽者。取其菩萨所灭身肉而啖食之。食已命终皆得生天。由是因故乃至最后入于涅槃。是故当知。菩萨摩诃萨宿昔愿力得清净已。能于长夜酬其宿愿作利益事。愿令有情临命终时。食我身肉得生天界。由此因缘乃至最后入于涅槃。令诸有情成就所思成就所求成就愿力

寂慧当知。菩萨摩诃萨。有如是等殊胜行愿。我念往昔过去世中。此阎浮提周匝四方。有八万四千广大国城。复多百千聚落县邑。百千俱胝那庾多人民居止。彼时国城有大灾难疾疫劫起。其中人民生种种病。谓于身分若生若熟疾状各异。或疮疖癣癞。或风癀痰等。大小病者散遍充满。求多千种精妙医师。用以妙药。而悉不能治疗彼等一切病苦。彼诸人民病无疗故。无所救护无所归向。震发大声哀泣而言。谁能为我息除病苦。或天龙夜叉乾闼婆等。或人非人。有能为我息除病者。我当罄舍一切财宝悉以奉之。我即如其教令荷彼深恩。寂慧当知。世尊释迦如来。当彼时中为帝释天主其名妙眼。于其天中以净天眼过于人眼。悉能观见彼诸人众受多病苦。复以清净天耳。遍闻一切。人众哀泣之声。其见闻已起悲愍心。即自思惟。我今应为此诸人民无依止无救护无归向者。作其依止救护归向。作是念已。即时帝释天主。于此阎浮提中有一大城名曰善作。其去不远即自变身为男子相。名曰善寂。处虚空中。普为开发阎浮提中一切人民。说伽陀曰

  善作大城此不远　　中有男子名善寂
  取彼身肉啖食之　　悉能息除一切病
  勿应惊怖怀怯惧　　随意欢喜取身肉
  此为妙药救人民　　是中无害无嗔恚

时彼国城聚落县邑。染疾苦者一切人众。闻彼空中伽陀声已。即时俱诣善作大城善寂人所。到已各各断取其肉食之治病。虽彼彼取之而身肉无尽

是时善寂。复为人众说伽陀曰

  我若当得佛菩提　　此真实法我无尽
  由真实故我此身　　愿取其肉亦无尽

是时普遍四方染疾苦者。一切人众于彼善寂人所。各各随意断取身肉。而善寂身安然如故。亦无增减续续断已旋旋复生。时彼国城一切人众食是肉者。彼彼所有一切病苦皆得除解。无病快乐悉无忧恼。如是次第阎浮提中一切人众。咸息诸病悉获轻安。是时一切人民男子女人童男童女皆自惟忖。彼善寂男子。能为我等息除诸病。令我无病身得轻安。我等今时持以何物用为供养。由是多人共集一处。同诣善寂人所。到已各各合掌恭信。异口同音说伽陀曰

  汝善依止善救护　　汝为医王复妙药
  随汝教令我病除　　我何所作伸供养

是时善寂男子。隐所变相还复帝释之身。普为一切人众说伽陀曰

  金银财宝及饮食　　我悉不为此等事
  但为救护诸有情　　十善业道令圆满
  菩提愿行坚固修　　为诸有情利乐因
  互相起发慈爱心　　生长一切利益事
  闻已应发菩提心　　复起最上大慈意
  普令积集胜妙因　　十善业道皆清净

复次寂慧。尔时帝释天主。说伽陀已复彼天宫。时阎浮提男子女人童男童女一切人众。莫知其数中无一人堕恶趣者。彼彼命终皆于善趣三十三天众同分生。生彼天已。帝释天主即为说法示教利喜。悉令不退转于阿耨多罗三藐三菩提心。其中有情或复远尘离垢得法眼净

复次寂慧。是故当知菩萨身密所作身业。得清净已弃一身命。能为成熟无量无数一切有情。毕竟令得阿耨多罗三藐三菩提果

复次金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。寂慧当知。菩萨身者是不破坏。坚固真实不生灭身。若诸有情应以有坏之身可化度者。即现其身而为化度。若诸有情应以无坏之身可化度者。即现其身而为化度。于一切种类悉不破坏。火不能烧刀不能断。是身坚固真实不坏金刚所成。是故寂慧。菩萨所现身相。但为成熟一切有情作利乐事。而是菩萨无所思惟。亦无分别是身是相。知身离相故即得法离相。亦非身离相与一切法离相有二差别。若相即身离相。彼相即法离相。如是离相能随入故。即自身离相与一切有情身离相二俱平等。何以故。由自身离相。一切有情身离相故。即入一切法界离相。以法界离相故。即入法离相。然于是中而实无有少法可得。谓以自身真如。即入一切有情身真如。一切有情身真如。即入自身真如。又复自身真如。即入一切法真如。以入一切法真如故。即入一切佛真如。又以自身真如故。即入过去未来现在真如。亦非过去真如与彼未来现在真如有所违背。所有过去未来现在真如。即是蕴处界真如。蕴处界真如即是清净真如。染净真如。即是生死涅槃真如。生死涅槃真如。即是无造作真如。无造作真如。即是一切造作真如。善男子。所说真如即是实性。实性即是如性。是无异性。无种类性。无生性。无诤论性。无执取性。谓以真如无法可取故。说真如是无取法。由彼真如无所取故。即如是取。于诸取中菩萨示现有所取法。亦非真如有取有作。以无取故即无诤论。无诤论故。于诸色中现有所取。然彼真如亦无所动。是故以其如实之智。伺察如来真实之身。以观如来身平等故。即当伺察自身真如。取要言之审观一切身非身性。毕竟不生。知一切身皆是缘生法所成故。如是知已乃能悟入彼法身门。入是法身门故。即成法身。非蕴处界身。即彼法身广大增胜。如实观想从是现身。为诸有情作利乐事。乃至一切见闻觉知。悉为有情成利乐故。寂慧当知。譬如世间耆婆医王。积集一切胜上之药。精妙和合成女人相。妙色端严而可乐见。如其所应安立施作。若来若去行住坐卧。分别事相。亦非分别非离分别。诸有病者。若国王大臣若长者居士。来诣耆婆医王妙药所成女人之所。相与和合。其和合已。一切病苦皆得息除。无病轻安而获快乐。寂慧。汝且观是耆婆医王。以善巧智。能为世间息除诸病。余诸医师无是智力。菩萨所有法身增胜。亦复如是。若能如理真实观者。而彼一切男子女人童男童女。为贪嗔痴烧然其身。若能如实观法身者。即能息除一切烦恼。心得轻安身离烧然。是故当知。菩萨宿昔愿力清净。菩萨法身广大增胜。如实而观即是菩萨身密清净。寂慧当知。菩萨法身非饮食力而能成故。亦非段食可能资养。菩萨了知如是相已。即为悲愍一切有情现受饮食。虽有所取而无著相。亦非护惜其身故有所取于所取中。而彼法身无增无减。是故当知。菩萨法身不生不灭亦无所起。于中示现生灭起作。但为成熟诸有情故。灭即无灭亦无造作。于一切法应如是知。诸有生者即和合义。于一切法应如是知。又复应知彼一切法生即无生。如来身者即是法身。即是法食即是法力。是法归趣。如来身者即虚空身。无等等身。三界一切最胜上身。一切如来通达身。无喻无比清净无垢无染污身。自性明亮身。自性不生身。自性无起身。离心意识身。幻焰水月自性身。空无相无愿所成身。十方最胜如虚空广大身。一切有情平等身。无边无际身。无种类无分别身。无毁无异身。于住无住得不动身。无色自性身。无受想行识自性身。非地界所成身。非水火风界所成身。非种非和合种非大种所成身。非种类法一切世间无比身。非眼所生非耳依止非鼻所知非舌了别非身和合非意所成等身。非心所转。非意识所转。亦非无转亦非随转。善男子由如是故。应当如实观如来身。而是菩萨于如来身住平等性。得清净已行菩萨行。乃至三千大千世界。或四大洲或阎浮提。一切王城聚落郡邑。菩萨于一切处普为现身。然于是中亦无所现亦无对碍。又复菩萨能于十方现诸魔身。于有现中现无对碍。于无现中现无对碍。由如是故。无见无闻无觉无知。诸有所现但为成熟一切有情。菩萨于其身念处中亦无增减。菩萨虽复知身无常知身是苦知身无我。然为有情示现其身作利乐事。菩萨知身法尔寂静。为有情故起分别身作诸利乐。菩萨又复了知因缘能成其身。然于彼彼因缘法中如实而观。亦无作者亦无受者。又复能观是身无知如草木瓦砾。菩萨身业虽已清净。然为有情示现其身。寂慧当知。释迦菩萨始从然灯佛所发菩提心。身语心业皆悉清净。且身业者具有无量无边功德。假使过于殑伽沙数等劫。或如来说或我所说。菩萨所有身密身业。广大清净不可穷尽

佛说如来不思议秘密大乘经卷第二佛说如来不思议秘密大乘经卷第三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    菩萨语密品第二

复次金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。善男子。云何名为菩萨语密语业清净。寂慧当知。随诸菩萨所起之处。即彼菩萨本生。随其菩萨本生。即入菩萨音声。所有一切有情音声语言。诸语言道言词诠晓。总集一切往返事相。微细伺察苦乐等言。悉入菩萨音声中住。都无障碍无著智见一切随转。乃至蚊虫蝇蝶微细音声。菩萨悉能诠表。令诸有情得闻菩萨音声之者身心轻安。随彼所闻如其诠表。悉从菩萨口门而出。此中如是说伽陀曰

  随诸有情无边际　　即彼种类亦无量
  于百劫中说无边　　此不思议何能说
  我以譬喻如义言　　说大士法亦无失
  无增无减若虚空　　起广大心而开演

复次寂慧菩萨。于其梵王所有一切种类音声。帝释所有种类音声。护世天王种类音声。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等种类音声。乃至一切有情种类音声。菩萨悉以音声随入。复次伽陀曰

  菩萨梵音欢喜说　　超胜梵王彼音声
  所说相应行慈悲　　喜舍四法皆和合
  帝释歌咏悦意声　　菩萨音声能隐覆
  随彼所出妙歌音　　如应分别诸法义
  紧那罗众妙音声　　菩萨音声悉超胜
  贪火炽然令息除　　如彼所言生爱乐
  欲界诸天悦意声　　诸天歌咏声各异
  法义随顺如理宣　　令彼一切生欢喜
  贫嗔痴慢及憍谄　　疑惑等类诸有情
  闻其菩萨如义声　　悉能止息贪嗔等
  所有色界诸天众　　闻最上人音声已
  一切咸生欢喜心　　愿求菩提生善趣
  摩睺罗伽乾闼婆　　龙等诸妙音乐声
  闻功德海所宣言　　一切广大生欢喜
  种种方处无边声　　人中此阎浮提等
  随闻菩萨妙音声　　闻已一切得解脱
  地居空居诸天界　　菩萨音声悉随入
  如其种类所入声　　宣说决定真实法
  迦陵频伽拘枳罗　　鹅雁鹦鹉并鹙鹭
  孔雀共命拘那罗　　吉祥鸟及鸳鸯等
  师子虎豹熊獐鹿　　象马犀牛猫犬猪
  此等走兽及飞禽　　音声随入皆欢喜
  一切四足及二足　　多足无足等有情
  菩萨随入众音声　　警悟如应生爱畏
  三千世界诸有情　　上中下品众差别
  三涂及彼人天中　　菩萨言音普随入
  是中菩萨无分别　　无执无缚无思想
  住无散乱等引心　　所作随应现诸相
  清净有情所求愿　　音声诠表俱胝刹
  过殑伽沙数亦然　　是心无持无发悟
  三千界中诸魔众　　咸闻菩萨广大声
  闻已惊怖速归心　　合掌恭信而顶礼
  常好诤论诸有情　　增上慢心不归信
  由闻大士清净言　　合掌恭信而顶礼
  聋哑及彼无舌者　　謇吃破坏诸有情
  由其菩萨美妙言　　即时能闻能言说
  烦恼烧然复逼迫　　造罪恶作百种具
  由闻菩萨善净言　　心得清凉息诸恶
  有情若闻无常声　　佛法僧声即得闻
  施戒忍法亦复然　　精进定慧悉闻听
  所有一切功德海　　多俱胝劫说不尽
  音声无边智无边　　悉住佛声而无断

复次寂慧。当知菩萨摩诃萨。语言音声之中。无爱着语。无猛恶语。无痴乱语。无染污语。无缚解语。无高下语。无粗涩语。无恶戾语。无缺漏语。无坚硬语。无违顺语。无退失语。无随恶语。无相违语。无随染语。无不定语。无躁动语。无贡高语。无忿恚语。无非时语。无杂欲语。无随方喜爱语。无思慕语。无极缓语。无极速语。无坏诸根语。无坏音声语。无破坏心语。无邪曲语。无劣弱语。无隐覆语。无衰朽语。无向背语。无深险语。无不出离语。无不愍念语。无害他语。无自他离间语。无出入语。无执取语。无不清净语。无不如理语。无不忍语。无杂乱语。无诬谤语。无非法语。无高胜语。无卑下语。无过时语。无时分差失语。无虚说语。无邪说语。无希求利养语。无不归摄语。无痴瞢语。无痴疑语。无不可爱语。无讦露语。无轻慢语。无自分高强语。无他分离散语。无自赞功能语。无破他功能语。无讥诮语。无折伏他语。无非所作语。无所作相违语。无破坏秘密语。无不防护语。无轻慢智者语。无毁谤贤圣语。无称美语。无赞誉语。无显发他人过失语。无如箭射激语。无说他非语。无不救拔语。无增上慢所说语。无罪业语。无不饶益语。寂慧当知。菩萨所出语言音声。皆是神通智力。福行果报之所成立。善种随转相续不断。凡所言说皆悉成就。菩萨一时或于树下行住坐卧。若有人来诣菩萨所。作是问言。汝知此树有几多叶。是时菩萨不观其树不数其叶应声答言。此树具有若干数叶。如其菩萨所出之言。即彼树叶更无增减。又复有人问殑伽河有几许沙。为几百邪。几千几百千。几俱胝几阿庾多。几儞庾多。几兢羯罗。几频婆罗。几尾播舍。几阿閦婆。几无量。几阿僧祇。几阿哩誐拏。几嚩诃。几龙力。几不可数。是时菩萨不观其河不数其沙应声答言。此河具有若干数沙。如其菩萨所出之言。即彼河沙更无增减。亦同如来智所知数。菩萨所言如实无妄。不假天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。并声闻缘觉众共作证。唯佛如来所可证知。寂慧。如是等缘而悉应知

复次寂慧。我念过去久远世中。有一仙人其名妙爱。有婆罗门名曰黑相。彼时有一尼拘陀大树其名贤善。有多枝叶周匝垂荫。纵广可及一俱卢舍。时妙爱仙人居其树侧。以神通力经七日中。审细观瞩数其树叶。于后一时。彼黑相婆罗门。入城乞食。经游至彼树下饭食已讫。即诣妙爱仙人居所。到已欢喜。互以美言而相慰问。多种谈论咸生适悦。时仙人言。大婆罗门。汝必应知于人世中。可能有人于此尼拘陀大树审细观知枝叶数不。婆罗门言。尊者。世亦有人。仙人复言为何人邪。婆罗门言。即汝尊者应为我说。仙人答言。大婆罗门汝为我说。时婆罗门。不观其树不数其叶。应声即为说伽陀曰

  八千那庾多数量　　俱胝复有九十二
  六十阿閦婆应知　　十六齐等其枝数
  又复三十那庾多　　九十六数殑羯罗
  尾播舍量有十三　　此等皆为彼叶数
  其树所有枝及叶　　如前数量无增减
  我随智力如实言　　疑者自数应无失

是时妙爱仙人。闻是说已深生惊异。说伽陀曰

  汝婆罗门神通智　　以真实语而善说
  贤善尼拘陀树王　　所有枝叶如实知
  汝亦不曾观其树　　而复不曾算其数
  即彼枝叶数难量　　能以智心而解入

仙人说伽陀已。又复问言。大婆罗门。如汝所说。为自智力而能知邪。为诸贤圣助汝说邪。婆罗门答言。尊者。汝今善听。我以人中之智如实而说。虚空可破斯言无妄

复次。金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。汝今当知彼时妙爱仙人者。即今大智舍利子是。黑相婆罗门者。即今世尊释迦师子是。由如是故菩萨所有语功德海。即能安住真实功德如理法义。寂慧。此等是名菩萨语密语业清净。其中若有少解入者。我说彼为最上慧人

    菩萨心密品第三之一

复次金刚手大秘密主菩萨摩诃萨告寂慧菩萨摩诃萨言。云何名为菩萨心密心业清净。寂慧当知。菩萨诸所作业。皆智所作非慢所作。悉是不灭神通妙智。以神通智游戏示现。一切事业神通建立。广大势力之所成办。而彼神通智相。即能成立一切行相。又彼神通妙慧。即能观见一切诸法。又神通智即无尽相。于一切处悉能随顺。又神通智即能随现一切色相。于彼彼色而悉遍故。又神通智即能随入彼一切声。于前后际音声平等故。又神通智普能观察诸有情心。以心自性伺察可见故。又神通智善能思念无边劫事。以前后际无所断故。又神通智能知一切种类之法。悉是解脱智行相故。又神通智于漏尽法顺时所求。于彼时分不过越故。又神通智即是出世间。圣决择分故。又神通智声闻缘觉。而悉不能彻其源底。又神通智即甚深义。悉能降伏诸魔外道。又神通智能至菩提道场。现证一切最上佛法。又神通智悉能随顺转妙法轮。又神通智善作调伏诸有情事。又神通智得大灌顶。于一切法而能自在。寂慧。此即是为菩萨心密心业清净。心清净故彼即无染。洁白明亮离诸烦恼。能善调伏善作诸业。善入禅定解脱三摩地三摩钵底。亦不毕竟堕于一切。尽无生法随念即生。亦复不为欲界所动。不由缚生不由缚灭不由缚起。所以者何。谓能解脱一切分别。解脱一切杂染系缚。解脱颠倒执取依止。即彼解脱生。即彼解脱灭。即彼解脱起。虽复有生而无所生。如是即能圆具大乘一切佛法。然彼佛法若于十方审谛伺求。悉无所得亦非无得。以一切佛法无得非无得故。即能随得彼一切法一切佛法。是故于一切法一切佛法中。无法非无法。何以故。以一切法审谛伺求。悉无所得亦非无得。若于诸法如实伺求。悉无所得非无得时。即无有法而可算数。谓一切法已能出过算数量故。若能了知彼一切法平等性者。是中无法亦非无法而可取着。此即诸法无取着义。若或领解是义即大无义。若无领解。彼即无义亦非无义。以现前安立无义可见故。若或有慧可了知者。即为障碍彼无碍慧。若或于慧无障碍故。是即无著。若无著即无住。若无住即无尽。若无尽即无勤亦无堕。若无勤堕即无非我。若无非我即亦无我。若无我即无取。若无取即无诤。若无诤即无论。即彼无论此说是为沙门之法。即沙门法。譬若虚空本来平等。以虚空平等故。非欲界系。非色界系。非无色界系。由如是故。于一切处悉无所系。以无系故无形显色及诸相状。无色相故即能随顺觉了。若能如是随觉了故即能一切差别分别。寂慧菩萨言。云何名为随顺觉了。复何名为差别分别。金刚手菩萨言。无有少法而可得者。此名随顺觉了。以觉了故即是差别分别。是故法中作此二说。寂慧。当知此等名为菩萨心密心业清净

佛说如来不思议秘密大乘经卷第三佛说如来不思议秘密大乘经卷第四

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    菩萨心密品第三之余

复次金刚手大秘密主菩萨摩诃萨。告寂慧菩萨摩诃萨言。善男子。菩萨心密者。谓修慈行即知无我。若修悲行即无众生。若修喜行即无寿者。若修舍行即无有人。若修布施行即心调伏。若修持戒行即心寂静。若修忍辱行即心无尽相。若修精进行即心离相。若修禅定行即心安定。若修慧行即心无伺察。若修四念处行即心无念亦无作意。若修四正断行即心正平等。若修四神足行即心无戏论。若修信根即心无著。若修精进根即心无发悟。若修念根即得自然智心。若修定根即得平等性智心。若修慧根即得无根本心。若修五力即得心无屈伏。若修七觉支即得慧分别心。若修八正道即得无所修心。若修奢摩他即得寂止心。若修毗钵舍耶即得无所观心。若修四圣谛即得毕竟无了知心。若修佛作意即得无作意心。若修法作意即得法界平等心。若修僧作意即得无住心。若修成熟有情行即得本来清净心。若修摄受正法行即得法界无差别心。若修严净佛土行即得虚空平等心。若修无生法忍行即得无所得心。若修不退转地行即得无转而转心。若修成就诸相行即得无相心。若修庄严菩提果即得三界圆满心。若修降伏诸魔行即得普摄一切有情心。若修趣向菩提行即得法界自性随觉了心。若修转法轮行即得无转非无转心。若修大涅槃行即得随观生死自性心。寂慧。当知此等皆是得忍菩萨。心秘密法心业清净。若彼菩萨如是清净已。即得一切有情心亦清净而是菩萨乃能随入诸有情心。即彼一切有情之心。皆从大菩提心光明中出。譬如虚空于一切处住随入一切处。菩萨心者亦复如是。于一切处住随入一切处

金刚手大秘密主菩萨摩诃萨。如是宣说菩萨所有身语心密不思议正法。时会中有七万二千天及人。发阿耨多罗三藐三菩提心。三万二千菩萨得无生法忍。八万四千人远尘离垢得法眼净。八千苾刍不受诸法。漏尽意解得心解脱。时此三千大千世界六种震动。有大光明普遍照耀。虚空自然雨众天华。复于空中有百千种殊妙音乐不鼓自鸣。其音乐中出如是言。若诸有情已得授记位者。方乃得闻此金刚手大秘密主菩萨摩诃萨所说正法。于中闻已受持读诵如理修行。广为他人随应宣说。永不忘失大菩提心。当知彼人非少善根而能成就。已于广多佛世尊所深植善本。勤修一切最胜福行。当为一切有情作大饶益

    震吼音声菩萨来会品第四

尔时世尊告寂慧菩萨摩诃萨言。善男子。汝闻空中多种鼓乐妙音声不。寂慧菩萨白佛言。世尊。我初已闻此是何等殊妙音声。愿佛为说。佛言寂慧。汝今当知有菩萨摩诃萨名震吼音声。从大云世界云音王如来所。来此娑婆世界。瞻礼于我亲近供养。及欲听受金刚手菩萨宣说正法。亦复乐见十方来会诸大菩萨摩诃萨众。是彼震吼音声菩萨。隐自身相住虚空中。雨众妙华鼓胜音乐供养于我。其乐音中出如是声。世尊如来于大会中。非久宣说广大正法。发是言已。即时震吼音声菩萨摩诃萨。从空而下入佛会中。头面礼足右绕七匝。住于佛前而白佛言。大云世界云音王如来。问讯世尊少病少恼。起居轻利气力安不。彼佛如来又作是说。金刚手大秘密主菩萨摩诃萨。有大方便善说正法。是佛威神之所建立。乃能如是通达一切无量佛法

尔时世尊。告震吼音声菩萨摩诃萨言。善哉善男子。汝善来此大众会中。乐听金刚手大秘密主菩萨摩诃萨宣说如来秘密不思议法。汝当于此谛听谛受

    持国轮王先行品第五

尔时会中诸菩萨众。咸起是念。此金刚手大秘密主菩萨摩诃萨。往昔于何佛世尊所。亲近听受深种善根。复修何等广大誓愿乃能如是。具大辩才善说诸法

尔时世尊。知诸菩萨心疑念已。即告寂慧菩萨言。善男子。我念过去世中。经阿僧祇劫。复过阿僧祇数无量无边不可思议劫前。有劫名善现。世界名庄严。有佛出世。号无边功德宝众庄严王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。寂慧。当知彼庄严世界。广大妙好安隐丰乐。人民炽盛地平如掌。无诸砂砾荆棘杂秽。草木树林青郁可爱。复有名华软草。覆地青润妙好。如孔雀项右旋喜相。有色有香令人适悦。下足于地随减四指。举足还复随起四指。无极寒热温凉调适。软美清风令人爱乐。其地庄严如吠琉璃。彼时人民色相严好。少贪嗔痴及余烦恼。人有孝爱复具势力。闻说善言能自开晓。而彼世尊无边功德宝众庄严王如来法中。有十二那庾多诸声闻众。三十二俱胝诸菩萨众。彼时人寿三十六俱胝岁。于中有人趣命终者。寂慧。当知而彼善现劫中。庄严世界。处于中四大洲。一一四大洲其量广阔。八万四千由旬。每一由旬。中有千国城郡邑聚落周匝围绕。彼庄严世界中。有大国城名极清净。而彼国城分量广阔。北六十四由旬。南四十由旬东西亦然。有十千园苑而为严饰。国城之内复有十千州城县邑。彼极清净国城之中。有大转轮圣王。名曰持国。七宝具足为四大洲主。于先佛所深植善根。福德威光王中最胜。不退转于阿耨多罗三藐三菩提心。寂慧。而彼持国转轮圣王。所居国城纵广正等十六由旬。广大殊妙有七重墙。七宝所成其上复有七重楼阁。七重宝网垂诸宝铃。墙内周匝有四大园。一名众花。二名德喜。三名孔雀喜。四名时分快乐。是诸园中各有大池。一名欢喜。二名喜上。三名香上。四名顺流。其池纵广半由旬量。悉以众宝砌其阶级。阎浮檀金而为其底。金沙布地。八功德水充满其中。有宝莲华弥覆其内。鹅雁鸳鸯众鸟游泳。又彼持国转轮圣王。有其七万宫嫔婇女。皆悉相好端严殊妙。而为女宝以用给侍。是诸宫嫔皆悉已发阿耨多罗三藐三菩提心。王有千子色相端严。勇猛无畏能伏他军人。各具其二十八种大丈夫相以为严饰。深心净信于阿耨多罗三藐三菩提法。寂慧。时彼世尊无边功德宝众庄严王如来。居极清净大国城中。彼持国转轮圣王。与诸大臣婆罗门长者乃至一切人民。咸悉恭敬尊重供养其王。净信彼无边功德宝众庄严王如来。及苾刍众满一俱胝岁。承事供养广持悦意。种种饮食珍妙衣服。乃至一切受用等物。悉以奉上。又诸苾刍众各以三园用献游止。寂慧。彼转轮王有诸太子。心各清净曾无放逸。亲近彼佛勇闻正法。不以欲乐而为染着。由不放逸其心寂定。听正法故是诸太子不久之间得五神通。即时各各踊身空中。犹如鹅王飞腾自在从园至园。从此城邑至彼城邑。乃至遍游四大洲界。随行空中说伽陀曰

  诸佛出世得何利　　总聚人间利复深
  仁者听法净信心　　经百劫中极难得
  今此人中仙出世　　宣说正法寂静道
  我今近彼善逝尊　　由闻法故生善趣
  闻正法已破恶趣　　闻正法已善趣生
  由闻法故烦恼除　　心得清凉最上乐
  空中说是伽陀时　　此大地中六震动
  天人空中出妙声　　大雨众华生悦意
  若人得见佛大师　　彼功德说不能尽
  应当顶礼二足尊　　合掌谛诚而恭信
  彼佛能知人心意　　如其所应为说法
  闻法三十六俱胝　　人皆住胜菩提道
  复有三百俱胝人　　获得最上净法眼
  一切皆生厌离心　　归佛出家依正教
  又四俱胝那庾多　　人受净戒作佛事
  听法供养佛世尊　　作已各还于本处

彼诸太子说伽陀已。同为其父持国转轮圣王作供养事。择以龙坚妙栴檀香。造作楼阁广大殊丽妙好严饰。纵广正等十由旬量。四方四隅分量齐等。楼观门径悉以龙坚妙栴檀香。制作圆具如天宫殿。其龙坚香半两价直。过于阎浮檀金价。而彼楼阁巧施工力妙好严成。是时持国转轮圣王。欲诣世尊无边功德宝众庄严王如来所。瞻礼亲近听受正法。时王诸子并宫嫔眷属。侍从父王。即入栴檀大楼阁中。其王处于莲华庄严师子座上。太子宫嫔臣佐人民咸皆尊重。以一切种花鬘涂香。上妙衣服宝幢幡盖。微妙音乐广伸供养。复以宝网垂覆楼阁。众共执擎而将前进。即时腾踊在虚空中。犹如鹅王自在而行。前至佛所。徐徐以彼楼阁安置地已。持国转轮圣王并太子宫嫔。从楼阁中安庠而下。前诣佛所头面着地礼佛双足。并苾刍众各敬礼已。右绕七匝还住佛前。合掌谛诚听受正法。时彼世尊无边功德宝众庄严王如来。知彼持国转轮圣王来佛会中乐欲听法。佛即如应为说妙法示教利喜。佛言大王。汝今当知有四种法。若如理修行者。即能安住大乘趣向胜道。所有善法而无坏失。何等为四。大王。一者信法能向胜道。复何名信。谓有信故而能随顺诸贤圣种。所不应作而悉不作。二者尊重能向胜道。以尊重故于诸圣者所说妙法而能听受。谛受法故耳无外听。三者无慢能向胜道。以无慢故即能于彼一切贤圣恭信顶礼。四者精进能向胜道。以精进故若身若心悉得轻安。所作善法皆能成办。大王。此等四法。若如理修行者。即能安住大乘趣向胜道

佛说如来不思议秘密大乘经卷第四佛说如来不思议秘密大乘经卷第五

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    持国轮王先行品第五之余

复次大王。有四种法。若圆满者。即能安住大乘。成就不放逸行。心无流散。何等为四。一者戒护诸根。二者观欲过失。三者摄受一切作无常想。四者于法决定为胜命根。大王。如是四法。若圆满者。即能安住大乘。成就不放逸行。心无流散。大王。有四种法。王者修行若具足者。说名仁王。何等为四。一者常不弃舍大菩提心。二者以菩提法教示他人。三者以诸善根回向菩提。四者于佛世尊大威德力。若见闻已。亦复于彼一切天人声闻缘觉所有威力生欢喜心。然即唯求佛大威力。大王。如是四法。王者修行若具足者。说名仁王。是故大王。应当常修不放逸行。信心清净忻慕正法。起乐法欲勤求正法。常当游戏正法园苑不着境界。所以者何。大王。当知欲无厌足。彼所足者是谓圣慧。又复大王。寿量微少命不久停。往趣他世罪业可怖。由是应知。常当亲近供养恭敬诸佛如来。以此善根。应于四处而用回向。何等为四。一者回向无尽果报。二者回向无尽法门。三者回向无尽妙智。四者回向无尽辩才。大王。复有四法。一者身清净故能成慧行。二者语清净故能成闻行。三者心清净故能成戒行。四者慧清净故能成智行。复有四法。一者方便圆满故能成熟有情。二者慧圆满故能降伏诸魔。三者愿圆满故即如说能行。四者值遇佛故即得一切佛法圆满

时彼持国转轮圣王。于彼佛所得闻正法。示教利喜生欢喜心适悦庆快。持以无价真珠妙宝。及王者所有一切受用。悉以献佛而为供养。乃至尽寿修诸梵行奉持五戒。是时王诸宫嫔。于彼佛所闻正法已。心大适悦踊跃欢喜。各以身所著衣及庄严具。覆于佛上。乃至尽寿修诸梵行奉持五戒。悉发阿耨多罗三藐三菩提心。时持国转轮圣王。快得善利增益法财。已与诸宫嫔眷属。各各至诚顶礼佛足。及苾刍众亦悉礼敬绕七匝已。即时入于大楼阁中。踊升虚空自在而行。还极清净大国城中

复次持国转轮圣王。于后一时择月圆日。严驾出游众花大园。而为玩赏。鼓吹清音奏妙歌乐。恣其所乐嬉戏游从。是时有二最上宫女。一名无毁。二名无比。同诣欢喜池中。清净澡沐出已衣覆。处于莲花师子之座。是二宫女。即于座中各有一童子。自然化生跏趺而坐。童子端严色妙无比。相好圆具人所乐观。于刹那间即各踊身住于虚空。是时空中有贤圣言。此二童子。一名法思。一名法慧。故此二名由斯而立。彼法思童子。于其无毁宫女坐中化生。彼法慧童子。于其无比宫女坐中化生。时二童子。在虚空中亦加趺坐。异口同音说伽陀曰

  仁者我今得善利　　所谓发生菩提心
  既发心已遇世尊　　起清净心而信礼
  大海深广难彻底　　生死轮转无休息
  有情广渡生死流　　彼菩提心不舍离
  有世界名无毁身　　有世尊名时分王
  我从彼来求法门　　乐见牟尼功德聚
  我时各各加趺坐　　分从二母坐中生
  我父持国大圣王　　故来合掌伸敬礼
  愿父伺察听我说　　阿庾多劫善得法
  乃至圆成大菩提　　所得于中不弃舍
  一切唯佛出世难　　父母难得居法位
  法中善友刹那逢　　清净妙宝随意现
  欲及精进不放逸　　出家得利具正知
  勤修利益心调柔　　惭愧多闻具善戒
  慈悲调寂为有情　　普令获得深法忍
  精进勤力无著心　　成熟摄受诸群品
  心离相故得调畅　　于其身命不顾惜
  思惟正法如救然　　愿获诸佛胜功德
  父王最上难得者　　我所称赞最上法
  我从彼佛刹中来　　还归彼佛本因处
  我等已住菩萨位　　普能摄受诸善法
  刹那获得五神通　　随念随观意能晓

时彼持国转轮圣王。与宫嫔眷属并二童子智者菩萨。以神通力处虚空中。同诣世尊无边功德宝众庄严王如来会中。到已各各顶礼佛足。一切众会普伸尊敬。是时彼佛。观二童子是真佛子。乐欲听受菩提道法。佛知其意。即为宣说甚深正法。佛言。善男子。当知诸法从缘所生。中无主宰亦无作者。知内是空外无所行。诸法皆空虚假无实。于见于作应悉清净。犹如虚空而无所取。彼佛世尊如是多种。广为宣说清净法时。会中有七十六那庾多及三俱胝人。得无生法忍。是时持国转轮圣王。在佛会中经七昼夜作供养已。与其诸子并宫嫔眷属。于刹那间还本所居。时彼轮王后于一时。独处栴檀楼阁之中。登于莲花师子之座。窃作是念。我此千子悉已安住阿耨多罗三藐三菩提法。然于其中何者最先得成阿耨多罗三藐三菩提果。我宜设法以验其事。作是念已即敕侍人。用以七宝妙巧作瓶。如其分量善施作已。即命各书千子名字置宝瓶中。复以七宝作妙莲花。于其花中安置宝瓶。然后于七昼夜广以微妙香花涂香粖香等及鼓吹歌音。严伸供养瓶中名字。是时空中有十千天人。助发种种妙供养事。如是供养七昼夜已。普召宫嫔眷属及王千子并二童子咸集其前。复以贤妙金床安置宝瓶。安已即时敕遣侍人。于宝瓶中取其名字。侍人如命瓶中最先取一名字。前奉于王其名乃是清净慧太子。然后次第遍取其名。即时于刹那间而此大地六种震动。所有宫嫔先各执持诸妙乐器。不鼓自鸣出妙歌音。寂慧。当知彼时清净慧太子。最先瓶中取其名者。岂异人乎。即是此贤劫中。过去俱留孙如来。次于瓶中取一名字。其名最胜军太子者。即是过去俱那含牟尼如来。次于瓶中取一名字。其名寂诸根太子者。即是过去迦叶如来。次于瓶中取一名字。其名一切义成太子者。寂慧。当知即我身是。次于瓶中取一名字。其名宝带太子者。即当成佛号慈氏如来。次于瓶中取一名字。其名牛王太子者。即当成佛号师子如来。次于瓶中取一名字。其名电天太子者。即当成佛号大幢如来。次于瓶中取一名字。其名贤王太子者。即当成佛号妙花如来。次于瓶中取一名字。其名净光吉祥太子者。即当成佛号花氏如来。次于瓶中取一名字。其名莲华眼太子者。即当成佛号善宿如来。次于瓶中取一名字。其名无垢光太子者。即当成佛号妙眼如来。次于瓶中取一名字。其名净池太子者。即当成佛号妙臂如来。次于瓶中取一名字。其名慧王太子者。即当成佛号明焰如来。次于瓶中取一名字。其名善庄严太子者。即当成佛号明味如来。次于瓶中取一名字。其名增长分太子者。即当成佛号导师如来。次于瓶中取一名字。其名净严王太子者。即当成佛号持胜功德如来。次于瓶中取一名字。其名吉祥密太子者。即当成佛号胜财如来。次于瓶中取一名字。其名妙光身太子者。即当成佛号智积如来。次于瓶中取一名字。其名勇健太子者。即当成佛号宝积如来。次于瓶中取一名字。其名宝称太子者。即当成佛号普光明如来。寂慧。当知如是等广说。彼千子中相继而取。乃至取一名字。其名大峰庄严太子者。即当成佛号无边功德宝称如来。寂慧。唯一名字在宝瓶中。最后取之。其名无边慧太子。而此太子于千子中居最小位。是时诸兄或轻侮言。我等诸兄当成佛时。已作佛事已度有情。汝于最后当何所作

时无边慧太子说伽陀曰

  佛法无边如虚空　　有情及慧亦无尽
  行愿清净戒薰修　　当听我说此行愿
  诸兄寿量若干数　　王者众会数若干
  如我寿量总聚之　　愿当尔许声闻众
  太子说是伽陀已　　空中天人赞善哉
  正士意乐净周圆　　利益有情无穷尽

寂慧。当知彼时最小无边慧太子者。当得成佛号乐欲如来。于贤劫中最后成佛。寂慧。所有贤劫中诸佛寿量及声闻众。彼乐欲如来而悉当得。是彼如来善乐欲故。是故如来名为乐欲

复次寂慧。汝且观是菩萨摩诃萨。善巧方便圆具净戒。无毁大愿满足胜行。彼诸太子九百九十九人。乃至无边慧太子。如上功德皆悉成就

是时彼千太子。俱谓二童子菩萨言。汝此法思法慧二善男子。往昔发何殊胜愿力。今如是邪。法思童子言。诸仁者。我与汝等皆如金刚手。菩萨相续胜行。不离一切如来无上秘密。不离一切佛法听受信解。法慧童子言。今我诸兄具胜愿力。愿我与汝悉证菩提。成菩提已。我皆劝请转妙法轮。如其愿力。于彼佛所受菩提记。寂慧。当知彼时持国转轮圣王者岂异人乎。即是然灯如来应供正等正觉。往昔因中居轮王位时。彼轮王千太子者。即是此贤劫之中千佛如来。从俱留孙如来。至乐欲如来(古经不译但云楼至)彼时法思童子。于无毁宫女坐中化生者。即是金刚手大秘密主菩萨摩诃萨神力所化。彼时法慧童子。于无比宫女坐中化生者。即是尸弃梵王。寂慧。彼时持国转轮圣王诸宫嫔者。即是今此会中诸菩萨众。彼诸宫嫔。尔时得王千子成熟化度。而悉不退转于阿耨多罗三藐三菩提心安住大乘。彼诸宫嫔。次第当于此贤劫中受菩提记。寂慧。汝复应观缘生之法理不相违。善根诸因及发心胜行果无坏失。今此会中诸菩萨大士。皆能增长最胜意乐

佛说如来不思议秘密大乘经卷第五佛说如来不思议秘密大乘经卷第六

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    菩提道品第六

佛告寂慧菩萨言。若诸菩萨摩诃萨。欲证阿耨多罗三藐三菩提果者。当学彼诸大士所行。非但以其语言得最胜道。要当真实修行。乃得菩提正道。此中云何名菩提道。谓于一切众生无诸损害。随起慈心勤修波罗蜜多。以四摄法普摄一切。修四梵行。勤行三十七品菩提道法。圆满六种神通事业。以善方便摄化众生。长养一切善根法行。此说是名大菩提道

复次寂慧。菩提道者。所谓意乐信重深心。清净正直无谄心平等故。行平等法不作诸罪故。无诸怖畏。彼菩提道增长法故。即是布施波罗蜜多。彼菩提道向安乐道故。即是持戒波罗蜜多。彼菩提道无损害故。即是忍辱波罗蜜多。彼菩提道建立诸法故。即是精进波罗蜜多。彼菩提道无杂乱故。即是禅定波罗蜜多。彼菩提道善了知故。即是般若波罗蜜多。彼菩提道通达出生无碍智故。即是大慈。彼菩提道无退转故。即是大悲。彼菩提道作欢喜故。即是大喜。彼菩提道随入真实故。即是大舍。彼菩提道去除荆棘故。即能远离贪嗔害疑等染法。彼菩提道顺安乐法故。即心无障碍。彼菩提道离险恶故。即不着色声香味触。彼菩提道离邪外法故。即善观蕴处界。彼菩提道能降诸魔故。即能除去一切烦恼。彼菩提道是广大法故。即能远离声闻缘觉作意。彼菩提道顺正法故。即能随顺先佛如来应供正等正觉。彼菩提道广能积集大法宝故。即善随顺一切智宝。彼菩提道常开明故。即能显发无碍智光。彼菩提道为善说者故。即得诸善知识共所摄受。彼菩提道离高下想故。即无违顺。彼菩提道离尘暗故。即无嗔忿疲懈。彼菩提道向善趣故。即能远离诸不善法。彼菩提道善住安乐方故。毕竟趣证大涅槃法。寂慧。当知此如是等。皆是菩萨所行大菩提道。若非趣非道者。所谓一切声闻缘觉此中真实建立菩萨摩诃萨。悉令成就阿耨多罗三藐三菩提果

    如来身密不思议品第七之一

尔时寂慧菩萨摩诃萨。前白金刚手菩萨大秘密主言。大秘密主。为我略说如来秘密。此中云何。是为如来秘密之法。金刚手菩萨告寂慧菩萨言。善男子谛听谛听。我今承佛威神。为汝宣说如来秘密。有其三种。何等为三。一者身密。二者语密。三者心密。云何名为如来身密。寂慧。当知所谓如来于无思惟无分别中。而能示现诸威仪相。善男子。若天若人或有见如来坐生尊重者。即令彼等见如来坐。或有天人乐见行者。即令彼等见如来行。或有天人乐见住者。即令彼等见如来住。或有天人乐见卧者。即令彼等见如来卧。或有天人乐闻说法生尊重者。即令彼等见佛说法。或有天人乐见寂默者。即令彼等见佛寂默。或有天人乐禅定者。即令彼等见佛在定。或有天人乐出定者。即令彼等见佛出定。或有天人乐见不瞬观视者。即令彼等见佛不瞬观视。或有天人乐神变者。即令彼等见佛神变。或有天人乐欲观佛金色相者。即令彼等见金色身。或有乐见白银色者。水精色者。琉璃色者。玛瑙色者。珊瑚色者。琥珀色者。赤珠色者。白珠色者。青黄赤白等诸色者。如月色者。如日色者。如火色者。如光聚色者。如帝释色者。如梵王色者。如雪色者。如雌黄色者。如朱砂色者如水色者。如无忧树花色者。如瞻波迦花色者。如苏摩那花色者。如婆师迦花色者。如俱母陀花色者。如钵讷摩花色者。如奔挐利迦花色者。如众妙花色者。如毗沙门天王色者。如持国天王色者。如初开莲花色者。如吉祥藏宝色者。如摩尼宝色者。如帝青宝色者。如虚空净光色者。此如是等种种色相。乃至无边功德色相。随诸信乐。如来各各皆令彼等悉得见佛诸色相身

复次寂慧。乃至三千大千世界。如殑伽沙数等一切众生。皆得人身。彼彼众生。各于如来形显色相及威仪事。随所思惟信解。皆得成办。如一众生。如是信解亦然。彼彼一切众生。皆于如来形显色相及威仪事。思惟信解皆得成办。又复众生心所信解。而各差别。寂慧。以是缘故。如来普令一切众生各随信解威仪事等。心生欢喜随信解已。令诸众生了知如来威仪事等。亦非如来若身若心有所动乱。亦无发悟而能善知一切众生。往昔行业心意差别。是故如来随应普现威仪事等。譬如清净圆镜置诸方所光照众色。随安挂处一切影像悉于中现。所照平等无增无减。而是圆镜无所思惟亦无分别。寂慧。如来亦复如是。了知一切众生心意。随所现相悉令欢喜。而佛如来无所思惟。亦无分别复无发悟。此即是名如来身密。复次寂慧。如来身者。非蕴处界之所成立。非业所成非烦恼生。不从父母胞胎所生。非羯逻蓝等大种所生。非血肉染污筋骨联续出入息等资养所生

复次寂慧。如来身者即非身也。所谓法身如虚空身。非色相身。离诸戏论无所行身。若诸众生乐见色相。而生信重所应度者。如来乃现色身诸对碍境。若诸众生乐法离相生信重者。于一切处一切种类无对碍境。天眼亦复不能观见。寂慧。当知一佛会中所有大众其见各异。或有众生见佛身者或不见者。或远处即见近处不见。或近处即见远处不见。或远处亦不见近处亦不见。或专注心见散乱心不见。或散乱心见专注心不见。或他观即见自观不见。或自观即见他观不见。或梦境中见寤已不见。或觉寤已见梦中不见。或定中见出定不见。或出定见定中不见。或善相即见不善相不见。或不善相见善相不见。或发悟心见无发悟心不见。或无发悟心见发悟心不见。或加行心见无加行心不见。或无加行心见加行心不见。此如是等。及余无量种相观如来身。彼色界天子。身相寂静所行寂静。善威仪道住等引心。善寂善调然目睢动。亦复不能观如来身分量色相。何以故。如来身者具无量种庄严色相。与虚空等。以其法身所成性故。譬如虚空广大无际。如来身相广大亦然。又如虚空遍入一切处一切处通达。如来身相亦复如是。遍入一切处一切处通达。又如虚空离诸戏论。如来身相亦复如是离诸戏论。又如虚空普能滋养一切众生。如来身相亦复如是。普能滋养一切众生。又如虚空无其种类亦无分别。如来身相亦复如是。无其种类亦无分别。又如虚空随入一切色相光明。如来身相亦复如是。随入一切色相光明。又如虚空所有一切色相光明悉住其中。如来身相亦复如是。一切众生色相光明住佛身中。又如虚空一切药草树林悉依止故而得滋长。如来身相亦复如是。悉能滋长一切众生所有善根。又如虚空非常非无常。而不可以语言宣说。如来身相亦复如是。非常非无常。而不可以语言宣说。亦复不能观其顶相

复次寂慧。我不见有世间一切天人魔梵沙门婆罗门等。而能观见如来应供正等正觉最胜顶相。所以者何。寂慧。当知我念一时世尊如来成道未久。在波罗奈国仙人堕处鹿野苑中。转妙法轮。是时东方有佛世尊。号瞻波迦花色世界名如幻。国名调冤。彼有菩萨名曰风持。来此娑婆世界。瞻礼亲近世尊释迦牟尼如来。到已头面顶礼佛足。右绕七匝住立佛前。尔时风持菩萨。承佛威神即作是念。今佛世尊身相广大无量无边。不能观其顶相。我今或可于佛世尊身量边际求以度量。风持菩萨作是念已。自见其身长六万八千由旬。见佛身相长八百四十万由旬。复作是念。我今或以自所得者游戏神力。而可度量如来身相分量边际邪。作是念已。即时菩萨承佛威神。以自通力乃往上方。过百俱胝殑伽沙数等佛土。有世界。名大莲华。佛号莲华吉祥藏王如来。现住说法教化众生。菩萨到已审谛观察。不能得见如来顶相。亦复不能度量佛身分量边际。时风持菩萨。前诣世尊莲华吉祥藏王如来所。头面礼足右绕七匝住立佛前。白佛言。世尊。我所来此其远近邪。彼佛告言。善男子。过百俱胝殑伽沙数等佛国土已到此世界。风持菩萨白彼佛言。世尊。我为不能观彼世尊释迦牟尼如来顶相。亦复不能观彼佛身分量边际。故远来此而伸请问。彼佛答言。善男子。假使汝今尽其神力。极尽上方一切世界。经于殑伽沙数等劫。亦复不能知彼佛身分量边际。又善男子。假使尽诸喻法不能譬喻。彼佛如来。所有戒定慧解脱解脱知见种种功德。若身语心若色若相。一切喻法皆不能喻。以彼如来超数法故。唯除虚空而可喻之。所谓如来戒定慧解脱解脱知见。悉如虚空故。若身语心若色若相。此说一切皆如虚空。是故应知。虚空无量故。如来身相亦复无量。寂慧。彼风持菩萨于彼佛所。闻是说已发希有心。踊跃欢喜适悦庆快。即时头面礼彼佛足。右绕七匝承佛威神。于刹那间隐彼佛土。还复至此娑婆世界。住立世尊释迦牟尼佛前。顶礼佛足右绕三匝。合掌谛诚向佛世尊。说伽陀曰

  一切佛法极广大　　与虚空等无边际
  若人意欲度其边　　彼即自招于损害
  我过百俱胝数量　　殑伽沙等佛刹土
  往一如来刹土中　　欲观如来身分量
  我既至彼佛刹已　　世界名曰大莲华
  不能观佛顶相高　　亦复不知身分量
  化主世尊居彼刹　　其名吉祥藏王尊
  彼佛知我意所思　　发如是言为我说
  若人欲以譬喻法　　喻其无边诸佛法
  彼佛不可随相知　　是人返招谤佛罪
  唯其一法可为喻　　与诸佛法等无异
  所谓周广太虚空　　分量边际不可得
  如其虚空广大故　　佛功德聚亦复然
  谓戒定慧解脱门　　及彼解脱知见等
  如其虚空无分量　　佛色相等亦复然
  顶相高广不能观　　与彼虚空界无异
  如其虚空广大故　　佛身广大亦复然
  由身广大量无边　　光明广大亦如是
  由其光明广大故　　语密广大亦复然
  语密广大量无边　　心密广大亦如是
  由其心密广大故　　佛慈广大亦复然
  佛慈广大量无边　　佛智广大亦如是
  由其佛智广大故　　佛身广大亦复然
  菩提出生胜福门　　广大无际亦如是
  由菩提心所生福　　胜相从彼福门生
  圆满虚空界无边　　出生胜上诸功德
  所有一切众生类　　普摄一切诸福蕴
  一切菩萨亦复然　　皆从菩提心所出
  所有一切菩萨众　　宣说福蕴极广大
  若能护持正法门　　所获福聚多于彼
  假使诸佛加行智　　经俱胝劫共宣扬
  护持正法福无边　　毕竟不知其边际
  大菩提心所生福　　护持正法福无边
  空解脱门若校量　　十六分中不及一
  空解脱门此所摄　　亦复不离菩提心
  护持正法诸福门　　一切皆同此中摄
  若能了此妙法趣　　是即菩萨大名称
  菩提功德获无边　　此乃是修菩萨行
  我今说是伽陀时　　俱胝刹土皆震动
  有千俱胝众天人　　鼓吹歌音俱胝数
  有千俱胝众生数　　悉发广大菩提心
  闻佛如是大威神　　风持我今如实说
  佛有如是不思议　　无量无边复无上
  诸佛普现众相门　　即自然智真秘密

寂慧当知如是等说。是即名为如来秘密

佛说如来不思议秘密大乘经卷第六佛说如来不思议秘密大乘经卷第七

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来身密不思议品第七之余

复次寂慧。如来身相。一众会中有得见者有不见者。其得见者欢喜瞻仰。其不见者默然懵瞪。寂慧当知。如来不以段食资养。或有众生见佛亦受世间食者。谓有威力具足修菩提行。诸贤圣众常随佛后。于食器中承受其食。是乃众生见佛如来数数举食置食器中。彼诸贤圣既受食已。若有众生于佛法中所应化度。宿种善根业障尽者。虽复在在所生不得饮食饥渴羸劣。以其宿善力故。彼等众生得佛如来残食而食。食已饱满心得轻安。身肢润益深心清净。即发阿耨多罗三藐三菩提心。若诸众生。堕在地狱饿鬼诸恶趣者。即不能发大菩提心。以是缘故乃至尽涅槃界寂慧。是故当知如来不受世间饮食。如来资养所谓法食。佛身坚固如那罗延天。真实故不坏故。金刚所成。寂慧。如来身者。非生熟藏之所成养。亦非涕洟杂恶不净所成。如来身者。如阎浮檀金。无缺无断离诸过失。如来身者。具大威力体坚重故犹如金刚。极柔软故如迦左邻那衣。随所触身皆获妙乐。寂慧当知。一时有诸具大威力天子天女礼敬佛足。随礼敬时手触佛足。触已即发阿耨多罗三藐三菩提心。是故当知如来不从杂染所生。复次寂慧。世间所有贪行众生暂见如来身已。即于自身生离贪想。嗔行众生。暂见如来身已即起慈心。痴行众生暂见如来身已。即得智光照耀等。分行众生暂见如来身已。即于已身离诸烦恼。悭吝众生暂见如来身已。即能信解舍法。破戒众生暂见如来身已。即能信解戒法清净。忿恚心众生暂见如来身已即得忍法。懈怠众生暂见如来身已即起精进。散乱心众生暂见如来身已即得寂定。愚痴众生暂见如来身已即得胜慧。善男子。取要而言。若诸众生暂见如来身者。一切善法皆不舍离。一切不善疑等染法。悉得销除安立善心。然佛如来而常安住无分别舍。此说是名如来身密

复次寂慧。又如如来化所化人作诸佛事。而佛如来心无加行。亦无发悟复无作意。佛亦不作是念。我能化彼所化人等。然所化众生可应度者。若此世界若他世界。乃至阿僧祇百千世界一切众生。为成熟故作诸利益。此说是名如来身密

复次寂慧。如来身放广大光明。具有无数百千种色。其光普照十方一切殑伽沙等诸佛刹土。广为成熟一切众生。而佛如来无所发悟。亦无加行复无作意。此等是名如来身密身业清净。寂慧。当知今此皆是。少略宣说如来身密身业业清净。若广说者。纵经一劫或过一劫。而亦不能得其边际。金刚手菩萨大秘密主。说是如来身密不思议法时。会中有十千人发阿耨多罗三藐三菩提心。八千菩萨获得忍法

尔时会中有诸天人以诸妙花散于佛上。及供养金刚手菩萨大秘密主。是时世尊舒右金色臂。置金刚手菩萨大秘密主顶上。作是赞言。善哉善哉秘密主。汝善宣说如来身密不思议法我悉知之。汝所说法我今随喜

    如来语密不思议品第八之一

复次金刚手菩萨大秘密主。告寂慧菩萨摩诃萨言。复何名为如来语密语业清净。所谓如来于昼夜中。成证阿耨多罗三藐三菩提果。于昼夜中。入大涅槃。然其中间。如来未尝宣说一字亦无诠表。何以故。以佛如来常在三摩呬多故。如来亦无出息入息若寻若伺。以无寻伺故。所出语言离诸邪妄。而佛世尊无寻无伺。无所分别无广分别。无说无示复无诠表。然诸众生亦闻如来有所宣说。而是如来毕竟在定。于一切种及一切时。亦以文字而能诠表。复无所表。若有众生因以文字生信重者。而彼众生自谓如来为我说法。然佛如来心常安住无分别舍

复次寂慧。如来亦非唇齿舌喉及其面门。出诸音声有所闻听。如来所出音声从虚空出。但以众生谓佛如来所有音声。从口门出。寂慧当知。如来语言具有六十四种殊妙之相。何等名为六十四种。一者流泽。二者柔软。三者悦意。四者可乐。五者清净。六者离垢。七者明亮。八者甘美。九者乐闻。十者无劣。十一者圆具。十二者调顺。十三者无涩。十四者无恶。十五者善柔。十六者悦耳。十七者适身。十八者心生勇锐。十九者心喜。二十者悦乐。二十一者无热恼。二十二者如教令。二十三者善了知。二十四者分明。二十五者善爱。二十六者令生欢喜。二十七者使他如教令。二十八者令他善了知。二十九者如理。三十者利益。三十一者离重复过失。三十二者如狮子音声。三十三者如龙音声。三十四者如云雷吼声。三十五者如龙王声。三十六者如紧那罗妙歌声。三十七者如迦陵频伽声。三十八者如梵王声。三十九者如共命鸟声。四十者如帝释美妙声。四十一者如振鼓声。四十二者不高。四十三者不下。四十四者随入一切音声。四十五者无缺减。四十六者无破坏。四十七者无染污。四十八者无希取。四十九者具足。五十者庄严。五十一者显示。五十二者圆满一切音声。五十三者诸根适悦。五十四者无讥毁。五十五者无轻转。五十六者无动摇。五十七者随入一切众会。五十八者诸相具足

复次寂慧。五十九者如来所出语言。普令十方一切世界一切众生心意欢喜。佛亦不作是念。我能宣说诸法。所谓契经。应颂。记别。讽诵。自说。缘起。本事。本生。方广。希法。论议。譬喻。又复秘密先行法。说本缘法说昔因法。近说多说广说。教示安立分位分别。解释开明如来所说。如是等法于彼一切大众会中。若苾刍苾刍尼优婆塞优婆夷众会。若天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等诸众会。佛能各各随其根性精进分量。如其所应为作法施。彼等众会闻说法时。皆谓所说从佛如来口门而出。然所说法亦无互相语言重复。而诸众会各随音声晓了诸法。寂慧。此即是名如来语密

复次寂慧。六十者。一切众生其数无量。一切众生行亦无量。如来所说众生心行。略有八万四千种类。但为根性下劣众生。令其解入如来所说。寂慧。当知众生心行无其分量。世间所有贪行众生。嗔行众生。痴行众生。等分行众生。彼彼众生心行差别。若佛如来于一劫中或过一劫。乃至如来住世经百千劫。随几许寿量极寿分限。而亦不能说诸众生心行边际。若佛但说众生心行无边际者。而诸众生不能解入返生痴迷。是故如来以善方便。于诸众生无量行中。略说数有八万四千。又复如来所说诸法。随诸众生心行差别。如其所应皆令开觉。寂慧。此即是名如来语密

复次寂慧。六十一者。如来语秘密智。随入一切众生心意。然其语言不从如来口门中出。但从虚空而出。若有众生谓佛如来所有语言从口门出者。彼勿起是见何以故。或有众生。见佛语言从乌瑟腻沙相出。或从顶出。或发际出。或从肩出。或从额出。或眉间出。或毫相中出。或从眼出。或从耳出。或从鼻出。或从颊出。或口门出。或从颈出。或从臂出。或从手出。或从指出。或两胁出。或胸前出。或背后出。或从脐出。或阴藏出。或从眼出。或从膝出。或从腨出。或从踝出。或从足出。或从诸相好中出。或从一切毛孔中出。如是等众生。知解有异。寂慧。此即是名如来语密

复次寂慧。六十二者。如来所出语言。随诸众生种种信解。随诸众生心意成熟。普使随应而得了知。然佛如来常住无分别舍。譬如世间假法所成诸音乐器。随彼所作而悉妙巧。手不触近非假人力。微风吹动出美妙声。其所出声皆是先业差别风所吹击。如来语言亦复如是。随诸众生一切意乐。智风吹击。亦非如来勤力所出。如来随顺一切众生先业差别众生境界。如应所说。寂慧。譬如响声随有所表。其所出声非内非外亦非中间。如来语言亦复如是。随其所出但为表了众生心意。而如来声非内非外亦非中间。又如大海之中。有如意珠宝。其名圆满一切意乐。悬高幢上自然出声。谓言此珠能满一切众生意乐。而是珠宝亦无分别。如来亦复如是。语言妙宝深心清净。悬置大悲幢上。随诸众生所有意乐。如来出妙语言。悉令晓了。然佛如来常住无分别舍。寂慧。此即是名如来语密

复次寂慧。六十三者。诸佛如来所有音声。无其分量。我不见有世间一切天人魔梵沙门婆罗门等。能知如来音声边际及分量者。何以故。我念一时。佛在王舍大城鹫峰山中。诸菩萨众而共围绕。宣说音声轮清净法门。广为众生显明宣示。于后一时。以慈氏菩萨摩诃萨加持力故。尊者大目干连即作是念。如来音声净轮分量。几何远邪。作是念已乃于本座隐而不现。以自神力即往须弥山顶。听佛如来音声远近。复运神力遍往三千大千世界。又过须弥山西。复过四大洲界。又过铁围山大铁围山。乃至世界边际。还住铁围山顶。审听如来音声分量。是声平等无所增减

尔时世尊知其事已。即作是念大目干连。意欲度量我之音声所有分量。我于今时宜摄神力。于是世尊摄神通已。大目干连承佛威神所加持故。以自通力于此世界西之方分。过九十九殑伽沙数佛刹土已。往一世界名光明幢。彼有如来号光明王。现住说法教化众生。是时尊者大目干连。到彼土已。审听世尊释迦牟尼如来音声分量。譬如十肘地方分中。此闻彼人所说音声。大目干连在彼世界。听佛音声亦复如是。其声平等无所增减。彼光明王如来。所有身量高百由旬。诸菩萨身高五十由旬。是时大目干连。以自神力于彼诸菩萨众所用钵中。循环而行。彼诸菩萨见是相已极生轻笑。即白佛言。世尊。今云何有如沙门相小虫。来此钵中循行。彼佛告言。诸善男子。汝等不应生轻慢心。所以者何。今此钵中行者。是彼世尊释迦牟尼如来上首声闻弟子。于大声闻众中神通第一

尔时尊者大目干连。前诣光明王如来所。头面礼足右绕七匝住立佛前。彼佛告言。尊者大目干连。此诸菩萨有所轻笑。汝今宜应承彼世尊释迦牟尼如来应供正等正觉所加持故。以自通力现诸神变。尊者大目干连白彼佛言。我今如佛教敕加趺而坐。于此宝洲作变化事。佛言。今正是时。尊者大目干连。即时勇身空中。高七俱胝多罗树量。作变化事。于其坐中化现百千俱胝那庾多。真珠璎珞广大庄严。而彼璎珞各出百千俱胝光明。一一光明门皆生莲花。是诸莲花台中。皆有世尊释迦牟尼如来形像安处其上。彼如来像皆悉宣说妙音声轮清净正法。大目干连白彼佛言。世尊。我今加趺而坐。于此四大洲一切世界。亦能作诸神通变化。乃至此小千世界。中千世界。三千大千世界。悉能作诸神通变化。彼佛告言。今正是时

尔时尊者大目干连。如其所应现神变已。收摄神力还住佛前。时彼诸菩萨众咸生希有之心。前白佛言。世尊。今此尊者大目干连。其何所为到此世界。彼佛告言。诸善男子。此大目干连为欲度量彼世尊释迦牟尼如来声轮分量故来至此

时彼世尊光明王如来。告尊者大目干连言。汝自今而往。勿复再起是心欲度如来声轮分量。谓以如来清净音声。无其分量不可度量故。假使以汝威势神力。极西方分经于殑伽沙数等劫。毕竟不能得彼世尊释迦牟尼如来音声妙轮分量边际。以佛如来音声妙轮无分量故

佛说如来不思议秘密大乘经卷第七佛说如来不思议秘密大乘经卷第八

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    如来语密不思议品第八之余

尔时尊者大目干连。礼彼佛足作是白言。世尊。我今悔罪我今悔罪。我于释迦牟尼如来无量音声清净妙轮。辄欲度量我斯深罪。又复世尊。我所来此几何远邪。彼佛答言。大目干连。汝过九十九殑伽沙数等世界已。到此刹中。大目干连白言。我此所来而极遥远。身力疲懈不能还复本刹土中。彼佛告言。大目干连。于汝意云何。汝勿起是见谓汝以自神力能到此刹。何以故。但以释迦牟尼如来加持力故汝能至此。汝今欲还本刹土者。应向彼佛虔伸敬礼。大目干连。汝今当知。若以汝自通力欲还本土。纵经一劫亦不能往。或复未至彼土中间而入涅槃。大目干连。汝今至此东西南北。谓何方分邪大目干连言。我心迷昧不知今时在何方分。彼佛告言。以是缘故汝今当知。若以汝自通力纵经一劫。毕竟不能还彼刹土。大目干连言。彼世尊释迦牟尼如来今在何方。彼佛告言。大目干连。彼世尊释迦牟尼如来现处东方。是时尊者大目干连。即向东方五轮着地。至诚敬礼世尊释迦牟尼如来。说伽陀曰

  二足圣尊摄受我　　人天供养大威德
  无边智具无边音　　我今欲还于本土

寂慧。今此王舍城鹫峰山中一切众会。以释迦牟尼如来威神力故。悉闻尊者大目干连号哭之声

尔时尊者阿难。前白佛言。世尊。今此所闻号哭之声。为何相邪。佛言阿难。此是目干连苾刍。往西方分去此佛刹。过九十九殑伽沙数等刹土。到光明幢世界世尊光明王如来刹中。现在于彼将欲还复此娑婆界故。有如是号哭之声。阿难白佛言。世尊。尊者大目干连。以何缘故到彼世界。佛言阿难。大目干连将还此土。其事因缘汝自当知

尔时鹫峰山中一切众会。合掌恭敬咸白佛言。世尊。我等乐见彼光明幢世界。瞻睹世尊光明王如来。及欲见彼诸菩萨众并尊者大目干连。尔时世尊。受劝请已即于眉间放大光明。名一切处通达。其光普照九十九殑伽沙数等佛刹。相续不断。于彼光明幢世界广大照曜。是时此会一切大众。悉得见彼光明幢世界。瞻睹世尊光明王如来。及见彼诸菩萨。又见大目干连五轮着地。向佛作礼发声号哭

尔时世尊释迦牟尼如来。告尊者大目干连言。汝今宜应随光所照。来复此土

尔时尊者大目干连。承佛世尊大光明轮。于思念间即时还此娑婆世界。住立佛前向佛世尊。头面礼足右绕七匝。重复谛诚五轮着地作是白言。世尊。我今悔罪我今悔罪。我于世尊无量音声清净妙轮。辄欲度量。我斯深罪故。我远适他界听佛音声。既至彼已。所闻佛声与此无异。佛言目干连。如汝所说。如来音声无有分量。犹如虚空无其分量。复无边际不可度量。若其虚空可度量者。如来音声亦可度量。何以故。虚空广大故。如来音声亦复广大。当王舍城中。往昔说是大目干连去来事时。有十千人发阿耨多罗三藐三菩提心。金刚手菩萨。告寂慧菩萨言。寂慧当知。此即是为如来语密

复次寂慧。六十四者。所有一切众生心心所转。而一众生心多于彼。寂慧菩萨言。大秘密主。若一众生心心所转。假使遍满三千大千世界。一切众生皆居缘觉之地。纵经一劫而亦不能思惟称量校计伺察。何况一切众生。金刚手菩萨言。寂慧。我今告语于汝。使汝开觉所有一切众生心心所转。即彼如来音声妙轮。出种种声宣说法时。令诸众生咸生欢喜。然佛世尊常住无分别舍。尔时金刚手菩萨。说伽陀曰

  三千世界诸众生　　一切皆证缘觉果
  纵经一劫尽筹量　　一众生心不能晓
  世间所有一众生　　唯佛能知彼心意
  随众生心虽了知　　佛无发悟无分别
  乃至一切众生类　　总聚思惟有其三
  世尊随类如所应　　净妙声轮宣正法
  法中自在演妙音　　一切闻者咸欣悦
  随所宣说名相生　　以诸法名善开示
  所有一切众生类　　色相名字及思惟
  一毛孔中放光明　　如来随应善分别
  所有世尊大慈化　　一切毛孔放光明
  光明超胜人中尊　　音声轮中宣妙法
  假使佛经一劫中　　以诸譬喻善宣说
  然佛语及音声轮　　毕竟不得其边际
  一切烦恼无色相　　所说语言亦无相
  由其语言无相因　　烦恼无相自息灭
  是故语言诸色相　　于一切处不可得
  以其毕竟无得故　　烦恼色相亦如是
  由其语言不实故　　所说非内亦非外
  烦恼不实亦复然　　染性非内亦非外
  以无少法可得故　　佛所说言遍十方
  烦恼无得亦复然　　是故有所佛宣说
  一切众生语言道　　上中下品有其三
  语言非身亦非心　　此中无住非无住
  譬如假法成乐具　　由风吹击众音声
  所出音声无所从　　是中亦无造作者
  由其宿昔善净性　　一切众生意风吹
  故佛世尊出妙音　　然佛亦无分别想
  譬如应声而对响　　音声非内亦非外
  人中尊出妙言语　　非内非外亦如是
  又如珠宝无分别　　令诸众生喜乐生
  佛无分别亦复然　　一切音声皆圆满

复次寂慧。当知如来语秘密智。随入一切众生宣说诸法。所有三千大千世界。一切众生种种生处。如来随入一切众生语言音声。以种种名字安立四谛。寂慧。如其所说。苦苦集苦灭向苦灭道谛

所有地居诸天。作如是说

珂吠　珂嚩牟梨　珂嚩那曳　珂嚩度噜

即是此说苦苦集苦灭向苦灭道谛

彼空居诸天作如是说

多哩帝　阿嚩哩帝　阿嚩哩多尾誐弥　阿嚩哩多儞萨多啰尼

即是此说苦苦集苦灭向苦灭道谛

彼四大王天作如是说

伊尼　　弥尼　捺纰　捺罗纰

即是此说苦苦集苦灭向苦灭道谛

彼忉利天作如是说

阿嚩哩多儞　阿西嚩帝　叉野嚩帝　叉野耨誐弥

即是此说苦苦集苦灭向苦灭道谛

彼夜摩天作如是说

输梨　输罗西嚩儞　输罗叉曳　输罗叉野婆嚩儞

即是此说苦苦集苦灭向苦灭道谛

彼兜率天作如是说

乌珂梨　目珂梨　尾嚩努　散左哩

即是此说苦苦集苦灭向苦灭道谛

彼化乐天作如是说

多啰多　散多啰多　多啰叉野　多啰目珂

即是此说苦苦集苦灭向苦灭道谛

彼他化自在天说作如是

诃诃呼　诃诃尾那曳　诃诃尾誐弥　诃啰儞誐弥

即是此说苦苦集苦灭向苦灭道谛

彼魔众天作如是说

盎誐览　盎誐啰母蓝　盎誐啰播都桑　盎誐啰儞　悉帝啰赧

即是此说苦苦集苦灭向苦灭道谛

彼梵众天作如是说

秫毗　秫毗葛哩　秫毗尾舍那　秫婆嚩哩多那

即是此说苦苦集苦灭向苦灭道谛

彼梵辅天作如是说

弥诃哩　僧诃哩　娑啰尼　娑啰娑啰尼

即是此说苦苦集苦灭向苦灭道谛

彼梵会天作如是说

没啰拏　没啰拏散提　没啰拏没噜诃拏没噜诃努波舍摩

即是此说苦苦集苦灭向苦灭道谛

彼大梵天作如是说

多啰讷哩　　多啰左俱哩　多萨布哩　俱啰嚩诃儞

即是此说苦苦集苦灭向苦灭道谛

彼少光天作如是说

呬呬　系呬　呼护　诃啰奴散提

即是此说苦苦集苦灭向苦灭道谛

(此下合有无量光天光音天说四谛文梵本元阙)彼少净天。作如是说

乌呬多　儞嚩呬多　儞誐叱多　儞誐摩儞

即是此说苦苦集苦灭向苦灭道谛

彼无量净天作如是说

西嚩儞　散西嚩儞　刹野西嚩儞　阿西嚩儞

即是此说苦苦集苦灭向苦灭道谛

彼遍净天作如是说

波哩砌祢　波哩砌努捺曳　嚩那俱梨　菩陀尾秫提

即是此说苦苦集苦灭向苦灭道谛

彼广果天作如是说

阿讫哩多　阿迦啰尼　阿啰拏尾誐帝　迦罗拏儞瑟耻

即是此说苦苦集苦灭向苦灭道谛

(于第四禅九天之内合有无云福生无想三天梵本元阙)彼无烦天作如是说

阿耨誐摩那　阿那誐摩那　阿耨散提　阿耨散提誐摩那

即是此说苦苦集苦灭向苦灭道谛

彼无热天作如是说

秫提　秫驮嚩帝　秫驮波哩秫提　　驮驮誐摩儞

即是此说苦苦集苦灭向苦灭道谛

彼善见天作如是说

[牟*含]摩摩　[牟*含]摩弥　摩那耨誐摩野　摩那耨誐摩

即是此说苦苦集苦灭向苦灭道谛

彼善现天作如是说

目讫底　目讫多嚩底　目讫多母梨　目讫多摩多耨散提

即是此说苦苦集苦灭向苦灭道谛

彼色究竟天作如是说

儞瑟耻　阿颠多儞瑟耻　阿羯腊波儞　阿钵啰底散提

寂慧当知。如是等诸天各各以其随天语言。安立四谛。并余龙众夜叉众乾闼婆众阿修罗众迦楼罗众紧那罗众摩睺罗伽众。及坚身夜叉众持鬘夜叉众等。各以彼彼种类语言。安立四谛

寂慧。此阎浮提诸国土中。少略而言满千国土。乃至十六大国一切人众。随彼方处种种语言。种种音声种种心想。如来随入一切语言音声。施设名字。所立四谛悉能解了。所谓尸迦国人。乃至世界边际所住国人。如是等阎浮提中满千国土。一切人众种种语言。种种音声种种心想。施设名字各说四谛。如来随入一切语言音声。悉能解了。亦非如来心识语言有所流散。寂慧。此小千世界中。有九十四俱胝那庾多百千种类语言名字。各说四谛。总摄一切所说言音。皆悉同归一四谛义。即是胜义谛。即是无生谛。即是如实谛。即是不动谛。寂慧。此即是为如来语密

复次寂慧。如来语言而能断除一切众生疑惑不决。所谓十方无量阿僧祇世界。普摄一切众生以佛智所知。而众生界多于地界。寂慧。正使一切众生。各各获得智慧具足。与尊者舍利子等无有异。以是缘故一切众生。各各皆以如舍利子所等智慧。以疑惑事于一劫中或过一劫。共相问难思惟称量伺察。而一众生复胜于一。是诸众生。以所疑事互思惟已。一时俱来请问世尊。时佛世尊。于弹指间应问皆答。是故世尊。随了一众生所起心念。普摄一切众生。咸以一音悉为宣说断诸疑网。令诸众生得断疑已。咸生欢喜。寂慧。此即是名如来语言。普能断除一切众生疑惑不决。然非如来心及语言有所动转。一切皆是如实所说。寂慧当知。如是等说。皆是如来秘密之语希有之语。此即名为语业清净

金刚手菩萨大秘密主。说是如来语秘密主。会中有三万二千众生发阿耨多罗三藐三菩提心。十方一切诸佛刹中。所有贤劫诸菩萨众。各各在彼佛世尊所修梵行者。是诸菩萨为供养佛及金刚手菩萨大秘密主故。垂诸宝盖散以妙花。是花槃旋来此会中。散于佛上及金刚手菩萨之身。乃至遍散一劫众会。其诸宝盖旋复空中住佛顶上。而诸宝盖出妙音声。作如是言。我等贤劫诸菩萨众。遣此奉用供养。世尊及金刚手菩萨大秘密主。惟愿摄受。随佛如来向所。宣说未曾有法。一切众会皆悉闻已。各复增胜发希有心。即向金刚手菩萨大秘密主。虔伸顶礼极生最上信重之想。咸作是言。大秘密主。我等今时快得善利。获闻金刚手菩萨宣说如来语密不思议法门。若诸众生闻此所说信解无疑。是诸众生所得人身功不唐弃。即为如来所应化度。彼得不退转于阿耨多罗三藐三菩提

佛说如来不思议秘密大乘经卷第八佛说如来不思议秘密大乘经卷第九

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净奉　诏译

    如来语密不思议品第八之余

尔时世尊。普告一切众会赞言。善哉善哉。乃谓寂慧菩萨摩诃萨言。寂慧当知。所有如来真实之理。如来正法如来所行。一切世间实难信解。而此正法。金刚手菩萨大秘密主能善宣说。若诸众生不久当得具是法者。即能于此所说正法。随其闻已而生信解。生信解已即能受持不惊不怖。随入义趣了真实性。是人当得授阿耨多罗三藐三菩提记。当佛如来称赞金刚手菩萨大秘密主善说法时。十方无量阿僧祇世界六种震动。有大光明普遍照曜。空中自然雨众妙花。鼓吹歌音种种振击。有阿僧祇众生发菩提心。阿僧祇菩萨得随顺忍。阿僧祇菩萨得无生法忍。阿僧祇菩萨善根成熟故。得一生补处。时彼大众会中佛世尊前。六万八千由旬之内。地界忽然而悉破裂。大水腾涌如恶叉聚。高起空中彻于梵界。时此一切三千大千世界香水充满

是时佛告寂慧菩萨摩诃萨言。寂慧。汝今见此水腾涌不。寂慧菩萨白佛言。我见世尊。今此所有是何先相。佛言寂慧。今此大地忽然破裂。水腾涌者非所思念。其有受持此正法者。彼等众生亦复如是。于正法中解如实理豁然开悟。而彼所有一切无明见等诸罪业门悉能开豁。无尽法光胜慧辩才所说理教。皆能出现。乃是金刚手大士。善为众生宣说正法。令诸众生心生欢喜。寂慧。当知今此正法。悉是如来不共胜相

    如来心密不思议品第九

复次金刚手菩萨大秘密主。告寂慧菩萨摩诃萨言。复何名为如来心密心业清净。寂慧。譬如无色界天众生。生已同以一识而为所缘。住八万四千劫。彼识亦非随余识转。尽寿边际于彼灭已。随业成熟随处受生。如来亦复如是。以无住识于昼夜中。菩萨成证阿耨多罗三藐三菩提果。于昼夜中如来入无余依大涅槃界。于其中间而佛如来。无心可转无心伺察。无心不伺察。无心知解。无心思念。无心限量。无心积集。无心离散。无心动乱。无心可高。无心可下。无心防卫。无心趣向。无心勇悍。无心观瞩。无心恼害。无心流荡。无心寂定。无心喜悦。无心逼恼。无心安处。无心遍行。无心分别。无心差别。无心遍计。无心在止。无心在观。无心随流于识。无自心建立。无他心观察。无心依止于眼。无心依止耳鼻舌身意。无心依止色。无心依止声香味触法。无心住所缘处。无心住意处。无心住内处。无心住外处。无心依法行。无心依智行。无心观察过去未来现在等法。寂慧。此是如来心业清净。如来心者无少法可取。于诸法中。但以无著无碍知见而转。如来自心既清净已。于诸众生不清净心。亦复不见于彼有见。及彼无见无所分别。虽有所见。而无戏论见无所见。是名为见彼如来智。不与肉眼所见相应。不与天眼所见相应。不与慧眼所见相应。不与法眼所见相应。不与佛眼所见相应。不与天耳所闻相应。不与他心智所知相应。不与宿住随念智所思相应。不与神通智所作相应。不与有漏智相应。于彼一切法所可相应者。谓一切法无碍之智。然佛如来而无加行。亦无发悟复无作意。善住如来智光明中。观察一切众生心行。了知一切法若染若净。所有如来十力。四无所畏。十八不共佛法。以如来智悉不舍离。然佛如来于是法中而无加行。亦无发悟复无作意。如来离心意识。常在三摩地中。亦不舍离一切佛事。于一切佛法无碍智中。而无所著。寂慧。譬如如来化如来像。彼所化像无心意识。无身行语行意行所转。以佛加持力故。而能施作一切佛事。如来亦复如是。与所化像等无异故。见一切法皆悉如化故无分别。于身语心无所发起。而能施作一切佛事。然无加行亦无发悟。复无作意。何以故。如来了知一切法相自性如化。是故如来自觉悟已。为悲愍故方便开觉一切众生。寂慧。当知彼如来智。不住有为不住无为。不住蕴处界。不住于内不住于外。不住善法不住不善法。不住世间不住出世间。不住有罪不住无罪。不住有漏不住无漏。不住过去不住未来不住现在。不住择灭。不住非择灭。如是乃至不住于识。如来于一切众生心行意乐之中。但以无著无碍知见而转。然无加行。亦无发悟复无作意。寂慧。此即是为如来心密不思议法。是故当知如来常在三摩呬多。亦不舍离一切众生心意表了

    称赞金刚手菩萨大秘密主功德品第十

尔时尊者舍利子。前白佛言。世尊。所有十方世界。贤劫诸菩萨众。现于诸佛世尊所修梵行者。彼金刚手菩萨大秘密主。于是诸菩萨众中。常随何等菩萨之后。佛言。舍利子。止止此是不思议行。世间天人于菩萨行。不生信者返招迷乱。若有众生。为善知识所摄受者。即于是中闻已净信不生惊怖。舍利子白佛言。我于如来极生净信。惟愿世尊为我宣说。佛言舍利子。金刚手菩萨大秘密主常随我后。汝能见不。舍利子白佛言。我以世尊威神力故。今方得见。亦非宿昔自能知见。佛言舍利子。如是如是。汝今当知。彼贤劫中诸菩萨众。而金刚手菩萨大秘密主常随其后。于一切处。现金刚手菩萨形相。以宿愿力及神通力故能如是。舍利子。乃至三千大千世界。所有一切诸众生类。而是金刚手菩萨大秘密主。现本形相亦常随后。然于所现加持智力。亦未圆满。又舍利子。彼金刚手菩萨。常随慈氏菩萨之后。汝能见不。舍利子白佛言。世尊。我今初见非昔所见。佛言舍利子。彼常随后汝自不见。他方世界若诸菩萨。若梵王帝释护世天等。常来见彼金刚手菩萨。执金刚杵。随慈氏菩萨之后。又舍利子。或于一时。彼贤劫中诸菩萨众。为慈氏菩萨现俱胝那庾多百千种诸变化事。而是金刚手菩萨大秘密主。亦随彼诸菩萨之后助加持故。又舍利子。乃至如来作变化事时。彼金刚手菩萨大秘密主亦随佛后。以愿力故助扬圣化。舍利子。是故当知。此如是等。皆是金刚手菩萨大秘密主。不思议神通加持智力。悉具足故

    菩萨苦行超胜以受食缘成熟众生品第十一

尔时寂慧菩萨摩诃萨。白金刚手菩萨大秘密主言。秘密主。汝可乐说菩萨苦行。诣菩提场降伏魔军。转正法轮。庄严佛土等事。我今欲闻愿为开发。此如是等希有之事汝现证知。金刚手菩萨大秘密主。告寂慧菩萨摩诃萨言。寂慧当知。菩萨苦行等事。具有无量功德庄严。假使住世一劫尽其寿量。而亦不能广分别说。我今为汝略说。寂慧。菩萨苦行非一种相。菩萨但为降伏诸魔及外道故。乃至禁戒诸相。或五热炙身。及余一切威仪事等。悉为降伏众魔外道。令其最胜最上。出过于彼所有禁戒修行诸难作事。彼诸外道不能作者。菩萨一切悉能现作。使其超胜。寂慧。或有众生。见其菩萨一足翘立。或见菩萨举其双臂。或见菩萨向日谛瞻。或见菩萨五热炙身。或见菩萨肘步而行。或见菩萨伫立不动。或见菩萨上起双足。或见菩萨头顶向下。或见菩萨卧于棘上。或见菩萨卧牛粪上。或见石上加趺而坐。或卧墙上。或卧果蓏之上。或卧椽上。或卧土上。或着蓑衣。或着草衣。或着鹿皮衣。或以衣覆身。或复裸形。或随日而转。或着冢间衣。或着树皮衣。或食莠稗。或食于根。或食于叶。或食于花。或食于果。或食于茎。或食于枝。或食藕根。或六日不食。或食秽豆。或食秽稻。或食荞麦。或食菉豆。或食青豆。或食于稻。或食脂麻。或食粳米。或但饮水而为资养。或食酥滴。或食蜜滴。或食乳滴。或常不食。或魔众中住。或单己坐。或一向立。寂慧。此如是等诸威仪事。及余无量难行苦行。菩萨为降伏外道故。悉能现同彼苦恶相。菩萨如是于六年中。未尝坏彼一威仪相。示现满足禁戒修行。精进冶炼菩萨所作。最胜最上坚固不退。如是六年现作诸相。亦非余信解者。更互得见所修禁戒。所有别外修禁戒者。见彼菩萨如是所修。皆悉降伏。寂慧。菩萨于一切处。所作所现。悉住舍心离诸过失

复次寂慧。菩萨如是修苦行时。有六十四那庾多天人。于三乘中善根成熟。寂慧当知。有诸天人。具大信解作善业者。彼见菩萨在宝楼阁中安庠而坐。入阿塞颇那迦定。受定中乐。菩萨终六年已从定而起。诸天人中有法欲者。志求法者。为彼成熟如应说法。彼诸天人见是菩萨。闻所说法。悉无别异所作事业。寂慧当知。此名菩萨大智积集大悲方便解入不思议甚深理法降伏一切邪魔外道入苦行智清净法门。又复寂慧菩萨于六年中。成办如是所应。示现极难行事。过六年已往泥连河。随顺世间澡沐作净。既沐身已住于岸侧。是时有一聚落中女。其名善生。构以百牛成乳糜粥净心捧持。诣菩萨所而以上之。是时复有六十俱胝天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等众。各各办造上妙饮食。持奉菩萨。咸作是言。惟愿菩萨大士受我饮食。惟愿大士受我饮食。寂慧是时菩萨。最先受彼善生女人所施乳糜。其彼六十俱胝天龙夜叉乾闼婆等。所施饮食亦悉受之。互不相见各各皆谓。菩萨受我所施饮食。菩萨受已。当证阿耨多罗三藐三菩提果。菩萨普为所施诸众。成熟阿耨多罗三藐三菩提善根法故。寂慧。此即是为菩萨苦行超胜。以受食缘成熟众生。方便胜行

佛说如来不思议秘密大乘经卷第九佛说如来不思议秘密大乘经卷第十

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    菩萨诣菩提场品第十二

尔时菩萨既澡沐已。复受饮食身力充实。即时往诣大菩提场。到已告语善地天子。并诸地居天子众等。说伽陀曰

  任持大地不动摇　　菩萨离爱断害者
  今此树下证菩提　　汝等庄严于此地
  善哉地居天欢喜　　普遍清净三千界
  广散最上妙香花　　遍洒香水皆清净
  所有坚手及持鬘　　常憍天等至空居
  欢喜瞻仰菩萨尊　　散众妙花伸供养
  四护世天并众会　　乃至一切四大洲
  遍三千界金网严　　覆以供养人中胜
  三千界中帝释主　　供养菩萨大威德
  如广胜殿天妙严　　三千界严亦如是
  夜摩天众咸欣悦　　覆琉璃网以严治
  广三千界宝珍奇　　为人中仙伸供养
  兜率天众咸欣悦　　布真珠网作严饰
  珠璎其犹半月形　　复散真珠广如雨
  化乐天王并天众　　阎浮檀金为宝网
  金网宝铎出妙声　　遍三千界闻皆喜
  诸有天中净妙宝　　无边照曜净光明
  他化自在天所严　　供养一切义无畏
  所有龙及乾闼婆　　摩睺罗伽修罗等
  各于自宫广庄严　　及以妙严于欲界

复次寂慧。是时大梵天王。见是菩萨诣菩提场殊胜相已。即告一切梵众天子言。汝诸仁者。知是事不。今此菩萨摩诃萨于大誓愿。广大甲胄而不弃舍。复于坚固甲胄无懈退意。能善成办诸菩萨行。修诸波罗蜜多善住彼岸。于一切菩萨地中善得自在。一切菩萨意乐悉能清净。复善通达一切众生种种根性。深入一切如来秘密分位。诸魔业道已悉超越。于一切善根得不坏信。诸佛威神共所建立。普示一切众生正解脱道。为大导师摧破一切魔外境界。三千大千界中一勇猛尊。积集法药为大医王。覆以解脱缯帛。为大法王放大慧光建大法幢。世间八法皆不能染。真实清净大莲花生。于一切法总持无忘。大海出生离诸增损。不动不摇如须弥山。妙善无垢妙善清净。自净妙慧大摩尼宝之所出生。一切法中而得无碍。大梵所生心业调畅。具如是等功德。菩萨今诣大菩提场。欲证阿耨多罗三藐三菩提果。降诸魔军。为令圆满如来十力。四无所畏。十八不共佛法。普为一切转大法轮。作狮子吼。于诸众生广行法施。令诸众生法眼清净。以其正法。摄伏一切邪异外论。为欲圆满往昔誓愿。为欲亲近诸佛世尊。于诸法中得富饶自在。汝诸仁者。当发勤勇之心。于菩萨所亲近供养

时大梵天王。以清净心。复告一切梵众天子言。诸仁者。今此菩萨。于多百千劫中精修禁戒。是即最上清净大士。今诣大菩提场。将成正觉。汝等宜应于一切三千大千世界。广作殊妙庄严等事

尔时大梵天王。说伽陀曰

  清净大士戒决定　　广为人天作利益
  人中天供天中天　　诣菩提场大寂默
  降伏一切魔军众　　一切智智真觉了
  一切佛法悉圆明　　转正法轮行利乐
  大智一振狮子吼　　一切众生闻皆喜
  令开法眼清净因　　人中尊诣菩提树
  邪异外论皆摄伏　　往昔誓愿悉周圆
  正觉事业现令成　　人中尊诣菩提树
  善哉和合皆专志　　普遍地方作庄严
  三千大千世界中　　普见庄严于欲界
  如其欲界所严事　　色界庄严亦复然
  善哉梵众清净心　　广作庄严三千界
  欲界所现供养事　　上界亦现诸供养
  遍散最上妙香花　　宝严众乐皆吹击
  三千世界诸天众　　见闻欣跃伸敬礼
  乃至色究竟天中　　各各自宫广严饰
  上中复上胜中胜　　普现庄严众天宫
  天女六十百俱胝　　建菩提场金刚座
  一切遍洒于香水　　复散种种殊妙花
  遍列众宝此地方　　大菩提场广严好
  语不能赞诸功德　　此有无量种庄严
  大士决定戒精修　　世间善利大威德
  将诣菩提树王下　　降伏魔军诸恶慧
  一切和合圣者行　　广作三千界严饰
  天人中尊法自在　　供养彼得无边福
  梵众闻彼人中尊　　殊妙庄严三千界
  妙花宝幢作严事　　变化世界宝所成
  俱胝妙盖化空中　　如日月光极严丽
  娑罗树花众最上　　化现悉如欢喜园
  大仙循道欢喜行　　变化庄严七车量
  宝成金莲华密覆　　七重界道而围绕
  帝释天主作庄严　　人天希有昔未见
  如忉利天广胜殿　　四大洲严亦复然
  夜摩兜率化乐天　　他化严同色究竟
  勇发勤力皆迅疾　　共严最上菩提场
  如欲界中胜庄严　　天龙等众亦如是
  于刹那间皆化现　　菩萨于中所行诣
  四方天女数俱胝　　诣菩提树众围绕
  涂香末香众妙花　　一切处洒妙香水
  大菩提树本妙严　　如忉利天园生树
  所有一切庄严事　　语不能赞诸功德
  那庾多数彼诸天　　彼彼庄严皆殊妙

复次寂慧。菩萨既至菩提场已。始下双足。千辐轮相按彼地时。即有广大光明出现。是光普照一切地狱傍生饿鬼趣中。诸众生类蒙光照触。所受诸苦暂得停息。迦梨迦龙王宫中大光普照

尔时迦梨迦龙王。见是菩萨光明照已。心生欢喜踊跃庆快。即时为彼自宫眷属。及诸龙众。说伽陀曰

  如金色光极晃曜　　大明照我龙王宫
  我蒙光照适其身　　亦复心生大欢喜
  如我于彼先佛所　　昔曾见此瑞光明
  而今所睹定无疑　　佛大无畏当出世
  汝等各持妙香花　　涂香末香花鬘等
  真金及彼摩尼珠　　以为璎珞并上服
  复持种种妙乐具　　珠宝所严众幡盖
  及宝所成妙高幢　　为天人师伸供养
  所有龙王妙宫殿　　广大庄严悉清净
  汝等应生欢喜心　　皆同亲诣于佛所

尔时迦梨迦龙王。与自宫人眷属并诸龙众。各持种种上妙香花衣服幢盖。及众乐具。鼓吹歌音上踊空中。香水如云遍洒一切。复雨龙华龙真珠等。如是广以龙王威神龙王通力。现诸化事诣菩萨所。到已即时与诸眷属礼菩萨足。鼓妙音乐虔伸供养。作供养已。是时龙王右绕而住。说妙伽陀。伸赞叹曰

  人中尊放大光明　　普照一切佛刹土
  刹那恶趣苦皆停　　我等龙宫俱照曜
  龙众蒙光照触已　　咸生欢喜作是言
  菩萨成佛定无疑　　金色光明乃如是
  有那庾多龙女众　　恭敬捧持妙香花
  及胜衣服众幡幢　　诣菩萨所伸供养
  今此地方花盖等　　一切殊妙广庄严
  又复药草诸树林　　低垂悉向菩提树
  江河停流而寂静　　风止摇击悉安然
  菩萨今日证菩提　　世间最胜降魔者
  梵王帝释诸光明　　日月光等悉映蔽
  蒙光照者得清凉　　佛出世故咸欢喜
  复有诸妙吉祥瓶　　右旋宛转在空中
  仙众龙众等居空　　右旋其状亦如是
  世间若天若人等　　各各至诚伸供养
  菩萨今日证菩提　　为求慧者开正道
  我等今日于佛所　　增益威光得善利
  我昔供养拘留孙　　及迦诺迦大圣主
  迦叶最上人中胜　　乃至今供释迦仙
  此求菩提大神通　　最胜希有昔未见
  具德最上人中尊　　出大梵音狮子吼
  坚求菩提决定心　　是心超胜无比等
  而彼日月可堕落　　须弥山王可破坏
  今日不圆十力尊　　世间无复有是处

复次寂慧。时迦梨迦龙王。上首之妃名曰金光。与诸龙女恭敬围绕。持以种种殊妙宝盖。种种妙衣及天花鬘。种种巧严真珠璎珞。种种上妙摩尼珠宝。及彼种种众妙香瓶。奏妙歌音诣菩萨所。到已礼敬。散诸宝花而伸供养。住菩萨前。说伽陀曰

  心无动乱无恐畏　　无贪无嗔亦无痴
  能调难调无染尊　　能离诸恶无所著
  我今顶礼净解脱　　大仙拔除诸疑箭
  以大智光破无明　　能度世间诸苦恼
  世间无依无救者　　菩萨善为作依救
  光明普照三界中　　天人欢喜心清净
  空中遍雨众妙华　　及散妙衣广严饰
  如是胜相我所知　　今日大仙成正觉
  胜者勇诣菩提树　　降伏诸魔无染尊
  烦恼黑闇网蠲除　　证大菩提心寂静
  汝经多俱胝劫中　　于先佛所求菩提
  难行能行为世间　　今时圆满胜意乐

复次寂慧。尔时菩萨将成正觉。有诸贤圣以威神力。而为警发。即时有一刈草之人。名曰吉祥。自然住立菩萨之右。持以净草。是草柔软如孔雀项。复如迦左邻那衣。色香具足一一右旋。时刈草人即持其草。诣菩萨前奉上菩萨。深发最胜阿耨多罗三藐三菩提心

复次寂慧。彼时吉祥刈草人者。以宿愿深固昔发愿言。愿我悉于贤劫之中。诸菩萨众成正觉所。大菩提场皆布净草。何以故。寂慧。我念过去。于此贤劫之前九十一劫中。有佛出世。号毗婆尸如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛法中。圆满一千大菩萨众。修持梵行。时彼世尊。为贤劫中诸大菩萨。授阿耨多罗三藐三菩提记。是时有一长者。名曰具慧。在大会中。闻彼世尊授诸菩萨菩提记已。即发阿耨多罗三藐三菩提心。时彼长者发是愿言。愿我于此贤劫。诸佛如来菩提场中。悉布胜妙师子之座。或施净草。寂慧当知。无复疑念。彼时具慧长者岂异人乎。即是释迦菩萨成正觉时奉净草者。吉祥刈草之人。以是缘故。汝今应知。彼吉祥刈草之人。随宿愿力。于诸佛所。或施净草。或布妙好师子之座。随诸众生信解智力。善根成熟。其事如是

复次寂慧。是时菩萨既至菩提树已。彼菩提树神及十千天女。皆悉捧持诸上妙花及涂香等。诣菩萨前。各以所持诸妙香花用散供养各各头面。礼菩萨足。异口同音。说伽陀曰

  归命威德大无畏　　善寂善调破诸恶
  离过勇猛大威光　　清净导师无染者
  能救无依诸苦恼　　唯一圣尊施诸乐
  世间烦恼病能除　　为大医王普救疗
  归命清净大名称　　天欢喜散花如雨
  决定今速证菩提　　起大慈心摄一切
  往诣树王登胜座　　摧破一切诸魔闇
  觉悟寂静证菩提　　亦如先佛所证悟
  俱胝劫修清净行　　难作能作利世间
  大仙意乐今已圆　　安坐树王成正觉

复次寂慧。是时菩萨持以净草诣菩提场。到已即于金刚座上。自布其草然后乃向菩提树王。恭敬顶礼右绕七匝。菩萨布草之后。是时即有八万四千天子。持以八万四千妙好。庄严师子之座。奉上菩萨。其座高广严好殊丽众宝庄饰。覆以宝网及真珠网。复垂珠璎而为交络。妙巧施设无数百千上妙衣服。菩萨尔时即现其身。各各安处八万四千师子座上。彼诸天子互不相见。皆谓菩萨在我所施师子座中。菩萨坐已。成证阿耨多罗三藐三菩提果。是诸天子。咸生欢喜清净之心。皆悉不退转于阿耨多罗三藐三菩提

佛说如来不思议秘密大乘经卷第十佛说如来不思议秘密大乘经卷第十一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    降魔品第十三

复次寂慧。菩萨安处大菩提场师子座已。即放眉间白毫相光普遍照曜。是光名曰警照诸魔。时此三千大千世界。有百俱胝魔众蒙光照触。各各于自所止宫中。身毛悚竖。复于自宫心生逼恼。其光映蔽魔宫暗冥。时彼诸魔乃作是念。何因何缘我等宫殿皆悉暗冥。岂非释迦菩萨坐菩提场。成证阿耨多罗三藐三菩提果耶。彼诸魔众。即时观见菩萨已坐大菩提场。是时诸魔。即各隐自所止宫中。彼一一魔各有无量无数百千俱胝那庾多夜叉侍卫种种色相。种种状貌。种种形体。奔驰往复周章惶怖。有种种头面。种种器仗。种种旌幢。周匝围绕。发大恶声哮呼号叫。恃魔威力起魔业通。诸魔首领普遍纵广二万由旬。魔众眷属亦复广多八万四千由旬。皆以菩萨摄化力故。咸悉来至菩提树下。寂慧当知。彼诸魔众到已。即时运魔业力。化现种种丑恶容相。发起多种不可意声。佷戾凶残哮吼震击。意欲摄伏毁害菩萨。是时会中有未离贪诸众生类。闻恶声已生大惊怖即趣命终。或未终间受多苦恼。以菩萨威神力故。而彼恶声久不能息。菩萨乃起大悲之心愍其逼恼。即为息灭诸有恶声。不令娆害一切众生。寂慧当知。此是菩萨善巧方便最胜境界。尔时菩萨。闻彼种种极恶声已。不生惊悚。何以故。菩萨所闻诸声。若美若恶悉如响应

复次寂慧。彼诸魔众。以诸恶相娆菩萨时。即有守护大菩提场。修菩提行诸贤圣众。以十六种言词毁呰诸魔。谓言恶者汝宜止止。勿得固起恶戾之相。而生娆害菩萨大士。所以者何。今汝诸魔欲坏菩萨。而菩萨力最大最胜。能坏汝等。如羸力人敌大力者。又汝诸魔欲胜菩萨。而菩萨力能胜汝等。如劣弱军战大勇者。又汝诸魔欲超菩萨。而菩萨力能超汝等。犹如星宿比月光明。又汝诸魔欲破菩萨。而菩萨力能破汝等。犹如猛风吹其糠秕。又汝诸魔欲摧菩萨。而菩萨力能摧汝等。犹如大树断截其根。又汝诸魔欲怖菩萨。而菩萨力能怖汝等。犹如群兽遇大师子。又汝诸魔欲令菩萨处枯涸地。而菩萨力能涸汝等。犹如炎日涸牛迹水。又汝诸魔欲毁菩萨而菩萨力能毁汝等。如边小国战大国土。又汝诸魔欲窥觇菩萨。而菩萨力能窥汝等。如恶人处脱其杀命。又汝诸魔欲乱菩萨。而菩萨力能乱汝等。犹如贾客广积珍财为火所爇。又汝诸魔欲令菩萨生大忧恼。而菩萨力能令汝等生大忧恼。如非法王失其王位。又汝诸魔。欲于菩萨起恚恶心。而菩萨力制汝恚心。犹如老雁折其翅羽。又汝诸魔欲杀菩萨。而菩萨力制汝杀心。如人经游旷野险难中竭财物。又汝诸魔。欲令菩萨作奔驰者。而菩萨力能令汝等奔怖驰走。如涉大海中破船舫。又汝诸魔欲令菩萨作萎悴者。而菩萨力能令汝等悉皆萎悴。如劫火洞然焚烧草木。又汝诸魔欲断菩萨。而菩萨力能断汝等。如大金刚断诸小石。寂慧。而彼守护大菩提场。修菩提行诸贤圣众。以如是等十六种言词。毁呰诸魔赞叹菩萨。然彼诸魔亦未退伏

尔时菩萨。即以百千俱胝那庾多阿僧祇劫积修妙行。谓布施持戒忍辱精进禅定胜慧。慈悲喜舍。念处正勤。神足根力觉道。奢摩他。毗钵舍那。明智解脱等法。极善所作柔软细妙。右金色臂舒置魔顶。而复遍身按息扪摩。起大悲意慈眼观视。深心解脱一切众生。一切世界诸佛世尊。现前作证正念正知。菩萨即时以手按地。菩萨大士手按地已。尔时大地六种震动。所谓动遍动等遍动。震遍震等遍震。吼遍吼等遍吼。涌遍涌等遍涌。爆遍爆等遍爆。击遍击等遍击。东涌西没。西涌东没。南涌北没。北涌南没。边涌中没。中涌边没。如是等六种震动。起十八变。周遍大地皆悉动摇。于刹那间现诸异相。时诸魔众。佷戾凶残哮吼震击。欲兴害者罪业等辈。见是相已咸生惊怖。又以菩萨威神力故。闻空中声。说伽陀曰

  应当归命圣大士　　诸仙众中最上仙
  广施无畏大慈悲　　普能救护诸群品

复次寂慧。彼诸恶魔闻是声已。于魔众中有八百万俱胝那庾多恶夜叉众。偃仆于地俱发声言。救苦救苦大士救我。余诸魔众咸欲奔走。尽其魔力不能前诣

尔时菩萨以悲愍故举身放光。由彼光明所照触故。时诸魔众悉离怖畏。即各还复所止宫中。寂慧。当其菩萨为诸魔众现神通时。有八百万俱胝那庾多恶夜叉众。悉发阿耨多罗三藐三菩提心。会中复有九百九十万俱胝那庾多人。发阿耨多罗三藐三菩提心。八万四千天子。以宿善力故。皆得无生法忍

    转法轮品第十四之一

复次寂慧。或有天人知彼菩萨降伏魔军。或有天人知彼一切诸恶魔众。不曾来诣菩萨之所。或有天人初知菩萨敷吉祥草就菩提座。或有天人见释迦菩萨处于众宝莲花庄严师子座上。或有天人见其菩萨处于地上。或见菩萨在阿说他树下安详而坐。或见菩萨在波利质多罗树。或俱毗陀罗树。或菩提树下。或见菩萨在众宝所成菩提树下。或有天人见菩提树高一多罗树量。或有天人见师子座高一多罗树量。或有天人见菩提树高七多罗树量。或有天人见师子座高半多罗树量。或见菩提树乃至高于八万四千由旬之量。或见师子座高四万二千由旬之量。或有天人见彼菩萨降伏魔军。或有天人见一魔军。或有天人见有广多恶魔军众。或见菩萨以游戏神通破魔军众。或见菩萨处虚空中。或见菩萨于虚空中踞师子座。或见菩萨菩提树下安处宝座。成证阿耨多罗三藐三菩提果。寂慧当知。菩萨成就无量最胜清净境界。皆是菩萨处于最上最胜大菩提场。具足如是无量功德现诸胜相。复次寂慧。菩萨安处最胜最上大菩提场。降魔军已。即有十方无量阿僧祇世界。往昔同修最胜道行。诸菩萨众咸来至此。俱发清净无畏等声。谓吉善声。快乐声。欢喜声。迅速声。捷利声。善哉声。不空声。勇猛声。士夫声。不退转声。增益声。吉祥声。无热恼声。大悲愍声。往昔意乐声功不唐捐声。悦可意声。坚固和合声。大士游戏声。最胜利益声。刹那相应声。一切智智声。成等正觉声。彼诸菩萨出如是等清净声。时又十方世界所来集会。最上最胜菩提场中。诸菩萨众复以俱胝那庾多百千美妙言音广作安慰。施设种种殊妙供养。复作种种最胜称赞。时彼宿修善行诸菩萨众。并十方世界所来集会。胜菩提场诸大菩萨。如是安慰供养称赞。而释迦菩萨虽降魔军。然于魔所无违无顺。何以故。菩萨已离违顺法故。菩萨能于刹那心中。胜慧相应。或有所知或有所见。或有所得或有所证。而彼一切皆得成就

复次寂慧。如来成道果已。即时十方无量阿僧祇世界诸佛如来咸舒右手按菩萨身安慰问言。佛子身肢无疲懈耶。乐触行耶。以自然智所成证耶。无障碍心所成证耶。以平等智所成证耶。无绮饰行耶。被大悲铠耶。令三宝种不断绝耶。于一切法得自在耶。寂慧当知彼时善根已成熟者。即能亲近大菩提场知胜所作。所有善根未成熟者。不能亲近亦复不知

复次寂慧。如来成道果已。七昼夜中审谛思惟真实法乐。而复谛观大菩提树目未尝瞬。是时乃有百千天子。广伸供养称赞顶礼。复有百千天女。各各虔恭顶礼称赞。是诸天女瞻睹如来胜威仪已。悉发阿耨多罗三藐三菩提心

复次寂慧。如来成道果已。有四大天王各持宝钵来诣佛所而伸供献四天王者。所谓东方持国天王。南方增长天王。西方广目天王。北方毗沙门天王。如是等此四大洲四大天王既至佛所。余复亦然。有百俱胝四大洲。百俱胝四大天王。各持宝钵。咸来佛所亦伸供献

尔时如来。受是四百俱胝诸宝钵已。即以神力合成一钵。一一四大天王。各起是心。如来受我所施之钵。于我钵中如次受食。彼彼咸生最上清净欢喜之心。不退转于阿耨多罗三藐三菩提

复次寂慧。如来成道果已。有二商主。一名怛啰布沙。一名嚩梨迦。并余六万天子。咸来佛所最初奉上清净饮食。是商主等。皆由宿昔咸发愿言。愿我最初奉上如来清净饮食。愿彼如来最初纳受我所施已。生欢喜心皆得不退转于阿耨多罗三藐三菩提

复次寂慧。菩萨初登最上最胜大菩提场。未圆一切智。今成道果已觉智周圆。然未转彼广大法轮。广为众生作大利益。何以故。菩萨从初发心乃至于今。坐菩提场成等正觉。欲为众生作利益故。寂慧。以是缘故汝今当知。随诸菩萨成菩提果已。彼彼亦然。皆为无量众生作大利益

复次寂慧。如来成道果已。时有梵王名曰尸弃。与六百八十万梵众天子俱。恭敬围绕隐彼梵界。即至佛前顶礼佛足。右绕七匝合掌谛诚。劝请世尊转妙法轮。作是白言。惟愿世尊。惟愿善逝。广为众生转妙法轮。会中所有具法器者。而能了知佛所说法。如彼往昔持国天王子。宿发胜愿。愿我于此贤劫之中。诸佛如来成道果已。皆悉劝请转妙法轮

复次寂慧。非唯今此尸弃梵王。劝请如来转妙法轮。所以者何。尸弃梵王初劝请已。复有十俱胝梵王众。十俱胝帝释天众。十俱胝大菩萨众。亦皆劝请如来转妙法轮

尔时尸弃梵王。知佛世尊默然受请。即于波罗奈国仙人堕处鹿野苑中。为佛世尊。敷设妙好师子之座。高四万二千由旬。殊妙严饰胜相具足。众所乐观安置于地。如其尸弃梵王。初设妙好师子座已。即时复有十俱胝梵天王众。十俱胝帝释天众。十俱胝大菩萨众。皆为世尊施设妙好师子之座。殊妙严饰胜相具足。众所乐观

佛说如来不思议秘密大乘经卷第十一佛说如来不思议秘密大乘经卷第十二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    转法轮品第十四之二

尔时世尊。即诣波罗奈国仙人堕处鹿野苑中。到已现身各各处于众师子座。是时梵王帝释诸大菩萨。一一各见如来在我所施座中。处于座上转大法轮。是彼诸众咸生清净欢喜之心。皆悉不退转于阿耨多罗三藐三菩提。是时世尊安处最上师子座已。即时十方无边世界皆悉震动。有大光明普遍照曜

尔时世尊。即入无边境界三摩地。入是三摩地已。时此三千大千世界。普遍大地坦平如掌。又此三千大千世界所有众生。若地狱饿鬼畜生人天诸趣。一切众类皆得安乐。无一众生为贪嗔痴并诸烦恼所娆害者。互起慈心如父母想

复次世尊。入是无边境界三摩地时。即有十方无量阿僧祇菩萨。咸来集会听受正法。是时乃至三千大千世界。所有一切具威力者。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。咸来佛会听受正法。寂慧当知。世尊欲说法时。而此三千大千世界普遍地方。一切人天广大之众。皆来集会周匝充满。一毛端量中无空隙。皆为听受世尊宣说正法

尔时世尊。知彼一切人天大众皆集会已。即从三摩地安详而起。发大悲心乃以如来清净慈眼。普遍观察一切众会。转正法轮。若沙门若婆罗门。并余一切皆同一法

复次寂慧。如来所转法轮。皆为一切众生。令其心意欢喜故转。复令众会一切众生。各各了知佛所说法。随佛世尊欲转法轮。先有十方无量阿僧祇菩萨。咸来集会听受正法。即时复有百千俱胝那庾多。欲界天子色界天子。亦来集会听受正法

尔时世尊作是说言。诸仁者。眼非常法。何以故。若以苦言应得度者。即闻所说此眼是苦。若以无我言应得度者。即闻所说此眼无我。若以空言应得度者。即闻所说此眼是空。若以寂静言应得度者。即闻所说此眼寂静。若以离言应得度者。即闻所说此眼法离。若以无常言应得度者。即闻所说此眼无常。若以无依止言应得度者。即闻所说眼无依止。若以如幻言应得度者。即闻所说此眼如幻。若以如梦言应得度者。即闻所说此眼如梦。若以如水月言应得度者。即闻所说眼如水月。若以如影像言应得度者。即闻所说眼如影像。若以如对响言应得度者。即闻所说眼如对响。若以空无相无愿无作无生无起等言应得度者。即闻所说此眼是空无相无愿无作无生无起。若以缘生言应得度者。即闻所说此眼缘生。说眼既然。耳鼻舌身意亦复如是。乃至若以缘生之言应得度者。即闻所说意是缘生。色声香味触法其义亦然。或闻空言。或闻五蕴无常之言。或闻十八界无常之言。或闻十二处无常之言。或闻苦言。或闻集言。或闻灭言。或闻道言。或闻四念处言。或闻四正断言。或闻四神足言。或闻五根言。或闻五力言。或闻七觉支言。或闻八正道言。或闻奢摩他言。或闻毗钵舍那言。或闻缘生法言。或闻声闻相应法言。或闻缘觉相应法言。或闻大乘法言

复次寂慧。如来所转法轮。皆为一切众生。令其心意欢喜故转。又复如来所转法轮。广为一切众生作大利益。假使有人与舍利子智慧等者。意欲筹量解入斯法。纵经百劫终不能入。何况余者。寂慧当知。如来从初作行。诣菩提场降伏魔军。以胜庄严震师子吼。游戏神通转大法轮。作如是等胜利益时。有八万四千人。发阿耨多罗三藐三菩提心。无量众众。于三乘中。而得成熟

    所缘品第十五之一

尔时金刚手菩萨大秘密主白佛言。世尊。如佛世尊所说法时。岂非我于如来所说有违背耶。或随顺耶。如来所说甚深广大。如来所说甚深秘密。一切世间难信难解罔彻源底。世尊。诸如来心真实决定。我于如来所说深法。或有知解。皆是如来胜智在我身中。此非我有士夫力用。佛言秘密主。如是如是如汝所说。所以者何。汝今当知。所有如来。安立譬喻演说诸法。而彼一切众生。皆有如来胜智在于身中。何以故。秘密主。而诸众生遍一切处。随其如来所说秘密。若不容受如来加持之力。而能随顺如来法性者。无有是处。又复于彼如来所说秘密深法。若闻若说若有知解。皆是如来加持力故

复次秘密主。如来正语有所说时。应知如来法性如实法性真常。又复如来所行如实所行真常。是故如来。以正语言说是正法。又秘密主。所有过去未来现在诸佛世尊。以一切世间难信难解阿耨多罗三藐三菩提如是正法。宣说引导广为开示。而彼众生。若于如是难信难解甚深正法。闻已即能生信解者。当知彼等众生。非于一佛十佛亲近承事。当知已于广多俱胝那庾多百千佛所。亲近承事。应知彼人是为正士精修福行。又秘密主。假使须弥山王或摧坠时。师能有人或以顶肩而为荷负。若彼不种善根众生。能于如是甚深正法。一念生起净信解者。无有是处。何况受持读诵如说修行。又秘密主。若有众生能于大乘正法之中。闻已信解者。当知是人。非于一佛亲近承事。已于广多佛所亲近承事。大乘法中广修胜行植善根种

尔时寂慧菩萨摩诃萨前白佛言。世尊。如佛世尊说近止法。此以何义而名近止。此近止者何所从来。佛言。善男子。所说近止者。即是近止烦恼增语。此近止烦恼。即是近止思惟分别遍计增语。此近止思惟分别遍计。即是近止想作意增语。此近止想作意。即是近止颠倒增语。此近止颠倒。即是近止因所缘增语。此近止因所缘。即是近止无明有爱增语。此近止无明有爱。即是近止我我所增语。此近止我我所。即是近止名色增语。此近止名色。即是近止断常见增语。此近止断常见。即是近止有身见增语。寂慧当知。若与所缘因见相应。即诸烦恼而亦随转。一切皆从有身见起。若能近止有身见者。即诸见止息。若有身见近止。即一切愿求亦止。若有身见近止。即诸烦恼亦止。寂慧。譬如大树若断其根。即枝叶茎干而悉枯悴。此有身见亦复如是。若近止已诸烦恼亦止。寂慧当知。一切众生始以不能觉了有身见故。即诸取烦恼随逐而生。若能觉了有身见者。即诸取烦恼不复随生亦无所害。寂慧菩萨白佛言。世尊。彼有身见何能觉了。佛言寂慧。若我人众生寿者等见而不起者。即能觉了彼有身见

复次寂慧。彼有身见不住于内不住于外。于一切处而悉不住。以不住故见无所住。寂慧。此无住智。如实觉了彼有身见。又复寂慧当知。有身见即是空增语。若能随顺空智忍者。即见无所取。此即是为如实觉了彼有身见。又有身见者。即是无相无愿无作无生无起等见。是见无所取。此即是为如实觉了彼有身见

复次寂慧当知。有身见者。即是无身非开非合。一切皆是不实分别。以其不实所分别故。彼即无分别。亦不离分别。由无分别不离分别故。即无所作无障无起。以无起故即无所行。由无所行故。如是此说乃名近止。寂慧菩萨言。何名近寂。佛言寂慧。有所缘心如火炽然。若无所缘及无所作即不炽然。不炽然法此名近寂。又如大火有薪即然无薪即灭。所缘心火炎炽亦然。若无所缘心火自灭。寂慧当知。具善巧方便菩萨。于般若波罗蜜多清净所缘法中。平等了知善根所缘胜法而不息灭。烦恼所缘染法制令不起。波罗蜜多胜法常令增进。魔业烦恼所缘染法永令断灭。菩提分法清净所缘不应弃舍。声闻缘觉意乐所缘而不取着。一切智心最上所缘不应舍离。于空所缘审谛伺察。一切众生大悲所缘深生愿乐。寂慧当知。具善巧方便菩萨。于般若波罗蜜多清净所缘法中。而得自在。无生所缘思惟决定。和合生起所缘亦不厌舍。无作所缘而复趣入。诸有善根施作所缘悉令开晓。无相所缘而善思择。菩提心所缘永无厌离。无愿所缘以慧正观。三界所缘不生厌离。菩萨以慧方便。于其无生一切所缘法中。自在而转。若见不净所缘。即于如来清净身心中住。若无常所缘即于生死无疲倦心住。若苦所缘即令一切众生快乐安置涅槃平等心住。若无我所缘即于一切众生。大悲心住。若贪所缘即于贪行众生中。以净大药开明心住。若嗔所缘即于嗔行众生中。以慈大药开明心住。若痴所缘即于痴行众生中。以缘生大药开明心住。若等分所缘即于等分行众生中。以无常想大药开明心住。若离贪所缘即于声闻法中开化心住。若离嗔所缘即于缘觉法中开化心住。若离痴所缘即于菩萨法中开化心住。若色所缘即于获得如来最上色相心住。若声所缘即于获得如来妙好音声心住。若香所缘即于获得如来戒香清净心住。若味所缘即于获得如来所有味中上味大人胜相清净心住。若触所缘即于获得如来所有细软手足妙触心住。若法所缘即于获得如来所有一切法中决定心住。若施所缘即于获得如来最上相好心住。若戒所缘即于严净佛土心住。若忍所缘即于获得梵音声相妙金色身清净心住。若精进所缘即于一切众生救度心住。若定所缘即于神通所起妙用心住。若慧所缘即于断一切众生烦恼诸见相续心住。若慈所缘即于一切众生起无障碍心住。若悲所缘即起护持正法心住。若喜所缘即起说法欢喜心住。若舍所缘即离诸违顺成办一切众生事业心住。若四摄法所缘即起成熟一切众生心住

佛说如来不思议秘密大乘经卷第十二佛说如来不思议秘密大乘经卷第十三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    所缘品第十五之二

复次寂慧。若诸菩萨为欲对治悭吝过失所缘法者。即起能舍己之所有心住。若为对治破戒过失所缘。即起持戒心住。若为对治嗔恚过失所缘即起坚固忍辱心住。若为对治懈怠过失所缘。即起精进成办如来胜力心住。若为对治散乱过失所缘。即起获得如来禅定心住。若为对治染慧过失所缘。即起圆满无碍智心住。若为声闻作意所缘。即起积集大乘心住。若为厌离所缘。即起不作诸罪心住。若为恶趣所缘。即起刹那所生诸恶趣中救度心住。若为天趣作意所缘。即起若成若坏后边心住。若为人趣作意所缘。即起不坚固心住。若为念佛作意所缘。即起诸佛摄受心住。若为念法作意所缘。即起于法不吝心住。若为念僧作意所缘。即起获得不退转于法轮心住。若为念舍作意所缘。即起一切能舍心住。若为念戒作意所缘。即起圆满求愿胜定觉支心住。若为念天作意所缘。即起诸天称赞佛智加持心住。若为身作意所缘。即起获得佛身清净心住。若为语作意所缘。即起获得诸佛语言清净心住。若为心作意所缘。即起获得佛平等心清净心住。若为有为法所缘。即起圆满如来智心住。若为无为法所缘。即起圆满佛智心住

寂慧当知。此如是等或有所缘。而诸菩萨无有不于一切智智现前法门中住。又诸菩萨于一切所缘法中。皆悉回向菩提。此即是名菩萨善巧方便觉了一切法通达观察。寂慧。譬如所有三千大千世界一切大地随诸所生。无有不是一切众生受用之所。彼诸菩萨亦复如是。所有一切所缘境界。无有不是善巧方便。菩萨共所受用菩提道分。无不成熟菩提道法。又如色法一切皆是四大所造。善巧方便菩萨亦复如是。或有所缘一切皆以菩提胜相和合相应

复次寂慧。若有众生悭吝恶作者。菩萨即为圆满布施波罗蜜多。持戒波罗蜜多。若诸众生起嗔恚行及懈怠者。菩萨即为圆满忍辱波罗蜜多。精进波罗蜜多。若诸众生起散乱心及愚痴行者。菩萨即为圆满禅定波罗蜜多。胜慧波罗蜜多。若诸众生不可悲愍者菩萨于彼无违害心。若诸众生所应饶益者。菩萨于彼无随顺心。若诸众生常称赞者。菩萨于彼而无高心。若诸众生不称赞者。菩萨于彼亦无下心。若见一切苦恼众生。菩萨即起大悲之心。若见一切快乐众生。菩萨即起欢喜之心。若见一切粗犷众生。菩萨即起调伏之心。若见一切调顺众生。菩萨即起慈爱之心。若见具有缘力众生。菩萨即起卫护之心。若见具有因力众生。菩萨即起摄化之心。随摄化已乃为教授。若见智慧开明众生。菩萨即为宣说甚深之法。若见具演说智众生。菩萨即为广大说法。若见如理众生。菩萨即为次第说法。若见众生乐著文句者。菩萨即以少略文句而为说法。若见众生乐以奢摩他为先导者。菩萨即为宣说毗钵舍那。若见众生乐以毗钵舍那为先导者。菩萨即为宣说趣入三摩地法。若见众生乐持戒者。菩萨先为宣说不究竟法。后复为说地狱等事。若见众生乐多闻者。即为宣说无疑惑法。若见众生乐三摩地者。即为宣说趣入慧法。若见众生乐旷野住者。即为宣说心寂静法。若见众生乐修头陀行者。即为宣说圣慧根法。若见钝根众生。即为宣说闻随顺法。若见坚着贪法众生。即为宣说不净之法。若见坚着嗔法众生。即为宣说慈心之法。若见坚着痴法众生。即为宣说缘生之法。若见等分行众生。即从中入中广为说法。所谓不净法慈心法缘生法。若随顺诸法所应度者。菩萨即为宣说增上戒法增上心法增上慧法。若见众生以佛胜相所应度者。即为宣说真实随顺菩提分法。若见轻慢众生所应度者。先为杜止轻慢之门。后为说法。若见众生相续乐观菩萨圣相者。菩萨即为常现其身。然根未熟者不为说法。若见众生乐巧说法所应度者。即以缘起譬喻解释说法。若见众生乐甚深法所应度者。即为宣说缘生无我无人无众生法。若有众生着诸见者为说空法。若见众生起寻求行者。即为宣说无相之法。若见众生起求愿者。即为宣说无愿之法。若见众生着诸蕴者。即为宣说如幻之法。若见众生着诸界者。即为宣说善决择法。若见众生着诸处者。即为宣说如梦之法。若见众生着欲界者。即为宣说逼恼之法。若见众生着色界者。即为宣说诸行苦法。若见众生着无色界者。即为宣说彼一切行无常之法。若见众生乐以苦法所应度者。即为宣说令于圣种生欢喜法。若见众生乐以乐法所应度者。为说无量禅定之法。若见众生乐天趣法所应度者。即为宣说纯一乐法。若见众生乐着诸相所应度者。为说无我无取之法。若见众生乐以声闻法所应度者。即为教授取证之法。若见众生乐以缘觉法所应度者。即为宣说于事于义少略之法。若见众生乐以初发心菩萨法所应度者。即为宣说深心发起大悲之法。若见众生乐以久修道行菩萨之法所应度者。即为宣说于轮回中无懈倦法。若见众生乐以不退转菩萨之法所应度者。即为宣说严净佛土之法。若见众生乐以一生补处菩萨之法所应度者。即为宣说大菩提场庄严之法。若见众生乐以佛身所应度者。为说菩萨胜行相续不空之法。寂慧当知。如是等法皆是具足智慧方便诸大菩萨。于彼清净所缘法中而得自在。是故广说不空之法。其所说法。为令一切众生欢喜故说

说是法时会中有十千人。发阿耨多罗三藐三菩提心。五千菩萨得无生法忍

    金刚手菩萨大秘密主授记品第十六之一

尔时会中有诸菩萨咸起是念。此金刚手菩萨大秘密主。其何久近当得成就阿耨多罗三藐三菩提果邪。所居佛土当何名字。菩萨成佛复名何等。眷属圆满其数几何

尔时世尊知诸菩萨心所念已。即时微笑。法尔诸佛现微笑时必有因缘。尔时世尊。从其面门放种种色广大光明。所谓青黄赤白红紫碧绿。其众色光普遍照曜无边世界乃至梵世。其光盘旋还来佛所右绕三匝。从佛世尊顶门而入

尔时寂慧菩萨摩诃萨。即于佛前合掌虔恭。以妙伽陀而伸请问

  如金色光妙无垢　　寂静月面体凝然
  破暗最上日光明　　人仙微笑今何为
  安处寂定莲花相　　大悲震吼进力增
  念智功德妙香薰　　善逝莲花笑何为
  念如净器定如油　　悲炷然灯破三垢
  妙慧光明息暗冥　　善逝智光笑何为
  悲轮光明慧观察　　息除三垢灭诸冥
  净开智眼利世间　　佛日妙光笑何为
  佛知三有世间意　　遍照一切天人心
  大仙慈眼视众生　　今何大仙现微笑

寂慧菩萨说伽陀已

尔时世尊即告寂慧菩萨摩诃萨言。今此金刚手菩萨大秘密主。于此贤劫诸佛如来应供正等正觉所。持金刚杵作供养事。以利益心守护正法。今于我此秘密法中广大施作。普为无量一切众生。成熟最上菩提善根。于此贤劫乃至最后楼至如来法中隐没。即于极乐世界阿閦如来佛刹中生。而彼世界阿閦如来。为彼诸菩萨宣说秘密一百八印。时金刚手菩萨大秘密主。闻其所说。不假加行解入义趣。如理如实随顺所行。其后复于无量无数诸如来所。亲近恭敬尊重供养。彼彼佛所皆修梵行护持正法。广为无量俱胝那庾多百千众生。成熟阿耨多罗三藐三菩提法。而后复过殑伽沙数劫中。圆满菩提分法。而乃得成阿耨多罗三藐三菩提果。号金刚步如来应供正等正觉出现于世明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名普净。劫名清妙。寂慧。而彼普净世界。金刚步如来刹土之中。安隐丰乐严净可观。天人炽盛菩萨广多。七宝具足殊妙庄严。七宝所谓金银琉璃砗磲码瑙珊瑚琥珀及赤珠宝。彼世界中周遍盈积。可八步量地平如掌。柔软复如迦左邻尼具诸乐触。建妙幡幢宝绳交络。天妙宝花处处垂下。最上精妙众香氛馥。空中自然奏诸音乐。无诸恶趣及众险难。如兜率天最胜受用。又彼世界随意所思。宫殿舍宇园林楼阁。饮食衣服众庄严具。皆悉具足随诸所用。皆与天人受用无异。受诸天人具大信解深信佛智。又彼世界亦复不闻声闻缘觉二乘名字。彼佛所说纯一清净大菩萨法。又彼金刚步如来。广多百千菩萨眷属。又彼世界不坏律仪。不减寿命不破戒行。不失正见。亦无颠狂聋哑跛伛謇吃犷恶斗竞缺减诸根等者。一切皆具二十八种天人胜相。而为庄严。彼佛如来寿八中劫。亦无天人中间夭逝。寂慧当知。彼金刚步如来。其如是等及余无量胜功德事。彼佛世尊随欲说法即放光明。彼诸众生见是光已。即知如来宣说妙法。若有众生互起思念。欲诣佛所瞻仰听法。即以彼佛神通智力所加持故。寻至佛所。或有以自神力至佛所者。即时天人大众咸来集会。时彼世尊踊身空中。高百千多罗树。时四大洲悉见如来广大身相。又十方世界悉闻震发显示如来清净妙音。一切众生闻者适悦。又复如来为诸菩萨说正法时。无一众生于其如来宣说之法有所违背。彼诸众生皆悉利根开明知解。又彼世界而无王者。唯佛世尊金刚步如来最上法王。又彼世界一切众生无我无执

复次寂慧。又彼金刚步如来。于彼刹中诸天人所欲行乞食。彼时若天若人即见如来圣像住在其前执持应器。彼诸天人见圣像已。各欲奉上如来清净饮食。及随意乐所欲方处座卧之具。百味食等皆悉严备。彼佛知时随受所施。佛受施已即出其舍。还复如来所止僧坊。诸菩萨众亦复随应入三摩地

寂慧当知。彼佛如来所住世界。具如是等及余无量胜功德事。是故名为普净世界

佛说如来不思议秘密大乘经卷第十三佛说如来不思议秘密大乘经卷第十四

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    金刚手菩萨大秘密主授记品第十六之余

尔时世尊。为金刚手菩萨大秘密主。当授记时会中有二万人。发阿耨多罗三藐三菩提心。皆愿生彼普净世界金刚步如来刹土之中

尔时金刚手菩萨大秘密主。闻佛世尊与授记已。心生庆快踊跃欢喜。即以金刚杵掷虚空中。当其戏掷金刚杵时。而此三千大千世界六种震动。天雨众华鼓奏音乐。复于一切众会。右手自然皆出种种妙色最上华鬘

尔时金刚手菩萨大秘密主。即于佛前合掌谛诚。说伽陀曰

  广博大法王　　无尽妙法藏
  欲为利世间　　善分别诸法
  已于诸法中　　舍除吝惜意
  随法依法修　　善住我归命
  佛清净大士　　圆满清净行
  功德王名称　　遍闻于三界
  能于三世中　　常持无尽智
  平等善所行　　顶礼无障碍
  月光极圆净　　遍净复清净
  日光极光明　　妙光胜光聚
  梵音极妙音　　净音深妙响
  三宝胜金光　　故我今顶礼
  常现净妙身　　亦无身系属
  常说妙语言　　离语言分别
  虽为大法师　　不生于法想
  解脱诸众生　　而无众生想
  世间何所作　　能报佛大恩
  功德胜利中　　唯出家能报
  诸闻佛教授　　无异法可转
  随所受法门　　真修如理作

尔时金刚手菩萨大秘密主。并余一切在会大众。各以所持众妙华鬘散于佛上。以佛威神力故所散华鬘。即时普遍此三千大千世界。皆现众妙华鬘庄严周匝。盈积可八步量

    无二无说品第十七

尔时寂慧菩萨摩诃萨前白金刚手菩萨大秘密主言。秘密主。世尊如来授仁者记邪。金刚手言。善男子。佛授我记如梦自性。寂慧言。今汝授记有何所得。金刚手言。无所得故而我得记。寂慧言。何法无所得。金刚手言。我人众生寿者悉无所得。彼蕴处界亦无所得。乃至若善不善。有罪无罪有漏无漏。世间出世间。有为无为若染若净。生死涅槃皆无所得。寂慧言。若法无所得。云何是中有授记乎。金刚手言。由无所得故。即于是中以通达智而乃授记。寂慧言。智何有二而可观邪。金刚手言。若有二可观即无授记可得。然以彼智无二可观。是故诸菩萨。于无二智中如是授记。寂慧言。若智无二可观者。复云何有能记所记邪。金刚手言。若能记若所记。以平等性于无二际中悉无所得。寂慧言。秘密主。无二际中云何有记。金刚手言。若彼际如是即是无二际。即于彼际中故如是授记。寂慧言。何名为际。复于何处而得授记。金刚手言。我际处授记。众生际处寿者际处人际处授记。寂慧言。且我际处复在何处。金刚手言。我际处者。即是如来解脱际处。寂慧言。如来解脱际处而在何处。金刚手言。如来解脱际处。在无明有爱际处。寂慧言。无明有爱际处复在何处。金刚手言。在毕竟无生无起际处。寂慧言。毕竟无生无起际复在何处。金刚手言。在无表了处。寂慧言。若无表了有何开示。金刚手言。若有开示即非无表了。寂慧言。云何无开示。金刚手言。诸有所表悉无开示。寂慧言。若无开示何有教令。金刚手言。若有教令即无开示。若无开示即无教令。寂慧言。云何得教令。金刚手言。虽有表了即无所受。寂慧言。云何表了而无所受。金刚手言。若不著文字即无所受。寂慧言。云何不著文字。金刚手言。谓随顺义。寂慧言。此复云何是随顺义。金刚手言。谓即于义而无所见。寂慧言。云何于义无所见邪。金刚手言。若义非义。悉于是中求不可得。寂慧言。若于义非义求不可得者。即何所求邪。金刚手言。由于义非义求不可得故。即无法可求寂慧言。若无法可求者。即于一切悉无求邪。金刚手言。此中无有少法可求。何以故。以无法可求故。法即无法寂慧言。此中何者名为法邪。金刚手言。若法之声尚不可得。是中复何而有法邪。善男子如是应知。若言法者。谓于文字不着不行。是故说言一切诸法无言无说。善男子。若有人言有所说者。彼即非说。以非说故。彼即无法亦非如理。寂慧言。秘密主。若尔者。岂非如来诸所说法亦非说邪。金刚手言。寂慧。岂非我先曾为汝说。世尊如来不说一字。以无说故。如来即以神通愿力。随众生意示有所说。寂慧言。设有说者何过失邪。金刚手言。有所说者语业过失。寂慧言。彼语业者复何过失。金刚手言。文字思惟取着过失。寂慧言。此复何能离过失邪。金刚手言。一切法中。若有所说若无所说。悉无少法而可表了。无表了故即离过失。又复于己无所开示亦离过失。寂慧言。其过失者何为根本。金刚手言。彼过失者取为根本。寂慧言。取孰为本。金刚手言。执着为本。寂慧言。执着孰为本。金刚手言。虚妄分别为本。寂慧言。虚妄分别孰为本。金刚手言。增上所缘见为本。寂慧言。增上所缘见孰为本。金刚手言。色声香味触法。即是增上所缘根本。寂慧言。云何无所缘。金刚手言。爱不相续即无所缘。寂慧当知。如佛所说。一切法中若断于爱即无所缘。金刚手菩萨大秘密主说是法时。会中有五百苾刍得心解脱。二百菩萨得无生法忍

    入旷野大城受食品第十八之一

尔时金刚手菩萨大秘密主。满所思念得授记已。安慰其心生大欢喜。踊跃庆快前白佛言。世尊。我今勤请世尊降赴我所居止秘密宫中。微伸供养期满七日。并请菩萨声闻大众。愿佛慈悲哀受我请。何以故。世尊。旷野大城中。有多夜叉罗刹鸠盘茶必舍左乾闼婆摩睺罗伽等。异类众生悉住于彼。令彼等众得见佛已于长夜中利益安乐。息除[彳*廣]戾恚恶之心。复令四大天王诸眷属等于长夜中获大利益安隐而住。若佛世尊。悲愍我故降赴我宫。菩萨声闻随受微供。使令无量诸众生类增长善根。复令我等圆满意乐。佛即默然而受其请

尔时金刚手菩萨大秘密主知佛世尊默受请已。心生欢喜踊跃庆快。即时头面顶礼佛足。右绕七匝速离佛会。还复所止旷野大城

时金刚手菩萨大秘密主。至自宫已乃起思念。我今如何施设供养。复依何等境界庄严而为严饰。令欲色界诸天子众起希有心。复令十方世界所来集会大菩萨众咸生欢喜。我亦于佛广大施作妙供养事。作是念已即自记忆往昔一时。佛于夜分入三摩地。其名寂静不思议广大所行。我亦随佛即入是定。东方去此过殑伽沙数等佛刹土已。到一世界名无边功德宝庄严。彼有如来号庄严王。其佛刹中化主世尊。为十千菩萨授菩提记。我于尔时见彼佛刹。不可思议天人庄严。超胜一切妙庄严事。我宜依彼无边功德宝庄严世界所庄严相而为严饰。当为世尊作供养事。

尔时金刚手菩萨大秘密主。即入大庄严王三摩地。于是三摩地中如实观。睹彼无边功德宝庄严世界。种种殊妙庄严等事。如其所观即运神力。于此旷野大城中。施设庄严与彼无异。而彼无边功德宝庄严世界者。东西南北纵广正等六十四由旬。以青琉璃而为其地。帝青大宝作其墙界。垂珠华璎众宝严饰阎浮檀金而为莲华。众宝枝叶众宝璎珞间错垂布。复有无数天妙宝衣。复有无数珠璎严饰。复有无数殊妙缯彩。垂以无数妙宝华鬘。烧香涂香众妙宝瓶。亦复无数周匝。遍散种种色华。人所观者殊妙悦意。若身若心欢喜调畅。出现无边功德宝聚。复现无量色相庄严。又有广多百千庄严妙师子座。宝机承足宝绳交络。宝华庄严垂真珠网。周匝盈积可八步量。又复布设无数天衣。空中复有宝网垂覆。如是种种妙庄严事。于余广多世界之中。昔所未见昔所未闻。又复严办百味精珍上妙饮食。又复布列百千庄严妙师子座安处空中。一一师子座。空中自然有妙宝盖。各各垂覆殊妙庄严众相具足

尔时金刚手菩萨大秘密主。于其定中安布如是殊妙胜相。施设庄严师子座已。从定而起过于夜分至明旦时。严办最上清净食已。深心清净将欲供养世尊如来菩萨大众

佛说如来不思议秘密大乘经卷第十四佛说如来不思议秘密大乘经卷第十五

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    入旷野大城受食品第十八之余

尔时。金刚手菩萨大秘密主。又过夜分即告四大天王言。诸仁者。汝等当知我今请佛并大菩萨诸声闻众。降我所止秘密宫中期满七日微伸供养。以佛世尊悲愍我故而受我请。汝等各有力能广多眷属。于七昼夜中勿生放逸勿起乱心。亦复且止诸余作事。专一精勤供养于佛。乃至此旷野大城所止。一切夜叉罗刹必隶多鸠盘茶必舍左乾闼婆摩睺罗伽等。并余所住诸众生类。以我教敕悉告语之。众等应知。金刚手菩萨。请佛世尊来降于此旷野大城期满七日作供养事。汝等宜应摄诸恚恶发清净心。复起广大欢喜之意。严供世尊听受正法

尔时金刚手菩萨大秘密主即告长子金刚军言。贤者。汝今宜应以自神力往彼梵界。自梵众天至色究竟天。于彼诸天各告语云。金刚手菩萨大秘密主。请佛世尊来降旷野大城秘密宫中。期满七日作供养事。汝等诸天欲见佛者宜速来此

是时秘密主长子金刚军。受父教令即如其命

尔时金刚手菩萨大秘密主复告次子妙臂言。贤者。汝今。宜应以自神力往地居天至空居天。谓四大王天忉利天夜摩天兜率天化乐天他化自在天。于彼诸天各告语云。金刚手菩萨大秘密主。请佛世尊来降旷野大城秘密宫中。期满七日作供养事。汝等诸天欲见佛者宜速来此

是时次子妙臂。受父教令即如其命。尔时于刹那间。即有广多无数百千欲界天子色界天子。周匝充满百千由旬之量填塞空中

尔时金刚手菩萨大秘密主。又过夜分即为世尊敷设卧具妙严饰已。右膝着地合掌谛诚向佛世尊。说妙伽陀而伸勤请

  善来最胜人中尊　　善来人中无上士
  人中增胜愿降临　　佛大牟尼时已至
  善来最胜二足尊　　善来二足尊最上
  二足增胜愿降临　　佛大牟尼时已至
  佛大莲华净戒生　　精进定水常增长
  如峰采华众所归　　寂静莲华愿来降
  最初安立四圣谛　　以慈悲眼遍观察
  常能震吼无我音　　佛大师子愿来降
  戒为根本念为茎　　觉支华秀常茂盛
  解脱智果已周圆　　佛大树王愿来降
  妙慧甚深复广博　　湛然定水遍清凉
  众行圆明大导师　　佛功德海愿来降
  大悲所成吉祥礼　　大慧光明广庄严
  莲华开觉众所归　　佛日光明愿来降
  正语震伏诸邪论　　解脱药树救沉痾
  小根群鹿悉开明　　佛大山王愿来降

尔时世尊受金刚手菩萨大秘密主至诚勤请。知时已至即告苾刍众言。汝等宜应着衣持钵往赴金刚手请。期满七日作供养事善哉行矣今正是时。付嘱守护僧坊之者。今此众中诸有已得神通之者。菩萨声闻各各随应以自神力游空而往。若复未具神力之者。应当随入如来清净大圆光中。游空而往

尔时世尊即于王舍大城鹫峰山中。隐身不现。菩萨声闻恭敬围绕。放大光明普遍照曜。天人天女导前从后歌咏称赞。奏百千种俱胝那庾多鼓吹音乐震动大地。天雨种种殊妙宝华。于佛刹中广现种种佛大威力。佛大神通佛大施作。佛大变化佛大吉祥。佛大胜光佛大威仪。佛大游戏等相。游空自在。往诣于彼旷野大城

是时世尊处虚空中犹如鹅王。进止安详自在而行。彼欲色界诸天子众。遥见世尊高处空中。犹如鹅王宛转自在。咸生欢喜适悦庆快。又如日轮初出清净可爱。如圆满月莹洁光明众星围绕。如帝释天主天众围绕。如大梵王梵众围绕。天众见已即起清净希有之心。各持种种天妙香华供养于佛。所谓天优钵罗华．俱母陀华．奔拏利迦华．曼陀罗华．摩诃曼陀罗华．波利质多罗华．摩诃波利质多罗华．曼殊沙华．摩诃曼殊沙华．可爱华．大可爱华．轮大轮华．陆生诸华。及余殊妙最胜香华。具有百叶或千叶者。及焰光华光味华。遍香华常香华。常开华。悦目华。此如是等。并余无量胜妙香华。遍散佛上。又复安立殊妙幡幢。奏以百千殊妙音乐

尔时世尊。现如是等殊妙胜相香华幢盖鼓奏音乐众庄严事。于须臾顷即至旷野大城。而先暂适毗沙门天王宫。佛及菩萨声闻大众。从空而下入彼宫中

尔时大地普遍震动。而复柔软殊妙可爱。亦不娆恼一切众生

尔时四大天王。知佛世尊已至旷野大城之中。各从所守方分。与诸眷属持以种种殊妙香华速来佛所。时四天王到已。头面顶礼佛足。即以所持殊妙香华。散于佛上而伸供养。合掌谛诚退住一面。彼诸眷属亦各至诚顶礼佛足合掌而住。佛即略为四天王等眷属众会。宣说法要

是时会中即有十千夜叉罗刹龙乾闼婆鸠盘茶等。睹佛胜相悉发阿耨多罗三藐三菩提心。彼四大天王宫嫔眷属中。有十千天女。发阿耨多罗三藐三菩提心

尔时金刚手菩萨大秘密主。与自眷属各各持以。如无边功德庄严世界之中。殊妙香华涂香末香宝幢幡盖。鼓吹歌音作诸妓乐。速诣毗沙门天王宫中佛世尊所。到已头面顶礼佛足右绕七匝。即以所持妙香华等诸供养具。严洁谛诚供养世尊。诸眷属等奏妙音乐。严奉肃恭归命顶礼。迎导世尊并诸菩萨声闻大众。入自宫中到已如次请各就座

尔时世尊处彼殊妙种种庄严师子之座。并诸菩萨声闻大众亦各就座

尔时金刚手菩萨大秘密主即告帝释梵王护世天等并余一切诸天子言。汝等宜应各务精勤随喜成办严供世尊。当令汝等增长施福

尔时诸天子众见是最胜境界殊妙庄严师子座已。生希有心咸作是言。此之胜相何力致邪。为佛世尊威神力邪。为金刚手大秘密主威神力邪。即闻空中有声告言。诸仁者。此是大秘密主威神所致。东方去此过殑伽沙数等佛土已。有世界名无边功德宝庄严。佛号庄严王。金刚手菩萨大秘密主见彼世界种种殊胜妙庄严事。以秘密主威神力故。令此宫中同彼世界胜庄严相

尔时世尊安处胜妙师子座已。即时旷野大城所居一切夜叉罗刹必舍左鸠盘茶乾闼婆摩睺罗伽等众。皆悉来诣佛世尊所。头面着地顶礼佛足。合掌虔恭退住一面

尔时金刚手菩萨大秘密主即告四大天王并余一切诸众会言。汝等宜应咸来助我同发至诚。严以清净殊妙饮食奉上世尊。使令汝等获大利益

尔时金刚手菩萨大秘密主即与眷属众会。自手清洁严办最上百味精珍。菩萨深心清净如来。所应供养发最胜心。奉上世尊并诸菩萨声闻大众悉令充足。饭食事讫而复奉上清净香水盥手涤器。乃于佛前退坐听法

是时旷野大城所居一切夜叉罗刹必舍左等。各各谛诚瞻仰世尊合掌虔恭归命顶礼

佛说如来不思议秘密大乘经卷第十五佛说如来不思议秘密大乘经卷第十六

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    护世品第十九之一

尔时金刚手菩萨大秘密主。劝请世尊宣说正法。作是白言。惟愿世尊。为未发菩提心众生。随宜说法令入法理。即当发起大菩提心住不退转。又此夜叉罗刹必舍左乾闼婆隐密神摩睺罗伽等诸众会。令彼长夜利益安乐善行相应。获得胜中最胜高显而不减失诸善法分

尔时世尊普告金刚手菩萨大秘密主等诸众会言。诸仁者。汝等谛听极善作意。我今宣说为令一切悉入法理诸修善行。善男子善女人等。普令获得最胜高显。于善法分而不坏失。于是金刚手菩萨大秘密主等诸众会一心善听

佛告大众。诸仁者。若善男子善女人。深发阿耨多罗三藐三菩提心已。即能具信广多清净。欲见诸圣乐闻正法善舍无吝。手出无尽善乐积集。施作福行舍心具足。于布施中乐行平等。无障碍心无浊染心信有业报。离诸分别疑惑犹豫善恶业果而不坏失。如是知已。于命缘等不应作者而悉不作。不杀生不偷盗不邪染不妄言不绮语不两舌不恶口不贪不嗔不邪见。于此十善业道坚持积集。于其十种不善业道舍而不作普行净信。与沙门婆罗门及有戒有德者。正道法中同修净行。于诸善法多闻勤行。深固作意善行相应。寂静调伏常说爱语。摄伏他论修善离恶。无高无下无毁无誉。随起正念住等引心。闭三有门息灭诸病。离诸重担超越疑惑出离诸有。如是知者即于诸佛及声闻弟子若沙门若婆罗门善知识所。随其所应亲近恭敬承事尊奉。彼等善知识所。听受正法示教利喜。谓说布施感大富果持戒生天多闻大慧净观不乱。此行布施即是布施报。此行悭吝即是悭吝报。此持戒即是持戒报。此毁戒即是毁戒报。此忍辱即是忍辱报。此嗔恚即是嗔恚报。此精进即是精进报。此懈怠即是懈怠报。此禅定即是禅定报。此散乱即是散乱报。此胜慧即是胜慧报。此恶慧即是恶慧报。此身善作即是身善作报。此身恶作即是身恶作报。此语善作即是语善作报。此语恶作即是语恶作报。此意善作即是意善作报。此意恶作即是意恶作报。此是善此是不善。此应作此不应作。此业作已于长夜中得利益安乐善行相应。此业作已于长夜中无利苦恼得不善行相应。如是等法于善知识所。闻其所说示教利喜。又复观察知是法器。即为宣说甚深之法。谓空无相无愿加行等法。复说无生无起无我无人无众生无寿者甚深缘起之法此法是有此即有得。此法是无此即无得。此法若有此即是生。此法若无此即是灭。此是无明缘行。行缘识。识缘名色。名色缘六处。六处缘触触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是即一大苦蕴生若法不有此即无得。即是灭法。谓无明灭即行灭。行灭即识灭。识灭即名色灭。名色灭即六处灭。六处灭即触灭。触灭即受灭受灭即爱灭。爱灭即取灭。取灭即有灭有灭即生灭。生灭即老死忧悲苦恼灭。如是即一大苦蕴灭。此等诸法若生若灭。于胜义谛中无有少法可得。何以故。一切法缘生故。无主宰无作者。无受者因缘故转。然于是中无法可转。亦非无转亦无异法。随转和合施设三界。但以烦恼业转故有施设。愚迷之者。于不实法中观以为实。智者应知无有少法作者可得。以作者不可得故。无法可转亦非无转。如是所说甚深之法。若能闻已不生疑惑。是人即入一切法无障碍性。不着色受想行识。不着眼色耳声鼻香舌味身触意法。眼识乃至意识。信一切法自性本空。信一切法自性本离。诸仁者。彼信不退菩萨。信是法故即不减失。见佛闻法承事净众。在在所生常得见佛。听受正法承事净众。常生有佛世时。随彼生已。发起精进勤求善法。以精进故。于白衣舍无义利事。谓妻子男女奴婢眷属。及所作用而悉弃舍。及盛年戏乐不生爱着起贤善心。愿于诸佛世尊清净教中正信出家。得出家已近善知识。与善知识同登善道。而能获得诸善意乐听闻善法。随所闻已真实修行。不以语饰胜慧具足。发起精进勤求多闻。随所闻法为他广说无所希求。所得名闻利养无爱着心。以如实语为他说法。随闻随住亦然。如实为他说法。使听法者获得大慈。于一切众生。起大悲心。于彼多闻而不厌舍。于身命缘少欲喜足寂静圆满。增长善行乐闲寂处。随所闻法审观其义。于诸义理摄而无散。不着于文归趣实义。普为一切天人世间。非但为己勤修胜行。广为众生勤求无上最胜之智。令他众生于佛智中得不放逸。此复云何名不放逸。所谓最初调摄诸根见眼色等。不取于相不着相好。诸色境中于味于染如实知故常求出离。耳声鼻香舌味身触意法亦然。智了知已不取于相不着相好。于味于染如实知故常求出离。此名不放逸。复次不放逸者。能于自心善调伏已。亦复随应摄护他心。烦恼染爱而善息除。法爱随转欲寻嗔寻害寻止而不行。贪嗔痴等诸不善根亦悉不行。复能制止身语意业诸不善行。不深固作意而亦不起。以要言之。一切罪不善法皆悉除断。此名不放逸。诸仁者。此如是等不放逸法。菩萨勤行即得净信而不放逸。大秘密主。汝等当知信之一法广多清净。即能常时专求善法。若具信补特伽罗。于他世中离恶趣怖。亦复不堕诸恶作心。而常获得众圣称赞

复次秘密主。住法行人即能获得正法善趣常乐见佛。安住圣道得大自在。得自在已。复令他人普皆圆满自在之法。住菩提心得如来智。又秘密主。若人欲得最胜妙乐。应当毕竟善修正行修涅槃法。大秘密主。今此众会皆承宿善根力故来集此。善修正行于诸善根而不减失。云何善根得不减失。谓修不放逸行。是故若天若人所有善根皆不减失。何以故。彼不放逸心善护诸境故。能离一切贪爱欲染近习法爱。即能制止欲嗔害寻。复能息除不深固作意诸不善法。离贪嗔痴。于身语意粗重过失而悉止息。乃至一切诸善法分。若有减失皆悉不行。此名不放逸。若人信解不放逸法。即能随顺诸精进事。以精进不放逸故。是人乃能积集修作净信功德。由修净信及不放逸精进法故。即能修作正念正知。以正念正知故。即于一切菩提分法而不坏失。若具净信不放逸精进正念正知者。即能勤修深固之法。大秘密主。菩萨若于深固法中得解脱者。即于有于无如实能知。此中云何是有。云何是无。谓正修圣解脱法。此即是有。若不正修圣解脱法。此即是无。若有业有报。此即是有。若无业无报。此即是无。若世俗谛中眼耳鼻舌身意。此即是有。胜义谛中眼耳鼻舌身意。此即是无。菩萨于大菩提发起精进即有。于大菩提懈怠即无。颠倒所起五蕴即有。无因所起之法即无。色是无常是苦是坏灭法即有。色是常是坚牢是相续是不坏灭是安住法即无。受想行识是无常是苦是坏灭法即有。受想行识是常是坚牢是相续是不坏灭是安住法即无。无明缘行即有。不实无明行即无。行缘识即有。不实行识即无。识缘名色即有。不实识名色即无。名色缘六处即有。不实名色六处即无。六处缘触即有。不实六处触即无。触缘受即有。不实触受即无。受缘爱即有。不实受爱即无。爱缘取即有。不实爱取即无。取缘有即有。不实取有即无。有缘生即有。不实生有即无。生缘老死忧悲苦恼即有。不实生老死忧悲苦恼即无。布施得大富即有。布施感贫穷即无。持戒生天即有。持戒堕恶趣即无。多闻具大慧即有。多闻成染慧即无。禅观不散乱即有。禅观散乱即无。不深固作意生起烦恼即有。深固作意生起烦恼即无。不起增上慢人趣证涅槃即有。增上慢人得佛授记即无。于一切处通达空即有。于内执我即无。以智勤行得解脱即有。我慢相应出离者即无。又若我人众生寿者。于不实五蕴中求其实法即无。复次大秘密主。勤行不放逸深固作意菩萨。于有于无如实了知。世间一切智者许可。如实知已。虽行于有而不取着。虽行于无亦不取着。即能通达诸佛世尊所说实义

佛说如来不思议秘密大乘经卷第十六佛说如来不思议秘密大乘经卷第十七

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    护世品第十九之二

复次大秘密主如来于一切法中总略而说有四法印。何等为四。一者诸行无常。为诸沙门婆罗门及长寿天执常语者破常想故。二者诸行是苦。为诸天人计乐想者破乐想故。三者诸法无我。为彼执我诸外道等破其我想。四者涅槃寂静。为诸增上慢者起寻求行破彼增上慢故。此言无常者。即是毕竟无有常法增语。此言苦者。即是远离愿求增语。此言无我者。即是空相增语。涅槃寂静者。即是无相作证增语。大秘密主。此如是法。若诸菩萨深固信解勤行修习。即于善法而不减失。速能圆满菩提分法

尔时护世四大天王。前白佛言。世尊。我等四王皆名护世。当以何法而能护世。佛告四大天王言。汝诸仁者。当修正法行即能护世。其正法行者。所谓十善。何等为十。一者不杀。二者于自富乐而生喜足无其分量。三者于他妻室不起染污。四者不破他众。五者不出恶言。六者所言如实。七者言无绮饰。八者于他富乐无所希望。九者止息嗔恚。十者正见清净。诸仁者。此十善法乃能护世。复有八法而能护世。何等为八。一者如说能行。二者于一切处尊重师长。三者顺行正道。四者心意质直。五者心常柔软。六者于一切众生常起慈心。七者不作诸罪。八者集诸善根。如是八法乃能护世。复有六法而能护世。何等为六。一者行慈身业。于师尊所及善知识同梵行者乃至一切众生。悉起尊重爱乐意念。是为第一身业和敬。二者行慈语业。于师尊所及善知识同梵行者乃至一切众生。悉起尊重爱乐意念是为第二语业和敬。三者行慈意业。于师尊所及善知识同梵行者乃至一切众生。悉起尊重爱乐意念。是为第三意业和敬。四者依法所得一切利养少略乃至钵中之食。与彼知识同梵行者。周普均平等同受用。又复尊重爱乐意念。是为第四利养和敬。五者于戒修法无断无缺圆具无浊。所应受者不生贪取。智所称赞离诸讥毁。以如是等净戒之法。与善知识同梵行者共所修持。又复尊重爱乐意念。是为第五戒修和敬。六者于诸正见出离法中及胜决择分。随何等法修其正行。即当如应与善知识同梵行者共所修作。又复尊重爱乐意念。是为第六同见和敬。诸仁者。此六和法乃能护世。复有四法而能护世。何等为四。一者不贪。以不贪故不堕恶趣。二者不嗔。以不嗔故不堕恶趣。三者不痴。以不痴故不堕恶趣。四者不怖。以不怖故不堕恶趣诸仁者。如是四法乃能护世。复有二法而能护世。何等为二。一者有惭。二者有愧。具是二法即能护世。复有一法而能护世。何等为一。谓真实行。以真实故即能护世。又复善语又无谄曲。此等一法皆能护世。诸仁者。如是等法汝等勤行即能护世。自能护已复令他人亦能护世

    去来品第二十

尔时世尊即作是念。我今宜应为此众会。宣说秘密大明章句。令其众会善根相应。大菩提法久住世间。作是念已。即告金刚手菩萨大秘密主言。我昔曾于阿波逻罗龙王宫中。及大菩提场初成道时。以利益心摄受世间。我时宣说大明章句。汝能记念耶。金刚手菩萨白佛言。世尊。我能记念。佛言秘密主。汝今说彼大明章句

是时金刚手菩萨大秘密主。从座而起前诣佛所。胡跪合掌顶礼佛足即说秘密大明章句曰

怛[寧*也]他(引句)贺虎罗(引二)虎罗嚩帝(引三)虎贺啰拏(引四)萨吴(引)拏(引五)左左左左左(引六)儞布拏(引七)刍怛刹多(引八)刹野刹夜(引九)多(引)刹野萨摩(引十)设末儞葛啰(引十一)贺卢(十二)贺卢嚩帝(十三)尸罗嚩帝(十四)紧阿(引)尾设野帝(十五)儞萨啰尼(引十六)惹惹(十七)惹惹末帝(十八)阿嚩叱(引十九)儞嚩吒(引二十)嚩栗多(二合引)奴娑(引)哩尼(引二十一)部(引)多(引)奴塞蜜哩(三合)帝(二十二)呼(引)祢嚩多(引)奴塞蜜哩(三合)帝(二十三)呼(引)那(引)誐(引)喃(引二十四)药叉(引)赧(引二十五)巘驮哩嚩(二合引)赧(引二十六)摩呼(引)啰誐(引)赧(引二十七)莎悉底(二合)哩婆(二合)嚩都(引)萨哩嚩(二合)萨埵(引)喃(引二十八)尾计囕都(引)摩诃(引)钵哩嚩(二合)多(引二十九)三咩他旦(引)驮啰尼(引三十)誐哩惹(二合引)都(引)三母捺啰(二合)尾誐壹帝(三十一)

金刚手菩萨大秘密主说是秘密章句时。一切魔宫皆悉振动。大地倾摇大海腾涌。一切众会皆悉战怖。咸诣佛所顶礼求救。是时世尊复以一足按地。大千世界皆悉动摇。时诸众会俱向佛所作是白言。救我世尊。救我善逝。我等一切惊怖战悼。佛言。勿怖勿怖。此是诸佛大明章句威神境界。能使大地振动大海腾涌。日住虚空亦复动摇

尔时世尊。即为金刚手菩萨及诸众会。如其所应略说法要。是时会中有八万人发大菩提心。有无量人住有学地

尔时金刚手菩萨大秘密主长子金刚军。持妙宝网覆于佛上。前白佛言。世尊。菩萨云何能于阿耨多罗三藐三菩提得不退转。佛言。善男子。菩萨若能具修十法即于阿耨多罗三藐三菩提得不退转。何等为十。一者常行无碍大慈。二者常起无倦大悲。三者精进办诸事业。四者善修空三摩地。五者现前通达胜慧。六者于一切处皆善通达。七者能以妙智清净三世。八者以无碍方便观实业报。九者虽了知空而植众德本。十者如其所说自性清净而善入圣道。菩萨若具如是十法。即于阿耨多罗三藐三菩提得不退转。时金刚军。复白佛言。世尊。菩萨当修何法于佛不思议门闻已安然不生惊怖。佛言。善男子。菩萨当修八法。即能于佛不思议门闻已安然不生惊怖。何等为八。一者增长胜慧。二者增长妙智。三者常为善友之所摄受。四者具大信解。五者善达如幻无生之法。六者信解无常之法。七者心行平等犹如虚空。八者于诸法中善知障碍所起之相。菩萨若具如是八法。即能于佛不思议门闻已安然不生惊怖。金刚军复白佛言。菩萨当修何法即能于诸所作而得自在。佛言。善男子。菩萨当修四法即能于诸所作而得自在。何等为四。一者善修现前无灭之法具五神通。二者善观胜解脱门具四禅定。三者超胜梵世具四梵行。四者以方便慧于一切处善修无生。菩萨若具如是四法。即能于诸所作而得自在。金刚军复白佛言。菩萨有几种法门。佛言。善男子。菩萨有四种法门。何等为四。一者智门。善入一切众生根性。二者慧门。能善分别宣说句义。三者陀罗尼门。善入一切言音总持。四者无碍解门。能善宣说诸无尽法。此为菩萨四种法门。金刚军复白佛言。菩萨有几种力。佛言。善男子。菩萨有九种力。何等为九。一者定力。大悲起故。二者精进力。不退转故。三者多闻力。胜慧生故。四者信解力。圆满解脱故。五者修习力。离散乱故。六者忍力。善护众生故。七者菩提心力。降伏诸魔故。八者大悲力。成熟众生故。九者无生忍力。圆满十力故。如是名为菩萨九力。当佛世尊说是法时。彼长子金刚军得无生法忍。证是忍已。复白佛言。惟愿世尊威神建立。令此正法于金刚手菩萨大秘密主宫中而得久住。使彼具法器众生获得闻慧。光明照触乃至如来般涅槃后。于阎浮提中广令流布使不隐没

尔时世尊受金刚军劝请已。即告金刚手菩萨大秘密主言。秘密主。汝今宜应宣说。我于大菩提场初成道时。护诸菩萨降伏摄受诸魔军众。所有秘密大明章句。建立加护令正法眼久住世间。摄伏诸魔邪异外法

尔时金刚手菩萨大秘密主。承佛教敕从座而起。偏袒右肩右膝着地。合掌恭敬顶礼世尊。说大明曰

怛[寧*也]佗(引一句)虎卢(二)虎罗(引三)虎梨(四)提(引)哩(五)诃(引)哩(引)底(六)阿酤(引)设罗刹曳(七)左梨(八)左罗嚩帝(九)娑(引)哩(十)刍哩(十一)羼(引)帝末利(十二)翅弥(十三)羼(引)帝葛哩(十四)刹弥(十五)设弥(十六)扇(引)帝葛哩(十七)虎呼(引十八)阿梨(十九)诘诘哩(二十)珂哩(二十一)阿(引)尾设儞(二十二)啰娑(二十三)啰娑儞(二十四)惹曳(二十五)惹野嚩帝(二十六)体哩(二合二十七)阿(引)嚩哩帝(二合二十八)尾嚩哩帝(二合二十九)阿嚩哩多(二十)儞(三十)梅(引)底哩(二合引)部(引)多(引)喃(引)僧誐啰(二合)呼(引三十一)捺弥(三十二)捺摩三钵儞(三十三)帝(引)兰拏(二合)多(引)啰曳(引三十四)部(引)莎焰莎悉帝(二合)祢尾毗踰(二合引三十五)那(引)倪毗踰(二合引三十六)药翅毗踰(二合引三十七)巘驮哩尾(二合)毗踰(二合引三十八)药叉西毗踰(二合引三十九)摩奴赊(引)摩奴试毗药(二合四十)莎悉底(二合)哩婆(二合)嚩都(引)萨捺(引)苏欠(四十一)

说是大明时。一切山王皆悉振动。大地倾摇大海腾涌。所有一切邪异外法。皆悉摄伏归正法语。善护一切正法宝藏。一切天众互相庆悦。说伽陀曰

  秘密大明宣说已　　能令正法久住世
  三千世界悉倾摇　　求人中尊愿救护
  大师善说真实语　　普为众会施无畏
  威神建立此法门　　能令正法久住世

尔时世尊于金刚手菩萨宫中住经七日。广为无量一切众生作利益已。乃至旷野大城一切情品。广大周遍无不蒙益。即离本宫还处空中。菩萨声闻人天大众恭敬围绕。复有无数百千夜叉罗刹阿修罗迦楼罗等。前后导从。梵王帝释护世天等。布光明网奏妙音乐雨众异花。时诸刹土皆悉振动。以佛威德神通势力。加持神变及威仪事。譬如鹅王游戏自在。渐吹还诣鹫峰山中。金刚手菩萨大秘密主。以佛威神而随佛后

佛说如来不思议秘密大乘经卷第十七佛说如来不思议秘密大乘经卷第十八

        译经三藏朝散大夫试光禄卿光梵大师　赐紫沙门臣惟净等奉　诏译

    勇力菩萨先行品第二十一

尔时世尊与诸菩萨声闻大众游止鹫峰山中。于日后分离本住处。为诸大众随宜说法

时阿阇世王。知佛世尊已复山中。宫嫔眷属并王舍城中六万人众。各持种种上妙香花涂香末香等诸供养。出王舍大城诣鹫峰山佛世尊所。到已头面顶礼佛足各住一面。时阿阇世王。前白佛言。世尊。我诸所作随宜安处。我子来白父王。当知世尊大师。于金刚手菩萨宫中。赴请已竟。今已还复鹫峰山中。我乃思念。希有世尊。佛于一切众生。大悲随转。于众生聚中无一众生如来世尊起厌舍者。于旷野大城金刚手宫中。赴请受供还复来此。广为众生成熟利益世尊。彼金刚手菩萨大秘密主。甚为希有。具大威力。能善宣说如来法律生大欢喜。而金刚手者。往昔曾于何佛如来应供正等正觉所。植种德本。乃能成办如是辩才。佛告阿阇世王言。大王当知。彼不种善根众生。于如是事极难信解。而彼决定种善根者。乃能于此生其信解。大王。假使十方如殑伽沙数等诸世界。尚能算数知其边际。彼金刚手菩萨大秘密主。于佛世尊所亲近供养。修诸梵行成就辩才。假使诸佛世尊而亦不能算其边际。以是缘故。大王。当知昔因缘者。我念过去阿僧祇劫。复过于前广大无量不思议劫。时有如来应供正等正觉。出现世间。号曰多闻明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名极严。劫名无毁。时彼世尊。为彼清净大菩萨众宣说正法。彼佛告言。诸善男子。汝等当知。若有菩萨能发大精进者。即于身命而悉舍弃。时彼会中有一菩萨名曰勇力。前白佛言。如是世尊。如是善逝。如佛所言。若有菩萨发精进者。即于身命而悉弃舍。如我解佛所说义。菩萨若生懈怠。岂能速证阿耨多罗三藐三菩提果。何以故。能发精进诸菩萨者。于生死中不起厌倦之意。而彼菩萨。于生死中常当称赞不乐涅槃。但为成熟诸众生故。世尊。菩萨勤行为利众生故。具精进信解。于生死中自得其乐。不乐涅槃之乐。所以者何。菩萨为利诸众生故。随其所应诸有施作。亦随所应皆获其乐。若住涅槃而何能作。是故诸菩萨于生死境界中自得其乐。而即不取涅槃境界。世尊。菩萨于生死境界中所得乐者。谓即勤行利众生故。而常得见无量诸佛。常闻无量清净正法。常能成熟无量众生。菩萨以住生死境界故。即能随入众生境界。而于涅槃境界之中不着舍行。菩萨住生死境界者。以怖堕于非境界中。何以故。非境界中不复能作利众生事。不能安住如来境界。以不能住如来境界故。不能长养一切众生。此中何名非境界邪。所谓声闻缘觉之地。若乐住者即弃舍众生不能成熟。何以故。声闻缘觉境界是为菩萨非境界故。以声闻缘觉怖畏生死。若能摄受无量生死者。唯除清净大菩萨尔。是故菩萨能于生死境界中住。大王当知。时彼多闻如来赞勇力菩萨言。善哉正士善说此语。复善尊重菩萨境界所作诸行。而不复堕非境界中。勇力菩萨白彼佛言。云何是菩萨自境界邪。彼佛答言。善男子。菩萨自境界者。谓能摄受无量生死不生怖畏。称赞菩萨广大胜行。而不乐住声闻缘觉之地。以无碍智和合三界。若损若益能善增长一切善根。以增益智成众德本。而复能以尽智成就无尽福行。虽观无生而善成办有生之法。虽知无众生。而善成熟一切众生。虽知诸法离性。而善摄受正法。虽知诸佛国土自性如空。而以妙智严净佛土。虽观诸佛法身无相。而善勤求如来所有殊妙相好。虽观诸法本无造作。而以妙智于众德本所作精进。虽观有为法不实。而于诸事业少求少作。复能善为一切众生随宜施设。虽观身心离着。而以妙智说法无厌。虽离愦闹而从禅定所生不着禅味。虽复觉了甚深之法。而以妙智随诸众生。种种行转善说法要。虽知无生。以智善思普摄三有。虽以智观诸法皆空。而善护所得之果。虽观声闻缘觉境界。而善求如来解脱轻安之法。虽不厌舍诸菩萨行。而常善观诸佛境界。善男子。此即是为彼诸菩萨自境界门。复次大王。彼时勇力菩萨。于彼多闻如来所。闻说如是清净境界法已。生希有心。白彼佛言。希有世尊。能善说此诸大菩萨自境界门清净正法。如我解佛所说义。即是具善巧方便菩萨。入一切法自境界门。譬如虚空。一切色象境界普照无著。一切色象亦无障碍。虚空境界亦无障碍。具善巧方便菩萨亦复如是。现前觉了彼一切法自境界故。又如虚空普照一切色象境界而无障碍。所有一切毒树药树棘刺之树花果香树。彼等一切生长于空。然彼虚空无染无净无违无顺。具善巧方便菩萨亦复如是。从慧出生彼一切法自境界门。谓异生法有学法无学法缘觉法菩萨法如来法等。何以故。彼一切法现所证故。又如世间草木丛林。而火不能为其作护。何以故。火若上腾悉皆烧爇极炽焰故。菩萨亦复如是。于一切法自境界中。慧光发明极炎炽故。又如金刚坚固之身。火不能烧刀不能断。毒不能中他力不能伏。菩萨亦复如是。非声闻习非缘觉习。非一切众生诸烦恼习。而能染故。菩萨随诸习染。悉以勤行增上慧力。咸开晓故。又如水清摩尼宝珠。而能清彼诸浊水故。菩萨亦复如是。以胜慧宝普能清净一切众生诸烦恼垢。又如有药名曰离毒。不与一切恶毒同处。而能息除一切毒故。菩萨亦复如是。具方便慧力故。不与一切众生烦恼及自烦恼而共同处。复能止息一切众生诸烦恼毒此如是等皆是一切法自境界门。大王。当知彼勇力菩萨说是法时。有八千人发阿耨多罗三藐三菩提心。二百菩萨得无生法忍。大王。当知彼时多闻如来法中勇力菩萨者岂异人乎。即此会中金刚手菩萨大秘密主是。此大士者。能于彼时被坚固精进之铠。于多佛所亲近恭敬深种善根

    阿阇世王问答品第二十二之一

尔时阿阇世王。即起是念。此金刚手菩萨大秘密主。右手所持大金刚杵几何轻重。而秘密主。有大力势能善执持

时金刚手菩萨大秘密主知其所念。即告阿阇世王言。大王。当知此金刚杵亦轻亦重。王言。以何缘故亦轻亦重。金刚手言。为欲调伏憍慢贡高诸众生故。此杵即重。为示无慢正直诸众生故。此杵即轻

时金刚手菩萨。即以所持大金刚杵置之于地。当置地时以神力故。三千大千世界六种振动。即告阿阇世王言。大王。汝今宜应以此地中大金刚杵而自举之。时阿阇世王。即时以自坚固勇力。欲举其杵竭其力势。不能动摇一毛端量。即生希有尊重之心。前诣佛所。合掌白佛言。世尊。我昔曾于战阵之所。取被甲大象。一手执持举掷于远。此金刚杵其量微小。我今竭自力势不能动摇。况复举邪。以何缘故其事如是。佛言大王。无自恼心。此金刚杵至极重故

时阿阇世王。即白帝释天主言。憍尸迦。今宜举此地中所置大金刚杵。时帝释天主。即时以自勇猛神力欲举其杵。尽竭其力不能动摇。即生希有尊重之心。前诣佛所而白佛言。世尊。我若与彼阿修罗王。斗战之时我力坚胜勇锐无敌。右手取彼毗摩质多罗阿修罗王所有大车。量广七百由旬。我时执持如迅风行。此金刚杵竭自势力不能动摇。岂非世尊广大威神所制止邪。佛言。憍尸迦。此亦非我神力所制。但为彼金刚杵至极重故。憍尸迦。于汝意云何。须弥山王至极重邪。天主白佛言。须弥山王至极重大喻所不及。佛言天主。此金刚杵金刚所成。重复过彼须弥山王。而金刚手菩萨。能以此杵掷碎轮围诸山。犹如糠秕。以其金刚大力势故

尔时帝释天主。即白尊者大目干连言。佛说尊者于声闻众中神通第一。愿今尊者。举此地中大金刚杵。尊者大目干连即自思念。我若于此人天大众之前。不能举动此金刚杵。岂非于我生慢心邪。作是念已运自神力。方欲前举彼金刚杵。即时三千大千世界六种振动。海水腾涌大地普皆怖畏振击。唯金刚杵不动不摇。是时尊者大目干连。前诣佛所顶礼佛足。作是白言。佛说我于声闻众中神通第一。具大威神名称力势。能以四大海水置于掌中。亦能转此三千大千世界。犹如有人以一金钱转于指端。又能空中止其日月。制彼威光不令转动。又能取彼须弥山王掷过梵世。又能调伏难陀乌波难陀二大龙王。又能于彼阳焰世界周行乞食。此金刚杵其量微小。然我亦复不能动摇。世尊。岂非我今神力减邪。佛言。大目干连。非汝神力有所减少。但为菩萨威力加持。一切声闻缘觉悉不能动。况余众生。又目干连。假使殑伽沙数诸佛刹中所有须弥山王悉能振动。唯金刚杵随置地方不能动摇。目干连白佛言。世尊。金刚手菩萨具大力势。而能戏掷此金刚杵。诚哉希有。佛言。大目干连。假使三千大千世界诸须弥山。尚能合入一须弥山悉能动摇。此金刚杵而不能动

尔时尊者大目干连生希有心。前白佛言。希有世尊。此金刚手菩萨大秘密主具大力势。善能持彼大金刚杵。此秘密主。为即父母所生力邪。为神力邪。佛言。大目干连。父母所生之力。随所入处皆有分量。而诸菩萨神通力者无尽无限。我若开示使天人世间咸生迷惑

尔时世尊。普遍观察诸众会已。告金刚手菩萨大秘密主言。汝今宜应自当举其地中所置大金刚杵

时金刚手菩萨大秘密主神力振动三千大千世界已。即以左手举取其杵。戏掷空中旋绕七匝。杵旋空已。即时接置安右手中。一切众会生希有心。合掌顶礼大秘密主。咸作是言。希有秘密主。能具如是广大力势。善持最胜大金刚杵。普愿一切众生皆悉获得如是胜力

时阿阇世王复白佛言。世尊。菩萨具修几法。即能获得如是胜力。佛言大王。菩萨若修十法获斯胜力。何等为十。一者。菩萨宁舍身命。终不弃舍无上正法。二者于一切众生。作谦下想不增慢心。三者于彼劣弱众生。起愍念心不生损害。四者见饥渴众生施妙饮食。五者见怖畏众生施其无畏。六者见疾病众生施药救疗。七者见贫乏众生惠令满足。八者见佛塔庙形像涂饰圆净。九者出欢喜言安慰众生。十者见彼负重疲困苦恼众生为除重担。菩萨若具如是十法。即能获得如是最胜之力

佛说如来不思议秘密大乘经卷第十八佛说如来不思议秘密大乘经卷第十九

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    阿阇世王问答品第二十二之二

复次阿阇世王白佛言。世尊。菩萨当修几法获得自在之法趣向自在。佛言大王。菩萨当修八法即得自在之法趣向自在。何等为八。一者出美善语心意质直。二者心常柔软。三者心善爱乐。四者心常平正。五者无谄。六者无诳。七者不嫉。八者心常调畅。菩萨若具如是八法。即得自在之法趣向自在。阿阇世王复白佛言。菩萨当修几法能于自在中住。佛言大王。菩萨当修四法能于自在中住。何等为四。一者若生人间。愿为转轮圣王值佛出世。二者愿为帝释值佛出世。三者愿为娑婆界主大梵天王值佛出世。四者愿为豪胜长者值佛出世。菩萨若具如是四法。能于自在中住。阿阇世王白佛言。世尊。净信以何为毕竟。佛言大王。善知识为毕竟。王言。多闻何为毕竟。佛言。多闻慧为毕竟。王言。布施何为毕竟。佛言。布施大富为毕竟。王言持戒何为毕竟。佛言。持戒能生善趣而为毕竟。王言。忍辱何为毕竟。佛言。忍辱随护众生而为毕竟。王言精进何为毕竟。佛言。精进善能圆满一切佛法而为毕竟。王言。禅定何为毕竟。佛言。禅定近寂为毕竟。王言。胜慧何为毕竟。佛言。胜慧息诸烦恼而为毕竟。王言。听法何为毕竟。佛言。听法断诸疑惑而为毕竟。王言。问法何为毕竟。佛言。问法离诸杂说而为毕竟。王言。居处闲寂何为毕竟。佛言。居处闲寂得禅定神通而为毕竟。王言。观想何为毕竟。佛言。观想离念为毕竟王言。无常声何为毕竟。佛言。无常声离诸执着而为毕竟。王言。苦声何为毕竟。佛言。苦声无取为毕竟。王言。无我声何为毕竟。佛言。无我声灭我我所而为毕竟。王言。寂静声何为毕竟。佛言。寂静声随止为毕竟。王言。深固作意何为毕竟。佛言。深固作意发起正见而为毕竟。王言。若身心离何为毕竟。佛言身心离发起禅定神通而为毕竟。王言。圣道何为毕竟。佛言。圣道现前三昧果而为毕竟。王言。信解何为毕竟。佛言。信解解脱圆满而为毕竟。王言。诸佛出世何为毕竟。佛言。诸佛出世成就一切菩提分法而为毕竟。王言。如何是佛出世。佛言大王。随发菩提心即是佛出世。王言。云何发菩提心。佛言。所谓大悲出生。王言。云何大悲出生。佛言。谓即发起净信。王言。云何发起净信。佛言。若发菩提心。即是发净信。王言。当云何发彼菩提心。佛言。深心不退转。是发菩提心。王言。云何是深心不退转。佛言。即是所起大悲。王言。云何能发大悲。佛言。于一切众生不生厌舍之心。即是大悲。王言。云何于众生得不厌舍。佛言。所谓不着己乐。王言。云何是不着己乐。佛言。谓于三宝常不舍离。王言。云何能于三宝不舍离邪。佛言。若能除去一切烦恼。即于三宝而不舍离

尔时阿阇世王重复肃恭前白佛言。希有世尊。希有善逝。善说如来清净法律。如来能善施设学处。复能随顺诸佛世尊所说正法。不坏因果远离断常。随诸所说成办事业。善恶果报俱无坏失。离诸虚诳如佛所说。如是最上广大清净教中谁人敢破。复谁问难及生毁谤。唯除不种善根诸罪业者。世尊。我昔不曾深种善根于佛勤孝。不能出自血肉报佛深恩。愿佛今时威力加护。今我一切烦恼一切罪业皆悉消灭。世尊。彼妙吉祥童真菩萨是善知识长夜利乐。为我息除诸有恶作。法光照我。我亦不能报彼深恩。世尊大慈大善知识。能为我说普尽梵行最上正法

    贤王天子品第二十三

尔时寂慧菩萨摩诃萨。前白金刚手菩萨大秘密主言。如佛世尊化所化事。汝秘密主。可能随作诸化事邪。金刚手菩萨言。今佛现前为我作证。所有殑伽沙数等。诸佛如来诸有化事。而我亦能随佛施作。所谓种种色相游戏神通。但以宿世深心清净而为毕竟

尔时寂慧菩萨。复白金刚手菩萨大秘密主言。我今劝请大秘密主。愿以神力加持护念。令此正法于后时后分后五百岁广宣流布。使彼正法所摄诸大士等得此正法堕于手。中金刚手菩萨。言善男子。诸佛如来于此正法已共加持。何以故。今此正法即是文字所成。而彼文字无生无尽亦不隐没。以其文字及所说义不能隐故。如来此说甚深正法亦不能隐。所以者何。无法可生。若法无生即法无灭。如是当知。如佛所言。若佛出世若不出世诸法常住。所谓法性法界法住。实际清净。法如是故。如其所说。诸法缘生亦不相违。若法缘生不相违故即是正法。以正法故即不隐没。如是所说乃名正法。寂慧菩萨言。秘密主。云何能被精进铠摄护正法。金刚手菩萨言。若于一切法不相违。即能被精进铠摄护正法。何以故。而此正法与一切法不相违故。寂慧菩萨言。何法是相违。金刚手菩萨言。文字相违故即法相违。而不复与生法相违。若彼不相违。是为摄护正法者。寂慧菩萨言。彼摄护正法。有与一切世间相违不。金刚手菩萨言有。善男子。何以故。世间众生取着诸见有执空语者。彼即世间相违。又谓世间是常乐我净。而世间者是无常是苦无我不净。彼即世间相违。又世间众生顺生死流逆正法流。彼即世间相违。又世间众生尊现世法。护正法者尊他世法。彼即世间相违。又世间众生取蕴处界。护正法者。说一切法无取着故。彼即世间相违。寂慧。当知以是缘故。护正法者与彼世间相违。寂慧菩萨言。大秘密主汝当云何摄护正法。金刚手菩萨言。如我摄护者。谓无我无众生无法而乃摄护。寂慧菩萨言。此复云何。金刚手菩萨言。谓我离故。众生离故。法离故。我众生法离故。过去离故。未来离故。现在离故。过去未来现在不离故。三世离故。三世不离故。诸佛离故。诸佛不离故。刹土离故刹土不离故。法离故。法不离故。若能通达如是法者。即能摄护正法

尔时世尊赞金刚手菩萨大秘密主言。善哉善哉。大士。汝善摄护正法。若于一切法无执无取即能摄护正法。若于一切法有相戏论无取无集。乃至一切分别遍计悉无分别。即能摄护正法

尔时会中有一天子名曰贤王。前白佛言。世尊。近止近寂是佛所说。若如所说者。即一切所缘皆悉寂止而无所观。以彼近寂不复和合发生诸法。虽法寂静遍寂近寂。而复任持如来正法亦不弃舍。虽复任持然于一切法无所任持亦无弃舍。当彼天子说是法时。会中有千苾刍得心解脱。有千天子得法眼净

尔时寂慧菩萨白贤王天子言。云何得是辩才。天子答言。能断一切习气。离语言道无所记说。胜义谛中无法可取故得辩才。寂慧菩萨言。天子。辩才云何出生。天子言。无辩才故。离辩才故。所以者何。无辩才者。此说即是无和合义。离辩才者。此说即是离戏论义。复次善男子。如所说故。何有辩才可得。若为他表了识即不转。若白表了识亦无住。以如是故乃得辩才。若于诸所缘。以意表了者又无障碍。法性之中而无所住。故得辩才。又一切法中智无所转。无有少法智可知解。故得辩才。又无住法中无出无入越诸染法。故得辩才。又一切法无生而生无灭而灭。故得辩才

尔时寂慧菩萨白佛言。希有世尊。此贤王天子具大辩才。佛言寂慧。此贤王天子。从极乐世界阿閦佛刹中而来至此。欲听金刚手菩萨大秘密主宣说如来秘密正法。又此天子。已得随入一切法相陀罗尼故。于百劫中无所愿求。自然获得无碍辩才。随所宣说辩才无碍

    总持功德赞说譬喻无尽品第二十四之一

尔时寂慧菩萨白佛言。世尊。云何名为随入一切法相陀罗尼。佛言寂慧。随入法相者。即是文字无尽随入之智。谓阿字门。随入一切法故。又阿字者。是即诸法出生之门。又阿字者。是即诸法初生后际。又阿字者于一切处成办事业。随起语业。无所了知非无了知。以阿字门随入一切法故。此说是名随入法相陀罗尼门

复次寂慧。所言随入者。于一切处无有少法如微尘许可出可入。无文字故。从何所来复从何入中亦何住。以其文字中无住故。而即无出何方而去。又以文字无和合故。即无文字而可记说。亦非无说无增无减。以无文字故无有是法。亦无非法而可分别。以无文字故无法可生无法可灭。无法可成无法可坏。寂慧当知。如是文字算数。即是心之算数。如心算数即是一切法算数。如一切法算数即非算数。何以故。法无算数可得故。以无算数法可算数故。即一切法算数不可得。如是即能随入法相。本来如是随入无生。若入无生亦复无起。此即无有少法可入。是故诸法无入而入。寂慧。若能如是入诸算数。即于辩才而不能断。何以故。法性无断故。若如是通达即能随应为他说法。随有所说现前作证。由如是随入诸法相故。即是随入众生相。以其随入众生相故。即如所信解善说诸法。寂慧。得陀罗尼菩萨。其心离垢意乐清净正行洁白。其心高胜所行善住妙慧最上。而获神通坚固圆满。不为魔军之所破坏。降伏外道制诸烦恼解除怨结。身有力势心无疲倦。辩才无尽演法无边善说无际。胜智无碍具深妙慧。善说深法多闻如海。住三摩地如须弥山。所有众会如师子王。世法清净如彼莲花。长养众生如其大地。息烦恼爱犹如大水。成熟众生犹如大火。于一切众生起平等心犹如妙月。破烦恼痴暗犹如大日。除烦恼怨如勇力者。心善调伏犹如大龙。高振法音如大云吼。普施法雨如澍大雨。疗治众生诸烦恼病如大医王。作大法王如王自在。善护世法如护世天。善观天人如帝释天主。心得自在具增上力犹如梵王。无所系着犹如飞鸟。怖诸愦闹犹如猴鹿。于一切众生忍伏诸恶犹如慈母。教授艺能开诸学门犹如慈父。施诸法宝流注无尽如毗沙门天王。得福庄严具诸相好。人所乐观见者欢喜。具七珍财无贫乏苦。摄诸无智称赞智者。具智慧故离诸过失。善护诸天善护诸龙及夜叉等。说法自在神通无碍。了知一切众生意乐。随入一切众生根性听法无厌。不求一切名闻利养说法无吝。无染着故具戒清净。无怨害故忍力清净。善能成办诸事业故精进清净。得自在故禅定清净。洁白智故胜慧清净。梵行最上故具四无量。善修出世静虑等持。成就无上菩提圣道。以具如是诸相功德故。当得无上法王灌顶。寂慧。当知得陀罗尼菩萨。尚获如是无量功德。若复如来神力加持诸有事业。皆得陀罗尼菩萨功德。经百千岁称赞譬喻而不能尽

尔时寂慧菩萨白贤王天子言。仁者。汝今快得善利。能善称赞如来无量无边功德。时贤王天子白寂慧菩萨言。善男子。胜义谛中无有少法可得称赞。何以故。法无有相非形显色。是故功德不能称赞得其边际。若形显色中决定有相者。即可以言词宣说称赞

佛说如来不思议秘密大乘经卷第十九佛说如来不思议秘密大乘经卷第二十

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    总持功德赞说譬喻无尽品第二十四之二

尔时贤王天子白佛言。世尊。一切法无摄受无我无取无续无断。然以方便随宜所作。诸勤行者。以正方便现前得法。世尊。譬如大水积于地下。须假人力勤行施作。或开以坑或凿以井。由勤力故方获其水。若无坑井水乃何得。勤行方便之者。亦复如是。以勤力故于一切处胜智通达。若无勤力智从何得。是故求菩提者。常勤方便发起精进。即能现前获得圣法。又如世间生盲之人。所生色象而不能见。众生烦恼暗蔽亦然。于所生法而不能见。又如世间有目之人于黑暗中。若无明炬即不能见一切色象。修天眼者亦复如是。若无善知识说法教导。不能于法而生信解。又如已具净天眼者。不假世间光明所照。菩萨亦复如是。所作已办者。不假他人而为教导。又如世人处胎藏者都无所见。亦复不见有所增长。发起精进菩萨亦复如是。虽修佛法亦不见菩提有所增长。又如大雪山王所有诸树依之而生。诸树必无中有破坏及彼焦枯。菩萨亦复如是。勤行方便修诸正法依智所生。亦不于中破坏减失。又如转轮圣王出于世间七宝随出。所谓轮宝象宝马宝珠宝女宝主藏神宝主兵神宝等。菩萨亦复如是。若发菩提心七宝亦随出。所谓布施持戒忍辱精进禅定胜慧方便等。又如转轮圣王统行四大洲界。于诸众生平等爱念而无异想。菩萨亦复如是。以四摄法普摄众生而无异想。四摄所谓布施爱语利行同事。又如转轮圣王行王法化。一切悉无斗战争讼。菩萨亦复如是。安居说法悉无一切邪外战讼。又如三千大千世界最初成立大须弥山及彼大海。菩萨亦复如是。初发菩提心先以深固大悲建立。又如世间日光出时先照高山。菩萨亦复如是。最初发起大智光明。令诸众生发起善根得智光照。又如大地受诸种子。而彼一切草木丛林。依地而生平等滋长。得陀罗尼菩萨亦复如是。以无著心于一切众生平等与法而无弃舍

尔时世尊赞贤王天子言善哉善哉。天子。汝今善能譬喻宣说诸菩萨法。天子。当知假使一切草木丛林名相等聚法聚声聚及形色聚。遍入一切众生心行。普以一切名相分别。一切众生周遍伺察。乃至众生饮食受用。悉为譬喻称扬赞说。彼得陀罗尼菩萨。所有功德而不能尽。天子。彼得陀罗尼菩萨者。诸有所说无有少法非佛语者。又复一切色相光明。声香味触法光明无不现前。所得辩才不随他闻而有系属。不观他相而有所说。于一切处随其所向通达无尽亦复无边。不以威力偏入一切。身无粗重心无所缘。能于百千诸佛现前说法无染无著。而是菩萨以彼诸佛威神建立故。得陀罗尼智慧辩才。有所说法无染无著亦无退转。天子。当知菩萨有三无著之法。何等为三。一者我无著。二者众生无著。三者法无著。又有三种通达清净。何等为三。一者法界清净。二者真如清净。三者实际清净。又有三种通达无尽。何等为三。一者法无尽。二者文字无尽。三者演说无尽。又有三种获得通达加持之力。何等为三。一者辩才加持。二者法义加持。三者入法加持。又有三种成就欢喜。何等为三。一者慧欢喜。二者智欢喜。三者断疑欢喜。又有三种速疾之法。何等为三。一者念速疾。二者慧速疾。三者行速疾

当佛说是总持功德赞说譬喻无尽法时。会中八百菩萨得入陀罗尼门

    嘱累正法品第二十五

尔时金刚手菩萨大秘密主白佛言。惟愿世尊。神力加持令此正法于后时后分后五百岁。阎浮提中广宣流布。佛言。秘密主。我有密护正法秘密大明章句。汝能记念不。是章句者。我昔曾于宝月如来所亲所听闻。金刚手菩萨白佛言。世尊。我亦记念。佛言。秘密主。汝今宜应为此众会。密护正法令久住世。当说往昔大明章句

尔时金刚手菩萨大秘密主。合掌顶礼十方一切诸佛。即说大明曰

怛[寧*也](切身下同)佗(引一句)惹野(二)惹野末帝(三)惹野设睹噜(二合引四)阿梨(五)阿末梨(六)阿卢力帝(七)末弥那末末散提(八)乌谛(九)乌怛末帝(十)乌怛啰尼(十一)阿(引)哩(十二)阿(引)啰摩尼(十三)阿哩怛摩尼(十四)阿牟(引)梨(引十五)牟罗(引)嚩窒帝(引十六)牟(引)逻(引)努誐帝(十七)阿窒(十八)末窒(十九)末窒帝(二十)阿(引)尼(二十一)摩(引)尼(二十二)摩(引)尼帝(引二十三)枯噜(引二十四)枯噜(引)散提(二十五)达哩摩(二合引)努誐帝(二十六)达哩摩(二合)怛翅(引二十七)达哩摩(二合)钵啰(二合)尾(引)尸(引二十八)萨哩(引二十九)萨啰(引)萨哩(引三十)阿毗祢(引三十一)毗那散提(三十二)伊呬(三十三)伊喝儞(三十四)伊那努誐弥(引三十五)儞誐啰(二合)呬摩(引)啰(引)赧(引三十六)儞哩伽(二合引)怛儞底(引)哩他也(三合引)喃(引三十七)牟(引)喝那(引)达哩摩(二合)捺尾(二合)尸赧(引三十八)尾驮末那(引)讫梨(二合引)舍(引)喃(引三十九)乌入嚩(二合引)罗那(引)达哩摩(二合)儞(引)底哩(二合引)赧(引四十)阿(引)荦(吕角切)叉(引)达(引)哩摩(二合)葛体迦(引)喃(引四十一)阿(引)尾设那(引)儞哩嚩(二合引)拏写(四十二)钵啰(二合)誐啰(二)呼(引)冒(引)提钵哩左(引)哩迦(引)喃(引四十三)钵哩三塞佗(二合引)钵那(引)钵哩沙(二合)那(引四十四)迦(引)夜(引)努钵啰(二合)那(引)喃(四十五)达(引)哩摩(二合)设啰(二合)嚩尼迦(引)喃(引四十六)三满按(引)喝啰怛鍐(二合四十七)萨藐誐多(引)喃(引四十八)阿嚩路(引)葛喃(四十九)萨藐葛钵啰(三合)帝钵那喃(引五十)阿(引)穆契(引)婆(引)嚩怛鑁(二合五十一)满怛啰(二合)钵那(引)儞摩(引)钵啰(二合)拏闪都(引五十二)满怛啰(二合)散提啰(引)[口*爾](引)那乌那(引)喝兰拏(五十三)倪也(二合引)那阿刍(引)拏多(引五十四)阿那嚩蜜哩(二合)[寧*也]多(引)祢(引)舍那(引)莎婆(引)嚩怛鍐(二合)(五十五)

金刚手菩萨大秘密主。说是秘密大明章句已。时此三千大千世界皆悉振动。即此三千大千世界一切魔众各与眷属。同时来诣佛世尊所。曲躬合掌俱白佛言。世尊。若诸法师能从口门出是大明章句者。我等诸魔皆往承事恭敬。令此大明最胜威力。一切天人不能破坏。我等常当密作护卫。无令一切伺得其便

尔时世尊普遍观察诸众会已。即说秘密大明章句曰

惹曳讷哩惹(二合)曳(一句)惹野末帝(二)设弥(三)设睹噜(二合引)儞哩伽(二合引)怛儞(四)阿牟(引)梨(五)牟(引)罗钵哩亲儞(六)摩(引)啰塞(引)[寧*也](切身)尾怛啰(二合引)萨儞(七)穆吉底(二合八)穆吉多(二合)嚩帝(九)戍(引)提(十)阿毗祢(十一)婆野牟(引)左儞(十二)婆(引)噜(引)喝尼(十三)难帝尾奈曳(二合引十四)尾[寧*也]钵啰(引)讫啰(二合)牟(引十五)

即说伽陀曰

  正法摄伏于他语　　以正法语善摄受
  于法宝藏常护持　　如来所说大明句

复说大明曰

阿弥(一句)末弥(二)末末亲祢(三)阿哩体(二合引四)阿哩佗(二合)儞萨多(二合引)啰尼(五)

此是呼召四大天王。大明章句

复说大明曰

提(引)哩(一句)提(引)啰嚩帝(二)虞(引)钵帝(二合引三)戍(引)毗(引四)戍(引)婆嚩帝(引五)设弥(六)

此是呼召帝释天主。大明章句

说伽陀曰

  具慈善顺大忍力　　为悲愍故说大明
  喜舍二法悉具圆　　梵王帝释咸呼召

复说大明曰

阿啰尼(引一句)嚩啰尼(二)珂溪(三)阿牟(引)梨(四)牟(引)罗输(引)驮儞(引五)

此是摄伏诸魔大明章句

说伽陀曰

  今此秘密大明句　　振动降伏一切魔
  人中圣主力加持　　善说斯经广流演
  如来所说此正法　　当知于后末世时
  宣说明句密加持　　振动还复如今日

时诸魔众咸来集会。说伽陀曰

  诸说法师大智者　　我等诸魔当密护
  令于最后末世时　　得此正法堕于手

尔时世尊告金刚手菩萨大秘密主。言。汝应当知今此正法。如来威神已加持故。无人能于此正法中有所动转。何以故。我念往昔过去世中。有佛出世。号宝月如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名无毁。劫亦名无毁。彼佛法中有二法师。有大威德名称力势。一名慧上。二名谛授。彼二法师。于宝月如来所。听闻受持此大明章句。满足半劫。随彼如来转正法轮。彼时所有三千大千世界百俱胝魔众。皆令成熟菩提圣法。寂慧菩萨前白佛言。世尊。彼宝月如来为现住说法。为已涅槃邪。佛言寂慧。东方去此百万俱胝佛刹。有佛国土其名无毁。佛号宝月。现住说法。彼佛寿量十千劫数。其佛刹中有诸魔众佷恶难调。彼佛宣说大明章句而悉调伏。得调伏已。皆于菩提圣法成熟圆满。秘密主。汝今当知。我亦曾于宝月如来法中。净修梵行成就菩提圣法。彼时慧上法师者。即我身是。彼时谛授法师者。即金刚手菩萨是。寂慧。当知我于彼时。与金刚手菩萨。同勤精进心不放逸。于彼佛世尊所。尊重恭敬广多供养。听受彼佛宣说秘密大明章句。降伏诸魔摄护正法

尔时世尊普遍观察诸众会已。普告众言。汝诸仁者。谁当堪任于佛如来入涅槃后。以我阿僧祇劫积集菩提胜行最上正法。受持卫护不令隐没

尔时会中有一万二千菩萨为护法故。从座而起合掌顶礼。向佛世尊说伽陀曰

  若人捐弃于身命　　所舍不求诸果报
  但为受持佛所宣　　最上清净正法故

复有贤王等五千天子。合掌顶礼前白佛言。世尊。我等咸愿受持如来菩提圣法。时诸天子说伽他曰

  普为一切众生故　　发起坚固大悲心
  我当受持此法门　　最上甚深佛所说

尔时帝释天主。尸弃梵王。毗沙门天王。说伽陀曰

  今此正法如妙药　　能治一切众生病
  我等当来悉护持　　愿佛知我众心意

尔时金刚手菩萨大秘密主。前白佛言。世尊。我当受持如来于阿僧祇劫积集无上正等正觉菩提圣法。即说伽他曰

  诸法本来无文字　　无中假以文字说
  圣尊悲愍故敷宣　　我当受持而流演

尔时世尊告尸弃梵王言。梵王当知。菩萨有三种最上供养承事。如来以其最上承事供养故。获福无量。何等为三。一者发起阿耨多罗三藐三菩提心。二者任持诸佛正法。三者随所闻法如实修行。大梵。如是三种最上供养。如来若住一劫乃至劫尽。或复寿命无量。此供养事所获福报。广说不能得其边际。所以者何。若欲最上供养诸如来者。应当修此三种最上广大清净法之供养

复次大梵。若有人于如来所说正法之中。而能受持一四句偈者。是即护持过去未来现在诸佛世尊菩提圣法。何以故。诸佛菩提从法出生。是故法之供养。超出世间财供养事。法供养者。诸供养中胜中最胜最上第一。大梵。我念过去光明王族中有一太子。名曰具慧。忽时一夜于其梦中。亲所听闻说二伽陀。闻已记念觉乃惟忖。我今得大宝藏。即时忽然高振其声。作如是言。我今得大宝藏时王及后子问其故。太子即时具陈上事。乃为父母说是二伽陀曰

  世间财宝聚还散　　王官水火贼盗分
  诸佛多闻妙法财　　多俱胝劫不坏失
  常无放逸甘露法　　利众生发菩提心
  深固寂静心亦然　　诸乐根本无所取

大梵。彼时太子为其父母。说梦中所闻二伽陀。时彼有八千人成熟菩提善根。四万二千众生悉得生天。以是缘故。所有多闻清净法财。应当精勤依法修行修正法故即能如应为他摄受

复次大梵。有二种法而能多作。何等为二。一者于诸众生不兴损害。二者勤求多闻而无厌足。若有能行此二法者。于正法眼而不断灭。大梵。汝于贤劫诸如来所。劝请说法善护正法。而彼贤劫诸佛如来。若诸清净众生方得值遇出世。是故汝今勿应厌舍。何以故。大梵。浊恶时中若能于一昼夜受持正法者。获福多于百千劫中清净佛刹持正法者。是故大梵。汝应发起广大精进。于此浊恶时中坚固护持如来正法

尔时世尊告尊者阿难言。汝今宜应于此所说如来秘密金刚手品部惹啰陀罗尼门坚固受持。于后末世为他广说。我今以是正法付嘱于汝。汝于末世时中。所有具彼劣信解者。不应为说此正法门使彼痴迷。何以故。于此正法罔彻源底故。若有于正法中得自在者。已善成办诸胜事业。是法器者。应当为说此正法门。彼得闻已不生惊怖。何以故。正法出生故

尔时尊者阿难前白佛言。世尊。我今以佛威神力故受持此法。随其力能流布宣演

佛言阿难。汝今见此金刚手菩萨大士于佛正法勤力护持不。阿难白佛言。唯然已见。佛言阿难。汝今亦然于此正法随宜摄受。坚固护持如应宣说。阿难白佛言。此经何名。我等云何受持。佛言阿难。是经名曰金刚手品。亦名宣说如来秘密。亦名不思议佛法。亦名无量福聚。如是名字汝当受持

复次阿难。汝今当知若有住菩萨乘人。佛眼所观者。能以众宝广大充满诸佛刹中。乃至从地积于有顶。广行布施而不望报。若复有人不以财利之心。如善所作为他演说此正法者。福多于彼。此说是名如来秘密无量福聚

当佛说此嘱累正法品时。会中有千俱胝人发阿耨多罗三藐三菩提心。九万六千菩萨获得忍法。八万四千人得法眼净。千六百苾刍得心解脱。千六百苾刍尼亦得心解脱。十方无量诸佛刹土皆悉振动。百千天人于虚空中鼓奏天乐雨众妙华。伸供养已咸作是言。愿此正法久住世间。于阎浮提广宣流布

佛说此经已。金刚手菩萨大秘密主。及寂慧等诸菩萨众。贤王等诸天子众。阿阇世王等诸大国王。并余菩萨。及阿难等诸大声闻。乃至一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜信受奉行

佛说如来不思议秘密大乘经卷第二十


佛说三十五佛名礼忏文一卷

    No. 326 [Nos. 310(24), 325]

佛说三十五佛名礼忏文一卷(出乌波离所问经)

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

娜谟释迦牟尼佛　娜谟金刚坚固能摧佛　娜谟宝焰佛　娜谟龙自在王佛　娜谟勤勇军佛　娜谟勤勇喜佛　娜谟宝火佛　娜谟宝月光佛　娜谟不空见佛　娜谟宝月佛　娜谟无垢佛　娜谟离垢佛　娜谟勇施佛娜谟净行佛　娜谟梵施佛　娜谟水王佛　娜谟水天佛　娜谟贤吉祥佛　娜谟无量威德佛　娜谟栴檀吉祥佛　娜谟光吉祥佛　娜谟无忧吉祥佛　娜谟那罗延吉祥佛　娜谟花吉祥佛　娜谟莲花光游戏神通佛　娜谟财吉祥佛　娜谟念吉祥佛　娜谟善称名号吉祥佛　娜谟帝幢幡王佛　娜谟斗战胜佛　娜谟勇健吉祥佛　娜谟勇健进佛　娜谟普遍照曜庄严吉祥佛　娜谟宝莲花游步佛　娜谟宝莲花妙住山王佛

如是等十方一切世界中诸佛世尊。出现世间住持游行。愿皆观察哀愍于我。我或今生或于余生。无始时来广作众罪。或自作或随喜作或教他作。或偷盗佛物四方僧物。或自作或随喜作或教他作。或造五无间罪十不善业道。或自作或随喜作或教他作。由此业障覆蔽身心生于八难。或堕地狱傍生鬼趣。或生边地及弥戾车。或生长寿天。设得人身诸根不具。或起邪见拨无因果。或厌诸佛出兴于世。如是一切业障。我今对一切诸佛世尊。具一切智者具五眼者。证实际者称量者。知者见者前。我今诚心悉皆忏悔不敢覆藏。愿我尸罗律仪复得如故。复愿诸佛世尊摄受护念证明于我若我今生或复余生。无始时来于流转生死。或曾舍施傍生一团之食。或曾持一净戒。或曾修梵行善根。或曾修少分无上智善根。悉皆合集计校筹量。如三世一切诸佛于最胜无上回向愿中。愿皆回向无上正等菩提

  一切罪忏悔　　诸福皆随喜
  及劝请诸佛　　愿证无上智
  过去及未来　　现在人中尊
  无量功德海　　我今稽首礼

(右此三十五佛名并忏悔法。出乌波离所问经。能净业障重罪。现生所求禅定解脱。及诸地位皆能满足。五天竺国修行大乘人。常于六时礼忏不阙。功德广多文烦不能尽录。但依天竺所行者略记之。余如本经所述也)

佛说三十五佛名礼忏文


佛说太子和休经一卷

    No. 344 [Nos. 310(37), 343]

佛说太子和休经一卷

        僧祐录云失译今附西晋录

佛在罗阅只国耆阇崛山中。与菩萨万人俱。比丘僧千二百五十人。诸优婆塞优婆夷。诸天王梵释及人民鬼神龙。无央数共坐。阿阇世王太子。名为和休。与长者子五百人。各持金花伞盖。从罗阅国出行。与太子相随俱到佛所。各持伞盖上佛已。各叉手头面着地为佛作礼却住佛前。太子叉手白佛言。菩萨何因缘得端正。何因缘不入女人腹中。而生莲花中。何因缘知前世宿命愿。佛加大恩当为我分别说之。佛告太子。菩萨忍辱不嗔怒者。后世生为人端正。菩萨不淫劮不与女人交通者。后世生不入女人腹中。便于莲华中化生。菩萨喜持经戒教人。后世生便自知宿名无央数世之事。太子白佛言。何因缘菩萨有三十二相。何因缘有八十种好。何因缘人民见佛身形。视之无厌极

佛告太子。本为菩萨时。好布施与人在所求索。欲得衣服饮食。金银珍宝车马。奴婢妻子。肌肉头目。皆不逆人无所贪惜。用是故得三十二相。菩萨慈心哀念人民蜎飞蠕动之类。如视赤子。欲念度脱用是故得八十种好。菩萨见怨家如视父母。其心适等无有异。用是故人民见佛身形。视之无厌极

太子白佛言。何因缘菩萨知深经智慧。何因缘知三昧安隐。何因缘佛所语皆使人闻者皆欢喜耶。佛告太子。菩萨喜书经讽诵学说。用是故知深经智慧。菩萨常好定意心安。用是故得三昧安隐。菩萨所语皆至诚不欺怠人。用是故所语诚信。人闻者皆欢喜。太子白佛言。何因缘菩萨身所行口所言心所念皆净洁。何因缘魔不能得其便。何因缘众人不敢诽谤佛经道。不敢诽谤比丘僧。佛告太子。菩萨喜侍佛喜经道喜比丘僧。用是故得净洁。菩萨昼夜经行精进。用是故魔不能得其便。菩萨所语皆至诚不欺。用是故人民不敢诽谤佛经道。不敢诽谤比丘僧。太子白佛言。何因缘菩萨得寿命长。何因缘得无病。何因缘家中皆和顺相重。不令他人别离。佛告太子。菩萨慈心不杀生。用是故后生得寿命长。菩萨不持刀杖恐怖人。用是故后世生得无病。菩萨见人有斗变喜行救解令和合。用是故后世生人不别离。太子白佛言。何因缘菩萨易得财物富有不难。何因缘不亡财物人不劫盗。何因缘得尊者豪贵耶。佛告太子。菩萨智黠不愚痴。用是故得大富不难。菩萨喜布施不贪惜余者。不亡财物。见人富乐得钱财不嫉妒。用是故得为尊者。菩萨不杀不自贡高。用是故得为豪贵。太子白佛言。何因缘菩萨得天眼洞视。何因缘天耳彻听。何因缘得知世间生死所趣善恶耶。佛告太子。菩萨喜于佛寺中然灯。用是故得天眼洞视。菩萨喜持倡伎乐佛寺中。用是故天耳彻听。菩萨入三昧得禅。用是故知世间生死所趣善恶。太子白佛言。何因缘菩萨得飞行四神足念。何因缘菩萨得念前世无央数劫之事。何因缘菩萨得佛便绝命。佛告太子。菩萨布施持车马象。及与骡驴骆驼。履屣与人。用是故得飞行四神足。菩萨喜念诸佛三昧神足。从学喜教人。用是故得念前世无央数劫之事。菩萨得佛意无所著。用是故便般泥洹绝命。太子白佛言。菩萨何因缘。预治佛国。何因缘预知后世得比丘僧。何因缘得光明遍照十方。佛告太子。菩萨常多愿。用是故预治佛国。菩萨布施与人民喜教人。行六波罗蜜经。用是故后得比丘僧。菩萨持七宝物作伞盖上佛及佛寺。用是故得光明遍照十方。佛为太子分别说是事。太子甚大欢喜。及五百长者子皆大欢喜。太子白佛言。我后世佛所说我悉受行皆当具足。佛大笑口中五色光出悉照十方。弥勒菩萨。起前长跪叉手白佛言。佛不妄笑。何因缘五色光出悉照十方耶。佛告弥勒菩萨。听我说之。太子和休及五百长者子。前世供养百亿佛。皆行菩萨道。乃前世提和竭罗佛时。是五百人。皆我弟子所教。后世悉当得共会。供养六亿佛。却后一劫。劫名为摩诃波罗蜜。共会一劫中。五百人前后皆同一字。名为若那颈头陀那后作佛时。其国土当如阿弥陀佛国。国中菩萨往来飞行者变化者。皆如阿弥陀佛国中诸菩萨。人闻是经皆当生阿弥陀佛国作菩萨如文殊师利菩萨三摩提钵菩萨。后世作佛者当如阿弥陀佛。说经已太子和休及五百长者子。诸菩萨比丘僧比丘优婆塞优婆夷。诸天梵人民鬼神龙。皆大欢喜。前为佛作礼而去

佛说太子和休经


佛说太子刷护经一卷

    No. 343 [Nos. 310(37), 344]

佛说太子刷护经一卷

        西晋三藏竺法护译

佛在罗阅只耆阇崛山中时。与千二百比丘。菩萨万二千人。优婆塞优婆夷。诸天王梵释。及无央数人民鬼神龙皆来俱会。阿阇世王太子。名为刷护。从国中与群臣长者子五百人。各持黄金华盖。出罗阅国相随出至佛所。持黄金华盖上佛已。却叉手持。头面着地为佛作礼讫竟。皆叉手住。阿阇世王太子刷护白佛言。愿欲问事。如佛肯说者当问。不肯者不敢问。佛言在所问事。太子白佛言。菩萨何因缘得颜颊端正。何因缘不入女人腹中。于莲华中化生。何因缘能自知前世宿命之事。愿佛大恩当为我曹说之。佛告太子。能忍辱不怒者。后生即为人姝好。不淫泆不与女人交通。若寿欲终时。人生一岁一月及七日者。后世生。便自知宿命无数世以来之事。太子白佛言。菩萨何因缘。身有三十二相。何因缘有八十种好。何因缘人民有见佛身者视之无厌极。佛告太子。本为菩萨时。好喜布施种种杂物。与诸佛菩萨及师父母人民。在所来索用。是故得三十二相。菩萨当有慈心。哀念十方人民及蜎飞蠕动之类。如视赤子皆欲令度脱。用是故得八十种好。菩萨见怨家父母心适等无有异。用是故人民见佛视之无厌极。太子复白佛言。菩萨何所因缘。知深经智慧及陀罗尼行。何因缘知三昧定意得安隐。何因缘佛所说皆快善。其有闻者皆欢喜信受。佛告太子。菩萨喜书信受讽诵学。用是故知深经智慧。得陀罗尼行。菩萨常喜专心正意。用是故得三昧安隐。菩萨所说皆至诚不欺。用是故所语人民皆信向。闻者莫不欢喜者。太子复白佛言。菩萨何因缘学经闻佛语人民皆信。何因缘知经律仪法。何因缘孝顺随佛教不犯。佛告太子。菩萨世世不谀谄。用是故学经闻佛语悉知不忘。菩萨入深经不恐不怖。用是故得经律便知仪法。菩萨世世敬佛敬经敬师敬父母。用是故得智慧。太子复白佛言。菩萨何因缘世世生佛边。何因缘问佛叹经晓知中慧。佛告太子。菩萨世世见人说经。不中坏乱不呵之。用是故得生佛边。菩萨数叹深经。用是故知中慧。太子复白佛言。何因缘不生恶处。何因缘生天上。何因缘不贪爱欲。佛告太子。菩萨世世信佛信经信比丘僧。用是故不生八恶处。菩萨持戒不缺。用是故生天上。菩萨知经法本空。用是故不贪爱欲。太子复白佛言。菩萨何因缘身所行口所言心所念皆净洁。何因缘魔不能得其便。何因缘不敢诽谤佛。不敢诽谤经。不敢诽谤比丘僧。佛告太子。菩萨侍佛喜学经爱比丘僧。用是故得净洁。菩萨昼夜行道精进不懈。用是故魔不能得其便。菩萨所语皆至诚。用是故众人不敢诽谤佛。不敢诽谤经道。不敢诽谤比丘僧。太子复白佛言。菩萨何因缘。好高声如梵天声。何因缘有八种音。何因缘知众人所念皆悉能报。佛告太子。菩萨世世至诚不欺。用是故好高声如梵天声。菩萨世世不恶口。用是故得八种音。菩萨世世不两舌不妄语。用是故众人所念悉能报故。太子复白佛言。何因缘得寿命长。何因缘身得无疾病。何因缘家室和顺相爱不令他人别离。佛告太子。不杀生者。用是故后生为人师寿命长。不持刀杖击人。用是故后生为人得无疾病。见人有变斗喜行和解令欢喜。用是故后生为人他人不能得别离。太子复白佛言。菩萨何因缘。多得财物珍宝有不离。何因缘不亡财物。不为人所劫盗。何因缘得尊者得高。佛告太子。不贪他人财物者。用是故后生为人得富乐。喜布施不悭贪。用是故不亡财物。物益增多。见人富乐得钱财。心不嫉妒。不自贡高。用是故后生得高尊。太子复白佛言。何因缘能得天眼洞视。何因缘得天耳彻听。何因缘能知世间人民死生之事。佛告太子。用好喜然灯于佛前。以是故后生为人得天眼洞视。好喜持倡伎乐于佛寺前。用是故后生为人得天耳彻听。菩萨喜定意入三昧得禅。用是故知世间死生之变。太子复白佛言。菩萨何因缘得飞行四神足。菩萨何因缘念知前世无数劫以来之事。菩萨何因缘得三活佛便般泥洹。佛告太子。菩萨好喜布施。常持车马驴骡象骆驼履屣及水船。与诸佛比丘僧及与人民。用是故得飞行四神足。菩萨常专心念诸佛。三昧从学喜行教人。用是故得念前世。无数劫以来之事。菩萨得阿维越致道。以念无所复着用是故能断死生之根。得佛道便般泥洹。太子复白佛言。菩萨何因缘预治国。何因缘预会比丘僧。何因缘光明照十方。佛告太子。菩萨本求大愿。用是故豫得佛国。菩萨好喜布施乞丐与人喜教人民为六波罗蜜。是故后得比丘僧。菩萨喜持七宝作华盖用上佛。用是故得光明遍照十方。佛为太子分别说是事。太子欢喜。及五百长者子皆大欢喜。太子刷护复白佛言。愿使我后世生者。佛所说令我悉受得悉奉行之。皆令如愿。佛便大笑。口中五色光出。佛告弥勒菩萨言。听我说之。太子刷护菩萨及长者子。前世皆供养百八亿佛皆行菩萨道。乃前世提和迦罗佛时。是五百人皆是佛弟子。是我所教。后世悉当共会。六亿佛却后一劫。摩诃波罗会一劫中。五百人前后作佛。皆同一名若那伎头陀耶。后作佛时。当如阿弥陀佛其国亦当如阿弥陀时等无异。国中菩萨往来者飞行者。皆如阿弥陀佛国。若有人民闻是经信喜者。皆当生阿弥陀国。佛说是已。太子刷护及五百长者子。诸比丘僧比丘尼。优婆塞优婆夷。诸天人民鬼神龙。皆大欢喜。前为佛作礼而去

太子刷护经


佛说无量清净平等觉经

    No. 361 [Nos. 360, 362-364]

佛说无量清净平等觉经卷第一

        后汉月支国三藏支娄迦谶译

佛在王舍国灵鹫山中。与大弟子众千二百五十人。菩萨七十二那术。比丘尼五百人。清信士七千人。清信女五百人。欲天子八十万。色天子七十万。遍净天子六十那术。梵天一亿。皆随佛住。神通飞化弟子。名曰知本际贤者。马师贤者。大力贤者。安详贤者。能赞贤者。满愿臂贤者。无尘贤者。氏聚迦叶贤者。牛齝贤者。上时迦叶贤者。治恒迦叶贤者。金杵坦迦叶贤者。舍利弗贤者。大目揵连贤者。大迦叶贤者。大迦旃延贤者。多睡贤者。大贾师贤者。大瘦短贤者。盈辨了贤者。不争有无贤者。知宿命贤者。了深定贤者。善来贤者。离越贤者。痴王贤者。氏戒聚贤者。类亲贤者。氏梵经贤者。多欲贤者。王宫生贤者。告来贤者。氏黑山贤者。经刹利贤者。博闻贤者。其女弟子。名曰大钦姓比丘尼。幻者比丘尼。莲华色比丘尼。生地动比丘尼。生地担比丘尼。生则侍者头痛比丘尼。安丰殖比丘尼。体柔软比丘尼。勇生行比丘尼。自净比丘尼。清信士名曰给饭孤独长者。安念众长者。快臂长者。火英长者。善容长者。具足宝长者。名远闻长者。香辟疫长者。安吉长者。施宝盈长者。欣赞长者。胎施殷长者。供异道长者。勇降怨长者。宝珥长者。宝结长者。清信女名曰生偻。名曰黑哲。名曰信法。名曰软善。名曰乐凉。名曰忍苦乐。名曰乐爱优婆夷。如此之人皆一种类。消尽诸垢勇净者也。无数之众悉共大会。于时佛坐思念正道。面有九色光。数千百变光甚大明。贤者阿难即从座起。更正衣服稽首佛足。长跪叉手。前白佛言。今佛面目光色。何以时时更变明乃尔乎。今佛面目光精数百千色。上下明彻好乃如是。我侍佛已来未曾见佛身体光曜巍巍重明乃尔。我未曾见至真等正觉光明威神有如今日明好不妄。会当念诸过去当来若他方佛国今现在佛

佛告阿难。有诸天来教汝。诸佛教汝令问我耶。若自从智出乎。阿难白佛言。亦无诸天无诸佛教。我今问佛者。自从意出来白佛耳。每佛坐起若行出入。有所至到。所当作为。所当教敕。我辄知佛意。今佛独当展转相思。故使面色光明乃如此耳。佛言。善哉阿难。若所问者。甚深快善多所度脱。若问佛者。胜于供养一天下阿罗汉辟支佛。布施诸天人民。及蜎飞蠕动之类累劫。百千万亿倍矣。佛言阿难。今诸天帝王人民。及蜎飞蠕动之类。汝皆度脱之。佛言。佛威神甚重难当。若所问者大深。汝乃慈心。于佛所哀。诸天人民。若比丘比丘尼优婆塞优婆夷大善。当尔尔。皆过度之。佛语阿难。如世间有优昙钵树。但有实无有华。天下有佛。乃有华出耳。世间有佛甚难得值。今我作佛出于天下。若有大德聪明善心。豫知佛意。若不忘在佛边侍佛也。若今所问善听谛听。佛语阿难。前已过去劫。大众多不可计。无边幅不可议。及尔时有过去佛。名定光如来。复次有佛。名曰曜光。复次有佛。名日月香。复次有佛。名安明山。复次有佛。名日月面。复次有佛。名无尘垢。复次有佛。名无沾污。复次有佛。名曰如龙无所不伏。复次有佛。名曰日光。复次有佛。名大音王。复次有佛。名宝洁明。复次有佛。名曰金藏。复次有佛。名焰宝光。复次有佛。名曰有举地。复次有佛。名曰琉璃光。复次有佛。名日月光。复次有佛。名曰日音声。复次有佛。名光明华。复次有佛。名神通游持意如海。复次有佛。名嗟叹光。复次有佛。名具足宝洁。复次有佛。名光开化。复次有佛。名曰大香闻。复次有佛。名曰降弃恚嫉。复次有佛。名妙琉璃紫磨金焰。复次有佛。名心持道华无能过者。复次有佛。名积众华。复次有佛。名水月光。复次有佛。名除众冥。复次有佛。名日光盖。复次有佛。名温和如来。复次有佛。名曰法意。复次有佛。名师子威象王步。复次有佛。名曰世豪。复次有佛。名曰净音。复次有佛。名不可胜。复次有佛。名楼夷亘罗。在中教授四十二劫。皆已过去。乃尔劫时作佛。天上天下人中之雄。经道法中勇猛之将。佛为诸天及世人民。说经讲道莫能过者。世饶王闻经道欢喜开解。便弃国位行作比丘。名昙摩迦留。发菩萨意。为人高才。智慧勇猛。无能踰者。与世绝异。到世饶王佛所。稽首为礼。长跪叉手。称赞佛言

  无量之光曜　　威神无有极
  如是之焰明　　无能与等者
  若以日摩尼　　火月水之形
  其景不可及　　其色亦难比
  颜色难称量　　一切世之最
  如是大音声　　遍诸无数刹
  或以三昧定　　精进及智慧
  威德无有辈　　殊胜亦希有
  深微谛善念　　从是得佛法
  持觉若如海　　其限无有底
  嗔恚及愚痴　　世尊之所无
  嗟叹佛世雄　　终始无厌足
  佛如好花树　　莫不爱乐者
  处处人民见　　一切皆欢喜
  令我作佛时　　愿使如法王
  过度于生死　　无不解脱者
  檀施调伏意　　戒忍及精进
  如是三昧定　　智慧为上最
  吾誓得佛者　　普逮得此事
  一切诸恐惧　　我为获大安
  假令有百千　　亿万那术佛
  如是佛之数　　使如恒水沙
  计以沙等佛　　一切皆供养
  不如求正道　　坚勇而不怯
  譬如恒水中　　流沙之世界
  复倍不可计　　无数之刹土
  光焰一切昭　　遍此诸数国
  如是精进力　　威神难可量
  令我为世雄　　国土最第一
  其众殊妙好　　道场踰诸刹
  国如泥洹界　　而无有等双
  我当常愍哀　　度脱一切人
  十方往生者　　其心悦清净
  已来到我国　　快乐喜安隐
  幸佛见信明　　是我第一证
  发愿在于彼　　精进力所欲
  十方诸世尊　　皆有无碍慧
  常念此尊雄　　知我心所行
  令我身止住　　于诸苦毒中
  我行精进力　　忍之终不悔

法宝藏比丘。说此唱赞世饶王如来至真等正觉已。发意欲求无上正真道最正觉。我立是愿。如多陀竭佛所有者。愿悉得之。拔人勤苦生死根本。悉令如佛。唯为说经。所可施行。令疾得决。我作佛时。令无及者。愿佛为我说诸佛国功德。我当奉持。当那中住。取愿作佛国亦如是。佛语阿难。其世饶王佛。知其高明所愿快善。即为法宝藏菩萨说经言。譬如大海水。一人升量之。一劫不止。尚可枯尽。令海空竭得其底泥。人至心求道。何而当不可得乎。求索精进不休止者。会得心中所欲愿耳

法宝藏菩萨。闻世饶王佛说经如是。则大欢喜踊跃。其佛则为选择二百一十亿佛国中诸天人民善恶国土之好丑。为选心中所愿用与之。世饶王佛说经竟。法宝藏菩萨便壹其心。则得天眼彻视。悉自见二百一十亿诸佛国中诸天人民之善恶国土之好丑。则选心所欲愿。便结得是二十四愿经。则奉行之。精进勇猛勤苦求索。如是无央数劫。所师事供养诸佛已。过去佛亦无央数。其法宝藏菩萨。至其然后。自致得作佛。名无量清净觉最尊。智慧勇猛光明无比。今现在所居国甚快善。在他方异佛国教授八方上下无央数诸天人民。及蜎飞蠕动之类。莫不得过度解脱忧苦者。无量清净佛为菩萨时。常奉行是二十四愿。珍宝爱重保持恭顺。精进禅行之。与众超绝卓然有异。皆无有能及者。佛言。何等为二十四愿者

一我作佛时。令我国中无有地狱禽兽饿鬼蜎飞蠕动之类。得是愿乃作佛。不得从是愿终不作佛

二我作佛时。令我国中人民有来生我国者。从我国去。不复更地狱饿鬼禽兽蠕动。有生其中者我不作佛

三我作佛时。人民有来生我国者。不一色类金色者。我不作佛

四我作佛时。人民有来生我国者。天人世间人有异者。我不作佛

五我作佛时。人民有来生我国者。皆自推所从来生本末所从来十亿劫宿命。不悉知念所从来生。我不作佛

六我作佛时。人民有来生我国者。不悉彻视。我不作佛

七我作佛时。人民有来生我国者。不悉知他人心中所念者。我不作佛

八我作佛时。我国中人民不悉飞者。我不作佛

九我作佛时。我国中人民不悉彻听者。我不作佛

十我作佛时。我国中人民有爱欲者。我不作佛

十一我作佛时。我国中人民住止尽般泥洹。不尔者我不作佛

十二我作佛时。我国诸弟子。令八方上下各千亿佛国中。诸天人民蠕动之类。作缘一觉大弟子。皆禅一心。共数我国中诸弟子。住至百亿劫无能数者。不尔者我不作佛

十三我作佛时。令我光明胜于日月。诸佛之明百亿万倍。昭无数天下窈冥之处皆常大明。诸天人民蠕动之类。见我光明。莫不慈心作善来生我国。不尔者我不作佛

十四我作佛时。令八方上下无数佛国诸天人民蠕动之类。令得缘一觉果证弟子坐禅一心。欲共计知我年寿几千万亿劫。令无能知寿涯底者。不尔者我不作佛

十五我作佛时。人民有来生我国者。除我国中人民所愿。余人民寿命无有能计者。不尔者我不作佛

十六我作佛时。国中人民皆使莫有恶心。不尔者我不作佛

十七我作佛时。令我名闻八方上下无数佛国。诸佛各于弟子众中。叹我功德国土之善。诸天人民蠕动之类闻我名字。皆悉踊跃来生我国。不尔者我不作佛

十八我作佛时。诸佛国人民有作菩萨道者。常念我净洁心。寿终时我与不可计比丘众。飞行迎之共在前立。即还生我国作阿惟越致。不尔者我不作佛

十九我作佛时。他方佛国人民。前世为恶。闻我名字及正为道。欲来生我国。寿终皆令不复更三恶道。则生我国在心所愿。不尔者我不作佛

二十我作佛时。我国诸菩萨不一生等。置是余愿功德。不尔者我不作佛

二十一我作佛时。我国诸菩萨。不悉三十二相者。我不作佛

二十二我作佛时。我国诸菩萨。欲共供养八方上下无数诸佛。皆令飞行。欲得万种自然之物。则皆在前。持用供养诸佛。悉遍已后日未中则还我国。不尔者我不作佛

二十三我作佛时。我国诸菩萨欲饭时。则七宝钵中。生自然百味饮食在前。食已钵皆自然去。不尔者我不作佛

二十四我作佛时。我国诸菩萨说经行道不如佛者。我不作佛。佛告阿难。无量清净佛为菩萨时。常奉行是二十四愿。分檀布施不犯道禁。忍辱精进一心智慧。志愿常勇猛。不毁经法。求索不懈。每独弃国捐王。绝去财色。精明求愿无所适莫。积功累德无央数劫。自致作佛悉皆得之。不忘其功也。佛言。无量清净佛光明最尊第一无比。诸佛光明皆所不及也。八方上下无央数诸佛中。有佛项中光明照七丈。中有佛项中光照一里。中有佛项中光明照五里。中有佛项中光明照二十里。中有佛项中光明照四十里。中有佛项中光明照八十里。中有佛项中光明照百六十里。中有佛项中光明照三百二十里。中有佛项中光明照六百四十里。中有佛项中光明照千三百里。中有佛项中光明照二千六百里。中有佛项中光明照五千二百里。中有佛项中光明照万四百里。中有佛项中光明照二万一千里。中有佛项中光明照四万二千里。中有佛项中光明照八万四千里。中有佛项中光明照十七万里。中有佛项中光明照三十五万里。中有佛项中光明照七十万里。中有佛项中光明照百五十万里。中有佛项中光明照三百万里。中有佛项中光明照六百万里。中有佛项中光明照千二百万里。中有佛项中光明照一佛国。中有佛项中光明照两佛国。中有佛项中光明照四佛国。中有佛项中光明照八佛国。中有佛项中光明照十五佛国。中有佛项中光明照三十佛国。中有佛项中光明照六十佛国。中有佛项中光明照百二十佛国。中有佛项中光明照五百佛国。中有佛项中光明照千佛国。中有佛项中光明照二千佛国。中有佛项中光明照四千佛国。中有佛项中光明照八千佛国。中有佛项中光明照万六千佛国。中有佛项中光明照三万二千佛国。中有佛项中光明照六万四千佛国。中有佛项中光明照十三万佛国。中有佛项中光明照二十六万佛国。中有佛项中光明照五十万佛国。中有佛项中光明照百万佛国。中有佛项中光明照二百万佛国。佛言。八方上下无央数诸佛。其项中光明所照。皆如是也。无量清净佛项中光明。焰照千万佛国。所以诸佛光明所照有远近者何。本前世宿命。求道为菩萨时。所愿功德。各自有大小。至其然后作佛时。悉各自得之。是故令光明转不同等。诸佛威神同等耳。自在意所欲作为不豫计。无量清净佛光明。所照最大。诸佛光明。皆所不能及也

佛称誉无量清净佛光明。无量清净佛光明极善。善中明好甚快无比。绝殊无极也。无量清净佛光明殊好。胜于日月之明。百亿万倍也。无量清净佛光明。诸佛光明中之极明也。无量清净佛光明。诸佛光明中之极好也。无量清净佛光明。诸佛光明中之极雄杰也。无量清净佛光明。诸佛光明中之快善也。无量清净佛光明。诸佛光明中之王也。无量清净佛光明。诸佛光明中之最极尊也。无量清净佛光明。诸佛光明中之寿明无极。无量清净佛光明。焰照诸无央数天下幽冥之处皆常明。诸有人民蜎飞蠕动之类。莫不见无量清净佛光明。见无量清净佛光明。莫不慈心欢喜者。世间诸有淫侄嗔怒愚痴。见无量清净佛光明。莫不作善者。诸泥犁禽兽薛荔。考掠勤苦之处。见无量清净佛光明至。皆休止不得复治。死后莫不得解脱忧苦者也。无量清净佛光明名闻八方上下无穷无极无央数佛国。诸天人民莫不闻知。闻知者莫不得过度者。佛言。我不独称誉无量清净佛光明也。八方上下无央数诸佛。辟支佛菩萨阿罗汉。所称誉皆如是佛言。其有人民善男子善女人。闻无量清净佛声。称誉光明。如是朝暮。常称誉其光明明好。至心不断绝。在心所欲愿往生无量清净佛国。可得为诸菩萨阿罗汉所尊敬。智慧勇猛。若其然后作佛者。亦当复为八方上下无央数辟支佛菩萨阿罗汉。所称誉光明。亦当复如是。则众比丘僧诸菩萨阿罗汉。诸天帝王人民。闻之皆欢喜踊跃。莫不赞叹者。佛言。我道无量清净佛光明姝好巍巍称誉快善。昼夜一劫尚未竟也。我但为若曹小说之耳。佛说无量清净。为菩萨求索。得是二十四愿。时阿阇世王太子。与五百大长者迦罗越子。各持一金华盖。前上佛已。悉却坐一面听经阿阇世王太子。及五百长者子。闻无量清净佛二十四愿。皆大欢喜踊跃。心中俱愿言。令我等后作佛时。皆如无量清净佛。佛则知之。告诸比丘僧。是阿阇世王太子。及五百长者子。却后无央数劫。皆当作佛如无量清净佛。佛言。是阿阇世王太子。五百长者子。作菩萨道已来。无央数劫。皆各供养四百亿佛已。今复来供养我。是阿阇世王太子。及五百人等。皆前世迦叶佛时。为我作弟子。今皆复会是共相值也。则诸比丘僧。闻佛言皆心踊跃。莫不欢喜者。佛告阿难。无量清净佛作佛已来。凡十八劫。所居国名须摩提。正在西方。去是阎浮利地界。千亿万须弥山佛国。其国地皆自然七宝。其一宝者名白银。二宝者名黄金。三宝者水精。四宝者琉璃。五宝者珊瑚。六宝者虎珀。七宝者车磲。是七宝皆以自共为地旷荡甚大无极。皆自相参转相入中。各自焜煌参光极明。自然软甚姝好无比。如其七宝地。诸八方上下众宝中精。都自然之合会共化生耳。其宝比如第六天上之七宝也。其国中无有须弥山。其日月星辰。第一四天王。第二忉利天。皆在虚空中。其国土无有大海水。亦无小海水。无江河洹水也。亦无山林溪谷。无有幽冥之处。其国七宝地皆平正。无有泥犁禽兽饿鬼。蜎飞蠕动之类也。无阿须伦诸龙鬼神也。终无有大雨时。亦无春夏秋冬也。亦无有大寒。亦不大热。常和调中适甚快善无比。皆有万种自然之物。百味饮食。意欲有所得。则自然在前。意不用者。则自然化去。比如第六天上自然之物。恣若自然则皆随意。其国中悉诸菩萨阿罗汉。无有妇女。寿命极寿。寿亦无央数劫。女人往生者。则化生皆作男子。但有菩萨阿罗汉无央数。悉皆洞视彻听。悉遥相见。遥相瞻望。遥相闻语声。悉皆求道善者。同一种类无有异人也。其诸菩萨阿罗汉。面目皆端正。清洁绝好。悉同一色。无有偏丑恶者。诸菩萨阿罗汉。皆才猛黠慧。其所衣服。皆衣自然之衣。都心中所念。常念道德。其所欲语言。便皆豫相知意。其所念言道。常说五事。其国中诸菩萨阿罗汉。自共相与语言。辄说经道。终不说他余之恶。其语言音响。如三百钟声。皆相敬爱。无有相憎者。皆自以长幼上下。先后言之。都共往会以义而礼。转相敬事如兄如弟。以仁履义。不妄动作。言语而诚。转相教令。不相违戾。转相承受。皆心洁净无所贪慕。终无有淫劮嗔怒之心愚痴之态也。无有邪心念妇女意也。悉智慧勇猛。和心欢乐。好喜经道皆自知其前世所从来生。亿万劫世时宿命善恶存亡。现在却知无极。无量清净佛所可教授讲堂精舍。皆复自然七宝。金银水精琉璃白玉虎珀车磲。自共转相成也。甚姝明好绝姝无比。亦无有作者。亦不知所从来。亦无有持来者。亦无所从去。无量清净佛所愿德重。其人作善故。论经语义。说经行道。讲会其中。自然化生耳。其讲堂精舍。皆复有七宝楼观栏楯。复以金银水精琉璃白玉虎珀车磲为璎珞。复以白珠明月珠摩尼珠为交络。覆盖其上。皆自作五音声音声甚姝无比。无量清净佛国。诸菩萨阿罗汉所居舍宅。皆复以七宝金银水精琉璃珊瑚虎珀车磲马瑙。化生转共相成也。其舍宅皆悉各有七宝楼观栏楯。复以金银水精琉璃白玉虎珀车磲为璎珞。复以白珠明月珠摩尼珠为交络。覆盖其上。皆各复自作五音声。无量清净佛讲堂精舍。及诸菩萨阿罗汉所居。七宝舍宅中外内处处。皆复自然流泉水浴池。其浴池者。皆复以自然七宝。七宝俱生金银水精琉璃珊瑚虎珀车磲。转共相成也。水底沙皆复以七宝金银水精琉璃珊瑚虎珀事磲也。有纯白银池者。其底沙皆黄金也。中有纯黄金池者。其水底沙皆白银也。中有纯水精池者。其水底沙皆琉璃也。中有纯琉璃池者。其水底沙皆水精也。中有纯珊瑚池者。其水底沙皆虎珀也。中有纯虎珀池者。其水底沙皆珊瑚也。中有纯车磲池者。其水底沙皆马瑙也。中有纯马瑙池者。其水底沙者皆车磲也。中有纯白玉池者。其水底沙者皆紫磨金也。中有纯紫磨金池者。其水底沙者皆白玉也。中复有二宝共作一池者。其水底沙者皆金银也。中复有三宝共作一池者。其水底沙者皆金银水精也。中复有四宝共作一池者。其水底沙金银水精琉璃也。中复有五宝共作一池者。其水底沙皆金银水精琉璃珊瑚虎珀也。中复有六宝共作一池者。其水底沙皆金银水精琉璃珊瑚虎珀车磲也。中复有七宝共作一池者。其水底沙皆金银水精琉璃珊瑚虎珀车磲马瑙也。其浴池中有长四十里者。中有池长八十里者。中有池长百六十里者。中有池长三百二十里者。中有池长六百四十里者。中有池长千二百八十里者。中有浴池长二千五百六十里者。中有浴池长五千一百二十里者。中有浴池长万二百四十里者。中有浴池长二万四百八十里者。其纵广各适等。是浴池者。皆诸菩萨阿罗汉常所可浴池。佛言。无量清净佛浴池。长四万八千里。广亦四万八千里。其浴池皆七宝转自共相成。其池水底沙。皆复以七宝白珠明月珠摩尼珠也。无量清净佛。及诸菩萨阿罗汉浴池中水。皆清净香洁。中皆有香华。悉自然生百种华。种种异色异香。华皆千叶。诸华甚香无比。香不可言也。其华香者。亦复非世间之华。复胜天上之华。是华香者。八方上下众华香中精。自然生耳。池中水流行。转相灌注。池中水流亦不迟亦不駃。皆复自作五音声。佛言。八方上下。无央数佛国。诸天人民。及蜎飞蠕动之类。诸生无量清净佛国者。都皆于是七宝水池莲华中化生。便则自然长大。亦无乳养之者。皆食自然之饮食。其身体者。亦非世间人之身体也。亦非天上人之身体也。皆积众善之德。悉受自然虚无之身体。甚姝好无比。佛语阿难。如世间贫穷乞丐人。令在帝王边住者。其人面目形貌。何等类乎。宁类帝王面目形貌颜色不。阿难言。假令使子在帝王边住者。其面目形状甚丑恶不好。不如帝王面目形类姝好。百千亿万倍也。所以者何。见乞人贫穷困极。饮食未曾有美食时也。既恶食不能得饱食。食栽支命。骨节相撑拄。无所用自给。常乏无有储。饥饿寒冻怔忪愁苦。但坐其前世宿命为人时。愚痴无智富益悭。有财不肯慈哀。仁贤为善博爱施与。但欲唐得。贪惜饮食独食嗜美。不信施贷后得偿报也。复不信作善后世得其福。蒙笼项佷益作众恶。如是寿终财物尽索。素无恩德无所恃怙。入恶道中坐之适苦。然后得出解脱。今生为人。作于下贱贫家作子。强像人形。状貌甚丑。衣被弊坏。单空独立。不蔽形体。乞丐生活耳。饥寒因苦。面目羸劣。不类人色。坐其前世身之所作。受其殃罚。示众见之莫谁哀者。弃捐市道暴露痟瘦。黑丑恶极不及人耳。所以帝王人中独尊最好者何。皆其前世宿命为人时作善。信爱经道。布施恩德。博爱顺义。慈仁喜与。不贪饮食。与众共之。无所遗惜都无违诤。得其福德寿终德随不更恶道。今生为人得生王家自然尊贵。独王典主揽制人民为人雄杰。面目洁白和颜好色。身体端正众共敬事。美食好衣随心恣意。在乐所欲自然在前都无违诤。于人中姝好。无忧快乐面色光泽。故乃尔耳

佛说无量清净平等觉经卷第一佛说无量清净平等觉经卷第二

        后汉月支国三藏支娄迦谶译

佛告阿难若言是也。如帝王虽于人中好无比当令在遮迦越王边住者。其面目形貌甚丑恶其状不好。比如乞人在帝王边住耳。帝王面丑。尚复不如遮迦越王面色姝好。百千亿万倍也。如遮迦越王。于天下绝好无比。当令在第二忉利天帝释边住者。其面甚丑不好。尚复不如天帝释面貌端正姝好。百千亿万倍也。如天帝释。令在第六天王边住者。其面貌甚丑不好。尚复不如第六天王面貌端正姝好。百千亿倍也。如第六天王。令在无量清净佛国中。诸菩萨阿罗汉边住者。其面甚丑。尚复不如无量清净佛国中。诸菩萨阿罗汉面貌端正姝好。百千亿万倍也

佛言。无量清净佛诸菩萨阿罗汉面貌。悉皆端正绝好无比。次于泥洹之道也。佛告阿难。无量清净佛。及诸菩萨阿罗汉。讲堂精舍所居处舍宅。中外浴池上。皆有七宝树。中有纯银树。中有纯金树。中有纯水精树。中有纯琉璃树。中有纯白玉树。中有纯珊瑚树。中有纯虎珀树。中有纯车磲树。种种各自异行。中复有两宝共作一树者。银树银根金茎银枝金叶银华金实。金树者。金根银茎金枝银叶金华银实。是两宝树转共相成。各自异行。中复有三宝共作一树者。银树。银根金茎。水精枝银叶。金华水精实。金树者。金根银茎。水精枝金叶。银华水精实。水精树者。水精根银茎。金枝水精叶。银华金实。是三宝树转共相成。各自异行中。复有四宝共作一树者。银树。银根金茎。水精枝琉璃叶。银华金实。金树者。金根银茎。水精枝琉璃叶金华银实。水精树者。水精根琉璃茎。银枝金叶。水精华琉璃实。琉璃树者。琉璃根水精茎。金枝银叶。琉璃华水精实。是四宝树转共相成。各自异行中。复有五宝共作一树者。银树。银根金茎。水精枝琉璃叶。珊瑚华金实。金树者。金根银茎。水精枝琉璃叶。珊瑚华银实。水精树者。水精根琉璃茎。珊瑚枝银叶。金华琉璃实。琉璃树者。琉璃根珊瑚茎。水精枝金叶。银华珊瑚实。珊瑚树者。珊瑚根琉璃茎水精枝金叶。银华琉璃实。是五宝树转共相成。各自异行中。复有六宝共作一树者。银树。银根金茎。水精枝琉璃叶珊瑚华虎珀实。金树者。金根银茎。水精枝琉璃叶。虎珀华珊瑚实。水精树者。水精根琉璃茎。珊瑚枝银叶。虎珀华金实。琉璃树者。琉璃根珊瑚茎。虎珀枝水精叶。金华银实。珊瑚树者。珊瑚根虎珀茎。银枝金叶。水精华琉璃实。虎珀树者。虎珀根珊瑚茎。金枝银叶。琉璃华水精实。是六宝树转共相成。各自异行中。复有七宝共作一树者。银树。银根金茎。水精节琉璃枝珊瑚叶。虎珀华车磲实。金树者。金根水精茎。琉璃节珊瑚枝虎珀叶。车磲华银实。水精树者。水精根琉璃茎。珊瑚节虎珀枝车磲叶。白玉华金实。琉璃树者。琉璃根珊瑚茎。虎珀节白玉枝车磲叶。水精华银实。珊瑚树者。珊瑚根虎珀茎。白玉节银枝明月珠叶。金华水精实。虎珀树者。虎珀根白玉茎。珊瑚节琉璃枝车磲叶。水精华金实。白玉树者。白玉根车磲茎。琉璃节珊瑚枝虎珀叶。金华摩尼珠实。是七宝树转共相成。种种各自异行。行行自相值。茎茎自相准。枝枝自相值。叶叶自相向。华华自相望。极自软好。实实自相当。佛言。无量清净佛。讲堂精舍中。外内七宝浴池绕边。上诸七宝树。及诸菩萨阿罗汉。七宝舍宅中。外七宝浴池绕。池边七宝树。数千百重行。皆各各如是行行。自作五音。声甚好无比。佛语阿难。如世间帝王。万种伎乐音声。不如遮迦越王。诸伎乐一音声好。百千亿万倍也。如遮迦越王。万种伎乐音声。尚复不如第二忉利天上。诸伎乐一音声好。百千亿万倍也。如忉利天上。万种伎乐之声。尚复不如第六天上。诸伎乐一音声好。百千亿万倍也。如第六天上。万种音乐之声。尚复不如无量清净佛国中。七宝树一音声好。百千亿万倍也。无量清净佛国。亦有万种自然之伎乐无极也。无量清净佛。及诸菩萨阿罗汉欲浴时。便各自入其七宝池中浴。诸菩萨阿罗汉意欲令水没足。水则没足。意欲令水至膝。水则至膝。意欲令水至腰。水则至腰。意欲令水至腋。水则至腋。意欲令水至颈。水则至颈。意欲令水自灌身上。水则灌身上。意欲令水转复还如故。水则转还复如故。恣若随意所欲好喜。佛言。无量清净佛。及诸菩萨阿罗汉皆浴已。悉自于一莲华上坐。则四方自然乱风起。其乱风者。亦非世间之风也。亦复非天上之风也。是乱风者。都为八方上下众风中之自然。都相合会共化生耳。其乱风亦不大寒。亦不大温。常和调中适其凉好无比。乱风徐起。亦不迟亦不疾。适得中宜。吹国中七宝树。七宝树皆复自作五音声。乱风吹华。悉覆盖其国中。华皆自散无量清净佛。及诸菩萨阿罗汉上。华适堕地。华皆厚四寸。极自软好无比。华小萎。则自然乱风吹萎华。悉自然去。则复四方。复自然乱风起。吹七宝树。七宝树。皆复自作五音声。乱风吹华。悉复自然散无量清净佛。及诸菩萨阿罗汉上。华堕地则自然乱风。复吹萎华。悉自然去。则复四方自然乱风起。吹七宝树华。如是者四反。诸菩萨阿罗汉中。有但欲闻经者。中有但欲闻音乐声者。中有但欲闻华香者。中有不欲闻经者。中有不欲闻五音者。中有不欲闻华香者。其所欲闻者。辄则独闻之。其所不欲闻者。了独不闻也。则皆自然随意在所欲喜乐。不违其心中所欲愿也。无量清净佛。及诸菩萨阿罗汉。皆浴讫已各自去。其诸菩萨阿罗汉。各自行道。中有在地讲经者。中有在地诵经者。中有在地说经者。中有在地口受经者。中有在地听经者。中有在地念经者。中有在地思道者。中有在地坐禅一心者。中有在地经行者。中有在虚空中讲经者。中有在虚空中诵经者。中有在虚空中说经者。中有在虚空中口受经者。中有在虚空中听经者。中有在虚空中念经者。中有在虚空中思念道者。中有在虚空中坐禅一心者。中有在虚空中经行者。中有未得须陀洹道者。则得须陀洹道。中有未得斯陀含道者。则得斯陀含道。中有未得阿那含道者。则得阿那含道。中有未得阿罗汉道者。则得阿罗汉道。中有未得阿惟越致菩萨者。则得阿惟越致菩萨。菩萨阿罗汉各自说经行道。皆悉得道。莫不欢喜踊跃者。诸菩萨中。有意欲供养八方上下无央数诸佛。即皆俱前。为无量清净佛作礼。却长跪叉手白佛辞行。欲供养八方上下诸无央数佛。无量清净佛则然可之。则使其行供养诸菩萨等。皆大欢喜。数千亿万人。无央数不可复计。皆智慧勇猛。各自翻飞等辈相追俱共散飞则行即到八方上下无央数诸佛所。皆前为佛作礼便则供养诸佛。其诸菩萨。意欲得万种自然之物在前。则自然百杂色华百种。自然杂缯幡彩百种物。自然劫波育衣。自然七宝。自然灯火。自然万种伎乐。悉皆在前。其华香万种自然之物者。亦非世间之物也。亦复非天上之物也。是万种之物。都为八方上下众物。自然共合会化生耳。意欲得者。则自然化生在前。意不用者。便则自化去。诸菩萨便共持供养诸佛及诸菩萨阿罗汉上。边傍前后徊绕周匝。自在意所欲得。则辄皆至。当尔之时。快乐不可言也。诸菩萨意。各欲得四十里华。则自然四十里华在前。诸菩萨皆于虚空中共持华。则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华甚香好。华适小萎便自堕地。则自然乱风吹。萎华悉自然去。诸菩萨意。各复欲得八十里华。则自然八十里华在前。诸菩萨皆复于虚空中。共持华散诸菩萨阿罗汉上。华皆复在虚空中下向。华小萎便自堕地。则自然乱风吹萎华去。诸菩萨意。各复欲得百六十里华。则自然百六十里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆复于虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得三百二十里华则自然三百二十里华在前。诸菩萨皆复于虚空共持华则散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得六百四十里华。则自然六百四十里华在前。诸菩萨皆复于虚空中。共持华散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹华悉自然去。诸菩萨意各复欲得千二百八十里华。则自然千二百八十里华在前。诸菩萨皆复于虚空中。共持华散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得二千五百六十里华。则自然二千五百六十里华在前。诸菩萨皆复于虚空中。共持华散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得五千一百二十里华。则自然五千一百二十里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得万二百四十里华。则自然万二百四十里华在前。诸菩萨皆复于虚空中。共持华散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。则自然乱风吹。华则自然去。诸菩萨意。各复欲得二万四百八十里华。则自然二万四百八十里华在前。诸菩萨皆复于虚空中。持华散诸佛及诸菩萨阿罗汉上。华皆复在虚空中下向。华适小萎便自堕地。自然乱风吹。华悉自然去。诸菩萨意。各复欲得五万里华。则自然五万里华在前。诸菩萨皆复于虚空中。共持华散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得十万里华。则自然十万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得二十万里华。则自然二十万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得四十万里华。则自然四十万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得八十万里华。则自然八十万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华则自然去。诸菩萨意。各复欲得百六十万里华。则自然百六十万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得三百万里华。则自然三百万里华在前。诸菩萨皆复于虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华皆在虚空中下向。华适小萎便自堕地。则自然乱风吹。华悉自然去。诸菩萨意。各复欲得四百万里华。则自然四百万里华在前。诸菩萨心意。俱大欢喜踊跃。皆在虚空中。共持华则散诸佛及诸菩萨阿罗汉上。华都自然合为一华。华正团圆周匝各适等。华转倍前极自软好。转胜于前华好。数百千色。色色异香。甚香不可言。诸菩萨皆大欢喜。俱于虚空中。大共作众音自然伎乐。乐佛及诸菩萨阿罗汉。当是之时。快乐不可言。诸菩萨皆悉却坐听经。听经竟则悉皆讽诵通利。重知经道益明智慧。其诸华香。小萎便自堕地。则自然乱风吹华。悉皆自然去。则诸佛国中。从第一四天王上。至三十六天上。诸菩萨阿罗汉天人。皆复于虚空中。大共作众音伎乐。诸天人前来者。转去避后来者。后来者转复供养如前。更相开避。诸天人欢喜听经。皆大共作音乐。当是之时。快乐无极。诸菩萨供养听经讫竟。便皆起为诸佛作礼而去。则复飞到八方上下。无央数诸佛所。则复供养听经。皆各如前时悉遍。以后日未中时。诸菩萨则皆飞而去。则还其国。悉前为无量清净佛作礼。皆却坐一面听经。听经竟皆大欢喜

佛言无量清净佛。及诸菩萨阿罗汉欲食时。则自然七宝机。自然劫波育。自然罽[疊*毛]以为座。无量清净佛。及诸菩萨阿罗汉皆坐已。前悉有自然七宝钵。中皆有自然百味饮食。饮食者。亦不类世间饮食之味也。亦复非天上饮食之味也。此百味饮食者。都为八方上下众。自然之饮食中精味。甚香美无有比。都自然化生耳。其饮食自在所欲得味甜酢。钵自在所欲得。诸菩萨阿罗汉中有欲得银钵者。中有欲得金钵者。中有欲得水精钵者。中有欲得琉璃钵者。中有欲得珊瑚钵者。中有欲得虎珀钵者。中有欲得白玉钵者。中有欲得车渠钵者。中有欲得玛瑙钵者。中有欲得明月珠钵者。中有欲得摩尼珠钵者。中有欲得紫磨金钵者。皆满其中百味饮食。自恣若随意则至。亦无所从来。亦无有供作者。自然化生耳。诸菩萨阿罗汉皆食。食亦不多亦不少。悉自然平等。诸菩萨阿罗汉食。亦不言美恶。亦不以美故喜。食已诸饭具钵机坐。皆自然化去。欲食时乃复化生耳。诸菩萨阿罗汉。皆心清洁不慕饭食。但用作气力耳。皆自然消散糜尽化去

佛告阿难。阿弥陀佛。为诸菩萨阿罗汉说法时。都悉大会讲堂上。其国诸菩萨阿罗汉。及诸天人民无央数。都不可复计。皆飞到无量清净佛所。悉前为无量清净佛作礼。却坐听经。无量清净佛。便则为诸比丘僧。诸菩萨阿罗汉。诸天人民。广说道智大经。皆悉闻知经道。莫不欢喜踊跃心开解者。即四方自然乱风起。吹国中七宝树。七宝树皆复作五音声。乱风吹七宝华华覆盖其国。皆在虚空中下向。华甚香极自软好。香遍国中。华皆自散无量清净佛。及诸菩萨阿罗汉上。华堕地皆厚四寸。华适小萎。则自然乱风吹。萎华自然去。则四方俱复自然乱风起。吹七宝树。七宝树皆复自作五音声。乱风吹七宝树华。华复如前。皆自然散无量清净佛。及诸菩萨阿罗汉上。华堕地复厚四寸。华小萎。则自然乱风吹。萎华悉自然去。乱风吹华。如是四反。则第一四天王诸天人。第二忉利天上诸天人。第三天上诸天人。第四天上诸天人。第五天上诸天人。第六天上诸天人。第七梵天上诸天人。上至第十六天上诸天人。上至三十六天上诸天人。皆持天上万种自然之物。百种杂色华。百种杂香。百种杂缯彩。百种劫波育叠衣。万种伎乐。转倍好相胜。各持来下。为无量清净佛作礼。则供养无量清净佛。及诸菩萨阿罗汉。诸天人皆复大作伎乐。乐无量清净佛。及诸菩萨阿罗汉。当是之时。快乐不可言。诸天人前来者。转去避后来者。后来者转复供养如前。更相开避。则东方无央数佛国。不可复计。如恒水边流沙。一沙一佛其数如是。诸佛各遣诸菩萨无央数。不可复计。皆飞到无量清净佛所。则为无量清净佛作礼。以头面着佛足。悉却坐一面听经。听经竟。诸菩萨皆大欢喜。悉起为无量清净佛作礼而去。则西方无央数诸佛国。复如恒水边流沙。一沙一佛其数如是。诸佛各复遣诸菩萨无央数。都不可复计。皆飞到无量清净佛所。则前为无量清净佛作礼。以头面着佛足。悉却坐一面听经。听经竟。诸菩萨皆大欢喜。起为无量清净佛作礼而去。则北方无央数诸佛国。复如恒水边流沙。一沙一佛其数如是。诸佛各复遣诸菩萨无央数。都不可复计。皆飞到无量清净佛所。则前为无量清净佛作礼。以头面着佛足。悉却坐一面听经。听经竟。诸菩萨皆大欢喜。起为无量清净佛作礼而去。南方无央数诸佛国。复如恒水边流沙。一沙一佛其数如是。诸佛各复遣诸菩萨无央数。都不可复计。皆飞到无量清净佛所。则前为无量清净佛作礼而去。则复四角无央数诸佛国。各复如恒水边流沙。一沙一佛其数各如是。诸佛各复遣诸菩萨无央数。都不可复计。皆飞到无量清净佛所。前为无量清净佛作礼已。头面着佛足。悉却坐一面听经。听经竟。诸菩萨皆大欢喜。起为无量清净佛作礼而去。佛言。八方上下诸无央数佛。更遣诸菩萨。飞到无量清净佛所。听经供养。转更相开避。如是则下面。诸八方无央数佛国。一方者各复如恒水边流沙。一沙一佛其数复如是。诸佛各遣诸菩萨无央数。都不可复计。皆飞到无量清净佛所。前为阿弥陀佛作礼。以头面着佛足。悉却坐听经。听经竟。诸菩萨皆大欢喜。起为无量清净佛作礼而去。上方诸佛。更遣诸菩萨。飞到无量清净佛所。听经供养相开避。前来者则去避后来者。后来者供养亦复如是。终无休绝极时

  譬若如恒沙刹　　东方佛国如是
  各各遣诸菩萨　　稽首礼无量觉
  西南北面皆尔　　如是恒沙数土
  是诸佛遣菩萨　　稽首礼无量觉
  此十方菩萨飞　　皆以衣裓诸华
  天拘蚕种种具　　往供养无量觉
  诸菩萨皆大集　　稽首礼无际光
  绕三匝叉手住　　叹国尊无量觉
  皆持华散佛上　　心清净称无量
  于佛前住自说　　愿使我刹如此
  所散华止虚空　　合成盖百由旬
  其柄妙严饰好　　悉遍覆众会上
  诸菩萨都往至　　诸尊刹难得值
  如是人闻佛名　　快安隐得大利
  吾等类得是德　　诸此刹获所好
  计本国若如梦　　无数劫净此土
  见菩萨绕世尊　　威神猛寿无极
  国觉众甚清净　　无数劫难思议
  时无量世尊笑　　三十六亿那术
  此数光从口出　　遍昭诸无数刹
  则回光还绕佛　　三匝已从顶入
  色霍然不复现　　天亦人皆欢喜
  廅楼亘从坐起　　正衣服稽首问
  白佛言何缘笑　　唯世尊说是意
  愿授我本空莂　　慈护成百福相
  闻是诸音声者　　一切人踊跃喜
  梵之音及雷霆　　八种音深重声
  佛授廅楼亘决　　今吾说仁谛听
  众世界诸菩萨　　到须阿提礼佛
  闻欢喜广奉行　　疾得至得净处
  已到此严净国　　便速得神足俱
  眼洞视耳彻听　　亦还得知宿命
  无量觉授其决　　我前世有本愿
  一切人闻说法　　皆疾来生我国
  吾所愿皆具足　　从众国来生者
  皆悉来到此间　　一生得不退转
  若菩萨更兴愿　　欲使国如我刹
  亦念度一切人　　令各愿达十方
  速疾超便可到　　安乐国之世界
  至无量光明土　　供养于无数佛
  其奉事亿万佛　　飞变化遍诸国
  恭敬已欢喜去　　便还于须摩提
  非有是功德人　　不得闻是经名
  唯有清净戒者　　乃逮闻此正法
  曾更见世尊雄　　则得信于是事
  谦恭敬闻奉行　　便踊跃大欢喜
  恶骄慢弊懈怠　　难以信于此法
  宿世时见佛者　　乐听闻世尊教
  譬从生盲冥者　　欲得行开导人
  声闻悉或大乘　　何况于俗凡诸
  天中天相知意　　声闻不了佛行
  辟支佛亦如是　　独正觉乃知此
  使一切悉作佛　　其净慧智本空
  复过此亿万劫　　计佛智无能及
  讲议说无数劫　　尽寿命犹不知
  佛之慧无边幅　　如是行清净致
  奉我教乃信是　　唯此人能解了
  佛所说皆能受　　是则为第一证
  人之命希可得　　佛在世甚难值
  有信慧不可致　　若闻见精进求
  闻是法而不忘　　便见敬得大庆
  则我之善亲厚　　以是故发道意
  设令满世界火　　过此中得闻法
  会当作世尊将　　度一切生老死

佛语阿难。无量清净佛。为诸菩萨阿罗汉说经竟。诸天人民中。有未得须陀洹道者。则得须陀洹道。中有未得斯陀含道者。则得斯陀含道。中有未得阿那含道者。则得阿那含道。中有未得阿罗汉道者。则得阿罗汉道。中有未得阿惟越致菩萨者。则得阿惟越致菩萨。阿弥陀佛。辄随其本宿命求道时。心所喜愿大小随意。为说经辄授之。令其疾开解得道。皆悉明慧各自好喜。所愿经道莫不喜乐诵习者。则各自讽诵经道。通利无厌无极也。诸菩萨阿罗汉中有诵经者。其音如雷声。中有说经者。如疾风暴雨。时诸菩萨阿罗汉。说经行道皆各如是。尽一劫竟终无懈倦时也。皆悉智慧勇猛。身体皆轻。便终无有痛痒。极时行步坐起。皆悉才健勇猛。如师子中王。在深林中。当有所趣。向时无有敢当者。无量清净佛国。诸菩萨阿罗汉。说经行道皆勇猛。无有疑难之意。则在心所作。为不豫计。百千亿万倍。是猛师子中王也。如是猛师子中王。百千亿万倍。尚复不如我第二弟子。摩诃目揵连勇猛。百千亿万倍也。无量清净国。诸菩萨阿罗汉。皆胜我第二弟子摩诃目揵连也。佛言。如摩诃目揵连勇猛。于诸佛国诸阿罗汉中。最为无比。如摩诃目揵连。飞行进止。智慧勇猛。洞视彻听。知八方上下去来现在之事。百千亿万倍都合为一智慧勇猛。当在无量清净佛国。诸阿罗汉中者。其德尚复不如无量清净佛国。一阿罗汉智慧勇猛者。千亿万倍也。是时坐中有一菩萨。字阿逸菩萨。阿逸菩萨。则起前长跪叉手。问佛言。阿弥陀佛国中。诸阿罗汉。宁颇有般泥洹去者不。愿欲闻之。佛告阿逸菩萨。若欲知者。如是四天下星。若见之不。阿逸菩萨言。唯然皆见之。佛言。而我第二弟子。摩诃目揵连。飞行四天下。一日一夜遍数星。知有几枚也。如是四天下。星甚众多。不可得计。尚为百千亿万倍。是四天下星也。佛言。如天下大海水。减去一渧水。宁能令海水为减不。阿逸菩萨言。减大海水。百千亿万斗石。水尚复不能令海减少也。佛言。阿弥陀佛国。诸阿罗汉中。虽有般泥洹去者。如是大海。减一小水耳。不能令诸在阿罗汉为减知少也。佛言。减大海水一溪水。宁能减海水不。阿逸菩萨言。减大海百千万亿溪水。尚复不能减海水。令知减少也。佛言。阿弥陀佛国。诸阿罗汉中。有般泥曰去者。如是大海减一溪水耳。不能减诸在阿罗汉。为减知少也。佛言。而大海减一恒水。宁能减海水不。阿逸菩萨言。减大海水百千万亿恒水。尚复不能减大海水。令减知少也。佛言。阿弥陀佛国。诸阿罗汉。般泥曰去者无央数。其在者。新得阿罗汉者。亦无央数。都不为增减也。佛言。令天下诸水。都流行入大海中。宁能令海水为增多不。阿逸菩萨言。不能令海水增多也。所以者何。是大海为天下诸水众善中王也。故能尔耳。佛言。无量清净佛国亦如是。悉令八方上下无央数佛国。无央数诸天人民。蜎飞蠕动之类。都往生无量清净佛国者。其辈甚大众多。不可复计。无量清净佛国。诸菩萨阿罗汉众比丘僧。都如常一法不异为增多也。所以者何。无量清净佛国为最快。八方上下无央数诸佛国中。众菩萨中王也。无量清净佛国。为诸无央数佛国中之雄国也。无量清净佛国。为诸无央数佛国中之珍宝也。无量清净佛国。为诸无央数佛国中之极长久也。无量清净佛国。为诸无央数佛国之众杰也。无量清净佛国。为诸无央数佛国中之广大也。无量清净佛国。为诸无央数佛国中都自然之无为也。无量清净佛国。为最快明好甚乐之无极也。无量清净佛国独胜者何。本为菩萨求道时。所愿勇猛。精进不懈。累德所致。故乃尔耳。阿逸菩萨则大欢喜。长跪叉手言。佛说无量清净佛国。诸阿罗汉。般泥洹去者甚众多。无央数国土快善之极。明好最姝无比。乃独尔乎。佛言。无量清净佛国。诸菩萨阿罗汉所居。七宝舍宅中。有在虚空中居者。中有在地居者。中有意欲令舍宅最高者。舍宅则高。中有意欲令舍宅最大者。舍宅则大。中有意欲令舍宅在虚空中者。舍宅则在虚空中。皆自然随意在所作为。中有殊不能令其舍宅。随意所作为者。所以者何。中有能者。皆是前世宿命求道时。慈心精进益作诸善。德重所能致也。中有不能致者。皆是前世宿命求道时。不慈心精进。作善少德小。悉各自然得之。所衣被服饮食。俱自然平等耳。是故不同。德有大小别。知勇猛令众见耳。佛告阿逸菩萨。若见是第六天上天王所居处不耶。阿逸菩萨言唯然皆见之。佛言。无量清净佛国土。讲堂舍宅。倍复胜第六天王所居处。百千亿万倍也。无量清净佛国。其诸菩萨阿罗汉。悉皆洞视彻听。悉复见知八方上下去来现在之事。复知诸无央数。天上天下人民。及蜎飞蠕动之类。皆悉知心意所念善恶。口所欲言。皆知当何岁何劫中。得度脱得人道。当往生无量清净佛国。知当作菩萨道得阿罗汉道。皆豫知之。无量清净佛国。诸菩萨阿罗汉。其项中光明。皆悉自有光明所照大小。其诸菩萨中。有最尊两菩萨。常在无量清净佛左右座边。坐侍政论。无量清净佛。常与是两菩萨共对坐。议八方上下去来现在之事。无量清净佛。若欲使令是两菩萨。到八方上下无央数诸佛所。是两菩萨便飞行。则到八方上下无央数诸佛所。随心所欲至到何方佛所。是两菩萨。则俱飞行则到飞行駃疾如佛。勇猛无比。其一菩萨名廅楼亘。其一菩萨名摩诃那光明智慧最第一。其两菩萨项中光明。各焰照他方。千须弥山佛国常大明。其诸菩萨项中光明。各照千亿万里。诸阿罗汉项中光明。各照七丈。佛言。其世间人民。善男子善女人。若有一急恐怖遭县官事者。但自归命是廅楼亘菩萨。无所不得解脱者也

佛说无量清净平等觉经卷第二佛说无量清净平等觉经卷第三

        后汉月氏国三藏支娄迦谶译

佛告阿逸菩萨。无量清净佛项中光明极大明。其日月星辰。皆在虚空中住止。亦不复回转运行。亦无有精光。其明皆蔽不复现。无量清净佛光明照国中。及焰照他方佛国常大明。终无有当冥时也。其国中无有一日二日也。无有十五日一月也。无有五月十月也。无有五岁十岁也。无有百岁千岁也。无有万岁亿岁亿万岁十亿万岁也。无有百千亿万岁也。无有千亿亿万岁也。无有一劫十劫也。无有百劫千劫也。无有万劫十万劫也。无有千万劫也。无有百千亿万劫也。佛言。无量清净佛光明。光明无极。无量清净佛光明。却后无数劫。无数劫。重复无数劫。无数劫不可复计劫。劫无央数。终无有当冥时也。无量清净国土及诸天。终无有坏败时也。所以者何。无量清净佛。寿命极长国土甚好。故能尔耳。佛言。无量清净佛尊寿。劫后无数劫常无央。无般泥洹时也。无量清净佛。于世间教授。意欲适度八方上下。诸无央数佛国。诸天人民。及蜎飞蠕动之类。皆欲使往生其国悉令得泥洹之道。其诸有作菩萨者。皆欲令悉作佛。作已悉令转。复教授八方上下。诸天人民。及蜎飞蠕动之类。皆复欲令悉得作佛。作佛时复教授无央数。诸天人民。蠕动之类。皆令得泥洹道去。诸所可教授弟子者。展转复相教授转相度脱。至令得须陀洹斯陀含阿那含阿罗汉辟支佛道。转相度脱皆得泥洹之道悉如是。无量清净佛。常未欲般泥曰也。无量清净佛。所脱度展转如是。复住无数劫。无数劫不可复计劫。终无有般泥洹时也。八方上下。无央数诸天人民。蜎飞蠕动之类。其生无量清净佛国者。不可复胜数。诸作阿罗汉。得泥洹之道者。亦无央数。都不可复计也。无量清净佛恩德。诸所布施。八方上下无穷无极。甚深大无量。快善不可言也。无量清净佛智慧教授所出经道。布告八方上下。诸无央数。天上天下。甚多不原。其经卷数甚大众。不可复计。都无极也。佛告阿逸菩萨。若欲知无量清净佛寿命无极时不也。阿逸菩萨言。愿皆欲闻知之。佛言明听。悉令八方上下。诸无央数佛国中。诸天人民。蜎飞蠕动之类。皆使得人道。悉令作辟支佛阿罗汉。共坐禅一心。都合其智慧。为一勇猛。共欲计知无量清净佛寿命。知寿几千亿万劫岁数。皆无有能计知极无量清净佛寿者也。佛言。复令他方面各千须弥山佛国中。诸天人民。及蜎飞蠕动之类。皆复得人道。悉令作辟支佛阿罗汉。皆令坐禅一心。共合其智慧。都为一勇猛。共欲数无量清净佛国中。诸菩萨阿罗汉。计千亿万人。皆无有能数者也。佛言。无量清净佛。年寿甚长久浩浩。浩浩照明善甚深无极无底。谁当能信知其者乎。独佛自知耳。阿逸菩萨闻佛言。即大欢喜。长跪叉手言。佛说无量清净。佛寿命甚长。威神大智慧光明。巍巍快善。乃独如是乎。佛言。无量清净佛。至其然后般泥洹者。其廅楼亘菩萨。便当作佛总领道智典主教授。世间八方上下。所过度诸天人民。蜎飞蠕动之类。皆令得佛泥洹之道。其善福德。当得复如大师无量清净佛。住止无央数劫。无央数劫不可复计劫。不可复计劫。准法大师。尔乃般泥曰。其次摩诃那钵菩萨。当复作佛典主智慧都总教授。所过度福德。当复如大师无量清净佛。止住无央数劫。常复不般泥洹。展转相承。受经道甚明。国土极善。其法如是。终无有断绝。不可极也

阿难长跪叉手问佛言。佛说无量清净佛国中。无有须弥山者。其第一四天王。第二忉利天。皆依因何等住止乎。愿欲闻之。佛告阿难。若有疑意于佛所耶。八方上下无穷无极无有边幅。其诸天下大海水。一人升量之。尚可枯尽得其底。佛智亦如是。八方上下。无穷无极。无有边幅。佛言。我智慧所知见。诸已过去佛。如我名字释迦文佛者。复如恒水边流沙。一沙一佛。甫始诸来欲求作佛者。如我名字释迦文佛者。复如恒水边流沙。一沙一佛。佛正坐直南向。视见南方今现在佛。如我名字释迦文佛者。复如恒水边流沙。一沙一佛。八方上下。去来现在诸佛。如我名字释迦文佛者。各如十恒水边流沙。一沙一佛。其数如是。佛皆悉豫见知之。佛言。往昔过去无央数劫已来。一劫十劫。百劫千劫。万劫亿劫。万亿劫亿万劫。劫中有佛。诸已过去佛。一佛十佛。百佛千佛。万佛亿佛。亿万佛中有佛佛。各各自有名字。名字不相同类。无有如我名字者。甫始当来劫。诸当来佛。一劫十劫。百劫千劫。万劫亿劫。万亿劫亿万劫。劫中有一佛十佛。百佛千佛。万佛万亿佛。亿万佛中有佛。佛各自有名字。名字各异。不同诸佛名字。时乃有一佛。如我名字释迦文佛耳。诸八方上下。无央数佛国。今现在佛。次他方异佛国。一佛国十佛国。百佛国千佛国。万佛国亿佛国。万亿佛国亿万佛国。佛国中有佛。各各自有名字。名字各异多多。复不可同。无有如我名字者。八方上下。无央数诸佛中。时时乃有如我名字释迦文佛耳。八方上下去来现在。其中间旷绝甚远悠悠。无穷无极。佛智亘然甚明。采古知今。前知无穷却睹未然。豫知无极。都不可复计。甚无央数佛。威神尊明。皆悉知之。佛智慧道德合明。都无有能问佛经道穷极者。佛智慧终不可斗量尽也。阿难闻佛言。则大恐怖衣毛皆起。阿难白佛言。我不敢有疑意于佛所也。所以问佛者。他方佛国皆有须弥山。其第一四王天。第二忉利天。皆依因之住止。我恐佛般泥曰后。傥有诸天人民。若比丘僧比丘尼优婆塞优婆夷。来问我无量清净佛国。何以独无须弥山。其第一四王天。第二忉利天。皆依因何等住止乎。我等应答之。今我不问佛者。佛去后。我当持何等语答报之乎。独佛自知之耳。其余人无有能为解之者。以是故问佛耳。佛言阿难。若言是也。第三焰天。第四兜率天。上至第七梵天。皆依因何等住止乎。阿难言。是诸天皆自然在虚空中住止。无所依因也。佛言。无量清净佛国。无有须弥山者亦如是。第一四王天。第二忉利天。皆自然在虚空中住止。无所依因也。佛言。佛威神甚重自在所欲作为。意欲有所作不豫计也。是诸天皆常自然在虚空中住止。何况佛威神尊重。自在所欲作为乎。阿难闻佛言。则大欢喜。长跪叉手言。佛智慧知八方上下去来现在之事。无穷无极无有边幅。甚高大妙绝。快善极明好甚无比。威神尊重不可当也。佛告阿逸菩萨。其世间人民。若善男子善女人。欲愿往生无量清净佛国者有三辈。作功德有大小转不能相及。佛言。何等为三辈。其最上第一辈者。当去家舍妻子断爱欲。行作沙门就无为道。当作菩萨道。奉行六波罗蜜经者。作沙门。不当亏失经戒。慈心精进。不当嗔怒。不当与女人交通。斋戒清净心无所贪慕。至精愿欲生无量清净佛国。当念至心不断绝者。其人便今世求道时。则自于其卧睡中。梦见无量清净佛。及诸菩萨阿罗汉。其人寿命欲终时。无量清净佛。则自与诸菩萨阿罗汉。共翻飞行迎之。则往生无量清净佛国。便于七宝水池莲华中化生。则自然受身长大。则作阿惟越致菩萨。便则与诸菩萨。共番辈飞行。供养八方上下。诸无央数佛。则智慧勇猛。乐听经道其心欢乐。所居七宝舍宅。在虚空中。恣随其意在所欲作为。去无量清净佛近。佛言诸欲往生无量清净佛国者。精进持经戒。奉行如是上法者。往生无量清净佛国者。可得为众所尊敬。是为上第一辈。佛言。其中辈者。其人愿欲往生无量清净佛国。虽不能去家舍妻子断爱欲行作沙门者。当持经戒无得亏失。益作分檀布施。常信受佛语深当作至诚忠信。饭食沙门。而作佛寺起塔。烧香散华然灯。悬杂缯彩。如是法者。无所适贪。不当嗔怒。斋戒清净慈心精进断欲念。欲往生无量清净佛国。一日一夜不断绝者。其人于今世。亦复于卧睡梦中。见无量清净佛。其人寿欲尽时。无量清净佛。则化令其人自见无量清净佛及国土。往生无量清净佛国者。可得智慧勇猛。佛言。其人奉行施与。如是者。若其然后中复悔。心中狐疑。不信分檀布施作诸善后世得其福。不信有无量清净佛国。不信往生其国中。虽尔其人续念不绝。暂信暂不信。意志犹豫无所专据。续结其善。愿名本续得往生其人寿命病欲终时。无量清净佛。则自化作形像。令其人目自见之。口不能复言。便心中欢喜踊跃。意念言。我悔不知益斋作善。今当生无量清净佛国。其人则心中悔过。悔过者过差少。无所须及。其人寿命终尽。则生无量清净佛国。不能得前至无量清净佛所。便道见无量清净佛国界边自然七宝城。心中便大欢喜。道止其城中。则于七宝水池莲华中化生。则受身自然长大。在城中于是间五百岁。其城广纵各二千里。城中亦有七宝舍宅。舍宅中自然内外皆有七宝浴池。浴池中亦有自然华绕。浴池上亦有七宝树重行。皆复作五音声。其饮食时。前亦有自然食。具百味食。在所欲得。其人于城中快乐。其城中比如第二忉利天上自然之物。其人于城中不能得出。复不能得见无量清净佛。但见其光明。心中自悔责。踊跃喜耳。亦复不能得闻经。亦复不能得见诸比丘僧。亦复不能得见知无量清净佛国中诸菩萨阿罗汉状貌何等类。其人若如是比而小适耳。佛亦不使尔身诸所作自然得之。皆心自趣向道入其城中。其人本宿命求道时。心口各异言念无诚。狐疑佛经。复不信向之。当自然入恶道中。无量清净佛哀愍。威神引之去耳。其人于城中。五百岁乃得出。往至无量清净佛所闻经。心不开解。亦复不得在诸菩萨阿罗汉比丘僧中听经。以去所居处舍宅在地。不能令舍宅随意高大在虚空中。复去无量清净佛甚大远。不能得近附无量清净佛。其人智慧不明。知经复少。心不欢乐意不开解。其人久久。亦自当智慧开解知经。明健勇猛心当欢乐。次当复如上第一辈。所以者何。其人但坐其前世宿命求道时。不大持斋戒亏失经法。心意狐疑不信佛语。不信佛经深。不信分檀布施作善后世当得其福。复坐中悔。不信往生无量清净佛国。作德不至心。用是故为第二中辈

佛言。其三辈者。其人愿欲生无量清净佛国。若无所用分檀布施。亦不能烧香散华然灯悬缯彩作佛寺起塔饮食沙门者。当断爱欲无所贪慕。慈心精进不当嗔怒。斋戒清净。如是清净者。当一心念欲生无量清净佛国。昼夜十日不断绝者。寿终则往生无量清净佛国。可复尊极智慧勇猛。佛言。其人作是已后。若复中作悔心。意用狐疑。不信作善后世当得其福。不信往生无量清净佛国。其人虽尔续得往生。其人寿命病欲终时。无量清净佛。则令其人于卧睡梦中。见无量清净佛国土。其人心中欢喜。意自念言。我悔不知益作善。今当生无量清净佛国。其人但心念是。口不能复言。则自悔过。悔过者过差减少。悔者无所复及。其人命终。则生无量清净佛国。不能得前至。便道见二千里七宝城。心中独欢喜。便止其中。复于七宝水池莲华中化生。则自然长大。其城亦复如前城法。比第二忉利天上自然之物。其人亦复于城中五百岁。五百岁竟乃得出。生无量清净佛所。心中大欢喜。其人听闻经。心不开解。意不欢喜。智慧不明。知经复少。所居舍宅在地。不能令舍宅随意高大在虚空中。复去无量清净佛。亦复如是。第二辈狐疑者。其人久久。亦当智慧开解知经。勇猛心当欢乐。次如上第一辈也。所以者何。皆坐前世宿命求道时。中悔狐疑。暂信暂不信。不信作善后得其福德。皆自然得之耳。随其功德有铉不铉。各自然趣向。说经行道卓德万殊超不相及。佛言。其欲求作菩萨道生无量清净佛国者。其然后皆当得阿惟越致菩萨。阿惟越致菩萨者。皆当有三十二相紫磨金色八十种好。皆当作佛。随心所愿。在欲于何方佛国作佛。终不更泥犁禽兽薜荔。随其精进求道。早晚之事事同等耳。求道不休会当得之。不失其所欲愿也。佛告阿逸菩萨等诸天帝王人民。我皆语若曹。诸欲生无量清净佛国。虽不能大精进禅持经戒者。大要当作善。一者不得杀生。二者不得盗窃。三者不得淫劮犯爱他人妇女。四者不得调欺。五者不得饮酒。六者不得两舌。七者不得恶口。八者不得妄言。九者不得嫉妒。十者不得贪欲。不得心有所悭惜。不得嗔怒。不得愚痴。不得随心嗜欲。不得心中中悔。不得狐疑。当作孝顺。当作至诚忠信。当作受佛经语深。当信作善后世得其福。奉持如是其法不亏失者。在心所愿可得往生无量清净佛国。至要当斋戒一心清净昼夜常念欲往生无量清净佛国。十日十夜不断绝。我皆慈愍之。悉令生无量清净佛国。佛言。世间人欲以慕及贤明。居家修善为道者。与妻子共居。在恩好爱欲之中忧念。若多家事匆务。不暇大斋戒一心清净。虽不能得离家。有空闲时自端正心。意念诸善专精行道。十日十夜殊使不能。尔自思惟熟计。欲度脱身者。下当绝念去忧。勿念家事。莫与女人同床。自端正身心断爱欲。一心斋戒清净。至意念生无量清净佛国。一日一夜不断绝者。寿终皆得往生其国。在七宝浴池莲华中化生。可得智慧勇猛。所居七宝舍宅。自在其意所欲作为。可次如上第一辈。佛语阿逸菩萨言。诸八方上下。无央数诸天人民。比丘僧比丘尼。优婆塞优婆夷。其往生无量清净佛国众等大会。皆共于七宝浴池中。都共人人。悉自于一大莲华上坐。皆自陈道德善。人人各自说其前世宿命求道时。持经戒所作善法。所从来生本末。其所好喜经道。知经智慧。所施行功德。从上次下转皆遍。以知经有明不明。有深浅大小。德有优劣厚薄。自然之道别知。才能智慧猛健。众相观照礼义和顺。皆自欢喜踊跃。智慧有勇猛。各不相属逮。佛言。其人殊不豫益作德。为善轻亏。不信之然。徙倚懈怠。为用可尔。至时都集说经行道。自然迫促。应答迟晚。道智卓殊超绝。才妙高猛。独于边羸。临事乃悔。悔者已出。其后当复何益。但心中悷悢慕及等耳

佛言。无量清净佛国。诸菩萨阿罗汉众等。大道聚会自都集。拘心制意端身正行。游戏洞达。俱相随飞行。幡辈出入。供养无极。欢心喜乐。乐共观经行道。和好文习。才猛智慧。志若虚空。精进求愿。心终不复中回意终不复转。终无有懈极时。虽求道外若迟缓。内独駃急疾。容容虚空中。适得其中。中表相应。自然严整。捡敛端直。身心净洁。无有爱欲有所适贪。无有众恶瑕秽。其志愿皆安定殊好。无增缺减。求道和正。不误倾邪。准望道法。随经约令。不敢违失蹉跌。若于绳墨。游于八方上下。无有边幅。自在所欲。至到无穷无极。咸然为道。恢廓慕及旷荡。念道无他之念。无有忧思。自然无为。虚无空立。淡安无欲。作德善愿。尽心求索。含哀慈愍。精进中表。礼义都合。通洞无违。和顺副称。苞罗表里。过度解脱。敢升入于泥洹。长与道德合明。自然相保守。快意之滋滋真。真了洁白。志愿高无上。清净定安。静乐之无有极。善好无有比。巍巍之耀照照。一旦开达明彻。自然中自然相。自然之有根本。自然成五光至九色。五光至九色参回转。数百千更变。最胜之自然。自然成七宝。横揽成万物。光精参明俱出好。甚姝无有极。其国土甚姝好若此。何不力为善。念道之自然。着于无上下。洞达无边幅。捐志虚空中。何不各精进。努力自求索。可得超绝去。往生无量清净阿弥陀佛国。横截于五道。恶道自闭塞。升道之无极。易往无有人。其国土不逆违。自然之随牵。何不弃世事行求道德。可得极长生。寿乐无有极。何为用世事。饶共忧无有常。世人薄俗。共争不急之事。共于是处剧恶极苦之中。勤身治生用相给活。无尊无卑。无富无贫。无老无少。无男无女。皆当共忧钱财。有无同然。忧思适等。屏营愁苦。累念思虑。为之走使。无有安时。有田忧田。有宅忧宅。有牛忧牛。有马忧马。有六畜忧六畜。有奴婢忧奴婢。衣被钱财金银宝物。复共忧之。重思累息。忧念怀愁恐。横为非常。水火盗贼。怨家债主。所漂烧系唐突没溺。忧毒怔忪无有解时。结愤心中慉气毒怒。病在胸腹忧苦心离。心坚意固适无纵舍。或坐摧藏终亡身命。弃捐之去莫谁随者。尊贵豪富有此忧惧。勤苦若此。结众寒热与痛共居。小家贫者穷困乏无。无田亦忧欲有田。无宅亦忧欲有宅。无牛亦忧欲有牛。无马亦忧欲有马。无六畜亦忧欲有六畜。无奴婢亦忧欲有奴婢。无衣被钱财什物饭食之属。亦忧欲有之。适有一少一。有是少是思有齐等。适小具有便复儩尽。如是苦生。当复求索。思想无益不能时得。身心俱劳坐起不安。忧念相随勤苦若此。焦心不离恚恨独怒。亦结众寒热与痛共居。或时坐之终身夭命。亦不肯作善为道。寿命尽死。皆当独远去。有所趣向。善恶之道莫能知者。或时世人父子兄弟。夫妇家室中外亲属。居天地之间。当相敬爱。不当相憎。有无当相给与。不当有贪。言色当和。莫相违戾。或傥心争有所恚怒。今世恨意微相嫉憎。后世转剧至成大怨。所以者何。今世之事。更欲相患害。虽不临时应急相破。杀之愁毒结愤精神。自然克识不得相离。皆当对相生。值更相报复。人在世间爱欲之中。独来独去死生。当行至趣苦乐之处。身自当之无有代者。善恶变化。殃咎异处。宿豫严待。当独升入远到他处。莫能见者去在何所。善恶自然追逐往生。窈窈冥冥别离久长。道路不同会见无期。甚难甚难复得相值。何不弃众事。各劢强健时。努力力为善。力精进来度世。可得极长寿。殊不肯求于道。复欲何须待欲何乐乎。如是世人。不信作善得善。不信为道得道。不信死后世复生不信施与得其福德。都不信之。亦以谓之不然。言无有是。但坐是故且自见之。更相看视。前后转相承受。父余教令。先人祖父。素不作善。本不为道。身愚神闇。心塞意闭。不见天道。殊无有能。见人生死。有所趣向。亦莫能知者。适无有见善恶之道。复无有语者。为用作善恶福德。殃咎祸罚。各自竞作为之用。殊无有怪也。至于生死之道转相续。颠倒上下。无常根本。皆当过去不可常得。教语开导。信道者少。皆当生死无有休止。如是曹人。朦冥抵突。不信经语。各欲快意。心不计虑。愚痴于爱欲。不解于道德。迷惑于嗔怒。贪猥于财色。坐之不得道。当更勤苦极。在于恶处生。终不得止休。息痛之甚可伤。或时家室中外。父子兄弟夫妇。至于生死之义。更相哭泪转相思慕。忧念愤结恩爱绕续。心意痛着对相顾思。昼夜无有解时。教示道德心不开明。恩爱情欲不离。闭塞蒙蒙交错覆蔽。不得思计。心自端正决断世事。专精行道便旋至竟。年寿命尽不能得道。无可奈何。总猥愦譊皆贪爱欲。如是之法。不解道者多。得道者少。世间匆匆无可聊赖。尊卑上下豪贵贫富。男女大小各自匆务。勤苦躬身各怀杀毒。恶气窈冥。莫不惆怅。为妄作事。恶逆天地。不从仁心。道德非恶。先随与之。恣听所为。其寿未至。便顿夺之。下入恶道。累世勤苦。展转愁毒。数千万亿岁。无有出期。痛不可言。甚可怜愍。佛告阿逸菩萨等诸天帝王人民。我皆语若曹。世间之事人用。是故坐不得道。若曹熟思惟之。恶者当纵舍远离之。从其善者。当坚持之勿妄为非。益作诸善。大小多少爱欲之荣。皆不可常得。犹当别离无可乐者。劢佛世时。其有信爱佛经诸深。奉行道德。皆是我小弟也。其有甫欲学佛经戒者。皆是我弟子也。其有欲出身。去家舍妻子。绝去财色。欲来作沙门。为佛作比丘者。皆是我子孙。我世甚难得值。其有愿欲生无量清净佛国者。可得智慧勇猛。为众所尊敬。勿得随心所欲。亏负经戒。在人后傥有疑意不解经者。复前问佛。佛当为若解之。阿逸菩萨长跪叉手言。佛威神尊重。所说经快善。我曹听佛经语。皆心贯思之。世人实尔。如佛所语无有异。今佛慈哀。我曹开视天道教语生路。耳目聪明长得度脱。若得更生。我曹听佛经语。莫不慈心欢喜踊跃开解者。我曹及诸天帝王人民。蜎飞蠕动之类皆蒙佛恩。无不得解脱忧苦者。佛诸教戒甚深。无极无底。佛智慧所见知。八方上下去来现在之事无上无边幅。佛甚难得值。经道甚难得闻。我曹皆慈心于佛所。今我曹得度脱者。皆是佛前世求道时。慊苦学问。精进所致。恩德普覆。所施行福德。相禄巍巍。光明彻照。洞虚无极。开入泥洹。教授经典。制威消化。愍动八方上下。无穷无极。佛为师法尊绝群圣。都无能及佛者。佛为八方上下诸天帝王人民作师。随其心所欲愿。大小皆令得道。今我曹得与佛相见。得闻无量清净佛声。我曹甚喜。莫不得黠慧开明者。佛告阿逸菩萨。若言是实当尔。若有慈心于佛所者。大喜实当念佛。天下久久。乃复有佛耳。今我于苦世作佛所出经道。教授洞达。截断狐疑。端心正行。拔诸爱欲。绝众恶根本。游步无拘。典总智慧。众道表里。揽持维纲。昭然分明开示五道。决正生死泥洹之道。佛言。若曹从无数劫以来。不可复计劫。若曹作菩萨道。欲过度诸天人民。及蜎飞蠕动之类。以来甚久远。人从若得道度者无央数。至得泥洹之道者亦无央数。若曹及八方上下。诸天帝王人民。若比丘比丘尼优婆塞优婆夷。若曹宿命从无数劫以来。展转是五道中。死生呼嗟。更相哭泪。转相贪慕。忧思愁毒。痛苦不可言至今世死生不绝。乃至今日与佛相见共会值是乃闻无量清净佛声甚快。善哉助汝曹喜。亦可自厌死生痛痒。生时甚痛甚苦甚极。至年长大亦苦亦极。死时亦痛亦苦亦极。甚恶臭处不净洁了无有可者。佛故悉语。若曹亦可自决断臭处恶露。若曹亦可端心正身益作诸善。于是常端中外。洁净身体。洗除心垢。自相约捡。表里相应。言行忠信。人能自度脱。转相扶接。拔诸爱欲。精明至心。求愿不转。结其善道根本。虽精进苦一世。须臾间耳。今世为善。后世生无量清净佛国。快乐甚无极。长与道合明。然善极相保守。长去离恶道痛痒之忧恼。拔勤苦诸恶根本。断诸爱欲恩好。长生无量清净佛国。亦无有诸痛痒。亦无复有诸恶臭处。亦无复有勤苦。亦无淫泆嗔怒愚痴。亦无有忧思愁毒。生于无量清净佛国。欲寿一劫十劫。百劫千劫万亿劫。自恣若意。欲住止寿无央数劫。不可复计数劫。恣汝随意皆可得之。欲食不食。恣若其意。都悉自然。皆可得之。次于泥洹之道。皆各自精明求索。心所欲愿。勿得狐疑心中悔。欲往生者。无得坐其过失。在无量清净佛国界边。自然七宝城中。讁五百岁。阿逸菩萨言。受佛严明重教。皆当精进一心求索。请奉行之不敢疑怠

佛说无量清净平等觉经卷第三佛说无量清净平等觉经卷第四

        后汉月氏国三藏支娄迦谶译

佛告阿逸菩萨等。若曹于是世。能自制心正意。身不作恶者。是为大德善。都为八方上下最无有比。所以者何。八方上下无央数佛国中。诸天人民。皆自然作善。不大为恶易教化。今我于是世间为佛。于五恶五痛五烧之中作佛为最剧。教语人民。令绝五恶。令去五痛。令去五烧。降化其心。令持五善得其福德度世长寿泥洹之道。佛言。何等为五恶。何等为五痛。何等为五烧中者。何等为消化五恶令持五善者。何等为持五善得其福德长寿度世泥洹之道。佛言。其一恶者。诸天人民下至禽兽蜎飞蠕动之类。欲为众恶。强者伏弱。转相克贼。自相杀伤。更相食啖。不知为善。恶逆不道。受其殃罚。道之自然。当往趣向。神明记识。犯之不贳。转相承续。故有贪穷下贱乞丐孤独人。有聋盲喑哑愚痴弊恶。下有尪狂不及逮之属。其有尊贵豪富。高才明达智慧勇猛。皆其前世宿命。为善慈孝。布恩施德。故有官事王法牢狱。不肯畏慎作恶入法。受其过讁重罚致剧。求望解脱难得度出。今世有是目前现在。寿终尤剧。入其窈冥。受身更生。譬若王法剧苦极刑。故有自然泥犁禽兽薜荔。蜎飞蠕动之类属。贸身形。改恶易道。寿命短长。魂神命精。自然入趣。受形寄胎。当独值向。相从共生。转相报偿。当相还复。殃恶讁罚。众事未尽。终不得离。展转其中。世世累劫。无有出期。难得解脱。痛不可言天地之间自然有是。虽不临时卒暴至。应时恒取自然之道。皆当善恶归之。是为一大恶。为一痛。为一烧。勤苦如是。愁毒呼嗟。比如剧火起烧人身。人能自于其中。一心制意端身正行。独作诸善。不为众恶者。身独度脱得其福德。可得长寿度世上天泥洹之道。是为一大善

佛言。其二恶者。世间帝王。长吏人民。父子兄弟。室家夫妇。略无义理。不从政令。转淫奢骄慢。各欲快意。恣心自在。更相欺调。殊不惧死。心口各异。言念无实。佞谄不忠。谀媚巧辞。行不端正。更相嫉憎。转相谗恶陷入恶枉。主上不明。心不察照。任用臣下。臣下存在。浅度能行。知其形势。在位不正。为其所调。妄捐忠良。不当天心。甚违道理臣欺其君。子欺其父。弟欺其兄。妇欺其夫。室家中外。知识相绍。各怀贪淫。心独恚怒。蒙聋愚痴欲益多。有尊卑上下。无男无女。无大无小。心俱同然。欲自厚己。破家亡身。不顾念前后。家室亲属。坐之破族。或时家中内外。知识朋友。乡党市里愚民。转共从事。更相利害。争钱财斗。忿怒成仇转争胜负。悭富焦心。不肯施与。专专守惜。爱宝贪重。坐之思念。心劳身苦。如是至竟。无所恃怙。独来独去。无一随者。善恶祸福。殃咎讁罚。追命所生。或在乐处。或入毒苦。然后乃悔。当复何及。或时世人。愚心少智。见善诽谤恚之。不肯慕及。但欲为恶。妄作非法。但欲盗窃。常怀毒心。欲得他人财物。用自供给。消散摩尽。赐复求索。邪心不正。常独恐怖。畏人有色。临时不计。事至乃悔。今世现在。长吏牢狱。自然趣向。受其殃咎。世间贫穷。乞丐孤独。但坐前世宿命。不信道德。不肯为善。今世为恶。天神别籍。寿终入恶道。故有自然泥犁禽兽薜荔。蜎飞蠕动之类。展转其中。世世累劫。无有出期。难得解脱。痛不可言。是为二大恶二痛二烧。勤苦如是。比如火起烧人身。人能自于其中。一心制意端身正行。独作众善。不为众恶者。身独度脱。得其福德。可得长寿度世上天泥洹之道。是为二大善

佛言。其三恶者。世间人民。寄生相因。共依居天地之间。处年寿命。无能几岁。至有豪贵者。贤明善人。下有贫贱尪羸愚者。中有不良之人。但怀念毒恶。身心不正。常念淫泆。烦满胸中。爱欲交错。坐起不安。贪意悭惜。但欲唐得。眄睐细色。恶态淫泆。有妇厌憎。私妄出入。持家所有。相结为非。聚会饮食。自共作恶。兴兵作贼。攻城格斗。劫杀截断。强夺不道。取人财物。偷窃趣得。不肯治生。所当求者。不肯为之。恶心在外。不能专作。欲击成事。恐势迫胁。持归给家。共相生活。恣心快意。极身作乐。行乱他人妇女。或于其亲属不避。尊卑长老。众共憎恶。家室中外。患而苦之。亦复不畏县官法令无所避。录如是之恶。自然牢狱。日月照识。神明记取。诸神摄录。故有自然泥犁禽兽薜荔。蜎飞蠕动之类。展转其中。世世累劫。无有出期。难得度脱。痛不可言。是为三大恶三痛三烧。勤苦如是。比若火起烧人身。人能自于其中。一心制意。端身正行。独作众善。不为众恶者。身独度脱。得其福德。可得长寿度世上天泥洹之道。是为三大善。佛言。其四恶者。诸恶人不能作善。自相坏败。转相教令。共作众恶。主为传言。但欲两舌恶口。骂詈妄语。相嫉更相斗乱。憎嫉善人。败坏贤善。于傍快恶。复不孝顺供养父母。轻易师父知识。无信难得诚实。自言尊贵有道。横行威武。加卷力势。侵克易人。不能自知。为恶无自羞惭。自用颇健。令人承事敬畏。复不敬畏天地。神明日月。亦不可教令作善。不可降化。自用偃蹇。谓常当尔。亦复无忧哀心。亦不知恐惧。恣意憍慢如是。天神记识。赖其前世宿命。颇作福德。小善扶接。营护助之。今世作恶。福德尽儩。诸善鬼神各去离之身独空立。无所复依。受重殃讁。寿命终身恶绕归。自然迫促。当往追逐。不得止息。自然众恶。共趣顿乏。其有名籍。在神明所。殃咎引牵。当值相得。当往趣向。受过讁罚。身心摧碎。神形苦极。不得离却。但得前行。入于火镬。当是时悔复何益。当复何及。天道自然。不得蹉跌。故有泥犁禽兽薜荔。蜎飞蠕动之属。展转其中。世世累劫。无有出期。难得解脱。痛不可言。是为四大恶四痛四烧。勤苦如是。比如火起烧人身。人能于其中。一心制意端身正行。独作众善。不为众恶者。身独度脱。得其福德。可得长寿度世上天泥洹之道。是为四大善

佛言。其五恶者。世人徙倚懈惰。不肯作善。不念治生。妻子饥寒。父母俱然。欲呵教其子。其子恶心。嗔目应怒。言令不和。违戾反逆剧于野人。比若怨家。不如无子。妄遍假贷。众共患厌。尤无返复。无有报偿之心。穷贫困乏。不能复得。辜较谐声。放纵游散。串数唐得。自用赈给。不畏防禁。饮食无极。吃酒嗜美。出入无有期度。鲁扈抵突。不知人情。睢眄强制。见人有喜。憎嫉恚之。无义无礼。自用职当。不可谏晓。亦复不忧念父母妻子有无。又复不念卒报父母之德。亦复不念师父之恩。心常念恶。口常言恶。日不成就。不信道德。不信有贤明先圣。不信作善为道可得度世。不信世间有佛。欲杀罗汉斗比丘僧。常欲杀人。欲杀父母兄弟妻子宗亲朋友。父母兄弟妻子宗亲朋友。憎恶见之。欲使之死。不信佛经语。不信人寿命终尽死。后世复生。不信作善得善。不信作恶得恶。如是曹人。男子女人。心意俱然。违戾反逆。愚痴蒙澒。嗔怒嗜欲。无所识知。自用快善。为大智慧。亦不知所从来。生死所趣向。不肯慈孝。恶逆天地。于其中间。求望侥幸。欲得长生。躬得不死。会当归就。生死勤苦善恶之道。身所作恶。殃咎众趣。不得度脱。亦不可降化令作善。慈心教语。开导生死善恶所趣有是。复不信之。然苦心与语。欲令度脱。无益其人。心中闭塞。意不开解。大命将至。至时皆悔。其后乃悔。当复何及。不豫计善。临穷何益。天地之间。五道分明。恢廓窈窕。浩浩茫茫。转相承受。善恶毒痛。身自当之。无有代者。道之自然。随其所行。追命所生。不得纵舍。善人行善。从善慈孝。从乐入乐从明入明。恶人行恶。从苦入苦。从冥入冥。谁能知者。独佛知见耳。教语人民。信用者少。生死不休。恶道不绝。如是世人。不可悉道。故有自然泥犁禽兽薜荔。蜎飞蠕动之类。展转其中世世累劫。无有出期。难得解脱。痛不可言。是为五大恶五痛五烧。勤苦如是。比如火起烧人身。人能自于其中。一心制意端身正行。言行相副。所作至诚。所语如语。心口不转。独作众善。不为众恶者。身独度脱。得其福德。可得长寿度世上天泥洹之道。是为五大善。佛告阿逸菩萨等。我皆语若曹。是世五恶。勤苦如是。令起五痛。令起五烧。展转相生。世间人民。不肯为善。欲作众恶。敢有犯此诸恶事者。皆悉自然。当更具历入恶道中。或其今世。先被病殃。死生不得。示众见之。寿终趣入至极大苦。愁痛酷毒。自相焦然。转相烧灭。至其后共作怨家。更相伤杀。从小微起至大困剧。皆从贪淫财色。不肯忍辱施与。各欲自快。无复有曲直。欲得健名。为痴欲所迫。随心思想。不能得也。结愤胸中。财色缚束。无有解脱。不知厌足。厚己诤欲。无所省录。都无义理。不随正道。富贵荣华。当时快意。不能忍辱。不知施善。威势无几。随恶名焦。身坐劳苦。久后大剧自然随逐。无有解已。王法施张。自然纠举。上下相应。罗网纲纪。[煢-(冗-几)][煢-(冗-几)]忪忪。当入其中。古今有是。痛哉可伤。佛语阿逸菩萨等。若世有是佛。皆慈愍哀之。威神摧动。众恶诸事。皆消化之。令得去恶就善。弃捐所思。奉持经戒。莫不承奉。施行经法。不敢违失度世无为泥洹之道。快善极乐。甚明无极。佛言。若曹诸天帝王人民。及后世人。得佛经语熟思惟之。能自于其中端心正行。其主上为善率化。捡御其下。教语人民。转相敕令。转共为善。转相度脱。各自端守。慈仁愍哀。终身不殆。尊圣敬孝。通洞博爱。佛语教令。无敢亏负。当忧度世泥洹之道。当忧断截生死痛痒。拔恶根本。当忧断绝泥犁禽兽薜荔。蜎飞蠕动之类。恶苦之道。当劢佛世。坚持经道。无敢失也。佛言。若曹当作善者。云何第一急。当自端身。当自端心。当自端目。当自端耳。当自端鼻。当自端口。当自端手。当自端足。能自捡敛。莫妄动作。身心净洁。俱善相应。中外约束。勿随嗜欲。不犯诸恶。言色常和。身行当专。行步坐起不动。作事所为。当先熟思虑计之。揆度才能。视瞻圆规。安定徐作为之。作事仓卒。不豫熟计。为之不谛。亡其功夫。败悔在后。唐苦亡身。至诚忠信。得道绝去。佛言。若曹于是。益作诸善。布恩施德。能不绝道禁。忍辱精进一心智慧。展转复相教化。作善为德。如是经法。慈心专一。斋戒清净。一日一夜者。胜于无量清净佛国。作善百岁。所以者何。无量清净佛国。皆积德众善。无为自然。在所求索。无有诸恶大如毛发。佛言。于是作善。十日十夜者。其得福。胜于他方佛国中人民。作善千岁。所以者何。他方佛国。皆悉作善。作善者多。为恶者少。皆有自然之物。不行求作便自得之。是间为恶者多。为善者少。不行求作不能得也。人能自端制作善。至心求道。故能尔耳。是间无有自然。不能自给。当行求索勤苦治生。转相欺怠调作好恶。得其财物归给妻子。饮苦食毒劳心苦身。如是至竟。心意不专周旋不安。人能自安静为善。精进作德。故能尔耳。佛言。我皆哀若曹及诸天帝王人民。皆教令作诸善。不为众恶。随其所能辄授与道。教戒开导悉奉行之。则君率化为善。教令臣下。父教其子。兄教其弟。夫教其妇。室家内外亲属朋友。转相教语作善为道。奉经持戒各自端守。上下相捡。无尊无卑。无男无女。斋戒清净。莫不欢喜。和顺义理。劝乐慈孝。自相约捡。其有得佛经语。悉持思之不当所作。如犯为之则自悔过。去恶就善。弃邪为正。朝闻夕改。奉持经戒。剧如贫人得宝。佛所行处。所在郡国。辄授与经戒。诸天日月星辰诸神。国王傍臣长吏人民。诸龙鬼神。泥犁禽兽。承奉行之。则君改化为善。斋戒精思。净自湔洒。端心正行。居位严慓。教敕率众为善。奉行道禁。令言令止。臣事其君。忠直受令。不敢违负。父子言令孝顺承受。兄弟夫妇宗亲朋友。上下相令顺言和理。尊卑大小转相敬事。以礼如义不相违负。莫不改往修来。洒心易行端正中表。自然作善所愿辄得。感善降化自然之道。求欲不死则可得长寿。求欲度世则可得泥洹之道。佛言。佛威神尊重。消恶化善莫不度脱。今我出于天下。在是恶中。于苦世作佛。慈愍哀伤教语开道。诸天帝王。傍臣左右。长吏人民。随其心所欲愿乐。皆令得道。佛诸所行处。所更过历郡国县邑。丘聚市里莫不丰熟。天下太平。日月运照。倍益明好。风雨时节。人民安宁。强不凌弱。各得其所。无恶岁疾疫。无病瘦者。兵革不起。国无盗贼无有怨抂。无有拘闭者。君臣人民莫不欢喜。忠慈至诚各自端守。皆自然守国。雍和孝顺莫不欢乐。有无相与布恩施德。心欢乐与皆相敬爱。推财让义。谦让于先。前后以礼敬事。如父如子。如兄如弟。莫不仁贤。和顺礼节都无违诤。快善无极。佛言。我哀子曹欲度脱之。剧父母念子。今八方上下。诸天帝王人民。及蜎飞蠕动之类。得佛经戒奉行佛道。皆得明慧心悉开解。莫不得度过度脱忧苦者。今我作佛。在于五恶五痛五烧之中。降化五恶。消尽五痛。绝灭五烧。以善攻恶拔去毒苦。令得五善明好。烧恶不起。我般泥洹去后。经道稍稍断绝。人民谀谄淳为众恶。不复作善。五烧复起。五痛剧苦。复如前法。自然还复。久后转剧不可悉说。我但为若曹。小道之耳。佛告阿逸菩萨等。若曹各思持之。展转相教戒。如佛经法无敢犯也。阿逸菩萨长跪叉手言。佛所说甚苦痛。世人为恶。甚剧如是如是。佛皆慈哀悉度脱之。皆言受佛重教。请展转相承。不敢犯也。佛告阿难。我哀若曹。令悉见无量清净佛及诸菩萨阿罗汉。所居国土。若欲见之不。阿难则大喜。长跪叉手言。愿皆欲见之。佛言。若起更被袈裟西向拜。当日没处。为无量清净佛作礼。以头面着地言。南无无量清净平等觉。阿难言诺受教。则起更被袈裟西向拜。当日所没处。为无量清净佛作礼。以头脑着地言。南无无量清净平等觉。阿难未起。无量清净佛。便大放光明威神。则遍八方上下。诸无央数佛国天地。则皆为大震动。诸天无央数天地。须弥山罗宝。摩诃须弥大山罗宝。诸天地大界小界。其中诸有大泥犁小泥犁。诸山林溪谷幽冥之处。皆则大明悉雨大开辟。则阿难诸菩萨阿罗汉等。诸天帝王人民。悉皆见无量清净佛。及诸菩萨阿罗汉国土七宝已。心皆大欢喜踊跃。悉起为无量清净佛作礼。以头脑着地。皆言南无无量清净三藐三佛陀。无量清净佛。放光明威神已。诸无央数天人民。及蜎飞蠕动之类。皆悉见无量清净佛光明。莫不慈心欢喜作善者。诸有泥犁禽兽薜荔。诸有考治勤苦之处。则皆休止不复治。莫不解脱忧苦者。诸有盲者则皆得视。诸跛躄蹇者则皆得走行。诸病者则皆愈起。诸尪者则皆强健。愚痴者则皆更黠慧。诸有淫泆嗔怒者皆悉慈心作善。诸有被毒者毒皆不行。钟鼓琴瑟箜篌乐器。诸伎不鼓皆自作音声。妇女珠环皆自作声。百鸟畜兽皆自悲鸣。当是之时。莫不欢喜得过度者。则时尔日。诸佛国中诸天人莫不持天上华香来下。于虚空中悉皆供养。散诸佛及无量清净佛上。诸天各共。大作万种自然伎乐。乐诸佛及诸菩萨阿罗汉。当是之时。甚快乐不可言

佛告阿难阿逸菩萨等。我说无量清净佛及诸菩萨阿罗汉国土自然七宝。当无有异乎。阿难长跪叉手言。佛说无量清净佛国土快善。如佛所说无有一异。佛言。我说无量清净佛功德国土快善。昼夜一劫尚复未竟。我但为若曹小说之耳。阿逸菩萨则长跪叉手问佛言。今佛国从是间当有几。阿惟越致菩萨。往生无量清净佛国。愿闻之。佛言。若欲知者明听着心中。阿逸菩萨言受教。佛言。从我国当有七百二十亿。阿惟越致菩萨。皆往生无量清净佛国。一阿惟越致菩萨者。前后供养无央数诸佛。以次如弥勒皆当作佛。及其余诸小菩萨辈者。无央数不可复计。皆当往生无量清净佛国。佛告阿逸菩萨。不但我国中诸菩萨当往生无量清净佛国。他方异国复有佛亦复如是。第一佛名光远昭。其国有百八十亿菩萨。皆当往生无量清净佛国。他方异国。第二佛佛名宝积。其国有九十亿菩萨。皆当往生无量清净佛国。他方异国。第三佛名儒无垢。有二百二十亿菩萨。皆当往生阿弥陀佛国。他方异国。第四佛名无极光明。其国有二百五十亿菩萨。皆当往生无量清净佛国。他方异国。第五佛名于世无上。其国有六百亿菩萨。皆当往生无量清净佛国。他方异国。第六佛名勇光。其国有万四千菩萨。皆当往生无量清净佛国。他方异国。第七佛名具足交络。其国有十四亿菩萨。皆当往生无量清净佛国。他方异国。第八佛名雄慧王。其国有八菩萨。皆当往生无量清净佛国。他方异国。第九佛名多力无过者。其国有八百一十亿菩萨。皆当往生无量清净佛国。他方异国。第十佛名吉良。其国有万亿菩萨。皆当往生无量清净佛国。他方异国。第十一佛名慧辩。其国有万二千菩萨。皆当往生无量清净佛国。他方异国。第十二佛名无上华。其国有诸菩萨无央数不可复计。皆阿惟越致。皆智慧勇猛。各供养无央数诸佛。以一时俱心愿欲往生。皆当生无量清净佛国。他方异国。第十三佛名乐大妙音。其国有七百九十亿菩萨。皆当往生无量清净佛国。佛言。是诸菩萨。皆阿惟越致。诸比丘僧中。及小菩萨辈无央数。皆当往生无量清净佛国。不独是十四佛国中诸菩萨当往生也。都八方上下无央数佛国。诸菩萨辈。各各如是。皆当往生无量清净佛国。其无央数。都共往会无量清净佛国。大众多不可复计。我但说八方上下无央数佛名字。昼夜一劫尚未竟。我但复说佛国诸比丘僧众菩萨。当往生无量清净佛国人数。说之一劫不休止尚未竟。我但为若曹。总揽都小说之耳

佛语阿难阿逸菩萨等。其世间帝王人民。善男子善女人。前世宿命行善所致相禄。乃当闻无量清净佛声。慈心欢喜我代之喜。佛言。其有善男子善女人。闻无量清净佛声。慈心欢喜。一时踊跃。心意清净。衣毛为起拔出者。皆前世宿命作佛道。若他方佛故。菩萨非凡人。其有人民男子女人。闻无量清净佛声。不信有佛者。不信佛经语。不信有比丘僧。心中狐疑。都无所信者。皆故从恶道中来。生愚蒙不解宿命。殃恶未尽。未当得度脱故。心中狐疑不信向耳。佛言。我语若曹。若曹所当作善法。皆当奉行信之。无得以我般泥洹去后故。若曹及后世人。无得复言。我不信有无量清净佛国。我故令若曹悉见无量清净佛国土。所当为者若自求之。我具为汝曹。道说经戒顺法。若曹当如佛法持之。无得毁失。我持是经以累汝曹。汝曹当坚持之。无得为妄增减是经法。我般泥洹去后。经道留止千岁。千岁后经道断绝。在心所愿皆可得道。佛言。师开导人耳目。智慧明达。度脱人令得善。舍泥洹之道。常当慈孝。于佛如父母。常念师恩。当念不断绝。则得道疾。佛言。天下有佛者甚难得值。人有信受师法经语深者。亦难得值。若有沙门。若师为人说佛经者。甚难得值。佛说是经时。则万二千亿诸天人民。皆得天眼彻视。悉一心皆为菩萨道。则二百二十亿诸天人民。皆得阿那含道。则八百沙门。皆得阿罗汉道。则四十亿菩萨。皆得阿惟越致。佛说经已。诸菩萨阿罗汉。诸天帝王人民。皆大欢喜。前趣为佛作礼绕佛三匝。以头面着佛足而去

佛说无量清净平等觉经卷第四


佛说无量寿经

    No. 360 [Nos. 361-364]

佛说无量寿经卷上

        曹魏天竺三藏康僧铠译

我闻如是。一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。一切大圣神通已达。其名曰尊者了本际．尊者正愿．尊者正语．尊者大号．尊者仁贤．尊者离垢．尊者名闻．尊者善实．尊者具足．尊者牛王．尊者优楼频蠡迦叶．尊者伽耶迦叶．尊者那提迦叶．尊者摩诃迦叶．尊者舍利弗．尊者大目揵连．尊者劫宾那．尊者大住．尊者大净志．尊者摩诃周那．尊者满愿子．尊者离障阂．尊者流灌．尊者坚伏．尊者面王．尊者果乘．尊者仁性．尊者喜乐．尊者善来．尊者罗云．尊者阿难。皆如斯等上首者也。又与大乘众菩萨俱。普贤菩萨．妙德菩萨．慈氏菩萨等。此贤劫中一切菩萨。又贤护等十六正士。善思议菩萨．信慧菩萨．空无菩萨．神通华菩萨．光英菩萨．慧上菩萨．智幢菩萨．寂根菩萨．愿慧菩萨．香象菩萨．宝英菩萨．中住菩萨．制行菩萨．解脱菩萨。皆遵普贤大士之德。具诸菩萨无量行愿。安住一切功德之法。游步十方。行权方便。入佛法藏究竟彼岸。于无量世界现成等觉。处兜率天弘宣正法。舍彼天宫降神母胎。从右胁生现行七步。光明显曜。普照十方无量佛土。六种振动。举声自称。吾当于世为无上尊。释梵奉侍天人归仰。示现算计文艺射御。博综道术。贯练群籍。游于后园。讲武试艺。现处宫中色味之间。见老病死悟世非常。弃国财位。入山学道。服乘白马宝冠璎珞。遣之令还。舍珍妙衣而着法服。剃除须发。端坐树下。勤苦六年。行如所应。现五浊刹随顺群生。示有尘垢沐浴金流。天按树枝。得攀出池。灵禽翼从往诣道场。吉祥感征表章功祚。哀受施草敷佛树下加趺而坐。奋大光明使魔知之。魔率官属而来逼试。制以智力皆令降伏。得微妙法成最正觉。释梵祈劝请转法轮。以佛游步。佛吼而吼。扣法鼓。吹法螺。执法剑。建法幢。震法雷。曜法电。澍法雨。演法施。常以法音觉诸世间。光明普照无量佛土。一切世界六种震动。总摄魔界动魔宫殿。众魔慑怖莫不归伏。掴裂邪网消灭诸见。散诸尘劳坏诸欲堑。严护法城开阐法门。洗濯垢污显明清白。光融佛法宣流正化。入国分卫获诸丰膳。贮功德。示福田。欲宣法。现欣笑。以诸法药救疗三苦。显现道意无量功德。授菩萨记成等正觉。示现灭度拯济无极。消除诸漏殖众德本。具足功德微妙难量。游诸佛国普现道教。其所修行清净无秽。譬如幻师现众异像为男为女无所不变。本学明了在意所为。此诸菩萨亦复如是。学一切法。贯综缕练。所住安谛。靡不感化。无数佛土。皆悉普现。未曾慢恣愍伤众生。如是之法一切具足。菩萨经典究畅要妙。名称普至导御十方。无量诸佛咸共护念。佛所住者皆已得住。大圣所立而皆已立。如来导化各能宣布。为诸菩萨而作大师。以甚深禅慧开导众人。通诸法性达众生相。明了诸国供养诸佛。化现其身犹如电光。善学无畏晓了幻法。坏裂魔网。解诸缠缚。超越声闻缘觉之地。得空无相无愿三昧。善立方便。显示三乘。于此中下而现灭度。亦无所作亦无所有。不起不灭得平等法。具足成就无量总持百千三昧。诸根智慧广普寂定。深入菩萨法藏。得佛华严三昧。宣扬演说一切经典。住深定门。悉睹现在无量诸佛。一念之顷无不周遍。济诸剧难诸闲不闲。分别显示真实之际。得诸如来辩才之智。入众言音。开化一切。超过世间诸所有法。心常谛住度世之道。于一切万物随意自在。为众生类作不请之友。荷负群生为之重任。受持如来甚深法藏。护佛种性常使不绝。兴大悲愍众生。演慈辩授法眼。杜三趣开善门。以不请之法。施诸黎庶。犹如孝子爱敬父母。于诸众生视之若己。一切善本皆度彼岸。悉获诸佛无量功德。智慧圣明不可思议。如是菩萨无量大士。不可称计一时来会

尔时世尊。诸根悦豫。姿色清净。光颜巍巍。尊者阿难承佛圣旨。即从座起。偏袒右肩。长跪合掌而白佛言。今日世尊。诸根悦豫。姿色清净。光颜巍巍。如明镜净影畅表里。威容显耀超绝无量。未曾瞻睹殊妙如今。唯然大圣我心念言。今日世尊住奇特法。今日世雄住佛所住。今日世眼住导师行。今日世英住最胜道。今日天尊行如来德。去来现在佛佛相念。得无今佛念诸佛耶。何故威神光光乃尔。于是世尊告阿难曰。云何阿难。诸天教汝来问佛耶。自以慧见问威颜乎。阿难白佛。无有诸天来教我者。自以所见问斯义耳。佛言。善哉阿难。所问甚快。发深智慧真妙辩才。愍念众生问斯慧义。如来以无尽大悲矜哀三界。所以出兴于世。光阐道教。普令群萌获真法利。无量亿劫难值难见。犹灵瑞华时时乃出。今所问者多所饶益。开化一切诸天人民。阿难。当知如来正觉其智难量多所导御。慧见无碍无能遏绝。以一餐之力能住寿命。亿百千劫无数无量。复过于此。诸根悦豫不以毁损。姿色不变光颜无异。所以者何。如来定慧究畅无极。于一切法而得自在。阿难谛听。今为汝说。对曰唯然愿乐欲闻

佛告阿难。乃往过去久远无量不可思议无央数劫。锭光如来兴出于世。教化度脱无量众生。皆令得道乃取灭度。次有如来名曰光远。次名月光。次名栴檀香。次名善山王。次名须弥天冠。次名须弥等曜。次名月色。次名正念。次名离垢。次名无著。次名龙天。次名夜光。次名安明顶。次名不动地。次名琉璃妙华。次名琉璃金色。次名金藏。次名炎光。次名炎根。次名地种。次名月像。次名日音。次名解脱华。次名庄严光明。次名海觉神通。次名水光。次名大香。次名离尘垢。次名舍厌意。次名宝炎。次名妙顶。次名勇立。次名功德持慧。次名蔽日月光。次名日月琉璃光。次名无上琉璃光。次名最上首。次名菩提华。次名月明。次名日光。次名华色王。次名水月光。次名除痴冥。次名度盖行。次名净信。次名善宿。次名威神。次名法慧。次名鸾音。次名师子音。次名龙音。次名处世。如此诸佛皆悉已过

尔时次有佛。名世自在王如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。时有国王。闻佛说法心怀悦豫寻发无上正真道意。弃国捐王行作沙门。号曰法藏。高才勇哲与世超异。诣世自在王如来所。稽首佛足右绕三匝。长跪合掌以颂赞曰

  光颜巍巍　　威神无极　　如是炎明
  无与等者　　日月摩尼　　珠光炎耀
  皆悉隐蔽　　犹如聚墨　　如来容颜
  超世无伦　　正觉大音　　响流十方
  戒闻精进　　三昧智慧　　威德无侣
  殊胜希有　　深谛善念　　诸佛法海
  穷深尽奥　　究其崖底　　无明欲怒
  世尊永无　　人雄师子　　神德无量
  功德广大　　智慧深妙　　光明威相
  震动大千　　愿我作佛　　齐圣法王
  过度生死　　靡不解脱　　布施调意
  戒忍精进　　如是三昧　　智慧为上
  吾誓得佛　　普行此愿　　一切恐惧
  为作大安　　假令有佛　　百千亿万
  无量大圣　　数如恒沙　　供养一切
  斯等诸佛　　不如求道　　坚正不却
  譬如恒沙　　诸佛世界　　复不可计
  无数刹土　　光明悉照　　遍此诸国
  如是精进　　威神难量　　令我作佛
  国土第一　　其众奇妙　　道场超绝
  国如泥洹　　而无等双　　我当愍哀
  度脱一切　　十方来生　　心悦清净
  已到我国　　快乐安隐　　幸佛信明
  是我真证　　发愿于彼　　力精所欲
  十方世尊　　智慧无碍　　常令此尊
  知我心行　　假令身止　　诸苦毒中
  我行精进　　忍终不悔

佛告阿难。法藏比丘说此颂已。而白佛言。唯然世尊。我发无上正觉之心。愿佛为我广宣经法。我当修行摄取佛国清净庄严无量妙土。令我于世速成正觉。拔诸生死勤苦之本。佛语阿难。时世自在王佛。告法藏比丘。如所修行庄严佛土。汝自当知。比丘白佛。斯义弘深非我境界。唯愿世尊广为敷演诸佛如来净土之行。我闻此已。当如说修行成满所愿。尔时世自在王佛。知其高明志愿深广。即为法藏比丘而说经言。譬如大海。一人斗量经历劫数。尚可穷底得其妙宝。人有至心精进求道不止会当克果。何愿不得

于是世自在王佛。即为广说二百一十亿诸佛刹土天人之善恶国土之粗妙。应其心愿悉现与之。时彼比丘闻佛所说严净国土。皆悉睹见超发无上殊胜之愿。其心寂静志无所著。一切世间无能及者。具足五劫。思惟摄取庄严佛国清净之行。阿难白佛。彼佛国土寿量几何。佛言。其佛寿命四十二劫。时法藏比丘。摄取二百一十亿诸佛妙土清净之行。如是修已诣彼佛所。稽首礼足绕佛三匝合掌而住。白言世尊。我已摄取庄严佛土清净之行。佛告比丘。汝今可说宜知是时。发起悦可一切大众。菩萨闻已修行此法。缘致满足无量大愿。比丘白佛。唯垂听察。如我所愿当具说之

设我得佛。国有地狱饿鬼畜生者。不取正觉

设我得佛。国中人天。寿终之后。复更三恶道者。不取正觉

设我得佛。国中人天。不悉真金色者。不取正觉

设我得佛。国中人天。形色不同有好丑者。不取正觉

设我得佛。国中人天。不悉识宿命。下至知百千亿那由他诸劫事者。不取正觉

设我得佛。国中人天。不得天眼。下至见百千亿那由他诸佛国者。不取正觉

设我得佛。国中人天。不得天耳。下至闻百千亿那由他诸佛所说。不悉受持者。不取正觉

设我得佛。国中人天。不得见他心智。下至知百千亿那由他诸佛国中众生心念者。不取正觉

设我得佛。国中人天。不得神足。于一念顷下至不能超过百千亿那由他诸佛国者。不取正觉

设我得佛。国中人天。若起想念贪计身者。不取正觉

设我得佛。国中人天。不住定聚。必至灭度者。不取正觉

设我得佛。光明有能限量。下至不照百千亿那由他诸佛国者。不取正觉

设我得佛。寿命有能限量。下至百千亿那由他劫者。不取正觉

设我得佛。国中声闻有能计量。乃至三千大千世界众生缘觉。于百千劫悉共计挍知其数者。不取正觉

设我得佛。国中人天。寿命无能限量。除其本愿修短自在。若不尔者。不取正觉

设我得佛。国中人天。乃至闻有不善名者。不取正觉

设我得佛。十方世界无量诸佛。不悉咨嗟称我名者。不取正觉

设我得佛。十方众生至心信乐。欲生我国乃至十念。若不生者不取正觉。唯除五逆诽谤正法

设我得佛。十方众生发菩提心修诸功德。至心发愿欲生我国。临寿终时。假令不与大众围绕现其人前者。不取正觉

设我得佛。十方众生闻我名号系念我国殖诸德本。至心回向欲生我国。不果遂者。不取正觉

设我得佛。国中人天。不悉成满三十二大人相者。不取正觉

设我得佛。他方佛土诸菩萨众来生我国。究竟必至一生补处。除其本愿自在所化。为众生故被弘誓铠。积累德本度脱一切。游诸佛国修菩萨行。供养十方诸佛如来。开化恒沙无量众生。使立无上正真之道。超出常伦。诸地之行。现前修习普贤之德。若不尔者不取正觉

设我得佛。国中菩萨。承佛神力供养诸佛。一食之顷不能遍至无量无数亿那由他诸佛国者不取正觉

设我得佛。国中菩萨。在诸佛前现其德本。诸所求欲供养之具。若不如意者。不取正觉

设我得佛。国中菩萨不能演说一切智者。不取正觉

设我得佛。国中菩萨不得金刚那罗延身者。不取正觉

设我得佛。国中人天。一切万物严净光丽。形色殊特穷微极妙无能称量。其诸众生。乃至逮得天眼。有能明了辨其名数者。不取正觉

设我得佛。国中菩萨。乃至少功德者。不能知见其道场树无量光色高四百万里者。不取正觉

设我得佛。国中菩萨。若受读经法讽诵持说。而不得辩才智慧者。不取正觉

设我得佛。国中菩萨。智慧辩才若可限量者。不取正觉

设我得佛。国土清净。皆悉照见十方一切无量无数不可思议诸佛世界。犹如明镜睹其面像。若不尔者。不取正觉

设我得佛。自地以上至于虚空。宫殿楼观池流华树。国土所有一切万物。皆以无量杂宝百千种香而共合成。严饰奇妙超诸人天。其香普薰十方世界。菩萨闻者皆修佛行。若不尔者。不取正觉

设我得佛。十方无量不可思议诸佛世界众生之类。蒙我光明触其体者。身心柔软超过人天。若不尔者。不取正觉

设我得佛。十方无量不可思议诸佛世界众生之类。闻我名字。不得菩萨无生法忍诸深总持者。不取正觉

设我得佛。十方无量不可思议诸佛世界。其有女人闻我名字。欢喜信乐发菩提心厌恶女身。寿终之后复为女像者。不取正觉

设我得佛。十方无量不可思议诸佛世界诸菩萨众。闻我名字。寿终之后常修梵行至成佛道。若不尔者。不取正觉

设我得佛。十方无量不可思议诸佛世界诸天人民。闻我名字。五体投地稽首作礼。欢喜信乐修菩萨行。诸天世人莫不致敬。若不尔者。不取正觉

设我得佛。国中人天。欲得衣服随念即至。如佛所赞应法妙服自然在身。若有裁缝染治浣濯者。不取正觉

设我得佛。国中人天。所受快乐。不如漏尽比丘者。不取正觉

设我得佛。国中菩萨。随意欲见十方无量严净佛土。应时如愿。于宝树中皆悉照见。犹如明镜睹其面像。若不尔者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字至于得佛。诸根缺陋不具足者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。皆悉逮得清净解脱三昧。住是三昧一发意顷。供养无量不可思议诸佛世尊。而不失定意。若不尔者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。寿终之后生尊贵家。若不尔者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。欢喜踊跃。修菩萨行具足德本。若不尔者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。皆悉逮得普等三昧。住是三昧至于成佛。常见无量不可思议一切如来。若不尔者。不取正觉

设我得佛。国中菩萨。随其志愿所欲闻法自然得闻。若不尔者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。不即得至不退转者。不取正觉

设我得佛。他方国土诸菩萨众。闻我名字。不即得至第一第二第三法忍。于诸佛法不能即得不退转者。不取正觉

佛告阿难。尔时法藏比丘。说此愿已而说颂曰

  我建超世愿　　必至无上道
  斯愿不满足　　誓不成等觉
  我于无量劫　　不为大施主
  普济诸贫苦　　誓不成等觉
  我至成佛道　　名声超十方
  究竟靡不闻　　誓不成等觉
  离欲深正念　　净慧修梵行
  志求无上道　　为诸天人师
  神力演大光　　普照无际土
  消除三垢冥　　明济众厄难
  开彼智慧眼　　灭此昏盲闇
  闭塞诸恶道　　通达善趣门
  功祚成满足　　威曜朗十方
  日月戢重晖　　天光隐不现
  为众开法藏　　广施功德宝
  常于大众中　　说法师子吼
  供养一切佛　　具足众德本
  愿慧悉成满　　得为三界雄
  如佛无量智　　通达靡不遍
  愿我功德力　　等此最胜尊
  斯愿若克果　　大千应感动
  虚空诸天人　　当雨珍妙华

佛语阿难。法藏比丘说此颂已。应时普地六种震动。天雨妙华以散其上。自然音乐空中赞言。决定必成无上正觉。于是法藏比丘。具足修满如是大愿。诚谛不虚超出世间深乐寂灭。阿难。法藏比丘于彼佛所。诸天魔梵龙神八部大众之中。发斯弘誓建此愿已。一向专志庄严妙土。所修佛国开廓广大超胜独妙。建立常然无衰无变。于不可思议兆载永劫。积殖菩萨无量德行。不生欲觉嗔觉害觉。不起欲想嗔想害想。不着色声香味触之法。忍力成就不计众苦。少欲知足无染恚痴。三昧常寂智慧无碍。无有虚伪谄曲之心和颜软语先意承问。勇猛精进志愿无惓。专求清白之法。以慧利群生。恭敬三宝奉事师长。以大庄严具足众行。令诸众生功德成就。住空无相无愿之法。无作无起观法如化。远离粗言自害害彼彼此俱害。修习善语自利利人彼我兼利。弃国捐王绝去财色。自行六波罗蜜。教人令行。无央数劫积功累德。随其生处在意所欲。无量宝藏自然发应。教化安立无数众生。住于无上正真之道。或为长者居士豪姓尊贵。或为刹利国君转轮圣帝。或为六欲天主乃至梵王。常以四事供养恭敬一切诸佛。如是功德不可称说。口气香洁如优钵罗华。身诸毛孔出栴檀香。其香普熏无量世界。容色端正相好殊妙。其手常出无尽之宝。衣服饮食珍妙华香。诸盖幢幡庄严之具。如是等事超诸人天。于一切法而得自在。阿难白佛。法藏菩萨。为已成佛而取灭度。为未成佛。为今现在。佛告阿难。法藏菩萨。今已成佛现在西方。去此十万亿刹。其佛世界名曰安乐。阿难又问。其佛成道已来为经几时。佛言。成佛已来凡历十劫。其佛国土自然七宝。金银琉璃珊瑚琥珀车磲玛瑙合成为地。恢廓旷荡不可限极。悉相杂厕转相入间。光赫焜耀微妙奇丽。清净庄严超踰十方一切世界。众宝中精。其宝犹如第六天宝。又其国土无须弥山及金刚围一切诸山。亦无大海小海溪渠井谷。佛神力故欲见则见。亦无地狱饿鬼畜生诸难之趣。亦无四时春秋冬夏。不寒不热常和调适。尔时阿难白佛言。世尊。若彼国土无须弥山。其四天王及忉利天。依何而住。佛语阿难。第三炎天。乃至色究竟天。皆依何住。阿难白佛。行业果报不可思议。佛语阿难。行业果报不可思议。诸佛世界亦不可思议。其诸众生功德善力。住行业之地。故能尔耳。阿难白佛。我不疑此法。但为将来众生。欲除其疑惑。故问斯义。佛告阿难。无量寿佛威神光明最尊第一。诸佛光明所不能及。或有佛光照百佛世界。或千佛世界。取要言之。乃照东方恒沙佛刹。南西北方四维上下亦复如是。或有佛光照于七尺。或照一由旬二三四五由旬。如是转倍乃至照一佛刹。是故无量寿佛号无量光佛。无边光佛。无碍光佛。无对光佛。炎王光佛。清净光佛。欢喜光佛。智慧光佛。不断光佛。难思光佛。无称光佛。超日月光佛。其有众生遇斯光者三垢消灭身意柔软。欢喜踊跃善心生焉。若在三涂勤苦之处。见此光明皆得休息无复苦恼。寿终之后皆蒙解脱。无量寿佛光明显赫照曜十方诸佛国土。莫不闻知。不但我今称其光明。一切诸佛声闻缘觉诸菩萨众。咸共叹誉亦复如是。若有众生。闻其光明威神功德。日夜称说至心不断。随意所愿得生其国。为诸菩萨声闻大众。所共叹誉称其功德。至其然后得佛道时。普为十方诸佛菩萨。叹其光明亦如今也。佛言。我说无量寿佛光明威神巍巍殊妙。昼夜一劫尚不能尽

佛语阿难。无量寿佛。寿命长久不可称计。汝宁知乎。假使十方世界无量众生皆得人身。悉令成就声闻缘觉。都共集会禅思一心竭其智力。于百千万劫悉共推算。计其寿命长远劫数。不能穷尽知其限极。声闻菩萨天人之众。寿命长短亦复如是。非算数譬喻所能知也。又声闻菩萨。其数难量不可称说。神智洞达威力自在。能于掌中持一切世界。佛语阿难。彼佛初会。声闻众数不可称计。菩萨亦然。能如大目揵连。百千万亿无量无数。于阿僧祇那由他劫。乃至灭度。悉共计挍。不能究了多少之数。譬如大海深广无量。假使有人。析其一毛以为百分。以一分毛沾取一渧。于意云何。其所渧者于彼大海。何所为多。阿难白佛。彼所渧水比于大海。多少之量非巧历算数言辞譬类所能知也。佛语阿难。如目连等。于百千万亿那由他劫。计彼初会声闻菩萨。所知数者犹如一渧。其所不知如大海水。又其国土。七宝诸树周满世界。金树。银树。琉璃树。颇梨树。珊瑚树。玛瑙树。车磲树。或有二宝三宝乃至七宝转共合成。或有金树。银叶华果。或有银树。金叶华果。或琉璃树。玻梨为叶华果亦然。或水精树。琉璃为叶华果亦然。或珊瑚树。玛瑙为叶华果亦然。或玛瑙树。琉璃为叶华果亦然。或车磲树。众宝为叶华果亦然。或有宝树。紫金为本。白银为茎。琉璃为枝。水精为条。珊瑚为叶。玛瑙为华。车磲为实。或有宝树。白银为本。琉璃为茎。水精为枝。珊瑚为条。玛瑙为叶。车磲为华。紫金为实。或有宝树。琉璃为本。水精为茎。珊瑚为枝。玛瑙为条。车磲为叶。紫金为华。白银为实。或有宝树。水精为本。珊瑚为茎。玛瑙为枝。车磲为条。紫金为叶。白银为华。琉璃为实。或有宝树。珊瑚为本。玛瑙为茎。车磲为枝。紫金为条。白银为叶。琉璃为华。水精为实。或有宝树。玛瑙为本。车磲为茎。紫金为枝。白银为条。琉璃为叶。水精为华。珊瑚为实。或有宝树。车磲为本。紫金为茎。白银为枝。琉璃为条。水精为叶。珊瑚为华。玛瑙为实。行行相值。茎茎相望。枝枝相准。叶叶相向。华华相顺。实实相当。荣色光曜不可胜视。清风时发出五音声。微妙宫商自然相和。又无量寿佛。其道场树高四百万里。其本周围五千由旬。枝叶四布二十万里。一切众宝自然合成。以月光摩尼持海轮宝众宝之王。而庄严之。周匝条间垂宝璎珞。百千万色种种异变。无量光炎照曜无极。珍妙宝网罗覆其上。一切庄严随应而现。微风徐动出妙法音。普流十方一切佛国。其闻音者得深法忍。住不退转。至成佛道。不遭苦患。目睹其色。耳闻其音鼻知其香舌尝其味。身触其光。心以法缘。一切皆得甚深法忍。住不退转至成佛道。六根清彻无诸恼患。阿难。若彼国人天。见此树者得三法忍。一者音响忍。二者柔顺忍。三者无生法忍。此皆无量寿佛威神力故。本愿力故。满足愿故。明了愿故。坚固愿故。究竟愿故

佛告阿难。世间帝王有百千音乐。自转轮圣王。乃至第六天上伎乐音声。展转相胜千亿万倍。第六天上万种乐音。不如无量寿国诸七宝树一种音声。千亿倍也。亦有自然万种伎乐。又其乐声无非法音。清畅哀亮微妙和雅。十方世界音声之中最为第一

又讲堂精舍宫殿楼观皆七宝庄严自然化成。复以真珠明月摩尼众宝。以为交露覆盖其上。内外左右有诸浴池。或十由旬。或二十三十。乃至百千由旬。纵广深浅各皆一等。八功德水湛然盈满。清净香洁味如甘露。黄金池者底白银沙。白银池者底黄金沙。水精池者底琉璃沙。琉璃池者底水精沙。珊瑚池者底琥珀沙。琥珀池者底珊瑚沙。车磲池者底玛瑙沙。玛瑙池者底车磲沙。白玉池者底紫金沙。紫金池者底白玉沙。或二宝三宝。乃至七宝转共合成。其池岸上有栴檀树。华叶垂布香气普熏。天优钵罗华。钵昙摩华。拘物头华。分陀利华。杂色光茂弥覆水上。彼诸菩萨及声闻众。若入宝池。意欲令水没足。水即没足。欲令至膝。即至于膝。欲令至腰。水即至腰。欲令至颈。水即至颈。欲令灌身。自然灌身。欲令还复。水辄还复。调和冷暖自然随意。开神悦体荡除心垢。清明澄洁净若无形。宝沙映彻无深不照。微澜回流转相灌注。安详徐逝不迟不疾。波扬无量自然妙声。随其所应莫不闻者。或闻佛声。或闻法声。或闻僧声。或寂静声。空无我声。大慈悲声。波罗蜜声。或十力无畏。不共法声。诸通慧声。无所作声。不起灭声。无生忍声。乃至甘露灌顶众妙法声。如是等声。称其所闻欢喜无量。随顺清净离欲寂灭真实之义。随顺三宝力无所畏不共之法。随顺通慧菩萨声闻所行之道。无有三涂苦难之名。但有自然快乐之音。是故其国名曰极乐。阿难。彼佛国土诸往生者。具足如是清净色身。诸妙音声神通功德。所处宫殿衣服饮食。众妙华香庄严之具。犹第六天自然之物。若欲食时。七宝应器自然在前。金银琉璃车磲玛瑙珊瑚虎珀明月真珠。如是众钵随意而至。百味饮食自然盈满。虽有此食实无食者。但见色闻香。意以为食。自然饱足。身心柔软无所味着。事已化去时至复现。彼佛国土清净安隐微妙快乐。次于无为泥洹之道。其诸声闻菩萨人天。智慧高明神通洞达。咸同一类形无异状。但因顺余方故有人天之名。颜貌端正超世希有。容色微妙非天非人。皆受自然虚无之身无极之体

佛告阿难。譬如世间贫穷乞人在帝王边。形貌容状宁可类乎。阿难白佛。假令此人在帝王边。羸陋丑恶无以为喻。百千万亿不可计倍。所以然者。贫穷乞人底极厮下。衣不蔽形食趣支命。饥寒困苦人理殆尽。皆坐前世不殖德本。积财不施富有益悭。但欲唐得贪求无厌。不信修善犯恶山积。如是寿终财宝消散。苦身积聚为之忧恼。于己无益徒为他有。无善可怙无德可恃。是故死堕恶趣受此长苦。罪毕得出生为下贱。愚鄙斯极示同人类。所以世间帝王人中独尊。皆由宿世积德所致。慈惠博施仁爱兼济。履信修善无所违诤。是以寿终福应得升善道。上生天上享兹福乐。积善余庆今得为人。遇生王家自然尊贵。仪容端正众所敬事。妙衣珍膳随心服御。宿福所追故能致此

佛告阿难。汝言是也。计如帝王。虽人中尊贵形色端正。比之转轮圣王。甚为鄙陋。犹彼乞人在帝王边。转轮圣王威相殊妙天下第一。比忉利天王。又复丑恶不得相喻。万亿倍也。假令天帝比第六天王。百千亿倍不相类也。设第六天王。比无量寿佛国菩萨声闻。光颜容色不相及逮。百千万亿不可计倍

佛告阿难。无量寿国其诸天人。衣服饮食华香璎珞。诸盖幢幡微妙音声。所居舍宅宫殿楼阁。称其形色高下大小。或一宝二宝。乃至无量众宝。随意所欲应念即至。又以众宝妙衣遍布其地。一切人天践之而行。无量宝网弥覆佛上。皆以金缕真珠百千杂宝奇妙珍异。庄严绞饰周匝四面。垂以宝铃。光色晃曜尽极严丽。自然德风徐起微动。其风调和不寒不暑。温凉柔软不迟不疾。吹诸罗网及众宝树。演发无量微妙法音。流布万种温雅德香。其有闻者尘劳垢习自然不起。风触其身皆得快乐。譬如比丘得灭尽三昧。又风吹散华遍满佛土。随色次第而不杂乱。柔软光泽馨香芬烈。足履其上陷下四寸。随举足已还复如故。华用已讫地辄开裂。以次化没清净无遗。随其时节风吹散华。如是六反。又众宝莲华周满世界。一一宝华百千亿叶。其叶光明无量种色。青色青光。白色白光。玄黄朱紫光色亦然。炜烨焕烂明曜日月。一一华中。出三十六百千亿光。一一光中。出三十六百千亿佛。身色紫金相好殊特。一一诸佛。又放百千光明。普为十方说微妙法。如是诸佛。各各安立无量众生于佛正道

无量寿经卷上佛说无量寿经卷下

        曹魏天竺三藏康僧铠译

佛告阿难。其有众生生彼国者。皆悉住于正定之聚。所以者何。彼佛国中无诸邪聚及不定之聚。十方恒沙诸佛如来。皆共赞叹无量寿佛威神功德不可思议。诸有众生闻其名号。信心欢喜乃至一念。至心回向愿生彼国。即得往生住不退转。唯除五逆诽谤正法

佛告阿难。十方世界诸天人民。其有至心愿生彼国。凡有三辈。其上辈者。舍家弃欲而作沙门。发菩提心。一向专念无量寿佛。修诸功德愿生彼国。此等众生临寿终时。无量寿佛与诸大众。现其人前。即随彼佛往生其国。便于七宝华中自然化生。住不退转。智慧勇猛神通自在。是故阿难。其有众生。欲于今世见无量寿佛。应发无上菩提之心。修行功德。愿生彼国

佛语阿难。其中辈者。十方世界诸天人民。其有至心愿生彼国。虽不能行作沙门大修功德。当发无上菩提之心。一向专念无量寿佛。多少修善。奉持斋戒。起立塔像。饭食沙门。悬缯然灯。散华烧香。以此回向愿生彼国。其人临终。无量寿佛。化现其身。光明相好具如真佛。与诸大众现其人前。即随化佛往生其国。住不退转。功德智慧次如上辈者也

佛语阿难。其下辈者。十方世界诸天人民。其有至心欲生彼国。假使不能作诸功德。当发无上菩提之心。一向专意乃至十念。念无量寿佛愿生其国。若闻深法欢喜信乐不生疑惑。乃至一念念于彼佛。以至诚心愿生其国。此人临终。梦见彼佛亦得往生。功德智慧次如中辈者也

佛告阿难。无量寿佛威神无极。十方世界无量无边不可思议诸佛如来。莫不称叹于彼东方恒沙佛国。无量无数诸菩萨众。皆悉往诣无量寿佛所。恭敬供养及诸菩萨声闻大众。听受经法宣布道化。南西北方四维上下亦复如是。尔时世尊而说颂曰

  东方诸佛国　　其数如恒沙
  彼土诸菩萨　　往觐无量觉
  南西北四维　　上下亦复然
  彼土菩萨众　　往觐无量觉
  一切诸菩萨　　各赍天妙华
  宝香无价衣　　供养无量觉
  咸然奏天乐　　畅发和雅音
  歌叹最胜尊　　供养无量觉
  究达神通慧　　游入深法门
  具足功德藏　　妙智无等伦
  慧日照世间　　消除生死云
  恭敬绕三匝　　稽首无上尊
  见彼严净土　　微妙难思议
  因发无量心　　愿我国亦然
  应时无量尊　　动容发欣笑
  口出无数光　　遍照十方国
  回光围绕身　　三匝从顶入
  一切天人众　　踊跃皆欢喜
  大士观世音　　整服稽首问
  白佛何缘笑　　唯然愿说意
  梵声犹雷震　　八音畅妙响
  当授菩萨记　　今说仁谛听
  十方来正士　　吾悉知彼愿
  志求严净土　　受决当作佛
  觉了一切法　　犹如梦幻响
  满足诸妙愿　　必成如是刹
  知法如电影　　究竟菩萨道
  具诸功德本　　受决当作佛
  通达诸法门　　一切空无我
  专求净佛土　　必成如是刹
  诸佛告菩萨　　令觐安养佛
  闻法乐受行　　疾得清净处
  至彼严净土　　便速得神通
  必于无量尊　　受记成等觉
  其佛本愿力　　闻名欲往生
  皆悉到彼国　　自致不退转
  菩萨兴志愿　　愿己国无异
  普念度一切　　名显达十方
  奉事亿如来　　飞化遍诸刹
  恭敬欢喜去　　还到安养国
  若人无善本　　不得闻此经
  清净有戒者　　乃获闻正法
  曾更见世尊　　则能信此事
  谦敬闻奉行　　踊跃大欢喜
  憍慢弊懈怠　　难以信此法
  宿世见诸佛　　乐听如是教
  声闻或菩萨　　莫能究圣心
  譬如从生盲　　欲行开导人
  如来智慧海　　深广无崖底
  二乘非所测　　唯佛独明了
  假使一切人　　具足皆得道
  净慧如本空　　亿劫思佛智
  穷力极讲说　　尽寿犹不知
  佛慧无边际　　如是致清净
  寿命甚难得　　佛世亦难值
  人有信慧难　　若闻精进求
  闻法能不忘　　见敬得大庆
  则我善亲友　　是故当发意
  设满世界火　　必过要闻法
  会当成佛道　　广济生死流

佛告阿难。彼国菩萨。皆当究竟一生补处。除其本愿。为众生故。以弘誓功德而自庄严。普欲度脱一切众生。阿难。彼佛国中。诸声闻众身光一寻。菩萨光明照百由旬。有二菩萨最尊第一。威神光明。普照三千大千世界。阿难白佛。彼二菩萨其号云何。佛言。一名观世音。二名大势至。是二菩萨。于此国土修菩萨行。命终转化生彼佛国。阿难。其有众生生彼国者。皆悉具足三十二相。智慧成满深入诸法。究畅要妙神通无碍。诸根明利。其钝根者成就二忍。其利根者得阿僧祇无生法忍。又彼菩萨。乃至成佛不更恶趣。神通自在常识宿命。除生他方五浊恶世。示现同彼如我国也。佛语阿难。彼国菩萨承佛威神。一食之顷往诣十方无量世界。恭敬供养诸佛世尊。随心所念。华香伎乐缯盖幢幡。无数无量供养之具。自然化生应念即至。珍妙殊特非世所有。转以奉散诸佛菩萨声闻大众。在虚空中化成华盖。光色晃耀香气普熏。其华周圆四百里者。如是转倍。乃覆三千大千世界。随其前后以次化没。其诸菩萨佥然欣悦。于虚空中共奏天乐。以微妙音歌叹佛德。听受经法欢喜无量。供养佛已未食之前。忽然轻举还其本国。佛语阿难。无量寿佛。为诸声闻菩萨大众颁宣法时。都悉集会七宝讲堂。广宣道教演畅妙法。莫不欢喜心解得道。即时四方自然风起。普吹宝树出五音声。雨无量妙华随风周遍。自然供养如是不绝。一切诸天皆赍天上百千华香万种伎乐。供养其佛及诸菩萨声闻大众。普散华香奏诸音乐。前后来往更相开避。当斯之时。熙然快乐不可胜言。佛告阿难。生彼佛国诸菩萨等。所可讲说常宣正法。随顺智慧无违无失。于其国土所有万物。无我所心无染着心。去来进止情无所系。随意自在无所适莫。无彼无我无竞无讼。于诸众生得大慈悲饶益之心。柔软调伏无忿恨心。离盖清净无厌怠心。等心胜心。深心定心。爱法乐法喜法之心。灭诸烦恼。离恶趣心。究竟一切菩萨所行。具足成就无量功德。得深禅定诸通明慧。游志七觉修心佛法。肉眼清彻靡不分了。天眼通达无量无限。法眼观察究竟诸道。慧眼见真能度彼岸。佛眼具足觉了法性。以无碍智为人演说。等观三界空无所有。志求佛法具诸辩才。除灭众生烦恼之患。从如来生解法如如。善知习灭音声方便。不欣世语乐在正论。修诸善本志崇佛道。知一切法皆悉寂灭。生身烦恼二余俱尽闻甚深法心不疑惧。常能修行其大悲者。深远微妙靡不覆载。究竟一乘至于彼岸。决断疑网慧由心出。于佛教法该罗无外。智慧如大海。三昧如山王。慧光明净超踰日月。清白之法具足圆满。犹如雪山。照诸功德等一净故。犹如大地。净秽好恶无异心故。犹如净水。洗除尘劳诸垢染故。犹如火王。烧灭一切烦恼薪故。犹如大风。行诸世界无障阂故。犹如虚空。于一切有无所著故。犹如莲华。于诸世间无染污故。犹如大乘。运载群萌出生死故。犹如重云。震大法雷觉未觉故。犹如大雨。雨甘露法润众生故。如金刚山。众魔外道不能动故。如梵天王。于诸善法最上首故。如尼拘类树。普覆一切故。如优昙钵华。希有难遇故。如金翅鸟。威伏外道故。如众游禽。无所藏积故。犹如牛王。无能胜故。犹如象王。善调伏故。如师子王。无所畏故。旷若虚空。大慈等故。摧灭嫉心不望胜故。专乐求法心无厌足。常欲广说志无疲倦。击法鼓。建法幢。曜慧日。除痴闇。修六和敬。常行法施。志勇精进心不退弱。为世灯明最胜福田。常为师导等无憎爱。唯乐正道无余欣戚。拔诸欲刺以安群生。功德殊胜莫不尊敬。灭三垢障游诸神通。因力缘力。意力愿力。方便之力。常力善力。定力慧力。多闻之力。施戒忍辱。精进禅定。智慧之力。正念止观诸通明力。如法调伏诸众生力。如是等力一切具足。身色相好功德辩才。具足庄严无与等者。恭敬供养无量诸佛。常为诸佛所共称叹。究竟菩萨诸波罗蜜。修空无相无愿三昧不生不灭诸三昧门。远离声闻缘觉之地。阿难。彼诸菩萨。成就如是无量功德。我但为汝略言之耳。若广说者。百千万劫不能穷尽

佛告弥勒菩萨诸天人等。无量寿国声闻菩萨。功德智慧不可称说。又其国土。微妙安乐清净若此。何不力为善。念道之自然。着于无上下。洞达无边际。宜各勤精进。努力自求之。必得超绝去。往生安养国。横截五恶趣。恶趣自然闭。升道无穷极。易往而无人。其国不逆违。自然之所牵。何不弃世事。勤行求道德。可获极长生。寿乐无有极。然世人薄俗。共诤不急之事。于此剧恶极苦之中。勤身营务以自给济。无尊无卑。无贫无富。少长男女共忧钱财。有无同然。忧思适等。屏营愁苦。累念积虑。为心走使无有安时。有田忧田。有宅忧宅。牛马六畜奴婢钱财衣食什物。复共忧之。重思累息忧念愁怖。横为非常水火盗贼怨家债主。焚漂劫夺消散磨灭。忧毒忪忪无有解时。结愤心中不离忧恼。心坚意固适无纵舍。或坐摧碎身亡命终。弃捐之去莫谁随者。尊贵豪富亦有斯患。忧惧万端勤苦若此。结众寒热与痛共俱。贫穷下劣困乏常无。无田亦忧欲有田。无宅亦忧欲有宅。无牛马六畜奴婢钱财衣食什物。亦忧欲有之。适有一复少一。有是少是。思有齐等。适欲具有便复糜散。如是忧苦当复求索。不能时得思想无益。身心俱劳坐起不安。忧念相随勤苦若此。亦结众寒热与痛共俱。或时坐之终身夭命。不肯为善行道进德寿终身死当独远去。有所趣向善恶之道莫能知者。世间人民父子兄弟夫妇家室中外亲属。当相敬爱无相憎嫉。有无相通无得贪惜。言色常和莫相违戾。或时心诤有所恚怒。今世恨意微相憎嫉。后世转剧至成大怨。所以者何。世间之事更相患害。虽不即时应急相破。然含毒畜怒结愤精神。自然克识不得相离。皆当对生更相报复。人在世间爱欲之中。独生独死独去独来。当行至趣苦乐之地。身自当之无有代者。善恶变化殃福异处。宿豫严待当独趣入。远到他所莫能见者。善恶自然追行所生。窈窈冥冥别离久长。道路不同会见无期。甚难甚难复得相值。何不弃众事。各曼强健时。努力勤修善。精进愿度世。可得极长生。如何不求道。安所须待欲何乐乎。如是世人。不信作善得善为道得道。不信人死更生惠施得福。善恶之事都不信之。谓之不然终无有是。但坐此故且自见之。更相瞻视先后同然。转相承受父余教令。先人祖父素不为善不识道德。身愚神闇心塞意闭。死生之趣善恶之道。自不能见无有语者。吉凶祸福竞各作之。无一怪也。生死常道转相嗣立。或父哭子或子哭父。兄弟夫妇更相哭泣。颠倒上下无常根本。皆当过去不可常保。教语开导信之者少。是以生死流转无有休止。如此之人。曚冥抵突不信经法。心无远虑各欲快意。痴惑于爱欲。不达于道德。迷没于嗔怒。贪狼于财色。坐之不得道。当更恶趣苦。生死无穷已。哀哉甚可伤。或时室家父子兄弟夫妇。一死一生更相哀愍。恩爱思慕忧念结缚。心意痛着迭相顾恋。穷日卒岁无有解已。教语道德心不开明。思想恩好不离情欲。惛曚闭塞愚惑所覆。不能深思熟计心自端政专精行道决断世事。便旋至竟年寿终尽不能得道。无可奈何。总猥愦扰皆贪爱欲。惑道者众。悟之者寡。世间匆匆。无可聊赖。尊卑上下贫富贵贱。勤苦匆务各怀杀毒。恶气窈冥为妄兴事。违逆天地不从人心。自然非恶先随与之。恣听所为待其罪极。其寿未尽便顿夺之下入恶道。累世怼苦展转其中。数千亿劫无有出期。痛不可言甚可哀愍

佛告弥勒菩萨诸天人等。我今语汝世间之事。人用是故坐不得道。当熟思计远离众恶。择其善者勤而行之。爱欲荣华不可常保。皆当别离无可乐者。曼佛在世当勤精进。其有至愿生安乐国者。可得智慧明达功德殊胜。勿得随心所欲。亏负经戒在人后也。傥有疑意不解经者。可具问佛当为说之。弥勒菩萨长跪白言。佛威神尊重。所说快善。听佛经者贯心思之。世人实尔如佛所言。今佛慈愍显示大道。耳目开明长得度脱。闻佛所说莫不欢喜。诸天人民蠕动之类。皆蒙慈恩解脱忧苦。佛语教诫甚深甚善。智慧明见八方上下去来今事莫不究畅。今我众等。所以蒙得度脱。皆佛前世求道之时谦苦所致。恩德普覆福禄巍巍。光明彻照达空无极开入泥洹。教授典揽威制消化。感动十方无穷无极。佛为法王尊超众圣。普为一切天人之师。随心所愿皆令得道。今得值佛。复闻无量寿声。靡不欢喜。心得开明

佛告弥勒。汝言是也。若有慈敬于佛者。实为大善。天下久久乃复有佛。今我于此世作佛。演说经法宣布道教。断诸疑网。拔爱欲之本。杜众恶之源。游步三界无所拘阂。典揽智慧众道之要。执持纲维昭然分明。开示五趣度未度者。决正生死泥洹之道。弥勒当知。汝从无数劫来修菩萨行。欲度众生其已久远。从汝得道至于泥洹。不可称数。汝及十方诸天人民一切四众。永劫已来展转五道。忧畏勤苦不可具言。乃至今世生死不绝。与佛相值听受经法。又复得闻无量寿佛。快哉甚善吾助尔喜。汝今亦可自厌生死老病痛苦恶露不净无可乐者。宜自决断端身正行益作诸善。修己洁体洗除心垢。言行忠信表里相应。人能自度转相拯济。精明求愿积累善本。虽一世勤苦须臾之间。后生无量寿佛国快乐无极。长与道德合明。永拔生死根本。无复贪恚愚痴苦恼之患。欲寿一劫百劫千亿万劫。自在随意皆可得之。无为自然。次于泥洹之道。汝等宜各精进求心所愿。无得疑惑中悔自为过咎。生彼边地七宝宫殿。五百岁中受诸厄也。弥勒白佛。受佛重诲。专精修学。如教奉行不敢有疑

佛告弥勒。汝等能于此世。端心正意不作众恶。甚为至德。十方世界最无伦匹。所以者何。诸佛国土天人之类。自然作善不大为恶。易可开化。今我于此世间作佛。处于五恶五痛五烧之中。为最剧苦。教化群生令舍五恶。令去五痛。令离五烧。降化其意令持五善获其福德度世长寿泥洹之道。佛言。何等为五恶。何等五痛。何等五烧。何等消化五恶。令持五善获其福德度世长寿泥洹之道

其一恶者。诸天人民蠕动之类。欲为众恶莫不皆然。强者伏弱转相克贼。残害杀戮迭相吞噬。不知修善恶逆无道。后受殃罚自然趣向。神明记识犯者不赦。故有贫穷下贱乞丐孤独聋盲喑哑愚痴憋恶。至有尪狂不逮之属。又有尊贵豪富高才明达。皆由宿世慈孝修善积德所致。世有常道王法牢狱。不肯畏慎。为恶入罪受其殃罚。求望解脱难得免出。世间有此目前现事。寿终后世尤深尤剧。入其幽冥转生受身。譬如王法痛苦极刑。故有自然三涂无量苦恼。转贸其身。改形易道。所受寿命或长或短。魂神精识自然趣之。当独值向相从共生更相报复无有止已。殃恶未尽不得相离。展转其中无有出期。难得解脱痛不可言。天地之间自然有是。虽不即时卒暴应至善恶之道会当归之。是为一大恶一痛一烧。勤苦如是。譬如大火焚烧人身。人能于中一心制意。端身正行独作诸善。不为众恶者。身独度脱获其福德度世上天泥洹之道。是为一大善也

佛言。其二恶者。世间人民父子兄弟室家夫妇。都无义理不顺法度。奢淫憍纵各欲快意。任心自恣更相欺惑。心口各异言念无实。佞谄不忠。巧言谀媚。嫉贤谤善。陷入怨枉。主上不明任用臣下。臣下自在机伪多端。践度能行知其形势。在位不正为其所欺。妄损忠良不当天心。臣欺其君。子欺其父。兄弟夫妇。中外知识。更相欺诳。各怀贪欲嗔恚愚痴。欲自厚己。欲贪多有。尊卑上下心俱同然。破家亡身不顾前后。亲属内外坐之灭族。或时室家知识乡党市里愚民野人。转共从事。更相剥害。忿成怨结。富有悭惜不肯施与。爱保贪重心劳身苦。如是至竟无所恃怙。独来独去无一随者。善恶祸福追命所生。或在乐处。或入苦毒。然后乃悔当复何及。世间人民。心愚少智。见善憎谤不思慕及。但欲为恶妄作非法。常怀盗心悕望他利。消散磨尽而复求索。邪心不正惧人有色。不豫思计事至乃悔。今世现有王法牢狱。随罪趣向受其殃罚。因其前世不信道德不修善本。今复为恶天神克识别其名籍。寿终神逝下入恶道。故有自然三涂无量苦恼。展转其中。世世累劫无有出期。难得解脱痛不可言。是为二大恶二痛二烧。勤苦如是。譬如大火焚烧人身。人能于中一心制意。端身正行独作诸善。不为众恶者。身独度脱。获其福德度世上天泥洹之道。是为二大善也

佛言。其三恶者。世间人民。相因寄生。共居天地之间。处年寿命无能几何。上有贤明长者尊贵豪富。下有贫穷厮贱尪劣愚夫。中有不善之人。常怀邪恶。但念淫劮。烦满胸中。爱欲交乱坐起不安。贪意守惜但欲唐得。眄睐细色邪态外逸。自妻厌憎私妄出入。费损家财事为非法。交结聚会兴师相伐。攻劫杀戮强夺不道。恶心在外不自修业。盗窃趣得欲击成事。恐势迫胁归给妻子。恣心快意极身作乐。或于亲属不避尊卑。家室中外患而苦之。亦复不畏王法禁令。如是之恶着于人鬼。日月照见神明记识。故有自然三涂无量苦恼。展转其中。世世累劫无有出期。难得解脱痛不可言。是为三大恶三痛三烧。勤苦如是。譬如大火焚烧人身。人能于中一心制意。端身正行独作诸善。不为众恶者。身独度脱获其福德度世上天泥洹之道。是为三大善也

佛言。其四恶者。世间人民不念修善。转相教令共为众恶。两舌恶口。妄言绮语。谗贼斗乱憎嫉善人败坏贤明。于傍快喜不孝二亲。轻慢师长。朋友无信。难得诚实。尊贵自大谓己有道。横行威势侵易于人。不能自知。为恶无耻。自以强健欲人敬难。不畏天地神明日月。不肯作善。难可降化。自用偃蹇谓可常尔。无所忧惧。常怀憍慢。如是众恶天神记识。赖其前世颇作福德。小善扶接营护助之。今世为恶福德尽灭。诸善神鬼各去离之。身独空立无所复依。寿命终尽诸恶所归。自然迫促共趣夺之。又其名籍记在神明。殃咎牵引。当往趣向。罪报自然无从舍离。但得前行入于火镬。身心摧碎精神痛苦。当斯之时悔复何及。天道自然不得蹉跌。故有自然三涂无量苦恼。展转其中。世世累劫无有出期。难得解脱痛不可言。是为四大恶四痛四烧。勤苦如是。譬如大火焚烧人身。人能于中一心制意。端身正行独作诸善。不为众恶。身独度脱。获其福德度世上天泥洹之道。是为四大善也

佛言。其五恶者。世间人民。徙倚懈惰不肯作善治身修业。家室眷属饥寒困苦。父母教诲。嗔目怒[(應-心)/言]。言令不和。违戾反逆譬如怨家。不如无子。取与无节。众共患厌。负恩违义。无有报偿之心。贫穷困乏不能复得。辜较纵夺放恣游散。串数唐得用自赈给。耽酒嗜美。饮食无度。肆心荡逸。鲁扈抵突。不识人情。强欲抑制。见人有善。憎嫉恶之。无义无礼。无所顾录。自用职当不可谏晓。六亲眷属所资有无。不能忧念。不惟父母之恩。不存师友之义。心常念恶。口常言恶。身常行恶。曾无一善。不信先圣诸佛经法。不信行道可得度世。不信死后神明更生。不信作善得善为恶得恶。欲杀真人斗乱众僧。欲害父母兄弟眷属。六亲憎恶愿令其死。如是世人心意俱然。愚痴曚昧。而自以智慧。不知生所从来死所趣向。不仁不顺。逆恶天地。而于其中。悕望侥幸。欲求长生。会当归死。慈心教诲令其念善。开示生死善恶之趣自然有是。而不信之。苦心与语无益其人。心中闭塞意不开解。大命将终悔惧交至。不豫修善。临穷方悔。悔之于后将何及乎。天地之间五道分明。恢廓窈冥浩浩茫茫善恶报应祸福相承。身自当之无谁代者。数之自然应其所行。殃咎追命无得纵舍。善人行善从乐入乐从明入明。恶人行恶从苦入苦从冥入冥。谁能知者独佛知耳。教语开示信用者少。生死不休恶道不绝。如是世人难可具尽。故有自然三涂无量苦恼。展转其中。世世累劫无有出期。难得解脱痛不可言。是为五大恶五痛五烧。勤苦如是。譬如大火焚烧人身。人能于中一心制意。端身正念。言行相副所作至诚。所语如语心口不转。独作诸善不为众恶者。身独度脱。获其福德度世上天泥洹之道。是为五大善也

佛告弥勒。吾语汝等是世五恶勤苦若此。五痛五烧展转相生。但作众恶不修善本。皆悉自然入诸恶趣。或其今世先被殃病。求死不得求生不得。罪恶所招示众见之。身死随行入三恶道。苦毒无量自相燋然。至其久后共作怨结。从小微起遂成大恶。皆由贪着财色不能施慧。痴欲所迫随心思想。烦恼结缚无有解已。厚己诤利无所省录。富贵荣华当时快意。不能忍辱不务修善。威势无几随以磨灭。身生劳苦久后大剧。天道施张自然纠举。纲纪罗网上下相应。茕茕忪忪当入其中。古今有是痛哉可伤

佛语弥勒。世间如是佛皆哀之。以威神力摧灭众恶。悉令就善弃捐所思。奉持经戒受行道法无所违失。终得度世泥洹之道。佛言。汝今诸天人民及后世人。得佛经语当熟思之。能于其中端心正行。主上为善率化其下。转相敕令各自端守。尊圣敬善仁慈博爱。佛语教诲无敢亏负。当求度世拔断生死众恶之本。永离三涂无量忧畏苦痛之道。汝等于是广殖德本。布恩施慧勿犯道禁。忍辱精进一心智慧。转相教化。为德立善正心正意。斋戒清净一日一夜。胜在无量寿国为善百岁。所以者何。彼佛国土无为自然。皆积众善无毛发之恶。于此修善十日十夜。胜于他方诸佛国中为善千岁。所以者何。他方佛国为善者多为恶者少。福德自然无造恶之地唯此间多恶无有自然。勤苦求欲转相欺殆。心劳形困饮苦食毒。如是匆务未尝宁息。吾哀汝等天人之类。苦心诲喻教令修善。随器开导授与经法。莫不承用。在意所愿皆令得道。佛所游履。国邑丘聚。靡不蒙化。天下和顺。日月清明。风雨以时。灾厉不起。国丰民安。兵戈无用。崇德兴仁。务修礼让。佛言。我哀愍汝等诸天人民。甚于父母念子。今吾于此世作佛。降化五恶消除五痛。绝灭五烧。以善攻恶。拔生死之苦。令获五德升无为之安。吾去世后经道渐灭。人民谄伪复为众恶。五烧五痛还如前法。久后转剧不可悉说。我但为汝略言之耳。佛告弥勒。汝等各善思之。转相教诫如佛经法无得犯也。于是弥勒菩萨合掌白言。佛所说甚善世人实尔。如来普慈哀愍。悉令度脱。受佛重诲不敢违失

佛告阿难。汝起更整衣服合掌恭敬。礼无量寿佛。十方国土诸佛如来。常共称扬赞叹彼佛无著无阂。于是阿难起整衣服。正身西向。恭敬合掌五体投地。礼无量寿佛。白言世尊。愿见彼佛安乐国土及诸菩萨声闻大众。说是语已。即时无量寿佛。放大光明。普照一切诸佛世界。金刚围山。须弥山王。大小诸山。一切所有皆同一色。譬如劫水弥满世界。其中万物沉没不现。滉漾浩汗唯见大水。彼佛光明亦复如是。声闻菩萨一切光明皆悉隐蔽。唯见佛光明耀显赫。尔时阿难即见无量寿佛。威德巍巍如须弥山王。高出一切诸世界上。相好光明靡不照耀。此会四众一时悉见。彼见此土亦复如是

尔时佛告阿难及慈氏菩萨。汝见彼国。从地已上至净居天。其中所有微妙严净。自然之物为悉见不。阿难对曰。唯然已见。汝宁复闻无量寿佛大音宣布一切世界化众生不。阿难对曰。唯然已闻。彼国人民。乘百千由旬七宝宫殿无所障阂。遍至十方供养诸佛。汝复见不。对曰已见。彼国人民有胎生者。汝复见不。对曰已见。其胎生者所处宫殿。或百由旬或五百由旬。各于其中受诸快乐。如忉利天亦皆自然。尔时慈氏菩萨白佛言。世尊。何因何缘。彼国人民胎生化生。佛告慈氏。若有众生。以疑惑心修诸功德。愿生彼国。不了佛智。不思议智。不可称智。大乘广智。无等无伦最上胜智。于此诸智疑惑不信。然犹信罪福修习善本。愿生其国。此诸众生生彼宫殿。寿五百岁。常不见佛不闻经法。不见菩萨声闻圣众。是故于彼国土。谓之胎生。若有众生。明信佛智乃至胜智。作诸功德信心回向。此诸众生于七宝华中自然化生加趺而坐。须臾之顷。身相光明智慧功德。如诸菩萨具足成就。复次慈氏。他方诸大菩萨。发心欲见无量寿佛。恭敬供养及诸菩萨声闻之众。彼菩萨等。命终得生无量寿国。于七宝华中自然化生。弥勒当知。彼化生者智慧胜故。其胎生者皆无智慧。于五百岁中。常不见佛不闻经法。不见菩萨诸声闻众。无由供养于佛。不知菩萨法式。不得修习功德。当知此人。宿世之时。无有智慧疑惑所致

佛告弥勒。譬如转轮圣王别有宫室七宝庄饰。张设床帐悬诸缯幡。若有诸小王子。得罪于王辄内彼宫中。系以金锁。供给饮食衣服床蓐华香伎乐。如转轮王无所乏少。于意云何。此诸王子宁乐彼处不。对曰不也。但种种方便。求诸大力欲自勉出。佛告弥勒。此诸众生亦复如是。以疑惑佛智生彼宫殿。无有形罚乃至一念恶事。但于五百岁中不见三宝。不得供养修诸善本。以此为苦。虽有余乐犹不乐彼处。若此众生识其本罪。深自悔责求离彼处。即得如意。往诣无量寿佛所。恭敬供养。亦得遍至无量无数诸如来所。修诸功德。弥勒当知。其有菩萨生疑惑者。为失大利是故应当明信诸佛无上智慧。弥勒菩萨白佛言。世尊。于此世界有几所不退菩萨。生彼佛国。佛告弥勒。于此世界有六十七亿不退菩萨。往生彼国。一一菩萨。已曾供养无数诸佛。次如弥勒者也。诸小行菩萨及修习少功德者。不可称计。皆当往生

佛告弥勒。不但我刹诸菩萨等往生彼国。他方佛土亦复如是。其第一佛名曰远照。彼有百八十亿菩萨。皆当往生。其第二佛名曰宝藏。彼有九十亿菩萨。皆当往生。其第三佛名曰无量音。彼有二百二十亿菩萨。皆当往生。其第四佛名曰甘露味。彼有二百五十亿菩萨。皆当往生。其第五佛名曰龙胜。彼有十四亿菩萨。皆当往生。其第六佛名曰胜力。彼有万四千菩萨。皆当往生。其第七佛名曰师子。彼有五百亿菩萨。皆当往生。其第八佛名曰离垢光。彼有八十亿菩萨。皆当往生。其第九佛名曰德首。彼有六十亿菩萨。皆当往生。其第十佛名曰妙德山。彼有六十亿菩萨。皆当往生。其第十一佛名曰人王。彼有十亿菩萨。皆当往生。其第十二佛名曰无上华。彼有无数不可称计诸菩萨众。皆不退转。智慧勇猛。已曾供养无量诸佛。于七日中即能摄取百千亿劫大士所修坚固之法。斯等菩萨皆当往生。其第十三佛名曰无畏。彼有七百九十亿大菩萨众。诸小菩萨及比丘等不可称计。皆当往生。佛语弥勒。不但此十四佛国中诸菩萨等当往生也。十方世界无量佛国。其往生者亦复如是甚多无数。我但说十方诸佛名号及菩萨比丘生彼国者。昼夜一劫尚未能竟。我今为汝略说之耳

佛语弥勒。其有得闻彼佛名号。欢喜踊跃乃至一念。当知此人为得大利。则是具足无上功德。是故弥勒。设有大火充满三千大千世界。要当过此。闻是经法。欢喜信乐。受持读诵。如说修行。所以者何。多有菩萨。欲闻此经而不能得。若有众生闻此经者。于无上道终不退转。是故应当专心信受持诵说行。吾今为诸众生说此经法。令见无量寿佛及其国土一切所有。所当为者皆可求之。无得以我灭度之后复生疑惑。当来之世经道灭尽。我以慈悲哀愍。特留此经止住百岁。其有众生值斯经者。随意所愿皆可得度

佛语弥勒。如来兴世难值难见。诸佛经道难得难闻。菩萨胜法诸波罗蜜。得闻亦难。遇善知识闻法能行。此亦为难。若闻斯经信乐受持。难中之难无过此难。是故我法如是作如是说如是教。应当信顺如法修行

尔时世尊说此经法无量众生皆发无上正觉之心。万二千那由他人得清净法眼。二十二亿诸天人民得阿那含。八十万比丘漏尽意解。四十亿菩萨得不退转。以弘誓功德而自庄严。于将来世当成正觉。尔时三千大千世界六种震动。大光普照十方国土。百千音乐自然而作。无量妙华芬芬而降。佛说经已。弥勒菩萨及十方来诸菩萨众。长老阿难诸大声闻。一切大众闻佛所说靡不欢喜

无量寿经卷下


佛说无畏授所问大乘经卷上

    No. 331 [Nos. 310(28), 330]

佛说无畏授所问大乘经卷上

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

如是我闻。一时世尊。在舍卫国祇树给孤独园。与大苾刍众千二百五十人俱。皆是阿罗汉。诸漏已尽无复烦恼。心善解脱慧善解脱。如大龙王所作已办。弃诸重担随得己利。尽诸有结。正智解脱。诸心寂静皆到彼岸。唯一补特伽罗。所谓阿难

复有五百大菩萨众。悉得一切陀罗尼门及三摩地门。皆是一生补处。时舍卫城有一长者。名无畏授。大富自在有大财宝。积诸受用库藏充满。金银琉璃真珠珊瑚螺贝宝等。皆悉具足。广有车乘象马牛羊。复多眷属奴婢仆从执事人等及诸朋友。一时无畏授。与五百长者。而共集会潜相谓言。诸仁者。遇佛出世斯为难事。人身难得时难契会。于佛教中净信极难。舍家出家成苾刍相。此亦为难。修行复难。彼诸有情知恩念报。而复甚难。但能少分施作尚不坏失。何况广多。又诸有情。若于如来教中能生净信。信已复能依教修行。极为难事。又诸有情。若能庄严如来教法。复能解脱轮回极为难事。是故我等。不应于声闻乘及缘觉乘中趣求涅槃。应于无上大乘法中趣求涅槃。于是众会以如是事。互言议已。咸悉发起广大胜心。皆言我今悉于无上大乘法中趣求涅槃。不乐声闻缘觉之乘。时无畏授与五百长者俱共围绕。出舍卫城诣世尊所。到已头面礼世尊足。右绕七匝退坐一面

尔时世尊。知是事已故。谓无畏授等五百长者言。汝诸长者以何缘故。来诣如来应供正等正觉所

时无畏授等五百长者。悉从座起。偏袒一肩右膝着地。向佛合掌顶礼白言世尊。我等向者共会一处。潜相谓言。遇佛出世斯为难事。人身难得时难契会。于佛教中净信极难。舍家出家成苾刍相此亦为难。修行复难。彼诸有情知恩念报而复甚难。但能少分施作尚不坏失。何况广多。又诸有情。若于如来教中能生净信。信已复能依教修行。极为难事。又诸有情。若能庄严如来教法。复能解脱轮回。极为难事。我等今时不应于声闻乘及缘觉乘中趣求涅槃。应于无上大乘法中趣求涅槃。世尊我等以如是事互言议已。咸悉发起广大胜心。皆于无上大乘法中趣求涅槃。不乐声闻缘觉之乘。我等乘此缘故。来诣如来应供正等正觉所。世尊诸菩萨摩诃萨。欲证阿耨多罗三藐三菩提者。当云何住。复云何学。云何修行

尔时世尊。赞无畏授等五百长者言。善哉善哉。汝诸长者甚善甚善。汝今能为安住阿耨多罗三藐三菩提。故来诣如来应供正等正觉所。汝等谛听极善作意。今为汝说。时无畏授等五百长者受教而听

佛言诸长者。若菩萨摩诃萨。欲证阿耨多罗三藐三菩提者。如其所住当如是学如是修行

又若菩萨摩诃萨。欲证阿耨多罗三藐三菩提者。应于一切有情起大悲心普遍亲近。广为摄受观察施作。而菩萨摩诃萨。于自身命不应爱着。所有舍宅妻子眷属饮食衣服乘驭床座珍宝财谷香华灯涂。乃至一切受用乐具悉不应着。何以故。多诸有情爱着身命故。广造罪业。彼彼所作业成熟已。堕在恶趣地狱中生。若于一切有情起大悲心。于自身命不爱着故。即于一切善趣中生。诸长者。是故菩萨摩诃萨。欲证阿耨多罗三藐三菩提者。于一切有情起大悲心。于自身命不生爱着。所有舍宅妻子眷属饮食衣服乘驭床座珍宝财谷香华灯涂。乃至一切受用乐具。悉不爱着已。然后自舍一切广行惠施。不求果报安住戒行。三相清净修诸忍辱。堪能具足一切有情。于己所作不饶益事。悉能忍伏。被大精进坚固甲胄。若身若命悉能弃舍。安住寂静心一境性。远离散乱胜慧决择诸善法分。不起我人众生寿者士夫补特伽罗意生等见。广为一切作诸胜行。为一切有情作意行施。为一切有情作意护戒。为一切有情作意行忍。为一切有情作意发起坚固精进。为一切有情作意安住诸胜定门。为一切有情作意修慧。为一切有情习学一切善巧方便

尔时无畏授等五百长者俱。白佛言世尊。我等昔来于自身命皆生爱着。所有舍宅妻子眷属饮食衣服乘驭床座珍宝财谷香华灯涂。乃至一切受用乐具悉生爱着。世尊菩萨摩诃萨。作何观察能于身命乃至一切受用乐具。不生爱着。愿佛为说

尔时世尊。告无畏授等五百长者言。菩萨摩诃萨。以无数种相观察于身。何等无数。所谓此身不实缘法。合集如极微聚。从顶至足次第破坏。彼九窍门及诸毛孔。不净流溢犹如蚁聚。蛇毒止中蛇毒违害。如怨敌如猿猴。多所损恼。如极恶友常起诤竞。身如聚沫不可撮摩。又如水泡旋有即坏。又如阳焰渴爱所生。又如芭蕉中无坚实。又如幻化从虚妄起。又如王者多种教令。又如怨对常来伺便。又如盗贼无有信义。又如杀者极难调制。如恶知识常不欢喜。如破法者隐没慧命。又如邪朋减失善法。又如空聚离于主宰。又如瓦器终归破坏。如小便坑不净充满。如大便处常多滓秽。又如食啖诸不净鬼及蛆虫狗等乐臭秽中。又如广积秽物远闻其臭。如恶疮疱难合其窍痛不可忍。又如毒箭入身酸楚。如恶家主难为侍养。又如朽舍及如漏船。虽假修治旋归散坏。又如坯器难为固惜。又如恶友常假将护。如河岸树风所动摇。如大河流终归死海。又如客舍多种违恼。如无主舍无所摄属。如巡警人常专捡察。及如边方多所侵娆。如积沙处渐当减下。如火蔓延。如海难渡。如地难平。如蛇置箧随生损害。又如婴儿常须存爱。又如破器无所堪用。如恶方处常虞坏乱。如杂毒食常当远离。如求乞人得种种物得已旋弃。又如大车负极重等。唯诸智者。于法觉了应如是知

佛说无畏授所问大乘经卷上佛说无畏授所问大乘经卷中

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣法护等奉　诏译

复次长者菩萨摩诃萨。观察此身。最初何因之所成立。谓依父母精血合集生起彼因。复由受其饮食。食已变坏旋聚即散。归淡荫藏淡荫流润。终归不净。然后火大增强煮变成熟。后归风力。由其风力各分滓重及与流润。滓重所谓大小便等。流润谓血。血变成肉。肉成于脂。脂成于骨。骨成其髓。髓成其精。精等乃成此不净身。菩萨观此不净身故。乃起思惟。此身多种合集。各别名相。谓三百骨。六十肪及膏相。合四百膜。五百肉团。六百脑。七百脉。九百筋。十六肋骨。复有三事。内缠其肠分生熟藏肠。有十六交络而住。二千五百脉道透映。一百七节。八十万俱胝毛孔。具有五根。九窍。七藏。不净充满。髓有一掬脑。有一掬脂。有三掬淡荫。六掬滓重。六掬风力。随遍血有一斗。如是一切各各充满。有七水脉。而复围绕。吸诸滋味。内火大增炽然烧煮。逼切疲极。身脉汗流。是等诸相极难可见。此之臭秽不净体相。是中云何起增上爱。如求丐人得所用物。得已旋弃。又如大车负极重等。唯诸智者于法觉了。应如是知即说颂曰

  此身多种不净聚　　愚无智者不了知
  强起增长爱着心　　如秽瓶破多秽气
  耳目口鼻皆秽物　　彼等何者为香洁
  涎眵结聍及涕洟　　诸虫杂恶何生爱
  譬如愚者取于炭　　勤力摩治欲令白
  炭尽力疲白莫成　　无智妄贪亦如是
  如人意欲成洁净　　多种修治于此身
  百转沐浴及香涂　　身坏命终归不净

尔时世尊复告无畏授等五百长者言。长者当知。菩萨摩诃萨欲证阿耨多罗三藐三菩提者。观察此身有四十四相。何等四十四。谓菩萨摩诃萨观察此身诚所厌弃。菩萨观身不可爱乐。以不饶益故。菩萨观身极为臭秽。脓血满故菩萨观身甚不坚牢。终破坏故。菩萨观身体性羸劣。筋骨相联故。菩萨观身不净。秽恶常流故。菩萨观身如幻。愚夫异生强起虚妄动乱相故。菩萨观身多所漏失。以九窍门常流注故。菩萨观身炽然烧爇。谓贪火所焚嗔火猛聚痴火暗冥故。菩萨观身贪嗔痴网。常所盖覆爱网相续故。菩萨观身窍穴所依。以九窍门及诸毛孔周遍流注杂秽充故。菩萨观身多种逼恼。四百四病常增损故。菩萨观身是为窟宅。八万四千户虫之所聚故。菩萨观身无常。终归死法故。菩萨观身无知。于法不知故。菩萨观身如器用。众缘合成终破坏故。菩萨观身逼切。众多忧恼故。菩萨观身无归趣。毕竟老死故。菩萨观身深隐。谄诳所行故。菩萨观身如地。难平满故。菩萨观身如火。以所爱色随系着故。菩萨观身无厌足。随五欲故。菩萨观身破坏。烦恼对碍故。菩萨观身无定分位。以其利衰现所受故。菩萨观身无自他缘。不得源流故。菩萨观身驰流心意。以种种缘作意伺察故。菩萨观身弃背毕竟。归于弃尸林故。菩萨观身为他所食。鹫鸟豺狼等食啖故。菩萨观身如轮盘影现。筋骨连接故。菩萨观身无所顾惜残弃漏失。脓血满故。菩萨观身耽着滋味。饮食所成故。菩萨观身勤苦无利。以是无常生灭法故。菩萨观身如恶友。起诸邪妄故。菩萨观身如杀者。重重现增苦故。菩萨观身为苦器。三苦逼恼故。所谓行苦坏苦苦苦。菩萨观身为苦聚。五蕴随转无主宰故。菩萨观身极不自在。种种缘成故。菩萨观身无寿者。离男女相故。菩萨观身空寂。诸蕴处界所合成故。菩萨观身虚假。以如梦故。菩萨观身不实。以如幻故。菩萨观身动乱。如阳焰故。菩萨观身驰流。如响应故。菩萨观身虚妄所起。如影现故。长者。菩萨摩诃萨以如是等四十四相观察于身。而菩萨摩诃萨作此观察时。所有于身乐欲。于身顾惜。于身执我。于身爱染。于身积集。于身系着。一切悉断。由是于命乐欲。于命顾惜。于命执我。于命爱染。于命积集。于命系着。乃至舍宅。妻子眷属。饮食衣服。乘驭床座。珍宝财谷。香华灯涂。一切受用乐具。若乐欲。若顾惜。若执我所。若爱染。若积集。若系着。一切亦断。由于身命能弃舍故。乃至一切爱用乐具亦悉弃舍。如是乃能圆满六波罗蜜多。长者。菩萨摩诃萨以能圆满波罗蜜多故。即能速证阿耨多罗三藐三菩提

尔时世尊欲重宣此义即说颂曰

  应知人身极难得　　莫因此身造众罪
  豺狗取食弃尸林　　空将此身为残弃
  愚无智者常动乱　　虚伪身中起贪爱
  此身难驭违背深　　昼夜受苦无停息
  此身苦轮常生病　　此身不净广充盈
  饥渴随逐娆恼深　　谁诸智者生爱着
  此身如地广无主　　及如恶友愚生爱
  因此身故众罪兴　　毕竟还自受诸苦
  此身不同金刚坚　　莫因此身广造罪
  智者应修胜福因　　于佛教中生净信
  此身不久徒存养　　衣服香严饮食资
  缘归破坏暂任持　　邪勤施作何空过
  经百劫中难得遇　　大牟尼尊出世间
  速于佛教净信生　　莫于恶趣受极怖
  假使寿千俱胝岁　　彼尚勿应生贪爱
  何况寿不满百年　　岂生贪爱无厌足
  或有一类奢侈者　　不念此身极难得
  广集嬉戏歌伎人　　于前戏剧求快乐
  度集财宝何有乐　　护惜重重苦恼增
  下劣愚夫喜悦生　　智者于中离贪着
  富贵不实如梦幻　　愚者驰流于心意
  刹那破坏刹那成　　谁诸智者生贪爱

佛说无畏授所问大乘经卷中佛说无畏授所问大乘经卷下

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

  譬如幻所成物像　　如乾闼婆城庄严
  愚人贪爱富亦然　　不知是妄生耽着
  百种苦求于财富　　得已极苦逼于身
  王官水火散坏时　　智者岂生于爱着
  妻子眷属随所爱　　广作诸罪当破坏
  极重过失不觉知　　智者于身不生着
  悭吝者求财富时　　父母亦不生尊重
  妻子眷属返憎嫌　　一向常贪于财利
  悭者不知于恩义　　唯念莫坏我所有
  背正向邪谄求财　　智者于彼不生信
  悭者意异语如实　　所应信者不生信
  见人虽将爱子同　　此是悭者谄妄起
  悭吝之者在世间　　虽亲典教亦通解
  驰流散乱出恶言　　心无悲愍极粗犷
  悭者处世无所托　　亦无知识及亲朋
  有所依附但求财　　智于悭者不生信
  悭者因求财富故　　于极恶事起思念
  是故智者正所观　　愚人于彼生欢喜
  金宝珠贝珊瑚等　　善业引生如聚沫
  于中贪爱诤竞兴　　彼不了知幻化性
  贤劫一佛出世时　　彼尊立名为慈氏
  偏覆大地得黄金　　彼从何来何因故
  于外随逐五欲境　　愚人散乱痴迷法
  如日中分夏月时　　渴欲奔驰焰为水
  空后一劫成世间　　虚空所成空自性
  焚烧破坏复还成　　此从何来彼何去
  沟涧池沼及大海　　枯涸破坏彼皆同
  虚假不实贪亦然　　谁诸智者生爱着
  智者慧力色相具　　于身常自作称量
  此中无味染何因　　舍宅财利应弃舍
  随逐五欲造恶业　　养育妻子并眷属
  死时妻子及诸亲　　谁能救护自当苦
  死时眷属不随去　　但随自作众业行
  苦恼逼逐于己身　　彼时谁为我分受
  三有独怖无亲爱　　妻子眷属假相亲
  愚人取以为乐因　　但增苦恼及忧戚
  父母妻子亲朋聚　　为求财利故相会
  彼等不随死者行　　唯自所作业相逐
  一切皆随业所行　　一切亦随业所住
  当知此身业所成　　智者应修于善业
  父母妻子眷属等　　以不了知故贪爱
  愚人广造众罪因　　智者不入无间狱
  所有余处业报尽　　无间极苦不解脱
  是故畏彼恶趣因　　智者勤劬离诸罪
  阎摩王前治罚时　　彼无朋友为救护
  亦无父母及诸亲　　随自所作业当受
  王言汝所得人身　　得已何不离诸罪
  今受极苦捶打时　　皆由汝作不善业
  自心所作不善已　　而复不信有业报
  如彼阎摩法王言　　汝受治罚非我罪
  自作业因自造罪　　自造罪已汝来此
  当受极苦自甘心　　由先所作非爱业
  死时众苦所逼迫　　亲属不能令解脱
  汝欲自求解脱时　　是故应离诸罪恶
  打击考掠及杻械　　此等若欲求远离
  舍宅亲友起怖心　　于佛教中修正行
  舍宅猛火大苦根　　而此心火常炽然
  智者于斯爱不生　　如大火聚极可怖
  住舍养亲常忧戚　　富乐忧愁亦复然
  自他过失等无差　　是故应离诸罪恶
  智者佛教生信乐　　不种自收胜乐根
  愚者不生爱乐心　　但贪舍宅诸苦本
  女身筋肉骨合集　　假起妄贪为我妻
  诸无智者染爱生　　不知女身都如幻
  智者了知诸欲乐　　及舍宅等皆生厌
  正法药治贪病除　　速疾出离诸缠缚

尔时无畏授等五百长者闻是正法已。悉得无生法忍。得法忍已。皆生最上踊跃欢喜。即说颂曰

  快哉于今日　　我等得大利
  彼一切利中　　此利益最上
  我等所发起　　广大菩提心
  于佛正法中　　清净生渴仰
  所起胜爱乐　　无上菩提心
  为一切有情　　广施诸安乐
  我等从今日　　极甚其身命
  誓于此深经　　生最上爱乐
  由起爱乐故　　得一切有情
  于彼当来世　　见者生欢喜
  彼一切有情　　诸欲发心者
  皆发起无上　　广大菩提心
  若一切有情　　爱乐菩提心
  当得胜果报　　最上金色身
  相好以庄严　　种种胜殊妙
  及得大光明　　世间广照耀
  无上菩提心　　此心广大心
  胜出一切心　　最上复清净
  彼一切功德　　由此心具足
  复具大胜力　　能脱一切病
  诸鲜福有情　　不乐菩提心
  此心懈退因　　不能观生死
  菩提神通智　　获最胜福力
  广积满虚空　　普施诸情品
  若人于河沙　　等数诸佛刹
  满以七珍财　　供养正等觉
  若人但合掌　　归向菩提心
  此胜供养因　　超过诸供养
  此供养无等　　所谓菩提心
  过此外无余　　为最胜最上
  菩提心功德　　是胜妙良药
  一切病能治　　施有情安乐
  观见诸有情　　三火常烧然
  无量劫拔除　　菩萨不懈退
  修此菩提行　　为勇猛医王
  救苦诸有情　　常远离疲懈
  数数往诸趣　　不舍菩提心
  勤于佛法中　　出现希有相
  我等得大利　　乐此菩提心
  愿我等当成　　大觉释师子

尔时世尊从其面门出现广大神通光明无数种色。所谓青黄赤白及紫碧绿。是光普照无边世界。上彻梵世。映蔽日月光明不现。其光旋环右绕世尊百千匝已。却从世尊顶门而入。尔时尊者阿难即从座起。偏袒一肩右膝着地。向佛合掌顶礼白言。世尊。何因何缘现是光明。若无因缘。如来应供正等正觉不放光相。时尊者阿难即说颂曰

  佛上胜者若无因　　法尔不现光明相
  愿为悲愍劣有情　　说放光明何因故
  一切有情皆贫乏　　佛应为施大圣财
  世间暗暝作照明　　愿说此光所因现

尔时世尊。告尊者阿难言。阿难。汝今见此五百长者不。悉为发阿耨多罗三藐三菩提心故。来诣我所。阿难白佛言。唯然已见。佛言阿难。是五百长者。今此会中闻正法已皆得无生法忍。阿难。此诸长者皆于过去佛所。奉近供养深种善根。从此没已不复堕诸恶趣。生人天中受胜妙乐。次第至彼慈氏如来应供正等正觉出现世时。生彼佛刹亲近供养尊重承事。其后乃至贤劫诸佛彼彼出世时。于一一佛所亲近供养。听受正法读诵记念广为人说。最后过二十五劫。于种种佛刹。皆当成就阿耨多罗三藐三菩提果。同名莲华吉祥藏如来应供正等正觉。出现世间。尔时尊者阿难前白佛言。今此广大甚深正法。希有世尊希有善逝。此经何名。我等云何奉持。佛言阿难。是经名为菩萨瑜伽师地法门。亦名无畏授所问。如是名字汝当受持

佛说此经已。尊者阿难等诸大声闻。及诸菩萨摩诃萨众并五百长者。世间天人阿修罗等一切大众。闻佛所说。皆大欢喜信受奉行

佛说无畏授所问大乘经卷下


佛说须赖经a

    No. 329 [Nos. 310(27), 328]

佛说须赖经

        前凉月氏国优婆塞支施仑译

闻如是。一时世尊。游于舍卫祇树给孤独园。与大比丘众俱千二百五十人。菩萨五千人。尔时世尊。游近舍卫大城。为国王大臣梵志长者及诸细民。供养世尊给所当得。尔时城中有极贫者名曰须赖。信佛法众奉持五戒修行十善。奉行慈心终不起心。于一切众生。行于悲心志不疲极。行于喜心常乐正法。行于护心苦乐不动。坚固无上正真道心。以方便善欲度人故。居舍卫城示现极贫

于是释提桓因。以天眼净彻视于人。见舍卫城中极贫须赖。执坚固德善行纯备心无恚怒。执志坚强无有瑕秽。坐起经行不失威仪。出入周旋常怀等行。饮食坐卧常怀等心。左右睡寐已皆除尽。少欲知足易充易可。损于利求利衰毁誉心不倾动。至心坚固离于贡高。摄持谦顺心靖纯淑。质直善说言信不华。奉八关斋知节少食。普城所敬无有厌足。诸造见者与之说事莫不欢喜。食节衣粗。又致供者让而不受。树叶为器茅草为席。衣食之余辄以转施无所藏积。清净洁白离于求业。于一切生无所志愿。常以昼夜各三诣佛。如来常开闭瑕容其。礼拜供养咨受法言。若其须赖欲诣佛时。若干百人常从与俱。若其须赖所游居处若行若住若坐若卧。其地界分无有空闲人众围绕

于是释提桓因取心念言。如是族姓子。净戒淳淑善行威仪。恐子将夺我处。当下试知审求何道。于是释化作数人住须赖前。骂詈须赖言不顺理。又以瓦石刀杖加害。于是须赖以其忍力专行慈心不嗔不恚。于是释提桓因。复化作人住须赖前。谓须赖言。唯然须赖。如是人等骂詈无限言不顺理。又以瓦石刀杖加汝。若仁见听为汝杀之。须赖答言。莫说是语。所以者何。不善谗人者杀生之报。正使彼等刀割我身[邱-丘+石]如跋跙树。尊尚不发恶意加于彼等。所以者何。一切诸法报应有二。种善者生善道。种恶者堕恶道。以是故我不敢恨彼。况欲断彼命。于是须赖。说是偈言

  其种于苦者　　必生获苦果
  其有种恬者　　必生得恬果
  如此报应者　　是知为现事
  恶者报应苦　　善者报应乐
  是故不当三　　为恶身口心
  是故有智者　　不当以劝人
  当常行三善　　于是身心口
  常以此劝彼　　若人乐善者

于是释所化人不能动须赖。于是舍去。于是释提桓因。于须赖前化作七宝金宝现须赖前。复化作众人。住须赖前谓须赖言。取是金宝可用布施亦可作福。可以作服饰卧具。亦可好衣亦可美食。云何守是贫行。须赖报言。前之恶行。诸仁者。我之此报令我如今贫鄙。然不能守是贫。当犯不与取也。惟须赖。宜可乐活尽寿。何为乃远虑后世之报以为言说。须赖报言。诸仁者。是为愚法。夫见法者虑是重报。能虑重报者。是则为明达。不明之士。悭贪他有犯不与取。能离悭贪则为明智。夫不智者贪得多积以护身命。无所护虑则为明达。于无常有常想。于苦有乐想。无我有我想。不净有净想。如是者犯不与取。观无常计苦计空计不净者。是则为明智。计吾我猗居家。是者犯不与取。不计我不犯他。如是辈则明智。无先饱不知足。如是辈犯不与取。先饱知足是则明智。不净戒者犯不与取。其净戒者是则明智。不见报应愚痴之士犯不与取。见报应者是则明智。夫饕餮者犯不与取。不饕餮者则为明智。图他所有贡高躁扰犯不与取。让一切有则为明智。当于是时则说偈言

  伏藏至千亿　　彼不闻舍心
  如是世之贫　　是则非明智
  家无一食储　　而有舍施心
  如是为大富　　明智者所叹
  圣贤善显现　　而能不为恶
  愚叹加严饰　　为恶则不显
  愿为智所骂　　不为愚所叹
  愚者叹于恶　　明者叹于善

天所化诸士。不能令须赖犯不与取。于是释化已为长者形。持名上宝价直百千。住须赖前。谓须赖言。我于王波斯匿前有所诤讼引仁为一证。以宝相与。愿仁为我证。须赖谓言。仁者莫作是说。我不能以不知故而作妄言。何以故。妄言人者。为自欺身亦欺他人。欺诸圣贤。妄言人者。令人身臭心口无信令其心恼。夫妄言人者。令其口臭令身失色天神所弃。夫妄言人者。亡失一切诸善本。于己愚冥迷失善路。夫妄言人者一切恶本。断绝善行闲居之本。于是时说此偈言

  夫口臭秽者　　妄言者语时
  忘失清白法　　意志多妄误
  为护己诸神　　圣贤所欺误
  彼士常羸疲　　夫喜妄言者
  诸恶之根本　　断善本于彼
  必当趣恶道　　夫妄言人者
  若以满天下　　金真珠相与
  夫守持法者　　不为之发言

释提桓因。不能使须赖妄言便舍去。于是释提桓因。谓阿须伦女首耶日行王女。识干执乐第一夫人法。汝等诣国贫须赖动其闲居。试知为审离欲为故服欲不耶。于是首耶阿须伦女日行王女。识干执乐第一夫人。于冥夜静时。于须赖所止地之分界。行诣于彼说温暖甜辞。与须赖言。起仁者。我等故来相事且观。须赖。我等形容之严好。涂栴檀香璎珞被服。鲜明适在盛时视此。须赖。以汝之福故得我等执事。须赖视已便作是说。汝等尽是地狱饿鬼畜生行事。非天人之执事。又观汝等身如幻化之自然。观汝等之形聚沫泡之相。栴檀香之涂我观其如是。审谛法聚会不净向所娆服严净。见如是幻化所作。心之躁疾合会愚。所观无常散灭法。以己福观汝等行趣地狱类。所以失志六不护己志欲何不明不净者。是则贪于欲。附臭处者。是则贪于欲。附秽恶者是则依于欲。纯荷诸苦者是则贪于欲。谓贪欲乐者是则附于欲欲。入地狱者是则附于欲欲。入畜生者。彼则附于欲欲。入饿鬼者。是则附于欲欲。亲恶人者。是则附于欲。不成就贪者。是则附于欲。斗诤怨讼会者。是则附于欲欲。被系闭者。是则附于欲。颠倒之所生增益爱结者。是则附于欲。狂悖迷惑者是则附于欲。醉乱闇冥者是则附于欲。不善之所近善之所舍离。一切诸不善之所缠缚者。是则附于欲。迷失径路者是则附于欲。修行不善者是则附于欲。羸劣夺人力者是则附于欲。云之所覆者是则附于欲欲。近鬼魅者是则附于欲欲。近返足鬼者。是则附于欲欲。近牛驴狗猪驼象羖羊豺者。是则附于欲欲。近非人者是则附于欲欲。离戒闻施者是则附于欲。放舍闲居者是则附于欲。专惑专冥专益劳尘。专损减于无上道者。是则附于欲。当于是时便说偈言

  臭秽不净者　　欲腐亦如是
  专苦不附乐　　狱鬼畜生处
  与不消者会　　欲丑亦如是
  处非法之处　　诤讼与怨恶
  系缚之缚者　　颠倒之所生
  爱欲所增益　　从是所生者
  是则附于欲　　迷惑之所惑
  和协与同尘　　是则附于欲
  烧然之景热　　合会成众恶
  毁灭于众善　　诸恶之根元
  如云之所盖　　附欲亦如是
  鬼魅之同处　　反足亦如是
  形色之所惑　　视欲亦如是
  牛羊狗犬猪　　驼象羖羊豺
  附欲之所亲　　离于一切法
  或闻施斗靖　　零落附于欲
  专惑增劳尘　　损减无上道
  是则附于欲　　欲脱者离色
  如汝满天下　　妙容胜汝等
  不能污吾意　　诸功德备悉

首耶阿须伦女日行王女。识干之夫人。不能动须赖皆舍而去。诣释提桓因。诣彼已勿疑也。天帝彼已见谛无复女色。彼已离于欲。普于世无著。于是释提桓因。益增惊恐衣毛为竖。无疑也族姓子。必从于我生。于是释提桓因。自往诣须赖。已住须赖前。叉手说偈言

  发何愿仁者　　汝行如是法
  闲居清白戒　　日月释梵帝

于是须赖。说偈答言

  日月释梵帝　　三界之上业
  此皆无常存　　如幻之示现
  云何明智者　　当着三界耶
  所可无生长　　亦无老病死
  亦无有憎爱　　所处平如秤
  愿普安一切　　成佛觉未觉

于是释提桓因。即欢喜踊跃。善心生焉。劝仁普慈心。如是之言说。善哉当成就。如是无上愿。速降伏众魔。雨于甘露法。为行众生故。必成世普愍于是国贫须赖。彼于异时。行于舍卫大城之中。便于城中。得先时人瑞应天金之珠价直普世宝。于是国贫须赖。提持珠已便举声。令于舍卫诸仁者。于是城若有极贫者。当以是直普世之宝而惠与之。彼时有旧长者居家贫者皆走驰诣。我等极贫以宝见惠。又复余人数百之众。亦从乞宝我等极贫。须赖答。汝等不贫。所以者何。于足舍卫大城之中有一极贫者。当以是金珠宝而惠与之。诸人答言。于是城中有谁极贫。答言。王波斯匿是极贫者。当以是宝而惠与之。诸人答言。止止须赖莫说是语。所以者何。王波斯匿者。丰富大财其业周普仓藏盈积。于是国贫须赖。于大众前。便说偈言

  财业虽丰广　　而不知充饱
  大海尚可满　　是贫终不足
  若增益贪求　　展转无休息
  现世及后世　　如是贫无智

于是国贫须赖持是金珠已。与诸大众围绕周匝。诣王波斯匿。当于尔时王波斯匿。以财宝故收上族姓子五百长者。为之设罪欲薄其财义。于是国贫须赖。持是金珠诣王波斯匿。诣已便谓王言。我行舍卫大城之中。得往古人瑞应金珠价直普世。大王。我便生意。欲以是宝与极贫者。以是故大王。如我所忆念是城中惟王极贫。善哉大王唯受是宝。于是王波斯匿便有惭颜。谓国贫须赖言。我贫于汝耶。于是国贫须赖。于大众前。为王波斯匿。便说偈言

  夫以贪缚者　　增业而不饱
  为王造损耗　　热己亦热彼
  不顾于后世　　无德不计死
  如是不贪耶　　以法故明者
  善立成大慈　　不成长尘劳
  知足无所欲　　彼贪不复生
  若见于众生　　即生大悲心
  以是无怨嫌　　如是富大财
  善处闲居士　　贪富贵之士
  如不获于法　　于下贫众生
  一切从众邪　　好于女色乐
  不顾当来世　　王如是贫者
  已属于女人　　其信清不浊
  戒禁净无瑕　　性和怀惭愧
  舍决常安住　　闻法从圣贤
  往往慧入心　　后世舍恶趣
  如是不贫士　　以法自校饰
  手终不舍施　　身寿业不要
  不从道趣要　　寿或于世行
  或犹如醉象　　如是之贫士
  无有志性故　　若有信佛宝
  法宝敬圣众　　身命业不要
  不要易取要　　不恚亦不愚
  立志乐不惑　　如是士不贫
  明智者所敬　　必性无饱足
  梦烧不舍步　　众流无充足
  昼夜流入海　　日月无充饱
  周行于四域　　王贪无终饱
  积财不饱终　　大王火性者
  不求烧草本　　此是其常数
  亦如是大王　　于三无所烧
  王富贵无常　　其喻如草露
  谁当愿求王　　闻如是说者

于是王波斯匿。谓国贫须赖言。我贫于卿谁当证是。大王不闻耶。如来无所著等正觉。一切知一切现。所知审诚信立所证。审于一切诸世人阿须伦。游于是舍卫大城。须赖。我亦曾闻见是者。大王。如来为我证王贫甚于我。以是故须赖当往问如来。如彼所决便当奉持。于是国贫须赖。说偈言

  我师行不违　　我今于是念
  彼知乘空来　　于彼无不知
  今世及后世　　心心俱知已
  大儒当至此　　彼亦无贡高
  愍一切众生　　虽远必当来
  众生至心故　　我唯愿大王
  必信意莫疲　　当立至诚誓
  世尊必当来　　华鬘及众香
  幢幡及伎乐　　大儒如是来

须赖叉手。右膝着地。说偈言

  若佛审谛知　　我定至心者
  以是至诚故　　若知立我前

说是言已于是地动。如来忽然化从地出。五百弟子。菩萨千二百。释梵护世者诸天数百万。见佛现神叹未曾有。王及大臣一切眷属皆跪礼胜足。数千众生供养世尊皆发道意。于是国贫须赖。叉手白世尊言。我行是舍卫大城中。得往古人瑞应金珠价直普世。以是故世尊。于是城中若有贫者当以与之。世尊。我谓是舍卫城中王波斯匿即是极贫。何以故。侵克他有不知厌足。贪于财宝不谛于诚实。娆恼下贫减损富有者。专于王势爱着色欲。以是金珠与之。王不肯受问我。以证我贫仁富。唯愿如来无所著等正觉。以一切智一切慧所知审为信审为称审别为一证。善哉世尊。等心于一切。去离贡高无所偏党愿说是义。于是世尊。告王波斯匿。审实大王如须赖言审尔。世尊审尔安住。于是世尊欲决须赖疑。告王波斯匿王。有缘大王富于须赖复有缘理。须赖富于大王。彼何等为缘。所谓王业尊贵之利。营从金银珠玉。水精琉璃真珠珊瑚。象马车乘仓藏储珍。以是因缘大王富于须赖。若复大王。施与戒闻舍无著闲居之德。慈悲喜护禅定解脱三昧正受。信佛法众坚固之志直信惭愧有行。以是因缘大王须赖富于王。假令大王所部人民。财宝富有皆如大王。以比此族姓须赖。行七步中间戒闻施智。百倍不及千倍不及。巨亿万倍。不得为比。于是王波斯匿。摄除贡高白世尊言。甚得善利安住。而我界内有是大士。世尊言。如是大王。如是大王。王之界内有是大士。又复大王。又复多有余大士在王国界如须赖者。王波斯匿。于须赖前说偈言

  仁是我之师　　佛亦我之师
  缘仁除贡高　　今以国相上
  愿与营从俱　　为仁之弟子
  为贡高所欺　　使于斯长夜
  为王位所惑　　不行于道法
  今闻须赖言　　蒙仁当行法
  今是五百人　　吾以贪故系
  今悉放舍之　　愿属仁侍使

此五百人。闻得解脱已欲报须赖恩。灭意不顾业无所复顾应。以誓自誓立一切智心。于是王波斯匿。谓须赖言。我贫仁不贫。须仁所言是为快善。其称须赖贫谪以犯王法。是须赖者但当名须赖。不得复称贫。于是族姓子须赖即从坐起。更整衣服右膝着地。叉手白佛言。是诸大众普会欲见如来。善哉世尊。为是大众如是说法。令是大众不忘见佛。佛告须赖言。族姓子。有四法具足受持。若族姓子族姓女。见如来者审见善见。何谓四法。至心爱心悦心敬心是为四。复有四。何谓四。是须赖。族姓子族姓女。见如来色像成就。便发无上正真道意。至心发意不违如来意。爱念众生欲永度脱故。欲使奉法故。欲使三宝不断故。以是四法故。须赖。族姓子族姓女。具足见如来成其审见善见。复有四法。族姓子族姓女。见于如来成其审见善见。何谓四。色痛想行识行无所视见。观四大等空。诸情如空聚。我想觉知。以是四事。族姓子族姓女。成其审见善见。复有四法。族姓子族姓女。见佛甚洁净。净于我离我故。净于众生离众生故。净于寿离寿故。净于命离命故。以是四法具足。族姓子族姓女。见如来甚洁净复有四。何谓四。天眼无所作为。慧眼无所著行。佛眼如审觉寤。法眼如知所现。是为四法。复有四法。族姓子族姓女。见如来甚洁净。何谓四。净于戒品无所连着。净于定品以诸法定故。净于慧品以度世智等故。净于解慧度智见品善解脱解脱无所度故。以是四法具足故。见如来甚洁净。当其说是四事次第法化时。七百弟子发意。以弟子乘而得解脱。具满千众生发无上正真道意。于是世尊。为王波斯匿及诸大众。说是法教训皆令欢喜踊跃。便从坐起。与菩萨及诸大弟子。以神足力乘于虚空犹如雁王。还到祇树给孤独园。于是王波斯匿。谓族姓子须赖言。若如仁者诣如来时愿见告敕。己欲侍从可尔。时王亦愿。大王后宫婇女及诸大臣大众围绕俱往见佛。于是舍卫大城之中立普施限。不诣佛者使有过讁。所以者何。又复大王。菩萨立行不独为己故。菩萨立行欲安一切众生故。又复大王。菩萨不以一人二人故而发道意。大聚大众以为将从于是显好。又问何谓菩萨之将从。一切则是菩萨将从。欲济度脱之故。发道意者是菩萨之将从不独小乘而转进故。心坚固者是菩萨之将从。欲摄伏一切谀谄众生之故。无怀之心是菩萨之将从。欲着异之行转进之故。无犹豫之心是菩萨之将从。不亭等转故。布施之心是菩萨之将从。摄怀嫉众生故。持戒之心是菩萨之将从。摄恶戒众生故。忍辱之心是菩萨之将从。摄持躁扰众生之故。精进之心是菩萨之将从。摄持懈废众生故。禅定之心是菩萨之将从。摄持乱意众生之故。智慧之心是菩萨之将从。摄持一持恶智众生之故。慈心大王是菩萨之将从。心存不舍众生故。悲心是菩萨之将从。入于生死不患厌故。喜心是菩萨之将从。以法乐乐于众生故。护心是菩萨之将从。憎爱俱灭等行之故。四恩者大王。是菩萨之将从。诸法无家而等行故。种种善本报应是菩萨之将从。相好智慧充满具足故。誓愿洁净是菩萨之将从。净佛国土故。三脱是菩萨之将从。止宿甘露门之等行故。诚信不两舌恶口妄言绮语是菩萨之将从。无违逆辞之等行故。柔软甘辞是菩萨之将从。应辩报答等行之故。无所娆乱是菩萨之将从。于一切众生无丑貌故。多闻具足舍以转受是菩萨之将从。志念无忘等之故。尊敬师长是菩萨之将从。未闻之法令人闻知。受持正法等行之故。舍家之心是菩萨之将从。如所作无有损减等行之故。闲居之心是菩萨之将从。白黑之法坚守护之故。威仪之心是菩萨之将从。不望于他有所受故。净德无染是菩萨之将从。以甘善本等行之故。洁净之心是菩萨之将从。无信众生以立其信等行之故。无放恣心是菩萨之将从。一切佛道品法。具足充满等行之故。于是王波斯匿。闻是说已欢喜踊跃善心生焉。以好名衣上服若干色彩。其价百千奉上须赖。供养法故以法故受。彼不肯受而说是言。止止大王。是王所服。所以者何。我自有弊服补纳之衣。有时大王。我之此弊衣。挂树一日或至七夜。无有取者亦无贪者。我起游行无顾惜意。以是故大王。凡衣服者但以盖形。使已无著意又令彼不贪。王波斯匿。谓族姓子须赖言。如汝须赖不受是衣者。愿以足履。令我长夜得福安隐。于是族姓子须赖。使足蹈是名服百千价衣。慈愍于王波斯匿故。于是王波斯匿。谓族姓子须赖言。是之名服。仁以足蹈何置之。对曰大王。是之名服。舍卫城中有诸贫穷孤独可以与之。于是王波斯匿。敕其左右卿等持衣。往于是舍卫城中。有诸贫穷孤独羸老便以与之。唯然大王。国中若干众人及诸贫穷者。闻王波斯匿以百千价衣若干种色与须赖已。而以惠施城内城外普来集聚。于舍卫城百千亿众生。皆适得是百千价服已皆服着之。适服着已善心生焉。我当以何等报是须赖而为供养。承佛威神又须赖所建立。便于空中而现声言。不以香华及涂香。不以甘肴膳。而可以报须赖无过发道意。须赖。不以衣食故。亦不利供养叹誉名德故。但以度众生及发道意故。顺从彼教者当行道之智。于是族姓子须赖便从坐起。与王波斯匿俱后宫婇女臣吏大众人众围绕前后。出舍卫城行诣祇树给孤独园。舍卫大城之中人众十亿国中贫人。闻族姓子须赖往见如来。念须赖恩悉皆从行。以佛威神。释提桓因从舍卫城至给孤独园。于其中间化作场地。广普杂婇妙好如忉利天。昼度之宫若干校饰。又化若干种宝树。于树下化作师子座。高妙坚固高千肘。以若干百千天缯敷其上文绣杂彩。阿须伦女首耶之后万玉女俱而侍卫。皆持天华天香鼓乐弦歌。供养如来师子之座已为供养。于是世尊。知众人已会。与诸菩萨及大弟子。出于祇树行诣于严净师子座。诣已于师子座结跏趺坐。如来适坐于师子之座。于是三千大千世界六种震动。现十八瑞动而复动而复大动。于是释提桓因子瞿或在会中坐。于是瞿或天子。化作六万座。天之所化。已请诸菩萨使各诣坐。便说偈言

  唯坐诸净　　士于是坐　　座是善本
  疾得佛座

诸菩萨愍瞿或天子故便坐其座。于是般若识干执乐王子。谓日行王女言。汝往与是五百天乐俱。同音歌叹佛德。俱供养世尊师子之座。须赖未来之顷。所以者何。族姓子须赖。功德巍巍将从众多。当见如来者则不审。汝等于是日行王女般若识干执乐王子之后。作五百乐往诣如来已皆稽首佛足。手执乐器。皆同一音叹世尊德。而歌颂曰。世尊往古百劫修闲居行。世尊普调众生使乐布施。世尊身口及心乐持净戒。愿礼体如须弥山。世尊忍慈固不劳。世尊精进坚力如树。世尊神慧之光无所不作。愿礼三垢无垢。世尊已胜贪淫嗔恚愚痴之垢。世尊所作已办愿礼三界所应供养。此诸垢污魔女。自如来见已。以无垢目心得安隐。成就佛念舍离于欲。不复触近于欲。乐问于如来除心之垢。莫使有劳垢意者欢悦众生意。愿礼彼足训世二百相胜。璎珞百福功德满。善音于众生所往净。愿礼无比神难及神天金软足。行步师子之云。与所往行化因释胎生。今所叹德百福满。愿使众生心普悦无疲惓。所叹胜之德愿令疾得叹是者。于是族姓子须赖。与王波斯匿及王后宫。与诸大众眷属围绕。诸天百千之所歌叹。行诣世尊已。稽首世尊足于一面住。王波斯匿。稽首如来足各绕三匝于一面住。于是王波斯匿。以其仁座而让须赖而说此言。唯族姓子。垂恩矜愍坐此仁座。须赖便坐于彼仁座。于是众中。有诸天子未见须赖者。见是贫人有何功德为王见敬乃如是耶。于是释提桓因知诸天子意。谓诸天子言。莫起慢意于是仁者。而令诸仁功德损减长夜不安。所以者何。我其审谛是族姓子大功德善法充满。又诸天子且待须臾。观其功德善法具足。于是族姓子须赖。欲悦诸天子意。便白佛言。唯然世尊。现说菩萨大士济度众生之严好。智之严好。示现严好。具足充满。疾成无上正真之道。是时世尊。以如是像放身光明照须赖身。适触身已。族姓子须赖蒙佛光明。是时须赖身逾释提桓因数千万倍。须赖之身姝好如是。于是诸天子见须赖身姝好如是。甚大欢喜便礼须赖。而以天华散敬其上。于是世尊。告族姓子须赖言。菩萨处贵而现卑贱欲度人故。是则名曰智之严净。而以威仪悦可众生。可众生已便现其行久现神通。是智严净。又族姓子。菩萨大士意得自在示现极贫。为诸梵志诸人所敬。是为严净。又族姓子。若其菩萨示现下贫感厉外学。除其贪意现处大业。又现舍家欲以导示厌家众生故。是为严净是为须赖。是菩萨净于众生智慧严净精进严净之具足也。疾成无上正真之道。于是阿难。白世尊言。是族姓子。发行已来久远。云何而为如来所光饰乃如是乎。于是世尊。告阿难言。是族姓子阿难。往世具足多供养诸佛数亿百千。行诸度无极所行之行。而以神通用为娱乐。已得三忍已得应辩。以方便善度众生故示现极贫。于是阿难白世尊言。族姓子须赖。示现贫行以度众生其数几如。世尊告曰阿难。欲天七千色天万二千。皆发无上正真道意。度世人无数发道意者及生善处。又问久如当成无上正真之道。得道之时名号云何。其佛世界严净何类。于是世尊。欲叹族姓子须赖国土严净。便说偈言

  阿难听我称　　诸世之将导
  以成众生故　　高广弘普称
  发于行大乘　　其劫无限数
  从始初发意　　行善行以来
  奉事于诸佛　　及其所供养
  为诸法之长　　常拥护之故
  智所往往行　　于诸度无极
  神通自娱乐　　长夜行四等
  善学方便善　　其见生死秽
  明审于佛法　　善学相纯淑
  知众生之本　　随本度脱之
  以意智所行　　住于甚清净
  已得应机辩　　住于诸总持
  已度于魔钩　　诸佛之威仪
  坚住而不动　　无所污染着
  度世之八法　　利衰现总持
  无所于诸法　　不远亦不近
  喻如虚空性　　其心无所著
  无有疲厌意　　常行大悲心
  坚固住总持　　以被慈德铠
  如于己之慈　　于众生所然
  终不怀嫌恨　　犯者不校问
  如其所应受　　迎待而不避
  口言行无违　　诸法普学法
  如其解脱相　　二法俱解脱
  三忍具足得　　于行无所起
  诸佛之所行　　威仪善建立
  于诸土行行　　多饶益众生
  彼方则不定　　而无有如来
  须赖所行处　　如供养世尊
  敬亦当如是　　诸天及世人
  我灭度之后　　后世法尽时
  须赖于行彼　　东方之世界
  其土名妙乐　　如来名无怒
  当从彼来还　　余三阿僧祇
  于其数不减　　于是已之后
  续当勤行道　　当严净国土
  欲度众生故　　彼于是劫后
  当成其胜道　　号光世音王
  土如阿閦佛　　如来之世界
  世界名善化　　众德悉备具
  安住寿万岁　　处于世教化
  僧数喻无限　　少发小乘者
  求大乘无限　　普知神通力
  凡夫愚闇垢　　善化普清净
  彼当普令称　　一法化教诲
  彼无魔牵连　　普等清净智
  导世灭度后　　正法住于世
  八万四千岁　　法慧不隐藏
  须赖所化众　　承奉道高行
  一切当生彼　　除置漏尽者

当为族姓子须赖解说决时。一切众会各各以衣覆须赖上。劝助之声三千大千世界莫不普知。以其劝助之声。无量无数诸天龙鬼干沓和阿须伦迦留罗真陀罗摩休勒人及非人。应声皆至聚会而坐。供养族姓子须赖。世尊亦为是等。以是法化因缘种种说法。皆令谛解于三乘行。于是王波斯匿。住世尊前。叉手白世尊。我狂醉王位。狂醉财业。狂醉荣贵。狂醉库藏金银仓谷。悭贪无厌。逼迫众生以为国财。如我世尊。世世以如是像处位施行之法化。皆从族姓子须赖闻已。我为极贫须赖所决。今于世尊前舍置于国。以琉璃太子立为王子。当奉戒当许身。为世尊及诸众僧守园给使。所有财宝当为三分。一分于佛前奉上众僧。二分与诸贫穷孤独。三分以为王事之储。谁复世尊。闻如是像法处位教化。当有意着于财业者也。为愚痴恶友所摄持者乃有着意。我以是所作善本惠施众生。愿发无上正真道意。于是会中五百长者五百居士五百梵志五百臣吏。闻王波斯匿作如是像师子之吼。皆发无上正真道意。舍家财业。欲于世尊之化舍家入道。会中三百人。其余皆现为比丘僧。已除须发服着袈裟。于是族姓子须赖。即从坐起更整衣服右膝着地。向世尊叉手白佛言。愿从世尊及十方现在诸佛受舍于家。于是族姓子须赖。稽首十方诸佛世尊而发愿言。诸佛世尊听许入道。于是诸佛各伸右掌。摩须赖头适触其头。须发皆堕法衣着身威仪安庠。于是三千大千世界六反震动。放大光明普照十方雨于天花。是诸佛臂皆不相障。世尊释迦文伸金色臂摩须赖头。彼诸发道意者见是现化。是辈皆当为诸佛之所授决。当说是法。时五百比丘发弟子乘皆得无著。满千菩萨皆得不起法忍。尔时世尊。告长老阿难言。受是法化奉持诵说。周满敷演广大众生。所以者何。是五浊世。众生浊。劳垢浊。寿命浊。邪见浊。时劫浊。佛兴世非是其时。欲度此等故使须赖示现极贫。所以者何。我不以如此忍界之仪。而示现一人不度也。以是故阿难。当现是法布示众生。此众生等当信是法当从解脱。当如是等为如来所化。佛告诸弟子。善念奉持。族姓子须赖。及王波斯匿。释提桓因。长老阿难。诸天龙鬼。及阿须伦及世间人。闻佛所说莫不欢喜。稽首而去

佛说须赖经


佛说须赖经b

    No. 328 [Nos. 310(27), 329]

佛说须赖经

        曹魏西域沙门白延于洛阳白马寺译

闻如是。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人及五千菩萨俱。尔时舍卫城中有极贫者名曰须赖。得坚固志不可转移。信佛法众身归三尊。奉持净戒修行十善。有四等心救济不倦。内性清净我乐无二。至意求佛无上大道。思惟所行昼夜诵习。以善方便导利人物。安贫自守以法为乐。于是天帝释以天眼见须赖功德殊妙。所闻不惑博览众经。无有邪行坐起安庠。行止卧觉不失仪法。少欲易足不贪利养。质直善说言信不华。斋戒省约食节衣菅。树叶为器茅草为席。不畜遗除无所藏积。国王人民莫不敬爱。常以昼夜各三诣佛咨受法信。佛知其意辄与相见。须赖每诣佛时。无数百人常从与俱。其所游至卧起经行。天人营护。天帝释自念言。是仁者戒行纯备。恐子将夺我处。当下试知审求何道。释便化作数人。蹴骂须赖言无忌讳。又以石掷捶杖加之于须赖。须赖忍力慈仁不嗔不怨。释便化作数人。谓须赖言。仁实见在我谓为卿杀之何如。须赖答言。子所谋者非善法也。正使彼人刀割我身尚无恨意。况但挝骂。所以者何。夫罪福有二果。种福者生天上。为罪者堕恶道。是故不当恨何况欲害彼。于是须赖即说偈言

  夫以种恶栽　　故生堕罪类
  若其种善本　　后必望福果
  觉恶以谛观　　当持慧分别
  恶栽非善本　　种德无恶果
  守三能无恶　　身口意常善
  上人忍无怨　　智者受不犯
  除三以清净　　身口意无瑕
  劝行福德者　　得愿必常安

化人不能使国贫。须赖有微害意。于是乃退。天帝释复以金银置其前。使化人谓须赖言。仁者取是宝。可用恣意布施作福亦可。好衣美食贫何可堪。须赖言。自我宿行不。亦当受斯贫苦。以贪宝妄取。后困必甚。化人言。且自欢娱快意终身。安知后事。须赖答言。此非慧语。或于一身不有远虑后受大罪。智者所畏。贪得多藏取非其有罪与盗等。智者所耻。爱身计寿自保不死。犯不与取智者不为。夫智者计身命无有常万物非我有。所贵唯道故无贪诤守善而已。又说偈言

  藏宝至千亿　　不施死时悔
  智者谓是贫　　宜识此至言
  节食不着味　　诚信而好施
  有慧虑为富　　佛说是常安
  能止不为恶　　守道中外清
  无戒而自严　　已犯斯非贤
  当受明为师　　勿用愚所誉
  愚誉牵入冥　　师明益近净

化人不能使须赖有贪意。即退去。天帝释复化。持真珠价直数亿。诣须赖言。我与人诤讼事闻国王。窃引仁者为证。愿以此珠相上。幸助一言。须赖答言。用为说此是我所畏。终不敢欺。所以者何。妄言者先为自欺。次为欺天。亦为欺法。令其口臭。言不见用。多被诽谤。心恒憔悴。天所不念。身色变福德消善名废。彼为上世圣贤所挠欺。失德本而生众恶。塞善之路自投邪冥。是为后世招致殃罪。又说偈言

  众欺生恶果　　自致口常臭
  都已忘前言　　入邪无正道
  自欺亦欺天　　欺法是自怨
  常为众所疑　　欺诈何益人
  欺为众恶本　　自绝善行业
  是故致痛聚　　妄言何益人
  设以满天下　　金银珠相与
  至守法诫者　　何时为宝欺

化人不能使须赖妄语。即时退去。天帝释还语夫人言。汝试将我妓女。与数琴般遮翼妇俱。见须赖共转其意坏其清行知有淫无。天后受教即从妓女。夜安静时。到须赖所住虚空中。作靡丽之辞言。仁者且起。天使我曹来侍左右。我曹形容既好。衣裳鲜明。璎珞珠宝服栴檀香。不老不少适在上时。端政皎洁可不瞻视。卿福所致故来相事。须赖仰头答言。若曹尽是地狱畜生饿鬼所爱。非彼天人上智所乐。我见若曹所有。如梦色像香。实如海泡沫。我见若形骨干。肉涂血浇筋缠。革裹皮覆以蔽污沾。譬如工师幻人目耳。汝曹上时我见无常。当就坏败为分离法。罪福我已觉。无毛发之爱念。若曹实坏人善心。不能成立人意。但污净行。若曹即连臭腐。习欲无乐坐致苦痛。自误堕冥入三恶道。欲非善本。斗讼恐恚。颠倒浊乱皆从欲起。痴狂致灾坐彼形残。外集内热不见福果。以亡人本种畜生类。后为牛马骡驴骆驼犬彘鸡鹅皆欲所致。违远圣贤亡失信戒闻施慧道。随欲一念不顾后世。是欲常坏求道之意何况其余。即说偈言

  欲污为臭腐　　独痛远安乐
  自掷饿鬼罪　　无虑常附恶
  无便为乱本　　远法去就误
  不虑致颠倒　　欲盛痴益置
  贪憎失善意　　邪念常恐惊
  内忧如外胐　　坐欲亡信根
  已为不善本　　如魃食人肝
  居衰事邪神　　为欲如痴狂
  淫为牛羊猪　　驴马象骆驼
  长受兽形苦　　是故慧舍欲
  弃信戒闻德　　远自投恶道
  为淫人痴网　　远女常疾脱
  如汝好形辈　　满此阎浮利
  一心住如山　　天神安能倾

时天后及妓女。不能使贫须赖有淫意。即还天宫。为天帝释说偈言

  子学深见谛　　说知女态恶
  已舍色无欲　　无疮不受毒

于是天帝益怖衣毛为竖。念是仁者诫净不邪必夺我处。便自下诣须赖说偈问言

  须赖欲求何　　诫净健乃尔
  愿说望帝王　　日月释梵耶

于是须赖答释偈言

  帝王日月天　　释梵虽为尊
  无常皆如幻　　未脱彼何明
  所欲乐不生　　无有老死患
  憎爱怨苦际　　愿度三界人

天帝意解欣然大悦。即说偈赞须赖言

  善哉愍世间　　疾解得如愿
  当除三世垢　　天人必蒙恩

于是须赖。经行舍卫城市。便于市中得先劫宝价当是世。即以手持而举声言。今是舍卫国有极贫者。吾以此宝而惠与之。尔时国内有故长者。乃昔富贾合数千人。应机悉走到须赖前。各自陈言。我等困穷惟见矜济。又有极贫无数之辈。亦皆驰至从乞求宝。须赖答言。诸贤不贫。今是城中有贫极者。吾以此宝当往与之。众人问言。观此城中谁极贫乎。须赖答言。王波斯匿国之最贫。众人言。勿宣是语。帝王何常而有贫者。度王宫藏珍琦不可呰计。须赖以偈答众人言

  虽多积财宝　　欲得求无厌
  如水昼夜流　　是辈犹为贫
  贪增不念苦　　邪行意不惭
  从此到彼世　　是为极贫困

于是须赖。与大众人民俱到王宫门。时王波斯匿在正殿。适收五百余长者。皆当有罪。王欲使多出财宝以赎其罪。傍臣白王须赖在外。王即请与相见。须赖入谓王言。我往日经行舍卫城市。得此明月珠意欲与贫者。观省此国之极贫者。莫甚于王。愿大王受是宝。王闻其言有惭愧色。答言。须赖我贫熟与卿同。须赖言。王贫甚于我。王言。愿说其意。须赖于大众前。为王说偈言

  夫财日夕贪无厌　　为君造害后烧痛
  自保不死不惟后　　是谓极贫无法行
  常有慈心不懈慢　　远色近贤而知足
  不好多求不畜积　　是生为智无怨恶
  居位舍正而为非　　以财恐民施刑法
  在安忘危快所欲　　欺人死困悔无及
  直信清净识者强　　节如知止闻不忘
  常知不恐乐在行　　是谓不贫圣所称
  夫已富贵不念施　　谓命可常坏在今
  贪浊迷惑如醉象　　意塞不觉是谓贫
  信佛法众行恭敬　　恕己安人善教诲
  不愚不恚不放恣　　以法自御为常富
  火烧草木不知足　　众流归海无满息
  日月不疲照四域　　贪至老死不厌欲
  火虽盛热不久燃　　富贵无常如浮云
  故慧不愿天及王　　慧意烧恶无复烟

王波斯匿谓须赖言。谁当证明我贫仁富。须赖答言。大王亦闻。世有如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。所见已谛。能现证要。今者不远。近在祇树给孤独园。王曰。我已厚禄得见此尊。须赖言。是圣师可以为证。王曰。愿请佛来如佛所断当以为正。于是须赖即说偈言

  佛慧悉遍见　　不须大王请
  今我意所念　　已见必哀来
  神通圣无漏　　世作后所受
  佛无不定智　　必来王莫疑
  常等无憎爱　　愍伤人非人
  虽远在他方　　但念其法言
  我愿大王信　　佛为慈悲主
  于是至意念　　世雄来不久
  豫出香华宝　　珠缨缯盖幡
  众妓调五音　　供佛当鲜明

须赖即叉手偏袒右肩。下两膝跪伏地。遥向佛说偈言

  佛悉知人意　　照见诸至诚
  愿称听至意　　现神住我前

于是地即大动。佛与五百比丘二百菩萨。化从地中出王殿上。释梵四天王无数百千天。悉从佛而来。王及吏民见佛现神。莫不悚然。加敬稽首佛足。若干千人。从敬发意愿为菩萨。于是国贫须赖。前礼佛足却住。白佛言。我行此城中得明月金珠。价直一阎浮利。念欲与贫者。观省是国独王极贫。所以者何。贪欲无厌。赋检不息娆恼不息。一国民为疲极迫强役羸。中伤至直。下有劳扰。上为欲缚。不念非常不顺正治。是故我献此明月珠不肯受。反诘我以贫富之证。是故愿见如来。无不开导无所不护。析疑除垢愿解此义。佛言。富哉须赖。言语至诚。大王勿疑。王曰。唯然世尊。以正真之言启发蒙冥。佛以善权方便。将护王意现其义言。王且谛听。亦有因缘计王所富。须赖无有。亦有要义计须赖富。王不能及。所谓王之富者。计有国财金银璧玉水精琉璃真珠珊瑚车磲玛瑙象马宫殿。所有饶裕治得自在。此王之富。须赖无有。当计须赖道德正相。布施戒具忍力精进。慧不放逸善行有叙。慈悲喜护爱敬三宝。学深意净直信惭愧。七财满具。是须赖富。王不能及。正使大王所部国界。人民悉富如释摩男。合此人财以比须赖道德之富。百分千分巨亿万分。计所不能及。是不可以譬喻为比。王言。善哉善哉。如世尊言。我已有福。我国界中乃有持法上富之人。佛言然亦多有真人在王界内。于时王波邪匿起住佛前。赞须赖言

  我尊仁与佛　　由仁我绮雅
  愿以国相上　　自今仁为师
  久已憍慢戒　　坐国远正法
  今闻须赖语　　愿详修梵行
  用贪财利故　　怨五百人系
  今赦贪无益　　念仁恩难忘

于是五百系人闻王赦其罪。皆念须赖恩。厌非常苦得无欲意。悉起礼佛。又礼须赖。王意欢喜重赞言

  仁富我实贫　　须赖言妙真
  今下令国中　　不得言仁贫

国人闻王令后。皆称须赖为富。无复贫名。须赖起正衣服。右膝着地叉手白佛言。今是大众集会。善哉世尊。愿说法语。使此众人不空见佛。佛言。善哉听我所说善思念之。有四法族姓子为见佛。何等四。为信为乐为悦为敬。是为四。复有四法。可得见佛。何等四。已见佛色像便起道意。自愿后世得身如是。以至意思念佛言常至诚。已悲哀诸人物。意不复动。已乐所履行不断三宝。是为四。复者四法为觉意。何等四。谓色。痛想行识。无所视所见转空。所想即知。是为四。复有四法见佛向净。何等四。不计彼我为内外除。不计常在为除寿命。不计断灭为舍习行。以佛眼见觉常眠意。是为四。复有四法见佛向净。何等四。一切法无此取。以正定为净行。已学成无上智。善权见净脱。是为四。族姓子族姓女。已见如来为向清净。佛说是时。七百比丘意解无漏。坐中菩萨皆得不起法忍。无数千人皆立德本。佛说经已。便从座起。与诸弟子及诸菩萨。现神飞去如凤凰王。还到祇树给孤独园

于是王波斯匿谓须赖言。仁者欲诣佛时。愿相告敕身欲随往。须赖言。亦愿大王敕诸后宫太子官属。并国吏民不诣佛者。使有司记其罪。所以者何。菩萨不但忧身忧人非人。菩萨在大众中威神倍好。王言。愿闻菩萨将从大众。为之奈何。须赖答言。一切众生菩萨皆能合会以为从者。谓以布施众人乐从。能转悭者使好布施。菩萨持戒众人乐从。化诸不信令信罪福。菩萨忍辱众人乐从。化诸嗔恚令无结恨。菩萨精进众人乐从。化诸无势令建精进。菩萨行禅众人乐从。化诸乱意令守一心。菩萨智慧众人乐从。化诸愚痴令得正智。菩萨行慈众人乐从。化诸不仁使有慈心。菩萨行悲众人乐从。入生死苦不厌正行。菩萨行喜众人乐从。化忧迷者能使乐法。菩萨行护众人乐从。安慰劝助使人入法。如是大王德行非一。又有四事为善受人。一曰护众生不违舍。二曰众德本行清净。三曰择好愿令佛国无三毒。四曰空不愿无思想。出诸魔网所拘制。菩萨常行柔软。化诸刚强不忘大乘。乐居山泽。不以毁断先世福德。善本日增普修众行。周满道法三十七品。菩萨以是合取人民。王波斯匿。欣然大悦善心生焉。王身所著彩衣。价直千万以上须赖。须赖不受言。大王意悦与受何异。王意不乐。须赖复言。我自有[卄/((女/女)*干)]衣着之甚悦。当用是忧衣为。王曰何故。须赖答言。我有时脱衣挂树舍。行一日或至七日。无贪取者。我亦无惜意。不顾望此衣。菩萨常服如此辈衣。既自无著意。又使彼不贪。王曰。愿仁愍念。足行衣上。使我长夜得福无量。须赖称王意。为蹈衣上。王曰。此衣已属须赖。吾将安置。须赖答言。大王。宜视此国中形露不蔽者。可以衣与之。王即敕左右。持此衣出赐诸贫穷人。诸贫穷人共得王彩衣。皆欢喜念须赖。当何以报其恩须赖至意。以佛威神空中有声。而说偈言

  不以香华宝　　甘快诸美食
  欲报此慈恩　　但当起道意
  至人不贪贵　　不乐诸奇异
  欲报当求佛　　大乘四等意

于是须赖。以日跌时与大众人。王亦与后宫一切宫属吏民俱行诣佛。是时舍卫清信士清信女。合十亿众。及得赐彩衣贫民。闻须赖当到佛所。皆悉从行。时天帝释。下从舍卫来至祇树。于中间化作大殿如忉利天宫。化作七宝树。于树下为佛设师子座方圆自副。以若干种缯敷其上。令万二千妓女罗住其边。作百种音乐。以为供养佛。佛知大众具至。即起到大殿。坐天师子座。佛身放光明照天地。空中散华其堕如雨。天帝释告子言拘。或吾为佛设座。汝可为诸菩萨真人作座。太子即化作六万余座悉严好。以天五彩之毡。已说偈言

  真人诸菩萨　　愿来坐此座
  是化天所乐　　常愿会佛前

诸菩萨大弟子坐已定。时般遮翼天。敕其天人。孚调五百余琴。令音调好进歌佛须赖。来者必有尊天俱主。我曹当退。即时调诸意。如歌颂言

  智行过百劫　　智盛施无量
  智戒摄身口　　当礼无上圣
  人忍无所犯　　精进人力强
  仁开定慧门　　当礼三界雄
  明断淫怒痴　　已尽灭无瑕
  自得复授彼　　当礼天人师
  慧观除三爱　　不贪世间荣
  恬惔无忧畏　　当礼是法王
  魔天进三女　　道意不为倾
  无著不可污　　当礼是至清
  奇相三十二　　众好自严身
  八声无不闻　　当礼天中天
  行地印文现　　无畏威远震
  齿齐肩间回　　当礼释中神
  我赞十力王　　檀独欢喜诚
  自归佛得福　　愿后如世尊

尔时须赖。从大众人民。亦若干千天人。俱到佛所。皆礼佛足各坐一面。王波斯匿与其所从。前礼佛足却住一面。于是王手自取床。谓须赖言。愿仁坐此座。诸天众中未见须赖者。念是贫人有何功德。而见敬乃如此。释知诸天意言。诸依福者不宜轻是人。所以者何。我可为证。是人守戒奉法难及。且待须臾方见其德。须赖欲使诸天意解。即白佛言。唯愿世尊。解说菩萨得威神见敬。至于无上正真之道。是时佛放身光。焰着须赖。其形状踰于天帝百千倍。天意皆悦。知非凡人悉已。天华散其上。佛告须赖。菩萨在贵不以憍慢。现若卑贱。能使众人不贪富贵亦无恨贫是为净德。其在豪贵能率余人兴布施。意在智现愚。能使愚人疾解智慧。是为净德。已能制意如汝须赖。示现极贫守戒如法。为诸梵志居士众人所敬。是为清净知善方便。贤者阿难白佛言。须赖学来久如。佛告阿难。其学甚久。已事若干亿百千佛。现得三忍博达众智。顺行诸善自见贫鄙。意净如是。阿难言。今宁有人愿求佛者。佛言。欲天七千。色天万二千。世人数千。皆发无上正真道意。阿难复问须赖久如。当成为佛。佛号为何。国土何类。佛为阿难。说此偈言

  阿难听我说　　须赖初发义
  护人无仇善　　德广常大施
  从始起意来　　其数难缕陈
  供养佛无厌　　奉法守不忘
  学六度无极　　进道乐久长
  梵行未曾漏　　守法慧不倾
  所行志念具　　觉对立道地
  已度众邪网　　性善觉内事
  已舍世八事　　利衰毁誉意
  一切等心视　　如空无挂碍
  爱法行无倦　　守忍慈为常
  爱人如爱己　　弃身安群生
  爱习悉教彼　　念熟说义实
  觉意不离法　　解空导二脱
  三忍具无念　　学法知可行
  所至必开导　　一切蒙其恩
  所在国邑兴　　辄往到其方
  宣化如佛意　　遍教诸天人
  我般泥曰后　　末时须赖终
  生东可乐国　　阿閦所山方
  余三阿僧祇　　行满大愿成
  得佛除世邪　　安隐度十方
  自然为神将　　号曰世尊王
  始如阿閦佛　　所度无有量
  世名德化成　　恶灭善义兴
  佛住千万岁　　众僧不可称
  彼愿罗汉少　　求佛者甚众
  时人力神足　　精进福行明
  其世五音声　　佛说法遍闻
  无有坏善魔　　正信脱邪患
  至佛灭度后　　八万四千人
  上法兴照世　　令行无讼意
  须赖所教化　　多愿摩诃衍
  悉会生其世　　不数已度人

佛拜须赖。时坐中天人鬼龙。各以好衣奉上须赖。欢乐之声闻于三千。亿百千人皆来礼之。佛为广说若干法要。解三乘行。王波斯匿避坐叉手。住白佛言。我以贪浊为国财醉。憍贵自恣作危殆行。得须赖妙言。乃自知最为贫。今欲舍家国付太子受世尊戒。身为佛比丘僧。守园给使。现在财宝为三分。一分奉佛弟子。二分施国人民。三分留为官储。得蒙佛恩。现身财宝不复贪乐。一切是福皆施众生。愿得无上正真道意。时坐中五百长者居士。五百梵志五百小臣。闻王誓愿如师子吼。皆发无上正真道意。一切舍欲以家之信。离家为道欲作沙门。除中三百人。其余佛悉以为沙门。于是须赖。退坐叉手白佛言。已亦愿从圣师子。十方诸现在佛。求哀作沙门。须赖慧力亦如来所成。便入三昧。一切十方诸现在佛。皆与其比丘僧俱现。须赖即起。稽首礼十方佛便为沙门。复求哀言。愿诸世尊。哀听受我使得成立。十方诸佛及释迦文。皆伸右臂摩须赖顶。诸佛臂各自现不相障。是时光明照三千世界。天雨众华。贤者须赖。自然法衣在身。被服正齐威仪安庠。当须赖得拜。时五百比丘漏尽意解。无余缚结。千菩萨得信忍。佛告阿难。受是记拜经奉持之。当为众人布说其义。所以者何。末世人多在邪信网。吾以是故于中作佛。化其恶意使见正道。令如须赖。从信入慧。我于世间周遍说法。一人不度我终不舍。是故阿难。当传此法令人信乐。终日习闻使意开解。当从是如得要。佛说经已皆欢喜。须赖比丘。诸比丘僧。天帝释及。王波斯匿。天人阿须轮。莫不乐闻

佛说须赖经


佛说须摩提菩萨经a

    No. 335 [Nos. 310(30), 334, 336]

佛说须摩提菩萨经

        姚秦三藏鸠摩罗什译

闻如是。一时佛在罗阅只耆阇崛山中。与大比丘众千二百五十人菩萨万人俱。尔时罗阅只大国有长者号曰优迦。优迦有女名须摩提。厥年八岁。历世奉敬过去无数百千诸佛。积累功德不可胜计。时须摩提。从罗阅只大国出诣耆阇崛山行到佛所。前以头面稽首佛足。礼毕即却在一面。以一心而往。叉手白佛。愿欲有所问。唯多陀竭。以方便解脱我之所疑。时佛默然即知女意。佛语须摩提。恣所欲问。多陀竭今当为汝具解说之。事事分别令汝欢喜。须摩提问佛言。菩萨云何所生人见之常欢喜。云何得大富有常多财宝。云何不为他人之所别离。云何不在母人腹中。常得化生千叶莲华中立法王前。云何得神足。从不可计亿刹土。去到彼问礼事诸佛。云何得无仇怨无侵嫉者。云何所说语言。闻者信从踊跃受行。云何得无殃罪。所作善行无能坏者。云何魔不能得其便。云何临寿终时。佛在前立为说经法。即令不堕苦痛之处。所问如是。是时佛语须摩提。如汝所问多陀竭义。善哉大快乃如是乎。汝若欲闻。谛听谛受勤思念之。吾当解说。时女即言甚善。世尊愿乐欲闻。于是须摩提。受教而听。佛言。菩萨有四事法。人见之皆欢喜。何等为四。一者嗔恚不起。视怨家如善知识。二者常有慈心向于一切。三者常行求索无上要法。四者作佛形像。是为四法。菩萨用是事故。人见之常欢喜。佛于是说偈言

  不起恚毁本根　　常行慈得要法
  作佛像身好洁　　心欢喜人喜见

佛语须摩提。菩萨复有四事法。得大富有。何等为四。一者布施以时。二者与已倍悦。三者与后不复悔。四者既与不求其报。是为四事。菩萨用是四事故。得大富有。佛于是说偈言

  以时施无悔心　　喜悦与无悕望
  所作施有勇慧　　在所处常大富

佛语须摩提。菩萨复有四事法。不为他人之所别离。何等为四。一者不传恶说斗乱彼此。二者导愚冥者使入佛道。三者若有毁败正法护使不绝。四者劝勉诸人教使求佛令坚不动。是为四法。菩萨用是四事故。不为他人之所别离。佛于是说偈言

  不传说斗彼此　　导愚冥护正法
  劝进人使求佛　　终无能别离者

佛语须摩提。菩萨复有四事法。得化生千叶莲华中立法王前。何等为四。一者细捣优钵华。波昙华。拘文华。分陀利华。令此四种末之如尘使满句虫。持是供养世尊若塔及舍利。二者不令他人起恚意。三者作佛像使坐莲华上。四者得最上觉便劝喜住。是为四法。菩萨用是四事故。化生千叶莲华中立法王前。佛于是说偈言

  施四华满句虫　　除恚恨受法义
  得上觉立佛前　　作形像生华中

佛语须摩提。菩萨复有四事法得神足。从一佛国至一佛国。何等为四。一者见人作功德不行断绝。二者见人说法而不中止。三者常然灯火于塔寺中。四者求三昧。是为四法。菩萨用是四事故。得神足从一佛国复至一佛国。佛于是说偈言

  行功德为法施　　闻经说不中止
  常然灯于佛寺　　入三昧遍诸国

佛语须摩提。菩萨复有四事法。得无仇怨无侵嫉者。何等为四。一者于善知识无谕谄心。二者不悭惜贪他人财物。三者见人布施助其喜。四者见菩萨诸所作为不诽谤。是为四法。菩萨用是四事故。常行是行得无仇怨无侵嫉者。佛于是说偈言

  于善友无谕谄　　不悭惜他人物
  见人施助其喜　　行菩萨无仇怨

佛语须摩提。菩萨复有四事法。其所语言闻者信从踊跃受行。何等为四。一者口之所说心亦无异。二者于善知识常有至诚。三者闻人说法不言是非。四者若见他人请令说经不求其短。是为四法。菩萨用是四事故。其所语言闻者信从踊跃受行。佛于是说偈言

  如所念言亦尔　　于善友有诚信
  闻讲法不求短　　若说经心喜踊

佛语须摩提。菩萨复有四事法。得无殃罪。所作善行疾得净住。何等为四。一者心意所念常志于善。二者常持戒三昧智慧。三者初发菩萨意。便起一切智。多所度脱。四者常有大慈愍于一切。是为四法。菩萨用是四事故。得灭无殃罪疾得净住。佛于是说偈言

  常志善念广度　　戒等定不离慧
  常教人一切智　　行慈意得净住

佛语须摩提。菩萨复有四事法。魔不能得其便。何等为四。一者常念于佛。二者常精进。三者常念经法。四者常立功德。是为四法。菩萨用是四事故。魔不能得其便。佛于是说偈言

  常喜意念于佛　　常精进在深法
  自勖勉立功德　　魔用是不得便

佛语须摩提。菩萨复有四事法。临寿终时。佛在前立为说经法。令不堕苦痛处。何等为四。一者为一切人故。具满诸愿。二者若人布施。诸不足者念欲足之。三者见人杂施。若有短少便裨助之。四者常念供养于三宝。是为四法。菩萨用是四事故。临寿终时。即见诸佛皆在前立为说经法。不令其人堕苦痛处。佛于是说偈言

  为一切满所愿　　无极哀劝足檀
  以杂施致黠慧　　供三宝得致佛

尔时须摩提白佛言。唯世尊所说四十事。我当奉行令不缺减。悉使具足不违一事。若失一事我为断佛法灭众弟子。是时长老摩诃目干连在大会中坐。即问须摩提。此四十事大士所行菩萨所为。甚亦难当。如汝小女何能办之。时须摩提答目干连言。假令我今审实能行此四十事者。三千大千国土皆当为我六反震动。雨于天华。诸音乐器不鼓自鸣。须摩提适发是言。应时三千大千国土六反震动。即雨天华乐器即鸣。女语目干连。是证明我之至诚。若未来有起菩萨意者亦当如是。我后亦当得多陀竭阿罗诃三耶三佛。信如我言。无有虚者。其在会者。皆当一等悉作金色。寻如所语辄作金色。于是目干连即从座起。正衣服下右膝叉手。为佛稽首作礼。前白佛言。今诸一切初发大意为菩萨者。我当自归为之作礼。所以者何。八岁女子感应如此。岂况高士摩诃萨乎。是时座中有大菩萨名文殊师利。谓须摩提言。于何法住。所现感应乃如是乎。须摩提答言。诸法不可计数亦无所住。而仁问我住于何法。仁作是问不如不问。文殊师利问须摩提言。此语云何乃至于斯乎。须摩提报文殊师利言。不于诸法有所住。亦无所疑亦不言是非。文殊师利问须摩提言。如来本不作行乎。须摩提报言。譬如月影现于水中。若梦野马深山之响。如来本行亦如是也。文殊师利问须摩提。如仁所说。合会是事为能得佛不。须摩提报言。云何仁者。谓痴黠行三事异乎。不为异也。一切一法诸法皆合。所以者何。若正法若不正法。适无所住亦无所取。亦无所收空无有色。文殊师利复问须摩提。解是义者为有几人。须摩提报言。夫作幻者。恣意作化宁有限无。幻师所化犹尚无限信解此法亦如是也。文殊师利问须摩提言。如我无化无幻起行。何法而与道合。须摩提报言。如仁所说致为大快。一切法处亦不有亦不无。至于如来无合无散。文殊师利闻彼所说甚悦赞善。文殊师利前白佛言。甚善须摩提所说自恣其意。微妙大可怪也。乃能深入逮得法忍。发意已来为几何乎。佛语文殊师利。是须摩提发阿耨多罗三耶三菩心。等住已来积不可计。先仁之前三十亿劫。仁乃于彼发无上平等度意。适乃甫入无所从生法忍。是仁本造发意时师也。文殊师利闻佛所言则前作礼。白须摩提。惟别久远今乃讲侍。与师相见得受法诲。须摩提报言。莫作是念。用何等故。无所从生法忍。亦无所念亦无有师。文殊师利问言。云何不转女人身。须摩提报言。于是无所得。所以者何。法无男无女。今者我当断仁所疑。文殊师利言。善哉乐欲闻之。须摩提谓文殊师利言。如今我后不久。亦当逮得如来无所著等正觉成慧行安定世间父无上士道法御天人师佛天中天。如是审谛我今便当变为男子。适作是语。即成男子头发即堕。袈裟在身便作沙弥。须摩提复谓文殊师利言。审我来世当作佛时。使我国中莫有三事。何等为三。一者魔事。二者泥犁。三者女人态。若我志诚。我身当如年三十沙门。时须摩提适作是语。形体颜色如年三十。须摩提复谓文殊师利言。我作佛时。令我国人皆作金色。地及城郭周匝有七宝树。令八重行七宝池水。四边中外皆生七宝杂色莲华。及诸杂宝不多不少皆悉停等。须摩提言。如仁之国。我之刹土亦当如是。如我志诚。诸在会者当作金色。适作是语。应时众会皆作金色。时持地神即从地出。化作天身举声称扬叹须摩提言。须摩提菩萨摩诃萨得作佛时。国土所有七宝池水。树及华实皆当如是。于是佛谓文殊师利。是须摩提菩萨摩诃萨不久当得作佛。字名远闻具足藏如来过四道不受平等觉兴具足行安隐世间天上天下无上大人。女意云何。法无所住。岂有我名乎。答曰。不也天中天。于女意云何。其幻化者。岂有到后世复来者乎。答曰。不也天中天。于女意云何。其幻化者。岂有所起所灭乎。答曰。不也天中天。于女意云何。其幻化者。岂有所有有形像乎。答曰。不也天中天。于女意云何。其幻化者。岂有见闻有幻无幻乎。答曰。不也天中天。其女曰。佛言我曾闻之。其幻化者。无有见闻有幻无幻。世尊又问。于女意云何。其幻化者。假使无身岂能令幻化发起诸行乎。女答曰。唯天中天。其幻化者。实为如此真无所有。佛言如是。其无明者无内无外。计其法者。亦无所有亦无字也。其明者。不至后世亦无还反。其无明者。亦无有起亦无有灭。其无明者。亦无形像。适兴无明。缘致众行。名色六入。更习痛爱受有。生老病死。勤苦愁恼大患集会。明女首意白佛言。甚为可奇。至未曾有。世尊所兴而不可及。所以者何。佛天中天。于虚空中而转法轮。法轮不可思议。所转法轮不可称限。无量法轮。无获法轮。无形法轮。无生法轮。灭度法轮。世尊告曰。如是如是诚如所云。吾所转轮为转空轮。所转法轮不可思议。所转法轮不可称限。其可转轮。无获无形无生为灭度也。时首意女欢喜踊跃。善心生焉。则以栴檀香捣及诸华香供养散佛。唯然世尊。以是德本深致拥护。而善救摄降伏诸根。抑制爱欲逮转法轮。转于空轮不思议轮不可称限无量无获无形无生灭度之轮。佛寻欣笑。五色青赤黄白绿光从口而出。甚大光明普照十方无数佛国。悉皆覆蔽日月之明。还绕佛身三匝从顶上入。贤者阿难。晓了七法。一曰知谊二曰解法。三曰晓时。四曰了节。五曰明众。六曰练己。七曰深识人本。即从座起更整衣服。偏袒右肩下右膝叉手白佛。今大圣欣笑为何感应。愿说其意。唯天中天。多所愍伤多所安隐。哀念诸天世间人民。分别说之。佛告阿难尔见梵志女首意。以末栴檀华香捣香。供养散佛乎。其心誓愿逮转法轮。对曰已见。佛言是女以斯德本。护己安人多所救摄。寿终之后当转女身。至八十四亿劫不归恶趣。供养六万诸佛世尊。出家为道志于沙门。听受经法。受经法已即时讽诵。将御如来现在正法。佛灭度后供养舍利。劝化无数无量众生不可计会。使立无上正真之道。恒以善意奉持要法。号天中天。佛说是经授须摩提莂时。三十亿人发无上平等度意。皆得阿惟越致。六万天子悉得法法眼生。座中有五百菩萨闻文殊师利所问甚深。意用不解中欲堕落。见须摩提所说至诚寻皆有应。即解身衣以用上佛。亦不谕谄无所悕望。持功德用自坚固。于无上平等度意。即得住阿惟越致。超九十劫不复生死。时佛授与五百人决。却后十劫。劫名无尘垢。佛号固受如来过四道不受平等觉。是五百人等当生彼国。国名焰气。当同一劫俱得作佛。皆同一字号庄饰豫知人意如来过四道不受平等之道最正觉。佛谓文殊师利。乃知是经多所饶益如是不乎。若今最后有菩萨摩诃萨及沙门。若善男子善女人等。求菩萨道奉行六波罗蜜。未晓沤和拘舍罗。不如书持是经讽诵读转。复教人常念其中事。诸欲闻者广为解说。佛复语文殊师利。前所不闻本所不行。如是等辈菩萨者当念习持。所以者何。譬如遮迦越王治于世时。至竟七宝不为缺减。其王寿终七宝为散。如是文殊师利。若佛经道住于世者。佛七觉意终不为减。若佛法灭。觉意诸法皆为乏尽。佛谓文殊师利。当求无数方便具索诸经。勤学书持为他人说。教授一切广解其义。常当精进是为法教。善男子善女人欲求佛道者莫中有悔。佛说经已。须摩提菩萨文殊师利菩萨摩诃目干连等。诸天及人其在会者。阿须罗揵沓和持世者。皆欢喜乐闻

佛说须摩提菩萨经


佛说须摩提菩萨经b

    No. 334 [Nos. 310(30), 335, 336]

佛说须摩提菩萨经(按开元录须摩提经亦直云须摩经)

        西晋三藏竺法护译

闻如是。一时佛在罗阅只灵鸟顶山中。与大比丘众千二百五十人。菩萨万人俱。尔时罗阅城大国。有长者号曰郁迦。郁迦有女。名须摩提。厥年八岁。历世奉敬过去无数百千诸佛。积累功德不可称计。时须摩提。从罗阅只大国出诣灵鸟山。行到佛所。前以头面稽首佛足。礼毕却住一面。叉手白佛言。愿欲有所问。唯佛以善权方便。解说我之所疑。时佛默然。即知女意。佛语须摩提。恣所欲问。如来今当为汝具解说之。事事分别。令汝欢喜。须摩提问佛言。菩萨云何所生处。人见之常欢喜。云何得大富有常多财宝。云何不为他人之所别离。云何不在母人腹中。常得化生千叶莲华中立法王前。云何得神足从不可计亿刹土。去到彼间礼诸佛。云何得无仇怨无侵嫉者。云何所说闻者信从踊跃受行。云何得无殃罪所作善行无能坏者。云何魔不能得其便。云何临寿终时佛在前立。为说经法即令不堕苦痛之处。所问如是。是时佛语须摩提。如汝所问如来义者。善哉大快乃如是乎。汝若欲闻谛听谛受勤思念之。吾当解说。时女即言。甚善世尊。愿乐欲闻。于是须摩提受教而听。佛言菩萨有四事法。人见之皆欢喜。何等为四。一者嗔恚不起。视冤家如善知识二者常有慈心向于一切。三者常行求索无上要法。四者作佛形像。是为四法。菩萨用是四事故。人见之常欢喜。佛于是说偈言

  不起恚毁本根　　常行慈得要法
  作佛象身好洁　　心欢喜人喜见

佛语须摩提。菩萨复有四事法。得大富有。何等为四。一者布施以时。二者与已倍悦。三者与后不复悔。四者既与不求其报。是为四法。菩萨用是四事故。得大富有常多财宝。佛于是说偈言

  以时施无悔心　　喜悦与无希望
  所作施有勇慧　　所在处常大富

佛语须摩提。菩萨复有四事法。不为他人之所别离。何等为四。一者不传恶说斗乱彼此。二者导愚痴者使入佛道。三者若有毁败正法护使不绝。四者劝勉诸人教使求佛令坚不动。是为四法。菩萨用是四事故。不为他人所别离。佛于是说偈言

  不传说斗彼此　　道愚冥护正法
  劝进人使求佛　　终无能别离者

佛语须摩提。菩萨复有四事法。得化生千叶莲华中立法王前。何等为四。一者细捣红莲华青莲华黄莲华白莲华。合此四种末之如尘。使满软妙华。持是供养世尊若塔及舍利。二者不令他人起恚意。三者作佛形像使坐莲华上。四者得最正觉便欢喜住。是为四法。菩萨用是四事故。常得化生千叶莲华中立法王前。佛于是说偈言

  施四华满软妙　　除恚恨受法义
  得上觉立佛前　　作形像生花中

佛语须摩提。菩萨复有四事法。得神足。从一佛国复至一佛国。何等为四。一者见人作功德不行断绝。二者见人说法而不中止。三者常然灯火于塔寺中。四者求三昧。是为四法。菩萨用是四事故。得神足从一佛国至一佛国。佛于是说偈言

  行功德为法施　　闻经说不中止
  常然灯于佛寺　　入三昧遍诸国

佛语须摩提。菩萨复有四事法。得无仇冤无侵嫉者。何等为四。一者于善知识无谀谄心。二者不悭贪妒他人物。三者见人布施助其喜。四者见菩萨诸所作为不行诽谤。是为四法。菩萨用是四事故。常行是行得无仇冤无侵嫉者。佛于是说偈言

  于善友无谀谄　　不悭惜他人物
  见人施助其喜　　行菩萨无仇冤

佛语须摩提。菩萨复有四事法。其所语言闻者信从踊跃受行。何等为四。一者口之所说心亦无异。二者于善知识常有至诚。三者闻人说法心不是非。四者若见他人请令说法不求其短。是为四法。菩萨用是四事故。其所语言闻者信从踊跃受行。佛于是说偈言

  如所念言亦尔　　于善友有至诚
  闻讲法不求短　　若说经心喜踊

佛语须摩提。菩萨复有四事法。得无殃罪所作善行疾得净住。何等为四。一者心意所念常志于善。二者常持戒三昧智慧。三者初发菩萨意便起一切智多所度脱。四者常有大慈愍于一切。是为四法。菩萨用是四事故。得无殃罪疾得净住。佛于是说偈言

  常志善念广度　　戒等定不离慧
  当教人一切智　　行慈意得净住

佛语须摩提。菩萨复有四事法。魔不能得其便。何者为四。一者常念于佛。二者常精进。三者常念经法。四者常立功德是为四法。菩萨用是四事故。魔不能得其便。佛于是说偈言

  常净意念于佛　　志精进在深法
  自勖勉立功德　　魔用是不得便

佛语须摩提。菩萨复有四事法。临寿终时。佛在前立为说经法。令其不堕苦痛之处。何等为四。一者为一切人故。具满诸愿。二者若人布施诸不足者念欲足之。三者见人杂施若有短少便裨助之。四者常念供养于三宝。是为四法。菩萨用是四事故。临寿终时即见诸佛。皆在前立为说经法。不令其人堕苦痛处。佛于是说偈言

  为一切满所愿　　无极哀劝足檀
  以杂施致黠慧　　供三宝得致佛

尔时须摩提白佛言。唯世尊。所说四十事。我当奉行令不缺减。悉使具足不违一事。若失一义我为断佛劫法减众弟子。是时大目揵连。在大会中坐。即问须摩提。此四十事。大士所行菩萨所为甚亦难。当如汝小女何能办之。时须摩提答目连言。假令我今审实能行此四十事者。三千大千国土。皆当为我六反震动。雨于天华诸音乐器不鼓自鸣。须摩提。适发是言。应时三千大千国土。六反震动。即雨天华。乐器皆鸣。女语目连。是则证明我之至诚。若有未来起菩萨意者亦当如是。我后不久亦当如如来无所著等正觉。信如我言无有虚者。其在众会皆当一等悉作金色。寻如所语辄作金色。于是目连即从坐起。整衣服下右膝。叉手为佛稽首作礼。前白佛言。今诸一切初发大意为菩萨者。我当自归为之作礼。所以者何。八岁女子。感应如此。岂况高士摩诃萨乎。是时座中有大菩萨。名文殊师利。谓须摩提言。于何法住所现感应乃如是乎。须摩提答言。诸法不可计数亦无所住。而仁问我住于何法。仁作是问不如不问。文殊师利问须摩提言。此语言何乃致斯乎。须摩提报文殊师利言。不于诸法有所住。亦无所疑。亦不言是非。文殊师利问须摩提言。如来本不作行乎。须摩提报言。譬如月影现于水中。若梦野马深山之响。如来本行亦如是也。文殊师利问须摩提。如仁所说合会是事为能得佛不。须摩提报言。云何仁者谓痴黠行三事异乎。不为异也。一切诸法皆合。所以者何。若正法若不正法。适无所住亦无所取。亦无所放空无有色。文殊师利复问须摩提。解是义者为有几人。须摩提报言。夫作幻者恣意所化宁有限无。幻师所化犹尚无限。信解此法亦如是也。文殊师利问须摩提言。如我无化无幻起行何法而与道合。须摩提报言。如仁所说致为大快。一切法处亦不有。亦不不有。至于如来无合无散。文殊师利闻彼所说甚悦赞善。文殊师利白佛言。甚善须摩提所说微妙大可怪也。乃能深入逮得法忍。发意已来为几何乎。佛语文殊师利。是须摩提。发无上平等度意等住已来。积不可计。先仁之前三十亿劫。仁乃于彼发无上正等度意。适甫乃入无所从生法忍。是仁本造发意时师。文殊师利闻佛所说则前作礼。白须摩提言。唯别久远今乃讲侍。与师相见得受法诲。须摩提报言。莫作是念用何等故。无所从生法忍。亦无所念亦无有师。文殊师利问言。云何不转女人有。须摩提报言。于是无所得。所以者何。法无男无女。今者我当断仁所疑。文殊师利言。善哉乐欲闻之。须摩提谓文殊师利言。如今我后亦当逮如来无所著等正觉成慧行安定世间父无上士道法御天人师佛天中天。如是审谛。我今便当变为男子。适作是语。便成男子。头发即堕袈裟着身。便为沙弥。须摩提复谓文殊师利言。审我来世当作佛时。使我国中莫有三事。何等为三。一者魔事。二者地狱。三者女人态。若我至诚我身当如年三十沙门。时须摩提。适作是语。形体颜色如年三十。时须摩提谓文殊师利言。我作佛时令我国人皆作金色。城郭及地周匝七宝。有七宝树令八种行。七宝池水四边中外。皆生七宝杂色莲华。及诸杂宝。不多不少皆悉停等。须摩提言。如仁之国我之刹土。亦当如是。如我至诚者。今在会者当作金色。适作是语应时众座皆作金色。时持地神即从地出。化作天身举声称扬。叹须摩提三言。摩诃须摩提菩萨摩诃萨得作佛时。国土所有七宝池水树及华实。皆当如是。于是佛谓文殊师利。是须摩提菩萨摩诃萨。不久当得佛。号宝德合吉祥如来无所著等正觉成慧行安定世间父无上士道法御天人师佛天中天。佛说是经。授须摩提莂时。三十亿人。发无上平等度意者。皆得立不退转。六万天子悉得诸法法眼生。座中有五百菩萨。闻文殊师利所言甚深。意用不解中欲堕落。见须摩提所说真诚寻皆有应。即解身衣以用上佛。亦不谀谄无所希望。持是功德用自坚固。于无上平等度意。即得住不退转地。超九十劫。不复生死。时佛授与五百人决。却后十劫。劫名无尘垢。佛号固受如来无所著等正觉。是五百人等当生彼国。国名焰气。当同一劫。俱得作佛。皆同一字。号庄饰预知人意如来无所著等正觉。佛谓文殊师利。乃如是经多所饶益。如是不乎。若今最后有菩萨摩诃萨及沙门若善男子善女人等。求菩萨道奉行六度无极。未晓善权方便。不如书持是经讽诵读转。复教人常念其中事。诸欲闻者广为解说。佛复语文殊师利。前所不闻本所不行。如是辈菩萨者当念习持。所以者何。譬如转轮圣王治于世间。当时至竟七宝不为缺减。其王寿终七宝为散。如是文殊师利。若佛经道住于世间者佛七觉意终不为灭。若佛法灭觉意诸法皆为之尽。佛谓文殊师利。当求无数方便。具索诸经勤学书持。为他人说教授一切。广解其义常当精进。是为法教。若善男子善女人。欲求道者莫中有悔。佛说经已。须摩提菩萨。文殊师利菩萨。大目揵连等诸天及人。其在会者。阿修罗揵沓和持世者。皆欢喜乐闻

佛说须摩提菩萨经


佛说遗日摩尼宝经

    No. 350 [Nos. 310(43), 351, 352]

佛说遗日摩尼宝经

        后汉月支国三藏支娄迦谶译

佛在舍卫国祇洹阿难邠坻阿蓝时。与摩诃比丘僧千二百五十人。菩萨万二千人。尔时佛语摩诃迦叶比丘言。菩萨有四事法智慧为减。何等为四事。一者不敬经不敬师。二者人有欲闻经者中断之。三者人有求深经者爱惜不肯与。四者自贡高轻侮他人。是为四。菩萨复有四事法智慧为增。何等为四。一者恭敬经尊师。二者人有来听经者不中断。三者人有欲得深经者不爱藏。四者具足为人说经。不从人有所徼冀。常自精进常随法行不哗说。是为四。菩萨有四事。世世亡菩萨道意。何等为四。一者欺调其师。二者主持他人长短。人无长短诽谤之。三者坏败菩萨道。四者骂詈为菩萨道者。是为四。菩萨有四事世世所生念菩萨道不忘。及自致至佛。何谓四事。一者不欺师。尽其形寿不两舌谀訑。二者尽形寿不两舌形笑他人。三者慈心于人不念人恶。四者视诸菩萨如见佛。及初发意无异。是为四。菩萨有四事。法中道断绝为菩萨日减。何谓为四。一者自贡高学外道。二者独欲自供养。不欲令他人得。三者反自憎菩萨还自相谤。四者人有来常所闻经妄止令断绝。是为四。菩萨有四事。求经道及有所求索不中断。何谓四事。但求索好经法。六波罗蜜。及菩萨毗罗经。及佛诸品。去嗔恚之心。敬事十方天下人。如奴事大夫。乐于经不为外道自益身也。自守不说人恶及谗溺于人。所不闻经不限佛智也。随其所喜经者各自闻得。是为四。菩萨有四事。心不委曲当远离。何谓为四。一者犹豫于佛法。二者自贡高嗔恚。顽佷用加于人。三者贪嫉谀訑四者说菩萨短。是为四。菩萨有四事。直行至诚。何谓为四。一者自有过恶不覆藏。自悔欲除其罪。二者实谛亡命亡。国亡财不两舌。三者设有灾变妄起。至骂詈数数轻易及挝捶闭着牢狱。设有是当自悔前世恶所致。四者无恨无嗔恚自信。是为四。菩萨有四事难调也。何谓四事。一者学经自用不随师法。二者所受教不用也。不慈孝于师。三者受比丘僧所信句。妄与他人。四者不敬于成就菩萨。是为四。菩萨有四事易调也。何谓为四。一者所闻经法随教不过。所闻者但闻取法不取严饰。二者当恭敬于师无谀谄。三者食知足持戒三昧如法。四者见成就菩萨。持善心向心口身亦尔。亦欲及其功德。是为四。菩萨有四事得其过。何谓四事。一者本不相习不当妄信。二者佛有深法不当妄教人。是为大过。三者人有喜菩萨道者。反教人罗汉道。是为大过。四者于比丘僧中。布施心不等与者。是为大过。是为四。菩萨有四事。得菩萨道。何谓四事。一者等心于十方人。二者布施等心于十方人。三者所作为等心于十方人。四者说经等心于十方人。是为四。菩萨有四事。矫称为菩萨。何谓四事。一者依经得生活。二者但欲声名不索佛道。三者但欲自安不念苦人。四者但口多说不欲度余人。是为四。菩萨有四事。成其功德。何谓四事。一者信虚空。二者所作恶信当悔。三者心念万物皆非我所。四者极大慈于十方人。是为四。菩萨有四恶知识。何谓四。一者教人为罗汉道灭意。二者教人为辟支佛道。自守无为。三者喜教人为教道。四者人求有学经者。持财物诱恤。不肯教人。是为四。菩萨有四善知识。何等为四。一者人所求索不逆也。用是故成佛道。二者经师。是为善知识。多闻经故。三者劝乐使人发意求佛。成于功德。四者佛天中天。是善知识。具足诸佛法故。是为四。菩萨有四珍宝。何谓为四。一者见佛已悉供养无二意。二者六波罗蜜法悉闻。三者常净心向师。四者止于爱欲。常止空闲处。是为四。菩萨有四事出于魔界。何谓为四。一者不舍菩萨心。二者无有嗔恚心向于十方人。大如毛发。三者悉学外余道。四者恭敬于诸菩萨。是为四。菩萨有四事。得功德不可复计。何谓为四。一者持法施与人。不希望欲有所得。二者人有犯戒者。当慈哀之。三者多教人为菩萨道。四者有下贱人来毁辱菩萨。悉当忍之。是为四

佛语迦叶言。不用字为字菩萨也。随法行。随法立用。是故字菩萨。菩萨。凡有三十二事。何谓三十二事。安隐慈心。于人自念。智虑少去。自用不高。自傗坚住不动。还所与亲厚。乃至般泥洹。善知识恶知识。等心无有异所。作为不懈怠。常和畅向于十方人。不中断等心悉遍至。不断慈心。索诸经法不忘。于经法中无有饱时。所有恶不覆藏皆发露。他人有短不念其短恶。诸福功德悉究竟。索所施与。但发心索佛耳。一切不索。有所生心。向十方人。不适有所憎。无思想之禅。不愿于其中也。沤和拘舍罗。护于智慧。四事杂布施。不乐于外事。不喜于小道。心喜于大道。离于恶知识。习善知识。以五旬自娱乐。譬如月初生时。稍稍增益。于智慧稍稍如是。不堕非法。所语无异。所说谛者恭敬

佛言。如是迦叶。三十二事。是故名为菩萨。佛言迦叶。譬如地。一切人随其所种。其地亦不置人也。如是发意菩萨。自致乃成佛饶益十方人。亦适无所置也。迦叶。譬如春夏温暖所种成熟。菩萨智慧成熟十方人功德如是。譬如水。百谷草木皆因水茂盛。菩萨如是。发心诸经法悉从中生。譬如风。悉成诸佛国土。菩萨如是。沤和拘舍罗悉成诸佛经。譬如日。无所不照天下皆见其明菩萨如是。智慧光明悉照十方人。经道之明。譬如月初生时日日增益。菩萨如是。精进具足于功德。譬如师子。独行独步无所畏。菩萨如是被戒德之铠。独行独步无所畏。譬如草木。虽无上枝下根由复生。菩萨如是。虽断三处极大慈续见世间。譬如万川四流皆归于海。合为一味。菩萨如是。持若干种行合会功德。持用成愿一味。入萨芸若中。譬如须弥山忉利住其上。菩萨如是发心成萨芸若。譬如树荫却雨。菩萨如是持极大慈雨于经道。譬如国王得傍臣共治。则好沤和拘舍罗。如是菩萨。所作为如佛。譬如天[雨/星]欲索雨不能得也。菩萨如是不学经道。豫知不高明也。譬如遮迦越罗王之所处。自然后七宝自然来生。菩萨如是初生萨芸若意。然后自然生三十七品经。譬如更治摩尼珠。其价增倍多所饶益。师成一人为菩萨道。众阿罗汉辟支佛皆依用得度。譬如毒药在人手中不害伤人。菩萨虽在爱欲中。持智慧不入恶道。譬如郡国多积粪壤。有益稻田菜园。菩萨虽在爱欲中。益于天上天下。佛语迦叶。若有菩萨欲学极大珍宝之积遗日罗经。当随是经本法精进。何等为本法。无法无我无人无寿无常无色无痛痒无思想无生死识。是为法本根。有常在一边。无常在一边。有常无常适在其中。无色无见无识。是故为中之智黠本也。譬如大地为一界。复一佛界。两界之际中。无色无见无识无我无识无所入无所语。是为智黠本也。心为一边。无心为一边。设无心无识无我无识。是为中间之本。诸佛经法等。无有异有德无德。内事外事。有世间无世间。为度者未度者。脱爱欲未脱爱欲。泥洹等无有异。有在一边。无有在一边。有无有适在中间。是为智黠中本也。佛语迦叶。我为汝曹说法。从生至死身所出生。苦痴在一边。黠在一边。无痴无黠适在中间。是为智黠中间之本

佛语迦叶。空不作法。法本无空无相不作法。法本无相无愿不作法。法本无愿无死生不作法。法本无死生。死生无出生无灭无处所。无形不作法。法本无形当随是本法。是为中间视本法。不自分别解身为空也。空弃空中之空本自空甫当来空现在空。佛语迦叶。人宁着痴大如须弥山。呼为有其过不足言耳。人有着空言有空。其过甚大。若有着痴者晓空得脱。着空者不得脱。佛语迦叶言。譬如人病得良医与药。药入腹中不行。于迦叶意云何。是人能愈不。迦叶报言大难。佛言。外余道晓空得脱。着空不得脱。譬如人畏于虚空啼哭教人却去虚空。佛语迦叶。是人宁却虚空不。迦叶言。不可却也。佛言。如是迦叶。若沙门婆罗门畏于虚空。其人亦空语复畏空。是人为狂。无有异。佛语迦叶言。譬如画师自画鬼神像。还自复恐怖。譬如人未得道者。如是色声香味。坐是堕死生中不晓法。譬如木中火出还自烧木。从观得黠自烧身。譬如幻师化作人。还自取幻师啖。如是色声香味对。从中出念啖空啖无他奇。佛语迦叶。譬如灯炷之明。不自念言我当逐冥去冥也。然灯炷照。不知冥所去处。如是智黠不念。我当去愚痴得智黠。不知愚痴所去处也。是智黠无所从来。亦无有持来者。是灯炷明是冥。空不可得持也。是智黠是痴。两者俱空无所持也。譬如大舍小舍百岁若千岁。未尝于其中然灯火也。却后各于中然灯火。迦叶。于迦叶意云何。是冥在中千岁。若我豪强不出。迦叶白佛言。不也。冥虽久在中。见火明不敢当即去。佛言。如是迦叶。菩萨数千巨亿万劫。在爱欲中为欲所覆。闻佛经一反念善罪即消尽。灯炷明者。于佛法中智黠明是也。冥爱欲即为消尽。譬如虚空中不生谷实也。地种乃生谷实耳。如是泥洹中不生菩萨也。粪治其地谷种润泽生。于爱欲中生菩萨。佛语迦叶。譬如旷野之中若山上。不生莲华及优钵华也。菩萨不于众阿罗汉辟支佛法中出也。譬如大陂水污泥之中。生莲华优钵华也。从爱欲中生菩萨法。譬如四大海停住。菩萨于三界功德中。润泽成菩萨道。譬如蠹虫食芥子空。罗汉辟支佛智尔所耳。譬如麻油破一发作百分。持一分揾油麻中为出几所渧。罗汉辟支佛智如是。如十方空所至。菩萨晓佛智如是。譬如遮迦越罗有千子无有一子。应遮迦越罗相也。虽有尔所子。不在子计中也。有罗汉数千巨亿万人。不在佛计中无一菩萨。佛虽有尔所。罗汉不具足为佛子也。譬如遮迦越罗正夫人与贫穷人。共交通从中生子。佛语迦叶。是宁应为遮迦越罗子不乎。迦叶报佛言。不也。佛言。如是迦叶。虽有罗汉从法中出。是非佛子也。不类菩萨。何以故。菩萨不断佛法故。譬如遮迦越罗与青衣交通却后生子。具足成遮迦越罗相。虽从青衣生。由为是遮迦越罗子也。如是菩萨虽在生死中行力少会为佛子。譬如遮迦越罗夫人怀躯七日。会当成遮迦越罗相也。诸天皆彻视见腹中胞胎。虽遮迦越罗子。多者无遮迦越罗相。诸天言由不如供养腹中七日子也。发意菩萨如是中有为佛道。诸天心念言虽有罗汉数千万亿豪尊。不如供养发意菩萨也。譬如摩尼珠。有水精大如须弥山。不如一摩尼珠。初发意菩萨众。阿罗汉辟支佛所不能及也。譬如遮迦越罗有少子。诸小王傍臣皆为作礼。初发意菩萨如是。诸天释梵世间人龙鬼神皆为作礼。譬如大山诸药草。悉出其巅亦无有主。随其有病者与诸病皆愈。菩萨如是持智慧药。愈十方天下人生死老病悉等心。譬如月初生人皆为作礼。月成满无有为作礼者。若有信佛者。于佛法中菩萨发意。若有信佛者。多为菩萨作礼者。何以故。从菩萨成佛故。譬如有智者不舍月为星宿作礼也。高人如是。不舍菩萨为罗汉作礼也。譬如天上天下共治一水精。会不能得摩尼珠也。一切自守持戒禅三昧。智黠罗汉虽众。不能坐佛树下。不能作佛也。尔时佛语摩诃迦叶菩萨。学用十方人故菩萨作功德。用十方人故菩萨作功德。不自贡高。菩萨常当教十方人愈其病。何等为愈病。淫者以观为药。嗔恚者以等心为药。痴者以十二因缘为药。疑不信者以空为药。欲处色处无色处。若欲觉此者。以无相为药。是我所非我所。爱欲所念。以无愿为药。四颠倒各自有药。何等为各自有药。一者有常以无常为药。二者有乐以苦为药。三者有言是我所以非我所为药。四者有身以观为药。四意止以身心为念。是为药。四意断一切恶悉断。是为药。四神足念合会成身以空弃为药。五根五力不信懈怠念功德为药。七觉意入法黠是为药。外道及不信以八道为药。是为各各分别药。佛语迦叶。若阎浮利。若医若医弟子者。或医王最尊三千国土满其中者。或医王满其中。虽有乃尔所医王。不能愈外道及不信者。不知当持何等法药愈也。菩萨作是念。不持世间药愈人病也。当持佛法药愈人病。何等为佛法药。随其因缘。黠慧中无我无人无寿无命。信空度脱。空无空闻是不恐不惧。持精进推念心。何等心入淫。何等心入嗔怒。何等心入痴。持过去当来今现在心入耶。过去为尽甫当来未至今现在无所住也。佛语迦叶言。心无色无视无见。佛语迦叶言。诸佛亦不见心者。本无所有无所因也。自作是因缘。自得是死生。心远至而独行。心譬如流水上生泡沫须臾而灭。心譬如天暴雨卒来无期。爱欲亦如是卒来无期心譬如飞鸟猕猴不适止一处也。心所因不适止一处也。譬如画师各各赋彩心各各异。如是随行所为。譬如王于众人中为上。心于诸功德中无上。譬如苍蝇在粪上住自以为净。心亦如是入爱欲中自以为净。心譬如怨家掷人着恶道中无有期也。譬如持灰作城。持无常作有常。譬如持钩行钓鱼得。心持非我所是我所。心譬如贼。所作功德反自辱。譬如阪上上下。心须臾有爱须臾有憎。心譬如怨家但伺人便。心常欲闻香。譬如画瓶盛屎。有何他奇心喜味。譬如奴随大夫使心乐对。譬如飞蛾自投灯火中

佛语迦叶。心索之了不可得。虽不可得是为无有。虽无有因为无所生。虽无所生亦无所出。虽无所出亦无所坏。虽无所坏亦无有死亦无有生。虽无所生无所死本无因缘死生。虽本无因缘无生亦无愿也。虽无愿亦无所持。虽无所持是为罗汉灭。是为罗汉灭无诫禁也。若死生若计所作罪本了无有。是无死生是为罗汉灭。罗汉灭亦无身行无口行无心行。是灭无有异也。何以故。诸经一味故。是灭皆等如虚空。是灭适无所莫。亦无是我所。亦非是我所。是灭谛本无谛。是灭本净无爱欲之瑕秽也。本灭离本灭。是灭随次至于泥洹。是灭无尽也。本无有生也。是灭安隐用至泥洹故安隐是灭也。常灭常经无本。是灭好去本无死生。佛语迦叶言。自求身事莫忧外事。后当来世比丘辈。譬如持块掷狗。狗但逐块不逐人。当来比丘亦尔。欲于山中空闲之处。常欲得安隐快乐。不肯内自观身也。如是为不晓色耳鼻舌身。从是何缘得脱乎。从是入城乞丐。若至聚邑。见色声香味细软欲得者。便为堕衰于山中。若多少持戒不内观。死则天上生。从天上来下生世间。从是以后不离三恶道。佛语迦叶言。比丘如狗逐块。人骂亦复骂之。人挝亦复挝之。不制心者亦如是。譬如调马师。马有[跳-兆+棠]踲者。当数数教之久后调好。比丘时时法观制心调。亦不见其恶如是。譬如人病喉咽痛。举一身皆为痛。人心系于是我所非我所。随外道亦如是。佛语迦叶言。沙门有二事。堕牢狱中。一者言是我所。二者求人欲得供养。沙门复有二事缚。何谓二事。一者学外道。二者多欲积衣被及袈裟钵。沙门复有二事中道断。何等为二事。一者与白衣厚善。二者见好持戒沙门反憎。沙门复有二事堕垢浊中。何谓二事。一者常念爱欲。二者喜交结知友。沙门复有二事着。何等为二事。自有过不肯悔。反念他人恶。沙门复有二事。堕泥犁中。何等为二事。一者诽谤经道。二者毁戒。沙门复有二事。何等为二事。一者都犯戒。二者于法中无所得。沙门复有二事悔。何等为二事。一者不应行强披袈裟。二者身不自持戒。持戒比丘反承事。沙门复有二事病难愈。何等为二事。一者心邪乱。二者人有作菩萨道者止断。佛语迦叶。沙门何故。正字沙门。有四事字为沙门。何等为四。一者形容被服像如沙门。二者外如沙门内怀偷[女*閻]。三者求索哗名自贡高。四者行不犯真沙门也。何等为形容被服如沙门者。髡头剔须。着袈裟持钵。心不正不持戒。但欲作恶喜学外道。是为被服如沙门。何因外如沙门内怀偷[女*閻]者。安徐而行。安徐而出安徐而入。外道粗恶于山间草屋为庐。内无信着我着我所。中有因苦直信者反自嫉妒。何因为求索哗名者。偷[女*閻]持戒令他人称誉。偷[女*閻]学经令他人称誉。偷[女*閻]僻处令人称誉。不自克责求度脱。但有偷[女*閻]何等为行不犯真沙门。不惜寿命损身。何况索归遗供养者。若有比丘守空行。常劝乐追。及悉见诸法净洁本无瑕秽。自作黠明不从他人持黠明。于佛法亦不着。何况常着色。亦无结者亦无脱者。本无不见泥洹。亦无死生亦无泥洹。是为真沙门

佛语迦叶。至诚沙门常当作是念。当效真沙门。莫效哗名谀訑沙门也。譬如贫人号名大富。但得富名无所有也。佛语迦叶。是人应得为有是字不。迦叶言不也。佛言如是。迦叶。虽有沙门字。不行沙门法也。亦如贫人自称大富。譬如人为水所没溺反渴欲死。沙门如是多讽经。高才不去情欲。于情欲中渴欲死。坐入泥犁禽兽薜荔中。譬如医满一具器药。不能自愈其病。虽多讽经而不持戒。譬如人病得王家药。不自护坐死。虽多讽经而不持戒如是。譬如摩尼珠堕于屎中。虽多讽经而不持戒。譬如死人着金傅饰。不持戒反被袈裟。像如持戒沙门。譬如长者子服饰。着新衣着新傅饰。多讽经持戒好亦如是。佛语迦叶。有四事。不持戒像类持戒人。何等为四。一者若有比丘禁戒所说不犯缺也。虽有是有着呼有人。二者若比丘悉知律经。着行是我所行。三者若有比丘着我是我所。四者常行等心。等心于人着怖畏于死生。是为沙门不持戒名持戒。佛语迦叶言。禁戒无形不着三界。何因名为戒。无吾无我无人无命无意无名无种无化无教。无有作者。无所来无所去。无制无灭。无身所犯无口所犯无心所犯。无世无计无世所住。亦无有戒亦不无戒。亦无所念亦无败坏亦无坐立。是故为禁戒矣。尔时佛说曰。戒无瑕秽着也。戒者无奢无嗔恚。安定就泥洹。如是为持戒。不爱身亦不爱命。不乐于五道。悉晓了人于法。于佛法中是故为戒。适不在中边止也。中边不着不着不缚。譬空中风。是为持戒名及种无所止也。人定心无所著。无我想无人想。晓是者是为净持戒也。不轻于禁戒不自贡高。常欲守道持戒。如是无有能过者。离我所想。自我及是我所。都无有是也。信于空及佛法行不沾污于世。不着于世间。从冥入明适无所因。不着于三界。是为持戒。时佛说是经法。二万二千诸天人。及世间人民诸龙鬼神。皆得须陀洹道。八百沙门皆得阿罗汉道。五百沙门素皆行守意得禅道。闻佛说深经皆不解不信。便从众坐避易亡去。迦叶比丘白佛言。是五百守禅比丘。闻深经不解不信摩诃而去。佛语迦叶。是五百守禅比丘信余众多。闻深法教不解不信。佛语迦叶。是五百比丘者。乃前迦叶佛时皆作婆罗门道。于迦叶佛所。一返闻经道心意乐喜。即时五百人自说言。迦叶佛所说快。乃尔五百人得是福祐。寿终皆生忉利天上。佛言。五百比丘得是福已。后于我法中作沙门。今闻深经不解不信。佛语迦叶言。是五百比丘持是所闻深经。得不堕恶道。于今世。皆当得阿罗汉般泥洹去。佛语须菩提言。汝行教五百亡去比丘令来还。须菩提白佛言。是五百比丘尚不欲闻佛所说。何肯随小罗汉语乎。佛即时化作两比丘。于五百比丘前徐行。五百比丘皆使行。及前两比丘。五百比丘问前两比丘言。二贤者欲何至凑。两比丘报言。欲到空闲山中安隐之处。自守坐禅不能复忧余。五百人复问言。何以故。两比丘复报言。佛所说深经。我不信不解也。五百人复报言。我亦欲入山止空闲之处。快坐禅无人来娆我。我曹亦复闻佛说经不信不乐也。两比丘复报言。是事当共谛议不戏也。不争者是为比丘法也。何因为泥洹身中。有我有神有命有人有意耶。当有至泥洹处者耶。五百人报言。是身亦无人亦无我亦无名亦无意亦无有。行至泥洹处者也。两比丘复报言。何等尽。当得泥洹者。五百人复报言。尽淫尽怒尽痴。是为泥洹。两比丘复问言。卿曹淫怒痴悉尽未。五百人复报言。亦无内亦无外也。两比丘复问言。贤者当莫着亦莫不着。虽不着莫不着。是为泥洹。禁戒不在死生。亦不在泥洹。智黠适等度脱见黠。亦不在死生。亦不在泥洹。是本法空无色。亦无所见。弃思想弃泥洹想。灭思想痛痒。得疾至所有法莫念。亦莫不念。灭思想痛痒。是为无所为。尔时两比丘说是经法。五百人皆得阿罗汉道。五百人屈还至佛所。须菩提问五百人言。诸贤者去至何所从何所来。五百人报言。佛所说经。无所从来去亦无所至。须菩提问五百人。谁是汝师者。五百人报言。本无有生何因当有出。须菩提复问。谁为卿曹说经者。五百人报言。无五阴无四大无六衰。是为我师。须菩提复问言。师为汝说何等经。五百人复报言。无缚亦无放。须菩提问言。本从何因缘守道乎。五百人报言。亦无守亦无有不守。须菩提复问言。所作为当如是。五百人复报言。亦无有当所作如是者。须菩提复问言。以为降伏魔耶。五百人复报言。无有五阴与魔也。须菩提复问言。卿曹当何时般泥洹乎。五百人复报言。化人般泥洹者。我尔时亦当复般泥洹。须菩提复问言。谁愈卿者。五百人复报言。无身无心是我师也当愈我。须菩提复问言。卿曹爱欲尽未。五百人复报言。诸缘法本尽。须菩提复问言。卿曹已住罗汉地耶。五百人复报言。亦无所取无所放。须菩提复问言。卿曹死生已断耶。五百人复报言。本断亦无所见。须菩提复问言。卿曹住能于忍地耶。五百人复报言。一切已脱着中去。时须菩提问事以所可报五百人。尔时百二十万人。及诸天鬼神龙皆得须陀洹道。千三百比丘皆得阿罗汉道。佛说经已。比丘比丘尼优婆塞优婆夷。诸天世人鬼。神龙皆欢喜。前为佛作礼而去

佛说遗日摩尼宝经


佛说优填王经

    No. 332 [Nos. 310(29), 333]

佛说优填王经

        西晋沙门释法炬奉　诏译

闻如是。一时佛在拘深国。王号曰优填。拘深国有逝心。名摩回提。生女端正华色世间少双。父睹女容一国希有。名曰无比。邻国诸王。群僚豪姓靡不娉焉。父答曰。若有君子容与女齐吾其应之。佛时行在其国。逝心。睹佛三十二相八十种好。身色紫金巍巍堂堂光仪无上。心喜而曰。吾女获匹。归语其妻曰。吾为无比得婿。促庄饰女将往也。夫妻共服饰。其女步瑶华光。珠玑璎珞庄严光国。夫妻共将女至佛所。妻道见佛迹相好之文光彩之色。非世所有。知为天尊。谓其夫曰。此人足迹文理乃尔。非世所闻斯将非凡。必自清净无复淫欲。将不取吾女无自辱也。夫曰。何以知其然。妻因说偈言

  淫人曳踵行　　恚者操指步
  愚者足躘地　　斯迹天人尊

逝心曰。非尔女人所知。汝不乐者便还归。乃自将女诣佛所。稽首佛足白佛言。大人勤劳教授。身无供养有是粗女愿给箕帚。佛言。汝以女为好耶。答曰。生得此女颜容实好世间无双。诸国王豪姓多有求者不以应之。窃见大人光色巍巍非世所见。贪得供养故宜自归耳。佛言。此女之好为着何许。逝心曰。从头至足周遍观之无不好也。佛言。惑哉肉眼。吾观之从头至足无一好耶。若头上有发。但是毛象马之尾亦皆尔也。发下有髑髅。但是骨屠家猪头骨亦尔也。头中有脑者如泥腥臊送。鼻下之着地莫能蹈者。目者是脆决之纯汁。鼻中有涕。口但有唾。腹藏肝肺皆亦腥臊。肠胃膀胱但成屎尿腐臭难论。腹为帏囊裹诸不净四支手足骨骨相拄筋连皮韬。但恃气息以动作之。譬若木人机关作之。既毕解列其体节节。相离手足狼藉人亦如是。有何等好而云少双。昔者吾在贝多树下。第六魔天王庄饰三女。颜容华色天中无比非徒此论。欲以坏吾道意。我为说身中秽恶。即皆化成老母形坏不复惭愧而去。今是屎囊欲何所恋急将还去。吾不取也。逝心闻佛所说忽然惭耻无辞复言。又白佛言。若仁不取者更以妻优填王可乎不。佛不答焉。逝心。即送女与优填王。王获女大悦。拜父为太傅。为女兴宫。伎乐千人以给侍之。王正后师事佛。得须陀洹道。此女赞之于王。王惑其言以百箭射其后。后见箭不惧都无恚怒。一意念佛慈心长跪向王。箭皆绕后三匝还住王前。百箭皆尔。王乃自惊畅然而惧。即驾白象金车驰诣佛所。未到下车避从步进稽首佛足。长跪自陈曰。吾有重咎在三尊。所以彼淫妖从欲兴邪。于佛圣众每一恶念。以箭百枚射佛弟子。如事陈之睹之心惧。唯佛至真无量之慈。白衣弟子慈力乃尔。岂况无上正真佛乎。我今首过归命三尊。唯佛弘慈原赦其咎。佛笑曰。善哉王。觉恶悔过此明人行也。吾受王善意。王稽首。如是至三佛亦三受之。王又头面着地退就坐曰。禀气匈顽忿戾自恣无忍辱心。三毒不除恶行快意。顺女妖邪不知其恶。自惟寿终必入地狱。愿佛加哀广说女恶魑魅之态。入其罗网鲜能自拔。吾闻其祸必以自诫。国民巨细得以改操。佛言。用此问为且说余义。王曰。余事异日说之不晚。女乱惑意凶祸之大。不闻其祸何缘远之。愿佛具为吾释地狱之变及女人之秽。佛言。具听。男子有淫之恶却睹女妖。王曰。善愿受明教。佛言。具听男子有四恶急所。当知世有淫夫。恒想睹女思闻妖声。远舍正法疑真信邪。淫网所綶没在盲冥。为欲所使如奴畏主。贪乐女色不觉九孔恶露之臭秽。浑沌欲中。如猪处溷不觉其臭。快以为安不计后当在无泽之狱受痛无极。注心在淫啖其涕唾玩其脓血。珍之如玉甘之如蜜。故曰欲态之士此为一恶态也。又亲之养子怀妊生育。稚得长大勤苦难论。到子成人惧家竭财膝行肘步。因媒表情致彼为妻。若在异域寻而追之。不问远近不避勤苦。注意在淫捐忘亲老。既得为妻贵之如宝。欲私相娱乐恶见父母。信其妖言。或致斗讼不惟身所从生。孤亲无量之恩。斯谓二恶态也。又人处世勤苦疲劳。躬自致财本自诚信敬道之意尊戴沙门。梵志之心觉世非常。布施为福取妻之后。情惑淫欲愚蔽自拥。背真向邪专由女色。若有布施之意。虽欲发言相呼女色。绝清净行更成小人。不识佛经之戒祸福之归。苟为淫色投身罗网。必堕恶道终而不改。斯谓三恶态也。又为人子不惟养恩。治生致财不以养亲。但以东西广求淫路。怀持宝物招人妇女。或杀六畜淫祀鬼神。饮酒歌舞合会之后。至求方便更相招呼。以遂奸情。及其获偶。喜无以喻。淫结缚着无所复识当尔之时唯此为乐。不觉恶露之臭秽地狱之苦痛。一则可笑二则可畏。譬若狂犬不知其非。斯谓四恶态也。佛言。男子有是四恶用堕三涂。当审远此态免苦耳。复听说女人之恶。佛便说偈言

  已为欲所使　　放意不能安
  习施于非法　　将何以为贤
  欲为畜生行　　以欲还自殃
  溷虫在臭中　　不知为处难
  如虫在冥中　　不知东以西
  结着于淫欲　　恶此亦虫论
  淫既不见道　　日夜种罪根
  现世君臣乱　　上下为迷昏
  王法为错乱　　正法为迷樊
  农夫舍常业　　贾人为珍连
  现世更牢狱　　死复入太山
  当受百种毒　　其痛难可当
  洋铜灌其口　　山连笮其身
  此辈有百数　　难可一一陈
  常在三恶道　　宛转如车轮
  若世时有佛　　而已不得闻
  女人最为恶　　难与为因缘
  恩爱一缚着　　牵人入罪门
  女人为何好　　但是屎尿囊
  何不谛系视　　为此而狂荒
  其内甚臭秽　　外为严饰容
  家有含毒蝎　　剧如蛇以龙
  譬如锦韬牟　　罗縠綶锋铓
  愚者睹其表　　玩之以自殃
  智者觉而舍　　痴者致死伤
  淫欲亦如是　　抱刃以自丧
  睹新即厌故　　所乐亦无常
  言为刀斧截　　笑为棘以荆
  内怀臭秽毒　　饰外以华香
  痴人贪其味　　不惟后受殃
  譬若鸩毒药　　以和甘露浆
  所向无不坏　　饮之皆仆僵
  亦如薪得火　　草木被重霜
  睹表不计里　　是为最非详
  女毒甚于是　　草乃见形伤
  绝欲以求道　　故有淫欲情
  其形甚易见　　痴人情不绝
  罗网四面张　　去道如丝发
  人本清净种　　如鱼处深渊
  智者乃自觉　　着网不得还
  欲网甚于是　　结缚甚欲坚
  投身置荆棘　　可得脱其身
  譬若饥猿猴　　望见熟甘果
  专心投色欲　　是辈百向堕
  亦如鱼食钩　　飞蛾入灯火
  愚者见欢喜　　不惟后受祸

佛说如是。优填王欢喜即以头面着地。白佛言。实从生以来不闻女人之恶乃尔。男子。悖乱随之堕罪。但不知故不制心意从今已后终身自悔。归命三尊不敢复犯。为佛作礼欢喜而去

佛说优填王经


父子合集经卷第一

    No. 320 [No. 310(16)]

父子合集经卷第一

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净饭王始发信心品第一

如是我闻。一时佛在舍卫国。说法施化能事毕已。往迦毗罗国。去城不远住尼拘律陀林中。与大比丘众千二百五十人俱。皆阿罗汉。诸漏已尽无复烦恼。心善解脱慧善解脱。如大龙王。所作已办。弃诸重担逮得己利。尽诸有结心得自在。能到最上究竟彼岸。其名曰阿若憍陈如。摩诃迦摄。优娄频罗迦摄。伽耶迦摄。那提迦摄。舍利弗。大目干连。众所知识。大阿罗汉等。复有种类差别舍邪归正外道尼干子沙门婆罗门。无数众会皆悉来集。所谓调伏调伏众。寂静寂静众。善超彼岸善超彼岸众。善住安隐善住安隐众。出离烦恼出离烦恼众。能离罪恶能离罪恶众。洗除罪垢洗除罪垢众。善超三有善超三有众。远离五尘远离五尘众。离诸障碍离诸障碍众。清净意乐清净意乐众。具足诸根具足诸根众。违顺解脱违顺解脱众。善护自身善护自身众。具诸正念具诸正念众。具四神足具四神足众。乐说明记乐说明记众。明了缘谛明了缘谛众。善寂诸根善寂诸根众。决定信解决定信解众。乐求义利乐求义利众。观察无我观察无我众。离诸分别离诸分别众。断除疑惑断除疑惑众。身行轻安身行轻安众。自在爱乐自在爱乐众。心善解脱心善解脱众。慧善解脱慧善解脱众。住圣种族住圣种族众。如是众会身意泰然乐得善利。各与徒属来诣佛所。犹如广大钵罗奢树枝叶繁茂生长圆满。清净而住

尔时世尊。于初夜分露地而坐。寂然无声。一切大众恭敬围绕。于是如来观察时会诸比丘众。而问之曰。何人堪往化净饭王劝导发心生净信解。时尊者憍陈如即从座起。偏袒右肩右膝着地。合掌作礼。白言世尊。我当愿往。佛言。憍陈如。汝居声闻最为上首。先解谛义有大名称。一切众生尊奉如师。且止是说。不须汝往。是时会中四大迦摄及舍利弗目干连等。各伸礼敬而作是言。我能往化净饭圣王。佛皆不允。止之如初。时大目干连即作是念。未知如来今遣何人诣父王所。遂入定观。乃睹如来心光远瞩彼优陀夷。犹如杲日穿其楼阁。从于东牖直注西垣。时目干连从定起已。往诣尊者优陀夷所。而语之曰。世尊召子。往化父王故相报尔。优陀夷曰。果蒙教敕固当从命。目干连曰。尊者所往此极难事。宜自审悉无贻后悔。所以者何。彼为灌顶刹帝利王。威德尊严性无敢犯。孰能导达何由召对。况复教化发生信心。今取诸譬子当可悉。如以百夫于累岁中。担负干薪积成大聚。纵火焚之其焰猛炽。复以酥油而沃其上。颇有人能于此广大火聚中行不为所害。又如有人欲于最胜龙象口中而取其牙。当知是人必遭所损。今欲往化净饭圣王。此极为难。亦复如是。我今粗陈少分譬喻。临事筹量好自安意。于是世尊乃召尊者优陀夷至。而语之曰。于我声闻弟子之中。汝为释种。具足辩才善说法要。今可往化净饭父王。以善方便开发道意。时优陀夷承佛指喻。唯然受教。白言世尊。我今当往。唯愿大慈勿垂轸虑。设使父王或见致怒。遥冀慈光冥加救护。尔时世尊为优陀夷。而说偈言

  贤哉优陀夷　　今当听我说
  汝具智辩才　　众中为上首
  释种净饭王　　见必生忻悦
  是故汝应往　　速劝令发心
  若能化父王　　发生清净意
  诸天及世人　　咸增长善利
  安闲不修善　　如沮岸将坠
  当于现生中　　除我慢疑惑
  富贵刹那顷　　增放逸染着
  如羁旅无财　　所思唯有苦
  处最胜宫殿　　受殊妙欲乐
  佛教不了知　　乐坏生悲恼
  具四种兵众　　七宝诸眷属
  随意而自在　　乐坏生悲恼
  有夜叉鬼神　　啖众生精气
  令人染众病　　于身何不护
  积聚诸珍宝　　如计罗娑山
  染慧所缠缚　　不能自观察
  由染慧覆心　　善法无所了
  如人处梦中　　何能有知觉
  凡夫失明慧　　决定获忧怖
  犹如涉远道　　而丧其伴侣
  是故优陀夷　　当以善方便
  劝王立信幢　　摧我慢高举
  余人非善巧　　奖助令发心
  汝具妙辩才　　能示三有苦
  我念过去劫　　有王出于世
  名称遍十方　　号曰真实聚
  以善法治世　　境极海边际
  具胝那臾多　　臣民咸归奉
  诸聚落城邑　　多种种花果
  地唯生软草　　无瓦砾荆棘
  流泉及林木　　处处皆围绕
  百千乾闼婆　　互奏诸音乐
  贤圣集其中　　民物咸丰乐
  多诸比丘众　　依止持净戒
  复有诸外道　　大仙大智者
  其数有百千　　舍所修苦行
  咸生真实见　　信乐佛正法
  怖彼三恶道　　愿得生天果
  彼王有太子　　名曰坚固慧
  值过去诸佛　　久植诸德本
  俱胝那由他　　人民皆亲近
  观五欲过患　　心常生厌离
  睹王所居处　　如彼天宫殿
  后妃竞围绕　　受欲乐无极
  是时坚固慧　　即启白父王
  我今诚实心　　誓求无上道
  于采女眷属　　都不生忻乐
  少年着欲者　　乐坏苦即至
  如往古大仙　　栖止于山谷
  五欲非究竟　　寂静即为乐
  王语坚固慧　　勿作如是说
  若不受欲乐　　何名为我子
  有国之富贵　　如彼多闻天
  诸宫殿楼阁　　众宝而庄严
  百千众妓乐　　周匝常围绕
  具最上色相　　类天女无异
  面貌皆圆满　　唇丹齿齐密
  额广复平正　　目比青莲叶
  形仪悉端直　　肤洁犹珂雪
  作众妙歌舞　　而共相娱乐
  年少色鲜白　　如彼枝上华
  汝当住于此　　勿弃于荣贵
  我今诚谓汝　　非毁亦非誉
  太子善了知　　王位极尊胜
  我闻是说已　　决志求出难
  于彼五欲境　　不着如梦寐
  复白于父王　　自念从无始
  为欲之所溺　　娱情不知愧
  犹如彼盲夫　　艰辛趣险道
  自舍平坦处　　凭谁为归救
  于欲不了知　　何由脱苦缚
  当离于险道　　此心非颠倒
  若能远诸欲　　安隐除过患
  当知着欲者　　如盲无所见
  欲境如瀑流　　倾注难防护
  世有明智人　　当生于厌怖
  欲为众苦因　　损害逾蛇螫
  刀杖与毒药　　炽火然相似
  坚固慧王子　　含悲白父王
  我志在山林　　离欲求解脱
  是身深可厌　　老病苦萦缚
  不顾王宝位　　愿允听出家
  是时王族中　　童子名月施
  见太子出家　　亦随修梵行
  太子出家已　　具勇猛精进
  获得五神道　　善修四无量
  人中释师子　　说法无所畏
  教化诸众生　　皆令入佛道
  彼月施童子　　以善巧方便
  示五欲过患　　劝王发道意
  优陀夷当知　　往昔坚固慧
  于汝意云何　　今则我身是
  其月施童子　　乐修真实行
  同居释种中　　今则汝身是
  是故优陀夷　　汝今应当往
  劝父王发心　　增长诸善利

尔时尊者优陀夷。闻佛世尊说是偈已。钦承慈旨作礼而退。于晨朝时执持应器。往迦毗罗城诣王宫门。见有百千释种皇族共集一处。时彼众中有一释种。名曰月面。与优陀夷旧为知识。遥见尊者往相慰问。何缘至此。优陀夷曰。今从世尊所住之处尼拘律陀林中。匍匐而来。奉佛慈旨遣令教化净饭父王开发净信。彼闻说已。而作是言。昔者太子若不舍家。决定当作转轮圣王。十善治化王四天下。当有七宝自然出现。所谓轮宝象宝马宝珠宝女宝兵宝主藏神宝。复有千子之所围绕。一切人民恭敬尊重。今既出家志乐空寂。则失如是广大富贵。今所集会正议此耳。所言未竟。时净饭王即召释种群列于庭。而语之曰。卿等当知。悉达太子弃舍国位上妙快乐。乐居林野。一何错谬。而今而后汝等不应往诣彼所供养恭敬。若有违者。必当捶罚。时有释种名曰善悟。聪慧明达多诸善巧。出至宫门见优陀夷。方便附近渐至屏处。始敢伸问。世尊导师。起居轻利安隐快乐。四大调和少病少恼。化度众生无疲劳耶。复有释种名曰无忧。复有释种名曰离忧。诣尊者所问讯世尊。一如前说。我等咸欲诣世尊所。适奉王旨。诸释种等不得于佛亲近供养。若有违越必行捶罚。为惧严敕无敢往者。时优陀夷闻已太息。净饭父王。何意如是。如来慧日出现世间。于诸众生多所饶益。一切人民四大天王帝释天主梵天王等。竞伸供养曾无虚日。我当求见彼净饭王具陈上事。乃入定观。知彼父王信根成熟决定可化。时尊者优陀夷具诸威仪。结跏趺坐涌在虚空。高七多罗树即现种种神通变化。时净饭王。遥见尊者乘空而来。心生欢喜合掌瞻仰。说伽陀曰

  希有成就殊胜行　　现诸神变具威仪
  乘空至此有何缘　　唯愿圣者速当说

尔时尊者优陀夷。以偈答曰

  我是圣王子之子　　依止如来法中住
  愿王速发净信心　　于胜福田兴供养
  太子弃国成佛道　　具胜吉祥大名称
  身光常照于世间　　智光能破诸痴暗
  犹如赫日除云翳　　空中普放大光明
  龙子智光亦复然　　于三有中常照耀
  又如皎月舒盛光　　揜蔽游空诸宿曜
  龙子智光亦复然　　能伏一切诸外道
  又如师子吼岩谷　　众兽闻已悉奔窜
  龙子宣畅妙法音　　摧诸异论令开解
  苦行外仙邪妄智　　不能入解无我理
  流转轮回三界中　　由无胜慧迷真谛
  一切世间诸有情　　盲无慧眼难出离
  如来开发智光明　　为破无始无明医
  善恶二途极明显　　一为平坦一险阻
  如来善为指其迷　　没淤泥者能救拔
  譬若云能含众水　　普滋大地无高下
  佛施法雨亦复然　　增长人天诸善种
  雨能充洽诸山林　　药草根茎及枝叶
  众妙花蘤悉开敷　　周遍庄严于大地
  亦如龙子雨法雨　　滋荣佛法功德树
  十力无畏不共法　　成熟菩提智花果
  海中众宝弥卢山　　焕赫岿然而不动
  佛处声闻大会中　　最胜光明无与等
  三十三天帝释主　　广兴供养妙庄严
  龙子巍巍大沙门　　诸天见者咸开悟
  欲入佛法解脱海　　成就智慧法宝藏
  当以戒定为船筏　　能至念处摩尼聚
  太子昔修诸苦行　　或住陂池或岩窟
  或依迥绝旷野中　　善达空无相无作
  牟尼大仙师子吼　　指诱群迷生觉悟
  如是善巧方便力　　难化能化使柔顺
  佛为最上调御师　　能施众生诸法宝
  寂静妙乐奢摩他　　戒定功德坚固藏
  若能依教修诸行　　除惑灭罪令清净
  是故天人阿修罗　　常乐闻持佛正法

于是净饭王。为尊者优陀夷。而说偈言

  我子舍家无少乐　　或乏饮食或卧具
  犹如鲜洁青莲华　　置之陆地当枯悴

尊者优陀夷。以偈答曰

  如来游戏诸神通　　常餐禅悦无饥渴
  由住寂静妙等持　　若金莲华体坚实

时净饭王。复说偈言

  太子昔在皇宫日　　百千采女常围绕
  睡寤常闻歌吹声　　栖止山林有何乐

尊者优陀夷。以偈答曰

  佛住解脱胜境界　　深心依止诸禅定
  行住坐卧威仪中　　常生喜乐曾无苦

时净饭王。复说偈言

  太子昔在皇宫日　　众妙茵褥敷卧具
  百千灯炬常照明　　向夕未尝知有暗

尊者优陀夷。以偈答曰

  牟尼广修殊胜行　　以四无量为茵褥
  心常利乐诸有情　　于中庸境无痴钝

时净饭王。复说偈言

  昔时太子居深殿　　游戏受用诸快乐
  左右侍卫善承迎　　独止山林何所得

尊者优陀夷。以偈答曰

  如来所止悉清胜　　乐居寂静阿兰若
  平等观视于世间　　常得天龙常恭敬

时净饭王。复说偈言

  昔日太子处王宫　　沐浴嫔嫱竞承事
  上妙涂香以莹身　　栖止山林何所得

尊者优陀夷。以偈答曰

  牟尼持戒为浴池　　永涤诸恶净无垢
  能令自他悉清净　　离众尘秽登彼岸

时净饭王。复说偈言

  太子所著殊妙衣　　金缕贯饰珠璎珞
  旃檀和合妙涂香　　栖止山林何所得

尊者优陀夷。以偈答曰

  牟尼以惭为上服　　菩提分法如珠鬘
  护戒清凉若涂香　　以用庄严功德体

时净饭王。复说偈曰

  太子所住常严警　　百千勇士持戈胄
  伞盖迎空蔽日光　　独向山林谁守护

尊者优陀夷。以偈答曰

  牟尼具足十智力　　于诸怖畏心不动
  慈悲普荫诸群生　　沙门法子常围绕

时净饭王复说偈言

  善哉善说佛功德　　不久当往闻法要
  愿今先受我供养　　复持香饭奉如来

父子合集经卷第一父子合集经卷第二

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净饭王始发信心品第一之余

时尊者优陀夷。知净饭王心生感悟。说偈赞已。白言大王。今佛世尊出兴于世为大法王。具足成就诸善功德。于彼沙门大众之中。犹如满月众星围绕。世尊光明复过于彼。大王。如来出世。如秋空日无云覆蔽其光特盛。佛于沙门大众之中。光明照耀复过于彼。又如海中有光明山。其光赫奕出于众山。佛处沙门大众之中。光明照耀复过于彼。又如帝释处善法堂。天众围绕身光炽盛异诸天子。佛于沙门大众之中。光明照耀复过于彼。又如大梵天王百千俱胝梵众围绕。一切身光无与等者。佛于沙门大众之中。光明照耀复过于彼。时净饭王。闻说世尊如是最胜光明威神。复自忆念。往昔太子初降生时。地六震动。所谓动遍动极遍动。起遍起极遍起。涌遍涌极遍涌。震遍震极遍震。击遍击极遍击。吼遍吼极遍吼。光照天地无与等者。即行七步不假扶掖。是时空中澍二种水。一者温暖。二者清冷。用为灌浴太子之身。地中自然涌出宝座。殊妙伞盖悬处虚空。有诸天子恭敬尊重。手执白拂侍立左右。乃至菩萨长年舍家厌五欲乐。常住正念说诚实语。令诸有情不相损害。所作决定勇猛坚固。愿成无上正等菩提。未得度者皆令得度。渐次至于究竟彼岸。于是净饭王为优陀夷。而说偈言

  若人初生时　　言说唯决定
  彼具寂静慧　　智者何不信
  太子初生时　　世间无与等
  为世所尊重　　智者何不信
  乃至于梦中　　曾无虚妄说
  如说而修行　　智者何不信
  于境不生贪　　不为贪所缚
  不顾金宝聚　　智者何不信
  嗔如利刀剑　　忿怒令他怖
  善离彼过失　　智者何不信
  胜慧常相应　　惊怖不能动
  由离痴过失　　智者何不信
  受用五欲乐　　不为彼缠缚
  胜慧善决择　　智者何不信
  百千种幻术　　无少分真实
  善人非所乐　　智者何不信
  无数巧妙言　　毕竟为戏论
  于缚不能脱　　智者何不信
  若爱乐法乐　　相应诸义利
  决定能离缚　　彼言何不信
  离垢方便力　　人孰能防御
  逾城出释宫　　彼言何不信
  弃舍五欲乐　　栖山若麋鹿
  志乐求菩提　　彼言何不信
  六年修苦行　　为度诸众生
  求最上菩提　　彼言何不信
  六年食麻麦　　不思诸美膳
  求最上菩提　　彼言何不信
  六年处谷山　　众魔来伺隙
  不能见少过　　彼言何不信
  何人不求利　　独无少希望
  善离贪过患　　彼言何不信
  无上正等觉　　若他未曾闻
  难信复难解　　彼言何不信
  若梵天请转　　或世尊自说
  如是微妙法　　彼言何不信
  怜愍释种故　　示生于王宫
  皆令脱苦缚　　彼言何不信
  未登彼岸者　　教诏令得度
  常发如是愿　　彼言何不信
  世尊于往昔　　尝如是劝化
  当知今亦然　　彼言何不信
  是故我今者　　求见法中王
  如是谛观察　　得身心清净

时净饭王说是偈已。复更思惟。谓尊者曰。是身何久。乃发道意。时优陀夷为净饭王。而说偈言

  大王今作人中主　　应当修习诸义利
  如来称赞发心因　　常得生于尊胜处
  若能发生清净意　　往诣牟尼大仙所
  所获功德难可量　　增长人天诸善种
  如来昔为王太子　　大悲愍念诸群萌
  广行平等无量心　　犹若莲华不着水
  一切有情没瀑流　　佛能救拔令出离
  是名无上两足尊　　王发净心善调伏
  佛智最上最第一　　善拔众生疑惑箭
  永离众苦得安乐　　王发净心善调伏
  太子永断三有缚　　降伏四种魔军众
  得成无上大菩提　　王发净心善调伏
  开示解脱甘露法　　帝释人王咸劝请
  利乐三界诸有情　　王发净心善调伏
  能转最胜妙法轮　　摄化一切诸外道
  其数俱胝那臾多　　王发净心善调伏
  如来慧眼极清净　　众生无明之所覆
  说法能除彼痴暗　　王发净心善调伏
  众生老死所逼迫　　如来说法除忧怖
  方便令登常乐门　　王发净心善调伏
  如来出现于世间　　如空四澍大云雨
  能灭炽然三毒火　　王发净心善调伏
  牟尼十力智光明　　销灭众生三世罪
  毕竟远离诸过咎　　王发净心善调伏
  如来常以大悲心　　爱念众生如赤子
  皆令离苦得解脱　　王发净心善调伏
  难化刚强诸众生　　如来方便能摄受
  令除掉举与憍慢　　王发净心善调伏
  众生没于贪欲海　　诸天着乐亦复然
  佛垂十力能拯接　　王发净心善调伏
  如来大悲无与等　　无量功德所庄严
  能救众生长夜苦　　王发净心善调伏
  如来大悲方便力　　若摩尼珠能莹水
  善除斗诤垢浊因　　王发净心善调伏
  如摩尼宝本性净　　众生见已咸欢喜
  牟尼永离烦恼因　　王发净心善调伏
  人天多受别离苦　　佛令获得寂静乐
  出离轮回生死因　　王发净心善调伏
  牟尼成就功德海　　我今略说一少分
  譬如虚空无有边　　王发净心善调伏

时净饭王闻偈赞已。即自忆念。向者菩萨未出家时。我曾亲见作胜事业。正念相应发决定愿。我当舍家誓成佛道。度诸众生令至彼岸。乃谓尊者优陀夷曰。汝今即是如来之子。自食讫已别赍供养。然后我当诣世尊所。时优陀夷生大欢喜即持香饭奉上如来。佛受供已。召诸比丘而告之曰。彼优陀夷。我遣往化净饭父王。今已信解。佛即赞彼优陀夷言。善哉善哉。汝今获得无量福蕴。令诸世间诸天及人。闻是事已增长善根。有诸比丘。白言世尊。彼优陀夷得几所福。佛言。假使十方殑伽河中所有沙数无量无边不可称量。是优陀夷所得福报。与彼沙数正等无异。于是世尊食已收钵。安住威仪加趺而坐。入定观察。父王将至。即召北方多闻天王。与其眷属百千俱胝那臾多大药叉将。于自宫出从空而来。屈伸臂顷到于佛所。合掌作礼。供养世尊及比丘众。住立一面

复次东方持国天王。与其眷属百千俱胝那臾多乾闼婆众。从空而来到于佛所。合掌作礼供养世尊及比丘众。住立一面

复次南方增长天王。与其眷属百千俱胝那臾多矩畔拏众。从空而来到于佛所。合掌作礼供养世尊及比丘众。住立一面

复次西方广目天王。与其眷属百千俱胝那臾多诸大龙众。从空而来到于佛所。合掌作礼供养世尊及比丘众。住立一面

复次帝释天主。与三十三天无数天子。来至佛所作礼供养。如是焰摩天睹史多天乐变化天他化自在天大梵王天光音天广果天净居天。此诸天子。各与百千俱胝那臾多天子眷属。来诣佛所头面作礼。供养恭敬及比丘僧。住立一面

复次毗摩质多罗阿修罗王。与六十那臾多眷属。着新净衣次第装束。从空而来到于佛所。头面作礼供养世尊及比丘众。在一面住

复次迦娄罗王。与其眷属八万六千眷属俱。从空而来到于佛所。合掌作礼供养世尊及比丘众。住立一面

复有外道大仙婆罗门等八十俱胝。从于诸方来诣佛所。亲近供养。譬若满月丽于空中。威德光明隐蔽宿曜。时彼众中天龙鬼神摩睺罗伽等。一心同声。以偈赞曰

  佛具智光明　　最胜无伦匹
  降伏阿修罗　　灭三毒痴暗
  佛面犹满月　　众相悉庄严
  具最上辩才　　能破诸异论
  百福妙严身　　天人无与等
  开导诸声闻　　如莲出浊水
  如帝释天主　　天子常围绕
  威德胜诸天　　身光亦复尔
  如来二足尊　　法子常围绕
  善说诸法要　　令众生开悟
  如焰摩天主　　眷属常围绕
  安坐大众中　　诸天咸尊重
  佛身无边光　　照险难恶道
  堕落诸众生　　蒙光皆离苦
  睹史多天主　　天众常围绕
  由昔福报故　　身光独为胜
  天与阿修罗　　及余龙神众
  释师子光明　　清净超于彼
  乐变化天主　　皆来至佛所
  为佛光所蔽　　令知先福业
  如是佛光明　　最上无能比
  能化未调伏　　令生净信解
  他化自在主　　天众常围绕
  由宿善业故　　身光独为胜
  如来十力尊　　正行皆圆满
  于诸天人中　　光明极炽盛
  色界大梵王　　身光超梵众
  八种妙音声　　诸天无与等
  如来大法王　　八部常恭敬
  演四谛法音　　光照三千界
  诸天龙神等　　咸来至佛所
  希闻梵音声　　愿佛开未悟
  大海深可量　　虚空可知际
  须弥尚可称　　佛功德无极

    父子合集经王诣佛所品第二

时净饭王前已。谓尊者优陀夷言。不久我当躬诣佛所。谅惟世尊。他心先鉴。即召释种择吉祥日。于日天子初出之时。我当严驾决定往矣。时诸释种闻王教敕咸生忻庆。各作是言。善哉大王。愿当侍从。时净梵王敕令排备象马车乘宝饰辇舆。以净黄土遍覆道路。驾青色车青宝装铰。于其车上悬青伞盖。宝网交络宝铃和鸣奏妙音乐作众歌舞。有百勇士擐青甲胄着青革屣。周匝围绕。无数翊从服青色衣。各各执持青色幢幡。及青色拂。复以众宝而饰其柄。种种庄严青色鲜洁。次第行列安徐前进。驾黄色车黄金装铰。于其车上张黄伞盖。宝网交络宝铃和鸣奏妙音乐作众歌舞。有百勇士擐黄甲胄着黄革屣。周匝围绕。无数翊从服黄色衣。各各执持黄色幢幡及黄色拂。复以众宝而饰其柄。种种庄严黄色鲜洁。次第行列安徐前进。驾红色车红宝装铰。于其车上张红伞盖。宝网交络宝铃和鸣奏妙音乐作众歌舞。有百勇士擐红甲胄着红革屣。周匝围绕。无数翊从服红色衣。各各执持红色幢幡及红色拂。复以众宝而饰其柄。种种庄严红色鲜洁。次第行列安徐前进。驾白色车白银装铰。于其车上张白伞盖。宝网交络宝铃和鸣奏妙音乐作众歌舞。有百勇士擐白甲胄着白革屣。周匝围绕。无数翊从服白色衣。各各执持白色幢幡及白色拂。复以众宝而饰其柄。种种庄严白色鲜洁。次第行列安徐前进。驾彩画车众宝装铰。于其车上张彩画盖。宝网交络宝铃和鸣奏妙音乐作众歌舞。有百勇士擐彩画甲着彩画履周匝围绕。无数翊从服彩画衣。各各执持彩画幢幡及杂色拂。复以众宝而饰其柄。种种庄严杂色鲜洁。次第行列安徐前进。于众车后有八万象。一一象上皆有七宝所成楼阁。金幢间列甚可爱乐。复于象后有八万马。亦以金宝而铰饰之。时净饭王乘最胜象。从自宫中出迦毗罗城。诣尼拘律陀林。诸释种等肃恭随从。是时世尊。遥见父王将诸臣佐释种眷属城中人民渐次来至。召诸比丘出林观瞩。比丘见已深生随喜。叹未曾有。初睹咸谓三十三天帝释天主而来至此。王所行路净治平坦。散五色华烧众名香。于虚空中悬众缯鬘。种种伎艺诸妙音乐行列道侧。一时俱作。王意熙怡前诣佛所

父子合集经卷第二父子合集经卷第三

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净饭王致礼如来品第三

尔时净饭王。将诸释种前后围绕。诣尼拘律陀园中。到已即下宝饰车乘。与诸臣从徒步而进。世尊知已欲化父王舍除憍慢发生净信。即升空中现神变相。游行往来自在无碍。时娑婆世界主大梵天王。在如来左。帝释天主居如来右。焰摩天王都史多天王。乐变化天王。他化自在天王。各各执持种种宝盖。随从如来乘空而行。多闻天王持国天王。合掌作礼住立东面。增长天王广目天王。头顶致敬住立西面。复有六欲诸天眷属。雨诸天花优钵罗花拘没那花奔拏利迦花曼陀罗花。及雨上妙细末栴檀沉水香等。诸天伎乐众妙歌舞。于虚空中一时俱作

尔时世尊。以神通力化作无数七宝楼阁。微妙庄严光明赫奕。令彼时会若天若人互相往来各得相见。是时众会心大欢喜。从昔已来未曾有也。时净饭王睹斯瑞相生希有心。即作是说。如来昔日为太子时。不以四天下转轮王位富贵自在心生顾恋。今于三千大千世界为大法王。具足圣财神通自在。常得诸天恭敬围绕。胜过于彼不可比喻。我今唯有释种眷属及诸人民。而为侍从。作是说已。喜悦无量生清净心。偏袒右肩右膝着地。合掌恭敬瞻仰如来。头面致礼。复作是言。世尊初生无人扶侍。即行七步观视十方。我于世间。最尊最胜。更无过上。越老病死。尽苦边际。我于尔时见是事已。心生欢喜曾伸礼敬。又复世尊为太子时。往田野中观于农作。憩阎浮树荫凉之下。日虽西昃其影不移。是时复有六欲天子。合掌恭敬侍立其侧。我于尔时亦伸礼敬。今睹世尊现是瑞相。乃为第三向佛作礼。时净饭王欲重宣此义。而说偈言

  福智无比两足尊　　初生即行于七步
  唱言世间独为胜　　我于彼时曾致礼
  又观农作憩阴凉　　日昃其影不移动
  六欲诸天侍其侧　　我于彼时伸礼敬
  今佛现此神变相　　愍念于我及众生
  世间无有如佛者　　此乃第三头面礼
  昔日我为立其名　　号曰一切义成就
  已得佛果遂夙心　　喜悦犹如饮甘露

时六欲天子。知净饭王一心渴仰欲睹如来。先于尼俱律陀园中。为佛世尊敷师子座。其座高胜诸珍严莹。即以天中憍奢阇衣上妙白[疊*毛]铺设其上。又彼林中自然化出众妙衣服。周匝庄严处处垂下。设座毕已。迎请世尊安坐其上。我自舍家至于成佛。乃与父王初得相见。作是念已从空中下。时净饭王获奉如来心大欢喜得未曾有。瞻仰粹容目不暂舍。尊重赞叹问讯慰劳。佛于座上结加趺坐。王与释种退坐一面

是时复有色界诸天皆来佛会。所谓梵众天。梵辅天。大梵王天。少光天。无量光天。极光净天。遍净天。无量净天。无云天。福生天。广果天。无烦天。无热天。善现天。善见天。色究竟天等。睹佛世尊为化父王现斯瑞相。咸皆欢喜共相庆慰。各持天中曼陀罗花摩诃曼陀罗花。而散佛上。又复以诸上妙天衣悬于空中。而为供养。复以种种严身之具。宝冠耳珰。指环臂钏。珠佩璎珞。珍琦束带。或以黄金为鬘众宝间饰。众宝为鬘黄金间饰。如是宝鬘贯以金线。巧妙光丽。奉上如来。又以种种上妙宝盖宝幢宝幡。行列供养。时诸天子作供养已。头面作礼住虚空中。散诸香水如微细雨。各各合掌以偈赞佛

  归依最胜大丈夫　　善能摄化群生者
  具大福智及名闻　　一切世间无与等
  归依最胜大丈夫　　胜慧深广难思议
  大悲怜愍诸有情　　为说四谛真实法
  归依最胜大丈夫　　永离贪恚愚痴垢
  巍巍相好遍庄严　　犹若金山显大海
  归依最胜大丈夫　　能摧异论无怯弱
  咸令舍除迷妄情　　具修正见清净行
  我等自惟宿福庆　　得值能仁出世间
  以此供养少善根　　回向自他得作佛

    父子合集经阿修罗王授记品第四

尔时世尊为化父王现神变已。时彼会中有诸阿修罗王。瞩是瑞相心各踊悦。复见色界诸天子等广大供养。深生随喜。时有上首尾摩唧怛啰阿修罗王。而作是言。我今于佛最初供养。以神通力。于彼园中即时化作六十那庾多众宝网幔。杂色间饰弥覆空中。宝幔之下复现六十那庾多宝庄严地。宝地之上复现六十那庾多殊妙楼阁。一一楼阁宝为其门。黄金楼阁以银为门。琉璃为牖。砗磲为柱。玻璃为栱。码瑙为地。真珠等宝间饰庄严。白银楼阁以金为门。琉璃为牖。珊瑚为柱。砗磲为拱。玻璃为地。真珠等宝间饰庄严。乃至码瑙楼阁玻璃为门。如是七宝所成楼阁户牖柱栱次第庄严。一一门中各现众宝师子之座。于座左右皆有修罗童子童女。手执白拂或持宝扇侍立其侧。一一座上有众宝盖。于前复现众色宝幢。于黄金门现出青幢。黄色为顶黄金为干。于白银门现出黄幢。青色为顶赤宝为干。于琉璃门现出红幢。赤色为顶黄金为干。于众宝门现彩画幢。众色为顶白银为干。如上所现众宝网幔宝地楼阁宝幢幡盖回转空中。绕佛三匝行列而住。如三十三天伊罗钵那大龙象王。徐行旋绕帝释天主。亦复如此。又复降雨天诸妙花。所谓曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。波噜沙迦花摩诃波噜沙迦花迦哩迦啰嚩花摩诃迦哩迦啰嚩花。钵吒罗花摩诃钵吒罗花。唧怛啰钵吒罗花摩诃唧怛啰钵吒罗花。又雨七宝所成之花。黄金花白银花砗磲花码瑙花吠琉璃花玻胝迦花真珠花等。复雨珍琦玩好之具。时会所乐皆得如意。又复降雨众妙香水涂香末香沉水香等。时迦毗罗城所积之花。举高七尺广六由旬。与其香水合和成泥。佛神力故。其香普薰遍满三千大千世界。其中众生若天若人闻是香已。皆发阿耨多罗三藐三菩提心。得不退转。彼阿修罗王作供养已。乘七宝车绕佛三匝。合掌向佛以偈赞曰

  最胜无动尊　　圆成菩提果
  能化诸有情　　出离于三界
  我以清净心　　现前伸供养
  愿得如世尊　　永脱轮回苦
  牟尼大圣主　　离染除诸惑
  堪为天人师　　救拔超彼岸
  善宣微妙法　　调伏诸众生
  度老死苦厄　　故我称赞礼

时尾摩唧怛啰阿修罗王。偈赞佛已。我今供养心犹未足。复以海中所有一切无价珍宝。奉上如来。以神通力化作六十那庾多微妙宝车。一一宝车以调顺马而驾御之。皆以金宝装校严饰。一一车上有妙幰盖。悬众宝铃出声和雅。其上各有阿修罗女。色相具足献妙歌舞。作诸伎乐其声嘹喨闻者无厌。佛神力故。令此乐音遍彻三千大千世界。其中有情闻是声已。身意泰然离诸染着。皆于阿耨多罗三藐三菩提。心不退转。时阿修罗王作供养已。与其眷属心大欢喜。合掌向佛重说偈言

  愿我常亲近　　牟尼大导师
  设最上供养　　得尽诸苦际

尔时会中复有阿修罗王。名曰极喜。发清净心广兴供养。一一供养与尾摩唧怛啰阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。合掌向佛以偈赞曰

  归依无上十力尊　　具修无边真实行
  决定了达一切法　　永断诸惑得无畏
  归依三界大导师　　解脱有爱诸结缚
  己超菩提胜彼岸　　复能拯拔沉溺者
  如来善说出离道　　众生闻已咸信受
  皆令清净涤诸染　　犹若莲花不着水
  牟尼胜智善观察　　了诸法空亦无相
  不着一切有为行　　譬如虚空无所依

尔时会中复有阿修罗王。名曰妙臂。发清净心广兴供养。一一供养与极喜阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。手捧金栗散如来上。合掌向佛以偈赞曰

  稽首吉祥调御师　　天中世间无与等
  了知众生性本空　　但有假想如阳焰
  无作无受无众生　　无我无人无彼此
  无言无说自性空　　诸法本来常寂静
  推求诸法不可得　　则于佛教善入解
  是人得名法王子　　随顺先佛之所行
  我今于佛伸供养　　调伏难化诸众生
  以此称赞少善根　　回向自他皆作佛

尔时会中复有阿修罗王。名曰大力。发清净心广兴供养。一一供养与妙臂阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。以诸宝花而散佛上。合掌向佛以偈赞曰

  稽首大法王　　慧眼照三有
  已渡生死海　　到究竟彼岸
  教导诸有情　　除惑无怖畏
  越四种瀑流　　得至安隐处
  甚深微妙慧　　穷世间源底
  知众生所欲　　深着颠倒想
  常以大悲心　　开示令觉悟
  破彼邪妄智　　具足真实见
  了达一切法　　无垢无所著
  如幻化阳焰　　亦如水中月
  牟尼最胜尊　　视众生如子
  皆令修正行　　不着于三世
  如来出世间　　了法皆虚假
  自性无所得　　他性悉皆空
  如世间愚夫　　梦中受欲乐
  毕竟不可得　　应当如理思

尔时会中复有阿修罗王。名曰罗睺。发清净心广兴供养。一一供养与大力阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以上妙唧怛啰钵吒罗花而散佛上。合掌向佛以偈赞曰

  巍巍无上士　　身光极晃耀
  诸天及世人　　无有如佛者
  犹若以芥子　　比于弥卢山
  亦如牛迹水　　以况于溟渤
  如来妙色相　　世间无与等
  一一相端严　　观者心无厌
  妙相难思议　　超过一切色
  如日照世间　　余光皆隐没
  佛威德光明　　映蔽诸天众
  如月现长空　　星光皆晦昧
  慧深如巨海　　身相若金山
  佛身智光明　　三界无伦匹

尔时会中复有阿修罗王。名曰净戒。发清净心广兴供养。一一供养与罗睺阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以摩诃唧怛啰钵吒罗花。而散佛上。合掌向佛以偈赞曰

  牟尼具胜智光明　　能破贪恚愚痴暗
  成就最上奢摩他　　降注法雨沃群品
  如来金刚座道场　　炽然智炬照三有
  能爇众生烦恼薪　　使无遗余成灰烬
  无量百千俱胝劫　　积集任持妙法藏
  普施热恼诸群迷　　闻者皆如饮甘露
  如来出现于世间　　能示众生正法眼
  无明生死长夜中　　智慧摩尼能显照

尔时会中复有阿修罗王。名喜斗战。发清净心广兴供养。一一供养与净戒阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以上妙钵吒罗花而散佛上。合掌向佛以偈赞曰

  归依圣主释师子　　于诸法中得无畏
  犹如勇将擐甲胄　　降伏他兵无怯弱
  能仁诸根常寂静　　不为烦恼所动乱
  永尽三毒一切垢　　余习展转不复起
  如来六返观众生　　无爱无憎无分别
  安住无缘广大慈　　于冤亲境悉平等
  佛知众生种种想　　各各开示袪诸妄
  皆令善住正思惟　　了心如幻无所著

尔时会中复有阿修罗王。名曰妙眼。发清净心广兴供养。一一供养与喜斗战阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以摩诃钵吒罗花而散佛上。合掌向佛以偈赞曰

  大威德世尊　　了诸法实相
  所谓诸法者　　从因缘故有
  无法无非法　　寻求不可得
  若有法可说　　此说唯假名
  如是种种相　　本来常寂静
  无名亦无相　　牟尼之所说
  虽说而无说　　少分不可得
  说者既亦无　　听者亦如是
  善达如是义　　不着一切法
  则能行大行　　是名真佛子

尔时会中复有阿修罗王。名越三世。发清净心广兴供养。一一供养与妙眼阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以殊妙真珠璎珞奉施如来。合掌向佛以偈赞曰

  如来具足诸功德　　净戒威仪悉圆满
  四种魔军智伏除　　三界无与佛齐等
  如来定力无能动　　非浅智者所能测
  行住坐卧定相应　　现诸利乐神通事
  如来胜慧无过上　　于大众中师子吼
  善说妙法破群疑　　摄化一切诸外道
  如来身色超三有　　种种相好遍庄严
  光明赫奕若金山　　广修檀施所获得

尔时会中复有阿修罗王。名曰普耀。发清净心广兴供养。一一供养与越三世阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。复以众妙珍宝散如来上。合掌向佛以偈赞曰

  我等舍离五欲乐　　来诣佛所伸供养
  各见如来对已前　　此不共德难思议
  一音所演清净法　　或乐广说或略说
  各随意欲而解了　　此不共德难思议
  一音所演清净法　　随其趣类各得解
  如来善巧应其机　　此不共德难思议
  一音所演清净法　　或令修习或调伏
  或有获证诸果利　　此不共德难思议

尔时会中复有阿修罗王。名目真邻陀。发清净心广兴供养。一一供养与普耀阿修罗王。等无有异。作供养已。乘七宝车绕佛三匝。以赤真珠而散佛上。合掌向佛以偈赞曰

  如来善化于父王　　舍除憍慢及邪见
  令发坚固净信心　　此为最上无比子
  法无自性从缘生　　如梦受乐非实事
  应知彼乐随想起　　是则名了诸法性
  譬如秋空起浮云　　妄情执有非坚固
  依于牟尼教法中　　智者不应增我慢
  心善观察不放逸　　则于世间无所著
  是名安住佛法中　　当证如幼三摩地

时诸阿修罗王作供养已。各各合掌住立佛前。身意泰然快得善利。皆发阿耨多罗三藐三菩提心。尔时世尊知诸阿修罗王心之所念。于大众中现微笑相。即于面门放五色光。其光遍照普佛世界。绕佛三匝复从世尊顶门而入。时尊者马胜睹是相已。从座而起偏袒右肩。右膝着地头面作礼。白言。世尊。以何因缘现斯瑞相。合掌向佛以偈问曰

  人中最胜释师子　　现斯瑞相非无因
  唯愿大悲为我说　　闻已皆使心安泰
  六十那由阿修罗　　广大净心兴供养
  将非如来与授记　　令彼闻已生欢喜
  时会咸作是思念　　放此光明非小缘
  唯愿如来愍我辈　　为说现相之所以
  为当有发菩提心　　或复初生于净信
  如来各各悉了知　　愿决众疑速当说

尔时世尊以偈答曰

  善哉马胜大比丘　　汝能咨问放光事
  我今欲于众会中　　记别最上真实果
  诸阿修罗兴福业　　志求无上大菩提
  贪恚障染悉蠲除　　如手触空无所碍
  由此发生清净意　　广兴无边妙供养
  后当舍此修罗身　　常生胜处增明慧
  未来过彼河沙劫　　亲近承事诸如来
  后身得作法中王　　相继成佛同名号
  皆称最上灯如来　　名闻普遍十方界
  教化六十那庾多　　众生闻法咸得度
  国土广博极严净　　尽一三千大千界
  其中受化诸众生　　具足福德及智慧
  不造一切非法业　　皆修平等安乐行
  彼佛皆说无诤法　　闻者无著亦无碍
  佛寿六十那庾多　　众生住命等无异
  彼诸如来化缘终　　机感相从亦入灭
  次第绍隆得作佛　　国土寿量悉同然
  亦化如上诸有情　　受持正法为佛子

父子合集经卷第三父子合集经卷第四

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    如来本行品第五

尔时尊者大迦摄波。见诸阿修罗王于佛会中以神通力化作广大诸供养已。叹未曾有。而作是念。如来昔行菩萨道时种何善根。乃能获得如是最上殊胜果报。作是念已。入三摩地一心观察。由佛加持即能忆念无量无边阿僧祇劫。世尊往昔在在处处。精勤修习无量无边广大福业。一一显现谛了无疑。假使十方殑伽沙数世界。其中所有一切众生皆得人身。复于尔所河沙劫中。一一有情各兴供养。如彼尾摩唧怛啰阿修罗王。所有福蕴。不及如来一发无上正等觉心所有功德。不可为比。时尊者摩诃迦摄波。从定起已。欢喜合掌以偈赞佛

  往昔牟尼大圣王　　誓求无上大菩提
  修罗虽兴广供养　　不及发心所得福
  如来圣德超三界　　于天人中无等伦
  旃檀香积若须弥　　堪受如斯大供养
  上妙涂香极清净　　其量深广如巨海
  人中师子出世间　　堪受如斯大供养
  或散种种上妙花　　积聚高若轮围顶
  如来圣德妙难思　　堪受如斯大供养
  以大海水为膏油　　苏弥山量为其炷
  然灯奉施大导师　　堪受如斯大供养
  或以无数妙花鬘　　奉上如来及塔庙
  佛具广大胜威德　　堪受如斯大供养
  设于无量俱胝劫　　持以万亿妙宝盖
  如来善化于父王　　堪受如斯大供养
  于不思议俱胝劫　　以宝幢满十方界
  如来成就大慈门　　堪受如斯大供养
  复于无量俱胝劫　　以河沙数妙缯幡
  牟尼利乐诸众生　　堪受如斯大供养
  如来善说诸法要　　众生咸悉能听受
  辩才无碍法中王　　言辞善巧无相似
  假使殑伽沙世界　　其中所有诸众生
  皆为十力天人师　　同出世间成佛道
  如是无数河沙佛　　各各化出无量首
  一一首现百千口　　复于口有百千舌
  于彼殑伽沙劫中　　称赞如来功德海
  寿量智慧及发心　　不能了知一少分

尔时世尊赞尊者摩诃迦摄波言。善哉善哉。迦摄波。汝今于彼声闻众中。具修梵行了达诸法。现证实际心得寂静。于我所证功德蕴中。善能入解思惟观察。我已成就无量无边不可思议福德之聚。已到最上第一彼岸。迦摄。止于如来一发大心。所有福报。若有色相。十方所有河沙世界不能容受。假使十方殑伽沙数诸佛世尊同出于世。复于尔所殑伽沙劫。欲说如来一发大心所有功德。不能穷尽。所以者何。如来昔修菩萨行时。无一发心不为摄受利益安乐一切有情。彼有情界无限量故。如来发心亦无限量。以有情界毕竟无尽故。如来发心亦复无尽。是故我今得诸天人阿修罗王如是供养。假使十方殑伽沙世界。其中所有一切众生。皆作供养。如彼阿修罗王。犹不能及一发大心所获功德。所以者何。彼诸有情心不清净。着果报故。迦摄当知。过去无量诸佛出世。初发大心。皆为怜愍一切有情令脱轮回得涅槃乐。我今所作亦复如是。复次迦摄。我念过去无量无边不可称数不可思议阿僧祇劫。尔时有佛出现于世。名曰帝幢如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛刹中所有众生不造罪恶。心无散乱不起邪思。无颠倒见及彼憍慢。身语意业毕竟清净。伏除烦恼离恶趣因。精勤修习互相策励。能于生死长夜之中。发勇猛心爱乐大乘。听闻正法如理修行。彼佛刹中有五种乐。一者欲乐。二出离乐。三者定乐。四者等持乐。五菩提乐。彼诸众生而常受用如是快乐。虽受彼乐而不耽着。如蜂采花但延其命。如禽飞空无所挂碍。此诸众生亦复如是。又彼有情无贪恚痴种种恶业烦恼过患。随先善业而受其乐。何以故。彼佛修行菩萨道时。所化众生唯纯善行。设有先世不善故业。现善根力销伏不起。是故彼土一切有情。唯一乐受相应现行。又彼佛土无种种难暴恶风雨祁寒酷热。随时所欲即降甘雨。又彼众生常乐闻法。各能了达尊重恭敬。设若经行若坐若立。思惟义趣深入法味。无有疲倦未尝睡眠。四威仪中精勤修习。由法乐故不生劳苦。唯修正断无颠倒见。设有错误寻即改悔。故无苦受。又彼如来昔修行时。身语意业未尝错谬。凡有所作智为先导。说菩萨法化诸众生。彼闻法已随智慧行。所作义利非痴爱俱。故无不苦不乐受。彼国众生其心平等。于一切处如理安住。故无冤憎会苦。又彼众生无彼无此。于一切法心无所著。故无爱别离苦。又彼众生于诸善法。不生轻慢。亦不毁訾。故无求不得苦。彼国众生有为所迁唯有行苦。何以故。其佛常说第一义谛微妙法故

复次迦摄彼。帝幢如来出现于世。寿命长远无量无边恒河沙劫。其中众生各各具足广大辩才。善说法要。皆为过去诸佛世尊教化成熟。来生其中。迦摄。于汝意云何。如是广大严净佛土。颇有无信。无戒无定无慧寡闻懈怠如是有情得生彼不。迦摄白言。不也世尊。迦摄。于汝意云何。如是广大严净佛土。颇有微细善根少劣善根怯弱善根业集烦恼为苦所摄。如是众生不净回向得生彼不。迦摄白言。不也世尊。如是佛刹其中生者。具足善根纯净无杂。住正思惟解脱诸苦。多闻精进清净回向。皆蒙先佛久已化度。如是众生得生其中。佛言迦摄。善哉善哉。如汝所说其事如是。昔帝幢如来者。于汝等意云何。知是谁也。时诸比丘默尔无对。当于是时东方去此过殑伽沙世界。有国名月光庄严。是中有佛名光明聚。现在说法。彼佛会中有妙吉祥童子。遥闻此界所问因缘。知诸大众无能答者。时彼童子即白佛言。我今应往娑婆世界释迦牟尼佛所为彼时会答其所问。时光明聚如来。谓童子曰。随意当往。是时童子即从彼没。以神通力屈伸臂顷。至娑婆世界释迦牟尼佛所。头面礼足住立一面。时佛世尊。语童子言。以何因缘而来至此。时妙吉祥童子合掌白言。我为众会答前所问。自远而来。彼往昔帝幢如来。岂异人乎。即今释迦牟尼如来是也。所以者何。由佛世尊具足成就不可思议微妙功德。方便善巧怜愍有情。皆令安住菩提之道。时众闻已咸共赞言。善哉童子。善答斯问。决众疑网。汝今所说是为正说。是真实说是最上说。尔时童子为彼众会。而说偈言

  圣主释师子　　具勇猛精进
  怜愍于世间　　现不思议事
  彼牟尼世尊　　过去已曾作
  八十俱胝佛　　成熟诸有情
  常以大悲心　　严净佛国土
  浅识不能知　　种种善方便
  不舍初发心　　随机而应现
  亦于未来世　　复现无量身
  或现为释梵　　或示作魔王
  遍法界有情　　莫能知少分
  或现王宫生　　成道转法轮
  乃至入涅盘　　显现佛功德
  或随其种类　　现作女人相
  不染世间法　　如莲性本净
  或涕泪悲泣　　或歌舞嬉戏
  或乘空往来　　皆为作佛事
  怖者令安隐　　慢者令柔顺
  为利彼众生　　现种种调伏
  痴者令离痴　　愚者示明智
  为利彼众生　　作权巧方便
  狂者得正念　　跛者得安行
  为利彼众生　　现诸神变事
  是故我稽首　　不思议精进
  普化诸有情　　皆令入佛道

    父子合集经迦楼罗王授记品第六

尔时会中。复有六万八千迦楼罗王。见诸阿修罗王作供养已。复闻如来与彼授记。发随喜心广兴供养。以神通力即时化作六万八千殊妙楼阁。一一楼阁七宝所成。所谓金银琉璃砗磲码瑙珊瑚玻璃。皆有七重。第一层级黄金为柱。椽梠枅栱白银为之众宝装铰。第二层级白银为柱。椽梠枅栱黄金为之诸珍严饰。乃至第七珊瑚为柱。真珠等宝杂厕间饰。如是楼阁一一皆有宝网罗上。或黄金网白银为网。乃至真珠以为其网。复悬无数众妙宝铃。微风发声听者无厌。复现六万八千宝盖。诸珍间错光明显照。复现六万八千宝幢。众色相间珠珍严饰。复现六万八千缯幡。五色綷错甚可爱乐。复现六万八千宝幔。或黄金线而用合成。或以银线吠琉璃线真珠等线。巧妙严饰。时迦楼罗王。即以如上所现六万八千七宝楼阁众宝网幔宝幢幡盖。奉上如来。于虚空中次第行列。徐行旋转绕佛三匝。如三十三天爱啰嚩拏大龙象王绕天帝已。住立一面。尔时迦楼罗王。合掌向佛以偈赞曰

  稽首归依无上士　　一切世间无与等
  能超生老病死因　　解脱轮回诸苦厄
  愿我速成就佛身　　具足妙相三十二
  八十种好遍庄严　　如那罗延坚固力
  愿我如佛真金色　　圆光丈六常照明
  行住坐卧威仪中　　摄化有情令出离
  愿我坚持诸禁戒　　住胜最上三摩地
  以方便智利群生　　皆使得成菩提道
  愿我此身永除断　　为他乘驭嗔恚心
  如佛具足大慈悲　　获得十八不共法
  了知诸法从缘起　　如幼如梦如谷响
  悉同牟尼大导师　　于人天中广开示

尔时世尊。知诸迦楼罗王深心了达志固精进。现微笑相放五色光。时马胜比丘睹是事已。头面作礼。合掌恭敬以偈问曰

  归依无上天人师　　现此希有难思事
  放斯光明非无因　　怜愍我等为演说
  迦楼罗王兴供养　　宝幔弥覆于空中
  世间昔未曾见闻　　愿两足尊说斯义
  今此众会诸人天　　合掌欣悦怀希望
  愿闻为彼迦楼王　　演畅未来解脱果
  佛为最上天人尊　　能赴群生之所欲
  唯愿如来为宣说　　令彼大众除疑怖
  众会若得离疑怖　　则能发生欢喜心
  若闻如来授记言　　当具奉行诸佛教
  唯冀大慈垂护念　　除疑增长诸善根
  各各合掌愿欲闻　　迦楼罗王得佛道

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜善咨问　　放光现笑之所因
  吾今当说应谛听　　令汝除疑生喜悦
  迦楼罗众兴福行　　誓求无上大菩提
  当成无畏十力尊　　获斯胜报名为佛
  由彼净心供养故　　定招相好所庄严
  十八不共法难思　　脱那罗延所乘驭
  由是坚持于净戒　　安住清净三摩地
  修习胜慧六神通　　严净一切诸佛刹
  由彼净心供养我　　后身脱此傍生报
  毕竟不历恶趣生　　常受人天胜福乐
  过彼殑伽沙劫数　　供养承事诸如来
  善能调伏诸根门　　然后皆当得作佛
  同称弥卢幢如来　　十号具足刹严净
  其劫名为自然生　　其土无彼三恶趣
  其中所有诸众生　　容仪挺特无残缺
  彼佛寿命极长远　　八万四千俱胝岁
  如是次第得成佛　　国土寿量悉同等
  各各化度诸众生　　八十那庾俱胝数
  皆令舍除憍慢习　　尽袪缠盖获清凉
  安住无生解脱门　　远尘离垢心清净
  以彼本有身金色　　恃其大力生憍慢
  是故成佛为有情　　先令断除憍慢法
  彼等过去无数劫　　曾为苦行大仙人
  其数六万有八千　　常乐修习神通事
  彼诸仙人得通已　　谓已自在世希有
  虽持禁戒具威仪　　安住山林生我慢
  由是堕于金翅中　　缘昔神通有大力
  以持戒故见我身　　忘失菩提因我慢
  我今与授成佛记　　略说先因令觉了
  广为利乐诸众生　　闻者咸共生欢喜

父子合集经卷第四父子合集经卷第五

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    龙女授记品第七

尔时会中。复有九十六俱胝龙女。见彼阿修罗王迦楼罗王于世尊所作供养已。复闻如来各与授彼成佛之记。心大欢喜踊跃无量。发清净心广陈供养。此诸龙女以神通力化作九十六俱胝青色伞盖。一一伞盖吠琉璃宝而作千骨。巧妙安布黄金为柄真珠为网。垂诸花鬘诸珍严饰。复化九十六俱胝上妙良马。亦以众宝装铰严饰。吠琉璃宝而为辔勒。又复变现众宝网幔。其量周广六十踰缮那。遍覆一切诸来大众。宝幔之下现一殊妙摩尼宝珠。光明显照无不明了。复现九十六俱胝众宝花鬘。巧妙奇绝周遍垂下。又复悬缀无数宝铃。微风动摇其声和雅。犹如天乐闻者无厌。复以细末多摩罗跋旃檀香沉水香等散如来上。复散优钵罗花詹博迦花。及散无量上妙衣服。种种无量杂色璎珞。种种无量杂色花鬘。是诸龙女。各乘彼马张设伞盖。于虚空中绕佛三匝。复奏龙宫种种音乐。其声清婉众所乐闻。又于迦毗罗城。降诸涂香及众香水如雨而下。与其香花合和成泥。纵广六十踰缮那。以彼如来威德加持。令此乐声及香水泥普闻三千大千世界。其中众生闻此声香。皆于阿耨多罗三藐三菩提得不退转。是诸龙女作供养已。头面礼敬合掌向佛。以偈赞曰

  我等宿庆值于佛　　净心忻乐兴福业
  供养牟尼大导师　　冀脱此身龙女报
  化出九十六俱胝　　众宝庄严妙伞盖
  供养无上调御师　　以此善因求出离
  复化九十六俱胝　　调顺善御青色马
  上妙青宝以庄严　　皆为供养如来故
  复化九十六俱胝　　青色宝幢空中转
  一一皆以身语心　　头面作礼伸回向
  诸龙宫中妙乐音　　一时俱奏声清彻
  牟尼出现于世间　　堪受如斯大供养
  如是种种乐音声　　远彻三千大千界
  其中众生若得闻　　皆得菩提不退转
  复现广大一宝幔　　纵广六十踰缮那
  周匝普遍于空中　　广覆诸来大集会
  中现最上摩尼珠　　炽盛光明悉委照
  普于天人大会中　　净心忻喜为供养
  我等以此少善根　　志求寂静菩提果
  一如牟尼大导师　　成就甚深微妙慧
  教化饶益诸众生　　解脱尘劳诸结缚
  亦如十力无上尊　　演说无边清净法
  诸有为法如幻化　　亦如聚沫非坚牢
  如空注雨起浮泡　　自性虚假无主宰
  智者观诸世间法　　譬如镜中现影像
  众生体性亦同然　　唯佛现证如实说
  愚夫不了谓为实　　于虚妄境生执着
  毕竟诸法本来空　　此愚痴者自欺诳
  由彼迷妄无知故　　不达诸法真实性
  如来由是出世间　　显示无我不可得
  譬如秋空起浮云　　暂时显现须臾没
  当知我相本来无　　智者谛观何所有
  如是一切世间法　　皆无自性非真实
  但能诳惑诸根门　　愚夫由此增狂乱
  牟尼超越于三界　　了诸法性无分别
  若依如来教奉行　　一切世间皆解脱
  若人闻是深妙法　　心生忻乐正思惟
  则能越离生死泥　　此非愚者之境界
  是故我今头面礼　　无烦恼者天人师
  大悲能救苦众生　　为舟为舍为依怙
  我等供养于如来　　为求无上菩提故
  当宣法要警群迷　　普愿自他成佛道

尔时如来。知诸龙女心之所念希望授记。即现瑞相放大光明。时尊者马胜睹是相已。头面礼足合掌向佛。以偈问曰

  世出世间胜智者　　忽兴神变放光明
  时会睹此称吉祥　　非无因缘发斯瑞
  人中最上牟尼主　　愿说光相之端由
  诸天人民龙鬼神　　闻已咸生欢喜念
  如来威德圣中圣　　于世间法无不了
  怜愍摄受诸众生　　说此放光神变事
  如来慧力妙难思　　穷尽诸法实相义
  众会瞻仰愿欲闻　　各令知已心安隐
  牟尼久已成正觉　　能与群生作义利
  何因放此大光明　　愿说咸得除疑惑
  今此大众心寂然　　堪能领解深法义
  一心瞻仰于如来　　闻已各发菩提意
  若人于事未决了　　其心掉动则生恼
  由此皆堕疑网中　　唯冀洪慈速开示
  谁于今日发大心　　何佛他方说大法
  谁得菩提破魔军　　放此光明甚希有
  何人广兴净福业　　佛怜愍故放净光
  圣主师子十力尊　　于大众中无畏说
  我等若蒙佛显示　　离诸疑怖心泰然
  咸生清净随喜心　　各各奉行于佛教

尔时世尊。为尊者马胜。说伽陀曰

  善哉马胜大比丘　　汝能咨问放光事
  吾今于此众会中　　为说龙女未来果
  汝等一心当谛听　　离诸散乱染因缘
  闻我说此放光因　　增长人天诸善利
  此诸龙女心开解　　能以智慧观实相
  了知诸法本性空　　不着世间业果报
  无人无我无众生　　亦无作者及受者
  补特伽罗自相空　　犹如阳焰镜中像
  诸龙女等植德本　　共兴广大净福业
  善能安住佛法中　　了世间法皆如幻
  如是作诸供养已　　誓求佛果大菩提
  后当舍此龙女身　　得生三十三天上
  得为帝释天宫主　　受用妙乐无毁訾
  具天寿量大名闻　　复往焰摩天中住
  得生焰摩天宫已　　具足受彼殊妙乐
  佛子安住此天中　　自在得终天寿量
  后复生于兜率天　　得彼天众常爱敬
  虽受快乐心不着　　犹若莲花性本净
  由彼宿习出世智　　常观诸法皆空寂
  譬如刻石画长存　　安住正念无移动
  后生乐变化天中　　天子天女常围绕
  不为他毁有名称　　满彼寿量无中夭
  受彼最上五欲乐　　而与正念常相应
  善修三种解脱门　　毕竟入解真空法
  复生他化自在天　　得彼天众常恭敬
  清净意乐住其中　　任持正法心无动
  所欲受用皆他变　　不起染着痴爱心
  佛子安住彼天宫　　得尽彼天寿边际
  由于欲乐生厌患　　忻求定地伏诸惑
  获得诸禅解脱门　　由此得生梵天上
  由彼定生诸善根　　受用喜乐一中劫
  定中适悦胜难思　　渐能进趣菩提道
  住彼梵宫经一劫　　专修正行净无杂
  善巧方便利有情　　无冤亲想心平等
  于喜妙乐悉通达　　亦不味着诸禅定
  善能觉悟寂诸根　　是为最上牟尼子
  彼梵天说自然法　　不与业果理相应
  唯此真实解脱门　　毕竟超越于三界
  若人于此生信解　　善能引导诸众生
  速成无上妙菩提　　是则名为世间眼
  彼龙女等生梵世　　饶益利乐诸天人
  教化令发清净心　　皆能进趣菩提道
  往诣无边佛刹土　　供养承事诸如来
  过彼未来星宿劫　　同成佛号寂诸根
  彼等闻佛授记已　　心净踊跃志坚固
  时会咸生欢喜心　　各各头面礼佛足

    父子合集经龙王授记品第八

尔时难陀乌波难陀龙王。与其眷属九十俱胝龙众。见诸龙女供养如来得授记已。身意泰然得未曾有。称赞如来究竟满足广大威德神通无碍。能知众生心之所念。所作事业皆悉闻知。各各现证无不了达。然彼如来大悲增上。或不待请即为说法或非时说。皆为教化成熟有情除烦恼热得涅盘乐。随机授法必令得果。乃至女人志意动乱。于淫怒痴自性增上。设闻法要不能领解。亦得如来之所化度。如彼六十俱胝龙女犹获授记。何况我等岂不蒙益。时彼龙王作是说已。于世尊所生难遭想。以神通力兴大香云满阎浮提。遍覆一切诸山大海。雨众香水旃檀末香。其香远闻普佛世界。又复于彼迦毗罗城。雨赤真珠积至于膝。纵广量等六十踰缮那。复于尼拘律陀林中。普散无量龙自在花。散已复散。变成花殿。其量亦广六十踰缮那。七宝相间而为其柱。复以半拏绀末罗石以甃其地。其石柔软触之清凉。众所乐观非世所有。复现九十俱胝众宝花鬘周匝垂下。又复悬挂众色名衣。复现种种巧妙缯幡香鬘宝鬘真珠鬘等。周遍庄严殊妙清净。又复涌出无数宝藏。行列殿中而为供养。又复出现最上无价摩尼宝珠以成其镜。表里莹彻无不交照。乃至迦毗罗城时会大众。种种供养殊胜庄严。于其镜中皆悉显现。复有九十俱胝龙马。诸妙珍宝以为辔勒。无数宝铃进步鸣响。是诸龙王各乘马已。于虚空中绕佛三匝。复奏龙宫无量音乐。及雨种种殊妙珍宝。散于如来及声闻众。作供养已头面礼足。瞻仰世尊目不暂舍。以我所集功德善根。愿与众生同得佛道。合掌向佛以偈颂曰

  久修慈忍大悲行　　成就百福相庄严
  舍家逾彼迦毗城　　志固为求无上道
  六年示修于苦行　　伏诸外道不疲劳
  直诣金刚座道场　　普施群生甘露法
  昔日如来调御师　　弃舍王宫妙欲乐
  断除顶发住山林　　于世浮荣心不顾
  牟尼昔舍于头目　　积功成满菩提因
  凡夫闻见尚无因　　况复效修其苦行
  如佛昔作忍辱仙　　为歌利王无辜害
  割截耳鼻及身肢　　不生恚恼心怡悦
  时有愚痴婆罗门　　来秤身肉而蹶倒
  说此难行苦行时　　我等闻已生悲恼
  何因如来不起嗔　　爱念众生如己子
  由兴害意堕泥犁　　慈尊于彼能垂救
  如来具足无上慧　　于己害者不加报
  昔修广大安乐因　　故得身肢复如故
  我等咸生净信心　　称赞如来真实行
  如彼牟尼利有情　　咸愿速登无上觉

尔时世尊。知诸龙王信解坚固发大誓愿。即于面门放种种光。其光普照上至梵天。复从如来顶门而入。时尊者马胜。合掌长跪即白佛言。法尔诸佛若放光明必有所谓。唯愿如来方便演说。时彼尊者说伽陀曰

  大哉无畏释师子　　何因缘故放此光
  慈门广利诸天人　　唯愿如来为我说
  此诸龙王并眷属　　及彼时会皆肃然
  唯冀牟尼震梵音　　说此放光希有事
  谁于释迦佛法中　　初发大心感斯瑞
  谁能摧破诸魔军　　令彼惶怖皆退没
  将非龙众久修行　　获得无尽诸功德
  愿闻现瑞之端由　　断除疑惑心清净

尔时世尊以偈答曰

  我以最上胜功德　　八种深远梵音声
  所说真实利众生　　汝当谛听放光事
  此诸龙王深净信　　设大供养世希有
  志心愿证佛菩提　　为度一切群生故
  常以悲心观世间　　普使众生脱苦厄
  未尝一心生疲劳　　坚固精进无退转
  修习清净奢摩他　　具足智力无能屈
  安住三种解脱门　　谓空无相及无愿
  得佛无上甚深慧　　了一切法皆虚假
  大悲愍念诸有情　　离冤亲想悉平等
  过彼殑伽沙劫数　　次第成佛出世间
  同名寂静慧如来　　十号具足土严净
  常说无我甘露法　　无诸外道及魔冤
  善巧方便应群机　　不违世俗谈真谛
  是诸众生闻法已　　了法自性悉皆空
  大悲方便演三乘　　胜义法中无所说
  此法非出于自然　　求之少分不可得
  乃至无有一众生　　闻佛言教而不解
  由饮解脱甘露味　　则能出离生老死
  及彼忧悲我慢幢　　皆因闻佛梵声故
  释尊无畏圣师子　　说诸龙意答所问
  佛子常随智慧行　　速得菩提无上果
  如来授彼诸龙记　　时众闻已生忻庆
  咸各归命牟尼尊　　于佛法中心寂静

父子合集经卷第五父子合集经卷第六

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    鸠盘茶王授记品第九

尔时会中有十八俱胝鸠盘茶王。见诸阿修罗及迦楼罗诸龙王等作供养已心生爱乐。复闻如来与彼授记。欢喜踊跃得未曾有。咸共赞言。如来成就最上智慧。于一切法无有疑惑。无喜无恚不生分别。堪受人天广大供养。譬如大海深广弥满不动不涌湛然安静。如来功德亦复如是。时彼鸠盘茶王并诸眷属。各发净心而兴供养。以神通力化作十八俱胝宝幔。是诸宝幔巧妙殊绝。皆以宝线次第严饰。所谓黄金线幔。白银线幔。吠琉璃幔。玻胝迦幔。赤真珠幔。杵藏珠幔。马藏珠幔等。若金线幔垂银花鬘若银线幔垂金花鬘吠琉璃幔玻胝迦鬘。玻胝迦幔吠琉璃鬘。赤真珠幔杵藏珠鬘。杵藏珠幔赤真珠鬘。马藏珠幔众宝为鬘。互相间列甚可爱乐。又复化出十八俱胝众宝妙车。所谓金车乃至马藏珠宝所成之车。于彼车上复现十八俱胝上妙伞盖。一一伞盖奇异巧妙。有骨百茎众宝装铰。或以纯金而为其柄。次第乃至吠琉璃柄。伞盖之下垂诸花鬘黄金花鬘。乃至摩尼珠宝所成花鬘。是诸伞盖以赤真珠巧妙交络以为其网。时鸠盘茶王各各乘彼众宝妙车。执持伞盖作诸伎乐。于虚空中绕佛三匝。以七宝花散如来上。散已复散。从车而下。礼世尊足在一面住。合掌向佛以偈赞曰

  牟尼圣主出世间　　如弥卢山显大海
  离诸忧畏不动涌　　堪受如斯妙供养
  常住寂静三摩地　　演说诸法无所著
  舍除憍慢诸垢染　　观察世间唯名想
  了知诸法如幻化　　犹如梦中受欲乐
  亦如水月体非真　　智者当作是观察
  乾闼婆城本无有　　于方处求不可得
  应知但以假名说　　诸世间法皆如是
  我等所作诸供养　　宝车宝盖宝幔等
  及以种种歌乐音　　如来观之如谷响
  愿我成佛如世尊　　为众生说如幻法
  皆令远离惑业因　　悉证菩提寂静道

尔时世尊。知诸鸠盘茶等心之所念。即于口中放大光明。时马胜比丘睹是光已。合掌向佛以偈问曰

  调御施化非无因　　瞩斯净光难思议
  时众欲知其所由　　别冀如来速演说
  睹佛面门现斯瑞　　诸天人民咸有疑
  愿佛怜愍诸群萌　　说此放光希有事
  谁于今日发大心　　乐于佛所闻正法
  何人于佛兴供养　　为说所获诸功德
  何人达彼有为行　　刹那能离诸过患
  何人证于实相门　　寂静意乐而不动
  何人得道降诸魔　　何人称赞佛功德
  何人断惑超三有　　息诸缠盖心泰然
  大众咸生恭敬意　　伫闻如来微妙音
  何因放此净光明　　愿决众疑分别说

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜问斯义　　为作世间饶益者
  我今说此光所从　　汝等一心当谛听
  今此鸠盘茶众等　　广兴供养净福业
  合掌住立于我前　　安住实际心不动
  以智慧力善修习　　起大悲心利群有
  后当脱此鬼趣身　　决定往生于胜处
  得为忉利天宫主　　亲近承事诸如来
  了达诸法无有疑　　如黑暗中然大炬
  未来复过俱胝劫　　严净无边佛刹土
  供养河沙佛世尊　　被精进铠修诸行
  饶益摄取诸有情　　决定自知当作佛
  及于方域而降生　　由是号曰除疑佛
  常说最上寂静法　　闻者心净离诸疑
  咸愿求趣大菩提　　救拔群生超彼岸
  我今已答汝所问　　普令时会心安隐
  故此授决鸠盘茶　　于未来世得作佛

    父子合集经乾闼婆王授记品第十

尔时会中。复有三十六俱胝乾闼婆王。见诸阿修罗迦楼罗诸龙眷属鸠盘茶等于如来所作供养已。复闻与授成佛之记。欢喜踊跃得未曾有。及闻称赞如来法性本来寂静清净无垢。无有少法之所显示。皆为增长众生善根。深生信解舍诸悭吝。即发无上菩提道心。时诸乾闼婆王为供佛故。以神通力化作三十六俱胝爱啰嚩拏大龙象王。一一象王各有六牙。一一牙上而有七池。一一池中有七莲华。一一莲华而有千叶。一一叶间有七天女。一一天女复以七女而为侍卫。复于一一龙象顶上。化出三十六俱胝上妙伞盖。七宝为网宝鬘交映。又复各现宝幔弥覆。悬诸花鬘处处周遍。彼莲华中所有天女。或作歌舞或奏音乐。或说伽陀赞佛功德。或散旃檀沉水末香。或散种种天诸妙花。或散种种上妙衣服。或散众宝严身之具。耳珰臂钏宝鬘金带。或有执持种种宝幢杂色幡盖。或散种种清净香水。于虚空中如雨而下。与诸香花合和成泥。遍迦毗罗城广六十由旬。随风所飘其香普至。是时彼诸乾闼婆王各各乘一大龙象王。竞奏百千诸妙音乐。徐行空中右绕三匝。以神力故令乐音声并前香风遍于三千大千世界。其中众生得闻乐声及彼香者。皆于阿耨多罗三藐三菩提得不退转。彼乾闼婆王于虚空中绕佛毕已。从象而下至于佛所复绕三匝。头面礼足住立一面。合掌向佛以偈赞曰

  如来具足诸妙相　　于三界中无与等
  解脱烦恼生死因　　已尽轮回苦边际
  显现无边大威神　　天上人中极希有
  成就寂静解脱门　　无有非人能动乱
  如来具足清净道　　本无所证无可说
  佛性真常本湛然　　依世俗谛强分别
  未来诸佛出世间　　亦能安住如是法
  法无自性本性空　　无有作者及主宰
  了知自他无所作　　是为世间具智者
  诸法各各不相知　　佛于无作示有作
  譬如多种集成车　　彼各不知自业用
  但由运载得车名　　佛说我相亦如是
  彼法无法可教招　　彼法无法可思念
  彼法无法令解脱　　彼法无法令变异
  如来如是了知已　　为众生依世俗说
  显示诸行有为门　　彼世俗相亦无得
  展转分别诸法性　　令浅智者得除疑
  诸法无相亦无名　　毕竟无住亦无作
  愿我等于未来世　　成佛如彼牟尼尊
  无边功德庄严身　　常说如是胜义法
  利乐世间具智者　　及彼邪见诸众生
  常起如是大悲心　　令出轮回生死海
  世间苦恼诸有情　　皆由邪慧心谄曲
  如猴轻躁无暂安　　唯佛大慈能救度
  恃彼贪恚痴我慢　　随其识浪常漂流
  展转沉沦苦海中　　唯佛大慈能救度
  众生愚痴无慧眼　　不知自业堕恶趣
  永失人天出要门　　唯佛大慈能救度

尔时世尊。知诸乾闼婆王心之所念。即于口中放大光明普照时会。于是尊者马胜比丘睹斯光已。合掌向佛以偈问曰

  如来今者现斯瑞　　寂然普放大光明
  时众相视咸惊疑　　未曾见是希有事
  何人蒙佛摄受故　　生大欢喜离诸障
  今佛放此净光明　　令彼信解力坚固
  何人奉行于大法　　如佛所说等无异
  今佛放此净光明　　于彼加持垂护念
  是诸大众生渴仰　　愿闻佛说光因缘
  合十指爪住佛前　　瞻仰尊颜无暂舍
  如来为世间作眼　　离诸垢染及忧怖
  大悲怜愍诸群生　　使除疑网心清净

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜问斯事　　我为饶益于世间
  咸令增长诸善根　　今放光明与授记
  尊者马胜大比丘　　闻佛许说光所以
  欢喜合掌无异缘　　冀梵音声次第说
  乾闼婆王兴供养　　为闻真净大法故
  此法唯依实际中　　本来自性无增减
  若人取相而分别　　彼则如幻不可得
  此法无实亦非虚　　由法性空佛无说
  彼作如是供养已　　后身当作烁迦罗
  是为生死最后身　　增进净行心无懈
  从一佛刹至佛刹　　承事河沙诸如来
  化度那由他有情　　果满得成离尘佛
  彼离尘佛出于世　　住寿那由他劫数
  常说诸法自性空　　复能显示一切智
  如是彼彼佛名号　　住世正法及像法
  说法化利诸众生　　悉同前佛等无异
  马胜汝问光因缘　　故我略说彼功德
  如是展转成佛时　　降伏天魔无亿数
  乾闼婆王授记已　　时众除疑心悦豫
  咸各归依牟尼尊　　合掌住立于一面

    父子合集经药叉王授记品第十一

尔时会中。有八十俱胝大药叉王。见彼阿修罗王乃至乾闼婆王等于如来所广作供养。复闻世尊与彼授记。欢喜踊跃得未曾有。恭敬尊重生难遭想。称赞如来智慧深远。于所说法心得入解。深生爱乐发清净信。以神通力化作广大殊妙供养。与前阿修罗王所作供养等无有异。时药叉王作供养已。绕佛三匝住立一面。合掌向佛以偈赞曰

  人中无比释师子　　具大神通及智慧
  如海深广不可涯　　是故我今头面礼
  苏弥卢山可称量　　劫烧洞然可知际
  唯佛智力妙难思　　一切无能穷极者
  过现未来诸世间　　所有诸趣有情类
  彼等造作善恶业　　佛能遍知无与等
  或有乐住阿兰若　　修寂静行除愦闹
  随其修习性不同　　佛能遍知无与等
  或具贪恚痴过患　　憍慢嫉妒诸恶行
  或有等分或随增　　佛能遍知无与等
  或有迷失于正道　　沉沦苦报无罢期
  或具信解随法行　　佛能遍知无与等
  有情乐作诸恶行　　彼业随逐不舍离
  以至惶怖命终时　　唯有如来能救度
  或持净戒往天宫　　或造黑业受众苦
  受报好丑理无差　　唯有如来悉知见
  或有智慧求解脱　　于佛法中而出家
  乐修圣道利有情　　得证无为寂灭乐
  复有愚夫虽出家　　依止如来法中住
  于甚深法不能解　　由无智故返生谤
  彼于佛教生毁訾　　造作无量苦因缘
  命终堕大地狱中　　劫尽更生余苦趣
  若人谛信增上心　　乐闻正法能守护
  善达诸法本性空　　离一切相无所著
  了知世间非坚固　　是身如幻如谷响
  常以悲愿利群生　　于佛菩提无退转
  我今称赞佛功德　　一切世间无过上
  回此少善及有情　　未来同得成佛道

尔时世尊。知诸药叉王等心之所念即于口中放大光明普照佛土。时马胜比丘见斯光已。合掌向佛以偈问曰

  大哉最胜两足尊　　忽放净光难思议
  此光希有非无因　　照耀世间逾满月
  今此众会皆合掌　　同声称扬佛功德
  唯愿如来震梵音　　为说此光之所以
  何人于佛生净信　　何人悟入真净法
  何人坚固菩提心　　唯冀如来分别说
  大慈悲主出于世　　能决群生众疑网
  诸天龙及人非人　　闻已心生大忻庆

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜大比丘　　汝能咨问如是义
  因光启请利天人　　皆令安住真实见
  彼药叉王陈供养　　增长见闻胜善根
  故我放此净光明　　今当与授成佛记
  如是彼诸药叉众　　悉了诸法从缘生
  由愿力故受此身　　心常安住菩提道
  能以智慧善观察　　知蕴处界皆虚假
  超出轮回苦恼因　　犹若莲华不着水
  自他和合染因缘　　一切觉了皆如幻
  观色自性空亦然　　得证寂灭无为理
  若能觉了诸法空　　亦达无相及无愿
  于此三种解脱门　　平等遍观无障碍
  能观智慧性本空　　所观境界何所有
  了知心境二都无　　是为具足菩提行
  诸天及人闻是法　　心生欢喜未曾有
  各各信解随法行　　渐能修习一切智
  如是密迹药叉众　　能以净心兴供养
  后当转此恶趣身　　往生诸天受妙乐
  彼等当于未来世　　奉觐无量俱胝佛
  号曰寂静慧如来　　住世寿命极长久
  教化无数声闻众　　犹如星宿现虚空
  具诸智者生其中　　国土严净无有苦
  一切世间人非人　　听佛所说无疲厌
  皆发勇猛清净心　　解脱烦恼诸结缚

父子合集经卷第六父子合集经卷第七

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    紧那罗王授记品第十二

尔时会中。有八俱胝紧那罗王。其上首者名曰大树。见诸阿修罗王乃至诸药叉众。咸于佛所广作供养。复闻如来与授记别。心生惊疑叹未曾有。谓若佛说一切世间诸蕴界处。但有假名无有少分令众生见。若佛菩萨亦不可见。云何世尊于大众中。与诸天龙次第授记。复令化度无量有情。从一佛刹至一佛刹。奉觐如来经河沙劫。广修诸行得成佛道。具诸相好国土庄严。寿命劫数正像法等。乃至缘毕入般涅盘。既言诸法皆悉空寂。何能建立授记之事。时大树紧那罗王。生此疑心未能决了。合掌向佛以偈问曰

  我闻如来作是说　　于佛妙慧心有疑
  既言空已复授记　　此义甚深不能了
  又云法界本空寂　　而说如月现于水
  既言空寂复现形　　此义甚深不能了
  云何诸法本无生　　复说乐求菩提者
  既言无生何有求　　此义甚深不能了
  云何诸法本无尽　　复说如来有灭度
  我今请问牟尼尊　　此义甚深不能了
  云何诸法皆如幻　　复说此殁得生天
  既言如幻何有生　　此义甚深不能了
  云何诸法无所依　　复说依止善知识
  既言无依何假人　　此义甚深不能了
  云何世间无作者　　复说有能断诸惑
  既言无作断无由　　此义甚深不能了
  云何诸法自性空　　复说观空得解脱
  既言空已复何观　　此义甚深不能了
  云何诸法刹那灭　　复说诸法常不灭
  既言迁变或凝常　　此义甚深不能了
  云何福业非积聚　　而说修习成菩提
  既言无集岂能成　　此义甚深不能了
  云何诸法无所说　　复说毁谤堕恶道
  既言无说谤何生　　此义甚深不能了
  无能胜者所宣说　　种种差别难晓了
  佛眼清净照世间　　普施群生甘露味
  余无有能为我等　　决择如上所疑事
  唯有如来能断除　　故我顶礼一切智

尔时世尊。为彼大树紧那罗王释诸疑故。以偈答曰

  紧那罗王汝所问　　既空依何而授记
  由彼达法性本空　　故得如来与授记
  以何因缘作是说　　诸法若有实性者
  则应不减亦不增　　于一切时无改转
  譬如圆鉴挂空中　　假明缘故现色像
  紧那罗王汝当知　　自性清净本如是
  法性无垢常湛然　　亦无动乱及变异
  汝观供养福业因　　于何法中有其相
  应知法界本寂静　　智者观法不可得
  诸有取相凡夫人　　于此疑惑不能了
  汝问诸法本无生　　复说发心求佛道
  紧那罗王汝当知　　十力妙智难思议
  凡愚没溺三界中　　于诸欲境生耽着
  由是常生颠倒心　　故受生死诸苦恼
  从昔未闻于正法　　设得闻已而不解
  使令安住实智中　　渐能求趣菩提果
  汝问诸法本无灭　　何故如来有灭度
  为破常见诸众生　　无有少法为常者
  汝问诸法犹如幻　　见生天者故怀疑
  为化凡愚诸众生　　恃己所有生憍慢
  汝问诸法无所依　　而见依止善知识
  若非依止说法师　　毕竟世间无出离
  汝问诸法无主宰　　而见世间有作者
  当观车由众分成　　有于运载作用事
  为化着我诸众生　　及彼执着我所者
  我为彼说无堪任　　是故但唯假名想
  汝问诸法自性空　　复说观空得解脱
  由彼分别执着心　　故于空义不能了
  汝问诸行刹那灭　　复云诸法性不灭
  为破着欲诸众生　　于非净处生净想
  譬如远瞩于阳焰　　渴者趣之而求水
  皆从妄想分别生　　当知水体不可得
  阳焰之处本无水　　自性净中本无染
  由彼愚夫颠倒心　　则为彼爱所缠缚
  汝问诸法无所说　　亦云谤者堕恶道
  愚夫闻已怀惊疑　　智者闻之除障碍
  世间诸法本空寂　　无智妄计执为我
  彼等若闻诸法空　　则生断灭怖畏想
  若人毁谤于空法　　皆由执着我人相
  犹如系缚于虚空　　增长愚痴堕恶趣
  或说善业往天中　　或生人间受快乐
  作者非实业不亡　　如梦中境唯心造
  当知诸趣皆如梦　　由迷真故不觉知
  梦中何有于去来　　愚夫妄谓真实境
  我虽说有所作业　　十方推求无作者
  譬如狂风吹树枝　　由相触故生其火
  彼风及木无思念　　谓言我能出于火
  两相因故火发生　　本无作者亦如此
  汝问福业无积聚　　云何能得菩提果
  如世间有百岁人　　虽经时分年无聚
  汝问诸法不可尽　　云何复说业可尽
  观空理者说无穷　　随世俗中则有尽
  我虽演说真实际　　由颠倒故于外求
  众生业惑障缘深　　不能了此胜义法
  紧那罗王汝当知　　于此胜义善安住
  一切诸相皆一相　　善通达者谓无相
  一切菩萨之所行　　一切诸法皆无作
  所谓阿字总持门　　由此入解一切法
  紧那罗王汝当知　　一切诸法本寂静
  此说无相总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法无分别
  此说平等总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法无自性
  此说清净总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法无有尽
  此说离障总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法非思议
  此说实相总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法无所趣
  此说解脱总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法本无动
  此说证净总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法假名说
  此说真实总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法不可得
  此说离相总持门　　由阿字门而入解
  紧那罗王汝当知　　一切诸法离思念
  此说静虑总持门　　由阿字门而入解
  此法非见非对治　　求彼二相无所有
  了知无相亦无名　　则能具足菩提道
  若法可见可对治　　是法非实非平等
  彼法自性离言诠　　譬如虚空无相似
  法性无有种种相　　亦非一相及异相
  非有冷相及热相　　如镜中像不可得
  非有曲相及直相　　亦复无有明暗相
  远离男相及女相　　此名入解真实相
  非谄非诳非动乱　　无有舒卷微细相
  亦无忿怒忻喜相　　非怯弱相起尽相
  非有入相及出相　　亦无进相及退相
  非其寤相及寐相　　复无去来现在相
  非是眼相及瞻视　　亦非盲瞽与瘴翳
  非其调顺非刚强　　非有覆藏及显露
  非是动转及止息　　离诸戏论常湛然
  智者当作如是观　　此名了知佛境界
  为欲调伏世间故　　于离言法强分别
  于此胜义善知了　　则能通达一切法

尔时大树紧那罗王。闻佛世尊释诸疑已。及闻演说总持字门深生入解。心大欢喜得未曾有。以神通力化八俱胝殊胜楼阁。巧妙奇绝。或住山峰或依林木。或化现于莲华之上。是诸重阁皆以七宝。合成花盖而悬其上。一一皆有众宝幢幡宝幔花鬘次第严饰。是八俱胝紧那罗王。各各升彼楼阁之上。于虚空中右绕三匝。复以上妙水陆之花而散佛上。散已即从重阁而下。至于佛所复绕三匝。瞻仰尊颜目不暂舍。一心合掌住立一面。思念如来过去现在积集无量最胜功德。佛知是已口放净光时尊者马胜比丘睹是相已头面礼佛。以偈问曰

  如来今者放光明　　净妙难思甚希有
  时众谛视于慈容　　犹若披云瞻满月
  何人今于世尊所　　乐闻最上微妙法
  以真实智善了知　　放此光明垂印可
  谁人初发菩提心　　感佛加持现斯瑞
  唯愿说此光因缘　　制诸外道令生信
  是时诸来大集会　　咸各欢喜发净心
  冀闻清净甘露音　　闻已奉行于佛教

尔时世尊。为尊者马胜比丘说伽陀曰

  具寿马胜问斯义　　当一心听无异缘
  我今为彼紧那罗　　授记未来成佛事
  彼所请问极难解　　皆为利乐诸世间
  我今为断彼疑心　　令于佛法善安住
  此大树紧那罗王　　与八俱胝徒属众
  由兴供养净福因　　命终当得生天上
  展转天中受妙乐　　满足九十俱胝岁
  获得如意五神通　　亲近承事河沙佛
  经历那由他刹土　　常说胜义第一法
  化度那由他有情　　得成无上菩提道
  号曰无量光如来　　劫名国土皆无异
  人中师子十力尊　　具足无边大智慧
  彼国所有诸菩萨　　修习善根悉圆满
  亦无求趣二乘人　　皆是一生居补处
  如是彼诸菩萨众　　各怀悲愿利群生
  能与世间作照明　　后当次第得作佛
  彼诸国土胜庄严　　离诸秽恶无烦恼
  犹如睹史多天宫　　受用清净知止足
  一切过患八无暇　　乃至名字未尝闻
  有情安隐住其中　　常餐法味禅悦乐
  大哉善逝天中天　　与授紧那罗佛记
  时众闻已心泰然　　稽首致礼无上士

    父子合集经宝璎珞天授记品第十三

尔时会中。有八俱胝宝璎珞天子。见诸阿修罗乃至紧那罗等于佛会所作大供养。及闻如来与彼授记。心甚欢喜得未曾有。时诸天子为供佛故。发勇猛心。绕迦毗罗城周匝六十踰缮那量。于虚空中雨曼陀罗花。缤纷而下积至于膝。作供养已绕佛三匝。住在一面合掌向佛。以偈赞曰

  具足大悲十力尊　　能救一切众生者
  诸根寂静放光明　　故我敬礼圣中圣
  诸天及龙人非人　　于佛法中生爱乐
  最上牟尼大导师　　是故我今归命礼
  如来出现于世间　　譬若众星中满月
  无边福智庄严身　　众生观者心无厌
  具足种种清净法　　六通三明四无畏
  十八不共法难量　　是故我今归命礼
  三十二相皆圆满　　八十随好妙严身
  巍巍犹若天帝幢　　是故我今归命礼
  成就最胜三摩地　　能断轮回诸结缚
  降伏无数亿魔军　　湛然安住心无动
  如来智慧力坚固　　常说四谛真实法
  广能化利诸人天　　咸令超越于彼岸
  人中最胜释师子　　破诸邪见及异论
  愿我当得如世尊　　说法使离诸痴暗
  超出世间成正觉　　常兴四种无量心
  怜愍摄受诸众生　　同证菩提无上道

尔时世尊。知诸天子深心所念。即于口中放大光明。时尊者马胜比丘睹是相已。合掌向佛以偈问曰

  牟尼现是希有相　　时众瞩已心忻悦
  各各谛奉大慈颜　　愿说放光之所以
  如来今放此净光　　必兴广大利益事
  我等顶礼无上尊　　唯冀洪音为开示

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜问斯义　　今当为汝分别说
  我为利乐诸人天　　与璎珞天授佛记
  如来若不因请说　　无由记别弟子事
  答汝问故息群疑　　彼离疑则心安住
  宝璎珞天于我所　　以净意乐伸供养
  从此展转生诸天　　百千天子常围绕
  复持天上妙香花　　供养无量俱胝佛
  于彼佛所发净心　　爱乐修行菩萨道
  如是精进供养已　　复于未来作佛事
  奉觐那由他世尊　　常说伽陀赞佛德
  如理广修清净行　　得那罗延坚固身
  于其欢喜劫中生　　具足圆成一切智
  号曰华幢胜如来　　有大名称无与等
  并余天子八俱胝　　同一劫中皆作佛
  彼佛土中无地狱　　亦无鬼趣与傍生
  及阿修罗憍慢心　　离于八难诸危苦
  彼诸天子成佛刹　　悉如三十三天中
  国土富乐遍庄严　　寿量长远皆相似
  彼土既无恶趣名　　泥复有作恶业者
  众生各各随法行　　皆住无诤清净行
  所化众生无有边　　过彼恒河沙数量
  彼佛出现世间时　　常说胜义第一法
  如是化缘归寂已　　广布舍利起塔庙
  一一舍利胜难思　　其中皆有佛身相
  咸各称赞佛功德　　住虚空中现神变
  教化无量诸众生　　皆发无上菩提意
  十力牟尼方便力　　为彼天子授道记
  时诸大众闻佛言　　住正思惟心寂静

父子合集经卷第七父子合集经卷第八

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    四大天王授记品第十四

尔时四大天王。并诸眷属九万天子。俱见诸阿修罗王乃至宝璎珞天等。于世尊所各作供养。复闻与授成佛之记。心大欢喜得未曾有。睹佛威神深生尊重。于佛法中欲求出离。发勇猛心精勤修习。譬如有人乘于坏船入驶流中欲达前岸。是人即时作此思念。如是坏器本非坚牢。不久沮坏要当速渡。用力求济可免斯难。彼四天王及诸天子。厌怖生死速求出离。勇猛之心亦复如是。时四大天王并诸天子。为供佛故以神通力。即时化作九万宝帐。众色间错众宝装铰。广大严饰世所希有。所谓赤真珠帐摩尼珠帐吠琉璃帐金刚宝帐黄金帐等。化作如是众宝帐已。于虚空中绕佛三匝。复化九万天诸伎乐。于虚空中复绕三匝。出妙乐声而为供养。又复降雨曼陀罗华摩诃曼陀罗华曼殊沙华摩诃曼殊沙华。而散佛上散已复散。绕佛三匝住立一面。合掌向佛以偈赞曰

  敬礼二足尊　　能救世间者
  离掉举昏沉　　及贪欲谄诳
  能断诸有结　　拔诸根毒刺
  摧伏我慢幢　　破无明黑暗
  四大善调和　　无便利垢秽
  不为毒所中　　九窍常清净
  解脱烦恼缚　　永尽诸苦际
  刚强难化者　　牟尼前摄受
  我等诸天人　　皆来至佛所
  瞻仰佛功德　　称赞所不及
  于三解脱门　　空无相无愿
  唯佛能证知　　通达无障碍
  彼真如实际　　为诸法所依
  愚夫设得闻　　如鹿怖猎师
  众生取诸相　　不能达法性
  起四种颠倒　　此为轮回行
  佛了知法性　　观世如虚拳
  诸蕴本来空　　处界亦如此
  若法与非法　　以名字而说
  如是一切法　　佛本无言说
  譬如大幻师　　化种种形像
  此实无主宰　　唯假名施设
  如是蕴与处　　及十八界等
  皆从幻妄生　　体性非坚固
  犹如工画师　　画作女人像
  身肢悉圆满　　相貌皆端正
  此相非实有　　但诳愚夫眼
  智者善了知　　法界本平等
  善入佛法者　　于此无疑惑
  譬如己掌中　　置之庵罗果
  如来智光明　　照彼群生类
  转最上法轮　　使之令开解
  愿我得佛时　　亦说如是法
  化一切众生　　同成无上觉

尔时世尊。知诸天子心之所念。即于面门放大光明普照时会。尊者马胜比丘睹是相已。合掌向佛以偈问曰

  大圣无上尊　　何故现斯瑞
  此必有因缘　　愿为我等说
  今此诸天王　　及天子眷属
  睹佛放净光　　咸生于疑惑
  何人发大心　　为当与授记
  谁今降诸魔　　愿为我等说
  何人于佛所　　作广大供养
  诸根善调伏　　蒙佛现斯瑞
  将非佛世尊　　与诸天授记
  愿两足尊说　　闻已咸欢喜
  令一切众生　　成熟诸义利
  求证大菩提　　如佛等无异

尔时世尊。为马胜比丘说伽陀曰

  马胜大比丘　　善问如是事
  我今放光明　　当为汝显示
  彼九亿天子　　皆来至我所
  说此光因缘　　与授成佛记
  是诸天子等　　久值遇诸佛
  善达诸法空　　说偈而赞叹
  安住佛法中　　信解心决定
  为求大菩提　　发勇猛精进
  复于未来世　　奉觐河沙佛
  若不供养者　　誓不成正觉
  作是供养已　　当得成佛道
  号曰持光明　　于世间最胜
  彼佛出于世　　如灯常照耀
  度脱声闻众　　数满八十会
  此诸比丘等　　善修如实智
  住是最后身　　皆得法眼净
  彼佛国土中　　所有众生类
  寿命极长远　　满八俱胝岁
  佛灭后之后　　咸皆怀恋慕
  造无数塔庙　　伸供养尊重
  那由他有情　　护持佛正法
  或有发大心　　或般无余者
  彼四大天王　　蒙如来授记
  心生大忻庆　　敬顺头面礼

    父子合集经三十三天授记品第十五

尔时三十三天帝释天主。与其眷属八十俱胝天子来诣佛会。见诸阿修罗王乃至四大天王等。于世尊所广大供养。复闻如来与彼授记。于佛法中增上爱乐。发希有心。求无上道。时帝释天主为供佛故。以神通力化作八十俱胝宝幔。是诸宝幔第一希有。皆以众宝而为璎珞。或赤真珠而为璎珞。或吠琉璃或摩尼珠。或以黄金而为璎珞。于诸宝幔周遍垂下。又复化出八十俱胝清净楼阁门牖栏楯众宝装铰。伞盖幢幡次第严饰。一一楼阁皆有上妙师子之座。众宝铃网而覆其上。一一座侧无数天女以为侍立。于重阁后复化八十俱胝众宝妙车。于上各悬杂色伞盖。以调顺马而驾御之。又复化出八十俱胝爱啰嚩拏大龙象王。一一象王有八十俱胝头。一一头皆有六牙。一一牙上而有七池。一一池中有七莲华皆有千叶。一一叶中有七天女。一一天女复以七女而为侍从。众宝璎珞以严其身。彼莲叶中及楼阁间。所有天女或有执持幢幡宝幔。或作歌舞或奏音乐。或散旃檀沉水香等。或散天中曼陀罗华及以七宝所成之华。于虚空中如雨而下。遍迦毗罗城纵广六十踰缮那量。散已复散积至于膝。是时八十俱胝天子为供养故。亦以神力化出八十俱胝龙象。一一象上皆有幰盖。亦以众宝而严饰之。复化八亿上妙宝车。复化八亿殊妙天女。复化八亿天诸伎乐。是诸天女各乘宝车。作乐歌舞散诸香华。于虚空中右绕三匝。如向所说阿修罗王所作供养无有异也。是时天主及诸天子伸供养已。作是思念此化天女作供养已。了知诸法如佛所说皆如幻化。复观自身亦同幻化。知彼供养及如来身亦如幻化。佛所说法悉成幻化。了知是已离诸疑惑。于世尊所右绕三匝。头顶礼敬住立一面。合掌向佛以偈赞曰

  化人所作诸供养　　巧妙变现无与等
  乃至观察自身相　　悉同幻化无有异
  谓若佛说一切法　　及与授记成佛事
  令诸天发欢喜心　　此等皆同于幻化
  此说牟尼清净身　　及所说法皆如幻
  唯愿如来绝众疑　　令于授记心开解
  谓彼愚夫诸异生　　迷于所行真实行
  由此不了如幻法　　乃说世间无授记
  谓若有学与无学　　及求缘觉弟子等
  彼皆了知如幻法　　于佛法中无疑惑
  有若乐修寂静行　　单已求证独觉果
  彼能了知如幻法　　于佛法中无疑惑
  有若乐行菩萨行　　利乐世间无放逸
  如是佛子了幻法　　于一切法无分别
  最上善逝调御师　　具足大悲无与等
  十力胜慧妙难思　　于此法中达自性
  或有依止阿兰若　　离诸热恼无希求
  彼能了知如幻法　　于佛法中无疑惑
  若达诸法如幻化　　实无少法而可得
  彼则远离一切疑　　当于佛教生尊重
  愿我成佛出世间　　常说诸法皆如幻
  皆令解脱虚妄因　　安住真常佛境界

尔时世尊。知彼天主及诸天子深心所念。于其面门放净光明。尊者马胜比丘睹是相已。合掌向佛以偈问曰

  牟尼具足大名称　　今者忽放净光明
  此光殊胜非无因　　唯愿大慈为我说
  如来面门现此瑞　　时会睹已咸有疑
  我等愿说光所从　　闻者皆得心清净
  诸天称赞佛功德　　广设最上妙供养
  将非如来放此光　　令诸天子心悦豫
  佛放无边离垢光　　此光清净逾珂月
  将非诸天达幻法　　十力与之垂印可
  牟尼积集菩提行　　常修法施心无吝
  唯冀如来决众疑　　令于佛法善安住

尔时世尊。为马胜比丘说伽陀曰

  善哉马胜大比丘　　汝能请问放光事
  我今为说此因由　　与诸天子授佛记
  如是彼诸天子众　　能了一切法如幻
  成就无边净智明　　灭诸痴暗除疑惑
  曾于过去生死中　　亲近承事河沙佛
  从彼闻法正思惟　　由是了知如幻法
  今于我前伸供养　　亦知诸法皆如化
  已于佛法离诸疑　　得决定心无损减
  彼等当于未来世　　得成最上菩提道
  号曰帝幢王如来　　巍巍功德极高显
  教化那由他众生　　为说如是如幻法
  是诸天子同名号　　次第皆当得作佛
  汝等诸天舍放逸　　观诸境界犹如幻
  渐能修习奢摩他　　速得无上菩提果

    父子合集经焰摩天授记品第十六

尔时焰摩天王与四俱胝天子来诣佛所。见诸阿修罗王乃至三十三天帝释天主。于佛世尊作大供养。复闻如来与彼授记。欢喜踊跃得未曾有。于佛法中深生爱乐。即作是念谓佛证得最上甘露第一之法。于诸世间无有少法而不能知。无所不见无不解了无不现证。由彼如来于世俗谛及胜义谛明了通达无有限碍。彼世俗者。谓世间行。若业若报已生未生皆悉知之无有错谬。彼胜义者。第一清净。不可识别不可智知。不可言说不可显示。非见非闻非取非舍。非动非静非得非失。非去非来非轻非重。非毁非誉非利非衰。非称非讥非乐非苦。非色非非色。非数非非数。非分别非离分别。非烦恼非离烦恼。绝诸戏论超诸言说。乃至所谓色相不可得。受想行识相亦不可得。眼相不可得。耳鼻舌身意相亦不可得。色相不可得。声香味触法相亦不可得。眼识不可得。耳鼻舌身意识亦不可得。眼触不可得。耳鼻舌身意触亦不可得。眼触所生诸受不可得。耳鼻舌身意触所生诸受亦不可得。色想不可得乃至法想亦不可得。地界不可得。水火风空识界亦不可得。欲界相不可得。色界无色界相亦不可得。有为相不可得。无为相亦不可得。若人于此胜义法中。求彼诸法及自性者不可得也。又诸无闻愚夫异生。闻是法者则怀惊怖。于佛法中心生悔恼。于一切智即便退失。诸天世人咸共轻毁。如是之人常处轮回。则为众苦之所缠缚。时焰摩天王及诸天子。观察世间一切众生常处生死众苦逼切。于佛正法深生尊重。以神通力作大供养。与前三十三天所陈供养胜过于彼。是诸天子供养毕已。右绕三匝头面礼足。住立一面合掌向佛。以偈赞曰

  观佛诸蕴皆空寂　　处界等法亦复然
  诸根境界常湛然　　则见如来真实性
  世间智者于实法　　不由他悟自然解
  所谓世俗及胜义　　离此更无第三法
  如来出现于世间　　随机演说世俗法
  众生若发清净心　　常获人天诸快乐
  人中无畏释师子　　依世俗谛说六趣
  诸天及人阿修罗　　地狱鬼界傍生等
  富乐丰饶尊胜族　　下劣种姓贫窭家
  仆隶走使伎乐人　　及彼癃残诸疾苦
  如是所说世俗法　　普为利益凡夫人
  由众生起渴爱心　　不能出离世八法
  所谓利衰及毁誉　　及与称讥苦乐等
  得者增于忻喜心　　失者常生于热恼
  此依世俗谈真谛　　由染慧故起颠倒
  不净为净苦为乐　　无我法中执为我
  于无常法谓为常　　起虚妄想而封着
  彼虽设得闻佛言　　心生惊怖不信受
  由谤如来正法故　　于地狱中受极苦
  如是贪欲愚痴人　　展转沉沦不休息
  若有人于佛法中　　以慧拣择非颠倒
  弃舍轮回苦恼因　　渐能修习菩提道
  诸法自性本清净　　及胜义谛非诠显
  若人闻生爱乐心　　当知是为真佛子
  我依如来作是说　　诸天一心当乐求
  若能如理依法行　　毕竟皆当成佛道

尔时世尊。知诸天子深心所念。口放净光普照时会。尊者马胜比丘睹是光已。一心合掌以偈问曰

  如来今者放光明　　众会见已生疑虑
  愿为我等说其由　　令此大众心安隐
  若或诸天得授记　　咸皆尊重生随喜
  具智慧者亦希望　　于佛法中常精进
  此诸天子住佛前　　皆为最上功德器
  伏冀如来阐大慈　　以梵音声垂摄受
  彼闻佛德心忻乐　　谓我当得无有疑
  若得如来授记言　　勇猛勤修无退转
  大哉无上天人师　　破异论者归正理
  众会伫闻微妙音　　速演诸天授记事

尔时世尊。为马胜尊者说伽陀曰

  马胜比丘当谛听　　我为宣说放光事
  此大集会诸天人　　乐闻如来功德故
  世有下劣凡夫人　　闻佛功德不忻乐
  彼怀贪恚常炽然　　百千生中多忿诤
  若于佛法生信乐　　是人曩劫曾薰习
  大悲愿力常相应　　当获如是佛功德
  若见世间衰苦者　　常起悲心为怜愍
  赞佛胜德叵思议　　令彼净信生爱乐
  诸天曾于过去佛　　广大修习诸善根
  今闻佛德妙难思　　犹若花鬘当顶受
  彼焰摩天并眷属　　于我法中求得度
  具足净慧大悲心　　厌离世间诸有结
  承事供养诸如来　　犹若殑伽沙数量
  积集无边胜福因　　为求无上菩提故
  人中师子出世间　　能设无边清净法
  众生没溺烦恼中　　以大悲心而济拔
  观诸众生萦业惑　　为设最上出离法
  彼闻法已正思惟　　知诸法空离自性
  诸根寂静无所著　　了一切法皆如幻
  各各达法本性空　　由此入解真实相
  彼诸天子于我前　　已作广大诸供养
  于彼未来星宿劫　　得成无上菩提果
  此诸如来出于世　　满四十四俱胝劫
  度脱无量苦众生　　皆令清净离诸惑
  彼焰摩天得授记　　同名大仙降冤佛
  今为马胜答其疑　　诸来大众皆忻庆

父子合集经卷第八父子合集经卷第九

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    睹史多天授记品第十七

尔时会中。有八十俱胝睹史多天子。见诸阿修罗王。乃至焰摩天等。于世尊所作诸供养。复闻如来与授无上大菩提记。心大欢喜得未曾有。是诸天子即作是念。此菩提法本无色相。受想行识亦复无相。今者世尊。当以何法而为授记。所以者何。色本无生菩提亦无生。乃至识无生故菩提亦无生。云何无生法能得菩提耶。如是色无灭故菩提亦无灭。乃至识无灭故菩提亦无灭。云何无灭法能得菩提耶。如是色寂静故菩提亦寂静。乃至识寂静故菩提亦寂静。如是色无二故菩提亦无二。乃至识无二故菩提亦无二。如是色无动故菩提亦无动。乃至识无动故菩提亦无动。如是色不可见故菩提亦不可见。乃至识不可见故菩提亦不可见。彼菩提相自性离故。复云何说不生不灭寂静无二湛然不动及不可见。于诸法中何者名色。色自性空。受想行识亦复皆空。何者名佛。何名菩萨。何名授记。佛佛自性空。菩萨。菩萨自性空。菩提。菩提自性空。授记。授记自性空。所名佛者但依世俗。假名呼召希望分别。诸有智者闻诸法空不生取着。彼愚痴人闻则嗔恚不能入解。譬如有人于睡梦中具足受用五欲快乐。觉已思念实不可得。智者了知不生忧恼。如是安住菩萨乘者。了菩提性。本来空寂实无所得。不生怖畏亦复如是。何以故。了知诸法皆如梦故。愚痴凡夫取解各异。于诸妄法而生执着。如是诸法皆不可得。凡夫不可得。凡夫法亦不可得。声闻不可得。声闻法亦不可得。缘觉不可得。缘觉法亦不可得。菩萨不可得。菩萨法亦不可得。佛不可得。佛法亦不可得。菩提不可得。菩提法亦不可得。涅盘不可得。涅盘法亦不可得。时睹史多天子作是说已。白言世尊。我今于此第一义中。得无疑惑。发清净心。造作上妙种种供养。胜焰摩天不可为比。作供养已。头面敬礼佛世尊足。右绕三匝住立一面。合掌向佛。以偈赞曰

  若人奉行如来教　　则为安住佛功德
  彼于三种解脱门　　深达义味无挂碍
  此中无色及受想　　亦无行识心与境
  了彼五蕴但假名　　是名具慧人师子
  如是最上胜丈夫　　不取少分菩提相
  已悟蕴空获善利　　于佛功德无疑惑
  深达菩提实相义　　不起希望不毁呰
  亦无忻喜任运心　　此则善住菩提行
  若人平等见法性　　则于诸法无所畏
  佛子能于此世间　　具足修证胜功德
  了达色相悉皆空　　于诸欲境咸弃舍
  观察轮回三有中　　亦不希求不愿乐
  若人明了五蕴法　　佛及菩提并授记
  说者听者二皆空　　如是悟解无所碍
  佛功德法凡夫法　　此一切相本无生
  能了最上法性门　　是则名为真佛子
  又复了知如是法　　五蕴处界本无灭
  佛及菩提授记言　　斯等诸法悉同等
  智者达解此法门　　而不舍离菩提行
  由了法性无灭故　　于佛菩提不难得
  又复诸蕴及处界　　佛及菩提皆空寂
  若人于此无依求　　彼则能持佛正法
  诸蕴处界皆无作　　佛及菩提授记事
  彼等诸法悉皆同　　如是了知为佛子
  诸蕴处界自性空　　佛及菩提授记事
  智者决定善了知　　此则名为真佛子
  诸蕴处界悉虚妄　　及与最胜二足尊
  菩提授记亦同然　　如是了知为佛子
  是法非离非不离　　亦非为有亦非无
  非有为相及无为　　如是了知为佛子
  如来出现于世间　　了达如是微妙义
  是为最上胜丈夫　　堪受诸天广供养
  我今称赞佛功德　　所获福报利群生
  唯有如来悉证知　　回向自他皆作佛

尔时世尊。知诸天子心之所念。希望如来与授佛记。即于座中放净光明。时尊者马胜睹是相已。合掌向佛。以偈问曰

  世尊今者何因缘　　以神通力现斯瑞
  愿为众会说其由　　一切世间咸喜悦
  睹佛口中放净光　　诸天皆悉怀疑惑
  各各瞻仰于慈颜　　一心愿闻佛所说
  譬如病者遇良医　　唯希拯救授灵药
  今此众等住佛前　　渴仰希须亦如是
  诸来集会天人众　　皆具广大清净慧
  一心谛听无异缘　　于佛所说能入解
  如来常以大悲心　　能破一切诸疑网
  彼等闻已皆奉持　　摧诸异论生正见

尔时世尊。为马胜比丘。说伽陀曰

  马胜汝今发斯问　　为利世间作照明
  智者能息诸群疑　　故得人天咸尊重
  睹史天王及天子　　达最上法甘露味
  作大供养妙庄严　　是故我今与授记
  彼以胜慧观世间　　得见法性无所著
  善达三种解脱门　　非愚痴者之所及
  彼于过去诸佛所　　已曾请问如是义
  观诸法性毕竟空　　悉如先佛之所说
  今复于我兴供养　　最上最胜无与比
  能以空义赞如来　　皆为利乐有情故
  一切诸法皆无生　　佛及菩提授记事
  乃至修习菩提者　　本性无生亦同等
  若人如是了法性　　决定当证大菩提
  彼诸天子昔闻持　　故能宣畅第一义
  能以明慧善决择　　了知法性常无减
  彼诸天子离诸疑　　自然成就无师智
  法性非取亦非求　　毕竟无依离分别
  彼诸天子离诸疑　　愚夫心则生惊怖
  一切诸法离自性　　菩提及彼菩提心
  彼诸天子善了知　　本来清净无染着
  睹史天王天子等　　住坚固慧无所住
  不久当得佛菩提　　具足圆成一切智
  于彼未来星宿劫　　次第出现于世间
  度脱无边诸众生　　同名决定智王佛
  如来知彼心所念　　应念忽放净光明
  为说授记成佛因　　令彼时会生忻庆

    父子合集经乐变化天授记品第十八

尔时乐变化天主。与七十俱胝天子眷属俱。见诸阿修罗王。乃至都史多天诸天子等。于世尊所作供养已。深生随喜踊跃无量。复闻如来与彼授记。是诸天子。闻是说已身意泰然。得住实际。于胜义法离诸疑惑。时乐变化天王。即从座起。头面礼足合掌恭敬。而白佛言。世尊。如我解佛所说义。一切诸法名为实际。名无量际无碍际。无住际无尽际无二际非际无际。说名实际。世尊。言实际者。不颠倒故。无量际者。非分限故。无碍际者。非和合故。无住际者。离自性故。无量际者。无有生故。无二际者。唯一相故。非际者。体非有故。无际者。本无极故。世尊。此实际法遍一切处。有为无为通达无碍。无有一法非实际故。乃至菩提亦是实际。复以何法名为菩提。此一切法即是菩提。乃至所有五无间业亦是菩提。何以故。彼菩提法离自性故。五无间业亦离自性。世尊。又彼五无间业即无余涅盘界。何以故。彼诸法性离罪相故。是故无间业名为涅盘界。世尊。住轮回者。可求涅盘。彼实际中无有二相。无生死可离无涅盘可证。何以故。自性离故。世尊。我今于此实际理中无有疑惑。若于此法得离疑者。当知是人。已于过去佛世尊所。得授阿耨多罗三藐三菩提记。是时如来。闻彼天王作是说已。欲令大众心净信解生欢喜故。即于座中放大光明。时尊者马胜比丘。以偈问曰

  怜愍世间调御师　　于大众中现斯瑞
  口中忽放净光明　　此相非无其所以
  今此诸来大集会　　咸生清净恭敬心
  愿说所放光因缘　　使除一切诸疑惑
  此等若闻佛所说　　一心谛听而信受
  咸遵佛教能奉行　　誓求无上菩提果
  唯愿如来速演说　　慰彼群生渴仰心
  诸天身意咸泰然　　决定自知当得佛

尔时世尊。为马胜比丘。说伽陀曰

  马胜今问放光事　　如来所作非无因
  汝当谛听无异思　　今与诸天授佛记
  化乐天王并眷属　　渐能成就一切智
  当于天人大众中　　作师子吼摧异论
  譬如一切山穴中　　不产珠玑无有惑
  如是化乐诸天人　　决定当来得作佛
  又如世间日没时　　不久应知月出现
  彼诸天子达法性　　自知必定成正觉
  又如世间日中时　　观诸色像皆明了
  彼诸天子达法性　　当获如来一切智
  又如世间夜分时　　有情咸知日不现
  彼诸天子达法性　　当得明慧悉照了
  又如世间诸流泉　　悉皆注下归于海
  彼诸佛子达法性　　必能速证大菩提
  如以瓦砾掷空中　　力尽坠地必应尔
  彼诸佛子达法性　　不久成佛无有疑
  若人了达此法性　　入佛知见离戏论
  彼当取证大功德　　往趣菩提场不远
  假使二十那由他　　弊魔说我不作佛
  由具正见达法性　　不能退坏菩提意
  如是彼诸天子众　　善解法性心无著
  各各希望授记言　　故我赞励生忻慰
  是诸天子久修习　　不由他悟能入解
  自知决定得菩提　　诸有智者皆随喜
  马胜比丘当了知　　若求无上菩提者
  常乐亲近佛世尊　　观诸法性无挂碍
  自能入解于正理　　复令他人善通达
  随其力能为演说　　是为第一行法者
  设百千劫行苦行　　以身血肉而布施
  于刹那顷了法性　　此福广大复过是
  过去所有一切佛　　现在救度众生者
  以及未来诸世尊　　无不依此而修习
  化乐天王并眷属　　今于我前伸供养
  已曾往昔植福因　　故能了斯深法义
  诸有世间具智者　　当须修证三摩地
  若能依止胜等持　　是人得至佛行处
  马胜比丘当了知　　此诸佛子悟法性
  常能游戏佛境界　　摧伏一切诸异论
  是故勤修清净业　　则能远离诸苦恼
  常乐亲近说法师　　得成无上菩提道

    父子合集经他化自在天授记品第十九

尔时他化自在天王。与八十那由他天子眷属俱。见诸阿修罗王。乃至乐变化天等。于如来所作诸供养。复闻如来与彼授记。欢喜踊跃得未曾有。白言世尊。此乐变化天所说实际。我今于实尚不可得。云何复说更有于际何以故。世尊。若见实者亦应见际。当知是人住二种相。何能入解证彼菩提。应知彼说是非道行。若善男子。离此二相名善安住。住无所住则无言说。求菩提者。无有少法当情可见。而能觉悟得彼菩提。何以故。此实际法。非有非无离一切相。非过去非现在非未来。非有为非无为。非识识非智知。非观察非现证。无有少法为能对治。亦无少法作所对治。何以故。法非烦恼所染污故。法无自性不可得故。若彼彼法有所对治。则有少法自性可见。世尊。若色生者。彼色离生相故。受想行识生者。受想行识离生相故。世尊。若色灭者。彼色离灭相故。受想行识灭者。受想行识离灭相故。世尊。若过去者。离过去相故。未来者。离未来相故。现在者。离现在相故。世尊。若有为者。离有为相故。无为者。离无为相故。如是五蕴所摄。三际所摄。有为所摄。无为所摄。此等诸法皆不可得。以不可得是故彼法。不可知不可见不可说不可解不可观不可证。世尊。若善男子善女人。为求菩提。如是发心决定修行。彼皆名为善能安住菩萨乘者。尔时他化自在天子。咸说是所悟法已。合掌向佛。以偈赞曰

  如来显示轮回际　　无始坚固难超越
  世间无智诸凡夫　　乐住三有生死海
  诸蕴本来自性空　　一切有情不可得
  无有少法可对治　　当知诸法皆无相
  色自性空本非有　　非知非识非观察
  非见非证亦非无　　依此正理善明了
  菩提无相不可得　　菩提分法亦复然
  佛菩萨僧但假名　　离心取相皆无相
  愚夫着欲取诸相　　自谓我得菩提心
  彼行颠倒境界中　　染慧难证真常理
  于佛境界离相者　　是为智者依法行
  远离诸相如无相　　亦离于空及不空
  依此修习菩提行　　获得最上第一乐
  一切外道不能知　　亦非声闻所行学
  又非辟支迦佛陀　　心善解脱离尘垢
  亦非无漏阿罗汉　　于此正理能入解
  牟尼无相菩提行　　唯大智者善了知
  若依正教能说空　　非二乘辈之所有
  善达实相不思议　　了一切法无自性
  菩提浅识不能知　　上根聪慧闻即解

尔时世尊。知诸他化天子心之所念。即于坐中放净光明。时马胜尊者睹是相已。合掌向佛。以偈问曰

  佛知他化天意乐　　忽放清净大光明
  此唯如来自证知　　愿为时众分别说
  诸天咸作是思念　　佛非无因现此光
  必为饶益诸群生　　令生谛信心渴仰
  今此大众怀犹豫　　由睹如是希有因
  口中放此净光明　　应与诸天授佛记
  彼等弃背轮回道　　求趣寂静涅盘城
  伫闻如来梵音声　　无碍辩才速演说
  众等尊重如来教　　达诸法性无有疑
  坚固闻持信解心　　称赞牟尼功德海
  如来正教不思议　　令众生至安隐处
  若能如理善修作　　毕竟得成无上道

尔时世尊。为尊者马胜。说伽陀曰

  善哉马胜大比丘　　咨问为利群生故
  我今放此净光明　　与授最上菩提记
  他化自在天主等　　信解坚固悉利根
  皆能奉持诸佛言　　久已修习菩提道
  能了世间诸妄想　　如见阳焰知非实
  愚夫谓水起妄心　　求菩提者勿同彼
  诸有执着想见者　　无智返怖于无相
  愚夫妄想趣非道　　离此能得大菩提
  妄想邪思为苦本　　随生分别即为缚
  智者了此悉皆空　　得胜总持寂静乐
  妄想之心不平等　　决定堕落于诸趣
  百千生中为苦缘　　三世如来同此说
  若人取着于想者　　则为阴界所缠缚
  善观察者息妄缘　　一切皆空无有相
  由想相故增诸惑　　复能损减诸福业
  若于无相离狐疑　　速证无上菩提果
  若人分别求圣道　　分别求道即为缚
  智者在欲而行禅　　彼则善修无相行
  诸法无体不可说　　分别诸法性皆空
  彼无相法离思惟　　如是菩提不难得
  闻佛世尊作是说　　众离疑惑得无畏
  如以詹博迦花鬘　　授之欢忻而顶受
  是诸天众心开悟　　今于佛所伸供养
  了知法性本来空　　于未来世皆作佛

父子合集经卷第九父子合集经卷第十

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    大梵王天授记品第二十

尔时会中。有六十俱胝梵天子众。见诸阿修罗王乃至他化自在天等。于世尊所作供养已。复闻如来与彼授记。欢喜踊跃怪未曾有。是诸天子。已于过去诸如来所。亲近供养积集善根。深修禅定超世俗法。于佛正教。各获最上甚深法乐。明了通达离诸戏论。生决定解。了知诸法非作非无作非生非无生非得非无得非尽非无尽非离非不离非垢非离垢非愚非不愚非智非无智非见非无见非取非不取非空非不空非相非无相非愿非无愿。是诸天子。如是知已心无所著。远离诸想无所依求。无种种求想。无作者想。无作者法想。无凡夫想。无凡夫法想。无声闻想。无声闻法想。无缘觉想。无缘觉法想。无菩萨想。无菩萨法想。无如来想。无如来法想。无涅盘想。无涅盘法想。无轮回想。无轮回法想。是诸天子。了彼法性犹如虚空。无有染着。于佛法中离分别想。时梵天王。合掌向佛。以寂静意。说偈赞佛

  如来具足平等慧　　修寂静行到彼岸
  说寂静法度群生　　观诸世间常寂静
  菩提寂静本无染　　依寂静境无动乱
  常餐寂静甘露味　　于一切处悉通达
  如是最上寂静道　　善观察者获妙乐
  依八正道久薰修　　能断世间烦恼缚
  修寂静法证菩提　　乃是先佛之所说
  决定能至涅盘城　　如佛世尊无有异
  若人依止佛正教　　受持读诵勤修学
  求趣寂静解脱门　　一切世间无过上
  善修平等寂静道　　诸根适悦常清净
  具诸福慧遍庄严　　如那罗延有大力
  若了寂静甘露法　　则能尽袪诸有相
  观察世间无所依　　是为最上如来子
  是人久遇于诸佛　　种植无边胜善根
  达斯寂静等持门　　息除诸惑无所染
  由具正念精进力　　离于谄曲懈怠想
  了知生死即涅盘　　能离世间诸相故
  诸佛出现于世间　　演说寂静解脱法
  智者了达无有疑　　永出轮回生死海
  若人于蕴求解脱　　于寂静法非爱乐
  唯悟蕴法不坚牢　　于佛菩提生惊怖
  离欲净心求解脱　　能以明慧善拣择
  着欲取相诸愚夫　　故佛于彼不开示
  若取寂灭亦是缚　　不能成就一切智
  不起一切执着心　　是名善住无相行
  能至无名安隐处　　逮得清净佛功德
  息诸诤论伏魔怨　　能断一切烦恼缚
  我以平等寂静意　　称赞牟尼福德聚
  回向法界诸有情　　同证无上菩提果

尔时大梵天王。知诸梵众天子偈赞佛德。合掌向佛。而说偈言

  牟尼善了世间法　　决定虚假如空拳
  亦如秋云及电光　　佛常显示袪诸妄
  如人梦中饥所逼　　遇餐上妙诸美膳
  毕竟无食亦无人　　如来证法亦如是
  又如梦中渴乏者　　得饮甘露清冷水
  应知渴饮悉皆无　　如来证法亦如是
  如梦中闻美妙言　　彼语言相实无得
  亦无说者及听人　　了法如此无疑惑
  又如箜篌出妙声　　彼声本无有自性
  智者观蕴理如然　　知蕴自性不可得
  无作无受无众生　　无所作业及受报
  亦无受彼果报者　　佛于此理善明了
  譬如摩尼体莹澈　　置之衣上随色变
  诸法自性本无尘　　随其分别而增染
  又如吹贝发大声　　推其响自何所得
  彼声自性本来空　　佛了诸法亦如是
  又如世间香美馔　　彼由众味而合成
  观食自性本来空　　佛了诸法亦如是
  如天帝幢极高显　　无思而现诸色像
  彼幢自性本来空　　大仙证法亦如是
  又如身藉众缘成　　推其体相不可得
  当知诸蕴本如然　　如来证法亦如是
  又如击鼓所出声　　能令闻者生忻悦
  彼之音响本来空　　如来证法亦如是
  如人以桴而击鼓　　寻其声自何方现
  复推隐没向何方　　如来证法亦如是
  又如鼓韵无憎爱　　离湿润缘则鸣响
  此身虚假本同然　　如来证法亦如是
  如人击鼓发响时　　彼声任运无所召
  了身如彼自性空　　如来证法亦如是

尔时世尊。知诸梵众大梵王等心之思念。以寂静意赞如来已。即从口中放大光明。令彼时会睹斯光已。坚固正见增发净慧。时尊者马胜比丘。以偈问曰

  如来今者现奇相　　放净光明极希有
  诸天及人龙鬼神　　睹斯神变咸疑虑
  最上牟尼调御士　　现此瑞应非无因
  愿佛开演光因由　　令诸时会心忻豫
  我等一心生渴仰　　瞻奉慈容无暂舍
  若得闻佛梵音声　　各各除疑生信解
  如来现此神通事　　必为慈念诸众生
  何缘放此净光明　　今正是时冀开示
  大圣牟尼方便力　　令时机发增上心
  众等合掌住佛前　　唯愿如来速演说

尔时世尊。为马胜比丘。说伽陀曰

  马胜汝瞩此光明　　普为成熟有情故
  时众若闻我所说　　则于菩提无退转
  大梵天王梵众等　　善达法性除疑惑
  已于那由他劫中　　修习无边清净行
  于诸境界无染着　　心如虚空无挂碍
  常乐利乐诸有情　　而不取证菩提果
  彼等复于未来世　　过于无量俱胝劫
  具足修证解脱门　　成就无边大忍力
  然后得成无上道　　号曰大忍力如来
  调伏摄化诸群生　　观诸世间皆空寂
  彼佛寿量极长久　　同昔修行诸劫数
  具大威德及名称　　能拔有情生死苦
  彼佛刹土极严净　　富乐丰饶无与等
  设于那由他劫中　　说其功德不能尽
  彼佛说法难思议　　自性空寂无所依
  其国所有诸众生　　成熟善根无损减
  皆尽轮回苦边际　　无一复受后有身
  亦无鬼畜地狱名　　唯有迁流诸行苦
  由悟诸行无常故　　各发胜愿生厌患
  是故彼国诸有情　　皆能永离老病死
  又彼有情善修作　　耳不复听余音声
  唯闻无我及无常　　苦空寂静无相法
  奉持佛语不放逸　　常修纯净真实行
  趣求甘露解脱门　　最上最胜菩提道
  彼土所有诸塔寺　　若墙若壁林木等
  皆出清净妙法音　　闻者咸登不退地
  此是如来神力故　　演斯八种梵音声
  闻已弃背生死流　　求证寂静真常乐
  其国所有诸众生　　已于过去河沙劫
  为菩提故久修行　　今当次第得成佛
  大梵天王梵众等　　由常修证寂灭理
  尔时彼佛及众生　　同餐寂灭甘露味
  复观众生界本空　　未曾暂起疲劳想
  故能遍入诸法性　　常修寂静无相行

    父子合集经光音天授记品第二十一

尔时会中。有八十俱胝光音天子。见诸阿修罗王乃至梵天王等。于世尊所。各现神变作诸供养。复闻如来与授阿耨多罗三藐三菩提记。欢喜踊跃得未曾有。是时天主。即从座起。偏袒右肩头面敬礼住立佛前。白言世尊。有三摩地。名照明诸法。若有菩萨。善修习此三摩地者。则能入解一切诸法。复能获得无量辩才。所谓无著辩才。加持辩才。善巧辩才。美妙辩才。适意辩才。离缚辩才。安隐辩才。甚深辩才。微妙辩才。无等辩才。乃至获得如来所有最上辩才。世尊。何故名为照明诸法三摩地。若菩萨摩诃萨得此三摩地者。于一切法无有寻伺及彼作意。若离此者。则无疑惑。若于诸法断除疑惑。于一切处通达无碍。何以故。以彼诸法离自性故。若了诸法自性无有。彼菩萨则能入解阿字义门。所谓阿者无作。阿者普遍。阿者非有为。阿者非无为。阿者无不成就。阿者无所依止。阿者非动。阿者非乱。阿者非分别。阿者非离分别。阿者非毕竟。阿者非散坏。阿者非形色。阿者非显色。阿者非住持。阿者非定住。阿者非知。阿者非见。阿者非言说。阿者非离言说。阿者非思议。阿者非离思议。阿者非去来。阿者非入出。阿者非有表。阿者非无表。阿者非名。阿者非相。阿者非对治。阿者非覆障。阿者非尽。阿者非无尽。阿者非二。阿者非不二。阿者非真实。阿者非虚妄。阿者非求。阿者非离求。阿者非净。阿者非离净。阿者非执。阿者非离执。阿者无生无所不生无少法可生。阿者无灭无所不灭无少法可灭。阿者不空无所不空。阿者无相无所不相。阿者无愿无所不愿。如是解已知非戏论。是名入解阿字义门。世尊。又复诸法从意中生。由阿字故引生达字。若能入解达字门者。则能入解一切教法。所谓入解有为法无为法有表法无表法世俗法胜义法。世尊。胜义法者。唯一真如。以言诠显何由能解。世尊。如人梦中作种种事。梦境非实但有假名。觉已了知皆由心造。世尊。如空谷中传于音响。自性无实从和合生。世尊。如幻化人作诸幻事。愚夫不了谓为实有。世尊。又如阳焰妄生水想。智者了知本无其体。世尊。又如镜中现诸色像。妄生分别实不可得。诸法性空亦复如是。但为悦豫彼愚夫人。毕竟诸法本来寂静。世尊。我昔曾闻先佛所说胜义谛法。得真实见。是诸天子。作此说已。佛所印可。头面作礼。以偈赞佛

  世尊善达第一义　　故能展转说诸法
  诸有聪慧佛真子　　于佛教海能游戏
  世间少智愚痴人　　由着我故不能解
  我及我所本来空　　十方求之不可得
  如见阳焰本非水　　愚夫妄想作水解
  如是颠倒执为我　　皆由染慧迷真智
  由于五欲生爱乐　　备受生死诸楚毒
  诸蕴自性本来空　　愚夫枉坠于诸趣
  彼无正智心狂乱　　于诸苦境妄为乐
  为三毒火镇烧然　　未尝觉悟生怖畏
  愚夫不厌诸垢惑　　如随怨贼为亲友
  闻如来说胜义空　　返生惊怖或轻毁
  犹如世间怯弱人　　虽持利剑心忧怖
  如来演畅正法门　　所谓微密一阿字
  出生最上真实慧　　如平坦地生乔木
  善能降伏众魔军　　速证无上菩提道
  牟尼有诸胜弟子　　了达如是第一义
  既自消伏三毒垢　　见余毒者施法药
  以八正道大船筏　　运载群生出有海
  令知诸法本来空　　息诸异论妄分别
  明人舍邪归正道　　夙昔曾修彼善根
  了法体性本来空　　心无所著即解脱
  若达法性即同佛　　是名大智那罗延
  诸法性空无所空　　亦无系缚及缚者
  真如寂灭离诸相　　体非垢染亦非净
  以其法尔本如然　　非烦恼缚亦无断
  如是了知诸法性　　是人不久得菩提
  自能得度亦利他　　善谈正理不希报
  有情常生虚妄想　　于境执着男女相
  增长愚痴染污心　　犹如渴鹿奔阳焰
  由彼彼业生诸趣　　此业皆由妄想生
  了业体性本来空　　毕竟无有能作者
  我等解佛所说义　　显示难思妙法门
  归命牟尼大导师　　诸根寂静无所著
  如来清净无瑕秽　　成就无边功德海
  于三界中作照明　　堪受诸天妙供养
  我等于今大会中　　称赞能仁大福聚
  善哉无比二足尊　　究尽诸法实相义
  以此所获善根力　　回施三有诸众生
  愿于未来净土中　　悉能成就菩提果

尔时世尊。知诸光音天子心之所念。于佛法中明了通达。具足殊胜广大辩才。希望如来与授佛记。即于口中放大光明。时尊者马胜比丘。睹是事已。合掌向佛。以偈问曰

  大悲救护世间者　　成就吉祥功德聚
  以方便力息群疑　　放此光明极希有
  众会若闻佛所说　　心生净信决定解
  勤修妙行趣菩提　　超出轮回生死海
  一切天人阿修罗　　为老病死所逼切
  如来常以大悲心　　救济令修八圣道
  彼由勇猛大精进　　深心坚固无退屈
  乐修如是妙法门　　誓证菩提求佛智
  今此会众无余念　　一心瞻仰佛慈颜
  愿闻如来微妙音　　决除疑网生忻庆
  睹佛现斯神变事　　口中放此净光明
  譬如痼疾遇良医　　亦如婴儿顾慈母
  何人请问深法藏　　满足广大悲愿力
  获得最上秘密门　　感佛现斯希有事
  众会心皆大欢喜　　冀闻佛说光因缘
  各能具足清净心　　修习如是三摩地

尔时世尊。为马胜比丘。说伽陀曰

  马胜具足妙辩才　　能应群心发斯问
  今正是时说此因　　斯则如来神变力
  此诸光音天子众　　往昔曾供无数佛
  观察世间苦众生　　誓求佛道而济度
  已修广大真实行　　决定当得一切智
  为彼深着邪见者　　指示咸令归正道
  彼等由闻佛正教　　深入义味生尊重
  犹如世间诸女人　　喜得生男心满足
  是诸天子心清净　　志求无上佛菩提
  曾于那由他劫中　　修习利他殊胜行
  所化众生无限量　　皆能发起大乘心
  具足福智相严身　　星宿劫中皆作佛
  彼诸天子成佛时　　国土无量百千亿
  广博殊妙不思议　　种种庄严无与等
  三恶趣及八无暇　　彼诸佛刹未尝闻
  亦无求证二乘人　　各各咸登不退地
  又彼诸佛刹土中　　有情寿量悉同等
  满足十亿恒河沙　　常能承事于诸佛
  若令那由他众生　　依二乘法取灭度
  不如能化于一人　　或男或女修大行
  以初福聚比于此　　百千万分不及一
  何况劝励于多人　　安住大乘菩萨道
  马胜汝今当谛听　　如来出世甚希有
  譬如优昙钵罗花　　经无边劫难值遇
  善巧方便说法师　　能示真实无为道
  志求寂静菩提者　　应当恭敬常亲近
  那由他数诸天子　　散妙宝衣从空下
  复以清净妙伽他　　称赞如来胜功德
  佛说寂静甘露法　　能袪众生烦恼热
  若依如来教奉行　　渐次得成无上觉

父子合集经卷第十父子合集经卷第十一

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    遍净天授记品第二十二

尔时会中。有十二那由他遍净天子。见诸阿修罗王。乃至光音天等。于世尊所设诸供养。复闻如来与授佛记。心生欢喜得未曾有。此诸天子。已于过去无量佛所植众德本。入解正法充足法财。有大神力自在无碍。从座而起头面礼足。白言世尊。有三摩地。名超诸法乐。若菩萨摩诃萨。获证如是妙三摩地。所作事业离诸攀缘。得最上乐不生苦受。无一因缘而非乐想。假使入于诸地狱中。种种苦具治罚逼迫。由是菩萨三摩地力。一切苦恼悉为快乐。如彼世间诸有情类。造作诸恶不律仪事。劫夺他财王法所戮。或截耳鼻。或断手足。或杖捶打。或绳系缚。为诸狱卒禁闭囹圄。虽受楚毒心无追悔。为贪所蔽翻如乐想。又诸有情。佣力自济艰辛求索以苦为乐。谓裁衣者。造蜡炬者。压蔗浆者。作伎乐者。造饮食者。供象酒者。或然酥灯及油灯者。如是等辈种种所作。或不如法或复迟惰。为彼主者呵骂驱遣。受诸陵辱皆如乐想。又如世间诸俳优者。令他喜悦。易己形状。作鸺鹠面。或师子面。或打或缚。翻为乐想。何以故。以彼众生作业决定。为贪所使心无悔故。菩萨摩诃萨亦复如是。为利有情。能于生死长夜之中。修习种种难行苦行。志求阿耨多罗三藐三菩提。乃至救济饥渴众生。啖己血肉常生乐想。或于菩萨。恶骂捶缚及断命根。虽受苦恼皆生乐想。如是具足广大愿力。能与众生种种快乐。长时修作无有间断。则能获得彼三摩地不为恶魔之所动乱。复能破坏一切魔业。当得如是五种自在。何等为五。一者寿命自在。二者所生自在。三者业报自在。四者寻伺自在。五者受用自在。彼菩萨。若求一生成等正觉。由得如是妙三摩地。即能如意满菩提愿。若不速求无上菩提。则能久住无量无数阿僧祇劫。利乐有情严净佛土。何以故。由彼菩萨从初发心。普为摄受一切有情。不怖恶道于彼受生。皆令习学诸菩萨行。善巧方便通达诸法。成熟般若波罗蜜多。是为善住菩萨乘者。世尊。若菩萨乐修如是三摩地者。当知是人。皆是如来威神功德之所加持。则能决定入解诸法自性本空。无有疑惑。时遍净天子作是说已。合掌作礼。以偈赞佛

  我等遍净诸天子　　于佛正法能了知
  头顶礼敬调御师　　诸根寂静无所畏
  如来以大智慧力　　悉能破坏诸魔军
  归依最上牟尼尊　　引导群萌登彼岸
  诸法自性无所有　　亦复毕竟无所住
  妄想攀缘悉了知　　犹如幻师明幻事
  如是六趣诸众生　　皆从虚妄因缘有
  谷响求之自性无　　如来证法亦同彼
  人中最上释师子　　观诸妄法悉皆空
  彼无我相亦无人　　及与众生寿者想
  如来大慈无与等　　为度愚夫出世间
  演实相法妙难思　　一切无能测量者
  佛观众生界平等　　常起清净无缘慈
  故能怜愍诸世间　　毕竟不见众生相
  我今于佛智慧海　　心无垢染离诸疑
  清净慈门利有情　　堪受诸天广供养
  如来最胜天中天　　常于众生起慈护
  而于十方世界中　　求其苦性不可得
  既无众生亦无苦　　是故如来无所缘
  已能除遣诸忧疑　　获证真常寂静乐
  佛于诸趣不见苦　　亦无所证大菩提
  以此愍念于有情　　皆令弃背生死缚
  无苦无救无众生　　亦无菩提而可得
  佛知法性本如然　　故我于佛伸妙供
  如来出现于世间　　以四无量利含识
  不见慈悲喜舍心　　亦不见有众生相
  不见行于放逸者　　亦复不见修圣道
  知佛如是方便门　　故我于佛兴供养
  牟尼常说四念处　　观身毕竟不可得
  我于佛教如是知　　今得供养救世者
  佛说观受不可得　　以受无有真实性
  乃至受者亦复然　　故我于佛兴供养
  佛说观心及观法　　二相求之不可得
  亦不见有所修念　　及以安住念处者
  我今不见有诸法　　亦复不见修法者
  佛以念处度众生　　彼念自性常空寂
  复说念与法和合　　欲求解脱应修习
  我于佛教如是知　　今得供养一切智
  念处一尚不可得　　况复说有二三四
  是故我今达佛意　　毕竟无受苦乐者
  如来常说四正勤　　有诸比丘专修习
  斯则能为解脱因　　得越轮回生死海
  如是无解亦无缚　　无佛无法及菩提
  而复不坏其假名　　故我于佛伸敬礼
  佛说如意四神足　　最上殊胜安隐乐
  诸根寂静解脱人　　修此能得涅盘道
  又彼如意及神足　　谛观彼体不可见
  非动非静非无作　　如是显现难思议
  今此众会诸天子　　而不见有众生想
  我于佛教正了知　　皆能远离诸疑惑
  此为最上法供养　　唯佛堪任受此供
  如来妙智无等伦　　故我一心生赞叹
  又复牟尼说五根　　此法能得菩提道
  出生福智二资粮　　善观察者除放逸
  所谓信进念定慧　　不见能修及所得
  我于佛法无有疑　　是故今当兴供养
  如来宣说五种力　　能除邪见心谄曲
  息诸烦恼破诸魔　　趣向无为寂静道
  如是诸力无能屈　　无有所缚及缚者
  我于佛法离诸疑　　今当供养调御士
  大仙开示七觉分　　最上清净菩提道
  善修习者诸有情　　得证真常安隐处
  牟尼复说八圣道　　成熟众生诸善根
  常修圣智现其前　　能尽苦际诸缠缚
  如是圣智及诸惑　　毕竟清净无有余
  诸天于此得无疑　　故我供养人中圣
  于奢摩他善修习　　毗钵舍那亦复然
  如来旷劫悉圆成　　能断诸惑及习气
  如是相应因与果　　及观察者悉皆空
  诸天于此得无疑　　故我供养牟尼主
  说不净观除贪欲　　慈心对治彼嗔恚
  以其智慧遣愚痴　　为利众生佛所说
  彼皆无作无罪相　　是故不垢亦不净
  诸天于此得无疑　　由此供养无上士
  又复佛说十不善　　杀盗淫妄及两舌
  恶言绮语贪恚痴　　此等名为十业道
  众生非有亦无杀　　余九过恶理同然
  无善恶相无对治　　以彼罪性本空寂
  此义非无佛正教　　然其不坏法体性
  如是牟尼最上法　　宣扬引导诸群迷
  如理作意正思惟　　是名最上真佛子

尔时遍净诸天子说是偈已。咸各默然。住在一面。时佛世尊。知诸天子心之所念。希授佛记。口中忽放清净光明。尊者马胜见是事已。合掌向佛。以偈问曰

  善哉调御大圣主　　为利群生出于世
  甚深智慧妙难思　　而能化伏诸天众
  穷尽诸法救世者　　现斯瑞相非无因
  能与众生作导师　　唯冀能仁为演说
  此诸遍净天子众　　合掌称赞甚希有
  瞻仰如来功德山　　闻已一心而顶受
  佛为最上天人师　　了达诸法无挂碍
  当愿怜念诸众生　　说此放光神变事
  何人于此生净心　　解于微妙甘露句
  彼于十方世界中　　当得圆明一切智
  谁于未来佛刹土　　饶益摄受诸群迷
  善宣无上妙法轮　　降伏魔军及异论
  是诸天子于佛教　　深入义味心决定
  唯愿如来震法音　　使诸时会除疑网
  百福庄严无上士　　慈心普覆于世间
  八种功德梵音声　　咸愿闻持佛教敕
  若有众生于佛所　　乐闻正法勤修习
  坚固不退菩提心　　渐能成就一切智
  如来善说微妙法　　能尽有情生死苦
  佛子净心当奉持　　则令佛种永不断

尔时世尊。为马胜比丘。说伽佗曰

  马胜善问放光事　　我为利乐诸天人
  汝所得福叵思量　　比喻说之尚无尽
  善哉尊者应其机　　一切大众心忻悦
  此等遍净诸天人　　于我法中得解脱
  往昔曾供于诸佛　　其数千亿那由他
  达诸法性无有疑　　各于彼佛问斯义
  彼由往昔因缘故　　以妙伽佗赞于佛
  此生复以清净心　　称扬贤劫诸善逝
  后于优昙钵罗劫　　成佛号曰那罗延
  教化那由他众生　　悉证无为寂静乐
  同一劫中出于世　　皆名法幢正等觉
  化度众生数同等　　次第皆当成佛道
  是诸如来化缘毕　　分布遗形诸舍利
  建立无量窣堵波　　犹若散花严佛刹
  如是所有众生类　　各于舍利兴供养
  咸登寂静甘露门　　一切如来所称叹
  若有称彼佛名号　　发生净信欢喜心
  当知由是善因缘　　得值当来弥勒佛
  彼得慈尊摄受故　　勤加精进断诸结
  乐修寂静奢摩他　　渐次得成无学果
  从一佛刹至佛刹　　供养亲近无疲懈
  于诸天人大众中　　称扬最上佛功德
  今此遍净诸天子　　皆具威德大名闻
  深达佛智不思议　　各各顶礼如来足

    父子合集经广果天授记品第二十三

尔时会中。有八俱胝广果天子。见诸阿修罗王乃至遍净天等。于世尊所。种种施设作诸供养。奉上如来。复闻与授成佛之记。心大欢喜得未曾有。是诸天子即作是念。如来所说一切诸法。于三际中求不可得。一切诸根皆不可说。若能入解彼法界者。则能通达一切诸法。若能了知一切诸法。则能证得四如实谛。所谓苦谛集谛灭谛道谛。如世尊说。一切诸法皆悉空寂。无我无人无众生无寿者无想无作。我等天子。于此法中心得决了。不生疑惑。世尊。以诸众生本寂静故。则无有苦。当如是知。所以者何。众生无故苦谛亦无。以无苦故集谛亦无。何以故。若无是因则无其果。世尊。以无集故灭谛亦无。何以故。若无集谛则无断集。以无灭故道谛亦无。何以故。无有是道不断集者。世尊。彼烦恼业不可得故。断烦恼灭亦不可得。以灭不可得故道亦不可得。未有是道无其果者。此四圣谛。但是分别假施设有。以非有故不可说为过现未来。何以故。过去已灭现在不住未来未至。于三际中皆不可得。依世俗谛有种种相。若三际非有。彼则无生亦非有灭。无想无作无施无受无说无听。无所说法无了悟者。以彼三世未曾有故。若法若空皆不可说。众生颠倒不能入解。无因无缘无名无相。无所诠表无所趣向。自性离故皆不可得。彼不可得亦不可得。何以故。以众生界本非有故。若彼彼法皆不可得。则无染净。无作无证。无凡夫地。无声闻地。无缘觉地。无菩萨地。无如来地。非地非无地。此即真如寂静无相。若说有表有为限量。名如来者。依世俗说。非胜义中有如来也。何以故。法无得故。若彼如来广大宣说色界乃至识界如是意界乃至法界。若无法界。无所依止亦无诠表。无四谛无五根无缘生等。世尊。彼一切法随其所在。安布建立种种名字。然不坏彼法界体性。世尊。如彼地界。随其方处建立名字。亦不坏彼地界本性。如是水界火界风界空界。立异名字亦复如是。世尊。又若证入彼法界者。即能入解二十二根。所谓眼根耳根鼻根舌根身根。女根男根命根。苦根乐根忧根喜根舍根意根。信根精进根念根定根慧根。未知当知根已知根具知根。世尊。若眼。眼体不可得。若根。根体亦不可得。何以故。眼离自性不可见故。若法自性不有彼即非物。以非物故即不可作。若不可作彼即不生。若不生者即是不灭。以不生不灭故。不可说为过现未来。于三世中无生灭者。彼即非眼亦非眼根。何有作用世俗诠表。世尊。譬如空拳中无有物。但诳愚童唯假名尔。胜义谛中以至空拳。所立名字亦不可得。如是乃至眼及眼根。于胜义中亦复非有

父子合集经卷第十一父子合集经卷第十二

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    广果天授记品之余

世尊。如是色蕴无有分量。无所住持亦非入解。何以故。以色自性不可得故。若诸法非作则无积聚。由积聚故说名为蕴。犹如世间造立舍宅。宫殿楼阁户牖轩槛。园林渠流墙墉围绕。多物积聚名为城邑。当知彼色本来非有。复以何法名为积聚。以无积聚亦无彼蕴。受想行识亦复如是。若于诸蕴各得入解。所造净色任持自性皆不可得。当知地界。地界性毕竟清净。乃至风界。风界性皆毕竟清净。何以故。自性离故。复何说有过现未来生灭等相。是故色蕴不可分别。受想行识亦不可分别。世尊。又若眼处自性非有。本来清净亦无有苦。但是世俗假名显示。彼名及体俱不可得。何以故。实无少法得名为眼。亦无少法得名为处。如是耳鼻舌身意。色声香味触法等处。自性非有本来清净。苦及苦名皆不可得。世尊。又彼眼界无少可得。何以故。若眼离眼性故。若界离界性故。乃至法界亦复如是。由自性离彼则非物。以非物故则非所作。非所作者则无有生。若无生者亦无有灭。若不生不灭即无过去现在未来建立施设。当知诸法本离自性。若法离自性者。无名相无作用无可说无称赞无授记。彼诸天子作是说已。时会闻者心生爱乐。欢喜踊跃快得善利。时彼天主。即从座起。前诣佛所。白言世尊。有三摩地名无量义门若菩萨摩诃萨。能修习是三摩地者。则能获得无量辩才。所谓相续辩才。相应辩才。正说辩才。无著辩才。不谬辩才。微密辩才。甚深辩才。善巧辩才。美妙辩才。正论辩才。得如是等殊胜辩才。各各入解无量法门。具足正见达诸法性。舍离攀缘灭除痴暗。了胜义法入总持门。入解蕴入解处入解界。入解诸根。入解四谛。入解缘生。入解众生入解无众生。入解有想入解无想。入解有形入解无形。入解我入解无我。入解空入解不空。入解相入解无相。入解愿入解无愿。入解出离入解不出离。入解有为入解无为。于如来教不可诠表。但唯假名世俗分别。非言说非无言说。非思议非无思议。非见非无见。非闻非无闻。非觉非无觉。非知非无知。非了别非无了别。非悟非不悟。非得非无得。非对非无对。非证非无证。非白非黑。非明非暗。非浅非深。非清非浊。非安非动。非缚非解。非顺非违。非染非净。非去非来。非生非灭。非智非愚。非成非坏。非道非非道。非执非离执。非众生非无众生。非寿者非无寿者。非我非无我。非有非不有。非空非不空。非相非无相。非愿非无愿。非出离非无出离。非有为非无为。非断非常。非邪非正。非真非假。非实非妄。非住非无住。非依止非无依止。非解脱非离解脱。非观察非现证。非轮回非涅盘。非凡夫境界。非声闻境界。非缘觉境界。非菩萨境界。非佛境界。非境界非非境界。若能如是入解法界。则能入解十二缘生。所谓无明缘行。行缘识乃至忧悲苦恼。为大苦聚。世尊。又彼无明性不可得。何以故。自性离故。若法自性离者彼则非物。以非物故则毕竟清净。亦无生灭非三世摄。无名无相不可显示。亦无记别。但为成熟愚夫。异生假名安立生诸戏论。于胜义中实不可得。世尊。又若无明无自性者。云何能生彼行支耶。以无明无故行支亦无。乃至无彼生缘老死。世尊。若法不生。云何有老。若无老者亦无有病及以灭故。即彼三世诸佛菩提。但唯世俗名字施设。非胜义谛作如是说。所言无明即是菩提。诸有支等亦即菩提。如是入解十二缘生。即是入解真实法界。世尊。如来不生。一切法亦不生。是故无生法即是如来。世尊。如来不灭一切法亦不灭。是故不灭法即是如来。世尊。如来无相一切法亦无相。是故无相法即是如来。举要言之。如是无名无相。不垢不净。非爱非憎。法界不可识。亦复不可知。世尊。真如者即是如来。一切诸法即是真如。是故一切法即是如来。世尊。实际者即是如来。一切诸法即是实际。是故一切法即是如来。世尊。随所有法即是如来。于其法中即有一切法。是故一切法即是如来。世尊。若有人言如来得阿耨多罗三藐三菩提者。当知此人是执着见。何以故。如来无二菩提亦无二。以无二故而无所得。世尊。若有人言如来转于无上法轮。当知是人为执着见。何以故。实无少法如来可得。以诸法性非随转故。世尊。若有人言如来化度无量众生。当知是人是执着见。何以故。实无众生如来度者。世尊。若有人言如来缘尽入般涅盘。当知是人是执着见。何以故。法性常住非生灭故。若有众生。于我所说如是法要。能信解者。当知是人。于阿耨多罗三藐三菩提得不退转。世尊。假使法界有其变异。若善男子善女人。深信是法。于佛菩提而退转者。无有是处。时诸广果天子。于如来前。说己所证胜义法已。头面礼足右绕三匝一心合掌。以偈赞佛

  归命牟尼大圣主　　具足胜慧无过上
  怜愍世间诸有情　　常说如是第一义
  成就无量功德聚　　救拔轮回诸苦因
  既自了达诸法性　　复能开示于群品
  五蕴自性本非有　　应知但诳彼愚夫
  譬如胶着猕猴身　　无智疑惑不能脱
  蕴体求之不可得　　无所依止绝攀缘
  如以璎珞饰虚空　　智者于斯得解脱
  又复牟尼作是说　　诸入自性悉皆无
  犹如深谷传于声　　彼响寻之何所有
  愚痴凡夫由此缚　　于真谛法不了知
  如持珠宝庄严风　　智者观之无所著
  彼一切智作是说　　诸界本来常空寂
  如示空拳但有名　　诳诱愚童实无得
  凡愚妄想执为有　　由于胜义不能解
  展转轮回三有中　　譬如商人迷巨海
  又复如来作是说　　诸根自性常清净
  如诸影像现镜中　　毕竟寻之本非有
  无智疑惑不能了　　迷真实法妄生爱
  犹如深渊堕网鱼　　为彼缠缚何由脱
  众生本空法亦空　　依真胜义无所得
  如依壁绘士夫形　　智者观之非有我
  愚夫执着生爱乐　　皆由不达于正教
  因缘自性无所依　　如彼卵生出其[穀-禾+卵]
  缘生之法刹那有　　暂起即灭匪坚牢
  如人梦中受五欲　　觉位推求何有乐
  无始有情妄分别　　常为境界之所缚
  若能达彼法性空　　如彼飞禽脱笼网
  诸法寂静离言说　　佛能于此证法性
  诸法寂静本来空　　佛能如是归圆寂
  诸法寂静离诸相　　佛能宣畅第一义
  佛于三界无所著　　如来由是出于世
  佛于诸法离诸怖　　由不起彼自他想
  广宣正教破群迷　　故称善导众生者
  佛于诸法离分别　　而能助显第一义
  此唯如来方便门　　非是凡夫之境界
  或有众生作是说　　如来已证大菩提
  或有众生作是说　　如来能转妙法轮
  或有众生作是说　　如来已度河沙众
  或有人作如是说　　佛于轮回久解脱
  饶益无量众生已　　入于寂静大涅盘
  皆是凡夫所执见　　为彼魔党之所持
  于胜义法不了知　　以不了故不知佛
  若有达斯正法者　　是人决定得菩提
  广能救度诸世间　　具足最上功德聚
  如是吉祥寂静法　　体即真如无变异
  唯有牟尼能证知　　我已善达实相义
  今此广果诸天子　　于甚深法心决了
  恭敬合掌无异缘　　住立佛前广宣说

尔时世尊知彼广果诸天子等。毕竟悟入第一义谛。亦能增长时众善根。即于口中放大光明。时尊者马胜。瞩斯相已合掌向佛。以偈问曰

  具足福智无上士　　何因现此神变相
  我曾往昔从佛闻　　若放净光为大利
  如来现此奇相已　　能令众会心泰然
  诸天及人阿修罗　　咸愿亲闻佛所说
  牟尼今者有何故　　口中忽放清凉光
  大众合掌住佛前　　瞻仰尊颜无暂舍
  佛为无上天人师　　愿速演斯希有相
  一切世间诸有情　　若闻佛说除犹豫
  今此广果天人众　　各各自知成佛事
  彼无所证亦无修　　何人所作何所得
  如来八种梵音声　　众生闻已咸忻庆
  随顺正理如法行　　悉能护持于佛教
  我等众会生渴仰　　冀于佛所得亲闻
  若蒙佛说宿修因　　增长人天诸善利
  彼诸天子久植本　　决定成就一切智
  当度无量苦众生　　令悟真如法自性

尔时世尊为马胜比丘。说伽陀曰

  善哉马胜发斯问　　我当为汝分别说
  为利广果诸天人　　于大众中现此瑞
  如来具足一切智　　有三种因放光明
  随顺观察彼机缘　　现此吉祥神变事
  或有乐住涅盘者　　小智求彼声闻乘
  或有爱乐默然者　　志求缘觉菩提果
  或乐为世大导师　　求佛菩提利含识
  故我观察彼善根　　随其乐欲而施设
  若求声闻得度者　　即为彼放下品光
  为求缘觉解脱人　　放中品光而济度
  马胜当知最上光　　与诸天子授佛记
  如其次第下中上　　显示三乘得果证
  若为声闻放光明　　其光出已从足没
  若为辟支佛净光　　现已即向脐中隐
  若为求彼无上道　　其光从佛顶门入
  随其胜劣有所表　　今与诸天记佛果
  马胜比丘当了知　　我今复说光明相
  若光渐次复增广　　从空宛转而右旋
  等佛身量遍庄严　　赫奕犹若融金聚
  如是变现净光明　　当知记别佛刹土
  若光出已犹如盖　　于上遍覆如来身
  有光如华住空中　　焕然显发端严相
  或光三匝入佛身　　斯皆记别佛寿命
  当知如来所现相　　善应群机信乐心
  今此广果诸天子　　满足八十俱胝数
  已经那由他劫中　　承事供养于诸佛
  常乐说是胜义法　　化利含识不疲劳
  誓求无上大菩提　　勇猛勤修无退屈
  过三十六俱胝劫　　具修福慧植善根
  救度无边诸有情　　悉令离苦获安隐
  然后皆当得作佛　　同名号曰那罗延
  其劫称为胜金幢　　各于异刹成正觉
  一一如来出于世　　国土清净妙庄严
  佛身犹若净日轮　　具智光明功德聚
  彼诸如来寿长远　　住世过于那由劫
  各各化度诸声闻　　其数广多无有量
  假使算师及弟子　　比喻校计不能知
  化菩萨众亦无边　　与声闻数等无异
  如是此诸菩萨众　　一同先佛所修行
  由是坚固菩提心　　皆能成就一切智
  彼诸如来化缘毕　　正法久住于世间
  十二那由他劫中　　为诸佛子常守护
  当其正法广流布　　有发菩提大心者
  数量犹如殑伽沙　　各各勤修菩萨行
  如是彼佛灭度已　　所有证悟声闻人
  悉皆求趣于涅盘　　犹如薪尽火随灭
  大众今闻佛所说　　咸发净心生信解
  欢喜住立于佛前　　一心顶礼如来足
  以无与等妙供养　　奉上调御天人师
  咸发坚勇精进心　　如救头然求出离
  勤修胜慧波罗蜜　　常乐亲近说法师
  此是最上真实门　　汝等比丘善修学

父子合集经卷第十二父子合集经卷第十三

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净居天子说偈赞佛品第二十四

尔时会中有无数净居天子及无量众生。于佛法中心得觉悟。离诸疑惑深生爱乐。欢喜踊跃得未曾有。一心合掌住立佛前。各以伽陀称赞于佛

尔时善施天子而说偈言

  佛昔舍身命　　国土及妻子
  圆满彼施行　　故我稽首礼

尔时净戒天子而说偈言

  坚固持净戒　　离一切垢染
  能渡于彼岸　　顶礼具戒者

尔时安忍天子而说偈言

  佛广修忍行　　为他断肢节
  不生怨恨心　　得成无上慧

尔时精进天子而说偈言

  大雄猛世尊　　舍生死重担
  勤修无退屈　　速至于菩提

尔时静虑天子而说偈言

  如来大威德　　常栖止禅定
  不着彼世间　　三际悉平等

尔时胜慧天子而说偈言

  如来胜慧力　　知众生诸行
  如业而受报　　随界趣流转

尔时明福业天子而说偈言

  若修彼福业　　胜报常现前
  余不能了知　　此唯佛境界

尔时了罪性天子而说偈言

  众生由惑业　　常贪求彼物
  于心若了悟　　一切悉通达

尔时善巧智天子而说偈言

  若人于佛智　　善思惟分别
  常念如己物　　菩提不难得

尔时善巧行天子而说偈言

  若起诸惑业　　内心非所思
  了罪性本空　　此为证法者

尔时遍趣行天子而说偈言

  若人造诸行　　随善恶流转
  受好丑之报　　佛眼悉知见

尔时离攀缘天子而说偈言

  若于所受报　　能了知攀缘
  虽生诸趣中　　常与智随转

尔时随顺善巧天子而说偈言

  若造作诸恶　　或修习众善
  皆由先业故　　随所生受果

尔时业善巧天子而说偈言

  了三世业行　　断故不造新
  愚夫无正慧　　随恶而流转

尔时果善巧天子而说偈言

  或因少果多　　或因多果少
  于此不了知　　为愚痴外道

尔时了知业行天子而说偈言

  善因生胜处　　恶业堕险难
  随众生所行　　如来悉明了

尔时见法乐天子而说偈言

  若人受福报　　而不了善法
  彼为自欺诳　　不久当堕落

尔时善受生天子而说偈言

  若造诸胜业　　顺生受其报
  唯佛正了知　　世间不能解

尔时善受名天子而说偈言

  若业经多生　　或俱胝劫数
  展转于今身　　受报佛能了

尔时受报成熟天子而说偈言

  若此业和合　　彼有情受生
  皆从昔因缘　　如来悉明了

尔时根未成熟天子而说偈言

  彼根未成熟　　乐作不善行
  远离二足尊　　不希望解脱

尔时善成熟天子而说偈言

  若业已成熟　　及未成熟者
  业性本来空　　随心之所造

尔时决定受天子而说偈言

  众生所作业　　若重若轻微
  如来悉证知　　受报无差忒

尔时了罪相天子而说偈言

  若造众恶行　　当堕于恶趣
  或外遇良缘　　转重令轻受

尔时明业报天子而说偈言

  积集诸罪恶　　为彼所缠缚
  不畏未来苦　　此邪见外道

尔时善思惟天子而说偈言

  能思择善行　　少善招胜报
  如以涓渧水　　置海永无减

尔时入解诸法天子而说偈言

  若人能永尽　　有漏分别业
  当证无学果　　是如来所说

尔时证佛智天子而说偈言

  佛眼悉明了　　三世诸业果
  种习无遗余　　敬礼遍知者

尔时业无余天子而说偈言

  世间诸有情　　或此生彼灭
  如来已永尽　　得称无畏者

尔时离攀缘行天子而说偈言

  众生所行行　　唯趣于生灭
  果报如梦幻　　此如来所说

尔时伏诸惑天子而说偈言

  愚痴着欲者　　如渴饮碱水
  是故调御师　　观之如梦事

尔时离分别天子而说偈言

  由贪痴过患　　起分别执着
  智者善了知　　梦中何有乐

尔时息虚妄天子而说偈言

  梦中说梦事　　从颠倒所起
  如来所教敕　　当求寂静法

尔时观察漏尽天子而说偈言

  如人于梦中　　见天雨洪注
  了梦体本无　　应知漏非有

尔时了梦境天子而说偈言

  梦境本为假　　何曾见其漏
  展转妄想生　　而作于漏解

尔时达真常天子而说偈言

  如世间童女　　梦已生于子
  生已而夭殇　　何有别离苦

尔时寻梦境天子而说偈言

  如人于梦中　　为他断己首
  彼识本无得　　谁为能断者

尔时正观察天子而说偈言

  彼智了诸法　　如梦境和合
  无喜无别离　　此为真胜义

尔时智心天子而说偈言

  从佛闻正法　　心了若虚空
  梦中寻梦因　　法性本如是

尔时意喜天子而说偈言

  汝等诸天人　　常乐在禅定
  了知彼世间　　犹如镜中像

尔时善慧天子而说偈言

  如来所说法　　如箜篌发声
  饶益诸天人　　故我称赞礼

尔时了幻化天子而说偈言

  幻人作幻事　　愚夫不能了
  智者所了知　　一切皆如幻

尔时定中变化天子而说偈言

  如来出于世　　如梦中见幻
  善达佛理者　　于此无疑惑

尔时如幻化天子而说偈言

  幻师知幻法　　于幻能变现
  由了彼幻故　　则见诸法性

尔时分别观智天子而说偈言

  汝观世间佛　　起思惟分别
  梦中见佛身　　于法何所说

尔时离思惟天子而说偈言

  无物不生贪　　由贪而积聚
  无思亦无贪　　见佛亦如此

尔时正智天子而说偈言

  深谷本无声　　亦无彼听者
  如是达佛理　　于世无所著

尔时善说天子而说偈言

  如人闻谷响　　彼声不可得
  愚夫不了知　　妄执以为实

尔时各各入解天子而说偈言

  诸愚夫执着　　不达胜义法
  若了法性者　　自他无疑惑

尔时求利益天子而说偈言

  最上胜义法　　诸佛等无异
  无说亦无听　　及彼领悟者

尔时入解法天子而说偈言

  断诸烦恼垢　　分别所分别
  离染得清净　　牟尼之所说

尔时善思惟天子而说偈言

  于诸法名数　　断有漏烦恼
  心净无瑕秽　　是名真佛子

尔时无依止天子而说偈言

  心等于虚空　　三界无所著
  善施不希报　　寂静无畏者

尔时无染污天子而说偈言

  于欲离诸贪　　色无色亦尔
  牟尼心平等　　如空无障碍

尔时无希望天子而说偈言

  于欲不希望　　色无色亦尔
  离和合相应　　归依无上王

尔时拔爱欲天子而说偈言

  由断彼爱垢　　拔三有毒箭
  敬礼调御师　　永超于彼岸

尔时降伏爱天子而说偈言

  发最上精进　　伏除世贪爱
  常起大悲心　　是为救世者

尔时离相应爱天子而说偈言

  离相应爱欲　　不复受轮回
  归依无上尊　　如莲超浊水

尔时达法性天子而说偈言

  归依离缚者　　善达实相义
  明了诸法性　　其心无所畏

尔时超欲泥天子而说偈言

  贪欲如淤泥　　勇捍能超越
  敬礼牟尼尊　　不复生三有

尔时弃珍玩天子而说偈言

  若人远追求　　则能离诸恶
  于珍玩无贪　　心净踰于彼

尔时离忧天子而说偈言

  若人于欲境　　心不生放逸
  则能越魔网　　是为大智者

尔时施无畏天子而说偈言

  自他修正行　　离忧怖热恼
  佛以无碍辩　　令众生觉了

尔时持誉天子而说偈言

  若闻佛音教　　善思惟分别
  是人于世间　　能尽诸苦际

尔时无所畏天子而说偈言

  救世释师子　　智海广无极
  决定了诸法　　能起对治道

尔时离诸怖天子而说偈言

  敬礼天中尊　　无垢无所著
  善拔烦恼箭　　能离一切怖

尔时无所著天子而说偈言

  若诸天魔梵　　请佛转法轮
  于大集会中　　唯佛得无畏

尔时师子奋迅天子而说偈言

  善说一切法　　成就一切智
  敬礼释师子　　三界无伦比

尔时除惊怖天子而说偈言

  师子依山谷　　心常离诸怖
  震吼林薮中　　驰散余小兽
  圣主出世间　　智慧叵思义
  演法怖众魔　　降伏诸外道

尔时降伏魔怨天子而说偈言

  所来所得法　　世间无与等
  故我稽首礼　　圣中最圣者

尔时师子慧天子而说偈言

  敬礼牟尼主　　众圣之导师
  成就一切智　　通达无边法

尔时随佛受生天子而说偈言

  如来证诸法　　无能发问者
  随佛所受生　　请宣深妙义

尔时持藏天子而说偈言

  佛持正法藏　　无畏善宣说
  百千亿有情　　皆令生觉悟

尔时随法行天子而说偈言

  随法修诸行　　能发菩提心
  于世间勇猛　　为最上丈夫

尔时乐法乐天子而说偈言

  彼大心众生　　由闻佛音教
  如法而行学　　得成无上果

尔时净心天子而说偈言

  如来梵音声　　闻已心清净
  虽万类机缘　　无能发问者

尔时清净眷属天子而说偈言

  佛于长夜中　　如理修众行
  具相好光明　　得眷属圆满

尔时无漏法天子而说偈言

  如来尽诸漏　　故能师子吼
  于未曾有法　　分别除疑惑

尔时达胜义天子而说偈言

  如来大智力　　了诸法自性
  诸天及世人　　无有如佛者

尔时尽诸漏天子而说偈言

  最胜大沙门　　毕竟尽诸漏
  今此大会中　　无能伸诘问

尔时常勇猛天子而说偈言

  大雄大智力　　诸法无不见
  惑业尽无余　　于问难无恼

尔时寂意天子而说偈言

  永离贪过患　　嗔痴亦复然
  不起恶业思　　敬礼寂静者

尔时相应行天子而说偈言

  归依善逝师　　永尽诸业惑
  正行常相应　　至一切智处

尔时相应智天子而说偈言

  无边相应行　　为佛所行处
  种现习亦除　　得成一切智

尔时相应慧天子而说偈言

  佛以相应慧　　为世作照明
  根本诸惑因　　毕竟永除断

尔时寂静受天子而说偈言

  永断一切惑　　深心常寂静
  佛子善精进　　于怖何所有

尔时智现证天子而说偈言

  佛尽诸烦恼　　种现及俱生
  破众生无明　　大悲无与等

尔时拔除随惑天子而说偈言

  牟尼天中天　　以智能觉悟
  断增上随惑　　及除余习气

尔时安隐住天子而说偈言

  能仁出兴世　　断诸有漏因
  示现从母生　　为利有情故

尔时离诸染天子而说偈言

  调御天人师　　离烦恼怖畏
  焚烧苦根芽　　无复余种子

尔时除虚妄天子而说偈言

  佛以一切智　　永弃无明垢
  依止清净行　　此名善调伏

父子合集经卷第十三父子合集经卷第十四

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净居天说偈赞佛品之二

尔时善称赞天子而说偈言

  佛超三有海　　能化彼难化
  是故于世间　　得称无所畏

尔时达真谛天子而说偈言

  成就一切智　　灭除诸惑业
  令尽无遗余　　是名大寂静

尔时法幢天子而说偈言

  建高胜法幢　　摧坚固我慢
  无量勇健力　　示众生正道

尔时法海天子而说偈言

  牟尼说诸法　　为大法宝藏
  开导彼群迷　　令至安隐处

尔时法衣天子而说偈言

  佛子住大法　　其心无厌足
  安忍离诸怖　　故能师子吼

尔时求法义天子而说偈言

  佛子善了知　　当勤求正法
  闻已如教行　　速得菩提道

尔时渴仰法天子而说偈言

  无量百千万　　俱胝有情众
  希闻佛音声　　志固常精进

尔时勇法天子而说偈言

  具广大辩才　　摧灭诸异论
  乐修殊胜行　　得最上菩提

尔时持法天子而说偈言

  佛说第一法　　甚深极难了
  印胜义皆空　　令得寂静道

尔时乐勇施天子而说偈言

  佛子善行施　　捐舍己身命
  以是因缘故　　得成最正觉

尔时离染慧天子而说偈言

  坚固持净戒　　其心无所畏
  闻佛正法音　　顶受无忘失

尔时无异缘天子而说偈言

  圣主法中王　　善巧说诸法
  不求二乘果　　勤修无上道

尔时近住天子而说偈言

  世雄二足尊　　为众生出现
  分别说三乘　　究竟唯佛智

尔时成就辩才天子而说偈言

  佛名遍十方　　辩才无限碍
  咸以清净心　　于所说随喜

尔时各各成就辩才天子而说偈言

  若人无辩才　　从佛所求愿
  说法除诸怖　　闻者不毁呰

尔时常喜天子而说偈言

  佛子住忍力　　为呵毁无恚
  志求大菩提　　常喜无怯弱

尔时离二乘天子而说偈言

  为如来长子　　不乐下劣乘
  若闻佛音声　　唯趣无上道

尔时无能胜天子而说偈言

  勇猛大精进　　不怖诸烦恼
  舍缘觉声闻　　誓求无上慧

尔时相续善法天子而说偈言

  乐修净分法　　而无有间断
  牟尼大导师　　知彼所依处

尔时善说法天子而说偈言

  摄受彼正法　　如来所印可
  住坚固精进　　如满月无减

尔时善法性天子而说偈言

  法自性洁白　　为客尘所覆
  皆由染污心　　如来能现证

尔时达正理天子而说偈言

  法性本无染　　黑白不共住
  此正理相应　　如来之所说

尔时分别善恶天子而说偈言

  一切不善法　　善力能摧灭
  若恶法增多　　违损于白业

尔时入正解天子而说偈言

  由彼染污行　　白法不增长
  定为损害缘　　此如来所说

尔时求解脱天子而说偈言

  染污力强盛　　心不希解脱
  隐覆一切智　　于此善决择

尔时明心天子而说偈言

  心若脱诸欲　　恶业不复生
  如来能证知　　为众生演说

尔时见烦恼天子而说偈言

  若不了正法　　不知染污行
  常违背佛言　　去圣道弥远

尔时见罪行天子而说偈言

  若不造诸恶　　善业则增益
  是故彼智人　　乐解脱安乐

尔时信力天子而说偈言

  离贪恚痴行　　则能越恶道
  如来出世间　　常如是教诲

尔时知善恶天子而说偈言

  若于染净法　　心不能分别
  佛说如是人　　为极愚痴者

尔时解脱行天子而说偈言

  随顺佛教诲　　弃舍诸不善
  是人于圣道　　决定得成就

尔时解脱现前天子而说偈言

  若弃诸恶法　　白业则现前
  精勤无退修　　弊魔不得便

尔时顺正理天子而说偈言

  诸佛所说法　　利乐于群生
  令远离非处　　不随彼劝请

尔时吉祥无畏天子而说偈言

  不净观治贪　　为相应正行
  彼贪既除已　　当令障转远

尔时进趣胜慧天子而说偈言

  慈心观治嗔　　彼嗔得解脱
  设复遇深怨　　而不生少怖

尔时净眼天子而说偈言

  净慧断痴惑　　是所对治法
  彼痴已遣除　　不随他教敕

尔时破疑惑天子而说偈言

  住正念思惟　　能离诸疑惑
  设遇邪师友　　依法善调伏

尔时达无相天子而说偈言

  如来说空法　　依空善安住
  既达于正理　　此不由他悟

尔时除我慢天子而说偈言

  了自他我慢　　高举何所得
  与正行相应　　皆悉令除断

尔时寂意天子而说偈言

  永断诸疑惑　　深心常寂静
  烦恼不复生　　安隐而得度

尔时观照天子而说偈言

  了知道非道　　依净而离染
  随顺诸佛言　　除怖得解脱

尔时了世俗天子而说偈言

  世俗唯假名　　能起对治道
  当知彼世尊　　亦假名施设

尔时身威仪天子而说偈言

  以智为前导　　身业随法行
  利乐诸有情　　得成一切智

尔时净身业天子而说偈言

  佛身业清净　　所作无错谬
  怜愍诸众生　　我今归命礼

尔时身业决定天子而说偈言

  身业善决择　　方便利群品
  信礼调御师　　为世照明者

尔时善观身天子而说偈言

  善观察身业　　具清净相好
  为无上丈夫　　能与一切乐

尔时成就语业天子而说偈言

  远离彼恶言　　具美妙功德
  住正念思惟　　是如来所说

尔时应辩天子而说偈言

  如来梵音声　　世间咸尊重
  善察彼时机　　非义利不说

尔时成就义利天子而说偈言

  远离不饶益　　与相应安乐
  不坏于果报　　是先佛所说

尔时不相违天子而说偈言

  未尝邪活命　　求利而妄语
  故佛大名闻　　世所不能坏

尔时实语天子而说偈言

  佛出于世间　　所说皆真实
  是故诸天人　　咸乐闻妙法

尔时了实际天子而说偈言

  佛以实语故　　得成最正觉
  了缘生诸法　　名正遍知者

尔时超缘生天子而说偈言

  若有为诸法　　及诸法实性
  牟尼法中王　　如理悉知见

尔时决定行天子而说偈言

  于自他所作　　身语意业行
  佛以清净智　　悉能分别说

尔时定意天子而说偈言

  佛以清净意　　六返观众生
  归命救世尊　　大悲无与等

尔时善伺察天子而说偈言

  如来有所作　　威仪无缺减
  悲智常相应　　愍念于三有

尔时觉意天子而说偈言

  佛心所缘处　　身语悉调柔
  于诸大众中　　未尝有错谬

尔时明了意天子而说偈言

  佛以意为地　　大悲观众生
  知法自性空　　方便令开悟

尔时过去善巧天子而说偈言

  若人于往昔　　所修诸行业
  施戒忍进禅　　如来悉明了

尔时观察过去天子而说偈言

  宿植诸德本　　承事多亿佛
  今满彼昔心　　获得菩提果

尔时具足相应行天子而说偈言

  佛于无量劫　　随处修胜行
  正念常相应　　不舍菩提故

尔时观察先行天子而说偈言

  亲近诸如来　　修习善咨问
  乐住三摩地　　出生种种法

尔时本行相应天子而说偈言

  过去诸佛所　　请问如教行
  于三摩地门　　观察无疲倦

尔时知宿住天子而说偈言

  生死多过失　　应作不应作
  如来了知已　　为说解脱法

尔时观先业行天子而说偈言

  昔同造诸恶　　染污业相似
  或迭相食啖　　或与之游戏

尔时了前际天子而说偈言

  如来出世间　　以禅定智力
  能知过去世　　诸趣无有碍

尔时知后际天子而说偈言

  佛知未来世　　智慧无障碍
  此殁及彼生　　业报亦复尔

尔时知后际境界天子而说偈言

  如来知后际　　智力无限碍
  众生所行行　　随业受其报

尔时离轮回天子而说偈言

  如来大勇猛　　成就无上慧
  于三有不着　　住最胜境界

尔时了世俗天子而说偈言

  众生所归趣　　起种种忆想
  但唯假名字　　此如来所说

尔时观现在天子而说偈言

  现在勇猛尊　　智力无能坏
  河沙诸佛土　　分别无限碍

尔时住无畏天子而说偈言

  圣主法中王　　照三世平等
  诸法无自性　　愚夫不能了

尔时智无著天子而说偈言

  如来善调伏　　三世无所住
  以法离自性　　一切无所得

尔时明三世慧天子而说偈言

  了过未无体　　蕴起倏归灭
  如是轮回相　　牟尼之所说

尔时意无著天子而说偈言

  诸法皆幻化　　如阳焰谷响
  有情及世间　　自性非真实

尔时喜三世天子而说偈言

  如来慧无等　　能了知三世
  诸根自性空　　一切皆如幻

尔时乐欲行天子而说偈言

  如来于中夜　　示现成正觉
  发勤勇乐欲　　未曾有退减

尔时发起乐欲天子而说偈言

  佛为世光明　　精进无损减
  由彼大勇猛　　超出成正觉

尔时超欲想天子而说偈言

  佛出于世间　　极勇猛精进
  能超欲淤泥　　如莲不着水

尔时乐欲解脱天子而说偈言

  如来出兴世　　说法界平等
  唯一无二相　　故我称赞礼

尔时发起精进天子而说偈言

  如来大威德　　能警觉群品
  勤修不懈怠　　天魔不能坏

尔时具正念天子而说偈言

  佛于一切处　　常起彼正念
  是故成道已　　获得念无减

尔时住等引天子而说偈言

  如来常在定　　知众生性欲
  随彼所修行　　而为说诸法

尔时尊重正智天子而说偈言

  世尊大智海　　边际无限量
  设经百千劫　　说之不能尽

尔时乐解脱天子而说偈言

  无能胜丈夫　　乐最上解脱
  由证解脱故　　于三有不着

尔时相应解脱天子而说偈言

  牟尼大圣主　　具解脱知见
  度无尽众生　　真智无有减

尔时观往行天子而说偈言

  昔于然灯佛　　达胜义法行
  勤修不退转　　证得大菩提

尔时甚深行天子而说偈言

  佛久离诸恶　　非如余有情
  知法自性空　　于三际无碍

尔时广慧天子而说偈言

  佛于一切智　　心不生疑惑
  正念常现前　　如持油满钵

尔时无散乱天子而说偈言

  佛心常湛然　　未曾有散乱
  法性本无染　　众生不能解

尔时安住智天子而说偈言

  如来不共法　　甚深叵思议
  于一切众生　　未曾不择舍

尔时超诸有天子而说偈言

  佛为天中仙　　三界无伦比
  了达一切法　　胜智无过上

尔时坚固不退天子而说偈言

  坚勇最胜尊　　于法无所畏
  觉悟诸有情　　其心悉平等

父子合集经卷第十四父子合集经卷第十五

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    外道婆罗门授记品第二十五

尔时会中有外道婆罗门。名钵哩没啰惹迦。与其眷属六万人俱。见诸阿修罗王。迦楼罗王。诸大龙王。夜叉乾闼婆等。及璎珞天。四天王天。三十三天焰摩天。睹史多天。乐变化天。他化自在天。梵众天。光音天。遍净天。广果天等。作供养已。蒙佛授记。及闻净居诸天子众以妙音声说偈赞佛。欢喜踊跃。得未曾有。时彼外道从座而起合掌向佛。而作是言。我闻瞿昙说无我法。心不爱乐而生疑惑。不乐住处无家所归。沙门瞿昙。若无我者。何故此身从因缘生。我见瞿昙神通色相。于天人中最为第一。具足成就广大威德。令诸见者皆生欢喜。又尝为诸广果天子。说一切法即是如来。云何乃言无有我耶。沙门瞿昙。愿为时会如实分别。我当听受。唯有如来他心能知。令我了解断除疑网。佛言。善哉外道。假使汝伸百千问难。我悉能答不以为难。我返问汝随汝意答。外道。云何有情最初结生入母胎中。汝知之否。外道答言。我宗所说有三种因。父母和合如是成胎。佛言外道。彼胎为从父贪起耶。答言不也。佛言外道。彼胎为从母思起耶。答言不也。佛言外道。彼胎为从天中退没入母腹耶。外道答言。不知也。外道。彼胎为从人趣中殁入母腹耶。答言。不知也。外道。彼胎为从阿修罗中地狱中畜生中饿鬼中殁入母腹耶。外道答言。皆不知也。佛言。外道于意云何。彼胎为从色生入母腹耶。答言。不知也。佛言外道。于意云何。彼胎为从受想行识生入母腹耶。答言。不知也。作是说已。佛即告言外道。此法甚深微细难知。非汝论议测度能解。唯具正见专心修学。于此理趣方能了知。譬如有人患其眼根。得遇良医治差其目。由是缘故复见众色。外道。若能亲近诸善知识。是人即得慧眼清净。以其慧眼得见深法。若不具足信等五根。入解深法无有是处。是故汝等诸外道辈。在昔生死长夜之中。为彼邪论之所诳惑。起于异见坚执不舍。于其非法取为正法。于非解脱执为解脱。于非出离而为出离。汝师自坏亦坏汝等。外道。譬如有人自己无目。为诸盲者而作引导。当知此辈必堕险难。如是沙门惑婆罗门。实非先觉自称先觉。自处非道说为正道。自未调伏谓已调伏。自依邪念谓为正念。自非救度谓能救度。自不能知出离之道。谓我能知出离之道。佛言外道。如牧牛人牵牛渡水。先不能知水之浅处。误入深渊旋转洄洑。彼牛舍此未达彼岸。溺于中流困厄无救。何以故。由牧牛者不能导故。外道。如汝等辈。实非导师自谓导师。令受化者返遭困厄。亦复如是。佛言外道。我称导师真善调伏。令于正法决定安隐。我是正觉如实觉了。令诸有情真实觉悟。我常正念忆持不忘。亦令众生离诸散乱。我善出离永脱轮回。令所化者得尽苦际。我示正道决定无异。令所化者得到彼岸。外道。汝今欲求解脱法者。应当发起清净乐欲一心尊重精勤修学。先所未闻出离法要。当生净信令汝入解。先已学者汝宗论议。应当舍离更不寻求。先未获得正法之藏。令汝悟入通达无碍。佛言外道。于我法中说有三种和合相应得入胎藏。所言父者。是为过去先业之因。所言母者。乃为过去先业之缘。最初结生羯逻蓝位。业招彼识托母胎中。此业熟故于彼受生。如寻香城随心所现。识依胎已渐次增广。譬如世间药草丛林依彼大地而得生长。外道。如是彼识入母胎已。渐次成就身支具足。将及产生形分显现。因缘和合相续不断。外道。如是胎中最初结生分位差别。唯除如来具一切智号正遍知真实了达。无智愚夫则不能解

佛言外道。若彼有情从地狱殁得生人趣。入母胎中出生世间。当有是相。其声嘶嗄语不明了。有所言说人不信用。匆遽慞惶事多忘失。心常恐怖身毛颤耸。梦中时见大火炽然。釜镬沸腾。奔走求避。狱卒罗刹执杖驱逐。或见被缚置于柱橛以杖捶打求脱不能。或见狂象毒蛇所趁交横驰走不知方处。为人轻贱视之如贼外道。是为从地狱来有是余习。智者了知愚夫不解

佛言外道。若彼有情从畜生殁得生人趣。入母胎中出生世间。当有是相。为人闇钝懒惰多睡。乐食泥土咀嚼草木。与愚痴人共为交友。常处黑暗及泥涂中。或坐或立足指掘地。头多臭气蝇虫[口*(一/巾)]食。动摇无时不能暂止。常苦饥渴。或得微劣不净饮食。便生喜足。多为谄诈虚说见闻。或于梦中身堕粪秽。或于田野啖其水草。或梦山谷丛林之中。为彼大蟒缠绕于身。受大惊怖无救护者。外道。是为从畜生来有是余习。设经一劫说不能尽。智者了知愚夫不解

佛言外道。若彼有情从鬼趣殁得生人趣。入母胎中出生世间。当有是相。其发黄赤怒目直视。常苦饥渴性唯悭嫉。多希财利心无止足。若见他财为己有想。于他好物思欲窃取不净残食食而无耻。见他所有园林花果。多欲摘取而损坏之。外道。是为从鬼趣来有是余习。智者了知愚夫不解

佛言外道。若彼有情从修罗殁得生人趣。入母胎中出生世间。当有是相。常怀忿怒我慢高心。乐为诤竞结怨不舍。勇健多力喜于斗战。多恃唇吻陵蔑于他。亦有智力及无明力。攻破他论以自活命。外道。是为从修罗来有是余习。智者所知愚夫不解

佛言外道。若彼有情从人趣殁复生人趣。入母胎中出生世间。当有是相。是人质直乐近贤善弃远恶人。笃信守节顾惜善名。性乐工巧。常怀愧耻乐行惠施。于善人所心无违逆。先观后作。言无疏谬。善能机辩通致使命。所有教敕忆持不忘。于处非处而能拣择。外道。是为从人趣来有是余习。智者所知愚夫不解。

佛言外道。若彼有情从天界殁得生人趣。入母胎中出生世间。当有是相。为人端正常好洁净。喜服华鬘薰香涂香。沐浴其身厌于尘垢。于彼五欲歌舞音乐。唯择上妙而不淫泆。常与善人共为交契。好登楼阁华丽堂宇。性唯慈忍令他喜悦。常以上服璎珞严身。进止威仪心无懈惰。外道。是为从天中来有是余习。智者所知愚夫不解

佛言外道。若善男子善女人。于善知识亲近恭敬供养礼拜。乐闻正法如理作意。即得超越如向所说诸恶色相

外道当知。若地狱来生人间者。以其先因多造嗔业损害有情。堕在地狱受诸苦恼。今得为人尚怀嗔恼。遇善知识为说对治相应善法。令起慈心。渐令修习戒波罗蜜

外道当知。若畜生来生人间者。以其先因积集愚痴数数造作彼不净行。今得为人尚多淫泆。遇善知识为说十二缘生观行。对治无明。令生觉悟发生净慧。渐令修习般若波罗蜜

外道当知。若鬼趣来生人间者。彼由先因悭贪嫉妒长时造作而无间断。今得人身性多鄙吝。遇善知识为说布施相应善法。对治彼悭。渐令修习施波罗蜜。外道当知。若阿修罗中来生人间者。彼先造作广大福行。常生我慢陵蔑他人。今生人中性多高举。遇善知识为说六处及空法门。对治我慢。渐令修习忍波罗蜜

外道当知。若人趣中来生人间者。由彼先修十善业道惯习力故。乐近善友柔和共住。观察正理悟无常法。厌生死苦忻真常乐。渐次修习六波罗蜜。能发无上菩提道意。当得如来一切种智

外道当知。若天趣中来生人间者。是人前身所修施戒。不能忘相皆希果报。以是缘故得生天上。久受天乐退生人世。为由宿昔福慧力故。念已先业必从天堕。而于此身勤加精进。劝行布施不应希报。若住相者则为过患。应住无相得福无量。劝持净戒不应希报。若取相者则为瑕垢。应当纯净离诸染污。如是持戒得福无量。于佛菩提得不退转

复次外道。从地狱出得生人趣者。是人应当近善知识。乐闻三世佛所说法。住阿兰若专修梵行。精勤习学心无疲懈。巧于问难分别义趣。了一切法无有自性。由解法故乐为他说。或于聚落城邑之中。化诸比丘及比丘尼诸优婆塞优婆夷等。讲宣正法。能令自他断恶修善。渐次修习得无上道

复次外道。从畜生脱得生人趣。彼应亲近善友良缘。得闻正法舍离愚痴。由善友力多闻熏习。观诸法空离诸缠缚。而于自身作非有想。于大众中心无所畏。自然证得平等法性。了一切法本无自性。速能获得一切种智

复次外道。从饿鬼脱得生人趣者。彼应依止善友知识。初习布施除其悭贪。由行施故发生善慧。乐求出离修清净行。于所修福而不取着。了知三世诸法平等。皆唯一相所谓无相。渐次修习得一切智

复次外道。从修罗中来生人趣者。应先发心依善知识。与烦恼魔共为斗战。烦恼魔者。所谓我慢。应当思惟。何者是慢。谁起此慢谁受此慢。亦不见有舍此慢者。如是作意思惟观察。我慢之相了不可得。自诳己身都无实性。则能了达诸法无性。若法自性不有彼则非物。若非物者则不可成办。若非成办彼则不生不灭。若无生灭则不可分别。若无分别则无过去未来现在。若三际不可得。当知彼法不可破坏。佛言外道。如是法性无变无异体即真如。名为如来。应知我相实不可得。由起我慢生修罗中。或人或天流转诸趣。是故观察我慢之相。本无体性自他平等。断除余习心得清净。外道。此名舍离我慢善巧方便波罗蜜多。汝于是中当勤修学。时彼会中六万外道。闻说此法得无生忍。从座而起顶礼佛足。一心合掌说偈赞佛

  世尊智力无与等　　能了众生所行行
  亦知诸法所归趣　　如观掌中庵罗果
  观彼世间诸恶业　　犹如云雾蔽虚空
  愚夫不了镇沉沦　　亦如盲者失正道
  有说世间为无常　　或言世间非无常
  又云非常非不常　　譬如狂象为拘缚
  有说世间无有边　　或言世间非无边
  又云非边非无边　　如彼飞禽被笼罩
  有说即身执为我　　或言离身别有我
  此皆妄见之所迷　　如兽触网心生恼
  有说大自在天化　　亦云非因之所生
  如是恶见覆有情　　如云翳彼水中月
  犹如笼中所拘鸟　　眼视笼窍欲求出
  当知外道愚痴人　　彼无解脱亦如是
  或有归依大梵天　　那罗延天多闻天
  如人处暗为贼侵　　彼无解脱常生怖
  外道愚夫着邪见　　心求出离无所依
  如囚拘系于狱中　　当如贫餧而求丐
  若能舍邪修正行　　如来于彼起慈心
  速令免离于轮回　　如王赦宥蠲诸咎
  如来备修诸苦行　　始证最上佛菩提
  为度愚疑邪见人　　皆悉解脱无明缚
  人中师子二足尊　　于诸法中得自在
  愍彼沉沦苦海中　　以方便力而拔济
  若蒙如来大智力　　消伏魔怨无有余
  愿我当得如世尊　　于大众中师子吼
  如来能动三千界　　放无量光普照明
  成熟一切诸有情　　唯愿与授菩提记

尔时世尊知诸外道深心信解。口放净光。时尊者马。胜以偈问曰

  如来威德无与等　　令诸外道生信心
  今于天人大众人　　放大光明叵思议
  睹佛净光从口出　　犹如秋空月满时
  诸天及人咸有疑　　愿闻佛光所因起
  何人于佛伸妙供　　何人称悦如来心
  何人住佛功德中　　感得如来现斯瑞
  外道今闻授佛记　　一切众生亦发心
  如来出现于世间　　为摄受彼令调伏
  善哉牟尼大圣主　　能断一切诸疑惑
  今此众会咸乐闻　　于佛法中生爱乐

尔时世尊为马胜比丘说伽陀曰

  马胜比丘汝当知　　今正是时发斯问
  为欲利乐诸有情　　请益如来放光事
  我今为汝分别说　　应当谛听无异思
  如来所作非无因　　宣生忻庆住正念
  此诸外道悉调伏　　舍于邪见得正见
  由入正法起对治　　故能安住菩提道
  了知无垢寂静法　　而于见取心厌离
  从佛闻斯授记音　　决定自知当作佛
  已曾往昔修正行　　得值二十俱胝佛
  供养承事不疲劳　　为求无上菩提故
  广行惠施心无吝　　坚持净戒住忍力
  精勤修习总持门　　依三摩地发净慧
  具足六度诸功德　　念念增进无退转
  摧诸异论舍邪宗　　百千问难善分别
  昔由习近恶知识　　依止群邪异见中
  得遇如来大导师　　顿弃所修邪教行
  于彼未来星宿劫　　皆当作佛同一名
  各各出现于世间　　号曰普遍胜名称
  其佛国土极严净　　种种珍宝妙庄严
  得离邪见诸众生　　同依佛教生明慧
  彼土无有三恶道　　及以八难所逼恼
  诸佛寿命极延长　　等同八万四千岁
  若人闻此佛名者　　悉能舍离于贪欲
  女人得转丈夫形　　斯由闻佛功德力
  如来善伏魔怨者　　与诸外道授佛记
  闻已咸生欢喜心　　皆当成就一切智

父子合集经卷第十五父子合集经卷第十六

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    六界差别品第二十六之一

尔时净饭王并诸营从眷属等。见诸阿修罗王乃至外道婆罗门蒙佛授记。发希有心叹未曾有。世尊言音美妙清彻。一切世间闻者忻悦。时净饭王始见如来。以爱恋故情意殷勤。尔时世尊知彼父王心之所念。而告之曰大王。我所说法初中后善其义巧妙。清净一相梵行圆满。今正说者。所谓分别六界差别分位法门。王当谛听善思念之。时净饭王即白佛言。善哉世尊。愿乐欲闻。为我宣说忆持信受。佛言大王。如是六界六触处。十八意所伺察。是补噜沙为缘得生。云何六界。所谓地界水界火界风界空界识界。云何六触处。谓眼触处而见于色。若耳触处得闻其声。若鼻触处能嗅于香。若舌触处悉尝于味。若身触处亲觉其触。若意触处则知于法。云何十八意所伺察。谓眼见色已若生适悦。若生忧恼。若住于舍。如是六根各各缘彼适悦等三。是名十八意所伺察。大王。云何为内地界。谓于内身所生硬涩。发毛爪齿皮肉筋骨。若内地界不生亦无有灭。则无集行。大王。若时女人。而于内心如所思惟彼补噜沙。彼补噜沙亦生爱乐。由二和合羯逻蓝生。又复思惟相似和合。而得生者无有是处。若二女人无有是处。二补噜沙亦无是处。若彼彼思惟而得生者亦无是处。自体无实非相应故。云何说此为坚硬性。大王。此坚硬性相似而立。毕竟此身溃烂散灭。唯冢圹中是所归趣。彼坚硬性从何所来。亦非四方上下而去。大王。此内地界应如是知

大王云何外地界坚硬性者。如彼世间初建梵王所居宫殿。大宝所成。复生他化自在诸天所居宫殿。皆七宝成。大王。若无地界。彼坚硬性从何所生。复成大地厚八万四千踰缮那。纵广六万踰缮那。复生轮围大轮围山。坚固安住同一金刚。复生苏弥卢山。庾健陀山。[寧*頁]泯陀山。伊舍陀山乃至黑山。如是三千大千世界。次第成已坚固安住。若无地界。彼坚硬性从何所来。大王。又此地界欲坏灭时。或为火焚或为水漂或为风吹。譬然酥油其焰炽盛。乃至灰烬不复可见。若为水漂犹如以盐投于水中须臾消散。若为毗岚猛风所吹。彼时三千大千世界悉皆散坏。净尽无余。大王。此外地界生时本空灭时亦空。自性空故。无有男相亦无女相。但唯言说之所显示。如是地界与地界性皆不可得。唯佛正慧而能了知

大王。云何内水界。谓此身内所有执受湿润等性。涎唾脂髓脓血便利。为内水界。大王。若时忽见亲爱人等。眼中流泪。或为苦恼所逼流泪。或闻深法信重流泪。或为寒风所吹流泪。如是水界从何所来。水相干时复何所去。乃至此界坏时。兴大黑云三十二重。遍覆三千大千世界。降霔洪雨点大如象。昼夜倾注相续不绝。如是时分经五十劫。其水积满上至梵世。大王。此外水界从何所来。又此世界将欲坏时有二日出。二日出已。小河泉流悉皆枯涸。三日出时。无热恼池所出四河亦皆干竭。四日出时。大海水减一踰缮那。或二或三渐次减至十踰缮那或二十踰缮那。次第枯竭至八十踰缮那。有余水在。或深至一多罗树。或深至胸臆。或深至牛迹。乃至少水如指面量。当尔之时。大海水中悉皆干燥净尽无余。大王。此水界相。生无所来灭无所去。生时本空灭时亦空。自性空故。无有男相亦无女相。但唯言说之所显示。如是水界与水界性皆不可得。唯佛正智而能了知

大王。云何身内火界。若此身中所有执受温暖蒸热咀嚼饮食成熟变坏便令安和。入热数者名为火界。云何外火界。谓不执受温热相生。若复有人于旷野中寻求火缘。或以蒿艾或牛粪屑或兜罗绵引火生已。或烧草木山林聚落。及余方处皆为所烧。大王。此火界性。生无所来灭无所去。生时本空灭时亦空。自性空故。但唯言说之所显示。如是火界与火界性皆不可得。唯佛正智而能了知

大王。云何身内风界轻动等相。谓此内风或时上行或时下行。或住腹间或胁或背。或发瘾胗或聚成块。或如刀裂或如针刺。出入息等遍满身支。云何外风界。谓若此风从四方来。或狂暴起摧折树木堕裂山峰。若微细起飘举身衣动多罗树。名外风界。大王。此风界相。生无所来灭无所去。生时本空灭时亦空。自性空故。无有男相亦无女相。但唯言说之所显示。如是风界与风界性皆不可得。唯佛正智而能了知

大王。云何内空界。若此身内皮肉血等。显现增长离质碍性。谓若眼窍耳穴面门咽喉。咽啖饮食所引滋味。于肠胃间通彻而出。若时业缘引生六处。诸处生已围绕空界。此说名入内空界数。然彼空界从何所来。又若方处外所显现离质碍性名外空界。大王。若色变坏一切皆空。所以者何。是虚空界本无尽故。安静不动犹如涅盘。遍一切处无有障碍。大王。譬如有人于彼高原穿凿池井。于意云何。是池井中所有空相从何所来。王曰。无所从来。佛言大王。设使彼人复填以土。于意云何。空何所去。王曰。空无所去。所以者何。是虚空界无去来故。不住男相亦非女相。大王。外虚空界本来无动。自性离故。但唯言说之所显示。除佛正慧而能了知

大王。云何识界。谓若眼根为主。缘彼形色及彼表色。名眼识界。若余五根缘于自境各别建立。名五识界。又此识界。不着于根不住于境。非内非外及二中间。然此识界。各各了别彼彼境已即便灭谢。生无所来灭无所去。大王。识生时空灭时亦空。自性离故。不住男相亦非女相。但唯言说之所显示。如是识界与识界性皆不可得。如佛正慧而能了知

大王。云何眼处。谓四大种。地界水界火界风界所造净色。若地界清净则眼处清净。若水火风界清净则眼处清净。何以故。由地界清净眼处得生。是中无有少法可得。如是乃至风界清净眼处得生。是中无有少法可得。何以故。无主宰故。无造作故。犹如涅盘自性清净。大王。如是眼处各各寻求皆不可得。所以者何。地界空故则地界清净。乃至风界空故则风界清净。若诸法自性本空。则彼界何有清净。亦无忿诤。若净若诤皆不可得。复有何色而可见耶。当知眼处毕竟空故自性亦空。前际后际皆不可得。未来所造亦不可得。何以故。自性离故。若自性无有。则无男相亦无女相何有爱乐。若生爱乐是魔境界。若无爱乐是佛境界。何以故。若无爱乐则能远离一切诸法

大王。云何耳处。谓四大种所造净色。分别行相如前所说。大王。诸法解脱决定现前。如法界空不可施设。大王。诸根各各乐着境界。眼缘色时而生爱乐。是故说色为眼境界。又此眼根缘于色境。有三种相。见可爱色起于贪想。不可爱色起于嗔想。非爱非恶而起舍想。如是乃至意着法处为意境界。若彼意处缘可爱色极生爱乐。为彼所牵引生贪行。不可爱色生于嗔行。爱非爱色起于痴行。如是声等三种攀缘领纳等相。准前应说

大王。诸根如幻境界如梦。譬如有人于梦寐中与诸婇女共相娱乐。大王。于意云何。彼梦觉已忆所受乐。为实有不。王曰不也。佛言大王。是人所梦执以为实。为智者不。不也世尊。何以故。梦中婇女毕竟非有。何况与之共相娱乐。当知是人忆梦中境。徒自疲劳不复可得。佛言大王。如是如是。愚痴众生眼见色已。心生爱乐复起贪着。为彼所牵造贪业行。身业三种语业四种意业三种。最初造作刹那灭谢。是业不依东西南北四维上下中间而住。于死边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱或堕傍生。琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭各为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空。若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。譬若有人于睡梦中。与诸冤对共相斗战。于意云何。是人觉已。忆念梦中斗战等事。为实有不。王曰不也。佛言大王。是人所梦执以为实。为智者不。王曰不也。世尊。何以故。梦中毕竟无有冤对。何况与之共相斗战。当知是人徒自忧恼都无有实。佛言大王。如是如是。愚痴异生眼见恶色。即生于恼厌离破坏。毁呰过失造嗔业行。身业三种语业四种意业三种。最初造作刹那灭谢。是业不依东西南北。四维上下中间而住。于死边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来灭无所去。彼业生时无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空自业自业空初识初识空若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。譬若有人于睡梦中为毕舍遮之所娆害。心生怖畏痴迷闷绝。大王。于意云何。是人觉已忆念梦中为鬼所娆。为实尔不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无鬼所恼。何更说有痴迷闷绝。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生眼见是色。迷惑不了造痴业行。身业三种语业四种意业三种。最初造作刹那灭谢。是业灭已。不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来。灭无所去。彼业生时无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空自业自业空初识初识空若灭灭空若生生空。了知业转无有作者。亦无受者。但唯名相分别显示

大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相名无相解脱门。若无有相即无愿求。名无愿解脱门。如是三法与空共行。涅盘先道当如是学

父子合集经卷第十六父子合集经卷第十七

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    六界差别品第二十六之二

佛言天王。譬如有人于睡梦中。闻妙乐声心生适悦。是人觉已忆念梦中美妙音乐。是实有不。王曰不也。佛言大王。于意云何。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无有乐声。何况复有生适悦耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生闻可意声起于爱乐。而生染着造作恶行。身三语四意业三种。作是业已刹那灭谢。是业灭已。不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生。琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来灭无所去。彼业生时无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空自业自业空初识初识空若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。耳闻恶声则生忧恼。如人梦中亲爱别离悲号啼哭生大苦恼。于意云何。是人觉已忆梦中事。是实有不。王曰不也。佛言大王。是人所梦执以为实。为智者不。王曰。不也世尊。何以故。梦中亲爱毕竟无有。何况复有别离事耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生闻其恶声则生忧恼。起于嗔心造作嗔业。所谓身三语四意业三种。造彼业已刹那灭谢。是业灭已。不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来灭无所去。彼业生时无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空自业自业空初识初识空若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。耳闻舍声起于舍想。如人梦中闻他宣说不了义句。于意云何。是人觉已忆念梦中所闻之声。为实有不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无有音声。何况更有不了义句。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生耳闻舍声不达义趣。轻慢毁呰造作痴业。身三语四意三种业。最初造作即便灭谢。是业灭已不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉忆梦中闻不了义句。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来灭无所去。彼业生时无所从来灭无所去。初识生时无所从来灭无所去。何以故。自性离故。如是了知身识身识空自业自业空初识初识空若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相名无相解脱门。若无有相则无愿求。名无愿解脱门。如是三法与空共行。涅盘先道决定如法界周遍虚空际。于此譬喻当如是知

大王。譬如有人于睡梦中。以旃檀香或多摩罗叶香及余香等而以涂身。于意云何。是人觉已忆念梦中所涂之香。是实有不。王曰不也。佛言大王。是人所梦执以为实。为智者不。王曰。不也世尊。何以故。梦中毕竟无有诸香。何况复有以涂身耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生初闻妙香便生爱乐。心起染着造如是业。身三语四意三种业。造彼业已即便灭谢。是业灭已。不依四方四维上下中间而住。乃至最后识灭自业现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生起各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。如人梦中见以死蛇死狗人尸。系己颈上心生怖畏。于意云何。是人觉已忆念所见。为实有不。王曰不也。佛言大王是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无死蛇等。何更复有系之颈耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生见是臭恶。嗔恚毁呰造作是业。身三语四意三种业。造是业已刹那灭谢。是业不依东西南北四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗果及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。譬如有人于睡梦中为彼非人断其鼻根于意云何。是人觉已忆念梦中鼻根断坏。是实有不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故梦中毕竟无有鼻根。何更说有被断坏耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生见鼻根坏。起恐怖想造作痴业。身三语四意三种业。最初造作刹那灭谢。是业灭已。不依四方四维上下中间而住。最后边际命根灭尽。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无有相则无愿求。名无愿解脱门。如是三法。与空共行涅盘先道。决定如法界。周遍虚空际。于此譬喻当如是知

大王。譬若有人于睡梦中为彼饥渴之所逼切。遇诸美馔随意而食。于意云何。是人觉已忆念美馔。为实有不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无彼美膳。况得食耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生见美食已。心生爱着起于贪行。身三语四意三种业。最初造作刹那灭谢。是业灭已。不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。如人梦中为饥所逼。得其苦瓠并拘赊怛计子。毕租摩哩捺子。而便食之心生恚恨。于意云何。是人觉已。忆其梦中食苦瓠等。为实有不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无苦瓠等。况复食耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚夫异生梦为饥逼啖其苦味。心生恚恼造是业行。身三语四意三种行。造彼业已即便灭谢。是业灭已。不依东方南西北方四维上下中间而住。最后边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王识为其主业为攀缘。二种相因初识生起或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王。如人梦中舌根断坏。于意云何。是人觉已。忆念梦中。是为实不。王曰不也。佛言大王。是人所梦执以为实。是智者不。王曰。不也世尊。何以故。梦中毕竟无有舌根。况复断坏。当知是人徒自疲劳都无有实佛言。大王。如是如是。愚夫异生见舌坏已。心生恚恼造是业行。身三语四意三种业。造彼业已刹那灭谢。是业不依四方四维上下而住。最后边际命根灭谢。自分业报皆悉现前。如梦觉已念梦中事。大王。识为其主业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空若生生空。了知业转无有作者亦无受者。但唯名相分别显示

大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无有相则无愿求。名无愿解脱门。如是三法。与空共行涅盘先道。决定如法界。周遍虚空际。于此譬喻。当如是知

父子合集经卷第十七父子合集经卷第十八

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    六界差别品第二十六之三

佛言大王。譬若有人于睡梦中与诸宝媛共相执持。是人觉已。忆念梦中所受妙触。为实尔不。王言不也。佛言大王。于意云何。是人所梦执以为实。是智者不。王言。不也世尊。何以故。梦中毕竟无有宝媛。况复有彼美妙触耶。当知是人徒自疲劳都无所得。佛言大王。如是如是。愚痴异生寡闻无智。于可意触而生爱乐。心生染着造如是业。身业三种语业四种意业三种。造作彼业刹那迁谢。是业灭已。不依东方南西北方四维上下中间而住。至命终时。见先所作心想中现。如彼睡觉忆梦中事。最后识灭自业现前。大王。识为其主业为攀缘。二种相因初识生起。作业受报。皆不失坏。或趣地狱或堕傍生琰摩罗界及阿修罗若人若天。同分种类相续不绝。大王。最后识灭名为死蕴。最初识起名为生蕴。大王。彼识起时。无所从来灭无所至。其缘生时。无所从来灭无所至。彼业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。无有作者亦无受者。但随世俗之所显示。非第一义作是说也。大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相名无相解脱门。若无相者则无希求。名无愿解脱门。若能了此三解脱门。与空共行菩提先道。广大如法性。究竟如虚空。于此譬喻。当如是知

复次大王。譬如有人于睡梦中。持热铜鍱以为衣服而自缠身。是人觉已。忆念梦中炽然铜鍱触身苦恼。为实尔不。王言不也。佛言大王。于意云何。是人所梦执为真实。是智者不。王言。不也世尊。何以故。梦中毕竟无热铜鍱。况复触身受苦恼耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚痴寡闻凡夫异生。见恐畏事心生嫌恶。妄生执着造是恶业。身业三种语业四种意业三种。造作彼业刹那迁谢。是业灭已。不依东方南西北方四维上下中间而住。至命终时。见昔所作心生恐惧。如彼睡觉念梦中事。最后识灭自业现前。大王。识为其主业为攀缘。二种相因初识生起。作业受果皆不失坏。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续而转。最后识灭名为死蕴。最初识起名为生蕴。大王。彼识起时。无所从来灭无所至。彼缘生时。无所从来灭无所至。彼业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。了知业报自性非有。无有作者亦无受者。但唯名相分别显示。大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无相者则无希求。名无愿解脱门。若能了知三解脱门。与空共行菩提先道。广大如法界。究竟如虚空。于此譬喻。当如是知

复次大王。如人梦中自见其身悉皆散坏不觉诸触。是人觉已。忆念梦中身根散坏而生忧恼。为实尔不。王言不也。佛言大王。于意云何。是人所梦执以为实。是智者不。王言。不也世尊。何以故。梦中毕竟无有身根。况复散坏。当知是人徒自疲劳都无有实。佛言。如是如是。愚痴寡闻凡夫异生。自见身坏心生执着。复起恐怖造是痴业。身业三种语业四种意业三种。造作彼业刹那迁谢。是业灭已。不依东方南西北方四维上下中间而住。至命终时。见先所作心生惶怖。如彼梦觉念梦中事。最后识灭自业现前。大王。识为其主业为攀缘。二种相因初识生起。作业受果皆不失坏。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。初识起时无所从来灭无所至。彼缘生时。无所从来灭无所至。其业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。了知业报自性非有。无有作者亦无受者。但唯名相分别显示。大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无相者则无希求。名无愿解脱门。若能了此三解脱门。与空共行菩提先道。广大如法界。究竟如虚空。于此譬喻当如是知。复次大王。如人梦中见彼幻师幻作五欲种种欲乐。自见其身为彼围绕受诸快乐。是人觉已忆念梦中所作事业。为实尔不。王言不也。佛言大王。于意云何。彼于梦境执以为实。是智者不。王言。不也世尊。何以故。梦中毕竟无彼幻师。况复变现五欲等事。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚痴寡闻凡夫异生意着于法心生贪染。复起追求转增痴爱。为彼所牵造如是罪。身业三种语业四种意业三种。造作彼业刹那迁谢。彼业灭已。不依东方南西北方四维上下中间而住。至命终时。见昔所作心想中现。自分业报皆悉现前。犹如梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。作业受报皆不失坏。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。身识生时。无所从来灭无所至。彼缘生时。无所从来灭无所至。彼业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。作业不可得。受报不可得。但唯名相分别显示。大王当知。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无相者则无希求。名无愿解脱门。依此了知三解脱门。与空共行菩提先道。广大如法界。究竟如虚空。于此譬喻。当如是知。复次大王。譬如有人于睡梦中。为彼瀑流漂没己身及其眷属。受诸惶怖种种苦恼。是人觉已。忆念梦中水所漂溺。为实尔不。王言不也。佛言大王。是人所梦执以为实。是智者不。王言。不也世尊。何以故。梦中毕竟无水所漂。况复有彼惶怖苦恼。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚痴寡闻凡夫异生。意着诸法生忧恼处。展转寻求无对治道。以不了故起诸恶行。身业三种语业四种意业三种。造作彼业刹那迁谢。是业灭已。不依东方南西北方四维上下中间而住。至命终时心生惶怖。见昔所作悉现其前。如人梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。作业受果皆不失坏。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。初识生已各受其报。同分心品相续不绝。最后识灭名为死蕴。最初识起名为生蕴。大王。初识生时。无所从来灭无所至。彼缘生时。无所从来灭无所至。彼业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。无有作者亦无受者。但唯名相分别显示。大王。诸根如幻境界如梦。一切诸法皆悉空寂。此名空解脱门。空无空相。名无相解脱门。若无相者则无希求。名无愿解脱门。若能了此三解脱门。与空共行菩提先道。广大如法界究竟如虚空。于此譬喻。当如是知

复次大王。譬如有人于睡梦中。自见其身饮酒惛醉。不识善法及诸恶行。功德过失都不觉知。是人觉已念梦中事。为实尔不。王言不也。佛言大王。于意云何。是人所梦执为真实。是智者不。王言。不也世尊。何以故。梦中毕竟无饮酒者。况惛醉耶。当知是人徒自疲劳都无有实。佛言大王。如是如是。愚痴寡闻凡夫异生。意着诸法。起爱染心造是痴业。身业三种语业四种意业三种。造作彼业刹那迁谢。是业灭已。不依东方南西北方四维上下中间而住。至命终时。见先所作自分业报心想中现。如人梦觉念梦中事。大王。识为其主业为攀缘。二种相因初识生起。作业受报皆不失坏。或趣地狱。或堕傍生琰摩罗界及阿修罗若人若天。各受其报。同类心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王。身识生时。无所从来灭无所至。彼缘生时。无所从来灭无所至。彼业生时。无所从来灭无所至。大王。无有少法从于此世得至他世。何以故。自性空故。如是了知初识初识空。自业自业空。身识身识空。若灭灭空若生生空。轮回轮回空。涅槃涅槃皆自性空。无有作者亦无受者。若业若报皆不可得。但唯名相分别显示。大王。诸根如幻境界如梦。一切诸法自性空寂。此名空解脱门。空无空相。名无相解脱门。若无相者则无希求。名无愿解脱门。若能了知三解脱门。与空共行菩提先道。广大如法界。究竟如虚空。于此譬喻。当如是知

父子合集经卷第十八父子合集经卷第十九

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净饭王信解品第二十七

尔时世尊。告净饭王言。大王。如上所说解脱法门。当自系心正念观察。勇猛精进决定修作。过去未来现在诸佛。依此得证无上菩提。能招世间一切富乐。能消世间一切渴爱。能伏世间一切我慢。能破世间一切邪见。能灭有情一切罪恶。未登初地凡夫异生。皆令证得平等法性。如是法要。非诸声闻及辟支佛所行境界。唯诸菩萨之所修作。大王。应作是念。我当云何于人天中得为眼目。于长夜中得为照明。于爱河中得为船筏。于险难处得为导师。无依怙者为作主宰。自得度已复能度他。自解脱已令他解脱。自得安隐令他安隐。自证涅槃复令他证。大王。不应观彼现在世间所受富乐五欲自在。诸根如幻境界如梦。谓于色境声香味触。心生贪着无满足时。大王。乃往过去无量俱胝那由他劫。有转轮王名无边称。富贵自在有大威德。象马车乘众宝辇舆。最胜轮宝无能坏者。已曾亲近无量诸佛。于彼佛所种多善根。随意所念皆得成就。大王。彼无边称王忽于一时。作是思惟。我当自试福德之力。以我福故。令四天下所有一切树木花果。皆得茂盛受用无尽。作是念已。彼四天下所有花果而得敷荣。大王。彼无边称王如是思惟。我今更试自善根力。令四天下一切人民。若有所愿随意无违。作是念已。彼四天下所有人民。一切希求皆得如意。大王。彼无边称王复更思惟。以我所有善根之力。令四天下降注香水。作是念已。于四天下普雨香水。大王。彼无边称王复更思惟。以我所有善根力故。令四天下普雨妙花。作是念已。于四天下降雨种种上妙天花。大王。彼无边称王复更思惟。以我所有善根力故。令四天下雨妙宝衣。作是念已。于四天下悉雨宝衣。大王。彼无边称王复更思惟。以我所有善根力故。令四天下悉皆雨银。作是念已。于四天下皆得雨银。大王。彼无边称王复更思惟。以我所有善根力故。令四天下降雨黄金。作是念已。于四天下皆雨黄金。所以者何。皆由无边称王于往昔时与诸众生。共修善业之所获得。大王。此阎浮提大地纵广一万八千踰缮那量。复有六十俱胝诸大城郭。中有一城名宝庄严。纵广正等十二踰缮那。四面平正妙巧成就。于其城外有多罗树。七重行列四宝所成。金银琉璃玻胝迦宝。装校严饰甚可爱乐。彼金树者。其叶花果悉皆是银。彼银树者。其叶花果皆是黄金。吠琉璃树。其叶花果皆玻胝迦。彼玻璃树。其叶花果悉是琉璃。其城七重宝网宝铃诸妙珍琦弥覆其上。城外复有七重宝堑。皆以七宝所共合成。一一宝堑。深半由旬广一由旬。金沙布底。八功德水澄湛盈满。诸妙音鸟翔集其中。优钵罗花拘没那花。钵讷摩花。分陀利花。普遍开发。周匝阶陛四宝合成。黄金为阶白银成陛。白银为阶黄金成陛。琉璃为阶玻璃成陛。玻璃为阶琉璃成陛。一一阶道七宝所成。其傍皆植金色芭蕉。复于道首置诸宝座。巧妙装校甚可爱乐。如是富乐种种严饰。皆是无边称王积集广大善根福力之所获得。又彼宝庄严城。周匝复有八万四千清净园林。一一园中有八大池。其池各广半踰缮那。一一池岸有四阶陛。四宝所成巧妙严饰。八功德水充满其中。众色莲华开敷弥布。于其池岸复有诸花。阿提目葛多花。詹博迦花。嚩始计花。苏曼那花。阿输迦花。婆师迦花。如是种种诸妙香花。无边称王与诸臣民。止住园中共为游乐。大王。彼王宫城高广严好。宝多罗树行植于上。宝网周遍宝铃和鸣出妙音响。如五乐声。时彼人民赖王德化。富乐自在安隐而住。大王。彼无边称王复于异时。如是思惟。我今应往东胜身洲。作是念已。王领四兵俱乘虚空即至其处。彼诸小王皆来奉迎。各以国土虔诚致献。王于彼住百千万岁。大王。彼无边称王复自思惟。我今当往西牛货洲。作是念已。领四兵众俱乘虚空即至其所。彼诸小王皆来奉迎。各以国土虔诚致献。王于彼住百千万岁。大王。彼无边称王复自思惟。我今当往北俱卢洲。作是念已。领四兵众俱乘虚空即至其所。彼诸人民欢喜归化。王于彼住百千万岁。大王。彼无边称王复自思惟。我昔闻有三十三天住须弥顶。我今当往。作是念已。即乘龙象与四兵众。飞腾空中上须弥顶。时无边称王问御臣曰。汝见须弥及以大海并四天下。其事云何。御臣答言。我见其相旋转不定如陶家轮。王语御臣。汝所见者。此龙象王大行未止。王复前进。问御臣曰。见须弥等其相云何。御臣答言。我今见彼须弥大海皆悉震动。王语臣曰。今将至于须弥山顶。此龙象王小行未止。王复前进问御臣曰。见须弥等其相云何。御臣答言。我今见彼须弥大海不动不转。王语臣曰。此龙象王。今已到彼须弥山顶。时无边称王及四兵众到须弥已。彼帝释天主。即时遥见无边称王欢喜来迎而作是言。善来大王。即分半座命王而坐。时无边称王即就其座。住于天上经无量岁。与彼天主分半同治。在彼时久作是思惟。可退彼天我独为主。作是念已。王及兵众即时退堕宝庄严城宝箧园中。时守园者见是事已。告城中人作是唱言。今有天人退没于此。时彼国王名曰作爱。闻是说已。速严驾驭诣彼园中。见如上事怪未曾有。即敕排备种种香花末香涂香。诣彼王所偏袒右肩右膝着地。长跪合掌安慰问讯。白彼王言。圣天至此为当是谁。彼即答曰。汝昔曾闻有转轮王名无边称不。作爱王言。我闻耆旧说。昔有王名无边称。威德自在领四天下。与四兵众乘空而上三十三天。汝所闻者岂异人乎。则我身是。时无边称王从天退已。初闻人间饮食气味不能堪任。犹如酥油沃热沙中。时作爱王见其顿弊不能止住。有何善说。我于来世作何宣传。时无边称王语作爱王曰。我从昔来富贵自在王四天下。一切所须皆得如意。升忉利天帝释分座。贪无厌故从天退下。如上众事当如是说。作是语已即便命终。佛言大王。往昔无边称王者。岂异人乎。今我身是。是故当知。诸根如幻境界如梦。系心正观勿生疑惑。尔时世尊而说偈言

  乐求正法财　　净心常质直
  五欲不坚牢　　智者当远离
  若于法明了　　则厌五欲乐
  彼善降其心　　能破诸烦恼
  由断烦恼故　　不受诸恶道
  离彼业道者　　为世所恭敬
  离贪欲染污　　开示欲过失
  心乐利群生　　称世间最胜
  闻五欲过患　　速能生厌离
  以智净其心　　处世无过上
  最胜大丈夫　　能灭众生恶
  令离彼贪行　　处世无过上
  最胜大丈夫　　能灭众生恶
  令离彼嗔行　　处世无过上
  最胜大丈夫　　能灭众生恶
  令离彼痴慢　　为清净智者

尔时世尊说是偈已。为净饭王复说法要。佛言大王。乃往过去无量世时。有转轮王名曰地生。善法治世七宝具足。所谓轮宝象宝马宝珠宝兵宝女宝主藏臣宝。王有太子名曰地天。绍继父王转轮王位。辅相大臣与王灌顶。为刹帝利灌顶圣王。于十五日月盛满时。澡沐首发洗浴身垢。着新净衣。以诸花鬘摩尼天冠种种璎珞。庄严其身。升高楼上采女围绕。即于东方有金轮宝。千辐具足毂辋圆满。光明照曜纵广七肘。时地天王睹是事已。我昔曾闻耆旧所说。若刹帝利受灌顶时有金轮现。如前所说。当知定作转轮圣王。我今应当自试验之。时地天王即从座起。偏袒右肩右膝着地。向轮合掌作如是言。此金轮宝当降于地。如是祷已依王前住。王以妙香上妙衣服。用拭轮宝置右掌中。而语轮曰。我今欲往东胜身洲。金轮乘空即至彼所。地天圣王出现之处。其地平正布诸宝花。以王威力地皆震动。井泉河池枯涸之处。八功德水悉皆盈满。所谓轻清甘滑不浊不臭。饮者无厌令腹无痛。一切林木华果敷荣。诸枯槁者复得滋茂。王所游处轮导其前。所至国土大小诸王。各以金槃盛满银粟。或以银槃盛满金粟。咸来奉迎安慰问讯。善来圣王。此土安隐唯愿居此治化人民。我等皆当给侍左右。王即语曰。我今不须国土珍宝。汝等应当随顺教诲远离杀生及不与取远离邪淫。亦莫妄语乃至邪见十不善业。汝等应当自住十善。亦教他人令住十善。孝养父母承事师长。莫作非法修行善行。亦劝他人勤行众善。时地天王与四兵众。从胜身洲过尽人境。渐度大海。至牛货洲及俱卢洲。宣王德化。悉降伏已。王及轮宝还阎浮提。于王宫门依空而住。时四天下变成七宝。所有一切三恶道苦。及八难处不善之声。悉皆消灭。况复有彼造恶业者。所以者何。皆由地天转轮圣王本愿力故。又彼轮宝于虚空中。往来旋转四天下时。处处皆生自然香稻。不假种植净无糠糩。又彼轮宝旋天下时。诸劫波树出天宝衣。一切有情受用如意。又彼轮宝旋天下时。诸有重病皆得痊愈。唯有三病。一者意乐。二者叚食。三者衰老。彼诸众生寿命千岁。设有微苦自然消殄。有如是等无量无边希有之事。俱时出现。时地天王。忽作是念。我今于此富贵自在。颇有余处而胜此耶复自思惟。我昔曾闻须弥山顶有三十三天快乐无比。今可诣彼。与四兵众即至彼所。时帝释天主。见地天王自远而来。即起奉迎善言问讯。分座令坐命王同治。时地天王经彼时久。欲退帝释独为天主。作是念已。王与兵众堕阎浮提末土罗城。彼地天王久居天宫受上妙乐。忽堕人世不能暂安。犹如酥油置热砂上。身心顿弊无所堪任。时地天王。而说偈言

  王者称自在　　不能断贪欲
  如火益干薪　　是故应远离
  如渴饮碱水　　转增其渴心
  当知着欲者　　无厌亦如是
  如众流入海　　曾无满足时
  当知着欲者　　无厌亦如是
  如镜照形容　　显现何曾定
  当知着色者　　无厌亦如是
  如闻空谷响　　应答无休息
  当知着声者　　无厌亦如是
  犹如盛香奁　　受薰未尝足
  当知着香者　　无厌亦如是
  如杓和美馔　　均布用无时
  当知着味者　　无厌亦如是
  如风行虚空　　转动曾无定
  当知着触者　　无厌亦如是
  如梦中饮水　　不能蠲渴想
  意着诸法者　　无厌亦如是
  若乐着诸欲　　贪火转炽然
  当以净智水　　灭之无有余

尔时地天转轮圣王说是偈已。寻即迁谢。佛言大王。地天王者岂异人乎。我身是也

父子合集经卷第十九父子合集经卷第二十

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    净饭王信解品第二十七之二

佛言大王。我今复说。往古世时有转轮王名曼达多。有大威势具大福德。从彼父王顶上而生。已于先世久修梵行。曾值无量百千俱胝那由他佛。于彼佛所植众德本。继嗣父王灌顶之位。统四天下豪富自在。于阎浮提出现治化。五欲娱乐殊胜第一。安隐丰饶人民炽盛。聚落城邑鸡飞相至。大地无有瓦砾荆棘。设有山阜多产金宝。园林泉池庄严国界。所都大城名阿瑜阇。其城东西十二由旬。南北修广各七由旬。宝网宝铃遍覆其上。王多眷属恭敬围绕。犹如帝释妙见大城。彼曼达多王造三时殿。一名月光。当热际时王居其中。二琉璃藏。于雨际时王居其中。三曰日光。于寒际时王居其中。若王入彼月光殿时。王与后妃采女眷属。前后围绕身得清凉。譬如牛头旃檀之香以涂其身。王体安和亦复如是。亦如帝释与诸天子在广胜殿受上妙乐。若雨际时。王与眷属入琉璃殿。譬如以彼多摩罗跋怛啰香以涂其身。王意适悦亦复如是。若寒际时。王与眷属入日光殿。如沉水香用涂其身。王体温暖亦复如是。大王。彼曼达多王随其时节。所至宫殿皆生乐触。或出凉风或降香雨。或奏伎乐。皆得如意。大王。彼曼达多王忽自宫内。七日之中雨诸金宝。满七日已王叹希有。清净福业感报若此。王住治化经无量岁。时曼达多王作是思惟。我闻西有大牛货洲。作是念已与四兵众上升虚空。从阎浮提渐至彼所。王到彼已受用最上饮食资具。国土人民安隐丰乐。于王宫内七日雨宝。与阎浮提等无有异。王于彼住百千万岁。时曼达多王复更思惟。我闻东有大胜身洲。作是念已。与四兵众上升虚空。从牛货洲渐至彼所。王到彼已受用美妙最上饮食。化治人民安隐丰乐。亦于宫内七日雨宝。与牛货洲等无有异。王住于彼经百千岁。大王。彼曼达多王复自思惟。我闻北有大俱卢洲。其中人民不生分别我我所想。今当往彼而试验之。作是念已。与四兵众俱乘虚空。从胜身洲即至其所。王到彼已。验其眷属乃知实尔。受上妙乐经无量岁。大王。彼曼达多王复更思惟。我曾闻有三十三天。在须弥顶各各安住。我今当往躬自观之。作是念已。与四兵众乘空而往。从俱卢洲即至其处。时彼天主与诸天子。集妙法堂论天中事。时帝释天主见曼达多王自远而来。即出迎之作如是言。善来大王远至于此。乃分半座命王同坐。曼达多王就彼坐时。有十种事。胜彼天主。一者寿命。二者容仪。三者名称。四者快乐。五者自在。六者端正。七者音声。八者身香。九者食味。十者细触。时曼达多王与彼天主。形色受用悉皆相似。唯目瞬动为其别也。而诸天子。以此辩知天主人王二种有异。佛言大王。曼达多王生于人间。与其天主形仪一等。殊胜福报未曾有也。住彼天中经无量岁。得为最胜自在天主。于四天下富乐独尊。帝释分治。心犹未足。时曼达多王忽于一时而起异意。我今自可独为天主。何须帝释。宜应退之。作是念已。王与四兵从天而堕于阎浮提阿瑜阇城最胜园中。当退没时。王之威光遍阎浮提普皆照曜。而能映夺日月光明。时彼人民出城游观。见是事已怪未曾有。即入城中而唱是言。今有天人并四兵众。从空退堕最胜园中。大王。尔时城中王及人民。即办种种涂香末香歌舞伎乐宝幢幡盖华鬘璎珞严身之具。速疾诣彼最胜园中。大王。彼曼达多王初堕人间地六震动。是时人民所有一切殊胜庄严最上妙香。各各持至最胜园中。用涂王身而为供养。时曼达多王久受天宫上妙快乐。不能堪任人中资具。譬若酥油置热砂上。身肢疲顿略无暂安。时城中王乃问之曰。天为是谁而堕于此。彼即告言。汝昔曾闻有转轮王名曼达多。王及人民咸皆答曰。曾闻有王名曼达多。有大威德统四天下。不离人趣。与四兵众。而能上升三十三天。时退堕天即告之曰。昔曼达多王者。我身是也。由无厌故而至于此。谁于福报而止足耶。时城中王及诸臣民。以偈问曰

  我闻耆旧说　　昔有转轮王
  名曰曼达多　　具广大威势
  与四兵眷属　　升三十三天
  教化诸天人　　为说于正法
  彼曼达多王　　舍天乐受苦
  无常力所加　　由心无足故
  人民皆合掌　　顶礼大王足
  王遗何善言　　未来我当说
  时曼达多王　　乃语众人曰
  我由着乐故　　从天而堕落
  有大威德力　　统领四天下
  受欲乐无足　　从天而堕落
  昔于自宫内　　七日雨珍宝
  受欲乐无足　　从天而堕落
  彼帝释天主　　分半座同治
  恶觉所恼乱　　从天而退堕
  于欲乐无厌　　不信受佛语
  破坏自福业　　流转轮回海
  世有大智者　　能离欲痴暗
  亦能教他人　　止足善观察
  若住正思惟　　随顺诸善法
  破坏轮回行　　及生老死厄
  观触如炽火　　观受亦复然
  如是善了知　　则于贪不起
  愚人着境界　　如闻音乐声
  了根境本空　　知法离自性
  六处不寂静　　唯遍计分别
  若了色等空　　则不生贪着
  智者善防护　　厌怖轮回苦
  慧眼常照明　　得离诸过患

佛言大王。尔时曼达多王岂异人乎。勿作异观。我身是也。由恃威德福力自在贪无厌故。而取终殁。是故大王。应舍豪富憍慢自在。安住净心莫生放逸。若离放逸利益自他。生诸善根住平等理。则能证入真如法性。大王当知。若有为界若无为界二种平等。非有男相亦非女相。亦非过去现在未来。当于此法安住自心。决定正观勿随他教。大王。往昔有王名曰昵弥。出现世间正法治化。心常寂静不生放逸。于彼彼处离放逸行。怖彼罪恶故不复作。大王。彼昵弥王志意坚固。常住观察三世平等。观彼过去一切诸法。住平等理本离自性。现在未来一切诸法离于自性。亦复如是。大王。彼昵弥王观三世法平等平等。不生取着。复观世间一切众生。为四颠倒之所惑着。于不净中而作净想。于逼迫中而生乐想。于无常中而起常想。于无我中而为我想。时昵弥王即作是念。世间愚夫深可悲愍。一切诸法自性空寂。痴妄所覆而不觉知。当设方便以四摄事。化诸有情令生信顺。即语彼言。汝当了知一切诸法本离自性。若法离自性者。当知彼法。即非过去现在未来。何以故。以一切法自性空故。若法自性空者。则不可分别说为过去现在未来。大王。彼昵弥王显示三世平等法已。是时众会百千俱胝那由他众生。闻法悟解得无生法忍。尔时三十三天诸天子等。集妙法堂共相议论。天眼遥见阎浮提中。有昵弥王十善治化。一切人民获得法利。善巧方便饶益众生。是时帝释天主在于余处。以净天耳闻如上说。时彼天主来会中坐。问诸天子。向说何事。彼即对曰。阎浮提人快得法利。有昵弥王深达诸法。善巧方便摄化众生。住颠倒者令离颠倒。前所论者乃此事耳。时彼天主谓天子曰。此昵弥王宿植德本。具足成就威神之力。汝欲见彼昵弥王不。诸天咸曰。我等愿见。是时帝释即敕御者名摩多黎。汝当严饰千辐宝车并诸营从诣阎浮提昵弥王所。作如是说。大王。此是帝释千辐宝车遣来迎王。唯愿乘此。勿生怖也。彼诸天子愿睹圣王。御者白言。王今升天。有二道往。为从颠倒众生道去。从不颠倒众生道去。王即报言汝可将我。于彼二道中间而去。时彼御者摩多黎言。随王教敕中道而进。王复告曰。汝可停车暂憩少时。我当观彼颠倒众生所住之处。时昵弥王以慈愿力。于须臾顷。令无量众生各各获得寂静神通游戏三摩地。及无生法忍。彼昵弥王。于此少时能成大利。所以者何。由彼积习不放逸行善巧方便利乐众生。时摩多黎渐次前进。复将王至须弥山顶。王初遥见林木青茂。谓御者曰。此中定是不颠倒众生所住之处。御者答曰。此林乃是三十三天。彼诸天子于妙法堂。一心瞻仰欲见大王。愿勿疑怖。当升此堂。时昵弥王容仪和悦身心不动。帝释遥见即起奉迎。善来大王。远屈威神无至疲极。乃分半座而奉彼王。共相慰问。王乃就坐。善哉大王。快得善利。能令佛法炽然增长。帝释乃谓诸天子言。此昵弥王久植善根。成就不可思议功德。善巧方便于少时间。教化八十俱胝有情离颠倒地安住佛法。彼摩多黎都不觉知。时昵弥王为诸天子广说法要。白天主言。我今当还于阎浮提。所以者何。为欲护持佛正法故。天主乃曰。愿王随意。佛言大王。往昔昵弥王者。我身是也。不放逸力不可思议。帝释分座尚无贪着。是故当知于佛法中勤加精进住不放逸。大王。何谓佛法。一切诸法皆是佛法。时净饭王闻是说已。白言世尊。若一切法皆佛法者。一切众生皆应是佛。佛言大王。众生不住颠倒见者。即是佛也。大王。所言佛者。或名真如。或名实际。或名法界。但依俗谛推求诠表。非胜义谛作是说也。大王。一切诸法本无生灭。此名阿字陀罗尼门。无自性无造作无相貌。无因缘无去来。无众生无寿者无养者无补特伽罗。无戏论无形状无边际。无染污无余习。无使者无断者。无缚无解。无进无退。无胜无劣。无散乱无妄失。无知无不知。非见非无见。非戒非无戒。非悔非离悔。非喜非无喜。非爱非无爱。非安非无安。非定非无定。非静非无静。非贪非离贪。非脱非离脱。非智非无智。非作非无作。非报非无报。大王。若能入解此阿字门。则能入解一切诸法。大王。色离自性。非已有非现有非当有。受想行识离彼自性。三世不有亦复如是。大王。譬如谷响非已有非现有非当有。色乃至识三世不有。亦复如是。大王。譬如阳焰非已有非现有非当有。色乃至识三世不有。亦复如是。大王。譬如聚沫非已有非现有非当有。色乃至识三世不有亦复如是。大王。譬如石女梦已生子。非已有非现有非当有。色乃至识三世不有。亦复如是。大王。虚空无依色乃至识亦无所依。大王。色无有生乃至识亦无生。大王。色无有灭乃至识亦无灭。大王。涅槃界无生灭。色乃至识亦无生灭。大王。法界无生灭。色乃至识亦无生灭。大王。此法乃是如来所行。不可思议微妙境界。非取非舍非得非失。非诸声闻及辟支佛凡夫异生之所能及。何以故。大王。一切诸法本无自性。若取若舍皆不可得。王于此法好自安意。正念观察勿随他教。时净饭王闻是说已。明了通达。乃知无有少法可得不可得。时此说名佛说是法。时净饭王与七万释种。各各获得无生法忍。尔时世尊知净饭王悟此法已。深心决定。即于口中放种种光。遍照无量无边世界超过梵世。复从如来顶门而入时尊者。马胜从座而起。偏袒右肩右膝着地。合掌作礼。以偈问佛

  勇猛大圣尊　　现此希有事
  普放净光明　　遍照于梵世
  一切智导师　　何故现斯瑞
  愿说其因由　　除我等疑惑
  如来成道已　　广饶益众生
  为度释种故　　令人天欢喜
  如来放光明　　觉悟诸佛子
  如法而修行　　当得无上智
  佛为三界主　　最胜无与比
  能破诸群疑　　清净心安隐

尔时世尊为马胜比丘。说伽陀曰

  马胜当谛听　　今放净光明
  为利乐释种　　令见真实智
  彼等善了达　　诸法不可得
  于我正法中　　寂静心安住
  释种大名称　　了法无所依
  得离彼疑心　　未来当作佛
  从此最后身　　得生极乐国
  于莲华化生　　奉觐无量寿
  安住彼佛刹　　精进无现转
  游化于十方　　承事俱胝佛
  于一一世界　　兴种种供养
  为利诸有情　　勤求无上道
  经一一佛刹　　建立诸佛事
  如来所加持　　勇悍心坚固
  于无量亿劫　　严持妙香花
  奉献诸世尊　　后当成正觉
  于彼彼佛所　　宣扬助法化
  成熟诸有情　　皆得心明悟
  又彼诸佛土　　无缘觉声闻
  唯有住大乘　　清净菩萨众
  一一佛寿量　　无量俱胝岁
  说化利众生　　缘尽如灯灭
  彼佛灭度已　　住持诸佛子
  安住于世间　　善宣空寂法
  如是弟子众　　摄化诸众生
  调伏于自心　　于空法得证
  住不放逸行　　观法自性空
  如理善修作　　当成一切智
  此诸释种等　　闻法悉开悟
  诸天及世人　　心生大欣庆

尔时世尊。语尊者舍利子。我今说此见真实性妙三摩地。若诸菩萨闻是法已。速能觉悟到于彼岸。何以故。此三摩地。明一切法自性非有无补特伽罗无少法可得。若有所得彼非觉悟。若无觉悟彼则无说。若无说者则无了知。若无了知则是三世诸佛之法。舍利子。我今以此见真实性三摩地门。付嘱于汝。汝等应当受持读诵广为他说。舍利子。若善男子善女人安住大乘。于十劫中行五波罗蜜。除般若波罗蜜。若人于此见真实性三摩地门。亲近听受。所得功德复过于彼。又舍利子。若复有人于十劫中闻是法已。乃至能为一人解说。所得功德复过于彼。又舍利子。若复有人于十劫中闻是法已。为他人说。不如有人于刹那顷修习观察。所得功德复过于彼。舍利子。汝当一心为诸菩萨分别开示使不断绝。何以故。若能证此三摩地者。速能证得无生法忍。当得阿耨多罗三藐三菩提。说是法时。尊者舍利子等诸比丘。净饭王等释梵诸天。阿修罗乾闼婆人非人等。闻佛所说。皆大欢喜。信受奉行

父子合集经卷第二十


观世音菩萨授记经

    No. 371 [No. 372]

观世音菩萨授记经

        宋黄龙国沙门昙无竭译

如是我闻。一时佛在波罗奈仙人鹿苑中。与大比丘众二万人俱。菩萨万二千。其名曰师子菩萨。师子意菩萨。安意菩萨。无喻意菩萨。持地菩萨。般罗达菩萨。神天菩萨。实事菩萨。伽睺多菩萨。贤力菩萨。明天菩萨。爱喜菩萨。文殊师利菩萨。智行菩萨。专行菩萨。现无碍菩萨。弥勒菩萨。如是等上首。菩萨摩诃萨万二千人俱。复有二万天子。善界天子。善住天子等。以为上首。皆住大乘。尔时世尊。与无量百千眷属围绕而为说法。尔时会中。有一菩萨。名华德藏。即从坐起偏袒右肩。右膝着地合掌向佛。而作是言。惟愿世尊。赐我中间。欲有所问。佛告华德藏菩萨。恣汝所问。诸有疑者吾已知之。当为解说令汝欢喜。尔时华德藏白佛言。世尊。菩萨摩诃萨。云何不退转于阿耨多罗三藐三菩提。及五神通。得如幻三昧以善方便能化其身。随众形类所成善根。而为说法。令得阿耨多罗三藐三菩提

佛告华德藏菩萨摩诃萨。善哉善哉。能于如来等正觉前。问如是义。汝华德藏。已于过去诸佛。殖诸善根。供养无数百千万亿诸佛世尊。于诸众生兴大悲心。善哉华德藏。谛听谛听。善思念之。当为汝说。对曰唯然愿乐欲闻。佛告华德藏菩萨摩诃萨。成就一法得如幻三昧。得是三昧。以善方便能化其身。随众形类所成善根。而为说法。令得阿耨多罗三藐三菩提。何等一法。谓无依止。不依三界。亦不依内。又不依外。于无所依得正观察。正观察已便得正尽。而于觉知无所损减。以无减心悉度正慧。谓一切法从缘而起。虚假而有。一切诸法因缘而生。若无因缘无有生法。虽一切法从因缘生。而无所生。如是通达无生法者。得入菩萨真实之道。亦名得入大慈悲心。怜愍度脱一切众生。善能深解如是义已。则知一切诸法如幻。但以忆想语言造化法耳。然此忆想语言造化诸法。究竟悉空。善能通达诸法空已。是名逮得如幻三昧。得三昧已。以善方便能化其身。随众形类而成善根。而为说法。令得阿耨多罗三藐三菩提

尔时华德藏菩萨摩诃萨。白佛言世尊。于此众中。颇有菩萨得是三昧乎。佛言有。今是会中。弥勒菩萨文殊师利等六十正士。不可思议大誓庄严。得是三昧。又白佛言世尊。唯此世界菩萨得是三昧。他方世界复有菩萨。成就如是如幻三昧。佛告华德藏。西方过此亿百千刹。有世界名安乐。其国有佛。号阿弥陀如来应供正遍知。今现在说法。彼有菩萨。一名观世音。二名得大势。得是三昧。复次华德藏。若有菩萨。从彼正士。七日七夜听受是法。便逮得如幻三昧。华德藏菩萨。白佛言世尊。彼国应有无量菩萨得是三昧。何以故。其余菩萨生彼国者。皆当往至彼正士所。听受是法。佛言。如是如是。如汝所言。有无量阿僧祇菩萨摩诃萨。从彼正士得是三昧。花德藏菩萨。白佛言。善哉世尊。如来应供正遍知。愿以神力。令彼正士至此世界。又令彼此两得相见。何以故。以彼正士至此刹故。善男子善女人。成善根者。闻其说法得是三昧。又愿见彼安乐世界阿弥陀佛。令此善男子善女人。发阿耨多罗三藐三菩提心。愿生彼国。生彼国已。绝不退转阿耨多罗三藐三菩提。尔时世尊受彼请已。即放眉间白毫相光。遍照三千大千国土。于此世界草木土石。须弥山王。目真邻陀山。大目真邻陀山。斫迦罗山。大斫迦罗山。乃至世界中间幽冥之处。普皆金色莫不大明。日月晖曜及大力威光。悉不复现。遍照西方亿百千刹乃至安乐世界。悉皆金色。大光右绕彼佛七匝。于如来前廓然不现。彼国众生菩萨声闻。悉见此土及释迦文与诸大众围绕说法。犹如掌中观阿摩勒果。皆生爱乐欢喜之心。唱如是言。南无释迦如来应供正遍知。于此众会比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。释梵四天王。菩萨声闻。皆见安乐世界阿弥陀佛。菩萨声闻眷属围绕。晃若宝山高显殊特。威光赫奕普照诸刹。如净目人于一寻内睹人面貌明了无碍。既见是已。欢喜踊跃唱如是言。南无阿弥陀如来应供正遍知。时此众中八万四千众生。皆发阿耨多罗三藐三菩提心。及种善根。愿生彼国。尔时安乐世界菩萨声闻。见此刹已。怪未曾有。欢喜合掌。礼释迦牟尼如来应供正遍知。作如是言。南无释迦牟尼佛。能为菩萨声闻说如是法。尔时安乐世界六种震动。动遍动等遍动。摇遍摇等遍摇。震遍震等遍震

尔时观世音及得大势菩萨摩诃萨。白彼佛言。甚奇世尊。释迦如来现希有事。何以故。彼释迦牟尼如来应供正遍知。少现名号。令无想大地六种震动。尔时阿弥陀佛。告彼菩萨。释迦牟尼不但此土现其名号。其余无量诸佛世界。悉现名号。大光普照六种震动。亦复如是。彼诸世界无量阿僧祇众生。闻释迦牟尼称誉名号。善根成就。皆得不退转于阿耨多罗三藐三菩提。时彼众中四十亿菩萨。闻释迦牟尼如来应供等正觉名号。同声发愿。善根回向阿耨多罗三藐三菩提。佛即授记。当得阿耨多罗三藐三菩提

尔时观世音及得大势菩萨摩诃萨。诣彼佛所头面礼足。恭敬合掌于一面住。白佛言世尊。释迦牟尼。放此光明。何因何缘。尔时彼佛告观世音。如来应供等正觉。放斯光明非无因缘。何以故。今日释迦牟尼如来应供正遍知。将欲演说菩萨珍宝处三昧经故先现瑞。尔时观世音。及得大势菩萨摩诃萨。白佛言世尊。我等欲诣娑婆世界。礼拜供养释迦牟尼佛。听其说法。佛言善男子。宜知是时。时二菩萨即相谓言。我等今日。定闻彼佛所说妙法。时二菩萨受佛教已。告彼四十亿菩萨眷属。善男子当共往诣娑婆世界。礼拜供养释迦牟尼佛。听受正法。何以故。释迦牟尼如来应供等正觉。能为难事。舍净妙国。以本愿力。兴大悲心。于薄德少福。增贪恚痴。浊恶世中。成阿耨多罗三藐三菩提。而为说法。说是语时。菩萨声闻同声叹言。彼土众生。得闻释迦牟尼如来应供正遍知名号。快得善利。何况得见发欢喜心。世尊我等。当共诣彼世界礼拜供养释迦牟尼佛。佛言。善男子。宜知是时。尔时观世音及得大势菩萨摩诃萨。与四十亿菩萨。前后围绕。于彼世界。以神通力各为眷属。化作四十亿庄严宝台。是诸宝台。纵广十二由旬。端严微妙。其宝台上。有处黄金。有处白银。有处琉璃。有处颇梨。有处赤珠。有处车磲。有处马瑙。有处二宝黄金白银。有处三宝金银琉璃。有处四宝。黄金白银琉璃颇梨。有处五宝。金银琉璃颇梨赤珠。有处六宝。黄金白银琉璃颇梨车磲赤珠。有处七宝。乃至马瑙。又以赤珠栴檀优钵罗钵昙摩拘物头分陀利而庄严之。又雨须曼那华。瞻卜花。波罗罗花。阿提目多花。罗尼花。瞿罗尼花。曼陀罗花。摩诃曼陀罗花。波楼沙花。摩诃波楼沙花。曼殊沙花。摩诃曼殊沙花。卢遮那花。摩诃卢遮那花。遮迦花。摩诃遮迦花。苏楼至遮迦花。栴那花。摩诃栴那花。苏楼至栴檀那花。栴奴多罗花。他逻花。摩诃他逻花。其宝台上种种杂色。斑烂炜晔清净照耀。诸宝台上。有化玉女八万四千。或执箜篌琴瑟筝笛。琵琶鼓贝。如是无量众宝乐器。奏微妙音俨然而住。或有玉女。执赤栴檀香。沉水栴檀香。或执黑沉水栴檀香。俨然而住。或有玉女。执优波罗。波头摩。拘物头。分陀利华。俨然而住。或有玉女。执曼陀罗花。摩诃曼陀罗花。波楼沙花。摩诃波楼沙花。卢遮那花。摩诃卢遮那花。栴那花。摩诃栴那花。苏楼至栴那花。遮迦花。摩诃遮迦花。苏楼至遮迦花。陀罗花。摩诃陀罗花。苏楼至陀罗花。庄严而住。或有玉女。执一切花果俨然而住。诸宝台上。众宝庄严师子之座。座上皆有化佛三十二相八十种好而自严身。台上各悬八万四千青黄赤白杂真珠。贯诸宝台上。各有八万四千众妙宝瓶。盛满末香列置其上。诸宝台上。各有八万四千众宝妙盖。弥覆其上。诸宝台上。各有八万四千众宝树。殖其上。诸宝台上。各有八万四千宝铃。罗覆其上。诸宝树间有七宝池。八功德水盈满其中。青黄赤白杂宝莲花。光色鲜映微风吹动。众宝行树出微妙音。其音和雅踰于天乐。诸宝台上。各有八万四千众妙宝绳。连绵树间。一一宝台。光明照耀八万四千由旬。莫不大明。尔时观世音及得大势菩萨摩诃萨。与其眷属八千亿众诸菩萨俱。庄严宝台悉皆同等。譬如力士屈伸臂顷。从彼国没。至此世界。时彼菩萨以神通力。令此世界地平如水。与八十亿菩萨前后围绕。以大功德庄严成就。端严殊特无可为喻。光明遍照娑婆世界。是诸菩萨诣释迦牟尼佛所。头面礼足。右绕七匝。却住一面。白佛言。世尊。阿弥陀佛。问讯世尊。少病少恼起居轻利。安乐行不。又现彼土庄严妙事时。此菩萨及声闻众。见此宝台众妙庄严。叹未曾有。各作是念。此诸宝台庄严微妙。从安乐国至此世界。为是佛力菩萨力耶。尔时华德藏菩萨承佛神力白佛言。甚奇世尊。未曾有也。今此娑婆世界。众妙宝台庄严如是。是谁威力。佛言。是观世音及得大势神通之力。于此世界现大庄严。甚奇世尊。不可思议。彼善男子。愿行清净。能以神力庄严宝台。现此世界。佛言。如是如是。如汝所说。彼善男子。已于无数亿那由他百千劫中。净诸善根。得如幻三昧。住是三昧。能以神通变化现如是事又华德藏。汝今且观东方世界。为何所见。时华德藏即以菩萨种种天眼。观于东方恒河沙等诸佛世界。见彼佛前。皆有观世音及得大势。庄严如前。恭敬供养皆称阿弥陀佛。问讯世尊。少病少恼起居轻利。安乐行不。南西北方四维上下亦复如是。尔时华德藏菩萨见是事已欢喜踊跃。得未曾有而白佛言。甚奇世尊。今此大士。乃能成就如是三昧。何以故。今此正士。能现庄严是诸佛刹。尔时世尊即以神力。令此众会见是事已。三万二千人。发阿耨多罗三藐三菩提心。华德藏菩萨白佛言。世尊。是二正士。久如发阿耨多罗三藐三菩提心。于何佛所。唯愿说之。令诸菩萨。修此愿行具足成就。佛言。谛听善思念之。当为汝说。善哉世尊。愿乐欲闻。佛言。乃往过去广远无量不可思议阿僧祇劫。我于尔时。为百千王。时初大王劫欲尽时。有世界名无量德聚安乐示现。其国有佛。号金光师子游戏如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是佛刹土。所有清净严饰之事。今为汝说。于意云何。安乐世界阿弥陀佛国土所有严净之事。宁为多不。答曰甚多。不可思议难可具说。佛告华德藏。假使有人。分析一毛以为百毛。以一分毛渧大海水。于意云何。一毛端水于大海水。何者为多。答曰。海水甚多。不可为譬。如是华德藏。应作是知。阿弥陀国庄严之事。如毛端水。金光师子游戏佛国。如大海水。声闻菩萨差降亦尔。彼金光师子游戏如来。亦为众生说三乘法。我于恒沙等劫。说此佛国功德庄严。菩萨声闻快乐之事。犹不能尽。尔时金光师子游戏如来法中有王。名曰威德王。千世界正法治化。号为法王。其威德王多诸子息。具二十八大人之相。是诸王子。皆悉住于无上之道。王有七万六千园观。其王诸子游戏其中。华德藏白佛言。世尊。彼佛刹土有女人耶。佛言。善男子。彼佛国土尚无女名。何况有实。其国众生净修梵行。纯一化生禅悦为食。彼威德王于八万四千亿岁。奉事如来不习余法。佛知至心。即为演说无量法印。何等为无量法印。华德藏菩萨。凡所修行。应当发于无量誓愿。何以故。菩萨摩诃萨。布施无量。持戒无量。忍辱无量。精进无量。禅定无量。智慧无量。所行六度摄生死无量。慈愍众生无量。庄严净土无量。音声无量。辩才无量。华德藏。乃至一念善相应回向无量。云何回向无量。如回向一切众生。令一切众生得无生证。以佛涅槃而般涅槃。是名回向无量。无边空无量。无相无量。无愿无量。无行如是。无欲实际。法性无生。无著解脱。涅槃无量。善男子。我但略说诸法无量。何以故以一切法无有限量。复次华德藏。彼威德王。于其园观。入于三昧。其王左右有二莲花。从地踊出。杂色庄严。其香芬馥如天栴檀。有二童子化生其中。加趺而坐。一名宝意。二名宝上。时威德王从禅定起。见二童子坐莲华藏。以偈问曰

  汝为天龙王　　夜叉鸠槃荼
  为人为非人　　愿说其名号

时王右面童子以偈答曰

  一切诸法空　　云何问名号
  过去法已灭　　当来法未生
  现在法不住　　仁者问谁名
  空法亦非人　　非龙非罗刹
  人与非人等　　一切不可得

左面童子而说偈言

  名名者悉空　　名名不可得
  一切法无名　　而欲问名字
  欲求真实名　　未曾所见闻
  夫生法即灭　　云何而问名
  说名字语言　　皆是假施设
  我名为宝意　　彼名为宝上

华德藏。是二童子说是偈已。与威德王俱诣佛所。头面礼足。右绕七匝。合掌恭敬于一面住。时二童子即共同声。以偈问佛

  云何为供养　　无上两足尊
  愿说其义趣　　闻者当奉行
  花香众伎乐　　衣食药卧具
  如是等供养　　云何为最胜

尔时彼佛即为童子而说偈言

  当发菩提心　　广济诸群生
  是则供正觉　　三十二明相
  设满恒沙刹　　珍妙庄严具
  奉献诸如来　　及欢喜顶戴
  不如以慈心　　回向于菩提
  是福为最胜　　无量无有边
  余供无过者　　超踰不可计
  如是菩提心　　必成等正觉

时二童子复说偈言

  诸天龙鬼神　　听我师子吼
  今于如来前　　弘誓发菩提
  生死无量劫　　本际不可知
  为一众生故　　尔数劫行道
  况此诸劫中　　度脱无量众
  修行菩提道　　而生疲惓心
  我若从今始　　起于贪欲心
  是则为欺诳　　十方一切佛
  嗔恚愚痴垢　　悭嫉亦复然
  今我说实语　　远离于虚妄
  我若于今始　　起于声闻心
  不乐修菩提　　是则欺世尊
  亦不求缘觉　　自济利己身
  当于万亿劫　　大悲度众生
  如今日佛土　　清净妙庄严
  令我得道时　　超踰亿百千
  国无声闻众　　亦无缘觉乘
  纯有诸菩萨　　其数无限量
  众生净无垢　　悉具上妙乐
  出生于正觉　　总持诸法藏
  此誓若诚实　　当动大千界
  说如是偈已　　应时普震动
  百千众伎乐　　演发和雅音
  光耀微妙服　　旋转而来降
  诸天于空中　　雨散众末香
  其香普流熏　　悦可众生心

佛告华德藏。于汝意云何。尔时威德王者岂异人乎。我身是也。时二童子。今观世音及得大势菩萨摩诃萨是也。善男子。是二菩萨于彼佛所。初发阿耨多罗三藐三菩提心。尔时华德藏白佛言。甚奇世尊。是善男子。未曾发心。成就如是甚深智慧。了达名字悉不可得。世尊。是二正士于彼先佛已曾供养。作诸功德。善男子。此恒河沙悉可知数。而此大士先供养佛。种诸善根不可称计。虽未发于菩提之心。而以不可思议而自庄严。于诸众生为最勇猛。尔时华德藏菩萨白佛言。世尊。其无量德聚安乐示现国土。为在何方。佛言。善男子。今此西方安乐世界。当于尔时。号无量德聚安乐示现。华德藏菩萨白佛言。世尊。愿为解说。令无量众生得大利益。是观世音于何国土成等正觉。世界庄严光明名号。声闻菩萨寿命所有。乃至成佛。其事云何。若世尊说是菩萨先所行愿。其余菩萨闻是愿已。必当修行而得满足。佛言。善哉谛听。当为汝说。对曰。唯然愿乐欲闻。佛言。善男子。阿弥陀佛寿命无量百千亿劫。当有终极。善男子。当来广远不可计劫。阿弥陀佛当般涅槃。般涅槃后。正法住世等佛寿命。在世灭后。所度众生悉皆同等。佛涅槃后。或有众生不见佛者。有诸菩萨。得念佛三昧。常见阿弥陀佛。复次善男子。彼佛灭后。一切宝物浴池莲花众宝行树。常演法音与佛无异。善男子。阿弥陀佛正法灭后。过中夜分明相出时。观世音菩萨。于七宝菩提树下。结加趺坐成等正觉。号普光功德山王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛国土自然七宝。众妙合成庄严之事。诸佛世尊。于恒沙劫说不能尽。善男子。我于今者为汝说譬。彼金光师子游戏如来国土庄严之事。方于普光功德山王如来国土。百万千倍亿倍。亿兆载倍。乃至算数所不能及。其佛国土无有声闻缘觉之名。纯诸菩萨充满其国。华德藏菩萨白佛言。世尊。彼佛国土名安乐耶。佛言。善男子。其佛国土号曰众宝普集庄严。善男子。普光功德山王如来。随其寿命。得大势菩萨。亲觐供养。至于涅槃。般涅槃后。奉持正法。乃至灭尽。法灭尽已。即于其国。成阿耨多罗三藐三菩提。号曰善住功德宝王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。如普光功德山王如来国土。光明寿命菩萨众。乃至法住等无有异。若善男子善女人。闻善住功德宝王如来名者。皆得不退于阿耨多罗三藐三菩提。又善男子若有女人。得闻过去金光师子游戏如来。善住功德宝王如来名者。皆转女身。却四十亿劫生死之罪。皆不退转于阿耨多罗三藐三菩提。常得见佛。闻受正法。供养众僧。舍此身已。出家成无碍辩。速得总持

尔时会中六十亿众同声叹言。南无十方般涅槃佛。同心共议。发阿耨多罗三藐三菩提。佛即受记当成阿耨多罗三藐三菩提。复有八万四千那由他众生。远尘离垢。于诸法中得法眼净。七千比丘漏尽意解。尔时观世音及得大势菩萨。即以神力。令此众会悉见十方无数诸佛世尊。皆为授其阿耨多罗三藐三菩提记。见已叹言。甚奇世尊。是诸如来为此大士授如是记。尔时华德藏菩萨白佛言。世尊。若善男子善女人。于此如来甚深经典。受持读诵。解说书写。广宣流布。得几所福。唯愿如来分别解说。何以故。当来恶世薄德众生。于此如来甚深经典。而不信受。以是因缘。长夜受苦难得解脱。世尊。唯愿说之。怜愍利益诸众生故。世尊。今此会中多有利根善男子善女人。于当来世而作大明。佛言。华德藏。善哉谛听。当为汝说。对曰受教。愿乐欲闻。佛言。若善男子。以三千大千世界一切众生置两肩上。尽其形寿随所须欲。衣食卧具床褥汤药。而供养之。所得功德。宁为多不。甚多世尊。若以慈心。供一众生随其所须。功德无量。何况一切。佛言。若善男子善女人。于此经典。受持读诵解说书写。种种供养广宣流布。发菩提心。所得功德。百千万倍不可为譬。华德藏菩萨白佛言。世尊。我从今日。于此如来所说经典。及过去当来三佛名号。常当受持读诵解说书写广宣流布。远离贪恚痴心。发阿耨多罗三藐三菩提。终不虚妄。世尊。我成佛者。若有女人闻如是法。现转女身。转女身已。当为授记。得阿耨多罗三藐三菩提。号曰离垢多陀阿伽度阿罗呵三藐三佛陀。说是经已。华德藏菩萨摩诃萨。及诸比丘比丘尼菩萨声闻。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻佛所说。皆大欢喜

观世音菩萨授记经


后出阿弥陀佛偈

    No. 373

后出阿弥陀佛偈

        古旧录云阙译人名今纪后汉录

  惟念法比丘　　乃从世饶王
  发愿喻诸佛　　誓二十四章
  世世见诸佛　　垓数无有量
  不废宿命行　　功德遂具成
  世界名清净　　得佛号无量
  国界平夷易　　丰乐多上人
  宝树若干种　　罗列丛相生
  本茎枝叶花　　种种各异香
  顺风日三动　　翕习如花生
  堕地如手布　　杂厕上普平
  一切无诸山　　海水及诸源
  但有河水流　　音响如说经
  天人入水戏　　在意所欲望
  令水齐胳肩　　意愿随念得
  佛寿十方沙　　光明普无边
  菩萨及弟子　　不可算称量
  若欲见彼佛　　莫疑亦莫忘
  有疑在胎中　　不合五百年
  不疑生基坐　　叉手无量前
  愿欲遍十方　　须臾则旋还
  惟念彼菩萨　　垓劫作功勤
  本行如此致　　得号会世尊
  佛兴难得值　　须臾会难闻
  讲说士难遇　　受学人难得
  若后遭末世　　法欲衰微时
  当共建拥护　　行佛无欲法
  佛能说此要　　各各勤思行
  受此无量福　　世世稽首行

后出阿弥陀佛偈


慧上菩萨问大善权经卷上

    No. 345 [Nos. 310(38), 346]

慧上菩萨问大善权经卷上

        西晋月氏国三藏竺法护译

闻如是。一时佛游舍卫城祇树给孤独园。与大比丘众俱。比丘八千诸大弟子学戒具足。菩萨万二千。一切圣通无所不达。已得总持辩才无量不起法忍。其德无限彻睹诸根。应病授药为师子吼。救济十方众生百千莫不蒙度。尔时世尊。从宴坐起斯须未久。与无数之众眷属周匝而为说经。时会菩萨名曰慧上。即从坐起更整衣服。长跪叉手前白佛言。愿欲有所问。唯如来至真。听者乃敢陈说。世尊告曰。恣所欲问。佛当为汝开解结滞。慧上白佛。所云善权为何谓乎。佛告慧上。善哉善哉族姓子。多所愍伤哀念。安隐诸天人民。劝化将来导引三涂。开阐佛法获微妙慧。乃问闿士善权方便。佛言谛听善思念之。吾当为汝申畅其要。慧上菩萨及与众会受教而听。于是佛告慧上曰。族姓子。善权闿士以一揣食。随时方便弘施流普。劝发黎元坠畜生者。使此二品悉趣德本。兴诸通慧。其心晓了具足佛慧。是谓菩萨善权方便

又族姓子。善权闿士。若人殖德劝赞代喜。以斯善本则施众生。以觉之心。顺一切心而不堕落。讲斯教已。成诸弟子缘觉之乘为诸通慧。是谓菩萨善权方便

又族姓子。善权闿士。十方诸树其华炜晔。香气芬馥人所钦尚。而无主名。敬采集合奉散诸佛誓以德本。已及众庶志诸通慧使备道明。具获无量戒品定品慧品解脱品度脱知见品。是谓菩萨善权方便

又族姓子。善权闿士愍察群萌。在安助喜彼患代受。以诸通慧因缘方便。建立德本用施众类。为十方世界誓被德铠。其遭恼害者则救摄所。患代受其罪劝。以通慧使获大安。是谓菩萨善权方便

又族姓子。善权闿士供一如来。观虑诸佛法身平等。戒定慧解度知见品亦复如之。知是供养一如来等。则为奉养十方诸佛。所见供祚闿士历受施祐众生。是谓菩萨善权方便。又族姓子。善权闿士敢所生处。其所住处不计吾我未曾自轻。如令讽读四句之颂。观察其义心不怯羸。宣显备具。不想利养。盖诸佛土若入国邑。辄兴大哀踊跃说之。誓愿闻吾四句颂者。皆成诸佛无碍辩才。是谓菩萨善权方便

又族姓子。善权闿士。假使生在贫匮之门。设行乞丐求一夕膳。无鄙劣心转奉贤众。若惠独人内自惟察。如来有言务恢广施。今吾乞与所进微鲜。建诸通慧誓意无量。殖斯德本劝发众生。侥获宝掌若如来至真等正觉。以斯妙慧光护夕供。所服纳者持戒学道。缘崇功德多所彼致。是谓菩萨善权方便

又族姓子。善权闿士。与诸弟子缘觉俱游。心不同归。见人供养弟子缘觉。意不钦获兴于二念。一从菩萨心成佛世尊。二弟子缘觉因佛法生。造斯观已。诸所供养未以为上。吾所学习则三品最。观无适莫无所贪乐。是谓菩萨善权方便

又族姓子。善权闿士行一布施。则具六度无极。何等六度。善权闿士见贫乞者。具足大施无悭贪心。斯施度无极。身自护禁奉持戒者。其犯恶者使立戒法。寻而给施令无所毁。斯戒度无极。若嗔恚者。御以慈心净心明心。愍哀等心。兴施布施。斯忍度无极。随宜供办饮食之膳。身口意行身等如空。斯进度无极。一心等施进止卧梦而无乱行。斯定度无极。如兹施已御念诸法。谁有施者。何所食者。谁受报应。造斯求者法不可得。不见施者及食施者。无受报应。斯慧度无极。是族姓子。权施若斯。则具六度无极之法。于是慧上菩萨白佛言。未曾有也天中天。闿士丈夫权施具足。一切佛法多所摄护。振于生死赡及余类。佛言至哉。诚如所云。权施虽微审成众德无量难计。又族姓子。行权闿士。何谓退还。以权方便而以施与。纵随恶友为之所拘。毕偿罪者自观念言。阴种诸入得无不灭。当除斯患乃至无为。吾誓当被道德之铠。任力发起周旋终始则务究竟慧上又问。唯天中天。假使有人犯于四罪有所想念。发意出家为菩萨道然后云何。佛言。设当毁失四重之禁。以权消罪众患悉除。是族姓子。为菩萨道无有罪衅

尔时慧上菩萨白世尊曰。何谓菩萨而有罪殃。佛言。若有闿士学得脱戒。得脱戒者则二百五十禁。于百千劫服食果蓏。为人所辱而皆忍之。若有想念弟子缘觉之行。闿士则为生死根缚。如族姓子。声闻缘觉犯本诸禁。不除阴种诸入。不得灭度也。如族姓子。舍闿士行不自改正而有想念。志求声闻缘觉。欲得无上正真之道为最正觉者。终不能成也

于是阿难白世尊曰。忆念我昔入舍卫城而行分卫。见有闿士名重胜王。在他室坐与女人同床。我谓犯秽心用惟虑。得无异人学梵行者。于如来教。将无造见闻想念于一切乎。时我世尊。瞻见立想叹发斯言。三千大千世界而六反震动。时重胜王。即自踊身住于空中。去地四丈九尺。报阿难曰。云何贤者。犯禁秽者宁能踊身止虚空乎。在如来前何不问耶。何谓菩萨犯罪之法。阿难投身即自悔过曰。唯然世尊。我甚迷谬。如何偏见求大龙短。佛告阿难。宜自修慎无察大乘正士之便而想其阙。由如贤者志弟子乘。若一若二同修杂行。不当视之狐疑懈废得无尽漏。如是阿难。勿观善权闿士有废退想于诸通慧。所以者何。菩萨大士。爱纳眷属业以三宝。不违佛法贤圣众也。使志无上正真之道。佛语阿难。若族姓子族姓女。心存大乘不离诸通慧。不荒五乐抑制五欲。观于五通得如来根。当知正士与女人俱。又听阿难。彼女人者乃往去世为重胜王百生之偶。宿情未拔故有色恩。贪重胜颜口发誓言。若与我俱得遂所娱。当从其教发无上正真道意。时重胜王心知其念。晨现整服由斯法门入之其室。观内外地心等无持。执手同处已如其欲。则颂曰

  愚哉悖于欲　　诸佛所不叹
  能蠲恩爱者　　得佛人中上

时女喜踊即从坐起。自投于地归命自责伏罪悔过。为重胜王而叹颂曰

  吾已离诸欲　　世尊之所叹
  节止恩爱着　　愿佛无上道
  前心之所想　　今首自悔过
  伤愍诸群生　　究竟发道意

尔时重胜王菩萨。随欲化女使发无上正真道意。即从坐起而出其室。阿难观斯心持清净。今吾授彼女决。转女身后九十九劫当得作佛。号离无数百千所受如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。以是贤者观菩萨行。所行无短不堕罪法。重胜王菩萨从虚空下。稽首佛足白世尊曰。闿士当行善权方便立于大哀。若劝一人导以法本。从其所生辄当获之信于善权。堕大地狱至于百劫。所遭苦痛恼剧之患。则当忍之。宁化一人使立德本不避此难。世尊告曰。善哉善哉。正士通达。是为菩萨大哀之行。超度诸受佛言族姓子。吾念过世无数劫时。有一学志。名曰焰光。处于林薮行吉祥愿。四百二十万岁净修梵行。过阕岁已入沙竭国有陶家女。见此学志姿貌姝好端正绝妙。欲意隆崇即自投托。学志问姊何所求乎。答曰慕仁。学志报言。吾不乐欲。女曰设不然者吾将自贼。焰光自念。吾护禁戒净修梵行。四百二十万岁。今若毁之非吉祥也。念已舍却离之七步。乃发慈哀。毁犯禁戒则堕地狱。若不如是女自残贼。宁令斯女获致安隐。吾当堪忍地狱之痛。焰光即还。又执其臂而喻之曰。从女之欲幸勿自危。学志退居习家之业十有二年。厌碍止足乃净四等。寿终之后生于梵天。佛言。族姓子。欲知尔时焰光学志。岂异人乎。莫造此观。则吾身是。陶家女者即瞿夷也。彼尚色欲此顺其心。吾以大哀越度生死百千之患。贤者且观余人所犯坠趣地狱。善权闿士更升梵天。佛告慧上。设舍利弗大目揵连。行善权者不使瞿和离比丘坠于地狱。所以者何。吾忆昔者拘楼秦佛时。有一比丘名曰无垢。处于闲居国家山窟。去彼不远有五神仙。有一女人道遇大雨。驰走避入无垢比丘所止之窟。雨霁出去。时五仙人见女各言。比丘奸秽谓之不净。无垢知诸神仙所念。即自踊身在于虚空去地四丈九尺。诸仙见之飞处空中。各曰如吾经典所记。染欲尘者则不得飞。寻五体投地伏首诬横。假使比丘不现神变。其五仙士堕大地狱。尔时无垢比丘则慈氏菩萨也。若舍利弗目揵连有权飞升。则瞿和离无由陷坠。当知此义。非声闻缘觉所能及知。唯独闿士分别晓了善权方便。犹如放逸女人四时庄严贪财利欲。或无智者变改人性。使从其意示于施身。敬重彼人殚尽其产。遂弃远之缘所获入未曾有悔。善权菩萨亦复如斯。观察人根可开化者。以何方便则化立之。敬施众生不吝其身。殖诸德本不藏情匿。设使知人已建德本。用其人故续命长善。一切欲乐无所贪慕。舍除恩爱令归于无。其心清净无所系着。犹如蜜蜂接采众花不计常想。于花枝叶一无所损。行权菩萨随俗方便。虽乐诸欲不计爱欲不发常想。不自毁身亦不损彼。譬如树种不失鲜色因而生牙无加茷者。如是族姓子。菩萨以空无想不愿之法。智度无极广大之慧。入诸尘劳随所乐行。不舍习俗欲不秽身。不违佛叹未曾退转。如捕鱼工引网布网。恣意所欲截众大流。收纲摄网多所获得。菩萨如是入空无想不愿之法。以细微心在一切慧。缚于大欲。诸通慧心以无护心。自在所获得生梵天。譬如丈夫工学咒术。为吏所捕五系缚之。其人自恣则以一咒。断诸缧绁而得解去。如是族姓子。善权菩萨五欲自乐。普与众俱恣其所幸。智力术力以一通慧。坏一切欲没生梵天。譬安隐师以一其心无所恶忌。变现荫庇送大贾人。或有愚谤而伤之曰。忖察此师自眷属财贿尚不合度。安能济众使免贼乎。将必遗漏无量钱宝。于是导师激愤耻之。即从坐起秉心坚强。带钾舞刀摧拉怨敌。所护安隐无所亡失。行权菩萨。执智慧刀随时所欲。以巧方便安习五乐。志弟子乘所不悦可。为发慈愍。云何若此兴放逸行。尚不自度何能济众降魔怨乎。所不堪偕也。菩萨以智慧度无极法。善权方便恣意所欲。以智慧刀断截尘劳裂诸罗网。超游自恣遍诸佛国。离女人土无有瑕秽

尔时有菩萨名曰爱敬。入舍卫大城普次行乞至贵姓家。贵姓有女名曰执祥。在楼观上闻比丘音。受食便出则睹其形。发放逸意。其欲甚盛不得从志。气绝命终其身动摇。比丘见女兴不净想。即发念言。何谓法乐自所喜者。计空无实其犹泡水。无所可遵耳目鼻口身意。如腐肉揣革裹皮覆。从足至顶何所可乐乎。观无诤讼无想无念。法无内外亦无寿命。都无所有。心何所著亦何所受。永离欲瑕亦无得也。谛观诸法无所起者。爱敬菩萨即得不起法忍。则时欣喜踊跃在虚空。去地四丈九尺。绕舍卫城七匝。于时世尊。见爱敬菩萨升在虚空。譬如雁王。神足无碍自由自在。告贤者阿难曰。汝见爱敬飞游进止如雁王乎。对曰已见。佛言阿难。爱敬菩萨。因色欲行获诸佛法。降伏魔兵则转法轮。执祥女终转女人身。得生忉利紫绀天宫。自然化有四百八十里殿。万四千玉女俱共侍之。缘此之德而发慧心。自念何行得生此乎。即知本在舍卫为贵姓女色惑爱敬。缘斯贪欲寿终转女即为男子。自然神化无央数众。志于欲着乃获此报。岂况清净恭肃之心。供养奉事尽敬菩萨乎。今伎乐之娱安可久。常当诣世尊及观爱敬菩萨。于是天子与其眷属。各执天花栴檀杂香。威光巍巍俱诣世尊爱敬大士。皆以花香而供上之。前稽首礼绕佛三匝住。各叉手而赞颂曰

  诸佛无思念　　乐最不可量
  如来无心意　　则获尊上道

  我在舍卫为女人　　其大名德不可议
  号曰执祥长者息　　端正姝好宝严身
  以为父母所珍重　　有正觉子无所著
  号曰爱敬威神大　　入舍卫城家分卫
  我闻其音柔软妙　　欢喜之心取饭食
  即自往诣无极法　　如来之子爱敬道
  吾见彼已起乱心　　迷惑爱欲贪放逸
  假使不得从我愿　　即当寿终用活为
  当时不能发口言　　虽奉饮食不能授
  我以爱欲放逸故　　则在其处寿命终
  虽不能应于道行　　降弃瑕秽女人身
  得为男子佛所叹　　即时得生忉利天
  宫殿则尊微妙好　　以宝合成无等伦
  有万四千诸眷属　　诸婇女乐悉具足
  即时心自发念言　　吾何因缘得致此
  寻时识念如此事　　爱欲之心报应然
  见于爱敬心欢喜　　以放逸心而贪视
  缘是之德获是报　　犹如光明照好树
  当为正觉佛子弟　　所在游欣安住慧
  爱欲之心报如此　　何况有人供养者
  吾身今即如来子　　愿发求尊佛智慧
  便当修行恒沙劫　　未曾舍离大志性
  皆由善师因爱敬　　则当供养法奉事
  供事于道无亲属　　唯愿学求在觉轨
  修于尊妙道之行　　以放逸心所睹着
  寻时则转于女身　　便获勇猛男子形
  父母在家皆号哭　　臭死于地自捽[打-丁+滅]
  心自念言是蛊道　　冲口骂詈此沙门
  应时天子承佛威　　往诣父母具解说
  无得骂詈嗔沙门　　将无长夜获苦恼
  父母欲得知我不　　吾已踊至忉利天
  应时退转女人身　　得为天子光巍巍
  父母当至安住所　　首骂詈罪自悔过
  更求救护不可得　　唯有如来为道慧
  时父母闻佛音响　　彼时勇猛劝化之
  皆和心解眷属俱　　同时往诣能仁佛
  则共稽首两足尊　　即自悔过嗔恚心
  悉共恭敬于如来　　启问安住令决正
  以何供事应奉佛　　何谓顺法佛众僧
  唯为吾等分别说　　假使闻者无异心
  最胜则知心所念　　救世口则说如此
  其欲供养一切佛　　坚固道意御诸想
  父母亲属及男女　　具足五百无减少
  听闻大人之所讲　　同时皆发大道心
  最胜所言仁无异　　阿难听我之所语
  如菩萨行无端底　　善权方便住智慧
  爱敬菩萨愿如此　　假使女人爱敬我
  则当令转女人形　　速为男子人中上
  阿难且观此名德　　余人所因堕地狱
  以放逸心贪习色　　因爱欲变为男子
  其心天子供养我　　常以恭敬获丰安
  彼所供养难计劫　　当得为佛号尽见
  此五百人发道意　　亦当自致人中尊
  何人闻此不供佛　　其欢悦心安无量
  计其爱敬菩萨者　　所开化女不一二
  无量百千亿那术　　以爱欲心立于道
  则为药王大名德　　何因菩萨当有秽
  因缘尘劳施安隐　　何况供养奉事者

尔时贤者阿难白佛言。犹如有人近须弥山。皆随山光昭为金色。设怀欢喜欲义心奉道法心。得近菩萨皆获一类。趣诸通慧心性自然。我从今始奉持菩萨。如须弥山。犹如药王。名曰见愈。有清净心若嗔恚意。见此药者众病皆除。菩萨如是净不净心。淫怒痴心觐菩萨者悉为除愈。时佛赞曰。善哉阿难。诚如尔言

于是贤者大迦叶白佛言。甚难及也。天中天菩萨大士不可思议。在所游至。为诸众生现无畏。欲空无想不愿。声闻缘觉唯行此法。菩萨普护。转使更入诸通慧迹。以善方便将顺其心。终不秽厌色声香味细滑法也

大迦叶复白佛言。我可叹喻菩萨大士之所行乎。佛言可叹。迦叶曰。譬大旷野断绝无人。自然有墙。上至三十三天。唯有一门。无央数人皆入旷野。去之不远有一大城。其国丰熟米谷卒贱快乐难言。人民众多不可称计。其在彼城则如金刚城。旁有江江侧有路旷。路之中有黠慧人。聪识念义。怀愍欲度入旷野者。举声而盟称。去旷野不远。大城之安永无死惧。吾为导师来趣所乐。众人报曰。吾等不行于此不动。欲睹城像城自然现。尔乃往耳。时复有人解微妙者应曰。常往随仁所凑。吾等如是薄福之人。闻此声已不信不乐。不从其教不度旷野。彼微妙人则度旷野。观路由河。则乘而进路之。左右有百千丈深大溪涧。布诸草木四方作桥。则济厄路四出无碍。大贼从后追而不惧。贼自然却终不还顾。稍稍前行亦不恐懅。不左右视则见大城。稍近城郭心不狐疑。入彼城邑为无量人。现其仪式增益福祚。迦叶叹已陈。喻大旷野者。谓生死之难。墙至三十三天者。谓无黠所著恩爱之欲也。唯有一门者。谓大乘也。人入旷野者。谓众愚冥凡夫之士也。黠人发愿呼众人者。谓菩萨大士所乐度无极也。志劣不行欲见城者。谓声闻缘觉也。应曰当往随仁所凑则菩萨也。闻声不信者。谓外道异学众邪行也。度旷野者。谓奉精进至诸通慧修诸三昧也。路由河者谓法门也。左大溪涧百千丈者。谓声闻地也。右大溪涧百千丈者。谓缘觉乘也。大布置草木作四方桥者。谓善权方便慧度无极也。四出无碍者。谓菩萨四恩之行摄无量人也。贼追不惧自然却者。谓魔官属及诸猗行也。终不还顾者。谓忍度无极也。稍稍前行。谓为菩萨之所开化进度无极也。亦不恐惧者。谓以清净心发起众生志平等觉也。不视左右者。谓不志乐声闻缘觉之利也。则见大城者。谓达诸通慧也。稍近城者。谓见道功德习行佛慧也。心无狐疑者。谓晓智慧善权诸度无极。则能遍睹一切众生无所畏恶。适入城已为无量人。造现仪式增益福祚者。谓如来至真等正觉也。佛天中天适兴在世。则为菩萨立于名号广建利义

于是世尊赞迦叶曰。善哉善哉乃叹斯喻。说此言时万二千天与人发无上正真道意。佛语迦叶菩萨。德行不可称计。学谛微妙善权方便。大士所作。不为已举不他人施。不言有我亦不言彼。时慧上菩萨白世尊曰。何谓一生补处。而迦叶佛时。口说斯言。用为觐是剃头沙门。安能有道佛道难得。世尊尔时何缘说此。佛语慧上。且止族姓子。无得节限平相如来及开士行。所以者何。菩萨大士善权方便不可思议。其有正士。当作斯观缘是化人。族姓子听。善思念之。有法号曰善权方便。菩萨从定光佛已来。所兴之慧不可思议。随时之宜敢可发起。讲菩萨法。从见定光世尊以来。得不起法忍。无一瑕阙无所忘失。亦无乱心智慧无损。已得法忍所造菩萨。一念之顷七日成佛。有菩萨志。发意之间一劫之喻。为一切人所在示现开化众生。以智慧力欲得成佛大平等觉。无量亿劫称叹邪见多所发起。是为菩萨善权方便

又族姓子。诸声闻学设使自在。于三昧者未曾有也。不逮菩萨三昧之定。身亦不动心无所想。亦非众人身心所及。又使菩萨三昧正受不进不退。常以四恩救摄群萠。不失精进不为懈怠。而为众人讲六度无极。是谓菩萨善权方便

又族姓子。菩萨发意之顷。于兜术天逮正真觉转于法轮。阎浮利人不能自致。升兜术天听受经法。菩萨心念天上诸天能下至此。是故正士。于阎浮利而现成佛。是为菩萨善权方便

又族姓子。菩萨发意。能从兜术忽然没已。不由胞胎。一时之顷成最正觉。傍人有疑此所从来为是天耶。揵陀罗变化所为乎。若怀狐疑不听受法。是故菩萨现处胞胎。是为菩萨善权方便

又族姓子。无得兴念菩萨处胞。勿怀斯意菩萨大士不由精胎。所以者何。有三昧名曰无垢。菩萨大士以斯正受而自庄严。兜术天人谓菩萨没而无动摇。不睹菩萨游于胞胎。现处母腹而从胁生。弃国捐家寻坐佛树。示勤苦行普现悉遍无所不变。无有劳扰而无染污。所以者何。菩萨之瑞所化清净。是为菩萨善权方便

佛告慧上。何故菩萨自化其身。紫磨金色现入胞胎。慧上答曰。寂然清净明白之品。世尊曰然。其菩萨者处众生上则第一尊。是则化来。诸天人民所不能及。是为菩萨善权方便

何故菩萨在母胞胎。具足十月无见而生。人傥起念在母之怀。日月不足诸根不具现满十月。是为菩萨善权方便

何故菩萨生于树园不在中宫。菩萨长夜习在闲居。志乐寂寞行平等净。欲令天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺罗人与非人皆舍室宇寂然供养。此诸华香普流天下。使迦维罗卫国中人民欢喜悦预不为放逸。是故菩萨在于树下寂寞处生。不在宫馆。是为菩萨善权方便

何故菩萨从右胁生。若不如是众人有疑。则谓菩萨因由遘精。而处胎藏不为化育。众必怀结犹预难决。是故示现令人开解。菩萨虽从右胁而生。母无疮瘠出入之患。往古尊圣因时如然。所行无违。是为菩萨善权方便

何故菩萨母攀树枝然后而生。设不尔者众人当谓。皇后虽生菩萨必有恼患。若如凡庶而无殊别。欲为黎元示现安隐。母适攀树枝。志性柔和。则菩萨诞育。是为菩萨善权方便

何故菩萨安和澹泊忽然而生。其身清净无有垢秽。菩萨至尊三界之上。虽处胎中如日昭水。净无所著不增不减。故现胁生不与凡同。是为菩萨善权方便

何故菩萨适生斯须。帝释即下前稽首奉不使余天。其释无始立兹本愿。菩萨若生。当以净意而奉受之。亦为菩萨本德之征。是为菩萨善权方便

何故菩萨适见受已。行地七步亦不八步。是为正士吉祥之应。应七觉意觉不觉者也。自古迄于今。未有能现行七步者。是为菩萨善权方便

何故菩萨已行七步举手而言。吾于世尊天上天下为最第一。当尽究竟生老死原。释梵梵志及诸天子。彼时众会莫不遍集。设不现斯当各自尊。则怀憍慢。便不复欲礼侍菩萨。菩萨愍念外道梵志诸天之众。长夜不安必坠恶趣而受苦痛。是故菩萨举声自赞。吾于世尊天上天下第一。权慧超异独步无侣。当究竟尽生老死根。以此音告三千大千世界。其诸天子未有来者应声便至。尔时异学梵志及诸天子。皆共稽首敬礼赞音叉手归诚。是为菩萨善权方便

何故菩萨大悦而笑不怀轻戏。笑而不谄笑。菩萨兴念。一切众类本与我俱。发上道意无上正觉。恐畏懈怠放逸自恣。故为卑贱愚冥贡高。或音声者解一切法。至诸通慧精进敏达。使归命佛犹斯大哀。发起萌类除却放逸。见已愿果彼亦普具。以故正士现大欣笑。是为菩萨善权方便

何故菩萨清净无垢而复洗浴。释梵四天所见供侍。凡人初生皆当洗浴。菩萨清净随俗而浴况世人乎。故现此义。是为菩萨善权方便

何故菩萨初生之后。去到空闲于树下坐。然后入城。欲以具足诸根之本。示现中宫弦歌倡伎音乐之娱。然火四锭由斯现缘。令众学劝。弃离财宝乐升微妙。入家复出不兴异行。去家学道则坐佛树。是为菩萨善权方便

何故菩萨生后七日其母便薨。后寿终尽福应升天非菩萨咎。前处兜术观后摩耶大命将终。余有十月七日之期。故从兜术神变来下现入后藏。以是推之非菩萨咎。是为菩萨善权方便

何故菩萨学书射御兵仗伎术摴蒱戏乐。随世习俗现前因缘。三千大千世界诸所伎乐。经藏道要诗颂术数。神咒所疗言谈嘲调。示现悉学无所不博。欲令庶人不自憍慢。是为菩萨善权方便

慧上菩萨问大善权经卷上慧上菩萨问大善权经卷下

        西晋月氏国三藏竺法护译

何故菩萨而有室娶。菩萨无欲不尚配匹。其于离欲则为正士。所以示现眷属妻息。傍人怀疑。菩萨非男斯黄门耳。欲除沉吟故纳瞿夷释氏之女。缘此现生子男罗云。假论罗云胞胎生者则非义也。所以者何。罗云于天变没化生。不由父母合会而育。又是菩萨本愿所致。昔锭光佛瞿夷有誓。后世为仁妻殖其德本。不违久要故娉纳之。情无所在俗人扰动迷惑色欲殷勤恋着。菩萨示现妻子眷属。寻复舍国。或有人言。正士之妃端正姝妙。乃尚捐去何况吾等。又菩萨本始学道时。所有妻妇群从眷属。相敬重故各共发愿。世世与仁俱生生相侍随至成佛道。故广敷演清白之法。中宫婇女四万二千人发无上正真道意。其余群类悉度恶趣。以故菩萨现有眷属。其诸婇女以恩爱情自烦恼者。适见菩萨澹然清净如明月珠。则离色欲。假使菩萨化于所化颜姿容貌由若己身。尔时婇女与化人俱恣可所娱。各心念言。吾等今日与菩萨俱志慕永异。于时菩萨往阎浮树荫下。而坐禅思欢喜行安。由如化人所造之变。菩萨昔从锭光佛来。所见爱欲因缘之业。皆是无始感发之应。是为菩萨善权方便

何故菩萨于阎浮树荫而坐禅思。化七十亿诸所天子令发道意。又复欲使皇后见之。心自念言。会当舍家。是故菩萨坐阎浮树荫而寂思惟。是为菩萨善权方便

何故菩萨夜半出家。至于江流而自洗浴。感诸群生为现德本。悉当念言。所立之处功德自然清白法故。由此夜半出家无碍极乐事皆当舍弃。清白之法不可离也。是为菩萨善权方便

何故菩萨在兜术天劝化诸天。来下现生天人叉手。时到可去门自然开。菩萨有念。王傥怀疑闻此不了长夜不安。遭值恐患坠于恶趣。故化天人天人开门。诸天坐中举声称扬非菩萨咎。欲慰王心委之于天。由观斯义有所劝化。是为菩萨善权方便

何故菩萨弃国捐王而现舍去。人当解知菩萨畏生老病死是故出家。不为增避家室亲族眷属枝党。是为菩萨善权方便

何故菩萨自剃头须发。三千大千世界诸天龙神。揵沓和人与非人。无能堪见菩萨顶者。况能为尊除须发者。于时菩萨劝度众生自除须发。念白净王当起恨意。谁剃子首。从使者闻。自剃之耳。王乃默然。是为菩萨善权方便

何故菩萨取宝璎珞冠帻手付车匿。发起众念。菩萨为道。不复贪乐珍宝之饰。于一切物而无所著故皆释之。后世边地法效菩萨。吾等出家亦当请学。从佛法则猗四贤行一切无著。不为阴入狐疑出家。设不如是人当疑言。不知产业故出家也。是为菩萨善权方便

佛言。族姓子今且听。此菩萨何故六年志修苦行。为诸菩萨有殃罪故。故现勤苦。为诸群生权其方便。于斯菩萨所兴为也。迦叶佛时口发是言。髡头沙门耳云何为佛。是则菩萨善权方便当知是义。何故菩萨而有斯言。优多摩纳(晋言上志一名焰花)有五亲友及五百弟子。为大梵志贵族姓子。本学大乘。为恶知友所见迷谬。失其道意。其五亲友信外异学不从真教。修外道经不习佛法。自谓有道为彼师长。其身自号吾等是佛。五百弟子亦复如是。焰花学志以权方便入斯志类。因发言呵难提和曰。何所为佛。髡头沙门佛道难得用往觐乎。焰花稍稍化五族姓子及五百弟子在异学者。故发斯言何所是佛。髡头沙门佛道难得。佛语慧上。观于彼世焰花学志。时在别处与五亲友五百眷属俱共正立。于时陶家者名难提和(晋言欢豫)。往至其所嗟叹迦叶如来功德。谓焰花学志。来共俱往诣迦叶佛。焰花心念。此诸学志德本未满。设吾今叹迦叶如来道之功德。毁诸异学族姓子等。便当愕住必不俱行。以故焰花护其本愿智慧无极。因权方便故言髡头沙门非是佛。佛道难得智慧无极何所处乎。行智度者无彼此想亦无道想。焰花通达究竟空慧普无所著。善权方便随一切法故发斯言。焰花学志与五亲友五百弟子。至池水侧浴讫出水。乘马车侣五亲友。从弟子游行讲经。尔时欢豫承佛威神欲化彼师从。迎焰花乘及侣弟子。即相问讯言所从来。欢豫以诚答曰。觐迦叶佛还。焰花曰。髡头沙门非为是佛佛道难得。陶者闻之甚用不悦。以手捉发。卿不信者可俱往质也。焰花筹虑。欢豫志性安隐仁和未曾卒暴。今旋吾急终不忘也。吾及弟子宜当共侣俱观其道。佥曰唯然。于是陶者。焰花五友五百弟子。便共俱行觐迦叶佛。佛则为说前世所兴道德之本。心即喜踊。赞焰花曰。世尊道德权慧乃尔。何惜不早为吾等说。五友弟子见迦叶佛道德巍巍辩才无量。皆发无上正真道意。时迦叶如来至真等正觉。说大乘业开阐法藏不退转轮。五大梵志五百弟子皆得不起法忍。佛告慧上。族姓子听。焰花若以佛智慧叹迦叶尊毁异学者。五大梵志五百弟子终不从化。又无由得觐迦叶佛。用欲开化之故因行权慧。故发斯言。髡头沙门非为是佛佛道难得。得不退转无所不达不复疑道。是为菩萨善权方便

佛告慧上。菩萨所以随时如化现有余殃勤苦之行。设不然者沙门梵志清净奉诫。诸余黎民将无知之。懈怠不进。适相见已得无说之。是藏异藏。斯等长夜曾无利义。不得安隐则归恶趣。用众罪衅如来故现余殃未尽。菩萨都无罪盖之患。持戒沙门梵志。若说粗言即当自疑。不加精进不得解脱。欲建斯等犹豫志者。菩萨以权口发此言。缘是度之即当自说。吾等无智自责悔过。唯学道慧普行恭敬。又外异学贡高自由。以故如来勤苦六年非为余殃。所以者何。或有沙门梵志。食一麻一米清净自在。欲摄此等具足其愿故。菩萨日服一麻一米以为限度。若不时食不得不还致于圣道。菩萨发言。髡头沙门不得。是佛佛道难得故以罪殃六年苦行。六年之中所可开度。则非异学之所及知。而令外道五百二十万人住平等慧。所可见发诱化人民。是为菩萨善权方便

何故如来聚会四辈。诸天龙神及人非人。为讲说经初夜欲竟。佛告阿难。取中衣来吾体少冷。阿难受教即取奉进。上夜已竟入于中夜。复命阿难取上衣来。吾寒欲着。即复进之。中夜已竟入于后夜。复命阿难。取众集衣来。吾欲着之。即复重进。佛便服着告诸比丘。吾听出家学者一时着三法衣。假使寒者亦可复之。所以者何。后世边地寒凉国城不堪单薄。随其土地应着复重。佛无寒无热无饥无渴。所以者何为处寒土不着复重。或致疾病。或能悔退不能究竟求道之意。是为如来善权方便

何故如来坐于草蓐。为来世人出家学者。或贪鲜好床座榻机。志在安软不加精进。或有少福不得好坐氍氀毾[登*毛]重莚被蓐。怨望退却。心当念言。如来世尊身欲成佛。坐于草蓐不着好床乃成佛道。何况我等当慕好座。佛言所教随其习俗。重茵累蓐不妨于道。细软不悦粗坚不忧。人心难齐志行若干。故以权变现若干教。是为如来善权方便

何故菩萨复起饭食。傍无德者自饿求道。夫以饥饿不能兴慧。故安隐食因成道德。说菩萨法开化群萌。多所安隐不以勤苦。菩萨受食得用成佛。由斯逮于一三昧定。以一三昧住百千劫。是为菩萨善权方便

何故菩萨闲居求道。草蓐敷于树下。用过去佛不贪床座。坐敷说谛吉祥礼义。设使菩萨说法粗略则入利义。其有以草施菩萨者因发道意。佛时授吉祥之决。汝于方来当得成为佛。号离垢如来至真等正觉。是为菩萨善权方便

何故菩萨坐佛树下使魔云集。设不速趣无上正真道者。其魔波旬不敢至菩萨所。又族姓子。菩萨初坐树下。心自念言。谁于欲界四域最尊。人从教者当令诣吾俱战决之。尔时具足入诸通慧故使魔试。其魔兵师八万四千亿。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒。皆发无上正真道意。是为菩萨善权方便

何故如来已成佛道。正坐七日而不起行察树无厌。是诸天子见其德行变化感动。心大欢喜。各心念言。吾等当求斯如来心何所倚乎。宿夜七日一心专精求之不得。缘是之故乃观世尊三十二相。心益踊跃则发无上正真道意。当来之世亦逮如兹坐于佛树。由斯如来坐树七日。是为菩萨善权方便

何故菩萨得成佛已。劝率无数天人之众。梵天不请亦不说法。于是如来心自念言。其在欲界不可称计诸天集会。及魔眷属鬼神罗刹。设见菩萨师子吼步辄发道意。见欢喜者缘致无为。又族姓子。诣佛树下。菩萨即时放顶相光。普照魔宫及三千大千世界。于其光明出一音声。今释种子能仁之尊。弃国捐家今成无上正真之道。已过汝界多度人民不可赀量空汝国境。宜当寻往与共战斗。时魔闻斯甚大愁毒。严四部兵具足三十那术垓。俱往诣佛树。于时菩萨以智慧宝建立大慈。慧明之胜紫磨金臂。诸天龙神释梵所敬。时梵志念。梵天化我。我从梵生。莫能超踰。世无尊师。梵天为上。如来念曰。吾致梵天令众人见。诸天龙神皆倚于梵。梵天犹尚稽首礼佛。宜当劝助如应说法。若无劝请如来不说。承佛威神令梵天来以法助劝。假使众人敬念梵天当劝如来。于是梵天。自舍其宫来诣世尊。大梵劝佛转法轮。时六百八十万梵天皆发无上正真道意。悉叹颂曰

  佛尊无有极　　最胜不可及
  行善权方便　　是亦为如来

佛告慧上菩萨。如来所现余殃有十。是亦世尊善权方便。当了至诚。欲使如来有毛发瑕。不具殖德本。欲令有短行不具足。逮成正觉坐佛树者此亦不然。所以者何。畅清白法无有众瑕。族姓子。欲知如来皆以[打-丁+彗][打-丁+滅]诸不善法。世尊无碍。况复立秽而有余殃。佛为医王除一切病无有阴盖。祐众生故示现余衅。欲令众庶护身口意修清净行。由如尊贵族姓有子。各长王家习于乳酪。体生疮瘠上至颈项腹藏亦痛。当服医药饮乳乃除困而获差。父母念之喜其得瘳。又族姓子。如来至真为普世父。除群[黍-禾+利]恼使获安隐。以故现疾。人闻余殃不敢作罪。是为菩萨善权方便

又告慧上菩萨。往昔久远世时不知罪福。故为众人示现殃衅。如来故说吾为法王不离宿罪。汝等之类安得离殃。由斯有言如来永无余殃。譬如有人善学书疏计校之术。教诸童子欲令成就。无所不知不以为碍。小儿见闻则受学了稍稍达本。如来如是悉学诸法无所不博。示现余殃欲令众生具清净法。譬如有医始学治病。解方晓药应病救疗。既能自愈广能愈人转复嗟叹。锭光佛时。乃于彼世。有五百贾人入海求宝。有异心者。心罪甚重开其罪门工学邪术殃害剧贼。观贾人貌则上有船于时导师号曰吉财。护众贾人随时消息。凶人念言。今我宁可悉害贾人独取珍宝。于阎浮提有大导师名曰大哀。时寐梦中海神语之。贾众之中有一贼人兴大恶心。皆欲危没五百贾人。独欲取宝。假令事建罪不可量。所以者何。此五百贾人。皆发无上正真道意立不退转。设使遇害心不回还。由其殃罪。一一菩萨行得成无上正真之道。贼坠地狱若干岁数其罪乃竟。今仁导师当行权变。而令此人不更地狱若干之痛。使众贾人不被危害。七日思惟无余方便。念言。唯当取之危其命耳。假语众贾者则皆兴怒。当杀此人必堕恶趣。复重自念。设我独杀亦当受罪。吾宁忍之。若百千劫受地狱恼。不令贾人普见危害而令一贼坠地狱也。时大哀师则为说法。令心欣然踊跃卧寐。佛言。族姓子。彼大导师由众贾人兴于大哀。以权方便害一贼命。寿终之后生第十二光音天上。时大哀师则吾身也。以斯方便越千劫生死。死则升天。同船五百贾人。斯贤劫中五百佛兴者是。菩萨岂有罪患越除终始。弥百千劫不当察佛而有愆咎。如来所现为众生故。时以阙漏权现铁釴。如来蹈之威神所达。所以者何。如来之身则金刚也。又族姓子。舍卫城中有二十人。复与二十人共为怨敌。时二十人各欲摄怨而危害之。为最后世相伺方便。彼二十人欲害二十怨者。承佛威神寻诣如来。于时世尊化四十人。亦欲劝导一切大众。告尊者大目揵连。今于此地当有铁釴自然来。出入佛右足大指。语未竟釴在佛前。目连白佛。今拔铁釴着异世界。佛言不然。时大目揵连。以精进力欲拔铁釴。是三千大千世界为大震动。不能摇釴如毛发也。于时世尊则往梵天。釴辄随之。如来还坐釴则住前。是时如来右手取釴以足蹈上。目连白佛。如来本罪而获釴殃。佛时告曰。昔与五百贾人共入大海。时有一人心怀恶意。吾时害之是其余殃。时二十人闻佛说此。转相谓言。如来法王已得自在。尚有余殃不能灭除。况于吾等不受罪乎。即来诣佛悔过自首。如来应时为说经法分别罪福。令四十人入平等慧。三万二千人远尘离垢诸法眼净。因是如来示现铁釴。是亦菩萨善权方便

何故世尊已离众病示有疾病。使医王耆域而合汤药。佛时立戒二百五十。未久五百比丘在他树间行道。向欲终毕心怀狐疑。如来有教。唯以一药疗身众病不得习余。时佛发念。以何方便令诸比丘得习余药。所以者何。假使如来随意听者。则后世人毁四贤诫。是以如来行权合药任于耆域。时净居天语比丘言。诸贤者。宜更求药无得危命。则相谓言。宁自碎身不毁佛诫。天答贤者。今者如来则法王也。令置小便更求余药。可改所习而慕所服。于时比丘离疑犹豫。乃求异药病即除愈。昼夜七日得无著道。假使如来不习汤药。此诸比丘不得解脱。将来之世亦当如是。其身安隐然后得道。是亦菩萨善权方便

何故如来众德普具。又入聚落而行分卫空钵来出。如来无殃愍观后世边地诸国而兴慈哀。其有比丘。入于郡国县邑丘聚行分卫者。而身薄福所乞不得。心念。如来功德充盛无量福会。时行分卫尚空钵出。我等善本所殖不弘。岂可怨舍而不乞乎。故当分卫。用是之故入城分卫空钵来出。又云。弊魔化诸梵志长者家。使不供佛不施众僧。未曾有此其魔波旬。未敢作威娆固如来沮废福意。佛之圣旨所变现也。梵志长者有此异心。非是本意非佛鲜福。彼时众人无所施者。又见如来空钵来出。魔界天人见不获膳。世尊得无心怀怅惘。昼夜一心念如来及弟子众。将必忧悒见佛弟子。心不增减前后适等。七万天子自投佛前。如来如应为说经法皆得法眼净。是亦菩萨善权方便

何以故旃遮摩尼木魁系腹诽谤如来。亦非世尊本之余殃。佛之威神能取暴意。从置恒沙刹外。如来以权现斯方便。当来比丘。或有出家行作沙门。为人所谤有怀疑者。观佛世尊虽见讥讪。心不动转不却宿罪。念佛如来普胜之德。犹复若兹。况我等而无讥议。思惟此已益加精进。清净奉戒心不回转。假使暴意梦中诽谤。寿终之后不离地狱。如来悉知令护禁戒。所以者何。如来之德不舍众生。是为如来善权方便

何故异道害须多利。埋着胜树间。佛诸通慧普观无碍。知当兴怒。则以示现如斯比像设不以刃加须多利者。须多利或投余患。佛解知女寿命终尽。是故彼类相教杀之。缘邪异学身所犯害必反罪辜。佛以等慧而化立之。由斯所建增益群生功德之本。是以如来七日不入城。化六十亿诸天入道。过七日后其四部众。皆来诣佛听法。八万四千人获平等慧。三亿人得道迹往来不还果证。是亦菩萨善权方便

何故如来三月食麦。如来素达。虽梵志请佛不得迷忘佛所兴化。所以者何。今五百马者。昔佛弟子也。所从食已。前世皆学菩萨大乘。供养过去诸世尊矣。从恶友教犯众罪殃坠为畜生。彼时又有五百马师。有菩萨名日藏。本立愿生其中。普化斯等令发道意。使弘大乘化诸马师。本非马师。如来护彼。令诸马畜皆得受决。为缘一切如来不食。无所志愿。威德能化瓦石刀杖为美饮食。三千大千世界所有。悉为甘膳奇特之味。所以者何。世尊自然有大人相上味之味。以故当知。如来所化饮食皆美。耆年阿难未得大哀。心自念言。云何世尊舍转轮膳今乃服麦。佛知其念。以五百马师之德。时五百马皆识宿命得近道心。五百菩萨发大慈哀往觐如来。五百马师自减半廪以用供佛。捐五百马谷供五百比丘。马师及马皆自悔过。见佛众僧竟三月已。五百马命终生兜术天。为天所敬。如应说法。得立不退转地。当成无上正真之道。阿难得知所施供养。时宫中人得未曾有。来白佛言。我等生长深宫之内。世尊。阿难未曾习此安隐欢喜。七日不食。族姓子。当知如来之身无有罪殃。后世或有持戒之人。请诸沙门而不设供。故为彼现。是为如来为人所请。虽不供办不令其人堕于罪地。又五百比丘与如来俱三月一夏。四百比丘悉有欲态无清净想。设得美食欲意遂盛。用粗食故欲心则薄。三月之中可得罗汉。如来以斯诸学比丘及化菩萨。随时示现非罪殃也。是亦如来善权方便

何故如来告大迦叶曰。汝当说经。吾腰背痛。时八千天子。本弟子行迦叶所化。于时来会乐仰三宝。殷勤在行闻说觉意。设百亿佛为说经法终不能解。唯迦叶比丘能度之耳。故佛告之分别觉意。八千天子闻义得慧。其疾病者往会听经。各心念言。如来法王因说觉意病即除愈。吾等云何不听经乎。何以故。族姓子。欲化诸天及病比丘使承经道。示现腰痛。故如来曰。迦叶说经令我除病。是亦如来善权方便

何故如来舍夷国败而佛头痛。众人悉当念言。如来亲属不尽其寿。护黎庶意坐枯树下。告侍者曰。吾头甚痛。尔时诸天计有常者三千人会。刹利之众不可称数。闻告阿难头痛之咎。念言。如求尚有余殃。闻经寻化天人七千。是亦如来善权方便

何故披罗陀梵志以五百事而骂世尊。时佛默然。后更称誉。佛亦默然。应时自归一心悔过。无所复言。佛能厌却使不出言。投徙置于殊异之土。尔时会中诸天世人无数之众。见佛忍辱慧力平等心柔和雅。四千人发无上正真道意。如来彻睹当来有所化故现默然。非佛余殃。是亦如来善权方便

族姓子。听调达所生常与菩萨共相娆害。怀怨憎心欲相危害。是亦如来菩萨方便

佛告慧上菩萨。诸天往来有所求索。则为具弘施度无极。所以者何。多所饶益覆满诸愿发起一切。以何因缘兴斯行乎。假使众生安净自利。则不解施不知受者。是故诸天化从空来诣菩萨所。试求妻子头目手足国城丘聚。应时菩萨周满所欲勇慧无难。众人见之则效布施。奉尊所行无所矜吝。我等亦当发愿求佛。修习禁戒不敢毁失。顺菩萨法未曾违舍。捶骂不恚轻易不恨。则弘忍辱度无极。以斯教化无数之众。其诸天人见有怨来诣如来所。则长戒禁。是亦如来善权方便。非余殃罪。所以者何。敢来试者则皆权也。寻皆导利无央数人。取要言之。如来所现残有十殃。皆当知佛行权随时。众庶怀恶多崇非法。故为现应。非有殃也。使知去就至无上慧。如来所叹权宜最尊。皆非殃罪但示现耳。作是得是。闻者悚惧不敢为非。又族姓子。广宣善权时时乃说。非为下愚薄福祚者。亦非声闻缘觉所知讲也。所以者何。彼等未曾学善权方便。唯菩萨大士解畅深归。喻如闇夜家中然火。悉照室内妻子眷属。菩萨如是。其有闻善权度无极。则晓达菩萨一切所行。当勤顺学吾本所习。佛嘱累汝。族姓子族姓女。欲求佛道。其有讲说善权方便。若百千里当往受学。则蒙光明。所以者何。假能听受如斯像法者。则为显发一切经典。除诸疑网使无结恨。尔时诸天世人四部众咸皆叹曰。其有闻斯权便经者。非法器人多不信乐。佛说经已。七万二千人皆发无上正真道意。阿难白佛。当何名斯经。云何奉持之。佛告阿难。是经名善权方便所度无极随时品也。当持当行。佛说如是。慧上菩萨及比丘众。菩萨大士诸天龙神。阿须伦世人。莫不欢喜

慧上菩萨问大善权经卷下


弥勒菩萨所问本愿经

    No. 349 [No. 310(42)]

弥勒菩萨所问本愿经

        西晋月氏国三藏竺法护译

闻如是。一时佛游于披只国。妙华山中恐惧树间鹿所聚处。与大比丘众俱。比丘五百人一切贤圣神通已达悉尊比丘。其名曰贤者了本际。贤者马师。贤者和波。贤者大称。贤者贤善。贤者离垢。贤者具足。贤者牛齝。贤者鹿吉祥。贤者优为迦叶。贤者那翼迦叶。贤者迦翼迦叶。贤者大迦叶。贤者所说。贤者所著。贤者面王。贤者难提。贤者和难。贤者罗云。贤者阿难。如是之辈。五百比丘。复有菩萨如弥勒等五百人。其名曰增意菩萨。坚意菩萨。辩积菩萨。光世音菩萨。大势至菩萨。瑛吉祥菩萨。软吉祥菩萨。神通华菩萨。空无菩萨。喜信净菩萨。根土菩萨。称土菩萨。柔软音响菩萨。净土菩萨。山积菩萨具足菩萨。根吉祥菩萨。如是等菩萨。五百人

尔时弥勒菩萨从座起整衣服长跪叉手白佛言。愿欲有所问。唯天中天听者乃敢问。佛告弥勒菩萨。我当听所问。便问在所欲。如来当随其所欲。而发遣之令心欢喜。于是弥勒菩萨得听所问。踊跃欢喜白世尊言。菩萨有几法行。皆弃诸恶道不随恶知识中。佛告弥勒菩萨。善哉善哉弥勒。菩萨多所哀念。多所安隐。愍伤诸天及人。乃发意问如来如此之义。谛听常思念之。弥勒即言。唯然世尊。受教而听。佛言弥勒。菩萨有一法行。弃诸恶道不随恶知识中。何谓为一。谓寂静平等道意。是为一法

佛语弥勒。菩萨复有二法行。弃诸恶道不随恶知识中。何等为二。一者住于定无所起。二者方便别诸所见。是为二法

佛语弥勒。菩萨复有三法行。弃诸恶道不随恶知识中。何等为三。一者得大哀法。二者于空无所习。三者所知无所念。是为三法

佛语弥勒。菩萨复有四法行。弃诸恶道不随恶知识中。何等为四。一者立于诫。二者于一切法无所疑。三者乐处闲居。四者等观。是为四法

佛语弥勒。菩萨复有五法行。弃诸恶道不随恶知识中。何等为五。一者常立德义。二者不求他人长短。三者自省身行。四者常乐于法。五者不自念身常救他人。是为五法

佛语弥勒。菩萨复有六法行。弃诸恶道不随恶知识中。何等为六。一者不悭贪。二者除弊恶之心。三者无愚痴。四者无粗言。五者其意如虚空。六者以空为舍。是为六法

佛语弥勒。菩萨复有七法行。弃诸恶道不随恶知识中。何等为七。一者有善权之意。二者能分别于诸法宝。三者常精进。四者常当欢悦。五者得于信忍。六者善解定意。七者总智慧明。是为七法

佛语弥勒。菩萨复有八法行。弃诸恶道不随恶知识中。何等为八。一者得直见。二者直念。三者直语。四者直治。五者直业。六者直方便。七者直意。八者直定。是为八法

佛语弥勒。菩萨复有九法行。弃诸恶道不随恶知识中。何等为九。一者菩萨以脱于欲远离诸恶。不善之法无有想念。以得寂定欢喜。行第一一心。二者已除想念。内意为寂其心为一。无想无行便得定意。心为欢悦。行第二一心。三者离欢喜观常为寂定。身得安隐如诸圣贤。所说所观心意无起。行第三一心。四者苦乐已断。欢悦忧戚皆悉为止。所观无苦无乐其意清净。得第四一心。五者过于色想。六者无复说想。七者不复念种种想。悉入无央数虚空慧。八者皆过无央数虚空慧。入无量诸识识知之行。九者皆过诸识知之慧。无复有无之想。皆过诸无识之慧。便入有想无想之行。不见想得寂定三昧。是为九法

佛语弥勒。菩萨复有十法行。弃诸恶道不随恶知识中。何等为十。一者得金刚三昧。二者所住处有所进益三昧。三者得善权教授三昧。四者得有念无念御度三昧。五者得普遍世间三昧。六者得于苦乐平等三昧。七者得宝月三昧。八者得月明三昧。九者得照明三昧。十者得二寂三昧。于一切诸法具足。弥勒。是为菩萨十法行。弃诸恶道不堕恶知识中。于是弥勒菩萨以偈赞佛言

  世尊本布施　　妻子及饮食
  头目无所惜　　佛德度无极
  护禁无所犯　　如鹖爱其毛
  奉戒无与等　　功德度无极
  已现于忍力　　悉等诸苦乐
  忍辱为大势　　佛德度无极
  已了精进力　　无上德对害
  精进为大至　　佛勤度无极
  已断一切恶　　导师乐一心
  大慧寂为力　　佛净度无极
  清净慧自在　　自然无所起
  智慧常第一　　佛明度无极
  慧降魔官属　　树下得大智
  上义离诸秽　　佛力降伏魔
  世尊转法轮　　大身师子吼
  恐伏诸外道　　佛慧度彼德
  色妙无与等　　戒德及智慧
  精进度诸岸　　佛道过众德
  难譬不可喻　　无上大智慧
  常讲诸法宝　　光明导御众

尔时贤者阿难白佛言。未曾有世尊。是弥勒菩萨所愿具足。说法无缺减。讲法字句平等。所说法句无所缚着。讲经竟无乱。佛言。如是如是。阿难。如其所云。弥勒菩萨辩才具足。所说经法无所缺减。佛言阿难。弥勒菩萨不独以偈赞我。乃往过世十无央数劫。尔时有佛号炎光具向作王如来无所著等正觉。今现在成慧行安定世间父无上士导御法天上天下尊佛天中天。尔时有梵志长者子名曰贤行。从园观出遥见如来经行身色光明无央数变见已。心念甚善未曾有也。如来之身不可思议。巍巍如是光色妙好威神照曜。吉祥之德以为庄饰。愿令我后当来之世。得身具足如是光色威神照曜。吉祥之德而自庄饰。作是愿已。便身伏地心念言审。我当来之世得法身。若如来无所著等正觉者。如来当过我身上。于时世尊炎光具向作王如来。知贤行长者子梵志心之所念。便过其身上。适越其上已。便得不起法忍。于是佛还顾告侍者言。我所以过长者子梵志贤行身上。即时令得不起法忍。眼能洞视耳能彻听。知他人心中所念。自知所从来生。身能飞行神通具足。佛适过梵志贤行身上。便达众智五通具足无所亡失。即以偈赞佛言

  往来世到十方　　人中尊无与等
  唯志道过诸行　　愿稽首觉导师
  以过诸世间明　　及摩尼火炎光
  佛光明为最上　　愿稽首觉导师
  如师子一鸣吼　　诸小兽无不伏
  佛讲法亦如是　　悉降伏诸异道
  眉间相清且彻　　威无量如积雪
  其光明照三界　　佛在世无与等
  圣足下生相轮　　其轮妙有千辐
  此土地及山陵　　不能动无上尊

是时佛告贤者阿难。欲知尔时长者子梵志贤行者。今弥勒菩萨是。贤者阿难即白佛言。弥勒菩萨得不起忍久远乃尔何以不速逮无上正真道最正觉耶。佛语阿难。菩萨以四事不取正觉。何等为四。一者净国土。二者护国土。三者净一切。四者护一切。是为四事。弥勒菩萨。求佛时。以是四事故不取佛。佛言阿难。我本求佛时。亦欲净国土亦欲净一切。亦欲护国土。亦欲护一切。弥勒。发意先我之前四十二劫。我于其后乃发道意于此贤劫以大精进。超越九劫得无上正真之道成最正觉

佛告贤者阿难。我以十事致最正觉。何等为十。一者所有无所爱惜。二者妻妇。三者儿子。四者头目。五者手足。六者国土。七者珍宝财物。八者髓脑。九者血肉。十者不惜身命。阿难。我以此十事疾得佛道

佛语阿难。复有十事疾得佛道。何等为十。一者以法立于诫德。二者常行忍辱。三者常行精进。四者常一其心。五者常行智慧度于无极。六者不舍一切。七者已得忍心等于一切。八者不习空。九者得空法忍。十者得无想之法。阿难。我以此十事。自致得佛道。佛语贤者阿难。我本求佛道时勤苦无数。乃得无上正真之道。其事非一。佛言阿难。乃过世时。有王太子。号曰一切现义。端政姝好。从园观而出道。见一人得疾困笃。见已有哀伤之心。问于病人。以何等药得疗即痊。病人答曰。唯王身血得疗我病。尔时太子。即以利刀刺身出血。以与病者。至心施与意无悔恨。佛语阿难。尔时现义太子。即我身是。阿难。四大海水尚可升量。我身血施不可称限。所以尔者求正觉故

佛语贤者阿难。乃往过世有王太子。号曰莲花王。端正姝好威神巍巍。从园观出游道。见一人身体病癞。见已即有哀念心。问于病人。以何等药疗于汝病。病者答曰。得王身髓以涂我体其病乃愈。是时太子即破身骨。以得其髓持与病者。欢喜惠施心无悔恨。尔时太子即我身是。佛语阿难。四大海水尚可升量。身髓布施不可称计

佛语贤者阿难。乃往去世有王号曰月明。端正姝好威神巍巍。从宫而出道。见盲者贫穷饥饿随道乞丐。往趣王所而白王言。王独尊贵安隐快乐。我独贫穷加复眼盲。尔时月明王。见此盲人哀之泪出。谓于盲者。有何等药得愈卿病。盲者答曰。唯得王眼能愈我病眼乃得视。尔时王月明。自取两眼施与盲者。其心静然无一悔意。月明王者。即我身是。佛言。须弥山尚可称知斤两。我眼布施不可称计

佛语贤者阿难。弥勒菩萨本求道时。不持耳鼻头目手足身命珍宝城邑妻子及以国土布施与人。以成佛道。但以善权方便安乐之行。得致无上正真之道。阿难白佛。弥勒菩萨以何善权得致佛道。佛言阿难。弥勒菩萨。昼夜各三正衣束体。叉手下膝着地。向于十方说此偈言

  我悔一切过　　劝助众道德
  归命礼诸佛　　令得无上慧

佛语贤者阿难。弥勒菩萨以是善权。得无上正真之道最正觉。阿难。弥勒菩萨求道本愿。使其作佛时。令我国中人民。无有诸垢瑕秽。于淫怒痴不大。殷勤奉行十善。我尔乃取无上正觉。佛语阿难。后当来世人民。无有垢秽奉行十善。于淫怒痴不以经心。正于尔时。弥勒。当得无上正真之道成最正觉。所以者何。弥勒菩萨本愿所致。佛语贤者阿难。我本求菩萨道时。欲护一切悉令得净。处于五浊淫怒痴中。乐在生死。所以者何。是诸人民多为非法。以非为是。奉行邪道转相贼害。不孝父母心常念恶。恶意向兄弟妻息眷属及他人。轻易师和上。常犯男子垢浊转相食啖。愿处是时世于中为佛。若郡国丘聚县邑。但说众恶转相贼害。瓦石相击杖相挝拨。便共聚会转相骂詈。自还其舍设置饭食。以毒着中欲害他人。起想垢浊转起诽谤。伏匿过恶还相发露无复善意。佛言阿难。我以大哀普念一切。为此辈人讲说经法。贤者阿难闻佛说此。即白佛言。未曾有是天中天如来等正觉。能至勤苦普弘大意。调御弊恶令得成就。为除重担具足法宝。为此辈人说其经法。佛言。如是阿难。如汝所言佛能忍此尔。乃应如来等正觉。教化刚强为除众冥。用佛法德具足之故。乃为此人说其经法。阿难白佛言。我闻如来坚重精进等心如是。衣毛为竖。此经名为何等。云何奉行。佛言阿难。此经名为本愿当持慈氏本行弥勒所问。当善持之。佛说经已。弥勒菩萨。贤者阿难。贤者大迦叶诸大弟子。及众菩萨。一切会者。诸天龙神干沓和世间人。闻经欢喜。前为佛作礼

弥勒菩萨所问本愿经


毗耶娑问经

    No. 354 [No. 310(49)]

    毗耶娑问经翻译之记

菩萨方便。摄化众生。必以大悲引邪从正。毗耶娑仙即其人也。为导群迷。令识因果。将诸异见。至如来所。归命咨启。听闻正法。因其请说。即以名经。故因此部毗耶娑问魏尚书令仪同高公。愍诸错习。示其归则简集能人善辞义者。在宅上面出此经典。正求法人沙门昙林。婆罗门客瞿昙流支。兴和四年岁次壬戌。月建在申。朔次乙丑。建初辛已。甲午毕功。凡有一万四千四百五十七字

毗耶娑问经卷上

        元魏婆罗门瞿昙般若流支译

如是我闻。一时婆伽婆。游阿踰阇强伽河岸。与大比丘众俱。彼比丘众。所作已办尽一切漏。无有障碍离有不退。勤为禅诵加趺而坐。随何处坐有在地处二人相随如法语论。群行如鹅如鸳鸯者。有在空舍有依树根。皆悉行禅。能取如来法之光明正法威仪。复有无量菩萨众俱。彼诸菩萨。无量功德名称普闻。彼处复有无量百千种种树林。多有淫欲俱耆罗鸟孔雀鹅鸟群蜂等声娑罗枳树枝叶垂布。如是处者欲心懈怠。喜睡频申皆悉远离。常有无量善香妙华

尔时佛告诸比丘言。汝诸比丘常当勤行。作所应作持戒正行。尔时世尊。与慧命阿难陀。长老大迦叶。长老舍利弗。长老薄居罗。长老利波多。阿若居怜等大声闻俱。欢喜语说

尔时西方有光明相犹如日轮。时阿难陀漏未尽故。见彼相已。即白佛言。云何世尊。西方分处焰色光明甚有威德。佛言阿难。于此世界有五通仙。名毗耶娑。揵陀迦离妇人之子。有五百仙以为眷属。住在彼处勤修苦行。不食而斋其身瘦瘠有命而已。读诵不住以为庄严。其名曰阿斯仙童子那罗提娑裴若波耶那那荼延那迦摩延那商枳啰娑鞞轲那娑徒啰陀等。诸大仙人相随经行

即于尔时。毗耶娑仙。亦见世尊与诸比丘多千眷属之所围绕。诸根调柔心意寂静。在于禅定离欲安乐在树林中。毗耶娑仙。既见佛已思惟念言。此人应是一切智者。名称普闻。彼必应是不妄语人。如是如来胜色具足。诸相成就甚为希有。世未曾有。如是色相胜妙希有。如是世尊。舍王欲乐。舍转轮王富乐自在如舍毒食。六万婇女第一端正。一切舍已而便出家在林中住。仙人众中有一仙人。名那罗陀。既见世尊心生欢喜。以妙伽他。赞如来曰

  青色树林中　　谁光洋金色
  如净毗琉璃　　如日出云山

时彼大仙及诸仙众。闻是说已心喜开眼。皆悉合掌欲向佛所

尔时佛语诸比丘言。汝等比丘见阎浮提。如是诸仙系缚手足。自悬着树不食而斋。着树皮衣卧在尘土。若在石上有以两手合取食已开手而食。或有食风。有十五日不食而斋。或有一月不食而斋。头须发爪悉皆长利。寅旦中暮三时读诵有种姓财有福德财。先咒物已置于火中。而供养火在地而卧。有在露地有在树下。有悬自手着树而睡。或有蹲踞如是睡者。或有在水如是睡者。有以五热而炙身者。有身逼火自炙卧者。有在大焰。下风卧者。有卧棘刺。有日炙身受苦求福。自诳其身得处便住。种姓胜上心以为足。心以为喜。离无上智。诸比丘。此大仙人而不能知生死出要。以欲痴故。还生有中。自谓正行不知是邪。尔时彼诸比丘。归命如来。白言世尊。我等梵行真正具足。和集相应得离生有

彼毗耶娑大仙人等。以阿罗汉威德力故。而生畏惧。安详谛视。心意敬重一心正意。与诸仙人眷属相随。绞摄长发并在一箱。以好缝绳角络其体。形色不白端摄身仪。二眼皆黄头发无腻。绞结相着块聚非一。手执三奇杖。置瓶之物世中最丑。种种语言悉皆善巧因成就语。蹑空而行到如来所。白言世尊。应知此义。我何因缘。并诸眷属今来到此。佛言。大仙一切有生。一切诸法。我悉知之

尔时慧命阿难陀白佛言。世尊。如是大仙仙众围绕。心有正知。有种种知。细知尽知。知而不畏长发不理。为是何人。佛言阿难。此是仙人。名毗耶娑。婆罗门法是其所作。造四毗陀善知声论。知种种书。时彼一切阿罗汉人。见毗耶娑大仙人已。作是思惟。彼人受苦勤劳持戒为何所得。此毗耶娑。生死苦恼未得解脱。彼阿罗汉如是思惟。此毗耶娑。来至佛所。云何问难。为问因缘。为问无我。时毗耶娑。问世尊言。佛出世难。今诸仙众和合来此。我少难问。唯愿且住为我解说。佛言大仙。恣汝所问随汝所念。皆悉可问我为汝说

时毗耶娑。问言世尊。云何布施。何故布施。何义名施。云何施主。何义施主。云何施人而非施主。云何不与得名施主。云何死已施福随行。施福云何。为有形段。聚集可见为不可见。施主施福为在何处。为在受者为在施者。云何世尊入涅槃已。供养塔等而得福报。佛入涅槃谁为受者。尔时世尊语毗耶娑大仙人言。汝问此法甚为微细。汝有辩才不可思议。能如是问。尔时长老舍利弗。发白面皱眉垂覆面。偏举一眉长引气息。谛观思量。见已而言。此毗耶娑大仙人主。有大名闻。一切人知。一切人说。岂可不知。同如世间愚痴小儿无智慧者。舍说因缘舍说无我。种种深法种种善如智。言语已而问如是布施之法

尔时慧命阿难陀。顶礼佛足。白言世尊。此毗耶娑大仙。所问布施果报我亦能说。佛言阿难。此则非时。若问如来声闻人说。此非所仪。且止阿难。无此道理

尔时慧命舍利弗白佛言。世尊。随彼仙人何意而问。我亦能说能满其意。佛言舍利弗。汝语太卒心不思量。长老舍利弗。勿作是语。此不相应。若如是者我声闻人则不相应。若来问我声闻说者。此不相应。则有人言。彼如来者非一切智。当有人言。毗耶娑仙往问如来。自不能说遣声闻说。或有人言。彼如来者有我慢见而不自说。尔时彼诸比丘。于世尊所生信净心。白言世尊。彼大仙问。如来能说能断彼疑

尔时世尊语毗耶娑大仙人言。汝听施报。复有施分。何义布施。既布施已自食自净。施已报转故名布施。以何义故名为施主。如是问者。大仙当听。若人有物彼信心生。信心生已以财付人遣向他国。彼人将物向他国施。彼人布施财主得福非施者福。彼所遣者虽持物施而非舍主。若人自物自手施者。则是舍主亦是施主。大仙当知。有三十三不净布施。何等名为三十三耶。一者有人邪心倒见。无净信心而舍财物。如是施者非净布施。二者有人。为报恩故而舍财物。则非布施。三者有人。无悲愍心而舍财物。亦非布施。四者有人。因欲心故而舍财物。亦非布施。五者有人。舍物与火亦非布施。六者有人。舍物与水亦非布施。七者有人生如是心。舍物与王望王识念。如是舍物非净布施。八者有人。以畏贼故舍物与之。如是施者亦非净施。又复更有五种舍物。皆非净施。何等为五。一者施毒非净布施。二者施刀非净布施。三者教人取肉而施非净布施。四者有人。所摄众生平等施与和集养育望得其力非净布施。五者有人。为名闻故而舍财物非净布施。十四有人。为歌戏故。与伎儿物非净布施。十五有人年终月尽。破散财物非净布施。十六有人。屋舍因缘而舍财物则非布施。十七有人。善友因缘以他财物。受与余人非净布施。十八有人或有田地。或在舍宅。或有谷聚。或有麦聚。鹿鸟所食鼠等所食。无清净心非净布施。十九有人。为学作故与工匠物。如是施者非净布施。二十有人身有病患。恐命尽故。舍物与医非净布施。二十一者若人打他若骂他已心悔生愧。舍物与之非净布施。二十二者若人施已。心则生疑为有报不。如是施者非净布施。二十三者若人施已心中悔热。如是施者非净布施。二十四者若人舍物与他人已。如是思量。若其有人取我物者。皆悉属我为我所秉。如是施者非净布施。二十五者若人施已如是思量。如是施福唯钟我身不属他人。如是施者非净布施。二十六者若人年老舍物而施。又非中年后时病困。死时欲至。脉节欲断。苦恼所逼欲入死道。无清净心。无信净心。阎魔罗使见之生笑。兄弟诸亲啼哭悲泣。至如是时舍物而与非净布施。二十七者若人为名舍物布施。如是我名他国遍闻某国某城大施之主。彼如是施非净布施。二十八者若与余人迭相憎嫉。见彼舍物多行布施。见已心慢不能堪忍。以嫉彼故舍物布施。非净布施。二十九者食他女故。为种姓故。舍珠舍金。若银金刚。若毗琉璃。缯绢衣裳及兜罗绵。造作敷具。如是舍物非净布施。三十者有人如是思惟舍物与人。我无儿息大富饶财应当舍物而行布施。如是施者非净布施。三十一者若复有人心生简择。如是念言。若与此人则有福德。若与彼人则无福德。如是施者非净布施。三十二者若人布施。舍离贫穷衣裳破坏垢腻之者。与多丰乐大富之人。非净布施。三十三者若复有人望好花果。舍物而与非净布施。大仙当知。此三十三垢染布施。而舍财物彼施报者。如以种子种之碱地烂坏不成。大仙当知。如是之人非不布施不得果报。复次大仙。譬如有人随何所取得种子已种之荒田。彼种子界地界相依。须得天雨种子变坏。虽有牙生不得花果。此布施分不得花果亦复如是

如是说已。毗耶娑仙。合掌向佛而作是言。如来世尊一切智人。以相应语说布施报。已作利益安乐众生。又复世尊。云何布施不失果报。有人持戒有不持戒。二俱施与。此义云何。佛言大仙。汝今善听布施报法。若有心信一切施与。故名布施。不畏未来而行布施。不轻毁他行布施者。乃名布施。大仙当知。若复有人不简福田。若有戒人。若无戒人。心信开眼。生爱念已。舍物施与。心常普缘一切众生。大仙当知。彼人施主。大仙当知。有五种施施主满足。何等为五。一者时施。二施行人。三施病人及瞻病者。四施法器。五施欲行异国土者。是为五种。复有五施。何等为五。一者法施。二资生施。三屋宅施。四灯明施。五香鬘施。是为五种

大仙问言。何者净施。佛言大仙。若人有信缘于众生。而生慈心常心喜心。舍物布施。彼一切净若愿解脱。如是布施则为清净。复有五种无上布施。何等为五。一施如来则为无上。二施众僧则为无上。三施法器则为无上。四施父母则为无上。五施王者失位贫穷则为无上。如是施者是上布施。若施老人孤独病急。是大布施。若为王嗔一向舍弃系缚欲杀。若诸急难为救彼故不顾自命。为舍财物是大布施。施病人药是大布施。若于持戒具足众僧。随时施与是大布施。施求智人是大布施。若施畜生有怖畏者。所谓训狐乌鹿等畜是大布施。若人贫急施随所须是大布施。大仙当知。此为大施。常应正修。若复有人为他所遣持物布施。即有净心同得施福。若复有人见他布施。心生随喜。亦得施福。若人劝施。若人施物。如是等人。皆得大福

复次大仙。如汝问言。云何世尊入涅槃已供养塔等得福报者。大仙当听。若人于我入涅槃已。当设供养。若复有人我未涅槃。今现在世供养我者。所得福报。此二平等。何以故。法身如来非是色身。若人于今现在供养。若我灭后而为供养。心平等故得福无异。大仙当知。如转轮王遍敕诸国。一切人民从今日始。勿复杀生。莫作妄语。彼有一人闻王敕已。虽不见王善护王敕。如是之人虽不供养转轮王身。王于彼人心生欢喜。如是之人。善护王敕。以不杀生善业因缘报生天处。大仙当知。若人不见我身色相。不学戒句为何所得。若人见我而心邪见。如提婆达入地狱故。若人于我入涅槃已。善学戒者彼胜应知。大仙当知。今我色胜证一切智。无信众生能令学戒。况有信者。若人于我入涅槃已而为供养。与现供养等无有异。大仙当听。如汝所问。布施福德为在何处。如是问者。譬如苇草丛密稠穊于中火起。若雨堕时即没彼处。如是如是。随何施主。布施具足福德和合。信雨既堕如是福德。即依施主不余处去。大仙当知。如是施福非有聚处。非有形相

如是施已施者身亡。施福不离如影随形。是名施者得福报果。果福不失。譬如甘蔗若蒲桃子。如其不压不得其汁。压之则得非甘蔗中蒲桃子中。现前和集有汁可见。非在节中亦非无汁。如是如是。布施财物。如是施报于彼施主。非住手中。非住心中。非住腹中。而是施报不离施主。犹如彼汁不离甘蔗若蒲桃子。如是施报不离施主。未熟不受。命行不尽不得施报。譬如树王尼拘陀子。其子微细种之在地则不可见。至树生时方乃可见。施主施福亦复如是。和合熟时乃得果报。譬如商人所赍至少入于大城。彼城功德少物治生。所获乃多具足而得。施亦如是。施时虽微得福报大。又如蜜蜂采取花味而不损花。施主如是。随何布施得果报力。则是施主。如是大仙。施主布施。福德势力。言施主者。以自施故得名为施

云何受者。受他所施能消他物。故名受者。又问云何为施福者。于世间中能救能护。能令满足得人天身。故名福德。言他世者次第传生至后世身。故名他世

尔时毗耶娑仙白佛言。世尊。我离疑心决定施分。复更有疑。世尊。此识云何于身中转。识云何见。云何于身而生贪乐

佛言大仙。譬如国王住于城内。怖畏他军先作坑堑周匝绕城。备具粮食弓箭刀楯种种器仗。多集勇健能斗战者。立健人憧。亦多聚集年少健人。给以食粮。敕诸酒肆多办好酒。摄出家人布施供养。以好财物摄受诸人。既如是已。唱声敕言。安住勿动。各严器仗手执弓箭。身着铠钾。拔刀警防。如是诫已。他军来至多有象马。是时国王安慰军众。作如是言。尽力勿畏。城壁若有不牢之处。当好防护日日常尔。如是乃至福德尽已。为他军众之所破坏。俄尔败散舍国而去。识亦如是。住身城中诸入中王。见无常军欲至生畏。即时造作信心坑堑治界崄岸。着忆念铠发勤精进。法藏为酒善调心马。彼时如是敕诫诸入作所应作。若有大力有无量力。无常军众来逼身城。速着施钾速取智刀。惭愧机关安置相应。护持实戒。如是正住。彼无常军忽然而至。即时共斗迭互相违无常军胜识则舍去。如城中王舍城而去。识亦如是。和合身中根大界中。既破坏已。六入失已舍彼身城。如坏城王舍城而走。彼王如是既舍城已依止余城。识亦如是。舍此身已摄取余身。应知此识如王无异

尔时毗耶娑仙白佛言。世尊。如是识者云何知身。若有福德若无福德。此识云何作如是知我舍此身。佛言大仙。譬如行人路遇大水其水泛涨。为渡彼水故上大筏。彼水既长奋波乱动。而复甚浊多饶恶虫。谓那迦罗舒舒摩罗水蛇恶鼋。有大恶风乱吹旋转。以彼筏故得到彼岸平安不乏。如是之人。于彼恶水大畏恶处。既得脱已绕筏三匝。于彼木筏转生爱心。爱心生已如是思惟。善哉此筏能令我渡如是大水

如是大仙。又复更有福德众生。身既死已识如是念。由我此身得生善道。天中而生。我于人身得利不空。我此死身犹如牢筏。能令我度恶道大水。我身大善合应供养。如是之身不诳于我。生死过中与我天处。如是念已。即于彼身。生爱念心。彼身如筏。舍彼身已去向他世

若复有人身无福德。彼人心识。譬如有人身上烂筏渡于大水。然彼筏木或出或没。彼人怖畏心生疑虑。我于今者将死不久。如是之人依彼烂筏。甚大怖畏随流下退至饶师子虎等恶兽大怖畏处。然后得渡。彼人如是既得渡已。于彼烂筏生嗔怒心。骂彼烂筏作如是言。颠倒恶行。此水泛涨多波浊恶。云何如是。令我遂到如是恶处。我于烂筏竟得何力。用此筏为即便弃舍。如是如是。众生心识。依无福身随流下退。堕于地狱呵责此身。作如是言。我得何力我已报得如是恶身。如是身者犹如羯那。我负此身如负羯那。我今甚恶因此烂身到地狱门。犹如莲花自丝所缚。大仙当知。识亦如是。若善福德如依善筏得渡生死。若无福德如依烂筏。则堕恶道。彼二种身。一有福德。一无福德。应如是知

又复此识转舍此身。得第二身。初在胎藏一七日中如是忆知。我某处退而来至此。亦能忆知前所作业。我作此业。若作善业。心则生喜既住藏中。母心喜笑多有胜相。颜有笑容皯不生。面有胜色随所行动。多用右足蹈地压重。无有因缘手摩右胁。喜鲜白衣。着则严好。众生如是有福德识。住母胁中如是相现

大仙当知。若无福识初受生时。一七日中则能忆知。我某处退而来生此。亦能忆知前所作业。如是念云何作恶业。如是忆念心则愁忧。以心忧故母相外现。彼无福德无善众生。住母胁中有外相出。身体臭恶而复瘦瘠。心愁忧恼数唾不止。皱面怒眼。如是众生初在胁中。即令彼家衰祸得病。如是恶业无福众生。欲出胎时或能杀母。或藏中死。无福众生有如是相

尔时毗耶娑仙白佛言。世尊。此初识心始入胎时。何所忆念何所见知。佛言大仙。彼识初生如是忆念。见树林中戏乐之处。宫殿楼观地水屈曲。平泽宽博。种种屋舍。此阎浮提。多有爱人。父母兄弟。如是见已极生爱心。福德和集迭相摄受。有施物者。有受物者。能知过去宿世之事。忆念过去无量百生无量千生。彼识如是数数忆念。既忆念已心生爱喜。能如是知。我此母者过去已曾五百世中与我为母。彼既如是心忆念已。于彼生处不生愿乐。心得离欲作如是心。我于此处数数生死。我于今始不用生死。不用有摄

如是说已。毗耶娑仙问言。世尊。如是识者。于生死中得离欲耶。佛言大仙。此则非时此则非处。彼时彼识无色不见。无有光明。如是识界非于此处而得离欲。于有为中非是不生。若如是者一切众生。有福德者无福德者。皆得涅槃。彼义如是。大仙应知。若彼识心如是思念。彼识则有如是胜力。应如是知非是身力。所言识者。何故名识。集故识思。知故名智故。名识识。识义如是。大仙应知。尔时世尊。即说偈言

  护一切怨家　　聚集作烦恼
  有知有不知　　痴慧和合行
  见慢无明等　　一切皆识知
  此三不离识　　非余处别有
  双相应说识　　一轮非是车
  二轮不能行　　有人复有牛
  车辐辋和合　　是二轮相应
  复以绳系缚　　如是为行车
  如是身之车　　彼以界和合
  复有根和合　　识见彼身车
  脉节等和合　　喉脉根系缚
  发骨齿头等　　甲皮之所覆
  胁及肠处胃　　并心肚与肺
  彼一切和合　　具足故名身
  识王身为车　　身车中行坐
  一切法皆知　　如是名为识

复次大仙。此识微细无色无质。非是可见。识非有色非青等色。色中无根。识若离根则无境界。若人心中惊动怖畏。若疑思量。如是一切皆是识力

尔时毗耶娑仙白佛言。世尊。一切众生本性云何。云何生天道。云何生鬼道。云何生畜生。云何生地狱。云何生善根。何者善根而生天中。以何业故生畜生中。以何业故生饿鬼中。以何业故生地狱中

佛言大仙。汝当善听我为汝说。凡夫众生退于本性。若生福德。此法乃是一切智知。非五通者所知境界。非天非梵阿迦尼等之所能知。是一切智所知境界。此法尚非声闻所知。况余能知。大仙当知。若我弟子声闻之人。已离三垢证得初果。所知境界诸余大天天中天等一切不知。非汝大仙之所能知。乃至不能知其少分

如是说已。毗耶娑仙。心即思惟如是念曰。生死诳我。如是念已。礼如来足。白言世尊。我今老弊破坏之身。无有忆念不能得果。不能荷负菩提重担。我于今者归依世尊。归依于法离三有僧。我从今日乃至命尽受三归依。并弟子众。一切如是。唯愿世尊。善为我说令我眷属大获善利。世尊乃是一切智日除烦恼闇。唯愿世尊。说此本性。众生本性。退生天中。佛言大仙。今正是时。我为汝说。大仙当知。若人以花香鬘而施。心乐修行信心相应。命终得生鬘庄严天。又复大仙。人欲死时身有善香。是花熏香又欲死时。上见花网有种种色以散彼人。尔时诸亲父母兄弟诸眷属等。手执华香而供养之。悲号啼哭。彼人尔时面色腻润目视不转。手足正直。如是舍命。彼欲死时见有胜相。所谓见丘见鬘庄严。见有百千端正妇女绕天宫殿。彼人见已而语兄弟诸亲等言。我于梦中见有丘聚种种宝珠。诸庄严具散种种花。若彼病人如是说者。应知此相命终得生鬘庄严天。彼人欲死则见父母房室和合。见已即生。又复彼时鬘庄严天。有二种根和合行欲。如阎浮提男子不异。有一胜法不净不出。彼心欲发迭相知已。身则和合有爱风出。而受欲乐即于彼时。经七日中住天女藏。七日满已。右胁而生即于生时。有天善香第一可爱。有种种花相系为鬘生在胸前。彼时复有妙香普熏满一由旬随风遍行。彼时复有杂色鬘生。所谓白色黑黄赤色。毗琉璃色。阎浮汁色。清净胜妙钵头摩色。种种杂色。铜色。火色。如是妙鬘乃至未死。不萎不蔫。常有善香。以是义故名鬘庄严。彼鬘庄严天宫之处。有妙天树不长不短。其汁极甜味如甘露。其枝垂下而复清净。种种树林处处和集。彼树有果。八分和合天味相应。彼果形量如频骡果。随彼天心忆念何食。于彼果中随念皆得。应知彼天食如是果。不名揣食。于彼地处远离棘刺妙花庄严。复有地处有青软草。复有地处金沙遍覆金角上出。复有卧处自然而有种种敷具。复有天女清净无垢。妙衣庄严偏举一眉。而作戏笑种种衣服庄严其身。又于彼处第一胜乐。行住具足于彼天年寿二百岁。命欲尽时。则有五相。何等为五。一谓彼天所依之树枝心萎蔫头低卷屈。其花失香。二于彼树心不喜乐。三则鬘萎。四天风凉变为热触。五诸天女心生怜愍。皆悉忧愁。一切同声。而说偈言

  具足天甘果　　饶种种天树
  多有天婇女　　天胜妙乐处
  天中福德尽　　舍已而离去

彼诸天女。围绕天子。发声大唤唱如是言。无常甚恶无怜愍意。如是天子有爱念心。命不自在于此处退。愿天童子速生人中。如是天女懊恼说已。彼天子身举体热发。既热发已。身则普然火起一焰即退彼处。身虽焰然不受苦恼。既退彼已则见人中父母和合。如是见已。即便受生。大仙当知。彼鬘庄严天子生时。云何处胎。彼住母胁则有胜相。若住藏中母则爱香。喜乐花鬘乐种种果青林丛树。受用心适彼一切乐皆悉具足身不疲倦。又彼福子住藏中故。复有善相。或梦见城种种宝物市易之处。种种华鬘以散道巷。应知彼母有如是相

复次大仙。如是童子。于鬘庄严天中退已。既生人中若见鬘者。生胜爱心乐鲜白衣。身色殊胜心无黠慧。不爱多淫乐多戏乐。若行住等悉皆迅疾。乐见戏处好尚细衣。爱好树林见他财富。多设方便悕望欲得。大仙当知。鬘庄严天。退生人中。有如是相

毗耶娑问经卷上毗耶娑问经卷下

        元魏婆罗门瞿昙般若流支译

复次大仙。四大天王。生退之相复应当知。如是大仙。若于贫人若于病人生怜愍心。若衣若食病患因缘所须医药。随时给施为除寒苦。道巷殖树行人坐息。造立池井沟渠水槽给施一切。如是信心喜心施与彼人。以是善业因缘。临欲死时身无垢秽。亦不羸瘦身色不变。不腻不烂一切身分不受苦恼。声不破坏。诸亲眷属悉皆聚集。无分散者故不忧恼。不患饥渴。脚不申缩。不受苦恼。不失便利。境界不碍故不愁苦。诸根不坏。彼人如是一切乐足。不苦恼死。若舍身时识心欢喜。见四天王诸天之众。在树林中戏乐之处。见天众已死尸面色。如生莲花。口出好香。其香犹如阿娑婆香。种种花香随风熏尸。彼死人识见四大王。天中生处父母相近

尔时天中彼父天子。在戏乐处游行嬉戏。欲心起发右手摩触天女脐下。以摩触故。识托怀中。至满七日乃有头发。具足庄严天童子生。生即知欲戏笑歌舞一切皆能。复次大仙。彼四大王诸天住处。所有宫殿纯金为地。种种庄严种种彩色。雕饰分明。百千天女在天宫殿。有百千树妙庄严枝。有随意风触身受乐

复次大仙。彼四大王天众住处。城隍平正。其城四方。纵广八万四千由旬。大仙当知。于彼林中有天宝珠。以为灯明疏妙缯彩。以衣树身悬幡枝上。树极柔软诸天见之。心生爱乐。于彼林中吹笛拍手。琵琶鼓等。和合乐声。在彼窟中

复次大仙。彼天童子种种食力。所谓揣食天饭善香。能生天力香色味等。功德具足。有天粳米名莲华光。自然而熟。甜如甘露。种种色味。具足相应。有二食盘。一是金盘。一是宝盘。随彼天子所须饭食。何者何等如是如是。彼彼饮食皆盘中生

复次大仙。彼天尔时。牟佉离汁生彼盘中。即变为花名阿娑婆。彼有善香其汁清冷。饮则凉乐。又复彼香令天童子醉乐怡适

复次大仙。彼四大王子。[阿-可+聶]宫殿周匝常有妙好华蔓。多饶妙花庄严殿柱。以如是柱。庄严宫殿金宝金刚。有胜天树娑罗翅蔓。上攀树枝有百千柱。床卧敷具庄严宫殿。六万天女。在中行坐。令彼宫殿端严胜妙。彼女殊胜身相举动。皆可观瞻。天衣光明庄严其身。妙声环钏以姿其媚善香妙色。欲心相应身极软弱。歌舞戏笑恒常不绝。多有姿媚两两共合。出美妙声与笛一音。彼天宫殿如是具足

复次大仙。彼天宫柱金宝间错。悬以缯幡处处垂下

复次大仙。彼四大王受胜欲乐。提头赖吒。毗楼勒叉。毗楼博叉。拘毗楼等。彼四大王在宫殿中。喜笑歌舞啸咏等声。天食充饱诸根喜乐。善爱意生彼处胜乐。皆悉具足

复次大仙。彼四大王。天众之中诸天童子。长臂洪直不粗不细。行如醉象具丈夫力。柔软之身具足天相。彼天行时。则有胜香熏一由旬

复次大仙。彼寿天年五百岁命无中夭伤。彼处胜乐一切具受。开眼看视有喜爱相。彼诸天众多有戏处。谓苏婆伽荼迦之处。迦昙婆迦及毗摩罗。光明庄严林王之处。阇那迦等胜戏乐处。有如是等第一香处。受用心喜。彼诸天子行彼处已。花珠金宝间错阶陛。其阶方正胜妙庄严名宝珠阶。百千天女妙声歌咏。珠宝乐器自然出声。多受欲乐福尽命终。则有相现。初则失影。不闻花香。迦陵频伽天女妙声。耳不复闻。大仙当知。又天众中彼天童子。于天宫殿众集之处至日不往。彼宫殿中百千天女。树生璎珞有妙胜花。俱翅罗声欲鸟之声林中具有。心不生乐在地旋转衣裳垢腻。其身极热悲苦看视地上旋转。于花帐处心不喜乐身中汗出。彼目常开今则眄瞬。彼处动转如鱼出水。为日所暴翻覆回转。独在地住。天女见已皆来围绕。详共悲哀同声啼哭。如是说言。何期爱人欲向何处。何期第一种种庄严柔软之身。异异无垢。胸膺宽博两肩可喜。平正之身柔软之身。何期戏处游戏常乐。种种处行今忽舍我。复舍天宫欲向何处。彼诸天女。既伤叹已。复说偈言

  种种善心作　　天树妙庄严
  此四大王处　　多饶饮食乐
  有四柱相应　　福德天胜处
  多饶天女爱　　丰华善心喜
  何忽恶无常　　令舍此而去

彼诸天女如是围绕。大声号哭涎出声坏。并啼并言可怜可愍。彼诸天女作如是言。离而远住。复申右臂取花散之。作如是言。生善道去。君善道去。向人界去。生福处地。信心犁之。应知彼天如是之身。彼欲死天既闻此已。如是思惟。自知身死。极大愁苦举体烝热。以烝热故。身则消洋犹如苏渧。于彼死处墓田之中。消洋尽坏。身体萎蔫。有扫风来。吹彼天身作一千分。碎末散去遍在虚空。于彼处退欲受人身。见阎浮提父母和合。彼既见已欢喜爱乐。即彼处生。初受生已。其母相出所谓喜笑。欲得胜食不喜食肉。喜着赤衣光明之衣。乐见人众聚会之处。于兄弟等生胜爱心。藏内胁中不受苦恼。无有涎唾又不恶心。无有身病在彼藏中。善具足手然后出生。彼既生已端正好色。见者爱念彼若增长。闻四王天心则欢喜。修行施戒饮酒不醉。心常惺悟身则肥鲜。恒以众香庄严其身。爱林戏处心多欲染。自身诸根乐近妇女。数数饮食乐好美膳。常修歌乐身体腻润不黑不白。其眼犹如青毗琉璃。大仙当知。四大王天退生人中。本性如是。四大王处。所熏相续有如是相

复次大仙。若有众生。舍离杀生信心清净。修行布施离偷盗已。以佉陀尼。蒲阇尼食梨何朱沙。余所须物衣裳财物。宝珠金等舍以布施。信乐心喜。以诸花等而为供养。礼拜塔寺奉施供养。命终之时身不坏烂。腻垢便利臭秽皆无。心生欢喜。自忆念身所作善根。临欲死时则有相现。面如金色鼻正不曲。心不动乱咽不杼气。亦不咳[口*數]及上气等。身不蒸热根不破坏。节脉不断身不苦恼。在于卧处身不回转。语声不破

复次大仙。如是众生或热病死。或中毒死。或贪华果而上树上。堕树而死。或食好食不消故死。彼欲舍阴内识。往见三十三天宫殿庄严。有珠金宝及金刚等。于分分处种种间杂。作金鱼形摩伽罗形。庄严殿门门上金幢。有种种乐迭相打触。出美好声能令心喜。饶种种枝相应好树。庄严林中。谓忧荼迦娑罗栴檀。香汁作泥以涂地处。金色彩画白真珠带。遍悬树下地皆柔软。常有庄严一切时净。有好金沙遍布其地。绕天珠焰以为灯鬘。多有天女天所分处。光明庄严常作天歌美妙音声。肘后庄严。胸有璎珞咽半璎珞。臂钏指环及耳磲等。种种庄严端正天女。大仙当知。三十三天诸天之众。彼处天子当于尔时。游戏受乐受诸欲行。彼於戏处树林中行。心生爱善彼福德识。见彼天上天子天女。同一处坐心喜爱乐。速彼生处。如綖穿珠牵綖珠走。不生异道。即于生时。彼天妇女手中花生。彼女见已。自知有儿即以此花。授与夫言。君今得子可生欢喜。彼天见之喜心增上。必知其妻得天童子。如是二天心生喜悦。如是童子七日满已。长发旋动清净无垢。天衣具足彼天未生。七日之中如是忆念。我某处退生此天中。某我父母我作善业。如是思惟极生喜心。喜心生已生则欲发。有欲即痴。彼乐欲者。遥见宫殿天戏乐处。如是见已。悕望欲得即便行往诣彼戏处如醉象行。臂如象手洪圆纤长。胸则平正。臂如金色。上下身粗。中身则细。行则详审深心勇健。腰如弓弝背骨平直。两髀洪满如芭蕉树。善知天法髭鬓断细。天香甚香瓜甲赤薄。身体香洁无主庄严。取以严身天无病苦。身有善香着妙天衣。色相殊妙天华严身。于宫殿中次第渐行。彼处见有无主天女。见天童子一切悉来围绕而住。作如是言。圣子善来善来圣子。此汝宫殿我无夫主。久离夫主独有童子。我今色少妙色具足。应相供养乳若金瓶。面如莲花开敷之色。我身犹如云中电行。端正可喜我是天女。今相供养奉给走使。此戏乐处波离耶多俱枳陀逻俱逻婆迦。多有枝心柔软可喜。而为庄严六万天女。娱乐此处今相娱乐。奉给圣子余宫殿处。皆悉不空。彼有琵琶鼓笛等乐。种种音声天敷庄严。师子座处自然出生。彼天既见种种庄严。妙好幡盖如王受位坐师子座。彼天童子。亦复如是。坐师子座。彼既坐已。诸乐器中出可爱声。普一切相唱声说言。此善众生于阎浮提。造福德业而来生此。天宫殿中。语天女言。汝来汝来速近此处。可为戏乐善作歌舞。乐此天子。此于人中作善根者。此声出已。六万天女。彼树林中两手取花。善香庄严。第一天衣名头居罗彼衣轻疏。胜上珠宝以为脚钏钏。有妙声。如是妇女而来近之。奉给供养彼诸天女。端正可喜犹如初月。面如莲花其香犹如阿娑婆花。如是妇女来近童子。作如是言。如是圣子。我以一切所须之物。供养供给随彼所用。此是童子自善根力。和集所得自福所摄。于今在此受天欲乐。如是大仙。彼天童子。天女相随。三十三天欢喜园林众杂林中。白衣石上有胜光明。娑卑都林佉罗佉啰。陀陀罗迦池泉流水。阿吒婆迦妙色好花。波离耶多俱枳陀罗。在如是等戏乐之处。第一凉乐。彼处无有大力恶风。彼处彼处林中多有若干妙声众鸟。多有天花。亦饶天果皆有妙香毗琉璃珠牟娑罗珠。及马瑙等。种种宝珠。以为灯明。复有众蜂及诸欲醉俱翅罗等。种种诸鸟有美妙声。有他眷鸟。有金翅鸟。此鸟青咽以妙珠宝间错其身。毗琉璃嘴长而严妙。有种种声。娑陀离多美妙歌声。于彼林中有种种花。杂色间错庄严其地。彼天童子。在如是处。受诸欲乐

复次大仙。三十三天宫殿地处。有妙池水清冷如月。八分具足清而无垢。复有胜妙百叶莲花开敷鲜荣。其池岸边宝树庄严花落在地。如是功德微妙之水。天子天女于彼池中相随戏乐。彼於戏处如心称意。若须食者。有种种宝间错槃生。随其所须皆悉具足。食色香白如君陀花。拘物陀花。如雪等色。色香具足。天女斟张。奉天童子。食足安乐寻即消化。离辛涩苦三种食过。如是食者天力无上。名曰苏陀。在彼槃中揣而食之。如业所得。大仙当知。若人施时垢心布施。得报亦尔。同一槃食食揣色异。有赤揣者。有黄揣者。有异揣者。身服一种成就一色。而槃中食异异不同。如是大仙。若人施已心生悔热。彼业得报食色则劣

复次大仙。三十三天有戏乐处。彼处名为尸利沙绀。有种种树枝花严好。种种天树百千和合。地处清净犹如颇梨。无垢柔软。复有天树花果具足。如是处者。非欲者住尸利沙迦清净之处。天女不住如是胜妙尸利沙绀戏乐之处。一切树林常有好花。如是花林常有诸天在下语说。大仙当知。我之所有声闻之人。诸弟子中最为胜者。所谓长老伽婆波帝。于婆罗门种姓中生。游心禅思慈心悲心。三昧眼开住慈三昧。于七日中息不出入。大仙当知。彼时既入慈三昧已。心若须风则有风吹。若其不须则无风吹。劫尽烧时地为一焰。彼身乃至如芥子许。亦不能烧。若须弥山堕其身分。于节节上即令停住。不能令动。若复难陀忧波难陀二恶龙王毒力炽盛。彼恶力毒。若以气嘘能动须弥。如是毒力四大海水能令味碱。大仙当知。如是大力恶毒龙王。伽婆波帝三昧力故。能令无毒。又复大仙。彼时长老伽婆波帝。尸梨沙绀戏乐处行。彼诸天女染欲心强。或因游戏至于彼处。若见长老伽婆波帝。生爱信心。能以天中曼陀罗花。居世赊迦。如是等花散而供养。合掌礼敬。又复彼处三十三天诸天子等。围绕供养。如是长老伽婆波帝。奉以天饭天甘露汁施令饱足。于日日中如是供养伽婆波帝。于彼林处树枝摇动深处游行。为彼天子数演伽他忧陀那尼陀那伊帝毗利多迦阇多迦裴不略阿浮多达摩毗尼修多罗忧波提舍阿波提舍。令彼天子闻已生信心喜悦乐故。在彼处天妙宫殿。坐禅读诵游行止住。亦复游彼尸梨沙迦戏乐之处

复次大仙。三十三天有善法堂天众集处。大仙当知。善法堂柱八万四千。彼柱皆是金宝金刚。若牟娑罗及迦罗婆。若马瑙等胜栴檀椽。并比在上铃鬘妙声。金沙覆地。大仙当知。彼善法堂垂天缯幡。竖立宝幢悬幡在上。复有乐声琵琶筝笛大鼓小鼓拍手吹贝箫啸美音。天子天女手如妙花。柔软之状如树枝心。迭相执手心生爱喜口常含笑。彼天童子彼天妇女。如是受乐。大仙当知。彼善法堂多天集处。种种珠宝间错其地。彼地青腻如毗琉璃。滑而无垢犹如净镜。多饶天花种种香末。远离风日青虫蚊虻如是等过。无有眠睡懈怠频申。彼善法堂乐触风窗。重楼屋壁种种庄严间错之文。形如半月。状似牛眼。天网缦覆。鸱尾妙门宽大广博。有乐触风宝鬘庄严。遍散妙花善香馨馥。多饶无量百千天女欲心戏笑。无有嫉心斗诤等过。迭相染欲爱心坚固。颊净无垢如月镜轮。天女之法以香彩色。用点颊额以庄严面。天女咏声共相娱乐。大仙当知。彼善法堂四方四角。四厢宽博多有树林。邃密云闇。有种种花戏乐之处。如是树林广百由旬。分分处处种种端严。有金莲花。复有散花遍布其地。复有种种微妙歌声。有种种树。其树名为居迦那陀波利耶多拘毗陀罗。如是等树处处多有以为庄严

复次大仙。彼善法堂一切所须金宝金刚。若牟娑罗及迦罗婆。复有白珠毗琉璃等。各有大聚。无主无护。多饶财物金宝之藏。彼一切物一切宝聚。皆悉庄严善法堂处。彼诸宝聚有种种色。以为庄严。彼善法堂周围复有百千戏处。以为庄严。无热无恼。种种衣服严饰其处。复次大仙。三十三天於戏乐处喜戏乐行。一切皆来集善法堂。娱乐喜乐

复次大仙。三十三天善见宫殿净如月镜。多有香花垂鬘庄严。有千天女。严饰微妙游戏娱乐。媚眼眄视奋动眉面犹如乱波。行虚空中以种种花庄严其身。善见宫殿庄严如是。多有珠瓶在宫殿中。铃网帘障出微妙声。以为庄严。若马若象行在宫殿。脚足伤地则起金尘。彼处多有端正天女。身着宝珠赤色光明若鸣。若抱。若捉衣裳。令彼戏处珠胜奇妙

复次大仙。善见宫殿有六万柱。彼柱皆是天妙金宝。以毗琉璃及金刚宝为柱头间。种种杂宝间错其柱。彼宫殿中汁香叶香。沉水等香种种香熏。复有种种善香胜熏。帝释天王在彼胜处。百千天女之所围绕。帝释王手执金刚牙。在宝殿上娱乐戏乐

复次大仙。三十三天因陀罗王。九千龙力。帝释王臂如天象手。身色如金鲜净无垢。形体平正。身中则细上下分粗。骨节不现体实不虚。发毛旋动清净无垢。身有光明衣则舒长。知因陀罗。所作释论能破诤论。多有无量百千天子常随亲近。天林宫殿及游戏处。随逐游行。金绳络身天妙璎珞。若半璎珞庄严其胸。其身胜妙不细不粗。中腰则细二髀平等。常以白饭甘露汁食。百千天女目鬘视之。肩颊端正。彼有醉象耳扇生风。风声美妙

复次大仙。彼大天王因陀罗主身脉不现。香气胜妙如善华香。彼大天王软美音声。大仙当知。彼大天王自身善香。若天白象欲发极醉。闻王身香即时醒解

复次大仙。因陀罗王身量高下。与余诸天乘马之量。高下平等。因陀罗王身色胜妙。见王身者金像不现

尔时毗耶娑大仙白佛言。世尊。希有世尊。彼帝释王大因陀罗。甚为胜妙实如世尊。圣法具足所说不异。佛言大仙。汝以何义如是美叹此无常身。大因陀罗。而言希有心生惊怪。譬如伎儿巧以泥团。造作种种人畜等形。又缚叶等插华在外。以诸彩色画为军众。木为机关彩画雕饰。如树生花画饰庄严。不过少时花则萎蔫。如以灯炷置于炉中。以火烧之则有光明。帝释王身亦复如是。大仙当知。阿泥楼大。父母所生其身力大。大仙当知。因陀罗王所有身力。阿泥楼大。父母所生身力为大。复次大仙。汝今且观阿泥楼大神通身力。如是说时。阿泥楼大心即忆念。如来加我。如是念已即入三昧。入三昧已身如金色。即有天王。新胜金冠如洋金色。在其头上。宝珠垂下傍面连肩动摇相摩。珠髻青发身体色润有胜光明。目如天上胜毗琉璃其色绀青。复有珠宝。牟娑罗宝。迦罗婆宝。日珠等宝。庄严身臂。彼以化力令身如是。复出天香。遍诸大众一切普熏。彼毗耶娑见其身已。心则变动从座而起。合掌恭敬生希有心。高声唱言。子子善哉。何何快哉。我得人身有果不空。我于今者到如来所。如来今者作一切智。相应语说。令我今者得见如是未曾有法

尔时世尊。语毗耶娑大仙人言。汝意云何。若因陀罗帝释王身。阿泥楼大长老之身。如是二身何者为胜。尔时毗耶娑大仙白佛言。世尊。因陀罗王身比阿泥楼大身。百分之中不及其一。于千分中亦不及一。阿泥楼大身色具足。如来语言。如是大仙勿生欢喜。以作福德发如是愿故得彼身

尔时大仙毗耶娑众。欢喜心开。白佛言。世尊。唯愿世尊。更为我说三十三天。佛言大仙。三十三天帝释天王第一天后。名曰舍支。百千天女住欢喜林。有种种花开发光明集在其身。颊如莲花唇色犹如金频婆果。第一光明微细衣服。林间戏处安行遨游。以天庄严善庄严耳。宝钏天珂庄严手臂。以好璎珞。及半璎珞。庄严其身。脚着宝钏钏有妙声。种种音乐欢喜林中如是游行。颊分宽博妙花散地。在上而行。脐下阴上有细毛文。沙宝跨衣行则声出。目青而宽开而有媚。发青长黑一一毛旋。鼻隆而直。远离嗔嫉斗诤等过。嗔怒皱面波奋动乱皆悉远离。身无藏过。大仙当知。舍支天后有喜欲力。胜弥楼山第一胜处。彼处广长多有树林。其树饶枝映障之处。心生爱乐微风吹花。动散出香复触其身。舍支身形不长不短不粗不细。其面严好如开莲花。口出妙香善巧语说增长佛种。大仙当知。三十三天一切天众。身体皆香无有病患。于游戏处若于宫殿如是游行

复次大仙。三十三天寿命千岁。彼天彼处如是行已。至命尽时彼天宫殿。本未曾有五种相出。应如是知。何等为五。地有清水犹如颇梨。冷而有文有乐触风。彼处多有种种枝花。既入池已油腻汗出。既见如是油腻汗已。心生疑虑。即便出水走向树林。彼既速行。天女见之顺后急行与共相随。既到一树即便住坐。既住坐已。天女忧悲发声叹息。咽中声破如是问言。圣子今者何故舍我。独在树下此有何乐。如是说已。彼天童子以忧叹声。语天女言。我头额上从本以来。未有腻出。如是说已。于两腋下即有汗出。而彼天女见汗出已。舍离远去。彼见天女远离身已。心生忧惧出入气粗。气粗出已。其心发热心既热故。头上沙鬘本未曾萎今者则蔫。鬘既蔫已。衣未曾垢今则垢出。天敷卧处不乐不乐

彼诸天女见如是相。心即思念。此天童子死相已出。将欲破坏知其必死。闻其气臭不可堪耐。即尔远之围绕而住。以闻其臭怜愍悲叹。咽喉声破口不能正。作如是言。何期第一柔软身天。在戏乐处林中行者。此三天处。如是池水有鸳鸯鸟。善法堂处欢喜之林鹅王鸳鸯。曼陀耆泥池水香洁。多有树林。树名象尘波利耶多俱耆多罗。在彼戏处多有蜜蜂。在杂林中以为庄严。常此处行今忽舍我去向何处。五相既现坏破欲去。彼诸天女如是啼哭。复更啼哭。彼见啼哭心则破坏。生大怖畏。其身发热眼目乱视。如行道路失伴之人。亦如商人海行船没。亦如遗失如意珠者心懊恼躄地。如大力风能堕山角。无常大风令天子堕。亦复如是。彼身极热在地旋转。如伽楼罗所捉龙子。生大怖畏举身战动。两手合掌。向天女言。我今患热。汝来汝来。可以手掌摩我令冷。如是心急身热欲然。如是身心俱受苦恼。彼诸天女。忧悲烧心住在远处。心生怜愍忧悲苦恼。身不能近不摩不触。于树林中取枝花叶。舒手遥置天子心上。作如是言。童子今者天福德尽。愿汝速生阎浮提处。彼天闻已知必定死。高声唱言。何期苦哉。何期苦哉。此三十三天处乃是恶处。如是种种具足庄严戏乐之处。第一宫殿受诸戏乐。多有天女种种爱染系缚心已。忽于今者趣于死道。住在远处。如是说言。愿汝死已生阎浮提。彼天如是数思惟已。闻彼语已举身欲起。极生悲苦啼哭而言。何期苦哉。欢喜树林种杂树林。白衣石上游戏坐处。何其善法彼留沙迦。波利耶多。此毗婆阇。曼陀耆尼大波流沙迦。如是宫殿第一宫殿。坚固门扇一切和集。我今忽舍此天宫殿。不得自在而便退此。三十三天命欲尽故。于自宫殿不能复见。唯见天女低面向下。以手拭眼引气破面。彼欲退天复作如是言。我于今者欲行死道。何期汝等退我所爱。不共我语。我今欲行生死长道。爱人可来急抱我咽。我从今已不复见汝。汝亦如是不复见我。如是天处何期甚恶。业果尽已闇无所见。云何此处三十三天。欲退之时皆悉空耶。云何此处三十三天。岂无琴乐拍手等耶。而我今者不复闻声。何期此处三十三天。第一可爱天乾闼婆。天色庄严金刚坚地。如是千眼帝释天王。复有何等福德众生。和集往彼而得见耶波利耶多俱枳陀罗。诸树花鬘在我头上。何期萎蔫。彼欲退天如是号唤。三十三天闻彼声已。一切愁忧取种种花。以自庄严清净须发。帝释天王百千天众。而为围绕。天后舍支天女围绕。那罗达离支多伽大般遮尸弃敦扶卢等天乾闼婆。天乐歌声美妙音声。而来向彼欲趣死道。五相出者既近见已。一切如是生怜愍心。同声唱言。何期苦哉。此恶无常无有悲心

帝释天王。见彼如是欲退天已。梵声说言。我等一切法皆如是。莫生爱着。当断爱心。若不断爱则生恶道。诸余天子亦复如是。一切同声如是说言。君善道去生于人中。一切众生造善业之地

如是说已彼欲退天。心即念言我今实退。即时合掌向彼天众。如是说言。三十三天一切天子。唯愿忍我我退时至。彼时天子引气直视。有二相出莲花叶眼。一切庄严皆悉失没。彼诸天子。见欲退天离庄严已。取曼罗婆居世舍耶居迦那大。如是等花遥散其身。即作天乐琵琶鼓笛。种种音声而以乐之。彼见如是供养身已。虽退天处心生欢喜。于阎浮提心生悕望。眼中泪出其声则粗。有因时业法集相应尽命。命尽死已。伽阿那风吹彼死天。彼风善香吹之令散。如是散已。即时远离三十三天。不知所在无有处所。不能生他若想若知。彼既退已生于人间。在胎藏中母则相现。喜笑歌舞心喜染欲。心常欢喜喜乐花果树林之处。乐着种种杂色衣服。常喜饮食。虽住藏内母胁不苦不乐邪欲。心喜善香花鬘庄严。卧则善梦非颠倒见。大仙当知。三十三天退生此时。住母藏中有如是相

大仙当知。其母尔时。一切藏过皆悉远离。后则出生。大仙当知。彼时童子既出生已。身分平正掌文成就。可喜柔软腰细齿密。身体柔软其心爱乐。胜功德欲性爱欲事。心爱细衣乐林戏处。身有胜香大富丰财。金宝具足大姓种族。常行施戒。欲心多者。则生贫家。心喜布施不黑不白。手足齐平。一切见者皆悉爱敬。性爱论义。其心柔软少于嗔心。乐行他妻。于自妻妾不生爱乐。于诸亲旧兄弟眷属。心不爱恋。大仙当知。三十三天退生人中。本性如是。世尊说已。毗耶娑仙。一切仙众。心生欢喜。叹言善哉

毗耶娑问经卷下


如来庄严智慧光明入一切佛境界经

    No. 357 [Nos. 358, 359]

如来庄严智慧光明入一切佛境界经卷上

        元魏天竺三藏昙摩流支译

如是我闻。一时婆伽婆。住王舍城鹫头山中第四重上法界藏殿。与大比丘众二万五十人俱。皆是阿罗汉。诸漏已尽无复烦恼心得自在。善得心解脱。善得慧解脱。心善调伏人中大龙。应作者作所作已办。离诸重担逮得己利。尽诸有结善得正智。心解脱一切心得自在到第一彼岸

复有阿若拘邻等八大声闻而为上首。复有菩萨摩诃萨七十二亿那由他。其名曰文殊师利法王子菩萨摩诃萨。善财功德菩萨摩诃萨。佛胜德菩萨摩诃萨。药王菩萨摩诃萨。药上菩萨摩诃萨等。皆住不退转地转大法轮。善能咨问大方广宝积法门。位阶十地究竟法云。智慧高大如须弥山。善修习空无相无愿心不生相。一切皆得大甚深法智慧光明。皆悉成就佛威仪行。此诸菩萨摩诃萨众。皆是诸佛神力所加。从于他方百千万亿那由他诸佛世界而来集会。皆得成就诸神通业。皆悉安住法性实际

尔时世尊作如是念。我今转于无上法轮。欲令诸菩萨摩诃萨。速疾生于大智慧力。又复欲令恒河沙等诸世界中。有大威德大神通力菩萨来集。时佛世尊复作是念。我为说大方广法门。欲现瑞相放大光明。何以故。欲令一切诸来菩萨摩诃萨等。皆悉咨问我所说法

尔时世尊念已放大光明云。普照十方阿僧祇不可思议三千大千微尘数等世界。即时十方一一世界。十十不可数佛国土。百千万亿那由他微尘数等菩萨摩诃萨俱来云集。一一菩萨各以菩萨神通力故。所有一切不可思议最胜供养供养诸佛。彼诸菩萨一一各以本愿力故。在如来前升莲华座。至心观佛瞻仰而住

即时法界藏殿上。有大宝莲华藏高座从地踊出。纵广亿那由他阿僧祇由旬。其华形相上下相称。以一切光明摩尼宝为体电光摩尼宝为周匝栏楯。不可思议光明摩尼宝为茎。不可思议摩尼宝以为眷属。过诸譬喻光明摩尼宝以为垂缨。自在王摩尼宝以为罗网。种种摩尼宝以为间错。悬诸无量宝盖幢幡。彼大宝莲华藏高座。周匝俱放十阿僧祇百千万亿那由他光明。是光尔时遍照十方无量世界。即时十方于一一方。有十亿不可说佛国土。百千万亿那由他微尘数等。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。四大天王释提桓因梵天王等。皆来集会。彼诸天等各各皆乘宝殿楼阁。一一皆有不可思议阿僧祇天女。作百千万亿那由他种种伎乐。娱乐而来到于佛所。复有诸天龙等。各各皆乘华殿楼阁。来诣佛所。复有诸天龙等。各各皆乘忧罗伽娑罗栴檀香殿楼阁。来诣佛所。复有诸天龙等。各各皆乘真珠宝殿楼阁。来诣佛所。复有诸天龙等。各各皆乘种种彩殿楼阁。来诣佛所。复有诸天龙等。各各皆乘金刚光明摩尼宝殿楼阁。来诣佛所。复有诸天龙等。各各皆乘阎浮那提金宝殿楼阁。来诣佛所。复有诸天龙等。各各皆乘集一切光明摩尼宝殿楼阁。来诣佛所。复有诸天龙等。各各皆乘自在王摩尼宝珠殿楼阁。来诣佛所。复有诸天龙等。各各皆乘如意宝珠殿楼阁。来诣佛所。复有诸天龙等。各各皆乘帝释王颈下璎珞摩尼宝珠殿楼阁。来诣佛所。复有诸天龙等。各各皆乘持清净大海普放千光明大摩尼宝珠殿楼阁。来诣佛所。如是等辈。各各皆有不可思议阿僧祇天女。作百千万亿那由他种种伎乐。娱乐而来到于佛所。到已俱作过一切世间不可思议不可称不可量不可数种种伎乐供养如来。彼诸天等以本愿力。随座所须自然具足却坐一面至心观佛瞻仰而住

尔时三千大千世界大地。即成阎浮檀金。种种摩尼宝树庄严世界。种种天华树。种种衣服树。种种忧罗伽娑罗栴檀树。种种香树庄严世界。电光摩尼宝以为罗网。遍覆三千大千世界。建大宝幢悬诸幡盖。彼诸树中一一皆有百千万亿那由他阿僧祇天女。皆现半身两手俱持百千万亿诸宝璎珞供养而住。尔时彼大宝莲华藏大师子座中出妙音声。而说偈言

  我依佛力生　　本愿今成就
  愿人王来坐　　奉戴两足尊
  我此身唯宝　　华净众所乐
  宝成由佛力　　愿尊满我愿
  坐师子华藏　　严世界及我
  说法多众闻　　逮得师子座
  我身千光明　　照无量世界
  愿尊坐我上　　生我欢喜心
  于此说法处　　已坐八亿佛
  愿尊今速坐　　摄受利益我

尔时世尊从本座起。即升大宝莲华藏大师子座结加趺坐。观察一切菩萨摩诃萨众。欲为菩萨说胜妙法即便现相即时一切菩萨摩诃萨众作是思惟。文殊师利法王子。应为我等咨问如来应正遍知不生不灭法门。以我等辈从久远来。已曾闻此胜妙法门。尔时文殊师利法王子见如来相。知诸菩萨摩诃萨众心思惟已。即白佛言。世尊。何等法门名不生不灭。即说偈言

  佛说无生灭　　彼释何等相
  何法不生灭　　愿说喻相应
  菩萨为智慧　　承诸佛神力
  无量世界来　　愿说胜妙法

尔时佛告文殊师利法王子言。善哉善哉文殊师利。汝能问佛此甚深义。文殊师利。汝为安隐无量众生。能与无量众生种种快乐。复能怜愍无量众生。广能利益无量众生。与无量众生人天之乐。为诸菩萨摩诃萨等究竟佛地。文殊师利。汝于此义莫惊怖畏。文殊师利。我为汝说不生不灭法当依智解。文殊师利。不生不灭法者。即是如来应正遍知

文殊师利。譬如大地大毗琉璃所成形相。犹如三十三天所住之处。彼大地中见三十三天。释提桓因并善法堂影现分明。及见天王释提桓因。天中所有五欲境界。戏乐等事一切皆见。尔时诸天唱告一切男子女人童男童女作如是言汝等可来观此天王释提桓因善法之堂。及天王所有五欲境界戏乐之具。复作是言。诸善男子善女人等。汝当布施持戒种诸善根。皆当得此善法堂处及以天中五欲境界戏乐之具。当作天王并得果报及神通力如释提桓因。随其所有五欲境界。毕竟成就必得受用。文殊师利。尔时彼诸善男子善女人童男童女等。于彼大毗琉璃地中。见三十三天释提桓因善法之堂。及五欲境界戏乐之具影现分明。即各散华合掌供养作如是言。如彼释提桓因身并善法堂。及彼天中五欲境界我亦应得。文殊师利。而彼众生皆悉不知三十三天善法之堂释提桓因。及五欲境界如是等事一切皆依大毗琉璃地中而现。何以故。大毗琉璃地清净故。一切影像悉现其中。文殊师利。而彼众生为求天王帝释身故。所有修行布施持戒种诸善根。皆悉回向三十三天文殊师利。而大毗琉璃地中实无有彼三十三天善法堂释提桓因。及以五欲境界等事。以大毗琉璃宝地清净镜像现故。彼三十三天善法之堂。释提桓因五欲境界。以不实故不生不灭。以大毗琉璃宝地清净镜像现故。文殊师利。如是如是。一切众生依清净心。如实修行见如来身。文殊师利。一切众生依如来加力故。见如来身而如来身。不实不生不灭。非有物非无物。非可见非不可见。非可观非不可观。非有心非无心。非可思议。非不可思议。非有非无。文殊师利。一切众生依于如来清净法身镜像力故。得见如来清净法身。奉施宝衣散华烧香。合掌供养而作是言。我亦应得如来应正遍知清净法身。文殊师利。而彼一切众生为求如来清净法身。布施持戒种诸善根。以此善根求如来智。回向阿耨多罗三藐三菩提

文殊师利。如彼大毗琉璃地镜像中。三十三天帝释王身不动不生。心不戏论不分别。不分别无分别。不思无思不思议无念寂灭寂静不生不灭。不可见不可闻。不可嗅不可味。不可触无诸相。不可觉不可知。如是文殊师利。如来应正遍知清净法身亦复如是。不动不生心不戏论不分别。不分别无分别。不思无思不思议无念。寂灭寂静不生不灭。不可见不可闻。不可嗅不可味。不可触无诸相。不可觉不可知

文殊师利。如来法身。不生不灭不去不来以此为体。如镜中像世间所见。随诸众生种种信力。如来示现种种异身。随彼众生感有长短。如来现身命有修促。随彼众生于大菩提有能信力如来现身。随彼众生闻法能信受如来现身。随彼众生信心能知三乘之法如来现身。随彼众生得解脱力如来现身

文殊师利。譬如虚空有大妙法鼓。依三十三天功德力生。离善法堂在虚空中。过一切诸天眼识境界。不可见不可观。文殊师利。彼大妙法鼓于何时出声。文殊师利。以彼诸天耽着五欲境界。常不舍离增长放逸。不入善法堂闻法思义。释提桓因亦耽着五欲境界。常不舍离增长放逸。不入善法堂。不升高座为天说法。尔时彼大妙法鼓。不可见不可观。过眼境界住虚空中出妙法声。彼妙法声遍闻三十三天而作是言。诸天当知。一切色声香味触法皆悉无常。莫行放逸天报速退。诸天当知。一切行苦一切行空一切行无我。是故诸天莫行放逸。若退天报生余苦处。诸天当共议法乐法喜法味法顺法念法。诸天若欲不舍天报五欲境界。应正修行。文殊师利彼法鼓声不可见无色。不分别无分别。过眼境界不生不灭。离音声语言。离心意意识。文殊师利。尔时三十三天闻妙鼓声。即入善法堂。议法乐法喜法味法顺法念法。如说修行。于彼天退生余胜处。释提桓因亦入善法堂。升法高座为诸天说法

文殊师利。若阿修罗共彼诸天斗战之时。三十三天力弱退散。尔时法鼓于虚空中出如是声。阿修罗闻甚大惊怖退入大海

文殊师利。彼大法鼓无形相无作者。不可见不可观元无实不可思议。无心无相无色无声。无体无二过眼境界。文殊师利。三十三天依本行业。彼大妙鼓空中出声。令彼诸天远离一切诸障忧恼无染寂静。文殊师利。如彼空中大法鼓身。不可见不可观。元无实不可思议。无心无相无色无声。无物无二过眼境界。依本行业法鼓出声。令三十三天远离一切诸障忧恼无染寂静。文殊师利。如三十三天心放逸时。彼妙法鼓出大音声。令三十三天远离一切诸障忧恼无染寂静。文殊师利。如是如来应正遍知清净法身一切世间所不能见。元无实不可思议。无心无相无色无体。无二过眼境界。文殊师利。如彼众生依本业行。随心能信得闻法声。而彼法声能令众生远离一切诸障忧恼无染寂静。文殊师利。彼清净法身无说无体。而诸众生依善根业力闻妙法声。谓如来说法。谓世间有佛。文殊师利。一切众生闻如来声。能得一切乐具。已信者令得正解。闻声正解是如来身。初发心菩萨及一切凡夫众生。闻如来说法。观察如来增长一切善根。文殊师利。如来应正遍知。清净法身不生不灭应如是知。文殊师利。譬如初夏依诸众生本业力故。大地所有种子谷草丛林药木出生增长。为与众生资生乐具。上虚空中出如是风。如是风者能生大云。生大云者能澍大雨。澍大雨者能满大地。满大地者能令一切诸种滋茂。尔时一切阎浮提人皆大欢喜。生大踊跃而作是言。此是大云此是大雨。文殊师利。于虚空中天不雨时。阎浮提人作如是言。无云无雨。文殊师利。随何时中普兴大云遍澍大雨。时诸众生咸作是言。希有大云希有大雨。普澍大雨充满大地。文殊师利。而彼虚空无云无雨。文殊师利。依因于风彼虚空中能生大云能生大雨。文殊师利。依因于风彼虚空中无云无雨。何以故。以依众生本业力故。文殊师利。如彼水聚于虚空中。风因缘住依风而雨。而世间人称言云雨。何以故。以依众生本业力故。于虚空中澍大雨聚充满大地。文殊师利。彼虚空中无云无雨。文殊师利。彼大云雨自性不生不灭。离心意意识离去来相。文殊师利。如是诸菩萨摩诃萨。依过去善根修诸善行。闻佛说法得无障碍道。一切众生一切声闻辟支佛等种诸善根求涅槃道。世间众生便谓如来应正遍知出现于世。如来说法皆是真语如语不异语。而诸天人称言如来。文殊师利。以依众生善根力故法身出声。而诸天人作如是言。如来说法。文殊师利。实无如来。何以故。如来法身。无相离相无处离处。不实不生不灭。文殊师利。而彼如来乐说辩才。为天人说法无有穷尽。随所应闻皆令开解。文殊师利。始发心菩萨及以一切毛道凡夫。依于众生本业力故。应见如来入涅槃者。如来即便入于涅槃不可得见。而彼众生起如是心。便谓如来毕竟涅槃。文殊师利。如来应正遍知。不生不死不起不灭。文殊师利。如来应正遍知。无始世来证于常住大般涅槃。文殊师利。如彼大云不实不生不灭虚妄故有。而诸众生念想假名云雨如是。文殊师利。如来不实不生不灭本来不生。而诸众生随其心想。闻如来应正遍知现有说法

文殊师利。譬如大自在梵天王。于十百千万三千大千诸世界中自在无碍。下观一切诸天宫殿。乃至观于四天王等。尔时彼大自在梵天王。于彼十百千万三千大千诸世界中为自在主。观于一切诸天宫殿。文殊师利。时宫殿中一切诸天。各各舍于五欲境界一切伎乐。舍诸欲念生大恭敬心。合掌供养大梵天王瞻仰而住。文殊师利。而彼大自在梵天王。于彼一切诸宫殿中暂时而现。尔时诸天为生梵世所有善根回向梵天。文殊师利。彼大自在梵天王。十百千万三千大千诸世界主。不退梵天住持梵宫。依自在愿住持力故。一切众生善根力故。应化梵天日日观察一切天宫。下至四天王天。各各舍于五欲境界一切伎乐。舍诸欲念生大恭敬心。合掌供养大梵天王瞻仰而住。而彼大自在梵天王。于彼一切诸宫殿中。暂时现身于本处不动。彼时诸天为生梵世。所有善根回向梵天。文殊师利。而于彼处无实梵天。文殊师利。彼梵天空彼梵天无不实。无名字无音声。无住处无体不思议。无相离心意意识不生不灭。文殊师利。彼大梵天依本愿善根住持力故。依彼诸天善根住持力故。于彼一切诸宫殿中暂时现身。文殊师利。而彼诸天不知梵天身空无不实。无名字无音声。无住处无体不思议。无相离心意意识不生不灭。如是文殊师利。如来应正遍知空无不实。无名字无音声。无住处无体不思议。无相离心意意识不生不灭亦复如是。文殊师利。如来应正遍知。依彼菩萨本愿行力。住持初发心菩萨。住一切声闻辟支佛乘。依一切毛道凡夫善根力故。如来应现百千万相好庄严之身。如镜中像本处不动。文殊师利。初发心菩萨。一切声闻辟支佛。及毛道凡夫。不知如来应正遍知空无不实不可观。无名字无音声。无住处无体不思议。无相离心意意识不生不灭。文殊师利。而如来百千万亿种种相好庄严之身。具足如来一切种种诸威仪行。随诸众生种种信故。出大妙声为众生说法。能令众生远离一切诸障忧恼无染寂静。而如来一切平等舍心无分别无异心。文殊师利。以是义故。言不生不灭者是名如来。尔时世尊而说偈言

  如来常不生　　诸法亦复然
  世间无实法　　愚痴妄取相
  无漏善法中　　无如及如来
  依彼善法力　　现世如镜像

文殊师利。譬如日光初出。先照最大山王。次照斫迦婆罗山摩诃斫迦婆罗山。次照余大山。次照余黑山。次照高原堆阜。后照深谷卑下之处。文殊师利。而彼日光不分别无分别不思惟。何以故。文殊师利。彼日光明无心意意识。不生不灭无相离相无念离念。无戏论无障碍离障碍。不住此岸不住彼岸。不高不下不缚不脱。不知非不知无烦恼非无烦恼。非实非不实。不在此岸不在彼岸。不在陆地不在水中。不在两岸不在中流。无觉离觉无色非无色。文殊师利。依于大地有高下中。日光随地有高下中。文殊师利。如来应正遍知亦复如是。不分别无分别不思惟。文殊师利。何以故。如来应正遍知。离心意意识不生不灭。无相离相无念离念。无戏论离戏论。无热恼离热恼。不住此岸不住彼岸。不高不下不缚不脱。不知非不知。无烦恼非无烦恼。非实语者非不实语者。不在此岸不在彼岸。不在陆地不在水中。不在两岸不在中流。非一切知者。非无一切知者。非觉者非无觉者。非行者非无行者。非修习者非无修习者。非念者非无念者。非有心者非无心者。离心者非离心者。无意者非无意者。非害者非无害者。非名者非无名者。非色者非无色者。非说者非无说者。非假名者非无假名者。非可见者非不可见者。体性如是非不如是。非说道者非无说道者。非证果者非无证果者。非分别者非无分别者。非离分别者非无离分别者。文殊师利。依彼无边法界众生上中下性。如来放大智日光轮。普照众生亦复如是。初照一切诸菩萨等清净直心大乘山王。次复照于住辟支佛乘。次复照于住声闻乘。次复照于随所能信善行众生。次复照于乃至住邪聚众生。皆为如来一切智日光轮所照。为毕竟利益一切众生。为生未来一切善根。为令增长一切善根。文殊师利。如来于彼一切事中平等舍心。无分别无异心。文殊师利。诸佛如来智日光轮无如是心。我为此众生说于妙法。而不为彼众生说法。文殊师利。诸佛如来无有如是分别之心。此众生信上法。此众生信中法。此众生信下法。此众生信正法。此众生信邪法。文殊师利。诸佛如来无如是心。此众生信上法。为说大乘。此众生信中法。为说缘觉乘。此众生信下法。为说声闻乘。此众生信正行。为说清净心法。乃至此众生信邪行。随所应闻而为说法。文殊师利。诸佛如来智日光轮。无有如是分别之心。何以故。诸佛如来智日光轮。远离一切分别异分别及诸戏论。文殊师利。依诸众生种种善根。诸佛如来智日光轮种种别异

文殊师利。譬如大海中有如意宝珠悬置高幢上。随何等何等众生念。须何等何等事。如是如是。闻彼摩尼宝珠出声。而彼摩尼宝珠。不分别无分别不思惟。无心离心离心意意识。文殊师利。如来亦复如是。不分别无分别不思惟。无心离心。离心意意识。不可测量离诸测量不得离得。贪不能转嗔不能转痴不能转。不实不妄。非常非不常。非照非不照。非明非不明。非觉者非不觉者。不生不灭。不思议不可思议。无体离体。不可取不可舍。不可戏论不可说。离诸言说。不喜离喜无生不可数离诸数量。不去无去去寂。绝一切诸趣。离一切言说。不可见不可观不可取。非虚空非不虚空。非可见非可说。非和合非离和合。非作非造。非示非染。非可清净。非名非色。非相非无相。非业非业报。非过去非未来非现在。非有烦恼非无烦恼。非诤非不诤。非声离一切声。无言无相离一切相。非内非外亦非中间。文殊师利。而如来宝珠清净直心。悬大慈悲高幢之上。随何等何等众生信。何等何等众生行。闻如是如是说法声。文殊师利。如来于一切事平等舍心。无分别无异心

文殊师利。譬如响声从他而出众生得闻。而彼响声非过去非未来非现在。非内非外非二中间可得。非生非灭非断非常。非知非不知非觉非不觉。非明非不明。非缚非脱。非毁非不毁。非念非不念。非处非不处。非住非不住。非地界非水界。非火界非风界。非有为非无为。非戏论非不戏论。非声非不声。非见非不见。非字非言非离言语。非称量离称量。非相离相。非寂静非离寂静。非长非短。非心非不心。非观非不观。非可见相非不可见相。非空非不空自体空。非可念非不可念离可念。非可觉非不可觉。离心意意识。一切处平等。无分别离异分别过三世。文殊师利。而彼响声。随种种众生种种言音闻种种响。文殊师利。如来应正遍知。说法音声亦复如是。非过去非未来非现在。非内非外非二中间可得。非生非灭非断非常。非知非不知。非觉非不觉。非明非不明。非缚非脱。非毁非不毁。非念非不念。非处非不处。非住非不住。非地界非水界。非火界非风界。非有为非无为。非戏论非不戏论。非声非不声。非见非不见。非字非言非离言语。非称量离称量。非相离相。非寂静非离寂静。非长非短。非心非不心。非观非不观。非可见相非不可见相。非空非不空自体空。非可念非不可念。离可念。非可觉非不可觉。离心意意识。一切处平等。无分别离异分别。过三世。文殊师利。随种种众生种种信种种解。闻于如来应正遍知如是如是说法音声。文殊师利。譬如大地住持万物。生长一切谷麦果蓏。草木树林建立成就。文殊师利。而彼大地。不分别无异分别。一切处平等。无分别无异分别心。无心离心意意识。文殊师利。如来应正遍知亦复如是。依于如来应正遍知。住持一切众生。生长一切善根。建立成就一切声闻辟支佛菩萨。及诸外道种种异见。尼犍子等从于邪见。乃至邪定聚众生所有诸善根。彼诸善根皆是如来应正遍知之所住持。皆依如来应正遍知。而得生长建立成就

文殊师利。而如来应正遍知。离一切分别。无分别异分别念。离一切心意意识。不可观离诸观。不可见离诸见。不可思惟离诸思惟。不可念离诸念。心平等无平等舍。一切处无分别离异分别

文殊师利。譬如虚空一切处平等。无分别异分别。不生不灭。非过去非未来非现在。不可见不可戏论。无色不可示不可表。不可触不可护。不可量离思量不可譬喻离诸譬喻。无住处不可取。离眼识道。离心意意识。无相无字。无声无念。无取无舍。不可转不可换。离言语道。一切处住一切处入。文殊师利。如诸众生以依地有高下中故。而言虚空有高下中。而彼虚空无高下中。文殊师利。如来应正遍知亦复如是。于一切处平等。无分别异分别。不生不灭。非过去非未来非现在。不可见不可戏。无色不可示不可表。不可触不可护。不可量离思量。不可譬喻离诸譬喻。无住处不可取。离眼识道。离心意意识。无相无字。无声无念。无取无舍。不可转不可换。离言语道。一切处住一切处入。文殊师利。依众生心有高下中故。见如来有高下中。而实如来无高下中。文殊师利。如来无如是心。此众生有下信心。我示下形色。此众生有中信心。我示中形色。此众生有上信心。我示上形色。文殊师利。如来说法亦复如是。文殊师利。如来无如是心。此众生有下信心。我为说声闻法。此众生有中信心。我为说辟支佛法。此众生有上信心。我为说大乘法。文殊师利。如来无如是心。此众生信布施故。我为说檀波罗蜜。此众生信持戒故。我为说尸波罗蜜。此众生信忍辱故。我为说羼提波罗蜜。此众生信精进故。我为说毗梨耶波罗蜜。此众生信禅定故。我为说禅波罗蜜。此众生信智慧故。我为说般若波罗蜜

如来庄严智慧光明入一切佛境界经卷上如来庄严智慧光明入一切佛境界经卷下

        元魏天竺三藏昙摩流支译

文殊师利。如来者名为法身。文殊师利。如来不生无生。文殊师利。如来无名无色。无言说无心意意识。文殊师利。如来无分别离分别。文殊师利。言如来者。名为空不可尽相。尽际实际。空平等一切法际不二际。常不可知处际。文殊师利。如来应正遍知。一切处无分别离异分别。非下非中非上。如是文殊师利。一切法无分别离分别。非下非中非上。何以故。一切法不可得故。文殊师利言。一切法不可得者。是一切法平等。言一切法平等者。是平等住。言平等住者。即是不动。言不动者。是一切法无依止。言一切法无依止者。彼无心定住。言无心定住者。即是无生。言无生者。即是不生。若如是见。彼心心数法毕竟不颠倒。若毕竟心不颠倒者。彼行者能得如实。若能如实得者。彼不起戏论。若不起戏论者。彼不行一切法。若不戏不行者。彼不在生死。若不在生死者。彼不能动。若不能动者。彼法不能相违。若法不能相违者。彼随顺一切法。彼随顺一切法者。彼法性中不能动。若法性中不能动者。彼得自性法。若得自性法者。彼无所得。何以故。依因缘生一切法故。若依因缘生一切法者。彼常不生。若常不生者。彼常不可得。若常不可得者。彼得实际法。若得实际法者。彼不共一切法住。若不共一切法住者。彼不共住。若不共住者。彼非有非无。若非有非无者。彼得法中住。若得法中住者。彼得修行正念法。若得修行正念法者。彼无一法非是佛法。何以故。以觉一切法空故。文殊师利。觉一切法空者名为菩提。菩提者名觉一切法空。空者即是菩提。如是空无相无愿。无作无行。无依无生。无取无处。觉如是法者名为菩提。菩提者名为修行正念。文殊师利。言修行正念者。不取不舍即名正念。不观不异名为行。不着不缚不脱名为行。不去不来名为行。文殊师利。正念行者。彼处无行无利无果无证。何以故。文殊师利。心自性清净故。彼心客尘烦恼染。而自性清净心不染。而彼自性清净心。即体无染不染者。彼处无对治法故。以何法对治能灭此烦恼。何以故。彼清净非净。即是本净。若本净者即是不生。若不生者彼即不染。若不染者彼不离染法。若离染法者。彼灭一切染。以何等法灭一切染。彼不生。若不生者是菩提。菩提者名为平等。平等者名为真如。真如者名为不异。不异者名为如实住一切有为无为法。文殊师利。真如者。彼处非有为非无为无二法。若非有为非无为无二法者是真如。文殊师利。言真如者彼实际。言实际者彼不异。不异者彼未来真如。言未来真如者。即是不异。言不异者彼即真如。言即真如者彼非常不真如。言非常不真如者。彼不染不净。言不染不净者。彼不生不灭。言不生不灭者。彼涅槃平等。言涅槃平等者。彼不在世间不在涅槃。言不在世间不在涅槃者。彼非过去非未来非现在。言非过去非未来非现在者。彼非下非中非上。言非下非中非上者。即是如来。言如来者名为实语。言实语者名为真如。言真如者名为如实。言如实者名为我。言我者即是不二。不二义者即是菩提。菩提者名为觉。觉者入三解脱门智。智者。入三世平等一切法智。言义者。于一切法无差别义。义者。无名无言不可说。言智者。觉了一切法名为智。识知一切法名为智。言义者。知众生及识智了义即是法。法者即是义。义智识智。了义智法智。法住智法体智。彼依法转所转义。自转平等不二义。平等不二义即是平等。平等者即是义。所言义识智平等者。即是入不二法门智。名为了义非不了义。言平等者。即是平等。即是空。言空者。即是幻我平等。言我平等者。即是法平等。言法平等者。即是离平等。离平等者。即是觉平等。觉平等者。即是菩提。文殊师利。着色者即是着眼。着眼者即是着自性。着见者即是着自我。着自身者。即是着自性空智着。不正念观者。即着法光明观法不着。着懈怠垢者。着证智坚固精进。如实知法名为着。着五盖菩提分名为着。不着无障解脱智。一切法自性清净因缘而有。又菩萨摩诃萨。如实知染净因。而不住染净因中者。起我起见是名染因。入一切法无我是名净因。见我我所是名染因。内寂静外不行是名净因。欲嗔恨害觉观是名染因。不净慈悲喜舍入十二因缘忍。名为净因。四颠倒是染因。四念处是净因。五盖是染因。五根是净因。六入是染因。六念是净因。七非净法是染因。七觉分是净因。八邪法是染因。八正法是净因。九恼事是染因。九次第定是净因。十不善业道是染因。十善业道是净因。略说一切不善念是染因。一切善念是净因。所言染因净因。彼一切法自性空。无我无人无命无寿者。无我所无使者。如幻无相内寂静。内寂静者即是寂灭。寂灭者即是自性清净。自性清净者即是不可得。不可得者即是无处。无处者即是实。实者即是虚空。何以故。文殊师利。无有一法若生若灭。文殊师利白佛言。世尊。若法如是。云何如来得菩提。佛告文殊师利言。文殊师利。无根无住。如来如是得菩提。文殊师利言。世尊。何者是根何者是住。佛告文殊师利。身见名为根。不实分别名为住。彼菩提平等。如来知一切法平等。是故说如来无根无住得菩提。文殊师利。言菩提者名为净亦名寂静。何者为净何者寂静。文殊师利。我我所眼空。何以故。自性空故。如是耳鼻舌身意我我所空。何以故。自性空故。是故知眼空不着色。是故说净。如是知耳空不着声是寂静。知鼻空不着香是寂静。知舌空不着味是寂静。知身空不着触是寂静。知意空不着法是寂静。文殊师利。菩提自性清净。以自性清净故。自性清净者。所言自性清净。彼不染如虚空。平等如虚空。自性同虚空。譬如虚空本来自性清净。文殊师利。言菩提者。不取不舍。云何不取云何不舍。言不取者。不取一切法。是故言不取。言不舍者。不舍一切法。是故言不舍。文殊师利。如来度大漂流。是故不取不舍。而彼真如不见彼此岸。如来知一切法离彼此岸。故言如来。文殊师利。菩提无相无观。何者无相无观。文殊师利。不见眼识名为无相。不见色名为无观。不见耳识名为无相。不闻声名为无观。不见鼻识名为无相。不闻香名为无观。不见舌识名为无相。不知味名为无观。不见身识名为无相。不知触名为无观。不见意识名为无相。不知法名为无观。文殊师利。是诸圣人境界。所谓三界境界。文殊师利。言菩提者。非过去非未来非现在。三世平等三世清净。文殊师利。何者是三世智。所谓过去法心不行。未来法识不去。现在法念不住。是故如来不住心意意识。以不住不分别无分别。以不分别无分别故。不见未来法现在法不戏论。文殊师利。菩提无身无为。何者是无身。何者是无为。文殊师利。无身者。所谓非眼识知。非耳鼻舌身意识知。文殊师利。若非心意意识知。彼无为。言无为者。不生不住不灭。是故言三世清净无为。如无为知。有为亦如是。何以故。所言一切法体者。即是无体。无体者。彼处无二言。文殊师利。言菩提者。名为无差别足迹。何者无差别。何者足迹。文殊师利。无相名无差别。真如名足迹。无住名无差别。法名足迹。无异名无差别。实际名足迹。不可得名无差别。不动名足迹。空名无差别。无相名足迹。无觉名无差别。无愿名足迹。不求名无差别。无众生名足迹。众生体名无差别。虚空名足迹。不见名无差别。不生名足迹。不灭名无差别。无为名足迹。无行名无差别。菩提名足迹。寂静名无差别。涅槃名足迹。不起名无差别。觉名足迹。文殊师利。菩提者不可以身得。不可以心得。何以故。文殊师利。身者顽碍无觉无心。譬如草木墙壁土块影像。心者如幻空无所有不实不作。文殊师利。身心如实觉名为菩提。依世间名字非第一义。何以故。文殊师利。菩提非身非心非法。非实非不实。非谛非不谛。不可如是说。文殊师利。不可以一切法说菩提。何以故。文殊师利。菩提无住处可说。文殊师利。譬如虚空无住处可说无为无生无灭。菩提亦如是。无住无为无生无灭可说。文殊师利。譬如一切世间之法。若求其实不可得说。文殊师利。菩提亦如是。以一切法说菩提实亦不可得。何以故。文殊师利。实法中无名字章句可得。何以故。不生不灭故。文殊师利。言菩提者。名不可取不可依。文殊师利。何者不可取何者不可依。文殊师利。如实知眼不可取。不见色名为不可依。如实知耳不可取。不闻声名为不可依。如实知鼻不可取。不闻香名为不可依。如实知舌不可取。不知味名为不可依。如实知身不可取。不觉触名为不可依。如实知意不可取。不见诸法名为不可依。文殊师利。如是如来。不取不依名证菩提。如是证菩提。不取眼不见色。是故不住眼识。不取耳不闻声。是故不住耳识。不取鼻不闻香。是故不住鼻识。不取舌。不知味。是故不住舌识。不取身不觉触。是故不住身识。不取意不知法。是故不住意识。文殊师利。如来不住心意意识。是故得名如来应正遍知

文殊师利。众生有四种心住法。依彼四种心住法。何等为四。所谓众生依色心住。如是受想行等。是为众生依四种心住。文殊师利。此四种心住法。如来如实知不生不灭。是故名为佛。文殊师利。言菩提者名为空。文殊师利。如彼一切法空不异菩提空。菩提空即一切法空。如彼一切法空。如来如实知名为觉者。文殊师利。非空空知。文殊师利。空者即菩提。菩提即是空。文殊师利空中无空亦无菩提。亦无二。以何等法为空。何等法为菩提。而说二名。何以故。文殊师利。一切无二无相无差别。无名无相。离心意意识。不生不灭不行无行。不集无字无声。文殊师利。言空者名取戏论。文殊师利。而第一法中。无法可得名为空。文殊师利。如说虚空。虚空而无虚空可名。名为虚空。文殊师利。空亦如是说名空。空而无法可说名之为空。如是入一切法。是名入一切法门。文殊师利。一切法无名。而依名说。文殊师利。如名非此处不离此处。如是依名说。何等法彼法非此处不离此处。如是文殊师利。如来如实知一切法。本来不生不起不灭。无相离心意意识。无字无声。文殊师利。言菩提者。如虚空平等。虚空非平非下非高。菩提亦非平非下非高。何以故。文殊师利。法无实有。文殊师利。若法无实有。云何说平等非下非高。文殊师利。如来如是觉一切法平等非高非下。如是觉已。无有少法不平等不高不下。如彼法住。如是如如实智知。文殊师利。何者是如实智。文殊师利。如实知一切法者。一切法无本来不生不灭。法本不生生已还灭。彼诸法无作者无取者而生。无作者无取者而灭。文殊师利。诸法依因缘生。无因缘灭。无实道者。是故如来为断道者说法。文殊师利。言菩提者。名为如实足迹。文殊师利。何者是如实足迹。文殊师利。言如实足迹者。即是菩提如菩提色亦如是不离如。如是不离如。受想行识。如菩提地界如不离如。水火风亦不离如。如菩提如是眼界色界眼识界不离如。文殊师利。如菩提耳界声界耳识界不离如。文殊师利。鼻界香界鼻识界不离如。舌界味界舌识界不离如。身界触界身识界不离如。意界法界意识界不离如。文殊师利。一切法假名法者。谓五阴十二入十八界。彼法如来如实觉非颠倒觉。如彼法住本际中际后际。如来如实知本际中际后际。如彼法本际不生。未来际不去。现在际不住。如实知如彼法足迹。如一法一切法亦如是。如一切法一法亦如是。文殊师利。而一多不可得。文殊师利。入一切法。阿门无阿门。文殊师利。何者阿门。何者无阿门。文殊师利。言阿者。初发一切善根法。无阿者。不见一切法。言阿者。心不住能令住。言无阿者。无相三昧解脱门。言阿者。称数观诸法相。言无阿者。名为过量。何者是过量。谓无识业。言阿者观有为法。言无阿者观无为法。文殊师利。言菩提者是无漏无取法。文殊师利。何者是无漏是无取。文殊师利。言无漏者。谓离四漏。何者为四。谓欲漏有漏无明漏见漏。以不取彼四种漏故。是故名为远离诸漏。文殊师利。何者无取。谓离四取。何等为四。谓欲取见取我取戒取。以此诸漏。众生为无明所闇。爱水所润。迭共相因虚妄取着。文殊师利。如来如实知我根本。以我清净如实知一切众生清净。所言我清净一切众生清净。此二无二无差别义。即是无生无灭。文殊师利。无生无灭何等法处。心意意识所不能知。文殊师利。何等法上无心意意识。彼法中无分别。分别何等法。而生不正念。是故菩萨生于正念。生正念者不起无明。不起无明者不起十二有支。不起十二有支者彼是不生。不生者即是位。位者即是了义。了义者即是第一义。第一义者即是无我义。无我义者即是不可说义。不可说义者即是因缘义。因缘义者即是法义。法义者即是如义。是故言见因缘者即是见法。见法者即是见如来。所言见者。虽见诸法而无所见。文殊师利。言有所见者。谓见心见观。如来不见心。若不见心不见观。彼是见实。文殊师利。彼诸法如是平等。如来如彼法平等而知。文殊师利。言菩提者。名为净无垢无点。文殊师利。何者为净。何者无垢。何者无点。文殊师利。空名为净。无相名无垢。无愿名无点。文殊师利。无生名为净。无行名无垢。无起名无点。文殊师利。自性名为净。善根净名无垢。光明圆满名无点。无戏论名为净。离戏论名无垢。寂灭一切戏论名无点。如名为净。法界名无垢。实际名无点。虚空名为净。无碍名无垢。不见名无点。内清净名为净。外不行名无垢。内外不见名无点。阴聚名为净。法界自体名无垢。十二入无去名无点。过去尽智名为净。未来无生智名无垢。现在住法界智名无点。文殊师利。略言净无垢无点。入一平等法足迹中。所谓寂静足迹。言寂静足迹者。即是寂灭。寂灭者即曰净。净者即是圣。文殊师利。如虚空菩提亦如是。如菩提法亦如是。如法法体亦如是。如法体众生亦如是。如众生国土亦如是。如国土涅槃亦如是。文殊师利。如来说一切法平等如涅槃。以毕竟究竟无所治法。离诸所治法。以本来清净。本来无垢。本来无点。文殊师利。如来如是如实觉一切法。观察一切众生性。即生清净无垢无点。奋迅大慈悲心。文殊师利。云何菩萨行菩萨行。文殊师利。若菩萨不生心。不为诸法尽。不为诸法生。非不为诸法不生。见诸法本来尽。见诸法不尽。而不生慢心言我如是知。而不坏诸法本来不生。文殊师利。菩萨如是行菩萨行。复次文殊师利。菩萨不见过去心尽行菩萨行。不见未来心未到行菩萨行。不见现在心有行菩萨行。而不着过去未来现在。心中如是行菩萨行。文殊师利。布施菩萨如来无二无差别。如是行名行菩萨行。持戒菩萨如来无二无差别。如是行名为行菩萨行。忍辱菩萨如来无二无差别。如是行名行菩萨行。精进菩萨如来无二无差别。如是行名行菩萨行。禅定菩萨如来无二无差别。如是行名行菩萨行。般若菩萨如来无二无差别。如是行名行菩萨行。文殊师利。菩萨不见色空。不见色不空。如是行名行菩萨行。何以故。色空色性。如是文殊师利。菩萨如是不行受想行识。不离受想行识。如是行名为行菩萨行。何以故。以不见心意识。文殊师利。无有一法若知若离若修若证。文殊师利。言尽者。彼法常尽。非不尽本来尽。若法本尽彼法不可尽。以不可尽是故说尽何以故。以如实尽故。若如实尽彼法不尽一法。若不尽一法彼法无为。若法无为。彼无为法不生不灭。是名如来。若如来出世及不出世。法性法体法住法位法界如实。法界如实住法智不生不灭。依彼智故知无为法。文殊师利。若入如是等诸法位者。知诸漏法不生不灭。文殊师利。言诸漏尽者。此依世间名字假言而说。而彼真如法身。无有法生亦无法灭。尔时文殊师利法王子菩萨摩诃萨。即从坐起偏袒右肩。右膝着地合掌向佛。即以妙偈赞叹如来。而说颂曰

  无色无形相　　无根无住处
  不生不灭故　　敬礼无所观
  不住亦不去　　不取亦不舍
  远离六入故　　敬礼无所观
  出过于三界　　等同于虚空
  诸欲不染故　　敬礼无所观
  于诸威仪中　　去来及睡寤
  常在寂静故　　敬礼无所观
  去来悉平等　　以住于平等
  不坏平等故　　敬礼无所观
  入诸无相定　　见诸法寂静
  常入平等故　　敬礼无所观
  诸佛虚空相　　虚空亦无相
  离诸因果故　　敬礼无所观
  虚空无中边　　诸佛身亦然
  心同虚空故　　敬礼无所观
  佛常在世间　　而不染世法
  不分别世间　　敬礼无所观
  诸法犹如幻　　而幻不可得
  离诸幻法故　　敬礼无所观

尔时世尊告文殊师利言。善哉善哉文殊师利。快说此法。文殊师利。如是如是。诸佛如来不应以色见。不应以法见。不应以相见。不应以好见。不应以法性见。文殊师利。诸佛如来。非可独见非可众见。文殊师利。诸佛如来无有人见无有人闻。无有人现在供养。无有人未来供养。文殊师利。诸佛如来不说诸法一不说诸法多。文殊师利。诸佛如来不证菩提。诸佛如来不依一法得名。亦非多法得名。文殊师利。诸佛如来不见诸法。不闻诸法不念诸法。不知诸法不觉诸法。文殊师利。诸佛如来。不说一法不示诸法。文殊师利。诸佛如来。现在不说诸法不示诸法文殊师利。诸佛如来不饮不食。文殊师利。诸佛如来无有法证。文殊师利。诸佛如来不断染法不证净法。文殊师利。诸佛如来不见诸法不闻诸法。不嗅诸法不知诸法。何以故。以一切法本清净故。文殊师利。若有人以三千大千世界微尘数等众生。令置辟支佛地。于此法门不生信心。若复有菩萨信此法门。此菩萨功德尚多于前。何况有人于此法门。若自书写令他书写。福多于彼无量无边

文殊师利。若三千大千世界所有众生。若卵生若胎生。若湿生若化生。若有色若无色。若有想若无想。若一足若二足若三足若四足。若多足若无足。彼诸众生。假使一时皆得人身。发菩提心悉为菩萨。一一菩萨。各以饮食衣服床榻卧具病瘦汤药。种种资生一切乐具。奉施供养恒河沙阿僧祇佛国土。微尘数等诸佛如来。及诸菩萨诸声闻僧如是乃至恒河沙阿僧祇劫。彼诸如来菩萨声闻。入涅槃后造七宝塔高一由旬。众宝栏楯周匝围绕。摩尼宝鬘以为间错。竖宝幢幡盖。自在摩尼宝王罗网弥覆其上。所得功德不可称计。若复有菩萨。以毕竟清净心。信此如来庄严智慧光明入一切佛境界经。信此法门。入此法门。不疑此法门。于此法门生清净心。乃至为他演说一偈。此菩萨所得功德。甚多无量阿僧祇。以此功德比前功德。百分不及一。歌罗千分不及一。百千分不及一。百千万分不及一。百千万亿分不及一。数分不及一。乃至算数譬喻所不能及。何以故。以能成就证佛智故

文殊师利。若有在家菩萨。以饮食衣服床榻卧具病瘦汤药。种种资生一切乐具。奉施供养恒河沙等阿僧祇诸佛如来。及诸菩萨诸声闻僧。如是乃至恒河沙等阿僧祇劫。所得功德不可称计。若复有出家菩萨。持戒心清净。乃至施与一畜生众生。乃至一口饮食。所得功德甚多无量阿僧祇。以此功德比前功德。百分不及一。歌罗千分不及一。百千万分不及一。百千万亿分不及一。歌罗少分不及一。乃至算数譬喻所不能及

文殊师利假使三千大千世界。微尘数等出家菩萨。持戒心清净。一一菩萨各以饮食衣服床榻卧具病瘦汤药。种种资生一切乐具。奉施供养十方世界恒河沙等。阿僧祇诸佛如来。及诸菩萨诸声闻僧。如是乃至恒河沙等阿僧祇劫。所得功德不可称计。若复有菩萨。持戒心清净。若在家若出家。闻此法门生信不疑。若自书写教他书写。所得功德甚多无量阿僧祇。以此功德比前菩萨檀施功德。百分不及一。歌罗千分不及一。百千万分不及一。数分不及一。乃至算数譬喻所不能及

文殊师利。若有菩萨摩诃萨。以满三千大千世界七宝。奉施供养诸佛如来。如是乃至三千大千世界微尘数劫。所得功德不可称计。若复有菩萨为余菩萨。于此法门中。乃至说一四句偈。所得功德甚多无量阿僧祇。以此功德比前功德百分不及一。歌罗千分不及一。百千万分不及一。百千万亿分不及一。数分不及一。歌罗少分不及一。算数分不及一。乃至算数譬喻所不能及

文殊师利。置满三千大千世界七宝。于三千大千世界微尘数劫。以用布施所得功德。文殊师利。若复有恒河沙等诸菩萨。一一菩萨恒河沙等阿僧祇佛国土。阎浮檀金以为世界。一切诸树天衣缠裹。集一切光明王摩尼宝罗网以覆其上。自在王摩尼宝以为楼阁。电光明摩尼宝以为栏楯。如意宝珠满彼世界。竖立一切诸宝幢幡盖。于日日中奉施供养恒河沙等阿僧祇诸佛如来。如是布施乃至恒河沙等阿僧祇劫。所得功德不可称计。若复有菩萨。信此法门。为余菩萨于此法门中乃至说一四句偈。所得功德甚多无量阿僧祇。以此功德比前功德百分不及一。歌罗千分不及一。百千万分不及一。百千万亿分不及一。数分不及一。歌罗少分不及一。僧企耶分不及一。数分不及一。忧波尼沙陀分不及一。乃至算数譬喻所不能及

文殊师利。假使三界中所有众生。彼诸众生。于地狱畜生饿鬼中。若有在家菩萨拔出尔许地狱畜生饿鬼众生置辟支佛地。所得功德不可称计。若复有出家菩萨乃至施与畜生一口饮食。所得功德胜前功德。无量无边阿僧祇

文殊师利。若复有十千国土。不可数亿那由他。百千万亿那由他。微尘数等出家菩萨。一一菩萨十方世界于一一方。见十亿不可说百千万亿那由他。微尘数等诸佛如来。一一如来及诸菩萨诸声闻僧。以饮食衣服卧具床榻病瘦汤药。种种资生一切乐具。满千亿那由他。百千万亿那由他。不可说微尘世界。自在王摩尼珠于一一日中。施一一如来并诸菩萨及声闻僧。如是乃至千亿那由他。百千万亿那由他。佛国土微尘数不可说劫。所得功德不可称计。若复有菩萨。信此法门。乃至施与一畜生众生。乃至一口饮食。所得功德甚多无量阿僧祇。以此功德比前功德百分不及一歌罗千分不及一。百千分不及一。百千万分不及一。百千万亿分不及一。僧企耶分不及一。歌罗少分不及一。数分不及一。乃至算数譬喻所不能及。何以故。以能信此法门不退转菩萨印故

文殊师利。若有菩萨教化十方一切世界所有众生置信行中。若复有菩萨化一众生置义行中。所得功德胜前功德无量无边。若复有菩萨教化十方一切世界所有众生置义行中。若复有菩萨化一众生置法行中。所得功德胜前功德无量无边

文殊师利。若复有菩萨教化十方一切世界所有众生置法行中。若复有余菩萨化一众生置八人中。所得功德胜前功德无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生置八人中。若复有菩萨化一众生令得须陀洹果。所得功德胜前功德无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生。令得须陀洹果。若复有菩萨化一众生令得斯陀含果所得功德胜前功德无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令得斯陀含果。若复有菩萨化一众生令得阿那含果。所得功德胜前功德无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令得阿那含果。若复有菩萨化一众生令得阿罗汉果。所得功德胜前功德乃至无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令得阿罗汉果。若复有菩萨化一众生令得辟支佛道。所得功德胜前功德乃至无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令得辟支佛道。若复有菩萨化一众生令发菩提心。所得功德乃至无量无边阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令发菩提心。若复有菩萨化一众生令得不退地。所得功德胜前功德乃至无量阿僧祇

文殊师利。若复有菩萨教化十方一切世界所有众生令得不退转地。若复有菩萨信此法门。若自书写教他书写广为人说。所得功德胜前功德乃至无量阿僧祇

如是乃至百千万亿那由他分不及其一。尔时世尊而说偈言

  菩萨能住持　　十亿佛妙法
  若人闻此经　　功德胜于彼
  为礼诸佛足　　神通游十方
  以华香涂香　　供养十亿佛
  若有闻此经　　为人须臾说
  功德胜于彼　　其数无有量
  若闻佛法身　　为第二人说
  钝闻生利智　　速证无上道
  为佛天人中　　造立诸妙塔
  满足无量亿　　上至于有顶
  周匝遍十方　　塔中竖幢幡
  金铃七宝盖　　如是供养佛
  菩萨闻是经　　若能自书写
  若教他书写　　其福胜于彼
  若人持此经　　远离于悭妒
  彼功德无量　　速成大菩提
  此经显法身　　如空现众像
  无量诸佛说　　是故应护持

佛说此经已。文殊师利法王子。及无量阿僧祇不可说不可说诸菩萨摩诃萨。及诸声闻众。一切世间天人阿修罗等。闻佛所说。欢喜奉行

如来庄严智慧光明入一切佛境界经卷下


入法界体性经

    No. 355

入法界体性经

        隋天竺三藏阇那崛多译

尔时婆伽婆。在王舍城耆阇崛山中。与大比丘众五百人俱。尔时文殊师利童子。于夜初分来诣佛所。到已在佛别门而立。是时如来住于三昧。尔时世尊从三昧起。见文殊师利童子住别门外。见已告言。文殊师利。汝来汝来。入内莫住于外。尔时文殊师利童子。闻佛告已。白佛言。善哉世尊。即诣佛所。到已顶礼佛足。却住一面

尔时世尊。告文殊师利童子。汝可就坐。时文殊师利童子言。善哉世尊。唯然受教。向佛合掌。却坐一面。于时文殊师利童子白佛言。世尊。今者世尊住何三昧而从起耶。佛告文殊师利。有三昧名曰宝积。然我于时。行此三昧。而从彼起。文殊师利复白佛言。以何因缘。名此三昧为宝积耶。佛告文殊师利。譬如大摩尼宝。善磨莹已安置净处。随彼地方。出诸珍宝。不可穷尽。如是文殊师利。我住此三昧。观于东方。见无量阿僧祇世界现在诸佛如来阿罗呵三藐三佛陀。如是南西北方四维上下。如是十方无量阿僧祇世界。我皆现见。是诸如来住此三昧。为众说法。文殊师利。我住此三昧。不见一法然非法界。文殊师利又此三昧。名实际印。若有纯直男子女人。行此印者辩才不断。文殊师利言。世尊。我有辩才。修伽陀我知辩才。佛言文殊师利。汝云何知辩才。文殊师利言。世尊。譬如彼摩尼宝不依余处。还依宝际而住。如是世尊。一切诸法更无所住。惟依实际而住。佛复告文殊师利。汝知实际乎。文殊师利言。如是世尊。我知实际。佛言文殊师利。何谓实际。文殊师利言。世尊。有我所际彼即实际。所有凡夫际。彼即实际。若业若果报。一切诸法悉是实际。世尊。若如是信者。即是实信。世尊。若颠倒信者。即是正信。若行非行。彼即正行。所以者何。正不正者。但有言说。不可得也。佛言。文殊师利。行者是何义。文殊师利言。世尊。行者是见实际义。佛言。文殊师利。修道是何义。文殊师利言。世尊。修道者思惟证义。佛言。文殊师利。汝云何为初行男子女人说法。文殊师利言。世尊。我于彼诸善男子善女人所。教发我见即是为其说法。世尊。我不灭贪欲诸患而为说法。所以者何。此等诸法。本性无生无灭故。世尊。若能灭实际。即能灭我见所生际。世尊。我为初行善男子善女人。如是说法。不受佛法。不着凡夫法。于诸法不举不舍。世尊。我为初发意男子女人。当如是说法。文殊师利言。世尊。亦为教化众生时。云何说法。佛言文殊师利。我不坏色生。亦不坏色不生故说法。如是受想行识亦不坏不生故说法。文殊师利。我不坏欲嗔痴等而为说法。文殊师利。我为诸教化者。当令知不思议法。我为说法。以如是故。我成阿耨多罗三藐三菩提。文殊师利。我无所坏诸法。已得成无上菩提。亦无有生。得成无上菩提。文殊师利。所言佛者。即是法界。于彼诸力无畏。亦是法界。文殊师利。我不见法界有其分数。我于法界中。不见此是凡夫法。此是阿罗汉法。辟支佛法。及诸佛法。其法界无有胜异。亦无坏乱。文殊师利。譬如恒河。若阎摩那。若可罗跋提河。如是等大河入于大海。其水不可别异。如是文殊师利。如是种种名字诸法。入于法界中无有名字差别。文殊师利。譬如种种诸谷聚中不可说别。是法界中亦无别名。有此有彼。是染是净。凡夫圣人及诸佛法。如是名字不可示现。如是法界如我今说。如是法界无违逆如是信乐。何以故。文殊师利。其逆顺界法界无二相故。无来无去。不可见故。无其起处。佛说如是法已。文殊师利复白佛言。世尊。我亦不见法界向恶道。亦不见向人天道。亦不向涅槃。佛复告文殊师利。若有人来问汝。云何现在有于六道。如是问者。汝云何答。文殊师利言。世尊。如是问者。我当解说。世尊。譬如有人睡眠作梦。或见地狱道。或见畜生道。或见阎摩罗人。或见阿修罗身。或见天处。或见人等。世尊。彼人所见梦事。诸道各各别异。又人问者。随意而说。然实无彼诸众生等。如是世尊。我虽说诸道各别。然其法界实无差别。世尊。如彼问者。我当为其如实解说。彼此无故。世尊。若行声闻乘取涅槃者。不可为说实义。世尊。彼等即今现在。亦不可为其分别。但说名字。何以故。取法界边际故。世尊。譬如大海有七种宝。若珂玉珊瑚金银生色等。可以相别。此是其宝。于法界中。不可知其别异之相。何以故。世尊。法界不生不灭。其法界无染无净。其法界无浊无乱。其法界中无可灭者。亦无生者

尔时世尊。知而故问文殊师利言。汝知法界耶。如是世尊。我知法界即是我界。佛复问文殊师利。汝知世间耶。文殊师利言。世尊。如幻化人所作处。是世间处。世尊。世间者但有名字。无实物可见。说名世间行。世尊。然我不离法界见于世间。何以故。无世间故。如世尊问言。世间何处行者。所谓色性不生不灭。彼行亦不生不灭。如是受想行识。此识性不生不灭。如是行亦无生无灭。世尊。如是一相所谓无相。佛复问言。文殊师利。汝岂不作是念。若现在如来阿罗诃三藐三佛陀。当灭度耶。文殊师利答言。世尊。岂可法界有已修集未修集也。法界既无修集。云何得有灭不现耶。佛言文殊师利。于汝意云何。过去诸佛。如恒伽沙等已灭度。汝岂不信耶。文殊师利言。世尊。我信诸如来皆已涅槃。见彼出处故。佛言文殊师利。于汝意云何。欲使诸凡夫死已更生也。文殊师利言。世尊。我尚不见有凡夫。何有更生耶。佛问文殊师利言。汝于佛前乐听法也。文殊师利言。世尊。我亦不见乐不乐相。佛言文殊师利。汝岂不乐法界耶。文殊师利答言。世尊。我不见有一法非法界者。更何所乐。佛言文殊师利。若慢者闻汝说。生大恐怖。文殊师利言。世尊。若慢者生怖。实际亦生恐怖。其实际不恐怖故。即一切诸法皆无恐怖。以无修作故。此是金刚句。佛言文殊师利。何故名此为金刚句。文殊师利言。世尊。诸法性不坏。是故名金刚句。世尊。如来不思议句。是诸法不思议。是金刚句。佛言文殊师利。何故复名此为金刚句。文殊师利言。世尊。诸法无思故。是金刚句。世尊。诸法是菩提。是金刚句。佛言文殊师利。何故复名此为金刚句。文殊师利言。世尊。一切法无所有。但有名字言说。诸法无此无彼。皆无所有。此彼无所有者。即是如。若是如者则是真实。若是实者彼则是菩提。是故得名为金刚句。文殊师利言。世尊。一切诸法是如来境界。是金刚句。佛言文殊师利。何故名此为金刚句。文殊师利言。世尊。诸法自性本来寂静故。是金刚句。佛告文殊师利。汝可唤阿难陀比丘来。令受持此法本句。文殊师利言。世尊。我于中不见有一法可说可听。世尊。我实不见一字有其说处。何有多句而可持乎。佛言。善哉善哉。文殊师利。汝善说此语。文殊师利。我见东方无量阿僧祇世界中。诸如来阿罗呵三藐三佛陀。亦说此法本

尔时长老舍利弗。从自住处出。往诣文殊师利童子住处。到已不见文殊师利。即诣佛所。到已在佛别门外边而住

尔时世尊告文殊师利童子言。文殊师利。是舍利弗比丘。今在门外。为欲听法。汝令使入。文殊师利言。世尊。若彼舍利弗际。若法界际。世尊。此二际。岂有在内在外若中间二耶。佛言不也。文殊师利言。世尊。言实际者。亦非实际。如是际非际。无内无外。不来不去。世尊。长老舍利弗际。即是实际。舍利弗界。即是法界。世尊。然此法界。无出无入。不来不去。其长老舍利弗。从何处来。当入何所。佛言。文殊师利。若我在内。共诸声闻语论。汝在于外而不听入。汝意岂不生苦恼想耶。文殊师利言。不也世尊。何以故。世尊凡所说法不离法界。如来说法即是法界。法界即是如来。说法界。如法界言说界。无二别无所有。名者说者。此等皆不离法界。世尊。以是义故。我不苦恼。世尊。若我恒河沙劫等。不来至世尊说法所。我时不生爱乐。亦无忧恼。何以故。若有二者即生忧恼。法界无二故无恼耶

尔时世尊告长老舍利弗言。舍利弗。汝来入听。文殊师利辩才耶。舍利弗言。唯然世尊。我甚乐闻。今在室外。欲听世尊及文殊师利童子所说。尔时文殊师利白佛言。世尊。令长老舍利弗得入听法。尔时世尊告长老舍利弗言。舍利弗汝来前入。舍利弗言善哉世尊。即前入室顶礼佛足。退坐一面。尔时文殊师利言。长老舍利弗。汝见何义故而来此耶。舍利弗言。文殊师利。我欲听法故来此耳。此处应有最胜法义。以有文殊师利与世尊共处。各有论说必有妙美。当有甚深最胜法义。时文殊师利言。如是如是。舍利弗。我说甚深最胜法。舍利弗言。文殊师利。此说法以何义为甚深最胜。文殊师利言。舍利弗。此法难知。以无器故。凡所说无所发起。此所说法不为发起故。凡夫亦不为发起。阿罗汉法亦不为发起。如来法起发此说法。以无所依无能依故。发此说法。是故说法平等。平等无有住处。毕竟寂静。说诸法故。此无所住故称最胜。舍利弗言。文殊师利。以何义故作如是说。阿罗汉漏尽非受此法器。文殊师利言。长老舍利弗。阿罗汉者惟尽欲嗔痴等粗惑故。彼何能作器。舍利弗。以是义故我作如是言。阿罗汉漏尽非此法器。舍利弗言。文殊师利以斯义故。我今求汝。从一游处至一游处。从室至室。从窟至窟。我故求汝。为法乐处。辩才欲听法故。文殊师利。我听世尊及汝说法。无有厌足。时文殊师利言。大德舍利弗。汝不知足听法耶。舍利弗言。文殊师利。我不厌听法。文殊师利言。大德舍利弗。岂可法界取说法耶。舍利弗言。不也。文殊师利言。大德舍利弗。既无厌听法。然法界共大德界。无二无别。其法界不取说法。若取则可知足。既不取是故不知足。舍利弗言。文殊师利。除诸如来。何有听法如是也。文殊师利言。大德舍利弗。汝言涅槃法。是舍利弗耶。舍利弗言。文殊师利。我有信。文殊师利言。汝云何信。舍利弗言。诸法本性成就故。我无涅槃。文殊师利又问。舍利弗。汝信无死法耶。舍利弗言。文殊师利。我有信。文殊师利言。汝云何信。舍利弗言。夫法界者。不死不生。我信如是。文殊师利又问。大德舍利弗。汝信无智具足漏尽阿罗汉耶。舍利弗言。我有信。文殊师利言。汝云何信。舍利弗言。无智智平等故。具足漏尽阿罗汉。何以故。非但智离无智。无智亦离。无智尽法更无智。无分别故。离智是漏尽阿罗汉。文殊师利问大德舍利弗言。汝信漏尽阿罗汉解脱法耶。舍利弗言。文殊师利我实有信。文殊师利言。汝云何信。舍利弗言。彼诸法离诸法。然不取诸法。我如是信。文殊师利问大德舍利弗言。汝信前世诸如来阿罗呵三藐三佛陀。灭度而不得涅槃耶。舍利弗言。我信。文殊又问。汝云何信。舍利弗言。文殊师利。彼不思议界无生无没者。我如是信。文殊师利问大德舍利弗言。汝信诸佛是一佛耶。舍利弗言。我信。文殊师利言。汝云何信。舍利弗言。文殊师利。法界不可分别。我如是信。文殊师利问大德舍利弗。汝信诸佛刹即是一佛刹耶。舍利弗言。我有信。文殊师利又问。汝云何信。舍利弗言。文殊师利。是诸佛刹依如。无尽刹亦无尽。我如是信。文殊师利问舍利弗。汝信诸法无可证无可灭。无可思念不可修作耶。舍利弗言。文殊师利。我有信。文殊师利言。汝云何信。舍利弗言。文殊师利。自体不自知自体。本性不舍本性。自体亦不证。亦无思念。不相违背。不生不灭。不取不舍。善住彼际。我如是信。文殊师利问言。舍利弗。汝信有为界。于法界中无有法生。亦无有灭。亦无积聚耶。舍利弗言。我有信。文殊又问。汝云何信。舍利弗言。文殊师利。彼诸法性不可得。知若生若灭若积聚住者。我如是信。文殊师利言。大德舍利弗。汝信有般若法界。于中亦有阿罗汉名字耶。舍利弗言。我有信。文殊师利言。汝云何信。舍利弗言。文殊师利。厌行般若法界。是阿罗汉界。然法界体离非欲嗔痴体。其阿罗汉岂能离法界也。我如是信。文殊师利言。大德舍利弗。汝信诸法皆是佛境界忍耶。舍利弗言。我实有信。文殊师利问言。汝云何信。舍利弗言。文殊师利。世尊本性觉自性离故。我如是信

尔时文殊师利言。善哉善哉。大德舍利弗。如汝所有境界。为我解释。我如是问汝如是答。是故我知有尔许行也。尔时世尊告长老舍利弗言。舍利弗。若有善男子善女人。受持此法本句。若为他解释。若读若诵。然彼人等速得辩才。舍利弗言。如是婆伽婆。如是修伽陀。大德世尊所说。世尊。然彼众生。于前世时。已曾供养诸佛世尊已。为彼善男子善女人。安立于此法印。彼等众生当得大觉

尔时长老舍利弗白佛言。世尊。此法本有何名字。我等云何奉持。佛告长老舍利弗言。舍利弗。我此法本名文殊师利童子所问。佛为解说。如是受持。亦名入法界。如是受持。亦名实际。如是受持。舍利弗。彼善男子善女人等。恭敬当如胜宝。若受持此法本。若读若诵。若思惟。如行当得无生法忍。若为生他善根。若少读诵已。而能为他多说法义。当得不断辩才。佛说此经时。文殊师利童子。及余菩萨摩诃萨。上坐舍利弗。及余诸比丘。并诸天众。揵闼婆人阿修罗等。闻佛所说皆大欢喜

入法界体性经


胜鬘师子吼一乘大方便方广经

    No. 353 [No. 310(48)]

胜鬘师子吼一乘大方便方广经

        宋中印度三藏求那跋陀罗译

    如来真实义功德章第一

如是我闻。一时佛住舍卫国祇树给孤独园。时波斯匿王及末利夫人。信法未久共相谓言。胜鬘夫人是我之女。聪慧利根通敏易悟。若见佛者必速解法心得无疑。宜时遣信发其道意。夫人白言。今正是时。王及夫人与胜鬘书略赞如来。无量功德。即遣内人名旃提罗。使人奉书至阿踰阇国入其宫内敬授胜鬘。胜鬘得书欢喜顶受。读诵受持生希有心。向旃提罗而说偈言

  我闻佛音声　　世所未曾有
  所言真实者　　应当修供养
  仰惟佛世尊　　普为世间出
  亦应垂哀愍　　必令我得见
  即生此念时　　佛于空中现
  普放净光明　　显示无比身
  胜鬘及眷属　　头面接足礼
  咸以清净心　　叹佛实功德
  如来妙色身　　世间无与等
  无比不思议　　是故今敬礼
  如来色无尽　　智慧亦复然
  一切法常住　　是故我归依
  降伏心过恶　　及与身四种
  已到难伏地　　是故礼法王
  知一切尔焰　　智慧身自在
  摄持一切法　　是故今敬礼
  敬礼过称量　　敬礼无譬类
  敬礼无边法　　敬礼难思议
  哀愍覆护我　　令法种增长
  此世及后生　　愿佛常摄受
  我久安立汝　　前世已开觉
  今复摄受汝　　未来生亦然
  我已作功德　　现在及余世
  如是众善本　　唯愿见摄受

尔时胜鬘及诸眷属。头面礼佛。佛于众中即为受记。汝叹如来真实功德。以此善根当于无量阿僧祇劫。天人之中为自在王一切生处常得见。我现前赞叹如今无异。当复供养无量阿僧祇佛过二万阿僧祇劫。当得作佛号。普光如来应正遍知。彼佛国土。无诸恶趣老病衰恼不适意苦亦无不善恶业道名。彼国众生色力寿命五欲众具皆悉快乐胜于他化自在诸天。彼诸众生纯一大乘诸有修习善根众生皆集于彼。胜鬘夫人得受记时。无量众生诸天及人愿生彼国。世尊悉记皆当往生

    十受章第二

尔时胜鬘闻受记已。恭敬而立受十大受。世尊。我从今日乃至菩提。于所受戒不起犯心。世尊。我从今日乃至菩提于诸尊长不起慢心。世尊。我从今日乃至菩提。于诸众生不起恚心。世尊。我从今日乃至菩提。于他身色及外众具不起疾心。世尊。我从今日乃至菩提。于内外法不起悭心。世尊。我从今日乃至菩提。不自为己受畜财物。凡有所受悉为成熟贫苦众生。世尊。我从今日乃至菩提。不自为己行四摄法。为一切众生故。以不爱染心无厌足心无挂碍心摄受众生。世尊。我从今日乃至菩提。若见孤独幽系疾病种种厄难困苦众生。终不暂舍。必欲安隐。以义饶益令脱众苦。然后乃舍。世尊。我从今日乃至菩提。若见捕养众恶律仪及诸犯戒终不弃舍。我得力时。于彼彼处见此众生。应折伏者而折伏之。应摄受者而摄受之。何以故。以折伏摄受故令法久住。法久住者。天人充满恶道减少。能于如来所转法轮。而得随转。见是利故救摄不舍。世尊。我从今日乃至菩提。摄受正法终不忘失。何以故。忘失法者则忘大乘。忘大乘者则忘波罗蜜。忘波罗蜜者则不欲大乘。若菩萨不决定大乘者。则不能得摄受正法欲。随所乐入。永不堪任越凡夫地。我见如是无量大过。又见未来摄受正法。菩萨摩诃萨无量福利故受此大受。法主世尊现为我证。唯佛世尊现前证知。而诸众生善根微薄。或起疑网以十大受极难度故。彼或长夜非义饶益不得安乐。为安彼故。今于佛前说诚实誓。我受此十大受如说行者。以此誓故于大众中当雨天花出天妙音。说是语时于虚空中。雨众天花出妙声言。如是如是如汝所说。真实无异。彼见妙花及闻音声一切众会疑惑悉除。喜踊无量而发愿言。恒与胜鬘常共俱会同其所行。世尊悉记一切大众如其所愿

    三愿章第三

尔时胜鬘。复于佛前发三大愿而作是言。以此实愿安隐无量无边众生。以此善根于一切生得正法智。是名第一大愿。我得正法智已。以无厌心为众生说。是名第二大愿。我于摄受正法舍身命财护持正法。是名第三大愿。尔时世尊即记胜鬘。三大誓愿如一切色悉入空界。如是菩萨恒沙诸愿。皆悉入此三大愿中。此三愿者真实广大

    摄受章第四

尔时胜鬘白佛言。我今当复承佛威神说调伏大愿真实无异。佛告胜鬘。恣听汝说。胜鬘白佛。菩萨所有恒沙诸愿。一切皆入一大愿中。所谓摄受正法。摄受正法真为大愿。佛赞胜鬘。善哉善哉。智慧方便甚深微妙。汝已长夜殖诸善本。来世众生久种善根者。乃能解汝所说。汝之所说摄受正法。皆是过去未来现在诸佛已说今说当说。我今得无上菩提。亦常说此摄受正法。如是我说摄受正法所有功德不得边际。如来智慧辩才亦无边际。何以故。是摄受正法有大功德有大利益

胜鬘白佛。我当承佛神力更复演说摄受正法广大之义。佛言。便说。胜鬘白佛。摄受正法广大义者。则是无量。得一切佛法摄八万四千法门。譬如劫初成时普兴大云雨众色雨及种种宝。如是摄受正法雨无量福报及无量善根之雨。世尊。又如劫初成时有大水聚。出生三千大千界藏及四百亿种种类洲。如是摄受正法。出生大乘无量界藏。一切菩萨神通之力。一切世间安隐快乐。一切世间如意自在。及出世间安乐。劫成乃至天人本所未得皆于中出。又如大地持四重担。何等为四。一者大海。二者诸山。三者草木。四者众生。如是摄受正法善男子善女人。建立大地堪能荷负四种重任。喻彼大地。何等为四。谓离善知识无闻非法众生。以人天善根而成熟之。求声闻者授声闻乘。求缘觉者授缘觉乘。求大乘者授以大乘。是名摄受正法善男子善女人建立大地堪能荷负四种重任。世尊。如是摄受正法善男子善女人。建立大地堪能荷负四种重任。普为众生作不请之友。大悲安慰哀愍众生。为世法母。又如大地有四种宝藏。何等为四。一者无价。二者上价。三者中价。四者下价。是名大地四种宝藏。如是摄受正法善男子善女人。建立大地得众生四种最上大宝。何等为四。摄受正法善男子善女人。无闻非法众生以人天功德善根而授与之。求声闻者授声闻乘。求缘觉者授缘觉乘。求大乘者授以大乘。如是得大宝众生。皆由摄受正法善男子善女人得此奇特希有功德。世尊。大宝藏者。即是摄受正法。世尊。摄受正法。摄受正法者。无异正法。无异摄受正法。正法即是摄受正法。世尊。无异波罗蜜。无异摄受正法。摄受正法即是波罗蜜。何以故。摄受正法善男子善女人。应以施成熟者。以施成熟。乃至舍身支节。将护彼意而成熟之。彼所成熟众生建立正法。是名檀波罗蜜。应以戒成熟者。以守护六根净身口意业。乃至正四威仪。将护彼意而成熟之。彼所成熟众生建立正法。是名尸波罗蜜。应以忍成熟者。若彼众生骂詈毁辱诽谤恐怖。以无恚心饶益心第一忍力乃至颜色无变。将护彼意而成熟之。彼所成熟众生建立正法。是名羼提波罗蜜。应以精进成熟者。于彼众生不起懈心生大欲心第一精进。乃至若四威仪。将护彼意而成熟之。彼所成熟众生建立正法。是名毗梨耶波罗蜜。应以禅成熟者。于彼众生以不乱心不外向心第一正念乃至久时所作久时所说终不忘失。将护彼意而成熟之。彼所成熟众生建立正法。是名禅波罗蜜。应以智慧成熟者。彼诸众生问一切义以无畏心而为演说一切论一切工巧究竟明处乃至种种工巧诸事。将护彼意而成熟之。彼所成熟众生建立正法。是名般若波罗蜜。是故世尊。无异波罗蜜。无异摄受正法。摄受正法即是波罗蜜

世尊。我今承佛威神更说大义。佛言。便说。胜鬘白佛。摄受正法。摄受正法者。无异摄受正法。无异摄受正法者。摄受正法善男子善女人。即是摄受正法。何以故。若摄受正法善男子善女人。为摄受正法舍三种分。何等为三。谓身命财。善男子善女人舍身者。生死后际等离老病死。得不坏常住无有变易不可思议功德如来法身。舍命者。生死后际等毕竟离死。得无边常住不可思议功德。通达一切甚深佛法。舍财者。生死后际等得不共一切众生无尽无减毕竟常住不可思议具足功德。得一切众生殊胜供养。世尊。如是舍三分善男子善女人。摄受正法。常为一切诸佛所记一切众生之所瞻仰

世尊。又善男子善女人摄受正法者。法欲灭时。比丘比丘尼优婆塞优婆夷。朋党诤讼破坏离散。以不谄曲不欺诳不幻伪。爱乐正法。摄受正法。入法朋中。入法朋者。必为诸佛之所授记。世尊。我见摄受正法如是大力。佛为实眼实智。为法根本。为通达法。为正法依。亦悉知见

尔时世尊。于胜鬘所说摄受正法大精进力。起随喜心。如是胜鬘。如汝所说。摄受正法大精进力。如大力士少触身分生大苦痛。如是胜鬘。少摄受正法令魔苦恼。我不见余一善法令魔忧苦如少摄受正法。又如牛王形色无比胜一切牛。如是大乘少摄受正法。胜于一切二乘善根。以广大故。又如须弥山王端严殊特胜于众山。如是大乘舍身命财以摄取心摄受正法。胜不舍身命财初住大乘一切善根。何况二乘。以广大故。是故胜鬘。当以摄受正法。开示众生教化众生建立众生。如是胜鬘。摄受正法。如是大利如是大福。如是大果。胜鬘。我于阿僧祇阿僧祇劫说摄受正法功德义利不得边际。是故摄受正法。有无量无边功德

    一乘章第五

佛告胜鬘。汝今更说一切诸佛所说摄受正法。胜鬘白佛。善哉世尊。唯然受教。即白佛言。世尊。摄受正法者是摩诃衍。何以故。摩诃衍者。出生一切声闻缘觉世间出世间善法。世尊。如阿耨大池出八大河。如是摩诃衍。出生一切声闻缘觉世间出世间善法。世尊。又如一切种子皆依于地而得生长。如是一切声闻缘觉世间出世间善法。依于大乘而得增长。是故世尊。住于大乘摄受大乘。即是住于二乘摄受二乘一切世间出世间善法。如世尊说六处。何等为六谓正法住。正法灭。波罗提木叉。比尼。出家。受具足。为大乘故说此六处。何以故。正法住者。为大乘故说。大乘住者。即正法住。正法灭者。为大乘故说。大乘灭者。即正法灭。波罗提木叉。比尼。此二法者。义一名异。比尼者即大乘学。何以故。以依佛出家而受具足。是故说大乘威仪戒是比尼是出家是受具足。是故阿罗汉。无出家受具足。何以故。阿罗汉依如来出家受具足故。阿罗汉归依于佛。阿罗汉有恐怖。何以故。阿罗汉于一切无行怖畏想住。如入执剑欲来害己。是故阿罗汉无究竟乐。何以故。世尊。依不求依如众生无依彼彼恐怖。以恐怖故则求归依。如阿罗汉有怖畏。以怖畏故。依于如来。世尊。阿罗汉辟支佛有怖畏。是故阿罗汉辟支佛。有余生法不尽故。有生有余梵行不成故。不纯事不究竟故。当有所作。不度彼故。当有所断。以不断故。去涅槃界远。何以故。唯有如来应正等觉得般涅槃。成就一切功德故。阿罗汉辟支佛。不成就一切功德。言得涅槃者。是佛方便。唯有如来得般涅槃。成就无量功德故。阿罗汉辟支佛。成就有量功德。言得涅槃者。是佛方便。唯有如来得般涅槃。成就不可思议功德故。阿罗汉辟支佛。成就思议功德。言得涅槃者。是佛方便。唯有如来得般涅槃。一切所应断过皆悉断灭。成就第一清净。阿罗汉辟支佛有余过。非第一清净。言得涅槃者。是佛方便。唯有如来得般涅槃。为一切众生之所瞻仰。出过阿罗汉辟支佛菩萨境界。是故阿罗汉辟支佛。去涅槃界远。言阿罗汉辟支佛观察解脱四智究竟得苏息处者。亦是如来方便。有余不了义说。何以故。有二种死。何等为二。谓分段死。不思议变易死。分段死者。谓虚伪众生。不思议变易死者。谓阿罗汉辟支佛大力菩萨意生身乃至究竟无上菩提。二种死中。以分段死故。说阿罗汉辟支佛智我生已尽。得有余果证故。说梵行已立。凡夫人天所不能办。七种学人先所未作。虚伪烦恼断故。说所作已办。阿罗汉辟支佛所断烦恼更不能受后有故。说不受后有。非尽一切烦恼。亦非尽一切受生故说不受后有。何以故有烦恼。是阿罗汉辟支佛所不能断烦恼有二种。何等为二。谓住地烦恼。及起烦恼住地有四种。何等为四。谓见一处住地欲爱住地。色爱住地。有爱住地。此四种住地。生一切起烦恼。起者刹那心刹那相应。世尊。心不相应无始无明住地。世尊。此四住地力。一切上烦恼依种。比无明住地。算数譬喻所不能及

世尊。如是无明住地力。于有爱数四住地。无明住地其力最大。譬如恶魔波旬于他化自在天色力寿命眷属众具自在殊胜。如是无明住地力。于有爱数四住地。其力最胜。恒沙等数上烦恼依。亦令四种烦恼久住。阿罗汉辟支佛智所不能断。唯如来菩提智之所能断。如是世尊。无明住地最为大力。世尊。又如取缘有漏业因而生三有。如是无明住地缘无漏业因。生阿罗汉辟支佛大力菩萨三种意生身。此三地彼三种意生身生。及无漏业生。依无明住地。有缘非无缘。是故三种意生及无漏业缘无明住地。世尊如是有爱住地数四住地。不与无明住地业同。无明住地异离四住地。佛地所断。佛菩提智所断。何以故。阿罗汉辟支佛。断四种住地。无漏不尽不得自在力。亦不作证。无漏不尽者。即是无明住地。世尊。阿罗汉辟支佛最后身菩萨。为无明住地之所覆障故。于彼彼法不知不觉。以不知见故。所应断者不断不究竟。以不断故。名有余过解脱。非离一切过解脱。名有余清净。非一切清净。名成就有余功德。非一切功德。以成就有余解脱有余清净有余功德故。知有余苦。断有余集。证有余灭。修有余道。是名得少分涅槃。得少分涅槃者。名向涅槃界。若知一切苦。断一切集。证一切灭。修一切道。于无常坏世间。无常病世间。得常住涅槃。于无覆护世间无依世间。为护为依。何以故。法无优劣故得涅槃。智慧等故得涅槃。解脱等故得涅槃。清净等故得涅槃。是故涅槃一味等味。谓解脱味。世尊。若无明住地。不断不究竟者。不得一味等味谓明解脱味。何以故。无明住地不断不究竟者。过恒沙等所应断法。不断不究竟。过恒沙等所应断法不断故。过恒沙等法应得不得应证不证。是故无明住地积聚生一切修道断烦恼上烦恼。彼生心上烦恼。止上烦恼。观上烦恼。禅上烦恼。正受上烦恼。方便上烦恼。智上烦恼。果上烦恼。得上烦恼。力上烦恼。无畏上烦恼。如是过恒沙等上烦恼。如来菩提智所断。一切皆依无明住地之所建立。一切上烦恼起。皆因无明住地缘无明住地。世尊。于此起烦恼刹那心刹那相应。世尊。心不相应无始无明住地。世尊。若复过于恒沙如来菩提智所应断法。一切皆是无明住地所持所建立。譬如一切种子皆依地生建立增长若地坏者彼亦随坏。如是过恒沙等如来菩提智所应断法。一切皆依无明住地生建立增长。若无明住地断者。过恒沙等如来菩提智所应断法。皆亦随断。如是一切烦恼上烦恼断过恒沙等。如来所得一切诸法通达无碍一切智见。离一切过恶。得一切功德法王法主。而得自在。登一切法自在之地。如来应等正觉正师子吼。我生已尽梵行已立所作已办不受后有。是故世尊。以师子吼依于了义。一向记说

世尊。不受后有智有二种。谓如来以无上调御。降伏四魔出一切世间。为一切众生之所瞻仰。得不思议法身。于一切尔焰地得无碍法自在。于上更无所作无所得地。十力勇猛升于第一无上无畏之地。一切尔炎无碍智观不由于他。不受后有智师子吼。世尊。阿罗汉辟支佛。度生死畏次第得解脱乐。作是念。我离生死恐怖不受生死苦。世尊。阿罗汉辟支佛观察时。得不受后有观第一苏息处涅槃地。世尊。彼先所得地。不愚于法不由于他。亦自知得有余地。必当得阿耨多罗三藐三菩提。何以故。声闻缘觉乘皆入大乘。大乘者即是佛乘。是故三乘即是一乘。得一乘者。得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提者。即是涅槃界。涅槃界者即是如来法身。得究竟法身者。则究竟一乘。无异如来无异法身。如来即法身。得究竟法身者。则究竟一乘。究竟者即是无边不断

世尊。如来无有限齐时。住如来应等正觉后际等住。如来无限齐。大悲亦无限齐。安慰世间。无限大悲无限安慰世间。作是说者。是名善说如来。若复说言无尽法常住法一切世间之所归依者。亦名善说如来。是故于未度世间无依世间。与后际等作无尽归依常住归依者。谓如来应等正觉也。法者即是说一乘道。僧者是三乘众。此二归依非究竟归依。名少分归依。何以故。说一乘道法。得究竟法身。于上更无说一乘法身。三乘众者有恐怖归依如来。求出修学向阿耨多罗三藐三菩提。是故二依非究竟依。是有限依。若有众生如来调伏。归依如来得法津泽。生信乐心归依法僧。是二归依非此二归依。是归依如来。归依第一义者。是归依如来。此二归依第一义。是究竟归依如来。何以故。无异如来。无异二归依。如来即三归依。何以故。说一乘道。如来四无畏成就师子吼说。若如来随彼所欲而方便说。即是大乘无有三乘。三乘者入于一乘。一乘者即第一义乘

    无边圣谛章第六

世尊。声闻缘觉初观圣谛以一智断诸住地。以一智四断知功德作证亦善知此四法义。世尊。无有出世间上上智。四智渐至及四缘渐至。无渐至法是出世间上上智。世尊。金刚喻者是第一义智。世尊。非声闻缘觉不断无明住地初圣谛智是第一义智。世尊。以无二圣谛智。断诸住地。世尊。如来应等正觉。非一切声闻缘觉境界不思议空智。断一切烦恼藏。世尊。若坏一切烦恼藏究竟智。是名第一义智。初圣谛智。非究竟智。向阿耨多罗三藐三菩提智

世尊。圣义者。非一切声闻缘觉。声闻缘觉成就有量功德。声闻缘觉成就少分功德。故名之为圣。圣谛者。非声闻缘觉谛。亦非声闻缘觉功德。世尊。此谛如来应等正觉初始觉知。然后为无明[穀-禾+卵]藏世间开现演说。是故名圣谛

    如来藏章第七

圣谛者说甚深义。微细难知。非思量境界。是智者所知。一切世间所不能信。何以故。此说甚深如来之藏。如来藏者。是如来境界。非一切声闻缘觉所知。如来藏处。说圣谛义。如来藏处甚深故。说圣谛亦甚深。微细难知。非思量境界。是智者所知。一切世间所不能信

    法身章第八

若于无量烦恼藏所缠如来藏不疑惑者。于出无量烦恼藏法身亦无疑惑。于说如来藏。如来法身不思议佛境界及方便说。心得决定者此则信解说二圣谛。如是难知难解者。谓说二圣谛义。何等为说二圣谛义。谓说作圣谛义。说无作圣谛义。说作圣谛义者。是说有量四圣谛。何以故。非因他能知一切苦断一切集证一切灭修一切道。是故世尊。有有为生死无为生死。涅槃亦如是。有余及无余。说无作圣谛义者。说无量四圣谛义。何以故。能以自力知一切受苦断一切受集证一切受灭修一切受灭道。如是八圣谛。如来说四圣谛。如是四无作圣谛义。唯如来应等正觉事究竟。非阿罗汉辟支佛事究竟。何以故。非下中上法得涅槃。何以故。如来应等正觉。于无作四圣谛义事究竟。以一切如来应等正觉。知一切未来苦断一切烦恼上烦恼所摄受一切集灭一切意生身除。一切苦灭作证。世尊。非坏法故。名为苦灭。所言苦灭者。名无始无作无起无尽离。尽常住自性清净离一切烦恼藏。世尊。过于恒沙不离不脱不异不思议佛法成就说如来法身。世尊。如是如来法身不离烦恼藏名如来藏

    空义隐覆真实章第九

世尊。如来藏智。是如来空智。世尊如来藏者。一切阿罗汉辟支佛大力菩萨。本所不见本所不得

世尊。有二种如来藏空智。世尊。空如来藏。若离若脱若异。一切烦恼藏。世尊。不空如来藏。过于恒沙不离不脱不异不思议佛法。世尊。此二空智。诸大声闻。能信如来。一切阿罗汉辟支佛。空智于四不颠倒境界转。是故一切阿罗汉辟支佛。本所不见。本所不得。一切苦灭。唯佛得证。坏一切烦恼藏。修一切灭苦道

    一谛章第十

世尊。此四圣谛。三是无常一是常。何以故。三谛入有为相。入有为相者。是无常。无常者是虚妄法。虚妄法者。非谛非常非依。是故苦谛集谛道谛。非第一义谛。非常非依

    一依章第十一

一苦灭谛。离有为相。离有为相者是常。常者非虚妄法。非虚妄法者。是谛是常是依。是故灭谛。是第一义

    颠倒真实章第十二

不思议是灭谛。过一切众生心识所缘。亦非一切阿罗汉辟支佛智慧境界。譬如生盲不见众色七日婴儿不见日轮。苦灭谛者。亦复如是。非一切凡夫心识所缘。亦非二乘智慧境界。凡夫识者二见颠倒。一切阿罗汉辟支佛智者。则是清净。边见者。凡夫于五受阴我见妄想计着生二见。是名边见。所谓常见断见。见诸行无常。是断见非正见。见涅槃常。是常见非正见。妄想见故作如是见。于身诸根分别思惟现法见坏。于有相续不见起于断见。妄想见故。于心相续愚闇不解不知。刹那间意识境界起于常见。妄想见故。此妄想见于彼义。若过若不及作异想分别。若断若常。颠倒众生于五受阴。无常常想苦有乐想。无我我想。不净净想。一切阿罗汉辟支佛净智者。于一切智境界及如来法身本所不见。或有众生。信佛语故。起常想乐想我想净想。非颠倒见。是名正见。何以故。如来法身是常波罗蜜乐波罗蜜。我波罗蜜。净波罗蜜。于佛法身。作是见者是名正见。正见者。是佛真子。从佛口生。从正法生。从法化生。得法余财。世尊净智者。一切阿罗汉辟支佛。智波罗蜜。此净智者。虽曰净智。于彼灭谛。尚非境界。况四依智。何以故。三乘初业。不愚于法。于彼义当觉当得。为彼故世尊说四依。世尊此四依者。是世间法。世尊。一依者。一切依止。出世间上上第一义依。所谓灭谛

    自性清净章第十三

世尊。生死者依如来藏。以如来藏故。说本际不可知。世尊。有如来藏故说生死。是名善说。世尊。生死。生死者。诸受根没。次第不受根起。是名生死。世尊。死生者此二法是如来藏。世间言说故。有死有生。死者谓根坏。生者新诸根起。非如来藏有生有死。如来藏者离有为相。如来藏常住不变。是故如来藏。是依是持是建立。世尊。不离不断不脱不异不思议佛法。世尊。断脱异外有为法依持建立者。是如来藏。世尊。若无如来藏者。不得厌苦乐求涅槃。何以故。于此六识及心法智。此七法刹那不住。不种众苦。不得厌苦乐求涅槃。世尊。如来藏者。无前际不起不灭法。种诸苦得厌苦乐求涅槃。世尊。如来藏者。非我非众生非命非人。如来藏者。堕身见众生颠倒众生空乱意众生。非其境界

世尊。如来藏者。是法界藏。法身藏。出世间上上藏。自性清净藏。此性清净。如来藏而客尘烦恼上烦恼所染。不思议如来境界。何以故。刹那善心非烦恼所染。刹那不善心亦非烦恼所染。烦恼不触心。心不触烦恼。云何不触法。而能得染心。世尊。然有烦恼有烦恼染心。自性清净心而有染者。难可了知。唯佛世尊。实眼实智。为法根本。为通达法。为正法依。如实知见

胜鬘夫人说是难解之法问于佛时。佛即随喜。如是如是。自性清净心而有染污难可了知。有二法难可了知。谓自性清净心。难可了知。彼心为烦恼所染亦难了知。如此二法。汝及成就大法菩萨摩诃萨乃能听受。诸余声闻唯信佛语

    真子章第十四

若我弟子随信增上者。依明信已随顺法智。而得究竟。随顺法智者观察施设根意解境界。观察业报。观察阿罗汉眼。观察心自在乐禅乐。观察阿罗汉辟支佛大力菩萨圣自在通。此五种巧便观成就。于我灭后未来世中。我弟子随信增上依于明信随顺法智。自性清净心。彼为烦恼染污而得究竟。是究竟者入大乘道因。信如来者。有是大利益。不谤深义

尔时胜鬘白佛言。更有余大利益。我当承佛威神复说斯义。佛言。更说。胜鬘白佛言。三种善男子善女人。于甚深义离自毁伤。生大功德入大乘道。何等为三。谓若善男子善女人。自成就甚深法智。若善男子善女人。成就随顺法智。若善男子善女人。于诸深法不自了知。仰惟世尊。非我境界。唯佛所知。是名善男子善女人仰惟如来。除此诸善男子善女人已

    胜鬘章第十五

诸余众生。于诸甚深法坚着妄说违背正法习诸外道腐败种子者。当以王力及天龙鬼神力而调伏之。尔时胜鬘与诸眷属顶礼佛足。佛言。善哉善哉。胜鬘。于甚深法方便守护。降伏非法善得其宜。汝已亲近百千亿佛能说此义

尔时世尊。放胜光明普照大众。身升虚空高七多罗树。足步虚空还舍卫国。时胜鬘夫人与诸眷属。合掌向佛观无厌足。目不暂舍。过眼境已踊跃欢喜。各各称叹如来功德。具足念佛还入城中。向友称王称叹大乘。城中女人七岁已上。化以大乘。友称大王。亦以大乘化诸男子七岁已上。举国人民皆向大乘

尔时世尊入只桓林。告长老阿难。及念天帝释。应时帝释与诸眷属。忽然而至住于佛前。尔时世尊向天帝释及长老阿难。广说此经。说已告帝释言。汝当受持读诵此经。憍尸迦。善男子善女人。于恒沙劫修菩提行。行六波罗蜜。若复善男子善女人。听受读诵乃至执持经卷。福多于彼。何况广为人说。是故憍尸迦。当读诵此经为三十三天分别广说。复告阿难。汝亦受持读诵。为四众广说。时天帝释白佛言。世尊。当何名斯经。云何奉持。佛告帝释。此经成就无量无边功德。一切声闻缘觉。不能究竟观察知见。憍尸迦。当知此经甚深微妙大功德聚。今当为汝略说其名。谛听谛听善思念之。时天帝释及长老阿难白佛言。善哉世尊。唯然受教。佛言。此经叹如来真实第一义功德。如是受持。不思议大受。如是受持。一切愿摄大愿。如是受持。说不思议摄受正法。如是受持。说入一乘。如是受持。说无边圣谛。如是受持。说如来藏。如是受持。说法身。如是受持。说空义隐覆真实。如是受持。说一谛。如是受持。说常住安隐一依。如是受持。说颠倒真实。如是受持。说自性清净心隐覆。如是受持。说如来真子。如是受持。说胜鬘夫人师子吼。如是受持。复次憍尸迦。此经所说断一切疑。决定了义入一乘道。憍尸迦。今以此说胜鬘夫人师子吼经。付嘱于汝。乃至法住受持读诵。广分别说。帝释白佛言。善哉世尊。顶受尊教。时天帝释长老阿难及诸大会天人阿修罗乾闼婆等。闻佛所说。欢喜奉行

胜鬘师子吼一乘大方便方广经(茨田宿祢安麻吕七世父母现在父母六亲眷属一切无边法界众生誓愿仕奉)


圣善住意天子所问经

    No. 341 [Nos. 310(36), 342]

    圣善住意天子所问经翻译之记

夫法留正像。唯圣是依季行。此世非贤岂伏。三藏法师毗目智仙。出自乌苌刹利王种。幼履慈踪。长蹑悲迹。摄化群迷。诫恶导善。常为众生不请之友。执此法灯。照彼昏闇。魏皇都邺。崇福以资。兴和二年岁次实沈。佛法加持。出此经典。名善住意天子所问。建午闰月朔次了丑。戊寅建功。乙已毕功助译弟子瞿昙流支。对译沙门昙林之笔。庶俟存道敬法之贤。如实印记。示令不惑耳

圣善住意天子所问经卷上

        元魏三藏毗目智仙共般若流支译

归命一切诸佛菩萨。归命世尊大智慧海。毗卢遮那释迦牟尼佛法光明。归命圣者文殊师利大菩萨海。归命圣者善住意天子。遍行大乘者

如是我闻。一时婆伽婆。住王舍城耆阇崛山中。与大比丘众六万二千人俱。皆是智者之所识知。一切悉是大阿罗汉。诸菩萨摩诃萨四万二千人。其名曰

文殊师利菩萨。师子幢菩萨。弥勒菩萨。观世自在菩萨。得大势菩萨。辩聚菩萨。持地菩萨。弥楼山菩萨。弥楼幢菩萨。不动摇菩萨。善思义菩萨。善思惟菩萨。踊猛意菩萨。慧心菩萨。善心菩萨。摩尼聚菩萨。山相击王菩萨。宝手菩萨。宝意菩萨。宝印手菩萨。常舒手菩萨。常缩手菩萨。常精进菩萨。度众生菩萨。增上精进菩萨。如说能行菩萨。精进愿菩萨。手灯菩萨。等心菩萨。舍罪菩萨。除诸悲闇菩萨。力不坏菩萨。日藏菩萨。金刚游步菩萨。无边游步菩萨。无量游步菩萨。不动足游步菩萨。虚空库菩萨。上意菩萨。胜意菩萨。增上意菩萨。吉行菩萨。持地住菩萨。月光菩萨。月幢菩萨。光幢菩萨。光德菩萨。游步到明菩萨。师子游步雷音菩萨。无碍辩菩萨。相应辩菩萨。捷疾辩菩萨。最胜菩萨。蔽日月光菩萨。无攀缘菩萨。无比菩萨。根常喜笑菩萨。障一切罪菩萨。舍女饰菩萨。摩尼那菩萨。光明菩萨。净满菩萨。得大菩萨。集光王菩萨。深吼菩萨。如是等上首。菩萨摩诃萨四万二千人俱

尔时复有四大神王。天帝释王。娑婆世界主。大梵天王。如是等上首。六万天子俱。复有七万三千天子。善住意天子。善寂天子。摩醯首罗天子。而为上首。皆乐修行菩萨之道。复有二万阿修罗王。罗睺阿修罗王。弥楼阿修罗王。而为上首。皆乐修行菩萨之道。复有六万龙王。名不苦恼龙王。名月龙王。名得叉迦龙王。而为上首。皆乐修行菩萨之道。如是复有无量百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人诸大众俱。比丘比丘尼优婆塞优婆夷皆悉来集。尔时世尊。无量百千眷属围绕。恭敬尊重而为说法。尔时文殊师利童子。于自寺住独坐思惟。心静三昧正念观察。正观察已起彼三昧。起三昧已复入三昧。以三昧力六种震动十方无量不可计数阿僧祇耶不可思议恒河沙等诸佛世界。尔时文殊师利童子。起彼三昧如法思惟。生如是心。佛出世难。人身难得。如优昙华。出时甚难。如是如来应正遍知。亦复如是。出世甚难人身难得。若无说法则不可得尽生死苦。诸佛正法甚深难知。若无佛者云何闻法。若不闻法则不能令众生苦尽。若我往至如来所已。如法难问如法难已。毕竟得发众生善根。毕竟能令菩萨乘人不可思议佛法满足。此处娑婆世界众生。极重贪欲极重嗔恚极重愚痴远离善法习近恶法。愚痴闇钝无殷重心。若其无佛无法无僧。云何而得令彼众生开慧眼净

尔时文殊师利童子。如是思惟。我召十方无量百千诸菩萨众。令集此处闻如来法。以身证知甚深法忍。尔时文殊师利童子。念已即入普光离垢庄严三昧。入三昧已放大光明。遍照十方不可计数阿僧祇耶不可思议无量无边恒河沙等诸佛世界。即时十方不可计数阿僧祇耶不可思议无量无边恒河沙等诸佛世界大光明现。其光明净十方世界坑涧堆阜树林诸山。斫迦婆罗目真邻陀雪山弥楼摩诃弥楼一切所有幽闇之处。悉皆大明不相障碍

尔时十方不可计数阿僧祇耶。不可思议无量无边恒河沙等。诸佛世界。诸佛世尊。皆悉现在现命现住。彼佛侍者既睹光明。各问其佛。白言世尊。何因何缘。于此世界大光明现。昔未见闻。如是光明甚可爱乐。世尊如是光明我等遇之。心得清净身力增益。贪欲恚痴不染众生。是谁威力何人宝藏。如是净光是谁所放。如是问已。彼佛世尊默然不答。如是十方诸佛世界。天声龙声夜叉声阿修罗声迦楼罗声乾闼婆声。人声非人声畜生声。如是众声一切止息。风声水声大海潮声。歌咏等声。如是诸声。以佛力故一切止息。皆悉寂然。一切寂静第一寂静。彼佛侍者。各各如是第二第三请其佛言。如是世尊何因何缘有此光明。唯愿说之。唯愿说之。如来若说则能利益一切众生。饶益安乐一切众生。令多众生一切皆得义相应乐。利安人天。是谁威力放此光明。遍照一切诸佛世界

尔时十方不可计数阿僧祇耶不可思议无量无边恒河沙等诸佛世界。诸佛世尊。一切同声。皆共一音。一切诸佛。同一口业。皆同一法。为侍者说。彼佛侍者一一皆知如来所说。彼佛世尊。所出音声遍满一切诸佛世界。彼诸天人一时俱作百千伎乐。彼乐音中说言无常苦无我等。如是如是和合出声。所谓空声无相声无愿声。无染声解脱声。法性声真如声实际声。布施声持戒声忍辱声精进声禅定声般若声。柔和声利益声。慈声悲声喜声舍声。出如是等百千法声。此声出已。有不可数亿那由他百千众生。必定不退阿耨多罗三藐三菩提。不堕声闻缘觉之地。不堕帝释大梵天王转轮王地

尔时十方不可计数阿僧祇耶。不可思议无量无边恒河沙等诸佛世界。诸佛世尊。告侍者言。止善男子。汝不须问。非汝境界。非诸声闻缘觉境界。声闻缘觉若闻我说心意迷乱。我若说者。一切天人皆悉迷没。善男子。以要言之。彼法光明所有功德。能令众生乃至无量不可思议善根成就。能令一切菩萨乘人乃至无量不可思议布施助道戒忍精进禅慧助道皆悉满足。善男子。汝今当知。若以一劫若余残劫。说此光明所有功德不可穷尽。诸佛菩萨。于诸众生。起慈悲心。放此光明。令诸众生渴仰欲闻。汝今谛听。善思念之。我为汝说。彼侍者言。如是世尊愿乐欲闻。彼佛世尊。各告侍者。作如是言。善男子。有佛世界名曰娑婆。彼中有佛号释迦牟尼如来应正遍知。于今现在现命现住。明行足善逝世间解无上士调御丈夫天人师佛世尊。出五浊世。彼处众生贪欲嗔恚愚痴所缚无恭敬心。诸根闇钝无惭无愧。为彼众生于彼世界如法苦行。获得阿耨多罗三藐三菩提觉已。而为说法。善男子。彼娑婆世界释迦牟尼如来佛土。有童子菩萨摩诃萨。名文殊师利。有大势力大智慧力大精进力。能与一切菩萨欢喜。菩萨化主。菩萨导首。安慰众生。菩萨之父。菩萨之母。解了一切诸法句义。黠慧明了得无障碍慧波罗蜜。得无障碍。愿力自在得陀罗尼。不可思议功德具足。于彼释迦牟尼如来所说法中。善能问难。能令众生善根成就。能令一切菩萨乘人。不可思议佛法满足。善男子。彼文殊师利童子菩萨。为集十方不可计数诸菩萨故放此光明。随何等人闻法因缘放此光明。彼佛侍者。各问其佛。白言世尊。彼文殊师利童子菩萨。住何三昧。而能如是放斯光明。彼佛答言。善男子。有三昧门名曰普光离垢庄严。文殊师利童子菩萨住是三昧。而能放此如是光明。彼侍者言不尔。世尊。如是光明。岂非彼佛世尊所放。能如是清。能如是净。能作如是身心喜乐。佛言不尔。善男子。菩萨常法共说菩萨教诫法门。尔时十方不可计数阿僧祇耶。不可思议无量无边。恒河沙等诸佛世界。彼不可数阿僧祇耶。不可思议无量无边。恒河沙等诸佛世界。一一世界诸菩萨等。既睹光明。各到佛所。头面礼足。白言世尊。如是无量功德光明。从何处来谁之所放。彼佛告言。善男子。有佛世界名曰娑婆。彼中有佛号释迦牟尼如来应正遍知。于今现在现命现住。为诸菩萨说清净法。彼有童子菩萨摩诃萨。名文殊师利。放此光明。为集十方诸菩萨故。如是说已。彼诸菩萨摩诃萨等。各请其佛。白言世尊。我今欲诣娑婆世界奉见世尊释迦牟尼如来应正遍知。供养彼佛礼拜亲近咨请问答。并见童子文殊师利及余菩萨摩诃萨等。佛言便往今正见时

时彼十方不可计数阿僧祇耶。不可思议无量无边亿那由他。有频婆罗百千菩萨摩诃萨等。各礼佛足。于其国土忽然不现。譬如壮士屈申臂顷。一刹那顷。一罗婆顷。摩睺多顷。各各到此娑婆世界。既到此已。皆至世尊释迦牟尼如来住处。有雨细末鬘利香者。雨涂香者。有雨华者。雨天优钵罗华。钵头摩华。拘物头华。芬陀利华。阿提目多伽华。雨瞻卜华。波吒罗华。檀尼师迦梨迦华。须摩那华。婆利师华。曼陀罗华。波流沙华。摩诃波流沙华。栴陀罗华。摩诃栴陀罗华。雨如是等无量妙华。雨如是等无量妙香。雨华香已。往至世尊释迦牟尼如来佛所。或有菩萨。同声赞叹如来功德。赞叹之声。闻于三千大千世界。如是赞叹至如来所。如是种种。各各异法。而来集会。皆到世尊释迦牟尼如来佛所。到佛所已。彼诸菩萨摩诃萨等。威德力故。令此世界若干地狱。若干畜生。若干饿鬼。所受苦恼皆得休息。无一众生贪欲所恼。亦复不为恚痴所恼。无有嫉妒。无幻伪者。无谄曲者。无憍慢者。亦不自是。亦不忿恚。亦不热恼。一切众生慈心相向。甚有爱念皆悉和顺

时彼菩萨亿那由他百千之众。皆到世尊释迦牟尼如来佛所。头面礼足。右绕如来有一匝者。有二匝者。有三匝者。有多匝者。绕如来已。上虚空中。去地不远一多罗树。忽然不现。一切皆入隐一切身菩萨三昧。入三昧已。随心所乐出生莲华。有种种色华。有无量百千众叶。于华台上结加趺坐。身不动摇

尔时长老摩诃迦叶。见此希有未曾有法神通之事。复见雨华。复见雨香。复闻乐声百千种音。见大光明。复见雨华遍四天下。满此世界积过于膝。见佛大会天龙夜叉。乾闼婆阿修罗迦楼罗。紧那罗摩睺罗伽人与非人。比丘比丘尼。优婆塞优婆夷等。身皆金色。尔时长老摩诃迦叶。从座而起。整服左肩右膝着地。摄身圆坐。向佛合掌。偈赞请曰

  欢喜常快乐　　善净口业说
  具十力雄猛　　功德有百重
  人处天处行　　悉无与等者
  叵思无称量　　恶意永已尽
  百那由他劫　　久修施戒等
  尊戒绝譬类　　无教诫善逝
  力忍力善力　　复有十力力
  无心作功德　　愿断我疑网
  见苦恼众生　　百劫修苦行
  而心不疲惓　　已令得欢喜
  舍国城妻子　　头目等种种
  一切心喜与　　愿断我疑网
  世尊久已舍　　象马及辇舆
  头衣等种种　　舍百那由他
  饮食舍等物　　舍与牟尼那
  施时常欢喜　　是故成善逝
  割截身体时　　忍受无嗔恨
  随问皆能答　　巧说忍善力
  修行于空法　　善思量净施
  功德毕竟持　　故我问清净
  贪嗔痴磨灭　　见众生苦恼
  贪嗔痴所覆　　我想而自缠
  悲心愍此故　　百劫行到道
  示导诸有者　　是故我归依
  以智慧增长　　彼得行善行
  常为诸众生　　说空法令乐
  无屈行善因　　成善逝世尊
  世尊禅清净　　愿断我疑网
  修行施戒忍　　精进悉已备
  禅慧皆具足　　常乐修慈心
  无等等功德　　如海不思议
  如海水之深　　是故我归依
  世尊于往昔　　一鸟来归依
  自割净身肉　　脔脔秤称之
  举身上秤槃　　乃与鸟平等
  世尊大慈光　　愿断我疑网
  太山可动转　　虚空可令有
  诸天功德舍　　亦可堕此地
  海水可枯竭　　修罗宫可堕
  日月可坠落　　世尊语叵异

尔时长老摩诃迦叶。以偈赞叹请如来已。白言世尊。以何因缘。有大光明遍照世界。如是妙色。昔所未有今见此瑞。佛告尊者大迦叶言。止止迦叶。汝今云何作如是说。莫如是问。如此之事。非是一切声闻缘觉所能测量。一切天人所迷没处。唯是诸佛如来所知。尊者大迦叶白佛言。世尊。如来若说多所利益多人安乐。尔时世尊。即告尊者大迦叶言。汝今谛听善思念之。我为汝说。大迦叶言。善哉世尊。愿乐欲闻。佛言迦叶。文殊师利童子。今入普光离垢庄严三昧。以三昧力放此光明。遍照十方不可计数阿僧祇耶。不可思议无量无边。恒河沙等诸佛世界。普召十方不可计数阿僧祇耶。不可思议无量无边。亿那由他有频婆罗百千菩萨。皆悉集此娑婆世界。彼诸菩萨今者皆悉顶礼我足。右绕三匝上虚空中。去地不远一多罗树。坐莲华座

尔时尊者摩诃迦叶白佛言。世尊。彼诸菩萨威神之力。乃能如是雨华雨香雨末香等。百千音乐皆出妙声。佛言。如是如是。迦叶。此诸菩萨威力如是。雨华雨香雨末香等。百千音乐皆出妙声。大迦叶言不尔。世尊。何处有此菩萨可见。佛言迦叶。彼乃非是声闻缘觉之所能见。何以故。迦叶。何处大悲菩萨境界。何处大慈。何处利益。何处修行。布施持戒忍辱精进禅定智慧。菩萨境界。非彼声闻缘觉信行。迦叶当知。此诸菩萨一切皆入隐一切身菩萨三昧。声闻缘觉所不能见。唯如来见。如是迦叶。已住此地菩萨能见。住地菩萨尚不能见此善男子。唯依信行。何况声闻缘觉能见。若能见者无有是处

尔时长老摩诃迦叶白佛言。世尊。菩萨修行成就几法行何善根成何功德。而能得入隐一切身菩萨三昧。佛言迦叶。诸菩萨摩诃萨。毕竟成就十种法故。则能得入隐一切身菩萨三昧。何等为十。一者信行坚固。二者为满大悲。心常不舍一切众生。三者舍一切物。四者受持佛法而不取着。五者不受声闻缘觉智慧。六者一切所有皆悉能舍。乃至身命何况余物。七者行不可数有为诸行。而心不取彼有为行。八者不可数量施戒忍进禅慧满足波罗蜜行。而不分别。九者起如是心。一切众生我悉安置于佛法中令趣菩提。十者不取众生不取菩提。迦叶当知诸菩萨摩诃萨。毕竟成就如是十法。则便得入隐一切身菩萨三昧

尔时长老摩诃迦叶白佛言。世尊。快说此语。世尊。乃能作如是说。世尊。声闻缘觉不曾一心发如是意。一切众生我皆令其得阿罗汉。尚不起心置诸众生罗汉法中。何况佛法。佛言。如是如是。迦叶。声闻缘觉皆不能入隐一切身菩萨三昧。此三昧名尚不能知何况能得。云何能入。若能入者无有是处

尔时长老摩诃迦叶白佛言。世尊。我今欲见彼诸菩萨。何以故。如法正士难可见故。佛言迦叶。汝觅文殊师利童子。则便得见。彼诸菩萨彼起三昧汝乃见之。复次迦叶汝已获得一切三昧。摄入三昧。觅彼菩萨摩诃萨等为在何法专心修行。尔时长老摩诃迦叶。世尊既听。以佛神力自神力故。即入二万诸三昧门。入已复起。欲望得见彼诸菩萨。在于何法专心修行而不能知。非彼菩萨若来若去是故不知。或非住处。或何所依。或何所作。或何所说。一切不见。一切不知

尔时长老摩诃迦叶白佛言。世尊。希有世尊。甚奇善逝。世尊。我入二万诸三昧门。欲望得见彼诸菩萨在于何法专心修行而不能见。菩萨如是尚不可见。何况如来。菩萨未得一切智处。已得如是三昧法门。菩萨摩诃萨未得一切智。犹尚如是。何况已得。世尊。其谁智慧。若善男子若善女人。若闻若见如此之事。而不发于阿耨多罗三藐三菩提心者。何人闻见而不发心。如是世尊。隐一切身菩萨三昧威神之力。尚不可测。何况复有其余三昧。佛言。如是如是。迦叶。一切声闻缘觉之人。尚非境界。况余众生

尔时长老舍利弗。作如是念。佛说我于声闻弟子智慧人中最为第一。若我觅彼菩萨摩诃萨在于何法专心修行应能见知。尔时长老舍利弗。作是念已。以佛神力自神力故。即入三万诸三昧门。入已复起欲望得见彼诸菩萨在于何法专心修行。而不能见彼诸菩萨乃至少相

尔时长老须菩提。作如是念。我应能见彼诸菩萨在于何法专心修行。尔时长老须菩提。作是念已。以佛神力自神力故。即入四万诸三昧门。入已复起。欲望得见彼诸菩萨在于何法专心修行。而不能见。非彼菩萨若来若去。是故不知。或非住处。或在住处。或经行处。非是卧处。非是坐处。一切不见。一切不知。尔时长老须菩提。礼二足尊。而作是言。世尊。如来说我阿兰若行最为第一。如是寂静三昧法门。我已得之。如是世尊。此四天下四洲世界。我见明了如一鼓头。第二世界。我见明了如二鼓头。世尊。譬如有人生便捉杖如须弥山。我入三昧彼执杖人即住我前。一劫打鼓不曾暂住。更不异作随彼打鼓。如是我得尔许三昧。唯我究竟阿兰若行。若经一劫。彼鼓音声不着耳识。何况能起如是三昧。若彼鼓声能起三昧。无有是处。世尊。彼如是法具足寂静我。如是法智慧具足。四万三昧入已复起。欲望得见彼诸菩萨乃至一人而不能见。亦复不能知其住处。如是世尊。菩萨摩诃萨知如是法。宁为一一众生利益。恒河沙劫生大地狱住地狱中。如是世尊。彼诸菩萨而不舍离彼如是法。不可思议甚深智慧。如是世尊。若我漏心未解脱者。于未来际常在生死。更不舍离如是大乘。尔时世尊。赞叹尊者须菩提言。善哉善哉。汝须菩提。以心信故作如是说。汝此受阴若不涅槃必得授记。汝之善根作恒河沙转轮王已。然后必得阿耨多罗三藐三菩提觉

又须菩提。三千大千世界众生宁为多不。须菩提言。甚多世尊。甚多善逝。佛言。如是须菩提。彼诸众生皆得智慧。如须菩提。如舍利弗。诸大声闻之所知见。皆共和合。乃至一劫若百千劫。觅彼菩萨望得见者。无力能见。何以故。非须菩提声闻缘觉所知境界。彼诸菩萨摩诃萨行。一切声闻缘觉不行。说此法时。会中八万四千天人。一切皆发阿耨多罗三藐三菩提心。尔时文殊师利童子。作是思惟。在他处住。无量菩萨亿那由他百千之众。我今普召令集此处。尔时文殊师利童子。既思惟已。即时如法现神通行。现神通已。化作八万四千莲华。亿那由他百千眷属大如车轮。金叶银茎胜藏罗网。毗琉璃须。彼莲华中有化菩萨。于华台上结加趺坐。金色之身。具三十二大人之相。具足功德。具足妙色。具足众好。具足光明。时彼莲华至四王天三十三天夜摩兜率。如是化乐他化自在。此化莲华如是遍到一切处去若干处处。召此三千大千世界。百亿须弥。四天王天。乃至遍召色究竟天。彼化莲华遍至一切欲界天子。色界天子。若干宫殿。出声普召一切皆闻。彼菩萨身遍至三千大千世界。说偈召曰

  慧日大世尊　　时乃出世间
  佛如优昙华　　如是甚难值
  雄猛释师子　　出现此世间
  依正法正说　　尽一切苦恼
  虽久食天味　　恣心五欲乐
  复随恶行去　　而于何处受
  若干欲受食　　而复更增长
  有为行众生　　三界悉无乐
  已得第一难　　所谓佛出难
  愚痴着我慢　　不知非尽苦
  汝等宜速去　　见佛闻胜法
  莫于佛灭后　　心悔何所及
  错入魔王网　　大怖畏之处
  长夜痴着乐　　何时得解脱
  唯有闻正法　　能生众生福
  速到三十二　　大人相佛所
  佛能救众生　　余不可归依
  佛是世间主　　大慈不思议
  修行不可数　　不可思议劫
  集无上智慧　　成佛释师子
  开示第一法　　深寂难可见
  何处无众生　　非命非丈夫
  一切时常舍　　永断无有余
  除舍一切相　　为众生说法
  何处开实际　　世间无心行
  以彼空无相　　亦无愿不作
  无染无相貌　　不生亦不出
  不来亦不去　　演说法明了
  不生亦不尽　　无少物可忆
  无相貌可见　　无思忆念说
  无少众生生　　无少众生死
  无涅槃众生　　何处众生出
  说法如响声　　无响声可取
  人尊解字相　　如是而说法
  若何处不遍　　不得风水火
  地不是分别　　智慧眼所说
  色受想行识　　如是等皆空
  虽说五阴法　　无物可聚积
  眼耳鼻舌身　　如意自相空
  虽复说彼空　　而空不可得
  色声香味触　　皆是意所乐
  虚妄起此法　　无自根本空
  如是诸众生　　解佛所说法
  欲得脱苦处　　应到医师所

彼化菩萨。周遍三千大千世界。说此偈时。九十六亿欲界诸天。色界天子。远尘离垢得法眼净。十千天子是菩萨乘修行之人。一切皆得无生法忍。时彼菩萨所召天子。不可数量。阿僧祇耶百千之众。一刹那顷。一罗婆顷。摩睺多顷可往世尊释迦牟尼如来应正遍知。往到佛所。头面礼足右绕三匝住在一面。以天华香。优钵罗华。钵头摩华拘物头华。芬陀利华。曼陀罗华。摩诃曼陀罗华。末香涂香。用散如来。大身诸天。上虚空中歌咏赞叹。彼时多有若干天人。皆悉来至此四天下遍满世界。无有空地。如掷扙处。所有地处皆悉遍满。尔时大身胜妙天子。此四天下世界之中。雨华遍满积过于膝

尔时善住意天子。善寂天子。惭愧持天子。九十六亿诸天子俱。乐行一切菩萨之道。皆共往诣文殊师利童子住处。既往到已。在于文殊师利童子住处寺外。右绕七匝。雨天曼陀罗华如雨而下。所雨之华遍覆虚空。高十由旬。成大华网台。形如浮图。有大光明遍照三千大千世界皆悉大明。雨天曼陀罗华于文殊师利童子寺所。尔时文殊师利童子。如法思惟。于此三千大千世界。上虚空中华网遍覆。华网光明遍照三千大千世界。皆悉大明。尔时文殊师利童子。从自寺出。随心所乐。有妙宝座即坐其上

尔时善住意天子头面敬礼文殊师利童子足下。余诸天子一切悉礼文殊师利童子足已。尔时文殊师利童子。如是思惟。何等人能与我相随。于世尊前问答论义。或说何等不思议句。难解句句。无处所句。不戏论句。无戏论句。不可说句。甚深句。实句无障碍句。不破坏句。空句无相句无愿句。真如说句。实际句。法界句。无相似句。不取句。不舍句。佛句法句僧句。得智慧满足句。三界平等句。一切法无所得句。一切法不生说句。师子句。健句无句句。如是说已。当有何等堪受法器能听受者。尔时文殊师利童子如是思惟。善住意天子。已曾供养过去诸佛。辩才无碍。彼则堪能与我相随于世尊前问答论议。尔时文殊师利童子。如是念已。语善住意天子言。善住意天子。汝得深忍无碍辩才。可世尊前与我相随问答论议。于是善住意天子语文殊师利童子言。文殊师利。如是我说。若彼于我。不听不读。不受不持。不思不念。不取不舍。不觉不知。不闻我说。不为他说。何以故。佛道无字无心。觉寤唯说名耳。如此名者不可修行。文殊师利。今此地处所说法语。此诸天子。于仁者边作意欲听。仁为说不。文殊师利答言。天子。若有念言我听法者。我不为说。欲得不取我不为说。何以故。有我可取。可得言听。如是取众生取命取丈夫。如是取者可得言听。若使天子有我慢心取我我所。若如是者彼说我听。如是取着而说法者。有三障碍。何者为三。一者得我。二者得众生。三者得法。天子当知。若非我慢非我我所。如是听法有三圆净。心不分别无所悕望无所忆念。彼何者法是三圆净。谓不得我心不分别。无所悕望无所忆念。不得法器心不分别。无所悕望无所忆念。无所得法心不分别。无所悕望无所忆念。天子当知。若如是听。彼平等听非不平等

时善住意天子赞言。善哉善哉。文殊师利。云何名为不退转耶。惟愿说之。文殊师利言。止止天子。汝莫分别。若使菩萨有退转者。菩提正觉非得菩提。天子问言。文殊师利。何处退转。文殊师利答言。天子。贪欲退转。嗔恚退转愚痴退转有爱退转。无明退转。乃至十二有支退转。因退转。见道退转。名退转。色退转。欲界退转。色界退转。无色界退转。声闻行退转。缘觉行退转。分别退转。取着退转。体退转。取体退转。断退转。常退转。取退转。舍退转。我想退转。众生想退转。命想退转。丈夫想退转。意思退转。障碍退转。颠倒退转。自身退转。自身见退转。自身根本六十二见退转。五盖退转。五取阴退转。一切内外入退转。界退转。佛想退转。法想退转。僧想退转。我成佛我说法。我度众生我破魔王。我得智慧有彼想退转。不分别十力。不分别十八不共佛法。不分别根无畏。不分别想。不分别佛世界庄严。不分别声闻功德。一切分别退转。如是天子。若菩萨此处退转。彼不退转

时善住意天子问言。何处不退转。文殊师利答言。天子。佛智慧不退转。空不退转。无相不退转。无愿不退转。真如不退转。法界不退转。实际不退转。平等不退转。天子言。若文殊师利作如是说。若菩萨此法分别不分别。无分别不分别退转。以是义故得言退转。曰彼有何法而言退转。曰有无非有非无。何法退转。何处退转。文殊师利言。若不实取。若不正取。若不如取。彼则不取不舍无相可作。以是义故得言退转。彼法退转不可说有。不可说无。何以故。若有若无而退转者。彼则有过。何以故。若有法退转则堕常边。若无法退转则堕断边。如来说法非断非常。不断不常是佛所说。天子。若彼真如前。不实想不如实知。则不断不常。如是天子。菩萨退转。说此法时。十千天子。一切皆得无生法忍

尔时善住意天子语文殊师利童子言。文殊师利。今共仁者。到如来所见于如来。见如来已礼拜赞叹。供养恭敬如法问难。文殊师利答言。天子。汝莫分别取如来行。天子问言。文殊师利如来何处。文殊师利答言。天子。即此前头有如来住。天子问言。若有如来我何不见。文殊师利答言。天子。若汝一切见则见彼如来。天子问言。文殊师利。仁者云何作如是说。即此前头有如来住。文殊师利问言。天子于意云何。今于汝前有何物耶。天子答言。有虚空界。文殊师利言。如是如来者即是虚空界。何以故以虚空界于一切法悉平等故。如是虚空即是如来。如是如来即是虚空。虚空如来不二不异。如是天子欲见如来当如是观。如实际知非有少物可分别取

圣善住意天子所问经卷上圣善住意天子所问经卷中

        元魏三藏毗目智仙共般若流支译

尔时文殊师利童子。随心化作三十二殿。四角四柱纵广正等。种种严饰。甚可爱乐。于彼殿中有化床座。以天宝物而覆其上。一一床座有化菩萨。具三十二大人之相。尔时文殊师利童子。以威神力。令此莲华遍行三千大千世界往如来所。围绕世尊及比丘僧。满三匝已。住虚空中光明遍满。世尊众会四方围绕。尔时莲华台中菩萨。并化殿上诸化菩萨。彼诸菩萨。同声以偈赞如来曰

  于恒河沙等　　不思议佛所
  供养多亿佛　　炽然勤精进
  如是久修行　　第一菩萨行
  彼甚可喜庆　　一切人之上
  光明色胜妙　　三界最第一
  离相牟尼尊　　说法令人听
  何处无有人　　无命无丈夫
  世尊如是知　　一切人之主
  行布施持戒　　是第一律师
  忍辱勤精进　　如禅定思量
  具足深般若　　三界不着尊
  善知彼岸道　　是故我归依
  若忆念知有　　世间人之主
  法主之世尊　　天人来供养
  于甚深空法　　究竟无有余
  当知如是人　　世界之尊主
  过去诸如来　　有方处人主
  常说人空法　　无物本无相
  此处无众生　　若生若死灭
  不来亦不去　　一切法相空
  化人空中眠　　非是真实见
  是法善逝说　　如化亦如梦
  恒沙世界宝　　有施与何人
  此福感有为　　空忍胜于是
  劫际如恒沙　　供养人中尊
  奉香华饮食　　为得佛菩提
  若闻如是法　　无人命丈夫
  得彼忍光明　　供养如来上
  多劫行布施　　饮食象马等
  彼非解脱因　　以有人想故
  彼寂静人上　　令多众解脱
  空性本光明　　知解脱庄严
  佛出世难值　　闻法生信难
  生世为人难　　善哉入佛法
  已离于八难　　复得于难得
  得信善逝法　　善思惟得见
  常专心听法　　莫如声取义
  恒宿阿兰若　　必得人中雄
  近善友法器　　远离恶知识
  等心于众生　　莫欺于菩萨
  持戒乐多闻　　粪扫衣乞食
  近树下精进　　随得食而食
  有为皆无常　　一相如阳炎
  一际知真谛　　速得菩提觉
  五阴如幻化　　内外入空聚
  常说如是法　　彼处无造作
  贪嗔本空无　　痴慢分别起
  非已今当有　　如是知得佛

说此偈时。于众会中。二万二千人。皆发阿耨多罗三藐三菩提心。五百比丘。不受诸法漏尽心得解脱。三百比丘尼。远尘离垢得法眼净。七千优婆塞优婆夷。二万七千天子。得离垢法眼。三百菩萨得无生法忍。于此三千大千世界六种震动。动遍动等遍动。震遍震等遍震

尔时长老舍利弗白佛言。世尊。是谁威力令此三千大千世界六种震动。此莲花中殿中菩萨。善说如是甚深之法。放大光明遍照此会。如是无量多亿天子。皆悉来集。如是无量多亿菩萨。皆悉来集。佛言。舍利弗。此是文殊师利童子威神力故。得见如是妙色庄严。何以故。舍利弗。文殊师利童子与善住意天子。今日相随请问。如来破坏魔军三昧法门。如法问难不可思议甚深佛法。尊者舍利弗言。不尔世尊。文殊师利童子未来此会我不曾见。佛言。舍利弗。汝善谛观如是文殊师利童子。今在此处与一切魔一切魔众一切魔官作大衰变。极大庄严来至我所

尔时文殊师利童子。入坏魔军三昧法门。文殊师利入坏魔军三昧门时。若干三千大千世界。百亿魔宫毁变欲坏。陈朽闇冥无有威光。一切魔身皆悉衰变。极成老弊。各自知见拄杖而去。魔之眷属亦复如是。见已宫殿毁变欲坏。陈朽闇冥无有威光。尔时众魔皆生怖畏。惊恐毛竖心生疑虑。作如是念。以何因缘。我此宫殿毁变欲坏。如是陈朽。如是闇冥无有威光。莫令我身退失此处。时彼众魔。生如是心未久之间。尔时文殊师利童子。即复化作百亿天子。在于魔前。彼化天子语魔波旬。作如是言。汝莫怖畏。非汝有恶。非汝有衰。非汝欲退。今有童子菩萨摩诃萨。名文殊师利。得不退转。彼今住在破坏魔军三昧法门。是彼菩萨威力所作。彼化天子说如是语。时魔既闻文殊师利童子名已。转更恐怖。一切魔宫皆悉战动。时魔波旬。语化天子作如是言。愿君救我。愿君救我。时化天子。语魔波旬作如是言。勿怖勿怖。汝今往诣释迦牟尼如来佛所。如来大悲于怖畏者能施无畏。彼化天子如是说已。即于其处忽然不现。时魔波旬一切眷属于一念顷一罗波顷。摩睺多顷。百亿波旬无量眷属。如老极老拄杖而去。何处如来应正遍知。往到佛所。一切同声而白佛言。救我世尊。救我世尊。救我善逝。救我善逝。惟愿世尊救我救我。惟愿善逝救我救我。我本妙色今者如是衰变不好者。世尊。我宁闻说亿百千佛如来名号。而不用闻文殊师利童子一名。何以故。以我闻此文殊师利童子名字。生大怖畏。惊恐危故。畏退失故。我今如是恐畏退失。尔时世尊语魔波旬作如是言。汝今云何如是说耶。亿百千佛如来名号不作一切众生利益。不曾已作。今亦不作。当亦不作。如是文殊师利童子。常作一切众生利益。已作今作当作利益。众生熟已令得解脱。汝今虽闻亿百千佛如来名号。不生苦恼。不生怖畏。云何而言文殊师利一童子名我不用闻。尔时魔波旬白佛言。世尊。我甚耻愧如是身老。我甚怖畏。世尊。我忆本身。我忆本色。愿还如本少身少色。佛言。波旬且住且住。且待须臾。文殊师利童子菩萨当来至此。汝此色者。非是真色。宜可除舍

尔时文殊师利童子。起彼三昧。无量百千诸天。导从无量百千诸大菩萨诸龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽。百千音乐皆出妙声。优钵罗花。钵头摩花。拘物头花。芬陀利花。如雨而下。极大庄严娱乐戏乐。来至佛所头面礼足。右绕三匝却住一面

尔时世尊告彼童子文殊师利作如是言。文殊师利。汝入破坏一切魔军三昧门耶。文殊师利答如来言。入已世尊。尔时世尊问童子言。文殊师利。于何佛所得是三昧。闻此三昧其已久如。文殊师利童子答言。世尊。未发菩提心时。我从彼佛得闻如是三昧法门。我此三昧如是成已。世尊问言。文殊师利彼佛如来名字何等说是三昧。汝从彼佛。得闻如是三昧法门。文殊师利答言。世尊。乃往过去无量无边不可思议阿僧祇耶阿僧祇劫有佛出世。号曼陀罗婆花香如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼说如是三昧法门。我从彼佛得闻如是破坏魔军三昧法门。世尊问言。文殊师利。此三昧门云何而得。文殊师利答言。世尊有二十法。若菩萨摩诃萨毕竟成就彼二十法得此三昧能坏魔军。何等二十

世尊。所谓菩萨。破坏贪欲。破坏贪心。破坏嗔恚。破坏嗔心。破坏愚痴。破坏痴心。破坏嫉妒。破坏嫉心。破坏憍慢。破坏慢心。破坏垢恶。破坏垢心。破坏热恼。破坏热心。破坏想念。破坏想心。破坏见着。破坏见心。破坏分别。破坏分别心。破坏取着。破坏取心。破坏执着。破坏执心。破坏取相。破坏相心。破坏有法。破坏有心。破坏常法。破坏常心。破坏断法。破坏断心。破坏阴法。破坏阴心。破坏界法。破坏界心。破坏入法。破坏入心。破坏三界。破坏三界心。如是二十。菩萨若能毕竟成就。此二十法得此三昧

复次世尊。有四种法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。一者清净心。二者不谄曲心。三者深心。四者一切施与。如是四法。菩萨若能。毕竟成就此四种法得此三昧。复有四法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。一者不违于信。二者毕竟实语。三者随顺想行。四者不取一切法。是为四法。复有四法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。一者亲近善知识。二者正念思惟。三者如法修行。四者不与恶人相随。是为四法。复有四法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。谓不缺戒。不穿漏戒。不依止戒。不浊戒等。是为四法。复有四法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。一者舍声闻心。二者不受辟支佛心。三者堪忍住持。四者不舍众生。是为四法。复有四法。若菩萨摩诃萨毕竟成就彼四种法得此三昧。何等为四。一者修习空法不取丈夫。二者修习无相不取于相。三者修习无愿不取愿心。四者心不贪着一切能舍。是为四法。世尊。菩萨摩诃萨毕竟成就如是法门。是故得此破坏魔军三昧法门。如是世尊。彼曼陀罗婆华香如来。说此三昧门。我从彼佛得闻如是三昧门已。复有如来。号一切珠宝电蔽日月光如来应正遍知。我于彼佛闻此三昧具足成就。彼佛说此三昧门时。彼众会中十千菩萨。皆得成就此三昧门

尔时长老舍利弗白佛言。世尊。希有世尊。今此童子文殊师利。乃能善得此三昧门。既成就此三昧门已。令魔波旬得此衰变。尔时世尊即告尊者舍利弗言。于意云何。汝舍利弗。见此三千大千世界魔波旬如是变者。勿作是见。何以故。舍利弗。如是十方恒河沙等。诸佛世界彼魔波旬。一切皆悉如是衰变。悉是文殊师利童子威力所作。尔时世尊如是说已。复告文殊师利童子作如是言。文殊师利。止汝神力所入三昧。令魔波旬还复前色如本具足。尔时文殊师利童子。即止神力时魔波旬一切前色。皆悉还复如本具足

尔时文殊师利童子问魔波旬作如是言。魔波旬。何处波旬眼。何处眼想。何处眼着。何处眼相。何处眼攀缘。何处眼障碍。何处眼忆念。何处眼我。何处眼依止。何处眼喜乐。何处眼戏论。何处眼我所。何处眼护。何处眼修。何处眼取。何处眼舍。何处眼分别。何处眼思量。何处眼决定。何处眼灭。何处眼生。何处眼执。何处眼来。如是等法。是汝境界。魔业妨碍。如是至意应如是知。色乃至法应如是知。何处波旬非眼。非眼想。非眼着。非眼相。非眼攀缘。非眼障碍。非眼忆念。非眼我。非眼依止。非眼喜乐。非眼戏论。非眼我所。非眼护。非眼修。非眼取。非眼舍。非眼分别。非眼思量。非眼决定。非眼灭。非眼生。非眼执。非眼来。如是等法。非汝境界。汝于其中无主无力无自在非自在取。如是至意应如是知。色乃至法应如是知。尔时文殊师利童子。如如法说。彼魔众中十千魔众。发阿耨多罗三藐三菩提心。魔之眷属八万四千。远尘离垢得法眼净

尔时长老摩诃迦叶白佛言。世尊。我欲得见文殊师利童子并彼菩萨摩诃萨。何以故。世尊。如是善人难可得见。尔时世尊语文殊师利童子言。文殊师利汝现十方诸来菩萨摩诃萨身。此会大众渴仰欲见。尔时文殊师利童子语诸菩萨。名法菩萨。希有日光菩萨。魔杖菩萨。妙音菩萨。定恶菩萨。寂治菩萨。胜治菩萨。法王吼菩萨。语如是等无量菩萨摩诃萨言。各各现汝童子本身。如汝各各自佛世界诸菩萨身。文殊师利如是说已。尔时彼诸菩萨等。起彼三昧。起三昧已。各示本身。一切皆见彼大众中。有菩萨身等须弥山。有菩萨身八万由旬。有菩萨身百千由旬。有菩萨身九十八十七十六十五十四十三十二十十千由旬。复有菩萨摩诃萨身一千由旬。有菩萨身五百由旬。有菩萨身一百由旬。有菩萨身五十由旬四十由旬三十由旬二十由旬十由旬者。有五由旬至一由旬。复有菩萨摩诃萨身。如此娑婆世界众生三肘半身。自有菩萨示如是身。当尔之时。此处三千大千世界。无有空地如掷杖处。一切悉遍。胜菩萨摩诃萨集。彼诸菩萨摩诃萨等。放大光明。遍照十方亿千诸佛如来世界

尔时文殊师利童子。从座而起整服左肩。右膝着地摄身圆坐。向佛合掌。白言。世尊。我问如来应正遍知一面方处。如是世尊。我于今者欲少问难。愿为解说。佛言。文殊师利。如来应正遍知恣汝所问。文殊师利随意问难。我能解说令汝心喜。尔时文殊师利童子一切众会至心静听。文殊师利言。世尊所言菩萨摩诃萨者。为何谓耶。以何义故得言菩萨摩诃萨乎。佛告文殊师利童子作如是言。文殊师利。所言菩萨摩诃萨者。一切法觉得言菩萨摩诃萨也。文殊师利一切法者。言语所说彼菩萨觉。文殊师利。如此菩萨。眼觉耳觉鼻觉舌觉身觉意觉。文殊师利。如此菩萨。何者眼觉。何者耳鼻舌身意觉。文殊师利。如此菩萨。眼本性空觉非有我觉。分别耳鼻舌身意等本性空觉非有我觉。分别色声香味触法本性空觉非有我觉。复次文殊师利。所言菩萨摩诃萨者。五取阴觉。何等法觉。所谓空觉。无相觉。无愿觉。无染觉。寂静觉。远离觉。无物觉。无体觉。不动觉。不生觉。不来觉。不去觉。无有觉。无主觉。无记觉。无知觉。无见觉。无人知觉。无戏论觉。无我觉。分别起觉。无分别起觉。因缘生觉。如幻觉。如梦觉。如焰觉。如响觉。如芭蕉坚觉。不久坚觉。无物空觉

复次文殊师利。所言菩萨摩诃萨者。贪嗔痴觉。云何而觉。从分别起。贪嗔痴觉。彼分别空。非有无体。非戏论。非记觉

复次文殊师利。所言菩萨摩诃萨者。谓欲界觉。色界。无色界觉。云何而觉。无我行名空远离觉

复次文殊师利。所言菩萨摩诃萨者。众生行觉。云何而觉。谓此众生欲行嗔行痴行平等。平等行故善知行觉。彼觉觉已。如如法说。令彼众生如如解脱

复次文殊师利。所言菩萨摩诃萨者。一切众生觉。云何而觉。一切众生唯空有名。不离彼名更有众生。一切众生即一众生。彼众生者非是众生。若如是知不分别者。得言菩萨摩诃萨也。菩萨。何等一切法觉。彼觉菩提得言菩萨。觉眼耳空心不分别我。如是觉得言菩萨。觉鼻舌空心不分别我。如是觉得言菩萨。智慧觉身觉意本空。觉已而说得言菩萨。觉色声香味触意乐一切皆空得言菩萨。觉色想受行本性空。觉识如幻得言菩萨。五阴如梦一相无相。不取我觉得言菩萨。内法不生。不戏论觉。有为名说彼名无物。觉贪欲恚。分别心生。彼不分别。常空无物。痴分别生分别因生。因见而生。不得彼见。觉三界空。一切无主非少物行得言菩萨。未过欲界分别中起。色无色界一切无主。少行众生黠慧皆觉如是欲行嗔行痴行。一切众生即一众生。彼众生无觉法无念。一切法生颠倒心觉。觉不实相一切智慧于中生善。乃无一声可忆可乐。无障碍相随行而行。菩萨如是得言菩萨。舍自身肉无所依止。次第觉知得言菩萨。得彼岸戒无念佛戒。若物不生则不和合。普慈众生众生不取。觉已利益故说大慈。住精进处思有为行。觉世间空。是菩提上禅有依止。非黠慧禅无处攀缘。是黠慧禅修般若刀。割烦恼见观察法性。非坏非割。尔时文殊师利童子白佛言。世尊。菩萨初发菩提心者。云何说言初发心耶。以何义故名初发心。佛言。文殊师利。何等菩萨正观三界一切想生。如是得言初发心者。文殊师利言。世尊。如我解佛所说义者。贪生嗔生愚痴心生得言菩萨初发心者。善住意天子语文殊师利童子言。文殊师利。若使菩萨初发心时。有贪欲恚愚痴生者。毛道凡夫皆有初心。应名菩萨。何以故。以取贪恚愚痴生故。文殊师利言。不尔天子。毛道凡夫贪欲恚痴无力能生。何以故。天子。诸佛如来缘觉声闻不退菩萨贪恚痴生。天子问言。文殊师利。以何意故如是说耶。如是众会不解仁者如是言语皆生疑心。云何云何。文殊师利问言。天子。于意云何。于虚空中鸟行动去。彼鸟迹相。得言有行。不得言行。天子言行。文殊师利言。如是天子。如说彼相。如是言语我如是说。诸佛如来缘觉声闻不退菩萨贪恚痴生。天子当知。随于何处。无依止生。无处可取。彼如是生。于何处所无差别生。天子。于何处所无所依止。无处可取无差别生。不平等生。无迹无句。不得言迹。不得言句。如是言生。不分别句。如是言生。不他生句。如是言生。无物体句。如是言生。无物说句。如是言生。以不来句。如是言生。以不去句。如是言生。以不生句。如是言生。无受持句。如是言生。以无记句。如是言生。以微尘句。如是言生。无忆念句。如是言生。无物行句。如是言生。不可说句。如是言生。不破坏句。如是言生。以无字句。如是言生。以不执句。如是言生。无阿梨耶句。如是言生。以不取句。如是言生。以不上句。如是言生。天子当知。初心菩萨发菩提心。于如是法不忆念。不观察不思量。不起不见。不闻不知。不取不舍。不生不灭。如是天子。菩萨摩诃萨依止何等。此法界。此平等。此实际。此方便。贪生嗔生愚痴心生。眼依止生。如是乃至意依止生。色无处取生。如是至识无处取生。名生色生因生一切见行生。无明生有爱生。乃至十二分因缘流转生。五欲功德生。三界处生。我我所生。自身生自身见生。自身根本六十二见生。佛想法想僧想生。我想他想生。地想水想火想风想空想识想生。四颠倒生。五盖生。四识住八邪九恼十不善业道生。天子当知。如是乃至一切分别。一切不分别。一切分别不分别。一切想一切戏论。一切求一切取着。一切喜乐。一切想。一切忆念。一切障碍。菩萨皆生。天子。如是法门如是应知。天子。若于此法不取无喜乐。无处取法如是言生。尔时世尊赞叹文殊师利童子。作如是言。善哉善哉。文殊师利。如是菩萨何处初发菩提之心。文殊师利。汝已供养恒河沙等诸佛世尊能如是说

尔时尊者舍利弗白佛言。世尊如是。世尊如此。文殊师利童子。已说菩萨初发菩提心。与得无生法忍。此二心生平等无异。佛言。如是舍利弗。如汝所说。舍利弗。燃灯如来授我记言。汝于来世阿僧祇劫当得作佛。号释迦牟尼如来应正遍知。舍利弗。我于尔时不舍此心。得无生法忍。如是舍利弗。此初发心菩萨。如文殊师利童子所说

尔时文殊师利童子白佛言。世尊。如我解佛所说义者。一切菩萨皆初发心。何以故。如世尊说一切心生皆是不生。若不生者则彼菩萨初发心生。如是言生。说此法时。二万三千菩萨。得无生法忍。五千比丘。不受诸法漏尽心得解脱。六十亿天子。远尘离垢于诸法中得法眼净

尔时长老摩诃迦叶白佛言。世尊。文殊师利童子。能作难作。文殊师利童子。说法如是能作众生利益。文殊师利言。长老大迦叶此乃非我能作难作。一切诸法皆悉不作。无有已作。无有今作。无有当作。长老大迦叶。我亦如是。非有法作。亦非有作。亦非不作。非有众生。非缚非解。何以故。无物可取乃是正法。若大迦叶。作如是说。能作难作。汝莫说我能作难作。非我难作。非如来作。非阿罗汉。非辟支佛。长老大迦叶。正说何人能作难作。毛道凡夫是正说说。何以故。长老大迦叶。若一切佛。皆不已得今得当得。若一切声闻一切缘觉。皆不已得今得当得。毛道凡夫一切皆得。大迦叶言。文殊师利。一切诸佛不得何法。文殊师利言。长老大迦叶。一切诸佛。皆不得我。不得众生。不得寿命。不得丈夫。亦不得断。亦不得常。亦不得阴。亦不得界。亦不得入。亦不得心。亦不得色。不得欲界。不得色界。不得无色界。不得分别。不得无分别。不得因生。不得颠倒。不得贪嗔痴。不得此世。不得彼世。亦不得我。不得我所。乃至不得一切诸法。长老大迦叶。非一切法悉皆不得不失不脱不取不舍不近不远。如是法门。摩诃迦叶。应如是知。若一切佛悉皆不得。毛道凡夫一切皆得。如是难作。若非佛作。非声闻作。非缘觉作。则是毛道凡夫人作。大迦叶言。云何作耶。文殊师利言。断作常作阿梨耶作。忆念欲作不作耶舍。戏论分别随顺举下。长老大迦叶。诸佛世尊不作此法。皆不已作今作当作。彼凡夫作如是难作

尔时文殊师利童子白佛言。世尊。言无生忍。无生忍者。云何而说无生忍耶。世尊。以何义故言无生忍。何法中忍得云法忍。菩萨何法得无生法忍。佛言。文殊师利实无有人生中法中得无生忍。实无得忍。言得忍者唯有言语。何以故。实无所得彼忍法故。不得法忍。得无所得。不得不失。如是得言得无生忍。文殊师利。无生法忍者不生。一切法忍不来。一切法忍不去。一切法忍无主。一切法忍不取。一切法忍不舍。一切法忍无物。一切法忍无体实。一切法忍无等。一切法忍无等等。一切法忍无相似。一切法忍尘虚空相似。一切法忍不坏。一切法忍不断。一切法忍无烦恼染。一切法忍无净。一切法忍空无相无愿。一切法忍离贪恚痴。一切法忍真如法界实际安置。一切法忍不分别无分别。无忆念无戏论。无思量不作。无力羸劣后时无物空迭互无空太虚空。如幻如化如响如影如焰。如芭蕉坚如水泡沫。一切法忍。此法忍者。非法非非法唯有名说。如是名者。无处无取本性自离。如是言忍心信解入。不忆不疑。不惊不怖不畏。身触正受行而不得身。文殊师利。此法如是。得言菩萨无生法忍。又亦不行一切法相。文殊师利童子言。世尊。所言忍者。云何言忍。若不为彼境界所伤。彼得言忍

尔时善住意天子问文殊师利童子言。文殊师利。伤何等法。文殊师利答言。天子。所谓伤眼。何法伤眼。所谓法者。爱不爱色。如是耳声鼻香舌味身触意法。如是天子。爱不爱法伤意亦尔。天子。若菩萨。眼见色不取相不取好。不分别无分别。不随顺不分别相。知本性空不念不伤。色乃至法应如是知。天子。若六入不着不伤。若不伤不着。彼得言忍。菩萨如是得无生法忍。不分别法。若生不生无漏不漏不分别法。若好若恶有为无为若不分别。如是得言不生法忍。说此法时。六万二千人发阿耨多罗三藐三菩提心。万二千菩萨得无生法忍

尔时善住意天子问文殊师利童子言。文殊师利。地地转行。地地转行者。云何菩萨地地转行。文殊师利问言。天子。若地地转行彼何人行。天子答言。文殊师利。菩萨不见地地转行。乃至不见十地转行。文殊师利言。不尔天子。佛说诸法皆如幻化。汝为信不。天子答言。文殊师利。我信是说。文殊师利问言。天子。何等幻人地地转行。如是乃至十地转行。天子答言。文殊师利。化人不有地地转行。乃至不有十地转行。文殊师利言。如是天子。若幻化人有转行者。彼我转行。何以故如佛所说一切诸法皆如幻故。是故天子。如是我说地转行者。不转行说非是转行。何以故。以一切法不转行故。非谓法中法法转行。非色受转行。非受色转行。非想行转行。非行想转行。非识色转行。非色识转行如是乃至一切诸法皆亦如是。皆四种说。非眼耳转行。非耳眼转行。非鼻舌转行。非舌鼻转行。非身意转行。非意身转行。此一切法各各自行自分境界。法钝无欲无心意行。不思不念乃至无有计校筹量。如草如壁如幻。无记非有记。作一相无相。以是义故。彼非转行。非来非去。天子当知。若菩萨能如是知。如是菩萨无法转行。非地分别。非地转行见。非是地舍非是退转。菩提转行。非是失灭。何以故。若人见有阴界入体。非彼转行。非是失灭。以一切法性本净故。复次天子。菩萨如是地转行者。譬如幻师以幻力作十重宫殿。彼自作已。即自坐上。于意云何。如是彼人有坐处不。天子答言。无处坐也。文殊师利言。如是天子。菩萨十地见有转行亦复如是

尔时善住意天子问文殊师利童子言。文殊师利。若有人来依投仁者。欲求出家而作是言。唯愿度我令得出家。文殊师利。云何为说。云何作法度令出家。云何授戒。云何戒品。云何教诫。文殊师利答言。天子若至我所求出家者。我为说言。汝善男子。今者实有出家心不。汝若实有出家心者。我当依法度汝出家。何以故。天子若出家者。或着欲界。或着色界。着无色界或着世间五欲功德九处中行。此善男子。如是取法。何者九处。天子。若无少处着彼人心无所得。若心无所得彼人不求出家。若不求出家彼人出家心不生。若出家心不生彼人得言不生。若不生者彼则苦尽。若苦尽者彼毕竟尽。若毕竟尽彼无所尽。若无所尽彼则不尽。若不尽者彼则是空。天子。彼善男子。我如是说

复次天子。若至我所求出家者。我为说言。善男子。汝今莫生出家之心。何以故。彼心不可为他所生。勿保此心。复次天子。若至我所求出家者。我为说言。善男子。汝莫除发是善出家。若如是者得言出家。天子问言文殊师利。以何意故如是说耶。文殊师利答言。天子。如来说法不断不坏。天子问言。何法不坏。文殊师利答言。天子色不断不坏。受想行识不断不坏。天子。随何等人有如是念。我除发者彼住我慢。非我慢行平等见人。如是得我彼则得发。若得发者则得众生。若得众生则得断想。天子。若不得我则不得他。若不得他则无我慢。若无我慢彼我寂灭。若我寂灭彼无分别。若无分别则不发动。若不发动则不戏论。若不戏论则不取不舍。若不取不舍。彼则非作亦非不作。非断非坏非有相着非不相着。不趣不舍。不减不增。不聚不散。无心忆念。不说不答。彼实安住。天子问言。文殊师利。所言实者。是何言语。文殊师利答言。天子。实者虚空得言其实。非是空尽。不尽不长。或有或无。是故得言虚空为实性空。是实真如。是实法界。是实实际。是实若是实者。得言不实。何以故。非今实有。非后时有。是故彼实

复次天子。若至我所求出家者。我为说言。汝善男子。不取袈裟。不着袈裟。是汝出家。若如是者得言出家。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。如来说法皆悉不取。天子问言。文殊师利。不取何法。文殊师利答言。天子。谓不取色若常无常。如是不取受想行识若常无常。亦不取眼若常无常。不取色。不取耳不取声。不取鼻不取香。不取舌不取味。不取身不取触。不取意不取法。不取贪。不取嗔。不取痴。不取颠倒。如是乃至一切诸法皆悉不取。天子。一切诸法。不取不舍不离不散。天子若取袈裟是愚痴念。如是彼人如是见行。天子。是故我说非取袈裟是净解脱。何以故。天子。袈裟是浊如来世尊菩提无浊。天子问言。文殊师利。何法是浊。文殊师利答言。天子。贪欲是浊。嗔恚是浊。愚痴是浊。因浊见浊。名浊。色浊。想浊取浊。相浊戏论浊。天子。若正观察此不善法皆悉无浊。若无浊者乃至无有少物住处。若无住处得言空处无秉作者。天子问言。文殊师利。言无秉作无秉作者。是何言语。而得说言无秉作耶。文殊师利答言。天子。言无秉作无秉作者。如此言语乃至无有少物秉作。如是得言无有秉作。天子。若有秉作彼如来说无有秉作。如是得言无有秉作。天子问言。文殊师利未知何法是秉作耶。文殊师利答言。天子。过于平等。过平等已。若法不得。非今时得非后时得。非今有生非当有生。彼法虚妄安住秉作。所谓我者分别秉作。众生者命者丈夫者人者。摩那婆者断者常者。分别秉作。阴界入等分别秉作。佛法众僧分别秉作。此持戒人此破戒人分别秉作。烦恼染净获得果证分别秉作。须陀洹果斯陀含果阿那含果阿罗汉法辟支佛法分别秉作。空无相无愿明解脱无欲分别秉作。天子。此如是法分别秉作。毛道凡夫未曾闻如来分别秉作。心欲得法妄想计着。彼痴凡夫分别分别转。彼妄想着欲得除灭。如来赞说无有秉作

尔时善住意天子。赞文殊师利童子言。善哉善哉。文殊师利。善说如是秉作法门。尔时如来赞叹文殊师利童子作如是言。善哉善哉。文殊师利。快说此法

圣善住意天子所问经卷中圣善住意天子所问经卷下

        元魏三藏毗目智仙共般若流支译

尔时文殊师利童子。复语善住意天子言。天子。若至我所求出家者。我为说言。汝善男子。若不受戒是汝出家。若如是者得言出家。天子问言。文殊师利以何意故如是说耶。文殊师利答言。天子。如佛所说二种受戒。何者是二。谓等受戒不等受戒。何者名为不等受戒。谓不等堕。何者不等堕。谓着我堕。着众生堕。着寿命堕。着丈夫堕。着断常堕。着邪见堕。着贪嗔痴堕。着欲界堕。色无色界忆念取堕。如是天子。乃至一切不善法堕。恶知识堕。不知出法取一切法。天子。当知如是名为不等受戒。天子。何者名为平等受戒。谓平等堕。何者平等。谓空平等。无相平等。无愿平等。天子。若如是证三解脱门。如实而入则不分别。无所分别则不退转。天子。如是名为平等受戒。复次天子。若修贪欲嗔恚愚痴。若修自身自身根本六十二见。若修颠倒。若修三恶身口意行八邪九恼十不善业道。如是得言正受戒也。天子。譬如一切种子皆依地生。药草树林依地生长。平等具足得言具足。如是天子。此佛法中。若正受戒得言受戒。天子。譬如一切种子药草树林依大地住。如是天子。正戒具足。何以故。以住戒故。法和合有。如彼种子药草树林具足生长。如是得言平等具足天子。戒依信住。如是一切菩提分法。以依戒故。生长具足。天子。如是过去未来现在诸佛世尊一切声闻。以正受戒。是故证得三解脱门。一切戏论皆悉断灭。天子。当知如是受戒是正受戒非不平等

复次天子。我与彼人。如是出家。如是受戒。汝善男子。当如是学莫忆念取。我如是学是汝出家天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。一切诸法皆悉不取天子。汝若取戒三界亦取。天子。于意云何。何者彼学。天子答言。谓波罗提木叉具足。文殊师利问言。天子。云何波罗提木叉具足。天子答言。具足名得言身具足言口具足意具足者。如是得言有波罗提木叉具足。文殊师利问言。天子。于意云何。何处身口意业不作。不曾已作今作当作。有何相似可得说言似。若青若黄若白若赤。若颇梨色。答言无也。文殊师利问言。天子。云何得说。天子答言。非是有为如是而说。若非有为彼不能说身口意业。文殊师利问言。天子。于意云何。若非有为彼可取不。天子答言。文殊师利不可取也。文殊师利言。天子。我意在此故如是说。莫忆念取我如是学。天子。若胜戒学若胜心学若胜慧学。彼学如际。如是应知。戒无所得是胜戒学。心无所得是胜心学。慧无所得是胜慧学。不分别心不忆念心不生胜心是。胜心学戒学慧学。应如是知。天子若心无所得则戒不忆念。若戒不忆念则三昧无所得。若三昧无所得则慧无所得。若慧无所得则一切疑不有。若一切疑不有则学不取。若学不取如是得言彼学忆念。若学忆念彼阿那含。若阿那含彼则清净。若清净者彼不和合。若不和合彼则不漏。若不漏者彼则正行。若如是行无色相似若无色相似彼是虚空。何以故。似彼虚空无形色故。天子。若如是学彼则不学。若不学者彼得言学。于何处学彼无处学。若无处学如是得言正学而住

于是文殊师利童子。复语善住意天子言。天子。我为彼人如出家法。如受戒法。如是为说。汝善男子。一切三千大千世界。信心檀越与汝饮食。汝心不念不生分别。此食难消此则能消。若如是者。汝是净戒。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。若取施者受者财物。如是分别得言我净。若取若赏若净。若有所得彼人有净。若心忆念彼人有净。若心分别彼人有净。天子。若更不取不赏不净。若无所得。若无忆念。若不分别。彼云何净。何以故。毕竟净故。天子。若取若赏若有所得。忆念分别得净信食。则是凡夫非阿罗汉。何以故。凡夫取赏心有所得。忆念分别取我分别。此人与我如是分别。彼得言净。云何名净。凡夫人行取三有生彼如是净。天子。阿罗汉者更无少物有异身行。不取异身。更不转生。何处有净。汝取彼施取三圆净。天子。当知何者名为三圆净耶。所谓不得施者受者及以财物。是三圆净。若如是净彼不复净。天子。我意在此故如是说。若一切三千大千世界。信心檀越施汝饮食。不忆念净。彼世界中得言福田。彼善出家

尔时文殊师利童子。复语善住意天子言。天子。我于彼人。如出家法。如受戒法。如是为说。若汝善男子。不宿阿兰若。不住聚落。不近聚落。不远聚落。不住独处。不乞食行。不请食食。不粪扫衣。不长者家取钵三衣。不露地坐。不少欲不知足。非常知足不远离行。不树下住。不房中宿。不残宿食。不食苏蜜。若汝善男子。如是一切头陀功德聚集。能行如是等法不忆念行。何以故。此慢心人如是相行。天子。若如是念我粪扫衣。我乞食行。我树下坐。我喜残食。我喜少欲我喜知足。我宿阿兰若。我露地坐。我能头陀。我为他说。天子。当知非正行法。如是法生。何以故。如此无分别。彼人尚不得我。何况头陀功德而有所得。若有所得无有是处。如是天子。若此头陀功德和合修行。心不忆念心不分别。我说彼人能说头陀。何以故。天子。若比丘抖擞贪欲。抖擞嗔恚。抖擞愚痴。抖擞三界。抖擞内外六入。我说彼人能说抖擞。如是抖擞。若不取不舍。不修不着。非是不着。我说彼人能说头陀。复次天子。如是我为彼出家人如是受戒。如是说言。汝善男子。若如是知。非知四谛。非修四念处。非修四正勤。非修四如意神足。非修五根。非修五力。非修七觉分。非修八圣道分。非修三十七菩提分法。非证三解脱门。何以故。天子。如是得言知不生相不修不证。何以故。非是不生能证念处。天子。云何而言不是忆念不正观察。一切诸法得言念处。天子。若比丘不住欲界不住色界不住无色界。如是比丘得言无住修四念处。云何而修如是不修。既不自修不令他修。若如是修得言修者。如是次第。乃至三十七菩提分法。应如是知。天子。何等比丘坐禅。禅师于一切法悉无所得。彼无忆念。若不忆念彼则不修。若不修者彼则不证。天子。以何因缘唯有名说。谓三十七菩提分法。彼名无物。意喜因缘而生此名。一相无相如是而说。或说或不说皆如是名。诸有识知皆无所得。此实知见。若有识知此三十七菩提分法皆无所得

天子问言。文殊师利。言禅师者何等比丘得言禅师。文殊师利答言。天子。此禅师者。于一切法一行思量。所谓不生。若如是知得言禅师。乃至无有少法可取得言禅师。不取何法。所谓不取此世彼世。不取三界。至一切法悉皆不取。谓一切法悉无众生。如是不取得言禅师。天子。若彼禅师。无少法取。非取不取。以是义故得言禅师。说是法时。会中无量百千众生皆生疑心。云何云何。此云何取。云何不取。如来说言知三解脱门得证涅槃。修三十七菩提分法证涅槃者。而此文殊师利童子。遮菩提分法得证涅槃者。此文殊师利童子所说共如来语不相应耶。尔时文殊师利童子。知彼比丘心生疑已。即问长老舍利弗言。大德舍利弗。汝信如来说汝智慧最第一耶。大德舍利弗。于何时中无欲法证有何法证。大德。岂不证四谛耶。修三十七菩提分法。或证三解脱门。长老舍利弗言。文殊师利。乃至无有少法可得。若修若证若知若得。何以故。以一切法不取不生无记空证不空空证。说此法时。三千比丘不受诸法漏尽心得解脱

尔时善住意天子。赞叹文殊师利童子作如是言。善哉善哉。文殊师利。利智慧人。善说如是甚深空忍。文殊师利言。天子。我非利智。一切毛道凡夫利智。何以故。毛道凡夫如利智智。何者利智。地狱利智。畜生利智。饿鬼利智。阎魔罗王世间利智。三界利智。如是利智得言利智。不知前际诸有为行。天子。毛道凡夫。贪欲利智。嗔恚利智。愚痴利智。非是声闻。非是缘觉得忍菩萨。如是天子。愚痴利智。如是应知。天子问言。文殊师利。仁戏论不。文殊师利答言不也。天子问言。学他语耶。文殊师利答言不也。天子问言。唯言语耶。文殊师利答言。如是如是。天子。我取言语。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。若菩萨一字一句。不动彼字不动句义。次第问道如实而知。不知空不知离。知无体知不生。如是知。若不知非知非解非受非作。是故得言唯言语句。尔时世尊赞叹文殊师利童子作如是言。善哉善哉。文殊师利。汝今已得陀罗尼故能如是说。文殊师利言。世尊。非我得陀罗尼。何以故。世尊。若愚痴人得陀罗尼。非佛菩萨得陀罗尼。何以故。世尊。愚痴凡夫得陀罗尼。得何等法。所谓得我得众生得命得丈夫。得断得常。得贪嗔痴。得无明有爱五阴自身十八界。六内入六外入。见分别不分别。无分别不分别行。如是世尊。愚痴凡夫得陀罗尼。以取相故分别不分别。无分别不分别行。如是世尊。愚痴之人得陀罗尼。何以故。若法愚痴人得则非佛得。非声闻得。非缘觉得。非菩萨得。如是得言愚痴之人得陀罗尼。何以故。如愚痴人。虚妄心取。非佛声闻缘觉菩萨

尔时善住意天子。语文殊师利童子言。文殊师利。仁者若非得陀罗尼。何故懞钝。文殊师利言。如是天子。我实懞钝。何以故。彼懞钝行无人能知。如来声闻缘觉菩萨。天子。若非懞钝彼人则是愚痴凡夫。何以故。以障碍故。愚痴凡夫。贪着心行懞钝黠慧。须陀洹人障碍行说尚贪心行。何况愚痴凡夫之人。如是天子。如是得言我是懞钝非得陀罗尼。何以故。乃至少物我不得故

尔时会中五百比丘。闻此法门不能信受。生大怖畏弃舍而去。自身将堕大地狱中。尔时尊者舍利弗。语文殊师利童子言。文殊师利。应当观察此会大众然后说法。仁说如是甚深法门。此众会中五百比丘。闻说如是甚深法门。不能信受。生大怖畏弃舍而去。自身将堕大地狱中。文殊师利言。大德舍利弗。汝莫分别乃至无有少物可得堕于地狱。何以故。以一切法悉不生故。大德舍利弗。汝语我言应当观察此会大众然后说法。大德舍利弗。若善男子善女人。依止我见依众生见。依寿命见依丈夫见。虽复供养恒河沙等诸佛如来应正遍知。及比丘僧。一切乐具。尽其形命如是供养。若闻我说如是难解甚深法门。一切世间闻不能信。谓空无相无愿寂静。不灭不生。无有众生寿命丈夫。无我无常苦法无我。舍而不受速堕地狱。大德舍利弗。若善男子。若善女人。闻此甚深难解之法。舍而不受生地狱中。从地狱出依止我见。虽复供养恒河沙等诸佛如来应正遍知。而不得闻此甚深法

尔时世尊赞叹文殊师利童子作如是言。善哉善哉。文殊师利。如是如是如汝所说。文殊师利。如诸如来出现于世。闻此法门亦复如是。如人证得须陀洹果。闻此法门亦复如是。如人证得斯陀含果。闻此法门亦复如是。如人证得阿那含果。闻此法门亦复如是。如人证得阿罗汉法。闻此法门亦复如是。何以故。非依止我得证此法。证此法时无所得故

尔时世尊即告尊者舍利弗言。舍利弗。此诸比丘速出地狱得证涅槃。非彼愚痴凡夫之人心有所得堕见疑中供养如来。舍利弗。如是彼人以是因缘当得涅槃。非是余人速得解脱。何以故。以不闻此甚深法故。舍利弗。善男子善女人。若得闻此甚深法门。一经于耳。虽不信受堕于地狱。而速解脱。非堕疑见非有所得

尔时善住意天子语文殊师利童子言。文殊师利。仁欲与我同梵行耶。文殊师利童子答言。如是天子。我欲与汝同于梵行。以汝梵行。不取梵行。不行梵行。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。若其取者彼得言行。若其不取彼何所作。天子。若得梵行彼则有行。若无所得彼何所作。天子问言。文殊师利。仁此梵行为何所作。文殊师利童子答言。如是天子。我非梵行。何以故。以此梵行非梵非行非我非梵行。如是得言我行梵行。天子赞言。善哉善哉。文殊师利。乃能如是以无障碍辩才乐说。文殊师利言。我有障碍。云何言我有无障碍辩才乐说。何以故。一切有我有我所者。皆有分别。诸有分别皆有障碍

尔时文殊师利童子。复语善住意天子言。天子。若汝天子欲同梵行。汝断一切诸众生命。而不捉铁。不捉刀块。不捉杖等。如是我汝同于梵行。天子问言。文殊师利。以何意故如是说耶。文殊师利问言。天子所言众生。言众生者。汝意云何。天子答言。文殊师利。所言众生。言众生者。乃至唯有名字想取。文殊师利言。如是天子。杀取我想。杀取命想。取丈夫想。天子问言。仁以何物杀取命想。文殊师利答言。天子。以慧铁杀。彼般若铁如捉如杀如捉不知。如割不知。天子。应知彼门若杀我想杀众生想。如是名杀一切众生。如是我汝同于梵行

尔时文殊师利童子。复语善住意天子言。天子。若汝天子。十不善业道集行。一切染分平等行。非是净分平等行。如是我汝同于梵行。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。若此染分平等。彼平等平等行。如是我汝同于梵行。天子。汝意云何。何者染分平等。天子答言。不作不贪。文殊师利问言。天子。言净分者是何法耶。天子答言。法性法界真如实际三解脱门此是净分。文殊师利问言。天子。汝复更能遮法界不。答言不也。文殊师利言。如是天子。以此意故我如是说。若汝染分平等非净分平等行。如是我汝同于梵行

尔时文殊师利童子。复语善住意天子言。天子。若汝天子。初始起心欲杀人时。汝能头上于先打者。如是我汝同于梵行。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。言杀杀者。是何言语。杀何物人。天子。当知杀言语者。杀贪嗔痴我慢嫉妒。幻伪谄曲取相想受。如是名杀。已说杀竟。天子应知。天子。若有禅师生贪欲心。生已能离。能令寂静。能令寂灭。如是得言空无所有不善不取。如是天子。欲心生灭思量通达。如是此心于何处生于何处灭。于何处乐。于何法乐。如是观察。贪无所得。于何处乐彼无所得。于何法乐彼无所得。若无所得彼则不取。若不取者彼则不舍。若不舍者。如是彼则不取不舍。如是得言离欲寂灭。如是乃至心如是说。天子当知。如是法杀即生即杀。如是得言初始起心欲杀人时头上先打。如是名杀。我意在此故如是说

尔时文殊师利童子。复语善住意天子言。天子。若汝天子。于佛不染法僧不染。如是我汝同于梵行。天子问言。文殊师利。以何意故如是说耶。文殊师利问言。天子。所言佛者。汝云何解。天子答言。文殊师利。如真如法界。如是言佛。文殊师利问言。天子于意云何。真如法界汝能染不。答言。不也。文殊师利言。我意在此故如是说。若汝天子于佛不染。如是我汝同于梵行。复次天子。所言法者。汝云何解。天子答言。文殊师利。是离欲法。如是言法。文殊师利问言。天子于意云何。彼离欲法汝能染不。答言不也。文殊师利言。我意在此故如是说。若汝天子于法不染。如是我汝同于梵行

复次天子。所言僧者。汝云何解。天子答言。以无为故。如是言僧。圣声闻僧是无为僧。如是言僧。文殊师利问言。天子于意云何。彼无为僧汝能染不。答言不也。文殊师利言。我意在此故如是说。若汝天子。于僧不染。如是我汝同于梵行。天子。若人得佛彼则染佛。若人得法彼则染法。若人得僧彼则染僧。天子。若不得佛。如是彼人不染于佛。若不得法。如是彼人不染于法。若不得僧。如是彼人不染于僧。何以故。以佛法僧非彼人得。以如是故得言不染。复次天子。若人爱佛爱法爱僧。彼人染佛染法染僧。若不得佛。彼不爱佛则不染佛。若不得法。彼不爱法则不染法。若不得僧。彼不爱僧则不染僧。天子。若不染着。此贪欲句。此不合句。此示句。此不实思量句。不实句。不实决定句。不离欲句。是故得言离欲寂灭。天子。我意在此故如是说。若汝天子。于佛不染法僧不染。如是我汝同于梵行

尔时善住意天子语文殊师利童子言。甚为希有。文殊师利。乃能如是说甚深处。我当报恩。文殊师利答言。天子。汝莫报恩。天子问言。我今云何得不报恩。文殊师利答言。天子。汝莫报恩。如是天子。汝莫报恩即是报恩。天子问言。文殊师利。仁不报恩。文殊师利答言。天子。如是如是。我不报恩。非我报恩。天子问言。文殊师利。以何意故如是说耶。文殊师利答言。天子。愚痴之人作异异法。愚痴之人作异异见。愚痴之人作异异行。以作异异法行见故。得言报恩。天子。当知此非正行善男子也。乃至少作或作不作。是故得言不报恩者。如佛世尊平等说法。谓一切法皆悉不作。亦不可作。心平等不异取不异作。是故得言不报恩者。天子问言。文殊师利。仁住何法如是说忍。为住忍说为住法说。文殊师利答言。天子。非忍非法。天子问言。文殊师利。于何处住如是说耶。文殊师利问言。天子。幻化人身于何处住。天子问言。何处复有幻化人住。文殊师利答言。天子。如真如住。彼幻化人如是而住。天子。当知若如是说何处住说。若如是者。云何问言何忍何法。天子。当知忍唯有名名无住处。法不移动。亦不分别。又无处所。天子。一切众生于何处住于彼处住。佛如是说。何以故。如佛所说如真如住。一切众生亦如是住。真如不动如。一切众生真如。如来真如。不二真如。不异真如。尔时善住意天子。语文殊师利童子言。文殊师利。言沙门那。沙门那者。是何言语言沙门那。文殊师利答言。天子。谓非沙门非婆罗门。何以故。天子。若不着欲界。不着色界。不着无色界。彼名沙门。我如是说。天子。若不漏眼。若不漏耳。若不漏鼻。若不漏舌。若不漏身。若不漏意。彼名沙门。我如是说。天子。若不依止。不依止说。不依止处。不依处说。彼名沙门。我如是说。天子。若无少心贪乐。无少处来。不伤无伤。彼名沙门。我如是说。如是句说。若非沙门非婆罗门

尔时会中。有五菩萨。得四禅处得五神通。时彼菩萨依三昧坐。依三昧起未得法忍。时彼菩萨自忆宿世。曾杀母来。曾杀父来。杀罗汉来。念彼残业。是故心热不能获得甚深法忍。不能证入。亦不存心。依我分别。心忆彼罪。不能舍离。是故不得甚深法忍。尔时世尊知彼菩萨心可开晓。以威神力加被文殊师利童子。尔时文殊师利童子。承佛神力。从坐而起。整服左肩。右手捉刀。磨令使利。疾走向佛。尔时世尊即语文殊师利童子作如是言。汝住汝住。文殊师利。我先被杀极被杀已。何以故。文殊师利。久远已来。何时有人生心杀我。若生杀心即是杀已。当尔之时。彼五菩萨有如是念。一切法如幻。非我非众生。非命非丈夫。非人摩那婆。非母非父。非阿罗汉。非佛法僧。非有此逆。无造逆人。何以故。今此文殊师利童子。黠慧深解。细心思量。聪明利智。诸佛所赞。得甚深忍。已曾供养过去无量亿那由他百千佛来。文殊师利。种种供养过去诸佛。自在智慧善能通达一切诸法。如法善说。如实而说。恭敬如来彼。捉利刀疾走向佛。佛言住住。文殊师利。我先被杀极被杀已。若少有法和合聚集。决定名佛名法名僧。名母名父名阿罗汉。有逆可取则不可离。当知彼法无体非有。非如非实。不生不起。空如幻化。是故此法无人得罪无罪可得。如是如是。思量善知。彼五菩萨如是知已。即时获得无生法忍。既得忍已欢喜踊跃。上虚空中。去地不远七多罗树。而说偈言

  一切法如幻　　皆从分别起
  此非决定有　　一切法皆空
  心不实分别　　愚痴取我想
  忆念过去世　　作何等恶业
  过去曾杀害　　父母良福田
  杀罗汉比丘　　作极重恶业
  彼恶业果报　　我应受苦恼
  今于善人所　　闻法除疑悔
  心不舍悔恨　　忆持大名人
  解已觉法界　　何处无烦恼
  佛善巧方便　　方便知牟尼
  以何方便力　　净众生疑悔
  诸法空无体　　非佛非法僧
  父母不可得　　非有阿罗汉
  非有少法杀　　亦无少法堕
  诸法平等相　　如彼平等住
  文殊大智慧　　已证如是法
  手捉利刀已　　疾走向如来
  如利刀如佛　　彼二无异相
  非生亦非实　　此中无人杀

说此捉铁刀法门之时。周遍十方恒河沙等。诸佛世界六种震动。大地极动世界皆起。时彼十方诸佛世界。诸佛世尊。皆悉现在现命现住。彼佛侍者各问其佛白言。世尊。是谁威力。动此大地。世界皆起。彼佛答言。善男子。有佛世界名曰娑婆。彼中有佛号释迦牟尼如来应正遍知。为众说法。彼娑婆世界有童子菩萨摩诃萨名文殊师利。于菩提道得不退转。捉利铁刀。智慧铁刀。疾走向佛。以为开晓余菩萨故。有自在力自知堪能。以是因缘令地大动。尔时世尊。依慧铁刀如如法说。令不可数众生眼净心解忍生欲行菩提。尔时世尊以住持力。住持拥护此众会中初始发起微少善根。虚妄分别种种分别诸众生等。令彼众生不见铁刀。于此所说捉刀法门不闻不听

尔时长老舍利弗。语文殊师利童子言。文殊师利。仁作极恶生死之业。欲杀医师。此业若熟于何处受。文殊师利言。大德舍利弗。皆作恶业。我从生来。不曾如是不知此行。于何处熟。大德舍利弗。何处幻人幻化业熟。我如是熟。何以故。以幻化人不生分别无虚妄故。大德舍利弗。一切诸法皆如幻化。复次大德舍利弗。我今问汝。随汝意答。于意云何。汝有铁刀可得不耶。答言无也。汝有恶业可得不耶。答言无也。有得果不。答言无也。大德舍利弗。若无铁无业无果报者。何处业熟。尔时尊者舍利弗言。文殊师利。以何意故如是说耶。文殊师利言。乃至无有少业报熟。何以故。以一切法无业无报无业报熟

尔时彼处十方世界诸来菩萨摩诃萨等白佛言。世尊。惟愿世尊。以威神力加被文殊师利童子。令至十方诸佛世界如是说法。如我来至此佛世界。尔时文殊师利童子。语彼菩萨摩诃萨言。汝善男子。各各观察自佛世界。时彼菩萨摩诃萨等。普彼十方各各观察自佛世界。各各自闻自佛世界。文殊师利童子音声。各见文殊师利童子住其佛前为诸大众说此法门。各各皆有善住意天子。问此法门。各各皆有诸菩萨集。皆有天子。如是见已得未曾有。皆悉叹言。希有希有。今此文殊师利童子。此佛世界安住不动。而一切处皆悉普现。一切皆见。尔时文殊师利童子。为彼菩萨说如是言。善男子。譬如幻师善学幻术。不动坐处示种种色。如是菩萨善学般若波罗蜜幻。如幻法中。乃至一切诸佛世界。随心忆念皆悉普现。何以故。一切诸法皆如幻故。如是应知

尔时世尊语文殊师利童子言。文殊师利。如诸如来出现于世。闻此法门亦复如是。如人证得须陀洹果。闻此法门亦复如是。如人证得斯陀含果。闻此法门亦复如是。如人证得阿那含果。闻此法门亦复如是。如人证得阿罗汉法。闻此法门亦复如是。闻此法门心生信解。如坐菩提。闻此法门亦复如是。文殊师利童子白言。如是世尊。如空如平等。如无相如平等。如无愿如平等。如真如如平等。如法界如平等。如实际如平等。如平等如平等。如解脱如平等。如远离如平等

尔时文殊师利童子白佛言。世尊。唯愿世尊。护此法门后世末世五十年时。于阎浮提广行流布。令善男子善女人咸得闻之。尔时三千大千世界。一切天人鼓乐出声。一切华树皆悉敷荣。出种种华。于此三千大千世界皆悉震动。放大光明遍满世界。蔽日月光令皆不现。六十四亿百千诸天。欢喜踊跃生希有心。住虚空中雨天华香。末香涂香如雨而下。鼓天伎乐一切合掌。同声唱言。善说如是最胜妙法奇妙胜法。今者文殊师利童子。说此法门。我等得闻。于此世界得生人中。便为再见转于法轮。若有众生闻此法门。有能信解不惊怖畏。当知是人必定不从小功德来。若有众生已曾供养过去诸佛。乃得闻此甚深法门不惊怖畏

尔时文殊师利童子白佛言。世尊。今有相现。此经法门住持不灭。能于后世五十年时。于阎浮提广行流布。佛言。如是如是。文殊师利。今有相现。此经法门住持不灭。文殊师利言。如是世尊。实作住持。令此法门久住于世。佛言。文殊师利。若三解脱门得证涅槃。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。文殊师利言。若世尊。说非我非众生非命非丈夫非人摩那婆非染非净。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。若世尊。说非贪嗔痴。非名非色。非因非见。非有非有识。非身非身记。非心非心记。非忆非忆念。非处非处行。非色非受非想非行非识。非眼非色。非耳非声。非鼻非香。非舌非味非身非触。非意非法。非欲界。非色界。非无色界。非断非常。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。若世尊说。非须陀洹非须陀洹果。非斯陀含非斯陀含果。非阿那含非阿那含果。非阿罗汉非阿罗汉法。非辟支佛非辟支佛法。非如来非如来法。非力非无畏。非想非识。非空非无相非无愿。非无欲非本性。非得非证。非集非明。非解脱。非彼岸非中间非此岸。非涅槃。非名非无记。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。若世尊说实无有人相应不相应不合不散。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。如是世尊。若前如来应正遍知。过去已说。无有少法众生得脱。无得涅槃。非有众生。非有法生。非有法灭。非失非动。如过去说。如是未来如是现在皆如是说。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。如是世尊。若说此法无少法说。非语非说。非言语说。非毕竟说。非后时说。非现前说。非响声说。非数数说。非此法说。无一字说。非此法说。无人现在听。无人未来听。无人得解脱。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。若世尊说此戒非戒非戒果。非三昧非三昧处。非般若非般若根智。非解脱非解脱智。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语。若世尊说。菩萨法中非布施舍。非戒守护。非忍修集。非精进发。非禅决定。非般若行。非求菩提。非实行转。非得菩提。非得力。非得无畏。非根非正。非转法轮。非解众生。非言语说。是实实语。此经法门。后世末世五十年时。于阎浮提广行流布。是实实语

说此法时。于此三千大千世界六种震动。尔时弥勒菩萨摩诃萨白佛言。世尊。以何因缘于此世界如是大动。世尊。即告弥勒菩萨摩诃萨言。弥勒。汝今莫作是语。少信众生闻不能解则生怖畏。弥勒菩萨摩诃萨白佛言。世尊。如来若说多人得力。多所利益安乐天人。佛言。弥勒过去已有七十四亿那由他百千诸佛。于此地处说此法门。文殊师利童子菩萨与善住意天子。相随问答论义。弥勒菩萨摩诃萨白佛言。世尊。文殊师利童子菩萨与善住意天子。相随闻此法门。其已久如。于何佛所闻此法门。佛言弥勒。过去久远七阿僧祇百千劫际。有佛出世号曰普华师子游步胜功德集如来应正遍知。如是善男子。于彼佛所闻此法门

说此法时。恒河沙等众生发阿耨多罗三藐三菩提心。彼二倍人得不退忍。彼二倍人得离垢法眼。世尊既说此法门已。时诸比丘。文殊师利童子菩萨。善住意天子。并诸天人阿修罗乾闼婆等。闻佛所说。皆大欢喜

圣善住意天子所问经卷下


文殊师利佛土严净经卷上

    No. 318 [Nos. 310(15), 319]

文殊师利佛土严净经卷上

        西晋月氏国三藏竺法护译

闻如是。一时佛游王舍城灵鹫山。与大比丘十万众俱。及诸菩萨八万四千。皆不退转无所从生。逮得权慧神通无极。随时而化救济三界。其名曰文殊师利。光世音。大势至诸菩萨等咸来云集。七十二亿诸天子俱。皆志大乘。四天王帝释梵天王。各与四万二千诸释梵俱。悉慕大道。四方阿须伦王。难头和难龙王。和伦龙王。娑竭龙王。摩那私龙王。持地龙王。阿耨达龙王。山积龙王。降魔龙王。上月龙王。如是龙王。各从其民六万二千。金比鬼神。旷野鬼神。妙毛鬼神。普等鬼神。善普鬼神。善财鬼神。普像鬼神。无诤鬼神。是诸鬼王。各与等类百千众俱来诣佛所。皆各稽首以次就位。悉都专精志愿经道饥虚于法。身口意并加敬归佛靖心而听

尔时国王太子。大臣百官。长者居士。民众大小。天龙鬼王。咸共供养随其所安。时佛明旦着衣持钵与大众俱。天龙鬼王侍从左右上虚空中。四种莲华纷纷如雨。百千伎乐不鼓自鸣。皆作释梵雅颂八声。诣阿阇贳就王之请。佛显神足光照十方。七宝莲华随迹处生。有化菩萨皆坐其上。光像分明不可称纪。绕城七匝而叹颂曰

  其导师至神　　所愍哀无量
  方便护众生　　消病愈诸疮
  能仁无所著　　心寂善调和
  彼吼护世明　　今日欲入城
  其意已解脱　　度生老病死
  诸天众集会　　各怀欣乐志
  其心甚坚强　　降魔并官属
  释师子至圣　　尊导已来到
  坏世众不消　　至真音难致
  甚猛能制御　　行道亿千劫
  意抱大慈愍　　普护于一切
  今日真正觉　　当入王舍城
  本所行布施　　难量无涯底
  衣食众宝乘　　无复有计限
  惠所爱男女　　妻室及国界
  今彼释师子　　欲入国王宫
  宿世施手足　　头目及耳鼻
  普惠无所逆　　不贪吝重珍
  总摄众功勋　　施一切所有
  尊人以是故　　得入一切智
  常以勤修学　　布施至戒慧
  护戒无缺漏　　故曰真丈夫
  逮戒照忍辱　　持功勋无量
  彼寂然心定　　今日当入城
  于百千亿劫　　行精进解脱
  哀伤众生故　　心未曾懈倦
  一心不可捡　　已度于彼岸
  音声越梵天　　今日欲入城
  其圣明道慧　　无限不可量
  不可得边涯　　假喻如虚空
  人中宝如是　　智德不可尽
  缘从达众行　　严净至尊惠
  因坐佛树下　　降魔及官属
  逮无退道明　　永安无忧戚
  道圣转法轮　　所度不可极
  今日释师子　　欲入王舍城
  若有发道意　　我当得成佛
  处世逮究竟　　诸相三十二
  常兴意无量　　至诚发道心
  辄归于最胜　　供养人中圣
  欲断淫怒痴　　消众尘劳秽
  志降伏一切　　无益瑕疵难
  便宜速行诣　　释师子圣尊
  奉贡众好养　　恪心不可限
  若欲生天上　　天帝释梵王
  百千亿诸天　　所知见宗仰
  常遭值安乐　　在天不失时
  当诣释师子　　所宣辞至真
  其欲慕圣帝　　王于四方城
  自然致七宝　　令我逮尊贵
  千子诸德具　　殊桀甚勇猛
  常勤奉事归　　至真大尊人
  若好尊者位　　长者积财宝
  其生业广大　　常游得自在
  眷属悉豪贵　　端正颜殊好
  当诣释师子　　名好物供尊
  其有已解脱　　方应求度者
  咸当谛听受　　大圣说寂寞
  以闻甘露句　　寂然无忧患
  人中之尊导　　音声甚难值

于时王舍城中无央数众。闻此叹颂劝训之音莫不欣悦。皆发道心。各赍众华诸杂妙香。幢幡宝盖伎乐百千。出城迎佛稽首足下退从佛后。世尊入城足蹈门阃。地则寻时六反震动。箜篌乐器不鼓自鸣。妇女珠环相[改-己+亭]作声。天雨华香其下纷纷。盲视聋听哑言跛行。病愈狂正拘躄得伸。诸被毒螫毒螫不行。裸者得衣贫者得财。飞鸟走兽相和悲鸣。当尔之时众生慈心无淫怒痴。灭除贡高猜恚恨疑。和悦相向如父如母。如兄如弟如身如子。各各欣喜而叹颂曰

  人中之上如月盛满
  为正导师丈夫师子
  世尊入城利益众生
  普安一切盲聋视听
  饥饱寒温乱者得定
  贫者得富狂邪得正
  诸天在上散雨华香
  作众伎乐以为供养
  众生慈心无三毒名
  下心悦意除憍慢情
  如父如母如弟如兄
  如身如子心同意并
  世尊法泽等润十方
  天人群类解无希望
  功勋如是所现难量
  十方威德班宣三藏

于时城中。有贵姓子名弃恶。遥睹世尊行步正齐。容仪端正威神光曜。诸根寂定恬淡玄默。和雅其性如水澄渟。中表清净犹猛师子兽中之王。如日初出照于朝阳。譬月盛满众星中明。佛在大众巍巍堂堂。相好昉着汪汪洋洋。心怀欣悦敬进迎佛。稽首足下右绕三匝。叉手自归长跪白佛。愿闻菩萨为行几法。疾逮正真为最正觉。从心辄成严净佛国。唯垂愍哀分别具说。佛言善哉。弃恶菩萨。乃问如来严净之德。是诸菩萨众行殊特。谛听谛受。善思仪则。弃恶菩萨一切众会。莫不喜踊一心恭肃。皆前礼佛受教而听。佛言。菩萨有一法行。疾成正真为最正觉。从心辄成严净佛国。何谓为一。心常哀愍济度众生。兴发至真仁和道心。何谓至真仁和道心。曰以发道心不行诸法。何所不行。曰不行三垢家业诸利。志存出家不猗众养。从心本愿常崇斯法。何谓出家所崇法行。曰修正真行奉一切法。何谓正真一切之法。曰分别晓了阴种诸入。何谓阴种何所晓了。曰有为无为法皆是五阴。解阴如幻所著。名为知阴本空。是谓晓了幻法本寂。从对而有剖判。本末不见。有二不见。无念亦无望想。此乃专修奉行出家。成菩萨行不舍众生。所以者何。能自调已畅达诸法。尔乃习辩为诸法众生。不得众生亦无诸法。佛言族姓子。是为菩萨一法之行。疾逮正真为最正觉。从心辄成严净佛国。弃恶菩萨。闻佛所说欣悦踊跃。即便逮得不起法忍。身升虚空去地七仞。彼时众中睹斯变化。有二千人发无上正真道意。万四千天人远尘离垢诸法眼净。时佛因笑。无数光色从其口出。照于十方无量世界。还绕佛三匝从顶上入。贤者阿难即从坐起。偏袒右肩长跪叉手。以偈赞佛

  游于诸法度无极　　最胜至真导以力
  皆了众生化上智　　唯愿宣现是笑义
  十力已达往过世　　愍哀亦畅将来业
  悉明现在十方事　　今用何故显笑意
  解于众生之所行　　今如师子睹诸心
  其智慧明无等侣　　唯宣众人调法御
  诸天亿垓普来集　　咸共叉手礼至圣
  愿演第一妙光音　　无数众会观法器

  其慧度无极　　世俗无畴匹
  皆知一切人　　善恶行所趣
  至仁今所笑　　愿为分别义
  当决众疑网　　普宣最尊法
  今诸会大众　　巨亿百千载
  以法故云集　　诸比丘默然
  如敬修供养　　百千伎乐音
  奉行靖心听　　唯愿决众疑

佛告阿难。汝乃见此弃恶菩萨住空中不。对曰已见。佛言阿难。是弃恶菩萨。却后六百二十万劫当成为佛。号曰寂化音如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。世界名安隐。劫名离音。其国比如阿閦如来妙乐世界。功勋严净等无有异。佛叹是已。乃便诣王阿阇世宫。王及夫人太子百官。华香伎乐欢喜迎佛。稽首足下退在佛后。佛入就座。菩萨圣众。名以次第坐如常位。王睹坐定寂靖无声。与后太子手自斟酌百种供膳食皆饱讫。行澡水毕兼施琦宝好衣贡佛别取小床在佛前坐。专心叉手听受道教。欲化中宫及来会者。尔时王阿阇世。长跪白佛。唯然世尊。嗔恨厌嫉从何所生。其愚无明从何所来慧何所灭。佛告王曰。从其吾我生嗔恨厌嫉。住于自大则生其愚。不别正谛是曰无明。见正从谛斯则为慧。慧除众恶如明消冥。见正从谛亦复如是。王重启曰。见正从谛愿分别之。佛言大王。法本空无从意生形。解意无处则无去来。了一切空是为见正。见正不转则曰从谛。具解如是乃曰为了。王闻佛言应心说法。欣然大悦善心生焉。即便叹曰。善哉世尊。至未曾有斯则如来之善言教。假令我身中寿终者。心不疑乱必能奉之。佛从座起与诸大众。即皆俱还于灵鹫山。敕诸直使布设众座。请诸会人皆令就坐。时舍利弗。承佛圣旨即从坐起。偏袒右臂长跪叉手而白佛言。向城中弃恶菩萨。所问微妙严净佛土。世尊即答粗举义要。弃恶寻便受佛记拜。闻者解释各获果证。意不达者咸用瞢瞢唯愿世尊。加哀重说具敷演之。令诸菩萨坚固其行。住于正道而不动转。成一切智降魔官属。摄诸异学灭诸尘劳。劝化邪业使入正道。舍小乘地转不退轮。具悉至愿利益众生。蒙严净力致无限明。未度者度未成者成。今现众会族姓子女。虚心乐闻唯重散说愿令法泽润及后世。加哀慈念当为众会

尔时世尊心念是法微妙殊特。乃是菩萨大士之业。今当班宣不宜小会。宁可现瑞感十方世界。即如所念。便放其身毛孔之光。普照十方恒沙世界。十方诸佛各遣菩萨。神智无量微妙明达。各从菩萨百亿之众。皆现神变来入忍界。见能仁佛供侍拜谒。稽首佛足各自陈曰。睹佛光瑞垂恩见接。凭恃四等听受法说。我本土佛而见难曰。汝曹何为诣忍世界。忍土五逆刚强弊恶。贪嫉淫妒骂詈咒咀。心多嗔毒转相伤害。粗犷[怡-台+龍]悷侜张难化。勿至忍界自深劳秽。我等皆复重自启曰。力能堪任来至忍界。正使遭值众恼诸害火烧刀割终无恨意。世尊及诸正士。乃能劳谦忍诲群生。愿乐礼侍咨受深经。我本土佛乃见遣听。重复敕曰。往族姓子。从意顺时。牢自持心慎勿懈疑。如我本土百千劫行。不如忍世精进一旦。是故世尊。历恒沙界不以为远。愿闻世尊说严净经。及诸正士论讲要言。于是弥勒菩萨即从坐起偏袒右臂。长跪叉手前诣佛所。以偈叹曰

  无量威德闻十方　　光照上下恒沙界
  一切众生无能称　　人中圣慧不可议
  十方世界恒沙国　　菩萨大众为法会
  用乐道法亦恪住　　唯人中尊宣法训
  世尊名称遍十方　　禁戒三昧智慧然
  仪好无动如师子　　犹若日光曜虚空
  诸天龙王及鬼神　　其比丘众比丘尼
  清信士女叉手住　　愍哀安住唯宣法
  以知过去及当来　　分别晓了今现在
  为众生本所应度　　以律开化决狐疑
  云何菩萨造立行　　国土严净光所照
  何因具足众大愿　　唯人中上宣此意
  何缘此等无贪嫉　　何谓禁戒无所犯
  以何为众修勤行　　因群黎故行愍哀
  何从奉行无数劫　　用精进故势力上
  智慧不倦脱无为　　济度众生勤苦患
  其意清定恒一心　　行净脱门住禅思
  修无所著如莲华　　云何立行消殄欲
  从何奉行深妙业　　何因志行度世法
  何缘伏魔及兵众　　以降化之即成佛

于时世尊告弥勒曰。布法高座。如来今当并为十方诸菩萨众。敷演往古性和佛国功勋严净愿行法典。弥勒受教。即心念言。如来何故使我施座。不令阿难目连等乎。文殊师利即知弥勒心之所念。便答弥勒。当知如来使仁布座。说是法时。非诸声闻缘觉之等所能受持。纯为菩萨宣是法耳。于时弥勒即如其像三昧正受。为佛设座高四百万里。以无数宝而校成之。天缯綩綖而布其上。座之光明照此三千大千世界。佛起升座。三千世界六反震动。于时如来告舍利弗。菩萨有四事法具足所愿。何谓为四。一曰志性仁和。二曰愍哀众生。三曰精进不懈。四曰一心常安。习善亲友。是为四法具足所愿

佛告舍利弗。菩萨复有一法不失所愿。何谓为一。于是开士。当学追慕阿閦如来宿命本行菩萨道时。志愿出家乐沙门行。世世所生不违本誓。乃能进至得如来号无所从生。是则菩萨第一之利用。舍家故得致十德。一者无有贪欲放逸之态。二者常好闲居不习愦闹。三者常奉佛行舍远小节。四者弃捐痴冥无益之法。五者不慕妻子家居恩爱。六者释置恶趣非法之患。七者摄取安乐天上善处。八者未曾违失宿命本德。九者诸天爱敬常恋侍卫。十者诸龙神王常拥护之。是为十德。若有菩萨不舍大乘慕度众生。常当追乐出家之业。是为一法不失所愿。随志所好致何佛土。如意辄成严净佛国。是则菩萨第一善利。佛告舍利弗。菩萨复有二事法。不舍所愿。何谓为二。一曰不乐小乘不学其行。不与从事愿开度之。不说其法用教化人。二曰常以无上正真之道。劝进众生令成佛法。是为二法。勤心正真等诲不倦。则便逮受十功德福处。何谓为十。一者摄取佛土无小乘学。二者纯诸菩萨圣众来会。三者诸佛世尊常念护之。四者十方诸佛所见叹誉。称其功德面为说法。五者发微妙心常修正真。六者不愿天帝释梵王。心常精勤志存正道。七者若生人间作转轮王。主四天下以道教导。八者所生之处不违道业。常见诸佛无上正真。九者诸天人民所见爱敬。十者受不可计无量功德。是为十处。所以者何。说能化度一佛国众生之类。皆令致得无著果证。不如菩萨弹指之顷。劝化一人发无上正真。何况十处功德妙深。随意所欲在取何国。如愿辄成严净之德。是为二法不违本愿

佛告舍利弗。菩萨复有三法不失所愿。能具功德严净佛土。何谓为三。一曰尊乐闲居心习靖寂。二曰常以殷勤谨护禁戒未曾阙漏。三曰常惠法施无衣食望。是为三法坚护禁戒行菩萨禁。因此辄逮十无畏。一者能护戒行入于城邑。若至聚落心无所难。二者若在众会说法勇猛。三者入众中饭食不恐。四者在家讲颂心无所惧。五者若入精舍亦无所畏。六者居在圣众不怀怯弱。七者言谈说事不以恐惧。八者往奉师父及诸和上。恭恪不慢无畏所犯。九者若有所说常抱慈心心不畏恶。十者若受衣食床卧医药亦无所难。是为十。又加十事乃具严净。何谓为十。一者不畏恶业。二者不贪亲族。三者不求名称。四者不慕家种。五者不姤种姓。六者常知止足。七者衣食床卧病瘦医药而知节限。八者虽在家居叹说道法。九者诸天往造稽首礼侍。十者未曾思念非宜之想。心常念佛欣然专精无衣食意。是乃具足严净佛土。又复十事受德名称何谓为十。一曰弃舍众会不慕因缘。二曰常习燕处不思城邑。三曰心存禅思无有邪念。四曰不志多事愦闹之中。五曰心常念佛无他之思。六曰不舍身安而为危害。七曰净修梵行未曾中碍。八曰以少事故得三昧定。九曰闻所说义要妙章句识念不失。十曰如所听经解义归趣能为人说。是为十法。佛告舍利弗。复有四法不失所愿。何谓为四。一曰菩萨所作言行相应。二曰弃捐自大。三曰舍于贪嫉。四曰见他人安代之悦豫。是为四。又有四事至诚谛教。何谓为四。一曰所生之处口常清净气优钵香。二曰言辞辩慧无所阙漏。三曰诸天世人皆保信之。四曰不失好声必获佛音。是为四。复有四法所修训诲。何谓为四。一曰不生三趣无憎恶者。二曰所学不慕九十六种所见迷惑。三曰怨家恶友不得其便。四曰天上世间咸共归礼。是为四。复有四法流布训诲。何谓为四。一曰不舍布施之心。谷米踊贵因时惠施。二曰不慕世荣所有财业。三曰往奉自归禁戒之士。四曰若有布施不怀贪嫉。是为四。复有四法。可悦他人心知止足。何谓为四。一曰是众生等是为我所吾当安之。二曰斯等贪财依怙身力以为无双。菩萨加哀施以所安。当计财业非是我侣。常畏五分侵夺无期。三曰若多财宝妻子炽盛眷属丰饶。不以信乐不恋国土。何况他人望于众生。四曰志未曾求非业钱财行在诸俗。是为四法。菩萨行是不失所愿严净佛土

佛告舍利弗。复有五法不失所愿。何谓为五。一曰常乐经法勤求道义。二曰知无数世所生往反。三曰以闻经法如诸佛行成就功勋。四曰所从听经每事问义。造立何行具足疾成。五曰若闻经法寻能奉行。是为五法。不失所愿严净佛土

佛告舍利弗。复有六法不失所愿。何谓为六。一曰好喜布施心无悭嫉。以身施与不惜寿命。不爱妻子异女眷属。心无希冀不怀望想。二曰菩萨在家若出行学。宁失身命不犯禁戒。谨慎守护常住梵行。兴发众生以戒劝助。三曰知身假借诸法如幻。坚住忍力逆对不起。设遭毒害刀杖加刑恶骂咒咀愁恼之患。未曾起意而有恨心。四曰奉行精进心无所著。深念非常如救头然。行止卧觉未曾懈废废火烧身心不退却。五曰专心守靖寂无他念。入无生寂伏想不起。心如灰灭形如枯朽。六曰见正从谛灭除邪伪。晓了三界如响如幻。法无常名如水月形。愍哀一切劝诲众生。是为六法如愿辄成。具足功德严净佛国。佛告舍利弗。复有七法不失所愿。何谓为七。一曰一切所有而以布施。所可施者亦无所获。二曰奉戒不亏不想所禁。三曰劝于众生不起法忍。四曰以精进行不得身心。五曰成就禅定一心摄念。六曰具足智慧不怀希望。七曰常志念佛舍众希望。是为七法。所行具足严净佛土

佛告舍利弗。复有八法不失所愿。何谓为八。一曰所宣不说无益之言。二曰以布施事用为庄严。三曰其心柔和而无粗犷。四曰恭敬法师不怀轻慢。五曰常行谦恪下意顺众。六曰性行清白而无沾污。七曰若不持戒知报应事。八曰不自伤行不毁他人。是为八法严净佛土

佛告舍利弗。复有九法不失所愿。何谓为九。一曰常护身行令不亏失。二曰口言谨慎而无缺漏。三曰将护其意使无邪想。四曰弃去贪欲心无所著。五曰刈除嗔恚心不起恨。六曰灭愚冥业不为闇昧。七曰常行至诚而无欺惑。八曰行慈坚固心不移易。九曰依善知友未曾舍远。是为九法严净佛土

佛告舍利弗。复有十法不失所愿。何谓为十。一曰闻地狱苦心怀恐惧。奉修哀心。二曰闻畜生苦亦复怖懅兴随道哀。三曰闻饿鬼苦亦复畏难发起大慈。四曰闻天上安亦复不喜常兴大哀。五曰闻于人间谷米踊贵。弊恶加害而兴慈仁。六曰心自念言加勤精进悉忍众苦。乃使佛土严净无量。七曰令无三苦众恼之患。八曰使其佛土丰饶平贱。九曰人民安和寿命无限。十曰皆自然生无所名属。至成无上正真之道。是为十法所愿不失严净佛土

佛告舍利弗。菩萨执华诣如来时若诣塔寺。当作是念。愿使众生心意软净颜貌和悦。如华软妙形色香洁。见莫不欢爱之欣悦。愿成佛时令我国中香树妙华周匝普遍。衣被饮食杂彩幡盖。金银珍宝皆自然生。其土人民禁戒清净。心意柔软和雅其性。逮深法忍神通无上。又舍利弗。菩萨所为先人后己。念安一切如父如母。见人得安欣然代喜。愿成佛时生我国者。皆令安和无嫉妒疑。恬然入定心无念思。又舍利弗。菩萨护口未曾犯失。不可之言不加人物。语常如法非义不出。愿成佛时生我国者。言辞柔和无有不可。语声八种出口和雅。又舍利弗。菩萨戒净身口意善。复劝他人使行己善。令转相教普及一切。愿成佛时生我国者。令身口意完净无漏。神通具足在所至凑。又舍利弗。菩萨所游兴隆道化。常以正真开度男女。未曾讲论小乘之语。愿成佛时生我国者。不闻声闻缘觉之行。转不退轮逮最正觉。令纯淑行流布无极。又舍利弗。若有菩萨不嫉彼供不断他养。见人得供代之悦预。愿成佛时生我国者。无贪嫉名皆获法利。又舍利弗。若有菩萨不自称善不说人短。不讲众僧比丘尼阙。闻见人论有如己犯。愿成佛时生我国者。皆令清净不闻罪名。又舍利弗。若有菩萨慕求经道如渴欲饮。志存正真不好异法。愿成佛时生我国者。皆乐经道慕求正法。又舍利弗。若有菩萨常作音乐歌颂佛德。供养如来若塔形像。以是德本劝助学者。愿成佛时百千伎乐不鼓自鸣。演八法音闻皆欣悦。开发道心悉获正真。又舍利弗。若有菩萨见众生心放逸驰骋。开视正要使不愦闹。愿成佛时生我国者。使无乱志。摄念入定以禅为食。众想寂灭皆至正觉。佛语舍利弗。假使如来以劫之寿咨嗟佛土。成就功勋不可究尽。而譬喻之。今粗为汝略举之耳。若有闻是菩萨行德。思齐慕及逮志不疑。亦当成其严净佛土

佛告舍利弗。菩萨复有三法。疾逮正觉。不失所愿如意即得。何谓为三。一曰所愿特尊与众不共。二曰所行安谛而不放逸。三曰如所闻法奉行不惓。是为三。舍利弗言。善哉至未曾有。如来善训道品备悉。所愿成就严净佛土

佛告舍利弗。如是如是。如尔所云。如来作佛积行所致。不以饰辞巧言成道。放逸行者自误入冥堕四颠倒。没生死河求出难得。若有菩萨闻是经者。愿乐奉行立不放逸。必当成就如上所教

于是会中。八万四千菩萨即从坐起叉手自归。同发声言。我等世尊。愿皆奉行如佛训教。具足所愿从行得道。除去饰辞放逸之巧。备悉弘誓戒德之要。愿使一切悉行敏诲。以行自严去众秽操。时佛欣笑。口中五色光出照于十方。还绕身三匝从顶上入。贤者舍利弗。前白佛言。何因缘笑。今佛归笑必当有意

佛告舍利弗。汝宁见此诸族姓子师子吼不。白言已见世尊。佛言。是族姓子于后来世。竟百千劫皆当成佛。号曰净愿如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。国土严净犹如西方安养之国。功勋严净等无有异。其寿命等亦无差别。又问云。何其寿命等亦无差别。佛言。各寿十劫

尔时师子步雷音菩萨即从坐起偏袒右肩。长跪白佛言。文殊师利童真。诸佛所叹咨嗟功德。今当久如成最正觉。佛言。汝自以是问文殊师利。寻如佛教前问文殊师利。仁尊。久如当成无上正真之道逮最正觉。文殊师利答曰。当作是问。仁为志学无上正真道乎。所以者何。假使吾身学佛道者。当作斯问。吾不求道。当何因成最正觉。又问。仁不以众生求最正觉乎。答曰不也。所以者何。众生不可得故。假使吾得众生处所。当为众生志求佛道。所以然者。无有吾我人寿命故。由是之故身无志求亦无退转。又问。仁不求佛慕佛法乎。答曰不也。所以者何。一切诸法皆悉佛法。若使众法无有众漏无受因缘无想。是志佛道。解了若此逮一切法。又如仁问逮立佛法。随仁意答。谁求志者。色志佛道乎。色志本净志佛道乎。其色本无志佛道乎。色自然。色悉空。色恍忽。色本净。色寂然。以此色法志求佛道成正觉乎。答曰不也。色不志道本净自然以空寂然。诸色法不志求道不成正觉法亦如是。文殊师利又问曰。痛想行识及与识法。志求佛道乎。答曰不也。文殊师利曰。五阴识法不成正觉。于意云何。其外五阴我人寿命。可言有处乎。答曰不也。文殊师利曰。如是我当分别。以何等法志求佛道成最正觉。又问文殊师利。其阿夷怙新学菩萨。闻是教训将无恐怖乎。所以者何。仁之名号一切导首。为众重任而今造证。为诸菩萨颁宣诸法。不志求道不成正觉。文殊师利答曰。法界不恐本际不惧。闻佛说法无所畏难。其恐惧者则怀忧戚。无忧戚者则离尘埃。彼则解脱。其以解脱则无所著。以无所著则无复转。以无复转则不复脱。其不脱者彼无从来。以无从来亦不从去。其无从去则无所愿。其无所愿则无志求。其无志求则无退转。以无退转。若不退转便不退转。空无不转无想不愿。斯本际者佛法不转。佛法无作无有边际。佛法无著则无所倚。佛法无行亦无精进。亦无所行无有教令。其诸佛法假有号耳。又计空法无所从生。无所从来无所从去。又计佛法不离尘劳贪怒痴垢。佛法无染尘劳之行。无有吾我寂无所念。所行无念无尽不起。平等无邪则诸佛法亦无非法。所以者何。无处所故无可行者。是曰佛法。若有新学菩萨闻是说者。若恐怖者疾成正觉。若不恐怖不成正觉。又问文殊。为谁说是。文殊曰。其恐怖者乃有妄想。以有妄想。心自念言。我身当得成最正觉。缘是之故便起道意志存正觉。于意云何。从来未曾有觉成空不。答曰无也。文殊又曰。世尊不云一切诸法等如虚空。答曰有是。文殊又曰。道犹虚空等亦本无。虚空如道。道如虚空。空之与道则无有二不可分别。其解斯等。则无所知亦不无慧。文殊师利说是语时。四千比丘漏尽意解。十二垓众得法眼净。九万六千人从古以来未发道心。皆发无上正真道意。四万二千人逮得无所从生法忍

文殊师利佛土严净经卷上文殊师利佛土严净经卷下

        西晋月氏国三藏竺法护译

于时师子步雷音菩萨。复问文殊师利。发意久如应发道心。文殊答曰。止族姓子。勿怀妄想。一切诸法皆无所生。假使有说我发道心吾当行道堕大邪见。所以者何。今观察心都永不见。心发道意。亦复不观彼发道心者也。吾亦不见道心所存。吾由是故不发道心。又问仁者。以无所见。今何以故宣此章句。文殊答曰。无所见者乃为等教。无所见趣。名是章句平等言辞。又问。何故言曰趣平等乎。文殊答曰。如族姓子所言等者。无若干故。其平等者彼无行法。于其平等无有譬喻。不见诸法是乃平等。若宣斯训则宣一业。若寂然业无有尘劳。不为嗔恨而说经法。不有断灭不计有常。不起不灭不有吾我亦无所受。不举不下不高不卑。虽有所说无有妄想亦无思求。若族姓子。有晓此法而奉行者。乃曰平等。又有菩萨广入于法。不见若干。亦复非一乃曰平等。其平等者则无偏党。其无偏党是甚清净

于时师子步雷音菩萨。前白佛言。唯然世尊。文殊师利。所说巍巍乃如是乎。发道心以来为几何耶。众会思渴愿乐欲闻。佛言。族姓子。文殊师利在深妙忍。所入深忍不逮得道。亦不得佛复不得心。以无所得故不说之。久如发心为发道意。唯佛今当为汝解说本初发心。乃往过去七千阿僧祇江河沙劫。乃尔世时有佛号雷音响如来至真等正觉。乃在东方。去此七十二垓佛土世界名曰快成。其佛土在彼颁宣道教。弟子声闻八十四亿百千垓众。诸菩萨等复倍是数。时有转轮圣王。名曰安拔号为法王。治以文法王四天下。王有七宝圣王。尔时往诣雷音响如来所。供养尽意八万四千岁。随其所安。王心念言。我已积功德行难量。不用斯心宁以德本并修劝助。复更思惟。以德劝助当求何劝。天帝梵王号转轮圣王声闻缘觉耶。适发是意。上虚空中演大音声。大王如是莫兴贱意。当发无上正真道心。王闻是言。即时大悦王弘慈心不转道意。所以者何。用其天人开示意之故。知我心念。时安拔王与大众俱。九十六亿垓人。往诣雷音响如来稽首足下。右绕七匝退住一面。以偈叹曰

  欲问殊胜法　　以奇雅答我
  云何人在世　　而致最超异
  以普俱供养　　自归于世护
  用无所著心　　永无所劝助
  世尊察知之　　吾独寂发心
  以兴广供养　　云何劝助之
  志天帝梵王　　为四方之王
  若求于声闻　　当慕缘觉乘
  我适发是念　　空中宣洪音
  仁者慎莫得　　劝助下劣心
  当为一切故　　兴发微妙心
  开显大道意　　饶益于世间
  今欲问于佛　　在诸法自由
  云何起发心　　不失于道意
  唯说斯义趣　　何因逮是处
  如我所像人　　而发菩提心
  天中尊愿说　　宣上妙章句
  大王且听之　　当宣以渐训
  愍哀于众生　　乐住于法本
  如所誓志愿　　转得成所趣
  吾亦往宿世　　因发起道心
  愍哀于众生　　而兴斯誓愿
  如本所志愿　　亦若心所念
  逮无动佛道　　在世寂上圣
  大王当强志　　造立极上心
  若修诸正行　　仁亦当成佛
  以闻是言教　　王意便欣然
  在一切普世　　颁宣师子吼
  假使于本际　　不知生死元
  为一一人行　　如若干众生
  今发于道心　　在一切世间
  普请于众生　　令不堕贫匮
  从今日以往　　假使生欲心
  辄当欺诸佛　　现在十方圣
  若生嗔恨厌　　嫉妒及贪苦
  未曾犯不可　　至成人中尊
  常当修梵行　　弃欲舍秽恶
  当学于诸佛　　戒禁调和性
  不以斯四色　　疾成佛正觉
  用心切之故　　当行于本际
  常严净佛土　　无限不可议
  当宣传名称　　通彻于十方
  唯圣见授慧　　成佛人中上
  令其心清净　　永无众犹豫
  常修治身行　　口言亦如是
  亦当净心念　　不犯众瑕疵
  假使我成佛　　在世人中尊
  以是正真言　　地当六反动
  设我言至诚　　真正不虚诈
  由是见证明　　虚空宣伎乐
  若实不谀谄　　无贪嫉不厌
  以是诚信故　　雨清净意花
  适宣斯言已　　至诚言无异
  十方亿万国　　则六反震动
  于上虚空中　　有巨亿音乐
  天雨杂意华　　积地四丈九
  其王以学是　　二十亿众人
  口宣柔和音　　必成佛上道
  二十亿众等　　一切建佛道
  见王发大道　　亦效学洪业

佛语师子步雷音菩萨。欲知尔时安拔王乎。答曰不及也。佛言。则今文殊师利身是也。发道心已来。如七千阿僧祇江河沙劫佛土满中尘。逮无所从生法忍已。过六十四江河沙劫。于彼世等则具十住成就十力。普备一切诸佛道地辨诸佛法。从初以来未曾一反生心而有发意也。皆以逮致无上正真之道。为最正觉。我亦不念言当云何成最正觉。其二十亿人。在往古雷音响。如来所发道心者。悉已逮致无上正真之道。成最正觉已转法轮。为诸众生兴立佛事。灭度去已。悉是文殊师利之所劝发。皆悉供养勤修众行。六度无极。普以执持传宣正法。于今现在适有一佛说法未灭度耳。下方界分去是四十四江河沙等佛土。有世界名地底。其佛号持地如来至真等正觉。今现在说法。与无央数诸声闻俱。其寿无限。佛说是往古喻时。七千人皆发无上正真道意

于是师子步雷音菩萨。问文殊师利。仁者在往古佛。具一切法如来十力。已备十地。用何等故不成正觉。文殊师利答曰。不以往古过去诸佛一切诸法成最正觉。所以然者。此言得道则为不得。亦无所逮。又问。云何具足佛法。答曰。具本无故。又问。云何具足本无。答曰。备悉虚空乃具本无。晓了虚空及诸佛法本无之义。等无有二不可分别。又问。云何以具一切诸法。答曰。具足五阴。乃能具三界一切。普备十方诸佛之法。又问。云何具足诸色。答曰。仁等见色。色有常乎。若无常耶。答曰不也。曰诸法有常若无常乎。又彼五阴有增有减耶。答曰不也。文殊师利曰。是故族姓子。若于诸法不增不减。故曰具足。曰何以具足。答曰。备诸法慧不所解亦如如慧不转。尔乃不知诸妄想处。以无妄想不造具损。其不具损乃曰平等。是故族姓子。等见诸色尔乃等见一切诸法痛想行识。亦复如是等无有异

于是师子步雷音菩萨。问文殊师利。又察仁者。逮得法忍以来久远悬绝迥邈巍巍。如是不一发心吾当得道。仁者。云何劝化众生使发道心。答曰。吾不劝众生令发道心。又问何故。答曰。众生不实。众生寂莫所在颠倒。故劝化之令发道心。假使众生不处颠倒。则无有道何所发乎。吾以是故。不劝众生使发道心。亦不化之令悉求道。所以然者。无所想者乃曰平等。其平等义无所志求亦不退转。是故名曰无所归趣无所从来。当观生死。所谓平等斯章句空。空无志求。又族姓子。向者所问逮得法忍以来。久远悬绝迥邈巍巍。如是不一发心吾当得佛。卿宁见心。以何等心得成佛道。答曰不也。所以者何。心者无形不可睹见。道亦复然。亦无形色复不可见。所以道者假有号耳。所曰言心及与佛道是悉假托。是故族姓子。吾宣斯辞。不一发心吾当得佛。其无发心无所生亦无所毁。以无所生无所毁者。乃名曰逮。又问。何所是时曰约时。乃曰为时耶。答曰。族姓子所云时者。畅平等觉所可觉者不增不损。永不起想亦无所灭。尔乃名曰随其等时。其不妄想本无本是则名曰随等时也。若逮正见。等于平等达于诸法。都无所获则不造计。若干种品一无所念。尔乃名曰随等时也。若身证明一切诸法。诸所相者皆为法相。晓了如是故有心着。若无有相则无所倚。尔乃名曰等随时矣。又问。何谓为逮。文殊师利答曰。无所行也。谓名所迹故曰为逮。而于三界悉无所行。假有斯辞其得尘劳则不能逮。所以然者。意无所存斯法无言。以是之故不可逮得。又族姓子。无所得者乃曰为逮。其无所言则不逮法便无所住。若不得法乃曰为逮

于时师子步雷音菩萨。前白佛言。善哉善哉世尊。唯如来说。文殊师利成佛道时国土何类。佛告之曰。汝以是语问于文殊师利。即受佛教问文殊师利曰。仁成佛时国土何类。文殊师利答曰。族姓子。若仁好乐佛道者。当问成佛国土何类。又问文殊师利。仁者。不乐佛国土乎。答曰不也。又问何故。答曰。其有所乐则为乐欲。其乐欲者则有恩爱。其恩爱者则有所受。若有所受则有苦患。其苦患者则无有护。是故吾身不成正觉。所以者何。无所得故。若不得道是故无乐。又如向者仁之所言。国土何类说其本末。吾不堪任自亏其身。所以者何。若有菩萨用叹己故。便自亏灭佛及国土功勋严净。面见如来无极法藏。时佛告曰。文殊师利。宜用时说成己佛土功勋严净。以何志愿如来听之。或有从仁闻说所愿诸余菩萨。缘是发意具足斯业。文殊师利答曰。唯然不敢违教。即从坐起偏袒右臂。右膝着地叉手白佛。唯承圣旨今当宣之。若族姓子及族姓女。求佛道者且共听之。闻已具得行是所愿。应时十方各如江河沙诸佛国土六反震动。时文殊师利复白佛言。唯然世尊。我之本愿如佛所言。从如七千阿僧祇江河沙劫行菩萨业。不成道场不致正觉。道眼彻视光睹十方。悉见诸佛普劝化一切众生悉成佛道。吾心坚住咸开化之。布施持戒忍辱精进一心智慧。而劝助之。皆是吾身之所劝化。唯然大圣。今观十方以无挂碍清净明眼所见。诸佛皆以劝助建立无上正真之道。斯等皆办。乃吾成无上正真之道。为最正觉也。虽有是言故尔续立不成正觉。假使所愿若具足者乃成佛耳。时彼众会诸菩萨等各心念言。文殊师利前后所见。诸佛世尊为几何。于时佛即知诸菩萨众心之所念。告师子步雷音菩萨曰。犹如族姓子。有一丈夫出现于世。取是三千大千佛土。满其中尘取破碎之。一一诸尘各各碎之。各如一佛国满中诸尘。族姓子。所趣云何。岂宁有人知是尘数多少者不。答曰。无能知者天中之天。佛言。假使族姓子。悉能晓了知是尘数佛国多少。不足言也。文殊师利明眼所睹。十方佛土所见。过是尘数之国。百倍千倍。万倍亿倍。巨亿万倍。兆载劫数不可限。无量无边。所愿如是不成正觉。正使佛国如江河沙。周匝十方满中佛树。一一树下有坐菩萨。须臾一时皆成无上正觉之道。逮最正觉。临灭度时。不须佛树道场起焉普为一切。复过十方不可计量诸佛国土。化于众生说法使度。所愿巍巍致此佛国乃成佛道。使其国中无有声闻缘觉之名。纯诸菩萨灭除疲厌嗔恨之难。净修梵行周遍佛土。悉复不闻女人之名。使诸菩萨皆得化生。身被法服加趺而坐。佛国严净纯诸菩萨。炽盛巍巍除小乘法

于是师子步雷音菩萨前白佛言。成佛之时所号云何。佛言。名曰普现如来至真等正觉。所以号曰普现者何。其佛功德普现十方无限国土。其有得见普现如来。若睹光明皆当得前。逮成无上正真之道。于今若佛灭度之后。得闻将来普现佛名。亦当得决。然后成无上正真之道。除入灭志得道迹者。文殊师利。复白佛言。唯然世尊。我所誓愿得成佛时生我国者。令无饥渴饮食之想。众味馔具自然满钵在右掌。适在掌中心则发念。不先供养十方诸佛。声闻缘觉及诸贫匮。危厄乞丐下劣众生。先自食者则为不宜。先饱一切然后乃食。寻如所念神通备足。在所至凑无有挂碍。行疾如所念。即到十方供养诸佛下遍众生。宝衣法服俱亦复然。先供养诸佛。次及所尊穷贱下劣皆先使安。无有八难众苦恼患。语则可意不闻恶言。学无禁戒是非之音。无尊无卑无富无贫。其生我国皆同一伦

于时师子步雷音菩萨。前白佛言。尔时彼土无名号字。佛言。如本誓愿所志具足。世界名曰离尘垢心。复白佛言。在于何方。佛言。在于南方。去是忍界极在其边。众妙宝摩尼明珠合成佛土。十方一切未曾见闻。奇珍众宝流布遍现。未曾朽败而有减损。菩萨所作欲令其地化成众宝。如念即成在作何宝。众妙香华所欲备有。亦无日月明冥昼夜。若菩萨身光所照随意。唯华开合别昼异夜。无有寒暑老病死事。唯行菩萨便成正觉。若至他方亦无异业。天上世间悉行菩萨临命终没皆成正觉。无有终没无中灭度。虚空之中不见伎乐悲和之音。自然而作其音。不宣爱欲之辞。恒出佛法六度无极菩萨箧藏经法之音。随意所好闻经法音。如念即解皆发正觉。见佛疑灭闻经解达。于时会中有无央数诸菩萨众。同时举声謦扬大音。佛闻是号适得其宜。名曰普现无违道教。若有众生闻普现名。乃获快利无极之庆。况生其国得见普现。值遇神化法则其行。若有闻是所说决者。则为见佛闻经入心藏之不忘。但逮得闻文殊师利成佛名德。巍巍乃尔何况目见。时佛告是诸菩萨曰。若有得闻百千亿佛名号功称。利益众生开化度人。不如文殊师利。一一劫中化导众生永安无患。何况得遇普现如来。其庆无喻诚如所云。于是众会。闻佛赞是诸菩萨言。应时座中诸天神王。及世间人各万亿垓。俱时稽首礼文殊师利。同发声言。今自归命普现如来。自归适讫。便有八万四千垓众。皆发无上正真道意。余无量人积众德本立不退转。时文殊师利复白佛言。今我愿是诸不可计。无量佛土功勋严净目之所睹。由从所愿瑞应处所。皆使合并成一佛土。不计声闻缘觉。严净五浊恶世发意之顷。正使我身江河沙劫称叹诸国功勋严净。无有限量不得其底。我所誓愿复过越彼。无能究竟证明我者。独佛缕练明知我耳。佛言。善哉诚如仁言。如来通慧三达无碍。真尔真尔等无有异。尔时会中诸菩萨众又心念言。如佛咨嗟文殊师利成佛国时功勋严净。何如西方安养世界无量寿佛严净等不。时佛即知诸菩萨心。便告师子步雷音菩萨。欲知西方安养世界无量寿佛功勋严净。比于文殊师利难以喻哉。假譬言之如取一毛破为百分。以一分毛取海水一渧。无量寿佛如一分毛水一渧耳。文殊师利成佛汪洋如海。巍巍荡荡不可思议

于时师子步雷音菩萨前白佛言。曾颇有余方如来国土严净如是者不。佛言有。东方去是百亿江河沙界。名曰超立愿。其佛号名普照常明德海王如来至真等正觉。与诸菩萨眷属围绕而说法经。兴演以来江河沙劫。其佛寿命亦无有限。比普现国严净正等。有四菩萨被弘誓铠得不可议。又白佛言。唯愿加哀宣布未闻。具说普照常明德海王如来其土严净。又四菩萨名号何等。在于何方游何佛土。净德普备能具斯处。佛言。第一菩萨名曰光英。游于东方无忧首如来佛土。第二菩萨名曰慧上。在于南方慧王如来佛土。第三菩萨名曰寂根。在于西方智积如来佛土。第四菩萨名曰意愿。在于北方钩锁如来佛土。于时世尊。即如其像三昧正受。其三昧名悉现严净。应时见东方普照常明德海王如来佛土。及诸菩萨功勋严净。自昔以来所希见闻。譬如掌中视宝珠耳。如普现佛国土无异。众会睹之莫不欣喜。诚如世尊所言。无有异也。世尊即便告诸菩萨。当如文殊师利所行为法。诸菩萨众同发声曰。唯然受教。当学文殊师利本发心行。成就严净不敢懈废

于时世尊。寻便欣笑光从口出。五色晃昱普照十方掩覆日月。绕身三匝还从顶入。弥勒菩萨即从坐起。长跪叉手前问佛言。佛不妄笑笑必有意。是何因缘愿佛说之。佛言弥勒。向佛说法现三昧力。皆见东方普照佛国。具足备悉严净功德。众会欣悦誓愿志学。今现八万四千菩萨。咸共发心成严净国。复有菩萨八万四千十六正士发仁慈心。性弱和雅所愿具足。斯等如是当逮文殊师利。其余菩萨不能若斯。虽尔缘是功德福。疾成无上正真之道为最正觉。国土成就不及文殊师利严净之德。佛言弥勒。若有菩萨心性至真。口宣誓愿不犯本心。亦当具足如文殊师利身。其心怯弱而有信乐。缘是口勇宣辞誓愿。转得超越六十万亿垓劫终始之难。六度无极则以具足。时四菩萨各从其方化作重阁众宝挍络。各从诸天无数百千。雨众天华鼓众音乐。神足威变地为动震。四面俱进来趣世尊。光照众会见莫不欣。弥勒长跪而白佛言。今地大动天华纷纷。重阁晃曜四方来臻。鼓乐弦歌天香苾芬。此何瑞应谁之威神。佛言弥勒。是四菩萨即来见佛。用自神力感动众会。故现此瑞劝化于法。时四菩萨即进诣佛稽首礼足绕佛三匝。佛命使坐退而就榻。时佛宣告诸会菩萨。此四正士多所劝发。兴建誓愿不可称计。设族姓子。谦敬渴仰于此正士。因问法义疑网永止。行菩萨业灭除终始。必逮无上正真之道。超二十亿劫周旋之恼。普具诸法六度无极。若有女人闻是正士名号之称。速转女身疾解正觉。尔时世尊敛复威神。一切众会还自如故。彼佛国土忽然不现。于是文殊师利前白佛言。唯然世尊。一切诸法犹若如幻。幻师所作适起寻灭。诸法展转亦复如是。其不起灭乃曰平等。平等学者必逮正觉。逮正觉已度脱一切。慧上菩萨问文殊师利曰。菩萨何行而成正觉。文殊师利答曰。无逮无失是曰正觉。慧上又问。宁可复得不可逮乎。亦复无乎。若不逮有。则无有众不可逮众。文殊师利答曰。亦不可逮亦复不无。所以不逮。是诸法过悉无所生。初无所有。非方当有不怀无得。文殊师利。又复问慧上曰。何所一业敷演经法

于是慧上答曰。其无所生亦无所坏。不造异住。是曰一业。敷演经法

光英菩萨曰。其无来无往。是曰一业敷演经法

寂根菩萨曰。其无所得亦无所等。亦不造证亦不寂然。亦无淡怕无去来今。是曰一业敷演经法

意愿菩萨曰。其不妄想佛法圣众。不念菩萨。无国土想无地狱念。不断章句不倚有常。是曰一业敷演经法

弥勒菩萨曰。不见五阴衰入诸种。不视不盲无妄想法。不畅入法不积不舍。是曰一业敷演经法

师子步雷音菩萨曰。其于乱法而无所乱。不造若干是凡夫法。斯习学法此诸佛法。不怀妄想不受一法。其业寂寞。是曰一业敷演经法

爱见菩萨曰。其逮本无不想今无。斯深妙法悉无妄想。是曰一业敷演经法

无碍辩菩萨曰。诸法皆尽究竟尽者。乃曰无尽。演一切法不可尽者。是曰一业敷演经法

善心念菩萨曰。其于诸念而无所思。若有所入亦不无心。不得不失。是曰一业敷演经法

觉离尘菩萨曰。于诸尘法而无所染亦无不染。不着不忧不忘不念。不作无不作不取不舍。是曰一业敷演经法

海底菩萨曰。其志如海永难得底。深入法要不见妄想。如所应行而颁宣法不我无彼。是曰一业敷演经法

十上月童真菩萨曰。普等众生若如月满。心不见等无所等。是曰一业敷演经法

消诸忧冥菩萨曰。其能休息一切忧疮不忧不戚。以能割除众愦诸本。何所是本吾我之本。其有等经共吾我行而说法者。是曰一业敷演经法

钩锁菩萨曰。若说于法。其不倚着欲界色界及无色界。不着声闻缘觉之法。不慕佛道。是曰不业敷演经法

普现菩萨曰。等宣诸法等于空无。不念于空不得平等。所说如是。是曰一业敷演经法

三品净菩萨曰。其讲说法净三品场。何谓三场。不得吾我。不想法会。不倚诸法。是曰三场清净之业宣布法训。如斯说者。是曰一业敷演经法

在所吉菩萨曰。知一切法归于平等。若晓了斯。而为分别不宣文字。以无所宣一切诸法。是曰一业敷演经法

深行菩萨曰。若有睹见一切诸法。亦无所见。若讲如是言辞。是曰一业敷演经法

如是要言。一切菩萨各言其志。说是一业经典法时。七千亿菩萨逮得无所从生法忍。八十万四千垓人皆发无上正真道意。七千比丘漏尽意解。九十六载诸天世人远尘离垢诸法眼生

于是师子步雷音菩萨前白佛言。文殊师利。成普现佛时。诸菩萨能有几所。其寿久如。何时成佛。佛言。卿自以是问于文殊师利。即如佛教。问文殊师利曰。仁当久如成最正觉。文殊师利答曰。虚空有形乃成正觉。假使幻人成佛道者。我身尔乃无著漏尽成最正觉。若呼有形而响有影。月能昼明日而夜照。尔乃我身成最正觉。志求道者。乃当问之成佛之期。又问。仁者为不志求道。答曰不也。曰何以故。答曰。道是文殊。文殊是道。所以者何。假有号耳。文殊及道其名寂寞。了无解空空则曰道

佛告师子步雷音菩萨言。宁曾见闻无量寿佛国中菩萨声闻众不。答曰唯然。亦见亦闻。佛言。为多少乎。答曰。不可思议不能称限。佛言。普现佛国菩萨之数。喻如积尘满十方界。无量寿佛菩萨声闻比数多少如一尘耳。又普现佛寿命无限。取譬言之。破碎十方三千世界。皆使作尘布散此尘过千佛国。乃着一尘周匝十方。而尽其尘。于族姓子宁能计知此尘数不。答曰。无能限焉。佛言。普现如来以劫之寿当一尘耳。计尘之喻尚不足言。欲知其要如虚无边。年寿劫数无以比焉。于时弥勒菩萨前白佛言。假使有人学于大乘。为是大智无极之慧。当忍勤苦无央数劫。自归普现行菩萨法。如斯大道不当懈废。佛言如是弥勒。诚如所云。谁有闻是无极大慧。不发道意爱乐之乎。唯有懈废小节之类。不解正真不乐之耳。佛说是时十千众人发大道心

尔时世尊。告师子步雷音菩萨言。今叹文殊师利自昔所行本心志愿。度佛无量菩萨无数。道慧高德不可思议。周匝十方诸得道者不能究尽。为作譬喻时。师子步雷音菩萨前白佛言。假使有人立弘誓愿无极之行。当如文殊师利志愿等不。忍勤苦行。于无数劫而无懈厌。不发劳想。佛言。族姓子意趣云何。虚空宁念我行昼夜日月时节年限劫数不。答曰不也。曰如是族姓子。晓了诸法亦如虚空。虚空寂定。不念昼夜日月时节年限劫数也。所以者何。空无念思岂有劳想。过江河沙劫亦无增损。不衰不盛不坏不毁。不生不老。不病不死。不去不来。所以然者。虚空与有假有号耳。文殊师利名号如是。其能晓了如虚空者。悉知诸法一切无辞皆无所有。便无恐怖不以为劳。文殊师利成佛久远乃尔志同。文殊师利等亦如是

于时海底菩萨。谓文殊师利。所被弘誓不可比喻。若有学者当云何进。文殊师利答曰。若有学我弘誓铠者志存誓愿。若如幻化则无所有亦无所为。佛说是经时。四大天王。天帝释梵天王。及余尊大神妙诸天。佥然同音。俱共叹曰。唯然世尊。其闻是经。为得善利无极之庆。何况受持讽诵学者。我当受持讽诵修学。广为人说普令流布。将护行者使法久存

于时师子步雷音菩萨前白佛言。唯然世尊。若有受持讽诵斯经得何福庆。若有闻者即便发心追慕志学。文殊师利景则复云何乎。佛言。若有菩萨学是法者。犹如如来已无挂碍。若于将来最后末世。则以七宝积满十方诸佛之国。则贡上佛供养一切。等心众生历劫不废。又兼法施备具六德。此之功德又不足计。不如闻是严净经法发心慕学。文殊师利。谟式讽诵。经行七步之内。德过于彼巨亿万倍无以为喻不可称计

时弥勒菩萨前白佛言。是经所名。云何奉持。佛语弥勒。斯经典者。号曰娱乐所愿殊特。当奉持之。又名文殊师利佛土功勋严净。亦复名曰其发道心志怀悦豫。当坚持之。尔时十方诸来菩萨。皆散天华供养是法。咨嗟文殊师利无量之德。法泽普润弘覆三界。开心受者皆逮正觉。前礼佛足绕佛三匝。忽然不现各还本国。佛说是时。化江河沙诸菩萨等立不退转。信是菩萨具成德本

于是文殊师利有三昧。名光普照辞训如幻。以斯定意而行正受。适三昧已。一切众会。皆见文殊师利。普在十方不可称计诸佛之国。各各佛前文殊师利住立咨嗟己国严净之德。众会见已叹未曾有。文殊师利所愿无尽。道德巍巍超绝无比。乃使其身遍显十方。端坐在此而不转移。威神功德堂堂不呰。佛说如是。诸菩萨众。比丘比丘尼。清信士清信女。诸天龙神。阿须伦世间人。皆大欢喜。稽首佛足。作礼而去

文殊师利佛土严净经卷下


文殊师利所说不思议佛境界经卷上

    No. 340 [No. 310(35)]

文殊师利所说不思议佛境界经卷上

        唐天竺三藏菩提流志奉　诏译

如是我闻。一时佛在舍卫国。祇树给孤独园。与大比丘众一千人菩萨十千人俱。复有欲界诸天子色界诸天子及净居天子。并其眷属无量百千周匝围绕。供养恭敬听佛说法。尔时佛告文殊师利菩萨言。童子。汝有辩才。善能开演。汝今应为菩萨大众宣扬妙法。时文殊师利菩萨白佛言。世尊。佛今令我说何等法。佛言童子。汝今应说诸佛境界。文殊师利菩萨言。世尊。佛境界者。非眼境界。非色境界。非耳境界。非声境界。非鼻境界。非香境界。非舌境界。非味境界。非身境界。非触境界。非意境界。非法境界。无如是等差别境界。是乃名为诸佛境界。世尊。善男子善女人。有欲入于佛境界者。以无所入而为方便乃能悟入。尔时文殊师利菩萨白佛言。世尊。如来于何等境界而得菩提。佛言童子。我于空境界得菩提。诸见平等故。无相境界得菩提。诸相平等故。无愿境界得菩提。三界平等故。无作境界得菩提。诸行平等故。童子。我于无生无起无为境界得菩提。一切有为平等故。时文殊师利菩萨复白佛言。世尊。无为者是何境界。佛言。童子。无为者非思量境界。文殊师利菩萨言。世尊。非思量境界者是佛境界。何以故。非思量境界中无有文字。无文字故。无所辩说。无所辩说故。绝诸言论。绝诸言论者。是佛境界也

尔时世尊问文殊师利菩萨言。童子。诸佛境界当于何求。文殊师利菩萨言。世尊。诸佛境界。当于一切众生烦恼中求。所以者何。若正了知众生烦恼。即是诸佛境界故。此正了知众生烦恼。是佛境界。非是一切声闻辟支佛所行之处

尔时世尊复语文殊师利菩萨言。童子。若佛境界即于一切众生烦恼中求者。诸佛境界有去来乎。文殊师利菩萨言。不也世尊。诸佛境界无来无去。佛言童子。若诸佛境界无来无去者。云何而言若正了知众生烦恼。即是诸佛境界耶。文殊师利菩萨言。世尊。如诸佛境界无来无去。诸烦恼自性亦复如是无来无去。佛言童子。何者是诸烦恼自性。文殊师利菩萨言。世尊。佛境界自性。即是诸烦恼自性。世尊。若佛境界自性。异诸烦恼自性者。如来则非平等正觉。以不异故。于一切法平等正觉说名如来

尔时世尊复语文殊师利菩萨言。童子。汝能了知如来所住平等法不。文殊师利菩萨言。世尊。我已了知。佛言童子。何者是如来所住平等法。文殊师利菩萨言。世尊。一切凡夫。起贪嗔痴处。是如来所住平等法。佛言童子。云何一切凡夫起贪嗔痴处。是如来所住平等法。文殊师利菩萨言。世尊。一切凡夫于空无相无愿法中起贪嗔痴。是故一切凡夫起贪嗔痴处。即是如来所住平等法。佛言童子。空岂是有法而言于中有贪嗔痴。文殊师利菩萨言。世尊。空是有。是故贪嗔痴亦是有。佛言童子。空云何有。贪嗔痴复云何有。文殊师利菩萨言。世尊。空以言说故有。贪嗔痴。亦以言说故有。如佛说比丘。有无生无起无作无为。非诸行法。此无生无起无作无为。非诸行法。非不有。若不有者。则于生起作为诸行之法。应无出离。以有故言出离耳。此亦如是。若无有空。则于贪嗔痴无有出离。以有空故说离贪等诸烦恼耳。佛言童子。如是如是。如汝所说。贪嗔痴等一切烦恼。莫不皆住于空之中。文殊师利菩萨复白佛言。世尊。若修行者。离贪嗔等而求于空。当知是人未善修行不得名为修行之者。何以故。贪嗔痴等一切烦恼即空故

尔时世尊复语文殊师利菩萨言。童子汝于贪嗔痴。为已出离为未离乎。文殊师利菩萨言。世尊。贪嗔痴性即是平等。我常住于如是平等。是故我于贪嗔痴。非已出离亦非未离。世尊。若有沙门婆罗门。自见离贪嗔痴。见他有贪嗔痴。即是二见。何谓二见。谓断见常见。所以者何。若见自身离贪嗔痴即是断见。若见他身有贪嗔痴即是常见。世尊。如是之人非为正住。夫正住者。不应于己见胜谓他为劣故。尔时世尊复语文殊师利菩萨言。童子。若如是者。住于何所名为正住。文殊师利菩萨言。世尊。夫正住者无有所住。住无所住。是乃名为正住之耳。佛言童子。岂不以住于正道为正住耶。文殊师利菩萨言。世尊。若住正道则住有为。若住有为则不住于平等法性。何以故。有为法有生灭故

尔时世尊复语文殊师利菩萨言。童子。无为是数法不。文殊师利菩萨言。世尊。无为者非是数法。世尊。若无为法堕于数者。则是有为非无为也。佛言童子。一切圣人得无为法不有数耶。文殊师利菩萨言。世尊。非诸圣人证于数法。已得出离诸数法故

尔时世尊复语。文殊师利菩萨言。童子。汝为成就圣法。为成就非圣法。文殊师利菩萨言。世尊。我不成就圣法。亦不成就非圣法。世尊。如有化人。为成就圣法。为成就非圣法。佛言童子。化人不可言成就圣法。亦不可言成就非圣法。文殊师利菩萨言。世尊。佛岂不说一切诸法皆如幻化。佛言如是。文殊师利菩萨言。世尊。一切诸法如幻化相。我亦如是。云何可言成就圣法成就非圣法

尔时世尊复语文殊师利菩萨言。童子。若如是者。汝何所得。文殊师利菩萨言。世尊。我得如来平等无自性境界。佛言童子。汝得佛境界耶。文殊师利菩萨言。若世尊于佛境界有所得者。我亦得于诸佛境界。时长老须菩提。问文殊师利菩萨言。大士。如来不得佛境界耶。文殊师利菩萨言。大德。汝为得声闻境界不。须菩提言。大士。圣心解脱无有境界。是故我今无境界可得。文殊师利菩萨言。大德。佛亦如是。其心解脱无有境界。云何而谓有所得乎。须菩提言。大士。汝今说法。可不将护初学心耶。文殊师利菩萨言。大德。我今问汝。随汝意答。如有良医欲治人病。为将护病人心故。不与辛酸碱苦应病之药。能令其人病得除差至安乐不。答言不也。文殊师利菩萨言。大德。此亦如是。若说法师。为将护初学心故。隐甚深法而不为说。随其意欲演粗浅义。能令学者出生死苦至涅槃乐。无有是处。说是法时。众中有五百比丘僧。诸漏永尽心得解脱。八百诸天子。远尘离垢得法眼净。复有七百诸天子。闻其辩才深生信乐。皆发阿耨多罗三藐三菩提心。尔时须菩提复白文殊师利菩萨言。大士。汝颇亦于声闻乘。而生信解。又以此乘法度众生不。文殊师利菩萨言。大德。我于一切乘皆生信解。大德。我信解声闻乘。亦信解辟支佛乘。亦信解三藐三佛陀乘。须菩提言。大士。汝为是声闻。为是辟支佛。为是三藐三佛陀耶。文殊师利菩萨言。大德。我虽是声闻。然不从他闻。虽是辟支佛。而不舍大悲及无所畏。虽已成正等觉。而于一切所应作事未尝休息。须菩提又问言。大士。汝云何是声闻。答曰。我恒为一切众生说未闻法。是故我为声闻。又问言。汝云何是辟支佛。答曰。我能了知一切诸法皆从缘起。是故我为辟支佛。又问言。汝云何是三藐三佛陀。答曰。我常恒觉一切诸法体相平等。是故我为三藐三佛陀。尔时须菩提又问言。大士。汝决定住于何地。为住声闻地。为住辟支佛地为住佛地耶。文殊师利菩萨言。大德。汝应知我决定住于一切诸地。须菩提言。大士。汝可亦决定住凡夫地耶。答曰如是。何以故。一切诸法及以众生。其性即是决定正位。我常住此正位。是故我言决定住于凡夫地也。须菩提。又问言。若一切法及以众生。即是决定正位者。云何建立诸地差别。而言此是凡夫地。此是声闻地。此是辟支佛地。此是佛地耶。文殊师利菩萨言。大德。譬如世间以言说故。于虚空中建立十方。所谓此是东方。此是南方。乃至此是上方。此是下方。虽虚空无差别。而诸方有如是。如是种种差别。此亦如是。如来于一切决定正位中。以善方便立于诸地。所谓此是凡夫地。此是声闻地。此是辟支佛地。此是菩萨地。此是佛地。虽正位无差别。而诸地有别耳

尔时须菩提。复白文殊师利菩萨言。大士。汝已入正位耶。文殊师利菩萨言。大德。我虽已入亦复非入。须菩提言。大士。云何已入而非入乎。文殊师利菩萨言。大德应知。此是菩萨智慧善巧。我今为汝说一譬喻。诸有智人以譬喻得解。大德。如有射师其艺超绝。惟有一子特钟心爱。其人复有极重怨仇。耳不欲闻眼不欲睹。或时其子出外游行。在于远处路侧而立。父遥见之。谓是其怨执弓持箭控弦而射。箭既发已方知是子。其人巧捷疾走追箭。箭未至间还复收得。言射师者喻菩萨也。一子者喻众生也。怨家者喻烦恼也。言箭者。此则喻于圣智慧也。大德当知。菩萨摩诃萨。以般若波罗蜜观一切法。无生正位大悲善巧故。故不于实际作证。而住声闻辟支佛地。誓将化度一切众生至佛地矣。尔时须菩提。又问文殊师利菩萨言。大士。何等菩萨能行此行。文殊师利菩萨言。大德。若菩萨。示行于世而不为世法所染。现同世间不于诸法起见。虽为断一切众生烦恼。勤行精进而入于法界不见尽相。虽不住有为亦不得无为虽处生死如游园观。本愿未满故。不求速证无上涅槃。虽深知无我而恒化众生。虽观诸法自性。犹如虚空。而勤修功德净佛国土。虽入于法界见法平等。而为庄严佛身口意业故不舍精进。若诸菩萨。具如是行乃能行耳

尔时须菩提复白文殊师利菩萨言。大士。汝今说此菩萨所行。非诸世间所能信受。文殊师利菩萨言。大德我今为欲令诸众生永出世间。说诸菩萨了达世法出离之行。须菩提言。大士。何者是世法。云何名出离。文殊师利菩萨言。大德。世间法者所谓五蕴。其五者何。谓色蕴受蕴想蕴行蕴识蕴。如是诸蕴。色如聚沫。受如浮泡。想如阳焰。行如芭蕉。识如幻化。是故此中无有世间亦无诸蕴及以如是言说名字。若得是解心则不散。心若不散则不染世法。若不染世法即是出离世间法也。复次大德。五蕴诸法。其性本空。性空则无二。无二则无我我所。无我我所则无所取着。无所取著者即是出离世间法也

复次大德。五蕴法者。以因缘有。因缘有故则无有力。无力则无主。无主则无我我所。无我我所则无受取。无受取则无执竞。无执竞则无诤论。无诤论者是沙门法。沙门法者知一切法。如空中响。若能了知一切诸法如空中响。即是出离世间法也

复次大德。此五蕴法同于法界。法界者则是非界。非界中。无眼界无色界无眼识界。无耳界无声界无耳识界。无鼻界无香界无鼻识界。无舌界无味界无舌识界。无身界无触界无身识界。无意界无法界无意识界。此中亦无地界水界火界风界虚空界识界。亦无欲界色界无色界。亦无有为界无为界。我人众生寿者等。如是一切皆无所有。定不可得。若能入是平等深义。与无所入而共相应。即是出离世间法也。说是法时会中比丘二百人。永尽诸漏心得解脱。各各脱身所著上衣。以奉文殊师利菩萨而作是言。若有众生得闻于此甚深妙法应生信受。若不生信欲求证悟终不可得

尔时长老须菩提语诸比丘言。汝何所得以何为证。诸比丘言。大德。无得无证是沙门法。所以者何。若有所得心则动乱。若有所证则自矜负。动乱矜负堕于魔业。若有自言我得我证。当知则是增上慢人。佛言。诸比丘。汝等审知增上慢义不。诸比丘答言。世尊。如我意者。若有人言我能知苦。是不知苦相而言我知。我能断集证灭修道。是不知集灭道相。乃至而言我能修道应知此是增上慢人。所以者何。苦相者即无生相。集灭道相。即无生相。无生相者即是非相。平等相是诸圣人。于一切法得解脱相。是中无有知苦断集。证灭修道。如是等相而可得者。若有众生得闻如是一切诸法平等之义。而生惊怖。应知是为增上慢者

尔时世尊即告之言。善哉善哉。诸比丘。如汝所说。如是如是。须菩提。汝等当知此诸比丘。已于过去迦叶佛所。从文殊师利童子。得闻如是甚深之法。以闻法故疾得神通。今复得闻随顺不逆。须菩提。若复有人于我法中。得闻斯义生信解者。皆于来世见弥勒佛。若未发大乘意。于三会中悉得解脱若已发大乘意者。皆得住于堪忍之地

尔时善胜天子白文殊师利菩萨言。大士。汝常于此阎浮提中。为众说法今兜率天上有诸天子。曾于过去值无量佛。供养恭敬种诸善根。然生在天中耽着境界。不能来此法会而有听受。昔种善根今将退失。若蒙诱诲必更增长。惟愿大士。暂往天宫。为彼诸天弘宣法要。尔时文殊师利菩萨。以神通力即于其处。忽然化作兜率天宫。如其所有悉皆备足。令善胜天子及此会中一切人天。皆谓在于彼天之上。具见于彼种种严饰。园林池沼果树行列殿堂楼阁。栋宇交临绣柱承梁雕窗间户。攒栌叠栱磊砢分布。称宝为台庄严绮错。其台极小犹有七层。或八层九层。乃至高于二十层者。一一台上处处层级。皆有众天女。盛年好色手足柔软。额广眉长面目清净。如金罗网常有光明。亦如莲华离诸尘垢。发言含笑进止回旋。动必合仪丽而有则。譬如满月人所乐见。笙篌琴瑟箫笛钟鼓。或歌或啸音节相和。妙妓成行。分庭共舞。如是等事宛然备瞩。时善胜天子。见自宫殿及其眷属欢娱事已。心生疑怪。白文殊师利菩萨言。奇哉大士。云何令我及以大众瞬息之间而来至此

尔时长老须菩提。语善胜天子言。天子。我初亦谓与诸大众皆共至于兜率陀天。而今乃知本来不动。曾不共往彼天之上。如是所见皆是文殊师利菩萨三昧神通之所现耳。时善胜天子即白佛言。世尊。文殊师利菩萨。甚为希有。乃能以三昧神通不思议力。令此众会不动本处而言至此兜率陀天。佛言天子。汝但知文殊师利童子神通变化少分之力。我之所知无有量也。天子。以文殊师利神通之力。假使如恒河沙等诸佛国土。种种严好各各不同。能于一佛土中普令明见。又以如恒河沙等诸佛国土。集在一处状如缯束。举掷上方不以为难。又以如恒河沙等诸佛国土。所有大海置一毛孔而令其中众生。不觉不知无所触娆。又以如恒河沙等诸佛国土。所有须弥山王以彼众山内于一山。复以此山内于芥子。而令住彼山上一切诸天。不觉不知亦无所娆。又以如恒河沙等诸佛国土。其中所有五道众生置右掌中。复取是诸国土一切乐具。一一众生尽以与之等无差别。又以如恒河沙等诸佛国土。劫尽烧时。所有大火集在一处。令其大小如一灯炷。所有火事如本无别。又如恒河沙等诸佛国土。所有日月若于一毛孔。舒光映之普令其明隐蔽不现。天子。我于一劫若一劫余。说文殊师利童子三昧神通变化之力。不可穷尽

尔时魔波旬自变其身作比丘形。在于会中却坐一面。白佛言。世尊。我今闻说文殊师利童子神通之力。不能信受。唯愿世尊。令于我前现其神力使我得见。尔时世尊知是恶魔变为比丘。欲令众生善根增长。故告文殊师利菩萨言。汝应自现神通之力。令此会中无量众生咸得善利

文殊师利所说不思议佛境界经卷上文殊师利所说不思议佛境界经卷下

        唐天竺三藏菩提流志奉　诏译

尔时文殊师利菩萨受佛教已。即时入一切法心自在神通三昧。入此三昧已起神通力。现于如上所说神变之事。显然明着皆悉现前。如佛所言不增不减。预斯会者靡不咸见。是时大众睹此神力。叹未曾有。同声唱言。善哉善哉。诸佛如来。为众生故出现世间。复有如是善权大士。同出于世。而能现此不可思议威神之力。尔时恶魔见此种种神变事已。欢喜踊跃礼文殊师利菩萨足。合掌恭敬而向如来。作如是言。文殊师利童子甚为希有。乃能现是不可思议神通变化。诸有闻者孰不惊疑。若有众生得闻此事。能生信受。假使恶魔如恒河沙。欲为恼害终不能也。世尊。我是恶魔。常于佛所。伺求其便。心喜恼害一切众生。若见有人精勤习善。必以威力为其障碍。世尊我从今日深发誓心。但此法门弘宣之处。所在国土城邑聚落。百由旬内我在其中。譬如盲者无有所作。不于众生而生侵恼。若见有受持读诵思惟解释是经者。必生尊重供给供养。世尊我之俦党。乐于佛法而生留难。若见有人修行于善。要加逼沮令其退失。我今为断如是恶事说陀罗尼。即说咒曰

怛侄他阿么黎(一)毗么黎(二)耻(音天以反)哆答鞞(三)阿羯波儞是多设咄[口*路](四)誓曳(五)誓耶末底(六)输(去声)婆末底(七)睒迷(去声下两字同)扇底(八)阿普迷(九)普普迷(十)地[口*梨](十一)阿契(十二)莫契(十三)佉契(十四)弭履罗(十五)阿伽(去声)迷(十六)普罗(十七)普罗普罗(十八)输(上声下同)迷输输迷(十九)地[口*梨]地[口*梨](二十)阿那跋底(二十一)耻哆答鞞(二十二)讫里多遏梯(二十三)讫里多毗(入声)提(二十四)毗卢折(音之热反)担(音丁合反二十五)萨达摩婆拏(上声)拘(二十六)曷写苏怛罗写陀路迦(二十七)阿(入声)跋罗自多伊婆苏履耶(二十八)

世尊。此陀罗尼拥护法师。能令其人勇猛精进辩才无断。一切恶魔无能得便。更令其魔心生欢喜。以衣服卧具饮食汤药。诸有所须而为供养。世尊。若有善男子善女人。受持此咒日夜不绝。则为一切天龙乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等常所守护。一切怨憎不能为害。佛语魔言。善哉善哉。汝今说此陀罗尼。令恒河沙等无量世界六种震动。魔王当知。汝此辩才。皆是文殊师利童子神力所作。文殊师利菩萨。以神通力令魔波旬。说此咒时。众中三万人。皆发阿耨多罗三藐三菩提心

尔时文殊师利菩萨。作是变已。摄其神力。即告善胜天子言。天子我今欲诣兜率陀天。汝可先往令其众集。时善胜天子。闻是语已与其眷属。右绕于佛及文殊师利等菩萨大众。于会中没须臾之间到彼天宫。至天宫已。普告众言。汝等当知文殊师利菩萨摩诃萨。愍我等故欲来至此。汝等诸天皆应舍离放逸诸乐而共来集。为听法故。时善胜天子。作是语已。于天宫中建立道场。其场广博清净严好。以天如意众宝所成。东西三万二千由旬。南北一万六千由旬。又于其中置无量百千师子之座。其座高广种种庄严。以天宝衣而覆其上。时善胜天子。严办道场及师子座已。曲躬合掌。遥向文殊师利菩萨。而作是言。我至天宫所为事毕。唯仁降止今正是时。尔时文殊师利菩萨与诸菩萨。一万二千人。大声闻一千五百人。及余无量百千天龙夜叉乾闼婆等。从坐而起顶礼佛足。右绕三匝。于如来前没而不现。须臾之顷至兜率陀天。诣道场中如其敷拟各坐其座

尔时四天王天。三十三天。夜摩天化乐天他化自在天。及色界中诸梵天众。递相传告而作是言。今文殊师利菩萨。在兜率陀天欲说大法。我等应共往诣其所。为欲听闻所未闻法。及见种种希有事故。作是语已。欲色界中无量阿僧祇。诸天子众。于须臾顷。各从所住。而来共集兜率天宫。以文殊师利菩萨威神之力。其道场中悉皆容受而无迫隘

尔时善胜天子。白文殊师利菩萨言。大士。今此大众悉已来集。愿以辩才阐明法教。时文殊师利菩萨普告众言。诸仁者。若诸菩萨。住四种行。则能成就一切善法。何等为四。一者持戒。二者修禅。三者神通。四者调伏。若能持戒则成就多闻。若能修禅则成就般若。若得神通则成就胜智。若住调伏则能成就心不放逸。是故我言若诸菩萨住于四行则能成就一切善法。诸仁者。当知持戒具足八法而得清净。何等为八。一者身行端直。二者诸业淳净。三者心无瑕垢。四者志尚坚贞。五者正命自资。六者头陀知足。七者离诸诈伪不实之相。八者恒不忘失菩提之心。是名持戒八种清净

复次诸仁者。应知多闻亦以八法而得清净。何等为八。一者敬顺师长。二者摧伏憍慢。三者精勤记持。四者正念不错。五者说释无倦。六者不自矜伐。七者如理观察。八者依教修行。是名多闻八种清净

复次诸仁者。应知禅定亦以八法而得清净。何等为八。一者常居兰若宴寂思惟。二者不共众人群聚谈说。三者于外境界无所贪着。四者若身若心舍诸荣好。五者饮食少欲。六者无攀缘处。七者不乐修饰音声文字。八者转教他人令得圣乐

复次。诸仁者。应知般若亦以八法而得清净。何等为八。一者善知诸蕴。二者善知诸界。三者善知诸处。四者善知诸根。五者善知三解脱门。六者永拔一切烦恼根本。七者永出一切盖缠等惑。八者永离一切诸见所行。是名般若八种清净

复次。诸仁者。应知神通亦以八法而得清净。何等为八。一者见一切色无有障碍。二者闻一切声无所限隔。三者遍知众生心之所行。四者忆念前际无碍无著。五者神足游行遍诸佛国。六者尽一切漏而不非时。七者广集善根而离诸散动。八者如初发誓愿恒为善友广济众生。是名神通八种清净

复次。诸仁者。当知于智亦以八法而得清净。何等为八。一者苦智遍知五蕴。二者集智永断诸爱。三者灭智观诸缘起毕竟不生。四者道智能证有为无为功德。五者因果智知业与事无有相违。六者决定智了知无我无众生等。七者三世智善能分别三世轮转。八者一切智智。谓般若波罗蜜于一切处无不证入。是名为智八种清净

复次。诸仁者。应知调伏亦以八法而得清净。何等为八。一者内恒寂静。二者外护所行。三者不舍三界。四者随顺缘起。五者观察诸法其性无生。六者观察诸法无有作者。七者观察诸法本来无我。八者毕竟不起一切烦恼。是名调伏八种清净

复次。诸仁者。应知不放逸亦以八法而得清净。何等为八。一者不污尸罗。二者恒净多闻。三者成就诸定。四者修行般若。五者具足神通。六者不自贡高。七者灭诸诤论。八者不退善法。是名不放逸八种清净

诸仁者。若诸菩萨住不放逸。则不失三种乐。何者为三。所谓诸天乐禅定乐涅槃乐。又则解脱三恶道。何者为三。所谓地狱道畜生道饿鬼道。又则不为三种苦之所逼迫。何者为三。所谓生苦老苦死苦。又则永离三种畏。何者为三。所谓不活畏恶名畏大众威德畏。又则超出三种有。何者为三。所谓欲有色有无色有。又则涤除三种垢。何者为三。所谓贪欲垢嗔恚垢愚痴垢。又则圆满三种学。何者为三。所谓戒学心学慧学。又则得三种清净。何者为三。所谓身清净语清净意清净。又则具足三种所成福。何者为三。所谓施所成福戒所成福修所成福。又则能修三种解脱门。何者为三。所谓空解脱门无相解脱门。无愿解脱门。又则令三种种性永不断绝。何者为三。所谓佛种性法种性僧种性。诸仁者。不放逸行有如是力。是故汝等应共修行

复次。诸仁者。菩萨所行六波罗蜜。一一具有三所治障。若住不放逸速能除断。何等为三。谓自不布施。不欲他施。嗔能施者。自不持戒。不欲他持。嗔能持者。自不忍辱。不欲他忍。嗔能忍者。自不精进。不欲他精进。嗔能精进者。自不修定。不欲他修。嗔能修者。自无智慧。不欲他有。嗔能有者。如是名为菩萨六度一一见有三障差别。不放逸行之所除断

复次诸仁者。菩萨所行六波罗蜜。各以三法而得成满。此三皆从不放逸生。何等为三。布施三者。谓一切能舍不求果报回向菩提。持戒三者。谓重心敬授护持不缺回向菩提。忍辱三者。谓柔和宽恕自护护他回向菩提。精进三者。谓不舍善轭无来去想回向菩提。禅定三者。谓遍入诸定无所攀缘回向菩提。般若三者。谓智光明彻。灭诸戏论回向菩提。如是名为菩萨六度一一三种能成满法。不放逸行之所生长

复次诸仁者。一切菩萨以不放逸故。速得成就三十七种菩提分等所有善法。证于诸佛无上菩提。云何速成菩提分法。谓诸菩萨以不放逸故。修四念处不经勤苦疾得圆满。云何修耶。谓观身处无所有。观察处无所有。观心处无所有。观法处无所有。于一切法皆无所得。如是名为修四念处。又诸菩萨以不放逸故。修四正勤疾得圆满。云何修习。谓诸菩萨。虽恒观察一切诸法本来无生无得无起无有作者。犹如虚空。而为未生诸恶不善法令不生故。摄心正住勤行精进。虽观一切法无业无果。而为诸众生已生诸恶不善法欲令断故。摄心正住勤行精进。虽信解一切法空无所有。而为未生诸善法欲令生故。摄心正住勤行精进虽知诸法本来寂静。而为已生诸善法欲令住故。不退失故更增长故。摄心正住勤行精进。是诸菩萨。虽恒观察一切诸法。无有所作无能作者。体相平等。是中无有少法可得若生若灭。而常精进修习不舍。是则名为修正勤耳。又诸菩萨以不放逸故。修四神足疾得圆满。云何修习谓诸菩萨虽永断欲贪。而恒不舍诸善法。欲若身若心常修善行。虽观诸法空无所得。而为化众生勤行精进。虽了知心识如幻如化。而恒不舍具诸佛法成正觉心。虽知诸法无依无作不可取着。而恒随所闻如理思惟。如是名为修习神足。又诸菩萨。以不放逸故。修习五根疾得圆满。云何修习。谓诸菩萨。虽依自力而有觉悟。不从他闻然教化众生。令其了知发生深信。虽无来想亦无去想。而勤遍修行一切智行。虽于境界无念无忆。而于其中不忘不愚。虽以智光开了诸法。而恒正定寂然不动。虽常安住平等法性。而断众翳障戏论分别。如是名为修习五根。又诸菩萨。以不放逸故。修习五力疾得圆满。云何修习。谓诸菩萨。修信力时。一切外论不能倾动。修精进力。一切恶魔无能沮坏。以修念力。不入声闻辟支佛地。修定力故。疾得远离五盖烦恼。以智慧力。永不取于诸见境界。是则名为修习五力。又诸菩萨。以不放逸故。修七觉分疾得圆满。云何修耶。谓诸菩萨。于一切善法恒不忘失。是修念觉分。于诸缘起常乐观察。是修择法觉分。行菩提道永不退转。是修精进觉分。知法而足无所希求。是修喜觉分。远离身心散动之失。是修猗觉分。入空无相无愿解脱是修定觉分。离于生起学习之心。是修舍觉分。是名为修七觉分法。又诸菩萨。以不放逸故。修八圣道疾得圆满。云何修习。谓永离于断常见故。名修习正见。离于欲觉恚觉害觉故。名修习正思惟。远离自他不平等故。名修习正语。离于谄伪不实相故。名修习正命。离于怯弱身心事故。名修习正业。离自矜足慢他心故。名修习正勤。离诸惛愚。名修习正念。息诸分别。名修习正定。是名修习八圣道分。诸仁者。我以如前所说之义。言诸菩萨住不放逸则得成就三十七种菩提分等一切善法。证于诸佛无上菩提。诸仁者。此不放逸菩萨。入于如是菩提分法已。则出一切生死淤泥。出生死已。于一切法。都无所见。无所见故无所言说。无所言说故则得入于毕竟寂静。云何名为毕竟寂静。以一切法非所作。非所作故不可取。不可取故无有用。无有用故不可安立。以之为有不可安立。以为有故。应知即是毕竟寂静。说是法时。会中有一万二千天子。远尘离垢法眼清净

尔时善胜天子。复白文殊师利菩萨言。大士云何名修行菩萨道。文殊师利菩萨言。天子。若菩萨虽不舍生死。而不为生死诸恶所染。虽不住无为。而恒修无为功德。虽具修行六波罗蜜。而示现声闻辟支佛行。是名修行菩萨道

复次天子。若菩萨虽于空清净。而善示诸境。亦不取于境。虽于无相清净。而善入诸相。亦不执于相。虽于无愿清净。而善行三界。亦不着于界。虽于无生无灭清净。而善说生灭。亦不受生灭。所以者何。此调伏心菩萨。虽了知一切法空无所有。然以诸众生于境界中而生见着。以见着故增长烦恼。菩萨欲令断诸见着。而为说法。令知一切境界是空。如说于空无相无愿。无生无灭皆亦如是。是名修行菩萨道。复次天子。有往有复。名修菩萨道。云何名为有往有复。观诸众生心所乐欲。名之为往。随其所应而为说法。名之为复。自入三昧名之为往。令诸众生得于三昧。名之为复。自行圣道名之为往。而能教化一切凡夫。名之为复。自得无生忍名之为往。令诸众生皆得此忍。名之为复。自以方便出于生死。名之为往。又令众生而得出离。名之为复。心乐寂静名之为往。常在生死教化众生。名之为复。自勤观察往复之行。名之为往。为诸众生说如斯法。名之为复。修空无相无愿解脱。名之为往。为令众生断于三种觉观心故而为说法。名之为复。坚发誓愿。名之为往。随其誓愿拯济众生。名之为复。发菩提心愿坐道场。名之为往。具修菩萨所行之行。名之为复。是名菩萨往复之道。说此法时。会中有菩萨五百人。皆得无生法忍

尔时善胜天子。白文殊师利菩萨言。大士。我曾闻有一切功德光明世界。如是世界在何方所。佛号何等。于中说法。文殊师利菩萨言。天子。于此上方过十二恒河沙佛土。有世界名一切功德光明。佛号普贤如来应正等觉。在此土中演说正法。善胜天子言。大士。我心欲见彼之世界及彼如来。惟愿仁慈示我令见。时文殊师利菩萨。即入三昧。此三昧名离垢光明。从其身中放种种光。其光上彻十二恒河沙佛土。至一切功德光明世界。种种色光遍满其国。彼诸菩萨见是光已得未曾有。合掌恭敬。白普贤如来言。世尊。今此光明从何所来。普贤佛言。善男子。于此下方。过十二恒河沙佛土。有世界名娑婆。佛号释迦牟尼如来应正等觉。今现在彼敷演法教。彼有菩萨名文殊师利。住不退转入离垢光明三昧。于其身中放种种光。其光远至十方无量阿僧祇世界。一一世界光悉充满。是故今者有此光明。彼诸菩萨复作是言。世尊。我等今者皆愿得见娑婆世界释迦牟尼佛。及文殊师利菩萨。尔时普贤如来。即于足下千辐相中放大光明。其光朗曜。过彼下方十二恒河沙佛土入此世界光悉周遍。彼诸菩萨以佛光明。莫不见此娑婆世界及释迦牟尼佛诸菩萨等。此土菩萨亦见彼国及普贤如来并菩萨众。尔时普贤如来。告诸菩萨言。娑婆世界恒说大法。汝等谁能往彼听受。众中有菩萨。名执智炬。从座而起。白言世尊。我今愿欲承佛神力往娑婆世界。惟愿如来垂哀见许。普贤如来言。善男子。今正是时当疾往诣。尔时执智炬菩萨。与诸菩萨十亿人俱。头顶敬礼普贤如来。合掌恭敬右绕七匝。于彼国没。譬如壮士屈伸臂顷。到娑婆世界兜率天宫。善住楼观中文殊师利菩萨众会之前。曲躬合掌。礼文殊师利菩萨足。而作是言。大士。汝所舒光至于我国。我世尊普贤如来应正等觉。垂许我等来此世界。为见大士礼事瞻仰听闻法故。尔时欲色界诸天子。见彼国土诸来菩萨已。咸作是言。善哉善哉。不可思议。甚为希有。甚为希有。文殊师利善权大士。乃有如是神通变化。以三昧力放是光明。而能至彼上方世界。令诸菩萨疾来诣。此时文殊师利菩萨。复为大众广宣妙法。众中有七十二那由他诸天子众。深生信解。发阿耨多罗三藐三菩提心

尔时文殊师利菩萨。于兜率天宫所为事毕。与诸菩萨释梵四天王等无量诸天。及一切功德光明国土诸来菩萨。不起于坐。于天宫没。一念之间到于佛所。皆从座起顶礼佛足。合掌恭敬右绕七匝。绕佛毕已。时执智炬菩萨。与其同类十亿人。前白佛言。世尊。普贤如来致问起居少病少恼安乐行不。于时世尊。如法慰问诸菩萨已。普观一切诸来大众。敕令复坐。广为说法莫不欢喜

尔时世尊。复告众言。汝等当知。此文殊师利童子。执智炬菩萨。为欲成熟无量众生。现此神通变化之事。此二丈夫。已能成就种种方便。获于深理智慧辩才。已于无量阿僧祇劫施作佛事。为众生故生于世间。若有众生得见此二菩萨者。应知则得六根自在。永不入于众魔境界。尔时执智炬菩萨。及所同来诸菩萨众。入此国土得见世尊。听闻法故证无生忍。既得忍已右绕于佛。敬礼双足。当尔之时。此三千大千世界为之震动。是诸菩萨即于佛前。没而不现。须臾之顷还到本国。尔时世尊。告长老阿难言。此法门汝当奉持。广为人说阿难言。唯世尊。此法门当何名之。云何奉持。佛言。此法门。名文殊师利所说不思议佛境界。如是奉持。佛说此经已。善胜天子长老阿难。及一切世间天人。阿修罗乾闼婆等。皆大欢喜。信受奉行

文殊师利所说不思议佛境界经卷下


须摩提经(按开元录云妙慧童女经流志后译)

    No. 336 [Nos. 310(30), 334, 335]

须摩提经(按开元录云妙慧童女经流志后译)

        大唐三藏法师菩提流支奉　诏译

如是我闻。一时佛在王舍城耆阇崛山中。与比丘众千二百五十人。菩萨摩诃萨十千人俱。时王舍城有长者女。名为妙慧。年始八岁。面貌端正容色姝好。诸相具足见者欢喜。曾于过去无量诸佛。亲近供养种诸善根。时彼女人诣如来所。顶礼佛足右绕三匝。长跪合掌。而说偈言

  无上等正觉　　为世大明灯
  菩萨之所行　　唯愿听我问

佛告妙慧。今恣汝问。当为解说令断疑网。尔时妙慧。即于佛前。以偈问曰

  云何得端正　　大富尊贵身
  复以何因缘　　眷属难沮坏
  云何见己身　　而受于化生
  千叶莲花上　　面奉诸世尊
  云何能证得　　自在胜神通
  遍往无量刹　　礼敬于诸佛
  云何得无怨　　所言人信受
  净除于法障　　永离诸魔业
  云何命终时　　得见于诸佛
  闻说清净法　　不受于苦恼
  大悲无上尊　　唯愿为我说

尔时佛告妙慧童女言。善哉善哉。善能问此深妙之义。谛听谛听善思念之。当为汝说。妙慧白言。唯然世尊。愿乐欲闻

佛言妙慧。菩萨成就四法。受端正身。何等为四。一者于恶友所不起嗔心。二者住于大慈。三者深乐正法。四者造佛形像。尔时世尊。而说偈言

  嗔坏善根勿增长　　慈心乐法造佛形
  当获具相庄严身　　一切众生常乐见

复次妙慧。菩萨成就四法。得富贵身。何等为四。一者应时行施。二者无轻慢心。三者欢喜而与。四者不希果报。尔时世尊。而说偈言

  应时行施无轻慢　　欢喜授与不希求
  能于此业常勤修　　所生当获大财位

复次妙慧。菩萨成就四法。得眷属不坏。何等为四。一者善能弃舍离间之语。二者邪见众生令住正见。三者正法将灭护令久住。四者教诸有情趣佛菩提。尔时世尊。而说偈言

  舍离间言及邪见　　正法将灭能护持
  安住众生大菩提　　当成不坏诸眷属

复次妙慧。菩萨成就四法。当于佛前得受化生处莲花座。何等为四。一者捧诸花果及细末香。散于如来及诸塔庙。二者终不于他妄加损害。三者造如来像安处莲华。四者于佛菩提深生净信。尔时世尊。而说偈言

  花香散佛及支提　　不害于他并造像
  于大菩提深信解　　得处莲花生佛前

复次妙慧。菩萨成就四法。从一佛土至一佛土。何等为四。一者见他修善不为障恼。二者他说法时未常留碍。三者然灯供养如来之塔。四者于诸禅定常勤修习。尔时世尊。而说偈言

  见人修善说正法　　不生谤毁加留难
  如来塔庙施灯明　　修习诸禅游佛刹

复次妙慧。菩萨成就四法。处世无怨。云何为四。一者以无谄心亲近善友。二者于他胜法无嫉妒心。三者他获名誉心常欢喜。四者于菩萨行无轻毁心。尔时世尊。而说偈言

  不以谀谄亲善友　　于人胜法无妒心
  他获名誉常欢喜　　不谤菩萨得无怨

复次妙慧。菩萨成就四法。所言人信。何等为四。一者发言修行常使相应。二者于善友所不覆诸恶。三者于所闻法不求过失。四者于说法者不生恶心。尔时世尊。而说偈言

  发言修行常相应　　己罪不藏于善友
  闻经不求人法过　　所言一切皆信受

复次妙慧。菩萨成就四法。能离法障速得清净。何等为四。一者以深意乐摄三律仪。二者闻甚深经不生诽谤。三者见新发意菩萨生一切智心。四者于诸有情大慈平等。尔时世尊。而说偈言

  以深意乐摄律仪　　闻甚深经能信解
  敬初发心如佛想　　慈心普洽障消除

复次妙慧。菩萨成就四法。能离诸魔。云何为四。一者了知法性平等。二者发起精进。三者常勤念佛。四者一切善根皆悉回向。尔时世尊。而说偈言

  能知诸法平等性　　常起精进念如来
  回向一切诸善根　　众魔不能得其便

复次妙慧。菩萨成就四法。临命终时诸佛现前。何等为四。一者他有所求施令满足。二者于诸善法深生信解。三者于诸菩萨施庄严具。四者于三宝所勤修供养。尔时世尊。而说偈言

  他有所求令满足　　信解深法舍严具
  三宝福田勤供养　　临命终时佛现前

尔时妙慧童女。闻佛说已。白言世尊。如佛所说菩萨诸行。我当奉行。世尊。若我于是四十行中。阙于一行而不修者。则违佛教欺诳如来

尔时尊者大目揵连。告妙慧言。菩萨之行甚难可行。汝今发斯殊胜大愿。岂于是愿得自在耶

尔时妙慧。白言尊者。若我弘愿真实不虚。能令诸行得圆满者。愿此三千大千世界六种震动

是时妙慧。重白目连。以我如是真实言故。于未来世当得成佛。亦如今日释迦如来。于我国中无有魔事。及以恶趣女人之名。若我此言非虚妄者。令斯大众身皆金色。说是语已众皆金色

尔时尊者大目揵连。即从坐起偏袒右肩顶礼佛足。白言世尊。我今先礼初发心菩萨。及诸菩萨摩诃萨众

尔时文殊师利法王子。告妙慧言。汝住何法发斯诚愿。妙慧答言。文殊师利非所问也。何以故。于法界中无所住故。又问。云何名为菩提。答曰。无分别法是名菩提。又问。云何名为菩萨。答曰。一切诸法等虚空相。是名菩萨。又问。云何名为菩提之行。答曰。犹如阳焰谷响之行。是菩提行

又问。依何密意作如是说。答曰。我于此中不见少法密非密者。又问。若如是者。一切凡夫应即菩提。答曰。汝谓菩提异凡夫耶。莫作是见。何以故。此等皆同一法界相非取非舍。无成坏故。又问。于此义中能解了者。其数几何。答曰。如若干幻化心心所量。若干幻化众生能了斯义。文殊师利言。幻化本无。何有如是心心所法。答曰。法界亦尔非有非无。乃至如来亦复如是。尔时文殊师利白佛言。世尊。今此妙慧甚为希有。乃能成就如是法忍。佛言。如是如是诚如所言。然此童女已于过去。发菩提心经三十劫。我乃发趣无上菩提。彼亦令汝住无生忍

尔时文殊师利。即从坐起为其作礼。白妙慧言。我于往昔无量劫前已曾供养。不谓今者还得亲近。妙慧告言。文殊师利。汝今莫起如是分别。何以故。以无分别得无生忍故。又问妙慧。汝今犹不转女身耶。妙慧答言。女人之相了不可得。今何所转

文殊师利。我当为汝除断疑惑。由我如是真实语故。于当来世。得阿耨多罗三藐三菩提时。于我法中。诸比丘辈闻命善来出家入道。我国土中所有众生身皆金色。服用资具如第六天。饮食丰饶随念而至。无有魔事及诸恶趣。亦复无有女人之名。有七宝林上罗宝网。七宝莲花覆以宝帐。如文殊师利所成净刹。装挍严饰等无有异

若我此言非虚妄者。令此大众身皆金色。我之女身变成男子。如三十岁知法比丘。说此语时。此诸大众皆作金色。妙慧菩萨转女成男。如三十岁知法比丘。是时地居天众。展转赞言。大哉大哉。妙慧菩萨摩诃萨。能于来世得菩提时。严持佛刹功德如是

尔时佛告文殊师利。此妙慧菩萨。于当来世成等正觉。号殊胜功德宝藏如来出现于世。佛说此经时。三十俱胝众生。于阿耨多罗三藐三菩提。住不退转。八十俱胝众生远尘离垢得法眼净。八千众生皆获智证。五千比丘行菩萨乘心欲退转。因见妙慧菩萨意乐善根威德殊胜故。各各脱身所著上服以施如来

如是施已。发弘誓言。我等以此善根。决定愿成阿耨多罗三藐三菩提。彼诸善男子等。以此善根回向无上菩提故。超九十劫生死之苦。不退转于阿耨多罗三藐三菩提

尔时世尊。即记之曰。汝等于当来世过千劫后。于无垢光明劫中阳焰世界难忍佛刹。于一劫中相次成佛。皆同一字。号辩才庄严如来。出现于世。文殊师利。如是法门有大威德。能令菩萨摩诃萨。及声闻乘者获大利益。文殊师利。或有善男子善女人。为求菩提无方便善巧。行六波罗蜜足满千劫。若复有人经于半月时。一书写读诵此经。所获福聚。比前功德百分千分百千俱胝。乃至算数譬喻所不能及

是故文殊师利。如是微妙法门。即诸菩萨契经之本。我今付嘱于汝。汝当来世受持读诵为人解说。譬如转轮圣王出现于世。所有七宝皆悉在前。王灭之后宝皆隐没。如是微妙法门流行于世。即诸如来七菩提分等法明不灭。若不流行正法常灭

是故文殊师利。若善男子善女人等。为求菩提。应当发起精进书写此经。受持读诵为人演说。此是我教。勿于后世生悔恨心。佛说此经已。妙慧菩萨。文殊师利菩萨。及诸大众。天人阿修罗乾闼婆等。闻佛所说皆大欢喜。信受奉行

须摩提经


郁迦罗越问菩萨行经

    No. 323 [Nos. 310(19), 322]

郁迦罗越问菩萨行经

        西晋月支国三藏竺法护译

    上士品第一

闻如是。一时佛游舍卫国祇树之园给孤独精舍。与大比丘众千二百五十人。慈氏菩萨。软首菩萨。除恶菩萨。光世音菩萨等五千人俱。尔时世尊。与无央数百千之众围绕说法。于是舍卫大城中有豪长者。名曰郁迦。与好喜长者。好叹长者。善施长者。有量长者。所乐长者。常名闻长者。施名闻长者。有名闻长者。善财长者。遵行长者。给孤独长者。宾祁长者。宠具足长者。审量长者俱。一一长者与五百眷属共出舍卫大城。往诣佛所稽首佛足。绕佛三匝却坐一面。皆志大乘殖众德本。悉有决于无上正真之道。于时郁迦见诸长者正士之会。承佛威神从坐起整衣服。叉手长跪白佛言。愿欲有所问。唯天中天。以善权方便哀为解说。佛告长者。所欲便问。吾当发遣令汝欢喜。郁迦白佛言。若有善男子善女人。发无上正真道意。问佛无数之慧。学于大乘。愿住大乘。劝助大乘。乘于大乘。解了大乘。请一切人等安一切。救护一切为大乘铠。其未度者我当度之。未脱者我当脱之。未安者我当安之。未般泥洹者我当令般泥洹。我当除一切人之重担。志愿无上之僧那见。无量生死诸恶瑕隙心不秽厌。无央数劫周旋尘劳其心不舍。若求菩萨道在家出家。欲具足佛法。善加哀于诸天人民。以此大乘将养一切。不断三宝之教。久住于一切之智。欲具足此慧。唯愿世尊。说居家菩萨戒德之法。谛行如来教。至不退转成无上正真道。今世后世所至之处与众卓异。及出家菩萨。弃捐爱欲笃信守道。剃除须发去为比丘乐受禁戒。行法行善行正。唯天中天。居家菩萨所住云何。其出家者所住云何。佛告郁迦。善哉善哉。长者乃能发意。广问如来如此之义。长者谛听善思念之。吾当为汝解说居家出家菩萨戒德精进所积之行。于是郁迦。受教而听。佛言长者。若有菩萨居家修道。当归命佛归命法归命僧。以自归之德。求于无上正真之道

长者居家菩萨。云何归命佛。我当具足佛三十二大人之相。诸所作为善本功德。积无央数愿常行精进。为三十二大人之相。如是名为归命于佛。云何为归命法。奉事法教。敬受于法。解法妙义。好法乐法。归法志法。导御法护持法住于寂法。鼓法僧住法行。在所行法。为法务说法界。法力为法住。行法施求法宝。我得无上正真之道最正觉时。当为诸天世间人民开度说法。是为归命法。云何归命于僧。居家菩萨。若见须陀洹。斯陀含。阿那含。阿罗汉。辟支佛。若弟子若凡人。皆当敬侍。瞻待如礼。卑顺逊言。不为狐疑。宗奉供养。承正行之众。每心念言。我得无上正真之道最正觉时。当为诸天人民一切成弟子众。当为说法有恭敬意不为轻慢。是为归命于僧

复次长者。居家菩萨。有四事法行归命佛。何等为四。一者志习佛道。二者以等心施意无偏邪。三者不断大悲。四者心不乐余乘。是为四居家菩萨为归命佛

复次长者。居家菩萨。有四法行归命法。何等为四。一者与正士法人相随相习。稽首敬从受其教敕。二者一心听法。三者如所闻法为人讲说。四者以是所施功德。愿求无上正真之道。是为四居家菩萨为归命法

复次长者。居家菩萨。有四法行归命僧。何等为四。一者已过声闻缘觉之乘意乐一切智。二者其有以饭食布施者以法教喻。三者以贤圣解脱导不退转众。四者不以弟子之业功德解脱为解脱也。是为四居家菩萨为归命僧

复次长者。居家菩萨。见如来心念求佛。为归命佛。闻说法心念法。为归命法。见如来贤圣之众意念佛道。为归命僧

复次长者。居家菩萨。欲具足愿布施。为归命佛。用护法布施为归命法。施已愿求一切智。为归命僧

复次长者。居家菩萨。为上士行。不为下士行。何谓上士。如法于财不以非法。以正法不邪。不务于邪。奉行直业。不娆他人。布施说法。念于财物为非常想。多为善事。孝养父母。常好布施。以等禀与门室亲属。知识交友。人客下使。教以上法。所为如法。弃捐诸担。及为一切却五阴担。常志精进。令诸担不起。令不学弟子缘觉之乘。开导诲授无厌足人。于身所安为念非常想。欲宁一切。若有利无利。若誉若谤。若有名若无名。若苦若乐。已过世间之所有法。心无憍慢。不着贫富。不着财利名誉苦乐。如世法行行于正法。审住正谛护于道家。救助净行正住佛道。却诸瑕秽。常有等心具足所愿。亦令他人具足其愿。不舍所行令人亦尔。所作究竟无有犹豫。常有反复所建辄善。见贫穷者矜济以财。恐惧者为无畏救。愁忧者慰除所患。羸劣者喻使忍辱。豪强者令无憍慢。贡高者令不自大。奉敬尊长咨启旧德。亲近博智请问方术以悟其疑。常为直见心无谄伪。等哀一切行无适莫无有害心。不别种性无所悕求。坚住一心好尚精进。与贤圣会思自修立。见非贤者为设大哀。住于慈悲。复慈于法等心。见无师法自放恣者。如所闻法为解开导闻已思义。于诸爱欲伎乐之乐。为非常想。不惜身命念如朝露想。计财如幻泡想。眷属为仇怨想。妇子男女为无黠地狱想。一切所受为苦想。舍宅产业常为远离想。所求索为善本想。家室为种想。亲属知识为地狱傍想。昼夜无异为等想。身无要当行要。命无要当住要。财无要当令要。何谓身要。能劳来于人。恭敬承顺。是为身要。若令善本不减。使功德常增。是为命要。于诸法无所受。不着财能布施。是为财要。长者。居家菩萨。以是比像而立家地。是为上士居家行也。不失如是无所著等正觉之戒。则为至诚。所为如法不转不退于无上正真道

    戒品第二

复次长者。居家菩萨当受五戒。一者不乐杀生。手不得持刀仗瓦石有所击害。不娆他人等心于一切。常有慈心行。二者不乐犯不与取。自于财物知足。不贪他人财。远离谀谄无黠之事。自知止足不着他有。草叶毛米不犯不与取。三者不乐邪淫。自于妻室觉知止足不犯外色。不当念淫计习淫劮致为甚苦。当护于自当作是观。自于妻起想便察恶露常惧欲尘。不当私心习着于欲。用是令人近地狱道。于身起想不为奇雅意不为安。当令立愿令我后不习淫欲。何况念欲与共合会。四者不乐妄语。所言至诚所说审谛。所行如语。不两舌不增减。无失说当行觉意。如所闻见说护于法。宁失身命终不妄语。五者不饮酒。不乐酒不尝酒。当安谛性。无卒暴无愚不定。心意当强。当安详念。施诸所有调御无义者。若施与人酒。当作是念。是为布施度无极时也随人所欲不断其侥。愿令我所作所施酒。受者令智慧。意志住施不乱。所以者何。菩萨为具足一切布施度无极

佛言长者。居家菩萨如是施与人酒。于法无有罪也。居家菩萨持是所戒功德。愿为无上正真之道。当善护是五戒为上精进。若有斗变解令和合。不当刚强语。当吉祥所言具足而不两舌。所说如义不为非法。所语辄善不失慈心。所言如语而不可动。断诸勤苦无伤害意。以忍辱之力。乘僧那涅之铠。当为正见远离邪见。其所施与无所适莫

    医品第三

复次长者。居家菩萨。所在郡国县邑居止。当以法护于郡国县邑。其无信者教令有信。无恭敬者教令恭敬。其无智者教令有智。其不孝父母不顾义理者。当教以法忠孝尊老。奉行精进志在修谨。其少智者教令博闻。贫穷者教以大施。无戒者教令持戒。恚怒者教令忍辱。懈怠者教令精进。放恣者令护一心。邪智者令住正智。病瘦者给与医药。无护者为作护。无所归者为受其归。无救者为作救乐。解导人一切如事为作法护。假令一人堕恶道者。居家菩萨。当为一反若二若三至于百反。教住善法及复住异种种善德。居家菩萨。当为一切建立大哀。坚住于一切智。被僧那之大铠。当作念言。我当度脱难解弊恶难开寤人。然后乃取无上正真之道。我心如是。不为直信。无谀谄人。又无伪慢。戒法完具。有德之人。被大僧那之铠。我用是闻法。不受行人故。被僧那之铠。愿令我常精进。使诸痴冥见我欢喜。菩萨所止处。当审谛无令妄横。假令一人有横堕恶道者。彼菩萨于如来无所著等正觉有大过矣。用是故居家菩萨在家修道。常当被是僧那之铠。愿言我当令所在郡国人民无有堕恶道者。譬如郡国县邑有良医。假使一人横死。其医于诸人有咎。菩萨亦如是。所在郡国县邑。居止不念救护诸人。若令一人有堕恶道者。其菩萨于如来无所著等正觉。为有咎也

    秽居品第四

复次长者。居家菩萨。当别知在家污秽之事。当作是念。何以故名为居家。断诸善根本。是名居家。不护尊品诸功德。是名居家。居诸不善尘垢。居诸不善之想。居诸不善之行。常与不调良无寂无法。令无一心。刚强恶人共会。是名居家。从是当为弊魔所得便。是名居家。居淫怒痴。居诸尘劳勤苦之法世俗杂事。常不得令善本具足。是名居家。住止此中所不当为而轻作之。慢不恭敬父母尊长众祐沙门梵志道士。是名居家。乐于爱欲不怀忧苦。愁泣诸不可意名居家。怀来牢狱嗔诤无和。变讼骂詈。是名居家。不能积善坏诸德本。所不当作者而妄为之。诸佛正士弟子所不叹也。是名居家。用住此中令人堕恶道。用住此中令人归淫怒痴之恐惧。是名居家。不得护戒品为舍定品。不得行慧品。不怀来解品。不起度知见品。是名居家。住此中者。着父母兄弟妻子亲里知识交友眷属朋党。恩爱之忧不知厌足。如众流归海。是故名居家。从是污染贪餮。起思想无志。居家多有贪想。诸恶愁忧无有绝极。居家恩爱会如美食杂毒。居家从本苦怨像如知识。居家多妨废贤圣之正教。居家常有斗讼。用众事因缘故。居家多贪求豪慕贵常为善恶事。居家为无常。不可久为败坏法。居家为勤苦。常有所求贪诸所有。居家为常有恶心。现刀仗如怨家。居家为无我所受。故令展转。居家为不净洁。自现清白。居家如画彩色。为但现好疾就磨灭。居家如幻所化。无有我而好往来聚会。居家譬如须曼华。适起随坏多所求故。居家为如朝露。日出则堕但有死忧。居家为如父母。乐少忧多。居家为如罗网。常忧色声香味细滑法。居家如铁觜鸟。但忧不善之想。居家为如毒蛇。忧说诸事。居家如火烧身。用意乱故。居家常畏怨敌。谓五贼冤家恶子故。居家为少安隐。不得度脱用无等故。如是长者。居家菩萨当别知在家为秽

    施品第五

复次长者。居家菩萨当布施持戒忍辱精进多为诸善。当作是念言。所施者为是我所。在家者为非我所。施与者为要。在家者为无要。施与者为后世安。在家者为后世苦。施与者为无畏备。在家者为忧守备。施与者无复护。在家者为警护。施与者为爱欲尽。在家者为爱欲增。施与者为无所受。在家者为有所受。施与者无复恐惧。在家者为有恐惧。施与者为成佛道。在家者为益魔官属。施与者为无尽。在家者为非常。施与者为守乐。在家者为守苦。施与者为断欲尘。在家者为增欲尘。施与者为大富。在家者为大贫。施与者为上士行。在家者为下士行。意无所念无所受。施与者诸佛所称誉。在家者为强项人所嗟叹。如是长者。居家菩萨所施与如此为要行。若见乞者当起三念。何等为三。一者以善知识想待。二者令得佛道想。三者令后世大富想。是为三。复有三念。何等为三。一者除悭贪嫉妒想。二者所有念布施想。三者不舍一切智想。是为三。复有三念。何等为三。一者所作安详为如来想。二者降伏魔想。三者不望报想。是为三。复有三念。一者见贫乞穷匮者。为开道化授想。二者行四恩不舍恩想。三者终始无有边幅受生死想。是为三。复有三念。一者离淫劮想。二者离嗔恚想。三者无愚痴想。是为三念。所以者何。长者。居家菩萨见乞丐者。淫怒痴即为薄。云何为薄。慈心布施无所爱惜。淫即为薄。若于乞人无恚恨意。嗔怒即为薄。若布施愿为一切智。愚痴即为薄。复次长者。居家菩萨。见乞丐者。六度无极即为具足。云何具足。若布施与人。不念受者有所取。是为布施度无极。心不忧佛道。是为持戒度无极。见乞丐者。不恚怒无害意。是为忍辱度无极。心不念若施人食然自饥乏。强割情与不违施心。是为精进度无极。若施乞者。每无厌足欢喜不悔心意喜悦。是为一心度无极。施于一切法无所著亦不想报。是为智慧度无极

复次长者。居家菩萨当远离世八法。不慕世之财利及妻子舍宅奴婢珍宝诸利。意无所著亦无欢喜亦无愁忧。一切所有无所贪慕。当行法念当作是观。父母妻子舍宅奴婢下使从是欲者。令我起苦乐因缘想。此非我类不。为用。愿常精进。用是等故。令益诸恶事。今现在世共会快乐之等。后世则为苦党。我当疾求其辈类。谓布施持戒智慧精进。无有放逸。怀来佛道。具足善本。此为是我之等类也。我所求索但求是愿耳。宁失身命不为妻子男女犯众恶也。长者。居家菩萨在家修道。见妇当有三念。何等为三。一者非常想。二者无所有想。三者无所受想。是为三。复有三念。何等为三。一者今诸欢乐之友非后世友。二者常精进奉行出入守意。是为等友。三者此为安隐等不为苦辈。是为三。复有三念。何等为三。一者不净洁想。二者瑕秽想。三者臭恶想。是为三。复有三。何等为三。一者罗刹想。二者反足却行安鬼神想。三者但有色想。是为三。复有三。何等为三。一者难饱足想。二者堕落想。三者无反复无止足想。是为三。复有三。何等为三。一者恶知识想。二者贪着想。三者妨废梵行清净想。是为三。复有三。何等为三。一者堕人于地狱想。二者堕人畜生想。三者令生饿鬼想。是为三。复有三。何等为三。一者恐惧想。二者有有想。三者受取想。是为三。复有三。何等为三。一者无我想。二者无受想。三者远离乱想。是为三

复次长者。居家菩萨所念当作是想。观其妻妇不当贪爱。于子若有重爱之心不重余人。当以三事自呵谏其意。何等为三。一者佛道为等意无偏邪意。二者佛道等行无偏邪行。三者佛道以一法行无若干行。当以是三事自谏意。若见于子计如仇怨不为善知识。所以者何。用是故令我离于佛种善知识。益当以好心念于如来。持诸所有爱子事。用起慈哀于一切人。以自爱身之德。用哀爱一切。当作是念言。一切是我子。我亦为一切作子。于是无有家室亲里往来周旋。所生处反更为怨家。愿令我所行所作。无有善知识亦无恶知识。所以者何。若有善知识。增益爱欲之想。若有恶知识。一切无复爱欲。我常欲自调其心令无所著。常行一切法入一切行。作邪行者堕邪事。为正行者得正事。以是故愿我莫有邪行。于一切作等心行。我所学愿。愿入一切智。如是长者。居家菩萨不着诸所有。亦无所受。亦无所贪。亦不染爱欲亦不起。亦不令无所起。居家菩萨若见乞丐者来。所施乞者当云何。心当作是念言。我持是物布施。会当得律行。除淫劮生死忧。入正我所持物布施。死时为善死。我用诸所布施故。临寿终时欢喜无悔恨心。若复心念。不能作惠施。见乞者当起四念。何等四。一者意为羸劣其功德少。二者是我之罪。于是大乘心不得自在兴立布施。三者适发意行所见用任我故。当忍辱施与于人。四者愿令我所作具足是愿。及一切人当晓喻乞者。长者。居家菩萨。若离世尊教。无有佛起。亦无有说法者。亦不见贤圣僧。便当遍念十方一切佛。是诸佛本行菩萨道时。皆行精进。然后得佛。具足一切佛法。念是一切佛已。当劝助如是。昼夜各三。净其身口意已。行等慈念诸善本远诸所有。当有惭愧。以诸功德本自庄饰。其心清净令人欢喜。信意乐于佛道无有乱。所作安谛恭敬断诸贡高憍慢。当讽诵三品法经。弃一切诸恶行。悔过以八十事。一心劝助诸福。具足相好。当转诸佛法轮。劝助诸佛转法轮。以无量行自受其国。寿不可计。长者。居家菩萨当行八关斋。持是斋戒功德。梵行清净沙门。行菩萨善本。与诸戒具道沙门梵志相随。恭敬奉事。不得见恶索其长短。若见犯戒比丘。当敬事袈裟。此为是世尊如来无所著等正觉袈裟。戒三昧智慧解脱见慧当为袈裟。作礼其袈裟已。离一切淫尘。是为诸贤圣神通之法。念是以后。益恭敬此比丘。当于是比丘起大哀。是恶行犯是戒。行非善戒。是佛法寂定调柔。有智入如来法门作沙门。不寂定无调柔。非贤者行为常勤苦。如来言。无戒不学者不当轻易。所以者何。非是其人过也。是淫尘之咎。用爱欲见不善本态。佛法有哀护。若能觉了是淫尘念空。便可得第一道意。可得作平等忍。所以者何。智慧能坏爱欲。世尊言。人不可轻妄。平相不可限。所以者何。欲平相人。则为平相如来。如来所知非我所究。如是于彼不当作恶心取其长短也

    礼塔品第六

复次长者。居家菩萨入佛寺精舍。当住门外至心作礼。然后当入精舍。当作是念言。是为空寺。无境界无有想有愿。为慈悲喜护居寺。为得平等所居。自念言。我何时当得如是居寺。出尘垢之居在是居。得十五日会说戒当新。当念起沙门意。无有菩萨在居家得最正觉者。皆出家入山。闲居岩处得佛道。所以者何。居家为垢居。出家者智者所称誉。及恒边沙等诸佛。我当一日为祠祀。布施一切所有。起意出家学道尔已。乃令我意欢喜耳。所以者何。无信人无反复人。盗贼屠魁罗邪吏民亦布施。薄不足言。我以戒智慧为上。慈心见恭敬。不惜身命。用一切故。我亦当奉行如来戒。令究竟得无上正真道最正觉。为一切作佛事。作如来未般泥洹者。令般泥洹。便当入精舍观诸比丘僧行。何所比丘为多智者谁为解法者。谁为持律者谁为。住法者。谁为持菩萨品者。谁为闲居行者。谁为分卫者。谁为服五衲衣者。谁为知止足者。谁为独行者。谁为坐禅者。谁为大乘者。谁为精进者。谁为典寺者。观一切比丘僧行已。皆当以等给足施与。不当有异心行。何况近聚落行者。近聚落者。亦当问讯。当往至于聚落。若有比丘无衣钵者。若病瘦无医药者。当给足当等心与。莫使有怨望意。所以者何。于世间皆有求安隐事。益当护凡夫之意。甚于阿罗汉。所以者何。凡夫事有怨望。阿罗汉无怨望故也。与多智比丘共相随。闻其所说当受学之。与解经者相随。闻其所解当受学之。与持律家相随者。解知罪垢当受学之。与持菩萨品家相随者。当受学六度无极善权方便行。与闲居行相随者。当受学知一心之行。若比丘有短乏者。当给与衣服钵器床卧具病瘦医药。于佛道中当遍等心用济。所以者何。便可以布施所惠故。劝助令起大道意。为沙门行善当如是。若沙门斗诤即当和解。若以法诤便当不惜身命为作法护。若比丘病困便当以身肉施与令差。其心不恨。一切德本以佛心为本。佛语长者。居家菩萨。以是比以是行以是瑞。应当在家修道

尔时郁迦长者。及诸迦罗越。皆同时举声言。甚难及天中天。如来善说居家之秽为诸魔行。出家之德名誉阐闻。唯世尊。我等亦眼见居家多有瑕垢。出家功德其行难量。我等愿从世尊受法。欲除须发得为比丘敬受大戒。佛告诸长者。出家甚难。常当专一守护禁法令无点缺。此诸长者。白佛言。世尊。出家有何为难。愿如来加哀听我等下须发受其戒敕我等能受奉慎教令。佛即听受令下须发。于是佛告弥勒菩萨诸行清净菩萨。持诸长者用付汝等下其须发是长者等则为上士。弥勒菩萨。应时为千二百长者剃除去须发。诸行清净菩萨。为千二百长者除去须发。佛说是居家菩萨戒德寂法品时。千二百人具足发无上正真道意。二千五百菩萨得音响忍。四千天及人得柔顺法忍

    止足品第七

是时郁迦长者。白佛言。如来无所著等正觉。以说居家地之善恶。于大乘所当行布施持戒忍辱精进一心智慧。愿世尊。复说出家下须发菩萨之行。持戒精进智慧止足之德。天中天出家菩萨。云何下须发奉行法律。何谓为出家。其心无有异。其行不移易。亦不求迎逆礼叉手。佛言。善哉善哉长者。乃问如来出家菩萨下须发具足之行。佛言。长者谛听善思念之。唯然世尊。郁迦长者受教而听。佛言。出家菩萨当作是念我何以故出家下须发。当更念言。我用欲具足佛法故出家下须发。常念精进于智慧无所著。如火在头忧救然炽。出家已便当行入。住于贤圣。如是知止足。知止足为名闻。于是分卫知止足。分卫知止足为名闻。于是于床卧知止足。于床卧知止足为名闻。于是于病瘦医药衣服知止足。于病瘦医药衣服知止足为名闻。长者。是谓贤圣之行。立是中致诸佛法。所谓为贤圣行也。佛告长者。出家菩萨有十事行着身衣被为知止足。何等为十。一者身着衣被常惭愧。二者身着袈裟护诸爱欲。无所著故。三者为沙门之服。令无所见令无所念。四者具袈裟之福为祐诸天世人。五者所以着袈裟心不以好乐欲。不习欲故。六者以善权意灭诸淫尘。七者知止足为善本。故受是衣。八者弃捐诸恶为善因缘。九者于贤圣道不转。于一心精进。十者愿令我一心着袈裟究竟。长者是为十事。出家菩萨着袈裟为止足之行

复有十事。当尽形寿行分卫。何等为十事。一者自有智德不待须人。二者若有人与我分卫。先当立于三乘。然后受其分卫。三者若人不与我分卫。吾于彼当起大哀。四者若人布施与于我。当精进食当有所成。五者不失如来教。六者发意顷使一心知止足。七者习行令无憍慢。八者从是功德致得无见顶上者。九者人见我亦当效我所学。十者一切男女小大布施与我。我当等心于一切专志致得一切智。长者是为十事行。出家菩萨不舍分卫。若有知识当令欢喜无有悔恨所至到处适无所慕何况着吾我亦无谀谄。在所饮处。于身有所益。亦能人所愿具足

佛言长者。我听使分卫。菩萨在草褥树下。若在冢间护戒有十事念。何等为十。一者已断诸我所有行。二者无我无所受。三者在闲居开户置床坐。四者远离爱欲诸着。五者少求无所著念诸德本。六者不惜身命但乐空闲。七者弃远诸会。八者所作罪皆消灭。九者一心三昧无瑕秽。十者念空出入守意。长者是为十事。出家菩萨在树下草褥坐。假使诣法会若师和上及问讯病者。到精舍适自身行。身心当俱往。若行受学讽诵经者。当解诸慧。于精舍房处。于闲居思惟。所以者何。在闲居者。当精进求法。一切所有非我想。一切法为他人想

佛言。出家菩萨习行医药有十事。何等为十。一者我当得如来世尊之智。二者不从他人取足。三者不复习瑕秽不净想。四者我当住清净。五者不复念诸欲味弃诸着。六者我当于凡夫有差特。七者诸善味当自然现我前。八者以医药断诸尘劳。九者断自诸见着。十者疾断诸病瘦得安隐。长者是为十事行。出家菩萨尽形寿当习医药

    闲居品第八

复次长者。出家菩萨在闲居行。当作是念言。我何故来在闲居。当复更念言。不但在闲居为沙门也。所以者何。彼闲居大有不调定不成就。无法则无义理者。谓獐鹿飞鸟之众蛊狐猕猴。野人摩睺勒射猎贼此不名为沙门。我所用来在闲居当具足此愿。谓沙门之义。长者何等为出家菩萨沙门义乎。谓意不乱得诸总持诸解诸慧具足所闻。于是得高明。习于大慈不舍大哀。得五神通。六度无极。其心自在不舍一切智。所说辄以善权之智。以法施一切。开道人民。不违四恩之行。念于六念。闻已即习。精进一心。奉法正解。一心得道慧不离寂定之处。护于正法及因缘罪福。以直见断一切念无念。以直念而愿说法。常行直言断诸罪。具足福行。以直治断诸所有着止。以直业至于佛道。行直方便。于诸法无意着止。以直意得一切智。行直定于空无恐怖。行无想于我无愿无所起为。至诚拥护于经义。不离法义亦无有人。长者是为菩萨出家沙门义也。彼出家菩萨不习众事。当作是念言。我当为一切人习德本。不独一人习善本。佛言长者。出家菩萨当习四事。如来所知。何等为四。一者习法会。二者习为他人说。三者习供养奉事如来。四者习不断佛乘意。是为四习。常解脱诸多习

若在闲居。当作念言。我何以故。来在闲居。当复更念言。我用恐惧故来至于此何等恐惧。畏聚会习淫怒痴。畏贡高怒慢害意于人。畏于贪嫉。畏于色声香味细滑之念。畏于身魔欲魔罪魔天魔。畏于非常为常想。畏于苦为乐想。畏无实为实想。畏无我有我想。畏有吾我。畏于狐疑不正思想犹豫淫劮。畏恶知识。畏于爱欲无黠。畏心意识不调良。畏诸盖覆蔽诸求。畏自见身。畏财利诸色。畏求处见。畏念无念他念。畏不见言见。不闻言闻。无意无识所言。畏沙门垢。畏种种行。畏于欲界色界无色界。畏于地狱畜生饿鬼。畏所生八难。畏所生五道。畏于卒念诸不善法。我所以来至此。不可以在家。于诸会愦闹中。一心为念空。以是恐惧解脱。怖畏诸过去。菩萨皆因恐畏解脱。蒙闲居力。得脱于恐惧。得佛道无畏。当来现在十方诸菩萨。皆以恐惧脱于怖畏。蒙闲居力。得佛道无畏。我以恐惧越一切畏住闲居。一切诸恐用受我故。住于吾着于我。污染于身爱。着我起于我。有我想有吾见。谓有身念于我。用护我身来至闲居。欲断我受用。护吾无因缘。当令我在闲居。得等义无畏。在闲居者无我想。在闲居者无他人想。在闲居者无得想。在闲居者无自见身迹也。在闲居者无有求住想。在闲居者无有泥洹想。何况当有淫尘想。所以名为闲居。于一切法无所住。哀护居三界者。一切畏想。无有习居想。于色声香味细滑无所居想。一切三昧无有诤乱居。调定其意寂定居。弃诸重担所居无惧。超越诸界已度使水。于诸有无所居。于贤圣行无念居。一心知止足居。在草褥居。深入慧居。精进一心居戒居。断诸缚着牢狱为解脱居。空无想无愿居。得三脱门调柔无所去居。意观十二因缘。所作已办居。入于寂定。譬如长者山泽有树草木野牛象马不恐不怖。如是长者。出家菩萨在闲居行视其身。如草木无毛发之想。见身如是。当精进行。不当起我想。便无恐惧。观其身空。是身无我无人无寿无命。从心有恐诸众庶人。用爱欲故当有畏惧。我以离念当为善想。譬如山泽中草木野牛不恐不怖。见一切法。皆他人许在空闲居当如是。所以者何。在闲居者断诸想。离淫嫉诸染污。在闲居者为如他无我无所受。出家菩萨。在闲居行当作是学。在闲居者当柔软守护戒品。在闲居者和顺定品。在闲居者怀来智慧品。在闲居者怀来解脱品。在闲居者住于度知见品。在闲居者爱护佛法品。在闲居者断十二使。在闲居者念正愿。在闲居者于诸法品为等。在闲居者不作疆界。在闲居者已脱诸入。在闲居者心不畏佛道。在闲居者。于空无所观取。在闲居者于法无所怀。在闲居者本有善德名闻。在闲居者佛所称誉。诸贤圣亦习闲居。在闲居者脱于爱欲。为有差特。入于一切智

复次长者。在闲居菩萨。以少少事故。具足六度无极。所以者何。在闲居行不惜身命。是为布施度无极。知止足寂定住起于三专。是为戒度无极。无害心慈遍于一切。忍于一切智。不堕余道。是为忍辱度无极。念言终不舍此空闲。得忍已乃舍。是为精进度无极。得于禅不着我。起诸德本。是为一心度无极。如心所念身行如是。于道亦然无所念。是为智慧度无极

长者。在闲居菩萨有四事法。何等为四。一者菩萨于是得多智。二者巧能分别决诸法律。三者了诸德本。四者以是博智知。一心精进住于空闲。是为四。复次长者。菩萨若多淫尘。不习于尘。尔乃住闲居。不着于尘不受于欲。如所闻法则能奉行

复次长者。菩萨得五神通。为诸天龙鬼神揵沓和说法。在闲居当如是

复次长者。菩萨当学佛法智。然后乃在空闲。用是故。得具足一切诸善本。然后持是德本。入诸郡国县邑。以义度人民。菩萨若欲讽诵经道故来下。审恭敬奉事师和上。长幼中年。稽首为礼。不当懈怠。于事当精进。不当不恭敬奉事。当作是念言。如来无所著等正觉。为诸天龙鬼神揵沓和所奉事。阿须伦迦留罗真陀罗摩睺勒所奉事。为诸释梵四王人非人所恭敬。于世为最尊。令一切安隐。佛不自为身求供养。人自来供养。何况我等。未有所知方欲学耳。反欲从他人求供养。我当奉事一切人。所以者何。比丘贪求供养减其法德。所以者何。为他人以法施。心当念言。以供养故。来奉事我。不以法故。以自有信心。来供养想施。其福不大。往至师和上所。身意当俱行。身意当解了住。若念我师和上行至他处。心不乐悔。于讽诵学经智者。当为师和上。不惜身命。当乐法故。便当随师和上行。用法故利。当舍一切财利之色。于师和上。欢喜闻一四句偈。若讽诵若布施行事。持戒忍辱精进一心事。若智慧事。若慈悲喜护事。一心起习佛道事。闻四句偈若讽诵。当供养师和上。在所从受字句义。所受讽诵。当以直心无有谀谄。用一切万物供养。尚未报师恩。何况以法供养。长者。若意闻所传说。若善音。佛法音。寂灭音。如教音。闻说如来音。当供事师一劫。尚未具足报师恩。佛言长者。以是故说法之福无有量。其智慧不可限。住于尊法亦无数。其有菩萨欲供养无量法。当供养出家菩萨。何等为出家之学。如其所闻法便行。当审谛清净其戒品

佛言长者。出家菩萨有四事法戒品清净。何等为四。一者住于贤圣之教。二者分卫以德乐知止足。三者出家菩萨不乐于家。四者不习戒亦无谄伪在闲居。是为四。复有四。何等为四。一者身所行至诚。身亦无所得。二者口所言至诚。口亦无所得。三者意所念柔软。意亦无所得。四者远离诸所见。住于一切智。是为四事。复有四。何等为四。一者弃我事。二者远吾事。三者断自在。四者舍因缘法。是为四。复有四。何等为四。一者我身与法一也。二者诸种与法种等。三者诸入为与空聚等。四者得智慧行适无所居。是为四。复有四。何等为四。一者身所知身自作。二者不为人所动。三者不入人罪法。灭于诸念。四者奉一切法。审谛无有异。是为四。复有四。何等为四。一者以脱于空。二者无想无恐惧。三者为一切大哀。四者得无我忍。是为四。彼若闻清净三昧。当作是念言。何等为清净三昧。奉一切法。意舍欲及我所。其心为一。其心无所流。心无所轻。戏以缚缚意。心无所著心不可见。心于内现。意之境界无有习会。意于我法为何等念。等于法界无有生无有行。内外无所著正受。是谓为三昧。是谓住法三昧。彼若闻审谛智慧清净。便当作是念言。何等为智慧。谓解于法句分别智慧为慧。入于解黠为慧。知他人心之所念解法为慧。于法正受。彼于智无智。于相无身为空。相无有持亦无有舍。相无有处无央数相所念为空

佛言长者。观法当如是。是为出家菩萨行。佛说是经时。八千人发大道意。此诸长者出家下须发者。皆得不起法忍。三万二千天及人远尘离垢。于诸法中得法眼净。二百比丘得无起余漏尽意解。郁迦长者欢喜踊跃。以殊异衣其价百千。用上如来说是言。我持是善本功德。施于一切菩萨。令是功德归流诸居家菩萨。皆令具足此法如如来。令出家菩萨得戒智慧具足此法。愿令出家菩萨得戒智慧犹如如来。唯然世尊。云何居家菩萨。在所居住。学具足出家戒法。佛告长者。居家菩萨。布施一切无所爱惜。其心常志大乘不望其报

复次长者。居家菩萨。当净修梵行。心不念习淫欲。何况受

复次长者。居家菩萨。解空事入四禅以善权行求无恃者令志寂灭

复次长者。居家菩萨。当大精进解智慧度无极。于一切仗大慈受一切法。当拥护以法教化人。是为四事行居家菩萨在家立出家戒法。尔时郁迦长者白佛言。世尊。我独立居家地。当住于如来教戒。我当为如来广达佛道。亦当学是出家之法。当复奉行是法禁。时佛便笑。诸佛世尊之法。笑时有无数色种种色不可思议色。从口中照无量佛国。上至梵天还绕佛身。于顶上[火*霍]然不现。贤者阿难。从坐起白佛言。佛不妄笑。愿闻其意。佛告阿难。汝见郁迦长者用法故供养于如来复作师子吼不。阿难。唯然世尊。我今已见。佛言阿难。是郁迦长者。住于居家地。于是贤劫诸有如来。皆当供养受其法教。居在家居。具足出家戒法。是时为诸如来普宣佛道。于是阿难问郁迦长者。用是居家为乐。居家为垢。居家不如出家受圣贤教法。郁迦答曰。阿难且止。勿作是语云。诸贤圣亦无垢染。有大哀解脱。不念自安。诸菩萨忍诸苦。不舍一切人。佛言阿难。是郁迦长者。虽住居家地常有等心。于是贤劫所度人民甚多。胜余出家菩萨百千人教授。所以者何。阿难。虽有出家菩萨百千人。其德之智不及郁迦长者。阿难白佛言。是名为何等经。云何持名。佛言阿难。是经一名郁迦长者所问。汝当受持。二名居家出家品。三名持一心宴坐其德名闻。佛言阿难。若有菩萨闻是经。为具足诸法。胜于百劫修梵清净懈废之行。是故阿难。欲作大精进者。及欲教他人精进者。自欲住于一切法德者。及欲立一切于法德者。当闻是经。当受持讽诵。所以者何。欲具足一切法。当视是经法与如来等。阿难。其有菩萨远离是经者。则为远离一切诸佛。不得复见一切诸佛。所以者何。其有说是经者。则为面见一切诸佛。阿难。政使是三千大千世界满其中火。菩萨便当入过其中。求闻是法受持讽诵。当以诸宝满三千大千世界。用供养师。受是经法持讽诵读。阿难。若有菩萨。供养过去当来今现在诸佛世尊。尽其形寿。供养尔所佛已。不受是经法不能讽诵。亦不于中作诸功德。为不供养去来今佛。阿难。若复有人闻是经典。受持讽诵广为人说。于中作诸功德。为已供养去来今佛。所以者何。诸如来无所著等正觉。以法为上。为从法生。佛说如是。贤者阿难。及郁迦长者诸天阿须伦世间人民。闻经欢喜。皆前为佛作礼而去

郁迦罗越问菩萨行经


般泥洹后灌腊经

    No. 391

般泥洹后灌腊经

        西晋月氏国三藏竺法护译

闻如是。一时佛在舍卫国祇树给孤独园。与摩诃比丘僧诸天人民共。会坐说经。阿难前长跪叉手白佛言。天中之天。欲有所问。愿佛说之。若佛般泥洹后。四辈弟子比丘比丘尼优婆塞优婆夷。四月八日七月十五日。灌腊当何所用。佛语阿难。灌腊佛者。是福愿人之度者。各自减钱宝。割取珍爱用求度世之福。当给寺然灯烧香用作经像。若供养师。施与贫穷。可设斋会。不可贳许。然后不出。此为现世负佛。自是心口所作当得妄语之罪。所以者何。为佛投槃作礼。以五种香水手自浴佛师。哒嚫咒愿。当此之时天龙鬼神皆明证知。此人出五家财物。侵妻子分用求福利。而反不出。当有五罪入三恶道。何等为五。一者财物日减。二者喜忘遗。三者治生所向无利。四者入太山地狱中被考治苦痛难言。五者后世来生。或作奴婢牛马骡驴骆驼。或作猪羊。是为五。更罪三恶。一者为入薜荔中作饿鬼。二者入禽兽作畜生。三者泥犁中当更十八地狱。罪不可数。七月十五日。自向七世父母五种亲属。有堕恶道勤苦剧者。因佛作礼福。欲令解脱忧苦。名为灌腊。佛者天上天下三界之王。不食世间人民也。其物皆众僧分之不应独取。是为大罪。若无僧可分。施贫穷孤独羸老。是种善根。诸弟子闻经欢喜。为佛作礼而去

般泥洹后灌腊经


大般涅槃经

    No. 375 [No. 374]

大般涅槃经卷第一

        宋代沙门慧严等依泥洹经加之

    序品第一

如是我闻。一时佛在拘尸城力士生地阿夷罗跋提河边娑罗双树间。尔时世尊与大比丘八十亿百千人俱前后围绕。二月十五日临涅槃时。以佛神力出大音声。其声遍满乃至有顶。随其类音普告众生。今日如来应供正遍知。怜愍众生覆护众生。等视众生。如罗睺罗。为作归依为世间舍。大觉世尊将欲涅槃。一切众生若有所疑今悉可问为最后问。尔时世尊于晨朝时。从其面门放种种光。其明杂色青黄赤白颇梨马瑙。光遍照此三千大千佛之世界。乃至十方亦复如是。其中所有六趣众生遇斯光者罪垢烦恼一切消除。是诸众生见闻是已。心大忧恼同时举声悲号啼哭。呜呼慈父痛哉苦哉。举手拍头槌胸大叫。其中或有身体战栗涕泣哽咽。尔时大地诸山大海皆悉震动。时诸众生共相谓言。且各裁抑莫大愁苦。当共疾往诣拘尸城力士生处。至如来所头面礼敬。劝请如来莫般涅槃。住世一劫若减一劫。互相执手复作是言。世间虚空众生福尽。不善诸业增长出世。仁等今当速往速往。如来不久必入涅槃。复作是言。世间虚空世间虚空。我等从今无有救护。无所宗仰贫穷孤露。一旦远离无上世尊。设有疑惑当复问谁

时有无量诸大弟子。尊者摩诃迦旃延。尊者薄俱罗。尊者优波难陀。如是等诸大比丘遇佛光者。其身战掉乃至大动不能自持。心浊迷闷发声大叫。生如是等种种苦恼。尔时复有八十百千诸比丘等。皆阿罗汉。心得自在所作已办。离诸烦恼调伏诸根。如大龙王有大威德。成就空慧逮得己利。如旃檀林旃檀围绕。如师子王师子围绕。成就如是无量功德。一切皆是佛之真子。各于晨朝日初出时。离常住处方用杨枝。遇佛光明更相谓言。仁等宜速澡漱清净。作是言已。举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。为欲利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面

尔时复有拘陀罗女。善贤比丘尼。优波难陀比丘尼。海意比丘尼。与六十亿比丘尼等。一切亦是大阿罗汉。诸漏已尽心得自在。所作已办离诸烦恼。调伏诸根犹如大龙。有大威德成就空慧。亦于晨朝日初出时。举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。亦欲利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面。于比丘尼众中复有诸比丘尼。皆是菩萨人中之龙。位阶十地安住不动。为化众生现受女身。而常修集四无量心。得自在力能化作佛

尔时复有一恒河沙菩萨摩诃萨。人中之龙位阶十地。安住不动方便现身。其名曰海德菩萨。无尽意菩萨。如是等菩萨摩诃萨而为上首。其心皆悉敬重大乘。安住大乘深解大乘。爱乐大乘守护大乘。善能随顺一切世间。作是誓言。诸未度者当令得度。已于过世无数劫中。修持净戒善持所行解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。成就如是无量功德。等观众生如视一子。亦于晨朝日初出时。遇佛光明举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。亦为利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面

尔时复有二恒河沙诸优婆塞。受持五戒威仪具足。其名曰威德无垢称王优婆塞。善德优婆塞等。而为上首。深乐观察诸对治门。所谓苦乐。常无常。净不净。我无我。实不实。归依非归依。众生非众生。恒非恒。安非安。为无为。断不断。涅槃非涅槃。增上非增上。常乐观察如是等法对治之门。亦欲乐闻无上大乘。如所闻已能为他说。善持净戒渴仰大乘。既自充足复能充足余渴仰者。善能摄取无上智慧。爱乐大乘守护大乘。善能随顺一切世间。度未度者。解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。心常深味清净戒行。悉能成就如是功德。于诸众生生大悲心。平等无二如视一子。亦于晨朝日初出时。为欲阇毗如来身故。人人各取香木万束。栴檀沉水牛头栴檀天木香等。是一一木文理及附。皆有七宝微妙光明。譬如种种杂彩画饰。以佛力故有是妙色青黄赤白。为诸众生之所乐见。诸木皆以种种香涂。郁金沉水及胶香等。散以诸花而为庄严。优钵罗花拘物头花波头摩花分陀利花。诸香木上悬五色幡。柔软微妙犹如天衣憍奢耶衣刍摩缯彩。是诸香木载以宝车。是诸宝车出种种光青黄赤白。辕辐皆以七宝厕填。是一一车驾以四马。是一一马骏疾如风。一一车前竖立五十七宝妙幢。真金罗网弥覆其上。一一宝车复有五十微妙宝盖。一一车上垂诸花鬘。优钵罗花拘物头花波头摩花分陀利花。其花纯以真金为叶金刚为台。是花台中多有黑蜂。游集其中欢娱受乐。又出妙音。所谓无常苦空无我。是音声中复说菩萨本所行道。复有种种歌舞伎乐筝笛箜篌箫瑟鼓吹。是乐音中复出是言。苦哉苦哉世间虚空。一一车前有优婆塞擎四宝案。是诸案上有种种花。优钵罗花拘物头花波头摩花分陀利花。郁金诸香及余薰香微妙第一。诸优婆塞为佛及僧。办诸食具种种备足。皆是栴檀沉水香薪。八功德水之所成熟。其食甘美有六种味。一苦二醋三甘四辛五碱六淡。复有三德。一者轻软。二者净洁。三者如法。作如是等种种庄严。至力士生处娑罗双树间。复以金沙遍布其地。以迦陵伽衣钦婆罗衣及缯彩衣而覆沙上。周匝遍满十二由旬。为佛及僧敷置七宝师子之座。其座高大如须弥山。是诸座上皆有宝帐垂诸璎珞。诸娑罗树悉悬种种微妙幡盖。种种好香用以涂树。种种名花以散树间。诸优婆塞各作是念。一切众生若有所乏。饮食衣服头目。支体。随其所须皆悉给与。作是施时离欲嗔恚秽浊毒心。无余思愿求世福乐。唯志无上清净菩提。是优婆塞等皆已安住于菩萨道。复作是念。如来今者受我食已当入涅槃。作是念已。身毛皆竖遍体血现如波罗奢花。涕泣盈目生大苦恼。各各赍持供养之具载以宝车。香木幢幡宝盖饮食。疾至佛所稽首佛足。以其所持供养之具欲供养如来。绕百千匝。举声号泣哀动天地槌胸大叫泪下如雨。复相谓言。苦哉仁者。世间虚空世间虚空。便自举身投如来前。而白佛言。唯愿如来。哀受我等最后供养。世尊。知时默然不受。如是三请悉皆不许。诸优婆塞不果所愿。心怀悲恼默然而住。犹如慈父唯有一子卒病命终殡送还归极大忧恼。诸优婆塞悲泣懊恼亦复如是。以诸供具安置一处。却住一面默然而坐

尔时复有三恒河沙诸优婆夷。受持五戒威仪具足。其名曰寿德优婆夷。德鬘优婆夷。毗舍佉优婆夷等。八万四千而为上首。悉能堪任护持正法。为度无量百千众生。故现女身呵责家法。自观己身如四毒蛇。是身常为无量诸虫之所唼食。是身臭秽贪欲狱缚。是身可恶犹如死狗。是身不净九孔常流。是身如城血肉筋骨皮裹其上。手足以为却敌楼橹。目为窍孔。头为殿堂。心王处中。如是身城诸佛世尊之所弃舍。凡夫愚人常所味着。贪淫嗔恚愚痴罗刹止住其中。是身不坚。犹如芦苇伊兰水沫芭蕉之树。是身无常念念不住。犹如电光暴水幻炎。亦如画水随画随合。是身易坏。犹如河岸临峻大树。是身不久当为狐狼鸱枭雕鹫乌鹊饿狗之所食啖。谁有智者当乐此身。宁以牛迹盛大海水。不能具说是身无常不净臭秽。宁丸大地使如枣等。渐渐转小犹葶苈子乃至微尘。不能具说是身过患。是故当舍如弃涕唾。以是因缘诸优婆夷。以空无相无愿之法常修其心。深乐咨受大乘经典。闻已亦能为他演说。护持本愿毁呰女身。甚可患厌性不坚牢。心常修集如是正观。破坏生死无际轮转。渴仰大乘既自充足。复能充足余渴仰者。深乐大乘守护大乘。虽现女身实是菩萨。善能随顺一切世间。度未度者。解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。坚持禁戒。皆悉成就如是功德。于诸众生生大悲心。平等无二如视一子。亦于晨朝日初出时。各相谓言。今日宜应至双树间。诸优婆夷所设供具倍胜于前。持至佛所稽首佛足。绕百千匝。而白佛言。世尊。我等今者为佛及僧办诸供具。唯愿如来哀受我供。如来默然而不许可。诸优婆夷不果所愿。心怀惆怅却坐一面

尔时复有四恒河沙毗舍离城诸离车等男女大小妻子眷属。及阎浮提诸王眷属。为求法故。善修戒行威仪具足。摧伏异学坏正法者。常相谓言。我等当以金银仓库。为令甘露无尽正法深奥之藏久住于世。愿令我等常得修学。若有诽谤佛正法者。当断其舌。复作是愿。若有出家毁禁戒者。我当罢令还俗策使。有能深乐护持正法。我当敬重如事父母。若有众僧能修正法。我当随喜令得势力。常欲乐闻大乘经典。闻已亦能为人广说。皆悉成就如是功德。其名曰净无垢藏离车子。净不放逸离车子。恒水无垢净德离车子。如是等各相谓言。仁等今可速往佛所。所办供养种种具足。一一离车各严八万四千大象八万四千驷马宝车。八万四千明月宝珠。天木栴檀沉水薪束。种种各有八万四千。一一象前有宝幢幡盖。其盖小者周匝纵广满一由旬。幡最短者长三十三由旬。宝幢卑者高百由旬。持如是等供养之具。往至佛所稽首佛足。绕百千匝。而白佛言。世尊。我等今者为佛及僧办诸供具。唯愿如来哀受我供。如来默然而不许可。诸离车等不果所愿心怀愁恼。以佛神力去地七多罗树。于虚空中默然而住。尔时复有五恒河沙大臣长者。敬重大乘。若有异学谤正法者。是诸人等力能摧伏。犹如雹雨摧折草木。其名曰日光长者。护世长者。护法长者。如是之等而为上首。所设供具五倍于前。俱共持往诣双树间。稽首佛足绕百千匝。而白佛言。世尊。我等今者为佛及僧设诸供具。唯愿哀愍受我等供。如来默然而不受之。诸长者等不果所愿心怀愁恼。以佛神力去地七多罗树。于虚空中默然而住

尔时复有毗舍离王及其后宫夫人眷属。阎浮提内所有诸王。除阿阇世并及城邑聚落人民。其名曰月无垢王等。各严四兵欲往佛所。是一一王各有一百八十万亿人民眷属。是诸车兵驾以象马。象有六牙马疾如风。庄严供具六倍于前。宝盖之中有极小者。周匝纵广满八由旬。幡极短者十六由旬。宝幢下者三十六由旬。是诸王等安住正法恶贱邪法。敬重大乘深乐大乘。怜愍众生等如一子。所持饮食香气流布满四由旬。亦于晨朝日初出时。持是种种上妙甘膳。诣双树间至如来所。而白佛言。世尊。我等为佛及比丘僧设是供具。唯愿如来。哀愍受我最后供养。如来知时亦不许可。是诸王等不果所愿。心怀愁恼却住一面

尔时复有七恒河沙诸王夫人。唯除阿阇世王夫人。为度众生现受女身。常观身行。以空无相无愿之法薰修其心。其名曰三界妙夫人。爱德夫人。如是等诸王夫人。皆悉安住于正法中。修行禁戒威仪具足。怜愍众生等如一子。各相谓言。今宜速往诣世尊所。诸王夫人所设供养七倍于前。香花宝幢缯彩幡盖上妙饮食。宝盖小者周匝纵广十六由旬。幡最短者三十六由旬。宝幢卑者六十八由旬。饮食香气周遍流布满八由旬。持如是等供养之具。往如来所稽首佛足。绕百千匝。而白佛言。世尊。我等为佛及比丘僧设是供具。唯愿如来。哀愍受我最后供养。如来知时默然不受。时诸夫人不果所愿心怀愁恼。自拔头发捶胸大哭。犹如慈母新丧爱子。却住一面默然而坐

尔时复有八恒河沙诸天女等。其名曰广目天女。而为上首。作如是言。汝等诸姊。谛观谛观。是诸人众所设种种上妙供具。欲供如来及比丘僧。我等亦当如是严设微妙供具供养如来。如来受已当入涅槃。诸姊。诸佛如来出世甚难。最后供养亦复倍难。若佛涅槃世间虚空。是诸天女爱乐大乘欲闻大乘。闻已亦能为人广说。渴仰大乘既自充足。复能充足余渴仰者。守护大乘。若有异学憎嫉大乘。势能摧灭如雹摧草。护持戒行威仪具足。善能随顺一切世间。度未度者。脱未脱者。于未来世当转法轮。绍三宝种使不断绝。修学大乘。以大庄严而自庄严。成就如是无量功德。等慈众生如视一子。亦于晨朝日初出时。各取种种天木香等。倍于人间所有香木。其木香气能灭人中种种臭秽。白车白盖驾四白马。一一车上皆张白帐。其帐四边悬诸金铃。种种香花宝幢幡盖。上妙甘膳种种伎乐。敷师子座。其座四足纯绀琉璃。于其座后各各皆有七宝倚床。一一座前复有金机。复以七宝而为灯树。种种宝珠以为灯明。微妙天花遍布其地。是诸天女设是供已。心怀哀感涕泪交流生大苦恼。亦为利益安乐众生。成就大乘第一空行。显发如来方便密教。亦为不断种种说法。往诣佛所稽首佛足。绕百千匝。而白佛言。世尊。唯愿如来。哀受我等最后供养。如来知时默然不受。诸天女等不果所愿心怀忧恼。却在一面默然而坐

尔时复有九恒河沙诸龙王等住于四方。其名曰和修吉龙王。难陀龙王。婆难陀龙王。而为上首。是诸龙王亦于晨朝日初出时。设诸供具倍于人天。持至佛所稽首佛足。绕百千匝。而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不受。是诸龙王不果所愿。心怀愁恼却坐一面

尔时复有十恒河沙诸鬼神王。毗沙门王而为上首。各相谓言。仁等今者可速诣佛所。所设供具倍于诸龙。持往佛所稽首佛足。绕百千匝。而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不许。是诸鬼王不果所愿。心怀愁恼却坐一面

尔时复有二十恒河沙金翅鸟王。降怨鸟王而为上首。复有三十恒河沙乾闼婆王。那罗达王而为上首。复有四十恒河沙紧那罗王。善见王而为上首。复有五十恒河沙摩睺罗伽王。大善见王而为上首。复有六十恒河沙阿修罗王。睒婆利王而为上首。复有七十恒河沙陀那婆王。无垢河水王。跋提达多王等。而为上首。复有八十恒河沙罗刹王。可畏王而为上首。舍离恶心更不食人。于怨憎中生慈悲心。其形丑陋以佛神力皆悉端正。复有九十恒河沙树林神王。乐香王而为上首。复有千恒河沙持咒王。大幻持咒王而为上首。复有一亿恒河沙贪色鬼魅。善见王而为上首。复有百亿恒河沙天诸婇女。蓝婆女。郁婆尸女。帝路沾女。毗舍佉女。而为上首。复有千亿恒河沙等诸鬼王。白湿王而为上首。复有十万亿恒河沙等诸天子及诸天王四天王等。复有十万亿恒河沙等四方风神。吹诸树上时非时花散双树间。复有十万亿恒河沙主云雨神。皆作是念。如来涅槃焚身之时。我当注雨令火时灭。众中热闷为作清凉。复有二十恒河沙大香象王。罗睺象王。金色象王。甘味象王。绀睺象王。欲香象王等。而为上首。敬重大乘爱乐大乘。知佛不久当般涅槃。各各拔取无量无边诸妙莲花。来至佛所头面礼佛却住一面。复有二十恒河沙等师子兽王。师子吼王而为上首。施与一切众生无畏。持诸花果来至佛所。稽首佛足却住一面。复有二十恒河沙等诸飞鸟王。凫雁鸳鸯孔雀诸鸟乾闼婆鸟。迦兰陀鸟。鸲鹆鹦鹉。俱翅罗鸟。婆嘻伽鸟。迦陵频伽鸟。耆婆耆婆鸟。如是等诸鸟持诸花果来至佛所。稽首佛足却住一面。复有二十恒河沙等水牛牛羊。往至佛所出妙香乳。其乳流满拘尸那城。所有沟坑色香美味悉皆具足。成是事已却住一面。复有二十恒河沙等四天下中诸神仙人。忍辱仙等而为上首。持诸香花及诸甘果。来诣佛所稽首佛足。绕佛三匝。而白佛言。唯愿世尊。哀受我等最后供养。如来知时默然不许。时诸仙人不果所愿。心怀愁恼却住一面。阎浮提中一切蜂王。妙音蜂王而为上首。持种种花来诣佛所稽首佛足。绕佛一匝却住一面

尔时阎浮提中比丘比丘尼一切皆集。唯除尊者摩诃迦叶阿难二众。复有无量阿僧祇恒河沙等世界中间及阎浮提所有诸山。须弥山王而为上首。其山庄严丛林蓊郁。枝叶茂盛荫蔽日光。种种妙花周遍严饰。龙泉流水清净香洁。诸天龙神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。神仙咒术作倡伎乐。如是等众弥满其中。是诸山神亦来诣佛。稽首佛足却住一面。复有阿僧祇恒河沙等四大海神及诸河神。有大威德具大神足。所设供养倍胜于前。诸神身光伎乐灯明。悉蔽日月令不复现。以占婆花散熙连河。来至佛所稽首佛足却住一面

尔时拘尸那城娑罗树林。其林变白犹如白鹤。于虚空中自然而有七宝堂阁。雕纹刻镂绮饰分明。周匝栏楯众宝杂厕。堂下多有流泉浴池。上妙莲花弥满其中。犹如北方郁单越国。亦如忉利欢喜之园。尔时娑罗树林中间种种庄严甚可爱乐。亦复如是。是诸天人阿修罗等。咸睹如来涅槃之相。皆悉悲感愁忧不乐

尔时四天王释提桓因。各相谓言。汝等观察诸天世人及阿修罗。大设供养欲于最后供养如来。我等亦当如是供养。若我最后得供养者。檀波罗蜜则为成就满足不难。尔时四天王所设供养倍胜于前。持曼陀罗花。摩诃曼陀罗花。迦枳楼伽花。摩诃迦枳楼伽花。曼殊沙花。摩诃曼殊沙花。散多尼迦花。摩诃散多尼迦花。爱乐花。大爱乐花。普贤花。大普贤花。时花。大时花。香城花。大香城花。欢喜花。大欢喜花。发欲花。大发欲花。香醉花。大香醉花。普香花。大普香花。天金叶花。龙华。波利质多树花。拘毗罗树花。复持种种上妙甘膳。来至佛所稽首佛足。是诸天人所有光明。能覆日月令不复现。以是供具欲供养佛。如来知时默然不受。尔时诸天不果所愿。愁忧苦恼却住一面

尔时释提桓因及三十三天。设诸供具亦倍胜前。及所持花亦复如是。香气微妙甚可爱乐。持得胜堂并诸小堂。来至佛所稽首佛足而白佛言。世尊。我等深乐爱护大乘。唯愿如来哀受我食。如来知时默然不受。时诸释天不果所愿。心怀愁恼却住一面。乃至第六天所设供养展转胜前。宝幢幡盖宝盖小者覆四天下。幡最短者周围四海。幢最卑者至自在天。微风吹幢出妙音声。持上甘膳来诣佛所。稽首佛足白佛言。世尊。唯愿如来。哀受我等最后供养。如来知时默然不受。是诸天等不果所愿。心怀愁恼却住一面。上至有顶。其余梵众一切来集。尔时大梵天王及余梵众。放身光明遍四天下。欲界人天日月光明悉不复现。持诸宝幢缯彩幡盖。幡极短者悬于梵宫至娑罗树间。来诣佛所。稽首佛足白佛言。世尊。唯愿如来。哀受我等最后供养。如来知时默然不受。尔时诸梵不果所愿。心怀愁恼却住一面。尔时毗摩质多阿修罗王。与无量阿修罗大眷属俱。身诸光明胜于梵天。持诸宝幢缯彩幡盖。其盖小者覆千世界。上妙甘膳。来诣佛所稽首佛足。而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不受。诸阿修罗不果所愿。心怀愁恼却住一面。尔时欲界魔王波旬。与其眷属诸天婇女无量无边阿僧祇众。开地狱门施清冷水。因而告曰。汝等今者无所能为。唯当专念如来应正遍知。建立最后随喜供养。当令汝等长夜获安。时魔波旬于地狱中。悉除刀剑无量苦毒。炽然炎火注雨灭之。以佛神力复发是心。令诸眷属皆舍刀剑弓弩铠仗鉾槊长钩金椎钺斧斗轮罥索。所持供养倍胜一切人天所设。其盖小者覆中千界。来至佛所稽首佛足。而白佛言。我等今者爱乐大乘守护大乘。世尊。若有善男子善女人。为供养故。为怖畏故。为诳他故。为财利故。为随他故。受是大乘。或真或伪。我等尔时当为是人除灭怖畏。说如是咒。

侘枳　咤咤罗侘枳　卢呵隶摩诃卢呵隶阿罗　遮罗　多罗　莎呵

是咒能令诸失心者。怖畏者。说法者。不断正法者。为伏外道故。护己身故。护正法故。护大乘故。说如是咒。若有能持如是咒者。无恶象怖。若至圹野空泽崄处不生怖畏。亦无水火师子虎狼盗贼王难。世尊。若有能持如是咒者。悉能除灭如是等怖。世尊。持是咒者我当护之如龟藏六。世尊。我等今者不以谀谄说如是事。持是咒者。我当至诚益其势力。唯愿如来。哀受我等最后供养。尔时佛告魔波旬言。我不受汝饮食供养。我已受汝所说神咒。为欲安乐一切众生四部众故。佛说是已默然不受。如是三请皆亦不受。时魔波旬不果所愿。心怀愁恼却住一面

尔时大自在天王。与其眷属无量无边及诸天众。所设供具悉覆梵释护世四王人天八部及非人等所有供具。梵释所设犹如聚墨在珂贝边悉不复现。宝盖小者能覆三千大千世界。持如是等供养之具。来诣佛所稽首佛足。绕无数匝。白佛言。世尊。我等所奉微末供具犹如蚊蚋供养于我。亦如有人以一掬水投于大海。然一小灯助百千日。春夏之月众花茂盛。有持一花益于众花。以葶苈子益须弥山。岂当有益大海日明众花须弥。世尊。我今所奉微末供具亦复如是。若以三千大千世界满中香花伎乐幡盖。供养如来尚不足言。何以故。如来为诸众生。常于地狱饿鬼畜生诸恶趣中受诸苦恼。是故世尊。应见哀愍受我等供

尔时东方去此无量无数阿僧祇恒河沙微尘等世界。彼有佛土名意乐美音。佛号虚空等如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时彼佛即告第一大弟子言。善男子。汝今宜往西方娑婆世界。彼土有佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛不久当般涅槃。善男子。汝可持此世界香饭。其饭香美食之安隐。可以奉献彼佛世尊。世尊食已入般涅槃。善男子。并可礼敬请决所疑。尔时无边身菩萨摩诃萨。即受佛教从座而起。稽首佛足右绕三匝。与无量阿僧祇大菩萨众俱。从彼国发来至此娑婆世界。应时此间三千大千世界大地六种震动。于是众中梵释四王魔王波旬摩醯首罗。如是大众见是地动。举身毛竖。喉舌枯燥。惊怖战栗各欲四散。自见其身无复光明。所有威德悉灭无余。是时文殊师利法王子。即从座起告诸大众。诸善男子。汝等勿怖。汝等勿怖。何以故。东方去此无量无数阿僧祇恒河沙微尘等世界。有世界名意乐美音。佛号虚空等如来应供正遍知。十号具足。彼有菩萨名无边身。与无量菩萨欲来至此供养如来。以彼菩萨威德力故。令汝身光悉不复现。是故汝等应生欢喜勿怀恐怖。尔时大众悉皆遥见彼佛大众。如明镜中自观己身。时文殊师利复告大众。汝今所见彼佛大众如见此佛。以佛神力。复当如是得见九方无量诸佛。尔时大众各相谓言。苦哉苦哉。世间虚空。如来不久当般涅槃。是时大众一切悉见无边身菩萨及其眷属。是菩萨身一一毛孔。各各出生一大莲花。一一莲花各有七万八千城邑。纵广正等如毗舍离城。墙壁诸堑七宝杂厕。多罗宝树七重行列。人民炽盛安隐丰乐。阎浮檀金以为却敌。一一却敌各有种种七宝林树。花果茂盛。微风吹动出微妙音。其声和雅犹如天乐。城中人民闻是音声。即时得受上妙快乐。是诸堑中妙水盈满。清净香洁如真琉璃。是诸水中有七宝船。诸人乘之游戏澡浴。共相娱乐快乐无极复有无量杂色莲花。优钵罗花拘物头花波头摩花分陀利花。其花纵广犹如车轮。其堑岸上多有园林。一一园中有五泉池。是诸池中复有诸花。优钵罗花。拘物头花。波头摩花。分陀利花。其花纵广亦如车轮。香气馚馥甚可爱乐。其水清净柔软第一。凫雁鸳鸯游戏其中。其园各有众宝宫宅。一一宫宅纵广正等满四由旬。所有墙壁四宝所成。所谓金银琉璃颇梨。真金窗牖周匝栏楯。玟瑰为地金沙布上。是宫宅中多有七宝流泉浴池。一一池边各有十八黄金梯陛。阎浮檀金为芭蕉树。如忉利天欢喜之园。是一一城各有八万四千人王一一诸王各有无量夫人婇女。共相娱乐欢喜受乐。其余人民亦复如是。各于住处。共相娱乐。是中众生不闻余名。纯闻无上大乘之声。是诸花中一一各有师子之座。其座四足皆绀琉璃。柔软素衣以布座上。其衣微妙出过三界。一一座上有一王坐。以大乘法教化众生。或有众生书持读诵如说修行。如是流布大乘经典。尔时无边身菩萨。安止如是无量众生于自身已。令舍世乐。皆作是言。苦哉苦哉世间虚空。如来不久当般涅槃。尔时无边身菩萨与无量菩萨周匝围绕。示现如是神通力已。持是种种无量供具。及以上妙香美饮食。若有得闻是食香气。烦恼诸垢皆悉消灭。以是菩萨神通力故。一切大众悉皆得见如是变化无边身菩萨身大无边量同虚空。唯除诸佛。余无能见是菩萨身其量边际。尔时无边身菩萨及其眷属。所设供养倍胜于前。来至佛所稽首佛足。合掌恭敬白佛言。世尊。唯愿哀愍受我等食。如来知时默然不受。如是三请悉亦不受。尔时无边身菩萨及其眷属却住一面。南西北方诸佛世界。亦有无量无边身菩萨。所持供养倍胜于前。来至佛所乃至却住一面。皆亦如是

尔时娑罗双树吉祥福地。纵广三十二由旬。大众充满间无空缺。尔时四方无边身菩萨及其眷属所坐之处。或如锥头针锋微尘。十方如微尘等诸佛世界诸大菩萨悉来集会。及阎浮提一切大众亦悉来集。唯除尊者摩诃迦叶阿难二众阿阇世王及其眷属乃至毒蛇视能杀人蛣蜣蝮蝎及十六种行恶业者。一切来集。陀那婆神阿修罗等。悉舍恶念皆生慈心。如父如母如姊如妹。三千大千世界众生慈心相向。亦复如是。除一阐提。尔时三千大千世界以佛神力故。地皆柔软无有丘墟土沙砾石荆棘毒草。众宝庄严犹如西方无量寿佛极乐世界。是时大众悉见十方如微尘等诸佛世界。如于明镜自观己身。见诸佛土亦复如是。尔时如来面门所出五色光明。其光明曜覆诸大会。令彼身光悉不复现。所应作已还从口入。时诸天人及诸会众阿修罗等。见佛光明还从口入。皆大恐怖身毛为竖。复作是言。如来光明出已还入。非无因缘。必于十方所作已办。将是最后涅槃之相。何其苦哉。何其苦哉。如何世尊一旦舍离四无量心。不受人天所奉供养。圣慧日光从今永灭。无上法船于斯沉没。呜呼痛哉世间大苦。举手捶胸悲号啼哭。支节战动不能自持。身诸毛孔流血洒地

大般涅槃经卷第一大般涅槃经卷第二

        宋代沙门慧严等依泥洹经加之

    纯陀品第二

尔时会中有优婆塞。是拘尸那城工巧之子名曰纯陀。与其同类十五人俱。为令世间得善果故。舍身威仪从座而起。偏袒右肩右膝着地。合掌向佛悲感流泪。顶礼佛足而白佛言。唯愿世尊及比丘僧。哀受我等最后供养。为度无量诸众生故。世尊。我等从今无主无亲无救无护无归无趣贫穷饥困。欲从如来求将来食。唯愿哀受我等微供然后涅槃。世尊。譬如刹利若婆罗门毗舍首陀。以贫穷故远至他国役力农作得好调牛。良田平正无诸沙卤恶草荒秽。唯悕天雨。言调牛者喻身口七。良田平正喻于智慧。除去沙卤恶草荒秽喻除烦恼。世尊。我今身有调牛良田耘除众秽。唯悕如来甘露法雨。贫四姓者即我身是。贫于无上法之财宝。唯愿哀愍除断我等贫穷困苦。拯及无量苦恼众生。我今所供虽复微少。冀得充足如来大众。我今无主无亲无归。愿垂矜愍如罗睺罗

尔时世尊一切种智无上调御告纯陀曰。善哉善哉。我今为汝除断贫穷。无上法雨雨汝身田令生法芽。汝今于我欲求寿命色力安乐无碍辩才。我当施汝常命色力。安无碍辩。何以故。纯陀。施食有二果报无差。何等为二。一者受已得阿耨多罗三藐三菩提。二者受已入于涅槃。我今受汝最后供养。令汝具足檀波罗蜜。尔时纯陀即白佛言。如佛所说二施果报无差别者。是义不然。何以故。先受施者烦恼未尽。未得成就一切种智。亦未能令众生具足檀波罗蜜。后受施者烦恼已尽。已得成就一切种智。能令众生普得具足檀波罗蜜。先受施者犹是众生。后受施者是天中天。先受施者。是杂食身烦恼之身是后边身是无常身。后受施者。无烦恼身金刚之身法身常身无边之身。云何而言二施果报等无差别。先受施者。未能具足檀波罗蜜乃至般若波罗蜜。唯得肉眼未得佛眼乃至慧眼。后受施者。已得具足檀波罗蜜乃至般若波罗蜜。具足佛眼乃至慧眼。云何而言二施果报等无差别。世尊。先受施者。受已食之入腹消化。得命得色得力得安得无碍辩。后受施者。不食不消无五事果。云何而言二施果报等无差别

佛言。善男子。如来已于无量无边阿僧祇劫。无有食身烦恼之身。无后边身常身法身金刚之身。善男子。未见佛性者。名烦恼身杂食之身。是后边身菩萨。尔时受饮食已入金刚三昧。此食消已即见佛性。得阿耨多罗三藐三菩提。是故我言二施果报等无差别。菩萨尔时破坏四魔。今入涅槃亦破四魔。是故我言二施果报等无差别。菩萨尔时虽不广说十二部经。先已通达。今入涅槃广为众生分别演说。是故我言二施果报等无差别。善男子。如来之身已于无量阿僧祇劫不受饮食。为诸声闻。说言先受难陀难陀波罗二牧牛女所奉乳糜。然后乃得阿耨多罗三藐三菩提。我实不食。我今普为此会大众。是故受汝最后所奉。实亦不食

尔时大众闻佛世尊普为大会哀受纯陀最后供养。欢喜踊跃同声赞言。善哉善哉。希有纯陀。汝今立字名不虚称。言纯陀者名解妙义。汝今建立如是大义。是故依实从义立名。故名纯陀。汝今现世得大名利德愿满足。甚奇纯陀。生在人中复得难得无上之利。善哉纯陀。如优昙花世间希有。佛出于世亦复甚难。值佛生信闻法复难。佛临涅槃最后供养。能办此事复难于是。南无纯陀南无纯陀。汝今已具檀波罗蜜。犹如秋月十五日夜清净圆满无诸云翳一切众生无不瞻仰。汝亦如是。而为我等之所瞻仰。佛已受汝最后供养。令汝具足檀波罗蜜。南无纯陀。是故说汝如月盛满一切众生无不瞻仰。南无纯陀。虽受人身心如佛心。汝今纯陀。真是佛子如罗睺罗等无有异。尔时大众即说偈言

  汝虽生人道　　已超第六天
  我及一切众　　今故稽首请
  人中最胜尊　　今当入涅槃
  汝应愍我等　　唯愿速请佛
  久住于世间　　利益无量众
  演说智所赞　　无上甘露法
  汝若不请佛　　我命将不全
  是故应见为　　稽请调御师

尔时纯陀欢喜踊跃。譬如有人父母卒丧忽然还活。纯陀欢喜亦复如是。复起礼佛而说偈言

  快哉获己利　　善得于人身
  蠲除贪恚等　　永离三恶道
  快哉获己利　　遇得金宝聚
  值遇调御师　　不惧堕畜生
  佛如优昙花　　值遇生信难
  遇已种善根　　永灭饿鬼苦
  亦复能损减　　阿修罗种类
  芥子投针锋　　佛出难于是
  我以具足檀　　度人天生死
  佛不染世法　　如莲花处水
  善断水顶种　　永度生死流
  生世为人难　　值佛世亦难
  犹如大海中　　盲龟遇浮孔
  我今所奉食　　愿得无上报
  一切烦恼结　　摧破无坚固
  我今于此处　　不求天人身
  设使得之者　　心亦不甘乐
  如来受我供　　欢喜无有量
  犹如伊兰花　　出于栴檀香
  我身如伊兰　　如来受我供
  如出栴檀香　　是故我欢喜
  我今得现报　　最胜上妙处
  释梵诸天等　　悉来供养我
  一切诸世间　　悉生大苦恼
  以知佛世尊　　今欲入涅槃
  高声唱是言　　世间无调御
  不应舍众生　　应视如一子
  如来在僧中　　演说无上法
  如须弥宝山　　安处于大海
  佛智能善断　　我等无明闇
  犹如虚空中　　云起得清凉
  如来能善除　　一切诸烦恼
  犹如日出时　　除云光普照
  是诸众生等　　恋慕增悲恸
  悉皆为生死　　苦水之所漂
  以是故世尊　　应长众生信
  为断生死苦　　久住于世间

佛告纯陀。如是如是。如汝所说。佛出世难如优昙花。值佛生信亦复甚难。佛临涅槃最后施食。能具足檀倍复甚难。汝今纯陀。莫大愁苦。应当欢喜深自庆幸得值最后供养如来。成就具足檀波罗蜜。不应请佛久住于世。汝今当观诸佛境界悉皆无常。诸行性相亦复如是。即为纯陀而说偈言

  一切诸世间　　生者皆归死
  寿命虽无量　　要必有终尽
  夫盛必有衰　　合会有别离
  壮年不久停　　盛色病所侵
  命为死所吞　　无有法常住
  诸王得自在　　势力无等双
  一切皆迁灭　　寿命亦如是
  众苦轮无际　　流转无休息
  三界皆无常　　诸有悉非乐
  有道本性相　　一切皆空无
  可坏法流转　　常有忧患等
  恐怖诸过恶　　老病死衰恼
  是诸无有边　　易坏怨所侵
  烦恼所缠裹　　犹如蚕处茧
  何有智慧者　　而当乐是处
  此身苦所集　　一切皆不净
  扼缚痈疮等　　根本无义利
  上至诸天身　　皆亦复如是
  诸欲皆无常　　故我不贪着
  离欲善思惟　　而证真实法
  究竟断有者　　今日当涅槃
  我度有彼岸　　出过一切苦
  是故于今者　　惟受上妙乐

尔时纯陀白佛言。世尊。如是如是。诚如圣教。我今所有智慧微浅犹如蚊蚋。何能思议如来涅槃深奥之义。世尊。我今已与诸大龙象菩萨摩诃萨断诸结漏文殊师利法王子等。世尊。譬如幼年初得出家虽未具戒即堕僧数。我亦如是。以佛菩萨神通力故。得在如是大菩萨数是故我今欲令如来久住于世不入涅槃。譬如饥人终无变吐唯愿世尊。亦复如是。常住于世不入涅槃

尔时文殊师利法王子告纯陀言。纯陀。汝今不应发如是言。欲使如来常住于世不般涅槃。如彼饥人无有变吐。汝今当观诸行性相。如是观行具空三昧。欲求正法。应如是学。纯陀问言。文殊师利。夫如来者天上人中最尊最胜。如是如来岂是行耶。若是行者为生灭法。譬如水泡速起速灭往来流转。犹如车轮。一切诸行亦复如是。我闻诸天寿命极长。云何世尊是天中天。寿命更促不满百年。如聚落主势得自在。以自在力能制他人。是人福尽其后贫贱人所轻蔑为他策使。所以者何。失势力故。世尊亦尔。同于诸行。同诸行者。则不得称为天中天。何以故。诸行即是生死法故。是故文殊。勿观如来同于诸行

复次文殊。为知而说不知而说而言如来同于诸行。设使如来同诸行者。则不得言于三界中为天中天自在法王。譬如人王有大力士。其力当千更无有能降伏之者。故称此士一人当千。如是力士王所爱念。偏赐爵禄封赏自然。所以得称当千人者。是人未必力敌于千但以种种伎艺所能能胜千故。故称当千。如来亦尔。降烦恼魔阴魔。天魔死魔。是故如来名三界尊。如彼力士一人当千。以是因缘成就具足种种无量真实功德。故称如来应正遍知。文殊师利。汝今不应忆想分别以如来法同于诸行。譬如巨富长者生子。相师占之有短寿相。父母闻已知其不任绍继家嗣。不复爱重视之如草。夫短寿者不为沙门婆罗门等男女大小。之所敬念。若使如来同诸行者。亦复不为一切世间人天众生之所奉敬如来所说不变不异。真实之法亦无受者。是故文殊。不应说言如来同于一切诸行

复次文殊。譬如贫女无有居家救护之者。加复病苦饥渴所逼。游行乞丐止他客舍寄生一子。是客舍主驱逐令去。携抱是儿欲至他国于其中路遇恶风雨寒苦并至。多为蚊虻蜂螫毒虫之所唼食。经由恒河抱儿而渡。其水漂疾而不放舍。于是母子遂共俱没。如是女人慈念功德命终之后生于梵天。文殊师利。若有善男子欲护正法。勿说如来同于诸行。不同诸行。唯当自责我今愚痴未有慧眼。如来正法不可思议。是故不应宣说如来定是有为定是无为。若正见者应说如来定是无为。何以故。能为众生生善法故。生怜愍故。如彼贫女在于恒河为爱念子而舍身命。善男子。护法菩萨亦应如是。宁舍身命不说如来同于有为。当言如来同于无为。以说如来同无为故。得阿耨多罗三藐三菩提。如彼女人得生梵天。何以故。以护法故。云何护法。所谓说言如来同于无为。善男子。如是之人虽不求解脱解脱自至。如彼贫女不求梵天梵天自应。文殊师利。如人远行中路疲极寄止他舍。卧寐之中其室忽然大火卒起即时惊寤寻自思惟。我于今者定死不疑。具惭愧故以衣缠身。即便命终生忉利天。从是已后满八十返作大梵王。满百千世生于人中为转轮王。是人不复生三恶趣。展转常生安乐之处。以是缘故。文殊师利若善男子有惭愧者。不应观佛同于诸行。文殊师利。外道邪见可说如来同于有为。持戒比丘不应如是于如来所生有为想。若言如来是有为者。即是妄语。当知是人死入地狱。如人自处于己舍宅。文殊师利。如来真实是无为法。不应复言是有为也。汝从今日于生死中。应舍无知求于正智。当知如来即是无为。若能如是观如来者。具足当得三十二相疾成阿耨多罗三藐三菩提。尔时文殊师利法王子赞纯陀言。善哉善哉。善男子。汝今已作长寿因缘。能知如来是常住法不变异法无为之法。汝今如是善覆如来有为之相。如被火人为惭愧故以衣覆身。以是善心生忉利天。复为梵王转轮圣王。不至恶趣常受安乐。汝亦如是。善覆如来有为相故。于未来世必定当得三十二相八十种好具足十八不共之法。无量寿命不在生死常受安乐。不久得成应正遍知。纯陀。如来次后自当广说。我之与汝俱亦当覆如来有为。有为无为且共置之。汝可随时速施饭食。如是施者诸施中最。若比丘比丘尼优婆塞优婆夷。远行疲极所须之物。应当清净随时给与。如是速施即是具足檀波罗蜜根本种子。纯陀。若有最后施佛及僧。若多若少若足不足宜速及时。如来正尔。当般涅槃。纯陀答言。文殊师利。汝今何故贪为此食。而言多少足与不足令我时施。文殊师利。如来昔日苦行六年尚自支持。况于今日须臾间耶。文殊师利。汝今实谓如来正觉受斯食耶。然我定知。如来身者即是法身非为食身。尔时佛告文殊师利。如是如是。如纯陀言。善哉纯陀。汝已成就微妙大智。善入甚深大乘经典。文殊师利语纯陀言。汝谓如来是无为者如来之身即是长寿。若作是知佛所悦可。纯陀答言。如来非独悦可于我。亦复悦可一切众生。文殊师利言。如来于汝及以我等一切众生。皆悉悦可。纯陀答言。汝不应言如来悦可。夫悦可者。则是倒想。若有倒想则是生死。有生死者即有为法。是故文殊。勿谓如来是有为也。若言如来是有为者。我与仁者俱行颠倒。文殊师利。如来无有爱念之想。夫爱念者。如彼乳牛爱念其子。虽复饥渴行求水草若足不足忽然还。归诸佛世尊无有是念。等视一切如罗睺罗。如是念者即是诸佛智慧境界。文殊师利。譬如国王调御驾驷。欲驰驴乘令及之者。无有是处。我与仁者亦复如是。欲尽如来微密深奥。亦无是处。文殊师利。如金翅鸟飞升虚空。无量由旬下观大海。悉见水性鱼鳖鼋鼍龟龙之属。及见己影如于明镜见诸色像。凡夫少智不能筹量如是所见。我与仁者亦复如是。不能筹量如来智慧。文殊师利语纯陀言。如是如是。如汝所说。我于此事非为不达。直欲试汝诸菩萨事

尔时世尊从其面门出种种光。其光明曜照文殊身。文殊师利遇斯光已。即知是事寻告纯陀。如来今者现是瑞相。不久必当入于涅槃。汝先所设最后供养。宜时奉献佛及大众。纯陀。当知。如来放是种种光明非无因缘。纯陀闻已悲塞默然。佛告纯陀。汝所奉施佛及大众。今正是时。如来正尔当般涅槃。第二第三亦复如是。尔时纯陀闻佛语已。举声啼哭悲咽而言。苦哉苦哉世间虚空。复白大众。我等今者一切当共五体投地同声劝佛莫般涅槃。尔时世尊复告纯陀。莫大啼哭自乱其心。当观是身犹如芭蕉热时之炎水泡幻化乾闼婆城坏器电光。亦如画水临死之囚熟果段肉。如织经尽。如碓上下。当观诸行犹杂毒食。有为之法多诸过患。于是纯陀复白佛言。如来不欲久住于世。我当云何而不啼泣。苦哉苦哉世间虚空。唯愿世尊。怜愍我等及诸众生。久住于世勿般涅槃。佛告纯陀。汝今不应发如是言。哀愍我故久住于世。我以哀愍汝及一切。是故今日欲入涅槃。何以故。诸佛法尔有为亦然。是故诸佛而说是偈

  有为之法　　其性无常　　生已不住
  寂灭为乐

纯陀。汝今当观一切行杂。诸法无我无常不住。此身多有无量过患。犹如水泡。是故汝今不应啼泣。尔时纯陀复白佛言。如是如是。诚如尊教。虽知如来方便示现入于涅槃。而我不能不怀忧恼。覆自思惟复生庆悦。佛赞纯陀。善哉善哉。能知如来示同众生方便涅槃。纯陀。汝今当听。如娑罗娑鸟春阳之月皆共集彼阿耨达池。诸佛亦尔皆至是处。纯陀。汝今不应思惟诸佛长寿短寿。一切诸法皆如幻相。如来在中以方便力无所染着。何以故。诸佛法尔。纯陀。我今受汝所献供养。为欲令汝度脱生死诸有漏故。若诸人天于此最后供养我者。悉皆当得不动果报常受安乐。何以故。我是众生良福田故。汝若复欲为诸众生作福田者。速办所施不宜久停。尔时纯陀为诸众生得度脱故。低头饮泪而白佛言。善哉世尊。我若堪任为福田时。则能了知如来涅槃及非涅槃。我等今者及诸声闻缘觉智慧犹如蚊蚋。实不能量如来涅槃及非涅槃。尔时纯陀及其眷属。愁忧啼泣围绕如来。烧香散华尽心敬奉。寻与文殊从座而去供办食具

    大般涅槃经哀叹品第三

纯陀去已未久之顷。是时此地六种震动。乃至梵世亦复如是。地动有二。或有地动或大地动。小动者名为地动。大动者名大地动。有小声者名曰地动。有大声者名大地动。独地动者名曰地动。山林河海一切动者名大地动。一向动者名曰地动。周回旋转名大地动。动名地动。动时能令众生心动名大地动。菩萨初从兜率天下阎浮提时。名大地动。从初生出家成阿耨多罗三藐三菩提转于法轮及般涅槃。名大地动。今日如来将入涅槃。是故此地如是大动。时诸天龙乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人闻是语已。身毛皆竖同声哀泣。而说偈言

  稽首调御师　　我等今劝请
  远离于人仙　　永无有救护
  今见佛涅槃　　我等没苦海
  悲恋怀忧恼　　如犊失其母
  贫穷无救护　　犹如困病人
  无医随自心　　食所不应食
  众生烦恼病　　常为诸见害
  远离法医王　　服食邪毒药
  是故佛世尊　　不应见遗舍
  如国无君主　　人民皆饥馑
  我等亦如是　　失荫及法味
  今闻佛涅槃　　我等心迷乱
  如彼大地动　　迷失于诸方
  大仙入涅槃　　佛日坠于地
  法水悉枯涸　　我等定当死
  如来般涅槃　　众生极苦恼
  譬如长者子　　新丧于父母
  如来入涅槃　　如其不还者
  我等及众生　　悉无有救护
  如来入涅槃　　乃至诸畜生
  一切皆愁怖　　苦恼焦其心
  我等于今日　　云何不愁恼
  如来见放舍　　犹如弃涕唾
  譬如日初出　　光明甚晖炎
  既能还自照　　亦灭一切闇
  如来神通光　　能除我苦恼
  处在大众中　　譬如须弥山

世尊。譬如国王生育诸子。形貌端正心常爱念。先教伎艺悉令通利。然后弃之付旃陀罗。世尊。我等今日为法王子。蒙佛教诲以具正见。愿莫放舍。如其放舍则同王子。唯愿久住不入涅槃。世尊。譬如有人善学诸论复于此论而生怖畏。如来亦尔。通达诸法而于诸法复生怖畏。若使如来久住于世说甘露味充足一切。如是众生则不复畏堕于地狱。世尊。譬如有人初学作务。为官所收闭之囹圄。有人问之汝受何事。答曰我今受大忧苦。若其得脱则得安乐。世尊亦尔。为我等故修诸苦行。我等今者犹未得免生死苦恼。云何如来得受安乐。世尊。譬如医王善解方药偏以秘方教授其子不教其余外受学者。如来亦尔。独以甚深秘密之藏偏教文殊。遗弃我等不见。顾愍。如来于法应无秘吝。如彼医王偏教其子不教外来诸受学者。彼医所以不能普教。情存胜负故有秘惜。如来之心终无胜负。何故如是不见教诲。唯愿久住莫般涅槃。世尊。譬如老少病苦之人。舍远夷涂而行险道。险道多难备受众苦。更有异人见而愍之。即便示以平坦好路。世尊。我亦如是。所言少者喻未增长法身之人。所言老者喻重烦恼。所言病者譬未脱生死。所言险道者喻二十五有。唯愿如来。示导我等甘露正道。久住于世勿入涅槃。尔时世尊告诸比丘。汝等比丘。莫如凡夫诸天人等愁忧啼哭。当勤精进系心正念。时诸天人阿修罗等。闻佛所说止不啼哭。犹如有人丧其爱子殡送已讫抑止不哭。尔时世尊为诸大众说是偈言

  汝等当开意　　不应大愁苦
  诸佛法皆尔　　是故当默然
  乐不放逸行　　守心正忆念
  远离诸非法　　自慰受欢乐

复次比丘。若有疑惑今皆当问。若空不空。若常无常。若苦不苦。若依非依。若去不去。若归非归。若恒非恒。若断若常。若众生非众生。若有若无。若实不实。若真不真。若灭不灭。若密不密。若二不二。如是等种种法中有所疑者今应咨问。我当随顺为汝断之。亦当为汝先说甘露。然后乃当入于涅槃。诸比丘。佛出世难人身难得。值佛生信是事亦难。能忍难忍是亦复难。成就禁戒具足无缺。得阿罗汉果是事亦难。如求金沙优昙钵花。汝诸比丘。离于八难得人身难。汝等遇我不应空过。我于往昔种种苦行。今得如是无上方便。为汝等故无量劫中舍身手足头目髓脑。是故汝等不应放逸。汝等比丘。云何庄严正法宝城具足种种功德珍宝。戒定智慧以为墙堑。汝今遇是佛法宝城。不应取此虚伪之物。譬如商主遇真宝城取诸瓦砾而便还家。汝亦如是。值遇宝城取虚伪物。汝诸比丘。勿以下心而生知足。汝等今者虽得出家。于此大乘不生贪慕。汝诸比丘。身虽得服袈裟染衣。心犹未染大乘净法。汝诸比丘。虽行乞食经历多处。初未曾求大乘法食。汝诸比丘。虽除须发未为正法除诸结使。汝诸比丘。今当真实教敕汝等。我今现在大众和合。如来法性真实不倒。是故汝等。应当精进摄心勇猛摧诸结使十力慧日既潜没已。汝等当为无明所覆。诸比丘。譬如大地诸山药草为众生用。我法亦尔。出生妙善甘露法味。而为众生种种烦恼病之良药。我今当令一切众生及我诸子四部之众悉皆安住秘密藏中。我亦复当安住是中入于涅槃。何等名为秘密之藏。犹如伊字三点若并则不成伊纵亦不成。如摩醯首罗面上三目。乃得成伊。三点若别亦不得成。我亦如是。解脱之法亦非涅槃。如来之身亦非涅槃。摩诃般若亦非涅槃。三法各异亦非涅槃。我今安住如是三法为众生故名入涅槃如世伊字

尔时诸比丘闻佛世尊定当涅槃。皆悉忧愁身毛为竖。涕泪交流稽首佛足绕无量匝白佛言。世尊。快说无常苦空无我。世尊。譬如一切众生迹中象迹为上。是无常想亦复如是。于诸想中最为第一。若有精勤修习之者。能除一切欲界贪爱色无色爱无明憍慢及无常想。世尊如来若离无常想者。今则不应入于涅槃。若不离者。云何说言修无常想离三界爱无明憍慢及无常想。世尊。譬如农夫于秋月时深耕其地能除秽草。是无常想亦复如是。能除一切欲界贪爱色无色爱无明憍慢及无常想。世尊。譬如耕田秋耕为上。如诸迹中象迹为胜于诸想中无常为最。世尊。譬如帝王知命将终。恩赦天下狱囚系闭悉令得脱。然后舍命。如来今者。亦应如是度诸众生一切无知无明系闭皆令解脱然后涅槃。我等今者皆未得度。云何如来便欲放舍入于涅槃。世尊。譬如有人为鬼所持遇良咒师以咒力故便得除差。如来亦尔。为诸声闻除无明鬼。令得安住摩诃般若解脱等法。如世伊字。世尊。譬如香象为人所缚。虽有良师不能禁制顿绝羁锁自恣而去。我未如是脱五十七烦恼系缚。云何如来便欲放舍入于涅槃。世尊。如人病疟值遇良医所苦得除。我亦如是。多诸患苦邪命热病。虽遇如来病未除愈。未得无上安隐常乐。云何如来便欲放舍入于涅槃。世尊。譬如醉人不自觉知。不识亲疏母女姊妹。迷荒淫乱言语放逸卧不净中。时有良师与药令服。服已即吐还自忆识。心怀惭愧深自克责。酒为不善诸恶根本。若能除断则远众罪。世尊。我亦如是往昔已来轮转生死。情色所醉贪嗜五欲。非母母想。非姊姊想。非女女想。于非众生。生众生想。是故轮转受生死苦。如彼醉人卧不净中。如来今当施我法药令我还吐烦恼恶酒。而我未得醒寤之心。云何如来便欲放舍入于涅槃。世尊。譬如有人叹芭蕉树以为坚实无有是处。世尊。众生亦尔。若叹我人众生寿命养育知见作者受者是真实者。亦无是处。我等如是修无我想。世尊。譬如浆滓无所复用。是身亦尔无我无主。世尊。如七叶花无有香气。是身亦尔无我无主。我等如是心常修习无我之想。如佛所说。一切诸法无我我所。汝诸比丘应当修习。如是修已则除我慢。离我慢已便入涅槃。世尊。譬如鸟迹空中现者无有是处有能修习无我想者而有诸见。亦无是处。尔时世尊赞诸比丘。善哉善哉。汝等善能修无我想。时诸比丘即白佛言。世尊。我等不但修无我想。亦更修习其余诸想所谓苦想无常等想。世尊。譬如醉人其心眩乱。见诸山川城廓宫殿日月星辰皆悉回转。世尊。若有不修苦无常想无我等想。如是之人不名为圣。多诸放逸流转生死。世尊。以是因缘我等善修如是诸想

尔时佛告诸比丘言。谛听谛听。汝向所引醉人喻者。但知文字未达其义。何等为义。如彼醉人见上日月实非回转生回转想。众生亦尔。为诸烦恼无明所覆生颠倒心。我计无我。常计无常。净计不净。乐计为苦。以为烦恼之所覆故。虽生此想不达其义。如彼醉人于非转处而生转想。我者即是佛义。常者是法身义。乐者是涅槃义。净者是法义。汝等比丘。云何而言有我想者憍慢贡高流转生死。汝等若言我亦修习无常苦无我等想。是三种修无有实义。我今当说胜三修法。苦者计乐乐者计苦。是颠倒法。无常计常常计无常。是颠倒法。无我计我我计无我。是颠倒法。不净计净净计不净。是颠倒法。有如是等四颠倒法。是人不知正修诸法。汝诸比丘。于苦法中而生乐想。于无常中而生常想。于无我中而生我想。于不净中而生净想。世间亦有常乐我净。出世亦有常乐我净。世间法者有字无义。出世间者有字有义。何以故。世间之法有四颠倒故不知义。所以者何。有想颠倒心倒见倒。以三倒故世间之人乐中见苦。常见无常。我见无我。净见不净。是名颠倒以颠倒故世间知字而不知义。何等为义。无我者即生死。我者即如来。无常者声闻缘觉。常者如来法身。苦者一切外道。乐者即是涅槃。不净者即有为法。净者诸佛菩萨所有正法。是名不颠倒。以不倒故知字知义。若欲远离四颠倒者。应知如是常乐我净

时诸比丘白佛言。世尊。如佛所说。离四倒者则得了知常乐我净。如来今者永无四倒。则已了知常乐我净。若已了知常乐我净。何故不住一劫半劫教导我等令离四倒。而见放舍欲入涅槃。如来若见顾念教敕。我当至心顶受修习。如来若当入涅槃者。我当云何与是毒身同共止住修于梵行。我等亦当随佛世尊入于涅槃。尔时佛告诸比丘。汝等不应作如是语。我今所有无上正法。悉以付嘱摩诃迦叶。是迦叶者当为汝等作大依止。犹如如来为诸众生作依止处。摩诃迦叶亦复如是。当为汝等作依止处。譬如大王多所统领。若游巡时悉以国事付嘱大臣。如来亦尔。所有正法。亦以付嘱摩诃迦叶。汝等当知。先所修习无常苦想非是真实。譬如春时有诸人等。在大池浴乘船游戏。失琉璃宝没深水中。是时诸人悉共入水求觅是宝。竞捉瓦石草木砂砾。各各自谓得琉璃珠。欢喜持出乃知非真。是时宝珠犹在水中。以珠力故水皆澄清。于是大众乃见宝珠故在水下。犹如仰观虚空月形。是时众中有一智人。以方便力安徐入水即便得珠。汝等比丘。不应如是修习无常苦无我想不净想等以为实义。如彼诸人各以瓦石草木沙砾而为宝珠。汝等应当善学方便在在处处常修我想常乐净想。复应当知先所修习四法相貌悉是颠倒。欲得真实修诸想者。如彼智人巧出宝珠。所谓我想常乐净想。尔时诸比丘白佛言。世尊。如佛先说。诸法无我汝当修学。修学是已则离我想。离我想者则离憍慢。离憍慢者得入涅槃。是义云何

佛告诸比丘。善哉善哉。汝今善能咨问是义为自断疑。譬如国王闇钝少智。有一医师性复顽嚚。而王不别厚赐俸禄。疗治众病纯以乳药。亦复不知病起根原。虽知乳药复不善解风冷热病。一切诸病悉教服乳。是王不别是医知乳好丑善恶。复有明医晓八种术。善疗众病知诸方药从远方来。是时旧医不知咨受。反生贡高轻慢之心。彼时明医即便依附请以为师。咨受医方秘奥之法。语旧医言。我今请仁以为师范。唯愿为我宣畅解说。旧医答言。卿今若能为我给使四十八年。然后乃当教汝医法。时彼明医即受其教。我当如是。我当如是。随我所能当给走使。是时旧医即将客医共入见王。是时客医即为王说种种医方及余伎艺。大王当知。应善分别。此法如是可以治国。此法如是可以疗病。尔时国王闻是语已。方知旧医痴闇无智。即便驱逐令出国界。然后倍复恭敬客医。是时客医作是念言。欲教王者今正是时。即语王言。大王。于我实爱念者当求一愿王即答言。从此右臂及余身分随意所求一切相与。彼客医言。王虽许我一切身分。然我不敢多有所求。今所求者。愿王宣令一切国内。从今已往不得复服旧医乳药。所以者何。是药毒害多伤损故。若故服者当斩其首。断乳药已。终无复有横死之人。常处安乐故求是愿。时王答言。汝之所求盖不足言。寻为宣令一切国内凡诸病人皆悉不听以乳为药。若为药者当斩其首。尔时客医和合众药。谓辛苦碱甜醋等味。以疗众病无不得差。其后不久王复得病。即命是医我今病困当云何治。医占王病应用乳药。寻白王言。如王所患应当服乳。我于先时所断乳药是非实语。今若服者最能除病。王今患热正应服乳。时王语医。汝今狂耶。为热病乎。而言服乳能除此病。汝先言毒。今云何服。欲欺我耶。先医所赞汝言是毒令我驱遣。今复言好最能除病。如汝所言。我本旧医定为胜汝。是时客医复语王言。王今不应作如是语。如虫食木有成字者。此虫不知是字非字。智人见之终不唱言是虫解字。亦不惊怪。大王当知。旧医亦尔。不别诸病悉与乳药。如彼虫道偶得成字。是先旧医不解乳药。好丑善恶。时王问言。云何不解。客医答王。是乳药者亦是毒害。亦是甘露。云何是乳复名甘露。若是乳牛不食酒糟滑草麦[麥*弋]。其犊调善。放牧之处不在高原亦不下湿。饮以清水。不令驰走。不与特牛同共一群。饮食调适行住得所。如是乳者。能除诸病。是则名为甘露妙药。除是乳已。其余一切皆名毒害。尔时大王闻是语已赞言。大医。善哉善哉。我从今日始知乳药善恶好丑。即便服之病得除愈。寻时宣令一切国内从今已往当服乳药。国人闻之皆生嗔恨。咸相谓言。大王。今者为鬼所持。为是狂耶。而诳我等复令服乳。一切人民皆怀嗔恨悉集王所。王言。汝等。不应于我而生嗔恨。如此乳药服与不服。悉是医教非是我咎。尔时大王及诸人民。踊跃欢喜倍共恭敬供养是医。一切病者皆服乳药病悉除愈。汝等比丘。当知如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。亦复如是。为大医王出现于世。降伏一切外道邪医。诸四众中唱如是言。我为医王。欲伏外道故唱是言。无我无人众生寿命养育知见作者受者。比丘。当知。是诸外道所言我者。如虫食木偶成字耳。是故如来于佛法中唱言无我。为调众生故。为知时故。如是无我有因缘故。亦说有我。如彼良医善知于乳是药非药。非如凡夫所计吾我凡夫愚人所计我者。或有说言。大如拇指。或如芥子。或如微尘。如来说我悉不如是。是故说言诸法无我。实非无我。何者是我。若法是实是真是常是主是依性不变易。是名为我。如彼大医善解乳药。如来亦尔。为众生故说诸法中真实有我。汝等四众应当如是修习是法

大般涅槃经卷第二大般涅槃经卷第三

        宋代沙门慧严等依泥洹经加之

    长寿品第四

佛复告诸比丘。汝于戒律有所疑者今恣汝问。我当解说令汝心喜。我已修学一切诸法本性空寂明了通达。汝等比丘。莫谓如来唯修诸法本性空寂。复告比丘。若于戒律有所疑者今悉可问。时诸比丘白佛言。世尊。我等无有智慧。能问如来应供正遍知。所以者何。如来境界不可思议。所有诸定不可思议。所演教诲不可思议。是故我等无有智慧。能问如来。世尊。譬如老人年百二十身婴长病。寝卧床席不能起居。气力虚劣余命无几。有一富人缘事欲行当至他方。以百斤金寄彼老人。而作是言。我今他行以是宝物持用相寄。或经十年或二十年。事毕当还还时归我。是老病人即便受之。而此老人复无继嗣。其后不久病笃命终。所寄之物悉皆散失。财主行还求索无所。如是痴人不知筹量所寄可否。是故行还求索无所。以是因缘丧失财宝。世尊。我等声闻亦复如是。虽闻如来殷勤教戒。不能受持令得久住。如彼老人受他寄付。我今无智于诸戒律当何所问。佛告比丘。汝等今者若问于我。则能利益一切众生。是故告汝。诸有疑网恣随所问。时诸比丘白佛言。世尊。譬如有人年二十五盛壮端正。多有财宝金银琉璃。父母妻子眷属宗亲悉皆具存。时有人来寄其宝物。语其人言。我有缘事欲至他处。事讫当还还时归我。是时壮夫守护是物如自己有。其人遇病即命家属。如是金宝是他所寄。彼若来索悉皆还之。智者如是善知筹量。行还索物皆悉得之无所亡失。世尊亦尔。若以法宝付嘱阿难及诸比丘。不得久住。何以故。一切声闻及大迦叶悉当无常。如彼老人受他寄物。是故应以无上佛法付诸菩萨。以诸菩萨善能问答。如是法宝则得久住。无量千世增益炽盛利安众生。如彼壮人受他寄物。以是义故。诸大菩萨乃能问耳。我等智慧犹如蚊蚋。何能咨请如来深法。时诸声闻默然而住。尔时佛赞诸比丘言。善哉善哉。汝等善得无漏之心。阿罗汉心。我亦曾念以此二缘。应以大乘付诸菩萨令是妙法久住于世。尔时佛告一切大众。善男子善女人。我之寿命不可称量。乐说之辩亦不可尽。汝等宜可随意咨问若戒若归。第二第三亦复如是。尔时众中有一童子菩萨摩诃萨。是多罗聚落婆罗门种姓大迦叶。以佛神力即从座起。偏袒右肩绕百千匝。右膝着地合掌向佛而白佛言。世尊。我于今者欲少咨问。若佛听者乃敢发言。佛告迦叶。如来应供正遍知。恣汝所问。当为汝说断汝所疑令汝欢喜

尔时迦叶菩萨复白佛言。世尊。如来哀愍已垂听许今当问之。然我所有智慧微少犹如蚊蚋。如来世尊道德巍巍。纯以栴檀师子难伏不可坏众而为眷属。如来之身犹真金刚。色如琉璃真实难坏。复为如是大智慧海之所围绕。是众会中诸大菩萨摩诃萨等。皆悉成就无量无边深妙功德犹如香象。于如是等大众之前。岂敢发问为当承佛神通之力。及因大众善根威德。少发问耳。即于佛前以偈问曰

  云何得长寿　　金刚不坏身
  复以何因缘　　得大坚固力
  云何于此经　　究竟到彼岸
  愿佛开微密　　广为众生说
  云何得广大　　为众作依止
  实非阿罗汉　　量与罗汉等
  云何知天魔　　为众作留难
  如来波旬说　　云何分别知
  云何诸调御　　心喜说真谛
  正善具成就　　演说四颠倒
  云何作善业　　大仙今当说
  云何诸菩萨　　能见难见性
  云何解满字　　及与半字义
  云何共圣行　　如娑罗娑鸟
  迦邻提日月　　太白与岁星
  云何未发心　　而名为菩萨
  云何于大众　　而得无所畏
  犹如阎浮金　　无能说其过
  云何处浊世　　不污如莲华
  云何处烦恼　　烦恼不能染
  如医疗众病　　不为病所污
  生死大海中　　云何作船师
  云何舍生死　　如蛇脱故皮
  云何观三宝　　犹如天意树
  三乘若无性　　云何而得说
  犹如乐未生　　云何名受乐
  云何诸菩萨　　而得不坏众
  云何为生盲　　而作眼目导
  云何示多头　　唯愿大仙说
  云何说法者　　增长如月初
  云何复示现　　究竟于涅槃
  云何勇进者　　示人天魔道
  云何知法性　　而受于法乐
  云何诸菩萨　　远离一切病
  云何为众生　　演说于秘密
  云何说毕竟　　及与不毕竟
  如其断疑网　　云何不定说
  云何而得近　　最胜无上道
  我今请如来　　为诸菩萨故
  愿为说甚深　　微妙诸行等
  一切诸法中　　悉有安乐性
  唯愿大仙尊　　为我分别说
  众生大依止　　两足尊妙药
  今欲问诸阴　　而我无智慧
  精进诸菩萨　　亦复不能知
  如是等甚深　　诸佛之境界

尔时佛赞迦叶菩萨。善哉善哉。善男子。汝今未得一切种智。我已得之。然汝所问甚深密藏。如一切智之所咨问等无有异。善男子。我坐道场菩提树下初成正觉。尔时无量阿僧祇恒河沙等诸佛世界有诸菩萨。亦曾问我是甚深义。然其所问句义功德。亦皆如是等无有异。如是问者则能利益无量众生。尔时迦叶菩萨复白佛言。世尊。我无智力能问如来如是深义。世尊。譬如蚊蚋不能飞过大海彼岸周遍虚空。我亦如是。不能咨问如来如是智慧大海法性虚空甚深之义。世尊。譬如国王髻中明珠。付典藏臣藏臣得已顶戴恭敬增加守护。我亦如是。顶戴恭敬增加守护如来所说方等深义。何以故。令我广得深智慧故。尔时佛告迦叶菩萨。善男子。谛听谛听。当为汝说。如来所得长寿之业。菩萨以是业因缘故而得长寿。是故应当至心听受。若业能为菩提因者。应当诚心听受是义。既听受已转为人说。善男子。我以修习如是业故。得阿耨多罗三藐三菩提。今复为人广说是义。善男子。譬如王子犯罪系狱。王甚怜愍爱念子故躬自回驾至其系所。菩萨亦尔。欲得长寿应当护念一切众生同于子想。生大慈大悲大喜大舍。授不杀戒教修善法。亦当安止一切众生于五戒十善。复入地狱饿鬼畜生阿修罗等一切诸趣。拔济是中苦恼众生。脱未脱者。度未度者。未涅槃者令得涅槃。安慰一切诸恐怖者。以如是等业因缘故。菩萨则得寿命长远于诸智慧而得自在。随所寿终生于天上

尔时迦叶菩萨复白佛言。世尊。菩萨摩诃萨等视众生同于子想。是义深隐我未能解。世尊。如来不应说言菩萨于诸众生修平等心同于子想。所以者何。于佛法中有破戒者作逆罪者毁正法者。云何当于如是等人同子想耶。佛告迦叶。如是如是。我于众生实作子想如罗睺罗。迦叶菩萨复白佛言。世尊。昔十五日僧布萨时。曾于具戒清净众中有一童子。不善修习身口意业。在隐屏处盗听说戒。密迹力士承佛神力。以金刚杵碎之如尘。世尊。是金刚神极成暴恶。乃能断是童子命根。云何如来视诸众生同于子想如罗睺罗。佛告迦叶。汝今不应作如是言。是童子者即是化人非真实也。为欲驱遣破戒毁法令出众故。金刚密迹示是化耳。迦叶。毁谤正法及一阐提。或有杀生乃至邪见及故犯禁。我于是等悉生悲心。同于子想如罗睺罗。善男子。譬如国王诸群臣等有犯王法随罪诛戮而不舍置。如来世尊不如是也。于毁法者。与驱遣羯磨。呵责羯磨。置羯磨。举罪羯磨。不可见羯磨。灭羯磨。未舍恶见羯磨。善男子。如来所以与谤法者作如是等降伏羯磨。为欲示诸行恶之人有果报故。善男子。汝今当知。如来即是施恶众生无恐畏者。若放一光若二若五或有遇者悉令远离一切诸恶。如来今者具有如是无量势力。善男子。未可见法汝欲见者。今当为汝说其相貌。我涅槃后随其方面。有持戒比丘威仪具足护持正法。见坏法者即能驱遣呵责纠治。当知是人得福无量不可称计。善男子。譬如有王专行暴恶会遇重病。有邻国王闻其名声兴兵而来将欲灭之。是时病王无力势故方乃恐怖改心修善。而是邻王得福无量。持法比丘亦复如是。驱遣呵责坏法之人令行善法。得福无量。善男子。譬如长者所居之处田宅屋舍生诸毒树。长者知已即便斫伐悉令永尽。又如少壮首生白发愧而剪拔不令生长。持法比丘亦复如是。见有破戒坏正法者。即应驱遣呵责举处。若善比丘见坏法者。置不驱遣呵责举处。当知是人佛法中怨。若能驱遣呵责举处。是我弟子真声闻也。迦叶菩萨复白佛言。世尊。如佛所言。则不等视一切众生同于子想如罗睺罗。世尊若有一人以刀害佛。复有一人栴檀涂佛。佛于二人若生等心。云何复言当治毁禁。若治毁禁。是言则失。佛告迦叶。善男子。譬如国王大臣。宰相产育诸子。颜貌端正聪明黠慧。若二三四将付严师。而作是言。君可为我教诏诸子。威仪礼节伎艺书数悉令成就。我今四子就君受学。假使三子由杖而死。余有一子必当苦治要令成就。虽丧三子我终不恨。迦叶。是父及师得杀罪不。不也世尊。何以故。以爱念故为欲成就无有恶心。如是教诲得福无量。善男子。如来亦尔。视坏法者等如一子。如来今以无上正法付嘱诸王大臣宰相比丘比丘尼优婆塞优婆夷。是诸国王及四部众。应当劝励诸学人等令得增上戒定智慧。若有不学是三品法懈怠破戒毁正法者。国王大臣四部之众应当苦治。善男子。是诸国王及四部众当有罪不。不也世尊。善男子。是诸国王及四部众尚无有罪。何况如来。善男子。如来善修如是平等。于诸众生同一子想。如是修者是名菩萨修平等心于诸众生同一子想。善男子。菩萨如是修习此业便得长寿。亦能善知宿世之事

迦叶菩萨复白佛言。世尊。如佛所说。菩萨若有修平等心。视诸众生同于子想便得长寿。如来不应作如是言。何以故。如知法人能说种种孝顺之法。还至家中以诸瓦石打掷父母。而是父母是良福田多所利益难遭难遇。应好供养反生恼害。是知法人言行相违。如来所言亦复如是。菩萨修习等心众生同子想者。应得长寿善知宿命。常住于世无有变易。今者世尊以何因缘寿命极短同人间耶。如来将无于诸众生生怨憎想。世尊。昔日作何恶业所害几命。得是短寿不满百年。佛告迦叶。善男子。汝今何缘于如来前发是粗言。如来长寿于诸寿中。最上最胜。所得常法于诸常中最为第一

迦叶菩萨复白佛言。世尊。云何如来得寿无量。佛告迦叶。善男子。如八大河。一名恒河。二名阎摩罗。三名萨罗。四名阿夷罗跋提。五名摩诃。六名辛头。七名博叉。八名悉陀。是八大河及诸小河悉入大海。迦叶。如是一切人中天上地及虚空寿命大河。悉入如来寿命海中。是故如来寿命无量。复次迦叶。譬如阿耨达池出四大河。如来亦尔。出一切命。迦叶。譬如一切诸常法中虚空第一。如来亦尔。于诸常中最为第一。迦叶。譬如诸药醍醐第一。如来亦尔。于众生中寿命第一

迦叶菩萨复白佛言。世尊。如来寿命若如是者。应住一劫若减一劫常宣妙法如霔大雨。迦叶。汝今不应于如来所生灭尽想。迦叶。若有比丘比丘尼优婆塞优婆夷乃至外道五通神仙得自在者。若住一劫若减一劫经行空中坐卧自在。左胁出火右胁出水。身出烟炎犹如火聚。若欲住寿能得如意。于寿命中修短自在。如是五通尚得如是随意神力。岂况如来于一切法得自在力。而当不能住寿半劫若一劫若百劫若百千劫若无量劫。以是义故。当知如来是常住法不变易法。如来此身是变化身非杂食身。为度众生示同毒树。是故现舍入于涅槃。迦叶。当知。佛是常法不变易法。汝等于是第一义中。应勤精进一心修习。既修习已广为人说

尔时迦叶菩萨白佛言。世尊。出世之法与世间法有何差别。如佛所言。佛是常法不变易法。世间亦说梵天是常自在天常无有变易。我常性常微尘亦常。若言如来是常法者。如来何故不常现耶。若不常现有何差别。何以故。梵天乃至微尘世性亦不现故。佛告迦叶。譬如长者多有诸牛。色虽种种同共一群。付放牧人令逐水草。唯为醍醐不求乳酪。彼牧牛者构已自食。长者命终所有诸牛。悉为群贼之所抄掠。贼得牛已无有妇女。即自构捋得已而食。尔时群贼各相谓言。彼大长者畜养此牛。不期乳酪唯为醍醐。我等今者当设何方而得之耶。夫醍醐者名为世间第一上味。我等无器设使得乳无安置处。复共相谓。唯有皮囊可以盛之。虽有盛处不知攒摇。浆犹难得况复生酥。尔时诸贼以醍醐故加之以水。以水多故乳酪醍醐一切俱失。凡夫亦尔。虽有善法皆是如来正法之余。何以故。如来世尊入涅槃后。窃盗如来遗余善法若戒定慧。如彼诸贼劫掠群牛。诸凡夫人虽复得是戒定智慧。无有方便不能解脱。以是义故不能获得常戒常定常慧解脱。如彼群贼不知方便亡失醍醐。又如群贼为醍醐故加之以水。凡夫亦尔。为解脱故说我众生寿命士夫梵天自在天微尘世性戒定智慧及与解脱非想非非想天即是涅槃。实亦不得解脱涅槃。如彼群贼不得醍醐。是诸凡夫有少梵行供养父母。以是因缘得生天上受少安乐。如彼群贼加水之乳。而是凡夫实不知因修少梵行供养父母得生天上。又不能知戒定智慧归依三宝。以不知故说常乐我净。虽复说之而实不知。是故如来出世之后。乃为演说常乐我净。如转轮王出现于世。福德力故群贼退散牛无损命。时转轮王即以诸牛付一牧人多巧便者。牧人方便即得醍醐。以醍醐故一切众生无有患苦。法轮圣王出现世时。诸凡夫人不能演说戒定慧者。即便弃舍如贼退散。尔时如来善说世法及出世法。为众生故令诸菩萨随人演说。菩萨摩诃萨既得醍醐。复令无量无边众生普得无上甘露法味。所谓如来常乐我净。以是义故。善男子。如来是常不变易法。非如世间凡夫愚人谓梵天等是常法也。此常法称要是如来非是余法。迦叶。应当如是知如来身。迦叶。诸善男子善女人。常当系心修此二字。佛是常住。迦叶。若有善男子善女人修此二字。当知是人随我所行至我至处。善男子。若有修习如是二字为灭相者。当知如来则于其人为般涅槃。善男子。涅槃义者。即是诸佛之法性也

迦叶菩萨白佛言。世尊。佛法性者其义云何。世尊。我今欲知法性之义。唯愿如来哀愍广说。夫法性者即是舍身。舍身者名无所有。若无所有身云何存。身若存者云何而言身有法性。身有法性云何得存。我今云何当知是义。佛告迦叶菩萨。善男子。汝今不应作如是说灭是法性。夫法性者无有灭也。善男子。譬如无想天成就色阴而无色想。不应问言是诸天等云何而住欢娱受乐云何行想云何见闻。善男子。如来境界非诸声闻缘觉所知。善男子。不应说言如来身者是灭法也。善男子。如来灭法是佛境界。非诸声闻缘觉所及。善男子。汝今不应思量如来何处住何处行何处见何处乐。善男子。如是之义亦非汝等之所知。及诸佛法身种种方便不可思议

复次善男子。应当修习佛法及僧而作常想。是三法者。无有异想。无无常想。无变异想。若于三法修异想者。当知是辈清净三归则无依处。所有禁戒皆不具足。终不能证声闻缘觉菩提之果。若能于是不可思议修常想者。则有归处。善男子。譬如因树则有树影。如来亦尔。有常法故则有归依非是无常。若言如来是无常者。如来则非诸天世人所归依处。迦叶菩萨白佛言。世尊。譬如闇中有树无影。迦叶。汝不应言有树无影。但非肉眼之所见耳。善男子。如来亦尔。其性常住是不变异。无智慧眼不能得见。如彼闇中不见树形。凡夫之人于佛灭后。说言如来是无常法。亦复如是。若言如来异法僧者。则不能成三归依处。如汝父母各各异故故使无常。迦叶菩萨复白佛言。世尊。我从今始当以佛法众僧三事常住启悟父母乃至七世皆令奉持。甚奇世尊。我今当学如来法僧不可思议。既自学已亦当为人广说是义。若有诸人不能信受。当知是辈久修无常。如是等人我当为其而作霜雹。尔时佛赞迦叶菩萨。善哉善哉。汝今善能护持正法。如是护法不欺于人。以不欺人善业缘故。而得长寿善知宿命

    大般涅槃经金刚身品第五

尔时世尊复告迦叶。善男子。如来身者是常住身。不可坏身金刚之身。非杂食身即是法身。迦叶菩萨白佛言。世尊。如佛所说如是等身我悉不见。唯见无常破坏尘土杂食等身。何以故。如来今当入涅槃故。佛告迦叶。汝今莫谓如来之身不坚可坏如凡夫身。善男子。汝今当知。如来之身无量亿劫坚牢难坏。非人天身非恐怖身非杂食身。如来之身非身。是身不生不灭不习不修。无量无边无有足迹。无知无形毕竟清净。无有动摇无受无行。不住不作无味无杂。非是有为非业非果。非行非灭非心非数。不可思议常不可议。无识离心亦不离心。其心平等无有亦有。无有去来而亦去来。不破不坏。不断不绝。不出不灭。非主亦主。非有非无。非觉非观。非字非不字。非定非不定。不可见了了见。无处亦处。无宅亦宅。无闇无明。无有寂静而亦寂静。是无所有。不受不施。清净无垢无诤断诤。住无住处。不取不堕。非法非非法。非福田非非福田。无尽不尽离一切尽。是空离空。虽不常住非念念灭无有垢浊。无字离字。非声非说。亦非修习。非称非量。非一非异。非像非相诸相庄严。非勇非畏。无寂不寂。无热不热。不可睹见无有相貌。如来度脱一切众生。无度脱故能解众生。无有解故觉了众生。无觉了故如实说法。无有二故不可量无等等。平如虚空无有形貌。同无生性不断不常。常行一乘众生见三。不退不转断一切结。不战不触非性住性。非合非散。非长非短非圆非方。非阴入界亦阴入界。非增非损。非胜非负。如来之身成就如是无量功德。无有知者无不知者。无有见者无不见者。非有为非无为。非世非不世。非作非不作。非依非不依。非四大非不四大。非因非不因。非众生非不众生。非沙门非婆罗门。是师子大师子非身非不身。不可宣说。除一法相不可算数。般涅槃时不般涅槃。如来法身皆悉成就如是无量微妙功德。迦叶。唯有如来乃知是相。非诸声闻缘觉所知迦叶。如是功德成如来身。非是杂食所长养身。迦叶。如来真身功德如是。云何复得诸疾患苦危脆不坚如坏器乎。迦叶。如来所以示病苦者。为欲调伏诸众生故。善男子。汝今当知。如来之身即金刚身汝从今日常当专心思惟此义莫念食身。亦当为人说如来身即是法身

迦叶菩萨白佛言。世尊。如来成就如是功德。其身云何当有病苦无常破坏。我从今日常当思惟如来之身是常法身安乐之身。亦当为人如是广说。唯然世尊。如来法身金刚不坏。而未能知所因云何。佛告迦叶。以能护持正法因缘故得成就是金刚身。迦叶。我于往昔护法因缘。今得成就是金刚身常住不坏。善男子。护持正法者。不受五戒不修威仪。应持刀剑弓箭鉾槊守护持戒清净比丘。迦叶菩萨白佛言。世尊。若有比丘离于守护独处空闲冢间树下。当说是人为真比丘。若有随逐守护者行。当知是辈是秃居士。佛告迦叶。莫作是语言秃居士。若有比丘随所至处供身取足。读诵经典思惟坐禅。有来问法即为宣说。所谓布施持戒福德少欲知足。虽能如是种种说法。然故不能作师子吼。不为师子之所围绕。不能降伏非法恶人。如是比丘不能自利及利众生。当知是辈懈怠懒惰。虽能持戒守护净行。当知是人无所能为。若有比丘供身之具亦常丰足。复能护持所受禁戒。能师子吼广说妙法。谓修多罗。祇夜受记伽陀。优陀那。伊帝目多伽。阇陀伽。毗佛略。阿浮陀达磨。以如是等九部经典为他广说。利益安乐诸众生故。唱如是言。涅槃经中制诸比丘不应畜养奴婢牛羊非法之物。若有比丘畜如是等不净之物。应当治之。如来先于异部经中说有比丘畜如是等非法之物。某甲国王如法治之驱令还俗。若有比丘能作如是师子吼时。有破戒者闻是语已。咸共嗔恚害是法师。是说法者设复命终。故名持戒自利利他。以是缘故。我听国主群臣宰相诸优婆塞护说法人。若有欲得护正法者。当如是学。迦叶。如是破戒不护法者。名秃居士。非持戒者得如是名。善男子。过去久远无量无边阿僧祇劫。于此拘尸那城。有佛出世号欢喜增益如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时世界广博严净。丰乐安隐人民炽盛无有饥渴。如安乐国诸菩萨等。彼佛世尊住世无量化众生已。然后乃于娑罗双树入般涅槃。佛涅槃后遗法住世无量亿岁。余四十年佛法未灭。尔时有一持戒比丘。名曰觉德。多有徒众眷属围绕。能师子吼颁宣广说九部经典。制诸比丘不得畜养奴婢牛羊非法之物。尔时多有破戒比丘。闻作是说皆生恶心。执持刀杖逼是法师。是时国王名曰有德。闻是事已为护法故。即便往至说法者所。与是破戒诸恶比丘极共战斗。令说法者得免危害。王时被枪举身周遍。尔时觉德寻赞王言。善哉善哉。王今真是护正法者。当来之世此身当为无量法器。王于是时得闻法已心大欢喜。寻即命终生阿閦佛国。而为彼佛作第一弟子。其王将从人民眷属。有战斗者有随喜者。一切不退菩提之心。命终悉生阿閦佛国。觉德比丘却后寿终亦得往生阿閦佛国。而为彼佛作声闻众中第二弟子。若有正法欲灭尽时。应当如是受持拥护。迦叶尔时王者则我身是。说法比丘迦叶佛是。迦叶。护正法者得如是等无量果报。以是因缘我于今日得种种相以自庄严。成就法身不可坏身

迦叶菩萨复白佛言。世尊。如来常身犹如画石。佛告迦叶。善男子。以是因缘故。比丘比丘尼优婆塞优婆夷。应当勤加护持正法。护法果报广大无量。善男子。是故护法优婆塞等。应执刀杖拥护如是持法比丘。若有受持五戒具者。不得名为大乘人也。不受五戒为护正法乃名大乘。护正法者应当执持刀剑器仗侍卫法师。迦叶白佛言。世尊。若诸比丘与如是等诸优婆塞持刀杖者共为伴侣。为有师耶。为无师乎。为是持戒。为是破戒。佛告迦叶。莫谓是等为破戒人。善男子。我涅槃后浊恶之世国土荒乱。互相抄掠人民饥饿。尔时多有为饥饿故发心出家。如是之人名为秃人。是秃人辈见有持戒威仪具足清净比丘护持正法。驱逐令出若杀若害。迦叶菩萨复白佛言。世尊是持戒人护正法者。云何当得游行村落城邑教化。善男子。是故我今听持戒人依诸白衣持刀杖者以为伴侣。若诸国王大臣长者优婆塞等。为护法故虽持刀杖。我说是等名为持戒。虽持刀杖不应断命。若能如是。即得名为第一持戒

迦叶。夫护法者。谓具正见能广宣说大乘经典。终不捉持王者宝盖油瓶谷米种种果蓏。不为利养亲近国王大臣长者。于诸檀越心无谄曲。具足威仪摧伏破戒诸恶人等。是名持戒护法之师。能为众生真善知识。其心弘广譬如大海。迦叶。若有比丘以利养故为他说法。是人所有徒众眷属。亦效是师贪求利养。是人如是便自坏众。迦叶。众有三种。一者犯戒杂僧。二者愚痴僧。三者清净僧。破戒杂僧则易可坏。持戒净僧利养因缘所不能坏。云何破戒杂僧。若有比丘虽持禁戒为利养故。与破戒者坐起行来共相亲附同其事业。是名破戒亦名杂僧。云何愚痴僧。若有比丘在阿兰若处。诸根不利闇钝[夢-夕+登]瞢少欲乞食。于说戒日及自恣时。教诸弟子清净忏悔。见非弟子多犯禁戒。不能教令清净忏悔。而便与共说戒自恣。是名愚痴僧。云何名清净僧。有比丘僧百千亿魔所不能坏。是菩萨众本性清净。能调如上二部之众。悉令安住清净众中。是名护法无上大师善持律者。为欲调伏利众生故。知诸戒相若轻若重。非是律者则不证知。若是律者则便证知。云何调众生故。若诸菩萨为化众生。常入聚落。不择时节。或至寡妇及淫女舍。与同住止经历多年。若是声闻所不应为。是名调伏利益众生。云何知重若见如来因。事制戒。汝从今日慎莫更犯。如四重禁出家之人所不应作。而故作者非是沙门非释种子。是名为重。云何为轻。若犯轻事如是三谏。若能舍者是名为轻。非律不证者。若有赞说不清净物应受用者。不共同止。是律应证者。善学戒律不近破戒。见有所行随顺戒律心生欢喜。如是能知佛法所作善能解说。是名律师。善解一字善持契经亦复如是。如是善男子。佛法无量不可思议。如来亦尔不可思议。迦叶菩萨白佛言。世尊。如是如是。诚如圣教。佛法无量不可思议。如来亦尔不可思议。故知如来常住不坏无有变异。我今善学亦当为人广宣是义。尔时佛赞迦叶菩萨。善哉善哉。如来身者即是金刚不可坏身。菩萨应当如是善学正见正知。若能如是了了知见。即是见佛金刚之身不可坏身。如于镜中见诸色像

    大般涅槃经名字功德品第六

尔时如来复告迦叶。善男子。汝今应当善持是经文字章句所有功德。若有善男子善女人。闻是经名生四趣者。无有是处。何以故。如是经典乃是无量无边诸佛之所修习。所得功德我今当说。迦叶菩萨白佛言。世尊。当何名此经。菩萨摩诃萨云何奉持。佛告迦叶。是经名为大般涅槃。上语亦善中语亦善下语亦善。义味深邃其文亦善。纯备具足清净梵行。金刚宝藏满足无缺。汝善谛听我今当说。善男子。所言大者名之为常。如八大河悉归大海。此经如是降伏一切诸结烦恼及诸魔性。然后要于大般涅槃放舍身命。是故名曰大般涅槃。善男子。又如医师有一秘方悉摄一切所有医术。善男子。如来亦尔。所说种种妙法秘密深奥藏门。悉皆入此大般涅槃。是故名为大般涅槃。善男子。譬如农夫春月下种常有悕望既收果实众望都息。善男子。一切众生亦复如是。修学余经常悕滋味。若得闻是大般涅槃。悕望诸经所有滋味悉皆永断。是大涅槃能令众生度诸有流。善男子。如诸迹中象迹为最。此经如是于诸经三昧最为第一善男子。譬如耕田秋耕为胜。此经如是诸经中胜。善男子。如诸药中醍醐第一善治众生热恼乱心。是大涅槃为最第一。善男子。譬如甜酥八味具足。大般涅槃亦复如是八味具足。云何为八。一者常。二者恒。三者安。四者清凉。五者不老。六者不死。七者无垢。八者快乐。是为八味。具足八味是故名为大般涅槃。若诸菩萨摩诃萨等安住是中。复能处处示现涅槃。是故名为大般涅槃。迦叶。善男子善女人若欲于此大般涅槃而涅槃者。皆作是学。如来常住法僧亦然。迦叶菩萨复白佛言。甚奇世尊。如来功德不可思议。法僧亦尔不可思议。是大涅槃亦不可思议。若有修学是经典者。得正法门能为良医。若未学者。当知是人盲无慧眼无明所覆

大般涅槃经卷第三大般涅槃经卷第四

        宋代沙门慧严等依泥洹经加之

    四相品第七之一

佛复告迦叶。善男子。菩萨摩诃萨分别开示大般涅槃。有四相义。何等为四。一者自正。二者正他。三者能随问答。四者善解因缘义。迦叶。云何自正。若佛如来见诸因缘而有所说。譬如比丘见大火聚。便作是言。我宁抱是炽然火聚。终不敢于如来所说十二部经及秘密藏谤言此经是魔所说。若言如来法僧无常。如是说者为自侵欺亦欺于人。宁以利刀自断其舌。终不说言如来法僧是无常也。若闻他说亦不信受。于此说者应生怜愍。如来法僧不可思议应如是持自观己身犹如火聚。是名自正

迦叶。云何正他。佛说法时有一女人乳养婴儿。来诣佛所稽首佛足。有所顾念心自思惟便坐一面。尔时世尊知而故问。汝以爱念多含儿酥。不知筹量消与不消。尔时女人即白佛言。甚奇世尊。善能知我心中所念。唯愿如来教我多少。世尊。我于今朝多与儿酥。恐不能消将无夭寿。唯愿如来为我解说。佛言。汝儿所食寻即消化增益寿命。女人闻已心大踊跃。复作是言。如来实说故我欢喜。世尊。如是为欲调伏诸众生故。善能分别说消不消。亦说诸法无我无常。若佛世尊先说常者。受化之徒。当言此法同彼外道即便舍去。复告女人。若儿长大能自行来。凡所食啖能消难消。本所与酥则不供足。我之所有声闻弟子亦复如是。如汝婴儿。不能消是常住之法。是故我先说苦无常。若我声闻诸弟子等功德已备。堪任修习大乘经典。我于是经为说六味。云何六味。说苦醋味。无常碱味。无我苦味。乐为甜味。我为辛味。常为淡味。彼世间中有三种味。所谓无常无我无乐。烦恼为薪智慧为火。以是因缘成涅槃食。谓常乐我。令诸弟子悉皆甘嗜。复告女人。汝若有缘欲至他处。应驱恶子令出其舍。悉以宝藏付示善子。女人白佛。实如圣教。珍宝之藏应示善子不示恶子姊我亦如是。般涅槃时如来微密无上法藏。不与声闻诸弟子等如汝宝藏不示恶子。要当付嘱诸菩萨等。如汝宝藏委付善子。何以故。声闻弟子生变异想。谓佛如来真实灭度。然我真实不灭度也。如汝远行未还之顷汝之恶子便言汝死。汝实不死。诸菩萨等说言如来常不变易。如汝善子不言汝死。以是义故。我以无上秘密之藏付诸菩萨。善男子。若有众生谓佛常住不变异者。当知是家则为有佛。是名正他

迦叶。云何能随问答者。若有人来问佛世尊。我当云何不舍钱财而得名为大施檀越佛言。若有沙门婆罗门等少欲知足不受不畜不净物者当施其人奴婢仆使。修梵行者施与女色。断酒肉者施以酒肉。不过中食施过中食。不着花香施以花香。如是施者。施名流布声闻天下。未曾损己一毫之费。是则名为能随问答。尔时迦叶菩萨白佛言。世尊。食肉之人不应施肉。何以故。我见不食肉者有大功德。佛赞迦叶。善哉善哉。汝今乃能善知我意。护法菩萨应当如是。善男子。从今日始不听声闻弟子食肉。若受檀越信施之时。应观是食如子肉想。迦叶菩萨复白佛言。世尊。云何如来不听食肉。善男子。夫食肉者断大慈种。迦叶又言。如来何故先听比丘食三种净肉。迦叶。是三种净肉随事渐制。迦叶菩萨复白佛言。世尊。何因缘故十种不净。乃至九种清净而复不听。佛告迦叶。亦是因事渐次而制。当知即是现断肉义。迦叶菩萨复白佛言。云何如来称赞鱼肉为美食耶。善男子。我亦不说鱼肉之属为美食也。我说甘蔗粳米石蜜一切谷麦及黑石蜜乳酪苏油以为美食。虽说应畜种种衣服。所应畜者要是坏色。何况贪着是鱼肉味。迦叶复言。如来若制不食肉者。彼五种味乳酪酪浆生酥熟酥胡麻油等。及诸衣服憍奢耶衣。珂贝皮革金银盂器。如是等物亦不应受。善男子。不应同彼尼干所见。如来所制一切禁戒各有异意。异意故听食三种净肉。异想故断十种肉。异想故一切悉断及自死者。迦叶。我从今日制诸弟子不得复食一切肉也。迦叶。其食肉者若行若住若坐若卧。一切众生闻其肉气悉生恐怖。譬如有人近师子已众人见之闻师子臭亦生恐怖

善男子。如人啖蒜臭秽可恶。余人见之闻臭舍去。设远见者犹不欲视况当近之。诸食肉者亦复如是。一切众生闻其肉气。悉皆恐怖生畏死想。水陆空行有命之类悉舍之走。咸言此人是我等怨。是故菩萨不习食肉。为度众生示现食肉。虽现食之其实不食。善男子。如是菩萨清净之食犹尚不食况当食肉。善男子。我涅槃后无量百岁。四道圣人悉复涅槃。正法灭后于像法。当有比丘貌像持律少读诵经贪嗜饮食长养其身。身所被服粗陋丑恶。形容憔悴无有威德。放畜牛羊担负薪草。头须发爪悉皆长利。虽服袈裟犹如猎师。细视徐行如猫伺鼠。常唱是言。我得罗汉。多诸病苦眠卧粪秽。外现贤善内怀贪嫉。如受哑法。婆罗门等。实非沙门现沙门像。邪见炽盛诽谤正法。如是等人破坏如来所制戒律正行威仪。说解脱果离不净法。及坏甚深秘密之教。各自随意反说经律。而作是言。如来皆听我等食肉。自生此论言是佛说互共诤讼。各自称是沙门释子。善男子。尔时复有诸沙门等。贮聚生谷受取鱼肉手自作食。执持油瓶宝盖革屣。亲近国王大臣长者。占相星宿勤修医道。畜养奴婢金银琉璃车渠马瑙颇梨真珠珊瑚虎珀璧玉珂贝种种果蓏。学诸技艺画师泥作。造书教学种植根栽。蛊道咒幻和合诸药作倡伎乐香花治身。摴蒲围棋学诸工巧。若有比丘能离如是诸恶事者。当说是人真我弟子。尔时迦叶复白佛言。世尊。诸比丘比丘尼优婆塞优婆夷因他而活。若乞食时得杂肉食。云何得食应清净法。佛言迦叶。当以水洗令与肉别然后乃食。若其食器为肉所污。但使无味听用无罪。若见食中多有肉者则不应受。一切现肉悉不应食。食者得罪。我今唱是断肉之制。若广说者则不可尽。涅槃时到是故略说。是则名为能随问答

迦叶。云何善解因缘义。如有四部之众来问我言。世尊。如是之义如来初出。何故不为波斯匿王说是法门深妙之义。或时说深或时说浅。或名为犯或名不犯。云何名堕。云何名律。云何名波罗提木叉义。佛言。波罗提木叉者。名为知足成就威仪无所受畜。亦名净命。堕者名四恶趣。又复堕者。堕于地狱乃至阿鼻。论其迟速过于暴雨。闻者惊怖坚持禁戒。不犯威仪修习知足。不受一切不净之物。又复堕者。长养地狱畜生饿鬼。以是诸义故名曰堕。波罗提木叉者。离身口意不善邪业。律者入戒威仪深经善义。遮受一切不净之物及不净因缘。亦遮四重。十三僧残。二不定法。三十舍堕。九十一堕。四悔过法。众多学法。七灭诤等。或复有人破一切戒。云何一切。谓四重法乃至七灭诤法。或复有人诽谤正法甚深经典。及一阐提具足成就。尽一切相无有因缘。如是等人自言我是聪明利智轻重之罪悉皆覆藏。覆藏诸恶如龟藏六。如是众罪长夜不悔。以不悔故日夜增长。是诸比丘所犯众罪终不发露。是使所犯遂复滋漫。是故如来知是事已。渐次而制不得一时。尔时有善男子善女人白佛言。世尊。如来久知如是之事何不先制。将无世尊欲令众生入阿鼻狱。譬如多人欲至他方迷失正路随逐邪道。是诸人等不知迷故皆谓是道。复不见人可问是非。众生如是迷于佛法不见正真。如来应为先说正道敕诸比丘。此是犯戒此是持戒。当如是制。何以故。如来正觉是真实者知见正道。唯有如来天中之天。能说十善增上功德及其义味。是故启请应先制戒。佛言。善男子。若言如来能为众生宣说十善增上功德。是则如来视诸众生如罗睺罗。云何难言将无世尊欲令众生入于地狱。我见一人有堕阿鼻地狱因缘。尚为是人住世一劫若减一劫我于众生有大慈悲。何缘当诳如子想者令入地狱。善男子。如王国内有纳衣者见衣有孔然后乃补。如来亦尔。见诸众生有入阿鼻地狱因缘。即以戒善而为补之。善男子。譬如转轮圣王先为众生说十善法。其后渐渐有行恶者。王即随事以渐断之。断诸恶已然后自行圣王之法。善男子。我亦如是。虽有所说不得先制。要因比丘渐行非法。然后方乃随事制之。乐法众生随教修行。如是等众乃能得见如来法身。如转轮王所有轮宝不可思议。如来亦尔不可思议。法僧二宝亦不可思议。能说法者及闻法者皆不可思议。是名善解因缘义也。菩萨如是分别开示四种相义。是名大乘大涅槃中因缘义也

复次自正者。所谓得是大般涅槃。正他者。我为比丘说言如来常存不变。随问答者。迦叶。因汝所问。故得广为菩萨摩诃萨比丘比丘尼优婆塞优婆夷说是甚深微妙之义。因缘义者。声闻缘觉不解如是甚深之义。不闻伊字三点而成解脱。涅槃。摩诃般若成秘密藏。我今于此阐扬分别。为诸声闻开发慧眼。假使有人作如是言。如是四事云何为一非虚妄耶。即应反质。是虚空无所有不动无碍。如是四事有何等异。是岂得名为虚妄乎。不也世尊。如是诸句即是一义。所谓空义。自正正他能随问答解因缘义。亦复如是。即大涅槃等无有异

佛言迦叶。若有善男子善女人作如是言。如来无常。云何当知是无常耶。如佛所言。灭诸烦恼名为涅槃。犹如火灭悉无所有。灭诸烦恼亦复如是。故名涅槃。云何如来为常住法不变易耶。如佛言曰。离诸有者乃名涅槃。是涅槃中无有诸有。云何如来为常住法不变易耶。如衣坏尽不名为物。涅槃亦尔。灭诸烦恼不名为物。云何如来为常住法不变易耶。如佛言曰。离欲寂灭名曰涅槃。如人斩首则无有首。离欲寂灭亦复如是。空无所有故名涅槃。云何如来为常住法不变易耶。如佛言曰

  譬如热铁　　槌打星流　　散已寻灭
  莫知所在　　得正解脱　　亦复如是
  已度淫欲　　诸有淤泥　　得无动处
  不知所至

云何如来为常住法不变易耶。迦叶。若有人作如是难者名为邪难。迦叶。汝亦不应作是忆想谓如来性是灭尽也。迦叶。灭烦恼者不名为物。何以故。永毕竟故是故名常。是句寂静为无有上。灭尽诸相无有遗余。是句鲜白常住无退。是故涅槃名曰常住。如来亦尔常住无变。言星流者。谓烦恼也。散已寻灭莫知所在者。谓诸如来烦恼灭已不在五趣。是故如来是常住法无有变易。复次迦叶。诸佛所师所谓法也。是故如来恭敬供养。以法常故诸佛亦常。迦叶菩萨复白佛言。若烦恼火灭如来亦灭。是则如来无常住处。如彼迸铁赤色灭已莫知所至。如来烦恼亦复如是。灭无所至。又如彼铁热与赤色灭已无有。如来亦尔灭已无常。灭烦恼火便入涅槃。当知如来即是无常。善男子。所言铁者名诸凡夫。凡夫之人虽灭烦恼灭已复生。故名无常。如来不尔灭不复生。是故名常。迦叶复言。如铁赤色灭已还置火中赤色复生。如来若尔应还生结。若结还生即是无常。佛言迦叶。汝今不应作如是言如来无常。何以故。如来是常。善男子。如彼燃木灭已有灰。烦恼灭已便有涅槃。坏衣斩首破瓶等譬亦复如是如是等物各有名字。名曰坏衣斩首破瓶。迦叶。如铁冷已可使还热。如来不尔。断烦恼已毕竟清凉。烦恼炽火更不复生。迦叶当知。无量众生犹如彼铁。我以无漏智慧炽火。烧彼众生诸烦恼结。迦叶复言。善哉善哉。我今谛知如来所说诸佛是常。佛言迦叶。譬如圣王处在后宫或时游观在于后园。王虽不在诸婇女中亦不得言圣王命终。善男子。如来亦尔。虽不现于阎浮提界入涅槃中。不名无常如来出于无量烦恼。入于涅槃安乐之处。游诸觉华欢娱受乐

迦叶复问。如佛言曰。我已久度烦恼大海。若佛已度烦恼海者。何缘复纳耶输陀罗生罗睺罗。以是因缘当知如来未度烦恼诸结大海。唯愿如来说。其因缘。佛告迦叶。汝不应言如来久度烦恼大海何缘复纳耶输陀罗生罗睺罗以是因缘当知如来未度烦恼诸结大海。善男子。是大涅槃能建大义。汝等今当至心谛听广为人说莫生惊疑。若有菩萨摩诃萨住大涅槃。须弥山王如是高广。悉能取令入于芥子。其诸众生依须弥者。亦不迫迮无往来想如本不异。唯应度者见是菩萨以须弥山纳芥子中。复还安止本所住处。善男子。复有菩萨摩诃萨住大涅槃。能以三千大千世界入于芥子。其中众生亦无迫迮及往来想如本不异。唯应度者见是菩萨以此三千大千世界纳芥子中。复还安止本所住处。善男子。复有菩萨摩诃萨住大涅槃。能以三千大千世界纳一毛孔。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取十方三千大千诸佛世界。置于针锋如贯枣叶。掷着他方异佛世界。其中所有一切众生不觉往返为在何处。唯应度者乃能见之。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取十方三千大千诸佛世界。置于右掌如陶家轮。掷置他方微尘世界。无一众生有往来想。唯应度者乃见之耳。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取一切十方无量诸佛世界悉纳己身。其中众生悉不迫迮亦无往返及住处想。唯应度者乃能见之。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。以十方世界内一尘中。其中众生亦无迫迮往返之想。唯应度者乃能见之。乃至本处亦复如是。善男子。是菩萨摩诃萨住大涅槃。则能示现种种无量神通变化。是故名曰大般涅槃。是菩萨摩诃萨所可示现。如是无量神通变化。一切众生无能测量。汝今云何能知如来习近爱欲生罗睺罗

善男子。我已久住是大涅槃。种种示现神通变化。于此三千大千世界百亿日月百亿阎浮提。种种示现如首楞严经中广说。我于三千大千世界。或阎浮提示现涅槃。亦不毕竟取于涅槃。或阎浮提示入母胎。令其父母生我子想。而我此身毕竟不从爱欲和合而得生也。我已久从无量劫来离于爱欲。我今此身即是法身。随顺世间示现入胎。善男子。此阎浮提林微尼园。示现从母摩耶而生。生已即能东行七步。唱如是言。我于人天阿修罗中最尊最上。父母人天见已惊喜生希有心。是诸人等谓是婴儿。而我此身无量劫来久离是法。如是身者即是法身。非是肉血筋脉骨髓之所成立。随顺世间众生法故示为婴儿。南行七步示现欲为无量众生作上福田。西行七步示现生尽永断老死是最后身。北行七步示现已度诸有生死。东行七步示为众生而作导首。四维七步示现断灭种种烦恼四魔种性成于如来应供正遍知。上行七步示现不为不净之物之所染污犹如虚空。下行七步示现法雨灭地狱火令彼众生受安隐乐毁禁戒者示作霜雹。于阎浮提生七日已示现剃发。诸人皆谓我是婴儿初始剃发。一切人天魔王波旬沙门婆罗门。无有能见我顶相者。况有持刀临之剃发。若有持刀至我顶者无有是处。我已久于无量劫中剃除须发。为欲随顺世间法故示现剃发。我既生已父母将我入天祠中。以我示彼摩醯首罗。摩醯首罗即见我时。合掌恭敬立在一面。我已久于无量劫中。舍离如是入天祠法。为欲随顺世间法故示现如是。我于阎浮提示现穿耳。一切众生实无有能穿我耳者。随顺世间众生法故示现如是。复以诸宝作师子珰庄严其耳。然我已于无量劫中离庄严具。为欲随顺世间法故作是示现示入学堂修学书疏。然我已于无量劫中具足成就遍观三界所有众生。无有堪任为我师者。为欲随顺世间法故示入学堂。故名如来应供正遍知。习学乘象槃马捔力种种技艺。亦复如是。于阎浮提而复示现为王太子。众生皆见我为太子于五欲中欢娱受乐。然我已于无量劫中。舍离如是五欲之乐。为欲随顺世间法故示如是相。相师占我。若不出家当为转轮圣王王阎浮提。一切众生皆信是言。然我已于无量劫中舍转轮王位。为法轮王。于阎浮提现离婇女五欲之乐见老病死及沙门已出家修道。众生皆谓悉达太子初始出家。然我已于无量劫中出家学道。随顺世法故示如是。我于阎浮示现出家受具足戒精勤修道。得须陀洹果斯陀含果。阿那含果。阿罗汉果。众人皆谓是阿罗汉果易得不难。然我已于无量劫中成阿罗汉果。为欲度脱诸众生故。坐于道场菩提树下以草为座摧伏众魔。众皆谓我始于道场菩提树下降伏魔宫。然我已于无量劫中久降伏已。为欲降伏刚强众生故现是化。我又示现大小便利出息入息。众皆谓我实有便利出息入息。然我是身所得果报无是诸患。随顺世间故示如是。我又示现受人信施。然我是身都无饥渴。随顺世法故示如是。我又示同诸众生故现有睡眠。然我已于无量劫中。具足无上深妙智慧远离三有进止威仪头目腹背举身疾痛木枪偿对[泳-永+盥]洗手足澡面漱口杨枝自净。众皆谓我有如是事。然我是身都无此也。手足清净犹如莲花。香气净洁如优钵罗香。一切众生谓我是人我实非人。我又示现受粪扫衣淣濯缝治。然我久已不须是衣。众人皆谓罗睺罗者是我之子。输头檀王是我之父。摩耶夫人是我之母。处在世间受诸快乐。舍如是事出家学道。众人复言是王太子瞿昙大姓。远离世乐求出世法。然我久离世间爱欲。如是等事悉是示现。一切众生咸谓是人。然我实非。善男子。我虽在此阎浮提中数数示现入于涅槃。然我实不毕竟涅槃。而诸众生皆谓如来真实灭尽。而如来性实不永灭是故当知是常住法不变易法。善男子。大涅槃者即是诸佛如来法界。我又示现阎浮提中出于世间。众生皆谓我始成佛。然我已于无量劫中所作已办。随顺世法故复示现于阎浮提初出成佛。我又示现于阎浮提不持禁戒犯四重罪。众人皆见谓我实犯。然我已于无量劫中。坚持禁戒无有漏缺。我又示现于阎浮提为一阐提。众人皆见是一阐提。然我实非一阐提也。一阐提者云何能成阿耨多罗三藐三菩提。我又示现于阎浮提破和合僧。众生皆谓我是破僧。我观人天无有能破和合僧者。我又示现于阎浮提护持正法。众人皆谓我是护法悉生惊怪。诸佛法尔不应惊怪。我又示现于阎浮提为魔波旬。众人皆谓我是波旬。然我久于无量劫中离于魔事。清净无染犹如莲花。我又示现于阎浮提女身成佛。众人见之。皆言甚奇女人能成阿耨多罗三藐三菩提。如来毕竟不受女身。为欲调伏无量众生故现女像。怜愍一切诸众生故。而复示现种种色像我又示现阎浮提中生于四趣。然我久已断诸趣因。以业因故堕于四趣。为度众生故生是中。我又示现阎浮提中作梵天王。令事梵者安住正法。然我实非。而诸众生咸皆谓我为真梵天。示现天像遍诸天庙亦复如是。我又示现于阎浮提入淫女舍。然我实无贪欲之想。清净不污犹如莲花。为诸贪淫着色众生。于四衢道宣说妙法。然我实无欲秽之心。众人谓我守护女人。我又示现于阎浮提入青衣舍。为欲诱化令住正法。然我实无如是恶业堕在青衣。我又示现阎浮提中而作教师。开化童蒙令住正法。我又示现于阎浮提入诸酒会博弈之处。示现种种胜负诤讼。为欲拔济彼诸众生。而我实无如是恶业。而诸众生皆谓我作如是之业。我又示现久住冢间。作大鹫身度诸飞鸟。而诸众生皆谓我是真实鹫身。然我久已离于是业。为欲度彼诸鹫鸟故示现如是。我又示现阎浮提中作大长者。为欲安立无量众生住于正法。又复示作诸王大臣王子辅相。于是众中各为第一。为修正法故处王位。我又示现阎浮提中疫病劫起多有众生为病所恼先施医药。然后为说微妙正法。令其安住无上菩提。众人皆谓是病劫起。又复示现阎浮提中饥饿劫起随其所须供给饮食。然后为说微妙正法。令其安住无上菩提。又复示现阎浮提中刀兵劫起即为说法令离怨害。使得安住无上菩提。又复示现为计常者说无常想。计乐想者为说苦想。计我想。者说无我想。计净想者说不净想。若有众生贪着三界。即为说法令离是处。度众生故为说无上微妙法药。为断一切烦恼树故。种植无上法药之树。为欲拔济诸外道故演说正法。虽复示现为众生师。而心初无众生师想。为欲拔济诸下贱故。现入其中而为说法。非是恶业受是身也。如来正觉如是安住大般涅槃。是故名为常住无变。如阎浮提东弗于逮西瞿耶尼北郁单越。亦复如是。如四天下三千大千世界亦尔。二十五有如首楞严经中广说。以是故名大般涅槃。若有菩萨摩诃萨。安住如是。大般涅槃。能示如是神通变化而无所畏。迦叶。以是缘故。汝不应言罗睺罗者是佛之子。何以故。我于往昔无量劫中已离欲有。是故如来名曰常住无有变易

迦叶复言。如来云何名曰常住。如佛言曰。如灯灭已无有方所。如来亦尔。既灭度已亦无方所。佛言。迦叶善男子。汝今不应作如是言。灯灭尽已无有方所。如来亦尔。既灭度已无有方所。善男子。譬如男女然灯之时。灯器大小悉满中油。随有油在其明犹存。若油尽已明亦俱尽。其明灭者譬烦恼灭。明虽灭尽灯器犹存。如来亦尔。烦恼虽灭法身常存。善男子。于意云何。明与灯器为俱灭不。迦叶答言。不也世尊。虽不俱灭然是无常。若以法身譬灯器者。灯器无常。法身亦尔。应是无常。善男子。汝今不应作如是难。如世间言器。如来世尊无上法器。彼器无常非如来也。一切法中涅槃为常。如来体之故名为常。复次善男子。言灯灭者是阿罗汉所证涅槃。以灭贪爱诸烦恼故。譬之灯灭。阿那含者名曰有贪。以有贪故不得说言同于灯灭。是故我昔覆相说言喻如灯灭。非大涅槃同于灯灭。阿那含者非数数来。又不还来二十五有。更不复受臭身虫身食身毒身。是则名为阿那含也。若更受身名为那含。不受身者名阿那含。有去来者名曰那含。无去来者名阿那含。

大般涅槃经卷第四大般涅槃经卷第五

        宋代沙门慧严等依泥洹经加之

    四相品之余

尔时迦叶菩萨白佛言。世尊。如佛所说。诸佛世尊有秘密藏。是义不然。何以故。诸佛世尊唯有密语无有密藏。譬如幻主机关木人。人虽睹见屈伸俯仰。莫知其内而使之然。佛法不尔。咸令众生悉得知见。云何当言诸佛世尊有秘密藏。佛赞迦叶。善哉善哉善男子。如汝所言。如来实无秘密之藏。何以故。如秋满月处空显露清净无翳人皆睹见。如来之言亦复如是。开发显露清净无翳。愚人不解谓之秘藏。智者了达则不名藏。善男子。譬如有人多积金银至无量亿其心悭吝不肯惠施拯济贫穷如是积聚乃名秘藏。如来不尔于无边劫积聚无量妙法珍宝心无悭吝。常以惠施一切众生。云何当言如来秘藏。善男子。譬如有人身根不具。或无一目一手一足。以羞耻故不令人见。人不见故名为秘藏。如来不尔。所有正法具足无缺令人睹见。云何当言如来秘藏。善男子。譬如贫人多负人财怖畏债主隐不欲现。故名为藏如来不尔。不负一切众生世法。虽负众生出世之法而亦不藏。何以故。恒于众生生一子想。而为演说无上法故。善男子。譬如长者多有财宝唯有一子心甚爱重情无舍离所有珍宝悉用示之。如来亦尔。视诸众生同于一子。善男子。如世间人以男女根丑陋鄙恶以衣覆蔽。故名为藏。如来不尔永断此根。以无根故无所覆藏。善男子。如婆罗门所有语论。终不欲令刹利毗舍首陀等闻。何以故。以此论中有过恶故。如来正法则不如是。初中后善。是故不得名为秘藏。善男子。譬如长者唯有一子心常忆念怜爱无已。将诣师所欲令受学。惧不速成寻便将还。以爱念故昼夜殷勤教其半字。而不教诲毗伽罗论。何以故。以其幼稚力未堪故。善男子。假使长者教半字已。是儿即时能得了知毗伽罗论不。不也世尊。如是长者于是子所有秘藏不。不也世尊。何以故。以子年幼故不为说。不以秘吝而不现示。所以者何。若有嫉妒秘吝之心。乃名为藏。如来不尔。云何当言如来秘藏。佛言。善哉善哉。善男子。如汝所言。若有嗔心嫉妒悭吝。乃名为藏。如来无有嗔心嫉妒。云何名藏。善男子。彼大长者谓如来也。言一子者谓一切众生。如来等视一切众生犹如一子。教一子者谓声闻弟子。半字者谓九部经。毗伽罗论者所谓方等大乘经典。以诸声闻无有慧力。是故如来为说半字九部经典。而不为说毗伽罗论方等大乘。善男子。如彼长者子既长大堪任读学。若不为说毗伽罗论可名为藏。若诸声闻有堪任力。能受大乘毗伽罗论。如来秘惜不为说者。可言如来有秘密藏。如来不尔。是故如来无有秘藏。如彼长者教半字已次为演说毗伽罗论。我亦如是。为诸弟子说于半字九部经已。次为演说毗伽罗论。所谓如来常存不变

复次善男子。譬如夏月兴大云雷降注大雨令诸农夫下种子者多获果实。不下种者无所收获。无所获者非龙王咎。而此龙王亦无所藏。我亦如是。降大法雨大涅槃经。若诸众生种善子者得慧芽果。无善子者则无所获。无所获者非如来咎。然佛如来实无所藏。迦叶复言。我今定知如来世尊无所秘藏。如佛所说。毗伽罗论谓佛如来常存不变。是义不然。何以故。佛昔说偈

  诸佛与缘觉　　声闻弟子众
  犹舍无常身　　何况诸凡夫

今者乃说常存无变。是义云何。佛言。善男子。我为一切声闻弟子教半字故而说是偈又善男子。波斯匿王其母命终。悲号恋慕不能自胜来至我所。我即问言。大王何故。悲苦懊恼乃至于此。王言。世尊。国大夫人某日命终。假使有能令我母命还如本者。我当舍国象马七珍及以身命悉以报之。我复语言。大王。且莫愁恼忧悲啼哭。一切众生寿命尽者名之为死。诸佛缘觉声闻弟子尚舍此身。况复凡夫。善男子。我为波斯匿王教半字故而说是偈。我今为诸声闻弟子说毗伽罗论。谓如来常存无有变易。若有人言如来无常。云何是人舌不堕落

迦叶复言。如佛所说

  无所积聚　　于食知足　　如鸟飞空
  迹不可寻

是义云何。世尊。于此众中谁得名为无所积聚。谁复得名于食知足。谁行于空迹不可寻。而此去者为至何方。佛言。迦叶。夫积聚者名曰财宝善男子。积聚有二种一者有为。二者无为。有为积聚者即声闻行。无为积聚者即如来行。善男子。僧亦二种有为无为。有为僧者名曰声闻。声闻僧者无有积聚。所谓奴婢非法之物库藏谷米盐豉胡麻大小诸豆。若有说言如来听蓄奴婢仆使如是之物。舌则卷缩。我诸所有声闻弟子名无积聚。亦得名为于食知足。若有贪食名不知足。不贪食者是名知足。迹难寻者则近无上菩提之道。我说是人虽去无至。迦叶复言。若有为僧尚无积聚。况无为僧。无为僧者即是如来。如来云何当有积聚。夫积聚者名为藏匿。是故如来凡有所说。无所匿惜。云何名藏。迹不可寻者所谓涅槃。涅槃之中无有日月星辰诸宿寒热风雨生老病死二十五有。离诸忧苦及诸烦恼。如是涅槃如来住处常不变易。以是因缘如来至是娑罗树间。于大涅槃而般涅槃。佛告迦叶。所言大者其性广博犹如有人寿命无量名大丈夫。是人若能安住正法名人中胜。如我所说八大人觉。为一人有为多人有。若一人具八则为最胜。所言涅槃者无诸疮疣。善男子。譬如有人为毒箭所射多受苦痛。值遇良医为拔毒箭涂以妙药。令其离痛得受安乐。是医即便游于城邑及诸聚落。随有患苦疮疣之处即往其所为疗众苦。善男子。如来亦尔。成等正觉为大医王。见阎浮提苦恼众生无量劫中被淫怒痴烦恼毒箭受大苦切。为如是等说大乘经甘露法药。疗治此已复至他方。有诸烦恼毒箭之处。示现作佛为其疗治。是故名曰大般涅槃。大般涅槃者名解脱处。随有调伏众生之处。如来于中而作示现。以是真实甚深义故。名大涅槃。迦叶菩萨复白佛言。世尊。世间医师悉能疗治一切众生疮疣病不。善男子。世间疮疣凡有二种。一者可治。二不可治。凡可治者医则能治。不可治者则不能治。迦叶复言。如佛言者。如来则为于阎浮提治众生已。若言治已。是诸众生其中云何复有未能得涅槃者。若未悉得云何如来说言治竟欲至他方。善男子。阎浮提内众生有二。一者有信。二者无信。有信之人则名可治。何以故。定得涅槃。无疮疣故。是故我说治阎浮提诸众生已。无信之人名一阐提。一阐提者名不可治。除一阐提余悉治已。是故涅槃名无疮疣

世尊。何等名涅槃。善男子。夫涅槃者名为解脱。迦叶复言。所言解脱为是色耶为非色乎。佛言。善男子。或有是色或非是色。言非色者。即是声闻缘觉解脱。言是色者。即是诸佛如来解脱。善男子。是故解脱亦色非色。如来为诸声闻弟子说为非色。世尊。声闻缘觉若非色者。云何得住。善男子。如非想非非想天亦色非色。我亦说为非色。若人难言非想非非想天若非色者。云何得住去来进止。如是之义诸佛境界。非诸声闻缘觉所知。解脱亦尔。亦色非色说为非色。亦想非想说为非想。如是之义诸佛境界。非诸声闻缘觉所知

尔时迦叶菩萨复白佛言。世尊。唯愿哀愍重垂广说大般涅槃行解脱义。佛赞迦叶。善哉善哉。善男子。真解脱者名曰远离一切系缚。若真解脱离诸系缚。则无有生亦无和合。譬如父母和合生子。真解脱者则不如是。是故解脱名曰不生。迦叶。譬如醍醐其性清净。如来亦尔。非因父母和合而生。其性清净。所以示现有父母者。为欲化度诸众生故。真解脱者即是如来。如来解脱无二无别。譬如春月下诸种子得暖润气寻便出生。真解脱者则不如是。又解脱者名曰虚无虚无即是解脱。解脱即是如来。如来即是虚无非作所作。凡是作者如城郭楼观。真解脱者则不如是。是故解脱即是如来。又解脱者即无为法。譬如陶师作已还破解脱不尔真解脱者不生不灭。是故解脱即是如来。如来亦尔。不生不灭不老不死不破不坏非有为法。以是义故。名曰如来。入大涅槃不老不死。有何等义。老者名为迁变。发白面皱。死者身坏命终。如是等法解脱中无。以无是事故名解脱。如来亦无发白面皱有为之法。是故如来无有老也。无有老故则无有死。又解脱者名曰无病。所谓病者四百四病。及余外来侵损身者是处无故故名解脱。无病疾者即真解脱。真解脱者即是如来。如来无病。是故法身亦无有病。如是无病即是如来。死者名曰身坏命终。是处无死即是甘露。是甘露者即真解脱真解脱者即是如来。如来成就如是功德。云何当言如来无常。若言无常无有是处。是金刚身云何无常。是故如来不名命终。如来清净无有垢秽。如来之身非胎所污。如分陀利本性清净。如来解脱亦复如是。如是解脱即是如来。是故如来清净无垢。又解脱者诸漏疮疣永无遗余。如来亦尔。无有一切诸漏疮疣。又解脱者无有斗诤。譬如饥人见他饮食生贪夺想。解脱不尔。又解脱者名曰安静。凡夫人言。夫安静者。谓摩醯首罗。如是之言即是虚妄。真安静者毕竟解脱。毕竟解脱即是如来。又解脱者名曰安隐。如多贼处名不安隐清夷之处乃名安隐。是解脱中无有怖畏。故名安隐。是故安隐即真解脱真解脱者即是如来。如来者即是法也。又解脱者无有等侣。有等侣者。如诸国王有邻国等。真解脱者则不如是。无等侣者。谓转轮圣王无能与等。解脱亦尔无有等侣。无等侣者即真解脱真解脱者即是如来转法轮王。是故如来无有等侣。有等侣者。无有是处。又解脱者名无忧愁。有忧愁者。譬如国王畏难强邻而生忧愁。夫解脱者则无是事。譬如坏怨则无忧虑。解脱亦尔是无忧畏。无忧畏者即是如来。又解脱者名无忧喜。譬如女人唯有一子从役远行。卒得凶问闻之愁苦。后复闻活便生欢喜。夫解脱中无如是事。无忧喜者即真解脱。真解脱者即是如来。又解脱者无有尘垢。譬如春月日没之后风起尘雾。夫解脱中无如是事。无尘雾者喻真解脱。真解脱者即是如来。譬如圣王髻中明珠无有垢秽。夫解脱性亦复如是无有垢秽。无垢秽者喻真解脱。真解脱者即是如来。如真金性不杂沙石乃名真宝。有人得之生于财想。夫解脱性亦复如是如彼真宝。彼真宝者喻真解脱。真解脱者即是如来。譬如瓦瓶破而声[斯/瓦]。金刚宝瓶则不如是。夫解脱者亦无[斯/瓦]破。金刚宝瓶喻真解脱。真解脱者即是如来是故如来身不可坏其。声[斯/瓦]者如[卄/毘]麻子置盛热中爆裂出声。夫解脱者无如是事。如彼金刚真宝之瓶无[斯/瓦]破声。假使无量百千人众悉共射之无能坏者。无[斯/瓦]破声喻真解脱。真解脱者即是如来。如贫穷人负他物故为他所系枷锁杖罚受诸苦毒夫解脱中无如是事。无有负债犹如长者多有财宝无量亿数势力自在不负他物。夫解脱者亦复如是多有无量法财珍宝。势力自在无有所负。无所负者喻真解脱。真解脱者即是如来。又解脱者名无逼切。如春涉热夏日食甜冬日触冷。真解脱中无有如是不适意事。无逼切者喻真解脱。真解脱者即是如来。又无逼切者。譬如有人饱食鱼肉而复饮乳是人则为近死不久。真解脱中无如是事。是人若得甘露良药所患得除。真解脱者亦复如是。甘露良药喻真解脱。真解脱者即是如来。云何逼切不逼切耶。譬如凡夫我慢自高。而作是念一切物中谁能害我。即便捉持蛇虎毒虫。当知是人不尽寿命则便横死。真解脱中无如是事不逼切者。如转轮王所有神珠能伏蛣蜣九十六种诸毒虫等。若有闻是神珠香者。诸毒消灭。真解脱者亦复如是皆悉远离二十五有。毒消灭者喻真解脱真解脱者即是如来。又不逼切者譬如虚空。解脱亦尔。彼虚空者喻真解脱。真解脱者即是如来。又逼切者如近干草燃诸灯火近则炽燃。真解脱中无如是事。又不逼切者譬如日月不逼众生。解脱亦尔。于诸众生无有逼切。无有逼切喻真解脱。真解脱者即是如来。又解脱者名无动法。犹如怨亲。真解脱中无如是事。又不动者如转轮王更无圣王以为亲友。若更有亲则无是处。解脱亦尔。更无有亲。若有亲者亦无是处。彼王无亲喻真解脱。真解脱者即是如来。如来者即是法也。又无动者譬如素衣易受染色。解脱不尔。又无动者如婆师花欲令有臭及青色者无有是处。解脱亦尔。欲令有臭及诸色者亦无是处。是故解脱即是如来。又解脱者名为希有。譬如水中生于莲花非为希有。火中生者是乃希有。有人见之便生欢喜。真解脱者亦复如是。其有见者心生欢喜。彼希有者喻真解脱。真解脱者即是如来。其如来者即是法身。又希有者譬如婴儿其齿未生渐渐长大然后乃生。解脱不尔无生不生。又解脱者名曰虚寂。无有不定。不定者如一阐提究竟不移。犯重禁者不成佛道无有是处。何以故。是人若于佛正法中心得净信。尔时即便灭一阐提。若复得作优婆塞者。是亦得能灭一阐提。犯重禁者灭此罪已则得成佛。是故若言毕定不移不成佛道无有是处。真解脱中都无如是灭尽之事又虚寂者堕于法界。如法界性即真解脱。真解脱者即是如来。又一阐提若尽灭者。则不得称一阐提也。何等名为一阐提耶。一阐提者断灭一切诸善根本。心不攀缘一切善法。乃至不生一念之善。真解脱中都无是事。无是事故即真解脱。真解脱者即是如来。又解脱者名不可量。譬如谷聚其量可知。真解脱者则不如是。譬如大海不可度量。解脱亦尔。不可度量。不可量者即真解脱。真解脱者即是如来。又解脱者名无量法。如一众生多有业报。解脱亦尔。有无量报。无量报者即真解脱。真解脱者即是如来。又解脱者名为广大。譬如大海无与等者。解脱亦尔。无能与等。无与等者即真解脱。真解脱者即是如来。又解脱者名曰最上。譬如虚空最高无比。解脱亦尔。最高无比。高无比者即真解脱。真解脱者即是如来。又解脱者名无能过。譬如师子所住之处。一切百兽无能过者。解脱亦尔。无有能过无能过者即真解脱。真解脱者即是如来。又解脱者名为无上。譬如北方诸方中上。解脱亦尔。为无有上。无有上者即真解脱。真解脱者即是如来。又解脱者名无上上。譬如北方之于东方为无上上。解脱亦尔。无有上上。无上上者即真解脱。真解脱者即是如来。又解脱者名曰恒法。譬如人天身坏命终是名曰恒非不恒也。解脱亦尔。非是不恒。非不恒者即真解脱。真解脱者即是如来。又解脱者名曰坚实。如佉陀罗栴檀沉水其性坚实。解脱亦尔。其性坚实。性坚实者即真解脱。真解脱者即是如来。又解脱者名曰不虚。譬如竹苇其体空疏。解脱不尔。当知解脱即是如来。又解脱者名不可污。譬如墙壁未被涂治。蚊虻在上止住游戏。若以涂治彩画雕饰。虫闻彩香即便不住。如是不住喻真解脱。真解脱者即是如来。又解脱者名曰无边。譬如聚落皆有边表。解脱不尔。譬如虚空无有边际解脱亦尔。无有边际。如是解脱即是如来。又解脱者名不可见。譬如空中鸟迹难见。如是难见喻真解脱。真解脱者即是如来。又解脱者名曰甚深。何以故。声闻缘觉所不能入。不能入者即真解脱。真解脱者即是如来。又甚深者诸佛菩萨之所恭敬。譬如孝子供养父母功德甚深。功德甚深喻真解脱。真解脱者即是如来。又解脱者名不可见。譬如有人不自见顶。解脱亦尔。声闻缘觉所不能见。不能见者即真解脱。真解脱者即是如来。又解脱者名无舍宅。譬如虚空无有舍宅。解脱亦尔。言舍宅者喻二十五有。无有舍宅者喻真解脱。真解脱者即是如来。又解脱者名不可取。如阿摩勒果人可取持。解脱不尔。不可取持。不可取持即真解脱。真解脱者即是如来。又解脱者名不可执。譬如幻物不可执持。解脱亦尔。不可执持。不可执持即真解脱真解脱者即是如来。又解脱者无有身体。譬如有人体生疮癞及诸痈疽颠狂干枯。真解脱中无如是病。无如是病喻真解脱。真解脱者即是如来。又解脱者名为一味。如乳一味。解脱亦尔。唯有一味。如是一味即真解脱。真解脱者即是如来。又解脱者名曰清净。如水无泥澄渟清净。解脱亦尔。澄渟清净。澄渟清净即真解脱。真解脱者即是如来。又解脱者名曰一味。如空中雨一味清净。一味清净喻真解脱。真解脱者即是如来。又解脱者名曰除却。譬如满月无诸云翳。解脱亦尔。无诸云翳。无诸云翳即真解脱。真解脱者即是如来。又解脱者名曰寂静。譬如有人热病除愈身得寂静。解脱亦尔。身得寂静。身得寂静即真解脱。真解脱者即是如来。又解脱者即是平等。譬如野田毒蛇鼠狼俱有杀心。解脱不尔。无有杀心。无杀心者即真解脱。真解脱者即是如来。又平等者譬如父母等心于子。解脱亦尔。其心平等。心平等者即真解脱。真解脱者即是如来。又解脱者名无异处。譬如有人唯居上妙清净屋宅更无异处。解脱亦尔。无有异处。无异处者即真解脱。真解脱者即是如来。又解脱者名曰知足。譬如饥人值遇甘馔食之无厌解脱不尔。如食乳糜更无所须。更无所须喻真解脱。真解脱者即是如来。又解脱者名曰断绝。如人被缚断缚得脱。解脱亦尔。断绝一切疑心结缚。如是断疑即真解脱。真解脱者即是如来。又解脱者名到彼岸。譬如大河有此彼岸。解脱不尔。虽无此岸而有彼岸。有彼岸者即真解脱。真解脱者即是如来。又解脱者名曰默然。譬如大海其水泛涨多诸音声。解脱不尔。如是解脱即是如来。又解脱者名曰美妙。譬如众药杂呵梨勒其味则苦。解脱不尔味如甘露。味如甘露喻真解脱。真解脱者即是如来。又解脱者除诸烦恼。譬如良医和合诸药善疗众病。解脱亦尔。能除烦恼。除烦恼者即真解脱。真解脱者即是如来。又解脱者名曰无迮。譬如小舍不容多人。解脱不尔。多所容受。多所容受即真解脱。真解脱者即是如来。又解脱者名灭诸爱不杂淫欲。譬如女人多诸爱欲。解脱不尔。如是解脱即是如来。如来如是无有贪欲嗔恚愚痴憍慢等结。又解脱者名曰无爱。爱有二种。一饿鬼爱。二者法爱。真解脱者离饿鬼爱。怜愍众生故有法爱。如是法爱即真解脱。真解脱者即是如来。又解脱者离我我所。如是解脱即是如来。如来者即是法也。又解脱者即是灭尽离诸有贪。如是解脱即是如来。如来者即是法也。又解脱者即是救护。能救一切诸怖畏者。如是解脱即是如来。如来者即是法也。又解脱者即是归处。若有归依如是解脱不求余依。譬如有人依恃于王不求余依。虽复依王则有动转。依解脱者无有动转。无动转者即真解脱。真解脱者即是如来。如来者即是法也。又解脱者名曰屋宅。譬如有人行于旷野则有险难。解脱不尔。无有险难。无险难者即真解脱。真解脱者即是如来。又解脱者是无所畏。如师子王于诸百兽不生怖畏。解脱亦尔。于诸魔众不生怖畏。无怖畏者即真解脱。真解脱者即是如来。又解脱者无有迮狭。譬如隘路乃至不受二人并行。解脱不尔。如是解脱即是如来。又有不迮。譬如有人畏虎堕井。解脱不尔。如是解脱即是如来。又有不迮。如大海中舍坏小船得坚牢船乘之渡海至安隐处心得快乐。解脱亦尔。心得快乐。得快乐者即真解脱。真解脱者即是如来。又解脱者拔诸因缘。譬如因乳得酪因酪得酥因酥得醍醐。真解脱中都无是因。无是因者即真解脱。真解脱者即是如来。又解脱者能伏憍慢。譬如大王慢于小王。解脱不尔。如是解脱即是如来。如来者即是法也。又解脱者伏诸放逸。谓放逸者多有贪欲。真解脱中无有是名。无是名者即真解脱。真解脱者即是如来。又解脱者能除无明。如上妙酥除诸滓秽乃名醍醐。解脱亦尔。除无明滓生于真明。如是真明即真解脱。真解脱者即是如来。又解脱者名为寂静纯一无二。如空野象独一无侣。解脱亦尔。独一无二。独一无二即真解脱。真解脱者即是如来。又解脱者名为坚实。如竹苇[卄/毘]麻茎干空虚而子坚实。除佛如来其余人天皆不坚实。真解脱者远离一切诸有漏等。如是解脱即是如来。又解脱者名能觉了增益于我。真解脱者亦复如是。如是解脱即是如来。又解脱者名舍诸有。譬如有人食已而吐。解脱亦尔。舍于诸有。舍诸有者即真解脱。真解脱者即是如来。又解脱者名曰决定。如婆师花香七叶中无。解脱亦尔。如是解脱即是如来。又解脱者名曰水大。譬如水大于诸大胜能润一切草木种子。解脱亦尔。能润一切有生之类。如是解脱即是如来。又解脱者名曰为入。如有门户则通入路。金性之处金则可得。解脱亦尔。如彼门户。修无我者则得入中。如是解脱即是如来。又解脱者名曰为善。譬如弟子随逐于师善奉教敕得名为善。解脱亦尔。如是解脱即是如来。又解脱者名出世法。于一切法最为出过。如众味中酥乳最胜。解脱亦尔。如是解脱即是如来。又解脱者名曰不动。譬如门阃风不能动。真解脱者亦复如是。如是解脱即是如来。又解脱者名无涛波。如彼大海其水涛波。解脱不尔。如是解脱即是如来。又解脱者譬如宫殿。解脱亦尔。当知解脱即是如来。又解脱者名曰所用。如阎浮檀金多有所任无有能说是金过恶。解脱亦尔。无有过恶。无有过恶即真解脱。真解脱者即是如来。又解脱者舍婴儿行。譬如大人舍小儿行。解脱亦尔。除舍五阴。除舍五阴即真解脱。真解脱者即是如来。又解脱者名曰究竟。如被系者从系得解洗浴清净然后还家。解脱亦尔。毕竟清净。毕竟清净即真解脱。真解脱者即是如来。又解脱者名无作乐。无作乐者以吐贪欲嗔恚痴故。譬如有人误饮毒药。为除毒故即服吐药。既得吐已毒即除愈身得安乐。解脱亦尔。吐诸烦恼结缚之毒。身得安乐名无作乐。无作乐者即真解脱。真解脱者即是如来。又解脱者名断四种毒蛇烦恼。断烦恼者即真解脱。真解脱者即是如来。又解脱者名离诸有灭一切苦得一切乐。永断贪欲嗔恚愚痴。拔断一切烦恼根本。拔根本者即真解脱。真解脱者即是如来。又解脱者。名断一切有为之法出生一切无漏善法断塞诸道。所谓若我无我非我非无我。唯断取着不断我见。我见者名为佛性。佛性者即真解脱。真解脱者即是如来。又解脱者名不空空。空空者名无所有。无所有者。即是外道尼犍子等所计解脱。而是尼犍实无解脱。故名空空。真解脱者则不如是。故不空空。不空空者即真解脱。真解脱者即是如来。又解脱者名空不空。如水酒乳酪酥蜜等瓶。虽无水酒酪酥蜜时。犹故得名为水等瓶。而是瓶等不可说空及以不空。若言空者则不得有色香味触。若言不空而复无有水酒等实。解脱亦尔。不可说色及以非色。不可说空及以不空。若言空者则不得有常乐我净。若言不空谁受是常乐我净者。以是义故。不可说空及以不空。空者谓无二十五有及诸烦恼一切苦一切相一切有为行。如瓶无酪则名为空。不空者。谓真实善色常乐我净不动不变。犹如彼瓶色香味触故名不空。是故解脱喻如彼瓶。彼瓶遇缘则有破坏。解脱不尔。不可破坏。不可破坏即真解脱。真解脱者即是如来。又解脱者名曰离爱。譬如有人爱心悕望释提桓因大梵天王自在天王。解脱不尔。若得成于阿耨多罗三藐三菩提已无爱无疑。无爱无疑即真解脱。真解脱者即是如来。若言解脱有爱疑者无有是处。又解脱者断诸有贪。断一切相一切系缚一切烦恼一切生死一切因缘一切果报。如是解脱即是如来。如来即是涅槃。一切众生怖畏生死诸烦恼故故受三归。譬如群鹿怖畏猎师既得免离。若得一跳则喻一归。如是三跳则喻三归。以三跳故得受安乐。众生亦尔。怖畏四魔恶猎师故受三归依。三归依故则得安乐。受安乐者即真解脱。真解脱者即是如来。如来者即是涅槃。涅槃者即是无尽。无尽者即是佛性。佛性者即是决定。决定者即是阿耨多罗三藐三菩提。迦叶菩萨白佛言。世尊。若涅槃佛性决定如来是一义者。云何说言有三归依。佛告迦叶。善男子。一切众生怖畏生死故求三归。以三归故则知佛性决定涅槃。善男子。有法名一义异。有法名义俱异。名一义异者。佛常法常比丘僧常涅槃虚空皆亦是常。是名名一义异。名义俱异者。佛名为觉。法名不觉。僧名和合。涅槃名解脱。虚空名非善亦名无碍。是为名义俱异。善男子。三归依者亦复如是。名义俱异。云何为一。是故我告摩诃波阇波提憍昙弥。莫供养我当供养僧。若供养僧则得具足供养三归。摩诃波阇波提即答我言。众僧之中无佛无法。云何说言供养众僧。则得具足供养三归。我复告言。汝随我语则供养佛。为解脱故即供养法。众僧受者则供养僧。善男子。是故三归不得为一。善男子。如来或时说一为三说三为一。如是之义诸佛境界。非是声闻缘觉所知。迦叶复言。如佛所说。毕竟安乐名涅槃者。是义云何。夫涅槃者舍身舍智。若舍身智谁当受乐。佛言。善男子。譬如有人食已心闷出外欲吐。既得吐已而复回还。同伴问之。汝今所患竟为差不而复来还。答言。已差身得安乐。如来亦尔。毕竟远离二十五有。永得涅槃安乐之处。不可动转无有尽灭。断一切受名无受乐。如是无受名为常乐。若言如来有受乐者无有是处。是故毕竟乐者即是涅槃。涅槃者即真解脱。真解脱者即是如来

迦叶复言。不生不灭是解脱耶。如是如是。善男子。不生不灭即是解脱。如是解脱即是如来。迦叶复言。若不生灭是解脱者。虚空之性亦无生灭应是如来。如如来性即是解脱

佛告迦叶。善男子。是事不然。世尊。何故不然。善男子。如迦兰伽及命命鸟。其声清妙宁可同于乌鹊音不。不也世尊。乌鹊之声。比命命等。百千万倍不可为比。迦叶复言。迦兰伽等其声微妙身亦不同。如来云何比之乌鹊。无异芥子比须弥山。佛与虚空亦复如是。迦兰伽声可譬佛声。不可以喻乌鹊之音。尔时佛赞迦叶菩萨。善哉善哉。善男子。汝今善解甚深难解。如来有时以因缘故。引彼虚空以喻解脱。如是解脱即是如来。真解脱者一切人天无能为譬。而此虚空实非其喻为化众生故以虚空非喻为喻。当知解脱即是如来。如来之性即是解脱。解脱如来无二无别。善男子。非喻者如无比之物不可引喻。有因缘故可得引喻。如经中说面貌端正如月盛满白象鲜洁犹如雪山。满月不得即同于面。雪山不得即是白象。善男子。不可以喻喻真解脱。为化众生故作喻耳。以诸譬喻知诸法性。皆亦如是

迦叶复言。云何如来作二种说。佛言。善男子。譬如有人执持刀剑以嗔恚心欲害如来。如来和悦无恚恨色。是人当得坏如来身成逆罪不。不也世尊。何以故。如来身界不可坏故。所以者何。以无身聚唯有法性。法性之性理不可坏。是人云何能坏佛身。直以恶心故成无间。以是因缘引诸譬喻得知实法。尔时佛赞迦叶菩萨。善哉善哉。善男子。我所欲说汝今已说。又善男子。譬如恶人欲害其母。住于野田在谷[卄/積]下。母为送食。其人见已。寻生害心便前磨刀。母时知已逃入[卄/積]中。其人持刀绕[卄/積]边斫。斫已欢喜生已害想。其母寻出还至家中。于意云何。是人成就无间罪不。世尊不可定说。何以故。若说有罪母身应坏身。若不坏云何言有。若说无罪。生已杀想心怀欢喜。云何言无。是人虽不具足逆罪而亦是逆以是因缘引诸譬喻得知实法。佛赞迦叶。善哉善哉。善男子。以是因缘我说种种方便譬喻以譬解脱。虽以无量阿僧祇喻。而实不可以喻为比。或有因缘亦可喻说。或有因缘不可引譬。是故解脱成就如是无量功德。趣涅槃者。涅槃如来亦有如是无量功德。以如是等无量功德成就满故。名大涅槃。迦叶菩萨白佛言。世尊。我今始知如来至处为无有尽。处若无尽当知寿命亦应无尽。佛言。善哉善哉。善男子。汝今善能护持正法。若有善男子善女人。欲断烦恼诸结缚者。当作如是护持正法

大般涅槃经卷第五大般涅槃经卷第六

        宋代沙门慧严等依泥洹经加之

    四依品第八

佛复告迦叶。善男子。是大涅槃微妙经中。有四种人。能护正法建立正法忆念正法。能多利益怜愍世间。为世间依安乐人天。何等为四。有人出世具烦恼性。是名第一。须陀洹人斯陀含人。是名第二。阿那含人。是名第三。阿罗汉人。是名第四。是四种人出现于世。能多利益怜愍世间。为世间依安乐人天

云何名为具烦恼性。若有人能奉持禁戒威仪具足建立正法。从佛所闻解其文义。转为他人分别宣说。所谓少欲是道。多欲非道。广说如是八大人觉。有犯罪者教令发露忏悔灭除。善知菩萨方便所行秘密之法。是名凡夫非第八人。第八人者不名凡夫。名为菩萨不名为佛

第二人者名须陀洹斯陀含。若得正法受持正法。从佛闻法如其所闻。闻已书写受持读诵转为他说。若闻法已不写不受不持不说。而言奴婢不净之物佛听畜者。无有是处。是名第二人。如是之人未得第二第三住处名为菩萨已得受记

第三人者名阿那含。阿那含者诽谤正法。若言听畜奴婢仆使不净之物。受持外道典籍书论。及为客尘烦恼所障。诸业烦恼之所覆盖。若藏如来真实舍利。及为外病之所恼害。或为四大毒蛇所侵。论说我者悉无是处。若说无我斯有是处。说着世法无有是处。若说大乘相续不绝斯有是处。若所受身有八万虫亦无是处。永离淫欲乃至梦中不失不净斯有是处。临终之日生怖畏者亦无是处。阿那含者为何谓也。是人不还。如上所说。所有过患永不能污。往返周旋名为菩萨。已得受记不久得成阿耨多罗三藐三菩提。是则名为第三人也

第四人者名阿罗汉。阿罗汉者。断诸烦恼舍于重担。逮得己利所作已办。住第十地得自在智。随人所乐种种色像。悉能示现如所庄严。欲成佛道即能得成。能成如是无量功德。名阿罗汉。是名四人。出现于世能多利益怜愍世间。为世间依安乐人天。于人天中最尊最胜。犹如如来名人中胜为归依处

迦叶白佛言。世尊。我今不依是四种人何以故。如瞿师罗经中佛为瞿师罗说。若天魔梵为欲破坏变为佛形。具足庄严三十二相八十种好。圆光一寻面部圆满犹月盛明。眉间毫相白踰珂雪。如是庄严来向汝者。汝当捡挍定其虚实。既觉知已应当降伏。世尊。魔等尚能变作佛形。况不能变作罗汉等四种之身。坐卧空中左胁出水右胁出火。身出烟炎犹如火聚。以是因缘我于是中心不生信。或有所说不能禀受。亦无敬念而作依止。佛言。善男子。于我所说若生疑者尚不应受。况如是等。是故应当善分别知是善不善可作不可作。如是作已长夜受乐。善男子。譬如偷狗夜入人舍。其家婢使若觉知者。即应驱骂汝疾出去。若不出者当断汝命。偷狗闻之即去不还。汝等从今亦应如是降伏波旬。应作是言。波旬。汝今不应作如是像。若故作者当以五系系缚于汝。魔闻是已便当还去。如彼偷狗更不复还

迦叶白佛言。世尊。如佛为瞿师罗长者说。若能如是降伏魔者。亦可得近大般涅槃。如来何必说是四人为依止处。如是四人所可言说未必可信。佛告迦叶。善男子。如我所说亦复如是非为不尔善男子。我为声闻有肉眼者。说言降魔。不为修学大乘人说。声闻之人虽有天眼故名肉眼。学大乘者虽有肉眼乃名佛眼。何以故。是大乘经名为佛乘。如此佛乘最上最胜。善男子。譬如有人勇健威猛。有怯弱者常来依附其勇健人常教怯者。汝当如是持弓执箭修学槊道长钩罥索。又复告言。夫斗战者虽如履刃。不应自生怖畏之念。当视人天生轻弱想。应自生心作勇健意。或时有人无有胆勇诈作健相。执持弓刀种种器仗以自庄严。来至阵中励声大呼。汝于是人亦复不应生于忧怖。如是辈人若见汝等不怖畏者。当知是人不久散坏如彼偷狗。善男子。如来亦尔。告诸声闻。汝等不应畏魔波旬。若魔波旬化作佛身至汝所者。汝当精勤坚固其心令彼降伏。时魔即当愁忧不乐复道而去。善男子。如彼健人不从他习。学大乘者亦复如是。得闻种种深密经典。其心欣乐不生惊怖。何以故。如是修学大乘之人。已曾供养恭敬礼拜过去无量万亿佛故。虽有无量亿千魔众欲来侵娆。于是事中终不惊畏。善男子。譬如有人得阿竭陀药不畏一切毒蛇等畏是药力故亦能消除一切诸毒。是大乘经亦复如是。如彼药力不畏一切诸魔恶毒。亦能降伏令不复起

复次善男子。譬如有龙性甚弊恶。欲害人时或以眼视或以气嘘。是故一切师子虎豹豺狼狗犬皆生怖畏。是等恶兽闻声见形。或触其身无不丧命。有善咒者以咒力故。能令如是诸恶毒龙金翅鸟等恶象师子虎豹豺狼柔善调顺悉任乘御。如是等兽见彼善咒即便调伏。声闻缘觉亦复如是。见魔波旬皆生恐怖。而魔波旬亦复不生畏惧之心犹行魔业。学大乘者亦复如是。见诸声闻怖畏魔事。于此大乘不生信乐。先以方便降伏诸魔。悉令调善堪任为乘。因为广说种种妙法声闻缘觉见调魔已不生怖畏。于此大乘无上正法方生信乐。作如是言。我等从今不应于此正法之中而作障碍。复次善男子。声闻缘觉于诸烦恼而生怖畏。学大乘者都无恐惧。修学大乘有如是力。以是因缘先所说者。为欲令彼声闻缘觉调伏诸魔。非为大乘。是大涅槃微妙经典不可消伏。甚奇甚特。若有闻者。闻已信受。能信如来是常住法。如是之人甚为希有如优昙花。我涅槃后若有得闻如是大乘微妙经典生信敬心。当知是等于未来世百千亿劫不堕恶道

尔时佛告迦叶菩萨。善男子。我涅槃后当有百千无量众生诽谤不信是大涅槃微妙经典。迦叶菩萨复白佛言。世尊。是诸众生于佛灭后。久近便当诽谤是经。世尊。复有何等纯善众生。当能拔济是谤法者

佛告迦叶。善男子。我般涅槃后四十年中。于阎浮提广行流布。然后乃当隐没于地。善男子。譬如甘蔗稻米石蜜酥酪醍醐随有之处其土人民皆言是味味中第一。或复有人纯食粟米及稊稗子。是人亦言我所食者最为第一。是薄福人受业报故。若是福人耳初不闻粟稗之名。所食唯是粳粮甘蔗石蜜醍醐。是大涅槃微妙经典亦复如是。钝根薄福不乐听闻。如彼薄福憎恶粳粮及石蜜等。二乘之人亦复如是。憎恶无上大涅槃经。或有众生其心欣乐听受是经。闻已欢喜不生诽谤。如彼福人食于粳粮善男子。譬如有王居在深山险难恶处。虽有甘蔗粳粮石蜜。以难得故贪惜积聚不敢啖食。惧其有尽唯食粟稗。有异国王闻而愍之。即以车载粳粮甘蔗而送与之。其王得已即便分布举国共食。民既食已皆生欢喜。咸作是言。因彼王故令我得是希有之味。善男子。是四种人亦复如是。为此无上大法之将。是四种中或有一人。见于他方无量菩萨。虽学如是大乘经典若自书写若令他书。为利养故。为称誉故。为解法故。为依止故。为用贸易其余经故。不能广为他人宣说。是故持是微妙经典。送至彼方与彼菩萨。令发无上菩提之心安住菩提而是菩萨得是经已。即便广为他人演说。令无量众得受如是大乘法味。皆悉是此一菩萨力。所未闻经悉令得闻。如彼人民因王力故。得希有食。又善男子。是大涅槃微妙经典所流布处。当知其地即是金刚。是中诸人亦如金刚。若有能听如是经者。即不退转于阿耨多罗三藐三菩提。随其所愿悉得成就。如我今日所可宣说。汝等比丘应善受持。若有众生不能听闻如是经典。当知是人甚可哀愍。何以故。是人不能受持如是大乘经典甚深义故

迦叶菩萨白佛言。世尊。如来灭后四十年中。是大乘典大涅槃经。于阎浮提广行流布。过是已后没于地者。却后久如复当还出

佛言。善男子。若我正法余八十年。前四十年是经复当于阎浮提雨大法雨

迦叶菩萨复白佛言。世尊。如是经典正法灭时。正戒毁时。非法增长时。无如法众生时。谁能听受奉持读诵令其通利供养恭敬书写解说。唯愿如来。哀愍众生分别广说。令诸菩萨闻已受持持已即得不退阿耨多罗三藐三菩提心

尔时佛赞迦叶。善哉善哉。善男子。汝今善能问如是义。善男子。若有众生于熙连河沙诸如来所。发菩提心。乃能于是恶世受持如是经典不生诽谤。善男子。若有众生于一恒河沙诸如来所。发菩提心。然后乃能于恶世中。不谤是法爱乐是典。不能为人分别广说。善男子。若有众生于二恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。正解信乐受持读诵。亦复不能为人广说。若有众生于三恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。虽为他说未解深义。若有众生于四恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。为他广说十六分中一分之义。虽复演说亦不具足。若有众生于五恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。广为人说十六分中八分之义。若有众生于六恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。为他广说。十六分中十二分义。若有众生于七恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。为他广说十六分中十四分义。若有众生于八恒河沙诸如来所。发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。亦劝他人令得书写。自能听受复劝他人令得听受读诵通利拥护坚持。怜愍世间诸众生故。供养是经亦劝他人令其供养。恭敬尊重读诵礼拜亦复如是。具足能解尽其义味。所谓如来常住不变毕竟安乐。广说众生悉有佛性。善知如来所有法藏。供养如是诸佛等已。建立如是无上正法受持拥护。若有始发阿耨多罗三藐三菩提心。当知是人未来之世。必能建立如是正法受持拥护。是故汝今不应不知未来世中护法之人。何以故。是发心者于未来世必能护持无上正法。善男子。有恶比丘闻我涅槃不生忧愁。今日如来入般涅槃何其快哉。如来在世遮我等利今入涅槃。谁复当有遮夺我者。若无遮夺我则还得如本利养。如来在世禁戒严峻。今入涅槃悉当放舍所受袈裟本为法式。今当废坏如木头幡。如是等人诽谤拒逆是大乘经。善男子。汝今应当如是忆持。若有众生成就具足无量功德。乃能信是大乘经典。信已受持。其余众生有乐法者。若能广为解说此经。其人闻已过去无量阿僧祇劫所作恶业皆悉除灭。若有不信是经典者。现身当为无量病苦之所恼害。多为众人所见骂辱。命终之后人所轻贱。颜貌丑陋资生艰难常不供足。虽复少得粗涩弊恶。生生常处贫穷下贱诽谤正法邪见之家。若临终时。或值荒乱刀兵竞起帝王暴虐怨家仇隙之所侵逼。虽有善友而不遭遇。资生所须求不能得。虽少得利常患饥渴。唯为凡下之所顾识。国王大臣悉不齿录。设复闻其有所宣说。正使是理终不信受。如是之人不至善处。如折翼鸟不能飞行。是人亦尔。于未来世不能得至人天善处。若复有人能信如是大乘经典。本所受形虽复粗陋。以经功德即便端正。威颜色力日更增多。常为人天之所乐见。恭敬爱念情无舍离。国王大臣及家亲属。闻其所说悉皆敬信。若我声闻弟子之中。欲行第一希有事者。当为世间广宣如是大乘经典

善男子。譬如雾露势虽欲住不过日出日既出已消灭无余。善男子。是诸众生所有恶业亦复如是。住世势力不过得见大涅槃日。是日既出悉能除灭一切恶业

复次善男子。譬如有人出家剃发虽服袈裟故未得受沙弥十戒。或有长者来请众僧。未受戒者即与大众俱共受请。虽未受戒已堕僧数。善男子。若有众生发心始学是大乘典大涅槃经。书持读诵亦复如是。虽未具足位阶十住。则已堕于十住数中。或有众生是佛弟子或非弟子。若因贪吝或因利养。听受是经乃至一偈闻已不谤。当知是人则为已近阿耨多罗三藐三菩提。善男子。以是因缘我说四人为世间依。善男子。如是四人。若以佛说言非佛说。无有是处。是故我说如是四人为世间依。善男子。汝应供养如是四人。世尊。我当云何识知是人而为供养

佛告迦叶。若有建立护持正法。如是之人应从启请。当舍身命而供养之。如我于是大乘经说

  有知法者　　若老若少　　故应供养
  恭敬礼拜　　犹如事火　　婆罗门等
  有知法者　　若老若少　　故应供养
  恭敬礼拜　　亦如诸天　　奉事帝释

迦叶菩萨白佛言。世尊。如佛所说。供养师长正应如是。今有所疑唯愿广说。若有长宿护持禁戒。从诸年少咨受未闻。云何是人当礼敬不。若当礼敬是则不名为持戒也。若是年少护持禁戒。从诸宿旧破戒之人咨受未闻。复应礼不。若出家人从在家人咨受未闻。复当礼不。然出家人不应礼敬在家之人。然佛法中年少幼小应当恭敬耆旧长宿。以是长宿先受具戒成就威仪。是故应当供养恭敬。如佛言曰。其破戒者是佛法中所不容受。犹如良田多有稊稗。又如佛说。有知法者若老若少。故应供养如事帝释。如是二句其义云何。将非如来虚妄说耶。如佛言曰。持戒比丘亦有所犯。何故如来而作是说。世尊。亦于余经中说听治破戒。如是所说其义未了。佛告迦叶。善男子。我为未来诸菩萨等学大乘者。说如是偈。不为声闻弟子说也。善男子。如我先说。正法灭已毁正戒时。增长破戒非法盛时。一切圣人隐不现时。受畜奴婢不净物时。是四人中当有一人出现于世。剃除须发出家修道。见诸比丘各各受畜奴婢仆使不净之物。净与不净一切不知。是律非律亦复不识。是人为欲调伏如是诸比丘故。与共和光不同其尘。自所行处及佛行处善能别知。虽见诸人犯波罗夷默然不举。何以故。我出于世为欲建立护持正法。是故默然而不纠治。善男子。如是之人为护法故。虽有所犯不名破戒

善男子。譬如国王遇病崩亡储君稚小未任绍继。有旃陀罗丰饶财宝巨富无量多有眷属。遂以强力乘国虚弱。篡居王位治化未久。国人居士婆罗门等亡叛逃走远投他国。虽有在者乃至不欲眼见是王。或有长者婆罗门等不离本土。譬如诸树随其生处即是中死。旃陀罗王知其国人逃叛者众寻即还。遣诸旃陀逻守逻诸道。复于七日击鼓唱令诸婆罗门。有能为我作灌顶师者。当分半国以为封赏。诸婆罗门虽闻是语悉无来者。各作是言。云何当有婆罗门种作如是事。旃陀罗王复作是言。婆罗门中若无一人为我师者。我要当令诸婆罗门与旃陀罗共住食宿同其事业。若有能来灌我顶者。半国之封此言不虚。咒术所致三十三天上妙甘露不死之药。亦当共分而服食之

尔时有一婆罗门子。年在弱冠修治净行。长发为相善知咒术。往至王所白言。大王。王所敕使我悉能为。尔时大王心生欢喜。受此童子作灌顶师。诸婆罗门闻是事已。皆生嗔恚责此童子。汝婆罗门。云何乃作旃陀罗师。尔时其王。即分半国与是童子。因共治国经历多时。尔时童子。语彼王言。我舍家法来作王师。悉教大王微密咒术。而今大王犹不见亲。时王答言。我今云何不亲汝耶。童子答言。先王所有不死之药犹未共食。王言。善哉善哉。大师。我实不知。师若须者愿便持去。是时童子闻王语已。即持归家请诸大臣而共食之。诸臣食已即共白王。快哉大师。有是甘露不死之药。王既知已语其师言。云何大师。独与诸臣服食甘露而不见分。尔时童子即更以余杂毒之药与王令服。王既服已须臾药发闷乱躄地。无所觉知犹如死人。尔时童子立本储君还以为王。作如是言。师子御座法不应令旃陀罗升。我从昔来未曾闻见旃陀罗种而为王者。若旃陀罗治国理民无有是处。大王今应还绍先王正法治国。尔时童子经理是已。复以解药与旃陀罗令其醒寤。既醒寤已驱令出国。是时童子虽为是事。犹故不失婆罗门法。其余居士婆罗门等。闻其所作叹未曾有。赞言。善哉善哉。仁者。善能驱遣旃陀罗王。善男子。我涅槃后护持正法诸菩萨等亦复如是。以方便力与彼破戒假名受畜一切不净物僧。同其事业。尔时菩萨若见有人虽多犯戒能治毁禁诸恶比丘。即往其所恭敬礼拜四事供养。经书什物悉以奉上。如其自无要当方便从诸檀越求乞与之。为是事故应畜八种不净之物。何以故。是人为治诸恶比丘。如彼童子驱旃陀罗故。尔时菩萨虽复恭敬礼拜是人受畜八种不净之物。悉无有罪。何以故。以是菩萨为欲摈治诸恶比丘。令清净僧得安隐住。流布方等大乘经典。利益一切诸天人故。善男子。以是因缘我于经中说是二偈。令诸菩萨皆共赞叹护法之人。如彼居士婆罗门等称赞童子善哉善哉。护法菩萨正应如是。若有人见护法之人与破戒者同其事业。说有罪者。当知是人自受其殃。是护法者实无有罪。善男子。若有比丘犯禁戒已。憍慢心故覆藏不悔。当知是人名真破戒。菩萨摩诃萨。为护法故虽有所犯不名破戒。何以故。以无憍慢发露悔故。善男子。是故我于经中覆相说如是偈

  有知法者　　若老若少　　故应供养
  恭敬礼拜　　犹如事火　　婆罗门等
  如第二天　　奉事帝释

以是因缘。我亦不为学声闻人。但为菩萨而说是偈

迦叶菩萨白佛言。世尊。如是等菩萨摩诃萨于戒纵缓。本所受戒为具在不。佛言。善男子。汝今不应作如是说。何以故。本所受戒如本不失。设有所犯即应忏悔。悔已清净。善男子。如故堤塘穿决有孔水则淋漏。何以故。无人治故。若有人治水则不出。菩萨亦尔。虽与破戒共作布萨。受戒自恣同其僧事所有戒律。不如堤塘穿决淋漏。何以故。若无清净持戒之人。僧则损减纵缓懈怠日有增长。若有清净持戒之人。即能具足不失本戒。善男子。于乘缓者乃名为缓。于戒缓者不名为缓。菩萨摩诃萨于此大乘心不懈慢。是名奉戒。为护正法以大乘水而自澡浴。是故菩萨虽现破戒不名为缓。迦叶菩萨白佛言。佛僧之中有四种人。如庵罗果生熟难知。破戒持戒云何可识佛言。善男子。因大涅槃微妙经典则易可知。云何因是大涅槃经可得知耶。譬如田夫种殖稻谷耘除莠稗以肉眼观名为净田。至其成实叶谷各异。如是八事能污染僧。若能除却以肉眼观则知清净。若持戒若破戒不作恶时。以肉眼观难可分别。若恶彰露则易可知。如彼莠稗易可分别。僧中亦尔。若能远离八种不净毒蛇之法。是名清净圣众福田。应为人天之所供养。清净果报非是肉眼所能分别。复次善男子。如迦罗迦林其树众多。于是林中唯有一树名镇头迦。是迦罗迦树镇头迦树。二果相似不可分别。其果熟时有一女人悉皆拾取。镇头迦果才有一分。迦罗迦果乃有十分。是女不识赍来诣市而炫卖之。凡愚小儿复不别故。买迦罗迦果啖已命终。有智人辈闻是事已。即问女人姊于何处得是果来。是时女人即示方所。诸人即言。如是方所多有无量迦罗迦树。唯有一根镇头迦树。诸人知已笑而舍去。善男子。大众之中八不净法。亦复如是。于是众中多有受用如是八法。唯有一人清净持戒不受如是八不净法。善知诸人受畜非法。而与同事不相舍离。如彼林中一镇头迦树。有优婆塞见是诸人多有非法。并不恭敬供养是人。若欲供养应先问言。大德。如是八事为受畜不。佛所听不。若言佛听。如是之人得共布萨羯磨自恣不。是优婆塞。如是问已。众皆答言。如是八事如来怜愍皆悉听畜。优婆塞言。祇洹精舍有诸比丘。或言金银佛所听畜。或言不听有言听者。是不听者不与共住说戒自恣。乃至不共一河饮水。利养之物悉不共之。汝等云何言佛听许。佛天中天虽复受之。汝等众僧亦不应畜。若有受者。乃至不应与共说戒自恣羯磨同其僧事。若共说戒自恣羯磨同僧事者。命终即当堕于地狱。如彼诸人食迦罗果已而便命终

复次善男子。譬如城市有卖药人。有妙甘药出于雪山。亦复多卖其余杂药味甘相似。时有诸人咸皆欲买而不识别。至卖药所问言。汝有雪山药不。其卖药人即答言。有。是人欺诈以余杂药。语买者言。此是雪山甘好妙药。时买药者以肉眼故。不能善别即买持归。便作是念。我今已得雪山甘药。迦叶。若声闻僧中。有假名僧有真实僧有和合僧。若持戒若破戒。于是众中等应供养恭敬礼拜。是优婆塞以肉眼故不能分别。譬如彼人不能分别雪山甘药。谁是持戒谁是破戒。谁是真僧谁是假僧。有天眼者乃能分别。迦叶。若优婆塞知是比丘是破戒人。不应给施礼拜供养。若知是人受畜八法。亦复不应给施所须礼拜供养。若于僧中有破戒者。不应以被袈裟因缘恭敬礼拜迦叶菩萨复白佛言。世尊。善哉善哉。如来所说真实不虚。我当顶受。譬如金刚珍宝异物。如佛所说是诸比丘当依四法。何等为四。依法不依人。依义不依语。依智不依识。依了义经不依不了义经。如是四法应当证知非四种人

佛言。善男子。依法者。即是如来大般涅槃。一切佛法即是法性。是法性者即是如来。是故如来常住不变。若复有言如来无常。是人不知不见法性。若不知见是法性者。不应依止。如上所说四人出世护持法者。应当证知而为依止。何以故。是人善解如来微密深奥藏故。能知如来常住不变。若言如来无常变易无有是处。如是四人即名如来。何以故。是人能解如来密语及能说故。若有人能了知如来甚深密藏。及知如来常住不变。如是之人若为利养。说言如来是无常者无有是处。如是之人尚可依止。何况不依是四种人。依法者即是法性。不依人者即是声闻。法性者即是如来。声闻者即是有为。如来者即是常住。有为者即是无常。善男子。若人破戒为利养故。说言如来无常变易。如是之人所不应依。善男子。是名定义

依义不依语者。义者名曰觉了。觉了义者名不羸劣。不羸劣者名曰满足。满足义者名曰如来常住不变。如来常住不变义者即是法常。法常义者即是僧常。是名依义不依语也。何等语言所不应依。所谓诸论绮饰文辞。如佛所说无量诸经。贪求无厌奸巧谀谄。诈现亲附现相求利。经理白衣为其执役。又复唱言佛听比丘畜诸奴婢不净之物金银珍宝谷米仓库牛羊象马贩卖求利。于饥馑世怜愍子故。复听比丘储贮陈宿手自作食不受而啖。如是等语所不应依

依智不依识者。所言智者即是如来。若有声闻不能善知如来功德。如是之识。不应依止。若知如来即是法身。如是真智所应依止。若见如来方便之身。言是阴界诸入所摄食所长养。亦不应依。是故知识不可依止。若复有人作是说者。及其经书亦不应依。依了义经不依不了义经者。不了义者谓声闻乘。闻佛如来深密藏处悉生疑怪。不知是藏出大智海。犹如婴儿无所别知。是则名为不了义也

了义者名为菩萨真实智慧。隐其自心无碍大智。犹如大人无所不知。是名了义。又声闻乘名不了义。无上大乘乃名了义。若言如来无常变易。名不了义。若言如来常住不变。是名了义。声闻所说应证知者。名不了义。菩萨所说应证知者。名为了义。若言如来食所长养。是不了义。若言常住不变易者。是名了义。若言如来入于涅槃如薪尽火灭。名不了义。若言如来入法性者。是名了义。声闻乘法则不应依。何以故。如来为欲度众生故。以方便力说声闻乘。犹如长者教子半字。善男子。声闻乘者犹如初耕未得果实。如是名为不了义也。是故不应依声闻乘。大乘之法则应依止。何以故。如来为欲度众生故。以方便力说于大乘。是故应依。是名了义。如是四依应当证知

复次依义者义名质直。质直者名曰光明。光明者名不羸劣。不羸劣者名曰如来。又光明者名为智慧。质直者名为常住

如来常者名为依法。法者名常。亦名无边。不可思议不可执持不可系缚。而亦可见。若有说言不可见者。如是之人所不应依。是故依法不依于人。若复有人以微妙语宣说无常。如是之言所不应依。是故依义不依于语。依智者。众僧是常无为不变。不畜八种不净之物。是故依智不依于识。若有说言识作识受无和合僧。何以故。夫和合者名无所有。无所有者云何言常。是故此识不可依止

依了义者。了义者名为知足。终不诈现威仪清白憍慢自高贪求利养。亦于如来随宜方便所说法中不生执着。是名了义。若有能住如是等中。当知是人则为已得住第一义。是故名为依了义经不依不了义不了义者如经中说一切烧燃一切无常一切皆苦一切皆空一切无我。是名不了义。何以故。以不能了如是义故。令诸众生堕阿鼻狱。所以者何。以取着故于义不了。一切烧者。谓如来说涅槃亦烧。一切无常者。涅槃亦无常。苦空无我亦复如是。是故名为不了义经不应依止。善男子。若有人言。如来怜愍一切众生善知时宜。以知时故说轻为重说重为轻。如来观知所有弟子。有诸檀越供给所须令无所乏。如是之人佛则不听受畜奴婢金银财宝贩卖市易不净物等。若诸弟子无有檀越供给所须。时世饥馑饮食难得。为欲建立护持正法。我听弟子受畜奴婢金银车乘田宅谷米卖易所须虽听受畜如是等物。要当净施笃信檀越。如是四法所应依止。若有戒律阿毗昙修多罗。不违是四亦应依止。若有说言有时非时有能护法不能护法。如来悉听一切比丘受畜如是不净物者。如是之言不应依止。若有戒律阿毗昙修多罗中有同是说。如是三分亦不应依。我为肉眼诸众生等说是四依。终不为于有慧眼者。是故我今说是四依。法者即是法性。义者即是如来常住不变。智者知一切众生悉有佛性。了义者了达一切大乘经典

大般涅槃经卷第六大般涅槃经卷第七

        宋代沙门慧严等依泥洹经加之

    邪正品第九

尔时迦叶白佛言。世尊。如上所说四种人等应当依止耶

佛言。如是如是。善男子。如我所说应当依止。何以故。有四魔故。何等为四。如魔所说诸余经律能受持者

迦叶菩萨白佛言。世尊。如佛所说有四种魔。若魔所说及佛所说。我当云何而得分别。有诸众生随逐魔行。复有随顺佛所教者。如是等辈复云何知。佛告迦叶。我般涅槃七百岁后。是魔波旬渐当坏乱我之正法。譬如猎师身服法衣。魔王波旬亦复如是。作比丘像比丘尼像优婆塞像优婆夷像。亦复化作须陀洹身。乃至化作阿罗汉身及佛色身。魔王以此有漏之形作无漏身。坏我正法。是魔波旬坏正法时。当作是言。菩萨昔于兜率天上没。来在此迦毗罗城白净王宫。依因父母爱欲和合生育是身。若言有人生于人中为诸世间天人大众所恭敬者。无有是处。又复说言往昔苦行种种布施头目髓脑国城妻子。是故今者得成佛道。以是因缘为诸人天乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽之所恭敬。若有经律作是说者。当知悉是魔之所说

善男子。若有经律作如是言。如来正觉久已成佛。今方示现成佛道者。为欲度脱诸众生故。示有父母依因爱欲和合而生。随顺世间作是示现。如是经律当知真是如来所说。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。即是菩萨

若有说言如来生时于十方面各行七步不可信者。是魔所说

若复有说如来出世于十方面各行七步此是如来方便示现。是名如来所说经律。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。即是菩萨。若有说言。菩萨生已父王使人将诣天祠。诸天见已悉下礼敬。是故名佛。复有难言天者先出佛在其后。云何诸天礼敬于佛。作是难者当知即是波旬所说

若有经言佛到天祠。是诸天等摩醯首罗大梵天王释提桓因。皆悉合掌敬礼其足如是经律是佛所说。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。即是菩萨若有经律说言菩萨为太子时以欲心故四方娉妻。处在深宫五欲自娱欢悦受乐。如是经律波旬所说

若有说言菩萨久已舍离欲心妻息之属。乃至不受三十三天上妙五欲如弃涕唾。何况人欲。剃除须发出家修道。如是经律是佛所说。若有随顺魔经律者。是魔眷属。若有随顺佛经律者。即是菩萨

若有说言佛在舍卫只陀精舍。听诸比丘受畜奴婢仆使牛羊象马驴骡鸡猪猫狗金银琉璃真珠玻璃车磲玛瑙珊瑚虎珀珂贝璧玉铜铁釜鍑大小铜盘所须之物。耕田种植贩卖市易储积谷米。如是众事佛大慈故。怜愍众生皆听畜之。如是经律悉是魔说若有说言佛在舍卫只陀精舍那梨楼鬼所住之处。尔时如来因婆罗门字羖羝德及波斯匿王。说言比丘。不应受畜金银琉璃颇梨真珠车磲马瑙珊瑚虎珀珂贝璧玉奴婢仆使童男童女牛羊象马驴骡鸡猪猫狗等兽铜铁釜鍑大小铜盘种种杂色床敷卧具资生所须。所谓屋宅耕田种植。贩卖市易自手作食自磨自舂。治身咒术调鹰方法。仰观星宿推步盈虚。占相男女解梦吉凶。是男是女非男非女六十四能。复有十八惑人咒术种种工巧。或说世间无量俗事。散香末香涂香薰香。种种花鬘治发方术。奸伪谄曲贪利无厌。爱乐愦闹戏笑谈说。贪嗜鱼肉。和合毒药治压香油。捉持宝盖及以革屣。造扇箱箧种种画像。积聚谷米大小麦豆及诸果蓏。亲近国王王子大臣及诸女人。高声大笑或复默然。于诸法中多生疑惑。多语妄说长短好丑或善不善。好着好衣。如是种种不净之物。于施主前躬自赞叹。出入游行不净之处。所谓沽酒淫女博奕。如是之人我今不听在比丘中。应当休道还俗役使。譬如莠稗悉灭无余。当知是等经律所制。悉是如来之所说也。若有随顺魔所说者。是魔眷属。若有随顺佛所说者。即是菩萨

若有说言菩萨为欲供养天神故入天祠。所谓梵天大自在天违陀天迦旃延天。所以入者。为欲调伏诸天人故。若言不尔无有是处。若言菩萨不能入于外道邪论。知其威仪文章伎艺。仆使斗诤不能和合。不为男女国王大臣之所恭敬。又亦不知和合诸药。以不知故乃名如来。如其知者是邪见辈。又复如来于怨亲中其心平等。如以刀割及香涂身。于此二人不生增益损减之心。唯能处中故名如来。如是经律当知是魔之所说也

若有说言。菩萨如是示入天祠外学法中出家修道。示现知其威仪礼节能解一切文章伎艺。示入书堂伎巧之处。能善和合仆使斗诤。于诸大众童男童女后宫妃后人民长者婆罗门等王及大臣贫穷等中。最尊最上。复为是等之所恭敬。亦能示现如是等事。虽处诸见不生爱心。犹如莲花不受尘垢。为度一切诸众生故。善行如是种种方便随顺世法。如是经律当知即是如来所说。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。是大菩萨。若有说言如来为我解说经律。若恶法中轻重之罪。及偷兰遮其性皆重。我等律中终不为之。我久忍受如是之法汝等不信。我当云何自舍己律就汝律耶。汝所有律是魔所说。我等经律是佛所制。如来先说九部法印。如是九印印。我经律。初不闻有方等经典一句一字。如来所说无量经律。何处有说方等经耶。如是等中未曾闻有十部经名。如其有者。当知必定调达所作。调达恶人以灭善法造方等经。我等不信如是等经是魔所说。何以故。破坏佛法相是非故。如是之言。汝经中有。我经中无。我经律中如来说言。我涅槃后恶世当有不正经律。所谓大乘方等经典。未来之世当有如是诸恶比丘。我又说言。过九部经有方等典。若有人能了知其义。当知是人正了经律。远离一切不净之物。微妙清净犹如满月。若有说言如来虽为一一经律演说义味如恒沙等。我律中无将知为无。如其有者。如来何故于我律中而不解说。是故我今不能信受。当知是人则为得罪。是人复言。如是经律我当受持。何以故。当为我作知足少欲断除烦恼智慧涅槃善法因故。如是说者非我弟子

若有说言如来为欲度众生故说方等经。当知是人真我弟子。若有不受方等经者。当知是人非我弟子。不为佛法而出家也。即是邪见外道弟子。如是经律是佛所说。若不如是是魔所说。若有随顺魔所说者。是魔眷属。若有随顺佛所说者。即是菩萨

复次善男子。若有说言如来不为无量功德之所成就。无常变异。以得空法宣说无我不顺世间。如是经律名魔所说

若有人言如来正觉不可思议。亦为无量阿僧祇等功德所成。是故常住无有变异。如是经律是佛所说。若有随顺魔所说者。是魔眷属。若有随顺佛所说者。即是菩萨复有人言。或有比丘实不毁犯波罗夷罪。众人皆谓犯波罗夷如断多罗树。而是比丘实无所犯。何以故。我常说言。四波罗夷若犯一者。犹如析石不可还合。若有自说得过人法。是则名为犯波罗夷。何以故。实无所得诈现得相故。如是之人退失人法。是名波罗夷。所谓若有比丘少欲知足。持戒清净住空闲处。若王大臣见是比丘。心生念言谓得罗汉。即前赞叹恭敬礼拜。复作是言。如是大师舍是身已。当得阿耨多罗三藐三菩提。比丘闻已即白王言。我实未得沙门道果。王莫称我已得道果。唯愿大王。勿为我说不知足法。不知足者。乃至谓得阿耨多罗三藐三菩提。皆默然受。我今若当默然受者。当为诸佛之所呵责。知足之行诸佛所赞。是故我欲终身欢乐奉修知足。又知足者。我定自知未得道果。王称我得我今不受。故名知足。时王答言。大师实得阿罗汉果如佛无异。尔时其王普皆宣告。内外人民中宫妃后。悉令皆知得沙门果。是故咸令一切闻者心生敬信供养尊重。如是比丘真是梵行清净之人。以是因缘普令诸人得大福德。而是比丘实不毁犯波罗夷罪。何以故。前人自生欢喜之心。赞叹供养故。如是比丘当有何罪。若有说言是人得罪。当知是经是魔所说

复有比丘说佛秘藏甚深经典。一切众生皆有佛性。以是性故断无量亿诸烦恼结。即得成于阿耨多罗三藐三菩提。除一阐提。若王大臣。作如是言。比丘汝当作佛不作佛耶。有佛性不。比丘答言。我今身中定有佛性。成以不成未能审之。王言大德。如其不作一阐提者。必成无疑。比丘言。尔实如王言。是人虽言定有佛性。亦复不犯波罗夷罪。复有比丘即出家时作是思惟。我今必定成阿耨多罗三藐三菩提。如是之人虽未得成无上道果。已为得福无量无边不可称计。假使有人当言是人犯波罗夷。一切比丘无不犯者。何以故。我于往昔八十亿劫。常离一切不净之物。少欲知足威仪成就。善修如来无上法藏。亦自定知身有佛性。是故我今得成阿耨多罗三藐三菩提。得名为佛有大慈悲。如是经律是佛所说。若有不能随顺是者。是魔眷属。若能随顺是大菩萨

复有说言无四波罗夷。十三僧残。二不定法。三十舍堕。九十一堕。四忏悔法。众多学法。七灭诤等无偷兰遮。五逆等罪及一阐提。若有比丘犯如是等堕地狱者。外道之人悉应生天。何以故。诸外道等无戒可犯。此是如来示现怖人故说斯戒。若言佛说我诸比丘若欲行淫应舍法服着俗衣裳然后行淫。复应生念淫欲因缘非我过咎。如来在世亦有比丘。习行淫欲得正解脱。或命终后生于天上。古今有之非独我作。或犯四重。或犯五戒。或行一切不净律仪。犹故得具真正解脱。如来虽说犯突吉罗如忉利天日月岁数八百万岁堕在地狱。是亦如来示现怖人。言波罗夷至突吉罗轻重无差。是诸律师妄作此言。言是佛制。毕定当知非佛所说。如是言说是魔经律。若复说言。于诸戒中若犯小戒。乃至细微当受苦报无有齐限。如是知已。防护自身如龟藏六。若有律师复作是言。凡所犯戒都无罪报。如是之人不应亲近。如佛所说

  若过一法　　是名妄语　　不见后世
  无恶不造

是故不应亲近是人。我佛法中清净如是。况复有犯偷兰遮罪。或犯僧残及波罗夷而非罪耶。是故应当深自防护如是等法。若不守护。更以何法名为禁戒。我于经中。亦说有犯四波罗夷乃至微细突吉罗等应当苦治。众生若不护持禁戒。云何当得见于佛性。一切众生虽有佛性。要因持戒然后乃见。因见佛性得成阿耨多罗三藐三菩提。九部经中无方等经。是故不说有佛性耳。经虽不说当知实有。若作是说。当知是人真我弟子

迦叶菩萨白佛言。世尊。如上所说。一切众生有佛性者。九部经中所未曾闻。如其说有。云何不犯波罗夷耶

佛言。善男子。如汝所说。实不毁犯波罗夷罪。善男子。譬如有人说言大海唯有七宝无八种者。是人无罪。若有说言九部经中无佛性者。亦复无罪。何以故。我于大乘大智海中说有佛性。二乘之人所不知见。是故说无。无有罪也。如是境界诸佛所知。非是声闻缘觉所及。善男子。若人不闻如来甚深秘密藏者。云何当知有佛性耶。何等名为秘密之藏。所谓方等大乘经典。善男子。有诸外道。或说我常或说我断。如来不尔。亦说有我亦说无我。是名中道。若有说言佛说中道一切众生悉有佛性。烦恼覆故不知不见。是故应当勤修方便断坏烦恼。若有能作如是说者。当知是人不犯四重。若有不作如是说者。是则名为犯波罗夷。若有说言我已成就阿耨多罗三藐三菩提。何以故。以有佛性故。有佛性者必定当成阿耨多罗三藐三菩提。以是因缘我今已得成就菩提。当知是人则名为犯波罗夷罪。何以故。虽有佛性以未修习诸善方便。是故未见。以未见故不能得成阿耨多罗三藐三菩提。善男子。以是义故。佛法甚深不可思议。迦叶菩萨白佛言。世尊。有王问言。云何比丘堕过人法

佛告迦叶。若有比丘为利养故。为饮食故。作诸谀谄奸伪欺诈。云何当令诸世间人定实知我是真乞士。以是因缘。令我大得利养名誉。如是比丘多愚痴故。长夜常念。我实未得四沙门果。云何当令诸世间人。谓我已得。复当云何令诸优婆塞优婆夷等。咸共指我作如是言。是人福德真是圣人。如是思惟。专为求利非为求法。行来出入进止安详执持衣钵不失威仪。独坐空处如阿罗汉。令世间人咸作是言。如是比丘。善好第一。精勤苦行修寂灭法。以是因缘。我当大得门徒弟子。诸人亦当大致供养衣服饮食卧具医药。令多女人敬念爱重。若有比丘及比丘尼。作如是事堕过人法。复有比丘。为欲建立无上正法住空闲处。非阿罗汉。而欲令人谓是罗汉是好比丘是善比丘寂静比丘。令无量人生于信心。以此因缘。我得无量诸比丘等以为眷属。因是得教破戒比丘及优婆塞悉令持戒。以是因缘建立正法。光扬如来无上大义。开显方等大乘法化。度脱一切无量众生。善解如来所说经律轻重之义。复言。我今亦有佛性。有经名曰如来秘藏。于是经中我当必定得成佛道。能尽无量亿烦恼结。广为无量诸优婆塞。说言。汝等尽有佛性。我与汝等俱当安住如来道地。成阿耨多罗三藐三菩提。尽无量亿诸烦恼结。作是说者。是人不名堕过人法。名为菩萨。若言有犯突吉罗者。忉利天上日月岁数八百万岁。堕地狱中受诸罪报。何况故犯偷兰遮罪。此大乘中若有比丘犯偷兰遮不应亲近。何等名为大乘经中偷兰遮罪。若有长者。造立佛寺以诸花鬘用供养佛。有比丘见花贯中缕不问辄取。名偷兰遮。若知不知亦如是犯。若以贪心破坏佛塔犯偷兰遮。如是之人不应亲近。若王大臣见塔朽故。为欲修补供养舍利。于是塔中。或得珍宝即寄比丘。比丘得已自在而用。如是比丘名为不净。多起斗诤。善优婆塞不应亲近供养恭敬。如是比丘名为无根。名为二根。名不定根。不定根者。欲贪女时身即为女。欲贪男时身即为男。如是比丘名为恶根。不名为男不名为女。不名出家不名在家。如是比丘不应亲近供养恭敬。于佛法中沙门法者。应生悲心覆育众生。乃至螘子应施无畏。是沙门法。远离饮酒乃至嗅香。是沙门法。不得妄语乃至梦中不念妄语。是沙门法。不生欲心乃至梦中。亦复如是。是沙门法

迦叶菩萨白佛言。世尊。若有比丘梦行淫欲。是犯戒不

佛言不也。应于淫欲生臭秽想乃至不生一念净想。远离女人烦恼爱想。若梦行淫寤应生悔。比丘乞食受供养时。应如饥世食子肉想。若生淫欲应疾舍离。如是法门当知是佛所说经律。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。是名菩萨。若有说言佛听比丘。常翘一脚寂默不言。投渊。赴火。自坠高岩不避险难。服毒断食。卧灰土上。自缚手足。杀害众生方道咒术。旃陀罗子无根二根及不定根身根不具。如是等辈。如来悉听出家为道。是名魔说。佛先听食五种牛味及以油蜜憍奢耶衣革屣等物。除是之外。若有说言听着摩诃楞伽。一切种子悉听贮畜。草木之属皆有寿命。佛说是已便入涅槃。若有经律作是说者。当知即是魔之所说。我亦不听常翘一脚。若为法故听行住坐卧。又亦不听服毒断食五热炙身。系缚手足杀害众生方道咒术。珂贝象牙以为革屣储畜种子草木有命。着摩诃楞伽若言世尊。作如是说当知是为外道眷属。非我弟子。我唯听食五种牛味及油蜜等。听着革屣憍奢耶衣。我说四大无有寿命。若有经律作是说者。是名佛说。若有随顺佛所说者。当知是等真我弟子。若有不随佛所说者是魔眷属。若有随顺佛经律者。当知是人是大菩萨。善男子。魔说佛说差别之相。今已为汝广宣分别。迦叶白佛言。世尊。我今始知魔说佛说差别之相。因是得入佛法深义。佛赞迦叶。善哉善哉。善男子。汝能如是晓了分别。是名黠慧

    大般涅槃经四谛品第十

佛复告迦叶。所言苦者不名苦圣谛。何以故。若言苦是苦圣谛者。一切畜生及地狱众生应有圣谛。善男子。若复有人。不知如来甚深境界常住不变微密法身。谓是食身非是法身。不知如来道德威力。是名为苦。何以故。以不知故。法见非法非法见法。当知是人必堕恶趣轮转生死。增长诸结多受苦恼。若有能知如来常住无有变异。或闻常住二字音声。若一经耳。即生天上。后解脱时乃能证知如来常住无有变易。既证知已。而作是言。我于往昔曾闻是义。今得解脱方乃证知。我于本际以不知故。轮转生死周回无穷。始于今日乃得真智。若如是知真是修苦多所利益。若不知者虽复勤修无所利益。是名知苦名苦圣谛。若人不能如是修习。是名为苦非苦圣谛。苦集谛者。于真法中不生真智。受不净物。所谓奴婢。能以非法言是正法。断灭正法不令久住。以是因缘不知法性。以不知故。轮转生死多受苦恼。不得生天及正解脱。若有深知不坏正法。以是因缘得生天上及正解脱。若有不知苦集谛处。而言正法无有常住悉是灭法。以是因缘于无量劫。流转生死受诸苦恼。若能知法常住不异。是名知集名集圣谛。若人不能如是修习。是名为集非集圣谛。苦灭谛者。若有多修习学空法。是为不善何以故。灭一切法故。坏于如来真法藏故。作是修学是名修空。修苦灭者。逆于一切诸外道等。若言修空是灭谛者。一切外道亦修空法应有灭谛。若有说言。有如来藏虽不可见。若能灭除一切烦恼尔乃得入。若发此心一念因缘。于诸法中而得自在。若有修习如来密藏。无我空寂。如是之人于无量世在生死中流转受苦。若有不作如是修者。虽有烦恼疾能灭除。何以故。因知如来秘密藏故。是名苦灭圣谛。若能如是修习灭者。是我弟子。若有不能作如是修。是名修空非灭圣谛。道圣谛者。所谓佛法僧宝及正解脱。有诸众生颠倒心。言无佛法僧及正解脱。生死流转犹如幻化。修习是见。以此因缘轮转三有久受大苦。若能发心见于如来常住无变。法僧解脱亦复如是。乘此一念于无量世。自在果报随意而得。何以故。我于往昔以四倒故非法计法。受于无量恶业果报。我今已灭如是见故成佛正觉。是名道圣谛。若有人言三宝无常。修习是见。是虚妄修非道圣谛。若修是法为常住者。是我弟子真见修习四圣谛法。是名四圣谛。迦叶菩萨白佛言。世尊。我今始知修习甚深四圣谛法

    大般涅槃经四倒品第十一

佛告迦叶。善男子。谓四倒者。于非苦中生于苦想。名曰颠倒。非苦者名为如来。生苦想者。谓诸如来无常变异。若说如来是无常者。名大罪苦。若言如来舍此苦身。入于涅槃如薪尽火灭。是名非苦而生苦想。是名颠倒。我若说言如来常者。即是我见。以我见故有无量罪。是故应说如来无常。如是说者我则受乐。如来无常即为是苦。若是苦者云何生乐。以于苦中生乐想故。名为颠倒。乐生苦想名为颠倒。乐者即是如来。苦者如来无常。若说如来是无常者。是名乐中生于苦想。如来常住是名为乐若我说言如来是常。云何复得入于涅槃。若言如来非是苦者。云何舍身而取灭度以于乐中生苦想故。名为颠倒。是名初倒。无常常想常无常想。是名颠倒。无常者名不修空。不修空故寿命短促若有说言不修空寂得长寿者。是名颠倒。是名第二颠倒。无我我想我无我想。是名颠倒。世间之人亦说有我。佛法之中亦说有我。世间之人虽说有我无有佛性。是则名为于无我中而生我想。是名颠倒。佛法有我即是佛性。世间之人说佛法无我。是名我中生无我想。若言佛法必定无我是故如来敕诸弟子。修习无我名为颠倒。是名第三颠倒净不净想。不净净想是名颠倒。净者即是如来常住。非杂食身非烦恼身非是肉身。非是筋骨系缚之身。若有说言如来无常是杂食身。乃至筋骨系缚之身。法僧解脱是灭尽者。是名颠倒。不净净想名颠倒者。若有说言。我此身中无有一法。是不净者。以无不净定当得入清净之处。如来所说修不净观。如是之言是虚妄说是名颠倒。是则名为第四颠倒迦叶菩萨白佛言。世尊。我从今日始得正见。世尊。自是之前。我等悉名邪见之人

大般涅槃经卷第七大般涅槃经卷第八

        宋代沙门慧严等依泥洹经加之

    如来性品第十二

迦叶白佛言。世尊。二十五有有我不耶。佛言。善男子。我者即是如来藏义。一切众生悉有佛性。即是我义。如是我义从本已来。常为无量烦恼所覆。是故众生不能得见。善男子。如贫女人舍内多有真金之藏。家人大小无有知者。时有异人善知方便语贫女言。我今雇汝。汝可为我耘除草秽。女即答言。我今不能。汝若能示我子金藏。然后乃当速为汝作。是人复言。我知方便能示汝子。女人答言。我家大小尚自不知。况汝能知。是人复言。我今审能。女人答言。我亦欲见并可示我。是人即于其家掘出金藏。女人见已心生欢喜。生奇特想宗仰是人。善男子。众生佛性亦复如是。一切众生不能得见。如彼宝藏贫人不知。善男子。我今普示一切众生所有佛性为诸烦恼之所覆蔽。如彼贫人有真金藏不能得见。如来今日普示众生诸觉宝藏。所谓佛性。一切众生见是事已。心生欢喜归仰如来。善方便者即是如来。贫女人者即是一切无量众生。真金藏者即佛性也

复次善男子。譬如女人生育一子婴孩得病。是女愁恼求觅良医。良医既至合三种药酥乳石蜜与之令服。因告女人儿服药已且莫与乳。须药消已尔乃与之。是时女人即以苦味用涂其乳。语其儿言。我乳毒涂不可复触。小儿渴乏欲得母乳。闻乳毒气便远舍去。至其药消母乃洗乳唤子与之。是时小儿虽复饥渴。先闻毒气是故不来。母复语言。为汝服药故以毒涂。汝药已消我已洗竟。汝便可来饮乳无苦。其儿闻已渐渐还饮。善男子。如来亦尔。为度一切教诸众生修无我法。如是修已永断我心入于涅槃。为除世间诸妄见故。示现出过世间法故。复示世间计我虚妄非真实故。修无我法清净身故。譬如女人为其子故以苦味涂乳。如来亦尔。为修空故说言诸法悉无有我。如彼女人净洗乳已而唤其子欲令还服。我今亦尔说如来藏。是故比丘不应生怖。如彼小儿闻母唤已渐还饮乳。比丘亦尔。应自分别如来秘藏。不得不有

迦叶菩萨白佛言。世尊。实无有我。何以故。婴儿生时无所知晓。若有我者即生之日寻应有知。以是义故定知无我。若定有我受生已后应无终没。若使一切皆有佛性是常住者应无坏相。若无坏相云何而有刹利婆罗门毗舍首陀及旃陀罗畜生差别。今见业缘种种不同诸趣各异。若定有我一切众生应无胜负。以是义故定知佛性非是常法。若言佛性定是常者。何缘复说有杀盗淫两舌恶口妄言绮语贪恚邪见。若我性常。何故酒后荒醉迷乱。若我性常。盲应见色。聋应闻声。哑应能语。拘躄能行。若我性常。不应避于火坑大水毒药刀剑恶人禽兽。若我常者。本所更事不应忘失。若不忘失。何缘复言我曾何处见是人耶。若我常者。则不应有老少盛衰忆念往事。若我常者止住何处。为在涕唾青黄赤白诸色中耶。若我常者应遍身中如胡麻油间无空处。若断身时我亦应断。佛告迦叶。善男子。譬如王家有大力士。其人眉间有金刚珠。与余力士捔力相扑。而彼力士以头触之其额上珠寻没肤中。都不自知是珠所在。其处有疮。即命良医欲自疗治。时有明医善知方药。即知是疮因珠入体。是珠入皮即便停住。是时良医寻问力士。卿额上珠为何所在。力士惊答。大师医王。我额上珠乃失去耶。是珠今者为何所在。将非幻化。忧愁啼哭。是时良医慰喻力士。汝今不应生大愁苦。汝因斗时宝珠入体。今在皮里影现于外。汝等斗时嗔恚毒盛。珠陷入体故不自知。是时力士不信医言。若在皮里脓血不净何缘不出。若在筋里不应可见。汝今云何欺诳于我。时医执镜以照其面。珠在镜中明了显现。力士见已心怀惊怪生奇特想。善男子。一切众生亦复如是。不能亲近善知识故。虽有佛性皆不能见。而为贪淫嗔恚愚痴之所覆蔽。故堕地狱畜生饿鬼阿修罗旃陀罗刹利婆罗门毗舍首陀。生如是等种种家中。因心所起种种业缘。虽受人身聋盲喑哑拘躄癃跛。于二十五有受诸果报。贪淫嗔恚愚痴覆心不知佛性。如彼力士宝珠在体谓呼失去。众生亦尔不知亲近善知识故。不识如来微密宝藏。修学无我譬如非圣虽说有我亦复不知我之真性。我诸弟子亦复如是。不知亲近善知识故。修学无我。亦复不知无我之处。尚自不知无我真性。况复能知有我真性。善男子。如来如是说诸众生皆有佛性。譬如良医示彼力士金刚宝珠。是诸众生为无量亿诸烦恼等之所覆蔽。不识佛性。若尽烦恼尔时乃得证知明了。如彼力士于明镜中见其宝珠。善男子。如来秘藏如是无量不可思议

复次善男子。譬如雪山有一味药。名曰乐味。其味极甜。在深丛下人无能见。有人闻香即知其地当有是药。过去世中有转轮王。于彼雪山为此药故。在在处处造作木筒以接是药。是药熟时从地流出集木筒中。其味真正。王既没已。其后是药或醋或碱或甜或苦或辛或淡如是一味随其流处。有种种异。是药真味停留在山犹如满月。凡人薄福虽以掘凿加功苦至而不能得。复有圣王出现于世。以福因缘即得是药真正之味。善男子。如来秘藏其味亦尔。为诸烦恼丛林所覆。无明众生不能得见。药一味者譬如佛性。以烦恼故出种种味。所谓地狱畜生饿鬼。天人男女非男非女。刹利婆罗门毗舍首陀。佛性雄猛难可毁坏。是故无有能杀害者。若有杀者则断佛性。如是佛性终不可断。性若可断无有是处。如我性者即是如来秘密之藏。如是秘藏一切无能毁坏烧灭。虽不可坏然不可见。若得成就阿耨多罗三藐三菩提尔乃证知。以是因缘无能杀者

迦叶菩萨复白佛言。世尊。若无杀者应当无有不善之业

佛告迦叶。实有杀生。何以故。善男子。众生佛性住五阴中。若坏五阴名曰杀生。若有杀生即堕恶趣。以业因缘而有刹利婆罗门等毗舍首陀及旃陀罗若男若女非男非女二十五有差别之相流转生死。非圣之人横计于我大小诸相犹如稗子。或如米豆乃至母指。如是种种妄生忆想。妄想之相无有真实。出世我相名为佛性。如是计我是名最善

复次善男子。譬如有人善知伏藏。即取利[钁-(目*目)+賏]掘地直下。磐石沙砾直过无难。唯至金刚不能穿彻。夫金刚者所有刀斧不能破坏。善男子。众生佛性亦复如是。一切论者天魔波旬及诸人天所不能坏。五阴之相即是起作。起作之相犹如石沙可穿可坏。佛性真我。譬如金刚不可毁坏。以是义故坏五阴者。名为杀生。善男子。必定当知佛法如是不可思议

善男子。方等经者犹如甘露亦如毒药。迦叶菩萨复白佛言。如来何缘说方等经譬如甘露亦如毒药

佛言。善男子。汝今欲知如来秘藏真实义不。迦叶白言。我今实欲得知如来秘藏之义。尔时世尊而说偈言

  或有服甘露　　伤命而早夭
  或复服甘露　　寿命得长存
  或有服毒生　　有缘服毒死
  无碍智甘露　　所谓大乘典
  如是大乘典　　亦名杂毒药
  如酥醍醐等　　及以诸石蜜
  服消则为药　　不消则为毒
  方等亦如是　　智者为甘露
  愚不知佛性　　服之则成毒
  声闻及缘觉　　大乘为甘露
  犹如诸味中　　乳最为第一
  如是勤进者　　依因于大乘
  得至于涅槃　　成人中象王
  众生知佛性　　犹如迦叶等
  无上甘露味　　不生亦不死
  迦叶汝今当　　善分别三归
  如是三归性　　则是我之性
  若能谛观察　　我性有佛性
  当知如是人　　得入秘密藏
  知我及我所　　是人已出世
  佛法三宝性　　无上第一尊
  如我所说偈　　其性义如是

尔时迦叶。复说偈言

  我今都不知　　归依三宝处
  云何当归趣　　无上无所畏
  不知三宝处　　云何作无我
  云何归佛者　　而得于安慰
  云何归依法　　唯愿为我说
  云何得自在　　云何不自在
  云何归依僧　　转得无上利
  云何真实说　　未来成佛道
  未来若不成　　云何归三宝
  我今无预知　　当行次第依
  云何未怀妊　　而作生子想
  若必在胎中　　则名为有子
  子若在胎中　　定当生不久
  是名为子义　　众生业亦然
  如佛之所说　　愚者不能知
  以其不知故　　轮回生死狱
  假名优婆塞　　不知真实义
  唯愿广分别　　除断我疑网
  如来大智慧　　唯垂哀分别
  愿说于如来　　秘密之宝藏
  迦叶汝当知　　我今当为汝
  善开微密藏　　令汝疑得断
  今当至心听　　汝于诸菩萨
  则与第七佛　　同其一名号
  归依于佛者　　真名优婆塞
  终不更归依　　其余诸天神
  归依于法者　　则离于杀害
  归依圣僧者　　不求于外道
  如是归三宝　　则得无所畏
  迦叶白佛言　　我亦归三宝
  是名为正路　　诸佛之境界
  三宝平等相　　常有大智性
  我性及佛性　　无二无差别
  是道佛所赞　　正进安止处
  亦名正遍见　　故为佛所称
  我亦趣善逝　　所赞无上道
  是最为甘露　　诸有所无有

尔时佛告迦叶菩萨。善男子。汝今不应如诸声闻凡夫之人分别三宝。于此大乘无有三归分别之相。所以者何。于佛性中即有法僧。为欲化度声闻凡夫。故分别说三宝异相。善男子。若欲随顺世间法者。则应分别有三归依。善男子。菩萨应作如是思惟。我今此身归依于佛。若即此身得成佛道。既成佛已不当恭敬礼拜供养于诸世尊。何以故。诸佛平等。等为众生作归依故。若欲尊重法身舍利。便应礼敬诸佛塔庙。所以者何。为欲化度诸众生故。亦令众生于我身中起塔庙想礼拜供养。如是众生以我法身为归依处。一切众生皆依非真邪伪之法。我当次第为说真法。又有归依非真僧者。我当为作依真僧处。若有分别三归依者。我当为作一归依处无三差别。于生盲众为作眼目。复当为诸声闻缘觉作真归处。善男子。如是菩萨为无量恶诸众生等及诸智者。而作佛事

善男子。譬如有人临阵战时即生心念。我于是中最为第一。一切兵众悉依恃我。亦如大子如是思惟。我当调伏其余王子绍继大王帝王之业而得自在。令诸王子悉见归依。是故不应生下劣心。如王王子大臣亦尔。善男子。菩萨摩诃萨亦复如是。作是思惟。云何三事与我一体。善男子。我示三事即是涅槃。如来者名无上士。譬如人身头最为上。非余支节手足等也。佛亦如是。最为尊上。非法僧也。为欲化度诸世间故。种种示现差别之相。如彼梯橙。是故汝今不应受持如凡愚人所知三归差别之相。汝于大乘猛利决断应如刚刀。迦叶菩萨白佛言。世尊。我知故问非为不知。我为菩萨大勇猛者。问于无垢清净行处。欲令如来为诸菩萨广宣分别奇特之事称扬大乘方等经典。如来大悲今已善说。我亦如是安住其中所说菩萨清净行处。即是宣说大涅槃经。世尊。我今亦当广为众生显扬如是如来秘藏。亦当证知真三归处。若有众生能信如是大涅槃经。其人则能自然了达三归依处。何以故。如来秘藏有佛性故。其有宣说是经典者。皆言身中尽有佛性。如是之人则不远求三归依处。何以故。于未来世我身即当成就三宝。是故声闻缘觉之人及余众生。皆依于我恭敬礼拜。善男子以是义故应当正学大乘经典。迦叶复言。佛性如是不可思议。三十二相八十种好亦不可思议

尔时佛赞迦叶菩萨。善哉善哉。善男子。汝已成就深利智慧。我今当更善为汝说入如来藏。若我住者即是常法不离于苦。若无我者修行净行无所利益。若言诸法皆无有我。是即断见。若言我住即是常见。若言一切行无常者。即是断见。诸行常者复是常见。若言苦者即是断见。若言乐者复是常见。修一切法常者堕于断见。修一切法断者堕于常见。如步屈虫要因前脚得移后足。修常断者亦复如是。要因断常。以是义故修余法苦者皆名不善。修余法乐者则名为善。修余法无我者是诸烦恼分。修余法常者是则名曰如来秘藏。所谓涅槃无有窟宅。修余无常法者即是财物。修余常法者谓佛法僧及正解脱。当知如是佛法中道。远离二边而说真法。凡夫愚人于中无疑。如羸病人服食酥已气力轻便。有无之法体性不定。譬如四大其性不同各自违反。良医善知随其偏发而消息之。善男子。如来亦尔。于诸众生犹如良医。知诸烦恼体相差别而为除断。开示如来秘密之藏。清净佛性常住不变。若言有者智不应染。若言无者即是妄语。若言有者不应默然。亦复不应戏论诤讼。但求了知诸法真性。凡夫之人戏论诤讼。不解如来微密藏故。若说于苦。愚人便谓身是无常。说一切苦。复不能知身有乐性。说无常者。凡夫之人计一切身皆是无常。譬如瓦坏。有智之人应当分别。不应尽言一切无常。何以故。我身即有佛性种子。若说无我。凡夫当谓一切佛法悉无有我。智者应当分别无我假名不实。如是知已不应生疑。若言如来秘藏空寂。凡夫闻之生断灭见。有智之人应当分别如来是常无有变易。若言解脱譬如幻化。凡夫当谓得真解脱即是磨灭。有智之人应当分别。人中师子虽有去来常住无变。若言无明因缘诸行。凡夫之人闻已分别生二法想。明与无明。智者了达其性无二。无二之性即是实性。若言诸行因缘识者。凡夫谓二。行之与识。智者了达其性无二。无二之性即是实性。若言十善十恶可作不可作善道恶道白法黑法。凡夫谓二。智者了达其性无二。无二之性即是实性。若言应修一切法苦。凡夫谓二。智者了达其性无二。无二之性即是实性。若言一切行无常者如来秘藏亦是无常。凡夫谓二。智者了达其性无二。无二之性即是实性。若言一切法无我如来秘藏亦无有我。凡夫谓二。智者了达其性无二。无二之性即是实性。我与无我性无有二。如来秘藏其义如是。不可称计无量无边诸佛所赞。我今于是一切功德成就经中皆悉说已

善男子。我与无我性相无二。汝应如是受持顶戴。善男子。汝亦应当坚持忆念如是经典。如我先于摩诃般若波罗蜜经中说我无我无有二相。如因乳生酪因酪得生酥因生酥得熟酥因熟酥得醍醐。如是酪性为从乳生。为从自生从他生耶。乃至醍醐亦复如是。若从他生。即是他作非是乳生。若非乳生乳无所为。若自生者。不应相似相续而生。若相续生则不俱生。若不俱生五种之味则不一时。虽不一时定复不从余处来也。当知乳中先有酪相。甘味多故不能自变。乃至醍醐亦复如是。是牛食啖水草因缘。血脉转变而得成乳若食甘草其乳则甜。若食苦草乳则苦味。雪山有草名曰肥腻。牛若食者纯得醍醐。无有青黄赤白黑色。谷草因缘其乳则有色味之异。是诸众生以明无明业因缘故生于二相。若无明转则变为明。一切诸法善不善等。亦复如是无有二相

迦叶菩萨白佛言。世尊。如佛所说乳中有酪。是义云何。世尊。若言乳中定有酪相以微细故不可见者。云何说言从乳因缘而生于酪。法若本无则名为生。如其已有云何言生。若言乳中定有酪相。百草之中亦应有乳。如是乳中亦应有草。若言乳中定无酪者。云何因乳而得生酪。若法本无而后生者。何故乳中不生于草

善男子。不可定言乳中有酪乳中无酪。亦不可说从他而生。若言乳中定有酪者。云何而得体味各异。是故不可说言乳中定有酪性。若言乳中定无酪者。乳中何故不生兔角。置毒乳中酪则杀人。是故不可说言乳中定无酪性。若言是酪从他生者。何故水中不生于酪。是故不可说言酪从他生。善男子。是牛食啖草因缘故血则变白。草血灭已众生福力变而成乳。是乳虽从草血而出不得言二。唯得名为从因缘生。酪至醍醐亦复如是。以是义故得名牛味。是乳灭已因缘成酪。何等因缘若酢若暖。是故得名从因缘有。乃至醍醐亦复如是。是故不得定言乳中无有酪相。从他生者离乳而有。无有是处。善男子。明与无明亦复如是。若与烦恼诸结俱者。名为无明若与一切善法俱者。名之为明。是故我言无有二相。以是因缘我先说言。雪山有草名曰肥腻。牛若食者即成醍醐。佛性亦尔善男子。众生薄福不见是草。佛性亦尔。烦恼覆故众生不见。譬如大海虽同一碱其中亦有上妙之水味同于乳。譬如雪山虽复成就种种功德多生诸药亦有毒草。诸众生身亦复如是。虽有四大毒蛇之种。其中亦有妙药大王。所谓佛性。非是作法。但为烦恼客尘所覆。若刹利婆罗门毗舍首陀能断除者。即见佛性成无上道。譬如虚空震雷起云一切象牙上皆生花。若无雷震花则不生亦无名字。众生佛性亦复如是。常为一切烦恼所覆不可得见。是故我说众生无我。若得闻是大般涅槃微妙经典。则见佛性如象牙花。虽闻契经一切三昧。不闻是经不知如来微妙之相。如无雷时象牙上花不可得见。闻是经已。即知一切如来所说秘藏佛性。譬如天雷见象牙花。闻是经已。即知一切无量众生皆有佛性。以是义故。说大涅槃名为如来秘密之藏。增长法身。犹如雷时象牙上花以能长养。如是大义。故得名为大般涅槃。若有善男子善女人。有能习学是大涅槃微妙经典。当知是人能报佛恩真佛弟子

迦叶菩萨白佛言。甚奇世尊。所言佛性甚深甚深难见难入。声闻缘觉所不能解佛言。善男子。如是如是。如汝所叹不违我说。迦叶菩萨白佛言。世尊。佛性者云何甚深难见难入

佛言。善男子。如百盲人为治目故造诣良医。是时良医即以金錍决其眼膜。以一指示问言见不。盲人答言。我犹未见。复以二指三指示之。乃言少见。善男子。是大涅槃微妙经典。如来未说亦复如是。无量菩萨虽具足行诸波罗蜜乃至十住。犹未能见所有佛性。如来既说即便少见。是菩萨摩诃萨萨既得见已。咸作是言。甚奇世尊。我等流转无量生死。常为无我之所惑乱。善男子。如是菩萨位阶十地。尚不明了知见佛性。何况声闻缘觉之人能得见耶。复次善男子。譬如仰观虚空鹅雁。为是虚空。为是鹅雁。谛观不已仿佛见之。十住菩萨于如来性知见少分亦复如是。况复声闻缘觉之人而能知见。善男子。譬如醉人欲涉远路朦胧见道。十住菩萨于如来性知见少分亦复如是。善男子。譬如渴人行于圹野。是人渴逼遍行求水。见有丛树树有白鹤。是人迷闷不能分别是树是水。谛观不已乃见白鹤及以丛树。善男子。十住菩萨于如来性知见少分亦复如是。善男子。譬如有人在大海中。乃至无量百千由旬。远望大舶楼橹堂阁。即作是念。彼是楼橹为是虚空。久视乃生必定之心知是楼橹。十住菩萨于自身中见如来性亦复如是。善男子。譬如王子身极懦弱通夜游戏至明清旦目视一切悉不明了。十住菩萨虽于己身见如来性。亦复如是不大明了。复次善男子。譬如臣吏王事所拘逼夜还家。电明暂发因见牛聚。即作是念。为是牛群为云为舍。是人久视虽生牛想犹不审定。十住菩萨虽于己身见如来性。未能审定亦复如是。复次善男子。如持戒比丘观无虫水而见虫相。即作是念。此中动者为是虫耶是尘土耶。久视不已虽知是尘亦不明了。十住菩萨于己身中见如来性。亦复如是不大明了。复次善男子。譬如有人于阴闇中远见小儿。即作是念。彼为是牛为人为鸟耶。久观不已虽见小儿犹不明了。十住菩萨于己身中见如来性。亦复如是不大明了。复次善男子。譬如有人于夜闇中见画菩萨。即作是念。是菩萨像自在天像大梵天像成染衣耶。是人久观虽复意谓是菩萨像亦不明了。十住菩萨于己身中见如来性。亦复如是不大明了。善男子。所有佛性如是甚深难得知见。唯佛能知。非诸声闻缘觉所及。善男子。智者应作如是分别知如来性。迦叶菩萨白佛言。世尊。佛性如是微细难知。云何肉眼而能得见

佛告迦叶。善男子。如非想非非想天。亦非二乘所能得知。随顺契经以信故知。善男子。声闻缘觉信顺如是大涅槃经。自知己身有如来性亦复如是。善男子。是故应当精勤修习大涅槃经。善男子。如是佛性唯佛能知非诸声闻缘觉所及

迦叶菩萨白佛言。世尊。非圣凡夫有众生性皆说有我

佛言。譬如二人共为亲友。一是王子。一是贫贱。如是二人互相往返。是时贫人见是王子有一好刀净妙第一。心中贪着。王子后时执持是刀逃至他国。贫人于后寄宿他家。即于眠中寱言刀刀。傍人闻之收至王所。时王问言。汝言刀者可以示我。是人具以上事答王。王今设使屠割臣身分裂手足。欲得刀者实不可得。臣与王子素为亲厚。先共一处虽曾眼见。乃至不敢以手掁触。况当故取。王复问言。卿所见刀相貌何类。答言。大王。臣所见者如羖羊角。王闻是已欣然而笑。语言。汝今随意所至莫生忧怖。我库藏中都无是刀况汝乃于王子边见。时王即问诸群臣言。汝等曾见如是刀不。言已便崩。寻立余子绍继王位。复问群臣。汝等曾于官库藏中见是刀不。诸臣答言。臣等曾见。又复问言。其状何似。答言。大王。如羖羊角。王言。我库藏中何缘当有如是相刀。次第四王皆悉检校求索不得。却后数时先逃王子。从他国还归其本土。复得为王。既登王位。复问诸臣。汝见刀不。答言。大王。臣等皆见。又复问言。其状何似。答言。大王。其色清净如优钵罗花。复有答言。形如羊角。复有答言。其色红赤犹如火聚。复有答言。犹如黑蛇。时王大笑。卿等皆悉不见我刀真实之相。善男子。菩萨摩诃萨亦复如是。出现于世说我真相。说已舍去。譬如王子持净妙刀逃至他国。凡夫愚人说言一切有我有我。如彼贫人止宿他舍寱言刀刀声闻缘觉问诸众生我有何相。答言。我见我相大如母指。或言如米。或如稗子。有言我相住在心中炽然如日。如是众生不知我相。譬如诸臣不知刀相。菩萨如是说于我法。凡夫不知种种分别妄作我相。如问刀相答似羊角。是诸凡夫次第相续而起邪见为断如是诸邪见故。如来示现说于无我。譬如王子语诸臣言我库藏中无如是刀。善男子。今日如来所说真我名曰佛性。如是佛性我佛法中。譬如净刀善男子。若有凡夫能善说者。即是随顺无上佛法。若有善能分别随顺宣说是者。当知即是菩萨相貌

    大般涅槃经文字品第十三

佛复告迦叶。所有种种异论咒术言语文字。皆是佛说非外道说。迦叶菩萨白佛言。世尊。云何如来说字根本。佛言。善男子。初说半字以为根本。持诸记论咒术文章诸阴实法。凡夫之人学是字本。然后能知是法非法

迦叶菩萨复白佛言。世尊。所言字者。其义云何。善男子。有十四音名为字义。所言字者名曰涅槃。常故不流。若不流者则为无尽。夫无尽者即是如来金刚之身。是十四音名曰字本。短阿者不破坏故。不破坏者名曰三宝。喻如金刚。又复阿者不流故。不流者即是如来。如来九孔无所流故。是故不流。又无九孔是故不流。不流即常。常即如来。如来无作。是故不流。又复阿者名为功德。功德者即是三宝。是故名阿。次长阿者名阿阇梨。阿阇梨者义何谓耶。于世间中得名圣者。何谓为圣。圣名无著少欲知足亦名清净。能度众生于三有流生死大海。是名为圣。又复阿者名曰制度。修持净戒随顺威仪。又复阿者名依圣人。应学威仪进止举动供养恭敬礼拜三尊孝养父母及学大乘。善男女等具持禁戒及诸菩萨摩诃萨等是名圣人。又复阿者名曰教诲。如言汝等如是应作如是莫作。若有能遮非威仪法。是名圣人。是故名阿

短伊者即是佛法。梵行广大清净无垢。譬如满月。汝等如是应作不作是义非义此是佛说此是魔说。是故名伊。长伊者。佛法微妙甚深难得。如自在天大梵天王法名自在。若能持者则名护法。又自在者名四护世。是四自在则能摄护大涅槃经。亦能自在敷扬宣说。又复伊者能为众生自在说法。复次伊者为自在故说。何等是耶。所谓修习方等经典。复次伊者。为断嫉妒如除稗秽。皆悉能令变成吉祥。是故名伊短忧者。于诸经中最上最胜增长上上谓大涅槃。复次忧者如来之性。声闻缘觉所未曾闻。如一切处北郁单越最为殊胜菩萨若能听受是经。于一切众最上最胜。是故名忧。长忧者。譬如牛乳诸味中上。如来之性亦复如是。于诸经中最尊最上。若有诽谤当知是人与牛无别。复次忧者。是人名为无慧正念诽谤如来微密秘藏。当知是人甚可怜愍。远离如来秘密之藏说无我法。是故名忧

咽者即是诸佛法性涅槃。是故名咽。野者谓如来义。复次野者。如来进止屈申举动。无不利益一切众生。是故名野

鸟者名烦恼义。烦恼者名曰诸漏。如来永断一切烦恼。是故名乌。炮者谓大乘义。于十四音是究竟义。大乘经典亦复如是。于诸经论最为究竟。是故名炮

庵者能遮一切诸不净物。于佛法中能舍一切金银宝物。是故名庵。痾者名胜乘义。何以故。此大乘典大涅槃经。于诸经中最为殊胜。是故名痾

迦者于诸众生起大慈悲。生于子想如罗睺罗作妙善义。是故名迦。呿者名非善友。非善友者名为杂秽。不信如来秘密之藏。是故名呿。伽者名藏。藏者即是如来秘藏。一切众生皆有佛性。是故名伽。重音伽者如来常音。何等名为如来常音。所谓如来常住不变。是故名伽。俄者一切诸行破坏之相。是故名俄

遮者即是修义。调伏一切诸众生故。名为修义。是故名遮。车者如来覆荫一切众生譬如大盖。是故名车。阇者是正解脱无有老相。是故名阇。阇重音阇者烦恼繁茂譬如稠林。是故名阇。若者是智慧义知真法性。是故名若

吒者于阎浮提示现半身而演说法。譬如半月。是故名吒。侘(土家反)者法身具足譬如满月。是故名侘。茶者是愚痴僧。不知常与无常譬如小儿。是故名茶。重音茶者不知师恩譬如羝羊。是故名茶。挐者非是圣义譬如外道。是故名拏。多者如来于彼告诸比丘宜离惊畏。当为汝等说微妙法。是故名多。他者名愚痴义。众生流转生死自缠如蚕。是故名他。陀者名曰大施。所谓大乘。是故名陀。重音陀者称赞功德。所谓三宝如须弥山。高峻广大无有倾倒。是故名陀。那者三宝安住无有倾动譬如门阃。是故名那

波者名颠倒义。若言三宝悉皆灭尽。当知是人为自疑惑。是故名波。颇者是世间灾。若言世间灾起之时三宝亦尽。当知是人愚痴无智违失圣旨。是故名颇。婆者名佛十力。是故名婆。重音婆者名为重担。堪任荷负无上正法。当知是人是大菩萨。是故名婆。摩者是诸菩萨严峻制度。所谓大乘大般涅槃。是故名摩

邪者是诸菩萨在在处处。为诸众生说大乘法。是故名邪。啰者能坏贪欲嗔恚愚痴说真实法。是故说啰。轻罗者名声闻乘动转不住。大乘安隐无有倾动。舍声闻乘精勤修习无上大乘。是故名罗。和者如来世尊为诸众生雨大法雨。所谓世间咒术经书。是故名和。赊者远离三箭。是故名赊。沙者名具足义。若能听是大涅槃经则为已得闻持一切大乘经典。是故名沙。娑者为诸众生演说正法令心欢喜。是故名娑。呵者名心欢喜。奇哉世尊离一切行。怪哉如来入般涅槃。是故名呵。罗者名曰魔义。无量诸魔不能毁坏如来秘藏。是故名罗。复次罗者。乃至示现随顺世间有父母妻子。是故名罗

鲁流卢楼如是四字说有四义。谓佛法僧及以对法。言对法者。随顺世间如提婆达示现坏僧。化作种种形貌色像。为制戒故。智者了达不应于此而生畏怖。是名随顺世间之行。以是故名鲁流卢楼

吸气舌根随鼻之声。长短超声随音解义。皆因舌齿而有差别。如是字义能令众生口业清净。众生佛性则不如是假于文字然后清净。何以故。性本净故。虽复处在阴界入中。而不同于阴入界也。是故众生悉应归依。诸菩萨等以佛性故。等视众生无有差别。是故半字于诸经书记论文章而为根本。又半字义皆是烦恼言说之本。故名半字。满字者。乃是一切善法言说之根本也。譬如世间为恶行者名为半人。修善行者名为满人。如是一切经书记论。皆因半字而为根本。若言如来及正解脱入于半字。是事不然。何以故。离文字故。是故如来于一切法无碍无著真得解脱。何等名为解了字义。有知如来出现于世能灭半字。是故名为解了字义。若有随逐半字义者。是人不知如来之性。何等名为无字义耶。亲近修习不善法者。是名无字。又无字者。虽能亲近修习善法。不知如来常与无常恒与非恒。及法僧二宝律与非律。经与非经魔说佛说。若有不能如是分别。是名随逐无字义也。我今已说如是随逐无字之义。善男子。是故汝今应离半字善解满字

迦叶菩萨白佛言。世尊。我等应当善学字数。今我值遇无上之师。已受如来殷勤诲敕。佛赞迦叶。善哉善哉。乐正法者应如是学

    大般涅槃经鸟喻品第十四

尔时佛告迦叶菩萨。善男子。鸟有二种。一名迦邻提二名鸳鸯。游止共俱不相舍离。是苦无常无我等法。亦复如是不得相离

迦叶菩萨白佛言。世尊。云何是苦无常无我如彼鸳鸯迦邻提鸟

佛言。善男子。异法是苦异法是乐。异法是常异法无常。异法是我异法无我。譬如稻米异于麻麦。麻麦复异豆粟甘蔗。如是诸种从其萌芽。乃至花叶皆是无常。果实成熟人受用时。乃名为常。何以故性真实故迦叶白佛言。世尊。如是等物若是常者同如来耶

佛言。善男子。汝今不应作如是说。何以故。若言如来如须弥山。劫坏之时须弥崩倒。如来尔时岂同坏耶。善男子。汝今不应受持是义。善男子。一切诸法唯除涅槃。更无一法而是常者。直以世谛言果实常迦叶菩萨白佛言。世尊。善哉善哉。如佛所说。佛告迦叶。如是如是。善男子。虽修一切契经诸定。乃至未闻大般涅槃。皆言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了己身有佛性故。是名为常。复次善男子。譬如庵罗树其花始敷名无常相。若成果实多所利益乃名为常。如是善男子。虽修一切契经诸定。未闻如是大涅槃时。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了自身有佛性故。是名为常。复次善男子。譬如金矿消融之时是无常相。融已成金多所利益乃名为常。如是善男子。虽修一切契经诸定。未闻如是大涅槃时。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了自身有佛性故。是名为常。复次善男子。譬如胡麻未被压时名曰无常。既压成油多有利益乃名为常。善男子。虽修一切契经诸定。未闻如是大涅槃时。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了己身有佛性故。是名为常。复次善男子。譬如众流皆归于海。一切契经诸定三昧。皆归大乘大涅槃经。何以故。究竟善说有佛性故。善男子。是故我言异法是常异法无常。乃至无我亦复如是迦叶菩萨白佛言。世尊。如来已离忧悲毒箭。夫忧悲者名为天。如来非天。忧悲者名为人。如来非人。忧悲者名二十五有。如来非二十五有。是故如来无有忧悲。何故称言如来忧悲。善男子。无想天者名为无想。若无想者则无寿命。若无寿命云何而有阴界诸入。以是义故。无想天寿不可说言有所住处。善男子。譬如树神依树而住。不得定言依枝依节依茎依叶。虽无定所不得言无。无想天寿亦复如是。善男子。佛法亦尔甚深难解。如来实无忧悲苦恼。而于众生起大慈悲。现有忧悲。视诸众生如罗睺罗。复次善男子。无想天中所有寿命。唯佛能知非余所及。乃至非想非非想处亦复如是。迦叶如来之性清净无染犹如化身。云何当有忧悲苦恼。若言如来有忧悲者。云何能利一切众生弘广佛法。若言无者。云何而言等视众生如罗睺罗。若不等视如罗睺罗。如是之言则为虚妄。以是义故。善男子佛不可思议。法不可思议。众生佛性不可思议。无想天寿不可思议如来有忧及以无忧是佛境界。非诸声闻缘觉所知。善男子。譬如空中舍宅微尘不得住立。若言舍宅不因空住无有是处。以是义故。不可说舍住于虚空不住虚空。凡夫之人虽复说言舍住虚空。而是虚空实无所住。何以故性无住故。善男子。心亦如是不可说言住阴界入及以不住。无想天寿亦复如是。如来忧悲亦复如是。若无忧悲云何说言等视众生如罗睺罗。若言有者复云何言性同虚空。善男子。譬如幻师虽复化作种种宫殿杀生长养系缚放舍。及作金银琉璃宝物丛林树木。都无实性。如来亦尔。随顺世间示现忧悲无有真实。善男子。如来已入大般涅槃。云何当有忧悲苦恼。若谓如来入于涅槃是无常者。当知是人则有忧悲。若谓如来不入涅槃常住不变。当知是人无有忧悲。如来有忧及以无忧无能知者

复次善男子。譬如下人能知下法不知中上。中者知中不知于上。上者知上及知中下。声闻缘觉亦复如是齐知自地。如来不尔悉知自地及以他地。是故如来名无碍智。示现幻化随顺世间。凡夫肉眼谓是真实。而欲尽知如来无碍无上智者。无有是处。有忧无忧唯佛能知。以是因缘异法有我异法无我。是名鸳鸯迦邻提性。复次善男子。佛法犹如鸳鸯共行。是迦邻提及鸳鸯鸟。盛夏水涨选择高原安处其子。为长养故。然后随本安隐而游。如来出世亦复如是。化无量众生令住正法。如彼鸳鸯迦邻提鸟选择高原安置其子。如来亦尔令诸众生所作办已。即便入于大般涅槃。善男子。是名异法是苦异法是乐。诸行是苦涅槃是乐。第一微妙坏诸行故。迦叶菩萨白佛言。世尊。云何众生得涅槃者名第一乐。佛言。善男子。如我所说诸行和合名为老死

  谨慎无放逸　　是处名甘露
  放逸不谨慎　　是名为死句
  若不放逸者　　则得不死处
  如其放逸者　　常趣于死路

若放逸者名有为法。是有为法为第一苦。不放逸者则名涅槃。彼涅槃者名为甘露第一最乐。若趣诸行是名死处受第一苦若至涅槃则名不死受最妙乐。若不放逸虽集诸行。是亦名为常乐不死不破坏身。云何放逸。云何不放逸。非圣凡夫是名放逸常死之法。出世圣人是不放逸无有老死。何以故。入于第一常乐涅槃。以是义故。异法是苦。异法是乐。异法是我异法无我。如人在地仰观虚空不见鸟迹。善男子。众生亦尔无有天眼。在烦恼中而不自见有如来性。是故我说无我密教。所以者何。无天眼者不知真我。横计我故因诸烦恼。所造有为即是无常。是故我说异法是常异法无常

  精进勇健者　　若处于山顶
  平地及旷野　　常见诸凡夫
  升大智慧殿　　无上微妙台
  既自除忧患　　亦见众生忧

如来悉断无量烦恼住智慧山。见诸众生常在无量亿烦恼中。迦叶菩萨复白佛言。世尊。如偈所说是义不然。何以故。入涅槃者无忧无喜。云何得升智慧台殿。复当云何住在山顶而见众生。佛言。善男子。智慧殿者即名涅槃。无忧患者谓如来也。有忧患者名凡夫人。以凡夫忧故如来无忧。须弥山顶者谓正解脱。勤精进者譬须弥山无有动转。地谓有为行也。是诸凡夫安住是地造作诸行。其智慧者则名正觉。离有常住故名如来。如来愍念无量众生常为诸有毒箭所中。是故名为如来有忧。迦叶菩萨复白佛言。世尊。若使如来有忧悲者。则不得称为等正觉。佛言迦叶。皆有因缘。随有众生应受化处。如来于中示现受生。虽现受生而实无生。是故如来名常住法。如迦邻提鸳鸯等鸟

大般涅槃经卷第八大般涅槃经卷第九

        宋代沙门慧严等依泥洹经加之

    月喻品第十五

佛告迦叶。譬如有人见月不现皆言月没而作没想。而此月性实无没也。转现他方彼处众生复谓月出。而此月性实无出也。何以故。以须弥山障故不现。其月常生性无出没。如来应供正遍知亦复如是。出现三千大千世界。或阎浮提示有父母。众生皆谓生阎浮提。或阎浮提示现涅槃。如来之性实无涅槃。而诸众生皆谓如来实般涅槃。譬如月没。善男子。如来之性实无生灭。为化众生示有生灭。善男子。如此满月余方见半此方半月余方见满。阎浮提人若见月初。皆谓一日起初月想。见月盛满谓十五日生盛满想。而此月性实无亏盈。因须弥山而有增减。善男子。如来亦尔。于阎浮提或现初生或现涅槃。现始生时犹如初月。一切皆谓童子初生行于七步如二日月或复示现入于书堂。如三日月。示现出家如八日月。放大智慧微妙光明。能破无量众生魔众。如十五日盛满之月。或复示现三十二相八十种好以自庄严。而现涅槃喻如月蚀。如是众生所见不同。或见半月或见满月或见月蚀。而此月性实无增减侵蚀之者。常是满月。如来之身亦复如是。是故名为常住不变。复次善男子。譬如满月一切悉现。在在处处城邑聚落。山泽水中若井若池。及诸水器一切皆现。有诸众生行百由旬百千由旬。见月常随。凡夫愚人妄生忆想言。我本于城邑屋宅见如是月。今复于此空泽见之。为是本月为异于本。各作是念。月形大小或言如鍑口。或言如车轮。或言如四十九由旬。一切皆见月之光明。或见团圆犹如金盘是月性一。种种众生各见异相。善男子。如来亦尔出现于世。或有人天而作是念。如来今者在我前住。复有畜生亦生是念。如来今者在我前住。或有聋哑亦见如来有聋哑相。众生杂类言音各异。皆谓如来悉同己语。亦各生念。在我舍宅受我供养。或有众生见如来身广大无量。或见微小。或有见佛是声闻像。或复有见为缘觉像。有诸外道复各念言。如来今者在我法中出家学道。或有众生复作是念。如来今者独为我故出现于世。如来实性喻如彼月。即是法身是无生身。方便之身随顺于世。示现无量本业因缘。在在处处示现有生。犹如彼月。以是义故如来常住无有变异。复次善男子。如罗睺罗阿修罗王以手遮月。世间诸人咸谓月蚀。阿修罗王实不能蚀。以阿修罗障其明故。是月团圆无有亏损。但以手障故使不现。若摄手时世间咸谓月复还生。皆言是月多受苦恼假使百千阿修罗王不能恼之。如来亦尔。示有众生于如来所生粗恶心出佛身血起五逆罪至一阐提。为未来世诸众生故。如是示现坏僧断法而作留难。假使无量百千诸魔不能侵出如来身血。所以者何。如来之身无有血肉筋脉骨髓。如来真实无恼坏。众生皆谓法僧毁坏如来灭尽。而如来性真实无变无有破坏。随顺世间如是示现。复次善男子。如二人斗。若以刀杖伤身出血。虽至于死不起杀想。如是业相轻而不重。于如来所本无杀心。虽出身血是业亦尔轻而不重。如来如是于未来世。为化众生示现业报。复次善男子。犹如良医勤教其子医方根本。此是根药此是茎药此是色药。种种相貌汝当善知。其子敬奉父之所敕精勤习学善解诸药。是医后时寿尽命终。其子号慕而作是言父本教我。根药如是茎药如是花药如是色相如是。如来亦尔为化众生示现制戒。应当如是受持莫犯作五逆罪诽谤正法及一阐提。为未来世起是事者是故示现。欲令比丘于佛灭后作如是知此是契经甚深之义。此是戒律轻重之相此是阿毗昙分别法句如彼医子

复次善男子。如人见月六月一蚀。而上诸天须臾之间已见月蚀。何以故。彼天日长人间短故。善男子。如来亦尔。天人咸谓如来短寿。如彼天人须臾之间频见月蚀。如来又于须臾之间。示现百千万亿涅槃。断烦恼魔阴魔死魔。是故百千万亿天魔悉知如来入般涅槃。又复示现无量百千先业因缘。随顺世间种种性故。示现如是无量无边不可思议。是故如来常住无变。复次善男子。譬如明月众生乐见。是故称月号为乐见。众生若有贪恚愚痴则不得称为乐见也。如来如是其性纯善清净无垢。是最可称为乐见也。乐法众生视之无厌。恶心之人不喜瞻睹。以是义故。故言如来譬如明月。复次善男子。譬如日出有三时异。谓春夏冬。冬日则短春日处中夏日极长。如来亦尔。于此三千大千世界。为短寿者及诸声闻示现短寿。斯等见已咸谓如来寿命短促喻如冬日。为诸菩萨示现中寿。若至一劫若减一劫喻如春日。唯佛睹佛其寿无量喻如夏日。善男子。如来所说方等大乘微密之教。示现世间雨大法雨。于未来世若有人能护持是典。开示分别利益众生。当知是辈是真菩萨。喻如盛夏天降甘雨。若有声闻缘觉之人。闻佛如来微密之教。喻如冬日多遇冷患。菩萨之人若闻如是微密教诲如来常住性无变易。喻如春日萌芽开敷。而如来性实无长短。为世间故示现如是。即是诸佛真实法性。复次善男子。譬如众星昼则不现。而人皆谓昼星灭没其实不没。所以不现日光映故。如来亦尔。声闻缘觉不能得见。犹如世人不见昼星。复次善男子。譬如阴闇日月不现。愚人谓言日月失没。而是日月实无失没。如来正法灭尽之时。三宝现没亦复如是非为永灭。是故当知如来常住无有变易。何以故。三宝真性不为诸垢之所染故

复次善男子。譬如黑月彗星夜现。其明炎炽暂出还没。众生见已生不祥想。诸辟支佛亦复如是出无佛世。众生见已皆谓如来真实灭度生忧悲想。而如来身实不灭度。如彼日月无有灭没

复次善男子。譬如日出众雾悉除。此大涅槃微妙经典。亦复如是出兴于世。若有众生一经耳者。悉能灭除一切诸恶无间罪业。是大涅槃甚深境界不可思议。善说如来微密之性。以是义故。诸善男子善女人等应于如来生常住心。无有变易正法不断僧宝不灭。是故应当多修方便勤学是典。是人不久当得阿耨多罗三藐三菩提。是故此经名为无量功德所成。亦名菩提不可穷尽。以不尽故。故得称为大般涅槃。有善光故犹如夏日。身无边故名大涅槃

    大般涅槃经菩萨品第十六

复次善男子。如日月光诸明中最一切诸明所不能及。大涅槃光亦复如是。于诸契经三昧光明最为殊胜。诸经三昧所有光明所不能及。何以故。大涅槃光能入众生诸毛孔故。众生虽无菩提之心。而能为作菩提因缘。是故复名大般涅槃。迦叶菩萨白佛言。世尊。如佛所说。大涅槃光入于一切众生毛孔。众生虽无菩提之心。而能为作菩提因者。是义不然。何以故。世尊。犯四重禁作五逆人及一阐提。光明入身作菩提因者。如是等辈与持净戒修习诸善有何差别。若无差别如来何故说四依义。世尊。又如佛言。若有众生。闻大涅槃一经于耳。则得断除诸烦恼者。如来云何先说有人恒沙佛所发菩提心。闻大涅槃不解其义。若不解义云何能断一切烦恼。佛言。善男子。除一阐提其余众生。闻是经已悉皆能作菩提因缘。法声光明入毛孔者。必定当得阿耨多罗三藐三菩提。何以故。若有人能供养恭敬无量诸佛。方乃得闻大涅槃经。薄福之人则不得闻。所以者何。大德之人乃能得闻如是大事。凡夫下劣则不得闻。何等为大。所谓诸佛甚深秘藏如来性是。以是义故名为大事。迦叶菩萨白佛言。世尊。云何未发菩提心者得菩提因。佛告迦叶。若有闻是大涅槃经。言我不用发菩提心。诽谤正法。是人即于梦中见罗刹像心中怖懅。罗刹语言。咄善男子。汝今若不发菩提心当断汝命。是人惶怖觉已即发菩提之心。是人命终若在三趣及在人天。续复忆念菩提之心。当知是人是大菩萨摩诃萨也。以是义故。是大涅槃威神之力。能令未发菩提心者作菩提因。善男子。是名菩萨发心因缘。非无因缘。以是义故大乘妙典真佛所说。复次善男子。如虚空中兴大云雨注于大地。枯木石山高原堆阜水所不住。流注下田陂池悉满。利益无量一切众生。是大涅槃微妙经典亦复如是。雨大法雨普润众生。唯一阐提发菩提心无有是处。复次善男子。譬如焦种虽遇甘雨百千万劫终不生芽。芽若生者无有是处。一阐提辈亦复如是。虽闻如是大般涅槃微妙经典。终不能发菩提心芽。若能发者无有是处。何以故。是人断灭一切善根如彼焦种。不能复生菩提根芽。复次善男子。譬如明珠置浊水中以珠威德水即为清投之淤泥不能令清。是大涅槃微妙经典亦复如是。置余众生五无间罪四重禁法浊水之中。犹可澄清发菩提心。投一阐提淤泥之中。百千万岁不能令清起菩提心。何以故。是一阐提灭诸善根。非其器故。假使是人百千万岁听受如是大涅槃经。终不能发菩提之心。所以者何无善心故

复次善男子。譬如药树名曰药王于诸药中最为殊胜。若和乳酪若蜜若酥若水若浆。若末若丸若以涂疮。薰身涂目若见若嗅。能灭众生一切诸病。如是药树不作是念。一切众生若取我根不应取叶。若取叶者不应取根。若取身者不应取皮。若取皮者不应取身。是树虽复不生是念。而能除灭一切病苦。善男子。是大涅槃微妙经典亦复如是。能除一切众生恶业四波罗夷五无间罪。若内若外所有诸恶。诸有未发菩提心者。因是则得发菩提心。何以故。是妙经典诸经中王。如彼药树诸药中王。若有修习是大涅槃及不修者。若闻有是经典名字。闻已敬信。所有一切烦恼重病皆悉除灭。唯不能令一阐提辈安住阿耨多罗三藐三菩提。如彼妙药虽能疗愈种种重病而不能治必死之人。复次善男子。如人手疮捉持毒药毒则随入若无疮者毒则不入。一阐提辈亦复如是。无菩提因如无疮者毒不得入。所谓疮者即是无上菩提因缘。毒者即是第一妙药。全无疮者谓一阐提。复次善男子。譬如金刚无能坏者悉能破坏一切之物。唯除龟甲及白羊角。是大涅槃微妙经典亦复如是。悉能安止无量众生于菩提道。唯不能令一阐提辈立菩提因。复次善男子。如马齿草娑罗翅树尼迦罗树虽断枝茎续生如故。不如多罗断已不生。是诸众生亦复如是。若得闻是大涅槃经。虽犯四禁及五无间。犹故能生菩提因缘。一阐提辈则不如是。虽得听受是妙经典。而不能生菩提道因

复次善男子。如佉陀罗镇头迦树断已不生一阐提辈亦复如是。虽得闻是大涅槃经。而不能发菩提因缘。复次善男子。譬如大雨终不住空。是大涅槃微妙经典亦复如是。普雨法雨于一阐提则不能住。是一阐提周体密致。犹如金刚不容外物。迦叶菩萨白佛言。世尊。如佛说偈

  不见善不作　　唯见恶可作
  是处可怖畏　　犹如险恶道

世尊。如是所说有何等义。佛言。善男子。不见者谓不见佛性。善者即是阿耨多罗三藐三菩提。不作者所谓不能亲近善友。唯见者见无因果恶者谓谤方等大乘经典。可作者谓一阐提说无方等。以是义故。一阐提辈无心趣向清净善法。何等善法。谓涅槃也。趣涅槃者谓能修习贤善之行。而一阐提无贤善行。是故不能趣向涅槃。是处可畏者谓谤正法谁应怖畏所谓智者。何以故。以谤法者无有善心及方便故。险恶道者谓诸行也。迦叶复言。如佛所说

  云何见所作　　云何得善法
  何处不怖畏　　如王夷坦道

是义何谓。佛言。善男子。见所作者发露诸恶从生死际所作诸恶。悉皆发露至无至处。以是义故是处无畏。喻如人王所游正路。其中盗贼悉皆逃走。如是发露一切诸恶悉灭无余。复次不见所作者。谓一阐提所作众恶而不自见。是一阐提憍慢心故。虽多作恶于是事中初无怖畏。以是义故不得涅槃。喻如猕猴捉水中月。善男子。假使一切无量众生。一时成就阿耨多罗三藐三菩提已。此诸如来亦复不见彼一阐提得成菩提。以是义故名不见所作。又复不见谁之所作。所谓不见如来所作。佛为众生说有佛性。一阐提辈流转生死不能知见。以是义故名为不见如来所作。又一阐提见于如来毕竟涅槃谓真无常犹如灯灭膏油俱尽。何以故。是人恶业不损减故。若有菩萨所作善业回向阿耨多罗三藐三菩提时。一阐提辈虽复毁呰破坏不信。然诸菩萨犹故施与。欲共成就无上之道。何以故诸佛法尔

  作恶不即受　　如乳即成酪
  犹灰覆火上　　愚者轻蹈之

一阐提者名为无目。是故不见阿罗汉道。如阿罗汉不行生死险恶之道。以无目故诽谤方等。不欲修习如阿罗汉勤修慈心。一阐提辈不修方等亦复如是。若人说言。我今不信声闻经典。信受大乘读诵解说。是故我今即是菩萨。一切众生悉有佛性。以佛性故众生身中。即有十力三十二相八十种好。我之所说不异佛说。汝今与我俱破无量诸恶烦恼如破水瓶。以破结故即能得见阿耨多罗三藐三菩提。是人虽作如是演说。其心实不信有佛性。为利养故随文而说。如是说者名为恶人。如是恶人不速受果如乳成酪。譬如王使善能谈论。巧于方便奉命他国。宁丧身命终不匿王所说言教。智者亦尔于凡夫中不惜身命。要必宣说大乘方等如来秘藏。一切众生皆有佛性。善男子。有一阐提作罗汉像住于空处诽谤方等大乘经典。诸凡夫人见已皆谓真阿罗汉是大菩萨摩诃萨。是一阐提恶比丘辈。住阿兰若处坏阿兰若法。见他得利心生嫉妒。作如是言。所有方等大乘经典。悉是天魔波旬所说。亦说如来是无常法。毁灭正法破坏众僧。复作是言。波旬所说非善顺说。作是宣说邪恶之法。是人作恶不即受报。如乳成酪灰覆火上愚轻蹈之如是人者谓一阐提。是故当知大乘方等微妙经典必定清净。如摩尼珠投之浊水水即为清。大乘经典亦复如是。复次善男子。譬如莲花为日所照无不开敷。一切众生亦复如是。若得见闻大涅槃日。未发心者皆悉发心为菩提因。是故我说大涅槃光所入毛孔必为妙因。彼一阐提虽有佛性。而为无量罪垢所缠。不能得出如蚕处茧。以是业缘不能得生菩提妙因。流转生死无有穷已

复次善男子。如优钵罗花钵头摩花拘物头华芬陀利华生淤泥中而不为彼淤泥所污。若有众生修大涅槃微妙经典亦复如是。虽有烦恼终不为彼烦恼所污。何以故。以知如来性相力故。善男子。譬如有国多清凉风若触众生身诸毛孔能除一切郁蒸之恼。此大乘典大涅槃经亦复如是。遍入一切众生毛孔。为作菩提微妙因缘。除一阐提何以故非法器故

复次善男子。譬如良医解八种药灭一切病。唯不能除阿萨阇病。一切契经禅定三昧亦复如是。能治一切贪恚愚痴诸烦恼病。能拔烦恼毒刺等箭。而不能治犯四重禁五无间罪。善男子复有良医过八种术。能除众生所有病苦。唯不能治必死之病。是大涅槃大乘经典亦复如是。能除众生一切烦恼。安住如来清净妙因。未发心者令得发心。唯除必死一阐提辈

复次善男子。譬如良医能以妙药治诸盲人。令见日月星宿诸明一切色像。唯不能治生盲之人。是大乘典大涅槃经亦复如是。能为声闻缘觉之人开发慧眼。令其安住无量无边大乘经典。未发心者。谓犯四禁五无间罪。悉能令发菩提之心。唯除生盲一阐提辈。复次善男子。譬如良医善解八术为治众生一切病苦。种种方药随病与之。所谓吐下涂身灌鼻。若薰若洗若丸若散。一切诸药。而贫愚人不欲服之。良医愍念即将是人。还其舍宅强与令服。以药力故所患得除。女人产难儿衣不出。若服此药儿衣即出。亦令婴儿安乐无患。是大乘典大涅槃经亦复如是。所至之处若至舍宅。能除众生无量烦恼犯四重禁五无间罪。未发心者悉令发心。除一阐提。迦叶菩萨白佛言。世尊。犯四重禁及五无间名极重恶譬如断截多罗树头更不复生。是等未发菩提之心。云何能与作菩提因。佛言。善男子。是诸众生若于梦中。梦堕地狱受诸苦恼。即生悔心。哀哉我等自招此罪。若我今得脱是罪者。必定当发菩提之心。我今所见最是极恶。从是觉已即知正法有大果报。如彼婴儿渐渐长大。常作是念。是医最良善解方药。我本处胎与我母药。母以药故身得安隐。以是因缘我命得全。奇哉我母受大苦恼。满足十月怀抱我身。既生之后推干去湿。除去不净大小便利。乳餔长养将护我身。以是义故。当报母恩色养侍卫随顺供养。犯四重禁及无间罪。临命终时念是大乘大涅槃经。虽堕地狱畜生饿鬼天上人中。如是经典亦为是人作菩提因。除一阐提。复次善男子。譬如良医及良医子。所知深奥出过诸医。善知除毒无上咒术。若恶毒蛇若龙若蝮。以诸咒术咒药令良。以此良药用涂革屣。以此革屣触诸毒虫毒为之消。唯除一毒名曰大龙。是大乘典大涅槃经亦复如是。若有众生犯四重禁五无间罪。悉能消灭令住菩提。如药革屣能消众毒。未发心者能令发心。安住无上菩提之道。是彼大乘大涅槃经威神药故。令诸众生生于安乐。唯除大龙一阐提辈

复次善男子。譬如有人以杂毒药用涂大鼓于众人中击令发声。虽无心欲闻闻之皆死。唯除一人不横死者。是大乘典大涅槃经亦复如是。在在处处诸行众中有闻声者。所有贪欲嗔恚愚痴悉皆灭尽。其中虽有无心思念。是大涅槃因缘力故能灭烦恼而结自灭。犯四重禁及五无间闻是经已亦作无上菩提因缘渐断烦恼。除不横死一阐提辈。复次善男子。譬如闇夜诸所营作一切皆息若未讫者要待日明。学大乘者虽修契经一切诸定。要待大乘大涅槃日。闻是如来微密之教。然后乃当造菩提业安住正法。犹如天雨润益增长一切诸种成就果实。悉除饥馑多受丰乐。如来秘藏无量法雨亦复如是。悉能除灭八种热病。是经出世如彼果实多所利益安乐一切。能令众生见如来性。如法花中八千声闻。得受记莂成大果实。如秋收冬藏更无所作。一阐提辈亦复如是。于诸善法无所营作。复次善男子。譬如良医闻他人子非人所持。寻以妙药并遣一使。敕语使言。卿持此药速与彼人。彼人若遇诸恶鬼神。以药力故悉当远去卿若迟晚吾当自往。终不令彼抂横死也。若彼病人得见使者及吾威德。诸苦当除得安隐乐。是大乘典大涅槃经亦复如是。若比丘比丘尼优婆塞优婆夷及诸外道有能受持如是经典。读诵通利复为他人分别广说。若自书写令他书写。斯等皆为菩提因缘。若犯四禁及五逆罪。若为邪鬼毒恶所持。闻是经典所有诸恶悉皆消灭。如见良医恶鬼远去。当知是人是真菩萨摩诃萨也。何以故。暂得闻是大涅槃故。亦以生念如来常故。暂得闻者尚得如是。何况书写受持读诵。除一阐提其余皆是菩萨摩诃萨。复次善男子。譬如聋人不闻音声。一阐提辈亦复如是。虽复欲听是妙经典而不得闻。所以者何。无因缘故。复次善男子。譬如良医一切医方无不通达。兼复广知无量咒术。是医见王作如是言。大王今者有必死病。其王答言。卿不见我腹内之事。云何而言必有死病。医即答言。若不见信应服下药。既下之后王自验之。王不肯服。尔时良医以咒术力。令王隐处遍生疮疱兼复[病-丙+帶]下虫血杂出。王见是已生大怖懅。赞彼良医。善哉善哉。卿先所白吾不用之。今乃知卿于吾此身作大利益。恭敬是医犹如父母。是大乘典大涅槃经亦复如是。于诸众生有欲无欲。悉能令彼烦恼崩落。是诸众生乃至梦中梦见是经恭敬供养。喻如大王恭敬良医是大良医知必死者终不治之。是大乘典大涅槃经亦复如是。终不能治一阐提辈。复次善男子。譬如良医善知八种悉能疗治一切诸病。唯不能治必死之人。诸佛菩萨亦复如是。悉能救疗一切有罪。唯不能治必死之人一阐提辈。复次善男子。譬如良医善知八种微妙经术。复能博达过于八种。以己所知先教其子。若水若陆山谷药草悉令识知。如是渐渐教八事已。次复教余最上妙术。如来应供正遍知亦复如是。先教其子诸比丘等。方便除灭一切烦恼修学净身不坚固想。谓水陆山谷。水者喻身受苦如水上泡。陆者喻身不坚如芭蕉树。其山谷者喻烦恼中修无我想。以是义故身名无我。如来如是于诸弟子。渐渐教学九部经法令善通利。然后教学如来秘藏。为其子故说如来常。如来如是说大乘典大涅槃经。为诸众生已发心者及未发心作菩提因。除一阐提。如是善男子。是大乘典大涅槃经。无量无数不可思议未曾有也。当知即是无上良医。最尊最胜众经中王

复次善男子。譬如大船从海此岸至于彼岸。复从彼岸还至此岸。如来正觉亦复如是。乘大涅槃大乘宝船。周旋往返济渡众生。在在处处有应度者。悉令得见如来之身。以是义故如来名曰无上船师。譬如有船则有船师。以有船师则有众生渡于大海。如来常住化度众生亦复如是。复次善男子。譬如有人在大海中乘船欲渡。若得顺风须臾之间。则能得过无量由旬。若不得者虽复久住经无量岁不离本处。有时船坏没水而死。众生如是。在彼愚痴生死大海乘诸行船。若得值遇大般涅槃猛利之风。则能疾到无上道岸。若不值遇当久流转无量生死。或时破坏堕于地狱畜生饿鬼。复次善男子。譬如有人不遇风王。久住大海作是思惟。我等今者必在此死。如是念时忽遇利风随顺渡海。复作是言。快哉是风未曾有也。令我等辈安隐得过大海之难。众生如是。久处愚痴生死大海困苦穷悴。未遇如是大涅槃风。则应生念。我等必定堕于地狱畜生饿鬼。是诸众生思惟是时。忽遇大乘大涅槃风。随顺吹向入于阿耨多罗三藐三菩提。方知真实生奇特想。叹言快哉。我从昔来未曾见闻如是如来微密之藏。尔乃于是大涅槃经生清净信

复次善男子。如蛇脱皮为死灭不。不也世尊。善男子。如来亦尔。方便示现弃舍毒身。可言如来无常灭耶。不也世尊。如来于此阎浮提中方便舍身。如彼毒蛇舍于故皮。是故如来名为常住。复次善男子。譬如金师得好真金随意造作种种诸器。如来亦尔。于二十五有悉能示现种种色身。为化众生拔生死故。是故如来名无边身。虽复示现种种诸身。亦名常住无有变易

复次善男子。如庵罗树及阎浮树一年三变。有时生花光色敷荣。有时生叶滋茂蓊郁。有时雕落状似枯死。善男子。于意云何。是树实为枯死不耶。不也世尊。善男子。如来亦尔。于三界中示三种身。有时初生有时长大有时涅槃。而如来身实非无常。迦叶菩萨赞言。善哉诚如圣教。如来常住无有变易。善男子。如来密语甚深难解。譬如大王告诸群臣先陀婆来。先陀婆者一名四实。一者盐。二者器。三者水。四者马。如是四物共同一名。有智之臣善知此名。若王洗时索先陀婆即便奉水。若王食时索先陀婆即便奉盐。若王食已欲饮浆时。索先陀婆即便奉器。若王游时索先陀婆即便奉马。如是智臣善解大王四种密语。是大乘经亦复如是有四无常。大乘智臣应当善知。若佛出世为众生说如来涅槃。智臣当知。此是如来为计常者说无常相。欲令比丘修无常想。或复说言正法当灭。智臣应知。此是如来为计乐者说于苦相。欲令比丘多修苦想。或复说言我今病苦众僧破坏。智臣当知。此是如来为计我者说无我相。欲令比丘修无我想。或复说言所谓空者是正解脱。智臣当知。此是如来说正解脱无二十五有。欲令比丘修学空想。以是义故。是正解脱则名为空。亦名不动。谓不动者是解脱中无有苦故。是故不动。是正解脱为无有相。谓无相者无有色声香味触等。故名无相。是正解脱常不变易。是解脱中无有无常热恼变易。是故解脱名曰常住不变清凉。或复说言一切众生有如来性。智臣当知。此是如来说于常法。欲令比丘修正常法。是诸比丘若能如是随顺学者。当知是人真我弟子。善知如来微密之藏。如彼大王智慧之臣善知王意。善男子。如是大王亦有如是密语之法。何况如来而当无耶。善男子。是故如来微密之教难可得知。唯有智者乃能解我甚深佛法。非是世间凡夫品类所能信也

复次善男子。如波罗奢树迦尼迦树阿叔迦树值天亢旱不生花实。及余水陆所生之物皆悉枯悴。无有润泽不能增长。一切诸药无复势力。善男子。是大乘典大涅槃经亦复如是。于我灭后有诸众生。不能恭敬无有威德。何以故。是诸众生不知如来微密藏故。所以者何。以是众生薄福德故。复次善男子。如来正法将欲灭尽。尔时多有行恶比丘。不知如来微密之藏。懒隋懈怠不能读诵宣扬分别如来正法。譬如痴贼弃舍真宝担负草木。不解如来微密藏故。于是经中懈怠不勤。哀哉大险当来之世甚可怖畏苦哉众生不勤听受是大乘典大涅槃经。唯诸菩萨摩诃萨等。能于是经取真实义不著文字。随顺不逆为众生说。复次善男子。如牧牛女。为欲卖乳贪多利故。加二分水转卖与余牧牛女人。彼女得已。复加二分转复卖与近城女人。彼女得已。复加二分转复卖与城中女人。彼女得已。复加二分诣市卖之。时有一人为子纳妇。急须好乳以供宾客。至市欲买。是卖乳者多索价直。是人语言。此乳多水实不直是。值我今日瞻侍宾客。是故当取。取已还家煮用作糜无复乳味。虽无乳味于苦味中犹胜千倍。何以故。乳之为味诸味中最。善男子。我涅槃后正法未灭余八十年。尔时是经于阎浮提当广流布。是时当有诸恶比丘。钞略是经分作多分。能灭正法色香美味。是诸恶人虽复诵读如是经典。灭除如来深密要义。安置世间庄严文饰无义之语。钞前着后钞后着前。前后着中中着前后。当知如是诸恶比丘是魔伴侣。受畜一切不净之物。而言如来悉听我畜。如牧牛女多加水乳。诸恶比丘亦复如是。杂以世语错定是经。令多众生不得正说正写正取尊重赞叹供养恭敬。是恶比丘为利养故。不能广宣流布是经。所可分流少不足言。如彼牧牛贫穷女人展转卖乳乃至作糜而无乳味。是大乘典大涅槃经亦复如是。展转薄淡无有气味。虽无气味犹胜余经越踰千倍。如彼乳味于诸苦味其胜千倍。何以故。是大乘典大涅槃经。于声闻经最为上首。喻如牛乳味中最胜。以是义故名大涅槃

复次善男子。若善男子善女人等。无有不求男子身者。何以故。一切女人皆是众恶之所住处。复次善男子。如蚊蚋水不能令此大地润洽。其女人者淫欲难满亦复如是。譬如大地一切作丸令如芥子。如是等男与一女人共为欲事犹不能足。假使男子数如恒沙。与一女人共为欲事亦复不足。善男子。譬如大海一切天雨百川众流皆悉归注。而彼大海未曾满足。女人之法亦复如是。假使一切悉为男子。与一女人共为欲事而亦不足。复次善男子。如阿叔迦树波吒罗树迦尼迦树春花开敷。群蜂唼取色香细味不知厌足。女人欲男亦复如是不知厌足。善男子。以是义故。诸善男子善女人等听是大乘大涅槃经常应呵责女人之相求于男子。何以故。是大乘典有丈夫相。所谓佛性。若人不知是佛性者则无男相。所以者何不能自知有佛性故。若有不能知佛性者。我说是等名为女人。若能自知有佛性者。我说是人为大丈夫。若有女人能知自身定有佛性。当知是等即为男子。善男子。是大乘典大涅槃经无量无边不可思议功德之聚。何以故。以说如来秘密藏故。是故善男子善女人。若欲速知如来密藏。应当方便勤修此经。迦叶菩萨白佛言。世尊。如是如是。如佛所说。我今已有丈夫之相。得入如来微密藏故。如来今日始觉悟我。因是即得决定通达。佛言。善哉善哉善男子。汝今随顺世间之法而作是说。迦叶复言。我不随顺世间法也。佛赞迦叶。善哉善哉。汝今所知无上法味甚深难知。而能得知如蜂采味。汝亦如是。复次善男子。如蚊子泽不能令此大地沾洽。当来之世是经流布亦复如是。如彼蚊泽。正法欲灭。是经先当没于此地。当知即是正法衰相。复次善男子。譬如过夏初月名秋秋雨连注。此大乘典大涅槃经亦复如是为彼南方诸菩萨故。当广流布降注法雨弥满其处。正法欲灭当至罽宾具足无缺潜没地中。或有信者或不信者。如是大乘方等经典甘露法味。悉没于地。是经没已。一切诸余大乘经典皆悉灭没。若得是经具足无缺人中象王。诸菩萨等当知。如来无上正法将灭不久

尔时文殊师利白佛言。世尊。今此纯陀犹有疑心。唯愿如来。重为分别令得除断。佛言善男子。云何疑心汝当说之。当为除断。文殊师利言。纯陀心疑如来常住。以得知见佛性力故。若见佛性而为常者。本未见时应是无常。若本无常后亦应尔。何以故。如世间物本无今有已有还无。如是等物悉是无常。以是义故。诸佛菩萨声闻缘觉无有差别。尔时世尊。即说偈言

  本有今无　　本无今有　　三世有法
  无有是处

善男子。以是义故。诸佛菩萨声闻缘觉。亦有差别亦无差别。文殊师利赞言。善哉诚如圣教。我今始解诸佛菩萨声闻缘觉亦有差别亦无差别。迦叶菩萨白佛言。世尊。如佛所说。诸佛菩萨声闻缘觉性无差别。唯愿如来分别广说。利益安乐一切众生。佛言。善男子。谛听谛听当为汝说

善男子。譬如长者多畜乳牛有种种色。常令一人守护将养。是人有时为祠祀故。尽构诸牛着一器中。见诸牛乳同一白色寻便惊怪。牛色各异其乳云何皆同一色。是人思惟。如此一切皆是众生业报因缘令乳色一。善男子。声闻缘觉菩萨亦尔。同一佛性犹如彼乳。所以者何。同尽漏故。而诸众生言佛菩萨声闻缘觉而有差别。有诸声闻凡夫之人。疑于三乘云何无别。是诸众生久后自解一切三乘同一佛性。犹如彼人解悟乳相由业因缘。复次善男子。譬如金矿淘炼滓秽然后销融成金之后价直无量。善男子。声闻缘觉菩萨亦尔。皆得成就同一佛性。何以故。除烦恼故。如彼金矿除诸滓秽。以是义故。一切众生同一佛性无有差别。以其先闻如来密藏。后成佛时自然得知。如彼长者知乳一相。何以故。以断无量亿烦恼故。迦叶菩萨白佛言。世尊。若一切众生有佛性者。佛与众生有何差别。如是说者多有过咎。若诸众生皆有佛性。何因缘故。舍利弗等以小涅槃而般涅槃。缘觉之人于中涅槃而般涅槃。菩萨之人于大涅槃而般涅槃。如是等人若同佛性。何故不同如来涅槃而般涅槃。善男子。诸佛世尊所得涅槃。非诸声闻缘觉所得。以是义故。大般涅槃名为善有。世若无佛非无二乘得二涅槃。迦叶复言。是义云何。佛言。无量无边阿僧祇劫乃有一佛。出现于世开示三乘。善男子。如汝所言。菩萨二乘无差别者。我先于此如来密藏大涅槃中已说其义。诸阿罗汉无有善有。何以故。诸阿罗汉悉当得是大涅槃故。以是义故。大般涅槃有毕竟乐。是故名为大般涅槃。迦叶言。如佛说者。我今始知差别之义无差别义。何以故。一切菩萨声闻缘觉未来之世皆当归于大般涅槃。譬如众流归于大海。是故声闻缘觉之人。悉名为常非是无常。以是义故。亦有差别亦无差别。迦叶言。云何性差别。佛言。善男子。声闻如乳缘觉如酪。菩萨之人如生熟酥。诸佛世尊犹如醍醐。以是义故。大涅槃中说四种性而有差别。迦叶复言。一切众生性相云何。佛言。善男子。如牛新生乳血未别。凡夫之性杂诸烦恼亦复如是。迦叶复言。拘尸那城有旃陀罗名曰欢喜。佛记是人。由一发心。当于此界千佛数中速成无上正真之道。以何等故。如来不记尊者舍利弗目犍连等速成佛道。佛言。善男子。或有声闻缘觉菩萨作誓愿言。我当久久护持正法然后乃成无上佛道。以发速愿故与速记。复次善男子。譬如商人有无价宝诣市卖之。愚人见已不识轻笑。宝主唱言。我此宝珠价直无数。闻已复笑各各相谓。此非真宝是颇梨珠。善男子。声闻缘觉亦复如是。若闻速记则便懈怠轻笑薄贱。如彼愚人不识真宝。于未来世有诸比丘。不能精勤修习善法。贫穷困苦饥饿所逼。因是出家长养其身。心志轻躁邪命谄曲。若闻如来授诸声闻速疾记者。便当大笑轻慢毁呰。当知是等即是破戒。自言已得过人之法。以是义故。随发速愿故与速记。护正法者为授远记。迦叶菩萨复白佛言。世尊。菩萨摩诃萨云何当得不坏眷属。佛告迦叶。若诸菩萨勤加精进欲护正法。以是因缘所得眷属不可沮坏。迦叶菩萨复白佛言。世尊。何因缘故众生得此唇口干焦。佛告迦叶。若有不识三宝常存。以是因缘唇口干焦。如人口爽不知甜苦辛醋咸淡六味差别。一切众生愚痴无智。不识三宝是长存法。是故名为唇口干焦。复次善男子。若有众生不知如来是常住者。当知是人则为生盲。若知如来是常住者。如是之人虽有肉眼。我说是等名为天眼。复次善男子。若有能知如来是常。当知是人久已修习如是经典。我说是等亦名天眼。虽有天眼而不能知如来是常。我说斯等名为肉眼。是人乃至不识自身手足支节。亦复不能令他识知。以是义故名为肉眼

复次善男子。如来常为一切众生而作父母。所以者何。一切众生种种形类。二足四足多足无足。佛以一音而为说法。彼彼异类。各各得解。悉皆叹言。如来今日为我说法。以是义故名为父母

复次善男子。如人生子始十六月虽复语言未可解了。而彼父母欲教其语。先同其音渐渐教之。是父母语可不正耶。不也世尊。善男子。诸佛如来亦复如是。随诸众生种种音声而为说法。为令安住佛正法故。随所应见而为示现种种形像。如来如是同彼语言。可不正耶。不也世尊。何以故。如来所说如师子吼。随顺世间种种音声。而为众生劝说妙法

大般涅槃经卷第九大般涅槃经卷第十

        宋代沙门慧严等依泥洹经加之

    一切大众所问品第十七

尔时世尊。从其面门放种种色青黄赤白红紫光明。照纯陀身。纯陀遇已。与诸眷属持诸肴膳疾往佛所。欲奉如来及比丘僧最后供养。种种器物充满具足持至佛所。尔时有大威德天人。而遮其前周匝围绕。谓纯陀言。且止纯陀。勿便奉施。尔时如来复放无量无边种种光明。诸天大众遇斯光已。寻听纯陀前至佛所奉其所施。尔时天人及诸众生。各各自取所持供养至于佛前。长跪白佛唯愿如来。听诸比丘受此供养。时诸比丘知是时故。执持衣钵一心安详。尔时纯陀为佛及僧。布置种种师子宝座。悬缯幡盖。花香璎珞。尔时三千大千世界庄严微妙。犹如西方安乐国土。尔时纯陀住于佛前。忧悲怅怏重白佛言。唯愿如来。犹见哀愍住寿一劫若减一劫。佛告纯陀。汝欲令我久住世者。宜当速奉最后具足檀波罗蜜。尔时一切。菩萨摩诃萨天人杂类。异口同音唱如是言。奇哉纯陀成大福德。能令如来受其最后无上供养。我等无福所设供具则为唐捐。尔时世尊欲令一切众望满足。于自身上一一毛孔化无量佛。一一诸佛各有无量诸比丘僧。是诸世尊及无量众。悉皆示现受其供养。释迦如来自受纯陀所奉设者。尔时纯陀所持粳粮成熟之食。摩伽陀国满足八斛。以佛神力皆悉充足一切大会。尔时纯陀见是事已。心生欢喜踊跃无量。一切大众亦复如是。尔时大众承佛圣旨。各作是念。如来今已受我等施。不久便当入于涅槃。作是念已心生悲喜。尔时树林其地狭小。以佛神力如针锋处。皆有无量诸佛世尊及其眷属等坐而食。所食之物亦无差别。是时天人阿修罗等啼泣悲叹。而作是言。如来今日已受我等最后供养。受供养已当般涅槃。我等当复更供养谁。我今永离无上调御盲无眼目。尔时世尊为欲安慰一切大众。而说偈言

  汝等莫悲叹　　诸佛法应尔
  我入于涅槃　　已经无量劫
  常受最胜乐　　永处安隐处
  汝今至心听　　我当说涅槃
  我已离食想　　终无饥渴患
  今当为汝等　　说其随顺愿
  令诸一切众　　咸得安隐乐
  汝闻应修行　　诸佛法常住
  假使乌与枭　　同共一树栖
  犹如亲兄弟　　尔乃永涅槃
  如来视一切　　犹如罗睺罗
  常为众生尊　　云何永涅槃
  假使蛇鼠狼　　同处一穴游
  相爱如兄弟　　尔乃永涅槃
  如来视一切　　犹如罗睺罗
  常为众生尊　　云何永涅槃
  假使七叶花　　转为婆师香
  迦留为镇头　　尔乃永涅槃
  如来视一切　　犹如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使一阐提　　现身成佛道
  永处第一乐　　尔乃入涅槃
  如来视一切　　皆如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使一切众　　一时成佛道
  远离诸过患　　尔乃入涅槃
  如来视一切　　皆如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使蚊蚋水　　浸坏于大地
  川谷海盈满　　尔乃入涅槃
  悲心视一切　　皆如罗睺罗
  常为众生尊　　云何永涅槃
  以是故汝等　　应深乐正法
  不应生忧恼　　号泣而啼哭
  若欲自正行　　应修如来常
  当观如是法　　长存不变易
  复应生是念　　三宝皆常住
  是则获大护　　如咒枯生果
  是名为三宝　　四众应善听
  闻已应欢喜　　即发菩提心
  若能计三宝　　常住同真谛
  此则是诸佛　　最上之誓愿

若有比丘比丘尼优婆塞优婆夷。能以如来最上誓愿而发愿者。当知是人无有愚痴堪受供养。以此愿力功德果报。于世最胜如阿罗汉。若有不能如是观了三宝常者。是旃陀罗。若有能知三宝常住实法因缘。离苦安乐无有娆害能留难者。尔时人天大众阿修罗等。闻是法已。心生欢喜踊跃无量。其心调柔善灭诸盖。心无高下威仪清净。颜貌怡悦知佛常住。是故施设诸天供养。散种种花末香涂香鼓天伎乐以供养佛。尔时佛告迦叶菩萨言。善男子。汝见是众希有事不。迦叶答言。已见世尊见诸如来无量无边不可称计受诸大众人天所奉饭食供养。又见诸佛大身庄严所坐之处如一针锋多众围绕不相障碍。复见大众悉发誓愿说十三偈。亦知大众各心念言如来今者独受我供。假使纯陀所奉饭食碎如微尘。一尘一佛犹不周遍。以佛神力悉皆充足一切大众。唯诸菩萨摩诃萨文殊师利法王子等。能知如是希有事耳。悉是如来方便示现。声闻大众及阿修罗等皆知如来是常住法。尔时世尊告纯陀言。汝今所见为是希有奇特事不。实尔世尊。我先所见无量诸佛三十二相八十种好庄严其身。今悉见为菩萨摩诃萨巨身殊异颜貌无比。唯见佛身譬如药树。为诸菩萨摩诃萨等之所围绕。佛告纯陀。汝先所见无量佛者是我所化。为欲利益一切众生令得欢喜。如是菩萨摩诃萨等所可修行不可思议。能作无量诸佛之事。纯陀。汝今皆已成就菩萨摩诃萨行得住十地菩萨所行具足成办。迦叶菩萨白佛言。世尊。如是如是如佛所说。纯陀所修成菩萨行我亦随喜。今者如来欲为未来无量众生作大明故。说是大乘大涅槃经。世尊。一切契经说有余义无余义耶。善男子。我所说者。亦有余义亦无余义。纯陀白佛言。世尊。如佛所说

  所有之物　　布施一切　　唯可赞叹
  无可毁损

世尊。是义云何。持戒毁戒有何差别。佛言。唯除一人余一切施皆可赞叹。纯陀问言。云何名为唯除一人。佛言。如此经中所说破戒。纯陀复言。我今未解。唯愿说之。佛告纯陀。言破戒者谓一阐提。其余在所一切布施皆可赞叹。获大果报。纯陀复问。一阐提者其义云何。佛告纯陀。若有比丘及比丘尼优婆塞优婆夷。发粗恶言诽谤正法。造是重业永不改悔心无惭愧。如是等人名为趣向一阐提道。若犯四重作五逆罪。自知定犯如是重事。而心初无怖畏惭愧不肯发露。于佛正法永无护惜建立之心。毁呰轻贱言多过咎。如是等人亦名趣向一阐提道。若复说言无佛法僧。如是等人亦名趣向一阐提道。唯除如此一阐提辈。施其余者一切赞叹

尔时纯陀复白佛言。世尊。所言破戒其义云何。佛告纯陀。若犯四重及五逆罪诽谤正法。如是等人名为破戒。纯陀复问。如是破戒可拔济不。佛告纯陀。有因缘故则可拔济。若被法服犹未舍远。其心常怀惭愧恐怖而自考责。咄哉何为犯斯重罪。何其怪哉造斯苦业。深自改悔生护法心。欲建正法。有护法者我当供养。若有读诵大乘典者。我当咨问受持读诵。既通利已复当为他分别广说。我说是人不为破戒。何以故。善男子。譬如日出能除一切尘翳闇冥。是大涅槃微妙经典出兴于世亦复如是。能除众生无量劫中所作众罪。是故此经说护正法得大果报拔济破戒。若有毁谤是正法者。能自改悔还归于法自念所作一切不善。如人自害心生恐怖惊惧惭愧。除此正法更无救护。是故应当还归正法。若能如是如说归依。布施是人得福无量。亦名世间应受供养。若犯如上恶业之罪。若经一月或十五日。不生归依发露之心。若施是人果报甚少。犯五逆者亦复如是。能生悔心内怀惭愧。今我所作不善之业甚为大苦。我当建立护持正法。是则不名五逆罪也。若施是人得福无量。犯逆罪已不生护法归依之心。有施是者福不足言。又善男子。犯重罪者汝今谛听。我当为汝分别广说。应生是心。谓正法者即是如来微密之藏。是故我当护持建立。施是人者得胜果报。善男子。譬如女人怀妊垂产值国荒乱远至他土在一天庙即便产育。后闻旧邦安隐丰熟。携持其子。欲还本土。路经恒河水涨暴急。荷负是儿不能得渡。即自念言。我宁与子一处并命。终不舍弃而独济也。作是念已与子俱没。命终之后寻生天中。以慈念子欲令得渡。而是女人本性弊恶。以爱子故得生天中。犯四重禁五无间罪。生护法心亦复如是。虽复先为不善之业。以护法故得为世间无上福田是护法者有如是等无量果报

纯陀复言。世尊。若一阐提能自改悔。恭敬供养赞叹三宝。施如是人得大果不。佛言。善男子。汝今不应作如是说。善男子。譬如有人食庵罗果吐核置地。而复念言。是果核中应有甘味。即复还取破而尝之。其味极苦心生悔恨。恐失果种即还收拾种之于地勤加修治。以苏油乳随时溉灌。于意云何。宁可生不。不也世尊。假使天降无上甘雨犹亦不生。善男子。彼一阐提亦复如是烧灭善根。当于何所而得除罪。善男子。若生善心是则不名一阐提也。善男子。以是义故。一切所施所得果报非无差别。何以故。施诸声闻所得报异。施辟支佛得报亦异。唯施如来获无上果。是故说言一切所施非无差别

纯陀复言。何故如来而说此偈。佛告纯陀。有因缘故我说此偈。王舍城中有优婆塞。心无净信奉事尼犍。而来问我布施之义。以是因缘故说斯偈。亦为菩萨摩诃萨等说秘藏义。如斯偈者其义云何。一切者少分一切。当知菩萨摩诃萨人中之雄。摄取持戒施其所须。舍弃破戒如除稊稗复次善男子。如我昔日所说偈言

  一切江河　　必有回曲　　一切丛林
  必名树木　　一切女人　　必怀谄曲
  一切自在　　必受安乐

尔时文殊师利菩萨摩诃萨。即从座起偏袒右臂右膝着地。前礼佛足而说偈言

  非一切河　　必有回曲　　非一切林
  悉名树木　　非一切女　　必怀谄曲
  一切自在　　不必受乐

佛所说偈其义有余。唯垂哀愍说其因缘。何以故。世尊。于此三千大千世界。有洲名拘耶尼。其洲有河端直不曲。名娑婆耶。犹如直绳入于西海。如是河相于余经中佛未曾说。唯愿如来。因此方等阿含经中说有余义。令诸菩萨深信解之。世尊。譬如有人先识金矿后不识金。如来亦尔。尽知法已。而所演说有余不尽。如来虽作如是余说。应当方便解其意趣。一切丛林必是树木。是亦有余。何以故。种种金银琉璃宝树。是亦名林。一切女人必怀谄曲。是亦有余。何以故。亦有女人善持禁戒。功德成就有大慈悲。一切自在必受安乐。是亦有余。何以故。有自在者转轮圣帝。如来法王不属死魔不可灭尽。梵释诸天虽得自在悉是无常。若得常住无变易者乃名自在。所谓大乘大般涅槃。佛言。善男子。汝今善得乐说之辩。且止谛听。文殊师利。譬如长者身婴病苦良医诊之为合膏药。是时病者贪欲多服。医语之言。若能消者则可随意。汝今体羸不应多服。当知是膏亦名甘露亦名毒药。若多服不消则名为毒。善男子。汝今勿谓是医所说。违于义理损失膏势。善男子。如来亦尔。为诸国王后妃太子王子大臣。因波斯匿王王子后妃憍慢心故。为欲调伏示现恐怖如彼良医。故说此偈

  一切江河　　必有回曲　　一切丛林
  必名树木　　一切女人　　必怀谄曲
  一切自在　　必受安乐

文殊师利。汝今当知。如来所说无有漏失。如此大地可令反覆。如来之言终无漏失。以是义故。如来所说一切有余。尔时佛赞文殊师利。善哉善哉善男子。汝已久知如是之义。愍哀一切。欲令众生得智慧故。广问如来如是偈义。尔时文殊师利法王子。复于佛前而说偈言

  于他语言　　随顺不逆　　亦不观他
  作以不作　　但自观身　　善不善行

世尊如是说此法药非为正说。于他语言随顺不逆者。唯愿如来垂哀正说。何以故。世尊。常说一切外学九十五种皆趣恶道。声闻弟子皆向正路。若护禁戒摄持威仪守慎诸根。如是等人深乐大法趣向善道。如来何故。于九部中见有毁他则便呵责。如是偈义为何所趣。佛告文殊师利。善男子我说此偈亦不尽为一切众生。尔时唯为阿阇世王。诸佛世尊若无因缘终不逆说。有因缘故乃说之耳。善男子。阿阇世王害其父已。来至我所欲折伏我。作如是问。云何世尊。是一切智非一切智耶。若一切智。调达往昔无量世中常怀恶心。随逐如来欲为逆害。云何如来听其出家。善男子以是因缘我为是王。而说此偈

  于他语言　　随顺不逆　　亦不观他
  作以不作　　但自观身　　善不善行

佛告大王。汝今害父已作逆罪最重无间。应当发露以求清净。何缘乃更见他过咎。善男子。以是义故。我为彼王而说是偈。复次善男子。亦为护持不毁禁戒成就威仪见他过者。而说是偈。若复有人受他教诲远离众恶。复教他人令远众恶。如是之人则我弟子。尔时世尊为文殊师利。复说偈言

  一切畏刀杖　　无不爱寿命
  恕己可为譬　　勿杀勿行杖

尔时文殊师利复于佛前。而说偈言

  非一切畏杖　　非一切爱命
  恕己可为譬　　勤作善方便

如来说是法句之义亦是未尽。何以故。如阿罗汉转轮圣王玉女象马主藏大臣。若诸天人及阿修罗。执持利剑能害之者。无有是处。勇士烈女马王兽王持戒比丘。虽复对至而不恐怖。以是义故。如来说偈亦是有余。若言恕己可为譬者。是亦有余。何以故。若使罗汉以己喻彼。则有我想及以命想。若有我想及以命想。则应拥护。凡夫亦应见阿罗汉悉是行人。若如是者即是邪见。若有邪见命终应生阿鼻地狱。又阿罗汉设于众生生害心者。无有是处。无量众生亦复无能害罗汉者。佛言。善男子。言我想者。谓于众生生大悲心无杀害想。谓阿罗汉平等之心。勿谓世尊无有因缘而逆说也。昔日于此王舍城中有大猎师。多杀群鹿请我食肉。我于尔时虽受彼请。于诸众生生慈悲心如罗睺罗。而说偈言

  当令汝长寿　　久久住于世
  受持不害法　　犹如诸佛寿

是故我说此偈

  一切畏刀杖　　无不爱寿命
  恕己可为譬　　勿杀勿行杖

佛言。善哉善哉文殊师利。为诸菩萨摩诃萨故。咨问如来如是密教

尔时文殊师利。复说是偈

  云何敬父母　　随顺而尊重
  云何修此法　　堕于无间狱

于是如来。复以偈答

  若以贪爱母　　无明以为父
  随顺尊重是　　则堕无间狱

尔时如来复为文殊师利。重说偈言

  一切属他　　则名为苦　　一切由己
  自在安乐　　一切憍慢　　势极暴恶
  贤善之人　　一切爱念

尔时文殊师利菩萨摩诃萨白佛言。世尊。如来所说是亦不尽。唯愿如来复垂哀愍说其因缘。何以故。如长者子从师学时为属师不。若属师者义不成就。若不属者亦不成就。若得自在亦不成就。是故如来所说有余。复次世尊。譬如王子无所综习触事不成是亦自在愚闇常苦。如是王子若言自在义亦不成。若言属他义亦不成。以是义故。佛所说义名为有余。是故一切属他不必受苦。一切自在不必受乐。一切憍慢势极暴恶。是亦有余。世尊。如诸列女憍慢心故出家学道。护持禁戒威仪成就。守摄诸根不令驰散。是故一切憍慢之结不必暴恶。贤善之人一切爱念。是亦有余。如人内犯四重禁已。不舍法服坚持威仪。护持法者见已不爱是人。命终必堕地狱。若有善人犯重禁已护持法者。见即驱出罢道还俗。以是义故。一切贤善不必悉爱。尔时佛告文殊师利。有因缘故如来于此说有余义。又有因缘诸佛如来而说是法。时王舍城有一女人名曰善贤。还父母家因至我所。归依于我及法众僧。而作是言。一切女人势不自由。一切男子自在无碍。我于尔时知是女心。即为宣说如是偈颂。文殊师利。善哉善哉。汝今能为一切众生。问于如来如是密语。文殊师利复说偈言

  一切诸众生　　皆依饮食存
  一切有大力　　其心无嫉妒
  一切因饮食　　而得诸病苦
  一切修净行　　而得受安乐

如是世尊。今受纯陀饮食供养。将无如来有恐怖耶。尔时世尊复为文殊。而说偈言

  非一切众生　　尽依饮食存
  非一切大力　　心皆无嫉妒
  非一切因食　　而致诸病苦
  非一切净行　　悉得受安乐

文殊师利。汝若得病我亦如是应得病苦。何以故。诸阿罗汉及辟支佛菩萨如来实无所食。为欲化彼示现受用无量众生所施之物。令其具足檀波罗蜜。拔济地狱畜生饿鬼。若言如来六年苦行身羸瘦者。无有是处。诸佛世尊独拔诸有不同凡夫。云何而得身羸劣耶。诸佛世尊精勤修习获金刚身。不同世人危脆之身。我诸弟子亦复如是。不可思议不依于食。一切大力无嫉妒者。亦有余义。如世间人终身永无嫉妒之心而无大力。一切病苦因食得者。亦有余义。亦见有人得客病者。所谓刺刺刀剑鉾槊。一切净行受安乐者。是亦有余。世间亦有外道之人。修于梵行多受苦恼。以是义故如来所说一切有余。是名如来非无因缘。而说此偈有因故说。昔日于此优禅尼国。有婆罗门名羖羝德。来至我所欲受第四八戒斋法。我于尔时为说是偈

尔时迦叶菩萨白佛言。世尊。何等名为无余义耶。云何复名一切义乎。善男子。一切者唯除助道常乐善法。是名一切。亦名无余。其余诸法亦名有余亦名无余。欲令乐法诸善男子知此有余及无余义。迦叶菩萨心大欢喜。踊跃无量前白佛言。甚奇世尊。等视众生如罗睺罗。尔时佛赞迦叶菩萨。善哉善哉。汝今所见微妙甚深

迦叶菩萨白佛言。世尊。唯愿如来说是大乘。大涅槃经所得功德。佛告迦叶。善男子。若有得闻是经名字。所得功德非诸声闻辟支佛等所能宣说。唯佛能知。何以故。不可思议是佛境界。何况受持读诵通利书写经卷

尔时诸天世人及阿修罗。即于佛前异口同音。而说偈言

  诸佛难思议　　法僧亦复然
  是故今劝请　　唯愿少停住
  尊者大迦叶　　及以阿难等
  二众之眷属　　不久须臾至
  并及摩竭主　　阿阇世大王
  至心敬信佛　　犹故未来此
  唯愿佛世尊　　少垂哀愍住
  于此大众中　　断我诸疑网

尔时如来为诸大众。而说偈言

  我法最长子　　是名大迦叶
  阿难勤精进　　能断一切疑
  汝等当谛观　　阿难多闻士
  自然能解了　　是常及无常
  以是故不应　　心怀大忧恼

尔时大众以种种物供养如来。供养佛已即发阿耨多罗三藐三菩提心。无量无边恒河沙数诸菩萨等得住初地。尔时世尊与文殊师利迦叶菩萨及与纯陀而受记莂。受记莂已说如是言。诸善男子。自修其心慎莫放逸。我今背疾举体皆痛。我今欲卧如彼小儿及常患者。文殊汝等。当为四部广说大法。今以此法付嘱于汝。乃至迦叶阿难等至。复当嘱付如是正法。尔时如来说是语已。为欲调伏诸众生故。现身有疾右胁而卧。如彼病人

    大般涅槃经现病品第十八

尔时迦叶菩萨白佛言。世尊。如来已免一切疾病。患苦悉除无复怖畏。世尊。一切众生有四毒箭则为病因。何等为四。贪欲嗔恚愚痴憍慢。若有病因则有病生所谓爱热肺病上气吐逆。肤体[病-丙+習][病-丙+習]其心闷乱。下痢哕噎小便麻沥。眼耳疼痛腹背胀满。颠狂干消鬼魅所著。如是种种身心诸病。诸佛世尊悉无复有。今日如来何缘顾命文殊师利。而作是言。我今背痛汝等当为大众说法。有二因缘则无病苦。何等为二。一者邻愍一切众生。二者给施病者医药。如来往昔已于无量万亿劫中。修菩萨道常行爱语。利益众生不令苦恼。施疾病者种种医药。何缘于今自言有病。世尊。世人有病或坐或卧不安其处。或索饮食敕诫家属修治产业。何故如来默然而卧。不教弟子声闻人等尸波罗蜜诸禅解脱三摩跋提修诸正勤。何缘不说如是甚深大乘经典。如来何故不以无量方便教大迦叶人中象王诸大人等。令其不退阿耨多罗三藐三菩提。何故不治诸恶比丘受畜一切不净物者世尊。实无有病云何默然右胁而卧。诸菩萨等凡所给施病者医药。所得善根悉施众生。而共回向一切种智。为除众生诸烦恼障业障报障。烦恼障者。贪欲嗔恚愚痴忿怒。缠盖焦恼嫉妒悭吝。奸诈谀谄无惭无愧。慢慢慢不如慢增上慢我慢邪慢憍慢。放逸贡高怼恨诤讼。邪命谄媚诈现异相。以利求利恶求多求。无有恭敬不随教诲。亲近恶友贪利无厌缠缚难解。欲于恶欲贪于恶贪。身见有见及以无见。频申喜睡欠呿不乐。贪嗜饮食其心[夢-夕+登]瞢。心缘异想不善思惟。身口多恶好喜多语。诸根闇钝发言多虚。常为欲觉恚觉害觉之所覆盖。是名烦恼障。业障者。五无间罪重恶之病。报障者。生在地狱畜生饿鬼诽谤正法及一阐提。是名报障。如是三障名为大病。而诸菩萨于无量劫修菩提时。给施一切疾病医药。常作是愿。令诸众生永断如是三障重病。复次世尊。菩萨摩诃萨修菩提时。给施一切病者医药。常作是愿。愿令众生永断诸病得成如来金刚之身。又愿一切无量众生作妙药王。断除一切诸恶重病。愿诸众生得阿伽陀药。以是药力能除一切无量恶毒。又愿众生于阿耨多罗三藐三菩提无有退转。速得成就无上佛药消除一切烦恼毒箭。又愿众生勤修精进。成就如来金刚之心。作微妙药疗治众病。不令有人生诤讼想。亦愿众生作大药树。疗治一切诸恶重病。又愿众生拔出毒箭。得成如来无上光明。又愿众生得入如来智慧大药微密法藏。世尊。菩萨如是已于无量百千万亿那由他劫。发是誓愿。令诸众生悉无诸病。何缘如来乃于今日唱言有病。复次世尊。世有病者不能坐起俯仰进止。饮食不御浆水不下。亦复不能教诫诸子修治家业。尔时父母妻子兄弟亲属知识。皆于是人生必死想。世尊。如来今日亦复如是。右胁而卧无所论说。此阎浮提有诸愚人当作是念。如来正觉必当涅槃生灭尽想。而如来性实不毕竟入于涅槃。何以故。如来常住无变易故。以是因缘不应说言我今背痛

复次世尊。世有病者身体羸损。若偃若侧卧着床褥。尔时众人心生恶贱起必死想。如来今者亦复如是。当为外道九十五种之所轻慢生无常想。彼诸外道当作是言。不如我等以我性人自在时节微尘等法而为常住无有变易。沙门瞿昙无常所迁是变易法。以是义故。世尊。今日不应默然右胁而卧。复次世尊。世有病者四大增损。互不调适羸瘦乏极。是故不能随意坐起卧着床褥。如来四大无不和适。身力具足亦无羸损。世尊。如十小牛力不如一大牛力。十大牛力不如一青牛力。十青牛力不如一凡象力。十凡象力不如一野象力。十野象力不如一二牙象力。十二牙象力不如一四牙象力。十四牙象力不如雪山一白象力。十雪山白象力不如一香象力。十香象力不如一青象力。十青象力不如一黄象力。十黄象力不如一赤象力。十赤象力不如一白象力。十白象力不如一山象力。十山象力不如一优钵罗象力。十优钵罗象力不如一波头摩象力。十波头摩象力不如一拘物头象力。十拘物头象力不如一分陀利象力。十分陀利象力不如人中一力士力。十人中力士力不如一钵健提力。十钵健提力不如一八臂那罗延力。十那罗延力不如一十住菩萨一节之力。一切凡夫身中诸节节不相到。人中力士节头相到。钵健提身诸节相接。那罗延身节头相拘。十住菩萨诸节骨解蟠龙相结。是故菩萨其力最大。世界成时从金刚际起金刚座。上至道场菩提树下。菩萨坐已其心即时逮得十力。如来今者不应如彼婴孩小儿。婴孩小儿愚痴无智无所能说。以是义故。随意偃侧无人讥诃。如来世尊有大智慧照明一切。人之大龙具大威德成就神通。无上仙人永断疑网。已拔毒箭进止安详。威仪具足得无所畏。今者何故右胁而卧。令诸人天悲愁苦恼。尔时迦叶菩萨即于佛前而说偈言

  瞿昙大圣德　　愿起演妙法
  不应如小儿　　病者卧床蓐
  调御天人师　　倚卧双树间
  下愚凡夫见　　当言必涅槃
  不知方等典　　甚深佛所行
  不见微密藏　　犹盲不见道
  唯有诸菩萨　　文殊师利等
  能解是甚深　　譬如善射人
  三世诸世尊　　大悲为根本
  如是大慈悲　　今为何所在
  若无大悲者　　是则不名佛
  佛若必涅槃　　是则不名常
  唯愿无上尊　　哀受我等请
  利益于众生　　摧伏诸外道

尔时世尊大悲熏心。知诸众生各各所念。将欲随顺毕竟利益。即从卧起结跏趺坐。颜貌熙怡如融金聚。面目端严犹月盛满。形容清净无诸垢秽。放大光明充遍虚空。其光大盛过百千日。照于东方南西北方四维上下诸佛世界。惠施众生大智之炬悉令得灭无明黑闇。令百千亿那由他众生安止不退菩提之心。尔时世尊心无疑虑如师子王。以三十二大人之相八十种好庄严其身。于其身上一切毛孔。一一毛孔出一莲花。其花微妙各具千叶。纯真金色。琉璃为茎金刚为须玫瑰为台。形大团圆犹如车轮。是诸莲花各出种种杂色光明。青黄赤白紫颇梨色。是诸光明皆悉遍至阿鼻地狱想地狱黑绳地狱众合地狱叫唤地狱大叫唤地狱焦热地狱大焦热地狱。是八地狱其中众生。常为诸苦之所逼切。所谓烧煮火炙斫刺[利-禾+皮]剥。遇斯光已如是众苦悉灭无余。安隐清凉快乐无极。是光明中宣说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中。乃至八种寒冰地狱。所谓阿波波地狱阿吒吒地狱阿罗罗地狱阿娑娑地狱优钵罗地狱波头摩地狱拘物头地狱分陀利地狱。是中众生常为寒苦之所逼恼。所谓擘裂身体碎坏互相残害。遇斯光已如是等苦亦灭无余。即得调和温暖适身。是光明中亦说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中尔时于此阎浮提界及余世界。所有地狱。皆悉空虚无受罪者除一阐提。饿鬼众生饥渴所逼以发缠身。于百千岁未曾得闻浆水之名。遇斯光已饥渴即除。是光明中亦说如来微密秘藏。言诸众生皆有佛性。众生闻已即便命终生人天中。令诸饿鬼亦悉空虚。除谤大乘方等正典。畜生众生互相杀害共相残食。遇斯光已恚心悉灭。是光明中亦说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中。当尔之时畜生亦尽。除谤正法。是一一花各有一佛。圆光一寻金色晃曜。微妙端严最上无比三十二相八十种好庄严其身。是诸世尊或有坐者或有行者。或有卧者。或有住者。或震雷音或澍洪雨。或放电光或扇大风。或出烟焰身如火聚。或复示现七宝诸山池泉河水山林树木。或复示现七宝国土城邑聚落宫殿屋宅。或复示现象马师子虎狼孔雀凤凰诸鸟。或复示现令阎浮提所有众生悉见地狱畜生饿鬼。或复示现欲界六天。复有世尊。或说阴界诸入多诸过患。或复有说四圣谛法。或复有说诸法因缘。或复有说诸业烦恼皆因缘生。或复有说我与无我。或复有说苦乐二法。或复有说常无常等。或复有说净与不净。复有世尊。为诸菩萨演说所行六波罗蜜。或复有说诸大菩萨所得功德。或复有说诸佛世尊所得功德。或复有说声闻之人所得功德。或复有说随顺一乘。或复有说三乘成道。或有世尊。左胁出水右胁出火。或有示现初生出家坐于道场菩提树下转妙法轮入于涅槃。或有世尊作师子吼。令此会中有得一果二果三果至第四果。或复有说出离生死无量因缘。尔时于此阎浮提中。所有众生遇斯光已。盲者见色聋者听声。哑者能言拘躄能行。贫者得财悭者能施。恚者慈心不信者信。如是世界无一众生修行恶法。除一阐提。尔时一切天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。罗刹健陀忧摩陀阿婆魔罗人非人等。悉共同声唱如是言。善哉善哉。无上天尊多所利益。说是语已踊跃欢喜。或歌或舞或身动转。以种种花散佛及僧。所谓天优钵罗花拘物头花波头摩花分陀利花。曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花散陀那华摩诃散陀那花。卢脂那花摩诃卢脂那花。香花大香花。适意花大适意花。爱见花大爱见花。端严花第一端严花。复散诸香。所谓沉水多伽楼香。栴檀郁金和合杂香海岸聚香。复以天上宝幢幡盖诸天伎乐筝笛笙瑟箜篌鼓吹。供养于佛而说偈言

  我今稽首大精进　　无上正觉两足尊
  天人大众所不知　　唯有瞿昙乃能了
  世尊往昔为我故　　于无量劫修苦行
  如何一旦弃本誓　　而便舍命欲涅槃
  一切众生不能见　　诸佛世尊秘密藏
  以是因缘难得出　　轮转生死坠恶道
  如佛所说阿罗汉　　一切皆当至涅槃
  如是甚深佛行处　　凡夫下愚谁能知
  施诸众生甘露法　　为断除彼诸烦恼
  若有服此甘露已　　不复受生老病死
  如来世尊已疗治　　百千无量诸众生
  令其所有诸重病　　一切消灭无遗余
  世尊久已舍病苦　　故得名为第七佛
  唯愿今日雨法雨　　润渍我等功德种
  是诸大众及人天　　如是请已默然住

说是偈时。莲花台中一切诸佛。从阎浮提遍至净居悉皆闻之。尔时佛告迦叶菩萨。善哉善哉。善男子。汝已具足如是甚深微妙智慧。不为一切诸魔外道之所破坏。善男子。汝已安住不为一切诸恶邪风之所倾动。善男子。汝已成就乐说辩才。已曾供养过去无量恒河沙等诸佛世尊。是故能问如来正觉如是之义。善男子。我于往昔无量无边亿那由他百千万劫。已除病根永离倚卧。迦叶。过去无量阿僧祇劫有佛出世。号无上胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸声闻说是大乘大涅槃经。开示分别显发其义。我于尔时亦为彼佛而作声闻。受持如是大涅槃典。读诵通利书写经卷。广为他人开示分别解说其义。以是善根回向阿耨多罗三藐三菩提。善男子。我从是来未曾有恶烦恼业缘堕于恶道。诽谤正法作一阐提。受黄门身无根二根。反逆父母杀阿罗汉破塔坏僧出佛身血。犯四重禁。从是已来身心安隐无诸苦恼。迦叶。我今实无一切疾病。所以者何。诸佛世尊久已远离一切病故。迦叶。是诸众生不知大乘方等密教。便谓如来真实有疾

迦叶。如言如来人中师子。而如来者实非师子。如是之言即是如来秘密之教。迦叶。如言如来人中大龙。而我已于无量劫中舍离是业。迦叶。如言如来是人是天。而我真实非人非天。亦非鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。非我非命非可养育。非人士夫。非作非不作。非受非不受。非世尊非声闻。非说非不说。如是等语皆是如来秘密之教

迦叶。如言如来犹如大海须弥山王。而如来者实非碱味同于石山。当知是语亦是如来秘密之教。迦叶。如言如来如分陀利。而我实非分陀利也。如是之言即是如来秘密之教。迦叶。如言如来犹如父母。而如来者实非父母。如是之言亦是如来秘密之教。迦叶。如言如来是大船师。而如来者实非船师。如是之言亦是如来秘密之教。迦叶。如言如来犹如商主。而如来者实非商主。如是之言亦是如来秘密之教。迦叶。如言如来能摧伏魔。而如来者实无恶心欲令他伏。如是之言。皆是如来秘密之教。迦叶。如言如来能治痈疮。而我实非治痈疮师。如是之言亦是如来秘密之教。迦叶。如我先说。若有善男子善女人善能修治身口意业。舍命之时。虽有亲族取其尸骸或以火烧或投大水或弃冢间狐狼禽兽竞共食啖。然心意识即生善道。而是心法实无去来亦无所至。直是前后相似相续相貌不异。如是之言即是如来秘密之教。迦叶。我今言病亦复如是。亦是如来秘密之教。是故顾命文殊师利。吾今背痛。汝等当为四众说法。迦叶。如来正觉实无有病右胁而卧。亦不毕竟入于涅槃。迦叶。是大涅槃即是诸佛甚深禅定。如是禅定非是声闻缘觉行处。迦叶。汝先所问。如来何故倚卧不起不索饮食诫敕家属修治产业。迦叶。虚空之性亦无坐起求索饮食敕诫家属修治产业。亦无去来生灭老壮出没伤破解脱系缚。亦不自说亦不说他。亦不自解亦不解他。非安非病。善男子。诸佛世尊亦复如是。犹如虚空。云何当有诸病苦耶

迦叶。世有三人其病难治。一谤大乘。二五逆罪。三一阐提。如是三病世中极重。悉非声闻缘觉之所能治。善男子。譬如有病必死难治。若有瞻病随意医药。若无瞻病随意医药。如是之病定不可治。当知是人必死不疑。善男子。是三种人亦复如是。若有声闻缘觉菩萨。或有说法或不说法。不能令其发阿耨多罗三藐三菩提心。迦叶。譬如病人。若有瞻病随意医药则可令差。若无此三则不可差。声闻缘觉亦复如是。从佛菩萨得闻法已。即便能发阿耨多罗三藐三菩提心。非不闻法能发心也。迦叶。譬如病人。若有瞻病随意医药。若无瞻病随意医药。皆悉可差。有一种人亦复如是。或值声闻不值声闻。或值缘觉不值缘觉。或值菩萨不值菩萨。或值如来不值如来。或得闻法或不闻法。自然得成阿耨多罗三藐三菩提。所谓有人或为自身或为他身。或为怖畏或为利养。或为谀谄或为诳他。书写如是大涅槃经。受持读诵供养恭敬为他说者

迦叶。有五种人于是大乘大涅槃典。有病行处非如来也。何等为五。一断三结得须陀洹果。不堕地狱畜生饿鬼。人天七返永断诸苦入于涅槃。迦叶。是名第一人有病行处。是人未来过八万劫。便当得成阿耨多罗三藐三菩提。迦叶。第二人者。断三结缚薄贪恚痴。得斯陀含果名一往来。永断诸苦入于涅槃。迦叶。是名第二人有病行处。是人未来过六万劫。便当得成阿耨多罗三藐三菩提。迦叶。第三人者。断五下结得阿那含果更不来此。永断诸苦入于涅槃。是名第三人有病行处。是人未来过四万劫。便当得成阿耨多罗三藐三菩提。迦叶。第四人者。永断贪欲嗔恚愚痴。得阿罗汉果烦恼无余入于涅槃。亦非麒麟独一之行。是名第四人有病行处。是人未来过二万劫。便当得成阿耨多罗三藐三菩提。迦叶。第五人者。永断贪欲嗔恚愚痴。得辟支佛道烦恼无余入于涅槃。真是麒麟独一之行。是名第五人有病行处。是人未来过十千劫。便当得成阿耨多罗三藐三菩提。迦叶。是名第五人有病行处。非如来也

大般涅槃经卷第十大般涅槃经卷第十一

        宋代沙门慧严等依泥洹经加之

    圣行品第十九之一

尔时佛告迦叶菩萨。善男子。菩萨摩诃萨应当于是般涅槃经专心思惟五种之行。何等为五。一者圣行。二者梵行。三者天行。四者婴儿行。五者病行。善男子。菩萨摩诃萨常当修习是五种行。复有一行是如来行。所谓大乘大涅槃经。迦叶。云何菩萨摩诃萨所修圣行。菩萨摩诃萨若从声闻若从如来。得闻如是大涅槃经。闻已生信。信已应作如是思惟。诸佛世尊有无上道有大正法大众正行。复有方等大乘经典。我今当为爱乐贪求大乘经故。舍离所爱妻子眷属所居舍宅金银珍宝微妙璎珞香花伎乐奴仆给使男女大小象马车乘牛羊鸡犬猪豕之属。复作是念。居家逼迫犹如牢狱。一切烦恼由之而生。出家闲旷犹如虚空。一切善法因之增长。若在家居不得尽寿净修梵行。我今应当剃除鬓发出家学道。复作是念。我今定当出家修学无上正真菩提之道。菩萨如是欲出家时。天魔波旬生大苦恼言。是菩萨复当与我兴大战诤。善男子。如是菩萨云何当复与人战诤。是时菩萨即至僧坊。若见如来及佛弟子。威仪具足诸根寂静。其心柔和清净寂灭。即至其所。而求出家。剃除须发服三法衣。既出家已奉持禁戒威仪不缺。进止安祥无所触犯。乃至小罪心生怖畏。护戒之心犹如金刚。善男子。譬如有人带持浮囊欲渡大海。尔时海中有一罗刹。即从此人乞索浮囊。其人闻已即作是念。我今若与必定没死。答言。罗刹。汝宁杀我浮囊叵得。罗刹复言。汝若不能全与我者。见惠其半。是人犹故不肯与之。罗刹复言。汝若不能惠我半者。幸愿与我三分之一。是人不肯。罗刹复言。若不能者施我手许。是人不肯。罗刹复言。汝今若复不能与我如手许者。我今饥穷众苦所逼。愿当济我如微尘许。是人复言。汝今所索诚复不多然我今日方当渡海。不知前道近远如何。若与汝者气当渐出。大海之难何由得过。能脱中路没水而死。善男子。菩萨摩诃萨护持禁戒亦复如是。如彼渡人护惜浮囊。菩萨如是守护戒时。常有烦恼诸恶罗刹。语菩萨言。汝当信我终不相欺。但破四禁护持余戒。以是因缘令汝安隐得入涅槃。菩萨尔时应作是言。我今宁持如是禁戒堕阿鼻狱。终不毁犯而生天上。烦恼罗刹复作是言。汝若不能破四禁者。可破僧残。以是因缘令汝安隐得入涅槃。菩萨亦应不随其语。罗刹复言。卿若不能犯僧残者。亦可故犯偷兰遮罪。以是因缘令汝安隐得入涅槃。菩萨尔时亦复不随。罗刹复言。卿若不能犯偷兰遮。可犯舍堕。以是因缘可得安隐入于涅槃。菩萨尔时亦复不随。罗刹复言。卿若不能犯舍堕者。可破波夜提。以是因缘令汝安隐得入涅槃。菩萨尔时亦复不随。罗刹复言。卿若不能犯波夜提者。幸可毁破突吉罗戒。以是因缘可得安隐入于涅槃。菩萨尔时心自念言。我今若犯突吉罗罪不发露者。则不能渡生死彼岸而得涅槃。菩萨摩诃萨于是微小诸戒律中。护持坚固心如金刚。菩萨摩诃萨持四重禁及突吉罗。敬重坚固等无差别。菩萨若能如是坚持。则为具足五支诸戒。所谓具足菩萨根本业清净戒。前后眷属余清净戒。非诸恶觉觉清净戒。护持正念念清净戒。回向阿耨多罗三藐三菩提戒

迦叶。是菩萨摩诃萨复有二种戒。一者受世教戒。二者得正法戒。菩萨若得正法戒者终不为恶。受世戒者。白四羯磨然后乃得。复次善男子。有二种戒。一者性重戒。二者息世讥嫌戒。性重戒者。谓四禁也。息世讥嫌戒者。不作贩卖轻秤小斗欺诳于人。因他形势取人财物。害心系缚。破坏成功。燃明而卧田宅种植。家业坐肆。不畜象马车乘牛羊驼驴鸡犬猕猴。孔雀鹦鹉共命及拘枳罗。豺狼虎豹猫狸猪豕及余恶兽。童男童女大男大女奴婢僮仆。金银琉璃颇梨真珠车磲马瑙珊瑚璧玉珂贝诸宝。赤铜白镴鋀石盂器。[毯-炎+瞿]毹毾[毯-炎+登]拘执[卄/毦]衣。一切谷米大小麦豆黍粟稻麻生熟食具。常受一食不曾再食。若行乞食及僧中食。常知止足。不受别请。不食肉不饮酒。五辛荤物。悉不食之。是故其身无有臭秽。常为诸天一切世人恭敬供养尊重赞叹。趣足而食终不长受。所受衣服才足覆身。进止常与三衣钵具。终不舍离如鸟二翼。不畜根子茎子节子接子子子。不畜宝藏若金若银饮食厨库衣裳服饰。高广大床象牙金床杂色编织悉不坐卧。不畜一切细软诸席。不坐一切象荐马荐。不以细软上妙衣服用敷床卧。其止息床不置二枕。亦不受畜妙好丹枕。安黄木枕。终不观视象斗马斗车斗兵斗若男若女牛羊鸡雉鹦鹉等斗亦不故往观视军阵。亦不故听吹贝鼓角琴瑟筝笛箜篌歌叫伎乐之声。除供养佛。摴蒲围棋波罗塞戏。师子象斗。弹棋六博拍鞠掷石。投[夢-夕+?]牵道八道行成。一切戏笑悉不观作。终不瞻相手足面目。不以爪镜芝草杨枝钵盂髑髅而作卜筮。亦不仰观虚空星宿。除欲解睡。不作王家往返使命。以此语彼以彼语此。终不谀谄邪命自活。亦不宣说王臣盗贼斗诤饮食国土饥馑恐怖丰乐安隐之事。善男子。是名菩萨摩诃萨息世讥嫌戒。善男子。菩萨摩诃萨坚持如是遮制之戒。与性重戒等无差别

善男子。菩萨摩诃萨受持如是诸禁戒已。作是愿言。宁以此身投于炽然猛火深坑。终不毁犯过去未来现在诸佛所制禁戒与刹利婆罗门居士等女而行不净。复次善男子。菩萨摩诃萨复作是愿。宁以热铁周匝缠身。终不敢以破戒之身而受信心檀越衣服。复次善男子。菩萨摩诃萨复作是愿。宁以此口吞热铁丸。终不敢以毁戒之口而食信心檀越饮食。复次善男子。菩萨摩诃萨复作是愿。宁卧此身大热铁上。终不敢以破戒之身受信心檀越床卧敷具。复次善男子。菩萨摩诃萨复作是愿。宁以此身受三百鉾终不敢以毁戒之身而。受信心檀越医药。复次善男子。菩萨摩诃萨复作是愿。宁以此身投热铁镬。终不敢以破戒之身受信心檀越房舍屋宅复次善男子。菩萨摩诃萨复作是愿。宁以铁椎打碎此身从头至足令如微尘。不以破戒。受诸刹利婆罗门居士恭敬礼拜。复次善男子。菩萨摩诃萨复作是愿。宁以热铁挑其两目。不以染心视他好色。复次善男子。菩萨摩诃萨复作是愿。宁以铁锥周遍刺身。不以染心听好音声。复次善男子。菩萨摩诃萨复作是愿。宁以利刀割去其鼻。不以染心贪嗅诸香。复次善男子。菩萨摩诃萨复作是愿。宁以利刀割裂其舌。不以染心贪着美味。复次善男子。菩萨摩诃萨复作是愿。宁以利斧斩斫其身。不以染心贪着诸触。何以故。以是因缘能令行者堕于地狱畜生饿鬼。迦叶。是名菩萨摩诃萨护持禁戒。菩萨摩诃萨护持如是诸禁戒已。悉以施与一切众生。以是因缘愿令众生护持禁戒。得清净戒善戒不缺戒不析戒大乘戒不退戒随顺戒毕竟戒具足成就波罗蜜戒。善男子。菩萨摩诃萨修持如是清净戒时。即得住于初不动地。云何名为不动地耶。菩萨住是不动地中。不动不堕不退不散。善男子。譬如须弥山随蓝猛风不能令动堕落退散。菩萨摩诃萨住是地中亦复如是。不为色声香味所动不堕地狱畜生饿鬼。不退声闻辟支佛地。不为异见邪风所散而作邪命。复次善男子。又不动者。不为贪欲恚痴所动。又不堕者。不堕四重。又不退者。不退还家。又不散者。不为违逆大乘经者之所散坏。复次善男子。菩萨摩诃萨亦复不为诸烦恼魔之所倾动。不为阴魔所堕。乃至坐于道场菩提树下。虽有天魔不能令其退阿耨多罗三藐三菩提。亦复不为死魔所散。善男子。是名菩萨摩诃萨修习圣行。善男子。云何名为圣行。圣行者。佛及菩萨之所行故。故名圣行。以何等故名佛菩萨为圣人耶。如是等人有圣法故。常观诸法性空寂故。以是义故故名圣人。有圣戒故故名圣人。有圣定慧故故名圣人。有七圣财。所谓信戒惭愧多闻智慧舍离故。故名圣人。有七圣觉故故名圣人。以是义故复名圣行

复次善男子。菩萨摩诃萨圣行者。观察是身从头至足。其中唯有发毛爪齿不净垢秽皮肉筋骨脾肾心肺肝胆肠胃生熟二藏大小便利涕唾目泪肪膏脑膜骨髓脓血脑骸诸脉。菩萨如是专念观时。谁有是我我为属谁。住在何处。谁属于我。复作是念骨是我耶离骨是耶。菩萨尔时除去皮肉。唯观白骨。复作是念。骨色相异。所谓青黄白色鸽色。如是骨相亦复非我。何以故。我者亦非青黄白色及以鸽色。菩萨系心作是观时即得断除一切色欲。复作是念。如是骨者从因缘生。依因足骨以拄踝骨。依因踝骨以拄[跳-兆+尃]骨。依因[跳-兆+尃]骨以拄膝骨。依因膝骨以拄髀骨。依因髀骨以拄臗骨。依因臗骨以拄腰骨。依因腰骨以拄脊骨。依因脊骨以拄肋骨。复因脊骨上拄项骨。依因项骨以拄颔骨。依因颔骨以拄牙齿。上有髑髅。复因项骨以拄肩骨。依因肩骨以拄臂骨。依因臂骨以拄腕骨。依因腕骨以拄掌骨。依因掌骨以拄指骨。菩萨摩诃萨如是观时。身所有骨一切分离。得是观已即断三欲。一形貌欲。二姿态欲。三细触欲。菩萨摩诃萨观青骨时。见此大地东西南北四维上下悉皆青相。如青色观黄白鸽色亦复如是。菩萨摩诃萨作是观时。眉间即出青黄赤白鸽等色光。菩萨于是一一诸光明中见有佛像。见已即问。如此身者不净因缘和合共成。云何而得坐起行住屈伸俯仰视瞬喘息悲泣喜笑。此中无主谁使之尔。作是问已。光中诸佛忽然不现。复作是念。或识是我。故使诸佛不为我说。复观此识次第生灭犹如流水。亦复非我。复作是念。若识非我。出息入息或能是我。复作是念。是出入息直是风性。而是风性乃是四大。四大之中何者是我。地性非我。水火风性亦复非我。复作是念。此身一切悉无有我。唯有心风因缘和合。示现种种所作事业。譬如咒力幻术所作。亦如箜篌随意出声。是故此身如是不净。假众因缘和合共成。当于何处而生贪欲。若被骂辱复于何处而生嗔恚。如我此身三十六物不净臭秽。何处当有受骂辱者。若闻其骂即便思惟。以何音声而见骂耶。一一音声不能见骂。若一不能众多亦尔。以是义故不应生嗔。若他来打亦应思惟。如是打者从何而生。复作是念。因手刀杖及以我身故得名打。我今何缘横嗔于他。乃是我身自招此咎。以我受是五阴身故。譬如因的则有箭中。我身亦尔。有身有打。我若不忍心则散乱。心若散乱则失正念。若失正念则不能观善不善义。若不能观善不善义。则行恶法。恶法因缘则堕地狱畜生饿鬼。菩萨尔时作是观已。得四念处。得四念处已则得住于堪忍地中。菩萨摩诃萨住是地已。则能堪忍贪欲恚痴。亦能堪忍寒热饥渴蚊虻蚤虱暴风恶触种种疾疫恶口骂詈挝打楚挞。身心苦恼一切能忍。是故名为住堪忍地。迦叶菩萨白佛言。世尊。菩萨未得住不动地。净持戒时颇有因缘得破戒不。善男子。菩萨未得住不动地。有因缘故可得破戒。迦叶言。唯然世尊。何者是耶。佛告迦叶。若有菩萨知以破戒因缘则能令人受持爱乐大乘经典。又能令其读诵通利书写经卷广为他说。不退转于阿耨多罗三藐三菩提。为如是故故得破戒。菩萨尔时应作是念。我宁一劫若减一劫。堕阿鼻地狱受此罪报。要令是人不退转于阿耨多罗三藐三菩提。迦叶。以是因缘菩萨摩诃萨得毁净戒。尔时文殊师利菩萨白佛言。世尊。若有菩萨。摄取护持如是之人。令不退转菩提之心。为是毁戒若堕阿鼻地狱无有是处。尔时佛赞文殊师利。善哉善哉。如汝所说。我念往昔。于阎浮提作大国王名曰仙预。爱念敬重大乘经典。其心纯善无有粗恶嫉妒悭吝。口常宣说爱语善语。身常摄护贫穷孤独。布施精进无有休废时世无佛声闻缘觉。我于尔时爱乐大乘方等经典。十二年中事婆罗门供给所须。过十二年施安已讫。即作是言。师等今应发阿耨多罗三藐三菩提心。婆罗门言。大王。菩提之性是无所有。大乘经典亦复如是。大王云何。乃欲令人同于虚空。善男子。我于尔时心重大乘。闻婆罗门诽谤方等。闻已即时断其命根。善男子。以是因缘从是已来不堕地狱善男子。拥护摄持大乘经典。乃有如是无量势力。复次迦叶。又有圣行。所谓四圣谛苦集灭道。迦叶。苦者逼迫相。集者能生长相。灭者寂灭相。道者大乘相。复次善男子。苦者现相。集者转相。灭者除相。道者能除相。复次善男子。苦者有三相。苦苦相行苦相坏苦相。集者二十五有。灭者灭二十五有。道者修戒定慧。复次善男子。有漏法者有二种有因有果。无漏法者亦有二种有因有果。有漏果者是则名苦。有漏因者则名为集。无漏果者则名为灭。无漏因者则名为道。复次善男子。八相名苦。所谓生苦老苦病苦死苦爱别离苦怨憎会苦求不得苦五盛阴苦。能生如是八苦法者。是名为集。无有如是八法之处。是名为灭。十力四无所畏三念处大悲。是名为道。善男子。生者出相所谓五种。一者初出。二者至终。三者增长。四者出胎。五者种类生。何等为老老有二种。一念念老。二终身老。复有二种。一增长老。二灭坏老。是名为老。云何为病。病谓四大毒蛇互不调适。亦有二种。一者身病。二者心病。身病有五。一者因水。二者因风三者因热四者杂病。五者客病。客病有四。一者非分强作。二者忘误堕落。三者刀杖瓦石。四者鬼魅所著。心病亦有四种。一者踊跃。二者恐怖。三者忧愁。四者愚痴。复次善男子。身心之病凡有三种。何等为三。一者业报。二者不得远离恶对。三者时节代谢。生如是等因缘名字受分别。病因缘者。风等诸病。名字者。心闷肺胀上气嗽逆心惊下痢。受分别者。头痛目痛手足等痛。是名为病。何等为死死者舍所受身。舍所受身亦有二种。一命尽死。二外缘死。命尽死者亦有三种。一者命尽非是福尽。二者福尽非是命尽。三者福命俱尽。外缘死者亦有三种。一者非分自害死。二者横为他死。三者俱死。又有三种死。一放逸死。二破戒死。三坏命根死。何等名为放逸死。若有诽谤大乘方等般若波罗蜜。是名放逸死。何等名为破戒死耶。毁犯去来现在诸佛所制禁戒。是名破戒死。何等名为坏命根死。舍五阴身。是名坏命根死。如是名曰死为大苦。何等名为爱别离苦。所爱之物破坏离散。所爱之物破坏离散亦有二种。一者人中五阴坏。二者天中五阴坏。如是人天所爱五阴分别校计有无量种。是名爱别离苦。何等名为怨憎会苦。所不爱者而共聚集。所不爱者而共聚集亦有三种。所谓地狱饿鬼畜生。如是三趣分别挍计有无量种。如是则名怨憎会苦。何等名为求不得苦。求不得苦亦有二种。一者所悕望处求不能得。二者多用功力不得果报。如是则名求不得苦。何等名为五盛阴苦。五盛阴苦者。生苦老苦病苦死苦。爱别离苦怨憎会苦求不得苦。是故名为五盛阴苦。迦叶。生之根本凡有如是七种之苦。老苦乃至五盛阴苦。迦叶。夫衰老者非一切有。佛及诸天一向定无。人中不定或有或无。迦叶。三界受身无不有生。老不必定。是故一切生为根本。迦叶。世间众生颠倒覆心。贪着生相厌患老死。菩萨不尔观于初生已见过患。迦叶。如有女人入于他舍。是女端正颜貌美丽。以好璎珞庄严其身。主人见已即便问言。汝字何等系属于谁。女人答言。我身即是功德大天。主人问言。汝所至处为何所作。女天答言。我所至处。能与种种金银琉璃颇梨真珠珊瑚虎珀车磲马瑙象马车乘奴婢仆使。主人闻已心生欢喜踊跃无量。我今福德故令汝来至我舍宅。即便烧香散花供养恭敬礼拜。复于门外更见一女。其形丑陋衣裳弊坏多诸垢腻。皮肤皴裂其色艾白。见已问言。汝字何等系属于谁。女人答言。我字黑闇。复问何故名为黑闇。女人答言。我所行处。能令其家所有财宝一切衰耗。主人闻已即持利刀。作如是言。汝若不去当断汝命。女人答言。汝甚愚痴无有智慧。主人问言。何故名我痴无智慧。女人答言。汝家中者即是我姊。我常与姊进止共俱。汝若驱我亦当驱姊。主人还入问功德天。外有一女云是汝妹。实为是不。功德天言。实是我妹。我与此妹行住共俱。未曾相离随所住处。我常作好彼常作恶我作利益彼作衰损。若爱我者亦应爱彼。若见恭敬亦应敬彼。主人即言。若有如是好恶事者。我皆不用各随意去。是时二女便共相将还其所止。尔时主人见其还去。心生欢喜踊跃无量。是时二女复共相随至一贫家。贫人见已心生欢喜。即请之言。从今已往愿汝二人常住我家。功德天言。我等先已。为他所驱。汝复何缘俱请我住。贫人答言。汝今念我。我以汝故复当敬彼。是故俱请令住我家。迦叶。菩萨摩诃萨亦复如是。不愿生天以生当有老病死故。是以俱弃曾无受心。凡夫愚人不知老病死等过患。是故贪受生死二法。复次迦叶。如婆罗门幼稚童子为饥所逼。见人粪中有庵罗果即便取之。有智见已呵责之言。汝婆罗门种姓清净。何故取是粪中秽果。童子闻已赮然有愧。即答之言。我实不食。为欲洗净还弃舍之。智者语言。汝大愚痴。若还弃者本不应取。善男子。菩萨摩诃萨亦复如是。于此生分不受不舍。如彼智者呵责童子。凡夫之人欣生恶死。如彼童子取果还弃。复次迦叶。譬如有人四衢道头器盛满食色香味具而欲卖之。有人远来饥虚羸乏。见其饭食色香味具。即指问言。此是何物。食主答言。此是上食色香味具。若食此食得色得力。能除饥渴得见诸天。唯有一患所谓命终。是人闻已即作是念。我今不用色力见天。亦不用死。即作是言。食是食已若命终者。汝今何为于此卖之。食主答言。有智之人终不肯买。唯有愚人不知是事。多与我价贪而食之。善男子。菩萨摩诃萨亦复如是。不愿生天得色得力见于诸天。何以故。以其不免诸苦恼故。凡夫愚痴随有生处皆悉贪爱。以其不见老病死故。复次善男子。譬如毒树根能杀人枝干茎节皮叶花实悉亦能杀。善男子。二十五有受生之处。所受五阴亦复如是一切能杀。复次迦叶。譬如粪秽多少俱臭。善男子。生亦如是。设寿八万下至十岁俱亦受苦。复次迦叶。譬如崄岸上有草覆于彼岸边多有甘露。若有食者寿天千年。永除诸病安隐快乐。凡夫愚人贪其味故。不知其下有大深坑。即前欲取不觉脚跌堕坑而死。智者知已舍离远去。善男子。菩萨摩诃萨亦复如是。尚不欲受天上妙食。况复人中。凡夫之人乃于地狱吞啖铁丸。况复人天上妙肴馔而能不食。迦叶。以如是譬及余无量无边譬喻。当知是生实为大苦。迦叶是名菩萨住于大乘大涅槃经观于生苦

迦叶。云何菩萨摩诃萨于是大乘大涅槃经观于老苦。老者能为嗽逆上气能坏勇力忆念进持盛年快乐憍慢贡高安隐自恣。能作背偻懈怠懒堕为他所轻。迦叶。譬如池水莲花满中开敷鲜荣甚可爱乐值天降雹悉皆破坏。善男子。老亦如是。悉能破坏盛壮好色。复次迦叶。譬如国王有一智臣善知兵法。有敌国王拒逆不顺。王遣此臣往讨伐之。即便擒获将来诣王。老亦如是。擒获壮色将付死王。复次迦叶。譬如折轴无所复用。老亦如是无所复用。复次迦叶。如大富家多有财宝金银琉璃珊瑚虎珀车磲马瑙。有诸怨贼若入其家。即能劫夺悉令空尽。善男子。盛年好色亦复如是。常为老贼之所劫夺。复次迦叶。譬如贫人贪着上膳细软衣裳。虽复悕望而不能得。善男子。老亦如是。虽有贪心欲受富乐。五欲自恣而不能得。复次迦叶。如陆地龟心常念水。善男子。人亦如是既为衰老之所干枯。心常忆念壮时所受五欲之乐。复次迦叶。犹如秋月所有莲花皆为一切之所乐见及其萎黄人所恶贱。善男子。盛年壮色亦复如是。悉为一切之所爱乐。及其老至众所恶贱。复次迦叶。譬如甘蔗既被压已滓无复味。壮年盛色亦复如是。既被老压无三种味。一出家味。二读诵味。三坐禅味。复次迦叶。譬如满月夜多光明昼则不尔。善男子。人亦如是。壮则端严形貌瑰玮。老则衰羸形神枯瘁。复次迦叶。譬如有王常以正法治国理民真实无曲慈愍好施。时为敌国之所破坏。流离逃迸远至他土。他土人民见而愍之。咸作是言。大王往日正法治国不枉万姓。如何一旦流离至此。善男子。人亦如是。既为衰老所坏败已。常赞壮时所行事业。复次迦叶。譬如灯炷唯赖膏油膏油既尽势不久停。善男子。人亦如是。唯赖壮膏。壮膏既尽衰老之炷何得久停。复次迦叶。譬如枯河不能利益人及非人飞鸟走兽。善男子。人亦如是。为老所枯不能利益一切作业。复次迦叶。譬如河岸临崄大树若遇暴风必当颠坠。善男子。人亦如是。临老险岸死风既至势不得住。复次迦叶。如车轴折不任重载。善男子。老亦如是。不能咨受一切善法。复次迦叶。譬如婴儿为人所轻。善男子。老亦如是。常为一切之所轻毁。迦叶。以是等譬及余无量无边譬喻。当知是老实为大苦。迦叶。是名菩萨摩诃萨修行大乘大涅槃经观于老苦迦叶。云何菩萨摩诃萨修行大乘大涅槃经观于病苦。所谓病者。能坏一切安隐乐事。譬如雹雨伤坏谷苗。复次迦叶。如人有怨心常忧愁而怀恐怖。善男子。一切众生亦复如是。常畏病苦心怀忧戚。复次迦叶。譬如有人形貌端正为王夫人欲心所爱。遣信逼唤与共交通。时王捕得。即便使人挑其一目截其一耳断一手足。是人尔时形容改异人所恶贱。善男子。人亦如是。先虽端严耳目具足。既为病苦所缠逼已则为众人之所恶贱。复次迦叶。譬如芭蕉竹苇及骡有子则死。善男子。人亦如是有病则死。复次迦叶。如转轮王主兵大臣常在前导王随后行。亦如鱼王蚁王蠡王牛王商主在前行时。如是诸众悉皆随从无舍离者。善男子。死转轮王亦复如是。常随病臣不相舍离。鱼蚁蠡牛商主病王亦复如是。常为死众之所随逐。迦叶。病因缘者。所谓苦恼愁忧悲叹身心不安。或为怨贼之所逼害。破坏浮囊拨撤桥梁。亦能劫夺正念根本。复能破坏盛壮好色力势安乐。除舍惭愧能为身心焦热炽然。以是等譬及余无量无边譬喻。当知病苦是为大苦。迦叶。是名菩萨摩诃萨修行大乘大涅槃经观于病苦

迦叶。云何菩萨修行大乘大涅槃经观于死苦所谓死者。能烧灭故。迦叶。如火灾起能烧一切。唯除二禅力不至故。善男子。死火亦尔能烧一切。唯除菩萨住于大乘大般涅槃。势不及故。复次迦叶。如水灾起一切漂没。唯除三禅力不至故。善男子。死水亦尔漂没一切。唯除菩萨住于大乘大般涅槃。复次迦叶。如风灾起能吹一切悉令散灭。唯除四禅力不至故。善男子。死风亦尔悉能吹灭一切所有唯除菩萨住于大乘大般涅槃。迦叶菩萨白佛言。世尊。彼第四禅以何因缘。风不能吹水不能漂火不能烧。佛告迦叶。善男子。彼第四禅内外过患一切无故。善男子。初禅过患内有觉观外有火灾二禅过患内有欢喜外有水灾。三禅过患内有喘息外有风灾。善男子。彼第四禅内外过患一切悉无。是故诸灾不能及之。善男子。菩萨摩诃萨亦复如是。安住大乘大般涅槃。内外过患一切皆尽。是故死王不能及之复次善男子。如金翅鸟能啖能消一切龙鱼金银等宝。唯除金刚不能令消。善男子。死金翅鸟亦复如是。能啖能消一切众生。唯不能消住于大乘大般涅槃菩萨摩诃萨。复次迦叶。譬如河岸所有草木大水瀑涨悉随漂流入于大海。唯除杨柳以其软故。善男子。一切众生亦复如是。悉皆随流入于死海。唯除菩萨住于大乘大般涅槃。复次迦叶。如那罗延悉能摧伏一切力士。唯除大风。何以故。以无碍故善男子。死那罗延亦复如是。悉能摧伏一切众生。唯除菩萨住于大乘大般涅槃。何以故。以无碍故。复次迦叶。譬如有人于怨憎中诈现亲善。常相追逐如影随形。伺求其便而欲杀之。彼怨谨慎坚牢自备。故使是人不能得杀。善男子。死怨亦尔。常伺众生而欲杀之。唯不能杀住于大乘大般涅槃菩萨摩诃萨。何以故。以是菩萨不放逸故。复次迦叶。譬如卒降金刚瀑雨。悉坏药木诸树山林土沙瓦石金银琉璃一切之物。唯不能坏金刚真宝。善男子。金刚死雨亦复如是。悉能破坏一切众生。唯除金刚菩萨住于大乘大般涅槃。复次迦叶。如金翅鸟能啖诸龙唯不能啖受三归者善男子。死金翅鸟亦复如是。能啖一切无量众生。唯除菩萨住三定者。何谓三定。空无相愿。复次迦叶。如摩罗毒蛇凡有所螫。虽有良咒上妙好药无如之何。唯阿竭多星咒能令除愈。善男子。死毒所螫亦复如是。一切医方无如之何。唯除菩萨住于大乘大般涅槃咒。复次迦叶。譬如有人为王所嗔。其人若能以软善语。贡上财宝便可得脱。善男子。死王不尔虽以软语钱财珍宝而贡上之。亦不得脱。善男子。夫死者于险难处无有资粮。去处悬远而无伴侣。昼夜常行不知边际。深邃幽闇无有灯明。入无门户而有处所。虽无痛处不可疗治。往无遮止到不得脱。无所破坏见者愁毒。非是恶色而令人怖。敷在身边不可觉知。迦叶。以是等譬及余无量无边譬喻。当知是死真为大苦。迦叶。是名菩萨修行大乘大涅槃经观于死苦

迦叶。云何菩萨住于大乘大涅槃经观爱别离苦。爱别离苦能为一切众苦根本。如说偈言

  因爱生忧　　因爱生怖
  若离于爱　　何忧何怖

爱因缘故则生忧苦。以忧苦故则令众生生于衰老。爱别离苦所谓命终。善男子。以别离故能生种种微细诸苦。今当为汝分别显示。善男子。过去之世人寿无量时。世有王名曰善住。其王尔时为童子身。太子治事及登王位各八万四千岁。时王顶上生一肉疱。其疱柔软如兜罗绵细软劫贝。渐渐增长不以为患。足满十月疱即开剖生一童子。其形端正奇异少双。色像分明人中第一。父王欢喜字曰顶生。时善住王即以国事委付顶生。弃舍宫殿妻子眷属。入山学道满八万四千岁。尔时顶生于十五日。处在高楼沐浴受斋。即时东方有金轮宝。其轮千辐毂辋具足。不由工匠自然成就而来应之。顶生大王即作是念。我昔曾闻五通仙说。若刹利王于十五日处在高楼沐浴受斋。若有金轮千辐不减毂辋具足。不由工匠自然成就而来应者。当知是王即当得作转轮圣帝。复作是念。我今当试。即以左手擎此轮宝。右执香炉右膝着地而发誓言。是金轮宝若实不虚。应如过去转轮圣王所行道法。作是誓已。是金轮宝飞升虚空遍十方已。还来住在顶生左手。尔时顶生心生欢喜踊跃无量。复作是言我今定作转轮圣王。其后不久复有象宝。状貌端严如白莲花七支拄地。顶生见已复作是念。我昔曾闻五通仙说。若转轮王于十五日处在高楼沐浴受斋。若有象宝。状貌端严如白莲花七支拄地而来应者。当知是王即是圣帝。复作是念。我今当试。即擎香炉右膝着地而发誓言。是白象宝若实不虚。应如过去转轮圣王所行道法。作是誓已。是白象宝从旦至夕周遍八方。尽大海际还住本处。尔时顶生心大欢喜踊跃无量。复作是言。我今定是转轮圣王。其后不久次有马宝。其色绀艳髦尾金色顶生见已复作是念。我昔曾闻五通仙说。若转轮王于十五日处在高楼沐浴受斋若有马宝。其色绀艳髦尾金色而来应者。当知是王即是圣帝。复作是念。我今当试。即执香炉右膝着地而发誓言。是绀马宝若实不虚。应如过去转轮圣王所行道法。作是誓已。是绀马宝从旦至夕周遍八方。尽大海际还住本处。尔时顶生心大欢喜踊跃无量。复作是言。我今定是转轮圣王。其后不久复有女宝。形容端正微妙第一。不长不短不白不黑。身诸毛孔出旃檀香。口气香洁如青莲花。其目远视见一由旬。耳闻鼻嗅亦复如是。其舌广大出能覆面。形色细薄如赤铜叶。心识聪哲有大智慧。于诸众生常有软语。是女以手触王衣时。即知王身安乐病患。亦知王心所缘之处。尔时顶生复作是念。若有女人能知王心。即是女宝。其后不久于王宫内。自然而有宝摩尼珠。纯青琉璃大如车毂。能于闇中照一由旬。若天降雨渧如车轴。是珠势力能作大盖覆一由旬。遮此大雨不令下过。尔时顶生复作是念。若转轮王得是宝珠必是圣帝。其后不久有主藏臣自然而出。多饶财宝巨富无量。库藏盈溢无所乏少。报得眼根力能彻见一切地中所有伏藏。随王所念皆能办之。尔时顶生复欲试之。即共乘船入于大海。告藏臣言。我今欲得珍异之宝。藏臣闻已即以两手挠大海水。时十指头出十宝藏。以奉圣王而白王言。大王所须随意用之。其余在者当投大海。尔时顶生心大欢喜。踊跃无量复作念言。我今定是转轮圣王。其后不久有主兵臣自然而出。勇健猛略策谋第一善知四兵。若任斗者则现圣王。若不任者退不令现。未摧伏者能令摧伏。已摧伏者力能守护。尔时顶生复作是念。若转轮王得是兵宝。当知定是转轮圣王。尔时顶生转轮圣帝告诸大臣。汝等当知。此阎浮提安隐丰乐。我今已有七宝成就千子具足。更何所为。诸臣答言。唯然大王。东弗婆提犹未归德。王今应往。尔时圣王即与七宝一切营从。飞空而往东弗婆提。彼土人民欢喜归化。复告大臣。我阎浮提及弗婆提。安隐丰乐人民炽盛悉来归化。七宝成就千子具足。复何所为。诸臣答言。唯然大王。西瞿陀尼犹未归德。尔时圣王复与七宝一切营从。飞空而往西瞿陀尼。王既至彼。彼土人民亦复归伏。复告大臣。我阎浮提及弗婆提此瞿陀尼。安隐丰乐人民炽盛皆以归化。七宝成就千子具足。复何所为。诸臣答言。唯然大王。北郁单越犹未归化。尔时圣王复与七宝一切营从。飞空而往北郁单越。王既至彼。彼土人民欢喜归德。复告大臣。我四天下安隐丰乐人民炽盛咸已归德。七宝成就千子具足。更何所为诸臣答言。唯然圣王。三十三天寿命极长安隐快乐。彼天身形端严无比。所居宫殿床榻卧具悉是七宝。自恃天福未来归化今应往讨令其摧伏。尔时圣王复与七宝一切营从。飞腾虚空上忉利天。见有一树其色青绿。圣王见已即问大臣。此是何色。大臣答言。此是波利质多罗树。忉利诸天夏三月日。常于其下娱乐受乐。又见白色犹如白云。复问大臣。彼是何色。大臣答言。是善法堂。忉利诸天常集其中论人天事。于是天主释提桓因。知顶生王已来在外。即出迎逆见已执手。升善法堂分座而坐。彼时二王形容相貌等无差别。唯有视眴为别异耳。是时圣王即生念言。我今宁可退彼王位即住其中为天王不。善男子。尔时帝释受持读诵大乘经典。开示分别为他演说。唯于深义未尽通达。以是读诵受持分别为他广说因缘力故。有大威德。善男子。是顶生王于此帝释生恶心已。即便堕落还阎浮提。与所爱念人天离别生大苦恼。复遇恶病即便命终。尔时帝释迦叶佛是。转轮圣王则我身是。善男子。当知如是爱别离者极为大苦。善男子。菩萨摩诃萨尚忆过去如是等辈爱别离苦。何况菩萨住于大乘大涅槃经。而当不观现在之世爱别离苦

善男子。云何菩萨修行大乘大涅槃经观怨憎会苦。善男子。是菩萨摩诃萨观于地狱畜生饿鬼人中天上。皆有如是怨憎会苦。譬如人观牢狱系闭枷锁杻械以为大苦。菩萨摩诃萨亦复如是。观于五道一切受生。悉是怨憎合会大苦。复次善男子。譬如有人常畏怨家枷锁杻械。舍离父母妻子眷属珍宝产业而远逃避。善男子。菩萨摩诃萨亦复如是。怖畏生死具足修行六波罗蜜入于涅槃。迦叶。是名菩萨修行大乘大般涅槃观怨憎会苦

善男子。云何菩萨修行大乘大般涅槃观求不得苦。求者一切尽求尽求者有二种。一求善法。二求不善法。善法未得苦。恶法未离苦。是则略说五盛阴苦。迦叶。是名苦谛

尔时迦叶菩萨摩诃萨白佛言。世尊。如佛所说。五盛阴苦是义不然。何以故。如佛往昔告释摩男。若色苦者一切众生不应求色。若有求者则不名苦。如佛告诸比丘。有三种受。苦受乐受不苦不乐受。如佛先为诸比丘说。若有人能修行善法则得受乐。又如佛说。于善道中六触受乐。眼见好色是则为乐。耳鼻舌身意思好法亦复如是。如佛说偈

  持戒则为乐　　身不受众苦
  睡眠得安隐　　寤则心欢喜
  若受衣食时　　诵习而经行
  独处于山林　　如是为最乐
  若能于众生　　昼夜常修慈
  因是得常乐　　以不恼他故
  少欲知足乐　　多闻分别乐
  无著阿罗汉　　亦名为受乐
  菩萨摩诃萨　　毕竟到彼岸
  所作众事办　　是名为最乐

世尊。如诸经中所说乐相其义如是。如佛今说云何当与此义相应。佛告迦叶。善哉善哉善男子。善能咨问如来是义。善男子。一切众生于下苦中横生乐想。是故我今所说苦相与本不异。迦叶菩萨白佛言。如佛所说。于下苦中生乐想者。下生下老下病下死下爱别离下求不得下怨憎会下五盛阴。如是等苦亦应有乐。世尊。下生者所谓三恶趣。中生者所谓人中。上生者所谓天上。若复有人作如是问。若于下乐生于苦想。于中乐中生无苦乐想。于上乐中生于乐想。当云何答。世尊。若下苦中生乐想者。未见有人当受千罚初一下时已生乐想。若不生者云何说言于下苦中而生乐想。佛告迦叶。如是如是。如汝所说。以是义故无有乐想。何以故。犹如彼人当受千罚受一下已即得脱者。是人尔时便生乐想。是故当知。于无乐中妄生乐想。迦叶言。世尊。彼人不以一下生于乐想。以得脱故而生乐想。迦叶。是故我昔为释摩男说五阴中乐实不虚也。迦叶。有三受三苦。三受者。所谓乐受苦受不苦不乐受。三苦者。所谓苦苦行苦坏苦。善男子。苦受者名为三苦。所谓苦苦行苦坏苦。余二受者所谓行苦坏苦。善男子。以是因缘生死之中实有乐受。菩萨摩诃萨以苦乐性不相舍离。是故说言一切皆苦。善男子。生死之中实无有乐。但诸佛菩萨随顺世间说言有乐。迦叶菩萨白佛言。世尊。诸佛菩萨若随俗说是虚妄否。如佛所说。修行善者则受乐报。持戒安乐身不受苦。乃至众事已办是为最乐。如是等经所说乐受是虚妄否。若是虚妄诸佛世尊久于无量百千万亿阿僧祇劫。修菩提道已离妄语。今作是说其义云何。佛言。善男子。如上所说诸受乐偈。即是菩提道之根本。亦能长养阿耨多罗三藐三菩提。以是义故先于经中说是乐相。善男子。譬如世间所须资生能为乐因故名为乐。所谓女色耽湎饮酒上馔甘味。渴时得水寒时遇火。衣服璎珞象马车乘奴婢僮仆。金银琉璃珊瑚真珠仓库谷米。如是等物世间所须。能为乐因是名为乐。善男子。如是等物亦能生苦。因于女人生男子苦。忧愁悲泣乃至断命。因酒甘味乃至仓谷亦能令人生大忧恼。以是义故。一切皆苦无有乐相。善男子。菩萨摩诃萨于是八苦解苦无苦。善男子。一切声闻辟支佛等不知乐因。为如是人于下苦中说有乐相。唯有菩萨住于大乘大般涅槃。乃能知是苦因乐因

大般涅槃经卷第十一大般涅槃经卷第十二

        宋代沙门慧严等依泥洹经加之

    圣行品之二

善男子。云何菩萨摩诃萨住于大乘大般涅槃观察集谛。善男子。菩萨摩诃萨观此集谛是阴因缘。所谓集者还爱于有。爱有二种。一爱己身。二爱所须。复有二种。未得五欲系心专求。既求得已堪忍专著。复有三种。欲爱色爱无色爱。复有三种。业因缘爱烦恼因缘爱苦因缘爱。出家之人有四种爱。何等为四。衣服饮食卧具汤药。复有五种。贪着五阴。随诸所须一切爱着。分别挍计无量无边。善男子。爱有二种。一者善爱。二不善爱。不善爱者凡愚之求。善法爱者诸菩萨求。善法爱者复有二种。不善与善。求二乘者名为不善。求大乘者是名为善。善男子。凡夫爱者名之为集。不名为谛。菩萨爱者名之实谛。不名为集。何以故。为度众生所以受生。不以爱故而受生也。迦叶菩萨白佛言。世尊。如佛世尊于余经中为诸众生。说业为因缘。或说憍慢。或说六触。或说无明为五盛阴而作因缘。今以何义说四圣谛。独以爱性为五阴因。佛赞迦叶善哉善哉。善男子。如汝所说。诸因缘者非为非因。但是五阴要因于爱。善男子。譬如大王若出游巡大臣眷属悉皆随从。爱亦如是。随爱行处是诸结等亦复随行。譬如腻衣随有尘着着则随住。爱亦如是。随所爱处业结亦住。复次善男子。譬如湿地则能生牙。爱亦如是。能生一切业烦恼牙。善男子。菩萨摩诃萨住是大乘大般涅槃深观此爱。凡有九种。一如债有余。二如罗刹女妇。三如妙花茎有毒蛇缠之。四如恶食性所不便而强食之。五如淫女。六如摩楼迦子。七如疮中瘜肉。八如暴风。九如彗星。云何名为如债有余。善男子。譬如穷人负他钱财。虽偿欲毕余未毕故。犹系在狱而不得脱。声闻缘觉亦复如是。以有爱习之余气故。不能得成阿耨多罗三藐三菩提。善男子。是名如债有余。善男子。云何如罗刹女妇。善男子。譬如有人得罗刹女纳以为妇。是罗刹女随所生子。生已便食。食子既尽。复食其夫。善男子。爱罗刹女亦复如是。随诸众生生善根子随生随食。善子既尽复食众生。令堕地狱畜生饿鬼。唯除菩萨是名如罗刹女妇。善男子。云何如妙花茎毒蛇缠之。譬如有人性爱好花。不见花茎毒蛇过患即便前捉。捉已蛇螫螫已命终。一切凡夫亦复如是。贪五欲花。不见是爱毒蛇过患而便受取。即为爱蛇之所毒螫。命终即堕三恶道中。唯除菩萨。是名如妙花茎毒蛇缠之。善男子。云何所不便食而强食之。譬如有人所不便食而强食之。食已腹痛患下而死。爱食如是。五道众生强食贪着。以是因缘堕三恶道。唯除菩萨。是名所不便食而强食之。善男子。云何如淫女。譬如愚人与淫女通。而彼淫女巧作种种谄媚现亲。悉夺是人所有钱财。钱财既尽便复驱逐。爱之淫女亦复如是。愚人无智与之交通。而是爱女夺其所有一切善法。善法既尽驱逐令堕三恶道中。唯除菩萨。是名淫女。善男子。云何如摩楼迦子。譬如摩楼迦子。若鸟食已随粪堕地。或因风吹来在树下即便生长缠绕束缚尼拘罗树。令不增长遂至枯死。爱摩楼迦子亦复如是。缠缚凡夫所有善法。不令增长遂至枯灭。既枯灭已命终之后堕三恶道。唯除菩萨。是名如摩楼迦子。善男子。云何如疮中瘜肉。如人久疮中生瘜肉。其人要当勤心疗治莫生舍心。若生舍心瘜肉增长虫疽复生。以是因缘即便命终。凡夫愚人五阴疮痍亦复如是。爱于其中而为瘜肉。应当勤心治爱瘜肉。若不治者命终即堕三恶道中。唯除菩萨。是名如疮中瘜肉。善男子。云何如暴风。譬如暴风能偃山夷岳拔于深根。爱欲暴风亦复如是。于父母所而生恶心。能拔大智舍利弗等无上深固菩提根本。唯除菩萨。是名如暴风。善男子。云何如彗星。譬如彗星出现天下一切人民饥馑病瘦婴诸苦恼。爱之彗星亦复如是。能断一切善根种子。令凡夫人孤穷饥馑生烦恼病流转生死受种种苦。唯除菩萨。是名如彗星。善男子。菩萨摩诃萨住于大乘大般涅槃。观察爱结如是九种。善男子。以是义故。诸凡夫人有苦无谛。声闻缘觉有苦有苦谛而无真实。诸菩萨等解苦无苦。是故无苦而有真谛。诸凡夫人有集无谛。声闻缘觉有集有集谛。诸菩萨等解集无集。是故无集而有真谛。声闻缘觉有灭非真。菩萨摩诃萨有灭有真谛。声闻缘觉有道非真。菩萨摩诃萨有道有真谛

善男子。云何菩萨摩诃萨住于大乘大般涅槃。见灭见灭谛。所谓断除一切烦恼。若烦恼断则名为常。灭烦恼火则名寂灭。烦恼灭故则得受乐。诸佛菩萨求因缘故。故名为净。更不复受二十五有故名出世。以出世故故名为我。常于色声香味触等。若男若女若生住灭。若苦若乐不苦不乐。不取相貌故名毕竟寂灭真谛。善男子。菩萨如是住于大乘大般涅槃观灭圣谛。善男子。云何菩萨摩诃萨住于大乘大般涅槃观道圣谛。善男子。譬如闇中因灯得见粗细之物。菩萨摩诃萨亦复如是。住于大乘大般涅槃。因八圣道见一切法。所谓常无常。有为无为。有众生非众生。物非物。苦乐。我无我。净不净。烦恼非烦恼。业非业。实不实。乘非乘。知无知。陀罗骠非陀罗骠。求那非求那。见非见。色非色。道非道。解非解。善男子。菩萨如是住于大乘大般涅槃观道圣谛

迦叶菩萨白佛言。世尊。若八圣道是道圣谛义不相应。何以故。如来或说信心为道能度诸漏。或时说道不放逸是。诸佛世尊不放逸故。得阿耨多罗三藐三菩提。亦是菩萨助道之法。或时说言精进是道。如告阿难。若有人能勤修精进。则得成就阿耨多罗三藐三菩提。或时说言观身念处。若有系心精勤修习是身念处。则得成就阿耨多罗三藐三菩提。或时说言正定为道。如告大德摩诃迦叶。夫正定者真实是道。非不正定而是道也。若入正定乃能思惟五阴生灭。非不人定能思惟也。或说一法若人修习能净众生。灭除一切忧愁苦恼逮得正法。所谓念佛三昧。或复说言修无常想是名为道。如告比丘。有能多修无常想者。能得阿耨多罗三藐三菩提。或说空寂阿兰若处独坐思惟。能得速成阿耨多罗三藐三菩提。或时说言为人演法是名为道。若闻法已疑网即断。疑网断已则得阿耨多罗三藐三菩提。或时说言持戒是道。如告阿难。若有精勤修持禁戒。是人则度生死大苦。或时说言亲近善友是名为道。如告阿难若有亲近善知识者则安净戒。若有众生能亲近我。则得发于阿耨多罗三藐三菩提心。或时说言修慈是道。修学慈者断诸烦恼得不动处。或时说言智慧是道。如佛昔为波阇波提比丘尼说。姊妹。如诸声闻以智慧刀能断诸流诸漏烦恼。或时如来说施是道。如佛往昔告波斯匿王。大王当知。我于往昔多行惠施。以是因缘今日得成阿耨多罗三藐三菩提。世尊。若八圣道是道谛者。如是等经岂非虚妄。若彼诸经非虚妄者。彼中何缘不说八道为道圣谛。若彼不说如来往昔何故错谬。然我定知诸佛如来久离错谬

尔时世尊赞迦叶菩萨。善哉善哉。善男子。汝今欲知菩萨大乘微妙经典所有秘密故作是问。善男子。如是诸经悉入道谛。善男子。如我先说。若有信道如是信道。是信根本。是能佐助菩提之道。是故我说无有错谬。善男子。如来善知无量方便。欲化众生故作如是种种说法。善男子。譬如良医识诸众生种种病源。随其所患而为合药。并药所禁唯水一种不在禁例。或服姜水或甘草水或细辛水或黑石蜜水或阿摩勒水或尼婆罗水或钵昼罗水或服冷水或服热水或蒲萄水或安石榴水。善男子。如是良医善知众生所患种种药。虽多禁水不在例。如来亦尔。善知方便于一法相。随诸众生分别广说种种名相。彼诸众生随所说受。受已修习除断烦恼。如彼病人随良医教所患得除。复次善男子。如有一人善解众语在大众中。是诸大众热渴所逼。咸发声言。我欲饮水我欲饮水。是人即时以清冷水随其种类说言是水。或言波尼。或言郁特。或言纱利蓝。或言婆利。或言婆耶。或言甘露。或言牛乳。以如是等无量水名为大众说。善男子。如来亦尔。以一圣道为诸声闻种种演说。从信根等至八圣道。复次善男子。譬如金师以一种金随意造作种种璎珞。所谓钳锁环钏钗铛天冠臂印。虽有如是差别不同然不离金。善男子。如来亦尔。以一佛道随诸众生种种分别而为说之。或说一种。所谓诸佛一道无二。复说二种。所谓定慧。复说三种。谓见慧智。复说四种。所谓见道修道无学道佛道。复说五种。所谓信行道法行道信解脱道见到道身证道。复说六种。所谓须陀洹道斯陀含道阿那含道阿罗汉道辟支佛道佛道。复说七种。所谓念觉分择法觉分精进觉分喜觉分除觉分定觉分舍觉分。复说八种。所谓正见正思惟正语正业正命正精进正念正定。复说九种。所谓八圣道及信。复说十种。所谓十力。复说十一种。所谓十力大慈。复说十二种。所谓十力大慈大悲。复说十三种。所谓十力大慈大悲念佛三昧。复说十六种。所谓十力大慈大悲念佛三昧及佛所得三正念处。复说二十道。所谓十力四无所畏大慈大悲念佛三昧三正念处。善男子。是道一体。如来昔日为众生故种种分别。复次善男子。譬如一火因所燃故得种种名。所谓木火草火糠火[麥*弋]火牛马粪火。善男子。佛道亦尔一而无二。为众生故种种分别。复次善男子。譬如一识分别说六。若至于眼则名眼识。乃至意识亦复如是。善男子。道亦如是一而无二。如来为化诸众生故种种分别。复次善男子。譬如一色眼所见者则名为色。耳所闻者则名为声。鼻所嗅者则名为香。舌所尝者则名为味。身所觉者则名为触。善男子。道亦如是一而无二。如来为欲化众生故种种分别。善男子。以是义故以八圣道分名道圣谛。善男子。是四圣谛诸佛世尊次第说之。以是因缘无量众生得度生死

迦叶菩萨白佛言。世尊。昔佛一时在恒河岸尸首林中。尔时如来取小树叶告诸比丘。我今手中所捉叶多一切因地草木叶多。诸比丘言。世尊。一切因地草木叶多不可称计。如来所捉少不足言。诸比丘。我所觉了一切诸法。如因大地生草木等。为诸众生所宣说者如手中叶。世尊尔时说如是言。如来所了无量诸法。若入四谛则为已说。若不入者应有五谛。佛赞迦叶。善哉善哉。善男子。汝今所问则能利益安隐快乐无量众生。善男子。如是诸法悉已摄在四圣谛中。迦叶菩萨复白佛言。如是等法若在四谛。如来何故唱言不说。佛言。善男子。虽复入中犹不名说。何以故。善男子。知四圣谛有二种智。一者中二者上。中者声闻缘觉智。上者诸佛菩萨智。善男子。知诸阴苦名为中智。分别诸阴有无量相悉是诸苦非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经竟不说之。善男子。知诸入者名之为门亦名为苦。是名中智。分别诸入有无量相悉是诸苦。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知诸界者名之为分。亦名为性亦名为苦。是名中智。分别诸界有无量相悉是诸苦。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知色坏相是名中智。分别诸色有无量相悉是诸苦。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知受觉相是名中智。分别诸受有无量觉相。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知想取相是名中智。分别是想有无量取相。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知行作相是名中智。分别是行无量作相。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知识分别相是名中智。分别是识无量知相。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知爱因缘能生五阴。是名中智。一人起爱无量无边。声闻缘觉所不能知。能知一切众生所起如是等爱。是名上智。如是等义我于彼经亦不说之。善男子。知灭烦恼是名中智。分别烦恼不可称计。灭亦如是不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知是道相能离烦恼。是名中智。分别道相无量无边。所离烦恼亦无量无边。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知世谛者是名中智。分别世谛无量无边不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。一切行无常诸法无我涅槃寂灭是第一义。是名中智。知第一义无量无边不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之

尔时文殊师利菩萨白佛言。世尊。所说世谛第一义谛。其义云何。世尊。第一义中有世谛不。世谛之中有第一义不。如其有者即是一谛。如其无者将非如来虚妄说耶。善男子。世谛者即第一义谛。世尊。若尔者则无二谛。佛言。善男子。有善方便随顺众生说有二谛。善男子。若随言说则有二种。一者世法。二者出世法。善男子。如出世人之所知者名第一义谛。世人知者名为世谛。善男子。五阴和合称言某甲。凡夫众生随其所称。是名世谛。解阴无有某甲名字离阴亦无某甲名字。出世之人如其性相而能知之。名第一义谛。复次善男子。或复有法有名有实。或复有法有名无实。善男子。有名无实者即是世谛。有名有实者是第一义谛。善男子。如我众生寿命知见养育丈夫作者受者。热时之炎乾闼婆城龟毛兔角旋火之轮。诸阴界入是名世谛。苦集灭道名第一义谛。善男子。世法有五种。一者名世。二者句世。三者缚世。四者法世。五者执着世。善男子。云何名世。男女瓶衣车乘屋舍。如是等物是名名世。云何句世。四句一偈。如是等偈是名句世。云何缚世。卷合系结束缚合掌。是名缚世。云何法世。如鸣椎集僧严鼓诫兵吹贝知时。是名法世。云何执着世。如望远人有染衣者。生想执着言是沙门非婆罗门。见有结绳横佩身上便生念言是婆罗门非沙门也。是名执着世。善男子。如是名为五种世法。善男子。若有众生于如是等五种世法。心无颠倒如实而知。是名第一义谛。复次善男子。若烧若割若死若坏。是名世谛。无烧无割无死无坏。是名第一义谛。复次善男子。有八苦相名为世谛。无生无老无病无死。无爱别离无怨憎会无求不得无五盛阴。是名第一义谛。复次善男子。譬如一人多有所能。若其走时则名走者。若收刈时复名刈者。或作饮食名作食者。若治材木则名工匠锻金银时言金银师。如是一人有多名字。法亦如是其实是一而有多名。依因父母和合而生。名为世谛。十二因缘和合生者。名第一义谛

文殊师利菩萨白佛言。世尊。所言实谛其义云何。佛言。善男子。言实谛者名曰真法。善男子。若法非真不名实谛。善男子。实谛者无颠倒。无颠倒者乃名实谛。善男子。实谛者无有虚妄。若有虚妄不名实谛。善男子。实谛者名曰大乘。非大乘者不名实谛。善男子。实谛者是佛所说非魔所说。若是魔说非佛说者不名实谛。善男子。实谛者一道清净无有二也。善男子。有常有乐有我有净。是则名为实谛之义。文殊师利白佛言。世尊。若以真实为实谛者。真实之法即是如来虚空佛性。若如是者如来虚空及与佛性无有差别。佛告文殊师利。有苦有谛有实。有集有谛有实。有灭有谛有实。有道有谛有实。善男子。如来非苦非谛是实。虚空非苦非谛是实。佛性非苦非谛是实。文殊师利。所言苦者为无常相是可断相。是为实谛。如来之性非苦非无常非可断相。是故为实。虚空佛性亦复如是。复次善男子。所言集者能令五阴和合而生。亦名为苦亦名无常是可断相。是为实谛。善男子。如来非是集性非是阴因非可断相。是故为实。虚空佛性亦复如是。善男子。所言灭者名烦恼灭。亦常无常。二乘所得名曰无常。诸佛所得是则名常。亦名证法。是为实谛。善男子。如来之性不名为灭。能灭烦恼非常无常。不名证知。常住无变。是故为实。虚空佛性亦复如是。善男子。道者能断烦恼亦常无常是可修法。是名实谛。如来非道能断烦恼非常无常。非可修法常住不变。是故为实。虚空佛性亦复如是。复次善男子。言真实者即是如来。如来者即是真实。真实者即是虚空。虚空者即是真实。真实者即是佛性。佛性者即是真实。文殊师利。有苦有苦因有苦尽有苦对。如来非苦乃至非对。是故为实不名为谛。虚空佛性亦复如是。苦者有为有漏无乐。如来非有为非有漏湛然安乐。是实非谛。文殊师利白佛言。世尊。如佛所说。不颠倒者名为实谛。若尔者四谛之中有四倒不。如其有者云何说言无有颠倒名为实谛。一切颠倒不名为实。佛告文殊师利。一切颠倒皆入苦谛。如诸众生有颠倒心。名为颠倒。善男子。譬如有人不受父母尊长教敕。虽受不能随顺修行。如是人等名为颠倒。如是颠倒非不是苦。即是苦也。文殊师利言。如佛所说。不虚妄者即是实谛。若尔者当知虚妄则非实谛。佛言。善男子。一切虚妄皆入苦谛。如有众生欺诳于他。以是因缘堕于地狱畜生饿鬼。如是等法名为虚妄。如是虚妄非不是苦即是苦也声闻缘觉诸佛世尊。远离不行故名虚妄。如是虚妄诸佛二乘所断除故故名实谛。文殊师利言。如佛所说。大乘是实谛者。当知声闻辟支佛乘则为不实。佛言。文殊师利。彼二乘者亦实不实。声闻缘觉断诸烦恼则名为实。无常不住是变易法名为不实。文殊师利言。如佛所说。若佛所说名为实者。当知魔说则为不实。世尊。如魔所说圣谛摄不。佛言。文殊师利。魔所说者二谛所摄。所谓苦集凡是一切非法非律。不能令人而得利益。终日宣说亦无有人见苦断集证灭修道。是名虚妄。如是虚妄名为魔说。文殊师利言。如佛所说。一道清净无有二者。诸外道等亦复说言。我有一道清净无二。若言一道是实谛者。与彼外道有何差别。若无差别不应说言一道清净。佛言。善男子。诸外道等有苦集谛无灭道谛。于非灭中而生灭想。于非道中而生道想。于非果中而生果想。于非因中而生因想。以是义故。彼无一道清净无二

文殊师利言。如佛所说。有常有我有乐有净是实义者。诸外道等应有实谛佛法中无。何以故。诸外道辈亦复说言。诸行是常。云何是常。可意不可意诸业报等受不失故。可意者名十善报。不可意者十不善报。若言诸行悉皆无常而作业者于此已灭。谁复于彼受果报乎。以是义故诸行是常。杀生因缘故名为常。世尊。若言诸行悉无常者。能杀可杀二俱无常。若无常者谁于地狱而受罪报。若言定有地狱受报者。当知诸行实非无常。世尊。系心专念亦名为常。所谓十年所念乃至百年亦不忘失。是故为常。若无常者本所见事谁忆谁念。以是因缘一切诸行非无常也。世尊。一切忆想亦名为常。有人先见他人手足头项等相。后时若见便还识之。若无常者本相应灭。世尊。诸所作业以久修习。若从初学或经三年或经五年。然后善知故名为常。世尊。算数之法从一至二从二至三乃至百千。若无常者初一应灭。初一若灭谁复至二。如是常一终无有二。以一不灭故得至二乃至百千。是故为常。世尊。如读诵法诵一阿含至二阿含。乃至三四阿含。如其无常所可读诵终不至四。以是读诵增长因缘。故名为常。世尊。瓶衣车乘如人负债。大地形相山河树林。药木草叶众生治病。皆悉是常亦复如是。世尊。一切外道皆作是说诸行是常。若是常者即是实谛。世尊。有诸外道复言有乐。云何知耶。受者定得可意报故。世尊。凡受乐者必定得之。所谓大梵天王大自在天释提桓因毗纽天及诸人天。以是义故名定有乐。世尊。有诸外道复言有乐。能令众生生求望故。饥者求食渴者求饮。寒者求温热者求凉。极者求息病者求差。欲者求色。若无乐者彼何缘求。以有求者故知有乐。世尊。有诸外道复作是言。施能得乐。世间之人好施沙门诸婆罗门贫穷困苦。衣服饮食卧具医药。象马车乘末香涂香。众花屋宅依止灯明。作如是等种种惠施。为我后世受可意报。是故当知决定有乐。世尊。有诸外道复作是言。以因缘故当知有乐。所谓受乐者。有因缘故名为乐触。若无乐者何得因缘。如无兔角则无因缘。有乐因缘则知有乐。世尊。有诸外道复作是言。上中下故当知有乐。下受乐者释提桓因。中受乐者大梵天王。上受乐者大自在天。以有如是上中下故。当知有乐。世尊。有诸外道复言有净。何以故。若无净者不应起欲。若起欲者当知有净。又复说言。金银珍宝琉璃颇梨车磲马瑙珊瑚真珠璧玉珂贝。流泉浴池饮食衣服。花香末香涂香灯烛之明。如是等物悉是净法。复次有净。谓五阴者即是净器盛诸净物。所谓人天诸仙阿罗汉辟支佛菩萨诸佛。以是义故名之为净。世尊。有诸外道复言有我。有所睹见能造作故。譬如有人入陶师家。虽复不见陶师之身。以见轮绳定知其家必是陶师。我亦如是。眼见色已必知有我。若无我者谁能见色。闻声乃至触法亦复如是。复次有我云何得知。因相故知。何等为相。喘息视眴寿命役心。受诸苦乐贪求嗔恚。如是等法悉是我相。是故当知必定有我。复次有我能别味故。有人食果见已知味。是故当知必定有我。复次有我云何知耶。执作业故。执镰能刈执斧能斫。执瓶盛水执车能御。如是等事我执能作。是故当知必定有我。复次有我云何知耶。即于生时欲得乳哺。乘宿习故。是故当知必定有我。复次有我云何知耶。和合利益他众生故。譬如瓶衣车乘田宅山林树木象马牛羊。如是等物若和合者则有利益。此内五阴亦复如是。眼等诸根有和合故则利益我。是故当知必定有我。复次有我云何知耶。有遮法故。如有物故则有遮碍。物若无者则无有遮。若有遮者则知有我。是故当知必定有我。复次有我云何知耶。伴非伴故。亲与非亲非是伴侣。正法邪法亦非伴侣。智与非智亦非伴侣。沙门非沙门。婆罗门非婆罗门。子非子。昼非昼。夜非夜。我非我。如是等法为伴非伴。是故当知必定有我。世尊。诸外道等种种说有常乐我净。当知定有常乐我净。世尊。以是义故。诸外道等亦得说言我有真谛。佛言。善男子。若有沙门婆罗门有常有乐有净有我者。是非沙门非婆罗门。何以故。迷于生死离一切智大导师故。如是沙门婆罗门等沉没诸欲。善法羸损故。是诸外道系在贪欲嗔恚痴狱。堪忍爱乐故。是诸外道虽知业果自作自受。而犹不能远离恶法。是诸外道非是正法正命自活。何以故。无智慧火不能消故。是诸外道虽欲贪着上妙五欲。贫于善法不勤修故是诸外道虽欲往至正解脱中。而持戒足不成就故。是诸外道虽欲求乐。而不能求乐因缘故。是诸外道虽复憎恶一切诸苦。然其所行未能远离诸苦因缘。是诸外道虽为四大毒蛇所缠。犹行放逸不能谨慎。是诸外道无明所覆。远离善友乐在三界无常炽然大火之中而不能出。是诸外道遇诸烦恼难愈之病而复不求大智良医。是诸外道方于未来。当涉无边险远之路。而不知以善法资粮而自庄严。是诸外道常为淫欲灾毒所害。而反抱持五欲霜毒。是诸外道嗔恚炽盛。而复反更亲近恶友。是诸外道常为无明之所覆蔽。而反推求邪恶之法。是诸外道常为邪见之所诳惑。而反于中生亲善想。是诸外道悕食甘果而种苦子。是诸外道已处烦恼闇室之中。而反远离大智炬明。是诸外道患烦恼渴。而复反饮诸欲碱水。是诸外道漂没生死无边大河。而复远离无上船师。是诸外道迷惑颠倒言诸行常。诸行若常无有是处

大般涅槃经卷第十二大般涅槃经卷第十三

        宋代沙门慧严等依泥洹经加之

    圣行品之下

善男子。我观诸行悉皆无常。云何知耶。以因缘故。若有诸法从缘生者则知无常。是诸外道无有一法不从缘生。善男子。佛性无生无灭无去无来。非过去非未来非现在。非因所作非无因作。非作非作者。非相非无相。非有名非无名。非名非色。非长非短。非阴界入之所摄持。是故名常。善男子。佛性即是如来。如来即是法。法即是常。善男子。常者即是如来。如来即是僧。僧即是常。以是义故从因生法不名为常。是诸外道无有一法不从因生。善男子。是诸外道不见佛性如来及法。是故外道所可言说。悉是妄语无有真谛。诸凡夫人先见瓶衣车乘舍宅城郭河水山林男女象马牛羊。后见相似便言是常。当知其实非是常也。善男子。一切有为皆是无常。虚空无为是故为常。佛性无为是故为常。虚空者即是佛性。佛性者即是如来。如来者即是无为。无为者即是常。常者即是法。法者即是僧。僧即无为。无为者即是常。善男子。有为之法凡有二种。色法非色法。非色法者心心数法。色法者地水火风。善男子。心名无常。何以故。性是攀缘相应分别故。善男子。眼识性异乃至意识性异。是故无常。善男子。色境界异乃至法境界异。是故无常。善男子。眼识相应异乃至意识相应异。是故无常。善男子。心若常者眼识应独缘一切法。善男子。若眼识异乃至意识异则知无常。以法相似念念生灭。凡夫见已计之为常。善男子。诸因缘相可破坏故亦名无常。所谓因眼因色因明因思惟生于眼识。耳识生时所因各异。非眼识因缘。乃至意识异亦如是。复次善男子。坏诸行因缘异故心名无常。所谓修无常心异。修苦空无我心异。心若常者应常修无常。尚不得观苦空无我。况复得观常乐我净。以是义故。外道法中不能摄取常乐我净。善男子。当知心法必定无常。复次善男子。心性异故名为无常。所谓声闻心性异。缘觉心性异。诸佛心性异。一切外道心有三种。一者出家心。二者在家心。三者在家远离心。乐相应心异。苦相应心异。不苦不乐相应心异。贪欲相应心异。嗔恚相应心异。愚痴相应心异。一切外道心相亦异。所谓愚痴相应心异。疑惑相应心异。邪见相应心异。进止威仪其心亦异。善男子。心若常者亦复不能分别诸色。所谓青黄赤白紫色。善男子。心若常者诸忆念法不应忘失。善男子。心若常者凡所读诵不应增长。复次善男子。心若常者不应说言已作今作当作。若有已作今作当作。当知是心必定无常。善男子。心若常者则无怨亲非怨非亲。心若常者则不应言我物他物若死若生。心若常者虽有所作不应增长。善男子。以是义故。当知心性各各别异。有别异故当知无常。善男子。我今于此非色法中。演说无常其义已显。复当为汝说色无常。是色无常本无有生。生已灭故。内身处胎歌罗逻时本无有生。生已变故。外诸牙茎本亦无生。生已变故。是故当知一切色法悉皆无常。善男子。所有内色随时而变。歌罗逻时异。安浮陀时异。伽那时异。闭手时异。诸疱时异。初生时异。婴孩时异。童子时异。乃至老时各各变异。所有外色亦复如是。牙异茎异枝异叶异花异果异。复次善男子。内味亦异。歌罗逻时乃至老时各各变异。外味亦尔。牙茎枝叶花果味异。歌罗逻时力异。乃至老时力异。歌罗逻时状貌异。乃至老时状貌亦异。歌罗逻时果报异。乃至老时果报亦异。歌罗逻时名字异。乃至老时名字亦异。所谓内色坏已还合故知无常。外诸树木亦坏已还合故知无常。次第渐生故知无常。次第生歌罗逻时乃至老时。次第生牙乃至果子故知无常。诸色可灭故知无常。歌罗逻灭时异。乃至老灭时异。牙灭时异。乃至果灭时异故知无常。凡夫无智见相似生计以为常。以是义故名曰无常。若无常即是苦。若苦即是不净。善男子。我因迦叶先问是事。于彼已答

复次善男子。诸行无我。善男子。总一切法谓色非色。色非我也。何以故。可破可坏可裂可折。生增长故。我者不可破坏裂折生长。以是义故知色非我。非色之法亦复非我。何以故。因缘生故。善男子。若诸外道以专念故知有我者。专念之性实非我也。若以专念为我性者。过去之事则有忘失。有忘失故定知无我。善男子。若诸外道以忆想故知有我者。无忆想故定知无我。如说见人手有六指。即便问言。我先何处共相见耶。若有我者不应复问。以相问故定知无我。善男子。若诸外道以有遮故知有我者。善男子。以有遮故定知无我。如言调达终不发言非调达也。我亦如是。若定是我终不遮我。以遮我故定知无我。若以遮故知有我者。汝今不遮定应无我。善男子。若诸外道以伴非伴知有我者。以无伴故应无有我。有法无伴。所谓如来虚空佛性。我亦如是实无有伴。以是义故定知无我。复次善男子。若诸外道以名字故知有我者。无我法中亦有我名。如贫贱人名字富贵。如言我死。若我死者我则杀我。而我实不可杀。假名杀我。亦如短人名为长者。以是义故定知无我。复次善男子。若诸外道以生已求乳知有我者。善男子。若有我者一切婴儿。不应执持粪秽火蛇毒药。以是义故定知无我。复次善男子。一切众生于三法中悉有等智。所谓淫欲饮食恐怖。是故无我。复次善男子。若诸外道以相貌故知有我者。善男子。相故无我。无相故亦无我。若人睡时不能进止俯仰视眴。不觉苦乐不应有我。若以进止俯仰视眴知有我者。机关木人亦应有我。善男子。如来亦尔。不进不止不俯不仰不视不眴。不苦不乐不贪不恚不痴不行。如来如是真实有我。复次善男子。若诸外道以见他食果口中生涎知有我者。善男子。以忆念故见则生涎。涎非我也我亦非涎。非喜非悲非哭非笑。非卧非起非饥非饱。以是义故定知无我。善男子。是诸外道痴如小儿无慧方便。不能了达常与无常苦乐净不净我无我。寿命非寿命众生非众生。实非实有非有。于佛法中取少许分。虚妄计有常乐我净。而实不知常乐我净。如生盲人不识乳色。便问他言。乳色何似。他人答言。色白如贝。盲人复问。是乳色者如贝声耶。答言不也。复问贝色为何似耶。答言犹稻米末。盲人复问。乳色柔软如稻米末耶。稻米末者复何所似。答言犹如雨雪。盲人复言。彼稻米末冷如雪耶。雪复何似。答言犹如白鹤。是生盲人虽闻如是四种譬喻。终不能得识乳真色。是诸外道亦复如是。终不能识常乐我净。善男子。以是义故。我佛法中有真实谛。非于外道

文殊师利白佛言。希有世尊。如来于今临般涅槃。方更转于无上法轮。乃作如是分别真谛。佛告文殊师利。汝今云何故于如来生涅槃想。善男子。如来实是常住不变不般涅槃。善男子。若有计我是佛我成阿耨多罗三藐三菩提。我即是法法是我所。我即是道道是我所。我即世尊世尊即是我所。我即声闻声闻即是我所。我能说法令他听受。我转法轮余人不能。如来终不作如是计。是故如来不转法轮。善男子。若有人作如是妄计。我即是眼眼即是我所。耳鼻舌身意亦复如是。我即是色色是我所。乃至法亦如是。我即是地地即是我所。水火风等亦复如是。善男子若有人言。我即是信信是我所。我是多闻多闻即是我所。我是檀波罗蜜檀波罗蜜即是我所。我是尸波罗蜜尸波罗蜜即是我所。我是羼提波罗蜜羼提波罗蜜即是我所。我是毗梨耶波罗蜜毗梨耶波罗蜜即是我所。我是禅波罗蜜禅波罗蜜即是我所。我是般若波罗蜜般若波罗蜜即是我所。我是四念处四念处即是我所。四正勤四如意足五根五力七觉分八圣道分亦复如是。善男子。如来终不作如是计。是故如来不转法轮。善男子。若言常住无有变易。云何说言佛转法轮。是故汝今不应说言如来方便转于法轮。善男子。譬如因眼缘色缘明缘思惟因缘和合得生眼识。善男子。眼不念言我能生识。色乃至思惟。终不念言我生眼识。眼识亦复不作念言我能自生。善男子。如是等法因缘和合得名为见。善男子。如来亦尔。因六波罗蜜三十七助菩提之法。觉了诸法。复因咽喉舌齿唇口言语音声。为憍陈如初始说法。名转法轮。以是义故如来不名转法轮也。善男子。若不转者即名为法。法即如来。善男子。譬如因燧因钻因手因干牛粪而得生火。燧亦不言我能生火。钻手牛粪各不念言我能生火。火亦不言我能自生。如来亦尔。因六波罗蜜乃至憍陈如。名转法轮。如来亦复不生念言我转法轮。善男子。若不生者是则名为转正法轮。是转法轮即名如来。善男子。譬如因酪因水因攒因瓶因绳因人手捉而得出酥。酪不念言我能出酥乃至人手亦不念言我能出酥。酥亦不言我能自出。众缘和合故得出酥。如来亦尔。终不念言我转法轮。善男子。若不出者是则名为转正法轮。是转法轮即是如来。善男子。譬如因子因地因水因火因风因粪因时因人作业而芽得生。善男子。子亦不言我能生牙。乃至作业亦不念言我能生牙。牙亦不言我能自生。如来亦尔。终不念言我转法轮。善男子。若不作者是则名为转正法轮。是转法轮即是如来。善男子。譬如因鼓因空因皮因人因桴和合出声。鼓不念言我能出声。乃至桴亦如是。声亦不言我能自生。善男子。如来亦尔。终不念言我转法轮。善男子。转法轮者名为不作。不作者即转法轮。转法轮者即是如来。善男子。转法轮者乃是诸佛世尊境界。非诸声闻缘觉所知善男子。虚空非生非出非作非造非有为法。如来亦尔。非生非出非作非造非有为法。如如来性佛性亦尔。非生非出非作非造非有为法。善男子。诸佛世尊语有二种。一者世语。二出世语。善男子。如来为诸声闻缘觉说于世语。为诸菩萨说出世语。善男子。是诸大众复有二种。一者求小乘。二者求大乘。我于昔日波罗奈城为诸声闻转于法轮。今始于此拘尸那城。为诸菩萨转大法轮。复次善男子。复有二人。中根上根。为中根人。于波罗奈转于法轮。为上根人人中象王迦叶菩萨等。今于此间拘尸那城转大法轮。善男子。极下根者如来终不为转法轮。极下根者即一阐提。复次善男子。求佛道者复有二种。一中精进。二上精进。于波罗奈为中精进转于法轮。今于此间拘尸那城为上精进转大法轮。复次善男子。我昔于彼波罗奈城初转法轮。八万天人得须陀洹果。今于此间拘尸那城。八十万亿人不退转于阿耨多罗三藐三菩提。复次善男子。波罗奈城大梵天王稽首请我转于法轮。今于此间拘尸那城。迦叶菩萨稽首请我转大法轮。复次善男子。我昔于彼波罗奈城转法轮时。说无常苦空无我今于此间拘尸那城转法轮时说常乐我净

复次善男子。我昔于彼波罗奈城转法轮时。所出音声闻于梵天。如来今于拘尸那城转法轮时。所出音声遍于东方二十恒河沙等诸佛世界。南西北方四维上下亦复如是。复次善男子。诸佛世尊凡有所说。皆悉名为转法轮也。善男子。譬如圣王所有轮宝未降伏者能令降伏已降伏者能令安隐。善男子。诸佛世尊凡所说法亦复如是。无量烦恼未调伏者能令调伏。已调伏者令生善根。善男子。譬如圣王所有轮宝则能消灭一切怨贼。如来演法亦复如是。能令一切诸烦恼贼皆悉寂静。复次善男子。譬如圣王所有轮宝上下回转。如来说法亦复如是能令下趣诸恶众生上生人天乃至佛道。善男子。是故汝今不应赞言如来于此更转法轮。尔时文殊师利白佛言。世尊。我于此义非为不知。所以问者。为欲利益诸众生故。世尊。我已久知。转法轮者实是诸佛如来境界。非是声闻缘觉所及。尔时世尊告迦叶菩萨。善男子。是名菩萨住于大乘大涅槃经所行圣行

迦叶菩萨白佛言。世尊。复以何义名为圣行。善男子。圣名诸佛世尊。以是义故名为圣行。世尊。若是诸佛之所行者。则非声闻缘觉菩萨所能修行。善男子。是诸世尊安住于此大般涅槃。而作如是开示分别演说其义。以是义故名曰圣行。声闻缘觉及诸菩萨。如是闻已则能奉行。故名圣行。善男子。是菩萨摩诃萨得是行已。则得住于无所畏地。善男子。若有菩萨得住如是无所畏地。则不复畏贪恚愚痴生老病死。亦复不畏恶道地狱畜生饿鬼。善男子。恶有二种。一者阿修罗。二者人中。人中有三种恶。一者一阐提。二者诽谤方等经典。三者犯四重禁善男子。住是地中诸菩萨等。终不畏堕如是恶中。亦复不畏沙门婆罗门外道邪见天魔波旬。亦复不畏受二十五有。是故此地名无所畏。善男子。菩萨摩诃萨住无畏地。得二十五三昧坏二十五有。善男子。得无垢三昧能坏地狱有。得无退三昧能坏畜生有。得心乐三昧能坏饿鬼有。得欢喜三昧能坏阿修罗有。得日光三昧能断弗婆提有。得月光三昧能断瞿耶尼有。得热炎三昧能断郁单越有。得如幻三昧能断阎浮提有。得一切法不动三昧能断四天处有。得难伏三昧能断三十三天处有。得悦意三昧能断炎摩天有。得青色三昧能断兜率天有。得黄色三昧能断化乐天有。得赤色三昧能断他化自在天有。得白色三昧能断初禅有。得种种三昧能断大梵王有。得双三昧能断二禅有。得雷音三昧能断三禅有。得澍雨三昧能断四禅有。得如虚空三昧能断无想有。得照镜三昧能断净居阿那含有。得无碍三昧能断空处有。得常三昧能断识处有。得乐三昧能断不用处有。得我三昧能断非想非非想处有。善男子。是名菩萨得二十五三昧断二十五有。善男子。如是二十五三昧名诸三昧王。善男子。菩萨摩诃萨入如是等诸三昧王。若欲吹坏须弥山王。随意即能。欲知三千大千世界所有众生心之所念。亦悉能知。欲以三千大千世界所有众生内于己身一毛孔中。随意即能。亦令众生无迫迮想。若欲化作无量众生悉令充满三千大千世界中者。亦能随意。欲分一身以为多身复合多身以为一身。虽作如是心无所著犹如莲花。善男子。菩萨摩诃萨得入如是三昧王已。即得住于自在之地。菩萨得住是自在地。得自在力随欲生处即得往生。善男子。譬如圣王领四天下随意所行无能障碍。菩萨摩诃萨亦复如是。一切生处若欲生者随意往生。善男子。菩萨摩诃萨若见地狱一切众生有可化令住善根者。菩萨即往而生其中。菩萨虽生非本业果。菩萨摩诃萨住自在地力因缘故而生其中。善男子。菩萨摩诃萨虽在地狱。不受炽然碎身等苦。善男子。菩萨摩诃萨所可成就。如是功德无量无边。百千万亿尚不可说。何况诸佛所有功德而当可说

尔时众中有一菩萨。名曰无垢藏王。有大威德成就神通。得大总持三昧具足得无所畏。即从座起偏袒右肩右膝着地。长跪合掌白佛言。世尊。如佛所说。诸佛菩萨所可成就。功德智慧无量无边。百千万亿实不可说。我意犹谓。故不如是大乘经典。何以故。因是大乘方等经力故。能出生诸佛世尊阿耨多罗三藐三菩提。时佛赞言。善哉善哉。善男子。如是如是。如汝所说。是诸大乘方等经典。虽复成就无量功德。欲比是经不得为喻。百倍千倍百千万亿倍。乃至算数譬喻所不能及。善男子。譬如从牛出乳从乳出酪从酪出生酥从生酥出熟酥从熟酥出醍醐。醍醐最上。若有服者众病皆除。所有诸药悉入其中。善男子。佛亦如是。从佛出生十二部经。从十二部经出修多罗。从修多罗出方等经。从方等经出般若波罗蜜。从般若波罗蜜出大涅槃。犹如醍醐。言醍醐者喻于佛性。佛性者即是如来。善男子。以是义故。说言如来所有功德无量无边不可称计

迦叶菩萨白佛言。世尊。如佛所赞大涅槃经。犹如醍醐最上最妙。若有能服众病悉除。一切诸药悉入其中。我闻是已窃复思念。若有不能听受是经。当知是人为大愚痴无有善心。世尊。我于今者实能堪忍剥皮为纸刺血为墨。以髓为水折骨为笔。书写如是大涅槃经。书已读诵令其通利。然后为人广说其义。世尊。若有众生贪着财物。我当施财然后以是大涅槃经劝之令读。若尊贵者先以爱语而随其意。然后渐当以是大乘大涅槃经劝之令读。若凡庶者当以威势逼之令读。若憍慢者我当为其而作仆使随顺其意令其欢喜。然后当以大般涅槃。而教导之。若有诽谤大乘经者。当以势力摧之令伏。既摧伏已然后劝令读大涅槃。若有爱乐大乘经者。我躬当往恭敬供养尊重赞叹。尔时佛赞迦叶菩萨。善哉善哉。汝甚爱乐大乘经典。贪大乘经受大乘经味大乘经。信敬尊重供养大乘。善男子。汝今以此善心因缘。当得超越无量无边恒河沙等诸大菩萨。在前得成阿耨多罗三藐三菩提。汝亦不久复当如我广为大众演说如是大般涅槃如来佛性诸佛所说秘密之藏。善男子过去之世佛日未出。我于尔时作婆罗门修菩萨行。悉能通达一切外道所有经论。修寂灭行具足威仪。其心清净。不为外来能生欲想之所破坏。灭嗔恚火。受持常乐我净之法。周遍求索大乘经典。乃至不闻方等名字。我于尔时住于雪山。其山清净流泉浴池。树林药木充满其地。处处石间有清流水。多诸香花周遍严饰。众鸟禽兽不可称计。甘果滋繁种别难计。复有无量藕根甘根青木香根。我于尔时独处其中唯食诸果。食已系心思惟坐禅。经无量岁。亦不闻有如来出世大乘经名。善男子。我修如是苦难行时。释提桓因等诸天人。心大惊怪即共集会。各各相谓而说偈言

  各共相指示　　清净雪山中
  寂静离欲主　　功德庄严王
  以离贪嗔慢　　永断诸愚痴
  口初未曾说　　粗恶等语言

尔时众中有一天子名曰欢喜。复说偈言

  如是离欲人　　清净勤精进
  将不求帝释　　及以诸天耶
  若是求道者　　修行诸苦行
  是人多欲求　　帝释所坐处

尔时复有一仙天子。即为帝释而说偈言

  天主憍尸迦　　不应生此虑
  外道修苦行　　何必求帝处

说是偈已复作是言。憍尸迦。世有大士。为众生故不贪己身。为欲利益诸众生故。而修种种无量苦行。如是之人见生死中诸过咎故。设见珍宝满此大地诸山大海。不生贪着如视涕唾。如是大士弃舍财宝所爱妻子头目髓脑手足支节所居舍宅象马车乘奴婢僮仆。亦不愿求生于天上。唯求欲令一切众生得受快乐。如我所解。如是大士清净无染众结永尽。唯欲求于阿耨多罗三藐三菩提。释提桓因复作是言。如汝言者是人则为摄取一切世间众生。大仙。若此世间有佛树者。能除一切诸天世人及阿修罗烦恼毒蛇。是诸众生住是佛树阴凉中者。烦恼诸毒悉得消灭。大仙。是人若当未来世中作善逝者。我等悉当得灭无量炽然烦恼。如是之事实为难信。何以故。无量百千诸众生等。发于阿耨多罗三藐三菩提心。见少微缘于阿耨多罗三藐三菩提即便动转如水中月水动则动。犹如画像难成易坏。菩提之心。亦复如是难发易坏。大仙。如有多人以诸铠仗牢自庄严欲前讨贼。临阵恐怖则便退散。无量众生亦复如是。发菩提心牢自庄严。见生死过心生恐怖即便退散。大仙。我见如是无量众生。发心之后皆生动转。是故我今虽见是人修于苦行无恼无热住于险道其行清净。未能信也。我今要当自往试之知其实能堪任荷负阿耨多罗三藐三菩提大重担不。大仙。犹如车有二轮则能载用。鸟有二翼堪任飞行。是苦行者亦复如是。我虽见其坚持禁戒。未知其人有深智不。若有深智当知则能堪任荷负阿耨多罗三藐三菩提之重担也。大仙。譬如鱼母多有胎子成就者少。如庵罗树花多果少。众生发心。乃有无量。及其成就少不足言。大仙。我当与汝俱往试之。大仙。譬如真金三种试已乃知其真。谓烧打磨。试彼苦行者亦当如是

尔时释提桓因。自变其身作罗刹像形甚可畏。下至雪山去其不远而便立住。是时罗刹心无所畏勇健难当。辩才次第其声清雅。宣过去佛所说半偈

  诸行无常　　是生灭法

说是半偈已便住其前。所现形貌甚可怖畏。顾眄遍视观于四方。是苦行者。闻是半偈心生欢喜。譬如估客于险难处夜行失伴。恐怖推索还遇同侣。心生欢喜踊跃无量。亦如久病未遇良医瞻病好药后卒得之。如人没海卒遇船舫。如渴乏人遇清冷水。如为怨逐忽然得脱。如久系人卒闻得出。亦如农夫炎旱值雨。亦如行人还得归家人见已生大欢喜。善男子。我于尔时闻是半偈。心中欢喜亦复如是。即从座起以手举发。四向顾视而说是言。向所闻偈谁之所说。尔时亦更不见余人。唯见罗刹即说是言。谁开如是解脱之门。谁能雷震诸佛音声。谁于生死睡眠之中而独觉寤。唱如是言。谁能于此示道生死饥馑众生无上道味。无量众生沉生死海。谁能于中作大船师。是诸众生常为烦恼重病所缠。谁能于中为作良医。说是半偈启悟我心。犹如半月渐开莲花。善男子。我于尔时更无所见。唯见罗刹。复作是念。将是罗刹说是偈耶。覆生疑惑。非其说耶。何以故。是人形容甚可怖畏。若有得闻是偈句者。一切恐怖丑陋即除。何有此人形貌如是能说此偈。不应火中出于莲花。非日光中出生冷水。善男子。我于尔时复作是念。我今无智。而此罗刹或能得见过去诸佛。从诸佛所闻是半偈。我今当问。即便前至是罗刹所。作如是言。善哉大士。汝于何处得是过去离怖畏者所说半偈。大士。复于何处而得如是半如意珠。大士。是半偈义乃是过去未来现在诸佛世尊之正道也。一切世间无量众生。常为诸见罗网所覆。终身于此外道法中。初不得闻如是出世十力世雄所说空义。善男子。我闻是已。即答我言。大婆罗门汝今不应问我是义。何以故。我不食来已经多日。处处求索了不能得。饥渴苦恼心乱谬语。非我本心之所知也。我今力能飞行虚空。至郁单越乃至天上。处处求食亦不能得。以是义故我说是语。善男子。我时即复语罗刹言。大士。若能为我说是偈竟。我当终身为汝弟子。大士。汝所说者名字不终义亦不尽。以何因缘不欲说耶。夫财施者则有竭尽。法施因缘不可尽也。法施无尽多所利益。我今闻此半偈法已。心生惊疑。汝今幸可为我除断。说此偈竟我当终身为汝弟子。罗刹答言。汝智太过但自忧身。都不见念今我定为饥苦所逼实不能说。我即问言。汝所食者为是何物。罗刹答言。汝不足问。我若说者令多人怖。我复问言。此中独处更无有人。我不畏汝何故不说。罗刹答言。我所食者唯人暖肉。其所饮者唯人热血。自我薄福唯食此食。周遍求索困不能得。世虽多人皆有福德。兼为诸天之所守护。而我无力不能得杀。善男子。我复语言。汝但具足说是半偈。我闻偈已当以此身奉施供养。大士。我设命终如此之身无所复用。当为虎狼鸱枭雕鹫之所啖食。然复不得一毫之福。我今为求阿耨多罗三藐三菩提。舍不坚身以易坚身。罗刹答言。谁当信汝如是之言。为八字故弃所爱身。善男子。我即答言。汝真无智。譬如有人施他瓦器得七宝器。我亦如是舍不坚身得金刚身。汝言谁当信者。我今有证。大梵天王释提桓因及四天王能证是事。复有天眼诸菩萨等为欲利益无量众生修行大乘具六度者。亦能证知。复有十方诸佛世尊利众生者。亦能证我为八字故舍于身命。罗刹复言。汝若如是能舍身者。谛听谛听。当为汝说其余半偈。善男子。我于尔时闻是事已心中欢喜。即解己身所著鹿皮。为此罗刹敷置法座。白言。和上。愿坐此座。我即于前叉手长跪而作是言。唯愿和上。善为我说其余半偈令得具足。罗刹即说

  生灭灭已　　寂灭为乐

尔时罗刹说是偈已。复作是言。菩萨摩诃萨汝今已闻具足偈义。汝之所愿为悉满足。若必欲利诸众生者。时施我身。善男子。我于尔时深思此义。然后处处若石若壁若树若道书写此偈。即便更系所著衣裳。恐其死后身体露现。即上高树。尔时树神复问我言。善哉仁者欲作何事。善男子。我时答言。我欲舍身以报偈价。树神问言。如是偈者何所利益。我时答言。如是偈句乃是过去未来现在诸佛所说开空法道。我为此法弃舍身命。不为利养名闻财宝转轮圣王四大天王释提桓因大梵天王人天中乐。为欲利益一切众生故舍此身。善男子。我舍身时复作是言。愿令一切悭惜之人悉来见我舍离此身。若有少施起贡高者。亦令得见我为一偈舍此身命如弃草木。我于尔时说是语已。寻即放身自投树下。下未至地时。虚空之中出种种声。其声乃至阿迦尼吒。尔时罗刹还复释身。即于空中接取我身安置平地。尔时释提桓因及诸天人大梵天王稽首顶礼于我足下。赞言善哉善哉。真是菩萨。能大利益无量众生。欲于无明黑闇之中然大法炬。由我爱惜如来大法故相娆恼。唯愿听我忏悔罪咎。汝于未来必定成就阿耨多罗三藐三菩提。愿见济度。尔时释提桓因及诸天众顶礼我足。于是辞去忽然不现。善男子。如我往昔为半偈故舍弃此身。以是因缘便得超越足十二劫。在弥勒前成阿耨多罗三藐三菩提。善男子。我得如是无量功德。皆由供养如来正法。善男子。汝今亦尔。发于阿耨多罗三藐三菩提心。则已超过无量无边恒河沙等诸菩萨上。善男子。是名菩萨住于大乘大般涅槃修于圣行

大般涅槃经卷第十三大般涅槃经卷第十四

        宋代沙门慧严等依泥洹经加之

    梵行品第二十之一

善男子。云何菩萨摩诃萨梵行。善男子。菩萨摩诃萨住于大乘大般涅槃。住七善法得具梵行。何等为七。一者知法。二者知义。三者知时。四者知足。五者自知。六者知众。七者知尊卑。善男子。云何菩萨摩诃萨知法。善男子。是菩萨摩诃萨知十二部经。谓修多罗祇夜授记伽陀优陀那尼陀那阿波陀那伊帝目多伽阇陀伽毗佛略。阿浮陀达摩。优波提舍。善男子。何等名为修多罗经。从如是我闻乃至欢喜奉行。如是一切名修多罗。何等名为祇夜经。佛告诸比丘。昔我与汝愚无智慧。不能如实见四真谛。是故流转久处生死没大苦海。何等为四。苦集灭道。如佛昔日为诸比丘说契经竟。尔时复有利根众生。为听法故后至佛所。即便问人。如来向者为说何事。佛时知已。即因本经以偈颂曰

  我昔与汝等　　不见四真谛
  是故久流转　　生死大苦海
  若能见四谛　　则得断生死
  生有既已尽　　更不受诸有

是名祇夜经。何等名为授记经。如有经律如来说时。为诸天人授佛记别汝阿逸多。未来有王名曰蠰佉。当于是世而成佛道。号曰弥勒。是名授记经。何等名为伽陀经。除修多罗及诸戒律。其余有说四句之偈。所谓

  诸恶莫作　　诸善奉行　　自净其意
  是诸佛教

是名伽陀经。何等名为优陀那经。如佛晡时入于禅定。为诸天众广说法要。时诸比丘各作是念。如来今者为何所作。如来明旦从禅定起。无有人问。以他心智即自说言。比丘当知。一切诸天寿命极长。汝诸比丘。善哉为他不求己利。善哉少欲。善哉知足。善哉寂静。如是诸经无问自说。是名优陀那经。何等名为尼陀那经。如诸经偈所因根本为他演说。如舍卫国有一丈夫罗网捕鸟得已笼系随与水谷而复还放。世尊知其本末因缘。而说偈言

  莫轻小恶　　以为无殃　　水渧虽微
  渐盈大器

是名尼陀那经。何等名为阿波陀那经。如戒律中所说譬喻。是名阿波陀那经。何等名为伊帝目多伽经。如佛所说。比丘当知。我出世时所可说者名曰契经。鸠留秦佛出世之时名甘露鼓。拘那含牟尼佛时名曰法镜。迦叶佛时名分别空。是名伊帝目多伽经。何等名为阇陀伽经。如佛世尊本为菩萨修诸苦行。所谓比丘当知。我于过去作鹿作罴作獐作兔。作粟散王转轮圣王龙金翅鸟。诸如是等行菩萨道时所可受身。是名阇陀伽。何等名为毗佛略经。所谓大乘方等经典。其义广大犹如虚空。是名毗佛略。何等名为未曾有经。如彼菩萨初出生时。无人扶持即行七步。放大光明遍观十方。亦如猕猴手捧蜜器以献如来。如白项狗佛边听法。如魔波旬变为青牛。行瓦钵间。令诸瓦钵互相振触无所伤损。如佛初生入天庙时令彼天像起下礼敬。如是等经名未曾有经。何等名为优波提舍经。如佛世尊所说诸经。若作议论分别广说辨其相貌。是名优波提舍经。菩萨若能如是了知十二部经。名为知法。云何菩萨摩诃萨知义。菩萨摩诃萨若于一切文字语言广知其义。是名知义。云何菩萨摩诃萨知时。善男子。菩萨善知如是时中任修寂静。如是时中任修精进。如是时中任修舍定。如是时中任供养佛。如是时中任供养师。如是时中任修布施持戒忍辱精进禅定具足般若波罗蜜。是名知时。云何菩萨摩诃萨知足。善男子。菩萨摩诃萨知足。所谓饮食衣药行住坐卧睡寤语默。是名知足。善男子。云何菩萨摩诃萨自知。是菩萨自知我有如是信如是戒如是多闻如是舍如是慧如是去来如是正念如是善行如是问如是答。是名自知。云何菩萨摩诃萨知众。善男子。是菩萨知如是等是刹利众婆罗门众居士众沙门众。应于是众如是行来如是坐起如是说法如是问答。是名知众。善男子。云何菩萨摩诃萨知人尊卑。善男子。人有二种。一者信。二者不信。菩萨当知。信者是善。其不信者不名为善。复次信有二种。一者常往僧坊。二者不往。菩萨当知。其往者善其不往者不名为善。往僧坊者复有二种。一者礼拜。二不礼拜。菩萨当知。礼拜者善。不礼拜者不名为善。其礼拜者复有二种。一者听法。二者不听。菩萨当知。听法者善。不听法者不名为善。其听法者复有二种。一至心听。二不至心。菩萨当知。至心听者是则名善。不至心者不名为善。至心听法复有二种。一者思义。二不思议。菩萨当知。思议者善。不思议者不名为善。其思议者复有二种。一如说行。二不如说行。如说行者是则为善。不如说行不名为善。如说行者复有二种。一求声闻。不能利安饶益一切苦恼众生。二者回向无上大乘。利益多人令得安乐。菩萨应知。能利多人得安乐者。最上最善。善男子。如诸宝中如意宝珠最为胜妙。如诸味中甘露最上。如是菩萨于人天中最胜最上不可譬喻。善男子。是名菩萨摩诃萨住于大乘大涅槃经住七善法。菩萨住是七善法已得具梵行

复次善男子。复有梵行。谓慈悲喜舍。迦叶菩萨白佛言。世尊。若多修慈能断嗔恚。修悲心者亦断嗔恚云何而言四无量心。推义而言则应有三。世尊。慈有三缘。一缘众生。二缘于法。三则无缘。悲喜舍心亦复如是。若从是义唯应有三。不应有四。众生缘者缘于五阴。愿与其乐。是名众生缘。法缘者。缘诸众生所须之物而施与之。是名法缘。无缘者缘于如来。是名无缘。慈者多缘贫穷众生。如来大师永离贫穷受第一乐。若缘众生则不缘佛。法亦如是。以是义故缘如来者。名曰无缘。世尊。慈之所缘一切众生。如缘父母妻子亲属。以是义故名众生缘。法缘者不见父母妻子亲属。见一切法皆从缘生。是名法缘。无缘者不住法相及众生相。是名无缘。悲喜舍心亦复如是。是故应三不应有四。世尊。人有二种。一者见行。二者爱行。见行之人多修慈悲。爱行之人多修喜舍。是故应二不应有四。世尊。夫无量者名曰无边。边不可得故名无量。若无量者则应是一不应言四。若言四者何得无量。是故应一不应四也。佛告迦叶。善男子。诸佛如来为诸众生所宣法要。其言秘密难可了知。或为众生说一因缘。如说何等为一因缘。所谓一切有为之法。善男子。或说二种因之与果。或说三种。烦恼业苦。或说四种。无明诸行生与老死。或说五种。所谓受爱取有及生。或说六种。三世因果。或说七种。谓识名色六入触受及以爱取。或说八种。除无明行及生老死。其余八事。或说九种。如城经中除无明行识。其余九事。或说十一。如为萨遮尼犍子说除生一法。其余十一。或时具说十二因缘。如王舍城为迦叶等具说十二。无明乃至生老病死。善男子。如一因缘为众生故种种分别。无量心法亦复如是。善男子。以是义故于诸如来深秘行处不应生疑。善男子。如来世尊有大方便。无常说常常说无常。说乐为苦说苦为乐不净说净净说不净。我说无我无我说我。于非众生说为众生。于实众生说非众生。非物说物物说非物。非实说实实说非实。非境说境境说非境。非生说生生说非生。乃至无明说明明说无明。色说非色非色说色。非道说道道说非道。善男子。如来以是无量方便为调众生。岂虚妄耶。善男子。或有众生贪于财货。我于其人自化其身作转轮王。于无量岁随其所须种种供给。然后教化令其安住阿耨多罗三藐三菩提。若有众生贪着五欲。于无量岁以妙五欲充足其情。然后劝化令其安住阿耨多罗三藐三菩提。若有众生荣豪自贵。我于其人无量岁中。为作仆使趋走给侍得其心已。即复劝化令其安住阿耨多罗三藐三菩提。若有众生性悷自是须人呵谏。我于无量百千岁中。教诃敦喻令其心调。然后复劝令其安住阿耨多罗三藐三菩提。善男子。如来如是于无量岁以种种方便。令诸众生安住阿耨多罗三藐三菩提。岂虚妄耶。诸佛如来虽处众恶。无所染污犹如莲花。善男子。应如是知四无量义。善男子。是无量心体性有四。若有修行生大梵处

善男子。如是无量伴侣有四。是故名四。夫修慈者能断贪欲。修悲心者能断嗔恚。修喜心者能断不乐。修舍心者能断贪欲嗔恚众生。善男子。以是义故得名为四非一二三。善男子。如汝所言。慈能断嗔悲亦如是应说三者。汝今不应作如是难。何以故。善男子。恚有二种。一能夺命。二能鞭挞。修慈则能断彼夺命。修悲能除彼鞭挞者。善男子。以是义故岂非四耶。复次嗔有二种。一嗔众生。二嗔非众生修慈心者断嗔众生。修悲心者断嗔非众生。复次嗔有二种。一有因缘。二无因缘。修慈心者断有因缘。修悲心者断无因缘。复次嗔有二种。一者久于过去修习。二者于今现在修习。修慈心者能断过去。修悲心者断于现在。复次嗔有二种。一嗔圣人。二嗔凡夫。修慈心者断嗔圣人。修悲心者断嗔凡夫。复次嗔有二种。一上二中修慈断上修悲断中。善男子。以是义故则名为四。何得难言应三非四。是故迦叶。是无量心伴侣相对分别为四。复以器故应名为四。器若有慈则不得有悲喜舍心。以是义故应四无减。善男子。以行分别故应有四。若行慈时无悲喜舍。是故有四。善男子。以无量故亦得名四。夫无量者则有四种。有无量心有缘非自在。有无量心自在非缘有无量心亦缘亦自在。有无量心非缘非自在。何等无量有缘非自在。缘于无量无边众生。而不能得自在三昧。虽得不定或得或失。何等无量自在非缘。如缘父母兄弟姊妹欲令安乐。非无量缘。何等无量亦缘亦自在。谓诸佛菩萨。何等无量非缘非自在。声闻缘觉不能广缘无量众生。亦非自在。善男子。以是义故名四无量。非诸声闻缘觉所知。乃是诸佛如来境界。善男子。如是四事声闻缘觉。虽名无量少不足言。诸佛菩萨则得名为无量无边。迦叶菩萨白佛言。世尊。如是如是实如圣教。诸佛如来所有境界。非诸声闻缘觉所及。世尊。颇有菩萨。住于大乘大般涅槃得慈悲心。非是大慈大悲心不。佛言。有善男子。菩萨若于诸众生中三品分别。一者亲人。二者怨憎。三者中人。于亲人中复作三品。谓上中下。怨憎亦尔。是菩萨摩诃萨于上亲中与增上乐。于中下亲亦复平等与增上乐。于上怨中与少分乐。于中怨所与中品乐。于下怨中与增上乐。菩萨如是转增修习。于上怨中与中品乐。于中下怨等与增上乐。转复修习于上中下等与上乐。若上怨中与上乐者。尔时得名慈心成就。菩萨尔时于父母所及上怨中。得平等心无有差别。善男子。是名得慈非大慈也。世尊。何缘菩萨得如是慈。犹故不得名为大慈。善男子。以难成故不名大慈。何以故。久于过去无量劫中。多集烦恼未修善法。是故不能于一日中调伏其心。善男子。譬如豌豆干时锥刺终不可着。烦恼坚硬亦复如是。虽一日夜系心不散难可调伏。又如家犬不畏于人。山林野鹿见人怖走。嗔恚难去如守家狗。慈心易失如彼野鹿。是故此心难可调伏。以是义故不名大慈。复次善男子。譬如画石其文常在画水速灭势不久住。嗔如画石。诸善根本如彼画水。是故此心难得调伏。如大火聚其明久住。电光之明不得暂停。嗔如火聚慈如电明。是故此心难得调伏。以是义故不名大慈。善男子。菩萨摩诃萨住于初地名曰大慈。何以故。善男子。最极恶者名一阐提。初住菩萨修大慈时。于一阐提心无差别。不见其过故不生嗔。以是义故得名大慈。善男子。为诸众生除无利益。是名大慈。欲与众生无量利乐。是名大悲。于诸众生心生欢喜。是名大喜。无所拥护名为大舍。若不见我法相己身。见一切法平等无二。是名大舍。自舍己乐施与他人。是名大舍。善男子。唯四无量能令菩萨增长具足六波罗蜜。其余诸行不必能尔。善男子。菩萨摩诃萨先得世间四无量心。然后乃发阿耨多罗三藐三菩提心。次第方得出世间者。善男子。因世无量。得出世无量。以是义故名大无量。迦叶菩萨白佛言。世尊。除无利益与利乐者。实无所为。如是思惟。即是虚观无有实利。世尊。譬如比丘观不净时。见所著衣悉是皮相而实非皮。所可食啖皆作虫相而实非虫。观大豆羹作下汁想而实非粪。观所食酪犹如髓脑而实非脑。观骨碎末犹如糗相而实非糗。四无量心亦复如是。不能真实利益众生令其得乐。虽口发言与众生乐而实不得。如是之观非虚妄耶。世尊。若非虚妄实与乐者。而诸众生何故不以诸佛菩萨威德力故一切受乐。若当真实不得乐者。如佛所说。我念往昔独修慈心。经此劫世七返成坏不来此生。世界成时生梵天中。世界坏时生光音天。若生梵天力势自在无能摧伏。于千梵中最胜最上。名大梵王。有诸众生皆于我所生最上想。三十六返作忉利王释提桓因。无量百千作转轮王。独修慈心乃得如是人天果报。若不实者云何得与此义相应。佛言。善哉善哉善男子。汝真勇猛无所畏惧。即为迦叶。而说偈言

  若于一众生　　不生嗔恚心
  而愿与彼乐　　是名为慈善
  一切众生中　　若起于悲心
  是名圣种性　　得福报无量
  设使五通仙　　悉满此大地
  有大自在主　　奉施其所安
  象马种种物　　所得福报果
  不及修一慈　　十六分中一

善男子。夫修慈者实非妄想谛是真实。若是声闻缘觉之慈。是名虚妄。诸佛菩萨真实不虚。云何知耶。善男子。菩萨摩诃萨修行如是大涅槃者。观土为金观金为土。地作水相水作地相水作火相火作水相。地作风相风作地相。随意成就无有虚妄。观实众生为非众生。观非众生为实众生。悉随意成无有虚妄。善男子。当知菩萨四无量心。是实思惟非不真实。复次善男子。云何名为真实思惟。谓能断除诸烦恼故。善男子。夫修慈者能断贪欲。修悲心者能断嗔恚。修喜心者能断不乐。修舍心者能断贪恚及众生相。以是故名真实思惟。复次善男子。菩萨摩诃萨四无量心。能为一切诸善根本。善男子。菩萨摩诃萨若不得见贫穷众生无缘生慈。若不生慈则不能起惠施之心。以施因缘令诸众生得安隐乐。所谓食饮车乘衣服。花香床卧舍宅灯明。如是施时心无系缚不生贪着。必定回向阿耨多罗三藐三菩提。其心尔时无所依止。妄想永断不为怖畏。名称利养不求人天。所受快乐不生憍慢。不望反报不为他诳。故行布施不求富贵。凡行施时不见受者持戒破戒是田非田此是知识此非知识。施时不见是器非器。不择日时是处非处。亦复不计饥馑丰乐。不见因果。此是众生此非众生是福非福。虽复不见施者受者及以财物乃至不见断及果报。而常行施无有断绝。善男子。菩萨若见持戒破戒乃至果报。终不能施。若不布施则不具足檀波罗蜜。若不具足檀波罗蜜。则不能成阿耨多罗三藐三菩提。善男子。譬如有人身被毒箭。其人眷属欲令安隐为除毒故。即命良医而为拔箭。彼人方言且待莫触。我今当观。如是毒箭。从何方来谁之所射。为是刹利婆罗门毗舍首陀。复更作念。是何木耶竹耶柳耶。其镞铁者何冶所出刚耶柔耶。其毛羽者是何鸟翼鸟鸱鹫耶。所有毒者为从作生自然而有。为是人毒为蛇毒耶。如是痴人竟未能知寻便命终。善男子。菩萨亦尔。若行施时分别受者持戒破戒乃至果报。终不能施。若不能施则不具足檀波罗蜜。若不具足檀波罗蜜。则不能成阿耨多罗三藐三菩提

善男子。菩萨摩诃萨行布施。时于诸众生慈心平等犹如子想。又行施时于诸众生起悲愍心。譬如父母瞻视病子。行施之时其心欢喜。犹如父母见子病愈。既施之后其心放舍。犹如父母见子长大能自存活。是菩萨摩诃萨于慈心中。布施食时常作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生得大智食勤进回向无上大乘。愿诸众生得善智食。不求声闻缘觉之食。愿诸众生得法喜食不求爱食。愿诸众生悉得般若波罗蜜食。皆令充满摄取无碍增上善根。愿诸众生悟解空相。得无碍身犹如虚空。愿诸众生常为受者。怜愍一切为众福田。善男子。菩萨摩诃萨修慈心时凡所施食。应当坚发如是等愿。复次善男子。菩萨摩诃萨于慈心中。布施浆时当作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生趣大乘河饮八味水。速涉无上菩提之道。离于声闻缘觉枯竭。渴仰志求无上佛乘。断烦恼渴渴仰法味。离生死爱爱乐大乘大般涅槃。具足法身得诸三昧。入于甚深智慧大海。愿诸众生得甘露味菩提出世离欲寂静如是诸味。愿诸众生具足无量百千法味。具法味已得见佛性。见佛性已能雨法雨。雨法雨已佛性遍覆犹如虚空。复令其余无量众生得一法味。所谓大乘。非诸声闻辟支佛味。愿诸众生得一甜味。无有六种差别之味。愿诸众生唯求法味无碍佛法所行之味。不求余味。善男子。菩萨摩诃萨于慈心中布施浆时。应当坚发如是等愿。复次善男子。菩萨摩诃萨于慈心中。施车乘时应作是愿。我今所施悉与一切众生共之。以是因缘。普令众生成于大乘。得住大乘不退于乘不动转乘金刚座乘。不求声闻辟支佛乘。向于佛乘无能伏乘无羸乏乘不退没乘无上乘十力乘大功德乘未曾有乘希有乘难得乘无边乘知一切乘。善男子。菩萨摩诃萨于慈心中施车乘时。常应如是坚发誓愿。复次善男子。菩萨摩诃萨于慈心中。布施衣时当作是愿。我今所施悉与一切众生共之。以是因缘令诸众生得惭愧衣法界覆身裂诸见衣。衣服离身一尺六寸得金色身。所受诸触柔软无碍。光色润泽皮肤细软。常光无量无色离色。愿诸众生皆悉普得无色之身过一切色。得入无色大般涅槃。善男子。菩萨摩诃萨布施衣时。应当如是坚发誓愿

复次善男子。菩萨摩诃萨于修慈中。布施花香涂香末香诸杂香时应作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生一切皆得佛花三昧。七觉妙鬘系其首顶。愿诸众生形如满月。所见诸色微妙第一。愿诸众生皆成一相百福庄严。愿诸众生随意得见可意之色。愿诸众生常遇善友。得无碍香离诸臭秽。愿诸众生具诸善根无上珍宝。愿诸众生相视和悦无有忧苦。众善各备不相忧念。愿诸众生戒香具足。愿诸众生持无碍戒。香气馚馥充满十方。愿诸众生得坚牢戒无悔之戒一切智戒。离诸破戒。悉得无戒未曾有戒无师戒无作戒无秽戒无污染戒竟已戒究竟戒。得平等戒。于香涂身及以斫刺等无憎爱。愿诸众生得无上戒大乘之戒。非小乘戒。愿诸众生悉得具足尸波罗蜜。犹如诸佛所成就戒。愿诸众生悉为布施持戒忍辱精进禅智之所薰修。愿诸众生悉得成于大般涅槃微妙莲花。其花香气充满十方。愿诸众生纯食大乘大般涅槃无上香馔。犹蜂采花但取香味。愿诸众生悉得成就无量功德所薰之身。善男子。菩萨摩诃萨于慈心中施花香时。常当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中。施床敷时应作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生得天中天所卧之床。得大智慧坐四禅处。卧于菩萨所卧之床。不卧声闻辟支佛床离卧恶床。愿诸众生得安乐卧离生死床。成大涅槃师子卧床。愿诸众生坐此床已。复为其余无量众生示现神通师子游戏。愿诸众生住此大乘大宫殿中。为诸众生演说佛性。愿诸众生坐无上床。不为世法之所降伏。愿诸众生得忍辱床。离于生死饥馑冻饿。愿诸众生得无畏床。永离一切烦恼怨贼。愿诸众生得清净床。专求无上正真之道。愿诸众生得善法床。常为善友之所拥护。愿诸众生得右胁卧床。依因诸佛所行之法。善男子。菩萨摩诃萨于慈心中施床敷时。应当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中。施舍宅时当作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生处大乘舍。修行善友所行之行。修大悲行六波罗蜜行大正觉行一切。菩萨所行道行无边广大如虚空行。愿诸众生皆得正念远离恶念。愿诸众生悉得安住常乐我净永离四倒。愿诸众生悉皆受持出世文字。愿诸众生必为无上一切智器。愿诸众生悉得入于甘露屋宅。愿诸众生初中后心。常入大乘涅槃屋宅。愿诸众生于未来世。常处菩萨所居宫殿。善男子。菩萨摩诃萨于慈心中施舍宅时。常当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中。施灯明时当作是愿。我今所施悉与一切众生共之。以是因缘。令诸众生光明无量安住佛法。愿诸众生常得照明。愿诸众生得色微妙光泽第一。愿诸众生其目清净无诸翳网。愿诸众生得大智炬。善解无我无众生相无人无命。愿诸众生皆得睹见清净佛性犹如虚空。愿诸众生肉眼清净。彻见十方恒沙世界。愿诸众生得佛光明普照十方。愿诸众生得无碍眼。皆悉得见清净佛性。愿诸众生得大智明。破一切闇及一阐提。愿诸众生得无量光。普照无量诸佛世界。愿诸众生然大乘灯离二乘灯。愿诸众生所得光明。灭无明闇过于千日并照之功。愿诸众生得大光明。悉灭三千大千世界所有黑闇。愿诸众生具足五眼。悟诸法相成无师觉。愿诸众生无见无明。愿诸众生悉得大乘大般涅槃微妙光明。示悟众生真实佛性。善男子。菩萨摩诃萨于慈心中施灯明时。常应勤发如是誓愿

善男子。一切声闻缘觉菩萨诸佛如来。所有善根慈为根本。善男子。菩萨摩诃萨修习慈心。能生如是无量善根。所谓不净出息入息无常生灭。四念处七方便三观处十二因缘无我等。观暖法顶法忍法世第一法。见道修道。正勤如意诸根诸力七菩提分八道。四禅四无量心。八解脱八胜处。十一切入。空无相愿。无诤三昧知他心智。及诸神通知本际智。声闻智缘觉智菩萨智佛智。善男子。如是等法慈为根本。善男子。以是义故。慈是真实非虚妄也。若有人问谁是一切诸善根本。当言慈是。以是义故慈是真实非虚妄也

善男子。能为善者名实思惟。实思惟者即名为慈。慈即如来。慈即大乘大乘即慈。慈即如来。善男子。慈即菩提道。菩提道即如来。如来即慈。善男子。慈即大梵。大梵即慈。慈即如来。善男子。慈者能为一切众生而作父母。父母即慈。慈即如来。善男子。慈者乃是不可思议诸佛境界。不可思议诸佛境界即是慈也。当知慈者即是如来。善男子。慈者即是众生佛性。如是佛性久为烦恼之所覆蔽。故令众生不得睹见。佛性即慈。慈即如来。善男子。慈即大空。大空即慈。慈即如来。善男子。慈即虚空。虚空即慈。慈即如来。善男子。慈即是常。常即是法。法即是僧。僧即是慈。慈即如来。善男子。慈即是乐。乐即是法。法即是僧。僧即是慈。慈即如来。善男子。慈即是净。净即是法。法即是僧。僧即是慈。慈即如来。善男子。慈即是我。我即是法。法即是僧。僧即是慈。慈即如来。善男子。慈即甘露。甘露即慈。慈即佛性。佛性即法。法即是僧。僧即是慈。慈即如来。善男子。慈者即是一切菩萨无上之道。道即是慈。慈即如来。善男子。慈者即是诸佛世尊无量境界。无量境界即是慈也。当知是慈即是如来

善男子。慈若无常无常即慈。当知是慈是声闻慈。善男子。慈若是苦苦即是慈。当知是慈是声闻慈。善男子。慈若不净不净即慈。当知是慈是声闻慈。善男子。慈若无我无我即慈。当知是慈是声闻慈。善男子。慈若妄想妄想即慈。当知是慈是声闻慈。善男子。慈若不名檀波罗蜜非檀之慈。当知是慈是声闻慈。乃至般若波罗蜜亦复如是。善男子。慈若不能利益众生。如是之慈是声闻慈。善男子。慈若不入一相之道。当知是慈是声闻慈。善男子。慈若不能觉了诸法。当知是慈是声闻慈。善男子。慈若不能见如来性。当知是慈是声闻慈。善男子。慈若见法悉是有相。当知是慈是声闻慈。善男子。慈若有漏有漏慈者是声闻慈。善男子。慈若有为有为之慈是声闻慈。善男子。慈若不能住于初住非初住慈。当知即是声闻慈也。善男子。慈若不能得佛十力四无所畏。当知是慈是声闻慈。善男子。慈若能得四沙门果。当知是慈是声闻慈也

善男子。慈若有无非有非无。如是之慈非诸声闻辟支佛等所能思议。善男子。慈若不可思议。法不可思议。佛性不可思议。如来亦不可思议

善男子。菩萨摩诃萨住于大乘大般涅槃修如是慈。虽复安于睡眠之中而不睡眠勤精进故。虽常觉悟亦无觉悟。以无眠故。于睡眠中诸天虽护亦无护者。不行恶故。眠不恶梦无有不善。离睡眠故。命终之后虽生梵天亦无所生。得自在故。善男子。夫修慈者能得成就如是无量无边功德。善男子。是大涅槃微妙经典。亦能成就如是无量无边功德。诸佛如来亦得成就如是无量无边功德

迦叶菩萨白佛言。世尊。菩萨摩诃萨所有思惟悉是真实声闻缘觉非真实者。一切众生。何故不以菩萨威力等受快乐。若诸众生实不得乐。当知菩萨所修慈心为无利益。佛言。善男子。菩萨之慈非不利益。善男子。有诸众生或必受苦或有不受。若有众生必受苦者。菩萨之慈为无利益。谓一阐提。若有受苦不必定者。菩萨之慈则为利益。令彼众生悉受快乐。善男子。譬如有人遥见师子虎豹豺狼罗刹鬼等自然生怖。夜行见杌亦生怖畏。善男子。如是诸人自然怖畏。众生如是见修慈者自然受乐。善男子。以是义故。菩萨修慈是实思惟非无利益

善男子。我说是慈有无量门。所谓神通。善男子。如提婆达教阿阇世欲害如来。是时我入王舍大城次第乞食。阿阇世王即放护财狂醉之象。欲令害我及诸弟子。其象尔时蹋杀无量百千众生。众生死已多有血气。是象嗅已狂醉倍常。见我翼从被服赤色谓呼是血。而复见趣我弟子中。未离欲者四怖驰走唯除阿难。尔时王舍大城之中一切人民。同时举声啼哭号泣。作如是言。怪哉如来今日灭没。如何正觉一旦散坏。是时调达心生欢喜。瞿昙沙门灭没甚善。从今已往真是不现。快哉此计我愿得遂。善男子。我于尔时为欲降伏护财象故。即入慈定舒手示之。即于五指出五师子。是象见已其心怖畏寻即失粪举身投地敬礼我足。善男子。我于尔时手五指头实无师子。乃是修慈善根力故令彼调伏。复次善男子。我欲涅槃始初发足向拘尸那城。有五百力士于其中路平治扫洒。中有一石众欲举弃尽力不能。我时怜愍即起慈心。彼诸力士寻即见我。以足母指举此大石。掷置虚空还以手接。安置右掌吹令碎末复还聚合。令彼力士贡高心息。即为略说种种法要。令其俱发阿耨多罗三藐三菩提心。善男子。如来尔时实不以指举此大石在虚空中还置右掌吹令碎末复合如本。善男子。当知即是慈善根力。令诸力士见如是事

复次善男子。此南天竺有一大城名首波罗。于是城中有一长者。名曰卢至为众导主。已于过去无量佛所殖诸善本。善男子。彼大城中一切人民。信伏邪道奉事尼犍。我时欲度彼长者故。从王舍城至彼城邑。其路中间相去六十五由旬。步涉而往。为欲化度彼诸人故。彼众尼犍闻我欲至首波罗城。即作是念。沙门瞿昙若至此者。此诸人民便当舍我更不供给。我等穷瘁奈何自活。诸尼犍辈各各分散告彼城人。沙门瞿昙今欲来此。然彼沙门委弃父母东西驰骋。所至之处能令土地谷米不登。人民饥馑死亡者众。病瘦相寻无可救解。瞿昙无赖纯将诸恶罗刹鬼神以为侍从。无父无母孤穷之人。而来咨启为作门徒。所可教诏纯说虚空。随其至处初无安乐。彼人闻已即怀怖畏。头面敬礼尼犍子足白言。大师。我等今者当设何计。尼犍答言。沙门瞿昙性好丛林流泉清水。外设有者宜应破坏。汝等便可相与出城。诸有之处斫伐令尽莫使有遗。流泉井池悉置粪尸。坚闭城门各严器仗。当壁防护勤自固守。彼设来者莫令得前。若不前者汝当安隐。我等亦当作种种术令彼瞿昙复道还去。彼诸人民闻是语已敬诺施行。斩伐树木污辱诸水。庄严器仗牢自防护。善男子。我于尔时至彼城已。不见一切树木丛林。唯见诸人庄严器仗当壁自守。见是事已寻生怜愍慈心向之。所有树木还生如本。复更生长其余诸树。不可称计河池泉井。其水清净盈满其中如青琉璃。生众杂花弥覆其上。变其城壁为绀琉璃。城内人民悉得彻见我及大众。门自开辟无能制者。所严器仗变成杂花。卢至长者而为上首。与其人民俱共相随往至佛所。我即为说种种法要。令彼诸人一切皆发阿耨多罗三藐三菩提心。善男子。我于尔时实不化作种种树木清净流水盈满河池变其本城为绀琉璃令彼人民彻见于我开其城门器仗为花。善男子。当知皆是慈善根力。能令彼人见如是事

复次善男子。舍卫城中有婆罗门女姓婆私吒。唯有一子爱之甚重遇病命终。尔时女人愁毒入心。狂乱失性裸身无耻。游行四衢啼哭失声。唱言。子子汝何处去。周遍城邑无有疲已。而是女人已于先佛殖众德本。善男子。我于是女起慈愍心。是时女人即得见我。便生子想还得本心。前抱我身如爱子法。我时即告侍者阿难。汝可持衣与是女人。既与衣已。便为种种说诸法要。是女闻法欢喜踊跃。发阿耨多罗三藐三菩提心。善男子。我于尔时实非彼子。彼非我母亦无抱持。善男子。当知皆是慈善根力。令彼女人见如是事

复次善男子。波罗奈城有优婆夷字曰摩诃斯那达多。已于过去无量先佛种诸善根。是优婆夷夏九十日。请命众僧奉施医药。是时众中有一比丘身婴重病。良医诊之当须肉药。若得肉者病则可除。若不得肉命将不全。时优婆夷闻医此言。寻持黄金遍至市里。唱如是言。谁有肉卖吾以金买。若有肉者当等与金。周遍城市求不能得。是优婆夷寻自取刀割其髀肉。切以为臛下种种香送病比丘。比丘服已病即得差。是优婆夷患疮苦恼不能堪忍。即发声言。南无佛陀南无佛陀。我于尔时在舍卫城闻其音声。于是女人起大慈心。是女寻见我持良药涂其疮上。还合如本。我即为其种种说法。闻法欢喜发阿耨多罗三藐三菩提心。善男子。我于尔时实不往至波罗奈城持药涂是优婆夷疮。善男子。当知皆是慈善根力。令彼女人见如是事

复次善男子。调达恶人贪不知足。多服酥故头痛腹满。受大苦恼不能堪忍。发如是言。南无佛陀南无佛陀。我时住在优禅尼城。闻其音声即生慈心。尔时调达寻便见我往至其所。手摩头腹授与盐汤而令服之。服已平复。善男子。我实不往调婆达所摩其头腹授汤令服。善男子。当知皆是慈善根力。令调婆达见如是事

复次善男子。憍萨罗国有诸群贼。其数五百群党抄劫为害滋甚。波斯匿王患其纵暴。遣兵伺捕。得已挑目。遂着黑闇丛林之下。是诸群贼已于先佛殖众德本。既失目已受大苦恼。各作是言。南无佛陀南无佛陀。我等今者无有救护啼哭号啕。我时住在祇洹精舍。闻其音声即生慈心。时有凉风吹香山中种种香药满其眼眶。寻还得眼如本不异。诸贼开眼即见如来。住立其前而为说法。贼闻法已发阿耨多罗三藐三菩提心。善男子。我于尔时实不作风吹香山中种种香药住其人前而为说法。善男子。当知皆是慈善根力。令彼群贼见如是事。复次善男子。琉璃太子以愚痴故。废其父王自立为主。复念宿嫌多害释种。取万二千释种诸女。刖劓耳鼻断截手足推之坑堑。时诸女人身受苦恼。作如是言。南无佛陀南无佛陀。我等今者无有救护。复大号啕。是诸女人已于先佛种诸善根。我于尔时在竹林中。闻其音声即起慈心。诸女尔时见我来至迦毗罗城以水洗疮以药傅之。苦痛寻除耳鼻手足还复如本。我时即为略说法要。悉令俱发阿耨多罗三藐三菩提心。即于大爱道比丘尼所。出家受具足戒。善男子。如来尔时实不往至迦毗罗城以水洗疮傅药止苦。善男子。当知皆是慈善根力。令彼女人得如是事。悲喜之心亦复如是。善男子。以是义故。菩萨摩诃萨修慈思惟。即是真实非虚妄也。善男子。夫无量者不可思议。菩萨所行不可思议。诸佛所行亦不可思议。是大乘典大涅槃经亦不可思议

大般涅槃经卷第十四大般涅槃经卷第十五

        宋代沙门慧严等依泥洹经加之

    梵行品之二

复次善男子。菩萨摩诃萨修慈悲喜已。得住极爱一子之地。善男子。云何是地。名曰极爱复名一子。善男子。譬如父母见子安隐心大欢喜。菩萨摩诃萨住是地中亦复如是。视诸众生同于一子。见修善者生大欢喜。是故此地名曰极爱。善男子。譬如父母见子遇患心生苦恼愍之愁毒初无舍离。菩萨摩诃萨住是地中亦复如是。见诸众生为烦恼病之所缠切。心生愁恼忧念如子。身诸毛孔血皆流出。是故此地名为一子。善男子。如人小时拾取土块粪秽瓦石枯骨木枝置于口中。父母见已恐为其患。左手捉头右手挑出。菩萨摩诃萨住是地中亦复如是。见诸众生法身未增。或行身口意业不善。菩萨见已则以智手拔之令出。不欲令彼流转生死受诸苦恼。是故此地复名一子。善男子。譬如父母所爱之子舍而终亡父母愁恼愿与并命。菩萨亦尔。见一阐提堕于地狱。亦愿与俱生地狱中。何以故。是一阐提若受苦时。或生一念改悔之心。我即当为说种种法令彼得生一念善根。是故此地复名一子。善男子。譬如父母唯有一子其子睡寤行住坐卧心常念之。若有罪咎善言诱谕不加其恶。菩萨摩诃萨亦复如是。见诸众生若堕地狱畜生饿鬼。或人天中造作善恶。心常念之初不放舍。若行诸恶终不生嗔以恶加之。是故此地复名一子

迦叶菩萨白佛言。世尊。如佛所说其言秘密。我今智浅云何能解。若诸菩萨住一子地能如是者。云何如来昔为国王行菩萨道时。断绝尔所婆罗门命。若得此地则应护念。若不得者复何因缘不堕地狱。若使等视一切众生同于子想如罗睺罗。何故复向提婆达多说如是言。痴人无羞食人涕唾。令彼闻已生于嗔恨起不善心出佛身血。提婆达多造是恶已。如来复记当堕地狱一劫受罪。世尊。如是之言云何于义不相违背。世尊。须菩提者住虚空地。凡欲入城求乞饮食要先观人。若有于己生嫌嫉心则止不行。乃至极饥犹不行乞。何以故。是须菩提常作是念。我忆往昔于福田所生一恶念。由是因缘堕大地狱受种种苦。我今宁饥终日不食。终不令彼于我起嫌堕于地狱受苦恼也。复作是念。若有众生嫌我立者。我当终日端坐不起。若有众生嫌我坐者。我当终日立不移处。行卧亦尔。是须菩提护众生故尚起是心。何况菩萨。菩萨若得一子地者。何缘如来出是粗言。使诸众生起重恶心。善男子。汝今不应作如是难言。佛如来为诸众生作烦恼因缘。善男子。假使蚊嘴能尽海底。如来终不为诸众生作烦恼因缘。善男子。假令大地悉为非色。水为干相。火为冷相。风为住相。三宝佛性及以虚空作无常相。如来终不为诸众生作烦恼因缘。善男子。假使毁犯四重禁罪及一阐提谤正法者。现身得成十力无畏三十二相八十种好。如来终不为诸众生作烦恼因缘。善男子。假使声闻辟支佛等常住不变。如来终不为诸众生作烦恼因缘。善男子。假使十住诸菩萨等犯四重禁。作一阐提诽谤正法。如来终不为诸众生作烦恼因缘。善男子。假使一切无量众生丧灭佛性。如来究竟入般涅槃。如来终不为诸众生作烦恼因缘。善男子。假使掷罥能系缚风。齿能破铁爪坏须弥。如来终不为诸众生作烦恼因缘。宁与毒蛇同共一处。内其两手饿师子口。佉陀罗炭用洗浴身。不应发言如来世尊为诸众生作烦恼因缘。善男子。如来真实能为众生断除烦恼。终不为作烦恼因也

善男子。如汝所言。如来往昔杀婆罗门者。善男子。菩萨摩诃萨乃至蚁子尚不故杀。况婆罗门。菩萨常作种种方便。惠施众生无量寿命。善男子。夫施食者则为施命。菩萨摩诃萨行檀波罗蜜时。常施众生无量寿命。善男子。修不杀戒得寿命长。菩萨摩诃萨行尸波罗蜜时。则为施与一切众生无量寿命。善男子。慎口无过得寿命长。菩萨摩诃萨行羼提波罗蜜时。常劝众生莫生怨想推直于人引曲向己。无所诤讼得寿命长。是故菩萨行羼提波罗蜜时。已施众生无量寿命。善男子。精勤修善得寿命长。菩萨摩诃萨行毗梨耶波罗蜜时。常劝众生勤修善法。众生行已得无量寿命。是故菩萨行毗梨耶波罗蜜时。已施众生无量寿命。善男子。修摄心者得寿命长。菩萨摩诃萨行禅波罗蜜时。劝诸众生修平等心。众生行已得寿命长。是故菩萨行禅波罗蜜时。已施众生无量寿命。善男子。于诸善法不放逸者得寿命长。菩萨摩诃萨行般若波罗蜜时。劝诸众生于诸善法不生放逸。众生行已以是因缘得寿命长。是故菩萨行般若波罗蜜时。已施众生无量寿命。善男子。以是义故。菩萨摩诃萨于诸众生终无夺命。善男子。汝向所问。杀婆罗门时得是地不。善男子。时我已得。以爱念故断其命根。非恶心也。善男子。譬如父母唯有一子爱之甚重犯官宪制。是时父母以怖畏故若摈若杀。虽有摈杀无有恶心。菩萨摩诃萨为护正法亦复如是。若有众生谤大乘者。即以鞭挞苦加治之。或夺其命。欲令改往遵修善法。菩萨常当作是思惟。以何因缘能令众生发起信心。随其方便要当为之。诸婆罗门命终之后。生阿鼻地狱则有三念。一者自念我从何处而来生此。即自知从人道中来。二者自念我今所生为是何处。即便自知是阿鼻狱。三者自念乘何业缘而来生此。即便自知乘谤方等大乘经典不信因缘为国主所杀而来生此。念是事已。即于大乘方等经典生信敬心。寻时命终生甘露鼓如来世界。于彼寿命具足十劫。善男子。以是义故我于往昔。乃与是人十劫寿命。云何名杀。善男子。有人掘地刈草斫树。斩截死尸骂詈鞭挞。以是业缘堕地狱不。迦叶菩萨白佛言。世尊。如我解佛所说义者。应堕地狱。何以故。如佛昔为声闻说法。汝诸比丘于诸草木莫生恶心。何以故。一切众生因恶心故堕于地狱。尔时佛赞迦叶菩萨。善哉善哉。如汝所说应善受持。善男子。若因恶心堕地狱者。菩萨尔时实无恶心。何以故。菩萨摩诃萨于一切众生乃至虫蚁。悉生怜愍利益心故。所以者何。善知因缘诸方便故。以方便力欲令众生种诸善根。善男子。以是义故。我于尔时以善方便虽夺其命而非恶心。善男子。婆罗门法若杀蚁子满足十车无有罪报。蚊虻蚤虱猫狸师子虎狼熊罴诸恶虫兽。及余能为众生害者。杀满十车。鬼神罗刹拘槃茶迦罗富单那。颠狂干枯诸鬼神等。能为众生作娆害者。有夺其命悉无罪报。若杀恶人则有罪报。杀已不悔则堕饿鬼。若能忏悔三日断食。其罪消灭无有遗余。若杀和上害其父母女人及牛。无数千年在地狱中。善男子。佛及菩萨知杀有三。谓下中上。下者蚁子乃至一切畜生。唯除菩萨示现生者。善男子。菩萨摩诃萨以愿因缘示受畜生。是名下杀。以下杀因缘堕于地狱畜生饿鬼具受下苦。何以故。是诸畜生有微善根。是故杀者具受罪报。是名下杀。中杀者从凡夫人至阿那含。是名为中。以是业因堕于地狱畜生饿鬼具受中苦。是名中杀。上杀者父母乃至阿罗汉辟支佛毕定菩萨。是名为上。以是业因缘故堕于阿鼻大地狱中具受上苦。是名上杀。善男子。若有能杀一阐提者。则不堕此三种杀中。善男子。彼诸婆罗门等一切皆是一阐提也。譬如掘地刈草斫树斩截死尸骂詈鞭挞无有罪报。杀一阐提亦复如是无有罪报。何以故。诸婆罗门乃至无有信等五法。是故虽杀不堕地狱

善男子。汝先所言。如来何故骂提婆达多痴人食唾。汝亦不应作如是问。何以故。诸佛世尊凡所发言不可思议。善男子。或有实语为世所爱。非时非法不为利益。如是之言我终不说。善男子。或复有言。粗犷虚妄非时非法闻者不爱。不能利益我亦不说。善男子。若有语言虽复粗犷真实不虚。是时是法能为一切众生利益。闻虽不悦我要说之。何以故。诸佛世尊应正遍知知方便故。善男子。如我一时游彼圹野聚落丛树在其林下。有一鬼神即名圹野。纯食肉血多杀众生。复于其聚日食一人。善男子。我于尔时为彼鬼神广说法要。然彼暴恶愚痴无智不受教法。我即化身为大力鬼。动其宫殿令不安所。彼鬼于时将其眷属。出其宫殿欲来拒逆。鬼见我时即失心念。惶怖躄地迷闷断绝犹如死人。我以慈愍手摩其身。即还起坐作如是言。快哉今日还得身命。是大神王具大威德。有慈愍心赦我愆咎。即于我所生善信心。我即还复如来之身。复更为说种种法要。令彼鬼神受不杀戒。即于是日圹野村中。有一长者次应当死。村人已送付彼鬼神。鬼神得已即以施我。我既受已。便为长者更立名字名手长者。尔时彼鬼即白我言。世尊。我及眷属唯仰血肉以自存活。今以戒故当云何活。我即答言。从今当敕声闻弟子。随有修行佛法之处。悉当令其施汝饮食。善男子。以是因缘为诸比丘制如是戒。汝等从今常当施彼圹野鬼食。若有住处不能施者。当知是辈非我弟子。即是天魔徒党眷属。善男子。如来为欲调伏众生故示如是种种方便。非故令彼生怖畏也。善男子。我亦以木打护法鬼。又于一时在一山上。推羊头鬼令堕山下。复于树头扑护猕猴鬼。令护财象见五师子。使金刚神怖萨遮尼犍。亦以针刺箭毛鬼身。虽作如是亦不令彼诸鬼神等有灭没者。直欲令彼安住正法故示如是种种方便。善男子。我于尔时实不骂辱提婆达多。提婆达多亦不愚痴食人涕唾。亦不生于恶趣之中阿鼻地狱受罪一劫。亦不坏僧出佛身血。亦不违犯四重之罪诽谤正法大乘经典。非一阐提。亦非声闻辟支佛也。善男子。提婆达多者实非声闻缘觉境界。唯是诸佛之所知见。善男子。是故汝今不应难言如来何缘呵啧骂辱提婆达多。汝于诸佛所有境界。不应如是生于疑网

迦叶菩萨白佛言。世尊。譬如甘蔗数数煎煮得种种味。我亦如是。从佛数闻多得法味。所谓出家味离欲味寂灭味道味。世尊。譬如真金数数烧打融消炼冶。转更明净调和柔软。光色微妙其价难量。然后乃为人天宝重。世尊。如来亦尔。郑重咨问则得闻见甚深之义。令深行者受持奉修。无量众生发阿耨多罗三藐三菩提心。然后为诸人天所宗恭敬供养

尔时佛赞迦叶菩萨。善哉善哉。菩萨摩诃萨为欲利益诸众生故。咨启如来如是深义。善男子。以是义故我随汝意。说于大乘方等甚深秘密之法。所谓极爱如一子地迦叶菩萨白佛言。世尊。若诸菩萨修慈悲喜得一子地者。修舍心时复得何地。佛言。善哉善哉。善男子。汝善知时知我欲说汝则咨问。菩萨摩诃萨修舍心时。则得住于空平等地如须菩提。善男子。菩萨摩诃萨住空平等地。则不见有父母兄弟姊妹儿息亲族知识怨憎中人。乃至不见阴界诸入众生寿命。善男子。譬如虚空无有父母兄弟妻子。乃至无有众生寿命。一切诸法亦复如是。无有父母乃至寿命。菩萨摩诃萨见一切法亦复如是。其心平等如彼虚空。何以故。善能修习诸空法故。迦叶菩萨白佛言。世尊。云何名空。善男子。空者所谓内空外空内外空有为空无为空无始空性空无所有空第一义空空空大空。菩萨摩诃萨云何观于内空。是菩萨摩诃萨观内法空。是内法空。谓无父母怨亲中人众生寿命常乐我净如来法僧所有财物。是内法中虽有佛性。而是佛性非内非外。所以者何。佛性常住无变易故。是名菩萨摩诃萨观于内空。外空者亦复如是。无有内法。内外空者亦复如是。善男子。唯有如来法僧佛性不在二空。何以故。如是四法常乐我净。是故四法不名为空。是名内外俱空。善男子。有为空者有为之法悉皆是空。所谓内空外空内外空。常乐我净空。众生寿命如来法僧第一义空。是中佛性非有为法。是故佛性非有为法空。是名有为空。善男子。云何菩萨摩诃萨观无为空。是无为法悉皆是空。所谓无无常苦不净无我阴界入众生寿命相有为有漏内法外法。无为法中佛等四法。非有为非无为。性是善故非无为。性常住故非有为。是名菩萨观无为空。云何菩萨摩诃萨观无始空。是菩萨摩诃萨见生死无始皆悉空寂。所谓空者常乐我净。皆悉空寂无有变易。众生寿命三宝佛性及无为法。是名菩萨观无始空。云何菩萨观于性空。是菩萨摩诃萨观一切法本性皆空。谓阴界入常无常苦乐净不净我无我。观如是等一切诸法不见本性。是名菩萨摩诃萨观于性空。云何菩萨摩诃萨观无所有空。如人无子言舍宅空。毕竟观空无有亲爱。愚痴之人言诸方空。贫穷之人言一切空。如是所计或空或非空。菩萨观时如贫穷人一切皆空。是名菩萨摩诃萨观无所有空。云何菩萨摩诃萨观第一义空。善男子。菩萨摩诃萨观第一义时。是眼生时无所从来。及其灭时去无所至。本无今有已有还无。推其实性无眼无主。如眼一切诸法亦复如是。何等名为第一义空。有业有报不见作者。如是空法名第一义空。是名菩萨摩诃萨观第一义空。云何菩萨摩诃萨观于空空。是空空中乃是声闻辟支佛等所迷没处。善男子。是有是无是名空空。是是非是是名空空。善男子。十住菩萨尚于是中通达少分犹如微尘。况复余人。善男子。如是空空亦不同于声闻所得空空三昧。是名菩萨观于空空。善男子。云何菩萨摩诃萨观于大空。善男子。言大空者谓般若波罗蜜。是名大空。善男子。菩萨摩诃萨得如是空门。则得住于虚空等地。善男子。我今于是大众之中。说如是等诸空义时。有十恒河沙等菩萨摩诃萨。即得住于虚空等地。善男子。菩萨摩诃萨住是地已。于一切法中无有滞碍系缚拘执心。无迷闷。以是义故名虚空等地。善男子。譬如虚空于可爱色不生贪着不爱色中不生嗔恚。菩萨摩诃萨住是地中亦复如是。于好恶色心无贪恚。善男子。譬如虚空广大无对悉能容受一切诸法。菩萨摩诃萨住是地中亦复如是。广大无对悉能容受一切诸法。以是义故。复得名为虚空等地

善男子。菩萨摩诃萨住是地中。于一切法亦见亦知。若行若缘若性若相若因若缘若众生心若根若禅定若乘若善知识若持禁戒若所施。如是等法一切知见。复次善男子。菩萨摩诃萨住是地中。知而不见。云何为知。知自饿法。投渊赴火自坠高岩常翘一脚五热炙身。常卧灰土棘刺编椽树叶恶草牛粪之上。衣粗麻衣冢间所弃粪扫氀褐钦婆罗衣獐鹿皮革刍草衣裳。茹菜啖食藕根油滓牛粪根果。若行乞食限从一家。主若言无即便舍去。设复还唤终不回顾。不食盐肉五种牛味。常所饮服糠汁沸汤。受持牛戒狗鸡雉戒。以灰涂身长发为相。以羊祠时先咒后杀。四月事火七日服风。百千亿花供养诸天。诸所欲愿因此成就。如是等法能为无上解脱因者。无有是处。是名为知。云何不见。菩萨摩诃萨不见一人行如是法得正解脱。是名不见。复次善男子。菩萨摩诃萨亦见亦知。何等为见。见诸众生行是邪法必堕地狱。是名为见。云何为知。知诸众生从地狱出生于人中。若能修行檀波罗蜜。乃至具足诸波罗蜜。是人必得入正解脱。是名为知。复次善男子。菩萨摩诃萨复有亦见亦知。云何为见。见常无常苦乐净不净。我无我。是名为见。云何为知知诸如来定不毕竟入于涅槃。知如来身金刚无坏非是烦恼所成就身。又非臭秽腐败之身。亦复能知一切众生悉有佛性。是名为知。复次善男子。菩萨摩诃萨复有亦知亦见。云何为知。知是众生信心成就。知是众生求于大乘是人顺流是人逆流是人正住。知是众生已到彼岸。顺流者谓凡夫人。逆流者从须陀洹乃至缘觉。正住者谓菩萨等。到彼岸者所谓如来应正遍知。是名为知。云何为见。菩萨摩诃萨住于大乘大涅槃典修梵行心。以净天眼。见诸众生造身口意三业不善堕于地狱畜生饿鬼。见诸众生修善业者命终当生天上人中。见诸众生从闇入闇。有诸众生从闇入明。有诸众生从明入闇。有诸众生从明入明。是名为见。复次善男子。菩萨摩诃萨复有亦知亦见。菩萨摩诃萨知诸众生修身修戒修心修慧。是人今世恶业成就。或因贪欲嗔恚愚痴。是业必应地狱受报。是人直以修身修戒修心修慧。现世轻受不堕地狱。云何是业能得现报。忏悔发露所有诸恶。既悔之后更不敢作。惭愧成就故。供养三宝故。常自呵责故。是人以是善业因缘。不堕地狱现世受报。所谓头痛目痛腹痛背痛横罗死殃。呵责骂辱鞭杖闭系饥饿困苦。受如是等现世轻报。是名为知。云何为见。菩萨摩诃萨见如是人不能修习身戒心慧。造少恶业。此业因缘应现受报。是人少恶不能忏悔不自呵责。不生惭愧无有怖惧。是业增长地狱受报。是名为见。复有知而不见。云何知而不见。知诸众生皆有佛性为诸烦恼之所覆蔽不能得见。是名知而不见。复有知而少见。十住菩萨摩诃萨等知诸众生皆有佛性见不明了。犹如闇夜所见不了。复有亦见亦知。所谓诸佛如来亦见亦知。复有亦见亦知不见不知。亦见亦知者。所谓世间。文字言语男女。车乘瓶盆舍宅城邑衣裳饮食。山河园林众生寿命。是名亦知亦见。云何不见不知。圣人所有微密之语。无有男女乃至园林。是名不见不知。复有知而不见。知所惠施知所供处。知于受者知因果报。是名为知。云何不见。不见所施供处受者及以果报。是名不见。菩萨摩诃萨知有八种。即是如来五眼所知

迦叶菩萨白佛言。世尊。菩萨摩诃萨能如是知得何等利。佛言。善男子。菩萨摩诃萨能如是知得四无碍。法无碍义无碍。辞无碍乐说无碍。法无碍者。知一切法及法名字。义无碍者。知一切法所有诸义。能随诸法所立名字而为作义。辞无碍者。随字论正音论阐陀论世辩论。乐说无碍者。所谓菩萨摩诃萨凡所演说无有障碍。不可动转无所畏省难可摧伏。善男子。是名菩萨能如是见知即得如是四无碍智。复次善男子。法无碍者。菩萨摩诃萨遍知声闻缘觉菩萨诸佛之法。义无碍者。乘虽有三知其归一。终不谓有差别之相。辞无碍者。菩萨摩诃萨于一法中作种种名。经无量劫说不可尽声闻缘觉能作是说。无有是处。乐说无碍者。菩萨摩诃萨于无量劫。为诸众生演说诸法。若名若义种种异说不可穷尽。复次善男子。法无碍者。菩萨摩诃萨虽知诸法而不取着。义无碍者。菩萨摩诃萨虽知诸义而亦不着辞。无碍者。菩萨摩诃萨虽知名字亦不取着。乐说无碍者。菩萨摩诃萨虽知乐说如是最上而亦不着。何以故。善男子。若取著者不名菩萨

迦叶菩萨复白佛言。世尊。若不取着则不知法。若知法者则是取着。若知不着则无所知。云何如来说言知法而不取着。佛言。善男子。夫取著者不名无碍。无所取着乃名无碍。善男子。是故一切诸菩萨等。有取著者则无无碍。若无无碍。不名菩萨。当知是人名为凡夫。何故取著名为凡夫。一切凡夫取着于色乃至着识。以着色故则生贪心。生贪心故为色系缚。乃至为识之所系缚。以系缚故则不得免生老病死忧悲大苦一切烦恼。是故取著名为凡夫。以是义故。一切凡夫无四无碍。善男子。菩萨摩诃萨已于无量阿僧祇劫知见法相。以知见故则知其义。以见法相及知义故。而于色中不生系着。乃至识中亦复如是。以不着故菩萨于色不生贪心。乃至识中亦不生贪。以无贪故则不为色之所系缚。乃至不为识之所缚。以不缚故则得脱于生老病死忧悲大苦一切烦恼。以是义故。一切菩萨得四无碍。善男子。以是因缘我为弟子。十二部中说系著者名为魔缚。若不著者则脱魔缚。譬如世间有罪之人为王所缚无罪之人王不能缚。菩萨摩诃萨亦复如是。有系著者为魔所缚。无系著者魔不能缚。以是义故。菩萨摩诃萨而无所著

复次善男子。法无碍者。菩萨摩诃萨善知字持而不忘失。所谓持者。如地如山如眼如云如人如母。一切诸法亦复如是。义无碍者。菩萨虽知诸法名字而不知义。得义无碍则知于义。云何知义。谓地持者。如地普持一切众生及非众生。以是义故名为地持。善男子。谓山持者。菩萨摩诃萨作是思惟。何故名山而为持耶。山能持地令无倾动。是故名持。何故复名眼为持耶。眼能持光故名为持。何故复名云为持耶。云名龙气。龙气持水故名云持。何故复名人为持耶。人能持法及以非法故名人持。何故复名母为持耶。母能持子故名母持。菩萨摩诃萨知一切法名字句义亦复如是。辞无碍者。菩萨摩诃萨以种种辞演说一义。亦无有义。犹如男女舍宅车乘众生等名。何故无义。善男子。夫义者乃是菩萨诸佛境界。辞者凡夫境界。以知义故得辞无碍。乐说无碍者。菩萨摩诃萨知辞知义。故于无量阿僧祇劫。说辞说义而不可尽。是名乐说无碍。善男子。菩萨摩诃萨于无量无边阿僧祇劫修行世谛。以修行故知法无碍。复于无量阿僧祇劫修第一义谛故。得义无碍。亦于无量阿僧祇劫习毗伽罗那论故。得辞无碍。亦于无量阿僧祇劫修习说世谛论故。得乐说无碍。善男子。声闻缘觉若有得是四无碍者。无有是处。善男子。九部经中我说声闻缘觉之人有四无碍。声闻缘觉真实无有。何以故。菩萨摩诃萨为度众生故修如是四无碍智。缘觉之人修寂灭法志乐独处。若化众生但现神通。终日默然无所宣说。云何当有四无碍智。何故默然而无所说。缘觉不能说法度人使得暖法顶法忍法世第一法须陀洹斯陀含阿那含阿罗汉辟支佛菩萨摩诃萨。不能令人发阿耨多罗三藐三菩提心。何以故。善男子。缘觉出世世间无有九部经典。是故缘觉无辞无碍乐说无碍。善男子。缘觉之人虽知诸法无法无碍。何以故。法无碍者名为知字。缘觉之人虽知文字无字无碍。何以故。不知常住二字法故。是故缘觉不得法无碍。虽知于义无义无碍。真知义者。知诸众生悉有佛性。佛性义者。名为阿耨多罗三藐三菩提。以是义故。缘觉之人不得义无碍。是故缘觉一切无有四无碍智。云何声闻无四无碍。声闻之人无有三种善巧方便。何等为三。一者必须软语然后受法。二者必须粗语然后受化。三者不软不粗然后受化。声闻之人无此三故。无四无碍。复次声闻缘觉不能毕竟知辞知义。无自在智知于境界。无有十力四无所畏。不能毕竟渡于十二因缘大河。不能善知众生诸根利钝差别未能永断二谛疑心。不知众生种种诸心所缘境界。不能善说第一义空。是故二乘无四无碍。迦叶菩萨白佛言。世尊。若诸声闻缘觉之人一切无有四无碍者。云何世尊。说舍利弗智慧第一大目犍连神通第一摩诃拘絺罗四无碍第一。如其无者如来何故作如是说。尔时世尊赞迦叶言。善哉善哉。善男子。譬如恒河有无量水。辛头大河水亦无量。博叉大河水亦无量。悉陀大河水亦无量。阿耨达池水亦无量。大海之中水亦无量如是诸水虽同无量。然其多少其实不等。声闻缘觉及诸菩萨四无碍智亦复如是。善男子。若说等者无有是处。善男子。我为凡夫说摩诃拘絺罗四无碍智为最第一。汝所问者其义如是。善男子。声闻之人或有得一或有得二。若具足四无有是处

迦叶菩萨白佛言。世尊。如佛先说梵行品中菩萨知见得四无碍者。菩萨知见则无所得。亦无有心言无所得。世尊。是菩萨摩诃萨实无所得。若使菩萨心有得者。则非菩萨名为凡夫。云何如来说言菩萨而有所得。佛言。善男子。善哉善哉。我将欲说而汝复问。善男子。菩萨摩诃萨实无所得。无所得者名四无碍。善男子。以何义故。无所得者名为无碍。若有得者则名为碍。有障碍者名四颠倒。善男子。菩萨摩诃萨无四倒故。故得无碍。是故菩萨名无所得。复次善男子。无所得者则名为慧。菩萨摩诃萨得是慧故名无所得。有所得者名为无明。菩萨永断无明闇故。故无所得。是故菩萨名无所得复次善男子。无所得者名大涅槃。菩萨摩诃萨安住如是大涅槃中。不见一切诸法性相。是故菩萨名无所得。有所得者名二十五有。菩萨永断二十五有得大涅槃。是故菩萨名无所得。复次善男子。无所得者名为大乘。菩萨摩诃萨不住诸法故得大乘。是故菩萨名无所得。有所得者名为声闻辟支佛道。菩萨永断二乘道故得于佛道。是故菩萨名无所得。复次善男子。无所得者名方等经。菩萨读诵如是经故得大涅槃。是故菩萨名无所得。有所得者名十一部经。菩萨所修纯说方等大乘经典。是故菩萨名无所得。复次善男子。无所有者名为虚空。世间无物名为虚空。菩萨得是虚空三昧无所见故。是故菩萨名无所得。有所得者名生死轮。一切凡夫轮回生死故有所见。菩萨永断一切生死。是故菩萨名无所得。复次善男子。菩萨摩诃萨无所得者名常乐我净。菩萨摩诃萨见佛性故得常乐我净。是故菩萨名无所得。有所得者名无常无乐无我无净。菩萨摩诃萨断是无常无乐无我无净。是故菩萨名无所得。复次善男子。无所得者名第一义空。菩萨摩诃萨观第一义空悉无所见。是故菩萨名无所得。有所得者名为五见。菩萨永断是五见故得第一义空。是故菩萨名无所得。复次善男子。无所得者名为阿耨多罗三藐三菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时悉无所见。是故菩萨名无所得。有所得者名为声闻缘觉菩提。菩萨永断二乘菩提。是故菩萨名无所得。善男子。汝之所问亦无所得。我之所说亦无所得。若说有得是魔眷属非我弟子。迦叶菩萨白佛言。世尊。为我说是菩萨无所得时。无量众生断有相心。以是事故我敢咨启无所得义。令如是等无量众生离魔眷属为佛弟子

迦叶菩萨白佛言。世尊。如来先于娑罗双树间。为纯陀说偈

  本有今无　　本无今有　　三世有法
  无有是处

世尊。是义云何。佛言。善男子。我为化度诸众生故而作是说。亦为声闻辟支佛故而作是说。亦为文殊师利法王子故而作是说。不但正为纯陀一人说是偈也。时文殊师利将欲问我。我知其心而为说之。我既说已。文殊师利即得解了。迦叶菩萨。言世尊如文殊等讵有几人能了是义。惟愿如来更为大众广分别说善男子。谛听谛听。今当为汝重敷演之。言本有者。我昔本有无量烦恼。以烦恼故现在无有大般涅槃。言本无者。本无般若波罗蜜。以无般若波罗蜜故。现在具有诸烦恼结。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有烦恼者。无有是处。复次善男子。言本有者。我本有父母和合之身。是故现在无有金刚微妙法身。言本无者。我身本无三十二相八十种好。以本无有三十二相八十种好故。现在具有四百四病。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有病苦者。无有是处。复次善男子。言本有者。我昔本有无常无我无乐无净。以有无常无我无乐无净故。现在无有阿耨多罗三藐三菩提。言本无者。本不见佛性。以不见故无常乐我净。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在无常乐我净者。无有是处。复次善男子。言本有者。本有凡夫修苦行心。谓得阿耨多罗三藐三菩提。以是事故现在不能破坏四魔。言本无者。我本无有六波罗蜜。以本无有六波罗蜜故。修行凡夫苦行之心谓得阿耨多罗三藐三菩提。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有苦行者。无有是处。复次善男子。言本有者。我昔本有杂食之身。以食身故现在无有无边之身。言本无者。本无三十七助道法。以无三十七助道法故。现在具有杂食之身。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有杂食身者。无有是处。复次善男子。言本有者。我昔本有一切法中取着之心。以是事故现在无有毕竟空定。言本无者。我本无有中道实义。以无中道真实义故。于一切法则有着心。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在说一切法是有相者。无有是处。复次善男子。言本有者。我初得阿耨多罗三藐三菩提时。有诸钝根声闻弟子。以有钝根声闻弟子故。不得演说一乘之实。言本无者。本无利根人中象王迦叶菩萨等。以无利根迦叶等故。随宜方便开示三乘。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在毕竟演说三乘法者。无有是处。复次善男子。言本有者。我本说言却后三月于娑罗双树当般涅槃。是故现在不得演说大方等典大般涅槃。言本无者。本昔无有文殊师利大菩萨等。以无有故现在说言如来无常。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在是无常者。无有是处善男子。如来普为诸众生故。虽知诸法说言不知。虽见诸法说言不见。有相之法说言无相。无相之法说言有相。实有无常说言有常。实有有常说言无常。我乐净等亦复如是。三乘之法说言一乘一乘之法随宜说三。略相说广广相说略。四重之法说偷兰遮。偷兰遮法说为四重。犯说非犯非犯说犯。轻罪说重重罪说轻。何以故。如来明见众生根故。善男子。如来虽作是说终无虚妄何以故。虚妄之语即是罪过。如来悉断一切罪过。云何当有虚妄语耶。善男子。如来虽无虚妄之言。若知众生因虚妄说得法利者。随宜方便则为说之。善男子一切世谛若于如来即是第一义谛。何以故。诸佛世尊为第一义故说于世谛。亦令众生得第一义谛。若使众生不得如是第一义者。诸佛终不宣说世谛。善男子。如来有时演说世谛。众生谓佛说第一义谛。有时演说第一义谛。众生谓佛说于世谛。是则诸佛甚深境界。非是声闻缘觉所知。善男子。是故汝先不应难言菩萨摩诃萨无所得也。菩萨常得第一义谛。云何难言无所得耶。迦叶复言。世尊。第一义谛亦名为道。亦名菩提。亦名涅槃。若有菩萨言有得道。菩提涅槃即是无常。何以故。法若常者则不可得。犹如虚空谁有得者。世尊。如世间物。本无今有名为无常。道亦如是。道若可得则名无常。法若常者无得无生。犹如佛性无得无生。世尊。夫道者非色非不色。不长不短。非高非下。非生非灭。非赤非白非青非黄。非有非无。云何如来说言可得。菩提涅槃亦复如是。佛言。如是如是。善男子。道有二种。一者常。二者无常。菩提之相亦有二种。一者常。二者无常。涅槃亦尔。外道道者名为无常。内道道者名之为常。声闻缘觉所有菩提。名为无常。菩萨诸佛所有菩提。名之为常。外解脱者名为无常。内解脱者名之为常。善男子。道与菩提及以涅槃悉名为常。一切众生常为无量烦恼所覆。无慧眼故不能得见。而诸众生为欲见故修戒定慧。以修行故见道菩提及以涅槃。是名菩萨得道菩提及涅槃也。道之性相实不生灭。以是义故不可捉持。善男子。道者虽无色像可见称量可知。而实有用。善男子。如众生心虽非是色非长非短非粗非细非缚非解非是见法而亦是有。以是义故。我为须达说言长者心为城主。长者若不护心则不护身口。若护心者则护身口。以不善护是身口故。令诸众生到三恶趣。护身口者则令众生得人天涅槃得名真实。其不得者名不真实。善男子。道与菩提及以涅槃亦复如是。亦有亦常。如其无者云何能断一切烦恼。以其有故一切菩萨了了见知。善男子。见有二种。一相貌见。二了了见。云何相貌见。如远见烟名为见火。实不见火。虽不见火亦非虚妄。见空中鹤便言见水。虽不见水亦非虚妄。如见花叶便言见根。虽不见根亦非虚妄。如人遥见篱间牛角。便言见牛。虽不见牛亦非虚妄。如见女人怀妊便言见欲。虽不见欲亦非虚妄。如见树生叶便言见水。虽不见水亦非虚妄。又如见云便言见雨。虽不见雨。亦非虚妄。如见身业及以口业便言见心。虽不见心亦非虚妄。是名相貌见。云何了了见。如眼见色。善男子。如人眼根清净不坏自观掌中阿摩勒果菩萨摩诃萨了了见道菩提涅槃亦复如是。虽如是见初无见相。善男子。以是因缘我于往昔告舍利弗。一切世间若有沙门若婆罗门若天若魔若梵若人。所不知不见不觉。惟有如来悉知见觉。及诸菩萨亦复如是。舍利弗若诸世间所知见觉。我与菩萨亦知见觉。世间众生之所不知不见不觉。亦不自知不知见觉。世间众生所知见觉。便自说言我知见觉。舍利弗。如来一切悉知见觉。亦不自言我知见觉。一切菩萨亦复如是。何以故。若使如来作知见觉相。当知是则非佛世尊。名为凡夫。菩萨亦尔

大般涅槃经卷第十五大般涅槃经卷第十六

        宋代沙门慧严等依泥洹经加之

    梵行品之三

迦叶菩萨言。如佛世尊为舍利弗说世间知者我亦得知。世间不知我亦悉知。其义云何。善男子。一切世间不知不见不觉佛性。若有知见觉佛性者。不名世间名为菩萨。世间之人亦复不知不见不觉十二部经十二因缘四倒四谛三十七品阿耨多罗三藐三菩提大般涅槃。若知见觉者不名世间当名菩萨。善男子。是名世间不知见觉。云何世间所知见觉。所谓梵天自在天八臂天。性时微尘法及非法是造化主。世界终始断常二见。说言初禅至非非想名为涅槃。善男子。是名世间所知见觉。菩萨摩诃萨于如是事亦知见觉。菩萨如是知见觉已。若言不知不见不觉。是为虚妄。虚妄之法则为是罪。以是罪故堕于地狱。善男子。若男若女若沙门若婆罗门。说言无道菩提涅槃。当知是辈名一阐提。魔之眷属名为谤法。如是谤法名谤诸佛。如是之人不名世间不名非世间。尔时迦叶闻是事已。即以偈颂而赞叹佛

  大慈愍众生　　故今我归依
  善拔众毒箭　　故称大医王
  世医所疗治　　虽差还复生
  如来所治者　　毕竟不复发
  世尊甘露药　　以施诸众生
  众生既服已　　不死亦不生
  如来今为我　　演说大涅槃
  众生闻秘藏　　即得不生灭

迦叶菩萨说是偈已。即白佛言。世尊。如佛所说。一切世间不知见觉。菩萨悉能知见觉者。若使菩萨是世间者。不得说言世间不知不见不觉。而是菩萨能知见觉。若非世间有何异相。佛言。善男子。言菩萨者亦是世间亦非世间。不知见觉者名为世间。知见觉者不名世间。汝言有何异者我今当说。善男子。若男若女若有初闻是涅槃经即生敬信。发阿耨多罗三藐三菩提心。是则名为世间菩萨。一切世间不知见觉。如是菩萨亦同世间不知见觉。菩萨闻是涅槃经已。知有世间不知见觉。应是菩萨所知见觉。知是事已即自思惟。我当云何方便修习得知见觉。覆自念言。唯当深心修持净戒。善男子。菩萨尔时以是因缘。于未来世在在生处戒常清净。善男子。菩萨摩诃萨以戒净故。在在生处常无憍慢邪见疑网。终不说言如来毕竟入于涅槃。是名菩萨修持净戒。戒既清净次修禅定。以修定故在在生处正念不忘。所谓一切众生悉有佛性。十二部经诸佛世尊常乐我净。一切菩萨安住方等大涅槃经悉见佛性。如是等事忆而不忘。因修定故得十一空。是名菩萨修清净定。戒定已备次修净慧。以修慧故初不计着身中有我我中有身是身是我非身非我。是名菩萨修习净慧。以修慧故所受持戒牢固不动。善男子。譬如须弥不为四风之所倾动。菩萨摩诃萨亦复如是。不为四倒之所倾动。善男子。菩萨尔时自知见觉。所受持戒无有倾动。是名菩萨所知见觉非世间也。善男子。菩萨见所持戒牢固不动心无悔恨。无悔恨故心得欢喜。得欢喜故心得悦乐。得悦乐故心则安隐。心安隐故得无动定。得无动定故得实知见。实知见故厌离生死。厌离生死故便得解脱。得解脱故明见佛性。是名菩萨所知见觉非世间也。善男子。是名世间不知见觉而是菩萨所知见觉

迦叶复言。云何菩萨修持净戒心无悔恨。乃至明了见于佛性。佛言。善男子。世间戒者不名清净。何以故。世间戒者为于有故。性不定故。非毕竟故。不能广为一切众生。以是义故名为不净。以不净故有悔恨心。以悔恨故心无欢喜。无欢喜故则无悦乐。无悦乐故则无安隐。无安隐故无不动定。无不动定故无实知见。无实知见故则无厌离。无厌离故则无解脱。无解脱故不见佛性。不见佛性故终不能得大般涅槃。是名世间戒不清净。善男子。菩萨摩诃萨清净戒者。戒非戒故。非为有故。定毕竟故。为众生故。是名菩萨戒清净也善男子。菩萨摩诃萨于净戒中。虽不欲生无悔恨心。无悔恨心自然而生。善男子。譬如有人执持明镜不期见面面像自现。亦如农夫种之良田不期生芽而芽自生。亦如然灯不期灭闇而闇自灭。善男子。菩萨摩诃萨坚持净戒。无悔恨心自然而生亦复如是。以净戒故心得欢喜。善男子。如端正人自见面貌心生欢喜。持净戒者亦复如是善男子。破戒之人见戒不净心不欢喜。如形残者自见面貌不生喜悦。破戒之人亦复如是。善男子。譬如牧牛有二女人。一持酪瓶。一持浆瓶。俱共至城而欲卖之。于路脚跌二瓶俱破。一则欢喜。一则愁恼。持戒破戒亦复如是。持净戒者心则欢喜。心欢喜故则便思惟。诸佛如来于涅槃中。说有能持清净戒者则得涅槃。我今修习如是净戒亦应得之。以是因缘心则悦乐。迦叶复言。喜之与乐有何差别。善男子。菩萨摩诃萨不作恶时名为欢喜。心净持戒名之为乐。善男子。菩萨摩诃萨观于生死。则名为喜。见大涅槃名之为乐。下名为喜上名为乐。离世共法名之为喜。得不共法名之为乐。以戒。净故身体轻柔口无粗过。菩萨尔时若见若闻若臭若尝若触若知悉无诸恶。以无恶故心得安隐。以安隐故。则得静定。得静定故得实知见。实知见故厌离生死。厌生死故则得解脱。得解脱故得见佛性。见佛性故得大涅槃。是名菩萨清净持戒非世间戒。何以故。善男子。菩萨摩诃萨所受净戒五法佐助。云何为五。一信。二惭。三愧。四善知识。五宗敬戒。离五盖故。所见清净离五见故。心无疑网离五疑故。一者疑佛。二者疑法。三者疑僧。四者疑戒。五者疑不放逸菩萨尔时即得五根。所谓信念精进定慧。得五根故得五种涅槃。谓色解脱乃至识解脱。是名菩萨清净持戒非世间也。善男子。是名世间之所不知不见不觉而是菩萨所知见觉

善男子。若我弟子受持读诵书写解说大涅槃经。有破戒者有人呵责轻贱毁辱而作是言。若佛秘藏大涅槃经有威力者。云何令汝毁所受戒。若人受持是涅槃经毁禁戒者。当知是经为无威力。若无威力虽复读诵为无利益。缘是轻毁涅槃经故。复令无量无边众生堕于地狱。受持是经而毁戒者。则是众生恶知识也。非我弟子是魔眷属。如是之人我亦不听受持是典。宁使不受不持不修。不以毁戒受持修习。善男子。若我弟子受持读诵书写演说涅槃经者。当正身心慎莫调戏轻躁举动。身为调戏心为轻动。求有之心名为轻动。身造诸业名为调戏。若我弟子求有造业不应受持是大乘典大涅槃经。若有如是受持经者。人当轻呵而作是言。若佛秘藏大涅槃经有威力者。云何令汝求有造业。若持经者求有造业。当知是经为无威力。若无威力虽复受持为无利益。缘是轻毁涅槃经故。复令无量无边众生堕于地狱。受持是经求有造业。则是众生恶知识也。非我弟子是魔眷属。复次善男子。若我弟子受持读诵书写演说大涅槃经。莫非时说。莫非国说。莫不请说。莫轻心说。莫处处说。莫自叹说。莫轻他说。莫灭佛法说。莫炽然世法说。善男子。若我弟子受持是经非时而说。乃至炽然世法说者。人当轻呵而作是言。若佛秘藏大涅槃经有威力者。云何令汝非时而说乃至炽然世法而说。若持经者作如是说。当知是经为无威力。若无威力虽复受持为无利益。缘是轻毁涅槃经故。令无量众生堕于地狱。受持是经非时而说。乃至炽然世法而说。则是众生恶知识也。非我弟子是魔眷属。善男子。若欲受持者。说大涅槃者。说佛性者。说如来秘藏者。说大乘者。说方等经者。说声闻乘者。说辟支佛乘者。说解脱者。见佛性者。先当清净其身。以身净故则无呵责。无呵责故令无量人于大涅槃生清净信。信心生故恭敬是经。若闻一偈一句一字。及说法者则得发于阿耨多罗三藐三菩提心。当知是人则是众生真善知识非恶知识。是我弟子非魔眷属。是名菩萨非世间也。善男子。是名世间之所不知不见不觉而是菩萨所知见觉

复次善男子。云何复名一切世间所不知见觉而是菩萨所知见觉。所谓六念处。何等为六。念佛念法念僧念戒念施念天。善男子。云何念佛如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊常不变易。具足十力四无所畏大师子吼。名大沙门大婆罗门。大净毕竟到于彼岸。无能胜者。无见顶者。无有怖畏不惊不动。独一无侣无师自悟。疾智大智利智深智解脱智不共智广普智毕竟智智宝成就。人中象王人中牛王人中龙王人中丈夫人中莲花分陀利花。调御人师为大施主大法之师。以知法故名大法师。以知义故名大法师。以知时故名大法师。以知足故名大法师。以知我故名大法师。知大众故名大法师。以知众生种种性故名大法师。以知诸根利钝中故名大法师。说中道故名大法师

云何名如来如过去诸佛所说不变。云何不变。过去诸佛为度众生说十二部经。如来亦尔故名如来。诸佛世尊从六波罗蜜三十七品十一空来至大涅槃。如来亦尔。是故号佛为如来也。诸佛世尊。为众生故。随宜方便开示三乘。寿命无量不可称计。如来亦尔。是故号佛为如来也

云何为应。世间之法悉名怨家。佛应害故故名为应。夫四魔者是菩萨怨。诸佛如来为菩萨时。能以智慧破坏四魔。是故名应。复次应者名为远离。为菩萨时应当远离无量烦恼。故名为应。复次应者名乐。过去诸佛为菩萨时。虽于无量阿僧祇劫为众生故受诸苦恼。终无不乐而常乐之。如来亦尔。是故名应。又复应者。一切人天应以种种香华璎珞幢幡伎乐而供养之。是故名应

云何正遍知。正者名不颠倒。遍知者于四颠倒无不通达。又复正者名为苦行。遍知者知因苦行定有苦果。又复正者名世间中。遍知者毕竟定知修习中道得阿耨多罗三藐三菩提。又复正者名为可数可量可称。遍知者不可数不可量不可称。是故号佛为正遍知善男子。声闻缘觉亦有遍知亦不遍知。何以故。遍知者名五阴十二入十八界。声闻缘觉亦得遍知。是名遍知。云何不遍知。善男子。假使二乘于无量劫观一色阴不能尽知。以是义故。声闻缘觉无有遍知

云何明行足明者名得无量善果。行名脚足。善果者名阿耨多罗三藐三菩提。脚足者名为戒慧。乘戒慧足得阿耨多罗三藐三菩提。是故名为明行足也。又复明者名咒。行者名吉。足者名果。善男子。是名世间义咒者名为解脱。吉者名为阿耨多罗三藐三菩提。果者名为大般涅槃。是故名为明行足也。又复明者名光。行者名业。足者名果。善男子。是名世间义。光者名不放逸。业者名六波罗蜜。果者名为阿耨多罗三藐三菩提。又复明者名为三明。一菩萨明。二诸佛明。三无明明。菩萨明者即是般若波罗蜜。诸佛明者。即是佛眼。无明明者即毕竟空。行者于无量劫为众生故修诸善业。足者明见佛性。以是义故名明行足。云何善逝。善者名高。逝名不高。善男子。是名世间义。高者名为阿耨多罗三藐三菩提。不高者即如来心也。善男子。心若高者不名如来。是故如来名为善逝。又复善者名为善知识。逝者善知识果。善男子。是名世间义。善知识者即初发心。果者名为大般涅槃。如来不舍最初发心得大涅槃。是故如来名为善逝。又复善者名好。逝者名有。善男子。是名世间义。好者名见佛性。有者名大涅槃。善男子。涅槃之性实非有也。诸佛世尊因世间故说言是有。善男子。譬如世人实无有子说言有子。实无有道说言有道。涅槃亦尔。因世间故说言为有。诸佛世尊成大涅槃故名善逝

善男子。云何世间解。善男子。世间者名为五阴。解者名知。诸佛世尊善知五阴故名世间解。又世间者名。为五欲。解名不着。不着五欲故名世间解。又世间解者。东方无量阿僧祇世界。一切声闻独觉不知不见不解。诸佛悉知悉见悉解。南西北方四维上下亦复如是。是故号佛为世间解。又世间者一切凡夫。解者知诸凡夫善恶因果。非是声闻缘觉所知。唯佛能知是。故号佛为世间解。又世间者名曰莲花。解名不污。善男子。是名世间义。莲花者即是如来。不污者。如来不为世间八法之所染污。是故号佛为世间解。又世间解者诸佛菩萨名世间解。何以故。诸佛菩萨见世间故。故名世间解。善男子。如因食得命名食为命。诸佛菩萨亦复如是。见世间故。故名世间解。云何无上士。上士者名之为断。无所断者名无上士。诸佛世尊无有烦恼故无所断。是故号佛为无上士。又上士者名为诤讼。无上士者无有诤讼。如来无诤。是故号佛为无上士。又上士者名语可坏。无上士者语不可坏。如来所言一切众生所不能坏。是故号佛为无上士。又上士者名为上座。无上士者名无上座。三世诸佛更无过者。是故号佛为无上士。上者名新。士者名故。诸佛世尊体大涅槃无新无故。是故号佛为无上士。云何调御丈夫。自既丈夫复调丈夫。善男子。言如来者实非丈夫非不丈夫。因调丈夫故名如来为丈夫也。善男子。一切男女若具四法则名丈夫。何等为四。一善知识。二能听法。三思惟义。四如说修行。善男子。若男若女具是四法则名丈夫。善男子。若有男子无此四法。则不得名为丈夫也。何以故。身虽丈夫行同畜生。如来调伏若男若女。是故号佛调御丈夫。复次善男子。如御马者凡有四种。一者触毛。二者触皮。三者触肉。四者触骨。随其所触称御者意。如来亦尔。以四种法调伏众生。一为说生令受佛语。如触其毛随御者意。二说生老便受佛语。如触毛皮随御者意。三者说生及以老病便受佛语。如触毛皮肉随御者意。四者说生及老病死便受佛语。如触毛皮肉骨随御者意。善男子。御者调马无有决定。如来世尊调伏众生必定不虚。是故号佛为调御丈夫。云何天人师。师有二种一者善教。二者恶教。诸佛菩萨常以善法教诸众生。何等善法。谓身口意善。诸佛菩萨教诸众生作如是言。善男子。汝当远离身不善业。何以故。以身恶业是可远离得解脱故。是故我以此法教汝。若是恶业不可远离得解脱者。终不教汝令远离也。若诸众生离恶业已堕三恶者。无有是处。以远离故成阿耨多罗三藐三菩提得大涅槃。是故诸佛菩萨常以此法教化众生。口意亦尔。是故号佛为无上师。复次昔未得道今已得之。以所得道为众生说。从本已来未修梵行今已修竟。以己所修为众生说。自破无明复为众生破坏无明。自得净目复为众生。破除盲冥令得净眼。自知二谛复为众生演说二谛。既自解脱复为众生说解脱法。自渡无边生死大河。复令众生皆悉得渡。自得无畏复教众生令无怖畏。自既涅槃复为众生演大涅槃。是故号佛为无上师。天者名昼。天上昼长夜短。是故名天。又复天者名无愁恼常受快乐。是故名天。又复天者名为灯明。能破黑闇而为大明。是故名天。亦以能破恶业黑闇。得诸善业而生天上。是故名天。又复天者名吉。以吉祥故得名为天。又复天者名日。日有光明故名日为天。以是义故名为天也。人者名日能多恩义。又复人者身口柔软。又复人者名有憍慢。又复人者能破憍慢。善男子。诸佛虽为一切众生无上大师。然经中说为天人师。何以故。善男子。诸众生中唯天与人。能发阿耨多罗三藐三菩提心。能修十善业道。能得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。得阿耨多罗三藐三菩提。是故号佛为天人师。云何为佛。佛者名觉。既自觉悟复能觉他。善男子。譬如有人觉知有贼贼无能为。菩萨摩诃萨能觉一切无量烦恼。既觉了已。令诸烦恼无所能为。是故名佛。以是觉故不生不老不病不死。是故名佛。婆伽婆者。婆伽名破。婆名烦恼。能破烦恼故名婆伽婆。又能成就诸善法故。又能善解诸法义故。有大功德无能胜故。有大名闻遍十方故。又能种种大慧施故。又于无量阿僧祇劫吐女根故。善男子。若男若女能如是念佛者。若行若住若坐若卧若昼若夜若明若闇。常得不离见佛世尊。善男子。何故名为如来应正遍知乃至婆伽婆而有如是无量功德大名称耶。善男子。菩萨摩诃萨于昔无量阿僧祇劫。恭敬父母和尚诸师上座长老。于无量劫常为众生而行布施。坚持禁戒修习忍辱。勤行精进禅定智慧。大慈大悲大喜大舍。是故今得三十二相八十种好金刚之身。又复菩萨于昔无量阿僧祇劫。修习信念进定慧根。于诸师长恭敬供养。常为法利不为食利。菩萨若持十二部经若读若诵。常为众生令得解脱安隐快乐。终不自为。何以故。菩萨常修出世间心及出家心无为之心无诤讼心无垢秽心无系缚心无取着心无覆盖心无无记心无生死心无疑网心无贪欲心无嗔恚心无愚痴心无憍慢心无秽浊心无烦恼心无苦心无量心广大心虚空心无心无无心调心不护心无覆藏心无世间心常定心常修心常解脱心无报心无愿心善愿心无误心柔软心不住心自在心无漏心第一义心不退心无常心正直心无谄曲心纯善心无多少心无坚心无凡夫心无声闻心无缘觉心善知心界知心生界知心住界知心自在界心。是故今得十力四无所畏大悲三念处常乐我净。是故得称如来乃至婆伽婆。是名菩萨摩诃萨念佛。云何菩萨摩诃萨念法。善男子。菩萨摩诃萨思惟诸佛所可说法最妙最上。因是法故能令众生得现在果。唯此正法无有时节。法眼所见非肉眼见。然不可以譬喻为比。不生不出不住不灭。不始不终无为无数。无舍宅者为作舍宅。无归作归。无明作明。未到彼岸令到彼岸。为无香处作无碍香。不可见见。不动不转不长不短。永断诸乐而安隐乐毕竟微妙。非色断色而亦是色。乃至非识断识而亦是识。非业断业非结断结。非物断物而亦是物。非界断界而亦是界。非有断有而亦是有。非入断入而亦是入。非因断因而亦是因。非果断果而亦是果。非虚非实。断一切实而亦是实。非生非灭。永断生灭而亦是灭。非相非非相。断一切相而亦是相。非教非不教而亦是师。非怖非安。断一切怖而亦是安。非忍非不忍。永断不忍而亦是忍。非止非不止。断一切止而亦是止。一切法顶。悉能永断一切烦恼。清净无相永脱诸相。无量众生毕竟住处。能灭一切生死炽火。乃是诸佛所游居处常。不变易。是名菩萨念法。云何念僧。诸佛圣僧如法而住。受正直法随顺修行。不可睹见不可捉持。不可破坏无能娆害。不可思议。一切众生良祐福田。虽为福田无所受取清净无秽。无漏无为广普无边。其心调柔平等无二。无有娆浊常不变易。是名念僧。云何念戒。菩萨思惟。有戒不破不漏不坏不杂。虽无形色而可护持。虽无触对善修方便。可得具足无有过咎。诸佛菩萨之所赞叹。是大方等大涅槃因。善男子。譬如大地船舫璎珞。大海灰汁舍宅刀剑桥梁良医妙药阿伽陀药如意宝珠脚足眼目父母阴凉。无能劫盗不可娆害。火不能焚水不能漂。大山梯蹬。诸佛菩萨妙宝胜幢。若住是戒得须陀洹果。我亦有分然我不须。何以故。若我得是须陀洹果不能广度一切众生。若住是戒则得阿耨多罗三藐三菩提。我亦有分是我所欲。何以故。若得阿耨多罗三藐三菩提。当为众生广说妙法而作救护。是名菩萨摩诃萨念戒。云何念施。菩萨摩诃萨深观此施。乃是阿耨多罗三藐三菩提因。诸佛菩萨亲近修习如是布施。我亦如是亲近修习。若不惠施不能庄严四部之众施虽不能毕竟断结而能除破现在烦恼。以施因缘故常为十方无量无边恒河沙等世界众生之所称叹。菩萨摩诃萨施众生食则施其命。以是果报成佛之时常不变易。以施乐故成佛之时则得安乐。菩萨施时如法求财不侵彼施是故成佛得清净涅槃。菩萨施时令诸众生不求而得。是故成佛得自在我。以施因缘令他得力。是故成佛获得十力。以施因缘令他得语是。故成佛得四无碍诸佛菩萨修集是施为涅槃因。我亦如是修习布施为涅槃因。广说如杂花中。云何念天。有四天王处乃至非想非非想处。若有信心得四天王处我亦有分。若戒多闻布施智慧得四天王处。乃至得非想非非想处我亦有分。然非我欲。何以故。四天王处乃至非想非非想处。皆是无常。以无常故生老病死。以是义故非我所欲。譬如幻化诳于愚夫。智慧之人所不惑着。如幻化者即是四天王处乃至非想非非想处。愚者即是一切凡夫。我则不同凡夫愚人。我曾闻有第一义天。谓诸佛菩萨常不变易。以常住故不生不老不病不死。我为众生精勤求于第一义天。何以故。第一义天能令众生除断烦恼。犹如意树。若我有信乃至有慧。则能得是第一义天。当为众生广分别说第一义天。是名菩萨摩诃萨念天。善男子。是名菩萨非世间也。是为世间不知见觉而是菩萨所知见觉。善男子。若我弟子谓受持读诵书写演说十二部经。及以受持读诵书写敷演解说大涅槃经等无差别者。是义不然。何以故。善男子。大涅槃者即是一切诸佛世尊甚深秘藏。以是诸佛甚深秘藏是则为胜。善男子。以是义故。大涅槃经甚奇甚特不可思议。迦叶菩萨白佛言。世尊。我亦知是大涅槃经甚奇甚特不可思议。佛法众僧不可思议。菩萨菩提大涅槃经亦不可思议。世尊。以何义故复言菩萨不可思议。善男子。菩萨摩诃萨无有教者。而能自发菩提之心。既发心已勤修精进。正使大火焚烧身首。终不求救舍念法心。何以故。菩萨摩诃萨常自思惟。我于无量阿僧祇劫。或在地狱饿鬼畜生人中天上。为诸结火之所烧然。初不曾得一决定法。决定法者即是阿耨多罗三藐三菩提。我为阿耨多罗三藐三菩提。终不护惜身心与命。我为阿耨多罗三藐三菩提。正使碎身犹如微尘。终不放舍勤精进也。何以故。勤进之心即是阿耨多罗三藐三菩提因。善男子。如是菩萨未见阿耨多罗三藐三菩提。乃能如是不惜身命。况复见已是故菩萨不可思议。又复不可思议。菩萨摩诃萨所见生死无量过患。非是声闻缘觉所及。虽知生死无量过恶。为众生故于中受苦不生厌离。是故复名不可思议。菩萨摩诃萨为众生故。虽在地狱受诸苦恼如三禅乐。是故复名不可思议。善男子。譬如长者其家失火。长者见已从舍而出。诸子在后未脱火难。长者尔时定知火害。为诸子故旋还赴救不顾其难。菩萨摩诃萨亦复如是。虽知生死多诸过恶。为众生故处之不厌。是故复名不可思议。善男子。无量众生发菩提心。见生死中多诸过恶。心即退没或为声闻或为缘觉。若有菩萨闻是经者。终不退失菩提之心而为声闻辟支佛也。如是菩萨虽复未阶初不动地。而心坚固无有退没。是故复名不可思议。善男子。若有人言我能浮渡大海之水。如是之言可思议不。世尊。如是之言或可思议。或不可思议。何以故。若人渡者则不可思议。阿修罗渡则可思议。善男子。我亦不说阿修罗也。正说人耳。世尊。人中亦有可思议者不可思议者。世尊。人亦二种。一者圣人。二者凡夫。凡夫之人则不可思议。贤圣之人则可思议。善男子。我说凡夫不说圣人。世尊。若凡夫人实不可思议。善男子。凡夫之人实不能渡大海水也。如是菩萨实能渡于生死大海。是故复名不可思议。善男子。若有人能以藕根丝悬须弥山。可思议不。不也世尊。善男子。菩萨摩诃萨于一念顷悉能称量一切生死。是故复名不可思议。善男子。菩萨摩诃萨已于无量阿僧祇劫。常观生死无常无我无乐无净。而为众生分别演说常乐我净。虽如是说然非邪见。是故复名不可思议。善男子。如人入水水不能溺。入大猛火火不能烧。如是之事不可思议。菩萨摩诃萨亦复如是。虽处生死不为生死之所恼害。是故复名不可思议。善男子。人有三品。谓上中下。下品之人初入胎时作是念言。我今处厕众秽归处。如死尸间众棘刺中大黑闇处。初出胎时复作是念。我今出厕出众秽处。乃至出于大黑闇处。中品之人作是念言。我今入于众树林中清净河中房室舍宅。出时亦尔。上品之人作是念言。我升殿堂在花林间。乘马乘象登陟高山。出时亦尔。菩萨摩诃萨初入胎时自知入胎住时知住出时知出。终不生于贪嗔之心。而未得阶初住地也。是故复名不可思议。善男子。阿耨多罗三藐三菩提。实不可以譬喻为比。善男子。心亦不可以方喻为比。而皆可说。菩萨摩诃萨无有师咨受学之处。而能得于阿耨多罗三藐三菩提。得是法已心无悭吝。常为众生而演说之。是故复名不可思议。善男子。菩萨摩诃萨有身远离非口。有口远离非身。有非身口而亦远离。身远离者谓离杀盗淫。是名身远离非口。口远离者谓离妄语两舌恶口无义语。是名口远离非身。非身非口是远离者所谓远离贪欲嗔恚邪见。善男子。是名非身非口而是远离。善男子。菩萨摩诃萨不见一法是身是业及与离主。而亦有离。是故复名不可思议。口亦如是。善男子从身离身。从口离口从慧远离非身非口善男子。实有此慧。然不能令菩萨远离。何以故。善男子。无有一法能坏能作。有为法性异生异灭。是故此慧不能远离。善男子。慧不能破。火不能烧水不能烂风不能动地不能持。生不能生老不能老住不能住坏不能坏。贪不能贪嗔不能嗔痴不能痴。以有为性异生异灭故。菩萨摩诃萨终不生念。我以此慧破诸烦恼。而自说言我破烦恼。虽作是说非是虚妄。是故复名不可思议。迦叶复言。世尊。我今始知菩萨摩诃萨不可思议。佛法众僧大涅槃经。及受持者菩提涅槃不可思议。世尊。无上佛法当久近住几时而灭。善男子。若大涅槃经乃至有是五行。所谓圣行梵行天行病行婴儿行。若我弟子有能受持读诵书写演说其义。为诸众生之所恭敬尊重赞叹种种供养。当知尔时佛法未灭。善男子。若大涅槃经具足流布。当尔之时我诸弟子。多犯禁戒造作众恶不能敬信如是经典。以不信故不能受持读诵书写解说其义。不为众人之所恭敬乃至供养。见受持者轻毁诽谤。汝是六师非佛弟子。当知佛法将灭不久。迦叶菩萨复白佛言。世尊。我亲从佛闻如是义。迦叶佛法住世七日然后灭尽。世尊。迦叶如来有是经不如其有者云何言灭。如其无者云何说言大涅槃经是诸如来秘密之藏。佛言。善男子。我先说言。唯有文殊乃解是义。今当重说。至心谛听。善男子。诸佛世尊有二种法。一者世法。二者第一义法。世法可灭。第一义法则不坏灭。复有二种。一者无常无我无乐无净。二者常乐我净。无常无我无乐无净则有坏灭。常乐我净则无坏灭。复有二种。一者二乘所持。二者菩萨所持。二乘所持则有坏灭。菩萨所持则无坏灭。复有二种。一者外。二者内。外法者则有坏灭。内法者则无坏灭。复有二种。一者有为。二者无为。有为之法则有坏灭。无为之法无有坏灭。复有二种。一者可得。二者不可得。可得之法则有坏灭。不可得者无有坏灭。复有二种。一者共法。二者不共共法坏灭。不共之法无有坏灭。复有二种。一者人中。二者天中。人中坏灭。天无坏灭。复有二种。一者十一部经。二者方等经。十一部经则有坏灭。方等经典无有坏灭。善男子。若我弟子受持读诵书写解说方等经典。恭敬供养尊重赞叹。当知尔时佛法不灭。善男子。汝向所问。迦叶如来有是经不者。善男子。大涅槃经悉是一切诸佛秘藏。何以故。诸佛虽有十一部经。不说佛性。不说如来常乐我净。诸佛世尊永不毕竟入于涅槃。是故此经名为如来秘密之藏。十一部经所不说故。故名为藏。如人七宝。不出外用名之为藏。善男子。是人所以藏积此物为未来事故。何等未来事。所谓谷贵贼来侵国。值遇恶王为用赎命。道路急难财难得时乃当出用。善男子。诸佛如来秘密之藏亦复如是。为未来世诸恶比丘。畜不净物。为四众说如来毕竟入于涅槃。读诵世典不敬佛经。如是等恶现于世时。如来为欲灭是诸恶令得远离邪命利养。如来则为演说是经。若是经典秘密之藏灭不现时。当知尔时佛法则灭。善男子。大涅槃经常不变易。云何难言迦叶佛时有是经不。善男子。迦叶佛时所有众生。贪欲微薄智慧滋多。诸菩萨摩诃萨等调柔易化。有大威德总持不忘。如大象王。世界清净。一切众生悉知如来终不毕竟入于涅槃常住不变。虽有是典不须演说。善男子。今世众生多诸烦恼。愚痴喜忘无有智慧。多诸疑网信根不立。世界不净。一切众生咸谓如来无常迁变毕竟入于大般涅槃。是故如来演说是典。善男子。迦叶佛法实亦不灭。何以故。常不变故。善男子。若有众生我见无我无我见我。常见无常无常见常。乐见无乐无乐见乐。净见不净不净见净。灭见不灭不灭见灭。罪见非罪非罪见罪。轻罪见重重罪见轻。乘见非乘非乘见乘。道见非道非道见道。实是菩提见非菩提。实非菩提谬见菩提。苦见非苦。集见非集。灭见非灭。实见非实。实是世谛见第一义谛。第一义谛见是世谛。归见非归非归见归。以真佛语名为魔语。实是魔语以为佛语。如是之时诸佛乃说大涅槃经。善男子宁说蚊嘴尽大海底。不可说言如来法灭宁说口吹须弥散坏。不可说言如来法灭。宁言以索系缚猛风。不可说言如来法灭。宁言佉陀罗火中生莲花不可说言如来法灭。宁说阿伽陀药而为毒药。不可说言如来法灭。宁说月可令热日可令冷。不可说言如来法灭。宁说四大各舍己性。不可说言如来法灭。善男子。若佛初出得阿耨多罗三藐三菩提已。未有弟子解甚深义彼佛世尊便涅槃者。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。佛虽涅槃。当知是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。无有笃信白衣檀越敬重佛法。佛便涅槃。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。多有笃信白衣檀越敬重佛法佛虽涅槃。当知佛法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。虽有笃信白衣檀越敬重佛法。而诸弟子演说经法。贪为利养不为涅槃。佛复灭度。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子凡所演说。不贪利养为求涅槃。佛虽灭度。当知是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。复有笃信白衣檀越敬重佛法。而诸弟子多起诤讼互相是非。佛复涅槃。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子修和敬法不相是非互相尊重佛虽涅槃。当知是法久住不灭。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子为大涅槃而演说法。互相恭敬不起诤讼。然畜一切不净之物。复自赞言。我得须陀洹果乃至阿罗汉果。佛复涅槃。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子为大涅槃演说经法。善修和敬互相尊重。不畜一切不净之物。亦不自言得须陀洹乃至得阿罗汉。彼佛世尊虽复灭度。当知是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子乃至不畜不净之物。又不自言得须陀洹至阿罗汉。各执所见种种异说而作是言。长老诸佛所制四重之法。乃至七灭诤法。为众生故或遮或开十二部经亦复如是。何以故。佛知国土时节各异众生不同利钝差别。是故如来或遮或开有轻重说。善男子。譬如良医为病服乳为病遮乳热病听服冷病则遮。如来亦尔。观诸众生烦恼病根亦开亦遮。长老我亲从佛闻如是义。唯我知义汝不能知。唯我解律汝不能解我知诸经汝不能知。彼佛复灭。当知是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子乃至不言我得须陀洹果至阿罗汉。亦不说言诸佛世尊为众生故或遮或开。长老。我亲从佛闻如是义如是法如是律。长老。当依如来十二部经。此义若是我当受持。如其非者我当弃舍。彼佛世尊虽复涅槃。当知是法久住于世。善男子。我法灭时有声闻弟子。或说有神。或说神空。或说有中阴。或说无中阴。或说有三世。或说无三世。或说有三乘。或说无三乘。或言一切有。或言一切无。或言众生有始有终。或言众生无始无终。或言十二因缘是有为法。或言因缘是无为法。或言如来有病苦行。或言如来无病苦行。或言如来不听比丘食十种肉。何等为十。人蛇象马驴狗师子猪狐猕猴。其余悉听。或言一切不听。或言比丘不作五事。何等为五。不卖生口刀酒酪沙胡麻油等。其余悉听。或言不听入五种舍。何等为五。屠儿淫女酒家王宫旃陀罗舍。余舍悉听。或言不听憍奢耶衣余一切听。或言如来听诸比丘受畜衣食卧具其价各直十万两金。或言不听。或言涅槃常乐我净。或言涅槃直是结尽更无别法名为涅槃。譬如织缕名之为衣。衣既坏已名之无衣。实无别法名无衣也。涅槃之体亦复如是。善男子。当尔之时我诸弟子。正说者少邪说者多。受正法少受邪法多。受佛语少受魔语多。善男子。尔时拘睒弥国有二弟子。一者罗汉。二者破戒。破戒徒众凡有五百。罗汉徒众其数一百。破戒者说如来毕竟入于涅槃。我亲从佛闻如是义。如来所制四重之法。若持亦可犯亦无罪。我今亦得阿罗汉果四无碍智。而阿罗汉亦犯如是四重之法。四重之法若是实罪。阿罗汉者终不应犯。如来在世制言坚持。临涅槃时皆悉放舍。时阿罗汉比丘言。长老。汝不应说如来毕竟入于涅槃。我知如来常不变易。如来在世及涅槃后。犯四重禁罪无差别。若言罗汉犯四重禁。是义不然。何以故。须陀洹人尚不犯禁。况阿罗汉。若长老言我是罗汉。阿罗汉者终不生想我得罗汉。阿罗汉者唯说善法不说不善。长老所说纯是非法。若有得见十二部经。定知长老非阿罗汉。善男子。尔时破戒比丘徒众即共断是阿罗汉命。善男子。是时魔王因是二众忿恚之心。悉共害是六百比丘。尔时凡夫各共说言。哀哉佛法于是灭尽。而我正法实不灭也。尔时其国有十二万诸大菩萨善持我法。云何当言我法灭耶。当于尔时阎浮提内无一比丘为我弟子。尔时波旬悉以大火焚烧一切所有经典。其中或有遗余在者。诸婆罗门即共偷取。处处采拾安置己典。以是义故。诸小菩萨佛未出时。率共信受婆罗门语。诸婆罗门虽作是说我有斋戒而诸外道真实无也。诸外道等虽复说言有我乐净。而实不解我乐净义。直以佛法一字二字一句二句。说言我典有如是义。尔时拘尸那城娑罗双树间。无量无边阿僧祇众闻是语已悉共唱言。世间虚空。世间虚空。迦叶菩萨告诸大众。汝等且莫忧愁啼哭。世间不空如来常住无有变易。法僧亦尔。尔时大众闻是语已啼哭即止。悉发阿耨多罗三藐三菩提心

大般涅槃经卷第十六大般涅槃经卷第十七

        宋代沙门慧严依泥洹经加之

    梵行品之第四

尔时王舍大城阿阇世王。其性弊恶喜行杀戮。具口四恶贪恚愚痴。其心炽盛。唯见现在不见未来。纯以恶人而为眷属。贪着现世五欲乐故。父王无辜横加逆害。因害父已心生悔热。身脱璎珞伎乐不御。心悔热故遍体生疮。其疮臭秽不可附近。寻自念言。我今此身已受花报。地狱果报将近不远。尔时其母字韦提希。以种种药而为涂之。其疮遂增无有降损。王即白母。如是疮者从心而生非四大起。若言众生有能治者。无有是处。时有大臣名曰月称。往至王所在一面立。白言。大王。何故愁悴颜容不悦。为身痛耶为心痛乎。王答臣言。我今身心岂得不痛。我父无辜横加逆害。我从智者曾闻是义。世有五人不脱地狱。谓五逆罪。我今已有无量无边阿僧祇罪云何身心而得不痛。又无良医治我身心。臣言。大王。莫大愁苦。即说偈言

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世有五人不脱地狱。谁往见之来语王耶。言地狱者。直是世间多智者说。如王所言。世无良医治身心者。今有大医名富兰那。一切知见得自在定。毕竟修习清净梵行。常为无量无边众生。演说无上涅槃之道。为诸弟子说如是法。无有黑业无黑业报。无有白业无白业报。无黑白业无黑白业报。无有上业及以下业。是师今在王舍城中。唯愿大王屈驾往彼可令是师疗治身心。时王答言。审能如是灭除我罪我当归依

复有一臣名曰藏德。复往王所而作是言。大王。何故面貌憔悴唇口干燋音声微细。犹如怯人见大怨敌。颜色懆变将何所苦。为身痛耶。为心痛乎。王即答言。我今身心云何不痛。我之痴盲无有慧目。近诸恶友而为亲善。随提婆达恶人之言。正法之王横加逆害。我昔曾闻智人说偈

  若于父母　　佛及弟子　　生不善心
  起于恶业　　如是果报　　在阿鼻狱

以是事故。今我心怖生大苦恼。又无良医而见救疗。大臣复言。唯愿大王。且莫愁怖。法有二种。一者出家。二者王法。王法者谓害其父则王国土。虽云是逆实无有罪。如迦罗罗虫要坏母腹然后乃生。生法如是。虽破母身实亦无罪。骡怀妊等亦复如是。治国之法法应如是。虽杀父兄实无有罪。出家法者乃至蚊蚁杀亦有罪。唯愿大王。宽意莫愁。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治身心者。今有大师名末伽梨拘舍离子。一切知见怜愍众生犹如赤子。已离烦恼能拔众生三毒利箭。一切众生于一切法无知见觉。唯是一人独知见觉。如是大师常为弟子说如是法。一切众生身有七分。何等为七。地水火风苦乐寿命。如是七法非化非作。不可毁害如伊师迦草。安住不动如须弥山。不舍不作犹如乳酪。各不诤讼若苦若乐若善不善。投之利刀无所伤害。何以故。七分空中无妨碍故命亦无害。何以故。无有害者及死者故。无作无受无说无听。无有念者及以教者。常说是法能令众生灭除一切无量重罪。是师今在王舍大城。唯愿大王。往至其所。王若见者。众罪消灭时王答言。审能如是除灭我罪我当归依

复有一臣名曰实得。复到王所即说偈言

  大王何故　　身脱璎珞　　首发蓬乱
  乃至如是　　王身何故　　战栗不安
  犹如猛风　　吹动花树

王今何故容色愁悴。犹如农夫下种之后天不降雨。愁苦如是。为是心痛为身痛耶。王即答言。我今身心岂得不痛。我父先王慈爱流恻。特见矜念实无辜咎。往问相师。相师答言。是儿生已定当害父。虽闻是语犹见瞻养。曾闻智者作如是言。若人通母及比丘尼。偷僧祇物。杀发无上菩提心者。及害其父。如是之人毕定当堕阿鼻地狱。我今身心岂得不痛。大臣复言。唯愿大王。且莫愁苦。如其父王修解脱者害则有罪。若治国法杀则无罪。大王。非法者名为无法无。无法者名为无法。譬如无子名为无子。亦如恶子名之无子。虽言无子实非无子。如食无盐名为无盐。食若少盐亦名无盐。如河无水名为无水。若有少水亦名无水。如念念灭亦言无常。虽住一劫亦名无常。如人受苦名为无乐。虽受少乐亦名无乐。如不自在名之无我。虽少自在亦名无我。如闇夜时。名之无日。云雾之时亦言无日。大王虽言少法名为无法实非无法。愿王留神听臣所说。一切众生皆有余业。以业缘故数受生死。若使先王有余业者。今王杀之竟有何罪。唯愿大王。宽意莫愁。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治身心者。今有大师名删阇耶毗罗胝子。一切知见其智渊深犹如大海。有大威德具大神通。能令众生离诸疑网。一切众生不知见觉。唯是一人独知见觉。今者近在王舍城住。为诸弟子说如是法。一切众中若是王者。自在随意造作善恶。虽为众恶悉无有罪。如火烧物无净不净。王亦如是与火同性。譬如大地净秽普载。虽为是事初无嗔喜。王亦如是与地同性。譬如水性净秽俱洗。虽为是事亦无忧喜。王亦如是与水同性。譬如风性净秽等吹。虽为是事亦无忧喜。王亦如是与风同性。如秋髡树春则还生。虽复髡斫实无有罪。一切众生亦复如是。此间命终还此间生。以还生故当有何罪。一切众生苦乐果报。悉皆不由现在世业。因在过去现在受果。现在无因未来无果。以现果故众生持戒。勤修精进遮现恶果。以持戒故则得无漏。得无漏故尽有漏业。以尽业故众苦得尽。众苦尽故故得解脱。唯愿大王。速往其所。令其疗治身心苦痛。王若见者众罪则除。王即答言。审有是师能除我罪我当归依

复有一臣名悉知义。即至王所作如是言。王今何故形不端严如失国者。如泉枯涸池无莲花树无花叶破戒比丘身无威德。为身痛耶为心痛乎。王即答言。我今身心岂得无痛。我父先王慈恻流念。然我不孝不知报恩。常以安乐安乐于我。而我背恩反断其乐。先王无辜横兴逆害。我亦曾闻智者说言。若有害父当于无量阿僧祇劫受大苦恼。我今不久必堕地狱。又无良医救疗我罪。大臣即言。唯愿大王。放舍愁苦。王不闻耶。昔者有王名曰罗摩。害其父已得绍王位。跋提大王毗楼真王。那睺沙王。迦帝迦王。毗舍佉王月光明王。日光明王爱王。持多人王。如是等王皆害其父得绍王位。然无一王入地狱者。于今现在毗琉璃王。优陀那王。恶性王。鼠王。莲花王。如是等王皆害其父。悉无一王生愁恼者。虽言地狱饿鬼天中。谁有见者。大王。唯有二有。一者人道。二者畜生。虽有是二。非因缘生。非因缘死。若非因缘何有善恶。唯愿大王勿怀愁怖。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治身心者。今有大师名阿耆多翅舍钦婆罗。一切知见观金与土平等无二。刀斫右胁左涂栴檀。于此二人心无差别。等视怨亲心无异相。此师真是世之良医。若行若立若坐若卧。常在三昧心无分散。告诸弟子作如是言。若自作若教他作。若自斫若教他斫。若自炙若教他炙。若自害若教他害。若自偷若教他偷。若自淫若教他淫。若自妄语若教他妄语。若自饮酒若教他饮酒。若杀一村一城一国。若以刀轮杀一切众生。若恒河已南布施众生。恒河已北杀害众生。悉无罪福。无施戒定。今者近在王舍城住。愿王速往。王若见者众罪除灭。王言。大臣。审能如是除灭我罪我当归依

复有大臣名曰吉德。复往王所作如是言。王今何故面无光泽。如日中灯。如昼时月。如失国君。如荒败土。大王。今者四方清夷无诸怨敌。而今何故如是愁苦。为身苦耶为心苦乎。有诸王子常生此念。我今何时当得自在。大王。今者已果所愿。自在王领摩伽陀国。先王宝藏具足而得。唯当快意纵情受乐。如是愁苦何用经怀。王即答言。我今云何得不愁恼。大臣。譬如愚人但贪其味不见利刀。如食杂毒不见其过。我亦如是。如鹿见草不见深阱。如鼠贪食不见猫狸。我亦如是。见现在乐不见未来不善苦果。曾从智者闻如是言。宁于一日受三百[矛*(替-曰+貝)]不于父母生一念恶。我今已近地狱炽火。云何当得不愁恼耶。大臣复言。谁来诳王言有地狱。如刺头利谁之所造。飞鸟色异。复谁所作。水性润渍石性坚硬。如风动性如火热性。一切万物自死自生谁之所作。言地狱者直是智者文辞造作。言地狱者为有何义。臣当说之地者名地。狱者名破。破于地狱无有罪报。是名地狱。又复地者名人。狱者名天。以害其父故到人天。以是义故婆薮仙人唱言。杀羊得人天乐。是名地狱。又复地者名命。狱者名长。以杀生故得寿命长。故名地狱。大王。是故当知实无地狱。大王。如种麦得麦种稻得稻。杀地狱者还得地狱。杀害于人应还得人。大王。今当听臣所说实无杀害。若有我者实亦无害。若无我者复无所害。何以故。若有我者常不变易。以常住故不可杀害。不破不怀不系不缚不嗔不喜。犹如虚空。云何当有杀害之罪。若无我者诸法无常。以无常故念念坏灭。念念灭故杀者死者皆念念灭。若念念灭谁当有罪。大王。如火烧木火则无罪。如斧斫树斧亦无罪。如镰刈草镰实无罪。如刀杀人刀实非人。刀既无罪人云何罪。如毒杀人毒实非人。毒药无罪人云何罪。一切万物皆亦如是。实无杀害云何有罪。唯愿大王莫生愁苦。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治恶业者。今有大师名迦罗鸠驮迦旃延。一切知见明了三世。于一念顷能见无量无边世界。闻声亦尔。能令众生远离过恶。犹如恒河。若内若外所有诸罪皆悉清净。是大良师亦复如是。能除众生内外众罪。为诸弟子说如是法。若人杀害一切众生。心无惭愧终不堕恶。犹如虚空不受尘水。有惭愧者即入地狱。犹如大水润湿于地。一切众生悉是自在天之所作。自在天喜众生安乐。自在天嗔众生苦恼。一切众生若罪若福。乃是自在天之所为。云何当言人有罪福。譬如工匠作机关木人行住坐卧唯不能言。众生亦尔。自在天者喻如工匠。木人者喻众生身。如是造化谁当有罪。如是大师今者近在王舍城住。唯愿速往如其见者众罪消灭。王即答言。审有是人能灭我罪我当归依复有一臣名无所畏。往至王所说如是言。大王世有愚人一日之中百喜百愁百眠百寤百惊百哭。有智之人斯无是事。大王何故忧愁如是。如失侣客。如堕深泥无救拔者。如人渴乏不得浆水。犹如迷人无有导者。如困病人无医救疗。如海船破无救接者。大王。今者为身痛耶为心痛乎。王即答言。我今身心岂得不痛。我近恶友不观口过。先王无辜横兴逆害。我今定知当入地狱。复无良医而见救济。臣即白言。唯愿大王。莫生愁毒。夫刹利者名为王种。若为国土若为沙门及婆罗门。为安人民。虽复杀害无有罪也。先王虽复恭敬沙门。不能承事诸婆罗门心无平等。无平等故则非刹利。大王。今者为欲供养诸婆罗门。杀害先王当有何罪。大王。实无杀害。夫杀害者杀害寿命。命名风气。风气之性不可杀害。云何害命而当有罪。唯愿大王。莫复愁苦。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医而疗治者。今有大师名尼乾陀若提子。一切知见怜愍众生。善知众生诸根利钝达解一切随宜方便。世间八法所不能污。寂静修习清净梵行。为诸弟子说如是言。无施无善无父无母。无今世后世。无阿罗汉无修无道。一切众生经八万劫。于生死轮自然得脱。有罪无罪悉亦如是。如四大河。所谓辛头恒河博叉私陀。悉入大海无有差别。一切众生亦复如是。得解脱时悉无差别。是师今在王舍城住。唯愿大王。速往其所。若得见者众罪消除。王即答言。审有是师能除我罪我当归依

尔时大医名曰耆婆。往至王所。白言大王。得安眠不。王以偈答言

  若有能永断　　一切诸烦恼
  不贪染三界　　乃得安隐眠
  若得大涅槃　　演说甚深义
  名真婆罗门　　乃得安隐眠
  身无诸恶业　　口离于四过
  心无有疑网　　乃得安隐眠
  身心无热恼　　安住寂静处
  获致无上乐　　乃得安隐眠
  心无有取着　　远离诸怨仇
  常和无诤讼　　乃得安隐眠
  若不造恶业　　心常怀惭愧
  信恶有果报　　乃得安隐眠
  敬养于父母　　不害一生命
  不盗他财物　　乃得安隐眠
  调伏于诸根　　亲近善知识
  破坏四魔众　　乃得安隐眠
  不见吉不吉　　及以苦乐等
  为诸众生故　　轮转于生死
  若能于是者　　乃得安隐眠
  谁得安隐眠　　所谓诸佛是
  深观空三昧　　身心安不动
  谁得安隐眠　　所谓慈悲者
  常修不放逸　　视众如一子
  众生无明冥　　不见烦恼果
  常造诸恶业　　不得安隐眠
  若为于自身　　及以他人身
  造作十恶业　　不得安隐眠
  若言为乐故　　害父无过咎
  随是恶知识　　不得安隐眠
  若食过节度　　冷饮而过差
  如是则病苦　　不得安隐眠
  若于王有过　　邪念他妇女
  及行圹路者　　不得安隐眠
  持戒果未熟　　太子未绍位
  盗者未获财　　不得安隐眠

耆婆。我今病重。于正法王兴恶逆害。一切良医妙药咒术善巧瞻病所不能治。何以故我父法王如法治国。实无辜咎横加逆害如鱼处陆当有何乐。如鹿在弶初无欢心。如人自知命不终日。如王失国逃迸他土。如人闻病不可疗治。如破戒者闻说罪过。我昔曾闻智者说言身口意业若不清净。当知是人必堕地狱。我亦如是。云何当得安隐眠耶。今我又无无上大医演说法药除我病苦。耆婆答言。善哉善哉。王虽作罪心生重悔而怀惭愧。大王。诸佛世尊常说是言。有二白法能救众生。一惭二愧。惭者自不作罪。愧者不教他作。惭者内自羞耻。愧者发露向人。惭者羞人。愧者羞天。是名惭愧。无惭愧者不名为人。名为畜生。有惭愧故则能恭敬父母师长。有惭愧故说有父母兄弟姊妹。善哉大王。具有惭愧。大王且听。臣闻佛说。智者有二。一者不造诸恶。二者作已忏悔。愚者亦二。一者作罪。二者覆藏。虽先作恶后能发露。悔已惭愧更不敢作。犹如浊水置之明珠以珠威力水即为清。如烟云除月则清明。作恶能悔亦复如是。王若忏悔怀惭愧者。罪即除灭清净如本。大王。富有二种。一者象马种种畜生。二者金银种种珍宝。象马虽多不敌一珠。大王。众生亦尔。一者恶富。二者善富。多作诸恶不如一善。臣闻佛说。修一善心破百种恶。大王。如少金刚能坏须弥。亦如少火能烧一切。如少毒药能害众生。少善亦尔能破大恶。虽名少善其实是大。何以故。破大恶故。大王。如佛所说。覆藏者漏。不覆藏者则无有漏。发露悔过是故不漏。若作众罪不覆不藏。以不覆故罪则微薄。若怀惭愧罪则消灭。大王。如水渧虽微渐盈大器。善心亦尔。一一善心能破大恶。若覆罪者罪则增长。发露惭愧罪则消灭。是故诸佛说有智者不覆藏罪。善哉大王。能信因果信业信报。唯愿大王。莫怀愁怖。若有众生造作诸罪覆藏不悔。心无惭愧。不见因果及以业报。不能咨启有智之人。不近善友。如是之人一切良医乃至瞻病所不能治。如迦摩罗病世医拱手。覆罪之人亦复如是。云何罪人。谓一阐提。一阐提者不信因果。无有惭愧不信业报。不见现在及未来世。不亲善友。不随诸佛所说教诫。如是之人名一阐提。诸佛世尊所不能治。何以故。如世死尸医不能治。一阐提者亦复如是。诸佛世尊所不能治。大王。今者非一阐提。云何而言不可救疗

如王所言。无能治者。大王当知。迦毗罗城净饭王子。姓瞿昙氏字悉达多。无师觉悟自然而得阿耨多罗三藐三菩提。三十二相八十种好庄严其身。具足十力四无所畏一切知见大慈大悲。怜愍一切如罗睺罗。随善众生如犊逐母。知时而说非时不语实语净语妙语义语法语一语。能令众生永离烦恼。善知众生诸根心性。随宜方便无不通达。其智高大如须弥山。深邃广远犹如大海。是佛世尊有金刚智。能破众生一切恶罪。若言不能无有是处。今者去此十二由旬。在拘尸那城娑罗双树间。而为无量阿僧祇等诸菩萨僧。演种种法。若有若无若有为若无为。若有漏若无漏。若烦恼果若善法果。若色法若非色法若非色非非色法。若我若非我若非我非非我。若常若非常若非常非非常。若乐若非乐若非乐非非乐。若相若非相若非相非非相。若断若非断若非断非非断。若世若出世若非世非出世。若乘若非乘若非乘非非乘。若自作自受若自作他受若无作无受。大王。若当于佛所闻无作无受。所有重罪即当消灭。王今且听。释提桓因命将欲终有五相现。一者衣裳垢腻。二者头上花萎。三者身体臭秽。四者腋下汗出。五者不乐本座。时天帝释或于静处。若见沙门若婆罗门。即至其所生于佛想。尔时沙门及婆罗门见帝释来深自庆幸。即说是语。天主我今归依于汝。释闻是已乃知非佛。复自念言。彼若非佛不能治我五退没相。是时御臣名般遮尸。语帝释言。憍尸迦。乾闼婆王名敦浮楼。其王有女字须跋陀。王若能以此女见与。臣当示王除衰相处。释即答言。善男子。毗摩质多阿修罗王。有女舍脂是吾所敬。卿若必能示吾消灭恶相处者。犹当相与。况须跋陀。憍尸迦。有佛世尊字。释迦牟尼。今者在于王舍大城。若能往彼咨禀未闻。衰没之相必得除灭。善男子。若佛世尊审能灭者。便可回驾至其住处。御臣奉命即回车乘。到王舍城耆阇崛山。至于佛所头面礼足。却坐一面白佛言。世尊。天人之中谁为系缚。憍尸迦。悭贪嫉妒。又言悭贪嫉妒因何而生。答言因无明生。又言无明复因何生。答言。因放逸生。又言放逸复因何生。答言。因颠倒生。又言颠倒复因何生。答言。因疑心生。世尊。颠倒之法因疑生者。实如圣教。何以故。我有疑心。以疑心故则生颠倒。于非世尊生世尊想。我今见佛疑网即除。疑网除故颠倒亦尽。颠倒尽故无有悭心乃至妒心。佛言。汝言无有悭妒心者。汝今已得阿那含耶。阿那含者无有贪心。若无贪心云何为命来至我所。如阿那含实不求命。世尊有颠倒者则有求命。无颠倒者则不求命。然我今者实不求命。所欲求者唯佛法身及佛智慧。憍尸迦。求佛法身及佛智慧。将来之世必当得之。尔时帝释闻佛说已。五衰没相即时消灭。便起作礼绕佛三匝。恭敬合掌而白佛言。世尊。我今即死即生失命得命。又闻佛记当得阿耨多罗三藐三菩提。是为更生为更得命。世尊。一切人天云何增益。复以何缘而致损减。憍尸迦。斗诤因缘人天损减。善修和敬则得增益。世尊。若以斗诤而损减者。我从今日更不复与阿修罗战。佛言。善哉善哉。憍尸迦。诸佛世尊说忍辱法是阿耨多罗三藐三菩提因

尔时释提桓因即前礼佛于是还去。大王。如来以能除诸恶相。是故称佛不可思议。王若往者所有重罪必当得除。大王且听。有婆罗门子字曰不害。以杀无量诸众生故名鸯崛魔。复欲害母。恶心起时身亦随动。身心动者即五逆因。五逆因故必堕地狱。后见佛时身心俱动复欲生害。身心动者即五逆因。五逆因故当入地狱。是人得遇如来大师。即时得灭地狱因缘。发阿耨多罗三藐三菩提心。是故称佛为无上医非六师也。大王。复有须毗罗王子。其父嗔之。截其手足推之深井。其母矜愍使人牵出将至佛所。寻见佛时手足还具。即发阿耨多罗三藐三菩提心。大王。以见佛故得现果报。是故称佛为无上医非六师也。大王。如恒河边有诸饿鬼。其数五百于无量岁初不见水。虽至河上纯见流火。饥渴所逼发声号哭。尔时如来在其河侧郁昙钵林坐一树下。时诸饿鬼来至佛所。白佛言。世尊。我等饥渴命将不远。佛言。恒河流水汝何不饮。鬼即答言。如来见水我则见火。佛言。恒河清流实无火也。以恶业故心自颠倒谓为是火。我当为汝除灭颠倒令汝见水。尔时世尊广为诸鬼说悭贪过。诸鬼即言。我今渴乏虽闻法言都不入心。佛言。汝若渴乏先入河水恣意饮之。是诸鬼等以佛力故即得饮水。既饮水已。如来复为种种说法。既闻法已悉发阿耨多罗三藐三菩提心。舍饿鬼形得于天身。大王。是故称佛为无上医非六师也。大王。舍婆提国群贼五百。波斯匿王挑出其目。盲无前导不能得往至于佛所。佛怜愍故即至贼所慰喻之言。善男子。善护身口更勿造恶。诸贼即时闻如来音微妙清彻。寻还得眼。即于佛前合掌礼佛而白佛言。世尊。我今知佛慈心普覆一切众生非独人天。尔时如来即为说法。既闻法已悉发阿耨多罗三藐三菩提心。是故如来真是世间无上良医非六师也。大王。舍婆提国有旃陀罗名曰气嘘。杀无量人。见佛弟子大目犍连。即时得破地狱因缘。而得上生三十三天。以有如是圣弟子故。称佛如来为无上医非六师也。大王。波罗捺城有长者子名阿逸多。淫匿其母。以是因缘杀戮其父。其母复与外人共通。子既知已便复杀之。有阿罗汉是其知识。于此知识复生愧耻即便杀之。杀已即到只桓精舍求欲出家。时诸比丘具知此人有三逆罪无敢听者。以不听故倍生嗔恚。即于其夜大放猛火焚烧僧坊多杀无辜。然后复往王舍城中。至如来所求哀出家。如来即听为说法要。令其重罪渐渐轻微发阿耨多罗三藐三菩提心。是故称佛为世良医非六师也。大王。王本性暴恶。信受恶人提婆达多。放大醉象欲令践佛。象既见佛即时醒悟。佛便申手摩其顶上复为说法。悉令得发阿耨多罗三藐三菩提心。大王。畜生见佛犹得破坏畜生业果。况复人耶。大王当知。若见佛者所有重罪必当得灭。大王。世尊未得阿耨多罗三藐三菩提时。魔与无量无边眷属至菩萨所。菩萨尔时以忍辱力。坏魔恶心令魔受法。寻发阿耨多罗三藐三菩提心。佛有如是大功德力。大王。有圹野鬼多害众生。如来尔时为善贤长者。至圹野村为其说法。时圹野鬼闻法欢喜。即以长者授于如来。然后便发阿耨多罗三藐三菩提心。大王。波罗奈国有屠儿名曰广额。于日日中杀无量羊。见舍利弗即受八戒经一日夜。以是因缘命终得为北方天王毗沙门子。如来弟子尚有如是大功德果。况复佛也。大王。北天竺有城名曰细石。其城有王名曰龙印。贪国重位戮害其父。害其父已心生悔恨。即舍国政来至佛所求哀出家。佛言善来。即成比丘重罪消灭。发阿耨多罗三藐三菩提心。大王当知。佛有如是无量无边大功德果。大王。如来有弟提婆达多。破坏众僧。出佛身血。害莲花比丘尼。作三逆罪。如来为说种种法要。令其重罪寻得微薄。是故如来为大良医非六师也。大王。若能信臣语者。唯愿速往至如来所。若不见信愿善思之。大王。诸佛世尊大悲普覆不限一人。正法弘广无所不包。怨亲平等心无憎爱。终不偏为一人令得阿耨多罗三藐三菩提余人不得如来。非独四部之师。普是一切天人龙鬼地狱畜生饿鬼等师。一切众生亦当视佛如父母想。大王当知。如来不但独为豪贵之人跋提迦王而演说法。亦为下贱优波离等。不独偏受须达多阿那邠坻所奉饭食。亦受贫人须达多食。不但独为舍利弗等利根说法。亦为钝根周梨槃特。不但独听大迦叶等无贪之性出家求道。亦听大贪难陀出家。不但独听烦恼薄者优楼频螺迦叶等出家求道。亦听烦恼深厚造重罪者波斯匿王弟优陀耶出家求道。不以纱草恭敬供养拔其嗔根鸯崛摩罗恶心欲害舍而不救。不但独为有智男子而演说法。亦为极愚牉合智者女人说法。不但独令出家之人得四道果。亦令在家得三道果。不但独为富多罗等舍诸匆务闲寂思惟而说法要。亦为频婆娑罗王等统领国事理王务者而说法要。不但独为断酒之人。亦为耽酒郁伽长者荒醉者说。不但独为入禅定者离婆多等。亦为丧子乱心婆罗门女婆私吒说。不但独为己之弟子。亦为外道尼干子说。不但独为盛壮之年二十五者。亦为衰老八十者说。不但独为根熟之人。亦为善根未熟者说。不但独为末利夫人。亦为淫女莲花女说。不但独受波斯匿王上馔甘味。亦受长者尸利鞠多杂毒之食。大王当知。尸利鞠多往昔亦作逆罪之因。以遇佛闻法。即发阿耨多罗三藐三菩提心。大王。假使一月常以衣食供养恭敬一切众生。不如有人一念念佛所得功德十六分一。大王。假使锻金为人车马载宝。其数各百以用布施。不如有人发心向佛举足一步。大王。假使复以象车百乘。载大秦国种种珍宝。及其女人身佩璎珞。数亦满百持用布施。犹故不如发心向佛举足一步。复置是事若以四事供养三千大千世界所有众生。犹亦不如发心向佛举足一步。复置是事。若使大王供养恭敬恒河沙等无量众生。不如一往娑罗双树到如来所诚心听法。尔时大王答言耆婆。如来世尊性已调柔。故得调柔以为眷属。如栴檀林纯以栴檀而为围绕。如来清净所有眷属亦复清净。犹如大龙纯以诸龙而为眷属。如来寂静所有眷属亦复寂静。如来无贪所有眷属亦复无贪。佛无烦恼所有眷属亦无烦恼。吾今既是极恶之人。恶业缠裹其身臭秽系属地狱云何当得至如来所。吾设往者恐不顾念接叙言说。卿虽劝吾令往佛所。然吾今日深自鄙悼都无去心。尔时虚空寻出声言。无上佛法将欲衰殄。甚深法河于是欲涸。大法明灯将灭。不久法山欲颓。法船欲沈法桥欲坏。法殿欲崩。法幢欲倒。法树欲折。善友欲去。大怖将至。法饿众生将至不久。烦恼疫病将欲流行。大闇时至渴法时来。魔王欣庆解释甲胄。佛日将没大涅槃山。大王。佛若去世王之重恶更无治者。大王。汝今已造阿鼻地狱极重之业。以是业缘必受不疑。大王。阿者言无。鼻者名间。间无暂乐故名无间。大王。假使一人独堕是狱。其身长大八万由旬。遍满其中间无空处。其身周匝受种种苦。设有多人身亦遍满不相妨碍。大王。寒地狱中暂遇热风以之为乐。热地狱中暂遇寒风亦名为乐。有地狱中设命终已。若闻活声即便还活。阿鼻地狱都无此事。大王。阿鼻地狱四方有门。一一门外各有猛火。东西南北交过通彻。八万由旬周匝铁墙。铁网弥覆其地亦铁。上火彻下下火彻上。大王。若鱼在[金*敖]脂膏焦然。是中罪人亦复如是。大王。作一逆者则便具受如是一罪。若造二逆罪即二倍。五逆具者罪亦五倍。大王。我今定知王之恶业必不得免。唯愿大王速往佛所。除佛世尊余无能救。我今愍汝故相劝导。尔时大王闻是语已。心怀怖惧举身战栗。五体掉动如芭蕉树。仰而答曰。汝为是谁。不现色像而但有声。大王。吾是汝父频婆娑罗。汝今当随耆婆所说。莫随邪见六臣之言。时王闻已闷绝躄地。身疮增剧臭秽倍前。虽以冷药涂而治之。疮烝毒热但增无损

大般涅槃经卷第十七大般涅槃经卷第十八

        宋代沙门慧严等依泥洹经加之

    梵行品之第五

尔时世尊在双树间。见阿阇世闷绝躄地。即告大众。我今当为是王。住世至无量劫不入涅槃。迦叶菩萨白佛言。世尊。如来当为无量众生不入涅槃。何故独为阿阇世王。佛言。善男子。是大众中无有一人谓我毕定入于涅槃。阿阇世王定谓我当毕竟永灭。是故闷绝自投于地。善男子。如我所言为阿阇世不入涅槃。如是密义汝未能解。何以故。我言为者。一切凡夫。阿阇世者。普及一切造五逆者。又复为者。即是一切有为众生。我终不为无为众生而住于世何以故。夫无为者非众生也。阿阇世者。即是具足烦恼等者。又复为者。即是不见佛性众生。若见佛性我终不为久住于世。何以故。见佛性者非众生也。阿阇世者。即是一切未发阿耨多罗三藐三菩提心者。又复为者。即是阿难迦叶二众。阿阇世者。即是阿阇世王后宫妃后及王舍城一切妇女。又复为者名为佛性。言阿阇者名为不生。世者名怨。以不生佛性故则烦恼怨生。烦恼怨生故不见佛性。以不生烦恼故。则见佛性。以见佛性故则得安住大般涅槃。是名不生。是故(名为)为阿阇世。善男子。阿阇者名不生不生者名涅槃。世名世法。为者名不污。以世八法所不污故。无量无边阿僧祇劫不入涅槃。是故我言为阿阇世无量亿劫不入涅槃。善男子。如来密语不可思议。佛法众僧亦不可思议。菩萨摩诃萨亦不可思议。大涅槃经亦不可思议。尔时世尊大悲导师。为阿阇世王入月爱三昧。入三昧已放大光明。其光清凉往照王身。身疮即愈郁蒸除灭。王觉疮愈身体清凉。语耆婆言。曾闻人说劫将欲尽三月并现。当是之时一切众生患苦悉除。时既未至此光何来照触吾身。疮苦除愈身得安乐。耆婆答言。此非劫尽三月并照。亦非火日星宿药草宝珠天光。王又问言。此光若非三月并照宝珠明者。为是谁光。大王当知。是天中天所放光明。是光无根无有边际。非热非冷。非常非灭。非色非无色。非相非无相。非青非黄非赤非白。欲度众生故使可见有相可说有根有边有热有冷青黄赤白。大王。是光虽尔实不可说不可睹见。乃至无有青黄赤白。王言耆婆。彼天中天以何因缘放斯光明。耆婆答言今是瑞相将为大王。以王先言世无良医疗治身心。故放此光先治王身然后及心。王言耆婆。如来世尊亦见念耶。耆婆答言。譬如一人而有七子。是七子中一子遇病父母之心非不平等。然于病子心则偏多。大王。如来亦尔。于诸众生非不平等。然于罪者心则偏重。于放逸者佛则慈念。不放逸者心则放舍。何等名为不放逸者。谓六住菩萨。大王。诸佛世尊于诸众生。不观种姓老少中年贫富时节日月星宿工巧下贱僮仆婢使。唯观众生有善心者。若有善心则便慈念。大王当知。如是瑞相即是如来。入月爱三昧所放光明。王即问言。何等名为月爱三昧。耆婆答言。譬如月光能令一切优钵罗花开敷鲜明。月爱三昧亦复如是。能令众生善心开敷。是故名为月爱三昧。大王。譬如月光能令一切行路之人心生欢喜。月爱三昧亦复如是。能令修习涅槃道者心生欢喜。是故复名月爱三昧。大王。譬如月光从初一日至十五日形色光明渐渐增长月爱三昧亦复如是。令初发心诸善根本渐渐增长。乃至具足大般涅槃。是故复名月爱三昧。大王。譬如月光从十六日至三十日形色光明渐渐损减月爱三昧亦复如是。光所照处所有烦恼能令渐减。是故复名月爱三昧。大王。譬如盛热之时一切众生常思月光。月光既照郁热即除。月爱三昧亦复如是。能令众生除贪恼热。大王。譬如满月众星中王。为甘露味一切众生之所爱乐。月爱三昧亦复如是。诸善中王为甘露味。一切众生之所爱乐。是故复名月爱三昧。王语

耆婆。我闻如来不与恶人同止坐起语言谈论。犹如大海不宿死尸。如鸳鸯鸟不住圊厕。释提桓因不与鬼住。鸠翅罗鸟不栖枯树。如来亦尔。我当云何而得往见。设其见者我身将不陷入地耶。我观如来宁近醉象师子虎狼猛火绝焰。终不近于重恶之人。是故我今思忖是已。当有何心往见如来。耆婆答言。大王。譬如渴人速赴清泉。饥者求食怖者求救病求良医热求荫凉寒者求火。王今求佛亦应如是。大王。如来尚为一阐提等演说法要。何况大王非一阐提。而当不蒙慈悲救济。王言。耆婆。我昔曾闻一阐提者。不信不闻不能观察不得义理。何故如来而为说法。耆婆答言。大王。譬如有人身遇重病。是人夜梦升一柱殿。服苏油脂及以涂身。卧灰食灰攀上枯树。或与猕猴游行坐卧。沉水没泥。堕坠楼殿高山树木象马牛羊。身着青黄赤黑色衣。喜笑歌舞。或见乌鹫狐狸之属。齿发堕落。裸形枕狗卧粪秽中。复与亡者行住坐起携手食啖。毒蛇满路而从中过。或复梦与被发女人共相抱持。多罗树叶以为衣服。乘坏驴车正南而游。是人梦已心生愁恼。以愁恼故身病愈增。以病增故诸家亲属遣使命医。所可遣使形体缺短根不具足。头蒙尘土著弊坏衣载故坏车。语彼医言。速疾上车。尔时良医即自思惟。今见是使相貌不吉。当知病者难可疗治。复作是念使虽不吉复当占日。为可治不。若四日六日八日十二日十四日。如是日者病亦难治。复作是念。日虽不吉复当占星。为可治不。若是火星金星昴星阎罗王星湿星满星。如是星时病亦难治。复作是念。星虽不吉复当观时。若是秋时冬时及日入时夜半时月入时。当知是病亦难可治。复作是念。如是众相虽复不吉或定不定。当观病人。若有福德皆可疗治。若无福德虽吉何益。思惟是已。寻与使俱在路复念。若彼病者有长寿相则可疗治。短寿相者则不可治。即于前路见二小儿。相牵斗诤捉头拔发瓦石刀杖共相撩打。见人持火自然殄灭。或见有人斫伐树木。或复见人手曳皮革随路而行。或见道路有遗落物。或见有人执持空器。或见沙门独行无侣。复见虎狼乌鹫野狐。见是事已复作是念。所遣使人乃至道路所见诸相悉皆不祥。当知病者定难疗治。复作是念。我若不往则非良师。如其往者不可救疗。复更念言。如是众相。虽复不祥。且当舍置往至病所。思惟是已复于前路闻如是声。所谓亡失死丧崩破坏折剥脱堕坠焚烧不来。不可疗治不能拔济。复闻南方有飞鸟声。所谓乌鹫舍利鸟声。若狗若鼠野狐猪兔。闻是声已复作是念。当知病者难可疗治。尔时即入病人舍宅见彼病人。数寒数热骨节疼痛。目赤流泪耳声闻外。咽喉结痛舌上裂破。其色正黑。头不自胜。体枯无汗。大小便利拥隔不通。身卒肥大红赤异常。语声不均或粗或细。举体斑驳异色青黄。其腹胀满言语不了。医见是已问瞻病言。病者昨来意志云何。答言。大师。其人本来敬信三宝及以诸天。今者变异敬信情息。本喜惠施今者悭吝。本性少食今则过多。本性敝恶今则和善。本性慈孝恭敬父母。今于父母无恭敬心。医闻是已即前嗅之。优钵罗香沉水杂香毕迦多香多伽罗香多摩罗跋香郁金香栴檀香。炙肉臭蒱桃酒臭烧筋骨臭鱼臭粪臭。知香臭已即前触身。觉身细软犹如缯绵劫贝纱花。或[革*卬]如石。或冰如冷。或热如火。或涩如沙。尔时良医见如是等种种相已。定知病者必死不疑。然不定言是人当死。语瞻病者。吾今遽务明当更来。随其所须恣意勿遮即便还家。明日使到复语使言。我事未讫兼未合药。智者当知。如是病者必死不疑。大王。世尊亦尔。于一阐提辈善知根性而为说法。何以故。若不为说一切凡夫当言如来无大慈悲。有慈悲者名一切智。若无慈悲云何说言一切智人。是故如来为一阐提而演说法。大王。如来世尊见诸病者常施法药。病者不服非如来咎。大王。一阐提辈分别有二。一者得现在善根。二者得后世善根。如来善知一阐提辈。能于现在得善根者。则为说法。后世得者亦为说法。今虽无益作后世因。是故如来为一阐提演说法要。一阐提者复有二种。一者利根。二者中根。利根之人于现在世能得善根。中根之人后世则得。诸佛世尊不空说法。大王。譬如净人坠堕圊厕有善知识见而愍之寻前捉发而拔出之。诸佛如来亦复如是见诸众生堕三恶道。方便救济令得出离。是故如来为一阐提而演说法。王语耆婆。若使如来审如是者。明当选择良日吉星然后乃往。耆婆白王。大王。如来法中无有选择良日吉星。大王。如重病人犹不看日时节吉凶唯求良医。王今病重求佛良医。不应选择良时好日。大王。如栴檀火及芛兰火二俱烧相无有异也。吉日凶日亦复如是。若到佛所俱得灭罪。唯愿大王。今日速往。尔时大王即命一臣名曰吉祥。而告之言。大臣当知。吾今欲往佛世尊所。速办所须供养之具。臣言。大王。善哉善哉。所须供具一切悉有。阿阇世王与其夫人。严驾车乘一万二千。姝壮大象其数五万。一一象上各载三人。赍持幡盖花香伎乐。种种供具无不备足。导从马骑有十八万。摩伽陀国所有人民。寻从王者其数足满五十八万。尔时拘尸那城所有大众满十二由旬。悉皆遥见阿阇世王与其眷属寻路而来。尔时佛告诸大众言。一切众生为阿耨多罗三藐三菩提近因缘者。莫先善友。何以故。阿阇世王若不随顺耆婆语者。来月七日必定命终堕阿鼻狱。是故近因莫若善友。阿阇世王复于前路。闻舍婆提毗流离王乘船入海遇火而死。瞿伽离比丘生身入地至阿鼻狱。须那刹多作种种恶到于佛所众罪得灭。闻是语已语耆婆言。吾今虽闻如是二言犹未审定。汝来耆婆。吾欲与汝同载一象。设我当入阿鼻地狱。冀汝捉持不令我堕。何以故。吾昔曾闻得道之人不入地狱

尔时佛告诸大众言。阿阇世王犹有疑心。我今当为作决定心。尔时会中有一菩萨名持一切。白佛言。世尊。如佛先说一切诸法皆无定相。所谓色无定相。乃至涅槃亦无定相。如来今者云何而言为阿阇世作决定心。佛言。善哉善哉。善男子。我今定为阿阇世王作决定心。何以故。若王疑心可破坏者。当知诸法无有定相。是故我为阿阇世王作决定心。当知是心为无决定。善男子。若彼王心是决定者。王之逆罪云何可坏。以无定相其罪可坏。是故我为阿阇世王作决定心。尔时大王即到娑罗双树间。至于佛所仰瞻如来。三十二相八十种好。犹如微妙真金之山。尔时世尊出八种声告言。大王。时阿阇世左右顾视。此大众中谁为大王。我既罪逆又无福德。如来不应称为大王。尔时如来即复唤言。阿阇世大王。时王闻已心大欢喜。即作是言。如来今日顾命语言。真知如来于诸众生大悲怜愍等无差别。白佛言。世尊。我今疑心永无遗余。定知如来真是众生无上大师。尔时迦叶菩萨语持一切菩萨言。如来已为阿阇世王作决定心。尔时阿阇世王即白佛言。世尊。假使我今得与梵王释提桓因坐起饮食犹不欣悦。得遇如来一言顾命深以欣庆。尔时阿阇世王即以所持幡盖香花伎乐供养。前礼佛足右绕三匝。礼敬毕已却坐一面

尔时佛告阿阇世王言。大王。今当为汝说正法要。汝当一心谛听谛听。凡夫常当系心观身有二十事。一谓我此身中空无无漏。二无诸善根本。三我此生死未得调顺。四堕坠深坑无处不畏。五以何方便得见佛性。六云何修定得见佛性。七生死常苦无常我净。八八难之难难得远离。九恒为怨家之所追逐。十无有一法能遮诸有。十一于三恶趣未得解脱。十二具足种种诸恶邪见。十三亦未造立渡五逆津。十四生死无际未得其边。十五不作诸业不得果报。十六无有我作他人受果。十七不作乐因终无乐果。十八若有造业果终不失。十九因无明生亦因而死。二十去来现在常行放逸。大王。凡夫之人常于此身当作如是二十种观。作是观已不乐生死。不乐生死则得止观。尔时次第观心生相。住相灭相次第观心生住灭相。定慧进戒亦复如是。观生住灭已。知心相乃至戒相终不作恶。无有死畏三恶道畏。若不系心观察如是二十事者。心则放逸无恶不造。阿阇世言。如我解佛所说义者。我从昔来初未曾观是二十事。故造众恶。造众恶故则有死畏三恶道畏。世尊。自我招殃造兹重恶。父王无辜横加逆害。是二十事设观不观。必定当堕阿鼻地狱。佛告大王。一切诸法性相无常无有决定。王云何言必定当堕阿鼻地狱。阿阇世王白佛言。世尊。若一切法无定相者。我之杀罪亦应不定。若杀定者一切诸法则非不定。佛言。大王。善哉善哉。诸佛世尊说一切法悉无定相。王复能知杀亦不定。是故当知杀无定相。大王。如汝。所言父王无辜横加逆害者。何者是父。但于假名众生五阴妄生父想。于十二入十八界中。何者是父。若色是父四阴应非。若四是父色亦应非。若色非色合为父者无有是处。何以故。色与非色性无合故。大王。凡夫众生于是色阴妄生父想。如是色阴亦不可害。何以故。色有十种是十种中唯色一种。可见可持可称可量可牵可缚。虽可见缚其性不住以不住故。不可得见不可捉持。不可称量不可牵缚。色相如是云何可杀。若色是父可杀可害获罪报者余九应非。若九非者则应无罪。大王。色有三种。过去未来现在。过去现在则不可害。何以故。过去过去故。现在念念灭故。遮未来故名之为杀。如是一色或有可杀或不可杀。有杀不杀色则不定。若色不定杀亦不定。杀不定故报亦不定。云何说言定入地狱。大王。一切众生所作罪业凡有二种。一者轻。二者重。若心口作则名为轻。身口心作则名为重。大王。心念口说身不作者所得报轻。大王。昔日口不敕杀但言刖足。大王。若敕侍臣立斩王首。坐时乃斩犹不得罪。况王不敕云何得罪。王若得罪诸佛世尊亦应得罪何以故。汝父先王频婆娑罗。曾于诸佛种诸善根。是故今日得居王位。诸佛若不受其供养则不为王。若不为王汝则不得为国生害。若汝杀父当有罪者。我等诸佛亦应有罪。若诸佛世尊无得罪者。汝独云何而得罪耶。大王。频婆娑罗往有恶心。于毗富罗山游行猎鹿。周遍圹野悉无所得。唯见一仙五通具足。见已即生嗔恚恶心。我今游猎所以不得正坐此人。驱逐令去。即敕左右而令杀之。其人临终生嗔恶心。退失神通而作誓言。我实无辜。汝以心口横加戮害。我于来世亦当如是还以心口而害于汝。时王闻已即生悔心供养死尸。是王如是尚得轻受不堕地狱。况王不尔。而当地狱受果报耶。先王自作还自受之。云何令王而得杀罪。如王所言父王无辜者。大王云何言无。夫有罪者则有罪报。无恶业者则无罪报。汝父先王若无辜罪云何有报。频婆娑罗于现世中。亦得善果及以恶果。是故先王亦复不定。以不定故杀亦不定。杀不定故云何而言定入地狱

大王。众生狂惑凡有四种。一者贪狂。二者药狂。三者咒狂。四者本业缘狂。大王。我弟子中有是四狂。虽多作恶我终不记是人犯戒。是人所作不至三恶。若还得心亦不言犯。王本贪国逆害父王。贪狂心作云何得罪。大王。如人酒醉逆害其母。既醒寤已心生悔恨。当知是业亦不得报。王今贪醉非本心作。若非本心云何得罪。大王。譬如幻师四衢道头幻作种种男女象马璎珞衣服愚痴之人谓为真实。有智之人知非真有。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。譬如山间响声。愚痴之人谓之实声。有智之人知其非真。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。如人有怨诈来亲附。愚痴之人谓为实亲。智者了达乃知虚诈。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。如人执镜自见面像。愚痴之人谓为真面。智者了达知其非真。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。如热时炎。愚痴之人谓之是水。智者了达知其非水。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。如乾闼婆城。愚痴之人谓为真实。智者了达知其非真。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。如人梦中受五欲乐。愚痴之人谓之为实。智者了达知其非真。杀亦如是凡夫谓实。诸佛世尊知其非真。大王。杀法杀业杀者杀果及以解脱。我皆了之则无有罪。王虽知杀云何有罪。大王。譬如有人主知典酒如其不饮则亦不醉虽复知火亦不烧燃。王亦如是。虽复知杀云何有罪。大王。有诸众生于日出时作种种罪。于月出时复行劫盗。日月不出则不作罪。虽因日月令其作罪。然此日月实不得罪。杀亦如是。虽复因王王实无罪。大王。如王宫中常敕屠羊心初无惧。云何于父。独生惧心。虽复人畜尊卑差别。宝命重死二俱无异。何故于羊心轻无惧。于父先王生重忧苦。大王。世间之人是爱僮仆不得自在。为爱所使而行杀害。设有果报乃是爱罪。王不自在当有何咎。大王。譬如涅槃非有非无而亦是有。杀亦如是虽非有无而亦是有。惭愧之人则为非有。无惭愧者则为非无。受果报者名之为有。空见之人则为非有。有见之人则为非无。有有见者亦名为有。何以故。有有见者得果报故。无有见者则无果报。常见之人则为非无。无常见者则为非有。常常见者不得为无。何以故。常常见者有恶业果故。是故常常见者不得为无。以是义故。虽非有无而亦是有。大王。夫众生者名出入息。断出入息故名为杀。诸佛随俗亦说为杀。大王。色是无常。色之因缘亦是无常。从无常因生色云何常。乃至识是无常。识之因缘亦是无常。从无常因生识云何常。以无常故苦。以苦故空。以空故无我。若是无常苦空无我为何所杀。杀无常者得常涅槃。杀苦得乐。杀空得实。杀于无我而得真我。大王。若杀无常苦空无我者则与我同。我亦杀于无常苦空无我不入地狱。汝云何入

尔时阿阇世王如佛所说观色乃至观识。作是观已即白佛言。世尊。我今始知色是无常乃至识是无常。我本若能如是知者则不作罪。世尊。我昔曾闻诸佛世尊常为众生而作父母。虽闻是语犹未审定。今则定知。世尊我亦曾闻。须弥山王四宝所成。所谓金银琉璃颇梨若有众鸟随所集处则同其色。虽闻是言亦不审定。我今来至佛须弥山则与同色。与同色者则知诸法无常苦空无我。世尊。我见世间从芛兰子生芛兰树。不见芛兰生栴檀树。我今始见从芛兰子生栴檀树。芛兰子者我身是也。栴檀树者即是我心无根信也。无根者。我初不知恭敬如来不信法僧。是名无根。世尊。我若不遇如来世尊。当于无量阿僧祇劫在大地狱受无量苦我今见佛。以是见佛所得功德。破坏众生所有一切烦恼恶心

佛言大王。善哉善哉。我今知汝必能破坏众生恶心。世尊。若我审能破坏众生诸恶心者。使我常在阿鼻地狱。无量劫中为诸众生。受大苦恼不以为苦。尔时摩伽陀国无量人民悉发阿耨多罗三藐三菩提心。以如是等无量人民发大心故。阿阇世王所有重罪即得微薄。王及夫人后宫婇女悉皆同发阿耨多罗三藐三菩提心。尔时阿阇世王语耆婆言。耆婆。我今未死已得天身。舍于短命而得长命。舍无常身而得常身。令诸众生发阿耨多罗三藐三菩提心。即是天身长命常身。即是一切诸佛弟子。说是语已。即以种种宝幢幡盖香花璎珞微妙伎乐而供养佛。复以偈颂而赞叹言

  实语甚微妙　　善巧于句义
  甚深秘密藏　　为众故显示
  所有广博言　　为众故略说
  具足如是语　　善能疗众生
  若有诸众生　　得闻是语者
  若信及不信　　定知是佛说
  诸佛常软言　　为众故说粗
  粗语及软语　　皆归第一义
  是故我今者　　归依于世尊
  如来语一味　　犹如大海水
  是名第一谛　　故无无义语
  如来今所说　　种种无量法
  男女大小闻　　同获第一义
  无因亦无果　　无生及无灭
  是名大涅槃　　闻者破诸结
  如来为一切　　常作慈父母
  当知诸众生　　皆是如来子
  世尊大慈悲　　为众故苦行
  如人着鬼魅　　狂乱多所作
  我今得见佛　　所得三业善
  愿以此功德　　回向无上道
  我今所供养　　佛法及众僧
  愿以此功德　　三宝常在世
  我今所当得　　种种诸功德
  愿以此破坏　　众生四种魔
  我遇恶知识　　造作三世罪
  今于佛前悔　　愿后更莫造
  愿诸众生等　　悉发菩提心
  系心常思念　　十方一切佛
  复愿诸众生　　永破诸烦恼
  了了见佛性　　犹如妙德等

尔时世尊赞阿阇世王。善哉善哉。若有人能发菩提心。当知是人则为庄严诸佛大众。大王汝昔已于毗婆尸佛初发阿耨多罗三藐三菩提心。从是已来至我出世。于其中间未曾堕于地狱受苦。大王当知。菩提之心乃有如是无量果报。大王。从今已往常当勤修菩提之心。何以故。从是因缘当得消灭无量恶故。尔时阿阇世王及摩伽陀举国人民。从座而起绕佛三匝辞退还宫。天行品者如杂花说

    大般涅槃经婴儿行品第二十一

善男子。云何名婴儿行。善男子。不能起住来去语言。是名婴儿。如来亦尔。不能起者。如来终不起诸法相。不能住者。如来不着一切诸法。不能来者。如来身行无有动摇。不能去者。如来已到大般涅槃。不能语者。如来虽为一切众生演说诸法实无所说。何以故。有所说者名有为法。如来世尊非是有为。是故无说。又无语者犹如婴儿言语未了。虽复有语实亦无语。如来亦尔。语未了者即是诸佛秘密之言。虽有所说众生不解。故名无语。又婴儿者。名物不一未知正语。虽名物不一未知正语。非不因此而得识物。如来亦尔。一切众生方类各异所言不同。如来方便随而说之。亦令一切因而得解。又婴儿者能说大字。如来亦尔。说于大字所谓婆啝。啝者有为。婆者无为。是名婴儿。啝者名为无常。婆者名为有常。如来说常众生闻已。为常法故断于无常。是名婴儿行。又婴儿者不知苦乐昼夜父母。菩萨摩诃萨亦复如是。为众生故不见苦乐无昼夜相。于诸众生其心平等。故无父母亲疏等相。又婴儿者不能造作大小诸事。菩萨摩诃萨亦复如是。菩萨不造生死作业。是名不作大事大事者即五逆也。菩萨摩诃萨终不造作五逆重罪。小事者即二乘心。菩萨终不退菩提心而作声闻辟支佛乘。又婴儿行者。如彼婴儿啼哭之时。父母即以杨树黄叶而语之言。莫啼莫啼我与汝金。婴儿见已生真金想便止不啼。然此杨叶实非金也。木牛木马木男木女婴儿见已。亦复生于男女等想即止不啼。实非男女以作如是男女想故。名曰婴儿。如来亦尔。若有众生欲造众恶。如来为说三十三天常乐我净端正自恣。于妙宫殿受五欲乐。六根所对无非是乐。众生闻有如是乐故。心生贪乐止不为恶。勤作三十三天善业。实是生死无常无乐无我无净。为度众生方便说言常乐我净。又婴儿者。若有众生厌生死时。如来则为说于二乘。然实无有二乘之实。以二乘故知生死过见涅槃乐。以是见故。则能自知有断不断有真不真有修不修有得不得。善男子。如彼婴儿于非金中而生金想。如来亦尔。于不净中而说为净。如来已得第一义故则无虚妄。如彼婴儿于非牛马作牛马想。若有众生于非道中作真道想。如来亦说非道为道非道之中实无有道。以能生道微因缘故。说非道为道。如彼婴儿于木男女生男女想。如来亦尔。知非众生说众生相。而实无有众生相也。若佛如来说无众生。一切众生则堕邪见。是故如来说有众生。于众生中作众生相者。则不能破众生相也。若于众生破众生相者。是则能得大般涅槃。以得如是大涅槃故止不啼哭。是名婴儿行。善男子。若有男女受持读诵书写解说是五行者。当知是人必定当得如是五行。迦叶菩萨白佛言。世尊。如我解佛所说义者。我亦定当得是五行。佛言。善男子。不独汝得如是五行。今此会中九十三万人。亦同于汝得是五行

大般涅槃经卷第十八大般涅槃经卷第十九

        宋代沙门慧严等依泥洹经加之

    光明遍照高贵德王菩萨品第二十二之一

尔时世尊。告光明遍照高贵德王菩萨摩诃萨言。善男子。若有菩萨摩诃萨修行如是大涅槃经。得十事功德。不与声闻辟支佛共。不可思议。闻者惊怪。非内非外。非难非易。非相非非相。非是世法。无有相貌。世间所无。何等为十。一者有五。何等为五。一者所不闻者而能得闻。二者闻已能为利益。三者能断疑惑之心。四者慧心正直无曲。五者能知如来密藏。是为五事。何等不闻而能得闻。所谓甚深微密之藏。一切众生悉有佛性。佛法众僧无有差别。三宝性相常乐我净。一切诸佛无有毕竟入涅槃者。常住无变。如来涅槃非有非无。非有为非无为。非有漏非无漏。非色非不色。非名非不名。非相非不相。非有非不有。非物非不物。非因非果。非待非不待。非明非闇。非出非不出。非常非不常。非断非不断。非始非终。非过去非未来。非现在。非阴非不阴。非入非不入。非界非不界。非十二因缘非不十二因缘。如是等法甚深微密昔所不闻而能得闻。复有不闻。所谓一切外道经书。四毗陀论。毗伽罗论。卫世师论。迦毗罗论。一切咒术医方伎艺。日月薄蚀星宿运变。图书谶记如是等经。初未曾闻秘密之义。今于此经而得知之。复有十一部经除毗佛略。亦无如是深密之义。今因此经而得知之。善男子。是名不闻而能得闻。闻已利益者。若能听受是大涅槃经。悉能具知一切方等大乘经典甚深义味。譬如男女于明净镜见其色像了了分明。大涅槃镜亦复如是。菩萨执之悉得明见大乘经典甚深之义。亦如有人在闇室中执大炬火悉见诸物。大涅槃炬亦复如是。菩萨执之得见大乘深奥之义。亦如日出有千光明悉能照了诸山幽闇令一切人远见诸物。是大涅槃清净慧日亦复如是。照了大乘深邃之处。令二乘人远见佛道。所以者何。以能听受是大涅槃微妙经故。善男子。若有菩萨摩诃萨。听受如是大涅槃经。得知一切诸法名字。若能书写读诵通利为他广说思惟其义。则知一切诸法义理。善男子。其听受者唯知名字不知其义。若能书写受持读诵为他广说思惟其义则能知义。复次善男子。听是经者闻有佛性未能得见。书写读诵为他广说思惟其义则得见之。听是经者闻有檀名。未能得见檀波罗蜜。书写读诵为他广说思惟其义则能得见檀波罗蜜。乃至般若波罗蜜亦复如是。善男子。菩萨摩诃萨若能听是大涅槃经。则知法知义具二无碍。于诸沙门婆罗门等若天魔梵一切世中。得无所畏开示分别十二部经。演说其义无有差违。不从他闻而能自知近于阿耨多罗三藐三菩提。善男子。是名闻已能为利益。断疑心者。疑有二种。一者疑名。二者疑义。听是经者断疑名心。思惟义者断疑义心。复次善男子。疑有五种。一者疑佛定涅槃不。二者疑佛是常住不。三者疑佛是真乐不。四者疑佛是真净不。五者疑佛是实我不。听是经者疑佛涅槃则得永断。书写读诵为他广说思惟其义四疑永断。复次善男子。疑有三种。一疑声闻为有为无。二疑缘觉为有为无。三疑佛乘为有为无。听是经者如是三疑永灭无余。书写读诵为他广说思惟其义。则能了知一切众生悉有佛性。复次善男子。若有众生不闻如是大涅槃经疑心甚多。所谓若常无常。若乐不乐。若净不净。若我无我。若命非命。若众生非众生。若毕竟不毕竟。若他世若过世。若有若无。若苦若非苦。若集若非集。若道若非道。若灭若非灭。若法若非法。若善若非善。若空若非空。听是经者如是诸疑悉得永断。复次善男子。若有不闻如是经者。复有种种众多疑心。所谓色是我耶。受想行识是我耶。眼能见耶我能见耶。乃至识能知耶我能知耶。色受报耶我受报耶。乃至识受报耶我受报耶。色至他世耶。我至他世耶。乃至识亦如是。生死之法有始有终耶。无始无终耶。听是经者如是等疑亦得永断。复有人疑。一阐提人犯四重禁作五逆罪谤方等经。如是等辈有佛性耶。无佛性耶。听是经者如是等疑悉得永断。复有人疑。世间有边耶。世间无边耶。有十方世界耶。无十方世界耶。听是经者如是等疑亦得永断。是名能断疑惑之心。慧心正直无邪曲者。心若有疑则所见不正。一切凡夫若不得闻是大涅槃微妙经典所见邪曲。乃至声闻辟支佛人所见亦曲。云何名为一切凡夫所见邪曲。于有漏中见常乐我净。于如来所见无常苦不净无我。见有众生寿命知见。计非有想非无想处以为涅槃。见自在天有八圣道。有见断见如是等见名为邪曲。菩萨摩诃萨若得闻是大涅槃经。修行圣行则得断除如是邪曲。云何名为声闻缘觉邪曲见耶。见于菩萨。从兜率下化乘白象降神母胎。父名净饭母曰摩耶。迦毗罗城处胎满足十月而生。生未至地帝释捧接。难陀龙王及婆难陀吐水而浴。摩尼跋陀大鬼神王。执持宝盖随后侍立。地神化花以承其足。四方各行满足七步。至于天庙令诸天像悉起承迎。阿私陀仙抱持占相。既占相已生大悲苦。自伤当终不睹佛兴。诣师学书算计射御图谶伎艺。处在深宫。六万婇女娱乐受乐。出城游观至迦毗罗园。道见老人乃至沙门法服而行。还至宫中见诸婇女形体状貌。犹如枯骨。所有宫殿冢墓无异。厌恶出家夜半踰城。至郁陀伽。阿罗逻等大仙人所。闻说识处及非有想非无想处。既闻是已谛观是处是非常苦不净无我。舍至树下具修苦行满足六年。知是苦行不能得成阿耨多罗三藐三菩提。尔时复到阿夷罗跋提河中洗浴。受牧牛女所奉乳糜。受已转至菩提树下。破魔波旬得成阿耨多罗三藐三菩提。于波罗奈为五比丘初转法轮。乃至于此拘尸那城入般涅槃。如是等见。是名声闻缘觉曲见。善男子。菩萨摩诃萨听受如是大涅槃经。悉得断除如是等见。若能书写读诵通利为他演说思惟其义。则得正直无邪曲见。善男子。菩萨摩诃萨修行如是大涅槃经。谛知菩萨无量劫来不从兜率降神母胎乃至拘尸那城入般涅槃。是名菩萨摩诃萨正直之见。能知如来深密义者。所谓即是大般涅槃。一切众生悉有佛性。忏四重禁。除谤法心。尽五逆罪。灭一阐提。然后得成阿耨多罗三藐三菩提。是名甚深秘密之义。复次善男子。云何复名甚深之义。虽知众生实无有我。而于未来不失业果。虽知五阴于此灭尽。善恶之业终不败亡。虽有诸业不得作者。虽有至处无有去者。虽有系缚无受缚者。虽有涅槃亦无灭者。是名甚深秘密之义

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如我解佛所说闻不闻义。是义不然。何以故。法若有者便应定有。法若无者便应定无。无不应生有不应灭。如其闻者是则为闻。若不闻者则为不闻。云何而言闻所不闻。世尊。若不可闻是为不闻。若已闻者则更不闻。何以故。已得闻故。云何而言闻所不闻。譬如去者到则不去去则不到。亦如生已不生不生不生。得已不得不得不得。闻已不闻不闻不闻亦复如是。世尊。若不闻闻者。一切众生未有菩提即应有之。未得涅槃亦应得之。未见佛性应见佛性。云何复言十住菩萨虽见佛性未得明了。世尊。若不闻闻者。如来往昔从谁得闻。若言得闻。何故如来于阿含中复言无师。若不闻不闻。如来得成阿耨多罗三藐三菩提者。一切众生不闻不闻。亦应得成阿耨多罗三藐三菩提。如来若当不闻如是大涅槃经见佛性者。一切众生不闻是经亦应得见。世尊。凡是色者或有可见或不可见。声亦如是或是可闻或不可闻。是大涅槃非色非声。云何而言可得见闻。世尊。过去已灭则不可闻。未来未至亦不可闻。现在听时则不名闻。闻已声灭更不可闻。是大涅槃亦非过去未来现在。若非三世则不可说。若不可说则不可闻。云何而言菩萨修是大涅槃经闻所不闻

尔时世尊赞光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。汝今善知一切诸法如幻如焰如乾闼婆城画水之迹。亦如泡沫。芭蕉之树空无有实。非命非我无有苦乐。如十住菩萨之所知见

时大众中忽然之顷有大光明。非青见青非黄见黄非赤见赤非白见白。非色见色非明见明非见而见。尔时大众遇斯光已身心快乐。譬如比丘入师子王定。尔时文殊师利菩萨摩诃萨白佛言。世尊。今此光明谁之所放。尔时如来默然不说。迦叶菩萨复问文殊师利。何因缘故。有此光明照于大众。文殊师利默然不答。尔时无边身菩萨复问迦叶菩萨。今此光明谁之所有。迦叶菩萨默然不说。净住王子菩萨复问无边身菩萨。何因缘故是大众中有此光明。无边身菩萨默然不说。如是五百菩萨皆亦如是。虽相咨问然无答者。尔时世尊问文殊师利言。文殊师利。何因缘故是大众中有此光明。文殊师利言。世尊。如是光明名为智慧。智慧者即是常住。常住之法无有因缘。云何佛问何因缘故有是光明。是光明者名大涅槃。大涅槃者则名常住。常住之法不从因缘。云何佛问何因缘故有是光明。是光明者即是如来。如来者即是常住。常住之法不从因缘。云何如来问于因缘。光明者名大慈大悲。大慈大悲者名为常住。常住之法不从因缘。云何如来问于因缘。光明者即是念佛。念佛者是名常住。常住之法不从因缘。云何如来问于因缘。光明者即是一切声闻缘觉不共之道。声闻缘觉不共之道即名常住。常住之法不从因缘。云何如来问于因缘。世尊亦有因缘。因灭无明则得炽然阿耨多罗三藐三菩提灯。佛言。文殊师利。汝今莫入诸法甚深第一义谛。应以世谛而解说之。文殊师利言。世尊。于此东方过二十恒河沙等世界。有佛世界名曰不动。其佛住处纵广正等足满一万二千由旬。其地七宝无有土石。平正柔软无诸沟坑。其诸树木四宝所成。金银琉璃及以颇梨。花果茂盛无时不有。若有众生闻其花香身心安乐。譬如比丘入第三禅。周匝复有三千大河。其水微妙八味具足。若有众生在中浴者所得喜乐。譬如比丘入第二禅。其河多有种种诸花。优钵罗花。波头摩花。拘物头花。分陀利花。香花。大香花。微妙香花。常花。一切众生无遮护花。其河两岸亦有众花。所谓阿提目多伽花。占婆花。波吒罗花。婆师罗花。摩利迦花。大摩利迦花。新摩利迦花。须摩那花。由提迦花。檀[少/兔]迦利花。常花。一切众生无遮护花。底布金沙。有四梯陛金银琉璃杂色颇梨。多有众鸟游集其中。复有无量虎狼师子诸恶鸟兽。其心相视犹如赤子。彼世界中一切无有犯重禁者诽谤正法及一阐提五逆等罪。其土调适无有寒热饥渴苦恼。无贪欲恚放逸嫉妒。无有日月昼夜时节。犹如第二忉利天上。其土人民等有光明。各各无有憍慢之心。一切悉是菩萨大士。皆得神通具大功德。其心悉皆尊重正法。乘于大乘爱念大乘。贪乐大乘护惜大乘。大慧成就得大总持。心常怜愍一切众生。其佛号曰满月光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。随所住处有所讲宣。其土众生无不得闻为琉璃光菩萨摩诃萨。讲宣如是大涅槃经。佛言。善男子。菩萨摩诃萨若能修行大涅槃经。所不闻者皆悉得闻。彼琉璃光菩萨摩诃萨问满月光明佛。亦如此间光明遍照高贵德王菩萨摩诃萨所问等无有异。彼满月光明佛即告琉璃光菩萨言。善男子。西方去此二十恒河沙佛土。彼有世界名曰娑婆。其土多有山陵堆阜土沙砾石荆蕀恶刺周遍充满。常有饥渴寒热苦恼。其土人民不能恭敬沙门婆罗门父母师长。贪着非法欲于非法。修行邪法不信正法。寿命短促有行奸诈。王者治之。王虽有国不知满足。于他所有生贪利心。兴师相伐枉死者众。王者修行如是非法。四天善神心无欢喜故降灾旱。谷米不登人民多病苦恼无量。彼中有佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。大悲纯厚愍众生故。于拘尸那城娑罗双树间。为诸大众敷演如是大涅槃经。彼有菩萨名光明遍照高贵德王。已问斯事如汝无异。佛今答之汝可速往自当得闻。世尊。彼琉璃光菩萨闻是事已。与八万四千菩萨摩诃萨欲来至此。故先现瑞以是因缘有此光明。是名因缘亦非因缘

尔时琉璃光菩萨与八万四千诸菩萨俱。持诸幡盖香花璎珞种种伎乐倍胜于前。俱来至此拘尸那城娑罗双树间。以己所持供养之具供养于佛。头面礼足合掌恭敬右绕三匝。修敬已毕却坐一面

尔时世尊问彼菩萨。善男子。汝为到来为不到来。琉璃光菩萨言。世尊到亦不来不到亦不来。我观是义都无有来。世尊。诸行若常亦复不来。若是无常亦无有来。若人见有众生性者有来不来。我今不见众生定性。云何当言有来不来。有憍慢者见有去来。无憍慢者则无去来。有取行者见有去来。无取行者则无去来。若见如来毕竟涅槃则有去来。不见如来毕竟涅槃则无去来。不闻佛性则有去来。闻佛性者则无去来。若见声闻辟支佛人有涅槃者则有去来。不见声闻辟支佛人有涅槃者则无去来。若见声闻辟支佛人常乐我净则有去来。若不见者则无去来。若见如来无常乐我净则有去来。若见如来常乐我净则无去来。世尊。且置斯事。欲有所问。唯垂哀愍少见听许。佛言。善男子。随意所问。今正是时。我当为汝分别解说。所以者何。诸佛难值如优昙花。法亦如是难可得闻。十二部中方等复难。是故应当专心听受。时琉璃光菩萨摩诃萨。既蒙听许兼被诫敕即白佛言。世尊。云何菩萨摩诃萨有能修行大涅槃经闻所不闻。尔时如来赞言。善哉善哉。善男子。汝今欲尽如是大乘大涅槃海。正复值我能善解说。汝今所有疑网毒箭。我为大医能善拔出。汝于佛性犹未明了。我有慧炬能为照明。汝今欲渡生死大河。我能为汝作大船师。汝于我所生父母想。我亦于汝生赤子心。汝心今者贪正法宝。值我多有能相惠施。谛听谛听。善思念之。吾当为汝分别宣释。善男子。欲听法者今正是时。若闻法已当生敬信至心听受恭敬尊重。于正法所莫求其过。莫念贪欲嗔恚愚痴。莫观法师种姓好恶。既闻法已莫生憍慢。莫为恭敬名誉利养。当为度世甘露法利。亦莫生念。我听法已先自度身然后度人。先自解身然后解人先自安身然后安人。先自涅槃然后令人而得涅槃。于佛法僧应生等想。于生死中生大苦想。于大涅槃应生常乐我净之想。先为他人然后为身。当为大乘莫为二乘。于一切法当无所住。亦莫专执一切法相。于诸法中莫生贪想。常生知法见法之想。善男子。汝能如是至心听法。是则名为闻所不闻。善男子。有不闻闻。有不闻不闻。有闻不闻。有闻闻。善男子。如不生生不生不生生不生生生。如不到到不到不到到不到到到。世尊。云何不生生。善男子。安住世谛初出胎时。是名不生生。云何不生不生。善男子。是大涅槃无有生相。是名不生不生。云何生不生。善男子。世谛死时是名生不生。云何生生。善男子。一切凡夫是名生生。何以故。生生不断故。一切有漏念念生故。是名生生。四住菩萨名生不生。何以故。生自在故是名生不生。善男子。是名内法。云何外法。未生生。未生未生。生未生。生生。善男子。譬如种子未生牙时。得四大和合人功作业然后乃生。是名未生生。云何未生未生。譬如败种及未遇缘。如是等辈名未生未生。云何生未生。如牙生已而不增长。是名生未生。云何生生。如牙增长。若生不生则无增长。如是一切有漏是名外法生生。琉璃光菩萨摩诃萨白佛言。世尊。有漏之法若有生者为是常耶是无常乎。生若是常有漏之法则无有生。生若无常则有漏是常。世尊。若生能自生生无自性。若能生他以何因缘不生无漏。世尊。若未生时有生者。云何于今乃名为生。若未生时无生者。何故不说虚空为生。佛言。善哉善哉。善男子。不生生不可说。生生亦不可说。生不生亦不可说。不生不生亦不可说。生亦不可说。不生亦不可说。有因缘故亦可得说。云何不生生不可说。不生名为生云何可说。何以故。以其生故。云何生生不可说。生生故生生生故不生亦不可说。云何生不生不可说。生即名为生。生不自生故不可说。云何不生。不生不可说不生者名为涅槃。涅槃不生故不可说。何以故。以修道得故。云何生亦不可说。以生无故。云何不生不可说。以有得故。云何有因缘故亦可得说。十因缘法为生作因。以是义故亦可得说。善男子。汝今莫入甚深空定。何以故。大众钝故。善男子。有为之法生亦是常。以住无常生亦无常。住亦是常。以生生故住亦无常。异亦是常。以法无常异亦无常。坏亦是常。以本无今有故。坏亦无常。善男子。以性故。生住异坏皆悉是常。念念灭故。不可说常。是大涅槃能断灭故。故名无常。善男子。有漏之法未生之时。已有生性故生能生。无漏之法本无生性。是故生不能生。如火有本性遇缘则发。眼有见性因色因明因心故见。众生生法亦复如是。由本有性遇业因缘父母和合则便有生

尔时琉璃光菩萨摩诃萨及八万四千菩萨摩诃萨闻是法已。踊在虚空高七多罗树。恭敬合掌而白佛言。世尊。我蒙如来殷勤教诲。因大涅槃始得悟解闻所不闻。亦令八万四千菩萨深解诸法不生生等。世尊。我今已解断诸疑网。然此会中有一菩萨名曰无畏。复欲咨禀唯垂听许。尔时世尊告无畏菩萨。善男子。随意问难。吾当为汝分别解说。尔时无畏菩萨与六万(一本云与八万)四千诸菩萨等。俱从座起更整衣服。长跪合掌而白佛言。世尊此土众生当造何业而得生彼不动世界。其土菩萨云何而得智慧成就。人中象王有大威德。具修诸行利智捷疾闻则能解。尔时世尊即说偈言

  不害众生命　　坚持诸禁戒
  受佛微妙教　　则生不动国
  不夺他人财　　常施惠一切
  造招提僧坊　　则生不动国
  不犯他妇女　　自妻不非时
  施持戒卧具　　则生不动国
  不为自他故　　求利及恐怖
  慎口不妄语　　则生不动国
  莫坏善知识　　远离恶眷属
  口常和合语　　则生不动国
  如诸菩萨等　　常离于恶口
  所说人乐闻　　则生不动国
  乃至於戏笑　　不说非时语
  谨慎常时语　　则生不动国
  见他得利养　　常生欢喜心
  不起嫉妒结　　则生不动国
  不恼于众生　　常生于慈心
  不生方便恶　　则生不动国
  邪见言无施　　父母及去来
  不起如是见　　则生不动国
  旷路作好井　　种殖果树林
  常施乞者食　　则生不动国
  若于佛法僧　　供养一香灯
  乃至献一花　　则生不动国
  若为恐怖故　　利养及福德
  书是经一偈　　则生不动国
  若为悕利福　　能于一日中
  读诵是经典　　则生不动国
  若为无上道　　一日一夜中
  受持八戒斋　　则生不动国
  不与犯重禁　　同共一处住
  呵谤方等者　　则生不动国
  若能施病者　　乃至于一果
  欢喜而瞻视　　则生不动国
  不犯僧鬘物　　善守于佛物
  涂扫佛僧地　　则生不动国
  造像若佛塔　　犹如大拇指
  常生欢喜心　　则生不动国
  若为是经典　　自身及财宝
  施于说法者　　则生不动国
  若能听书写　　受持及读诵
  诸佛秘密藏　　则生不动国

尔时无畏菩萨摩诃萨白佛言。世尊。我今已知所造业缘得生彼国。是光明遍照高贵德王菩萨摩诃萨。普为怜愍一切众生。先所咨问。如来若说则能利益安乐人天阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽等。尔时世尊即告光明遍照高贵德王菩萨。善哉善哉。善男子。汝今于此当至心听。吾当为汝分别解说。有因缘故未到不到。有因缘故不到到。有因缘故到不到。有因缘故到到。何因缘故未到不到。善男子。夫不到者。是大涅槃凡夫未到。以有贪欲嗔恚愚痴故。身业口业不清净故。及受一切不净物故。犯四重故。谤方等故。一阐提故。五逆罪故。以是义故未到不到。善男子。何因缘故不到到。不到者名大涅槃。何义故到。永断贪欲嗔恚愚痴身口恶故。不受一切不净物故。不犯四重故。不谤方等经故。不作一阐提故。不作五逆罪故。以是义故名不到到。须陀洹者八万劫到。斯陀含者六万劫到。阿那含者四万劫到。阿罗汉者二万劫到。辟支佛者十千劫到。以是义故名不到到。善男子。何因缘故名到不到。到者名为二十五有。一切众生常为无量烦恼诸结之所覆蔽。往来不离犹如轮转。是名为到。声闻缘觉及诸菩萨已得永离。故名不到。为欲化度诸众生故示现在中。亦名为到。善男子。何因缘故名为到到。到者即是二十五有。一切凡夫须陀洹乃至阿那含烦恼因缘故名到到。善男子。闻所不闻亦复如是。有不闻闻。有不闻不闻。有闻不闻。有闻闻。云何不闻闻。善男子。不闻者名大涅槃。何故不闻。非有为故。非音声故。不可说故。云何亦闻。得闻名故。所谓常乐我净。以是义故名不闻闻。尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如佛所说。大涅槃者不可得闻。云何复言常乐我净而可得闻。何以故。世尊。断烦恼者名得涅槃。若未断者名为不得。以是义故涅槃之性本无今有。若世间法本无今有则名无常。譬如瓶等本无今有。已有还无故名无常。涅槃若尔云何说言常乐我净。复次世尊。凡因庄严而得成者。悉名无常。涅槃若尔应是无常。何等因缘。所谓三十七品六波罗蜜四无量心观于骨相阿那波那六念处破析六大。如是等法皆是成就涅槃因缘故名无常。复次世尊。有名无常。若涅槃是有亦应无常。如佛昔于阿含中说声闻缘觉诸佛世尊皆有涅槃。以是义故名为无常。复次世尊。可见之法名为无常。如佛先说。见涅槃者则得断除一切烦恼。复次世尊。譬如虚空于诸众生等无障碍故名无常。若使涅槃是常等者。何故众生有得不得涅槃若尔于诸众生不平等者则不名常。世尊。譬如百人共有一怨若害此怨则多人受乐。若使涅槃是平等法。一人得时应多人得。一人断结应多人亦断。若不如是云何名常。譬如有人恭敬供养尊重赞叹国王王子父母师长则得利养。是不名常。涅槃亦尔不名为常。何以故。如佛昔于阿含经中告阿难言。若有人能恭敬涅槃。则得断结受无量乐。以是义故不名为常。世尊。若涅槃中有常乐我净名者。不名为常。如其无者云何可说

尔时世尊告光明遍照高贵德王菩萨摩诃萨言。涅槃之体非本无今有。若涅槃体本无今有者。则非无漏常住之法。有佛无佛性相常住。以诸众生烦恼覆故不见涅槃。便谓为无。菩萨摩诃萨以戒定慧熏修其心。断烦恼已便得见之。当知涅槃是常住法非本无今有。是故为常。善男子。如闇室中井种种七宝。人亦知有闇故不见。有智之人善知方便。然大明灯持往照了悉得见之。是人于此终不生念水及七宝本无今有。涅槃亦尔本自有之非适今也。烦恼闇故众生不见。大智如来以善方便燃智慧灯。令诸菩萨得见涅槃常乐我净。是故智者于此涅槃不应说言本无今有。善男子。汝言因庄严故得成涅槃应无常者。是亦不然。何以故。善男子。涅槃之体非生非出非实非虚。非作业生。非是有漏有为之法。非闻非见。非堕非死。非别异相亦非同相。非往非还非去来今。非一非多非长非短。非圆非方非尖非斜。非有相非无相。非名非色。非因非果。非我我所。以是义故涅槃是常恒不变易。是以无量阿僧祇劫。修集善法以自庄严然后乃见。善男子。譬如地下有八味水一切众生而不能得。有智之人施功穿掘则便得之。涅槃亦尔。譬如盲人不见日月良医疗之则便得见。而是日月非是本无今有。涅槃亦尔。先自有之非适今也。善男子。如人有罪系之囹圄久乃得出还家得见父母兄弟妻子眷属。涅槃亦尔。善男子。汝言因缘故涅槃之法应无常者。是亦不然。何以故。善男子。因有五种。何等为五。一者生因。二者和合因。三者住因。四者增长因。五者远因。云何生因。生因者。即是业烦恼等及外诸草木子。是名生因云何和合因。如善与善心和合。不善与不善心和合。无记与无记心和合。是名和合因。云何住因。如下有柱屋则不堕山河树木因大地故而得住立。内有四大无量烦恼众生得住。是名住因。云何增长因。因缘衣服饮食等故令众生增长。如外种子火所不烧鸟所不食则得增长。如诸沙门婆罗门等依因和上善知识等而得增长。如因父母子得增长。是名增长因。云何远因。譬如因咒鬼不能害毒不能中。依凭国王无有盗贼。如芽依因地水火风等。如水攒及人为酥远因。如明色等为识远因。父母精血为众生远因。如时节等悉名远因。善男子。涅槃之体非是如是五因所成。云何当言是无常因。复次善男子。复有二因。一者作因。二者了因。如陶师轮绳。是名作因。如灯烛等照闇中物。是名了因。善男子。大涅槃者不从作因而有。唯从了因。了因者。所谓三十七助道法六波罗蜜。是名了因。善男子。布施者是涅槃因非大涅槃因。檀波罗蜜乃得名为大涅槃因。三十七品是涅槃因非大涅槃因。无量无边阿僧祇劫菩提法乃得名为大涅槃因。尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。云何布施不得名为檀波罗蜜。云何布施而得名之檀波罗蜜。乃至般若云何不得名为般若波罗蜜。云何得名为般若波罗蜜。云何名涅槃。云何名大涅槃

佛言。善男子。菩萨摩诃萨修行方等大般涅槃。不闻布施不见布施。不闻檀波罗蜜不见檀波罗蜜。乃至不闻般若不见般若。不闻般若波罗蜜不见般若波罗蜜不闻涅槃不见涅槃。不闻大涅槃不见大涅槃。菩萨摩诃萨修大涅槃知见法界。解了实相空无所有。无有和合觉知之相。得无漏相无所作相如幻化相热时炎相乾闼婆城虚空之相。菩萨尔时得如是相。无贪恚痴不闻不见。是名菩萨摩诃萨真实之相安住实相。菩萨摩诃萨自知此是檀此是檀波罗蜜。乃至此是般若此是般若波罗蜜。此是涅槃此是大涅槃

善男子。云何是施非波罗蜜。见有乞者然后乃与。是名为施非波罗蜜。若无乞者开心自施。是则名为檀波罗蜜。若时时施是名为施非波罗蜜。若修常施是则名为檀波罗蜜。若施他已还生悔心。是名为施非波罗蜜。施已不悔是则名为檀波罗蜜。菩萨摩诃萨于财物中生四怖心。王贼水火。欢喜施与是则名为檀波罗蜜。若望报施是名为施非波罗蜜。施不望报是则名为檀波罗蜜。若为恐怖名闻利养家法相续天上五欲。为憍慢故。为胜慢故。为知识故。为来报故。如市易法。善男子。如人种树为得荫凉为得花果及以材木。若人修行如是等施。是名为施非波罗蜜

菩萨摩诃萨修行如是大涅槃者。不见施者受者财物。不见时节。不见福田及非福田。不见因不见缘。不见果报。不见作者。不见受者。不见多不见少。不见净不见不净。不轻受者己身财物。不见见者不见不见者。不计己他。唯为方等大般涅槃常住法故修行布施。为利一切诸众生故而行布施。为断一切众生烦恼故行于施。为诸众生不见受者施者财物故行于施。善男子。譬如有人堕大海水抱持死尸则得度脱。菩萨摩诃萨修大涅槃。行布施时亦复如是如彼死尸。善男子。譬如有人闭在深狱门户坚牢唯有厕孔便从中出到无碍处。菩萨摩诃萨修大涅槃。行布施时亦复如是。善男子。譬如贵人恐怖急厄更无恃怙依旃陀罗。菩萨摩诃萨修大涅槃。行于布施亦复如是。善男子。譬如病人为除病苦得安乐故服食不净。菩萨摩诃萨修大涅槃。行于布施亦复如是。善男子。如婆罗门值谷勇贵为寿命故食啖狗肉。菩萨摩诃萨修大涅槃。行于布施亦复如是。善男子。大涅槃中如是之事。从无量劫来不闻而闻。尸罗尸罗波罗蜜。乃至般若般若波罗蜜。如佛杂花经中广说善男子。云何菩萨摩诃萨修大涅槃不闻而闻。十二部经其义深邃昔来不闻。今因是经得具足闻。先虽得闻唯闻名字。而今于此大涅槃经乃得闻义。声闻缘觉唯闻十二部经名字不闻其义。今于此经具足得闻。是名不闻而闻。善男子。一切声闻缘觉经中。不曾闻佛有常乐我净不毕竟灭。三宝佛性无差别相。犯四重罪谤方等经作五逆罪及一阐提悉有佛性。今于此经而得闻之。是名不闻而闻

大般涅槃经卷第十九大般涅槃经卷第二十

        宋代沙门慧严等依泥洹经加之

    高贵德王菩萨品之二

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。若犯重禁谤方等经作五逆罪一阐提等有佛性者。是等云何复堕地狱。世尊。若使是等有佛性者。云何复言无常乐我净。世尊。若断善根名一阐提者。断善根时所有佛性云何不断。佛性若断云何复言常乐我净。如其不断何故名为一阐提耶。世尊。犯四重禁名为不定。谤方等经作五逆罪。及一阐提悉名不定。如是等辈若决定者。云何得成阿耨多罗三藐三菩提从须陀洹乃至辟支佛亦名不定。若须陀洹至辟支佛是决定者。亦不应成阿耨多罗三藐三菩提。世尊。若犯四重不决定者。须陀洹乃至辟支佛亦不决定。如是不定诸佛如来亦复不定。若佛不定涅槃体性亦复不定。至一切法亦复不定。云何不定。若一阐提除一阐提则成佛道。诸佛如来亦应如是入涅槃已。亦应还出不入涅槃。若如是者涅槃之性则为不定。不决定故。当知无有常乐我净。云何说言一阐提等当得涅槃。尔时世尊告光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。为欲利益无量众生令得安乐。怜愍慈念诸世间故。为欲增长发菩提心诸菩萨故。作如是问。善男子。汝已亲近过去无量诸佛世尊。于诸佛所种诸善根。久已成就菩提功德。降伏众魔令其退散。已教无量无边众生。悉令得至阿耨多罗三藐三菩提。久已通达诸佛如来所有甚深秘密之藏。已问过去无量无边恒河沙等诸佛世尊如是甚深微密之义。我都不见一切世间若人若天沙门婆罗门若魔若梵有能咨问如来是义。今当诚心谛听谛听。吾当为汝分别演说。善男子。一阐提者亦不决定。若决定者是一阐提终不能得阿耨多罗三藐三菩提。以不决定是故能得。如汝所言。佛性不断。云何一阐提断善根者。善男子。善根有二种。一者内。二者外。佛性非内非外。以是义故佛性不断。复有二种。一者有漏。二者无漏。佛性非有漏非无漏。是故不断。复有二种。一者常。二者无常。佛性非常非无常。是故不断。若是断者则应还得。若不还得则名不断。若断已得名一阐提。犯四重者亦是不定。若决定者犯四重禁终不能得阿耨多罗三藐三菩提。谤方等经亦复不定。若决定者谤正法人终不能得阿耨多罗三藐三菩提。作五逆罪亦复不定。若决定者五逆之人终不能得阿耨多罗三藐三菩提。色与色相二俱不定。香味触相生相至无明相阴入界相二十五有相四生乃至一切诸法皆亦不定。善男子。譬如幻师在大众中。化作四兵车步象马。作诸璎珞严身之具城邑聚落山林树木泉池河井。而彼众中有诸小儿无有智慧睹见之时悉以为实。其中智人知其虚诳。以幻力故惑人眼目。善男子。一切凡夫乃至声闻辟支佛等。于一切法见有定相亦复如是。诸佛菩萨于一切法不见定相。善男子。譬如小儿于盛夏月见热时焰谓之为水。有智之人于此热焰终不生于实水之想。但是虚焰诳人眼目非实是水。一切凡夫声闻缘觉。见一切法亦复如是悉谓是实。诸佛菩萨于一切法不见定相。善男子。譬如山涧因声有响小儿闻之谓是实声。有智之人解无定实但有声相诳于耳识。善男子。一切凡夫声闻缘觉。于一切法亦复如是见有定相。诸菩萨等解了诸法悉无定相。见无常相空寂等相无生灭相。以是义故。菩萨摩诃萨见一切法是无常相。善男子。亦有定相。云何为定。常乐我净。在何处耶。所谓涅槃。善男子。须陀洹果亦复不定。不决定故经八万劫得阿耨多罗三藐三菩提心。斯陀含果亦复不定。不决定故经六万劫得阿耨多罗三藐三菩提心。阿那含果亦复不定。不决定故经四万劫得阿耨多罗三藐三菩提心。阿罗汉果亦复不定。不决定故经二万劫得阿耨多罗三藐三菩提心。辟支佛道亦复不定。不决定故经十千劫得阿耨多罗三藐三菩提心。善男子。如来今于拘尸那城娑罗双树间。示现倚卧师子之床欲入涅槃。令诸未得阿罗汉果众弟子等及诸力士生大忧苦。亦令天人阿修罗乾闼婆迦楼罗紧那罗摩睺罗迦等大设供养。欲使诸人以千端[疊*毛]缠裹其身七宝为棺盛满香油积诸香木以火焚之。唯除二端不可得烧。一者儭身。二最在外。为诸众生分散舍利以为八分。一切所有声闻弟子。咸言如来入于涅槃。当知如来亦不毕定入于涅槃。何以故。如来常住不变易故。以是义故如来涅槃亦复不定。善男子。当知如来亦复不定。如来非天。何以故。有四种天。一者世间天。二者生天。三者净天。四者义天。世间天者如诸国王。生天者从四天王乃至非有想非无想天。净天者从须陀洹至辟支佛。义天者十住菩萨摩诃萨等。以何义故十住菩萨名为义天。以能善解诸法义故。云何为义。见一切法是空义故善男子。如来非王亦非四天乃至非有想非无想天从须陀洹至辟支佛十住菩萨。以是义故如来非天。然诸众生亦复称佛为天中天。是故如来非天非非天。非人非非人。非鬼非非鬼。非地狱畜生饿鬼。非非地狱畜生饿鬼。非众生非非众生。非法非非法。非色非非色。非长非非长非短非非短。非相非非相。非心非非心。非有漏非无漏。非有为非无为。非常非无常。非幻非非幻。非名非非名。非定非非定。非有非无。非说非非说。非如来非不如来。以是义故如来不定。善男子。何故如来不名世天。世天者即是诸王。如来久于无量劫中已舍王位。是故非王。非非王者如来生于迦毗罗城净饭王家。是故非非王。非生天者如来久已离诸有故。是故非生天。非非生天。何以故。升兜率天下阎浮提故。是故如来非非生天。亦非净天。何以故。如来非是须陀洹乃至非辟支佛。是故如来非是净天。非非净天。何以故。世间八法所不能染。犹如莲花不受尘水。是故如来非非净天。亦非义天。何以故如来非是十住菩萨故。是故如来非义天也。非非义天。何以故。如来常修十八空义故。是故如来非非义天。如来非人。何以故如来久于无量劫中离人有故。是故非人。亦非非人。何以故。生于迦毗罗城故。是故非非人。如来非鬼。何以故。不害一切诸众生故。是故非鬼。亦非非鬼。何以故。亦以鬼像化众生故。是故非非鬼。如来亦非地狱畜生饿鬼。何以故。如来久离诸恶业故。是故非地狱畜生饿鬼。亦非非地狱畜生饿鬼。何以故。如来亦复现受三恶诸趣之身化众生故。是故非非地狱畜生饿鬼。亦非众生。何以故。久已远离众生性故。是故如来非众生。亦非非众生。何以故。或时演说众生相故。是故如来非非众生。如来非法。何以故。诸法各各有别异相。如来不尔唯有一相。是故非法。亦非非法。何以故。如来法界故。是故非非法。如来非色。何以故。十色入所不摄故。是故非色。亦非非色。何以故。身有三十二相八十种好故。是故非非色。如来非长。何以故。断诸色故。是故非长。亦非非长。何以故。一切世间无有能见顶髻相故。是故非非长。如来非短。何以故。久已远离憍慢结故。是故非短。亦非非短。何以故。为瞿师罗长者示三尺身故。是故非非短。如来非相。何以故。久已远离诸相相故。是故非相。亦非非相。何以故。善知诸相故。是故非非相。如来非心。何以故。虚空相故。是故非心。亦非非心。何以故。有十力心法故。亦能知他众生心故。是故非非心。如来非有为。何以故。常乐我净故。是故非有为。亦非无为。何以故。有来去坐卧示现涅槃故。是故非无为。如来非常。何以故。身有分故。是故非常。云何非常。以有知故。常法无知犹如虚空。如来有知。是故非常。云何非常。有言说故。常法无言亦如虚空。如来有言。是故无常。有姓氏故名曰无常。无姓之法乃名为常。虚空常故无有姓氏。如来有姓姓瞿昙氏。是故无常。有父母故名曰无常。无父母者乃名曰常。虚空常故无有父母。佛有父母是故无常。有四威仪名曰无常。无四威仪乃名曰常。虚空常故无四威仪。佛有四仪是故无常。常住之法无有方所。虚空常故无有方所。如来出在东天竺地住舍婆提或王舍城。是故无常。以是义故如来非常。亦非非常。何以故生永断故。有生之法名曰无常。无生之法乃名为常。如来无生。是故为常。常法无性。有性之法名曰无常。如来无生无性。无生无性故常。有常之法遍一切处。犹如虚空无处不有。如来亦尔遍一切处。是故为常。无常之法或言此有或言彼无。如来不尔。不可说言是处有彼处无。是故为常。无常之法有时是有有时是无。如来不尔有时是有有时是无。是故为常。常住之法无名无色。虚空常故无名无色。如来亦尔无名无色。是故为常。常住之法无因无果。虚空常故无因无果。如来亦尔无因无果。是故为常。常住之法三世不摄。如来亦尔三世不摄。是故为常。如来非幻。何以故。永断一切虚诳心故。是故非幻。亦非非幻。何以故。如来或时分此一身为无量身。无量之身复为一身。出壁直过无有障碍。履水如地入地如水。行空如地。身出烟焰如大火聚。云雷震动其声可畏。或为城邑聚落舍宅山川树木。或作大身。或作小身男身女身童男童女身。是故如来亦非非幻。如来非定。何以故。如来于此拘尸那城娑罗双树间。示现入于般涅槃故。是故非定。亦非非定。何以故。常乐我净故。是故如来亦非非定。如来非有漏。何以故。断三漏故。故非有漏。三漏者欲界一切烦恼除无明。是名欲漏。色无色界一切烦恼除无明。是名有漏。三界无明名无明漏。如来永断是故非漏。复次一切凡夫不见有漏。云何凡夫不见有漏。一切凡夫于未来世悉有疑心。未来世中当得身耶不得身耶。过去世中身本有耶为本无耶现在世中是身有耶是身无耶。若有我者。是色耶。非色耶。色非色耶。非色非非色耶。想耶。非想耶。想非想耶。非想非非想耶。是身属他耶。不属他耶。属不属耶。非属非不属耶。有命无身耶。有身无命耶。有身有命耶。无身无命耶。身之与命有常耶。无常耶。常无常耶。非常非无常耶。身之与命自在作耶。时节作耶。无因作耶。世性作耶。微尘作耶。法非法作耶。士夫作耶。烦恼作耶。父母作耶。我住心耶。住眼中耶。遍满身中耶。从何来耶。去何至耶。谁生耶。谁死耶。我于过去是婆罗门姓耶。是刹利姓耶。是毗舍姓耶。是首陀罗姓耶。当于未来得何姓耶。我此身者过去之时。是男身耶。是女身耶。畜生身耶。若我杀生。当有罪耶。当无罪耶。乃至饮酒。当有罪耶。当无罪耶。我自作耶。为他作耶。我受报耶。身受报耶。如是疑见无量烦恼覆众生心。因是疑见生六种心。决定有我。决定无我。我见我。我见无我。无我见我。我作我受我知。是名邪见。如来永拔如是无量见漏根本。是故非漏。善男子。菩萨摩诃萨于大涅槃修圣行者。亦得永断如是诸漏。诸佛如来常修圣行。是故无漏善男子。凡夫不能善摄五根则有三漏。为恶所牵至不善处。善男子。譬如恶马其性佷悷能令乘者至险恶处。不能善摄此五根者亦复如是。令人远离涅槃善道至诸恶处。譬如恶象心未调顺。有人乘之不随意去。远离城邑至空旷处。不能善摄此五根者亦复如是。将人远离涅槃城邑。至于生死旷野之处。善男子。譬如佞臣教王作恶。五根佞臣亦复如是。常教众生造无量恶。善男子。譬如恶子不受师长父母教敕则无恶不造。不调五根亦复如是。不受师长善言教敕无恶不造。善男子。凡夫之人不摄五根。常为地狱畜生饿鬼之所贼害。亦如怨盗害及善人。善男子。凡夫之人不摄五根驰骋五尘。譬如牧牛不善守护犯人苗稼。凡夫之人不摄五根。常在诸有多受苦恼。善男子。菩萨摩诃萨修大涅槃行圣行时。常能善调守摄五根。怖畏贪欲嗔恚愚痴憍慢嫉妒。为得一切诸善法故。善男子。若能善守此五根者则能摄心。若能摄心则摄五根。譬如有人拥护于王则护国土护国土者则护于王。菩萨摩诃萨亦复如是。若得闻是大涅槃经则得智慧。得智慧故则得专念。五根若散念则能止。何以故。是念慧故。善男子。如善牧者设牛东西啖他苗稼则便遮止不令犯暴。菩萨摩诃萨亦复如是。念慧因缘故守摄五根不令驰散。菩萨摩诃萨有念慧者。不见我相不见我所相。不见众生及所受用。见一切法同法性相。生于土石瓦砾之相。譬如屋舍从众缘生无有定性。见诸众生四大五阴之所成立。推无定性。无定性故菩萨于中不生贪着。一切凡夫见有众生故起。烦恼。菩萨摩诃萨修大涅槃有念慧故。于诸众生不生贪着。复次菩萨摩诃萨修大涅槃经者。不着众生相作种种法相。善男子。譬如画师以众杂彩画作众像若男若女若牛若马。凡夫无知见之则生男女等相。画师了知无有男女。菩萨摩诃萨亦复如是。于法异相观于一相。终不生于众生之相。何以故。有念慧故。菩萨摩诃萨修大涅槃。或时睹见端正女人。终不生于贪着之心。何以故善观相故。善男子。菩萨摩诃萨知五欲法无有欢乐不得暂停。如犬啮枯骨。如人持火逆风而行。如箧毒蛇。梦中所得路边果树多人所掷。亦如段肉众乌竞逐。如水上泡画水之迹。如织经尽。如囚趣市。犹如假借势不得久。观欲如是多诸过恶。复次善男子。菩萨摩诃萨观诸众生。为色香味触因缘故。从昔无数无量劫来常受苦恼。一一众生一劫之中。所积身骨如王舍城毗富罗山。所饮乳汁如四海水。身所出血复多四海水。父母兄弟妻子眷属。命终哭泣所出目泪多四大海。尽地草木斩以为筹。以数父母亦不能尽。无量劫来或在地狱畜生饿鬼。所受行苦不可称计。抟此大地犹如枣等易可穷极。生死无量不可得尽。菩萨摩诃萨如是深观一切众生欲因缘故受苦无量。菩萨观是生死行苦故不失念慧。善男子。譬如世间有诸大众满二十五里。王敕一臣持一油钵。经由中过莫令倾覆。若弃一渧当断汝命。复遣一人拔刀在后随而怖之。臣受王教尽心坚持。经历尔所大众之中。虽见可意五邪欲等。心常念言。我若放逸着彼邪欲。当弃所持命不全济。是人以是怖因缘故。乃至不弃一渧之油。菩萨摩诃萨亦复如是。于生死中不失念慧。以不失故虽见五欲心不贪着。若见净色不生色相。唯观苦相。乃至识相亦复如是。不作生相不作灭相。不作因相观和合相。菩萨尔时五根清净。根清净故护根戒具。一切凡夫五根不净不能善持。名曰根漏。菩萨永断是故无漏。如来拔出永断根本。是故非漏。复次善男子。复有离漏。菩萨摩诃萨欲为无上甘露佛果故离于恶漏。云何为离。若能修行大涅槃经书写受持读诵解说思惟其义。是名为离。何以故。善男子。我都不见十二部经能离恶漏如此方等大涅槃经。善男子。譬如良师教诸弟子。诸弟子中有受教者心不造恶。菩萨摩诃萨修大涅槃微妙经典。亦复如是心不造恶。善男子。譬如世间有善咒术。若有一闻却后七年不为一切毒药所中。蛇不能螫。若有诵者乃至命尽无有众恶。善男子。是大涅槃亦复如是。若有众生一经耳者。却后七劫不堕恶道。若有书写读诵解说思惟其义。必得阿耨多罗三藐三菩提。净见佛性如彼圣王得甘露味。善男子。是大涅槃有如是等无量功德。善男子。若有人能书写是经。读诵解说为他敷演思惟其义。当知是人真我弟子善受我教。是我所见我之所念。是人谛知我不涅槃。随如是人所住之处若城邑聚落山林旷野房舍田宅楼阁殿堂。我亦在中常住不移。我于是人常作受施。或作比丘比丘尼优婆塞优婆夷婆罗门梵志贫穷乞人。云何当令是人得知如来受其所施之物。善男子。是人或于夜卧梦中梦见佛像。或见天像沙门之像国主圣王师子王像莲花形像优昙花像。或见大山或大海水。或见日月或见白象及白马像。或见父母。得花得果金银琉璃颇梨等宝五种牛味。尔时当知即是如来受其所施。寤已喜乐寻得种种所须之物。心不念恶乐修善法。善男子。是大涅槃悉能成就如是无量阿僧祇等不可思议无边功德。善男子。汝今应当信受我语。若有善男子善女人。欲见我者欲恭敬我。欲同法性而见于我。欲得空定。欲见实相。欲得修习首楞严定师子王定。欲破八魔。八魔者。所谓四魔无常无乐无我无净。欲得人中天上乐者。见有受持大涅槃经书写读诵为他解说思惟义者。当往亲近依附咨受供养恭敬尊重赞叹。为洗手足布置床席四事供给令无所乏。若从远来应十由延路次奉迎。为是经故所重之物应以奉献。如其无者应自卖身。何以故。是经难遇过优昙花。善男子。我念过去无量无边那由他劫。尔时世界名曰娑婆。有佛世尊号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸大众宣说如是大涅槃经。我于尔时从善友所。转闻彼佛当为大众说大涅槃。我闻是已其心欢喜。欲设供养居贫无物。欲自卖身薄福不售。即欲还家路见一人。而便语言。吾欲卖身君能买不。其人答曰我家作业人无堪者。汝设能为我当买汝。我即问言。有何作业人无堪能。其人答言。吾有恶病良医处药。应当日服人肉三两。卿若能以身肉三两日日见给。便当与汝金钱五枚。我时闻已心中欢喜。我复语言。汝与我钱假我七日。须我事讫便还相就。其人答言。七日不可。审能尔者当许一日。善男子。我于尔时即取其钱。还至佛所头面礼足。尽其所有而以奉献。然后诚心听受是经。我时闇钝虽得闻经。唯能受持一偈文句

  如来证涅槃　　永断于生死
  若有至心听　　常得无量乐

受是偈已。即便还至彼病人家。善男子。我时虽复日日与三两肉。以念偈因缘故不以为痛。日日不废足满一月。善男子。以是因缘其病得差。我身平复亦无疮痍。我时见身具足完具即发阿耨多罗三藐三菩提心。一偈之力尚能如是。何况具足受持读诵。我见此经有如是利。复倍发心。愿于未来成得佛道。字释迦牟尼。善男子。以是一偈因缘力故。令我今日于大众中为诸天人具足宣说。善男子。以是因缘是大涅槃不可思议。成就无量无边功德。乃是诸佛如来甚深秘密。之藏。以是义故。能受持者断离恶漏。所谓恶者恶象恶马恶牛恶狗毒蛇住处。恶刺土地悬崖崄岸暴水洄澓恶人恶国恶城恶舍恶知识等。如是等辈。若作漏因。菩萨即离。若不能作则不远离。若增有漏则便离之。若不增长则不远离。若作恶法则便离之。若能作善则不远离。云何为离。不持刀杖常以正慧方便而远离之。是故名为正慧远离为生善法则离恶法。菩萨摩诃萨自观其身。如病如疮如痈。如怨。如箭入体。是大苦聚。悉是一切善恶根本。是身虽复不净如是。菩萨犹故瞻视将养。何以故。非为贪身为善法故。为于涅槃不为生死。为常乐我净不为无常无乐我净。为菩提道不为有道。为于一乘不为三乘。为三十二相八十种好微妙之身。不为乃至非有想非无想身。为法轮王不为转轮王。善男子。菩萨摩诃萨常当护身。何以故。若不护身命则不全。命若不全则不能得书写是经受持读诵为他广说思惟其义。是故菩萨应善护身以是义故。菩萨得离一切恶漏。善男子。如欲渡水善护船筏。临路之人善护良马。田夫种植善护粪秽。如为差毒善护毒蛇。如人为财护旃陀罗。为坏贼故养护健将。亦如寒人爱护于火。如癞病者求于毒药。菩萨摩诃萨亦复如是。虽见是身无量不净具足充满。为欲受持大涅槃经故。犹好将护不令乏少。菩萨摩诃萨观于恶象及恶知识等无有二。何以故。俱坏身故。菩萨摩诃萨于恶象等心无怖惧。于恶知识生畏惧心。何以故。是恶象等唯能坏身不能坏心。恶知识者二俱坏故。是恶象等唯坏一身。恶知识者坏无量善身无量善心。是恶象等唯能破坏不净臭身。恶知识者能坏净身及以净心。是恶象等能坏肉身。恶知识者坏于法身。为恶象杀不至三趣。为恶友杀必至三趣。是恶象等但为身怨。恶知识者为善法怨。是故菩萨常当远离诸恶知识。如是等漏凡夫不离。是故生漏。菩萨离之则不生漏。菩萨如是尚无有漏。况于如来。是故非漏。云何亲近漏。一切凡夫受取衣食卧具医药。为身心乐求如是物造种种恶。不知过味轮回三趣。是故名漏。菩萨摩诃萨见如是过则便远离。若须衣时即便受取不为身故但为于法。不长憍慢心常卑下。不为严饰但为羞耻障诸寒暑恶风恶雨恶虫蚊虻蝇蚤蝮螫。虽受饮食心无贪着。不为身故。常为正法不为肤体。但为众生不为憍慢。为身力故不为怨害。为治饥疮。虽得上味心无贪着。受取房舍亦复如是。贪慢之结不令居心。为菩提舍遮止结贼。障恶风雨故受屋舍。求医药者心无贪慢。但为正法不为寿命。为常命故。善男子。如人病疮为苏糗涂以衣裹之。为出脓血苏糗涂傅。为疮愈故以药坌之。为恶风故在深屋中。菩萨摩诃萨亦复如是。观身是疮故以衣覆。为九孔脓求索饮食。为恶风雨受取房舍。为四毒发求觅医药。菩萨受取四种供养。为菩提道非为寿命。何以故。菩萨摩诃萨作是思惟。我若不受是四供养。身则磨灭不得坚牢。若不坚牢则不忍苦。若不忍苦则不能得修习善法。若能忍苦则得修习无量善法。我若不能堪忍众苦。则于苦受生嗔恚心。于乐受中生贪着心。若求乐不得则生无明。是故凡夫于四供养生于有漏。菩萨摩诃萨能深观察不生于漏。是故菩萨名为无漏。云何如来当名有漏。是故如来不名有漏

复次善男子。一切凡夫虽善护身。心犹故生于三种恶觉。以是因缘虽断烦恼得生非想非非想处。犹故还堕三恶道中。善男子。譬如有人渡于大海垂至彼岸没水而死。凡夫之人亦复如是。垂尽三有还堕三涂。何以故。无善觉故。何等善觉。所谓六念处。凡夫之人善心羸劣不善炽盛。善心羸故慧心薄少。慧心薄故增长诸漏。菩萨摩诃萨慧眼清净见三觉过。知是三觉有种种患。常与众生作三乘怨。三觉因缘乃令无量凡夫众生不见佛性。无量劫中生颠倒心。谓佛世尊无常乐我唯有一净。如来毕竟入于涅槃。一切众生无常无乐无我无净。颠倒心故言有常乐我净。实无三乘。颠倒心故言有三乘。一实之道真实不虚。颠倒心故言无一实。是三恶觉。常为诸佛及诸菩萨之所呵责。是三恶觉常害于我或亦害他。有是三觉一切诸恶常来随从。是三觉者即是三缚。连缀众生无边生死。菩萨摩诃萨常作如是观察三觉。菩萨或时有因缘故应生欲觉默然不受。譬如端正净洁之人不受一切粪秽不净。如热铁丸人无受者。如婆罗门性不受牛肉。如饱满人不受恶食。如转轮王不与一切旃陀罗等同坐一床。菩萨摩诃萨恶贱三觉不受不味亦复如是。何以故。菩萨思惟。众生知我是良福田。我当云何受是恶法。若受恶觉则不任为众生福田。我自不言是良福田。众生见相便言我是。我今若起如是恶觉。则为欺诳一切众生。我于往昔以欺诳故。无量劫中流转生死堕三恶道。我若恶心受人信施。一切天人及五通仙悉当证知而见呵责。我若恶觉受人信施。或令施主果报减少或空无报。我若恶心受檀越施。则与施主而为怨仇。一切施主恒于我所起赤子想。我当云何欺诳于彼而生怨想。何以故。或令施主不得果报或少果报故。我常自称为出家人。夫出家者不应起恶。若起恶者则非出家。出家之人身口相应。若不相应则非出家。我弃父母兄弟妻子眷属知识出家修道。正是修习诸善觉时。非是修习不善觉时。譬如有人入海求宝不取真珠直取水精。亦如有人弃妙音乐游戏粪秽。如舍宝女爱念卑陋。如弃金器而用瓦盂。如弃甘露服食毒药。如舍亲旧贤善良医反从怨憎求药自疗

我亦如是。舍离大师如来世尊甘露法味。而服魔怨种种恶觉。人身难得如优昙花。我今已得。如来难值过优昙花。我今已值。清净法宝难得见闻。我今已闻。犹如盲龟值浮木孔。人命不停过于山水。今日虽存明亦难保。云何纵心令住恶法。壮色不停犹如奔马。云何恃怙而生憍慢。犹如恶鬼伺求人过。四大恶鬼亦复如是。常来伺求我之过失。云何当令恶觉发起。譬如朽宅垂崩之屋。我命亦尔云何起恶。我名沙门。沙门之人名学善觉。我今乃起不善之觉。云何当得名沙门也。我名出家。出家之人名修善道。我今行恶。云何当得名为出家。我今名为真婆罗门。婆罗门者名修净行。我今乃行不净恶觉。云何当得名婆罗门。我今亦名刹利大姓。刹利姓者能除怨敌。我今不能除恶怨敌。云何当得名刹利姓。我名比丘。比丘之人名破烦恼。我今不破恶觉烦恼。云何当得名为比丘。世有六处难可值遇。我今已得。云何当令恶觉居心。何等为六。一佛世难遇。二正法难闻。三怖心难起。四中国难生。五人身难得。六诸根难具。如是六事难得已得。是故不应起于恶觉。菩萨尔时修行如是大涅槃经。常勤观察是诸恶心。一切凡夫不见如是恶心过患故受三觉。名为受漏。菩萨见已不受不着放舍不护。依八圣道推之令去。斩之令断。是故菩萨无有受漏。云何当言如来有漏。以是义故。如来世尊非是有漏

大般涅槃经卷第二十大般涅槃经卷第二十一

        宋代沙门慧严等依泥洹经加之

    光明遍照高贵德王菩萨品之三

复次善男子。凡夫若遇身心苦恼起种种恶。若得身病。若得心病。令身口意作种种恶。以作恶故轮回三趣具受诸苦。何以故。凡夫之人无念慧故。是故生于种种诸漏。是名念漏。菩萨摩诃萨常自思惟。我从往昔无数劫来。为是身心造种种恶。以是因缘流转生死。在三恶道具受众苦。遂令我远三乘正路。菩萨以是恶因缘故。于己身心生大怖畏。舍离众恶趣向善道。善男子。譬如有王以四毒蛇盛之一箧令人养食瞻视卧起摩洗其身。若令一蛇生嗔恚者。我当准法戮之都市。尔时其人闻王切令。心生惶怖舍箧逃走。王时复遣五旃陀罗拔刀随之。其人回顾见后五人遂疾舍去。是时五人以恶方便。藏所持刀密遣一人诈为亲善。而语之言。汝可还来。其人不信投一聚落欲自隐匿。既入聚中窥视诸舍都不见人执诸瓨器悉空无物。既不见人求物不得。即便坐地闻空中声。咄哉男子。此聚空旷无有居民。今夜当有六大贼来。汝设遇者命将不全。汝当云何而得免之。尔时其人恐怖遂增。复舍而去。路值一河。河水漂急无有船筏。以怖畏故即取种种草木为筏。复更思惟。我设住此当为毒蛇五旃陀罗一诈亲者及六大贼之所危害。若渡此河筏不可依当没水死。宁没水死终不为彼蛇贼所害。即推草筏置之水中身倚其上。运手动足截流而去。既达彼岸安隐无患。心意泰然恐怖消除菩萨摩诃萨得闻受持大涅槃经。观身如箧。地水火风如四毒蛇。见毒触毒气毒啮毒。一切众生遇是四毒故丧其命。众生四大亦复如是。或见为恶。或触为恶。或气为恶。或啮为恶。以是因缘远离众善。复次善男子。菩萨摩诃萨观四毒蛇有四种姓。所谓刹利婆罗门毗舍首陀。是四大蛇亦复如是有四种性。坚性湿性热性动性。是故菩萨观是四大与四毒蛇同其种性。复次善男子。菩萨摩诃萨观是四大如四毒蛇。云何为观。是四毒蛇常伺人便。何时当视。何时当触。何时当嘘。何时当啮。四大毒蛇亦复如是。常伺众生求其短缺。若为四蛇之所杀者。终不至于三恶道中。若为四大之所杀害。必至三恶定无有疑。是四毒蛇虽复瞻养亦欲杀人。四大亦尔。虽常供给。亦常牵人造作众恶。是四毒蛇若一嗔者则能杀人。四大之性亦复如是。若一大发亦能害人。是四毒蛇虽同一处四心各异。四大毒蛇亦复如是。虽同一处性各别异。是四毒蛇虽复恭敬难可亲近。四大毒蛇亦复如是。虽复恭敬亦难亲近。是四毒蛇若害人时。或有沙门婆罗门等。若以咒药则可疗治。四大杀人虽有沙门婆罗门等神咒良药。皆不能治。如自喜人闻四毒蛇气臭可恶则便远离。诸佛菩萨亦复如是。闻四大臭即便远离。尔时菩萨复更思惟四大毒蛇生大怖畏。背之驰走修八圣道

五旃陀罗即是五阴。云何菩萨观于五阴如旃陀罗。旃陀罗者常能令人恩爱别离怨憎集会。五阴亦尔。令人贪近不善之法远离一切纯善之法。复次善男子。如旃陀罗种种器仗以自庄严。若刀若楯若弓若箭若铠若槊能害于人。五阴亦尔。以诸烦恼牢自庄严。害诸痴人令堕诸有。善男子。如旃陀罗有过之人得便害之。五阴亦尔。有诸结过常能害人。是故菩萨深观五阴如旃陀罗。复次菩萨观察五阴如旃陀罗。旃陀罗人无慈愍心怨亲俱害。五阴亦尔。无慈愍心善恶俱害。如旃陀罗恼一切人。五阴亦尔。以诸烦恼常恼一切生死众生。是故菩萨观于五阴如旃陀罗。复次菩萨观察五阴如旃陀罗。旃陀罗人常怀害心。五阴亦尔常怀诸结恼害之心。如人无足刀杖侍从。当知必为旃陀罗人之所杀害。众生亦尔。无足无刀无有侍从。则为五阴之所贼害。足名为戒。刀名为慧。侍从名为善知识也。无此三事故为五阴之所贼害是故菩萨观于五阴如旃陀罗。复次善男子。菩萨摩诃萨观察五阴过旃陀罗。何以故。众生若为五旃陀罗之所杀者不堕地狱。为阴杀者则堕地狱以是义故。菩萨观阴过旃陀罗。作是观已而作愿言。我宁终身近旃陀罗。不能暂时亲近五阴。旃陀罗者唯能害于欲界痴人。是五阴贼遍害三界凡夫众生。旃陀罗人唯能杀戮有罪之人。是五阴贼不问众生有罪无罪悉能害之。旃陀罗人不害衰老妇女稚小。是五阴贼不问众生老小女弱一切悉害。是故菩萨深观此阴过旃陀罗。是故发愿。宁当终身近旃陀罗。不能暂时亲近五阴。复次善男子。旃陀罗者唯害他人终不自害。五阴之贼自害害他及旃陀罗。旃陀罗人可以善言钱财宝货求而得脱。五阴不尔。不可强以善言诱喻钱财宝货求而得脱。旃陀罗人于四时中不必常杀。五阴不尔。常于念念害诸众生。旃陀罗人唯在一处可有逃避。五阴不尔。遍一切处无可逃避。旃陀罗人虽复害人害已不随。五阴不尔。杀众生已随逐不离。是故菩萨宁以终身近旃陀罗。不能暂时亲近五阴。有智之人以善方便得脱五阴。善方便者即八圣道六波罗蜜四无量心。以是方便而得解脱。身心不为五阴所害。何以故。身如金刚心如虚空。是故身心难可沮坏。以是义故。菩萨观阴成就种种诸不善法。生大怖畏修八圣道。亦如彼人畏四毒蛇五旃陀罗涉路而去无所顾留

诈亲善者名为贪爱。菩萨摩诃萨深观爱结如怨诈亲。若知实者则无能为。若不能知必为所害。贪爱亦尔若知其性。则不能令众生轮转生死苦中。如其不知轮回六趣具受众苦。何以故。爱之为病难舍离故。如怨诈亲难可远离。怨诈亲者常伺人便。令爱别离怨憎合会。爱亦如是。令人远离一切善法近于一切不善之法。以是义故。菩萨摩诃萨深观贪爱如怨诈亲。见不见故。闻不闻故。如凡夫人见生死过虽有智慧以痴覆故后还不见。声闻缘觉亦复如是。虽见不见虽闻不闻。何以故。以爱心故。所以者何。见生死过不能疾至阿耨多罗三藐三菩提。以是义故。菩萨摩诃萨观此爱结如怨诈亲。云何名为怨诈亲相。如怨不实诈现实相。不可亲近诈现近相。实是不善诈现善相。实是不爱诈为爱相。何以故。常伺人便欲为害故。爱亦如是。常为众生非实诈实。非近诈近。非善诈善。非爱诈爱。常诳一切轮回生死。以是义故。菩萨观爱如怨诈亲。怨诈亲者但见身口不睹其心。是故能诳。爱亦如是。唯为虚诳实不可得。是故能惑一切众生。怨诈亲者有始有终易可远离。爱不如是。无始无终难可远离。怨诈亲者远则难觉近则易知。爱不如是。近尚难知况复远耶。以是义故。菩萨观爱过于诈亲。一切众生以。爱结故远大涅槃近于生死。远常乐我净近无常苦无我不净。是故我于处处经中说为三垢于现在事以无明故。不见过患不能舍离。爱怨诈亲。终不能害有智之人。是故菩萨深观此爱生大怖畏修八圣道。犹如彼人畏四毒蛇五旃陀罗及一诈亲涉路不回

空聚落者即内六入。菩萨摩诃萨观是六入空无所有犹如空聚。如彼怖人既入聚已乃至不见有一居人。遍捉瓨器不得一物。菩萨亦尔。谛观六入空无所有。不见众生一物之实。是故菩萨观内六入空无所有如彼空聚。善男子。彼空聚落群贼远望。终不生于空虚之想。凡夫之人亦复如是。于六入聚不生空想。以其不能生空想故。轮回生死受无量苦。善男子。群贼既至乃生空想。菩萨亦尔。观此六入常生空想。生空想故则不轮回生死受苦。菩萨摩诃萨于此六入常无颠倒。无颠倒故。是故不复轮回生死。复次善男子。如有群贼入此空聚则得安乐。烦恼诸贼亦复如是。入此六入则得安乐。如贼住空聚心无所畏。烦恼群贼亦复如是。住是六入亦无所畏。如彼空聚乃是师子虎狼种种恶兽之所住处。是内六入亦复如是。一切众恶烦恼恶兽之所住处。是故菩萨深观六入空无所有。纯是一切不善住处。复次善男子。菩萨摩诃萨观内六入空无所有如彼空聚。何以故。处诳不实故。空无所有作有想故。实无有乐作乐想故。实无有人作人想故。内六入者亦复如是。空无所有而作有想。实无有乐而作乐想。实无有人而作人想。唯有智人乃能知之得其真实。复次善男子。如空聚落或时有人或时无人。六入不尔。一向无人。何以故。性常空故。智者所知非是眼见。是故菩萨观内六入多诸怨害。修八圣道不休不息。犹如彼人畏四毒蛇五旃陀罗一诈亲善及六大贼怖着正路

六大贼者即外六尘。菩萨摩诃萨观此六尘如六大贼。何以故。能劫一切诸善法故。如六大贼能劫一切人民财宝。是六尘贼亦复如是。能劫一切众生善财。如六大贼若入人舍。则能劫夺现家所有不择好恶。令巨富者忽尔贫穷。是六尘贼亦复如是。若入人根则能劫夺一切善法。善法既尽贫穷孤露作一阐提。是故菩萨谛观六尘如六大贼。复次善男子。如六大贼欲劫人时要因内人。若无内人则便中还。是六尘贼亦复如是。欲劫善法要因内有众生知见常乐我净不空等相。若内无有如是等相。六尘恶贼则不能劫一切善法。有智之人内无是相。凡夫则有。是故六尘常来侵夺善法之财。不善护故为其所劫。护者名慧。有智之人能善防护故不被劫。是故菩萨观是六尘如六大贼等无差别。复次善男子。如六大贼能为人民身心苦恼。是六尘贼亦复如是。常为众生身心苦恼。六大贼者唯能劫人现在财物。是六尘贼常劫众生三世善财。六大贼者夜则欢乐。六尘恶贼亦复如是。处无明闇则得欢乐。是六大贼唯有诸王乃能遮止。六尘恶贼亦复如是。唯佛菩萨乃能遮止。是六大贼凡欲劫夺。不择端正种姓聪哲多闻博学豪贵贫贱。六尘恶贼亦复如是。欲劫善法不择端正乃至贫贱。是六大贼虽有诸王截其手足。犹故不能令其心息。六尘恶贼亦复如是。虽须陀洹斯陀含阿那含截其手足。亦不能令不劫善法。如勇健人乃能摧伏是六大贼。诸佛菩萨亦复如。乃能摧伏六尘恶贼。譬如有人多诸种族宗党炽盛则不为彼六贼所劫。众生亦尔。有善知识不为六尘恶贼所劫。是六大贼若见人物则能偷劫。六尘不尔。若见若知若闻若嗅若触若觉皆悉能劫。六大贼者唯能劫夺欲界人财。不能劫夺色无色界。六尘恶贼则不如是。能劫三界一切善宝。是故菩萨谛观六尘过彼六贼。作是观已修八圣道直往不回。如彼怖人畏四毒蛇五旃陀罗一诈亲善及六大贼。舍空聚落涉路而去

路值一河者即是烦恼。云何菩萨观此烦恼犹如大河。如彼驶河能漂香象。烦恼驶河亦复如是。能漂缘觉。是故菩萨深观烦恼犹如驶河。深难得底故名为河。边不可得故名为大。其中多有种种恶鱼。烦恼大河亦复如是。唯佛菩萨能得底故。故名极深。唯佛菩萨得其边故。故名广大。常害一切痴众生故。故名恶鱼。是故菩萨观此烦恼犹如大河。如大河水能长一切草木丛林。烦恼大河亦复如是。能长众生二十五有。是故菩萨观此烦恼犹如大河。譬如有人堕大河水无有惭愧。众生亦尔。堕烦恼河无有惭愧。如堕河者未得其底即便命终。堕烦恼河亦复如是。未尽其底。周回轮转二十五有。所言底者名为空相。若有不修如是空相。当知是人不得出离二十五有。一切众生不能善修空无相故。常为烦恼驶河所漂。如彼大河唯能坏身。不能漂没一切善法。烦恼大河则不如是。能坏一切身心善法。彼大暴河唯能漂没欲界中人。烦恼大河乃能漂没三界人天。世间大河运手动足则到彼岸。烦恼大河唯有菩萨因六波罗蜜乃能得渡。如大河水难可得渡。烦恼大河亦复如是。难可得渡。云何名为难可得渡。乃至十住诸大菩萨犹故未能毕竟得渡。唯有诸佛乃毕竟渡。是故名为难可得渡。譬如有人为河所漂不能修习毫厘善法。众生亦尔。为烦恼河所漂没者。亦复不能修习善法。如人堕河为水所漂。余有力者则能拔济。堕烦恼河为一阐提。声闻缘觉乃至诸佛不能拔济。世间大河劫尽之时。七日并照能令枯涸。烦恼大河则不如是。声闻缘觉虽修七觉犹不能干。是故菩萨观诸烦恼。犹如暴河

譬如彼人畏四毒蛇五旃陀罗一诈亲善及六大贼。舍空聚落随路而去。既至河上聚草为筏。菩萨亦尔。畏四大蛇五阴旃陀罗爱诈亲善六入空聚六尘恶贼。至烦恼河修戒定慧解脱解脱知见六波罗蜜三十七品。以为船筏。依乘此筏渡烦恼河。到于彼岸常乐涅槃。菩萨修行大涅槃者。作是思惟。我若不能忍受如是身苦心苦。则不能令一切众生。渡烦恼河。以是思惟。虽有如是身心苦恼默然忍受。以忍受故则不生漏。菩萨如是尚无诸漏。况佛如来而当有漏。是故诸佛不名有漏。云何如来非无漏耶。如来常行有漏中故。有漏即是二十五有。是故声闻凡夫之人言佛有漏。诸佛如来真实无漏

善男子。以是因缘诸佛如来无有定相。善男子。是故犯四重禁谤方等经及一阐提悉皆不定

尔时光明遍照高贵德王菩萨摩诃萨言。如是如是。诚如圣教。一切诸法悉皆不定。以不定故当知如来亦不毕竟入于涅槃。如佛先说。菩萨摩诃萨修大涅槃。闻不闻。中有涅槃大涅槃。云何涅槃。云何大涅槃

尔时佛赞光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。若有菩萨得念总持。乃能如汝之所咨问。善男子。如世人言。有海大海。有河大河。有山大山。有地大地。有城大城。有众生大众生。有王大王。有人大人。有天天中天。有道大道。涅槃亦尔。有涅槃有大涅槃。云何涅槃。善男子。如人饥饿得少饭食名为安乐。如是安乐亦名涅槃。如病得差则名安乐。如是安乐亦名涅槃。如人怖畏得归依处则得安乐。如是安乐亦名涅槃。如贫穷人获七宝物则得安乐如是安乐亦名涅槃。如人观骨不起贪欲则得安乐。如是安乐亦名涅槃。如是涅槃不得名为大涅槃也。何以故。以饥渴故病故怖故贫故生贪着故。是名涅槃非大涅槃。善男子。若凡夫人及以声闻。或因世俗。或因圣道。断欲界结则得安乐。如是安乐亦名涅槃。不得名为大涅槃也。能断初禅乃至能断非想非非想处结则得安乐。如是安乐亦名涅槃。不得名为大涅槃也。何以故。还生烦恼有习气故。云何名为烦恼习气。声闻缘觉有烦恼气。所谓我身我衣我去我来我说我听。诸佛如来入于涅槃。涅槃之性无我无乐唯有常净。是则名为烦恼习气。佛法众僧有差别相。如来毕竟入于涅槃。声闻缘觉诸佛如来。所得涅槃等无差别。以是义故。二乘所得非大涅槃。何以故。无常乐我净故。常乐我净乃得名为大涅槃也

善男子。譬如有处能受众水名为大海随有声闻缘觉菩萨诸佛如来所入之处名大涅槃。四禅三三昧八背舍八胜处十一切处随能摄取如是无量诸善法者名大涅槃善男子。譬如有河第一香象不能得底则名为大。声闻缘觉至十住菩萨不见佛性。名为涅槃非大涅槃。若能了了见于佛性。则得名为大涅槃也。是大涅槃唯大象王能尽其底。大象王者谓诸佛也。善男子。若摩诃那伽及钵犍陀大力士等。经历多时所不能上乃名大山。声闻缘觉及诸菩萨摩诃那伽大力士等所不能见。如是乃名大涅槃也。复次善男子。随有小王之所住处名为小城。转轮圣王所住之处乃名大城。声闻缘觉八万六万四万二万一万住处名为涅槃。无上法主圣王住处。乃得名为大般涅槃。以是故名大般涅槃。善男子。譬如有人见四种兵不生怖畏。当知是人名大众生。若有众生。于三恶道烦恼恶业不生怖畏。而能于中广度众生。当知是人得大涅槃。若有人能供养父母。恭敬沙门及婆罗门修治善法。所言诚实无有欺诳。能忍诸恶惠施贫乏。名大丈夫。菩萨亦尔。有大慈悲怜愍一切。于诸众生犹如父母。能度众生于生死河。普示众生一实之道。是则名为大般涅槃。善男子。大名不可思议。若不可思议一切众生所不能信。是则名为大般涅槃。唯佛菩萨之所见故名大涅槃。以何因缘。复名为大。以无量因缘然后乃得故名为大。善男子。如世间人以多因缘之所得者则名为大。涅槃亦尔。以多因缘之所得故。故名为大。云何复名为大涅槃。有大我故名大涅槃。涅槃无我大自在故。名为大我。云何名为大自在耶。有八自在则名为我。何等为八。一者能示一身以为多身。身数大小犹如微尘。充满十方无量世界。如来之身实非微尘。以自在故现微尘身。如是自在则为大我。二者示一尘身满于三千大千世界。如来之身实不满于三千大千世界。何以故。以无碍故。直以自在故满三千大千世界。如是自在名为大我。三者能以满此三千大千世界之身。轻举飞空过于二十恒河沙等诸佛世界。而无障碍。如来之身实无轻重。以自在故能为轻重如是自在名为大我。四者以自在故而得自在。云何自在。如来一心安住不动。所可示化无量形类各令有心。如来有时或造一事。而令众生各各成办。如来之身常住一土。而令他土一切悉见。如是自在名为大我。五者根自在故。云何名为根自在耶。如来一根亦能见色闻声嗅香别味觉触知法。如来六根亦不见色闻声嗅香别味觉触知法。以自在故令根自在。如是自在名为大我。六者以自在故得一切法。如来之心亦无得想。何以故。无所得故。若是有者可名为得。实无所有。云何名得。若使如来计有得想。是则诸佛不得涅槃。以无得故名得涅槃。以自在故得一切法。得诸法故名为大我。七者说自在故如来演说一偈之义。经无量劫义亦不尽。所谓若戒若定若施若慧。如来尔时都不生念我说彼听。亦复不生一偈之想。世间之人四句为偈。随世俗故说名为偈。一切法性亦无有说。以自在故如来演说。以演说故名为大我。八者如来遍满一切诸处犹如虚空。虚空之性不可得见。如来亦尔实不可见。以自在故令一切见。如是自在名为大我。如是大我名大涅槃。以是义故名大涅槃。复次善男子。譬如宝藏多诸珍异百种具足故名大藏。诸佛如来甚深奥藏亦复如是。多诸奇异具足无缺。名大涅槃。复次善男子。无边之物乃名为大。涅槃无边是故名大。复次善男子。有大乐故名大涅槃。涅槃无乐。以四乐故名大涅槃。何等为四。一者断诸乐故。不断乐者则名为苦。若有苦者不名大乐。以断乐故则无有苦。无苦无乐乃名大乐。涅槃之性无苦无乐。是故涅槃名为大乐。以是义故名大涅槃复次善男子。乐有二种。一者凡夫。二者诸佛。凡夫之乐无常败坏。是故无乐。诸佛常乐无有变异。故名大乐。复次善男子。有三种受。一者苦受。二者乐受。三者不苦不乐受。不苦不乐是亦为苦涅槃虽同不苦不乐。然名大乐。以大乐故名大涅槃。二者大寂静故名为大乐。涅槃之性是大寂静。何以故。远离一切愦闹法故。以大寂故名大涅槃

三者一切知故名为大乐。非一切知不名大乐。诸佛如来一切知故。名为大乐。以大乐故名大涅槃。四者身不坏故名为大乐。身若可坏则不名乐。如来之身金刚无坏非烦恼身无常之身。故名大乐。以大乐故名大涅槃。善男子。世间名字或有因缘。或无因缘。有因缘者。如舍利弗。母名舍利。因母立字。故名舍利弗。如摩鋀罗道人。生摩鋀罗国。因国立名。故名摩鋀罗道人。如目犍连。目犍连者即是姓也。因姓立名。故名目犍连。如我生于瞿昙种姓。因姓立名。称为瞿昙。如毗舍佉道人。毗舍佉者即是星名。因星为名名毗舍佉。如有六指。因六指故名六指人。如佛奴天奴。因佛因天故名佛奴天奴。因湿生故。故名湿生。如因声故。名为迦迦罗。名究究罗呾呾罗。如是等名是因缘名。无因缘者。如莲花地水火风虚空。如曼陀婆一名二实。一名殿堂。二名饮浆。堂不饮浆。亦复得名为曼陀婆。如萨婆车多名为蛇盖。实非蛇盖。是名无因。强立名字。如坻罗婆夷名为食油。实不食油。强为立名。名为食油。是名无因强立名字。善男子。是大涅槃亦复如是无有因缘强为立名。善男子。譬如虚空不因小空名为大也。涅槃亦尔。不因小相名大涅槃。善男子。譬如有法不可称量不可思议。故名为大。涅槃亦尔。不可称量不可思议。故得名为大般涅槃。以纯净故名大涅槃。云何纯净。净有四种。何等为四。一者二十五有名为不净。能永断故得名为净。净即涅槃。如是涅槃亦得名有。而是涅槃实非是有。诸佛如来随世俗故说涅槃有。譬如世人非父言父非母言母。实非父母而言父母。涅槃亦尔。随世俗故说言诸佛有大涅槃。二者业清净故。一切凡夫业不清净故无涅槃。诸佛如来业清净故。故名大净。以大净故名大涅槃。三者身清净故。身若无常则名不净。如来身常故名大净。以大净故名大涅槃。四者心清净故。心若有漏名曰不净。佛心无漏故名大净。以大净故名大涅槃。善男子。是名善男子善女人修行如是大涅槃经具足成就初分功德

大般涅槃经卷第二十一大般涅槃经卷第二十二

        宋代沙门慧严等依泥洹经加之

    光明遍照高贵德王菩萨品之四

复次善男子。云何菩萨摩诃萨修大涅槃成就具足第二功德。善男子。菩萨摩诃萨修大涅槃。昔所不得而今得之。昔所不见而今见之。昔所不闻而今闻之。昔所不到而今得到。昔所不知而今知之。云何名为昔所不得而今得之。所谓神通昔所不得而今乃得。通有二种。一者内。二者外。所言外者与外道共。内复有二。一者二乘。二者菩萨。菩萨修行大涅槃经所得神通。不与声闻辟支佛共。云何名为不与声闻辟支佛共。二乘所作神通变化。一心作一不得众多。菩萨不尔。于一心中则能具足现五趣身。所以者何。以得如是大涅槃经之势力故。是则名为昔所不得而今得之。又复云何昔所不得而今得之。所谓身得自在心得自在。何以故。一切凡夫所有身心不得自在。或心随身或身随心。云何名为心随于身。譬如醉人酒在身中尔时身动心亦随动。亦如身懒心亦随懒。是则名为心随于身。又如婴儿其身稚小心亦随小。大人身大心亦随大。又如有人身体粗涩心常思念欲得膏油润渍令软。是则名为心随于身。云何名为身随于心。所谓去来坐卧修行施戒忍辱精进。愁恼之人身则羸悴。欢喜之人身则肥鲜。恐怖之人身体战动。专心听法身则怡悦。悲泣之人涕泪横流。是则名为身随于心。菩萨不尔。于身心中俱得自在。是则名为昔所不得而今得之。复次善男子。菩萨摩诃萨所现身相犹如微尘。以此微身悉能遍至无量无边恒河沙等诸佛世界无所障碍。而心常定初不移动。是则名为心不随身。是亦名为昔所不到而今能到。何故复名昔所不到而今能到。一切声闻辟支佛等所不能到。菩萨能到。是故名为昔所不到而今能到。一切声闻辟支佛等。虽以神通不能变身如细微尘遍至无量恒河沙等诸佛世界。声闻缘觉身若动时心亦随动。菩萨不尔。心虽不动身无不至。是名菩萨心不随身。复次善男子。菩萨化身犹如三千大千世界。以此大身入一尘身。其心尔时亦不随小。声闻缘觉虽能化身令如三千大千世界。而不能以如此大身入微尘身。于此事中尚自不能。况能令心而不随动。是名菩萨心不随身。复次善男子。菩萨摩诃萨以一音声。能令三千大千世界众生悉闻。心终不念令是音声遍诸世界使诸众生昔所不闻而今得闻。而是菩萨亦初不言我令众生昔所不闻而今得闻。菩萨若言因我说法令诸众生不闻者闻。当知是人终不能得阿耨多罗三藐三菩提。何以故。众生不闻我为说者。如此之心是生死心。一切菩萨是心已尽。以是义故。菩萨摩诃萨所有身心不相随逐。善男子。一切凡夫身心相随。菩萨不尔。为化众生故虽现身小心亦不小。何以故。诸菩萨等所有心性常广大故。虽现大身心亦不大。云何大身。身如三千大千世界。云何小心行婴儿行。以是义故心不随身菩萨摩诃萨已于无量阿僧祇劫。远酒不饮而心亦动。心无悲苦身亦流泪。实无恐怖身亦战栗。以是义故。当知菩萨身心自在不相随逐。菩萨摩诃萨唯现一身而诸众生各各见异。复次善男子。云何菩萨摩诃萨修大涅槃。昔所不闻而今得闻。菩萨摩诃萨先取声相。所谓象声马声车声人声贝鼓箫笛歌哭等声。而修习之。以修习故。能闻无量三千大千世界所有地狱音声。复转修习得异耳根。异于声闻缘觉天耳。何以故。二乘所得清净耳根。若依初禅净妙四大。唯闻初禅不闻二禅。乃至四禅亦复如是。虽可一时得闻三千大千世界所有音声。而不能闻无量无边恒河沙等世界音声。以是义故。菩萨所得异于声闻缘觉耳根。以是异故。昔所不闻而今得闻。虽闻音声而心初无闻声之相。不作有相常相乐相我相净相主相依相作相因相定相果相。以是义故。诸菩萨等昔所不闻而今得闻

尔时光明遍照高贵德王菩萨摩诃萨言。若佛所说。不作定相不作果相。是义不然。何以故。如来先说。若人闻是大涅槃经一句一字。必定得成阿耨多罗三藐三菩提。如来于今云何复言无定无果。若得阿耨多罗三藐三菩提。即是定相即是果相。云何而言无定无果。闻恶声故则生恶心生恶心故则至三涂。若至三涂则是定果。云何而言无定无果

尔时如来赞言。善哉善哉。善男子。能作是问。若使诸佛说诸音声有定果相者。则非诸佛世尊之相。是魔王相。生死之相。远涅槃相何以故。一切诸佛凡所演说无定果相。善男子。譬如刀中照人面像。竖则见长横则见广。若有定相云何而得竖则见长横则见广。以是义故。诸佛世尊凡所演说无定果相。善男子。夫涅槃者实非声果。若使涅槃是声果者。当知涅槃非是常法。善男子。譬如世间从因生法。有因则有果。无因则无果。因无常故果亦无常。所以者何。因亦作果。果亦作因。以是义故。一切诸法无有定相。若使涅槃从因生者。因无常故果亦无常。而是涅槃不从因生体非是果。是故为常。善男子。以是义故。涅槃之体无定无果。善男子。夫涅槃者亦可言定亦可言果。云何为定。一切诸佛所有涅槃常乐我净。是故为定。无生老坏。是故为定一阐提等犯四重禁诽谤方等。作五逆罪舍除本心。必定得故。是故为定。善男子。如汝所言。若人闻我说大涅槃一字一句得阿耨多罗三藐三菩提者。汝于是义犹未解了。汝当谛听。吾当为汝更分别之。善男子。若有善男子善女人。闻大涅槃一字一句。不作字相。不作句相。不作闻相。不作佛相。不作说相。如是义者名无相相。以无相相故得阿耨多罗三藐三菩提。善男子。如汝所言。闻恶声故至三涂者。是义不然。何以故。非以恶声而至三涂。当知是果乃是恶心。所以者何有善男子善女人等。虽闻恶声心不生恶。是故当知非因恶声生三趣中。而诸众生因烦恼结。恶心滋多生三恶趣。非因恶声。若声有定相。诸有闻者一切悉应生于恶心。或有生者有不生者。是故当知声无定相。以无定故。虽复因之不生恶心

世尊。声若无定。云何菩萨昔所不闻而今得闻

善男子。声无定相。昔所不闻令诸菩萨而今得闻。以是义故。我作是说。昔所不闻而今得闻。善男子。云何昔所不见而今得见善男子。菩萨摩诃萨修大涅槃微妙经典。先取明相。所谓日月星宿[這-言+(序-予+手)]燎灯烛珠火之明药草等光。以修习故得异眼根。异于声闻缘觉所得。云何为异。二乘所得清净天眼。若依欲界四大眼根不见初禅。若依初禅不见上地。乃至自眼犹不能见。若欲多见极至三千大千世界。菩萨摩诃萨不修天眼见妙色身悉是骨相。虽见他方恒河沙等世界色相。不作色相。不作常相有相物相名字等相作因缘相。不作见相。不言是眼微妙净相。唯见因缘非因缘相。云何因缘。色是眼缘。若使是色非因缘者。一切凡夫不应生于见色之相。以是义故。色名因缘。非因缘者。菩萨摩诃萨虽复见色不作色相。是故非缘。以是义故。菩萨所得清净天眼。异于声闻缘觉所得。以是异故。时遍见十方世界现在诸佛。是名菩萨昔所不见而今得见。以是异故。能见微尘。声闻缘觉所不能见。以是异故。虽见自眼初无见相。见无常相见凡夫身三十六物不净充满。如于掌中观阿摩勒果。以是义故。昔所不见而今得见。若见众生所有色相。则知其人大小乘根。一触衣故。亦知是人善恶诸根差别之相。以是义故。昔所不知而今得知。以一见故。昔所不知而今得知。以此知故。昔所不见而今得见。复次善男子。云何菩萨昔所不知而今得知。菩萨摩诃萨虽知凡夫贪恚痴心。初不作心及心数相。不作众生及以物相。修第一义毕竟空相。何以故。一切菩萨常善修习空性相故。以修空故。昔所不知而今得知。云何为知。知无有我无有我所。知诸众生皆有佛性。以佛性故。一阐提等舍离本心。悉当得成阿耨多罗三藐三菩提。如此皆是声闻缘觉所不能知。菩萨能知。以是义故。昔所不知而今得知。复次善男子。云何昔所不知而今得知。菩萨摩诃萨修大涅槃微妙经典。念过去世一切众生所生种姓父母兄弟妻子眷属知识怨憎。于一念中得殊异智。异于声闻缘觉智慧。云何为异。声闻缘觉所有智慧。念过去世所有众生种姓父母乃至怨憎。而作种姓至怨憎相。菩萨不尔。虽念过去种姓父母乃至怨憎。终不生于种姓父母怨憎等相。常作法相空寂之相。是名菩萨昔所不知而今得知。复次善男子。云何昔所不知而今得知。菩萨摩诃萨修大涅槃微妙经典。得他心智。异于声闻缘觉所得。云何为异。声闻缘觉以一念智知人心时。则不能知地狱畜生饿鬼天心。菩萨不尔。于一念中遍知六趣众生之心。是名菩萨昔所不知而今得知。复次善男子。复有异知。菩萨摩诃萨于一心中。知须陀洹初心次第至十六心。以是义故。昔所不知而今得知。是为菩萨修大涅槃具足成就第二功德

复次善男子。云何菩萨摩诃萨修大涅槃成就具足第三功德。善男子。菩萨摩诃萨修大涅槃舍慈得慈。得慈之时不从因缘。云何名为舍慈得慈。善男子。慈名世谛。菩萨摩诃萨舍世谛慈得第一义慈。第一义慈不从缘得。复次云何舍慈得慈。慈若可舍名凡夫慈。慈若可得即名菩萨无缘之慈。舍一阐提慈犯重禁慈谤方等慈作五逆慈。得怜愍慈得如来慈世尊之慈无因缘慈。云何复名舍慈得慈。舍黄门慈无根二根女人之慈屠脍猎师畜养鸡猪如是等慈。亦舍声闻辟支佛慈。得诸菩萨无缘之慈。不见已慈不见他慈。不见持戒不见破戒。虽自见悲不见众生。虽有苦受不见受者。何以故。以修第一真实义故。是名菩萨修大涅槃成就具足第三功德

复次善男子。云何菩萨摩诃萨修大涅槃成就具足第四功德。善男子。菩萨摩诃萨修大涅槃成就具足第四功德。有十种事。何等为十。一者根深难可倾拔。二者自身生决定想。三者不观福田及非福田。四者修净佛土。五者灭除有余。六者断除业缘。七者修清净身。八者了知诸缘。九者离诸怨敌。十者断除二边。云何根深难可倾拔。所言根者名不放逸。不放逸者为是何根。所谓阿耨多罗三藐三菩提根。善男子。一切诸佛诸善根本皆不放逸。不放逸故诸余善根展转增长。以能增长诸善根故。于诸善中最为殊胜。善男子。如诸迹中象迹为上。不放逸法亦复如是。于诸善法最为殊胜。善男子。如诸明中日光为最。不放逸法亦复如是。于诸善法最为殊胜。善男子。如诸王中转轮圣王为最第一。不放逸法亦复如是。于诸善法为最第一。善男子。如诸流中四河为最。不放逸法亦复如是。于诸善法为上为最。善男子。如诸山中须弥山王为最第一。不放逸法亦复如是。于诸善法为最第一。善男子。如水生花中青莲为最。不放逸法亦复如是。于诸善法为最为上。善男子。如陆生花中婆利师花为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。如诸兽中师子为最。不放逸法亦复如是。于诸善法为最为上。善男子。如飞鸟中金翅鸟王为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。如大身中罗睺阿修罗王为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。如一切众生若二足四足多足无足中如来为最。不放逸法亦复如是。于善法中为最为上。善男子。如诸众中佛僧为上。不放逸法亦复如是。于善法中为最为上。善男子。如佛法中大涅槃法为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。以是义故。不放逸根深固难拔。云何不放逸故而得增长。所谓信根戒根施根慧根忍根闻根进根念根定根善知识根。如是诸根不放逸故而得增长。以增长故深固难拔。以是义故。名为菩萨摩诃萨修大涅槃根深难拔

云何于身作决定想。于自身所生决定心。我今此身于未来世。定当为阿耨多罗三藐三菩提器。心亦如是不作狭小不作变易。不作声闻辟支佛心。不作魔心及自乐心乐生死心。常为众生求慈悲心。是名菩萨于自身中生决定心。我于来世当为阿耨多罗三藐三菩提器。以是义故。菩萨摩诃萨修大涅槃。于自身中生决定想

云何菩萨不观福田及非福田。云何福田。外道持戒上至诸佛。是名福田。若有念言。如是等辈是真福田。当知是心则为狭劣。菩萨摩诃萨悉观一切无量众生无非福田。何以故。以善修习异念处故。有异念处善修习者。观诸众生无有持戒及以毁戒。常观诸佛世尊所说。施虽四种俱得净报。何等为四。一者施主清净受者不净。二者施主不净受者清净。三者施受俱净。四者二俱不净。云何施净受者不净。施主具有戒闻智慧。知有惠施及以果报。受者破戒专著邪见无施无报。是名施净受者不净。云何名为受者清净施主不净。施主破戒专著邪见。言无惠施及以果报。受者持戒多闻智慧。知有惠施及施果报。是名施主不净受者清净。云何名为施受俱净。施者受者俱有持戒多闻智慧。知有惠施及施果报。是名施受二俱清净。云何名为二俱不净。施者受者破戒邪见。言无有施及施果报。若如是者云何复言得净果报。以无施无报故名为净。善男子。若有不见施及施报。当知是人不名破戒专著邪见。若依声闻言不见施及施果报。是则名为破戒邪见。若依如是大涅槃经。不见惠施及施果报。是则名为持戒正见。菩萨摩诃萨有异念处。以修习故。不见众生持戒破戒施者受者及施果报。是故得名持戒正见。以是义故。菩萨摩诃萨不观福田及非福田

云何名为净佛国土。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离杀害心。以此善根愿与一切众生共之。愿诸众生得寿命长有大势力获大神通。以是誓愿因缘力故。于未来世成佛之时。国土所有一切众生。得寿命长有大势力获大神通。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离偷盗心。以此善根愿与一切众生共之。愿诸佛国土地所有纯是七宝。众生富足所欲自恣。以此誓愿因缘力故。于未来世成佛之时。所得国土纯是七宝。众生富足所欲自恣。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离淫欲心。以此善根愿与一切众生共之。愿诸佛土所有众生无有贪欲嗔恚痴心。亦无饥渴苦恼之患。以是誓愿因缘力故。于未来世成佛之时。国土众生远离贪淫嗔恚痴心。一切无有饥渴苦恼。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离妄语心。以此善根愿与一切众生共之。愿诸佛土常有茂林花果香树。所有众生得妙音声。以是誓愿因缘力故。于未来世成佛之时。所有国土常有茂林花果香树。其中众生悉得清净上妙音声。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故远离两舌。以此善根愿与一切众生共之。愿诸佛土所有众生常共和合讲说正法。以是誓愿因缘力故。成佛之时国土所有一切众生悉共和合讲论法要。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故远离恶口。以此善根愿与一切众生共之。愿诸佛土地平如掌无有石沙荆蕀恶刺。所有众生其心平等。以是誓愿因缘力故。于未来世成佛之时。所得国土地平如掌。无有石沙荆蕀恶刺。所有众生其心平等。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离无义语。以此善根愿与一切众生共之。愿诸佛土所有众生无有苦恼。以是誓愿因缘力故。于未来世成佛之时。国土所有一切众生无有苦恼。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故远离贪嫉。以此善根愿与一切众生共之。愿诸佛土一切众生无有贪嫉恼害邪见。以此誓愿因缘力故。于未来世成佛之时。国土所有一切众生悉无贪嫉恼害邪见。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故远离恼害。以此善根愿与一切众生共之。愿诸佛土所有众生悉共修习大慈大悲得一子地。以是誓愿因缘力故。于未来世成佛之时。世界所有一切众生。悉共修习大慈大悲得一子地。复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故远离邪见。以此善根愿与一切众生共之。愿诸佛土所有众生悉得摩诃般若波罗蜜。以是誓愿因缘力故。于未来世成佛之时。世界众生悉得受持摩诃般若波罗蜜。是名菩萨修净佛土云何菩萨摩诃萨灭除有余。有余有三。一者烦恼余报。二者余业。三者余有。善男子。云何名为烦恼余报。若有众生习近贪欲。是报熟故堕于地狱。从地狱出受畜生身。所谓鸽。雀。鸳鸯。鹦鹉。耆婆耆婆。舍利伽鸟。青雀。鱼。鳖。猕猴。獐鹿。若得人身受黄门形女人二根无根淫女。若得出家犯初重戒。是名余报。复次善男子。若有众生。以殷重心习近嗔恚。是报熟故堕于地狱。从地狱出受畜生身。所谓毒蛇具四种毒。见毒触毒啮毒嘘毒。师子虎狼熊罴猫狸鹰鹞之属。若得人身具足十六诸恶律仪。若得出家犯第二重戒。是名余报。复次善男子。若有修习愚痴之人。是报熟时堕于地狱。从地狱出受畜生身。所谓象猪牛羊水牛蚤虱蚊虻蚁子等形。若得人身聋盲喑哑癃残背偻。诸根不具不能受法。若得出家诸根闇钝喜犯重戒乃至卑贱。是名余报。复次善男子。若有修习憍慢之人。是报熟时堕于地狱。从地狱出受畜生身。所谓粪虫驼驴犬马。若生人中受奴婢身贫穷乞丐。或得出家常为众生之所轻贱破第四戒。是名余报。如是等名烦恼余报。如是余报菩萨摩诃萨以能修习大涅槃故悉得除灭。云何余业。谓一切凡夫业。一切声闻业。须陀洹人受七有业。斯陀含人受二有业。阿那含人受色有业。是名余业。如是余业菩萨摩诃萨以能修习大涅槃故悉得断除。云何余有。阿罗汉得阿罗汉果。辟支佛得辟支佛果。无业无结而转二果。是名余有。如是三种有余之法。菩萨摩诃萨修习大乘大涅槃经故得灭除。是名菩萨摩诃萨灭除有余

云何菩萨修清净身。菩萨摩诃萨修不杀戒有五种心。谓下中上上中上上乃至正见亦复如是。是五十心名初发心。具足决定成五十心。是名满足。如是百心名百福德。具足百福成于一相。如是展转具足成就三十二相。名清净身。所以复修八十种好。世有众生事八十神。何等八十。十二日。十二大天。五大星。北斗。马天。行道天。婆罗堕跋阇天。功德天。二十八宿。地天风天水天。火天。梵天。楼陀天。因提天。拘摩罗天。八臂天。摩醯首罗天。半阇罗天。鬼子母天。四天王天。造书天。婆薮天。是名八十。为此众生修八十好以自庄严。是名菩萨清净之身。何以故。是八十天一切众生之所信伏。是故菩萨修八十好其身不动。令彼众生随其所信各各得见。见已宗敬各发阿耨多罗三藐三菩提心。以是义故。菩萨摩诃萨修于净身。善男子。譬如有人欲请大王。要当庄严所有舍宅极令清净。办具种种百味肴膳。然后王乃就其所请。菩萨摩诃萨亦复如是。欲请阿耨多罗三藐三菩提法轮王故。先当修身极令清净。无上法王乃当处之。以是义故。菩萨摩诃萨要当修于清净之身。善男子。譬如有人欲服甘露先当净身。菩萨摩诃萨亦复如是。欲服无上甘露法味般若波罗蜜。要当先以八十种好清净其身。善男子。譬如妙好金银宝器盛之净水中表俱净。菩萨摩诃萨其身清净亦复如是。盛阿耨多罗三藐三菩提水中表俱净。善男子。如波罗捺素白之衣易受染色何以故。性白净故。菩萨摩诃萨亦复如是。以身净故疾得阿耨多罗三藐三菩提。以是义故。菩萨摩诃萨修于净身。云何菩萨摩诃萨了知诸缘。菩萨摩诃萨不见色相。不见色缘。不见色体。不见色生。不见色灭。不见一相。不见异相。不见见者。不见相貌。不见受者。何以故。了因缘故。如色一切法亦如是。是名菩萨了知诸缘

云何菩萨坏诸怨敌。一切烦恼是菩萨怨。菩萨摩诃萨常远离故。是名菩萨坏诸怨敌。五住菩萨视诸烦恼不名为怨。所以者何。因烦恼故菩萨有生。以有生故。故能展转教化众生。以是义故不名为怨。何等为怨。所谓诽谤方等经者。菩萨随生不畏地狱畜生饿鬼。唯畏如是谤方等者。一切菩萨有八种魔名为怨家。远是八魔名离怨家。是名菩萨离诸怨敌

云何菩萨远离二边。言二边者。谓二十五有及爱烦恼。菩萨常离二十五有及爱烦恼。是名菩萨远离二边。是名菩萨摩诃萨修大涅槃具足成就第四功德

尔时光明遍照高贵德王菩萨摩诃萨言。如佛所说。若有菩萨修大涅槃。悉作如是十事功德。如来何故唯修九事不修净土佛言。善男子。我于往昔亦常具修如是十事。一切菩萨及诸如来。无有不修是十事者。若使世界不净充满诸佛世尊于中出者无有是处。善男子。汝今莫谓诸佛出兴不净世界。当知是心不善狭劣。汝今当知。我实不出阎浮提界。譬如有人说言此界独有日月他方世界无有日月。如是之言无有义理。若有菩萨发如是言。此佛世界秽恶不净。他方佛土清净庄严。亦复如是。善男子。西方去此娑婆世界。度三十二恒河沙等诸佛国土。彼有世界名曰无胜。彼土何故名曰无胜。其土所有庄严之事皆悉平等无有差别。犹如西方安乐世界。亦如东方满月世界。我于彼土出现于世。为化众生故于此界阎浮提中现转法轮。非但我身独于此中现转法轮。一切诸佛亦于此中而转法轮。以是义故。诸佛世尊非不修行如是十事。善男子。慈氏菩萨以誓愿故。当来之世令此世界清净庄严。以是义故。一切诸佛所有世界无不严净

复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第五功德。善男子。菩萨摩诃萨修大涅槃具足成就第五功德。有五事果。何等为五。一者诸根完具。二者不生边地。三者诸天爱念。四者常为天魔沙门刹利婆罗门等之所恭敬。五者得宿命智。菩萨以是大涅槃经因缘力故。具足如是五事功德

光明遍照高贵德王菩萨言。如佛所说。若有善男子善女人。修于布施则得具成五事功德。今云何言因大涅槃得是五事佛言。善哉善哉。善男子。如是之事其义各异。今当为汝分别解说。施得五事。不定不常不净不胜不异非无漏。不能利益安乐怜愍一切众生。若依如是大涅槃经。所得五事。是定是常是净是胜是异是无漏。则能利益安乐怜愍一切众生。善男子。夫布施者得离饥渴大涅槃经能令众生悉得远离二十五有渴爱之病。布施因缘令生死相续。大涅槃经能令生死断不相续。因布施故受凡夫法。因大涅槃得作菩萨。布施因缘能断一切贫穷苦恼。大涅槃经能断一切贫善法者。布施因缘有分有果。因大涅槃得阿耨多罗三藐三菩提无分无果。是名菩萨摩诃萨修大涅槃微妙经典。具足成就第五功德

善男子。云何菩萨修大涅槃微妙经典。具足成就第六功德。菩萨摩诃萨修大涅槃得金刚三昧。安住是中悉能破散一切诸法。见一切法皆是无常皆是动相。恐怖因缘病苦劫盗。念念灭坏无有真实。一切皆是魔之境界无可见相。菩萨摩诃萨住是三昧。虽施众生乃至不见一众生实。为众生故精勤修习尸波罗蜜。乃至修习般若波罗蜜。亦复如是。菩萨若见有一众生不能毕竟具足成就檀波罗蜜乃至具足般若波罗蜜。善男子。譬如金刚所拟之处无不碎坏。而是金刚无有折损。金刚三昧亦复如是。所拟之法无不碎坏。而是三昧无有折损。善男子。如诸宝中金刚最胜。菩萨所得金刚三昧亦复如是。于诸三昧为最第一。何以故。菩萨摩诃萨修是三昧。一切三昧悉来归属。善男子。如诸小王悉来归属转轮圣王。一切三昧亦复如是。悉来归属金刚三昧。善男子。譬如有人为国怨仇人所厌患。有人杀之一切世人无不称赞是人功德。金刚三昧亦复如是。菩萨修习能坏一切众生怨敌。是故常为一切三昧之所宗敬。善男子。譬如有人其力盛壮人无当者。复更有人力能伏之。当知是人世所称美。金刚三昧亦复如是。力能摧伏难伏之法。以是义故。一切三昧悉来归属。善男子。譬如有人在大海浴。当知是人已用诸河泉池之水。菩萨摩诃萨亦复如是。修习如是金刚三昧。当知已为修习诸余一切三昧。善男子。如香山中有一泉水名阿耨达。其泉具足八味之水。有人饮之无诸病苦。金刚三昧亦复如是具八正道。菩萨修习断诸烦恼疮疣重病。善男子。如人供养摩醯首罗。当知是人已为供养一切诸天。金刚三昧亦复如是。有人修习当知已为修习一切诸余三昧。善男子。若有菩萨安住如是金刚三昧。见一切法无有障碍。如于掌中观阿摩勒果。菩萨虽复得如是见。终不作想见一切法。善男子。譬如有人坐四衢道见诸众生来去坐卧。金刚三昧亦复如是。见一切法生灭出没。善男子。譬如高山有人登之远望诸方皆悉明了。金刚定山亦复如是。菩萨登之远望诸法无不明了。善男子。譬如春月天降甘雨其渧微致间无空处。明眼之人见之明了。菩萨亦尔。得金刚定清净之目。远见东方所有世界。其中或有国土成坏。一切皆见明了无障。乃至十方亦复如是。善男子。如由乾陀山七日并出其山所有树木丛林一切烧尽。菩萨修习金刚三昧亦复如是。所有一切烦恼丛林即时消灭。善男子。譬如金刚虽能摧破一切有物终不生念我能摧破。金刚三昧亦复如是。菩萨修已能破烦恼。终不生念我能坏结。善男子。譬如大地能持万物终不生念我力能持。火亦不念我能烧物。水亦不念我能润渍。风亦不念我能动物。空亦不念我能容受。涅槃亦复不生念言我令众生而得灭度。金刚三昧亦复如是。虽能灭除一切烦恼。而初无心言我能灭。若有菩萨安住如是金刚三昧。于一念中变身如佛其数无量。遍满十方恒河沙等诸佛世界。而是菩萨虽作是化。其心初无憍慢之想。何以故。菩萨常念。谁有是定能作是化。唯有菩萨安住如是金刚三昧乃能作耳。菩萨摩诃萨安住如是金刚三昧。于一念中遍到十方恒河沙等诸佛世界还其本处。虽有是力亦不念言我能如是。何以故。以是三昧因缘力故。菩萨摩诃萨安住如是金刚三昧。于一念中能断十方恒河沙等世界众生所有烦恼。而心初无断诸众生烦恼之想。何以故。以是三昧因缘力故。菩萨住是金刚三昧。以一音声有所演说。一切众生各随种类而得解了。示现一色一切众生各各皆见种种色相。安住一处身不移易。能令众生随其方面各各而见。演说一法若界若入。一切众生各随本解而得闻之。菩萨安住如是三昧。虽见众生而心初无众生之相。虽见男女无男女相。虽见色法无有色相。乃至见识亦无识相虽见昼夜无昼夜相。虽见一切无一切相。虽见一切烦恼诸结。亦无一切烦恼之相。见八圣道无圣道相。虽见菩提无菩提相。见于涅槃无涅槃相。何以故。善男子。一切诸法本无相故。菩萨以是三昧力故。见一切法如本无相。何故名为金刚三昧。善男子。譬如金刚若在日中色则不定。金刚三昧亦复如是。在于大众色亦不定。是故名为金刚三昧。善男子。譬如金刚一切世人不能评价。金刚三昧亦复如是。所有功德一切人天不能评量。是故复名金刚三昧。善男子。譬如贫人得金刚宝则得远离贫穷困苦恶鬼邪毒。菩萨摩诃萨亦复如是。得是三昧则能远离烦恼诸苦诸魔邪毒。是故复名金刚三昧。是名菩萨修大涅槃具足成就第六功德

大般涅槃经卷第二十二大般涅槃经卷第二十三

        宋代沙门慧严等依泥洹经加之

    光明遍照高贵德王菩萨品之五

复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第七功德。善男子。菩萨摩诃萨修大涅槃微妙经典。作是思惟。何法能为大般涅槃而作近因。菩萨。即知有四种法为大涅槃而作近因。若言勤修一切苦行是大涅槃近因缘者。是义不然。所以者何。若离四法得涅槃者无有是处。何等为四。一者亲近善友。二者专心听法。三者系念思惟。四者如法修行。善男子。譬如有人身遇众病若热若冷虚劳下疟众邪鬼毒到良医所。良医即为随病说药。是人至心善受医教。随教合药如法服之。服已病愈身得安乐。有病之人譬诸菩萨。大良医者譬善知识。良医所说譬方等经。善受医教譬善思惟方等经义。随教合药譬如法修行三十七助道之法。病除愈者譬灭烦恼。得安乐者喻得涅槃常乐我净。善男子。譬如有王欲如法治令民安乐。咨诸智臣其法云何。诸臣即以先王旧法而为说之。王既闻已至心信行。如法治国无诸怨敌。是故令民安乐无患。善男子。王者譬诸菩萨。诸智臣者譬善知识。智臣为王所说治法譬十二部经。王既闻已至心信行。譬诸菩萨系心思惟十二部经所有深义。如法治国譬诸菩萨如法修行。所谓六波罗蜜。以能修习六波罗蜜故。无诸怨敌譬诸菩萨已离诸结烦恼恶贼。得安乐者譬诸菩萨得大涅槃常乐我净。善男子。譬如有人遇恶癞病。有善知识而语之言。汝若能到须弥山边病可得差。所以者何。彼有良药味如甘露。若能服者病无不愈。其人至心信是事已。即往彼山采服甘露。其病除愈身得安乐。恶癞病者譬诸凡夫。善知识者譬诸菩萨摩诃萨等。至心信受譬四无量心。须弥山者譬八圣道。甘露味者譬于佛性。癞病除愈譬灭烦恼。得安乐者譬得涅槃常乐我净。善男子。譬如有人畜诸弟子聪明大智是人昼夜常教不惓。诸菩萨等亦复如是。一切众生有信不信。而常教化无有疲厌。善男子。善知识者所谓佛菩萨辟支佛声闻人中信方等者。何故名为善知识耶。善知识者能教众生远离十恶修行十善。以是义故名善知识。复次善知识者如法而说。如说而行。云何名为如法而说如说而行。自不杀生教人不杀。乃至自行正见教人正见。若能如是则得名为真善知识。自修菩提。亦能教人修行菩提。以是义故名善知识。自能修行信戒布施多闻智慧。亦能教人信戒布施多闻智慧。复以是义名善知识。善知识者有善法故。何等善法。所作之事不求自乐。常为众生而求安乐。见他有过不说其短。口常宣说纯善之事。以是义故名善知识。善男子。如空中月从初一日至十五日渐渐增长。善知识者亦复如是。令诸学人渐远恶法增长善法。善男子。若有亲近善知识者。本未有戒定慧解脱解脱知见即便有之。未具足者则得增广。何以故。以其亲近善知识故。因是亲近复得了达十二部经甚深之义。若能听是十二部经甚深义者名为听法

听法者则是大乘方等经典。听方等经名真听法。真听法者即是听受大涅槃经。大涅槃中闻有佛性如来毕竟不般涅槃。是故名为专心听法。专心听法名八圣道。以八圣道能断贪欲嗔恚愚痴故名听法。夫听法者名十一空。以此诸空于一切法不作相貌。夫听法者名初发心乃至究竟阿耨多罗三藐三菩提心。以因初心得大涅槃。不以闻故得大涅槃。以修习故得大涅槃。善男子。譬如病人虽闻医教及药名字不能愈病。要以服故乃得除差。虽听十二深因缘法不能断灭一切烦恼。要以系念善思惟故能得除断。是名第三系念思惟

复以何义名系念思惟。所谓三三昧。空三昧无相三昧无作三昧。空者于二十五有不见一实。无作者于二十五有不作愿求。无相者无有十相。所谓色相声相香相味相触相生相住相灭相男相女相。修习如是三三昧者。是名菩萨系念思惟

云何名为如法修行。如法修行即是修行檀波罗蜜乃至般若波罗蜜。知阴入界真实之相。亦知声闻缘觉诸佛同于一道而般涅槃。法者即是常乐我净。不生不老不病不死。不饥不渴不苦不恼。不退不没善男子。解大涅槃甚深义者。则知诸佛终不毕竟入于涅槃

善男子。第一真实善知识者。所谓菩萨诸佛世尊。何以故。常以三种善调御故。何等为三。一者毕竟软语。二者毕竟呵责。三者软语呵责。以是义故。菩萨诸佛即是真实善知识也。复次善男子。佛及菩萨为大医故名善知识。何以故。知病知药应病授药故譬如良医善八种术先观病相。相有三种。何等为三谓风热水。有风病者授之酥油。热病之人授之石蜜。水病之人授之姜汤。以知病根授药得差故名良医。佛及菩萨亦复如是。知诸凡夫病有三种。一者贪欲。二者嗔恚。三者愚痴。贪欲病者教观骨相。嗔恚病者观慈悲相愚痴病者观十二缘相。以是义故。诸佛菩萨名善知识。善男子。譬如船师善渡人故名大船师。诸佛菩萨亦复如是。度诸众生生死大海。以是义故名善知识。复次善男子。因佛菩萨令诸众生具足修得善法根故。善男子。譬如雪山乃是种种微妙上药根本之处。佛及菩萨亦复如是。悉是一切善根本处。以是义故名善知识。善男子。雪山之中有上香药名曰娑呵。有人见之得寿无量无有病苦。虽有四毒不能中伤。若有触者增长寿命满百二十。若有念者得宿命智。何以故。药势力故。诸佛菩萨亦复如是。若有见者即得断除一切烦恼。虽有四魔不能干乱。若有触者命不可夭。不生不死不退不没。所谓触者若在佛边听受妙法。若有念者得阿耨多罗三藐三菩提。以是义故。诸佛菩萨名善知识。善男子。如香山中有阿耨达池。由是池故有四大河。所谓恒河。辛头。私陀。博叉。世间众生常作是言。若有罪者浴此四河众罪得灭。当知此言虚妄不实。除此已往何等为实。诸佛菩萨是乃为实。所以者何。若人亲近则得灭除一切众罪。以是义故名善知识。复次善男子。譬如大地所有药木一切丛林百谷甘蔗花果之属。值天炎旱将欲枯死。难陀龙王及婆难陀怜愍众生。从大海出降澍甘雨。一切丛林百谷草木滋润还生。一切众生亦复如是。所有善根将欲消灭。诸佛菩萨生大慈悲。从智慧海降甘露雨。令诸众生具足还得十善之法。以是义故。诸佛菩萨名善知识。善男子。譬如良医善八种术见诸病人。不观种姓端正丑陋钱财宝货悉为治之。是故世称为大良医。诸佛菩萨亦复如是。见诸众生有烦恼病。不观种姓端正丑陋钱财宝货。生慈愍心悉为说法。众生闻已烦恼病除。以是义故。诸佛菩萨名善知识。以是亲近善友因缘。则得近于大般涅槃

云何菩萨听法因缘而得近于大般涅槃。一切众生以听法故则具信根。得信根故乐行布施戒忍精进禅定智慧。得须陀洹果乃至佛果。是故当知。得诸善法皆是听法因缘势力。善男子。譬如长者唯有一子。遣至他国市易所须。示其道路通塞之处。而复诫之。若遇淫女慎莫亲爱。若亲爱者丧身殒命及以财宝。弊恶之人亦莫交游。其子敬顺父之教敕。身心安隐多获宝货。菩萨摩诃萨为诸众生敷演法要亦复如是。示诸众生及四部众诸道通塞。是诸众等以闻法故。远离诸恶具足善法。以是义故。听法因缘则得近于大般涅槃。善男子。譬如明镜照人面像无不明了。听法明镜亦复如是。有人照之则见善恶明了无翳。以是义故。听法因缘则得近于大般涅槃。善男子。譬如商人欲至宝渚。不知道路有人示之其人随语即至宝渚。多获诸珍不可称计。一切众生亦复如是。欲至善处采取道宝。不知其路通塞之相。菩萨示之众生随已。得至善处获得无上大涅槃宝。以是义故。听法因缘则得近于大般涅槃。善男子。譬如醉象狂逸暴恶多欲杀害。有调象师以大铁钩钩斲其顶。即时调顺恶心都尽。一切众生亦复如是。贪欲嗔恚愚痴醉故欲多造恶。诸菩萨等以闻法钩斲之令住更不得起造诸恶心。以是义故。听法因缘则得近于大般涅槃。是故我于处处经中说。我弟子专心听受十二部经。则离五盖修七觉分。以是修习七觉分故。则得近于大般涅槃。以听法故须陀洹人离诸恐怖。所以者何。须达长者身遭重病心大愁怖。闻舍利弗说须陀洹有四功德十种慰喻。闻是事已恐怖即除。以是义故。听法因缘则得近于大般涅槃。何以故。开法眼故。世有三人。一者无目。二者一目。三者二目。言无目者常不闻法。一目之人虽暂闻法其心不住。二目之人专心听受如闻而行。以听法故得知世间如是三人。以是义故。听法因缘则得近于大般涅槃。善男子。如我昔于拘尸那城。时舍利弗身遇病苦。我时顾命阿难比丘广为说法。时舍利弗闻是事已告四弟子。汝举我床往至佛所我欲听法。时四弟子奉命舁往。既得闻法。闻法力故所苦除差身得安隐。以是义故。听法因缘则得近于大般涅槃云何菩萨思惟因缘而得近于大般涅槃。因是思惟心得解脱。何以故。一切众生常为五欲之所系缚。以思惟故悉得解脱。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切众生常为常乐我净四法之所颠倒。以思惟故得见诸法无常无乐无我无净。如是见已四倒即断。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切诸法有四种相。何等为四。一者生相。二者老相。三者病相。四者灭相。以是四相能令一切凡夫众生至须陀洹生大苦恼。若能系念善思惟者。虽遇此四不生众苦。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切善法无不因是思惟而得。何以故。有人虽于无量无边阿僧祇劫专心听法。若不思惟终不能得阿耨多罗三藐三菩提。以是义故。思惟因缘则得近于大般涅槃。复次善男子。若有众生。信佛法僧无有变易而生恭敬。当知皆是系念思惟因缘力故。因得断除一切烦恼。以是义故。思惟因缘则得近于大般涅槃

云何菩萨如法修行。善男子。断诸恶法修习善法。是名菩萨如法修行。复次云何如法修行。见一切法空无所有无常无乐无我无净。以是见故。宁舍身命不犯禁戒。是名菩萨如法修行。复次云何如法修行。修有二种。一者真实。二者不实。不实者不知涅槃佛性如来法僧实相虚空等相。是名不实。云何真实。能知涅槃佛性如来法僧实相虚空等相。是名真实。云何名为知涅槃相涅槃之相凡有八事。何等为八。一者尽。二善性。三实。四真。五常。六乐。七我。八净。是名涅槃。复有八事。何等为八。一者解脱。二者善性。三者不实。四者不真。五者无常。六者无乐。七者无我。八者无净。复有六相。一者解脱。二者善性。三者不实。四者不真。五者安乐。六者清净。若有众生。依世俗道断烦恼者。如是涅槃则有八事解脱不实。何以故。以不常故。以无常故则无有实。无有实故则无有真。虽断烦恼以还起故。无常无我无乐无净。是名涅槃解脱八事。云何六相。声闻缘觉断烦恼故。名为解脱。而未能得阿耨多罗三藐三菩提故。名为不实。以不实故名为不真。未来之世当得阿耨多罗三藐三菩提故名无常。以得无漏八圣道故。名为净乐。善男子。若如是知是知涅槃。不名佛性如来法僧实相虚空。云何菩萨知于佛性。佛性有六。何等为六。一常二净三实四善五当见六真。复有七事。一者可证。余六如上。是名菩萨知于佛性。云何菩萨知如来相。如来即是觉相善相。常乐我净解脱真实示道可见。是名菩萨知如来相。云何菩萨知于法相。法者若善不善。若常不常。若乐不乐。若我无我。若净不净。若知不知。若解不解。若真不真。若修不修。若师非师。若实不实。是名菩萨知于法相。云何菩萨知于僧相。僧者若常乐我净。是弟子相可见之相善真不实。何以故。一切声闻得佛道故。何故名真。悟法性故。是名菩萨知于僧相。云何菩萨知于实相。实相者若常无常。若乐无乐。若我无我。若净无净。若善不善。若有若无。若涅槃非涅槃。若解脱非解脱。若知不知。若断不断。若证不证。若修不修。若见不见。是名实相。非是涅槃佛性如来法僧虚空。是名菩萨因修如是大涅槃。故知于涅槃佛性如来法僧实相虚空等法差别之相。善男子。菩萨摩诃萨修大涅槃微妙经典。不见虚空。何以故。佛及菩萨虽有五眼所不见故。唯有慧眼乃能见之。慧眼所见无法可见。故名为见。若见无物名虚空者。如是虚空乃名为实。以是实故则名常无。以常无故无乐我净。善男子。空名无法无法名空。譬如世间无物名空。虚空之性亦复如是。无所有故名为虚空。善男子。众生之性与虚空性俱无实性。何以故。如人说言。除灭有物然后作空而是虚空实不可作。何以故。无所有故。以无有故当知无空。是虚空性。若可作者则名无常。若无常者不名虚空。善男子。如世间人说言虚空无色无碍常不变易。是故世称虚空之法为第五大。善男子。而是虚空实无有性。以光明故。故名虚空实无虚空。犹如世谛实无其性为众生故说有世谛。善男子。涅槃之体亦复如是。无有住处。直是诸佛断烦恼处。故名涅槃。涅槃即是常乐我净。涅槃虽乐非是受乐。乃是上妙寂灭之乐。诸佛如来有二种乐。一寂灭乐。二觉知乐。实相之体有三种乐。一者受乐。二寂灭乐。三觉知乐。佛性一乐以当见故。得阿耨多罗三藐三菩提时名菩提乐

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。若烦恼断处是涅槃者。是事不然。何以故。如来往昔初成佛道。至尼连禅河边。尔时魔王与其眷属。到于佛所而作是言。世尊。涅槃时到。何故不入。佛告魔王。我今未有多闻弟子善持禁戒聪明利智能化众生。是故不入。若言烦恼断处是涅槃者。诸菩萨等于无量劫已断烦恼。何故不得称为涅槃。俱是断处。何缘独称诸佛有之菩萨无耶。若断烦恼非涅槃者。何故如来昔告生名婆罗门言。我今此身即是涅槃。如来又时在毗舍离国。魔复启请如来。昔以未有弟子多闻持戒聪明利智能化众生。不入涅槃。今已具足何故不入。如来尔时即告魔言。汝今莫生悒迟之想。却后三月吾当涅槃。世尊。若使灭度非涅槃者。何故如来自期三月当般涅槃。世尊。若断烦恼是涅槃者。如来往昔初在道场菩提树下。断烦恼时便是涅槃。何故复言却后三月当般涅槃。世尊。若使尔时是涅槃者。云何方为拘尸那城诸力士等。说言后夜当般涅槃。如来诚实云何发是虚妄之言

尔时世尊告光明遍照高贵德王菩萨摩诃萨言。善男子。若言如来得广长舌。当知如来于无量劫已离妄语。一切诸佛及诸菩萨。凡所发言诚谛无虚。善男子。如汝所言。波旬往昔启请于我入涅槃者。善男子。而是魔王真实不知涅槃定相。何以故。波旬意谓不化众生默然而住便是涅槃。善男子。譬如世人见人不言无所造作。便谓是人如死无异。魔王波旬亦复如是。意谓如来不化众生默无所说。便谓如来入般涅槃。善男子。如来不说佛法众僧无差别相。唯说常住清净二法无差别耳。善男子。佛亦不说佛及佛性涅槃无差别相。唯说常恒不变无差别耳。善男子。佛亦不说涅槃实相无差别相。唯说常有实不变易无差别耳。善男子。尔时我诸声闻弟子生于诤讼。如拘睒弥诸恶比丘。违反我教多犯禁戒。受不净物贪求利养。向诸白衣而自赞叹我得无漏。谓须陀洹果。乃至我得阿罗汉果。毁辱他人。于佛法僧戒律和上不生恭敬。公于我前言如是物佛所听畜。如是等物佛不听畜。我亦语言。如是等物我实不听。复反我言。如是等物实是佛听。如是恶人不信我言。为是等故我告波旬汝莫悒迟。却后三月当般涅槃。善男子。因如是等恶比丘故。令诸声闻受学弟子不见我身不闻我法。便言如来入于涅槃。唯诸菩萨能见我身常闻我法。是故不言我入涅槃。声闻弟子虽复发言如来涅槃。而我实不入于涅槃。善男子。若我所有声闻弟子说言如来入涅槃者。当知是人非我弟子是魔伴党。邪见恶人非正见也。若言如来不入涅槃。当知是人真我弟子非魔伴党。正见之人非恶邪也。善男子。我初不见弟子之中有言如来不化众生默然而住名般涅槃也。善男子。譬如长者多有子息舍至他方。未得还顷诸子咸谓父已长逝。而是长者实不终没。诸子嗔倒皆生没想。声闻弟子亦复如是。不见我故便谓如来已于拘尸那城娑罗双树间而般涅槃。而我实不般涅槃也。声闻弟子生涅槃想。善男子。譬如明灯有人覆之余不知者谓灯已灭而是明焰实亦不灭。以不知故生于灭想。声闻弟子亦复如是。虽有慧眼以烦恼覆令心颠倒。不见真身而便妄生灭度之想。而我实不毕竟灭度。善男子。如生盲人不见日月。以不见故不知昼夜明暗之相。以不知故便说无有日月之实。实有日月盲者不见。以不见故而生倒想言无日月。声闻弟子亦复如是。如彼生盲不见如来。便谓如来入于涅槃。如来实不入于涅槃。以倒想故生如是心。善男子。譬如云雾覆蔽日月。痴人便言无有日月。日月实有直以覆故众生不见。声闻弟子亦复如是。以诸烦恼覆智慧眼不见如来。便言如来入于灭度。善男子。直是如来现婴儿行非灭度也。善男子。如阎浮提日入之时众生不见。以黑山障故。而是日性实无没入。众生不见生没入想。声闻弟子亦复如是。为诸烦恼山所障故不见我身。以不见故便于如来生灭度想。而我实不毕竟永灭。是故我于毗舍离国告波旬言。却后三月我当涅槃。善男子。如来玄见迦叶菩萨却后三月善根当熟。亦见香山须跋陀罗竟安居已当至我所。是故我告魔王波旬。却后三月当般涅槃。善男子。有诸力士其数五百。终竟三月亦当得发阿耨多罗三藐三菩提心我为是故告波旬言。却后三月当般涅槃善男子。如纯陀等及五百梨车庵罗果女。却后三月无上道心善根成熟。为是等故我告波旬。却后三月当般涅槃。善男子。须那刹多亲近外道尼干子等。我为说法满十二年。彼人邪见不信不受。我知是人邪见根栽却后三月定可拔断。我为是故告波旬言。却后三月当般涅槃。善男子。何因缘故我于往昔尼连河边告魔波旬。我今未有多智弟子。是故不得入涅槃者。我时欲为五比丘等于波罗奈转法轮故。次复欲为五比丘等所谓耶奢。富那。毗摩罗阇。憍梵波提。须婆睺。次复欲为郁伽长者等五十人。次复欲为摩伽陀国频婆娑罗王等无量人天。次复欲为优楼频螺迦叶门徒五百比丘。次复欲为那提迦叶伽耶迦叶兄弟二人及五百弟子。次复欲为舍利弗大目犍连等二百五十比丘转妙法轮。是故我告魔王波旬不般涅槃。善男子。有名涅槃非大涅槃。云何涅槃非大涅槃。不见佛性而断烦恼。是名涅槃非大涅槃。以不见佛性故无常无我唯有乐净。以是义故。虽断烦恼不得名为大般涅槃也。若见佛性能断烦恼。是则名为大般涅槃。以见佛性故得名为常乐我净。以是义故。断除烦恼。亦得称为大般涅槃。善男子。涅者言不。槃者言灭。不灭之义名为涅槃。槃又言覆。不覆之义乃名涅乐。槃言去来。不去不来乃名涅槃。槃者言取。不取之义乃名涅槃。槃言不定。定无不定乃名涅槃。槃言新故。无新故义乃名涅槃。槃言障碍。无障碍义乃名涅槃。善男子。有优楼迦迦毗罗弟子等言。槃者名相无相之义乃名涅槃。善男子。槃者言有。无有之义乃名涅槃。槃名和合。无和合义乃名涅槃。槃者言苦。无苦之义乃名涅槃。善男子。断烦恼者不名涅槃。不生烦恼乃名涅槃。善男子。诸佛如来烦恼不起。是名涅槃。所有智慧于法无碍。是为如来。如来非是凡夫声闻缘觉菩萨。是名佛性。如来身心智慧遍满无量无边阿僧祇土无所障碍。是名虚空。如来常住无有变易。名曰实相。以是义故。如来实不毕竟涅槃。是名菩萨修大涅槃微妙经典具足成就第七功德

善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第八功德。善男子。菩萨摩诃萨修大涅槃。除断五事远离五事。成就六事修习五事守护一事亲近四事。信顺一实心善解脱慧。善解脱。善男子。云何菩萨断除五事。所谓五阴。色受想行识。所言阴者其义何谓。能令众生生死相续不离重担。分散聚合三世所摄。求其实义了不可得。以是诸义故名为阴。菩萨摩诃萨虽见色阴不见其相。何以故。于十色中推求其性悉不可得。为世界故说言为阴。受有百八。虽见受阴初无受相。何以故。受虽百八理无定实。是故菩萨不见受阴。想行识等亦复如是。菩萨摩诃萨深见五阴是生烦恼之根本也。以是义故。方便令断。云何菩萨远离五事。所谓五见。何等为五。一者身见。二者边见。三者邪见。四者戒取。五者见取。因是五见生六十二见。因是诸见生死不绝。是故菩萨防护不近。云何菩萨成就六事。诸六念处。何等为六。一者念佛。二者念法。三者念僧。四者念天。五者念施。六者念戒是名菩萨成就六事。云何菩萨修习五事。所谓五定。一者知定。二者寂定。三者身心受快乐定。四者无乐定。五者首楞严定。修习如是五种定心。则得近于大般涅槃。是故菩萨勤心修习。云何菩萨守护一事。谓菩提心。菩萨摩诃萨常勤守护是菩提心。犹如世人守护一子。亦如瞎者护余一目。如行旷野守护导者。菩萨守护菩提之心亦复如是。因护如是菩提心故。得阿耨多罗三藐三菩提。因得阿耨多罗三藐三菩提故常乐我净具足而有。即是无上大般涅槃。是故菩萨守护一法。云何菩萨亲近四事。谓四无量心。何等为四。一者大慈。二者大悲。三者大喜。四者大舍。因是四心能令无量无边众生发菩提心。是故菩萨系心亲近。云何菩萨信顺一实。菩萨了知一切众生皆归一道。一道者谓大乘也。诸佛菩萨为众生故分之为三。是故菩萨信顺不逆。云何菩萨心善解脱。贪恚痴心永断灭故。是名菩萨心善解脱。云何菩萨慧善解脱。菩萨摩诃萨于一切法知无障碍。是名菩萨慧善解脱。因慧解脱昔所不闻而今得闻。昔所不见而今得见。昔所不到而今得到

尔时光明遍照高贵德王菩萨摩诃萨言。世尊。如佛所说。心解脱者是义不然。何以故。心本无系。所以者何。是心本性不为贪欲嗔恚愚痴诸结所缚。若本无系。云何而言心善解脱。世尊。若心本性不为贪结之所系者。何等因缘而能得系。如人[穀-禾+牛]角本无乳相。虽加功力乳无由出[穀-禾+牛]于乳者则不如是。加功虽少乳则多出。心亦如是。本无贪者今云何有。若本无贪后方有者。诸佛菩萨本无贪相今悉应有。世尊。譬如石女本无子相。虽加功力无量因缘子不可得。心亦如是本无贪相。虽造众缘贪无由生。世尊。如钻湿木火不可得。心亦如是。虽复钻求贪不可得。云何贪结能系于心。世尊。譬如压沙油不可得。心亦如是。虽复压之贪不可得。当知贪心二理各异。设复有之何能污心。世尊。譬如有人安橛于空终不得住。安贪于心亦复如是。种种因缘不能令贪系缚于心。世尊。若心无贪名解脱者。诸佛菩萨何故不拔虚空中刺。世尊。过去世心不名解脱。未来世心亦无解脱。现在世心不与道共。何等世心名得解脱。世尊。如过去灯不能灭闇。未来世灯亦不灭闇。现在世灯复不灭闇。何以故。明之与闇二不并故。心亦如是。云何而言心得解脱。世尊。贪亦是有若贪无者。见女相时不应生贪。若因女相而得生者。当知是贪真实而有。以有贪故堕三恶道。世尊。譬如有人见画女像亦复生贪。以生贪故得种种罪。若本无贪云何见画而生于贪。若心无贪云何如来说言菩萨心得解脱。若心有贪云何见相然后方生。不见相者则不生耶。我今现见有恶果报。当知有贪嗔恚愚痴亦复如是。世尊。譬如众生有身无我。而诸凡夫横计我想虽有我想。不堕三趣。云何贪者于无女相而起女想。堕三恶道。世尊。譬如钻木而生于火。然是火性众缘中无。以何因缘而得生耶。世尊。贪亦如是。色中无贪。香味触法亦复无贪。云何于色香味触法而生贪耶。若众缘中悉无贪者。云何众生独生于贪。诸佛菩萨而不生耶。世尊。心亦不定。若心定者无有贪欲嗔恚愚痴。若不定者云何而言心得解脱。贪亦不定。若不定者云何因之生三恶趣。贪者境界二俱不定。何以故。俱缘一色。或生于贪或生于嗔。或生愚痴。是故贪者及与境界二俱不定。若俱不定。何故如来说言菩萨修大涅槃心得解脱

尔时世尊告光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。心亦不为贪结所系。亦非不系。非是解脱非不解脱。非有非无。非现在非过去非未来。何以故。善男子。一切诸法无自性故。善男子。有诸外道作如是言。因缘和合则有果生。若众缘中本无生性而能生者。虚空不生亦应生果。虚空不生非是因故。以众缘中本有果性。是故合集而得生果。所以者何。如提婆达欲造墙壁则取泥土不取彩色。欲造画像则集彩色不取草木。作衣取缕不取泥木。作舍取泥不取缕綖。以人取故。当知是中各能生果。以能生果故。当知因中必先有性。若无性者一物之中。应当出生一切诸物。若是可取可作可出。当知是中必先有果。若无果者。人则不取不作不出。唯有虚空无取无作故。能出生一切万物。以有因故。如尼拘陀子住尼拘陀树。乳有醍醐。缕中有布。泥中有瓶。善男子。一切凡夫无明所盲作是定说。色有着义心有贪性。复言凡夫心有贪性亦解脱性。遇贪因缘心则生贪。若遇解脱心则解脱。虽作此说是义不然。有诸凡夫复作是言。一切因中悉无有果。因有二种一者微细。二者粗大。细即是常。粗则无常。从微细因转成粗因。从此粗因转复成果。粗无常故果亦无常。善男子。有诸凡夫复作是言。心亦无因贪亦无因。以时节故则生贪心。如是等辈以不能知心因缘故。轮回六趣具受生死。善男子。譬如枷犬系之于柱终日绕柱不能得离。一切凡夫亦复如是。被无明枷系生死柱绕二十五有不能得离。善男子。譬如有人堕于圊厕既得出已而复还入。如人病差还为病因。如人涉路值空旷处既得过已而复还来。又如净洗还涂泥土。一切凡夫亦复如是。已得解脱无所有处。唯未得脱非非想处。而复还来至三恶趣。何以故。一切凡夫唯观于果不观因缘如犬逐块不逐于人。凡夫之人亦复如是。唯观于果不观因缘。以不观故。从非想退还三恶趣。善男子。诸佛菩萨终不定说因中有果因中无果及有无果非有非无果。若言因中先定有果及定无果定有无果定非有非无果。当知是等皆魔伴党。系属于魔即是爱人。如是爱人不能永断生死系缚。不知心相及以贪相。善男子。诸佛菩萨显示中道。何以故。虽说诸法非有非无而不决定。所以者何。因眼因色因明因心因念识则得生。是识决定不在眼中色中明中心中念中。亦非中间非有非无。从缘生故名之为有。无自性故名之为无。是故如来说言诸法非有非无。善男子。诸佛菩萨终不定说心有净性及不净性。净不净心无住处故。从缘生贪故说非无。本无贪性故说非有。善男子。从因缘故心则生贪。从因缘故心则解脱。善男子。因缘有二。一者随于生死。二者随大涅槃。善男子。有因缘故。心共贪生共贪俱灭。有共贪生不共贪灭。有不共贪生共贪俱灭。有不共贪生不共贪灭。云何心共贪生共贪俱灭。善男子。若有凡夫未断贪心修习贪心。如是之人心共贪生心共贪灭。一切众生不断贪心。心共贪生心共贪灭。如欲界众生一切皆有初地味禅。若修不修常得成就。遇因缘故即便得之。言因缘者谓火灾也。一切凡夫亦复如是。若修不修心共贪生心共贪灭。何以故。不断贪故。云何心共贪生不共贪灭。声闻弟子有因缘故生于贪心。畏贪心故修白骨观。是名心共贪生不共贪灭。复有心共贪生不共贪灭。如声闻人未证四果。有因缘故生于贪心。证四果时贪心得灭。是名心共贪生不共贪灭。菩萨摩诃萨得不动地时。心共贪生不共贪灭。云何不共贪生共贪俱灭。若菩萨摩诃萨断贪心已为众生故示现有贪。以示现故能令无量无边众生咨受善法具足成就。是名不共贪生共贪俱灭。云何不共贪生不共贪灭。谓阿罗汉缘觉诸佛除不动地其余菩萨。是名不共贪生不共贪灭。以是义故。诸佛菩萨不决定说心性本净性本不净。善男子。是心不与贪结和合亦复不与嗔痴和合。善男子。譬如日月虽为烟尘云雾及阿修罗之所覆蔽。以是因缘令诸众生不能得见。虽不可见日月之性终不与彼五翳和合。心亦如是。以因缘故生于贪结。众生虽说心与贪合。而是心性实不与合。若是贪心即是贪性。若是不贪即不贪性。不贪之心不能为贪。贪结之心不能不贪。善男子。以是义故贪欲之结不能污心。诸佛菩萨永破贪结。是故说言心得解脱。一切众生从因缘故生于贪结从因缘故心得解脱。善男子。譬如雪山悬峻之处人与猕猴俱不能行。或复有处猕猴能行人不能行。或复有处人与猕猴二俱能行。善男子。人与猕猴能行处者。如诸猎师纯以黐胶置之案上用捕猕猴。猕猴痴故往手触之。触已粘手。欲脱手故以脚蹋之。脚复随着。欲脱脚故以口啮之。口复粘着。如是五处悉无得脱。于是猎师以杖贯之负还归家。雪山崄处譬佛菩萨所得正道。猕猴者譬诸凡夫猎师者喻魔波旬。黐胶者譬贪欲结。人与猕猴俱不行者。譬诸凡夫魔王波旬俱不能行。猕猴能行人不能行者。譬诸外道有智慧者。诸恶魔等虽以五欲不能系缚。人与猕猴俱能行者。一切凡夫及魔波旬。常处生死不能修行。凡夫之人五欲所缚。令魔波旬自在将去。如彼猎师擒捕猕猴负之归家。善男子。譬如国王安住己界身心安乐。若至他界则得众苦。一切众生亦复如是。若能自住于己境界则得安乐若至他界则遇恶魔受诸苦恼。自境界者谓四念处。他境界者谓五欲也。云何名为系属于魔。有诸众生无常见常常见无常。苦见于乐乐见于苦。不净见净净见不净。无我见我我见无我。非实解脱妄见解脱。真实解脱见非解脱。非乘见乘乘见非乘。如是之人名系属魔。系属魔者心不清净。复次善男子。若见诸法真实是有总别定相。当知是人若见色时便作色相。乃至见识亦作识相。见男男相。见女女相。见日日相。见月月相。见岁岁相。见阴阴相。见入入相。见界界相。如是见者名系属魔。系属魔者心不清净。复次善男子。若见我是色色中有我我中有色色属于我。乃至见我是识识中有我我中有识识属于我。如是见者系属于魔非我弟子。善男子。我声闻弟子远离如来十二部经。修习种种外道典籍。不修出家寂灭之业。纯营世俗在家之事。何等名为在家之事。受畜一切不净之物奴婢田宅象马车乘驼驴鸡犬狝猴猪羊种种谷麦。远离师僧亲附白衣违反圣教。向诸白衣作如是言。佛听比丘受畜种种不净之物。是名修习在家之事。有诸弟子。不为涅槃但为利养亲近听受十二部经。招提僧物及僧鬘物。衣着贪啖如自己有。悭惜他家。及以称誉亲近国王及诸王子。卜筮吉凶推步盈虚。围棋六博摴蒱投壶。亲比丘尼及诸处女。畜二沙弥。常游屠猎酤酒之家及旃陀罗所住之处。种种贩卖手自作食。受使邻国通致信命。如是之人当知即是魔之眷属非我弟子。以是因缘心共贪生心共贪灭。乃至痴心共生共灭亦复如是善男子。以是因缘心性不净亦非不净。是故我说心得解脱。若有不受不畜一切不净之物。为大涅槃受持读诵十二部经书写解说。当知是等真我弟子。不行恶魔波旬境界。即是修习三十七品以修习故不共贪生。不共贪灭。是名菩萨修大涅槃微妙经典具足成就第八功德

大般涅槃经卷第二十三大般涅槃经卷第二十四

        宋代沙门慧严等依泥洹经加之

    光明遍照高贵德王菩萨品之六

复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第九功德。善男子。菩萨摩诃萨修大涅槃微妙经典。初发五事悉得成就。何等为五。一者信。二者直心。三者戒。四者亲近善友。五者多闻

云何为信。菩萨摩诃萨信于三宝施有果报。信于二谛一乘之道更无异趣。为诸众生速得解脱。诸佛菩萨分别为三。信第一义谛。信善方便。是名为信。如是信者若诸沙门若婆罗门若天魔梵。一切众生所不能坏。因是信故得圣人性。修行布施若多若少。悉得近于大般涅槃不堕生死。戒闻智慧亦复如是。是名为信。虽有是信而亦不见。是为菩萨修大涅槃成就初事

云何直心。菩萨摩诃萨于诸众生作质直心。一切众生若遇因缘则生谄曲。菩萨不尔。何以故。善解诸法悉因缘故。菩萨摩诃萨虽见众生诸恶过咎终不说之。何以故。恐生烦恼。若生烦恼则堕恶趣。如是菩萨若见众生有少善事则赞叹之。云何为善。所谓佛性。赞佛性故令诸众生发阿耨多罗三藐三菩提心

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如佛所说。菩萨摩诃萨赞叹佛性。令无量众生发阿耨多罗三藐三菩提心。是义不然。何以故。如来初开涅槃经时。说有三种。一者若有病人得良医药及瞻病者病则易差。如其不得则不可愈。二者若得不得悉不可差。三者若得不得悉皆可差。一切众生亦复如是。若遇善友诸佛菩萨闻说妙法。能发阿耨多罗三藐三菩提心。如其不遇则不能发。所谓须陀洹斯陀含阿那含阿罗汉辟支佛。二者虽遇善友诸佛菩萨闻说妙法亦不能发。若其不遇亦不能发。谓一阐提。三者若遇不遇一切悉能发阿耨多罗三藐三菩提心。所谓菩萨。若言遇与不遇悉发阿耨多罗三藐三菩提心者。如来今者云何说言。因赞佛性令诸众生发阿耨多罗三藐三菩提心。世尊。若遇善友诸佛菩萨闻说妙法及以不遇。悉不能发阿耨多罗三藐三菩提心。当知是义亦复不然。何以故。如是之人当得阿耨多罗三藐三菩提故。一阐提辈以佛性故。若闻不闻悉亦当得阿耨多罗三藐三菩提故。世尊。如佛所说。何等名为一阐提耶。谓断善根。如是之义亦复不然。何以故。不断佛性故。如是佛性理不可断。云何佛说断诸善根。如佛往昔说十二部经。善有二种。一者常。二者无常。常者不断。无常者断。无常可断故堕地狱。常不可断何故不遮。佛性不断非一阐提。如来何故作如是说言一阐提。世尊若因佛性发阿耨多罗三藐三菩提心。何故如来广为众生说十二部经。世尊。譬如四河出阿耨达池。若有天人诸佛世尊。说言是河不入大海当还本源无有是处。菩提之心亦复如是。有佛性者。若闻不闻。若戒非戒。若施非施。若修不修。若智非智。悉皆应得阿耨多罗三藐三菩提。世尊。如优陀延山日从中出至于正南。日若念言我不至西还东方者。无有是处。佛性亦尔。若不闻不戒不施不修不智不得阿耨多罗三藐三菩提者。无有是处。世尊。诸佛如来说因果性非有非无。如是之义是亦不然。何以故。如其乳中无酪性者则无有酪。尼拘陀子无五丈者。则不能生五丈之质。若佛性中无阿耨多罗三藐三菩提树者。云何能生阿耨多罗三藐三菩提树。以是义故。所说因果非有非无。如是之义云何相应

尔时世尊赞言。善哉善哉。善男子。世有二人。甚为希有如优昙花。一者不行恶法。二者有罪能悔。如是之人甚为希有。复有二人。一者作恩。二者念恩。复有二人。一者咨受新法。二者温故不忘。复有二人。一者造新。二者修故。复有二人。一乐闻法。二乐说法。复有二人。一善问难。二善能答。善问难者汝身是也。善能答者谓如来也。善男子。因是善问即得转于无上法轮。能枯十二因缘大树。能度无边生死大河。能与魔王波旬共战。能摧波旬所立胜幢。善男子。如我先说。三种病人值遇良医瞻病好药。及以不遇病悉得差。是义云何。若得不得谓定寿命。所以者何。是人已于无量世中修三种善。谓上中下。以修如是三种善故得定寿命。如郁单越人寿命千年。有遇病者若得良医好药瞻病。及以不得悉皆得差。何以故。得定命故。善男子。如我所说。若有病人得遇良医好药瞻病病得除差。若不遇者则不得差。是义云何。善男子。如是之人寿命不定。命虽不尽有九因缘能夭其寿。何等为九。一者知食不安而反食之。二者多食。三者宿食未消而复更食。四者大小便利不随时节。五者病时不随医教。六者不随瞻病教敕。七者强耐不吐。八者夜行。以夜行故恶鬼打之。九者房室过差。以是缘故。我说病者若遇医药病则可差。若不遇者则不可愈。善男子。如我先说。若遇不遇俱不差者。是义云何。有人命尽若遇不遇悉不可差。何以故。以命尽故。以是义故我说病人若遇医药及以不遇悉不得差。众生亦尔。发菩提心者若遇善友诸佛菩萨咨受深法。若不遇之皆悉当成。何以故。以其能发菩提心故。如郁单越人得定寿命。如我所说。从须陀洹至辟支佛。若闻善友诸佛菩萨所说深法。则发阿耨多罗三藐三菩提心。若不值遇诸佛菩萨闻说深法。则不能发阿耨多罗三藐三菩提心。如不定命以九因缘命则中夭。如彼病人值遇医药病则得差。若不遇者病则不差。是故我说遇佛菩萨闻说深法则能发心。若不值遇则不能发。如我先说。若遇善友诸佛菩萨闻说深法。若不值遇俱不能发。是义云何。善男子。一阐提辈若遇善友诸佛菩萨闻说深法及以不遇。俱不得离一阐提心。何以故。断善法故。一阐提辈亦得阿耨多罗三藐三菩提。所以者何。若能发于菩提之心。则不复名一阐提也。善男子。以何缘故。说一阐提得阿耨多罗三藐三菩提。一阐提辈实不能得阿耨多罗三藐三菩提。如命尽者虽遇良医好药瞻病不能得差。何以故。以命尽故。善男子。一阐名信。提名不具。不具信故名一阐提。佛性非信。众生非具。以不具故云何可断。一阐名善方便。提名不具。修善方便不具足故名一阐提。佛性非是修善方便。众生非具。以不具故云何可断。一阐名进。提名不具。进不具故名一阐提。佛性非进众生非具。以不具故云何可断。一阐名念。提名不具。念不具故名一阐提。佛性非念众生非具。以不具故云何可断。一阐名定。提名不具。定不具故名一阐提。佛性非定众生非具。以不具故云何可断。一阐名慧。提名不具。慧不具故名一阐提。佛性非慧众生非具。以不具故云何可断。一阐名无常善。提名不具。以无常善不具足故名一阐提。佛性非无常非善非不善。何以故。善法要从方便而得。而是佛性非方便得。是故非善。何故复名非不善耶。能得善果故。善果即是阿耨多罗三藐三菩提。又善法者生已得故。而是佛性非生已得。是故非善。以断生得诸善法故名一阐提。善男子。如汝所言。若一阐提有佛性者。云何不遮地狱之罪。善男子。一阐提中无有佛性。善男子。譬如有王闻箜篌音。其声清妙心即耽着。喜乐爱念情无舍离。即告大臣如是妙音从何处出。大臣答言。如是妙音从箜篌出。王复语言。持是声来。尔时大臣即持箜篌置于王前。而作是言。大王当知。此即是声。王语箜篌。出声出声。而是箜篌声亦不出。尔时大王即断其弦声亦不出。取其皮木悉皆折裂。推求其声了不能得。尔时大王即嗔大臣。云何乃作如是妄语。大臣白王。夫取声者法不如是。应以众缘善巧方便声乃出耳。众生佛性亦复如是无有住处。以善方便故得可见。以可见故得阿耨多罗三藐三菩提。一阐提辈不见佛性。云何能遮三恶道罪。善男子。若一阐提信有佛性。当知是人不至三趣。是亦不名一阐提也。以不自信有佛性故即堕三趣。堕三趣故名一阐提

善男子。如汝所说。若乳无酪性不应出酪。尼拘陀子无五丈性。则不应有五丈之质。愚痴之人作如是说。智者终不发如是言。何以故。以无性故。善男子。如其乳中有酪性者。不应复假众缘力也。善男子。如水乳杂卧至一月终不成酪。若以一渧颇求树汁。投之于中即便成酪。若本有酪何故待缘。众生佛性亦复如是。假众缘故则便可见。假众缘故得成阿耨多罗三藐三菩提。若待众缘然后成者即是无性。以无性故能得阿耨多罗三藐三菩提。善男子。以是义故。菩萨摩诃萨常赞人善不讼彼缺。名质直心

复次善男子。云何菩萨质直心耶。菩萨摩诃萨常不犯恶。设有过失即时忏悔。于师同学终不覆藏。惭愧自责不敢复作。于轻罪中生极重想。若人诘问答言实犯。复问是罪为好不好。答言。不好。复问。是罪为善不善。答言。不善。复问。是罪是善果耶不善果耶。答言。是罪实非善果。又问。是罪谁之所造。将非诸佛法僧所作。答言。非佛法僧我所作也。乃是烦恼之所构集。以直心故信有佛性。信佛性故则不得名一阐提也。以直心故名佛弟子。若受众生衣服饮食卧具医药种各千万不足为多。是名菩萨质直心也

云何菩萨修治于戒。菩萨摩诃萨受持禁戒。不为生天不为恐怖。乃至不受狗戒鸡戒牛戒雉戒。不作破戒。不作缺戒。不作瑕戒不作杂戒。不作声闻戒。受持菩萨摩诃萨戒尸罗波罗蜜戒。得具足戒不生憍慢。是名菩萨修大涅槃具第三戒

云何菩萨亲近善友。菩萨摩诃萨常为众生说于善道不说恶道。说于恶道非善果报。善男子。我身即是一切众生真善知识。是故能断富伽罗婆罗门所有邪见。善男子。若有众生亲近我者。虽有应生地狱因缘即得生天。如须那刹多等应堕地狱。以见我故即得断除地狱因缘生于色天。虽有舍利弗目犍连等。不名众生真善知识。何以故生一阐提心因缘故。善男子。我昔住于波罗奈国时。舍利弗教二弟子。一观白骨。一令数息。经历多年皆不得定。以是因缘即生邪见。言无涅槃无漏之法。若其有者我应得之。何以故。我能善持所受戒故。我于尔时见是比丘生此邪心。唤舍利弗而呵啧之。汝不善教。云何乃为是二弟子颠倒说法。汝二弟子其性各异。一主浣衣。一是金师。金师之子应教数息浣衣之人应教骨观。以汝错教令是二人生于恶邪。我于尔时为是二人如应说法。二人闻已得阿罗汉果。是故我为一切众生真善知识。非舍利弗目犍连等。若使众生有极重结得遇我者。我以方便即为断之。如我弟难陀有极重欲。我以种种善巧方便而为除断。鸯掘魔罗有重嗔恚。以见我故嗔恚即断。阿阇世王有重愚痴。以见我故痴心即灭。如婆熙伽长者。于无量劫积集成就极重烦恼。以见我故即便断灭。设有弊恶厮下之人。亲近于我作弟子者。以是因缘。一切人天恭敬爱念。尸利鞠多邪见炽盛。因见我故邪见即灭。因见我故断地狱因作生天缘。如气嘘旃陀罗。命垂终时。因见我故还得寿命。如憍尸迦。狂心错乱。因见我故还得本心。如瘦瞿昙弥。屠家之子。常作恶业。以见我故即便舍离。如阐提比丘。因见我故宁舍身命不毁禁戒。如草系比丘。以是义故。阿难比丘说半梵行名善知识。我言不尔。具足梵行乃名善知识。是名菩萨修大涅槃具足第四亲善知识

云何菩萨具足多闻。菩萨摩诃萨为大涅槃十二部经书写读诵分别解说。是名菩萨具足多闻。除十一部唯毗佛略。受持读诵书写解说。亦名菩萨具足多闻。除十二部经。若能受持是大涅槃微妙经典。书写读诵分别解说。是名菩萨具足多闻。除是经典具足全体。若能受持一四句偈。复除是偈若能受持如来常住性无变易。是名菩萨具足多闻。复除是事。若知如来常不说法。亦名菩萨具足多闻。何以故。法无性故。如来虽说一切诸法常无所说。是名菩萨修大涅槃成就第五具足多闻

善男子。若有善男子善女人。为大涅槃具足成就如是五事。难作能作。难忍能忍。难施能施。云何菩萨难作能作。若闻有人食一胡麻得阿耨多罗三藐三菩提者。信是语故乃至无量阿僧祇劫常食一麻若闻入火得阿耨多罗三藐三菩提者。于无量劫在阿鼻狱入炽火聚。是名菩萨难作能作。云何菩萨难忍能忍。若闻受苦手杖刀石斫打因缘得大涅槃。即于无量阿僧祇劫。身具受之不以为苦。是名菩萨难忍能忍。云何菩萨难施能施。若闻能以国城妻子头目髓脑惠施于人得阿耨多罗三藐三菩提者。即于无量阿僧祇劫。以其所有国城妻子头目髓脑惠施于人。是名菩萨难施能施。菩萨虽复难作能作。终不念言是我所作。难施能施亦复如是。善男子。譬如父母唯有一子爱之甚重。以好衣裳上妙甘膳。随时将养令无所乏。设令其子于父母所起轻慢心恶口骂辱。父母爱故不生嗔恨。亦不念言我与是儿衣服饮食。菩萨摩诃萨亦复如是。视诸众生犹如一子。若子遇病父母亦病。为求医药勤加救疗。病既差已终不生念。我为是儿疗治病苦。菩萨亦尔。见诸众生遇烦恼病。生爱念心而为说法。以闻法故诸烦恼断。烦恼断已终不念言。我为众生断诸烦恼。若生此念终不得成阿耨多罗三藐三菩提。唯作是念。无一众生我为说法令断烦恼。菩萨摩诃萨于诸众生不嗔不喜。何以故。善能修习空三昧故。菩萨若修空三昧者。当于谁所生嗔生喜。善男子。譬如山林猛火所焚若人斫伐或为水漂。而是林木当于谁所生嗔生喜。菩萨摩诃萨亦复如是。于诸众生无嗔无喜。何以故。修空三昧故

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。一切诸法性自空耶。空空故空。若性自空者。不应修空然后见空。云何如来言以修空而见空耶。若性自不空。虽复修空不能令空

善男子。一切诸法性本自空。何以故。一切法性不可得故。善男子。色性不可得。云何色性。色性者非地水火风。不离地水火风。非青黄赤白不离青黄赤白。非有非无。云何当言色有自性。以性不可得故说为空。一切诸法亦复如是。以相似相续故。凡夫见已说言诸法性不空寂。菩萨摩诃萨具足五事。是故见法性本空寂。善男子。若有沙门及婆罗门。见一切法性不空者。当知是人非是沙门非婆罗门。不得修习般若波罗蜜。不得入于大般涅槃。不得现见诸佛菩萨。是魔眷属。善男子。一切诸法性本自空。亦因菩萨修习空故见诸法空。善男子。如一切法性无常故灭能灭之。若非无常灭不能灭。有为之法有生相故生能生之。有灭相故灭能灭之。一切诸法有苦相故苦能令苦。善男子。如盐性碱能碱异物。石蜜性甘能甘异物。苦酒性酢能酢异物。姜本性辛能辛异物。呵梨勒苦能苦异物。庵罗果淡能淡异物。毒性能害令异物害。甘露之性令人不死。若合异物亦能不死。菩萨修空亦复如是。以修空故见一切法性皆空寂

光明遍照高贵德王菩萨复作是言。世尊。若盐能令非碱作碱。修空三昧若如是者。当知是定非善非妙其性颠倒。若空三昧唯见空者。空是无法为何所见

善男子。是空三昧见不空法能令空寂然非颠倒。如盐非碱作碱。是空三昧亦复如是不空作空。善男子。贪是有性非是空性。贪若是空众生不应以是因缘堕于地狱。若堕地狱云何贪性当是空耶。善男子。色性是有。何等色性所谓颠倒。以颠倒故众生生贪。若是色性非颠倒者。云何能令众生生贪。以生贪故当知色性非不是有。以是义故。修空三昧非颠倒也。善男子。一切凡夫若见女人即生女相。菩萨不尔。虽见女人不生女相。以不生相贪则不生。贪不生故非颠倒也。以世间人见有女故。菩萨随说言有女人。若见男时说言是女。则是颠倒。是故我为阇提说言。汝婆罗门。若以昼为夜是即颠倒。以夜为昼是亦颠倒。昼为昼相夜为夜相。云何颠倒。善男子。一切菩萨住九地者见法有性。以是见故不见佛性。若见佛性则不复见一切法性。以修如是空三昧故不见法性。以不见故则见佛性。诸佛菩萨有二种说。一者有性。二者无性。为众生故说有法性。为诸贤圣说无法性。为不空者见法空故。修空三昧令得见空。无法性者亦修空故空。以是义故修空见空。善男子。汝言见空空是无法为何见者。善男子。如是如是。菩萨摩诃萨实无所见。无所见者即无所有。无所有者即一切法。菩萨摩诃萨修大涅槃。于一切法悉无所见。若有见者不见佛性。不能修习般若波罗蜜。不得入于大般涅槃。是故菩萨见一切法性无所有。善男子。菩萨不但因见三昧而见空也。般若波罗蜜亦空。禅波罗蜜亦空。毗梨耶波罗蜜亦空。羼提波罗蜜亦空。尸波罗蜜亦空。檀波罗蜜亦空。色亦空眼亦空识亦空。如来亦空。大般涅槃亦空。是故菩萨见一切法皆悉是空。是故我在迦毗罗城告阿难言。汝莫愁恼悲泣啼哭。阿难即言。如来世尊我今亲属悉皆殄灭。云何当得不悲泣耶。如来与我俱生此城。俱同释种亲戚眷属。云何如来独不愁恼光颜更显。善男子。我复告言。阿难。汝见迦毗真实是有。我见空寂悉无所有。汝见释种悉是亲戚。我修空故悉无所见。以是因缘汝生愁苦。我身容颜益更光显。诸佛菩萨修习如是空三昧故不生愁恼。是名菩萨修大涅槃微妙经典成就具足第九功德。善男子。云何菩萨修大涅槃微妙经典。具足最后第十功德。善男子。菩萨修习三十七品。入大涅槃常乐我净。为诸众生分别解说大涅槃经显示佛性。若须陀洹斯陀含阿那含阿罗汉辟支佛菩萨信是语者。悉得入于大般涅槃。若不信者轮回生死

尔时光明遍照高贵德王菩萨白佛言。世尊。何等众生于是经中不生恭敬

善男子。我涅槃后有声闻弟子。愚痴破戒喜生斗诤。舍十二部经读诵种种外道典籍文颂手笔。受畜一切不净之物。言是佛听。如是之人以好栴檀贸易凡木。以金易鋀石。银易白镴。绢易氀褐。以甘露味易于恶毒。云何栴檀贸易凡木。如我弟子为供养故。向诸白衣演说经法。白衣情逸不喜听闻。白衣处高比丘在下。兼以种种肴膳饮食而供给之犹不肯听。是名栴檀贸易凡木。云何以金贸易鋀石。鋀石譬色声香味触。金以譬戒我诸弟子以色因缘破所受戒。是名以金贸易鋀石。云何以银易于白镴。银譬十善。镴譬十恶。我诸弟子放舍十善行十恶法。是名以银贸易白镴。云何以绢贸易氀褐。氀褐以譬无惭无愧。绢譬惭愧。我诸弟子放舍惭愧习无惭愧。是名以绢贸易氀褐。云何甘露贸易毒药。毒药以譬种种利养。甘露以譬诸无漏法。我诸弟子为利养故。向诸白衣若自举赞言得无漏。是名甘露贸易毒药。以如是等恶比丘故。是大涅槃微妙经典。广行流布于阎浮提。当是之时有诸弟子受持读诵书写是经广说流布。当为如是诸恶比丘之所杀害。是恶比丘相与聚会共立严制。若有受持大涅槃经书写读诵分别说者。一切不得共住共坐谈论语言。何以故。涅槃经者非佛所说邪见所造。邪见之人即是六师。六师所说非佛经典。所以者何。一切诸佛悉说诸法无常无我无乐无净。若言诸法常乐我净。云何当是佛所说经。诸佛菩萨听诸比丘畜种种物。六师所说不听弟子畜一切物。如是之义。云何当是佛之所说。诸佛菩萨不制弟子断牛五味及以食肉。六师不听食五种盐五种牛味及以脂血。若断是者云何当是佛之正典。诸佛菩萨演说三乘。而是经中纯说一乘。谓大涅槃。如此之言云何当是佛之正典。诸佛毕竟入于涅槃。是经言佛常乐我净不入涅槃。是经不在十二部数。即是魔说非是佛说。善男子。如是之人虽我弟子。不能信顺是涅槃经。善男子。当尔之时若有众生。信此经典乃至半句。当知是人真我弟子。因如是信即见佛性入于涅槃

尔时光明遍照高贵德王菩萨白佛言。世尊。善哉善哉。如来今日善能开示大涅槃经。世尊。我因是事即得悟解大涅槃经一句半句以解一句至半句故见少佛性。如佛所说。我亦当得入大涅槃。是名菩萨修大涅槃微妙经典具足成就第十功德

大般涅槃经卷第二十四大般涅槃经卷第二十五

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品第二十三之一

尔时佛告一切大众。诸善男子。汝等若疑有佛无佛有法无法有僧无僧有苦无苦有集无集有灭无灭有道无道有实无实有我无我有乐无乐有净无净有常无常有乘无乘有性无性有众生无众生有有无有有真无真有因无因有果无果有作无作有业无业有报无报者。今恣汝问。吾当为汝分别解说。善男子。我实不见若天若人若魔若梵若沙门若婆罗门有来问我不能答者

尔时会中有一菩萨名师子吼。即从座起敛容整服前礼佛足。长跪叉手白佛言。世尊。我适欲问。如来大慈复垂听许

尔时佛告诸大众言。诸善男子。汝等今当于是菩萨深生恭敬尊重赞叹。应以种种香花伎乐璎珞幡盖衣服饮食卧具医药房舍殿堂而供养之迎来送去。所以者何。是人已于过去诸佛深种善根福德成就。是故今于我前欲师子吼。善男子。如师子王自知身力牙爪锋铓四足据地安住岩穴振尾出声。若有能具如是诸相当知是则能师子吼。真师子王晨朝出穴频申欠呿。四向顾望发声震吼。为十一事。何等十一。一为欲坏实非师子诈作师子故。二为欲试自身力故。三为欲令住处净故。四为诸子知处所故。五为群辈无怖心故。六为眠者得觉悟故。七为一切放逸诸兽不放逸故。八为诸兽来依附故。九为欲调诸香象故。十为教告诸子息故。十一为欲庄严自眷属故。一切禽兽闻师子吼。水性之属潜没深渊。陆行之类藏伏窟穴。飞者堕落。诸大香象怖走失粪。诸善男子。如彼野干虽逐师子至于百年。终不能作师子吼也。若师子子始满三年则能哮吼如师子王。善男子。如来正觉智慧牙爪。四如意足六波罗蜜满足之身。十力雄猛大悲为尾。安住四禅清净窟宅。为诸众生而师子吼。摧破魔军示众十力。开佛行处为诸邪见作归依所。安抚生死怖畏之众。觉悟无明睡眠众生。行恶法者为作悔心。开示邪见一切众生。令知六师非师子吼故。破富兰那等憍慢心故。为令二乘生悔心故。为教五住诸菩萨等生大力心故。为令正见四部之众于彼邪见四部徒众不生怖畏故从圣行梵行天行窟宅频申而出。为欲令彼诸众生等破憍慢故。欠呿为令诸众生等生善法故。四向顾望为令众生得四无碍故。四足据地为令众生具足安住尸波罗蜜故。故师子吼。师子吼者名决定说。一切众生悉有佛性。如来常住无有变易。善男子。声闻缘觉虽复随逐如来世尊无量百千阿僧祇劫。而亦不能作师子吼。十住菩萨若能修行是三行处。当知是则能师子吼。诸善男子。是师子吼菩萨摩诃萨。今欲如是大师子吼。是故汝等应当深心供养恭敬尊重赞叹

尔时世尊告师子吼菩萨摩诃萨言。善男子。汝若欲问今可随意。师子吼菩萨摩诃萨白佛言。世尊。云何为佛性。以何义故名为佛性。何故复名常乐我净。若一切众生有佛性者。何故不见一切众生所有佛性。十住菩萨住何等法不了了见。佛住何等法而了了见。十住菩萨以何等眼不了了见。佛以何眼而了了见

佛言。善男子。善哉善哉。若有人能为法咨启。则为具足二种庄严。一者智慧。二者福德。若有菩萨具足如是二庄严者则知佛性。亦复解知名为佛性。乃至能知十住菩萨以何眼见诸佛世尊以何眼见

师子吼菩萨言。世尊。云何名为智慧庄严。云何名为福德庄严

善男子。慧庄严者。谓从一地乃至十地。是名慧庄严。福德庄严者。谓檀波罗蜜乃至般若。非般若波罗蜜。复次善男子。慧庄严者。所谓诸佛菩萨福德庄严者。谓声闻缘觉九住菩萨

复次善男子。福德庄严者。有为有漏有有有果报有碍非常。是凡夫法。慧庄严者。无为无漏无有无果报无碍常住。善男子。汝今具足是二庄严。是故能问甚深妙义。我亦具足是二庄严能答是义

师子吼菩萨摩诃萨言。世尊。若有菩萨具足如是二庄严者。则不应问一种二种。云何世尊。说言能答一种二种。所以者何。一切诸法无一二种。一种二种者是凡夫相

佛言。善男子。若有菩萨。无二种庄严。则不能知一种二种。若有菩萨具二庄严。则能解知一种二种。若言诸法无一二者。是义不然。何以故。若无一二云何得说一切诸法无一无二。善男子。若言一二是凡夫相。是乃名为十住菩萨非凡夫也。何以故。一者名为涅槃。二者名为生死。何故一者名为涅槃。以其常故。何故二者名为生死。爱无明故。常涅槃者非凡夫相。生死二者亦非凡夫相。以是义故。具二庄严者能问能答善男子。汝问云何为佛性者。谛听谛听。吾当为汝分别解说。善男子。佛性者名第一义空。第一义空名为智慧。所言空者不见空与不空。智者见空及与不空常与无常苦之与乐我与无我。空者一切生死。不空者谓大涅槃。乃至无我者即是生死。我者谓大涅槃。见一切空不见不空。不名中道。乃至见一切无我不见我者。不名中道。中道者名为佛性。以是义故佛性常恒无有变易。无明覆故令诸众生不能得见。声闻缘觉见一切空不见不空。乃至见一切无我不见于我。以是义故不得第一义空。不得第一义空故不行中道。无中道故不见佛性。善男子不见中道者凡有三种。一定乐行。二定苦行。三者苦乐行。定乐行者。所谓菩萨摩诃萨怜愍一切诸众生故。虽复处在阿鼻地狱如三禅乐。定苦行者。谓诸凡夫。苦乐行者。谓声闻缘觉。声闻缘觉行于苦乐作中道想。以是义故。虽有佛性而不能见。如汝所问。以何义故名佛性者。善男子。佛性者。即是一切诸佛阿耨多罗三藐三菩提中道种子。复次善男子。道有三种。谓下上中。下者梵天无常谬见是常。上者生死无常谬见是常。三宝是常横计无常。何故名上。能得最上阿耨多罗三藐三菩提故。中者名第一义空。无常见无常。常见于常。第一义空不名为下。何以故。一切凡夫所不得故不名为上。何以故。即是上故。诸佛菩萨所修之道不上不下。以是义故名为中道

复次善男子。生死本际凡有二种。一者无明。二者有爱。是二中间则有生老病死之苦。是名中道。如是中道能破生死。故名为中。以是义故。中道之法名为佛性。是故佛性常乐我净以诸众生不能见故。无常无乐无我无净。佛性实非无常无乐无我无净。善男子。譬如贫人家有宝藏是人不见以不见故无常无乐无我无净。有善知识而语之言。汝舍宅中有金宝藏。何故如是贫穷困苦无常无乐无我无净。即以方便令彼得见。以得见故是人即得常乐我净。佛性亦尔。众生不见。以不见故无常无乐无我无净。有善知识诸佛菩萨。以方便力种种教告令彼得见。以得见故众生即得常乐我净

复次善男子。众生起见凡有二种。一者常见。二者断见。如是二见不名中道。无常无断乃名中道。无常无断即是观照十二缘智。如是观智是名佛性。二乘之人虽观因缘。犹亦不得名为佛性。佛性虽常以诸众生无明覆故不能得见。又未能渡十二缘河。犹如兔马。何以故。不见佛性故。善男子。是观十二因缘智慧。即是阿耨多罗三藐三菩提种子。以是义故。十二因缘名为佛性。善男子。譬如胡苽名为热病。何以故。能为热病作因缘故。十二因缘亦复如是。善男子。佛性者有因有因因。有果有果果。有因者即十二因缘。因因者即是智慧。有果者即是阿耨多罗三藐三菩提。果果者即是无上大般涅槃。善男子。譬如无明为因诸行为果行因识果。以是义故。彼无明体亦因亦因因。识亦果亦果果。佛性亦尔。善男子。以是义故。十二因缘不出不灭不常不断非一非二不来不去非因非果。善男子。是因非果。如佛性是果非因。如大涅槃是因是果。如十二因缘所生之法非因非果。名为佛性。非因果故常恒无变。以是义故。我经中说十二因缘其义甚深。无知无见不可思惟。乃是诸佛菩萨境界。非诸声闻缘觉所及。以何义故甚深甚深。众生业行不常不断而得果报。虽念念灭而无所失。虽无作者而有作业。虽无受者而有果报。受者虽灭果不败亡。无有虑知和合而有。一切众生虽与十二因缘共行而不见知。不见知故无有终始。十住菩萨唯见其终不见其始。诸佛世尊见始见终。以是义故。诸佛了了得见佛性。善男子。一切众生不能见于十二因缘。是故轮转。善男子。如蚕作茧自生自死。一切众生亦复如是。不见佛性故自造结业流转生死。犹如拍鞠。善男子。是故我于诸经中说。若有人见十二缘者即是见法。见法者即是见佛。佛者即是佛性。何以故。一切诸佛以此为性。善男子。观十二缘智凡有四种。一者下。二者中。三者上。四者上上。下智观者不见佛性。以不见故得声闻道。中智观者不见佛性。以不见故得缘觉道。上智观者见不了了。不了了故住十住地。上上智观者见了了。故得阿耨多罗三藐三菩提道。以是义故。十二因缘名为佛性。佛性者即第一义空。第一义空名为中道。中道者即名为佛。佛者名为涅槃

尔时师子吼菩萨摩诃萨白佛言。世尊。若佛与佛性无差别者。一切众生何用修道佛言。善男子。如汝所问是义不然。佛与佛性虽无差别。然诸众生悉未具足。善男子。譬如有人恶心害母害已生悔。二业虽善是人故名地狱人也。何以故。是人定当堕地狱故。是人虽无地狱阴界诸入。犹故得名为地狱人。善男子。是故我于诸经中说若见有人修行善者名见天人。修行恶者名见地狱。何以故。定受报故。善男子。一切众生定得阿耨多罗三藐三菩提故。是故我说一切众生悉有佛性。一切众生真实未有三十二相八十种好。以是义故。我于此经而说是偈

  本有今无　　本无今有　　三世有法
  无有是处

善男子。有者凡有三种。一未来有。二现在有。三过去有。一切众生未来之世当有阿耨多罗三藐三菩提。是名佛性。一切众生现在悉有烦恼诸结。是故现在无有三十二相八十种好。一切众生过去之世有断烦恼。是故现在得见佛性。以是义故。我常宣说一切众生悉有佛性。乃至一阐提等亦有佛性。一阐提等无有善法佛性亦善。以未来有故。一阐提等悉有佛性。何以故。一阐提等定当得成阿耨多罗三藐三菩提故。善男子。譬如有人家有乳酪。有人问言汝有酥耶。答言我有酪实非酥。以巧方便定当得故。故言有酥。众生亦尔。悉皆有心。凡有心者定当得成阿耨多罗三藐三菩提。以是义故。我常宣说一切众生悉有佛性。善男子。毕竟有二种。一者庄严毕竟。二者究竟毕竟。一者世间毕竟。二者出世毕竟。庄严毕竟者六波罗蜜。究竟毕竟者一切众生所得一乘。一乘者名为佛性。以是义故。我说一切众生悉有佛性。一切众生悉有一乘。以无明覆故不能得见。善男子。如郁单曰三十三天果报覆故此间众生不能得见。佛性亦尔。诸结覆故众生不见复次善男子。佛性者即首楞严三昧。性如醍醐。即是一切诸佛之母。以首楞严三昧力故。而令诸佛常乐我净。一切众生悉有首楞严三昧。以不修行故不得见。是故不能得成阿耨多罗三藐三菩提。善男子。首楞严三昧者有五种名。一者首楞严三昧。二者般若波罗蜜。三者金刚三昧。四者师子吼三昧。五者佛性。随其所作处处得名。善男子。如一三昧得种种名。如禅名四禅。根名定根。力名定力。觉名定觉。正名正定。八大人觉名为定觉。首楞严定亦复如是。善男子。一切众生具足三定。谓上中下。上者谓佛性也。以是故言一切众生悉有佛性。中者一切众生具足初禅。有因缘时则能修习。若无因缘则不能修。因缘二种。一谓火灾。二谓破欲界结。以是故言一切众生悉具中定。下定者十大地中心数定也。以是故言一切众生悉具下定。一切众生悉有佛性。烦恼覆故不能得见。十住菩萨虽见一乘。不知如来是常住法。以是故言十住菩萨虽见佛性而不明了。善男子。首楞者名一切毕竟。严者名坚。一切毕竟而得坚固。名首楞严。以是故言首楞严定名为佛性

善男子。我于一时住尼连禅河。告阿难言。我今欲洗。汝可取衣及以澡豆。我既入水。一切飞鸟水陆之属悉来观我。尔时复有五百梵志来在河边。因到我所各相谓言。云何而得金刚之身。若使瞿昙不说断见。我当从其启受斋法。善男子。我于尔时以他心智。知是梵志心之所念。告梵志言。云何谓我说于断见。彼梵志言。瞿昙。先于处处经中说诸众。生悉有无我。既言无我。云何而言非断见耶。若无我者。持戒者谁破戒者谁。佛言。我亦不说一切众生悉有无我。我常宣说一切众生悉有佛性。佛性者岂非我耶。以是义故我不说断。一切众生不见佛性故。无常无我无乐无净。如是则名说断见也。时诸梵志闻说佛性即是我故。即发阿耨多罗三藐三菩提心。寻时出家修菩提道。一切飞鸟水陆之属。亦发无上菩提之心。既发心已寻得舍身。善男子。是佛性者实非我也。为众生故说名为我。善男子。如来有因缘故说无我为我。真实无我。虽作是说无有虚妄。善男子。有因缘故说我为无我。而实有我。为世界故。虽说无我而无虚妄。佛性无我如来说我。以是常故。如来是我而说无我。得自在故

尔时师子吼菩萨摩诃萨白佛言。世尊。若一切众生悉有佛性如金刚力士者。以何义故。一切众生不能得见

佛言。善男子。譬如色法虽有青黄赤白之异长短质像盲者不见。虽复不见。亦不得言无青黄赤白长短质像。何以故盲虽不见。有目见故。佛性亦尔。一切众生虽不能见。十住菩萨见少分故。如来全见。十住菩萨所见佛性如夜见色。如来所见如昼见色。善男子。譬如瞎者见色不了。有善良医而为治目以药力故得了了见。十住菩萨亦复如是。虽见佛性不能明了。以首楞严三昧力故能得明了。善男子。若有人见一切诸法无常无我无乐无净。见非一切法亦无常无我无乐无净。如是之人不见佛性。一切者名为生死。非一切者名为三宝。声闻缘觉见一切法无常无我无乐无净。非一切法亦见无常无我无乐无净。以是义故不见佛性。十住菩萨见一切法无常无我无乐无净。非一切法分见常乐我净。以是义故。十分之中得见一分。诸佛世尊见一切法无常无我无乐无净。非一切法见常乐我净。以是义故。见于佛性如观掌中阿摩勒果。以是义故。首楞严定名为毕竟。善男子。譬如初月虽不可见不得言无。佛性。亦尔。一切凡夫虽不得见亦不得言无佛性也

善男子。佛性者所谓十力四无所畏大悲三念处。一切众生悉有三种破烦恼故然后得见。一阐提等破一阐提。然后能得十力四无所畏大悲三念处。以是义故。我常宣说一切众生悉有佛性

善男子。十二因缘一切众生等共有之。亦内亦外。何等十二。过去烦恼名为无明。过去业者则名为行。现在世中初始受胎是名为识。入胎五分四根未具名为名色。具足四根未名触时是名六入。未别苦乐是名为触。染习一爱是名为受。习近五欲是名为爱。内外贪求是名为取。为内外事起身口意业是名为有。现在世识名未来生。现在名色六入触受。名未来世老病死也。是名十二因缘。善男子。一切众生虽有如是十二因缘或有未具。如歌罗逻时死则无十二。从生乃至老死得具十二。色界众生无三种受三种触三种爱无有老病。亦得名为具足十二。无色众生无色乃至无有老死。亦得名为具足十二。以定得故。故名众生平等具有十二因缘。善男子。佛性亦尔。一切众生定当得成阿耨多罗三藐三菩提故。是故我说一切众生悉有佛性。善男子。雪山有草名为忍辱。牛若食者则出醍醐。更有异草。牛若食者则无醍醐。虽无醍醐不可说言雪山之中无忍辱草。佛性亦尔。雪山者名为如来。忍辱草者名大涅槃。异草者十二部经。众生若能听受咨启大般涅槃则见佛性。十二部中虽不闻有。不可说言无佛性也

善男子。佛性者亦色非色非色非非色。亦相非相非相非非相。亦一非一非一非非一。非常非断非非常非非断。亦有亦无非有非无。亦尽非尽非尽非非尽。亦因亦果非因非果。亦义非义非义非非义。亦字非字非字非非字。云何为色。金刚身故。云何非色。十八不共非色法故。云何非色非非色。色非色无定相故。云何为相。三十二相故。云何非相。一切众生相不现故。云何非相非非相。相非相不决定故。云何为一。一切众生悉一乘故。云何非一。说三乘故。云何非一非非一。无数法故。云何非常。从缘见故。云何非断。离断见故。云何非非常非非断。无终始故。云何为有。一切众生悉皆有故。云何为无。从善方便而得见故。云何非有非无。虚空性故。云何名尽。得首楞严三昧故。云何非尽。以其常故。云何非尽非非尽。一切尽相断故。云何为因。以了因故。云何为果以决定故。云何非因非果。以其常故。云何为义。悉能摄取义无碍故。云何非义。不可说故。云何非义非非义。毕竟空故。云何为字。有名称故。云何非字。名无名故。云何非字非非字。断一切字故。云何非苦非乐。断一切受故。云何非我。未能具得八自在故。云何非非我。以其常故。云何非我非非我。不作不受故。云何为空。第一义空故。云何非空。以其常故。云何非空非非空。能为善法作种子故。善男子。若有人能思惟解了大涅槃经如是之义。当知是人则见佛性。佛性者不可思议。乃是诸佛如来境界。非诸声闻缘觉所知。善男子。佛性者非阴界入。非本无今有。非已有还无。从善因缘众生得见。譬如黑铁入火则赤出冷还黑。而是黑色非内非外。因缘故有。佛性亦尔。一切众生烦恼火灭则得闻见。善男子。如种灭已芽则得生。而是芽性非内非外。乃至花果亦复如是。从缘故有。善男子。是大涅槃微妙经典。成就具足无量功德佛性亦尔。悉是无量无边功德之所成就

尔时师子吼菩萨摩诃萨言。世尊。菩萨具足成就几法得见佛性而不明了。诸佛世尊成就几法得了了见

善男子。菩萨具足成就十法。虽见佛性而不明了。云何为十。一者少欲。二者知足。三者寂静。四者精进。五者正念。六者正定。七者正慧。八者解脱。九者赞叹解脱。十者以大涅槃教化众生。师子吼菩萨言。世尊。少欲知足有何差别。善男子。少欲者不求不取。知足者得少之时心不悔恨。少欲者少有所欲。知足者但为法事心不愁恼。善男子。欲者有三。一者恶欲。二者大欲。三者欲欲。恶欲者。若有比丘心生贪欲。欲为一切大众上首。令一切僧随逐我后。令诸四部悉皆供养恭敬赞叹尊重于我。令我先为四众说法。皆令一切信受我语。亦令国王大臣长者皆恭敬我。令我大得衣服饮食卧具医药上妙屋宅。为生死欲是名恶欲。云何大欲。若有比丘生于欲心。云何当令四部之众。悉皆知我得初住地乃至十住。得阿耨多罗三藐三菩提。得阿罗汉果乃至须陀洹果。我得四禅乃至四无阂智。为于利养是名大欲。欲欲者。若有比丘欲生梵天魔天自在天转轮圣王若刹利若婆罗门皆得自在。为利养故是名欲欲。若不为是三种恶欲之所害者。是名少欲。欲者名为二十五爱无有如是二十五爱。是名少欲。不求未来所欲之事。是名少欲。得而不着是名知足。不求恭敬是名少欲。得不积聚是名知足。善男子。亦有少欲不名知足。有知足不名少欲。有亦少欲亦知足。有不知足不少欲。少欲者谓须陀洹。知足者谓辟支佛。少欲知足者谓阿罗汉。不少欲不知足者所谓菩萨。善男子。少欲知足复有二种。一者善。二者不善。不善者所谓凡夫。善者圣人菩萨。一切圣人虽得道果不自称说。不称说故心不恼恨。是名知足。善男子。菩萨摩诃萨修习大乘大涅槃经欲见佛性。是故修习少欲知。足。云何寂静。寂静有二。一者心静。二者身静。身寂静者终不造作身三种恶。心寂静者亦不造作意三种恶。是则名为身心寂静身寂静者不亲近四众。不预四众所有事业。心寂静者终不修习贪欲恚痴。是则名为身心寂静。或有比丘身虽寂静心不寂静。有心寂静身不寂静。有身心寂静。又有身心俱不寂静。身寂静心不寂静者。或有比丘坐禅静处远离四众。心常积集贪欲嗔痴。是名身寂静心不寂静。心寂静身不寂静者。或有比丘亲近四众国王大臣。断贪恚痴。是名心寂静身不寂静。身心寂静者。谓佛菩萨。身心不寂静者。谓诸凡夫。何以故。凡夫之人身心虽静。不能深观无常无乐无我无净。以是义故。凡夫之人不能寂静身口意业。一阐提辈犯四重禁作五逆罪。如是之人亦不得名身心寂静。云何精进。若有比丘欲令身口意业清净。远离一切诸不善业。修习一切诸善业者。是名精进。是勤进者系念六处。所谓佛法僧戒施天。是名正念。具正念者所得三昧。是名正定。具正定者观见诸法犹如虚空。是名正慧。具正慧者远离一切烦恼诸结。是名解脱。得解脱者为诸众生称美解脱。言是解脱常恒不变。是名赞叹解脱。解脱即是无上大般涅槃。涅槃者即是烦恼诸结火灭。又涅槃者名为屋宅。何以故。能遮烦恼恶风雨故。又涅槃者名为归依。何以故。能过一切诸怖畏故。又涅槃者名为洲渚。何以故。四大暴河不能漂故。何等为四。一者欲暴。二者有暴。三者见暴。四无明暴。是故涅槃名为洲渚。又涅槃者名毕竟归。何以故。能得一切毕竟乐故。若有菩萨摩诃萨。成就具足如是十法。虽见佛性而不明了。复次善男子。出家之人有四种病。是故不得四沙门果。何等四病。谓四恶欲。一为衣欲二为食欲。三为卧具欲。四为有欲。是名四恶欲。是出家病。有四良药能疗是病。谓粪扫衣能治比丘为衣恶欲。乞食能破为食恶欲。树下能破卧具恶欲。身心寂静能破比丘为有恶欲。以是四药除是四病。是名圣行如是圣行则得名为少欲知足。寂静者有四种乐。何等为四。一者出家乐。二寂静乐。三永灭乐。四毕竟乐。得是四乐名为寂静。具四精进故名精进。具四念处故名正念。具四禅故。故名正定。见四圣实故。故名正慧永断一切烦恼结故。故名解脱。呵说一切烦恼过故。故名赞叹解脱。善男子。菩萨摩诃萨安住具足如是十法。虽见佛性而不明了。复次善男子。菩萨摩诃萨闻是经已亲近修习。远离一切世间之事。是名少欲。既出家已不生悔心。是名知足。既知足已。近空闲处远离愦闹。是名寂静。不知足者不乐空闲。夫知足者常乐空寂。于空寂处常作是念。一切世间悉谓我得沙门道果。然我今者实未能得。我今云何诳惑于人。作是念已。精勤修习沙门道果。是名精进。亲近修习大涅槃者。是名正念。随顺天行。是名正定。安住是定正见正知。是名正慧。正见知者能得远离烦恼结缚。是名解脱。十住菩萨为众生故称美涅槃。是则名为赞叹解脱。善男子。菩萨摩诃萨安住具足如是十法。虽见佛性而不明了。复次善男子。夫少欲者。若有比丘住空寂处端坐不卧。或住树下。或在冢间。或在露处。随有草地而坐其上。乞食而食随得为足。或一坐食不过一食唯畜三衣粪衣毳衣。是名少欲。既行是事心不生悔。是名知足。修空三昧。是名寂静。得四果已于阿耨多罗三藐三菩提心不休息。是名精进。系心思惟如来常恒无有变易。是名正念。修八解脱是名正定。得四无碍是名正慧。远离七漏是名解脱。称美涅槃无有十相名叹解脱。十相者。谓生老病死色声香味触无常。远离十相者名大涅槃。善男子。是名菩萨摩诃萨安住具足如是十法虽见佛性而不明了。复次善男子。为多欲故亲近国王大臣长者刹利婆罗门毗舍首陀。自称我得须陀洹果至阿罗汉果为利养故。行住坐卧乃至大小便利。若见檀越犹行恭敬接引语言。破恶欲者名为少欲虽未能坏诸结烦恼。而能同于如来行处。是名知足。善男子。如是二法乃是念定近因缘也。常为师宗同学所赞。我亦常于处处经中。称美赞叹如是二法。若能具足是二法者。则得近于大涅槃门及五种乐。是名寂静。坚持戒者名为精进。有惭愧者名为正念。不见心相名为正定。不求诸法性相因缘。是名正慧。无有相故烦恼则断。是名解脱。称美如是大涅槃经。名赞解脱。善男子。是名菩萨摩诃萨安住十法。虽见佛性而不明了。善男子。如汝所问。十住菩萨以何眼故。虽见佛性而不了了。诸佛世尊以何眼故。见于佛性而得了了。善男子。慧眼见故不得明了。佛眼见故故得明了。为菩提行故则不了了。若无行故。则得了了。住十住故虽见不了。不住不去故得了了。菩萨摩诃萨智慧因故见不了了。诸佛世尊断因果故见则了了。一切觉者名为佛性。十住菩萨不得名为一切觉故。是故虽见而不明了。善男子。见有二种。一者眼见。二者闻见。诸佛世尊眼见佛性。如于掌中观阿摩勒。十住菩萨闻见佛性故不了了。十住菩萨唯能自知定得阿耨多罗三藐三菩提。而不能知一切众生悉有佛性

大般涅槃经卷第二十五大般涅槃经卷第二十六

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品之二

善男子。复有眼见。诸佛如来十住菩萨眼见佛性。复有闻见。一切众生乃至九地闻见佛性。菩萨若闻一切众生悉有佛性。心不生信不名闻见

善男子。若有善男子善女人欲见如来。应当修习十二部经受持读诵书写解说师子吼菩萨摩诃萨言。世尊。一切众生不能得知如来心相。当云何观而得知耶

善男子。一切众生实不能知如来心相。若欲观察而得知者。有二因缘。一者眼见。二者闻见。若见如来所有身业。当知是则为如来也。是名眼见。若观如来所有口业。当知是则为如来也。是名闻见。若见色貌一切众生无与等者。当知是则为如来也。是名眼见。若闻音声微妙最胜。不同众生所有音声。当知是则为如来也。是名闻见。若见如来所作神通。为众生为利养。若为众生不为利养。当知是则为如来也。是名眼见。若观如来以他心智观众生时。为利养说为众生说。若为众生不为利养。当知是则为如来也。是名闻见。云何如来而受是身。何故受身为谁受身。是名眼见。若观如来云何说法。何故说法为谁说法。是名闻见。以身恶业加之不嗔。当知是则为如来也。是名眼见。以口恶业加之不嗔。当知是则为如来也。是名闻见。若见菩萨初生之时。于十方面各行七步。摩尼跋陀富那跋陀鬼神大将执持幡盖。震动无量无边世界。金光晃曜弥满虚空。难陀龙王及跋难陀。以神通力浴菩萨身。诸天形像承迎礼拜。阿私陀仙合掌恭敬。盛年舍欲如弃涕唾。不为世乐之所迷惑。出家修道乐于闲寂。为破邪见六年苦行。于诸众生平等无二。心常在定初无散乱。相好严丽庄饰其身所游之处丘墟皆平。衣服离身四寸不堕。行时直视不顾左右。所食之物物无完过。坐起之处草不动乱。为调众生故往说法心无憍慢。是名眼见。若闻菩萨行七步已唱如是言。我今此身最是后边。阿私陀仙合掌而言。大王当知。悉达太子定当得成阿耨多罗三藐三菩提。终不在家作转轮王。何以故。相明了故。转轮圣王相不明了。悉达太子身相炳着。是故必得阿耨多罗三藐三菩提。见老病死复作是言。一切众生甚可怜愍。常与如是生老病死共相随逐而不能观。常行于苦我当断之。从阿罗逻五通仙人受无想定。既成就已后说其非。从郁陀仙受非有想非无想定。既成就已。说非涅槃是生死法。六年苦行无所克获。即作是言。修是苦行空无所得。若是实者我应得之。以虚妄故我无所得。是名邪术非正道也。既成道已。梵天劝请。惟愿如来当为众生广开甘露说无上法。佛言。梵王。一切众生常为烦恼之所障覆。不能受我正法之言。梵王复言。世尊。一切众生凡有三种。所谓利根中根钝根。利根能受惟愿为说。佛言。梵王。谛听谛听。我今当为一切众生开甘露门。即于波罗奈国转正法轮宣说中道。一切众生不破诸结非不能破。非破非不破故名中道。不度众生非不能度。是名中道。非一切成亦非不成。是名中道。凡有所说不自言师不言弟子。是名中道。说不为利非不得果。是名中道。正语实语时语真语。言不虚发微妙第一。如是等法是名闻见。善男子。如来心相实不可见。若有善男子善女人欲见如来。应当依是二种因缘尔时师子吼菩萨摩诃萨白佛言。世尊。如先所说。庵罗果喻四种人等。有人行细心不正实。有人心细行不正实。有人心细行亦正实。有人心不细行不正实。是初二种云何可知。如佛所说。唯依是二不可得知

佛言。善哉善哉。善男子。庵罗果喻二种人等实难可知。以难知故。我经中说当与共住。住若不知当与久处。久处不知当以智慧。智慧不知当深观察。以观察故则知持戒及以破戒。善男子。具是四事。共住久处智慧观察。然后得知持戒破戒。善男子。戒有二种。持者亦二。一究竟。二不究竟。有人以因缘故受持禁戒。智者当观。是人持戒为为利养为究竟持。善男子。如来戒者无有因缘。是故得名为究竟戒。以是义故。菩萨虽为诸恶众生之所伤害不生恚碍。是故如来得名成就毕竟持戒究竟持戒。善男子。我昔一时与舍利弗及五百弟子俱。共止住摩伽陀国瞻婆大城。时有猎师追逐一鸽。是鸽惶怖至舍利弗影。犹故战栗如芭蕉树。至我影中身心安隐恐怖得除。是故当知。如来世尊毕竟持戒。乃至身影犹有是力。善男子。不究竟戒尚不能得声闻缘觉。何况能得阿耨多罗三藐三菩提。复有二种。一为利养。二为正法。为利养故受持禁戒。当知是戒不见佛性及以如来。虽闻佛性及如来名。犹不得名为闻见也。若为正法受持禁戒。当知是戒能见佛性及以如来。是名眼见。亦名闻见。复有二种。一者根深难拔。二者根浅易动。若能修习空无相愿。是名根深难拔。若不修习是三三昧。虽复修习为二十五有。是名根浅易动。复有二种。一为自身。二为众生。为众生者能见佛性及以如来。持戒之人复有二种。一者性自能持。二者须他教敕。若受戒已经无量世初不漏失。或值恶国遇恶知识恶时恶世。闻邪恶法邪见同止。尔时虽无受戒之法。修持如本无所毁犯。是名性自能持。若遇师僧白四羯磨然后得戒。虽得戒已。要凭和上诸师同学善友诲喻乃知进止。听法说法备诸威仪。是名须他教敕。善男子。性能持者眼见佛性及以如来。亦名闻见。戒复有二。一声闻戒。二菩萨戒。从初发心乃至得成阿耨多罗三藐三菩提。是名菩萨戒。若观白骨乃至证得阿罗汉果。是名声闻戒。若有受持声闻戒者。当知是人不见佛性及以如来。若有受持菩萨戒者。当知是人得阿耨多罗三藐三菩提。能见佛性如来涅槃

师子吼菩萨言。世尊。何因缘故受持禁戒。佛言。善男子。为心不悔故。何故不悔。为受乐故。何故受乐。为远离故。何故远离。为安隐故。何故安隐。为禅定故。何故禅定。为实知见故。何故为实知见。为见生死诸过患故。何故为见生死过患。为心不贪着故。何故为心不贪着。为得解脱故。何故为得解脱。为得无上大涅槃故。何故为得大般涅槃。为得常乐我净法故。何故为得常乐我净。为得不生不灭故。何故为得不生不灭。为见佛性故。是故菩萨性自能持究竟净戒。善男子。持戒比丘虽不发愿求不悔心。不悔之心自然而得。何以故法性尔故虽不求乐远离安隐真实知见。见生死过心不贪着。解脱涅槃常乐我净不生不灭。见于佛性而自然得。何以故法性尔故师子吼菩萨言。世尊。若因持戒得不悔果。因于解脱得涅槃果者。戒则无因涅槃无果。戒若无因则名为常。涅槃有因则是无常。若尔者涅槃则为本无今有。若本无今有是为无常。犹如然灯。涅槃若尔。云何得名我乐净耶

佛言。善男子。善哉善哉。汝以曾于无量佛所种诸善根。能问如来如是深义。善男子。不失本念乃如是问也。我忆往昔过无量劫。波罗奈城有佛出世号曰善得。尔时彼佛三亿岁中。演说如是大涅槃经。我时与汝俱在彼会。我以是事咨问彼佛。尔时如来为众生故。三昧正受未答此义。善哉大士。乃能忆念如是本事。谛听谛听当为汝说。戒亦有因。谓听正法。听正法者是亦有因。谓近善友。近善友者是亦有因。所谓信心。有信心者是亦有因。因有二种。一者听法。二思惟义。善男子。信心者因于听法。听法者因于信心。如是二法亦因亦因因。亦果亦果果。善男子。譬如尼干立拒举瓶互为因果不得相离。善男子。如无明缘行行缘无明。是无明行亦因亦因因。亦果亦果果。乃至生缘老死老死缘生。是生老死亦因亦因因。亦果亦果果。善男子。生能生法不能自生。不自生故由生生生。生生不自生赖生故生。是故二生亦因亦因因。亦果亦果果。善男子。信心听法亦复如是。善男子。是果非因谓大涅槃何故名果。是上果故。沙门果故。婆罗门果故。断生死故。破烦恼故。是故名果。为诸烦恼之所呵责。是故涅槃名果。烦恼者名为过过。善男子。涅槃无因而体是果。何以故。无生灭故。无所作故。非有为故。是无为故。常不变故。无处所故。无始终故。善男子。若涅槃有因则不得称为涅槃也。槃者言因。般涅言无。无有因故故称涅槃

师子吼菩萨言。如佛所说。涅槃无因是义不然若言无者则合六义。一者毕竟无故名之为无。如一切法无我无我所。二者有时无故名之为无。如世人言河池无水无有日月。三者少故名之为无。如世人言食中少碱名为无碱。甘浆少甜名为无甜。四者无受故名之为无。如旃陀罗不能受持婆罗门法。是故名为无婆罗门。五者受恶法故名之为无。如世人言受恶法者不名沙门及婆罗门。是故名为无有沙门及婆罗门。六者不对故名之为无。譬如无白名之为黑无有明故名之无明。世尊。涅槃亦尔。有时无因故名涅槃

佛言善男子。汝今所说如是六义。何故不引毕竟无者以喻涅槃。乃取有时无耶。善男子。涅槃之体毕竟无因。犹如无我及无我所。善男子。世法涅槃终不相对。是故六事不得为喻。善男子。一切诸法悉无有我。而此涅槃真实有我。以是义故。涅槃无因而体是果。是因非果名为佛性。非因生故是因非果。非沙门果故名非果。何故名因。以了因故。善男子。因有二种。一者生因。二者了因。能生法者是名生因。灯能了物故名了因。烦恼诸结是名生因。众生父母是名了因。如谷子等是名生因。地水粪等是名了因。复有生因。谓六波罗蜜阿耨多罗三藐三菩提。复有了因。谓佛性阿耨多罗三藐三菩提。复有了因。谓六波罗蜜佛性。复有生因。谓首楞严三昧阿耨多罗三藐三菩提。复有了因。谓八正道阿耨多罗三藐三菩提。复有生因。所谓信心六波罗蜜师子吼菩萨言。世尊。如佛所说。见于如来及以佛性。是义云何。世尊。如来之身无有相貌。非长非短非白非黑。无有方所不在三界。非有为相非眼识识。云何可见。佛性亦尔

佛言。善男子。佛身二种。一者常。二者无常。无常者为欲度脱一切众生方便示现。是名眼见。常者如来世尊解脱之身。亦名眼见亦名闻见。佛性亦二。一者可见。二不可见。可见者十住菩萨诸佛世尊。不可见者一切众生。眼见者谓十住菩萨诸佛如来眼见众生所有佛性。闻见者一切众生九住菩萨闻有佛性。如来之身复有二种。一者是色。二者非色。色者如来解脱。非色者如来永断诸色相故。佛性二种。一者是色。二者非色。色者阿耨多罗三藐三菩提。非色者凡夫乃至十住菩萨。十住菩萨见不了了。故名非色。善男子。佛性者复有二种。一者是色。二者非色。色者谓佛菩萨。非色者一切众生。色者名为眼见。非色者名为闻见。佛性者非内非外。虽非内外然非失坏。故名众生悉有佛性

师子吼菩萨言。世尊。如佛所说。一切众生悉有佛性如乳中有酪。金刚力士诸佛佛性如清醍醐。云何如来说言佛性非内非外

佛言。善男子。我亦不说乳中有酪。酪从乳生故言有酪。世尊。一切生法各有时节。善男子。乳时无酪亦无生酥熟酥醍醐。一切众生亦谓是乳。是故我言乳中无酪。如其有者何故不得二种名字。如人二能言金铁师。酪时无乳生酥熟酥及以醍醐。众生亦谓是酪非乳非生熟酥及以醍醐。乃至醍醐亦复如是。善男子。因有二种。一者正因。二者缘因。正因者如乳生酪。缘因者如酵暖等。从乳生故。故言乳中而有酪性师子吼菩萨言。世尊。若乳无酪性角中亦无。何故不从角中生耶

善男子。角亦生酪。何以故。我亦说言缘因有二。一酵二暖。角性暖故亦能生酪。师子吼言。世尊。若角能生酪求酪之人何故求乳而不取角。佛言。善男子。是故我说正因缘因。师子吼菩萨言。若使乳中本无酪性今方有者。乳中本无庵摩罗树。何故不生。二俱无故。善男子。乳亦能生庵摩罗树。若以乳灌一夜之中增长五尺。以是义故我说二因。善男子。若一切法一因生者可得难言乳中何故不能出生庵摩罗树。善男子。犹如四大为一切色而作因缘。然色各异差别不同。以是义故。乳中不生庵摩罗树

世尊。如佛所说有二种因正因缘因。众生佛性为是何因。善男子。众生佛性亦二种因。一者正因。二者缘因。正因者谓诸众生。缘因者谓六波罗蜜

师子吼言。世尊。我今定知乳有酪性。何以故。我见世间求酪之人。唯取于乳终不取水。是故当知乳有酪性。善男子。如汝所问是义不然。何以故。譬如有人欲见面像即便取刀

师子吼言。世尊。以是义故乳有酪性。刀无面像何故取刀。佛言。善男子。若此刀中定有面像何故颠倒。竖则见长横则见阔。若是自面何故见长。若是他面何得称言是己面像。若因己面见他面者。何故不见驴马面像。师子吼言。世尊眼光到彼故见面长。佛言。善男子。而此眼光实不到彼。何以故。近远一时俱得见故。不见中间所有物故。善男子。光若到彼而得见者。一切众生悉见于火何故不烧。如人远见白物不应生疑。鹄耶幡耶人耶树耶。若光到者。云何得见水精中物渊中鱼石。若不到见。何故得见水精中物。而不得见壁外之色。是故若言眼光到彼而见长者。是义不然。善男子。如汝所言乳有酪者。何故卖乳之人。但取乳价不责酪直。卖草马者但取马价不责驹直。善男子。世间之人无子息故故求娉妇。妇若怀妊不得言女。若言是女有儿性故故应娉者。是义不然。何以故。若有儿性亦应有孙。若有孙者则是兄弟。何以故。一腹生故。是故我言女无儿性。若其乳中有酪性者。何故一时不见五味。若树子中有尼拘陀五丈质者。何故一时不见芽茎枝叶花果形色之异。善男子。乳色时异味异果异。乃至醍醐亦复如是。云何可说乳有酪性。善男子。譬如有人明当服酥今已患臭。若言乳中定有酪性亦复如是。善男子。譬如有人有笔纸墨和合成字而是纸中本无有字。以本无故假缘而成。若本有者何须众缘。譬如青黄合成绿色。当知是二本无绿性。若本有者何须合成。善男子。譬如众生因食得命而此食中。实无有命。若本有命未食之时食应是命。善男子。一切诸法本无有性。以是义故我说是偈

  本无今有　　本有今无　　三世有法
  无有是处

善男子。一切诸法因缘故生因缘故灭。善男子。若众生内有佛性者。一切众生应有佛身如我今也。众生佛性不破不坏不牵不捉不系。不缚。如众生中所有虚空。一切众生悉有虚空。无挂碍故。各不自见有此虚空。若使众生无虚空者。则无去来行住坐卧不生不长。以是义故。我经中说一切众生有虚空界。虚空界者是名虚空。众生佛性亦复如是。十住菩萨少能见之如金刚珠。善男子。众生佛性诸佛境界。非是声闻缘觉所知。一切众生不见佛性。是故常为烦恼系缚流转生死。见佛性故诸结烦恼所不能系。解脱生死得大涅槃

师子吼菩萨言。世尊。一切众生有佛性性如乳中酪性。若乳无酪性云何佛说有二种因。一者正因。二者缘因。缘因者一酵二暖。虚空无性故无缘因。佛言。善男子。若使乳中定有酪性者何须缘因。师子吼菩萨言。世尊。以有性故故须缘因。何以故欲明见故。缘因者即是了因。世尊譬如闇中先有诸物。为欲见故以灯照了。若本无者灯何所照。如泥中有瓶故须人水轮绳杖等而为了因。如尼拘陀子须地水粪而作了因。乳中酵暖亦复如是须作了因。是故虽先有性要假了因然后得见以是义故。定知乳中先有酪性

善男子。若使乳中定有酪性者。即是了因。若是了因复何须了。善男子。若是了因性是了者。常应自了。若自不了何能了他。若言了因有二种性。一者自了。二者了他。是义不然。何以故。了因一法。云何有二。若有二者乳亦应二。若使乳中无二相者。云何了因而独有二。师子吼言。世尊。如世人言我共八人。了因亦尔。自了了他。佛言。善男子。了因若尔则非了因。何以故。数者能数自色他色故得言八。而此色性自无了相。无了相故要须智性乃数自他。是故了因不能自了亦不了他。善男子。一切众生有佛性者。何故修习无量功德。若言修习是了因者已同酪坏。若言因中定有果者。戒定智慧则无增长。我见世人本无禁戒禅定智慧。从师受已渐渐增益。若言师教是了因者。当师教时受者未有戒定智慧。若是了者应了未有。云何乃了戒定智慧。令得增长

师子吼菩萨言。世尊。若了因无者。云何得名有乳有酪。善男子。世间答难凡有三种。一者转答。如先所说。何故名戒。以不悔故乃至为得大涅槃故。二者默然答。如有梵志来问我言。我是常耶。我时默然。三者疑答。如此经中。若了因有二乳中何故不得有二。善男子。我今转答。如世人言有乳酪者。以定得故是故得名有乳有酪。佛性亦尔。有众生有佛性以当见故

师子吼言。世尊。如佛所说是义不然。过去已灭未来未到。云何名有。若言当有名为有者。是义不然。如世间人见无儿息便言无儿。一切众生无佛性者。云何说言一切众生悉有佛性。佛言。善男子。过去名有。譬如种橘芽生子灭芽亦甘甜。乃至生果味亦如是熟已乃醋。善男子。而是醋味子芽乃至生果悉无随本。熟时形色相貌则生醋味。而是醋味本无今有。虽本无今有非不因本。如是本子虽复过去故得名有。以是义故过去名有。云何复名未来为有。譬如有人种植胡麻。有人问言何故种此。答言有油。实未有油。胡麻熟已取子熬烝捣压乃得。当知是人非虚妄也。以是义故名未来有。云何复名过去有耶。善男子。譬如有人私屏骂王。经历年岁王乃闻之。闻已即问。何故见骂。答言。大王。我不骂也。何以故。骂者已灭。王言。骂者我身二俱存在云何言灭以是因缘丧失身命。善男子。是二实无而果不灭。是名过去有。云何复名未来有耶。譬如有人往陶师所问有瓶不。答言有瓶。而是陶师实未有瓶。以有泥故。故言有瓶。当知是人非妄语也。乳中有酪。众生佛性亦复如是。欲见佛性应当观察时节形色。是故我说一切众生悉有佛性实不虚妄

师子吼言。一切众生无佛性者。云何而得阿耨多罗三藐三菩提。以正因故。故令众生得阿耨多罗三藐三菩提。何等正因。所谓佛性。世尊。若尼拘陀子无尼拘陀树者。何故名为尼拘陀子。而不名为佉陀罗子。世尊。如瞿昙姓不得称为阿坻耶姓。阿坻耶姓亦复不得称瞿昙姓。尼拘陀子亦复如是。不得称为佉陀罗尼子。佉陀罗尼子不得称为尼拘陀子。犹如世尊不得舍离瞿昙种姓。众生佛性亦复如是。以是义故。当知众生悉有佛性。佛言。善男子。若言子中有尼拘陀者。是义不然。如其有者何故不见。善男子。如世间物有因缘故不可得见。云何因缘。谓远不可见如空中鸟迹。近不可见如人眼睫。坏故不见如根败者。乱想故不见如心不专一。细故不见如小微尘。障故不见如云表星。多故不见如稻聚中麻。相似故不见如豆在豆聚。尼拘陀树不同如是八种因缘。如其有者何故不见。若言细故不见者。是义不然。何以故树相粗故。若言性细云何增长。若言障故不可见者常应不见。本无粗相今则见粗。当知是粗本无见性。本无见性今则可见。当知是见亦本无性。子亦如是。本无有树今则有之当有何咎

师子吼言。如佛所说有二种因。一者正因。二者了因。尼拘陀子以地水粪作了因故令细得粗。佛言。善男子。若本有者。何须了因。若本无性。了何所了。若尼拘陀中本无粗相。以了因故乃生粗者。何故不生佉陀罗树。二俱无故。善男子。若细不见者粗应可见譬如一尘则不可见多尘和合则应可见。如是子中粗应可见。何以故。是中已有芽茎花果。一一果中有无量子。一一子中有无量树。是故名粗。有是粗故故应可见。善男子。若尼拘陀子有尼拘陀性而生树者。眼见是子为火所烧。如是烧性亦应本有。若本有者树不应生。若一切法本有生灭。何故先生后灭不一时耶。以是义故当知无性

师子吼菩萨言。世尊。若尼拘陀子本无树性而生树者。是子何故不出于油。二俱无故。善男子。如是子中亦能出油。虽本无性因缘故有

师子吼言。何故不名胡麻油耶。善男子。非胡麻故。善男子。如火缘生火水缘生水。虽俱从缘不能相有。尼拘陀子及胡麻油亦复如是。虽俱从缘各不相生。尼拘陀子性能治冷。胡麻油者性能治风。善男子。譬如甘蔗因缘故生石蜜黑蜜。虽俱一缘色相各异。石蜜治热黑蜜治冷

师子吼菩萨言。世尊。如其乳中无有酪性麻无油性。尼拘陀子无有树性。泥无瓶性。一切众生无佛性者。如佛先说一切众生悉有佛性。是故应得阿耨多罗三藐三菩提者。是义不然。何以故。人天无性。以无性故。人可作天天可作人。以业缘故不以性故。菩萨摩诃萨以业因缘故。得阿耨多罗三藐三菩提。若诸众生有佛性者。何因缘故。一阐提等断诸善根堕于地狱。若菩提心是佛性者。一阐提等不应能断。若可断者云何得言佛性是常。若非常者不名佛性。若诸众生有佛性者。何故名为初发心耶。云何而言是毗跋致阿毗跋致。毗跋致者。当知是人无有佛性。世尊。菩萨摩诃萨一心趣向阿耨多罗三藐三菩提大慈大悲。见生老死烦恼过患。观大涅槃无生老死烦恼诸过。信于三宝及业果报受持禁戒。如是等法名为佛性。若离是法有佛性者。何须是法而作因缘。世尊。如乳不假缘必当成酪。生酥不尔要待因缘。所谓人功水瓶攒绳。众生亦尔。有佛性者。应离因缘得阿耨多罗三藐三菩提。若定有者。行人何故。见三恶苦生老病死而生退心。亦不须修六波罗蜜。即应得成阿耨多罗三藐三菩提。如乳非缘而得成酪。然非不因六波罗蜜而得成于阿耨多罗三藐三菩提。以是义故。当知众生悉无佛性。如佛先说僧宝是常。如其常者则非无常。非无常者云何而得阿耨多罗三藐三菩提。僧若常者云何复言一切众生悉有佛性。世尊。若使众生从本已来无菩提心。亦无阿耨多罗三藐三菩提心。后方有者。众生佛性亦应如是本无后有。以是义故。一切众生应无佛性

佛言。善哉善哉。善男子。汝已久知佛性之义。为众生故作如是问。一切众生实有佛性。汝言众生若有佛性不应言有初发心者。善男子。心非佛性。何以故。心是无常佛性常故。汝言何故有退心者。实无退心。心若有退终不能得阿耨多罗三藐三菩提。以迟得故名之为退。此菩提心实非佛性。何以故。一阐提等断于善根堕地狱故。若菩提心是佛性者。一阐提辈则不得名一阐提也。菩提之心亦不得名为无常也。是故定知菩提之心实非佛性

善男子。汝言众生若有佛性不应假缘。如乳成酪者。是义不然。何以故。若言五缘成于生酥。当知佛性亦复如是。譬如众石有金有银有铜有铁俱禀四大一名一实。而其所出各各不同。要假众缘众生福德炉冶人功。然后出生。是故当知本无金性。众生佛性不名为佛。以诸功德因缘和合。得见佛性然后得佛

汝言众生悉有佛性何故不见者。是义不然何以故。以诸因缘未和合故。善男子。以是义故。我说二因正因缘因。正因者名为佛性。缘因者发菩提心。以二因缘得阿耨多罗三藐三菩提。如石出金

善男子。汝言僧常一切众生无佛性者。善男子。僧名和合。和合有二。一者世和合。二者第一义和合。世和合者名声闻僧。义和合者名菩萨僧。世僧无常。佛性是常。如佛性常义僧亦尔。复次有僧谓法和合。法和合者谓十二部经。十二部经常。是故我说法僧是常。善男子。僧名和合。和合者名十二因缘。十二因缘中亦有佛性。十二因缘常。佛性亦尔。是故我说僧有佛性。又复僧者诸佛和合。是故我说僧有佛性

善男子。汝言众生若有佛性云何有退有不退者。谛听谛听。我当为汝分别解说。善男子。菩萨摩诃萨有十三法则便退转。何等十三。一者心不信。二者不作心。三者疑心。四者吝惜身财。五者于涅槃中生大怖畏。云何乃令众生永灭。六者心不堪忍。七者心不调柔。八者愁恼。九者不乐。十者放逸。十一者自轻己身。十二者自见烦恼无能坏者。十三者不乐进趣菩提之法。善男子。是名十三法。令诸菩萨退转菩提。复有六法坏菩提心。何等为六。一者吝法。二者于诸众生起不善心。三者亲近恶友。四者不勤精进。五者自大憍慢。六者营务世业。如是六法则能破坏菩提之心。善男子。有人得闻诸佛世尊是人天师于众生中最上无比胜于声闻辟支佛等法眼明了见法无碍。能度众生于大苦海。闻已即复发大誓愿。如其世间有如是人我亦当得。以是因缘发阿耨多罗三藐三菩提心。或复为他之所教诲发菩提心。或闻菩萨阿僧祇劫修行苦行然后乃得阿耨多罗三藐三菩提。闻已思惟。我今不堪如是苦行。云何能得。是故有退。善男子。复有五法退菩提心。何等为五。一者乐在外道出家。二者不修大慈之心。三者好求法师过恶。四者常乐处在生死。五者不喜受持读诵书写解说十二部经。是名五法退菩提心。复有二法退菩提心。何等为二。一者贪乐五欲。二者不能恭敬尊重三宝。以如是等众因缘故退菩提心

云何复名不退之心。有人闻佛能度众生生老病死不从师咨自然修习得阿耨多罗三藐三菩提。若菩提道是可得者。我当修习必令得之。以是因缘发菩提心。所作功德若多若少。悉以回向阿耨多罗三藐三菩提。作是誓愿。愿我常得亲近诸佛及佛弟子。常闻深法五情完具。若遇苦难不失是心。复愿诸佛及诸弟子。常于我所生欢喜心具五善根。若诸众生斫伐我身斩截手足头目支节。当于是人生大慈心深自喜庆。如是诸人为我增长菩提因缘。若无是者我当何缘而得成就阿耨多罗三藐三菩提。复发是愿。莫令我得无根二根女人之身。不系属人不遭恶主。不属恶王不生恶国。若得好身种姓真正。多饶财宝不生憍慢。令我常闻十二部经受持读诵书写解说。若为众生有所演说。愿令受者敬信无疑。常于我所不生恶心。宁当少闻多解义味。不愿多闻于义不了。愿作心师不师于心。身口意业不与恶交。能施一切众生安乐。身戒心慧不动如山。为欲受持无上正法。于身命财不生悭吝。不净之物不为福业。正命自活心无邪谄。受恩常念小恩大报。善知世中所有事艺。善解众生方俗之言。读诵书写十二部经。不生懈怠懒堕之心。若诸众生不乐听闻。方便引接令彼乐闻。言常柔软口不宣恶。不和合众能令和合。有忧怖者令离忧怖。饥馑之世令得丰足。疾病之世作大医王。病药所须财宝自在。令疾病者悉得除愈。刀兵之劫有大力势。断其残害令无遗余。能断众生种种怖畏。所谓死畏闭系打掷水火王贼贫穷破戒恶名恶道。如是等畏悉当断之。父母师长深生恭敬。怨憎之中生大慈心。常修六念空三昧门十二因缘生灭等观出息入息天行梵行及以圣行金刚三昧首楞严定。无三宝处令我自得寂静之心。若其身心受大苦时。莫失无上菩提之心。莫以声闻辟支佛心而生知足。无三宝处常在外道法中出家。为破邪见不习其道。得法自在得心自在。于有为法了了见过。令我怖畏二乘道果。如惜命者怖畏舍身。为众生故乐处三恶。如诸众生乐忉利天。为一一人于无量劫。受地狱苦心不生悔。见他得利不生妒心。常生欢喜如自得乐。若值三宝当以衣服饮食卧具房舍医药灯明花香伎乐幡盖七宝供养。若受佛戒坚固护持。终不生于毁犯之想。若闻菩萨难行苦行。其心欢喜不生悔恨。自识往世宿命之事。终不造作贪嗔痴业。不为果报而集因缘。于现在乐。不生贪着。善男子。若有能发如是愿者。是名菩萨终不退失菩提之心。亦名施主。能见如来明了佛性。能调众生度脱生死。善能护持无上正法。能得具足六波罗蜜。善男子。以是义故。不退之心不名佛性善男子。汝不可以有退心故。言诸众生无有佛性。譬如二人俱闻他方有七宝山。山有清泉其味甘美。有能到者永断贫穷。服其水者增寿万岁。唯路悬远崄阻多难。时彼二人俱欲共往。一人庄严种种行具。一则空往无所赍持。相与前进路值一人。多赍宝货七珍具足。二人便前问言。仁者。彼土实有七宝山耶。其人答言。实有不虚。我已获宝饮服其水。唯患路险多有盗贼。沙砾棘刺乏于水草。往者千万达者甚少。闻是事已一人即悔寻作是言。路既悬远艰难非一。往者无量达者无几。而我云何当能到彼。我今产业粗自供足。若涉斯路或失身命。身命不全长寿安在。一人复言。有人能过我亦能过。若得果达则得如愿采取珍宝饮服甘水。如其不达以死为期。是时二人一则悔退一则前进。到彼山所多获财宝。如愿服水多赍所有还其所止。奉养父母供给宗亲。时悔还者见是事已心中生热。彼去已还我何为住。即便庄严涉道而去。七宝山者喻大涅槃。甘美之水喻于佛性。其二人者喻二菩萨初发心者。险恶道者喻于生死。所逢人者喻佛世尊。有盗贼者喻于四魔。沙砾棘刺喻诸烦恼。无水草者喻不修习菩提之道。一人还者喻退转菩萨。其直往者喻不退菩萨。善男子。众生佛性常住不变。犹彼崄道不可说言人悔还故令道无常。佛性亦尔。善男子。菩提道中终无退者。善男子。如向悔者。见其先伴获宝而还势力自在供养父母给足宗亲多受安乐。见是事已心中生热。即复庄严复道还去。不惜身命堪忍众难。遂便到彼七宝山中。退转菩萨亦复如是。善男子。一切众生定当得成阿耨多罗三藐三菩提。以是义故我经中说。一切众生乃至五逆犯四重禁及一阐提悉有佛性

师子吼言。世尊。云何菩萨有退不退。善男子。若有菩萨修习如来三十二相业因缘者。得名不退。得名菩萨摩诃萨也。名不动转。名为怜愍一切众生。名胜一切声闻缘觉。名阿毗跋致。善男子。若菩萨摩诃萨持戒不动施心不移。安住实语如须弥山。以是业缘得足下平如奁底相。若菩萨摩诃萨于父母所和上师长乃至畜生。以如法财供养供给。以是业缘得成足下千辐轮相

若菩萨摩诃萨不杀不盗。于父母师长常生欢喜。以是业缘得成三相。一者手指纤长。二者足跟长。三者其身方直。如是三相同一业缘。若菩萨摩诃萨修四摄法摄取众生。以是业缘得网缦指如白鹅王。若菩萨摩诃萨父母师长若病苦时。自手洗拭捉持按摩。以是业缘得手足软。若菩萨摩诃萨持戒闻法惠施无厌。以是业缘得节踝佣满身毛上靡。若菩萨摩诃萨专心听法演说正教。以是业缘得鹿王膞。若菩萨摩诃萨于诸众生不生害心。饮食知足常乐惠施瞻病给药。以是业缘其身圆满如尼拘陀树。立手过膝。顶有肉髻无见顶相。若菩萨摩诃萨见怖畏者为作救护。见裸跣者施与衣服。以是业缘得阴藏相。若菩萨摩诃萨亲近智者远离愚人。善喜问答。扫治行路。以是业缘皮肤细软身毛右旋。若菩萨摩诃萨常以衣服饮食卧具医药香花灯明施人。以是业缘得身金色常光明曜。若菩萨摩诃萨行施之时。所珍之物能舍不吝。不观福田及非福田。以是业缘得七处满相。若菩萨摩诃萨布施之时心不生疑。以是业缘得柔软声。若菩萨摩诃萨如法求财以用布施。以是业缘得缺骨充满师子上身臂肘佣纤。若菩萨摩诃萨远离两舌恶口恚心。以是业缘得四十齿白净齐密。若菩萨摩诃萨于诸众生修大慈悲。以是业缘得二牙相。若菩萨摩诃萨常作是愿。有来求者随意给与。以是业缘得师子颊。若菩萨摩诃萨随诸众生所须饮食悉皆与之。以是业缘得味中上味。若菩萨摩诃萨自修十善兼以化人。以是业缘得广长舌。若菩萨摩诃萨不讼彼短不谤正法。以是业缘得梵音声。若菩萨摩诃萨见诸怨憎生于喜心。以是业缘得目睫绀色。若菩萨摩诃萨不隐他德称扬其善。以是业缘得白毫相。善男子。若菩萨摩诃萨修习如是三十二相业因缘时。则得不退菩提之心

善男子。一切众生不可思议。诸佛境界业果佛性亦不可思议。何以故。如是四法皆悉是常。以是常故不可思议。一切众生烦恼覆障故名为常。断常烦恼故名无常。若言一切众生常者。何故修习八圣道分为断众苦。众苦若断则名无常。所受之乐则名为常。是故我言一切众生烦恼覆障不见佛性。以不见故不得涅槃

大般涅槃经卷第二十六大般涅槃经卷第二十七

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品之三

师子吼言。世尊。如佛所说。一切诸法有二种因。一者正因。二者缘因。以是二因应无缚解。是五阴者念念生灭。如其生灭谁缚谁解。世尊。因此五阴生后五阴。此阴自灭不至彼阴。虽不至彼能生彼阴。如因子生芽子不至芽虽不至芽而能生芽。众生亦尔。云何缚解。善男子。谛听谛听。我当为汝分别解说。善男子。如人舍命受大苦时。宗亲围绕号哭懊恼。其人惶怖莫知依救。虽有五情无所觉知。肢节战动不能自持。身体虚冷暖气欲尽。见先所修善恶报相。善男子。如日垂没山陵堆阜影现东移理无西逝。众生业果亦复如是。此阴灭时彼阴续生。如灯生闇灭灯灭闇生。善男子。如蜡印印泥印与泥合印灭文成。而是蜡印不变在泥。文非泥出不余处来。以印因缘而生是文。现在阴灭中阴阴生。是现在阴终不变为中阴五阴。中阴五阴亦非自生不从余来。因现阴故生中阴阴。如印印泥印坏文成。名虽无差而时节各异。是故我说。中阴五阴非肉眼见天眼所见。是中阴中有三种食一者思食。二者触食。三者意食。中阴二种。一善业果。二恶业果。因善业故得善觉观。因恶业故得恶觉观。父母交会牉合之时。随业因缘一向受生处。于母生爱于父生嗔。父精出时谓是已有。见已心悦而生欢喜。以是三种烦恼因缘。中阴阴坏生后五阴。如印印泥印坏文成。生时诸根有具不具。具者见色则生于贪。生于贪故则名为爱。狂故生贪是名无明。贪爱无明二因缘故所见境界皆悉颠倒。无常见常无我见我无乐见乐无净见净。以四倒故作善恶行。烦恼作业业作烦恼。是名系缚。以是义故名五阴生。是人若得亲近于佛及佛弟子诸善知识。便得闻受十二部经。以闻法故观善境界。观善境界故得大智慧。大智慧者名正知见。得知见故于生死中而生悔心。生悔心故不生欢乐。不生欢乐故能破贪心。破贪心故修八圣道。修八圣道故得无生死。无生死故名得解脱。如火不遇薪名之为灭。灭生死故名为灭度。以是义故名五阴灭

师子吼言。空中无刺云何言拔。阴无系者云何系缚。佛言。善男子。以烦恼锁系缚五阴。离五阴已无别烦恼。离烦恼已无别五阴。善男子。如柱持屋。离屋无柱离柱无屋。众生五阴亦复如是。有烦恼故名为系缚。无烦恼故名为解脱。善男子。如拳。合掌。系缚等三合散生灭更无别法。众生五阴亦复如是。有烦恼故名为系缚。无烦恼故名为解脱。善男子。如说名色系缚众生。名色若灭则无众生。离名色已无别众生。离众生已无别名色。亦名名色系缚众生。亦名众生系缚名色

师子吼言。世尊。如眼不自见指不自触刀不自割受不自受。云何如来说言名色系缚名色。何以故。言名色者即是众生。言众生者即是名色。若言名色系缚众生。即是名色系缚名色。佛言。善男子。如二手合时更无异法而来合也。名之与色亦复如是。以是义故。我言名色系缚众生。若离名色则得解脱。是故我言众生解脱

师子吼言。世尊。若有名色是系缚者。诸阿罗汉未离名色亦应系缚。善男子。解脱二种。一者子断。二者果断。言子断者名断烦恼。阿罗汉等已断烦恼众结烂坏。是故子结不能系缚。未断果故名果系缚。诸阿罗汉不见佛性。以不见故不得阿耨多罗三藐三菩提。以是义故可言果系。不得说言名色系缚。善男子。譬如然灯油未尽时明则不灭油若尽者灭则无疑。善男子。所言油者喻诸烦恼。灯喻众生。一切众生烦恼油故不入涅槃。若得断者则入涅槃师子吼言。世尊。灯之与油二性各异。众生烦恼则不如是。众生即是烦恼。烦恼即是众生。众生名五阴五阴名众生。五阴名烦恼烦恼名五阴。云何如来喻之于灯。佛言。善男子。喻有八种。一者顺喻。二者逆喻。三者现喻。四者非喻。五者先喻。六者后喻。七先后喻。八者遍喻。云何顺喻。如经中说。天降大雨沟渎皆满。沟渎满故小坑满。小坑满故大坑满。大坑满故小泉满。小泉满故大泉满。大泉满故小池满。小池满故大池满大池满故小河满。小河满故大河满。大河满故大海满。如来法雨亦复如是。众生戒满。戒满足故不悔心满。不悔心满故欢喜满。欢喜满故远离满。远离满故安隐满。安隐满故三昧满。三昧满故正知见满。正知见满故厌离满。厌离满故呵啧满。呵责满故解脱满。解脱满故涅槃满。是名顺喻。云何逆喻。大海有本所谓大河。大河有本所谓小河。小河有本所谓大池。大池有本所谓小池。小池有本所谓大泉。大泉有本所谓小泉。小泉有本所谓大坑。大坑有本所谓小坑。小坑有本所谓沟渎。沟渎有本所谓大雨。涅槃有本所谓解脱。解脱有本所谓呵责。呵责有本所谓厌离。厌离有本所谓正知见正知见有本所谓三昧。三昧有本所谓安隐。安隐有本所谓远离。远离有本所谓喜心。喜心有本所谓不悔。不悔有本所谓持戒。持戒有本所谓法雨。是名逆喻。云何现喻。如经中说。众生心性犹若猕猴。猕猴之性舍一取一。众生心性亦复如是。取着色声香味触法无暂住时。是名现喻。云何非喻。如我昔告波斯匿王。大王。有亲信人从四方来。各作是言。大王。有四大山从四方来欲害人民。王若闻者当设何计。王言。世尊。设有此来无逃避处。唯当专心持戒布施。我即赞言。善哉大王。我说四山即是众生生老病死。生老病死常来切人。云何大王。不修戒施。王言。世尊。持戒布施得何等果。我言。大王于人天中多受快乐。王言。世尊。尼拘陀树持戒布施。亦于人天受安乐耶。我言。大王。尼拘陀树不能持戒修行布施。如其能者则受无异。是名非喻。云何先喻。我经中说。譬如有人贪着妙花采取之时为水所漂。众生亦尔。贪着五欲为生老死之所漂没。是名先喻。云何后喻。如法句经说

  莫轻小恶　　以为无殃　　水渧虽微
  渐盈大器

是名后喻。云何先后喻。譬如芭蕉生果则死。愚人得养亦复如是。如骡怀妊命不久全。云何遍喻。如经中说。三十三天有波利质多树其根入地深五由延高百由延。枝叶四布五十由延。叶熟则黄。诸天见已心生欢喜。是叶不久必当堕落。其叶既落复生欢喜。是枝不久必当变色。枝既变色复生欢喜。是色不久必当生疱。见已复喜。是疱不久必当生嘴。见已复喜。是嘴不久必当开敷。开敷之时香气周遍五十由延。光明远照八十由延。尔时诸天夏三月时在下受乐。善男子。我诸弟子亦复如是。叶色黄者喻我弟子念欲出家。其叶落者喻我弟子剃除须发。其色变者喻我弟子白四羯磨受具足戒。初生疱者喻我弟子发阿耨多罗三藐三菩提心。嘴者喻于十住菩萨得见佛性。开敷者喻于菩萨得阿耨多罗三藐三菩提。香者喻于十方无量众生受持禁戒。光者喻于如来名号无碍周遍十方。夏三月者喻三三昧。三十三天受快乐者。喻于诸佛在大涅槃得常乐我净。是名遍喻。善男子。凡所引喻不必尽取。或取少分或取多分或复全取。如言如来面如满月。是名少分。善男子。譬如有人初不见乳。转问他言乳为何类。彼人答言如水蜜贝。水则湿相蜜则甜相贝则色相。虽引三喻未即乳实。善男子。我言灯喻喻于众生亦复如是。善男子。离水无河。众生亦尔。离五阴已无别众生。善男子。如离葙舆轮辐轴辋更无别车。众生亦尔。善男子。若欲得合彼灯喻者。谛听谛听我今当说。炷者喻于二十五有。油者喻爱。明喻智慧。除破黑闇喻破无明。暖喻圣道。如灯油尽明焰则灭。众生爱尽则见佛性。虽有名色不能系缚。虽复处在二十五有。不为诸有之所污染

师子吼言。世尊。众生五阴空无所有。谁有受教修习道者。佛言。善男子。一切众生皆有念心慧心发心勤精进心信心定心。如是等法虽念念生灭。犹故相似相续不断。故名修道。师子吼言。世尊。如是等法皆念念灭。是念念灭亦相似相续。云何修习。佛言。善男子。如灯虽念念灭而有光明除破闇冥。念等诸法亦复如是。善男子。如众生食虽念念灭亦令饥者而得饱满。譬如上药虽念念灭亦能愈病。日月光明虽念念灭亦能增长树林草木。善男子。汝言念念灭云何增长者。心不断故名为增长。善男子。如人诵书所诵字句不得一时。前不至中中不至后。人之与字及以心想俱念念灭。以久修故而得通利。善男子。譬如金师从初习作至于皓首。虽念念灭前不至后。以积习故所作遂妙。是故得称善好金师。读诵经书亦复如是善男子。譬如种子地亦不教汝当生芽。以法性故芽则自生。乃至花亦不教汝当作果。以法性故而果自生。众生修道亦复如是。善男子。譬如数法一不至二二不至三。虽念念灭而至千万。众生修道亦复如是。善男子。譬如灯念念灭。初灭之焰不教后焰我灭汝生当破诸闇。善男子。譬如犊子生便求乳。求乳之智实无人教。虽念念灭而初饥后饱。是故当知不应相似。若相似者不应异生。众生修道亦复如是。初虽未增以久修故。则能破坏一切烦恼

师子吼言。世尊。如佛所说。须陀洹人得果证已。虽生恶国犹故持戒。不杀盗淫两舌饮酒。须陀洹阴即此处灭不至恶国。修道亦尔。不至恶国。若相似者何故不生净妙国土。若恶国阴非须陀洹阴。云何而得不作恶业。佛言。善男子。须陀洹者虽生恶国终不失于须陀洹名。阴不相似。是故我引犊子为喻。须陀洹人虽生恶国。以道力故不作恶业。善男子。譬如香山有师子王。是故一切飞鸟走兽。绝迹此山无敢近者。有时是王至雪山中。一切鸟兽犹故不住。须陀洹人亦复如是。虽不修道以道力故不作诸恶。善男子。譬如有人服食甘露。甘露虽灭以其力势能令是人不生不死。善男子。如须弥山有上妙药名楞伽利。有人服之虽念念灭。以药力故不遇患苦。善男子。如转轮王所坐之处。王虽不在无人敢近。何以故。王威力故。须陀洹人亦复如是虽生恶国不修习道。以道力故不作恶业。善男子。须陀洹阴于此而灭虽生异阴。犹故不失须陀洹阴。善男子。譬如众生为果实故于种子中多役作业粪治溉灌。未得果实而子复灭。亦得名为因子得果。须陀洹阴亦复如是。善男子。譬如有人资产巨富唯有一子先已终殁。其子有子复在他土。其人忽然奄便终亡。孙闻是已还收产业。虽知财货非其所作。然其收取无遮护者。何以故以姓一故。须陀洹阴亦复如是

师子吼言。如佛说偈

  比丘若修习　　戒定及智慧
  当知是不退　　亲近大涅槃

世尊。云何修戒云何修定云何修慧。佛言。善男子。若有人受持禁戒。但为自利人天受乐。不为度脱一切众生。不为护持无上正法。但为利养畏三恶道。为命色力安无碍辩。畏惧王法恶名秽称为世事业。如是护戒则不得名修习戒也。善男子。云何名为真修习戒。受持戒时。若为度脱一切众生。为护正法度未度故。解未解故。归无归故。未入涅槃令得入故。如是修时不见戒不见戒相不见持者。不见果报不观毁犯。善男子。若能如是是则名为修习戒也。云何复名修习三昧。修三昧时。为自度脱为于利养。不为众生不为护法。为见贪欲秽食等过男女等根九孔不净斗讼打刺互相杀害。若为此事修三昧者。是则不名修习三昧。善男子。云何复名真修三昧。若为众生修习三昧。于众生中得平等心。为令众生得不退法。为令众生得圣心故。为令众生得大乘故为欲护持无上法故。为令众生不退菩提故。为令众生得首楞严故。为令众生得金刚三昧故。为令众生得陀罗尼故。为令众生得四无碍故。为令众生见佛性故。作是行时不见三昧不见三昧相。不见修者。不见果报。善男子。若能如是是则名为修习三昧。云何复名修于智慧。若有修者作是思惟。我若修习如是智慧。则得解脱度三恶道。谁能利益一切众生。谁能度人于生死道。佛出世难如优昙花。我今能断诸烦恼结必得解脱。是故我当勤修智慧速断烦恼早得度脱。如是修者不得名为修习智慧。云何名为修习智慧者。若观生老死苦。一切众生无明所覆。不知修习无上正道。愿我此身悉代众生受大苦恼。众生所有贫穷下贱破戒之心贪嗔痴业。愿皆悉来集于我身。愿诸众生不生贪取。不为名色之所系缚。愿诸众生早度生死。令我一身处之不厌。愿令一切皆得阿耨多罗三藐三菩提。如是修时不见智慧不见智慧相。不见修者。不见果报。是则名为修习智慧。善男子。修习如是戒定智慧。是名菩萨。不能如是修戒定慧。是名声闻。复次善男子。云何复名修习于戒。若能破坏一切众生十六恶律仪。何等十六。一者为利养食羔羊肥已转卖。二者为利买已屠杀。三者为利养食猪豚肥已转卖。四者为利买已屠杀。五者为利养食牛犊肥已转卖。六者为利买已屠杀。七者为利养鸡令肥肥已转卖。八者为利买已屠杀。九者钓鱼。十者猎师。十一劫夺。十二魁脍。十三网捕飞鸟。十四两舌。十五狱卒。十六咒龙。能为众生永断如是十六恶业。是名修戒。云何修定。能断一切世间三昧。所谓无身三昧。能令众生生颠倒心谓是涅槃。又无边心三昧。净聚三昧。世边三昧。世断三昧。世性三昧。世丈夫三昧。非想非非想三昧。如是等定能令众生生颠倒心谓是涅槃。若能永断如是三昧。是则名为修习三昧。云何复名修习智慧。能破世间所有恶见。一切众生悉有恶见。所谓色即是我亦是我所。色中有我我中有色。乃至识亦如是。常即是我色灭我存。色即是我色灭我灭。复有人言。作者名我受者名色。复有人言。作者名色受者名我。复有人言。无作无受自生自灭悉非因缘。复有人言。无作无受悉是自在之所造作。复有人言。无有作者无有受者。一切悉是时节所作。复有人言。作者受者悉无所有。地等五大名为众生。善男子。若能破坏一切众生如是恶见。是则名为修习智慧。善男子。修习戒者为身寂静。修习三昧为心寂静。修习智慧为坏疑心。坏疑心者为修习道。修习道者为见佛性。见佛性者为得阿耨多罗三藐三菩提故。得阿耨多罗三藐三菩提者。为得无上大涅槃故。得大涅槃者为断众生一切生死一切烦恼一切诸有一切诸界一切诸谛故。断于生死乃至断谛。为得常乐我净法故

师子吼言。世尊。如佛所说。若不生灭名大涅槃。生亦如是不生不灭。何故不得名为涅槃。善男子。如是如是。如汝所言。是生虽复不生不灭而有始终

世尊。是生死法亦无始终。若无始终则名为常。常即涅槃。何故不名生死为涅槃耶。善男子。是生死法悉有因果。有因果故不得名之为涅槃也。何以故。涅槃之体无因果故。师子吼言。世尊。夫涅槃者亦有因果。如佛所说

  从因故生天　　从因堕恶道
  从因故涅槃　　是故皆有因

如佛往昔告诸比丘。我今当说沙门道果。言沙门者。谓能具修戒定智慧。道者谓八圣道。沙门果者所谓涅槃。世尊。涅槃如是岂非果耶。云何说言涅槃之体无因无果。佛言。善男子。我所宣说涅槃因者所谓佛性。佛性之性不生涅槃。是故我言涅槃无因。能破烦恼故名大果。不从道生故名无果。是故涅槃无因无果

师子吼言。世尊。众生佛性为悉共有为各各有。若共有者一人得阿耨多罗三藐三菩提时。一切众生亦应同得。世尊。如二十人同有一怨。若一人能除余十九人皆亦同除。佛性若尔。一人得时余亦应得。若各各有则是无常。何以故。可算数故。然佛所说众生佛性不一不二。若各各有不应说言诸佛平等。亦不应说佛性如空。佛言。善男子。众生佛性不一不二。诸佛平等犹如虚空。一切众生同共有之。若有能修八圣道者。当知是人则得明见。善男子。雪山有草名曰忍辱。牛若食之则成醍醐。众生佛性亦复如是

师子吼言。如佛所说。忍辱草者一耶多耶。如其一者牛食则尽。如其多者云何而言众生佛性亦如是耶。如佛所说。若有修习八圣道者则见佛性。是义不然。何以故。道若一者如忍辱草则应有尽。如其有尽一人修已余则无分。道若多者云何得言具足修习。亦不得名萨婆若智。佛言。善男子。如平坦路。一切众生悉于中行无障碍者。中路有树其阴清凉。行人在下憩驾止息。然其树阴常住不移。亦不消坏。无持去者。路喻圣道。阴喻佛性。善男子。譬如大城唯有一门。虽有多人经由入出。都无有能作障碍者。亦复无人破坏毁落而赍持去。善男子。譬如桥梁行人所由。亦无有人遮止障碍毁坏持去。善男子。譬如良医遍疗众病。亦无有能遮止是医治此舍彼。圣道佛性亦复如是

师子吼言。世尊。所引诸喻义不如是。何以故。先者在路于后则妨。云何而言无有障碍。余亦皆尔。圣道佛性若如是者。一人修时应妨余者。佛言。善男子。如汝所说义不相应。我所喻道是少分喻非一切也。善男子。世间道者则有障碍。此彼之异无有平等。无漏道者则不如是。能令众生无有障碍。平等无二无有方处此彼之异。如是正道能为一切众生佛性。而作了因不作生因。犹如明灯照了于物。善男子。一切众生皆同无明因缘于行不可说言一人无明因缘行已其余应无。一切众生悉有无明因缘于行。是故说言十二因缘一切平等。众生所修无漏正道亦复如是。等断众生烦恼四生诸界有道。以是义故名为平等。其有证者彼此知见无有障碍。是故得名萨婆若智

师子吼言。一切众生身不一种。或有天身。或有人身畜生饿鬼地狱之身。如是多身差别非一。云何而言佛性为一。佛言。善男子。譬如有人置毒乳中乃至醍醐皆悉有毒。乳不名酪。酪不名乳。乃至醍醐亦复如是。名字虽变毒性不失。遍五味中皆悉如是。若服醍醐亦能杀人。实不置毒于醍醐中。众生佛性亦复如是。虽处五道受别异身。而是佛性常一无变

师子吼言。世尊。十六大国有六大城。所谓舍婆提城。婆枳多城。瞻婆城。毗舍离城。波罗奈城。王舍城。如是六城世中最大。何故如来舍之在此边地弊恶极陋隘小拘尸那城。入般涅槃

善男子。汝不应言拘尸那城边地弊恶最陋隘小。应言是城微妙功德之所庄严。何以故。诸佛菩萨所行处故。善男子。如贱人舍。王若过者则应赞叹。是舍严丽福德成就。乃令大王回驾临顾。善男子。如人重病服秽弊药服已病愈。即应欢喜赞叹是药最上最妙能愈我病。善男子。如人乘船在大海中。其船卒坏无所依倚。因倚死尸得到彼岸。到彼岸已应大欢喜赞叹是尸我赖相遇而得安隐。拘尸那城亦复如是。乃是诸佛菩萨行处。云何而言边地弊恶隘陋小城。善男子。我念往昔过恒河沙劫。劫名善觉。时有圣王姓憍尸迦。七宝成就千子具足。其王始初造立此城。周匝纵广十二由延。七宝庄严土多有河。其水清净柔软甘美。所谓尼连禅河。伊罗跋提河。熙连禅河。伊搜末堆河。毗婆舍那河。如是等河其数五百。此河彼岸树木繁茂花果鲜洁。尔时人民寿命无量。时转轮圣王过百年已。作是唱言。如佛所说。一切诸法皆悉无常。若能修习十善法者。能断如是无常大苦。人民闻已咸共奉修十善之法。我于尔时闻佛名号。受持十善思惟修习。初发阿耨多罗三藐三菩提心。发是心已复以是法。转教无量无边众生言一切法无常变坏。是故我今续于此处。亦说诸法无常变坏。唯说佛身是常住法。我忆往昔所行因缘。是故今来在此涅槃。亦欲酬报此地往恩。以是义故我经中说。我眷属者受恩能报。复次善男子。往昔众生寿无量时。尔时此城名拘舍跋提。周匝纵广五十由延。时阎浮提居民邻接鸡飞相及。有转轮王名曰善见。七宝成就千子具足。王四天下。第一太子思惟正法得辟支佛。时转轮王见其太子成辟支佛威仪庠序神通希有。见是事已即舍王位如弃涕唾。出家在此娑罗树间。八万岁中修习慈心。悲喜舍心各八万岁。善男子。欲知尔时善见圣王则我身是。是故我今常乐游止如是四法。是四法者名为三昧。以是义故。如来之身常乐我净。善男子。以是因缘今来止此拘尸那城娑罗树间。三昧正受。善男子。我念往昔过无量劫。此城尔时名迦毗罗卫。其城有王名曰白净。其王夫人名曰摩耶。王有一子名悉达多。尔时王子不由师教自然思惟。得阿耨多罗三藐三菩提。有二弟子。一名舍利弗。二名大目犍连。给侍弟子名曰阿难。尔时世尊在双树间。演说如是大涅槃经。我时在会得预斯事。闻诸众生悉有佛性。闻是事已即于菩提得不退转。寻自发愿。愿未来世成佛之时。父母国土名字弟子。侍使之人说法教化。如今世尊等无有异。以是因缘。今来在此敷扬演说大涅槃经

善男子。我初出家未得阿耨多罗三藐三菩提时。频婆娑罗王遣使而言。悉达太子。若为圣王我当臣属。若不乐家得阿耨多罗三藐三菩提者。愿先来至此王舍城。说法度人受我供养。我时默然已受彼请善男子。我初得阿耨多罗三藐三菩提已向竭阇国。时伊连禅河有婆罗门。姓迦叶氏。与五百弟子在彼河侧求无上道。我为是人故往说法。迦叶言。瞿昙。我今年迈已百二十。摩伽陀国所有人民。及其大王频婆娑罗。咸谓我已证罗汉果。我今若当在于汝前听受法者。一切人民或生倒心。大德迦叶非罗汉耶。幸愿瞿昙速往余处。若此人民定知瞿昙功德胜我。我等无由复得供养。我时答言。迦叶。汝若于我不生殷重大嗔恨者。见容一宿明当早去。迦叶言。瞿昙。我心无他深相爱重。但我住处有一毒龙。其性暴急恐相危害。我言。迦叶。毒中之毒不过三毒。我今已断。世间之毒我所不畏。迦叶复言。苟能不畏善哉听住。善男子。我于尔时故为迦叶现十八变如经中说。尔时迦叶及其眷属五百等辈。见闻是已证罗汉果。是时迦叶复有二弟。一名伽耶迦叶。二名那提迦叶。师徒眷属复有五百。亦皆证得阿罗汉果。时王舍城六师之徒闻是事已。即于我所生大恶心。我时赴信受彼王请诣王舍城。未至中路王与无量百千之众悉来奉迎。我为说法。时闻法已。欲界诸天八万六千发阿耨多罗三藐三菩提心。频婆娑罗王所将营从十二万人得须陀洹果。无量众生成就忍心。既入城已度舍利弗大目犍连及其眷属二百五十。令舍本心出家学道。我即住彼受王供养。外道六师相与聚集诣舍卫城

时彼城中有一长者名须达多。为儿娉妇诣王舍城。既达彼城寄止长者珊檀那舍。时此长者中夜而起。告诸眷属。仁等可起速共庄严扫治宅舍办具肴膳。须达闻已寻自思惟。将非欲请摩伽王耶。为有婚姻欢乐会乎。思惟是已寻前问言。大士。欲请摩伽陀王频婆娑罗耶。为有婚姻欢乐会乎。匆务不安乃如是耶。长者答言。不也居士。我明请佛无上法王。须达长者初闻佛名身毛皆竖。寻复问言。何等名佛。长者答言。汝不闻耶。迦毗罗城有释种子。字悉达多。姓瞿昙氏。父名白净。其生未久相师占之。定当得作转轮圣王。如庵罗果已在手中。心不愿乐舍之出家。无师自觉得阿耨多罗三藐三菩提。贪恚痴尽常住无变。不生不灭无有忧畏。于诸众生其心平等。犹如父母等视一子。所有身心众中最胜。虽胜一切而无憍慢。涂割二事其心无二。智慧通达于法无碍。具足十力四无所畏五智三昧大慈大悲及三念处。故号为佛明受我请。是故匆匆未暇相瞻

须达多言。善哉大士。所言佛者功德无上。今在何处。长者答言。今在此间王舍大城。住迦兰陀竹林精舍。时须达多一心念佛所有功德十力无畏五智三昧大慈大悲及三念处。作是念时忽然大明。其明猛盛犹如白日。即寻光出至城门下。佛神力故门自然开。既出门已路有天祠。须达经过礼拜致敬。寻还黑闇。心生惶怖。复欲还返所止之处。时彼城门有一天神。告须达言。仁者若往如来所者多获善利。须达多言。云何善利。天言。长者。假使有人真宝交结。骏马百匹香象百头宝车百乘。铸金为人其数复百。端正女人身佩璎珞众宝厕填。上妙宫宅殿堂屋字雕文刻镂。金盘银粟银盘金粟。数各一百以施一人。如是展转尽阎浮提所得功德。不如有人发意一步诣如来所。须达多言。善男子。汝是谁耶。天言。长者。我是胜相婆罗门子。是汝往昔善知识也。我因往日见舍利弗大目犍连心生欢喜。舍身得作北方天王毗沙门子。专知守护此王舍城。我因礼拜舍利弗等生欢喜心。尚得如是妙好之身。况当得见如来大师礼拜供养。须达长者闻是事已。即还复道来诣我所。到已头面敬礼我足。我时即为如应说法。长者闻已得须陀洹果。既获果证复请我言。如来大慈。惟愿临顾。至舍卫城受我微供。我即问言。卿舍卫城颇有精舍相容受不。须达多言。若佛哀愍必见垂顾便当自竭营办成立。善男子。我于尔时默然受请。须达长者已蒙听许。即白我言。我从昔来未为斯事。惟愿如来遣舍利弗指授仪则。我即顾命敕令营佐。时舍利弗与须达多。共载一车往舍卫城。我神力故经一日夜便到所止。时须达多白舍利弗。大德。此大城外何处有地不近不远多饶泉池。有好林树花果郁茂清净闲旷。我当于中为佛世尊及比丘僧造立精舍。舍利弗言。只陀园林不近不远清净寂寞多有泉流。树木花果随时而有。此处最胜可立精舍。时须达多闻是语已。即往只陀大长者所。告只陀言。我今欲为无上法王造立僧坊。唯仁园地可以造立。吾今欲买能见与不。只陀答言。设以真金遍布其地犹不相与。须达多言。善哉只陀。林地属我汝便取金。只陀答言。我园不卖云何取金。须达多言。若意不了当共往诣断事人所。时二长者即共俱往。断事者言。园属须达只陀取金。须达长者即时使人车马载负随集布地。一日之中唯五百步。金未周遍。只陀言曰。长者若悔随意听止。须达多言。吾不悔也。自念当出何藏金足。只陀念言。如来法王真实无上。所说妙法清净无染。故使斯人轻宝乃尔。即语须达。余未遍者不复须金。请以见与。我自为佛造立门楼。常使如来经由出入。只陀长者自造门坊。须达长者七日之中成立大房足三百间。禅坊静处六十三所。冬屋夏堂各各别异。厨坊浴室洗脚之处。大小圊厕无不备足。所设已讫。即执香炉。向王舍城遥作是言。所设已办。惟愿如来慈哀怜愍。为诸众生受是住处。我时玄知是长者心。即与大众发王舍城。譬如壮士屈伸臂顷。至舍卫城只陀园林须达精舍。我既到已。须达长者以其所设奉施于我。我时受已即住其中

大般涅槃经卷第二十七大般涅槃经卷第二十八

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品之四

是时六师心生嫉妒。悉来集诣波斯匿王。作如是言。大王当知。王之土境清夷闲静。真是出家住止之处。是故我等为斯事故而来至此。大王。以正法治为民除患。沙门瞿昙年既幼稚学日又浅道术无施。此国先有耆旧宿德。自怙王种不生恭敬。若是王种法应治民。如其出家应敬宿德。大王善听。沙门瞿昙真实不生王种之中。瞿昙沙门若有父母。何由劫夺他人父母。大王。我经中说。过千岁已有一妖祥幻化物出。所谓沙门瞿昙是也。是故当知。沙门瞿昙无父无母。若有父母云何说言诸法无常苦空无我无作无受。以幻术故诳惑众生。愚者信受。智者舍之。大王。夫人王者天下父母。如秤如地如风如火如道如河如桥如灯如日如月。如法断事不择怨亲。沙门瞿昙不听我活。随我去处追逐不舍。唯愿大王。听我与彼捔其道力。若彼胜我我当属彼。我若胜彼彼当属我。王言。大德。汝等各各自有行法。止住之处亦各不同。我今定知。如来世尊于汝无妨。六师答言。云何无妨。沙门瞿昙以幻术法。诱诳诸人及婆罗门归伏已尽。王若听我与捔道力。王之善名流布八方。如其不者恶声盈路。王言。大德。汝等未知如来道力威神巍巍。故求捔试。若定知者恐不能也。大王。汝今已受瞿昙幻耶。唯愿大王。留神听察莫轻我等。构之虚言不如验之以实。王言。善哉善哉。六师之徒欢喜而出

时波斯匿王即敕严驾。来至我所头面礼敬。右绕三匝退坐一面。而白我言。世尊。六师向来求捔道力。我不量度敢已许之。佛言。大王。善哉善哉。但当更于此国处处造立僧坊。何以故。我若与彼捔其神力。彼众之中受化者多。此处狭小云何容受。善男子。我于尔时为六师故。从初一日至十五日。现大希有神通变化。当是时也无量众生发阿耨多罗三藐三菩提心。无量众生于三宝所生信不疑。六师徒众其数无量。破邪见心正法出家。无量众生于菩提中得不退心。无量众生得陀罗尼诸三昧门。无量众生得须陀洹果至阿罗汉果

尔时六师内心惭愧。相与围绕至婆枳多城。教彼人民信受邪法。瞿昙沙门但说空事。善男子。我时为母处忉利天波利质多树安居说法。是时六师心大欢喜。唱言。善哉。瞿昙幻术今已灭没。复教无量无数众生增长邪见。尔时频婆娑罗波斯匿王及四部众。白目连言。大德。此阎浮提邪见增长。众生可愍行大黑闇。惟愿大德。至彼天上稽首世尊。如我言曰。譬如犊子其生未久。若不得乳必死无疑。我等众生亦复如是。惟愿如来哀愍众生还来住此。时目犍连默然而许。如大力士屈伸臂顷。往彼天上至世尊所。白佛言。阎浮提中所有四众渴仰如来思见闻法。频婆娑罗波斯匿王及四众等。稽首足下。此阎浮提所有众生。邪见增长行大黑闇甚可怜愍。譬如犊子其生未久。若不得乳必死不疑。我等亦尔。惟愿如来。为众生故还来在此阎浮提中。佛告目连。汝今速还至阎浮提。告诸国王及四部众。却后七日我当还下为六师故复当至彼婆枳多城。过七日已。佛与释天梵天魔天无量天子及首陀会一切天人。前后围绕至婆枳多城。大师子吼。作如是言。唯我法中独有沙门及婆罗门。一切诸法无常无我。涅槃寂静离诸过患。若言他法亦有沙门及婆罗门有常有我有涅槃者无有是处。尔时无量无边众生发阿耨多罗三藐三菩提心。是时六师各相谓言。若我法中实无沙门婆罗门者。云何而得世间供养。于是六师复相集聚诣毗舍离

善男子。我于一时住毗舍离庵罗林间。时庵罗女知我在中欲来我所。我于尔时告诸比丘当观念处善修智慧。随所修习心莫放逸。云何名为观于念处。若有比丘。观察内身不见于我及以我所。观察外身及内外身。不见于我及以我所。观受心法亦复如是。是名念处。云何名为修习智慧。若有比丘。真实而见苦集灭道。是名比丘修习智慧。云何名为心不放逸。若有比丘。念佛念法念僧念戒念舍念天。是名比丘心不放逸。时庵罗女即至我所。头面作礼右绕三匝。修敬已毕却坐一面。善男子。我于尔时为庵罗女如应说法。是女闻已发阿耨多罗三藐三菩提心

时彼城中有梨车子。其数五百。来至我所。头面作礼右绕三匝。修敬已毕却坐一面。我时复为诸梨车子如应说法。诸善男子。夫放逸者有五事果。何等为五。一者不得自在财利。二者恶名流布无外。三者不乐惠施穷乏。四者不乐见于四众。五者不得诸天之身。诸善男子。因不放逸能生世法出世间法。若有欲得阿耨多罗三藐三菩提者。应当勤修不放逸法。夫放逸者复得十三果报。何等十三。一者乐为世间作业。二者乐说无益之言。三者常乐久寝睡眠。四者乐说世间之事。五者常乐亲近恶友。六者懈怠懒惰。七者常为他人所轻。八者虽有所闻寻复忘失。九者乐处边地。十者不能调伏诸根。十一者食不知足。十二者不乐空寂。十三者所见不正。是名十三。善男子。夫放逸者。虽得近佛及佛弟子犹故为远。诸梨车子言。我等自知是放逸人。何以故。如其我等不放逸者。如来法王当出我土。时大会中有婆罗门子。名曰无胜。语诸梨车。善哉善哉。如汝所言。频婆娑罗王已获大利。如来世尊出其国土。犹如大池生妙莲花。虽生在水水不能污。诸梨车子。佛亦如是。虽生彼国不为世法之所滞碍。诸佛世尊无出无入。为众生故出现于世。不为世法之所滞碍。仁等自迷耽荒五欲。不知亲近往如来所。是故名为放逸之人。非佛出于摩伽陀国名放逸也。何以故。如来世尊犹彼日月。非为一人二人出世。时诸梨车闻是语已。寻发阿耨多罗三藐三菩提心。复作是言。善哉善哉。无胜童子。快说如是善妙之言。时诸梨车各各脱身所著一衣以施无胜。无胜受已转以奉我。复作是言。世尊。我从梨车得是衣物。唯愿如来。哀愍众生受我所献。我于尔时愍彼无胜即为纳受。时诸梨车同时合掌作如是言。唯愿如来。于此土地一时安居受我微供。我时默然受梨车请

是时六师闻是事已。师宗相与诣波罗奈。尔时我复往波罗奈住波罗河边。时波罗奈有长者子。名曰宝称。耽荒五欲不知非常。以我到故自然而得白骨观法。见其殿舍宫人婇女悉为白骨。心生怖惧。如刀毒蛇如贼如火。即出其舍来诣我所随路告言。瞿昙沙门。我今如为贼所追逐。甚大怖惧。愿见救济。佛言。善男子。佛法众僧安隐无惧。长者子言。若三宝中无所畏者。我今亦当得无所畏。我即听其出家为道。时长者子复有同友其数五十。遥闻宝称厌离出家。即共和顺相与出家

六师闻已展转复诣瞻婆大城。时瞻婆国一切人民。悉共奉事六师之徒。初未曾闻佛法僧名。多有诸人作极恶业。我于尔时为众生故往瞻婆城。时彼城中有大长者无有继嗣。供事六师以求子息。于后不久其妇怀妊。长者知已往六师所。欢喜而言。我妇怀妊男耶女耶。六师答言。生必是女。长者闻已心生愁恼。复有知识来谓长者。何故愁恼乃如是耶。长者答言。我妇怀妊未知男女故问六师。六师见语。如我相法生必是女。我闻是语自惟年老财富无量。如其非男无所付嘱。是故我愁。知识复言。汝无智慧。先不闻耶。优楼频螺迦叶兄弟为谁弟子。佛耶六师耶。六师若是一切智者。迦叶何故舍之为佛弟子。又舍利弗目犍连等。及诸国王频婆娑罗等。诸王夫人末利夫人等。诸国长者须达多等。如是诸人非佛弟子耶。旷野鬼神。阿阇世王。护财醉象。鸯掘摩罗。恶心炽盛欲害其母。如是等辈斯非如来所调伏耶。长者。如来世尊于一切法知见无碍。故名为佛。发言无二故名如来。断烦恼故名阿罗诃。世尊所说终无有二。六师不尔云何可信。如来今者近在此住。若欲实知当诣佛所。尔时长者即与是人。来诣我所头面作礼。右绕三匝合掌长跪。而作是言。世尊。于诸众生平等无二怨亲一相。我为爱结之所系缚。于怨亲中未能无二。我今欲问如来世事。深自愧惧未敢发言。世尊。我妇怀妊。六师相言。生必是女。是事云何。佛言。长者。汝妇怀妊是男无疑。其儿生已福德无比。尔时长者闻是语已。生大欢喜便退还家。尔时六师闻我玄记生者必男有大福德。心生嫉妒。以庵罗果和合毒药。持往其家语长者言。快哉瞿昙善说其相。汝妇临月可服此药。服此药已儿则端正产者无患。长者欢喜受其毒药与妇令服。服已寻死。六师欢喜周遍城市高声唱言。沙门瞿昙记彼长者妇当生男其儿福德天下无胜。今儿未生母已丧命。尔时长者复于我所。生不信心。即依世法殡殓棺盖。送至城外多积干薪以火焚之。我以道眼明见此事。顾命阿难。取我衣来。吾欲往彼摧灭邪见。时毗沙门天告摩尼跋陀大将言。如来今欲诣彼冢间。卿可速往平治扫洒安师子。座求妙香花庄严其地。尔时六师遥见我往。各相谓言。瞿昙沙门至此冢间欲啖肉耶。尔时多有未得法眼诸优婆塞。各怀愧惧而白我言。彼妇已死愿不须往。尔时阿难语诸人言。且待须臾。如来不久当广开阐诸佛境界。我时到已坐师子座。长者难言。所言无二可名世尊。母已终亡云何生子。我言。长者。卿于尔时都不见问母命修短。但问所怀为是男女。诸佛如来发言无二。是故当知定必得子。是时死尸火烧腹裂。子从中出端坐火中。犹如鸳鸯处莲花台。六师见已复作是言。妖哉瞿昙。善为幻术。长者见已心复欢喜。呵啧六师。若言幻者汝何不作。我于尔时寻告耆婆。汝往火中抱是儿来。耆婆欲往。六师前牵语耆婆言。瞿昙沙门所作幻术未必常尔。或能不能。如其不能脱能烧害。汝今云何信受其言。耆婆答言。如来使入阿鼻地狱。所有猛火尚不能烧。况世间火。尔时耆婆前入火聚。犹入清凉大河水中。抱持是儿还诣我所授儿与我。我受儿已告长者言。一切众生寿命不定如水上泡。众生若有重业果报。火不能烧毒不能害。是儿业报。非我所作。时长者言。善哉世尊。是儿若得尽其天命。唯愿如来为立名字。佛言。长者。是儿生于猛火之中。火名树提。应名树提。尔时会中见我神化。无量众生发阿耨多罗三藐三菩提心

尔时六师周遍六城不得停足。惭愧低头。复来至此拘尸那城。既至此已唱如是言。诸人当知。沙门瞿昙是大幻师诳惑天下遍六大城。譬如幻师幻作四兵。所谓车兵马兵象兵步兵。又复幻作种种璎珞城郭宫宅河池树木。沙门瞿昙亦复如是。幻作王身为说法故。或作沙门婆罗门身男身女身小身大身。或作畜生鬼神之身。或说无常。或说有常。或时说苦。或时说乐。或说有我。或说无我。或说有净。或说无净。或时说有。或时说无。所为虚妄故名为幻。譬如因子随子得果。瞿昙沙门亦复如是。摩耶所生母既是幻。子不得非。沙门瞿昙无实知见。诸婆罗门经年积岁。修习苦行护持禁戒。尚言未有真实知见。何况瞿昙年少学浅不修苦行。云何而有真实知见。若能具满七年苦行。见犹不多。况所修习不满六年。愚人无智信受其教。如大幻师诳惑愚者。沙门瞿昙亦复如是。善男子。如是六师于此城中。大为众生增长邪见。善男子。我见是事心生怜愍。以其神力请召十方诸大菩萨。云集此林周遍弥满四十由旬。今于此中大师子吼。善男子。虽于空处多有所说。则不得名师子吼也。于此智人大众之中。真得名为大师子吼。师子吼者说一切法悉无常苦无我不净。唯说如来常乐我净

尔时六师复作是言。若瞿昙有我我亦有我。所言我者见者名我。瞿昙。譬如有人向中见物。我亦如是。向喻于眼见者喻我。佛告六师。若言见者名我是义不然。何以故。汝所引喻因向见者。人在一向六根俱用。若定有我因眼见者。何不如彼一根之中俱伺诸尘。若一根中不能一时闻见六尘。当知无我。所引向喻。虽经百年见者因之所见无异。眼根若尔年迈根熟亦应无异。人向异故见内见外。眼根若尔亦应内外一时俱见。若不见者云何有我。六师复言。瞿昙。若无我者谁能见耶。佛言有色有明有心有眼。是四和合故名为见。是中实无见者受者。众生颠倒言有见者及以受者。以是义故。一切众生所见颠倒。诸佛菩萨所见真实。六师若言色是我者。是亦不然。何以故。色实非我。色若是我不应而得丑陋形貌。何故复有四姓差别。不悉一种婆罗门耶。何故属他不得自在。诸根缺陋生不具足。何故不作诸天之身。而受地狱畜生饿鬼种种诸身。若不能得随意作者。当知必定无有我也。以无我故名为无常。无常故苦。苦故为空。空故颠倒。以颠倒故一切众生轮转生死。受想行识亦复如是。六师。如来世尊永断色缚乃至识缚。是故名为常乐我净。复次色者即是因缘。若因缘者则名无我。若无我者名为苦空。如来之身非是因缘。非因缘故则名有我。若有我者即常乐净。六师复言。瞿昙。色亦非我乃至识亦非我。我者遍一切处犹如虚空。佛言。若遍有者则不应言我初不见。若初不见则知是见本无今有。若本无今有是名无常。若无常者云何言遍。若遍有者五道之中应具有身。若有身者应各受报。若各受报云何而言转受人天。汝言遍者一耶多耶。我若一者则无父子怨亲中人。我若多者一切众生所有五根悉应平等。所有业慧亦应如是。若如是者云何说言根有具足不具足者。善业恶业愚智差别。瞿昙。众生我者无有边际。法与非法则有分齐。众生修法则得好身。若行非法则得恶身。以是义故。众生业果不得无差。佛言。六师。法与非法若如是者我则不遍。我若遍者则应悉到。如其到者修善之人亦应有恶。行恶之人亦应有善。若不尔者云何言遍瞿昙。譬如一室然百千灯各各自明不相妨碍。众生我者亦复如是。修善行恶不相杂合。汝等若言我如灯者。是义不然。何以故。彼灯之明从缘而有。灯增长故明亦增长。众生我者则不如是。明从灯出住在异处。众生我者不得如是从身而出住在异处。彼灯光明与闇共住。何以故。如闇室中然一灯时照则不了及至多灯乃得明了。若初灯破闇则不须后灯。若须后灯。当知初明与闇共住。瞿昙。若无我者谁作善恶。佛言。若我作者云何名常。如其常者云何而得有时作善有时作恶。若言有时作善恶者。云何复得言我无边。若我作者何故而复习行恶法。如其我是作者知者。何故生疑众生无我。以是义故。外道法中定无有我。若言我者则是如来。何以故。身无边故。无疑网故。不作不受故名为常。不生不灭故名为乐。无烦恼垢故名为净。无有十相故名为空。是故如来常乐我净空无诸相。诸外道言。若言如来常乐我净无相故空。当知瞿昙所说之法则非空也。是故我今当顶戴受持。尔时外道其数无量。于佛法中信心出家

善男子。以是因缘故。我于此娑罗双树大师子吼。师子吼者名大涅槃。善男子。东方双者破于无常获得于常。乃至北方双者破于不净而得于净。善男子。此中众生为双树故护娑罗林。不令外人取其枝叶斫截破坏。我亦如是为四法故。令诸弟子护持佛法。何等为四。常乐我净。此四双树四王典掌。我为四王护持我法。是故于中而般涅槃。善男子。娑罗双树花果常茂。常能利益无量众生。我亦如是。常能利益声闻缘觉。花者喻我。果者喻乐。以是义故。我于此间娑罗双树入大寂定。大寂定者名大涅槃师子吼言。世尊。如来何故二月涅槃。善男子。二月名春。春阳之月万物生长。种植根栽花果敷荣。江河盈满百兽孚乳。是时众生多生常想。为破众生如是常心。说一切法悉是无常。唯说如来常住不变。善男子。于六时中孟冬枯悴众不爱乐。阳春和液人所贪爱。为破众生世间乐故演说常乐。我净亦尔。如来为破世我世净。故说如来真实我净。言二月者喻于如来二种法身。冬不乐者智者不乐如来无常入于涅槃。二月乐者喻于智者爱乐如来常乐我净。种植者喻诸众生闻法欢喜发阿耨多罗三藐三菩提心种诸善根。河者喻于十方诸大菩萨来诣我所咨受如是大涅槃典。百兽孚乳者喻我弟子生诸善根。花喻七觉。果喻四果。以是义故。我于二月入大涅槃

师子吼言。如来初生出家成道转妙法轮皆以八日。何故涅槃独十五日。佛言。善哉善哉。善男子。如十五日月无亏盈。诸佛如来亦复如是。入大涅槃无有亏盈。以是义故。于十五日入般涅槃。善男子。如十五日月盛满时有十一事。何等十一。一能破闇二令众生见道非道。三令众生见道邪正。四除郁蒸得清凉乐。五能破坏萤火高心。六息一切贼盗之想。七除众生畏恶兽心。八能开敷优钵罗花。九合莲花。十发行人进路之心。十一令诸众生乐受五欲多获快乐。善男子。如来满月亦复如是。一者破坏无明大闇。二者演说正道邪道。三者开示生死邪崄涅槃平正。四者令人远离贪欲嗔恚痴热。五者破坏外道光明。六者破坏烦恼结贼。七者除灭畏五盖心。八者开敷众生种善根心。九者覆盖众生五欲之心。十者发起众生进修趣向大涅槃行。十一者令诸众生乐修解脱。以是义故。于十五日入大涅槃。而我真实不入涅槃。我弟子中愚痴恶人。定谓如来入于涅槃。譬如母人多有诸子其母舍行至他国土。未还之顷诸子各言我母已死。而是母人实不死也

师子吼菩萨言。世尊。何等比丘能庄严此娑罗双树。善男子。若有比丘。受持读诵十二部经。正其文句通达深义。为人解说初中后善。为欲利益无量众生。演说梵行。如是比丘则能庄严娑罗双树。师子吼言。世尊。如我解佛所说义者。阿难比丘即其人也。何以故。阿难比丘受持读诵十二部经。为人开说正语正义。犹如泻水置之异器。阿难比丘亦复如是。从佛所闻如闻传说善男子。若有比丘得净天眼。见于十方三千大千世界所有。如观掌中庵摩勒果。如是比丘亦能庄严娑罗双树。师子吼言。世尊。若如是者。阿尼楼驮比丘即其人也。何以故。阿尼楼驮天眼见于三千大千世界所有乃至中阴悉能明了无障碍故。善男子。若有比丘少欲知足。心乐寂静。勤行精进念定慧解。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。迦叶比丘即其人也。何以故。迦叶比丘善修少欲知足等法。善男子。若有比丘为益众生不为利养。修习通达无诤三昧圣行空行。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。须菩提比丘即其人也。何以故。须菩提者善修无诤圣行空行故。善男子。若有比丘善修神通。一念之中能作种种神通变化。一心一定能作二果。所谓水火。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。目连比丘即其人也。何以故。目犍连者善修神通无量变化故。善男子。若有比丘善修大智利智庄严智解脱智甚深智广智无边智无胜智实智。具足成就如是慧根。于怨亲中心无差别。若闻如来涅槃无常心无忧戚。若闻常住不入涅槃不生欣庆。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。舍利弗比丘即其人也。何以故。舍利弗者善能成就具足如是大智慧故。善男子。若有比丘。能说众生悉有佛性。得金刚身无有边际常乐我净。身心无碍得八自在。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。唯有如来是其人也。何以故。如来之身金刚无边常乐我净身心无碍具八自在故。世尊。唯有如来乃能庄严娑罗双树。如其无者则不端严。惟愿大慈为庄严故常住于此娑罗树林

佛言。善男子。一切诸法性无住住。汝云何言愿如来住。善男子。凡言住者名为色法。从因缘生故名为住。因缘无处故名无住。如来已断一切色缚。云何当言如来住耶。受想行识亦复如是。善男子。住名憍慢。以憍慢故不得解脱。不得解脱故名为住。谁有憍慢从何处来。是故得名为无住住。如来永断一切憍慢。云何而言愿如来住。住者名有为法。如来已断有为之法。是故不住。住名空法。如来已断如是空法。是故获得常乐我净。云何而言愿如来住。住者名为二十五有如来已断二十五有。云何而言愿如来住。住者即是一切凡夫。诸圣无去无来无住。如来已断去来住相。云何言住。夫无住者。名无边身。身无边故。云何而言惟愿如来住娑罗林。若住此林则是有边身。若有边则是无常。如来是常。云何言住。夫无住者名曰虚空。如来之性同于虚空。云何言住。又无住者名金刚三昧。金刚三昧坏一切住。金刚三昧即是如来。云何言住。又无住者则名为幻。如来同幻。云何言住。又无住者名无始终。如来之性无有始终。云何言住。又无住者名无边法界。无边法界即是如来。云何言住。又无住者名首楞严三昧。首楞严三昧知一切法而无所著。以无著故名首楞严。如来具足首楞严定。云何言住。又无住者名处非处力。如来成就处非处力。云何言住。又无住者名檀波罗蜜。檀波罗蜜若有住者。则不得至尸波罗蜜乃至般若波罗蜜。以是义故檀波罗蜜名为无住。如来乃至不住般若波罗蜜。云何愿言如来常住娑罗树林。又无住者名修四念处。如来若住四念处者。则不能得阿耨多罗三藐三菩提名不住住。又无住者名无边众生界。如来悉到一切众生无边界分而无所住。又无住者名无屋宅。无屋宅者名为无有。无有者名为无生。无生者名为无死。无死者名为无相。无相者名为无系。无系者名为无著。无著者名为无漏。无漏即善。善即无为。无为者即大涅槃常。大涅槃常者即我我者即净。净者即乐。常乐我净即是如来。善男子。譬如虚空不住东方南西北方四维上下。如来亦尔。不住东方南西北方四维上下。善男子。若有说言身口意恶得善果者。无有是处。身口意善得恶果者。亦无是处。若言凡夫得见佛性十住菩萨不得见者。亦无是处。一阐提辈犯五逆罪谤方等经毁四重禁。得阿耨多罗三藐三菩提者。亦无是处。六住菩萨烦恼因缘堕三恶道。亦无是处。菩萨摩诃萨以真女身得阿耨多罗三藐三菩提者。亦无是处。一阐提常三宝无常。亦无是处。如来住于拘尸那城。亦无是处。善男子。如来今于此拘尸那城。入大三昧深禅定窟。众不见故名大涅槃师子吼言。如来何故入禅定窟。善男子。为欲度脱诸众生故。未种善根令得种故。已种善根得增长故。善果未熟令得熟故。为已熟者说趣阿耨多罗三藐三菩提故。轻贱善法者令生尊贵故。诸有放逸者令离放逸故。为与文殊师利等诸大香象共论议故。为欲教化乐读诵者深爱禅定故。为以圣行梵行天行化众生故。为观不共深法藏故。为欲呵责放逸弟子故。如来常寂犹尚乐定。况汝等辈烦恼未尽而生放逸。为欲呵责诸恶比丘受畜八种不净之物及不少欲不知足故。为令众生尊重所闻禅定法故。以是因缘入禅定窟师子吼言。世尊。无相定者名大涅槃。是故涅槃名为无相。以何因缘名为无相。善男子。无十相故。何等为十。所谓色相声相香味触相生住坏相男相女相。是名十相。无如是相故名无相。善男子。夫着相者则能生痴痴故生爱。爱故系缚。系缚故受生。生故有死。死故无常。不着相者则不生痴。不生痴故则无有爱。无有爱故则无系缚。无系缚故则不受生。不受生故则无有死。无有死故则名为常。以是义故涅槃名常

师子吼言。世尊。何等比丘能断十相。佛言。善男子。若有比丘。时时修习三种相者则断十相。时时修习三昧定相。时时修习智慧之相。时时修习舍相。是名三相

师子吼言。世尊。云何名为定慧舍相定。是三昧者一切众生皆有三昧。云何方言修习三昧。若心在一境则名三昧。若更余缘则不名三昧。如其不定非一切智。非一切智云何名定。若以一行得三昧者。其余诸行亦非三昧。若非三昧则非一切智。若非一切智云何名三昧。慧舍二相亦复如是

佛言。善男子。如汝所言。缘于一境得名三昧。其余诸缘不名三昧。是义不然。何以故。如是余缘亦一境故。行亦如是。又言众生先有三昧不须修者。是亦不然。所以者何。言三昧者名善三昧。一切众生真实未有。云何而言不须修习。以住如是善三昧中观一切法。名善慧相。不见三昧智慧异相。是名舍相。复次善男子。若取色相不能观色常无常相是名三昧。若能观色常无常相。是名慧相。三昧慧等观一切法。是名舍相。善男子。如善御驾驷迟疾得所。迟疾得所故名舍相。菩萨亦尔。若三昧多者则修习慧。若慧多者则修习三昧。三昧慧等则名为舍。善男子。十住菩萨智慧力多三昧力少。是故不得明见佛性。声闻缘觉三昧力多智慧力少。以是因缘不见佛性。诸佛世尊定慧等故。明见佛性了了无碍。如观掌中庵摩勒果。见佛性者名为舍相

奢摩他者名为能灭。能灭一切烦恼结故。又奢摩他者名曰能调。能调诸根恶不善故。又奢摩他者名曰寂静。能令三业成寂静故。又奢摩他者名曰远离。能令众生离五欲故。又奢摩他者名曰能清能清贪欲嗔恚愚痴三浊法故。以是义故。故名定相。毗婆舍那名为正见。亦名了见。名为能见。名曰遍见。名次第见。名别相见。是名为慧。忧毕叉者名曰平等。亦名不诤。又名不观。亦名不行。是名为舍。善男子。奢摩他者有二种。一者世间。二出世间。复有二种。一者成就。二不成就。成就者所谓诸佛菩萨。不成就者所谓声闻辟支佛等。复有三种。谓下中上。下者谓诸凡夫。中者声闻缘觉。上者诸佛菩萨。复有四种。一退。二住。三进。四能大利益。复有五种。所谓五智三昧。何等为五。一无食三昧。二无过三昧。三身意清净一心三昧。四因果俱乐三昧。五常念三昧。复有六种。一观骨三昧。二慈三昧。三观十二因缘三昧。四阿那婆那三昧。五念觉观三昧。六观生灭三昧。复有七种。所谓七觉分。一念觉分。二择法觉分。三精进觉分。四喜觉分。五除觉分。六定觉分。七舍觉分。复有七种。一须陀洹三昧。二斯陀含三昧。三阿那含三昧。四阿罗汉三昧。五辟支佛三昧。六菩萨三昧。七如来觉知三昧。复有八种。谓八解脱三昧。一内有色相外观色解脱三昧。二内无色相外观色解脱三昧。三净解脱身证三昧。四空处解脱三昧。五识处解脱三昧。六无所有处解脱三昧。七非有想非无想处解脱三昧。八灭尽定解脱三昧。复有九种。所谓九次第定。四禅四空及灭尽定三昧。复有十种。所谓十一切处三昧。何等为十。一者地一切处三昧。二者水一切处三昧。三者风一切处三昧。四者青一切处三昧。五者黄一切处三昧。六者赤一切处三昧。七者白一切处三昧。八者空一切处三昧。九者识一切处三昧。十者无所有一切处三昧。复有无数种所谓诸佛菩萨。善男子。是名三昧相善男子。慧有二种。一者世间。二出世间。复有三种。一者般若。二者毗婆舍那。三者阇那。般若者名一切众生。毗婆舍那者一切圣人。阇那者诸佛菩萨。又般若者名为别相。毗婆舍那者名为总相。阇那者名为破相。复有四种。所谓观四真谛。善男子。为三事故修奢摩他。何等为三。一者不放逸故。二者庄严大智故。三者得自在故。复次为三事故修毗婆舍那。何等为三。一者为观生死恶果报故。二者为欲增长诸善根故。三者为破一切诸烦恼故

大般涅槃经卷第二十八大般涅槃经卷第二十九

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品之五

师子吼言。世尊。如经中说。若毗婆舍那能破烦恼。何故复修奢摩他耶佛言。善男子。汝言毗婆舍那破烦恼者。是义不然。何以故。有智慧时则无烦恼。有烦恼时则无智慧。云何而言毗婆舍那能破烦恼。善男子譬如明时无闇闇时无明。若有说言明能破闇。无有是处。善男子。谁有智慧谁有烦恼。而言智慧能破烦恼。如其无者则无所破。善男子。若言智慧能破烦恼。为到故破不到故破。若不到破者。凡夫众生则应能破。若到故破者。初念应破。若初念不破后亦不破。若初到便破是则不到。云何说言智慧能破。若言到与不到而能破者。是义不然。复次毗婆舍那破烦恼者。为独能破为伴故破。若独能破。菩萨何故修八正道若伴故破。当知独则不能破也。若独不能伴亦不能。如一盲人不能见色。虽伴众盲亦不能见。毗婆舍那亦复如是。善男子。如地坚性火热性水湿性风动性。而地坚性乃至风动性。非因缘作其性自尔。如四大性烦恼亦尔性自是断。若是断者云何而言智慧能断。以是义故。毗婆舍那决定不能破诸烦恼。善男子。如盐性碱令异物碱。蜜本性甘令异物甘。水本性湿令异物湿。智慧性灭令异法灭者。是义不然。何以故。若法无灭云何智慧强能令灭。若言盐碱令异物碱慧灭亦尔能令异法灭者。是亦不然。何以故。智慧之性念念灭故。若念念灭云何而言能灭他法。以是义故。智慧之性不破烦恼。善男子。一切诸法有二种灭。一者性灭。二者毕竟灭。若性灭者云何而言智慧能灭。若言智慧能灭烦恼如火烧物。是义不然。何以故。如火烧物则有遗烬。智慧若尔应有余烬。如斧伐树破处可见。智慧若尔有何可见。慧若能令烦恼离者。如是烦恼应余处现。如诸外道离六大城拘尸城现。若是烦恼不余处现。则知智慧不能令离。善男子。一切诸法性若自空。谁能令生谁能令灭。生异灭异无造作者。善男子。若修习定则得如是正智正见。以是义故。我经中说。若有比丘修习定者。能见五阴生灭之相。善男子。若不修定世间之事尚不能了。况于出世。若无定者平处颠坠。心缘异法口宣异言。耳闻异声心解异义。欲造异字手书异文。欲行异路身涉异径。若有修习三昧定者。则大利益乃至阿耨多罗三藐三菩提

善男子。菩萨摩诃萨具足二法。能大利益。一定二智。善男子。如刈菅草执急则断。菩萨摩诃萨修是二法亦复如是。善男子。如拔坚木先以手动后则易出。菩萨定慧亦复如是。先以定动后以智拔。善男子。如浣垢衣先以灰汁后以清水衣则鲜洁。菩萨定慧亦复如是。善男子。如先读诵后则解义。菩萨定慧亦复如是。善男子。譬如勇人先以铠仗牢自庄严然后御阵能坏怨贼。菩萨定慧亦复如是。善男子。譬如巧匠钳鐹盛金自在随意[打-丁+毛]搅融消。菩萨定慧亦复如是。善男子。譬如明镜照了面像。菩萨定慧亦复如是。善男子。如先平地然后下种。先从师受后思惟义。菩萨定慧亦复如是。以是义故。菩萨摩诃萨修是二法能大利益。善男子。菩萨摩诃萨修是二法。调摄五根堪忍众苦。所谓饥渴寒热打掷骂辱。恶兽所啮蚊虻所螫。常摄其心不令放逸。不为利养行于非法。客尘烦恼所不能污。不为诸邪异见所惑。常能远离诸恶觉观。不久成就阿耨多罗三藐三菩提。为欲成就利众生故。善男子。菩萨摩诃萨修是二法。四倒暴风不能吹动。如须弥山虽为四风之所吹鼓不能令动。不为外道邪师所拔。如帝释幢不可移转。众邪异术不能诳惑。常受微妙第一安乐。能解如来深秘密义。受乐不欣逢苦不戚。诸天世人恭敬赞叹。明见生死及非生死。善能了知法界法性身有常乐我净之法是则名为大涅槃乐

善男子。定相者名空三昧。慧相者名无愿三昧。舍相者名无相三昧。善男子。若有菩萨摩诃萨。善知定时慧时舍时及知非时。是名菩萨摩诃萨行菩提道。师子吼言。世尊。云何菩萨知时非时。善男子。菩萨摩诃萨因于受乐生大憍慢。或因说法而生憍慢。或因精勤而生憍慢。或因解义善问答时。而生憍慢。或因亲近恶知识故而生憍慢。或因布施所重之物而生憍慢。或因世间善法功德而生憍慢。或因世间豪贵之人所恭敬故而生憍慢。当知尔时不宜修智宜应修定。是名菩萨知时非时。若有菩萨勤修精进。未得利益涅槃之乐。以不得故生于悔心。以钝根故不能调伏五情诸根。诸垢烦恼势力盛故自疑戒律。有羸损故。当知尔时不宜修定宜应修智。是名菩萨知时非时。善男子。若有菩萨定慧二法不平等者。当知尔时不宜修舍。二法若等则宜修之。是名菩萨知时非时。善男子。若有菩萨修习定慧起烦恼者。当知尔时不宜修舍。宜应读诵书写解说十二部经念佛念法念僧念戒念天念舍。是名修舍。善男子。若有菩萨修习如是三法相者。以是因缘得无相涅槃

师子吼言。世尊。无十相故名大涅槃为无相者。复以何缘。名为无生无出无作屋宅洲归安隐灭度涅槃寂静无诸病苦无所有耶。佛言。善男子。无因缘故。故名无生。以无为故。故名无出。无造业故。故名无作。不入五见。故名屋宅。离四瀑水。故名为洲。调众生故。故名归依。坏结贼故。故名安隐。诸结火灭。故名灭度。离觉观故。故名涅槃。远愦闹故。名曰寂静。永断必死。故名无病。一切无故。名无所有。善男子。若菩萨摩诃萨作是观时。即得明了见于佛性

师子吼言。世尊。菩萨摩诃萨成就几法。能见如是无相涅槃至无所有。佛言。善男子。菩萨摩诃萨成就十法。则能明见涅槃无相至无所有。何等为十。一者信心具足。云何名为信心具足。深信佛法众僧是常。十方诸佛方便示现一切众生及一阐提悉有佛性。不信如来生老病死及修苦行提婆达多真实破僧出佛身血如来毕竟入于涅槃正法灭尽。是名菩萨信心具足。二者净戒具足。云何名为净戒具足。善男子。若有菩萨自言戒净。虽不与彼女人和合。见女人时或共嘲调言语戏笑。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽不与彼女人身合嘲调戏笑。于壁障外遥闻女人璎珞环钏种种诸声心生爱着。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽复不与女人和合言语嘲调听其音声。然见男子随逐女时。或见女人随逐男时。便生贪着。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽复不与女人和合言语嘲调听其音声见男女相随。然为生天受五欲乐。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。善男子。若有菩萨。清净持戒。而不为戒不为尸罗波罗蜜。不为众生不为利养。不为菩提不为涅槃。不为声闻辟支佛。唯为最上第一义故护持禁戒。善男子。是名菩萨净戒具足。三者亲近诸善知识。善知识者若有能说信戒多闻布施智慧令人受行。是名菩萨善知识也。四者乐于寂静。寂静者所谓身心寂静。观察诸法甚深法界。是名寂静。五者精进。精进者所谓系心观四正谛。设头火然终不放舍。是名精进。六者念具足。念具足者所谓念佛念法念僧念戒念天念舍。是名念具足。七者软语。软语者所谓实语妙语先意问讯时语真语。是名软语。八者护法。护法者所谓爱乐正法常乐演说。读诵书写思惟其义。广宣敷扬令其流布。若见有人书写解说读诵赞叹思惟义者。为求资生而供养之。所谓衣服饮食卧具医药。为护法故不惜身命。是名护法。九者菩萨摩诃萨见有同学同戒有所乏少。转从他乞熏钵染衣瞻病所须衣服饮食卧具房舍而供给之。十者具足智慧。智慧者所谓观于如来常乐我净一切众生悉有佛性。观法二相。所谓空不空常无常乐无乐我无我净不净。异法可断异法不可断。异法从缘生异法从缘见。异法从缘果异法非缘果。是名具足智慧。善男子。是名菩萨具足十法即能明见涅槃无相

师子吼言。世尊。如佛先告纯陀。汝今已得见于佛性得大涅槃。成就阿耨多罗三藐三菩提。是义云何。世尊。如经中说。若施畜生得百倍报。施一阐提得千倍报。施持戒者百千倍报。若施外道断烦恼者得无量报。施四道向及以四果至辟支佛得无量报。施不退菩萨及最后身诸大菩萨如来世尊。所得福报无量无边不可称计不可思议。纯陀大士。若受如是无量报者。是报无尽。何时当得阿耨多罗三藐三菩提。世尊。经中复说。若人重心造善恶业必得果报。若现世受。若次生受。若后世受。纯陀善业重心作故。当知是业必定受报。若定受报云何得成阿耨多罗三藐三菩提。云何复得见于佛性。世尊。经中复说。施三种人果报无尽。一者病人。二者父母。三者如来。世尊。经中复说。佛告阿难。一切众生如其无有欲界业者。即得阿耨多罗三藐三菩提。色无色业亦复如是。世尊。如法句偈。非空非海中。非入山石间。无有地方所。脱之不受业。又阿尼楼驮言。世尊。我忆往昔以一食施。八万劫中不堕三恶。世尊。一食之施尚得是报。何况纯陀信心施佛。具足成就檀波罗蜜。世尊。若善果报不可尽者。谤方等经犯五逆罪毁四重禁一阐提罪云何可尽。若不可尽。云何能得见于佛性成阿耨多罗三藐三菩提

佛言。善哉善哉。善男子。唯有二人。能得无量无边功德。不可称计不可宣说。能竭生死漂流瀑河。降魔怨敌摧魔胜幢。能转如来无上法轮。一者善问。二者善答。善男子。佛十力中业力最深。善男子。有诸众生于业缘中心轻不信。为度彼故作如是说。善男子。一切作业有轻有重。轻重二业复各有二。一者决定。二不决定。善男子。或有人言。恶业无果。若言恶业定有果者。云何气嘘旃陀罗而得生天。鸯掘摩罗得解脱果。以是义故。当知作业有定得果不定得果。我为除断如是邪见故于经中说如是语。一切作业无不得果。善男子。或有重业可得作轻。或有轻业可得作重。非一切人唯有愚智。是故当知非一切业悉定得果。虽不定得亦非不得。善男子。一切众生凡有二种。一者智人。二者愚人。有智之人以智慧力。能令地狱极重之业现世轻受。愚痴之人现世轻业地狱重受。师子吼言。世尊。若如是者则不应求清净梵行及解脱果。佛言。善男子。若一切业定得果者。则不应求梵行解脱。以不定故则修梵行及解脱果。善男子。若能远离一切恶业则得善果。若远善业则得恶果。若一切业定得果者。则不应求修习圣道。若不修道则无解脱。一切圣人所以修道。为坏定业得轻报故。不定之业无果报故。若一切业定得果者。则不应求修习圣道。若人远离修习圣道得解脱者。无有是处。不得解脱得涅槃者。亦无是处。善男子。若一切业定得果者。一世所作纯善之业。应当永已常受安乐。一世所作极重恶业。亦应永已受大苦恼。业果若尔则无修道解脱涅槃。人作人受。婆罗门作婆罗门受。若如是者则不应有下姓下有。人应常人。婆罗门应常婆罗门。小时作业应小时受。不应中年及老时受。老时作恶生地狱中。地狱初身不应便受。应待老时然后乃受。若老时不杀不应壮年得寿。若无壮寿云何至老。业无失故。业若无失。云何而有修道涅槃。善男子。业有二种。定以不定。定业有二。一者报定。二者时定。或有报定而时不定缘合则受。或三时受。所谓现受生受后受。善男子。若定心作善恶等业。作已深生信心欢喜。若发誓愿供养三宝。是名定业。善男子。智者善根深固难动。是故能令重业为轻。愚痴之人不善深厚。能令轻业而作重报。以是义故。一切诸业不名决定。菩萨摩诃萨无地狱业。为众生故发大誓愿生地狱中

善男子。往昔众生寿百年时。恒沙众生受地狱报。我见是已即发大愿受地狱身。菩萨尔时实无是业。为众生故受地狱果。我于尔时在地狱中经无量岁。为诸罪人广开分别十二部经。诸人闻已坏恶果报令地狱空。除一阐提。是名菩萨摩诃萨非现生后受是恶业。复次善男子。是贤劫中无量众生。堕畜生中受恶业果。我见是已复发誓愿。为欲说法度众生故。或作獐鹿罴鸽猕猴龙蛇金翅鱼鳖狐兔牛马之身。善男子。菩萨摩诃萨实无如是畜生恶业。以大愿力为众生故现受是身。是名菩萨摩诃萨非现生后受是恶业。复次善男子。是贤劫中复有无量无边众生生饿鬼中。或食吐汁脂肉脓血屎尿涕唾寿命无量百千万岁。初不曾闻浆水之名。况复眼见而得饮也。设遥见水生意往趣。到则变成猛火脓血。或时不变则有多人手执矛槊。遮护捉持不令得前。或天降雨至身成火。是名恶业果报。善男子。菩萨摩诃萨实无如是诸恶业果。为化众生令得解脱故。发誓愿受如是身。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫。生屠脍家畜养鸡猪牛羊。弶猎罗网渔捕旃陀罗舍作贼劫盗。菩萨实无如是恶业。为度众生令得解脱。以大愿力受如是身。是名菩萨摩诃萨非现生后受是恶业。善男子。是贤劫中复生边地。多作贪欲嗔恚愚痴习行非法。不信三宝后世果报。不能恭敬父母亲老耆旧长宿。善男子。菩萨尔时实无是业。为令众生得解脱故。以大愿力而生其中。是名菩萨摩诃萨非现生后受是。恶业。善男子。是贤劫中复受女身恶身贪身嗔身痴身妒身悭身幼身诳身缠盖之身。善男子。菩萨尔时亦无是业。但为众生得解脱故。以大愿力愿生其中。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫受黄门身无根二根及不定根。善男子。菩萨摩诃萨实无如是诸恶身业。为令众生得解脱故。以大愿力愿生其中。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫复习外道尼干子法信受其法。无施无祠无施祠报。无善恶业无善恶报。无现在世及未来世。无此无彼无有圣人。无变化身无道涅槃。善男子。菩萨实无如是恶业。但为众生令得解脱。以大愿力受是邪法。是名菩萨摩诃萨非现生后受是恶业

善男子。我念往昔与提婆达多俱为商主。各各自有五百贾人。为利益故至大海中采取珍宝。恶业缘故路遇暴风。吹破船舫伴党死尽。尔时我与提婆达多。不杀果报长寿缘故。为风所吹俱至陆地。时提婆达多贪惜宝货。生大忧苦发声啼哭。我时语言。提婆达多。不须啼哭。提婆达多即语我言。谛听谛听。譬如有人贫穷困苦。至冢墓间手捉死尸而作是言。愿汝今者施我死乐。我当施汝贫穷寿命。尔时死尸即便起坐语贫人言。善男子。贫穷寿命汝自受之。我今甚乐如是死乐。实不欣汝贫穷而生。然我今日既无死乐兼复贫穷。云何而得不啼哭耶。我复慰喻。汝且莫愁。今有二珠价直无数。当分一枚以相惠施。我即分与复语之言。有命之人能得此宝。如其无命谁能得耶。我时疲弊诣一树下止息眠卧。提婆达多贪心炽盛。为余一珠即生恶心。刺坏我目劫夺我珠。我时患疮发声呻号。时有一女来至我所而问我言。仁者何故呻号如是。我即为其广说本事。女人闻已复重问我。汝名字何。我即答言。名为实语女言。云何知汝为实语耶。我即立誓若我今于提婆达多有恶心者。目当如是永为盲瞎。如其无者当还得眼。言已其目平复如故。善男子。是名菩萨摩诃萨说现世报。善男子。我念往昔生南天竺富单那城婆罗门家。是时有王名迦罗富。其性暴恶憍慢自大。年壮色美耽着五欲。我于尔时为度众生在彼城外寂默禅思。尔时彼王春木花敷。与其眷属宫人婇女出城游观。在树林下五欲自娱。其诸婇女舍王游戏遂至我所。我时欲为断彼贪故而为说法。时王寻来即见我时。便生恶心而问我言。汝今已得罗汉果耶。我言。不得。复言。获得不还果耶。我言不得。复作是言。汝今若未得是二果。则为具足贪欲烦恼。云何自恣观我女人。我即答言。大王当知。我今虽未断贪欲结。然其内心实无贪着。王言。痴人。世有诸仙服气食果。见色犹贪。况汝盛年未断贪欲。云何见色而当不着。我言。大王。见色不着实不因于服气食果。皆由系心无常不净。王言。若有轻他而生诽谤。云何得名修持净戒。我言。大王。若有妒心则有诽谤。我无妒心。云何言谤。王言。大德。云何名戒。大王。忍名为戒。王言。若忍是戒者。当截汝耳。若能忍者知汝持戒。即截其耳。时我被截颜色不变。时王群臣见是事已。即谏王言。如是大士不应加害。王告诸臣。汝等云何知是大士。诸臣答言。见受苦时容色不变。王复语言。我当更试知变不变。即劓其鼻刖其手足。尔时菩萨已于无量无边世中。修习慈悲愍苦众生。时四天王心怀嗔忿雨沙砾石。王见是已心大怖畏。复至我所长跪而言。唯愿哀愍听我忏悔。我言。大王。我心无嗔亦如无贪。王言。大德。云何得知心无嗔恨。我即立誓。我若真实无嗔恨者。令我此身平复如故。发是愿已身即平复。是名菩萨摩诃萨说现世报

善男子。善业生报后报。及不善业亦复如是。菩萨摩诃萨得阿耨多罗三藐三菩提时。一切诸业悉得现报。不善恶业得现报者。如王作恶天降恶雨。亦如有人示猎师罴处及宝色鹿其手堕落。是名恶业现受果报。生报者如一阐提犯四重禁及五逆罪。后报者如持戒人深发誓愿。愿未来世常得如是净戒之身。若有众生寿百年时八十年时。于中当作转轮圣王教化众生

善男子。若业定得现世报者。则不能得生报后报。菩萨摩诃萨修三十二大人相业。则不能得现世报也。若业不得三种报者。是名不定。善男子。若言诸业定得报者。则不得有修习梵行解脱涅槃。当知是人非我弟子是魔眷属。若言诸业有定不定。定者现报生报后报。不定者缘合则受不合不受。以是义故。应有梵行解脱涅槃。当知是人真我弟子非魔眷属。善男子。一切众生不定业多决定业少。以是义故。有修习道。修习道故。决定重业可使轻受。不定之业非生报受

善男子有二种人。一者不定作定报现报作生报轻报作重报。应人中受在地狱受。二者定作不定。应生受者回为现受。重报作轻。应地狱受人中轻受。如是二人。一愚二智。智者为轻。愚者令重。善男子。譬如二人于王有罪。眷属多者其罪则轻。眷属少者应轻更重。愚智之人亦复如是。智者善业多故重则轻受。愚者善业少故轻则重受。善男子。譬如二人一则肥壮。一则羸瘦。俱没深泥。肥壮能出。羸者则没。善男子。譬如二人俱共服毒。一有咒力及阿伽陀。一者无有。有咒药者毒不能伤。无咒药者服时即死。善男子。譬如二人俱多饮浆。一火势盛。一则微弱。火势多者则能消化。火势弱者则为其患。善男子。譬如二人为王所系。一有智慧。一则愚痴。其有智者则能得脱。愚痴之人无有脱期。善男子。譬如二人俱涉险路。一则有目。一则盲瞽。有目之人直过无患。盲者坠落堕深坑险。善男子。譬如二人俱共饮酒。一则多饮。一则少饮。其多饮者饮则无患。其少饮者饮则成患。善男子。譬如二人俱敌怨阵。一则铠仗具足庄严。一则自身。其有仗者能破怨敌。其自身者不能自勉。复有二人粪秽污衣。一觉寻浣。一觉不浣。其寻浣者衣则净洁。其不浣者垢秽日增。复有二人俱共乘车。一有辐轴一无辐轴。有辐轴者随意而去。无辐轴者则不移处。复有二人俱行旷路。一有资粮。一则空往。有资粮者则得度险。其空往者则不能过。复有二人为贼所劫。一有宝藏。一则无藏。有宝藏者心无忧戚其无藏者心则愁恼。愚智之人亦复如是。有善藏者重业轻受。无善藏者轻业重受

师子吼菩萨言。世尊。如佛所说。非一切业悉得定果。亦非一切众生定受。世尊。云何众生令现轻报地狱重受。地狱重报现世轻受。佛言。一切众生凡有二种。一者有智。二者愚痴若能修习身戒心慧。是名智者。若不能修身戒心慧。是名愚痴。云何名为不修习身。若不能摄五情诸根。名不修身。不能受持七种净戒。名不修戒。不调心故名不修心。不修圣行名不修慧。复次不修身者不能具足清净戒体。不修戒者受畜八种不净之物。不修心者不能修习三种相故。不修慧者不修梵行故。复次不修身者不能观身。不能观色及观色相。不观身相。不知身数。不知是身从此到彼。于非身中而生身相。于非色中而作色相。是故贪着我身身数。名不修身。不修戒者。若受下戒不名修戒。受持边戒为自利戒为自调戒。不能普为安乐众生。非为护持无上正法。为生天上受五欲乐。不名修戒不修心者。若心散乱不能专一守自境界。自境界者谓四念处。他境界者所谓五欲。若不能修四念处者。名不修心。于恶业中不善护心。名不修慧。复次不修身者不能深观是身无常无住危脆念念灭坏是魔境界。不修戒者不能具足尸波罗蜜。不修心者不能具足禅波罗蜜。不修慧者不能具足般若波罗蜜。复次不修身者贪着我身及我所身。我身常恒无有变易。不修戒者为自身故作十恶业。不修心者于恶业中不能摄心。不修慧者以不摄心不能分别善恶等法。复次不修身者不断我见。不修戒者不断戒取。不修心者作贪嗔业趣向地狱。不修慧者不断痴心。复次。不修身者不能观身。虽无过咎而常是怨。善男子。譬如男子有怨常逐伺求其便。智者觉已系心慎护。若不慎护则为所害。一切众生身亦如是。常以饮食冷暖将养。若不如是将护守慎即当散坏。善男子。如婆罗门奉事火天。常以香花赞叹礼拜供养承事期满百年。若一触时寻烧人手。是火虽得如是供养。终无一念报事者恩。一切众生身亦如是。虽于多年以好香花璎珞衣服饮食卧具病瘦医药而供给之。若遇内外诸恶因缘即时灭坏。都不忆念往日供给衣食之恩。善男子。譬如有王畜四毒蛇置之一箧以付一人仰令瞻养。是四蛇中设一生嗔则能害人。是人恐怖常求饮食随时守护。一切众生四大毒蛇亦复如是。若一大嗔则能坏身。善男子。如人久病应当至心求医疗治若不勤救必死不疑。一切众生身亦如是。常应摄心不令放逸。若放逸者即便灭坏。善男子。譬如坏瓶不耐风雨打掷捶压。一切众生身亦如是。不耐饥渴寒热风雨打系恶骂。善男子。如痈未熟常当善护不令人触。设有触者即大苦痛。一切众生身亦如是。善男子。如骡怀妊自害其躯。一切众生身亦如是。内有风冷身即受苦。善男子。譬如芭蕉生实则枯。一切众生身亦如是。善男子。亦如芭蕉内无坚实。一切众生身亦如是。善男子。如蛇鼠狼各各相于常生怨心。众生四大亦复如是。善男子。譬如鹅王不乐冢墓。菩萨亦尔。于身冢墓亦不贪乐。善男子。如旃陀罗七世相继不舍其业是故为人之所轻贱。是身种子亦复如是。种子精血究竟不净。以不净故诸佛菩萨之所轻呵。善男子。是身不如摩罗耶山生于栴檀。亦不能生优钵罗花芬陀利花瞻婆花摩差迦花婆师迦花。九孔常流脓血不净。生处臭秽丑陋可恶。常与诸虫共在一处。善男子。譬如世间虽有上妙清净园林死尸至中则为不净。众共舍之不生爱着。色界亦尔。虽复净妙以有身故诸佛菩萨悉共舍之。善男子。若有不能作如是观。名不修身。不修戒者。善男子。若不能观戒是一切善法梯橙。亦是一切善法根本。如地悉是一切树木所生之本。是诸善根之导首也。如彼商主导众商人。戒是一切善法胜幢。如天帝释所立胜幢。戒能永断一切恶业及三恶道。能疗恶病犹如药树。戒是生死险道资粮。戒是摧结破贼铠仗。戒是灭结毒蛇良咒。戒是度恶业行桥梁。若有不能如是观者。名不修戒。不修心者。不能观心轻躁动转难捉难调。驰骋奔逸如大恶象。念念迅速如彼电光。躁扰不住犹如猕猴。如幻如炎。乃是一切诸恶根本。五欲难满如火获薪。亦如大海吞受诸流。如曼陀山草木滋多。不能观察生死虚妄。耽惑致患如鱼吞钩。常先引导诸业随从。犹如贝母引导诸子。贪着五欲不乐涅槃。如驼食蜜乃至于死不顾刍草。深着现乐不观后过。如牛贪苗不惧杖楚。驰骋周遍二十五有。犹如疾风吹兜罗[卄/毦]所不应求求无厌足。如无知人求无热火。常乐生死不乐解脱。如纴婆虫乐纴婆树。迷惑爱着生死臭秽。犹如狱囚乐狱卒女。亦如厕猪乐处不净。若有不能如是观者。名不修心。不修慧者不观智慧有大势力如金翅鸟。能坏恶业坏无明闇犹如日光。能拔阴树如水漂物。焚烧邪见犹如猛火。慧是一切善法根本佛菩萨母之种子也。若有不能如是观者不名修慧。善男子。第一义中若见身身相身因身果身聚身一身二此身彼身身灭身等身修修者。若有如是见者名不修身。善男子。若见戒戒相戒因戒果上戒下戒戒聚戒一戒二此戒彼戒戒灭戒等戒修修者戒波罗蜜。若有如是见者名不修戒。若见心心相心因心果心聚心及心数心一心二此心彼心心灭心等心修修者上中下心善心恶心。若有如是见者名不修心。善男子。若见慧慧相慧因慧果慧聚慧一慧二此慧彼慧慧灭慧等上中下慧钝慧利慧慧修修者。若有如是见者名不修慧。善男子。若有不修身戒心慧。如是之人于小恶业得大恶报。以恐怖故常生是念。我属地狱作地狱行。虽闻智者说地狱苦。常作是念。如铁打铁石还打石木自打木火虫乐火。地狱之身还似地狱。若似地狱有何苦事。譬如苍蝇为唾所粘不能得出。是人亦尔。于小罪中不能自出。心初无悔不能修善覆藏瑕疵。虽有过去一切善业。悉为是罪之所垢污。是人所有现受轻报转为地狱极重恶果。善男子。如小器水置盐一升其味碱苦难可得饮。是人罪业亦复如是。善男子。譬如有人负他一钱不能偿故身被系缚多受众苦。是人罪业亦复如是师子吼菩萨言。世尊。是人何故令现轻报转地狱受。佛言。善男子。一切众生若具五事。令现轻报转地狱受。何等为五。一者愚痴故。二者善根微少故。三者恶业深重故。四者不忏悔故。五者不修本善业故。复有五事。一者修习恶业故。二者无戒财故。三者远离诸善根故。四者不修身戒心慧故。五者亲近恶知识故。善男子。是故能令现世轻报地狱重受

师子吼言。世尊。何等人能转地狱报现世轻受。善男子。若有修习身戒心慧。如先所说。能观诸法同如虚空。不见智慧不见智者。不见愚痴不见愚者。不见修习及修习者。是名智者。如是之人则能修习身戒心慧。是人能令地狱果报现世轻受。是人设作极重恶业。思惟观察能令轻微。作是念言。我业虽重不如善业。譬如叠花虽复百斤终不能敌真金一两。如恒河中投一升盐水无碱味饮者不觉。如巨富者虽多负人千万宝物无能系缚令其受苦。如大香象能坏铁锁自在而去。智慧之人亦复如是。常思惟言。我善力多恶业羸弱。我能发露忏悔除恶能修智慧。智慧力多无明力少。如是念已。亲近善友修习正见。受持读诵书写解说十二部经。见有受持读诵书写解说之者。心生恭敬兼以衣食房舍卧具病药花香。而供养之赞叹尊重。所至到处称说其善不说其短。供养三宝敬信方等大涅槃经如来常恒无有变易一切众生悉有佛性。是人能令地狱重报现世轻受。善男子。以是义故。非一切业悉有定果。亦非一切众生定受

大般涅槃经卷第二十九大般涅槃经卷第三十

        宋代沙门慧严等依泥洹经加之

    师子吼菩萨品之六

师子吼菩萨言。世尊。若一切业不定得果。一切众生悉有佛性。应当修习八圣道者。何因缘故。一切众生悉不得是大般涅槃。世尊。若一切众生有佛性者。即当定得阿耨多罗三藐三菩提。何须修习八圣道耶。世尊。如此经中说有病人。若得医药及瞻病人随病饮食。若使不得皆悉除差。一切众生亦复如是。若遇声闻及辟支佛诸佛菩萨诸善知识。若闻说法修习圣道。若不遇不闻不修习道。悉当得成阿耨多罗三藐三菩提。何以故。以佛性故。世尊。譬如日月无有能遮令不得至頞多山边。四大河水不至大海。一阐提等不至地狱。一切众生亦复如是。无有能遮令不得至阿耨多罗三藐三菩提。何以故以佛性故。世尊。以是义故。一切众生不须修道。以佛性力故应得阿耨多罗三藐三菩提。不以修习圣道力故。世尊。若一阐提犯四重禁五逆罪等。不得阿耨多罗三藐三菩提者。应须修习。以因佛性定当得故。非因修习然后得也。世尊。譬如磁石去铁虽远以其力故铁则随着。众生佛性亦复如是。是故不须勤修习道佛言。善哉善哉。善男子。如恒河边有七种人。若为洗浴恐畏寇贼。或为采花则入河中。第一人者入水则没。何以故。羸无势力不习浮故。第二人者虽没还出出已复没。何以故。身力大故。则能还出。不习浮故出已还没。第三人者没已即出。出更不没。何以故。身重故没。力大故出。先习浮故出已即住。第四人者入已便没没已还出。出已即住遍观四方。何以故。重故则没。力大故还出。习浮则住。不知出处故观四方。第五人者入已即没。没已还出。出已即住。住已观方。观已即去。何以故为怖畏故。第六人者入已即去浅处则住。何以故观贼近远故。第七人者既至彼岸。登上大山无复恐怖。离诸怨贼受大快乐。善男子。生死大河亦复如是。有七种人。畏烦恼贼故发意欲渡生死大河。出家剃发身被法服。既出家已亲近恶友。随顺其教听受邪法。所谓众生身者即是五阴。五阴者即名五大。众生若死永断五大。断五大故何须修习善恶诸业。是故当知无有善恶及善恶报。如是则名一阐提也。一阐提者名断善根。断善根故没生死河不能得出。何以故。恶业重故无信力故。如恒河边第一人也。善男子。一阐提辈有六因缘。没三恶道不能得出。何等为六。一者恶心炽盛故。二者不见后世故。三者乐习烦恼故。四者远离善根故。五者恶业障隔故。六者亲近恶知识故。复有五事没三恶道。何等为五。一者于比丘边作非法故。二者比丘尼边作非法故。三者自在用僧祇物故。四者母边作非法故。五者于五部僧互生是非故。复有五事没三恶道。何等为五。一者常说无善恶果故。二者杀发菩提心众生故。三者喜说法师过失故。四者法说非法非法说法故。五者为求法过而听受故。复有三事没三恶道。何等为三。一谓如来无常永灭。二谓正法无常迁变。三谓僧宝可灭坏故。是故常没三恶道中。第二人者发意欲渡生死大河。断善根故没不能出。所言出者亲近善友则得信心。信心者信施施果。信善善果。信恶恶果。信生死苦无常败坏。是名为信。以得信心修习净戒。受持读诵书写解说。常行惠施善修智慧。以钝根故复遇恶友。不能修习身戒心慧。听受邪法。或值恶时处恶国土断诸善根。断善根故常没生死。如恒河边第二人也。第三人者发意欲渡生死大河。断善根故于中沉没。亲近善友得名为出。信于如来是一切智常恒无变。为众生故说无上道。一切众生悉有佛性。如来非灭法僧亦尔无有灭坏。一阐提等不断其法。终不能得阿耨多罗三藐三菩提。要当远离然后乃得。以信心故修习净戒。修净戒已受持读诵书写解说十二部经。为诸众生广宣流布。乐于惠施修习智慧。以利根故坚住信慧心无退转。如恒河边第三人也。第四人者发意欲渡生死大河。断善根故于中沉没。亲近善友故得信心。是名为出。得信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧。心无退转遍观四方。四方者四沙门果。如恒河边第四人也。第五人者发意欲渡生死大河。断善根故于中沉没。亲近善友故得信心。是名为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧心无退转。无退转已即便前进。前进者谓辟支佛。虽能自渡不及众生。是名为去。如恒河边第五人也。第六人者发意欲渡生死大河。断善根故于中沉没。亲近善友获得信心。得信心故名之为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧。心无退转。无退转已即复前进遂到浅处到浅处已即住不去。住不去者所谓菩萨。为欲度脱诸众生故住观烦恼。如恒河边第六人也。第七人者发意欲渡生死大河。断善根故于中沉没。亲近善友获得信心。得信心已是名为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧心无退转。无退转已即便前进。既前进已得到彼岸登大高山离诸恐怖多受安乐。善男子。彼岸山者喻于如来。受安乐者喻佛常住。大高山者喻大涅槃。善男子。是恒河边如是诸人。悉具手足而不能渡。一切众生亦复如是。实有佛宝法宝僧宝。如来常说诸法要义有八圣道大般涅槃。而诸众生悉不能得。此非我咎。亦非圣道众生等过。当知悉是烦恼过恶。以是义故。一切众生不得涅槃。善男子。譬如良医知病说药病者不服非医咎也。善男子。如有施主以其所有施一切人。有不受者非施主咎。善男子。譬如日出幽冥皆明盲瞽之人不见道路非日过也。善男子。如恒河水能除渴乏渴者不饮非水咎也。善男子。譬如大地普生果实平等无二农夫不种非地过也。善男子。如来普为一切众生。广开分别十二部经。众生不受非如来咎

善男子。若修道者即得阿耨多罗三藐三菩提。善男子。汝言众生悉有佛性。应得阿耨多罗三藐三菩提。如磁石者。善哉善哉。以有佛性因缘力故。得阿耨多罗三藐三菩提。若言不须修圣道者。是义不然。善男子。譬如有人行于旷野渴乏遇井。其井极深虽不见水当知必有。是人方便求觅罐绠汲取则见。佛性亦尔。一切众生虽复有之。要须修习无漏圣道然后得见。善男子。如有胡麻则得见油离诸方便则不得见。甘蔗亦尔。善男子。如三十三天北郁单越。虽是有法。若无善业神通道力。则不能见。地中草根及地下水。以地覆故。众生不见。佛性亦尔。不修圣道故不得见。善男子。如汝所说。世有病人若遇瞻病良医好药随病饮食。及以不遇悉得差者。善男子。我为六住诸菩萨等说如是义。善男子。譬如虚空于诸众生非内非外非内外故亦无挂碍。众生佛性亦复如是。善男子。譬如有人财在异方虽不现前随意受用。有人问之则言我许。何以故以定有故。众生佛性亦复如是。非此非彼以定得故言一切有。善男子。譬如众生造作诸业若善若恶非内非外。如是业性非有非无。亦复非是本无今有。非无因出。非此作此受此作彼受彼作彼受。无作无受时节和合而得果报。众生佛性亦复如是。亦复非是本无今有。非内非外非有非无非此非彼。非余处来非无因缘。亦非一切众生不见。有诸菩萨时节因缘和合得见。时节者所谓十住菩萨摩诃萨。修八圣道于诸众生得平等心。尔时得见不名为作。善男子。汝言如磁石者。是义不然。何以故石不吸铁。所以者何。无心业故。善男子。异法有故异法出生。异法无故异法灭坏。无有作者无有坏者。善男子。犹如猛火不能焚薪火出薪坏名为焚薪。善男子。譬如葵藿随日而转。而是葵藿亦无敬心无识无业。异法性故而自回转。善男子。如芭蕉树因雷增长。是树无耳无心意识。异法有故异法增长。异法无故异法灭坏。善男子。如阿叔迦树女人摩触花为之出。是树无心亦无觉触。异法有故异法出生。异法无故异法灭坏。善男子。如橘得尸果则滋多。而是橘树无心无触。异法有故异法滋多。异法无故异法灭坏。善男子。如安石榴塼骨粪故果实繁茂。安石榴树亦无心触。异法有故异法出生。异法无故异法灭坏。善男子。磁石吸铁亦复如是。异法有故异法出生。异法无故异法灭坏。众生佛性亦复如是。不能吸得阿耨多罗三藐三菩提。善男子。无明不能吸取诸行。行亦不能吸取识也。亦得名为无明缘行行缘于识。有佛无佛法界常住

善男子。若言佛性住众生中者。善男子。常法无住。若有住处即是无常。善男子。如十二因缘无定住处。若有住处十二因缘不得名常。如来法身亦无住处。法界法入法阴虚空悉无住处。佛性亦尔。都无住处。善男子。譬如四大力虽均等有坚有热有湿有动有重有轻有赤有白有黄有黑。而是四大亦无有业。异法界故各不相似。佛性亦尔。异法界故时至则现。善男子。一切众生不退佛性故名之为有。阿毗跋致故。以当有故。决定得故。定当见故。是故名为一切众生悉有佛性

善男子。譬如有王告一大臣汝牵一象以示盲者。尔时大臣受王敕已。多集众盲以象示之。时彼众盲各以手触。大臣即还而白王言。臣已示竟。尔时大王即唤众盲各各问言。汝见象耶。众盲各言。我已得见。王言。象为何类。其触牙者即言象形如莱茯根。其触耳者言象如箕。其触头者言象如石。其触鼻者言象如杵。其触脚者言象如木臼。其触脊者言象如床。其触腹者言象如瓮。其触尾者言象如绳。善男子。如彼众盲不说象体亦非不说。若是众相悉非象者。离是之外更无别象。善男子。王喻如来应正遍知。臣喻方等大涅槃经。象喻佛性。盲喻一切无明众生。是诸众生闻佛说已或作是言。色是佛性。何以故。是色虽灭次第相续。是故获得无上如来三十二相如来色常。如来色者常不断故。是故说色名为佛性。譬如真金质虽迁变色常不异。或时作钏作蛇作盘。然其黄色初无改易。众生佛性亦复如是。质虽无常而色。是常。以是故说色为佛性。或有说言。受是佛性。何以故。受因缘故获得如来真实之乐。如来受者谓毕竟受第一义受。众生受性虽复无常。然其次第相续不断。是故获得如来常受。譬如有人姓憍尸迦。人虽无常而姓是常经千万世无有改易。众生佛性亦复如是。以是故说受为佛性。又有说言。想是佛性。何以故。想因缘故获得如来真实之想。如来想者名无想想。无想想者非众生想非男女想。亦非色受想行识想非想断想。众生之想虽复无常。以想次第相续不断故。得如来常恒之想。善男子。譬如众生十二因缘众生虽灭而因缘常。众生佛性亦复如是。以是故说想为佛性。又有说言。行为佛性。何以故行名寿命寿因缘故获得如来常住寿命。众生寿命虽复无常。而寿次第相续不断。故得如来真实常寿。善男子。譬如十二部经听者说者虽复无常而是经典常存不变。众生佛性亦复如是。以是故说行为佛性。又有说言。识为佛性。识因缘故获得如来平等之心。众生意识虽复无常。而识次第相续不断故。得如来真实常心。如火热性火虽无常热非无常。众生佛性亦复如是。以是故说识为佛性。又有说言。离阴有我我是佛性。何以故。我因缘故获得如来八自在我。有诸外道说言。去来见闻悲喜语说为我。如是我相虽复无常。而如来我真实是常。善男子。如阴入界虽复无常而名是常。众生佛性亦复如是。善男子。如彼盲人各各说象虽不得实非不说象。说佛性者亦复如是。非即六法不离六法。善男子。是故我说众生佛性非色不离色乃至非我不离我。善男子。有诸外道。虽说有我而实无我。众生我者即是五阴离阴之外更无别我。善男子。譬如茎叶须台合为莲花离是之外更无别花。众生我者亦复如是。善男子。譬如墙壁草木和合名之为舍离是之外更无别舍。如佉陀罗树波罗奢树尼拘陀树郁昙钵树和合为林离是之外更无别林。譬如车兵象马步兵和合为军离是之外更无别军。譬如五色杂綖和合名之为绮离是之外更无别绮。如四姓和合名为大众离是之外更无别众。众生我者亦复如是。离五阴外更无别我。善男子。如来常住则名为我。如来法身无边无碍不生不灭得八自在。是名为我。众生真实无如是我及以我所。但以必定当得毕竟第一义空。故名佛性

善男子。大慈大悲名为佛性。何以故。大慈大悲常随菩萨如影随形。一切众生必定当得大慈大悲。是故说言一切众生悉有佛性。大慈大悲者名为佛性。佛性者名为如来。大喜大舍名为佛性。何以故。菩萨摩诃萨若不能舍二十五有。则不能得阿耨多罗三藐三菩提。以诸众生必当得故。是故说言一切众生悉有佛性。大喜大舍者即是佛性。佛性者即是如来。佛性者名大信心。何以故。以信心故菩萨摩诃萨则能具足檀波罗蜜乃至般若波罗蜜。一切众生必定当得大信心故。是故说言一切众生悉有佛性。大信心者即是佛性。佛性者即是如来。佛性者名一子地。何以故。以一子地因缘故。菩萨则于一切众生得平等心。一切众生必定当得一子地故。是故说言一切众生悉有佛性。一子地者即是佛性。佛性者即是如来。佛性者名第四力。何以故。以第四力因缘故。菩萨则能教化众生。一切众生必定当得第四力故。是故说言一切众生悉有佛性。第四力者即是佛性。佛性者即是如来。佛性者名十二因缘。何以故。以因缘故如来常住。一切众生定有如是十二因缘。是故说言一切众生悉有佛性。十二因缘即是佛性。佛性者即是如来。佛性者名四无碍智。以四无碍因缘故说字义无碍。字义无碍故能化众生。四无碍者即是佛性。佛性者即是如来。佛性者名顶三昧。以修如是顶三昧故。则能总摄一切佛法。是故说言顶三昧者名为佛性。十住菩萨修是三昧未得具足。虽见佛性而不明了。一切众生必定得故。是故说言一切众生悉有佛性。善男子。如上所说。种种诸法一切众生定当得故。是故说言一切众生悉有佛性。善男子。我若说色是佛性者。众生闻已则生邪倒。以邪倒故命终则生阿鼻地狱。如来说法为断地狱。是故不说色是佛性。乃至说识亦复如是

善男子。若诸众生了佛性者则不须修道。十住菩萨修八圣道少见佛性。况不修者而得见耶。善男子。如文殊师利诸菩萨等。已无量世修习圣道了知佛性。云何声闻辟支佛等能知佛性。若诸众生欲得了了知佛性者。应当一心受持读诵书写解说供养恭敬尊重赞叹是涅槃经。见有受持乃至赞叹如是经者。应当以好房舍衣服饮食卧具病瘦医药而供给之。兼复赞叹礼拜问讯。善男子。若有已于过去无量无边世中亲近供养无量诸佛深种善根。然后乃得闻是经名。善男子。佛性不可思议。佛法僧宝亦不可思议。一切众生悉有佛性而不能知。是亦不可思议。如来常乐我净之法亦不可思议。一切众生能信如是大涅槃经。亦不可思议

师子吼菩萨言。世尊。如佛所说。一切众生能信如是大涅槃经不可思议者。世尊。是大众中有八万五千亿人。于是经中不生信心。是故有能信是经者。名不可思议。善男子。如是诸人于未来世。亦当定得信是经典。见于佛性得阿耨多罗三藐三菩提师子吼言。世尊。云何不退菩萨。自知决定有不退心。佛言。善男子。菩萨摩诃萨当以苦行自试其心。日食一胡麻经一七日。粳米菉豆麻子粟[序-予+禾]及以白豆。亦复如是。各一七日食一麻时作是思惟。如是苦行都无利益。无利益事尚能为之。况有利益而当不作。于无利益心能堪忍不退不转。是故定得阿耨多罗三藐三菩提。如是等日修苦行时。一切皮肉消瘦皱减。如断生瓠置之日中。其目却陷如井底星。肉尽肋出如朽草屋。脊骨连现如重线塼。所坐之处如马蹄迹。欲坐则伏欲起则偃。虽受如是无利益苦。然不退于菩提之心。复次善男子。菩萨摩诃萨为破众苦施安乐故。乃至能舍内外财物及其身命如弃刍草。若能不惜是身命者。如是菩萨自知必定有不退心。我定当得阿耨多罗三藐三菩提。复次菩萨为法因缘。剜身为灯[疊*毛]缠皮肉苏油灌之烧以为炷。菩萨尔时受是大苦。自呵其心而作是言。如是苦者。于地狱苦百千万分犹未及一。汝于无量百千劫中。受大苦恼都无利益。汝若不能受是轻苦。云何而能于地狱中救苦众生。菩萨摩诃萨作是观时身不觉苦。其心不退不动不转。菩萨尔时应深自知。我定当得阿耨多罗三藐三菩提。善男子。菩萨尔时具足烦恼未有断者。为法因缘能以头目髓脑手足血肉施人。以钉钉身投岩赴火。菩萨尔时虽受如是无量众苦。若心不退不动不转。菩萨当知我今定有不退之心。当得阿耨多罗三藐三菩提。善男子。菩萨摩诃萨为破一切众生苦恼。愿作粗大畜生之身。以身血肉施于众生。众生取时复生怜愍。菩萨尔时闭气不喘示作死相。令彼取者。不生杀害疑网之想。菩萨虽受畜生之身。终不造作畜生之业。何以故。善男子。菩萨既得不退心已。终不造作三恶道业。菩萨摩诃萨若未来世。有微尘等恶业果报不定受者。以大愿力为众生故而悉受之。譬如病人为鬼所著藏隐身中。以咒力故即时相现。或语或喜或嗔或骂或啼或哭。菩萨摩诃萨未来之世三恶道业亦复如是。菩萨摩诃萨受熊身时。常为众生演说正法。或受迦宾阇罗鸟身。为诸众生说正法故。受瞿陀身鹿身兔身象身羖羊狝猴白鸽金翅鸟龙蛇之身。受如是等畜生身时。终不造作畜生恶业。常为其余畜生众生演说正法。令彼闻法速得转离畜生身故。菩萨尔时虽受畜身不作恶业。当知必定有不退心。菩萨摩诃萨于饥馑世见饿众生。作龟鱼身无量由旬。复作是愿。愿诸众生取我肉时随取随生。因食我肉离饥渴苦。一切悉发阿耨多罗三藐三菩提心。菩萨发愿。若有因我离饥渴者。未来之世速得远离二十五有饥渴之患。菩萨摩诃萨受如是苦心不退者。当知必定得阿耨多罗三藐三菩提。复次菩萨于疾疫世见病苦者。作是思惟。如药树王若有病者。取根取茎取枝取叶取花取果取皮取肤悉得愈病。愿我此身亦复如是。若有病者闻声触身。服食血肉乃至骨髓病悉除愈。愿诸众生食我肉时。不生恶心如食子肉。我治病已常为说法。愿彼信受思惟转教。复次善男子。菩萨具足烦恼虽受身苦。其心不退不动不转。当知必定得不退心成阿耨多罗三藐三菩提。复次善男子。若有众生为鬼所病。菩萨见已即作是言。愿作鬼身大身健身多眷属身。使彼闻见病得除愈。菩萨摩诃萨为众生故勤修苦行。虽有烦恼不污其心。复次善男子。菩萨摩诃萨虽复修行六波罗蜜。亦复不求六度之果。修行无上六波罗蜜时。作是愿言。我今以此六波罗蜜施一一众生。一一众生受我施已。悉令得成阿耨多罗三藐三菩提。我亦自为六波罗蜜。勤修苦行受诸苦恼。当受苦时愿我不退菩提之心。善男子。菩萨摩诃萨作是愿时。是名不退菩提之相

复次善男子。菩萨摩诃萨不可思议。何以故。菩萨摩诃萨深知生死多诸罪过。观大涅槃有大功德。为诸众生处在生死受种种苦心无退转。是名菩萨不可思议。复次善男子。菩萨摩诃萨无有因缘而生怜愍。实不受恩而常施恩。虽施于恩而不求报。是故复名不可思议。复次善男子。或有众生。为自利益修诸苦行。菩萨摩诃萨为利他故修行苦行。是名自利。是故复名不可思议。复次菩萨具足烦恼。为坏怨亲所受诸苦修平等心。是故复名不可思议。复次菩萨若见诸恶不善众生。若呵责若软语若驱摈若纵舍。有恶性者现为软语。有憍慢者现为大慢。而其内心实无憍慢。是名菩萨方便不可思议。复次菩萨具足烦恼。少财物时来求者多。心不迮小。是名菩萨不可思议。复次菩萨于佛出时知佛功德。为众生故于无佛处受边地身。如盲如聋如跛如癖。是名菩萨不可思议。复次菩萨深知众生所有罪过。为度脱故常与共行。虽随其意罪垢不污。是故复名不可思议

复次菩萨了了知见。无众生相无烦恼污。无修习道离烦恼者。虽为菩提无菩提行。亦无成就菩提行者。无有受苦及破苦者。而亦能为众生坏苦行菩提行。是故复名不可思议。复次菩萨受后边身处兜率天。是亦名为不可思议。何以故。兜率陀天欲界中胜。在下天者其心放逸。在上天者诸根闇钝。是故名胜。修施修戒得上下身。修施戒定得兜率身。一切菩萨毁呰诸有破坏诸有。终不造作兜率天业受彼天身。何以故。菩萨若处其余诸有。亦能教化成就众生。实无欲心而生欲界。是故复名不可思议。菩萨摩诃萨生兜率天。有三事胜。一者命。二者色。三者名。菩萨摩诃萨实不求于命色名称。虽无求心而所得胜。菩萨摩诃萨深乐涅槃然有因亦胜。是故复名不可思议。菩萨摩诃萨如是三事虽胜诸天。而诸天等于菩萨所。终不生于嗔心妒心憍慢之心。常生喜心。菩萨于天亦不憍慢。是故复名不可思议。菩萨摩诃萨不造命业。而于彼天毕竟寿命。是名命胜。亦无色业而妙色身光明遍满。是名色胜。菩萨摩诃萨处彼天宫不乐五欲唯为法事。是故名称充满十方。是名名胜。是故复名不可思议。菩萨摩诃萨下兜率天。是时大地六种震动。是故复名不可思议。何以故。菩萨下时欲色诸天悉来侍送。发大音声赞叹菩萨。以口风气故令地动。复有菩萨人中象王。人中象王名为龙王。龙王初入胎时。有诸龙王在此地下或怖或寤。是故大地六种震动。是故复名不可思议。菩萨摩诃萨知入胎时住时出时。知父知母不净不污。如帝释发青色宝珠。是故复名不可思议。善男子。大涅槃经亦复如是不可思议。善男子。譬如大海有八不思议。何等为八。一者渐渐转深。二者深难得底。三者同一碱味。四者潮不过限。五者有种种宝藏。六者大身众生在中居住。七者不宿死尸。八者一切万流。大雨投之不增不减。善男子。渐渐转深有三事。何等为三。一众生福力。二者顺风而行。三者河水入故。乃至不增不减亦各有三。是大涅槃微妙经典亦复如是。有八不可思议。一渐渐深。所谓五戒十戒二百五十戒菩萨戒。须陀洹果斯陀含果阿那含果阿罗汉果。辟支佛果。菩萨果。阿耨多罗三藐三菩提果。是涅槃经说是等法。是名渐渐深。是故此经名渐渐深。二者深难得底。如来世尊不生不灭。不得阿耨多罗三藐三菩提。不转法轮。不食不受不行惠施。是故名为常乐我净。一切众生悉有佛性。佛性非色不离于色。非受想行识乃至不离于识。是常可见了因非作因。须陀洹乃至辟支佛。当得阿耨多罗三藐三菩提。亦无烦恼亦无住处。虽无烦恼不名为常是故名深。复有甚深于是经中。或时说我或说无我。或时说常或说无常。或时说净或说不净。或时说乐或时说苦。或时说空或说不空。或说一切有或说一切无或说三乘或说一乘。或说五阴即是佛性。金刚三昧及以中道。首楞严三昧十二因缘第一义空。慈悲平等于诸众生。顶智信心知诸根力。一切法中无挂碍智。虽有佛性不说决定。是故名深。三者一味。一切众生同有佛性。皆同一乘同一解脱。一因一果同一甘露。一切当得常乐我净。是名一味。四者潮不过限。如是经中制诸比丘。不得受畜八不净物。若我弟子。有能受持读诵书写解说分别是大涅槃微妙经典。宁失身命终不犯之。是名潮不过限。五有种种宝藏。是经即是无量宝藏。所言宝者。谓四念处四正勤四如意分五根五力七觉分八圣道分。婴儿行圣行梵行天行。诸善方便众生佛性。菩萨功德如来功德声闻功德缘觉功德。六波罗蜜无量三昧无量智慧。是名宝藏。六者大身众生所居住处。大身众生者谓佛菩萨。大智慧故名大众生。大身故。大心故。大庄严故。大调伏故。大方便故。大说法故。大势力故。大徒众故。大神通故。大慈悲故。常不变故。一切众生无挂碍故。容受一切诸众生故。是名大身众生所居之处。七者不宿死尸。死尸者。谓一阐提犯四重禁五无间罪。诽谤方等。非法说法法说非法。受畜八种不净之物。佛物僧物随意而用。或于比丘比丘尼所作非法事。是名死尸。是涅槃经离如是等。是故名为不宿死尸。八者不增不减。无边际故无始终故。非色故非作故。常住故不生灭故。一切众生悉平等故。一切法性同一性故。是名无增减。是故此经如彼大海有八不思议

师子吼言。世尊。若言如来不生不灭名为深者。一切众生有四种生。卵生胎生湿生化生。是四种生人中具有。如施婆罗比丘优婆施婆罗比丘弥迦罗长者母尼拘陀长者母半阇罗长者母。各五百子同于卵生。当知人中则有卵生。湿生者如佛所说。我于往昔作菩萨时。作顶生王及手生王。如今所说庵罗树女迦不多树女当知人中则有湿生。劫初之时一切众生皆悉化生。如来世尊得八自在。何因缘故不化生耶。佛言。善男子。一切众生四生所生。得圣法已。不得如本卵生湿生。善男子。劫初众生皆悉化生。当尔之时佛不出世。善男子。若有众生遇病苦时须医须药。劫初之时众生化生。虽有烦恼其病未发。是故如来不出其世。劫初众生身心非器。是故如来不出其世。善男子。如来世尊所有事业胜诸众生。所谓种姓眷属父母。以殊胜故凡所说法人皆信受。是故如来不受化生。善男子。一切众生父作子业子作父业。如来世尊若受化身则无父母。若无父母。云何能令一切众生作诸善业。是故如来不受化身。善男子。佛正法中有二种护。一者内。二者外。内护者所谓禁戒。外护者族亲眷属。若佛如来受化身者则无外护。是故如来不受化身。善男子。有人恃姓而生憍慢。如来为破如是慢故。生在贵姓不受化身。善男子。如来世尊有真父母。父名净饭母名摩耶。而诸众生犹言是幻。云何当受化生之身。若受化身。云何得有碎身舍利。如来为益众生福德故碎其身而令供养。是故如来不受化身。一切诸佛悉无化生。云何独令我受化身

尔时师子吼菩萨。合掌长跪右膝着地。以偈赞佛

  如来无量功德聚　　我今不能广宣说
  今为众生演一分　　唯愿哀愍听我说
  众生无明闇中行　　具受无边百种苦
  世尊能令远离之　　是故世称为大悲
  众生往返生死绳　　放逸迷荒无安乐
  如来能施众安乐　　是故永断生死绳
  佛能施众安乐故　　自于己乐不贪乐
  为诸众生修苦行　　是故世间兴供养
  见他受苦身战动　　处在地狱不觉痛
  为诸众生受大苦　　是故无胜无有量
  如来为众修苦行　　成就具足满六度
  心处邪风不倾动　　是故能胜世大士
  众生常欲得安乐　　而不知修安乐因
  如来能教令修习　　犹如慈父爱一子
  佛见众生烦恼患　　心苦如母念病子
  常思离病诸方便　　是故此身系属他
  一切众生行诸苦　　其心颠倒以为乐
  如来演说真苦乐　　是故称号为大悲
  世间皆处无明[穀-禾+卵]　　无有智嘴能破之
  如来智嘴能啄坏　　是故名为最大子
  不为三世所摄持　　无有名字及假号
  觉知涅槃甚深义　　是故称佛为大觉
  有河洄澓没众生　　无明所盲不知出
  如来自渡能渡彼　　是故称佛大船师
  能知一切诸因果　　亦复通达尽灭道
  常施众生病苦药　　是故世称大医王
  外道邪见说苦行　　因是能得无上乐
  如来演说真乐行　　能令众生受快乐
  如来世尊破邪道　　开示众生正真路
  行是道者得安乐　　是故称佛为导师
  非自非他之所作　　亦非共作无因作
  如来所说苦受事　　胜于一切诸外道
  成就具足戒定慧　　亦以此法教众生
  以法施时无妒吝　　是故称佛无缘悲
  无所造作无因缘　　获得无因无果报
  是故一切诸智者　　称说如来不求报
  常共世间放逸行　　而身不为放逸污
  是故名为不思议　　世间八法不能污
  如来世尊无怨亲　　是故其心常平等
  我师子吼赞大悲　　能吼无量师子吼

大般涅槃经卷第三十大般涅槃经卷第三十一

        宋代沙门慧严等依泥洹经加之

    迦叶菩萨品第二十四之一

迦叶菩萨白佛言。世尊。如来怜愍一切众生。不调能调不净能净。无归依者能作归依。未解脱者能令解脱得八自在。为大医师作大药王。善星比丘是佛菩萨时子。出家之后受持读诵分别解说十二部经。坏欲界结获得四禅。云何如来记说善星。是一阐提厮下之人地狱劫住不可治人。如来何故不先为其演说正法后为菩萨。如来世尊若不能救善星比丘。云何得名有大慈愍有大方便。佛言。善男子。譬如父母唯有三子。其一子者有信顺心恭敬父母。利根智慧于世间事能速了知。其第二子不敬父母无信顺心。利根智慧于世间事能速了知。其第三子不敬父母无信顺心钝根无智。父母若欲教告之时。应先教谁先亲爱谁。当先教谁知世间事。迦叶菩萨白佛言。世尊。应先教授有信顺心恭敬父母。利根智慧知世事者。其次第二乃及第三。而彼二子虽无信顺恭敬之心。为慈念故次复教之。善男子。如来亦尔。其三子者初喻菩萨。中喻声闻。后喻一阐提。如十二部经修多罗中微细之义。我先已为诸菩萨说。浅近之义为声闻说。世间之义为一阐提五逆罪说。现在世中虽无利益。以怜愍故为生后世诸善种子。善男子如三种田。一者渠流便易。无诸沙卤瓦石棘刺。种一得百。二者虽无沙卤瓦石棘刺渠流险难。收实减半。三者渠流险难多有沙卤瓦石棘刺。种一得一为槀草故。善男子。农夫春月先种何田。世尊。先种初田。次第二田。后及第三。初喻菩萨。次喻声闻。后喻一阐提。善男子。譬如三器。一者完。二者漏。三者破。若欲盛置乳酪酥水。先用何者。世尊。应用完者次用漏者后及破者。其完净者喻菩萨僧。漏喻声闻。破喻一阐提。善男子。如三病人俱至医所。一者易治。二者难治。三不可治。善男子。医若治者当先治谁。世尊。应先治易次及第二后及第三。何以故。为亲属故。其易治者喻菩萨僧。其难治者喻声闻僧。不可治者喻一阐提。现在世中虽无善果。以怜愍故。为种后世诸善种子故。善男子。譬如大王有三种马。一者调壮大力。二者不调齿壮大力。三者不调羸老无力。王若乘御当先何者。世尊。应当先乘调壮大力。次乘第二后及第三。善男子。调壮大力喻菩萨僧。其第二者喻声闻僧。其第三者喻一阐提。现在世中虽无利益。以怜愍故为种后世诸善种子故。善男子。如大施时有三人来。一者贵族聪明持戒。二者中姓钝根持戒。三者下姓钝根毁戒。善男子。是大施主应先施谁。世尊。应先贵姓利根持戒次及第二后及第三。第一喻菩萨僧。第二喻声闻僧。第三喻一阐提。善男子。如大师子杀香象时皆尽其力。杀兔亦尔。不生轻想。诸佛如来亦复如是。为诸菩萨及一阐提。演说法时功用无二

善男子。我于一时住王舍城。善星比丘为我给使我于初夜为天帝释演说法要。弟子之法应后师眠。尔时善星以我久坐心生恶念。时王舍城小男小女若啼不止父母则语。汝若不止当将汝付薄拘罗鬼。尔时善星反被拘执而语我言。速入禅室薄拘罗来。我言。痴人。汝常不闻如来世尊无所畏耶。尔时帝释即语我言。世尊。如是人等亦复得入佛法中耶。我即语言。憍尸迦。如是人者得入佛法。亦有佛性当得阿耨多罗三藐三菩提。我虽为是善星说法。而彼都无信受之心。善男子。我于一时在迦尸国尸婆富罗城。善星比丘为我给使。我时欲入彼城乞食无量众生虚心渴仰欲见我迹。善星比丘寻随我后而毁灭之。既不能灭而令众生生不善心。我入城已。于酒家舍见一尼干踡脊蹲地餐食酒糟。善星比丘见已而言。世尊。世间若有阿罗汉者是人最胜。何以故。是人所说无因无果。我言。痴人。汝常不闻阿罗汉者不饮酒不害人不欺诳不盗不淫。如是之人杀害父母食啖酒糟。云何而言是阿罗汉。是人舍身必定当堕阿鼻地狱。阿罗汉者永断三恶。云何而言是阿罗汉。善星即言。四大之性犹可转易。欲令是人必堕阿鼻无有是处。我言。痴人。汝常不闻诸佛如来诚言无二。我虽为是善星说法。而彼绝无信受之心。善男子。我于一时与善星比丘住王舍城。尔时城中有一尼干名曰苦得。常作是言。众生烦恼无因无缘。众生解脱亦无因缘。善星比丘复作是言。世尊。世间若有阿罗汉者苦得为上。我言。痴人。苦得尼干实非罗汉。不能解了阿罗汉道。善星复言。何故罗汉于阿罗汉而生嫉妒。我言。痴人。我于罗汉不生嫉妒而汝自生恶邪见耳。若言苦得是罗汉者。却后七日当患宿食腹痛而死。死已生于食吐鬼中。其同学辈当[臼/丌]其尸置寒林中。尔时善星即往苦得尼干子所语言。长老。汝今知不。沙门瞿昙记汝七日当患宿食腹痛而死。死已生于食吐鬼中。同学同师当舁汝尸置寒林中。长老。好善思惟作诸方便。当令瞿昙堕妄语中。尔时苦得闻是语已即便断食。从初一日乃至六日。满七日已便食黑蜜。食黑蜜已复饮冷水。饮冷水已腹痛而终。终已同学舁其尸丧置寒林中。即受食吐饿鬼之形在其尸边。善星比丘闻是事已至寒林中。见苦得身受食吐形在其尸边踡脊蹲地。善星语言。大德死耶。苦得答言。我已死矣。云何死耶。答言。因腹痛死。谁出汝尸。答言。同学出置何处。答言。痴人。汝今不识是寒林耶。得何等身。答言。我得食吐鬼身。善星谛听如来善语真语时语义语法语。善星。如来口出如是实语。汝于尔时云何不信。若有众生不信如来真实语者。彼亦当受如我此身。尔时善星即还我所。作如是言。世尊。苦得尼乾命终之后生三十三天。我言。痴人。阿罗汉者无有生处。云何而言苦得生于三十三天。世尊。实如所言。苦得尼干实不生于三十三天。今受食吐饿鬼之身。我言。痴人。诸佛如来诚言无二。若言如来有二言者。无有是处。善星即言。如来尔时虽作是说。我于是事都不生信。善男子。我亦常为善星比丘说真实法。而彼绝无信受之心。善男子。善星比丘虽复读诵十二部经获得四禅。乃至不解一偈一句一字之义。亲近恶友退失四禅。失四禅已生恶邪见。作如是说。无佛无法无有涅槃。沙门瞿昙善知相法。是故能得知他人心。我于尔时告善星言。我所说法初中后善。其言巧妙字义真正所说无杂。具足成就清净梵行。善星比丘复作是言。如来虽复为我说法。而我真实谓无因果。善男子。汝若不信如是事者。善星比丘今者近在尼连禅河可共往问。尔时如来即与迦叶往善星所。善星比丘遥见佛来。见已即生恶邪之心。以恶心故生身陷入堕阿鼻狱

善男子。善星比丘虽入佛法无量宝聚空无所获。乃至不得一法之利。以放逸故恶知识故。譬如有人虽入大海多见众宝而无所得。以放逸故。又如入海虽见宝聚自戮而死。或为罗刹恶鬼所杀。善星比丘亦复如是。入佛法已为恶知识罗刹大鬼之所杀害。善男子。是故如来以怜愍故。常说善星多诸放逸。善男子。若本贫穷于是人所虽生怜愍其心则薄。若本巨富后失财物。于是人所生于怜愍其心则厚。善星比丘亦复如是。受持读诵十二部经获得四禅。然后退失甚可怜愍。是故我说善星比丘多诸放逸。多放逸故断诸善根。我诸弟子有见闻者。于是人所无不生于重怜愍心。如初巨富后失财者。我于多年。常与善星共相随逐。而彼自生恶邪之心。以恶邪故不舍恶见。善男子。我从昔来见是善星。若有善根如毛发许。终不记彼断绝善根。是一阐提厮下之人地狱劫住。以其宣说无因无果无有作业。尔乃记彼永断善根。是一阐提厮下之人地狱劫住。善男子。譬如有人没圊厕中。有善知识以手[打-丁+毛]之。若得头发便欲拔出。久求不得尔乃息意。我亦如是。求觅善星微少善根便欲拔济。终日求之乃至不得如毛发许。是故不得拔其地狱

迦叶菩萨言。世尊。如来何故记彼当堕阿鼻地狱。善男子。善星比丘多有眷属。皆谓善星是阿罗汉是得道果。我欲坏彼恶邪心故。记彼善星以放逸故堕于地狱。善男子。汝今当知。如来所说真实无二。何以故。若佛所记当堕地狱。若不堕者无有是处。声闻缘觉所记莂者。则有二种。或虚或实。如目揵连在摩伽陀国遍告诸人。却后七日天当降雨。时竟不雨。复记牸牛当生白犊。及其产时乃产驳犊。记生男者后乃产女。善男子。善星比丘常为无量诸众生等。宣说一切。无善恶果。尔时永断一切善根。乃至无有如毛发许。善男子。我久知是善星比丘当断善根。犹故共住满二十年畜养共行。我若远弃不近左右。是人当教无量众生造作恶业。是名如来第五解力

世尊。一阐提辈以何因缘无有善法。善男子。一阐提辈断善根故。众生悉有信等五根。而一阐提辈永断灭故。以是义故。杀害蚁子犹得杀罪。杀一阐提无有杀罪。世尊。一阐提者终无善法。是故名为一阐提耶。佛言。如是如是。世尊。一切众生有三种善。所谓过去未来现在。一阐提辈亦不能断未来善法。云何说言断诸善法名一阐提耶。善男子。断有二种。一者现在灭。二者现在障于未来。一阐提辈具是二断。是故我言断诸善根。善男子。譬如有人没圊厕中唯有一发毛头未没。虽复一发毛头未没。而一毛头不能胜身。一阐提辈亦复如是。虽未来世当有善根而不能救地狱之苦未来之世虽可救拔。现在之世无如之何。是故名为不可救济。以佛性因缘则可得救。佛性者非过去非未来非现在。是故佛性不可得断。如朽败子不能生牙。一阐提辈亦复如是。世尊。一阐提辈不断佛性佛性亦善。云何说言断一切善。善男子。若诸众生现在世中有佛性者。则不得名一阐提也。如世间中众生我性。佛性是常三世不摄。三世若摄名为无常。佛性未来以当见故。故言众生悉有佛性。以是义故。十住菩萨具足庄严乃得少见。迦叶菩萨言。世尊。佛性者常犹如虚空。何故如来说言未来。如来若言一阐提辈无善法者。一阐提辈于其同学同师父母亲族妻子。岂当不生爱念心耶。如其生者非是善乎。佛言。善哉善哉。善男子。快发斯问。佛性者犹如虚空。非过去非未来非现在。一切众生有三种身。所谓过去未来现在。众生未来具足庄严清净之身得见佛性。是故我言佛性未来。善男子。我为众生或时说因为果。或时说果为因。是故经中。说命为食见色为触。未来身净故说佛性。世尊。如佛所说义如是者。何故说言一切众生悉有佛性。善男子。众生佛性虽现在无不可言无。如虚空性虽无现在不得言无。一切众生虽复无常。而是佛性常住无变。是故我于此经中说。众生佛性非内非外犹如虚空非内非外。如其虚空有内外者。虚空不名为一为常。亦不得言一切处有。虚空虽复非内非外。而诸众生悉皆有之。众生佛性亦复如是。如汝所言。一阐提辈有善法者。是义不然。何以故。一阐提辈若有身业口业意业取业求业施业解业。如是等业悉是邪业。何以故。不求因果故。善男子如呵梨勒果根茎枝叶花实悉苦。一阐提业亦复如是

善男子。如来具足知诸根力。是故善能分别众生上中下根。能知是人转下作中。能知是人转中作上。能知是人转上作中。能知是人转中作下。是故当知。众生根性无有决定。以无定故或断善根断已还生。若诸众生根性定者。终不先断断已复生。亦不应说一阐提辈堕于地狱寿命一劫。善男子。是故如来说一切法无有定相

迦叶菩萨白佛言。世尊。如来具足知诸根力。定知善星当断善根。以何因缘听其出家。佛言。善男子。我于往昔初出家时。吾弟难陀。从弟阿难。调婆达多。子罗睺罗。如是等辈皆悉随我出家修道。我若不听善星出家。其人次当得绍王位。其力自在当坏佛法。以是因缘我便听其出家修道。善男子。善星比丘若不出家。亦断善根于无量世都无利益。今出家已。虽断善根能受持戒。供养恭敬耆旧长宿有德之人。修习初禅乃至四禅。是名善因。如是善因能生善法。善法既生能修习道。既修习道当得阿耨多罗三藐三菩提。是故我听善星出家。善男子。若我不听善星比丘出家受戒。则不得称我为如来具足十力。善男子。佛观众生具足善法及不善法。是人虽具如是二法。不久能断一切善根具不善根。何以故。如是众生不亲善友。不听正法不善思惟不如法行。以是因缘能断善根具不善根。善男子。如来复知是人现世若未来世少壮老时。当近善友听受正法苦集灭道。尔时则能还生善根。善男子。譬如有泉去村不远其水甘美具八功德。有人热渴欲往泉所。边有智者。观是渴人必定无疑当至水所。何以故。无异路故。如来世尊观诸众生亦复如是。是故如来名为具足知诸根力

尔时世尊取地少土置之爪上。告迦叶言。是土多耶。十方世界地土多乎。迦叶菩萨白佛言。世尊。爪上土者不比十方所有土也。善男子。有人舍身还得人身。舍三恶身得受人身。诸根完具生于中国。具足正信能修习道。修习道已能得解脱。得解脱已能入涅槃。如爪上土。舍人身已得三恶身。舍三恶身得三恶身。诸根不具生于边地。信邪倒见修习邪见。不得解脱常乐涅槃。如十方界所有地土。善男子。护持禁戒。精勤不懈不犯四重。不作五逆。不用僧鬘物。不作一阐提不断善根。信如是等涅槃经典。如爪上土。毁戒懈怠。犯四重禁。作五逆罪。用僧鬘物。作一阐提断诸善根。不信是经。如十方界所有地土。善男子。如来善知众生如是上中下根。是故称佛具知根力

迦叶菩萨白佛言。世尊。如来具足是知根力。是故能知一切众生上中下根利钝差别。知现在世众生诸根。亦知未来众生诸根。如是众生于佛灭后作如是说。如来毕竟入于涅槃。或不毕竟入于涅槃。或说有我或说无我。或有中阴或无中阴。或说有退或说无退。或言如来身是有为。或言如来身是无为。或有说言十二因缘是有为法。或说因缘是无为法。或说心是有常。或说心是无常。或有说言。受五欲乐能障圣道。或说不遮。或说世第一法唯是欲界。或说三界。或说布施唯是意业。或有说言即是五阴。或有说言有三无为。或有说言无三无为。复有说言或有造色。复有说言或无造色。或有说言有无作色。或有说言无无作色。或有说言有心数法。或有说言无心数法。或有说言有五种有。或有说言有六种有。或有说言八戒斋法优婆塞戒具足受得。或有说言不具受得。或说比丘犯四重已比丘戒在。或说不在。或有说言须陀洹人斯陀含人阿那含人阿罗汉人皆得佛道。或言不得。或说佛性即众生有。或说佛性离众生有。或有说言犯四重禁作五逆罪一阐提等皆有佛性。或说言无。或有说言有十方佛。或有说言无十方佛。如其如来具足成就知根力者。何故今日不决定说

佛告迦叶菩萨。善男子。如是之义非眼识知。乃至非意识知。乃是智慧之所能知。若有智者。我于是人终不作二。是亦谓我不作二说。于无智者作不定说。而是无智亦复谓我作不定说。善男子。如来所有一切善行悉为调伏诸众生故。譬如医王所有医方悉为疗治一切病苦。善男子。如来世尊为国土故为时节故为他语故为人故为众根故。于一法中作二种说。于一名法说无量名。于一义中说无量名。于无量义说无量名。云何一名说无量名犹如涅槃。亦名涅槃亦名无生。亦名无出亦名无作。亦名无为亦名归依。亦名窟宅亦名解脱。亦名光明亦名灯明。亦名彼岸亦名无畏。亦名无退亦名安处。亦名寂静亦名无相。亦名无二亦名一行。亦名清凉亦名无闇。亦名无碍亦名无诤。亦名无浊亦名广大。亦名甘露亦名吉祥。是名一名作无量名。云何一义说无量名。犹如帝释。亦名帝释亦名憍尸迦。亦名婆蹉婆亦名富兰陀罗。亦名摩佉婆亦名因陀罗。亦名千眼亦名舍脂夫。亦名金刚亦名宝顶亦名宝幢。是名一义说无量名。云何于无量义说无量名。如佛如来。名为如来。义异名异。亦名阿罗呵。义异名异亦名三藐三佛陀。义异名异亦名船师亦名导师。亦名正觉亦名明行足。亦名大师子王。亦名沙门亦名婆罗门。亦名寂静亦名施主。亦名到彼岸亦名大医王。亦名大象王亦名大龙王。亦名施眼亦名大力士。亦名大无畏。亦名宝聚。亦名商主亦名得脱。亦名大丈夫亦名天人师。亦名大分陀利亦名独无等侣。亦名大福田亦名大智慧海。亦名无相亦名具足八智。如是一切义异名异。善男子。是名无量义中说无量名。复有一义说无量名。所谓如阴。亦名为荫亦名颠倒。亦名为谛亦名四念处。亦名四食亦名四识住处。亦名为有亦名为道。亦名为时亦名众生。亦名为世亦名第一义。亦名三修谓身戒心。亦名因果亦名烦恼。亦名解脱亦名十二因缘。亦名声闻辟支佛。亦名地狱饿鬼畜生人天。亦名过去现在未来。是名一义说无量名。善男子。如来世尊为众生故广中说略略中说广。第一义谛说为世谛。说世谛法为第一义谛。云何名为广中说略如告比丘。我今宣说十二因缘。云何名为十二因缘。所谓因果。云何名为略中说广。如告比丘。我今宣说苦集灭道。苦者所谓无量诸苦。集者所谓无量烦恼。灭者所谓无量解脱。道者所谓无量方便。云何名为第一义谛说为世谛。如告比丘。吾今此身有老病死。云何名为世谛说为第一义谛。如告憍陈如。汝得法故名阿若憍陈如。是故随人随意随时。故名如来知诸根力。善男子。我若当于如是等义作定说者。则不得称我为如来具知根力。善男子。有智之人当知香象所负非驴所胜。一切众生所行无量。是故如来种种为说无量之法。何以故。众生多有诸烦恼故。若使如来说于一行。不名如来具足成就知诸根力。是故我于余经中说。五种众生不应还为说五种法。为不信者不赞正信。为毁禁者不赞持戒。为悭贪者。不赞布施。为懈怠者不赞多闻。为愚痴者不赞智慧。何以故。智者若为是五种人说是五事。当知说者不得具足知诸根力。亦不得名怜愍众生。何以故。是五种人闻是事已。生不信心恶心嗔心。以是因缘于无量世受苦果报。是故不名怜愍众生具知根力。是故我先于余经中。告舍利弗。汝慎无为利根之人广说法语。钝根之人略说法也。舍利弗言。世尊。我但为怜愍故说。非是具足根力故说。善男子。广略说法是佛境界。非诸声闻缘觉所知。善男子。如汝所言。佛涅槃后诸弟子等各异说者。是人皆以颠倒因缘不得正见。是故不能自利利他。善男子。是诸众生非唯一性一行一根一种国土一善知识。是故如来为彼种种宣说法要。以是因缘十方三世诸佛如来。为众生故开示演说十二部经。善男子。如来说是十二部经。非为自利但为利他。是故如来第五力者名为解力。是二力故。如来深知是人现在能断善根是人后世能断善根。是人现在能得解脱。是人后世能得解脱。是故如来名无上力士

善男子。若言如来毕竟涅槃不毕竟涅槃。是人不解如来意故作如是说。善男子。是香山中有诸仙人五万三千。皆于过去迦叶佛所修诸功德未得正道。亲近诸佛听受正法。如来欲为是等人故。告阿难言。过三月已吾当涅槃。诸天闻已其声展转乃至香山。诸仙闻已即生悔心。作如是言。云何我等得生人中不亲近佛。诸佛如来出世甚难如优昙花。我今当往至世尊所听受正法。善男子。尔时五万三千诸仙即来我所。我时即为如应说法。诸大士色是无常。何以故。色之因缘是无常故。无常因生色云何常。乃至识亦如是。尔时诸仙闻是法已。即时获得阿罗汉果

善男子。拘尸那竭有诸力士三十万人无所系属。自恃憍恣色力命财狂醉乱心。善男子。我为调伏诸力士故。告目连言。汝当调伏如是力士。时目犍连敬顺我教。于五年中种种教化。乃至不能令一力士受法调伏。是故我复为彼力士告阿难言。过三月已吾当涅槃。善男子。时诸力士闻是语已。相与集聚平治道路。过三月已。我时便从毗舍离国至拘尸那城。中路遥见诸力士辈。即自化身为沙门像往力士所。作如是言。诸童子作何事耶。力士闻已皆生嗔恨。作如是言。沙门。汝今云何谓我等辈为童子耶。我时语言。汝今大众三十万人尽其身力。不能移此微小之石。云何不名为童子乎。诸力士言。汝若谓我为童子者。当知汝即是大人也。善男子。我于尔时以足二指掘出此石。是诸力士见是事已。即于己身生轻劣想。复作是言。沙门。汝今复能移徙此石令出道不。我言。童子。何因缘故严治此道。诸力士言。沙门。汝不知耶。释迦如来当由此路至娑罗林入于涅槃。以是因缘我等平治。我时赞言。善哉。童子。汝等已发如是善心。吾当为汝除去此石。我时以手举掷高至阿迦尼吒。时诸力士见石在空。皆生惊怖寻欲四散。我复告言。诸力士等。汝今不应生恐怖心各欲散去。诸力士言。沙门。若能救护我者我当安住。尔时我复以手接石置之右掌。力士见已心生欢喜。复作是言。沙门。是石常耶是无常乎。我于尔时以口吹之。石即散坏犹如微尘。力士见已唱言。沙门。是石无常。即生愧心而自考责。云何我等恃怙自在色力命财而生憍慢。我知其心即舍化身。还复本形而为说法。力士见已一切皆发菩提之心善男子。拘尸那竭有一工巧。名曰纯陀。是人先于迦叶佛所发大誓愿。释迦如来入涅槃时。我当最后奉施饮食。是故我于毗舍离国顾命比丘优婆摩那。善男子。过三月已。吾当于彼拘尸那竭娑罗双树入般涅槃。汝可往告纯陀令知

善男子。王舍城中有五通仙。名须跋陀年百二十。常自称是一切智人。生大憍慢。已于过去无量佛所种诸善根。我亦为欲调伏彼故。告阿难言。过三月已吾当涅槃。须跋闻已当来我所生信敬心。我当为彼说种种法。其人闻已当得尽漏

善男子。罗阅耆王频婆娑罗。其王太子名曰善见。业因缘故生恶逆心。欲害其父而不得便。尔时恶人提婆达多。亦因过去业因缘故。复于我所生不善心欲害于我。即修五通不久获得。与善见太子共为亲厚。为太子故现作种种神通之事。从非门出从门而入。从门而出非门而入。或时示现象马牛羊男女之身。善见太子见已即生爱心喜心敬信之心。为是事故严设种种供养之具而供养之。又复白言。大师圣人。我今欲见曼陀罗花。时提婆达多即便往至三十三天。从彼天人而求索之。其福尽故都无与者。既不得花作是思惟。曼陀罗树无我我所。我若自取当有何罪。即前欲取便失神通。还见己身在王舍城。心生惭愧不能复见善见太子。复作是念。我今当往至如来所求索大众。佛若听者我当随意教诏敕使舍利弗等。尔时提婆达多便来我所作如是言。唯愿如来。以此大众付嘱于我。我当种种说法教化令其调伏。我言。痴人。舍利弗等聪明大智世所信伏。我犹不以大众付嘱。况汝痴人食唾者乎。时提婆达复于我所倍生恶心。作如是言。瞿昙。汝今虽复调伏大众。势亦不久当见磨灭。作是语已。大地即时六返震动。提婆达多寻时躄地。于其身边出大暴风。吹诸尘土而污坌之。提婆达多见恶相已。复作是言。若我此身现世必入阿鼻地狱。我要当报如是大怨。时提婆达多寻起往至善见太子所。善见见已即问。圣人。何故颜容憔悴有忧色耶。提婆达言。我常如是汝不知乎。善见答言。愿说其意何因缘尔。提婆达言。我今与汝极成亲爱。外人骂汝以为非理。我闻是事岂得不忧。善见太子复作是言。国人云何骂辱于我。提婆达言。国人骂汝为未生怨。善见复言。何故名我为未生怨。谁作此名。提婆达言。汝未生时一切相师皆作是言。是儿生已当杀其父。是故外人皆悉号汝为未生怨。一切内人护汝心故。谓为善见。韦提夫人闻是语已。既生汝身于高楼上。弃之于地坏汝一指。以是因缘人复号汝为婆罗留枝。我闻是已心生愁愦。而复不能向汝说之。提婆达多以如是等种种恶事。教令杀父。若汝父死我亦能杀瞿昙沙门。善见太子问一大臣名曰雨行大王何故为我立字作未生怨。大臣即为说其本末。如提婆达所说无异。善见闻已。即与大臣收其父王闭之城外。以四种兵而守卫之。韦提夫人闻是事已即至王所。所守王人遮不听入。尔时夫人生嗔恚心便呵骂之。时诸守人即告太子。大王夫人欲见父王不审听不。善见闻已复生嗔嫌。即往母所前牵母发拔刀欲斫。尔时耆婆白言。大王。有国已来罪虽极重不及女人。况所生母。善见太子闻是语已。为耆婆故即便放舍。遮断父王衣服卧具饮食汤药。过七日已王命便终。善见太子见父丧已方生悔心。雨行大臣复以种种恶邪之法。而为说之。大王。一切业行都无有罪。何故今者而生悔心。耆婆复言。大王。当知如是业者罪兼二重。一者杀父王。二者杀须陀洹。如是罪者除佛更无能除灭者。善见王言。如来清净无有秽浊。我等罪人云何得见。善男子。我知是事故告阿难。过三月已吾当涅槃。善见闻已即来我所。我为说法重罪得薄。获无根信。善男子。我诸弟子闻是说已不解我意。故作是言。如来定说毕竟涅槃善男子。菩萨二种。一者实义。二者假名。假名菩萨闻我三月当入涅槃。皆生退心。而作是言。如其如来无常不住。我等何为为是事故。无量世中受大苦恼。如来世尊成就具足无量功德。尚不能坏如是死魔。况我等辈当能坏耶。善男子。是故我为如是菩萨。而作是言。如来常住无有变易。善男子。我诸弟子闻是说已不解我意。定言如来终不毕竟入于涅槃

善男子。有诸众生生于断见。作如是言。一切众生身灭之后。善恶之业无有受者。我为是人作如是言。善恶果报实有受者。云何知有。善男子。过去之世拘尸那竭。有王名曰善见。作童子时经八万四千岁。作太子时八万四千岁。及登王位亦八万四千岁。于独处坐作是思惟。众生薄福寿命短促。常有四怨而随逐之。不自觉知犹故放逸。是故我当出家修道断绝四怨生老病死。即敕有司。于其城外作七宝堂。作已便告群臣百官宫内妃后诸子眷属。汝等当知。我欲出家能见听不。尔时大臣及其眷属。各作是言。善哉。大王。今正是时。时善见王将一使人独往堂上。复经八万四千年修习慈心。是慈因缘于后八万四千世。次第得作转轮圣王。三十世中作释提桓因。无量世中作诸小王。善男子。尔时善见岂异人乎。莫作斯观即我身是。善男子。我诸弟子闻是说已不解我意。唱言如来定说有我及有我所。又我一时为诸众生。说言。我者即是性也。所谓内外因缘十二因缘众生五阴心界世间功德业行自在天世。即名为我。我诸弟子闻是说已不解我意。唱言如来定说有我

善男子。复于异时有一比丘来至我所。作如是言。世尊。云何名我。谁是我耶。何缘故我。我时即为比丘说言。比丘。无我我所。眼者即是本无今有已有还无。其生之时无所从来。及其灭时亦无所至。虽有业果无有作者。无有舍阴及受阴者。如汝所问。云何我者我即期也。谁是我者即是业也。何缘我者即是爱也。比丘。譬如二手相拍声出其中。我亦如是。众生业爱三因缘故名之为我。比丘。一切众生色不是我。我中无色色中无我。乃至识亦如是。比丘。诸外道辈虽说有我终不离阴。若说离阴别有我者无有是处。一切众生行如幻化热时之焰。比丘。五阴皆是无常无乐无我无净。善男子。尔时多有无量比丘。观此五阴无我我所得阿罗汉果。善男子。我诸弟子闻是说已不解我意。唱言如来定说无我

善男子。我于经中复作是言。三事和合得受是身。一父二母三者中阴。是三和合得受是身。或时复说阿那含人现般涅槃。或于中阴入般涅槃。或复说言。中阴身根具足明了。皆因往业如净醍醐。善男子。我或时说弊恶众生所受中阴。如世间中粗涩氀褐。纯善众生所受中阴。如波罗奈所出白[疊*毛]。我诸弟子闻是说已不解我意唱言如来说有中阴

善男子。我复为彼逆罪众生。而作是言。造五逆者舍身直入阿鼻地狱。我复说言。昙摩留枝比丘舍身直入阿鼻地狱。于其中间无止宿处。我复为彼犊子梵志说言。梵志。若有中阴则有六有。我复说言。无色众生无有中阴。善男子。我诸弟子闻是说已不解我意。唱言佛说定无中阴

善男子。我于经中复说有退。何以故。因于无量懈怠懒惰诸比丘等不修道。故说退五种。一者乐于多事。二者乐说世事。三者乐于睡眠。四者乐近在家。五者乐多游行。以是因缘令比丘退。说退因缘复有二种。一内二外。阿罗汉人虽离内因不离外因。以外因缘故则生烦恼。生烦恼故则便退失。复有比丘名曰瞿坻。六返退失。退已惭愧复更进修第七即得。得已恐失以刀自害。我复或说有时解脱。或说六种阿罗汉等。我诸弟子闻是说已不解我意。唱言如来定说有退

善男子。经中复说。譬如焦炭不还为木。亦如瓶坏更无瓶用。烦恼亦尔。阿罗汉断终不还生。亦说。众生生烦恼因凡有三种。一者未断烦恼。二者不断因缘。三者不善思惟。而阿罗汉无二因缘。谓断烦恼无不善思惟。善男子。我诸弟子闻是说已不解我意。唱言如来定说无退

善男子。我于经中说。如来身凡有二种。一者生身。二者法身。言生身者即是方便应化之身。如是身者可得言是生老病死长短黑白。是此是彼是学无学。我诸弟子闻是说已不解我意。唱言如来定说佛身是有为法法身即是常乐我净。永离一切生老病死。非白非黑非长非短非此非彼非学非无学。若佛出世及不出世。常住不动无有变易。善男子。我诸弟子闻是说已不解我意。唱言如来定说佛身是无为法

善男子。我经中说。云何名为十二因缘。从无明生行。从行生识。从识生名色。从名色生六入。从六入生触。从触生受。从受生爱。从爱生取。从取生有。从有生生。从生则有老死忧苦。善男子。我诸弟子闻是说已不解我意。唱言如来说十二缘定是有为

我又一时告喻比丘而作是言。十二因缘有佛无佛性相常住。善男子。有十二缘不从缘生。有从缘生非十二缘。有从缘生亦十二缘。有非缘生亦非十二缘。有十二缘非缘生者。谓未来世十二支也。有从缘生非十二缘者。谓阿罗汉所有五阴。有从缘生亦十二缘者。谓凡夫人所有五阴十二因缘。有非缘生非十二缘者。谓虚空涅槃。善男子。我诸弟子闻是说已不解我意。唱言如来说十二缘定是无为

善男子。我经中说。一切众生作善恶业。舍身之时。四大于此即时散坏。纯善业者心即上行。纯恶业者心即下行。善男子。我诸弟子闻是说已不解我意。唱言如来说心定常善男子。我于一时为频婆娑罗王而作是言。大王当知。色是无常。何以故。从无常因而得生故。是色若从无常因生。智者云何说言是常。若色是常不应坏灭生诸苦恼。今见是色散灭破坏。是故当知色是无常。乃至识亦如是。善男子。我诸弟子闻是说已不解我意。唱言如来说心定断

善男子。我经中说。我诸弟子受诸香花金银宝物妻子奴婢百不净物获得正道。得正道已亦不舍离。我诸弟子。闻是说已不解我意。定言如来说受五欲不妨圣道

又我一时复作是说。在家之人得正道者无有是处。善男子。我诸弟子闻是说已不解我意。唱言如来说受五欲定遮正道

善男子。我经中说。远离烦恼未得解脱。犹如欲界修习世间第一法也。善男子。我诸弟子闻作是说不解我意。唱言如来说第一法唯是欲界

又复我说。暖法顶法忍法世第一法。在于初禅至第四禅。我诸弟子闻是说已不解我意。唱言如来说如是法在于色界又复我说。诸外道等先已得断四禅烦恼。修习暖法顶法忍法世第一法。观四真谛得阿那含果。我诸弟子闻是说已不解我意。唱言如来说第一法在无色界

善男子。我经中说。四种施中有三种净。一者施主信因信果信施。受者不信。二者受者信因果施。施主不信。三者施主受者二俱有信。四者施主受者二俱不信。是四种施初三种净。我诸弟子闻是说已不解我意。唱言如来说施唯意

善男子。我于一时复作是说。施者施时以五事施。何等为五。一者施色。二者施力。三者施安。四者施命。五者施辩。以是因缘施主还得五事果报。我诸弟子闻是说已不解我意。唱言佛说施即五阴

善男子。我于一时宣说涅槃即是远离烦恼永尽灭无遗余。犹如灯灭更无法生。涅槃亦尔。言虚空者即无所有。譬如世间无所有故名为虚空。非智缘灭即无所有。如其有者应有因缘。有因缘故应有尽灭。以其无故无有尽灭。我诸弟子闻是说已。不解我意。唱言佛说无三无为

善男子。我于一时为目干连而作是言。目连。夫涅槃者即是章句。即是足迹。是毕竟处。是无所畏。即是大师。即是大果。是毕竟智。即是大忍无碍三昧。是大法界。是甘露味。即是难见。目连。若说无涅槃者。云何有人生诽谤者堕于地狱。善男子。我诸弟子闻是说已不解我意。唱言如来说有涅槃

复于一时我为目连而作是说。目连。眼不牢固。至身亦尔皆不牢固。不牢固故名为虚空。食下回转消化之处。一切音声皆名虚空。我诸弟子闻是说已不解我意。唱言如来决定说有虚空无为。复于一时为目连说。目连。有人未得须陀洹果住忍法时。断于无量三恶道报。当知不从智缘而灭。我诸弟子闻是说已不解我意。唱言如来决定说有非智缘灭

善男子。我又一时为跋波比丘说。若比丘观色。若过去若未来若现在若近若远若粗若细。如是等色非我我所。若有比丘。如是观已能断色爱。跋波又言。云何名色。我言四大名色。四阴名名。我诸弟子闻是说已不解我意。唱言如来决定说言色是四大

善男子。我复说言。譬如因镜则有像现。色亦如是因四大造。所谓粗细涩滑青黄赤白。长短方圆斜角轻重寒热饥渴烟云尘雾。是名造色犹如响像。我诸弟子闻是说已不解我意。唱言如来说有四大则有造色。成无四大无有造色

善男子。往昔一时菩提王子作如是言。若有比丘。护持禁戒若发恶心。当知是时失比丘戒。我时语言。菩提王子。戒有七种从于身口有无作色。以是无作色因缘故。其心虽在恶无记中。不名失戒犹名持戒。以何因缘名无作色。非异色因不作异色果。善男子。我诸弟子闻是说已不解我意。唱言佛说有无作色

善男子。我于余经作如是言。戒者即是遮制恶法。若不作恶是名持戒。我诸弟子闻是说已不解我意。唱言如来决定宣说无无作色

善男子。我于经中作如是说。圣人色阴乃至识阴。皆是无明因缘所出。一切凡夫亦复如是。从无明生爱。当知是爱即是无明。从爱生取。当知是取即无明爱。从取生有。是有即是无明爱取。从有生受。当知是受即是行有。从受因缘生于名色无明爱取有行。受触识六入等。是故受者即十二支。善男子。我诸弟子闻是说已不解我意。唱言如来说无心数

善男子。我于经中作如是说。从眼色明恶欲四法则生眼识。言恶欲者即是无明。欲性求时即名为爱。爱因缘取。取名为业。业因缘识。识缘名色。名色缘六入。六入缘触。触缘想受爱信精进定慧。如是等法因触而生。然非是触。善男子。我诸弟子闻是说已不解我意。唱言如来说有心数

善男子。我或时说唯有一有。或说二三四五六七八九至二十五。我诸弟子闻是说已不解我意。唱言如来说有五有。或言六有

善男子。我往一时住迦毗罗卫尼拘陀林。时释摩男来至我所。作如是言。云何名为优婆塞也。我即为说。若有善男子善女人。诸根完具受三归依。是则名为优婆塞也。释摩男言。世尊。云何名为一分优婆塞。我言。若受三归及受一戒。是名一分优婆塞也。我诸弟子闻是说已不解我意。唱言如来说优婆塞戒不具受得

善男子。我于一时住恒河边。尔时迦旃延来至我所。作如是言。世尊。我教众生令受斋法。或一日或一夜或一时或一念。如是之人成斋不耶。我言。比丘。是人得善不名得斋。我诸弟子闻是说已不解我意。唱言如来说八戒斋具受乃得

善男子。我于经中作如是说。若有比丘。犯四重已不名比丘。名破比丘亡失比丘。不复能生善牙种子。譬如焦种不生果实。如多罗树头若断坏则不生果。犯重比丘亦复如是。我诸弟子闻是说已不解我意。唱言如来说诸比丘犯重禁已失比丘戒。善男子。我于经中为纯陀说四种比丘。一者毕竟到道。二者示道。三者受道。四者污道。犯四重者即是污道。我诸弟子闻是说已不解我意。唱言如来说诸比丘犯四重已不失禁戒

善男子。我于经中告诸比丘。一乘一道一行一缘。如是一乘乃至一缘。能为众生作大寂静。永断一切系缚愁苦苦及苦因。令一切众到于一有。我诸弟子闻是说已不解我意。唱言如来说须陀洹乃至阿罗汉皆得佛道

善男子。我于经中说须陀洹人间天上七返往来便般涅槃。斯陀含人一受人天便般涅槃阿那含人凡有五种。或有中间般涅槃者。乃至上流般涅槃者。阿罗汉人凡有二种。一者现在。二者未来。现在亦断烦恼五阴。未来亦断烦恼五阴。我诸弟子闻是说已不解我意。唱言如来说须陀洹至阿罗汉不得佛道

善男子。我于此经说言。佛性具有六事。一常二实三真四善五净六可见。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有

善男子。我又说言。众生佛性犹如虚空。虚空者非过去非未来非现在。非内非外。非是色声香味触摄。佛性亦尔。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有

善男子。我又复说。众生佛性犹如贫女宅中宝藏。力士额上金刚宝珠。转轮圣王甘露之泉。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有

善男子。我又复说。犯四重禁一阐提人谤方等经作五逆罪皆有佛性。如是众生都无善法佛性是善。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有

善男子。我又复说。众生者即是佛性。何以故。若离众生不得阿耨多罗三藐三菩提。是故我与波斯匿王说于象喻。如盲说象虽不得象然不离象。众生说色。乃至说识是佛性者亦复如是。虽非佛性非不佛性。如我为王说箜篌喻。佛性亦尔。善男子。我诸弟子闻是说已不解我意。作种种说如盲问乳。佛性亦尔。以是因缘或有说言。犯四重禁谤方等经作五逆罪一阐提等悉有佛性。或说言无。善男子。我于处处经中说言。一人出世多人利益。一国土中二转轮王。一世界中二佛出世。无有是处。一四天下八四天王。乃至二他化自在天。亦无是处。然我乃说从阎浮提阿鼻地狱上至阿迦腻吒天。我诸弟子闻是说已不解我意。唱言佛说无十方佛。我亦于诸大乘经中。说有十方佛

大般涅槃经卷第三十一大般涅槃经卷第三十二

        宋代沙门慧严等依泥洹经加之

    迦叶菩萨品之二

善男子。如是诤讼是佛境界。非诸声闻缘觉所知。若人于是生疑心者。犹能摧坏无量烦恼如须弥山。若于是中生决定者是名执着。迦叶菩萨白佛言。世尊。云何执着。佛言。善男子。如是之人若从他闻。若自寻经。若他故教。于所著事不能放舍。是名执着。迦叶复言。世尊如是执着为是善耶是不善乎。善男子。如是执着不名为善。何以故。不能摧坏诸疑网故。迦叶复言。世尊。如是人者本自不疑。云何说言不坏疑网。善男子。夫不疑者即是疑也。世尊。若有人谓须陀洹人不堕三恶。是人亦当名著名疑。善男子。是可名定不得名疑。何以故。善男子。譬如有人先见人树。后时夜行遥见杌根。便生疑想人耶树耶。善男子。如人先见比丘梵志。后时于路遥见比丘即生疑想是沙门耶是梵志乎。善男子。如人先见牛与水牛。后遥见牛便生疑想彼是牛耶是水牛乎。善男子。一切众生先见二物后便生疑。何以故。心不了故。我亦不说须陀洹人有堕三恶不堕三恶。是人何故生于疑心。迦叶言。世尊。如佛所说。要先见已然后疑者。有人未见二种物时亦复生疑。何等是耶所谓涅槃。世尊。譬如有人路遇浊水。然未曾见而亦生疑如是水者深耶浅耶。是人未见云何生疑。善男子。夫涅槃者即是断苦。非涅槃者即是苦也。一切众生见有二种见苦非苦。苦非苦者。即是饥渴寒热嗔喜病瘦安隐。老壮生死系缚解脱。恩爱别离怨憎聚会。众生见已即便生疑。当有毕竟远离如是苦恼事不。是故众生于涅槃中而生疑也。汝意若谓是人先来未见浊水云何疑者。是义不然。何以故。是人先于余处见已。是故于此未曾到处而复生疑。世尊。是人先见深浅处时已不生疑。于今何故而复生疑。佛言。善男子。本未行故所以生疑。是故我言不了故疑。迦叶菩萨白佛言。世尊。如佛所说。疑即是着着即是疑。为是谁耶。善男子。断善根者

迦叶言。世尊。何等人辈能断善根。善男子。若有聪明黠慧利根能善分别。远离善友不听正法。不善思惟不如法住。如是之人能断善根离是四事。心自思惟无有施物。何以故。施者即是舍于财物。若施有报当知施主常应贫穷。何以故。子果相似故。是故说言无因无果。若如是说无因无果。是则名为断善根也。复作是念。施主受者及以财物。三事无常无有停住。若无停住云何说言此是施主受者财物。若无受者云何得果。以是义故无因无果。若如是说无因无果。当知是人能断善根。复作是念。施者施时有五事施。受者受已或时作善或作不善。而是施主亦复不得善不善果。如世间法从子生果果还作子。因即施主果即受者。而是受者不能以此善不善法令施主得。以是义故无因无果。若如是说无因无果。当知是人能断善根。复作是念无有施物。何以故。施物无记。若是无记云何而得善果报耶。无善恶果即是无记。财若无记当知即无善恶果报。是故无施无因无果。若如是说无因无果。当知是人能断善根。复作是念。施者即意。若是意者无见无对非是色法。若非是色云何可施。是故无施无因无果。若如是说无因无果。当知是人能断善根。复作是念。施主若为佛像天像命过父母。而行施者即无受者。若无受者应无果报。若无果报是为无因。若无因者是为无果。若如是说无因无果。当知是人能断善根。复作是念。无父无母。若言父母是众生因生众生者。理应常生无有断绝。何以故。因常有故。然不常生。是故当知无有父母。复作是念。无父无母。何以故。若众生身因父母有。一人应具男女二根。然无具者。当知众生非因父母。复作是念非因父母而生众生。何以故。眼见众生不似父母。谓身色心威仪进止。是故父母非众生因。复作是念。一切世间有四种无。一者未生名无。如泥团时未有瓶用。二者灭已名无。如瓶坏已是名为无。三者各异互无。如牛中无马马中无牛。四者毕竟名无。如兔角龟毛。众生父母亦复如是同此四无。若言父母众生因者。父母死时子不必死。是故父母非众生因。复作是念。若言父母众生因者。应因父母常生众生。然而复有化生湿生。是故当知非因父母生众生也。复作是念。自有众生非因父母而得生长。譬如孔雀闻雷震声而便得娠。又如青雀饮雄雀泪而便得娠。如命命鸟见雄者舞即便得娠。作是念时。如其不遇善知识者。当知是人能断善根。复作是念。一切世间无善恶果。何以故。有诸众生具十善法。乐于惠施勤修功德。是人亦复疾病集身中年夭丧。财物损失多诸忧苦。有行十恶悭贪嫉妒懒惰懈怠不修诸善。身安无病终保年寿。多饶财宝无诸愁苦。是故当知无善恶果。复作是念。我亦曾闻诸圣人说。有人修善命终多堕三恶道中。有人行恶命终生于人天之中。是故当知无善恶果。复作是念。一切圣人有二种说。或说杀生得善果报。或说杀生得恶果报。是故当知圣说不定。圣若不定我云何定。是故当知无善恶果。复作是念。一切世间无有圣人。何以故。若言圣人应得正道。一切众生具烦恼时修正道者。当知是人正道烦恼一时俱有。若一时有当知正道不能破结。若无烦恼而修道者。如是正道为何所作。是故具烦恼者道不能坏。不具烦恼道则无用。是故当知一切世间无有圣人。复作是念。无明缘行乃至生缘老死。是十二因缘一切众生等共有之。八圣道者其性平等亦应如是。一人得时一切应得。一人修时应一切苦灭。何以故。烦恼等故。而今不得。是故当知无有正道。复作是念。圣人皆有同凡夫法。所谓饮食行住坐卧睡眠喜笑饥渴寒热忧愁恐怖。若同凡夫如是事者。当知圣人不得圣道。若得圣道应当永断如是等事。如是等事如其不断当知无道。复作是念。圣人有身受五欲乐亦复骂辱。挝打于人嫉妒憍慢。受于苦乐作善恶业。是因缘故知无圣人。若有道者应断是事。是事不断当知无道。复作是念。多怜愍者名为圣人。何因缘故名为圣人。道因缘故名为圣人。若道性怜愍。便应愍念一切众生。不待修已然后方得。如其无愍何故圣人因得圣道能怜愍耶。是故当知世无圣道。复作是念。一切四大。不从因生。众生等有是四大性。不观众生是边应到。彼不应到。若有圣道性应如是。然今不尔。是故当知世无圣人。复作是念。若诸圣人有一涅槃。当知是则无有圣人。何以故。不可得故。常住之法理不可得不可取舍。若诸圣人涅槃多者是则无常。何以故。可数法故。涅槃若一一人得时一切应得。涅槃若多是则有边。如其有边云何名常。若有说言涅槃体一解脱是多。如盖是一牙舌是多。是义不然。何以故。一一所得非一切得。亦有边故是应无常。若无常者云何得名为涅槃耶。涅槃若无谁为圣人。是故当知无有圣人。复作是念。圣人之道非因缘得。若圣人道非因缘得。何故一切不作圣人。若一切人非圣人者。当知是则无有圣人及以圣道。复作是念。圣说正见有二因缘。一者从他闻法。二者内自思惟。是二因缘若从缘生。所从生者复从缘生。如是展转有无穷过。若是二事不从缘生。一切众生何故不得。作是观时能断善根。善男子。若有众生。深见如是无因无果。是人能断信等五根。善男子。断善根者非是下劣愚钝之人。亦非天中及三恶道。破僧亦尔

迦叶菩萨白佛言。世尊。如是之人何时当能还生善根。佛言。善男子。是人二时还生善根。初入地狱出地狱时。善男子。善有三种。过去现在未来。若过去者其性自灭。因虽灭尽果报未熟。是故不名断过去果。断三世因故名为断

迦叶菩萨白佛言。世尊。若断三世因名断善根。断善根人即有佛性。如是佛性。为是过去为是现在为是未来为遍三世。若过去者云何名常。佛性亦常。是故当知非过去也。若未来者云何名常。何故佛说一切众生必定当得。若必定得云何言断。若现在者复云何常。何故复言必定可见。如来亦说佛性有六。一常二真三实四善五净六可见。若断善根有佛性者。则不得名断善根也。若无佛性云何复言一切众生悉有佛性。若言佛性亦有亦断。云何如来复说是常

佛言。善男子。如来世尊为众生故有四种答。一者定答。二者分别答。三者随问答。四者置答。善男子。云何定答。若问恶业得善果耶不善果乎。是应定答得不善果。善亦如是。若问如来一切智不。是应定答是一切智。若问佛法是清净不。是应定答必定清净。若问如来弟子如法住不。是应定答有如法住。是名定答。云何分别答。如我所说四真谛法。云何为四。苦集灭道。何谓苦谛。有八苦故名曰苦谛。云何集谛。五阴因故名为集谛。云何灭谛。贪欲嗔痴毕竟尽故名为灭谛。云何道谛。三十七助道法名为道谛。是名分别答。云何随问答。如我所说一切法无常。复有问言。如来世尊为何法故说于无常。答言。如来为有为法故说无常。无我亦尔。如我所说一切法烧他。又问言。如来世尊为何法故说一切烧。答言。如来为贪嗔痴说一切烧。善男子。如来十力四无所畏。大慈大悲三念处。首楞严等八万亿诸三昧门。三十二相八十种好。五智印等三万五千诸三昧门。金刚定等四千二百诸三昧门。方便三昧无量无边。如是等法是佛佛性。如是佛性则有七事。一常二我三乐四净五真六实七善。是名分别答。善男子。后身菩萨佛性有六。一常二净三真四实五善六少见。是名分别答。如汝先问。断善根人有佛性者。是人亦有如来佛性。亦有后身佛性。是二佛性障未来故得名为无。毕竟得故得名为有。是名分别答。如来佛性非过去非现在。非未来。后身佛性现在未来少可见故得名现在。未具见故名为未来。如来未得阿耨多罗三藐三菩提时。佛性因故亦是过去现在未来。果则不尔。有是三世有非三世。后身菩萨佛性因故亦是过去现在未来。果亦如是。是名分别答。九住菩萨佛性六种。一常二善三真四实五净六可见。佛性因故亦是过去现在未来。果亦如是。是名分别答。八住菩萨下至六住佛性五事。一真二实三净四善五可见。佛性因故亦是过去现在未来。果亦如是。是名分别答。五住菩萨下至初住佛性五事。一真二实三净四可见五善不善。善男子。是五种佛性六种佛性七种佛性。断善根人必当得故。故得言有。是名分别答。若有说言。断善根者定有佛性定无佛性。是名置答

迦叶菩萨言。世尊。我闻不答乃名置答。如来今者何因缘答而名置答。善男子。我亦不说置而不答乃说置答。善男子。如是置答复有二种。一者遮止。二者莫着。以是义故得名置答

迦叶菩萨白佛言。世尊。如佛所说。云何名因亦是过去现在未来。果亦过去现在未来。非是过去现在未来。佛言。善男子。五阴二种。一者因二者果。是因五阴是过去现在未来。是果五阴亦是过去现在未来。亦非过去现在未来。善男子。一切无明烦恼等结悉是佛性。何以故。佛性因故。从无明行及诸烦恼得善五阴。是名佛性。从善五阴乃至获得阿耨多罗三藐三菩提。是故我于经中先说。众生佛性如杂血乳。血者即是无明行等一切烦恼。乳者即是善五阴也。是故我说从诸烦恼及善五阴得阿耨多罗三藐三菩提。如众生身皆从精血而得成就。佛性亦尔。须陀洹人斯陀含人。断少烦恼佛性如乳。阿那含人佛性如酪。阿罗汉人犹如生酥。从辟支佛至十住菩萨犹如熟酥。如来佛性犹如醍醐。善男子。现在烦恼为作障故。令诸众生不得睹见。如香山中有忍辱草。非一切牛皆能得食。佛性亦尔。是名分别答。迦叶菩萨白佛言。世尊。五种六种七种佛性。若未来有者云何说言断善根人有佛性耶。佛言。善男子。如诸众生有过去业。因是业故众生现在得受果报。有未来业以未生故终不生果。有现在烦恼。若无烦恼一切众生应当了了现见佛性。是故断善根人以现在世烦恼因缘能断善根。未来佛性力因缘故还生善根。迦叶言。世尊。未来云何能生善根。善男子。犹如灯日虽复未生亦能破闇。未来之生能生众生。未来佛性亦复如是。是名分别答

迦叶菩萨白佛言。世尊。若言五阴是佛性者。云何说言众生佛性非内非外。佛言。善男子。何因缘故如是失意。我先不说众生佛性是中道耶。迦叶言。世尊。我实不失意。直以众生于此中道不能解故。故发斯问。善男子。众生不解即是中道。或时有解或有不解。善男子。我为众生得开解故。说言佛性非内非外。何以故。凡夫众生或言佛性住五阴中如器中有果。或言离阴而有犹如虚空。是故如来说于中道。众生佛性非内六入非外六入。内外合故名为中道。是故如来宣说佛性即是中道。非内非外故名中道。是名分别答。复次善男子。云何名为非内非外。善男子。或言。佛性即是外道。何以故。菩萨摩诃萨于无量劫。在外道中断诸烦恼。调伏其心教化众生。然后乃得阿耨多罗三藐三菩提。是以佛性即是外道。或言。佛性即是内道。何以故。菩萨虽于无量劫中修习外道。若离内道则不能得阿耨多罗三藐三菩提。是以佛性即是内道。是故如来遮此二边。说言佛性非内非外亦名内外是名中道。是名分别答。复次善男子。或言佛性即是如来金刚之身三十二相八十种好。何以故。不虚诳故。或言佛性即是十力四无所畏大慈大悲及三念处首楞严等一切三昧。何以故。因是三昧生金刚身三十二相八十种好故。是故如来遮此二边说言。佛性非内非外亦名内外是名中道。是名分别答。复次善男子。或有说言。佛性即是内善思惟。何以故。离善思惟则不能得阿耨多罗三藐三菩提故。是故佛性即是内善思惟。或有说言。佛性即是从他闻法。何以故。从他闻法则能内善思惟。若不闻法则无思惟。是以佛性即是从他闻法。是故如来遮此二边说言。佛性非内非外。亦名内外。是名中道。复次善男子。复有说言。佛性是外谓檀波罗蜜。从檀波罗蜜得阿耨多罗三藐三菩提。是以说言檀波罗蜜即是佛性。或有说言。佛性是内谓五波罗蜜。何以故。离是五事当知则无佛性因果。是以说言五波罗蜜即是佛性。是故如来遮此二边。说言佛性非内非外亦内亦外是名中道。复次善男子。或有说言。佛性在内譬如力士额上宝珠。何以故。常乐我净如宝珠故。是以说言佛性在内。或有说言。佛性在外如贫宝藏。何以故。方便见故。佛性亦尔在众生外。以方便故而得见之。是故如来遮此二边。说言佛性非内非外亦内亦外。是名中道

善男子。众生佛性非有非无。所以者何。佛性虽有非如虚空。何以故。世间虚空虽以无量善巧方便不可得见。佛性可见。是故虽有非如虚空。佛性虽无不同兔角。何以故。龟毛兔角虽以无量善巧方便不可得生。佛性可生。是故虽无不同兔角。是故佛性非有非无亦有亦无。云何名有。一切悉有。是诸众生不断不灭犹如灯焰。乃至得阿耨多罗三藐三菩提。是故名有。云何名无。一切众生现在未有一切佛法常乐我净。是故名无。有无合故即是中道。是故佛说众生佛性非有非无。善男子。若有人问是种子中有果无果耶。应定答言。亦有亦无。何以故。离子之外不能生果。是故名有。子未出牙。是故名无。以是义故亦有亦无。所以者何。时节有异其体是一。众生佛性亦复如是。若言众生中别有佛性者。是义不然。何以故。众生即佛性。佛性即众生。直以时异有净不净。善男子。若有问言。是子能生果不是果能生子不。应定答言亦生不生。世尊。如世人说乳中有酪。是义云何。善男子。若有说言乳中有酪是名执着。若言无酪是名虚妄。离是二事应定说言亦有亦无。何故名有。从乳生酪。因即是乳果即是酪。是名为有。云何名无。色味各异服用不同。热病服乳冷病服酪。乳生冷病酪生热病。善男子。若言乳中有酪性者。乳即是酪酪即是乳。其性是一何因缘故。乳在先出酪不先生。若有因缘一切世人何故不说。若无因缘何故酪不先出。若酪不先出。谁作次第乳酪生酥熟酥醍醐。是故知酪先无今有。若先无今有是无常法。善男子。若有说言。乳有酪性能生于酪。水无酪性故不生酪。是义不然。何以故。水草亦有乳酪之性。所以者何。因于水草则出乳酪。若言乳中定有酪性。水草无者是名虚妄。何以故。心不等故故言虚妄。善男子。若言乳中定有酪者。酪中亦应定有乳性。何因缘故乳中出酪酪不出乳。若无因缘当知是酪本无今有。是故智者应言乳中非有酪性非无酪性。善男子。是故如来于是经中说如是言。一切众生定有佛性。是名为着。若无佛性是名虚妄。智者应说众生佛性亦有亦无。善男子。四事和合生于眼识。何等为四。眼色明欲。是眼识性非眼非色非明非欲。从和合故便得出生。如是眼识本无今有已有还无。是故当知无有本性。乳中酪性亦复如是。若有说言水无酪性故不出酪。是故乳中定有酪性。是义不然。何以故。善男子。一切诸法异因异果。亦非一因生一切果。非一切果从一因生。善男子。如从四事生于眼识。不可复说从此四事应生耳识。善男子。离于方便乳中得酪酪出生酥。不得如是要须方便。善男子。智者不可见离方便从乳得酪谓得生酥亦应如是离方便得。善男子。是故我于是经中说。因生故法有。因灭故法无。善男子。如盐性碱。能令非碱使碱。若非碱物先有碱性。世人何故更求盐耶。若先无者当知先无今有。以余缘故而得碱也。若言一切不碱之物皆有碱性微故不知。由此微性盐能令碱。若本无性虽复有盐不能令碱譬如种子自有四大缘外四大而得增长芽茎枝叶。盐性亦尔者是义不然。何以故。不碱之物先有碱性者。盐亦应有微不碱性。是盐若有如是二性。何因缘故。离不碱物不可独用。是故知盐本无二性。如盐一切不碱之物亦复如是。若言外四大种力能增长内四大者。是义不然。何以故。次第说故。不从方便乳中得酪生酥乃至一切诸法皆不如是非方便。得四大亦复如是。若说从外四大增内四大。不见从内四大增外四大。如尸利沙果先无形质见昴星时果则出生足长五寸。如是果者实不因于外四大增

善男子。如我所说十二部经。或随自意说。或随他意说。或随自他意说。云何名为随自意说。如五百比丘问舍利弗。大德。佛说身因何者是耶。舍利弗言。诸大德。汝等亦各得正解脱。自应识之。何缘方作如是问耶。有比丘言。大德。我未获得正解脱时。意谓无明即是身因。作是观时得阿罗汉果。复有说言。大德。我未获得正解脱时。谓爱无明即是身因。作是观时得阿罗汉果。或有说言。行识名色六入触受爱取有生饮食五欲即是身因。尔时五百比丘各各自说己所解已。共往佛所稽首佛足右绕三匝。礼拜毕已却坐一面。各以如上己所解义向佛说之。舍利弗白佛言。世尊。如是诸人谁是正说谁不正说。佛告舍利弗。善哉善哉。一一比丘无非正说。舍利弗言。世尊。佛意云何。佛言。舍利弗。我为欲界众生说言父母即是身因。如是等经名随自意说。云何名为随他意说。如巴吒罗长者。来至我所作如是言。瞿昙。汝知幻不。若知幻者即大幻人。若不知者非一切智。我言。长者。知幻之人名幻人耶。长者言。善哉善哉。知幻之人即是幻人。佛言。长者。舍卫国内波斯匿王。有旃陀罗名曰气歔。汝知不耶。长者答言。瞿昙。我久知之。佛言。汝久知者可得即是旃陀罗不。长者言。瞿昙。我虽知是旃陀罗。然我此身非旃陀罗。佛言。长者。汝得是义知旃陀罗非旃陀罗。我今何故不得知幻而非幻乎。长者。我实知幻。知幻人知幻果报知幻伎术。我知杀。知杀人知杀果报知杀解脱。乃至知邪见。知邪见人知邪见果报知邪见解脱。长者。若说非幻之人名为幻人。非邪见人说邪见人得无量罪。长者言。瞿昙。如汝所说我得大罪。我今所有悉以相上。幸莫令彼波斯匿王知我此事。佛言。长者。是罪因缘不必失财。乃当因是堕三恶道。是时长者闻恶道名心生恐怖白佛言。圣人。我今失意获得大罪。圣人。今者是一切智应当了知获得解脱。我当云何得脱地狱饿鬼畜生。尔时我为说四真谛。长者闻已得须陀洹果。心生惭愧向佛忏悔。我本愚痴佛非幻人而言是幻。我从今日归依三宝。佛言。善哉善哉。长者。是名随他意说。云何名为随自他说。如我所说。如一切世间智者说有我亦说有。智者说无我亦说无。世间智人说五欲乐有无常苦无我可断。我亦说有。世间智人说五欲乐有常我净无有是处。我亦如是说无是处。是名随自他说。善男子。如我所说。十住菩萨少见佛性。是名随他意说。何故名少见。十住菩萨得首楞严等三昧三千法门。是故了了自知当得阿耨多罗三藐三菩提。不见一切众生定得阿耨多罗三藐三菩提。是故我说十住菩萨少分见佛性。善男子。我常宣说一切众生悉有佛性。是名随自意说。一切众生不断不灭。乃至得阿耨多罗三藐三菩提。是名随自意说。一切众生悉有佛性。烦恼覆故不能得见。我说如是汝说亦尔。是名随自他意说

善男子。如来或时为一法故说无量法。如经中说。一切梵行因善知识。一切梵行因虽无量。说善知识则已摄尽。如我所说。一切恶行邪见为因。一切恶行因虽无量。若说邪见则已摄尽。或说阿耨多罗三藐三菩提信心为因。是菩提因虽复无量。若说信心则已摄尽。善男子。如来虽说无量诸法以为佛性。然不离于阴入界也

善男子。如来说法为众生故。有七种语。一者因语。二者果语。三者因果语。四者喻语。五者不应说语。六者世流布语。七者如意语。云何名因语。现在因中说未来果。如我所说。善男子。汝见众生乐杀乃至乐行邪见。当观是人即地狱人。善男子。若有众生不乐杀生乃至邪见。当观是人即是天人。是名因语。云何果语。现在果中说过去因。如经中说。善男子。如汝所见贫穷众生颜貌丑陋不得自在。当知是人定有破戒妒心嗔心无惭愧心。若见众生多财巨富诸根完具威德自在。当知是人定有戒施精勤惭愧无有妒嗔。是名果语。云何因果语。如经中说。善男子。众生现在六入触因是名过去业果。如来亦说名之为业。是业因缘得未来果。是名因果语。云何喻语。如说师子王者即喻我身。大象王大龙王。波利质多罗树。七宝聚大海须弥山大地大雨。船师导师调御丈夫力士牛王。婆罗门沙门大城多罗树。如是喻。经名为喻语。云何不应语。我经中说。天地可合河不入海。如为波斯匿王说四方山来。如为鹿母优婆夷说。若娑罗树能受八戒。则得受于人天之乐。如说十住菩萨有退转心。不说如来有二种语。宁说须陀洹人堕三恶道。不说十住有退转心是名不应语。云何世流布语。如佛所说。男女大小去来坐卧。车乘房舍瓶衣众生常乐我净。军林城邑幻化合散。是名世流布语。云何如意语。如我呵责毁禁之人。令彼自责护持禁戒。如我赞叹须陀洹人令诸凡夫生于善心。赞叹菩萨为令众生发菩提心。说三恶道所有苦恼。为令修习诸善法故。说一切烧。唯为一切有为法故。无我亦尔。说诸众生悉有佛性。为令一切不放逸故。是名如意语

善男子。如来复有随自意语。如来佛性则有二种。一者有二者无。有者所谓三十二相八十种好。十力四无所畏三念处大慈大悲。首楞严等无量三昧。金刚等无量三昧。方便等无量三昧。五智印等无量三昧。是名为有。无者所谓如来过去诸善不善无记。业因果报烦恼五阴十二因缘。是名为无。善男子。如有无善不善。有漏无漏。世间非世间。圣非圣。有为无为。实不实。寂静非寂静。诤非诤。界非界。烦恼非烦恼。取非取。受记非受记。有非有。三世非三世。时非时。常无常我无我乐无乐净无净。色受想行识非色受想行识。内入非内入。外入非外入。十二因缘非十二因缘。是名如来佛性有无。乃至一阐提佛性有无亦复如是。善男子。我虽说言一切众生悉有佛性。众生不解佛如是等随自意语。善男子。如是语者后身菩萨尚不能解。况于二乘其余菩萨。善男子。我往一时在耆阇崛山。与弥勒菩萨共论世谛。舍利弗等五百声闻。于是事中都不识知。何况出世第一义谛。善男子。或有佛性。一阐提有善根人无。或有佛性。善根人有一阐提无。或有佛性二人俱有。或有佛性二人俱无。善男子。我诸弟子若解如是四句义者。不应难言一阐提人定有佛性定无佛性。若言众生悉有佛性。是名如来随自意语。如来如是随自意语。众生云何一向作解。善男子。如恒河中有七众生。一者常没。二者暂出还没。三者出已则住。四者出已遍观四方。五者遍观已行。六者行已复住。七者水陆俱行。言常没者。所谓大鱼受大恶业身重处深。是故常没。暂出还没者。如是大鱼受恶业故。身重处浅暂见光明。因光故暂出重故还没。出已即住者。谓坻弥鱼身处浅水。乐见光明故出已住。遍观四方者。所谓[魚*昔]鱼为求食故遍观四方是故观方。观已行者。谓是[魚*昔]鱼遥见余物谓是可食。疾行趣之故观已行。行已复住者。是鱼趣已既得可食即便停住故行已复住。水陆俱行者。即是龟也。善男子。如是微妙大涅槃河。其中亦有七种众生。从初常没乃至第七或入或出。言常没者。有人闻是大涅槃经。如来常住无有变易常乐我净。终不毕竟入于涅槃。一切众生悉有佛性。一阐提人谤方等经作五逆罪犯四重禁。必当得成菩提之道。须陀洹斯陀含阿那含阿罗汉辟支佛等。必当得成阿耨多罗三藐三菩提。闻是语已生不信心。即作是念。作是念已便作是言。是涅槃典即外道书非是佛经。是人尔时远离善友不闻正法。虽时得闻不能思惟。虽复思惟不思惟善。不思善故如恶法住。恶法住者则有六种。一者恶。二者无善。三者污法。四者增有。五者恼热。六受恶果。是名为没。何故名没。无善心故。常行恶故。不修对治故。是名为没。所言恶者。圣人呵责故。心生怖畏故。善人远离故。不益众生故。是名为恶。言无善者。能生无量恶果报故。常为无明所缠绕故。乐与恶人为等侣故。无有修善诸方便故。其心颠倒常错谬故。是名无善言污法者。常污身口故。污净众生故。增不善业故。远离善法故。是名污法。言增有者。如上三人所行之法。能增地狱畜生饿鬼。不能修习解脱之法。身口意业不厌诸有。是名增有。言恼热者。是人具行如上四事。能令身心二事烦热远离寂静。则名为热。受地狱报故名为热。烧诸众生故名为热。烧诸善法故名为热。善男子。信心清凉是人不具。是故名热言受恶果者。是人具足行上五事。死堕地狱饿鬼畜生。善男子。有三恶事复名恶果。一者烦恼恶。二者业恶。三者报恶。是名受恶果报。善男子。是人具足如上六事。能断善根作五逆罪。能犯四重能谤三宝。用众僧物能作种种非法之事。是因缘故沉没在于阿鼻地狱。所受身形纵广八万四千由延。是人身口心业重故不能得出。何以故。其心不能生善法故。虽有无量诸佛出世。不闻不见故名常没。如恒河中大鱼。善男子。我虽复说一阐提等名为常没。复有常没非一阐提。何者是耶。如人为有修施戒善。是名常没。善男子。有四善事获得恶果。何等为四。一者为胜他故读诵经典。二者为利养故受持禁戒。三者为他属故而行布施。四者为于非想非非想处故系念思惟。是四善事得恶果报。若人修集如是四事。是名没已还出出已还没。何故名没。乐三有故。何故名出。以见明故。明者即是闻戒施定。何故还没。增长邪见生憍慢故。是故我于经中说偈

  若有众生乐诸有　　为有造作善恶业
  是人遂失涅槃道　　是名暂出还复没
  行于黑闇生死海　　虽得解脱杂烦恼
  是人还受恶果报　　是名暂出还复没

善男子。如彼大鱼因见光故暂得出水其身重故还复沉没。如上二人亦复如是。善男子。或复有人乐着三有。是名为没。得闻如是大涅槃经生于信心。是名为出。何因缘故名之为出。闻是经已远离恶法修习善法。是名为出。是人虽信亦不具足。何因缘故信不具足。是人虽信大般涅槃常乐我净。言如来身无常无我无乐无净。如来则有二种涅槃。一者有为。二者无为。有为涅槃无常乐我净。无为涅槃有常乐我净。虽信佛性是众生有。不必一切皆悉有之。是故名为信不具足

善男子。信有二种。一者信。二者求。如是之人虽复有信不能推求。是故名为信不具足。信复有二。一从闻生。二从思生。是人信心从闻而生不从思生。是故名为信不具足。复有二种。一信有道。二信得者。是人信心唯信有道。都不信有得道之人。是故名为信不具足。复有二种。一者信正。二者信邪。言有因果有佛法僧。是名信正。言无因果三宝性异。信诸邪语富兰那等。是名信邪。是人虽信佛法僧宝。不信三宝同一性相。虽信因果不信得者。是故。名为信不具足

是人成就不具足信。所受禁戒亦不具足。何因缘故名不具足。因不具故所得禁戒亦不具足。复何因缘名不具足。戒有二种。一威仪戒。二从戒戒。是人唯具威仪等戒不具从戒戒。是故名为戒不具足。复有二种。一者作戒。二者无作戒。是人唯具作戒不具无作戒。是故名为戒不具足。复有二种。一从身口得于正命。二从身口不得正命。是人虽从身口不得正命。是故名为戒不具足。复有二种。一者求戒。二者舍戒。是人唯具求有之戒不得舍戒。是故名为戒不具足。复有二种。一者随有。二者随道。是人唯具随有之戒不具随道。是故名为戒不具足。复有二种。一者善戒。二者恶戒。身口意善是名善戒。牛戒狗戒是名恶戒。是人深信是二种戒俱有善果。是故名为戒不具足

是人不具信戒二事。所修多闻亦不具足。云何名为闻不具足。如来所说十二部经。唯信六部不信六部。是故名为闻不具足。虽复受持是六部经不能读诵为他解说无所利益。是故名为闻不具足。又复受是六部经已。为论议故。为胜他故。为利养故。为诸有故。持读诵说。是故名为闻不具足。善男子。我于经中说闻具足。云何具足。若有比丘身口意善。先能供养和上诸师有德之人。是诸师等于是人所生爱念心。以是因缘教授经法。是人至心受持诵习。持诵习已获得智慧。得智慧已能善思惟如法而住。善思惟已则得正义。得正义已身心寂静。身心寂已则生喜心。喜心因缘心则得定。因得定故得正知见。正知见已于诸有中心生厌悔。悔诸有故能得解脱。是人无有如是等事。是故名为闻不具足

是人不具如是三事。施亦不具。施有二种。一者财施。二者法施。是人虽复行于财施为求有故。虽行法施亦不具足。何以故。秘不尽说畏他胜故。是故名为施不具足。财法二施各有二种。一者圣。二者非圣。圣者施已不求果报。非圣施已求于果报。圣者法施为增长法。非圣法施为增诸有。如是之人为增财故而行财施。为增有故而行法施。是故名为施不具足。复次是人受六部经。见受法者而供给之。不受法者则不供给。是故名为施不具足

是人不具如上四事。所修智慧亦不具足。智慧之性性能分别。是人不能分别如来是常无常。如来于此涅槃经中。说言。如来即是解脱。解脱即是如来。如来即是涅槃。涅槃即是解脱。于是义中不能分别。梵行即是如来。如来即是慈悲喜舍。慈悲喜舍即是解脱。解脱即是涅槃。涅槃即是慈悲喜舍。于是义中不能分别。是故名为智不具足。复次不能分别佛性。佛性即是如来。如来即是一切不共之法。不共之法即是解脱。解脱即是涅槃。涅槃即是不共之法。于是义中不能分别。是故名为智不具足。复次不能分别四谛苦集灭道。不能分别四真谛故不知圣行。不知圣行故不知如来。不知如来故不知解脱。不知解脱故不知涅槃。是故名为智不具足

是人不具如是五事则有二种。一增善法。二增恶法。云何名为增长恶法。是人不见已不具足。自言具足而生着心。于同行中自谓为胜。是故亲近同己恶友。既亲近已。复得更闻不具足法。闻已心喜其心染着。起于憍慢多行放逸。因放逸故亲近在家。亦乐闻说在家之事。远离清净出家之法。以是因缘增长恶法。增恶法故身口意等起不净业。三业不净故增长地狱畜生饿鬼。是名暂出还没。暂出还没者。我佛法中其谁是耶。谓提婆达多。瞿伽离比丘。惋手比丘。善星比丘。低舍比丘。满宿比丘。慈地比丘尼。旷野比丘尼。方比丘尼。慢比丘尼。净洁长者。求有优婆塞。舍勒释种。象长者。名称优婆夷。光明优婆夷。难陀优婆夷。军优婆夷。铃优婆夷。如是等人名为暂出还没。譬如大鱼见明故出身重故没

第二之人深自知见行不具足。不具足故求近善友。近善友故乐咨未闻。闻已乐受。受已乐善思惟。善思惟已能如法住。如法住故增长善法。增善法故终不复没。是名为住。我佛法中其谁是耶。谓舍利弗。大目犍连。阿若憍陈如等五比丘。耶舍等五百比丘。阿[少/兔]楼陀童子迦叶摩诃迦叶十力迦叶。瘦瞿昙弥比丘尼。波吒罗花比丘尼。胜比丘尼。实义比丘尼。意比丘尼。跋陀比丘尼。净比丘尼。不退转比丘尼。频婆娑罗王。郁伽长者。须达多长者。释摩男。贫须达多。鼠狼长者子。名称长者。具足长者。师(有本作即)子将军。优波离长者。刀长者。无畏优婆夷。善住优婆夷。爱法优婆夷。勇健优婆夷。天得优婆夷。善生优婆夷。具身优婆夷。牛得优婆夷。旷野优婆夷。摩诃斯那优婆夷。如是等比丘比丘尼优婆塞优婆夷。得名为住。云何为住。常乐睹见善光明故。以是因缘若佛出世若不出世。如是等人终不造恶。是名为住。如低弥鱼乐见光明不沈不没。如是等众亦复如是。是故我于经中说偈

  若人善能分别义　　至心求于沙门果
  若能呵责一切有　　是人名为如法住
  若能供养无量佛　　则能无量世修道
  若受世乐不放逸　　是人名为如法住
  亲近善友听正法　　内善思惟如法住
  乐见光明修习道　　获得解脱安隐住

大般涅槃经卷第三十二大般涅槃经卷第三十三

        宋代沙门慧严等依泥洹经加之

    迦叶菩萨品第二十四之三

善男子。智不具足凡有五事。是人知已求近善友。如是善友当观是人贪欲嗔恚愚痴思觉何者偏多。若知是人贪欲多者。即应为说不净观法。嗔恚多者为说慈悲。思觉多者教令数息。着我多者当为分析十八界等。是人闻已至心受持。心受持已如法修行。如法行已次第获得四念处观身受心法。得是观已次第复观十二因缘。如是观已次得暖法

迦叶菩萨白佛言。世尊。一切众生悉有暖法。何以故。如佛所说。三法和合名为众生。一寿二暖三识。若从是义一切众生应先有暖。云何如来说言暖法因善友生。佛言。善男子。如汝所问有暖法者。一切众生至一阐提皆悉有之。如我今者所说暖法。要因方便然后乃得。本无今有。以是义故非诸众生一切先有。是故汝今不应难言一切众生皆有暖法。善男子。如是暖法是色界法非欲界有。若言一切众生有者。欲界众生亦皆应有。欲界无故当知一切有。何以故。我弟子有外道则无。以是义故一切众生不必悉有。善男子。一切外道唯观六行。我诸弟子具足十六行。是十六行一切众生不必悉有。迦叶菩萨白佛言。世尊。所言暖法云何名暖。为自性暖为他故暖。佛言。善男子。如是暖法自性是暖非他故暖。迦叶菩萨言。世尊。如来先说马师满宿无有暖法。何以故。于三宝所无信心故。是故无暖。当知信心即是暖法。善男子。信非暖法。何以故。因于信心后得暖故。善男子。夫暖法者即是智慧。何以故。观四谛故。是故名之为十六行。行即是智。善男子。如汝所问。何因缘故名为暖者。善男子。夫暖法者即是八圣道之火相故名为暖。善男子。譬如攒火先有暖气次有火生后则烟出。是无漏道亦复如是。暖者即是十六行也。火者即是须陀洹果。烟者即是修道断结。迦叶菩萨复白佛言。世尊。如是暖法亦是有法亦是有为。是法报得色界五阴。是故名有。是因缘故复名有为。若是有为云何能为无漏道相。佛言。善男子。如是如是如汝所说。善男子。如是暖法虽是有为有法。还能破坏有为有法。是故能为无漏道相。善男子。如人乘马亦爱亦策。暖心亦尔。爱故受生厌故观行。是故虽复有法有为。而能与彼正道作相得暖法。人七十三种。欲界十种。是人具足一切烦恼。从断一分至于九分。如欲界初禅乃至无所有处亦复如是。是名七十三种。如是等人得暖法已。则不复能断于善根作五逆罪犯四重禁。是人二种。一遇善友。二遇恶友。遇恶友者暂出还没。遇善友者遍观四方。观四方者即是顶法。是法虽复性是五阴亦缘四谛。是故得名遍观四方。得顶法已次得忍法。是忍亦尔性亦五阴亦缘四谛。是人次得世第一法。是法虽复性是五阴亦缘四谛。是人次第得苦法忍。忍性是慧缘于一谛。如是忍法缘一谛已。乃至见断烦恼得须陀洹果。是名第四遍观四方。四方者即是四谛

迦叶菩萨白佛言。世尊。如佛先说。须陀洹人所断烦恼。犹如纵广四十里水。其余在者如一毛渧。此中云何说断三结名须陀洹。一者我见。二者非因见因。三者疑网。世尊。何因缘故名须陀洹遍观四方。复何因缘名须陀洹。复何因缘说须陀洹喻以[魚*昔]鱼。佛言。善男子。须陀洹人虽复能断无量烦恼。此三重故亦摄一切须陀洹人所断结故。善男子。譬如大王出游巡时虽有四兵世人俱言王来王去。何以故。世间重故。是三烦恼亦复如是。何因缘故名之为重。一切众生常所起故。微难识故。故名为重。如是三结难可断故。能为一切烦恼因故。是三对治之怨敌故。谓戒定慧。善男子。有诸众生闻须陀洹能断如是无量烦恼。则生退心便作是言。众生云何能断如是无量烦恼。是故如来方便说三。如汝所问。何因缘故须陀洹人喻观四方。善男子。须陀洹人观于四谛获得四事。一者住坚固道。二者能遍观察。三者能如实见。四者能坏大怨。坚固道者是须陀洹所有五根无能动者。是故名为住坚固道。能遍观者悉能呵责内外烦恼。如实见者即是忍智。坏大怨者谓四颠倒。如汝所问。何因缘故名须陀洹者。善男子。须名无漏。陀洹名修习。修习无漏故名须陀洹。善男子。复有须者名流。流有二种。一者顺流。二者逆流。以逆流故名须陀洹。迦叶菩萨言。世尊。若从是义何因缘故。斯陀含人阿那含人阿罗汉人。不得名为须陀洹耶。善男子。从须陀洹乃至诸佛。亦得名为须陀洹。若斯陀含乃至诸佛无须陀洹。云何得名斯陀含乃至佛。一切众生名有二种。一者旧二者客。凡夫之时有世名字。既得道已更为立名名须陀洹。以先得故名须陀洹。以后得故名斯陀含。是人亦名须陀洹。亦名斯陀含。乃至佛亦复如是。善男子。流有二种。一者解脱。二者涅槃。一切圣人皆有是二。亦可得名须陀洹。亦名斯陀含。乃至佛亦复如是。善男子。须陀洹者亦名菩萨。何以故。菩萨者即是尽智及无生智。须陀洹人亦复求索如是二智。是故当知须陀洹人得名菩萨。须陀洹人亦得名觉。何以故。正觉见道断烦恼故。正觉因果故。正觉共道及不共道故。斯陀含乃至阿罗汉亦复如是。善男子。是须陀洹凡有二种。一者利根。二者钝根。钝根之人人天七返。是钝根人复有五种。或有六返五四三二。利根之人现在获得须陀洹果至阿罗汉果。善男子。如汝所问。何因缘故须陀洹人喻以[魚*昔]鱼。善男子。[魚*昔]鱼有四事。一者骨细故轻。二者有翅故轻。三者乐见光明。四者衔物坚持。须陀洹人亦有四事。言骨细者喻烦恼微。言有翅者喻奢摩他毗婆舍那。乐见光明喻于见道。衔物坚持喻闻如来说无常苦无我不净坚持不舍。犹如魔王化作佛像。首罗长者见已心惊。魔见长者其心动已。即语长者。我先所说四真谛者是说不真。今当为汝更说五谛六阴十三入十九界。长者闻已寻观法相都无此理。是故坚持其心不动。迦叶菩萨白佛言。世尊。是须陀洹先得道故名须陀洹。以初果故名须陀洹。若先得道名须陀洹者。得苦法忍时何故不得名须陀洹。乃名为向。若以初果名须陀洹。外道之人先断烦恼至无所有处。修无漏道得阿那含果。何故不名为须陀洹。善男子。以初果故名须陀洹。如汝所问。外道之人先断烦恼至无所有处。修无漏道得阿那含。何故不名须陀洹者。善男子。以初果故名须陀洹。是人尔时具足八智及十六行。迦叶言。世尊。得阿那含人亦复如是亦得八智具十六行。何故不得名须陀洹。善男子。有漏十六行有二种。一者共二者不共。无漏十六行亦有二种。一者向果。二者得果。八智亦二。一者向果。二者得果。须陀洹人舍共十六行得不共十六行。舍向果八智得果八智。阿那含人即不如是。是故初果名须陀洹。善男子。须陀洹人缘于四谛。阿那含人唯缘一谛。是故初果名须陀洹。以是因缘喻以[魚*昔]鱼。遍观已行者即是斯陀含系心修道。为断贪欲嗔痴憍慢。如彼[魚*昔]鱼遍观方已为食故行

行已复住喻阿那含得食已住。是阿那含凡有二种。一者现在得阿那含进修即得阿罗汉果。二者贪着色界无色界中寂静三昧。是人不受欲界身故名阿那含。是阿那含复有五种。一者中般涅槃。二者受身般涅槃。三者行般涅槃。四者无行般涅槃。五者上流般涅槃。复有六种。五种如上。六现在般涅槃。复有七种。六种如上。七无色界般涅槃。行般涅槃复有二种。或受二身或受四身。若受二身是名利根。若受四身是名钝根。复有二种。一者精进无自在定。二者懈怠有自在定。复有二种。一者具精进定。二者不具是二。善男子。欲色众生有二种业。一者作业。二受生业。中涅槃者唯有作业无受生业。是故于中而般涅槃。舍欲界身未至色界。以利根故于中涅槃。是中涅槃阿那含人有四种心。一者非学非无学。二者学。三者无学。四者非学非无学。入于涅槃云何复名中般涅槃。善男子。是阿那含四种心中。二是涅槃。二非涅槃。是故名为中般涅槃。受身涅槃复有二种。一者作业。二者生业。是人舍欲界身受色界身。精勤修道尽其寿命入于涅槃。迦叶菩萨言。世尊。若言尽命入涅槃者。云何而言受身涅槃。佛言。善男子。是人受身然后乃断三界烦恼。是故名为受身涅槃。善男子。行般涅槃者常修行道。以有为三昧力故能断烦恼入于涅槃。是名行般涅槃。无行般涅槃者。是人定知当得涅槃是故懈怠。亦以有为三昧力故。寿尽则得入于涅槃。是名无行般涅槃。上流般涅槃者若有人得第四禅已。是人生于初禅爱心。以是因缘退生初禅。是有二流。一烦恼流。二者道流。以道流故是人寿尽生二禅爱。以爱因缘生于二禅。至第四禅亦复如是。是四禅中复有二种。一者入无色界。二者入五净居。如是二人一乐三昧二乐智慧。乐智慧者入五净居乐三昧者入无色界。如是二人。一者修第四禅有五阶差。二者不修。云何为五。下中上上中上上。修上上者处无小天。修上中者处善见天。修上品者处善可见天。修中品者处无热天。修下品者处少广天。如是二人。一乐论议。二乐寂静。乐寂静者入无色界。乐论议者处五净居。复有二种。一者修熏禅。二者不修熏禅。修熏禅者入五净居。不修熏禅者生无色界。尽其寿命而般涅槃。是名上流般涅槃。若欲入于无色界者。即不能修四禅五差。若修五差则能呵责无色界定。迦叶菩萨白佛言。世尊。中涅槃者则是利根。若利根者何不现在入涅槃耶。何故欲界有中涅槃色界则无。佛言。善男子。是人现在四大羸劣不能修道。虽有比丘四大康健。无有房舍饮食衣服卧具医药。众缘不具。是故不得现在涅槃。善男子。我昔一时在舍卫国阿那邠低精舍。有一比丘来至我所。作如是言。世尊。我常修道而不能得须陀洹果至阿罗汉果。我时即告阿难言。汝今当为是比丘具诸所须。尔时阿难将是比丘。至只陀林与好房舍。是时比丘语阿难言。大德唯愿为我庄严房舍净洁修治。七宝严丽悬缯幡盖。阿难言。世间贫者乃名沙门。我当云何能办是事。是比丘言。大德。若能为我作者善。若不能者我当还往至世尊所。尔时阿难即往佛所作如是言。世尊。向者比丘从我求索种种庄严七宝幡盖。不审是事当云何耶。我于尔时复告阿难。汝今还去随比丘意。所须之物为办具之。尔时阿难即还房中。为是比丘事事具办。比丘得已系念修道。不久即得须陀洹果至阿罗汉果。善男子。无量众生应入涅槃。以所乏故妨乱其心。是故不得。善男子。复有众生多喜教化。其心匆务不能得定。是故不得现在涅槃。善男子。如汝所问。何因缘故舍欲界身有中涅槃色界无者。善男子。是人观于欲界烦恼因缘有二。一者内二者外。而色界中无外因缘。欲界复有二种爱心。一者欲爱。二者食爱。观是二爱至心呵责。既呵责已得入涅槃。是欲界中能得呵责诸粗烦恼。所谓悭贪嗔妒无惭无愧。以是因缘能得涅槃。又欲界道其性勇健。何以故。得四果故。是故欲界有中涅槃色界中无。善男子。中涅槃者凡有三种。谓上中下。上者舍身未离欲界便得涅槃。中者始离欲界未至色界便得涅槃。下者离欲界已至色界边乃得涅槃。喻以[魚*昔]鱼得食已住。是人亦尔。云何名住。处在色界及无色界得受身故。是故名住。不受欲界人天地狱畜生饿鬼。是故名住。已断无量诸烦恼结余少在故。是故名住。复何因缘名之为住。终不造作共凡夫事。是故名住。自无所畏不令他畏。是故名住。远离二爱悭贪嗔恚。是故名住

善男子。到彼岸者喻阿罗汉辟支佛菩萨佛。犹如神龟水陆俱行。何因缘故喻之以龟。善藏五故。是阿罗汉乃至诸佛亦复如是。善覆五根是故喻龟。言水陆者水喻世间陆喻出世。是诸圣等亦复如是。能观一切恶烦恼故到于彼岸。是故喻以水陆俱行善男子。如恒河中七种众生虽有鱼龟之名不离于水。如是微妙大涅槃中。从一阐提上至诸佛虽有异名。然亦不离于佛性水。善男子。是七众生若善法若不善法。若方便道若解脱道。若次第道若因若果。悉是佛性。是名如来随自意语。迦叶菩萨言。世尊。若有因则有果。若无因则无果。涅槃名果常故无因。若无因者云何名果。而是涅槃亦名沙门名沙门果。云何沙门云何沙门果。善男子。一切世间有七种果。一者方便果。二者报恩果。三者亲近果。四者余残果。五者平等果。六者果报果。七者远离果。方便果者如世间人秋多收谷咸相谓言得方便果。方便果者名业行果。如是果者有二种因。一者近因。二者远因。近因者所谓种子。远因者谓水粪人功。是名方便果。报恩果者如世间人供养父母。父母咸言。我今已得恩养之果。子能报恩名之为果。如是果者因亦二种。一者近因。二者远因。近者即是父母过去纯善之业。远者即是所生孝子。是名报恩果。亲近果者譬如有人亲近善友或得须陀洹果至阿罗汉果。是人唱言。我今已得亲近果报。如是果者因有二种。一者近因。二者远因。近者信心。远者善友。是名亲近果。余残果者如因不杀得第三身延年益寿。是名残果。如是果者有二种因。一者近因。二者远因。近者即是身口意净。远者即是延年益寿。是名残果。平等果者谓世界器。如是果者亦二种因。一者近因。二者远因。近因者所谓众生修十善业。远因者所谓三灾。是名平等果。果报果者如人获得清净身已修身口意清净之业。是人便说我得果报果。如是果者因有二种。一者近因。二者远因。近因者所谓现在身口意净。远因者所谓过去身口意净。是名果报果。远离果者即是涅槃离诸烦恼。一切善业是涅槃因。复有二种。一者近因。二者远因。近者即是三解脱门。远因者即无量世所修善法。善男子。如世间法或说生因或说了因。出世之法亦复如是。亦说生因亦说了因。善男子。三解脱门三十七品。能为一切烦恼作不生生因。亦为涅槃而作了因。善男子。远离烦恼则得了了见于涅槃。是故涅槃唯有了因无有生因。善男子。如汝所问。云何沙门那云何沙门果者。善男子。沙门那者即八正道。沙门果者从道毕竟永断一切贪嗔痴等。是名沙门那沙门果。迦叶菩萨言。世尊。何因缘故八正道者名沙门那。善男子。世言沙门名乏那者名道。如是道者断一切乏断一切道。以是义故名八正道为沙门那。从是道中获得果故名沙门果。善男子。又沙门那者如世间人有乐静者亦名沙门。如是道者亦复如是。能令行者离身口意恶邪命等得乐寂静。是故名之为沙门那。善男子。如世下人能作上人。是名沙门。如是道者亦复如是。能令下人作上人故。是故得名为沙门那。善男子。阿罗汉人修是道者得沙门果。是故得名到于彼岸。阿罗汉果者即是无学五分法身。戒定慧解脱解脱知见。因是五分得到彼岸。是故名为到于彼岸。到彼岸故而自说言。我生已尽梵行已立。所作已办更不受有。善男子。是阿罗汉永断三世生因缘故。是故自说我生已尽。亦断三界五阴身故。是故复言我生已尽。所修梵行已毕竟故。是故唱言梵行已立。又舍学道亦名已立。如本所求今日已得。是故唱言所作已办。修道得果亦言已办。获得尽智无生智故。唱言我生已尽尽诸有结。以是义故名。阿罗汉得到彼岸。如阿罗汉辟支佛亦复如是。菩萨及佛具足成就六波罗蜜名到彼岸。是佛菩萨得阿耨多罗三藐三菩提已。名为具足六波罗蜜。何以故。得六波罗蜜果故以得果故名为具足

善男子。是七众生不修身不修戒不修心不修慧。不能修习如是四事。则能造作五逆重罪。能断善根犯四重禁谤佛法僧是故得名为常沉没。善男子。是七人中有能亲近善知识者。至心听受如来正法。内善思惟如法而住。精勤修习身戒心慧。是故得名渡生死河到于彼岸。若有说言一阐提人得阿耨多罗三藐三菩提者。是名染着。若言不得是名虚妄。善男子。是七种人或有一人具七。或有七人各一。善男子。若有心口异想异说。言一阐提得阿耨多罗三藐三菩提者。当知是人谤佛法僧。若人心口异想异说。言一阐提不得阿耨多罗三藐三菩提。是人亦名谤佛法僧。善男子。若有说言八圣道分凡夫所得。是人亦名谤佛法僧。若有说言八圣道分非凡夫得。是人亦名谤佛法僧。善男子。若有说言一切众生定有佛性定无佛性。是人亦名谤佛法僧。善男子。是故我于契经中说有二种人谤佛法僧。一者不信嗔恚心故。二者虽信不解义故。善男子。若人信心无有智慧。是人则能增长无明。若有智慧无有信心。是人则能增长邪见。善男子。不信之人嗔恚心故。说言无有佛法僧宝信者无慧颠倒解义。令闻法者谤佛法僧。善男子。是故我说。不信之人嗔恚心故。有信之人无智慧故。是人能谤佛法僧宝。善男子。若有说言一阐提等未生善法便得阿耨多罗三藐三菩提。是人亦名谤佛法僧。若复有言一阐提人舍一阐提于异身中得阿耨多罗三藐三菩提。是人亦名谤佛法僧。若复说言一阐提人能生善根。生善根已相续不断。得阿耨多罗三藐三菩提。故言一阐提得阿耨多罗三藐三菩提。当知是人不谤三宝。善男子。若有人言一切众生定有佛性。常乐我净不作不生。烦恼因缘故不可见。当知是人谤佛法僧。若有说言一切众生都无佛性犹如兔角从方便生本无今有已有还无。当知是人谤佛法僧。若有说言众生佛性非有如虚空。非无如兔角。何以故。虚空常故兔角无故。是故得言亦有亦无。有故破兔角。无故破虚空。如是说者不谤三宝。善男子。夫佛性者不名一法。不名十法不名百法。不名千法不名万法。未得阿耨多罗三藐三菩提时。一切善不善无记尽名佛性。如来或时因中说果果中说因。是名如来随自意语。随意语故名为如来。随意语故名阿罗呵。随意语故名三藐三佛陀迦叶菩萨言。世尊。如佛所说众生佛性犹如虚空。云何名为如虚空耶。善男子。虚空之性非过去非未来非现在。佛性亦尔。善男子。虚空非过去。何以故。无现在故。法若现在可说过去。以无现在故无过去亦无现在。何以故。无未来故。法若未来可说现在。以无未来故无现在亦无未来。何以故。无现在过去故。若有现在过去则有未来。以无现在过去故则无未来。以是义故虚空之性非三世摄。善男子。以虚空无故无有三世。不以有故无三世也。如虚空花非是有故无有三世。虚空亦尔。非是有故无有三世。善男子。无物者即是虚空。佛性亦尔。善男子。虚空无故非三世摄。佛性常故非三世摄。善男子。如来已得阿耨多罗三藐三菩提。所有佛性一切佛法常无变易。以是义故无有三世犹如虚空。善男子。虚空无故非内非外。佛性常故非内非外。故说佛性犹如虚空。善男子。如世间中无挂碍处名为虚空。如来得阿耨多罗三藐三菩提已。于一切佛法无有挂碍。故言佛性犹如虚空。以是因缘我说佛性犹如虚空迦叶菩萨白佛言。世尊。如来佛性涅槃非三世摄而名为有。虚空亦非三世所摄。何故不得名为有耶。佛言。善男子。为非涅槃名为涅槃。为非如来名为如来。为非佛性名为佛性。云何名为非涅槃耶。所谓一切烦恼有为之法。为破如是有为烦恼。是名涅槃。非如来者谓一阐提至辟支佛。为破如是一阐提等至辟支佛。是名如来。非佛性者所谓一切墙壁瓦石无情之物。离如是等无情之物。是名佛性。善男子。一切世间无非虚空对于虚空。迦叶菩萨白佛言。世尊。世间亦无非四大对而犹得名四大是有。虚空无对。何故不得名之为有。佛言。善男子。若言涅槃非三世摄虚空亦尔者。是义不然。何以故。涅槃是有可见可证。是色足迹章句是有。是相是缘是归依处。寂静光明安隐彼岸。是故得名非三世摄。虚空之性无如是法。是故名无。若有离于如是等法更有法者。应三世摄。虚空若同是有法者。不得非是三世所摄。善男子。如世人说虚空名为无色无对不可睹见。若无色无对不可见者即心数法。虚空若同心数法者。不得不是三世所摄。若三世摄即是四阴。是故离四阴已无有虚空。复次善男子。诸外道言。夫虚空者即是光明。若是光明即是色法。虚空若尔是色法者即是无常。是无常故三世所摄。云何外道说非三世。若三世摄则非虚空。亦可说言虚空是常。善男子。复有人言虚空者即是住处。若有住处即是色法。而一切处皆是无常三世所摄。虚空亦常非三世摄。若说处者知无虚空。复有说言虚空者即是次第。若是次第即是数法。若是可数即三世摄。若三世摄云何言常。善男子。若复说言。夫虚空者不离三法。一者空二者实三者空实。若言空是。当知虚空是无常法。何以故。实处无故。若言实是。当知虚空亦是无常。何以故。空处无故。若空实是。当知虚空亦是无常。何以故。二处无故。是故虚空名之为无。善男子。如说虚空是可作法。如说去树去舍而作虚空。平作虚空覆于虚空上于虚空画虚空色如大海水。是故虚空是可作法。一切作法皆是无常犹如瓦瓶。虚空若尔应是无常。善男子。世间人说一切法中无挂碍处名虚空者。是无碍处于一法所。为具足有为分有耶。若具足有当知余处。则无虚空。若分有者则是彼此可数之法。若是可数当知无常。善男子。若有人说虚空无碍与有并合。又复说言虚空在物如器中果。二俱不然。何以故。若言并合则有三种。一异业合如飞鸟集树。二共业合如两羊相触。三已合共合如二双指合在一处。若言异业共合。异则有二。一是物业。二虚空业。若空业合物空则无常。若物业合空物则不遍。如其不遍是亦无常。若言虚空是常其性不动与动物合者。是义不然。何以故。虚空若常物亦应常。物若无常空亦无常。若言虚空亦常无常无有是处。若共业合。是义不然。何以故。虚空名遍。若与业合业亦应遍。若是遍者应一切遍。若一切遍应一切合。不应说有合与不合。若言已合共合如二双指合。是义不然。何以故。先无有合后方合故。先无后有是无常法。是故不得说言虚空已合共合如世间法先无后有是物无常。虚空若尔亦应无常。若言虚空在物如器中果。是义不然。何以故。如是虚空先无器时在何处住。若有住处虚空则多。如其多者云何言常言一言遍。若使虚空离空有住。有物亦应离虚空住。是故当知无有虚空。善男子。若有说言指住之处名为虚空。当知虚空是无常法。何以故。指有四方。若有四方当知虚空亦有四方。一切常法都无方所。以有方故虚空无常。若是无常不离五阴。要离五阴是无所有。善男子。有法若从因缘住者。当知是法名为无常。善男子。譬如一切众生树木因地而住。地无常故因地之物次第无常。善男子。如地因水。水无常故地亦无常。如水因风。风无常故水亦无常。风依虚空。虚空无常故风亦无常。若无常者云何说言虚空是常遍一切处。虚空无故非是过去未来现在。亦如兔角是无物故。非是过去未来现在。是故我说佛性常故非三世摄。虚空无故非三世摄。善男子。我终不与世间共诤。何以故。世智说有我亦说有。世智说无我亦说无

迦叶菩萨言。世尊。菩萨摩诃萨具足。几法不与世诤。不为世法之所沾污。佛言。善男子。菩萨摩诃萨具足十法不与世诤。不为世法之所沾污。何等为十。一者信心。二者有戒。三者亲近善友。四者内善思惟。五者具足精进。六者具足正念。七者具足智慧。八者具足正语。九者乐于正法。十者怜愍众生。善男子。菩萨具足如是十法不与世诤。不为世法之所沾污如优钵罗花。迦叶菩萨白佛言。世尊。如佛所说。世智说有我亦说有。世智说无我亦说无。何等名为世智有无。佛言。善男子。世智若说色是无常苦空无我。乃至识亦如是。善男子。是名世智说有我亦说有。善男子。世智说色无有常乐我净。受想行识亦复如是。善男子。是名世智说无我亦说无。迦叶菩萨白佛言。世尊。世间智者即佛菩萨一切圣人。若诸圣人色是无常苦空无我。云何如来说佛色身常恒无变。世间智者所说无法。云何如来说言是有。如来世尊作如是说。云何复言不与世诤不为世法之所沾污。如来已离三种颠倒。所谓想倒心倒见倒。应说佛色实是无常。今乃说常。云何得名远离颠倒不与世诤。佛言。善男子。凡夫之色从烦恼生。是故智说色是无常苦空无我。如来色者远离烦恼。是故说是常恒无变

迦叶菩萨言。世尊。云何为色从烦恼生。善男子。烦恼三种。所谓欲漏有漏无明漏。智者应当观是三漏所有罪过。所以者何。知罪过已则能远离。譬如医师先诊病脉知病所在然后授药。善男子。如人将盲至蕀林中舍之而还。盲人于后甚难得出。设得出者身体坏尽。世间凡夫亦复如是。不能知见三漏过患则随逐行。如其见者则能远离知罪过已。虽受果报果报轻微。善男子。有四种人。一作业时重受报时轻。二作业时轻受报时重。三作业时重受报亦重。四作业时轻受报亦轻。善男子。若人能观烦恼罪过。是人作业受果俱轻。善男子。有智之人作如是念。我应远离如是等漏。又复不应作如是等鄙恶之事。何以故。我今未得脱于地狱饿鬼畜生人天报故。我若修道当因是力破坏诸苦。是人观已贪欲嗔恚愚痴微弱。既见贪欲嗔痴轻已。其心欢喜。复作是念。我今如是皆由修道因缘力故。令我得离不善之法亲近善法。是故现在。得见正道。应当勤加而修习之。是人因是勤修道力。远离无量诸恶烦恼。及离地狱饿鬼畜生人天果报。是故我于契经中说。当观一切有漏烦恼及有漏因。何以故。有智之人若但观漏不观漏因。则不能断诸烦恼也。何以故。智者观漏从是因生。我今断因漏则不生。善男子。如彼医师先断病因病则不生。智者先断烦恼因者亦复如是。有智之人先当观因次观果报。知从善因生于善果。知从恶因生于恶果。观果报已远离恶因。观果报已。复当次观烦恼轻重。观轻重已先离重者。既离重已。轻者自去。善男子。智者若知烦恼烦恼因烦恼果报烦恼轻重。是人尔时精勤修道不息不悔。亲近善友至心听法。为灭如是诸烦恼故。善男子。譬如病者自知病轻必可除差。虽得苦药服之不悔。有智之人亦复如是。勤修圣道欢喜不愁不息不悔。善男子。若人能知烦恼烦恼因烦恼果报烦恼轻重。为除烦恼故勤修圣道。是人不从烦恼生色。受想行识亦复如是。若不能知烦恼烦恼因烦恼果报烦恼轻重不勤修习。是人则从烦恼生色受想行识亦复如是。善男子。知烦恼烦恼因烦恼果报烦恼轻重。为断烦恼修行道者。即是如来。以是因缘如来色常乃至识常。善男子。不知烦恼烦恼因烦恼果报烦恼轻重。不能修道即是凡夫。是故凡夫色是无常。受想行识悉是无常。善男子。世间智者一切圣人菩萨诸佛说是二义。我亦如是说是二义。是故我说不与世间智者共诤不为世法之所沾污

迦叶菩萨复白佛言。世尊。如佛所说。三有漏者。云何名为欲漏有漏无明漏耶。佛言。善男子。欲漏者。内恶觉观因于外缘生于欲漏。是故我昔在王舍城。告阿难言。阿难。汝今受此女人所说偈颂。是偈乃是过去诸佛之所宣说。是故一切内恶觉观外诸因缘。名之为欲。是名欲漏。有漏者。色无色界内诸恶法外诸因缘。除欲界中外诸因缘内诸觉观是名有漏。无明漏者。不能了知我及我所不别内外。名无明漏。善男子。无明即是一切诸漏根本。何以故。一切众生无明因缘。于阴入界忆想作相。名为众生。是名想倒心倒见倒。以是因缘生一切漏。是故我于十二部经。说无明者即是贪因嗔因痴因。迦叶菩萨言。世尊。如来昔于十二部经说言不善思惟因缘生于贪欲嗔痴。今何因缘乃说无明。善男子。如是二法互为因果互相增长。不善思惟生于无明。无明因缘生不善思惟。善男子。其能生长诸烦恼者。皆悉名为烦恼因缘。亲近如是烦恼因缘。名为无明不善思惟。如子生牙。子是近因四大远因。烦恼亦尔。迦叶菩萨白佛言。世尊。如佛所说无明即漏。云何复言因无明故生于诸漏。佛言。善男子。如我所说。无明漏者是内无明。因于无明生诸漏者是内外因。若说无明漏是名内倒不识无常苦空无我。若说一切烦恼因缘是名不知外我我所。若说无明漏。是名无始无终从无明生阴入界等

迦叶菩萨白佛言。世尊。如佛所说。有智之人知于漏因。云何名为知于漏因。善男子。智者当观。何因缘故生是烦恼。造作何行生此烦恼。于何时中生此烦恼。共谁住时生此烦恼。何处止住生此烦恼。观何事已生于烦恼。受谁房舍卧具饮食衣服汤药而生烦恼。何因缘故转下作中转中作上。下业作中中业作上。菩萨摩诃萨作是观时。则得远离生漏因缘。如是观时未生烦恼遮令不生。已生烦恼便得除灭。是故我于契经中说。智者当观生烦恼因

迦叶菩萨白佛言。世尊。众生一身云何能起种种烦恼。佛言。善男子。如一器中有种种子得水雨已各各自生。众生亦尔。器虽是一。爱因缘故而能生长种种烦恼

迦叶菩萨言。世尊。智者云何观于果报。善男子。智者当观。诸漏因缘能生地狱饿鬼畜生。是漏因缘得人天身。即是无常苦空无我。是身器中得三种苦三种无常。是漏因缘能令众生作五逆罪受诸恶报。能断善根犯四重禁诽谤三宝。智者当观。我既受得如是之身。不应生起如是烦恼受诸恶果迦叶菩萨言。世尊。有无漏果。复言智者断诸果报。无漏果报在断中不。诸得道人有无漏果。如其智者求无漏果。云何佛说一切智者应断果报。若其断者今诸圣人云何得有。善男子。如来或时因中说果果中说因。如世间人说泥即瓶缕即是衣。是名因中说果。果中说因者。牛即水草人即是食。我亦如是因中说果。先于经中作是说言。我从心身(因心运心故名心身)至梵天边。是名因中说果。果中说因。此六入者名过去业。是名果中说因。善男子。一切圣人真实无有无漏果报。一切圣人修道果报更不生漏。是故名为无漏果报。善男子。有智之人如是观时。即得永灭烦恼果报。善男子。智者观已。为断如是烦恼果报修习圣道。圣道者即空无相愿。修是道已能灭一切烦恼果报

大般涅槃经卷第三十三大般涅槃经卷第三十四

        宋代沙门慧严等依泥洹经加之

    迦叶菩萨品之四

迦叶菩萨白佛言。世尊。一切众生皆从烦恼而得果报。言烦恼者所谓恶也。从恶烦恼所生烦恼亦名为恶。如是烦恼则有二种。一因二果。因恶故果恶。果恶故子恶。如纴婆果其子苦故花果茎叶一切皆苦。犹如毒树其子毒故果亦是毒。因亦众生果亦众生。因亦烦恼果亦烦恼。烦恼因果即是众生。众生即是烦恼因果。若从是义。云何如来先喻雪山亦有毒草微妙药王。若言烦恼即是众生。众生即是烦恼。云何而言众生身中有妙药王。佛言。善哉善哉

善男子。无量众生咸同此疑。汝今能为启请求解。我亦能断。谛听谛听。善思念之。今当为汝分别解说。善男子。雪山喻者即是众生。言毒草者即是烦恼。妙药王者即净梵行。善男子。若有众生。能修如是清净梵行。是名身中有妙药王。迦叶菩萨白佛言。世尊。云何众生有清净梵行。善男子。犹如世间从子生果。是果有能与子作因。有不能者。有能作者。是名果子。若不能作唯得名果不得名子。一切众生亦复如是。皆有二种。一者有烦恼果。是烦恼因。二者有烦恼果。非烦恼因。是烦恼果非烦恼因。是则名为清净梵行

善男子。众生观受知是一切漏之近因。所谓内外漏。受因缘故。不能断绝一切诸漏。亦不能出三界牢狱。众生因受着我我所。生于心倒想倒见倒。是故众生先当观受。如是受者为一切爱而作近因。是故智者欲断爱者当先观受。善男子。一切众生十二因缘所作善恶皆因受时。是故我为阿难说言。阿难。一切众生所作善恶皆是受时。是故智者先当观受。既观受已复当更观如是受者何因缘生。若因缘生。如是因缘复从何生。若无因生。无因何故不生无受。复观是受。不因自在天生。不因士夫生。不因微尘生。非时节生。不因想生。不因性生。不从自生。不从他生。非自他生。非无因生。是受皆从缘合而生。因缘者即是爱也。是和合中非有受非无受。是故我当断是和合。断和合故则不生受。善男子。智者既观因已次观果报。众生因受受于地狱饿鬼畜生乃至三界无量苦恼。受因缘故受无常乐。受因缘故断于善根。受因缘故获得解脱。作是观时不作受因。云何名为不作受因。谓分别受。何等受能作爱因。何等爱能作受因。善男子。众生若能如是深观爱因受因。则便能断我及我所。善男子。若人能作如是等观。则应分别爱之与受在何处灭。即见爱受有少灭处。当知亦应有毕竟灭。尔时即于解脱生信。生信心已。是解脱处何由而得。知从八正即便修习。云何名为八正道耶。是道观受有三种相。一者苦。二者乐。三者不苦不乐。如是三种俱能增长身之与心。何因缘故能增长耶。触因缘也。是触三种。一者无明触。二者明触。三者非明无明触。言明触者即八正道。其余二触增长身心及三种受。是故我应断二种触因缘。触断不生三受。善男子。如是受者亦名为因亦名为果。智者当观亦因亦果。云何为因。因受生爱。名之为因。云何名果。因触生故。名之为果。是故此受亦因亦果。智者如是观是受已。次复观爱受果报故。名之为爱。智者观爱复有二种。一者杂食。二者无食。杂食爱者因生老病死一切诸有。无食爱者断生老病死一切诸有贪无漏道。智者复当作如是念。我若生是杂食之爱。则不能断生老病死。我今虽贪无漏之道。不断受因则不能得无漏道果。是故应当先断是触。触既断已受则自灭。受既灭已爱亦随灭。是名八正道。善男子。若有众生能如是观。虽有毒身其中亦有微妙药王。如雪山中虽有毒草亦有妙药。善男子。如是众生虽从烦恼而得果报。而是果报更不复为烦恼作因。是即名为清净梵行

复次善男子。智者当观受爱二事何因缘生。知因想生。何以故。众生见色亦不生贪。及观受时亦不生贪。若于色中生颠倒想。谓色即是常乐我净。受是常恒无有变易。因是倒想生贪恚痴。是故智者应当观想。云何观想。当作是念。一切众生未得正道皆有倒想。云何倒想。于非常中生于常想。于非乐中生于乐想。于非净中生于净想。于空法中生于我想。于非男女大小昼夜岁月衣服房舍卧具。生于男女乃至卧具想。是想三种。一者小。二者大。三者无边。小因缘故生于小想。大因缘故生于大想。无量缘故生无量想。复有小想。谓未入定。复有大想。谓已入定。复有无量想。谓十一切入。复有小想。所谓欲界一切想等。复有大想。所谓色界一切想等。复有无量想。谓无色界一切想等。三想灭故受则自灭。想受灭故名为解脱。迦叶菩萨言。世尊。灭一切法名为解脱。如来云何说想受灭名解脱耶。佛言。善男子。如来或时因众生说闻者解法。或时因法说于众生。闻者亦解说于众生。云何名为因众生说闻者解法。如我先为大迦叶说。迦叶。众生灭时善法则灭。是名因众生说闻者解法。云何因法说于众生闻者亦解说于众生。如我先为阿难说言。我亦不说亲近一切法。亦复不说不亲近一切法。若法近已善法衰羸不善炽盛。如是法者不应亲近。若法近已不善衰灭善法增长。如是法者是应亲近。是名因法说于众生闻者亦解说于众生。善男子。如来虽说想受二灭。则已总说一切可断。智者既观如是想已次观想因。是无量想因何而生。知因触生。是触二种。一者因烦恼触。二者因解脱触。因无明生名烦恼触。因明生者名解脱触。因烦恼触生于倒想。因解脱触生不倒想。观想因已次观果报

迦叶菩萨白佛言。世尊。若以因此烦恼之想生于倒想。一切圣人实有倒想而无烦恼。是义云何。佛言。善男子。云何圣人而有倒想。迦叶菩萨言。世尊。一切圣人牛作牛想亦说是牛。马作马想亦说是马。男女大小舍宅车乘去来亦尔。是名倒想。善男子。一切凡夫有二种想。一者世流布想。二者着想。一切圣人唯有世流布想无有着想。一切凡夫恶觉观故。于世流布生于着想。一切圣人善觉观故。于世流布不生着想。是故凡夫名为倒想。圣人虽知不名倒想。智者如是观想因已次观果报。是恶想果在于地狱饿鬼畜生人天中受。如我因断恶觉观故。无明触断是故想断。因想断故果报亦断。智者为断如是想因修八正道。善男子。若有能作如是等观。则得名为清净梵行。善男子。是名众生毒身之中有妙药王如雪山中虽有毒草亦有妙药

复次善男子。智者观欲。欲者即是色声香味触。善男子。即是如来因中说果。从此五事生于欲耳实非欲也。善男子。愚痴之人贪求受之。于是色中生颠倒想。乃至触中亦生倒想。倒想因缘便生于受。是故世间说因倒想生十种想。欲因缘故在于世间受恶果报。以恶加于父母沙门婆罗门等。所不应作而故作之不惜身命。是故智者观是恶想因缘故生欲心。智者如是观欲因已次观果报。是欲多有诸恶果报。所谓地狱饿鬼畜生人中天上。是名观果报。若是恶想得除灭者。终不生于此欲心也。无欲心故不受恶受。无恶受故则无恶果。是故我应先断恶想。断恶想已如是等法自然而灭。是故智者为灭恶想修八正道。是则名为清净梵行。是名众生毒身之中有妙药王如雪山中虽有毒草亦有妙药

复次善男子。智者如是观是欲已次当观业。何以故。有智之人当作是念。受想触欲即是烦恼。是烦恼者能作生业不作受业。如是烦恼与业共行则有二种。一作生业。二作受业。是故智者当观于业。是业三种。谓身口意。善男子。身口二业亦名为业亦名业果。意唯名业不名为果。以业因故则名为业。善男子。身口二业名为外业意业名内。是三种业共烦恼行故作二种业。一者生业。二者受业。善男子。正业者即意业也。期业者谓身口业。先发故名意业。从意业生名身口业。是故意业得名为正。智者观业已次观业因。业因者即无明触。因无明触众生求有。求有因缘即是爱也。爱因缘故造作三种身口意业。善男子。智者如是观业因已次观果报。果报有四。一者黑黑果报。二者白白果报。三者杂杂果报。四者不黑不白不黑不白果报。黑黑果报者。作业时垢果报亦垢。白白果报者。作业时净果报亦净。杂杂果报者。作业时杂果报亦杂。不白不黑不白不黑果报者。名无漏业。迦叶菩萨白佛言。世尊。先说无漏无有果报。今云何言不白不黑果报耶。佛言。善男子。是义有二。一者亦果亦报。二者唯果非报。黑黑果报亦名为果亦名为报。黑因生故得名为果。能作因故复名为报。净杂亦尔。无漏果者因有漏生故名为果。不作他因不名为报。是故名果不名为报。迦叶菩萨白佛言。世尊。是无漏业非是黑法。何因缘故不名为白。善男子。无有报故不名为白。对治黑故故名为白。我今乃说受果报者名之为白。是无漏业不受报故。不名为白名为寂静。如是业者有定受报处。如十恶法定在地狱饿鬼畜生。十善之业定在人天。十不善法有上中下。上因缘故受地狱身。中因缘故受畜生身。下因缘故受饿鬼身。人业十善复有四种。一者下。二者中。三者上。四者上上。下因缘故生郁单越。中因缘故生弗婆提。上因缘故生瞿陀尼。上上因缘生阎浮提。有智之人作是观已即作是念。我当云何断是果报。复作是念。是业因缘无明触生。我若断除无明与触。如是业果则灭不生。是故智者为断无明触因缘故修八正道。是则名为清净梵行。善男子。是名众生毒身之中有妙药王如雪山中虽有毒。草亦有妙药

复次善男子。智者观业观烦恼已次观是二所得果报。是二果报即是苦也。既知是苦则能舍离一切受生。智者复观烦恼因缘生于烦恼。业因缘故亦生烦恼。烦恼因缘复生于业。业因缘生苦。苦因缘故生于烦恼。烦恼因缘生有。有因缘生苦。有因缘生有。有因缘生业。业因缘生烦恼。烦恼因缘生苦。苦因缘生苦。善男子。智者若能作如是观。当知是人能观业苦。何以故。如上所观。即是生死十二因缘。若人能观如是生死十二因缘。当知是人不造新业能坏故业。善男子。有智之人观地狱苦。观一地狱乃至一百三十六所。一一地狱有种种苦。皆是烦恼业因缘生。观地狱已次观饿鬼畜生等苦。作是观已。复观人天所有诸苦。如是众苦皆从烦恼业因缘生。善男子。天上虽无大苦恼事。然其身体柔软细滑。见五相时极受大苦。如地狱苦等无差别。善男子。智者深观三界诸苦皆从烦恼业因缘生。善男子。譬如坏器即易破坏。众生受身亦复如是。既受身已是众苦器。譬如大树花果繁茂众鸟能坏。如多干草小火能焚。众生受身为苦所坏亦复如是。善男子。智者若能观苦八种如圣行中。当知是人能断众苦。善男子。智者深观是八苦已次观苦因。苦因者即爱无明。是爱无明则有二种。一者求身。二者求财。求身求财二俱是苦。是故当知。爱无明者即是苦因。善男子。是爱无明则有二种。一者内。二者外。内能作业外能增长。又复内能作业外作业果。断内爱已业则得断。断外爱已果则得断。内爱能生未来世苦。外爱能生现在世苦。智者观爱即是苦因。既观因已次观果报。苦果报者即是取也。爱果名取。是取因缘即内外爱则有爱苦。善男子。智者当观爱因缘取。取因缘爱。若我能断爱取二事。则不造业受于众苦。是故智者为断受苦修八正道。善男子。若有人能如是观者。是则名为清净梵行。是名众生毒身之中有妙药王如雪山中虽有毒草亦有妙药

迦叶菩萨白佛言。世尊。云何名为清净梵行。佛言。善男子。一切法是。迦叶菩萨言。世尊。一切法者义不决定。何以故。如来或说是善不善。或时说为四念处观。或说是十二入。或说是善知识。或说是十二因缘。或说是众生。或说是正见邪见。或说十二部经。或说即是二谛。如来今乃说一切法为净梵行。悉是何等一切法耶。佛言。善哉善哉。善男子。如是微妙大涅槃经。乃是一切善法宝藏。譬如大海是众宝藏。是涅槃经亦复如是。即是一切字义秘藏。善男子。如须弥山众药根本。是经亦尔。即是菩萨戒之根本。善男子。譬如虚空是一切物之所住处。是经亦尔。即是一切善法住处。善男子。譬如猛风无能系缚。一切菩萨行是经者亦复如是。不为一切烦恼恶法之所系缚。善男子。譬如金刚无能坏者。是经亦尔。虽有外道恶邪之人不能破坏。善男子。如恒河沙无能数者如是经义亦复如是无能数者。善男子。是经典者。为诸菩萨而作法幢如帝释幢。善男子。是经即是趣涅槃城之商主也。如大导师引诸商人趣向大海。善男子。是经能为诸菩萨等作法光明。如世日月能破诸闇。善男子。是经能为病苦众生作大良药。如香山中微妙药王能治众病。善男子。是经能为一阐提杖。犹如羸人因之得起。善男子。是经能为一切恶人而作桥梁。犹如世桥能渡一切。善男子。是经能为行三有者遇烦恼热而作阴凉。如世间盖遮覆暑热。善男子。是经即是大无畏王。能坏一切烦恼恶魔。如师子王降伏众兽。善男子。是经即是大神咒师。能坏一切烦恼魔鬼。如世咒师能去魍魉。善男子。是经即是无上霜雹。能坏一切生死果报。如世雹雨坏诸果实。善男子。是经能为坏戒目者作大良药。犹如世间安阇陀药善疗眼痛。善男子。是经能住一切善法。如世间地能住众物。善男子。是经即是毁戒众生之明镜也。如世间镜见诸色像。善男子。是经能为无惭愧者而作衣服。如世衣裳障蔽形体。善男子。是经能为贫善法者作大财宝。如功德天利益贫者。善男子。是经能为渴法众生作甘露浆。如八味水充足渴者。善男子。是经能为烦恼之人而作法床。如世乏人遇安隐床。善男子。是经能为初地菩萨至十地菩萨。而作璎珞香花涂香末香烧香。清净种性具足之乘。过于一切六波罗蜜受妙乐处。如忉利天波利质多罗树。善男子。是经即是金刚利斧。能伐一切烦恼大树。即是利刀。能割习气。即是勇健能摧魔怨。即是智火。焚烦恼薪。即因缘藏。出辟支佛。即是声闻藏。生声闻人。即是一切诸天之眼。即是一切人之正道。即是一切畜生依处。即是饿鬼解脱之处。即是地狱无上之尊。即是一切十方众生无上之器。即是十方过去未来现在诸佛之父母也。善男子。是故此经摄一切法。如我先说。此经虽摄一切诸法。我说梵行即是三十七助道法。善男子。若离如是三十七品。终不能得声闻正果乃至阿耨多罗三藐三菩提果。不见佛性及佛性果。以是因缘梵行即是三十七品。何以故。三十七品性非颠倒能坏颠倒。性非恶见能坏恶见。性非怖畏能坏怖畏。性是净行能令众生毕竟造作清净梵行

迦叶菩萨白佛言。世尊。有漏之法亦复能作无漏法因。如来何故不说有漏为净梵行。善男子。一切有漏即是颠倒。是故有漏不得名为清净梵行。迦叶菩萨白佛言。世尊。世第一法为是有漏是无漏耶。佛言。善男子。是有漏也。世尊。虽是有漏性非颠倒。何故不名清净梵行。善男子。世第一法无漏因故似于无漏。向无漏故不名颠倒。善男子。清净梵行发心相续乃至毕竟。世第一法唯是一念。是故不得名净梵行。迦叶菩萨白佛言。世尊。众生五识亦是有漏。非是颠倒复非一念。何故不名清净梵行。善男子。众生五识虽非一念。然是有漏复是颠倒。增诸漏故名为有漏。体非真实着想故倒。云何名为体非真实着想故倒。非男女中生男女想。乃至舍宅车乘瓶衣亦复如是。是名颠倒。善男子。三十七品性无颠倒。是故得名清净梵行。善男子。若有菩萨。于三十七品。知根知因知摄知增知主知导知胜知实知毕竟者。如是菩萨则得名为清净梵行。迦叶菩萨白佛言。世尊。云何名为知根乃至知毕竟耶。佛言。善男子。善哉善哉。菩萨发问为于二事。一者为自知故。二者为他知故。汝今已知。但为无量众生未解启请是事。是故我今重赞叹汝。善哉善哉。善男子。三十七品根本是欲。因名明触。摄取名受。增名善思。主名为念。导名为定。胜名智慧。实名解脱。毕竟名为大般涅槃。善男子。善欲即是初发道心。乃至阿耨多罗三藐三菩提之根本也。是故我说欲为根本。善男子。如世间说一切苦恼爱为根本。一切疾病宿食为本。一切断事斗诤为本。一切恶事虚妄为本。迦叶菩萨白佛言。世尊。如来先于此经中说一切善法不放逸为本。今乃说欲。是义云何。佛言。善男子。若言生因。善欲是也。若言了因不放逸是。如世间说一切果者子为其因。或复有说子为生因地为了因。是义亦尔。迦叶菩萨言。世尊。如来先于余经中说三十七品佛是根本。是义云何。善男子。如来先说众生初知三十七品佛是根本。若自证得欲为根本。世尊。云何明触名之为因。善男子。如来或时说明为慧或说为信。善男子。信因缘故亲近善友是名为触。亲近因缘得闻正法是名为触。因闻正法身口意净是名为触。因三业净获得正命是名为触。因正命故得净根戒。因净根戒乐寂静处。因乐寂静能善思惟。因善思惟得如法住。因如法住得三十七品。能坏无量诸恶烦恼。是名为触。善男子。受名摄取。众生受时能作善恶。是故名受为摄取也。善男子。受因缘故生诸烦恼。三十七品能破坏之。是故以受为摄取也。因善思惟能破烦恼。是故名增。何以故。勤修习故得如是等三十七品。若观能破诸恶烦恼要赖专念。是故以念为主。如世间中一切四兵随主将意。三十七品亦复如是皆随念主善男子。既入定已。三十七品能善分别一切法相。是故以定为导。是三十七品分别法相智为最胜。是故以慧为胜。如是智慧知烦恼已。智慧力故烦恼消灭。如世间中四兵坏怨或一或二勇健者能。三十七品亦复如是。智慧力故能坏烦恼。是故以慧为胜。善男子。虽因修习三十七品获得四禅神通安乐亦不名实。若坏烦恼。证解脱时乃名为实。是三十七品发心修道。虽得世乐及出世乐四沙门果及以解脱。亦不得名为毕竟也。若能断除三十七品所行之事是名涅槃。是故我说毕竟者即大涅槃

复次善男子。善爱念心即是欲也。因善爱念。亲近善友故名为触。是名为因。因近善友故名为受。是名摄取。因近善友能善思惟。故名为增。因是四法能生长道。所谓欲念定智。是即名为主导胜也。因是三法得二解脱。除断爱故得心解脱。断无明故得慧解脱。是名为实。如是八法毕竟得果名为涅槃。故名毕竟

复次善男子。欲者即是发心出家。触者即是白四羯磨。是名为因。摄者即是受二种戒。一者波罗提木叉戒。二者净根戒。是名为受。是名摄取。增者即是修习四禅。主者即是须陀洹果斯陀含果。导者即是阿那含果。胜者即是阿罗汉果。实者即是辟支佛果。毕竟者即是阿耨多罗三藐三菩提果

复次善男子。欲名为识。触名六入。摄名为受。增名无明。主名名色。导名为爱。胜名为取。实名为有。毕竟者名生老病死迦叶菩萨言。世尊。根本因增。如是三法云何有异。善男子。所言根者即是初发。因者即是相似不断。增者即是灭相似已能生相似。复次善男子。根即是作。因即是果。增即可用。善男子。未来之世虽有果报。以未受故名之为因。及其受时是名为增。复次善男子。根即是求。得即是因。用即是增。善男子。是经中根即是见道。因即修道。增者即是无学道也。复次善男子。根即正因。因即方便因。从是二因获得果报。名为增长迦叶菩萨言。世尊。如佛所说。毕竟者即是涅槃。如是涅槃云何可得。善男子。若菩萨摩诃萨比丘比丘尼优婆塞优婆夷能修十想。当知是人能得涅槃。云何为十。一者无常想。二者苦想。三者无我想。四者厌离食想。五者一切世间不可乐想。六者死想。七者多过罪想。八者离想。九者灭想。十者无爱想。善男子。菩萨摩诃萨比丘比丘尼优婆塞优婆夷。修习如是十种想者。是人毕竟定得涅槃。不随他心自能分别善不善等。是名真实称比丘义乃至得称优婆夷义

迦叶菩萨言。世尊。云何名为菩萨乃至优婆夷等修无常想。善男子。菩萨二种。一初发心。二已行道。无常想者亦复二种。一粗二细。初心菩萨观无常想时作是思惟。世间之物凡有二种。一内二外。如是内物无常变异。我见生时小时大时壮时老时死时。是诸时节各各不同。是故当知内物无常。复作是念。我见众生或有肥鲜具足色力去来进止自在无碍。或见病苦色力毁悴颜貌羸损不得自在。或见财富库藏盈溢。或见贫穷触事斯乏。或见成就无量功德。或见具足无量恶法。是故定知内法无常。复观外法。子时牙时茎时叶时花时果时。如是诸时各各不同。如是外法。或有具足或不具足。是故当知一切外物定是无常。既观见法是无常已。复观闻法。我闻诸天具足成就极妙快乐神通自在。亦有五相。是故当知即是无常。复闻劫初有诸众生。各各具足上妙功德。身光自照不假日月。无常力故光灭德损。复闻昔有转轮圣王统四天下。成就七宝得大自在。而不能坏无常之相。复观大地。往昔之时安处布置无量众生。间无空处如车轮许。具足生长一切妙药。丛林树木果实滋茂。众生薄福令此大地无复势力所生之物遂成虚耗。是故当知。内外之法一切无常。是则名为粗无常也。既观粗已次观细者。云何名细。菩萨摩诃萨观于一切内外之物乃至微尘。在未来时已是无常。何以故。具足成就破坏相故。若未来色非无常者。不得言色有十时差别。云何为十。一者膜时。二者泡时。三者胞时。四者肉团时。五者肢时。六者婴孩时。七者童子时。八者少年时。九者盛壮时。十者衰老时。菩萨观膜。若非无常不应至胞。乃至盛壮非无常者终不至老。若是诸时非念念灭终不渐长。应当一时成长具足。无是事故。是故当知。定有念念微细无常。复见有人诸根具足颜色暐晔。后见枯悴复作是念。是人定有念念无常。复观四大及四威仪。复观内外各二苦因饥渴寒热。复观是四。若无念念微细无常。亦不得说如是四苦。若有菩萨能作是念。是名菩萨观细无常。如内外色心法亦尔。何以故。行六处故。行六处时。或生喜心。或生嗔心。或生爱心。或生念心。展转异生不得一种。是故当知。一切色法及非色法悉是无常。善男子。菩萨若能于一念中见一切法生灭无常。是名菩萨具无常想。善男子。智者修习无常想已。远离常慢常倒想倒

次修苦想。何因缘故有如是苦。深知是苦因于无常。因无常故受生老病死。生老病死因缘故名为无常。无常因缘故受内外苦。饥渴寒热鞭打骂辱。如是等苦皆因无常。复次智者深观此身即无常器。是器即苦。以器苦故。所受盛法亦复是苦。善男子。智者复观生即是苦灭即是苦。苦生灭故即是无常非我我所。修无我想。智者复观苦即无常无常即苦。若苦无常智者云何说言有我。苦非是我无常亦尔。如是五阴亦苦无常。众生云何说言有我。复次观一切法有异和合。不从一和合生一切法。亦非一法是一切和合果。一切和合皆无自性。亦无一性亦无异性。亦无物性亦无自在。诸法若有如是等相。智者云何说言有我。复作是念。一切法中无有一法能为作者。若使一法不能作者。众法和合亦不能作。一切诸法性终不能独生独灭。和合故灭。和合故生。是法生已众生倒想。言是和合从和合生。众生想倒无有真实。云何而有真实我耶。是故智者观于无我。又复谛观。何因缘故众生说我。是我若有应一应多。我若一者云何而有刹利婆罗门毗舍首陀人天地狱饿鬼畜生大小老壮。是故知我非是一也。我若多者云何说言众生我者是一是遍无有边际。若一若多二俱无我

智者如是观无我已。次复观于厌离食想。作是念言。若一切法无常苦空无我。云何为食起身口意三种恶业。若有众生。为贪食故起身口意三种恶业。所得财物众皆共之。后受苦果无共分者。善男子。智者复观。一切众生为饮食故身心受苦。若从众苦而得食者。我当云何于是食中而生贪着。是故于食不生贪心。复次智者当观因于饮食身得增长。我今出家受戒修道为欲舍身。今贪此食云何当得舍此身耶。如是观已虽复受食。犹如旷野食其子肉。其心厌恶都不甘乐。深观抟食有如是过。次观触食如被剥牛为无量虫之所啑食。次观思食如大火聚。识食犹如三百钻矛。善男子。智者如是观四食已。于食终不生贪乐想。若犹生贪当观不净。何以故。为离食爱故。于一切食善能分别不净之想。随诸不净令与相似。如是观已。若得好食及以恶食。受时犹如涂痈疮药。终不生于贪爱之心。善男子。智者若能如是观者。是名成就厌离食想。迦叶菩萨言。世尊。智者观。食作不净想。为是实观虚解观耶。若是实观。所观之食实非不净。若是虚解。是法云何名为善想。佛言。善男子。如是观者亦是实观亦是虚解。能坏贪食故名为实。非虫见虫故名虚解。善男子。一切有漏皆名为虚亦能得实。善男子。若有比丘。发心乞食预作是念。我当乞食。愿得好者莫得粗恶。愿必多得莫令鲜少。亦愿速得莫令迟晚。如是比丘不名于食得厌离想。所修善法日夜衰耗。不善之法渐当增长。善男子。若有比丘。欲乞食时先当愿言。令诸乞者悉得饱满。其施食者得无量福。我若得食为疗毒身修习善法利益施主。作是愿时所修善法日夜增长。不善之法渐当消灭。善男子。若有比丘能如是修。当知是人不空食于国中信施

善男子。智者具足如是四想。能修世间不可乐想。作是念言。一切世间无处不有生老病死。而我此身无处不生。若世间中无有一处当得离于生老病死。我当云何乐于世间。一切世间无有进得而不退失。是故世间定是无常。若是无常。云何智人而乐于世。一一众生周遍经历一切世间具受苦乐。虽复得受梵天之身乃至非想非非想天。命终还堕三恶道中。虽为四王乃至他化自在天身。命终生于畜生道中。或为师子虎兕豺狼象马牛驴。次观转轮圣王之身。统四天下豪贵自在。福尽贫困衣食不供。智者深观如是事已。生于世间不可乐想。智者复观世间有法。所谓舍宅衣服饮食卧具医药。香花璎珞种种伎乐财物宝货。如是等事皆为离苦。而是等物体即是苦。云何以苦欲离于苦。善男子。智者如是观已。于世间物不生爱乐而作乐想。善男子。譬如有人身婴重病。虽有种种音乐倡伎香花璎珞。终不于中生贪爱乐。智者观已亦复如是。善男子。智者深观。一切世间非归依处。非解脱处非寂静处。非可爱处非彼岸处。非是常乐我净之法。若我贪乐如是世间。我当云何得离是法。如人不乐处闇而求光明还复归闇。闇即世间。明即出世。若我乐世增长黑闇远离光明。闇即无明。光即智明。是智明因即是世间不可乐想。一切贪结虽是系缚。然我今者贪于智明不贪世间。智者深观如是法已。具足世间不可乐想

善男子。有智之人已修世间不可乐想。次修死想。观是寿命。常为无量怨仇所绕。念念损减无有增长。犹山瀑水不得停住。亦如朝露势不久停。如囚趣市步步近死。如牵牛羊诣于屠所。迦叶菩萨言。世尊。云何智者观念念灭。善男子。譬如四人皆善射术。聚在一处各射一方。俱作是念。我等四箭俱发俱堕。复有一人作是念言。如是四箭及其未堕。我能一时以手接取。善男子。如是之人可说疾不。迦叶菩萨言。如是世尊。佛言。善男子。地行鬼疾复速是人。有飞行鬼复速地行。四天王疾复速飞行。日月神天复速四王。行坚疾天复速日月。众生寿命复速坚疾。善男子。一息一眴众生寿命四百生灭。智者若能观命如是。是名能观念念灭也善男子。智者观命系属死王。我若能离如是死王。则得永断无常寿命。复次智者观。是寿命犹如河岸临峻大树。亦如有人作大逆罪及其受戮无怜惜者。如师子王大饥困时。亦如毒蛇吸大风时。犹如渴马护惜水时。如大恶鬼嗔恚发时。众生死王亦复如是。善男子。智者若能作如是观。是则名为修习死想。善男子。智者复观。我今出家设得寿命七日七夜。我当于中精勤修道护持禁戒说法教化利益众生。是名智者修于死想。复以七日七夜为多。若得六日五日四日三日二日一日一时乃至出息入息之顷。我当于中精勤修道护持禁戒说法教化利益众生。是名智者善修死想。智者具足如上六想。即七想因。何等名七。一者常修想。二者乐修想。三者无嗔想。四者无妒想。五者善愿想。六者无慢想。七者三昧自在想。善男子。若有比丘具足七想。是名沙门名婆罗门。是名寂静是名净洁。是名解脱。是名智者。是名正见名到彼岸。名大医王是大商主。是名善解如来秘密。亦知诸佛七种之语名正见知。断七种语中所生疑网。善男子。若人具足如上六想。当知是人能呵三界。远离三界灭除三界。于三界中不生爱着。是名智者具足十想。若有比丘具足十想。即得称可沙门之相。尔时迦叶菩萨即于佛前。以偈赞佛

  怜愍世间大医王　　身及智慧俱寂静
  无我法中有真我　　是故敬礼无上尊
  发心毕竟二不别　　如是二心先心难
  自未得度先度他　　是故我礼初发心
  初发已为人天师　　胜出声闻及缘觉
  如是发心过三界　　是故得名最无上
  世救要求然后得　　如来无请而为师
  佛随世间如犊子　　是故得名大悲牛
  如来功德满十方　　凡下无智不能赞
  我今赞叹慈悲心　　为报身口二种业
  世间常乐自利益　　如来终不为是事
  能断众生世果报　　是故我礼自他和
  世间逐亲作益厚　　如来利益无怨亲
  佛无是相如世人　　是故其心等无二
  世间说异作业异　　如来如说业无差
  凡所修行断诸行　　是故得名为如来
  先已了知烦恼过　　示现处之为众生
  久于世间得解脱　　乐处生死慈悲故
  虽现天身及人身　　慈悲随逐如犊子
  如来即是众生母　　慈心即是小犊子
  自受众苦念众生　　愍悲念时心不悔
  怜愍心盛不觉苦　　故我稽首拔苦者
  如来虽作无量福　　身口意业恒清净
  常为众生不为己　　是故我礼清净业
  如来受苦不觉苦　　见众生苦如己苦
  虽为众生处地狱　　不生苦想及悔心
  一切众生受异苦　　悉是如来一人苦
  觉已其心转坚固　　故能勤修无上道
  佛具一味大慈心　　愍念众生如子想
  众生不知佛能救　　故谤如来及法僧
  世间虽具众烦恼　　亦有无量诸过恶
  如是众结及罪过　　佛初发心已能坏
  唯有诸佛能赞佛　　除佛无能赞叹者
  我今唯以一法赞　　所谓慈心游世间
  如来是慈大法聚　　是慈亦能度众生
  即是无上真解脱　　解脱即是大涅槃

大般涅槃经卷第三十四大般涅槃经卷第三十五

        宋代沙门慧严等依泥洹经加之

    憍陈如品第二十五之一

尔时世尊告憍陈如。色是无常。因灭是色获得解脱常住之色。受想行识亦是无常。因灭是识获得解脱常住之识。憍陈如。色即是苦。因灭是色获得解脱安乐之色。受想行识亦复如是。憍陈如。色即是空。因灭空色获得解脱非空之色。受想行识亦复如是。憍陈如。色是无我。因灭是色获得解脱真我之色。受想行识亦复如是。憍陈如。色是不净。因灭是色获得解脱清净之色。受想行识亦复如是。憍陈如。色是生老病死之相。因灭是色获得解脱非生老病死相之色。受想行识亦复如是。憍陈如。色是无明因。因灭是色获得解脱非无明因色。受想行识亦复如是。憍陈如。乃至色是生因。因灭是色获得解脱非生因色。受想行识亦复如是。憍陈如。色者即是四颠倒因。因灭倒色获得解脱非四倒因色。受想行识亦复如是。憍陈如。色是无量恶法之因。所谓男女等身食爱欲爱。贪嗔嫉妒恶心悭心。抟食识食思食触食。卵生胎生湿生化生。五欲五盖。如是等法皆因于色。因灭色故获得解脱无如是等无量恶色。受想行识亦复如是。憍陈如。色即是缚。因灭缚色获得解脱无缚之色。受想行识亦复如是。憍陈如色即是流。因灭流色获得解脱非流之色。受想行识亦复如是。憍陈如。色非归依。因灭是色获得解脱归依之色。受想行识亦复如是。憍陈如。色是疮疣。因灭是色获得解脱无疮疣色。受想行识亦复如是。憍陈如。色非寂静。因灭是色获得涅槃寂静之色。受想行识亦复如是。憍陈如。若有人能如是知者。是名沙门名婆罗门。具足沙门婆罗门法。憍陈如。若离佛法无有沙门无婆罗门。亦无沙门婆罗门法。一切外道虚假诈称都无实行。虽复作相言有是二。实无是处。何以故。若无沙门婆罗门法。云何而言有沙门婆罗门。我常于此大众之中作师子吼。汝等亦当在大众中作师子吼

尔时外道有无量人。闻是语已心生嗔恶。瞿昙今说我等众中无有沙门及婆罗门。亦无沙门婆罗门法。我当云何广设方便语瞿昙言我等众中亦有沙门有沙门法。有婆罗门有婆罗门法。时彼众中有一梵志。唱如是言。诸仁者。瞿昙之言如狂无异。何可捡校。世间狂人或歌或舞或哭或笑或骂或赞。于怨亲所不能分别。沙门瞿昙亦复如是。或说我生净饭王家。或言不生。或说生已行至七步。或说不行。或说从小习学世事。或说我是一切智人。或时处宫受乐生子。或时厌患呵责恶贱。或时亲修苦行六年。或时呵责外道苦行。或言从彼郁头蓝弗阿罗逻等禀承未闻。或时说其无所知晓。或时说言菩提树下得阿耨多罗三藐三菩提。或时说言我不至树无所克获。或时说言我今此身即是涅槃。或言身灭乃是涅槃。瞿昙所说如狂无异。何故以此而愁愦耶。诸婆罗门即便答言。大士。我等今者何得不愁。沙门瞿昙先出家已。说无常苦空无我不净。我诸弟子闻生恐怖。云何众生无常苦空无我不净不受其语。今者瞿昙复来至此娑罗林中。为诸大众说有常乐我净之法。我诸弟子闻是语已。悉舍我去受瞿昙语。以是因缘生大愁苦。尔时复有一婆罗门。作如是言。诸仁者。谛听谛听。瞿昙沙门名修慈悲。是言虚妄非真实也。若有慈悲云何教我诸弟子等自受其法。慈悲果者随顺他意。今违我愿。云何言有。若有说言沙门瞿昙不为世间八法所染。是亦虚妄。若言瞿昙少欲知足。今者云何夺我等利。若言种姓是上族者。是亦虚妄。何以故。从昔已来不见不闻大师子王残害小鼠。若使瞿昙是上种姓。如何今者恼乱我等。若言瞿昙具大势力。是亦虚妄。何以故。从昔已来亦不见闻金翅鸟王与乌共诤。若言力大。复以何事与我共斗。若言瞿昙具他心智。是亦虚妄。何以故。若具此智。以何因缘不知我心。诸仁者。我昔曾从先旧智人闻说是事。过百年已世间当有一妖幻出。即是瞿昙。如是妖惑今于此处娑罗林中将灭不久。汝等今者不应愁恼。尔时复有一尼犍子答言。仁者。我今愁苦不为自身弟子供养。但为世间痴闇无眼。不识福田及非福田。弃舍先旧智婆罗门供养年少。以为愁耳。瞿昙沙门大知咒术。因咒术力能令一身作无量身。令无量身还作一身。或以自身作男女像牛羊象马。我力能灭如是咒术。瞿昙沙门咒术既灭。汝等当还多得供养受于安乐。尔时复有一婆罗门。作如是言。诸仁者。瞿昙沙门成就具足无量功德。是故汝等不应与诤。大众答言。痴人。云何说言沙门瞿昙具大功德。其生七日母便命终。是可得名福德相耶。婆罗门言。骂时不嗔打时不报。当知即是大福德相。其身具足三十二相八十种好无量神通。是故当知是福德相。心无憍慢先意问讯。言语柔软初无粗犷。年志俱盛心不卒暴。王国多财无所爱恋。舍之出家如弃涕唾。是故我说沙门瞿昙成就具足无量功德。大众答言。善哉仁者。瞿昙沙门实如所说成就无量神通变化。我不与彼捔试是事。瞿昙沙门受性柔软不堪苦行。生长深宫不综外事。唯可软语。不知伎艺书籍论议。请共详辩正法之要。彼若胜我我当给事。我若胜彼彼当事我

尔时多有无量外道。和合共往摩伽陀王阿阇世所。王见便问。诸仁者。汝等各各修习圣道是出家人。舍离财货及在家事。我国人民皆共供养。敬心瞻视无相犯触。何故和合而来至此。诸仁者。汝等各受异法异戒出家不同。亦复各各自随戒法出家修道。何因缘故。今者一心而共和合。犹如叶落旋风所吹聚在一处。说何因缘而来至此。我常拥护出家之人。乃至不惜身之与命。尔时一切诸外道众。咸作是言。大王谛听。大王今者。是大法桥。是大法砺。是大法秤。即是一切功德之器。一切功德真实之性。正法道路。即是种子之良田也。一切国土之根本也。一切国土之明镜也。一切诸天之形像也。一切国人之父母也。大王。一切世间功德宝藏即是王身。何以故。名功德藏。王断国事不择怨亲。其心平等如地水火风。是故名王为功德藏。大王。现在众生虽复寿短。王之功德如昔长寿安乐时王。亦如顶生善见忍辱那睺沙王。耶耶帝王。尸毗王。一叉鸠王。如是等王具足善法。大王今者亦复如是。大王。以王因缘国土安乐人民炽盛。是故一切出家之人慕乐此国。持戒精勤修习正道。大王。我经中说。若出家人随所住国。持戒精进勤修正道。其王亦有修善之分。大王。一切盗贼王已整理。出家之人都无畏惧。今者唯有一大恶人瞿昙沙门。王未捡校。我等甚畏。其人自恃豪族种姓身色具足。又因过去布施之报多得供养。恃此众事生大憍慢。或因咒术而生憍慢。以是因缘不能苦行。受畜细软衣服卧具。是故一切世间恶人。为利养故往集其所。而为眷属不能苦行。咒术力故。调伏迦叶及舍利弗目犍连等。今复来至我所住处娑罗林中。宣说是身常乐我净诱我弟子。大王。瞿昙先说无常无乐无我无净。我能忍之。今乃宣说常乐我净。我实不忍。惟愿大王。听我与彼瞿昙论议。王即答言。诸大士。汝等今者为谁教导。而令其心狂乱不定。如水涛波旋火之轮猿猴掷树。是事可耻。智人若闻即生怜愍。愚人闻之即生嗤笑。汝等所说非出家相。汝若病风黄水患者。吾悉有药能疗治之。如其鬼病家兄耆婆善能去之。汝等今者欲以手爪刨须弥山。欲以口齿齰啮金刚。诸大士。譬如愚人见师子王饥时睡眠而欲悟之。如人以指置毒蛇口。如欲以手触灰覆火。汝等今者亦复如是。善男子。譬如野狐作师子吼。犹如蚊子共金翅鸟捔行迟疾。如兔渡海欲尽其底。汝等今者亦复如是。汝若梦见胜瞿昙者。是梦狂惑未足可信。诸大士。汝等今者兴建是意。犹如飞蛾投大火聚。汝随我语不须更说。汝虽赞我平等如秤。勿令外人复闻此语。尔时外道复作是言。大王。瞿昙沙门所作幻术到汝边耶。乃令大王心疑不信是等圣人。大王。不应轻蔑如是大士。大王。是月增减。大海碱味。摩罗延山。如是等事谁之所作。岂非我等婆罗门耶。大王。不闻阿竭多仙十二年中恒河之水停耳中耶。大王。不闻瞿昙仙人大现神通十二年中变作释身。并令释身作羝羊形作千女根在释身耶。大王。不闻耆[少/兔]仙人一日之中饮四海水令大地干耶。大王。不闻婆薮仙人为自在天作三眼耶。大王。不闻罗逻仙人变迦富罗城作卤(他本作国)土耶。大王。婆罗门中有如是等大力诸仙现可捡校。大王。云何见轻蔑耶。王言。诸仁者。若不见信故欲为者如来正觉今者近在娑罗林中。汝等可往随意问难。如来亦当为汝分别称汝意答

尔时阿阇世王与诸外道徒众眷属。往至佛所头面作礼右绕三匝。修敬已毕却住一面。白佛言。世尊。是诸外道欲随意问难。唯愿如来随意答之。佛言。大王。且止我自知时

尔时众中有婆罗门名阇提首那。作如是言。瞿昙。汝说涅槃是常法耶。如是如是。大婆罗门。婆罗门言。瞿昙。若说涅槃常者。是义不然。何以故。世间之法从子生果相续不断。如从埿出瓶从缕得衣。瞿昙常说修无常想获得涅槃。因是无常果云何常。瞿昙又说。解脱欲贪即是涅槃。解脱色贪及无色贪即是涅槃。灭无明等一切烦恼即是涅槃。从欲乃至无明烦恼皆是无常。因是无常。所得涅槃亦应无常。瞿昙又说。从因故生天。从因故堕地狱。从因得解脱。是故诸法皆从因生。若从因故得解脱者。云何言常。瞿昙亦说。色从缘生故名无常。受想行识亦复如是。如是解脱若是色者当知无常。受想行识亦复如是。若离五阴有解脱者。当知解脱即是虚空。若是虚空不得说言从因缘生。何以故。是常是一遍一切处。瞿昙亦说。从因生者。即是苦也。若是苦者云何复说解脱是乐。瞿昙又说。无常即苦苦即无我。若是无常苦无我者即是不净。一切从因所生诸法。皆无常苦无我不净。云何复说涅槃即是常乐我净。若瞿昙说亦常无常亦苦亦乐亦我无我亦净不净。如是岂非是二语耶。我亦曾从先旧智人闻说是语。佛若出世。言则无二。瞿昙今者说于二语。复言佛即我身是也。是义云何。佛言。婆罗门。如汝所说。我今问汝随汝意答。婆罗门言。善哉瞿昙。佛言。婆罗门。汝性常耶是无常乎。婆罗门言。我性是常。婆罗门。是性能作一切内外法之因耶。如是瞿昙。佛言。婆罗门。云何作因。瞿昙。从性生大。从大生慢。从慢生十六法。所谓地水火风空五知根。眼耳鼻舌身五业根。手脚口声男女二根心平等根。是十六法从五法生。色声香味触。是二十一法。根本有三。一者染。二者粗。三者黑。染者名爱。粗者名嗔。黑名无明。瞿昙。是二十四法皆因性生。婆罗门。是大等法常无常耶。瞿昙。我法性常。大等诸法悉是无常。婆罗门。如汝法中因常果无常。然我法中因虽无常果是常者有何等过。婆罗门。汝等法中有二因不。答言有。佛言云何为二。婆罗门言。一者生因。二者了因。佛言。云何生因。云何了因。婆罗门言。生因者如埿出瓶。了因者如灯照物。佛言。是二种因因性是一。若是一者。可令生因作于了因。可令了因作生因不。不也瞿昙。佛言。若使生因不作了因了因不作生因。可得说言是因相不。婆罗门言。虽不相作故有因相。婆罗门。了因所了即同了不。不也瞿昙。佛言。我法虽从无常获得涅槃而非无常。婆罗门。从了因得故常乐我净。从生因得故无常无乐无我无净。是故如来所说有二。如是二语无有二也。是故如来名无二语。如汝所说。曾从先旧智人边闻。佛出于世无有二语。是言善哉。一切十方三世诸佛所说无差。是故说言佛无二语。云何无差。有同说有无同说无。故名一义。婆罗门。如来世尊虽名二语为了一语故。云何二语了于一语。如眼色二语生识一语。乃至意法亦复如是。婆罗门言。瞿昙。善能分别如是语义。我今未解所出二语了于一语。尔时世尊即为宣说四真谛法。婆罗门。言苦谛者亦二亦一。乃至道谛亦二亦一。婆罗门言。世尊。我已知已。佛言。善男子。云何知已。婆罗门言。世尊。苦谛一切凡夫二是圣人一。乃至道谛亦复如是。佛言。善哉已解。婆罗门言。世尊。我今闻法已得正见。今当归依佛法僧宝。唯愿大慈听我出家。尔时世尊告憍陈如。汝当为是阇提首那。剃除须发听其出家。时憍陈如即受佛敕为其剃发。即下手时有二种落。一者鬓发。二者烦恼。即于坐处得阿罗汉果

复有梵志。姓婆私吒。复作是言。瞿昙所说涅槃常耶。如是梵志。婆私吒言。瞿昙。将不说无烦恼为涅槃耶。如是梵志。婆私吒言。瞿昙。世间四种名之为无。一者未出之法名之为无。如瓶未出埿时名为无瓶。二者已灭之法名之为无。如瓶坏已名为无瓶。三者异相互无名之为无。如牛中无马马中无牛。四者毕竟无故名之为无。如龟毛兔角。瞿昙。若以除烦恼已名涅槃者。涅槃即无。若是无者云何言有常乐我净。佛言。善男子。如是涅槃非是先无同埿时瓶。亦非灭无同瓶坏无。亦非毕竟无如龟毛兔角同于异无。善男子。如汝所言。虽牛中无马不可说言牛亦是无。虽马中无牛亦不可说马亦是无。涅槃亦尔。烦恼中无涅槃。涅槃中无烦恼。是故名为异相互无。婆私吒言。瞿昙。若以异无为涅槃者。夫异无者无常乐我净。瞿昙。云何说言涅槃常乐我净。佛言。善男子。如汝所说是异无者有三种无。牛马悉是先无后有。是名先无。已有还无。是名坏无。异相无者。如汝所说。善男子。是三种无涅槃中无。是故涅槃常乐我净。如世病人。一者热病。二者风病。三者冷病。是三种病三药能治。有热病者苏能治之。有风病者油能治之。有冷病者蜜能治之。是三种药能治如是三种恶病。善男子。风中无油油中无风。乃至蜜中无冷冷中无蜜。是故能治。一切众生亦复如是有三种病。一者贪。二者嗔。三者痴。如是三病有三种药。不净观者能为贪药。慈心观者能为嗔药。观因缘智能为痴药。善男子。为除贪故作非贪观。为除嗔故作非嗔观。为除痴故作非痴观。三种病中无三种药。三种药中无三种病。善男子。三种病中无三药故。无常无我无乐无净。三种药中无三种病。是故得称常乐我净。婆私吒言。世尊。如来为我说常无常。云何为常。云何无常。佛言。善男子。色是无常。解脱色常。乃至识是无常。解脱识常。善男子。若有善男子善女人。能观色乃至识是无常者。当知是人获得常法。婆私吒言。世尊。我今已知常无常法。佛言。善男子。汝云何知常无常法。婆私吒言。世尊。我今知我色是无常得解脱常。乃至识亦如是。佛言。善男子。汝今善哉已报是身。告憍陈如。是婆私吒已证阿罗汉果。汝可施其三衣钵器。时憍陈如如佛所敕施其衣钵。时婆私吒受衣钵已。作如是言。大德憍陈如。我今因是弊恶之身得善果报。唯愿大德。为我屈意至世尊所具宣我心。我既恶人触犯如来尔瞿昙姓。唯愿为我忏悔此罪。我亦不能久住毒身。今入涅槃。时憍陈如即往佛所。作如是言。世尊。婆私吒比丘生惭愧心。自言顽嚚触犯如来尔瞿昙姓。不能久住是毒蛇身。今欲灭身寄我忏悔。佛言。憍陈如。婆私吒比丘已于过去无量佛所成就善根。今受我语如法而住。如法住故获得正果。汝等应当供养其身。尔时憍陈如从佛闻已。还其身所而设供养。时婆私吒于焚身时作种种神足。诸外道辈见是事已。高声唱言。是婆私吒已得瞿昙沙门咒术。是人不久复当胜彼瞿昙沙门

尔时众中复有梵志。名曰先尼。复作是言。瞿昙。有我耶。如来默然。瞿昙。无我耶。如来默然。第二第三亦如是问。佛皆默然。先尼言。瞿昙。若一切众生有我遍一切处是一作者。瞿昙。何故默然不答。佛言。先尼。汝说是我遍一切处耶。先尼答言。瞿昙。不但我说一切智人亦如是说。佛言。善男子。若我周遍一切处者。应当五道一时受报。若有五道一时受报。汝等梵志何因缘故。不造众恶为遮地狱。修诸善法为受天身。先尼言。瞿昙。我法中我则有二种。一作身我。二者常身我。为作身我修离恶法不入地狱。修诸善法生于天上。佛言。善男子。如汝说我遍一切处。如是我者若作身中当知无常。若作身无云何言遍。瞿昙。我所立我亦在作中亦是常法。瞿昙。如人失火烧舍宅时。其主出去。不可说言舍宅被烧主亦被烧。我法亦尔。而此作身虽是无常。当无常时我则出去。是故我我亦遍亦常。佛言。善男子。如汝说我亦遍亦常。是义不然。何以故。遍有二种。一者常。二者无常。复有二种。一色。二无色。是故若言一切有者。亦常亦无常。亦色亦无色。若言舍主得出不名无常。是义不然。何以故。舍不名主主不名舍。异烧异出故得如是。我则不尔。何以故。我即是色色即是我。无色即我我即无色。云何而言色无常时我则得出。善男子。汝意若谓一切众生同一我者。如是即违世出世法。何以故。世间法名父母子女。若我是一。父即是子子即是父。母即是女女即是母。怨即是亲亲即是怨。此即是彼彼即是此。是故若说一切众生同一我者。是即违背世出世法。先尼言。我亦不说一切众生同于一我。乃说一人各有一我。佛言。善男子。若言一人各有一我。是为多我。是义不然。何以故。如汝先说我遍一切。若遍一切一切众生业根应同。天得见时佛得亦见。天得作时佛得亦作。天得闻时佛得亦闻。一切诸法皆亦如是。若天得见非佛得见者。不应说我遍一切处。若不遍者是即无常。先尼言。瞿昙。一切众生我遍一切。法与非法不遍一切。以是义故。佛得作异天得作异。是故瞿昙。不应说言佛得见时天得应见。佛得闻时天得应闻。佛言。善男子。法与非法非业作耶。先尼言。瞿昙。是业所作。佛言。善男子。若法非法是业作者。即是同法。云何言异。何以故。佛得业处有天得我。天得业处有佛得我。是故佛得作时天得亦作。法与非法亦应如是。善男子。是故一切众生法与非法若如是者。所得果报亦应不异。善男子。从子出果是子终不思惟分别。我唯当作婆罗门果。不与刹利毗舍首陀而作果也。何以故。从子出果终不障碍如是四姓。法与非法亦复如是不能分别我唯当与佛得作果。不与天得作果。作天得果。不作佛得果。何以故。业平等故。先尼言。瞿昙。譬如一室有百千灯炷虽有异明则无差。灯。炷别异喻法非法。其明无差喻众生我。佛言。善男子。汝说灯明以喻我者。是义不然。何以故。室异灯异。是灯光明亦在炷边亦遍室中。汝所言我若如是者。法非法边俱应有我。我中亦应有法非法。若法非法无有我者。不得说言遍一切处。若俱有者何得复以炷明为喻。善男子。汝意若谓炷之与明真实别异。何因缘故炷增明盛炷枯明灭。是故不应以法非法喻于灯炷光明无差喻于我也。何以故。法非法我三事即一。先尼言。瞿昙。汝引灯喻是事不吉。何以故。灯喻若吉我已先引。如其不吉何故复说。善男子。我所引喻都亦不作吉以不吉随汝意说。是喻亦说离炷有明。即炷有明。汝心不等故说灯炷喻法非法。明则喻我。是故责汝。炷即是明离炷有明。法即有我我即有法。非法即我我即非法。汝今何故。但受一边不受一边。如是喻者于汝不吉。是故我今还以教汝。善男子。如是喻者即是非喻。是非喻故于我即吉于汝不吉。善男子。汝意若谓若我不吉汝亦不吉。是义不然。何以故。见世间人自刀自害自作他用。汝所引喻亦复如是。于我则吉于汝不吉。先尼言。瞿昙。汝先责我心不平等。今汝所说亦不平等。何以故。瞿昙。今者以吉向己不吉向我。以是推之真是不平。佛言。善男子。如我不平能破汝不平。是故汝平我之不平即是吉也。我之不平破汝不平。令汝得平即是我平。何以故。同诸圣人得平等故。先尼言。瞿昙。我常是平。汝云何言坏我不平。一切众生平等有我。云何言我是不平耶。善男子。汝亦说言当受地狱。当受饿鬼。当受畜生。当受人天。我若先遍五道中者。云何方言当受诸趣。汝亦说言。父母和合然后生子。若子先有云何复言和合已有。是故一人有五趣身。若是五处先有身者。何因缘故为身造业。是故不平。善男子。汝意若谓我是作者。是义不然。何以故。若我作者何因缘故自作苦事。然今众生实有受苦。是故当知我非作者。若言是苦非我所作不从因生。一切诸法亦当如是不从因生。何因缘故说我作耶。善男子。众生苦乐实从因缘。如是苦乐能作忧喜。忧时无喜喜时无忧。或喜或忧。智人云何说是常耶。善男子。汝说我常。若是常者云何说有十时别异。常法不应有歌罗逻时乃至老时。虚空常法尚无一时况有十时。善男子。我者非是歌罗逻时乃至老时。云何说有十时别异。善男子。若我作者是我亦有盛时衰时。众生亦有盛时衰时。若我尔者云何是常。善男子。我若作者云何一人有利有钝。善男子。我若作者是我能作身业口业意业。若是我所作者云何口说无有我耶。云何自疑有耶无耶。善男子。汝意若谓离眼有见。是义不然。何以故。若离眼已别有见者何须此眼。乃至身根亦复如是。汝意若谓我虽能见要因眼见。是亦不然。何以故。如有人言。须曼那花能烧大村。云何能烧。因火能烧。汝立我见亦复如是。先尼言。瞿昙。如人执镰则能刈草。我因五根见闻至触亦复如是。善男子。人镰各异。是故执镰能有所作。离根之外更无别我。云何说言我因诸根能有所作。善男子。汝意若谓执镰能刈我亦如是。是我有手耶为无手乎。若有手者何不自执。若无手者云何说言我是作者。善男子。能刈草者即是镰也。非我非人。若我人能何故因镰。善男子。人有二业。一则执草。二者执镰。是镰唯有能断之功。众生见法亦复如是。眼能见色从和合生。若从因缘和合见者。智人云何说言有我。善男子。汝意若谓身作我受。是义不然。何以故。世间不见天得作业佛得受果。若言不是身作我非因受。汝等何故从于因缘求解脱耶。汝先是身非因缘生得解脱已。亦应非因而更生身。如身一切烦恼亦应如是。先尼言。瞿昙。我有二种。一者有知。二者无知。无知之我能得于身。有知之我能舍离身。犹如坏瓶既被烧已失于本色更不复生。智者烦恼亦复如是。既灭坏已更不复生。佛言。善男子。所言知者智能知耶我能知乎。若智能知何故说言我是知耶。若我知者何故方便更求于智。汝意若谓我因智知同花喻坏。善男子。譬如刺树性自能刺。不得说言树执刺刺。智亦如是。智自能知云何说言我执智知。善男子。如汝法中我得解脱。无知我得知我得耶。若无知得当知犹故具足烦恼。若知得者当知已有五情诸根。何以故。离根之外别更无知。若具诸根云何复名得解脱耶。若言是我其性清净离于五根。云何说言遍五道有。以何因缘为解脱故修诸善法。善男子。譬如有人拔虚空刺。汝亦如是。我若清净云何复言断诸烦恼。汝意若谓不从因缘获得解脱。一切畜生何故不得。先尼言。瞿昙。若无我者谁能忆念。佛告先尼。若有我者何缘复忘。善男子。若念是我者何因缘故念于恶念。念所不念不念所念。先尼复言。瞿昙。若无我者谁见谁闻。佛言。善男子。内有六入外有六尘。内外和合生六种识。是六种识因缘得名。善男子。譬如一火因木得故名为木火。因草得故名为草火。因糠得故名为糠火。因牛粪得名牛粪火。众生意识亦复如是。因眼因色因明因欲名为眼识。善男子。如是眼识不在眼中乃至欲中。四事和合故生是识。乃至意识亦复如是。若是因缘和合故生智。不应说见即是我乃至触即是我。善男子。是故我说眼识乃至意识一切诸法即是幻也。云何如幻。本无今有已有还无。善男子。譬如苏面蜜姜胡椒荜茇蒲萄胡桃石榴桵子如是和合名欢喜丸。离是和合无欢喜丸。内外六入是名众生我人士夫。离内外入无别众生我人士夫。先尼言。瞿昙。若无我者云何说言我见我闻我苦我乐我忧我喜。佛言。善男子。若言我见我闻名有我者。何因缘故世间复言汝所作罪非我见闻。善男子。譬如四兵和合名军。如是四兵不名为一。而亦说言我军勇健我军胜彼。是内外入和合所作亦复如是。虽不是一亦得说言我作我受我见我闻我苦我乐。先尼言。瞿昙。如汝所言。内外和合谁出声言我作我受。佛言。先尼。从爱无明因缘生业。从业生有。从有出生无量心数。心生觉观。觉观动风。风随心触喉舌齿唇。众生想倒声出说言我作我受我见我闻。善男子。如幢头铃。风因缘故便出音声。风大声大风小声小无有作者。善男子。譬如热铁投之水中出种种声。是中真实无有作者。善男子。凡夫不能思惟分别如是事故。说言有我及有我所我作我受。先尼言。如瞿昙说无我我所。何缘复说常乐我净。佛言。善男子。我亦不说内外六入及六识意常乐我净。我乃宣说灭内外入所生六识名之为常。以是常故名之为我。有常我故名之为乐。常我乐故名之为净。善男子。众生厌苦断是苦因。自在远离是名为我。以是因缘我今宣说常乐我净。先尼言。世尊。唯愿大慈为我宣说。我当云何获得如是常乐我净。佛言。善男子。一切世间从本已来具足大慢能增长慢。亦复造作慢因慢业是故今者受慢果报。不能远离一切烦恼得常乐我净。若诸众生欲得远离一切烦恼。先当离慢。先尼言。世尊。如是如是。诚如圣教。我先有慢。因慢因缘故称如来尔瞿昙姓。我今已离如是大慢。是故诚心启请求法。云何当得常乐我净。佛言。善男子。谛听谛听。今当为汝分别解说。善男子。若能非自非他非众生者远离是法。先尼言。世尊。我已知解得正法眼。佛言。善男子。汝云何知已解已得正法眼。世尊。所言色者非自非他非诸众生。乃至识亦复如是。我如是观得正法眼。世尊。我今甚乐出家修道。愿见听许。佛言。善来比丘。即时具足清净梵行证阿罗汉果

外道众中复有梵志姓迦叶氏。复作是言。瞿昙。身即是命身异命异。如来默然。第二第三亦复如是。梵志复言。瞿昙。若人舍身未得后身。于其中间岂可不名身异命异。若是异者瞿昙何故默然不答。善男子。我说身命皆从因缘非不因缘。如身命一切法亦如是。梵志复言。瞿昙。我见世间有法不从因缘。佛言。梵志。汝云何见世间有法不从因缘。梵志言。我见大火焚烧榛木风吹绝焰堕在余处。是岂不名无因缘耶。佛言。善男子。我说是火亦从因生非不从因。梵志言。瞿昙。绝焰去时不因薪炭。云何而言因于因缘。佛言。善男子。虽无薪炭因风而去。风因缘故其焰不灭。瞿昙。若人舍身未得后身。中间寿命谁为因缘。佛言。梵志。无明与爱而为因缘。是无明爱二因缘故寿命得住。善男子。有因缘故身即是命命即是身。有因缘故身异命异。智者不应一向而说身异命异。梵志言。世尊。唯愿为我分别解说。令我了了得知因果。佛言。梵志因即五阴果亦五阴。善男子。若有众生不然火者是则无烟。梵志言。世尊。我已知已我已解已。佛言。善男子。汝云何知云何解。世尊。火即烦恼。能于地狱饿鬼畜生人天烧然。烟者即是烦恼果报。无常不净臭秽可恶。是故名烟。若有众生不作烦恼。是人则无烦恼果报。是故如来说不然火则无有烟。世尊。我已正见。唯愿慈矜听我出家。尔时世尊告憍陈如。听是梵志出家受戒。时憍陈如受佛敕已。和合众僧听其出家受具足戒。经五日已得阿罗汉果

外道众中复有梵志。名曰富那。复作是言。瞿昙。汝见世间是常法已说言常耶。如是义者实耶虚耶。常无常亦常无常非常非无常。有边无边亦有边亦无边。非有边非无边。是身是命身异命异。如来灭后如去不如去亦如去不如去非如去非不如去。佛言。富那。我不说世间常虚实常无常亦常无常非常非无常。有边无边亦有边无边非有边非无边。是身是命身异命异。如来灭后如去不如去亦如去不如去非如去非不如去。富那复言。瞿昙。今者见何罪过不作是说。佛言。富那。若有人说世间是常唯此为实余妄语者。是名为见。见所见处是名见行。是名见业是名见着。是名见缚是名见苦。是名见取是名见怖。是名见热。是名见缠。富那。凡夫之人为见所缠。不能远离生老病死。回流六趣受无量苦。乃至非如去非不如去亦复如是。富那。我见是见有如是过。是故不着不为人说。瞿昙。若见如是罪过不着不说。瞿昙。今者何见何着何所宣说。佛言。善男子。夫见著者名生死法。如来已离生死法故。是故不着。善男子。如来名为能见能说不名为着。瞿昙。云何能见。云何能说。佛言。善男子。我能明见苦集灭道。分别宣说如是四谛。我见如是故能远离一切见一切爱一切流一切慢。是故我具清净梵行无上寂静获得常身。是身亦非东西南北。富那言。瞿昙。何因缘故常身非是东西南北。佛言。善男子。我今问汝随汝意答。于意云何。善男子。如于汝前然大火聚。当其然时汝知然不。如是瞿昙。是火灭时汝知灭不。如是瞿昙富那。若有人问汝。前火聚然从何来灭何所至。当云何答。瞿昙。若有问者我当答言。是火生时赖于众缘。本缘。已尽新缘未至是火则灭。若复有问。是火灭已至何方面。复云何答。瞿昙。我当答言。缘尽故灭不至方所。善男子。如来亦尔。若有无常色乃至无常识因爱故然。然者即受二十五有。是故然时可说是火东西南北。现在爱灭二十五有果报不然。以不然故不可说有东西南北。善男子。如来已灭无常之色至无常识。是故身常。身若是常不得说有东西南北。富那言。请说一喻唯愿听采。佛言。善哉善哉。随意说之。世尊。如大村外有娑罗林。中有一树先林而生足一百年。是时林主灌之以水随时修治。其树陈朽皮肤枝叶悉皆脱落唯贞实在。如来亦尔。所有陈故悉已除尽。唯有一切真实法在。世尊。我今甚乐出家修道。佛言。善来比丘。说是语已。即时出家漏尽证得阿罗汉果

大般涅槃经卷第三十五大般涅槃经卷第三十六

        宋代沙门慧严等依泥洹经加之

    憍陈如品下

复有梵志名曰清净浮。作如是言。瞿昙。一切众生不知何法。见世间常无常亦常无常非有常非无常乃至非如去非不如去。佛言。善男子。不知色故乃至不知识故。见世间常乃至非如去非不如去。梵志言。瞿昙众生知何法故不见世间常乃至非如去非不如去。佛言。善男子。知色故乃至知识故。不见世间常乃至非如去非不如去。梵志言。世尊唯愿为我分别解说世间常无常。佛言。善男子。若人舍故不造新业。是人能知常与无常。梵志言。世尊我已知见。佛言。善男子。汝云何见。汝云何知。世尊。故名无明与爱。新名取有。若人远离是无明爱不作取有。是人真实知常无常。我今已得正法净眼归依三宝。唯愿如来听我出家。佛告憍陈如。听是梵志出家受戒。时憍陈如受佛敕已。将至僧中为作羯磨令得出家。十五日后诸漏永尽得阿罗汉果

犊子梵志复作是言。瞿昙。我今欲问能见听不。如来默然。第二第三亦复如是。犊子复言。瞿昙。我久与汝共为亲友。汝之与我义无有二。我欲咨问何故默然。尔时世尊作是思惟。如是梵志其性儒雅纯善质直。常为知故而来咨启不为恼乱。彼若问者当随意答。佛言。犊子。善哉善哉。随所疑问。吾当答之。犊子言。瞿昙。世有善耶。如是梵志。有不善耶。如是梵志。瞿昙。愿为我说令我得知善不善法。佛言。善男子。我能分别广说其义。今当为汝简略说之。善男子。欲名不善。解脱欲者名之为善。嗔恚愚痴亦复如是。杀名不善不杀名善。乃至邪见亦复如是。善男子。我今为汝已说三种善不善法。及说十种善不善法。若我弟子能作如是分别三种善不善法乃至十种善不善法。当知是人能尽贪欲嗔恚愚痴一切诸漏断一切有。梵志言。瞿昙。是佛法中颇有一比丘。能尽如是贪欲嗔痴一切诸漏一切有不。佛言。善男子。是佛法中非一二三乃至五百乃有无量诸比丘等。能尽如是贪欲恚痴一切诸漏一切诸有。瞿昙。置一比丘。是佛法中颇有一比丘尼。能尽如是贪欲嗔痴一切诸漏一切有不。佛言。善男子。是佛法中非一二三乃至五百。乃有无量诸比丘尼。能断如是贪欲嗔痴一切诸漏一切诸有。犊子言。瞿昙。置一比丘一比丘尼。是佛法中颇有一优婆塞。持戒精勤梵行清净度疑彼岸断于疑网不。佛言。善男子。我佛法中非一二三乃至五百。乃有无量诸优婆塞。持戒精勤梵行清净。断五下结得阿那含。度疑彼岸断于疑网。犊子言。瞿昙。置一比丘一比丘尼一优婆塞。是佛法中颇有一优婆夷。持戒精勤梵行清净。度疑彼岸断疑网不。佛言。善男子。我佛法中非一二三乃至五百。乃有无量诸优婆夷。持戒精勤梵行清净。断五下结得阿那含。度疑彼岸断于疑网。犊子言。瞿昙。置一比丘一比丘尼尽一切漏。一优婆塞一优婆夷持戒精勤梵行清净断于疑网。是佛法中颇有优婆塞。受五欲乐心无疑网不。佛言。善男子。是佛法中非一二三乃至五百。乃有无量诸优婆塞。断于三结得须陀洹。薄贪恚痴得斯陀含。如优婆塞优婆夷亦如是。世尊。我于今者乐说譬喻。佛言。善哉善哉。乐说便说。世尊。譬如难陀婆难陀龙王等降大雨。如来法雨亦复如是。平等雨于优婆塞优婆夷。世尊。若诸外道欲来出家。不审如来几月试之。佛言。善男子。皆四月试不必一种。世尊。若不一种。唯愿大慈听我出家。尔时世尊告憍陈如。听是犊子出家受戒。时憍陈如受佛敕已。立众僧中为作羯磨。于出家后满十五日得须陀洹果。既得果已复作是念。若有智慧从学得者。我今已得堪任见佛。即往佛所头面作礼。修敬已毕却住一面白佛言。世尊。诸有智慧从学得者我今已得。唯愿为我重分别说。令我获得无学智慧。佛言。善男子。汝勤精进修习二法。一奢摩他。二毗婆舍那。善男子。若有比丘欲得须陀洹果。亦当勤修如是二法。若复欲得斯陀含果阿那含果阿罗汉果。亦当修习如是二法。善男子。若有比丘欲得四禅四无量心。六神通。八背舍八胜处。无诤智顶智毕竟智四无碍智。金刚三昧尽智无生智。亦当修习如是二法。善男子。若欲得十住地无生法忍无相法忍不可思议法忍。圣行梵行天行菩萨行。虚空三昧智印三昧。空无相无作三昧。地三昧不退三昧。首楞严三昧金刚三昧。阿耨多罗三藐三菩提佛行。亦当修习如是二法。犊子闻已礼拜而出。在娑罗林中修是二法。不久即得阿罗汉果。是时复有无量比丘欲往佛所。犊子见已问言。大德欲何所至。诸比丘言。欲往佛所。犊子复言。诸大德。若至佛所愿为宣启。犊子梵志修二法已得无学智。今报佛恩入般涅槃。时诸比丘至佛所已白佛言。世尊。犊子比丘寄我等语。世尊。犊子梵志修习二法得无学智。今报佛恩入于涅槃。佛言。善男子。犊子梵志得阿罗汉果。汝等可往供养其身。时诸比丘受佛敕已。还其尸所大设供养

纳衣梵志复作是言。如瞿昙说。无量世中作善不善。未来还得善不善身。是义不然。何以故。如瞿昙说因烦恼故获得是身。若因烦恼获得身者。身为在先烦恼在先。若烦恼在先。谁之所作住在何处。若身在先。云何说言因烦恼得。是故若言烦恼在先是则不可。若身在先是亦不可。若言一时又亦不可。先后一时义皆不可。是故我说一切诸法皆有自性不从因缘

复次瞿昙。坚是地性。湿是水性。热是火性。动是风性。无所挂碍是虚空性。是五大性非因缘有。若使世间有一法性非因缘有。一切法性亦应如是非因缘有。若有一法从因缘有。何因缘故五大之性不从因缘。瞿昙。众生善身及不善身获得解脱。皆是自性不从因缘。是故我说一切诸法自性故有非因缘生

复次瞿昙。世间之法有定用处。譬如工匠云如是木任作车舆如是任作门户床机。亦如金师所可造作在额上者名之为鬘。在颈下者名之为璎。在臂上者名之为钏。在指上者。名之为环。用处定故。名为定性。瞿昙。一切众生亦复如是。有五道性故有地狱饿鬼畜生人天。若如是者云何说言从于因缘。复次瞿昙。一切众生其性各异。是故名为一切自性。瞿昙。如龟陆生自能入水。犊子生已能自饮乳。鱼见钩饵自然吞食。毒蛇生已自然食土。如是等事谁有教者。如刺生已自然头尖。飞鸟毛羽自然色别。世间众生亦复如是。有利有钝有富有贫有好有丑。有得解脱有得下有。是故当知。一切法中各有自性。复次如瞿昙说。贪欲嗔痴从因缘生。如是三毒因缘五尘。是义不然。何以故。众生睡时远离五尘。亦复生于贪欲嗔痴。在胎亦尔。初出胎时未能分别五尘好丑。亦复生于贪欲嗔痴。诸仙贤圣处闲寂处无有五尘。亦能生于贪欲嗔痴。亦复有人因于五尘生于不贪不嗔不痴。是故不必从于因缘生一切法。以自性故。复次瞿昙。我见世人。五根不具多饶财宝得大自在。有根具足贫穷下贱。不得自在为人仆使。若有因缘何故如是。是故诸法各有自性不由因缘。复次瞿昙。世间小儿亦复未能分别五尘。或笑或啼。笑时知喜。啼时知愁。是故当知。一切诸法各有自性。复次瞿昙。世法有二。一者有。二者无。有即虚空。无即兔角。如是二法。一是有故不从因缘。二是无故亦非因缘。是故诸法有自性故不从因缘

佛言。善男子。如汝所言。如五大性一切诸法亦应如是。是义不然。何以故。善男子。汝法中以五大是常。何因缘故一切诸法悉不是常。若世间物是无常者。是五大性何因缘故不是无常。若五大常世间之物亦应是常。是故汝说五大之性有自性故不从因缘。令一切法同五大者。无有是处

善男子。汝言用处定故有自性者。是义不然。何以故。皆从因缘得名字故。若从因得名。亦从因得义。云何名为从因得名。如在额上名之为鬘。在颈名璎。在臂名钏。在车名轮。火在草木名草木火。善男子。木初生时无箭槊性。从因缘故工造为箭。从因缘故工造为槊。是故不应说一切法有自性也。善男子。汝言如龟陆生性自入水。犊子生已性能饮乳。是义不然。何以故。若言入水非因缘者。俱非因缘何不入火。犊子生已性能[口*束]乳不从因缘。俱非因缘何不[口*束]角。善男子。若言诸法悉有自性不须教习无有增长。是义不然。何以故。今见有教缘教增长。是故当知无有自性。善男子。若一切法有自性者。诸婆罗门一切不应为清净身杀羊祠祀。若为身祠。是故当知无有自性。善男子。世间语法凡有三种。一者欲作。二者作时。三者作已。若一切法有自性者。何故世中有是三语。有三语故。故知一切无有自性。善男子。若言诸法有自性者。当知诸法各有定性。若有定性甘蔗一物何缘作浆。作蜜石蜜酒苦酒等。若有一性何缘乃出如是等味。若一物中出如是等。当知诸法不得一定各有一性。善男子。若一切法有定性者。圣人何故饮甘蔗浆石蜜黑蜜酒时不饮。后为苦酒复还得饮。是故当知无有定性。若无定性云何不因因缘而有。善男子。汝说一切法有自性者。云何说喻。若有喻者当知诸法无有自性。若有自性当知无喻。世间智者皆说譬喻。当知诸法无有自性无有一性。善男子。汝言身为在先烦恼在先者。是义不然。何以故。若我当说身在先者。汝可难言汝亦同我。身不在先何因缘故而作是难。善男子。一切众生身及烦恼。俱无先后一时而有。虽一时有要因烦恼而得有身。终不因身有烦恼也。汝意若谓如人二眼一时而得不相因待左不因右右不因左。烦恼及身亦如是者。是义不然。何以故。善男子。世间眼见炷之与明。虽复一时明要因炷。终不因明而有炷也。善男子。汝意若谓身不在先故知无因。是义不然。何以故。若以身先无因缘故名为无者。汝不应说一切诸法皆有因缘。若言不见故不说者。今见瓶等从因缘出。何故不说如瓶身先因缘亦复如是。善男子。若见不见一切诸法。皆从因缘无有自性。善男子。若言一切法悉有自性无因缘者。汝何因缘说于五大。是五大性即是因缘。善男子。五大因缘虽复如是。亦不应说诸法皆同五大因缘。如世人说。一切出家精勤持戒。旃陀罗等亦应如是精勤持戒。善男子。汝言五大有定坚性。我观是性转故不定。善男子。酥蜡胡胶于汝法中名之为地。是地不定。或同于水。或同于地。故不得说自性故坚。善男子。白镴铅锡铜铁金银。于汝法中名之为火。是火四性。流时水性。动时风性。热时火性。坚时地性。云何说言定名火性。善男子。水性名流。若水冻时不名为地故名水者。何因缘故波动之时不名为风。若动不名风。冻时亦应不名为水。若是二义从因缘者。何故说言一切诸法不从因缘。善男子。若言五根性能见闻觉知触故皆是自性不从因缘。是义不然。何以故。善男子。自性之性性不可转。若言眼性见者常应能见。不应有见有不见时。是故当知从因缘见非无因缘。善男子。汝言非因五尘生贪解脱。是义不然。何以故。善男子。生贪解脱虽复不因五尘因缘。恶觉观故则生贪欲。善觉观故则得解脱。善男子。内因缘故生贪解脱。外因缘故则能增长。是故汝言一切诸法各有自性。不因五尘生贪解脱。无有是处。善男子。汝言具足诸根乏于财物不得自在。诸根残缺多饶财宝得大自在。因此以明有自性故不从因缘者。是义不然。何以故。善男子。众生从业而有果报。如是果报则有三种。一者现报。二者生报。三者后报。贫穷巨富根具不具是业各异。若有自性。具诸根者应饶财宝。饶财宝者应具诸根。今则不尔。是故定知无有自性皆从因缘。善男子。如汝所言。世间小儿未能分别五尘因缘亦啼亦笑。是故一切有自性者。是义不然。何以故。若自性者笑应常笑啼应常啼。不应一笑一啼。若一笑一啼。当知一切悉从因缘。是故不应说一切法有自性故不从因缘。梵志言。世尊。若一切法从因缘有。如是身者从何因缘。佛言。善男子。是身因缘烦恼与业。梵志言。世尊。如其是身从烦恼业。是烦恼业可断不耶。佛言。如是如是。梵志复言。世尊。唯愿为我分别解说。令我闻已不移是处悉得断之。佛言。善男子。若知二边中间无碍。是人则能断烦恼业。世尊。我已知解得正法眼。佛言。汝云何知。世尊。二边即色及色解脱。中间即是八正道也。受想行识亦复如是。佛言。善哉善哉。善男子。善知二边断烦恼业。世尊。唯愿听我出家受戒。佛言。善来比丘。即时断除三界烦恼得阿罗汉果

尔时复有一婆罗门。名曰弘广。复作是言。瞿昙。知我今所念不。佛言。善男子。涅槃是常有为无常。曲即邪见直即圣道。婆罗门言。瞿昙。何因缘故作如是说。善男子。汝意每谓。乞食是常别请无常。曲是户钥直是帝幢。是故我说涅槃是常有为无常。曲谓邪见直谓八正。非如汝先所思惟也。婆罗门言。瞿昙。实知我心。是八正道悉令众生得尽灭不。尔时世尊默然不答。婆罗门言。瞿昙。已知我心。我今所问何故默然而不见答。时憍陈如即作是言。大婆罗门。若有问世有边无边。如来常尔默然不答。八圣是直涅槃是常。若修八圣即得灭尽。若不修习则不能得。大婆罗门。譬如大城其城四壁都无孔窍唯有一门。其守门者聪明有智能善分别。可放则放可遮则遮。虽不能知出入多少。定知一切有入出者皆由此门。善男子。如来亦尔。城喻涅槃。门喻八正。守门之人喻于如来。善男子。如来今者虽不答汝尽与不尽。其有尽者要当修习是八正道。婆罗门言。善哉善哉。大德憍陈如。如来善能说微妙法。我今实欲知城知道自作守门。憍陈如言。善哉善哉。汝婆罗门。能发无上广大之心。佛言。止止憍陈如。是婆罗门非适今日发是心也。乃往过去过无量劫。有佛世尊名普光明如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是人先已于彼佛所发阿耨多罗三藐三菩提心。此贤劫中当得作佛。久已通达了知法相。为众生故现处外道示无所知。以是因缘。汝憍陈如。不应赞言善哉善哉汝今能发如是大心

尔时世尊知已即告憍陈如言。阿难比丘今为所在。憍陈如言。世尊。阿难比丘在娑罗林外。去此大会十二由旬。而为六万四千亿魔之所娆乱。是诸魔众悉自变身为如来像。或有宣说一切诸法从因缘生。或有说言一切诸法不从因生。或有说言一切因缘皆是常法。从缘生者悉是无常。或有说言五阴是实或说虚假。入界亦尔。或有说言有十二缘。或有说言正有四缘。或说诸法如幻如化如热时焰。或有说言因闻得法。或有说言因思得法。或有说言因修得法。或复有说不净观法。或复有说出息入息。或复有说四念处观。或复有说三种观义七种方便。或复有说暖法顶法忍法世间第一法学无学地。菩萨初住乃至十住。或有说空无相无作。或复有说修多罗。祇夜。毗伽罗那。伽陀。忧陀那。尼陀那。阿波陀那。伊帝目多伽。阇陀伽。毗佛略。阿浮陀达摩。优波提舍。或说四念处四正勤四如意足五根五力七觉分八圣道。或说内空外空内外空有为空无为空。无始空。性空远离空散空自相空无相空阴空入空界空善空不善空无记空菩提空道空涅槃空行空得空第一义空空空大空。或有示现神通变化身出水火。或身上出水身下出火。身下出水身上出火。左胁在下右胁出水。右胁在下左胁出水。一胁震雷一胁降雨。或有示现诸佛世界。或复示现菩萨初生行至七步。处在深宫受五欲时。初始出家修苦行时。往菩提树坐三昧时。坏魔军众转法轮时。示大神通入涅槃时。世尊。阿难比丘见是事已。作是念言。如是神变昔来未见。谁之所作。将非世尊释迦作耶。欲起欲语都不从意。阿难比丘入魔罥故。复作是念。诸佛所说各各不同。我于今者当受谁语。世尊。阿难今者极受大苦。虽念如来无能救者。以是因缘不来至此大众之中

尔时文殊师利菩萨摩诃萨白佛言。世尊。此大众中有诸菩萨。已于一生发阿耨多罗三藐三菩提心。至无量生发菩提心。已能供养无量诸佛。其心坚固具足修行檀波罗蜜乃至般若波罗蜜。成就功德。久已亲近无量诸佛。净修梵行得不退转菩提之心。得不退忍不退转持。得如法忍首楞严等无量三昧。如是等辈闻大乘经终不生疑。善能分别宣说三宝同一性相常住不变。闻不思议不生惊怪。闻种种空心不怖懅。了了通达一切法性。能持一切十二部经广解其义。亦能受持无量诸佛十二部经。何忧不能受持如是大涅槃典。何因缘故问憍陈如阿难所在。尔时世尊告文殊师利。谛听谛听。善男子。我成佛已过二十年住王舍城。尔时我告诸比丘言。诸比丘。今此众中谁能为我受持如来十二部经。供给左右所须之事。亦使不失自身善利。时憍陈如在彼众中来白我言。我能受持十二部经。供给左右不失所作自利益事。我言。憍陈如。汝已朽迈当须使人。云何方欲为我给使。时舍利弗复作是言。我能受持佛一切语。供给所须不失所作自利益事。我言。舍利弗。汝已朽迈当须使人。云何方欲为我给使。乃至五百诸阿罗汉皆亦如是我悉不受。尔时目连在大众中作是思惟。如来今者不受五百比丘给使。佛意为欲令谁作耶。思惟是已即便入定。观见如来心在阿难。如日初出光照西壁。见是事已即从定起语憍陈如。大德。我见如来欲令阿难给事左右。尔时憍陈如与五百阿罗汉往阿难所作如是言。阿难。汝今当为如来给使请受是事。阿难言。诸大德。我实不堪给事如来。何以故。如来尊重如师子王如龙如火。我今秽弱云何能办诸比丘言。阿难。汝受我语给事如来得大利益。第二第三亦复如是。阿难言。诸大德。我亦不求大利益事。实不堪任奉给左右。时目犍连复作是言。阿难。汝今未知。阿难言。大德。唯愿说之。目犍连言。如来先日僧中求使。五百罗汉皆求为之如来不听。我即入定见如来意欲令汝为。汝今云何反更不受。阿难闻已合掌长跪作如是言。诸大德。若有是事如来世尊与我三愿。当顺僧命给事左右。目犍连言。何等三愿。阿难言。一者如来设以故衣赐我听我不受。二者如来设受檀越别请听我不往。三者听我出入无有时节。如是三事佛若听者。当顺僧命。时憍陈如五百比丘还来我所。作如是言。我等已劝阿难比丘。唯求三愿。若佛听者当顺僧命。文殊师利。我于尔时赞阿难言。善哉善哉。阿难比丘具足智慧预见讥嫌。何以故。当有人言汝为衣食奉给如来。是故先求不受故衣不随别请。憍陈如。阿难比丘具足智慧。入出有时即不能得广作利益四部之众。是故求欲出入无时。憍陈如。我为阿难开是三事随其意愿。时目犍连还阿难所语阿难言。吾已为汝启请三事。如来大慈皆已听许。阿难言。大德。若佛听者请往给侍。文殊师利。阿难事我二十余年。具足八种不可思议。何等为八。一者事我已来二十余年。初不随我受别请食。二者事我已来初不受我陈故衣服。三者自事我来至我所时终不非时。四者自事我来具足烦恼。随我入出诸王刹利豪贵大姓。见诸女人及天龙女不生欲心。五者自事我来持我所说十二部经。一经于耳曾不再问。如写瓶水置之一瓶唯除一问。善男子。琉璃太子杀诸释氏坏迦毗罗城。阿难尔时。心怀愁恼发声大哭。来至我所作如是言。我与如来俱生此城同一释种。云何如来光颜如常。我则憔悴。我时答言。阿难。我修空定故不同汝。过三年已还来问我。世尊。我往于彼迦毗罗城。曾闻如来修空三昧。是事虚实。我言。阿难。如是如是。如汝所说。六者自事我来虽未获得知他心智。常知如来所入诸定。七者自事我来未得愿智。而能了知如是众生到如来所。现在能得四沙门果。有后得者。有得人身。有得天身。八者自事我来如来所有秘密之言悉能了知。善男子。阿难比丘具足如是八不思议。是故我称阿难比丘为多闻藏。善男子。阿难比丘具足八法。能具足持十二部经。何等为八。一者信根坚固。二者其心质直。三者身无病苦。四者常勤精进。五者具足念心。六者心无憍慢。七者成就定慧。八者具足从闻生智。文殊师利。毗婆尸佛侍者弟子名阿叔迦。亦复具足如是八法。尸弃如来侍者弟子名差摩迦罗。毗舍浮佛侍者弟子名忧波扇陀。迦罗鸠村驮佛侍者弟子名曰跋提。迦那含牟尼佛侍者弟子名曰苏坻。迦叶佛侍者弟子名叶婆蜜多。皆亦具足如是八法。我今阿难亦复如是具足八法。是故我称阿难比丘为多闻藏。善男子。如汝所说。此大众中虽有无量无边菩萨。是诸菩萨皆有重任。所谓大慈大悲。如是慈悲之因缘故。各各匆务调伏眷属庄严自身。以是因缘我涅槃后。不能宣通十二部经。若有菩萨或时能说人不信受。文殊师利。阿难比丘是吾之弟。给事我来二十余年。所可闻法具足受持。喻如写水置之一器。是故我今顾问阿难为何所在。欲令受持是涅槃经。善男子。我涅槃后阿难比丘所未闻者。弘广菩萨当能流布。阿难所闻自能宣通。文殊师利。阿难比丘今在他处。去此会外十二由旬。而为六万四千亿魔之所恼乱。汝可往彼发大声言。一切诸魔。谛听谛听。如来今说大陀罗尼。一切天龙乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。山神树神河神海神舍宅等神。闻是持名无不恭敬受持之者。是陀罗尼十恒河沙诸佛世尊所共宣说。能转女身。自识宿命。若受五事。一者梵行。二者断肉。三者断酒。四者断辛。五者乐在寂静。受五事已。至心信受读诵书写是陀罗尼。当知是人即得超越七十七亿弊恶之身。尔时世尊即便说之

阿摩隶　毗摩隶　涅磨隶　瞢伽隶　醯摩罗　若竭鞞　三慢那跋提　娑婆他娑檀尼　婆罗磨他娑檀尼　磨那斯　阿拙提　毗罗只　庵罗赖低　婆岚弥婆岚　摩莎隶　富泥富那摩奴赖绨

尔时文殊师利从佛受是陀罗尼已。至阿难所在魔众中作如是言。诸魔眷属。谛听我说所从佛受陀罗尼咒。魔王闻是陀罗尼已。悉发阿耨多罗三藐三菩提心。舍于魔业即放阿难。文殊师利与阿难俱来至佛所。阿难见佛至心礼敬却住一面

佛告阿难。是娑罗林外有一梵志。名须跋陀。年百二十。虽得五通未舍憍慢。获得非想非非想定。生一切智起涅槃想。汝可往彼语须跋言。如来出世如优昙花。于今中夜当般涅槃。若有所作可及时作。莫于后日而生悔心。阿难。汝之所说彼定信受。何以故。汝曾往昔五百世中作须跋陀子。其人爱心习犹未尽。以是因缘信受汝语。尔时阿难受佛敕已。往须跋所作如是言。仁者当知。如来出世如优昙花。于今中夜当般涅槃。欲有所作可及时作。莫于后日生悔心也。须跋言。善哉阿难。我今当往至如来所。尔时阿难与须跋陀还至佛所。时须跋陀到已。问讯作如是言。瞿昙。我今欲问随我意答。佛言。须跋。今正是时。随汝所问。我当方便随汝意答。瞿昙。有诸沙门婆罗门等作如是言。一切众生受苦乐报。皆随往日本业因缘。是故若有持戒精进。受身心苦能坏本业。本业既尽众苦尽灭。众苦尽灭即得涅槃。是义云何。佛言。善男子。若有沙门婆罗门等作是说者。我为怜愍常当往来如是人所。既至彼已我当问之。仁者。实作如是说不。彼若见答。我如是说。何以故。瞿昙。我见众生习行诸恶多饶财宝身得自在。又见修善贫穷多乏不得自在。又见有人多役力用求财不得。又见不求自然得者。又见有人慈心不杀反更中夭。又见喜杀终保年寿。又见有人净修梵行精勤持戒有得解脱有不得者。是故我说一切众生受苦乐报。皆由往日本业因缘。须跋。我复当问。仁者。实见过去业不。若有是业为多少耶。现在苦行能破多少耶。能知是业已尽不尽耶。是业既尽一切尽耶。彼若见答。我实不知。我便当为彼人引喻。譬如有人身被毒箭。其家眷属为请医师令拔是箭。既拔箭已身得安隐。其后十年是人犹忆了了分明。是医为我拔出毒箭以药涂拊。令我得差安隐受乐。仁既不知过去本业。云何能知现在苦行定能破坏过去业耶。彼若复言。瞿昙。汝今亦有过去本业。何故独责我过去业。瞿昙经中亦作是说。若见有人豪贵自在。当知是人先世好施。如是不名过去业耶。我复答言。仁者。如是知者名为比知不名真知。我佛法中或有由因知果。或有从果知因。我佛法中有过去业有现在业。汝则不尔。唯有过去业无现在业。汝法不从方便断业。我法不尔从方便断。汝业尽已则得苦尽。我即不尔。烦恼尽已业苦则尽。是故我今责汝过去业。彼人若言瞿昙我实不知从师受之。师作是说我实无咎。我言。仁者汝师是谁。彼若见答。是富兰那。我复语言。汝昔何不一一咨问。大师实知过去业不。汝师若言我不知者。汝复云何受是师语。若言我知复应问言。下苦因缘受中上苦不。中苦因缘受下上苦不。上苦因缘受中下苦不。若言不者。复应问言。师云何说苦乐之报唯过去业非现在耶。复应问言。是现在苦过去有不。若过去有。过去之业悉已都尽。若都尽者云何复受今日之身。若过去无唯现在有。云何复言众生苦乐皆过去业。仁者。若知现在苦行能坏过去业。现在苦行复以何破。如其不破苦即是常。苦若是常。云何说言得苦解脱。若更有行坏苦行者。过去已尽云何有苦。仁者。如是苦行能令乐业受苦果不。复令苦业受乐果不。能令无苦无乐业作不受果不。能令现报作生报不。能令生报作现报不。令是二报作无报不。能令定报作无报不。能令无报作定报不。彼若复言。瞿昙不能。我复当言。仁者。如其不能何因缘故受是苦行。仁者当知。定有过去业现在因缘。是故我言因烦恼生业因业受报。仁者当知。一切众生有过去业有现在因。众生虽有过去寿业。要赖现在饮食因缘。仁者。若说众生受苦受乐定由过去本业因缘。是事不然。何以故。仁者。譬如有人为王除怨。以是因缘多得财宝。因是财宝受现在乐。如是之人现作乐因现受乐报。譬如有人杀王爱子。以是因缘丧失身命。如是之人现作苦因现受苦报。仁者。一切众生现在因于四大时节土地人民受苦受乐。是故我说。一切众生不必尽因过去本业受苦乐也。仁者。若以断业因缘力故得解脱者。一切圣人不得解脱。何以故。一切众生过去本业无始终故。是故我说。修圣道时是道能遮无始终业。仁者。若受苦行便得道者。一切畜生悉应得道。是故先当调伏其心不调伏身。以是因缘。我经中说。斫伐此林。莫斫伐树。何以故。从林生怖不从树生。欲调伏身先当调心。心喻于林身喻于树。须跋陀言。世尊。我已先调伏心。佛言。善男子。汝今云何能先调心。须跋陀言。世尊。我先思惟。欲是无常无乐无净。观色即是常乐清净。作是观已。欲界结断获得色处。是故名为先调伏心。次复观色。色是无常如痈如疮如毒如箭。见无色常清净寂静。如是观已。色界结尽得无色处。是故名为先调伏心。次复观想即是无常痈疮毒箭。如是观已。获得非想非非想处。是非想非非想即一切智寂静清净。无有堕坠常恒不变。是故我能调伏其心。佛言。善男子。汝云何能调伏心耶。汝今所得非想非非想定犹名为想。涅槃无想。汝云何言获得涅槃。善男子。汝已先能呵责粗想。今者云何爱着细想。不知呵责如是非想非非想处故名为想如痈如疮如毒如箭。善男子。汝师郁头蓝弗利根聪明。尚不能断如是非想非非想处受于恶身。况其余者。世尊。云何能断一切诸有。佛言。善男子。若观实相是人能断一切诸有。须跋陀言。世尊。云何名为实相。善男子。无相之相名为实相。世尊。云何名为无相之相。善男子。一切法无自相他相及自他相。无无因相无作相无受相。无作者相无受者相。无法非法相。无男女相。无士夫相。无微尘相。无时节相。无为自相无为他相无为自他相。无有相无无相。无生相无生者相。无因相无因因相。无果相无果果相。无昼夜相无明闇相。无见相无见者相。无闻相。无闻者相。无觉知相无觉知者相。无菩提相无得菩提者相。无业相无业主相。无烦恼相无烦恼主相。善男子。如是等相随所灭处名真实相。善男子。一切诸法皆是虚假。随其灭处是名为实。是名实相。是名法界。名毕竟智。名第一义谛。名第一义空。善男子。是相法界毕竟智第一义谛第一义空。下智观故得声闻菩提。中智观故得缘觉菩提。上智观故得无上菩提

说是法时。十千菩萨得一生实相。万五千菩萨。得二生法界。二万五千菩萨得毕竟智。三万五千菩萨悟第一义谛。是第一义谛。亦名第一义空。亦名首楞严三昧。四万五千菩萨得虚空三昧。是虚空三昧亦名广大三昧。亦名智印三昧。五万五千菩萨得不退忍。是不退忍。亦名如法忍。亦名如法界。六万五千菩萨得陀罗尼。是陀罗尼。亦名大念心。亦名无碍智。七万五千菩萨得师子吼三昧。是师子吼三昧。亦名金刚三昧。亦名五智印三昧。八万五千菩萨得平等三昧。是平等三昧。亦名大慈大悲。无量恒河沙等众生发阿耨多罗三藐三菩提心。无量恒河沙等众生发缘觉心。无量恒河沙等众生发声闻心。人女天女二万亿人现转女身得男子身。须跋陀罗得阿罗汉果

大般涅槃经卷第三十六


大般涅槃经后分卷

    No. 377

大般涅槃经后分卷上

        大唐南海波淩国沙门若那跋陀罗译

    憍陈如品余

尔时须跋陀罗。从佛闻说大般涅槃甚深妙法。而得法眼见法清净。爱护正法已舍邪见。于佛法中深信坚固。即从如来欲求出家。佛言。善哉善哉。须跋陀罗善。来比丘。悦可圣心善入佛道。于是须跋陀罗。欢喜踊跃忻庆无量。即时须发自落而作沙门。法性智水灌注心原。无复缚着。漏尽意解得罗汉果。须跋陀罗既证果已。即前佛所瞻仰尊颜头面礼足。偏袒右肩右膝着地长跪合掌。悲喜交流深自悔责在昔罪咎。而白佛言。世尊。恨我毒身久劫已来常相欺惑。令我长没无明邪见。沦溺三界外道法中。痛哉苦哉为害滋甚。今大喜庆。蒙如来恩得入正法。世尊。智慧大海慈愍无量。窃自惟忖。累劫碎躯未能报此须臾之恩。须跋陀罗说是语已。悲泣流泪不能自裁。复白佛言。世尊。我年老迈余命无几。未脱众苦行苦迁逼。唯愿世尊。少住教诫哀愍救护莫般涅槃。尔时世尊默然不许。须跋陀罗不果所请。愁忧热恼高声唱曰。苦哉苦哉。世间虚空。世间虚空。如何于今大怖即至热恼流行。哀哉哀哉。众生福尽正慧眼灭。复更流泪悲号哽咽。遍体血现发声大哭。于如来前举身投地。慌乱浊心昏迷闷绝。久乃苏醒涕泪哽咽。而白佛言。世尊。我今不忍见于如来入般涅槃。中心痛切难任裁抑。我自何能与此坏器毒身共住。今前宁可先自速灭。唯愿世尊。后当涅槃。尔时须跋陀罗。说是语已悲恋哽咽。于是时顷即入涅槃

尔时不可说不可说无数亿恒河沙诸大菩萨比丘比丘尼。一切世间天人阿修罗等。同声唱言。苦哉苦哉。如何正觉一旦舍离。无主无归无依无趣。追思恋慕悲感号泣。互相执手捶胸闷绝迷失诸方。哀恸三千大千世界。尔时世尊。出八种声普告大众。莫大号哭犹如婴儿。各相裁抑勿自乱心。汝等于此行苦生死大海。勤修净心莫失念慧。疾求正智速出诸有。三界受身苦轮无际。无明郎主恩爱魔王。役使身心策为僮仆。遍缘境界造生死业。贪恚狂痴念念伤害。无量劫来常受苦恼。何有智者不反斯原。汝等当知。我旷劫来已入大寂。无阴界入永断诸有。金刚宝藏常乐我净。我今于此显难思议现方便力。入大涅槃示同世法。欲令众生知身如电生恋慕心。生死瀑河漂流速疾。诸行轮转法应如是。如来涅槃甚深甚深不可思议。乃是诸佛菩萨境界。非诸声闻缘觉所知

佛复告诸大众。是须跋陀罗。已曾供养恒河沙佛。于诸佛所深种善根。以本愿力常在尼干外道法中。出家修行。以方便慧诱进邪见失道众生令入正智。须跋陀罗乘本愿力。今得遇我最后涅槃得闻正法。既闻正法得罗汉果。既得果已复入涅槃。自我得道度阿若憍陈如。最后涅槃度须跋陀罗。吾事究竟无复施为。设我久住无异今也。尔时世尊说是语已。即嘘长叹唱言。善哉善哉。须跋陀罗为报佛恩。汝等大众。应当供养其尸安立塔庙。尔时大众。惆怅惨结掩泪裁抑。即依佛教以香木苏油茶毗其尸。须跋陀罗当焚尸时。即于火中放大光明现十八变。身上出水身下出火。右胁出火左胁出水。小复现大大复现小满虚空中。尔时无量大众。及诸外道邪见众生。发菩提心得入正见。须跋陀罗现神变已还复火中茶毗已讫。是时大众悲感伤悼。收取舍利起塔供养

    大般涅槃经遗教品第一

尔时佛告阿难普及大众。吾灭度后汝等四众。当勤护持我大涅槃。我于无量万亿阿僧祇劫。修此难得大涅槃法。今已显说。汝等当知。此大涅槃乃是十方三世一切诸佛金刚宝藏。常乐我净周圆无缺。一切诸佛于此涅槃而般涅槃。最后究竟理极无遗。诸佛于此放舍身命。故名涅槃。汝等。欲得决定真报佛恩。疾得菩提诸佛摩顶。世世所生不失正念。十方诸佛常现其前。昼夜守护令一切众得出世法。当勤修习此涅槃典

佛复告阿难。吾未成佛示入郁头蓝弗外道法中。修学四禅八定受行其教。吾成佛来毁呰其法渐渐诱进。最后须跋陀罗皆入佛道。如来以大智炬烧邪见幢。如干草叶投大火焰。阿难。今我亲戚诸释种子吾甚忧念。我涅槃后汝当精勤。以善教诫我诸眷属。授与妙法深心诲诱。勿得调戏放逸散心。入诸境界受行邪法。未脱三界世间痛苦。早求出离于此五浊爱欲之中。应生忧畏无救护想。一失人身难可追复。毕此一形常须警察。无常大鬼情求难脱。怜愍众生莫相杀害。乃至蠢动应。施无畏。身业清净常生妙土。口业清净离诸过恶。莫食肉莫饮酒。调伏心蛇令入道果。深思行业善恶之报。如影随形。三世因果循环不失。此生空过后悔无追。涅槃时至示教如是

尔时阿难闻佛语已。身心战动情识恾然。悲哽 喑 咽深没忧海。举体迷闷昏乱浊心。投如来前犹如死人。尔时阿泥楼逗安慰阿难。轻其愁心而语之言。咄哉何为愁苦。如来涅槃时至。今日虽有明旦则无。汝依我语咨启如来如是四问。佛涅槃后六群比丘行污他家恶性车匿。云何共住而得示教。如来在世以佛为师。世尊灭后以何为师。若佛在世依佛而住。如来既灭依何而住。如来灭后结集法藏。一切经初安何等语。尔时阿难如从梦中闻阿泥楼逗。安慰其心令致四问。渐得醒悟哀不自胜。具陈上问而以白佛

佛告阿难。何为忧苦悲哀乃尔。诸佛化周。施为已讫法归是处。善哉善哉。阿难。汝致四问为最后问。能大利益一切世间。汝等谛听。善思念之。唯然世尊。愿乐欲闻。佛告阿难。如汝所问。佛涅槃后六群比丘恶性车匿行污他家。云何共住而得示教。阿难。车匿比丘其性鄙恶。我涅槃后渐当调伏。其心柔和舍本恶性。阿难。我弟难陀。具极重欲其性鄙恶。如来以善方便示教利喜。知其根性以波若慧。为说十二因缘。所谓无明缘行。行缘识。乃至老死忧悲苦恼。皆是无明憎爱丛林。一切行苦弥满三界遍流六道。大苦根本无明所起。以波若慧示以性净谛观根本。即断诸有过患无明。根本灭故无明灭。无明灭则行灭。乃至老死忧悲苦恼皆灭。得此观时摄心定住即入三昧。以三昧力得入初禅。渐渐次第入第四禅。继心正念如是修习。然后自当得证上果离三界苦。阿难。尔时难陀比丘。深生信心依我教法勤心修习。不久即得阿罗汉果。阿难。我涅槃后汝当依我教法正观。教示六群车匿比丘。深心依此清净正法。不久自当得证上果。阿难。当知皆因无明。增长三界生死大树。飘没爱河众苦长夜。黑闇崖下绕生死柱。六识为枝妄念为本。无明波浪心识策使。游戏六尘种苦恼芽。无能制者。自在如王。是故我言无明郎主念念伤害。众生不觉轮转生死。阿难。一切众生为此无明起诸爱结。我见覆蔽八万四千。烦恼郎主役使其身。身心破裂不得自在。阿难。无明若灭三界都尽。以是因缘名出世人。阿难。若能谛观十二因缘。究竟无我深入本净。即能远离三界大火。阿难。如来是真语者说诚实言。最后付嘱汝当修行。阿难。如汝所问。佛去世后以何为师者。阿难。尸波罗蜜戒是汝大师。依之修行能得出世甚深定慧。阿难。如汝所问。佛涅槃后依何住者。阿难。依四念处严心而住。观身性相同于虚空。名身念处。观受不在内外不住中间。名受念处。观心但有名字名字性离。名心念处。观法不得善法不得不善法。名法念处。阿难。一切行者。应当依此四念处住。阿难。如汝所问。如来灭后结集法藏。一切经初安何等语者。阿难。如来灭后结集法藏。一切经初。当安如是我闻一时佛住某方某处与诸四众而说是经

尔时阿难复白佛言。若佛在世若涅槃后。有信心檀越。以金银七宝一切乐具奉施如来。云何举置。佛告阿难。若佛现在所施佛物。僧众应知。若佛灭后一切信心所施佛物。应用造佛形像。及造佛衣七宝幡盖。买诸香油宝花以供养佛。除供养佛。余不得用。用者即犯盗佛物罪。阿难复白佛言。若佛现在若复有人以金银七宝房舍殿堂妻子奴婢衣服饮食一切乐具。深心恭敬礼拜供养如来。佛涅槃后。若复有人。以金银七宝妻妾奴婢衣服饮食一切乐具。供养如来形像深心恭敬礼拜供养。世尊。如是二人深心供养。所得福德何者为多。佛告阿难。如是二人。皆以深心供养。所得福德其福无异。何以故。虽佛灭后。法身常存。是以深心供养其福正等。阿难复白佛言。若佛现在。若复有人。还以深心如上供养恭敬如来。佛涅槃后。若复有人。还以深心如上供养恭敬全身舍利。世尊。如是二人所得福德何者为多。佛告阿难。如是二人得福正等。功德广大无量无边。乃至毕苦其福不尽。阿难复白佛言。若佛现在。若复有人。如上深心一切供养恭敬如来。佛涅槃后。若复有人。如上深心供养恭敬半身舍利。世尊。如是二人所得福德何者为多。佛告阿难。如是二人深心供养得福无异。所得福德无量无边。阿难。若佛灭后。若复有人。深心供养如来舍利四分之一。八分之一。十六分之一。百分之一。千分之一。万分之一。恒河沙分之一。乃至如芥子许。皆以深心供养恭敬尊重赞叹。若佛现在。若复有人。深心供养恭敬如来。如是二人所得福德皆悉无异。其福无量不可称计。阿难当知。若佛现在。若涅槃后。若复有人深心恭敬供养礼拜尊重赞叹。如是二人所得福德无二无别。佛告阿难及诸大众。我涅槃后。天上人间一切众生。得我舍利悲喜交流哀感欣庆。恭敬礼拜深心供养。得无量无边功德。阿难。若见如来舍利即是见佛。见佛即是见法。见法即是见僧。见僧即见涅槃。阿难。当知以是因缘。三宝常住无有变易。能为众生作归依处。阿难复白佛言。佛涅槃后。一切大众依何法则茶毗如来而得舍利深心供养。佛告阿难。我般涅槃。汝等大众当依转轮圣王茶毗方法。阿难复白。转轮圣王茶毗法则其事云何。佛告阿难。转轮圣王命终之后。经停七日乃入铁棺。既入棺已即以微妙香油注满棺中。闭棺令密。复经七日。从棺中出以诸香水灌洗沐浴。既灌洗已烧众名香而以供养。以兜罗绵遍体儭身。然后即以无价上妙白[疊*毛]千张。次第相重遍缠王身。既已缠讫以众香油满铁棺中。圣王之身尔乃入棺。密闭棺已。载以香木七宝车上。其车四面垂诸璎珞。一切宝绞庄严其车。无数花幡七宝幢盖。一切妙香一切天乐围绕供养。尔乃纯以众妙香木表里文饰。微妙香油茶毗转轮圣王之身。茶毗已讫收取舍利。于都城内四衢道中起七宝塔。塔开四门安置舍利。一切世间所共瞻仰。阿难。其转轮王以少福德绍此王位。未脱诸有具足五欲。妻妾婇女恶见三毒。一切烦恼诸结使等未断一毫。命终之后世间犹乃如是法则。起塔供养一切瞻仰。阿难。何况如来已于无量无边无数阿僧祇劫。永舍五欲妻妾婇女。于世间法已作霜雹。难勤能勤。难行能行。一切菩萨出世苦行勤苦修习。十方三世一切诸佛所行之道甚深微妙清净戒定慧解脱解脱知见六波罗蜜。无不具足。修习如来十力大悲四无所畏。三解脱门十八大空。六通五眼。三十七品十八不共法。三十二相八十种好。一切诸佛寿命。一切净佛国土。一切成就众生。一切难行苦行。一切摄善法戒。一切摄众生戒。一切摄律仪戒。一切功德。一切智慧。一切庄严。一切大愿。一切方便。如是等不可思议福德智慧。皆已成就无不具足。断除一切不善。断除一切烦恼。断除一切烦恼余习。通达四谛十二因缘。于菩提树降伏四魔成就种智。如是妙法悉修习已。尔乃一切诸佛唱言。善哉善哉。同以法性智水灌法身顶。乃成阿耨多罗三藐三菩提。以是因缘。我今号天人师十方种觉至极世尊。天上人间无与等者。等视众生如罗睺罗。故名如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。怜愍世间化缘周毕。为众生故今入涅槃。随世间法如转轮王。为令众生普得供养。阿难。我入涅槃如转轮王。经停七日乃入铁棺。以妙香油注满棺中密盖棺门。其棺四面应以七宝间杂庄严。一切宝幢香花供养。经七日已复出铁棺。既出棺已应以一切众妙香水。灌洗沐浴如来之身。既灌洗已以上妙兜罗绵遍体缠身。次以微妙无价白[疊*毛]千张。复于绵上缠如来身又入铁棺。复以微妙香油盛满棺中闭棺令密。尔乃纯以微妙牛头栴檀沉水一切香木盛七宝车。一切众宝以为庄严。载以宝棺至茶毗所。无数宝幢。无数宝盖。无数宝衣。无数天乐。无数香花。周遍虚空悲哀供养。一切天人无数大众。应各以栴檀沉水微妙香油茶毗如来。哀号恋慕茶毗已讫。天人四众收取舍利盛七宝瓶。于都城内四衢道中。起七宝塔供养舍利。能令众生得大功德。离三有苦至涅槃乐。阿难当知。一切四众起佛舍利七宝塔已。应当更起三塔供养。所谓辟支佛塔。阿罗汉塔。转轮王塔。为令世间知归依故。阿难白佛言。如来出世悲愍众生。显示十力大悲四无所畏。十二因缘四谛之法三解脱门。八种梵音雷震三界。五色慈光遍照六道。随顺众生心业所转。或得四果三乘所行。或证无漏无为缘觉之道。或入无灭无生菩萨之地。或得无量诸陀罗尼。或得五眼。或得六通。或脱三恶。或出八难。或离人天三界之苦。如来慈力清净。如来解脱法门不可思议。乃至涅槃一切世间人天四众起七宝塔。供养舍利得大功德。能令众生脱三界苦入正解脱。以是因缘。佛般涅槃。一切世间人天大众。报佛甚深无量慈恩。起七宝塔供养舍利。理应如是。世尊。其余三塔于诸众生得何等利。而令起立恭敬供养。佛告阿难。其辟支佛。悟法因缘入深法性。已脱诸有一切过患。能为人天而作福田。以是因缘起塔供养。所得福德次于如来。能令众生皆得妙果。阿难。其阿罗汉。于三界中生分已尽。不受后有梵行已立。能为世间而作福田。是故应当起塔供养。所得福德次辟支佛。亦令众生皆得解脱。阿难。其转轮王。虽未解脱三界烦恼。福德力故治四天下。而以十善化育群生。是诸众生之所尊敬。以是四众起塔供养。所得福德亦复无量

阿难白佛言。佛般涅槃。一切四众。当于何所茶毗如来得收舍利。唯愿示教。佛告阿难。佛般涅槃。一切四众。若于拘尸城内茶毗如来。其城中人皆绍王位。则相讨罚诤讼无量。亦令一切得福阶差。阿难。一切四众可于城外茶毗如来。为令世间得福等故。阿难白佛言。佛入涅槃茶毗已讫。一切四众收取舍利安置宝瓶。当于何所起七宝塔。一切皆得深心供养。唯愿示教。佛告阿难。佛般涅槃茶毗既讫。一切四众收取舍利置七宝瓶。当于拘尸那伽城内四衢道中起七宝塔。高十三层。上有相轮。一切妙宝间杂庄严。一切世间众妙花幡而严饰之。四边栏楯七宝合成。一切庄挍靡不周遍。其塔四面面开一门。层层间次窗牖相当。安置宝瓶如来舍利。天人四众瞻仰供养。阿难。其辟支佛塔应十一层。亦以众宝而严饰之。阿难。其阿罗汉塔成以四层。亦以众宝而严饰之。阿难。其转轮王塔。亦七宝成。无复层级。何以故。未脱三界诸有苦故。尔时阿泥楼逗白佛言。佛涅槃后茶毗已讫。一切天人四部大众。如何分布如来舍利而得供养。尔时佛告阿泥楼逗。我般涅槃汝等天人取佛舍利。以平等心分布三界一切六道世间供养。尔时释提桓因白佛。我今从佛敬请如来半身舍利。而我深心愿供养故。佛告天帝。如来等视众生如罗睺罗。汝不应请半身舍利。何以故。平等利祐诸众生故。佛告天帝。我今与汝右边上颔一牙舍利。可于天上起塔供养。能令汝得福德无尽

尔时天人一切大众。悲哀流泪不能自裁。尔时世尊普告四众。佛般涅槃。汝等天人莫大愁恼。何以故。佛虽涅槃而有舍利常存供养。复有无上法宝。修多罗藏。毗那耶藏。阿毗达磨藏。以是因缘。三宝四谛常住于世。能令众生深心归依。何以故。供养舍利即是佛宝。见佛即见法身。见法即见贤圣。见贤圣故即见四谛。见四谛故即见涅槃。是故当知三宝常住无有变易。能为世间作归依故。佛复告诸大众。汝等莫大愁苦。我今于此垂欲涅槃。若戒若归若常无常。三宝四谛六波罗蜜十二因缘。有所疑者当速发问为究竟问。佛涅槃后无复疑悔。三过告众。尔时四众忧悲苦恼哽咽流泪。痛切中心追思恋慕愁毒闷绝。佛神力故掩泪寂然无发问者。何以故。一切四众已于戒归三宝四谛。通达晓了无有疑故。尔时世尊知诸四众无复余疑叹言。善哉善哉。汝等四众。已能通达三宝四谛无有疑也。犹如净水洗荡身垢。汝等当勤精进早得出离。莫生愁恼迷闷乱心

尔时世尊于师子座。以真金手却身所著僧伽梨衣。显出紫磨黄金师子胸臆。普示大众告言。汝等一切天人大众。应当深心看我紫磨黄金色身。尔时四众一切瞻仰大觉世尊真金色身。目不暂舍悉皆快乐。譬如比丘入第三禅难生是中。尔时世尊以黄金身示大众已。即放无量无边百千万亿大涅槃光。普照十方一切世界。日月所照无复光明。放是光已复告大众。当知如来为汝等故。累劫勤苦截身手足。尽修一切难行苦行。大悲本愿于此五浊成阿耨多罗三藐三菩提。得此金刚不坏紫磨色身。具足三十二相八十种好。无量光明普照一切。见形遇光无不解脱。佛复告诸大众。佛出世难如优昙花希有难见。汝等大众。最后遇我。为于此身不生空过。我以本誓愿力生此秽土。化缘周毕今欲涅槃。汝等以至诚心看我紫磨黄金色身。汝当修习如是清净之业。于未来世得此果报

尔时世尊如是三反殷勤三告。以真金身示诸大众。即从七宝师子大床。上升处空高一多罗树一反告言。我欲涅槃。汝等大众。看我紫磨黄金色身。如是展转高七多罗树七反告言。我欲涅槃。汝等大众。应当深心看我紫磨黄金色身。从空中下坐师子床。复告大众。我欲涅槃。汝等深心看我紫磨黄金色身。尔时世尊从师子床复升虚空高一多罗树。复告大众。我欲涅槃。汝等深心看我紫磨黄金色身。如是展转高七多罗树七反告言。我欲涅槃。汝等大众。看我紫磨黄金色身。从空中下坐师子床。复告大众。我欲涅槃。汝等深心看我紫磨黄金色身。尔时世尊从师子床复升虚空高一多罗树。复告大众。我欲涅槃。汝等深心看我紫磨黄金色身。如是展转高七多罗树七反告言。我欲涅槃。汝等深心看我紫磨黄金色身。从空中下坐师子床。复告大众。我欲涅槃。汝等深心看我紫磨黄金色身。尔时世尊显出如来紫磨黄金色身。普示大众。如是三反上升虚空高七多罗树。三反从空中下坐师子床。如是殷勤二十四反告诸大众。我欲涅槃。汝等深心看我金刚坚固不坏紫磨黄金无畏色身。如优昙花难可值遇。汝等当知。我欲涅槃。汝等应当以至诚心看我紫磨黄金色身。如热渴人遇清冷水。饮之令饱无复余念。汝等大众。亦复如是。我欲涅槃。汝等大众。应当深心瞻仰为是最后见于如来。自此见已无复再睹。汝等大众。瞻仰令足无复后悔。佛复告诸大众。我涅槃后。汝等大众。应广修行早出三有。勿复懈怠散心放逸。尔时一切世界天人四众。遇涅槃光瞻仰佛者。一切三涂八难世间人天所有烦恼。四重五逆极恶罪咎。永灭无余皆得解脱。尔时世尊显出紫磨黄金色身。殷勤相告示大众已。还举僧伽梨衣如常所披

    大般涅槃经应尽还源品第二

佛复告诸大众。我今时至举身疼痛。说是语已即入初禅。以涅槃光遍观世界入寂灭定。尔时世尊所言未讫即入初禅。从初禅出入第二禅。从二禅出入第三禅。从三禅出入第四禅。从四禅出入虚空处。从空处出入无边识处。从识处出入不用处。从不用出入非想非非想处。从非非想处出入灭尽定。从灭尽定出还入非想非非想处。从非非想出入不用处。从不用出入无边识处。从无边识处出入虚空处。从空处出入第四禅。从四禅出入第三禅。从三禅出入第二禅。从二禅出入第一禅

尔时世尊。如是逆顺入诸禅已。普告大众。我以甚深波若。遍观三界一切六道。诸山大海大地含生。如是三界根本性离。毕竟寂灭同虚空相。无名无识永断诸有。本来平等无高下想。无见无闻无觉无知。不可系缚不可解脱。无众生无寿命。不生不起不尽不灭。非世间非非世间。涅槃生死皆不可得。二际平等等诸法故。闲居静住无所施为。究竟安置必不可得。从无住法法性施为。断一切相一无所有。法相如是。其知是者名出世人。是事不知名生死始。汝等大众。应断无明灭生死始

尔时世尊说是语已复入超禅。从初禅出入第三禅。从三禅出入虚空处。从虚空出入无所有处。从无所有出入灭尽想定。从灭尽定出次第还入。至非想非非想处。从非非想出入无边识处。从识处出入第四禅。从四禅出入第二禅。从二禅出入于初禅。如是逆顺入超禅已。复告大众。我以摩诃般若。遍观三界有情无情。一切人法悉皆究竟。无系缚者。无解脱者。无主无依不可摄持。不出三界。不入诸有。本来清净无垢无烦恼。与虚空等。不平等非不平等。尽诸动念思想心息。如是法相名大涅槃。真见此法名为解脱。凡夫不知名曰无明。作是语已复入超禅。从初禅出乃至入灭尽定。从灭尽定出乃至入初禅。如是逆顺入超禅已。复告大众。我以佛眼遍观三界一切诸法。无明本际性本解脱。于十方求了不能得。根本无故。所因枝叶皆悉解脱。无明解脱故。乃至老死皆得解脱。以是因缘。我今安住常寂灭光名大涅槃。尔时阿难。无极悲哀忧愁痛苦。心狂慌乱情识昏迷。如重醉人都无知觉。不见四众。不知如来已入涅槃为未涅槃

尔时世尊。如是三过从超入诸禅定遍观法界。普为大众三反说法。如来如是展转二十七反入诸禅定。阿难。以不知故佛入一禅即致一问。如是二十七反问阿泥楼逗。佛已涅槃为未涅槃。阿泥楼逗深知如来入诸禅定。二十七反皆答阿难。佛未涅槃。尔时一切大众皆悉慌乱都不觉知。如来涅槃为未涅槃。尔时世尊。三反入诸禅定。三反示诲众已。于七宝床右胁而卧。头枕北方足指南方。面向西方后背东方。其七宝床微妙璎珞以为庄严。娑罗树林四双八只。西方一双在如来前。东方一双在如来后。北方一双在佛之首。南方一双在佛之足。尔时世尊。娑罗林下寝卧宝床。于其中夜入第四禅寂然无声。于是时顷便般涅槃。大觉世尊入涅槃已。其娑罗林东西二双合为一树。南北二双合为一树。垂覆宝床盖于如来。其树即时惨然变白犹如白鹤。枝叶花果皮干悉皆爆裂堕落。渐渐枯悴摧折无余

尔时十方无数万亿恒河沙普佛世界。一切大地皆大震动。出种种音唱言。苦哉苦哉。世界空虚。演出无常苦空哀叹之声。尔时十方世界一切诸山。目真邻陀山。摩诃目真邻陀山。铁围山。大铁围山。诸须弥山香山宝山。金山黑山。一切大地所有诸山。一时震裂悉皆崩倒。出大音声震吼世界唱言。苦哉苦哉。如何一旦世间孤露。慧日灭没大涅槃山。一切众生丧真慈父。失所敬天无瞻仰者。尔时十方世界一切大海。悉皆混浊沸涌涛波。出种种音唱言。苦哉苦哉。正觉已灭众生罪苦。长夜久流生死大海。迷失正路何由解脱。尔时一切江河溪涧沟壑。川流。泉源渠井浴池。悉皆倾覆水尽枯涸。尔时十方世界大地虚空寂然大闇。日月精光悉无复照。黑闇愁恼弥布世界。于是时间忽然黑风鼓怒惊振。吹扇尘沙弥闇世界。尔时大地一切卉木。药草诸树花果枝叶。悉皆摧折碎落无遗。于是时顷十方世界一切诸天。遍满虚空哀号悲叹。震动三千大千世界。雨无数百千种种上妙天香天花。遍满三千大千世界[卄/積]高须弥供养如来。于上空中复雨无数天幢天幡天璎珞天轩盖天宝珠。遍满虚空变成宝台。四面珠璎七宝绞络。光明华彩供养如来。于上空中复奏无数微妙天乐。鼓吹弦歌出种种音唱言。苦哉苦哉。佛已涅槃。世界空虚。群生眼灭。烦恼罗刹大欲流行。行苦相续痛轮不息。尔时阿难。心慌迷闷都不觉知。不识如来已入涅槃未入涅槃。唯见非恒境界。复问楼逗。佛涅槃耶。楼逗答言。大觉世尊已入涅槃。尔时阿难闻是语已。闷绝躄地犹如死人。寂无气息冥冥不晓。尔时楼逗。以清冷水洒阿难面扶之令起。以善方便而慰喻之语阿难言。哀哉哀哉。痛苦奈何奈何。莫大愁毒热恼乱心。如来化缘周毕。一切人天无能留者。苦哉苦哉。奈何奈何。何期今日人天之师为事究竟。无能留者。奈何我与汝等且共裁抑。复慰喻言。阿难。佛虽涅槃而有舍利无上法宝。常住于世。能为众生而作归依。我与汝等当勤精进。以佛法宝授与众生。令脱众苦报如来恩。尔时阿难。闻慰喻已渐得醒悟。哽咽流泪悲不自胜。其拘尸那城娑罗林间纵广三十二由旬。天人大众皆悉遍满。尖头针锋受无量众。间无空缺不相障蔽。尔时无数亿菩萨一切大众。悉皆迷闷昏乱浊心。都不觉知如来涅槃及未涅槃。唯见非恒变动。一时同问楼逗。佛涅槃耶。尔时楼逗告诸大众一切天人。大觉世尊已入涅槃。尔时无数一切大众闻是语已。一时昏迷闷绝躄地。苦毒入心阨声不出。其中或有随佛灭者。或失心者。或身心战 掉 者。或互相执手哽咽流泪者。或常捶胸大叫者。或举手拍头自拔发者。或有唱言痛哉痛哉荼毒苦 者 。或有唱言如来涅槃一何疾 哉 。或有唱言失我所敬天者。或有叹言世界空虚众生眼灭者。或有叹言烦恼大鬼已流行者。或有叹言众生善芽种子灭者。或有叹言魔王欣庆解甲胄者。或自呵责身心无常观者。或有正观得解脱者。或有伤叹无归依者。中有遍体血现流洒地者。如是异类殊音。一切大众哀声普震一切世界。尔时娑婆世界主尸弃大梵天王。知佛已入涅槃。与诸天众即从初禅飞空而下。举声大哭流泪悲咽。投如来前闷绝躄地。久乃稣醒哀不自胜。即于佛前以偈悲叹

  世尊往昔本誓愿　　为我等故居忍土
  乃隐无量自在力　　贫所乐法度众生
  方便逐宜随应说　　众生无不受安乐
  诱进令出三有苦　　究竟皆至涅槃道
  如来慈母育众生　　普饮众生大悲乳
  何期一旦忽舍离　　人天孤露无所依
  痛哉众生善种芽　　无天甘露令增长
  善芽渐渐衰灭已　　罪业相牵堕恶道
  奈何世界悉空虚　　众生正慧眼已灭
  既行无明黑闇中　　堕落三有沦溺苦
  奈何众生罪无救　　愿依舍利得解脱
  劝请如来大悲力　　救护令我脱苦地
  何其痛哉此恶世　　如来弃我入涅槃

尔时释提桓因。与诸大众从空而下唱言。苦哉苦哉。发声大哭悲泣流泪。投如来前闷绝躄地。久乃稣醒悲哀哽咽。胡跪佛前。说偈哀叹

  如来历劫行苦行　　普为我等群生故
  得成无上正觉道　　等育众生如一子
  施法药中为上药　　疗病医中为胜医
  大慈悲云荫众生　　甘露慧雨雨一切
  慧日光照无明闇　　无明众生见圣道
  圣月慈光照六趣　　三有蒙光脱众苦
  何期于今舍大慈　　已入涅槃众不见
  本誓大悲今何在　　弃舍众生如涕唾
  我等一切诸众生　　如犊失母必当死
  四众互相执手哭　　捶胸大哀动三界
  苦哉苦哉诸有人　　如何一旦尽孤露
  我等福尽苦何甚　　善芽燋燃无复润
  唯愿法宝舍利光　　照我令脱三有苦
  哀哉痛哉我等众　　几何重得见如来

尔时楼逗。悲哀号泣伤悼无量。胡跪佛前。以偈悲赞

  正觉法王育我等　　饮我法乳长法身
  众生法身未成立　　又复慧命少资粮
  应以八音常演畅　　令众闻已悉悟道
  常放大慈五色光　　令众蒙光皆解脱
  如何今日永涅槃　　行苦众生何依趣
  苦哉世尊舍大悲　　我等孤穷必当死
  虽知世尊现方便　　我等无能不悲哀
  四众迷闷昏失心　　哀动天地震三界
  世尊独处大安乐　　众生大苦欲何之
  世尊往昔为我等　　众劫舍头截手足
  得成无上正觉道　　不久住世即涅槃
  我及四众处无明　　魔王欣庆舍甲胄
  哀哉世尊愿大悲　　舍利慈光摄我等
  伏请世尊愍四众　　法宝流润愿不穷
  我等不能即殒灭　　苟存余命能几何
  苦哉痛切难堪忍　　重见世尊无复期

尔时阿难。闷绝渐醒举手拍头。捶胸哽咽悲泣流泪。哀不自胜。长跪佛前。以偈悲叹

  我昔与佛誓愿力　　幸共同生释种中
  如来得成正觉道　　我为侍者二十载
  深心敬养情未足　　一旦见弃入涅槃
  痛哉哀哉荼毒苦　　无极长夜痛切心
  我身未脱诸有网　　无明之[穀-禾+卵]未出离
  世尊慧[此/束]未啄破　　如何见舍疾涅槃
  我如初生之婴儿　　失母不久必当死
  世尊如何见放舍　　独出三界受安乐
  我今忏悔于世尊　　侍佛已来二十年
  四威仪中多懈堕　　不能悦可大圣心
  愿正觉尊大慈悲　　施我甘露令安乐
  我愿穷尽未来际　　常觐世尊为侍者
  唯愿世尊大慈光　　一切世界摄受我
  痛哉痛哉不可说　　喑咽何能陈圣恩

尔时无数亿恒河沙菩萨。一切世间天人大众。互相执手悲泣流泪。哀不自胜各相裁抑。即皆自办无数微妙香花。曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。无数天上人间海岸栴檀沉水。百千 万 种和香。无数香泥香水。宝盖宝幢宝幡真珠璎珞。遍满虚空。投如来前。悲哀供养。尔时拘尸城内男女大小一切人众悲哀流泪。各办无数微妙香花幡盖等倍胜于前。投如来所悲哀供养。尔时四天王。与诸天众悲哀流泪。各办无数香花一切供养等三倍于前。悲泣流泪来诣佛所。投如来前。悲哀供养五天。如是倍胜于前。色界无色界诸天亦如是倍胜供养

大般涅槃经后分卷上大般涅槃经后分卷下

        大唐南海波淩国沙门若那跋陀罗译

    机感茶毗品第三

尔时拘尸城内一切男女悲泣流泪。不知茶毗法则云何。问阿难言。如来涅槃如何法则可以茶毗。尔时帝释具陈上事而以答言。如佛所说依轮王法。尔时拘尸城内一切人民。悲泣流泪摠入城中。即作金棺七宝庄严。即办微妙无价白[疊*毛]千张。无数细软妙兜罗绵。办无数微妙栴檀沉水。百千万种和香香泥香水。一切缯盖幡花等。如云遍满在于空中积高须弥。既办已讫悲哀流泪。将至佛所投如来前。悲咽不胜而申供养。尔时拘尸城内一切人民及诸大众。重复悲哀哽咽流泪。复持无量香花幡盖一切供具。如云遍满空中。互相执手捶胸哽咽。涕泣盈目哀震大千。投如来前悲哀供养。尔时大众悲哽喑咽深重敬心。各以细妙白[疊*毛]障手。扶于如来入金棺中。注满香油棺门即闭。尔时拘尸城内一切士女贪福善心相欲摄取如来功德。不令天人一切大众同举佛棺。即共详议遣四力士壮大无双。脱其所著璎珞衣服期心请举如来圣棺欲入城内。自申供养尽其神力都不能胜。尔时城内复遣八大力士。至圣棺所脱所著衣共擎佛棺。皆尽其神力都亦不得。拘尸城内复遣十六极大力士。来至棺所脱所著衣。共举佛棺亦不能胜。尔时楼逗语力士言。纵使尽城内人男女大小。举如来棺欲入城内亦不能得。何况汝等而能胜耶。汝等当请大众及诸天力助汝举棺乃得入城。楼逗所言未讫。尔时帝释即持微妙大七宝盖无数香花幢幡音乐。与诸天众悲泣流泪。垂在空中供养圣棺。至第六天及色界天。皆如帝释供养圣棺。尔时世尊大悲普覆。令诸世间得平等心得福无异。于娑罗林即自举棺。升虚空中高一多罗树。拘尸城内一切人民及诸世间人天大众。等共不得举佛圣棺。尔时帝释及诸天众。即持七宝大盖四柱宝台四面庄严。七宝璎珞垂虚空中覆佛圣棺。无数香花幢幡璎珞。音乐微妙杂彩空中供养。至第六天色界诸天。倍前帝释覆佛圣棺及申供养。尔时拘尸城内一切人民。见佛圣棺升在空中。捶胸大哭悲咽懊恼。尔时一切天人于大圣尊宝棺前路。遍散七宝真珠香花璎珞微妙杂彩缤纷如云。地及虚空悉皆遍满。哀泣流泪供养如来七宝灵棺。同声唱言。苦哉苦哉。我等无福。举佛圣棺遂不能得。我等孤露何有善根。尔时世尊大圣金棺。于娑罗林虚空之中。徐徐乘空从拘尸城西门而入。尔时拘尸城内一切士女。无数菩萨声闻天人大众。地及虚空悉皆遍满。随从如来大圣灵棺。互相执手号声大哭。捶胸叫唤喑咽流泪。各持无数香花宝幢幡盖。地及虚空悉皆遍满。悲号哀叹供养灵棺。其拘尸那城一面纵广四十八由旬。尔时如来七宝金棺。徐徐乘空从拘尸城东门而出。乘空右绕入城南门。渐渐空行从北门出。乘空左绕还从拘尸西门而入。如是展转绕三匝已。乘空徐徐还入西门。乘空而行从东门出。空行左绕入城北门。渐渐空行从南门出。乘空右绕还入西门。如是展转绕经四匝。如是左右绕拘尸城经于七匝

尔时七宝圣棺当入城时。一切大众悲号哽咽。各持无数微妙香木。栴檀沉水一切宝香。文理香洁普熏世界。复持无数宝幢幡盖香花璎珞。至茶毗所悲哀供养。尔时四天王及诸天众悲泣流泪。各持天上上妙栴檀沉水。表里香洁芬馥周遍。各五百根大如车轮。复持一切宝香宝幢宝盖妙花璎珞。至茶毗所悲哀供养。第二天各一千根。第三天各二千。第四天各三千。第五天各四千。第六天各五千。及幡花至茶毗所悲哀供养。尔时色界无色诸天惟有香花。至茶毗所悲哀供养。尔时一切世间大众。各持微妙栴檀沉水香花幡盖。至茶毗所悲哀供养。尔时楼逗。涕泣盈目哀悼无极。从诸天人乞妙香木栴檀沉水。足六千根。文理香洁芬馥周遍。至茶毗所悲哀供养。阿耨达池四面纵广二百由旬出四大河。佛初成道恒河北岸。一树栴檀随佛而生。大如车轮高七多罗树。香气普熏供养如来。其香树神与树俱生。常取此香供养于佛。佛入涅槃此一檀树即随佛灭。皮叶俱落神亦随死。有诸异神取此香树。送茶毗所悲哀供养。其地乃是三世诸佛茶毗之处。大觉世尊乘本愿力亦于是处茶毗。是处有诸往古诸佛无量宝塔。金刚不坏坚固之处。尔时如来大圣宝棺。渐渐空行至茶毗所。徐徐垂空下安七宝床上。其床一切众妙璎珞无价杂彩以为庄严。于是时顷复经七日。尔时拘尸城内一切士女。无数菩萨声闻三十三天一切大众。悲哀哽咽持诸幡盖宝幢香花。随从佛棺经于七日。以佛神力一切天人无饥渴想一无思食。唯见哀泣恋慕如来。既满七日大圣如来将欲出棺。尔时拘尸城内一切士女无数大众。复大哀泣震动世界。复持香花无数幢盖微妙天乐。投佛棺前哀咽供养。是时大众悲哽流泪。各以细微白[疊*毛]自障其手深重敬心。从宝棺中扶于如来紫磨黄金三十二相八十种好坚固不坏金刚之身。安详而出置七宝床

尔时大众重大悲哀。声震十方普佛世界。复持一切香花缯盖音乐深心供养。闷绝哽咽投如来前。是时大众复更悲咽盈目流泪。各持无数香水香泥。深重敬心从头至足。灌洗如来三十二相八十种好无量福德智慧庄严。金刚坚固紫磨黄金不坏色身。复洗宝棺微妙清净。既灌洗已。是时大众复大号哭悲哀哽咽。烧微妙香散七宝花。无数宝幢幡盖地及虚空悉皆遍满。悲哀号泣供养如来。是时大众咸哀喑咽。即持无数妙兜罗绵。从头至足缠裹如来金刚色身。既缠身已。复以上妙无价白[疊*毛]千张。于兜罗上次第相重缠如来身。缠身已讫。是时大众重大悲哀号哭闷绝。复持香花幡盖宝幢音乐哽咽供养。是时大众哀泣流泪深重敬心。各以白[疊*毛]障手喑咽悲哽。共扶如来入宝棺中。注满香油棺门寻闭。尔时大众重大悲哀声震世界。复持香花幡盖音乐。号恸悲泣供养宝棺。尔时一切大众所集微妙香木积高须弥。芬馥香气普薰世界。相重密次成大香楼。四面七宝庄严。幢盖幡花璎珞杂彩。遍空如云以为庄严。人天音乐悲哀供养。是时天人大众。将欲举棺置香楼上。复大悲哀捶胸大叫声震大千。复持幢盖香花音乐悲哀供养。是时大众哀悼悲结深重敬心。各以白[疊*毛]障手。共举如来大圣宝棺。置于庄严妙香楼上。复大号泣绝而复稣唱言。苦哉苦哉。何期孤露无有依恃。悲咽流泪。复散香花宝幢幡盖音乐杂彩。一切尽心悲哀供养。尔时如来大圣宝棺。既上微妙宝香楼已。将欲举火茶毗如来。是时大众复大号哭惊震大千。复更深重悲哀供养大圣宝棺及妙香楼。尔时一切大众哀泣盈目。各持七宝香烛大如车轮。焰彩光明遍照世界。一时大哭茶毗香楼。哀震大千一切世界。复以香花遍满供养。是时宝烛至香楼所自然殄灭。是时一切诸天。复持无上七宝大烛焰光普照。悲哀流泪投香楼所皆悉殄灭。尔时一切海神。持海中火七宝大烛无数光焰。投香楼所亦皆殄灭。是时大众。长时号哭一切供养。不知如来何缘未毕。投火香楼茶毗不燃。尔时世尊大悲普润。待迦叶众来至乃燃。时大迦叶。与五百弟子在耆阇崛山。去拘尸城五十由旬。身心寂然入于三昧。于正受中倏尔心惊。举身战栗从定中出。见诸山地皆大震动。即知如来已入涅槃。告诸弟子。我佛大师入般涅槃。时经七日已入棺中。苦哉苦哉。应当疾往至如来所。恐已茶毗不得见佛三十二相八十种好真净色身。迦叶。以敬佛故不敢飞空往如来所。即将弟子寻路疾行。悲哀速往正满七日。至拘尸城城东路首。迦叶。遇见一婆罗门执一天花随路而来。迦叶问言。仁者何来。答曰。佛般涅槃我于茶毗所来。复问。此是何花。答言。于茶毗所得此天花。迦叶就乞。答言。不得。我期将归拟示六亲家中供养。迦叶。就借着其顶上便即闷绝。昏迷躄地喑咽悲哽。良久乃苏即自惟忖。于此号泣不见如来八十种好紫磨色身。何所追益。即与弟子疾共前进。至拘尸城北门而入。于其城中入一僧坊。见诸比丘丛聚一处。语迦叶言。汝等远来深劳苦耶。安坐待食。迦叶答言。我之大师已入涅槃。我有何情安此待食。诸比丘言。汝师是谁。答言。汝不知耶。哀哉痛苦。大觉世尊今已涅槃。比丘闻已各大欢喜而作是言。快哉快哉。如来在世禁制我等戒律严峻。我等甚不堪忍不能依行。今已涅槃严峻禁戒已应放舍。汝且待食。有何急耶。佛神力故掩诸天耳。及大迦叶诸弟子等皆悉不闻恶比丘语。唯有迦叶独自闻之。于是迦叶。即将弟子悲泣流泪疾往佛所。是时迦叶与诸弟子窃共思念。我等如何得诸供物。将至佛所供养如来。迦叶复言。我自生长在此城中。乞供养物亦应可得。将诸弟子即就城内次第告乞。得妙白[疊*毛]足满千张。复得无数妙兜罗绵。复得无量宝花香泥香水香油。宝幢幡盖音乐弦歌璎珞杂彩悉皆具足。迦叶与诸弟子悲哀流泪。即持疾往出城西门。尔时迦叶即闻茶毗之所一切大众悲咽号哭。共问帝释已供养讫。如何得火然此香楼茶毗如来。帝释答言。人众且待。摩诃迦叶即时而至。释言未讫一切大众正于哀中即见迦叶。与诸弟子寻路悲来。众即停哀便为开路。迦叶前进遥见佛棺。将诸弟子一时礼拜。号哭哽咽闷绝躄地。昏浊乱心良久乃醒。流泪不胜渐渐前行问大众言。如何得开大悲圣棺。大众答言。佛入涅槃已经二七。恐有损坏。如何得开。迦叶答言。如来之身金刚坚固。常乐我净不可沮坏。德香芬馥若栴檀山。作是语已涕泗交流至佛棺所。尔时如来大悲平等。为迦叶故棺自然开。白[疊*毛]千张及兜罗绵皆即解散。显出三十二相八十种好真金紫磨坚固色身。迦叶与诸弟子见已。闷绝躄地喑咽哀哽。良久乃苏涕泣盈目。与诸弟子徐上香楼近佛棺边。复更喑咽号哭悲哽。即以所得香花幡盖宝幢璎珞。音乐弦歌哀号供养。即以香泥香水灌洗如来金色之身。烧香散花哀泣供养。灌洗已讫。迦叶与诸弟子。持其所得妙兜罗绵缠于如来紫磨色身。次以旧绵缠新绵上。兜罗缠已。复以所得白[疊*毛]千张。次第相重于兜罗上缠如来身。缠白[疊*毛]已复持旧[疊*毛]。着新[疊*毛]上次第相缠。总缠已讫。棺门即闭。七宝璎珞一切庄严。尔时迦叶复重悲哀。与诸弟子右绕七匝。盈目流泪长跪合掌。说偈哀叹

  苦哉苦哉大圣尊　　我今荼毒苦切心
  世尊灭度一何速　　大悲不能留待我
  我于崛山禅定中　　遍观如来悉不见
  又观见佛已涅槃　　倏尔心战大震惊
  忽见闇云遍世界　　复睹山地大震动
  即知如来已涅槃　　故我疾来已不见
  世尊大悲不普我　　令我不见佛涅槃
  不蒙一言相教告　　我今孤露何所依
  世尊我今大痛苦　　情乱迷闷昏浊心
  我今为礼世尊顶　　为复哀礼如来胸
  为复敬礼大圣手　　为复悲礼如来腰
  为复敬礼如来脐　　为复深心礼佛足
  何苦不见佛涅槃　　惟愿示我敬礼处
  如来在世众安乐　　今入涅槃皆大苦
  哀哉哀哉深大苦　　大悲示教所礼处

尔时迦叶。哽咽悲哀说是偈已。世尊大悲即现二足千辐轮相。出于棺外回示迦叶。从千辐轮放千光明。遍照十方一切世界。尔时迦叶与诸弟子。见佛足已。一时礼拜千辐轮相。即更闷绝昏迷躄地。良久乃醒。与诸弟子哀号哽咽右绕七匝。绕七匝已复礼佛足。悲哀哭泣声震世界。复更说偈哀叹佛足

  如来究竟大悲心　　平等慈光无二照
  众生有感无不应　　示我二足千辐轮
  我今深心归命礼　　千辐轮相二尊足
  千辐轮中放千光　　遍照十方普佛刹
  我今归依头面礼　　千辐轮相长光照
  众生遇光皆解脱　　三涂八难皆离苦
  我复归依头面礼　　轮光普救诸恶趣
  世尊往昔无数劫　　为我等故修苦行
  今证得此金刚体　　足下由放千光明
  悲哀稽首归命礼　　安于众生千辐轮
  佛修众德为一切　　修道树日降四魔
  四魔降已伏外道　　众生因此得正见
  稽首归依头面礼　　众生正见光明足
  佛为一切真慈父　　足光平等度众生
  我复归依头面礼　　平等离苦轮足光
  我遇千辐光明足　　悲喜交流哀切心
  我复悲哀头面礼　　有感千辐轮光相
  稽首归依轮足光　　乘究竟乘出三界
  敬礼天人归依足　　轮光普照三有苦
  众生未得脱苦门　　皆悉归命轮光足
  我等轮回未出离　　如何轮足见放舍
  哀哉哀哉诸众生　　长夜莫睹轮足光
  悔过世尊大慈悲　　示敬千辐轮光足
  哀哉今遇轮光相　　自此当何复再睹

尔时迦叶与诸弟子说是偈已。复重闷绝昏迷躄地。良久渐醒。悲哀哽咽不能自裁。大觉世尊千辐轮相金刚双足。还自入棺封闭如故。尔时城内一切士女天人大众。见大迦叶复重号哭。捶胸大叫哀震大千无量世界。各将所持悲哽供养

尔时拘尸城内有四力士。璎珞严身持七宝炬。大如车轮焰光普照。以焚香楼茶毗如来。炬投香楼自然殄灭。迦叶告言。大圣宝棺三界之火所不能烧。何况汝力而能烧耶。城内复有八大力士。更持七宝大炬光焰。一切将投棺所亦皆殄灭。城内复有十六极大力士。各持七宝大炬来投香楼亦悉殄灭。城内复有三十六极大。力士各持七宝大炬来投亦皆殄灭

尔时迦叶告诸力士一切大众。汝等当知纵使一切天人所有炬火。不能茶毗如来宝棺。汝等不须劳苦强欲为作。尔时城内士女天人大众复重悲哀。各以所持号泣供养。一时礼拜右绕七匝。悲号大哭声震三千。尔时如来以大悲力。从心胸中火踊棺外。渐渐茶毗经于七日。焚妙香楼尔乃方尽。尔时城内士女天人大众。于七日间悲号哭泣哀声不断。各以所持供养不歇。尔时四天王各作是念。我以香水注火令灭。急收舍利天上供养。作是念已即持七宝金瓶盛满香水。复将须弥四埵四大香洁出甘乳树。树各千围高百由旬。随四天王同时而下至茶毗所。树流甘乳注写香瓶一时注火。注已火势转高都无灭也。尔时海神莎伽罗龙王及江神河神。见火不灭各作是念。我取香水注火令灭。急收舍利住处供养。作是念已。各持宝瓶盛取无量香水。至茶毗所一时注火。注已火势如故都亦不灭。尔时楼逗诸四天王及海神等。汝注香水令火灭者。可不欲取舍利还本所居而供养耶。答言。实尔。楼逗语四天王言。汝大贪心。汝居天上舍利随汝。若在天宫。地居之人如何得往而供养耶。复语海神。汝等住在大海江河。如来舍利汝收取者。地居之人如何得往而供养耶。尔时四天王即皆忏悔。悔已各还天宫。尔时大海江河神等。皆亦忏悔诚如圣言。悔已各还

    大般涅槃经圣躯廓润品第四

尔时帝释。持七宝瓶及供养具至茶毗所。其火一时自然灭尽。帝释即开如来宝棺欲请佛牙。楼逗即问。汝何为耶。答言。欲请佛牙还天供养。楼逗言。莫辄自取。可待大众尔乃共分。释言。佛先与我一牙舍利。是以我来火即自灭。帝释说是语已即开宝棺。于佛口中右畔上颔取牙舍利。即还天上起塔供养。尔时有二捷疾罗刹。隐身随释。众皆不见。盗取一双佛牙舍利。尔时城内一切士女一切大众。即一时来欲争舍利。楼逗告言。大众当知待且安详。如佛所说。应当如法共分供养。尔时城内士女一切大众。不闻楼逗所言。乃各执持矛槊弓箭刀剑罥索一切战具。各自庄严欲取舍利。尔时城内人众即开佛棺。兜罗白[疊*毛]宛然不烧。大众见已复大号哭流泪盈目。各将所持悲哀供养。深心礼拜流泪长跪。同说偈赞

  如来以大自在力　　于一切世得自在
  大悲本愿处斯土　　周旋苦海度众生
  无量智慧神通力　　出没生死无挂碍
  能以一身为多身　　多身一身为无量
  神变普应咸皆见　　无缘即现入涅槃
  我等福尽无应缘　　故乃如来见放舍
  佛于娑罗宝棺中　　大力士举皆不起
  大悲之力自轻举　　升空高一多罗树
  乘虚徐绕拘尸城　　七日大圣绕七匝
  绕已自临茶毗所　　不共神力所施为
  一切天人莫能测　　佛于大般涅槃中
  金刚不坏力自在　　一切茶毗火不然
  自于心中出慈火　　焚烧七日示现尽
  人天不能灭此火　　如来大悲示应力
  帝释来至火便灭　　妙兜罗绵缠佛身
  大火焚烧都不燃　　白[疊*毛]随佛宝棺内
  火中俨然而不烧　　方知如来自在力
  于法自在为法王　　敬礼大悲三界尊
  敬礼圣中无畏者　　敬礼普覆大慈力
  敬礼神变自在者　　我等从今离世尊
  没苦无能见救护　　哀哉哀哉大圣尊
  方今长别何由见

尔时大众说是偈已。重复悲泣各以所持尽哀供养。尔时楼逗普为天人一切大众。与城内人共于棺所。徐举白[疊*毛]及兜罗绵。其迦叶等白[疊*毛]千张火全不烧。其城内人白[疊*毛]千张。除外一重余者灰烬。其兜罗绵宛然如故。尔时楼逗取此白[疊*毛]及兜罗绵细破分之。与诸大众令起宝塔而供养之。楼逗复取[疊*毛]灰亦细分众。令起宝塔而供养之。其余烬灰无复得分。众各自取起塔供养。其城内人先已遣匠。造八金坛八师子座。各以七宝而为庄严。其七宝坛各受一斛。各置七宝师子座上。其八师子七宝之座。座别各有三十二力士。各严七宝璎珞杂彩缠身。共举七宝八师子座。座上复各有八婇女。身严七宝璎珞杂彩持七宝坛。座上复各有八婇女。严身璎珞执七宝盖覆金坛上。座上复各有八婇女。身严璎珞持七宝剑卫七宝坛。座上复各有八婇女。身严璎珞执雉毛纛竖坛四面。座别各有无量人众。持妙音乐幢幡宝盖香花璎珞围绕供养。座各复有无量人众。各持弓箭矛槊罥索长钩一切战具而围绕之。从拘尸城前后围绕向茶毗所。其八师子七宝之座出城去后。城内人众即持无数香泥香水。寻力士后平治涂地作香泥路。广博严事向茶毗所。其路两边无数宝幢幡盖香花。真珠璎珞众妙杂彩。音乐弦歌严饰路边。俨然供养待大圣尊舍利而还。其诸力士持八师子七宝之座。围绕至茶毗所。即大哀泣号哭哽咽声震大千。各以所持深心供养

尔时世尊大悲力故。碎金刚体成末舍利。惟留四牙不可沮坏。尔时大众既见舍利复重悲哀。以其所持流泪供养。尔时楼逗。与城内人涕泣盈目收取舍利。着师子座七宝坛中。满八金坛舍利便尽。尔时一切天人大众。见佛舍利入金坛中。重更悲哭涕泣流泪。各将所持深心供养。尔时城内诸大力士及诸士女。将欲持佛舍利金坛向拘尸城。尔时大众复重悲哀。各将所持流泪供养。尔时城内诸大力士及围绕众并城内人悲咽流泪。举八师子七宝之座。随香泥路回向拘尸。尔时一切人天大众。复大悲哀声震世界。各将所持随从舍利哀号供养。如来舍利至城内已置四衢道中。尔时拘尸城人。即严四兵无数军众。身着甲铠各执战具。绕拘尸城四面周匝。无数重兵俨然而住。拟防外人来抄掠故。虽为仪式无战诤心。复有五百大咒术师。守城四门。为遮难故。复有无数宝幢幡盖。微妙庄严大雉毛纛。于城四维俨然供养。为标式故。尔时城内一切士女天人大众。复大悲哀。各将所持深心供养。其舍利坛置师子座经于七日。于七日中一切大众。日夜悲号哀声不断。尽以所持深心供养。其八师子七宝之座。各有五百大咒术师各共持之。遮有天龙夜叉神鬼来欺夺故。经七日间。尔时如来本生眷属。迦毗罗国王诸释种等。佛神力故都不觉知佛入涅槃。佛涅槃后经三七日尔乃方知。时彼国王诸释种等。悲哭号泣即共疾来至拘尸城。见诸兵众无数千人围绕城外。复见宝幢幡盖列城四维映蔽国界。复见大咒术师守城四门。王及释等问咒师言。佛涅槃耶。答云。佛涅槃来过四七日。茶毗已竟将分舍利。王言。我等是佛所生眷属。佛神力故令我不知如来涅槃。我今欲见如来舍利。卿可开路令我得入。咒师兵众闻是语已即听入城。王及释种得入城已。见佛舍利在师子座。悲号哽咽涕泪交流右绕七匝。绕七匝已收泪而言。我今欲请如来舍利一分将还供养。大众答曰。虽知汝是释种眷属。然佛世尊先已有言。分布舍利未见及汝。各有请主。汝如何得汝可还耶。尔时王及释种不果所请。号哭悲哀闷绝躄地。良久乃醒。悲不自胜。语众人言。如来世尊是我释种。愍汝等故于此涅槃。汝等如何见有欺忽。乃不分我一分舍利。作是语讫。各礼舍利。右绕七匝悲泣流泪。生忿恨心慨悼还家

尔时摩迦陀主阿阇世王。害父王已。深生悔恨身生恶疮。既遇世尊月爱光触身疮渐愈。来诣佛所求哀忏悔。世尊大悲。即以甘露微妙法药洗荡身疮。极重罪灭即还本宫。都不觉知如来涅槃。于涅槃夜梦见月落日从地出。星宿云雨缤纷而陨。复有烟气从地而出。见七彗星现于天上。复梦天上有大火聚遍空炽然一时堕地。梦已寻觉心大惊战。即召诸臣。具陈斯梦。此何祥耶。臣答王言。是佛涅槃不祥之相。佛灭度后。三界众生六道有识。烦恼横起。故现大火从天落地。佛入灭度月爱慈光慧云普润。悉皆灭没即云月落。星落地者。佛涅槃后。八万律仪一切戒法。众生违反不依佛教。乃行邪法堕于地狱。日出地者。佛涅槃后三涂恶道苦聚日光出现世间。故感斯梦。王闻是语。将诸臣从 夜半即来 至拘尸城。见诸无数四兵之众。防卫拘尸无量重数。复见城门有咒术师防止外难。王见是已即问咒师。佛涅槃耶。咒师答言。佛涅槃来已经四七。当今大众将分舍利。王言。佛入涅槃我都不知。我于夜梦见不祥事。以问诸臣。方知如来入大涅槃。我欲入城礼拜如来金刚舍利。汝为通路。咒师闻已即听前入。王至城内四衢道中。见师子座舍利金坛。复睹大众悲哀供养。王与徒众一时礼拜悲泣流泪。右绕七匝哀惨供养。尔时王就大众。请求如来一分舍利还国供养。大众答言。何晚至耶。佛已先说分布方法。舍利皆已各有所请。无有仁分。仁可还宫。阿阇世王不果所请。愁忧不乐即礼舍利惆怅而还

尔时毗离外道名王。佛涅槃后经三七已尔乃方知。即将臣从疾往拘尸。既至拘尸即见无数四兵之众。防卫拘尸绕无量重。尔时阿勒伽罗王。佛涅槃后经三七已尔乃方知。即将臣从疾往拘尸。既至拘尸即见无数四兵之众。防卫拘尸绕无量重。尔时毗耨队不畏王。佛入涅槃经三七已尔乃方知。尔时遮罗伽罗国王。佛入涅槃经三七已尔乃方知。尔时师伽那王。佛入涅槃经三七已尔乃方知。尔时波肩罗外道名王。佛入涅槃经三七已尔乃方知。即将臣从疾往拘尸。既至拘尸即见无数四兵之众。防卫拘尸绕无量重。复见城门有大咒师防止外难。王问咒师。佛涅槃耶。答言。佛涅槃来已经四七。当今大众将分舍利。王语咒师。佛入涅槃我都不知。故今晚至。我欲入城礼拜供养如来舍利。汝可开路。咒师闻已即听前入。至四衢道见师子座七宝庄严。安置七宝舍利金坛。复见大众悲哀供养。王将从众一时礼拜悲哀流泪。右绕七匝各以所持凄惨供养。王语众言。佛入涅槃我都不知。一何苦哉。不得见佛。请众与我一分舍利还国供养。众言。汝何来晚。佛已先说分布法轨。舍利皆已各有所请。无有仁分。仁可还宫。王及臣众不果所请。愁忧不乐。即礼舍利悲恋而还。尔时诸菩萨及声闻众。天人龙鬼国王长者大臣人民。一切大众悲号涕泣捶胸大哭。五体投地作礼而去

大般涅槃经后分卷下


大般涅槃经序

    No. 374大般涅槃经序

        后秦释道朗撰

大般涅槃经者。盖是法身之玄堂。正觉之实称。众经之渊镜。万流之宗极。其为体也。妙存有物之表。周流无穷之内。任运而动。见机而赴。任运而动。则乘虚照以御物。寄言蹄以通化。见机而赴。则应万形而为像。即群情而设教。至乃形充十方。而心不易虑。教弥天下。而情不在已。厕流尘蚁而弗下。弥盖群圣而不高。功济万化而不恃。明踰万日而不居。浑然与太虚同量。泯然与法性为一。夫法性以至极为体。至极则归于无变。所以生灭不能迁其常。生灭不能迁其常。故其常不动。非乐不能亏其乐。故其乐无穷。或我生于谬想。非我起于因假。因假存于名数。故至我越名数而非无。越名数而非无。故能居自在之圣位。而非我不能变。非净生于虚净。故真净水镜于万法。水镜于万法。故非净不能渝。是以斯经粗章叙常乐我净为宗义之林。开究玄致为涅槃之原用。能阐秘藏于未闻。启灵管以通照。拯四重之痈疽。拔无间之疣赘。阐秘藏则畅群识之情。审妙我之在已。启灵管则悟玄[火/几]之潜。映神珠之在体。然四重无间诽谤方等。斯乃众患之[病-丙+干]痟。创疣之甚者。故大涅槃以无创疣为义名。斯经以大涅槃为宗目。宗目举则明统摄于众妙。言约而义备。义名立则照三乘之优劣。至极之有在。然冥化无朕。妙契无言。任之冲境。则理不虚运。是以此经开诚言为教本。广众喻以会义。建护法以涉初。睹秘藏以穷原。畅千载之固滞。散灵鹫之余疑。至于理微幽蟠微于微者。则诸菩萨弘郢匠之功。旷舟船之济。请难云构。翻覆周密。由使幽涂融坦。宗归豁然。是故诵其文而不疲。语其义而不倦。甘其味而无足。餐其音而不厌。始可谓微言兴咏于真丹。高韵初唱于赤县。梵音震响于聋俗。真容巨曜于今日。而寡闻之士。偏执之流。不量愚见。敢评大圣无涯之典。遂使是非兴于诤论。讥谤生于快心。先觉不能返其迷。众圣莫能移其志。方将沈蔽八邪之网。长沦九流之渊。不亦哀哉。不亦哀哉。天竺沙门昙无谶者。中天竺人。婆罗门种。天怀秀拔。领鉴明邃。机辩清胜。内外兼综。将乘运流化。先至炖煌。停止数载。大沮渠河西王者。至德潜着。建隆王业。虽形处万机。每思弘大道。为法城堑。会开定西夏。斯经与谶自远而至。自非至感先期。孰有若兹之遇哉。谶既达此。以玄始十年岁次大梁。十月二十三日。河西王劝请令译。谶手执梵文。口宣秦言。其人神情既锐。而为法殷重。临译敬情。殆无遗隐。搜研本正。务存经旨。唯恨梵本分离残缺未备耳。余以庸浅。豫遭斯运。夙夜感戢。欣遇良深。聊试标位。叙其宗格。岂谓必然窥其宏要者哉

大般涅槃经卷第一

        北凉天竺三藏昙无谶译

    寿命品第一

如是我闻。一时佛在拘尸那国力士生地阿利罗跋提河边娑罗双树间。尔时世尊。与大比丘八十亿百千人俱。前后围绕。二月十五日临涅槃时。以佛神力出大音声。其声遍满乃至有顶。随其类音普告众生。今日如来应正遍知。怜愍众生覆护众生。等视众生如罗睺罗。为作归依屋舍室宅。大觉世尊将欲涅槃。一切众生若有所疑。今悉可问。为最后问。尔时世尊。于晨朝时从其面门放种种光。其明杂色。青黄赤白颇梨马瑙光。遍照此三千大千佛之世界。乃至十方亦复如是。其中所有六趣众生遇斯光者。罪垢烦恼一切消除。是诸众生见闻是已。心大忧愁。同时举声悲啼号哭。呜呼慈父。痛哉苦哉。举手拍头捶胸叫唤。其中或有身体战栗涕泣哽咽。尔时大地诸山大海。皆悉震动。时诸众生共相谓言。且各裁抑莫大愁苦。当疾往诣拘尸那城力士生处。至如来所头面礼敬。劝请如来莫般涅槃。住世一劫若减一劫。互相执手复作是言。世间空虚众生福尽。不善诸业增长出世。仁等。今当速往速往。如来不久必入涅槃。复作是言。世间空虚。世间空虚。我等从今无有救护无所宗仰。贫穷孤露。一旦远离无上世尊。设有疑惑当复问谁

时有无量诸大弟子。尊者摩诃迦旃延。尊者薄俱罗。尊者优波难陀。如是等诸大比丘。遇佛光者其身战掉。乃至大动不能自持。心浊迷闷发声大唤。生如是等种种苦恼。尔时复有八十百千诸比丘等。皆阿罗汉。心得自在所作已办。离诸烦恼调伏诸根。如大龙王有大威德。成就空慧逮得己利。如栴檀林栴檀围绕。如师子王师子围绕。成就如是无量功德。一切皆是佛之真子。于其晨朝日始初出。离常住处嚼杨枝时遇佛光明。并相谓言。仁等速疾漱口澡手。作是言已。举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。为欲利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面

尔时复有拘陀罗女。善贤比丘尼。优波难陀比丘尼。海意比丘尼。与六十亿比丘尼等。一切亦是大阿罗汉。诸漏已尽。心得自在所作已办。离诸烦恼调伏诸根。犹如大龙有大威德。成就空慧。亦于晨朝日初出时。举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。亦欲利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面。于比丘尼众中复有诸比丘尼。皆是菩萨人中之龙。位阶十地安住不动。为化众生现受女身。而常修集四无量心。得自在力能化作佛

尔时复有一恒河沙菩萨摩诃萨。人中之龙。位阶十地安住不动。方便现身。其名曰海德菩萨。无尽意菩萨。如是等菩萨摩诃萨而为上首。其心皆悉敬重大乘。安住大乘深解大乘。爱乐大乘守护大乘。善能随顺一切世间作是誓言。诸未度者当令得度。已于过世无数劫中。修持净戒善持所行解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。成就如是无量功德。等观众生如视一子亦于晨朝日初出时遇佛光明。举身毛竖遍体血现如波罗奢花。涕泣盈目生大苦恼。亦为利益安乐众生。成就大乘第一空行。显发如来方便密教。为不断绝种种说法。为诸众生调伏因缘故。疾至佛所稽首佛足。绕百千匝。合掌恭敬却坐一面

尔时复有二恒河沙诸优婆塞。受持五戒威仪具足。其名曰威德无垢称王优婆塞。善德优婆塞等。而为上首。深乐观察诸对治门。所谓苦乐常无常净不净我无我实不实。归依非归依。众生非众生。恒非恒安非安。为无为断不断。涅槃非涅槃。增上非增上。常乐观察如是等法对治之门。亦欲乐闻无上大乘。如所闻已能为他说。善持净戒渴仰大乘。既自充足。复能充足余渴仰者。善能摄取无上智慧。爱乐大乘守护大乘。善能随顺一切世间。度未度者。解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。心常深味清净戒行。悉能成就如是功德。于诸众生生大悲心。平等无二如视一子。亦于晨朝日初出时。为欲阇毗如来身故。人人各取香木万束。栴檀沉水牛头栴檀天木香等。是一一木文理及附。皆有七宝微妙光明。譬如种种杂彩画饰。以佛力故有是妙色青黄赤白。为诸众生之所乐见。诸木皆以种种香涂。郁金沉水及胶香等。散以诸花而为庄严。优钵罗花。拘物头花。波头摩花。分陀利花诸香木上悬五色幡。柔软微妙犹如天衣。憍奢耶衣刍摩缯彩。是诸香木载以宝车。是诸宝车出种种光青黄赤白。辕轹皆以七宝厕填。是一一车驾以四马。是一一马骏疾如风。一一车前竖立五十七宝妙幢。真金罗网弥覆其上。一一宝车复有五十微妙宝盖。一一车上垂诸花鬘。优钵罗花。拘物头花。波头摩花。分陀利花其花纯以真金为叶。金刚为台。是花台中多有黑蜂。游集其中欢娱受乐。又出妙音所谓无常苦空无我。是音声中复说菩萨本所行道。复有种种歌舞伎乐筝笛箜篌箫瑟鼓吹。是乐音中复出是言。苦哉苦哉。世间空虚。一一车前有优婆塞擎四宝案。是诸案上有种种花。优钵罗花。拘物头花。波头摩花。分陀利花。郁金诸香及余薰香。微妙第一。诸优婆塞为佛及僧。办诸食具种种备足。皆是栴檀沉水香薪。八功德水之所成熟其食甘美有六种味。一苦二醋三甘四辛五碱六淡。复有三德。一者轻软。二者净洁。三者如法。作如是等种种庄严。至力士生处娑罗双树间。复以金沙遍布其地。以加陵伽衣钦婆罗衣及缯彩衣而覆沙上。周匝遍满十二由旬。为佛及僧敷置七宝师子之座。其座高大如须弥山。是诸座上皆有宝帐垂诸璎珞。诸娑罗树悉悬种种微妙幡盖。种种好香以涂树身。种种名花以散树间。诸优婆塞各作是念。一切众生若有所乏。须食与食须饮与饮。须头与头须目与目。随诸众生所须之物皆悉给与。作是施时离欲嗔恚秽浊毒心。无余思惟求世福乐。唯期无上清净菩提。是优婆塞等皆已安住于菩萨道。复作是念。如来今者受我食已当入涅槃。作是念已身毛皆竖。遍体血现如波罗奢花。涕泣盈目生大苦恼。各各赍持供养之具。载以宝车香木幢幡宝盖饮食。疾至佛所稽首佛足。以其所持供养之具。供养如来绕百千匝。举声号泣哀动天地。捶胸大叫泪下如雨。复相谓言。苦哉仁者。世间空虚。世间空虚。便自举身投如来前而白佛言。唯愿如来。哀受我等最后供养。世尊知时默然不受。如是三请悉皆不许。诸优婆塞不果所愿。心怀悲恼默然而住。犹如慈父唯有一子卒病丧亡。送其尸骸置于冢间。归还怅恨愁忧苦恼。诸优婆塞忧愁苦恼亦复如是。以诸供具安置一处。却在一面默然而坐

尔时复有三恒河沙诸优婆夷。受持五戒威仪具足。其名曰寿德优婆夷。德鬘优婆夷。毗舍佉优婆夷等。八万四千而为上首。悉能堪任护持正法。为度无量百千众生故。现女身呵责家法。自观己身如四毒蛇。是身常为无量诸虫之所唼食。是身臭秽贪欲狱缚。是身可恶犹如死狗。是身不净九孔常流。是身如城血肉筋骨皮裹其上。手足以为却敌楼橹。目为窍孔。头为殿堂心王处中。如是身城诸佛世尊之所弃舍。凡夫愚人常所味着。贪淫嗔恚愚痴罗刹止住其中。是身不坚犹如芦苇伊兰水泡芭蕉之树。是身无常念念不住。犹如电光暴水幻炎。亦如画水随画随合。是身易坏犹如河岸临峻大树。是身不久当为狐狼鸱枭雕鹫乌鹊饿狗之所食啖。谁有智者当乐此身。宁以牛迹盛大海水。不能具说是身无常不净臭秽。宁丸大地使如枣等。渐渐转小犹葶苈子乃至微尘。不能具说是身过患。是故当舍如弃涕唾。以是因缘诸优婆夷。以空无相无愿之法常修其心。深乐咨受大乘经典。闻已亦能为他演说护持本愿。毁呰女身甚可患厌性不坚牢。心常修集如是正观。破坏生死无际轮转。渴仰大乘既自充足。复能充足余渴仰者。深乐大乘守护大乘。虽现女身实是菩萨善能随顺一切世间。度未度者解未解者。绍三宝种使不断绝。于未来世当转法轮。以大庄严而自庄严。坚持禁戒。皆悉成就如是功德。于诸众生生大悲心。平等无二如视一子。亦于晨朝日初出时各相谓言。今日宜应至双树间。诸优婆夷所设供具倍胜于前持至佛所。稽首佛足绕百千匝。而白佛言。世尊。我等今者为佛及僧办诸供具。唯愿如来哀受我供。如来默然而不许可。诸优婆夷不果所愿。心怀惆怅却坐一面

尔时复有四恒河沙毗耶离城诸离车等。男女大小妻子眷属。及阎浮提诸王眷属。为求法故善修戒行威仪具足。摧伏异学坏正法者。常相谓言。我等当以金银仓库。为令甘露无尽正法深奥之藏久住于世。愿令我等常得修学。若有诽谤佛正法者当断其舌。复作是愿。若有出家毁禁戒者。我当罢令还俗策使。有能深乐护持正法。我当敬重如事父母。若有众僧能修正法。我当随喜令得势力。常欲乐闻大乘经典。闻已亦能为人广说。皆悉成就如是功德。其名曰净无垢藏离车子。净不放逸离车子。恒水无垢净德离车子。如是等各相谓言。仁等。今可速往佛所。所办供养种种具足。一一离车各严八万四千大象。八万四千驷马宝车。八万四千明月宝珠。天木栴檀沉水薪束。种种各有八万四千。一一象前有宝幢幡盖。其盖小者周匝纵广满一由旬。幡最短者长三十二由旬。宝幢卑者高百由旬。持如是等供养之具。往至佛所。稽首佛足绕百千匝。而白佛言。世尊。我等今者为佛及僧办诸供具。唯愿如来哀受我供。如来默然而不许可。诸离车等不果所愿心怀愁恼。以佛神力去地七多罗树。于虚空中默然而住。尔时复有五恒河沙大臣长者。敬重大乘。若有异学谤正法者。是诸人等力能摧伏。犹如雹雨摧折草木。其名曰日光长者。护世长者。护法长者。如是之等而为上首。所设供具五倍于前。俱共往诣娑罗双树间。稽首佛足绕百千匝。而白佛言。世尊。我等今者为佛及僧设诸供具。唯愿哀愍受我等供。如来默然而不受之。诸长者等不果所愿心怀愁恼。以佛神力去地七多罗树。于虚空中默然而住

尔时复有(应有六恒河沙)毗舍离王。及其后宫夫人眷属。阎浮提内所有诸王。除阿阇世并及城邑聚落人民。其名曰月无垢王等。各严四兵欲往佛所。是一一王各有一百八十万亿人民眷属。是诸车兵驾以象马。象有六牙马疾如风。庄严供具六倍于前。宝盖之中有极小者。周匝纵广满八由旬。幡极短者十六由旬。宝幢卑者三十六由旬。是诸王等皆悉安住于正法中恶贱邪法。敬重大乘深乐大乘。怜愍众生等如一子。所持饮食香气流布满四由旬。亦于晨朝日初出时。持是种种上妙甘膳。诣双树间至如来所。而白佛言。世尊。我等为佛及比丘僧设是供具。唯愿如来。哀愍受我最后供养。如来知时亦不许可。是诸王等不果所愿。心怀愁恼却住一面

尔时复有七恒河沙诸王夫人。唯除阿阇世王夫人。为度众生现受女身常观身行。以空无相无愿之法薰修其心。其名曰三界妙夫人。爱德夫人。如是等诸王夫人。皆悉安住于正法中。修行禁戒威仪具足。怜愍众生等如一子。各相谓言。今宜速往诣世尊所。诸王夫人所设供养七倍于前。香花宝幢缯彩幡盖上妙饮食。宝盖小者周匝纵广十六由旬。幡最短者三十六由旬。宝幢卑者六十八由旬。饮食香气周遍流布满八由旬。持如是等供养之具。往如来所稽首佛足绕百千匝。而白佛言。世尊。我等为佛及比丘僧设是供具。唯愿如来。哀愍受我最后供养。如来知时默然不受。时诸夫人不果所愿心怀愁恼。自拔头发捶胸大哭。犹如新丧所爱之子。却在一面默然而住

尔时复有八恒河沙诸天女等。其名曰广目天女。而为上首。作如是言。汝等诸姊。谛观谛观。是诸人众所设种种上妙供具。欲供如来及比丘僧。我等亦当如是严设微妙供具供养如来。如来受已当入涅槃。诸姊。诸佛如来出世甚难。最后供养亦复倍难。若佛涅槃世间空虚。是诸天女爱乐大乘欲闻大乘。闻已亦能为人广说。渴仰大乘既自充足。复能充足余渴仰者。守护大乘。若有异学憎嫉大乘。势能摧灭如雹摧草。护持戒行威仪具足。善能随顺一切世间。度未度者脱未脱者。于未来世当转法轮。绍三宝种使不断绝。修学大乘。以大庄严而自庄严。成就如是无量功德。等慈众生如视一子。亦于晨朝日初出时。各取种种天木香等。倍于人间所有香木。其木香气能灭人中种种臭秽。白车白盖驾四白马。一一车上皆张白帐。其帐四边悬诸金铃种种香花宝幢幡盖。上妙甘膳种种伎乐敷师子座。其座四足纯绀琉璃。于其座后各各皆有七宝倚床。一一座前复有金机。复以七宝而为灯树。种种宝珠以为灯明。微妙天花遍布其地。是诸天女设是供已。心怀哀感涕泪交流生大苦恼。亦为利益安乐众生。成就大乘第一空行。显发如来方便密教。亦为不断种种说法。往诣佛所稽首佛足绕百千匝。而白佛言。世尊。唯愿如来。哀受我等最后供养。如来知时默然不受。诸天女等不果所愿心怀忧恼。却在一面默然而坐

尔时复有九恒河沙诸龙王等住于四方。其名曰和修吉龙王。难陀龙王。婆难陀龙王。而为上首。是诸龙王亦于晨朝日初出时。设诸供具倍于人天。持至佛所稽首佛足绕百千匝。而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不受。是诸龙王不果所愿。心怀愁恼却坐一面

尔时复有十恒河沙诸鬼神王。毗沙门王而为上首。各相谓言。仁等。今者可速诣佛所。设供具倍于诸龙。持往佛所稽首佛足绕百千匝。而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不许。是诸鬼王不果所愿。心怀愁恼却坐一面

尔时复有二十恒河沙金翅鸟王。降怨鸟王而为上首。复有三十恒河沙乾闼婆王。那罗达王而为上首。复有四十恒河沙紧那罗王。善见王而为上首。复有五十恒河沙摩睺罗伽王。大善见王而为上首。复有六十恒河沙阿修罗王。睒婆利王而为上首。复有七十恒河沙陀那婆王。无垢河水王。跋提达多王等。而为上首。复有八十恒河沙罗刹王。可畏王而为上首。舍离恶心更不食人。于怨憎中生慈悲心。其形丑陋。以佛神力皆悉瑞正。复有九十恒河沙树林神王。乐香王而为上首。复有千恒河沙持咒王。大幻持咒王而为上首。复有一亿恒河沙贪色鬼魅。善见王而为上首。复有百亿恒河沙天诸娙女。蓝婆女。郁婆尸女。帝路沾女。毗舍佉女。而为上首。复有千亿恒河沙地诸鬼王。白湿王而为上首。复有十万亿恒河沙等诸天子及诸天王四天王等。复有十万亿恒河沙等四方风神。吹诸树上时非时花散双树间。复有十万亿恒河沙主云雨神。皆作是念。如来涅槃焚身之时。我当注雨令火时灭。众中热闷为作清凉。复有二十恒河沙大香象王。罗睺象王。金色象王。甘味象王。绀眼象王。欲香象王等。而为上首。敬重大乘爱乐大乘。知佛不久当般涅槃。各各拔取无量无边诸妙莲花。来至佛所头面礼佛却住一面。复有二十恒河沙等师子兽王。师子吼王而为上首。施与一切众生无畏。持诸花果来至佛所。稽首佛足却住一面。复有二十恒河沙等诸飞鸟王。凫雁鸳鸯孔雀诸鸟。乾闼婆鸟。迦兰陀鸟。鸲鹆鹦鹉。俱翅罗鸟。婆嘻伽鸟。迦陵频伽鸟。耆婆耆婆鸟。如是等诸鸟持诸花果来至佛所。稽首佛足却住一面。复有二十恒河沙等水牛牛羊。往至佛所出妙香乳。其乳流满拘尸那城。所有沟坑色香美味悉皆具足。成是事已却住一面。复有二十恒河沙等四天下中诸神仙人。忍辱仙等而为上首。持诸香花及诸甘果来诣佛所。稽首佛足绕佛三匝。而白佛言。唯愿世尊。哀受我等最后供养。如来知时默然不许。时诸仙人不果所愿。心怀愁恼却住一面。阎浮提中一切蜂王。妙音蜂王而为上首。持种种花来诣佛所。稽首佛足绕佛一匝却住一面

尔时阎浮提中比丘比丘尼一切皆集。唯除尊者摩诃迦叶阿难二众。复有无量阿僧祇恒河沙等世界中间。及阎浮提所有诸山。须弥山王而为上首。其山庄严丛林蓊郁。诸树茂盛枝条扶疏荫蔽日光。种种妙花周遍而有。龙泉流水清净香洁。诸天龙神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。神仙咒术作倡伎乐。如是等众弥满其中。是诸山神亦来诣佛。稽首佛足却住一面。复有阿僧祇恒河沙等。四大海神及诸河神。有大威德。具大神足。所设供养。倍胜于前。诸神身光伎乐灯明。悉蔽日月令不复现。以占婆花散熙连河。来至佛所稽首佛足却住一面

尔时拘尸那城娑罗树林。其林变白犹如白鹤。于虚空中自然而有七宝堂阁。雕文刻镂绮饰分明。周匝栏楯众宝杂厕。堂下多有流泉浴池。上妙莲花弥满其中。犹如北方郁单越国。亦如忉利欢喜之园。尔时娑罗树林中间。种种庄严。甚可爱乐。亦复如是。是诸天人阿修罗等。咸睹如来涅槃之相。皆悉悲感愁忧不乐

尔时四天王释提桓因。各相谓言。汝等观察诸天世人及阿修罗。大设供养欲于最后供养如来。我等亦当如是供养。若我最后得供养者。檀波罗蜜则为成就满足不难。尔时四天王所设供养倍胜于前。持曼陀罗花摩诃曼陀罗花。迦枳楼伽花摩诃迦枳楼伽花。曼殊沙花摩诃曼殊沙花。散多尼迦花摩诃散多尼迦花。爱乐花大爱乐花。普贤花。大普贤花。时花大时花。香城花大香城花。欢喜花大欢喜花。发欲花大发欲花。香醉花大香醉花。普香花大普香花天金叶花龙华。波利质多树花拘毗罗树花。复持种种上妙甘膳。来至佛所稽首佛足。是诸天人所有光明。能覆日月令不复现。以是供具欲供养佛。如来知时默然不受。尔时诸天不果所愿。愁忧苦恼却住一面

尔时释提桓因及三十三天。设诸供具亦倍胜前。及所持花亦复如是。香气微妙甚可爱乐。持得胜堂并诸小堂。来至佛所稽首佛足。而白佛言。世尊。我等深乐爱护大乘。唯愿如来哀受我食。如来知时默然不受。时诸释天不果所愿。心怀愁恼却住一面。乃至第六天所设供养展转胜前。宝幢幡盖。宝盖小者覆四天下。幡最短者周围四海。幢最卑者至自在天。微风吹幡出妙音声。持上甘膳来诣佛所稽首佛足白佛言。世尊。唯愿如来哀受我等最后供养。如来知时默然不受。是诸天等不果所愿。心怀愁恼却住一面。上至有顶。其余梵众一切来集。尔时大梵天王及余梵众。放身光明遍四天下。欲界人天日月光明悉不复现。持诸宝幢缯彩幡盖。幡极短者悬于梵宫至娑罗树间。来诣佛所稽首佛足白佛言。世尊。唯愿如来。哀受我等最后供养。如来知时默然不受。尔时诸梵不果所愿。心怀愁恼却住一面。尔时毗摩质多阿修罗王。与无量阿修罗大眷属俱。身诸光明胜于梵天。持诸宝幢缯彩幡盖。其盖小者覆千世界。上妙甘膳来诣佛所稽首佛足而白佛言。唯愿如来。哀受我等最后供养。如来知时默然不受。诸阿修罗不果所愿。心怀愁恼却住一面

尔时欲界魔王波旬。与其眷属诸天婇女。无量无边阿僧祇众。开地狱门施清冷水。因而告曰。汝等今者无所能为。唯当专念如来应正遍知。建立最后随喜供养。当令汝等长夜获安。时魔波旬于地狱中。悉除刀剑无量苦毒。炽然炎火注雨灭之。以佛神力复发。是心。令诸眷属皆舍刀剑弓弩铠仗鉾槊长钩金锤钺斧斗轮罥索。所持供养倍胜一切人天所设。其盖小者覆中千界。来至佛所稽首佛足而白佛言。我等今者爱乐大乘守护大乘。世尊。若有善男子善女人。为供养故。为怖畏故。为诳他故。为财利故。为随他故。受是大乘或真或伪。我等尔时当为是人除灭怖畏。说如是咒

啅抧　吒吒罗啅抧　卢呵隶　摩诃卢诃隶　阿罗　遮罗　多罗　莎呵

是咒。能令诸失心者怖畏者说法者不断正法者。为伏外道故。护己身故。护正法故。护大乘故。说如是咒。若有能持如是咒者无恶象怖。若至旷野空泽崄处不生怖畏。亦无水火师子虎狼盗贼王难。世尊。若有能持如是咒者。悉能除灭如是等怖。世尊。持是咒者我当护之如龟藏六。世尊。我等今者不以谕谄说如是事。持是咒者我当至诚益其势力。唯愿如来。哀受我等最后供养。尔时佛告魔波旬言。我不受汝饮食供养。我已受汝所说神咒。为欲安乐一切众生四部众故。佛说是已默然不受。如是三请皆亦不受。时魔波旬不果所愿。心怀愁恼却住一面

尔时大自在天王与其眷属无量无边及诸天众。所设供具悉覆梵释护世四王人天八部及非人等所有供具。梵释所设犹如聚墨在珂贝边悉不复现宝盖小者能覆三千大千世界。持如是等供养之具。来诣佛所稽首佛足绕无数匝白佛言。世尊。我等所献微末供具。喻如蚊子供养于我。亦如有人以一掬水投于大海。然一小灯助百千日。春夏之月众花茂盛。有持一花益于众花。以亭历子益须弥山。岂当有益大海日明众花须弥。世尊。我今所奉微末供具亦复如是。若以三千大千世界满中香花伎乐幡盖。供养如来尚不足言。何以故。如来为诸众生常于地狱饿鬼畜生诸恶趣中受诸苦恼。是故世尊。应见哀愍受我等供

尔时东方去此无量无数阿僧祇恒河沙数微尘等世界。彼有佛土名意乐美音。佛号虚空等如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时彼佛即告第一大弟子言。善男子。汝今宜往西方娑婆世界。彼土有佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛不久当般涅槃。善男子。汝可持此世界香饭。其饭香美。食之安隐。可以此食奉献彼佛世尊。世尊食已入般涅槃。善男子。并可礼敬请决所疑。尔时无边身菩萨摩诃萨。即受佛教从座而起。稽首佛足右绕三匝。与无量阿僧祇菩萨俱。从彼国发来至此娑婆世界。应时此间三千大千世界大地六种震动。于是众中梵释四天王魔王波旬摩醯首罗。如是大众见是地动。举身毛竖喉舌枯燥。惊怖战栗各欲四散。自见其身无复光明。所有威德殄灭无余。是时文殊师利法王子。即从座起告诸大众。诸善男子。汝等勿怖。汝等勿怖。何以故。东方去此无量无数阿僧祇恒河沙微尘等世界。有世界名意乐美音。佛号虚空等如来应正遍知十号具足。彼有菩萨名无边身。与无量菩萨欲来至此供养如来。以彼菩萨威德力故。令汝身光悉不复现。是故汝等应生欢喜勿怀恐怖。尔时大众悉皆遥见彼佛大众。如明镜中自观己身。时文殊师利复告大众。汝今所见彼佛大众如见此佛。以佛神力复当如是得见九方无量诸佛。尔时大众各相谓言。苦哉苦哉。世间空虚。如来不久当般涅槃。是时大众一切悉见无边身菩萨及其眷属。是菩萨身一一毛孔各各出生一大莲花。一一莲花各有七万八千城邑。纵广正等如毗耶离城。墙壁诸堑七宝杂厕。多罗宝树七重行列。人民炽盛安隐丰乐。阎浮檀金以为却敌。一一却敌各有种种七宝林树花果茂盛。微风吹动出微妙音。其声和雅犹如天乐。城中人民闻是音声。即得受于上妙快乐。是诸堑中妙水盈满。清净香洁如真琉璃。是诸水中有七宝船。诸人乘之游戏澡浴。共相娱乐快乐无极。复有无量杂色莲花。优钵罗花。拘物头花。波头摩花。分陀利花。其花纵广犹如车轮。其堑岸上多有园林。一一园中有五泉池。是诸池中复有诸花。优钵罗花。拘物头花。波头摩花。分陀利花。其花纵广亦如车轮。香气馚馥甚可爱乐。其水清净柔软第一。凫雁鸳鸯游戏其中。其园各有众宝宫宅。一一宫宅纵广正等满四由旬。所有墙壁四宝所成。所谓金银琉璃颇梨。真金为向周匝栏楯。玫瑰为地金沙布上。是宫宅中多有七宝流泉浴池。一一池边各有十八黄金梯陛。阎浮檀金为芭蕉树。如忉利天欢喜之园。是一一城各有八万四千人王。一一诸王各有无量夫人婇女。共相娱乐欢喜受乐。其余人民亦复如是。各于住处共相娱乐是中众生不闻余名。纯闻无上大乘之声。是诸花中一一各有师子之座。其座四足皆绀琉璃。柔软素衣以布座上。其衣微妙出过三界。一一座上有一王坐。以大乘法教化众生。或有众生书持读诵如说修行。如是流布大乘经典。尔时无边身菩萨。安止如是无量众生。于自身已令舍世乐。皆作是言。苦哉苦哉。世间空虚。如来不久当般涅槃。尔时无边身菩萨。与无量菩萨周匝围绕。示现如是神通力已。持是种种无量供具。及以上妙香美饮食。若有得闻是食香气。烦恼诸垢皆悉消灭。以是菩萨神通力故。一切大众悉皆得见如是变化无边身菩萨。身大无边量同虚空。唯除诸佛余无能见是菩萨身其量边际。尔时无边身菩萨及其眷属。所设供养倍胜于前。来至佛所稽首佛足合掌恭敬白佛言。世尊。唯愿哀愍受我等食。如来知时默然不受。如是三请悉亦不受。尔时无边身菩萨及其眷属。却住一面。南西北方诸佛世界。亦有无量无边身菩萨。所持供养倍胜于前。来至佛所乃至却住一面皆亦如是

尔时娑罗双树吉祥福地。纵广三十二由旬大众充满间无空缺。尔时四方无边身菩萨及其眷属所坐之处。或如锥头针锋微尘。十方如微尘等诸佛世界诸大菩萨悉来集会。及阎浮提一切大众亦悉来集。唯除尊者摩诃迦叶阿难二众。阿阇世王及其眷属。乃至毒蛇视能杀人蜣螂蝮蝎及十六种行恶业者。一切来集。陀那婆神阿修罗等。悉舍恶念皆生慈心。如父如母如姊如妹。三千大千世界众生。慈心相向亦复如是。除一阐提。尔时三千大千世界。以佛神力故地皆柔软。无有丘墟土沙砾石荆棘毒草。众宝庄严犹如西方无量寿佛极乐世界。是时大众悉见十方如微尘等诸佛世界。如于明镜自观己身。见诸佛土亦复如是。尔时如来面门所出五色光明。其光明曜覆诸大会。令彼身光悉不复现所应作已还从口入。时诸天人及诸会众阿修罗等。见佛光明还从口入。皆大恐怖身毛为竖。复作是言。如来光明出已还入。非无因缘必于十方所作已办。将是最后涅槃之相。何期苦哉。何期苦哉。如何世尊。一旦舍离四无量心。不受人天所奉供养。圣慧日光从今永灭。无上法船于斯沉没。呜呼痛哉。世间大苦。举手捶胸悲号啼哭。支节战动不能自持。身诸毛孔流血洒地

大般涅槃经卷第一大般涅槃经卷第二

        北凉天竺三藏昙无谶译

    寿命品第一之二

尔时会中有优婆塞。是拘尸那城工巧之子。名曰纯陀。与其同类十五人俱。为令世间得善果故。舍身威仪从座而起。偏袒右肩右膝着地。合掌向佛悲泣堕泪。顶礼佛足而白佛言。唯愿世尊及比丘僧。哀受我等最后供养。为度无量诸众生故。世尊。我等从今无主无亲。无救无护无归无趣贫穷饥困。欲从如来求将来食。唯愿哀愍受我微供。然后乃入于般涅槃。世尊。譬如刹利若婆罗门毗舍首陀。以贫穷故远至他国。役力农作得好调牛。良田平正。无诸沙卤恶草株杌。唯悕天雨。言调牛者喻身口七。良田平正喻于智慧。除去沙卤恶草株杌喻除烦恼。世尊。我今身有调牛良田除去株杌。唯悕如来甘露法雨。贫四姓者即我身是贫。于无上法之财宝。唯愿哀愍除断我等贫穷困苦。拯及无量苦恼众生。我今所供虽复微少冀得充足如来大众。我今无主无亲无归。愿垂矜愍如罗睺罗

尔时世尊一切种智无上调御告纯陀曰。善哉善哉。我今为汝除断贫穷。无上法雨雨汝身田令生法芽。汝今于我欲求寿命色力安辩。我当施汝常命色力安无碍辩。何以故。纯陀。施食有二果报无差。何等为二。一者受已得阿耨多罗三藐三菩提。二者受已入于涅槃。我今受汝最后供养。令汝具足檀波罗蜜。尔时纯陀即白佛言。如佛所说二施果报无差别者。是义不然。何以故。先受施者烦恼未尽。未得成就一切种智。亦未能令众生具足檀波罗蜜。后受施者烦恼已尽。已得成就一切种智。能令众生普得具足檀波罗蜜。先受施者直是众生。后受施者是天中天。先受施者是杂食身烦恼之身。是后边身是无常身。后受施者无烦恼身金刚之身。法身常身无边之身。云何而言二施果报等无差别。先受施者未能具足檀波罗蜜乃至般若波罗蜜。唯得肉眼未得佛眼乃至慧眼。后受施者已得具足檀波罗蜜乃至般若波罗蜜。具足佛眼乃至慧眼。云何而言二施果报等无差别。世尊。先受施者受已食啖入腹消化。得命得色得力得安得无碍辩。后受施者不食不消无五事果。云何而言二施果报等无差别

佛言。善男子。如来已于无量无边阿僧祇劫。无有食身烦恼之身。无后边身常身法身金刚之身。善男子。未见佛性者名烦恼身杂食之身。是后边身菩萨尔时受饮食已入金刚三昧。此食消已即见佛性得阿耨多罗三藐三菩提。是故我言二施果报等无差别。菩萨尔时破坏四魔。今入涅槃亦破四魔。是故我言二施果报等无差别。菩萨尔时虽不广说十二部经先已通达。今入涅槃广为众生分别演说。是故我言二施果报等无差别。善男子。如来之身已于无量阿僧祇劫不受饮食。为诸声闻说言。先受难陀难陀波罗二牧牛女所奉乳糜。然后乃得阿耨多罗三藐三菩提。我实不食。我今为于此会大众。是故受汝最后所奉。实亦不食

尔时大众闻佛世尊普为大会受于纯陀最后供养。欢喜踊跃同声赞言。善哉善哉。希有纯陀。汝今立字名不虚称言。纯陀者名解妙义。汝今建立如是大义。是故依实从义立名。故名纯陀。汝今现世得大名利德愿满足。甚奇纯陀。生在人中复得难得无上之利。善哉纯陀。如优昙花世间希有。佛出于世亦复甚难。值佛生信闻法复难。佛临涅槃最后供养。能辨是事复难于是。南无纯陀。南无纯陀。汝今已具檀波罗蜜。犹如秋月十五日夜。清净圆满无诸云翳。一切众生无不瞻仰。汝亦如是。而为我等之所瞻仰。佛已受汝最后供养。令汝具足檀波罗蜜。南无纯陀。是故说汝如月盛满。一切众生无不瞻仰。南无纯陀。虽受人身心如佛心。汝今纯陀。真是佛子。如罗睺罗等无有异。尔时大众即说偈言

  汝虽生人道　　已超第六天
  我及一切众　　今故稽首请
  人中最胜尊　　今当入涅槃
  汝应愍我等　　唯愿速请佛
  久住于世间　　利益无量众
  演说智所赞　　无上甘露法
  汝若不请佛　　我命将不全
  是故应见为　　稽请调御师

尔时纯陀欢喜踊跃。譬如有人父母卒丧忽然还活。纯陀欢喜亦复如是。复起礼佛。而说偈言

  快哉获己利　　善得于人身
  蠲除贪恚等　　永离三恶道
  快哉获己利　　遇得金宝聚
  值遇调御师　　不惧堕畜生
  佛如优昙花　　值遇生信难
  遇已种善根　　永离饿鬼苦
  亦复能损减　　阿修罗种类
  芥子投针锋　　佛出难于是
  我以具足檀　　度人天生死
  佛不染世法　　如莲花处水
  善断有顶种　　永度生死流
  生世为人难　　值佛世亦难
  犹如大海中　　盲龟遇浮孔
  我今所奉食　　愿得无上报
  一切烦恼结　　摧破不坚牢
  我今于此处　　不求天人身
  设使得之者　　心亦不甘乐
  如来受我供　　欢喜无有量
  犹如伊兰花　　出于栴檀香
  我身如伊兰　　如来受我供
  如出栴檀香　　是故我欢喜
  我今得现报　　最胜上妙处
  释梵诸天等　　悉来供养我
  一切诸世间　　悉生诸苦恼
  以知佛世尊　　欲入于涅槃
  高声唱是言　　世间无调御
  不应舍众生　　应视如一子
  如来在僧中　　演说无上法
  如须弥宝山　　安处于大海
  佛智能善断　　我等无明闇
  犹如虚空中　　起云得清凉
  如来能善除　　一切诸烦恼
  犹如日出时　　除云光普照
  是诸众生等　　啼泣面目肿
  悉皆为生死　　苦水之所漂
  以是故世尊　　应长众生信
  为断生死苦　　久住于世间

佛告纯陀。如是如是。如汝所说。佛出世难如优昙花。值佛生信亦复甚难。佛临涅槃最后施食。能具足檀复倍甚难。汝今纯陀。莫大愁苦应生踊跃喜自庆幸。得值最后供养如来。成就具足檀波罗蜜。不应请佛久住于世。汝今当观诸佛境界悉皆无常。诸行性相亦复如是。即为纯陀。而说偈言

  一切诸世间　　生者皆归死
  寿命虽无量　　要必当有尽
  夫盛必有衰　　合会有别离
  壮年不久停　　盛色病所侵
  命为死所吞　　无有法常者
  诸王得自在　　势力无等双
  一切皆迁动　　寿命亦如是
  众苦轮无际　　流转无休息
  三界皆无常　　诸有无有乐
  有道本性相　　一切皆空无
  可坏法流转　　常有忧患等
  恐怖诸过恶　　老病死衰恼
  是诸无有边　　易坏怨所侵
  烦恼所缠裹　　犹如蚕处茧
  何有智慧者　　而当乐是处
  此身苦所集　　一切皆不净
  扼缚痈疮等　　根本无义利
  上至诸天身　　皆亦复如是
  诸欲皆无常　　故我不贪着
  离欲善思惟　　而证于真实
  究竟断有者　　今日当涅槃
  我度有彼岸　　已得过诸苦
  是故于今者　　纯受上妙乐
  以是因缘故　　证无戏论边
  永断诸缠缚　　今日入涅槃
  我无老病死　　寿命不可尽
  我今入涅槃　　犹如大火灭
  纯陀汝不应　　思量如来义
  当观如来住　　犹如须弥山
  我今入涅槃　　受于第一乐
  诸佛法如是　　不应复啼哭

尔时纯陀白佛言。世尊。如是如是。诚如圣教。我今所有智慧微浅犹如蚊虻。何能思议如来涅槃深奥之义。世尊。我今已与诸大龙象菩萨摩诃萨。断诸结漏文殊师利法王子等。世尊。譬如幼年初得出家。虽未受具即堕僧数。我亦如是。以佛菩萨神通力故。得在如是大菩萨数。是故我今欲令如来久住于世不入涅槃。譬如饥人终无变吐。愿使世尊亦复如是。常住于世不入涅槃

尔时文殊师利法王子告纯陀言。纯陀。汝今不应发如是言。欲使如来常住于世不般涅槃。如彼饥人无所变吐。汝今当观诸行性相。如是观行具空三昧。欲求正法应如是学。纯陀问言。文殊师利。夫如来者。天上人中最尊最胜。如是如来岂是行耶。若是行者为生灭法。譬如水泡速起速灭。往来流转犹如车轮。一切诸行亦复如是。我闻诸天寿命极长。云何世尊是天中天。寿命更促不满百年。如聚落主势得自在。以自在力能制他人。是人福尽其后贫贱。人所轻蔑为他策使。所以者何。失势力故。世尊亦尔同于诸行。同诸行者则不得称为天中天。何以故。诸行即是生死法故。是故文殊。勿观如来同于诸行

复次文殊。为知而说不知而说。而言如来同于诸行。设使如来同诸行者。则不得言于三界中为天中天自在法王。譬如人王有大力士。其力当千。更无有能降伏之者。故称此人一人当千。如是力士王所爱念。偏赐爵禄封赏自然。所以得称当千人者。是人未必力敌于千。但以种种伎艺所能能胜千故。故称当千。如来亦尔。降烦恼魔阴魔天魔死魔。是故如来名三界尊。如彼力士一人当千。以是因缘成就具足种种无量真实功德。故称如来应正遍知。文殊师利。汝今不应忆想分别以如来法同于诸行。譬如巨富长者生子。相师占之有短寿相。父母闻已知其不任绍继家嗣。不复爱重视如刍草。夫短寿者不为沙门婆罗门等男女大小之所敬念。若使如来同诸行者。亦复不为一切世间人天众生之所奉敬。如来所说不变不异真实之法亦无受者。是故文殊。不应说言如来同于一切诸行

复次文殊。譬如贫女无有居家救护之者。加复病苦饥渴所逼。游行乞丐止他客舍寄生一子。是客舍主驱逐令去。其产未久携抱是儿欲至他国。于其中路遇恶风雨寒苦并至。多为蚊虻蜂螫毒虫之所唼食。经由恒河抱儿而度。其水漂疾而不放舍。于是母子遂共俱没。如是女人慈念功德。命终之后生于梵天。文殊师利若有善男子欲护正法。勿说如来同于诸行不同诸行。唯当自责我今愚痴未有慧眼。如来正法不可思议。是故不应宣说如来定是有为定是无为。若正见者。应说如来定是无为。何以故。能为众生生善法故生怜愍故。如彼贫女在于恒河为爱念子而舍身命。善男子。护法菩萨亦应如是。宁舍身命不说如来同于有为。当言如来同于无为。以说如来同无为故得阿耨多罗三藐三菩提。如彼女人得生梵天。何以故。以护法故。云何护法。所谓说言如来同于无为。善男子。如是之人虽不求解脱解脱自至。如彼贫女不求梵天梵天自至。文殊师利。如人远行中路疲极寄止他舍。卧寐之中其室忽然大火卒起。即时惊寤。寻自思惟。我于今者定死不疑。具惭愧故以衣缠身。即便命终生忉利天。从是已后满八十返作大梵王。满百千世生于人中为转轮王。是人不复生三恶趣。展转常生安乐之处。以是缘故。文殊师利。若善男子。有惭愧者不应观佛同于诸行文殊师利。外道邪见可说如来同于有为。持戒比丘不应如是于如来所生有为想。若言如来是有为者。即是妄语。当知是人死入地狱。如人自处于己舍宅。文殊师利。如来真实是无为法。不应复言是有为也。汝从今日于生死中应舍无智求于正智当知如来即是无为。若能如是观如来者。具足当得三十二相。速疾成就阿耨多罗三藐三菩提。尔时文殊师利法王子赞纯陀言。善哉善哉。善男子。汝今已作长寿因缘能知如来是常住法不变异法无为之法。汝今如是善覆如来有为之相。如彼火人为惭愧故以衣覆身。以是善心生忉利天。复为梵王转轮圣王。不至恶趣常受安乐。汝亦如是善覆如来有为相故。于未来世必定当得三十二相八十种好十八不共法无量寿命。不在生死常受安乐。不久得成应正遍知。纯陀。如来次后自当广说我之与汝俱亦当覆如来有为。有为无为且共置之。汝可随时速施饭食。如是施者。诸施中最。若比丘比丘尼优婆塞优婆夷。远行疲极所须之物应当清净随时给与。如是速施即是具足檀波罗蜜根本种子。纯陀。若有最后施佛及僧。若多若少若足不足宜速及时。如来正尔当般涅槃。纯陀答言。文殊师利。汝今何故。贪为此食而言多少足与不足令我时施。文殊师利。如来昔日苦行六年尚自支持。况于今日须臾间耶。文殊师利。汝今实谓如来正觉受斯食耶。然我定知如来身者。即是法身非为食身。尔时佛告文殊师利。如是如是。如纯陀言。善哉纯陀。汝已成就微妙大智。善入甚深大乘经典。文殊师利语纯陀言。汝谓如来是无为者。如来之身即是长寿。若作是知佛所悦可。纯陀答言。如来非独悦可于我。亦复悦可一切众生。文殊师利言。如来于汝及以于我一切众生皆悉悦可。纯陀答言。汝不应言如来悦可。夫悦可者则是倒想。若有倒想则是生死。有生死者即有为法。是故文殊。勿谓如来是有为也。若言如来是有为者。我与仁者俱行颠倒。文殊师利。如来无有爱念之想。夫爱念者。如彼母牛爱念其子。虽复饥渴行求水草。若足不足忽然还归。诸佛世尊无有是念。等视一切如罗睺罗。如是念者。即是诸佛智慧境界。文殊师利。譬如国王调御驾驷。欲令驴车而及之者。无有是处。我与仁者亦复如是。欲尽如来微密深奥亦无是处。文殊师利。如金翅鸟飞升虚空无量由旬。下观大海悉见水性鱼鳖鼋鼍龟龙之属。及见己影如于明镜见诸色像。凡夫少智不能筹量如是所见。我与仁者亦复如是。不能筹量如来智慧。文殊师利语纯陀言。如是如是。如汝所说。我于此事非为不达。直欲试汝诸菩萨事

尔时世尊。从其面门出种种光。其光明曜照文殊身。文殊师利。遇斯光已即知是事。寻告纯陀。如来今者现是瑞相。不久必当入于涅槃。汝先所设最后供养。宜时奉献佛及大众。纯陀当知。如来放是种种光明非无因缘。纯陀闻已情塞默然。佛告纯陀。汝所奉施佛及大众今正是时。如来正尔当般涅槃。第二第三亦复如是。尔时纯陀闻佛语已。举声啼哭悲咽而言。苦哉苦哉。世间空虚。复白大众。我等今者一切当共五体投地。同声劝佛莫般涅槃。尔时世尊复告纯陀。莫大啼哭令心憔悴。当观是身。犹如芭蕉热时之炎。水泡幻化乾闼婆城坏器电光。亦如画水临死之囚熟果段肉。如织经尽如碓上下。当观诸行犹杂毒食。有为之法多诸过患。于是纯陀复白佛言。如来不欲久住于世。我当云何而不啼泣。苦哉苦哉。世间空虚。唯愿世尊。怜愍我等及诸众生。久住于世勿般涅槃。佛告纯陀。汝今不应发如是言。怜愍我故久住于世。我以怜愍汝及一切。是故今欲入于涅槃。何以故。诸佛法尔。有为亦然。是故诸佛。而说偈言

  有为之法　　其性无常　　生已不住
  寂灭为乐

纯陀。汝今当观一切行杂诸法。无我无常不住。此身多有无量过患犹如水泡。是故汝今不应啼泣。尔时纯陀复白佛言。如是如是。诚如尊教。虽知如来方便示现入于涅槃。而我不能不怀苦恼。覆自思惟复生庆悦。佛赞纯陀。善哉善哉。能知如来示同众生方便涅槃。纯陀。汝今当听如娑罗娑鸟。春阳之月皆共集彼阿耨达池。诸佛亦尔。皆至是处。纯陀。汝今不应思惟诸佛长寿短寿。一切诸法皆如幻相。如来在中以方便力无所染着。何以故。诸佛法尔。纯陀。我今受汝所献供养。为欲令汝度于生死诸有流故。若诸人天于此最后供养我者。悉皆当得不动果报常受安乐。何以故。我是众生良福田故。汝若复欲为诸众生作福田者。速办所施不宜久停。尔时纯陀。为诸众生得度脱故。低头饮泪而白佛言。善哉世尊。我若堪任为福田时。则能了知如来涅槃及非涅槃。我等今者及诸声闻缘觉智慧犹如蚊蚁。实不能量如来涅槃及非涅槃。尔时纯陀及其眷属。愁忧啼泣围绕如来。烧香散花尽心敬奉。寻与文殊从座而去。供办食具。其去未久。是时此地六种震动。乃至梵世亦复如是。地动有二。或有地动或大地动。小动者名为地动。大动者名大地动。有小声者名曰地动。有大声者名大地动。独地动者名曰地动。山河树木及大海水一切动者名大地动。一向动者名曰地动。周回旋转名大地动。动名地动。动时能令众生心动名大地动。菩萨初从兜率天下阎浮提时名大地动。从初生出家成阿耨多罗三藐三菩提转于法轮及般涅槃名大地动。今日如来将入涅槃。是故此地如是大动。时诸天龙乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。闻是语已身毛皆竖。同声哀泣。而说偈言

  稽首礼调御　　我等今劝请
  违离于人仙　　永无有救护
  今见佛涅槃　　我等没苦海
  愁忧怀悲恼　　犹如犊失母
  贫穷无救护　　犹如困病人
  无医随自心　　食所不应食
  众生烦恼病　　常为诸见害
  远离法医师　　服食邪毒药
  是故佛世尊　　不应见舍离
  如国无君主　　人民皆饥饿
  我等亦如是　　失荫及法味
  今闻佛涅槃　　我等心迷乱
  如彼大地动　　迷失于诸方
  大仙入涅槃　　佛日坠于地
  法水悉枯涸　　我等定当死
  如来般涅槃　　众生极苦恼
  譬如长者子　　新丧于父母
  如来入涅槃　　如其不还者
  我等及众生　　悉无有救护
  如来入涅槃　　乃至诸畜生
  一切皆愁怖　　苦恼焦其心
  我等于今日　　云何不愁恼
  如来见放舍　　犹如弃涕唾
  譬如日初出　　光明甚晖炎
  既能还自照　　亦灭一切闇
  如来神通光　　能除我苦恼
  虚在大众中　　譬如须弥山

世尊。譬如国王生育诸子形貌端正心常爱念。先教伎艺悉令通利。然后将付魁脍令杀。世尊。我等今日为法王子。蒙佛教诲以具正见愿莫放舍。如其放舍则同王子。唯愿久住不入涅槃。世尊。譬如有人善学诸论。复于此论而生怖畏。如来亦尔通达诸法。而于诸法复生怖畏。若使如来久住于世。说甘露味充足一切。如是众生则不复畏堕于地狱。世尊。譬如有人初学作务。为官所收闭之囹圄。有人问之汝受何事。答曰。我今受大忧苦。若其得脱则得安乐。世尊亦尔。为我等故修诸苦行。我等今者犹未得免生死苦恼。云何如来得受安乐。世尊。譬如医王善解方药。偏以秘方教授其子。不教其余外受学者。如来亦尔。独以甚深秘密之藏偏教文殊。遗弃我等不见顾愍。如来于法应无悭吝。如彼医王偏教其子。不教外来诸受学者。彼医所以不能普教。情存胜负故有秘惜。如来之心终无胜负。何故如是不见教诲。唯愿久住莫般涅槃。世尊。譬如老少病苦之人。离于善径行于险路。路险涩难多受苦恼。更有异人见之怜愍。即便示以平坦好道。世尊。我亦如是。所谓少者喻未增长法身之人。老者喻重烦恼。病者喻未脱生死。险路者喻二十五有。唯愿如来。示导我等甘露正道。久住于世勿入涅槃

尔时世尊告诸比丘。汝等比丘。莫如凡夫诸天人等愁忧啼哭。当勤精进系心正念。时诸天人阿修罗等。闻佛所说止不啼哭。犹如有人殡丧子已止不啼哭。尔时世尊为诸大众。说是偈言

  汝等当开意　　不应大愁苦
  诸佛法皆尔　　是故当默然
  乐不放逸行　　守心正忆念
  远离诸非法　　慰意受欢乐

复次比丘。若有疑念今皆当问。若空不空。若常无常。若苦不苦。若依非依。若去不去。若归非归。若恒非恒。若断若常。若众生非众生。若有若无。若实不实。若真不真。若灭不灭。若密不密。若二不二。如是等种种法中有所疑者。今应咨问。我当随顺为汝断之。亦当为汝先说甘露。然后乃当入于涅槃。诸比丘。佛出世难人身难得。值佛生信是事亦难。能忍难忍是亦复难。成就禁戒具足无缺得阿罗汉果是事亦难。如求金沙优昙钵花。汝诸比丘。离于八难得人身难。汝等遇我不应空过。我于往昔种种苦行。今得如是无上方便。为汝等故无量劫中舍身手足头目髓脑。是故汝等不应放逸。汝等比丘。云何庄严正法宝城。具足种种功德珍宝戒定智慧以为墙堑埤堄。汝今遇是佛法宝城。不应取此虚伪之物。譬如商主遇真宝城。及诸瓦砾而便还家。汝亦如是。值遇宝城取虚伪物。汝诸比丘。勿以下心而生知足。汝等今者。虽得出家。于此大乘不生贪慕。汝诸比丘。身虽得服袈裟染衣。其心犹未得染大乘清净之法汝诸比丘虽行乞食经历多处。初未曾乞大乘法食。汝诸比丘。虽除须发未为正法除诸结使。汝诸比丘今当真实教敕汝等。我今现在大众和合。如来法性真实不倒。是故汝等应当精进摄心勇猛摧诸结使。十力慧日既灭没已。汝等当为无明所覆。诸比丘。譬如大地诸山药草为众生用。我法亦尔。出生妙善甘露法味。而为众生种种烦恼病之良药。我今当令一切众生及以我子四部之众。悉皆安住秘密藏中。我亦复当安住是中入于涅槃。何等名为秘密之藏。犹如伊字三点。若并则不成伊。纵亦不成。如摩醯首罗面上三目。乃得成伊三点。若别亦不得成。我亦如是。解脱之法亦非涅槃。如来之身亦非涅槃。摩诃般若亦非涅槃。三法各异亦非涅槃。我今安住如是三法。为众生故名入涅槃。如世伊字

尔时诸比丘。闻佛世尊定当涅槃。皆悉忧愁身毛为竖涕泪盈目。稽首佛足绕无量匝白佛言。世尊。快说无常苦空无我。世尊。譬如一切众生迹中象迹为上。是无常想亦复如是。于诸想中最为第一。若有精勤修习之者。能除一切欲界欲爱色无色爱无明憍慢及无常想。世尊。如来若离无常想者。今则不应入于涅槃。若不离者。云何说言修无常想离三界爱无明憍慢及无常想。世尊。譬如农夫秋月之时深耕其地能除秽草。是无常想亦复如是。能除一切欲界欲爱色无色爱无明憍慢及无常想。世尊。譬如耕田秋耕为胜。如诸迹中象迹为胜。于诸想中。无常想为胜。世尊。譬如帝王知命将终。恩赦天下狱囚系闭。悉令得脱然后舍命。如来今者亦应如是。度诸众生一切无知无明系闭。皆令解脱。然后乃入于般涅槃。我等今者皆未得度。云何如来便欲放舍入于涅槃。世尊。譬如有人为鬼所持。遇良咒师以咒力故便得除差。如来亦尔。为诸声闻除无明鬼。令得安住摩诃般若解脱等法如世伊字。世尊。譬如香象为人所缚。虽有良师不能禁制。[去*頁]绝羁锁自恣而去。我未如是脱五十七烦恼系缚。云何如来便欲放舍入于涅槃。世尊。如人病疟值遇良医所苦得除。我亦如是。多诸患苦邪命热病。虽遇如来病未除愈。未得无上安隐常乐。云何如来便欲放舍入于涅槃。世尊。譬如醉人不自觉知。不识亲疏母女姊妹。迷荒淫乱言语放逸。卧粪秽中。时有良师与药令服。服已吐酒还自忆识。心怀惭愧深自克责。酒为不善诸恶根本。若能除断则远众罪世尊。我亦如是。往昔已来轮转生死。情色所醉贪嗜五欲。非母母想非姊姊想。非女女想。于非众生生众生想。是故轮转受生死苦。如彼醉人卧粪秽中。如来今当施我法药。令我还吐烦恼恶酒。而我未得醒寤之心。云何如来便欲放舍入于涅槃。世尊。譬如有人叹芭蕉树以为坚实。无有是处。世尊。众生亦尔。若叹我人众生寿命养育知见作者受者是真实者。亦无是处。我等如是修无我想。世尊。譬如浆滓无所复用。是身亦尔无我无主。世尊。如七叶花无有香气。是身亦尔无我无主。我等如是心常修习无我之想。如佛所说一切诸法无我我所。汝诸比丘应当修习。如是修已则除我慢。离我慢已便入涅槃。世尊。譬如鸟迹。空中现者。无有是处。有能修习无我想者而有诸见。亦无是处

尔时世尊赞诸比丘。善哉善哉。汝等善能修无我想。时诸比丘即白佛言。世尊。我等不但修无我想。亦更修习其余诸想。所谓苦想无常想无我想。世尊。譬如人醉其心愐眩。见诸山河石壁草木宫殿屋舍日月星辰皆悉回转。世尊。若有不修苦无常想无我等想。如是之人不名为圣。多诸放逸流转生死。世尊。以是因缘我等善修如是诸想

尔时佛告诸比丘。谛听谛听。汝向所引醉人喻者。但知文字未达其义。何等为义。如彼醉人见上日月实非回转生回转想。众生亦尔。为诸烦恼无明所覆生颠倒心。我计无我常计无常。净计不净乐计为苦。以为烦恼之所覆故。虽生此想不达其义。如彼醉人于非转处而生转想。我者即是佛义。常者是法身义。乐者是涅槃义。净者是法义。汝等比丘。云何而言。有我想者憍慢贡高流转生死。汝等若言。我亦修习无常苦无我等想。是三种修无有实义。我今当说胜三修法。苦者计乐。乐者计苦。是颠倒法。无常计常。常计无常。是颠倒法。无我计我。我计无我。是颠倒法。不净计净。净计不净。是颠倒法。有如是等四颠倒法。是人不知正修诸法。汝诸比丘。于苦法中生于乐想。于无常中生于常想。于无我中生于我想。于不净中生于净想。世间亦有常乐我净。出世亦有常乐我净。世间法者有字无义。出世间者有字有义。何以故。世间之法有四颠倒故不知义。所以者何。有想颠倒心倒见倒。以三倒故世间之人。乐中见苦。常见无常。我见无我。净见不净。是名颠倒。以颠倒故世间知字而不知义。何等为义。无我者名为生死。我者名为如来。无常者声闻缘觉。常者如来法身。苦者一切外道。乐者即是涅槃。不净者即有为法。净者诸佛菩萨所有正法。是名不颠倒。以不倒故知字知义。若欲远离四颠倒者。应知如是常乐我净

时诸比丘白佛言。世尊。如佛所说离四倒者。则得了知常乐我净。如来今者永无四倒。则已了知常乐我净。若已了知常乐我净。何故不住一劫半劫教导我等令离四倒而见放舍欲入涅槃。如来若见顾念教敕。我当至心顶受修习。如来若入于涅槃者。我等云何与是毒身同共止住修于梵行。我等亦当随佛世尊入于涅槃。尔时佛告诸比丘。汝等不应作如是语。我今所有无上正法悉以付嘱摩诃迦叶。是迦叶者。当为汝等作大依止。犹如如来为诸众生作依止处。摩诃迦叶亦复如是。当为汝等作依止处。譬如大王多所统领。若游巡时悉以国事付嘱大臣。如来亦尔。所有正法亦以付嘱摩诃迦叶。汝等当知。先所修习无常苦想非是真实。譬如春时有诸人等在大池浴乘船游戏失琉璃宝没深水中。是时诸人悉共入水求觅是宝。竞捉瓦石草木沙砾。各各自谓得琉璃珠欢喜持出乃知非真。是时宝珠犹在水中。以珠力故水皆澄清。于是大众乃见宝珠。故在水下。犹如仰观虚空月形。是时众中有一智人。以方便力安徐入水即便得珠。汝等比丘。不应如是修习无常苦无我想不净想等以为实义。如彼诸人各以瓦石草木沙砾而为宝珠。汝等应当善学方便。在在处处常修我想常乐净想。复应当知先所修习四法相貌悉是颠倒。欲得真实修诸想者。如彼智人巧出宝珠。所谓我想常乐净想。尔时诸比丘白佛言。世尊。如佛先说诸法无我汝当修学。修学是已则离我想。离我想者则离憍慢。离憍慢者得入涅槃。是义云何

佛告诸比丘。善哉善哉。汝今善能咨问是义为自断疑。譬如国王闇钝少智。有一医师性复顽嚚。而王不别厚赐俸禄。疗治众病纯以乳药。亦复不知病起根原。虽知乳药复不善解。或有风病冷病热病一切诸病悉教服乳。是王不别是医知乳好丑善恶。复有明医晓八种术。善疗众病知诸方药。从远方来。是时旧医不知咨受。反生贡高轻慢之心。彼时明医即便依附请以为师。咨受医方秘奥之法。语旧医言。我今请仁以为师范。唯愿为我宣畅解说。旧医答言。卿今若能为我给使四十八年。然后乃当教汝医法。时彼明医即受其教。我当如是。我当如是。随我所能当给走使。是时旧医即将客医共入见王。是时客医即为王说种种医方及余伎艺。大王当知。应善分别此法如是可以治国。此法如是可以疗病。尔时国王闻是语已。方知旧医痴騃无智。即便驱逐令出国界。然后倍复恭敬客医。是时客医作是念言。欲教王者今正是时。即语王言。大王。于我实爱念者当求一愿。王即答言。从此右臂及余身分随意所求一切相与。彼客医言。王虽许我一切身分。然我不敢多有所求。今所求者。愿王宣令一切国内。从今已往不得复服旧医乳药。所以者何。是药毒害多伤损故。若故服者当斩其首。断乳药已终更无有横死之人。常处安乐。故求是愿。时王答言。汝之所求盖不足言。寻为宣令一切国内。有病之人皆悉不听以乳为药。若为药者当斩其首。尔时客医以种种味和合众药。谓辛苦碱甜醋等味。以疗众病无不得差。其后不久王复得病。即命是医。我今病重困苦欲死。当云何治。医占王病应用乳药。寻白王言。如王所患应当服乳。我于先时所断乳药。是大妄语。今若服者最能除病。王今患热正应服乳。时王语医汝今狂耶。为热病乎。而言服乳能除此病。汝先言毒。今云何服欲欺我耶。先医所赞。汝言是毒。令我驱遣。今复言好最能除病。如汝所言。我本旧医定为胜汝。是时客医复语王言。王今不应作如是语。如虫食木有成字者。此虫不知是字非字。智人见之终不唱言。是虫解字。亦不惊怪。大王当知。旧医亦尔。不别诸病悉与乳药。如彼虫道偶成于字。是先旧医不解乳药好丑善恶。时王问言。云何不解。客医答王。是乳药者。亦是毒害。亦是甘露。云何是乳复名甘露。若是牸牛不食酒糟滑草麦[麥*弋]其犊调善。放牧之处不在高原亦不下湿。饮以清流不令驰走。不与特牛同共一群。饮餧调适行住得所。如是乳者能除诸病。是则名为甘露妙药。除是乳已其余一切皆名毒害。尔时大王闻是语已。赞言大医。善哉善哉。我从今日始知乳药善恶好丑。即便服之病得除愈。寻时宣令一切国内。从今已往当服乳药。国人闻之皆生嗔恨。咸相谓言。大王。今者为鬼所持为狂颠耶。而诳我等复令服乳。一切人民皆怀嗔恨悉集王所王言。汝等不应于我而生嗔恨。而此乳药服与不服。悉是医教非是我咎。尔时大王及诸人民。踊跃欢喜倍共恭敬供养是医。一切病者皆服乳药病悉除愈。汝等比丘。当知如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。亦复如是。为大医王出现于世。降伏一切外道邪医。诸王众中唱如是言。我为医王欲伏外道。故唱是言。无我无人众生寿命养育知见作者受者。比丘当知。是诸外道。所言我者。如虫食木偶成字耳。是故如来于佛法中唱是无我。为调众生故。为知时故说是无我。有因缘故亦说有我。如彼良医善知于乳是药非药。非如凡夫所计吾我。凡夫愚人所计我者。或言大如拇指。或如芥子。或如微尘。如来说我悉不如是。是故说言。诸法无我实非无我。何者是我。若法是实是真是常是主是依性不变易者。是名为我。如彼大医善解乳药。如来亦尔。为众生故说诸法中真实有我。汝等四众应当如是修习是法

大般涅槃经卷第二大般涅槃经卷第三

        北凉天竺三藏昙无谶译

    寿命品第一之三

佛复告诸比丘。汝于戒律有所疑者今恣汝问。我当解说令汝心喜。我已修学一切诸法本性空寂了了通达。汝等比丘。莫谓如来唯修诸法本性空寂。复告诸比丘。若于戒律有所疑者今可致问。时诸比丘即白佛言。世尊。我等无有智慧能问如来应正遍知。所以者何。如来境界不可思议。所有诸定不可思议。所演教诲不可思议。是故我等无有智慧能问如来。世尊。譬如老人年百二十身婴长病寝卧床席不能起居气力虚劣余命无几。有一富人缘事欲行当至他方。以百斤金寄是老人而作是言。我今他行。以是宝物持用相寄。或十年还。二十年还。汝当还我。是时老人即便受之。而此老人复无继嗣。其后不久病笃命终。所寄之物悉皆散失。财主行还偿索无所。如是痴人不知筹量可寄不可寄。是故行还债索无所。以是因缘丧失财宝。世尊。我等声闻亦复如是。虽闻如来殷勤教诫。不能受持令法久住。如彼老人受他寄付。我今无智于诸戒律当何所问。佛告诸比丘。汝等今者若问于我则能利益。一切众生。是故告汝听随所疑恣意而问。尔时诸比丘白佛言。世尊。譬如有人年二十五盛壮端正。多有财宝金银琉璃。父母妻子眷属宗亲悉皆存在。亦有人来寄其宝物。语其人言。我有缘事欲至他处。事讫当还。汝当还我。是时壮人守护是物如自己有。其人偶病即命家属。如是金宝是他所寄。彼若来索悉皆还之。智者如是。善知筹量行还索物皆悉得之无所亡失。世尊亦尔。若以法宝付嘱阿难及诸比丘不得久住。何以故。一切声闻及大迦叶悉当无常。如彼老人受他寄物。是故应以无上佛法付诸菩萨。以诸菩萨善能问答如是法宝。则得久住无量千世。增益炽盛利安众生。如彼壮人受他寄物。以是义故。诸大菩萨乃能问耳。我等智慧犹如蚊虻。何能咨请如来深法。时诸声闻默然而住。尔时佛赞诸比丘言。善哉善哉。汝等。善得无漏之心阿罗汉心。我亦曾念以此二缘。应以大乘付诸菩萨令是妙法久住于世。尔时佛告一切大众。善男子善女人。我之寿命不可称量。乐说之辩亦不可尽。汝等宜可随意咨问。若戒若归。第二第三亦复如是。尔时众中有一菩萨摩诃萨。本是多罗聚落人也。姓大迦叶。婆罗门种。年在幼稚。以佛神力即从座起。偏袒右臂。绕百千匝。右膝着地合掌向佛。而白佛言。世尊。我于今者欲少咨问。若佛听者乃敢发言。佛告迦叶。如来应正遍知恣汝所问。当为汝说断汝所疑令汝欢喜

尔时迦叶菩萨摩诃萨白佛言。世尊。如来哀愍已垂听许今当问之。然我所有智慧微少犹如蚊虻。如来世尊道德巍巍。纯以栴檀师子难伏不可坏众而为眷属。如来之身犹真。金刚。色如琉璃。真实难坏。复为如是大智慧海之所围绕。是众会中诸大菩萨摩诃萨等。皆悉成就无量无边深妙功德犹如香象。于如是等大众之前岂敢发问。为当承佛神通之力及因大众善根威德少发问耳。即于佛前说偈问曰

  云何得长寿　　金刚不坏身
  复以何因缘　　得大坚固力
  云何于此经　　究竟到彼岸
  愿佛开微密　　广为众生说
  云何得广大　　为众作依止
  实非阿罗汉　　而与罗汉等
  云何知天魔　　为众作留难
  佛说波旬说　　云何分别知
  云何诸调御　　心喜说真谛
  正善具成就　　演说四颠倒
  云何作善业　　大仙今当说
  云何诸菩萨　　能见难见性
  云何解满字　　及与半字义
  云何共圣行　　如娑罗娑鸟
  迦邻提日月　　太白与岁星
  云何未发心　　而名为菩萨
  云何于大众　　而得无所畏
  犹如阎浮金　　无能说其过
  云何处浊世　　不污如莲华
  云何处烦恼　　烦恼不能染
  如医疗众病　　不为病所污
  生死大海中　　云何作船师
  云何舍生死　　如蛇脱故皮
  云何观三宝　　犹如天意树
  三乘若无性　　云何而得说
  犹如乐未生　　云何名受乐
  云何诸菩萨　　而得不坏众
  云何为生盲　　而作眼目导
  云何示多头　　唯愿大仙说
  云何说法者　　增长如月初
  云何复示现　　究竟于涅槃
  云何勇进者　　示人天魔道
  云何知法性　　而受于法乐
  云何诸菩萨　　远离一切病
  云何为众生　　演说于秘密
  云何说毕竟　　及与不毕竟
  如其断疑网　　云何不定说
  云何而得近　　最胜无上道
  我今请如来　　为诸菩萨故
  愿为说甚深　　微妙诸行等
  一切诸法中　　悉有安乐性
  唯愿大仙尊　　为我分别说
  众生大依止　　两足尊妙药
  今欲问诸阴　　而我无智慧
  精进诸菩萨　　亦复不能知
  如是等甚深　　诸佛之境界

尔时佛赞迦叶菩萨。善哉善哉。善男子。汝今未得一切种智。我已得之。然汝所问甚深密藏。如一切智之所咨问等无有异。善男子。我坐道场菩提树下初成正觉。尔时无量阿僧祇恒河沙等诸佛世界有诸菩萨。亦曾问我是甚深义。然其所问句义功德亦皆如是等无有异。如是问者。则能利益无量众生

尔时迦叶菩萨复白佛言。世尊。我无智力能问如来如是深义。世尊。譬如蚊虻不能飞过大海彼岸周遍虚空。我亦如是。不能咨问如来如是智慧大海法性虚空甚深之义。世尊。譬如国王髻中明珠付典藏臣。藏臣得已顶戴恭敬增加守护。我亦如是顶戴恭敬增加守护如来所说方等深义。何以故。令我广得深智慧故。尔时。佛告迦叶菩萨。善男子。谛听谛听。当为汝说如来所得长寿之业。菩萨以是业因缘故得寿命长。是故应当至心听受。若业能为菩提因者。应当诚心听受是义。既听受已转为人说。善男子。我以修习如是业故得阿耨多罗三藐三菩提。今复为人广说是义。善男子。譬如王子犯罪系狱。王甚怜愍爱念子故。躬自回驾至其系所。菩萨亦尔。欲得长寿应当护念一切众生同于子想。生大慈大悲大喜大舍。授不杀戒教修善法。亦当安止一切众生于五戒十善。复入地狱饿鬼畜生阿修罗等一切诸趣。拔济是中苦恼众生。脱未脱者。度未度者。未涅槃者令得涅槃。安慰一切诸恐怖者。以如是等业因缘故。菩萨则得寿命长远。于诸智慧而得自在。随所寿终生于天上

尔时迦叶菩萨复白佛言。世尊。菩萨摩诃萨等视众生同于子想。是义深隐我未能解。世尊。如来不应说言菩萨于诸众生修平等心同于子想。所以者何。于佛法中有破戒者作逆罪者毁正法者。云何当于如是等人同子想耶。佛告迦叶。如是如是。我于众生实作子想如罗睺罗。迦叶菩萨复白佛言。世尊。昔十五日僧布萨时。曾于受具清净众中有一童子。不善修习身口意业。在屏隈处盗听说戒。密迹力士承佛神力。以金刚杵碎之如尘。世尊。是金刚神极成暴恶。乃能断是童子命根。云何如来视诸众生同于子想如罗睺罗。佛告迦叶。汝今不应作如是言。是童子者。即是化人非真实也。为欲驱遣破戒毁法令出众故。金刚密迹亦是化耳。迦叶。毁谤正法及一阐提。或有杀生乃至邪见及故犯禁。我于是等悉生悲心同于子想如罗睺罗。善男子。譬如国王诸群臣等有犯王法随罪诛戮而不舍置。如来世尊不如是也。于毁法者。与驱遣羯磨诃责羯磨置羯磨举罪羯磨不可见羯磨灭羯磨未舍恶见羯磨。善男子。如来所以与谤法者作如是等降伏羯磨。为欲示诸行恶之人有果报故。善男子。汝今当知。如来即是施恶众生无恐畏者。若放一光若二若五。或有遇者悉令远离一切诸恶。如来今者具有如是无量势力。善男子。未可见法汝。欲见者。今当为汝说其相貌。我涅槃已随其方面有持戒比丘。威仪具足护持正法。见坏法者。即能驱遣呵责征治。当知是人得福无量不可称计。善男子。譬如有王专行暴恶会遇重病。有邻国王闻其名声兴兵而来规欲殄灭。是时病王无力势故方乃恐怖改心修善。而是邻王得。无量福。持法比丘亦复如是。驱遣呵责坏法之人。令行善法得福无量。善男子。譬如长者所居之处田宅屋舍生诸毒树。长者知已即便斫伐永令灭尽。又如壮人首生白发愧而剪拔不令生长。持法比丘亦复如是。见有破戒坏正法者。即应驱遣呵责举处。若善比丘见坏法者。置不呵责驱遣举处。当知是人佛法中怨。若能驱遣呵责举处。是我弟子真声闻也。迦叶菩萨复白佛言。世尊。如佛所言。则不等视一切众生同于子想如罗睺罗。世尊。若有一人以刀害佛。复有一人持栴檀涂佛。佛于此二若生等心。云何复言。当治毁禁。若治毁禁是言则失。佛告迦叶菩萨。善男子。譬如国王大臣宰相产育诸子。颜貌端正聪明黠慧。若二三四将付严师而作是言。君可为我教诏诸子。威仪礼节伎艺书疏校计算数悉令成就。我今四子就君受学。假使三子病杖而死。余有一子必当苦治要令成就。虽丧三子我终不恨。迦叶。是父及师得杀罪不。不也世尊。何以故。以爱念故为欲成就无有恶心。如是教诲得福无量。善男子。如来亦尔。视坏法者等如一子。如来今以无上正法。付嘱诸王大臣宰相比丘比丘尼优婆塞优婆夷。是诸国王及四部众。应当劝励诸学人等。令得增上戒定智慧。若有不学是三品法懈怠破戒毁正法者。王者大臣四部之众应当苦治。善男子。是诸国王及四部众当有罪不。不也世尊。善男子。是诸国王及四部众尚无有罪。何况如来。善男子。如来善修如是平等于诸众生同一子想。如是修者。是名菩萨修平等心于诸众生同一子想。善男子。菩萨如是修习此业得寿命长。亦能善知宿世之事

迦叶菩萨复白佛言。世尊。如佛所说菩萨若有修平等心。视诸众生同于子想得寿命长。如来不应作如是说。何以故。如知法人能说种种孝顺之法。还至家中以诸瓦石打掷父母。而是父母是良福田多所利益。难遭难遇。应好供养反生恼害。是知法人言行相违。如来所言亦复如是。菩萨修习等心众生同子想者。应得长寿善知宿命常住于世无有变易。今者世尊。以何因缘寿命极短同人间耶。如来将无于诸众生生怨憎想。世尊。昔日作何恶业断几命根。得是短寿不满百年。佛告迦叶。善男子。汝今何缘于如来前发是粗言。如来长寿。于诸寿中最上最胜。所得常法。于诸常中最为第一

迦叶菩萨复白佛言。世尊。云何如来得寿命长。佛告迦叶。善男子。如八大河。一名恒河。二名阎摩罗。三名萨罗。四名阿梨罗跋提。五名摩诃。六名辛头。七名博叉。八名悉陀。是八大河及诸小河悉入大海。迦叶。如是一切人中天上地及虚空寿命大河。悉入如来寿命海中。是故如来寿命无量。复次迦叶。譬如阿耨达池出四大河。如来亦尔出一切命。迦叶。譬如一切诸常法中虚空第一。如来亦尔。于诸常中最为第一。迦叶。譬如诸药醍醐第一。如来亦尔。于众生中寿命第一

迦叶菩萨复白佛言。世尊。如来寿命若如是者。应住一劫若减一劫。常宣妙法如霔大雨。迦叶。汝今不应于如来所生灭尽想。迦叶。若有比丘比丘尼优婆塞优婆夷。乃至外道五通神仙得自在者。若住一劫若减一劫。经行空中坐卧自在。左胁出火右胁出水。身出烟炎犹如火聚。若欲住寿能得如意。于寿命中修短自任。如是五通尚得如是随意神力。岂况如来于一切法得自在力。而当不能住寿半劫若一劫若百劫若百千劫若无量劫。以是义故。当知如来是常住法不变易法。如来此身是变化身非杂食身。为度众生示同毒树。是故现舍入于涅槃。迦叶。当知佛是常法不变易法。汝等于是第一义中应勤精进一心修习。既修习已广为人说

尔时迦叶菩萨白佛言。世尊。出世之法与世间法有何差别。如佛言曰。佛是常法不变易法。世间亦说梵天是常自在天常无有变易。我常性常微尘亦常。若言如来是常法者。如来何故不常现耶。若不常现有何差别。何以故。梵天乃至微尘世性亦不现故。佛告迦叶。譬如长者多有诸牛色虽种种同共一群。付放牧人令逐水草。但为醍醐不求乳酪。彼牧牛者构已自食。长者命终所有诸牛悉为群贼之所抄掠。贼得牛已无有妇女。即自构捋得已而食。尔时群贼各相谓言。彼大长者畜养此牛不期乳酪但为醍醐。我等今者当设何方而得之耶。夫醍醐者。名为世间第一上味。我等无器。设使得乳无安置处。复共相谓唯有皮囊可以盛之。虽有盛处不知攒摇。浆犹难得况复生酥。尔时诸贼以醍醐故加之以水。以水多故乳酪醍醐一切俱失。凡夫亦尔。虽有善法皆是如来正法之余。何以故。如来世尊入涅槃后。盗窃如来遗余善法若戒定慧。如彼诸贼劫掠群牛。诸凡夫人虽复得是戒定智慧。无有方便不能解说。以是义故不能获得常戒常定常慧解脱。如彼群贼不知方便丧失醍醐。亦如群贼为醍醐故加之以水。凡夫亦尔。为解脱故说我众生寿命士夫。梵天自在天微尘世性。戒定智慧及与解脱。非想非非想天即是涅槃。实亦不得解脱涅槃。如彼群贼不得醍醐。是诸凡夫有少梵行供养父母。以是因缘得生天上受少安乐。如彼群贼加水之乳。而是凡夫实不知因修少梵行供养父母得生天上。又不能知戒定智慧归依三宝。以不知故说常乐我净。虽复说之而实不知。是故如来出世之后。乃为演说常乐我净。如转轮王出现于世。福德力故群贼退散牛无损命。时转轮王即以诸牛付一牧人多巧便者。是人方便即得醍醐。以醍醐故一切众生无有患苦。法轮圣王出现世时。诸凡夫人不能演说戒定慧者。即便退散如贼退散。尔时如来善说世法及出世法。为众生故令诸菩萨随而演说。菩萨摩诃萨既得醍醐。复令无量无边众生获得无上甘露法味。所谓如来常乐我净。以是义故。善男子。如来是常不变易法。非如世间凡夫愚人。谓梵天等是常法也。此常法称要是如来非是余法。迦叶。应当如是知如来身。迦叶。诸善男子善女人。常当系心修此二字佛是常住。迦叶。若有善男子善女人修此二字。当知是人随我所行至我至处。善男子。若有修习如是二字为灭相者。当知如来则于其人为般涅槃。善男子。涅槃义者。即是诸佛之法性也

迦叶菩萨白佛言。世尊。佛法性者。其义云何。世尊。我今欲知法性之义。唯愿如来哀愍广说。夫法性者即是舍身。舍身者名无所有。若无所有身云何存。身若存者云何而言身有法性。身有法性云何得存。我今云何当知是义。佛告迦叶菩萨。善男子。汝今不应作如是说灭是法性。夫法性者无有灭也。善男子。譬如无想天成就色阴而无色想。不应问言。是诸天等云何而住欢娱受乐。云何行想。云何见闻。善男子。如来境界非诸声闻缘觉所知。善男子。不应说言。如来身者是灭法也。善男子。如是灭法是佛境界。非诸声闻缘觉所及。善男子。汝今不应思量如来何处住何处行何处见何处乐。善男子。如是之义。亦非汝等之所知及。诸佛法身种种方便不可思议

复次善男子。应当修习佛法及僧而作常想。是三法者。无有异想。无无常想。无变异想。若于三法修异想者。当知是辈清净三归则无依处。所有禁戒皆不具足。终不能证声闻缘觉菩提之果。若能于是不可思议。修常想者则有归处。善男子。譬如因树则有树影。如来亦尔。有常法故则有归依。非是无常。若言如来是无常者。如来则非诸天世人所归依处。迦叶菩萨白佛言。世尊。譬如闇中有树无影。迦叶。汝不应言有树无影。但非肉眼之所见耳。善男子。如来亦尔。其性常住是不变异。无智慧眼不能得见。如彼闇中不见树影。凡夫之人于佛灭后说言如来是无常法。亦复如是。若言如来异法僧者。则不能成三归依处。如汝父母各各异故。故使无常。迦叶菩萨复白佛言。世尊。我从今始当以佛法众僧三事常住。启悟父母乃至七世皆令奉持。甚奇世尊。我今当学如来法僧不可思议。既自学已亦当为人广说是义。若有诸人不能信受。当知是辈久修无常。如是之人我当为其而作霜雹。尔时佛赞迦叶菩萨善哉善哉。汝今善能护持正法。如是护法不欺于人。以不欺人善业缘故。而得长寿善知宿命

    大般涅槃经金刚身品第二

尔时世尊复告迦叶。善男子。如来身者是常住身。不可坏身。金刚之身。非杂食身。即是法身。迦叶菩萨白佛言。世尊。如佛所说。如是等身我悉不见。唯见无常破坏微尘杂食等身。何以故。如来当入于涅槃故。佛言。迦叶。汝今莫谓如来之身不坚可坏如凡夫身。善男子。汝今当知。如来之身无量亿劫坚牢难坏。非人天身非恐怖身非杂食身。如来之身非身是身。不生不灭。不习不修。无量无边无有足迹。无知无形毕竟清净无有动摇。无受无行不住不作。无味无杂非是有为。非业非果非行非灭非心非数不可思议。常不可思议无识离心亦不离心。其心平等无有亦有。无有去来而亦去来。不破不坏不断不绝。不出不灭非主亦主。非有非无非觉非观。非字非不字。非定非不定。不可见了了见。无处亦处。无宅亦宅。无闇无明。无有寂静。而亦寂静。是无所有不受不施。清净无垢。无诤断诤。住无住处。不取不堕。非法非非法。非福田非不福田。无尽不尽离一切尽。是空离空。虽不常住非念念灭无有垢浊。无字离字。非声非说亦非修习。非称非量。非一非异。非像非相。诸相庄严。非勇非畏。无寂不寂。无热不热。不可睹见无有相貌。如来度脱一切众生。无度脱故能解众生。无有解故觉了众生。无觉了故如实说法。无有二故不可量。无等等。平如虚空无有形貌同无生性。不断不常。常行一乘。众生见三。不退不转断一切结。不战不触非性住性。非合非散。非长非短。非圆非方。非阴入界亦阴入界。非增非损。非胜非负。如来之身成就如是无量功德。无有知者无不知者。无有见者无不见者。非有为非无为。非世非不世。非作非不作。非依非不依。非四大非不四大。非因非不因。非众生非不众生。非沙门非婆罗门。是师子大师子。非身非不身。不可宣说。除一法相不可算数。般涅槃时不般涅槃。如来法身皆悉成就如是无量微妙功德。迦叶。唯有如来乃知是相。非诸声闻缘觉所知。迦叶。如是功德成如来身。非是杂食所长养身。迦叶。如来真身功德如是。云何复得诸疾患苦。危脆不坚如坏器乎。迦叶。如来所以示病苦者。为欲调伏诸众生故。善男子。汝今当知。如来之身即金刚身。汝从今日常当专心思惟此义莫念食身。亦当为人说如来身即是法身

迦叶菩萨白佛言。世尊。如来成就如是功德。其身云何当有病苦无常破坏。我从今日常当思惟。如来之身是常法身安乐之身。亦当为他如是广说。唯然世尊。如来法身金刚不坏。而未能知所因云何。佛言。迦叶。以能护持正法因缘故。得成就是金刚身。迦叶。我于往昔护法因缘。今得成就是金刚身常住不坏。善男子。护持正法者。不受五戒不修威仪。应持刀剑弓箭鉾槊。守护持戒清净比丘。迦叶菩萨白佛言。世尊。若有比丘离于守护。独处空闲冢间树下。当说是人为真比丘。若有随逐守护者行。当知是辈是秃居士。佛告迦叶。莫作是语言秃居士。若有比丘随所至处供身趣足。读诵经典思惟坐禅。有来问法即为宣说。所谓布施持戒福德少欲知足。虽能如是种种说法。然故不能作师子吼。不为师子之所围绕。不能降伏非法恶人。如是比丘不能自利及利众生。当知是辈懈怠懒堕。虽能持戒守护净行。当知是人无所能为。若有比丘供身之具亦常丰足。复能护持所受禁戒。能师子吼广说妙法。谓修多罗祇夜受记伽陀优陀那伊帝曰多伽阇陀伽毗佛略阿浮陀达磨。以如是等九部经典为他广说。利益安乐诸众生故。唱如是言。涅槃经中制诸比丘。不应畜养奴婢牛羊非法之物。若有比丘。畜如是等不净之物。应当治之。如来先于异部经中说。有比丘畜如是等非法之物。某甲国王如法治之驱令还俗。若有比丘。能作如是师子吼时。有破戒者闻是语已。咸共嗔恚害是法师。是说法者。设复命终故名持戒自利利他。以是缘故我听国主群臣宰相诸优婆塞护说法人。若有欲得护正法者。当如是学。迦叶。如是破戒不护法者名秃居士。非持戒者得如是名。善男子。过去之世无量无边阿僧祇劫。于此拘尸那城有佛出世。号欢喜增益如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时世界广博严净丰乐安隐。人民炽盛无有饥渴。如安乐国诸菩萨等。彼佛世尊住世无量。化众生已然后乃于娑罗双树入般涅槃。佛涅槃后正法住世无量亿岁。余四十年佛法未灭。尔时有一持戒比丘。名曰觉德。多有徒众眷属围绕能师子吼。颁宣广说九部经典。制诸比丘不得畜养奴婢牛羊非法之物。尔时多有破戒比丘。闻作是说。皆生恶心执持刀杖逼是法师。是时国王。名曰有德。闻是事已为护法故。即便往至说法者所。与是破戒诸恶比丘极共战斗。令说法者得免危害。王于尔时身被刀剑箭槊之疮。体无完处如芥子许。尔时觉德寻赞王言。善哉善哉。王今真是护正法者。当来之世。此身当为无量法器。王于是时得闻法已心大欢喜。寻即命终生阿閦佛国。而为彼佛作第一弟子。其王将从人民眷属。有战斗者。有随喜者。一切不退菩提之心。命终悉生阿閦佛国。觉德比丘。却后寿终亦得往生阿閦佛国。而为彼佛作声闻众中第二弟子。若有正法欲灭尽时。应当如是受持拥护。迦叶。尔时王者则我身是。说法比丘迦叶佛是。迦叶。护正法者。得如是等无量果报。以是因缘我于今日得种种相以自庄严。成就法身不可坏身

迦叶菩萨复白佛言。世尊。如来常身犹如画石。佛告迦叶菩萨。善男子。以是因缘故。比丘比丘尼优婆塞优婆夷。应当勤加护持正法。护法果报广大无量。善男子。是故护法优婆塞等。应执刀杖拥护如是持法比丘。若有受持五戒之者。不得名为大乘人也。不受五戒为护正法乃名大乘。护正法者。应当执持刀剑器仗侍说法者。迦叶白佛言。世尊。若诸比丘与如是等诸优婆塞持刀杖者。共为伴侣为有师耶为无师乎。为是持戒为是破戒。佛告迦叶。莫谓是等为破戒人。善男子。我涅槃后浊恶之世国土荒乱。互相抄掠人民饥饿。尔时多有为饥饿故发心出家。如是之人名为秃人。是秃人辈见有持戒威仪具足清净比丘护持正法。驱逐令出若杀若害。迦叶菩萨复白佛言。世尊。是持戒人。护正法者。云何当得游行村落城邑教化。善男子。是故我今听持戒人。依诸白衣持刀杖者以为伴侣。若诸国王大臣长者优婆塞等。为护法故虽持刀杖。我说是等名为持戒。虽持刀杖不应断命。若能如是即得名为第一持戒

迦叶。言护法者。谓具正见能广宣说大乘经典。终不捉持王者宝盖油瓶谷米种种果蓏。不为利养亲近国王大臣长者。于诸檀越心无谄曲具足威仪摧伏破戒诸恶人等。是名持戒护法之师。能为众生真善知识。其心弘广譬如大海。迦叶。若有比丘以利养故为他说法。是人所有徒众眷属。亦效是师贪求利养。是人如是便自坏众。迦叶众有三种一者犯戒杂僧。二者愚痴僧。三者清净僧。破戒杂僧则易可坏。持戒净僧利养因缘所不能坏。云何破戒杂僧。若有比丘虽持禁戒。为利养故与破戒者坐起行来。共相亲附同其事业。是名破戒亦名杂僧。云何愚痴僧。若有比丘在阿兰若处。诸根不利闇钝[夢-夕+登]瞢少欲乞食。于说戒日及自恣时。教诸弟子清净忏悔。见非弟子多犯禁戒。不能教令清净忏悔。而便与共说戒自恣。是名愚痴僧。云何名清净僧。有比丘僧。不为百千亿数诸魔之所沮坏。是菩萨众本性清净。能调如上二部之众。悉令安住清净众中。是名护法无上大师善持律者。为欲调伏利众生故。知诸戒相若轻若重。非是律者则不证知。若是律者则便证知。云何调伏众生故。若诸菩萨为化众生常入聚落不择时节。或至寡妇淫女舍宅。与同住止经历多年。若是声闻所不应为。是名调伏利益众生。云何知重。若见如来因事制戒。汝从今日慎莫更犯。如四重禁。出家之人所不应作。而便故作。非是沙门。非释种子。是名为重。云何为轻。若犯轻事如是三谏。若能舍者。是名为轻。非律不证者。若有赞说不清净物应受用者。不共同止。是律应证者。善学戒律不近破戒。见有所行随顺戒律心生欢喜。如是能知佛法所作善能解说。是名律师。善解一字。善持契经。亦复如是。如是善男子。佛法无量不可思议。如来亦尔不可思议。迦叶菩萨白佛言。世尊。如是如是。诚如圣教。佛法无量不可思议。如来亦尔不可思议。故知如来常住不坏无有变异。我今善学。亦当为人广宣是义。尔时佛赞迦叶菩萨。善哉善哉。如来身者。即是金刚不可坏身。菩萨应当如是善学正见正知。若能如是了了知见。即是见佛金刚之身不可坏身。如于镜中见诸色像

    大般涅槃经名字功德品第三

尔时如来复告迦叶。善男子。汝今应当善持是经文字章句所有功德。若有善男子善女人。闻是经名生四趣者。无有是处。何以故。如是经典乃是无量无边诸佛之所修习。所得功德我今当说。迦叶菩萨白佛言。世尊。当何名此经。菩萨摩诃萨云何奉持。佛告迦叶。是经名为大般涅槃。上语亦善。中语亦善。下语亦善。义味深邃其文亦善。纯备具足清净梵行。金刚宝藏满足无缺。汝今善听。我今当说。善男子。所言大者。名之为常。如八大河悉归大海。此经如是。降伏一切诸结烦恼及诸魔性。然后要于大般涅槃放舍身命。是故名曰大般涅槃。善男子。又如医师有一秘方。悉摄一切所有医方。善男子。如来亦尔。所说种种妙法秘密深奥藏门。悉皆入于大般涅槃。是故名为大般涅槃。善男子。譬如农夫春月下种常有悕望。既收果实众望都息。善男子。一切众生亦复如是。修学余经常悕滋味。若得闻是大般涅槃。悕望诸经所有滋味悉皆永断。是大涅槃能令众生度诸有流。善男子。如诸迹中象迹为最。此经如是。于诸经三昧最为第一。善男子。譬如耕田秋耕为胜。此经如是诸经中胜。善男子。如诸药中醍醐第一善治众生热恼乱心。是大涅槃为最第一。善男子。譬如甜酥八味具足。大般涅槃亦复如是八味具足。云何为八。一者常。二者恒。三者安。四者清凉。五者不老。六者不死。七者无垢。八者快乐。是为八味具足。具是八味。是故名为大般涅槃若诸菩萨摩诃萨等安住是中。复能处处示现涅槃。是故名为大般涅槃。迦叶。善男子善女人。若欲于此大般涅槃而涅槃者。当如是学如来常住。法僧亦然。迦叶菩萨复白佛言。甚奇世尊。如来功德不可思议。法僧亦尔不可思议。是大涅槃亦不可思议。若有修学是经典者。得正法门能为良医。若未学者。当知是人盲无慧眼无明所覆

大般涅槃经卷第三大般涅槃经卷第四

        北凉天竺三藏昙无谶译

    如来性品第四之一

佛复告迦叶。善男子。菩萨摩诃萨分别开示大般涅槃。有四相义。何等为四。一者自正。二者正他。三者能随问答。四者善解因缘义。云何自正。若佛如来见诸因缘而有所说。譬如比丘见大火聚便作是言。我宁抱是炽燃火聚。终不敢于如来所说十二部经及秘密藏。谤言云是波旬所说。若言如来法僧无常。如是说者为自侵欺。亦欺于人。宁以利刀自断其舌。终不说言。如来法僧是无常也。若闻他说亦不信受。于此说者应生怜愍。如来法僧不可思议。应如是持。自观己身犹如火聚。是名自正

云何正他。佛说法时。有一女人乳养婴儿。来诣佛所稽首佛足。有所顾念。心自思惟。便坐一面。尔时世尊知而故问。汝以爱念多唅儿酥。不知筹量消与不消。尔时女人即白佛言。甚奇世尊。善能知我心中所念。唯愿如来教我多少。世尊。我于今朝多与儿苏。恐不能消将无夭寿。唯愿如来为我解说。佛言。汝儿所食寻即消化增益寿命。女人闻已心大踊跃。复作是言。如来实说故我欢喜。世尊。如是为欲调伏诸众生故。善能分别说消不消。亦说诸法无我无常。若佛世尊先说常者。受化之徒当言此法与外道同即便舍去。复告女人。若儿长大能自行来。凡所食啖能消难消。本所与苏则不供足。我之所有声闻弟子亦复如是。如汝婴儿。不能消是常住之法。是故我先说苦无常。

若我声闻诸弟子等。功德已备堪任修习大乘经典。我于是经为说六味。云何六味。说苦醋味无常碱味无我苦味乐如甜味我如辛味常如淡味。彼世间中有三种味。所谓无常无我无乐。烦恼为薪智慧为火。以是因缘成涅槃饭。谓常乐我。令诸弟子悉皆甘嗜。复告女人。汝若有缘欲至他处。应驱恶子令出其舍。悉以宝藏付示善子。女人白佛。实如圣教。珍宝之藏应示善子。不示恶子。姊。我亦如是。般涅槃时。如来微密无上法藏。不与声闻诸弟子等。如汝宝藏不示恶子。要当付嘱诸菩萨等。如汝宝藏委付善子。何以故。声闻弟子生变异想谓佛如来真实灭度。然我真实不灭度也。如汝远行未还之顷汝之恶子便言汝死。汝实不死。诸菩萨等说言如来常不变易。如汝善子不言汝死。以是义故。我以无上秘密之藏付诸菩萨。善男子。若有众生谓佛常住不变异者。当知是家则为有佛。是名正他

能随问答者。若有人来问佛世尊。我当云何不舍钱财。而得名为大施檀越。佛言。若有沙门婆罗门等。少欲知足不受不畜不净物者。当施其人奴婢仆使。修梵行者施与女人断酒肉者施以酒肉

不过中食施过中食。不着花香施以花香。如是施者施名流布。遍至他方。财宝之费不失毫厘。是则名为能随问答。尔时迦叶菩萨白佛言。世尊。食肉之人不应施肉。何以故。我见不食肉者有大功德。佛赞迦叶。善哉善哉。汝今乃能善知我意。护法菩萨应当如是。善男子。从今日始不听声闻弟子食肉。若受檀越信施之时。应观是食如子肉想。迦叶菩萨复白佛言。世尊。云何如来不听食肉。善男子。夫食肉者断大慈种。迦叶又言。如来何故。先听比丘食三种净肉。迦叶。是三种净肉随事渐制。迦叶菩萨复白佛言。世尊。何因缘故。十种不净乃至九种清净而复不听。佛告迦叶。亦是因事渐次而制当知即是现断肉义。迦叶菩萨复白佛言。云何如来。称赞鱼肉为美食耶。善男子。我亦不说鱼肉之属为美食也。我说甘蔗粳米石蜜一切谷麦及黑石蜜乳酪苏油。以为美食。虽说应畜种种衣服。所应畜者要是坏色。何况贪着是鱼肉味。迦叶复言。如来若制不食肉者。彼五种味乳酪酪浆生酥熟酥胡麻油等。及诸衣服憍奢耶衣珂贝皮革金银盂器。如是等物亦不应受。善男子。不应同彼尼干所见。如来所制一切禁戒各有异意。异意故听食三种净肉。异想故断十种肉。异想故一切悉断。及自死者。迦叶。我从今日制诸弟子。不得复食一切肉也。迦叶。其食肉者。若行若住若坐若卧。一切众生闻其肉气悉生恐怖。譬如有人近师子已。众人见之闻师子臭亦生恐怖

善男子。如人啖蒜臭秽可恶。余人见之闻臭舍去。设远见者犹不欲视。况当近之。诸食肉者亦复如是。一切众生闻其肉气。悉皆恐怖生畏死想。水陆空行有命之类悉舍之走。咸言此人是我等怨。是故菩萨不习食肉。为度众生示现食肉。虽现食之其实不食。善男子。如是菩萨清净之食。犹尚不食。况当食肉。善男子。我涅槃后。无量百岁。四道圣人悉复涅槃正法灭后。于像法中当有比丘。似像持律少读诵经。贪嗜饮食长养其身。身所被服粗陋丑恶。形容憔悴无有威德。放畜牛羊担负薪草。头须发爪悉皆长利。虽服袈裟犹如猎师。细视徐行如猫伺鼠。常唱是言。我得罗汉。多诸病苦眠卧粪秽。外现贤善内怀贪嫉。如受哑法婆罗门等。实非沙门现沙门像。邪见炽盛诽谤正法。如是等人破坏如来所制戒律正行威仪。说解脱果离不净法。及坏甚深秘密之教。各自随意反说经律。而作是言。如来皆听我等食肉。自生此论。言是佛说互共诤讼。各自称是沙门释子。善男子。尔时复有诸沙门等。贮聚生谷受取鱼肉。手自作食。执持油瓶宝盖革屣。亲近国王大臣长者。占相星宿勤修医道畜养奴婢。金银琉璃车磲马瑙颇梨真珠珊瑚虎珀璧玉珂贝。种种果蓏学诸伎艺。画师泥作造书教学。种植根栽蛊道咒幻。和合诸药作倡伎乐。香花治身樗蒱围棋学诸工巧。若有比丘能离如是诸恶事者。当说是人真我弟子。尔时迦叶复白佛言。世尊。诸比丘比丘尼优婆塞优婆夷。因他而活。若乞食时得杂肉食。云何得食应清净法。佛言。迦叶。当以水洗令与肉别然后乃食。若其食器为肉所污。但使无味听用无罪。若见食中多有肉者则不应受。一切现肉悉不应食食者得罪。我今唱是断肉之制。若广说者即不可尽。涅槃时到。是故略说。是则名为能随问答

迦叶。云何善解因缘义。如有四部之众来问我言。世尊。如是之义如来初出。何故不为波斯匿王说是法门深妙之义。或时说深。或时说浅。或名为犯。或名不犯。云何名堕。云何名律。云何名波罗提木叉义。佛言。波罗提木叉者。名为知足。成就威仪无所受畜。亦名净命。堕者名四恶趣。又复堕者。堕于地狱乃至阿鼻。论其迟速过于暴雨。闻者惊怖。坚持禁戒不犯威仪。修习知足。不受一切不净之物。又复堕者。长养地狱畜生饿鬼。以是诸义故名曰堕。波罗提木叉者。离身口意不善邪业。律者入戒威仪深经善义。遮受一切不净之物及不净因缘。亦遮四重十三僧残二不定法三十舍堕九十一堕四悔过法众多学法七灭诤等。或复有人尽破一切戒。云何一切。谓四重法乃至七灭诤法。或复有人诽谤正法甚深经典。及一阐提具足成就尽一切相无有因缘。如是等人自言我是聪明利智。轻重之罪悉皆覆藏。覆藏诸恶如龟藏六。如是众罪长夜不悔。以不悔故日夜增长。是诸比丘所犯众罪终不发露。是使所犯遂复滋蔓。是故如来知是事已。渐次而制不得一时。尔时有善男子善女人。白佛言。世尊。如来久知如是之事。何不先制将无。世尊。欲令众生入阿鼻狱。譬如多人欲至他方迷失正路随逐邪道。是诸人等不知迷故皆谓是道。复不见人可问是非。众生如是迷于佛法不见正真。如来应为先说正道。敕诸比丘。此是犯戒此是持戒。当如是制。何以故。如来正觉是真实者知见正道。惟有如来天中之天。能说十善增上功德及其义味。是故启请应先制戒。佛言。善男子。若言如来能为众生宣说十善增上功德。是则如来视诸众生如罗睺罗。云何难言将无。世尊。欲令众生入于地狱。我见一人有堕阿鼻地狱因缘。尚为是人住世一劫若减一劫。我于众生有大慈悲。何缘当诳如子想者令入地狱。善男子。如王国内有纳衣者。见衣有孔然后方补。如来亦尔。见诸众生有入阿鼻地狱因缘。即以戒善而为补之。善男子。譬如转轮圣王先为众生说十善法。其后渐渐有行恶者。王即随事渐渐而断。断诸恶已然后自行圣王之法。善男子。我亦如是虽有所说不得先制。要因比丘渐行非法。然后方乃随事制之。乐法众生随教修行。如是等众乃能得见如来法身。如转轮王所有轮宝不可思议。如来亦尔不可思议。法僧二宝亦不可思议。能说法者及闻法者皆不可思议。是名善解因缘义也。菩萨如是分别开示四种相义。是名大乘大涅槃中因缘义也

复次自正者。所谓得是大般涅槃。正他者。我为比丘说言。如来常存不变。随问答者。迦叶。因汝所问故。得广为菩萨摩诃萨比丘比丘尼优婆塞优婆夷。说是甚深微妙义理。因缘义者。声闻缘觉不解如是甚深之义。不闻伊字三点而成解脱涅槃摩诃般若成秘密藏。我今于此阐扬分别为诸声闻开发慧眼。假使有人作如是言。如是四事云何为一非虚妄耶。即应反质是虚空无所有不动无碍。如是四事有何等异。是岂得名为虚妄乎。不也世尊。如是诸句即是一义。所谓空义。自正。正他。能随问答。解因缘义。亦复如是。即大涅槃等无有异

佛告迦叶。若有善男子善女人作如是言。如来无常。云何当知是无常耶。如佛所言。灭诸烦恼名为涅槃。犹如火灭悉无所有。灭诸烦恼亦复如是故名涅槃。云何如来为常住法不变易耶。如佛言曰。离诸有者乃名涅槃。是涅槃中无有诸有。云何如来为常住法不变易耶。如衣坏尽不名为物。涅槃亦尔。灭诸烦恼不名为物。云何如来为常住法不变易耶。如佛言曰。离欲寂灭名曰涅槃。如人斩首则无有首。离欲寂灭亦复如是。空无所有故名涅槃。云何如来为常住法不变易耶。如佛言曰

  譬如热铁　　捶打星流　　散已寻灭
  莫知所在　　得正解脱　　亦复如是
  已度淫欲　　诸有淤泥　　得无动处
  不知所至

云何如来为常住法不变易耶。迦叶。若有人作如是难者名为邪难。迦叶。汝亦不应作是忆想。谓如来性是灭尽也。迦叶。灭烦恼者不名为物。何以故。永毕竟故是故名常。是句寂静为无有上。灭尽诸相无有遗余。是句鲜白常住不退。是故涅槃名曰常住。如来亦尔常住无变。言星流者。谓烦恼也。散已寻灭莫知所在者。谓诸如来烦恼灭已不在五趣。是故如来是常住法无有变易。复次迦叶。诸佛所师所谓法也。是故如来恭敬供养。以法常故诸佛亦常。迦叶菩萨复白佛言。若烦恼火灭如来亦灭。是则如来无常住处。如彼迸铁赤色灭已莫知所至。如来烦恼亦复如是灭无所至。又如彼铁热与赤色灭已无有。如来亦尔。灭已无常灭烦恼火便入涅槃。当知如来即是无常。善男子。所言铁者名诸凡夫。凡夫之人虽灭烦恼灭已复生故名无常。如来不尔灭已不生是故名常。迦叶复言。如铁赤色灭已还置火中赤色复生。如来若尔应还生结。若结还生即是无常。佛言。迦叶。汝今不应作如是言如来无常。何以故。如来是常。善男子。如彼燃木灭已有灰。烦恼灭已便有涅槃。坏衣斩首破瓶等喻亦复如是。如是等物各有名字。名曰坏衣斩首破瓶。迦叶。如铁冷已可使还热。如来不尔断烦恼已毕竟清凉。烦恼炽火更不复生。迦叶。当知无量众生犹如彼铁。我以无漏智慧炽火。烧彼众生诸烦恼结。迦叶复言。善哉善哉。我今谛知如来所说诸佛是常。佛言。迦叶。譬如圣王素在后宫。或时游观在于后园。王虽不在诸婇女中。亦不得言圣王命终。善男子。如来亦尔。虽不现于阎浮提界入涅槃中不名无常。如来出于无量烦恼入于涅槃安乐之处。游诸觉华欢娱受乐

迦叶复问。如佛言曰。我已久度烦恼大海。若佛已度烦恼海者。何缘复共耶输陀罗生罗睺罗。以是因缘当知如来未度烦恼诸结大海。唯愿如来说其因缘。佛告迦叶。汝不应言如来久度烦恼大海。何缘复共耶输陀罗生罗睺罗。以是因缘当知如来未度烦恼诸结大海。善男子。是大涅槃能建大义。汝等今当至心谛听。广为人说莫生惊疑。若有菩萨摩诃萨住大涅槃须弥山王。如是高广悉能令入葶苈子糩。其诸众生依须弥者亦不迫迮。无来往想如本不异。唯应度者见是菩萨以须弥山内葶苈糩复还安止本所住处。善男子。复有菩萨摩诃萨住大涅槃。能以三千大千世界置葶苈糩。其中众生亦无迫迮。及往来想如本不异。唯应度者见是菩萨以此三千大千世界置葶苈糩。复还安止本所住处。善男子。复有菩萨摩诃萨住大涅槃。能以三千大千世界内一毛孔。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取十方三千大千诸佛世界。置于针锋如贯枣叶。掷着他方异佛世界。其中所有一切众生不觉往返为在何处。唯应度者乃能见之。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取十方三千大千诸佛世界。置于右掌如陶家轮。掷置他方微尘世界。无一众生有往来想。唯应度者乃见之耳。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。断取一切十方无量诸佛世界悉内己身。其中众生悉无迫迮。亦无往返及住处想。唯应度者乃能见之。乃至本处亦复如是。善男子。复有菩萨摩诃萨住大涅槃。以十方世界内一尘中。其中众生亦无迫迮往返之想。唯应度者乃能见之。乃至本处亦复如是。善男子。是菩萨摩诃萨住大涅槃。则能示现种种无量神通变化。是故名曰大般涅槃。是菩萨摩诃萨所可示现如是无量神通变化。一切众生无能测量。汝今云何能知如来习近淫欲生罗睺罗

善男子。我已久住是大涅槃种种示现神通变化。于此三千大千世界百亿日月百亿阎浮提种种示现。如首楞严经中广说。我于三千大千世界或阎浮提示现涅槃。亦不毕竟取于涅槃。或阎浮提示入母胎令其父母生我子想。而我此身毕竟不从淫欲和合而得生也。我已久从无量劫来离于淫欲。我今此身即是法身随顺世间示现入胎。善男子。此阎浮提林微尼园。示现从母摩耶而生。生已即能东行七步唱如是言。我于人天阿修罗中最尊最上。父母人天见已惊喜生希有心。而诸人等谓是婴儿。而我此身无量劫来久离是法。如来身者即是法身。非是肉血筋脉骨髓之所成立。随顺世间众生法故示为婴儿。南行七步示现欲为无量众生作上福田。西行七步示现生尽永断老死是最后身。北行七步示现已度诸有生死。东行七步示为众生而作导首。四维七步示现断灭种种烦恼四魔种性。成于如来应正遍知。上行七步示现不为不净之物之所染污犹如虚空。下行七步示现法雨灭地狱火。令彼众生受安隐乐。毁禁戒者示作霜雹。于阎浮提生七日已又示剃发。诸人皆谓我是婴儿初始剃发。一切人天魔王波旬沙门婆罗门。无有能见我顶相者。况有持刀临之剃发。若有持刀至我顶者无有是处。我久已于无量劫中剃除须发。为欲随顺世间法故示现剃发。我既生已父母将我入天祠中。以我示于摩醯首罗。摩醯首罗即见我时合掌恭敬立在一面。我已久于无量劫中舍离如是入天祠法。为欲随顺世间法故示现如是。我于阎浮提示现穿耳。一切众生实无有能穿我耳者。随顺世间众生法故示现如是。复以诸宝作师子珰用庄严耳。然我已于无量劫中离庄严具为欲随顺世间法故作是示现。示入学堂修学书疏。然我已于无量劫中具足成就。遍观三界所有众生无有堪任为我师者。为欲随顺世间法故示入学堂故名如来应正遍知。习学乘象盘马捔力种种伎艺亦复如是。于阎浮提而复示现为王太子。众生皆见我为太子于五欲中欢娱受乐。然我已于无量劫中舍离如是五欲之乐。为欲随顺世间法故示如是相。相师占我若不出家当为转轮圣王王阎浮提。一切众生皆信是言。然我已于无量劫中舍转轮王位为法轮王。于阎浮提现离婇女五欲之乐。见老病死及沙门已出家修道。众生皆谓悉达太子初始出家。然我已于无量劫中出家学道。随顺世法故示如是。我于阎浮提示现出家受具足戒精勤修道。得须陀洹果斯陀含果阿那含果阿罗汉果。众人皆谓是阿罗汉果易得不难。然我已于无量劫中成阿罗汉果。为欲度脱诸众生故坐于道场菩提树下以草为座摧伏众魔。众皆谓我始于道场菩提树下降伏魔官。然我已于无量劫中久降伏已。为欲降伏刚强众生故现是化。我又示现大小便利出息入息。众皆谓我有大小便利出息入息。然我是身所得果报悉无如是大小便利出入息等。随顺世间故示如是。我又示现受人信施。然我是身都无饥渴。随顺世法故示如是。我又示同诸众生故现有睡眠。然我已于无量劫中。具足无上深妙智慧远离三有。进止威仪头痛腹痛背痛木枪洗足洗手洗面漱口嚼杨枝等。众皆谓我有如是事。然我此身都无此事。我足清净犹如莲花。口气净洁如优钵罗香。一切众生谓我是人我实非人。我又示现受粪扫衣浣濯缝打。然我久已不须是衣。众人皆谓罗睺罗者是我之子。输头檀王是我之父。摩耶夫人是我之母。处在世间受诸快乐。离如是事出家学道。众人复言。是王太子瞿昙大姓。远离世乐求出世法。然我久离世间淫欲。如是等事悉是示现。一切众生咸谓是人然我实非。善男子。我虽在此阎浮提中数数示现入于涅槃。然我实不毕竟涅槃。而诸众生皆谓如来真实灭尽。而如来性实不永灭。是故当知是常住法不变易法。善男子。大涅槃者即是诸佛如来法界。我又示现阎浮提中出于世间。众生皆谓我始成佛。然我已于无量劫中所作已办。随顺世法故复示现于阎浮提初出成佛。我又示现于阎浮提不持禁戒犯四重罪。众人皆见谓我实犯。然我已于无量劫中。坚持禁戒无有漏缺。我又示现于阎浮提为一阐提。众人皆见是一阐提。然我实非一阐提也。一阐提者云何能成阿耨多罗三藐三菩提。我又示现于阎浮提破和合僧。众生皆谓我是破僧。我观人天无有能破和合僧者。我又示现于阎浮提护持正法。众人皆谓我是护法悉生惊怪。诸佛法尔不应惊怪。我又示现于阎浮提为魔波旬。众人皆谓我是波旬。然我久于无量劫中离于魔事。清净无染犹如莲花。我又示现于阎浮提女身成佛。众人皆言。甚奇女人能成阿耨多罗三藐三菩提。如来毕竟不受女身。为欲调伏无量众生故现女像。怜愍一切诸众生故。而复示现种种色像。我又示现阎浮提中生于四趣。然我久已断诸趣因。以业因故堕于四趣。为度众生故生是中。我又示现阎浮提中作梵天王。令事梵者安住正法。然我实非而诸众生咸皆谓我为真梵天。示现天像遍诸天庙亦复如是。我又示现于阎浮提入淫女舍。然我实无贪淫之想。清净不污犹如莲花。为诸贪淫嗜色众生。于四衢道宣说妙法。然我实无欲秽之心。众人谓我守护女人。我又示现于阎浮提入青衣舍。为教诸婢令住正法。然我实无如是恶业堕在青衣。我又示现阎浮提中而作博士。为教童蒙令住正法。我又示现于阎浮提入诸酒会博弈之处。示受种种胜负斗诤。为欲拔济彼诸众生。而我实无如是恶业。而诸众生皆谓我作如是之业。我又示现久住冢间。作大鹫身度诸飞鸟。而诸众生皆谓我是真实鹫身。然我久已离于是业。为欲度彼诸鸟鹫故示如是身。我又示现阎浮提中作大长者。为欲安立无量众生住于正法。又复示作诸王大臣王子辅相。于是众中各为第一。为修正法故住王位。我又示现阎浮提中疫病劫起多有众生为病所恼。先施医药然后为说微妙正法。令其安住无上菩提。众人皆谓是病劫起。又复示现阎浮提中饥饿劫起。随其所须供给饮食。然后为说微妙正法。令其安住无上菩提。又复示现阎浮提中刀兵劫起。即为说法令离怨害。使得安住无上菩提。又复示现为计常者说无常想。计乐想者为说苦想。计我想者说无我想。计净想者说不净想。若有众生贪着三界。即为说法令离是处。度众生故为说无上微妙法药。为断一切烦恼树故。种植无上法药之树。为欲拔济诸外道故说于正法。虽复示现为众生师。而心初无众生师想。为欲拔济诸下贱故。现入其中而为说法。非是恶业受是身也。如来正觉如是安住于大涅槃。是故名为常住无变。如阎浮提东弗于逮西瞿耶尼北郁单越亦复如是。如四天下三千大千世界亦尔。二十五有如首楞严经中广说。以是故名大般涅槃。若有菩萨摩诃萨安住如是大般涅槃。能示如是神通变化而无所畏。迦叶。以是缘故汝不应言罗睺罗者是佛之子。何以故。我于往昔无量劫中已离欲有。是故如来名曰常住无有变易

迦叶复言。如来云何名曰常住。如佛言曰如灯灭已无有方所。如来亦尔。既灭度已亦无方所。佛言。迦叶。善男子。汝今不应作如是言。灯灭尽已无有方所。如来亦尔既灭度已无有方所。善男子。譬如男女然灯之时。灯炉大小悉满中油。随有油在其明犹存。若油尽已明亦俱尽。其明灭者喻烦恼灭。明虽灭尽灯炉犹存。如来亦尔。烦恼虽灭法身常存。善男子。于意云何。明与灯炉为俱灭不。迦叶答言。不也世尊。虽不俱灭然是无常。若以法身喻灯炉者。灯炉无常。法身亦尔应是无常。善男子。汝今不应作如是难如世间言器。如来世尊无上法器。而器无常非如来也。一切法中涅槃为常。如来体之故名为常。复次善男子。言灯灭者即是罗汉所证涅槃。以灭贪爱诸烦恼故喻之灯灭。阿那含者名曰有贪。以有贪故不得说言同于灯灭。是故我昔覆相说言。喻如灯灭。非大涅槃同于灯灭。阿那含者非数数来。又不还来二十五有。更不受于臭身虫身食身毒身。是则名为阿那含也。若更受身名为那含。不受身者名阿那含。有去来者名曰那含。无去来者名阿那含

大般涅槃经卷第四大般涅槃经卷第五

        北凉天竺三藏昙无谶译

    如来性品第四之二

尔时迦叶菩萨白佛言。世尊。如佛所说诸佛世尊有秘密藏。是义不然。何以故。诸佛世尊唯有密语无有密藏。譬如幻主机关木人。人虽睹见屈伸俯仰。莫知其内而使之然。佛法不尔咸令众生悉得知见。云何当言诸佛世尊有秘密藏。佛赞迦叶。善哉善哉。善男子。如汝所言。如来实无秘密之藏。何以故。如秋满月处空显露。清净无翳人皆睹见。如来之言亦复如是。开发显露清净无翳。愚人不解谓之秘藏。智者了达则不名藏。善男子。譬如有人多积金银至无量亿。其心悭吝不肯惠施拯济贫穷。如是积聚乃名秘藏。如来不尔于无边劫积聚无量妙法珍宝。心无悭吝常以惠施一切众生。云何当言如来秘藏。善男子譬如有人身根不具。或无一目一手一足。以羞耻故不令人见。人不见故名为秘藏。如来不尔所有正法具足无缺令人睹见。云何当言如来秘藏。善男子。譬如贫人多负人财。怖畏债主隐不欲现故名为藏。如来不尔不负一切众生世法。虽负众生出世之法而亦不藏。何以故。恒于众生生一子想。而为演说无上法故。善男子。譬如长者多有财宝。唯有一子心甚爱重情无舍离。所有珍宝悉用示之。如来亦尔。视诸众生同于一子。善男子。如世间人以男女根丑陋鄙恶。以衣覆蔽故名为藏。如来不尔永断此根。以无根故无所覆藏。善男子。如婆罗门所有语论。终不欲令刹利毗舍首陀等闻。何以故。以此论中有过恶故。如来正法则不如是。初中后善。是故不得名为秘藏。善男子。譬如长者唯有一子。心常忆念怜爱无已。将诣师所欲令受学。惧不速成寻便将还。以爱念故昼夜殷勤教其半字。而不教诲毗伽罗论。何以故。以其幼稚力未堪故。善男子。假使长者教半字已。是儿即时能得了知毗伽罗论不。不也世尊。如是长者于是子所有秘藏不。不也世尊。何以故。以子年幼故不为说。不以秘故吝而不说。所以者何。若有嫉妒秘吝之心乃名为藏。如来不尔。云何当言如来秘藏。佛言。善哉善哉。善男子。如汝所言。若有嗔心嫉妒悭吝乃名为藏。如来无有嗔心嫉妒。云何名藏。善男子。彼大长者谓如来也。所言一子者谓一切众生。如来视于一切众生犹如一子。教一子者谓声闻弟子。半字者谓九部经。毗伽罗论者所谓方等大乘经典。以诸声闻无有慧力。是故如来为说半字九部经典。而不为说毗伽罗论方等大乘。善男子。如彼长者子既长大堪任读学。若不为说毗伽罗论可名为藏若诸声闻有堪任力。能受大乘毗伽罗论。如来秘惜不为说者。可言如来有秘密藏。如来不尔。是故如来无有秘藏。如彼长者教半字已。次为演说毗伽罗论。我今亦尔。为诸弟子说于半字九部经已。次为演说毗伽罗论。所谓如来常存不变

复次善男子。譬如夏月兴大云雷降注大雨。令诸农夫下种之者多获果实。不下种者无所克获。无所获者非龙王咎。而此龙王亦无所藏。我今如来亦复如是。降大法雨大涅槃经。若诸众生种善子者得慧芽果。无善子者则无所获。无所获者非如来咎。然佛如来实无所藏。迦叶复言。我今定知如来世尊无所秘藏。如佛所说毗伽罗论。谓佛如来常存不变。是义不然。何以故。佛昔说偈

  诸佛与缘觉　　及以弟子众
  犹舍无常身　　何况诸凡夫

今者乃说常存无变。是义云何。佛言。善男子。我为一切声闻弟子。教半字故而说是偈。善男子。波斯匿王其母命终悲号恋慕不能自胜来至我所。我即问言。大王。何故悲苦懊恼乃至于此。王言。世尊。国大夫人是日命终。假使有能令我母命还如本者。我当舍国象马七珍及以身命悉以赏之。我复语言。大王。且莫愁恼忧悲啼哭。一切众生寿命尽者名之为死。诸佛缘觉声闻弟子尚舍此身况复凡夫。善男子。我为波斯匿王教半字故而说是偈。我今为诸声闻弟子说毗伽罗论。谓如来常存无有变易。若有人言如来无常。云何是人舌不堕落

迦叶复言。如佛所说

  无所聚积　　于食知足　　如鸟飞空
  迹不可寻

是义云何。世尊。于此众中谁得名为无所积聚。谁复得名于食知足。谁行于空迹不可寻。而此去者为至何方。佛言迦叶。夫积聚者名曰财宝。善男子。积聚有二种。一者有为。二者无为。有为积聚者即声闻行。无为积聚者即如来行。善男子。僧亦有二种。有为无为。有为僧者名曰声闻。声闻僧者无有积聚。所谓奴婢非法之物库藏谷米。盐豉胡麻大小诸豆。若有说言如来听畜奴婢仆使如是之物舌则卷缩。我诸所有声闻弟子名无积聚。亦得名为于食知足。若有贪食名不知足。不贪食者是名知足。迹难寻者则近无上菩提之道。我说是人虽去无至。迦叶复言。若有为僧尚无积聚况无为僧。无为僧者即是如来。如来云何当有积聚。夫积聚者名为藏匿。是故如来凡有所说无所吝惜云何名藏。迹不可寻者所谓涅槃。涅槃之中无有日月星辰诸宿寒热风雨生老病死二十五有。离诸忧苦及诸烦恼。如是涅槃如来住处常不变易。以是因缘。如来至是娑罗树间于大涅槃而般涅槃。佛告迦叶。所言大者其性广博。犹如有人寿命无量名大丈夫。是人若能安住正法名人中胜。如我所说八大人觉。为一人有为多人有。若一人具八则为最胜。所言涅槃者无诸疮疣。善男子。譬如有人为毒箭所射多受苦痛。值遇良医为拔毒箭傅以妙药。令其离苦得受安乐。是医即便游于城邑及诸聚落。随有患苦疮疣之处。即往其所为疗众苦。善男子。如来亦尔。成等正觉为大医王。见阎浮提苦恼众生。无量劫中被淫怒痴烦恼毒箭受大苦切。为如是等说大乘经甘露法药。疗治此已复至他方有诸烦恼毒箭之处。示现作佛为其疗治。是故名曰大般涅槃。大般涅槃者名解脱处。随有调伏众生之处。如来于中而作示现。以是真实甚深义故名大涅槃。迦叶菩萨复白佛言。世尊。世间医师悉能疗治一切众生疮疣病不。善男子。世间疮疣凡有二种。一者可治二不可治。凡可治者医则能治。不可治者则不能治。迦叶复言。如佛言者如来则为于阎浮提治众生已。若言治已是诸众生其中云何复有未能得涅槃者。若未悉得云何如来说言治竟欲至他方。善男子。阎浮提内众生有二。一者有信二者无信。有信之人则名可治。何以故。定得涅槃无疮疣故。是故我说治阎浮提诸众生已。无信之人名一阐提。一阐提者名不可治。除一阐提余悉治已。是故涅槃名无疮疣

世尊。何等名涅槃。善男子。夫涅槃者名为解脱。迦叶复言。所言解脱为是色耶为非色乎。佛言。善男子。或有是色或非是色。言非色者即是声闻缘觉解脱。言是色者即是诸佛如来解脱。善男子。是故解脱亦色非色。如来为诸声闻弟子说为非色。世尊。声闻缘觉若非色者云何得住。善男子。如非想非非想天亦色非色。我亦说为非色。若人难言。非想非非想天若非色者。云何得住去来进止。如是之义诸佛境界。非诸声闻缘觉所知。解脱亦尔。亦色非色说为非色。亦想非想说为非想。如是之义诸佛境界。非诸声闻缘觉所知

尔时迦叶菩萨复白佛言。世尊。唯愿哀愍重垂广说大涅槃行解脱之义。佛赞迦叶。善哉善哉。善男子。真解脱者名曰远离一切系缚。若真解脱离诸系缚。则无有生亦无和合。譬如父母和合生子。真解脱者则不如是。是故解脱名曰不生。迦叶。譬如醍醐其性清净。如来亦尔。非因父母和合而生其性清净。所以示现有父母者。为欲化度诸众生故。真解脱者即是如来。如来解脱无二无别。譬如春月下诸种子。得暖气已寻便出生。真解脱者则不如是。又解脱者名曰虚无。虚无即是解脱。解脱即是如来。如来即是虚无非作所作。凡是作者犹如城郭楼观却敌。真解脱者则不如是。是故解脱即是如来。又解脱者即无为法。譬如陶师作已还破。解脱不尔。真解脱者不生不灭。是故解脱即是如来。如来亦尔。不生不灭不老不死不破不坏非有为法。以是义故名曰如来入大涅槃。不老不死有何等义。老者名为迁变。发白面皱。死者身坏命终。如是等法解脱中无。以无是事故名解脱。如来亦无发白面皱有为之法。是故如来无有老也。无有老故则无有死。又解脱者名曰无病。所谓病者四百四病及余外来侵损身者。是处无故故名解脱。无疾病者即真解脱。真解脱者即是如来。如来无病是故法身亦无有病。如是无病即是如来。死者名曰身坏命终。是处无死即是甘露。是甘露者即真解脱。真解脱者即是如来。如来成就如是功德。云何当言如来无常。若言无常无有是处。是金刚身云何无常。是故如来不名命终。如来清净无有垢秽。如来之身非胎所污。如分陀利本性清净。如来解脱亦复如是。如是解脱即是如来。是故如来清净无垢。又解脱者诸漏疮疣永无遗余。如来亦尔。无有一切诸漏疮疣。又解脱者无有斗诤。譬如饥人见他饮食生贪夺想。解脱不尔。又解脱者名曰安静。凡夫人言。夫安静者谓摩醯首罗。如是之言即是虚妄。真安静者毕竟解脱。毕竟解脱即是如来。又解脱者名曰安隐。如多贼处不名安隐。清夷之处乃名安隐。是解脱中无有怖畏故名安隐。是故安隐即真解脱。真解脱者即是如来。如来者即是法也。又解脱者无有等侣。有等侣者如有国王有邻国等。夫解脱者则无如是。无等侣者谓转轮圣王。无有能与作齐等者。解脱亦尔无有等侣。无等侣者即真解脱。真解脱者即是如来转法轮王。是故如来无有等侣。有等侣者无有是处。又解脱者名无忧愁。有忧愁者譬如国王畏难强邻而生忧愁。夫解脱者则无是事。譬如坏怨则无忧虑。解脱亦尔是无忧畏。无忧畏者即是如来。又解脱者名无忧喜。譬如女人只有一子从役远行卒得凶问。闻之愁苦后复闻活便生欢喜。夫解脱中无如是事。无忧喜者即真解脱。真解脱者即是如来。又解脱者无有尘垢。譬如春月日没之后风起尘雾。夫解脱中无如是事。无尘雾者喻真解脱。真解脱者即是如来。譬如圣王髻中明珠无有垢秽。夫解脱性亦复如是无有垢秽。无垢秽者喻真解脱。真解脱者即是如来。如真金性不杂沙石乃名真宝。有人得之生于财想。夫解脱性亦复如是如彼真宝。彼真宝者喻真解脱。真解脱者即是如来。譬如瓦瓶破而声[斯/瓦]。金刚宝瓶则不如是。夫解脱者亦无[斯/瓦]破。金刚宝瓶喻真解脱。真解脱者即是如来。是故如来身不可坏。其声[斯/瓦]者如蜱麻子盛热之时置之日曝出声震爆。夫解脱者无如是事。如彼金刚真宝之瓶无[斯/瓦]破声。假使无量百千之人悉共射之无能坏者。无[斯/瓦]破声喻真解脱。真解脱者即是如来。如贫穷人负他物故。为他所系枷锁策罚受诸苦毒。夫解脱中无如是事无有负债。犹如长者多有财宝无量亿数势力自在不负他物。夫解脱者亦复如是。多有无量法财珍宝势力自在无所负也。无所负者喻真解脱。真解脱者即是如来。又解脱者名无逼切。如春涉热夏日食甜冬日冷触。真解脱中无有如是不适意事。无逼切者喻真解脱。真解脱者即是如来。又无逼切者譬如有人饱食鱼肉而复饮乳。是人则为近死不久。真解脱中无如是事。是人若得甘露良药所患得除。真解脱者亦复如是。甘露良药喻真解脱。真解脱者即是如来。云何逼切不逼切耶。譬如凡夫我慢自高。而作是念一切众中谁能害我。即便携持蛇虎毒虫。当知是人不尽寿命则为横死。真解脱中无如是事。不逼切者如转轮王。所有神珠能伏蜣螂九十六种诸毒虫等。若有闻是神珠香者诸毒消灭。真解脱者亦复如是。皆悉远离二十五有。毒消灭者喻真解脱。真解脱者即是如来。又不逼切者譬如虚空解脱亦尔。彼虚空者。喻真解脱。真解脱者即是如来。又逼切者如近干草然诸灯火。近则炽然。真解脱中无如是事。又不逼切者譬如日月不逼众生。解脱亦尔于诸众生无有逼切。无有逼切喻真解脱。真解脱者即是如来。又解脱者名无动法。犹如怨亲真解脱中无如是事。又不动者如转轮王更无圣王以为亲友。若更有亲则无是处。解脱亦尔更无有亲。若有亲者亦无是处。彼王无亲喻真解脱。真解脱者即是如来。如来者即是法也。又无动者譬如素衣易受染色解脱不尔。又无动者如婆师花欲令有臭及青色者无有是处。解脱亦尔欲令有臭及诸色者亦无是处。是故解脱即是如来。又解脱者名为希有。譬如水中生于莲花非为希有。火中生者是乃希有。有人见之便生欢喜。真解脱者亦复如是。其有见者心生欢喜。彼希有者喻真解脱。真解脱者即是如来。其如来者即是法身。又希有者譬如婴儿。其齿未生渐渐长大然后乃生。解脱不尔无有生与不生。又解脱者名曰虚寂无有不定。不定者如一阐提究竟不移。犯重禁者不成佛道无有是处。何以故。是人若于佛正法中心得净信。尔时即便灭一阐提。若复得作优婆塞者。亦得断灭于一阐提。犯重禁者灭此罪已则得成佛。是故若言毕定不移不成佛道无有是处。真解脱中都无如是灭尽之事。又虚寂者堕于法界。如法界性即真解脱。真解脱者即是如来。又一阐提若尽灭者则不得称一阐提也。何等名为一阐提耶。一阐提者断灭一切诸善根。本心不攀缘一切善法。乃至不生一念之善。真解脱中都无是事。无是事故即真解脱。真解脱者即是如来。又解脱者名不可量。譬如谷聚其量可知。真解脱者则不如是。譬如大海不可度量。解脱亦尔不可度量。不可量者即真解脱。真解脱者即是如来。又解脱者名无量法。如一众生多有业报。解脱亦尔有无量报。无量报者即真解脱。真解脱者即是如来。又解脱者名为广大。譬如大海无与等者。解脱亦尔无能与等。无与等者即真解脱。真解脱者即是如来。又解脱者名曰最上。譬如虚空最高无比。解脱亦尔最高无比。高无比者即真解脱。真解脱者即是如来。又解脱者名无能过。譬如师子所住之处一切百兽无能过者。解脱亦尔无有能过。无能过者即真解脱。真解脱者即是如来。又解脱者名为无上。譬如北方诸方中上。解脱亦尔为无有上。无有上者即真解脱。真解脱者即是如来。又解脱者名无上上。譬如北方之于东方为无上上。解脱亦尔无有上上。无上上者即真解脱。真解脱者即是如来。又解脱者名曰恒法。譬如人天身坏命终是名曰恒非不恒也。解脱亦尔非是不恒。非不恒者即真解脱。真解脱者即是如来。又解脱者名曰坚实。如佉陀罗栴檀沆水其性坚实。解脱亦尔其性坚实。性坚实者即真解脱。真解脱者即是如来。又解脱者名曰不虚。譬如竹苇其体空疏。解脱不尔。当知解脱即是如来。又解脱者名不可污。譬如墙壁未被涂治蚊虻在上止住游戏。若以涂治彩画雕饰虫闻彩香即便不住。如是不住喻真解脱。真解脱者即是如来。又解脱者名曰无边。譬如聚落皆有边表解脱不尔。譬如虚空无有边际解脱亦尔无有边际。如是解脱即是如来。又解脱者名不可见。譬如空中鸟迹难见。如是难见喻真解脱。真解脱者即是如来。又解脱者名曰甚深。何以故。声闻缘觉所不能入。不能入者即真解脱。真解脱者即是如来。又甚深者诸佛菩萨之所恭敬。譬如孝子供养父母功德甚深。功德甚深喻真解脱。真解脱者即是如来。又解脱者名不可见。譬如有人不见自顶解脱亦尔。声闻缘觉所不能见。不能见者即真解脱。真解脱者即是如来。又解脱者名无屋宅。譬如虚空无有屋宅解脱亦尔。言屋宅者喻二十五有。无有屋宅者喻真解脱。真解脱者即是如来。又解脱者名不可取。如阿摩勒果人可取持。解脱不尔不可取持。不可取持即真解脱。真解脱者即是如来。又解脱者名不可执。譬如幻物不可执持。解脱亦尔不可执持。不可执持即真解脱。真解脱者即是如来。又解脱者无有身体。譬如有人体生疮疣及诸痈疽癫狂干枯。真解脱中无如是病。无如是病喻真解脱。真解脱者即是如来。又解脱者名为一味。如乳一味解脱亦尔唯有一味。如是一味即真解脱。真解脱者即是如来。又解脱者名曰清净。如水无泥澄静清净。解脱亦尔澄静清净。澄静清净即真解脱。真解脱者即是如来。又解脱者名曰一味。如空中雨一味清净。一味清净喻真解脱。真解脱者即是如来。又解脱者名曰除却。譬如满月无诸云翳。解脱亦尔无诸云翳。无诸云翳即真解脱。真解脱者即是如来。又解脱者名曰寂静。譬如有人热病除愈身得寂静。解脱亦尔身得寂静。身得寂静即真解脱。真解脱者即是如来。又解脱者即是平等。譬如野田毒蛇鼠狼俱有杀心。解脱不尔无有杀心。无杀心者即真解脱。真解脱者即是如来又平等者譬如父母等心于子。解脱亦尔其心平等。心平等者即真解脱。真解脱者即是如来。又解脱者名无异处。譬如有人唯居上妙清净屋宅更无异处。解脱亦尔无有异处。无异处者即真解脱。真解脱者即是如来。又解脱者名曰知足。譬如饥人值遇甘馔食之无厌。解脱不尔如食乳糜更无所须。更无所须喻真解脱。真解脱者即是如来。又解脱者名曰断绝。如人被缚断缚得脱。解脱亦尔断绝一切疑心结缚。如是断疑即真解脱。真解脱者即是如来。又解脱者名到彼岸。譬如大河有此彼岸。解脱不尔虽无此岸而有彼岸。有彼岸者即真解脱。真解脱者即是如来。又解脱者名曰默然。譬如大海其水沆涨多诸音声。解脱不尔如是解脱即是如来。又解脱者名曰美妙。譬如众药杂呵梨勒其味则苦。解脱不尔味如甘露。味如甘露喻真解脱。真解脱者即是如来。又解脱者除诸烦恼。譬如良医和合诸药善疗众病。解脱亦尔能除烦恼。除烦恼者即真解脱。真解脱者即是如来。又解脱者名曰无迮。譬如小舍不容多人。解脱不尔多所容受。多所容受即真解脱。真解脱者即是如来。又解脱者名灭诸爱不杂淫欲。譬如女人多诸爱欲。解脱不尔如是解脱即是如来。如来如是无有贪欲嗔恚愚痴憍慢等结。又解脱者名曰无爱。爱有二种。一者饿鬼爱。二者法爱。真解脱者离饿鬼爱。怜愍众生故有法爱。如是法爱即真解脱。真解脱者即是如来。又解脱者离我我所。如是解脱即是如来。如来者即是法也。又解脱者即是灭尽离诸有贪。如是解脱即是如来。如来者即是法也。又解脱者即是救护。能救一切诸怖畏者。如是解脱即是如来。如来者即是法也。又解脱者即是归处。若有归依如是解脱不求余依。譬如有人依恃于王不求余依。虽复依王则有动转。依解脱者无有动转。无动转者即真解脱。真解脱者即是如来。如来者即是法也。又解脱者名为屋宅。譬如有人行于旷野则有险难。解脱不尔无有险难。无险难者即真解脱。真解脱者即是如来。又解脱者是无所畏。如师子王于诸百兽不生怖畏。解脱亦尔于诸魔众不生怖畏。无怖畏者即真解脱。真解脱者即是如来。又解脱者无有迮狭。譬如隘路乃至不受二人并行。解脱不尔如是解脱即是如来。又有不迮譬如有人畏虎堕井。解脱不尔如是解脱即是如来。又有不迮如大海中舍坏小船得坚牢船。乘之度海到安隐处心得快乐。解脱亦尔心得快乐。得快乐者即真解脱。真解脱者即是如来。又解脱者拔诸因缘。譬如因乳得酪因酪得酥因酥得醍醐。真解脱中都无是因。无是因者即真解脱。真解脱者即是如来。又解脱者能伏憍慢。譬如大王慢于小王。解脱不尔如是解脱即是如来。如来者即是法也。又解脱者伏诸放逸。谓放逸者多有贪欲。真解脱中无有是名。无是名者即真解脱。真解脱者即是如来。又解脱者能除无明。如上妙酥除诸滓秽乃名醍醐。解脱亦尔除无明滓生于真明。如是真明即真解脱。真解脱者即是如来。又解脱者名为寂静纯一无二。如空野象独一无侣。解脱亦尔独一无二。独一无二即真解脱。真解脱者即是如来。又解脱者名为坚实如竹苇蜱麻茎干空虚而子坚实。除佛如来其余人天皆不坚实。真解脱者远离一切诸有流等。如是解脱即是如来。又解脱者名能觉了增益于我。真解脱者亦复如是。如是解脱即是如来。又解脱者名舍诸有。譬如有人食已而吐。解脱亦尔舍于诸有。舍诸有者即真解脱。真解脱者即是如来。又解脱者名曰决定。如婆师花香七叶中无。解脱亦尔如是解脱即是如来。又解脱者名曰水大。譬如水大于诸大胜能润一切草木谷子。解脱亦尔能润一切有生之类。如是解脱即是如来。又解脱者名曰为入。如有门户则通入路金性之处金则可得。解脱亦尔如彼门户修无我者则得入中。如是解脱即是如来。又解脱者名曰为善。譬如弟子随逐于师善奉教敕得名为善。解脱亦尔如是解脱即是如来。又解脱者名出世法。于一切法最为出过。如众味中酥乳最胜。解脱亦尔如是解脱即是如来。又解脱者名曰不动。譬如门阃风不能动。真解脱者亦复如是。如是解脱即是如来。又解脱者名无涛波。如彼大海其水涛波。解脱不尔如是解脱即是如来。又解脱者譬如宫殿。解脱亦尔当知解脱即是如来。又解脱者名曰所用。如阎浮檀金多有所任。无有能说是金过恶。解脱亦尔无有过恶。无有过恶即真解脱。真解脱者即是如来。又解脱者舍婴儿行。譬如大人舍小儿行。解脱亦尔除舍五阴。除舍五阴即真解脱。真解脱者即是如来。又解脱者名曰究竟。如被系者从系得脱洗浴清净然后还家。解脱亦尔毕竟清净。毕竟清净即真解脱。真解脱者即是如来。又解脱者名无作乐。无作乐者贪欲嗔恚愚痴吐故。喻如有人误饮蛇毒为除毒故即服吐药。既得吐已毒即除愈身得安乐。解脱亦尔吐于烦恼诸结缚毒身得安乐名无作乐。无作乐者即真解脱。真解脱者即是如来。又解脱者名断四种毒蛇烦恼。断烦恼者即真解脱。真解脱者即是如来。又解脱者名离诸有。灭一切苦得一切乐。永断贪欲嗔恚愚痴。拔断一切烦恼根本。拔根本者即真解脱。真解脱者即是如来。又解脱者名断一切有为之法。出生一切无漏善法。断塞诸道所谓若我无我非我非无我。唯断取着不断我见。我见者名为佛性。佛性者即真解脱。真解脱者即是如来。又解脱者名不空空。空空者名无所有。无所有者即是外道尼犍子等所计解脱。而是尼犍实无解脱故名空空。真解脱者则不如是故不空空。不空空者即真解脱。真解脱者即是如来。又解脱者名空不空。如水酒酪酥蜜等瓶。虽无水酒酪酥蜜时。犹故得名为水等瓶。而是瓶等不可说空及以不空。若言空者则不得有色香味触。若言不空而复无有水酒等实解脱亦尔不可说色及以非色。不可说空及以不空。若言空者则不得有常乐我净。若言不空谁受是常乐我净者。以是义故不可说空及以不空。空者谓无二十五有及诸烦恼。一切苦一切相一切有为行。如瓶无酪则名为空。不空者。谓真实善色常乐我净不动不变。犹如彼瓶色香味触故名不空。是故解脱喻如彼瓶。彼瓶遇缘则有破坏。解脱不尔不可破坏。不可破坏即真解脱。真解脱者即是如来。又解脱者名曰离爱。譬如有人爱心悕望释提桓因大梵天王自在天王。解脱不尔若得成于阿耨多罗三藐三菩提已无爱无疑。无爱无疑即真解脱。真解脱者即是如来。若言解脱有爱疑者无有是处。又解脱者断诸有贪。断一切相一切系缚一切烦恼一切生死一切因缘一切果报。如是解脱即是如来。如来即是涅槃。一切众生怖畏生死诸烦恼故故受三归。譬如群鹿怖畏猎师。既得免离若得一跳则喻一归。如是三跳则喻三归。以三跳故得受安乐。众生亦尔怖畏四魔恶猎师故受三归依。三归依故则得安乐。受安乐者即真解脱。真解脱者即是如来。如来者即是涅槃。涅槃者即是无尽。无尽者即是佛性。佛性者即是决定。决定者即是阿耨多罗三藐三菩提。迦叶菩萨白佛言。世尊。若涅槃佛性决定如来是一义者。云何说言有三归依。佛告迦叶。善男子。一切众生怖畏生死故求三归。以三归故则知佛性决定涅槃。善男子。有法名一义异。有法名义俱异。名一义异者。佛常法常比丘僧常。涅槃虚空皆亦是常。是名名一义异。名义俱异者。佛名为觉法名不觉僧名和合。涅槃名解脱虚空名非善亦名无碍。是为名义俱异。善男子。三归依者亦复如是。名义俱异云何为一。是故我告摩诃波阇波提憍昙弥。莫供养我当供养僧。若供养僧则得具足供养三归。摩诃波阇波提即答我言。众僧之中无佛无法。云何说言供养众僧。则得具足供养三归。我复告言。汝随我语则供养佛。为解脱故即供养法。众僧受者则供养僧。善男子。是故三归不得为一。善男子。如来或时说一为三说三为一。如是之义诸佛境界非是声闻缘觉所知。迦叶复言。如佛所说毕竟安乐名涅槃者是义云何。夫涅槃者舍身舍智。若舍身智谁当受乐。佛言。善男子。譬如有人食已心闷出外欲吐。既得吐已而复回还。同伴问之汝今所患竟为差不。而复来还答言。已差身得安乐。如来亦尔毕竟远离二十五有永得涅槃安乐之处。不可动转无有尽灭。断一切受名无受乐。如是无受名为常乐。若言如来有受乐者无有是处。是故毕竟乐者即是涅槃。涅槃者即真解脱。真解脱者即是如来

迦叶复言。不生不灭是解脱耶。如是如是善男子。不生不灭即是解脱。如是解脱即是如来。迦叶复言。若不生不灭是解脱者。虚空之性亦无生灭应是如来。如如来性即是解脱

佛告迦叶。善男子。是事不然。世尊。何故不然。善男子。如迦兰伽鸟及命命鸟。其声清妙宁可同于乌鹊音不。不也世尊。乌鹊之声比命命等百千万倍不可为比。迦叶复言。迦兰伽等其声微妙身亦不同如来云何比之乌鹊无异葶苈比须弥山。佛与虚空亦复如是。迦兰伽声可喻佛声。不可以喻乌鹊之音

尔时佛赞迦叶菩萨言。善哉善哉善男子。汝今善解甚深难解如来有时以因缘故引彼虚空以喻解脱。如是解脱即是如来。真解脱者一切人天无能为匹。而此虚空实非其喻。为化众生故以虚空非喻为喻。当知解脱即是如来。如来之性即是解脱。解脱如来无二无别。善男子。非喻者。如无比之物不可引喻。有因缘故可得引喻。如经中说面貌端正犹月盛满。白象鲜洁犹如雪山。满月不得即同于面。雪山不得即是白象。善男子。不可以喻喻真解脱。为化众生故作喻耳。以诸譬喻知诸法性皆亦如是

迦叶复言。云何如来作二种说。佛言善男子。譬如有人执持刀剑以嗔恚心欲害如来。如来和悦无恚恨色。是人当得坏如来身成逆罪不。不也世尊。何以故。如来身界不可坏故。所以者何。以无身聚唯有法性。法性之性理不可坏。是人云何能坏佛身。直以恶心故成无间。以是因缘引诸譬喻得知实法。尔时佛赞迦叶菩萨。善哉善哉善男子。我所欲说汝今已说。又善男子。譬如恶人欲害其母。住于野田在谷[卄/積]下。母为送食其人见已寻生害心便前磨刀。母时知已逃入[卄/積]中。其人持刀绕[卄/積]遍斫。斫已欢喜生已杀想。其母寻后从谷[卄/積]出还至家中。于意云何。是人成就无间罪不。不也世尊。不可定说。何以故。若说有罪母身应坏。身若不坏云何言有。若说无罪生已杀想心怀欢喜。云何言无。是人虽不具足逆罪而亦是逆。以是因缘引诸譬喻得知实法。佛赞迦叶。善哉善哉善男子。以是因缘我说种种方便譬喻以喻解脱。虽以无量阿僧祇喻。而实不可以喻为比。或有因缘亦可喻说。或有因缘不可喻说。是故解脱成就如是无量功德趣涅槃者。涅槃如来亦有如是无量功德。以如是等无量功德成就满故名大涅槃。迦叶菩萨白佛言。世尊。我今始知如来至处为无有尽处。若无尽当知寿命亦应无尽。佛言。善哉善哉善男子。汝今善能护持正法。若有善男子善女人欲断烦恼诸结缚者。当作如是护持正法

大般涅槃经卷第五大般涅槃经卷第六

        北凉天竺三藏昙无谶译

    如来性品第四之三

善男子。是大涅槃微妙经中有四种人。能护正法建立正法忆念正法能多利益。怜愍世间为世间依安乐人天。何等为四。有人出世具烦恼性是名第一。须陀洹人。斯陀含人是名第二。阿那含人是名第三。阿罗汉人是名第四。是四种人出现于世。能多利益怜愍世间为世间依安乐人天

云何名为具烦恼性。若有人能奉持禁戒威仪具足建立正法。从佛所闻解其文义转为他人分别宣说。所谓少欲是道。多欲非道。广说如是八大人觉。有犯罪者教令发露忏悔灭除。善知菩萨方便所行秘密之法。是名凡夫非第八人。第八人者不名凡夫。名为菩萨不名为佛

第二人者名须陀洹斯陀含。若得正法受持正法从佛闻法。如其所闻闻已书写受持读诵转为他说。若闻法已不写不受不持不说。而言奴婢不净之物佛听畜者无有是处。是名第二人。如是之人未得第二第三住处名为菩萨已得受记

第三人者名阿那含。阿那含者诽谤正法。若言听畜奴婢仆使不净之物。受持外道典籍书论及为客尘烦恼所障。诸旧烦恼之所覆盖。若藏如来真实舍利及。为外病之所恼害。或为四大毒蛇所侵。论说我者悉无是处。若说无我斯有是处。说着世法无有是处。若说大乘相续不绝斯有是处。若所受身有八万虫亦无是处。永离淫欲乃至梦中不失不净斯有是处。临终之日生怖畏者亦无是处。阿那含者为何谓也。是人不还如上所说。所有过患永不能污。往返周旋名为菩萨已得受记。不久得成阿耨多罗三藐三菩提。是则名为第三人也

第四人者名阿罗汉。阿罗汉者断诸烦恼舍于重担。逮得己利所作已办住第十地得自在智。随人所乐种种色像悉能示现。如所庄严欲成佛道即能得成。能成如是无量功德名阿罗汉。是名四人出现于世能多利益怜愍世间为世间依安乐人天。于人天中最尊最胜犹如如来。名人中胜为归依处

迦叶白佛言。世尊。我今不依是四种人。何以故。如瞿师罗经中佛为瞿师罗说。若天魔梵为欲破坏变为佛像。具足庄严三十二相八十种好圆光一寻。面部圆满犹月盛明眉间毫相白踰珂雪。如是庄严来向汝者。汝当捡校定其虚实。既觉知已应当降伏。世尊。魔等尚能变作佛身况当不能作罗汉等四种之身。坐卧空中左胁出水右胁出火身出烟炎犹如火聚。以是因缘我于是中心不生信。或有所说不能禀受亦无敬念而作依止。佛言善男子。于我所说若生疑者尚不应受况如是等。是故应当善分别知是善不善可作不可作。如是作已长夜受乐。善男子。譬如偷狗夜入人舍。其家婢使若觉知者即应驱骂汝疾出去。若不出者当夺汝命。偷狗闻之即去不还。汝等从今亦应如是降伏波旬。应作是言波旬汝今不应作如是像。若故作者当以五系系缚于汝。魔闻是已便当还去。如彼偷狗更不复还

迦叶白佛言。世尊。如佛为瞿师罗长者说。若能如是降伏魔者。亦可得近大般涅槃。如来何必说是四人为依止处。如是四人所可言说未必可信。佛告迦叶。善男子。如我所说亦复如是非为不尔。善男子。我为声闻有肉眼者说言降魔。不为修学大乘人说。声闻之人虽有天眼故名肉眼。学大乘者虽有肉眼乃名佛眼。何以故。是大乘经名为佛乘。而此佛乘最上最胜。善男子。譬如有人勇健威猛有怯弱者常来依附。其勇健人常教怯者。汝当如是持弓执箭修学槊道长钩罥索。又复告言。夫斗战者虽如履刃不应生于怖畏之想。当视人天生轻弱想。应自生心作勇健想。或时有人素无胆勇诈作健相。执持弓刀种种器仗以自庄严。来至阵中唱呼大唤。汝于是人亦复不应生于忧怖。如是辈人若见汝时不怖畏者。当知是人不久散坏如彼偷狗。善男子。如来亦尔告诸声闻。汝等不应畏魔波旬。若魔波旬化作佛身至汝所者。汝当精勤坚固其心降伏于魔。时魔即当愁忧不乐复道而去。善男子。如彼健人不从他习。学大乘者亦复如是。得闻种种深密经典其心欣乐不生惊怖。何以故。如是修学大乘之人。已曾供养恭敬礼拜过去无量万亿佛故。虽有无量亿千魔众欲来侵娆。于是事中终不惊畏。善男子。譬如有人得阿竭陀药不畏一切毒蛇等。畏是药力故亦能消除一切毒等。是大乘经亦复如是。如彼药力不畏一切诸魔毒等。亦能降伏令更不起

复次善男子。譬如有龙性甚妒憋。欲害人时或以眼视或以气嘘。是故一切师子虎豹豺狼狗犬皆生怖畏。是等恶兽或闻声见形或触其身无不丧命。有善咒者以咒力故。能令如是诸恶毒龙金翅鸟等恶象师子虎豹豺狼。皆悉调善任为御乘。如是等兽见彼善咒即便调伏。声闻缘觉亦复如是。见魔波旬皆生恐怖。而魔波旬亦复不生畏惧之心犹行魔业。学大乘者亦复如是。见诸声闻怖畏魔事于此大乘不生信乐。先以方便降伏诸魔悉令调善堪任为乘。因为广说种种妙法。声闻缘觉见调魔已不生怖畏。于此大乘无上正法方生信乐。作如是言我等从今不应于此正法之中而作障碍

复次善男子。声闻缘觉于诸烦恼而生怖畏。学大乘者都无恐惧。修学大乘有如是力。以是因缘先所说者。为欲令彼声闻缘觉调伏诸魔非为大乘。是大涅槃微妙经典不可消伏甚奇甚特。若有闻者闻已信受。能信如来是常住法。如是之人甚为希有如优昙花。我涅槃后若有得闻如是大乘微妙经典生信敬心。当知是等于未来世百千亿劫不堕恶道

尔时佛告迦叶菩萨。善男子。我涅槃后当有百千无量众生。诽谤不信是大涅槃微妙经典。迦叶菩萨复白佛言。世尊。是诸众生于佛灭后久近便当诽谤是经。世尊。复有何等纯善众生。当能拔济是谤法者

佛告迦叶。善男子。我般涅槃后四十年中于阎浮提广行流布。然后乃当隐没于地。善男子。譬如甘蔗稻米石蜜乳酥醍醐随有之处。其土人民皆言是味味中第一。或复有人纯食粟米及以稗子。是人亦言我所食者最为第一。是薄福人受业报故。若是福人耳初不闻粟稗之名。所食唯是粳粮甘蔗石蜜醍醐。是大涅槃微妙经典亦复如是。钝根薄福不乐听闻。如彼薄福憎恶粳粮及石蜜等。二乘之人亦复如是。憎恶无上大涅槃经。或有众生其心甘乐听受是经闻已欢喜不生诽谤。如彼福人食于稻粮

善男子。譬如有王居在山中险难恶处。虽有甘蔗稻粮石蜜以其难得贪惜积聚。不敢啖食惧其有尽唯食粟稗。有异国王闻之怜笑。即以车载稻粮甘蔗而送与之。其王得已即便分张举国共食。民既食已皆生欢喜。咸作是言因彼王故令我得是希有之食。善男子。是四种人亦复如是。为此无上大法之将。是四种中或有一人见于他方无量菩萨虽学如是大乘经典若自书写若令他书。为利养故为称誉故为了法故为依止故。为用博易其余经故。不能广为他人宣说。是故持是微妙经典送至彼方与彼菩萨。令发无上菩提之心安住菩提。而是菩萨得是经已即便广为他人演说令无量众得受如是大乘法味。皆悉是此一菩萨力所未闻经悉令得闻。如彼人民因王力故得希有食。又善男子。是大涅槃微妙经典所流布处。当知其地即是金刚。是中诸人亦如金刚。若有能听如是经者。即不退转于阿耨多罗三藐三菩提。随其所愿悉得成就如我今日所可宣说。汝等比丘应善受持。若有众生不能听闻如是经典。当知是人甚可怜愍。何以故。是人不能受持如是大乘经典甚深义故

迦叶菩萨白佛言。世尊。如来灭后四十年中是大乘典大涅槃经于阎浮提广行流布。过是已后没于地者。却后久近复当还出佛言。善男子。若我正法余八十年前四十年。是经复当于阎浮提雨大法雨

迦叶菩萨复白佛言。世尊。如是经典正法灭时正戒毁时。非法增长时无如法众生时。谁能听受奉持读诵。令其通利供养恭敬书写解说唯愿如来。怜愍众生分别广说令诸菩萨闻已受持。持已即得不退阿耨多罗三藐三菩提心

尔时佛赞迦叶。善哉善哉。善男子。汝今善能问如是义。善男子。若有众生于熙连河沙等诸佛所发菩提心。乃能于是恶世受持如是经典不生诽谤。善男子。若有能于一恒河沙等诸佛世尊发菩提心。然后乃能于恶世中不谤是法爱乐是典。不能为人分别广说。善男子。若有众生于二恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。正解信乐受持读诵亦不能为他人广说。若有众生于三恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷虽为他说未解深义。若有众生于四恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷为他广说十六分中一分之义。虽复演说亦不具足。若有众生于五恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷广为人说十六分中八分之义。若有众生于六恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷为他广说十六分中十二分义。若有众生于七恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷为他广说十六分中十四分义。若有众生于八恒河沙等佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷亦劝他人令得书写。自能听受复劝他人令得听受读诵通利。拥护坚持怜愍世间诸众生故供养是经。亦劝他人令其供养恭敬尊重读诵礼拜亦复如是。具足能解尽其义味。所谓如来常住不变毕竟安乐。广说众生悉有佛性。善知如来所有法藏。供养如是诸佛等已。建立如是无上正法受持拥护。若有始发阿耨多罗三藐三菩提心。当知是人未来之世必能建立如是正法受持拥护。是故汝今不应不知未来世中护法之人。何以故。是发心者于未来世必能护持无上正法。善男子。有恶比丘闻我涅槃不生忧愁。今日如来入般涅槃何期快哉。如来在世遮我等利今入般涅槃谁复当有遮夺我者。若无遮夺我则还得如来利养。如来在世禁戒严峻今入涅槃悉当放舍。所受袈裟本为法式今当废坏如木头幡。如是等人诽谤拒逆是大乘经。善男子。汝今应当如是忆持。若有众生成就具足无量功德。乃能信是大乘经典信已受持。其余众生有乐法者。若能广为解说此经。其人闻已过去无量阿僧祇劫所作恶业皆悉除灭。若有不信是经典者。现身当为无量病苦之所恼害。多为众人所见骂辱。命终之后人所轻贱颜貌丑陋。资生艰难常不供足虽复少得粗涩弊恶。生生常处贫穷下贱诽谤正法邪见之家。若临终时或值荒乱刀兵竞起。帝王暴虐怨家仇隙之所侵逼。虽有善友而不遭遇。资生所须求不能得。虽少得利常患饥渴。唯为凡下之所顾识。国王大臣悉不齿录。设复闻其有所宣说正使是理终不信受。如是之人不至善处。如折翼鸟不能飞行。是人亦尔于未来世不能得至人天善处。若复有人能信如是大乘经典。本所受形虽复粗陋。以经功德即便端正威颜色力日更增多。常为人天之所乐见。恭敬爱恋情无舍离。国王大臣及家亲属闻其所说悉皆敬信。若我声闻弟子之中欲行第一希有事者。当为世间广宣如是大乘经典

善男子。譬如雾露势虽欲住不过日出。日既出已消灭无余。善男子。是诸众生所有恶业亦复如是。住世势力不过得见大涅槃日。是日既出悉能除灭一切恶业

复次善男子。譬如有人出家剃发虽服袈裟。故未得受沙弥十戒。或有长者来请众僧。未受戒者即与大众俱共受请。虽未受戒已堕僧数。善男子。若有众生发心始学是大乘典大涅槃经。书持读诵亦复如是。虽未具足位阶十住则已堕于十住数中。或有众生是佛弟子或非弟子。若因贪怖或因利养听受是经乃至一偈。闻已不谤当知是人则为已近阿耨多罗三藐三菩提。善男子。以是因缘我说四人为世间依。善男子。如是四人若以佛说言非佛说无有是处。是故我说如是四人为世间依。善男子。汝应供养如是四人。世尊。我当云何识知是人而为供养

佛告迦叶。若有建立护持正法。如是之人应从启请当舍身命而供养之。如我于是大乘经说

  有知法者　　若老若少　　故应供养
  恭敬礼拜　　犹如事火　　婆罗门等
  有知法者　　若老若少　　故应供养
  恭敬礼拜　　亦如诸天　　奉事帝释

迦叶菩萨白佛言。世尊。如佛所说供养师长正应如是。今有所疑唯愿广说。若有长宿护持禁戒。从年少边咨受未闻云何是人当礼敬不。若当礼敬是则不名为持戒也。若是年少护持禁戒。从诸宿旧破戒人边咨受未闻复应礼不。若出家人从在家人咨受未闻复当礼不。然出家人不应礼敬在家人也。然佛法中年少幼小应当恭敬耆旧长宿。以是长宿先受具戒成就威仪。是故应当供养恭敬。如佛言曰其破戒者。是佛法中所不容受。犹如良田多有稊稗。又如佛说有知法者。若老若少故应供养如事帝释。如是二句其义云何。将非如来虚妄说耶。如佛言曰持戒比丘亦有所犯。何故如来而作是说。世尊。亦于余经中说听治破戒。如是所说其义未了。佛告迦叶。善男子。我为未来诸菩萨等学大乘者说如是偈。不为声闻弟子说也。善男子。如我先说正法灭已毁正戒时增长破戒。非法盛时一切圣人隐不现时。受畜奴婢不净物时。是四人中当有一人出现于世。剃除须发出家修道。见诸比丘各各受畜奴婢仆使不净之物。净与不净一切不知。是律非律亦复不识。是人为欲调伏如是诸比丘故。与共和光不同其尘。自所行处及佛行处善能别知。虽见诸人犯波罗夷默然不举。何以故。我出于世为欲建立护持正法。是故默然而不举处。善男子。如是之人为护法故虽有所犯不名破戒

善男子。如有国王遇病崩亡。储君稚小未任绍继。有旃陀罗丰饶财宝巨富无量多有眷属。自以强力伺国虚弱篡居王位治化未久。国人居士婆罗门等亡叛逃走远投他国。虽有在者乃至不欲眼见是王。或有长者婆罗门等不离本土。譬如诸树随其生处即是中死。旃陀罗王知其国人逃叛者众寻即还。遣诸旃陀罗守逻诸道。复于七日击鼓唱令诸婆罗门。有能为我作灌顶师者。当以半国而为爵赏。诸婆罗门闻是语已悉无来者各作是言。何处当有婆罗门种作如是事。旃陀罗王复作是言。婆罗门中若无一人为我师者。我要当令诸婆罗门与旃陀罗共住食宿同其事业。若有能来灌我顶者。半国之封此言不虚。咒术所致三十三天上妙甘露不死之药。亦当共分而服食之

尔时有一婆罗门子。年在弱冠修治净行长发为相善知咒术。往至王所白言。大王。王所敕使我悉能为。尔时大王心生欢喜。受此童子作灌顶师。诸婆罗门闻是事已。皆生嗔恚责此童子。汝婆罗门。云何乃作旃陀罗师。尔时其王即分半国与是童子。因共治国经历多时。尔时童子语其王言。我舍家法来作王师。然教大王微密咒术。而今大王犹不见亲。时王答言。我今云何不亲汝耶。童子答言。先王所有不死之药犹未共食。王言善哉善哉大师。我实不知师若须者唯愿持去。是时童子闻王语已。即取归家请诸大臣而共食之。诸臣食已即共白王。快哉大师。有是甘露不死之药。王既知已语其师言。云何大师。独与诸臣服食甘露而不见分。尔时童子更以其余杂毒之药与王令服。王既服已须臾药发。闷乱躄地无所觉知犹如死人。尔时童子立本储君还以为王。作如是言。师子御座法不应令旃陀罗升。我从昔来未曾闻见旃陀罗种而为王也。若旃陀罗治国理民无有是处。汝今应还绍继先王正法治国。尔时童子经理是已。复以解药与旃陀罗令其醒寤。既醒寤已驱令出国。是时童子虽为是事犹故不失婆罗门法。其余居士婆罗门等闻其所作叹未曾有。赞言善哉善哉仁者。善能驱遣旃陀罗王。善男子。我涅槃后护持正法诸菩萨等亦复如是。以方便力与彼破戒假名。受畜一切不净物僧同其事业。尔时菩萨若见有人虽多犯戒能治毁禁诸恶比丘。即往其所恭敬礼拜四事供养。经书什物悉以奉上。如其自无要当方便从诸檀越求觅而与。为是事故应畜八种不净之物。何以故。是人为治诸恶比丘。如彼童子驱旃陀罗。尔时菩萨虽复恭敬礼拜是人受畜八种不净之物。悉无有罪。何以故。以是菩萨为欲摈治诸恶比丘。令清净僧得安隐住。流布方等大乘经典利益一切诸天人故。善男子。以是因缘我于经中说是二偈。令诸菩萨皆共赞叹护法之人。如彼居士婆罗门等称赞童子善哉善哉。护法菩萨正应如是。若有人见护法之人与破戒者同其事业说有罪者。当知其人自受其殃。是护法者实无有罪。善男子。若有比丘犯禁戒已。憍慢心故覆藏不悔。当知是人名真破戒。菩萨摩诃萨为护法故虽有所犯不名破戒。何以故。以无憍慢发露悔故。善男子。是故我于经中覆相说如是偈

  有知法者　　若老若少　　故应供养
  恭敬礼拜　　犹如事火　　婆罗门等
  如第二天　　奉事帝释

以是因缘我亦不为学声闻人。但为菩萨而说是偈

迦叶菩萨白佛言。世尊。如是等菩萨摩诃萨于戒极缓。本所受戒为具在不。佛言善男子。汝今不应作如是说。何以故。本所受戒如本不失。设有所犯即应忏悔悔已清净。善男子。如故堤塘穿穴有孔水则淋漏。何以故。无人治故。若有人治水则不出。菩萨亦尔。虽与破戒共作布萨受戒自恣同其僧事。所有戒律不如堤塘穿穴淋漏。何以故。若无清净持戒之人僧。则损减慢缓懈怠日有增长。若有清净持戒之人。即能具足不失本戒。善男子。于乘缓者乃名为缓。于戒缓者不名为缓。菩萨摩诃萨于此大乘心不懈慢是名本戒。为护正法以大乘水而自澡浴。是故菩萨虽现破戒不名为缓。迦叶菩萨白佛言。众僧之中有四种人。如庵罗果生熟难知。破戒持戒云何可识

佛言善男子。因大涅槃微妙经典则易可知。云何因是大涅槃经可得知耶。譬如田夫种稻谷等芸除稗[禾*秀]。以肉眼观名为净田。至其成实草谷各异。如是八事能污染僧若能除却。以肉眼观则知清净。若有持戒破戒不作恶时。以肉眼观难可分别。若恶彰露则易可知。如彼稗[禾*秀]易可分别。僧中亦尔若能远离于八不净毒蛇之法是名清净。圣众福田应为人天之所供养。清净果报非是肉眼所能分别。复次善男子。如迦罗迦林其树众多。于是林中唯有一树名镇头迦。是迦罗迦树镇头迦树。二果相似不可分别。其果熟时有一女人悉皆拾取。镇头迦果才有一分。迦罗迦果乃有十分。是女不识赍来诣市而炫卖之。凡愚小儿复不别故。买迦罗迦果啖已命终。有智人辈闻是事已即问女人。姊于何处持是果来。是时女人即示方所。诸人即言。如是方所多有无量迦罗迦树。唯有一根镇头迦树。诸人知已笑而舍去。善男子。大众之中八不净法亦复如是。于是众中多有受用如是八法。唯有一人清净持戒。不受如是八不净法。而知诸人受畜非法。然与同事不相舍离。如彼林中一镇头迦树。有优婆塞见是诸人多有非法。并不恭敬供养是人。若欲供养应先问言。大德。如是八事为受畜不。佛所听不。若言佛听。如是之人得共布萨羯磨自恣不。是优婆塞如是问已。众皆答言。如是八事如来怜愍皆悉听畜。优婆塞言。祇洹精舍有诸比丘或言金银佛所听畜。或言不听有言听者。是不听者不与共住说戒自恣。乃至不共一河饮水。利养之物悉不共之。汝等云何言佛听许。佛天中天虽复受之。汝等众僧亦不应畜。若有受者乃至不应与共说戒自恣羯磨同其僧事。若共说戒自恣羯磨同僧事者。命终即当堕于地狱。如彼诸人食迦罗果已而便命终

复次善男子。譬如城市有卖药人。有妙甘药出于雪山。亦复多卖其余杂药昧甘相似。时有诸人咸皆欲买然不识别。至卖药所问言。汝有雪山药不。其卖药人即答言有。是人欺诈以余杂药语买者言。此是雪山甘好妙药。时买药者以肉眼故。不能善别即买持去。复作是念我今已得雪山甘药。迦叶。若声闻僧中有假名僧有真实僧。有和合僧若持戒破戒。于是众中等应供养恭敬礼拜。是优婆塞以肉眼故不能分别。喻如彼人不能分别雪山甘药。谁是持戒谁是破戒谁是真僧谁是假僧。有天眼者乃能分别。迦叶。若优婆塞知是比丘是破戒人不应给施礼拜供养。若知是人受畜八法亦复不应给施所须礼拜供养。若于僧中有破戒者。不应以被袈裟因缘恭敬礼拜

迦叶菩萨复白佛言。世尊。善哉善哉。如来所说真实不虚我当顶受。譬如金刚珍宝异物。如佛所说是诸比丘当依四法。何等为四。依法不依人。依义不依语。依智不依识。依了义经不依不了义经如是四法应当证知非四种人

佛言善男子。依法者。即是如来大般涅槃。一切佛法即是法性。是法性者即是如来。是故如来常住不变。若复有言如来无常。是人不知不见法性。若不知见是法性者不应依止。如上所说四人出世护持法者。应当证知而为依止。何以故。是人善解如来微密深奥藏故。能知如来常住不变。若言如来无常变易无有是处。如是四人即名如来。何以故是人能解如来密语及能说故。若有人能了知如来甚深密藏。及知如来常住不变。如是之人若为利养说言如来是无常者无有是处。如是之人尚可依止。何况不依是四人也。依法者即是法性。不依人者即是声闻。法性者即是如来。声闻者即是有为。如来者。即是常住。有为者即是无常。善男子。若人破戒为利养故。说言如来无常变易。如是之人所不应依。善男子。是名定义

依义不依语者。义者名曰觉了。觉了义者名不羸劣。不羸劣者名曰满足。满足义者。名曰如来常住不变。如来常住不变义者即是法常。法常义者即是僧常。是名依义不依语也。何等语言所不应依。所谓诸论绮饰文辞。如佛所说无量诸经。贪求无厌多奸谀谄。诈现亲附现相求利。经理白衣为其执役。又复唱言。佛听比丘畜诸奴婢不净之物。金银珍宝谷米仓库牛羊象马。贩卖求利于饥馑世怜愍子故。听诸比丘储贮陈宿手自作食不受而啖。如是等语所不应依

依智不依识者。所言智者即是如来。若有声闻不能善知如来功德。如是之识不应依止。若知如来即是法身。如是真智所应依止。若见如来方便之身。言是阴界诸入所摄食所长养亦不应依。是故知识不可依止。若复有人作是说者。及其经书亦不应依。依了义经不依不了义经。不了义经者。谓声闻乘。闻佛如来深密藏处悉生疑怪。不知是藏出大智海。犹如婴儿无所别知。是则名为不了义也

了义者名为菩萨。真实智慧随于自心。无碍大智犹如大人无所不知。是名了义。又声闻乘名不了义。无上大乘乃名了义。若言如来无常变易名不了义。若言如来常住不变是名了义。声闻所说应证知者名不了义。菩萨所说应证知者名为了义。若言如来食所长养是不了义。若言常住不变易者是名了义。若言如来入于涅槃如薪尽火灭名不了义。若言如来入法性者是名了义。声闻乘法则不应依。何以故。如来为欲度众生故。以方便力说声闻乘。犹如长者教子半字。善男子。声闻乘者犹如初耕未得果实。如是名为不了义也。是故不应依声闻乘。大乘之法则应依止。何以故。如来为欲度众生故。以方便力说于大乘是故应依。是名了义。如是四依应当证知

复次依义者。义名质直。质直者名曰光明。光明者名不羸劣。不羸劣者名曰如来。又光明者名为智慧。质直者名为常住

如来常者名为依法。法者名常亦名无边。不可思议不可执持不可系缚而亦可见。若有说言不可见者。如是之人所不应依。是故依法不依于人。若有人以微妙之语宣说无常。如是之言所不应依。是故依义不依于语。依智者。众僧是常无为不变。不畜八种不净之物。是故依智不依于识。若有说言识作识受无和合僧。何以故。夫和合者名无所有。无所有者云何言常。是故此识不可依止依了义者。了义者名为知足。终不诈现威仪清白。憍慢自高贪求利养。亦于如来随宜方便所说法中不生执着。是名了义。若有能住如是等中。当知是人则为已得住第一义。是故名为依了义经

不依不了义。不了义者如经中说。一切烧燃一切无常一切皆苦一切皆空一切无我。是名不了义。何以故。以不能了如是义故。令诸众生堕阿鼻狱。所以者何。以取着故于义不了。一切烧者谓如来说涅槃亦烧。一切无常者涅槃亦无常。苦空无我亦复如是。是故名为不了义经不应依止。善男子。若有人言如来怜愍一切众生善知时宜。以知时故说轻为重说重为轻。如来观知所有弟子有诸檀越供给所须令无所乏。如是之人佛则不听受畜奴婢金银财宝贩卖市易不净物等。若诸弟子无有檀越供给所须。时世饥馑饮食难得。为欲建立护持正法。我听弟子受畜奴婢金银车乘田宅谷米卖易所须。虽听受畜如是等物要当净施笃信檀越。如是四法所应依止。若有戒律阿毗昙修多罗。不违是四亦应依止。若有说言有时非时有能护法。不能护法。如来悉听一切比丘受畜如是不净物者。如是之言不应依止。若有戒律阿毗昙修多罗中有同是说。如是三分亦不应依。我为肉眼诸众生等说是四依。终不为于有慧眼者。是故我今说是四依。法者即是法性。义者即是如来常住不变。智者了知一切众生悉有佛性。了义者了达一切大乘经典

大般涅槃经卷第六大般涅槃经卷第七

        北凉天竺三藏昙无谶译

    如来性品第四之四

尔时迦叶白佛言。世尊。如上所说四种人等应当依耶

佛言。如是如是。善男子。如我所说应当依止。何以故。有四魔故。何等为四。如魔所说诸余经律能受持者。迦叶菩萨白佛言。世尊。如佛所说有四种魔。若魔所说及佛所说。我当云何而得分别。有诸众生随逐魔行。复有随顺佛所教者。如是等辈复云何知。佛告迦叶。我般涅槃七百岁后。是魔波旬渐当沮坏我之正法。譬如猎师身服法衣。魔王波旬亦复如是。作比丘像比丘尼像优婆塞像优婆夷像。亦复化作须陀洹身。乃至化作阿罗汉身及佛色身。魔王以此有漏之形作无漏身坏我正法。是魔波旬坏正法时。当作是言。菩萨昔于兜率天上没来。在此迦毗罗城白净王宫。依因父母爱欲和合生育是身。若言有人生于人中为诸世间天人大众所恭敬者。无有是处。又复说言。往昔苦行种种布施头目髓脑国城妻子。是故今者得成佛道。以是因缘为诸人天乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽之所恭敬。若有经律作是说者。当知悉是魔之所说

善男子。若有经律作如是言。如来正觉久已成佛。今方示现成佛道者。为欲度脱诸众生故。示有父母依因爱欲和合而生。随顺世间作是示现。如是经律当知真是如来所说。若有随顺魔所说者是魔眷属。若能随顺佛说经律即是菩萨

若有说言如来生时于十方面各行七步不可信者是魔所说

若复有说如来出世于十方面各行七步。此是如来方便示现。是名如来所说经律。若有随顺魔所说者是魔眷属。若能随顺佛所说者。即是菩萨。若有说言菩萨生已父王使人将诣天祠。诸天见已悉下礼敬。是故名佛。复有难言天者先出。佛在于后。云何诸天礼敬于佛。作是难者。当知即是波旬所说若有经言佛到天祠。是诸天等摩醯首罗大梵天王释提桓因。皆悉合掌敬礼其足。如是经律是佛所说。若有随顺魔所说者。是魔眷属。若能随顺佛所说者即是菩萨

若有经律说言。菩萨为太子时。以贪心故四方娉妻。处在深宫五欲自娱欢悦受乐。如是经律波旬所说

若有说言菩萨久已舍离贪心妻息之属。乃至不受三十三天上妙五欲如弃涕唾。何况人欲。剃除须发出家修道。如是经律是佛所说。若有随顺魔经律者是魔眷属。若有随顺佛经律者即是菩萨

若有说言佛在舍卫只陀精舍。听诸比丘受畜奴婢仆使牛羊象马驴骡鸡猪猫狗。金银琉璃真珠颇梨车磲马瑙珊瑚虎珀。珂具璧玉铜铁釜鍑大小铜。盘所须之物。耕田种植贩卖市易储积谷米。如是众事。佛大慈故怜愍众生皆听畜之。如是经律悉是魔说若有说言佛在舍卫只陀精舍那梨楼鬼所住之处。尔时如来因婆罗门字羖羝德。及波斯匿王说言。比丘不应受畜金银琉璃颇梨真珠车磲玛瑙珊瑚虎珀珂具璧玉。奴婢仆使童男童女。牛羊象马驴骡鸡猪猫狗等兽。铜铁釜鍑。大小铜槃。种种杂色床敷卧具。资生所须。所谓屋宅耕田种殖贩卖市易。自手作食自磨自舂。治身咒术调鹰方法。仰观星宿推步盈虚。占相男女解梦吉凶。是男是女非男非女。六十四能复有十八。惑人咒术种种工巧。或说世间无量俗事。散香末香涂香薰香。种种花鬘治发方术。奸伪谄曲贪利无厌。爱乐愦闹戏笑谈说。贪嗜鱼肉和合毒药治押香油。捉持宝盖及以革屣。造扇箱箧种种画像。积聚谷米大小麦豆及诸果蓏。亲近国王王子大臣及诸女人。高声大笑或复默然。于诸法中多生疑惑。多语妄说长短好丑或善不善。好着好衣。如是种种不净之物。于施主前躬自赞叹。出入游行不净之处。所谓沽酒淫女博弈。如是之人我今不听在比丘中。应当休道还俗役使。譬如稗[禾*秀]悉灭无余。当知是等经律所制。悉是如来之所说也。若有随顺魔所说者是魔眷属。若有随顺佛所说者即是菩萨

若有说言菩萨为欲供养天神故入天祠。所谓梵天大自在天。违陀天迦旃延天。所以入者。为欲调伏诸天人故。若言不尔。无有是处。若言菩萨不能入于外道邪论。知其威仪文章伎艺。仆使斗诤不能和合。不为男女国王大臣之所恭敬。又亦不知和合诸药。以不知故乃名如来。如其知者是邪见辈。又复如来于怨亲中其心平等。如以刀割及香涂身。于此二人不生增益损减之心。唯能处中故名如来。如是经律当知是魔之所说也

若有说言菩萨如是示入天祠。外学法中出家修道。示现知其威仪礼节。能解一切文章伎艺。示入书堂伎巧之处。能善和合仆使斗诤。于诸大众童男童女后宫妃后人民长者婆罗门等王及大臣贫穷等中最尊最上。复为是等之所恭敬。亦能示现如是等事。虽处诸见不生爱心。犹如莲花不受尘垢。为度一切诸众生故。善行如是种种方便随顺世法。如是经律当知即是如来所说。若有随顺魔所说者是魔眷属。若能随顺佛所说者是大菩萨。若有说言如来为我解说经律。若恶法中轻重之罪及偷兰遮其性皆重。我等律中终不为之。我久忍受如是之法。汝等不信我当云何自舍己律就汝律耶。汝所有律是魔所说。我等经律是佛所制。如来先说九部法印。如是九印印我经律。初不闻有方等经典。一句一字如来所说。无量经律何处有说方等经耶。如是等中未曾闻有十部经名。如其有者。当知必定调达所作。调达恶人以灭善法造方等经我等不信。如是等经是魔所说。何以故。破坏佛法相是非故。如是之言。汝经中有我经中无。我经律中如来说言。我涅槃后恶世当有不正经律。所谓大乘方等经典。未来之世当有如是诸恶比丘。我又说言。过九部经有方等典。若有人能了知其义。当知是人正了经律。远离一切不净之物。微妙清净犹如满月。若有说言如来虽为一一经律说如恒河沙等义味。我律中无将知为无。如其有者。如来何故于我律中而不解说。是故我今不能信受。当知是人则为得罪。是人复言。如是经律我当受持。何以故。当为我作知足少欲断除烦恼智慧涅槃善法因故。如是说者非我弟子

若有说言如来为欲度众生故说方等经。当知是人真我弟子。若有不受方等经者。当知是人非我弟子。不为佛法而出家也。即是邪见外道弟子。如是经律是佛所说。若不如是是魔所说。若有随顺魔所说者是魔眷属。若有随顺佛所说者即是菩萨

复次善男子。若有说言如来不为无量功德之所成就。无常变异以得空法。宣说无我不顺世间。如是经律名魔所说

若有人言如来正觉不可思议。亦为无量阿僧祇等功德所成。是故常住无有变异。如是经律是佛所说。若有随顺魔所说者是魔眷属。若有随顺佛所说者即是菩萨

复有人言。或有比丘实不毁犯波罗夷罪。众人皆谓犯波罗夷。如断多罗树。而是比丘实无所犯。何以故。我常说言。四波罗夷。若犯一者。犹如析石不可还合。若有自说得过人法。是则名为犯波罗夷。何以故。实无所得诈现得相故。如是之人退失人法。是名波罗夷。所谓若有比丘少欲知足。持戒清净住空闲处。若王大臣见是比丘。生心念言谓得罗汉。即前赞叹恭敬礼拜。复作是言。如是大师。舍是身已当得阿耨多罗三藐三菩提。比丘闻已即答王言。我实未得沙门道果。王莫称我已得道果。唯愿大王。勿为我说不知足法。不知足者乃至谓得阿耨多罗三藐三菩提皆默然受。我今若当默然受者。当为诸佛之所呵责。知足之行诸佛所赞。是故我欲终身欢乐奉修知足。又知足者。我定自知未得道果。王称我得。我今不受。故名知足。时王答言。大师实得阿罗汉果如佛无异。尔时其王普皆宣告内外人民中宫妃后。悉令皆知得沙门果。是故咸令一切闻者。心生敬信供养尊重。如是比丘真是梵行清净之人。以是因缘普令诸人得大福德。而是比丘实不毁犯波罗夷罪。何以故。前人自生欢喜之心赞叹供养故。如是比丘当有何罪。若有说言是人得罪。当知是经是魔所说

复有比丘说佛秘藏甚深经典。一切众生皆有佛性。以是性故断无量亿诸烦恼结。即得成于阿耨多罗三藐三菩提。除一阐提。若王大臣作如是言。比丘汝当作佛不作佛耶。有佛性不。比丘答言。我今身中定有佛性。成以不成未能审之。王言。大德。如其不作一阐提者必成无疑。比丘言尔实如王言。是人虽言定有佛性。亦复不犯波罗夷也。复有比丘。即出家时作是思惟。我今必定成阿耨多罗三藐三菩提。如是之人虽未得成无上道果。已为得福无量无边不可称计。假使有人当言是人犯波罗夷。一切比丘无不犯者。何以故。我于往昔八十亿劫。常离一切不净之物。少欲知足威仪成就。善修如来无上法藏。亦自定知身有佛性。是故我今得成阿耨多罗三藐三菩提。得名为佛有大慈悲。如是经律是佛所说。若有不能随顺是者是魔眷属。若能随顺是大菩萨

复有说言无四波罗夷十三僧残二不定法三十舍堕九十一堕四忏悔法众多学法七灭诤等。无偷兰遮五逆等罪及一阐提。若有比丘犯如是等堕地狱者。外道之人悉应生天。何以故。诸外道等无戒可犯。是故如来示现怖人故说斯戒。若言佛说我诸比丘若欲行淫。应舍法服着俗衣裳然后行淫。复应生念淫欲因缘非我过咎。如来在世亦有比丘习行淫欲得正解脱。或命终后生于天上。古今有之非独我作。或犯四重。或犯五戒。或行一切不净律仪。犹故而得真正解脱。如来虽说犯突吉罗如忉利天日月岁数八百万岁堕在地狱。亦是如来示现怖人。言波罗夷至突吉罗轻重无差。是诸律师妄作此言言是佛制。毕定当知非佛所说。如是言说是魔经律。若复说言。于诸戒中若犯小戒。乃至微细当受苦报无有齐限。如是知已防护自身如龟藏六。若有律师复作是言。凡所犯戒都无罪报。如是之人不应亲近。如佛所说

  若过一法　　是名妄语　　不见后世
  无恶不造

是故不应亲近是人。我佛法中清净如是。况复有犯偷兰遮罪或犯僧残及波罗夷而非罪耶。是故应当深自防护如是等法。若不守护更以何法名为禁戒。我于经中亦说。有犯四波罗夷乃至微细突吉罗等。应当苦治众生。若不护持禁戒。云何当得见于佛性。一切众生虽有佛性。要因持戒然后乃见。因见佛性得成阿耨多罗三藐三菩提。九部经中无方等经。是故不说有佛性也。经虽不说当知实有。若作是说。当知是人真我弟子

迦叶菩萨白佛言。世尊。如上所说一切众生有佛性者。九部经中所未曾闻。如其说有。云何不犯波罗夷耶

佛言。善男子。如汝所说。实不毁犯波罗夷也。善男子。譬如有人说言大海唯有七宝无八种者。是人无罪。若有说言九部经中无佛性者。亦复无罪。何以故。我于大乘大智海中说有佛性。二乘之人所不知见。是故说无不得罪也。如是境界诸佛所知。非是声闻缘觉所及。善男子。若人不闻如来甚深秘密藏者。云何当知有佛性耶。何等名为秘密之藏。所谓方等大乘经典。善男子。有诸外道。或说我常。或说我断。如来不尔。亦说有我。亦说无我。是名中道。若有说言佛说中道一切 众 生悉有佛性。烦恼覆故不知不见。是故应当勤修方便断坏烦恼。若有能作如是说者。当知是人不犯四重。若不能作如是说者。是则名为犯波罗夷。若有说言我已成就阿耨多罗三藐三菩提。何以故。以有佛性故。有佛性者必定当成阿耨多罗三藐三菩提。以是因缘我今已得成就菩提。当知是人则名为犯波罗夷罪。何以故。虽有佛性以未修习诸善方便。是故未见。以未见故不能得成阿耨多罗三藐三菩提。善男子。以是义故佛法甚深不可思议。迦叶菩萨白佛言。世尊。有王问言。云何比丘堕过人法

佛告迦叶。若有比丘。为利养故。为饮食故。作诸谀谄奸伪欺诈。云何当令诸世间人定实知我是乞士也。以是因缘令我大得利养名誉。如是比丘多愚痴故。长夜常念我实未得四沙门果。云何当令诸世间人谓我已得。复当云何令诸优婆塞优婆夷等。咸共指我作如是言。是人福德真是圣人。如是思惟。正为求利非为求法。行来出入进止安详。执持衣钵不失威仪。独坐空处如阿罗汉。令世间人咸作是言。如是比丘善好第一。精勤苦行修寂灭法。以是因缘我当大得门徒弟子。诸人亦当大致供养衣服饮食卧具医药。令多女人敬念爱重。若有比丘及比丘尼。作如是事堕过人法。复有比丘为欲建立无上正法住空寂处。非阿罗汉而欲令人谓是罗汉。是好比丘。是善比丘。寂静比丘。令无量人生于信心。以此因缘我得无量诸比丘等以为眷属。因是得教破戒比丘及优婆塞悉令持戒。以是因缘建立正法。光扬如来无上大事。开显方等大乘法化。度脱一切无量众生。善解如来所说经律轻重之义。复言我今亦有佛性。有经名曰如来秘藏。于是经中我当必定得成佛道。能尽无量亿烦恼结。广为无量诸优婆塞。说言汝等尽有佛性。我之与汝俱当安住如来道地。成阿耨多罗三藐三菩提。尽无量亿诸烦恼结。作是说者。是人不名堕过人法。名为菩萨。若言有犯突吉罗者。忉利天上日月岁数八百万岁。堕地狱中受诸罪报。何况故犯偷兰遮罪。此大乘中若有比丘犯偷兰遮不应亲近。何等名为大乘经中偷兰遮罪。若有长者造立佛寺。以诸花鬘用供养佛。有比丘见花贯中缕不问辄取犯偷兰遮。若知不知亦如是犯。若以贪心破坏佛塔犯偷兰遮。如是之人不应亲近。若王大臣见塔朽故。为欲修补供养舍利。于是塔中或得珍宝即寄比丘。比丘得已自在而用。如是比丘名为不净多起斗诤。善优婆塞不应亲近供养恭敬。如是比丘名为无根。名为二根。名不定根。不定根者欲贪女时身即为女。欲贪男时身即为男。如是比丘名为恶根。不名为男。不名为女。不名出家。不名在家。如是比丘不应亲近供养恭敬。于佛法中沙门法者。应生悲心覆育众生。乃至蚁子应施无畏。是沙门法。远离饮酒乃至嗅香。是沙门法。不得妄语乃至梦中不念妄语。是沙门法。不生欲心乃至梦中亦复如是。是沙门法迦叶菩萨白佛言。世尊。若有比丘梦行淫欲是犯戒不

佛言。不也。应于淫欲生臭秽想。乃至不生一念净想。远离女人烦恼爱想。若梦行淫寤应生悔。比丘乞食受供养时。应如饥世食子肉想。若生淫欲应疾舍离。如是法门当知是佛所说经律。若有随顺魔所说者是魔眷属。若能随顺佛所说者是名菩萨。若有说言佛听比丘常翘一脚寂默不言。

投渊赴火。自坠高岩。不避险难。服毒断食。卧灰土上。自缚手足。杀害众生。方道咒术。旃陀罗子无根二根及不定根身根不具。如是等辈如来悉听出家为道。是名魔说。佛先听食五种牛味及以油蜜。憍奢耶衣革屣等物。除是之外。若有说言听着摩诃楞伽。一切种子悉听贮畜。草木之属皆有寿命。佛说是已便入涅槃。若有经律作是说者。当知即是魔之所说。我亦不听常翘一脚。若为法故听行住坐卧。又亦不听服毒断食五热炙身。系缚手足杀害众生方道咒术。珂具象牙以为革屣。储畜种子草木有命。着摩诃楞伽。若言世尊作如是说。当知是为外道眷属。非我弟子。我唯听食五种牛味及油蜜等。听着革屣憍奢耶衣。我说四大无有寿命。若有经律作是说者。是名佛说若有随顺佛所说者。当知是等真我弟子。若有不随佛所说者。是魔眷属。若有随顺佛经律者。当知是人是大菩萨

善男子。魔说佛说差别之相。今已为汝广宣分别。迦叶白佛言。世尊。我今始知魔说佛说差别之相。因是得入佛法深义。佛赞迦叶。善哉善哉。善男子。汝能如是晓了分别。是名黠慧

善男子。所言苦者不名圣谛。何以故。若言苦是苦圣谛者。一切牛羊驴马及地狱众生应有圣谛。善男子。若复有人不知如来甚深境界常住不变微密法身。谓是食身非是法身。不知如来道德威力。是名为苦。何以故。以不知故法见非法非法见法。当知是人必堕恶趣轮转生死。增长诸结多受苦恼。若有能知如来常住无有变易。或闻常住二字音声。若一经耳即生天上。后解脱时乃能证知如来常住无有变易。既证知已而作是言。我于往昔曾闻是义。今得解脱方乃证知。我于本际以不知故轮转生死周遍无穷。始于今日乃得真智。若如是知。真是修苦。多所利益。若不知者。虽复勤修无所利益。是名知苦名苦圣谛。若人不能如是修习。是名为苦非苦圣谛。苦集谛者。于真法中不生真智受不净物。所谓奴婢能以非法言是正法。断灭正法不令久住。以是因缘不知法性。以不知故轮转生死多受苦恼。不得生天及正解脱。若有深知不坏正法。以是因缘得生天上及正解脱。若有不知苦集谛处而言正法无有常住悉是灭法。以是因缘于无量劫流转生死受诸苦恼。若能知法常住不异。是名知集名集圣谛。若人不能如是修习。是名为集非集圣谛。苦灭谛者。若有多修习学空法。是为不善。何以故。灭一切法故。坏于如来真法藏故。作是修学。是名修空。修苦灭者。逆于一切诸外道等。若言修空是灭谛者。一切外道亦修空法应有灭谛。若有说言有如来藏虽不可见若能灭除一切烦恼尔乃得入。若发此心一念因缘。于诸法中而得自在。若有修习如来密藏无我空寂。如是之人于无量世。在生死中流转受苦。若有不作如是修者。虽有烦恼疾能灭除。何以故。因知如来秘密藏故。是名苦灭圣谛。若能如是修习灭者。是我弟子。若有不能作如是修。是名修空非灭圣谛。道圣谛者。所谓佛法僧宝及正解脱。有诸众生颠倒心言无佛法僧及正解脱。生死流转犹如幻化。修习是见。以此因缘轮转三有久受大苦。若能发心见于如来常住无变。法僧解脱亦复如是。乘此一念于无量世自在果报随意而得。何以故。我于往昔以四倒故非法计法受于无量恶业果报。我今已灭如是见故成佛正觉。是名道圣谛。若有人言三宝无常。修习是见是虚妄修非道圣谛。若修是法为常住者。是我弟子。真见修习四圣谛法。是名四圣谛。迦叶菩萨复白佛言。世尊。我今始知修习甚深四圣谛法

佛告迦叶。善男子。谓四倒者。于非苦中生于苦想。名曰颠倒。非苦者名为如来。生苦想者。谓于如来无常变异。若说如来是无常者。名大罪苦。若言如来舍此苦身入于涅槃如薪尽火灭。是名非苦而生苦想。是名颠倒我若说言如来常者即是我见。以我见故有无量罪。是故应说如来无常。如是说者我则受乐。如来无常即为是苦。若是苦者云何生乐。以于苦中生乐想故。名为颠倒。乐生苦想。名为颠倒。乐者即是如来。苦者如来无常。若说如来是无常者。是名乐中生于苦想。如来常住。是名为乐。若我说言如来是常。云何复得入于涅槃。若言如来非是苦者。云何舍身而取灭度。以于乐中生苦想故。名为颠倒。是名初倒。无常常想常无常想。是名颠倒。无常者名不修空。不修空故寿命短促。若有说言不修空寂得长寿者。是名颠倒。是名第二颠倒。无我我想我无我想。是名颠倒。世间之人亦说有我。佛法之中亦说有我。世间之人虽说有我无有佛性。是则名为于无我中而生我想。是名颠倒。佛法有我即是佛性。世间之人说佛法无我。是名我中生无我想。若言佛法必定无我是故如来敕诸弟子修习无我。名为颠倒。是名第三颠倒。净不净想不净净想。是名颠倒。净者即是如来常住。非杂食身非烦恼身非是肉身。非是筋骨系缚之身。若有说言如来无常是杂食身。乃至筋骨系缚之身。法僧解脱是灭尽者。是名颠倒。不净净想名颠倒者。若有说言我此身中无有一法是不净者。以无不净定当得入清净之处。如来所说修不净观。如是之言是虚妄说。是名颠倒。是则名为第四颠倒迦叶菩萨白佛言。世尊。我从今日始得正见。世尊。自是之前我等悉名邪见之人。世尊。二十五有有我不耶

佛言。善男子。我者即是如来藏义。一切众生悉有佛性。即是我义。如是我义从本已来常为无量烦恼所覆。是故众生不能得见。善男子。如贫女人舍内多有真金之藏。家人大小无有知者。时有异人善知方便语贫女人。我今雇汝汝可为我芸除草秽。女即答言。我不能也。汝若能示我子金藏。然后乃当速为汝作。是人复言。我知方便能示汝子。女人答言。我家大小尚自不知。况汝能知。是人复言。我今审能。女人答言。我亦欲见并可示我。是人即于其家掘出真金之藏。女人见已心生欢喜。生奇特想宗仰是人。善男子。众生佛性亦复如是。一切众生不能得见。如彼宝藏贫人不知。善男子。我今普示一切众生所有佛性。为诸烦恼之所覆蔽。如彼贫人有真金藏不能得见。如来今日普示众生诸觉宝藏。所谓佛性。而诸众生见是事已心生欢喜归仰如来。善方便者即是如来。贫女人者即是一切无量众生。真金藏者即佛性也

复次善男子。譬如女人生育一子婴孩得病。是女愁恼求觅医师。医师既来合三种药。酥乳石蜜。与之令服因告女人。儿服药已且莫与乳。须药消已尔乃与之。是时女人即以苦物用涂其乳。母语儿言。我乳毒涂不可复触。小儿渴乏欲得母乳。闻乳毒气便远舍去。遂至药消母人以水净洗其乳。唤其子言。来与汝乳。是时小儿虽复饥渴。先闻毒气是故不来。母复语言。为汝服药故以毒涂。汝药已消我已洗竟。汝便可来饮乳无苦。是儿闻已渐渐还饮。善男子。如来亦尔。为度一切教诸众生修无我法。如是修已永断我心入于涅槃。为除世间诸妄见故。示现出过世间法故。复示世间计我虚妄非真实故。修无我法清净身故。喻如女人为其子故以苦味涂乳。如来亦尔。为修空故说言诸法悉无有我。如彼女人净洗乳已而唤其子欲令还服。我今亦尔说如来藏。是故比丘不应生怖。如彼小儿闻母唤已渐还饮乳。比丘亦尔。应自分别如来秘藏不得不有

迦叶菩萨白佛言。世尊。实无有我。何以故。婴儿生时无所知晓。若有我者即生之日寻应有知。以是义故定知无我。若定有我。受生已后应无终殁。若使一切皆有佛性。是常住者应无坏相。若无坏相云何而有刹利婆罗门毗舍首陀及旃陀罗畜生差别。今见业缘种种不同诸趣各异。若定有我一切众生应无胜负。以是义故定知佛性非是常法。若言佛性定是常者。何缘复说有杀盗淫两舌恶口妄言绮语贪恚邪见。若我性常。何故酒后迷荒醉乱。若我性常。盲应见色。聋应闻声。哑应能语。拘躄能行。若我性常。不应避于火坑大水毒药刀剑恶人禽兽。若我常者本所更事不应忘失。若不忘失何缘复言我曾何处见是人耶。若我常者则不应有少壮老等衰盛力势忆念往事。若我常者止住何处。为在涕唾青黄赤白诸色中耶。若我常者应遍身中如胡麻油间无空处。若断身时我亦应断。佛告迦叶。善男子。譬如王家有大力士。其人眉间有金刚珠。与余力士较力相扑而彼力士以头抵触其额上。珠寻没肤中都不自知是珠所在。其处有疮即命良医欲自疗治。时有明医善知方药。即知是疮因珠入体是珠入皮即便停住。是时良医寻问力士。卿额上珠为何所在。力士惊答大师医王。我额上珠乃无去耶。是珠今者为何所在。将非幻化忧愁啼哭。是时良医慰喻力士。汝今不应生大愁苦。汝因斗时宝珠入体今在皮里影现于外。汝曹斗时嗔恚毒盛珠陷入体故不自知。是时力士不信医言。若在皮里脓血不净何缘不出。若在筋里不应可见。汝今云何欺诳于我。时医执镜以照其面。珠在镜中明了显现。力士见已心怀惊怪生奇特想。善男子。一切众生亦复如是。不能亲近善知识故。虽有佛性皆不能见。而为贪淫嗔恚愚痴之所覆蔽故。堕地狱畜生饿鬼阿修罗旃陀罗刹利婆罗门毗舍首陀。生如是等种种家中。因心所起种种业缘。虽受人身聋盲喑哑拘躄癃跛。于二十五有受诸果报。贪淫嗔恚愚痴覆心不知佛性。如彼力士宝珠在体谓呼失去。众生亦尔不。知亲近善知识故。不识如来微密宝藏。修学无我。喻如非圣。虽说有我亦复不知我之真性我诸弟子亦复如是。不知亲近善知识故。修学无我亦复不知无我之处。尚自不知无我真性。况复能知有我真性。善男子。如来如是说诸众生皆有佛性。喻如良医示彼力士金刚宝珠。是诸众生为诸无量亿烦恼等之所覆蔽不识佛性。若尽烦恼尔时乃得证知了了。如彼力士于明镜中见其宝珠。善男子。如来秘藏如是无量不可思议

复次善男子。譬如雪山有一味药。名曰乐味。其味极甜在深丛下人无能见。有人闻香即知其地当有是药。过去往世有转轮王。于此雪山为此药故。在在处处造作木筒以接是药。是药熟时从地流出集木筒中。其味真正。王既殁已其后是药。或醋或碱或甜或苦或辛或淡。如是一味随其流处有种种异。是药真味停留在山犹如满月。凡人薄福虽以[钁-(目*目)+賏]斸加功困苦而不能得。复有圣王出现于世。以福因缘即得是药真正之味。善男子。如来秘藏其味亦尔。为诸烦恼丛林所覆。无明众生不能得见。一味者喻如佛性。以烦恼故出种种味。所谓地狱畜生饿鬼天人。男女非男非女。刹利婆罗门毗舍首陀。佛性雄猛难可沮坏。是故无有能杀害者。若有杀者则断佛性。如是佛性终不可断性若可断。无有是处。如我性者即是如来秘密之藏。如是秘藏一切无能沮坏烧灭。虽不可坏然不可见。若得成就阿耨多罗三藐三菩提尔乃证知。以是因缘无能杀者

迦叶菩萨复白佛言。世尊。若无杀者应当无有不善之业

佛告迦叶。实有杀生。何以故。善男子。众生佛性住五阴中。若坏五阴名曰杀生。若有杀生即堕恶趣。以业因缘而有刹利婆罗门等毗舍首陀及旃陀罗。若男若女非男非女。二十五有差别之相流转生死。非圣之人横计于我大小诸相。犹如稗子或如米豆乃至母指。如是种种妄生忆想。妄想之想无有真实。出世我相名为佛性。如是计我是名最善

复次善男子。譬如有人善知伏藏。即取利[钁-(目*目)+賏]斸地直下磐石沙砾直过无难。唯至金刚不能穿彻。夫金刚者所有刀斧不能沮坏。善男子。众生佛性亦复如是。一切论者天魔波旬及诸人天所不能坏。五阴之相即是起作。起作之相喻如石沙可穿可坏。佛性者喻如金刚不可沮坏。以是义故坏五阴者名为杀生。善男子。必定当知佛法如是不可思议

大般涅槃经卷第七

卧灰土上。自坠高岩。投渊赴火。五热炙身。卧棘刺上。淘糠饮汁。服毒断食。杀害众生。故弄师子。咒术方道。旃陀罗种。二根无根二根合一。悉听为道。断五种味。乳酪酪浆生酥熟酥油蜜之等。听着缯彩以轲为跋。一切谷米草木之类皆有寿命。佛说是已便入涅槃。如是说者即是魔说。若言如来不听比丘。常翘一脚寂默不言。卧灰土上。自坠高岩。投渊赴火。五热炙身。卧棘刺上。淘糠饮汁。服毒断食。杀害众生。故弄师子。咒术方道。旃陀罗种。二根无根。二根合者。不听为道。听服五种。乳酪酪浆酥油蜜等。不听受着缯彩衣服以轲为跋。谷米草木无命无我。非众生数。若有能作如是说者。是我弟子。若不能者。当知即是外道弟子。如是经律是佛所说。若有随顺魔所说者。是魔眷属。若能随顺佛所说者。是名菩萨大般涅槃经卷第八

        北凉天竺三藏昙无谶译

    如来性品第四之五

善男子。方等经者。犹如甘露亦如毒药。迦叶菩萨复白佛言。如来何缘说方等经。譬如甘露亦如毒药

佛言。善男子。汝今欲知如来秘藏真实义不。迦叶言尔。我今实欲得知如来秘藏之义。尔时世尊而说偈言

  或有服甘露　　伤命而早夭
  或复服甘露　　寿命得长存
  或有服毒生　　有缘服毒死
  无碍智甘露　　所谓大乘典
  如是大乘典　　亦名杂毒药
  如酥醍醐等　　及以诸石蜜
  服消则为药　　不消则为毒
  方等亦如是　　智者为甘露
  愚不知佛性　　服之则成毒
  声闻及缘觉　　大乘为甘露
  犹如诸味中　　乳最为第一
  如是勤精进　　依因于大乘
  得至于涅槃　　成人中象王
  众生知佛性　　犹如迦叶等
  无上甘露味　　不生亦不死
  迦叶汝今当　　善分别三归
  如是三归性　　则是我之性
  若能谛观察　　我性有佛性
  当知如是人　　得入秘密藏
  知我及我所　　是人已出世
  佛法三宝性　　无上第一尊
  如我所说偈　　其性义如是

尔时迦叶复说偈言

  我今都不知　　归依三宝处
  云何当归趣　　无上无所畏
  不知三宝处　　云何作无我
  云何归佛者　　而得于安慰
  云何归依法　　唯愿为我说
  云何得自在　　云何不自在
  云何归依僧　　转得无上利
  云何真实说　　未来成佛道
  未来若不成　　云何归三宝
  我今无预知　　当行次第依
  云何未怀妊　　而作生子想
  若必在胎中　　则名为有子
  子若在胎中　　定当生不久
  是名为子义　　众生业亦然
  如佛之所说　　愚者不能知
  以其不知故　　轮回生死狱
  假名优婆塞　　不知真实义
  唯愿广分别　　除断我疑网
  如来大智慧　　唯垂哀分别
  愿说于如来　　秘密之宝藏
  迦叶汝当知　　我今当为汝
  善开微密义　　令汝疑得断
  今当至心听　　汝于诸菩萨
  则与第七佛　　同其一名号
  归依于佛者　　真名优婆塞
  终不更归依　　其余诸天神
  归依于法者　　则离于杀害
  归依圣僧者　　不求于外道
  如是归三宝　　则得无所畏
  迦叶白佛言　　我亦归三宝
  是名为正路　　诸佛之境界
  三宝平等相　　常有大智性
  我性及佛性　　无二无差别
  是道佛所赞　　正进安止处
  亦名正遍见　　故为佛所称
  我亦趣善逝　　所赞无上道
  是最为甘露　　诸有所无有

尔时佛告迦叶菩萨。善男子。汝今不应如诸声闻凡夫之人分别三宝于此大乘无有三归分别之相。所以者何。于佛性中即有法僧。为欲化度声闻凡夫故分别说三归异相。善男子。若欲随顺世间法者。则应分别有三归依。善男子。菩萨应作如是思惟。我今此身归依于佛。若即此身得成佛道。既成佛已不当恭敬礼拜供养于诸世尊。何以故。诸佛平等等为众生作归依故。若欲尊重法身舍利。便应礼敬诸佛塔庙。所以者何。为欲化度诸众生故。亦令众生于我身中起塔庙想礼拜供养。如是众生以我法身为归依处。一切众生皆依非真邪伪之法。我当次第为说真法。又有归依非真僧者。我当为作依真僧处。若有分别三归依者。我当为作一归依处无三差别。于生盲众为作眼目。复当为诸声闻缘觉作真归处。善男子。如是菩萨。为无量恶诸众生等及诸智者而作佛事

善男子。譬如有人临阵战时即生心念。我于是中最为第一。一切兵众悉依恃我。亦如王子如是思惟。我当调伏其余王子绍继大王霸王之业而得自在。令诸王子悉见归依。是故不应生下劣心。如王王子大臣亦尔。善男子。菩萨摩诃萨亦复如是。作是思惟。云何三事与我一体。善男子。我示三事即是涅槃。如来者名无上士。譬如人身头最为上。非余支节手足等也。佛亦如是最为尊上。非法僧也。为欲化度诸世间故。种种示现差别之相如彼梯橙。是故汝今不应受持如凡愚人所知三归差别之相。汝于大乘猛利决断应如刚刀。迦叶菩萨白佛言。世尊。我知故问非为不知。我为菩萨大勇猛者。问于无垢清净行处。欲令如来为诸菩萨广宣分别奇特之事。称扬大乘方等经典。如来大悲今已善说。我亦如是安住其中。所说菩萨清净行处。即是宣说大涅槃经。世尊。我今亦当广为众生显扬如是如来秘藏。亦当证知真三归处。若有众生能信如是大涅槃经。其人则能自然了达三归依处。何以故。如来秘藏有佛性故。其有宣说是经典者。皆言身中尽有佛性。如是之人则不远求三归依处。何以故。于未来世我身即当成就三宝。是故声闻缘觉之人及余众生皆依于我恭敬礼拜。善男子。以是义故应当正学大乘经典。迦叶复言。佛性如是不可思议。三十二相八十种好亦不可思议

尔时佛赞迦叶菩萨。善哉善哉。善男子。汝已成就深利智慧。我今当更善为汝说入如来藏。若我住者即是常法不离于苦。若无我者修行净行无所利益。若言诸法皆无有我是即断见。若言我住即是常见。若言一切行无常者。即是断见。诸行常者复是常见。若言苦者即是断见。若言乐者复是常见。修一切法常者堕于断见。修一切法断者堕于常见。如步屈虫要因前脚得移后足。修常断者亦复如是。要因断常。以是义故。修余法苦者皆名不善。修余法乐者则名为善。修余法无我者是诸烦恼分。修余法常者是则名曰如来秘藏。所谓涅槃无有窟宅。修余无常法者即是财物。修余常法者谓佛法僧及正解脱。当知如是佛法中道远离二边而说真法。凡夫愚人于中无疑。如羸病人服食酥已气力轻便。有无之法体性不定。譬如四大其性不同各相违反。良医善知随其偏发而消息之。善男子。如来亦尔。于诸众生犹如良医。知诸烦恼体相差别而为除断。开示如来秘密之藏清净佛性常住不变。若言有者智不应染。若言无者即是妄语。若言有者不应默然。亦复不应戏论诤讼。但求了知诸法真性。凡夫之人戏论诤讼不解如来微密藏故。若说于苦愚人便谓身是无常。说一切苦复不能知身有乐性。若说无常者凡夫之人计一切身皆是无常譬如瓦坏。有智之人应当分别。不应尽言一切无常。何以故。我身即有佛性种子。若说无我凡夫当谓一切佛法悉无有我。智者应当分别无我假名不。实如是知已不应生疑。若言如来秘藏空寂。凡夫闻之生断灭见。有智之人应当分别如来是常无有变易。若言解脱喻如幻化。凡夫当谓得解脱者即是摩灭。有智之人应当分别人中师子虽有去来常住无变。若言无明因缘诸行。凡夫之人闻已分别生二法想。明与无明。智者了达其性无二。无二之性即是实性。若言诸行因缘识者。凡夫谓二行之与识。智者了达其性无二。无二之性即是实性。若言十善十恶可作不可作。善道恶道白法黑法。凡夫谓二。智者了达其性无二。无二之性即是实性。若言应修一切法苦。凡夫谓二。智者了达其性无二。无二之性即是实性。若言一切行无常者。如来秘藏亦是无常。凡夫谓二智者了达其性无二。无二之性即是实性。若言一切法无我。如来秘藏亦无有我。凡夫谓二。智者了达其性无二。无二之性即是实性。我与无我性无有二。如来秘藏其义如是。不可称计无量无边诸佛所赞。我今于是一切功德成就经中皆悉说已

善男子。我与无我性相无二。汝应如是受持顶戴。善男子。汝亦应当坚持忆念如是经典。如我先于摩诃般若波罗蜜经中说我无我无有二相。如因乳生酪。因酪得生酥。因生酥得熟酥。因熟酥得醍醐。如是酪性为从乳生为从自生从他生耶。乃至醍醐亦复如是。若从他生即是他作非是乳生。若非乳生乳无所为。若自生者不应相似相续而生。若相续生则不俱生。若不俱生五种之味则不一时。虽不一时定复不从余处来也。当知乳中先有酪相。甘味多故不能自变。乃至醍醐亦复如是。是牛食啖水草因缘。血脉转变而得成乳。若食甘草其乳则甜。若食苦草乳则苦味。雪山有草名曰肥腻。牛若食者纯得醍醐。无有青黄赤白黑色谷草因缘。其乳则有色味之异。是诸众生以明无明业因缘故生于二相。若无明转则变为明。一切诸法善不善等。亦复如是无有二相

迦叶菩萨白佛言。世尊。如佛所说乳中有酪是义云何。世尊。若言乳中定有酪相。以微细故不可见者。云何说言从乳因缘而生于酪。法若本无则名为生。如其已有云何言生。若言乳中定有酪相。百草之中亦应有乳。如是乳中亦应有草。若言乳中定无酪者。云何因乳而得生酪。若法本无而后生者。何故乳中不生于草

善男子。不可定言乳中有酪乳中无酪。亦不可说从他而生。若言乳中定有酪者。云何而得体味各异。是故不可说言乳中定有酪性。若言乳中定无酪者。乳中何故不生兔角。置毒乳中酪则杀人。是故不可说言乳中定无酪性。若言是酪从他生者。何故水中不生于酪。是故不可说言酪从他生。善男子。是牛食啖草因缘故。血则变白草血灭已。众生福力变而成乳。是乳虽从草血而出不得言二。唯得名为从因缘生。酪至醍醐亦复如是。以是义故得名牛味。是乳灭已因缘成酪。何等因缘若酢若暖。是故得名从因缘有。乃至醍醐亦复如是。是故不得定言乳中无有酪相。从他生者离乳而有。无有是处。善男子。明与无明亦复如是。若与烦恼诸结俱者。名为无明。若与一切善法俱者。名之为明。是故我言无有二相。以是因缘我先说言。雪山有草名曰肥腻。牛若食者即成醍醐。佛性亦尔

善男子。众生薄福不见是草。佛性亦尔。烦恼覆故众生不见。譬如大海虽同一碱其中亦有上妙之水味同于乳。喻如雪山虽复成就种种功德多生诸药。亦有毒草。诸众生身亦复如是。虽有四大毒蛇之种其中亦有妙药大王。所谓佛性。非是作法。但为烦恼客尘所覆。若刹利婆罗门毗舍首陀能断除者。即见佛性成无上道。譬如虚空震雷起云。一切象牙上皆生花。若无雷震花则不生亦无名字。众生佛性亦复如是。常为一切烦恼所覆不可得见。是故我说众生无我。若得闻是大般涅槃微妙经典则见佛性。如象牙花。虽闻契经一切三昧。不闻是经不知如来微妙之相。如无雷时象牙上花不可得见。闻是经已即知一切如来所说秘藏佛性。喻如天雷见象牙花。闻是经已即知一切无量众生皆有佛性。以是义故说大涅槃。名为如来秘密之藏。增长法身犹如雷时象牙上花。以能长养如是大义。故得名为大般涅槃。若有善男子善女人。有能习学是大涅槃微妙经典。当知是人能报佛恩真佛弟子。迦叶菩萨白佛言。甚奇世尊。所言佛性甚深甚深难见难入。声闻缘觉所不能服

佛言。善男子。如是如是。如汝所叹。不违我说。迦叶菩萨白佛言。世尊。佛性者云何甚深难见难入

佛言。善男子。如百盲人为治目故造诣良医。是时良医即以金錍决其眼膜。以一指示问言见不。盲人答言。我犹未见。复以二指三指示之乃言少见。善男子。是大涅槃微妙经典如来未说亦复如是。无量菩萨虽具足行诸波罗蜜乃至十住。犹未能见所有佛性。如来既说即便少见。是菩萨摩诃萨既得见已。咸作是言。甚奇世尊。我等流转无量生死。常为无我之所惑乱。善男子。如是菩萨位阶十地尚不了了知见佛性。何况声闻缘觉之人能得见耶。复次善男子。譬如仰观虚空鹅雁。为是虚空为是鹅雁。谛观不已仿佛见之。十住菩萨于如来性知见少分亦复如是。况复声闻缘觉之人能得知见。善男子。譬如醉人欲涉远路蒙聋见道。十住菩萨于如来性知见少分亦复如是。善男子。譬如渴人行于圹野。是人渴逼遍行求水见有丛树。树有白鹤是人迷闷不能分别是树是水。谛观不已乃见白鹤及以丛树。善男子。十住菩萨于如来性知见少分亦复如是。善男子譬如有人在大海中乃至无量百千由旬。远望大舶楼橹堂阁。即作是念。彼是楼橹。为是虚空。久视乃生必定之心知是楼橹。十住菩萨于自身中见如来性亦复如是。善男子。譬如王子身极懦弱通夜游戏。至明清旦目视一切悉不明了。十住菩萨虽于己身见如来性亦复如是不大明了。复次善男子。譬如臣吏王事所拘逼夜还家。电明暂发因见牛聚。即作是念。为是牛耶聚云屋舍。是人久视虽生牛想犹不审定。十住菩萨虽于己身见如来性未能审定亦复如是。复次善男子。如持戒比丘观无虫水而见虫相。即作是念。此中动者为是虫耶是尘土耶。久视不已虽知是尘亦不明了。十住菩萨于己身中见如来性亦复如是不大明了。复次善男子。譬如有人于阴闇中远见小儿。即作是念。彼为是牛鹫鸟人耶。久观不已虽见小儿犹不明了。十住菩萨于己身分见如来性亦复如是不大明了。复次善男子。譬如有人于夜闇中见画菩萨像。即作是念。是菩萨像自在天像大梵天像成染衣耶。是人久观虽复意谓是菩萨像亦不明了。十住菩萨于己身分见如来性亦复如是不大明了。善男子。所有佛性如是甚深难得知见。唯佛能知。非诸声闻缘觉所及。善男子。智者应作如是分别知如来性。迦叶菩萨白佛言。世尊。佛性如是微细难知。云何肉眼而能得见

佛言。迦叶。善男子。如彼非想非非想天。亦非二乘所能得知。随顺契经以信故知。善男子。声闻缘觉信顺如是大涅槃经。自知己身有如来性亦复如是。善男子。是故应当精勤修习大涅槃经。善男子。如是佛性唯佛能知。非诸声闻缘觉所及

迦叶菩萨白佛言。世尊。非圣凡夫有众生性皆说有我

佛言。譬如二人共为亲友。一是王子。一是贫贱。如是二人互相往返。是时贫人见是王子有一好刀净妙第一心中贪着。王子后时捉持是刀逃至他国。于是贫人后于他家寄卧止宿。即于眠中讇语刀刀傍人闻之收至王所。时王问言。汝言刀者何处得耶。是人具以上事答王。王今设使屠割臣身分张手足。欲得刀者实不可得。臣与王子素为亲厚。先与一处虽曾眼见。乃至不敢以手[打-丁+棠]触。况当故取。王复问言。卿见刀时相貌何类。答言。大王。臣所见者如羖羊角。王闻是已欣然而笑。语言。汝今随意所至莫生忧怖。我库藏中都无是刀。况汝乃于王子边见。时王即问诸群臣言。汝等曾见如是刀不。言已崩背。寻立余子绍继王位。复问辅臣。卿等。曾于官藏之中见是刀不。诸臣答言。臣等曾见。覆复问言。其状何似答言。大王。如羖羊角。王言。我官藏中何处当有如是相刀。次第四王皆悉捡挍求索不得。却后数时。先逃王子从他国还来至本土。复得为王既登王位。复问诸臣。汝见刀不。答言。大王。臣等皆见。覆复问言。其状何似。答言。大王。其色清净如优钵罗花。复有答言。形如羊角。复有说言。其色红赤犹如火聚。复有答言。犹如黑蛇。时王大笑。卿等皆悉不见我刀真实之相

善男子。菩萨摩诃萨亦复如是。出现于世说我真相。说已舍法。喻如王子持净妙刀逃至他国。凡夫愚人说言一切有我有我。如彼贫人止宿他舍讇语刀刀。声闻缘觉问诸众生我有何相。答言。我见我相大如母指。或言如米。或如稗子。有言我相住在心中炽然如日。如是众生不知我相。喻如诸臣不知刀相。菩萨如是说于我法。凡夫不知种种分别妄作我相。如问刀相。答似羊角。是诸凡夫次第相续而起邪见。为断如是诸邪见故。如来示现说于无我。喻如王子语诸臣言。我库藏中无如是刀。善男子。今日如来所说真我。名曰佛性。如是佛性。我佛法中喻如净刀。善男子。若有凡夫能善说者。即是随顺无上佛法。若有善能分别随顺宣说是者。当知即是菩萨相貌。善男子。所有种种异论咒术言语文字。皆是佛说非外道说

迦叶菩萨白佛言。世尊。云何如来说字根本。佛言。善男子。说初半字以为根本。持诸记论咒术文章诸阴实。法凡夫之人学是字本。然后能知是法非法

迦叶菩萨复白佛言。世尊。所言字者其义云何。善男子。有十四音名为字义。所言字者名曰涅槃。常故不流。若不流者则为无尽。夫无尽者即是如来金刚之身。是十四音名曰字本。恶者不破坏故。不破坏者名曰三宝。喻如金刚。又复恶者名不流故。不流者即是如来。如来九孔无所流故是故不流。又无九孔是故不流。不流即常常即如来。如来无作是故不流。又复恶者名为功德。功德者即是三宝。是故名恶。阿者名阿阇梨。阿阇梨者义何谓耶。于世间中得名圣者。何谓为圣圣名无著。少欲知足亦名清净。能度众生于三有流生死大海是名为圣。又复阿者名曰制度。修持净戒随顺威仪。又复阿者名依圣人。应学威仪进止举动。供养恭敬礼拜三尊。孝养父母及学大乘。善男女等具持禁戒。及诸菩萨摩诃萨等是名圣人。又复阿者名曰教诲。如言汝来如是应作如是莫作。若有能遮非威仪法是名圣人。是故名阿

亿者即是佛法。梵行广大清净无垢。喻如满月。汝等如是应作不作是义非义。此是佛说。此是魔说。是故名亿。伊者佛法。微妙甚深难得。如自在天大梵天王。法名自在若能持者则名护法。又自在者名四护世。是四自在则能摄护大涅槃经。亦能自在敷扬宣说。又复伊者能为众生自在说法。复次伊者为自在故说何等是也。所谓修习方等经典。复次伊者为断嫉妒如除稗秽。皆悉能令变成吉祥。是故名伊

郁者于诸经中最上最胜。增长上上谓大涅槃。复次郁者如来之性声闻缘觉所未曾闻。如一切处北郁单越最为殊胜。菩萨若能听受是经于一切众最为殊胜。以是义故是经得名最上最胜。是故名郁。优者喻如牛乳诸味中上。如来之性亦复如是。于诸经中最尊最上。若有诽谤当知是人与牛无别。复次优者是人名为无慧正念。诽谤如来微密秘藏。当知是人甚可怜愍。远离如来秘密之藏说无我法。是故名优

咽者即是诸佛法性涅槃。是故名咽。嘢者谓如来义。复次嘢者如来进止屈伸举动。无不利益一切众生。是故名嘢

乌者名烦恼义。烦恼者名曰诸漏。如来永断一切烦恼。是故名乌。炮者谓大乘义。于十四音是究竟义。大乘经典亦复如是。于诸经论最为究竟。是故名炮

庵者能遮一切诸不净物。于佛法中能舍一切金银宝物。是故名庵。阿者名胜乘义。何以故。此大乘典大涅槃经。于诸经中最为殊胜。是故名阿

迦者于诸众生起大慈悲。生于子想如罗睺罗作妙上善义。是故名迦。佉者名非善友。非善友者名为杂秽。不信如来秘密之藏。是故名佉。伽者名藏。藏者即是如来秘藏。一切众生皆有佛性。是故名伽。[口*恒]者如来常音。何等名为如来常音。所谓如来常住不变。是故名[口*恒]。俄者一切诸行破坏之相。是故名俄

遮者即是修义。调伏一切诸众生故。名为修义。是故名遮。车者如来覆荫一切众生。喻如大盖。是故名车。阇者。是正解脱。无有老相。是故名阇。膳者烦恼繁茂。喻如稠林。是故名膳。喏者是智慧义。知真法性。是故名喏

吒者于阎浮提示现半身而演说法。喻如半月。是故名吒。侘者法身具足。喻如满月。是故名侘。荼者是愚痴僧。不知常与无常。喻如小儿。是故名荼。祖者不知师恩。喻如羝羊。是故名祖。拏者非是圣义。喻如外道。是故名拏。多者如来于彼告诸比丘。宜离惊畏当为汝等说微妙法。是故名多。他者名愚痴义。众生流转生死缠裹如蚕蜣螂。是故名他。陀者名曰大施。所谓大乘是故名陀。弹者称赞功德。所谓三宝如须弥山高峻广大无有倾倒。是故名弹。那者三宝安住无有倾动。喻如门阃。是故名那

波者名颠倒义。若言三宝悉皆灭尽。当知是人为自疑惑是故名波。颇者是世间灾。若言世间灾起之时三宝亦尽。当知是人愚痴无智违失圣旨。是故名颇。婆者名佛十力。是故名婆。滼者名为重担。堪任荷负无上正法。当知是人是大菩萨。是故名滼。摩者是诸菩萨严峻制度。所谓大乘大般涅槃。是故名摩

蛇者是诸菩萨在在处处为诸众生说大乘法。是故名蛇。啰者能坏贪欲嗔恚愚痴说真实法。是故名啰。罗者名声闻乘动转不住。大乘安固无有倾动。舍声闻乘精勤修习无上大乘。是故名罗。和者如来世尊。为诸众生雨大法雨。所谓世间咒术经书。是故名和。奢者远离三箭。是故名奢沙者名具足义若能听是大涅槃经。则为已得闻持一切大乘经典。是故名沙。娑者为诸众生演说正法令心欢喜。是故名娑。呵者名心欢喜。奇哉世尊离一切行。怪哉如来入般涅槃。是故名呵。[口*荼]者名曰魔义。无量诸魔不能毁坏如来秘藏。是故名[口*荼]。复次[口*荼]者乃至示现随顺世间有父母妻子。是故名[口*荼]鲁流卢楼。如是四字说有四义。谓佛法僧及以对法。言对法者随顺世间。如调婆达示现坏僧。化作种种形貌色像。为制戒故智者了达不应。于此而生畏怖。是名随顺世间之行。以是故名鲁流卢楼

吸气舌根随鼻之声。长短超声随音解义。皆因舌齿而有差别。如是字义能令众生口业清净。众生佛性则不如是假于文字然后清净。何以故。性本净故虽复处在阴界入中。则不同于阴入界也。是故众生悉应归依诸菩萨等。以佛性故等视众生无有差别。是故半字于诸经书记论文章而为根本。又半字义皆是烦恼言说之本。故名半字。满字者乃是一切善法言说之根本也。譬如世间为恶之者名为半人。修善之者名为满人。如是一切经书记论皆因半字而为根本。若言如来及正解脱入于半字。是事不然。何以故。离文字故。是故如来于一切法无碍无著真得解脱。何等名为解了字义。有知如来出现于世能灭半字。是故名为解了字义。若有随逐半字义者。是人不知如来之性。何等名为无字义也。亲近修习不善法者是名无字。又无字者虽能亲近修习善法。不知如来常与无常恒与非恒。及法僧二宝律与非律。经与非经魔说佛说。若有不能如是分别。是名随逐无字义也。我今已说如是随逐无字之义。善男子。是故汝今应离半字善解满字迦叶菩萨白佛言。世尊。我等应当善学字数。今我值遇无上之师。已受如来殷勤诲敕。佛赞迦叶。善哉善哉。乐正法者应如是学

尔时佛告迦叶菩萨。善男子。鸟有二种。一名迦邻提。二名鸳鸯。游止共俱不相舍离。是苦无常无我等法。亦复如是不得相离

迦叶菩萨白佛言。世尊。云何是苦无常无我。如彼鸳鸯迦邻提鸟

佛言。善男子。异法是苦异法是乐。异法是常异法无常。异法是我异法无我。譬如稻米异于麻麦。麻麦复异豆粟甘蔗。如是诸种从其萌芽乃至叶花皆是无常。果实成熟人受用时乃名为常。何以故。性真实故

迦叶白佛言。世尊。如是等物若是常者同如来耶

佛言。善男子。汝今不应作如是说。何以故。若言如来如须弥山。劫坏之时须弥崩倒。如来尔时岂同坏耶。善男子。汝今不应受持是义。善男子。一切诸法唯除涅槃。更无一法而是常者。直以世谛言果实常

迦叶菩萨白佛言。世尊。善哉善哉。如佛所说。佛告迦叶。如是如是。善男子。虽修一切契经诸定。乃至未闻大般涅槃。皆言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了己身有佛性故。是名为常。复次善男子。譬如庵罗树其花始敷名无常相。若成果实多所利益乃名为常。如是善男子。虽修一切契经诸定。未闻如是大涅槃时。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了自身有佛性故。是名为常。复次善男子。譬如金矿消融之时。是无常相融已成金多所利益。乃名为常。如是善男子。虽修一切契经诸定。未闻如是大涅槃时。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了自身有佛性故。是名为常。复次善男子。譬如胡麻未被压时名曰无常。既压成油多有利益。乃名为常。善男子。虽修一切契经诸定。未闻如是大涅槃经。咸言一切悉是无常。闻是经已虽有烦恼如无烦恼。即能利益一切人天。何以故。晓了己身有佛性故。是名为常。复次善男子。譬如众流皆归于海。一切契经诸定三昧皆归大乘大涅槃经。何以故。究竟善说有佛性故。善男子。是故我言异法是常异法无常。乃至无我亦复如是

迦叶菩萨白佛言。世尊。如来已离忧悲毒箭。夫忧悲者名为天如来非天。忧悲者名为人如来非人。忧悲者名二十五有。如来非二十五有。是故如来无有忧悲。何故称言如来忧悲。善男子。无想天者名为无想。若无想者则无寿命。若无寿命云何而有阴界诸入。以是义故。无想天寿不可说言有所住处。善男子。譬如树神依树而住。不得定言依枝依节依茎依叶。虽无定所不得言无。无想天寿亦复如是。善男子。佛性亦尔。甚深难解。如来实无忧悲苦恼。而于众生起大慈悲现有忧悲。视诸众生如罗睺罗。复次善男子。无想天中所有寿命唯佛能知非余所及。乃至非想非非想处亦复如是。迦叶。如来之性清净无染。犹如化身。何处当有忧悲苦恼。若言如来无忧悲者。云何能利一切众生弘广佛法。若言无者云何而言等视众生如罗睺罗。若不等视如罗睺罗。如是之言则为虚妄。以是义故。善男子。佛不可思议法不可思议众生佛性不可思议。无想天寿不可思议。如来有忧及以无忧。是佛境界非诸声闻缘觉所知。善男子。譬如空中舍宅微尘不可住立。若言舍宅不因空住无有是处。以是义故。不可说舍住于虚空不住虚空。凡夫之人虽复说言舍住虚空。而是虚空实无所住。何以故。性无住故。善男子。心亦如是。不可说言住阴界入及以不住。无想天寿亦复如是。如来忧悲亦复如是。若无忧悲云何说言等视众生如罗睺罗。若言有者复云何言性同虚空。善男子。譬如幻师虽复化作种种宫殿。杀生长养系缚放舍。及作金银琉璃宝物丛林树木都无实性。如来亦尔。随顺世间示现忧悲无有真实。善男子。如来已入于般涅槃。云何当有忧悲苦恼。若谓如来入于涅槃是无常者。当知是人则有忧悲。若谓如来不入涅槃常住不变。当知是人无有忧悲。如来有愁及以无愁无能知者

复次善男子。譬如下人能知下法不知中上。中者知中不知于上。上者知上及知中下。声闻缘觉亦复如是。齐知自地。如来不尔悉知自地及以他地。是故如来名无碍智。示现幻化随顺世间凡夫肉眼谓是真实。而欲尽知如来无碍无上智者无有是处。有愁无愁唯佛能知。以是因缘异法有我异法无我。是名鸳鸯迦邻提鸟性

复次善男子。佛法犹如鸳鸯共行。是迦邻提及鸳鸯鸟。盛夏水涨选择高原安处其子为长养故。然后随本安隐而游。如来出世亦复如是。化无量众令住正法。如彼鸳鸯迦邻提鸟选择高原安置其子。如来亦尔。令诸众生所作已办即便入于大般涅槃。善男子。是名异法是苦异法是乐。诸行是苦涅槃是乐。第一微妙坏诸行故。迦叶菩萨白佛言。世尊。云何众生得涅槃者名第一乐。佛言。善男子。如我所说诸行和合名为老死

  谨慎无放逸　　是处名甘露
  放逸不谨慎　　是名为死句
  若不放逸者　　则得不死处
  如其放逸者　　常趣于死路

若放逸者名有为法。是有为法为第一苦。不放逸者则名涅槃。彼涅槃者名为甘露第一最乐。若趣诸行是名死处受第一苦。若至涅槃则名不死受最妙乐。若不放逸虽集诸行。是亦名为常乐不死不破坏身。云何放逸云何不放逸。非圣凡夫是名放逸常死之法。出世圣人是不放逸无有老死。何以故。入于第一常乐涅槃。以是义故。异法是苦异法是乐。异法是我异法无我。如人在地仰观虚空不见鸟迹。善男子。众生亦尔无有天眼。在烦恼中而不自见有如来性。是故我说无我密教。所以者何。无天眼者不知真我横计我故。因诸烦恼所造有为即是无常。是故我说异法是常异法无常

  精进勇健者　　若处于山顶
  平地及旷野　　常见诸凡夫
  升大智慧殿　　无上微妙台
  既自除忧患　　亦见众生忧

如来悉断无量烦恼住智慧山。见诸众生常在无量亿烦恼中。迦叶菩萨复白佛言。世尊。如偈所说是义不然。何以故。入涅槃者无忧无喜。云何得升智慧台殿。复当云何住在山顶而见众生。佛言。善男子。智慧殿者即名涅槃。无忧愁者谓如来也。有忧愁者名凡夫人。以凡夫忧故如来无忧。须弥山顶者谓正解脱。勤精进者喻须弥山无有动转。地谓有为行也。是诸凡夫安住是地造作诸行。其智慧者则名正觉。离有常住故名如来。如来愍念无量众生。常为诸有毒箭所中。是故名为如来有忧。迦叶菩萨复白佛言。世尊。若使如来有忧戚者。则不得称为等正觉。佛言迦叶。皆有因缘随有众生应受化处。如来于中示现受生虽现受生而实无生。是故如来名常住法。如迦邻提鸳鸯等鸟

大般涅槃经卷第八大般涅槃经卷第九

        北凉天竺三藏昙无谶译

    如来性品第四之六

复次善男子。譬如有人见月不现。皆言月没而作没想。而此月性实无没也。转现他方彼处众生复谓月出。而此月性实无出也。何以故。以须弥山障故不现。其月常生性无出没。如来应正遍知亦复如是。出于三千大千世界。或阎浮提示有父母。众生皆谓如来生于阎浮提内。或阎浮提示现涅槃。而如来性实无涅槃。而诸众生皆谓如来实般涅槃喻如月没。善男子。如来之性实无生灭。为化众生故示生灭。善男子。如此满月余方见半。此方半月余方见满。阎浮提人若见月初皆谓一日起初月想。见月盛满谓十五日生盛满想。而此月性实无亏盈。因须弥山而有增减。善男子。如来亦尔于阎浮提或现初生或现涅槃。现始生时犹如初月一切皆谓童子初生。行于七步如二日月。或复示现入于书堂如三日月。示现出家如八日月。放大智慧微妙光明。能破无量众生魔众。如十五日盛满之月。或复示现三十二相八十种好。以自庄严而现涅槃喻如月蚀。如是众生所见不同。或见半月或见满月或见月蚀。而此月性实无增减蚀啖之者常是满月。如来之身亦复如是。是故名为常住不变。复次善男子。喻如满月一切悉现。在在处处城邑聚落山泽水中若井若池若盆若鍑一切皆现。有诸众生行百由旬百千由旬见月常随。凡夫愚人妄生忆想言。我本于城邑屋宅见如是月今复于此空泽而见。为是本月为异于本。各作是念月形大小或如鍑口。或复有言大如车轮。或言犹如四十九由旬。一切皆见月之光明。或见团圆喻如金盘。是月性一种种众生各见异相。善男子。如来亦尔出现于世。或有人天而作是念。如来今者在我前住。复有众生亦生是念如来今者在我前住。或有聋哑亦见如来有聋哑相。众生杂类言音各异皆谓如来悉同己语。亦各生念在我舍宅受我供养。或有众生见如来身广大无量。有见微小或有见佛是声闻像。或复有见为缘觉像。有诸外道复各念言。如来今者在我法中出家学道。或有众生复作是念。如来今者独为我故出现于世。如来实性喻如彼月即是法身是无生身。方便之身随顺于世示现无量本业因缘。在在处处示现有生犹如彼月。以是义故如来常住无有变易。复次善男子。如罗睺罗阿修罗王以手遮月。世间诸人咸谓月蚀。阿修罗王实不能蚀以阿修罗障其明故。是月团圆无有亏损。但以手障故使不现。若摄手时世间咸谓月已还生皆言是月多受苦恼。假使百千阿修罗王不能恼之。如来亦尔。示有众生于如来所生粗恶心出佛身血起五逆罪至一阐提。为未来世诸众生故如是示现坏僧断法而作留难。假使百千无量诸魔不能侵出如来身血。所以者何。如来之身无有肉血筋脉骨髓。如来真实实无恼坏。众生皆谓法僧毁坏如来灭尽。而如来性真实无变无有破坏随顺世间如是示现。复次善男子。如二人斗若以刀杖伤身出血虽至于死不起杀想。如是业相轻而不重。于如来所本无杀心虽出身血是业亦尔轻而不重。如来如是于未来世为化众生示现业报。复次善男子。犹如良医勤教其子医方根本。此是根药此是茎药此是色药种种相貌汝当善知。其子敬奉父之所敕精勤习学善解诸药。是医后时寿尽命终。其子号啕而作是言。父本教我根药如是茎药如是花药如是色相如是。如来亦尔为化众生示现制戒。应当如是受持莫犯。作五逆罪诽谤正法及一阐提。为未来世起是事者是故示现。欲令比丘于佛灭后作如是知。此是契经甚深之义。此是戒律轻重之相。此是阿毗昙分别法句。如彼医子

复次善男子。如人知月六月一蚀。而上诸天须臾之间已见月蚀。何以故。彼天日长人间短故。善男子。如来亦尔天人咸谓如来寿短。如彼天人须臾之间频见月蚀。如来又于须臾之间示现百千万亿涅槃。断烦恼魔阴魔死魔。是故百千万亿天魔悉知如来入般涅槃。又复示现无量百千先业因缘。随顺世间种种性故。示现如是无量无边不可思议。是故如来常住无变。复次善男子。譬如明月众生乐见。是故称月号为乐见。众生若有贪恚愚痴。则不得称为乐见也。如来如是其性纯善清净无垢。是最可称为乐见也。乐法众生视之无厌。恶心之人不喜瞻睹。以是义故故言如来喻如明月。复次善男子。譬如日出有三时异。谓春夏冬。冬日则短春日处中夏日极长。如来亦尔于此三千大千世界为短寿者。及诸声闻示现寿短。斯等见已咸谓如来寿命短促喻如冬日。为诸菩萨示现中寿若至一劫若减一劫喻如春日。唯佛睹佛其寿无量喻如夏日。善男子。如来所说方等大乘微密之教示现世间。雨大法雨于未来世。若有人能护持是典开示分别利益众生。当知是辈真是菩萨喻如盛夏天降甘雨。若有声闻缘觉之人闻佛如来微密之教。喻如冬日多遇冷患。菩萨之人若闻如是微密教诲如来常住性无变易。喻如春日萌牙开敷。而如来性实无长短为世间故示现如是。即是诸佛真实法性。复次善男子。譬如众星昼则不现。而人皆谓昼星灭没其实不没。所以不现日光映故。如来亦尔声闻缘觉不能得见。喻如世人不见昼星。复次善男子。譬如阴闇日月不现。愚夫谓言日月失没。而是日月实不失没。如来正法灭尽之时三宝现没。亦复如是非为永灭。是故当知如来常住无有变易。何以故。三宝真性不为诸垢之所染故

复次善男子。譬如黑月彗星夜现。其明炎炽暂出还没。众生见已生不祥想。诸辟支佛亦复如是出无佛世。众生见已皆谓如来真实灭度生忧悲想。而如来身实不灭度。如彼日月无有灭没

复次善男子。譬如日出众雾悉除。此大涅槃微妙经典亦复如是出兴于世。若有众生一经耳者悉能灭除一切诸恶无间罪业。是大涅槃甚深境界不可思议。善说如来微密之性。以是义故诸善男子善女人等。应于如来生常住心无有变易正法不断僧宝不灭。是故应当多修方便勤学是典。是人不久当得成于阿耨多罗三藐三菩提。是故此经名为无量功德所成。亦名菩提不可穷尽。以不尽故故得称为大般涅槃。有善光故犹如夏日。身无边故名大涅槃

复次善男子。如日月光诸明中最。一切诸明所不能及。大涅槃光亦复如是。于诸契经三昧光明最为殊胜。诸经三昧所有光明所不能及。何以故。大涅槃光能入众生诸毛孔故。众生虽无菩提之心而能为作菩提因缘。是故复名大般涅槃。迦叶菩萨白佛言。世尊。如佛所说大涅槃光入于一切众生毛孔。众生虽无菩提之心。而能为作菩提因者。是义不然。何以故。世尊。犯四重禁作五逆人及一阐提。光明入身作菩提因者。如是等辈与净持戒修习诸善有何差别。若无差别如来何故说四依义。世尊。又如佛言若有众生闻大涅槃一经于耳。则得断除诸烦恼者。如来云何先说有人于恒河沙等佛所发心。闻大涅槃不解其义。若不解义云何能断一切烦恼。佛言善男子。除一阐提。其余众生闻是经已。悉皆能作菩提因缘。法声光明入毛孔者必定当得阿耨多罗三藐三菩提。何以故。若有人能供养恭敬无量诸佛。方乃得闻大涅槃经。薄福之人则不得闻。所以者何。大德之人乃能得闻。如是大事厮下小人则不得闻。何等为大。所谓诸佛甚深秘藏谓佛性是。以是义故名为大事。迦叶菩萨白佛言。世尊。云何未发菩提心者得菩提因。佛告迦叶。若有闻是大涅槃经。言我不用发菩提心诽谤正法。是人即于梦中见罗刹像心中怖懅。罗刹语言咄善男子。汝今若不发菩提心当断汝命。是人惶怖觉已即发菩提之心。是人命终若在三恶及在人天。续复忆念菩提之心。当知是人是大菩萨摩诃萨也。以是义故。是大涅槃威神力故。能令未发菩提心者作菩提因。善男子。是名菩萨发心因缘非无因缘。以是义故。大乘妙典真佛所说。复次善男子。如虚空中兴大云雨注于大地。枯木石山高原堆阜水所不住。流注下田陂池悉满利益无量一切众生。是大涅槃微妙经典亦复如是。雨大法雨普润众生。唯一阐提发菩提心无有是处。复次善男子。譬如焦种虽遇甘雨百千万劫终不生芽。芽若生者亦无是处。一阐提辈亦复如是。虽闻如是大般涅槃微妙经典。终不能发菩提心牙。若能发者无有是处。何以故。是人断灭一切善根。如彼焦种不能复生菩提根牙。复次善男子。譬如明珠置浊水中以珠威德水即为清。投之淤泥不能令清。是大涅槃微妙经典亦复如是。置余众生五无间罪四重禁法浊水之中。犹可澄清发菩提心。投一阐提淤泥之中。百千万岁不能令清起菩提心。何以故。是一阐提灭诸善根非其器故。假使是人百千万岁听受如是大涅槃经。终不能发菩提之心。所以者何。无善心故

复次善男子。譬如药树名曰药王。于诸药中最为殊胜。若和酪浆若蜜若苏若水若乳若末若丸。若以涂疮薰身涂目若见若嗅。能灭众生一切诸病。如是药树不作是念。一切众生若取我根不应取叶。若取叶者不应取根。若取身者不应取皮。若取皮者不应取身。是树虽复不生是念而能除灭一切病苦。善男子。是大涅槃微妙经典亦复如是。能除一切众生恶业四波罗夷五无间罪。若内若外所有诸恶诸有未发菩提心者。因是则得发菩提心。何以故。是妙经典诸经中王。如彼药树诸药中王。若有修习是大涅槃及不修者。若闻有是经典名字。闻已敬信所有一切烦恼重病皆悉除灭。唯不能令一阐提辈安止住于阿耨多罗三藐三菩提。如彼妙药虽能疗愈种种重病。而不能治必死之人。复次善男子。如人手疮捉持毒药毒则随入。若无疮者毒则不入。一阐提辈亦复如是。无菩提因如无疮者毒不得入。所谓疮者即是无上菩提因缘。毒者即是第一妙药。完无疮者谓一阐提。复次善男子。譬如金刚无能坏者。而能破坏一切之物。唯除龟甲及白羊角。是大涅槃微妙经典亦复如是。悉能安止无量众生于菩提道。唯不能令一阐提辈立菩提因。复次善男子。如马齿草娑罗翅树尼迦罗树。虽断枝茎续生如故。不如多罗断已不生是诸众生亦复如是。若得闻是大涅槃经虽犯四禁及五无间。犹故能生菩提因缘。一阐提辈则不如是。虽得听受是妙经典而不能生菩提道因。复次善男子。如佉陀罗树镇头迦树断已不生及诸焦种。一阐提辈亦复如是。虽得闻是大涅槃经而不能发菩提因缘犹如焦种。复次善男子。譬如大雨终不住空是大涅槃微妙经典亦复如是。普雨法雨于一阐提则不能住。是一阐提周体密致。犹如金刚不容外物。迦叶菩萨白佛言。世尊。如佛说偈

  不见善不作　　唯见恶可作
  是处可怖畏　　犹如险恶道

世尊。如是所说有何等义。佛言善男子。不见者谓不见佛性。善者即是阿耨多罗三藐三菩提。不作者所谓不能亲近善友。唯见者见无因果。恶者谓谤方等大乘经典。可作者谓一阐提说无方等。以是义故一阐提辈无心趣向清净善法。何等善法谓涅槃也。趣涅槃者谓能修习贤善之行。而一阐提无贤善行。是故不能趣向涅槃。是处可畏谓谤正法。谁应怖畏所谓智者。何以故。以谤法者无有善心及方便故。险恶道者谓诸行也。迦叶复言。如佛所说

  云何见所作　　云何得善法
  何处不怖畏　　如王夷坦道

是义何谓。佛言善男子。见所作者。发露诸恶从生死际所作诸恶悉皆发露。至无至处。以是义故是处无畏。喻如人王所游正路。其中盗贼悉皆逃走。如是发露一切诸恶悉灭无余。复次不见所作者。谓一阐提所作众恶而不自见。是一阐提憍慢心故。虽多作恶于是事中初无怖畏。以是义故不得涅槃。喻如猕猴捉水中月。善男子。假使一切无量众生一时成于阿耨多罗三藐三菩提已。此诸如来亦复不见彼一阐提成于菩提。以是义故名不见所作。又复不见谁之所作。所谓不见如来所作。佛为众生说有佛性。一阐提辈流转生死不能知见。以是义故名为不见如来所作。又一阐提见于如来毕竟涅槃谓真无常。犹如灯灭膏油俱尽。何以故。是人恶业不亏损故。若有菩萨所作善业回向阿耨多罗三藐三菩提时。一阐提辈虽复毁呰破坏不信。然诸菩萨犹故施与。欲共成于无上之道。何以故。诸佛法尔

  作恶不即受　　如乳即成酪
  犹灰覆火上　　愚者轻蹈之

一阐提者名为无目。是故不见阿罗汉道。如阿罗汉不行生死险恶之道。以无目故诽谤方等。不欲修习如阿罗汉勤修慈心。一阐提辈不修方等亦复如是。若人说言我今不信声闻经典。信受大乘读诵解说是故我今即是菩萨。一切众生悉有佛性。以佛性故众生身中即有十力三十二相八十种好。我之所说不异佛说。汝今与我俱破无量诸恶烦恼如破水瓶。以破结故即得见于阿耨多罗三藐三菩提。是人虽作如是演说。其心实不信有佛性。为利养故随文而说。如是说者名为恶人。如是恶人不速受果如乳成酪。譬如王使善能谈论巧于方便奉命他国。宁丧身命终不匿王所说言教。智者亦尔于凡夫中不惜身命。要必宣说大乘方等如来秘藏。一切众生皆有佛性。善男子。有一阐提作罗汉像。住于空处诽谤方等大乘经典。诸凡夫人见已皆谓真阿罗汉是大菩萨摩诃萨。是一阐提恶比丘辈住阿兰若处。坏阿兰若法见他得利心生嫉妒。作如是言所有方等大乘经典悉是天魔波旬所说。亦说如来是无常法。毁灭正法破坏众僧。复作是言波旬所说非善顺说。作是宣说邪恶之法。是人作恶不即受报。如乳成酪灰覆火上愚轻蹈之。如是人者谓一阐提。是故当知大乘方等微妙经典必定清净。如摩尼珠投之浊水水即为清。大乘经典亦复如是。复次善男子。譬如莲花为日所照无不开敷。一切众生亦复如是。若得见闻大涅槃日。未发心者皆悉发心为菩提因。是故我说大涅槃光所入毛孔必为妙因。彼一阐提虽有佛性而为无量罪垢所缠。不能得出如蚕处茧。以是业缘不能生于菩提妙因。流转生死无有穷已

复次善男子。如优钵罗花钵头摩花拘牟头华分陀利华。生于淤泥而终不为彼泥所污。若有众生修大涅槃微妙经典亦复如是。虽有烦恼终不为此烦恼所污。何以故。以知如来性相力故。善男子。譬如有国多清冷风。若触众生身诸毛孔能除一切郁蒸之恼。此大乘典大涅槃经亦复如是。遍入一切众生毛孔为作菩提微妙因缘。除一阐提。何以故非法器故

复次善男子。譬如良医解八种药灭一切病唯除必死。一切契经禅定三昧亦复如是。能治一切贪恚愚痴诸烦恼病。能拔烦恼毒刺等箭。而不能治犯四重禁五无间罪。善男子。复有良医过八种术能除众生所有病苦。唯不能治必死之病。是大涅槃大乘经典亦复如是。能除众生一切烦恼。安住如来清净妙因。未发心者令得发心。唯除必死一阐提辈

复次善男子。譬如良医能以妙药治诸盲人。令见日月星宿诸明一切色像。唯不能治生盲之人。是大乘典大涅槃经亦复如是。能为声闻缘觉之人开发慧眼。令其安住无量无边大乘经典。未发心者谓犯四禁五无间罪悉能令发菩提之心。唯除生盲一阐提辈。复次善男子。譬如良医善解八术为治众生一切病苦。与种种方吐下诸药。及以涂身熏药灌鼻散药丸药。若贫愚人不欲服之。良医愍念即将是人还其舍宅强与令服。以药力故所患得除。女人产时儿衣不出与之令服服已即出。并令婴儿安乐无患。是大乘典大涅槃经亦复如是。所至之处若至舍宅能除众生无量烦恼。犯四重禁五无间罪未发心者悉令发心。除一阐提。迦叶菩萨白佛言。世尊。犯四重禁及五无间名极重恶。譬如断截多罗树头更不复生。是等未发菩提之心云何能与作菩提因。佛言善男子。是诸众生若于梦中梦堕地狱。受诸苦恼即生悔心哀哉我等自招此罪。若我今得脱是罪者必定当发菩提之心我今所见最是极恶。从是觉已即知正法有大果报。如彼婴儿渐渐长大。常作是念是医最良善解方药。我本处胎与我母药。母以药故身得安隐。以是因缘我命得全。奇哉我母受大苦恼。满足十月怀抱我胎。既生之后推干去湿。除去不净大小便利。乳餔长养将护我身。以是义故我当报恩。色养侍卫随顺供养。犯四重禁及无间罪临命终时念是大乘大涅槃经。虽堕地狱畜生饿鬼天上人中。如是经典亦为是人作菩提因。除一阐提。复次善男子。譬如良医及良医子。所知深奥出过诸医。善知除毒无上咒术。若恶毒蛇若龙若蝮以诸咒术咒药令良。复以此药用涂革屣。以此革屣触诸毒虫毒为之消。唯除一毒名曰大龙。是大乘典大涅槃经亦复如是。若有众生犯四重禁五无间罪。悉能消灭令住菩提。如药革屣能消众毒。未发心者能令发心安止住于菩提之道。是彼大乘大涅槃经威神药故。令诸众生生于安乐。唯除大龙一阐提辈

复次善男子。譬如有人以杂毒药用涂大鼓。于大众中击之发声。虽无心欲闻闻之皆死。唯除一人不横死者。是大乘典大涅槃经亦复如是。在在处处诸行众中有闻声者。所有贪欲嗔恚愚痴悉皆灭尽。其中虽有无心思念。是大涅槃因缘力故能灭烦恼而结自灭。犯四重禁及五无间闻是经已。亦作无上菩提因缘渐断烦恼。除不横死一阐提也。复次善男子。譬如闇夜诸所营作一切皆息若未讫者要待日明。学大乘者虽修契经一切诸定。要待大乘大涅槃日。闻于如来微密之教。然后乃当造菩提业安住正法。犹如天雨润益增长一切诸种成就果实。悉除饥馑多受丰乐。如来秘藏无量法雨亦复如是。悉能除灭八种热病。是经出世如彼果实多所利益安乐一切。能令众生见于佛性。如法花中八千声闻得受记莂成大果实。如秋收冬藏更无所作。一阐提辈亦复如是于诸善法无所营作。复次善男子。譬如良医闻他人子非人所持。寻以妙药并遣一使敕语使言。卿持此药速与彼人。彼人若遇诸恶鬼神以药力故悉当远去。卿若迟晚吾自当往终不令彼抂横死也。若彼病人得见使者及吾威德。诸苦当除得安隐乐。是大乘典大涅槃经亦复如是。若比丘比丘尼优婆塞优婆夷及诸外道。有能受持如是经典。读诵通利。复为他人分别广说若自书写令他书写。斯等皆为菩提因缘。若犯四禁及五逆罪。若为邪鬼毒恶所持。闻是经典所有诸恶悉皆消灭。如见良医恶鬼远去。当知是人是真菩萨摩诃萨也。何以故。暂得闻是大涅槃故亦以生念如来常故。暂得闻者尚得如是。何况书写受持读诵。除一阐提其余皆是菩萨摩诃萨。复次善男子。譬如聋人不闻音声。一阐提辈亦复如是。虽复欲听是妙经典而不得闻。所以者何无因缘故。复次善男子。譬如良医一切医方无不通达。兼复广知无量咒术。是医见王作如是言。大王。今者有必死病。其王答言。卿不见我腹内之事。云何而言有必死病。医即答言。若不见信应服下药。既下之后王自验之。王不肯服。尔时良医以咒术力令王粪门遍生疮疱。兼复[病-丙+帶]下虫血杂出。王见是已生大怖懅。赞彼良医善哉善哉。卿先所白吾不用之。今乃知卿于吾此身作大利益。恭敬是医犹如父母。是大乘典大涅槃经亦复如是。于诸众生有欲无欲悉能令彼烦恼崩落。是诸众生乃至梦中梦见是经恭敬供养。喻如大王恭敬良医。是大良医知必死者终不治之。是大乘典大涅槃经亦复如是。终不能治一阐提辈。复次善男子。譬如良医善知八种悉能疗治一切诸病。唯不能治必死之人。诸佛菩萨亦复如是悉能救疗一切有罪。唯不能治必死之人一阐提辈。复次善男子。譬如良医善知八种微妙经术。复能博达过于八种。以己所知先教其子。若水若陆山涧药草悉令识知。如是渐渐教八事已。次复教余最上妙术。如来应正遍知亦复如是。先教其子诸比丘等方便除灭一切烦恼。修学净身不坚固想。谓水陆山涧水者喻身受苦如水上泡。陆者喻身不坚如芭蕉树。其山涧者喻烦恼中修无我想。以是义故身名无我。如来如是于诸弟子渐渐教学九部经法令善通利。然后教学如来秘藏。为其子故说如来常。如来如是说大乘典大涅槃经。为诸众生已发心者及未发心作菩提因。除一阐提。如是善男子。是大乘典大涅槃经无量无数不可思议未曾有也。当知即是无上良医。最尊最胜众经中王

复次善男子。譬如大船从海此岸至于彼岸。复从彼岸还至此岸。如来应正遍知亦复如是。乘大涅槃大乘宝船。周旋往返济渡众生。在在处处有应度者。悉令得见如来之身。以是义故如来名曰无上船师。譬如有船则有船师。以有船师则有众生渡于大海。如来常住化度众生亦复如是。复次善男子。譬如有人在大海中乘船欲渡。若得顺风须臾之间。则能得过无量由延。若不得者虽复久住经无量岁不离本处。有时船坏没水而死。众生如是在于愚痴生死大海乘诸行船。若得值遇大般涅槃猛利之风。则能疾到无上道岸。若不值遇当久流转无量生死。或时破坏堕于地狱畜生饿鬼。复次善男子。譬如有人不遇风王久住大海。作是思惟我等今者必在此死。如是念时忽遇利风随顺渡海。复作是言快哉是风未曾有也。令我等辈安隐得过大海之难。众生如是久处愚痴生死大海困苦穷悴。未遇如是大涅槃风。则应生念我等必定堕于地狱畜生饿鬼。是诸众生思惟是时忽遇大乘大涅槃风。随顺吹向入于阿耨多罗三藐三菩提。方知真实生奇特想叹言快哉。我从昔来未曾见闻如是如来微密之藏。尔乃于是大涅槃经生清净信

复次善男子。如蛇脱皮为死灭耶。不也世尊。善男子。如来亦尔方便示现弃舍毒身。可言如来无常灭耶。不也世尊。如来于此阎浮提中方便舍身。如破毒蛇舍于故皮。是故如来名为常住。复次善男子。譬如金师得好真金随意造作种种诸器。如来亦尔于二十五有悉能示现种种色身。为化众生拔生死故。是故如来名无边身。虽复示现种种诸身亦名常住无有变易

复次善男子。如庵罗树及阎浮树一年三变。有时生花光色敷荣。有时生叶滋茂蓊郁。有时雕落状似枯死。善男子。于意云何是树实为枯灭不耶。不也世尊。善男子。如来亦尔于三界中示三种身。有时初生有时长大有时涅槃。而如来身实非无常。迦叶菩萨赞言。善哉诚如圣教。如来常住无有变易

善男子。如来密语甚深难解。譬如大王告诸群臣先陀婆来。先陀婆者一名四实。一者盐。二者器。三者水。四者马。如是四法皆同此名。有智之臣善知此名。若王洗时索先陀婆即便奉水。若王食时索先陀婆即便奉盐。若王食已将欲饮浆索先陀婆即便奉器。若王欲游索先陀婆即便奉马。如是智臣善解大王四种密语。是大乘经亦复如是有四无常。大乘智臣应当善知。若佛出世为众生说如来涅槃。智臣当知此是如来为计常者说无常相。欲令比丘修无常想。或复说言正法当灭。智臣应知此是如来为计乐者说于苦相。欲令比丘多修苦想。或复说言我今病苦众僧破坏。智臣当知此是如来为计我者说无我相。欲令比丘修无我想。或复说言所谓空者是正解脱。智臣当知此是如来说正解脱无二十五有。欲令比丘修学空想。以是义故。是正解脱则名为空亦名不动。谓不动者是解脱中无有苦故是故不动。是正解脱为无有相。谓无相者无有色声香味触等故名无相。是正解脱常不变易。是解脱中无有无常热恼变易。是故解脱名曰常住不变清凉。或复说言一切众生有如来性。智臣当知此是如来说于常法欲令比丘修正常法。是诸比丘若能如是随顺学者。当知是人真我弟子善知如来微密之藏。如彼大王智慧之臣善知王意。善男子。如是大王亦有如是密语之法。何况如来而当无耶。善男子。是故如来微密之教难可得知。唯有智者乃能解我甚深佛法。非是世间凡夫品类所能信也

复次善男子。如波罗奢树迦尼迦树阿叔迦树。值天亢旱不生花实。及余水陆所生之物。皆悉枯悴无有润泽不能增长。一切诸药无复势力。善男子。是大乘典大涅槃经亦复如是。于我灭后有诸众生不能恭敬无有威德。何以故。是诸众生不知如来微密藏故。所以者何。以是众生薄福德故。复次善男子。如来正法将欲灭尽。尔时多有行恶比丘。不知如来微密之藏。懒堕懈怠不能读诵宣扬分别如来正法。譬如痴贼弃舍真宝担负草[麥*弋]。不解如来微密藏故。于是经中懈怠不勤。哀哉大险当来之世甚可怖畏。苦哉众生不勤听受是大乘典大涅槃经。唯诸菩萨摩诃萨等能于是经取真实义。不著文字随顺不逆为众生说。复次善男子。如牧牛女为欲卖乳。贪多利故加二分水。转卖与余牧牛女人。彼女得已复加二分。转复卖与近城女人。女人得已复加二分。转复卖与城中女人。彼女得已复加二分诣市卖之。时有一人为子纳妇。当须好乳以瞻宾客。至市欲买是卖乳者多索价数。是人答言汝乳多水不直尔许。正值我今瞻待宾客是故当取。取已还家煮用作糜都无乳味。虽复无味于苦味中千倍为胜。何以故。乳之为味诸味中最。善男子。我涅槃后正法未灭余八十年。尔时是经于阎浮提当广流布。是时当有诸恶比丘。抄略是经分作多分能灭正法色香美味。是诸恶人虽复诵读如是经典。灭除如来深密要义。安置世间庄严文饰无义之语。抄前着后抄后着前。前后着中中着前后。当知如是诸恶比丘是魔伴侣。受畜一切不净之物。而言如来悉听我畜。如牧牛女多加水乳。诸恶比丘亦复如是。杂以世语错定是经。令多众生不得正说正写正取尊重赞叹供养恭敬。是恶比丘为利养故。不能广宣流布是经。所可分流少不足言。如彼牧牛贫穷女人展转卖乳。乃至成糜而无乳味。是大乘典大涅槃经亦复如是。展转薄淡无有气味。虽无气味犹胜余经足一千倍。如彼乳味于诸苦味为千倍胜。何以故。是大乘典大涅槃经于声闻经最为上首。喻如牛乳味中最胜。以是义故名大涅槃

复次善男子。若善男子善女人等。无有不求男子身者。何以故。一切女人皆是众恶之所住处。复次善男子。如蚊子尿不能令此大地润洽。其女人者淫欲难满亦复如是。譬如大地一切作丸如葶苈子。如是等男与一女人共为欲事犹不能足。假使男子数如恒沙与一女人共为欲事犹不能足。善男子。譬如大海一切天雨百川众流皆悉投注。而彼大海未曾满足。女人之法亦复如是。假使一切悉为男者与一女人共为欲事而亦不足。复次善男子。如阿叔迦树波吒罗树迦尼迦树。春花开敷。有蜂唼取色香细味不知厌足。女人欲男亦复如是不知厌足。善男子。以是义故。诸善男子善女人等听是大乘大涅槃经。常应呵责女人之相求于男子。何以故。是大经典有丈夫相。所谓佛性。若人不知是佛性者则无男相。所以者何。不能自知有佛性故。若有不能知佛性者。我说是等名为女人。若能自知有佛性者。我说是人为丈夫相。若有女人能知自身定有佛性。当知是等即为男子。善男子。是大乘典大涅槃经。无量无边不可思议功德之聚。何以故。以说如来秘密藏故。是故善男子善女人。若欲速知如来密藏。应当方便勤修此经。迦叶菩萨白佛言。世尊。如是如是。如佛所说。我今已有丈夫之相。得入如来微密藏故。如来今日始觉悟我。因是即得决定通达。佛言。善哉善哉。善男子。汝今随顺世间之法而作是说。迦叶复言。我不随顺世间法也。佛赞迦叶。善哉善哉。汝今所知无上法味甚深难知而能得知。如蜂采味。汝亦如是。复次善男子。如蚊子泽不能令此大地沾洽。当来之世是经流布亦复如是。如彼蚊泽。正法欲灭。是经先当没于此地。当知即是正法衰相。复次善男子。譬如过夏初月名秋秋雨连注。此大乘典大涅槃经亦复如是。为于南方诸菩萨故。当广流布降注法雨弥满其处。正法欲灭当至罽宾具足无缺潜没地中。或有信者或不信者。如是大乘方等经典甘露法味悉没于地。是经没已一切诸余大乘经典皆悉灭没。若得是经具足无缺人中象王。诸菩萨等当知如来无上正法将灭不久

大般涅槃经卷第九大般涅槃经卷第十

        北凉天竺三藏昙无谶译

    如来性品第四之七

尔时文殊师利白佛言。世尊。今此纯陀犹有疑心。唯愿如来重为分别令得除断。佛言。善男子。云何疑心汝当说之当为除断。文殊师利言。纯陀心疑如来常住以得知见佛性力故。若见佛性而为常者。本未见时应是无常。若本无常后亦应尔。何以故。如世间物本无今有已有还无。如是等物悉是无常。以是义故诸佛菩萨声闻缘觉无有差别。尔时世尊。即说偈言

  本有今无　　本无今有　　三世有法
  无有是处

善男子。以是义故。诸佛菩萨声闻缘觉。亦有差别亦无差别。文殊师利赞言。善哉诚如圣教。我今始解诸佛菩萨声闻缘觉亦有差别亦无差别。迦叶菩萨白佛言。世尊。如来所说诸佛菩萨声闻缘觉性无差别。唯愿如来分别广说利益安乐一切众生。佛言。善男子。谛听谛听当为汝说。善男子。譬如长者若长者子。多畜乳牛有种种色。常令一人守护将养。是人有时为祠祀故尽构诸牛着一器中。见其乳色同一白色寻便惊怪。牛色各异。其乳云何皆同一色。是人思惟如此一切皆是众生业报因缘令乳色一。善男子。声闻缘觉菩萨亦尔。同一佛性犹如彼乳。所以者何。同尽漏故而诸众生言。佛菩萨声闻缘觉而有差别。有诸声闻凡夫之人疑于三乘云何无别。是诸众生久后自解一切三乘同一佛性。犹如彼人悟解乳相由业因缘。复次善男子。譬如金矿淘炼滓秽然后消融成金之后价直无量。善男子。声闻缘觉菩萨亦尔。皆得成就同一佛性。何以故。除烦恼故如彼金矿除诸滓秽。以是义故。一切众生同一佛性无有差别。以其先闻如来密藏后成佛时自然得知。如彼长者知乳一相。何以故。以断无量亿烦恼故。迦叶菩萨白佛言。世尊。若一切众生有佛性者。佛与众生有何差别。如是说者多有过咎。若诸众生皆有佛性。何因缘故舍利弗等以小涅槃而般涅槃。缘觉之人于中涅槃而般涅槃。菩萨之人于大涅槃而般涅槃。如是等人若同佛性。何故不同如来涅槃而般涅槃。善男子。诸佛世尊所得涅槃。非诸声闻缘觉所得。以是义故大般涅槃名为善有。世若无佛非无二乘得二涅槃。迦叶复言。是义云何。佛言。无量无边阿僧祇劫乃有一佛出现于世开示三乘。善男子。如汝所言菩萨二乘无差别者。我先于此如来密藏大涅槃中已说其义。诸阿罗汉无有善有。何以故。诸阿罗汉悉当得是大涅槃故。以是义故大般涅槃有毕竟乐。是故名为大般涅槃。迦叶言。如佛说者我今始知差别之义无差别义。何以故。一切菩萨声闻缘觉未来之世皆当归于大般涅槃。譬如众流归于大海。是故声闻缘觉之人悉名为常非是无常。以是义故亦有差别亦无差别。迦叶言。云何性差别。佛言善男子。声闻如乳缘觉如酪。菩萨之人如生熟酥。诸佛世尊犹如醍醐。以是义故大涅槃中说四种性而有差别。迦叶复言。一切众生性相云何。佛言善男子。如牛新生乳血未别。凡夫之性杂诸烦恼亦复如是。迦叶复言拘尸那城有旃陀罗名曰欢喜。佛记是人由一发心。当于此界千佛数中速成无上正真之道。以何等故如来不记尊者舍利弗目犍连等速成佛道。佛言善男子。或有声闻缘觉菩萨作誓愿言。我当久久护持正法然后乃成无上佛道。以发速愿故与速记。复次善男子。譬如商人有无价宝诣市卖之。愚人见之不识轻笑。宝主唱言我此宝珠价直无数。闻已复笑各各相谓。此非真宝是颇梨珠。善男子。声闻缘觉亦复如是。若闻速记则便懈怠轻笑薄贱。如彼愚人不识真宝。于未来世有诸比丘。不能翘勤修习善法。贫穷困苦饥饿所逼。因是出家长养其身。心志轻躁邪命谄曲。若闻如来授诸声闻速疾记者。便当大笑轻慢毁呰。当知是等即是破戒。自言已得过人之法。以是义故随发速愿故与速记。护正法者为授远记。迦叶菩萨复白佛言。世尊。菩萨摩诃萨云何当得不坏眷属。佛告迦叶。若诸菩萨勤加精进欲护正法。以是因缘所得眷属不可沮坏。迦叶菩萨复白佛言。世尊。何因缘故众生得此唇口干焦。佛告迦叶。若有不识三宝常存。以是因缘唇口干焦。如人口爽不知甜苦辛醋咸淡六味差别。一切众生愚痴无智不识三宝是常住法。是故名为唇口干焦。复次善男子。若有众生不知如来是常住者。当知是人则为生盲。若知如来是常住者。如是之人虽有肉眼我说是等名为天眼。复次善男子。若有能知如来是常。当知是人久已修习如是经典。我说是等亦名天眼。虽有天眼而不能知如来是常。我说斯等名为肉眼。是人乃至不识自身手脚支节。亦复不能令他识知。以是义故名为肉眼

复次善男子。如来常为一切众生而作父母。所以者何。一切众生种种形类二足四足多足无足。佛以一音而为说法。彼彼异类各自得解各各叹言。如来今日为我说法。以是义故名为父母

复次善男子。如人生子始十六月虽复语言未可解了。而彼父母欲教其语先同其音渐渐教之。是父母语可不正耶。不也世尊。善男子。诸佛如来亦复如是。随诸众生种种音声而为说法。为令安住于正法故。随所应见而为示现种种形像。如来如是同彼语言可不正耶。不也世尊。何以故。如来所说如师子吼。随顺世间种种音声而为众生叹说妙法

    大般涅槃经一切大众所问品第五

尔时世尊。从其面门放种种色青黄赤白红紫光明。照纯陀身纯陀遇已。与诸眷属持诸肴膳疾往佛所。欲奉如来及比丘僧最后供养。种种器物充满具足持至佛前。尔时有大威德天人。而遮其前周匝围绕谓纯陀言。且住纯陀勿便奉施。当尔之时如来复放无量无边种种光明。诸天大众遇斯光已。寻听纯陀前至佛所奉其所施。尔时天人及诸众生。各各自取所持供养至于佛前长跪白佛。唯愿如来。听诸比丘受此饮食。时诸比丘知是时故执持衣钵一心安详。尔时纯陀为佛及僧布置种种师子宝座。悬缯幡盖花香璎珞。尔时三千大千世界庄严微妙。犹如西方安乐国土。尔时纯陀住于佛前忧悲怅怏重白佛言。唯愿如来。犹见哀愍住寿一劫若减一劫。佛告纯陀。汝欲令我久住世者。宜当速奉最后具足檀波罗蜜。尔时一切菩萨摩诃萨。天人杂类异口同音唱如是言。奇哉纯陀。成大福德能令如来受取最后无上供养。而我等辈无福所致。所说供具则为唐捐。尔时世尊欲令一切众望满足。于自身上一一毛孔化无量佛。一一诸佛各有无量诸比丘僧。是诸世尊及无量众悉皆示现受其供养。释迦如来自受纯陀所奉设者。尔时纯陀所持粳粮成熟之食。摩伽陀国满足八斛。以佛神力皆悉充足一切大会。尔时纯陀见是事已心生欢喜踊跃无量。一切大众亦复如是。尔时大众承佛圣旨各作是念。如来今已受我等施不久便当入于涅槃。作是念已心生悲喜。尔时树林其地狭小。以佛神力如针锋处皆有无量诸佛。世尊及其眷属等。坐而食所食之物亦无差别。是时天人阿修罗等啼泣悲叹而作是言。如来今日已受我等最后供养。受供养已当般涅槃。我等当复更供养谁。我今永离无上调御盲无眼目。尔时世尊为欲慰喻一切大众。而说偈言

  汝等莫悲叹　　诸佛法应尔
  我入于涅槃　　已经无量劫
  常受最胜乐　　永处安隐处
  汝今至心听　　我当说涅槃
  我已离食想　　终无饥渴患
  我今当为汝　　说其随顺愿
  令诸一切众　　咸得安隐乐
  汝闻应修行　　诸佛法常住
  假使乌角鸱　　同共一树栖
  犹如亲兄弟　　尔乃永涅槃
  如来视一切　　犹如罗睺罗
  常为众生尊　　云何永涅槃
  假使蛇鼠狼　　同处一穴游
  相爱如兄弟　　尔乃永涅槃
  如来视一切　　犹如罗睺罗
  常为众生尊　　云何永涅槃
  假使七叶花　　转为婆师香
  迦留迦果树　　转为镇头果
  如来视一切　　犹如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使一阐提　　现身成佛道
  永处第一乐　　尔乃入涅槃
  如来视一切　　皆如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使一切众　　一时成佛道
  远离诸过患　　尔乃入涅槃
  如来视一切　　皆如罗睺罗
  云何舍慈悲　　永入于涅槃
  假使蚊子尿　　浸坏于大地
  诸山及百川　　大海悉盈满
  若有如是事　　尔乃入涅槃
  悲心视一切　　皆如罗睺罗
  常为众生尊　　云何永涅槃
  以是故汝等　　应深乐正法
  不应生忧恼　　号泣而啼哭
  若欲自正行　　应修如来常
  当观如是法　　长存不变易
  复应生是念　　三宝皆常住
  是则获大护　　如咒枯生果
  是名为三宝　　四众应善听
  闻已应欢喜　　即发菩提心
  若能计三宝　　常住同真谛
  此则是诸佛　　最上之誓愿

若有比丘比丘尼优婆塞优婆夷。能以如来最上誓愿而发愿者。当知是人无有愚痴堪受供养。以此愿力功德果报于世最胜如阿罗汉。若有不能如是观了三宝常者是旃陀罗。若有能知三宝常住实法因缘。离苦安乐无有娆害能留难者。尔时人天大众阿修罗等。闻是法已心生欢喜踊跃无量。其心调柔善灭诸盖心无高下。威德清净颜貌怡悦知佛常住。是故施设诸天供养。散种种花末香涂香。鼓天伎乐以供养佛。尔时佛告迦叶菩萨言。善男子汝见是众希有事不。迦叶答言。已见世尊。见诸如来无量无边不可称计。受诸大众人天所奉饭食供养。又见诸佛其身姝大。所坐之处如一针锋。多众围绕不相障碍。复见大众悉发誓愿说十三偈。亦知大众各心念言。如来今者独受我供。假使纯陀所奉饭食碎如微尘一尘一佛犹不周遍。以佛神力悉皆充足一切大众。唯诸菩萨摩诃萨。及文殊师利法王子等。能知如是希有事耳。悉是如来方便示现。声闻大众及阿修罗等。皆知如来是常住法。尔时世尊告纯陀言。汝今所见为是希有奇特事不。实尔世尊。我先所见无量诸佛三十二相八十种好庄严其身。今悉见为菩萨摩诃萨体貌傀异姝大殊妙。唯见佛身喻如药树为诸菩萨摩诃萨等之所围绕。佛告纯陀。汝先所见无量佛者是我所化。为欲利益一切众生令得欢喜。如是菩萨摩诃萨等所可修行不可思议。能作无量诸佛之事。纯陀。汝今皆已成就菩萨摩诃萨行得住十地。菩萨所行具足成办。迦叶菩萨白佛言。世尊。如是如是如佛所说。纯陀。所修成菩萨行我亦随喜。今者如来欲为未来无量众生作大明故。说是大乘大涅槃经。世尊。一切契经说有余义无余义耶。善男子。我所说者亦有余义亦无余义。纯陀白佛言。世尊。如佛所说

  所有之物　　布施一切　　唯可赞叹
  无可亏损

世尊是义云何。持戒毁戒有何差别。佛言。唯除一人。余一切施皆可赞叹。纯陀问言。云何名为唯除一人。佛言。如此经中所说破戒。纯陀复言。我今未解。唯愿说之。佛言。纯陀言。破戒者谓一阐提。其余在所一切布施皆可赞叹获大果报。纯陀复问。一阐提者其义云何。佛言。纯陀。若有比丘及比丘尼优婆塞优婆夷。发粗恶言诽谤正法。造是重业永不改悔心无惭愧。如是等人名为趣向一阐提道。若犯四重作五逆罪自知定犯。如是重事而心初无怖畏惭愧不肯发露。于佛正法永无护惜建立之心。毁呰轻贱言多过咎。如是等人亦名趣向一阐提道。若复说言无佛法僧。如是等人亦名趣向一阐提道。唯除如此一阐提辈。施其余者一切赞叹

尔时纯陀复白佛言。世尊。所言破戒其义云何。答言。纯陀。若犯四重及五逆罪诽谤正法。如是等人名为破戒。纯陀复问。如是破戒可拔济不。答言。纯陀。有因缘故则可拔济。若被法服犹未舍远。其心常怀惭愧恐怖而自考责。咄哉何为犯斯重罪。何期怪哉造斯苦业。其心改悔生护法心欲建正法。有护法者我当供养。若有读诵大乘典者我当咨问。受持读诵既通利已。复当为他分别广说。我说是人不为破戒。何以故。善男子。譬如日出能除一切尘翳闇冥。是大涅槃微妙经典出兴于世亦复如是。能除众生无量劫中所作众罪。是故此经说护正法得大果报拔济破戒。若有毁谤是正法者。能自改悔还归于法。自念所作一切不善。如人自害心生恐怖惊惧惭愧。除此正法更无救护。是故应当还归正法。若能如是如说归依布施是人得福无量。亦名世间应受供养。若犯如上恶业之罪。若经一月或十五日。不生归依发露之心。若施是人果报甚少。犯五逆者亦复如是。能生悔心内怀惭愧。今我所作不善之业甚为大苦。我当建立护持正法。是则不名五逆罪也。若施是人得福无量。犯逆罪已不生护法归依之心。有施是者福不足言。又善男子。犯重罪者。汝今谛听。我当为汝分别广说。应生是心。谓正法者。即是如来微密之藏。是故我当护持建立。施是人者得胜果报。善男子。譬如女人怀妊垂产值国荒乱逃至他土。在一天庙即便生产。闻其旧邦安隐丰熟。携将其子欲还本土。中路值河水涨暴急荷负是儿不能得渡。即自念言。我今宁与一处并命终。不舍弃而独渡也。念已母子俱共没命。命终之后寻生天中。以慈念子欲令得渡。而是女人本性弊恶。以爱子故得生天中。犯四重禁五无间罪。生护法心亦复如是。虽复先为不善之业。以护法故得为世间无上福田。是护法者有如是等无量果报

纯陀复言。世尊。若一阐提能自改悔。恭敬供养赞叹三宝。施如是人得大果报不佛言。善男子。汝今不应作如是说。善男子。譬如有人食庵罗果吐核置地。而复念言。是果核中应有甘味。即复还取破而尝之。其味极苦。心生悔恨。恐失果种即还收拾。种之于地勤加修治。以苏油乳随时溉灌。于意云何。宁可生不。不也世尊。假使天降无上甘雨犹亦不生。善男子。彼一阐提亦复如是。烧然善根。当于何处而得除罪。善男子。若生善心是则不名一阐提也。善男子。以是义故。一切所施所得果报非无差别。何以故。施诸声闻所得报异。施辟支佛得报亦异。唯施如来获无上果。是故说言一切所施非无差别

纯陀复言。何故如来而说此偈。佛言。纯陀。有因缘故我说此偈。王舍城中有优婆塞。心无净信奉事尼犍。而来问我布施之义。以是因缘故说斯偈。亦为菩萨摩诃萨等说秘蜜藏义。如斯偈者其义云何。一切者少分一切。当知菩萨摩诃萨人中之雄。摄取持戒施其所须。舍弃破戒如除稊稗

复次善男子。如我昔日所说偈言

  一切江河　　必有回曲　　一切丛林
  必名树木　　一切女人　　必怀谄曲
  一切自在　　必受安乐

尔时文殊师利菩萨摩诃萨。即从座起。偏袒右臂右膝着地。前礼佛足而说偈言

  非一切河　　必有回曲　　非一切林
  悉名树木　　非一切女　　必怀谄曲
  一切自在　　不必受乐

佛所说偈其义有余。唯垂哀愍说其因缘。何以故。世尊。于此三千大千世界有渚名拘耶尼。其渚有河端直不曲名娑婆耶。喻如绳墨直入西海。如是河相于余经中佛未曾说。唯愿如来。因此方等阿含经中说有余义。令诸菩萨深解是义。世尊。譬如有人先识金矿后不识金。如来亦尔。尽知法已而所演说有余不尽。如来虽作如是余说应当方便解其意趣。一切丛林必是树木。是亦有余。何以故。种种金银琉璃宝树。是亦名林。一切女人必怀谄曲。是亦有余。何以故。亦有女人善持禁戒。功德成就有大慈悲。一切自在必受乐者。是亦有余。何以故。有自在者转轮圣帝。如来法王不属死魔不可灭尽。梵释诸天虽得自在悉是无常。若得常住无变易者乃名自在。所谓大乘大般涅槃。佛言。善男子。汝今善得乐说之辩。且止谛听。文殊师利。譬如长者身婴病苦。良医诊之为合膏药。是时病者贪欲多服。医语之言。若能消者则可多服。汝今体羸不应多服。当知是膏亦名甘露亦名毒药。若多服不消则名为毒。善男子。汝今勿谓是医所说违失义理丧膏力势。善男子。如来亦尔。为诸国王后妃太子王子大臣。因波斯匿王王子后妃憍慢心故。为欲调伏示现恐怖如彼良医。故说偈言

  一切江河　　必有回曲　　一切丛林
  必名树木　　一切女人　　必怀谄曲
  一切自在　　必受安乐

文殊师利。汝今当知。如来所说无有漏失。如此大地可令反覆。如来之言终无漏失。以是义故如来所说一切有余。尔时佛赞文殊师利。善哉善哉。善男子。汝已久知如是之义。愍哀一切欲令众生得智慧故。广问如来如是偈义

尔时文殊师利法王之子。复于佛前而说偈言

  于他言语　　随顺不逆　　亦不观他
  作以不作　　但自观身　　善不善行

世尊。如是说此法药非为正说。于他语言随顺不逆者。唯愿如来垂哀正说。何以故。世尊。常说一切外学九十五种皆趣恶道。声闻弟子皆向正路。若护禁戒摄持威仪安慎诸根。如是等人深乐大法趣向善道。如来何故于九部中见有毁他则便呵责。如是偈义为何所趣。佛告文殊师利。善男子。我说此偈亦不尽为一切众生。尔时唯为阿阇世王。诸佛世尊。若无因缘终不逆说。有因缘故乃说之耳。善男子。阿阇世王害其父已来至我所。欲折伏我作如是问。云何世尊。有一切智非一切智耶。若一切智。调达往昔无量世中常怀恶心随逐如来欲为杀害。云何如来听其出家。善男子。以是因缘。我为是王。而说此偈

  于他语言　　随顺不逆　　亦不观他
  作以不作　　但自观身　　善不善行

佛告大王。汝今害父已作逆罪。最重无间应当发露以求清净。何缘乃更见他过咎。善男子。以是义故。我为彼王而说是偈。复次善男子。亦为护持不毁禁戒成就威仪。见他过者而说是偈。若复有人受他教诲远离众恶。复教他人令远众恶如是之人则我弟子

尔时世尊。为文殊师利。而说偈言

  一切畏刀杖　　无不爱寿命
  恕己可为喻　　勿杀勿行杖

尔时文殊师利。复于佛前而说偈言

  非一切畏杖　　非一切爱命
  恕己可为喻　　勤作善方便

如来。说是法句之义亦是未尽。何以故。如阿罗汉。转轮圣王玉女象马主藏大臣。若诸天人及阿修罗执持利剑能害之者。无有是处。勇士烈女马王兽王。持戒比丘虽复对至而不恐怖。以是义故。如来说偈亦是有余。若言恕己可为喻者是亦有余。何以故。若使罗汉以己喻彼。则有我想及以命想。若有我想及以命想则应拥护。凡夫亦应见阿罗汉悉是行人。若如是者即是邪见。若有邪见命终之时即应生于阿鼻地狱。又复罗汉设于众生生害心者。无有是处。无量众生亦复无能害罗汉者。佛言。善男子。言我想者。谓于众生生大悲心无杀害想。谓阿罗汉平等之心。勿谓世尊无有因缘而逆说也。昔日于此王舍城中有大猎师。多杀群鹿请我食肉。我于是时虽受彼请。于诸众生生慈悲心。如罗睺罗。而说偈言

  当令汝长寿　　久久住于世
  受持不害法　　犹如诸佛寿

是故我说是偈

  一切畏刀杖　　无不爱寿命
  恕己可为喻　　勿杀勿行杖

佛言。善哉善哉。文殊师利。为诸菩萨摩诃萨故。咨问如来如是密教。尔时文殊师利。复说是偈

  云何敬父母　　随顺而尊重
  云何修此法　　堕于无间狱

于是如来。复以偈答文殊师利

  若以贪爱母　　无明以为父
  随顺尊重是　　则堕无间狱

尔时如来。复为文殊师利菩萨。重说偈言

  一切属他　　则名为苦　　一切由己
  自在安乐　　一切憍慢　　势极暴恶
  贤善之人　　一切爱念

尔时文殊师利菩萨摩诃萨白佛言。世尊。如来所说是亦不尽。唯愿如来复垂哀愍说其因缘。何以故。如长者子从师学时为属师不。若属师者义不成就。若不属者亦不成就。若得自在亦不成就。是故如来所说有余。复次世尊。譬如王子无所综习触事不成。是亦自在愚闇常苦。如是王子若言自在义亦不成。若言属他义亦不成。以是义故。佛所说义名为有余。是故一切属他不必受苦。一切自在不必受乐。一切憍慢势极暴恶是亦有余。世尊。如诸烈女憍慢心故出家学道。护持禁戒威仪成就。守摄诸根不令驰散。是故一切憍慢之结不必暴恶。贤善之人一切爱念是亦有余。如人内犯四重禁已。不舍法服坚持威仪。护持法者见已不爱。是人命终必堕地狱。若有贤人犯重禁已。护法见之即驱令出罢道还俗。以是义故。一切贤善何必悉爱

尔时佛告文殊师利。有因缘故如来于此说有余义。又有因缘诸佛如来而说是法。时王舍城有一女人。名曰善贤。还父母家因至我所。归依于我及法众僧。而作是言。一切女人势不自由。一切男子自在无碍。我于尔时知是女心。即为宣说如是偈颂。文殊师利。善哉善哉。汝今能为一切众生。问于如来如是密语。文殊师利复说偈言

  一切诸众生　　皆依饮食存
  一切有大力　　其心无嫉妒
  一切因饮食　　而多得病苦
  一切修净行　　而得受安乐

如是世尊。今受纯陀饮食供养。将无如来有恐怖耶。尔时世尊。复为文殊。而说偈言

  非一切众生　　尽依饮食存
  非一切大力　　心皆无嫉妒
  非一切因食　　而致病苦患
  非一切净行　　悉得受安乐

文殊师利。汝若得病我亦如是应得病苦。何以故。诸阿罗汉及辟支佛菩萨如来实无所食。但欲化彼示现受用无量众生所施之物。令其具足檀波罗蜜。拔济地狱畜生饿鬼。若言如来六年苦行身羸瘦者。无有是处。诸佛世尊独拔诸有不同凡夫。云何而得身羸劣耶。诸佛世尊精勤修习获金刚身。不同世人危脆之身。我诸弟子亦复如是。不可思议不依于食。一切大力无嫉妒者亦有余义。如世间人终身永无嫉妒之心而亦无力。一切病苦因食得者亦有余义。亦见有人得客病者。所谓。刺刺刀剑鉾槊。一切净行受安乐者是亦有余。世间亦有外道之人。修于梵行多受苦恼。以是义故。如来所说一切有余。是名如来非无因缘而说此偈。有因故说。昔日于此优禅尼国。有婆罗门名羖羝德。来至我所欲受第四八戒斋法。我于尔时为说是偈

尔时迦叶菩萨白佛言。世尊。何等名为无余义耶。云何复名一切义乎。善男子。一切者唯除助道常乐善法是名一切亦名无余。其余诸法亦名有余亦名无余。欲令乐法诸善男子知此有余及无余义。迦叶菩萨心大欢喜踊跃无量。前白佛言。甚奇世尊。等视众生如罗睺罗。尔时佛赞迦叶菩萨。善哉善哉。汝今所见微妙甚深

迦叶菩萨白佛言。世尊。唯愿如来说是大乘大涅槃经所得功德。佛告迦叶。善男子。若有得闻是经名字所得功德。非诸声闻辟支佛等所能宣说。唯佛能知。何以故。不可思议是佛境界。何况受持读诵通利书写经卷

尔时诸天世人及阿修罗。即于佛前异口同音。而说偈言

  诸佛难思议　　法僧亦复然
  是故今劝请　　唯愿小停住
  尊者大迦叶　　及以阿难等
  二众之眷属　　且待须臾至
  并及摩伽主　　阿阇世大王
  至心敬信佛　　犹故未来此
  唯愿于如来　　小垂哀愍住
  于此大众中　　断我诸疑网

尔时如来为诸大众。而说偈言

  我法最长子　　是名大迦叶
  阿难勤精进　　能断一切疑
  汝等当谛观　　阿难多闻士
  自然当解了　　是常及无常
  以是故不应　　心怀于忧恼

尔时大众以种种物供养如来。供养佛已即发阿耨多罗三藐三菩提心。无量无边恒河沙等诸菩萨辈得住初地。尔时世尊。与文殊师利迦叶菩萨及以纯陀。而受记莂。受记莂已说如是言。诸善男子。自修其心慎莫放逸。我今背疾举体皆痛。我今欲卧。如彼小儿及常患者。汝等文殊。当为四部广说大法。今以此法付嘱于汝。乃至迦叶阿难等来。复当付嘱如是正法。尔时如来说是语已。为欲调伏诸众生故现身有疾。右胁而卧如彼病人

大般涅槃经卷第十大般涅槃经卷第十一

        北凉天竺三藏昙无谶译

    现病品第六

尔时迦叶菩萨白佛言。世尊。如来已免一切疾病。患苦悉除无复怖畏。世尊。一切众生有四毒箭则为病因。何等为四。贪欲嗔恚愚痴憍慢。若有病因则有病生。所谓爱热肺病上气吐逆。肤体[病-丙+習][病-丙+習]其心闷乱。下痢哕噎小便淋沥。眼耳疼痛背满腹胀。颠狂干干消鬼魅所著。如是种种身心诸病。诸佛世尊悉无复有。今日如来何缘顾命文殊师利而作是言。我今背痛。汝等当为大众说法。有二因缘则无病苦。何等为二。一者怜愍一切众生。二者给施病者医药。如来往昔已于无量万亿劫中修菩萨道。常行爱语利益众生不令苦恼。施疾病者种种医药。何缘于今自言有病。世尊。世有病人或坐或卧不安处所。或索饮食敕诫家属修治产业。何故如来默然而卧。不教弟子声闻人等。尸波罗蜜诸禅解脱三摩跋提修诸正勤。何缘不说如是甚深大乘经典。如来何故不以无量方便教大迦叶人中象王诸大人等。令不退于阿耨多罗三藐三菩提。何故不治诸恶比丘受畜一切不净物者。世尊。实无有病。云何默然右胁而卧。诸菩萨等凡所给施病者医药所得善根。悉施众生而共回向一切种智。为除众生诸烦恼障业障报障。烦恼障者。贪欲嗔恚愚痴。忿怒缠盖焦恼嫉妒悭吝奸诈谀谄无惭无愧。慢慢慢不如慢增上慢我慢邪慢憍慢。放逸贡高怼恨诤讼邪命谄媚。诈现异相以利求利恶求多求。无有恭敬不随教诲。亲近恶友贪利无厌缠缚难解。欲于恶欲贪。于恶贪。身见有见及以无见。频申喜睡欠呿不乐。贪嗜饮食其心[夢-夕+登]瞢。心缘异想不善思惟。身口多恶好喜多语。诸根闇钝发言多虚。常为欲觉恚觉害觉之所覆盖。是名烦恼障。业障者。五无间罪重恶之病。报障者。生在地狱畜生饿鬼。诽谤正法及一阐提。是名报障。如是三障名为大病。而诸菩萨于无量劫修菩提时。给施一切疾病医药常作是愿。令诸众生永断如是三障重病。复次世尊。菩萨摩诃萨修菩提时。给施一切病者医药常作是愿。愿令众生永断诸病得成如来金刚之身。又愿一切无量众生作妙药王。断除一切诸恶重病。愿诸众生得阿伽陀药。以是药力能除一切无量恶毒。又愿众生于阿耨多罗三藐三菩提无有退转。速得成就无上佛药。消除一切烦恼毒箭。又愿众生勤修精进成就如来金刚之心。作微妙药疗治众病。不令有人生诤讼想。亦愿众生作大药树疗治一切诸恶重病。又愿众生拔出毒箭得成如来无上光明。又愿众生得入如来智慧大药微密法藏。世尊。菩萨如是已于无量百千万亿那由他劫。发是誓愿令诸众生悉无复病。何缘如来乃于今日唱言有病。复次世尊。世有病人不能坐起俯仰进止。饮食不御浆水不下。亦复不能教戒诸子修治家业。尔时父母妻子兄弟亲属知识。各于是人生必死想。世尊。如来今日亦复如是。右胁而卧无所论说。此阎浮提有诸愚人当作是念。如来正觉必当涅槃生灭尽想。而如来性实不毕竟入于涅槃。何以故。如来常住无变易故。以是因缘不应说言我今背痛

复次世尊。世有病者身体羸损若偃若侧卧着床褥。尔时家室心生恶贱起必死想。如来今者亦复如是。当为外道九十五种之所轻慢生无常想。彼诸外道当作是言。不如我等以我性常自在时节微尘等法而为常住无有变易。沙门瞿昙无常所迁。是变易法。以是义故。世尊。今日不应默然右胁而卧。复次世尊。世有病者四大增损互不调适羸瘦乏极。是故不能随意坐起卧着床褥。如来四大无不和适。身力具足亦无羸损。世尊。如十小牛力不如一大牛力。十大牛力不如一青牛力。十青牛力不如一凡象力。十凡象力不如一野象力。十野象力不如一二牙象力。十二牙象力不如一四牙象力。十四牙象力不如雪山一白象力。十雪山白象力不如一香象力。十香象力不如一青象力。十青象力不如一黄象力。十黄象力不如一赤象力。十赤象力不如一白象力。十白象力不如一山象力。十山象力不如一优钵罗象力。十优钵罗象力不如一拘物头象力。十拘物头象力不如一分陀利象力。十分陀利象力不如人中一力士力。十人中力士力不如一钵健提力。十钵健提力不如一八臂那罗延力。十那罗延力不如一十住菩萨一节之力。一切凡夫身中诸节节不相到。人中力士节头相到。钵健提身诸节相接。那罗延身节头相拘。十住菩萨诸节骨解盘龙相结。是故菩萨其力最大。世界成时从金刚际起金刚座。上至道场菩提树下。菩萨坐已其心即时逮得十力。如来今者不应如彼婴孩小儿。婴孩小儿愚痴无智无所能说。以是义故。随意偃侧无人讥诃。如来世尊有大智慧照明一切。人中之龙具大威德。成就神通无上仙人。永断疑网已拔毒箭。进止安详威仪具足得无所畏。今者何故右胁而卧。令诸人天悲愁苦恼。尔时迦叶菩萨。即于佛前而说偈言

  瞿昙大圣德　　愿起演妙法
  不应如小儿　　病者卧床席
  调御天人师　　倚卧双树间
  下愚凡夫见　　当言必涅槃
  不知方等典　　甚深佛所行
  不见微密藏　　犹盲不见道
  惟有诸菩萨　　文殊师利等
  能解是甚深　　譬如善射者
  三世诸世尊　　大悲为根本
  如是大慈悲　　今为何所在
  若无大悲者　　是则不名佛
  佛若必涅槃　　是则不名常
  惟愿无上尊　　哀受我等请
  利益于众生　　摧伏诸外道

尔时世尊。大悲熏心知诸众生各各所念。将欲随顺毕竟利益。即从卧起结跏趺坐。颜貌熙怡如融金聚。面目端严犹月盛满。形容清净无诸垢秽。放大光明充遍虚空。其光大盛过百千日。照于东方南西北方四维上下诸佛世界。惠施众生大智之炬。悉令得灭无明黑闇。令百千亿那由他众生安止不退菩提之心。尔时世尊。心无疑虑如师子王。以三十二大人之相八十种好庄严其身。于其身上一切毛孔。一一毛孔出一莲花。其花微妙各具千叶。纯真金色。琉璃为茎。金刚为须。玫瑰为台。形大团圆犹如车轮。是诸莲花各出种种杂色光明。青黄赤白紫颇梨色。是诸光明皆悉遍至阿鼻地狱想地狱黑绳地狱众合地狱叫唤地狱大叫唤地狱焦热地狱大焦热地狱。是八地狱其中众生常为诸苦之所逼切。所谓烧煮火炙斫刺[利-禾+皮]剥。遇斯光已如是众苦悉灭无余。安隐清凉快乐无极。是光明中宣说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中。乃至八种寒冰地狱。所谓阿波波地狱阿吒吒地狱阿罗罗地狱阿婆婆地狱优钵罗地狱波头摩地狱拘物头地狱分陀利地狱。是中众生常为寒苦之所逼恼。所谓擘裂身体碎坏互相残害。遇斯光已如是等苦亦灭无余。即得调和熅暖适身。是光明中亦说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中。尔时于此阎浮提界及余世界。所有地狱皆悉空虚无受罪者。除一阐提。饿鬼众生饥渴所逼以发缠身。于百千岁未曾得闻浆水之名。遇斯光已饥渴即除。是光明中亦说如来微密秘藏。言诸众生皆有佛性。众生闻已即便命终生人天中。令诸饿鬼亦悉空虚。除谤大乘方等正典。畜生众生互相杀害共相残食。遇斯光已恚心悉灭。是光明中亦说如来秘密之藏。言诸众生皆有佛性。众生闻已即便命终生人天中。当尔之时畜生亦尽除谤正法。是一一花各有一佛。圆光一寻金色晃曜。微妙端严最上无比。三十二相八十种好庄严其身。是诸世尊。或有坐者。或有行者。或有卧者。或有住者。或有震雷音者。或澍雨者。或放电光。或复兴风。或出烟焰身如火聚。或复示现七宝诸山。池泉河水山林树木。或复示现七宝国土城邑聚落宫殿屋宅。或复示现象马师子虎狼孔雀凤凰诸鸟。或复示现令阎浮提所有众生悉见地狱畜生饿鬼。或复示现欲界六天。复有世尊。或说阴界诸入多诸过患。或复有说四圣谛法。或复有说诸法因缘。或复有说诸业烦恼皆因缘生。或复有说我与无我。或复有说苦乐二法。或复有说常无常等。或复有说净与不净。复有世尊为诸菩萨演说所行六波罗蜜。或复有说诸大菩萨所得功德。或复有说诸佛世尊所得功德。或复有说声闻之人所得功德。或复有说随顺一乘。或复有说三乘成道。或有世尊左胁出水右胁出火。或有示现初生出家坐于道场菩提树下转妙法轮入于涅槃。或有世尊作师子吼。令此会中有得一果二果三果至第四果。或复有说出离生死无量因缘。尔时于此阎浮提中。所有众生遇斯光已。盲者见色。聋者听声。哑者能言。拘躄能行。贫者得财。悭者能施。恚者慈心。不信者信。如是世界无一众生修行恶法。除一阐提

尔时一切天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽罗刹健陀忧摩陀阿婆魔罗人非人等。悉共同声唱如是言。善哉善哉。无上天尊。多所利益。说是语已踊跃欢喜。或歌或舞。或身动转。以种种花散佛及僧。所谓天优钵罗花。拘物头花。波头摩花。分陀利花。曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。散陀那花摩诃散陀那花。卢脂那花摩诃卢脂那花。香花大香花。适意花大适意花。爱见花大爱见花。端严花第一端严花。复散诸香。所谓沉水多伽楼香栴檀郁金和合杂香海岸聚香。复以天上宝幢幡盖。诸天伎乐筝笛笙瑟。箜篌鼓吹。供养于佛。而说偈言

  我今稽首大精进　　无上正觉两足尊
  天人大众所不知　　惟有瞿昙乃能了
  世尊往昔为我故　　于无量劫修苦行
  如何一旦放本誓　　而便舍命欲涅槃
  一切众生不能见　　诸佛世尊秘密藏
  以是因缘难得出　　轮转生死坠恶道
  如佛所说阿罗汉　　一切皆当至涅槃
  如是甚深佛行处　　凡夫下愚谁能知
  施诸众生甘露法　　为欲断除诸烦恼
  若有服此甘露已　　不复受生老病死
  如来世尊以疗治　　百千无量诸众生
  令其所有诸重病　　一切消灭无遗余
  世尊久已舍病苦　　故得名为第七佛
  惟愿今日雨法雨　　润渍我等功德种
  是故大众及人天　　如是请已默然住

说是偈时。莲花台中一切诸佛。从阎浮提遍至净居悉皆闻之。尔时佛告迦叶菩萨。善哉善哉。善男子。汝已具足如是甚深微妙智慧。不为一切诸魔外道之所破坏。善男子。汝已安住不为一切诸邪恶风之所倾动。善男子。汝已成就乐说辩才。已曾供养过去无量恒河沙等诸佛世尊。是故能问如来正觉如是之义。善男子。我于往昔无量无边亿那由他百千万劫。已除病根永离倚卧。迦叶。过去无量阿僧祇劫有佛出世。号无上胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸声闻说是大乘大涅槃经。开示分别显发其义。我于尔时亦为彼佛而作声闻。受持如是大涅槃典。读诵通利书写经卷。广为他人开示分别解说其义。以是善根回向阿耨多罗三藐三菩提。善男子。我从是来未曾有恶烦恼业缘堕于恶道。诽谤正法作一阐提。受黄门身无根二根。反逆父母杀阿罗汉破塔坏僧出佛身血犯四重禁。从是已来身心安隐无诸苦恼。迦叶。我今实无一切疾病。所以者何。诸佛世尊久已远离一切病故。迦叶。是诸众生不知大乘方等密教。便谓如来真实有疾迦叶。如言如来人中师子。而如来者实非师子。如是之言即是如来秘密之教。迦叶。如言如来人中大龙。而我已于无量劫中舍离是业。迦叶。如言如来是人是天。而我真实非人非天。亦非鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。非我非命非可养育非人士夫。非作非不作。非受非不受。非世尊非声闻。非说非不说。如是等语。皆是如来秘密之教

迦叶。如言如来犹如大海须弥山王。而如来者实非碱味同于石山。当知是语亦是如来秘密之教。迦叶。如言如来如分陀利。而我实非分陀利也。如是之言即是如来秘密之教。迦叶。如言如来犹如父母。而如来者实非父母。如是之言亦是如来秘密之教。迦叶。如言如来是大船师。而如来者实非船师。如是之言亦是如来秘密之教。迦叶。如言如来犹如商主。而如来者实非商主。如是之言亦是如来秘密之教。迦叶。如言如来能摧伏魔。而如来者实无恶心欲令他伏。如是之言皆是如来秘密之教。迦叶。如言如来能治痈疮。而我实非治痈师也。如是之言亦是如来秘密之教。迦叶。如我先说。若有善男子善女人。善能修治身口意业。舍命之时虽有亲族取其尸骸。或以火烧。或投大水。或弃冢间。狐狼禽兽竞共食啖。然心意识即生善道。而是心法实无去来亦无所至。真是前后相似相续相貌不异。如是之言即是如来秘密之教。迦叶。我今言病亦复如是。亦是如来秘密之教。是故顾命文殊师利。吾今背痛。汝等当为四众说法。迦叶。如来正觉实无有病右胁而卧。亦不毕竟入于涅槃。迦叶。是大涅槃即是诸佛甚深禅定。如是禅定非是声闻缘觉行处。迦叶。汝先所问如来何故倚卧不起不索饮食。戒敕家属修治产业。迦叶。虚空之性亦无坐起求索饮食。敕戒家属修治产业。亦无去来生灭老壮出没伤破解脱系缚。亦不自说亦不说他。亦不自解亦不解他。非安非病。善男子。诸佛世尊亦复如是。犹如虚空。云何当有诸病苦耶

迦叶。世有三人其病难治。一谤大乘。二五逆罪。三一阐提。如是三病世中极重。悉非声闻缘觉菩萨之所能治。善男子。譬如有病必死难治。若有瞻病随意医药。若无瞻病随意医药。如是之病定不可治。当知是人必死不疑。善男子。是三种人亦复如是。若有声闻缘觉菩萨。或有说法或不说法。不能令其发阿耨多罗三藐三菩提心。迦叶。譬如病人若有瞻病随意医药则可令差。若无此三则不可差。声闻缘觉亦复如是。从佛菩萨得闻法已。即能发于阿耨多罗三藐三菩提心。非不闻法能发心也。迦叶。譬如病人若有瞻病随意医药。若无瞻病随意医药皆悉可差。有一种人亦复如是。或值声闻不值声闻。或值缘觉不值缘觉。或值菩萨不值菩萨。或值如来不值如来。或得闻法或不闻法。自然得成阿耨多罗三藐三菩提。所谓有人。或为自身。或为他身。或为怖畏。或为利养。或为谀谄。或为诳他。书写如是大涅槃经。受持读诵供养恭敬为他说者

迦叶。有五种人于是大乘大涅槃典。有病行处非如来也。何等为五。一断三结得须陀洹果。不堕地狱畜生饿鬼。人天七返永断诸苦入于涅槃。迦叶。是名第一人有病行处。是人未来过八万劫。便当得成阿耨多罗三藐三菩提。迦叶。第二人者。断三结缚薄贪恚痴。得斯陀含果名一往来。永断诸苦入于涅槃。迦叶。是名第二人有病行处。是人未来过六万劫。便当得成阿耨多罗三藐三菩提。迦叶。第三人者。断五下结得阿那含果。更不来此。永断诸苦入于涅槃。是名第三人有病行处。是人未来过四万劫。便当得成阿耨多罗三藐三菩提。迦叶。第四人者。永断贪欲嗔恚愚痴得阿罗汉果。烦恼无余入于涅槃。亦非骐驎独一之行。是名第四人有病行处。是人未来过二万劫。便当得成阿耨多罗三藐三菩提。迦叶。第五人者。永断贪欲嗔恚愚痴得辟支佛道。烦恼无余入于涅槃。真是骐驎独一之行。是名第五人有病行处。是人未来过十千劫。便当得成阿耨多罗三藐三菩提。迦叶。是名第五人有病行处。非如来也

    大般涅槃经圣行品第七之一

尔时佛告迦叶菩萨。善男子。菩萨摩诃萨应当于是大般涅槃经。专心思惟五种之行。何等为五。一者圣行。二者梵行。三者天行。四者婴儿行。五者病行。善男子。菩萨摩诃萨常当修习是五种行。复有一行是如来行。所谓大乘大涅槃经。迦叶。云何菩萨摩诃萨所修圣行。菩萨摩诃萨若从声闻若从如来。得闻如是大涅槃经。闻已生信。信已应作如是思惟。诸佛世尊有无上道。有大正法大众正行。复有方等大乘经典。我今当为爱乐贪求大乘经故。舍离所爱妻子眷属所居舍宅。金银珍宝微妙璎珞香花伎乐。奴婢仆使男女大小。象马车乘牛羊鸡犬猪豕之属。复作是念。居家迫迮犹如牢狱。一切烦恼由之而生。出家宽旷犹如虚空。一切善法因之增长。若在家居不得尽寿净修梵行。我今应当剃除须发出家学道。作是念已。我今定当出家修学无上正真菩提之道。菩萨如是欲出家时。天魔波旬生大苦恼。言是菩萨复当与我兴大战诤。善男子。如是菩萨何处当复与人战诤。是时菩萨即至僧坊。若见如来及佛弟子。威仪具足诸根寂静。其心柔和清净寂灭。即至其所而求出家。剃除须发服三法衣。既出家已奉持禁戒威仪不缺进止安详。无所触犯。乃至小罪心生怖畏。护戒之心犹如金刚。善男子。譬如有人带持浮囊欲渡大海。尔时海中有一罗刹。即从其人乞索浮囊。其人闻已即作是念。我今若与必定没死。答言。罗刹。汝宁杀我浮囊叵得。罗刹复言。汝若不能全与我者。见惠其半。是人犹故不肯与之。罗刹复言。汝若不肯惠我半者。幸愿与我三分之一。是人不肯。罗刹复言。若不能者当施手许。是人不肯。罗刹复言。汝今若复不能与我如手许者。我今饥穷众苦所逼。愿当济我如微尘许。是人复言。汝今所索诚复不多。然我今日方当渡海。不知前途近远如何。若与汝者气当渐出。大海之难何由得过。脱能中路没水而死。善男子。菩萨摩诃萨护持禁戒亦复如是。如彼渡人护惜浮囊。菩萨如是护戒之时。常有烦恼诸恶罗刹语菩萨言。汝当信我终不相欺。但破四禁护持余戒。以是因缘令汝安隐得入涅槃。菩萨尔时应作是言。我今宁持如是禁戒堕阿鼻狱。终不毁犯而生天上。烦恼罗刹复作是言。卿若不能破四禁者可破僧残。以是因缘令汝安隐得入涅槃。菩萨亦应不随其语。罗刹复言。卿若不能犯僧残者。亦可故犯偷兰遮罪。以是因缘令汝安隐得入涅槃。菩萨尔时亦复不随。罗刹复言。卿若不能犯偷兰遮者可犯舍堕。以是因缘可得安隐入于涅槃。菩萨尔时亦不随之。罗刹复言。卿若不能犯舍堕者可破波夜提。以是因缘令汝安隐得入涅槃。菩萨尔时亦不随之。罗刹复言。卿若不能犯波夜提者。幸可毁破突吉罗戒。以是因缘可得安隐入于涅槃。菩萨尔时心自念言。我今若犯突吉罗罪不发露者。则不能渡生死彼岸而得涅槃。菩萨摩诃萨于是微小诸戒律中。护持坚固心如金刚。菩萨摩诃萨持四重禁及突吉罗。敬重坚固等无差别。菩萨若能如是坚持则为具足五根诸戒。所谓具足菩萨根本业清净戒。前后眷属余清净戒。非诸恶觉。觉清净戒。护持正念念清净戒。回向阿耨多罗三藐三菩提戒

迦叶。是菩萨摩诃萨复有二种戒。一者受世教戒。二者得正法戒。菩萨若受正法戒者终不为恶。受世教戒者白四羯磨然后乃得。复次善男子。有二种戒。一者性重戒。二者息世讥嫌戒。性重戒者。谓四禁也。息世讥嫌戒者。不作贩卖轻秤小斗欺诳于人。因他形势取人财物。害心系缚破坏成功。然明而卧。田宅种植家业坐肆。不畜象马车乘牛羊驼驴鸡犬猕猴孔雀鹦鹉共命及拘枳罗。豺狼虎豹猫狸猪豕及余恶兽。童男童女大男大女奴婢僮仆。金银琉璃颇梨真珠车磲马瑙珊瑚璧玉珂贝诸宝。赤铜白腊鋀石盂器[毯-炎+瞿]毹毾[毯-炎+登]拘执眊衣。一切谷米大小麦豆穈粟稻麻生熟食具。常受一食不曾再食。若行乞食及僧中食。常知止足不受别请。不食肉不饮酒。五辛能熏悉不食之。是故其身无有臭处。常为诸天一切世人恭敬供养尊重赞叹。趣足而食终不长受。所受衣服才足覆身。进止常与三衣钵具。终不舍离如鸟二翼。不畜根子茎子节子椄子子子。不畜宝藏若金若银饮食厨库衣裳服饰。高广大床象牙金床杂色编织悉不用坐。不畜一切细软诸席。不坐象荐马荐。不以细软上妙衣服用敷床卧。其床两头不置二枕。亦不受畜妙好丹枕安黄木枕。终不观看象斗马斗车斗兵斗男斗女斗牛斗羊斗水牛鸡雉鹦鹉等斗。亦不故往观看军阵。不应故听吹贝鼓角琴瑟筝笛箜篌歌叫伎乐之声。除供养佛。摴蒱围棋波罗塞戏师子象斗。弹棋六博拍鞠掷石投壶牵道八道行成。一切戏笑悉不观作。终不瞻相手脚面目。不以抓镜芝草杨枝钵盂髑髅而作卜筮。亦不仰观虚空星宿。除欲解睡。不作王家往返使命以此语彼以彼语此。终不谀谄邪命自活。亦不宣说王臣盗贼斗诤饮食国土饥馑恐怖丰乐安隐之事。善男子。是名菩萨摩诃萨息世讥嫌戒。善男子。菩萨摩诃萨坚持如是遮制之戒。与性重戒等无差别

善男子。菩萨摩诃萨受持如是诸禁戒已。作是愿言。宁以此身投于炽然猛火深坑。终不毁犯过去未来现在诸佛所制禁戒。与刹利女婆罗门女居士女而行不净。复次善男子。菩萨摩诃萨复作是愿。宁以热铁周匝缠身。终不敢以破戒之身受于信心檀越衣服。复次善男子。菩萨摩诃萨复作是愿。宁以此口吞热铁丸。终不敢以毁戒之口食于信心檀越饮食。复次善男子。菩萨摩诃萨复作是愿。宁卧此身大热铁上。终不敢以破戒之身受于信心檀越床敷卧具。复次善男子。菩萨摩诃萨复作是愿。我宁以身受三百鉾。终不敢以毁戒之身受于信心檀越医药。复次善男子。菩萨摩诃萨复作是愿。宁以此身投热铁镬。不以破戒受于信心檀越房舍屋宅。复次善男子。菩萨摩诃萨复作是愿。宁以铁捶打碎此身从头至足令如微尘。不以破戒受诸刹利婆罗门居士恭敬礼拜。复次善男子。菩萨摩诃萨复作是愿。宁以热铁挑其两目。不以染心视他好色。复次善男子。菩萨摩诃萨复作是愿。宁以铁锥遍身搀刺。不以染心听好音声。复次善男子。菩萨摩诃萨复作是愿。宁以利刀割去其鼻。不以染心贪嗅诸香。复次善男子。菩萨摩诃萨复作是愿。宁以利刀割裂其舌。不以染心贪着美味。复次善男子。菩萨摩诃萨复作是愿。宁以利斧斩斫其身。不以染心贪着诸触。何以故。以是因缘能令行者堕于地狱畜生饿鬼。迦叶。是名菩萨摩诃萨护持禁戒。菩萨摩诃萨护持如是诸禁戒已。悉以施于一切众生。以是因缘愿令众生护持禁戒。得清净戒善戒不缺戒不析戒大乘戒不退戒随顺戒毕竟戒。具足成就波罗蜜戒。善男子。菩萨摩诃萨修持如是清净戒时。即得住于初不动地。云何名为不动地耶。菩萨住是不动地中。不动不堕不退不散。善男子。譬如须弥山旋蓝猛风不能令动堕落退散。菩萨摩诃萨住是地中亦复如是。不为色声香味所动。不堕地狱畜生饿鬼。不退声闻辟支佛地。不为异见邪风所散而作邪命。复次善男子。又复动者不为贪欲恚痴所动。又复堕者不堕四重。又复退者不退戒还家。又复散者不为违逆大乘经者之所散坏。复次善男子。菩萨摩诃萨亦复不为诸烦恼魔之所倾动。不为阴魔所堕。乃至坐于道场菩提树下。虽有天魔不能令其退于阿耨多罗三藐三菩提。亦复不为死魔所散。善男子。是名菩萨摩诃萨修习圣行。善男子。云何名为圣行。圣行者佛及菩萨之所行处故。故名圣行。以何等故。名佛菩萨为圣人耶。如是等人有圣法故。常观诸法性空寂故。以是义故故名圣人。有圣戒故复名圣人。有圣定慧故故名圣人。有七圣财。所谓信戒惭愧多开智慧舍离。故名圣人。有七圣觉故故名圣人。以是义故复名圣行

大般涅槃经卷第十一大般涅槃经卷第十二

        北凉天竺三藏昙无谶译

    圣行品第七之二

复次善男子。菩萨摩诃萨圣行者。观察是身从头至足。其中唯有发毛爪齿不净垢秽。皮肉筋骨脾肾心肺肝胆肠胃生熟二藏大小便利涕唾目泪。肪膏脑膜骨髓脓血脑胲诸脉。菩萨如是专念观时。谁有是我。我为属谁。住在何处。谁属于我。复作是念。骨是我耶。离骨是耶。菩萨尔时除去皮肉唯观白骨。复作是念。骨色相异。所谓青黄赤白及以鸽色。如是骨相亦复非我。何以故。我者亦非青黄赤白及以鸽色。菩萨系心作是观时即得断除一切色欲。复作是念。如是骨者从因缘生。依因足骨以拄踝骨。依因踝骨以拄膊骨。依因膊骨以拄膝骨。依因膝骨以拄髀骨。依因髀骨以拄臗骨。依因臗骨以拄腰骨。依因腰骨以拄脊骨。依因脊骨以拄肋骨。复因脊骨上拄项骨。依因项骨以拄颔骨。依因颔骨以拄牙齿。上有髑髅。复因项骨以拄膊骨。依因膊骨以拄臂骨。依因臂骨以拄腕骨。依因腕骨以拄掌骨。依因掌骨以拄指骨。菩萨摩诃萨如是观时身所有骨一切分离。得是观已即断三欲。一形貌欲。二姿态欲。三细触欲。菩萨摩诃萨观青骨时。见此大地东西南北四维上下悉皆青相。如青色观黄白鸽色亦复如是。菩萨摩诃萨作是观时。眉间即出青黄赤白鸽等色光。是菩萨于是一一诸光明中见有佛像。见已即问。如此身者不净因缘和合共成。云何而得坐起行住屈伸俯仰。视瞬喘息悲泣喜笑。此中无主。谁使之然。作是问已。光中诸佛忽然不现。复作是念或识是我。故使诸佛不为我说。复观此识次第生灭犹如流水亦复非我。复作是念。若识非我出息入息或能是我。复作是念。是出入息直是风性。而是风性乃是四大。四大之中何者是我。地性非我水火风性亦复非我。复作是念。此身一切悉无有我。唯有心风因缘和合示现种种所作事业。譬如咒力幻术所作。亦如箜篌随意出声。是故此身如是不净假众因缘和合共成。而于何处生此贪欲。若被骂辱复于何处而生嗔恚。而我此身三十六物不净臭秽。何处当有受骂辱者。若闻其骂即便思惟。以何音声而见骂耶。一一音声不能见骂。若一不能多亦不能。以是义故不应生嗔。若他来打亦应思惟。如是打者从何而生。复作是念。因手刀杖及以我身故得名打。我今何缘横嗔于他。乃是我身自招此咎。以我受是五阴身故。譬如因的则有箭中。我身亦尔有身有打。我若不忍心则散乱。心若散乱则失正念。若失正念则不能观善不善义。若不能观善不善义则行恶法。恶法因缘则堕地狱畜生饿鬼。菩萨尔时作是观已得四念处。得四念处已则得住于堪忍地中。菩萨摩诃萨住是地已。则能堪忍贪欲恚痴。亦能堪忍寒热饥渴蚊虻蚤虱。暴风恶触种种疾疫。恶口骂詈挝打楚挞。身心苦恼一切能忍。是故名为住堪忍地。迦叶。菩萨摩诃萨白佛言。世尊。菩萨未得住不动地净持戒时。颇有因缘得破戒不。善男子。有菩萨未得住不动地。有因缘故可得破戒。迦叶敬诺。何者是耶。佛言。迦叶。若有菩萨知以破戒因缘。则能令人受持爱乐大乘经典。又能令其读诵通利书写经卷广为他说。不退转于阿耨多罗三藐三菩提。为如是故故得破戒。菩萨尔时应作是念。我宁一劫若减一劫堕于阿鼻地狱受罪。要必当令如是之人不退转于阿耨多罗三藐三菩提。迦叶。以是因缘菩萨摩诃萨得毁净戒。尔时文殊师利菩萨摩诃萨白佛言。世尊。若有菩萨摄取护持如是之人令不退于菩提之心。为是毁戒。若堕阿鼻无有是处。尔时佛赞文殊师利。善哉善哉。如汝所说。我念往昔于此阎浮提作大国王。名曰仙预。爱念敬重大乘经典。其心纯善无有粗恶嫉妒悭吝。口常宣说爱语善语。身常摄护贫穷孤独。布施精进无有休废。时世无佛声闻缘觉。我于尔时爱乐大乘方等经典。十二年中事婆罗门供给所须。过十二年施安已讫。即作是言。师等今应发阿耨多罗三藐三菩提心。婆罗门言。大王。菩提之性是无所有。大乘经典亦复如是。大王。云何乃令人物同于虚空。善男子。我于尔时心重大乘。闻婆罗门诽谤方等。闻已即时断其命根。善男子。以是因缘从是已来不堕地狱。善男子。拥护摄持大乘经典。乃有如是无量势力

复次迦叶。又有圣行所谓四圣谛。苦集灭道是名四圣谛。迦叶。苦者逼迫相。集者能生长相。灭者寂灭相。道者大乘相。复次善男子。苦者现相。集者转相。灭者除相。道者能除相。复次善男子。苦者有三相。苦苦相行苦相坏苦相。集者二十五有。灭者灭二十五有。道者修戒定慧。复次善男子。有漏法者有二种。有因有果。无漏法者亦有二种。有因有果。有漏果者是则名苦。有漏因者则名为集。无漏果者则名为灭。无漏因者则名为道。复次善男子。八相名苦。所谓生苦老苦病苦死苦爱别离苦怨憎会苦求不得苦五盛阴苦。能生如是八苦法者。是名为因。无有如是八法之处。是名为灭。十力四无所畏三念处大悲。是名为道。善男子。生者出相。所谓五种。一者初出。二者至终。三者增长。四者出胎。五者种类生。何等为老。老有二种。一念念老。二终身老。复有二种。一增长老。二灭坏老。是名为老。云何为病。病谓四大毒蛇互不调适。亦有二种。一者身病。二者心病。身病有五。一者因水。二者因风。三者因热。四者杂病。五者客病。客病有四。一者非分强作。二者忘误堕落。三者刀杖瓦石。四者鬼魅所著。心病亦有四种。一者踊跃。二者恐怖。三者忧愁。四者愚痴。复次善男子。身心之病凡有三种。何等为三。一者业报。二者不得远离恶对。三者时节代谢。生如是等因缘名字受分别病。因缘者。风等诸病。名字者。心闷肺胀上气咳逆心惊下痢。受分别者。头痛目痛手足等痛。是名为病。何等为死。死者舍所受身。舍所受身亦有二种。一命尽死。二外缘死。命尽死者亦有三种。一者命尽非是福尽。二者福尽非是命尽。三者福命俱尽。外缘死者复有三种。一者非分自害死。二者横为他死。三者俱死。又有三种死。一放逸死。二破戒死。三坏命根死。何等名为放逸死。若有诽谤大乘方等般若波罗蜜。是名放逸死。何等名为破戒死耶。毁犯去来现在诸佛所制禁戒。是名破戒死。何等名为坏命根死。舍五阴身。是名坏命根死。如是名曰死为大苦。何等名为爱别离苦。所爱之物破坏离散。所爱之物破坏离散亦有二种。一者人中五阴坏。二者天中五阴坏。如是人天所爱五阴。分别挍计有无量种。是名爱别离苦。何等名为怨憎会苦。所不爱者而共聚集。所不爱者而共聚集复有三种。所谓地狱饿鬼畜生。如是三趣分别挍计有无量种。如是则名怨憎会苦。何等名为求不得苦。求不得苦复有二种。一者所悕望处求不能得。二者多役功力不得果报。如是则名求不得苦。何等名为五盛阴苦。五盛阴苦者。生苦老苦病苦死苦爱别离苦怨憎贪苦求不得苦。是故名为五盛阴苦。迦叶。生之根本凡有如是七种之苦。老苦乃至五盛阴苦。迦叶。夫衰老者非一切有。佛及诸天一向定无。人中不定或有或无。迦叶。三界受身无不有生老不必定。是故一切生为根本。迦叶。世间众生颠倒覆心。贪着生相厌患老死。迦叶。菩萨不尔。观其初生已见过患。迦叶。如有女人入于他舍。是女端正颜貌瑰丽。以好璎珞庄严其身。主人见已即便问言。汝字何等系属于谁。女人答言。我身即是功德大天。主人问言。汝所至处为何所作。女人答言。我所至处能与种种金银琉璃颇梨真珠珊瑚虎珀车磲马瑙象马车乘奴婢仆使。主人闻已心生欢喜踊跃无量。我今福德故令汝来至我舍宅。即便烧香散花供养恭敬礼拜。复于门外更见一女。其形丑陋衣裳弊坏多诸垢腻。皮肤皴裂其色艾白。见已问言。汝字何等系属谁家。女人答言。我字黑闇。复问。何故名为黑闇。女人答言。我所行处能令其家所有财宝一切衰秏。主人闻已即持利刀作如是言。汝若不去当断汝命。女人答言。汝甚愚痴无有智慧。主人问言。何故名我痴无智慧。女人答言。汝舍中者即是我姊。我常与姊进止共俱。汝若驱我亦当驱彼。主人还入问功德天。外有一女云是汝妹实为是不。功德天言。实是我妹。我与此妹行住共俱未曾相离。随所住处我常作好彼常作恶。我常利益彼常作衰。若爱我者亦应爱彼。若见恭敬亦应敬彼。主人即言。若有如是好恶事者。我俱不用各随意去。是时二女俱共相将还其所止。尔时主人见其还去。心生欢喜踊跃无量。是时二女复共相随至一贫家。贫人见已心生欢喜即请之言。从今已去愿汝二人常住我家。功德天言。我等先以为他所驱。汝复何缘俱请我住。贫人答言。汝今念我。我以汝故复当敬彼。是故俱请令住我家。迦叶。菩萨摩诃萨亦复如是。不愿生天。以生当有老病死故。是以俱弃曾无爱心。凡夫愚人不知老病死等过患。是故贪受生死二法。复次迦叶。如婆罗门幼稚童子为饥所逼。见人粪中有庵罗果即便取之。有智见已呵责之言。汝婆罗门种姓清净。何故取是粪中秽果。童子闻已赧然有愧。即答之言。我实不食为欲洗净还弃舍之。智者语言。汝大愚痴若还弃者本不应取。善男子菩萨摩诃萨亦复如是。于此生分不受不舍。如彼智者呵责童子。凡夫之人欣生恶死。如彼童子取果还弃。复次迦叶。譬如四衢道头有人。器盛满食色香味具而欲卖之。有人远来饥虚羸乏。见其饭食色香味具即指之言。此是何物。食主答言。此是上食色香味具。若食此食得色得力。能除饥渴得见诸天。唯有一患。所谓命终。是人闻已即作是念。我今不用色力见天。亦不用死即作是言。食是食已若命终者。汝今何用于此卖之。食主答言。有智之人终不肯买。唯有愚人不知是事。多与我价贪而食之。善男子。菩萨摩诃萨亦复如是。不愿生天得色得力见于诸天。何以故。以其不免诸苦恼故。凡夫愚痴随有生处皆悉贪爱。以其不见老病死故。复次善男子。譬如毒树。根亦能杀。茎亦能杀。皮花果实悉亦能杀。善男子。二十五有受生之处所受五阴亦复如是。一切能杀。复次迦叶。譬如粪秽多少俱臭。善男子。生亦如是。设寿八万下至十岁俱亦受苦。复次迦叶。譬如崄岸上有草覆。于彼岸边多有甘露。若有食者寿天千年永除诸病安隐快乐。凡夫愚人贪其味故不知其下有大深坑。即前欲取不觉脚跌堕坑而死。智者知已舍离远去。善男子。菩萨摩诃萨亦复如是。尚不欲受天上妙食。况复人中凡夫之人乃于地狱吞啖铁丸。况复人天上妙肴馔而不能食。迦叶。以如是喻及余无量无边譬喻。当知是生实为大苦。迦叶。是名菩萨摩诃萨住于大乘大涅槃经观于生苦

迦叶。云何菩萨摩诃萨。于是大乘大涅槃经观于老苦。老者能为咳逆上气能坏勇力。忆念进持盛年快乐憍慢贡高。安隐自恣能作背膢。懈怠懒惰为他所轻。迦叶。譬如池水莲花满中开敷鲜荣甚可爱乐。值天降雹。悉皆破坏。善男子。老亦如是悉能破坏盛壮好色。复次迦叶。譬如国王有一智臣善知兵法。有敌国王拒逆不顺。王遣此臣往讨伐之。即便擒获将来诣王。老亦如是擒获壮色将付死王。复次迦叶。譬如折轴无所复用。老亦如是无所复用。复次迦叶。如大富家多有财宝金银琉璃珊瑚虎珀车磲马瑙。有诸怨贼若入其家即能劫夺悉令空尽。善男子。盛年好色亦复如是。常为老贼之所劫夺。复次迦叶。譬如贫人贪着上膳细软衣裳。虽复悕望而不能得。善男子。老亦如是虽有贪心欲受富乐五欲自恣而不能得。复次迦叶。如陆地龟心常念水。善男子。人亦如是。既为衰老之所干枯。心常忆念壮时所受五欲之乐。复次迦叶。犹如秋月所有莲花皆为一切之所乐见。及其萎黄人所恶贱。善男子。盛年壮色亦复如是。悉为一切之所爱乐。及其老至众所恶贱。复次迦叶。譬如甘蔗既被压已滓无复味。善男子。壮年盛色亦复如是。既被老压无三种味。一出家味。二读诵味。三坐禅味。复次迦叶。譬如满月夜多光明昼则不尔。善男子。人亦如是壮则端严形貌瑰玮。老则衰羸形神枯瘁。复次迦叶。譬如有王常以正法治于国土真实无曲慈悲好施。时为敌国之所破坏。流离逃迸遂至他土。他土人民见已生于怜愍之心。咸作是言。大王。往日正法治国不抂万姓。如何一旦流离至此。善男子。人亦如是既为衰老所坏败已。常赞壮时所行事业。复次迦叶。譬如灯炷唯赖膏油。膏油既尽势不久停。善男子。人亦如是唯赖壮膏。壮膏既尽衰老之炷何得久停。复次迦叶。譬如枯河不能利益人及非人飞鸟走兽。善男子。人亦如是为老所枯不能利益一切作业。复次迦叶。譬如河岸临峻之树。若遇暴风必当颠坠。善男子。人亦如是临老险岸死风既至势不得住。复次迦叶。如车轴折不任重载。善男子。老亦如是不能咨受一切善法。复次迦叶。譬如婴儿为人所轻。善男子。老亦如是常为一切之所轻毁。迦叶。以是等喻及余无量无边譬喻。当知是老实为大苦。迦叶。是名菩萨摩诃萨修行大乘大涅槃经观于老苦

迦叶。云何菩萨摩诃萨修行大乘大涅槃经观于病苦。所谓病者。能坏一切安隐乐事。譬如雹雨伤坏谷苗。复次迦叶。如人有怨心常忧愁而怀恐怖。善男子。一切众生亦复如是。常畏病苦心怀愁忧。复次迦叶。譬如有人形貌端正。为王夫人欲心所爱。遣使逼唤与共交通。时王捕得即便使人挑其一目截其一耳断一手足。是人尔时形容改异。人所恶贱。善男子。人亦如是。虽复身体耳目具足。既为病苦所缠逼已。则为众人之所恶贱。复次迦叶。如芭蕉树竹苇芦骡有子则死。善男子。人亦如是有病则死。复次迦叶。如转轮王主兵大臣常在前导王随后行。亦如鱼王蚁王蠡王牛王。商主在前行时如是诸众悉皆随从无舍离者。善男子。死转轮王亦复如是。常随病臣不相舍离。鱼蚁蠡牛商主病王亦复如是。常为死众之所随逐。迦叶。病因缘者。所谓苦恼愁忧悲叹身心不安。或为怨贼之所逼害。破坏浮囊拨撤桥梁。亦能劫夺正念根本。复能破坏盛壮好色力势安乐。除舍惭愧能为身心焦热炽然。以是等喻及余无量无边譬喻。当知病苦是为大苦。迦叶。是名菩萨摩诃萨修行大乘大涅槃经观于病苦

迦叶。云何菩萨摩诃萨修行大乘大涅槃经观于死苦。所谓死者。能烧灭故。迦叶。如火灾起能烧一切。唯除二禅。力不至故。善男子。死火亦尔能烧一切。唯除菩萨住于大乘大般涅槃。势不及故。复次迦叶。如水灾起一切漂没。唯除三禅。力不至故。善男子。死水亦尔漂没一切。唯除菩萨住于大乘大般涅槃。复次迦叶。如风灾起能吹一切悉令散灭。唯除四禅。力不至故。善男子。死风亦尔悉能吹灭一切所有。唯除菩萨住于大乘大般涅槃。迦叶菩萨白佛言。世尊。彼第四禅以何因缘。风不能吹水不能漂火不能烧。佛告迦叶。善男子。彼第四禅内外过患一切无故。善男子。初禅过患内有觉观外有火灾。二禅过患内有欢喜外有水灾。三禅过患内有喘息外有风灾。善男子。彼第四禅内外过患一切俱无。是故诸灾不能及之。善男子。菩萨摩诃萨亦复如是。安住大乘大般涅槃。内外过患一切皆尽。是故死王不能及之。复次善男子。如金翅鸟能啖能消一切龙鱼金银等宝。唯除金刚不能令消。善男子。死金翅鸟亦复如是。能啖能消一切众生。唯不能消住于大乘大般涅槃菩萨摩诃萨。复次迦叶。譬如河岸所有草木大水瀑涨悉随漂流入于大海。唯除杨柳以其软故。善男子。一切众生亦复如是。悉皆随流入于死海。唯除菩萨住于大乘大般涅槃。复次迦叶。如那罗延悉能摧伏一切力士。唯除大风。何以故。以无碍故。善男子。死那罗延亦复如是。悉能摧伏一切众生。唯除菩萨住于大乘大般涅槃。何以故。以无碍故。复次迦叶。譬如有人于怨憎中诈现亲善。常相追逐如影随形。伺求其便而欲杀之。彼怨谨慎坚牢自备故。使是人不能得杀。善男子。死怨亦尔。常伺众生而欲杀之。唯不能杀住于大乘大般涅槃菩萨摩诃萨。何以故。以是菩萨不放逸故。复次迦叶。譬如卒降金刚瀑雨。悉坏药木诸树山林土沙瓦石金银琉璃一切之物。唯不能坏金刚真宝。善男子。金刚死雨亦复如是。悉能破坏一切众生。唯除金刚菩萨住于大乘大般涅槃。复次迦叶。如金翅鸟能啖诸龙。唯不能啖受三归者。善男子。死金翅鸟亦复如是。能啖一切无量众生。唯除菩萨住三定者。何谓三定。空无相愿。复次迦叶。如摩罗毒蛇凡所触螫。虽有良咒上妙好药无如之何。唯阿竭多星咒能令除愈。善男子。死毒所螫亦复如是。一切医方无如之何。唯除菩萨住于大乘大般涅槃咒。复次迦叶。譬如有人为王所嗔。其人若能以软善语贡上财宝便可得脱。善男子。死王不尔。虽以软语钱财珍宝而贡上之亦不得脱。善男子。夫死者于崄难处无有资粮。去处悬远而无伴侣。昼夜常行不知边际。深邃幽闇无有灯明。入无门户而有处所。虽无痛处不可疗治。往无遮止到不得脱。无所破坏见者愁毒。非是恶色而令人怖。敷在身边不可觉知。迦叶。以是等喻及余无量无边譬喻。当知是死真为大苦。迦叶。是名菩萨摩诃萨修行大乘大涅槃经观于死苦

迦叶。云何菩萨摩诃萨住于大乘大涅槃经观爱别离苦。爱别离苦能为一切众苦根本。如说偈言

  因爱生忧　　因爱生怖　　若离于爱
  何忧何怖

爱因缘故则生忧苦。以忧苦故则令众生生于衰老。爱别离苦所谓命终。善男子。以别离故能生种种微细诸苦。今当为汝分别显示。善男子。过去之世人寿无量。时世有王名为善住。其王尔时为童子身太子治事。及登王位各八万四千岁。时王顶上生一肉疱。其疱柔软如兜罗绵。细软劫贝渐渐增长。不以为患足满十月。疱即开剖生一童子。其形端正奇异少双。色像分明人中第一。父王欢喜字之顶生。时善住王。因以国事委付顶生。弃舍宫殿妻子眷属。入山学道满八万四千岁。尔时顶生于十五日处在高楼沐浴受斋。即时东方有金轮宝。其轮千辐毂辋具足。非工匠造自然成就而来应之。顶生大王即作是念。我昔曾闻五通仙说。若刹利王于十五日处在高楼沐浴受斋。若有金轮千辐不减毂辋具足。非工匠造自然成就而来应者。当知是王即当得作转轮圣帝。复作是念。我今当试。即以左手擎此轮宝。右执香炉右膝着地而发誓言。是金轮宝若实不虚。应如过去转轮圣王所行道去。作是誓已。是金轮宝飞升虚空遍十方已。还来住在顶生左手。尔时顶生心生欢喜踊跃无量。复作是言。我今定当作转轮王。其后不久复有象宝。状貌端严如白莲花七支拄地。顶生见已复作是念。我昔曾闻五通仙说。若转轮王于十五日处在高楼沐浴受斋。若有象宝状貌端严如白莲花七支拄地而来应者。当知是王即是圣王。复作是念。我今当试。即擎香炉右膝着地而发誓言。是白象宝若实不虚。应如过去转轮圣王所行道去。作是誓已是白象宝。从旦至夕。周遍八方尽大海际还住本处。尔时顶生心大欢喜踊跃无量。复作是言。我今定是转轮圣王。其后不久次有马宝。其色绀炎髦尾金色。顶生见已复作是念。我昔曾闻五通仙说。若转轮王于十五日处在高楼沐浴受斋。若有马宝其色绀艳髦尾金色而来应者。当知是王即是圣王。复作是念。我今当试。即执香炉右膝着地而发誓言。是绀马宝若实不虚。应如过去转轮圣王所行道去。作是誓己是绀马宝从旦至夕。周遍八方尽大海际还住本处。尔时顶生心大欢喜踊跃无量。复作是言。我今定是转轮圣王。其后不久复有女宝形容端正微妙第一。不长不短不白不黑。身诸毛孔出栴檀香。口气香洁如青莲花。其目远视见一由旬。耳闻鼻嗅亦复如是。其舌广大出能覆面。形色细薄如亦铜叶。心聪睿哲有大智慧。于诸众生常有软语。是女以手触王衣时。即知王身安乐病患。亦知王心所缘之处。尔时顶生复作是念。若有女人能知王心即是女宝。其后不久于王宫内自然而有宝摩尼珠。纯青琉璃大如人脾。能于闇中照一由旬。若天降雨渧如车轴。是珠力能作盖遍覆足一由旬。遮此大雨不令下过。尔时顶生复作是念。若转轮王得是宝珠必是圣王。其后不久有主藏臣自然而出。多饶财宝巨富无量库藏盈溢无所乏少。报得眼根力能彻见一切地中所有伏藏。随王所念皆能办之。尔时顶生复欲试之。即共乘船入于大海告藏臣言。我今欲得珍异之宝。藏臣闻已即以两手挠大海水。时十指头出十宝藏。以奉圣王而白王言。大王。所须随意用之。其余在者当投大海。尔时顶生心大欢喜踊跃无量。复作念言。我今定是转轮圣王。其后不久有主兵臣自然而出。勇健猛略策谋第一善知四兵。若任斗者则现圣王。若不任者退不令现。未摧伏者能令摧伏。已摧伏者力能守护。尔时顶生复作是念。若转轮王得是兵宝。当知定是转轮圣王。尔时顶生转轮圣帝告诸大臣。汝等当知此阎浮提安隐丰乐。然我今已七宝成就千子具足更何所为。诸臣答言。唯然。大王。东弗婆提犹未归德王应往讨。尔时圣王与其七宝一切营从。飞空而往东弗婆提。彼土人民欢喜归化。复告大臣。我阎浮提及弗婆提安隐丰乐人民炽盛悉来归化。七宝成就千子具足复何所为。诸臣答言。唯然。大王。西瞿陀尼犹未归德。尔时圣王复与七宝一切营从飞空而往西瞿陀尼。王既至彼。彼土人民亦复归化。复告大臣。我阎浮提及弗婆提此瞿陀尼安隐丰乐人民炽盛。咸以归化。七宝成就千子具足复何所为。诸臣答言。唯然。大王。北郁单越犹未归化。尔时圣王复与七宝一切营从。飞空而往北郁单越。王既至彼。彼土人民欢喜归德。复告大臣。我四天下安隐丰乐人民炽盛咸已归德。七宝成就千子具足更何所为。诸臣答言。唯然。圣王。三十三天寿命极长安隐快乐。彼天身形端严无比。所居宫殿床榻卧具悉是七宝。自恃天福未来归化。今可往讨令其摧伏。尔时圣王复与七宝一切营从。飞腾虚空上忉利天。见有一树其色青绿。圣王见已即问大臣。此是何色。大臣答言。此是波利质多罗树。忉利诸天夏三月日常于其下娱乐受乐。复见白色犹如白云。复问大臣。彼是何色。大臣答言。是善法堂忉利诸天常集其中论人天事。于是天主释提桓因。知顶生王已来在外即出迎。逆见已执手升善法堂分座而坐。彼时二王形容相貌等无差别。唯有视眴为别异耳。是时圣王即生念言。我今宁可退彼王位。即住其中为天王不。善男子。尔时帝释受持读诵大乘经典。开示分别为他演说。唯于深义未尽通达。以是读诵受持分别为他广说因缘力故有大威德。善男子。而是顶生于此帝释生恶心已。即便堕落还阎浮提。与所爱念人天离别生大苦恼。复遇恶病即便命终。尔时帝释迦叶佛是。转轮圣王则我身是。善男子。当知如是爱别离者极为大苦。善男子。菩萨摩诃萨尚忆过去如是等辈爱别离苦。何况菩萨住于大乘大涅槃经。而当不观现在之世爱别离苦

善男子。云何菩萨摩诃萨修行大乘大涅槃经观怨憎会苦。善男子。是菩萨摩诃萨观于地狱畜生饿鬼人中天上。皆有如是怨憎会苦。譬如人观牢狱系闭枷锁杻械以为大苦。菩萨摩诃萨亦复如是。观于五道一切受生。悉是怨憎合会大苦。复次善男子。譬如有人常畏怨家枷锁杻械。舍离父母妻子眷属珍宝产业而远逃避。善男子。菩萨摩诃萨亦复如是。怖畏生死具足修行六波罗蜜入于涅槃。迦叶。是名菩萨摩诃萨修行大乘大般涅槃观怨憎会苦

善男子。云何菩萨修行大乘大般涅槃观求不得苦。求者一切尽求。尽求者有二种。一求善法。二求不善法。善法未得苦恶法未离苦。是则略说五盛阴苦。迦叶。是名苦谛

尔时迦叶菩萨摩诃萨白佛言。世尊。如佛所说五盛阴苦是义不然。何以故。如佛往昔告释摩男。若色苦者一切众生不应求色。若有求者则不名苦。如佛告诸比丘。有三种受。苦受乐受不苦不乐受。如佛先为诸比丘说。若有人能修行善法则得受乐。又如佛说于善道中六触受乐。眼见好色是则为乐。耳鼻舌身意思好法亦复如是。如佛说偈

  持戒则为乐　　身不受众苦
  睡眠得安隐　　寤则心欢喜
  若受衣食时　　诵习而经行
  独处于山林　　如是为最乐
  若能于众生　　昼夜常修慈
  因是得常乐　　以不恼他故
  少欲知足乐　　多闻分别乐
  无著阿罗汉　　亦名为受乐
  菩萨摩诃萨　　毕竟到彼岸
  所作众事办　　是名为最乐

世尊。如诸经中所说乐相其义如是。如佛今说云何当与此义相应。 佛告迦叶。善哉善哉。善男子。善能咨问如来是义。善男子。一切众生于下苦中横生乐想。是故我今所说苦相与本不异。尔时迦叶菩萨白佛言。如佛所说于下苦中生乐想者。下生下老下病下死。下爱别离下求不得下怨憎会下五盛阴。如是等苦亦应有乐。世尊。下生者。所谓三恶趣中生者所谓人中。上生者所谓天上。若复有人作如是问。若于下乐生于苦想。于中乐中生无苦乐想。于上乐中生于乐想。当云何答。世尊。若下苦中生乐想者。未见有人当受千罚初一下时已生乐想。若不生者。云何说言于下苦中而生乐想。佛告迦叶。如是如是如汝所说。以是义故无有乐想。何以故。犹如彼人当受千罚受一下已即得脱者。是人尔时便生乐想。是故当知于无乐中妄生乐想。迦叶言。世尊。彼人不以一下生于乐想。以得脱故而生乐想。迦叶是故我昔为释摩男说。五阴中乐实不虚也。迦叶。有三受三苦。三受者。所谓乐受苦受不苦不乐受。三苦者。所谓苦苦行苦坏苦。善男子。苦受者名为三苦。所谓苦苦行苦坏苦。余二受者。所谓行苦坏苦。善男子。以是因缘生死之中实有乐受。菩萨摩诃萨以苦乐性不相舍离。是故说言一切皆苦。善男子。生死之中实无有乐。但诸佛菩萨随顺世间说言有乐。迦叶菩萨白佛言。世尊。诸佛菩萨若随俗说是虚妄否。如佛所说修行善者则受乐报。持戒安乐身不受苦。乃至众事已办是为最乐。如是等经所说乐受是虚妄否。若是虚妄诸佛世尊。久于无量百千万亿阿僧祇劫。修菩提道已离妄语。今作是说其义云何。佛言。善男子。如上所说诸受乐偈即是菩提道之根本。亦能长养阿耨多罗三藐三菩提。以是义故。先于经中说是乐相。善男子。譬如世间所须资生能为乐因故名为乐。所谓女色耽愐饮酒上馔甘味。渴时得水寒时遇火。衣服璎珞象马车乘奴婢僮仆。金银琉璃珊瑚真珠仓库谷米。如是等物世间所须能为乐因是名为乐。善男子。如是等物亦能生苦。因于女人生男子苦。忧愁悲泣乃至断命。因酒甘味乃至仓谷。亦能令人生大忧恼。以是义故一切皆苦无有乐相。善男子。菩萨摩诃萨于是八苦解苦无苦。善男子。一切声闻辟支佛等不知乐因。为如是人于下苦中说有乐相。唯有菩萨住于大乘大般涅槃。乃能知是苦因乐因

大般涅槃经卷第十二大般涅槃经卷第十三

        北凉天竺三藏昙无谶译

    圣行品第七之三

善男子。云何菩萨摩诃萨住于大乘大般涅槃观察集谛。善男子。菩萨摩诃萨观此集谛是阴因缘。所谓集者还爱于有。爱有二种。一爱己身。二爱所须。复有二种。未得五欲系心专求。既求得已堪忍专著。复有三种。欲爱色爱无色爱。复有三种。业因缘爱烦恼因缘爱苦因缘爱。出家之人有四种爱。何等为四。衣服饮食卧具汤药。复有五种。贪着五阴随诸所须一切爱着。分别挍计无量无边。善男子。爱有二种。一者善爱二不善爱。不善爱者。惟愚求之。善法爱者诸菩萨求。善法爱者复有二种不善与善。求二乘者名为不善。求大乘者是名为善。善男子。凡夫爱者名之为集。不名为谛。菩萨爱者名之实谛不名为集。何以故。为度众生所以受生。不以爱故而受生也。迦叶菩萨白佛言。世尊。如佛世尊。于余经中为诸众生说业为因缘。或说憍慢。或说六触。或说无明。为五盛阴而作因缘。今以何义说四圣谛。独以爱性为五阴因。佛赞迦叶菩萨。善哉善哉。善男子。如汝所说。诸因缘者非为非因。但是五阴要因于爱。善男子。譬如大王若出游巡。大臣眷属悉皆随从。爱亦如是随爱行处。是诸结等亦复随行。譬如腻衣随有尘着着则随住。爱亦如是随所爱处业结亦住。复次善男子。譬如湿地则能生牙。爱亦如是能生一切业烦恼牙。善男子。菩萨摩诃萨住是大乘大般涅槃深观此爱。凡有九种。一如债有余。二如罗刹女妇。三如妙花茎中有毒蛇缠之。四如恶食性所不便而强食之。五如淫女。六如摩楼迦子。七如疮中息肉。八如暴风。九如彗星。云何名为如债有余。善男子。譬如穷人负他钱财。虽偿欲毕余未毕故。犹系在狱而不得脱。声闻缘觉亦复如是。以有爱习之余气故。不能得成阿耨多罗三藐三菩提。善男子。是名如债有余。善男子。云何如罗刹女妇。善男子。譬如有人以罗刹女而为妇妾。是罗刹女随所生子生已便啖子。既尽已复啖其夫。善男子。爱罗刹女亦复如是。随诸众生生善根子随生随食。善子既尽复啖众生。令堕地狱畜生饿鬼。唯除菩萨。是名如罗刹女妇。善男子。云何如妙花茎毒蛇缠之。譬如有人性爱好花。不见花茎毒蛇过患即便前捉。捉已蛇螫螫已命终。一切凡夫亦复如是。贪五欲花不见是爱毒蛇过患而便受取。即为爱毒之所蝎螫。命终堕于三恶道中。唯除菩萨。是名如妙花茎毒蛇缠之。善男子。云何所不便食而强食之。譬如有人所不便食而强食之。食已腹痛患下而死。爱食亦尔。五道众生强食贪着。以是因缘堕三恶道。唯除菩萨。是名所不便食而强食之善男子。云何淫女。譬如愚人与淫女通。而彼淫女巧作种种谄媚现亲。悉夺是人所有钱财。钱财既尽便复驱逐。爱之淫女亦复如是。愚人无智与之交通。而是爱女夺其所有一切善法。善法既尽驱逐令堕三恶道中。唯除菩萨。是名淫女。善男子。云何摩楼迦子。譬如摩楼迦子若鸟食已随粪堕地。或因风吹来在树下即便生长。缠绕缚束尼拘陀树。令不增长遂至枯死。爱摩楼迦子亦复如是。缠缚凡夫所有善法。不令增长遂至枯灭。既枯灭已命终之后堕三恶道。唯除菩萨。是名摩楼迦子。善男子。云何疮中息肉。如人久疮中生息肉。其人要当勤心疗治莫生舍心。若生舍心疮息增长虫疽复生。以是因缘即便命终。凡夫愚人五阴疮痍亦复如是爱于其中而为息肉。应当勤心疗治爱息。若不治者命终即堕三恶道中。唯除菩萨。是名疮中息肉。善男子。云何暴风。譬如暴风能偃山移岳拔深根栽。爱暴大风亦复如是。于父母所而生恶心。能拔大智舍利弗等无上深固菩提根栽。唯除菩萨。是名暴风。善男子。云何如彗星。譬如彗星出现天下一切人民饥馑病瘦瘿诸苦恼。爱之彗星亦复如是。能断一切善根种子。令凡夫人孤穷饥馑生烦恼病。流转生死受种种苦。唯除菩萨。是名彗星。善男子。菩萨摩诃萨住于大乘大般涅槃。观察爱结如是九种。善男子。以是义故诸凡夫人有苦无谛。声闻缘觉有苦有苦谛而无真实。诸菩萨等解苦无苦。是故无苦而有真实。诸凡夫人有集无谛。声闻缘觉有集有集谛。诸菩萨等解集无集。是故无集而有真谛。声闻缘觉有灭非真。菩萨摩诃萨有灭有真谛。声闻缘觉有道非真。菩萨摩诃萨有道有真谛

善男子。云何菩萨摩诃萨住于大乘大般涅槃见灭见灭谛。所谓断除一切烦恼。若烦恼断则名为常。灭烦恼火则名寂灭。烦恼灭故则得受乐。诸佛菩萨求因缘故故名为净。更不复受二十五有故名出世。以出世故名为我常。于色声香味触男女生住灭。苦乐不苦不乐不取相貌。故名毕竟寂灭真谛。善男子。菩萨如是住于大乘大般涅槃观灭圣谛。善男子。云何菩萨摩诃萨住于大乘大般涅槃观道圣谛。善男子。譬如闇中因灯得见粗细之物。菩萨摩诃萨亦复如是。住于大乘大般涅槃因八圣道见一切法。所谓常无常有为无为。有众生非众生物非物。苦乐我无我净不净。烦恼非烦恼业非业。实不实乘非乘。知不知陀罗骠非陀罗骠。求那非求那。见非见色非色道非道解非解。善男子。菩萨如是住于大乘大般涅槃观道圣谛

迦叶菩萨白佛言。世尊。若八圣道是道圣谛义不相应。何以故。如来或说信心为道能度诸漏。或时说道不放逸是。诸佛世尊不放逸故得阿耨多罗三藐三菩提。亦是菩萨助道之法。或时说言精进是道。如告阿难。若有人能勤修精进则得成于阿耨多罗三藐三菩提。或时说言观身念处。若有系心精勤修习是身念处。则得成于阿耨多罗三藐三菩提。或时说言正定为道如告大德摩诃迦叶。夫正定者真实是道。非不正定而是道也。若入正定乃能思惟五阴生灭。非不入定能思惟也。或说一法若人修。习能净众生灭除一切忧愁苦恼。逮得正法所谓念佛三昧。或复说言修无常想是名为道。如告比丘有能多修无常想者。能得阿耨多罗三藐三菩提。或说空寂阿兰若处独坐思惟。能得速成阿耨多罗三藐三菩提。或时说言为人演法是名为道。若闻法已疑网即断。疑网断已则得阿耨多罗三藐三菩提。或时说言持戒是道。如告阿难若有精勤修持禁戒。是人则度生死大苦。或时说言亲近善友是名为道。如告阿难。若有亲近善知识者则具净戒。若有众生能亲近我。则得发于阿耨多罗三藐三菩提心。或时说言修慈是道。修学慈者断诸烦恼得不动处。或时说言智慧是道。如佛昔为波阇波提比丘尼说姊妹。如诸声闻以智慧刀能断诸流诸漏烦恼。或时如来说施是道。如佛往昔告波斯匿王。大王。当知我于往昔多行惠施。以是因缘今日得成阿耨多罗三藐三菩提。世尊。若八圣道是道谛者。如是等经岂非虚妄。若彼诸经非虚妄者。彼中何缘不说八道为道圣谛。若彼不说如来往昔何故错谬。然我定知诸佛如来久离错谬

尔时世尊赞迦叶菩萨。善哉善哉。善男子。汝今欲知菩萨大乘微妙经典所有秘密故作是问。善男子。如是诸经悉入道谛。善男子。如我所说若有信道。如是信道是信根本。是能佐助菩提之道。是故我说无有错谬。善男子。如来善知无量方便欲化众生。故作如是种种说法。善男子。譬如良医识诸众生种种病原。随其所患而为合药并药所禁。唯水一种不在禁例。或服姜水。或甘草水。或细辛水。或黑石蜜水。或阿摩勒水。或尼婆罗水。或钵昼罗水。或服冷水。或服热水。或蒲萄水。或安石榴水。善男子。而是良医善知众生所患。种种药虽多禁水不在例。如来亦尔善知方便。于一法相随诸众生分别广说种种名相。彼诸众生随所说受。受已修习除断烦恼。如彼病人随良医教所患得除。复次善男子。如有一人善解杂语在大众中。是诸大众热渴所逼咸发声言。我欲饮水我欲饮水。是人即时以清冷水随其种类说言是水。或言波尼。或言郁持。或言纱利蓝。或言纱利。或言婆耶。或言甘露。或言牛乳。以如是等无量水名为大众说。善男子。如来亦尔以一圣道为诸声闻种种演说。从信根等至八圣道。复次善男子。譬如金师以一种金随意造作种种璎珞。所谓钳锁环钏钗珰天冠臂印。虽有如是差别不同。然不离金。善男子。如来亦尔。以一佛道随诸众生种种分别而为说之。或说一种。所谓诸佛一道无二。复说二种所谓定慧。复说三种谓见慧智。复说四种。所谓见道修道无学道佛道。复说五种。所谓信行道法行道信解脱道见到道身证道。复说六种。所谓须陀洹道斯陀含道阿那含道阿罗汉道辟支佛道佛道。复说七种。所谓念觉分择法觉分精进觉分喜觉分除觉分定觉分舍觉分。复说八种。所谓正见正思惟正语正业正命正精进正念正定。复说九种。所谓八圣道及信。复说十种所谓十力。复说十一种。所谓十力大慈。复说十二种。所谓十力大慈大悲。复说十三种。所谓十力大慈大悲念佛三昧。复说十六种。所谓十力大慈大悲念佛三昧及佛所得三正念处。复说二十道。所谓十力四无所畏大慈大悲念佛三昧三正念处。善男子。是道一体。如来昔日为众生故种种分别。复次善男子。譬如一火因所然故得种种名。所谓木火草火糠火[麥*戈]火牛马粪火。善男子。佛道亦尔一而无二。为众生故种种分别。复次善男子。譬如一识分别说六。若至于眼则名眼识。乃至意识亦复如是。善男子。道亦如是一而无二。如来为化诸众生故种种分别。复次善男子。譬如一色眼所见者则名为色。耳所闻者则名为声。鼻所嗅者则名为香。舌所尝者则名为味。身所觉者则名为触。善男子。道亦如是一而无二。如来为欲化众生故种种分别。善男子。以是义故以八圣道分名道圣谛。善男子。是四圣谛诸佛世尊次第说之。以是因缘无量众生得度生死

迦叶菩萨白佛言。世尊。昔佛一时在恒河岸尸首林中。尔时如来取其树叶告诸比丘。我今手中所捉叶多。一切因地草木叶多。诸比丘言。世尊。一切因地草木叶多不可称计。如来所捉少不足言。诸比丘。我所觉了一切诸法。如因大地生草木等。为诸众生所宣说者。如手中叶。世尊。尔时说如是言。如来所了无量诸法。若入四谛则为已说。若不入者应有五谛。尔时佛赞迦叶菩萨。善哉善哉。善男子。汝今所问则能利益安隐快乐无量众生。善男子。如是诸法悉已摄在四圣谛中。迦叶菩萨复作是言。如是等法若在四谛。如来何故唱言不说。佛言善男子。虽复入中犹不名说。何以故。善男子。知四圣谛有二种智。一者中二者上。中者声闻缘觉智。上者诸佛菩萨智。善男子。知诸阴苦名为中智。分别诸阴有无量相悉是诸苦。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经竟不说之。善男子。知诸入者名之为门亦名为苦。是名中智。分别诸入有无量相悉是诸苦。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知诸界者名之为分。亦名为性亦名为苦。是名中智。分别诸界有无量相悉是诸苦非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知色坏相是名中智。分别诸色有无量相悉是诸苦。非诸声闻缘觉所知是名上智。如是等义我于彼经亦不说之。善男子。知受觉相是名中智。分别诸受有无量觉相。非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知想取相是名中智。分别是想有无量取相。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知行作相是名中智。分别是行无量作相非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知识分别相是名中智。分别是识无量知相非诸声闻缘觉所知。是名上智。善男子。如是等义我于彼经亦不说之。善男子。知爱因缘能生五阴是名中智。一人起爱无量无边声闻缘觉所不能知。能知一切众生所起如是等爱。是名上智。如是等义我于彼经亦不说之。善男子。知灭烦恼是名中智。分别烦恼不可称计。灭亦如是不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知是道相能离烦恼是名中智。分别道相无量无边所离烦恼亦无量无边。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。知世谛者是名中智。分别世谛无量无边不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之。善男子。一切行无常诸法无我涅槃寂灭是第一义。是名中智。知第一义无量无边不可称计。非诸声闻缘觉所知。是名上智。如是等义我于彼经亦不说之

尔时文殊师利菩萨摩诃萨白佛言。世尊。所说世谛第一义谛其义云何。世尊。第一义中有世谛不。世谛之中有第一义不。如其有者即是一谛。如其无者将非如来虚妄说耶。善男子。世谛者即第一义谛。世尊。若尔者则无二谛。佛言善男子。有善方便随顺众生说有二谛。善男子。若随言说则有二种。一者世法。二者出世法。善男子。如出世人之所知者名第一义谛。世人知者名为世谛。善男子。五阴和合称言某甲。凡夫众生随其所称是名世谛。解阴无有某甲名字。离阴亦无某甲名字。出世之人如其性相而能知之名第一义谛。复次善男子。或复有法有名有实。或复有法有名无实。善男子。有名无实者即是世谛。有名有实者是第一义谛。善男子。如我众生寿命知见养育丈夫作者受者。热时之炎乾闼婆城。龟毛兔角旋火之轮。诸阴界入是名世谛。苦集灭道名第一义谛。善男子。世法有五种。一者名世。二者句世。三者缚世。四者法世。五者执着世。善男子。云何名世。男女瓶衣车乘屋舍如是等物。是名名世。云何句世。四句一偈如是等偈。名为句世。云何缚世。卷合系结束缚合掌。是名缚世。云何法世。如鸣捶集僧严鼓戒兵吹贝知时。是名法世。云何执着世。如望远人有染衣者。生想执着言是沙门非婆罗门。见有结绳横佩身上。便生念言是婆罗门非沙门也。是名执着世。善男子。如是名为五种世法。善男子。若有众生于如是等五种世法。心无颠倒如实而知。是名第一义谛。复次善男子。若烧若割若死若坏。是名世谛。无烧无割无死无坏。是名第一义谛。复次善男子。有八苦相名为世谛。无生无老无病无死。无爱别离无怨憎会。无求不得无五盛阴。是名第一义谛。复次善男子。譬如一人多有所能。若其走时则名走者。或收刈时复名刈者。或作饮食名作食者。若治材木则名工匠。锻金银时言金银师。如是一人有多名字。法亦如是其实是一而有多名。依因父母和合而生名为世谛。十二因缘和合生者名第一义谛

文殊师利菩萨摩诃萨白佛言。世尊。所言实谛其义云何。佛言善男子。言实谛者名曰真法。善男子。若法非真不名实谛。善男子。实谛者无颠无倒。无颠倒者乃名实谛。善男子。实谛者无有虚妄。若有虚妄不名实谛。善男子。实谛者名曰大乘。非大乘者不名实谛。善男子。实谛者是佛所说非魔所说。若是魔说非佛说者不名实谛。善男子。实谛者一道清净无有二也。善男子。有常有乐有我有净。是则名为实谛之义。文殊师利白佛言。世尊。若以真实为实谛者。真实之法即是如来虚空佛性。若如是者如来虚空及与佛性无有差别。佛告文殊师利。有苦有谛有实。有集有谛有实。有灭有谛有实。有道有谛有实。善男子。如来非苦非谛是实。虚空非苦非谛是实。佛性非苦非谛是实。文殊师利。所言苦者为无常相是可断相是为实谛。如来之性非苦非无常非可断相。是故为实虚空。佛性亦复如是。复次善男子。所言集者能令五阴和合而生。亦名为苦亦名无常。是可断相是为实谛。善男子。如来非是集性非是阴因非可断相。是故为实虚空。佛性亦复如是。善男子。所言灭者名烦恼灭。亦常无常。二乘所得名曰无常。诸佛所得是则名常。亦名证法是为实谛。善男子。如来之性不名为灭。能灭烦恼非常非无常。不名证知常住无变。是故为实虚空。佛性亦复如是。善男子。道者能断烦恼亦常无常。是可修法是名实谛。如来非道能断烦恼。非常无常非可修法常住不变。是故为实虚空。佛性亦复如是。复次善男子。言真实者即是如来。如来者即是真实。真实者即是虚空。虚空者即是真实。真实者即是佛性。佛性者即是真实。文殊师利。有苦有苦因有苦尽有苦对。如来非苦乃至非对。是故为实不名为谛。虚空佛性亦复如是。苦者有为有漏无乐。如来非有为非有漏湛然安乐是实非谛。文殊师利白佛言。世尊。如佛所说不颠倒者名为实谛。若尔者四谛之中有四倒不。如其有者。云何说言无有颠倒名为实谛。一切颠倒不名为实佛告文殊师利。一切颠倒皆入苦谛。如诸众生有颠倒心名为颠倒。善男子。譬如有人不受父母尊长教敕。虽受不能随顺修行。如是人等名为颠倒。如是颠倒非不是苦即是苦也。文殊师利言。如佛所说不虚妄者即是实谛。若尔者当知虚妄则非实谛。佛言善男子。一切虚妄皆入苦谛。如有众生欺诳于他。以是因缘堕于地狱畜生饿鬼。如是等法名为虚妄。如是虚妄非不是苦即是苦也。声闻缘觉诸佛世尊远离不行故名虚妄。如是虚妄诸佛二乘所断除故故名实谛。文殊师利言。如佛所说大乘是实谛者。当知声闻辟支佛乘则为不实。佛言文殊师利。彼二乘者亦实不实。声闻缘觉断诸烦恼则名为实。无常不住是变易法名为不实。文殊师利言如佛所说若佛所说名为实者。当知魔说则为不实。世尊。如魔所说圣谛摄不。佛言文殊师利。魔所说者二谛所摄所谓苦集。凡是一切非法非律不能令人而得利益。终日宣说亦无有人。见苦断集证灭修道是名虚妄。如是虚妄名为魔说。文殊师利言。如佛所说一道清净无有二者。诸外道等亦复说言。我有一道清净无二。若言一道是实谛者。与彼外道有何差别。若无差别不应说言一道清净。佛言善男子。诸外道等有苦集谛无灭道谛。于非灭中而生灭想。于非道中而生道想。于非果中生于果想。于非因中生于因想。以是义故。彼无一道清净无二

文殊师利言。如佛所说有常有我有乐有净是实义者。诸外道等应有实谛。佛法中无。何以故。诸外道辈亦复说言诸行是常。云何是常。可意不可意诸业报等受不失故。可意者名十善报。不可意者十不善报。若言诸行悉皆无常。而作业者于此已灭。谁复于彼受果报乎。以是义故诸行是常。杀生因缘故名为常。世尊。若言诸行悉无常者。能杀可杀二俱无常。若无常者谁于地狱而受罪报。若言定有地狱受报者。当知诸行实非无常。世尊。系心专念亦名为常。所谓十年所念乃至百年亦不忘失是故为常。若无常者本所见事谁忆谁念。以是因缘一切诸行非无常也。世尊。一切忆想亦名为常。有人先见他人手脚头项等相。后时若见便还识之。若无常者本想应灭。世尊。诸所作业以久修习。若从初学或经三年或经五年。然后善知故名为常。世尊。算数之法。从一至二从二至三乃至百千。若无常者初一应灭。初一若灭谁复至二。如是常一终无有二。以一不灭故得至二乃至百千。是故为常。世尊。如读诵法。读一阿含至二阿含。乃至三四阿含。如其无常所可读诵终不至四。以是读诵增长因缘故名为常。世尊。瓶衣车乘如人负债。大地形相山河树林。药木草叶众生治病。皆悉是常亦复如是。世尊。一切外道皆作是说诸行是常。若是常者即是实谛。世尊。有诸外道复言有乐。云何知耶。受者定得可意报故。世尊。凡受乐者必定得之。所谓大梵天王大自在天释提桓因毗纽天及诸人天。以是义故名定有乐。世尊。有诸外道复言有乐。能令众生生求望故。饥者求食渴者求饮。寒者求温热者求凉。极者求息病者求差欲者求色。若无乐者彼何缘求。以有求者故知有乐。世尊。有诸外道复作是言施能得乐。世间之人好施沙门诸婆罗门。贫穷困苦衣服饮食卧具医药。象马车乘末香涂香。众花屋宅依止灯明。作如是等种种惠施。为我后世受可意报。是故当知决定有乐。世尊。有诸外道复作是言以因缘故当知有乐。所谓受乐者有因缘故名为乐触。若无乐者何得因缘。如无兔角则无因缘。有乐因缘则知有乐。世尊。有诸外道复作是言上中下故当知有乐。下受乐者释提桓因。中受乐者大梵天王。上受乐者大自在天。以有如是上中下故当知有乐。世尊。有诸外道复言有净。何以故。若无净者不应起欲。若起欲者当知有净。又复说言。金银珍宝琉璃颇梨车磲马瑙珊瑚真珠璧玉珂贝。流泉浴池饮食衣服。花香末香涂香灯烛之明。如是等物悉是净法。复次有净谓五阴者即是净器盛诸净物。所谓人天诸仙阿罗汉辟支佛菩萨诸佛。以是义故名之为净。世尊。有诸外道复言有我。有所睹见能造作故。譬如有人入陶师家。虽复不见陶师之身。以见轮绳定知。其家必是陶师。我亦如是眼见色已必知有我。若无我者谁能见色闻声乃至触法亦复如是。复次有我。云何得知因相故知。何等为相。喘息视眴寿命役心受诸苦乐贪求嗔恚。如是等法悉是我相。是故当知必定有我。复次有我能别味故。有人食果见已知味。是故当知必定有我。复次有我云何知耶执作业故。执镰能刈执斧能斫执瓶盛水执车能御。如是等事我执能作。当知必定而有我也。复次有我云何知耶。即于生时欲得乳餔乘宿习故。是故当知必定有我。复次有我云何知耶。和合利益他众生故。譬如瓶衣车乘田宅。山林树木象马牛羊。如是等物若和合者则有利益。此内五阴亦复如是。眼等诸根有和合故则利益我。是故当知必定有我。复次有我云何知耶。有遮法故如有物故则有遮碍。物若无者则无有遮。若有遮者则知有我。是故当知必定有我。复次有我云何知耶。伴非伴故亲与非亲非是伴侣。正法邪法亦非伴侣。智与非智亦非伴侣。沙门非沙门。婆罗门非婆罗门。子非子昼非昼夜非夜我非我。如是等法为伴非伴。是故当知必定有我。世尊。诸外道等种种说有常乐我净。当知定有常乐我净。世尊。以是义故。诸外道等亦得说言我有真谛

佛言善男子。若有沙门婆罗门有常有乐。有净有我者是非沙门非婆罗门。何以故。迷于生死离一切智大导师故。如是沙门婆罗门等沉没诸欲善法羸损故。是诸外道系在贪欲嗔恚痴狱。堪忍爱乐故。是诸外道虽知业果自作自受。而犹不能远离恶法。是诸外道非是正法正命自活。何以故。无智慧火不能消故。是诸外道虽欲贪着上妙五欲。贫于善法不勤修故。是诸外道虽欲往至正解脱中。而持戒足不成就。故是诸外道虽欲求乐。而不能求乐因缘。故是诸外道虽复憎恶一切诸苦。然其所行未能远离诸苦因缘。是诸外道虽为四大毒蛇所缠。犹行放逸不能谨慎是诸外道无明所覆远离善友。乐在三界无常炽然大火之中而不能出。是诸外道遇诸烦恼难愈之病。而复不求大智良医。是诸外道方于未来当涉无边险远之路。而不知习善法资粮而自庄严。是诸外道常为淫欲灾毒所害。而反抱持五欲霜毒。是诸外道嗔恚炽盛。而复反更亲近恶友。是诸外道常为无明之所覆蔽。而反推求邪恶之法。是诸外道常为邪见之所诳惑。而反于中生亲善想。是诸外道怖食甘果而种苦子。是诸外道已处烦恼闇室之中。而反远离大智炬明。是诸外道患烦恼渴。而复反饮诸欲碱水。是诸外道漂没生死无边大河。而复远离无上船师。是诸外道迷惑颠倒言诸行常。诸行若常无有是处

大般涅槃经卷第十三大般涅槃经卷第十四

        北凉天竺三藏昙无谶译

    圣行品第七之四

善男子。我观诸行悉皆无常。云何知耶以因缘故。若有诸法从缘生者则知无常。是诸外道无有一法不从缘生。善男子。佛性无生无灭无去无来。非过去非未来非现在。非因所作非无因作。非作非作者。非相非无相。非有名非无名。非名非色非长非短。非阴界入之所摄持。是故名常。善男子。佛性即是如来。如来即是法。法即是常。善男子。常者即是如来如来即是僧。僧即是常。以是义故从因生法不名为常。是诸外道无有一法不从因生。善男子。是诸外道不见佛性如来及法。是故外道所可言说悉是妄语无有真谛。诸凡夫人。先见瓶衣车乘舍宅城郭河水山林男女象马牛羊。后见相似便言是常。当知其实非是常也。善男子。一切有为皆是无常。虚空无为是故为常。佛性无为是故为常。虚空者即是佛性。佛性者即是如来。如来者即是无为。无为者即是常。常者即是法。法者即是僧。僧即无为。无为者即是常。善男子。有为之法凡有二种。色法非色法。非色法者心心数法。色法者地水火风。善男子。心名无常。何以故。性是攀缘相应分别故。善男子。眼识性异乃至意识性异是故无常。善男子。色境界异乃至法境界异是故无常。善男子。眼识相应异乃至意识相应异是故无常。善男子。心若常者眼识应独缘一切法。善男子。若眼识异乃至意识异则知无常。以法相似念念生灭。凡夫见已计之为常。善男子。诸因缘相可破坏故亦名无常。所谓因眼因色因明因思惟生于眼识。耳识生时所因各异非眼识因缘。乃至意识异亦如是

复次善男子。坏诸行因缘异故心名无常。所谓修无常心异。修苦空无我心异。心若常者应常修无常。尚不得观苦空无我。况复得观常乐我净。以是义故。外道法中不能摄取常乐我净。善男子。当知心法必定无常。复次善男子。心性异故名为无常。所谓声闻心性异。缘觉心性异。诸佛心性异。一切外道心有三种。一者出家心。二者在家心。三者在家远离心。乐相应心异。苦相应心异。不苦不乐相应心异。贪欲相应心异。嗔恚相应心异。愚痴相应心异。一切外道心相亦异。所谓愚痴相应心异。疑惑相应心异。邪见相应心异。进止威仪其心亦异。善男子。心若常者亦复不能分别诸色。所谓青黄赤白紫色。善男子。心若常者诸忆念法不应忘失。善男子。心若常者凡所读诵不应增长。复次善男子。心若常者不应说言已作今作当作。若有已作今作当作。当知是心必定无常。善男子。心若常者则无怨亲非怨非亲。心若常者则不应言我物他物若死若生。心若常者虽有所作不应增长。善男子。以是义故。当知心性各各别异。有别异故当知无常。善男子。我今于此非色法中演说无常其义已显。复当为汝说色无常。是色无常本无有生生已灭故。内身处胎歌罗逻时本无有生生已变故。外诸牙茎本亦无生生已变故。是故当知一切色法悉皆无常。善男子。所有内色随时而变。歌罗逻时异。安浮陀时异。伽那时异。闭手时异。诸疱时异。初生时异。婴孩时异。童子时异。乃至老时各各变异。所谓外色亦复如是。牙异茎异枝异叶异花异果异。复次善男子。内味亦异歌罗逻时。乃至老时各各变异。外味亦尔。牙茎枝叶花果味异。歌罗逻时力异。乃至老时力异。歌罗逻时状貌异。乃至老时状貌亦异。歌罗逻时果报异。乃至老时果报亦异。歌罗逻时名字异。乃至老时名字亦异。所谓内色坏已还合故知无常。外诸树木亦坏已还合故知无常。次第渐生故知无常。次第生歌罗逻时乃至老时。次第生牙乃至果子故知无常。诸色可灭故知无常。歌罗逻灭时异。乃至老灭时异。牙灭时异乃至果灭时异故知无常。凡夫无知。见相似生计以为常。以是义故。名曰无常。若无常即是苦。若苦即是不净

善男子。我因迦叶先问是事于彼已答

复次善男子。诸行无我。善男子。总一切法谓色非色色非我也。何以故。可破可坏可裂可打生增长故。我者不可破坏裂打生长。以是义故。知色非我非色之法亦复非我。何以故。因缘生故。善男子。若诸外道以专念故知有我者。专念之性实非我也。若以专念为我性者。过去之事则有忘失。有忘失故定知无我。善男子。若诸外道以忆想故知有我者。无忆想故定知无我。如说见人手有六指。即便问言。我先何处共相见耶。若有我者不应复问。以相问故定知无我。善男子。若诸外道以有遮故知有我者。善男子。以有遮故定知无我。如言调达终不发言非调达也。我亦如是若定是我终不遮我。以遮我故定知无我。若以遮故知有我者。汝今不遮定应无我。善男子。若诸外道以伴非伴知有我者。以无伴故应无有我有法无伴。所谓如来虚空佛性我亦如是实无有伴。以是义故。定知无我。复次善男子。若诸外道以名字故知有我者。无我法中亦有我名。如贫贱人名字富贵。如言我死。若我死者我则杀我。而我实不可杀假名杀我。亦如矬人名为长者。以是义故。定知无我。复次善男子。若诸外道以生已求乳知有我者。善男子。若有我者一切婴儿不应执持粪秽火蛇毒药。以是义故。定知无我。复次善男子。一切众生于三法中悉有等智。所谓淫欲饮食恐怖是故无我。复次善男子。若诸外道以相貌故知有我者。善男子。相故无我无相故亦无我。若人睡时不能进止俯仰视眴。不觉苦乐不应有我。若以进止俯仰视眴知有我者。机关木人亦应有我。善男子。如来亦尔。不进不止不俯不仰不视不眴。不苦不乐不贪不恚不痴不行。如来如是真实有我。复次善男子。若诸外道以见他食果口中生涎知有我者。善男子。以忆念故见则生涎涎非我也。我亦非涎非喜非悲非欠非笑。非卧非起非饥非饱。以是义故。定知无我。善男子。是诸外道痴如小儿。无慧方便不能了达常与无常。苦乐净不净我无我。寿命非寿命。众生非众生。实非实有非有。于佛法中取少许分。虚妄计有常乐我净。而实不知常乐我净。如生盲人不识乳色。便问他言乳色何似。他人答言色白如贝。盲人复问是乳色者如贝声耶。答言。不也。复问贝色为何似耶。答言。犹稻米末。盲人复问乳色柔软如稻米末耶。稻米末者复何所似。答言。犹如雨雪。盲人复言。彼稻米末冷如雪耶。雪复何似。答言。犹如白鹤。是生盲人虽闻如是四种譬喻。终不能得识乳真色。是诸外道亦复如是。终不能识常乐我净。善男子。以是义故。我佛法中有真实谛非于外道

文殊师利白佛言。希有世尊。如来于今临般涅槃方更转于无上法轮。乃作如是分别真谛。佛告文殊师利。汝今云何故于如来生涅槃想。善男子。如来实是常住不变不般涅槃。善男子。若有计我是佛我成阿耨多罗三藐三菩提。我即是法法是我所。我即是道道是我所。我即世尊世尊即是我所。我即声闻声闻即是我所。我能说法令他听受。我转法轮余人不能。如来终不作如是计。是故如来不转法轮。善男子。若有人作如是妄计。我即是眼眼即是我所。耳鼻舌身意亦复如是。我即是色色是我所。乃至法亦如是。我即是地地即是我所。水火风等亦复如是。善男子。若有人言我即是信信是我所。我是多闻多闻即是我所。我是檀波罗蜜檀波罗蜜即是我所。我是尸波罗蜜尸波罗蜜即是我所。我是羼提波罗蜜羼提波罗蜜即是我所。我是毗梨耶波罗蜜毗梨耶波罗蜜即是我所。我是禅波罗蜜禅波罗蜜即是我所。我是般若波罗蜜般若波罗蜜即是我所。我是四念处四念处即是我所。四正勤四如意足五根五力七觉分八圣道分亦复如是。善男子。如来终不作如是计。是故如来不转法轮。善男子。若言常住无有变易。云何说言佛转法轮。是故汝今不应说言如来方更转于法轮。善男子。譬如因眼缘色缘明缘思惟。因缘和合得生眼识。善男子。眼不念言我能生识。色乃至思惟终不念言我生眼识。眼识亦复不作念言我能自生。善男子。如是等法因缘和合得名为见。善男子。如来亦尔。因六波罗蜜三十七助菩提之法觉了诸法。复因咽喉舌齿唇口言语音声。为憍陈如初始说法名转法轮。以是义故。如来不名转法轮也。善男子。若不转者即名为法。法即如来。善男子。譬如因燧因钻因手因干牛粪而得生火。燧亦不言我能生火。钻手牛粪各不念言我能生火。火亦不言我能自生。如来亦尔。因六波罗蜜。乃至憍陈如名转法轮。如来亦复不生念言我转法轮。善男子。若不生者是则名为转正法轮。是转法轮即名如来。善男子。譬如因酪因水因攒因瓶因绳因人。手捉而得出苏。酪不念言我能出苏乃至人手亦不念言我能出苏。苏亦不言我能自出。众缘和合故得出苏。如来亦尔。终不念言我转法轮。善男子。若不出者是则名为转正法轮。是转法轮即是如来。善男子。譬如因子因地因水因火因风因粪因时。因人作业而牙得生。善男子。子亦不言我能生牙乃至作业。亦不念言我能生牙。牙亦不言我能自生。如来亦尔。终不念言我转法轮。善男子。若不能者是则名为转正法轮。是转法轮即是如来。善男子。譬如因鼓因空因皮因人因桴和合出声。鼓不念言我能出声。乃至桴亦如是。声亦不言我能自生。善男子。如来亦尔。终不念言我转法轮。善男子。转法轮者名为不作。不作者即转法轮。转法轮者即是如来。善男子。转法轮者乃是诸佛世尊境界。非诸声闻缘觉所知。善男子。虚空非生非出非作非造非有为法。如来亦尔。非生非出非作非造非有为法。如如来性佛性亦尔。非生非出非作非造非有为法。善男子。诸佛世尊语有二种。一者世语。二者出世语。善男子。如来为诸声闻缘觉说于世语。为诸菩萨说出世语。善男子。是诸大众复有二种。一者求小乘。二者求大乘。我于昔日波罗奈城。为诸声闻转于法轮。今始于此拘尸那城为诸菩萨转大法轮。复次善男子。复有二人中根上根。为中根人于波罗奈转于法轮。为上根人人中象王迦叶菩萨等。今于此间拘尸那城转大法轮。善男子。极下根者如来终不为转法轮。极下根者即一阐提。复次善男子。求佛道者复有二种。一中精进。二上精进。于波罗奈。为中精进转于法轮。今于此间拘尸那城。为上精进转大法轮。复次善男子。我昔于彼波罗奈城初转法轮。八万天人得须陀洹果。今于此间拘尸那城。八十万亿人不退转于阿耨多罗三藐三菩提。复次善男子。波罗奈城大梵天王。稽首请我转于法轮。今于此间拘尸那城。迦叶菩萨稽首请我转大法轮。复次善男子。我昔于彼波罗奈城转法轮时。说无常苦空无我。今于此间拘尸那城转法轮时。说常乐我净

复次善男子。我昔于彼波罗奈城转法轮时。所出音声闻于梵天。如来今于拘尸那城转法轮时。所出音声遍于东方二十恒河沙等诸佛世界。南西北方四维上下亦复如是。复次善男子。诸佛世尊凡有所说。皆悉名为转法轮也。善男子。譬如圣王所有轮宝未降伏者能令降伏。已降伏者能令安隐。善男子。诸佛世尊凡所说法亦复如是。无量烦恼未调伏者能令调伏。已调伏者令生善根。善男子。譬如圣王所有轮宝则能消灭一切怨贼。如来演法亦复如是。能令一切诸烦恼贼皆悉寂静。复次善男子。譬如圣王所有轮宝下上回转。如来说法亦复如是。能令下趣诸恶众生上生人天乃至佛道。善男子。是故汝今不应赞言如来于此更转法轮。尔时文殊师利白佛言。世尊。我于此义非为不知。所以问者为欲利益诸众生故。世尊。我已久知转法轮者。实是诸佛如来境界。非是声闻缘觉所知。尔时世尊告迦叶菩萨。善男子。是名菩萨住于大乘大涅槃经所行圣行

迦叶菩萨白佛言。世尊。复以何义名为圣行。善男子。圣名诸佛世尊。以是义故。名为圣行世尊。若是诸佛之所行者。则非声闻缘觉菩萨所能修行。善男子。是诸世尊安住于此大般涅槃。而作如是开示分别演说其义。以是义故。名曰圣行。声闻缘觉及诸菩萨如是闻已则能奉行故名圣行。善男子。是菩萨摩诃萨得是行已则得住于无所畏地。善男子。若有菩萨得住如是无所畏地。则不复畏贪恚愚痴生老病死。亦复不畏恶道地狱畜生饿鬼。善男子。恶有二种。一者阿修罗。二者人中。人中有三种恶。一者一阐提。二者诽谤方等经典。三者犯四重禁。善男子。住是地中诸菩萨等终不畏堕如是恶中。亦复不畏沙门婆罗门外道邪见天魔波旬。亦复不畏受二十五有。是故此地名无所畏。善男子。菩萨摩诃萨住无畏地。得二十五三昧坏二十五有。善男子。得无垢三昧能坏地狱有。得无退三昧能坏畜生有。得心乐三昧能坏饿鬼有。得欢喜三昧能坏阿修罗有。得日光三昧能断弗婆提有。得月光三昧能断瞿耶尼有。得热炎三昧能断郁单越有。得如幻三昧能断阎浮提有。得一切法不动三昧能断四天处有。得难伏三昧能断三十三天处有。得悦意三昧能断炎摩天有。得青色三昧能断兜率天有。得黄色三昧能断化乐天有。得赤色三昧能断他化自在天。有得白色三昧能断初禅有。得种种三昧能断大梵天有。得双三昧能断二禅有。得雷音三昧能断三禅有。得霔雨三昧能断四禅有。得如虚空三昧能断无想有。得照镜三昧能断净居阿那含有。得无碍三昧能断空处有。得常三昧能断识处有。得乐三昧能断不用处有。得我三昧能断非想非非想处有。善男子。是名菩萨得二十五三昧断二十五有。善男子。如是二十五三昧名诸三昧王。善男子。菩萨摩诃萨入如是等诸三昧王。若欲吹坏须弥山王随意即能。欲知三千大千世界所有众生心之所念亦悉能知。欲以三千大千世界所有众生。内于己身一毛孔中随意即能。亦令众生无迫迮想。若欲化作无量众生悉令充满三千大千世界中者亦能随意。欲分一身以为多身。复合多身以为一身。虽作如是心无所著。犹如莲花。善男子。菩萨摩诃萨得入如是三昧王已。即得住于自在之地。菩萨得住是自在地得自在力。随欲生处即得往生。善男子。譬如圣王领四天下随意所行无能障碍。菩萨摩诃萨亦复如是。一切生处若欲生者随意往生。善男子。菩萨摩诃萨若见地狱一切众生有可化令住善根者。菩萨即往而生其中。菩萨虽生非本业果。菩萨摩诃萨住自在地力因缘故而生其中。善男子。菩萨摩诃萨虽在地狱。不受炽然碎身等苦。善男子。菩萨摩诃萨所可成就如是功德。无量无边百千万亿尚不可说。何况诸佛所有功德而当可说

尔时众中有一菩萨名住无垢藏王。有大威德成就神通。得大总持三昧具足得无所畏。即从座起偏袒右肩右膝着地长跪合掌白佛言。世尊。如佛所说诸佛菩萨所可成就功德智慧。无量无边百千万亿实不可说。我意犹谓故不如是大乘经典。何以故。因是大乘方等经力故能出生诸佛世尊阿耨多罗三藐三菩提。时佛赞言。善哉善哉。善男子。如是如是。如汝所说。是诸大乘方等经典。虽复成就无量功德。欲比是经不得为喻。百倍千倍百千万亿倍乃至算数譬喻所不能及。善男子。譬如从牛出乳从乳出酪。从酪出生稣。从生稣出熟稣。从熟稣出醍醐。醍醐最上若有服者众病皆除。所有诸药悉入其中。善男子。佛亦如是。从佛出生十二部经。从十二部经出修多罗。从修多罗出方等经。从方等经出般若波罗蜜。从般若波罗蜜出大涅槃。犹如醍醐。言醍醐者喻于佛性。佛性者即是如来。善男子。以是义故。说言如来所有功德无量无边不可称计

迦叶菩萨白佛言。世尊。如佛所赞大涅槃经犹如醍醐最上最妙。若有能服众病悉除。一切诸药悉入其中。我闻是已窃复思念。若有不能听受是经。当知是人为大愚痴无有善心。世尊我于今者实能堪忍。剥皮为纸刺血为墨以髓为水折骨为笔。书写如是大涅槃经。书已读诵令其通利。然后为人广说其义。世尊。若有众生贪着财物我当施财。然后以是大涅槃经劝之令读。若尊贵者先以爱语而随其意。然后渐当以是大乘大涅槃经劝之令读。若凡庶者当以威势逼之令读。若憍慢者我当为其而作仆使。随顺其意令其欢喜。然后当以大般涅槃而教导之。若有诽谤大乘经者。当以势力摧之令伏。既摧伏已然后劝之令读大涅槃经。若有爱乐大乘经者。我躬当往恭敬供养尊重赞叹。尔时佛赞迦叶菩萨。善哉善哉。汝甚爱乐大乘经典。贪大乘经爱大乘经味大乘经。信敬尊重供养大乘。善男子。汝今以此善心因缘当得超越无量无边恒河沙等诸大菩萨。在前得成阿耨多罗三藐三菩提。汝亦不久复当如我广为大众演说如是大般涅槃如来佛性诸佛所说秘密之藏。善男子。过去之世佛日未出。我于尔时作婆罗门修菩萨行。悉能通达一切外道所有经论。修寂灭行具足威仪其心清净。不为外来能生欲想之所破坏。灭嗔恚火受持常乐我净之法。周遍求索大乘经典乃至不闻方等名字。我于尔时住于雪山。其山清净流泉浴池树林药木充满其地。处处石间有清流水。多诸香花周遍严饰。众鸟禽兽不可称计。甘果滋繁种别难计。复有无量藕根甘根青木香根。我于尔时独处其中唯食诸果。食已系心思惟坐禅经无量岁。亦不闻有如来出世大乘经名。善男子。我修如是难行苦行时。释提桓因等诸天人心大惊怪。即共集会各各相谓。而说偈言

  各共相指示　　清净雪山中
  寂静离欲主　　功德庄严王
  以离贪嗔慢　　永断谄愚痴
  口初未曾说　　粗恶等语言

尔时众中有一天子名曰欢喜复说偈言

  如是离欲人　　清净勤精进
  将不求帝释　　及以诸天耶
  若是外道者　　修行诸苦行
  是人多欲求　　帝释所坐处

尔时复有一仙天子即为帝释而说偈言

  天主憍尸迦　　不应生此虑
  外道修苦行　　何必求帝处

说是偈已复作是言。憍尸迦。世有大士。为众生故不贪己身。为欲利益诸众生故。而修种种无量苦行。如是之人见生死中诸过咎故。设见珍宝满此大地诸山大海。不生贪着如视涕唾。如是大士。弃舍财宝所爱妻子。头目髓脑手足支节。所居舍宅象马车乘奴婢僮仆。亦不愿求生于天上。唯求欲令一切众生得受快乐。如我所解。如是大士清净无染众结永尽。唯欲求于阿耨多罗三藐三菩提。释提桓因复作是言。如汝言者。是人则为摄取一切世间所有众生。大仙。若此世间有佛树者。能除一切诸天世人及阿修罗烦恼毒蛇。若诸众生住是佛树阴凉中者。烦恼诸毒悉得消灭。大仙。是人若当未来世中作善逝者。我等悉当得灭无量炽然烦恼。如是之事实为难信。何以故。无量百千诸众生等发于阿耨多罗三藐三菩提心。见少微缘于阿耨多罗三藐三菩提即便动转。如水中月水动则动。犹如画像难成易坏。菩提之心亦复如是难发易坏。大仙。如有多人以诸铠仗牢自庄严欲前讨贼。临阵恐怖则便退散。无量众生亦复如是。发菩提心牢自庄严见生死过心生恐怖即便退散。大仙。我见如是无量众生发心之后皆生动转。是故我今虽见是人修于苦行无恼无热住于险道。其行清净未能信也。我今要当自往试之。知其实能堪任荷负阿耨多罗三藐三菩提大重担不。大仙。犹如车有二轮则能载用。鸟有二翼堪任飞行。是苦行者亦复如是。我虽见其坚持禁戒。未知其人有深智不。若有深智当知则能堪任荷负阿耨多罗三藐三菩提之重担也。大仙。譬如鱼母多有胎子成就者少。如庵罗树花多果少。众生发心乃有无量。及其成就少不足言。大仙。我当与汝俱往试之。大仙。譬如真金三种试已乃知其真。谓烧打磨。试彼苦行者亦当如是

尔时释提桓因。自变其身作罗刹像形甚可畏。下至雪山去其不远而便立住。是时罗刹。心无所畏勇健难当。辩才次第其声清雅。宣过去佛所说半偈

  诸行无常　　是生灭法

说是半偈已便住其前。所现形貌甚可怖畏。顾眄遍视观于四方。是苦行者。闻是半偈心生欢喜。譬如估客于险难处夜行失伴恐怖推求。还遇同侣心生欢喜踊跃无量。亦如久病未遇良医瞻病好药后卒得之。如人没海卒遇船舫。如渴乏人遇清冷水。如为怨逐忽然得脱。如久系人卒闻得出。亦如农夫炎旱值雨。亦如行人还得归家。家人见已生大欢喜。善男子。我于尔时闻是半偈心中欢喜亦复如是。即从座起以手举发。四向顾视而说是言。向所闻偈谁之所说。尔时亦更不见余人唯见罗刹。即说是言。诸开如是解脱之门。谁能雷震诸佛音声。谁于生死睡眠之中而独觉寤唱如是言。谁能于此示道生死饥馑众生无上道味。无量众生沉生死海。谁能于中作大船师。是诸众生常为烦恼重病所缠。谁能于中为作良医。说是半偈启悟我心。犹如半月渐开莲花。善男子。我于尔时更无所见唯见罗刹。复作是念将是罗刹说是偈耶。仍复生疑或非其说。何以故。是人形容甚可怖畏。若有得闻是偈句者。一切恐怖丑陋即除。何有此人形貌如是能说此偈。不应火中出于莲花。非日光中出生冷水。善男子。我于尔时复作是念。我今无智。而此罗刹或能得见过去诸佛。从诸佛所闻是半偈。我今当问。即便前至是罗刹所作如是言。善哉大士。汝于何处得是过去离怖畏者所说半偈。大士。复于何处而得如是半如意珠。大士。是半偈义乃是过去未来现在诸佛世尊之正道也。一切世间无量众生常为诸见罗网所覆。终身于此外道法中。初不曾闻如是出世十力世雄所说空义。善男子。我问是已。即答我言。大婆罗门。汝今不应问我是义。何以故。我不食来已经多日。处处求索了不能得。饥渴苦恼心乱讇语。非我本心之所知也。假使我今力能飞行虚空至郁单越。乃至天上处处求食亦不能得。以是之故我说是语。善男子。我时即复语罗刹言。大士。若能为我说是偈竟。我当终身为汝弟子。大士。汝所说者名字不终义亦不尽。以何因缘不欲说耶。夫财施者则有竭尽。法施因缘不可尽也。虽无有尽多所利益。我今闻此半偈法已心生惊疑。汝今幸可为我除断说此偈竟。我当终身为汝弟子。罗刹答言。汝智太过但自忧身。都不见念今我定为饥苦所逼。实不能说。我即问言。汝所食者。为是何物。罗刹答言。汝不足问。我若说者令多人怖。我复问言。此中独处更无有人。我不畏汝何故不说。罗刹答言。我所食者唯人暖肉。其所饮者唯人热血。自我薄福唯食此食。周遍求索困不能得。世虽多人皆有福德。兼为诸天之所守护。而我无力不能得杀。善男子。我复语言。汝但具足说是半偈。我闻偈已当以此身奉施供养。大士。我设命终。如此之身无所复用。当为虎狼鸱枭雕鹫之所啖食。然复不得一毫之福。我今为求阿耨多罗三藐三菩提。舍不坚身以易坚身。罗刹答言。谁当信汝如是之言。为八字故弃所爱身。善男子。我即答言。汝真无智。譬如有人施他凡器得七宝器。我亦如是。舍不坚身得金刚身。汝言谁当信者我今有证。大梵天王释提桓因及四天王能证是事。复有天眼诸菩萨等。为欲利益无量众生。修行大乘具六度者。亦能证知。复有十方诸佛世尊利众生者。亦能证我为八字故舍于身命。罗刹复言。汝若如是能舍身者。谛听谛听。当为汝说其余半偈。善男子。我于尔时闻是事已心中欢喜。即解己身所著鹿皮。为此罗刹敷置法座。白言。和上。愿坐此座。我即于前叉手长跪而作是言。唯愿和上。善为我说其余半偈令得具足罗刹即说

  生灭灭已　　寂灭为乐

尔时罗刹说是偈已复作是言。菩萨摩诃萨汝今已闻具足偈义。汝之所愿为悉满足。若必欲利诸众生者。时施我身。善男子。我于尔时深思此义。然后处处若石若壁若树若道书写此偈。即便更系所著衣裳。恐其死后身体露现。即上高树。尔时树神复问我言。善哉仁者。欲作何事。善男子。我时答言。我欲舍身以报偈价。树神问言。如是偈者何所利益。我时答言。如是偈句乃是过去未来现在诸佛所说开空法道。我为此法弃舍身命。不为利养名闻财宝转轮圣王四大天王释提桓因大梵天王人天中乐。为欲利益一切众生故舍此身。善男子。我舍身时复作是言。愿令一切悭惜之人。悉来见我舍离此身。若有少施起贡高者。亦令得见我为一偈舍此身命如弃草木。我于尔时说是语已。寻即放身自投树下。下未至地时。虚空之中出种种声。其声乃至阿迦尼吒。尔时罗刹还复释身。即于空中接取我身安置平地。尔时释提桓因及诸天人大梵天王。稽首顶礼于我足下。赞言。善哉善哉。真是菩萨。能大利益无量众生。欲于无明黑闇之中然大法炬。由我爱惜如来大法故相娆恼。唯愿听我忏悔罪咎。汝于未来必定成就阿耨多罗三藐三菩提愿见济度。尔时释提桓因及诸天众。顶礼我足。于是辞去忽然不现。善男子。如我往昔为半偈故舍弃此身。以是因缘便得超越足十二劫。在弥勒前成阿耨多罗三藐三菩提。善男子。我得如是无量功德。皆由供养如来正法。善男子。汝今亦尔发于阿耨多罗三藐三菩提心。则已超过无量无边恒河沙等诸菩萨上。善男子。是名菩萨住于大乘大般涅槃修于圣行

大般涅槃经卷第十四大般涅槃经卷第十五

        北凉天竺三藏昙无谶译

    梵行品第八之一

善男子。云何菩萨摩诃萨梵行。善男子。菩萨摩诃萨住于大乘大般涅槃。住七善法得具梵行。何等为七。一者知法。二者知义。三者知时。四者知足。五者自知。六者知众。七者知尊卑。善男子。云何菩萨摩诃萨知法。善男子。是菩萨摩诃萨知十二部经。谓修多罗。祇夜。授记。伽陀。优陀那。尼陀那。阿波陀那。伊帝曰(他本云目)多伽。阇陀伽。毗佛略。阿浮陀达摩。优波提舍。善男子。何等名为修多罗经。从如是我闻乃至欢喜奉行。如是一切名修多罗。何等名为祇夜经。佛告诸比丘。昔我与汝愚无智慧不能如实见四真谛。是故流转久处生死没大苦海。何等为四苦集灭道。如佛昔日为诸比丘说契经竟。尔时复有利根众生。为听法故后至佛所即便问人。如来向者为说何事。佛时知已即因本经。以偈颂曰

  我昔与汝等　　不见四真谛
  是故久流转　　生死大苦海
  若能见四谛　　则得断生死
  生有既已尽　　更不受诸有

是名祇夜经。何等名为授记经。如有经律如来说时为诸大人受佛记别。汝阿逸多。未来有王。名曰蠰佉。当于是世而成佛道。号曰弥勒。是名授记经。何等名为伽陀经。除修多罗及诸戒律。其余有说四句之偈。所谓

  诸恶莫作　　诸善奉行　　自净其意
  是诸佛教

是名伽陀经。何等名为优陀那经。如佛晡时入于禅定为诸天众广说法要。时诸比丘各作是念。如来今者为何所作。如来明旦从禅定起无有人问。以他心智即自说言。比丘当知。一切诸天寿命极长。汝诸比丘。善哉为他不求己利。善哉少欲。善哉知足。善哉寂静。如是诸经无问自说。是名优陀那经。何等名为尼陀那经。如诸经偈所因根本为他演说。如舍卫国有一丈夫罗网捕鸟。得已笼系随与水谷而复还放。世尊知其本末因缘。而说偈言

  莫轻小罪　　以为无殃　　水渧虽微
  渐盈大器

是名尼陀那经。何等名为阿波陀那经。如戒律中所说譬喻。是名阿波陀那经。何等名为伊帝曰(他本云目)多伽经。如佛所说。比丘当知。我出世时所可说者。名曰戒经。鸠留秦佛出世之时。名甘露鼓。拘那含牟尼佛时。名曰法镜。迦叶佛时。名分别空。是名伊帝曰多伽经。何等名为阇陀伽经。如佛世尊本为菩萨修诸苦行。所谓比丘当知。我于过去作鹿作罴作獐作兔。作粟散王转轮圣王。龙金翅鸟。诸如是等。行菩萨道时所可受身。是名阇陀伽。何等名为毗佛略经。所谓大乘方等经典。其义广大犹如虚空。是名毗佛略。何等名为未曾有经。如彼菩萨初出生时无人扶持。即行七步放大光明遍观十方。亦如猕猴手捧蜜器以献如来。如白项狗佛边听法。如魔波旬变为青牛行瓦钵间。令诸瓦钵互相橖触无所伤损。如佛初生入天庙时。令彼天像起下礼敬。如是等经名未曾有经。何等名为优波提舍经。如佛世尊所说诸经。若作议论分别广说辩其相貌。是名优波提舍经。菩萨若能如是了知十二部经。名为知法

云何菩萨摩诃萨知义。菩萨摩诃萨若于一切文字语言广知其义。是名知义。云何菩萨摩诃萨知时。善男子。菩萨善知如是时中任修寂静如是时中任修精进。如是时中任修舍定。如是时中任供养佛。如是时中任供养师。如是时中任修布施持戒忍辱精进禅定具足般若波罗蜜。是名知时。云何菩萨摩诃萨知足。善男子。菩萨摩诃萨知足。所谓食饮衣药行住坐卧睡寤语默。是名知足。善男子。云何菩萨摩诃萨自知。是菩萨自知我有如是信。如是戒如是多闻如是舍如是慧如是去来如是正念如是善行如是问如是答。是名自知。云何菩萨摩诃萨知众。善男子。是菩萨知如是等。是刹利众婆罗门众居士众沙门众。应于是众如是行来如是坐起。如是说法如是问答。是名知众。善男子。云何菩萨摩诃萨知人中尊卑。善男子。人有二种。一者信。二者不信。菩萨当知信者是善。其不信者不名为善。复次信有二种。一者常往僧坊。二者不往菩萨。当知其往者善。其不往者不名为善。往僧坊者复有二种。一者礼拜。二不礼拜。菩萨当知礼拜者善。不礼拜者不名为善。其礼拜者复有二种。一者听法。二者不听法。菩萨当知听法者善。不听法者不名为善。其听法者复有二种。一至心听。二不至心。菩萨当知至心听者是则名善。不至心者不名为善。至心听法复有二种。一者思义。二不思义。菩萨当知思义者善。不思义者不名为善。其思义者复有二种。一如说行。二不如说行。如说行者是则为善。不如说行不名为善。如说行者复有二种。一求声闻。不能利安饶益一切苦恼众生。二者回向无上大乘。利益多人令得安乐。菩萨应知能利多人得安乐者最上最善。善男子。如诸宝中如意宝珠最为胜妙。如诸味中甘露最上。如是菩萨于人天中最胜最上不可譬喻。善男子。是名菩萨摩诃萨住于大乘大涅槃经住七善法。菩萨住是七善法已得具梵行

复次善男子。复有梵行。谓慈悲喜舍。迦叶菩萨白佛言。世尊。若多修慈能断嗔恚。修悲心者亦断嗔恚。云何而言四无量心。推义而言则应有三。世尊。慈有三缘。一缘众生。二缘于法。三则无缘。悲喜舍心亦复如是。若从是义唯应有三不应有四。众生缘者。缘于五阴愿与其乐。是名众生缘。法缘者。缘诸众生所须之物而施与之。是名法缘。无缘者。缘于如来。是名无缘。慈者多缘贫穷众生。如来大师永离贫穷受第一乐。若缘众生则不缘佛法亦如是。以是义故缘如来者。名曰无缘。世尊。慈之所缘一切众生。如缘父母妻子亲属。以是义故。名曰众生缘。法缘者。不见父母妻子亲属。见一切法皆从缘生。是名法缘。无缘者。不住法相及众生相。是名无缘。悲喜舍心亦复如是。是故应三不应有四。世尊。人有二种。一者见行。二者爱行。见行之人多修慈悲。爱行之人多修喜舍。是故应二不应有四。世尊。夫无量者。名曰无边。边不可得故名无量。若无量者则应是一不应言四。若言四者何得无量。是故应一不应四也。佛告迦叶。善男子。诸佛如来为诸众生所宣法要。其言秘密难可了知。或为众生说一因缘。如说何等为一因缘。所谓一切有为之法。善男子。或说二种因之与果。或说三种烦恼业苦。或说四种无明诸行生与老死。或说五种所谓受爱取有及生。或说六种三世因果。或说七种谓识名色六入触受及以爱取。或说八种除无明行及生老死其余八事。或说九种如城经中。除无明行识其余九事。或说十一如为萨遮尼犍子说。除生一法其余十一。或时具说十二因缘。如王舍城为迦叶等具说十二无明乃至生老病死。善男子。如一因缘为众生故种种分别。无量心法亦复如是。善男子。以是义故于诸如来深秘行处不应生疑。善男子。如来世尊有大方便。无常说常常说无常。说乐为苦说苦为乐。不净说净净说不净。我说无我无我说我。于非众生说为众生。于实众生说非众生。非物说物物说非物。非实说实实说非实。非境说境境说非境。非生说生生说非生。乃至无明说明明说无明。色说非色非色说色。非道说道道说非道。善男子。如来以是无量方便为调众生。岂虚妄耶。善男子。或有众生贪于财货。我于其人自化其身作转轮王。于无量岁随其所须种种供给。然后教化令其安住阿耨多罗三藐三菩提。若有众生贪着五欲。于无量岁以妙五欲充足其愿。然后劝化令其安住阿耨多罗三藐三菩提。若有众生荣豪自贵。我于其人无量岁中为作仆使。趍走给侍得其心已。即复劝化令其安住阿耨多罗三藐三菩提。若有众生性悷自是须人呵谏。我于无量百千岁中教诃敦喻令其心调。然后复劝令其安住阿耨多罗三藐三菩提。善男子。如来如是于无量岁以种种方便。令诸众生安住阿耨多罗三藐三菩提。岂虚妄耶。诸佛如来虽处众恶无所染污犹如莲花。善男子。应如是知四无量义。善男子。是无量心体性有四。若有修行生大梵处。善男子。如是无量伴侣有四。是故名四。夫修慈者能断贪欲。修悲心者能断嗔恚。修喜心者能断不乐。修舍心者能断贪欲嗔恚众生。善男子。以是义故得名为四非一二三。善男子。如汝所言慈能断嗔悲亦如是。应说三者。汝今不应作如是难。何以故。善男子。恚有二种。一能夺命。二能鞭挞。修慈则能断彼夺命。修悲能除彼鞭挞者。善男子。以是义故岂非四耶。复次嗔有二种。一嗔众生。二嗔非众生。修慈心者断嗔众生。修悲心者断非众生。复次嗔有二种。一有因缘。二无因缘。修慈心者断有因缘。修悲心者断无因缘。复次嗔有二种。一者久于过去修习。二者于今现在修习。修慈心者能断过去。修悲心者断于现在。复次嗔有二种。一嗔圣人。二嗔凡夫。修慈心者断嗔圣人。修悲心者断嗔凡夫。复次嗔有二种。一上二中。修慈断上。修悲断中。善男子。以是义故则名为四。何得难言应三非四。是故迦叶。是无量心伴侣相对分别为四。复以器故应名为四器。若有慈则不得有悲喜舍心。以是义故应四无减。善男子。以行分别故应有四。若行慈时无悲喜舍。是故有四。善男子。以无量故亦得名四。夫无量者则有四种。有无量心有缘非自在。有无量心自在非缘。有无量心亦缘亦自在。有无量心非缘非自在。何等无量有缘非自在。缘于无量无边众生。而不能得自在三昧。虽得不定或得或失。何等无量自在非缘。如缘父母兄弟姊妹欲令安乐非无量缘。何等无量亦缘亦自在。谓诸佛菩萨。何等无量非缘非自在。声闻缘觉不能广缘无量众生。亦非自在。善男子。以是义故名四无量。非诸声闻缘觉所知。乃是诸佛如来境界。善男子。如是四事。声闻缘觉虽名无量少不足言。诸佛菩萨则得名为无量无边。迦叶菩萨白佛言。世尊。如是如是实如圣教。诸佛如来所有境界。非诸声闻缘觉所及。世尊。颇有菩萨住于大乘大般涅槃得慈悲心。非是大慈大悲心不。佛言有。善男子。菩萨若于诸众生中三品分别。一者亲人。二者怨憎。三者中人。于亲人中复作三品。谓上中下。怨憎亦尔。是菩萨摩诃萨于上亲中与增上乐。于中下亲亦复平等与增上乐。于上怨中与少分乐。于中怨所与中品乐。于下怨中与增上乐。菩萨如是转复修习。于上怨中与中品乐于中下怨等与增上乐。转复修习于上中下等与上乐。若上怨中与上乐者。尔时得名慈心成就。菩萨尔时于父母所及上怨中。得平等心无有差别。善男子。是名得慈非大慈也。世尊。何缘菩萨得如是慈。犹故不得名为大慈。善男子。以难成故不名大慈。何以故。久于过去无量劫中。多集烦恼未修善法。是故不能于一日中调伏其心。善男子。譬如剜豆干时锥刺。终不可着。烦恼坚硬亦复如是。虽一日夜系心不散难可调伏。又如家犬不畏于人。山林野鹿见人怖走。嗔恚难去如守家狗。慈心易失如彼野鹿。是故此心难可调伏。以是义故不名大慈。复次善男子。譬如画石其文常在。画水速灭势不久住。嗔如画石。诸善根本如彼画水。是故此心难得调伏如大火聚其明久住。电光之明不得暂停嗔如火聚。慈如电明。是故此心难得调伏。以是义故不名大慈。善男子。菩萨摩诃萨住于初地名曰大慈。何以故。善男子。最极恶者名一阐提。初住菩萨修大慈时于一阐提心无差别。不见其过故不生嗔。以是义故得名大慈。善男子。为诸众生除无利益是名大慈。欲与众生无量利乐是名大悲。于诸众生心生欢喜是名大喜。无所拥护名为大舍。若不见我法相己身。见一切法平等无二。是名大舍。自舍己乐施与他人。是名大舍。善男子。唯四无量能令菩萨增长具足六波罗蜜。其余诸行不必能尔。善男子。菩萨摩诃萨先得世间四无量心。然后乃发阿耨多罗三藐三菩提心。次第方得出世间者。善男子。因世无量得出世无量。以是义故名大无量。迦叶菩萨白佛言。世尊。除无利益与利乐者实无所为。如是思惟即是虚观无有实利。世尊。譬如比丘观不净时。见所著衣悉是皮相而实非皮。所可食啖皆作虫相而实非虫。观大豆羹作下汁想而实非粪。观所食酪犹如髓脑而实非脑。观骨碎末犹如糗相而实非糗。四无量心亦复如是。不能真实利益众生令其得乐。虽口发言与众生乐而实不得。如是之观非虚妄耶。世尊。若非虚妄实与乐者。而诸众生何故不以诸佛菩萨威德力故一切受乐。若当真实不得乐者。如佛所说我念往昔独修慈心。经此劫世七返成坏不来此生。世界成时生梵天中。世界坏时生光音天。若生梵天力势自在无能摧伏。于千梵中最胜最上名大梵王。有诸众生皆于我所生最上想。三十六返作忉利天王释提桓因。无量百千作转轮王独修慈心乃得如是人天果报。若不实者云何得与此义相应。佛言。善哉善哉。善男子。汝真勇猛无所畏惧。即为迦叶。而说偈言

  若于一众生　　不生嗔恚心
  而愿与彼乐　　是名为慈善
  一切众生中　　若起于悲心
  是名圣种性　　得福报无量
  设使五通仙　　悉满此大地
  有大自在天　　奉施其所安
  象马种种物　　所得福报果
  不及修一慈　　十六分中一

善男子。夫修慈者实非妄想谛是真实。若是声闻缘觉之慈是名虚妄。诸佛菩萨真实不虚云何知耶。善男子。菩萨摩诃萨修行如是大涅槃者。观土为金观金为土。地作水相水作地相。水作火相火作水相。地作风相风作地相。随意成就无有虚妄。观实众生为非众生。观非众生为实众生。悉随意成无有虚妄。善男子。当知菩萨四无量心。是实思惟非不真实。复次善男子。云何名为真实思惟。谓能断除诸烦恼故。善男子。夫修慈者能断贪欲。修悲心者能断嗔恚。修喜心者能断不乐。修舍心者能断贪恚及众生相。以是故名真实思惟。复次善男子。菩萨摩诃萨四无量心。能为一切诸善根本。善男子。菩萨摩诃萨若不得见贫穷众生无缘生慈。若不生慈则不能起惠施之心。以施因缘令诸众生得安隐乐。所谓食饭车乘衣服花香床卧舍宅灯明。如是施时心无系缚不生贪着。必定回向阿耨多罗三藐三菩提。其心尔时无所依止。妄想永断不为怖畏名称利养。不求人天所受快乐。不生憍慢不望返报不为诳他。故行布施不求富贵。凡行施时不见受者持戒破戒是田非田。此是知识此非知识。施时不见是器非器。不择日时是处非处。亦复不计饥馑丰乐。不见因果此是众生此非众生是福非福。虽复不见施者受者及以财物。乃至不见断及果报。而常行施无有断绝。善男子。菩萨若见持戒破戒乃至果报终不能施。若不布施则不具足檀波罗蜜。若不具足檀波罗蜜。则不能成阿耨多罗三藐三菩提。善男子。譬如有人身被毒箭。其人眷属欲令安隐为除毒故。即命良医而为拔箭。彼人方言且待莫触。我今当观。如是毒箭从何方来。谁之所射为是刹利婆罗门毗舍首陀。复更作念。是何木耶竹耶柳耶。其镞铁者何冶所出刚耶柔耶。其毛羽者是何鸟翼鸟鸱鹫耶。所有毒者为从作生自然而有。为是人毒恶蛇毒耶。如是痴人竟未能知寻便命终。善男子。菩萨亦尔。若行施时分别受者持戒破戒乃至果报终不能施。若不能施则不具足檀波罗蜜。若不具足檀波罗蜜。则不能成阿耨多罗三藐三菩提

善男子。菩萨摩诃萨行布施时。于诸众生慈心平等犹如子想。又行施时于诸众生起悲愍心。譬如父母瞻视病子。行施之时其心欢喜。犹如父母见子病愈。既施之后其心放舍。犹如父母见子长大能自在活。是菩萨摩诃萨于慈心中布施食时。常作是愿。我今所施悉与一切众生共之。以是因缘令诸众生得大智食。勤进回向无上大乘。愿诸众生得善智食。不求声闻缘觉之食。愿诸众生得法喜食不求爱食。愿诸众生悉得般若波罗蜜食皆令充满。摄取无碍增上善根。愿诸众生悟解空相得无碍身犹如虚空。愿诸众生常为受者。怜愍一切为众福田。善男子。菩萨摩诃萨修慈心时。凡所施食应当坚发如是等愿。复次善男子。菩萨摩诃萨于慈心中布施浆时。当作是愿。我今所施悉与一切众生共之。以是因缘令诸众生趣大乘河饮八味水。速涉无上菩提之道。离于声闻缘觉枯竭。渴仰求于无上佛乘。断烦恼渴渴仰法味。离生死爱爱乐大乘大般涅槃。具足法身得诸三昧。入于甚深智慧大海。愿诸众生得甘露味菩提出世离欲寂静如是诸味。愿诸众生具足无量百千法味。具法味已得见佛性。见佛性已能雨法雨。雨法雨已佛性遍覆犹如虚空。复令其余无量众生得一法味。所谓大乘非诸声闻辟支佛味。愿诸众生得一甜味。无有六种差别之味。愿诸众生唯求法味无碍佛法所行之味。不求余味。善男子。菩萨摩诃萨于慈心中布施浆时。应当坚发如是等愿。复次善男子。菩萨摩诃萨于慈心中施车乘时。应作是愿。我今所施悉与一切众生共之。以是因缘普令众生成于大乘。得住大乘不退于乘不动转乘金刚座乘。不求声闻辟支佛乘。向于佛乘无能伏乘。无羸乏乘不退没乘。无上乘十力乘。大功德乘未曾有乘。希有乘难得乘。无边乘知一切乘。善男子。菩萨摩诃萨于慈心中施车乘时。常应如是坚发誓愿。复次善男子。菩萨摩诃萨于慈心中布施衣时。当作是愿。我今所施悉与一切众生共之。以是因缘令诸众生得惭愧衣。法界覆身裂诸见衣。衣服离身一尺六寸得金色身。所受诸触柔软无碍。光色润泽皮肤细软。常光无量无色离色。愿诸众生皆悉普得无色之身。过一切色得入无色大般涅槃。善男子。菩萨摩诃萨布施衣时。应当如是坚发誓愿

复次善男子。菩萨摩诃萨于修慈中。布施花香涂香末香诸杂香时。应作是愿。我今所施悉与一切众生共之。以是因缘令诸众生一切皆得佛花三昧。七觉妙鬘系其首顶。愿诸众生形如满月。所见诸色微妙第一。愿诸众生皆成一相百福庄严。愿诸众生随意得见可意之色。愿诸众生常遇善友得无碍香离诸臭秽。愿诸众生具诸善根无上珍宝。愿诸众生相视和悦无有忧苦。众善各备不相忧念。愿诸众生戒香具足。愿诸众生持无碍戒。香气馚馥充满十方。愿诸众生得坚牢戒无悔之戒。一切智戒。离诸破戒悉得无戒未曾有戒。无师戒无作戒无荒戒无污染戒竟已戒究竟戒。得平等戒。于香涂身及以斫刺等无憎爱。愿诸众生得无上戒大乘之戒非小乘戒。愿诸众生悉得具足尸波罗蜜。犹如诸佛所成就戒。愿诸众生悉为布施持戒忍辱精进禅智之所薰修。愿诸众生悉得成于大般涅槃微妙莲花。其花香气充满十方。愿诸众生纯食大乘大般涅槃无上香馔。犹蜂采花但取香味。愿诸众生悉得成就无量功德所薰之身。善男子。菩萨摩诃萨于慈心中施花香时。常当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中施床敷时。应作是愿。我今所施悉与一切众生共之。以是因缘令诸众生得天中天所卧之床。得大智慧坐四禅处。卧于菩萨所卧之床。不卧声闻辟支佛床离卧恶床。愿诸众生得安乐卧离生死床。成大涅槃师子卧床。愿诸众生坐此床已。复为其余无量众生示现神通师子游戏。愿诸众生住此大乘大宫殿中。为诸众生演说佛性。愿诸众生坐无上床。不为世法之所降伏。愿诸众生得忍辱床。离于生死饥馑冻饿。愿诸众生得无畏床。永离一切烦恼怨贼。愿诸众生得清净床。专求无上正真之道。愿诸众生得善法床。常为善友之所拥护。愿诸众生得右胁卧床。依因诸佛所行之法。善男子。菩萨摩诃萨于慈心中施床敷时。应当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中施舍宅时常作是愿。我今所施悉与一切众生共之。以是因缘令诸众生处大乘舍。修行善友所行之行。修大悲行六波罗蜜行大正觉行一切菩萨所行道行。无边广大如虚空行。愿诸众生皆得正念远离恶念。愿诸众生悉得安住常乐我净永离四倒。愿诸众生悉皆受持出世文字。愿诸众生必为无上一切智器。愿诸众生悉得入于甘露屋宅。愿诸众生初中后心常入大乘涅槃屋宅。愿诸众生于未来世常处菩萨所居宫殿。善男子。菩萨摩诃萨于慈心中施舍宅时。常当坚发如是誓愿

复次善男子。菩萨摩诃萨于慈心中施灯明时。常作是愿。我今所施悉与一切众生共之。以是因缘令诸众生光明无量安住佛法。愿诸众生常得照明。愿诸众生得色微妙光泽第一。愿诸众生其目清净无诸翳网。愿诸众生得大智炬。善解无我无众生相无人无命。愿诸众生皆得睹见清净佛性犹如虚空。愿诸众生肉眼清净彻见十方恒沙世界。愿诸众生得佛光明普照十方。愿诸众生得无碍明。皆悉得见清净佛性。愿诸众生得大智明。破一切闇及一阐提。愿诸众生得无量光。普照无量诸佛世界。愿诸众生然大乘灯离二乘灯。愿诸众生所得光明灭无明闇。过于千日普照之功。愿诸众生得火珠明悉灭三千大千世界所有黑闇。愿诸众生具足五眼悟诸法相成无师觉。愿诸众生无见无明愿诸众生悉得大乘大般涅槃微妙光明。示悟众生真实佛性。善男子。菩萨摩诃萨于慈心中施灯明时。常应勤发如是誓愿

善男子。一切声闻缘觉菩萨诸佛如来。所有善根慈为根本。善男子。菩萨摩诃萨修习慈心。能生如是无量善根。所谓不净出息入息无常生灭。四念处七方便三观处十二因缘无我等观。暖法顶法忍法世第一法。见道修道正勤如意诸根诸力七菩提分八圣道。四禅四无量心八解脱八胜处。一切入空无相愿无诤三昧。知他心智及诸神通知本际智。声闻智缘觉智菩萨智佛智。善男子。如是等法慈为根本。善男子。以是义故。慈是真实非虚妄也。若有人问谁是一切诸善根本。当言慈是。以是义故慈是真实非虚妄也善男子。能为善根者名实思惟。实思惟者即名为慈。慈即如来慈即大乘。大乘即慈慈即如来。善男子。慈即菩提道。菩提道即如来。如来即慈。善男子。慈即大梵大梵即慈。慈即如来。善男子。慈者能为一切众生而作父母。父母即慈慈即如来。善男子。慈者乃是不可思议。诸佛境界不可思议。诸佛境界即是慈也。当知慈者即是如来。善男子。慈者即是众生佛性。如是佛性久为烦恼之所覆蔽故。令众生不得睹见。佛性即慈慈即如来。善男子。慈即大空大空即慈。慈即如来。善男子。慈即虚空虚空即慈。慈即如来。善男子。慈即是常常即是法。法即是僧僧即是慈。慈即如来。善男子。慈即是乐乐即是法。法即是僧僧即是慈。慈即如来。善男子。慈即是净净即是法。法即是僧僧即是慈。慈即如来。善男子。慈即是我我即是法。法即是僧僧即是慈。慈即如来。善男子。慈即甘露甘露即慈。慈即佛性佛性即法。法即是僧僧即是慈。慈即如来。善男子。慈者即是一切菩萨无上之道。道即是慈慈即如来。善男子。慈者即是诸佛世尊无量境界。无量境界即是慈也。当知是慈即是如来

善男子。慈若无常无常即慈。当知是慈是声闻慈。善男子。慈若是苦苦即是慈。当知是慈是声闻慈。善男子。慈若不净不净即慈。当知是慈是声闻慈。善男子。慈若无我无我即慈。当知是慈是声闻慈。善男子。慈若妄想妄想即慈。当知是慈是声闻慈。善男子。慈若不名檀波罗蜜。非檀之慈当知是慈是声闻慈。乃至般若波罗蜜亦复如是。善男子。慈若不能利益众生。如是之慈是声闻慈。善男子。慈若不入一乘之道。当知是慈是声闻慈。善男子。慈若不能觉了诸法。当知是慈是声闻慈。善男子。慈若不能见如来性。当知是慈是声闻慈。善男子。慈若见法悉是有相。当知是慈是声闻慈。善男子。慈若有漏。有漏慈者是声闻慈。善男子。慈若有为有为之慈是声闻慈。善男子。慈若不能住于初住。非初住慈当知即是声闻慈也。善男子。慈若不能得佛十力四无所畏。当知是慈是声闻慈。善男子。慈若能得四沙门果。当知是慈是声闻慈也

善男子。慈若有无非有非无。如是之慈非诸声闻辟支佛等所能思议。善男子。慈若不可思议。法不可思议。佛性不可思议。如来亦不可思议。善男子。菩萨摩诃萨住于大乘大般涅槃。修如是慈。虽复安于睡眠之中而不睡眠勤精进故。虽常觉悟亦无觉悟以无眠故。于睡眠中诸天虽护亦无护者不行恶故。眠不恶梦无有不善离睡眠故。命终之后虽生梵天亦无所生得自在故。善男子。夫修慈者。能得成就如是无量无边功德。善男子。是大涅槃微妙经典。亦能成就如是无量无边功德。诸佛如来亦得成就如是无量无边功德

大般涅槃经卷第十五大般涅槃经卷第十六

        北凉天竺三藏昙无谶译

    梵行品第八之二

迦叶菩萨白佛言。世尊。菩萨摩诃萨所有思惟悉是真实。声闻缘觉非真实者。一切众生何故不以菩萨威力等受快乐。若诸众生实不得乐。当知菩萨所修慈心为无利益。佛言。善男子。菩萨之慈非不利益。善男子。有诸众生或必受苦或有不受。若有众生必受苦者。菩萨之慈为无利益谓一阐提。若有受苦不必定者。菩萨之慈则为利益。令彼众生悉受快乐。善男子。譬如有人遥见师子虎豹豺狼罗刹鬼等自然生怖。夜行见杌亦生怖畏。善男子。如是诸人自然怖畏。众生如是见修慈者自然受乐。善男子。以是义故。菩萨修慈是实思惟非无利益

善男子。我说是慈有无量门。所谓神通。善男子。如提婆达教阿阇世欲害如来。是时我入王舍大城次第乞食。阿阇世王即放护财狂醉之象。欲令害我及诸弟子。其象尔时蹋杀无量百千众生。众生死已多有血气。是象嗅已狂醉倍常。见我翼从被服赤色。谓呼是血而复见趣。我弟子中未离欲者。四怖驰走唯除阿难。尔时王舍大城之中一切人民。同时举声啼哭号泣作如是言。怪哉如来今日灭没。如何正觉一旦散坏。是时调达心生欢喜。瞿昙沙门灭没甚善。从今已往真是不现。快哉此计我愿得遂。善男子。我于尔时为欲降伏护财象故。即入慈定舒手示之。即于五指出五师子。是象见已其心怖畏寻即失粪。举身投地敬礼我足。善男子。我于尔时手五指头实无师子。乃是修慈善根力故令彼调伏。复次善男子。我欲涅槃始初发足向拘尸那城。有五百力士。于其中路平治扫洒。中有一石众欲举弃尽力不能。我时怜愍即起慈心。彼诸力士。寻即见我以足母指举此大石掷置虚空。还以手接安置右掌。吹令碎末复还聚合。令彼力士贡高心息。即为略说种种法要。令其俱发阿耨多罗三藐三菩提心。善男子。如来尔时实不以指举此大石在虚空中。还置右掌吹令碎末复合如本。善男子。当知即是慈善根力。令诸力士见如是事

复次善男子。此南天竺有一大城名首波罗。于是城中有一长者名曰卢至。为众导主已于过去无量佛所殖众善本。善男子。彼大城中一切人民信伏邪道奉事尼犍。我时欲度彼长者故。从王舍城至彼城邑。其路中间相去六十五由旬。步涉而往为欲化度彼诸人故。彼众尼犍闻我欲至首波罗城。即作是念。沙门瞿昙若至此者。此诸人民便当舍我更不供给。我等穷悴奈何自活。诸尼犍辈各各分散告彼城人。沙门瞿昙今欲来此。然彼沙门委弃父母东西驰骋。所至之处能令土地谷米不登。人民饥馑死亡者众。病瘦相寻无可救解。瞿昙无赖。纯将诸恶罗刹鬼神以为侍从。无父无母孤穷之人而来咨启为作门徒。所可教诏纯说虚空。随其至处初无安乐。彼人闻已即怀怖畏。头面敬礼尼犍子足白言。大师。我等今者当设何计。尼犍答言。沙门瞿昙性好丛林流泉清水。外设有者宜应破坏。汝等便可相与出城。诸有之处斫伐令尽莫使有遗。流泉井池悉置粪尸。坚闭城门各严器仗。当壁防护勤自固守。彼设来者莫令得前。若不前者汝当安隐。我等亦当作种种术。令彼瞿昙复道还去。彼诸人民闻是语已。敬诺施行斩伐树木污辱诸水。庄严器仗牢自防护。善男子。我于尔时至彼城已。不见一切树木丛林。唯见诸人庄严器仗当壁自守。见是事已寻生怜愍慈心向之。所有树木还生如本。复更生长其余诸树不可称计。河池井泉其水清净。盈满其中如青琉璃。生众杂花弥覆其上。变其城壁为绀琉璃。城内人民悉得彻见。我及大众。门自开辟无能制者。所严器仗变成杂花。卢至长者而为上首。与其人民俱共相随往至佛所。我即为说种种法要。令彼诸人一切皆发阿耨多罗三藐三菩提心。善男子。我于尔时。实不化作种种树木清净流水盈满河池。变其本城为绀琉璃。令彼人民彻见于我。开其城门器仗为花。善男子。当知皆是慈善根力。能令彼人见如是事

复次善男子。舍卫城中。有婆罗门女姓婆私吒。唯有一子爱之甚重。遇病命终。尔时女人愁毒入心狂乱失性。裸身无耻游行四衢。啼哭失声唱言。子子。汝何处去。周遍城邑无有疲已。而是女人已于先佛殖众德本。善男子。我于是女起慈愍心。是时女人即得见我便生子想。还得本心前抱我身呜唼我口。我时即告侍者阿难。汝可持衣与是女人。既与衣已便为种种说诸法要。是女闻法欢喜踊跃。发阿耨多罗三藐三菩提心。善男子。我于尔时实非彼子。彼非我母亦无抱持。善男子。当知皆是慈善根力。令彼女人见如是事

复次善男子。波罗奈城有优婆夷。字曰摩诃斯那达多。已于过去无量先佛种诸善根。是优婆夷。夏九十日请命众僧奉施医药。是时众中有一比丘。身婴重病良医诊之当须肉药。若得肉者病则可除。若不得肉命将不全。时优婆夷闻医此言。寻持黄金遍至市[厂@黑]。唱如是言。谁有肉卖吾以金买。若有肉者当等与金。周遍城市求不能得。是优婆夷寻自取刀割其髀肉。切以为臛下种种香送病比丘。比丘服已病即得差。是优婆夷患疮苦恼不能堪忍。即发声言。南无佛陀南无佛陀。我于尔时在舍卫城闻其音声。于是女人起大慈心。是女寻见我持良药涂其疮上还合如本。我即为其种种说法。闻法欢喜发阿耨多罗三藐三菩提心。善男子。我于尔时实不往至波罗奈城。持药涂是优婆夷疮。善男子。当知皆是慈善根力。令彼女人见如是事

复次善男子。调达恶人贪不知足。多服稣故头痛腹痛。受大苦恼不能堪忍。发如是言。南无佛陀南无佛陀。我时住在优禅尼城闻其音声即生慈心。尔时调达寻便见我往至其所。手摩头腹授与盐汤而令服之。服已平复。善男子。我实不往调婆达所。摩其头腹授汤令服。善男子。当知皆是慈善根力。令调婆达见如是事

复次善男子。憍萨罗国有诸群贼其数五百。群党抄劫为害滋甚。波斯匿王患其纵暴遣兵伺捕。得已挑目遂着黑闇丛林之下。是诸群贼已于先佛殖众德本。既失目已受大苦恼。各作是言。南无佛陀南无佛陀。我等今者无有救护啼哭号啕。我时住在祇洹精舍。闻其音声即生慈心。时有凉风吹香山中种种香药满其眼眶。寻还得眼如本不异。诸贼开眼即见如来。住立其前而为说法。贼闻法已发阿耨多罗三藐三菩提心。善男子。我于尔时实不作风吹香山中种种香药。住其人前而为说法。善男子。当知皆是慈善根力。令彼群贼见如是事。复次善男子。琉璃太子以愚痴故。废其父王自立为主。复念宿嫌多害释种。取万二千释种诸女。刖劓耳鼻断截手足推之坑堑。时诸女人身受苦恼。作如是言。南无佛陀南无佛陀。我等今者无有救护复大号啕。是诸女人已于先佛种诸善根。我于尔时在竹林中。闻其音声即起慈心。诸女尔时见我来至迦毗罗城。以水洗疮以药傅之苦痛寻除。耳鼻手足还复如本。我时即为略说法要。悉令俱发阿耨多罗三藐三菩提心。即于大爱道比丘尼所出家受具足戒。善男子。如来尔时实不往至迦毗罗城。以水洗疮傅药止苦。善男子。当知皆是慈善根力。令彼女人见如是事。悲喜之心亦复如是。善男子。以是义故菩萨摩诃萨修慈思惟。即是真实非虚妄也。善男子。夫无量者不可思议。菩萨所行不可思议。诸佛所行亦不可思议。是大乘典大涅槃经亦不可思议

复次善男子。菩萨摩诃萨修慈悲喜已。得住极爱一子之地。善男子。云何是地名曰极爱复名一子。善男子。譬如父母见子安隐心大欢喜。菩萨摩诃萨住是地中亦复如是。视诸众生同于一子。见修善者生大欢喜。是故此地名曰极爱。善男子。譬如父母见子遇患心生苦恼。愍之愁毒初无舍离。菩萨摩诃萨住是地中亦复如是。见诸众生为烦恼病之所缠切。心生愁恼忧念如子。身诸毛孔血皆流出。是故此地名为一子。善男子。如人小时拾取土块粪秽瓦石枯骨木枝置于口中。父母见已恐为其患。左手捉头右手挑出。菩萨摩诃萨住是地中亦复如是。见诸众生法身未增。或行身口意业不善。菩萨见已则以智手拔之令出。不欲令彼流转生死受诸苦恼。是故此地复名一子。善男子。譬如父母所爱之子舍而终亡。父母愁恼愿与并命。菩萨亦尔。见一阐提堕于地狱。亦愿与俱生地狱中。何以故。是一阐提若受苦时。或生一念改悔之心。我即当为说种种法。令彼得生一念善根。是故此地复名一子。善男子。譬如父母唯有一子。其子睡寤行住坐卧心常念之。若有罪咎善言诱喻不加其恶。菩萨摩诃萨亦复如是。见诸众生若堕地狱畜生饿鬼。或人天中造作善恶心常念之初不放舍。若行诸恶终不生嗔以恶加之。是故此地复名一子迦叶菩萨白佛言。世尊。如佛所说其言秘密。我今智浅云何能解。若诸菩萨住一子地能如是者。云何如来昔为国王行菩萨时。断绝尔所婆罗门命。若得此地则应护念。若不得者复何因缘不堕地狱。若使等视一切众生同于子想如罗睺罗。何故复向提婆达多说如是言。痴人无羞食人涕唾。令彼闻已生于嗔恨起不善心出佛身血。提婆达多造是恶已。如来复记当堕地狱一劫受罪。世尊。如是之言云何于义不相违背。世尊。须菩提者住虚空地。凡欲入城求乞饮食要先观人。若有于己生嫌嫉心则止不行。乃至极饥犹不行乞。何以故。是须菩提常作是念。我忆往昔于福田所生一恶念。由是因缘堕大地狱受种种苦。我今宁饥终日不食。终不令彼于我起嫌堕于地狱受苦恼也。复作是念。若有众生嫌我立者。我当终日端坐不起。若有众生嫌我坐者。我当终日立不移处行卧亦尔。是须菩提护众生故尚起是心何况菩萨。菩萨若得一子地者。何缘如来出是粗言。使诸众生起重恶心。善男子。汝今不应作如是难言。佛如来为诸众生作烦恼因缘。善男子。假使蚊嘴能尽海底。如来终不为诸众生作烦恼因缘。善男子。假令大地悉为非色。水为坚相火为冷相风为住相。三宝佛性及以虚空作无常相。如来终不为诸众生作烦恼因缘。善男子。假使毁犯四重禁罪及一阐提谤正法者。现身得成十力无畏三十二相八十种好。如来终不为诸众生作烦恼因缘。善男子。假使声闻辟支佛等常住不变。如来终不为诸众生作烦恼因缘。善男子。假使十住诸菩萨等。犯四重禁作一阐提诽谤正法。如来终不为诸众生作烦恼因缘。善男子。假使一切无量众生丧灭佛性。如来究竟入般涅槃。如来终不为诸众生作烦恼因缘。善男子。假使掷罥能系缚风。齿能破铁爪坏须弥。如来终不为诸众生作烦恼因缘。宁与毒蛇同共一处。内其两手饿师子口。佉陀罗炭用洗浴身。不应发言如来世尊为诸众生作烦恼因缘。善男子。如来真实能为众生断除烦恼。终不为作烦恼因也

善男子。如汝所言如来往昔杀婆罗门者。善男子。菩萨摩诃萨乃至蚁子尚不故杀。况婆罗门。菩萨常作种种方便。惠施众生无量寿命。善男子。夫施食者则为施命。菩萨摩诃萨行檀波罗蜜时。常施众生无量寿命。善男子。修不杀戒得寿命长。菩萨摩诃萨行尸波罗蜜时。则为施与一切众生无量寿命。善男子。慎口无过得寿命长。菩萨摩诃萨行羼提波罗蜜时。常劝众生莫生怨想。推直于人引曲向己无所诤讼得寿命长。是故菩萨行羼提波罗蜜时。已施众生无量寿命。善男子。精勤修善得寿命长。菩萨摩诃萨行毗梨耶波罗蜜时。常劝众生勤修善法。众生行已得无量寿命。是故菩萨行毗梨耶波罗蜜时。已施众生无量寿命。善男子。修摄心者得寿命长。菩萨摩诃萨行禅波罗蜜时。劝诸众生修平等心。众生行已得寿命长。是故菩萨行禅波罗蜜时。已施众生无量寿命。善男子。于诸善法不放逸者得寿命长。菩萨摩诃萨行般若波罗蜜时。劝诸众生于诸善法不生放逸。众生行已以是因缘得寿命长。是故菩萨行般若波罗蜜时。已施众生无量寿命。善男子。以是义故菩萨摩诃萨于诸众生终无夺命。善男子。汝向所问杀婆罗门时得是地不。善男子。时我已得。以爱念故断其命根非恶心也。善男子。譬如父母唯有一子爱之甚重犯官宪制。是时父母以怖畏故若摈若杀。虽复摈杀无有恶心。菩萨摩诃萨为护正法亦复如是。若有众生谤大乘者。即以鞭挞苦加治之或夺其命。欲令改往遵修善法。菩萨常当作是思惟。以何因缘能令众生发起信心。随其方便要当为之。诸婆罗门命终之后生阿鼻地狱。要有三念。一者自念我从何处而来生此。即便自知从人道中来。二者自念我今所生为是何处。即便自知是阿鼻狱。三者自念乘何业缘而来生此。即便自知乘谤方等大乘经典不信因缘。为国主所杀而来生此。念是事已即于大乘方等经典生信敬心。寻时命终生甘露鼓如来世界。于彼寿命具足十劫。善男子。以是义故我于往昔乃与是人十劫寿命。云何名杀。善男子。有人掘地刈草斫树。斩截死尸骂詈鞭挞。以是业缘堕地狱不。迦叶菩萨白佛言。世尊。如我解佛所说义者应堕地狱。何以故。如佛昔为声闻说法。汝诸比丘于余焦木莫生恶心。何以故。一切众生因恶心故堕于地狱尔时佛赞迦叶菩萨。善哉善哉。如汝所说。应善受持。善男子。若因恶心堕地狱者。菩萨尔时实无恶心。何以故。菩萨摩诃萨于一切众生乃至虫蚁。悉生怜愍利益心故。所以者何。善知因缘诸方便故。以方便力欲令众生种诸善根。善男子。以是义故。我于尔时以善方便虽夺其命而非恶心。善男子。婆罗门法若杀蚁子满足十车无有罪报。蚊虻蚤虱猫狸师子虎狼熊罴诸恶虫兽。及余能为众生害者杀满十车。鬼神罗刹拘槃茶迦罗富单那颠狂干枯诸鬼神等。能为众生作娆害者。有夺其命悉无罪报。若杀恶人则有罪报。杀已不悔则堕饿鬼。若能忏悔三日断食其罪消灭无有遗余。若杀和上害其父母女人及牛。无数千年在地狱中。善男子。佛及菩萨知杀有三。谓下中上。下者蚁子乃至一切畜生。唯除菩萨示现生者。善男子。菩萨摩诃萨以愿因缘示受畜生是名下杀。以下杀因缘堕于地狱畜生饿鬼具受下苦。何以故。是诸畜生有微善根。是故杀者具受罪报是名下杀。中杀者从凡夫人至阿那含是名为中。以是业因堕于地狱畜生饿鬼。具受中苦是名中杀。上杀者。父母乃至阿罗汉辟支佛毕定菩萨。是名为上。以是业因缘故堕于阿鼻大地狱中。具受上苦。是名上杀。善男子。若有能杀一阐提者。则不堕此三种杀中。善男子。彼诸婆罗门等一切皆是一阐提也。譬如掘地刈草斫树。斩截死尸骂詈鞭挞无有罪报。杀一阐提亦复如是无有罪报。何以故。诸婆罗门乃至无有信等五根。是故虽杀不堕地狱

善男子。汝先所言如来何故骂提婆达多痴人食唾。汝亦不应作如是问何以故。诸佛世尊凡所发言不可思议。善男子。或有实语为世所爱。非时非法不为利益。如是之言我终不说。善男子。或复有言粗犷虚妄。非时非法闻者不爱不能利益。我亦不说。善男子。若有语言。虽复粗犷真实不虚。是时是法能为一切众生利益。闻虽不悦我要说之。何以故。诸佛世尊应正遍知知方便故。善男子。如我一时游彼圹野聚落丛树在其林下。有一鬼神即名圹野。纯食肉血多杀众生。复于其聚日食一人。善男子。我于尔时为彼鬼神广说法要。然彼暴恶愚痴无智不受教法。我即化身为大力鬼。动其宫殿令不安所。彼鬼于时将其眷属出其宫殿欲来拒逆。鬼见我时即失心念。惶怖躄地迷闷断绝。犹如死人。我以慈愍手摩其身即还起坐。作如是言。快哉今日还得身命。是大神王具大威德。有慈愍心赦我愆咎。即于我所生善信心。我即还复如来之身。复更为说种种法要。令彼鬼神受不杀戒。即于是日圹野村中有一长者次应当死。村人已送付彼鬼神。鬼神得已即以施我。我既受已便为长者。更立名字名手长者。尔时彼鬼即白我言。世尊。我及眷属唯仰血肉以自存活。今以戒故当云何活。我即答言。从今当敕声闻弟子。随有修行佛法之处。悉当令其施汝饮食。善男子。以是因缘为诸比丘制如是戒。汝等从今常当施彼圹野鬼食。若有住处不能施者。当知是辈非我弟子。即是天魔徒党眷属。善男子。如来为欲调伏众生故。示如是种种方便。非故令彼生怖畏也。善男子。我亦以木打护法鬼。又于一时在一山上。推羊头鬼令堕山下。复于树头扑护猕猴鬼。令护财象见五师子。使金刚神怖萨遮尼犍。亦以针刺箭毛鬼身。虽作如是。亦不令彼诸鬼神等有灭没者。直欲令彼安住正法。故示如是种种方便。善男子。我于尔时实不骂辱提婆达多。提婆达多亦不愚痴食人[口*弟]唾。亦不生于恶趣之中阿鼻地狱受罪一劫。亦不坏僧出佛身血。亦不违犯四重之罪诽谤正法大乘经典非一阐提。亦非声闻辟支佛也。善男子。提婆达多者。实非声闻缘觉境界。唯是诸佛之所知见。善男子。是故汝今不应难言。如来何缘呵责骂辱提婆达多。汝于诸佛所有境界。不应如是生于疑网

迦叶菩萨白佛言。世尊。譬如甘蔗数数煎煮得种种味。我亦如是从佛数闻多得法味。所谓出家味离欲味寂灭味道味。世尊。譬如真金数数烧打融消炼治。转更明净调和柔软。光色微妙其价难量。然后乃为人天宝重。世尊。如来亦尔。郑重咨问则得闻见甚深之义。令深行者受持奉修。无量众生发阿耨多罗三藐三菩提心。然后为诸人天所宗恭敬供养

尔时佛赞迦叶菩萨。善哉善哉。菩萨摩诃萨。为欲利益诸众生故。咨启如来如是深义。善男子。以是义故。我随汝意说于大乘方等甚深秘密之法。所谓极爱如一子地

迦叶菩萨白佛言。世尊。若诸菩萨修慈悲喜得一子地者。修舍心时复得何地。佛言。善哉善哉。善男子。汝善知时。知我欲说汝则咨问。菩萨摩诃萨修舍心时。则得住于空平等地如须菩提。善男子。菩萨摩诃萨住空平等地。则不见有父母兄弟姊妹儿息亲族知识怨憎中人。乃至不见阴界诸入众生寿命。善男子。譬如虚空无有父母兄弟妻子。乃至无有众生寿命。一切诸法亦复如是。无有父母乃至寿命。菩萨摩诃萨见一切法亦复如是。其心平等如彼虚空。何以故。善能修习诸空法故。迦叶菩萨白佛言。世尊。云何名空。善男子。空者。所谓内空外空内外空有为空无为空无始空性空无所有空第一义空空空大空。菩萨摩诃萨云何观于内空。是菩萨摩诃萨观内法空。是内法空谓无父母怨亲中人众生寿命常乐我净如来法僧所有财物。是内法中虽有佛性。而是佛性非内非外。所以者何。佛性常住无变易故。是名菩萨摩诃萨观于内空。外空者。亦复如是无有内法。内外空者亦复如是。善男子。唯有如来法僧佛性不在二空。何以故。如是四法常乐我净。是故四法不名为空。是名内外俱空。善男子。有为空者。有为之法悉皆是空。所谓内空外空内外空常乐我净空。众生寿命如来法僧第一义空。是中佛性非有为法。是故佛性非有为法空。是名有为空。善男子。云何菩萨摩诃萨观无为空。是无为法悉皆是空。所谓无常苦不净无我。阴界入众生寿命相。有为有漏内法外法。无为法中佛等四法。非有为非无为。性是善故非无为。性常住故非有为。是名菩萨观无为空。云何菩萨摩诃萨观无始空。是菩萨摩诃萨见生死无始皆悉空寂。所谓空者常乐我净皆悉空寂无有变易。众生寿命三宝佛性及无为法。是名菩萨观无始空。云何菩萨观于性空。是菩萨摩诃萨观一切法本性皆空。谓阴界入常无常苦乐净不净我无我。观如是等一切诸法不见本性。是名菩萨摩诃萨观于性空。云何菩萨摩诃萨观无所有空。如人无子言舍宅空。毕竟观空无有亲爱。愚痴之人言诸方空。贫穷之人言一切空。如是所计或空或非空。菩萨观时如贫穷人一切皆空。是名菩萨摩诃萨观无所有空。云何菩萨摩诃萨观第一义空。善男子。菩萨摩诃萨观第一义时。是眼生时无所从来。及其灭时去无所至。本无今有。已有还无。推其实性无眼无主。如眼无性一切诸法亦复如是。何等名为第一义空。有业有报不见作者。如是空法名第一义空。是名菩萨摩诃萨观第一义空。云何菩萨摩诃萨观于空空。是空空中乃是声闻辟支佛等所。迷没处。善男子。是有是无。是名空空。是是非是是。是名空空。善男子。十住菩萨尚于是中通达少分犹如微尘。况复余人。善男子。如是空空。亦不同于声闻所得空空三昧。是名菩萨观于空空。善男子。云何菩萨摩诃萨观于大空。善男子。言大空者。谓般若波罗蜜是名大空。善男子。菩萨摩诃萨得如是空门。则得住于虚空等地。善男子。我今于是大众之中说如是等诸空义时。有十恒河沙等菩萨摩诃萨。即得住于虚空等地。善男子。菩萨摩诃萨住是地已。于一切法中无有滞碍系缚拘执心无迷闷。以是义故名虚空等地。善男子。譬如虚空于可爱色不生贪着。不爱色中不生嗔恚。菩萨摩诃萨住是地中亦复如是。于好恶色心无贪恚。善男子。譬如虚空广大无对。悉能容受一切诸法。菩萨摩诃萨住是地中亦复如是。广大无对悉能容受一切诸法。以是义故复得名为虚空等地

善男子。菩萨摩诃萨住是地中。于一切法亦见亦知若行若缘。若性若相若因若缘。若众生心若根若禅定若乘。若善知识若持禁戒若所施。如是等法一切知见。复次善男子。菩萨摩诃萨住是地中知而不见。云何为知。知自饿法投渊赴火自坠高岩常翘一脚五热炙身。常卧灰土棘刺编椽树叶恶草牛粪之上。衣粗麻衣冢间所弃粪扫氀褐钦婆罗衣獐鹿皮革刍草衣裳。茹菜啖草藕根油滓牛粪根果。若行乞食限从一家。主若言无即便舍去。设复还唤终不回顾。不食盐肉五种牛味。常所饮服糠汁沸汤。受持牛戒狗鸡雉戒。以灰涂身长发为相。以羊祠时先咒后杀。四月事火七日服风。百千亿花供养诸天。诸所欲愿因此成就。如是等法能为无上解脱因者。无有是处。是名为知。云何不见。菩萨摩诃萨不见一人行如是法得正解脱。是名不见。复次善男子。菩萨摩诃萨亦见亦知。何等为见。见诸众生行是邪法必堕地狱。是名为见。云何为知。知诸众生从地狱出生于人中。若能修行檀波罗蜜。乃至具足诸波罗蜜。是人必得入正解脱。是名为知。复次善男子。菩萨摩诃萨复有亦见亦知。云何为见。见常无常苦乐净不净我无我。是名为见。云何为知。知诸如来定不毕竟入于涅槃。知如来身金刚无坏非是烦恼所成就身。又非臭秽腐败之身。亦复能知一切众生悉有佛性。是名为知。复次善男子。菩萨摩诃萨复有亦知亦见。云何为知。知是众生信心成就。知是众生求于大乘。是人顺流。是人逆流。是人正住。知是众生已到彼岸。顺流者谓凡夫人。逆流者从须陀洹乃至缘觉。正住者诸菩萨等到彼岸者。所谓如来应正遍知。是名为知。云何为见。菩萨摩诃萨住于大乘大涅槃典修梵行心。以净天眼见诸众生造身口意三业不善堕于地狱畜生饿鬼。见诸众生修善业者命终当生天上人中。见诸众生从闇入闇。有诸众生从闇入明。有诸众生从明入闇。有诸众生从明入明。是名为见。复次善男子。菩萨摩诃萨复有亦知亦见。菩萨摩诃萨知诸众生修身修戒修心修慧。是人今世恶业成就。或因贪欲嗔恚愚痴。是业必应地狱受报。是人直以修身修戒修心修慧。现世轻受不堕地狱。云何是业能得现报。忏悔发露所有诸恶。既悔之后更不敢作。惭愧成就故。供养三宝故。常自呵责故。是人以是善业因缘不堕地狱现世受报。所谓头痛目痛腹痛背痛横罗死殃。呵责骂辱鞭杖闭系饥饿困苦。受如是等现世轻报。是名为知。云何为见。菩萨摩诃萨见如是人不能修习身戒心慧。造少恶业。此业因缘应现受报。是人少恶不能忏悔。不自呵责。不生惭愧。无有怖惧。是业增长地狱受报。是名为见。复有知而不见。云何知而不见。知诸众生皆有佛性。为诸烦恼之所覆蔽不能得见。是名知而不见。复有知而少见。十住菩萨摩诃萨等知诸众生皆有佛性。见不明了。犹如闇夜所见不了。复有亦见亦知。所谓诸佛如来亦见亦知。复有亦见亦知不见不知。亦见亦知者。所谓世间文字言语男女车乘瓶[分/凡]舍宅城邑。衣裳饮食山河园林众生寿命。是名亦知亦见。云何不见不知。圣人所有微密之语。无有男女乃至园林。是名不见不知。复有知而不见。知所惠施知所供处。知于受者知因果报。是名为知。云何不见。不见所施供处受者及以果报。是名不见。菩萨摩诃萨知有八种。即是如来五眼所知

大般涅槃经卷第十六大般涅槃经卷第十七

        北凉天竺三藏昙无谶译

    梵行品第八之三

迦叶菩萨白佛言。世尊。菩萨摩诃萨能如是知得何等利。佛言。善男子。菩萨摩诃萨能如是知得四无碍。法无碍义无碍辞无碍乐说无碍。法无碍者。知一切法及法名字。义无碍者。知一切法所有诸义。能随诸法所立名字而为作义。辞无碍者。随字论正音论阐陀论世辩论。乐说无碍者。所谓菩萨摩诃萨凡所演说无有障碍。不可动转。无所畏省。难可摧伏。善男子。是名菩萨能如是见知即得如是四无碍智。复次善男子。法无碍者。菩萨摩诃萨遍知声闻缘觉菩萨诸佛之法。义无碍者。乘虽有三知其归一。终不谓有差别之相。辞无碍者。菩萨摩诃萨于一法中作种种名。经无量劫说不可尽。声闻缘觉能作是说。无有是处。乐说无碍者。菩萨摩诃萨于无量劫为诸众生演说诸法。若名若义种种异说不可穷尽。复次善男子。法无碍者。菩萨摩诃萨虽知诸法而不取着。义无碍者。菩萨摩诃萨虽知诸义而亦不着。辞无碍者。菩萨摩诃萨虽知名字亦不取着。乐说无碍者。菩萨摩诃萨虽知乐说。如是最上而亦不着。何以故。善男子。若取著者不名菩萨迦叶菩萨复白佛言。世尊。若不取着则不知法。若知法者则是取着。若知不着则无所知。云何如来说言知法而不取着。佛言。善男子。夫取著者不名无碍。无所取着乃名无碍。善男子。是故一切诸菩萨等。有取著者则无无碍。若无无碍不名菩萨。当知是人名为凡夫。何故取著名为凡夫。一切凡夫取着于色乃至着识。以着色故则生贪心。生贪心故为色系缚。乃至为识之所系缚。以系缚故则不得免生老病死忧悲大苦一切烦恼。是故取著名为凡夫。以是义故一切凡夫无四无阂。善男子。菩萨摩诃萨已于无量阿僧祇劫知见法相。以知见故则知其义。以见法相及知义故。而于色中不生系着。乃至识中亦复如是。以不着故菩萨于色不生贪心。乃至识中亦不生贪。以无贪故则不为色之所系缚。乃至不为识之所缚。以不缚故则得脱于生老病死忧悲大苦一切烦恼。以是义故一切菩萨得四无碍。善男子。以是因缘。我为弟子十二部中说系著者名为魔缚。若不著者则脱魔缚。譬如世间有罪之人为王所缚。无罪之人王不能缚。菩萨摩诃萨亦复如是。有系著者为魔所缚。无系著者魔不能缚。以是义故菩萨摩诃萨而无所著

复次善男子法无碍者。菩萨摩诃萨善知字持而不忘失。所谓持者。如地如山如眼如云如人如母。一切诸法亦复如是。义无碍者。菩萨虽知诸法名字而不知义。得义无碍则知于义。云何知义。谓地持者。如地普持一切众生及非众生。以是义故名地为持。善男子。谓山持者。菩萨摩诃萨作是思惟。何故名山而为持耶。山能持地令无倾动。是故名持。何故复名眼为持耶。眼能持光故名为持。何故复名云为持耶。云名龙气。龙气持水故名云持。何故复名人为持耶。人能持法及以非法故名人持。何故复名母为持耶。母能持子故名母持。菩萨摩诃萨知一切法名字句义亦复如是。辞无碍者。菩萨摩诃萨以种种辞演说一义亦无有义。犹如男女舍宅车乘众生等名。何故无义。善男子。夫义者。乃是菩萨诸佛境界。辞者凡夫境界。以知义故得辞无碍乐说无碍者。菩萨摩诃萨知辞知义故。于无量阿僧祇劫说辞说义而不可尽。是名乐说无碍。善男子。菩萨摩诃萨于无量无边阿僧祇劫修行世谛。以修行故知法无碍。复于无量阿僧祇劫修第一义谛故得义无碍。亦于无量阿僧祇劫。习毗伽罗那论故得辞无碍。亦于无量阿僧祇劫。修习说世谛论故得乐说无碍。善男子。声闻缘觉若有得是四无阂者。无有是处善男子。九部经中我说声闻缘觉之人有四无碍。声闻缘觉真实无有。何以故。菩萨摩诃萨为度众生故修如是四无碍智。缘觉之人修寂灭法志乐独处。若化众生但现神通。终日默然无所宣说。云何当有四无碍智。何故默然而无所说。缘觉不能说法度人使得暖法顶法忍法世第一法。须陀洹斯陀含阿那含阿罗汉辟支佛菩萨摩诃萨。不能令人发阿耨多罗三藐三菩提心。何以故。善男子。缘觉出世世间无有九部经典。是故缘觉无辞无碍乐说无碍。善男子缘觉之人虽知诸法无法无碍。何以故。法无碍者。名为知字。缘觉之人虽知文字无字无碍。何以故。不知常住二字故。是故缘觉不得法无碍。虽知于义无义无碍。真知义者。知诸众生悉有佛性。佛性义者。名为阿耨多罗三藐三菩提。以是义故缘觉之人不得义无碍。是故缘觉一切无有四无碍智。云何声闻无四无碍。声闻之人无有三种善巧方便。何等为三。一者必须软语然后受法。二者必须粗语然后受化。三者不软不粗然后受化。声闻之人无此三故无四无碍。复次声闻缘觉不能毕竟知辞知义。无自在智知于境界。无有十力四无所畏不能毕竟度于十二因缘大河。不能善知众生诸根利钝差别。未能永断二谛疑心。不知众生种种诸心所缘境界。不能善说第一义空。是故二乘无四无碍。迦叶菩萨白佛言。世尊。若诸声闻缘觉之人。一切无有四无碍者。云何世尊。说舍利弗智慧第一。大目犍连神通第一。摩诃拘絺罗四无碍第一。如其无者如来何故作如是说。尔时世尊赞迦叶言。善哉善哉。善男子。譬如恒河有无量水。辛头大河水亦无量。博叉大河水亦无量。悉陀大河水亦无量。阿耨达池水亦无量。大海之中水亦无量。如是诸水虽同无量。然其多少其实不等。声闻缘觉及诸菩萨四无碍智亦复如是。善男子。若说等者无有是处。善男子。我为凡夫说摩诃拘絺罗四无碍智为最第一。汝所问者其义如是。善男子。声闻之人或有得一或有得二。若具足四无有是处迦叶菩萨白佛言。世尊。如佛先说梵行品中。菩萨知见得四无碍者。菩萨知见则无所得。亦无有心言无所得。世尊。是菩萨摩诃萨实无所得。若使菩萨心有得者。则非菩萨名为凡夫。云何如来说言菩萨而有所得。佛言。善男子。善哉善哉。我将欲说而汝复问。善男子。菩萨摩诃萨实无所得。无所得者名四无碍。善男子。以何义故无所得者名为无碍。若有得者则名为碍。有障碍者名四颠倒。善男子。菩萨摩诃萨无四倒故故得无碍。是故菩萨名无所得。复次善男子。无所得者则名为慧。菩萨摩诃萨得是慧故名无所得。有所得者名为无明。菩萨永断无明闇故故无所得。是故菩萨名无所得。复次善男子。无所得者名大涅槃。菩萨摩诃萨安住如是大涅槃中。不见一切诸法性相。是故菩萨名无所得。有所得者名二十五有。菩萨永断二十五有得大涅槃。是故菩萨名无所得。复次善男子。无所得者名为大乘。菩萨摩诃萨不住诸法故得大乘。是故菩萨名无所得。有所得者名为声闻辟支佛道。菩萨永断二乘道故得于佛道。是故菩萨名无所得。复次善男子。无所得者名方等经。菩萨读诵如是经故得大涅槃。是故菩萨名无所得。有所得者名十一部经。菩萨不修纯说方等大乘经典。是故菩萨名无所得。复次善男子。无所得者名为虚空。世间无物名为虚空。菩萨得是虚空三昧无所见故。是故菩萨名无所得。有所得者名生死轮。一切凡夫轮回生死故有所见。菩萨永断一切生死。是故菩萨名无所得。复次善男子。菩萨摩诃萨无所得者名常乐我净。菩萨摩诃萨见佛性故得常乐我净。是故菩萨名无所得。有所得者名无常无乐无我无净。菩萨摩诃萨断是无常无乐无我无净。是故菩萨名无所得。复次善男子。无所得者名第一义空。菩萨摩诃萨观第一义空悉无所见。是故菩萨名无所得。有所得者名为五见。菩萨永断是五见故得第一义空。是故菩萨名无所得。复次善男子。无所得者名为阿耨多罗三藐三菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时悉无所见。是故菩萨名无所得。有所得者名为声闻缘觉菩提。菩萨永断二乘菩提。是故菩萨名无所得。善男子。汝之所问亦无所得。我之所说亦无所得。若有所得是魔眷属非我弟子。迦叶菩萨白佛言。世尊。为我说是菩萨无所得时。无量众生断有相心。以是事故我敢咨启无所得义。令如是等无量众生离魔眷属为佛弟子迦叶菩萨白佛言。世尊。如来先于娑罗双树间。为纯陀说偈

  本有今无　　本无今有　　三世有法
  无有是处

世尊。是义云何。佛言。善男子。我为化度诸众生故而作是说。亦为声闻辟支佛故而作是说。亦为文殊师利法王子故而作是说。不但正为纯陀一人说是偈也。时文殊师利将欲问我。我知其心而为说之。我既说已文殊师利即得解了。迦叶菩萨言。世尊。如文殊等讵有几人能了是义。惟愿如来更为大众广分别说。善男子。谛听谛听。今当为汝重敷演之。言本有者。我昔本有无量烦恼。以烦恼故现在无有大般涅槃。言本无者。本无般若波罗蜜。以无般若婆罗蜜。故现在具有诸烦恼结。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有烦恼者无有是处。复次善男子。言本有者。我本有父母和合之身。是故现在无有金刚微妙法身。言本无者。我身本无三十二相八十种好。以本无有三十二相八十种好故。现在具有四百四病。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有病苦者无有是处。复次善男子。言本有者。我昔本有无常无我无乐无净。以有无常无我无乐无净故。现在无有阿耨多罗三藐三菩提。言本无者。本不见佛性以不见故无常乐我净。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在无常乐我净者无有是处。复次善男子。言本有者。本有凡夫修苦行心谓得阿耨多罗三藐三菩提。以是事故现在不能破坏四魔。言本无者。我本无有六波罗蜜。以本无有六波罗蜜故修行凡夫苦行之心。谓得阿耨多罗三藐三菩提。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有苦行者无有是处。复次善男子。言本有者。我昔本有杂食之身。以有食身故现在无有无边之身。言本无者。本无三十七助道法。以无三十七助道法故现在具有杂食之身。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在有杂食身者无有是处。复次善男子。言本有者。我昔本有一切法中取着之心。以是事故现在无有毕竟空定。言本无者。我本无有中道实义。以无中道真实义故于一切法则有着心。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在说一切法是有相者无有是处。复次善男子。言本有者。我初得阿耨多罗三藐三菩提时。有诸钝根声闻弟子。以有钝根声闻弟子故不得演说一乘之实。言本无者。本无利根人中象王。迦叶菩萨等以无利根。迦叶等故随宜方便开示三乘。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在毕竟演说三乘法者无有是处复次善男子。言本有者。我本说言却后三月于娑罗双树当般涅槃。是故现在不得演说大方等典大般涅槃。言本无者。本昔无有文殊师利大菩萨等。以无有故现在说言如来无常。若有沙门若婆罗门若天若魔若梵若人。说言如来去来现在是无常者无有是处

善男子。如来普为诸众生故虽知诸法说言不知。虽见诸法说言不见。有相之法说言无相。无相之法说言有相。实有无常说言有常。实有有常说言无常。我乐净等亦复如是。三乘之法说言一乘。一乘之法随宜说三。略相说广广相说略。四重之法说偷兰遮。偷兰遮法说言四重。犯说非犯非犯说犯。轻罪说重重罪说轻。何以故。如来明见众生根故。善男子。如来虽作是说终无虚妄。何以故虚妄之语即是罪过。如来悉断一切罪过。云何当有虚妄语耶。善男子。如来虽无虚妄之言。若知众生因虚妄说得法利者。随宜方便则为说之。善男子。一切世谛若于如来即是第一义谛。何以故。诸佛世尊为第一义故说于世谛。亦令众生得第一义谛。若使众生不得如是第一义者。诸佛终不宣说世谛。善男子。如来有时演说世谛。众生谓佛说第一义谛。有时演说第一义谛。众生谓佛说于世谛。是则诸佛甚深境界。非是声闻缘觉所知。善男子。是故汝先不应难言菩萨摩诃萨无所得也。菩萨常得第一义谛。云何难言无所得耶。迦叶复言。世尊。第一义谛亦名为道。亦名菩提亦名涅槃。若有菩萨言有得道菩提涅槃即是无常。何以故。法若常者则不可得。犹如虚空谁有得者。世尊。如世间物本无今有名为无常。道亦如是道若可得则名无常。法若常者无得无生。犹如佛性无得无生。世尊。夫道者。非色非不色不长不短非高非下。非生非灭非赤非白非青非黄非有非无。云何如来说言可得。菩提涅槃亦复如是。佛言。如是如是。善男子。道有二种。一者常。二者无常。菩提之相亦有二种。一者常。二者无常。涅槃亦尔。外道道者名为无常。内道道者名之为常。声闻缘觉所有菩提名为无常。菩萨诸佛所有菩提名之为常。外解脱者名为无常。内解脱者名之为常。善男子。道与菩提及以涅槃悉名为常。一切众生常为无量烦恼所覆。无慧眼故不能得见。而诸众生为欲见故修戒定慧。以修行故见道菩提及以涅槃。是名菩萨得道菩提及涅槃也。道之性相实不生灭。以是义故不可捉持。善男子。道者虽无色像可见称量可知而实有用。善男子。如众生心虽非是色非长非短非粗非细非缚非解。非是见法而亦是有。以是义故我为须达。说言长者心为城主。长者若不护心则不护身口。若护心者则护身口。以不善护是身口故。令诸众生到三恶趣。护身口者则令众生得人天涅槃得名真实。其不得者不名真实。善男子。道与菩提及以涅槃亦复如是亦有亦常。如其无者云何能断一切烦恼。以其有故一切菩萨了了见知。善男子。见有二种。一相貌见。二了了见。云何相貌见。如远见烟名为见火。实不见火。虽不见火亦非虚妄。见空中鹤便言见水。虽不见水亦非虚妄。如见花叶便言见根。虽不见根亦非虚妄。如人遥见篱间牛角便言见牛。虽不见牛亦非虚妄。如见女人怀妊便言见欲。虽不见欲亦非虚妄。如见树生叶便言见水。虽不见水亦非虚妄。又如见云便言见雨。虽不见雨亦非虚妄。如见身业及以口业便言见心。虽不见心亦非虚妄。是名相貌见。云何了了见。如眼见色。善男子。如人眼根清净不坏自观掌中阿摩勒果。菩萨摩诃萨了了见道。菩提涅槃亦复如是。虽如是见初无见相。善男子。以是因缘我于往昔告舍利弗。一切世间若有沙门若婆罗门若天若魔若梵若人之所不知不见不觉。惟有如来悉知见觉。及诸菩萨亦复如是。舍利弗。若诸世间所知见觉。我与菩萨亦知见觉。世间众生之所不知不见不觉。亦不自知不知见觉。世间众生所知见觉。便自说言我知见觉。舍利弗。如来一切悉知见觉。亦不自言我知见觉。一切菩萨亦复如是。何以故。若使如来作知见觉相。当知是则非佛世尊。名为凡夫菩萨亦尔

迦叶菩萨言。如佛世尊为舍利弗说。世间知者我亦得知世间不知我亦悉知。其义云何。善男子。一切世间不知不见不觉佛性。若有知见觉佛性者。不名世间名为菩萨。世间之人亦复不知不见不觉十二部经十二因缘四倒四谛三十七品。阿耨多罗三藐三菩提大般涅槃。若知见觉者不名世间当名菩萨。善男子。是名世间不知见觉。云何世间所知见觉。所谓梵天自在天八臂天性时微尘法及非法。是造化主世界终始断常二见。说言初禅至非非想名为涅槃。善男子。是名世间所知见觉。菩萨摩诃萨于如是事亦知见觉。菩萨如是知见觉已。若言不知不见不觉是为虚妄。虚妄之法则为是罪。以是罪故堕于地狱。善男子。若男若女若沙门若婆罗门。说言无道菩提涅槃。当知是辈名一阐提魔之眷属名为谤法。如是谤法名谤诸佛。如是之人不名世间不名非世间。尔时迦叶闻是事已即以偈颂。而赞叹佛

  大慈愍众生　　故令我归依
  善拔众毒箭　　故称大医王
  世医所疗治　　虽差还复生
  如来所治者　　毕竟不复发
  世尊甘露药　　以施诸众生
  众生既服已　　不死亦不生
  如来今为我　　演说大涅槃
  众生闻秘藏　　即得不生灭

迦叶菩萨说是偈已即白佛言。世尊。如佛所说一切世间不知见觉。菩萨悉能知见觉者。若使菩萨是世间者不得说言世间不知不见不觉。而是菩萨能知见觉若非世间有何异相。佛言。善男子。言菩萨者亦是世间亦非世间。不知见觉者名为世间。知见觉者不名世间。汝言有何异者我今当说。善男子。若男若女若有初闻是涅槃经。即生敬信发阿耨多罗三藐三菩提心。是则名为世间。菩萨一切世间不知见觉。如是菩萨亦同世间不知见觉。菩萨闻是涅槃经已。知有世间不知见觉应是菩萨所知见觉。知是事已即自思惟。我当云何方便修习得知见觉。覆自念言。惟当深心修持净戒。善男子。菩萨尔时以是因缘于未来世在在生处戒常清净。善男子。菩萨摩诃萨以戒净故。在在生处常无憍慢邪见疑网。终不说言如来毕竟入于涅槃。是名菩萨修持净戒。戒既清净次修禅定。以修定故在在生处正念不忘。所谓一切众生悉有佛性。十二部经诸佛世尊常乐我净。一切菩萨安住方等大涅槃经悉见佛性。如是等事忆而不忘。因修定故得十一空。是名菩萨修清净定。戒定已备次修净慧。以修慧故初不计着身中有我我中有身。是身是我非身非我。是名菩萨修习净慧。以修慧故所受持戒牢固不动。善男子。譬如须弥不为四风之所倾动。菩萨摩诃萨亦复如是。不为四倒之所倾动。善男子。菩萨尔时自知见觉所受持戒无有倾动。是名菩萨所知见觉非世间也。善男子。菩萨见所持戒牢固不动心无悔恨。无悔恨故心得欢喜。得欢喜故心得悦乐。得悦乐故心则安隐。心安隐故得无动定。得无动定故得实知见。实知见故厌离生死。厌离生死故便得解脱。得解脱故明见佛性。是名菩萨所知见觉非世间也。善男子。是名世间不知见觉。而是菩萨所知见觉迦叶复言。云何菩萨修持净戒心无悔恨。乃至明了见于佛性。佛言。善男子。世间戒者不名清净。何以故。世间戒者为于有故性不定故非毕竟故。不能广为一切众生。以是义故名为不净。以不净故有悔恨心。以悔恨故心无欢喜。无欢喜故则无悦乐。无悦乐故则无安隐。无安隐故无不动定。无不动定故无实知见。无实知见故则无厌离。无厌离故则无解脱。无解脱故不见佛性。不见佛性故终不能得大般涅槃。是名世间戒不清净。善男子。菩萨摩诃萨清净戒者。戒非戒故非为有故定毕竟故为众生故。是名菩萨戒清净也。善男子。菩萨摩诃萨于净戒中虽不欲生无悔恨心。无悔恨心自然而生。善男子。譬如有人执持明镜。不期见面面像自现。亦如农夫种之良田不期生牙而牙自生。亦如然灯不期灭闇而闇自灭。善男子。菩萨摩诃萨坚持净戒无悔恨心自然而生亦复如是。以净戒故心得欢喜。善男子。如端正人自见面貌心生欢喜。持净戒者亦复如是。善男子。破戒之人见戒不净心不欢喜。如形残者自见面貌不生喜悦。破戒之人亦复如是。善男子。譬如牧牛有二女人。一持酪瓶一持浆瓶。俱共至城而欲卖之。于路脚跌二瓶俱破。一则欢喜一则愁恼。持戒破戒亦复如是。持净戒者心则欢喜。心欢喜故则便思惟。诸佛如来于涅槃中说有能持清净戒者则得涅槃。我今修习如是净戒亦应得之。以是因缘心则悦乐。迦叶复言。喜之与乐有何差别。善男子。菩萨摩诃萨不作恶时名为欢喜。心净持戒名之为乐。善男子。菩萨摩诃萨观于生死则名为喜。见大涅槃名之为乐。下名为喜上名为乐。离世共法名之为喜。得不共法名之为乐。以戒净故身体轻柔口无粗过。菩萨尔时若见若闻若。轻若尝若触若知悉无诸恶。以无恶故心得安隐。以安隐故则得静定。得静定故得实知见。实知见故厌离生死。厌生死故则得解脱。得解脱故得见佛性。见佛性故得大涅槃。是名菩萨清净持戒非世间戒。何以故。善男子。菩萨摩诃萨所受净戒五法佐助。云何为五。一信二惭三愧四善知识五宗敬戒。离五盖故所见清净。离五见故心无疑网。离五疑故。一者疑佛。二者疑法。三者疑僧。四者疑戒。五者疑不放逸。菩萨尔时即得五根。所谓信念精进定慧。得五根故得五种涅槃。谓色解脱乃至识解脱。是名菩萨清净持戒非世间也。善男子。是名世间之所不知不见不觉。而是菩萨所知见觉

善男子。若我弟子受持读诵书写演说大涅槃经有破戒者。有人呵责轻贱毁辱而作是言。若佛秘藏大涅槃经有威力者。云何令汝毁所受戒。若人受持是涅槃经毁禁戒者。当知是经为无威力。若无威力虽复读诵为无利益。缘是轻毁涅槃经故。复令无量无边众生堕于地狱。受持是经而毁戒者则是众生恶知识也。非我弟子是魔眷属。如是之人我亦不听受持是典。宁使不受不持不修不以毁戒受持修习。善男子。若我弟子受持读诵书写演说涅槃经者。当正身心慎莫调戏轻躁举动。身为调戏心为轻动。求有之心名为轻动。身造诸业名为调戏。若我弟子求有造业。不应受持是大乘典大涅槃经。若有如是受持经者。人当轻呵而作是言。若佛秘藏大涅槃经有威力者。云何令汝求有造业。若持经者求有造业。当知是经为无威力。若无威力虽复受持为无利益。缘是轻毁涅槃经故。复令无量无边众生堕于地狱。受持是经求有造业则是众生恶知识也。非我弟子是魔眷属。复次善男子。若我弟子受持读诵书写演说是涅槃经。莫非时说莫非国说。莫不请说莫轻心说。莫处处说莫自叹说莫轻他说。莫灭佛法说莫炽然世法说。善男子。若我弟子受持是经非时而说。乃至炽然世法说者。人当轻呵而作是言。若佛秘藏大涅槃经有威力者。云何令汝非时而说乃至炽然世法而说。若持经者作如是说。当知是经为无威力。若无威力虽复受持为无利益。缘是轻毁涅槃经故令无量众生堕于地狱。受持是经非时而说乃至炽然世法而说。则是众生恶知识也。非我弟子是魔眷属。善男子。若欲受持者。说大涅槃者。说佛性者。说如来秘藏者。说大乘者。说方等经者。说声闻乘者。说辟支佛乘者。说解脱者。见佛性者。先当清净其身。以身净故则无呵责。无呵责故令无量人于大涅槃生清净信。信心生故恭敬是经。若闻一偈一句一字及说法者。则得发于阿耨多罗三藐三菩提心。当知是人则是众生真善知识非恶知识。是我弟子非魔眷属。是名菩萨非世间也。善男子。是名世间之所不知不见不觉。而是菩萨所知见觉

大般涅槃经卷第十七大般涅槃经卷第十八

        北凉天竺三藏昙无谶译

    梵行品第八之四

复次善男子。云何复名一切世间所不知见觉。而是菩萨所知见觉。所谓六念处。何等为六。念佛念法念僧念戒念施念天。善男子。云何念佛。如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。常不变易具足十力四无所畏大师子吼。名大沙门大婆罗门大净毕竟到于彼岸。无能胜者无见顶者。无有怖畏不惊不动。独一无侣无师自悟。疾智大智利智深智解脱智不共智广普智毕竟智智宝成就。人中象王人中牛王。人中龙王人中丈夫。人中莲花分陀利花。调御人师为大施主大法之师。以知法故名大法师。以知义故名大法师。以知时故名大法师。以知足故名大法师。以知我故名大法师。知大众故名大法师。以知众生种种性故名大法师。以知诸根利钝中故名大法师。说中道故名大法师

云何名如来。如过去诸佛所说不变。云何不变。过去诸佛为度众生说十二部经。如来亦尔。故名如来。诸佛世尊从六波罗蜜三十七品十一空来至大涅槃。如来亦尔。是故号佛为如来也。诸佛世尊为众生故随宜方便开示三乘。寿命无量不可称计。如来亦尔。是故号佛为如来也

云何为应世间之法悉名怨家。佛应害故故名为应。夫四魔者是菩萨怨。诸佛如来为菩萨时。能以智慧破坏四魔。是故名应。复次应者名为远离。为菩萨时应当远离无量烦恼故名为应。复次应者名乐。过去诸佛为菩萨时。虽于无量阿僧祇劫为众生故受诸苦恼终无不乐而常乐之。如来亦尔是故名应。又复应者一切人天应以种种香花璎珞幢幡妓乐而供养之。是故名应

云何正遍知。正者名不颠倒。遍知者于四颠倒无不通达。又复正者名为苦行。遍知者知因苦行定有苦果。又复正者名世间中。遍知者毕竟定知修习中道得阿耨多罗三藐三菩提。又复正者名为可数可量可称。遍知者不可数不可量不可称。是故号佛为正遍知。善男子。声闻缘觉亦有遍知亦不遍知。何以故。遍知者名五阴十二入十八界。声闻缘觉亦得遍知。是名遍知。云何不遍知。善男子。假使二乘于无量劫观一色阴不能尽知。以是义故声闻缘觉无有遍知

云何明行足。明者名得无量善果。行名脚足。善果者名阿耨多罗三藐三菩提。脚足者名为戒慧。乘戒慧足得阿耨多罗三藐三菩提。是故名为明行足也。又复明者名咒。行者名吉。足者名果。善男子。是名世间义。咒者名为解脱。吉者名为阿耨多罗三藐三菩提。果者名为大般涅槃。是故名为明行足也。又复明者名光。行者名业。足者名果。善男子。是名世间义。光者名不放逸。业者名六波罗蜜。果者名为阿耨多罗三藐三菩提。又复明者名为三明。一菩萨明。 二诸佛明。三无明明。菩萨明者即是般若波罗蜜。诸佛明者即是佛眼。无明明者即毕竟空。行者于无量劫为众生故修诸善业。足者明见佛性。以是义故名明行足。云何善逝。善者名高。逝名不高。善男子。是名世间义。高者名为阿耨多罗三藐三菩提。不高者即如来心也。善男子。心若高者不名如来。是故如来名为善逝。又复善者名为善知识。逝者善知识果。善男子是名世间义。善知识者即初发心。果者名为大般涅槃。如来不舍最初发心得大涅槃。是故如来名为善逝。又复善者名好。逝者名有。善男子。是名世间义。好者名见佛性。有者名大涅槃。善男子。涅槃之性实非有也。诸佛世尊因世间故说言是有。善男子。譬如世人实无有子说言有子。实无有道说言有道。涅槃亦尔。因世间故说言为有。诸佛世尊成大涅槃故名善逝

善男子。云何世间解。善男子。世间者名为五阴。解者名知。诸佛世尊善知五阴故名世间解。又世间者名为五欲。解名不着。不着五欲故名世间解。又世间解者。东方无量阿僧祇世界。一切声闻缘觉不知不见不解。诸佛悉知悉见悉解。南西北方四维上下亦复如是。是故号佛为世间解。又世间者一切凡夫。解者知诸凡夫善恶因果。非是声闻缘觉所知。惟佛能知是故号佛为世间解。又世间者名曰莲花。解名不污。善男子。是名世间义。莲花者即是如来。不污者如来不为世间八法之所染污。是故号佛为世间解。又世间解者诸佛菩萨名世间解。何以故。诸佛菩萨见世间故故名世间解。善男子。如因食得命名食为命。诸佛菩萨亦复如是。见世间故故名世间解。云何无上士。上士者名之为断。无所断者名无上士。诸佛世尊无有烦恼故无所断。是故号佛为无上士。又上士者名为诤讼。无上士者无有诤讼。如来无诤是故号佛为无上士。又上士者名语可坏。无上士者语不可坏。如来所言一切众生所不能坏。是故号佛为无上士。又上士者名为上座。无上士者名无上座。三世诸佛更无过者。是故号佛为无上士。上者名新。士者名故。诸佛世尊体大涅槃无新无故。是故号佛为无上士。云何调御丈夫。自既丈夫复调丈夫。善男子。言如来者实非丈夫非不丈夫。因调丈夫故名如来为丈夫也。善男子。一切男女若具四法则名丈夫。何等为四。一善知识。二能听法。三思惟义。四如说修行。善男子。若男若女具是四法则名丈夫。善男子。若有男子无此四法则不得名为丈夫也。何以故。身虽丈夫行同畜生。如来调伏若男若女。是故号佛调御丈夫。复次善男子。如御马者凡有四种。一者触毛。二者触皮。三者触肉。四者触骨。随其所触称御者意。如来亦尔。以四种法调伏众生。一为说生令受佛语。如触其毛随御者意。二说生老便受佛语。如触毛皮随御者意。三者说生及以老病便受佛语。如触毛皮肉随御者意。四者说生及老病死便受佛语。如触毛皮肉骨随御者意。善男子。御者调马无有决定。如来世尊调伏众生必定不虚。是故号佛为调御丈夫。云何天人师。师有二种。一者善教。二者恶教。诸佛菩萨常以善法教诸众生。何等善法。谓身口意善。诸佛菩萨教诸众生作如是言。善男子。汝当远离身不善业。何以故。以身恶业是可远离得解脱故。是故我以此法教汝。若是恶业不可远离得解脱者。终不教汝令远离也。若诸众生离恶业已堕三恶者无有是处。以远离故成阿耨多罗三藐三菩提得大涅槃。是故诸佛菩萨常以此法教化众生。口意亦尔。是故号佛为无上师。复次昔未得道今已得之。以所得道为众生说。从本已来未修梵行今已修竟。以己所修为众生说。自破无明复为众生破坏无明。自得净目复为众生破除盲冥令得净眼。自知二谛复为众生演说二谛。既自解脱复为众生说解脱法。自度无边生死大河复令众生皆悉得度。自得无畏复教众生令无怖畏。自既涅槃复为众生演大涅槃。是故号佛为无上师。天者名昼。天上昼长夜短是故名天。又复天者名无愁恼。常受快乐是故名天。又复天者名为灯明。能破黑闇而为大明是故名天。亦以能破恶业黑闇。得于善业而生天上是故名天。又复天者名吉。以吉祥故得名为天。又复天者名曰日。有光明故名曰为天。以是义故名为天也。人者名曰能多恩义。又复人者身口柔软。又复人者名有憍慢。又复人者能破憍慢。善男子。诸佛虽为一切众生无上大师。然经中说为天人师。何以故。善男子。诸众生中惟天与人能发阿耨多罗三藐三菩提心。能修十善业道。能得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。得阿耨多罗三藐三菩提。是故号佛为天人师。云何为佛。佛者名觉。既自觉悟复能觉他。善男子。譬如有人觉知有贼贼无能为。菩萨摩诃萨能觉一切无量烦恼。既觉了已令诸烦恼无所能为是故名佛。以是觉故不生不老不病不死是故名佛。婆伽婆者。婆伽名破。婆名烦恼。能破烦恼故名婆伽婆。又能成就诸善法故。又能善解诸法义故。有大功德无能胜故。有大名闻遍十方故。又能种种大慧施故。又于无量阿僧祇劫吐女根故。善男子。若男若女能如是念佛者。若行若住若坐若卧若昼若夜若明若闇。常得不离见佛世尊。善男子。何故名为如来应正遍知乃至婆伽婆。而有如是无量功德大名称耶。善男子。菩萨摩诃萨于昔无量阿僧祇劫。恭敬父母和上诸师上座长老。于无量劫常为众生而行布施。坚持禁戒修集忍辱。勤行精进禅定智慧。大慈大悲大喜大舍。是故今得三十二相八十种好金刚之身。又复菩萨于昔无量阿僧祇劫。修集信念进定慧根。于诸师长恭敬供养常为法利不为食利。菩萨若持十二部经。若读若诵常为众生令得解脱安隐快乐终不自为。何以故。菩萨常修出世间心及出家心无为之心。无诤讼心无垢秽心无系缚心无取着心。无覆盖心无无记心无生死心无疑网心。无贪欲心无嗔恚心无愚痴心。无憍慢心无秽浊心无烦恼心无苦心。无量心广大心虚空心。无心无无心调心不护心。无覆藏心无世间心。常定心常修心常解脱心。无报心无愿心善愿心无误心。柔软心不住心自在心无漏心。第一义心不退心无常心。正直心无谄曲心。纯善心无多少心无坚硬心。无凡夫心无声闻心无缘觉心。善知心界知心生界知心住界知心自在界心。是故今得十力四无所畏大悲三念处常乐我净。是故得称如来乃至婆伽婆。是名菩萨摩诃萨念佛。云何菩萨摩诃萨念法。善男子。菩萨摩诃萨思惟诸佛所可说法最妙最上。因是法故。能令众生得现在果。惟此正法无有时节法眼所见非肉眼见。然不可以譬喻为比。不生不出不住不灭不始不终无为无数。无舍宅者为作舍宅。无归作归无明作明。未到彼岸令到彼岸。为无香处作无碍香。不可见见不动不转不长不短。永断诸乐而安隐乐毕竟微妙。非色断色而亦是色。乃至非识断识而亦是识。非业断业非结断结。非物断物而亦是物。非界断界而亦是界。非有断有而亦是有。非入断入而亦是入。非因断因而亦是因。非果断果而亦是果。非虚非实断一切实而亦是实。非生非灭永离生灭而亦是灭。非相非非相断一切相而亦是相。非教非不教而亦是师。非怖非安断一切怖而亦是安。非忍非不忍永断不忍而亦是忍。非止非不止断一切止而亦是止一切法顶。悉能永断一切烦恼清净无相永脱诸相。无量众生毕竟住处能灭一切生死炽火。乃是诸佛所游居处常不变易。是名菩萨念法。云何念僧。诸佛圣僧如法而住。受正直法随顺修行。不可睹见不可捉持不可破坏。无能娆害不可思议。一切众生良祐福田虽为福田无所受取清净无秽无漏无为广普无边。其心调柔平等无二。无有挠浊常不变易。是名念僧。云何念戒。菩萨思惟有戒不破不漏不坏不杂。虽无形色而可护持。虽无触对善修方便。可得具足无有过咎。诸佛菩萨之所赞叹。是大方等大涅槃因。善男子。譬如大地船舫璎珞大姓大海。灰汁舍宅刀剑桥梁。良医妙药阿伽陀药。如意宝珠脚足眼目父母阴凉。无能劫盗不可娆害。火不能焚水不能漂。大山梯蹬诸佛菩萨妙宝胜幢。若住是戒得须陀洹果我亦有分然我不须。何以故。若我得是须陀洹果。不能广度一切众生。若住是戒则得阿耨多罗三藐三菩提。我亦有分是我所欲。何以故。若得阿耨多罗三藐三菩提。当为众生广说妙法而作救护。是名菩萨摩诃萨念戒。云何念施。菩萨摩诃萨深观此施乃是阿耨多罗三藐三菩提。因诸佛菩萨亲近修集如是布施。我亦如是亲近修集。若不惠施不能庄严四部之众。施虽不能毕竟断结。而能除破现在烦恼。以施因缘故常为十方无量无边恒河沙等。世界众生之所称叹。菩萨摩诃萨施众生食则施其命。以是果报成佛之时常不变易。以施乐故成佛之时则得安乐。菩萨施时如法求财不侵彼施此。是故成佛得清净涅槃。菩萨施时令诸众生不求而得。是故成佛得自在。我以施因缘令他得力。是故成佛获得十力。以施因缘令他得语。是故成佛得四无碍。诸佛菩萨修集是施为涅槃因。我亦如是。修集布施为涅槃因。广说如杂花中。云何念天。有四天王处乃至非想非非想处。若有信心得四天王处我亦有分。若戒多闻布施智慧得四天王处。乃至得非想非非想处我亦有分然非我所欲。何以故。四天王处乃至非想非非想处皆是无常。以无常故生老病死以是义故非我所欲。譬如幻化诳于愚夫。智慧之人所不惑着。如幻化者即是四天王处。乃至非想非非想处。愚者即是一切凡夫。我则不同凡夫愚人。我曾闻有第一义天。谓诸佛菩萨常不变易。以常住故不生不老不病不死。我为众生精勤求于第一义天。何以故。第一义天能令众生除断烦恼犹如意树。若我有信乃至有慧则能得是第一义天。当为众生广分别说第一义天。是名菩萨摩诃萨念天。善男子。是名菩萨非世间也。是为世间不知见觉。而是菩萨所知见觉。善男子。若我弟子。谓受持读诵书写演说十二部经。及以受持读诵书写敷演解说大涅槃经等无差别者。是义不然。何以故。善男子。大涅槃者即是一切诸佛世尊甚深秘藏。以是诸佛甚深秘藏是则为胜。善男子。以是义故。大涅槃经甚奇甚特不可思议。迦叶菩萨白佛言。世尊。我亦知是大涅槃经甚奇甚特不可思议。佛法众僧不可思议。菩萨菩提大般涅槃亦不可思议。世尊。以何义故复言菩萨不可思议。善男子。菩萨摩诃萨无有教者而能自发菩提之心。既发心已勤修精进。正使大火焚烧身首终不求救舍念法心。何以故。菩萨摩诃萨常自思惟。我于无量阿僧祇劫或在地狱饿鬼畜生人中天上。为诸结火之所烧然。初不曾得一决定法。决定法者即是阿耨多罗三藐三菩提。若我为于阿耨多罗三藐三菩提终不护惜身心与命。我为阿耨多罗三藐三菩提正使碎身犹如微尘。终不放舍勤精进也。何以故。勤进之心即是阿耨多罗三藐三菩提因。善男子。如是菩萨未见阿耨多罗三藐三菩提。乃能如是不惜身命况复见已。是故菩萨不可思议。又复不可思议。菩萨摩诃萨所见生死无量过患。非是声闻缘觉所及。虽知生死无量过恶。为众生故于中受苦不生厌离。是故复名不可思议。菩萨摩诃萨为众生故虽在地狱。受诸苦恼如三禅乐。是故复名不可思议。善男子。譬如长者其家失火。长者见已从舍而出。诸子在后未脱火难。长者尔时定知火害。为诸子故旋还赴救不顾其难。菩萨摩诃萨亦复如是。虽知生死多诸过恶。为众生故处之不厌。是故复名不可思议。善男子。无量众生发菩提心。见生死中多诸过恶心即退没。或为声闻或为缘觉。若有菩萨闻是经者。终不退失菩提之心。而为声闻辟支佛也。如是菩萨虽复未阶初不动地。而心坚固无有退没。是故复名不可思议。善男子。若有人言我能浮渡大海之水。如是之言可思议不。不也。世尊。如是之言或可思议或不可思议。何以故。若人渡者则不可思议。阿修罗渡则可思议。善男子。我亦不说阿修罗也。正说人耳。世尊。人中亦有可思议者不可思议者。世尊。人亦二种。一者圣人。二者凡夫。凡夫之人则不可思议。贤圣之人则可思议。善男子。我说凡夫不说圣人。世尊。若凡夫人实不可思议。善男子。凡夫之人实不能渡大海水也。如是菩萨实能渡于生死大海。是故复名不可思议。善男子。若有人能以藕根丝悬须弥山可思议不。不也。世尊。善男子。菩萨摩诃萨于一念顷悉能称量一切生死。是故复名不可思议。善男子。菩萨摩诃萨已于无量阿僧祇劫。常观生死无常无我无乐无净。而为众生分别演说常乐我净。虽如是说然非邪见。是故复名不可思议。善男子。如人入水水不能漂。入大猛火火不能烧。如是之事不可思议。菩萨摩诃萨亦复如是。虽处生死不为生死之所恼害。是故复名不可思议。善男子。人有三品谓上中下。下品之人初入胎时作是念言。我今处厕众秽归处如死尸间。众蕀刺中大黑闇处。初出胎时复作是念。我今出厕出众秽处。乃至出于大黑闇处。中品之人作是念言。我今入于众树林中。清净河中房舍屋宅。出时亦尔。上品之人作是念言。我升殿堂在花林间。乘马乘象登涉高山。出时亦尔。菩萨摩诃萨初入胎时自知入胎。住时知住出时知出。终不生于贪嗔之心。而未得阶初住地也。是故复名不可思议。善男子。阿耨多罗三藐三菩提实不可以譬喻为比。善男子。心亦不可以方喻为比而皆可说。菩萨摩诃萨无有师咨受学之处。而能得于阿耨多罗三藐三菩提法。得是法已心无悭吝常为众生而演说之。是故复名不可思议。善男子。菩萨摩诃萨有身远离非口。有口远离非身。有非身非口而亦远离。身远离者。谓离杀盗淫。是名身远离非口。口远离者。谓离妄语两舌恶口无义语。是名口远离非身。非身非口是远离者。所谓远离贪嫉嗔恚邪见。善男子。是名非身非口而亦远离。善男子。菩萨摩诃萨不。见一法是身是业及与离主而亦有离。是故复名不可思议。口亦如是。善男子。从身离身从口离口从慧远离非身非口。善男子。实有此慧然不能令菩萨远离。何以故。善男子。无有一法能坏能作有为法性异生异灭。是故此慧不能远离。善男子。慧不能破火不能烧水不能烂风不能动地不能持。生不能生老不能老住不能住坏。不能坏。贪不能贪嗔不能嗔痴不能痴。以有为性异生异灭故。菩萨摩诃萨终不生念我以此慧破诸烦恼。而自说言我破烦恼。虽作是说非是虚妄。是故复名不可思议。迦叶复言。世尊。我今始知菩萨摩诃萨不可思议。佛法众僧大涅槃经及受持者。菩提涅槃不可思议。世尊。无上佛法当久近住几时而灭。善男子。若大涅槃经乃至有是五行。所谓圣行梵行天行病行婴儿行。若我弟子有能受持读诵书写演说其义。为诸众生之所恭敬尊重赞叹种种供养。当知。尔时佛法未灭。善男子。若大涅槃经具足流布。当尔之时。我诸弟子。多犯禁戒造作众恶。不能敬信如是经典。以不信故不能受持读诵书写解说其义。不为众人之所恭敬乃至供养。见受持者轻毁诽谤。汝是六师非佛弟子。当知。佛法将灭不久。迦叶菩萨复白佛言。世尊。我亲从佛闻如是义。迦叶佛法住世七日然后灭尽。世尊。迦叶如来有是经不。如其有者。云何言灭。如其无者。云何说言大涅槃经是诸如来秘密之藏。佛言。善男子。我先说言惟有文殊乃解是义。今当重说至心谛听。善男子。诸佛世尊。有二种法。一者世法。二者第一义法。世法者则有坏灭。第一义法则不坏灭。复有二种。一者无常无我无乐无净。二者常乐我净。无常无我无乐无净则有坏灭。常乐我净则无坏灭。复有二种。一者二乘所持。二者菩萨所持。二乘所持则有坏灭。菩萨所持则无坏灭。复有二种。一者外。二者内。外法者则有坏灭。内法者则无坏灭。复有二种。一者有为二者无为。有为之法则有坏灭。无为之法无有坏灭。复有二种。一者可得。二者不可得。可得之法则有坏灭。不可得者无有坏灭。复有二种。一者共法。二者不共法。共法坏灭。不共之法无有坏灭。复有二种。一者人中二者天中。人中坏灭天无坏灭。复有二种。一者十一部经。二者方等经。十一部经则有。坏灭。方等经典无有坏灭。善男子。若我弟子受持读诵书写解说方等经典。恭敬供养尊重赞叹。当知。尔时佛法不灭。善男子。汝向所问迦叶如来有是经不者。善男子。大涅槃经悉是一切诸佛秘藏。何以故。诸佛虽有十一部经不说佛性。不说如来常乐我净。诸佛世尊永不毕竟入于涅槃。是故此经名为如来秘密之藏。十一部经所不说故故名为藏。如人七宝不出外用名之为藏。善男子。是人所以藏积此物为未来事故。何等未来事。所谓谷贵贼来侵国。值遇恶王为用赎命。道路涩难财难。得时乃当出用。善男子。诸佛如来秘密之藏亦复如是。为未来世。诸恶比丘畜不净物。为四众说如来毕竟入于涅槃。读诵世典不敬佛经。如是等恶现于世时。如来为欲灭是诸恶令得远离邪命利养。如来则为演说是经。若是经典秘密之藏灭不现时。当知。尔时佛法则灭。善男子。大涅槃经常不变易。云何难言迦叶佛时有是经不。善男子。迦叶佛时所有众生贪欲微薄智慧滋多。诸菩萨摩诃萨等调柔易化。有大威德总持不忘如大象王世界清净。一切众生悉知如来终不毕竟入于涅槃常住不变。虽有是典不须演说。善男子。今世众生多诸烦恼愚痴喜忘无有智慧。多诸疑网信根不立世界不净。一切众生咸谓如来无常迁变毕竟入于大般涅槃。是故如来演说是典善男子。迦叶佛法实亦不灭。何以故。常不变故。善男子。若有众生我见无我无我见我。常见无常无常见常。乐见无乐无乐见乐。净见不净不净见净。灭见不灭不灭见灭。罪见非罪非罪见罪。轻罪见重重罪见轻。乘见非乘非乘见乘。道见非道非道见道。实是菩提见非菩提。实非菩提谬见菩提。苦见非苦集见非集。灭见非灭实见非实。实是世谛见第一义谛第一义谛见是世谛。归见非归非归见归。以真佛语名为魔语。实是魔语以为佛语。如是之时诸佛乃说大涅槃经善男子。宁说蚊嘴尽大海底。不可说言如来法灭。宁说口吹须弥散坏。不可说言如来法灭。宁言以索系缚猛风。不可说言如来法灭。宁言佉陀罗火中生莲花。不可说言如来法灭宁说阿伽陀药而为毒药不可说言如来法灭宁说月可令热日可令冷不可说言如来法灭。宁说四大各舍己性。不可说言如来法灭。善男子若佛初出得阿耨多罗三藐三菩提已。未有弟子解甚深义。彼佛世尊便涅槃者。当知。是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。佛虽涅槃。当知。是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。无有笃信白衣檀越敬重佛法佛便涅槃。当知。是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义多有笃信白衣檀越敬重佛法。佛虽涅槃。当知。佛法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。虽有笃信白衣檀越敬重佛法。而诸弟子演说经法贪为利养。不为涅槃佛复灭度。当知是法不久住世

复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子凡所演说不贪利养为求涅槃。佛虽灭度。当知。是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。复有笃信白衣檀越敬重佛法。而诸弟子多起诤讼互相是非。佛复涅槃。当知。是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子修和敬法不相是非互相尊重。佛虽涅槃。当知。是法久住不灭。复次善男子。若佛初出得阿耨多罗三藐三菩提已。虽有弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子为大涅槃而演说法互相恭敬不起诤讼。然畜一切不净之物。复自赞言我得须陀洹果乃至阿罗汉果。佛复涅槃。当知。是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子解甚深义。复有笃信白衣檀越敬重佛法。彼诸弟子为大涅槃演说经法。善修和敬互相尊重。不畜一切不净之物。亦不自言得须陀洹乃至得阿罗汉。彼佛世尊虽复灭度。当知。是法久住于世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子。乃至不畜不净之物。又不自言得须陀洹乃至阿罗汉。各执所见种种异说而作是言。长老。诸佛所制四重之法。乃至七灭诤法。为众生故或遮或开。十二部经亦复如是。何以故。佛知国土时节各异众生不同利钝差别。是故如来或遮或开有轻重说。善男子。譬如良医为病服乳为病遮乳。热病听服冷病则遮。如来亦尔。观诸众生烦恼病根亦开亦遮。长老。我亲从佛闻如是义。惟我知义汝不能知。惟我解律汝不能解。我知诸经汝不能知。彼佛复灭。当知。是法不久住世。复次善男子。若佛初出得阿耨多罗三藐三菩提已。有诸弟子乃至不言我得须陀洹果至阿罗汉。亦不说言诸佛世尊为众生故或遮或开。长老。我亲从佛闻如是义如是法如是律。长老。当依如来十二部经。此义若是我当受持。如其非者我当弃舍。彼佛世尊虽复涅槃。当知。是法久住于世。善男子。我法灭时有声闻弟子。或说有神或说神空。或说有中阴或说无中阴。或说有三世或说无三世。或说有三乘或说无三乘。或言一切有或言一切无或言众生有始有终。或言众生无始无终。或言十二因缘是有为法。或言因缘是无为法。或言如来有病苦行。或言如来无病苦行。或言如来不听比丘食十种肉。何等为十。人蛇象马驴狗师子猪狐猕猴其余悉听。或言一切不听。或言比丘不作五事。何等为五。不卖生口刀酒酪沙胡麻油等。其余悉听。或言不听入五种舍。何等为五。屠儿淫女酒家王宫旃陀罗舍。余舍悉听。或言不听着憍奢耶衣。余一切听。或言如来听诸比丘受畜衣食卧具。其价各直十万两金。或言不听。或言涅槃常乐我净。或言涅槃直是结。尽更无别法名为涅槃。譬如织缕名之为衣。衣既坏已名之无衣实。无别法名无衣也涅槃之体亦复如是。善男子。当尔之时我诸弟子。正说者少邪说者多。受正法少受邪法多。受佛语少受魔语多。善男子。尔时拘睒弥国有二弟子。一者罗汉。二者破戒。破戒徒众凡有五百。罗汉徒众其数一百。破戒者说。如来毕竟入于涅槃。我亲从佛闻如是义。如来所制四重之法。若持亦可犯亦无罪。我今亦得阿罗汉果四无碍智。而阿罗汉亦犯。如是四重之法。四重之法若是实罪。阿罗汉者终不应犯。如来在世制言坚持。临涅槃时皆悉放舍。阿罗汉比丘言。长老。汝不应说如来毕竟入于涅槃。我知如来常不变易。如来在世及涅槃后犯四重禁罪无差别。若言罗汉犯四重禁。是义不然。何以故。须陀洹人尚不犯禁。况阿罗汉。若长老言。我是罗汉。阿罗汉者终不生想我得罗汉。阿罗汉者惟说善法不说不善。长老所说纯是非法。若有得见十二部经。定知长老非阿罗汉。善男子。尔时破戒比丘徒众。即共断是阿罗汉命。善男子。是时魔王因是二众忿恚之心。悉共害是六百比丘。尔时凡夫各共说言。哀哉佛法于是灭尽。而我正法实不灭也。尔时其国有十二万诸大菩萨善持我法。云何当言我法灭耶。当于尔时。阎浮提内无一比丘为我弟子。尔时波旬悉以大火焚烧一切所有经典。其中或有遗余在者。诸婆罗门即共偷取处处采拾安置己典。以是义故。诸小菩萨佛未出时率共信受婆罗门语。诸婆罗门虽作是说。我有斋戒而诸外道真实无也。诸外道等虽复说言有我乐净。而实不解我乐净义。直以佛法一字二字一句二句。说言我典有如是义。尔时拘尸那城娑罗双树间。无量无边阿僧祇众闻是语已。悉共唱言。世间虚空世间虚空。迦叶菩萨告诸大众。汝等且莫忧愁啼哭。世间不空如来常住无有变易。法僧亦尔。尔时大众。闻是语已啼哭即止。悉发阿耨多罗三藐三菩提心

大般涅槃经卷第十八大般涅槃经卷第十九

        北凉天竺三藏昙无谶译

    梵行品第八之五

尔时王舍大城阿阇世王。其性弊恶喜行杀戮具口四恶。贪恚愚痴其心炽盛。唯见现在不见未来。纯以恶人而为眷属。贪着现世五欲乐故。父王无辜横加逆害。因害父已心生悔热。身诸璎珞妓乐不御。心悔热故遍体生疮。其疮臭秽不可附近。寻自念言我今此身已受花报。地狱果报将近不远。尔时其母字韦提希。以种种药而为傅之。其疮遂增无有降损。王即白母如是疮者。从心而生非四大起。若言众生有能治者无有是处。时有大臣名曰月称。往至王所在一面立。白言。大王。何故愁悴颜容不悦。为身痛耶为心痛乎。王即答言。我今身心岂得不痛。我父无辜横加逆害。我从智者曾闻是义。世有五人不脱地狱。谓五逆罪我今已有无量无边阿僧祇罪。云何身心而得不痛。又无良医治我身心。臣言。大王。莫大愁苦。即说偈言

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世有五人不脱地狱。谁往见之来语王耶。言地狱者即是世间。多智者说如王所言。世无良医治身心者。今有大医名富兰那。一切知见得自在定。毕竟修习清净梵行。常为无量无边众生。演说无上涅槃之道。为诸弟子说如是法。无有黑业无黑业报。无有白业无白业报。无黑白业无黑白业报。无有上业及以下业。是师今在王舍城中。唯愿大王。屈驾往彼可令是师疗治身心。时王答言。审能如是灭除我罪我当归依

复有一臣名曰藏德。复往王所而作是言。大王。何故面貌憔悴唇口干焦。音声微细犹如怯人。见大怨敌颜色皴裂。将何所苦为身痛耶为心痛乎。王即答言。我今身心云何不痛。我之痴盲无有慧目。近诸恶友而为亲善。随调婆达恶人之言。正法之王横加逆害。我昔曾闻智人说偈

  若于父母　　佛及弟子　　生不善心
  起于恶业　　如是果报　　在阿鼻狱

以是事故。令我心怖生大苦恼。又无良医而见救疗。大臣。复言。唯愿大王。且莫愁怖法有二种。一者出家。二者王法。王法者。谓害其父则王国土虽云是逆实无有罪。如迦罗罗虫要坏母腹然后乃生。生法如是虽破母身实亦无罪。骡怀妊等亦复如是。治国之法。法应如是。虽杀父兄实无有罪。出家法者乃至蚊蚁杀亦有罪。唯愿大王。宽意莫愁。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言世无良医治身心者。今有大师名末伽黎拘舍离子。一切知见怜愍众生犹如赤子。已离烦恼能拔众生三毒利箭。一切众生于一切法无知见觉。唯是一人独知见觉。如是大师常为弟子说如是法。一切众生身有七分。何等为七。地水火风苦乐寿命。如是七法非化非作不可毁害。如伊师迦草。安住不动如须弥山。不舍不作犹如乳酪。各不诤讼。若苦若乐。若善不善。投之利刀无所伤害。何以故。七分空中无妨碍故。命亦无害。何以故。无有害者及死者故。无作无受无说无听。无有念者及以教者。常说是法能令众生灭除一切无量重罪。是师今在王舍大城。唯愿大王。往至其所。王若见者众罪消灭。时王答言。审能如是除灭我罪。我当归依

复有一臣。名曰实得。复到王所即说偈言

  大王何故　　身脱璎珞　　首发蓬乱
  乃至如是　　王身何故　　战栗不安
  犹如猛风　　吹动花树

王今何故容色愁悴。犹如农夫下种之后天不降雨。愁苦如是。为是心痛为身痛耶。王即答言。我今身心岂得不痛。我父先王慈爱流恻。特见矜念实无辜咎。往问相师。相师答言。是儿生已定当害父。虽闻是语犹见赡养。曾闻智者作如是言。若人奸母及比丘尼。偷僧祇物。杀发无上菩提心者。害及其父。如是之人毕定当堕阿鼻地狱。我今身心岂得不痛。大臣复言唯愿大王且莫愁苦。如其父王修解脱者害则有罪。若治国法杀则无罪。大王。非法者名为非法。无法者名为无法。譬如无子名为无子。亦如恶子名之无子。虽言无子实非无子。如食无盐名为无盐。食若少盐亦名无盐。如河无水名之无水。若有少水亦名无水。如念念灭亦言无常。虽住一劫亦名无常。如人受苦名为无乐。虽受少乐亦名无乐。如不自在名之无我。虽少自在亦名无我。如闇夜时名之无日。云雾之时亦言无日。大王。虽言少法名为无法。实非无法。愿王留神听臣所说。一切众生皆有余业。以业缘故数受生死。若使先王有余业者。今王杀之竟有何罪。唯愿大王宽意莫愁。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治身心者。今有大师名删阇耶毗罗胝子。一切知见。其智渊深犹如大海。有大威德具大神通。能令众生离诸疑网。一切众生不知见觉。唯是一人独知见觉。今者近在王舍城住。为诸弟子说如是法。一切众中若是王者。自在随意造作善恶。虽为众恶悉无有罪。如火烧物无净不净。王亦如是与火同性。譬如大地净秽普载。虽为是事初无嗔喜。王亦如是与地同性。譬如水性净秽俱洗。虽为是事亦无忧喜。王亦如是与水同性。譬如风性净秽等吹。虽为是事亦无忧喜。王亦如是与风同性。如秋髡树春则还生。虽复髡斫实无有罪。一切众生亦复如是。此间命终还此间生。以还生故当有何罪。一切众生苦乐果报。悉皆不由现在世业。因在过去现在受果。现在无因未来无果。以现果故众生持戒勤修精进遮现恶果。以持戒故则得无漏。得无漏故尽有漏业。以尽业故众苦得尽。众苦尽故。故得解脱。唯愿大王。速往其所。令其疗治身心苦痛。王若见者众罪则除。王即答言。审有是师能除我罪。我当归依

复有一臣名悉知义。即至王所作如是言。王今何故形不端严。如失国者。如泉枯涸。池无莲花。树无花叶。破戒比丘身无威德。为身痛耶。为心痛乎。王即答言。我今身心岂得不痛。我父先王慈恻流念。然我不孝不知报恩。常以安乐安乐于我。而我背恩反断其乐。先王无辜横兴逆害。我亦曾闻智者说言。若有害父当于无量阿僧祇劫受大苦恼。我今不久必堕地狱。又无良医救疗我罪。大臣即言。唯愿大王。放舍愁苦。王不闻耶。昔者有王。名曰罗摩。害其父已得绍王位。跋提大王。毗楼真王。那睺沙王。迦帝迦王。毗舍佉王。月光明王。日光明王。爱王。持多人王。如是等王。皆害其父得绍王位。然无一王入地狱者。于今现在毗琉璃王优陀那王恶性王鼠王莲花王。如是等王皆害其父。悉无一王生愁恼者。虽言地狱饿鬼天中谁有见者。大王。唯有二有。一者人道。二者畜生。虽有是二非因缘生非因缘死。若非因缘何有善恶。唯愿大王勿怀愁怖。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治身心者。今有大师名阿耆多翅舍钦婆罗。一切知见。观金与土平等无二。刀破右胁左涂栴檀。于此二人心无差别。等视怨亲心无异相。此师真是世之良医。若行若立若坐若卧。常在三昧心无分散。告诸弟子作如是言。若自作若教他作。若自斫若教他斫。若自炙若教他炙。若自害若教他害。若自偷若教他偷。若自淫若教他淫。若自妄语若教他妄语。若自饮酒若教他饮酒。若杀一村一城一国。若以刀轮杀一切众生。若恒河已南布施众生。恒河已北杀害众生。悉无罪福无施戒定。今者近在王舍城住。愿王速往。王若见者众罪除灭。王言。大臣。审能如是除灭我罪。我当归依复有大臣。名曰吉德。复往王所作如是言。王今何故面无光泽。如日中灯。如昼时月。如失国君。如荒败土。大王今者。四方清夷无诸怨敌。而今何故如是愁苦。为身苦耶。为心苦乎。有诸王子常生此念。我今何时当得自在。大王。今者已果所愿自在。王领摩伽陀国先王宝藏具足而得。唯当快意纵情受乐。如是愁苦何用经怀。王即答言。我今云何得不愁恼。大臣。譬如愚人但贪其味不见利刀。如食杂毒不见其过。我亦如是。如鹿见草不见深阱。如鼠贪食不见猫狸。我亦如是。见现在乐不见未来不善苦果。曾从智者闻如是言。宁于一日受三百赞。不于父母生一念恶。我今已近地狱炽火。云何当得不愁恼耶。大臣。复言。谁来诳王言有地狱。如刺头利谁之所造。飞鸟色异复谁所作。水性润渍石性坚硬。如风动性如火热性。一切万物自死自生谁之所作。言地狱者直是智者文辞造作。言地狱者为有何义。臣当说之。地者名地。狱者名破。破于地狱无有罪报。是名地狱。又复地者名人。狱者名天。以害其父故到人天。以是义故婆薮仙人唱言。杀羊得人天乐。是名地狱。又复地者名命。狱者名长。以杀生故得寿命长。故名地狱。大王。是故当知实无地狱。大王。如种麦得麦种稻得稻。杀地狱者还得地狱。杀害于人应还得人。大王。今当听臣所说实无杀害。若有我者实亦无害。若无我者复无所害。何以故。若有我者常不变易。以常住故不可杀害。不破不坏不系不缚不嗔不喜犹如虚空。云何当有杀害之罪。若无我者诸法无常。以无常故念念坏灭。念念灭故杀者死者皆念念灭。若念念灭谁当有罪。大王。如火烧木。火则无罪。如斧斫树。斧亦无罪。如镰刈草。镰实无罪。如刀杀人。刀实非人。刀既无罪。人云何罪。如毒杀人。毒实非人。毒药非罪。人云何罪。一切万物皆亦如是。实无杀害。云何有罪。唯愿大王莫生愁苦。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医治恶业者。今有大师名迦罗鸠驮迦旃延。一切知见明了三世。于一念顷能见无量无边世界。闻声亦尔。能令众生远离过恶。犹如恒河若内若外所有诸罪皆悉清净。是大良师亦复如是。能除众生内外众罪。为诸弟子说如是法。若人杀害一切众生。心无惭愧终不堕恶。犹如虚空不受尘水。有惭愧者即入地狱。犹如大水润湿于地。一切众生悉是自在天之所作。自在天喜众生安乐。自在天嗔众生苦恼。一切众生若罪若福。乃是自在天之所为。云何当言人有罪福。譬如工匠作机关木人。行住坐卧唯不能言。众生亦尔。自在天者喻如工匠。木人者喻众生身。如是造化谁当有罪。如是大师今者近在王舍城住。唯愿速往。如得见者众罪消灭。王即答言。审有是人能灭我罪。我当归依。复有一臣名无所畏。往至王所说如是言。大王。世有愚人一日之中百喜百愁百眠百寤百惊百哭。有智之人斯无是事。大王。何故忧愁如是。如失侣客。如堕深泥无救拔者。如人渴乏不得浆水。犹如迷人无有导者。如困病人无医救疗。如海船破无救接者。大王。今者为身痛耶。为心痛乎。王即答言。我今身心岂得不痛。我近恶友不观口过。先王无辜横兴逆害。我今定知当入地狱。复无良医而见救济。臣即白言。唯愿大王。莫生愁毒。夫刹利者。名为王种。若为国土。若为沙门及婆罗门。为安人民虽复杀害无有罪也。先王虽复恭敬沙门。不能承事诸婆罗门。心无平等。心无平等故则非刹利。大王。今者为欲供养诸婆罗门。杀害先王。当有何罪。大王。实无杀害。夫杀害者杀害寿命。命名风气。风气之性不可杀害。云何害命而当有罪。唯愿大王莫复愁苦。何以故

  若常愁苦　　愁遂增长　　如人喜眠
  眠则滋多　　贪淫嗜酒　　亦复如是

如王所言。世无良医而疗治者。今有大师名尼乾陀若提子。一切知见怜愍众生。善知众生诸根利钝。达解一切随宜方便。世间八法所不能污。寂静修习清净梵行。为诸弟子说如是言。无施无善无父无母。无今世后世。无阿罗汉。无修无道。一切众生经八万劫。于生死轮自然得脱。有罪无罪悉亦如是。如四大河。所谓辛头恒河博叉私陀。悉入大海无有差别。一切众生亦复如是。得解脱时悉无差别。是师今在王舍城住。唯愿大王速往其所。若得见者众罪消除。王即答言。审有是师能除我罪。我当归依

尔时大医。名曰耆婆。往至王所白言。大王。得安眠不。王即以偈答言

  若有能永断　　一切诸烦恼
  不贪染三界　　乃得安隐眠
  若得大涅槃　　演说甚深义
  名真婆罗门　　乃得安隐眠
  身无诸恶业　　口离于四过
  心无有疑网　　乃得安隐眠
  身心无热恼　　安住寂静处
  获致无上乐　　乃得安隐眠
  心无有取着　　远离诸怨仇
  常和无诤讼　　乃得安隐眠
  若不造恶业　　心常怀惭愧
  信恶有果报　　乃得安隐眠
  敬养于父母　　不害一生命
  不盗他财物　　乃得安隐眠
  调伏于诸根　　亲近善知识
  破坏四魔众　　乃得安隐眠
  不见吉不吉　　及以苦乐等
  为诸众生故　　轮转于生死
  若能如是者　　乃得安隐眠
  谁得安隐眠　　所谓诸佛是
  深观空三昧　　身心安不动
  谁得安隐眠　　所谓慈悲者
  常修不放逸　　视众如一子
  众生无明冥　　不见烦恼果
  常造诸恶业　　不得安隐眠
  若为于自身　　及以他人身
  造作十恶业　　不得安隐眠
  若言为乐故　　害父无过咎
  随是恶知识　　不得安隐眠
  若食过节度　　冷饮而过差
  如是则病苦　　不得安隐眠
  若于王有过　　邪念他妇女
  及行圹路者　　不得安隐眠
  持戒果未熟　　太子未绍位
  盗者未获财　　不得安隐眠

耆婆。我今病重。于正法王兴恶逆害。一切良医妙药咒术善巧瞻病所不能治。何以故。我父法王如法治国。实无辜咎横加逆害。如鱼处陆当有何乐。如鹿在弶初无欢心。如人自知命不终日。如王失国逃迸他土。如人闻病不可疗治。如破戒者闻说罪过。我昔曾闻智者说言。身口意业若不清净。当知是人必堕地狱。我亦如是。云何当得安隐眠耶。今我又无无上大医演说法药除我病苦。耆婆答言。善哉善哉。王虽作罪心生重悔而怀惭愧。大王。诸佛世尊常说是言。有二白法能救众生。一惭二愧。惭者自不作罪愧者不教他作。惭者内自羞耻。愧者发露向人。惭者羞人愧者羞天。是名惭愧。无惭愧者不名为人。名为畜生。有惭愧故则能恭敬父母师长。有惭愧故说有父母兄弟姊妹。善哉大王具有惭愧。大王且听。臣闻佛说。智者有二。一者不造诸恶。二者作已忏悔。愚者亦二。一者作罪。二者覆藏。虽先作恶后能发露。悔已惭愧更不敢作。犹如浊水置之明珠。以珠威力水即为清。如烟云除月则清明。作恶能悔亦复如是。王若忏悔怀惭愧者。罪即除灭清净如本。大王。富有二种。一者象马种种畜生。二者金银种种珍宝。象马虽多不敌一珠。大王。众生亦尔。一者恶富。二者善富。多作诸恶不如一善。臣闻佛说修一善心破百种恶。大王。如少金刚能坏须弥。亦如少火能烧一切。如少毒药能害众生。少善亦尔能破大恶。虽名少善其实是大。何以故。破大恶故。大王。如佛所说覆藏者漏。不覆藏者则无有漏。发露悔过是故不漏。若作众罪不覆不藏。以不覆故罪则微薄。若怀惭愧罪则消灭。大王。如水渧虽微渐盈大器。善心亦尔。一一善心能破大恶。若覆罪者罪则增长。发露惭愧罪则消灭。是故诸佛说有智者不覆藏罪。善哉大王。能信因果信业信报。唯愿大王莫怀愁怖。若有众生造作诸罪。覆藏不悔心无惭愧。不见因果及以业报。不能咨启有智之人不近善友。如是之人一切良医乃至瞻病所不能治。如迦摩罗病世医拱手。覆罪之人亦复如是。云何罪人。谓一阐提。一阐提者不信因果无有惭愧不信业报。不见现在及未来世。不亲善友。不随诸佛所说教戒。如是之人名一阐提。诸佛世尊所不能治。何以故。如世死尸医不能治。一阐提者亦复如是。诸佛世尊所不能治。大王今者。非一阐提。云何而言不可救疗

如王所言无能治者。大王当知。迦毗罗城净饭王子。姓瞿昙氏。字悉达多。无师觉悟自然而得阿耨多罗三藐三菩提。三十二相八十种好庄严其身。具足十力四无所畏一切知见大慈大悲。怜愍一切如罗睺罗。随善众生如犊逐母。知时而说非时不语。实语净语妙语义语法语一语。能令众生永离烦恼。善知众生诸根心性。随宜方便无不通达。其智高大如须弥山。深邃广远犹如大海。是佛世尊有金刚智。能破众生一切恶罪。若言不能无有是处。今者去此十二由旬。在拘尸那城娑罗双树间。而为无量阿僧祇等诸菩萨僧。演种种法。若有若无若有为若无为。若有漏若无漏。若烦恼果若善法果。若色法若非色法。若非色非非色法。若我若非我。若非我非非我。若常若非常。若非常非非常。若乐若非乐。若非乐非非乐。若相若非相。若非相非非相。若断若非断。若非断非非断。若世若出世。若非世非出世。若乘若非乘。若非乘非非乘。若自作自受。若自作他受。若无作无受。大王。若当于佛所闻无作无受。所有重罪即当消灭。王今且听。释提桓因命将欲终。有五相现。一者衣裳垢腻。二者头上花萎。三者身体臭秽。四者腋下汗出。五者不乐本座。时天帝释或于静处。若见沙门若婆罗门。即至其所生于佛想。尔时沙门及婆罗门见帝释来。深自庆幸即说是语。天主。我今归依于汝。释闻是已乃知非佛。复自念言。彼若非佛不能治我五退没相。是时御臣名般遮尸。语帝释言。憍尸迦。乾闼婆王名敦浮楼。其王有女字须跋陀。王若能以此女见与臣。当示王除衰相处。释即答言。善男子。毗摩质多阿修罗王有女舍脂。是吾所敬。卿若必能示吾消灭恶相处者。犹当相与。况须跋陀。憍尸迦。有佛世尊字释迦牟尼。今者在于王舍大城。若能往彼咨禀未闻。衰没之相必得除灭。善男子。若佛世尊审能灭者。便可回驾至其住处。御臣奉命即回车乘。到王舍城耆阇崛山。至于佛所头面礼足。却坐一面白佛言。世尊。天人之中谁为系缚。憍尸迦。悭贪嫉妒。又言。悭贪嫉妒因何而生。答言。因无明生。又言。无明复因何生。答言。因放逸生。又言。放逸复因何生。答言。因颠倒生。又言。颠倒复因何生。答言。因疑心生。世尊。颠倒之法因疑生者。实如圣教。何以故。我有疑心。以疑心故则生颠倒。于非世尊生世尊想。我今见佛疑网即除。疑网除故颠倒亦尽。颠倒尽故无有悭心乃至妒心。佛言。汝言无有悭妒心者。汝今已得阿那含耶。阿那含者无有贪心。若无贪心云何为命来至我所。而阿那含实不求命。世尊。有颠倒者则有求命。无颠倒者则不求命。然我今者实不求命。所欲求者唯佛法身及佛智慧。憍尸迦。求佛法身及佛智慧。将来之世必当得之。尔时帝释闻佛说已。五衰没相即时消灭。便起作礼绕佛三匝。恭敬合掌而白佛言。世尊。我今即死即生失命得命。又闻佛记当得阿耨多罗三藐三菩提。是为更生为更得命。世尊。一切人天云何增益。复以何缘而致损减。憍尸迦。斗诤因缘人天损减。善修和敬则得增益。世尊。若以斗诤而损减者。我从今日更不复与阿修罗战。佛言。善哉善哉。憍尸迦。诸佛世尊说忍辱法。是阿耨多罗三藐三菩提因

尔时释提桓因。即前礼佛。于是还去。大王。如来以能除诸恶相。是故称佛不可思议。王若往者。所有重罪必当得除。大王。且听有婆罗门子。字曰不害。以杀无量诸众生故名鸯崛魔。复欲害母。恶心起时身亦随动。身心动者即五逆因。五逆因故必堕地狱。后见佛时身心俱动复欲生害。身心动者即五逆因。五逆因故当入地狱。是人得遇如来大师。即时得灭地狱因缘。发阿耨多罗三藐三菩提心。是故称佛为无上医。非六师也。大王。复有须毗罗王子。其父嗔之截其手足推之深井。其母矜愍使人牵出将至佛所。寻见佛时手足还具。即发阿耨多罗三藐三菩提心。大王。以见佛故得现果报。是故称佛为无上医。非六师也。大王。如恒河边有诸饿鬼。其数五百。于无量岁初不见水。虽至河上纯见流火。饥渴所逼发声号哭。尔时如来。在其河侧郁昙钵林坐一树下。时诸饿鬼来至佛所。白佛言。世尊。我等饥渴命将不远。佛言。恒河流水汝何不饮。鬼即答言。如来见水我则见火。佛言。恒河清流实无火也。以恶业故心自颠倒。谓为是火。我当为汝除灭颠倒令汝见水。尔时世尊。广为诸鬼说悭贪过。诸鬼即言。我今渴乏。虽闻法言都不入心。佛言。汝若渴乏先可入河恣意饮之。是诸鬼等以佛力故即得饮水。既饮水已如来复为种种说法。既闻法已。悉发阿耨多罗三藐三菩提心。舍饿鬼形得于天身。大王。是故称佛为无上医。非六师也。大王。舍婆提国群贼五百。波斯匿王挑出其目。无有前导不能得往至于佛所。佛怜愍故即至贼所慰喻之言。善男子。善护身口更勿造恶。诸贼即时闻如来音微妙清彻寻还得眼。即于佛前合掌礼佛。而白佛言。世尊。我今知佛慈心普覆一切众生非独人天。尔时如来即为说法。既闻法已悉发阿耨多罗三藐三菩提心。是故如来真是世间无上良医。非六师也。大王。舍婆提国有旃陀罗。名曰气嘘。杀无量人。见佛弟子大目犍连。即时得破地狱因缘而得上生三十三天。以有如是圣弟子故。称佛如来为无上医。非六师也。大王。波罗捺城。有长者子。名阿逸多。淫匿其母。以是因缘杀戮其父。其母复与外人共通。子既知已便复害之。有阿罗汉是其知识。于此知识复生愧耻。即便杀之。杀已即到只桓精舍求欲出家。时诸比丘具知此人。有三逆罪无敢听者。以不听故倍生嗔恚。即于其夜大放猛火焚烧僧坊多杀无辜。然后复往王舍城中。至如来所求哀出家。如来即听为说法要。令其重罪渐渐轻微。发阿耨多罗三藐三菩提心。是故称佛为世良医。非六师也。大王。王本性暴恶信受恶人提婆达多。放大醉象欲令践佛。象既见佛即时醒悟。佛便申手摩其顶上。复为说法悉令得发阿耨多罗三藐三菩提心。大王。畜生见佛犹得破坏畜生业果。况复人耶。大王当知。若见佛者所有重罪必当得灭。大王。世尊未得阿耨多罗三藐三菩提时。魔与无量无边眷属至菩萨所。菩萨尔时以忍辱力坏魔恶心令魔受法。寻发阿耨多罗三藐三菩提心。佛有如是大功德力。大王。有圹野鬼多害众生。如来尔时为善贤长者至圹野村为其说法。时圹野鬼闻法欢喜。即以长者授于如来。然后便发阿耨多罗三藐三菩提心。大王。波罗奈国有屠儿。名曰广额。于日日中。杀无量羊。见舍利弗即受八戒经一日一夜。以是因缘命终得为北方天王毗沙门子。如来弟子尚有如是大功德果。况复佛也。大王。北天竺有城。名曰细石。其城有王。名曰龙印。贪国重位戮害其父。害其父已心生悔恨。即舍国政来至佛所求哀出家。佛言善来。即成比丘重罪消灭。发阿耨多罗三藐三菩提心。大王当知。佛有如是无量无边大功德果。大王。如来。有弟提婆达多。破坏众僧出佛身血害莲花比丘尼。作三逆罪。如来为说种种法要。令其重罪寻得微薄。是故如来为大良医。非六师也。大王。若能信臣语者。唯愿速往至如来所。若不见信愿善思之。大王。诸佛世尊大悲普覆不限一人。正法弘广无所不苞。怨亲平等心无憎爱。终不偏为一人令得阿耨多罗三藐三菩提余人不得。如来非独四部之师。普是一切天人龙鬼地狱畜生饿鬼等师。一切众生亦当视佛如父母想。大王当知。如来不但独为豪贵之人跋提迦王而演说法。亦为下贱优波离等。不独偏受须达多阿那邠坻所奉饭食。亦受贫人须达多食。不但独为舍利弗等利根说法。亦为钝根周梨槃特。不但独听大迦叶等无贪之性出家求道。亦听大贪难陀出家。不但独听烦恼薄者优楼频螺迦叶等出家求道。亦听烦恼深厚造重罪者波斯匿王弟优陀耶出家求道。不以莎草恭敬供养拔其嗔根。鸯崛魔罗恶心欲害舍而不救。不但独为有智男子而演说法。亦为极愚牉合智者女人说法。不但独令出家之人得四道果。亦令在家得三道果。不但独为富多罗等舍诸匆务闲寂思惟而说法要。亦为频婆娑罗王等统领国事理王务者而说法要。不但独为断酒之人。亦为耽酒郁伽长者荒醉者说。不但独为入禅定者离婆多等。亦为丧子乱心婆罗门女婆私吒说。不但独为己之弟子。亦为外道尼干子说。不但独为盛壮之年二十五者。亦为衰老八十者说。不但独为根熟之人。亦为善根未熟者说。不但独为末利夫人。亦为淫女莲花女说。不但独受波斯匿王上馔甘味。亦受长者尸利鞠多杂毒之食。大王当知。尸利鞠多往昔亦作逆罪之因。以遇佛闻法即发阿耨多罗三藐三菩提心。大王。假使一月常以衣食供养恭敬一切众生。不如有人一念念佛。所得功德十六分一。大王。假使锻金为人车马载宝。其数各百以用布施。不如有人发心向佛举足一步。大王。假使复以象车百乘载大秦国种种珍宝。及其女人身佩璎珞。数亦满百持用布施。犹故不如发心向佛举足一步。复置是事。若以四事供养三千大千世界所有众生。犹亦不如发心向佛举足一步。复置是事。若使大王供养恭敬恒河沙等无量众生。不如一往娑罗双树到如来所诚心听法。尔时大王答言。耆婆。如来世尊性已调柔。故得调柔以为眷属。如栴檀林纯以栴檀而为围绕。如来清净所有眷属亦复清净。犹如大龙纯以诸龙而为眷属。如来寂静所有眷属亦复寂静。如来无贪所有眷属亦复无贪。佛无烦恼所有眷属亦无烦恼。吾今既是极恶之人。恶业缠裹其身臭秽系属地狱。云何当得至如来所。吾设往者恐不顾念接叙言说。卿虽劝吾令往佛所。然吾今日深自鄙悼都无去心。尔时虚空寻出声言。无上佛法将欲衰殄。甚深法河于是欲涸。大法明灯将灭不久。法山欲颓法船欲沈。法桥欲坏法殿欲崩。法幢欲倒法树欲折。善友欲去。大怖将至。法饿众生将至不久。烦恼疫病将欲流行。大闇时至渴法时来。魔王欣庆解释甲胄。佛日将没大涅槃山。大王。佛若去世王之重恶更无治者。大王。汝今已造阿鼻地狱极重之业。以是业缘必受不疑。大王。阿者言无。鼻者名间。间无暂乐。故名无间。大王。假使一人独堕是狱。其身长大八万由延。遍满其中间无空处。其身周匝受种种苦。设有多人身亦遍满不相妨碍。大王。寒地狱中暂遇热风以之为乐。热地狱中暂遇寒风亦名为乐。活地狱中设命终已。若闻活声即便还活。阿鼻地狱都无此事。大王阿鼻地狱四方有门。一一门外各有猛火。东西南北交过通彻八万由延。周匝铁墙铁网弥覆其地亦铁。上火彻下下火彻上。大王。若鱼在[金*敖]脂膏焦然。是中罪人亦复如是。大王。作一逆者则便具受如是一罪。若造二逆罪则二倍。五逆具者罪亦五倍。大王。我今定知王之恶业必不得免。唯愿大王。速往佛所。除佛世尊余无能救。我今愍汝故相劝导。尔时大王闻是语已。心怀怖惧举身战栗。五体掉动如芭蕉树。仰而答曰。汝为是谁。不现色像而但有声。大王。吾是汝父频婆娑罗。汝今当随耆婆所说。莫随邪见六臣之言。时王闻已闷绝躄地。身疮增剧臭秽倍前。虽以冷药涂而治之。疮烝毒热但增无损

大般涅槃经卷第十九大般涅槃经卷第二十

        北凉天竺三藏昙无谶译

    梵行品第八之六

尔时世尊。在双树间见阿阇世闷绝躄地。即告大众。我今当为是王住世至无量劫不入涅槃。迦叶菩萨白佛言。世尊。如来当为无量。众生不入涅槃。何故独为阿阇世王。佛言。善男子。是大众中无有一人谓我毕定入于涅槃。阿阇世王定谓我当毕竟永灭。是故闷绝自投于地。善男子。如我所言。为阿阇世不入涅槃。如是密义汝未能解。何以故。我言为者。一切凡夫。阿阇世者普及一切造五逆者。又复为者。即是一切有为众生。我终不为无为众生而住于世。何以故。夫无为者。非众生也。阿阇世者。即是具足烦恼等者。又复为者。即是不见佛性众生。若见佛性我终不为久住于世。何以故。见佛性者。非众生也。阿阇世者。即是一切未发阿耨多罗三藐三菩提心者。又复为者。即是阿难迦叶二众。阿阇世者。即是阿阇世王后宫妃后及王舍城一切妇女。又复为者。名为佛性。言阿阇者。名为不生。世者名怨。以不生佛性故则烦恼怨生。烦恼怨生故不见佛性。以不生烦恼故则见佛性。以见佛性故。则得安住大般涅槃。是名不生。是故名为为阿阇世。善男子。阿阇者名不生。不生者名涅槃。世名世法。为者名不污。以世八法所不污故。无量无边阿僧祇劫不入涅槃。是故我言。为阿阇世。无量亿劫不入涅槃。善男子。如来密语不可思议。佛法众僧亦不可思议。菩萨摩诃萨亦不可思议。大涅槃经亦不可思议。尔时世尊大悲导师。为阿阇世王入月爱三昧。入三昧已放大光明。其光清凉往照王身。身疮即愈郁蒸除灭。王觉疮愈身体清凉。语耆婆言。曾闻人说劫将欲尽三月并现。当是之时一切众生患苦悉除。时既未至。此光何来照触吾身。疮苦除愈身得安乐。耆婆答言。此非劫尽三月并照。亦非火日星宿药草宝珠天光。王又问言。此光若非三月并照宝珠明者。为是谁光。大王当知。是天中天所放光明。是光无根无有边际。非热非冷非常非灭。非色非无色。非相非无相。非青非黄非赤非白。欲度众生。故使可见有相。可说有根有边有热有冷青黄赤白。大王。是光虽尔实不可说不可睹见。乃至无有青黄赤白。王言。耆婆。彼天中天。以何因缘放斯光明。大王。今是瑞相将为大王。以王先言世无良医疗治身心。故放此光先治王身然后治心。王言。耆婆。如来世尊亦见念耶。耆婆答言。譬如一人而有七子。是七子中一子遇病。父母之心非不平等。然于病子心则偏多。大王。如来亦尔。于诸众生非不平等。然于罪者心则偏重。于放逸者佛则慈念。不放逸者心则放舍。何等名为不放逸者。谓六住菩萨。大王。诸佛世尊于诸众生不观种姓老少中年贫富时节。日月星宿工巧下贱僮仆婢使。惟观众生有善心者。若有善心则便慈念。大王当知。如是瑞相。即是如来入月爱三昧所放光明。王即问言。何等名为月爱三昧。耆婆答言。譬如月光能令一切优钵罗花开敷鲜明。月爱三昧亦复如是。能令众生善心开敷。是故名为月爱三昧。大王。譬如月光能令一切行路之人心生欢喜。月爱三昧亦复如是。能令修习涅槃道者心生欢喜。是故复名月爱三昧。大王。譬如月光从初一日至十五日形色光明渐渐增长。月爱三昧亦复如是。令初发心诸善根本渐渐增长。乃至具足大般涅槃。是故复名月爱三昧。大王。譬如月光从十六日至三十日形色光明渐渐损减。月爱三昧亦复如是。光所照处所有烦恼能令渐灭。是故复名月爱三昧。大王。譬如盛热之时一切众生常思月光。月光既照郁热即除。月爱三昧亦复如是。能令众生除贪恼热。大王。譬如满月众星中王为甘露味。一切众生之所爱乐。月爱三昧亦复如是。诸善中王为甘露味。一切众生之所爱乐。是故复名月爱三昧

王言。我闻如来不与恶人同止坐起语言谈论。犹如大海不宿死尸。如鸳鸯鸟不住清厕。释提桓因不与鬼住。鸠翅罗鸟不栖枯树。如来亦尔。我当云何而得往见。设其见者。我身将不陷入地耶。我观如来。宁近醉象师子虎狼猛火绝焰。终不近于重恶之人。是故我今思忖是已。当有何心往见如来。耆婆答言。大王。譬如渴人速赴清泉。饥者求食。怖者求救。病求良医。热求荫凉。寒者求火。王今求佛亦应如是。大王。如来尚为一阐提等演说法要。何况大王非一阐提。而当不蒙慈悲救济。王言。耆婆。我昔曾闻。一阐提者不信不闻不能观察不得义理。何故如来而为说法。耆婆答言。大王。譬如有人身遇重病是人夜梦升一柱殿服苏油脂及以涂身。卧灰食灰攀上枯树。或与猕猴游行坐卧沉水没泥。堕坠楼殿高山树木。象马牛羊身着青黄赤黑色衣喜笑歌舞。或见乌鹫狐狸之属。齿发堕落裸形枕狗卧粪秽中。复与亡者行住坐起携手食啖。毒蛇满路而从中过。或复梦与被发女人共相抱持。多罗树叶以为衣服。乘坏驴车正南而游。是人梦已心生愁恼。以愁恼故身病踰增。以病增故诸家亲属遣使命医。所可遣使形体缺短根不具足。头蒙尘土著弊坏衣载故坏车。语彼医言。速疾上车。尔时良医即自思惟。今见是使相貌不吉。当知病者难可疗治。复作是念。使虽不吉当复占日为可治不。若四日六日八日十二日十四日。如是日者病亦难治。复作是念。日虽不吉当复占星为可治不。若是火星金星昴星阎罗王星湿星满星。如是星时病亦难治。复作是念。星虽不吉复当观时。若是秋时冬时及日入时夜半时月入时。当知是病亦难可治。复作是言。如是众相虽复不吉或定不定。当观病人若有福德皆可疗治。若无福德虽吉何益思惟是已寻与使俱。在路复念。若彼病者有长寿相则可疗治。短寿相者则不可治。即于前路见二小儿。相牵斗诤捉头拔发。瓦石刀杖共相撩打。见人持火自然殄灭。或见有人斫伐树木。或复见人手曳皮革随路而行。或见道路有遗落物。或见有人执持空器。或见沙门独行无侣。复见虎狼乌鹫野狐。见是事已复作是念。所遣使人乃至道路所见诸相悉皆不祥。当知病者定难疗治。复作是念。我若不往则非良师。如其往者不可救疗。复更念言。如是众相虽复不祥。且当舍置往至病所。思惟是已复于前路闻如是声。所谓亡失死丧崩破坏折剥脱堕坠焚烧。不来不可疗治不能拔济。复闻南方有飞鸟声。所谓乌鹫舍利鸟声。若狗若鼠野狐兔猪。闻是声已复作是念。当知病者难可疗治。尔时即入病人舍宅。见彼病人数寒数热骨节疼痛。目赤流泪耳声闻外咽喉结痛舌上裂破其色正黑。头不自胜体枯无汗。大小便利拥隔不通。身卒肥大红赤异常。语声不均或粗或细。举是斑驳异色青黄。其腹胀满言语不了。医见是已问瞻病言。病者咋来意志云何。答言。大师。其人本来敬信三宝及以诸天。今者变异敬信情息。本喜惠施今者悭吝。本性少食今则过多。本性和善今则弊恶。本性慈孝恭敬父母。今于父母无恭敬心。医闻是已即前嗅之优钵罗香沉水杂香毕迦多香多伽罗香多摩罗跋香郁金香栴檀香。炙肉臭蒱桃酒臭烧筋骨臭鱼臭粪臭。知香臭已即前触身。觉身细软犹如缯绵劫贝娑花。或硬如石或冷如冰或热如火或涩如沙。尔时良医见如是等种种相已。定知病者必死不疑然不定言是人当死语瞻病者。吾今剧务明当更来随其所须恣意勿遮。即便还家明日使到复语使言。我事未讫兼未合药。智者当知如是病者必死不疑。大王。世尊亦尔。于一阐提辈善知根性而为说法。何以故。若不为说。一切凡夫当言如来无大慈悲。有慈悲者名一切智若无慈悲云何说言一切智人。是故如来为一阐提而演说法。大王。如来世尊见诸病者当施法药。病者不服非如来咎。大王。一阐提辈分别有二。一者得现在善根。二者得后世善根。如来善知一闇提辈能于现在得善根者则为说法。后世得者亦为说法。今虽无益作后世因。是故如来为一阐提演说法要。一阐提者复有二种。一者利根。二者中根。利根之人于现在世能得善根。中根之人后世则得。诸佛世尊不空说法。大王。譬如净人坠堕清厕。有善知识见而愍之寻前捉发而拔出之。诸佛如来亦复如是。见诸众生堕三恶道。方便救济令得出离。是故如来为一阐提而演说法。王语耆婆。若使如来审如是者。明当选择良日吉星然后乃往。耆婆白王。大王。如来法中无有选择良日吉星。大王。如重病人犹不看日时节吉凶惟求良医。王今病重求佛良医。不应选择良时好日。大王。如栴檀火及芛兰火。二俱烧相无有异也。吉日凶日亦复如是。若到佛所俱得灭罪。惟愿大王今日速往。尔时大王即命一臣名曰吉祥。而告之言。大臣当知吾今欲往佛世尊所。速办供养所须之具。臣言。大王。善哉善哉所须供具一切悉有。阿阇世王与其夫人严驾车乘一万二千。姝壮大象其数五万。一一象上各载三人。赍持幡盖花香伎乐种种供具无不备足。导从马骑有十八万。摩伽陀国所有人民寻从王者。其数足满五十八万。尔时拘尸那城所有大众满十二由旬。悉皆遥见阿阇世王与其眷属寻路而来。尔时佛告诸大众言。一切众生为阿耨多罗三藐三菩提近因缘者莫先善友。何以故。阿阇世王若不随顺耆婆语者。来月七日必定命终堕阿鼻狱。是故近因莫若善友。阿阇世王。复于前路闻舍婆提毗流离王乘船入海遇火而死。瞿伽离比丘生身入地至阿鼻狱。须那刹多作种种恶到于佛所众罪得灭。闻是语已语耆婆言。吾今虽闻如是二语犹未审定。汝来耆婆。吾欲与汝同载一象。设我当入阿鼻地狱。冀汝捉持不令我堕。何以故。吾昔曾闻得道之人不入地狱

尔时佛告诸大众言。阿阇世王犹有疑心。我今当为作决定心。尔时会中有一菩萨。名持一切。白佛言。世尊。如佛先说一切诸法皆无定相所谓色无定相乃至涅槃亦无定相。如来今者云何而言。为阿阇世作决定心。佛言。善哉善哉。善男子。我今定为阿阇世王作决定心。何以故。若王疑心可破坏者。当知诸法无有定相。是故我为阿阇世王作决定心。当知是心为无决定。善男子。若彼王心是决定者。王之逆罪云何可坏。以无定相其罪可坏。是故我为阿阇世王作决定心。尔时大王即到娑罗双树间。至于佛所仰瞻如来三十二相八十种好。犹如微妙真金之山。尔时世尊出八种声告言。大王。时阿阇世左右顾视此大众中谁是大王。我既罪戾又无福德。如来不应称为大王。尔时如来即复唤言。阿阇世大王。时王闻已心大欢喜即作是言。如来今日顾命语言。真知如来于诸众生大悲怜愍等无差别。白佛言。世尊。我今疑心永无遗余。定知如来真是众生无上大师。尔时迦叶菩萨语持一切菩萨言。如来已为阿阇世王作决定心。尔时阿阇世王即白佛言。世尊。假使我今得与梵王释提桓因坐起饮食犹不欣悦。得遇如来一言顾命深以欣庆。尔时阿阇世王即以所持幡盖香花伎乐供养。前礼佛足右绕三匝。礼敬毕已却坐一面

尔时佛告阿阇世王言。大王。今当为汝说正法要。汝当一心谛听谛听。凡夫常当系心观身。有二十事。 一所谓我此身中空无无漏 。二无诸善根本。三我此生死未得调顺。四堕坠深坑无处不畏。五以何方便得见佛性。六云何修定得见佛性。七生死常苦无常我净。八八难之难难得远离。九恒为怨家之所追逐。十无有一法能遮诸有。十一于三恶趣未得解脱。十二具足种种诸恶邪见。十三亦未造立度五逆津。十四生死无际未得其边。十五不作诸业不得果报。十六无有我作他人受果。十七不作乐因终无乐果。十八若有造业果终不失。十九因无明生亦因而死 二十去来现在常行放逸 。大王。凡夫之人常于此身当作如是二十种观。作是观已不乐生死。不乐生死则得正观。尔时次第观心生相住相灭相。次第观心生住灭相。定慧进戒亦复如是观生住灭已。知心相乃至戒相。终不作恶。无有死畏三恶道畏。若不系心观察如是二十事者。心则放逸无恶不造。阿阇世言。如我解佛所说义者。我从昔来初未曾观是二十事故造众恶。造众恶故则有死畏三恶道畏。世尊。自我招殃造兹重恶。父王无辜横加逆害。是二十事设观不观。必定当堕阿鼻地狱。佛告大王。一切诸法性相无常无有决定。王云何言必定当堕阿鼻地狱。阿阇世王白佛言。世尊。若一切法无定相者。我之杀罪亦应不定。若杀定者一切诸法则非不定。佛言。大王。善哉善哉。诸佛世尊说一切法悉无定相。王复能知杀亦不定。是故当知杀无定相。大王。如汝所言。先父无辜横加逆害者。何者是父。但于假名众生五阴妄生父想。于十二入十八界中何者是父。若色是父四阴应非。若四是父色亦应非。若色非色合为父者无有是处。何以故。色与非色性无合故。大王。凡夫众生于是色阴妄生父想。如是色阴亦不可害。何以故。色有十种。是十种中唯色一种。可见可持可称可量可牵可缚。虽可见缚其性不住。以不住故不可得见不可捉持不可称量不可牵缚。色相如是云何可杀。若色是父可杀可害获罪报者。余九应非。若九非者则应无罪。大王。色有三种。过去未来现在。过去现在则不可害。何以故。过去过去故。现在念念灭故。遮未来故名之为杀。如是一色或有可杀。或不可杀。有杀不杀色则不定。若色不定杀亦不定。杀不定故报亦不定。云何说言定入地狱。大王。一切众生所作罪业凡有二种。一者轻二者重。若心口作则名为轻。身口心作则名为重。大王。心念口说身不作者所得报轻。大王。昔日口不敕杀但言削足。大王。若敕侍臣立斩王首坐时乃斩犹不得罪。况王不敕云何得罪。王若得罪。诸佛世尊亦应得罪。何以故。汝父先王频婆娑罗。常于诸佛种诸善根。是故今日得居王位。诸佛若不受其供养则不为王。若不为王汝则不得为国生害。若汝杀父当有罪者。我等诸佛亦应有罪。若诸佛世尊无有罪者。汝独云何而得罪耶。大王。频婆娑罗往有恶心。于毗富罗山游行猎鹿。周遍圹野悉无所得。唯见一仙五通具足。见已即生嗔恚恶心。我今游猎所以不得。正坐此人驱逐令去。即敕左右而令杀之。其人临终生嗔恶心退失神通。而作誓言。我实无辜汝以心口横加戮害。我于来世亦当如是还以心口而害于汝。时王闻已即生悔心供养死尸是王如是尚得轻受不堕地狱。况王不尔。而当地狱受果报耶。先王自作还自受之。云何令王而得杀罪。如王所言父王无辜者。大王。云何言无。夫有罪者则有罪报。无恶业者则无罪报。汝父先王若无辜罪云何有报。频婆娑罗于现世中亦得善果及以恶果。是故先王亦复不定。以不定故杀亦不定。杀不定故云何而言定入地狱

大王。众生狂惑凡有四种。一者贪狂。二者药狂。三者咒狂。四者本业缘狂。大王。我弟子中有是四狂。虽多作恶。我终不记是人犯戒。是人所作不至三恶。若还得心亦不言犯。王本贪国逆害父王。贪狂心作云何得罪。大王。如人酒醉逆害其母。既醒寤已心生悔恨。当知是业亦不得报。王今贪醉非本心作。若非本心云何得罪。大王譬如幻师四衢道头幻作种种男女象马璎珞衣服。愚痴之人谓为真实。有智之人知非真有。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。譬如山间响声。愚痴之人谓之实声。有智之人知其非真。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。如人有怨诈来亲附。愚痴之人谓为实亲。智者了达乃知虚诈。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。如人执镜自见面像。愚痴之人谓为真面。智者了达知其非真。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。如热时炎。愚痴之人谓之是水。智者了达知其非水。杀亦如是。凡夫谓实诸佛世尊知其非真。大王。如乾闼婆城。愚痴之人谓为真实。智者了达知其非真。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。如人梦中受五欲乐。愚痴之人谓之为实。智者了达知其非真。杀亦如是。凡夫谓实。诸佛世尊知其非真。大王。杀法杀业杀者杀果及以解脱。我皆了之则无有罪。王虽知杀。云何有罪。大王。譬如有人主知典酒。如其不饮则亦不醉。虽复知火亦不烧然。王亦如是虽复知杀云何有罪。大王。有诸众生于日出时作种种罪。于月出时复行劫盗。日月不出则不作罪。虽因日月令其作罪。然此日月实不得罪。杀亦如是。虽复因王王实无罪。大王。如王宫中常敕屠羊心初无惧。云何于父独生惧心。虽复人畜尊卑差别。宝命畏死二俱无异。何故于羊心轻无惧。于父先王生重忧苦。大王。世间之人是爱僮仆不得自在。为爱所使而行杀害。设有果报乃是爱罪。王不自在当有何咎。大王。譬如涅槃非有非无而亦是有。杀亦如是。虽非有非无而亦是有。惭愧之人则为非有。无惭愧者则为非无。受果报者名之为有。空见之人则为非有。有见之人则为非无。有有见者亦名为有。何以故。有有见者得果报故。无有见者则无果报。常见之人则为非有。无常见者则为非无。常常见者不得为无。何以故。常常见者有恶业果故。是故常常见者不得为无。以是义故虽非有无而亦是有。大王。夫众生者名出入息。断出入息故名为杀。诸佛随俗亦说为杀。大王。色是无常。色之因缘亦是无常。从无常因生色云何常。乃至识是无常。识之因缘亦是无常。从无常因生识云何常。以无常故苦。以苦故空。以空故无我。若是无常苦空无我为何所杀。杀无常者得常涅槃。杀苦得乐杀空得实。杀于无我而得真我。大王。若杀无常苦空无我者则与我同。我亦杀于无常苦空无我不入地狱。汝云何入

尔时阿阇世王。如佛所说观色乃至观识。作是观已即白佛言。世尊。我今始知色是无常乃至识是无常。我本若能如是知者则不作罪。世尊。我昔曾闻诸佛世尊常为众生而作父母。虽闻是语犹未审定。今则定知。世尊。我亦曾闻须弥山王四宝所成。所谓金银琉璃颇梨。若有众鸟随所集处则同其色。虽闻是言亦不审定。我今来至佛须弥山则与同色。与同色者则知诸法无常苦空无我。世尊。我见世间从芛兰子生芛兰树。不见芛兰生栴檀树。我今始见从芛兰子生栴檀树。芛兰子者我身是也。栴檀树者即是我心无根信也。无根者。我初不知恭敬如来。不信法僧。是名无根。世尊。我若不遇如来世尊。当于无量阿僧祇劫在大地狱受无量苦。我今见佛以是见佛所得功德。破坏众生所有一切烦恼恶心

佛言。大王。善哉善哉。我今知汝必能破坏众生恶心。世尊。若我审能破坏众生诸恶心者。使我常在阿鼻地狱。无量劫中为诸众生受大苦恼不以为苦。尔时摩伽陀国无量人民悉发阿耨多罗三藐三菩提心。以如是等无量人民发大心故。阿阇世王所有重罪即得微薄。王及夫人后宫婇女悉皆同发阿耨多罗三藐三菩提心。尔时阿阇世王语耆婆言。耆婆。我今未死已得天身舍于短命而得长命。舍无常身而得常身。令诸众生发阿耨多罗三藐三菩提心。即是天身长命常身。即是一切诸佛弟子。说是语已即以种种宝幢幡盖香花璎珞微妙伎乐而供养佛。复以偈颂而赞叹言

  实语甚微妙　　善巧于句义
  甚深秘密藏　　为众故显示
  所有广博言　　为众故略说
  具足如是言　　善能疗众生
  若有诸众生　　得闻是语者
  若信及不信　　定知是佛说
  诸佛常软语　　为众故说粗
  粗语及软语　　皆归第一义
  是故我今者　　归依于世尊
  如来语一味　　犹如大海水
  是名第一谛　　故无无义语
  如来今所说　　种种无量法
  男女大小闻　　同获第一义
  无因亦无果　　无生及无灭
  是名大涅槃　　闻者破诸果
  如来为一切　　常作慈父母
  当知诸众生　　皆是如来子
  世尊大慈悲　　为众故苦行
  如人着鬼魅　　狂乱多所作
  我今得见佛　　所得三业善
  愿以此功德　　回向无上道
  我今所供养　　佛法及众僧
  愿以此功德　　三宝常在世
  我今所当得　　种种诸功德
  愿以此破坏　　众生四种魔
  我遇恶知识　　造作三世罪
  今于佛前悔　　愿后更莫造
  愿诸众生等　　悉发菩提心
  系心常思念　　十方一切佛
  复愿诸众生　　永破诸烦恼
  了了见佛性　　犹如妙德等

尔时世尊赞阿阇世王。善哉善哉。若有人能发菩提心。当知是人则为庄严诸佛大众。大王。汝昔已于毗婆尸佛初发阿耨多罗三藐三菩提心。从是已来至我出世。于其中间未曾堕于地狱受苦。大王当知。菩提之心乃有如是无量果报。大王。从今已往常当勤修菩提之心。何以故。从是因缘当得消灭无量恶故。尔时阿阇世王。及摩伽陀举国人民从座而起绕佛三匝辞退还宫。天行品者如杂花说

    大般涅槃经婴儿行品第九

善男子。云何名婴儿行。善男子。不能起住来去语言。是名婴儿。如来亦尔不能起者。如来终不起诸法相。不能住者。如来不着一切诸法。不能来者。如来身行无有动摇。不能去者。如来已到大般涅槃。不能语者。如来虽为一切众生演说诸法实无所说。何以故。有所说者名有为法。如来世尊非是有为是故无说。又无语者犹如婴儿。语言未了。虽复有语实亦无语。如来亦尔。诘未了者即是诸佛秘密之言。虽有所说众生不解故名无语。又婴儿者名物不一未知正语。虽名物不一未知正语。非不因此而得识物。如来亦尔。一切众生方类各异所言不同。如来方便随而说之。亦令一切因而得解。又婴儿者能说大字。如来亦尔说于大字。所谓婆啝。啝者有为婆者无为。是名婴儿。啝者名为无常。婆者名为有常。如来说常众生闻已为常法故断于无常。是名婴儿行。又婴儿者。不知苦乐昼夜父母。菩萨摩诃萨亦复如是。为众生故不知苦乐无昼夜想。于诸众生其心平等。故无父母亲疏等相。又婴儿者。不能造作大小诸事。菩萨摩诃萨亦复如是。菩萨不造生死作业是名不作。大事者即五逆也。菩萨摩诃萨终不造作五逆重罪。小事者即二乘心。菩萨终不退菩提心而作声闻辟支佛乘。又婴儿行者。如彼婴儿啼哭之时。父母即以杨树黄叶而语之言。莫啼莫啼我与汝金。婴儿见已生真金想便止不啼。然此杨叶实非金也。木牛木马木男木女。婴儿见已亦复生于男女等想。即止不啼。实非男女。以作如是男女想故名曰婴儿。如来亦尔。若有众生欲造众恶。如来为说三十三天常乐我净端正自恣。于妙宫殿受五欲乐。六根所对无非是乐。众生闻有如是乐故心生贪乐。止不为恶。勤作三十三天善业。实是生死无常无乐无我无净。为度众生方便说言常乐我净。又婴儿者。若有众生厌生死时。如来则为说于二乘。然实无有二乘之实。以二乘故知生死过见涅槃乐。以是见故则能自知。有断不断有真不真有修不修有得不得。善男子。如彼婴儿于非金中而生金想。如来亦尔。于不净中而为说净。如来已得第一义故则无虚妄。如彼婴儿于非牛马作牛马想。若有众生于非道中作真道想。如来亦说非道为道。非道之中实无有道。以能生道微因缘故说非道为道。如彼婴儿于木男女生男女想。如来亦尔。知非众生说众生想。而实无有众生相也。若佛如来说无众生。一切众生则堕邪见。是故如来说有众生。于众生中作众生想者。则不能破众生相也。若于众生破众生相者。是则能得大般涅槃。以得如是大涅槃故止不啼哭。是名婴儿行。善男子。若有男女受持读诵书写解说是五行者。当知是人必定当得如是五行。迦叶菩萨白佛言。世尊。如我解佛所说义者。我亦定当得是五行。佛言。善男子。不独汝得如是五行。今此会中九十三万人亦同于汝得是五行

大般涅槃经卷第二十大般涅槃经卷第二十一

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之一

尔时世尊。告光明遍照高贵德王菩萨摩诃萨言。善男子。若有菩萨摩诃萨修行如是大涅槃经。得十事功德。不与声闻辟支佛共。不可思议闻者惊怪。非内非外非难非易非相非非相。非是世法无有相貌世间所无。何等为十。一者有五。何等为五。一者所不闻者而能得闻。二者闻已能为利益。三者能断疑惑之心。四者慧心正直无曲。五者能知如来密藏。是为五事。何等不闻而能得闻。所谓甚深微密之藏。一切众生悉有佛性。佛法众僧无有差别。三宝性相常乐我净。一切诸佛无有毕竟入涅槃者常住无变。如来涅槃。非有非无。非有为非无为。非有漏非无漏。非色非不色。非名非不名。非相非不相。非有非不有。非物非不物。非因非果。非待非不待。非明非闇非出非不出。非常非不常。非断非不断。非始非终。非过去非未来非现在。非阴非不阴。非入非不入。非界非不界。非十二因缘非不十二因缘。如是等法甚深微密。昔所不闻而能得闻。复有不闻。所谓一切外道经书四毗陀论毗伽罗论卫世师论迦毗罗论。一切咒术医方伎艺。日月博蚀星宿运变图书谶记如是等经。初未曾闻。秘密之义今于此经而得知之。复有十一部经除毗佛略。亦无如是深密之义。今因此经而得知之。善男子。是名不闻而能得闻。闻已利益者。若能听受是大涅槃经。悉能具知一切方等大乘经。典甚深义味。譬如男女于明净镜见其色像了了分明。大涅槃镜亦复如是。菩萨执之悉得明见大乘经典甚深之义。亦如有人在闇室中执大炬火悉见诸。物大涅槃炬亦复如是。菩萨执之得见大乘深奥之义。亦如日出有千光明。悉能照了诸山幽闇。令一切人远见诸物。是大涅槃清净慧日亦复如是。照了大乘深邃之处。令二乘人远见佛道。所以者何。以能听受是大涅槃微妙经典故。善男子。若有菩萨摩诃萨听受如是大涅槃经。得知一切诸法名字。若能书写读诵通利。为他广说思惟其义。则知一切诸法义理。善男子。其听受者唯知名字。不知其义。若能书写受持读诵。为他广说思惟其义。则能知义。复次善男子。听是经者闻有佛性未能得见。书写读诵为他广说思惟其义则得见之。听是经者闻有檀名未能得见檀波罗蜜。书写读诵为他广说思惟其义。则能得见檀波罗蜜。乃至般若波罗蜜亦复如是。善男子。菩萨摩诃萨若能听是大涅槃经。则知法知义具二无碍。于诸沙门婆罗门等。若天魔梵一切世中得无所畏。开示分别十二部经演说其义无有差违。不从他闻而能自知。近于阿耨多罗三藐三菩提。善男子。是名闻已能为利益。断疑心者。疑有二种。一者疑名。二者疑义。听是经者断疑名心。思惟义者断疑义心。复次善男子。疑有五种。一者疑佛定涅槃不。二者疑佛是常住不。三者疑佛是真乐不。四者疑佛是真净不。五者疑佛是实我不。听是经者疑佛涅槃则得永断。书写读诵为他广说思惟其义四疑永断。复次善男子。疑有三种。一疑声闻为有为无。二疑缘觉为有为无。三疑佛乘为有为无。听是经者如是三疑永灭无余。书写读诵为他广说思惟其义。则能了知一切众生悉有佛性。复次善男子。若有众生不闻如是大涅槃经其心多疑。所谓若常无常若乐不乐若净不净若我无我。若命非命。若众生非众生。若毕竟不毕竟。若他世若过世。若有若无。若苦若非苦若集若非集若道若非道若灭若非灭。若法若非法。若善若非善。若空若非空。听是经者如是诸疑悉得永断。复次善男子。若有不闻如是经者。复有种种众多疑心。所谓色是我耶受想行识是我耶。眼能见耶我能见耶。乃至识能知耶我能知耶。色受报耶我受报耶。乃至识受报耶我受报耶。色至他世耶我至他世耶。乃至识亦如是。生死之法有始有终耶。无始无终耶听是经者如是等疑亦得永断。复有人疑。一阐提人犯四重禁作五逆罪谤方等经。如是等辈有佛性耶无佛性耶。听是经者如是等疑悉得永断。复有人疑。世间有边耶世间无边耶。有十方世界耶无十方世界耶。听是经者如是等疑亦得永断。是名能断疑惑之心。慧心正直无邪曲者。心若有疑则所见不正。一切凡夫若不得闻是大涅槃微妙经典所见邪曲。乃至声闻辟支佛人所见亦曲。云何名为一切凡夫所见邪曲。于有漏中见常乐我净。于如来所见无常苦不净无我。见有众生寿命知见。计非有想非无想处以为涅槃。见自在天有八圣道。有见断见如是等见名为邪曲。菩萨摩诃萨若得闻是大涅槃经。修行圣行则得断除如是邪曲。云何名为声闻缘觉邪曲见耶。见于菩萨从兜率下化乘白象降神母胎。父名净饭母曰摩耶。迦毗罗城处胎满足十月而生。生未至地帝释捧接。难陀龙王及婆难陀吐水而浴。摩尼跋陀大鬼神王执持宝盖随后侍立地神化花以承其足。四方各行满足七步。到于天庙令诸天像悉起承迎阿私陀仙抱持占相。既占相已生大悲苦。自伤当终不睹佛兴。诣师学书算计射御图谶伎艺。处在深宫六万婇女娱乐受乐。出城游观至迦毗罗园。道见老人乃至沙门法服而行。还至宫中见诸婇女形体状貌犹如枯骨。所有宫殿冢墓无异。厌恶出家夜半踰城。至郁陀伽阿罗逻等大仙人所。闻说识处及非有想非无想处。既闻是已谛观是处是非常苦不净无我舍至树下具修苦行满足六年。知是苦行不能得成阿耨多罗三藐三菩提。尔时复到阿利跋提河中洗浴。受牧牛女所奉乳糜。受已转至菩提树下。破魔波旬得成阿耨多罗三藐三菩提。于波罗奈为五比丘初转法轮。乃至于此拘尸那城入般涅槃。如是等见。是名声闻缘觉曲见。善男子。菩萨摩诃萨听受如是大涅槃经。悉得断除如是等见。若能书写读诵通利为他演说思惟其义。则得正直无邪曲见。善男子。菩萨摩诃萨修行如是大涅槃经。谛知菩萨无量劫来不从兜率降神母胎。乃至拘尸那城入般涅槃。是名菩萨摩诃萨正直之见。能知如来深密义者。所谓即是大般涅槃一切众生悉有佛性。忏四重禁除谤法心尽五逆罪灭一阐提。然后得成阿耨多罗三藐三菩提。是名甚深秘密之义。复次善男子。云何复名甚深之义。虽知众生实无有我。而于未来不失业果。虽知五阴于此灭尽。善恶之业终不败亡。虽有诸业不得作者。虽有至处无有去者。虽有系缚无受缚者。虽有涅槃亦无灭者。是名甚深秘密之义。尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如我解佛所说闻不闻。义是义不。然何以故。法若有者便应定有。法若无者便应定无。无不应生有不应灭。如其闻者是则为闻。若不闻者则为不闻。云何而言闻所不闻。世尊。若不可闻是为不闻。若已闻者则更不闻。何以故。已得闻故。云何而言闻所不闻。譬如去者。到则不去去则不到。亦如生已不生不生不生。得已不得不得不得。闻已不闻不闻不闻亦复如是。世尊。若不闻闻者。一切众生未有菩提即应有之。未得涅槃亦应得之。未见佛性应见佛性。云何复言十住菩萨虽见佛性未得明了。世尊。若不闻闻者。如来往昔从谁得闻。若言得闻。何故如来于阿含中复言无师。若不闻不闻如来得成阿耨多罗三藐三菩提者。一切众生不闻不闻亦应得成阿耨多罗三藐三菩提。如来若当不闻如是大涅槃经见佛性者。一切众生不闻是经亦应得见。世尊。凡是色者或有可见或不可见。声亦如是或是可闻或不可闻。是大涅槃非色非声。云何而言可得见闻。世尊。过去已灭则不可闻。未来未至亦不可闻。现在听时则不名闻。闻已声灭更不可闻。是大涅槃亦非过去未来现在。若非三世则不可说。若不可说则不可闻。云何而言菩萨修是大涅槃经闻所不闻

尔时世尊赞光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。汝今善知一切诸法。如幻如焰如乾闼婆城画水之迹。亦如泡沫芭蕉之树空无有实。非命非我无有苦乐。如十住菩萨之所知见。时大众中忽然之顷有大光明。非青见青非黄见黄非赤见赤非白见白。非色见色非明见明非见而见。尔时大众遇斯光已身心快乐。譬如比丘入师子王定。尔时文殊师利菩萨摩诃萨白佛言。世尊。今此光明谁之所放。尔时如来默然不说。迦叶菩萨复问文殊师利。何因缘故有此光明照于大众。文殊师利默然不答。尔时无边身菩萨复问迦叶菩萨。今此光明谁之所有。迦叶菩萨默然不说。净住王子菩萨复问无边身菩萨。何因缘故是大众中有此光明。无边身菩萨默然不说。如是五百菩萨皆亦如是。虽相咨问然无答者。尔时世尊问文殊师利言。文殊师利。何因缘故。是大众中有此光明。文殊师利言。世尊。如是光明名为智慧。智慧者即是常住。常住之法无有因缘。云何佛问何因缘故有是光明。是光明者名大涅槃。大涅槃者则名常住。常住之法不从因缘。云何佛问何因缘故有是光明。是光明者即是如来。如来者即是常住。常住之法不从因缘。云何如来问于因缘。光明者名大慈大悲。大慈大悲者名为常住。常住之法不从因缘。云何如来问于因缘。光明者即是念佛。念佛者是名常住。常住之法不从因缘。云何如来问于因缘。光明者即是一切声闻缘觉不共之道。声闻缘觉不共之道即名常住。常住之法不从因缘。云何如来问于因缘。世尊。亦有因缘因灭无明。则得炽然阿耨多罗三藐三菩提灯。佛言。文殊师利。汝今莫入诸法甚深第一义谛。应以世谛而解说之。文殊师利言。世尊。于此东方过二十恒河沙等世界。有佛世界名曰不动。其佛住处纵广正等足满一万二千由旬。其地七宝无有土石。平正柔软无诸沟坑。其诸树木四宝所成。金银琉璃及以颇梨。花果茂盛无时不有。若有众生闻其花香身心安乐。譬如比丘入第三禅。周匝复有三千大河。其水微妙八味具足。若有众生在中浴者。所得喜乐譬如比丘入第二禅。其河多有种种诸花。优钵罗花波头摩花拘物头花分陀利花香花大香花微妙香花常花一切众生无遮护花。其河两岸亦有众花。所谓阿提目多伽花占婆花波吒罗花婆师罗花摩利迦花大摩利迦花新摩利迦花须摩那迦花由提迦花檀[少/兔]迦利花常花一切众生无遮护花。底布金沙有四梯梐金银琉璃杂色颇梨。多有众鸟游集其上。复有无量虎狼师子诸恶鸟兽。其心相视犹如赤子。彼世界中一切无有犯重禁者。诽谤正法及一阐提五逆等罪。其土调适无有寒热饥渴苦恼。无贪欲恚放逸嫉妒。无有日月昼夜时节。犹如第二忉利天上。其土人民等有光明。各各无有憍慢之心。一切悉是菩萨大士。皆得神通具大功德。其心悉皆尊重正法。乘于大乘爱念大乘贪乐大乘护惜大乘。大慧成就得大总持。心常怜愍一切众生。其佛号曰满月光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。随所住处有所讲宣。其土众生无不得闻为琉璃光菩萨摩诃萨讲宣如是大涅槃经。佛言。善男子。菩萨摩诃萨若能修行大涅槃经。所不闻者皆悉得闻。彼琉璃光菩萨摩诃萨问满月光明佛。亦如此间光明遍照高贵德王菩萨摩诃萨所问等无有异。彼满月光明佛即告琉璃光菩萨言。善男子。西方去此二十恒河沙佛土。彼有世界名曰娑婆。其土多有山陵堆阜土沙砾石荆蕀毒刺周遍充满。常有饥渴寒热苦恼。其土人民不能恭敬沙门婆罗门父母师长。贪着非法欲于非法修行邪法不信正法寿命短促。有行奸诈王者治之。王虽有国不知满足。于他所有生贪利心。兴师相伐枉死者众王者。修行如是非法。四天善神心无欢喜。故降灾旱谷米不登人民多病苦恼无量。彼中有佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。大悲纯厚愍众生故。于拘尸那城娑罗双树间。为诸大众敷演如是大涅槃经。彼有菩萨名光明遍照高贵德王。已问斯事如汝无异。佛今答之汝可速往自当得闻。世尊。彼琉璃光菩萨闻是事已。与八万四千菩萨摩诃萨欲来至此故先现瑞。以此因缘有此光明。是名因缘亦非因缘。尔时琉璃光菩萨与八万四千诸菩萨俱。持诸幡盖香花璎珞种种伎乐倍胜于前。俱来至此拘尸那城娑罗双树间。以己所持供养之具供养于佛。头面礼足合掌恭敬右绕三匝。修敬已毕却坐一面

尔时世尊问彼菩萨。善男子。汝为到来为不到来。琉璃光菩萨言。世尊。到亦不来不到亦不来。我观是义都无有来。世尊。诸行若常亦复不来。若是无常亦无有来。若人见有众生性者有来不来。我今不见众生定性。云何当言有来不来。有憍慢者见有去来。无憍慢者则无去来。有取行者见有去来。无取行者则无去来。若见如来毕竟涅槃则有去来。不见如来毕竟涅槃则无去来。不闻佛性则有去来。闻佛性者则无去来。若见声闻辟支佛人有涅槃者则有去来。不见声闻辟支佛人有涅槃者则无去来。若见声闻辟支佛人常乐我净则有去来。若不见者则无去来。若见如来无常乐我净则有去来。若见如来常乐我净则无去来。世尊。且置斯事欲有所问。唯垂哀愍少见听许。佛言。善男子。随意所问今正是时。我当为汝分别解说。所以者何。诸佛难值如优昙花。法亦如是难可得闻。十二部经中方等复难。是故应当专心听受。时琉璃光菩萨摩诃萨。既蒙听许兼被诫敕。即白佛言。世尊。云何菩萨摩诃萨有能修行大涅槃经闻所不闻。尔时如来赞言。善哉善哉。善男子。汝今欲尽如是大乘大涅槃海。正复值我能善解说。汝今所有疑网毒镞。我为大医能善拔出。汝于佛性犹未明了。我有慧炬能为照明。汝今欲度生死大河。我能为汝作大船师。汝于我所生父母想。我亦于汝生赤子心。汝心今者贪正法宝。值我多有能相惠施。谛听谛听善思念之。吾当为汝分别宣释。善男子。欲听法者今正是时。若闻法已当生敬信。至心听受恭敬尊重。于正法所莫求其过。莫念贪欲嗔恚愚痴。莫睹法师种姓好恶。既闻法已莫生憍慢。莫为恭敬名誉利养。当为度世甘露法利。亦莫生念。我听法已先自度身然后度人。先自解身然后解人。先自安身然后安人。先自涅槃然后令人而得涅槃。于佛法僧应生等想。于生死中生大苦想。于大涅槃应生常乐我净之想。先为他人然后为身。当为大乘莫为二乘。于一切法当无所住。亦莫专执一切法相。于诸法中莫生贪相。常生知法见法之相。善男子。汝能如是至心听法。是则名为闻所不闻。善男子。有不闻闻有不闻不闻有闻不闻有闻闻。善男子。如不生生。不生不生。生不生。生生。如不到到。不到不到。到不到。到到。世尊。云何不生生。善男子。安住世谛初出胎时。是名不生生。云何不生不生。善男子。是大涅槃无有生相。是名不生不生。云何生不生。善男子。世谛死时是名生不生。云何生生。善男子。一切凡夫是名生生。何以故。生生不断故。一切有漏念念生故。是名生生。四住菩萨名生不生。何以故。生自在故是名生不生。善男子。是名内法。云何外法。未生生。未生未生。生未生。生生。善男子。譬如种子未生牙时。得四大和合人功作业然后乃生。是名未生生。云何未生未生。譬如败种及未遇缘。如是等辈名未生未生。云何生未生。如牙生已而不增长。是名生未生。云何生生。如牙增长。若生不生则无增长。如是一切有漏是名外法生生。琉璃光菩萨摩诃萨白佛言。世尊。有漏之法若有生者。为是常耶是无常乎。生若是常有漏之法则无有生。生若无常则有漏是常。世尊。若生能自生生无自性。若能生他以何因缘不生无漏。世尊。若未生时有生者。云何于今乃名为生。若未生时无生者。何故不说虚空为生。佛言。善哉善哉。善男子。不生生不可说。生生亦不可说。生不生亦不可说。不生不生亦不可说。生亦不可说。不生亦不可说。有因缘故亦可得说。云何不生生不可说。不生名为生。云何可说。何以故以其生故。云何生生不可说。生生故生。生生故不生亦不可说。云何生不生不可说。生即名为生。生不自生故不可说。云何不生不生不可说。不生者名为涅槃。涅槃不生故不可说。何以故。以修道得故云何生亦不可说。以生无故。云何不生不可说。以有得故。云何有因缘故亦可得说。十因缘法为生作因。以是义故亦可得说。善男子。汝今莫入甚深空定。何以故大众钝故。善男子。有为之法生亦是常。以住无常生亦无常住亦是常。以生生故住亦无常异亦是常。以法无常异亦无常坏亦是常。以本无今有故坏亦无常。善男子。以性故生住异坏皆悉是常。念念灭故不可说常。是大涅槃能断灭故故名无常。善男子。有漏之法未生之时已有生性故生能生。无漏之法本无生性是故生不能生。如火有本性遇缘则发。眼有见性因色因明因心故见。众生生法亦复如是。由本有性遇业因缘。父母和合则便有生。尔时琉璃光菩萨摩诃萨。及八万四千菩萨摩诃萨。闻是法已踊在虚空高七多罗树。恭敬合掌而白佛言。世尊。我蒙如来殷勤教诲。因大涅槃始得悟解闻所不闻。亦令八万四千菩萨深解诸法不生生等。世尊。我今已解断诸疑网。然此会中有一菩萨名曰无畏。复欲咨禀唯垂听许。尔时世尊告无畏菩萨。善男子。随意问难吾当为汝分别解脱。尔时无畏。菩萨与六万(一本云与八万)四千诸菩萨等俱从座起。更整衣服长跪合掌而白佛言。世尊。此土众生当造何业而得生彼不动世界。其土菩萨云何而得智慧成就。人中象王有大威德。具修诸行利智捷疾闻则能解。尔时世尊即说偈言

  不害众生命　　坚持诸禁戒
  受佛微妙教　　则生不动国
  不夺他人财　　常施惠一切
  造招提僧坊　　则生不动国
  不犯他妇女　　自妻不非时
  施持戒卧具　　则生不动国
  不为自他故　　求利及恐怖
  慎口不妄语　　则生不动国
  莫坏善知识　　远离恶眷属
  口常和合语　　则生不动国
  如诸菩萨等　　常离于恶口
  所说人乐闻　　则生不动国
  乃至於戏笑　　不说非时语
  谨慎常时说　　则生不动国
  见他得利养　　常生欢喜心
  不起嫉妒结　　则生不动国
  不恼于众生　　常生于慈心
  不生方便恶　　则生不动国
  邪见言无施　　父母及去来
  不起如是见　　则生不动国
  旷路作好井　　种殖果树林
  常施乞者食　　则生不动国
  若于佛法僧　　供养一香灯
  乃至献一花　　则生不动国
  若为恐怖故　　利养及福德
  书是经一偈　　则生不动国
  若为悕利福　　能于一日中
  读诵是经典　　则生不动国
  若为无上道　　一日一夜中
  受持八戒斋　　则生不动国
  不与犯重禁　　同共一处住
  呵谤方等者　　则生不动国
  若能施病者　　乃至于一果
  欢喜而瞻视　　则生不动国
  不犯僧鬘物　　善守于佛物
  涂扫佛僧地　　则生不动国
  造像及佛塔　　犹如大拇指
  常生欢喜心　　则生不动国
  若为是经典　　自身及财宝
  施于说法者　　则生不动国
  若能听书写　　受持及读诵
  诸佛秘密藏　　则生不动国

尔时无畏菩萨摩诃萨白佛言。世尊。我今已知所造业缘得生彼国。是光明遍照高贵德王菩萨摩诃萨。普为怜愍一切众生先所咨问。如来若说则能利益安乐人天阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽等。尔时世尊即告光明遍照高贵德王菩萨。善哉善哉。善男子。汝今于此当至心听。吾当为汝分别解说。有因缘故未到不到。有因缘故不到到。有因缘故到不到。有因缘故到到。何因缘故未到不到。善男子。夫不到者是大涅槃。凡夫未到以有贪欲嗔恚愚痴故。身业口业不清净故。及受一切不净物故。犯四重故谤方等故一阐提故五逆罪故。以是义故未到不到。善男子。何因缘故不到到。不到者名大涅槃。何义故到。永断贪欲嗔恚愚痴身口恶故。不受一切不净物故。不犯四重故。不谤方等经故。不作一阐提故。不作五逆罪故。以是义故名不到到。须陀洹者八万劫到。斯陀含者六万劫到。阿那含者四万劫到。阿罗汉者二万劫到。辟支佛者十千劫到。以是义故名不到到。善男子。何因缘故名到不到。到者名为二十五有。一切众生常为无量烦恼诸结之所覆蔽。往来不离犹如轮转。是名为到。声闻缘觉及诸菩萨已得永离。故名不到。为欲化度诸众生故示现在中。亦名为到。善男子。何因缘故名为到到。到者即是二十五有。一切凡夫须陀洹乃至阿那含。烦恼因缘故名到到。善男子。闻所不闻亦复如是。有不闻闻。有不闻不闻。有闻不闻。有闻闻。云何不闻闻。善男子。不闻者名大涅槃。何故不闻。非有为故非音声故不可说故。云何亦闻。得闻名故。所谓常乐我净。以是义故名不闻闻。尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如佛所说大涅槃者不可得闻。云何复言常乐我净而可得闻。何以故世尊。断烦恼者名得涅槃。若未断者名为不得。以是义故涅槃之性本无今有。若世间法本无今有则名无常。譬如瓶等本无今有已有还无。故名无常。涅槃亦尔。云何说言常乐我净。复次世尊。凡因庄严而得成者。悉名无常。涅槃若尔应是无常。何等因缘所谓三十七品六波罗蜜四无量心。观于骨相阿那波那。六念处破析六大。如是等法皆是成就涅槃因缘。故名无常。复次世尊。有名无常。若涅槃是有亦应无常。如佛昔于阿含中说。声闻缘觉诸佛世尊皆有涅槃。以是义故名为无常。复次世尊。可见之法名为无常。如佛先说。见涅槃者则得断除一切烦恼。复次世尊。譬如虚空于诸众生等无障碍。故名为常。若使涅槃是常等者。何故众生有得不得。涅槃若尔于诸众生不平等者则不名常。世尊。譬如百人共有一怨。若害此怨则多人受乐。若使涅槃是平等法。一人得时应多人得。一人断结应多人亦断。若不如是云何名常。譬如有人恭敬供养尊重赞叹国王王子父母师长。则得利养是不名常。涅槃亦尔不名为常。何以故。如佛昔于阿含经中告阿难言。若有人能恭敬涅槃。则得断结受无量乐。以是义故不名为常。世尊。若涅槃中有常乐我净名者不名为常。如其无者云何可说

尔时世尊告光明遍照高贵德王菩萨摩诃萨言。涅槃之体非本无今有。若涅槃体本无今有者。则非无漏常住之法。有佛无佛性相常住。以诸众生烦恼覆故不见涅槃便谓为无。菩萨摩诃萨以戒定慧勤修其心。断烦恼已便得见之。当知涅槃是常住法。非本无今有是故为常。善男子。如闇室中井种种七宝。人亦知有闇故不见。有智之人善知方便然大明灯持往照了悉得见之。是人于此终不生念。水及七宝本无今有。涅槃亦尔本自有之非适今也。烦恼闇故众生不见。大智如来以善方便燃智慧灯。令诸菩萨得见涅槃常乐我净。是故智者于此涅槃不应说言本无今有。善男子。汝言因庄严故得成涅槃应无常者。是亦不然。何以故。善男子。涅槃之体非生非出非实非虚。非作业生非是有漏有为之法。非闻非见非堕非死。非别异相亦非同相。非往非还非去来今非一非多。非长非短非圆非方非尖非斜非有相非无相非名非色。非因非果非我我所。以是义故。涅槃是常恒不变易。是以无量阿僧祇劫修集善法。以自庄严然后乃见。善男子。譬如地下有八味水。一切众生而不能得。有智之人施功穿掘则便得之。涅槃亦尔。譬如盲人不见日月。良医疗之则便得见。而是日月非是本无今有。涅槃亦尔先自有之非适今也。善男子。如人有罪系之囹圄久乃得出。还家得见父母兄弟妻子眷属。涅槃亦尔。善男子。汝言因缘故涅槃之法应无常者。是亦不然。何以故。善男子。因有五种。何等为五。一者生因。二者和合因。三者住因。四者增长因。五者远因。云何生因。生因者即是业烦恼等。及外诸草木子。是名生因。云何和合因。如善与善心和合。不善与不善心和合。无记与无记心和合。是名和合因。云何住因。如下有柱屋则不堕。山河树木因大地故而得住立。内有四大无量烦恼众生得住。是名住因。云何增长因。因缘衣服饮食等故令众生增长。如外种子火所不烧鸟所不食则得增长。如诸沙门婆罗门等。依因和上善知识等而得增长。如因父母子得增长。是名增长因。云何远因。譬如因咒鬼不能害毒不能中。依凭国王无有盗贼。如芽依因地水火风等。如水攒及人为苏远因。如明色等为识远因。父母精血为众生远因。如时节等悉名远因。善男子。涅槃之体非是如是五因所成。云何当言是无常因。复次善男子。复有二因。一者作因。二者了因。如陶师轮绳。是名作因。如灯烛等照闇中物。是名了因。善男子。大涅槃者。不从作因而有唯有了因。了因者。所谓三十七助道法六波罗蜜。是名了因。善男子。布施者是涅槃因。非大涅槃因。檀波罗蜜乃得名为大涅槃因。三十七品是涅槃因。非大涅槃因。无量阿僧祇助菩提法。乃得名为大涅槃因

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。云何布施不得名为檀波罗蜜。云何布施而得名之檀波罗蜜。乃至般若云何不得名为般若波罗蜜。云何得名为般若波罗蜜。云何名涅槃。云何名大涅槃佛言。善男子。菩萨摩诃萨修行方等大般涅槃。不闻布施不见布施。不闻檀波罗蜜不见檀波罗蜜。乃至不闻般若不见般若。不闻般若波罗蜜不见般若波罗蜜。不闻涅槃不见涅槃。不闻大涅槃不见大涅槃。菩萨摩诃萨修大涅槃。知见法界解了实相空无所有。无有和合觉知之相。得无漏相无所作相如幻化相。热时炎相乾闼婆城虚空之相。菩萨尔时得如是相。无贪恚痴不闻不见。是名菩萨摩诃萨真实之相安住实相。菩萨摩诃萨自知此是檀此是檀波罗蜜。乃至此是般若此是般若波罗蜜。此是涅槃此是大涅槃善男子。云何是施非波罗蜜。见有乞者然后乃与。是名为施非波罗蜜。若无乞者开心自施是则名为檀波罗蜜。若时时施是名为施非波罗蜜。若修常施是则名为檀波罗蜜。若施他已还生悔心是名为施非波罗蜜。施已不悔是则名为檀波罗蜜。菩萨摩诃萨于财物中生四怖心。王贼水火。欢喜施与是则名为檀波罗蜜。若望报施是名为施非波罗蜜。施不望报是则名为檀波罗蜜。若为恐怖名闻利养家法相续天上五欲。为憍慢故为胜他故为知识故为来报故。如市易法。善男子。如人种树。为得荫凉为得花果及以材木。若人修行如是等施是名为施非波罗蜜菩萨摩诃萨修行如是大涅槃者。不见施者受者财物。不见时节不见福田及非福田。不见因不见缘不见果报。不见作者不见受者。不见多不见少。不见净不见不净。不轻受者。己身财物。不见见者不见不见者不计己他。唯为方等大般涅槃常住法故修行布施。为利一切诸众生故而行布施。为断一切众生烦恼故行于施。为诸众生不见受者施者财物故行于施。善男子。譬如有人堕大海水抱持死尸则得度脱。菩萨摩诃萨修大涅槃行布施时。亦复如是如彼死尸。善男子。譬如有人闭在深狱门户坚牢。唯有厕孔便从中出到无碍处。菩萨摩诃萨修大涅槃行布施时亦复如是。善男子。譬如贵人恐怖急厄更无恃怙依旃陀罗。菩萨摩诃萨修大涅槃行于布施亦复如是。善男子。譬如病人为除病苦得安乐故服食不净。菩萨摩诃萨修大涅槃行于布施亦复如是。善男子。如婆罗门值榖勇贵为寿命故食啖狗肉。菩萨摩诃萨修大涅槃行于布施亦复如是。善男子。大涅槃中如是之事。从无量劫来不闻而闻。尸罗尸罗波罗蜜。乃至般若般若波罗蜜。如佛杂花经中广说

大般涅槃经卷第二十一大般涅槃经卷第二十二

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之二

善男子。云何菩萨摩诃萨修大涅槃不闻而闻。十二部经其义深邃昔来不闻。今因是经得具足闻。先虽得闻唯闻名字。而今于此大涅槃经乃得闻义。声闻缘觉唯闻十二部经名字不闻其义。今于此经具足得闻。是名不闻而闻。善男子。一切声闻缘觉经中。不曾闻佛有常乐我净不毕竟灭。三宝佛性无差别相。犯四重罪谤方等经作五逆罪及一阐提悉有佛性。今于此经而得闻之。是名不闻而闻。光明遍照高贵德王菩萨摩诃萨白佛言。世尊。若犯重禁谤方等经作五逆罪一阐提等有佛性者。是等云何复堕地狱。世尊。若使是等有佛性者。云何复言无常乐我净。世尊。若断善根名一阐提者。断善根时所有佛性云何不断。佛性若断云何复言常乐我净。如其不断何故名为一阐提耶。世尊。犯四重禁名为不定。谤方等经作五逆罪及一阐提悉名不定。如是等辈若决定者。云何得成阿耨多罗三藐三菩提。得须陀洹乃至辟支佛亦名不定。若须陀洹至辟支佛是决定者。亦不应成阿耨多罗三藐三菩提。世尊。若犯四重不决定者。须陀洹乃至辟支佛亦不决定。如是不定诸佛如来亦复不定。若佛不定。涅槃体性亦复不定。至一切法亦复不定。云何不定。若一阐提除一阐提则成佛道。诸佛如来亦应如是。入涅槃已。亦应还出不入涅槃。若如是者涅槃之性则为不定。不决定故当知无有常乐我净。云何说言一阐提等当得涅槃。尔时世尊告光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。为欲利益无量众生令得安乐。怜愍慈念诸世间故。为欲增长发菩提心诸菩萨故。作如是问。善男子。汝已亲近过去无量诸佛世尊。于诸佛所种诸善根。久已成就菩提功德。降伏众魔令其退散。已教无量无边众生。悉令得至阿耨多罗三藐三菩提。久已通达诸佛如来所有甚深秘密之藏。已问过去无量无边恒河沙等诸佛世尊如是甚深微密之义。我都不见一切世间。若人若天沙门婆罗门若魔若梵。有能咨问如来是义。今当诚心谛听谛听。吾当为汝分别演说。善男子。一阐提者亦不决定。若决定者是一阐提终不能得阿耨多罗三藐三菩提。以不决定是故能得。如汝所言佛性不断。云何一阐提断善根者。善男子。善根有二种。一者内。二者外。佛性非内非外。以是义故佛性不断。复有二种。一者有漏。二者无漏。佛性非有漏非无漏。是故不断。复有二种。一者常。二者无常。佛性非常非无常。是故不断。若是断者则应还得。若不还得则名不断。若断已得名一阐提。犯四重者亦是不定。若决定者。犯四重禁终不能得阿耨多罗三藐三菩提。谤方等经亦复不定。若决定者。谤正法人终不能得阿耨多罗三藐三菩提。作五逆罪亦复不定。若决定者。五逆之人终不能得阿耨多罗三藐三菩提。色与色相二俱不定。香味触相生相。至无明相阴入界相二十五有相四生乃至一切诸法。皆亦不定。善男子。譬如幻师在大众中化作四兵车步象马。作诸璎珞严身之具。城邑聚落山林树木泉池河井。而彼众中有诸小儿无有智慧。睹见之时悉以为实。其中智人知其虚诳以幻力故惑人眼目。善男子。一切凡夫乃至声闻辟支佛等。于一切法见有定相亦复如是。诸佛菩萨于一切法不见定相。善男子。譬如小儿于盛夏月见热时焰谓之为水。有智之人于此热焰终不生于实水之想。但是虚焰诳人眼目非实是水。一切凡夫声闻缘觉见一切法。亦复如是悉谓是实。诸佛菩萨于一切法不见定相。善男子。譬如山涧因声有响。小儿闻之谓是实声。有智之人解无定实。但有声相诳于耳识。善男子。一切凡夫声闻缘觉于一切法。亦复如是见有定相。诸菩萨等解了诸法悉无定相。见无常相空寂等相无生灭相。以是义故。菩萨摩诃萨见一切法是无常相。善男子。亦有定相。云何为定。常乐我净。在何处耶。所谓涅槃。善男子。须陀洹果亦复不定。不决定故经八万劫得阿耨多罗三藐三菩提心。斯陀含果亦复不定。不决定故经六万劫得阿耨多罗三藐三菩提心。阿那含果亦复不定。不决定故经四万劫得阿耨多罗三藐三菩提心。阿罗汉果亦复不定。不决定故经二万劫得阿耨多罗三藐三菩提心。辟支佛道亦复不定。不决定故经十千劫得阿耨多罗三藐三菩提心。善男子。如来今于拘尸那城娑罗双树间。示现倚卧师子之床欲入涅槃。令诸未得阿罗汉果众弟子等及诸力士生大忧苦。亦令天人阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽等大设供养。欲使诸人以千端叠缠裹其身。七宝为棺盛满香油。积诸香木以火焚之。唯除二端不可得烧。一者儭身。二最在外。为诸众生分散舍利以为八分。一切所有声闻弟子。咸言如来入于涅槃。当知如来亦不毕定入于涅槃。何以故。如来常住不变易故。以是义故。如来涅槃亦复不定。善男子。当知如来亦复不定。如来非天。何以故。有四种天。一者世间天二者生天。三者净天。四者义天。世间天者如诸国王。生天者从四天王乃至非有想非无想天。净天者从须陀洹至辟支佛。义天者十住菩萨摩诃萨等。以何义故十住菩萨名为义天。以能善解诸法义故。云何为义。见一切法是空义故。善男子。如来非王亦非四天乃至非有想非无想天。从须陀洹至辟支佛十住菩萨。以是义故。如来非天。然诸众生亦复称佛为天中天。是故如来非天非非天。非人非非人。非鬼非非鬼。非地狱畜生饿鬼。非非地狱畜生饿鬼。非众生非非众生。非法非非法。非色非非色。非长非非长。非短非非短。非相非非相。非心非非心。非有漏非无漏。非有为非无为。非常非无常。非幻非非幻。非名非非名。非定非非定。非有非无。非说非非说。非如来非不如来。以是义故。如来不定。善男子。何故如来不名世天。世天者即是诸王。如来久于无量劫中已舍王位。是故非王。非非王者。如来生于迦毗罗城净饭王家。是故非非王。非生天者。如来久已离诸有故。是故非生天。非非生天。何以故。升兜率天下阎浮提故。是故如来非非生天。亦非净天。何以故。如来非是须陀洹乃至非辟支佛。是故如来非是净天。非非净天。何以故。世间八法所不能染。犹如莲花不受尘水。是故如来非非净天。亦非义天。何以故。如来非是十住菩萨故。是故如来非义天也。非非义天。何以故。如来常修十八空义故。是故如来非非义天。如来非人。何以故。如来久于无量劫中离人有故是。故非人。亦非非人。何以故。生于迦毗罗城故是故非非人。如来非鬼。何以故。不害一切诸众生故。是故非鬼。亦非非鬼。何以故。亦以鬼像化众生故。是故非非鬼。如来亦非地狱畜生饿鬼。何以故。如来久离诸恶业故。是故非地狱畜生饿鬼。亦非非地狱畜生饿鬼。何以故。如来亦复现受三恶诸趣之身化众生故。是故非非地狱畜生饿鬼。亦非众生。何以故。久已远离众生性故。是故如来非众生。亦非非众生。何以故。或时演说众生相故。是故如来非非众生。如来非法。何以故。诸法各各有别异相。如来不尔唯有一相。是故非法。亦非非法。何以故。如来。法界故。是故非非法。如来非色何以故。十色入所不摄故。是故非色。亦非非色。何以故。身有三十二相八十种好故。是故非非色。如来非长。何以故。断诸色故。是故非长。亦非非长。何以故。一切世间无有能见顶髻相故。是故非非长。如来非短。何以故。久已远离憍慢结故。是故非短。亦非非短。何以故。为瞿师罗长者示三尺身故。是故非非短。如来非相。何以故。久已远离诸相相故。是故非相。亦非非相。何以故。善知诸相故。是故非非相。如来非心。何以故。虚空相故。是故非心。亦非非心。何以故。有十力心法故。亦能知他众生心故。是故非非心。如来非有为。何以故。常乐我净故。是故非有为。亦非无为。何以故。有来去坐卧示现涅槃故。是故非无为。如来非常。何以故。身有分故是故非常。云何非常。以有知故。常法无知犹如虚空。如来有知是故非常。云何非常。有言说故。常法无言亦如虚空。如来有言是故无常。有姓氏故名曰无常。无姓之法乃名为常。虚空常故无有姓氏。如来有姓姓瞿昙氏是故无常。有父母故名曰无常。无父母者乃名曰常。虚空常故无有父母。佛有父母是故无常。有四威仪名曰无常。无四威仪乃名曰常。虚空常故无四威仪。佛有四威仪是故无常。常住之法无有方所。虚空常故无有方所。如来出在中天竺地。住舍婆提或王舍城。是故无常。以是义故如来非常亦非非常。何以故。生永断故。有生之法名曰无常。无生之法乃名为常。如来无生是故为常。常法无性。有性之法名曰无常。如来无生无性无生无性故常。有常之法遍一切处。犹如虚空无处不有。如来亦尔遍一切处。是故为常。无常之法或言此有或言彼无。如来不尔不可说言是处有彼处无。是故为常。无常之法有时是有有时是无。如来不尔有时是有有时是无。是故为常。常住之法无名无色。虚空常故无名无色。如来亦尔无名无色是故为常。常住之法无因无果。虚空常故无因无果。如来亦尔无因无果。是故为常。常住之法三世不摄。如来亦尔三世不摄是故为常。如来非幻。何以故。永断一切虚诳心故。是故非幻。亦非非幻。何以故。如来或时分此一身为无量身。无量之身复为一身。山壁直过无有障碍。履水如地入地如水行空如地。身出烟焰如大火聚。云雷震动其声可畏。或为城邑聚落舍宅山川树木。或作大身或作小身。男身女身童男童女身。是故如来亦非非幻。如来非定。何以故。如来于此拘尸那城娑罗双树间。示现入于般涅槃故。是故非定。亦非非定。何以故。常乐我净故。是故如来亦非非定。如来非有漏。何以故。断三漏故。故非有漏。三漏者。欲界一切烦恼除无明是名欲漏。色无色界一切烦恼除无明是名有漏。三界无明名无明漏。如来永断是故非漏。复次一切凡夫不见有漏。云何凡夫不见有漏。一切凡夫于未来世悉有疑心。未来世中当得身耶不得身耶。过去世中身本有耶为本无耶。现在世中是身有耶是身无耶。若有我者。是色耶非色耶。色非色耶非色非非色耶。想耶非想耶。想非想耶非想非非想耶。是身属他耶不属他耶。属不属耶非属非不属耶。有命无身耶有身无命耶。有身有命耶无身无命耶。身之与命有常耶无常耶。常无常耶非常非无常耶。身之与命自在作耶时节作耶。无因作耶世性作耶。微尘作耶法非法作耶。士夫作耶烦恼作耶父母作耶。我住心耶。住眼中耶遍满身中耶。从何来耶去何至耶。谁生耶谁死耶。我于过去是婆罗门姓耶。是刹利姓耶。是毗舍姓耶。是首陀罗姓耶。当于未来得何姓耶。我此身者。过去之时是男身耶是女身耶畜生身耶。若我杀生当有罪耶当无罪耶。乃至饮酒当有罪耶当无罪耶。我自作耶为他作耶。我受报耶身受报耶。如是疑见无量烦恼覆众生心。因是疑见生六种心。决定有我。决定无我。我见我。我见无我。无我见我。我作我受我知。是名邪见。如来永拔如是无量见漏根本。是故非漏。善男子。菩萨摩诃萨于大涅槃修圣行者。亦得永断如是诸漏。诸佛如来常修圣行。是故无漏善男子。凡夫不能善摄五根。则有三漏为恶所牵至不善处。善男子。譬如恶马其性佷悷能令乘者至崄恶处。不能善摄此五根者。亦复如是。令人远离涅槃善道至诸恶处。譬如恶象心未调顺有人乘之不随意去远离城邑至空旷处。不能善摄此五根者。亦复如是。将人远离涅槃城邑至于生死旷野之处。善男子。譬如佞臣教王作恶。五根佞臣。亦复如是。常教众生造无量恶。善男子。譬如恶子不受师长父母教敕则无恶不造。不调五根。亦复如是。不受师长善言教敕无恶不造。善男子。凡夫之人不摄五根。常为地狱畜生饿鬼之所贼害。亦如怨盗害及善人。善男子。凡夫之人不摄五根驰骋五尘。譬如牧牛不善守护犯人苗稼。凡夫之人不摄五根常在诸有多受苦恼。善男子。菩萨摩诃萨修大涅槃行圣行时。常能善调守摄五根。怖畏贪欲嗔恚愚痴憍慢嫉妒。为得一切诸善法故。善男子。若能善守此五根者则能摄心。若能摄心则摄五根。譬如有人拥护于王则护国土。护国土者则护于王。菩萨摩诃萨。亦复如是。若得闻是大涅槃经则得智慧。得智慧故则得专念。五根若散念则能止。何以故。是念慧故。善男子。如善牧者设牛东西啖他苗稼则便遮止不令犯暴。菩萨摩诃萨。亦复如是。念慧因缘故守摄五根不令驰散。菩萨摩诃萨有念慧者。不见我相不见我所相不见众生及所受用。见一切法同法性相。生于土石瓦砾之相。譬如屋舍从众缘生无有定性。见诸众生四大五阴之所成立推无定性。无定性故菩萨于中不生贪着。一切凡夫见有众生故起烦恼。菩萨摩诃萨修大涅槃。有念慧故于诸众生不生贪着。复次菩萨摩诃萨修大涅槃经者。不着众生相作种种法相。善男子。譬如画师以众杂彩画作众像若男若女若牛若马。凡夫无智见之则生男女等相。画师了知无有男女。菩萨摩诃萨。亦复如是。于法异相观于一相。终不生于众生之相。何以故。有念慧故。菩萨摩诃萨修大涅槃。或时睹见端正女人终不生于贪着之相。何以故。善观相故。善男子。菩萨摩诃萨知五欲法无有欢乐不得暂停。如犬啮枯骨。如人持火逆风而行。如箧毒蛇梦中所得路首有果树多人所掷。亦如段肉众鸟竞逐。如水上泡画水之迹。如织经尽。如囚趣市。犹如假借势不得久观。欲如是多诸过恶。复次善男子。菩萨摩诃萨观诸众生。为色香味触因缘故。从昔无数无量劫来常受苦恼。一一众生一劫之中所积身骨。如王舍城毗富罗山。所饮乳汁如四海水。身所出血多四海水。父母兄弟妻子眷属命终哭泣所出目泪多四大海。尽地草木为四寸筹以数父母亦不能尽。无量劫来或在地狱畜生饿鬼所受行苦不可称计。揣此大地犹如枣等易可穷极生死难尽。菩萨摩诃萨如是深观一切众生以是欲因缘故受苦无量。菩萨以是生死行苦故不失念慧。善男子。譬如世间有诸大众满二十五里。王敕一臣持一油钵经由中过莫令倾覆。若叶一渧当断汝命。复遣一人拔刀在后随而怖之。臣受王教尽心坚持经历尔所大众之中。虽见可意五邪欲等心常念言。我若放逸着彼邪欲当弃所持命不全济。是人以是怖因缘故乃至不弃一渧之油。菩萨摩诃萨。亦复如是。于生死中不失念慧。以不失故虽见五欲心不贪着。若见净色不生色相唯观苦相。乃至识相亦复如是。不作生相不作灭相不作因相观和合相。菩萨尔时五根清净。根清净故护根戒具。一切凡夫五根不净。不能善持名曰根漏。菩萨永断是故无漏。如来拔出永断根本是故非漏。复次善男子。复有离漏。菩萨摩诃萨欲为无上甘露佛果故离于恶漏。云何为离。若能修行大涅槃经。书写受持读诵解说思惟其义是名为离。何以故。善男子。我都不见十二部经能离恶漏如此方等大涅槃经。善男子。譬如良师教诸弟子。诸弟子中有受教者心不造恶。菩萨摩诃萨修大涅槃微妙经典。亦复如是心不造恶。善男子。譬如世间有善咒术。若有一闻却后七年不为一切毒药所中蛇不能螫。若有诵者乃至命尽无有众恶。善男子。是大涅槃。亦复如是。若有众生一经耳者却后七劫不堕恶道。若有书写读诵解说思惟其义。必得阿耨多罗三藐三菩提净见佛性。如彼圣王得甘露味。善男子。是大涅槃有如是等无量功德。善男子。若有人能书写是经读诵解说为他敷演思惟其义。当知是人真我弟子善受我教。是我所见我之所念是人谛知我不涅槃。随如是人所住之处若城邑聚落山林旷野房舍田宅楼阁殿堂。我亦在中常住不移我于是人常作受施。或作比丘比丘尼优婆塞优婆夷婆罗门梵志贪穷乞人。云何当令是人得知如来受其所施之物。善男子。是人或于夜卧梦中梦见佛像。或见天像沙门之像国王圣王师子王像莲花形像优昙花像。或见大山或大海水。或见日月或见白象及白马像。或见父母得花得果金银琉璃颇梨等宝五种牛味。尔时当知。即是如来受其所施。寤已喜乐寻得种种所须之物。心不念恶乐修善法。善男子。是大涅槃悉能成就如是无量阿僧祇等不可思议无边功德。善男子。汝今应当信受我语。若有善男子善女人欲见我者欲恭敬我。欲同法性而见于我。欲得空定欲见实相。欲得修习首楞严定师子王定。欲破八魔。八魔者。所谓四魔无常无乐无我无净。欲得人中天上乐者。见有受持大涅槃经书写读诵为他解说思惟义者。当往亲近依附咨受供养恭敬尊重赞叹。为洗手足布置床席四事供给令无所乏。若从远来应十由延路次奉迎为是经故。所重之物应以奉献。如其无者应自卖身。何以故。是经难遇过优昙花。善男子。我念过去无量无边那由他劫。尔时世界名曰娑婆。有佛世尊号释迦牟尼如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸大众宣说如是大涅槃经。我于尔时从善友所。转闻彼佛当为大众说大涅槃。我闻是已其心欢喜欲设供养。居贫无物欲自卖身薄福不售。即欲还家路见一人而便语言。吾欲卖身君能买不。其人答曰。我家作业人无堪者。汝设能为我当买汝。我即问言。有何作业人无堪能。其人见答吾有恶病良医处药。应当日服人肉三两。卿若能以身肉三两日日见给。便当与汝金钱五枚。我时闻已心中欢喜。我复语言。汝与我钱假我七日。须我事讫便还相就。其人见答七日不可。审能尔者当许一日。善男子。我于尔时即取其钱还至佛所。头面礼足尽其所有而以奉献。然后诚心听受是经。我时闇钝虽得闻经。唯能受持一偈文句

  如来证涅槃　　永断于生死
  若有至心听　　常得无量乐

受是偈已即便还至彼病人家。善男子。我时虽复日日与三两肉。以念偈因缘故不以为痛。日日不废足满一月。善男子。以是因缘其病得差。我身平复亦无疮痍。我时见身具足完具即发阿耨多罗三藐三菩提心。一偈之力尚能如是。何况具足受持读诵。我见此经有如是利复倍发心。愿于未来成得佛道字释迦牟尼。善男子。以是一偈因缘力故。令我今日于大众中为诸天人具足宣说。善男子。以是因缘是大涅槃不可思议。成就无量无边功德。乃是诸佛如来甚深秘密之藏。以是义故。能受持者断离恶漏。所谓恶者恶象恶马恶牛恶狗。毒蛇住处恶刺土地悬崖崄岸暴水回澓。恶人恶国恶城恶舍恶知识等。如是等辈若作漏因菩萨即离。若不能作则不远离。若增有漏则便离之。若不增长则不远离。若作恶法则便离之。若能作善则不远离。云何为离。不持刀杖常以正慧方便而远离之。是故名为正慧远离。为生善法则离恶法。菩萨摩诃萨自观其身。如病如疮如痈如怨。如箭入体是大苦聚。悉是一切诸恶根本。是身虽复不净如是。菩萨犹故瞻视将养。何以故。非为贪身为善法故。为于涅槃不为生死。为常乐我净不为无常无乐我净。为菩提道不为有道。为于一乘不为三乘。为三十二相八十种好微妙之身。不为乃至非有想非无想身。为法轮王不为转轮王。善男子。菩萨摩诃萨常当护身。何以故。若不护身命则不全命。若不全则不能得书写是经受持读诵。为他广说思惟其义。是故菩萨应善护身。以是义故。菩萨得离一切恶漏。善男子。如欲渡者应善护筏临路之人善护良马。田夫种植善护粪秽如为差毒善护毒蛇。如人为财护旃陀罗。为坏贼故将护健儿。亦如寒人爱护于火。如癞病者求于毒药。菩萨摩诃萨亦复如是。虽见是身无量不净具足充满。为欲受持大涅槃经故。犹好将护不令乏少。菩萨摩诃萨。观于恶象及恶知识等无有二。何以故。俱坏身故。菩萨摩诃萨于恶象等心无怖惧。于恶知识生畏惧心。何以故。是恶象等唯能坏身不能坏心。恶知识者二俱坏故。是恶象等唯坏一身。恶知识者坏无量善身无量善心。是恶象等唯能破坏不净臭身。恶知识者能坏净身及以净心。是恶象等能坏肉身。恶知识者坏于法身。为恶象杀不至三恶。为恶友杀必至三恶。是恶象等但为身怨。恶知识者为善法怨。是故菩萨常当远离诸恶知识。如是等漏凡夫不离是故生漏。菩萨离之则不生漏。菩萨如是尚无有漏。况于如来。是故非漏。云何亲近漏。一切凡夫受取衣食卧具医药。为身心乐求如是物造种种恶。不知过未轮回三趣。是故名漏。菩萨摩诃萨见如是过则便远离。若须衣时即便受取。不为身故但为于法。不长憍慢心常卑下。不为严饰但为羞耻。障诸寒暑恶风恶雨恶虫蚊虻蝇蚤蝮螫。虽受饮食心无贪着。不为身故常为正法。不为肌肤但为众生。不为憍慢为身力故。不为怨害为治肌疮。虽得上味心无贪着受取房舍亦复如是。贪慢之结不令居心。为菩提舍遮止结贼。障恶风雨故受屋舍。求医药者心无贪慢。但为正法不为寿命为常命故。善男子。如人病疮为苏糗涂以衣裹之。为出脓血苏糗涂拊。为疮愈故以药坌之。为恶风故在深屋中。菩萨摩诃萨亦复如是。观身是疮故以衣覆。为九孔脓求索饮食。为恶风雨取受房舍。为四毒发求觅医药。菩萨受取四种供养。为菩提道非为寿命。何以故。菩萨摩诃萨作是思惟。我若不受是四供养身则磨灭不得坚牢。若不坚牢则不忍苦。若不忍苦则不能得修习善法。若能忍苦则得修习无量善法。我若不能堪忍众苦。则于苦受生嗔恚心。于乐受中生贪着心。若求乐不得则生无明。是故凡夫于四供养生于有漏。菩萨摩诃萨能深观察不生于漏。是故菩萨名为无漏。云何如来当名有漏。是故如来不名有漏

大般涅槃经卷第二十二大般涅槃经卷第二十三

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之三

复次善男子。一切凡夫虽善护身。心犹故生于三种恶觉。以是因缘。虽断烦恼得生非想非非想处。犹故还堕三恶道中。善男子。譬如有人渡于大海。垂至彼岸没水而死。凡夫之人亦复如是。垂尽三有还堕三涂。何以故。无善觉故。何等善觉。所谓六念处。凡夫之人善心羸劣不善炽盛。善心羸故慧心薄少。慧心薄故增长诸漏。菩萨摩诃萨慧眼清净见三觉过。知是三觉有种种患。常与众生作三乘怨。三觉因缘乃令无量凡夫众生不见佛性。无量劫中生颠倒心。谓佛世尊。无常乐我唯有一净。如来毕竟入于涅槃。一切众生无常无乐无我无净。颠倒心故言有常乐我净。实无三乘颠倒心故言有三乘。一实之道真实不虚颠倒心故言无一实。是三恶觉常为诸佛及诸菩萨之所呵责。是三恶觉常害于我或亦害他。有是三觉一切诸恶常来随从。是三觉者即是三缚。连缀众生无边生死。菩萨摩诃萨常作如是观察三觉。菩萨或时有因缘故应生欲觉默然不受。譬如端正净洁之人不受一切粪秽不净。如热铁丸人无受者。如婆罗门性不受牛肉。如饱满人不受恶食。如转轮王不与一切旃陀罗等同坐一床。菩萨摩诃萨恶贱三觉不受不味亦复如是。何以故。菩萨思惟众生知我是良福田。我当云何受是恶法。若受恶觉则不任为众生福田。我自不言是良福田。众生见相便言我是。我今若起如是恶觉。则为欺诳一切众生。我于往昔以欺诳故。无量劫中流转生死堕三恶道。我若以恶心受人信施。一切天人及五通仙悉当证知而见诃责。我若恶觉受人信施。或令施主果报减少或空无报。我若恶心受檀越施。则与施主而为怨仇。一切施主恒于我所起赤子想。我当云何欺诳于彼而生怨想。何以故。或令施主不得果报或少果报故。我常自称为出家人。夫出家者不应起恶。若起恶者则非出家。出家之人身口相应。若不相应则非出家。我弃父母兄弟妻子眷属知识出家修道。正是修习诸善觉时非是修习不善觉时。譬如有人入海求宝不取真宝直取水精。亦如有人弃妙音乐游戏粪秽。如弃宝女与婢交通。如弃金器用于瓦盂。如弃甘露服食毒药。如舍亲旧良善之医从怨恶医求药而服

我亦如是。舍离大师如来世尊甘露法味。而服魔怨种种恶觉。人身难得如优昙花。我今已得。如来难值过优昙花。我今已值。清净法宝难得见闻。我今已闻。犹如盲龟值浮木孔。人命不停过于山水今日虽存明亦难保。云何纵心令住恶法。壮色不停犹如奔马。云何恃怙而生憍慢。犹如恶鬼伺求人过。四大恶鬼亦复如是常来伺求我之过失。云何当令恶觉发起。譬如朽宅垂崩之屋。我命亦尔。云何起恶。我名沙门。沙门之人名觉善觉。我今乃起不善之觉。云何当得名沙门也。我名出家。出家之人名修善道。我今行恶云何当得名为出家。我今名为真婆罗门。婆罗门者名修净行。我今乃行不净恶觉。云何当得名婆罗门。我今亦名刹利大姓。刹利姓者能除怨敌。我今不能除恶怨敌。云何当得名刹利姓。我名比丘。比丘之人名破烦恼。我今不破恶觉烦恼。云何当得名为比丘。世有六处难可值遇我今已得。云何当令恶觉居心。何等为六。一佛世难遇。二正法难闻。三怖心难生。四难生中国。五难得人身。六诸根难具。如是六事难得已得。是故不应起于恶觉。菩萨尔时修行如是大涅槃经。常勤观察是诸恶心。一切凡夫不见如是恶心过患故受三觉。名为受漏。菩萨见已不受不着放舍不护。依八圣道推之令去斩之令断。是故菩萨无有受漏。云何当言如来有漏。以是义故。如来世尊非是有漏。复次善男子。凡夫若遇身心苦恼起种种恶。若得身病若得心病。令身口意作种种恶。以作恶故轮回三趣具受诸苦。何以故。凡夫之人无念慧故。是故生于种种诸漏。是名念漏。菩萨摩诃萨常自思惟。我从往昔无数劫来为是身心造种种恶。以是因缘流转生死在三恶道具受众苦。遂令我远三乘正路。菩萨以是恶因缘故。于己身心生大怖畏舍离众恶趣向善道。善男子。譬如有王以四毒蛇盛之一箧令人瞻养餧饲卧起摩洗其身。若令一蛇生嗔恚者我当准法戮之都市。尔时其人闻王切令心生惶怖舍箧逃走。王时复遣五旃陀罗拔刀随后。其人回顾见后五人遂疾舍去。是时五人以恶方便藏所持刀。密遣一人诈为亲善而语之言汝可还来。其人不信投一聚落欲自隐匿。既入聚中窥看诸舍都不见人。执捉[土*瓦]器悉空无物。既不见人求物不得。即便坐地闻空中声咄哉男子。此聚空旷无有居民。今夜当有六大贼来。汝设遇者命将不全。汝当云何而得免之。尔时其人恐怖遂增复舍而去。路值一河其河漂急无有船筏。以怖畏故即取种种草木为筏。复更思惟我设住此。当为毒蛇五旃陀罗一诈亲者及六大贼之所危害。若渡此河筏不可依当没水死。宁没水死终不为彼蛇贼所害。即推草筏置之水中。身猗其上手抱脚踏截流而渡。既达彼岸安隐无患心意泰然怖恐消除

菩萨摩诃萨得闻受持大涅槃经。观身如箧地水火风如四毒蛇见毒触毒气毒啮毒。一切众生遇是四毒故丧其命。众生四大亦复如是。或见为恶或触为恶或气为恶或啮为恶。以是因缘远离众善。复次善男子。菩萨摩诃萨观四毒蛇有四种姓。所谓刹利婆罗门毗舍首陀。是四大蛇亦复如是。有四种性。坚性湿性热性动性。是故菩萨观是四大与四毒蛇同其种性。复次善男子。菩萨摩诃萨观是四大如四毒蛇。云何为观。是四毒蛇常伺人便。何时当视何时当触何时当[口*歔]何时当啮四大毒蛇亦复如是。常伺众生求其短缺。若为四蛇之所杀者。终不至于三恶道中。若为四大之所杀害。必至三恶道定无有疑。是四毒蛇虽复瞻养亦欲杀人。四大亦尔。虽常供给亦常牵人造作众恶。是四毒蛇若一嗔者则能杀人。四大之性亦复如是。若一大发亦能害人。是四毒蛇虽同一处四心各异。四大毒蛇亦复如是。虽同一处性各别异。是四毒蛇虽复恭敬难可亲近。四大毒蛇亦复如是。虽复恭敬亦难亲近。是四毒蛇若害人时。或有沙门婆罗门等若以咒药则可疗治。四大杀人虽有沙门婆罗门等神咒良药则不能治。如自喜人闻四毒蛇气臭可恶则便远离。诸佛菩萨亦复如是。闻四大臭即便远离。尔时菩萨复更思惟四大毒蛇生大怖畏背之驰走修八圣道

五旃陀罗即是五阴。云何菩萨观于五阴如旃陀罗。旃陀罗者。常令别人恩爱别离怨憎集会。五阴亦尔。令人贪近不善之法。远离一切纯善之法。复次善男子。如旃陀罗种种器仗以自庄严。若刀若楯若弓若箭若铠若槊能害于人。五阴亦尔。以诸烦恼牢自庄严。害诸痴人令堕诸有。善男子。如旃陀罗有过之人得便害之。五阴亦尔。有诸结过常能害人。以是义故。菩萨深观五阴如旃陀罗。复次菩萨观察五阴如旃陀罗。旃陀罗人无慈愍心怨亲俱害。五阴亦尔。无慈愍心善恶俱害。如旃陀罗恼一切人。五阴亦尔。以诸烦恼常恼一切生死众生。是故菩萨观于五阴如旃陀罗。复次菩萨观察五阴如旃陀罗。旃陀罗人常怀害心。五阴亦尔。常怀诸结恼害之心。如人无足刀杖侍从。当知。必为旃陀罗人之所杀害。众生亦尔。无足无刀无有侍从。则为五阴之所贼害。足名为戒。刀名为慧。侍从名为善知识也。无此三事故为五阴之所贼害。是故菩萨观于五阴如旃陀罗

复次善男子菩萨摩诃萨。观察五阴过旃陀罗。何以故。众生若为五旃陀罗之所杀者不堕地狱。为阴杀者则堕地狱。以是义故。菩萨观阴过旃陀罗。作是观已而作愿言。我宁终身近旃陀罗不能暂时近于五阴。旃陀罗者唯能害于欲界痴人。是五阴贼遍害三界凡夫众生。旃陀罗人唯能杀戮有罪之人。是五阴贼不问众生有罪无罪悉能害之。旃陀罗人不害衰老妇女稚小。是五阴贼不问众生老稚妇女一切悉害。是故菩萨。深观此阴过旃陀罗。是故发愿宁当终身近旃陀罗。不能暂时亲近五阴。复次善男子。旃陀罗者唯害他人终不自害。五阴之贼自害害他过旃陀罗。旃陀罗人可以善言钱财宝货求而得脱。五阴不尔。不可强以善言诱喻钱财宝货求而得脱。旃陀罗人于四时中不必常杀。五阴不尔。常于念念害诸众生。旃陀罗人唯在一处可有逃避。五阴不尔。遍一切处无可逃避。旃陀罗人虽复害人害已不随。五阴不尔。杀众生已随逐不离。是故菩萨宁以终身近旃陀罗。不能暂时近于五阴。有智之人以善方便得脱五阴。善方便者。即八圣道六波罗蜜四无量心。以是方便而得解脱身心不为五阴所害。何以故身如金刚心如虚空是故身心难可沮坏。以是义故。菩萨观阴成就种种诸不善法生大怖畏修八圣道。亦如彼人畏四毒蛇。五旃陀罗涉路而去无所顾留诈亲善者名为贪爱。菩萨摩诃萨深观爱结如怨诈亲。若知实者则无能为。若不能知必为所害。贪爱亦尔。若知其性则不能令众生轮转生死苦中。如其不知轮回六趣具受众苦。何以故。爱之为病难舍离故。如怨诈亲难可远离。怨诈亲者常伺人便令爱别离怨憎合会。爱亦如是。令人远离一切善法。近于一切不善之法。以是义故。菩萨摩诃萨深观贪爱如怨诈亲。见不见故闻不闻故。如凡夫人见生死过虽有智慧以痴覆故后还不见。声闻缘觉亦复如是。虽见不见虽闻不闻。何以故。以爱心故。所以者何。见生死过不能疾至阿耨多罗三藐三菩提。以是义故。菩萨摩诃萨观此爱结如怨诈亲。云何名为怨诈亲相。如怨不实诈现实相。不可亲近诈现近相。实是不善诈现善相。实是不爱诈为爱相。何以故。常伺人便欲为害故。爱亦如是。常为众生非实诈实非近诈近非善诈善非爱诈爱。常诳一切轮回生死。以是义故。菩萨观爱如怨诈亲。怨诈亲者但见身口不睹其心是故能诳。爱亦如是。唯为虚诳实不可得。是故能惑一切众生。怨诈亲者有始有终易可远离。爱不如是。无始无终难可远离。怨诈亲者远则难知近则易知。爱不如是近尚难知况复远耶。以是义故。菩萨观爱过于诈亲。一切众生以爱结故。远大涅槃近于生死。远常乐我净近无常苦无我不净。是故我于处处经中说为三垢。于现在事以无明故。不见过患不能舍离爱怨诈亲。终不能害有智之人。是故菩萨深观此爱生大怖畏修八圣道。犹如彼人畏四毒蛇五旃陀罗及一诈亲。涉路不回

空聚落者即是六入。菩萨摩诃萨观内六入空无所有犹如空聚。如彼怖人既入聚已。乃至不见有一居人。遍捉[土*瓦]器不得一物。菩萨亦尔。谛观六入空无所有不见众生一物之实。是故菩萨观内六入空无所有如彼空聚。善男子。彼空聚落群贼远望终不生于虚空之想。凡夫之人亦复如是。于六入聚不生空想。以其不能生空想故。轮回生死受无量苦。善男子。群贼既至乃生空想。菩萨亦尔。观此六入常生空想。生空想故则不轮回生死受苦。菩萨摩诃萨于此六入常无颠倒。无颠倒故是故不复轮回生死。复次善男子。如有群贼入此空聚则得安乐。烦恼诸贼亦复如是。入此六入则得安乐。如贼住空聚心无所畏。烦恼群贼亦复如是。住是六入亦无所畏如彼空聚。乃是师子虎狼种种恶兽之所住处。是内六入亦复如是。一切众恶烦恼走兽之所住处。是故菩萨深观六入空无所有。纯是一切不善住处。复次善男子。菩萨摩诃萨。观内六入空无所有如彼空聚。何以故。虚诳不实故。空无所有作有想故。实无有乐作乐想故。实无有人作人想故。内六入者亦复如是。空无所有而作有想。实无有乐而作乐想。实无有人而作人想。唯有智人乃能知之得其真实。复次善男子。如空聚落或时有人或时无人。六入不尔一向无人。何以故。性常空故。智者所知非是眼见。是故菩萨观内六入多诸怨害。修八圣道不休不息。犹如彼人畏四毒蛇五旃陀罗一诈亲善及六大贼怖着正路

六大贼者即外六尘。菩萨摩诃萨观此六尘如六大贼。何以故。能劫一切诸善法故。如六大贼能劫一切人民财宝。是六尘贼亦复如是。能劫一切众生善财如六大贼。若入人舍则能劫夺现家所有不择好恶。令巨富者忽尔贫穷。是六尘贼亦复如是。若入人根则能劫夺一切善法。善法既尽贫穷孤露作一阐提。是故菩萨谛观六尘如六大贼。复次善男子。如六大贼欲劫人时要因内人。若无内人则便中还。是六尘贼亦复如是。欲劫善法要因内有众生知见常乐我净不空等相。若内无有如是等相六尘恶贼则不能劫一切善法。有智之人内无是相凡夫则有。是故六尘常来侵夺善法之财。不善护故为其所劫。护者名慧有智之人能善防护故不被劫。是故菩萨观是六尘如六大贼等无差别。复次善男子。如六大贼能为人民身心苦恼。是六尘贼亦复如是。常为众生身心苦恼。六大贼者唯能劫人现在财物。是六尘贼常劫众生三世善财。六大贼者夜则欢乐。六尘恶贼亦复如是。处无明闇则得欢乐。是六大贼唯有诸王乃能遮止。六尘恶贼亦复如是。唯佛菩萨乃能遮止。是六大贼凡欲劫夺不择端正种姓聪哲多闻博学豪贵贫贱。六尘恶贼亦复如是。欲劫善法不择端正乃至贫贱。是六大贼虽有诸王截其手足。犹故不能令其心息。六尘恶贼亦复如是。虽须陀洹斯陀含阿那含截其手足。亦不能令不劫善法。如勇健人乃能摧伏是六大贼。诸佛菩萨亦复如是。乃能摧伏六尘恶贼。譬如有人多诸种族宗党炽盛则不为彼六贼所劫。众生亦尔。有善知识不为六尘恶贼所劫。是六大贼若见人物则能偷劫。六尘不尔。若见若知若闻若嗅若触若觉皆悉能劫。六大贼者唯能劫夺欲界人财。不能劫夺色无色界。六尘恶贼则不如是。能劫三界一切善宝。是故菩萨谛观六尘过彼六贼。作是观已修八圣道直往不回。如彼怖人畏四毒蛇五旃陀罗一诈亲者及六大贼。舍空聚落涉路而去

路值一河者即是烦恼。云何菩萨观此烦恼犹如大河。如彼驶河能漂香象。烦恼驶河亦复如是。能漂缘觉。是故菩萨深观烦恼犹如驶河。深难得底故名为河。边不可得故名为大。其中多有种种恶鱼烦恼大河亦复如是。唯佛菩萨能得底故故名极深。唯佛菩萨得其边故故名广大。常害一切痴众生故故名恶鱼。是故菩萨观此烦恼犹如大河。如大河水能长一切草木丛林。烦恼大河亦复如是。能长众生二十五有。是故菩萨观此烦恼犹如大河。譬如有人堕大河水无有惭愧。众生亦尔。堕烦恼河无有惭愧。如堕河者未得其底即便命终。堕烦恼河亦复如是。未尽其底周回轮转二十五有。所言底者名为空相。若有不修如是空相。当知是人不得出离二十五有。一切众生不能善修空无相故。常为烦恼驶河所漂。如彼大河唯能坏身不能漂没一切善法。烦恼大河则不如是。能坏一切身心善法。彼大暴河唯能漂没欲界中人。烦恼大河乃能漂没三界人天。世间大河手抱脚踏则到彼岸。烦恼大河唯有菩萨因六波罗蜜乃能得渡。如大河水难可得渡。烦恼大河亦复如是难可得渡。云何名为难可得渡。乃至十住诸大菩萨犹故未能毕竟得渡。唯有诸佛乃毕竟渡。是故名为难可得渡。譬如有人为河所漂。不能修习毫厘善法。众生亦尔。为烦恼河所漂没者。亦复不能修习善法。如人堕河为水所漂。余有力者则能拔济。堕烦恼河为一阐提。声闻缘觉乃至诸佛不能拔济。世间大河劫尽之时七日并照能令枯涸。烦恼大河则不如是。声闻缘觉虽修七觉犹不能干。是故菩萨观诸烦恼犹如暴河

譬如彼人畏四毒蛇五旃陀罗。诈亲善及六大贼。舍空聚落随路而去。既至河上取草为筏者。菩萨亦尔。畏四大蛇五阴旃陀罗爱诈亲善六入空聚六尘恶贼至烦恼河。修戒定慧解脱解脱知见六波罗蜜三十七品以为船筏。依乘此筏渡烦恼河到于彼岸常乐涅槃。菩萨修行大涅槃者作是思惟。我若不能忍受如是身苦心苦。则不能令一切众生渡烦恼河。以是思惟虽有如是身心苦恼默然忍受。以忍受故则不生漏。如是菩萨尚无诸漏。况佛如来而当有漏。是故诸佛不名有漏。云何如来非无漏也。如来常行有漏中故。有漏即是二十五有。是故声闻凡夫之人言佛有漏。诸佛如来真实无漏。善男子。以是因缘诸佛如来无有定相。善男子。是故犯四重禁谤方等经及一阐提悉皆不定

尔时光明遍照高贵德王菩萨摩诃萨言。如是如是诚如圣教。一切诸法皆悉不定。以不定故当知如来亦不毕竟入于涅槃。如佛先说菩萨摩诃萨修大涅槃。闻不闻中有涅槃大涅槃。云何涅槃云何大涅槃

尔时佛赞光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。若有菩萨得念总持。乃能如汝之所咨问。善男子。如世人言有海大海有河大河有山大山有地大地有城大城。有众生大众生有王大王有人大人有天天中天有道大道。涅槃亦尔有涅槃有大涅槃。云何涅槃。善男子。如人饥饿得少饭食名为安乐。如是安乐亦名涅槃。如病得差则名安乐。如是安乐亦名涅槃。如人怖畏得归依处则得安乐。如是安乐亦名涅槃。如贫穷人获七宝物则得安乐。如是安乐亦名涅槃。如人观骨不起贪欲则得安乐。如是安乐亦名涅槃。如是涅槃不得名为大涅槃也。何以故。以饥渴故病故怖故贫故生贪着故。是名涅槃非大涅槃。善男子。若凡夫人及以声闻。或因世俗或因圣道。断欲界结则得安乐。如是安乐亦名涅槃。不得名为大涅槃也。能断初禅乃至能断非想非非想处结则得安乐。如是安乐亦名涅槃。不得名为大涅槃也。何以故。还生烦恼有习气故。云何名为烦恼习气。声闻缘觉有烦恼气。所谓我身我衣我去我来我说我听。诸佛如来入于涅槃。涅槃之性无我无乐唯有常净。是则名为烦恼习气。佛法众僧有差别相。如来毕竟入于涅槃。声闻缘觉诸佛如来所得涅槃等无差别。以是义故二乘所得非大涅槃。何以故。无常乐我净故。常乐我净乃得名为大涅槃也。善男子。譬如有处能受众水名为大海。随有声闻缘觉菩萨。诸佛如来所入之处名大涅槃。四禅三三昧八背舍八胜处十一切处。随能摄取如是无量诸善法者名大涅槃

善男子。譬如有河第一香象不能得底则名为大。声闻缘觉至十住菩萨不见佛性。名为涅槃非大涅槃。若能了了见于佛性。则得名为大涅槃也。是大涅槃唯大象王能尽其底。大象王者谓诸佛也。善男子。若摩诃那伽及钵揵陀。大力士等经历多时所不能上。乃名大山。声闻缘觉及诸菩萨摩诃那伽大力士等所不能见。如是乃名大涅槃也。复次善男子。随有小王之所住处名为小城。转轮圣王所住之处乃名大城。声闻缘觉八万六万四万二万一万住处名为涅槃。无上法主圣王住处乃得名为大般涅槃。以是故名大般涅槃。善男子。譬如有人见四种兵不生怖畏。当知是人名大众生。若有众生于三恶道烦恼恶业不生怖畏。而能于中广度众生。当知是人得大涅槃。若有人能供养父母恭敬沙门及婆罗门。修治善法所言诚实无有欺诳。能忍诸恶惠施贫乏名大丈夫。菩萨亦尔有大慈悲怜愍一切。于诸众生犹如父母。能度众生于生死河。普示众生一实之道。是则名为大般涅槃。善男子。大名不可思议。若不可思议一切众生所不能信。是则名为大般涅槃。唯佛菩萨之所见故名大涅槃。以何因缘复名为大。以无量因缘然后乃得故名为大。善男子。如世间人以多因缘之所得者。则名为大。涅槃亦尔以多因缘之所得故。故名为大。云何复名为大涅槃。有大我故名大涅槃。涅槃无我大自在故名为大我。云何名为大自在耶。有八自在则名为我。何等为八。一者能示一身以为多身。身数大小犹如微尘充满十方无量世界。如来之身实非微尘。以自在故现微尘身。如是自在则为大我

二者示一尘身满于三千大千世界。如来之身实不满于三千大千世界。何以故。以无碍故。直以自在故。满于三千大千世界。如是自在名为大我。三者能以满此三千大千世界之身轻举飞空。过于二十恒河沙等诸佛世界而无障碍。如来之身实无轻重。以自在故能为轻重。如是自在名为大我

四者以自在故而得自在。云何自在。如来一心安住不动。所可示化无量形类各令有心。如来有时或造一事。而令众生各各成办。如来之身常住一土。而令他土一切悉见。如是自在名为大我

五者根自在故。云何名为根自在耶。如来一根亦能见色闻声嗅香别味觉触知法。如来六根亦不见色闻声嗅香别味觉触知法。以自在故令根自在。如是自在名为大我六者以自在故得一切法。如来之心亦无得想。何以故。无所得故。若是有者可名为得。实无所有云何名得。若使如来计有得想。是则诸佛不得涅槃。以无得故名得涅槃。以自在故得一切法。得诸法故名为大我

七者说自在故。如来演说一偈之义。经无量劫义亦不尽。所谓若戒若定若施若慧。如来尔时都不生念我说彼听。亦复不生一偈之想。世间之人以四句为偈。随世俗故说名为偈。一切法性亦无有说。以自在故如来演说。以演说故名为大我

八者如来遍满一切诸处犹如虚空。虚空之性不可得见。如来亦尔实不可见。以自在故令一切见。如是自在名为大我。如是大我名大涅槃。以是义故名大涅槃

复次善男子。譬如宝藏多诸珍异百种具足故名大藏。诸佛如来甚深奥藏亦复如是。多诸奇异具足无缺名大涅槃。复次善男子。无边之物乃名为大。涅槃无边是故名大

复次善男子。有大乐故名大涅槃。涅槃无乐以四乐故名大涅槃。何等为四。一者断诸乐故。不断乐者则名为苦。若有苦者不名大乐。以断乐故则无有苦。无苦无乐乃名大乐。涅槃之性无苦无乐。是故涅槃名为大乐。以是义故名大涅槃。复次善男子。乐有二种。一者凡夫。二者诸佛。凡夫之乐无常败坏是故无乐。诸佛常乐无有变异故名大乐。复次善男子。有三种受。一者苦受。二者乐受。三者不苦不乐受。不苦不乐是亦为苦。涅槃虽同不苦不乐。然名大乐。以大乐故名大涅槃二者大寂静故名为大乐。涅槃之性是大寂静。何以故。远离一切愦闹法故。以大寂故名大涅槃

三者一切知故名为大乐。非一切知不名大乐。诸佛如来一切知故名为大乐。以大乐故名大涅槃

四者身不坏故名为大乐。身若可坏则不名乐。如来之身金刚无坏非烦恼身无常之身。故名大乐。以大乐故名大涅槃

善男子。世间名字或有因缘。或无因缘。有因缘者。如舍利弗。母名舍利。因母立字故名舍利弗。如摩鋀罗道人。生摩鋀罗国。因国立名故名摩鋀罗道人。如目犍连。目犍连者即是姓也。因姓立名故名目犍连。如我生于瞿昙种姓。因姓立名称为瞿昙。如毗舍佉道人。毗舍佉者即是星名。因星为名名毗舍佉。如有六指因六指故名六指人。如佛奴天奴。因佛因天故名佛奴天奴。因湿生故故名湿生。如因声故名为迦迦罗。名究究罗咀咀罗。如是等名是因缘名。无因缘者。如莲花地水火风虚空。如曼陀婆一名二实。一名殿堂。二名饮浆堂。不饮浆亦复得名为曼陀婆。如萨婆车多名为蛇盖。实非蛇盖是名无因强立名字。如坻罗婆夷名为食油。实不食油强为立名名为食油。是名无因强立名字。善男子。是大涅槃亦复如是。无有因缘强为立名。善男子。譬如虚空不因小空名为大空也。涅槃亦尔不因小相名大涅槃。善男子。譬如有法不可称量 不可思议故名为大。涅槃亦尔不可称量不可思议故得名为大般涅槃。以纯净故名大涅槃。云何纯净。净有四种。何等为四。一者二十五有名为不净。能永断故得名为净。净即涅槃如是涅槃亦得名有。而是涅槃实非是有。诸佛如来随世俗故说涅槃有。譬如世人非父言父非母言母。实非父母而言父母。涅槃亦尔。随世俗故说言诸佛有大涅槃。二者业清净故。一切凡夫业不清净故无涅槃。诸佛如来业清净故故名大净。以大净故名大涅槃。三者身清净故。身若无常则名不净。如来身常故名大净。以大净故名大涅槃。四者 心清净故。心若有漏名曰不净。佛心无漏故名大净。以大净故名大涅槃。善男子。是名善男子善女人修行如是大涅槃经。具足成就初分功德

大般涅槃经卷第二十三大般涅槃经卷第二十四

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之四

复次善男子。云何菩萨摩诃萨修大涅槃。成就具足第二功德。善男子。菩萨摩诃萨修大涅槃。昔所不得而今得之。昔所不见而今见之。昔所不闻而今闻之。昔所不到而今得到。昔所不知而今知之。云何名为昔所不得而今得之。所谓神通。昔所不得而今乃得。通有二种。一者内。二者外。所言外者与外道共。内复有二。一者二乘。二者菩萨。菩萨修行大涅槃经所得神通。不与声闻辟支佛共。云何名为不与声闻辟支佛共。二乘所作神通变化一心作一不得众多。菩萨不尔于一心中则能具足现五趣身。所以者何。以得如是大涅槃经之势力故。是则名为昔所不得而今得之。又复云何昔所不得而今得之。所谓身得自在心得自在。何以故。一切凡夫所有身心不得自在。或心随身或身随心

云何名为心随于身。譬如醉人酒在身中。尔时身动心亦随动。亦如身懒心亦随懒。是则名为心随于身。又如婴儿其身稚小心亦随小大人身大心亦随大。又如有人身体粗涩。心常思念。欲得膏油润渍令软。是则名为心随于身

云何名为身随于心。所谓去来坐卧修行施戒忍辱精进。愁恼之人身则羸悴。欢喜之人身则肥鲜。恐怖之人身体战动。专心听法身则怡悦。悲泣之人涕泪横流。是则名为身随于心。菩萨不尔。于身心中俱得自在。是则名为昔所不得而今得之

复次善男子。菩萨摩诃萨所现身相犹如微尘。以此微身悉能遍至无量无边恒河沙等诸佛世界无所障碍。而心常定初不移动。是则名为心不随身

是亦名为昔所不到而今能到。何以复名昔所不到而今能到。一切声闻辟支佛等所不能到菩萨能到。是故名为昔所不到而今能到一切声闻辟支佛等。虽以神通不能变身如细微尘。遍至无量恒河沙等诸佛世界。声闻缘觉身若动时心亦随动。菩萨不尔。心虽不动身无不至。是名菩萨心不随身。复次善男子。菩萨化身犹如三千大千世界。以此大身入一尘身。其心尔时亦不随小。声闻缘觉虽能化身令如三千大千世界。而不能以如此大身入微尘身。于此事中尚自不能。况能令心而不随动。是名菩萨心不随身。复次善男子。菩萨摩诃萨以一音声能令三千大千世界众生悉闻。心终不念令是音声遍诸世界。使诸众生昔所不闻而今得闻。而是菩萨亦初不言我令众生昔所不闻而今得闻。菩萨若言因我说法令诸众生不闻闻者。当知是人终不能得阿耨多罗三藐三菩提。何以故。众生不闻我为说者。如此之心是生死心。一切菩萨是心已尽。以是义故。菩萨摩诃萨所有身心不相随逐。善男子。一切凡夫身心相随。菩萨不尔。为化众生故虽现身小心亦不小何以故。诸菩萨等所有心性常广大故。虽现大身心亦不大。云何大身。身如三千大千世界。云何小心。行婴儿行。以是义故心不随身。菩萨摩诃萨已于无量阿僧祇劫远酒不饮而心亦动。心无悲苦身亦流泪。实无恐怖身亦战栗。以是义故。当知菩萨身心自在不相随逐。菩萨摩诃萨唯现一身。而诸众生各各见异

复次善男子。云何菩萨摩诃萨修大涅槃。昔所不闻而今得闻。菩萨摩诃萨先取声相。所谓象声马声车声人声贝声鼓声箫笛等声歌声哭声而修习之。以修习故能闻无量三千大千世界所有地狱音声。复转修习得异耳根。异于声闻缘觉天耳。何以故。二乘所得清净耳通。若依初禅净妙四大。唯闻初禅不闻二禅。乃至四禅亦复如是。虽可一时得闻三千大千世界所有音声。而不能闻无量无边恒河沙等世界音声。以是义故。菩萨所得异于声闻缘觉耳根。以是异故昔所不闻而今得闻。虽闻音声而心初无闻声之相。不作有相常相乐相我相净相主相依相作相因相定相果相。以是义故。诸菩萨等昔所不闻而今得闻

尔时光明遍照高贵德王菩萨摩诃萨言。若佛所说不作定相不作果相。是义不然。何以故。如来先说。若人闻是大涅槃经一句一字。必定得成阿耨多罗三藐三菩提。如来于今云何复言无定无果。若得阿耨多罗三藐三菩提。即是定相即是果相。云何而言无定无果。闻恶声故则生恶心。生恶心故则至三涂。若至三涂则是定果。云何而言无定无果

尔时如来赞言。善哉善哉。善男子。能作是问。若使诸佛说诸音声有定果相者。则非诸佛世尊之相。是魔王相生死之相远涅槃相。何以故。一切诸佛凡所演说无定果相。善男子。譬如刀中见人面像。竖则见长横则见阔。若有定相云何而得竖则见长横则见阔。以是义故。诸佛世尊凡所演说无定果相。善男子。夫涅槃者实非声果。若使涅槃是声果者。当知涅槃非是常法。善男子。譬如世间从因生法。有因则有果无因则无果。因无常故果亦无常。所以者何。因亦作果果亦作因。以是义故一切诸法无有定相。若使涅槃从因生者。因无常故果亦无常。而是涅槃不从因生。体非是果是故为常。善男子。以是义故。涅槃之体无定无果。善男子。夫涅槃者。亦可言定亦可言果。云何为定。一切诸佛所有涅槃常乐我净。是故为定。无生老坏是故为定。一阐提等犯四重禁诽谤方等作五逆罪。舍除本心必定得故。是故为定

善男子。如汝所言。若人闻我说大涅槃一字一句。得阿耨多罗三藐三菩提者。汝于是义犹未了了。汝当谛听吾当为汝更分别之。善男子。若有善男子善女人。闻大涅槃一字一句。不作字相不作句相不作闻相不作佛相不作说相。如是义者名无相相。以无相相故得阿耨多罗三藐三菩提。善男子。如汝所言闻恶声故到三涂者。是义不然。何以故。非以恶声而至三涂。当知是果乃是恶心。所以者何。有善男子善女人等。虽闻恶声心不生恶。是故当知非因恶声生三涂中。而诸众生因烦恼结恶心滋多生三恶趣非因恶声。若声有定相。诸有闻者。一切悉应生于恶心。或有生者有不生者。是故当知声无定相。以无定故虽复因之不生恶心。世尊。声若无定。云何菩萨昔所不闻而今得闻。善男子。声无定相。昔所不闻令诸菩萨而今得闻。以是义故。我作是说。昔所不闻而今得闻善男子。云何昔所不见而今得见。善男子。菩萨摩诃萨修大涅槃微妙经典先取明相。所谓日月星宿[火*定]燎灯烛珠火之明药草等光。以修习故得异眼根。异于声闻缘觉所得。云何为异。二乘所得清净天眼。若依欲界四大眼根不见初禅。若依初禅不见上地。乃至自眼犹不能见。若欲多见极至三千大千世界。菩萨摩诃萨不修天眼见妙色身悉是骨相。虽见他方恒河沙等世界色相。不作色相。不作常相。有相物相名字等相。作因缘相不作见相。不言是眼微妙净相。唯见因缘非因缘相。云何因缘。色是眼缘。若使是色非因缘者。一切凡夫不应生于见色之相。以是义故。色名因缘非因缘者。菩萨摩诃萨虽复见之不生色相。是故非缘。以是义故。菩萨所得清净天眼异于声闻缘觉所得。以是异故一时遍见十方世界现在诸佛。是名菩萨昔所不见而今得见。以是异故能见微尘声闻缘觉所不能见以是异故。虽见自眼初无见相。见无常相见凡夫身三十六物不净充满。如于掌中观阿摩勒果。以是义故。昔所不见而今得见。若见众生所有色相。则知其人大小乘根。一触衣故亦知是人善恶诸根差别之相。以是义故。昔所不知而今得知。以一见故昔所不知而今得知。以此知故昔所不见而今得见。复次善男子。云何菩萨昔所不知而今得知。菩萨摩诃萨虽知凡夫贪恚痴心。初不作心及心数相。不作众生及以物相。修第一义毕竟空相。何以故。一切菩萨常善修习空性相故。以修空故昔所不知而今得知。云何为知。知无有我无有我所。知诸众生皆有佛性。以佛性故一阐提等舍离本心。悉当得成阿耨多罗三藐三菩提。如此皆是声闻缘觉所不能知。菩萨能知。以是义故。昔所不知而今得知。复次善男子。云何昔所不知而今得知。菩萨摩诃萨修大涅槃微妙经典。念过去世一切众生所生种姓父母兄弟妻子眷属知识怨憎。于一念中得殊异智。异于声闻缘觉智慧。云何为异。声闻缘觉所有智慧。念过去世所有众生种姓父母乃至怨憎。而作种姓至怨憎相。菩萨不尔。虽念过去种姓父母乃至怨憎。终不生于种姓父母怨憎等相。常作法相空寂之相。是名菩萨昔所不知而今得知。复次善男子。云何昔所不知而今得知。菩萨摩诃萨修大涅槃微妙经典得他心智。异于声闻缘觉所得。云何为异。声闻缘觉以一念智知人心时。则不能知地狱畜生饿鬼天心。菩萨不尔。于一念中遍知六趣众生之心。是名菩萨昔所不知而今得知。复次善男子。复有异知菩萨摩诃萨。于一心中。知须陀洹初心次第至十六心。以是义故。昔所不知而今得知。是为菩萨修大涅槃具足成就第二功德

复次善男子。云何菩萨摩诃萨修大涅槃成就具足第三功德。善男子。菩萨摩诃萨修大涅槃舍慈得慈。得慈之时。不从因缘。云何名为舍慈得慈。善男子。慈名世谛。菩萨摩诃萨舍世谛慈得第一义慈。第一义慈不从缘得。复次云何舍慈得慈。慈若可舍名凡夫慈。慈若可得即名菩萨无缘之慈。舍一阐提慈犯四重禁慈谤方等慈作五逆慈。得怜愍慈得如来慈世尊之慈无因缘慈。云何复名舍慈得慈。舍黄门慈无根二根女人之慈。屠脍猎师畜养鸡猪如是等慈。亦舍声闻缘觉之慈。得诸菩萨无缘之慈。不见自慈不见他慈。不见持戒不见破戒。虽自见悲不见众生。虽有苦受不见受者。何以故。以修第一真实义故。是名菩萨修大涅槃成就具足第三功德

复次善男子。云何菩萨摩诃萨修大涅槃成就具足第四功德。善男子。菩萨摩诃萨修大涅槃成就具足第四功德。有十事。何等为十。一者根深难可倾拔。二者自身生决定想。三者不观福田及非福田。四者修净佛土。五者灭除有余。六者断除业缘。七者修清净身。八者了知诸缘。九者离诸怨敌。十者断除二边。云何根深难可倾拔。所言根者名不放逸。不放逸者为是何根。所谓阿耨多罗三藐三菩提根。善男子。一切诸佛诸善根本皆不放逸。不放逸故诸余善根转转增长。以能增长诸善根故。于诸善中最为殊胜。善男子。如诸迹中象迹为上。不放逸法亦复如是。于诸善法最为殊胜。善男子。如诸明中日光为最。不放逸法亦复如是。于诸善法最为殊胜。善男子。如诸王中转轮圣王为最第一。不放逸法亦复如是。于诸善法为最第一。善男子。如诸流中四河为最。不放逸法亦复如是。于诸善法为上为最。善男子。如诸山中须弥山王为最第一。不放逸法亦复如是于诸善法为最第一。善男子。如水生花中青莲花为最。不放逸法亦复如是。于诸善法为最为上。善男子。如陆生花中婆利师花为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。如诸兽中师子为最。不放逸法亦复如是。于诸善法为最为上。善男子。如飞鸟中金翅鸟王为最为上。不放逸法亦复如是。于诸善法为最为上

善男子。如大身中罗睺阿修罗王为最为上。不放逸法亦复如是于诸善法为最为上。善男子。如一切众生若二足四足多足无足中如来为最。不放逸法亦复如是。于善法中为最为上。善男子。如诸众中佛僧为上。不放逸法亦复如是。于善法中为最为上。善男子。如佛法中大涅槃法为最为上。不放逸法亦复如是。于诸善法为最为上。善男子。以是义故。不放逸根深固难拔。云何不放逸故而得增长。所谓信根戒根施根慧根忍根闻根进根念根定根善知识根。如是诸根不放逸故而得增长。以增长故深固难拔。以是义故。名为菩萨摩诃萨修大涅槃根深难拔

云何于身作决定想。于自身所生决定心。我今此身于未来世定当为阿耨多罗三藐三菩提器。心亦如是不作狭小不作变易。不作声闻辟支佛心。不作魔心及自乐心乐生死心。常为众生求慈悲心。是名菩萨于自身中生决定心。我于来世当为阿耨多罗三藐三菩提器。以是义故。菩萨摩诃萨修大涅槃。于自身中生决定想。云何菩萨不观福田及非福田。云何福田。外道持戒上至诸佛是名福田。若有念言。如是等辈是真福田。当知是心则为狭劣。菩萨摩诃萨悉观一切无量众生无非福田。何以故。以善修习异念处故有异念处。善修习者观诸众生无有持戒及以毁戒。常观诸佛世尊所。说施虽四种俱得清净报。何等为四。一者施主清净受者不净。二者施主不净受者清净。三者施受俱净。四者施受二俱不净

云何施净受者不净。施主具有戒闻智慧。知有慧施及以果报。受者破戒专著邪见无施果报。是名施净受者不净

云何名为受者清净施主不净。施主破戒专著邪见言无慧施及以果报。受者持戒多闻智慧知有惠施及施果报是名施主不净受者清净

云何名为施受俱净。施者受者俱有持戒多闻智慧。知有惠施及施果报。是名施受二俱清净

云何名为二俱不净。施者受者破戒邪见言无有施及施果报。若如是者云何复言得净果报。以无施无报故名为净。善男子。若有不见施及施报。当知是人不名破戒。专著邪见若依声闻。言不见施及施果报。是则名为破戒邪见。若依如是大涅槃经不见惠施及施果报。是则名为持戒正见。菩萨摩诃萨有异念处以修习故。不见众生持戒破戒施者受者及施果报。是故得名持戒正见。以是义故。菩萨摩诃萨不观福田及非福田

云何名为净佛国土。菩萨摩诃萨修大涅槃微妙经典为阿耨多罗三藐三菩提度众生故离杀害心。以此善根愿与一切众生共之。愿诸众生得寿命长。有大势力获大神通。以是誓愿因缘力故。于未来世成佛之时。国土所有一切众生得寿命长有大势力获大神通

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故离偷盗心。以此善根愿与一切众生共之。愿诸佛国土地所有纯是七宝。众生富足所欲自恣。以此誓愿因缘力故。于未来世成佛之时所得国土纯是七宝。众生富足所欲自恣

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故离淫欲心。以此善根愿与一切众生共之。愿诸佛土所有众生。无有贪欲嗔恚痴心。亦无饥渴苦恼之者。以是誓愿因缘力故。于未来世成佛之时。国土众生远离贪淫嗔恚痴心。一切无有饥渴苦恼

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提。度众生故离妄语心。以此善根愿与一切众生共之。愿诸佛土常有花树果树香树。所有众生得妙音声。以是誓愿因缘力故。于未来世成佛之时。所有国土常有花树果树香树。其中众生悉得清净上妙音声

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故远离两舌。以此善根愿与一切众生共之。愿诸佛土所有众生常共和合讲说正法。以是誓愿因缘力故。成佛之时。国土所有一切众生悉共和合讲论法要

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故远离恶口。以此善根愿与一切众生共之。愿诸佛土地平如掌无有沙砾瓦石之属荆蕀恶刺。所有众生其心平等。以是誓愿因缘力故。于未来世成佛之时。所有国土地平如掌无有沙砾荆蕀恶刺。所有众生其心平等

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故离无义语。以此善根愿与一切众生共之。愿诸佛土所有众生无有苦恼。以是誓愿因缘力故。于未来世成佛之时。国土所有一切众生无有苦恼

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故远离贪嫉。以此善根愿与一切众生共之。愿诸佛土一切众生无有贪嫉恼害邪见。以此誓愿因缘力故。于未来世成佛之时。国土所有一切众生悉无贪嫉恼害邪见

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故远离恼害。以此善根愿与一切众生共之。愿诸佛土所有众生悉共修习大慈大悲得一子地。以是誓愿因缘力故。于未来世成佛之时。世界所有一切众生悉共修习大慈大悲得一子地

复次善男子。菩萨摩诃萨修大涅槃微妙经典。为阿耨多罗三藐三菩提度众生故远离邪见。以此善根愿与一切众生共之。愿诸佛土所有众生悉得摩诃般若波罗蜜。以是誓愿因缘力故。于未来世成佛之时。世界众生悉得受持摩诃般若波罗蜜。是名菩萨修净佛土

云何菩萨摩诃萨灭除有余。有余有三。一者烦恼余报。二者余业。三者余有。善男子。云何名为烦恼余报。若有众生习近贪欲。是报熟故堕于地狱。从地狱出受畜生身。所谓鸽雀鸳鸯鹦鹉耆婆耆婆舍利伽鸟青雀鱼鳖弥猴獐鹿。若得人身受黄门形女人二根无根淫女。若得出家犯初重戒。是名余报

复次善男子。若有众生以殷重心习近嗔恚。是报熟故堕于地狱。从地狱出受畜生身。所谓毒蛇具四种毒。见毒触毒啮毒歔毒。师子虎狼熊罴猫狸鹰鹞之属。若得人身具足十六诸恶律仪。若得出家犯第二重戒。是名余报

复次善男子。若有修习愚痴之人。是报熟时堕于地狱。从地狱出受畜生身。所谓象猪牛羊水牛蚤虱蚊虻蚁子等形。若得人身聋盲喑哑癃残背瘘。诸根不具不能受法。若得出家诸根闇钝喜犯重戒乃至五钱。是名余报。复次善男子。若有修习憍慢之人。是报熟时堕于地狱。从地狱出受畜生身。所谓粪虫驼驴犬马。若生人中受奴婢身贫穷乞丐。或得出家常为众生之所轻贱破第四戒。是名余报。如是等名烦恼余报。如是余报菩萨摩诃萨以能修习大涅槃故悉得除灭。云何余业。谓一切凡夫业。一切声闻业。须陀洹人受七有业。斯陀含人受二有业。阿那含人受色有业。是名余业。如是余业菩萨摩诃萨以能修习大涅槃故悉得断除

云何余有。阿罗汉得阿罗汉果。辟支佛得辟支佛果。无业无结而转二果。是名余有。如是三种有余之法。菩萨摩诃萨修习大乘大涅槃经故得灭除。是名菩萨摩诃萨灭除有余云何菩萨修清净身。菩萨摩诃萨修不杀戒有五种心。谓下中上上中上上。乃至正见亦复如是。是五十心名初发心。具足决定成五十心是名满足。如是百心名百福德。具足百福成于一相。如是展转具足成就三十二相。名清净身。所以复修八十种好。世有众生事八十神。何等八十。十二日十二大天五大星北斗马天行道天婆罗堕跋阇天功德天二十八宿地天风天水天火天梵天楼陀天因提天拘摩罗天八臂天摩醯首罗天半阇罗天鬼子母天四天王天造书天婆薮天。是名八十。为此众生修八十好以自庄严。是名菩萨清净之身。何以故。是八十天一切众生之所信伏。是故菩萨修八十好其身不动。令彼众生随其所信各各而见。见已宗敬各发阿耨多罗三藐三菩提心。以是义故。菩萨摩诃萨修于净身。善男子。譬如有人欲请大王。要当庄严所有舍宅极令清净。辨具种种百味肴膳。然后王当就其所请。菩萨摩诃萨亦复如是。欲请阿耨多罗三藐三菩提法轮王故。先当修身极令清净。无上法王乃当处之。以是义故。菩萨摩诃萨要当修于清净之身。善男子。譬如有人欲服甘露先当净身。菩萨摩诃萨亦复如是。欲服无上甘露法味般若波罗蜜。要当先以八十种好清净其身。善男子。譬如妙好金银盂器盛之净水中表俱净。菩萨摩诃萨其身清净亦复如是。盛阿耨多罗三藐三菩提水中表俱净。善男子。如波罗奈素白之衣易受染色。何以故。性白净故。菩萨摩诃萨亦复如是。以身净故疾得阿耨多罗三藐三菩提。以是义故。菩萨摩诃萨修于净身。云何菩萨摩诃萨善知诸缘。菩萨摩诃萨不见色相。不见色缘不见色体。不见色生不见色灭。不见一相不见异相。不见见者不见相貌不见受者。何以故。了因缘故。如色一切法亦如是。是名菩萨了知诸缘

云何菩萨离诸怨敌。一切烦恼是菩萨怨敌。菩萨摩诃萨常远离故。是名菩萨坏诸怨敌。五住菩萨视诸烦恼不名为怨。所以者何。因烦恼故菩萨有生。以有生故。故能展转教化众生。以是义故不名为怨。何等为怨。所谓诽谤方等经者。菩萨随生不畏地狱畜生饿鬼。唯畏如是谤方等者。一切菩萨有八种魔名为怨家。远是八魔名离怨家。是名菩萨离诸怨家

云何菩萨远离二边。言二边者。谓二十五有及爱烦恼。菩萨常离二十五有及爱烦恼。是名菩萨远离二边。是名菩萨摩诃萨修大涅槃具足成就第四功德

尔时光明遍照高贵德王菩萨摩诃萨言。如佛所说若有菩萨修大涅槃。悉作如是十事功德。如来何故唯修九事不修净土

佛言。善男子。我于往昔亦常具修如是十事。一切菩萨及诸如来无有不修是十事者。若使世界不净充满。诸佛世尊于中出者。无有是处。善男子。汝今莫谓诸佛出于不净世界。当知是心不善狭劣。汝今当知我实不出阎浮提界。譬如有人说言此界独有日月。他方世界无有日月。如是之言无有义理。若有菩萨发如是言。此佛世界秽恶不净。他方佛土清净严丽。亦复如是。善男子。西方去此娑婆世界度三十二恒河沙等诸佛国土。彼有世界名曰无胜。彼土何故名曰无胜。其土所有严丽之。事皆悉平等无有差别。犹如西方安乐世界。亦如东方满月世界。我于彼土出现于世。为化众生故。于此界阎浮提中现转法轮。非但我身独于此中现转法轮。一切诸佛亦于此中而转法轮。以是义故。诸佛世尊非不修行如是十事。善男子。慈氏菩萨以誓愿故。当来之世令此世界清净庄严。以是义故。一切诸佛所有世界无不严净

复次善男子。云何菩萨摩诃萨。修大涅槃微妙经典。具足成就第五功德。善男子。菩萨摩诃萨修大涅槃具足成就第五功德。有五事。何等为五。一者诸根完具。二者不生边地。三者诸天爱念。四者常为天魔沙门刹利婆罗门等之所恭敬。五者得宿命智。菩萨以是大涅槃经因缘力故。具足如是五事功德光明遍照高贵德王菩萨言。如佛所说若有善男子善女人修于布施。则得具成五事功德。今云何言因大涅槃得是五事

佛言。善哉善哉。善男子。如是之事其义各异。今当为汝分别解说。施得五事不定不常不净不胜不异。非无漏。不能利益安乐怜愍一切众生。若依如是大涅槃经所得五事。是定是常是净是胜是异。是无漏。则能利益安乐怜愍一切众生。善男子。夫布施者则离饥渴。大涅槃经能令众生悉得远离二十五有渴爱之病。布施因缘令生死相续。大涅槃经能令生死断不相续。因布施故受凡夫法。因大涅槃得作菩萨。布施因缘能断一切贫穷苦恼。大涅槃经能断一切贫善法者。布施因缘有分有果。因大涅槃得阿耨多罗三藐三菩提无分无果。是名菩萨摩诃萨修大涅槃微妙经典。具足成就第五功德

善男子。云何菩萨修大涅槃微妙经典。具足成就第六功德。菩萨摩诃萨修大涅槃。得金刚三昧安住是中。悉能破散一切诸法。见一切法皆是无常皆是动相恐怖因缘。病苦劫盗念念灭坏无有真实。一切皆是魔之境界无可见相。菩萨摩诃萨住是三昧。虽施众生乃至不见一众生。实为众生故精勤修习尸波罗蜜。乃至修习般若波罗蜜亦复如是。菩萨若见有一众生。不能毕竟具足成就檀波罗蜜乃至具足般若波罗蜜。善男子。譬如金刚所拟之处无不碎坏。而是金刚无有折损。金刚三昧亦复如是。所拟之法无不碎坏。而是三昧无有折损。善男子。如诸宝中金刚最胜。菩萨所得金刚三昧亦复如是。于诸三昧为最第一。何以故。菩萨摩诃萨修是三昧。一切三昧悉来归属。善男子。如诸小王悉来归属转轮圣王。一切三昧亦复如是。悉来归属金刚三昧。善男子。譬如有人为国怨仇人所厌患。有人杀之。一切世人无不称赞是人功德。金刚三昧亦复如是。菩萨修习能坏一切众生怨敌。是故常为一切三昧之所宗敬。善男子。譬如有人其力盛壮人无当者。复更有人力能伏之。当知是人世所称美。金刚三昧亦复如是。力能摧伏难伏之法。以是义故。一切三昧悉来归属。善男子。譬如有人在大海浴。当知是人已用诸河泉池之水。菩萨摩诃萨亦复如是。修习如是金刚三昧。当知已为修习其余一切三昧。善男子。如香山中有一泉水名阿那婆踏多。其泉具足八味之水。有人饮之无诸病苦。金刚三昧亦复如是具八正道。菩萨修习断诸烦恼疮疣重病。善男子。如人供养摩醯首罗。当知是人已为供养一切诸天。金刚三昧亦复如是。有人修习当知已为修习一切诸余三昧。善男子。若有菩萨安住如是金刚三昧。见一切法无有障碍。如于掌中观阿摩勒果。菩萨虽复得如是见。终不作想见一切法。善男子。譬如有人坐四衢道头见诸众生来去坐卧。金刚三昧亦复如是。见一切法生灭出没。善男子。譬如高山有人登之远望诸方皆悉明了。金刚定山亦复如是。菩萨登之远望诸法无不明了。善男子。譬如春月天降甘雨其渧微致间无空处。明眼之人见之了了。菩萨亦尔得金刚定清净之目。远见东方所有世界。其中或有国土成坏。一切皆见了了无障。乃至十方亦复如是。善男子。如由乾陀山七日并出。其山所有树木丛林一切烧尽。菩萨修习金刚三昧亦复如是。所有一切烦恼丛林即时消灭。善男子。譬如金刚虽能摧破一切有物。终不生念我能摧破。金刚三昧亦复如是。菩萨修已能破烦恼。终不生念我能坏结。善男子。譬如大地能持万物。终不生念我力能持。火亦不念我能烧物。水亦不念我能润渍。风亦不念我能动物。空亦不念我能容受。涅槃亦复不生念言。我令众生而得灭度。金刚三昧亦复如是。虽能灭除一切烦恼。而初无心言我能灭。若有菩萨安住如是金刚三昧。于一念中变身如佛。其数无量遍满十方恒河沙等诸佛世界。而是菩萨虽作是化。其心初无憍慢之想。何以故。菩萨常念。谁有是定能作是化。唯有菩萨安住如是金刚三昧乃能作耳。菩萨摩诃萨安住如是金刚三昧。于一念中遍到十方恒河沙等诸佛世界还其本处。虽有是力亦不念言我能如是。何以故。以是三昧因缘力故。菩萨摩诃萨安住如是金刚三昧。于一念中能断十方恒河沙等世界众生所有烦恼。而心初无断诸众生。烦恼之想。何以故。以是三昧因缘力故。菩萨住是金刚三昧。以一音声有所演说。一切众生各随种类而得解了。示现一色一切众生各各皆见种种色相。安住一处身不移易能令众生随其方面各各而见。演说一法若界若入。一切众生各随本解而得闻之

菩萨安住。如是三昧。虽见众生而心初无众生之相。虽见男女无男女相。虽见色法无有色相。乃至见识亦无识相。虽见昼夜无昼夜相。虽见一切无一切相。虽见一切烦恼诸结。亦无一切烦恼之相。虽见八圣道无圣道相。虽见菩提无菩提相。虽见于涅槃无涅槃相。何以故。善男子。一切诸法本无相故。菩萨以是三昧力故。见一切法如本无相。何故名为金刚三昧。善男子。譬如金刚若在日中色则不定。金刚三昧亦复如是。在于大众色亦不定。是故名为金刚三昧。善男子。譬如金刚一切世人不能评价。金刚三昧亦复如是。所有功德一切人天不能评量。是故复名金刚三昧。善男子。譬如贫人得金刚宝。则得远离贫穷困苦恶鬼邪毒。菩萨摩诃萨亦复如是。得是三昧则能远离烦恼诸苦诸魔邪毒。是故复名金刚三昧。是名菩萨修大涅槃具足成就第六功德

大般涅槃经卷第二十四大般涅槃经卷第二十五

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之五

复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第七功德。善男子。菩萨摩诃萨修大涅槃微妙经典。作是思惟。何法能为大般涅槃而作近因。菩萨即知有四种法为大涅槃而作近因。若言勤修一切苦行是大涅槃近因缘者。是义不然。所以者何。若离四法得涅槃者无有是处。何等为四。一者亲近善友。二者专心听法。三者系念思惟。四者如法修行。善男子。譬如有人身遇众病。若热若冷虚劳下疟众邪鬼毒到良医所。良医即为随病说药。是人至心善受医教。随教合药如法服之。服已病愈身得安乐。有病之人喻诸菩萨。大良医者喻善知识。良医所说喻方等经。善受医教喻善思惟方等经义。随教合药喻如法修行三十七助道之法。病除愈者喻灭烦恼。得安乐者喻得涅槃常乐我净善男子。譬如有王欲如法治令民安乐。咨诸智臣其法云何。诸臣即以先王旧法而为说之。王既闻已至心信行。如法治国无诸怨敌。是故令民安乐无患。善男子。王者喻诸菩萨。诸智臣者喻善知识。智臣为王所说治法喻十二部经。王既闻已至心信行。喻诸菩萨系心思惟十二部经所有深义。如法治国喻诸菩萨如法修行。所谓六波罗蜜。以能修习六波罗蜜故无诸怨敌。喻诸菩萨已离诸结烦恼恶贼。得安乐者喻诸菩萨得大涅槃常乐我净

善男子。譬如有人遇恶癞病。有善知识而语之言。汝若能到须弥山边病可得差。所以者何。彼有良药味如甘露。若能服者病无不愈。其人至心信是事已。即往彼山采服甘露。其病除愈身得安乐。恶癞病者喻诸凡夫。善知识者喻诸菩萨摩诃萨等。至心信受喻四无量心。须弥山者喻八圣道。甘露味者喻于佛性。癞病除愈喻离烦恼。得安乐者喻得涅槃常乐我净。善男子。譬如有人畜诸弟子聪明大智。是人昼夜常教不倦。诸菩萨等亦复如是。一切众生有信不信。而常教化无有疲厌

善男子。善知识者所谓菩萨佛辟支佛声闻人中信方等者。何故名为善知识耶。善知识者能教众生远离十恶修行十善。以是义故名善知识。复次善知识者如法而说如说而行。云何名为如法而说如说而行。自不杀生教人不杀。乃至自行正见教人正见。若能如是则得名为真善知识。自修菩提亦能教人修行菩提。以是义故名善知识。自能修行信戒布施多闻智慧。亦能教人信戒布施多闻智慧。复以是义名善知识。善知识者有善法故。何等善法。所作之事不求自乐。常为众生而求于乐。见他有过不讼其短。口常宣说纯善之事。以是义故名善知识

善男子。如空中月从初一日至十五日渐渐增长。善知识者亦复如是。令诸学人渐远恶法增长善法。善男子。若有亲近善知识者。本未有戒定慧解脱解脱知见即便有之。未具足者则得增广。何以故。以其亲近善知识故。因是亲近复得了达十二部经甚深之义。若能听是十二部经甚深义者。名为听法。听法者则是大乘方等经典。听方等经名真听法。真听法者即是听受大涅槃经。大涅槃中闻有佛性如来毕竟不般涅槃。是故名为专心听法。专心听法名八圣道。以八圣道能断贪欲嗔恚愚痴故名听法。夫听法者名十一空。以此诸空于一切法不作相貌。夫听法者名初发心。乃至究竟阿耨多罗三藐三菩提心。以因初心得大涅槃。不以闻故得大涅槃。以修习故得大涅槃

善男子。譬如病人虽闻医教及药名字不能愈病。以服食故能得差病。虽听十二深因缘法。不能得断一切烦恼。要以系念善思惟故能得除断。是名第三系念思惟。复以何义。名系念思惟。所谓三三昧。空三昧无相三昧无作三昧。空者于二十五有不见一实。无作者于二十五有不作愿求。无相者无有十相。所谓色相声相香相味相触相生相住相灭相男相女相。修习如是三三昧者。是名菩萨系念思惟。云何名为如法修行。如法修行即是修行檀波罗蜜乃至般若波罗蜜。知阴入界真实之相。亦如声闻缘觉诸佛同于一道而般涅槃。法者即是常乐我净。不生不老不病不死不饥不渴不苦不恼不退不没。善男子。解大涅槃甚深义者。则知诸佛终不毕竟入于涅槃

善男子。第一真实善知识者。所谓菩萨诸佛世尊。何以故。常以三种善调御故。何等为三。一者毕竟软语。二者毕竟呵责。三者软语呵责。以是义故。菩萨诸佛即是真实善知识也。复次善男子。佛及菩萨为大医故名善知识。何以故。知病知药应病授药故。譬如良医善八种术先观病相。相有三种。何等为三。谓风热水。有风病者授之苏油。热病之人授之石蜜。水病之人授之姜汤。以知病根授药得差。故名良医。佛及菩萨亦复如是。知诸凡夫病有三种。一者贪欲。二者嗔恚。三者愚痴。贪欲病者教观骨相。嗔恚病者观慈悲相。愚痴病者观十二缘相。以是义故。诸佛菩萨名善知识。善男子。如大船师善渡人故名大船师。诸佛菩萨亦复如是。度诸众生生死大海。以是义故名善知识。复次善男子。因佛菩萨令诸众生具足修得善法根本故。善男子。譬如雪山乃是种种微妙上药根本之处。佛及菩萨亦复如是。悉是一切善根本处。以是义故名善知识。善男子。雪山之中有上香药名曰娑呵。有人见之得寿无量无有病苦。虽有四毒不能中伤。若有触者增长寿命满百二十。若有念者得宿命智。何以故。药势力故。诸佛菩萨亦复如是。若有见者即得断除一切烦恼。虽有四魔不能干乱。若有触者命不可夭不生不死不退不没。所谓触者若在佛边听受妙法。若有念者得阿耨多罗三藐三菩提。以是义故诸佛菩萨名善知识。善男子。如香山中有阿那婆踏多池水。由是池故有四大河。所谓恒河辛头私陀博叉。世间众生常作是言。若有罪者浴此四河众罪得灭。当知此言虚妄不实。除此已往何等为实。诸佛菩萨是乃为实。所以者何。若人亲近则得灭除一切众罪。以是义故名善知识。复次善男子。譬如大地所有药木一切丛林百谷甘蔗花果之属。值天炎旱将欲枯死。难陀龙王及婆难陀怜愍众生。从大海出降澍甘雨。一切丛林百谷草木滋润还生。一切众生亦复如是。所有善根将欲消灭。诸佛菩萨生大慈悲。从智慧海降甘露雨。令诸众生具足还得十善之法。以是义故诸佛菩萨名善知识。善男子。譬如良医善八种术。见诸病人不观种姓端正好丑钱财宝货悉为治之。是故世称为大良医。诸佛菩萨亦复如是。见诸众生有烦恼病不观种姓端正好丑钱财宝货。生慈愍心悉为说法。众生闻已烦恼病除。以是义故诸佛菩萨名善知识。以是亲近善友因缘。则得近于大般涅槃

云何菩萨听法因缘而得近于大般涅槃。一切众生以听法故则具信根。得信根故乐行布施持戒忍辱精进禅定智慧。得须陀洹果乃至佛果。是故当知得诸善法皆是听法因缘势力。善男子。譬如长者惟有一子。遣至他国市易所须。示其道路通塞之处。而复诫之。若遇淫女慎莫亲爱。若亲爱者丧身殒命及以财宝。弊恶之人亦莫交游。其子敬顺父之教敕。身心安乐多获宝货。菩萨摩诃萨为诸众生敷演法要亦复如是。示诸众生及四部众诸道通塞。是诸众生以闻法故。远离诸恶具足善法。以是义故。听法因缘则得近于大般涅槃。善男子。譬如明镜照人面像无不明了。听法明镜亦复如是。有人照之则见善恶明了无翳以是义故。听法因缘则得近于大般涅槃。善男子。譬如估客欲至宝渚不知道路。有人示之。其人随语即至宝渚。多获诸珍不可称计。一切众生亦复如是。欲至善处采取道宝。不知其路通塞之处。菩萨示之众生随已得至善处。获得无上大涅槃宝。以是义故。听法因缘则得近于大般涅槃。善男子。譬如醉象狂騃暴恶多欲杀害。有调象师以大铁钩钩斲其顶。即时调顺恶心都尽。一切众生亦复如是。贪欲嗔恚愚痴醉故欲多造恶。诸菩萨等以闻法钩斲之令住。更不得起造诸恶心。以是义故。听法因缘则得近于大般涅槃。是故我于处处经中说。我弟子专心听受十二部经。则离五盖修七觉分。以是修习七觉分故。则得近于大般涅槃。以听法故须陀洹人离诸恐怖。所以者何。须达长者身遇重病心大愁怖。闻舍利弗说须陀洹有四功德十种慰喻。闻是事已恐怖即除。以是义故。听法因缘则得近于大般涅槃。何以故。开法眼故。世有三人。一者无目。二者一目。三者二目。言无目者常不闻法。一目之人虽暂闻法其心不住。二目之人专心听受如闻而行。以听法故得知世间。如是三人以是义故。听法因缘则得近于大般涅槃。善男子。如我昔于拘尸那城。时舍利弗身遇病苦。我时顾命阿难比丘广为说法。时舍利弗闻是事已告四弟子。汝舁我床往至佛所。我欲听法。时四弟子即共舁往既得闻法。闻法力故所苦除差身得安隐。以是义故。听法因缘则得近于大般涅槃

云何菩萨思惟因缘而得近于大般涅槃。因是思惟心得解脱。何以故。一切众生常为五欲之所系缚。以思惟故悉得解脱。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切众生常为常乐我净四法之所颠倒。以思惟故得见诸法无常无乐无我无净。如是见已四倒即断。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切诸法有四种相。何等为四。一者生相。二者老相。三者病相。四者灭相。以是四相能令一切凡夫众生至须陀洹生大苦恼。若能系念善思惟者。虽遇此四不生于苦。以是义故。思惟因缘则得近于大般涅槃。复次善男子。一切善法无不因于思惟而得。何以故。有人虽于无量无边阿僧祇劫专心听法。若不思惟终不能得阿耨多罗三藐三菩提以是义故。思惟因缘则得近于大般涅槃。复次善男子。若有众生信佛法僧无有变易而生恭敬。当知皆是系念思惟因缘力故。因得断除一切烦恼。以是义故。思惟因缘则得近于大般涅槃

云何菩萨如法修行。善男子。断诸恶法修习善法。是名菩萨如法修行。复次云何如法修行。见一切法空无所有。无常无乐无我无净。以是见故宁舍身命不犯禁戒。是名菩萨如法修行。复次云何如法修行。修有二种。一者真实。二者不实。不实者。不知涅槃佛性如来法僧实相虚空等相。是名不实。云何真实。能知涅槃佛性如来法僧实相虚空等相。是名真实。云何名为知涅槃相。涅槃之相凡有八事。何等为八。一者尽二善性三实四真五常六乐七我八净。是名涅槃。复有八事。何等为八。一者解脱。二者善性。三者不实。四者不真。五者无常。六者无乐。七者无我。八者无净。复有六相。一者解脱。二者善性。三者不实。四者不真。五者安乐。六者清净。若有众生依世俗道断烦恼者。如是涅槃则有八事解脱不实。何以故。以不常故。以无常故则无有实。无有实故则无有真。虽断烦恼以还起故。无常无我无乐无净。是名涅槃解脱八事。云何六相。声闻缘觉断烦恼故。名为解脱。而未能得阿耨多罗三藐三菩提故名为不实。以不实故名为不真。未来之世当得阿耨多罗三藐三菩提故名无常。以得无漏八圣道故名为净乐。善男子。若如是知。是知涅槃不名佛性如来法僧实相虚空

云何菩萨知于佛性。佛性有六。何等为六。一常二净三实四善五当见六真。复有七事。一者可证余六如上。是名菩萨知于佛性云何菩萨知如来相。如来即是觉相善相。常乐我净解脱真实示道可见。是名菩萨知如来相

云何菩萨知于法相。法者。若善不善。若常不常若乐不乐。若我无我若净不净。若知不知若解不解。若真不真若修不修。若师非师若实不实。是名菩萨知于法相

云何菩萨知于僧相。僧者若常乐我净是弟子相可见之相。善真不。实何以故。一切声闻得佛道故。何故名真。悟法性故。是名菩萨知于僧相

云何菩萨知于实相。实相者。若常无常若乐无乐。若我无我若净无净。若善不善若有若无。若涅槃非涅槃。若解脱非解脱。若知不知若断不断。若证不证若修不修。若见不见。是名实相。非是涅槃佛性如来法僧虚空。是名菩萨因修如是大涅槃故。知于涅槃佛性如来法僧实相虚空等法差别之相

善男子。菩萨摩诃萨修大涅槃微妙经典。不见虚空。何以故。佛及菩萨虽有五眼所不见故。惟有慧眼乃能见之。慧眼所见无法可见。故名为见。若是无物名虚空者。如是虚空乃名为实。以是实故则名常无。以常无故无乐我净。善男子。空名无法无法名空。譬如世间无物名空。虚空之性亦复如是。无所有故名为虚空。善男子。众生之性与虚空性俱无实性。何以故。如人说言。除灭有物然后作空。而是虚空实不可作。何以故。无所有故。以无有故当知无空。是虚空性若可作者则名无常。若无常者不名虚空。善男子。如世间人说言虚空无色无碍常不变易。是故世称虚空之法为第五大。善男子。而是虚空实无有性。以光明故故名虚空。实无虚空。犹如世谛实无其性。为众生故说有世谛。善男子。涅槃之体亦复如是无有住处。直是诸佛断烦恼处故名涅槃。涅槃即是常乐我净。涅槃虽乐非是受乐。乃是上妙寂灭之乐。诸佛如来有二种乐。一寂灭乐。二觉知乐。实相之体有三种乐。一者受乐。二寂灭乐。三觉知乐。佛性一乐以当见故。得阿耨多罗三藐三菩提时名菩提乐

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。若烦恼断处是涅槃者。是事不然。何以故。如来往昔初成佛道至尼连禅河边。尔时魔王与其眷属到于佛所。而作是言。世尊。涅槃时到何故不入。佛告魔王。我今未有多闻弟子善持禁戒聪明利智能化众生。是故不入。若言烦恼断灭之处是涅槃者。诸菩萨等于无量劫已断烦恼。何故不得称为涅槃。俱是断处何缘独称诸佛有之菩萨无耶。若断烦恼非涅槃者。何故如来昔告生名婆罗门言。我今此身即是涅槃。如来昔时在毗舍离国。魔复启请。如来。昔以未有弟子多闻持戒聪明利智能化众生不入涅槃。今已具足何故不入。如来尔时即告魔言。汝今莫生悒迟之想。却后三月吾当涅槃。世尊。若使灭度非涅槃者。何故如来。自期三月当般涅槃。世尊。若断烦恼是涅槃者。如来往昔初在道场菩提树下。断烦恼时便是涅槃。何故复言却后三月当般涅槃。世尊。若使尔时是涅槃者。云何方为拘尸那城诸力士等。说言后夜当般涅槃。如来诚实。云何出是虚妄之言

尔时世尊。告光明遍照高贵德王菩萨摩诃萨言。善男子。若言如来得广长舌。当知如来于无量劫已离妄语。一切诸佛及诸菩萨。凡所发言诚谛无虚。善男子。如汝所言。波旬往昔启请于我入涅槃者。善男子。而是魔王真实不知涅槃定相。何以故。波旬意谓。不化众生默然而住便是涅槃。善男子。譬如世人见人不言无所造作。便谓是人如死无异。魔王波旬亦复如是。意谓如来不化众生默无所说。便谓如来入般涅槃。善男子。如来不说佛法众僧无差别相。惟说常住清净二法无差别耳。善男子。佛亦不说佛及佛性涅槃无差别相。惟说常恒不变无差别耳。善男子。佛亦不说涅槃实相无差别相。惟说常有实不变易无差别耳。善男子。尔时我诸声闻弟子生于诤讼如拘睒弥。诸恶比丘违反我教多犯禁戒。受不净物贪求利养。向诸白衣而自赞叹我得无漏。谓须陀洹果乃至我得阿罗汉果。毁辱于他于佛法僧戒律和上不生恭敬。公于我前言如是物佛所听畜。如是等物佛不听畜。我亦语言如是等物我实不听。复反我言如是等物实是佛听。如是恶人不信我言。为是等故我告波旬。汝莫悒迟。却后三月当般涅槃。善男子。因如是等恶比丘故。令诸声闻受学弟子不见我身不闻我法。便言如来入于涅槃。惟诸菩萨能见我身常闻我法。是故不言我入涅槃。声闻弟子虽复发言如来涅槃。而我实。不入于涅槃。善男子。若我所有声闻弟子说言如来入涅槃者。当知是人非我弟子是魔伴党。邪见恶人非正见也。若言如来不入涅槃。当知是人真我弟子非魔伴党。正见之人非恶邪也。善男子。我初不见弟子之中有言如来不化众生默然而住名般涅槃也。善男子。譬如长者多有子息舍至他方。未得还顷诸子并谓父已死矣。而是长者实亦不死。诸子颠倒皆生死想。声闻弟子亦复如是不见我故。便谓如来已于拘尸那城娑罗双树间而般涅槃。而我实不般涅槃也。声闻弟子生涅槃想。善男子。譬如明灯有人覆之。余不知者谓灯已灭。而是明焰实亦不灭。以不知故生于灭想。声闻弟子亦复如是。虽有慧目以烦恼覆。令心颠倒不见真身。而便生于灭度之想。而我实不取灭度也

善男子。如生盲人不见日月。以不见故不知昼夜明闇之相。以不知故便说无有日月之实。实有日月盲者不见。以不见故生于倒想言无日月。声闻弟子亦复如是。如彼生盲不见如来。便谓如来入于涅槃。如来实不入于涅槃。以倒想故生如是心。善男子。譬如云雾覆蔽日月。痴人便言无有日月。日月实有直以覆故众生不见。声闻弟子亦复如是。以诸烦恼覆智慧眼不见如来。便言如来入于灭度。善男子。真是如来现婴儿行非灭度也。善男子。如阎浮提日入之时。众生不见以黑山障故。而是日性实无没入。众生不见生没入想。声闻弟子亦复如是。为诸烦恼山所障故不见我身。以不见故便于如来生灭度想。而我实不趣灭度也

是故我于毗舍离国告波旬言。却后三月我当涅槃。善男子。如来玄见迦叶菩萨却后三月善根当熟。亦见香山须跋陀罗竟安居已当至我所。是故我告魔王波旬。却后三月当般涅槃。善男子。有诸力士其数五百。终竟三月亦当得发阿耨多罗三藐三菩提心。我为是故告波旬言。却后三月当般涅槃。善男子。纯陀等辈及五百梨车庵罗果女。却后三月无上道心善根成熟。为是等故我告波旬。却后三月当般涅槃。善男子。须那刹多亲近外道尼干子等。我为说法满十二年。彼人邪见不信不受。我知是人邪见根栽。却后三月定可斫伐。我为是故告波旬言。却后三月当般涅槃

善男子。何因缘故我于往昔尼连河边告魔波旬。我今未有多智弟子。是故不得入涅槃者。我时欲为五比丘等于波罗奈转法轮故。复次欲为五比丘等。所谓耶奢富那毗摩罗阇憍梵波提须婆睺。次复欲为郁伽长者等五十人。次复欲为摩伽陀国频婆娑罗王等无量人天。次复欲为优楼频螺迦叶门徒五百比丘。次复欲为那提迦叶伽耶迦叶兄弟二人及五百弟子。次复欲为舍利弗目犍连等二百五十比丘转妙法轮。是故我告魔王波旬不般涅槃

善男子。有名涅槃非大涅槃。云何涅槃非大涅槃。不见佛性而断烦恼是名涅槃非大涅槃。以不见佛性故。无常无我惟有乐净。以是义故。虽断烦恼不得名为大般涅槃也。若见佛性能断烦恼。是则名为大涅槃也。以见佛性故得名为常乐我净。以是义故。断除烦恼亦得称为大般涅槃

善男子。涅者言不。槃者言织。不织之义名为涅槃。槃又言覆。不覆之义乃名涅槃。槃言去来。不去不来乃名涅槃。槃者言取。不取之义乃名涅槃。槃言不定。定无不定乃名涅槃。槃言新故。无新故义乃名涅槃。槃言障碍。无障碍义乃名涅槃。善男子。有忧罗迦迦毗罗弟子等言。槃者名相。无相之义乃名涅槃。善男子。槃者言有。无有之义乃名涅槃。槃名和合。无和合义乃名涅槃。槃者言苦。无苦之义乃名涅槃。善男子。断烦恼者不名涅槃。不生烦恼乃名涅槃。善男子。诸佛如来烦恼不起是名涅槃。所有智慧于法无碍是为如来。如来非是凡夫声闻缘觉菩萨。是名佛性。如来身心智慧遍满无量无边阿僧祇土无所障碍。是名虚空。如来常住无有变易。名曰实相。以是义故如来实不毕竟涅槃。是名菩萨修大涅槃微妙经典。具足成就第七功德复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第八功德。善男子。菩萨摩诃萨修大涅槃。除断五事远离五事。成就六事。修习五事。守护一事。亲近四事。信顺一实。心善解脱慧善解脱

善男子。云何菩萨除断五事。所谓五阴。色受想行识。所言阴者其义何。谓能令众生生死相续不离重檐。分散聚合三世所摄。求其义理了不可得。以是诸义故名为阴。菩萨摩诃萨虽见色阴不见其相。何以故。于十色中推求其性悉不可得。为世界故说言为阴。受有百八。虽见受阴初无受相。何以故。受虽百八理无定实。是故菩萨不见受阴。想行识等亦复如是。菩萨摩诃萨深见五阴。是生烦恼之根本也。以是义故方便令断

云何菩萨远离五事。所谓五见。何等为五。一者身见。二者边见。三者邪见。四者戒取。五者见取。因是五见生六十二见。因是诸见生死不绝。是故菩萨防之不近

云何菩萨成就六事。谓六念处何等为六。一者念佛。二者念法三者念僧。四者念天。五者念施六者念戒是名菩萨成就六事

云何菩萨修习五事。所谓五定。一者知定。二者寂定三者身心受快乐定四者无乐定。五者首楞严定。修习如是五种定心。则得近于大般涅槃。是故菩萨勤心修习

云何菩萨守护一事。谓菩提心。菩萨摩诃萨常勤守护是菩提心。犹如世人守护一子。亦如瞎者护余一目。如行圹野守护导者。菩萨守护菩提之心。亦复如是。因护如是菩提心故得阿耨多罗三藐三菩提。因得阿耨多罗三藐三菩提故常乐我净具足而有。即是无上大般涅槃。是故菩萨守护一法

云何菩萨亲近四事。谓四无量心。何等为四。一者大慈。二者大悲。三者大喜。四者大舍。因是四心能令无量无边众生发菩提心。是故菩萨系心亲近。云何菩萨信顺一实。菩萨了知一切众生皆归一道。一道者谓大乘也。诸佛菩萨为众生故分之为三。是故菩萨信顺不逆

云何菩萨心善解脱。贪恚痴心永断灭故。是名菩萨心善解脱

云何菩萨慧善解脱。菩萨摩诃萨于一切法知无障碍。是名菩萨慧善解脱。因慧解脱昔所不闻而今得闻。昔所不见而今得见。昔所不到而今得到。尔时光明遍照高贵德王菩萨摩诃萨言。世尊。如佛所说心解脱者。是义不然。何以故。心本无系。所以者何。是心本性不为贪欲嗔恚愚痴诸结所系若本无系。云何而言心善解脱。世尊。若心本性不为贪结之所系者。何等因缘而能得系如人构角本无乳相。虽如功力乳无由出。构乳之者不得如是加功虽少乳则多出。心亦如是。本无贪者今云何有。若本无贪后方有者。诸佛菩萨本无贪相今悉应有。世尊。譬如石女本无子相。虽加功力无量因缘子不可得心亦如是本无贪相。虽造众缘贪无由生。世尊。如攒湿木火不可得。心亦如是。虽复攒求贪不可得。云何贪结能系于心。世尊。譬如押沙油不可得。心亦如是虽复押之贪不可得。当知贪心二理各异。设复有之何能污心。世尊譬如有人安橛于空终不得住。安贪于心亦复如是。种种因缘不能令贪系缚于心。世尊。若心无贪名解脱者。诸佛菩萨何故不拔虚空中刺。世尊。过去世心不名解脱。未来世心亦无解脱。现在世心不与道共。何等世心名得解脱。世尊。如过去灯不能灭闇。未来世灯亦不灭闇。现在世灯复不灭闇。何以故。明之与闇二不并故。心亦如是。云何而言心得解脱。世尊。贪亦是有。若贪无者。见女相时不应生贪。若因女相而得生者。当知是贪真实而有。以有贪故堕三恶道。世尊。譬如有人见画女像亦复生贪。以生贪故得种种罪。若本无贪云何见画而生于贪。若心无贪。云何如来说言菩萨心得解脱。若心有贪。云何见相然后方生。不见相者则不生也。我今现见有恶果报。当知有贪嗔恚愚痴亦复如是。世尊。譬如众生有身无我而诸凡夫横计我想。虽有我想不堕三恶。云何贪者于无女相而起女想堕三恶道。世尊譬如攒木而生于火。然是火性众缘中无。以何因缘而得生耶。世尊。贪亦如是色中无贪。香味触法亦复无贪。云何于色香味触法生于贪耶。若众缘中悉无贪者。云何众生独生于贪。诸佛菩萨而不生耶。世尊心亦不定。若心定者。无有贪欲嗔恚愚痴。若不定者。云何而言心得解脱。贪亦不定。若不定者。云何因之生三恶趣。贪者境界二俱不定。何以故。俱缘一色或生于贪或生于嗔或生愚痴。是故贪者及与境界二俱不定。若俱不定。何故如来说言菩萨修大涅槃心得解脱

尔时世尊告光明遍照高贵德王菩萨摩诃萨言。善哉善哉。善男子。心亦不为贪结所系亦非不系。非是解脱非不解脱。非有非无。非现在非过去非未来。何以故。善男子。一切诸法无有自性故。善男子。有诸外道作如是言。因缘和合则有果生。若众缘中本无生性而能生者。虚空不生亦应生果。虚空不生非是因故。以众缘中本有果性。是故合集而得生果。所以者何。如提婆达欲造墙壁。则取泥土不取彩色。欲造画像则集彩色不取草木。作衣取缕不取泥木。作舍取泥不取缕线。以人取故当知是中各能生果以能生果故当知因中必先有性。若无性者一物之中应当出生一切诸物。若是可取可作可出。当知是中必先有果。若无果者人则不取不作不出。惟有虚空无取无作故能出生一切万物。以有因故如尼拘陀子作尼拘陀树。乳有醍醐缕中有布泥中有瓶。善男子。一切凡夫无明所盲作是定说。色有着义心有贪性。复言凡夫心有贪性亦解脱性。遇贪因缘心则生贪。若遇解脱心则解脱。虽作此说是义不然。有诸凡夫复作是言。一切因中悉无有果。因有二种。一者微细。二者粗大。细即是常粗则无常。从微细因转成粗因。从此粗因转复成果。粗无常故果亦无常。善男子。有诸凡夫复作是言。心亦无因贪亦无因。以时节故则生贪心。如是等辈。以不能知心因缘故。轮回六趣具受生死。善男。子譬如枷犬系之于柱。终日绕柱不能得离。一切凡夫亦复如是。被无明枷系生死柱。绕二十五有不能得离。善男子。譬如有人堕于圊厕。既得出已而复还入。如人病差还为病因。如人涉路值空旷处既得过已而复还来。又如净洗还涂泥土。一切凡夫亦复如是。已得解脱无所有处。唯未得脱非非想处。而复还来至三恶趣。何以故。一切凡夫惟观于果不观因缘。如犬逐块不逐于人。凡夫之人亦复如是。惟观于果不观因缘。以不观故从非想退还三恶趣

善男子。诸佛菩萨终不定说因中有果因中无果。及有无果非有非无果。若言因中先定有果及定无果。定有无果定非有非无果。当知是等皆魔伴党系属于魔即是爱人。如是爱人不能永断生死系缚。不知心相及以贪相。善男子。诸佛菩萨显示中道。何以故。虽说诸法非有非无而不决定。所以者何。因眼因色因明因心因念识则得生。是识决定不在眼中色中明中心中念中。亦非中间非有非无。从缘生故名之为有。无自性故名之为无。是故如来说言诸法非有非无。善男子。诸佛菩萨终不定说心有净性及不净性。净不净性心无住处故。从缘生贪故说非无。本无贪性故说非有。善男子。从因缘故心则生贪。从因缘故心则解脱。善男子。因缘有二。一者随于生死。二者随大涅槃

善男子。有因缘故心共贪生共贪俱灭。有共贪生不共贪灭。有不共贪生共贪俱灭。有不共贪生不共贪灭

云何心共贪生共贪俱灭。善男子。若有凡夫未断贪心修习贪心。如是之人心共贪生心共贪灭。一切众生不断贪心。心共贪生心共贪灭。如欲界众生一切皆有初地味禅。若修不修常得成就。遇因缘故即便得之。言因缘者谓火灾也。一切凡夫亦复如是。若修不修心共贪生心共贪灭。何以故。不断贪故云何心共贪生不共贪灭。声闻弟子有因缘故生于贪心。畏贪心故修白骨观。是名心共贪生不共贪灭。复有心共贪生不共贪灭。如声闻人未证四果。有因缘故生于贪心。证四果时贪心得灭。是名心共贪生不共贪灭。菩萨摩诃萨得不动地时。心共贪生不共贪灭。云何不共贪生共贪俱灭。若菩萨摩诃萨断贪心已。为众生故示现有贪。以示现故能令无量无边众生。咨受善法具足成就。是名不共贪生共贪俱灭

云何不共贪生不共贪灭。谓阿罗汉缘觉诸佛。除不动地其余菩萨。是名不共贪生不共贪灭。以是义故。诸佛菩萨不决定说心性本净性本不净。善男子。是心不与贪结和合。亦复不与嗔痴和合。善男子。譬如日月虽为烟尘云雾及罗睺罗之所覆蔽。以是因缘令诸众生不能得见。虽不可见日月之性终不与彼五翳和合。心亦如是以因缘故。生于贪结众生虽说心与贪合。而是心性实不与合。若是贪心即是贪性。若是不贪即不贪性。不贪之心不能为贪。贪结之心不能不贪。善男子。以是义故。贪欲之结不能污心。诸佛菩萨永破贪结。是故说言心得解脱。一切众生从因缘故生于贪结。从因缘故心得解脱

善男子。譬如雪山悬峻之处人与猕猴俱不能行。或复有处猕猴能行人不能行。或复有处人与猕猴二俱能行。善男子。人与猕猴能行处者。如诸猎师纯以黐胶置之案上用捕猕猴。猕猴痴故往手触之触已粘手。欲脱手故以脚踏之脚复随着。欲脱脚故以口啮之口复粘着。如是五处悉无得脱。于是猎师以杖贯之负还归家。雪山崄处喻佛菩萨所得正道。猕猴者喻诸凡夫。猎师者喻魔波旬。黐胶者喻贪欲结。人与猕猴俱不行者喻诸凡夫魔王波旬俱不能行。猕猴能行人不能者。喻诸外道有智慧者。诸恶魔等虽以五欲不能系缚。人与猕猴俱能行者。一切凡夫及魔波旬常处生死不能修行。凡夫之人五欲所缚。令魔波旬自在将去。如彼猎师黐捕猕猴檐负归家

善男子。譬如国王安住己界身心安乐。若至他界则得众苦。一切众生亦复如是。若能自住于己境界则得安乐。若至他界则遇恶魔受诸苦恼。自境界者谓四念处。他境界者谓五欲也。云何名为系属于魔有诸众生无常见常常见无常。苦见于乐乐见于苦。不净见净净见不净。无我见我我见无我。非实解脱横见解脱。真实解脱见非解脱。非乘见乘乘见非乘。如是之人名系属魔。系属魔者心不清净。复次善男子。若见诸法真实是有总别定相。当知是人若见色时便作色相。乃至见识亦作识相。见男男相见女女相。见日日相见月月相。见岁岁相见阴阴相。见入入相见界界相。如是见者名系属魔。系属魔者心不清净。复次善男子。若见我是色。色中有我。我中有色。色属于我乃至。见我是识。识中有我。我中有识。识属于我。如是见者系属于魔非我弟子。善男子。我声闻弟子远离如来十二部经。修习种种外道典籍。不修出家寂灭之法纯营世俗在家之事。何等名为在家事也。受畜一切不净之物。奴婢田宅象马车乘。驼驴鸡犬猕猴猪羊。种种谷麦。远离师僧亲附白衣。违反圣教向诸白衣作如是言。佛听比丘受畜种种不净之物。是名修习在家之事。有诸弟子不为涅槃。但为利养亲近听受十二部经。招提僧物及僧鬘物。衣着食啖如自己有悭惜他家。及以称誉亲近国王及诸王子。卜筮吉凶推步盈虚。围棋六博摴蒱投壶。亲近比丘尼及诸处女。畜二沙弥常游屠猎酤酒之家。及旃陀罗所住之处。种种贩卖手自作食。受使邻国通致信命。如是之人当知即是魔之眷属非我弟子。以是因缘心共贪生心共贪灭。乃至痴心。共生共灭亦复如是。善男子。以是因缘心性不净亦非不净。是故我说心得解脱。若有不受不畜一切不净之物。为大涅槃受持读诵十二部经书写解说。当知是等真我弟子。不行恶魔波旬境界。即是修习三十七品。以修习故不共贪生不共贪灭是名菩萨修大涅槃微妙经典。具足成就第八功德

大般涅槃经卷第二十五大般涅槃经卷第二十六

        北凉天竺三藏昙无谶译

    光明遍照高贵德王菩萨品第十之六

复次善男子。云何菩萨摩诃萨修大涅槃微妙经典。具足成就第九功德。善男子。菩萨摩诃萨修大涅槃微妙经典。初发五事悉得成就。何等为五。一者信。二者直心。三者戒。四者亲近善友。五者多闻

云何为信。菩萨摩诃萨信于三宝施有果报。信于二谛一乘之道更无异趣。为诸众生速得解脱。诸佛菩萨分别为三。信第一义谛信善方便。是名为信。如是信者。若诸沙门若婆罗门若天魔梵。一切众生所不能坏。因是信故得圣人性。修行布施若多若少。悉得近于大般涅槃不堕生死。戒闻智慧亦复如是。是名为信。虽有是信而亦不见。是为菩萨修大涅槃成就初事

云何直心。菩萨摩诃萨于诸众生作质直心。一切众生若遇因缘则生谄曲。菩萨不尔。何以故。善解诸法悉因缘故。菩萨摩诃萨虽见众生诸恶过咎终不说之。何以故。恐生烦恼。若生烦恼则堕恶趣。如是菩萨若见众生有少善事则赞叹之。云何为善。所谓佛性。赞佛性故令诸众生发阿耨多罗三藐三菩提心

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。如佛所说菩萨摩诃萨赞叹佛性。令无量众生发阿耨多罗三藐三菩提心。是义不然。何以故。如来初开涅槃经时说有三种。一者若有病人。得良医药及瞻病者病则易差。如其不得则不可愈。二者若得不得悉不可差。三者若得不得悉皆可差。一切众生亦复如是。若遇善友诸佛菩萨闻说妙法。则得发于阿耨多罗三藐三菩提心。如其不遇则不能发。所谓须陀洹斯陀含阿那含呵罗汉辟支佛

二者虽遇善友诸佛菩萨闻说妙法亦不能发。若其不遇亦不能发。谓一阐提。三者若遇不遇一切悉能发阿耨多罗三藐三菩提心。所谓菩萨。若言遇与不遇悉发阿耨多罗三藐三菩提心者。如来今者云何说。言因赞佛性。令诸众生发阿耨多罗三藐三菩提心。世尊。若遇善友诸佛菩萨闻说妙法及以不遇。悉不能发阿耨多罗三藐三菩提心。当知是义亦复不然。何以故。如是之人当得阿耨多罗三藐三菩提故。一阐提辈以佛性故。若闻不闻悉亦当得阿耨多罗三藐三菩提故。世尊。如佛所说何等名为一阐提耶。谓断善根。如是之义亦复不然。何以故。不断佛性故。如是佛性理不可断。云何佛说断诸善根。如佛往昔说十二部经。善有二种。一者常。二者无常。常者不断。无常者断。无常可断故堕地狱常不可断何故不遮佛性不断非一阐提。如来何以作如是说言一阐提。世尊。若因佛性发阿耨多罗三藐三菩提心。何故如来广为众生说十二部经。世尊。譬如四河从阿那婆踏多池出。若有天人诸佛世尊。说言是河不入大海当还本源。无有是处。菩提之心亦复如是。有佛性者。若闻不闻若戒非戒若施非施若修不修若智非智。悉皆应得阿耨多罗三藐三菩提。世尊。如优陀延山日从中出至于正南。日若念言我不至西还东方者。无有是处。佛性亦尔。若不闻不戒不施不修不智。不得阿耨多罗三藐三菩提者。无有是处。世尊。诸佛如来说因果性非有非无。如是之义是亦不然。何以故。如其乳中无酪性者则无有酪。尼拘陀子无五丈性者则不能生五丈之质。若佛性中无阿耨多罗三藐三菩提树者。云何能生阿耨多罗三藐三菩提树。以是义故。所说因果非有非无。如是之义云何相应

尔时世尊赞言。善哉善哉。善男子。世有二人甚为希有如优昙花。一者不行恶法。二者有罪能悔。如是之人甚为希有。复有二人。一者作恩。二者念恩。复有二人。一者咨受新法。二者温故不忘。复有二人。一者造新。二者修故。复有二人。一乐闻法。二乐说法。复有二人。一善问难。二善能答。善问难者汝身是也。善能答者谓如来也。善男子。因是善问即得转于无上法轮。能枯十二因缘大树。能度无边生死大河。能与魔王波旬共战。能摧波旬所立胜幢。善男子。如我先说三种病人值遇良医瞻病好药及以不遇病悉得差。是义云何。若得不得谓定寿命。所以者何。是人已于无量世中修三种善。谓上中下。以修如是三种善故得定寿命。如郁单越人寿命千年。有遇病者。若得良医好药瞻病及以不得悉皆得差。何以故。得定命故

善男子。如我所说若有病人得遇良医好药瞻病病得除差。若不遇者则不得差。是义云何。善男子。如是之人寿命不定。命虽不尽有九因缘能夭其寿。何等为九。一者知食不安而反食之。二者多食。三者宿食不消而复更食。四者大小便利不随时节。五者病时不随医教。六者不随瞻病教敕。七者强耐不吐。八者夜行。以夜行故恶鬼打之。九者房室过度。以是缘故。我说病者若遇医药病则可差。若不遇者则不可愈。善男子。如我先说若遇不遇俱不差者。是义云何。有人命尽若遇不遇悉不可差。何以故。以命尽故。以是义故我说病人若遇医药及以不遇悉不得差。众生亦尔。发菩提心者。若遇善友诸佛菩萨咨受深法若不遇之皆悉当成。何以故。以其能发菩提心故。如郁单越人得定寿命。如我所说从须陀洹至辟支佛。若闻善友诸佛菩萨所说深法。则发阿耨多罗三藐三菩提心。若不值遇诸佛菩萨闻说深法。则不能发阿耨多罗三藐三菩提心。如不定命。以九因缘命则中夭。如彼病人值遇医药病则得差。若不遇者病则不差。是故我说遇佛菩萨闻说深法则能发心。若不值遇则不能发

如我先说若遇善友诸佛菩萨闻说深法。若不值遇俱不能发。是义云何。善男子。一阐提辈若遇善友诸佛菩萨闻说深法。及以不遇俱不得离一阐提心。何以故。断善法故。一阐提辈亦得阿耨多罗三藐三菩提。所以者何。若能发于菩提之心则不复名一阐提也。善男子。以何缘故说一阐提得阿耨多罗三藐三菩提。一阐提辈实不能得阿耨多罗三藐三菩提。如命尽者虽遇良医好药瞻病不能得差。何以故。以命尽故

善男子。一阐名信。提名不具。不具信故名一阐提。佛性非信众生非具。以不具故云何可断。一阐名善方便。提名不具。修善方便不具足故名一阐提。佛性非是修善方便。众生非具以不具故。云何可断。一阐名进。提名不具。进不具故名一阐提。佛性非进众生非具。以不具故云何可断。一阐名念。提名不具。念不具故名一阐提。佛性非念众生非具。以不具故云何可断。一阐名定提名不具。定不具故名一阐提。佛性非定众生非具。以不具故云何可断。一阐名慧提名不具。慧不具故名一阐提。佛性非慧众生非具。以不具故云何可断。一阐名无常善。提名不具。以无常善不具足故名一阐提。佛性是常非善非不善。何以故善法要从方便。而得。而是佛性非方便得是故非善。何故复名非不善耶。能得善果故。善果即是阿耨多罗三藐三菩提。又善法者生已得故。而是佛性非生已得是故非善。以断生得诸善法故名一阐提

善男子。如汝所言若一阐提有佛性者。云何不遮地狱之罪。善男子。一阐提中无有佛性。善男子。譬如有王闻箜篌音。其声清妙心即耽着喜乐爱念情无舍离。即告大臣。如是妙音从何处出。大臣答言。如是妙音从箜篌出。王复语言。持是声来。尔时大臣即持箜篌置于王前而作是言。大王。当知此即是声。王语箜篌出声出声。而是箜篌声亦不出。尔时大王即断其弦声亦不出。取其皮木悉皆析裂推求其声了不能得。尔时大王即嗔大臣。云何乃作如是妄语。大臣白王。夫取声者法不如是。应以众缘善巧方便声乃出耳。众生佛性亦复如是无有住处。以善方便故得可见。以可见故得阿耨多罗三藐三菩提。一阐提辈不见佛性。云何能遮三恶道罪。善男子。若一阐提信有佛性。当知是人不至三恶。是亦不名一阐提也。以不自信有佛性故即堕三恶。堕三恶故名一阐提

善男子。如汝所说若乳无酪性不应出酪。尼拘陀子无五丈性。则不应有五丈之质。愚痴之人作如是说。智者终不发如是言。何以故。以无性故。善男子。如其乳中有酪性者。不应复假众缘力也。善男子。如水乳杂卧至一月终不成酪。若以一渧颇求树汁。投之于中即便成酪。若本有酪何故待缘。众生佛性亦复如是。假众缘故则便可见。假众缘故得成阿耨多罗三藐三菩提。若待众缘然后成者即是无性。以无性故能得阿耨多罗三藐三菩提。善男子。以是义故。菩萨摩诃萨常赞人善不讼彼缺名质直心。复次善男子。云何菩萨质直心也。菩萨摩诃萨常不犯恶设有过失即时忏悔。于师同学终不覆藏。惭愧自责不敢复作。于轻罪中生极重想。若人诘问答言实犯。复问是罪为好不好。答言不好。复问是罪为善不善。答言不善。复问是罪是善果耶不善果耶。答言是罪实非善果。又问是罪谁之所造。将非诸佛法僧所作。答言非佛法僧我所作也。乃是烦恼之所构集。以直心故信有佛性。信佛性故则不得名一阐提也。以直心故名佛弟子。若受众生衣服饮食卧具医药种各千万不足为多。是名菩萨质直心也。云何菩萨修治于戒。菩萨摩诃萨受持禁戒。不为生天不为恐怖。乃至不受狗戒鸡戒牛戒雉戒。不作破戒不作缺戒。不作瑕戒不作杂戒。不作声闻戒。受持菩萨摩诃萨戒尸罗波罗蜜戒。得具足戒不生憍慢。是名菩萨修大涅槃具足第三戒

云何菩萨亲近善友。菩萨摩诃萨常为众生说于善道不说恶道。说于恶道非善果报。善男子。我身即是一切众生真善知识。是故能断富伽罗婆罗门所有邪见。善男子。若有众生亲近我者。虽有生于地狱因缘即得生天。如须那刹多等应堕地狱。以见我故即得断除地狱因缘生于色天。虽有舍利弗目犍连等不名众生真善知识。何以故。生一阐提心因缘故。善男子。我昔住于波罗奈国时。舍利弗教二弟子。一观白骨。一令数息。经历多年各不得定。以是因缘即生邪见。言无涅槃无漏之法。设其有者我应得之。何以故。我能善持所受戒故。我于尔时见是比丘生此邪心。唤舍利弗而呵责之汝不善教。云何乃为是二弟子颠倒说法。汝二弟子其性各异。一主浣衣一是金师。金师之子应教数息。浣衣之人应教骨观。以汝错教令是二人生于恶邪。我于尔时为是二人如应说法。二人闻已得阿罗汉果。是故我为一切众生真善知识。非舍利弗目犍连等。若使众生有极重结得遇我者。我以方便即为断之。如我弟难陀有极重欲。我以种种善巧方便而为除断。鸯掘魔罗有重嗔恚。以见我故嗔恚即息。阿阇世王有重愚痴。以见我故痴心即灭。如婆熙伽长者于无量劫修习成就极重烦恼。以见我故即便断灭。设有弊恶厮下之人亲近于我作弟子者。以是因缘一切人天恭敬爱念。尸利鞠多邪见炽盛因见我故邪见即灭。因见我故断地狱因作生天缘如气嘘旃陀罗。命垂终时因见我故还得寿命。如憍尸迦。狂心错乱因见我故还得本心如瘦瞿昙弥。屠家之子常修恶业以见我故即便舍离。如阐提比丘。因见我故宁舍身命不毁禁戒。如草系比丘。以是义故。阿难。比丘说半梵行名善知识。我言不尔具足梵行乃名善知识。是名菩萨修大涅槃具足第四亲善知识

云何菩萨具足多闻。菩萨摩诃萨为大涅槃十二部经书写读诵分别解说。是名菩萨具足多闻。除十一部惟毗佛略受持读诵书写解说亦名菩萨具足多闻。除十二部经若能受持是大涅槃微妙经典。书写读诵分别解说。是名菩萨具足多闻。除是经典具足全体。若能受持一四句偈。复除是偈若能受持如来常住性无变易。是名菩萨具足多闻。复除是事若知如来常不说法。亦名菩萨具足多闻。何以故。法无性故。如来虽说一切诸法常无所说。是名菩萨修大涅槃。成就第五具足多闻

善男子。若有善男子善女人。为大涅槃具足成就如是五事。难作能作难忍能忍难施能施。云何菩萨难作能作。若闻有人食一胡麻得阿耨多罗三藐三菩提者。信是语故乃至无量阿僧祇劫常食一麻。若闻入火得阿耨多罗三藐三菩提者。于无量劫在阿鼻地狱入炽火聚。是名菩萨难作能作。云何菩萨难忍能忍。若闻受苦手杖刀石斫打因缘得大涅槃。即于无量阿僧祇劫。身具受之不以为苦。是名菩萨难忍能忍。云何菩萨难施能施。若闻能以国城妻子头目髓脑惠施于人得阿耨多罗三藐三菩提者。即于无量阿僧祇劫。以其所有国城妻子头目髓脑惠施于人。是名菩萨难施能施。菩萨虽复难作能作。终不念言是我所作。难施能施。亦复如是。善男子。譬如父母惟有一子爱之甚重。以好衣裳上妙甘膳。随时将养令无所乏。其子若于是父母所。生轻慢心恶口骂辱。父母爱故不生嗔恨。亦不念言我与是儿衣服饮食。菩萨摩诃萨。亦复如是。视诸众生犹如一子。若子遇病父母亦病。为求医药勤而疗之。病既差已终不生念我为是儿疗治病苦。菩萨亦尔。见诸众生遇烦恼病。生爱念心而为说法。以闻法故诸烦恼断。烦恼断已终不念言。我为众生断诸烦恼。若生此念终不得成阿耨多罗三藐三菩提。惟作是念无一众生我为说法令断烦恼。菩萨摩诃萨于诸众生不嗔不喜。何以故。善能修习空三昧故。菩萨若修空三昧者。当于谁所生嗔生喜。善男子。譬如山林猛火所焚若人斫伐或为水漂。而是林木当于谁所生嗔生喜。菩萨摩诃萨。亦复如是。于诸众生无嗔无喜。何以故。修空三昧故

尔时光明遍照高贵德王菩萨摩诃萨白佛言。世尊。一切诸法性自空耶。空空故空若性自空者。不应修空然后见空。云何如来言以修空而见空也。若性自不空。虽复修空不能令空。善男子。一切诸法性本自空。何以故。一切法性不可得故。善男子。色性不可得。云何色性。色性者。非地水火风不离地水火风。非青黄赤白不离青黄赤白。非有非无。云何当言色有自性。以性不可得故说为空。一切诸法。亦复如是。以相似相续故。凡夫见已说言诸法性不空寂。菩萨摩诃萨具足五事。是故见法性本空寂。善男子。若有沙门及婆罗门。见一切法性不空者。当知。是人非是沙门非婆罗门。不得修习般若婆罗蜜。不得入于大般涅槃。不得现见诸佛菩萨。是魔眷属。善男子。一切诸法性本自空。亦因菩萨修习空故见诸法空。善男子。如一切法性无常故灭能灭之。若非无常灭不能灭。有为之法有生相故生能生之。有灭相故灭能灭之。一切诸法有苦相故苦能令苦。善男子。如盐性碱能碱异物。石蜜性甘能甘异物。苦酒性酢能酢异物。姜本性辛能辛异物。诃梨勒苦能苦异物。庵罗果醈能醈异物。毒性能害令异物害。甘露之性令人不死。若合异物亦能不死。菩萨修空。亦复如是。以修空故见一切法性皆空寂

光明遍照高贵德王菩萨复作是言。世尊。若盐能令非碱作碱。修空三昧若如是者。当知。是定非善非妙其性颠倒。若空三昧惟见空者定是无法为何所见

善男子。是空三昧见不空法能令空寂然非颠倒。如盐非碱作碱。是空三昧亦复如是。不空作空。善男子。贪是有性非是空性。贪若是空众生不应以是因缘堕于地狱。若堕地狱云何贪性当是空耶。善男子。色性是有。何等色性所谓颠倒。以颠倒故众生生贪。若是色性非颠倒者。云何能令众生生贪。以生贪故。当知。色性非不是有。以是义故。修空三昧非颠倒也。善男子。一切凡夫若见女人即生女相。菩萨不尔。虽见女人不生女相。以不生相贪则不生。贪不生故非颠倒也。以世间人见有女相故。菩萨随说言有女人。若见男时说言是女则是颠倒。是故我为阇提说言。汝婆罗门若以昼为夜是即颠倒。以夜为昼是亦颠倒。昼为昼相夜为夜相云何颠倒。善男子。一切菩萨住九地者见法有性。以是见故不见佛性。若见佛性则不复见一切法性。以修如是空三昧故不见法性。以不见故则见佛性。诸佛菩萨有二种说。一者有性。二者无性。为众生故说有法性。为诸贤圣说无法性。为不空者见法空故修空三昧令得见空。无法性者亦修空故空。以是义故修空见空善男子。汝言见空空是无法为何所见者。善男子。如是如是。菩萨摩诃萨实无所见。无所见者即无所有。无所有者即一切法。菩萨摩诃萨修大涅槃。于一切法悉无所见。若有见者不见佛性。不能修习般若波罗蜜。不得入于大般涅槃。是故菩萨见一切法性无所有。善男子。菩萨不但因见三昧而见空也。般若波罗蜜亦空。禅波罗蜜亦空。毗梨耶波罗蜜亦空。羼提波罗蜜亦空。尸波罗蜜亦空。檀波罗蜜亦空。色亦空眼亦空识亦空。如来亦空大般涅槃亦空。是故菩萨见一切法皆悉是空。是故我在迦毗罗城告阿难言。汝莫愁恼悲泣啼哭。阿难即言。如来世尊。我今眷属悉皆死丧。云何当得不愁啼耶。如来与我俱生此城。俱同释种亲戚眷。属云何如来独不愁恼光颜更显。善男子。我复告言。阿难汝见迦毗真实而有。我见空寂悉无所有。汝见释种悉是亲戚。我修空故悉无所见。以是因缘汝生愁苦。我身容颜益更光显。诸佛菩萨修习如是空三昧故不生愁恼。是名菩萨修大涅槃微妙经典。成就具足第九功德善男子。云何菩萨修大涅槃微妙经典。具足最后第十功德。善男子。菩萨修习三十七品。入大涅槃常乐我净。为诸众生分别解说大涅槃经显示佛性。若须陀洹斯陀含阿那含阿罗汉辟支佛菩萨。信是语者悉得入于大般涅槃。若不信者轮回生死

尔时光明遍照高贵德王菩萨白佛言。世尊。何等众生于是经中不生恭敬。善男子。我涅槃后有声闻弟子。愚痴破戒喜生斗诤舍十二部经。读诵种种外道典籍文颂手笔。受畜一切不净之物言是佛听。如是之人以好栴檀贸易凡木。以金易鋀石。银易白腊。绢易氀褐。以甘露味易于恶毒。云何栴檀贸易凡木。如我弟子为供养故。向诸白衣演说经法。白衣情逸不喜听闻。白衣处高比丘在下。兼以种种肴膳饮食而供给之。犹不肯听。是名栴檀贸易凡木。云何以金贸易鋀石。鋀石喻色声香味触。金喻于戒。我诸弟子以色因缘破所受戒。是名以金贸易鋀石。云何以银易于白腊。银喻十善腊喻十恶。我诸弟子放舍十善行十恶法。是名以银贸易白腊。云何以绢贸易氀褐。氀褐喻于无惭无愧。绢喻惭愧。我诸弟子放舍惭愧习无惭愧。是名以绢贸易氀褐。云何甘露贸易毒药。毒药喻于种种利养。甘露喻于诸无漏法。我诸弟子为利养故。向诸白衣若自赞誉言得无漏。是名甘露贸易毒药

以如是等恶比丘故是大涅槃微妙经典广行流布于阎浮提。当是时也有诸弟子。受持读诵书写是经广说流布。当为如是诸恶比丘之所杀害。时恶比丘共相聚集立严峻制。若有受持大涅槃经。书写读诵分别说者。一切。不得共住共坐谈论语言。何以故涅槃经者非佛所说邪见所造。邪见之人即是六师。六师经典非佛经典。所以者何。一切诸佛悉说诸法无常无我无乐无净。若言诸法常乐我净。云何当是佛所说经诸佛菩萨听诸比丘畜种种物。六师所说不听弟子畜一切物。如是之义。云何当是佛之所说。诸佛菩萨不制弟子断牛五味及以食肉。六师不听食五种盐五种牛味及以脂血。若断是者。云何当是佛之正典。诸佛菩萨说于三乘。而是经中纯说一乘。谓大涅槃。如此之言云何当是佛之正典。诸佛毕竟入于涅槃。是经言佛常乐我净不入涅槃。是经不在十二部数。即是魔说非是佛说。善男子。如是之人虽我弟子。不能信顺是涅槃经。善男子。当尔之时若有众生信此经典乃至半句。当知。是人真我弟子。因如是信即见佛性入于涅槃

尔时光明遍照高贵德王菩萨白佛言。世尊。善哉善哉。如来今日善能开示大涅槃经。世尊。我因是事即得悟解大涅槃经一句半句。以解一句至半句故见少佛性。如佛所说我亦当得入大涅槃。是名菩萨修大涅槃微妙经典。具足成就第十功德

大般涅槃经卷第二十六大般涅槃经卷第二十七

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之一

尔时佛告一切大众。诸善男子。汝等。若疑有佛无佛有法无法有僧无僧。有苦无苦有集无集有灭无灭有道无道。有实无实有我无我有乐无乐有净无净有常无常。有乘无乘有性无性。有众生无众生。有有无有有真无真。有因无因有果无果。有作无作有业无业有报无报者。今恣汝所问吾当为汝分别解说。善男子。我实不见若天若人若魔若梵若沙门若婆罗门。有来问我不能答者

尔时会中有一菩萨名师子吼。即从座起敛容整服前礼佛足。长跪叉手白佛言。世尊。我适欲问。如来大慈复垂听许

尔时佛告诸大众言。诸善男子。汝等今当于是菩萨深生恭敬尊重赞叹。应以种种香花伎乐璎珞幡盖衣服饮食卧具医药房舍殿堂。而供养之迎来送去。所以者何。是人已于过去诸佛深种善根福德成就。是故今于我前欲师子吼

善男子。如师子王自知身力。牙爪锋芒四足踞地安住岩穴振尾出声。若有能具如是诸相。当知。是则能师子吼。真师子王晨朝出穴频申欠呿。四向顾望发声震吼为十一事。何等十一。一为欲坏实非师子诈作师子故。二为欲试自身力故。三为欲令住处净故。四为诸子知处所故。五为群辈无怖心故。六为眠者得觉寤故。七为一切放逸诸兽不放逸故。八为诸兽来依附故。九为欲调大香象故。十为教告诸子息故。十一为欲庄严自眷属故。一切禽兽闻师子吼。水性之属潜没深渊。陆行之类藏伏窟穴。飞者堕落诸大香象怖走失粪。诸善男子。如彼野干虽逐师子至于百年。终不能作师子吼也。若师子子始满三年。则能哮吼如师子王

善男子。如来正觉智慧牙爪四如意足。六波罗蜜满足之身。十力雄猛大悲为尾。安住四禅清净窟宅。为诸众生而师子吼摧破魔军。示众十力开佛行处。为诸邪见作归依所。安抚生死怖畏之众。觉寤无明睡眠众生。行恶法者为作悔心。开示邪见一切众生令知六师非师子吼故。破富兰那等憍慢心故。为令二乘生悔心故。为教五住诸菩萨等生大力心故。为令正见四部之众于彼邪见四部徒众不生怖畏故。从圣行梵行天行窟宅频申而出。为欲令彼诸众生等破憍慢故欠呿。为令诸众生等生善法故四向顾望。为令众生得四无碍故四足踞地。为令众生具足安住尸波罗蜜故。故师子吼。师子吼者名决定说。一切众生悉有佛性。如来常住无有变易。善男子。声闻缘觉虽复随逐如来世尊无量百千阿僧祇劫。而亦不能作师子吼。十住菩萨若能修行是三行处。当知。是则能师子吼。诸善男子。是师子吼菩萨摩诃萨。今欲如是大师子吼。是故汝等应当深心供养恭敬尊重赞叹

尔时世尊告师子吼菩萨摩诃萨言。善男子。汝若欲问今可随意。师子吼菩萨摩诃萨白佛言。世尊。云何为佛性。以何义故。名为佛性。何故复名常乐我净。若一切众生有佛性者。何故不见一切众生所有佛性。十住菩萨住何等法不了了见。佛住何等法而了了见。十住菩萨以何等眼不了了见。佛以何眼而了了见

佛言。善男子。善哉善哉。若有人能为法咨启。则为具足二种庄严。一者智慧。二者福德。若有菩萨具足如是二庄严者则知佛性。亦复解知名为佛性。乃至能知十住菩萨以何眼见诸佛世尊以何眼见

师子吼菩萨言。世尊。云何名为智慧庄严。云何名为福德庄严。善男子。慧庄严者。谓从一地乃至十地。是名慧庄严。福德庄严者。谓檀波罗蜜乃至般若非般若波罗蜜。复次善男子。慧庄严者。所谓诸佛菩萨。福德庄严者。谓声闻缘觉九住菩萨

复次善男子。福德庄严者。有为有漏有有有果报有碍非常是凡夫法。慧庄严者无为无漏。无无无果报无碍常住。善男子。汝今具足是二庄严。是故能问甚深妙义。我亦具足是二庄严能答是义

师子吼菩萨摩诃萨言。世尊。若有菩萨具足如是二庄严者。则不应问一种二种。云何世尊。说言能答一种二种。所以者何。一切诸法无一二种。一种二种者是凡夫相

佛言。善男子。若有菩萨无二种庄严。则不能知一种二种。若有菩萨具二庄严。则能解知一种二种。若言诸法无一二者。是义不然。何以故。若无一二云何得说一切诸法无一无二。善男子。若言一二是凡夫相。是乃名为十住菩萨。非凡夫也。何以故。一者名为涅槃。二者名为生死。何故一者名为涅槃。以其常故。何故二者名为生死。爱无明故。常涅槃者。非凡夫相生死。二者亦非凡夫相。以是义故。具二庄严者能问能答

善男子。汝问云何为佛性者。谛听谛听。吾当为汝分别解说。善男子。佛性者名第一义空。第一义空名为智慧。所言空者不见空与不空。智者见空及与不空。常与无常苦之与乐我与无我。空者一切生死。不空者谓大涅槃。乃至无我者即是生死。我者谓大涅槃。见一切空不见不空不名中道。乃至见一切无我。不见我者不名中道。中道者名为佛性。以是义故。佛性常恒无有变易。无明覆故令诸众生不能得见。声闻缘觉见一切空不见不空。乃至见一切无我不见于我。以是义故。不得第一义空。不得第一义空故不行中道。无中道故不见佛性。善男子。不见中道者凡有三种。一者定乐行。二者定苦行。三者苦乐行。定乐行者。所谓菩萨摩诃萨怜愍一切诸众生故。虽复处在阿鼻地狱如三禅乐。定苦行者。谓诸凡夫。苦乐行者。谓声闻缘觉。声闻缘觉行于苦乐作中道想。以是义故。虽有佛性而不能见。如汝所问以何义故。名佛性者。善男子。佛性者。即是一切诸佛阿耨多罗三藐三菩提中道种子。复次善男子。道有三种。谓下上中。下者梵天无常谬见是常。上者生死无常谬见是常。三宝是常横计无常。何故名上。能得最上阿耨多罗三藐三菩提故。中者名第一义空。无常见无常常见于常。第一义空不名为下。何以故。一切凡夫所不得故。不名为上。何以故。即是下故。诸佛菩萨所修之道不上不下。以是义故。名为中道

复次善男子。生死本际凡有二种。一者无明。二者有爱。是二中间则有生老病死之苦。是名中道。如是中道能破生死故名为中。以是义故。中道之法名为佛性。是故佛性常乐我净。以诸众生不能见故。无常无乐无我无净。佛性实非无常无乐无我无净。善男子。譬如贫人家有宝藏是人不见。以不见故无常无乐无我无净。有善知识而语之言。汝舍宅中有金宝藏。何故如是贫穷困苦无常无乐无我无净。即以方便令彼得见以得见故是人即得常乐我净。佛性亦尔。众生不见。以不见故无常无乐无我无净。有善知识诸佛菩萨。以方便力种种教告令彼得见。以得见故众生即得常乐我净

复次善男子。众生起见凡有二种。一者常见。二者断见。如是二见不名中道。无常无断乃名中道。无常无断即是观照十二因缘智。如是观智是名佛性。二乘之人虽观因缘。犹亦不得名为佛性。佛性虽常以诸众生无明覆故不能得见。又未能渡十二因缘河犹如兔马。何以故。不见佛性故。善男子。是观十二因缘智慧。即是阿耨多罗三藐三菩提种子。以是义故。十二因缘名为佛性。善男子。譬如胡瓜名为热病。何以故。能为热病作因缘故。十二因缘亦复如是。善男子。佛性者。有因有因因有果有果果。有因者即十二因缘。因因者即是智慧。有果者即是阿耨多罗三藐三菩提。果果者即是无上大般涅槃。善男子。譬如无明为因诸行为果行因识果。以是义故。彼无明体亦因亦因因。识亦果亦果。果佛性亦尔。善男子。以是义故。十二因缘不出不灭不常不断非一非二。不来不去非因非果。善男子。是因非果如佛性。是果非因如大涅槃。是因是果如十二因缘所生之法。非因非果名为佛性。非因果故常恒无变。以是义故。我经中说十二因缘其义甚深。无知无见不可思惟。乃是诸佛菩萨境界。非诸声闻缘觉所及。以何义故甚深甚深。众生业行不常不断而得果报。虽念念灭而无所失。虽无作者而有作业。虽无受者而有果报。受者虽灭果不败亡。无有虑知和合而。有一切众生虽与十二因缘共行而不见知。不见知故无有终始。十住菩萨惟见其终不见其始。诸佛世尊见始见终。以是义故。诸佛了了得见佛性。善男子。一切众生不能见于十二因缘。是故轮转。善男子。如蚕作茧自生自死。一切众生亦复如是。不见佛性故自造结业流转生死犹如拍毬。善男子。是故我于诸经中说。若有人见十二缘者即是见法。见法者即是见佛。佛者即是佛性。何以故。一切诸佛以此为性。善男子。观十二缘智凡有四种。一者下。二者中。三者上。四者上上。下智观者不见佛性。以不见故得声闻道。中智观者不见佛性。以不见故得缘觉道。上智观者见不了了。不了了故住十住地。上上智观者见了了故。得阿耨多罗三藐三菩提道。以是义故。十二因缘名为佛性。佛性者即第一义空。第一义空名为中道。中道者即名为佛。佛者名为涅槃。尔时师子吼菩萨摩诃萨白佛言。世尊。若佛与佛性无差别者。一切众生何用修道。佛言。善男子。如汝所问是义不然。佛与佛性虽无差别。然诸众生悉未具足。善男子。譬如有人恶心害母。害已生悔三业虽善。是人故名地狱人也。何以故。是人定当堕地狱故。是人虽无地狱阴界诸入。犹故得名为地狱人。善男子。是故我于诸经中说。若见有人修行善者名见天人。修行恶者名见地狱。何以故。定受报故。善男子。一切众生定得阿耨多罗三藐三菩提故。是故我说一切众生悉有佛性。一切众生真实未有三十二相八十种好。以是义故。我于此经而说是偈

  本有今无　　本无今有　　三世有法
  无有是处

善男子。有者凡有三种。一未来有。二现在有。三过去有。一切众生未来之世。当有阿耨多罗三藐三菩提是名佛性。一切众生现在悉有烦恼诸结。是故现在无有三十二相八十种好。一切众生过去之世有断烦恼。是故现在得见佛性。以是义故。我常宣说一切众生悉有佛性。乃至一阐提等亦有佛性。一阐提等无有善法。佛性亦善以未来有故。一阐提等悉有佛性。何以故。一阐提等定当得成阿耨多罗三藐三菩提故。善男子。譬如有人家有乳酪。有人问言。汝有苏耶。答言。我有酪实非苏。以巧方便定当得故。故言有苏。众生亦尔。悉皆有心。凡有心者定当得成阿耨多罗三藐三菩提。以是义故。我常宣说一切众生悉有佛性

善男子。毕竟有二种。一者庄严毕竟。二者究竟毕竟。一者世间毕竟。二者出世毕竟。庄严毕竟者。六波罗蜜。究竟毕竟者。一切众生所得一乘。一乘者名为佛性。以是义故。我说一切众生悉有佛性。一切众生悉有一乘。以无明覆故不能得见。善男子。如郁单越三十三天。果报覆故此间众生不能得见。佛性亦尔。诸结覆故众生不见。复次善男子。佛性者即首楞严三昧性如醍醐。即是一切诸佛之母。以首楞严三昧力故。而令诸佛常乐我净。一切众生悉有首楞严三昧。以不修行故不得见。是故不能得成阿耨多罗三藐三菩提。善男子。首楞严三昧者。有五种名。一者首楞严三昧。二者般若波罗蜜。三者金刚三昧。四者师子吼三昧。五者佛性。随其所作处处得名。善男子。如一三昧得种种名。如禅名四禅。根名定根。力名定力。觉名定觉。正名正定。八大人觉名为定觉。首楞严定亦复如是。善男子。一切众生具足三定。谓上中下。上者谓佛性也。以是故言一切众生悉有佛性。中者一切众生具足初禅。有因缘时则能修习。若无因缘则不能修。因缘二种。一谓火灾。二谓破欲界结。以是故言一切众生悉具中定。下定者十大地中心数定也。以是故言一切众生悉具下定。一切众生悉有佛性。烦恼覆故不能得见。十住菩萨虽见一乘。不知如来是常住法。以是故言十地菩萨虽见佛性而不明了。善男子。首楞者。名一切毕竟。严者名坚。一切毕竟而得坚固名首楞严。以是故言首楞严定名为佛性

善男子。我于一时住尼连禅河告阿难言。我今欲洗汝可取衣及以澡豆。我既入水一切飞鸟水陆之属悉来观我。尔时复有五百梵志来在河边。因到我所各相谓言。云何而得金刚之身。若使瞿昙不说断见。我当从其启受齐法。善男子。我于尔时以他心智。知是梵志心之所念。告梵志言。云何谓我说于断见。彼梵志言。瞿昙。先于处处经中说诸众生悉无有我。既言无我。云何而言非断见耶。若无我者持戒者谁。破戒者谁。佛言。我亦不说一切众生悉无有我。我常宣说一切众生悉有佛性。佛性者岂非我耶。以是义故。我不说断见。一切众生不见佛性。故无常无我无乐无净。如是则名说断见也。时诸梵志闻说佛性即是我故。即发阿耨多罗三藐三菩提心。寻时出家修菩提道。一切飞鸟水陆之属亦发无上菩提之心。既发心已寻得舍身。善男子。是佛性者实非我也。为众生故说名为我

善男子。如来有因缘故说无我为我。真实无我虽作是说无有虚妄。善男子。有因缘故说我为无我。而实有我为世界故。虽说无我而无虚妄。佛性无我如来说我以其常故。如来是我而说无我得自在故

尔时师子吼菩萨摩诃萨白佛言。世尊。若一切众生悉有佛性。如金刚力士者。以何义故。一切众生不能得见。佛言。善男子。譬如色法虽有青黄赤白之异长短质像盲者不见。虽复不见。亦不得言无青黄赤白长短质像。何以故。盲虽不见有目见故。佛性亦尔。一切众生虽不能见。十住菩萨见少分故。如来全见。十住菩萨所见佛性如夜见色。如来所见如昼见色。善男子。譬如瞎者见色不了。有善良医而为治目。以药力故得了了见。十住菩萨亦复如是。虽见佛性不能明了。以首楞严三昧力故能得明了。善男子。若有人见一切诸法无常无我无乐无净。见非一切法无常无我无乐无净。如是之人不见佛性。一切者名为生死。非一切者名为三宝。声闻缘觉见一切法无常无我无乐无净。非一切法亦见无常无我无乐无净。以是义故。不见佛性。十住菩萨见一切法无常无我无乐无净。非一切法分见常乐我净。以是义故。十分之中得见一分。诸佛世尊见一切法无常无我无乐无净。非一切法见常乐我净。以是义故。见于佛性如观掌中阿摩勒果。以是义故。首楞严定名为毕竟。善男子。譬如初月虽不可见不得言无。佛性亦尔。一切凡夫虽不得见。亦不得言无佛性也

善男子。佛性者。所谓十力四无所畏大悲三念处。一切众生悉有三种破烦恼故。然后得见一阐提等。破一阐提然后能得十力四无所畏大悲三念处。以是义故。我常宣说一切众生悉有佛性

善男子。十二因缘一切众生等共有之亦内亦外。何等十二。过去烦恼名为无明。过去业者则名为行。现在世中初始受胎是名为识。入胎五分四根未具名为名色。具足四根未名触时是名六入。未别苦乐是名为触。染习一爱是名为受。习近五欲是名为爱。内外贪求是名为取。为内外事起身口意业是名为有。现在世识名未来生。现在名色六入触受名未来世老病死也。是名十二因缘。善男子。一切众生虽有如是十二因缘。或有未具。如歌罗逻时死则无十二。从生乃至老死得具十二。色界众生无三种受三种触三种爱。无有老病亦得名为具足十二。无色众生无色乃至无有老病。亦得名为具足十二。以定得故故名众生平等具有十二因缘。善男子。佛性亦尔。一切众生定当得成阿耨多罗三藐三菩提故。是故我说一切众生悉有佛性。善男子。雪山有草名为忍辱。牛若食者则出醍醐。更有异草。牛若食者则无醍醐。虽无醍醐不可说言雪山之中无忍辱草。佛性亦尔。雪山者名为如来。忍辱草者名大涅槃。异草者十二部经。众生若能听受咨启大般涅槃则见佛性。十二部中虽不闻有。不可说言无佛性也。善男子。佛性者。亦色非色非色非非色。亦相非相非相非非相。亦一非一非一非非一。非常非断非非常非非断。亦有亦无非有非无。亦尽非尽非尽非非尽。亦因亦果非因非果。亦义非义非义非非义。亦字非字非字非非字。云何为色。金刚身故。云何非色。十八不共非色法故。云何非色非非色。色非色无定相故云何为相三十二相故。云何非相。一切众生相不现故。云何非相非非相。相非相不决定故。云何为一。一切众生悉一乘故。云何非一。说三乘故。云何非一非非一。无数法故。云何非常。从缘见故。云何非断。离断见故。云何非非常非非断。无终始故。云何为有。一切众生悉皆有故。云何为无。从善方便而得见故。云何非有非无。虚空性故。云何名尽。得首楞严三昧故。云何非尽。以其常故。云何非尽非非尽。一切尽相断故。云何为因。以了因故云何为果。果决定故。云何非因非果。以其常故。云何为义。悉能摄取义无碍故。云何非义。不可说故。云何非义非非义。毕竟空故。云何为字。有名称故。云何非字。名无名故。云何非字非非字。断一切字故。云何非苦非乐。断一切受故。云何非我。未能具得八自在故。云何非非我。以其常故。云何非我非非我。不作不受故。云何为空。第一义空故。云何非空。以其常故。云何非空非非空。能为善法作种子故。善男子。若有人能思惟解了大涅槃经如是之义。当知。是人则见佛性。佛性者不可思议。乃是诸佛如来境界。非诸声闻缘觉所知。善男子。佛性者非阴界入。非本无今有。非已有还无。从善因缘众生得见。譬如黑铁入火则赤出冷还黑。而是黑色非内非外因缘故有。佛性亦尔。一切众生烦恼火灭则得闻见。善男子。如种灭已芽则得生。而是芽性非内非外。乃至花果亦复如是。从缘故有。善男子。是大涅槃微妙经典。成就具足无量功德。佛性亦尔。悉是无量无边功德之所成就

尔时师子吼菩萨摩诃萨言。世尊。菩萨具足成就几法。得见佛性而不明了。诸佛世尊成就几法。得了了见。善男子。菩萨具足成就十法虽见佛性而不明了。云何为十。一者少欲。二者知足。三者寂静。四者精进。五者正念。六者正定。七者正慧。八者解脱。九者赞叹解脱。十者以大涅槃教化众生。师子吼菩萨言。世尊。少欲知足有何差别。善男子。少欲者。不求不取。知足者。得少之时心不悔恨。少欲者。少有所欲。知足者。但为法事心不愁恼。善男子。欲者有三。一者恶欲。二者大欲。三者欲欲。恶欲者。若有比丘心生贪欲。欲为一切大众上首。令一切僧随逐我后。令诸四部悉皆供养恭敬赞叹尊重于我。令我先为四众说法。皆令一切信受我语。亦令国王大臣长者皆恭敬我。令我大得衣服饮食卧具医药上妙屋宅。为生死欲。是名恶欲。云何大欲。若有比丘生于欲心。云何当令四部之众。悉皆知我得初住地乃至十住。得阿耨多罗三藐三菩提。得阿罗汉果乃至须陀洹果。我得四禅乃至四无阂智。为于利养。是名大欲。欲欲者。若有比丘。欲生梵天魔天自在天转轮圣王若刹利居士若婆罗门皆得自在。为利养故。是名欲欲。若不为是三种恶欲之所害者。是名少欲。欲者名为二十五爱。无有如是二十五爱。是名少欲。不求未来所欲之事。是名少欲。得而不着是名知足。不求恭敬。是名少欲。得不积聚。是名知足。善男子。亦有少欲不名知足。有知足不名少欲。有亦少欲亦知足。有不知足不少欲。少欲者。谓须陀洹。知足者。谓辟支佛。少欲知足者。谓阿罗汉。不少欲不知足者。所谓菩萨。善男子。少欲知足复有二种。一者善。二者不善。不善者。所谓凡夫善者。圣人菩萨。一切圣人虽得道果不自称说。不称说故心不恼恨。是名知足。善男子。菩萨摩诃萨修习大乘大涅槃经欲见佛性。是故修习少欲知足。云何寂静。寂静有二。一者心静。二者身静。身寂静者。终不造作身三种恶。心寂静者。亦不造作意三种恶。是则名为身心寂静。身寂静者。终不亲近四众。不预四众所有事业。心寂静者。终不修习贪欲嗔恚愚痴。是则名为身心寂静。或有比丘身虽寂静心不寂静。有心寂静身不寂静。有身心寂静。又有身心俱不寂静。身寂静心不寂静者。或有比丘坐禅静处远离四众。心常积集贪欲嗔痴。是名身寂静心不寂静。心寂静身不寂静者。或有比丘亲近四众国王大臣断贪恚痴。是名心寂静身不寂静。身心寂静者。谓佛菩萨。身心不寂静者。谓诸凡夫。何以故。凡夫之人。身心虽静。不能深观无常无乐无我无净。以是义故。凡夫之人不能寂静身口意业。一阐提辈犯四重禁作五逆罪。如是之人亦不得名身心寂静

云何精进。若有比丘欲令身口意业清净。远离一切诸不善业。修习一切诸善业者。是名精进。是勤精进者系念六处。所谓佛法僧戒施天是名正念。具正念者。所得三昧。是名正定。具正定者。观见诸法犹如虚空。是名正慧。具正慧者。远离一切烦恼诸结。是名解脱。得解脱者。为诸众生称美解脱。言是解脱常恒不变。是名赞叹解脱。解脱即是无上大般涅槃。涅槃者即是烦恼诸结火灭。又涅槃者。名为室宅。何以故。能遮烦恼恶风雨故。又涅槃者。名为归依。何以故。能过一切诸怖畏故。又涅槃者。名为洲渚。何以故。四大暴河不能漂故。何等为四。一者欲暴。二者有暴。三者见暴。四者无明暴。是故涅槃名为洲渚。又涅槃者。名毕竟归。何以故。能得一切毕竟乐故。若有菩萨摩诃萨成就具足如是十法。虽见佛性而不明了

复次善男子。出家之人有四种病。是故不得四沙门果。何等四病。谓四恶欲。一为衣欲。二为食欲。三为卧具欲。四为有欲。是名四恶欲。是出家病有四良药能疗是病。谓粪扫衣。能治比丘为衣恶欲。乞食能破为食恶欲。树下能破卧具恶欲。身心寂静能破比丘为有恶欲。以是四药除是四病。是名圣行。如是圣行则得名为少欲知足。寂静者有四种乐。何等为四。一者出家乐。二寂静乐。三永灭乐。四毕竟乐。得是四乐名为寂静。具四精进故名精进。具四念处故名正念。具四禅故故名正定。见四圣实故故名正慧。永断一切烦恼结故故名解脱。呵说一切烦恼过故。故名赞叹解脱。善男子。菩萨摩诃萨安住具足如是十法。虽见佛性而不明了

复次善男子。菩萨摩诃萨闻是经已亲近修习。远离一切世间之事。是名少欲。既出家已不生悔心。是名知足。既知足已近空闲处远离愦闹。是名寂静。不知足者不乐空闲。夫知足者常乐空寂。于空寂处常作是念。一切世间悉谓我得沙门道果。然我今者实未能得。我今云何诳惑于人。作是念已精勤修习沙门道果。是名精进。亲近修习大涅槃者。是名正念。随顺天行是名正定。安住是定正见正知。是名正慧。正见知者能得远离烦恼结缚。是名解脱。十住菩萨为众生故称美涅槃。是则名为赞叹解脱。善男子。菩萨摩诃萨安住具足如是十法。虽见佛性而不明了

复次善男子。夫少欲者。若有比丘住空寂处端坐不卧。或住树下。或在冢间。或在露处。随有草地而坐其上。乞食而食。随得为足。或一坐食不过一食。惟畜三衣粪衣毳衣。是名少欲。既行是事心不生悔。是名知足。修空三昧是名寂静。得四果已于阿耨多罗三藐三菩提心不休息。是名精进。系心思惟如来常恒无有变易。是名正念。修八解脱。是名正定。得四无碍。是名正慧。远离七漏。是名解脱。称美涅槃无有十相。名赞叹解脱。十相者。谓生老病死色声香味触无常。远离十相者名大涅槃。善男子。是名菩萨摩诃萨安住具足如是十法。虽见佛性而不明了

复次善男子。为多欲故亲近国王大臣长者刹利婆罗门毗舍首陀。自称我得须陀洹果乃至阿罗汉果。为利养故行住坐卧乃至大小便利。若见檀越犹行恭敬接引语言。破恶欲者名为少欲。虽未能坏诸结烦恼。而能同于如来行处。是名知足。善男子。如是二法乃是念定近因缘也。常为师宗同学所赞。我亦常于处处经中称美赞叹如是二法。若能具足是二法者。则得近于大涅槃门及五种乐。是名寂静。坚持戒者。名为精进。有惭愧者。名为正念。不见心相。名为正定。不求诸法性相因缘。是名正慧。无有相故烦恼则断。是名解脱。称美如是大涅槃经名赞叹解脱。善男子。是名菩萨摩诃萨安住十法。虽见佛性而不明了。善男子。如汝所言十住菩萨以何眼故。虽见佛性而不了了。诸佛世尊以何眼故。见于佛性而得了了。善男子。慧眼见故不得明了。佛眼见故故得明了。为菩提行故则不了了。若无行故则得了了。住十住故虽见不了。住不住故则得了了。菩萨摩诃萨智慧因故见不了了。诸佛世尊断因果故见则了了。一切觉者名为佛性。十住菩萨不得名为一切觉故。是故虽见而不明了。善男子。见有二种。一者眼见。二者闻见。诸佛世尊眼见佛性。如于掌中观阿摩勒果。十住菩萨闻见佛性故不了了。十住菩萨唯能自知定得阿耨多罗三藐三菩提。而不能知一切众生悉有佛性

善男子。复有眼见。诸佛如来十住菩萨眼见佛性。复有闻见。一切众生乃至九地闻见佛性。菩萨若闻一切众生悉有佛性。心不生信不名闻见。善男子。若有善男子善女人。欲见如来应当修习十二部经。受持读诵书写解说。师子吼菩萨摩诃萨言。世尊。一切众生不能得知如来心相。当云何观而得知耶。善男子。一切众生实不能知如来心相。若欲观察而得知者。有二因缘。一者眼见。二者闻见。若见如来所有身业。当知是则为如来也。是名眼见。若观如来所有口业。当知是则为如来也。是名闻见。若见色貌一切众生无与等者当知是则为如来也。是名眼见。若闻音声微妙最胜不同众生所有音声。当知是则为如来也。是名闻见。若见如来所作神通为为众生为为利养。若为众生不为利养。当知是则为如来也。是名眼见。若观如来以他心智观众生时。为利养说为众生说。若为众生不为利养。当知是则为如来也。是名闻见。云何如来而受是身。何故受身。为谁受身。是名眼见。若观如来云何说法何故说法为谁说法。是名闻见以身恶业加之不嗔。当知是则为如来也。是名眼见。以口恶业加之不恚。当知是则为如来也。是名闻见。若见菩萨初生之时。于十方面各行七步。摩尼跋陀富那跋陀鬼神大将。执持幡盖。震动无量无边世界。金光晃曜弥满虚空。难陀龙王及跋难陀以神通力浴菩萨身。诸天形像承迎礼拜。阿私陀仙合掌恭敬。盛年舍欲如弃涕唾。不为世乐之所迷惑。出家修道乐于闲寂。为破邪见六年苦行。于诸众生平等无二。心常在定初无散乱。相好严丽庄饰其身。所游之处丘墟皆平。衣服离身四寸不堕。行时直视不顾左右。所食之物物无完过。坐起之处草不动乱。为调众生故往说法。心无憍慢。是名眼见。若闻菩萨行七步已唱如是言。我今此身最是后边。阿私陀仙合掌而言。大王当知。悉达太子。定当得成阿耨多罗三藐三菩提。终不在家作转轮王。何以故。相明了故。转轮圣王相不明了。悉达太子身相炳着。是故必得阿耨多罗三藐三菩提。见老病死复作是言。一切众生甚可怜愍。常与如是生老病死共相随逐。而不能观常行于苦。我当断之。从阿罗逻五通仙人受无想定。既成就已后说其非。从郁陀伽仙受非有想非无想定。既成就已说非涅槃是生死法。六年苦行无所克获。即作是言。修是苦行空无所得。若是实者我应得之。以虚妄故我无所得。是名邪术非正道也。既成道已梵天劝请。惟愿如来当为众生广开甘露说无上法。佛言。梵王。一切众生常为烦恼之所障覆。不能受我正法之言。梵王复言。世尊。一切众生凡有三种。所谓利根中根钝根。利根能受。惟愿为说。佛言。梵王。谛听谛听。我今当为一切众生开甘露门。即于波罗奈国转正法轮宣说中道。一切众生不破诸结非不能破。非破非不破。故名中道。不度众生非不能度。是名中道。非一切成亦非不成。是名中道。凡有所说不自言师不言弟子。是名中道。说不为利非不得果。是名中道。正语实语时语真语。言不虚发微妙第一。如是等法。是名闻见。善男子。如来心相实不可见。若有善男子善女人。欲见如来应当依是二种因缘

大般涅槃经卷第二十七大般涅槃经卷第二十八

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之二

尔时师子吼菩萨摩诃萨白佛言。世尊。如先所说庵罗果喻四种人等。有人行细心不正实。有人心细行不正实。有人心细行亦正实。有人心不细行不正实。是初二种云何可知。如佛所说。虽依是二不可得知

佛言。善哉善哉。善男子。庵罗果喻二种人等实难可知。以难知故我经中说。当与共住。住若不知。当与久处。久处不知。当以智慧。智若不知。当深观察。以观察故。则知持戒及以破戒。善男子。具是四事共住久处智慧观察。然后得知持戒破戒。善男子。戒有二种。持戒亦二。一究竟戒。二不究竟。有人以因缘故受持禁戒。智者当观是人持戒。为为利养为究竟持。善男子。如来戒者无有因缘。是故得名为究竟戒。以是义故。菩萨虽为诸恶众生之所伤害不生恚碍。是故如来得名成就毕竟持戒究竟持戒。善男子。我昔一时与舍利弗及五百弟子。俱共止住摩伽陀国瞻婆大城。时有猎师追逐一鸽。是鸽惶怖至舍利弗影。犹故战栗如芭蕉树至我影中身心安隐恐怖得除。是故当知如来世尊毕竟持戒。乃至身影犹有是力。善男子。不究竟戒尚不能得声闻缘觉。何况能得阿耨多罗三藐三菩提。复有二种。一为利养。二为正法。为利养故受持禁戒当知是戒不见佛性及以如来。虽闻佛性及如来名。犹不得名为闻见也。若为正法受持禁戒。当知是戒能见佛性及以如来。是名眼见。亦名闻见。复有二种。一者根深难拔。二者根浅易动。若能修习空无相愿。是名根深难拔。若不修习是三三昧。虽复修习为二十五有。是名根浅易动。复有二种。一为自身。二为众生。为众生者能见佛性及以如来。持戒之人复有二种。一者性自能持。二者须他教敕。若受戒已经无量世初不漏失。或值恶国遇恶知识恶时恶世。闻邪恶法邪见同止。尔时虽无受戒之法。修持如本无所毁犯。是名性自能持。若遇师僧白四羯磨然后得戒。虽得戒已要凭和上诸师同学善友诲喻乃知进止。听法说法备诸威仪。是名须他教敕。善男子。性能持者。眼见佛性及以如来。亦名闻见。戒复有二。一声闻戒。二菩萨戒。从初发心乃至得成阿耨多罗三藐三菩提。是名菩萨戒。若观白骨乃至证得阿罗汉果。是名声闻戒。若有受持声闻戒者。当知是人不见佛性及以如来。若有受持菩萨戒者。当知是人得阿耨多罗三藐三菩提。能见佛性如来涅槃。师子吼菩萨言。世尊。何因缘故受持禁戒。佛言。善男子。为心不悔故。何故不悔。为受乐故。何故受乐。为远离故。何故远离。为安隐故。何故安隐。为禅定故。何故禅定。为实知见故。何故为实知见。为见生死诸过患故。何故为见于生死过患。为心不贪着故。何故为心不贪着。为得解脱故。何故为得解脱。为得无上大涅槃故。何故为得大般涅槃。为得常乐我净法故。何故为得常乐我净。为得不生不灭故。何故为得不生不灭。为见佛性故。是故菩萨性自能持究竟净戒。善男子。持戒比丘虽不发愿求不悔心。不悔之心自然而得。何以故。法性尔故。虽不求乐远离安隐真实知见。见生死过。心不贪着解脱涅槃常乐我净不生不灭。见于佛性而自然得。何以故。法性尔故。师子吼菩萨言。世尊。若因持戒得不悔果。因于解脱得涅槃果者。戒则无因。涅槃无果。戒若无因则名为常。涅槃有因则是无常。若尔者涅槃则为本无今有。若本无今有是为无常。犹如然灯。涅槃若尔。云何得名我乐净耶。佛言。善男子。善哉善哉。汝以曾于无量佛所种诸善根。能问如来如是深义。善男子。不失本念乃如是问也。我忆往昔过无量劫。波罗奈城有佛出世。号曰善得。尔时彼佛三亿岁中演说如是大涅槃经。我时与汝俱在彼会。我以是事咨问彼佛。尔时如来为众生故三昧正受未答此义。善哉大士。乃能忆念如是本事。谛听谛听。当为汝说。戒亦有因。谓听正法。听正法者是亦有因。谓近善友。近善友者是亦有因。所谓信心。信心者是亦有因。因有二种。一者听法。二思惟义。善男子。信心者因于听法。听法者因于信心。如是二法。亦因亦因因。亦果亦果果。善男子。譬如尼干立拒举瓶互为因果不得相离。善男子。如无明缘行。行缘无明。是无明行亦因亦因因。亦果亦果果。乃至生缘老死。老死缘生。是生老死亦因亦因因。亦果亦果果。善男子。生能生法不能自生。不自生故由生生生。生生不自生复赖生故生。是故二生亦因亦因因。亦果亦果果。善男子。信心听法亦复如是。善男子。是果非因谓大涅槃。何故名果。是上果故。沙门果故。婆罗门果故。断生死故。破烦恼故。是故名果。为诸烦恼之所呵责。是故涅槃名果。烦恼者名为过过善男子。涅槃无因而体是果。何以故。无生灭故。无所作故。非有为故。是无为故。常不变故。无处所故。无始终故。善男子。若涅槃有因。则不得称为涅槃也。槃者言因。般涅言无。无有因故。故称涅槃

师子吼菩萨言。如佛所说涅槃无因。是义不然。若言无者则合六义。一者毕竟无故。故名为无。如一切法无我无我所。二者有时无故。故名为无。如世人言。河池无水无有日月三者少故故名为无。如世人言。食中少碱名为无碱。甘浆少甜名为无甜。四者无受故故名为无。如旃陀罗不能受持婆罗门法。是故名为无婆罗门。五者受恶法故。故名为无。如世人言受恶法者不名沙门及婆罗门。是故名为无有沙门及婆罗门。六者不对故。故名为无。譬如无白名之为黑。无有明故名之无明。世尊。涅槃亦尔有时无因故名涅槃

佛言。善男子。汝今所说如是六义。何故不引毕竟无者以喻涅槃。乃取有时无耶。善男子。涅槃之体毕竟无因。犹如无我及无我所。善男子。世法涅槃终不相对。是故六事不得为喻。善男子。一切诸法悉无有我。而此涅槃真实有我。以是义故。涅槃无因而体是果。是因非果名为佛性。非因生故是因非果。非沙门果故名非果。何故名因以了因故。善男子。因有二种。一者生因。二者了因。能生法者是名生因。灯能了物故名了因。烦恼诸结是名生因。众生父母是名了因。如谷子等是名生因。地水粪等是名了因。复有生因。谓六波罗蜜阿耨多罗三藐三菩提。复有了因。谓佛性阿耨多罗三藐三菩提。复有了因。谓六波罗蜜佛性。复有生因。谓首楞严三昧阿耨多罗三藐三菩提。复有了因。谓八正道阿耨多罗三藐三菩提。复有生因。所谓信心六波罗蜜。师子吼菩萨言。世尊。如佛所说见于如来及以佛性。是义云何。世尊。如来之身无有相貌。非长非短非白非黑。无有方所不在三界非有为相非眼识识。云何可见。佛性亦尔佛言。善男子。佛身二种。一者常。二者无常。无常者为欲度脱一切众生方便示现。是名眼见。常者如来世尊解脱之身。亦名眼见亦名闻见。佛性亦二。一者可见。二不可见。可见者十住菩萨诸佛世尊。不可见者一切众生。眼见者谓十住菩萨诸佛如来。眼见众生所有佛性。闻见者一切众生九住菩萨。闻有佛性如来之身。复有二种。一者是色。二者非色。色者如来解脱。非色者如来永断诸色相故。佛性二种。一者是色。二者非色。色者阿耨多罗三藐三菩提。非色者凡夫乃至十住菩萨。十住菩萨见不了了故名非色。善男子。佛性者复有二种。一者是色。二者非色。色者谓佛菩萨。非色者一切众生。色者名为眼见。非色者名为闻见佛性者非内非外。虽非内外然非失坏。故名众生悉有佛性师子吼菩萨言。世尊。如佛所说一切众生悉有佛性如乳中有酪。金刚力士诸佛佛性如净醍醐。云何如来说言佛性非内非外佛言。善男子。我亦不说乳中有酪。酪从乳生故言有酪。世尊。一切生法各有时节。善男子。乳时无酪亦无生苏熟苏醍醐。一切众生亦谓是乳。是故我言乳中无酪。如其有者。何故不得二种名字。如人二能言金铁师。酪时无乳生苏熟苏及以醍醐。众生亦谓是酪非乳。非生熟苏及以醍醐。亦复如是。善男子。因有二种。一者正因。二者缘因。正因者如乳生酪。缘因者如醪暖等。从乳生故故言乳中而有酪性。师子吼菩萨言。世尊。若乳无酪性角中亦无。何故不从角中生耶

善男子。角亦生酪。何以故。我亦说言缘因有二一醪二暖。角性暖故亦能生酪师子吼言。世尊。若角能生酪。求酪之人何故求乳而不取角

佛言。善男子。是故我说正因缘因。师子吼菩萨言。若使乳中本无酪性今方有者。乳中本无庵摩罗树。何故不。生。二俱无故善男子。乳亦能生庵摩罗树。若以乳灌一夜之中增长五尺。以是义故我说二因。善男子。若一切法一因生者。可得难言乳中何故不能出生庵摩罗树。善男子。犹如四大为一切色而作因缘。然色各异差别不同。以是义故。乳中不生庵摩罗树。世尊。如佛所说。有二因者正因缘因。众生佛性为是何因。善男子。众生佛性亦二种因。一者正因。二者缘因。正因者谓诸众生。缘因者谓六波罗蜜

师子吼言。世尊。我今定知乳有酪性。何以故。我见世间求酪之人。唯取于乳终不取水。是故当知乳有酪性

善男子。如汝所问。是义不然。何以故。一切众生欲见面像即便取刀

师子吼言。世尊。以是义故乳有酪性。若刀无面像何故取刀

佛言。善男子。若此刀中定有面像。何故颠倒。竖则见长。横则见阔。若是自面何故见长。若是他面何得称言是己面像。若因己面见他面者。何故不见驴马面像。师子吼言。世尊。眼光到彼故见面长

佛言。善男子。而此眼光实不到彼。何以故。近远一时俱得见故。不见中间所有物故。善男子。光若到彼而得见者。一切众生悉见于火。何故不烧。如人远见白物。不应生疑鹤耶幡耶人耶树耶。若光到者。云何得见水精中物渊中鱼石。若不到见何故得见水精中物。而不得见壁外之色。是故若言眼光到彼而见长者。是义不然。善男子。如汝所言乳有酪者。何故卖乳之人但取乳价不责酪直。卖草马者但取马价不责驹直。善男子。世间之人无子息故故求娉妇。妇若怀妊不得言女。若言是女有儿性故故应娉者。是义不然。何以故。若有儿性亦应有孙。若有孙者则是兄弟。何以故。一腹生故。是故我言女无儿性。若其乳中有酪性者。何故一时不见五味。若树子中有尼拘陀五丈质者。何故一时不见芽茎枝叶花果形色之异。善男子。乳色时异味异果异。乃至醍醐亦复如是。云何可说乳有酪性。善男子。譬如有人明当服苏今已患臭。若言乳中定有酪性亦复如是。善男子。譬如有人有笔纸墨和合成字。而是纸中本无有字。以本无故假缘而成。若本有者何须众缘譬如青黄合成绿色。当知是二本无缘性若本有者何须合成。善男子。譬如众生因食得命。而此食中实无有命。若本有命未食之时食应是命。善男子。一切诸法本无有性。以是义故我说是偈

  本无今有　　本有今无　　三世有法
  无有是处

善男子。一切诸法因缘故生因缘故灭。善男子。若诸众生内有佛性者。一切众生应有佛身如我今也。众生佛性不破不坏不牵不捉不系不缚。如众生中所有虚空。一切众生悉有虚空无挂碍故。各不自见有此虚空。若使众生无虚空者。则无去来行住坐卧不生不长。以是义故。我经中说一切众生有虚空界。虚空界者是名虚空。众生佛性亦复如是。十住菩萨少能见之如金刚珠。善男子。众生佛性诸佛境界。非是声闻缘觉所知。一切众生不见佛性。是故常为烦恼系缚流转生死。见佛性故诸结烦恼所不能系。解脱生死得大涅槃。师子吼菩萨言。世尊。一切众生有佛性性。如乳中酪性。若乳无酪性。云何佛说有二种因。一者正因。二者缘因。缘因者。一醪二暖。虚空无性故无缘因

佛言。善男子。若使乳中定有酪性者。何须缘因。师子吼菩萨言。世尊。以有性故故须缘因。何以故。欲明见故。缘因者即是了因。世尊。譬如闇中先有诸物。为欲见故以灯照了。若本无者灯何所照。如泥中有瓶。故须人水轮绳杖等而为了因。如尼拘陀子。须地水粪而作了因。乳中醪暖亦复如是。须作了因。是故虽先有性。要假了因然后得见以是义故。定知乳中先有酪性

善男子。若使乳中定有酪性者即是了因。若是了因复何须了。善男子。若是了因性是了者常应自了。若自不了何能了他。若言了因有二种性。一者自了。二者了他。是义不然。何以故。了因一法。云何有二。若有二者乳亦应二。若使乳中无二相者。云何了因而独有二。师子吼言。世尊。如世人言我共八人。了因亦尔。自了了他

佛言。善男子。了因若尔则非了因。何以故。数者能数自色他色故得言八。而此色性自无了相。无了相故要须智性乃数自他。是故了因不能自了亦不了他。善男子。一切众生有佛性者。何故修习无量功德。若言修习是了因者已同酪坏。若言因中定有果者。戒定智慧则无增长。我见世人本无禁戒禅定智慧。从师受已渐渐增益。若言师教是了因者。当师教时受者未有戒定智慧。若是了者应了未有。云何乃了戒定智慧令得增长。师子吼菩萨言。世尊。若了因无者。云何得名有乳有酪

善男子。世间答难凡有三种。一者转答。如先所说。何故名戒。以不悔故。乃至为得大涅槃故。二者默然答。如有梵志来问我言。我是常耶。我时默然。三者疑答。如此经中若了因有二。乳中何故不得有二。善男子。我今转答。如世人言有乳酪者以定得故。是故得名有乳有酪佛性亦尔。有众生有佛性。以当见故。师子吼言。世尊。如佛所说是义不然。过去已灭未来未到。云何名有。若言当有名为有者。是义不然。如世间人见无儿息便言无儿。一切众生无佛性者。云何说言一切众生悉有佛性

佛言。善男子。过去名有。譬如种橘。芽生子灭。芽亦甘甜。乃至生果味亦如是。熟已乃醋。善男子。而是醋味子芽乃至生果悉无。随本熟时形色相貌则生醋味。而是醋味本无今有。虽本无今有非不因本。如是本子虽复过去故得名有。以是义故过去名有。云何复名未来为有。譬如有人种植胡麻。有人问言何故种此。答言有油实未有油。胡麻熟已收子熬烝捣压。然后乃得出油。当知是人非虚妄也。以是义故名未来有。云何复名过去有耶。善男子。譬如有人私屏骂王。经历年岁王乃闻之。闻已即问。何故见骂。答言。大王。我不骂也。何以故。骂者已灭。王言。骂者我身二俱存在。云何言灭。以是因缘丧失身命。善男子。是二实无而果不灭。是名过去有。云何复名未来有耶。譬如有人往陶师所问有瓶不。答言有瓶。而是陶师实未有瓶。以有泥故。故言有瓶。当知是人非妄语也。乳中有酪众生佛性亦复如是。欲见佛性应当观察时节形色。是故我说一切众生悉有佛性。实不虚妄。师子吼言。一切众生无有佛性者。云何而得阿耨多罗三藐三菩提。以正因故故令众生得阿耨多罗三藐三菩提。何等正因。所谓佛性。世尊。若尼拘陀子。无尼拘陀树者。何故名为尼拘陀子。而不名为佉陀罗子。世尊。如瞿昙姓不得称为阿坻耶姓。阿坻耶姓亦复不得称瞿昙姓。尼拘陀子亦复如是。不得称为佉陀罗尼子。佉陀罗尼子不得称为尼拘陀子。犹如世尊不得舍离瞿昙种姓。众生佛性亦复如是。以是义故。当知众生悉有佛性佛言。善男子。若言之中有尼拘陀者。是义不然。如其有者。何故不见。善男子。如世间物有因缘故不可得见。云何因缘。谓远不可见。如空中鸟迹。近不可见。如人眼睫。坏故不见。如根败者。乱想故不见。如心不专一。细故不见。如小微尘。障故不见。如云表星。多故不见。如稻聚中麻。相似故不见。如豆在豆聚。尼拘陀树不同如是八种因缘。如其有者何故不见。若言细障故不见者。是义不然。何以故。树相粗故。若言性细。云何增长。若言障故不可见者常应不见。本无粗相今则见粗。当知是粗本无其性。本无见性今则可见。当知是见亦本无性。子亦如是。本无有树今则有之当有何咎。师子吼言。如佛所说有二种因。一者正因。二者了因。尼拘陀子以地水粪作了因故令细得粗

佛言。善男子。若本有者何须了因。若本无性了何所了。若尼拘陀中本无粗相。以了因故乃生粗者。何故不生佉陀罗树。二俱无故。善男子。若细不见者粗应可见。譬如一尘则不可见。多尘和合则应可见。如是子中粗应可见。何以故。见中已有芽茎花果。一一果中有无量子。一一子中有无量树。是故名粗。有是粗故故应可见。善男子。若尼拘陀子。有尼拘陀性而生树者。眼见是子为火所烧。如是烧性亦应本有。若本有者树不应生。若一切法本有生灭。何故先生后灭不一时耶。以是义故。当知无性

师子吼菩萨言。世尊。若尼拘陀子本无树性而生树者。是子何故不出于油。二俱无故。善男子。如是子中亦能生油。虽无本性因缘故有

师子吼言。何故不名胡麻油耶。善男子。非胡麻故。善男子。如火缘生火水缘生水。虽俱从缘不能相有。尼拘陀子及胡麻油亦复如是。虽俱从缘各不相生。尼拘陀子性能治冷。胡麻油者性能治风。善男子。譬如甘蔗。因缘故生石蜜黑蜜。虽俱一缘色貌各异。石蜜治热黑蜜治冷

师子吼菩萨言。世尊。如其乳中无有酪性。麻无油性。尼拘陀子无有树性。泥无瓶性。一切众生无佛性者。如佛先说一切众生悉有佛性。是故应得阿耨多罗三藐三菩提者。是义不然。何以故。人天无性。以无性故人可作天天可作人。以业因缘不以性故。菩萨摩诃萨以业因缘故得阿耨多罗三藐三菩提。若诸众生有佛性者。何因缘故。一阐提等断诸善根堕于地狱。若菩提心是佛性者。一阐提等不应能断。若可断者云何得言佛性是常。若非常者不名佛性。若诸众生有佛性者。何故名为初发心耶。云何而言是毗跋致阿毗跋致。毗跋致者当知是人无有佛性。世尊。菩萨摩诃萨一心趣向阿耨多罗三藐三菩提。大慈大悲见生老病死烦恼过患。观大涅槃无生老死烦恼诸过。信于三宝及业果报受持禁戒。如是等法名为佛性。若离是法有佛性者。何须是法而作因缘。世尊。如乳不假缘必当成酪。生苏不尔要待因缘。所谓人功水瓶攒绳。众生亦尔。有佛性者。应离因缘得阿耨多罗三藐三菩提。若定有者行人何故见三恶苦生老病死而生退心。亦不须修六波罗蜜。即应得成阿耨多罗三藐三菩提。如乳非缘而得成酪。然非不因六波罗蜜而得成于阿耨多罗三藐三菩提。以是义故。当知众生悉无佛性。如佛先说僧宝是常。如其常者则非无常。非无常者云何而得阿耨多罗三藐三菩提。僧若常者云何复言一切众生悉有佛性。世尊。若使众生从本已来无菩提心。亦无阿耨多罗三藐三菩提心。后方有者众生佛性亦应如是本无后有。以是义故。一切众生应无佛性。佛言。善哉善哉。善男子。汝已久知佛性之义。为众生故作如是问。一切众生实有佛性。汝言众生若有佛性。不应而有初发心者。善男子。心非佛性。何以故。心是无常佛性常故。汝言何故有退心者。实无退心。心若有退终不能得阿耨多罗三藐三菩提。以迟得故名之为退。此菩提心实非佛性。何以故。一阐提等断于善根堕地狱故。若菩提心是佛性者。一阐提辈则不得名一阐提也。菩提之心亦不得名为无常也。是故定知菩提之心实非佛性

善男子。汝言众生若有佛性不应假缘如乳成酪者。是义不然。何以故。若言五缘成于生苏。当知佛性亦复如是。譬如众石有金有银有铜有铁。俱禀四大一名一实。而其所出各各不同。要假众缘众生福德炉冶人功然后出生。是故当知本无金性。众生佛性不名为佛。以诸功德因缘和合得见佛性。然后得佛。汝言众生悉有佛性何故不见者。是义不然。何以故。以诸因缘未和合故。善男子。以是义故。我说二因正因缘因。正因者名为佛性。缘因者发菩提心。以二因缘得阿耨多罗三藐三菩提。如石出金

善男子。汝言僧常一切众生无佛性者。善男子。僧名和合。和合有二。一者世和合。二者第一义和合。世和合者名声闻僧。义和合者名菩萨僧。世僧无常佛性是常。如佛性常义僧亦尔。复次有僧谓法和合。法和合者谓十二部经。十二部经常。是故我说法僧是常。善男子。僧名和合。和合者名十二因缘。十二因缘中亦有佛性。十二因缘常佛性亦尔。是故我说僧有佛性。又复僧者谓诸佛和合。是故我说僧有佛性

善男子。汝言众生若有佛性。云何有退有不退者。谛听谛听我当为汝分别解说。善男子。菩萨摩诃萨有十三法则便退转。何等十三。一者心不信。二者不作心。三者疑心。四者吝惜身财。五者于涅槃中生大怖畏。云何乃令众生永灭。六者心不堪忍。七者心不调柔。八者愁恼。九者不乐。十者放逸。十一者自轻己身。十二者自见烦恼无能坏者。十三者不乐进趣菩提之法。善男子。是名十三法。令诸菩萨退转菩提。复有六法坏菩提心。何等为六。一者吝法。二者于诸众生起不善心。三者亲近恶友。四者不勤精进。五者自大憍慢。六者营务世业。如是六法则能破坏菩提之心。善男子。有人得闻诸佛世尊是人天师。于众生中最上无比胜于声闻辟支佛等。法眼明了见法无碍。能度众生于大苦海。闻已即复发大誓愿。如其世间有如是人。我亦当得以是因缘发阿耨多罗三藐三菩提心。或复为他之所教诲发菩提心。或闻菩萨阿僧祇劫修行苦行。然后乃得阿耨多罗三藐三菩提。闻已思惟。我今不堪如是苦行。云何能得是故有退。善男子。复有五法退菩提心。何等为五。一者乐在外道出家。二者不修大慈之心。三者好求法师过恶。四者常乐处在生死。五者不喜受持读诵书写解说十二部经。是名五法退菩提心。复有二法退菩提心。何等为二。一者贪乐五欲。二者不能恭敬尊重三宝。以如是等众因缘故退菩提心

云何复名不退之心。有人闻佛能度众生生老病死。不从师咨自然修习得阿耨多罗三藐三菩提。若菩提道是可得者。我当修习必令得之。以是因缘发菩提心。所作功德若多若少悉以回向阿耨多罗三藐三菩提。作是誓愿。愿我常得亲近诸佛及佛弟子。常闻深法五情完具。若遇苦难不失是心。复愿诸佛及诸弟子。常于我所生欢喜心具。五善根。若诸众生斫伐我身斩截手足头目支节。当于是人生大慈心深自喜庆。如是诸人为我增长菩提因缘。若无是者我当何缘而得成就阿耨多罗三藐三菩提。复发是愿。莫令我得无根二根女人之身。不系属人不遭恶主不属恶王不生恶国。若得好身种姓真正多饶财宝不生憍慢。令我常闻十二部经受持读诵书写解说。若为众生有所演说。愿令受者敬信无疑常于我所不生恶心。宁当少闻多解义味。不愿多闻于义不了。愿作心师不师于心。身口意业不与恶交。能施一切众生安乐。身戒心慧不动如山。欲为受持无上正法。于身命财不生悭吝。不净之物不为福业。正命自活心无邪谄。受恩常念小恩大报。善知世中所有事艺。善解众生方俗之言。读诵书写十二部经不生懈怠懒堕之心。若诸众生不乐听闻。方便引接令彼乐闻。言常柔软口不宣恶。不和合众能令和合。有忧怖者令离忧怖。饥馑之世令得丰足。疾病之世作大医王病药所须财宝自在。令疾病者悉得除愈。刀兵之劫有大力势断其残害令无遗余。能断众生种种怖畏。所谓若死闭系打掷水火王贼贫穷破戒恶名恶道。如是等畏悉当断之。父母师长深生恭敬。怨憎之中生大慈心。常修六念空三昧门十二因缘生灭等观。出息入息天行梵行及以圣行。金刚三昧首楞严定。无三宝处令我自得寂静之心。若其身心受大苦时。莫失无上菩提之心。莫以声闻辟支佛心而生知足。无三宝处常在外道法中出家。为破邪见不习其道。得法自在得心自在。于有为法了了见过。令我怖畏二乘道果。如惜命者怖畏舍身。为众生故乐处三恶。如诸众生乐忉利天。为一一人于无量劫受地狱苦心不生悔。见他得利不生妒心。常生欢喜如自得乐。若值三宝当以衣服饮食卧具房舍医药。灯明花香伎乐幡盖七宝供养。若受佛戒坚固护持。终不生于毁犯之想。若闻菩萨难行苦行。其心欢喜不生悔恨。自识往世宿命之事。终不造作贪嗔痴业。不为果报而集因缘。于现在乐不生贪着。善男子。若有能发如是愿者。是名菩萨终不退失菩提之心。亦名施主。能见如来明了佛性。能调众生度脱生死。善能护持无上正法。能得具足六波罗蜜。善男子。以是义故。不退之心不名佛性

善男子。汝不可以有退心故。言诸众生无有佛性。譬如二人俱闻他方有七宝山。山有清泉其味甘美。有能到者永断贫穷服其水者增寿万岁。唯路悬远崄阻多难。时彼二人俱欲共往。一人庄严种种行具。一则空往无所赍持。相与前进路值一人多赍宝货七珍具足。二人便前问言。仁者。彼土实有七宝山耶。其人答言。实有不虚我已获宝饮服其水。唯患路崄多有盗贼。沙卤棘刺乏于水草。往者千万达者甚少。闻是事已一人即悔寻作是言。路既悬远艰难非一。往者无量达者无几。而我云何当能到彼。我今产业粗自供足。若涉斯路或失身命。身命不全长寿安在。一人复言。有人能过我亦能过。若得果达则得如愿采取珍宝饮服甘水。如其不达以死为期。是时二人一则悔还。一则前进到彼山所多获财宝。如愿服水多赍所有还其所止。奉养父母赈给宗亲。时悔还者见是事已心中生热。彼去已还我何为住。即便庄严涉道而去。七宝山者喻大涅槃。甘美之水喻于佛性。其二人者喻二菩萨初发道心。崄恶道者喻于生死。所逢人者喻佛世尊。有盗贼者喻于四魔。沙卤棘刺喻诸烦恼。无水草者喻不修习菩提之道。一人还者喻退转菩萨。其直往者喻不退菩萨。善男子。众生佛性常住不变犹彼崄道。不可说言人悔还故令道无常。佛性亦尔。善男子。菩提道中终无退者。善男子。如向悔者。见其先伴获宝而还。势力自在供养父母给足宗亲多受安乐。见是事已心中生热。即复庄严复道还去。不惜身命堪忍众难。遂便到彼七宝山中。退转菩萨亦复如是。善男子。一切众生定当得成阿耨多罗三藐三菩提。以是义故。我经中说。一切众生乃至五逆犯四重禁及一阐提悉有佛性师子吼言。世尊。云何菩萨有退不退。善男子。若有菩萨修习如来三十二相业因缘者得名不退。得名菩萨摩诃萨也。名不动转。名为怜愍一切众生。名胜一切声闻缘觉。名阿毗跋致。善男子。若菩萨摩诃萨持戒不动施心不移安住实语如须弥山。以是业缘得足下平如奁底相

若菩萨摩诃萨于父母所和上师长乃至畜生。以如法财供养供给。以是业缘得成足下千辐轮相

若菩萨摩诃萨不杀不盗。于父母师长常生欢喜。以是业缘得成三相。一者手指纤长。二者足跟长。三者其身方直。如是三相同一业缘。若菩萨摩诃萨修四摄法摄取众生。以是业缘得网缦指如白鹅王

若菩萨摩诃萨父母师长若病苦时。自手洗拭捉持案摩。以是业缘得手足软若菩萨摩诃萨持戒闻法惠施无厌。以是业缘得节踝[跳-兆+庸]满身毛上靡

若菩萨摩诃萨专心听法演说正教。以是业缘得鹿王[跳-兆+專]

若菩萨摩诃萨于诸众生不生害心。饮食知足常乐惠施瞻病给药。以是业缘其身圆满如尼拘陀树。立手过膝顶有肉髻无见顶相。若菩萨摩诃萨见怖畏者为作救护。见裸跣者施与衣服。以是业缘得阴藏相

若菩萨摩诃萨亲近智者远离愚人。善喜问答扫治行路。以是业缘皮肤细软身毛右旋。若菩萨摩诃萨常以衣服饮食卧具医药香花灯明施人。以是业缘得身金色常光明曜。若菩萨摩诃萨行施之时。所珍之物能舍不吝不观福田及非福田。以是业缘得七处满相

若菩萨摩诃萨布施之时心不生疑。以是业缘得柔软声

若菩萨摩诃萨如法求财以用布施。以是业缘得缺骨充满师子上身臂肘佣纤若菩萨摩诃萨远离两舌恶口恚心。以是业缘得四十牙齿白净齐密

若菩萨摩诃萨于诸众生修大慈悲。以是业缘得二牙相

若菩萨摩诃萨常作是愿。有来求者随意给与以是业缘得师子颊

若菩萨摩诃萨随诸众生所须饮食悉皆与之。以是业缘得味中上味

若菩萨摩诃萨自修十善兼以化人。以是业缘得广长舌

若菩萨摩诃萨不讼彼短不谤正法。以是业缘得梵音声

若菩萨摩诃萨见诸怨憎生于喜心。以是业缘得目睫绀色

若菩萨摩诃萨不隐他德称扬其善。以是业缘得白毫相。善男子。若菩萨摩诃萨修习如是三十二相业因缘时。则得不退菩提之心

善男子。一切众生不可思议。诸佛境界业果佛性亦不可思议。何以故。如是四法皆悉是常。以是常故不可思议。一切众生烦恼覆障故名为常。断常烦恼故故名无常。若言一切众生常者。何故修习八圣道分为断众苦。众苦若断则名无常。所受之乐则名为常。是故我言。一切众生烦恼覆障不见佛性。以不见故不得涅槃

大般涅槃经卷第二十八大般涅槃经卷第二十九

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之三

师子吼言。世尊。如佛所说。一切诸法有二种因。一者正因。二者缘因。以是二因应无缚解。是五阴者念念生灭。如其生灭谁有缚解。世尊。因此五阴生后五阴。此阴自灭不至彼阴。虽不至彼能生彼阴。如因子生芽子不至芽。虽不至芽而能生芽。众生亦尔。云何缚解。善男子。谛听谛听我当为汝分别解说。善男子。如人舍命受大苦时。宗亲围绕。号哭懊恼。其人惶怖莫知依救。虽有五情无所知觉。肢节战动不能自持。身体虚冷暖气欲尽。见先所修善恶报相。善男子。如日垂没山陵堆阜。影现东移理无西逝。众生业果亦复如是。此阴灭时彼阴续生。如灯生闇灭灯灭闇生善男子。如蜡印印泥。印与泥。合印灭文成。而是蜡印不变在泥。文非泥出不余处来。以印因缘而生是文。现在阴灭中阴阴生。是现在阴终不变为中阴五阴。中阴五阴亦非自生不从余来。因现阴故生中阴阴。如印印泥印坏文成。名虽无差而时节各异。是故我说中阴五阴非肉眼见天眼所见。是中阴中有三种食。一者思食。二者触食。三者意食。中阴二种。一善业果。二恶业果。因善业故得善觉观。因恶业故得恶觉观。父母交会牉合之时。随业因缘向受生处。于母生爱于父生嗔。父精出时谓是己有。见已心悦而生欢喜。以是三种烦恼因缘。中阴阴坏生后五阴。如印印泥印坏文成。生时诸根有具不具。具者见色则生于贪。生于贪故则名为爱。狂故生贪是名无明。贪爱无明二因缘故。所见境界皆悉颠倒。无常见常无我见我。无乐见乐无净见净。以四倒故作善恶行。烦恼作业业作烦恼。是名系缚。以是义故名五阴生。是人若得亲近于佛及佛弟子诸善知识。便得闻受十二部经。以闻法故观善境界。观善境界故得大智慧。大智慧者名正知见。得知见故于生死中而生悔心。生悔心故不生欢乐。不生欢乐故能破贪心。破贪心故修八圣道。修八圣道故得无生死。无生死故名得解脱。如火不遇薪名之为灭。灭生死故名为灭度。以是义故名五阴灭。师子吼言。空中无刺云何言拔。阴无系者云何系缚。佛言。善男子。以烦恼锁系缚五阴。离五阴已无别烦恼。离烦恼已无别五阴。善男子。如柱持屋离屋无柱离柱无屋。众生五阴亦复如是。有烦恼故名为系缚。无烦恼故名为解脱。善男子。如拳合掌。系结等三。合散生灭更无别法。众生五阴亦复如是。有烦恼故名为系缚。无烦恼故名为解脱。善男子。如说名色系缚众生。名色若灭则无众生。离名色已无别众生。离众生已无别名色。亦名名色系缚众生。亦名众生系缚名色。师子吼言。世尊。如眼不自见指不自触刀不自割受不自受。云何如来说言名色系缚名色。何以故。言名色者即是众生。言众生者即是名色。若言名色系缚众生。即是名色系缚名色。佛言。善男子。如二手合时。更无异法而来合也。名之与色亦复如是。以是义故。我言名色系缚众生。若离名色则得解脱。是故我言众生解脱。师子吼言。世尊若有名色是系缚者。诸阿罗汉未离名色亦应系缚。善男子。解脱二种。一者子断。二者果断。言子断者名断烦恼。阿罗汉等已断烦恼众结烂坏。是故子结不能系缚。未断果故名果系缚。诸阿罗汉不见佛性。以不见故不得阿耨多罗三藐三菩提。以是义故。可言果系。不得说言名色系缚。善男子。譬如然灯油未尽时明则不灭。若油尽者灭则无疑。善男子。所言油者喻诸烦恼。灯喻众生。一切众生烦恼油故不入涅槃。若得断者则入涅槃。师子吼言。世尊。灯之与油二性各异。众生烦恼则不如是。众生即是烦恼烦恼即是众生。众生名五阴五阴名众生。五阴名烦恼烦恼名五阴。云何如来喻之于灯。佛言。善男子。喻有八种。一者顺喻。二者逆喻。三者现喻。四者非喻。五者先喻。六者后喻。七者先后喻。八者遍喻。云何顺喻。如经中说。天降大雨沟渎皆满。沟渎满故小坑满。小坑满故大坑满。大坑满故小泉满。小泉满故大泉满。大泉满故小池满。小池满故大池满。大池满故小河满。小河满故大河满。大河满故大海满。如来法雨亦复如是。众生戒满。戒满足故不悔心满。不悔心满故欢喜满。欢喜满故远离满。远离满故安隐满。安隐满故三昧满。三昧满故正知见满。正知见满故厌离满。厌离满故呵责满。呵责满故解脱满。解脱满故涅槃满。是名顺喻。云何逆喻。大海有本所谓大河。大河有本所谓小河。小河有本所谓大池。大池有本所谓小池。小池有本所谓大泉。大泉有本所谓小泉。小泉有本所谓大坑。大坑有本所谓小坑。小坑有本所谓沟渎。沟渎有本所谓大雨。涅槃有本所谓解脱。解脱有本所谓呵责。呵责有本所谓厌离。厌离有本所谓正知见。正知见有本所谓三昧。三昧有本所谓安隐。安隐有本所谓远离。远离有本所谓喜心。喜心有本所谓不悔。不悔有本所谓持戒。持戒有本所谓法雨。是名逆喻。云何现喻。如经中说。众生心性犹如猕猴。猕猴之性舍一取一。众生心性亦复如是。取着色声香味触法无暂住时。是名现喻。云何非喻。如我昔告波斯匿王。大王。有亲信人从四方来各作是言。大王。有四大山从四方来欲害人民。王若闻者当设何计。王言。世尊。设有此来无逃避处。惟当专心持戒布施。我即赞言。善哉大王。我说四山即是众生生老病死。生老病死常来切人。云何大王。不修戒施。王言。世尊。持戒布施得何等果。我言。大王。于人天中多受快乐。王言。世尊。尼拘陀树持戒布施。亦于人天受安隐耶。我言。大王。尼拘陀树不能持戒修行布施。如其能者则受无异。是名非喻。云何先喻。我经中说。譬如有人贪着妙花。采取之时为水所漂。众生亦尔。贪受五欲。为生死水之所漂没。是名先喻。云何后喻。如法句说

  莫轻小罪　　以为无殃　　水渧虽微
  渐盈大器

是名后喻。云何先后喻。譬如芭蕉生果则死。愚人得养亦复如是。如骡怀妊命不久全。云何遍喻。如经中说。三十三天有波利质多树。其根入地深五由延。高百由延。枝叶四布五十由延。叶熟则黄。诸天见已心生欢喜。是叶不久必当堕落。其叶既落复生欢喜。是枝不久必当变色。枝既变色复生欢喜。是色不久必当生疱。见已复喜。是疱不久必当生嘴。见已复喜。是嘴不久必当开剖。开剖之时香气周遍五十由延。光明远照八十由延。尔时诸天夏三月时在下受乐。善男子。我诸弟子亦复如是。叶色黄者。喻我弟子念欲出家。其叶落者。喻我弟子剃除须发。其色变者。喻我弟子白四羯磨受具足戒。初生疱者。喻我弟子发阿耨多罗三藐三菩提心。嘴者。喻于十住菩萨得见佛性。开剖者。喻于菩萨得阿耨多罗三藐三菩提。香者。喻于十方无量众生受持禁戒。光者。喻于如来名号无碍周遍十方。夏三月者。喻三三昧。三十三天受快乐者。喻于诸佛在大涅槃得常乐我净。是名遍喻。善男子。凡所引喻不必尽取。或取少分或取多分或复全取。如言如来面如满月。是名少分。善男子。譬如有人初不见乳转。问他言乳为何类。彼人答言如水蜜贝。水则湿相蜜则甜相贝则色相。虽引三喻未即乳实。善男子。我言灯喻喻于众生亦复如是。善男子。离水无河。众生亦尔。离五阴已无别众生。善男子。如离箱舆轮轴辐辋更无别车。众生亦尔。善男子。若欲得合彼灯喻者。谛听谛听我今当说。炷者喻于二十五有。油者喻爱。明喻智慧。除破黑闇喻破无明。暖喻圣道。如灯油尽明焰则灭。众生爱尽则见佛性。虽有名色不能系缚。虽复处在二十五有。不为诸有之所污染。师子吼言。世尊。众生五阴空无所有。谁有受教修习道者。佛言。善男子。一切众生皆有念心慧心发心勤精进心信心定心。如是等法虽念念生灭。犹故相似相续不断。故名修道。师子吼言。世尊。如是等法皆念念灭。是念念灭亦相似相续。云何修习。佛言。善男子。如灯虽念念灭。而有光明除破闇冥。念等诸法亦复如是。善男子。如众生食虽念念灭。亦令饥者而得饱满。譬如上药虽念念灭亦能愈病。日月光明虽念念灭。亦能增长树林草木。善男子。汝言念念灭云何增长者。心不断故名为增长。善男子。如人诵书所诵字句不得一时。前不至中中不至后。人之与字及以心想俱念念灭。以久修故而得通利。善男子。譬如金师从初习作至于皓首。虽念念灭前不至后。以积习故所作遂妙。是故得称善好金师。读诵经书亦复如是善男子。譬如种子。地亦不教汝当生芽。以法性故牙则自生。乃至花亦不教汝当作果。以法性故而果自生。众生修道亦复如是。善男子。譬如数法。一不至二二不至三。虽念念灭而至千万。众生修道亦复如是。善男子。如灯念念灭。初灭之焰不教后焰我灭汝生当破诸闇。善男子。譬如犊子生便求乳。求乳之智实无人教。虽念念灭而初饥后饱。是故当知不应相似。若相似者不应异生。众生修道亦复如是。初虽未增以久修故。则能破坏一切烦恼。师子吼言。世尊。如佛所说。须陀洹人得果证已。虽生恶国犹故持戒。不杀盗淫两舌饮酒。须陀洹阴即此处灭不至恶国。修道亦尔不至恶国。若相似者何故不生净妙国土。若恶国阴非须陀洹阴。云何而得不作恶业。佛言。善男子。须陀洹者虽生恶国。终不失于须陀洹名阴不相似。是故我引犊子为喻。须陀洹人虽生恶国。以道力故不作恶业。善男子。譬如香山有师子王。是故一切飞鸟走兽绝迹。此山无敢近者。有时是王至雪山中。一切鸟兽犹故不住。须陀洹人亦复如是。虽不修道以道力故不作诸恶。善男子。譬如有人服食甘露。甘露虽灭以其力势能令是人不生不死。善男子。如须弥山有上妙药名楞伽利。有人服之虽念念灭。以药力故不遇患苦。善男子。如转轮王所坐之处。王虽不在无人敢近。何以故。王威力故。须陀洹人亦复如是虽生恶国不修习道。以道力故不作恶业。善男子。须陀洹阴于此而灭虽生异阴。犹故不失须陀洹阴。善男子。譬如众生为果实故于种子中多役作业。粪治溉灌未得果实而子复灭。亦得名为因子得果。须陀洹阴亦复如是。善男子。譬如有人资产巨富。惟有一子先已终殁。其子有子复在他土。其人忽然奄便命终。孙闻是已还收产业。虽知财货非其所作。然其收取无遮护者。何以故。以姓一故。须陀洹阴亦复如是。师子吼言。如佛说偈

  比丘若修习　　戒定及智慧
  当知是不退　　亲近大涅槃

世尊。云何修戒云何修定云何修慧。佛言。善男子。若有人受持禁戒。但为自利人天受乐。不为度脱一切众生。不为拥护无上正法。但为利养畏三恶道。为命色力安无碍辩。畏惧王法恶名秽称为世事业。如是护戒则不得名修习戒也。善男子。云何名为真修习戒。受持戒时。若为度脱一切众生为护正法。度不度故。解未解故。归无归故。未入涅槃令得入故。如是修时。不见戒不见戒相不见持者。不见果报不观毁犯。善男子。若能如是。是则名为修习戒也。云何复名修习三昧。修三昧时。为自度脱为于利养。不为众生不为护法。为见贪欲秽食等过。男女等根九孔不净。斗讼打刺互相杀害。若为此事修三昧者。是则不名修习三昧。善男子。云何复名真修三昧。若为众生修习三昧。于众生中得平等心。为令众生得不退法。为令众生得圣心故。为令众生得大乘故。为欲护持无上法故。为令众生不退菩提故。为令众生得首楞严故。为令众生得金刚三昧故。为令众生得陀罗尼故。为令众生得四无碍故。为令众生见佛性故。作是行时。不见三昧不见三昧相。不见修者不见果报。善男子。若能如是。是则名为修习三昧。云何复名修于智慧。若有修者作是思惟。我若修习如是智慧。则得解脱度三恶道谁能利益一切众生。谁能度人于生死道。佛出世难如优昙钵花。我今能断诸烦恼结必得解脱果。是故我当勤修智慧。速断烦恼早得度脱。如是修者。不得名为修习智慧。云何名为真修习者。智者若观生老死苦。一切众生无明所覆。不知修习无上正道。愿我此身悉代众生受大苦恼。众生所有贫穷下贱破戒之心贪嗔痴业。愿皆悉来集于我身。愿诸众生不生贪取。不为名色之所系缚。愿诸众生早度生死。令我一身处之不厌。愿令一切皆得阿耨多罗三藐三菩提。如是修时。不见智慧不见智慧相。不见修者不见果报。是则名为修习智慧。善男子。修习如是戒定智慧是名菩萨。不能如是修戒定慧是名声闻

复次善男子。云何复名修集于戒。若能破坏一切众生十六恶律仪。何等十六。一者为利餧养羔羊肥已转卖。二者为利买已屠杀。三者为利餧养猪豚肥已转卖。四者为利买已屠杀。五者为利餧养牛犊肥已转卖。六者为利买已屠杀。七者为利养鸡令肥肥已转卖。八者为利买已屠杀。九者钓鱼。十者猎师。十一者劫夺。十二者魁脍。十三者网捕飞鸟。十四者两舌。十五者狱卒。十六者咒龙。能为众生永断如是十六恶业。是名修戒。云何修定。能断一切世间三昧。所谓无身三昧。能令众生生颠倒心谓是涅槃。有无边心三昧净聚三昧世边三昧世断三昧世性三昧世丈夫三昧非想非非想三昧。如是等定能令众生生颠倒心谓是涅槃。若能永断如是三昧。是则名为修习三昧。云何复名修习智慧。能破世间所有恶见。一切众生悉有恶见。所谓色即是我亦是我所。色中有我我中有色。乃至识亦如是。常即是我色灭我存。色即是我色灭我灭。复有人言。作者名我受者名色。复有人言。作者名色受者名我。复有人言。无作无受自生自灭悉非因缘。复有人言。无作无受悉是自在之所造作。复有人言。无有作者无有受者。一切悉是时节所作。复有人言。作者受者悉无所有。地等五大名为众生。善男子。若能破坏一切众生如是恶见。是则名为修智慧也。善男子。修习戒者为身寂静。修习三昧为心寂静。修习智慧为坏疑心。坏疑心者为修习道。修习道者为见佛性。见佛性者为得阿耨多罗三藐三菩提故。得阿耨多罗三藐三菩提者为得无上大涅槃故。得大涅槃者为断众生一切生死一切烦恼一切诸有一切诸界一切诸谛故。断于生死乃至断谛。为得常乐我净法故

师子吼言。世尊。如佛所说。若不生不灭名大涅槃者。生亦如是不生不灭。何故不得名为涅槃。善男子。如是如是如汝所言。是生虽复不生不灭而有始终。世尊。是生死法亦无始终。若无始终则名为常。常即涅槃。何故不名生死为涅槃耶。善男子。是生死法悉有因果。有因果故不得名之为涅槃也。何以故。涅槃之体无因果故。师子吼言。世尊。夫涅槃者亦有因果。如佛所说

  从因故生天　　从因堕恶道
  从因故涅槃　　是故皆有因

如佛往昔告诸比丘。我今当说沙门道果。言沙门者。谓能具修戒定智慧。道者谓八圣道。沙门果者所谓涅槃。世尊。涅槃如是岂非果耶。云何说言涅槃之体无因无果。佛言。善男子。我所宣说涅槃因者。所谓佛性。佛性之性不生涅槃。是故我言涅槃无因。能破烦恼故名大果。不从道生故名无果。是故涅槃无因无果。师子吼言。世尊。众生佛性为悉共有为各各有。若共有者一人得阿耨多罗三藐三菩提时。一切众生亦应同得世尊。如二十人同有一怨。若一人能除。余十九人皆亦同除。佛性亦尔。一人得时余亦应得。若各各有则是无常。何以故。可算数故。然佛所说众生佛性不一不二。若各各有不应说言诸佛平等。亦不应说佛性如空。佛言。善男子。众生佛性不一不二。诸佛平等犹如虚空。一切众生同共有之。若有能修八圣道者。当知是人则得明见。善男子。雪山有草名曰忍辱。牛若食之则成醍醐。众生佛性亦复如是。师子吼言。如佛所说忍辱草者。一耶多耶。如其一者牛食则尽。如其多者云何而言众生佛性亦如是耶。如佛所说。若有修习八圣道者则见佛性。是义不然。何以故。道若一者如忍辱草则应有尽。如其有尽一人修已余则无分。若道多者云何得言具足修习。亦不得名萨婆若智。佛言。善男子。如平坦路一切众生悉于中行无障碍者。中路有树其阴清凉。行人在下憩驾止息。然其树阴常住不移。亦不消坏无持去者。路。喻圣道。阴喻佛性。善男子。譬如大城唯有一门。虽有多人经由入出。都无有能作障碍者。亦复无人破坏毁落而赍持去。善男子。譬如桥梁行人所由。亦无有人遮止障碍毁坏持去。善男子。譬如良医遍疗众病。亦无有能遮止是医治此舍彼。圣道佛性亦复如是。师子吼言。世尊。所引诸喻义不如是。何以故。先者在路于后则妨。云何而言无有障碍。余亦皆尔。圣道佛性若如是者。一人修时应妨余者。佛言。善男子。如汝所言义不相应。我所喻道是少分喻非一切也。善男子。世间道者则有障碍。此彼之异无有平等。无漏道者则不如是。能令众生无有障碍。平等无二无有方处此彼之异。如是正道能为一切众生佛性。而作了因不作生因。犹如明灯照了于物。善男子。一切众生皆同无明因缘于行。不可说言一人无明因缘行已其余应无。一切众生悉有无明因缘于行。是故说言十二因缘一切平等。众生所修无漏正道亦复如是。等断众生烦恼四生诸界有道。以是义故名为平等。其有证者彼此知见无有障碍。是故得名萨婆若智。师子吼言。一切众生身不一种。或有天身或有人身畜生饿鬼地狱之身。如是多身差别非一。云何而言佛性为一。佛言。善男子。譬如有人置毒乳中。乃至醍醐皆悉有毒。乳不名酪酪不名乳。乃至醍醐亦复如是。名字虽变毒性不失。遍五味中皆悉如是。若服醍醐亦能杀人。实不置毒于醍醐中。众生佛性亦复如是。虽处五道受别异身。而是佛性常一无变

师子吼言。世尊。十六大国有六大城。所谓舍婆提城婆枳多城瞻婆城毗舍离城波罗奈城王舍城。如是六城世中最大。何故如来舍之。在此边地弊恶极陋隘小拘尸那城入般涅槃。善男子。汝不应言拘尸那城边地弊恶最陋隘小应言是城微妙功德之所庄严。何以故。诸佛菩萨所行处故。善男子。如贱人舍。王若过者则应赞叹。是舍严丽功德成就。能令大王回驾临顾。善男子。如人重病服秽弊药。服已病愈即应欢喜赞叹。是药最上最妙能愈我病。善男子。如人乘船在大海中。其船卒坏无所依倚。因倚死尸得到彼岸。到彼岸已应大欢喜赞叹。是尸我赖相遇而得安隐。拘尸那城亦复如是。乃是诸佛菩萨行处。云何而言边地弊恶陋隘小城。善男子。我念往昔过恒河沙劫劫名善觉。时有圣王姓憍尸迦。七宝成就千子具足。其王始初造立此城。周匝纵广十二由延七宝庄严。土多有河其水清净柔软甘美。所谓泥连禅河伊罗跋提河熙连禅河伊搜末堆河毗婆舍那河。如是等河其数五百。河此彼岸树木繁茂花果鲜洁。尔时人民寿命无量。时转轮圣王过百年已作是唱言。如佛所说。一切诸法皆悉无常。若能修习十善法者。能断如是无常大苦。人民闻已咸共奉修十善之法。我于尔时闻佛名号。受持十善思惟修习。初发阿耨多罗三藐三菩提心。发是心已复以是法转教无量无边众生言。一切法无常变坏。是故我今续于此处。亦说诸法无常变坏。惟说佛身是常住法。我忆往昔所行因缘。是故今来在此涅槃。亦欲酬报此地往恩。以是义故。我经中说。我眷属者受恩能报

复次善男子。往昔众生寿无量时。尔时此城名拘舍跋提。周匝纵广五十由延。时阎浮提居民邻接鸡飞相及。有转轮王名曰善见。七宝成就千子具足。王四天下。第一太子思惟正法得辟支佛。时转轮王见其太子成辟支佛威仪庠序神通希有。见是事已即舍王位如弃涕唾。出家在此娑罗树间。八万岁中修习慈心。悲喜舍心各八万岁。善男子。欲知尔时善见圣王则我身是。是故我今常乐游止如是四法。是四法者名为三昧。以是义故如来之身常乐我净。善男子。以是因缘今来在此拘尸那城娑罗树间三昧正受

善男子。我念往昔过无量劫。此城尔时名迦毗罗卫。其城有王名曰白净。其王夫人名曰摩耶。王有一子名悉达多。尔时王子不由师教。自然思惟得阿耨多罗三藐三菩提。有二弟子。一名舍利弗。二名大目犍连。给侍弟子名曰阿难。尔时世尊在双树间演说如是大涅槃经。我时在会得预斯事。闻诸众生悉有佛性。闻是事已即于菩提得不退转。寻自发愿。愿未来世成佛之时。父母国土名字弟子侍使之人说法教化。如今世尊等无有异。以是因缘今来在此敷扬演说大涅槃经。善男子。我初出家未得阿耨多罗三藐三菩提时。频婆娑罗王遣使而言。悉达太子。若为圣王我当臣属。若不乐家得阿耨多罗三藐三菩提者。愿先来至此王舍城说法度人受我供养。我时默然已受彼请。善男子。我初得阿耨多罗三藐三菩提已向竭阇国时。伊连禅河有婆罗门姓迦叶氏。与五百弟子在彼河侧求无上道。我为是人故往说法。迦叶言。瞿昙。我今年迈已百二十。摩伽陀国所有人民及其大王频婆娑罗。咸谓我已证罗汉果。我今若当在于汝前听受法者。一切人民或生倒心。大德迦叶非罗汉耶。幸愿瞿昙速往余处。若此人民定知瞿昙功德胜我。我等无由复得供养。我时答言。迦叶。汝若于我不生殷重大嗔恨者。见容一宿明当早去。迦叶言。瞿昙。我心无他深相爱重。但我住处有一毒龙。其性暴急恐相危害。我言。迦叶。毒中之毒不过三毒。我今已断。世间之毒我所不畏。迦叶复言。苟能不畏善哉听住。善男子。我于尔时故为迦叶现十八变。如经中说。尔时迦叶及其眷属五百等辈。见闻是已证罗汉果。是时迦叶复有二弟。一名伽耶迦叶。二名那提迦叶。师徒眷属复有五百。亦皆证得阿罗汉果。时王舍城六师之徒。闻是事已即于我所生大恶心。我时赴信受彼王请诣王舍城。未至中路王与无量百千之众悉来奉迎。我为说法。时闻法已。欲界诸天八万六千发阿耨多罗三藐三菩提心。频婆娑罗王所将营从十二万人得须陀洹果。无量众生成就忍心。既入城已度舍利弗大目犍连及其眷属二百五十人。令舍本心出家学道。我即住彼受王供养。外道六师相与聚集诣舍卫城

时彼城中有一长者名须达多。为儿娉妇诣王舍城。既达彼城寄止长者珊檀那舍。时此长者中夜而起告诸眷属。仁等。可起速共庄严扫治宅舍办具肴膳。须达闻已寻自思惟。将非欲请摩伽王耶。为有婚姻欢乐会乎。思惟是已寻前问言。大士。欲请摩伽陀王频婆娑罗耶。为有婚姻欢乐会乎。遽务不安乃如是耶。长者答言。不也居士。我明请佛无上法王。须达长者初闻佛名身毛皆竖。寻复问言。何等名佛。长者答言。汝不闻耶。迦毗罗城有释种子。字悉达多姓瞿昙氏父名白净。其生未久相师占之。定当得作转轮圣王。如庵罗果已在手中。心不愿乐舍之出家。无师自觉得阿耨多罗三藐三菩提贪恚痴尽。常住无变不生不灭无有忧畏。于诸众生其心平等犹如父母等视一子。所有身心众中最胜。虽胜一切而无憍慢。涂割二事其心无二。智慧通达于法无碍。具足十力四无所畏五智三昧大慈大悲及三念处。故号为佛。明受我请。是故匆匆未暇相瞻。须达多言。善哉大士。所言佛者功德无上今在何处。长者答言。今在此间王舍大城。住迦兰陀竹林精舍。时须达多一心念佛所有功德十力无畏五智三昧大慈大悲及三念处。作是念时忽然大明。其明猛盛犹如白日。即寻光出至城门下。佛神力故门自开辟。既出门已路有天祠。须达经过礼拜致敬。寻还黑闇心生惶怖。复欲还返所止之处。时彼城门有一天神告须达言。仁者。若往如来所者多 护 善利。须达多言。云何善利。答言。长者。假使有人真宝珓珞骏马百匹香象百头宝车百乘。铸金为人其数复百。端正女人身佩璎珞众宝厕填。上妙宫宅殿堂屋宇雕文刻镂。金盘银粟银盘金粟数各一百以施一人。如是展转尽阎浮提。所得功德。不如有人发意一步诣如来所。须达多言。善男子。汝是谁耶。答言。长者。我是胜相婆罗门子。是汝往昔善知识也。我因往日见舍利弗大目犍连心生欢喜。舍身得作北方天王毗沙门子。专知守护此王舍城。我因礼拜舍利弗等生欢喜心。尚得如是妙好之身。况当得见如来大师礼拜供养。须达长者闻是事已。即还复道来诣我所。到已头面敬礼我足。我时即为如应说法。长者闻已得须陀洹果。既获果证复请我言。如来大慈。惟愿临顾至舍卫城受我微供。我即问言。卿舍卫国颇有精舍相容受不。须达多言。若佛哀愍必见垂顾。便当自竭营办成立。善男子。我于尔时默然受请。须达长者已蒙听许即白我言。我从昔来未为斯事。惟愿如来。遣舍利弗指授仪则。我即顾命敕令营佐。时舍利弗与须达多共载一车往舍卫城。我神力故。经一日夜便到所止。时须达多白舍利弗。大德。此大城外何处有地。不近不远多饶泉池。有好林树花果郁茂清净闲豫。我当于中为佛世尊及比丘僧造立精舍。舍利弗言。只陀园林不近不远。清净寂寞多有泉池树。木花果随时而有。此处最胜可安立精舍。时须达多闻是语已。即往只陀大长者所。告只陀言。我今欲为无上法王造立僧坊。惟仁园地任中造立。吾今欲买能见与不。只陀答言。设以真金遍布其地犹不相与。须达多言。善哉只陀。林地属我。汝便取金。只陀答言。我园不卖云何取金。须达多言。若意不了当共往诣断事人所。时二长者即共俱往断事者所。断事者言。园属须达只陀取金。须达长者即时使人车马载负随集布地。一日之中唯五百步金未周遍。只陀言曰。长者。若悔随意听止。须达多言。吾不悔也。自念当出何藏金足。只陀念言。如来法王真实无上。所说妙法清净无染。故使斯人轻宝乃尔。即语须达。余未遍者不复须金。请以见与。我自为佛造立门楼。常使如来经由出入。只陀长者自造门楼。须达长者七日之中成立大房足三百口。禅房静处六十三所。冬室夏堂各各别异。厨坊浴室洗脚之处。大小圊厕无不备足。所设已讫即执香炉向王舍城遥作是言。所设已办惟愿如来。慈哀怜愍为诸众生受是住处。我时玄知是长者心。即与大众发王舍城。譬如壮士屈伸臂顷。至舍卫城只陀园林须达精舍。我既到已。须达长者以其所设奉施于我。我时受已即住其中

大般涅槃经卷第二十九大般涅槃经卷第三十

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之四

时诸六师心生嫉妒。悉共集诣波斯匿王作如是言。大王当知。王之土境清夷闲静。真是出家住止之处。是故我等为斯事故而来至此。大王。以法正治为民除患。沙门瞿昙年既幼稚。学日又浅道术无施。此国先有耆旧宿德。自怙王种不生恭敬。若是王种法应治民。如其出家应敬宿德。大王善听。沙门瞿昙真实不生王种之中。瞿昙沙门若有父母何由劫夺他之父母。大王。我经中说。过千岁已有一妖祥幻化物出。所谓沙门瞿昙是也。是故当知。沙门瞿昙无父无母。若有父母云何说言诸法无常苦空无我无作无受。以幻术故诳惑众生。愚者信受智者舍之。大王。夫人王者天下父母。如秤如地如风如火如道如河如桥如灯如日如月。如法断事不择怨亲。沙门瞿昙不听我活。随我去处追逐不舍。惟愿大王。听我等辈与彼瞿昙较其道力。若彼胜我我当属彼。我若胜彼彼当属我。王言。大德。汝等各各自有行法。止住之处亦各不同。我今定知。如来世尊于汝无妨。六师答言。云何无妨。沙门瞿昙以幻术法诱诳诸人及婆罗门归伏已尽。王若听我与较道力。王之善名流布八方。如其不者恶声盈路。王言。大德。汝以未知如来道力威神巍巍故求较试。若定知者恐不能也。大王。汝今已受瞿昙幻耶。唯愿大王。留神听察。莫轻我等构之虚言。不如验之以实。王言。善哉善哉。六师之徒欢喜而出。时波斯匿王即敕严驾来至我所。头面敬礼右绕三匝退坐一面而白我言。世尊。六师向来求较道力。我不量度敢已许之

佛言。大王。善哉善哉。但当更于此国处处造立僧坊。何以故。我若与彼较其神力。彼众之中受化者多。此处狭小云何容受。善男子。我于尔时为六师故。从初一日至十五日。现大希有神通变化。当是时也。无量众生发阿耨多罗三藐三菩提心。无量众生于三宝所生信不疑。六师徒众其数无量。破邪见心正法出家。无量众生于菩提中得不退心。无量众生得陀罗尼诸三昧门。无量众生得须陀洹果至阿罗汉果

尔时六师内心惭愧。相与围绕至婆枳多城。教彼人民信受邪法。瞿昙沙门但说空事。善男子。我时为母处忉利天波利质多树安居说法。是时六师心大欢喜唱言。善哉。瞿昙幻术今已灭没。复教无量无数众生增长邪见。尔时频婆娑罗王波斯匿王。及四部众白目连言。大德。此阎浮提邪见增长。众生可愍行大黑闇。惟愿大德。至彼天上稽首世尊如我言曰。譬如犊子其生未久若不得乳必死无疑。我等众生亦复如是。惟愿如来。哀愍众生还来住此。尔时目连默然而许。如大力士屈伸臂顷往彼天上。至世尊所白佛言。阎浮提中所有四众渴仰如来思见闻法。频婆娑罗王波斯匿王及四众等稽首足下。此阎浮提所有众生邪见增长。行大黑闇甚可怜愍譬如犊子其生未久若不得乳必死不疑。我等亦尔。惟愿如来。为众生故。还来在此阎浮提中。佛告目连。汝今速还至阎浮提。告诸国王及四部众。却后七日我当还下。为六师故复当至彼婆枳多城。过七日已我与释天梵天魔天无量天子及首陀会一切天人。前后围绕至婆枳多城。大师子吼作如是言。惟我法中独有沙门及婆罗门。一切诸法无常无我涅槃寂静离诸过恶。若言他法亦有沙门及婆罗门。有常有我有涅槃者无有是处。尔时无量无边众生发阿耨多罗三藐三菩提心。是时六师各相谓言。若我法中实无沙门婆罗门者。云何而得世间供养于是六师。复相集聚诣毗舍离。善男子。我于一时住毗舍离庵罗林间。时庵罗女知我在中。欲来我所。我于尔时告诸比丘。当观念处善修智慧随所修习心莫放逸。云何名为观于念处。若有比丘观察内身不见于我及以我所。观察外身及内外身不见于我及以我所。观受心法亦复如是。是名念处。云何名为修习智慧。若有比丘真实而见苦集灭道。是名比丘修习智慧。云何名为心不放逸。若有比丘念佛念法念僧念戒念舍念天。是名比丘心不放逸。时庵罗女即至我所。头面作礼右绕三匝。修敬已毕却坐一面。善男子。我于尔时为庵罗女如应说法。是女闻已发阿耨多罗三藐三菩提心。时彼城中有梨车子其数五百来至我所。头面作礼右绕三匝。修敬已毕却坐一面。我时复为诸梨车子如应说法。诸善男子。夫放逸者有五事果。何等为五。一者不得自在财利。二者恶名流布于外。三者不乐慧施穷乏。四者不乐见于四众。五者不得诸天之身。诸善男子。因不放逸能生世法出世间法。若有欲得阿耨多罗三藐三菩提者。应当勤修不放逸法。夫放逸者。复有十三果报。何等十三。一者乐为世间作业。二者乐说无益之言。三者常乐久寝睡眠。四者乐说世间之事。五者常乐亲近恶友。六者常懈怠懒惰。七者常为他人所轻。八者虽有所闻寻复忘失。九者乐处边地。十者不能调伏诸根。十一者食不知足。十二者不乐空寂。十三者所见不正。是名十三。善男子。夫放逸者。虽得近佛及佛弟子犹故为远。诸梨车子言。我等自知是放逸人。何以故。如其我等不放逸者。如来法王当出我土。时大会中有婆罗门子。名曰无胜。语诸梨车子。善哉善哉。如汝所言。频婆娑罗王已获大利。如来世尊出其国土。犹如大池生妙莲花。虽生在水水不能污。诸梨车子。佛亦如是。虽生彼国不为世法之所滞碍。诸佛世尊无出无入。为众生故出现于世。不为世法之所滞碍。仁等。自迷耽荒五欲。不知亲近往如来所。是故名为放逸之人。非佛出于摩伽陀国名放逸也。何以故。如来世尊犹彼日月。非为一人二人出世。时诸梨车闻是语已。寻发阿耨多罗三藐三菩提心。复作是言。善哉善哉。无胜童子。快说如是善妙之言。时诸梨车各各脱身所著一衣以施无胜。无胜受已。转以奉我。复作是言。世尊。我从梨车得是衣物。惟愿如来。哀愍众生受我所献。我于尔时。愍彼无胜即为纳受。时诸梨车同时合掌。作如是言。惟愿如来。于此土地一时安居受我微供。我时默然受梨车请。是时六师闻是事已。师宗相与诣波罗奈城。尔时我复往波罗奈住波罗河边。时波罗奈有长者子。名曰宝称。耽荒五欲不知非常。以我到故自然而得白骨观法。见其殿舍宫人婇女悉为白骨。心生怖惧如刀毒蛇如贼如火。即出其舍来诣我所随路而言。瞿昙沙门。我今如为贼所追逐甚大怖惧。愿见救济。佛言。善男子。佛法众僧安隐无惧。长者子言。若三宝中无所畏者。我今亦当得无所畏。我即听其出家为道。时长者子复有同友其数五十。遥闻宝称厌欲出家。即共和顺相与出家。六师闻已展转复诣瞻婆大城。时瞻婆大国一切人民悉共奉事六师之徒。初未曾闻佛法僧名。多有诸人作极恶业。我于尔时为众生故往瞻婆城。时彼城中有大长者无有继嗣。供事六师以求子息。其后不久妇则怀妊。长者知已。往六师所欢喜而言。我妇怀妊男耶女耶。六师答言。生必是女。长者闻已心生愁恼。复有知识来谓长者。何故愁恼乃如是耶。长者答言。我妇怀妊未知男女故问六师。六师见语如我相法生必是女。我闻是语自惟年老财富无量。如其非男无所付嘱是故我愁。知识复言。汝无智慧先不闻耶。优楼频螺迦叶兄弟为谁弟子。佛耶六师耶。六师若是一切智者。迦叶何故舍之不事为佛弟子。又舍利弗目犍连等及诸国王频婆娑罗等。诸王夫人末利夫人等。诸国长者须达多等。如是诸人非佛弟子耶。旷野鬼神阿阇世王护财醉象鸯掘魔罗。恶心炽盛欲害其母。如是等辈斯非如来所调伏耶。长者。如来世尊于一切法知见无碍故名为佛。发言无二故名如来。断烦恼故名阿罗诃。世尊所说终无有二。六师不尔。云何可信。如来今者近在此住。若欲实知当诣佛所。尔时长者即与是人来诣我所。头面作礼右绕三匝。合掌长跪而作是言。世尊。于诸众生平等无二怨亲一相。我为爱结之所系缚。于怨亲中未能无二。我今欲问如来世事。深自愧惧未敢发言。世尊。我妇怀妊六师相言。生必是女。是事云何。佛言。长者。汝妇怀妊是男无疑。其儿生已福德无比。尔时长者闻我语已生大欢喜便退还家。尔时六师闻我玄记生者必男有大福德。心生嫉妒以庵罗果和合毒药。持往其家语长者言。快哉瞿昙。善说其相汝妇临月可服此药。服此药已儿则端正产者无患。长者欢喜受其毒药与妇令服服已寻死。六师欢喜周遍城市高声唱言。沙门瞿昙。记彼长者。妇当生男其儿福德天下无胜。今儿未生母已丧命。尔时长者复于我所生不信心。即依世法殡殓棺盖送至城外。多积干薪以火焚之。我以道眼明见此事顾命阿难。取我衣来吾欲往彼摧灭邪见

时毗沙门天告摩尼跋陀大将而作是言。如来。今欲诣彼冢间。卿可速往平治扫洒安师子座求妙花香庄严其地。尔时六师遥见我往。各相谓言。瞿昙沙门。至此冢间欲啖肉耶。是时多有未得法眼诸优婆塞。各怀差愧而白我言。彼妇已死愿不须往。尔时阿难语众人言。且待须臾如来不久当广开阐诸佛境界。我时到已坐师子座。长者难言。所言无二可名世尊。母已终亡云何生子。我言。长者卿于尔时都不见问母命修短。但问所怀为是男女。诸佛如来发言无二。是故当知。定必得子。是时死尸火烧腹裂。子从中出端坐火中。犹如鸳鸯处莲花台。六师见已复作是言。妖哉瞿昙。善为幻术。长者见已心复欢喜呵责六师。若言幻者汝何不作。我于尔时寻告耆婆。汝往火中抱是儿来。耆婆欲往。六师前牵语耆婆言。瞿昙沙门。所作幻术未必常尔。或能不能如其不能脱相烧害。汝今云何信受其言。耆婆答言。如来使入阿鼻地狱所有猛火尚不能烧。况世间火。尔时耆婆前入火聚。犹入清凉大河水中。抱持是儿还诣我所授儿与我。我受儿已告长者言。一切众生寿命不定如水上泡。众生若有殷重业果。火不能烧毒不能害。是儿业果非我所作。时长者言。善哉世尊。是儿若得尽其天命。惟愿如来为立名字。佛言。长者。是儿生于猛火之中。火名树提。应名树提。尔时会中见我神化。无量众生发阿耨多罗三藐三菩提心。尔时六师周遍六城不得停足惭愧低头。复来至此拘尸那城。既至此已唱如是言。诸人当知。沙门瞿昙。是大幻师诳惑天下遍六大城。譬如幻师幻作四兵。所谓车兵马兵象兵步兵。又复幻作种种璎珞城郭宫宅河池树木。沙门瞿昙。亦复如是。幻作王身为说法故。或作沙门身婆罗门身男身女身小身大身。或作畜生鬼神之身。或说无常或说有常。或时说苦或时说乐。或说有我或说无我。或说有净或说无净。或时说有或时说无。所为虚妄故名为幻。譬如因子随子得果。瞿昙沙门。亦复如是。摩耶所生母既是幻。子不得非。沙门瞿昙。无实知见。诸婆罗门经年积岁修习苦行护持禁戒。尚言未有真实知见。何况瞿昙年少学浅不修苦行。云何而有真实知见。若能具满七年苦行见犹不多。况所修习不满六年。愚人无智信受其教。如大幻师诳惑愚者。沙门瞿昙。亦复如是。善男子。如是六师于此城中大为众生增长邪见。善男子。我见是事心生怜愍。以其神力请召十方诸大菩萨。云集此林周匝弥满四十由延。今于此中大师子吼。善男子。虽于空处多有所说。则不得名师子吼也。于此智人大众之中。真得名为大师子吼。师子吼者。说一切法悉无常苦无我不净。惟说如来常乐我净。尔时六师复作是言。若瞿昙。有我我亦有我。所言我者见者名我。瞿昙。譬如有人向中见物。我亦如是。向喻于眼。见者喻我。佛告六师。若言见者名我。是义不然。何以故。汝所引喻因向见者。人在一向六根俱用。若定有我因眼见者。何不如彼一根之中俱伺诸尘。若一根中不能一时闻见六尘。当知无我。所引向喻虽经百年见者因之所见无异。眼根若尔。年迈根熟亦应无异。人向异故见内见外。眼根若尔。亦应内外一时俱见。若不见者云何有我。六师复言。瞿昙。若无我者谁能见耶。佛言。有色有明有心有眼。是四和合故名为见。是中实无见者受者。众生颠倒言有见者及以受者。以是义故。一切众生所见颠倒。诸佛菩萨所见真实。六师。若言色是我者。是亦不然。何以故。色实非我。色若是我不应而得丑陋形貌。何故复有四姓差别。悉不一种婆罗门耶。何故属他不得自在。诸根缺陋生不具足。何故不作诸天之身。而受地狱畜生饿鬼种种诸身。若不能得随意作者。当知。必定无有我也。以无我故名为无常。无常故苦。苦故为空。空故颠倒。以颠倒故一切众生轮转生死。受想行识亦复如是。六师。如来世尊永断色缚乃至识缚。是故名为常乐我净。复次色者即是因缘。若因缘者则名无我。若无我者名为苦空。如来之身非是因缘。非因缘故则名有我。若有我者即常乐净。六师复言。瞿昙。色亦非我乃至识亦非我。我者遍一切处犹如虚空。佛言。若遍有者则不应言我初不见。若初不见则知是见本无今有。若本无今有是名无常。若无常者云何言遍。若遍有者五道之中应具有身。若有身者应各受报。若各受报云何而言转受人天。汝言遍者一耶多耶。我若一者则无父子怨亲中人。我若多者一切众生所有五根悉应平等。所有业慧亦应如是。若如是者云何说言根有具足不具足者。善业恶业愚智差别。瞿昙。众生我者无有边际。法与非法则有分齐。众生修法则得好身。若行非法则得恶身。以是义故。众生业果不得无差

佛言。善男子。法与非法若如是者我则不遍。我若遍者则应悉到。如其到者修善之人亦应有恶。行恶之人亦应有善。若不尔者云何言遍。瞿昙。譬如一室然百千灯。各各自明不相妨碍。众生我者亦复如是。修善行恶不相杂合。善男子。汝等若言我如灯者。是义不然。何以故。彼灯之明从缘而有。灯增长故明亦增长。众生我者则不如是明从灯出住在异处。众生我者不得如是从身而出住在异处。彼灯光明与闇共住。何以故。如闇室中然一灯时照则不了。及至多灯乃得明了。若初灯破闇则不须后灯。若须后灯。当知。初明与闇共住。瞿昙。若无我者谁作善恶

佛言。若我作者云何名常。如其常者。云何而得有时作善有时作恶。若言有时作善恶者。云何复得言我无边。若我作者。何故而复习行恶法。如其我是作者。智者何故生疑。众生无我。以是义故外道法中定无有我。若言我者则是如来。何以故。身无边故无疑网故。不作不受故名为常。不生不灭故名为乐。无烦恼垢故名为净。无有十相故名为空。是故如来常乐我净空无诸相。诸外道言。若言如来常乐我净无相故空。当知瞿昙所说之法则非空也。是故我今当顶戴受持。尔时外道其数无量。于佛法中信心出家。善男子。以是因缘故我于此娑罗双树大师子吼。师子吼者名大涅槃。善男子。东方双者破于无常获得于常。乃至北方双者破于不净而得于净。善男子。此中众生为双树故护娑罗林。不令外人取其枝叶斫截破坏。我亦如是。为四法故令诸弟子护持佛法。何等名四。常乐我净。此四双树四王典掌。我为四王护持我法。是故于中而般涅槃。善男子。娑罗双树花果常茂。常能利益无量众生。我亦如是。常能利益声闻缘觉。花者喻我。果者喻乐。以是义故。我于此间婆罗双树入大寂定。大寂定者名大涅槃。师子吼言。世尊。如来何故二月涅槃善男子。二月名春。春阳之月万物生长。种植根栽花果敷荣。江河盈满百兽孚乳。是时众生多生常想。为破众生如是常心。说一切法悉是无常。惟说如来常住不变。善男子。于六时中孟冬枯悴众不爱乐。春阳和液人所贪爱。为破众生世间乐故。演说常乐我净亦尔。如来为破世我世净故说如来真实我净。言二月者。喻于如来二种法身。冬不乐者。智者不乐如来无常入于涅槃。二月乐者。喻于智者爱乐如来常乐我净。种植者。喻诸众生闻法欢喜发阿耨多罗三藐三菩提心种诸善根。河者。喻于十方诸大菩萨来诣我所咨受如是大涅槃典。百兽孚乳者。喻我弟子生诸善根。花喻七觉果喻四果。以是义故。我于二月入大涅槃。师子吼言。如来初生出家成道转妙法轮皆以八日。何故涅槃独十五日。佛言。善哉善哉。善男子。如十五日月无亏盈。诸佛如来亦复如是。入大涅槃无有亏盈。以是义故。以十五日入般涅槃。善男子。如十五日月盛满时有十一事。何等十一。一能破闇。二令众生见道非道。三令众生见道邪正。四除郁蒸得清凉乐。五能破坏荧火高心。六息一切贼盗之想。七除众生畏恶兽心。八能开敷优钵罗花。九合莲花。十引发行人进路之心。十一令诸众生乐受五欲多获快乐。善男子。如来满月亦复如是。一者破坏无明大闇。二者演说正道邪道。三者开示生死邪崄。涅槃平正。四者令人远离贪欲嗔恚痴热。五者破坏外道无明。六者破坏烦恼结贼。七者除灭畏五盖心。八者开敷众生种善根心。九者覆盖众生五欲之心。十者发起众生进修趣向大涅槃行。十一者令诸众生乐修解脱。以是义故。于十五日入大涅槃。而我真实不入涅槃。我弟子中愚痴恶人。定谓如来入于涅槃。譬如母人多有诸子。其母舍行至他国土。未还之顷诸子各言。我母已死。而是母人实不死也

师子吼菩萨言。世尊。何等比丘能庄严此娑罗双树。善男子。若有比丘受持读诵十二部经。正其文句通达深义为人解说初中后善。为欲利益无量众生演说梵行。如是比丘则能庄严娑罗双树。师子吼菩萨言。世尊。如我解佛所说义者。阿难比丘即其人也。何以故。阿难比丘受持读诵十二部经。为人开说正语正义。犹如写水置之异器。阿难比丘亦复如是。从佛所闻如闻转说

善男子。若有比丘得净天眼见于十方三千大千世界所有。如观掌中庵摩勒果。如是比丘亦能庄严娑罗双树。师子吼言。世尊。若如是者。阿尼楼驮比丘即其人也。何以故。阿尼楼驮。天眼见于三千大千世界所有乃至中阴。悉能明了无障碍故

善男子。若有比丘少欲知足心乐寂静。勤行精进念定慧解。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。迦叶比丘即其人也。何以故。迦叶比丘善修少欲知足等法

善男子。若有比丘为益众生故不为利养。修习通达无诤三昧圣行空行。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。须菩提比丘即其人也。何以故。须菩提者。善修无诤圣行空行故

善男子。若有比丘善修神通。一念之中能作种种神通变化。一心一定能作二果所谓水火。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。目连比丘即其人也。何以故。目揵连者。善修神通无量变化故

善男子。若有比丘修习大智利智疾智解脱智甚深智广智无边智无胜智实智。具足成就如是慧根。于怨亲中心无差别。若闻如来涅槃无常心不忧戚。若闻常住不入涅槃不生欣庆。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。舍利弗比丘即其人也。何以故。舍利弗者。善能成就具足如是大智慧故

善男子。若有比丘能说众生悉有佛性得金刚身无有边际。常乐我净身心无碍得八自在。如是比丘则能庄严娑罗双树。师子吼言。世尊。若如是者。惟有如来即其人也。何以故。如来之身金刚无边。常乐我净身心无碍具八自在故。世尊。惟有如来乃能庄严娑罗双树。如其无者则不端严。惟愿大慈。为庄严故常住于此娑罗林中。佛言。善男子。一切诸法性无住住。汝云何言愿如来住。善男子。凡言住者名为色法。从因缘生故名为住。因缘无处故名不住住。如来已断一切色缚。云何当言如来住耶。受想行识亦复如是。善男子。住名憍慢。以憍慢故不得解脱。不得解脱故名为住。谁有憍慢从何处来。是故得名为无住住。如来永断一切憍慢。云何而言愿如来住。住者名有为法。如来已断有为之法是故不住。住名空法。如来已断如是空法。是故获得常乐我净。云何而言愿如来住。住者名为二十五有。如来已断二十五有。云何而言愿如来住。住者即是一切凡夫。诸圣无去无来无住。如来已断去来住相。云何言住。夫无住者名无边身。身无边故云何而言惟愿如来住娑罗林。若住此林则是有边身。若有边则是无常。如来是常云何言住。夫无住者名曰虚空。如来之性同于虚空云何言住。又无住者名金刚三昧。金刚三昧坏一切住。金刚三昧即是如来云何言住。又无住者。则名为幻。如来同幻云何言住。又无住者名无始终。如来之性无有始终云何言住。又无住者名无边法界。无边法界即是如来云何言住。又无住者名首楞严三昧。首楞严三昧知一切法而无所著。以无著故名首楞严。如来具足首楞严定云何言住。又无住者名处非处力。如来成就处非处力云何言住。又无住者名檀波罗蜜。檀波罗蜜若有住者。则不得至尸波罗蜜乃至般若波罗蜜。以是义故。檀波罗蜜名为无住。如来乃至不住般若波罗蜜。云何愿言如来常住娑罗树林。又无住者名修四念处。如来若住四念处者。则不能得阿耨多罗三藐三菩提。是名不住住。又无住者名无边众生界。如来悉到一切众生无边界分而无所住。又无住者名无屋宅。无屋宅者名为无有。无有者名为无生。无生者名为无死。无死者名为无相。无相者名为无系。无系者名为无著。无著者名为无漏。无漏即善善即无为。无为者即大涅槃。大涅槃即常常者即我。我者即净净者即乐。常乐我净即是如来。善男子。譬如虚空不住东方南西北方四维上下。如来亦尔。不住东方南西北方四维上下。善男子。若有说言身口意恶得善果者无有是处。身口意善得恶果者亦无是处。若言凡夫得见佛性。十住菩萨不得见者亦无是处。一阐提辈犯五逆罪谤方等经毁四重禁。得阿耨多罗三藐三菩提者亦无是处。六住菩萨烦恼因缘堕三恶道亦无是处。菩萨摩诃萨以真女身得阿耨多罗三藐三菩提者亦无是处。一阐提常三宝无常亦无是处。如来住于拘尸那城亦无是处。善男子。如来今于此拘尸那城入大三昧深禅定窟。众不见故名入涅槃

师子吼言。如来何故入禅定窟。善男子。为欲度脱诸众生故。未种善根者令得种故。已种善根者得增长故。善果未熟令得熟故。为已熟者说趣阿耨多罗三藐三菩提故。轻贱善法者令生尊重故。诸有放逸者令离放逸故。为与文殊师利等诸大香象共论议故。为欲教化乐读诵者深爱禅定故。为以圣行梵行天行教化众生故。为观不共深法藏故。为欲呵责放逸弟子故。如来常寂犹尚乐定。况汝等辈烦恼未尽而生放逸。为欲呵责诸恶比丘受畜八种不净之物及不少欲不知足故。为令众生尊重所闻禅定法故。以是因缘入禅定窟

师子吼言。世尊。无相定者名大涅槃。是故涅槃名为无相。以何因缘名为无相。善男子。无十相故。何等为十。所谓色相声相香相味相触相生住坏相男相女相。是名十相。无如是相故名无相。善男子。夫着相者则能生痴。痴故生爱。爱故系缚。系缚故受生。受生故有死。死故无常。不着相者则不生痴。不生痴故则无有爱。无有爱故则无系缚。无系缚故则不受生。不受生故则无有死。无有死故则名为常。以是义故涅槃名常。师子吼言。世尊。何等比丘能断十相。佛言。善男子。若有比丘数数修习三种相者则断十相。数数修习三昧定相。数数修习智慧之相。数数修习舍相。是名三相。师子吼言。世尊。云何名为定慧舍相。定是三昧者。一切众生皆有三昧。云何方言修习三昧。若心在一境则名三昧。若更余缘则不名三昧。如其不定非一切智。非一切智云何名定。若以一行得三昧者。其余诸行亦非三昧。若非三昧则非一切智。若非一切智云何名三昧。慧舍二相亦复如是佛言。善男子。如汝所言缘于一境得名三昧其余诸缘不名三昧。是义不然。何以故。如是余缘亦一境故行亦如是。又言众生先有三昧不须修者。是亦不然。所以者何。言三昧者名善三昧。一切众生真实未有。云何而言不须修习。以住如是善三昧中观一切法名善慧相。不见三昧智慧异相。是名舍相

复次善男子。若取色相不能观色常无常相。是名三昧。若能观色常无常相。是名慧相。三昧慧等观一切法。是名舍相。善男子。如善御驾驷迟疾得所。迟疾得所故名舍相。菩萨亦尔。若三昧多者则修习慧。若慧多者则修习三昧。三昧慧等则名为舍。善男子。十住菩萨智慧力多三昧力少。是故不得明见佛性。声闻缘觉三昧力多智慧力少。以是因缘不见佛性。诸佛世尊定慧等故明见佛性了了无碍。如观掌中庵摩勒果。见佛性者名为舍相。奢摩他者名为能灭。能灭一切烦恼结故。又奢摩他者名曰能调。能调诸根恶不善故。又奢摩他者名曰寂静。能令三业成寂静故。又奢摩他者名曰远离。能令众生离五欲故。又奢摩他者名曰能清。能清贪欲嗔恚愚痴三浊法故。以是义故故名定相。毗婆舍那名为正见。亦名了见。名为能见。名曰遍见。名次第见。名别相见。是名为慧。忧毕叉者。名曰平等。亦名不诤。又名不观。亦名不行。是名为舍。善男子。奢摩他者有二种。一者世间。二者出世间。复有二种。一者成就。二不成就。成就者。所谓诸佛菩萨。不成就者。所谓声闻辟支佛等。复有三种。谓下中上。下者谓诸凡夫。中者声闻缘觉。上者诸佛菩萨。复有四种。一者退。二者住。三者进。四者能大利益。复有五种。所谓五智三昧。何等为五。一者无食三昧。二者无过三昧。三者身意清净一心三昧。四者因果俱乐三昧。五者常念三昧。复有六种。一者观骨三昧。二者。慈三昧。三者观十二因缘三昧。四者阿那婆那三昧。五者正念觉观三昧。六者观生灭住异三昧。复有七种。所谓七觉分。一者念处觉分。二者择法觉分。三者精进觉分。四者喜觉分。五者除觉分。六者定觉分。七者舍觉分。复有七种。一者须陀洹三昧二者斯陀含三昧。三者阿那含三昧。四者阿罗汉三昧。五者辟支佛三昧。六者菩萨三昧。七者如来觉知三昧。复有八种。谓八解脱三昧。一者内有色相外观色解脱三昧。二者内无色相外观色解脱三昧。三者净解脱身证三昧。四者空处解脱三昧。五者识处解脱三昧。六者无所有处解脱三昧。七者非有想非无想处解脱三昧。八者灭尽定处解脱三昧。复有九种所谓九次第定。四禅四空及灭尽定三昧。复有十种。所谓十一切处三昧。何等为十。一者地一切处三昧。二者水一切处三昧。三者风一切处三昧。四者青一切处三昧。五者黄一切处三昧。六者赤一切处三昧。七者白一切处三昧。八者空一切处三昧。九者识一切处三昧。十者无所有一切处三昧。复有无数种。所谓诸佛菩萨。善男子。是名三昧相。善男子。慧有二种。一者世间。二者出世间。复有三种一者般若。二者毗婆舍那。三者阇那。般若者名一切众生。毗婆舍那者一切圣人。阇那者诸佛菩萨。又般若者名为别相。毗婆舍那者名为总相。阇那者名为破相。复有四种。所谓观四真谛。善男子。为三事故修奢摩他。何等为三。一者不放逸故。二者庄严大智故。三者得自在故。复次为三事故修毗婆舍那。何等为三。一者为观生死恶果报故。二者为欲增长诸善根故。三者为破一切诸烦恼故

大般涅槃经卷第三十大般涅槃经卷第三十一

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之五

师子吼言。世尊。如经中说。若毗婆舍那能破烦恼。何故复修奢摩他耶。佛言。善男子。汝言毗婆舍那破烦恼者。是义不然。何以故。有智慧时则无烦恼。有烦恼时则无智慧。云何而言毗婆舍那能破烦恼。善男子。譬如明时无闇闇时无明。若有说言明能破闇。无有是处。善男子。谁有智慧。谁有烦恼。而言智慧能破烦恼。如其无者则无所破。善男子。若言智慧能破烦恼。为到故破不到故破。若不到破者。凡夫众生则应能破。若到故破者。初念应破。若初念不破后亦不破。若初到便破是则不到。云何说言智慧能破。若言到与不到而能破者。是义不然。复次毗婆舍那破烦恼者。为独能破。为伴故破。若独能破菩萨何故修八正道。若伴故破。当知独则不能破也。若独不能伴亦不能。如一盲人不能见色。虽伴众盲亦不能见。毗婆舍那亦复如是。善男子。如地坚性火热性水湿性风动性。而地坚性乃至风动性。非因缘作。其性自尔。如四大性烦恼亦尔。性自是断。若是断者。云何而言智慧能断。以是义故。毗婆舍那决定不能破诸烦恼。善男子。如盐性碱令异物碱。蜜本性甘令异物甘。水本性湿令异物湿。智慧性灭令法灭者。是义不然。何以故。若法无灭。云何智慧强能令灭。若言盐碱令异物碱。慧灭亦尔。能令异法灭者。是亦不然。何以故。智慧之性念念灭故。若念念灭。云何而言能灭他法。以是义故。智慧之性不破烦恼。善男子。一切诸法有二种灭。一者性灭。二者毕竟灭。若性灭者。云何而言智慧能灭。若言智慧能烧烦恼如火烧物。是义不然。何以故。如火烧物则有遗烬。智慧若尔应有余烬。如斧伐树斫处可见。智慧若尔有何可见。慧若能令烦恼离者。如是烦恼应余处现。如诸外道离六大城拘尸那现。若是烦恼不余处现。则知智慧不能令离。善男子。一切诸法性若自空谁能令生。谁能令灭。异生异灭无造作者。善男子。若修习定则得如是正知正见以是义故。我经中说。若有比丘修习定者。能见五阴生灭之相。善男子。若不修定。世间之事尚不能了。况于出世。若无定者。平处颠坠。心缘异法。口宣异言。耳闻异语。心解异义。欲造异字手书异文。欲行异路身涉异径。若有修习三昧定者。则大利益。乃至阿耨多罗三藐三菩提

善男子。菩萨摩诃萨具足二法能大利益。一者定。二者智。善男子。如刈菅草执急则断。菩萨摩诃萨修是二法。亦复如是。善男子。如拔坚木先以手动后则易出。菩萨定慧亦复如是。先以定动后以智拔。善男子。如浣垢衣先以灰汁后以清水衣则鲜洁。菩萨定慧亦复如是。善男子。如先读诵后则解义。菩萨定慧亦复如是。善男子。譬如勇人先以铠仗牢自庄严。然后御阵能坏怨贼。菩萨定慧亦复如是。善男子。譬如巧匠钳鐹盛金自在随意挠搅融消。菩萨定慧亦复如是。善男子。譬如明镜照了面像。菩萨定慧亦复如是。善男子。如先平地然后下种。先从师受后思惟义。菩萨定慧亦复如是。以是义故。菩萨摩诃萨修是二法能大利益。善男子。菩萨摩诃萨修是二法。调摄五根堪忍众苦。所谓饥渴寒热打掷骂辱。恶兽所啮蚊虻所螫。常摄其心不令放逸。不为利养行于非法。客尘烦恼所不能污。不为诸邪异见所惑。常能远离诸恶觉观。不久成就阿耨多罗三藐三菩提。为欲成就利众生故。善男子。菩萨摩诃萨修是二法。四倒暴风不能吹动。如须弥山虽为四风之所吹鼓不能令动。不为外道邪师所拔。如帝释幢不可移转。众邪异术不能诳惑。常受微妙第一安乐。能解如来深秘密义。受乐不欣逢苦不戚。诸天世人恭敬赞叹。明见生死及非生死。善能了知法界法性。身有常乐我净之法。是则名为大涅槃乐

善男子。定相者名空三昧。慧相者名无愿三昧。舍相者名无相三昧。善男子若有菩萨摩诃萨善知定时慧时舍时及知非时。是名菩萨摩诃萨行菩提道。师子吼言。世尊。云何菩萨知时非时。善男子。菩萨摩诃萨因于受乐生大憍慢。或因说法而生憍慢。或因精勤而生憍慢。或因解义善问答时而生憍慢。或因亲近恶知识故而生憍慢。或因布施所重之物而生憍慢。或因世间善法功德而生憍慢。或因世间豪贵之人所恭敬故而生憍慢。当知尔时不宜修智宜应修定。是名菩萨知时非时。若有菩萨勤修精进。未得利益涅槃之乐。以不得故生于悔心。以钝根故不能调伏五情诸根。诸垢烦恼势力盛故。自疑戒律有羸损故。当知尔时不宜修定宜应修智。是名菩萨知时非时。善男子。若有菩萨定慧二法不平等者。当知尔时不宜修舍。二法若等则宜修之。是名菩萨知时非时。善男子。若有菩萨修习定慧起烦恼者。当知尔时不宜修舍。宜应读诵书写解说十二部经。念佛念法念僧念戒念天念舍。是名修舍。善男子。若有菩萨修习如是三法相者。以是因缘得无相涅槃

师子吼言。世尊。无十相故名大涅槃为无相者。复以何缘。名为无生无出无作屋宅洲归安隐灭度涅槃寂静无诸病苦无所有耶。佛言。善男子。无因缘故。故名无生。以无为故。故名无出。无造业故。故名无作。不入五见故名屋宅。离四瀑水故名为洲。调众生故。故名归依。坏结贼故。故名安隐。诸结火灭故名灭度离觉观故。名曰涅槃。远愦闹故。名曰寂静。永断必死故名无病。一切无故名无所有。善男子。若菩萨摩诃萨作是观时。即得明了见于佛性。师子吼言。世尊。菩萨摩诃萨成就几法。能见如是无相涅槃至无所有。佛言。善男子。菩萨摩诃萨成就十法。则能明见涅槃无相至无所有。何等为十。一者信心具足。云何名为信心具足。深信佛法众僧是常。十方诸佛方便示现。一切众生及一阐提悉有佛性。不信如来生老病死及修苦行。提婆达多真实破僧出佛身血。如来毕竟入于涅槃正法灭尽。是名菩萨信心具足。二者净戒具足。云何名为净戒具足。善男子。若有菩萨自言戒净。虽不与彼女人和合。见女人时或生嘲调言语戏笑。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽不与彼女人身合嘲调戏笑。于壁障外遥闻女人璎珞环钏种种诸声心生爱着。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽复不与女人和合言语嘲调听其音声。然见男子随逐女时。或见女人随逐男时。便生贪着。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。复有菩萨自言戒净。虽复不与女人和合言语嘲调听其音声见男女相随。然为生天受五欲乐。如是菩萨成就欲法毁破净戒。污辱梵行令戒杂秽。不得名为净戒具足。善男子。若有菩萨清净持戒。而不为戒不为尸罗波罗蜜。不为众生不为利养。不为菩提不为涅槃。不为声闻辟支佛。唯为最上第一义故护持禁戒。善男子。是名菩萨净戒具足。三者亲近诸善知识。善知识者。若有能说信戒多闻布施智慧令人受行。是名菩萨善知识也。四者乐于寂静。寂静者。所谓身心寂静观察诸法甚深法界。是名寂静。五者精进。精进者。所谓系心观四真谛设头火然终不放舍。是名精进。六者念具足。念具足者。所谓念佛念法念僧念戒念天念舍。是名念具足。七者软语。软语者。所谓实语妙语先意问讯时语真语。是名软语。八者护法。护法者。所谓爱乐正法常乐演说。读诵书写思惟其义。广宣敷扬令其流布。若见有人书写解说读诵赞叹思惟义者。为求资生而供养之。所谓衣服饮食卧具医药。为护法故不惜身命。是名护法。九者菩萨摩诃萨见有同学同戒有所乏少。转从他乞熏钵染衣。瞻病所须衣服饮食卧具房舍而供给之。十者具足智慧。智慧者。所谓观于如来常乐我净。一切众生悉有佛性。观法二相。所谓空不空常无常乐无乐我无我净不净。异法可断异法不可断。异法从缘生异法从缘见。异法从缘果异法非缘果。是名具足智慧。善男子。是名菩萨具足十法。即能明见涅槃无相师子吼言。世尊。如佛先告纯陀。汝今已得见于佛性得大涅槃。成就阿耨多罗三藐三菩提。是义云何。世尊。如经中说。若施畜生得百倍报。施一阐提得千倍报。施持戒者百千倍报。若施外道断烦恼者得无量报。奉施四向及以四果至辟支佛得无量报。施不退菩萨及最后身诸大菩萨如来世尊。所得福报无量无边不可称计不可思议。纯陀大士。若受如是无量报者。是报无尽。何时当得阿耨多罗三藐三菩提。世尊。经中复说。若人重心造善恶业必得果报。若现世受。若次生受。若后世受。纯陀善业殷重心作。当知是业必定受报。若定受报。云何得成阿耨多罗三藐三菩提。云何复得见于佛性。世尊。经中复说。施三种人果报无尽。一者病人。二者父母。三者如来。世尊。经中复说。佛告阿难。一切众生如其无有欲界业者。即得阿耨多罗三藐三菩提。色无色业亦复如是。世尊。如法句偈。非空非海中。非入山石间。无有地方所。脱之不受业。又阿尼楼驮言。世尊。我忆往昔以一食施。八万劫中不堕三恶。世尊。一食之施尚得是报。何况纯陀信心施佛。具足成就檀波罗蜜。世尊。若善果报不可尽者。谤方等经犯五逆罪毁四重禁一阐提罪云何可尽。若不可尽。云何能得见于佛性成阿耨多罗三藐三菩提。佛言。善哉善哉。善男子。唯有二人能得无量无边功德。不可称计不可宣说。能竭生死漂流瀑河。降魔怨敌摧魔胜幢。能转如来无上法轮。一者善问。二者善答。善男子。佛十力中业力最深。善男子。有诸众生于业缘中心轻不信。为度彼故作如是说。善男子。一切作业有轻有重。轻重二业复各有二。一者决定。二者不决定。善男子。或有人言恶业无果。若言恶业定有果者。云何气嘘旃陀罗而得生天。鸯掘摩罗得解脱果。以是义故。当知作业有定得果不定得果。我为除断如是邪见。故于经中说如是语。一切作业无不得果。善男子或有重业可得作轻。或有轻业可得作重。非一切人唯有愚智。是故当知非一切业悉定得果。虽不定得。亦非不得。善男子。一切众生凡有二种。一者智人。二者愚痴。有智之人以智慧力。能令地狱极重之业现世轻受。愚痴之人现世轻业地狱重受。师子吼言。世尊。若如是者。则不应求清净梵行及解脱果。佛言。善男子。若一切业定得果者。则不应求梵行解脱。以不定故则修梵行及解脱果。善男子。若能远离一切恶业则得善果。若远善业则得恶果。若一切业定得果者。则不应求修习圣道。若不修道则无解脱。一切圣人所以修道。为坏定业得轻报故。不定之业无果报故。若一切业定得果者。则不应求修习圣道。若人远离修习圣道得解脱者。无有是处。不得解脱得涅槃者。亦无是处。善男子。若一切业定得果者。一世所作纯善之业。应当永已常受安乐。一世所作极重恶业。亦应永已受大苦恼。业果若尔则无修道解脱涅槃。人作人受。婆罗门作婆罗门受。若如是者。则不应有下姓下人。人应常人。婆罗门应常婆罗门。小时作业应小时受。不应中年及老时受。老时作恶生地狱中。地狱初身不应便受。应待老时然后乃受。若老时不杀不应壮年得寿。若无壮寿云何至老。业无失故。业若无失。云何而有修道涅槃。善男子。业有二种。定以不定。定业有二。一者报定。二者时定。或有报定而时不定。缘合则受。或三时受。所谓现受生受后受。善男子。若定心作善恶等业。作已深生信心欢喜。若发誓愿供养三宝。是名定业。善男子。智者善根深固难动。是故能令重业为轻。愚痴之人不善深厚。能令轻业而作重报。以是义故。一切诸业不名决定。菩萨摩诃萨无地狱业。为众生故发大誓愿生地狱中。善男子。往昔众生寿百年时。恒沙众生受地狱报。我见是已即发大愿受地狱身。菩萨尔时实无是业。为众生故受地狱果。我于尔时在地狱中经无量岁。为诸罪人广开分别十二部经。诸人闻已坏恶果报令地狱空。除一阐提。是名菩萨摩诃萨非现生后受是恶业。复次善男子。是贤劫中无量众生堕畜生中受恶业果。我见是已复发誓愿。为欲说法度众生故。或作獐鹿熊罴猕猴龙蛇金翅鸟鸽鱼鳖兔象牛马之身。善男子。菩萨摩诃萨实无如是畜生恶业。以大愿力为众生故现受是身。是名菩萨摩诃萨非现生后受是恶业。复次善男子。是贤劫中复有无量无边众生生饿鬼中。或食吐汁脂肉脓血屎尿涕唾。寿命无量百千万岁。初不曾闻浆水之名。况复眼见而得饮也。设遥见水生意往趣。到则变成猛火脓血。或时不变则有多人手执矛槊遮护捉持不令得前。或天降雨至身成火。是名恶业果报。善男子。菩萨摩诃萨实无如是诸恶业果。为化众生令得解脱。故发誓愿受如是身。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫生屠脍家。畜养鸡猪牛羊弶猎罗网[敲-高+(虎-儿+魚)]捕。旃陀罗舍作贼劫盗。菩萨实无如是恶业。为度众生令得解脱。以大愿力受如是身。是名菩萨摩诃萨非现生后受是恶业。善男子。是贤劫中复生边地。多作贪欲嗔恚愚痴习行非法。不信三宝后世果报。不能恭敬父母亲老耆旧长宿。善男子。菩萨尔时实无是业。为令众生得解脱故。以大愿力而生其中。是名菩萨摩诃萨非现生后受是恶业。善男子。是贤劫中复受女身恶身贪身嗔身痴身妒身悭身幻身诳身缠盖之身。善男子。菩萨尔时亦无是业。但为众生得解脱故。以大愿力愿生其中。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫受黄门身无根二根及不定根。善男子。菩萨摩诃萨实无如是诸恶身业。为令众生得解脱故。以大愿力愿生其中。是名菩萨摩诃萨非现生后受是恶业。善男子。我于贤劫复习外道尼干子法。信受其法无施无祠无施祠报。无善恶业无善恶业报。无现在世及未来世。无此无彼无有圣人。无变化身无道涅槃。善男子。菩萨实无如是恶业。但为众生令得解脱。以大愿力受是邪法。是名菩萨摩诃萨非现生后受是恶业

善男子。我念往昔与提婆达多俱为商主。各各自有五百商人。为利益故至大海中采取珍宝。恶业缘故路遇暴风吹破船舫伴党死尽。尔时我与提婆达多。不杀果报长寿缘故。为风所吹俱至陆地。时提婆达多贪惜宝货生大忧苦发声啼哭。我时语言提婆达多不须啼哭。提婆达多即语我言。谛听谛听譬如有人贫穷困苦。至冢墓间手捉死尸而作是言。愿汝今者施我死乐。我当施汝贫穷寿命。尔时死尸即便起坐语贫人言。善男子。贫穷寿命汝自受之。我今甚乐如是死乐。实不欣汝贫穷而生。然我今日既无死乐兼复贫穷。云何而得不啼哭耶。我复慰喻汝且莫愁。今有二珠价直无数。当分一枚以相惠施。我即分与复语之言。有命之人能得此宝。如其无命谁能得耶。我时疲弊诣一树下止息眠卧提婆达多贪心炽盛。为余一珠即生恶心刺坏我目劫夺我珠。我时患疮发声呻号。时有一女。来至我所而问我言。仁者。何故呻号如是。我即为其广说本事。女人闻已复重问我汝名字何。我即答言。名为实语。女言。云何知汝为实语耶。我即立誓。若我今于提婆达多有恶心者。目当如是永为盲瞽。如其无者当还得眼。言已其目平复如故。善男子。是名菩萨摩诃萨说现世报

善男子。我念往昔生南天竺富单那城婆罗门家。是时有王名迦罗富。其性暴恶憍慢自大。年壮色美耽着五欲。我于尔时为度众生在彼城外寂默禅思。尔时彼王春木花敷与其眷属宫人婇女出城游观在树林下五欲自娱。其诸婇女舍王游戏遂至我所。我时欲为断彼贪故而为说法。时王寻来即见我时。便生恶心而问我言。汝今已得罗汉果耶。我言不得。复言。获得不还果耶。我言不得。复作是言。汝今若未得是二果。则为具足贪欲烦恼。云何自恣观我女人。我即答言。大王。当知我今虽未断于贪结。然其内心实无贪着。王言。痴人世有诸仙服气食果见色犹贪。况汝盛年未断贪欲。云何见色而当不贪。我言。大王。见色不着实不因于服气食果。皆由系心无常不净。王言。若有轻他而生诽谤。云何得名修持净戒。我言。大王。若有妒心则有诽谤。我无妒心云何言谤。王言。大德。云何名戒。大王。忍名为戒。王言。若忍是戒者。当截汝耳若能忍者知汝持戒。即截其耳时我被截颜色不变。时王群臣见是事已即谏王言。如是大士不应加害。王告诸臣。汝等云何知是大士。诸臣答言。见受苦时容色不变。王复语言。我当更试知变不变。即劓其鼻刖其手足。尔时菩萨已于无量无边世中修习慈悲愍苦众生。时四天王心怀嗔忿雨沙砾石。王见是已心大怖畏。复至我所长跪而言。唯愿哀愍听我忏悔。我言。大王。我心无嗔亦如无贪。王言。大德。云何得知心无嗔恨。我即立誓我若真实无嗔恨者。令我此身平复如故。发是愿已身即平复。是名菩萨摩诃萨说现世报善男子。善业生报后报。及不善业亦复如是。菩萨摩诃萨得阿耨多罗三藐三菩提时。一切诸业悉得现报。不善恶业得现报者。如王作恶天降恶雨。亦如有人示猎师罴处及宝色鹿其手堕落。是名恶业现受果报。生报者。如一阐提犯四重禁及五逆罪。后报者。如持戒人深发誓愿。愿未来世常得如是净戒之身。若有众生寿百年时八十年时。于中当作转轮圣王教化众生。善男子。若业定得现世报者。则不能得生报后报。菩萨摩诃萨修三十二大人相业。则不能得现世报也。若业不得三种报者。是名不定。善男子。若言诸业定得报者。则不得有修习梵行解脱涅乐。当知是人非我弟子是魔眷属。若言诸业有定不定。定者现报生报后报。不定者缘合则受不合不受。以是义故。应有梵行解脱涅槃。当知是人真我弟子非魔眷属。善男子。一切众生不定业多决定业少。以是义故有修习道。修习道故决定重业可使轻受。不定之业非生报受。善男子。有二种人。一者。不定作定报。现报作生报。轻报作重报。应人中受在地狱受。二者。定作不定。应生受者回为现受。重报作轻。应地狱受人中轻受。如是二人一愚二智。智者为轻愚者令重。善男子。譬如二人于王有罪。眷属多者其罪则轻。眷属少者应轻更重。愚智之人亦复如是。智者善业多故重则轻受。愚者善业少故轻则重受。善男子。譬如二人一则肥壮一则羸瘦。俱没深泥肥壮能出羸者则没。善男子。譬如二人俱共服毒。一有咒力及阿伽陀。一者无有赖咒药者毒不能伤。其无咒药服时即死。善男子。譬如二人俱多饮浆。一火力势盛一则微弱。火势多者则能消化。火势弱者则为其患。善男子。譬如二人为王所系。一有智慧一则愚痴。其有智者则能得脱。愚痴之人无有脱期。善男子。譬如二人俱涉险路。一则有目一则盲瞽。有目之人直过无患。盲者坠落堕深坑险。善男子。譬如二人俱共饮酒。一则多食一则少食。其多食者饮则无患。其少食者饮则成患。善男子。譬如二人俱敌怨阵。一则铠仗具足庄严一则白身。其有仗者能破怨敌。其自身者不能自勉。复有二人粪秽污衣。一觉寻浣一觉不浣。其寻浣者衣则净洁。其不浣者垢秽日增。复有二人俱共乘车。一有副轴一无副轴。有副轴者随意而去。无副轴者则不移处。复有二人俱行旷路。一有资粮一则空往。有资粮者则得度险。其空往者则不能过。复有二人为贼所劫。一有宝藏一则无藏。有宝藏者心无忧戚。其无藏者心则愁恼。愚智之人亦复如是。有善藏者重业轻受。无善藏者轻业重受

师子吼菩萨言。世尊。如佛所说非一切业悉得定果。非一切众生定受。世尊。云何众生令现轻报地狱重受。地狱重报现世轻受。佛言。一切众生凡有二种。一者有智。二者愚痴。若能修习身戒心慧。是名智者。若不能修身戒心慧。是名愚者。云何名为不修习身。若不能摄五情诸根名不修身。不能受持七种净戒名不修戒。不调心故名不修心。不修圣行名不修慧。复次不修身者。不能具足清净戒体。不修戒者。受畜八种不净之物。不修心者。不能修习三种相故。不修慧者。不修梵行故。复次不修身者。不能观身不能观色及观色相。不观身相不知身数。不知是身从此到彼。于非身中而生身相。于非色中而作色相。是故贪着我身身数。名不修身。不修戒者。若受下戒不名修戒。受持边戒为自利戒为自调戒。不能普为安乐众生。非为护持无上正法。为生天上受五欲乐。不名修戒。不修心者。若心散乱不能专一守自境界。自境界者谓四念处。他境界者所谓五欲。若不能修四念处者。名不修心。于恶业中不善护心。名不修慧。复次不修身者。不能深观是身无常无住危脆念念灭坏是魔境界。不修戒者。不能具足尸波罗蜜。不修心者。不能具足禅波罗蜜。不修慧者。不能具足般若波罗蜜。复次不修身者。贪着我身及我所身。我身常恒无有变易。不修戒者。为自身故作十恶业。不修心者。于恶业中不能摄心。不修慧者。以不摄心不能分别善恶等法。复次不修身者不断我见。不修戒者不断戒取。不修心者作贪嗔业趣向地狱。不修慧者不断痴心。复次不修身者。不能观身虽无过咎而常是怨。善男子。譬如男子有怨常逐伺求其便。智者觉已系心慎护。若不慎护则为其害。一切众生身亦如是。常以浆水饮食冷暖调适将养。若不如是将护守慎即当散坏。善男子。如婆罗门奉事火天。常以香花赞叹礼拜供养承事期满百年。若一触时寻烧人手。是火虽得如是供养。终无一念报事者恩。一切众生身亦如是。虽于多年以好香花璎珞衣服饮食卧具病瘦医药而供给之。若遇内外诸恶因缘即时灭坏。都不忆念往日供给衣食之恩。善男子。譬如有王畜四毒蛇置之一箧。以付一人仰令瞻养。是四蛇中设一生嗔则能害人。是人恐怖常求饮食随时守护。一切众生四大毒蛇亦复如是。若一大嗔则能坏身。善男子。如人久病应当至心求医疗治。若不勤救必死不疑。一切众生身亦如是。常应摄心不令放逸。若放逸者即便灭坏。善男子。譬如坏瓶不耐风雨打掷捶押。一切众生身亦如是。不耐饥渴寒热风雨打系恶骂。善男子。如痈未熟常当善护不令人触。设有触者即大苦痛。一切众生身亦如是。善男子。如骡怀妊自害其躯。一切众生身亦如是。内有风冷身即受害。善男子。譬如芭蕉生实则枯。一切众生身亦如是。善男子。亦如芭蕉内无坚实。一切众生身亦如是。善男子。如蛇鼠狼各各相于常生怨心。众生四大亦复如是。善男子。譬如鹅王。不乐冢墓。菩萨亦尔于身冢墓亦不贪乐。善男子。如旃陀罗七世相继不舍其业。是故为人之所轻贱。是身种子亦复如是。种子精血究竟不净。以不净故诸佛菩萨之所轻呵。善男子。是身不如摩罗耶山生于栴檀。亦不能生优钵罗花芬陀利花瞻婆花摩利迦花婆师迦花。九孔常流脓血不净。生处臭秽丑陋可恶。常与诸虫共在一处。善男子。譬如世间虽有上妙清净园林。死尸于中则为不净。众共舍之不生爱着。色界亦尔虽复净妙以有身故。诸佛菩萨悉共舍之

善男子。若有不能作如是观。名不修身不修戒者。善男子。若不能观戒是一切善法梯橙。亦是一切善法根本。如地悉是一切树木所生之本。是诸善根之导首也。如彼商主导众商人。戒是一切善法胜幢。如天帝释所立胜幢。戒能永断一切恶业及三恶道。能疗恶病犹如药树。戒是生死险道资粮。戒是摧结破贼铠仗。戒是灭结毒蛇良咒。戒是度恶业行桥梁。若有不能如是观者。名不修戒。不修心者。不能观心轻躁动转难捉难调。驰骋奔逸如大恶象。念念迅速如彼电光。躁扰不住犹如猕猴。如幻如炎乃是一切诸恶根本。五欲难满。如火获薪。亦如大海吞受诸流。如曼陀山草木滋多。不能观察生死虚妄。耽惑致患如鱼吞钩。常先引导诸业随从。犹如贝母引导诸子。贪着五欲不乐涅槃。如鮀食蜜乃至于死。不顾刍草深着现乐不观后过。如牛贪苗不惧杖楚。驰骋周遍二十五有。犹如疾风吹兜罗[卄/毦]。所不应求求无厌足。如无智人求无热火。常乐生死不乐解脱。如纴婆虫乐纴婆树。迷惑爱着生死臭秽。犹如狱囚乐狱卒女。亦如厕猪乐处不净。若有不能如是观者。名不修心。不修慧者。不观智慧有大势力如金翅鸟。能坏恶业坏无明闇犹如日光。能拔阴树如水漂物。焚烧邪见犹如猛火。慧是一切善法根本。佛菩萨母之种子也。若有不能如是观者。不名修慧。善男子。第一义中若见身身相身因身果身聚身一身二此身彼身身灭身等身修修者。若有如是见者。名不修身。善男子。若见戒戒相戒因戒果上戒下戒戒聚戒一戒二此戒彼戒戒灭戒等戒修修者戒波罗蜜。若有如是见者。名不修戒若见心心相心因心果心聚心及心数心一心二此心彼心心灭心等心修修者上中下心善心恶心。若有如是见者。名不修心。善男子。若见慧慧相慧因慧果慧聚慧一慧二此慧彼慧慧灭慧等上中下慧钝慧利慧慧修修者。若有如是见者。名不修慧。善男子。若有不修身戒心慧。如是之人。于小恶业得大恶报。以恐怖故常生是念。我属地狱作地狱行。虽闻智者说地狱苦。常作是念如铁打铁石还打石木自打木火虫乐火。地狱之身还似地狱。若似地狱有何苦事。譬如苍蝇为唾所粘不能得出。是人亦尔于小罪中不能自出。心初无悔不能修善覆藏瑕疵。虽有过去一切善业。悉为是罪之所垢污。是人所有现受轻报。转为地狱极重恶果。善男子。如小器水置盐一升。其味碱苦难可得饮。是人罪业亦复如是。善男子。譬如有人负他一钱不能偿故身被系缚多受众苦。是人罪业亦复如是。师子吼菩萨言。世尊。是人何故令现轻报转地狱受。佛言。善男子。一切众生若具五事令现轻报转地狱受。何等为五。一者愚痴故。二者善根微少故。三者恶业深重故。四者不忏悔故。五者不修本善业故。复有五事。一者修习恶业故。二者无戒财故。三者远离诸善根故。四者不修身戒心慧故。五者亲近恶知识故。善男子。是故能令现世轻报地狱重受。师子吼言。世尊。何等人能转地狱报现世轻受。善男子。若有修习身戒心慧如先所说。能观诸法同如虚空。不见智慧不见智者。不见愚痴不见愚者。不见修习及修习者。是名智者。如是之人则能修习身戒心慧。是人能令地狱果报现世轻受。是人设作极重恶业。思惟观察能令轻微。作是念言我业虽重不如善业。譬如[疊*毛]花虽复百斤终不能敌真金一两。如恒河中投一升盐水无碱味饮者不觉。如巨富者虽多负人千万宝物。无能系缚令其受苦。如大香象能坏铁锁自在而去。智慧之人亦复如是。常思惟言我善力多恶业羸弱。我能发露忏悔除罪恶业能修智慧。智慧力多无明力少。如是念已亲近善友修习正见。受持读诵书写解说十二部经。见有受持读诵书写解说之者。心生恭敬兼以衣食房舍卧具病药花香。而供养之赞叹尊重所至到处称说其善不讼其短。供养三宝敬信方等大涅槃经。如来常恒无有变易。一切众生悉有佛性。是人能令地狱重报现世轻受。善男子。以是义故。非一切业悉有定果。亦非一切众生定受

大般涅槃经卷第三十一大般涅槃经卷第三十二

        北凉天竺三藏昙无谶译

    师子吼菩萨品第十一之六

师子吼菩萨言。世尊。若一切业不定得果。一切众生悉有佛性。应当修习八圣道者。何因缘故。一切众生悉不得是大般涅槃。世尊。若一切众生有佛性者。即当定得阿耨多罗三藐三菩提。何须修习八圣道耶。世尊。如此经中说有病人若得医药及瞻病人随病饮食。若使不得皆悉除差。一切众生亦复如是。若遇声闻及辟支佛诸佛菩萨诸善知识。若闻说法修习圣道。若不遇不闻不修习道。悉当得成阿耨多罗三藐三菩提。何以故。以佛性故。世尊。譬如日月无有能遮令不得至頞多山边。四大河水不至大海。一阐提等不至地狱。一切众生亦复如是。无有能遮令不得至阿耨多罗三藐三菩提。何以故。以佛性故。世尊。以是义故。一切众生不须修道。以佛性力故应得阿耨多罗三藐三菩提。不以修习圣道力故。世尊。若一阐提犯四重禁五逆罪等。不得阿耨多罗三藐三菩提者。应须修习以因佛性定当得故。非因修习然后得也。世尊。譬如磁石去铁虽远。以其力故铁则随着。众生佛性亦复如是。是故不须勤修习道。佛言。善哉善哉。善男子。如恒河边有七种人。若为洗浴恐畏寇贼。或为采花则入河中。第一人者入水则沈。何以故。羸无势力不习浮故。第二人者虽没还出出已复没。何以故。身力大故则能还出。不习浮故出已还没。第三人者没已即出出更不没。何以故。身重故没力大故出。先习浮故出已即住。第四人者入已便没没已还出。出已即住遍观四方。何以故。重故则沈力大故还出习浮则住。不知出处故观四方。第五人者入已即沉沉已便出。出已即住住已观方。观已即去。何以故。为怖畏故。第六人者入已即去浅处则住。何以故。观贼近远故。第七人者既至彼岸登上大山无复恐怖。离诸怨贼受大快乐。善男子。生死大河亦复如是。有七种人畏烦恼贼故。发意欲渡生死大河。出家剃发身被法服。既出家已亲近恶友。随顺其教听受邪法。所谓众生身者即是五荫。五荫者即名五大。众生若死永断五大。断五大故何须修习善恶诸业。是故当知无有善恶及善恶报。如是则名一阐提也。一阐提者名断善根。断善根故没生死河不能得出。何以故。恶业重故无信力故。如恒河边第一人也。善男子。一阐提辈有六因缘。没三恶道不能得出。何等为六。一者恶心炽盛故。二者不见后世故。三者乐习烦恼故。四者远离善根故。五者恶业障隔故。六者亲近恶知识故。复有五事没三恶道。何等为五。一者于比丘边作非法故。二者比丘尼边作非法故。三者自在用僧鬘物故。四者母边作非法故。五者于五部僧互生是非故。复有五事没三恶道。何等为五。一者常说无善恶果故。二者杀发菩提心众生故。三者喜说法师过失故。四者法说非法非法说法故。五者为求法过而听受故。复有三事没三恶道。何等为三。一谓如来无常永灭。二谓正法无常迁变。三谓僧宝可灭坏故。是故常没三恶道中。第二人者。发意欲渡生死大河。断善根故没不能出。所言出者亲近善友则得信心。是信心者。信施施果信善善果信恶恶果。信生死苦无常败坏。是名为信。以得信心修习净戒。受持读诵书写解说。常乐惠施善修智慧。以钝根故复遇恶友。不能修习身戒心慧。听受邪法或值恶时处恶国土断诸善根。断善根故常没生死。如恒河边第二人也。第三人者。发意欲渡生死大河。断善根故于中沉没。亲近善友得名为出。信于如来是一切智常恒无变为众生故说无上道。一切众生悉有佛性如来非灭法僧亦尔无有灭坏。一阐提等不断其法。终不能得阿耨多罗三藐三菩提。要当远离然后乃得。以信心故修习净戒。修习戒已受持读诵书写解说十二部经。为诸众生广宣流布。乐于惠施修习智慧。以利根故坚住信慧心无退转。如恒河边第三人也。第四人者。发意欲渡生死大河。断善根故于中沉没。亲近善友故得信心是名为出。得信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧。心无退转遍观四方。观四方者四沙门果。如恒河边第四人也。第五人者。发意欲渡生死大河。断善根故于中沉没。亲近善友故得信心是名为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于慧施修习智慧。以利根故坚住信慧心无退转。无退转已即便前进。前进者谓辟支佛。虽能自渡不及众生是名为去。如恒河边第五人也。第六人者。发意欲渡生死大河。断善根故于中沉没。亲近善友获得信心。得信心故名之为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧心无退转。无退转已即复前进遂到浅处。到浅处已即住不去。住不去者所谓菩萨。为欲度脱诸众生故住观烦恼。如恒河边第六人也。第七人者。发意欲渡生死大河。断善根故于中沉没。亲近善友获得信心。得信心已是名为出。以信心故受持读诵书写解说十二部经。为众生故广宣流布。乐于惠施修习智慧。以利根故坚住信慧心。无退转。无退转已即便前进既前进已得到彼岸登大高山。离诸恐怖多受安乐。善男子。彼岸山者喻于如来。受安乐者喻佛常住。大高山者喻大涅槃。善男子。是恒河边如是诸人。悉具手足而不能渡。一切众生亦复如是。实有佛宝法宝僧宝。如来常说诸法要义。有八圣道大般涅槃。而诸众生悉不能得。此非我咎亦非圣道。众生等过。当知悉是烦恼过恶。以是义故。一切众生不得涅槃。善男子。譬如良医知病说药。病者不服非医咎也。善男子。如有施主以其所有施一切人。有不受者非施主咎。善男子。譬如日出幽冥皆明。盲瞽之人不见道路非日过也。善男子。如恒河水能除渴乏。渴者不饮非水咎也。善男子。譬如大地普生果实平等无二。农夫不种非地过也。善男子。如来普为一切众生广开分别十二部经。众生不受非如来咎。善男子。若修道者即得阿耨多罗三藐三菩提。善男子。汝言众生悉有佛性。应得阿耨多罗三藐三菩提如磁石者。善哉善哉。以有佛性因缘力故得阿耨多罗三藐三菩提。若言不须修圣道者。是义不然。善男子。譬如有人行于旷野渴乏遇井。其井幽深虽不见水当知必有。是人方便求觅罐绠汲取则见。佛性亦尔一切众生虽复有之。要须修习无漏圣道然后得见。善男子。如有胡麻则得见油。离诸方便则不得见。甘蔗亦尔。善男子。如三十三天北郁单越。虽是有法若无善业神通道力则不。能见。地中草根及地下水。以地覆故众生不见。佛性亦尔不修圣道故不得见。善男子。如汝所说世有病人。若遇瞻病良医好药随病饮食。及以不遇悉得差者。善男子。我为六住诸菩萨等说如是义。善男子。譬如虚空于诸众生非内非外。非内外故亦无挂碍。众生佛性亦复如是。善男子。譬如有人财在异方虽不现前随意受用。有人问之则言我许。何以故以定有故。众生佛性亦复如是。非此非彼以定得故言一切有。善男子。譬如众生造作诸业若善若恶非内非外。如是业性非有非无。亦复非是本无今有。非无因出。非此作此受此作彼受。彼作彼受无作无受。时节和合而得果报。众生佛性亦复如是。亦复非是本无今有。非内非外非有非无非此非彼。非余处来非无因缘。亦非一切众生不见。有诸菩萨时节因缘和合得见时节者所谓十住菩萨摩诃萨修八圣道。于诸众生得平等心。尔时得见不名为作。善男子。汝言如磁石者。是义不然。何以故石不吸铁。所以者何无心业故。善男子。异法有故异法出生。异法无故异法灭坏。无有作者无有坏者。善男子。犹如猛火不能焚薪。火出薪坏名为焚薪善男子。譬如葵藿随日而转。而是葵藿亦无敬心无识无业。异法性故而自回转。善男子。如芭蕉树因雷增长。是树无耳无心意识。异法有故异法增长。异法无故异法灭坏。善男子。如阿叔迦树。女人摩触花为之出。是树无心亦无觉触。异法有故异法出生。异法无故异法灭坏。善男子。如橘得尸果则滋多。而是橘树无心无触。异法有故异法滋多。异法无故异法灭坏。善男子。如安石榴塼骨粪故果实繁茂。安石榴树亦无心触。异法有故异法出生。异法无故异法灭坏。善男子。磁石吸铁亦复如是。异法有故异法出生。异法无故异法灭坏。众生佛性亦复如是。不能吸得阿耨多罗三藐三菩提。善男子。无明不能吸取诸行。行亦不能吸取识也。亦得名为无明缘行行缘于识。有佛无佛法界常住

善男子。若言佛性住众生中者。善男子。常法无住若有住处即是无常。善男子。如十二因缘无定住处。若有住处十二因缘不得名常。如来法身亦无住处。法界法入法阴虚空悉无住处。佛性亦尔都无住处善男子。譬如四大力虽均等。有坚有热有湿有动。有重有轻有赤有白有黄有黑。而是四大亦无有业。异法界故各不相似。佛性亦尔异法界故时至则现。善男子。一切众生不退佛性故名之为有。阿毗跋致故以当有故。决定得故定当见故。是故名为一切众生悉有佛性。善男子。譬如有王告一大臣。汝牵一象以示盲者。尔时大臣受王敕已。多集众盲以象示之。时彼众盲各以手触。大臣即还而白王言。臣已示竟。尔时大王。即唤众盲各各问言。汝见象耶。众盲各言。我已得见。王言。象为何类。其触牙者即言象形如芦菔根。其触耳者言象如箕。其触头者言象如石。其触鼻者言象如杵。其触脚者言象如木臼。其触脊者言象如床。其触腹者言象如瓮。其触尾者言象如绳。善男子。如彼众盲不说象体亦非不说。若是众相悉非象者。离是之外更无别象。善男子。王喻如来正遍知也。臣喻方等大涅槃经。象喻佛性。盲喻一切无明众生。是诸众生闻佛说已。或作是言色是佛性。何以故。是色虽灭次第相续。是故获得无上如来三十二相如来色常。如来色者常不断故。是故说色名为佛性。譬如真金质虽迁变色常不异。或时作钏作[金*毘]作盘。然其黄色初无改易。众生佛性亦复如是质虽无常而色是常。以是故说色为佛性。或有说言受是佛性。何以故。受因缘故获得如来真实之乐。如来受者谓毕竟受第一义受。众生受性虽复无常。然其次第相续不断。是故获得如来常受。譬如有人姓憍尸迦。人虽无常而姓是常。经千万世无有改易。众生佛性亦复如是。以是故说受为佛性。又有说言想是佛性。何以故。想因缘故获得如来真实之想。如来想者名无想想。无想想者非众生想非男女想。亦非色受想行识想非想断想。众生之想虽复无常。以想次第相续不断。故得如来常恒之想。善男子。譬如众生十二因缘。众生虽灭而因缘常。众生佛性亦复如是。以是故说想为佛性。又有说言行为佛性。何以故。行名寿命寿因缘故。获得如来常住寿命。众生寿命虽复无常。而寿次第相续不断。故得如来真实常寿。善男子。譬如十二部经。听者说者虽复无常。而是经典常存不变。众生佛性亦复如是。以是故说行为佛性。又有说言识为佛性。识因缘故获得如来平等之心。众生意识虽复无常。而识次第相续不断。故得如来真实常心。如火热性火虽无常热非无常。众生佛性亦复如是。以是故说识为佛性。又有说言离阴有我我是佛性。何以故。我因缘故获得如来八自在我。有诸外道说言。去来见闻悲喜语说为我。如是我相虽复无常。而如来我真实是常善男子。如阴入界虽复无常而名是常。众生佛性亦复如是。善男子。如彼盲人各各说象。虽不得实非不说象。说佛性者亦复如是。非即六法不离六法。善男子。是故我说众生佛性非色不离色。乃至非我不离我。善男子。有诸外道虽说有我而实无我。众生我者即是五阴。离阴之外更无别我。善男子。譬如茎叶须台合为莲花。离是之外更无别花。众生我者亦复如是。善男子。譬如墙壁草木和合名之为舍。离是之外更无别舍。如佉陀罗树波罗奢树尼拘陀树郁昙钵树和合为林。离是之外更无别林。譬如车兵象马步兵和合为军。离是之外更无别军。譬如五色杂线和合名之为绮。离是之外更无别绮。如四姓和合名为大众。离是之外更无别众。众生我者亦复如是。离五阴外更无别我。善男子。如来常住则名为我。如来法身无边无碍不生不灭。得八自在是名为我。众生真实无如是我及以我所。但以必定当得毕竟第一义空故名佛性。善男子。大慈大悲名为佛性。何以故。大慈大悲常随菩萨如影随形。一切众生必定当得大慈大悲。是故说言一切众生悉有佛性。大慈大悲者名为佛性。佛性者名为如来。大喜大舍名为佛性。何以故。菩萨摩诃萨若不能舍二十五有。则不能得阿耨多罗三藐三菩提。以诸众生必当得故。是故说言一切众生悉有佛性。大喜大舍者即是佛性。佛性者即是如来。佛性者名大信心。何以故。以信心故菩萨摩诃萨则能具足檀波罗蜜乃至般若波罗蜜。一切众生必定当得大信心故。是故说言一切众生悉有佛性。大信心者即是佛性。佛性者即是如来。佛性者名一子地。何以故。以一子地因缘故。菩萨则于一切众生得平等心。一切众生必定当得一子地故。是故说言一切众生悉有佛性。一子地者即是佛性。佛性者即是如来。佛性者名第四力。何以故。以第四力因缘故。菩萨则能教化众生。一切众生必定当得第四力故。是故说言一切众生悉有佛性。第四力者即是佛性。佛性者即是如来。佛性者名十二因缘。何以故。以因缘故如来常住一切众生定有如是十二因缘。是故说言一切众生悉有佛性。十二因缘即是佛性。佛性者即是如来。佛性者名四无碍智。以四无碍因缘故说字义无碍。字义无碍故能化众生。四无碍者即是佛性。佛性者即是如来。佛性者名顶三昧。以修如是顶三昧故。则能总摄一切佛法。是故说言顶三昧者名为佛性。十住菩萨修是三昧未得具足。虽见佛性而不明了。一切众生必定得故。是故说言一切众生悉有佛性。善男子。如上所说种种诸法。一切众生定当得故。是故说言一切众生悉有佛性。善男子。我若说色是佛性者。众生闻已则生邪倒。以邪倒故命终则生阿鼻地狱。如来说法为断地狱。是故不说色是佛性。乃至说识亦复如是。善男子。若有众生了佛性者则不须修道。十住菩萨修八圣道少见佛性。况不修者而得见耶。善男子。如文殊师利诸菩萨等已无量世修习圣道了知佛性。云何声闻辟支佛等能知佛性。若诸众生欲得了了知。佛性者。应当一心受持读诵书写解说供养恭敬尊重赞叹是涅槃经。见有受持乃至赞叹如是经者。应当以好房舍衣服饮食卧具病瘦医药而供给之。兼复赞叹礼拜问讯。善男子。若有已于过去无量无边世中。亲近供养无量诸佛深种善根。然后乃得闻是经名。善男子。佛性不可思议。佛法僧宝亦不可思议。一切众生悉有佛性而不能知是亦不可思议。如来常乐我净之法亦不可思议。一切众生能信如是大涅槃经亦不可思议。师子吼菩萨言。世尊。如佛所说一切众生能信如是大涅槃经不可思议者。世尊。是大众中有八万五千亿人。于是经中不生信心。是故有能信是经者。名不可思议。善男子。如是诸人于未来世亦当定得信是经典。见于佛性得阿耨多罗三藐三菩提

师子吼言。世尊。云何不退菩萨自知决定有不退心。佛言。善男子。菩萨摩诃萨当以苦行自试其心。日食一胡麻经一七日。粳米菉豆麻子粟[麾-毛+黍]及以白豆亦复如是各一七日。食一麻时作是思惟。如是苦行都无利益。无利益事尚能为之。况有利益而当不作。于无利益心能堪忍不退不转。是故定得阿耨多罗三藐三菩提。如是等日修苦行时。一切皮肉消瘦皱减如断生瓠置之日中。其目欠陷如井底星。肉尽肋出如朽草屋。脊骨连现如重线塼。所坐之处如马蹄迹。欲坐则伏欲起则偃。虽受如是无利益苦。然不退于菩提之心。复次善男子。菩萨摩诃萨为破众苦施安乐故。乃至能舍内外财物及其身命如弃刍草。若能不惜是身命者。如是菩萨自知必定有不退心。我定当得阿耨多罗三藐三菩提。复次菩萨为法因缘。剜身为灯[疊*毛]缠皮肉苏油灌之烧以为炷。菩萨尔时受是大苦。自呵其心而作是言。如是苦者于地狱苦。百千万分未是一分。汝于无量百千劫中受大苦恼都无利益。汝若不能受是轻苦。云何而能于地狱中救苦众生。菩萨摩诃萨作是观时身不觉苦。其心不退不动不转。菩萨尔时应深自知。我定当得阿耨多罗三藐三菩提。善男子。菩萨尔时具足烦恼未有断者。为法因缘能以头目髓脑手足血肉施于众生。以钉钉身投岩赴火。菩萨尔时虽受如是无量众苦。若心不退不动不转。菩萨当知我今定有不退之心。当得阿耨多罗三藐三菩提。善男子。菩萨摩诃萨为破一切众生苦恼。愿作粗大畜生之身。以身血肉施于众生。众生取时复生怜愍。菩萨尔时闭气不喘示作死相。令彼取者不生杀害疑网之想。菩萨虽受畜生之身。终不造作畜生之业。何以故。善男子。菩萨既得不退心已。终不造作三恶道业。菩萨摩诃萨若未来世有微尘等恶业果报不定受者。以大愿力为众生故而悉受之。譬如病人为鬼所著藏隐身中。以咒力故即时相现。或语或喜或嗔或骂或啼或哭菩萨摩诃萨未来之世三恶道业亦复如是。菩萨摩诃萨受熊身时。常为众生演说正法。或受迦宾阇罗鸟身。为诸众生说正法故。受瞿陀身鹿身兔身象身羖羊身猕猴白鸽金翅鸟龙蛇之身。受如是等畜生身时。终不造作畜生恶业。常为其余畜生众生演说正法。令彼闻法速得转离畜生身故。菩萨尔时虽受畜生身不作恶业。当知必定有不退心。菩萨摩诃萨于饥馑世见饿众生。作龟鱼身无量由延复作是愿。愿诸众生取我肉时随取随生。因食我肉离饥渴苦。一切悉发阿耨多罗三藐三菩提心。菩萨发愿若有因我离饥渴者。未来之世速得远离二十五有饥渴之患菩萨摩诃萨受如是苦心不退者。当知必定得阿耨多罗三藐三菩提。复次菩萨于疾疫世见病苦者作是思惟。如药树王若有病者。取根取茎取枝取叶取花取果取皮取肤悉得愈病。愿我此身亦复如是。若有病者闻声触身。服食血肉乃至骨髓病悉除愈。愿诸众生食我肉时不生恶心如食子肉。我治病已常为说法。愿彼信受思惟转教。复次善男子。菩萨具足烦恼虽受身苦。其心不退不动不转。当知必定得不退心成阿耨多罗三藐三菩提复次善男子。若有众生为鬼所病。菩萨见已即作是言。愿作鬼身大身健身多眷属身。使彼闻见病得除愈。菩萨摩诃萨为众生故勤修苦行。虽有烦恼不污其心。复次善男子。菩萨摩诃萨虽复修行六波罗蜜。亦不求于六波罗蜜果。修行无上六波罗蜜时作是愿言。我今以此六波罗蜜施一切众生。一一众生受我施已悉令得成阿耨多罗三藐三菩提。我亦自为六波罗蜜勤修苦行受诸苦恼。当受苦时愿我不退菩提之心。善男子。菩萨摩诃萨作是愿时。是名不退菩提之相。复次善男子。菩萨摩诃萨不可思议。何以故。菩萨摩诃萨深知生死多诸罪过。观大涅槃有大功德。为诸众生处在生死受种种苦心无退转。是名菩萨不可思议。复次善男子。菩萨摩诃萨无有因缘而生怜愍。实不受恩而常施恩。虽施于恩而不求报。是故复名不可思议。复次善男子。或有众生为自利益修诸苦行。菩萨摩诃萨为利他故修行苦行是名自利。是故复名不可思议

复次菩萨具足烦恼为坏怨亲所受诸苦修平等心。是故复名不可思议。复次菩萨若见诸恶不善众生。若诃责若软语若驱摈若舍之。有恶性者现为软语。有憍慢者现为大慢。而其内心实无憍慢。是名菩萨方便不可思议。复次菩萨具足烦恼少财物时。而求者多心不迮小。是名菩萨不可思议。复次菩萨于佛出时知佛功德。为众生故于无佛处受边地身。如盲如聋如跛如躄是名菩萨不可思议。复次菩萨深知众生所有罪过。为度脱故常与共行。虽随其意罪垢不污。是故复名不可思议

复次菩萨了了知见无众生相无烦恼污无修习道。离烦恼者虽为菩提无菩提行。亦无成就菩提行者。无有受苦及破苦者。而亦能为众生坏苦行菩提行。是故复名不可思议。复次菩萨受后边身处兜率天。是亦名为不可思议。何以故。兜率陀天欲界中胜。在下天者其心放逸。在上天者诸根闇钝是故名胜。修施修戒得上下身。修施戒定得兜率身。一切菩萨毁呰诸有破坏诸有终不造作兜率天业受彼天身。何以故。菩萨若处其余诸有。亦能教化成就众生。实无欲心而生欲界。是故复名不可思议。菩萨摩诃萨生兜率天有三事胜。一者命。二者色。三者名。菩萨摩诃萨实不求于命色名称。虽无求心而所得胜。菩萨摩诃萨深乐涅槃然有因缘亦胜。是故复名不可思议。菩萨摩诃萨如是三事虽胜诸天。而诸天等于菩萨所。终不生于嗔心妒心憍慢之心常生喜心。菩萨于天亦不憍慢。是故复名不可思议。菩萨摩诃萨不造命业而于彼天毕竟寿命。是名命胜。亦无色业而妙色身光明遍满。是名色胜。菩萨摩诃萨处彼天宫不乐五欲唯为法事。是故名称充满十方。是名名胜。是故复名不可思议。菩萨摩诃萨下兜率天。是时大地六种震动。是故复名不可思议。何以故。菩萨下时欲色诸天悉来侍送发大音声赞叹菩萨。以口风气故令地动。复有菩萨人中象王人中象王名为龙王。龙王初入胎时有诸龙王在此地下或怖或喜。是故大地六种震动。是故复名不可思议。菩萨摩诃萨知入胎时住时出时。知父知母。不净不污如帝释髻青色宝珠。是故复名不可思议。善男子。大涅槃经亦复如是不可思议。善男子。譬如大海有八不思议。何等为八。一者渐渐转深。二者深难得底。三者同一碱味。四者潮不过限。五者有种种宝藏。六者大身众生在中居住。七者不宿死尸。八者一切万流大雨投之不增不减。善男子。渐渐转深有三事。何等三。一者众生福力。二者顺风而行。三者河水入故。乃至不增不减亦各有三。是大涅槃微妙经典亦复如是有八不思议。一者渐渐深。所谓优婆塞戒沙弥戒比丘戒菩萨戒。须陀洹果斯陀含果阿那含果阿罗汉果辟支佛果菩萨果阿耨多罗三藐三菩提果。是涅槃经说如是等法。是名渐渐深。是故此经名渐渐深。二者深难得底。如来世尊不生不灭。不得阿耨多罗三藐三菩提不转法轮。不食不受不行惠施。是故名为常乐我净。一切众生悉有佛性。佛性非色不离于色。非受想行识乃至不离于识。是常可见了因非作因。须陀洹乃至辟支佛当得阿耨多罗三藐三菩提。亦无烦恼亦无住处。虽无烦恼不名为常。是故名深。复有甚深。于是经中或时说我或说无我。或时说常或说无常。或时说净或说不净。或时说乐或时说苦。或时说空或说不空。或说一切有或说一切无。或说三乘或说一乘。或说五阴即是佛性。金刚三昧及以中道。首楞严三昧十二因缘。第一义空慈悲平等。于诸众生顶智信心知诸根力。一切法中无挂碍智。虽有佛性不说决定。是故名深。三者一味。一切众生同有佛性皆同一乘。同一解脱一因一果同一甘露。一切当得常乐我净。是名一味。四者潮不过限。如是经中制诸比丘。不得受畜八不净物。若我弟子有能受持读诵书写解说分别是大涅槃微妙经典。宁失身命终不犯之。是名潮不过限。五者有种种宝藏。是经即是无量宝藏。所言宝者。谓四念处四正勤四如意分五根五力七觉分八圣道分。婴儿行圣行梵行天行。诸善方便众生佛性。菩萨功德如来功德声闻功德缘觉功德。六波罗蜜无量三昧无量智慧。是名宝藏。六者大身众生所居住处。大身众生者谓佛菩萨。大智慧故名大众生。大身故大心故。大庄严故大调伏故。大方便故大说法故。大势力故大徒众故。大神通故大慈悲故。常不变故一切众生无挂碍故。容受一切诸众生故。是名大身众生所居之处。七者不宿死尸死尸者。谓一阐提犯四重禁五无间罪诽谤方等。非法说法法说非法。受畜八种不净之物。佛物僧物随意而用或于比丘比丘尼所作非法事。是名死尸。是涅槃经离如是等。是故名为不宿死尸。八者不增不减。无边际故无始终故。非色故非作故。常住故不生灭故。一切众生悉平等故。一切法性同一性故。是名无增减。是故此经如彼大海有八不思议

师子吼言。世尊。若言如来不生不灭名为深者。一切众生有四种生卵生胎生湿生化生。是四种生人中具有。如施婆罗比丘。优婆施婆罗比丘。弥迦罗长者母。尼拘陀长者母。半阇罗长者母。各五百子同于卵生。当知人中则有卵生。湿生者如佛所说。我于往昔作菩萨时作顶生王及手生王。如今所说庵罗树女迦不多树女。当知人中则有湿生。劫初之时一切众生皆悉化生。如来世尊得八自在。何因缘故不化生耶。佛言。善男子。一切众生四生所生。得圣法已不得如本卵生湿生。善男子。劫初众生皆悉化生。当尔之时佛不出世。善男子。若有众生遇病苦时须医须药。劫初之时众生化生。虽有烦恼其病未发。是故如来不出其世。劫初众生身心非器。是故如来不出其世。善男子。如来世尊所有事业胜诸众生。所谓种姓眷属父母。以殊胜故凡所说法人皆信受。是故如来不受化生。善男子。一切众生父作子业子作父业。如来世尊若受化身则无父母。若无父母云何能令一切众生作诸善业。是故如来不受化身。善男子。佛正法中有二种护。一者内。二者外。内护者所谓戒禁。外护者族亲眷属。若佛如来受化身者则无外护。是故如来不受化身。善男子。有人恃姓而生憍慢。如来为欲破如是慢故。生在贵姓不受化身。善男子。如来世尊有真父母。父名净饭母名摩耶。而诸众生犹言是幻。云何当受化生之身。若受化身云何得有碎身舍利。如来为益众生福德故。碎其身而令供养。是故如来不受化身。一切诸佛悉无化生。云何独令我受化身。尔时师子吼菩萨。合掌长跪右膝着。地以偈赞佛

  如来无量功德聚　　我今不能广宣说
  今为众生演一分　　唯愿哀愍听我说
  众生无明闇中行　　具受无边百种苦
  世尊能令远离之　　是故世称为大悲
  众生往返生死绳　　放逸迷荒无安乐
  如来能施众安乐　　是故永断生死绳
  佛能施众安乐故　　自于已乐不贪乐
  为诸众生修苦行　　是故世间兴供养
  见他受苦身战动　　处在地狱不觉痛
  为诸众生受大苦　　是故无胜无有量
  如来为众修苦行　　成就具足满六度
  心处邪风不倾动　　是故能胜世大士
  众生常欲得安乐　　而不知修安乐因
  如来能教令修习　　犹如慈父爱一子
  佛见众生烦恼患　　心苦如母念病子
  常思离病诸方便　　是故此身系属他
  一切众生行诸苦　　其心颠倒以为乐
  如来演说真苦乐　　是故称号为大悲
  世间皆处无明[聲-耳+卵]　　无有智嘴能破之
  如来智嘴能啄坏　　是故名为最大子
  不为三世所摄持　　无有名字及假号
  觉知涅槃甚深义　　是故称佛为大觉
  有河洄澓没众生　　无明所盲不知出
  如来自渡能渡彼　　是故称佛大船师
  能知一切诸因果　　亦复通达尽灭道
  常施众生病苦药　　是故世称大医王
  外道邪见说苦行　　因是能得无上乐
  如来演说真乐行　　能令众生受快乐
  如来世尊破邪道　　开示众生正真路
  行是道者得安乐　　是故称佛为导师
  非自非他之所作　　亦非共作无因作
  如来所说苦受事　　胜于一切诸外道
  成就具足戒定慧　　亦以此法教众生
  以法施时无妒吝　　是故称佛无缘悲
  无所造作无因缘　　获得无因无果报
  是故一切诸智者　　称说如来不求报
  常共世间放逸行　　而身不为放逸污
  是故名为不思议　　世间八法不能污
  如来世尊无怨亲　　是故其心常平等
  我师子吼赞大悲　　能吼无量师子吼

大般涅槃经卷第三十二大般涅槃经卷第三十三

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之一

迦叶菩萨白佛言。世尊。如来怜愍一切众生。不调能调不净能净。无归依者能作归依。未解脱者能令解脱。得八自在为大医师作大药王。善星比丘是佛菩萨时子。出家之后受持读诵分别解说十二部经。坏欲界结获得四禅。云何如来记说善星。是一阐提厮下之人。地狱劫住不可治人。如来何故不先为其演说正法后为菩萨。如来世尊若不能救善星比丘。云何得名有大慈愍有大方便。佛言。善男子。譬如父母唯有三子。其一子者有信顺心恭敬父母。利根智慧于世间事能速了知。其第二子不敬父母无信顺心。利根智慧于世间事能速了知。其第三子不敬父母无信顺心。钝根无智父母若欲教告之时。应先教谁先亲爱谁当先教谁知世间事。迦叶菩萨白佛言。世尊。应先教授有信顺心恭敬父母。利根智慧知世事者。其次第二乃及第三。而彼二子虽无信心恭敬之心。为愍念故次复教之。善男子。如来亦尔。其三子者。初喻菩萨中喻声闻后喻一阐提。如十二部经修多罗中微细之义。我先已为诸菩萨说。浅近之义为声闻说。世间之义为一阐提五逆罪说。现在世中虽无利益以怜愍故。为生后世诸善种子。善男子。如三种田。一者渠流便易。无诸沙卤。瓦石棘刺种一得百。二者虽无沙卤瓦石棘刺。渠流险难收实减半。三者渠流险难。多诸沙卤瓦石棘刺。种一得一为槀草故。善男子。农夫春月先种何田。世尊。先种初田次第二田后及第三。初喻菩萨次喻声闻后喻一阐提。善男子。譬如三罂。一者完二者漏三者破。若欲盛置乳酪水苏先用何者。世尊。应用完者次用漏者后及破者。其完净者喻菩萨僧漏喻声闻破喻一阐提。善男子。如三病人俱至医所。一者易治。二者难治。三者不可治。善男子。医若治者当先治谁。世尊。应先治易次及第二后及第三。何以故为亲属故。其易治者喻菩萨僧。其难治者喻声闻僧。不可治者喻一阐提。现在世中虽无善果。以怜愍故为种后世诸善子故。善男子。譬如大王有三种马。一者调壮大力。二者不调齿壮大力。三者不调羸老无力。王若乘者当先乘谁。世尊。应当先乘调壮大力。次用第二后用第三。善男子。调壮大力喻菩萨僧。其第二者喻声闻僧。其第三者喻一阐提。现在世中虽无利益。以怜愍故为种后世诸善种子。善男子。如大施时有三人来。一者贵族聪明持戒。二者中姓钝根持戒。三者下姓钝根毁戒。善男子。是大施主应先施谁。世尊。应先施于贵姓之子利根持戒。次及第二后及第三。其第一者喻菩萨僧。其第二者喻声闻僧。其第三者喻一阐提。善男子。如大师子杀香象时皆尽其力。杀兔亦尔不生轻想。诸佛如来亦复如是。为诸菩萨及一阐提。演说法时功用无二善男子。我于一时住王舍城。善星比丘为我给使。我于初夜为天帝释演说法要。弟子法应后师眠卧。尔时善星以我久坐心生恶念。时王舍城小男小女若啼不止。父母则语汝若不止。当将汝付薄拘罗鬼。尔时善星反被拘执而语我言。速入禅室薄拘罗来。我言痴人汝常不闻如来世尊无所畏耶。尔时帝释即语我言。世尊。如是人等亦复得入佛法中耶。我即语言。憍尸迦。如是人者得入佛法。亦有佛性当得阿耨多罗三藐三菩提。我虽为是善星说法。而彼都无信受之心。善男子。我于一时在迦尸国尸婆富罗城。善星比丘为我给使。我时欲入彼城乞食。无量众生虚心渴仰欲见。我迹。善星比丘寻随我后而毁灭之。既不能灭而令众生生不善心。我入城已于酒家舍。见一尼干踡脊蹲地餐食酒糟。善星比丘见已而言。世尊。世间若有阿罗汉者是人最胜。何以故。是人所说无因无果。我言痴人。汝常不闻阿罗汉者。不饮酒不害人不欺诳不偷盗不淫劮。是人杀害父母食啖酒糟。云何而言是阿罗汉。是人舍身必定当堕阿鼻地狱。阿罗汉者永断三恶。云何而言是阿罗汉。善星即言。四大之性犹可转易欲令。是人必堕阿鼻无有是处。我言痴人。汝常不闻诸佛如来诚言无二。我虽为是善星说法。而彼绝无信受之心。善男子。我于一时与善星比丘住王舍城。尔时城中有一尼干名曰苦得常作是言众生烦恼无因无缘。众生解脱亦无因缘。善星比丘复作是言。世尊。世间若有阿罗汉者苦得为上。我言痴人。苦得尼干实非罗汉。不能解了阿罗汉道。善星复言。何因缘故阿罗汉人于阿罗汉而生嫉妒。我言痴人。我于罗汉不生嫉妒。而汝自生恶邪见耳。若言苦得是罗汉者。却后七日当患宿食腹痛而死。死已生于食吐鬼中。其同学辈当[臼/丌]其尸置寒林中。尔时善星即往苦得尼干子所语言。长老。汝今知不。沙门瞿昙记汝。七日当患宿食腹痛而死。死已生于食吐鬼中。同学同师当。[臼/丌]汝尸置寒林中。长老。好善思惟作诸方便。当令瞿昙堕妄语中。尔时苦得闻是语已即便断食。从初一日乃至六日。满七日已便食黑蜜。食黑蜜已复饮冷水饮冷水已腹痛而终。终已同学舁其尸丧置寒林中。即受食吐饿鬼之形在其尸边。善星比丘闻是事已。至寒林中见苦得身。受食吐形在其尸边踡脊蹲地。善星语言。大德死耶。苦得答言。我已死矣。云何死耶。答言。因腹痛死。谁出汝尸。答言。同学。出置何处。答言。痴人汝今不识是寒林耶。得何等身。答言。我得食吐鬼身。善星。谛听如来善语真语时语义语法语。善星。如来口出如是实语。汝于尔时云何不信。若有众生不信如来真实语者。彼亦当受如我此身。尔时善星即还我所作如是言。世尊。苦得尼乾命终之后生三十三天。我言痴人。阿罗汉者无有生处。云何而言苦得生于三十三天。世尊。实如所言苦得尼干。实不生于三十三天。今受食吐饿鬼之身。我言痴人。诸佛如来诚言无二。若言如来有二言者无有是处。善星即言。如来尔时虽作是说我于是事都不生信。善男子。我亦常为善星比丘说真实法。而彼绝无信受之心

善男子。善星比丘虽复读诵十二部经获得四禅。乃至不解一偈一句一字之义。亲近恶友退失四禅。失四禅已生恶邪见。作如是说无佛无法无有涅槃。沙门瞿昙善知相法。是故能得知他人心。我于尔时告善星言。我所说法初中后善。其言巧妙字义真正。所说无杂具足成就清净梵行。善星比丘复作是言。如来虽复为我说法。而我真实谓无因果。善男子。汝若不信如是事者。善星比丘今者近在尼连禅河可共往问。尔时如来即与迦叶往善星所。善星比丘遥见如来。见已即生恶邪之心。以恶心故生身陷入堕阿鼻狱善男子。善星比丘虽入佛法无量宝聚空无所获。乃至不得一法之利。以放逸故恶知识故。譬如有人虽入大海多见众宝而无所得以放逸故。又如入海虽见宝聚自戮而死。或为罗刹恶鬼所杀。善星比丘亦复如是。入佛法已为恶知识罗刹大鬼之所杀害。善男子。是故如来以怜愍故常说善星多诸放逸。善男子。若本贫穷于是人所虽生怜愍其心则薄。若本巨富后失财物。于是人所生于怜愍其心则厚。善星比丘亦复如是。受持读诵十二部经获得四禅。然后退失甚可怜愍。是故我说善星比丘多诸放逸。多放逸故断诸善根。我诸弟子有见闻者。于是人所无不生于重怜愍心。如初巨富后失财者。我于多年常与善星共相随逐。而彼自生恶邪之心。以恶邪故不舍恶见。善男子。我从昔来见是善星有少善根如毛发许。终不记彼断绝善根是一阐提厮下之人地狱劫住。以其宣说无因无果无有作业。尔乃记彼永断善根。是一阐提厮下之人地狱劫住。善男子。譬如有人没圊厕中。有善知识以手挠之。若得首发便欲拔出。久求不得尔乃息意。我亦如是求觅善星微少善根便欲拔济。终日求之乃至不得如毛发许。是故不得拔其地狱。迦叶菩萨言。世尊。如来何故记彼当堕阿鼻地狱。善男子。善星比丘多有眷属。皆谓善星是阿罗汉是得道果。我欲坏彼恶邪心故。记彼善星以放逸故堕于地狱。善男子。汝今当知如来所说真实无二。何以故。若佛所记当堕地狱。若不堕者无有是处。声闻缘觉所记莂者。则有二种或虚或实。如目犍连在摩伽陀国遍告诸人。却后七日天当降雨时竟不雨。复记牸牛当生白犊。及其产时乃产驳犊。记生男者后乃产女

善男子。善星比丘常为无量诸众生等。宣说一切无善恶果。尔时永断一切善根。乃至无有如毛发许。善男子。我久知是善星比丘当断善根。犹故共住满二十年畜养共行。我若远弃不近左右。是人当教无量众生造作恶业。是名如来第五解力。世尊。一阐提辈以何因缘无有善法善男子。一阐提辈断善根故众生悉有信等五根。而一阐提辈永断灭故。以是义故。杀害蚁子犹得杀罪。杀一阐提无有杀罪。世尊。一阐提者终无善法。是故名为一阐提耶。佛言。如是如是。世尊。一切众生有三种善。所谓过去未来现在。一阐提辈亦不能断未来善法。云何说言断诸善法名一阐提耶善男子。断有二种。一者现在灭。二者现在障于未来。一阐提辈具。足二断。是故我言断诸善根。善男子。譬如有人没圊厕中。唯有一发毛头未没。虽复一发毛头未没。而一毛头不能胜身。一阐提辈亦复如是。虽未来世当有善根。而不能救地狱之苦。未来之世虽可救拔。现在之世无如之何。是故名为不可救济。以佛性因缘则可得救。佛性者非过去非未来非现在。是故佛性不可得断。如朽败子不能生芽。一阐提辈亦复如是。世尊。一阐提辈不断佛性佛性亦善。云何说言断一切善。善男子。若诸众生现在世中有佛性者。则不得名一阐提也。如世间中众生我性。佛性是常三世不摄。三世若摄名为无常。佛性未来以当见故。故言众生悉有佛性。以是义故。十住菩萨具足庄严乃得少见。迦叶菩萨言。世尊。佛性者常犹如虚空。何故如来说言未来。如来若言一阐提辈无善法者。一阐提辈于其同学同师父母亲族妻子。岂当不生爱念心耶。如其生者非是善乎。佛言。善哉善哉。善男子。快发斯问。佛性者犹如虚空。非过去非未来非现在。一切众生有三种身。所谓过去未来现在。众生未来具足庄严清净之身得见佛性。是故我言佛性未来。善男子。我为众生或时说因为果。或时说果为因。是故经中说命为食见色为触。未来身净故说佛性。世尊。如佛所说义如是者。何故说言一切众生悉有佛性。善男子。众生佛性虽现在无不可言无。如虚空性虽无现在不得言无。一切众生虽复无常而是佛性常住无变。是故我于此经中说。众生佛性非内非外。犹如虚空非内非外。如其虚空有内外者。虚空不名为一为常。亦不得言一切处有。虚空虽复非内非外。而诸众生悉皆有之。众生佛性亦复如是。如汝所言一阐提辈有善法者。是义不然。何以故。一阐提辈若有身业口业意业。取业求业施业解业。如是等业悉是邪业。何以故。不求因果故。善男子。如呵梨勒果根茎枝叶花实悉苦。一阐提业亦复如是

善男子。如来具足知诸根力。是故善能分别众生上中下根。能知是人转下作中。能知是人转中作上。能知是人转上作中。能知是人转中作下。是故当知众生根性无有决定。以无定故或断善根断已还生。若诸众生根性定者。终不先断断已复生。亦不应说一阐提辈堕于地狱寿命一劫。善男子。是故如来说一切法无有定相。迦叶菩萨白佛言。世尊。如来具足知诸根力。定知善星当断善根。以何因缘。听其出家。佛言。善男子。我于往昔初出家时。吾弟难陀。从弟阿难。调婆达多。子罗睺罗。如是等辈皆悉随我出家修道。我若不听善星出家。其人次当得绍王位。其力自在当坏佛法。以是因缘我便听其出家修道。善男子。善星比丘若不出家亦断善根。于无量世都无利益。今出家已虽断善根。能受持戒供养恭敬耆旧长宿有德之人。修习初禅乃至四禅。是名善因。如是善因能生善法。善法既生能修习道。既修习道当得阿耨多罗三藐三菩提。是故我听善星出家。善男子。若我不听善星比丘出家受戒。则不得称我为如来具足十力

善男子。佛观众生具足善法及不善法。是人虽具如是二法。不久能断一切善根具不善根。何以故。如是众生不亲善友不听正法不善思惟不如法行。以是因缘能断善根具不善根。善男子。如来复知是人现世若未来世少壮老时。当近善友听受正法苦集灭道。尔时则能还生善根。善男子。譬如有泉去村不远。其水甘美具八功德。有人热渴欲往泉所。边有智者观是渴人。必定无疑当至水所。何以故。无异路故。如来世尊。观诸众生亦复如是。是故如来名为具足知诸根力。尔时世尊取地少土置之爪上。告迦叶言。是土多耶。十方世界地土多乎。迦叶菩萨白佛言。世尊。爪上土者。不比十方所有土也。善男子。有人舍身还得人身。舍三恶身得受人身。诸根完具生于中国。具足正信能修习道。修习道已能得解脱。得解脱已能入涅槃如爪上土。舍人身已得三恶身。舍三恶身得三恶身。诸根不具生于边地。信邪倒见修习邪道。不得解脱常乐涅槃。如十方界所有地土。善男子。护持禁戒精勤不懈。不犯四重不作五逆不用僧鬘物。不作一阐提不断善根。信如是等涅槃经典。如爪上土。毁戒懈怠犯四重禁作五逆罪用僧鬘物。作一阐提断诸善根。不信是经如十方界所有地土。善男子。如来善知众生如是上中下根。是故称佛具知根力迦叶菩萨白佛言。世尊。如来具足是知根力。是故能知一切众生上中下根利钝差别。知现在世众生诸根。亦知未来众生诸根。如是众生于佛灭后作如是说。如来毕竟入于涅槃。或不毕竟入于涅槃。或说有我或说无我。或有中阴或无中阴。或说有退或说无退。或言如来身是有为。或言如来身是无为。或有说言十二因缘是有为法。或说因缘是无为法。或说心是有常。或说心是无常。或有说言受五欲乐能障圣道或说不遮。或说世第一法唯是欲界或说三界。或说布施唯是意业。或有说言即是五阴。或有说言有三无为。或有说言无三无为。复有说言或有造色。复有说言或无造色。或有说言有无作色。或有说言无无作色。或有说言有心数法。或有说言无心数法。或有说言有五种有。或有说言有六种有。或有说言八戒斋。法优婆塞戒具足受得。或有说言不具受得。或说比丘犯四重已比丘戒在。或说不在。或有说言须陀洹人斯陀含人阿那含人阿罗汉人皆得佛道。或言不得。或说佛性即众生有。或说佛性离众生有。或有说言犯四重禁作五逆罪一阐提等皆有佛性。或说言无。或有说言有十方佛。或有说言无十方佛。如其如来具足成就知根力者。何故今日不决定说

佛告迦叶菩萨。善男子。如是之义非眼识知。乃至非意识知。乃是智慧之所能知。若有智者我于是人终不作二。是亦谓我不作二说。于无智者作不定说而是无智亦复谓我作不定说。善男子。如来所有一切善行悉为调伏诸众生故。譬如医王所有医方悉为疗治一切病苦。善男子。如来世尊为国土故为时节故为他语故为诸人故为众根故。于一法中作二种说。于一名法说无量名。于一义中说无量名。于无量义说无量名。云何一名说无量名。犹如涅槃亦名涅槃。亦名无生亦名无出。亦名无作亦名无为。亦名归依亦名窟宅。亦名解脱亦名光明。亦名灯明亦名彼岸。亦名无畏亦名无退。亦名安处亦名寂静。亦名无相亦名无二。亦名一行亦名清凉。亦名无闇亦名无碍。亦名无诤亦名无浊。亦名广大亦名甘露亦名吉祥。是名一名作无量名。云何一义说无量名。犹如帝释亦名帝释。亦名憍尸迦。亦名婆蹉婆。亦名富兰陀罗。亦名摩佉婆。亦名因陀罗。亦名千眼。亦名舍支夫。亦名金刚。亦名宝顶。亦名宝幢。是名一义说无量名。云何于无量义说无量名。如佛如来亦名如来义。异名异。亦名阿罗。呵义异名异亦名三藐三佛陀义异名异。亦名船师。亦名导师。亦名正觉。亦名明行足。亦名大师子王。亦名沙门。亦名婆罗门。亦名寂静。亦名施主。亦名到彼岸。亦名大医王。亦名大象王。亦名大龙王。亦名施眼。亦名大力士。亦名大无畏。亦名宝聚。亦名商主。亦名得脱。亦名大丈夫。亦名天人师。亦名大分陀利。亦名独无等侣。亦名大福田。亦名大智慧海。亦名无相。亦名具足八智。如是一切义异名异。善男子。是名无量义中说无量名。复有一义说无量名。所谓如阴亦名为阴。亦名颠倒。亦名为谛。亦名四念处。亦名四食。亦名四识住处。亦名为有。亦名为道。亦名为时。亦名众生。亦名为世。亦名第一义。亦名三修谓身戒心。亦名因果。亦名烦恼。亦名解脱。亦名十二因缘。亦名声闻辟支佛。亦名地狱饿鬼畜生人天。亦名过去现在未来。是名一义说无量名。善男子。如来世尊为众生故广中说略略中说广。第一义谛说为世谛。说世谛法为第一义谛。云何名为广中说略。如告比丘我今宣说十二因缘。云何名为十二因缘。所谓因果。云何名为略中说广。如告比丘我今宣说苦集灭道。苦者所谓无量诸苦。集者所谓无量烦恼。灭者所谓无量解脱。道者所谓无量方便。云何名为第一义谛说为世谛。如告比丘吾今此身有老病死。云何名为世谛说为第一义谛。如告憍陈如汝得法故名阿若憍陈如。是故随人随意随时。故名如来知诸根力。善男子。我若当于如是等义作定说者。则不得称我为如来具知根力。善男子。有智之人当知香象所负非驴所胜。一切众生所行无量。是故如来种种为说无量之法。何以故。众生多有诸烦恼故。若使如来说于一行。不名如来具足成就知诸根力。是故我于余经中说。五种众生不应还为说五种法。为不信者不赞正信。为毁禁者不赞持戒。为悭贪者不赞布施。为懈怠者不赞多闻。为愚痴者不赞智慧。何以故。智者若为是五种人说是五事。当知说者不得具足知诸根力。亦不得名怜愍众生。何以故。是五种人闻是事已。生不信心恶心嗔心。以是因缘于无量世受苦果报。是故不名怜愍众生具知根力。是故我先于余经中告舍利弗。汝慎无为利根之人广说法语钝根之人略说法也。舍利弗言。世尊。我但为怜愍故说。非是具足根力故说。善男子。广略说法是佛境界。非诸声闻缘觉所知。善男子。如汝所言佛涅槃后。诸弟子等各异说者。是人皆以颠倒因缘不得正见。是故不能自利利他。善男子。是诸众生非唯一性一行一根一种国土一善知识。是故如来为彼种种宣说法要。以是因缘十方三世诸佛如来。为众生故开示演说十二部经。善男子。如来说是十二部经。非为自利但为利他。是故如来第五力者名为解力。是二力故如来深知是人现在能断善根。是人后世能断善根。是人现在能得解脱。是人后世能得解脱。是故如来名无上力士

大般涅槃经卷第三十三大般涅槃经卷第三十四

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之二

善男子。若言如来毕竟涅槃不毕竟涅槃。是人不解如来意故作如是说。善男子。是香山中有诸仙人五万三千。皆于过去迦叶佛所。修诸功德未得正道亲近诸佛听受正法。如来欲为如是人故告阿难言。过三月已吾当涅槃。诸天闻已其声展转乃至香山。诸仙闻已即生悔心作如是言。云何我等得生人中不亲近佛。诸佛如来出世甚难如优昙花。我今当往至世尊所听受正法。善男子。尔时五万三千诸仙即来我所。我时即为如应说法。诸大士。色是无常何以故。色之因缘是无常故。无常因生色云何常。乃至识亦如是。尔时诸仙闻是法已。即时获得阿罗汉果。善男子。拘尸那竭有诸力士三十万人无所系属。自恃憍恣色力命财狂醉乱心。善男子。我为调伏诸力士故告目连言。汝当调伏如是力士。时目犍连敬顺我教。于五年中种种教化。乃至不能令一力士受法调伏。是故我复为彼力士告阿难言。过三月已吾当涅槃。善男子。时诸力士闻是语已。相与集聚平治道路过三月已。我时便从毗舍离国至拘尸那城。中路遥见诸力士辈。即自化身为沙门像。往力士所作如是言。诸童子。作何事耶。力士闻已皆生嗔恨作如是言。沙门。汝今云何谓我等辈为童子耶。我时语言。汝今大众三十万人尽其身力。不能移此微末小石。云何不名为童子乎。诸力士言。汝若谓我为童子者。当知汝即是大人也。善男子。我于尔时以足二指掘出此石。是诸力士见是事已。即于已身生轻劣想复作是言。沙门。汝今复能移徙此石令出道不。我言童子。何因缘故严治此道诸力士言。沙门。汝不知耶。释迦如来当由此路至娑罗林入于涅槃。以是因缘我等平治。我时赞言。善哉善哉童子。汝等已发如是善心。吾当为汝除去此石。我时以手举掷大石。高至阿迦尼吒。时诸力士见石在空。皆生惊怖寻欲四散。我复告言。诸力士等。汝今不应生恐怖心各欲散去。诸力士言。沙门。若能救护我者我当安住。尔时我复以手接石置之右掌。力士见已心生欢喜复作是言。沙门。是石常耶是无常乎。我于尔时以口吹之。石即散坏犹如微尘。力士见已唱言。沙门。是石无常。即生愧心而自考责。云何我等恃怙自在色力命财而生憍慢。我知其心即舍化身还复本形而为说法。力士见已一切皆发菩提之心。善男子。拘尸那竭有一工巧名曰纯陀。是人先于迦叶佛所发大誓愿。释迦如来入涅槃时我当最后奉施饮食。是故我于毗舍离国顾命比丘优婆摩那。善男子。过三月已吾当于彼拘尸那竭娑罗双树入般涅槃。汝可往告纯陀令知。善男子。王舍城中有五通仙名须跋陀。年百二十常自称是一切智人生大憍慢。已于过去无量佛所种诸善根。我亦为欲调伏彼故告阿难言。过三月已吾当涅槃。须跋闻已当来我所生信敬心。我当为彼说种种法。其人闻已当得尽漏。善男子。罗阅耆王频婆娑罗。其王太子名曰善见。业因缘故生恶逆心欲害其父而不得便。尔时恶人提婆达多亦因过去业因缘故。复于我所生不善心欲害于我。即修五通不久获得。与善见太子共为亲厚。为太子故现作种种神通之事。从非门出从门而入。从门而出非门而入。或时示现象马牛羊男女之身。善见太子见已。即生爱心喜心敬信之心。为是事故严设种种供养之具而供养之又复白言。大师圣人。我今欲见曼陀罗花。时调婆达多即便往至三十三天。从彼天人而求索之。其福尽故都无与者。既不得花作是思惟。曼陀罗树无我我所。我若自取当有何罪。即前欲取便失神通。还见己身在王舍城。心生惭愧不能复见善见太子。复作是念我今当往至如来所求索大众。佛若听者我当随意教诏敕使舍利弗等。尔时提婆达多便来我所作如是言。唯愿如来。以此大众付嘱于我。我当种种说法教化令其调伏。我言痴人。舍利弗等聪明大智世所信伏。我犹不以大众付嘱。况汝痴人食唾者乎。时提婆达复于我所倍生恶心作如是言。瞿昙。汝今虽复调伏大众。势亦不久当见磨灭。作是语已大地即时六返震动。提婆达多寻时躄地。于其身边出大暴风吹诸尘土而污坌之。提婆达多见。恶相已复作是言。若我此身现世必入阿鼻地狱。我要当报如是大怨。时提婆达多寻起往至善见太子所。善见见已即问。圣人。何故颜容憔悴有忧色耶。提婆达言。我常如是汝不知乎。善见答言。愿说其意何因缘尔提婆达言。我今与汝极成亲爱。外人骂汝以为非理。我闻是事。岂得不忧。善见太子复作是言。国人云何骂辱于我。提婆达言。国人骂汝为未生怨。善见复言。何故名我为未生怨谁作此名。提婆达言。汝未生时一切相师皆作是言。是儿生已当杀其父。是故外人皆悉号汝为未生怨。一切内人护汝心故谓为善见。韦提夫人闻是语已。既生汝身于高楼上弃之于地坏汝一指。以是因缘人复号汝为婆罗留枝。我闻是已心生愁愦。而复不能向汝说之。提婆达多以如是等种种恶事教令杀父。若汝杀父我亦能杀瞿昙沙门。善见太子问一大臣名曰雨行。大王何故为我立字作未生怨。大臣即为说其本末如提婆达所说无异。善见闻已即与大臣收其父王闭之城外。以四种兵而守卫之。韦提夫人闻是事已即至王所。诸守王人遮不听入。尔时夫人生嗔恚心便呵骂之。时诸守人即告太子。大王夫人欲得往见父王。不审听不。善见闻已复生嗔嫌即往母所前牵母发拔刀欲斫。尔时耆婆白言。大王。有国已来罪虽极重。不及女人况所生母。善见太子闻是语已。为耆婆故即便放舍。遮断父王衣服卧具饮食汤药。过七日已王命便终。善见太子见父丧已方生悔心。雨行大臣复以种种恶邪之法而为说之。大王。一切业行都无有罪。何故今者而生悔心。耆婆复言。大王。当知如是业者罪兼二种。一者杀害父王。二者杀须陀洹。如是罪者除佛更无能除灭者。善见王言。如来清净无有秽浊。我等罪人云何得见。善男子我知是事故告阿难。过三月已吾当涅槃。善见闻已即来我所。我为说法重罪得薄获无根信。善男子。我诸弟子闻是说已。不解我意故作是言。如来定说毕竟涅槃

善男子。菩萨二种。一者实义。二者假名。假名菩萨闻我三月当入涅槃。皆生退心而作是言。如其如来无常不住。我等何为为是事故无量世中受大苦恼。如来世尊成就具足无量功德。尚不能坏如是死魔。况我等辈当能坏耶。善男子。是故我为如是菩萨而作是言。如来常住无有变易。善男子。我诸弟子闻是说已不解我意。定言如来终不毕竟入于涅槃善男子。有诸众生生于断见作如是言。一切众生身灭之后。善恶之业无有受者。我为是人作如是言。善恶果报实有受者。云何知有。善男子。过去之世拘尸那竭。有王名曰善见。作童子时经八万四千岁。作太子时八万四千岁。及登王位亦八万四千岁。于独处坐作是思惟。众生薄福寿命短促。常有四怨而随逐之。不自觉知犹故放逸。是故我当出家修道断绝四怨生老病死。即敕有司于其城外作七宝堂。作已便告群臣百官宫内妃后诸子眷属。汝等当知我欲出家能见听不。尔时大臣及其眷属各作是言。善哉大王。今正是时。时善见王将一使人独住堂上。复经八万四千年中修习慈心。是慈因缘于后八万四千世中。次第得作转轮圣王。三十世中作释提桓因。无量世中作诸小王。善男子。尔时善见岂异人乎。莫作斯观即我身是。善男子。我诸弟子闻是说已不解我意。唱言如来定说有我及有我所。又我一时为诸众生说言。我者即是性也。所谓内外因缘。十二因缘众生五阴。心界世间功德业行自在天世。即名为我。我诸弟子闻是说已不解我意。唱言如来定说有我。善男子。复于异时有一比丘。来至我所作如是言。世尊。云何名我。谁是我耶。何缘故我。我时即为比丘说言。比丘。无我我所。眼者即是本无今有已有还无。其生之时无所从来。及其灭时亦无所至。虽有业果无有作者。无有舍阴及受阴者。如汝所问云何我者我即期也。谁是我者即是业也。何缘我者即是爱也。比丘。譬如二手相拍声出其中。我亦如是众生业爱三因缘故。名之为我。比丘。一切众生色不是我。我中无色色中无我。乃至识亦如是。比丘。诸外道辈虽说有我终不离阴。若说离阴别有我者。无有是处。一切众生行如幻化热时之焰。比丘。五阴皆是无常无乐无我无净。善男子。尔时多有无量比丘。观此五阴无我我所得阿罗汉果。善男子。我诸弟子闻是说已不解我意。唱言如来定说无我

善男子。我于经中复作是言。三事和合得受是身。一父二母三者中阴。是三和合得受是身。或时复说阿那含人现般涅槃。或于中阴入般涅槃。或复说言中阴身根具足明了。皆因往业如净醍醐。善男子。我或时说弊恶众生所受中阴。如世间中粗涩氀褐。纯善众生所受中阴。如波罗奈所出白[疊*毛]。我诸弟子闻是说已不解我意。唱言如来说有中阴。善男子。我复为彼逆罪众生而作是言。造五逆者舍身直入阿鼻地狱。我复说言昙摩留枝比丘。舍身直入阿鼻地狱。于其中间无止宿处。我复为彼犊子梵志说言。梵志。若有中阴则有六有。我复说言无色众生无有中阴。善男子。我诸弟子闻是说已不解我意。唱言佛说定无中阴

善男子。我于经中复说有退何以故。因于无量懈怠懒惰诸比丘等不修道故。说退五种。一者乐于多事。二者乐说世事。三者乐于睡眠。四者乐近在家。五者乐多游行。以是因缘令比丘退。说退因缘复有二种。一内二外。阿罗汉人虽离内因不离外因。以外因缘故则生烦恼。生烦恼故则便退失。复有比丘名曰瞿抵。六返退失退已惭愧复更进修。第七即得得已恐失以刀自害。我复或说有时解脱或说六种阿罗汉等。我诸弟子闻是说已不解我意。唱言如来定说有退。善男子。经中复说。譬如焦炭不还为木。亦如瓶坏更无瓶用。烦恼亦尔阿罗汉断终不还生。亦说众生生烦恼因凡有三种。一者未断烦恼。二者不断因缘。三者不善思惟。而阿罗汉无二因缘。谓断烦恼为不善思惟。善男子。我诸弟子闻是说已不解我意。唱言如来定说无退善男子。我于经中说如来身凡有二种。一者生身。二者法身。言生身者。即是方便应化之身。如是身者。可得言是生老病死长短黑白。是此是彼是学无学。我诸弟子闻是说已不解我意。唱言如来。定说佛身是有为法。法身即是常乐我净。永离一切生老病死。非白非黑非长非短。非此非彼非学非无学。若佛出世及不出世。常住不动无有变易。善男子。我诸弟子闻是说已不解我意。唱言如来定说佛身是无为法

善男子。我经中说云何名为十二因缘。从无明生行。从行生识。从识生名色。从名色生六入。从六入生触。从触生受。从受生爱。从爱生取。从取生有。从有生生。从生则有老死忧苦。善男子。我诸弟子闻是说已不解我意。唱言如来说十二缘定是有为。我又一时告喻比丘而作是言。十二因缘有佛无佛性相常住。善男子。有十二缘不从缘生。有从缘生非十二缘有从缘生亦十二缘。有非缘生非十二缘。有十二缘非缘生者。谓未来世十二支也。有从缘生非十二缘者。谓阿罗汉所有五阴。有从缘生亦十二缘者。谓凡夫人所有五阴十二因缘。有非缘生非十二缘者。谓虚空涅槃。善男子。我诸弟子闻是说已不解我意。唱言如来说十二缘定是无为

善男子。我经中说一切众生作善恶业舍身之时。四大于此即时散坏。纯善业者心即上行。纯恶业者心即下行。善男子。我诸弟子闻是说已不解我意。唱言如来说心定常。善男子。我于一时为频娑婆罗王而作是言。大王。当知色是无常。何以故。从无常因而得生故。是色若从无常因生。智者云何说言是常。若色是常不应坏灭生诸苦恼。今见是色散灭破坏。是故当知色是无常。乃至识亦如是。善男子。我诸弟子闻是说已不解我意。唱言如来说心定断。善男子。我经中说我诸弟子受诸香花金银宝物妻子奴婢八不净物获得正道。得正道已亦不舍离。我诸弟子闻是说已不解我意。定言如来说受五欲不妨圣道。又我一时复作是说。在家之人得正道者无有是处。善男子。我诸弟子闻是说已不解我意。唱言如来说受五欲定遮正道

善男子。我经中说远离烦恼未得解脱。犹如欲界修习世间第一法也。善男子。我诸弟子闻作是说不解我意。唱言如来说第一法唯是欲界。又复我说暖法顶法忍法世间第一法。在于初禅至第四禅。我诸弟子闻是说已不解我意。唱言如来说如是法在于色界。又复我说诸外道等。先已得断四禅烦恼。修习暖法顶法忍法世第一法。观四真谛得阿那含果。我诸弟子闻是说已不解我意。唱言如来说第一法在无色界。善男子。我经中说四种施中有三种净。一者施主信因信果信施。受者不信因果与施。二者受者信因果施。施主不信因果及施。三者施主受者二俱有信四者施主受者二俱不信。是四种施初三种净。我诸弟子闻是说已不解我意唱言如来说施唯意。善男子。我于一时复作是说。施者施时以五事施。何等为五。一者施色。二者施力。三者施安。四者施命。五者施辩。以是因缘施主还得五事果报。我诸弟子闻是说已不解我意。唱言佛说施即五阴

善男子。我于一时宣说。涅槃即是远离。烦恼永尽灭无遗余。犹如灯灭更无法生涅槃亦尔。言虚空者即无所有。譬如世间无所有故名为虚空。非智缘灭即无所有。如其有者应有因缘。有因缘故应有尽灭。以其无故无有尽灭。我诸弟子闻是说已不解我意。唱言佛说无三无为。善男子。我于一时为目干连而作是言。目连。夫涅槃者。即是章句即是足迹。是毕竟处是无所畏。即是大师即是大果。是毕竟智即是大忍无碍三昧。是大法界是甘露味即是难见。目连。若说无涅槃者。云何有人生诽谤者堕于地狱。善男子。我诸弟子闻是说已不解我意。唱言如来说有涅槃。复于一时我为目连而作是说。目连。眼不牢固至身亦尔皆不牢固。不牢固故名为虚空。食下回转消化之处。一切音声皆名虚空。我诸弟子闻是说已不解我意。唱言如来决定说有虚空无为。复于一时为目连说。目连。有人未得须陀洹果住忍法时。断于无量三恶道报。当知不从智缘而灭。我诸弟子闻是说已不解我意。唱言如来决定说有非智缘灭善男子。我又一时为跋波比丘说。跋波若比丘观色已若过去若未来若现在。若近若远若粗若细。如是等色非我我所。若有比丘如是观已能断色爱。跋波又言云何名色。我言四大名色四阴名名。我诸弟子闻是说已不解我意。唱言如来决定说言色是四大。善男子。我复说言譬如因镜则有像现。色亦如是因四大造。所谓粗细涩滑青黄赤白。长短方圆斜角轻重。寒热饥渴烟云尘雾。是名造色犹如响像。我诸弟子闻是说已不解我意。唱言如来说有四大则有造色。或有四大无有造色。善男子。往昔一时菩提王子作如是言。若有比丘护持禁戒若发恶心。当知是时失比丘戒。我时语言。菩提王子。戒有七种从于身口有无作色。以是无作色因缘故。其心虽在恶无记中。不名失戒犹名持戒。以何因缘名无作色。非异色因不作异色因果。善男子。我诸弟子闻是说已不解我意。唱言佛说有无作色。善男子。我于余经作如是言。戒者即是遮制恶法。若不作恶是名持戒。我诸弟子闻是说已不解我意。唱言如来决定宣说无无作色

善男子。我于经中作如是说。圣人色阴乃至识阴。皆是无明因缘所出。一切凡夫亦复如是从无明生爱。当知是爱即是无明。从爱生取当知是取即无明爱。从取生有是有即是无明爱取。从有生受当知是受即是行有。从受因缘生于名色无明爱取有行受触识六入等。是故受者即十二支。善男子。我诸弟子闻是说已不解我意。唱言如来说无心数。善男子。我于经中作如是说。从眼色明恶欲等四则生眼识。言恶欲者即是无明。欲性求时即名为爱。爱因缘取取名为业。业因缘识。识缘名色。名色缘六入。六入缘触。触缘想受爱信精进定慧。如是等法因触而生然非是触。善男子。我诸弟子闻是说已不解我意。唱言如来说有心数

善男子。我或时说唯有一有。或说二三四五六七八九至二十五。我诸弟子闻是说已不解我意。唱言如来说有五有或言六有。善男子。我往一时住迦毗罗卫尼拘陀林时。释摩男来至我所作如是言。云何名为优婆塞也。我即为说若有善男子善女人。诸根完具受三归依。是则名为优婆塞也。释摩男言。世尊。云何名为一分优婆塞。我言。摩男。若受三归及受一戒。是名一分优婆塞也。我诸弟子闻是说已不解我意。唱言如来说优婆塞戒不具受得。善男子。我于一时住恒河边。尔时迦旃延来至我所作如是言。世尊。我教众生令受斋法。或一日或一夜。或一时或一念。如是之人成斋不耶。我言。比丘。是人得善不名得斋。我诸弟子闻是说已不解我意。唱言如来说八戒斋具受乃得

善男子。我于经中作如是说。若有比丘犯四重已。不名比丘名破比丘亡失比丘。不复能生善牙种子。譬如焦种不生果实。如多罗树头若断坏则不生果。犯重比丘亦复如是。我诸弟子闻是说已不解我意。唱言如来说诸比丘犯重禁已失比丘戒。善男子。我于经中为纯陀说四种比丘。一者毕竟到道。二者示道。三者受道。四者污道。犯四重者即是污道。我诸弟子闻是说已不解我意。唱言如来说诸比丘犯四重已不失禁戒。善男子。我于经中告诸比丘。一乘一道一行一缘。如是一乘乃至一缘。能为众生作大寂静。永断一切系缚愁苦苦及苦因。令一切众到于一有。我诸弟子闻是说已不解我意。唱言如来说须陀洹。乃至阿罗汉人皆得佛道。善男子。我于经中说须陀洹人人间天上七返往来便般涅槃。斯陀含人一受人天便般涅槃。阿那含人凡有五种。或有中间般涅槃者。乃至上流般涅槃者。阿罗汉人凡有二种。一者现在。二者未来。现在亦断烦恼五阴。未来亦断烦恼五阴。我诸弟子闻是说已不解我意。唱言如来说须陀洹至阿罗汉不得佛道。善男子。我于此经说言佛性具有六事。一常二实三真四善五净六可见。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有。善男子。我又说言众生佛性犹如虚空。虚空者非过去非未来非现在非内非外。非是色声香味触摄佛性亦尔。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有。善男子。我又复说众生佛性。犹如贫女宅中宝藏。力士额上金刚宝珠。转轮圣王甘露之泉。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有。善男子。我又复说犯四重禁一阐提人谤方等经作五逆罪皆有佛性。如是众生都无善法佛性是善。我诸弟子闻是说已不解我意。唱言佛说众生佛性离众生有。善男子。我又复说众生者即是佛性。何以故。若离众生不得阿耨多罗三藐三菩提。是故我与波斯匿王说于象喻。如盲说象虽不得象然不离象。众生说色乃至说识。是佛性者亦复如是。虽非佛性非不佛性。如我为王说箜篌喻佛性亦尔。善男子。我诸弟子闻是说已。不解我意作种种说。如盲问乳佛性亦尔。以是因缘或有说言犯四重禁谤方等经作五逆罪一阐提等。悉有佛性或说言无。善男子。我于处处经中说言。一人出世多人利益。一国土中二转轮王。一世界中二佛出世。无有是处。一四天下八四天王乃至二他化自在天。亦无是处。然我乃说从阎浮提阿鼻地狱上至阿迦腻吒天。我诸弟子闻是说已不解我意。唱言佛说无十方佛。我亦于诸大乘经中说有十方佛

大般涅槃经卷第三十四大般涅槃经卷第三十五

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之三

善男子。如是诤讼是佛境界。非诸声闻缘觉所知。若人于是生疑心者犹能摧坏。无量烦恼如须弥山。若于是中生决定者。是名执着。迦叶菩萨白佛言。世尊。云何执着。佛言。善男子。如是之人若从他闻。若自寻经若他故教。于所著事不能放舍。是名执着。迦叶复言。世尊。如是执着为是善耶是不善乎。善男子。如是执着不名为善。何以故。不能摧坏诸疑网故。迦叶复言。世尊。如是人者本自不疑。云何说言不坏疑网。善男子。夫不疑者即是疑也。世尊。若有人谓须陀洹人不堕三恶。是人亦当名著名疑。善男子。是可名定不得名疑。何以故。善男子。譬如有人先见人树。后时夜行遥见杌根。便生疑想人耶树耶。善男子。如人先见比丘梵志。后时于路遥见比丘即生疑想。是沙门耶是梵志乎。善男子。如人先见牛与水牛。后遥见牛便生疑想。彼是牛耶是水牛乎。善男子。一切众生先见二物后便生疑。何以故心不了故。我亦不说须陀洹人有堕三恶不堕三恶。是人何故生于疑心。迦叶言。世尊。如佛所说要先见已然后疑者。有人未见二种物时亦复生疑。何等是耶。所谓涅槃。世尊。譬如有人路遇浊水。然未曾见而亦生疑。如是水者深耶浅耶。是人未见云何生疑。善男子。夫涅槃者即是断苦。非涅槃者即是苦也。一切众生见有二种见苦非苦。苦非苦者即是饥渴寒热嗔喜。病瘦安隐老壮生死。系缚解脱恩爱别离怨憎聚会。众生见已即便生疑。当有毕竟远离如是苦恼事不。是故众生于涅槃中而生疑也。汝意若谓是人先来未见浊水云何疑者。是义不然。何以故。是人先于余处见已。是故于此未曾到处而复生疑。世尊。是人先见深浅处时已不生疑。于今何故而复生疑。佛言。善男子。本未行故所以生疑。是故我言不了故疑。迦叶菩萨白佛言。世尊。如佛所说疑即是着着即是疑。为是谁耶。善男子。断善根者。迦叶言。世尊。何等人辈能断善根。善男子。若有聪明黠慧利根能善分别。远离善友不听正法。不善思惟不如法住。如是之人能断善根。离是四事心自思惟无有施物。何以故。施者即是舍于财物。若施有报当知施主常应贫穷。何以故。子果相似故。是故说言无因无果。若如是说无因无果。是则名为断善根也。复作是念施主受者及以财物。三事无常无有停住。若无停住云何说言此是施主受者财物。若无受者云何得果。以是义故无因无果。若如是说无因无果。当知是人能断善根。复作是念施者施时有五事施。受者受已或时作善或作不善。而是施主亦复不得善不善果。如世间法从子生果果还作子。因即施主果即受者。而是受者不能以此善不善法令施主得。以是义故无因无果。若如是说无因无果。当知是人能断善根。复作是念无有施物。何以故施物无记。若是无记云何而得善果报耶。无善恶果即是无记。财若无记当知即无善恶果报。是故无施无因无果。若如是说无因无果当知是人能断善根。复作是念施者即意。若是意者无见无对非是色法。若非是色云何可施。是故无施无因无果。若如是说无因无果。当知是人能断善根。复作是念施主若为佛像天像命过父母。而行施者即无受者。若无受者应无果报。若无果报是为无因。若无因者是为无果。若如是说无因无果。当知是人能断善根。复作是念无父无母。若言父母是众生因生众生者。理应常生无有断绝。何以故因常有故。然不常生是故当知无有父母。复作是念无父无母何以故。若众生身因父母有。一人应具男女二根。然无具者当知众生非因父母。复作是念非因父母而生众生。何以故。眼见众生不似父母。谓身色心威仪进止。是故父母非众生因。复作是念一切世间有四种无。一者未生名无。如泥团时未有瓶用。二者灭已名无。如瓶坏已是名为无。三者各异互无。如牛中无马马中无牛。四者毕竟名无。如兔角龟毛。众生父母亦复如是同此四无。若言父母众生因者。父母死时子不必死。是故父母非众生因。复作是念若言父母众生因者。应因父母常生众生。然而复有化生湿生。是故当知非因父母生众生也。复作是念自有众生非因父母而得生长。譬如孔雀闻雷震声而便得娠。又如青雀饮雄雀尿而便得娠。如命命鸟见雄者舞即便得娠。作是念时如其不遇善知识者。当知是人能断善根。复作是念一切世间无善恶果。何以故。有诸众生具十善法。乐于惠施勤修功德。是人亦复疹病集身中年夭丧。财物损失多诸忧苦。有行十恶悭贪嫉妒懒惰懈怠不修诸善。身安无病终保年寿。多饶财宝无诸愁苦。是故当知无善恶果。复作是念我亦曾闻诸圣人说。有人修善命终多堕三恶道中。有人行恶命终生于人天之中。是故当知无善恶果。复作是念一切圣人有二种说。或说杀生得善果报。或说杀生得恶果报。是故当知圣说不定。圣若不定我云何定。是故当知无善恶果。复作是念一切世间无有圣人。何以故。若言圣人应得正道。一切众生具烦恼时修正道者。当知是人正道烦恼一时俱有。若一时有当知正道不能破结。若无烦恼而修道者。如是正道为何所作。是故具烦恼者道不能坏。不具烦恼道则无用。是故当知一切世间无有圣人。复作是念无明缘行乃至生缘老死。是十二因缘一切众生等共有之。八圣道者其性平等。亦应如是一人得时一切应得。一人修时应一切苦灭。何以故。烦恼等故而今不得。是故当知无有正道。复作是念圣人皆有同凡夫法。所谓饮食行住坐卧。睡眠喜笑饥渴寒热忧愁恐怖。若同凡夫如是事者。当知圣人不得圣道。若得圣道应当永断如是等事。如是等事如其不断。当知无道。复作是念圣人有身受五欲乐。亦复骂辱挝打于人嫉妒憍慢受于苦乐作善恶业。是因缘故知无圣人。若有道者应断是事。是事不断当知无道。复作是念多怜愍者名为圣人。何因缘故名为圣人。道因缘故名为圣人。若道性怜愍便应愍念一切众生。不待修已然后方得。如其无愍何故圣人因得圣道能怜愍耶。是故当知世无圣道。复作是念一切四大不从因生。众生等有是四大性。不观众生是边应到彼不应到。若有圣道性应如是。然今不尔是故当知世无圣人。复作是念若诸圣人有一涅槃。当知是则无有圣人。何以故不可得故。常住之法理不可得不可取舍。若诸圣人涅槃多者是则无常。何以故可数法故。涅槃若一。一人得时一切应得。涅槃若多是则有边。如其有边云何名常。若有说言涅槃体一解脱是多。如盖是一。牙舌是多。是义不然。何以故。一一所得非一切得。以有边故是应无常。若无常者云何得名为涅槃耶。涅槃若无谁为圣人。是故当知无有圣人。复作是念圣人之道非因缘得。若圣人道非因缘得。何故一切不作圣人。若一切人非圣人者。当知是则无有圣人及以圣道。复作是念圣说正见有二因缘。一者从他闻法。二者内自思惟。是二因缘若从缘生。所从生者复从缘生。如是展转有无穷过。若是二事不从缘生。一切众生何故不得。作是观时能断善根。善男子。若有众生深见如是无因无果。是人能断信等五根。善男子。断善根者非是下劣愚钝之人。亦非天中及三恶道破僧亦尔。迦叶菩萨白佛言。世尊。如是之人何时当能还生善根。佛言。善男子。是人二时还生善根。初入地狱出地狱时。善男子。善有三种。过去现在未来。若过去者其性自灭。因虽灭尽果报未熟。是故不名断过去果。断三世因故名为断

迦叶菩萨白佛言。世尊。若断三世因名断善根。断善根人即有佛性。如是佛性。为是过去为是现在为是未来为遍三世。若过去者云何名常。佛性亦常是故当知非过去也。若未来者云何名常。何故佛说一切众生必定当得。若必定得云何言断。若现在者复云何常。何故复言必定可见。如来亦说佛性有六。一常二真三实四善五净六可见。若断善根有佛性者。则不得名断善根也。若无佛性云何复言一切众生悉有佛性。若言佛性亦有亦断。云何如来复说是常。佛言。善男子。如来世尊为众生故有四种答。一者定答。二者分别答。三者随问答。四者置答。善男子。云何定答。若问恶业得善果耶不善果乎。是应定答得不善果。善亦如是。若问如来一切智不。是应定答是一切智。若问佛法是清净不。是应定答必定清净。若问如来弟子如法住不。是应定答有如法住。是名定答。云何分别答。如我所说四真谛法。云何为四。苦集灭道。何谓苦谛有八苦故名曰苦谛。云何集谛五阴因故名为集谛。云何灭谛。贪欲嗔痴毕竟尽故名为灭谛。云何道谛三十七助道法故名为道谛。是名分别答。云何随问答如我所说一切法无常。复有问言如来世尊为何法故说于无常。答言如来为有为法故说无常。无我亦尔。如我所说一切法烧他。又问言如来世尊为何法故说一切烧。答言如来为贪嗔痴说一切烧善男子。如来十力四无所畏大慈大悲三念处首楞严等。八万亿诸三昧门。三十二相八十种好五智印等。三万五千诸三昧门金刚定等。四千二百诸三昧门方便三昧无量无边。如是等法是佛佛性。如是佛性则有七事。一常二我三乐四净五真六实七善。是名分别答。善男子。后身菩萨佛性有六。一常二净三真四实五善六少见。是名分别答。如汝先问断善根人有佛性者。是人亦有如来佛性。亦有后身佛性。是二佛性障未来故得名为无。毕竟得故得名为有。是名分别答。如来佛性非过去非现在非未来。后身佛性现在未来。少可见故得名现在。未具见故名为未来。如来未得阿耨多罗三藐三菩提时佛性因故亦是过去现在未来果则不尔。有是三世有非三世。后身菩萨佛性因故亦是过去现在未来果亦如是。是名分别答。九住菩萨佛性六种。一常二善三真四实五净六可见。佛性因故亦是过去现在未来果亦如是。是名分别答。八住菩萨下至六住佛性五事。一真二实三净四善五可见。佛性因故亦是过去现在未来果亦如是。是名分别答。五住菩萨下至初住佛性五事。一真二实三净四可见五善不善。善男子。是五种佛性六种佛性七种佛性。断善根人必当得故。故得言有。是名分别答。若有说言断善根者定有佛性定无佛性。是名置答。迦叶菩萨言。世尊。我闻不答乃名置答。如来今者何因缘答而名置答。善男子。我亦不说置而不答乃说置答。善男子。如是置答复有二种。一者遮止。二者莫着。以是义故得名置答

迦叶菩萨白佛言。世尊。如佛所说云何名因亦是过去现在未来。果亦过去现在未来。非是过去现在未来。佛言。善男子。五阴二种。一者因。二者果。是因五阴是过去现在未来。是果五阴亦是过去现在未来。亦非过去现在未来。善男子。一切无明烦恼等结悉是佛性。何以故。佛性因故从无明行及诸烦恼得善五阴。是名佛性从善五阴。乃至获得阿耨多罗三藐三菩提。是故我于经中先说。众生佛性如杂血乳。血者即是无明行等一切烦恼。乳者即是善五阴也。是故我说从诸烦恼及善五阴得阿耨多罗三藐三菩提。如众生身皆从精血而得成就。佛性亦尔。须陀洹人斯陀含人断少烦恼佛性如乳。阿那含人佛性如酪。阿罗汉人犹如生酥。从辟支佛至十住菩萨犹如熟酥。如来佛性犹如醍醐。善男子。现在烦恼为作障故。令诸众生不得睹见。如香山中有忍辱草非一切牛皆能得食。佛性亦尔。是名分别答。迦叶菩萨白佛言。世尊。五种六种七种佛性若未来有者。云何说言断善根人有佛性耶。佛言。善男子。如诸众生有过去业。因是业故众生现在得受果报。有未来业以未生故终不生果有现在烦恼。若无烦恼一切众生应当了了现见佛性。是故断善根人。以现在世烦恼因缘能断善根。未来佛性力因缘故还生善根。迦叶言。世尊。未来云何能生善根。善男子。犹如灯日虽复未生亦能破闇。未来之生能生众生未来佛性亦复如是。是名分别答

迦叶菩萨白佛言。世尊。若言五阴是佛性者。云何说言众生佛性非内非外。佛言。善男子。何因缘故如是失意。我先不说众生佛性是中道耶。迦叶言。世尊。我实不失意。直以众生于此中道不能解故。故发斯问。善男子。众生不解即是中道。或时有解或有不解。善男子。我为众生得开解故。说言佛性非内非外。何以故凡夫众生或言佛性住五阴中如器中有果。或言离阴而有犹如虚空。是故如来说于中道。众生佛性非内六入非外六入。内外合故名为中道。是故如来宣说佛性即是中道。非内非外故名中道。是名分别答。复次善男子。云何名为非内非外。善男子。或言佛性即是外道。何以故。菩萨摩诃萨于无量劫在外道中。断诸烦恼调伏其心教化众生。然后乃得阿耨多罗三藐三菩提。是以佛性即是外道。或言佛性即是内道。何以故。菩萨虽于无量劫中修习外道。若离内道则不能得阿耨多罗三藐三菩提。是以佛性即是内道。是故如来遮此二边。说言佛性非内非外亦名内外。是名中道是名分别答。复次善男子。或言佛性即是如来金刚之身三十二相八十种好。何以故。不虚诳故。或言佛性即是十力四无所畏大慈大悲及三念处首楞严等一切三昧。何以故。因是三昧生金刚身三十二相八十种好故。是故如来遮此二边。说言佛性非内非外亦名内外。是名中道是名分别答。复次善男子。或有说言佛性即是内善思惟。何以故。离善思惟则不能得阿耨多罗三藐三菩提故。是故佛性即是内善思惟。或有说言佛性即是从他闻法。何以故。从他闻法则能内善思惟。若不闻法则无思惟。是以佛性即是从他闻法。是故如来遮此二边。说言佛性非内非外亦名内外。是名中道。复次善男子。复有说言佛性是外。谓檀波罗蜜从檀波罗蜜得阿耨多罗三藐三菩提。是以说言檀波罗蜜即是佛性。或有说言佛性是内谓五波罗蜜。何以故。离是五事当知则无佛性因果。是以说言五波罗蜜即是佛性。是故如来遮此二边。说言佛性非内非外亦内亦外。是名中道。复次善男子。或有说言佛性在内。譬如力士额上宝珠。何以故。常乐我净如宝珠故。是以说言佛性在内。或有说言佛性在外如贫宝藏。何以故。方便见故。佛性亦尔在众生外。以方便故而得见之。是故如来遮此二边。说言佛性非内非外亦内亦外。是名中道

善男子。众生佛性非有非无。所以者何。佛性虽有非如虚空。何以故。世间虚空虽以无量善巧方便不可得见。佛性可见是故虽有非如虚空。佛性虽无不同兔角。何以故。龟毛兔角虽以无量善巧方便不可得生。佛性可生是故虽无不同兔角。是故佛性非有非无亦有亦无。云何名有。一切悉有是诸众生不断不灭犹如灯焰。乃至得阿耨多罗三藐三菩提。是故名有。云何名无。一切众生现在未有一切佛法常乐我净。是故名无。有无合故即是中道。是故佛说众生佛性非有非无。善男子。如有人问是种子中有果无耶。应定答言亦有亦无。何以故。离子之外不能生果是故名有。子未出芽是故名无。以是义故。亦有亦无。所以者何。时节有异其体是一。众生佛性亦复如是。若言众生中别有佛性者。是义不然。何以故。众生即佛性。佛性即众生。直以时异有净不净。善男子。若有问言是子能生果不。是果能生子不。应定答言亦生不生。世尊。如世人说乳中有酪是义云何。善男子。若有说言乳中有酪是名执着。若言无酪是名虚妄。离是二事应定说言亦有亦无。何故名有。从乳生酪因即是乳果即是酪。是名为有。云何名无。色味各异服用不同。热病服乳冷病服酪。乳生冷病酪生热病。善男子。若言乳中有酪性者。乳即是酪酪即是乳其性是一。何因缘故乳在先出酪不先生。若有因缘一切世人何故不说。若无因缘何故酪不先出。若酪不先出谁作次第乳酪生苏熟苏醍醐。是故知酪先无今有。若先无今有是无常法。善男子。若有说言乳有酪性能生于酪。水无酪性故不生酪。是义不然。何以故。水草亦有乳酪之性。所以者何。因于水草则出乳酪。若言乳中定有酪性水草无者。是名虚妄。何以故心不等故。故言虚妄。善男子。若言乳中定有酪者。酪中亦应定有乳性。何因缘故乳中出酪酪不出乳。若无因缘当知是酪本无今有。是故智者应言乳中非有酪性非无酪性。善男子。是故如来于是经中说如是言。一切众生定有佛性是名为着。若无佛性是名虚妄。智者应说众生佛性亦有亦无。善男子。四事和合生于眼识。何等为四。眼色明欲。是眼识性非眼非色非明非欲。从和合故便得出生如是眼识本无今有已有还无。是故当知无有本性。乳中酪性亦复如是。若有说言水无酪性故不出酪。是故乳中定有酪性。是义不然。何以故。善男子。一切诸法异因异果。亦非一因生一切果。非一切果从一因生。善男子。如从四事生于眼识。不可复说从此四事应生耳识。善男子。离于方便乳中得酪酪出生酥。不得如是要须方便。善男子。智者不可见离方便从乳得酪。谓得生酥亦应如是离方便得善男子。是故我于是经中说。因生故法有。因灭故法无。善男子。如盐性碱能令非碱使碱。若非碱物先有碱性。世人何故更求盐耶。若先无者当知先无今有。以余缘故而得碱也。若言一切不碱之物皆有碱性。微故不知由此微性盐能令碱。若本无性虽复有盐不能令碱。譬如种子自有四大。缘外四大而得增长芽茎枝叶。盐性亦尔者。是义不然。何以故。不碱之物先有碱性者。盐亦应有微不碱性。是盐若有如是二性。何因缘故离不碱物不可独用。是故知盐本无二性。如盐一切不碱之物亦复如是。若言外四大种力能增长内四大者。是义不然。何以故。次第说故不从方便。乳中得酪生苏乃至一切诸法皆不如是非方便得。四大亦复如是。若说从外四大增内四大。不见从内四大增外四大。如尸利沙果先无形质。见昂星时果则出生足长五寸。如是果者实不因于外四大增

善男子。如我所说十二部经。或随自意说。或随他意说。或随自他意说。云何名为随自意说。如五百比丘问舍利弗。大德。佛说身因何者是耶。舍利弗言。诸大德。汝等亦各得正解脱自应识之。何缘方作如是问耶。有比丘言。大德。我未获得正解脱时意谓。无明即是身因。作是观时得阿罗汉果。复有说言。大德。我未获得正解脱时谓。爱无明即是身因。作是观时得阿罗汉果。或有说言。行识名色六入触受爱取有生饮食五欲即是身因。尔时五百比丘。各各自说己所解已共往佛所。稽首佛足右绕三匝礼拜毕已却坐一面。各以如上己所解义向佛说之。舍利弗白佛言。世尊。如是诸人谁是正说。谁不正说。佛告舍利弗。善哉善哉一一比丘无非正说。舍利弗言。世尊。佛意云何。佛言舍利弗。我为欲界众生说言。父母即是身因。如是等经名随自意说。云何名为随他意说。如巴吒罗长者。来至我所作如是言。瞿昙。汝知幻不。若知幻者即大幻人。若不知者非一切智。我言。长者。知幻之人名幻人耶。长者言。善哉善哉。知幻之人即是幻人。佛言。长者。舍卫国内波斯匿王有旃陀罗名曰气嘘。汝知不耶。长者答言。瞿昙。我久知之。佛言。汝久知者可得即是旃陀罗不。长者言。瞿昙。我虽知是旃陀罗。然我此身非旃陀罗。佛言。长者。汝得是义知旃陀罗非旃陀罗。我今何故不得知幻而非幻乎。长者。我实知幻知幻人知幻果报知幻伎术。我知杀知杀人知杀果报知杀解脱。乃至知邪见知邪见人知邪见果报知邪见解脱。长者。若说非幻之人名为幻人。非邪见人说邪见人得无量罪。长者言。瞿昙。如汝所说我得大罪。我今所有悉以相上。幸莫令彼波斯匿王知我此事。佛言。长者。是罪因缘不必失财。乃当因是堕三恶道。是时长者闻恶道名心生恐怖。白佛言。圣人。我今失意获得大罪。圣人。今者是一切智应当了知获得解脱。我当云何得脱地狱饿鬼畜生。尔时我为说四真谛。长者。闻已得须陀洹果心生惭愧向佛忏悔。我本愚痴佛非幻人而言是幻。我从今日归依三宝。佛言。善哉善哉。长者。是名随他意说。云何名为随自他说。如我所说如一切世间智者说有我亦说有。智人说无我亦说无。世间智人说五欲乐有无常苦无我可断我亦说有。世间智人说五欲乐有常我净无有是处。我亦如是说无是处。是名随自他说。善男子。如我所说十住菩萨少见佛性。是名随他意说。何故名少见。十住菩萨得首楞严等三昧三千法门。是故了了自知当得阿耨多罗三藐三菩提。不见一切众生定得阿耨多罗三藐三菩提。是故我说十住菩萨少见佛性。善男子。我常宣说一切众生悉有佛性。是名随自意说。一切众生不断不灭乃至得阿耨多罗三藐三菩提。是名随自意说。一切众生悉有佛性。烦恼覆故不能得见。我说如是汝说亦尔。是名随自他意说

善男子。如来或时为一法故说无量法。如经中说一切梵行因善知识。一切梵行因虽无量。说善知识则已摄尽。如我所说一切恶行邪见为因。一切恶行因虽无量。若说邪见则已摄尽。或说阿耨多罗三藐三菩提信心为因。是菩提因虽复无量。若说信心则已摄尽。善男子。如来虽说无量诸法以为佛性。然不离于阴入界也

善男子。如来说法为众生故有七种语。一者因语。二者果语。三者因果语。四者喻语。五者不应说语。六者世流布语。七者如意语。云何名因语。现在因中说未来果如我所说。善男子。汝见众生乐杀乃至乐行邪见。当观是人即地狱人。善男子。若有众生不乐杀生乃至邪见。当观是人即是天人。是名因语。云何果语。现在果中说过去因如经中说。善男子。如汝所见贫穷众生颜貌丑陋不得自在。当知是人定有破戒妒心嗔心无惭愧心。若见众生多财巨富诸根完具威德自在。当知是人定有戒施精勤惭愧无有妒嗔。是名果语。云何因果语如经中说。善男子。众生现在六入触因。是名过去业果。如来亦说名之为业。是业因缘得未来果。是名因果语。云何喻语。如说师子王者即喻我身。大象王大龙王。波利质多罗树。七宝聚大海须弥山大地大雨。船师导师调御丈夫。力士牛王婆罗门沙门。大城多罗树。如是喻经。名为喻语。云何不应语。我经中说天地可合河不入海。如为波斯匿王说四方山来。如为鹿母优婆夷说。若娑罗树能受八戒。则得受于人天之乐。如说十住菩萨有退转心。不说如来有二种语。宁说须陀洹人堕三恶道。不说十住有退转心。是名不应语。云何世流布语。如佛所说男女大小去来坐卧。车乘房舍瓶衣。众生常乐我净。军林城邑僧幻合散。是名世流布语。云何如意语。如我呵责毁禁之人。令彼自责护持禁戒。如我赞叹须陀洹人。令诸凡夫生于善心。赞叹菩萨为令众生发菩提心。说三恶道所有苦恼。为令修习诸善法故。说一切烧唯为一切有为法故无我亦尔。说诸众生悉有佛性。为令一切不放逸故。是名如意语

大般涅槃经卷第三十五大般涅槃经卷第三十六

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之四

善男子。如来复有随自意语。如来佛性则有二种。一者有。二者无。有者。所谓三十二相八十种好。十力四无所畏。三念处大慈大悲。首楞严等无量三昧。金刚等无量三昧。方便等无量三昧。五智印等无量三昧。是名为有无者。所谓如来过去诸善不善无记业因果报。烦恼五阴十二因缘。是名为无。善男子。如有无善不善。有漏无漏。世间非世间。圣非圣有为无为。实不实寂静非寂静。诤非诤界非界。烦恼非烦恼。取非取受记非。受记。有非有三世非三世。时非时常无常我无我乐无乐净无净。色受想行识非色受想行识。内入非内入。外入非外入。十二因缘非十二因缘。是名如来佛性有无。乃至一阐提佛性有无。亦复如是。善男子。我虽说言一切众生悉有佛性。众生不解佛如是等随自意语。善男子。如是语者。后身菩萨尚不能解。况于二乘其余菩萨。善男子。我往一时在耆阇崛山。与弥勒菩萨共论世谛。舍利弗等五百声闻于是事中都不识知。何况出世第一义谛。善男子。或有佛性一阐提有善根人无。或有佛性善根人有一阐提无。或有佛性二人俱有。或有佛性二人俱无。善男子。我诸弟子若解如是四句义者。不应难言一阐提人定有佛性定无佛性。若言众生悉有佛性。是名如来随自意语。如来如是。随自意语。众生云何一向作解。善男子。如恒河中有七众生。一者常没。二者暂出还没。三者出已则住。四者出已遍观四方。五者遍观已行。六者行已复住。七者水陆俱行。言常没者。所谓大鱼。受大恶业身重处深是故常没。暂出还没者。如是大鱼。受恶业故身重处浅暂见光明。因光故出重故还没。出已住者。谓坻弥鱼。身处浅水乐见光明故出已住。遍观万者。所谓[魚*昔]鱼。为求食故遍观四方是故观方。观已行者。谓是[魚*昔]鱼。遥见余物谓是可食。疾行趣之故观已行。行已复住者。是鱼趣已既得可食即便停住故行已复住。水陆俱行者。即是龟也。善男子。如是微妙大涅槃河。其中亦有七种众生。从初常没乃至第七或入或出。所言没者。有人闻是大涅槃经如来常住无有变易。常乐我净终不毕竟入于涅槃。一切众生悉有佛性。一阐提人谤方等经作五逆罪犯四重禁。必当得成菩提之道。须陀洹人斯陀含人阿那含人阿罗汉人辟支佛等。必当得成阿耨多罗三藐三菩提。闻是语已生不信心即作是念。作是念已便作是言。是涅槃典即外道。书非是佛经。是人尔时远离善友不闻正法。虽时得闻不能思惟。虽复思惟不思惟善。不思善故如恶法住。恶法住者则有六种。一者恶。二者无善。三者污法。四者增有。五者恼热。六者受恶果。是名为没。何故名没。无善心故。常行恶故。不修对治故。是名为没。所言恶者。圣人呵责故。心生怖畏故。善人远离故。不益众生故。是名为恶。言无善者。能生无量恶果报故。常为无明所缠绕故。乐与恶人为等侣故。无有修善诸方便故。其心颠倒常错谬故。是名无善言。污法者。常污身口故。污净众生故。增不善业故。远离善法故。是名污法。言增有者。如上三人所行之法。能增地狱畜生饿鬼。不能修习解脱之法。身口意业不厌诸有。是名增有。言恼热者。是人具行如上四事。能令身心二事恼热。远离寂静则名为热。受地狱报故名为热。烧诸众生故名为热。烧诸善法故名为热。善男子。信心清凉是人不具。是故名热。言受恶果者。是人具足行上五事。死堕地狱饿鬼畜生。善男子。有三恶事复名恶果。一者烦恼恶。二者业恶。三者报恶。是名受恶果报。善男子。是人具足如上六事。能断善根作五逆罪。能犯四重能谤三宝用僧鬘物。能作种种非法之事。是因缘故沉没在于阿鼻地狱。所受身形纵广八万四千由旬。是人身口心业重故不能得出。何以故。其心不能生善法故。虽有无量诸佛出世不闻不见。是故名常没如恒河中大鱼。善男子。我虽复说一阐提等。名为常没。复有常没。非一阐提何者是耶。如人为有修施戒善。是名常没。善男子。有四善事获得恶果。何等为四。一者为胜他故读诵经典。二者为利养故受持禁戒。三者为他属故而行布施。四者为于非想非非想处故系念思惟。是四善事得恶果报。若人修习如是四事。是名没已还出出已还没。何故名没。乐三有故。何故名出。以见明故。明者即是闻戒施定。何故还没。增长邪见生憍慢故。是故我于经中说偈

  若有众生乐诸有　　为有造作善恶业
  是人迷失涅槃道　　是名暂出还复没
  行于黑闇生死海　　虽得解脱杂烦恼
  是人还受恶果报　　是名暂出还复没

善男子。如彼大鱼因见光故暂得出水。其身重故还复沉没。如上二人亦复如是。善男子。或复有人乐着三有。是名为没。得闻如是大涅槃经生于信心。是名为出。何因缘故名之为出。闻是经已远离恶法修习善法。是名为出。是人虽信亦不具足。何因缘故信不具足。是人虽信大般涅槃常乐我净。言如来身无常无我无乐无净。如来则有二种涅槃。一者有为。二者无为。有为涅槃无常乐我净。无为涅槃有常乐我净。虽信佛性是众生有。不必一切皆悉有之。是故名为信不具足。善男子。信有二种。一者信。二者求。如是之人虽复有信不能推求。是故名为信不具足。信复有二。一从闻生。二从思生。是人信心从闻而生不从思生。是故名为信不具足。复有二种。一信有道。二信得者。是人信心唯信有道。都不信有得道之人。是故名为信不具足。复有二种。一者信正。二者信邪。言有因果有佛法僧。是名信正。言无因果三宝性异。信诸邪语富兰那等。是名信邪。是人虽信佛法僧宝。不信三宝同一性相。虽信因果不信得者。是故名为信不具足。是人成就不具足信。所受禁戒亦不具足。何因缘故名不具足。因不具故所得禁戒亦不具足。复何因缘名不具足。戒有二种。一威仪戒。二从戒戒。是人唯具威仪等戒。不具从戒戒。是故名为戒不具足。复有二种。一者作戒。二者无作戒。是人唯具作戒。不具无作戒。是故名为戒不具足。复有二种。一从身口得于正命。二从身口不得正命。是人虽从身口不得正命。是故名为戒不具足。复有二种。一者求戒。二者舍戒。是人唯具求有之戒不得舍戒。是故名为戒不具足。复有二种。一者随有。二者随道。是人唯具随有之戒不具随道。是故名为戒不具足。复有二种一者善戒。二者恶戒。身口意善是名善戒。牛戒狗戒是名恶戒。是人深信是二种戒俱有善果。是故名为戒不具足是人不具信戒二事。所修多闻亦不具足。云何名为闻不具足。如来所说十二部经。唯信六部不信六部。是故名为闻不具足。虽复受持是六部经。不能读诵为他解说无所利益。是故名为闻不具足。又复受是六部经已。为论议故为胜他故为利养故为诸有故受持读诵解说。是故名为闻不具足。善男子。我于经中说闻具足。云何具足。若有比丘身口意善。先能供养和上诸师有德之人。是诸师等于是人所生爱念心。以是因缘教授其法。是人至心受持诵习。持诵习已获得智慧。得智慧已能善思惟如法而住。善思惟已则得正义。得正义已身心寂静。身心寂已则生喜心。喜心因缘心则得定。因得定故得正知见。正知见已于诸有中心生厌悔。悔诸有故能得解脱。是人无有如是等事。是故名为闻不具足。是人不具如是三事。施亦不具。施有二种。一者财施。二者法施。是人虽复行于财施为求有故。虽行法施亦不具足。何以故。秘不尽说畏他胜故。是故名为施不具足。财法二施各有二种。一者圣。二者非圣。圣者施已不求果报。非圣施已求于果报。圣者法施为增长法。非圣法施为增诸有。如是之人为增财故而行财施。为增有故而行法施。是故名为施不具足。复次是人受六部经。见受法者而供给之。不受法者则不供给。是故名为施不具足。是人不具如上四事。所修智慧亦不具足。智慧之性性能分别。是人不能分别如来是常无常。如来于此涅槃经中说言。如来即是解脱。解脱即是如来。如来即是涅槃。涅槃即是解脱。于是义中不能分别。梵行即是如来。如来即是慈悲喜舍。慈悲喜舍即是解脱。解脱即是涅槃。涅槃即是慈悲喜舍。于是义中不能分别。是故名为智不具足。复次不能分别佛性。佛性即是如来。如来即是一切不共之法。不共之法即是解脱。解脱即是涅槃。涅槃即是不共之法。于是义中不能分别。是故名为智不具足。复次不能分别四谛苦集灭道。不能分别四真谛故不知圣行。不知圣行故不知如来。不知如来故不知解脱。不知解脱故不知涅槃。是故名为智不具足。是人不具如是五事。则有二种。一增善法。二增恶法。云何名为增长恶法。是人不见己不具足。自言具足而生着心。于同行中自谓为胜。是故亲近同己恶友。既亲近已复得更闻不具足法。闻已心喜其心染着。起于憍慢多行放逸。因放逸故亲近在家。亦乐闻说在家之事。远离清净出家之法。以是因缘增长恶法。增恶法故身口意等起不净业。三业不净故增长地狱畜生饿鬼。是名暂出还没暂出还没者。我佛法中其谁是耶。谓提婆达多。瞿伽离比丘。惋手比丘。善星比丘低舍比丘。满宿比丘。慈地比丘尼。旷野比丘尼。方比丘尼。慢比丘尼。净洁长者。求有优婆塞。舍勒释种。象长者。名称优婆夷。光明优婆夷。难陀优婆夷。军优婆夷。铃优婆夷。如是等人名为暂出还没。譬如大鱼见明故出身重故没。第二之人深自知见行不具足。不具足故求近善友。近善友故乐咨未闻。闻已乐受。受已乐善思惟。善思惟已能如法住。如法住故增长善法。增善法故终不复没。是名为住。我佛法中其谁是耶。谓舍利弗。大目犍连阿若憍陈如等五比丘。耶舍等五比丘。阿[少/兔]楼陀。童子迦叶。摩诃迦叶。十力迦叶。瘦瞿昙弥比丘尼。波吒罗花比丘尼。胜比丘尼。实义比丘尼。意比丘尼。跋陀比丘尼。净比丘尼。不退转比丘尼。频婆娑罗王。郁伽长者。须达多长者。释摩男。贫须达多。鼠狼长者子。名称长者。具足长者。师子将军。优波离长者。刀长者。无畏优婆夷。善住优婆夷。爱法优婆夷。勇健优婆夷。天得优婆夷。善生优婆夷。具身优婆夷。牛得优婆夷。旷野优婆夷。摩诃斯那优婆夷。如是等比丘比丘尼。优婆塞优婆夷。得名为住。云何为住。常乐睹见善光明故。以是因缘若佛出世若不出世。如是等人终不造恶。是名为住。如低弥鱼乐见光明不沈不没。如是等众亦复如是。是故我于经中说偈

  若人善能分别义　　至心求于沙门果
  若能呵责一切有　　是人名为如法住
  若能供养无量佛　　则能无量世修道
  若受世乐不放逸　　是人名为如法住
  亲近善友听正法　　内善思惟如法住
  乐见光明修习道　　获得解脱安隐住

善男子。智不具足凡有五事。是人知已求近善友。如是善友当观是人贪欲嗔恚愚痴思觉何者偏多。若知是人贪欲多者即应为说不净观法。嗔恚多者为说慈悲。思觉多者教令数息。着我多者当为分析十八界等。是人闻已至心受持。心受持已如法修行。如法行已次第获得四念处观身受心法。得是观已次第复观十二因缘。如是观已次得暖法。迦叶菩萨白佛言。世尊。一切众生悉有暖法。何以故。如佛所说三法和合名为众生。一寿二暖三识。若从是义一切众生应先有暖。云何如来说言暖法因善友生。佛言。善男子。如汝所问有暖法者。一切众生至一阐提皆悉有之。如我今者所说暖法。要因方便然后乃得本无今有。以是义故。非诸众生一切先有。是故汝今不应难言一切众生皆有暖法。善男子。如是暖法是色界法非欲界有。若言一切众生有者。欲界众生亦皆应有。欲界无故当知一切不必都有。善男子。色界虽有非一切有。何以故。我弟子有外道则无。以是义故。一切众生不必都有。善男子。一切外道唯观六行。我诸弟子具足十六。是十六行一切众生不必都有。迦叶菩萨白佛言。世尊。所言暖法云何名暖。为自性暖为他故暖。佛言。善男子。如是暖法自性是暖非他故暖。迦叶。菩萨言。世尊。如来先说马师满宿无有暖法。何以故。于三宝所无信心故是故无暖。当知信心即是暖法。善男子。信非暖法。何以故。因于信心获得暖故。善男子。夫暖法者即是智慧。何以故观四谛故。是故名之为十六行。行即是智。善男子。如汝所问何因缘故名为暖者。善男子。夫暖法者。即是八圣道之火相。故名为暖。善男子。譬如攒火先有暖气次有火生后则烟出。是无漏道亦复如是。暖者即是十六行也。火者即是须陀洹果。烟者即是修道断结。迦叶菩萨复白佛言。世尊。如是暖法亦是有法亦是有为。是法报得色界五阴是故名有。是因缘故复名有为。若是有为云何能为无漏道相。佛言。善男子。如是如是如汝所说。善男子。如是暖法虽是有为有法。还能破坏有为有法。是故能为无漏道相。善男子。如人乘马亦爱亦策。暖心亦尔爱故受生厌故观行。是故虽复有法有为。而能与彼正道作相。得暖法人七十三种欲界十种。是人具足一切烦恼。从断一分至于九分。如欲界初禅乃至无所有处亦复如是。是名七十三种如是等人得暖法已。则不复能断于善根作五逆罪犯四重禁。是人二种。一遇善友。二遇恶友。遇恶友者暂出还没。遇善友者遍观四方。观四方者即是顶法。是法虽复性是五阴亦缘四谛。是故得名遍观四方。得顶法已次得忍法。是忍亦尔性亦五阴亦缘四谛。是人次得世第一法。是法虽复性是五阴亦缘四谛。是人次第得苦法忍。忍性是慧缘于一谛。如是忍法缘一谛已。乃至见断烦恼得须陀洹果。是名第四遍观四方。四方者即是四谛。迦叶菩萨白佛言。世尊。如佛先说须陀洹人所断烦恼。犹如纵广四十里水。其余在者如一毛渧。此中云何说断三结名须陀洹一者我见。二者非因。见因三者疑网。世尊。何因缘故名须陀洹遍观四方。复何因缘名须陀洹。复何因缘说须陀洹喻以[魚*昔]鱼。佛言。善男子。须陀洹人虽复能断无量烦恼。此三重故亦摄一切须陀洹人所断结故。善男子。譬如大王出游巡时。虽有四兵世人但言王来王去。何以故世间重故。是三烦恼亦复如是。何因缘故名之为重。一切众生常所起故微难识故。是故名重。如是三结难可断故。能为一切烦恼因故。是三对治之怨敌故。谓戒定慧。善男子。有诸众生闻须陀洹能断如是无量烦恼。则生退心便作是言。众生云何能断如是无量烦恼。是故如来方便说三。如汝所问何因缘故须陀洹人喻观四方。善男子。须陀洹人观于四谛获得四事。一者住坚固道。二者能遍观察。三者能如实见。四者能坏大怨。坚固道者是须陀洹所有五根无能动者。是故名为住坚固道。能遍观者悉能呵责内外烦恼。如实见者即是忍智。坏大怨者谓四颠倒。如汝所问何因缘故名须陀洹者。善男子。须名无漏。陀洹名修习。修习无漏名须陀洹。善男子。复有须者名流。流有二种。一者顺流。二者逆流。以逆流故名须陀洹。迦叶菩萨言。世尊。若从是义何因缘故。斯陀含人阿那含人阿罗汉人。不得名为须陀洹耶。善男子。从须陀洹乃至诸佛。亦得名为须陀洹。若斯陀含乃至诸佛无须陀洹。云何得名斯陀含乃至佛。一切众生名有二种。一者旧。二者客。凡夫之时有世名字。既得道已更为立名名须陀洹。以先得故名须陀洹。以后得故名斯陀含。是人亦名须陀洹亦名斯陀含。乃至佛亦复如是。善男子。流有二种。一者解脱。二者涅槃。一切圣人皆有是二。亦可得名须陀洹亦名斯陀含。乃至佛亦复如是。善男子。须陀洹者亦名菩萨。何以故。菩萨者即是尽智及无生智。须陀洹人亦复求索如是二智。是故当知须陀洹人得名菩萨。须陀洹人亦得名觉。何以故。正觉见道断烦恼故。正觉因果故。正觉共道及不共道故。斯陀含乃至阿罗汉亦复如是。善男子。是须陀洹凡有二种。一者利根。二者钝根。钝根之人人天七返。是钝根人复有五种。或有六五四三二种。利根之人现在获得须陀洹果至阿罗汉果。善男子。如汝所问何因缘故须陀洹人喻以[魚*昔]鱼。善男子。[魚*昔]鱼有四事。一者骨细故轻。二者有翅故轻。三者乐见光明。四者衔物坚持。须陀洹人亦有四事。言骨细者喻烦恼微。言有翅者喻奢摩他毗婆舍那。乐见光明喻于见道。衔物坚持喻闻如来说无常苦无我不净坚持不舍。犹如魔王化作佛像。首罗长者见已心惊。魔见长者其心动已即语长者。我先所说四真谛者是说不真。今当为汝更说五谛六阴十三入十九界。长者闻已寻观法相都无此理。是故坚持其心不动。迦叶菩萨白佛言。世尊。是须陀洹先得道故名须陀洹以初果故。名须陀洹。若先得道名须陀洹者。得苦法忍时何故不得名须陀洹乃名为向。若以初果名须陀洹。外道之人先断烦恼至无所有处。修无漏道得阿那含果。何故不名为须陀洹。善男子。以初果故名须陀洹。如汝所问外道之人先断烦恼至无所有处。修无漏道得阿那含。何故不名须陀洹者。善男子。以初果故名须陀洹。是人尔时具足八智及十六行。迦叶言。世尊。得阿那含亦复如是。亦得八智具十六行。何故不得名须陀洹。善男子。有漏十六行有二种。一者共。二者不共。无漏十六行亦有二种。一者向果。二者得果。八智亦二。一者向果。二者得果。须陀洹人舍共十六行。得不共十六行。舍向果八智。得得果八智。阿那含人即不如是。是故初果名须陀洹。善男子。须陀洹人缘于四谛。阿那含人唯[魚*昔]一谛。是故初果名须陀洹。以是因缘喻以[魚*昔]鱼。遍观已行。行者即是斯陀含人系心修道。为断贪欲嗔痴憍慢。如彼[魚*昔]鱼遍观方已为食故行行已复住。喻阿那含得食已住。是阿那含凡有二种。一者现在得阿那含。进修即得阿罗汉果。二者贪着色界无色界中寂静三昧。是人不受欲界身故名阿那含。是阿那含复有五种。一者中般涅槃。二者受身般涅槃。三者行般涅槃。四者无行般涅槃。五者上流般涅槃。复有六种五种。如上加现在般涅槃。复有七种六种。如上加无色界般涅槃行般涅槃。复有二种或受二身或受四身。若受二身是名利根。若受四身是名钝根。复有二种。一者精进无自在定。二者懈怠有自在定。复有二种。一者具精进定。二者不具是二。善男子。欲色众生有二种业。一者作业。二者受生业。中涅槃者。唯有作业无受生业。是故于中而般涅槃。舍欲界身未至色界。以利根故于中涅槃是中涅槃。阿那含人有四种心。一者非学非无学。二者学。三者无学。四者非学非无学。入于涅槃云何复名中般涅槃。善男子。是阿那含四种心中。二是涅槃二非涅槃。是故名为中般涅槃。受身涅槃复有二种。一者作业。二者生业。是人舍欲界身受色界身。精勤修道尽其寿命入于涅槃。迦叶菩萨言。世尊。若言尽命入涅槃者。云何而言受身涅槃。佛言。善男子。是人受身然后乃断三界烦恼。是故名为受身涅槃。善男子。行般涅槃者。常修行道有为三昧力故。能断烦恼入于涅槃。是名行般涅槃。无行般涅槃者。是人定知当得涅槃是故懈怠。亦以有为三昧力故。寿尽则得入于涅槃。是名无行般涅槃。上流般涅槃者。若有人得第四禅已。是人生于初禅爱心。以是因缘退生初禅。是有二流。一烦恼流。二者道流。以道流故是人寿尽生二禅爱。以爱因缘生于二禅。至第四禅亦复如是。是四禅中复有二种。一者入无色界。二者入五净居。如是二人。一乐三昧二乐智慧。乐智慧者入五净居。乐三昧者入无色界。如是二人。一者修第四禅有五阶差。二者不修。云何为五。下中上上中上上。修上上者处无小天。修上中者处善见天。修上品者处善可见天。修中品者处无热天。修下品者处少广天。如是二人。一乐论议。二乐寂静。乐寂静者入无色界。乐论议者处五净居。复有二种。一者修熏禅。二者不修熏禅。修熏禅者入五净居。不修熏禅者生无色界。尽其寿命而般涅槃。是名上流般涅槃。若欲入于无色界者。即不能修四禅五差。若修四禅五差则能呵责无色界定。迦叶菩萨白佛言。世尊。中涅槃者则是利根。若利根者何不现在入涅槃耶。何故欲界有中涅槃色界则无。佛言。善男子。是人现在四大羸劣不能修道。虽有比丘四大康健。无有房舍饮食衣服卧具医药。众缘不具是故不得现在涅槃。善男子。我昔一时在舍卫国阿那邠低精舍。有一比丘来至我所作如是言。世尊。我常修道而不能得须陀洹果至阿罗汉果。我时即告阿难言。汝今当为如是比丘具诸所须。尔时阿难将是比丘。至只陀林与好房舍。是时比丘语阿难言。大德。唯愿为我庄严房舍净洁修治。七宝严丽悬缯幡盖。阿难言。世间贫者乃名沙门。我当云何能办是事。是比丘言。大德。若能为我作者善哉善哉。若不能者我当还往至世尊所。尔时阿难即往佛所作如是言。世尊。向者比丘。从我求索种种庄严七宝幡盖。不审是事当云何耶。我于尔时复告阿难。汝今还去随比丘意。所须之物为办具之。尔时阿难即还房中。为是比丘事事具辨。比丘得已系念修道。不久即得须陀洹果至阿罗汉果。善男子。无量众生应入涅槃。以所乏故妨乱其心是故不得。善男子。复有众生多喜教化。其心匆务不能得定。是故不得现在涅槃。善男子。如汝所问何因缘故。舍欲界身有中涅槃色界无者。善男子。是人观于欲界烦恼因缘有二。一者内。二者外。而色界中无外因缘。欲界复有二种爱心。一者欲爱。二者色爱。观是二爱至心呵责。既呵责已得入涅槃。是欲界中能得呵责诸粗烦恼。所谓悭贪嗔妒无惭无愧。以是因缘能得涅槃。又欲界道其性勇健。何以故得四果故。是故欲界有中涅槃色界中无。善男子。中涅槃者凡有三种。谓上中下。上者。舍身未离欲界便得涅槃。中者。始离欲界未至色界便得涅槃。下者。离欲界已至色界边乃得涅槃。喻以[魚*昔]鱼得食已住。是人亦尔。云何名住。处在色界及无色界得受身故。是故名住。不受欲界人天地狱畜生饿鬼。是故名住。已断无量诸烦恼结余少在故。是故名住。复何因缘名之为住。终不造作共凡夫事。是故名住。自无所畏不令他畏。是故名住。远离二爱悭贪嗔恚。是故名住。善男子。到彼岸者。喻阿罗汉辟支佛菩萨佛。犹如神龟水陆俱行。何因缘故。喻之以龟。善藏五根故。阿罗汉乃至诸佛亦复如是。善覆五根是故喻龟。言水陆者。水喻世间陆喻出世。是诸圣等亦复如是。能观一切恶烦恼故到于彼岸。是故喻以水陆俱行。善男子。如恒河中七种众生。虽有鱼龟之名不离于水。如是微妙大涅槃中。从一阐提上至诸佛虽有异名。然亦不离于佛性水。善男子。是七众生若善法若不善法。若方便道若解脱道若次第道。若因若果悉是佛性。是名如来随自意语。迦叶菩萨言。世尊。若有因则有果。若无因则无果。涅槃名果。常故无因。若无因者云何名果。而是涅槃亦名沙门名沙门果。云何沙门。云何沙门果。善男子。一切世间有七种果。一者方便果。二者报恩果。三者亲近果。四者余残果。五者平等果。六者果报果。七者远离果。方便果者。如世间人秋多收谷。咸相谓言得方便果。方便果者名业行果。如是果者有二种因。一者近因。二者远因。近因者。所谓种子。远因者。谓水粪人功。是名方便果。报恩果者。如世间人供养父母。父母咸言我今已得恩养之果。子能报恩名之为果。如是果者因亦二种。一者近因。二者远因。近因者。即是父母过去纯善之业。远因者。即是所生孝子。是名报恩果。亲近果者。譬如有人亲近善友或得须陀洹果至阿罗汉果。是人唱言我今已得亲近果报。如是果者因有二种。一者近因。二者远因。近者信心。远者善友。是名亲近果。余残果者。如因不杀得第三身延年益寿。是名残果。如是果者有二种因。一者近因。二者远因。近者。即是身口意净。远者。即是延年益寿。是名残果。平等果者谓世界器。如是果者亦二种因。一者近因。二者远因。近因者。所谓众生修十善业。远因者。所谓三灾。是名平等果。果报果者。如人获得清净身已修身口意清净三业。是人便说我得报果。如是果者因有二种。一者近因。二者远因。近因者。所谓现在身口意净。远因者。所谓过去身口意净。是名果报果。远离果者。即是涅槃离诸烦恼一切善业。是涅槃因复有二种。一者近因。二者远因。近因者。即是三解脱门。远因者。即无量世所修善法。善男子。如世间法或说生因或说了因。出世之法亦复如是亦说生因亦说了因。善男子。三解脱门三十七品。能为一切烦恼作不生生因。亦为涅槃而作了因。善男子。远离烦恼则得了了见于涅槃。是故涅槃唯有了因无有生因。善男子。如汝所问云何沙门那云何沙门果者。善男子。沙门那者即八正道。沙门果者从道毕竟永断一切贪嗔痴等。是名沙门那沙门果。迦叶菩萨言。世尊。何因缘故。八正道者名沙门那。善男子。世言沙门名之为乏。那者名道。如是道者断一切乏断一切道。以是义故。名八正道为沙门那。从是道中获得果故名沙门果。善男子。又沙门那者。如世间人有乐静者亦名沙门。如是道者亦复如是。能令行者离身口意恶邪命等得乐寂静。是故名之为沙门那。善男子。如世下人能作上人。是名沙门。如是道者亦复如是。能令下人作上人故。是故得名为沙门那。善男子。阿罗汉人修是道者得沙门果。是故得名到于彼岸。阿罗汉果者即是无学。五分法身戒定慧解脱解脱知见。因是五分得到彼岸。是故名为到于彼岸。到彼岸故而自说言。我生已尽梵行已立。所作已办更不受有。善男子。是阿罗汉永断三世生因缘故。是故自说。我生已尽。亦断三界五阴果故。是故复言我生已尽。所修梵行已毕竟故。是故唱言梵行已立。又舍学道亦名已立。如本所求今日已得。是故唱言所作已办。修道得果亦言已办。获得尽智无生智故。唱言我生已尽尽诸有结。以是义故。名阿罗汉得到彼岸。如阿罗汉辟支佛亦复如是。菩萨及佛具足成就六波罗蜜名到彼岸。是佛菩萨得阿耨多罗三藐三菩提已。名为具足六波罗蜜。何以故。得六波罗蜜果故。以得果故名为具足

善男子。是七众生不修身不修戒不修心不修慧。不能修习如是四事。则能造作五逆重罪。能断善根犯四重禁谤佛法僧。是故得名为常沉没。善男子。是七人中有能亲近善知识者。至心听受如来正法内善思惟如法而住。精勤修习身戒心慧。是故得名渡生死河到于彼岸。若有说言一阐提人得阿耨多罗三藐三菩提者是名染着。若言不得是名虚妄。善男子。是七种人或有一人具七。或有七人各一。善男子。若有心口异想异说言。一阐提得阿耨多罗三藐三菩提者。当知是人谤佛法僧。若人心口异想异说言。一阐提不得阿耨多罗三藐三菩提。是人亦名谤佛法僧。善男子。若有说言八圣道分凡夫所得。是人亦名谤佛法僧。若有说言八圣道分非凡夫得。是人亦名谤佛法僧。善男子。若有说言一切众生定有佛性定无佛性。是人亦名谤佛法僧。善男子。是故我于契经中说。有二种人谤佛法僧。一者不信嗔恚心故。二者虽信不解义故。善男子。若人信心无有智慧。是人则能增长无明。若有智慧无有信心。是人则能增长邪见。善男子。不信之人嗔恚心故。说言无有佛法僧宝。信者无慧颠倒解义。令闻法者谤佛法僧。善男子。是故我说不信之人嗔恚心故。有信之人无智慧故。是人能谤佛法僧宝。善男子。若有说言一阐提等未生善法。便得阿耨多罗三藐三菩提。是人亦名谤佛法僧。若复有言一阐提人舍一阐提。于异身中得阿耨多罗三藐三菩提。是人亦名谤佛法僧。若复说言一阐提人能生善根。生善根已相续不断得阿耨多罗三藐三菩提。故言一阐提得阿耨多罗三藐三菩提。当知是人不谤三宝。善男子。若有人言一切众生定有佛性常乐我净。不作不生烦恼因缘故不可见。当知是人谤佛法僧。若有说言一切众生都无佛性。犹如兔角从方便生。本无今有已有还无。当知是人谤佛法僧。若有说言众生佛性。非有如虚空非无如兔角。何以故。虚空常故兔角无故。是故得言亦有亦无。有故破兔角。无故破虚空。如是说者不谤三宝。善男子。夫佛性者。不名一法不名十法。不名百法不名千法不名万法。未得阿耨多罗三藐三菩提时。一切善不善无记尽名佛性。如来或时因中说果果中说因。是名如来随自意语。随意语故名为如来。随意语故名阿罗呵。随意语故名三藐三佛陀

大般涅槃经卷第三十六大般涅槃经卷第三十七

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之五

迦叶菩萨言。世尊。如佛所说众生佛性犹如虚空。云何名为如虚空耶。善男子。虚空之性非过去非未来非现在。佛性亦尔。善男子。虚空非过去。何以故无现在故。法若现在可说过去。以无现在故无过去亦无现在。何以故。无未来故。法若未来可说现在。以无未来故无现在亦无未来。何以故。无现在过去故。若有现在过去则有未来。以无现在过去故则无未来。以是义故。虚空之性非三世摄。善男子。以虚空无故无有三世。不以有故无三世也。如虚空花非是有故无有三世。虚空亦尔非是有故无有三世。善男子。无物者。即是虚空佛性亦尔。善男子。虚空无故非三世摄。佛性常故非三世摄。善男子。如来已得阿耨多罗三藐三菩提。所有佛性一切佛法常无变易。以是义故。无有三世犹如虚空。善男子。虚空无故非内非外。佛性常故非内非外。故说佛性犹如虚空。善男子。如世间中无挂碍处名为虚空。如来得阿耨多罗三藐三菩提已于一切佛法无有挂碍。故言佛性犹如虚空。以是因缘我说佛性犹如虚空。迦叶菩萨白佛言。世尊。如来佛性涅槃非三世摄而名为有。虚空亦非三世所摄。何故不得名为有耶。佛言。善男子。为非涅槃名为涅槃。为非如来名为如来。为非佛性名为佛性。云何名为非涅槃耶。所谓一切烦恼有为之法。为破如是有为烦恼。是名涅槃。非如来者。谓一阐提至辟支佛。为破如是一阐提等至辟支佛。是名如来。非佛性者。所谓一切墙壁瓦石无情之物。离如是等无情之物。是名佛性。善男子。一切世间无非虚空对于虚空。迦叶菩萨白佛言。世尊。世间亦无非四大对。而犹得名四大是有。虚空无对何故不得名之为有佛言。善男子。若言涅槃非三世摄虚空亦尔者。是义不然。何以故。涅槃是有可见可证是色足迹章句。是有是相是缘是归依处寂静光明安隐彼岸。是故得名非三世摄。虚空之性无如是法是故名无。若有离于如是等法。更有法者应三世摄。虚空若同是有法者。不得非是三世所摄。善男子。如世人说虚空名为无色无对不可睹见。若无色无对不可见者。即心数法。虚空若同心数法者。不得不是三世所摄。若三世摄即是四阴。是故离四阴已无有虚空。复次善男子。诸外道言。夫虚空者即是光明。若是光明即是色法。虚空若尔是色法者即是无常。是无常故三世所摄。云何外道说非三世。若三世摄则非虚空。亦可说言虚空是常。善男子。复有人言虚空者即是住处。若有住处即是色法。而一切处皆是无常三世所摄。虚空亦常非三世摄。若说处者知无虚空。复有说言虚空者即是次第。若是次第即是数法。若是可数即三世摄。若三世摄云何言常。善男子。若复说言夫虚空者不离三法。一者空。二者实。三者空实。若言空是当知虚空是无常法。何以故实处无故。若言实是当知虚空亦是无常。何以故空处无故。若空实是当知虚空亦是无常。何以故二处无故。是故虚空名之为无。善男子。如说虚空是可作法。如说去树去舍而作虚空平作虚空。覆于虚空上于虚空。画虚空色如大海水。是故虚空是可作法。一切作法皆是无常犹如瓦瓶。虚空若尔应是无常。善男子。世间人说一切法中无挂碍处名虚空者。是无碍处于一切法所。为具足有为分有耶。若具足有。当知余处则无虚空。若分有者。则是彼此可数之法。若是可数当知无常。善男子。若有人说虚空无碍与有并合。又复说言虚空在物如器中果。二俱不然。何以故。若言并合则有三种。一异业合。如飞鸟集树。二共业合。如两羊相触。三已合共合。如二双指合在一处。若言异业共合异则有二。一是物业。二虚空业。若空业合物空则无常。若物业合空物则不遍。如其不遍是亦无常。若言虚空是常。其性不动与动物合者。是义不然。何以故。虚空若常物亦应常。物若无常空亦无常。若言虚空亦常无常无有是处。若共业合是义不然。何以故。虚空名遍。若与业合业亦应遍。若是遍者应一切遍。若一切遍应一切合。不应说有合与不合。若言已合共合如二双指合。是义不然。何以故。先无有合后方合故。先无后有是无常法。是故不得说言虚空已合共合。如世间法先无后有是物无常。虚空若尔亦应无常。若言虚空在物如器中果。是义不然。何以故。如是虚空先无器时在何处住。若有住处虚空则多。如其多者云何言常言一言遍。若使虚空离空有住。有物亦应离虚空住。是故当知无有虚空。善男子。若有说言指住之处名为虚空。当知虚空是无常法。何以故。指有四方若有四方。当知虚空亦有四方。一切常法都无方所。以有方故虚空无常。若是无常不离五阴。要离五阴是无所有。善男子。有法若从因缘住者。当知是法名为无常。善男子。譬如一切众生树木因地而住。地无常故因地之物次第无常。善男子。如地因水水无常故地亦无常。如水因风风无常故水亦无常。风依虚空虚空无常故风亦无常。若无常者云何说言虚空是常遍一切处。虚空无故非是过去未来现在。亦如兔角是无物故。非是过去未来现在。是故我说佛性常故非三世摄。虚空无故非三世摄。善男子。我终不与世间共诤。何以故。世智说有我亦说有世智说无我亦说无。迦叶菩萨言。世尊。菩萨摩诃萨具足几法不与世诤。不为世法之所沾污。佛言。善男子。菩萨摩诃萨具足十法不与世诤。不为世法之所沾污。何等为十。一者信心。二者有戒。三者亲近善友。四者内善思惟。五者具足精进。六者具足正念。七者具足智慧。八者具足正语。九者乐于正法。十者怜愍众生。善男子。菩萨具足如是十法不与世诤。不为世法之所沾污如优钵罗花。迦叶菩萨白佛言。世尊。如佛所说世智说有我亦说有。世智说无我亦说无。何等名为世智有无。佛言。善男子。世智若说色是无常苦空无我。乃至识亦如是。善男子。是名世间智者说有。我亦说有。善男子。世间智者说色无有常乐我净。受想行识亦复如是。善男子。是名世间智者说无。我亦说无。迦叶菩萨白佛言。世尊。世间智者。即佛菩萨一切圣人若诸圣人。色是无常苦空无我。云何如来说佛色身常恒无变。世间智者所说无法。云何如来说言是有。如来世尊作如是说。云何复言不与世诤。不为世法之所沾污。如来已离三种颠倒。所谓想倒心倒见倒。应说佛色实是无常今乃说常。云何得名远离颠倒不与世诤。佛言。善男子。凡夫之色从烦恼生。是故智说色是无常苦空无我。如来色者远离烦恼。是故说是常恒无变

迦叶菩萨言。世尊。云何为色从烦恼生。善男子。烦恼三种。所谓欲漏有漏无明漏。智者应当观是三漏所有罪过。所以者何。知罪过已则能远离。譬如医师先诊病脉。知病所在然后授药。善男子。如人将盲至蕀林中舍之而还。盲人于后甚难得出。设得出者身体坏尽。世间凡夫亦复如是。不能知见三漏过患则随逐行。如其见者则能远离。知罪过已虽受果报果报轻微。善男子。有四种人。一作业时重受报时轻。二作业时轻受报时重。三作业时重受报俱重。四作业时轻受报俱轻。善男子。若人能观烦恼罪过。是人作业受果俱轻。善男子。有智之人作如是念。我应远离如是等漏。又复不应作如是等鄙恶之事。何以故。我今未得脱于地狱饿鬼畜生人天报故。我若修道当因是力破坏诸苦。是人观已贪欲嗔恚愚痴微弱。既见贪欲嗔痴轻已其心欢喜。复作是念。我今如是皆由修道因缘力故。令我得离不善之法亲近善法。是故现在得见正道。应当勤加而修习之。是人因是勤修道力。远离无量诸恶烦恼。及离地狱饿鬼畜生人天果报。是故我于契经中说。当观一切有漏烦恼及有漏因。何以故。有智之人若但观漏。不观漏因则不能断诸烦恼也。何以故。智者观漏从是因生。我今断因漏则不生。善男子。如彼医师先断病因病则不生智者先断烦恼因者。亦复如是。有智之人先当观因。次观果报。知从善因生于善果。知从恶因生于恶果。观果报已远离恶因。观果报已。复当次观烦恼轻重。观轻重已先离重者。既离重已轻者自去。善男子。智者若知烦恼烦恼因烦恼果报烦恼轻重。是人尔时精勤修道。不息不悔。亲近善友至心听法。为灭如是诸烦恼故。善男子。譬如病者自知病轻必可除差。虽得苦药服之不悔。有智之人亦复如是。勤修圣道欢喜不愁不息不悔。善男子。若人能知烦恼烦恼因烦恼果报烦恼轻重。为除烦恼故勤修圣道。是人不从烦恼生。色受想行识亦复如是。若不能知烦恼烦恼因烦恼果报烦恼轻重。不勤修道是人则从烦恼生。色受想行识亦复如是。善男子。知烦恼烦恼因烦恼果报烦恼轻重。为断烦恼修行道者即是如来。以是因缘如来色常乃至识常。善男子。不知烦恼烦恼因烦恼果报烦恼轻重。不能修道即是凡夫。是故凡夫色是无常。受想行识悉是无常。善男子。世间智者一切圣人菩萨诸佛说是二义。我亦如是说是二义。是故我说。不与世间智者共诤。不为世法之所沾污。迦叶菩萨复白佛言。世尊。如佛所说三有漏者。云何名为欲漏有漏无明漏耶。佛言。善男子。欲漏者。内恶觉观因于外缘生于欲漏。是故我昔在王舍城告阿难言。阿难。汝今受此女人所说偈颂。是偈乃是过去诸佛之所宣说。是故一切内恶觉观外诸因缘。名之为欲。是名欲漏。有漏者。色无色界内诸恶法外诸因缘。除欲界中外诸因缘内诸觉观。是名有漏。无明漏者。不能了知我及我所。不别内外。名无明漏。善男子。无明即是一切诸漏根本。何以故。一切众生无明因缘于阴入界忆想作相。名为众生。是名想倒心倒见倒。以是因缘生一切漏。是故我于十二部经说无明者。即是贪因嗔因痴因。迦叶菩萨言。世尊。如来昔于十二部经说言。不善思惟因缘生于贪欲嗔痴。今何因缘乃说无明。善男子。如是二法互为因果互相增长。不善思惟生于无明。无明因缘生不善思惟。善男子。其能生长诸烦恼者。皆悉名为烦恼因缘。亲近如是烦恼因缘。名为无明。不善思惟如子生芽。子是近因四大远因。烦恼亦尔。迦叶菩萨白佛言。世尊。如佛所说无明即漏。云何复言。因无明故生于诸漏。佛言。善男子。如我所说无明漏者。是内无明因于无明。生诸漏者。是内外因。若说无明漏是名内倒。不识无常苦空无我。若说一切烦恼因缘。是名不知外我我所。若说无明漏。是名无始无终。从无明生阴入界等。迦叶菩萨白佛言。世尊。如佛所说。有智之人知于漏因。云何名为知于漏因。善男子。智者当观。何因缘故生是烦恼。造作何行生此烦恼。于何时中生此烦恼。共谁住时生此烦恼。何处止住生此烦恼。观何事已生于烦恼。受谁房舍卧具饮食衣服汤药而生烦恼。何因缘故。转下作中转中作上。下业作中中业作上。菩萨摩诃萨作是观时则得远离生漏因缘。如是观时未生烦恼遮令不生。已生烦恼便得除灭。是故我于契经中说。智者当观生烦恼因。迦叶菩萨白佛言。世尊。众生一身云何能起种种烦恼。佛言。善男子。如一器中有种种子。得水雨已各各自生。众生亦尔。器虽是一。爱因缘故而能生长种种烦恼。迦叶菩萨言。世尊。智者云何观于果报。善男子。智者当观。诸漏因缘能生地狱饿鬼畜生。是漏因缘得人天身。即是无常苦空无我。是身器中得三种苦三种无常。是漏因缘能令众生作五逆罪受诸恶报。能断善根犯四重禁诽谤三宝。智者当观。我既受得如是之身。不应生起如是烦恼受诸恶果。迦叶菩萨言。世尊。有无漏果。复言智者断诸果报。无漏果报在断中不。诸得道人有无漏果。如其智者求无漏果。云何佛说一切智者应断果报。若其断者。今诸圣人云何得有。善男子。如来或时因中说果果中说因。如世间人说泥即是瓶缕即是衣。是名因中说果。果中说因者。牛即水草人即是食。我亦如是。因中说果。先于经中作是说言。我从心身(因心运身故名心身)至梵天边。是名因中说果。果中说因。此六入者名过去业。是名果中说因。善男子。一切圣人真实无有无漏果报。一切圣人修道果报更不生漏。是故名为无漏果报。善男子。有智之人如是观时。即得永灭烦恼果报。善男子。智者观已。为断如是烦恼果报修习圣道。圣道者即空无相愿。修是道已。能灭一切烦恼果报。迦叶菩萨白佛言。世尊。一切众生皆从烦恼而得果报。言烦恼者所谓恶也。从恶烦恼所生烦恼亦名为恶。如是烦恼则有二种。一因二果。因恶故果恶。果恶故子恶。如纴婆果。其子苦故花果茎叶一切皆苦。犹如毒树。其子毒故果亦是毒。因亦众生果亦众生。因亦烦恼果亦烦恼。烦恼因果即是众生。众生即是烦恼因果。若从是义。云何如来先喻雪山亦有毒草微妙药王。若言烦恼即是众生众生即是烦恼。云何而言众生身中有妙药王。佛言。善哉善哉。善男子。无量众生咸同此疑。汝今能为启请求解。我亦能断。谛听谛听善思念之。今当为汝分别解说。善男子。雪山喻者即是众生。言毒草者即是烦恼。妙药王者即净梵行。善男子。若有众生。能修如是清净梵行。是名身中有妙药王。迦叶菩萨白佛言。世尊。云何众生有清净梵行。善男子。犹如世间从子生果。是果有能与子作因。有不能者有能作者。是名果子。若不能作。唯得名果不得名子。一切众生亦复如是。皆有二种。一者有烦恼果是烦恼因。二者有烦恼果非烦恼因。是烦恼果非烦恼因。是则名为清净梵行

善男子。众生观受。知是一切漏之近因。所谓内外漏。受因缘故。不能断绝一切诸漏。亦不能出三界牢狱。众生因受着我我所。生于心倒想倒见倒。是故众生先当观受。如是受者为一切爱而作近因。是故智者欲断爱者当先观受。善男子。一切众生十二因缘所作善恶皆因受时。是故我为阿难说言。阿难。一切众生所作善恶皆是受时。是故智者先当观受。既观受已复当更观。如是受者何因缘生。若因缘生如是因缘复从何生。若无因生无因何故不生无受。复观是受不因自在天生。不因士夫生。不因微尘生。非时节生。不因想生不因性生。不从自生不从他生。非自他生非无因生。是受皆从缘合而生。因缘者即是爱也。是和合中非有受非无受。是故我当断是和合。断和合故则不生受。善男子。智者既观因已次观果报。众生因受受于地狱饿鬼畜生乃至三界无量苦恼。受因缘故受无常乐。受因缘故断于善根。受因缘故获得解脱。作是观时不作受因。云何名为不作受因。谓分别受。何等受能作爱因。何等爱能作受因。善男子。众生若能如是深观爱因受因。则便能断我及我所。善男子。若人能作如是等观。则应分别爱之与受在何处灭。即见爱受有少灭处。当知亦应有毕竟灭。尔时即于解脱生信。生信心已是解脱处何由而得。知从八正即便修习。云何名为八正道耶。是道观受有三种相一者苦。二者乐。三者不苦不乐。如是三种俱能增长身之与心。何因缘故能增长耶。触因缘也。是触三种。一者无明触。二者明触。三者非明无明触。言明触者即八正道。其余二触增长身心及三种受。是故我应断二种触因缘。触断故不生三受。善男子。如是受者亦名为因亦名为果。智者当观亦因亦果。云何为因。因受生爱名之为因。云何名果。因触生故名之为果。是故此受亦因亦果。智者如是观是受已。次复观爱。受果报故名之为爱。智者观爱复有二种。一者杂食。二者无食。杂食爱者。因生老病死一切诸有。无食爱者。断生老病死一切诸有。贪无漏道。智者复当作如是念。我若生是杂食之爱。则不能断生老病死。我今虽贪无漏之道不断受因。则不能得无漏道果。是故应当先断是触。触既断已受则自灭。受既灭已爱亦随灭。是名八正道。善男子。若有众生能如是观。虽有毒身其中亦有微妙药王。如雪山中虽有毒草亦有妙药。善男子。如是众生虽从烦恼而得果报。而是果报更不复为烦恼作因。是即名为清净梵行

复次善男子。智者当观受爱二事。何因缘生知因想生。何以故。众生见色亦不生贪。及观受时亦不生贪。若于色中生颠倒想。谓色即是常乐我净。受是常恒无有变易。因是倒想生贪恚痴。是故智者应当观想。云何观想。当作是念。一切众生未得正道皆有倒想。云何倒想。于非常中生于常想。于非乐中生于乐想。于非净中生于净想。于空法中生于我想。于非男女大小昼夜岁月衣服房舍卧具。生于男女至卧具想。是想三种。一者小。二者大。三者无边。小因缘故生于小想。大因缘故生于大想。无量缘故生无量想。复有小想。谓未入定。复有大想。谓已入定。复有无量想。谓十一切入。复有小想。所谓欲界一切想等。复有大想。所谓色界一切想等。复有无量想。谓无色界一切想等。三想灭故受则自灭。想受灭故名为解脱。迦叶菩萨言。世尊。灭一切法名为解脱。如来云何说想受灭名解脱耶。佛言。善男子。如来或时因众生。说闻者解法。或时因法说于众生。闻者亦解说于众生。云何名为因众生说闻者解法。如我先为大迦叶说。迦叶。众生灭时善法则灭。是名因众生说闻者解法。云何因法说于众生。闻者亦解说于众生。如我先为阿难说言。我亦不说亲近一切法。亦复不说不亲近一切法。若法近已。善法衰羸不善炽盛。如是法者不应亲近。若法近已。不善衰灭善法增长。如是法者是应亲近。是名因法说于众生。闻者亦解说于众生。善男子。如来虽说想受二灭。则已总说一切可断。智者既观如是想已。次观想因。是无量想因何而生。知因触生。是触二种。一者因烦恼触。二者因解脱触。因无明生名烦恼触。因明生者名解脱触。因烦恼触生于倒想。因解脱触生不倒想。观想因已。次观果报。迦叶菩萨白佛言。世尊。若以因此烦恼之想生于倒想。一切圣人实有倒想而无烦恼。是义云何。佛言。善男子。云何圣人而有倒想。迦叶菩萨言。世尊。一切圣人牛作牛想亦说是牛。马作马想亦说是马。男女大小舍宅车乘去来亦尔。是名倒想。善男子。一切凡夫有二种想。一者世流布想。二者着想。一切圣人唯有世流布想无有着想。一切凡夫恶觉观故。于世流布生于着想。一切圣人善觉观故。于世流布不生着想。是故凡夫名为倒想。圣人虽知不名倒想。智者如是观想因已。次观果报。是恶想果在于地狱饿鬼畜生人天中受。如我因断恶觉观故。无明触断是故想断。因想断故果报亦断。智者为断如是想因修八正道。善男子。若有能作如是等观。则得名为清净梵行。善男子。是名众生毒身之中有妙药王。如雪山中虽有毒草亦有妙药

复次善男子。智者观欲。欲者即是色声香味触。善男子。即是如来因中说果。从此五事生于欲耳。实非欲也。善男子。愚痴之人贪求受之。于是色中生颠倒想。乃至触中亦生倒想。倒想因缘便生于受。是故世间说因倒想生十种想。欲因缘故。在于世间受恶果报。以恶加于父母沙门婆罗门等。所不应作而故作之不惜身命。是故智者观是恶想因缘故生欲心。智者如是观欲因已。次观果报。是欲多有诸恶果报。所谓地狱饿鬼畜生人中天上。是名观果报。若是恶想得除灭者。终不生于此欲心也。无欲心故不受恶受。无恶受故则无恶果。是故我应先断恶想。断恶想已。如是等法自然而灭。是故智者为灭恶想修八正。道是则名为清净梵行。是名众生毒身之中有妙药王。如雪山中虽有毒草亦有妙药

复次善男子。智者如是观是欲已。次当观业。何以故。有智之人当作是念。受想触欲即是烦恼。是烦恼者。能作生业不作受业。如是烦恼与业共行。则有二种。一作生业。二作受业。是故智者当观于业。是业三种。谓身口意。善男子。身口二业亦名为业亦名业果。意唯名业不名为果。以业因故则名为业。善男子。身口二业名为外业。意业名内。是三种业共烦恼行故。作二种业。一者生业。二者受业善男子。正业者即意业也。期业者谓身口业。先发故名意业。从意业生名身口业。是故意业得名为正。智者观业已。次观业因。业因者即无明触。因无明触众生求有。求有因缘即是爱也。爱因缘故。造作三种身口意业。善男子。智者如是观业因已。次观果报。果报有四。一者黑黑果报。二者白白果报。三者杂杂果报。四者不黑不白不黑不白果报。黑黑果报者。作业时垢果报亦垢。白白果报者。作业时净果报亦净。杂杂果报者。作业时杂果报亦杂。不白不黑不白不黑果报者。名无漏业。迦叶菩萨白佛言。世尊。先说无漏无有果报。今云何言不白不黑果报耶。佛言。善男子。是义有二。一者亦果亦报。二者唯果非报。黑黑果报亦名为果亦名为报。黑因生故得名为果。能作因故复名为报。净杂亦尔。无漏果者因有漏生。故名为果。不作他因不名为报。是故名果不名为报。迦叶菩萨白佛言。世尊。是无漏业非是黑法。何因缘故不名为白。善男子。无有报故不名为白。对治黑故故名为白。我今乃说受果报者名之为白。是无漏业不受报故。不名为白名为寂静。如是业者有定受报处。如十恶法定在地狱饿鬼畜生。十善之业定在人天。十不善法有上中下。上因缘故受地狱身。中因缘故受畜生身。下因缘故受饿鬼身。人业十善复有四种。一者下。二者中。三者上。四者上上下因缘故生郁单越。中因缘故生弗婆提。上因缘故生瞿陀尼。上上因缘生阎浮提。有智之人作是观已。即作是念我当云何断是果报。复作是念。是业因缘无明触生。我若断除无明与触。如是业果则灭不。生是故智者为断无明触因缘故修八正道。是则名为清净梵行。善男子。是名众生毒身之中有妙药王。如雪山中虽有毒草亦有妙药

复次善男子。智者观业观烦恼已。次观是二所得果报。是二果报即是苦也。既知是苦则能舍离一切受生。智者复观。烦恼因缘生于烦恼。业因缘故亦生烦恼。烦恼因缘复生于业。业因缘生苦。苦因缘故生于烦恼。烦恼因缘生有。有因缘生苦。有因缘生有。有因缘生业。业因缘生烦恼。烦恼因缘生苦。苦因缘生苦。善男子。智者若能作如是观。当知是人能观业苦。何以故。如上所观即是生死十二因缘。若人能观如是生死十二因缘。当知是人。不造新业能坏故业。善男子。有智之人观地狱苦。观一地狱乃至一百三十六所。一一地狱有种种苦。皆是烦恼业因缘生。观地狱已。次观饿鬼畜生等苦。作是观已。复观人天所有诸苦。如是众苦皆从烦恼业因缘生。善男子。天上虽无大苦恼事。然其身体柔软细滑。见五相时极受大苦。如地狱苦等无差别。善男子。智者深观三界诸苦。皆从烦恼业因缘生。善男子。譬如坏器即易破坏。众生受身亦复如是。既受身已是众苦器。譬如大树花果繁茂众鸟能坏。如多干草小火能焚。众生受身为苦所坏亦复如是。善男子。智者若能观苦八种如圣行中。当知是人能断众苦善男子。智者深观是八苦已次观苦因。苦因者即爱无明。是爱无明则有二种。一者求身。二者求财。求身求财二俱是苦。是故当知爱无明者即是苦因。善男子。是爱无明则有二种。一者内。二者外。内能作业外能增长。又复内能作业外作业果。断内爱已业则得断。断外爱已果则得断。内爱能生未来世苦。外爱能生现在世苦。智者观爱即是苦因。既观因已。次观果报。苦果报者即是取也。爱果名取是取因缘。即内外爱则有爱苦。善男子。智者当观爱因缘取取因缘爱。若我能断爱取二事。则不造业受于众苦。是故智者为断爱苦修八正道。善男子。若有人能如是观者。是则名为清净梵行。是名众生毒身之中有妙药王。如雪山中虽有毒草亦有妙药

大般涅槃经卷第三十七大般涅槃经卷第三十八

        北凉天竺三藏昙无谶译

    迦叶菩萨品第十二之六

迦叶菩萨白佛言。世尊。云何名为清净梵行。佛言。善男子。一切法是。迦叶菩萨言。世尊。一切法者义不决定。何以故。如来或说是善不善。或时说为四念处观。或说是十二入。或说是善知识。或说是十二因缘。或说是众生。或说是正见邪见。或说十二部经。或说即是二谛。如来今乃说一切法为净梵行。悉是何等一切法耶。佛言。善哉善哉。善男子。如是微妙。大涅槃经。乃是一切善法宝藏。譬如大海是众宝藏。是涅槃经亦复如是。即是一切字义秘藏。善男子。如须弥山众药根本。是经亦尔。即是菩萨戒之根本。善男子。譬如虚空是一切物之所住处。是经亦尔。即是一切善法住处。善男子。譬如猛风无能系缚。一切菩萨行是经者亦复如是。不为一切烦恼恶法之所系缚。善男子。譬如金刚无能坏者。是经亦尔。虽有外道恶邪之人不能破坏。善男子。如恒河沙无能数者。如是经义亦复如是。无能数者。善男子。是经典者为诸菩萨而作法幢如帝释幢。善男子。是经即是趣涅槃城之商主也。如大导师引诸商人趣向大海。善男子。是经能为诸菩萨等作法光明。如世日月能破诸闇。善男子。是经能为病苦众生作大良药。如香山中微妙药王能治众病。善男子。是经能为一阐提杖。犹如羸人因之得起。善男子。是经能为一切恶人而作桥梁。犹如世桥能渡一切。善男子。是经能为行二十五有者。遇烦恼热而作阴凉。如世间盖遮覆暑热。善男子。是经即是大无畏王。能坏一切烦恼恶魔。如师子王降伏众兽。善男子。是经即是大神咒师。能坏一切烦恼恶鬼。如世咒师能去魍魉。善男子。是经即是无上霜雹。能坏一切生死果报。如世雹雨坏诸果实。善男子。是经能为坏戒目者作大良药。犹如世间安阇那药善疗眼痛。善男子。是经能住一切善法。如世间地能住众物。善男子。是经即是毁戒众生之明镜也。如世明镜见诸色像。善男子。是经能为无惭愧者而作衣服。如世衣裳障蔽形体。善男子。是经能为贫善法者作大财宝。如功德天利益贫者。善男子。是经能为渴法众生作甘露浆。如八味水充足渴者。善男子。是经能为烦恼之人而作法床。如世之人遇安隐床。善男子。是经能为初地菩萨至十住菩萨。而作璎珞香花涂香末香烧香。清净种性具足之乘。过于一切六波罗蜜受妙乐处。如忉利天波利质多罗树。善男子。是经即是刚利智斧能伐一切烦恼大树。即是利刀能割习气。即是勇健能摧魔怨。即是智火焚烦恼薪。即因缘藏出辟支佛。即是闻藏生声闻人。即是一切诸天之眼。即是一切人之正道。即是一切畜生依处。即是饿鬼解脱之处。即是地狱无上之尊。即是一切十方众生无上之器。即是十方过去未来现在诸佛之父母也。善男子。是故此经摄一切法。如我先说此经虽摄一切诸法。我说梵行即是三十七助道法。善男子。若离如是三十七品。终不能得声闻正果乃至阿耨多罗三藐三菩提果。不见佛性及佛性果。以是因缘梵行即是三十七品。何以故。三十七品性非颠倒能坏颠倒。性非恶见能坏恶见。性非怖畏能坏怖畏。性是净行能令众生毕竟造作清净梵行。迦叶菩萨白佛言。世尊。有漏之法亦复能作。无漏法因。如来何故不说有漏为净梵行。善男子。一切有漏即是颠倒。是故有漏不得名为清净梵行。迦叶菩萨白佛言。世尊。世第一法为是有漏是无漏耶。佛言。善男子。是有漏也。世尊。虽是有漏性非颠倒。何故不名清净梵行。善男子。世第一法无漏因故似于无漏。向无漏故不名颠倒。善男子。清净梵行发心相续乃至毕竟。世第一法唯是一念。是故不得名净梵行。迦叶菩萨白佛言。世尊。众生五识亦是有漏。非是颠倒复非一念。何故不名清净梵行。善男子。众生五识虽非一念。然是有漏复是颠倒。增诸漏故名为有漏。体非真实着想故倒。云何名为体非真实着想故倒。非男女中生男女想。乃至舍宅车乘瓶衣亦复如是。是名颠倒。善男子。三十七品性无颠倒。是故得名清净梵行。善男子。若有菩萨于三十七品。知根知因知摄知增知主知导知胜知实知毕竟者。如是菩萨则得名为清净梵行

迦叶菩萨白佛言。世尊。云何名为知根乃至知毕竟耶。佛言。善男子。善哉善哉。菩萨发问为于二事。一者为自知故。二者为他知故。汝今已知但为无量众生未解启请是事。是故我今重赞叹汝。善哉善哉。善男子。三十七品根本是欲。因名明触。摄取名受。增名善思。主名为念。导名为定。胜名智慧。实名解脱。毕竟名为大般涅槃。善男子。善欲即是初发道心。乃至阿耨多罗三藐三菩提之根本也。是故我说欲为根本。善男子。如世间说。一切苦恼爱为根本。一切疹病宿食为本。一切断事斗诤为本。一切恶事虚妄为本。迦叶菩萨白佛言。世尊。如来先于此经中说。一切善法不放逸为本。今乃说欲。是义云何。佛言。善男子。若言生因善欲是也。若言了因不放逸是。如世间说。一切果者子为其因。或复有说。子为生因地为了因。是义亦尔。迦叶菩萨言。世尊。如来先于余经中说。三十七品佛是根本。是义云何。善男子。如来先说众生初知三十七品佛是根本。若自证得欲为根本。世尊。云何明触。名之为因。善男子。如来或时说明为慧。或说为信。善男子。信因缘故亲近善友。是名为触。亲近因缘得闻正法。是名为触。因闻正法身口意净。是名为触。因三业净获得正命。是名为触。因正命故得净根戒。因净根戒乐寂静处。因乐寂静能善思惟。因善思惟得如法住。因如法住得三十七品。能坏无量诸恶烦恼。是名为触。善男子。受名摄取。众生受时能作善恶。是故名受为摄取也。善男子。受因缘故生诸烦恼。三十七品能破坏之。是故以受为摄取也。因善思惟能破烦恼。是故名增。何以故。勤修习故。得如是等三十七品。若观能破诸恶烦恼要赖专念。是故以念为主。如世间中一切四兵随主将意。三十七品亦复如是。皆随念主。善男子。既入定已。三十七品能善分别一切法相。是故以定为导。是三十七品分别法相。智为最胜。是故以慧为胜。如是智慧知烦恼已。智慧力故烦恼消灭。如世间中四兵坏怨。或一或二勇健者能。三十七品亦复如是。智慧力故能坏烦恼。是故以慧为胜。善男子。虽因修习三十七品获得四禅神通安乐。亦不名实。若坏烦恼证解脱时。乃名为实。是三十七品发心修道。虽得世乐及出世乐四沙门果及以解脱。亦不得名为毕竟也。若能断除三十七品所行之事。是名涅槃。是故我说毕竟者即大涅槃

复次善男子。善爱念心即是欲也。因善爱念亲近善友。故名为触。是名为因。因近善友故名为受。是名摄取。因近善友能善思惟。故名为增。因是四法能生长道。所谓欲念定智。是即名为主导胜也。因是三法得二解脱。除断爱故心得解脱。断无明故慧得解脱。是名为实。如是八法毕竟得果名为涅槃。故名毕竟。复次善男子。欲者即是发心出家。触者即是白四羯磨。是名为因。摄者即是受二种戒。一者波罗提木叉戒。二者净根戒。是名为受。是名摄取。增者即是修习四禅。主者即是须陀洹果斯陀含果。导者即是阿那含果。胜者即是阿罗汉果。实者即是辟支佛果。毕竟者即是阿耨多罗三藐三菩提果

复次善男子。欲名为识。触名六入。摄名为受。增名无明。主名名色。导名为爱。胜名为取。实名为有。毕竟者名生老病死迦叶菩萨言。世尊。根本因增。如是三法云何有异。善男子。所言根者即是初发。因者即是相似不断。增者即是灭相似已能生相似。复次善男子。根即是作因即是果。增即可用。善男子。未来之世虽有果报。以未受故名之为因。及其受时是名为增。复次善男子。根即是求得即是因用即是增。善男子。是经中根即是见道。因即修道。增者即是无学道也。复次善男子。根即正因因即方便因。从是二因获得果报。名为增长。迦叶菩萨言。世尊。如佛所说。毕竟者即是涅槃。如是涅槃云何可得。善男子。若菩萨摩诃萨比丘比丘尼优婆塞优婆夷能修十想。当知是人能得涅槃。云何为十。一者无常想。二者苦想。三者无我想。四者厌离食想。五者一切世间不可乐想。六者死想。七者多过罪想。八者离想。九者灭想。十者无爱想。善男子。菩萨摩诃萨比丘比丘尼优婆塞优婆夷。修习如是十种想者。是人毕竟定得涅槃。不随他心自能分别善不善等。是名真实。称比丘义。乃至得称优婆夷义迦叶菩萨言。世尊。云何名为菩萨乃至优婆夷等修无常想。善男子。菩萨二种。一初发心。二已行道。无常想者亦复二种。一粗二细。初心菩萨观无常想时作是思惟。世间之物凡有二种。一内二外。如是内物无常变异。我见生时小时大时壮时老时死时。是诸时节各各不同。是故当知内物无常。复作是念。我见众生。或有肥鲜具足色力去来进止自在无碍。或见病苦。色力毁悴颜貌羸损不得自在。或见财富库藏盈溢。或见贫穷触事鲜乏。或见成就无量功德。或见具足无量恶法。是故定知内法无常。复观外法。子时芽时茎时叶时花时果时。如是诸时各各不同。如是外法。或有具足或不具足。是故当知。一切外物定是无常。既观见法是无常已。复观闻法。我闻诸天具足成就极妙快乐神通自在。亦有五相。是故当知即是无常。复闻劫初有诸众生。各各具足上妙功德。身光自照不假日月。无常力故光灭德损。复闻昔有转轮圣王统四天下。成就七宝得大自在。而不能坏无常之相。复观大地。往昔之时安处布置无量众生。间无空处如车轮许。具足生长一切妙药。藂林树木果实滋茂。众生薄福令此大地无复势力。所生之物遂成虚耗。是故当知。内外之法一切无常。是则名为粗无常也。既观粗已次观细者。云何名细。菩萨摩诃萨观于一切内外之物乃至微尘。在未来时已是无常。何以故。具足成就破坏相故。若未来色非无常者。不得言色。有十时差别。云何十时。一者膜时。二者泡时。三者疱时。四者肉团时。五者肢时。六者婴孩时。七者童子时。八者少年时。九者盛壮时。十者衰老时。菩萨观膜若非无常不应至泡。乃至盛壮非无常者终不至老。若是诸时非念念灭终不渐长。应当一时成长具足。无是事故。是故当知。定有念念。微细无常。复见有人诸根具足颜色暐晔。后见枯悴。复作是念。是人定有念念无常。复观四大及四威仪。复观内外各二苦因饥渴寒热。复观是四若无念念微细无常。亦不得说如是四苦。若有菩萨能作是念。是名菩萨观细无常。如内外色心法亦尔。何以故。行六处故。行六处时。或生喜心或生嗔心。或生爱心或生念心。展转异生不得一种。是故当知。一切色法及非色法悉是无常。善男子。菩萨若能于一念中。见一切法生灭无常。是名菩萨具无常想。善男子。智者修习无常想已。远离常慢常倒想倒

次修苦想。何因缘故有如是苦。深知是苦因于无常。因无常故受生老病死。生老病死因缘故名为无常。无常因缘故。受内外苦饥渴寒热鞭打骂辱。如是等苦皆因无常。复次智者深观此身。即无常器。是器即苦。以器苦故。所受盛法亦复是苦。善男子。智者复观。生即是苦灭即是苦。苦生灭故即是无常。非我我所修无我想。智者复观苦即无常无常即苦。若苦无常智者云何说言有我。苦非是我无常亦尔。如是五阴亦苦无常。众生云何说言有我。复次观。一切法有异和合。不从一和合生一切法。亦非一法是一切和合果。一切和合皆无自性。亦无一性亦无异性。亦无物性亦无自在。诸法若有如是等相。智者云何说言有我。复作是念。一切法中无有一法能为作者。若使一法不能作者。众法和合亦不能作。一切诸法性终不能独生独灭。和合故灭和合故生。是法生已众生倒想。言是和合从和合生。众生想倒无有真实。云何而有真实我耶。是故智者观于无我。又复谛观何因缘故众生说我。是我若有应一应多。我若一者。云何而有刹利婆罗门毗舍首陀。人天地狱饿鬼畜生大小老壮。是故知我非是一也。我若多者。云何说言众生我者。是一是遍无有边际。若一若多二俱无我

智者如是观无我已。次复观于厌离食想。作是念言。若一切法无常苦空无我。云何为食起身口意三种恶业。若有众生为贪食故。起身口意三种恶业。所得财物众皆共之。后受苦果无共分者。善男子。智者复观。一切众生为饮食故身心受苦。若从众苦而得食者。我当云何于是食中而生贪着。是故于食不生贪心。复次智者当观。因于饮食身得增长。我今出家受戒修道。为欲舍身。今贪此食云何当得舍此身耶。如是观已。虽复受食。犹如旷野食其子肉。其心厌恶都不甘乐。深观揣食有如是过。次观触食。如被剥牛为无量虫之所唼食。次观思食如大火聚。识食犹如三百钻矛。善男子。智者如是观四食已。于食终不生贪乐想。若犹生贪当观不净。何以故。为离食爱故。于一切食。善能分别不净之想。随诸不净令与相似。如是观已。若得好食及以恶食。受时犹如涂痈疮药。终不生于贪爱之心。善男子。智者若能如是观者。是名成就厌离食想。迦叶菩萨言。世尊。智者观。食作不净想。为是实观虚解观耶。若是实观。所观之食实非不净。若是虚解。是法云何名为善想。佛言。善男子。如是想者。亦是实观亦是虚解。能坏贪食故名为实。非虫见虫故名虚解。善男子。一切有漏皆名为虚。亦能得实。善男子。若有比丘发心乞食预作是念。我当乞食愿得好者莫得粗恶。愿必多得莫令鲜少。亦愿速得莫令迟晚。如是比丘不名于食得厌离想。所修善法日夜衰耗。不善之法渐当增长。善男子。若有比丘欲乞食时。先当愿言。令诸乞者悉得饱满。其施食者得无量福。我若得食为疗毒身。修习善法利益施主。作是愿时所修善法日夜增长。不善之法渐当消灭。善男子。若有比丘能如是修。当知是人不空食于国中信施

善男子。智者具足如是四想。能修世间不可乐想。作是念言。一切世间无处不有生老病死。而我此身无处不生。若世间中无有一处当得离于生老病死。我当云何乐于世间。一切世间无有进得而不退失。是故世间定是无常。若是无常云何智人而乐于世。一一众生周遍经历一切世间具受苦乐。虽复得受梵天之身乃至非想非非想天。命终还堕三恶道中。虽为四王乃至他化自在天身。命终生于畜生道中。或为师子虎豹豺狼象马牛驴。次观转轮圣王之身。统四天下豪贵自在。福尽贫困衣食不供。智者深观如是事已。生于世间不可乐想。智者复观世间有法。所谓舍宅衣服饮食卧具医药。香花璎珞种种伎乐财物宝货。如是等事皆为离苦。而是等物体即是苦。云何以苦欲离于苦。善男子。智者如是观已。于世间物不生爱乐而作乐想。善男子。譬如有人身婴重病。虽有种种音乐倡伎香花璎珞。终不于中生贪爱乐。智者观已亦复如是。善男子。智者深观一切世间。非归依处。非解脱处。非寂静处。非可爱处。非彼岸处。非是常乐我净之法。若我贪乐如是世间。我当云何得离是法。如人不乐处闇而求光明还复归闇。闇即世间明即出世。若我乐世增长黑闇远离光明。闇即无明光即智明。是智明因即是世间不可乐想。一切贪结虽是系缚。然我今者贪于智明不贪世间。智者深观如是法已。具足世间不可乐想善男子。有智之人已修世间不可乐想。次修死想观。是寿命常为无量怨储所绕。念念损减无有增长。犹山瀑水不得停住。亦如朝露势不久停。如囚趣市步步近死。如牵牛羊诣于屠所。迦叶菩萨言。世尊。云何智者观念念灭。善男子。譬如四人皆善射术聚在一处。各射一方俱作是念。我等四箭俱发俱堕。复有一人作是念言。如是四箭及其未堕。我能一时以手接取。善男子。如是之人可说疾不。迦叶菩萨言。如是世尊。佛言。善男子。地行鬼疾复速是人。有飞行鬼复速地行。四天王疾复速飞行。日月神天复速四王。行坚疾天复速日月。众生寿命复速坚疾。善男子。一息一眴众生寿命四百生灭。智者若能观命如是。是名能观念念灭也。善男子。智者观命系属死王。我若能离如是死王。则得永断无常寿命。复次智者观是寿命犹如河岸临峻大树。亦如有人作大逆罪。及其受戮无怜惜者。如师子王大饥困时。亦如毒蛇吸大风时。犹如渴马护惜水时。如大恶鬼嗔恚发时。众生死王亦复如是。善男子。智者若能作如是观。是则名为修习死想。善男子。智者复观。我今出家设得寿命七日七夜。我当于中精勤修道护持禁戒。说法教化利益众生。是名智者修于死想。复以七日七夜为多。若得六日五日四日三日二日一日一时。乃至出息入息之顷。我当于中精勤修道护持禁戒。说法教化利益众生。是名智者善修死想。智者具足如上六想即七想因。何等名七。一者常修想。二者乐修想。三者无嗔想。四者无妒想。五者善愿想。六者无慢想。七者三昧自在想。善男子。若有比丘具足七想。是名沙门名婆罗门。是名寂静。是名净洁。是名解脱。是名智者。是名正见。名到彼岸。名大医王。是大商主。是名善解如来秘密。亦知诸佛七种之语。名正见知断七种语中所生疑网。善男子。若人具足如上六想。当知是人能呵三界。远离三界灭除三界。于三界中不生爱着。是名智者具足十想。若有比丘具是十想。即得称可沙门之相。尔时迦叶菩萨。即于佛前以偈赞佛

  怜愍世间大医王　　身及智慧俱寂静
  无我法中有真我　　是故敬礼无上尊
  发心毕竟二不别　　如是二心先心难
  自未得度先度他　　是故我礼初发心
  初发已为人天师　　胜出声闻及缘觉
  如是发心过三界　　是故得名最无上
  世救要求然后得　　如来无请而为师
  佛随世间如犊子　　是故得名大悲牛
  如来功德满十方　　凡下无智不能赞
  我今赞叹慈悲心　　为报身口二种业
  世间常乐自利益　　如来终不为是事
  能断众生世果报　　是故我礼自他利
  世间逐亲作益厚　　如来利益无怨亲
  佛无是相如世人　　是故其心等无二
  世间说异作业异　　如来如说业无差
  凡所修行断诸行　　是故得名为如来
  先已了知烦恼过　　示现处之为众生
  久于世间得解脱　　乐处生死慈悲故
  虽现天身及人身　　慈悲随逐如犊子
  如来即是众生母　　慈心即是小犊子
  自受众苦念众生　　悲念时心不悔没
  怜愍心盛不觉苦　　故我稽首拔苦者
  如来虽作无量福　　身口意业恒清净
  常为众生不为己　　是故我礼清净业
  如来受苦不觉苦　　见众受苦如己苦
  虽为众生处地狱　　不生苦想及悔心
  一切众生受异苦　　悉是如来一人苦
  觉已其心转坚固　　故能勤修无上道
  佛具一味大慈心　　悲念众生如子想
  众生不知佛能救　　故谤如来及法僧
  世间虽具众烦恼　　亦有无量诸过恶
  如是众结及罪过　　佛初发心已能坏
  唯有诸佛能赞佛　　除佛无能赞叹者
  我今唯以一法赞　　所谓慈心游世间
  如来慈是大法聚　　是慈亦能度众生
  即是无上真解脱　　解脱即是大涅槃

大般涅槃经卷第三十八大般涅槃经卷第三十九

        北凉天竺三藏昙无谶译

    憍陈如品第十三之一

尔时世尊告憍陈如。色是无常。因灭是色。获得解脱常住之色。受想行识亦是无常。因灭是识。获得解脱常住之识。憍陈如。色即是苦。因灭是色。获得解脱安乐之色。受想行识亦复如是。憍陈如。色即是空。因灭空色。获得解脱非空之色。受想行识亦复如是。憍陈如。色是无我。因灭是色。获得解脱真我之色。受想行识亦复如是。憍陈如。色是不净。因灭是色。获得解脱清净之色。受想行识亦复如是。憍陈如。色是生老病死之相。因灭是色。获得解脱非生老病死相之色。受想行识亦复如是。憍陈如。色是无明因。因灭是色。获得解脱非无明因色。受想行识亦复如是。憍陈如。乃至色是生因。因灭是色。获得解脱非生因色。受想行识亦复如是。憍陈如。色者即是四颠倒因。因灭倒色。获得解脱非四倒因色。受想行识亦复如是。憍陈如。色是无量恶法之因。所谓男女等身食爱欲爱。贪嗔嫉妒恶心悭心。揣食识食思食触食。卵生胎生湿生化生五欲五盖。如是等法皆因于色。因灭色故。获得解脱无如是等无量恶色。受想行识亦复如是。憍陈如。色即是缚。因灭缚色。获得解脱无缚之色。受想行识亦复如是。憍陈如。色即是流。因灭流色。获得解脱非流之色。受想行识亦复如是。憍陈如。色非归依。因灭是色。获得解脱归依之色。受想行识亦复如是。憍陈如。色是疮疣。因灭是色。获得解脱无疮疣色。受想行识亦复如是。憍陈如。色非寂静。因灭是色。获得涅槃寂静之色。受想行识亦复如是。憍陈如。若有人能如是知者。是名沙门名婆罗门。具足沙门婆罗门法。憍陈如。若离佛法无有沙门无婆罗门。亦无沙门婆罗门法。一切外道虚假诈称都无实行。虽复作相言有是二。实无是处。何以故。若无沙门婆罗门法。云何而言有沙门婆罗门。我常于此大众之中作师子吼。汝等亦当在大众中作师子吼。尔时外道有无量人。闻是语已心生嗔恶。瞿昙。今说我等众中无有沙门及婆罗门。亦无沙门婆罗门法我当云何。广设方便语瞿昙言。我等众中亦有沙门有沙门法。有婆罗门有婆罗门法。时彼众中有一梵志。唱如是言。诸仁者。瞿昙之言如狂无异何可检校。世间狂人或歌或舞或哭或笑或骂或赞。于怨亲所不能分别。沙门瞿昙亦复如是。或说我生净饭王家或言不生。或说生已行至七步或说不行。或说从小习学世事。或说我是一切智人。或时处宫受乐生子。或时厌患呵责恶贱。或时亲修苦行六年。或时呵责外道苦行。或言从彼郁头蓝弗阿罗逻等禀承未闻。或时说其无所知晓。或时说言菩提树下得阿耨多罗三藐三菩提。或时说言我不至树无所克获。或时说言我今此身即是涅槃。或言身灭乃是涅槃。瞿昙所说如狂无异。何故以此而愁忧耶。诸婆罗门即便答言。大士。我等今者何得不愁。沙门瞿昙先出家已。说无常苦空无我等法。我诸弟子闻生恐怖。云何众生无常苦空无我不净不受其语。今者瞿昙复来至此娑罗林中。为诸大众说有常乐我净之法。我诸弟子闻是语已悉舍我去受瞿昙语。以是因缘生大愁苦。尔时复有一婆罗门作如是言。诸仁者。谛听谛听。瞿昙沙门名修慈悲。是名虚妄非真实也。若有慈悲云何教我诸弟子等自受其法。慈悲果有随顺他意。今违我愿云何言有。若有说言沙门瞿昙不为世间八法所染是亦虚妄。若言瞿昙少欲知足。今者云何夺我等利。若言种姓是上族者是亦虚妄。何以故。从昔已来不见不闻大师子王残害小鼠。若使瞿昙是上种姓。如何今者恼乱我等。若言瞿昙具大势力是亦虚妄。何以故。从昔已来亦不见闻金翅鸟王与鸟共诤。若言力大复以何事与我共斗。若言瞿昙具他心智是亦虚妄。何以故。若具此智以何因缘不知我心。诸仁者。我昔曾从先旧智人闻说是事。过百年已世间当有一妖幻出。即是瞿昙如是妖惑。今于此处娑罗林中将灭不久。汝等今者不应愁恼。尔时复有一尼犍子答言。仁者。我今愁苦不为自身弟子供养。但为世间痴闇无眼不识福田及非福田。弃舍先旧智婆罗门。供养年少以为愁耳。瞿昙沙门大知咒术。因咒术力能令一身作无量身。令无量身还作一身。或以自身作男女像牛羊象马。我力能灭如是咒术。瞿昙沙门咒术既灭。汝等当还多得供养受于安乐。尔时复有一婆罗门。作如是言。诸仁者。瞿昙沙门成就具足无量功德。是故汝等不应与诤。大众答言。痴人。云何说言沙门瞿昙具大功德。其生七日母便命终。是可得名福德相耶。婆罗门言。骂时不嗔打时不报。当知即是大福德相。其身具足三十二相八十种好无量神通。是故当知是福德相心无憍慢先意问讯。言语柔软初无粗犷。年志俱盛心不卒暴。王国多财无所爱恋。舍之出家如弃涕唾。是故我说沙门瞿昙成就具足无量功德。大众答言。善哉仁者。瞿昙沙门实如所说。成就无量神通变化。我不与彼捔试是事。瞿昙沙门受性柔软不堪苦行。生长深宫不综外事唯可软语。不知伎艺书籍论议。请共详辩正法之要。彼若胜我我当给事。我若胜彼彼当事我。尔时多有无量外道。和合共往摩伽陀王阿阇世所。王见便问。诸仁何来。汝等各各修习圣道。是出家人舍离财货及在家事。然我国人皆共供养敬心瞻视无相犯触。何故和合而来至此。诸仁者。汝等各受异法异戒出家不同。亦复各各自随戒法出家修道。何因缘故今者一心而共和合。犹如落叶旋风所吹聚在一处。说何因缘而来至此。我常拥护出家之人。乃至不惜身之与命。尔时一切诸外道众咸作是言。大王谛听。大王。今者是大法桥是大法砺是大法秤。即是一切功德之器。一切功德真实之性。正法道路。即是种子之良田也。一切国土之根本也。一切国土之大明镜。一切诸天之形像也。一切国人之父母也。大王。一切世间功德宝藏即是王身。何以故。名功德藏。王断国事不择怨亲。其心平等如地水火风。是故名王为功德藏。大王。现在众生虽复寿短。王之功德如昔长寿安乐时王。亦如顶生善见忍辱那睺沙王。耶耶帝王尸毗王一叉鸠王。如是等王具足善法。大王。今者亦复如是。大王。以王因缘国土安乐人民炽盛。是故一切出家之人慕乐此国。持戒精勤修习正道。大王。我经中说若出家人随所住国。持戒精进勤修正道其王亦有修善之分。大王。一切盗贼王已整理。出家之人都无畏惧。今者唯有一大恶人瞿昙沙门。王未捡校我等甚畏。其人自恃豪族种姓身色具足。又因过去布施之报多得供养。恃此众事生大憍慢。或因咒术而生憍慢。以是因缘不能苦行。受畜细软衣服卧具。是故一切世间恶人。为利养故往集其所。而为眷属不能苦行。咒术力故调伏迦叶及舍利弗目犍连等。今复来至我所住处娑罗林中。宣说是身常乐我净诱我弟子。大王。瞿昙先说无常无乐无我无净我能忍之。今乃宣说常乐我净我实不忍。惟愿大王。听我与彼瞿昙论议。王即答言。诸大士。汝等今者为谁教导而令其心狂乱不定。如水涛波旋火之轮猿猴掷树是事可耻。智人若闻即生怜愍。愚人闻之即生嗤笑。汝等所说非出家相。汝若病风黄水患者。吾悉有药能疗治之。如其鬼病家兄耆婆善能去之。汝等今者欲以手爪刨须弥山。欲以口齿齰啮金刚。诸大士。譬如愚人见师子王饥时睡眠而欲悟之。如人以指置毒蛇口。如欲以手触灰覆火。汝等今者亦复如是。善男子。譬如野狐作师子吼。犹如蚊子共金翅鸟捔行迟疾。如兔渡海欲尽其底。汝等今者亦复如是。汝若梦见胜瞿昙者。是梦狂惑未足可信。诸大士。汝等今者兴建是意。犹如飞蛾投大火聚。汝随我语不须更说。汝虽赞我平等如秤。勿令外人复闻此语

尔时外道复作是言。大王。瞿昙沙门所作幻术到汝边耶。乃令大王心疑不信是等圣人。大王。不应轻蔑如是大士。大王。是月增减大海碱味摩罗延山。如是等事谁之所作。岂非我等婆罗门耶。大王。不闻阿竭多仙十二年中恒河之水停耳中耶。大王。闻瞿昙仙人大现神通。十二年中变作释身。并令释身作羝羊形。作千女根在释身耶。大王。不闻耆[少/兔]仙人一日之中饮四海水令大地干耶。大王。不闻婆薮仙人为自在天作三眼耶。大王。不闻阿罗逻仙人变迦富罗城作卤土耶。大王。婆罗门中有如是等大力诸仙现可捡校。大王。云何见轻蔑耶。王言。诸仁者。若不见信故欲为者。如来正觉今者近在娑罗林中。汝等可往随意问难。如来亦当为汝分别称汝意答

尔时阿阇世王与诸外道徒众眷属往至佛所。头面作礼右绕三匝。修敬已毕却住一面。白佛言。世尊。是诸外道欲随意问难。唯愿如来随意答之。佛言。大王。且止我自知时

尔时众中有婆罗门名阇提首那。作如是言。瞿昙。汝说涅槃是常法耶。如是如是。大婆罗门。婆罗门言。瞿昙。若说涅槃常者是义不然。何以故。世间之法从子生果相续不断。如从埿出瓶从缕得衣。瞿昙。常说修无常想获得涅槃。因是无常果云何常。瞿昙。又说解脱欲贪即是涅槃。解脱色贪及无色贪即是涅槃。灭无明等一切烦恼即是涅槃。从欲乃至无明烦恼皆是无常。因是无常所得涅槃亦应无常。瞿昙。又说从因故生天。从因故堕地狱。从因得解脱。是故诸法皆从因生。若从因故得解脱者。云何言常。瞿昙。亦说色从缘生故名无常。受想行识亦复如是。如是解脱若是色者当知无常。受想行识亦复如是。若离五阴有解脱者。当知解脱即是虚空。若是虚空不得说言从因缘生。何以故。是常是一遍一切处。瞿昙。亦说从因生者即是苦也。若是苦者。云何复说解脱是乐。瞿昙。又说无常即苦苦即无我。若是无常苦无我者即是不净。一切从因所生诸法。皆无常苦无我不净。云何复说涅槃即是常乐我净。若瞿昙说亦常无常亦苦亦乐亦我无我亦净不净。如是岂非是二语耶。我亦曾从先旧智人闻说是语。佛若出世言则无二。瞿昙今者说于二语。复言佛即我身是也。是义云何。佛言。婆罗门。如汝所说我今问汝随汝意答。婆罗门言。善哉瞿昙。佛言。婆罗门。汝性常耶是无常乎。婆罗门言。我性是常。婆罗门。是性能作一切内外法之因耶。如是瞿昙。佛言。婆罗门。云何作因。瞿昙。从性生大从大生慢。从慢生十六法。所谓地水火风空。五知根眼耳鼻舌身。五业根手脚口声男女二根。心平等根。是十六法。从五法生色声香味触。是二十一法。根本有三。一者染。二者粗。三者黑。染者名爱。粗者名嗔。黑名无明。瞿昙。是二十五法皆因性生。婆罗门。是大等法常无常耶。瞿昙。我法性常。大等诸法悉是无常。婆罗门。如汝法中因常果无常。然我法中因虽无常果是常者有何等过。婆罗门。汝等法中有二因不。答言有。佛言。云何有。婆罗门言。一者生因。二者了因。佛言。云何生因。云何了因。婆罗门言。生因者如埿出瓶。了因者如灯照物。佛言。是二种因因性是一。若是一者可令生因作于了因。可令了因作生因不。不也瞿昙。佛言。若使生因不作了因。了因不作生因。可得说言是因相不。婆罗门言。虽不相作故有因相。婆罗门。了因所了即同了不。不也瞿昙。佛言。我法虽从无常获得涅槃而非无常。婆罗门。从了因得故常乐我净。从生因得故无常无乐无我无净。是故如来所说有二。如是二语无有二也。是故如来名无二语。如汝所说曾从先旧智人边闻。佛出于世无有二语。是言善哉。一切十方三世诸佛所说无差。是故说言佛无二语。云何无差。有同说有无同说无故名一义。婆罗门。如来世尊虽名二语为了一语故。云何二语了于一语。如眼色二语生识一语。乃至意法亦复如是。婆罗门言。瞿昙。善能分别如是语义。我今未解所出二语了于一语。尔时世尊即为宣说四真谛法。婆罗门。言苦谛者亦二亦一。乃至道谛亦二亦一。婆罗门言。世尊。我已知已。佛言。善男子。云何知已。婆罗门言。世尊。苦谛一切凡夫二是圣人一。乃至道谛亦复如是。佛言。善哉已解。婆罗门言。世尊。我今闻法已得正见。今当归依佛法僧宝。唯愿大慈听我出家。尔时世尊告憍陈如。汝当为是阇提首那。剃除须发听其出家。时憍陈如即受佛敕为其剃发。即下手时有二种落。一者须发。二者烦恼。即于坐处得阿罗汉果

复有梵志姓婆私吒。复作是言。瞿昙。所说涅槃常耶。如是梵志。婆私吒言。瞿昙。将不说无烦恼为涅槃耶。如是梵志。婆私吒言。瞿昙。世间四种名之为无。一者未出之法名之为无。如瓶未出埿时名为无瓶。二者已灭之法名之为无。如瓶坏已名为无瓶。三者异相互无名之为无。如牛中无马马中无牛。四者毕竟无故名之为无。如龟毛兔角。瞿昙。若以除烦恼已名涅槃者。涅槃即无。若是无者。云何言有常乐我净

佛言。善男子。如是涅槃非是先无同埿时瓶。亦非灭无同瓶坏无。亦非毕竟无如龟毛兔角同于异无。善男子。如汝所言虽牛中无马。不可说言牛亦是无。虽马中无牛。亦不可说马亦是无涅槃亦尔。烦恼中无涅槃。涅槃中无烦恼。是故名为异相互无婆私吒言。瞿昙若以异无为涅槃者。夫异无者。无常乐我净。瞿昙。云何说言涅槃常乐我净。佛言。善男子如汝所说是异无者。有三种无。牛马悉是先无后有。是名先无。已有还无是名坏无。异相无者。如汝所说。善男子。是三种无涅槃中无。是故涅槃常乐我净。如世病人。一者热病。二者风病。三者冷病。是三种病三药能治。有热病者苏能治之。有风病者油能治之。有冷病者蜜能治之。是三种药能治如是三种恶病。善男子。风中无油油中无风。乃至蜜中无冷冷中无蜜。是故能治。一切众生亦复如是。有三种病。一者贪二者嗔。三者痴。如是三病有三种药。不净观者能为贪药。慈心观者能为嗔药。观因缘智能为痴药。善男子。为除贪故作非贪观。为除嗔故作非嗔观。为除痴故作非痴观。三种病中无三种药。三种药中无三种病。善男子。三种病中无三药故。无常无我无乐无净。三种药中无三种病。是故得称常乐我净。婆私吒言。世尊。如来为我说常无常。云何为常。云何无常。佛言。善男子。色是无常解脱色常。乃至识是无常解脱识常。善男子。若有善男子善女人。若观色乃至识是无常者。当知是人获得常法。婆私吒言。世尊。我今已知常无常法。佛言。善男子。汝云何知常无常法。婆私吒言。世尊。我今知我色是无常得解脱常。乃至识亦如是。佛言。善男子。汝今善哉已报是身。告憍陈如。是婆私吒。已证阿罗汉果。汝可施其三衣钵器。时憍陈如如佛所敕施其衣钵。时婆私吒受衣钵已作如是言。大德憍陈如。我今因是弊恶之身得善果报。唯愿大德。为我屈意至世尊所具宣我心。我既恶人触犯如来称瞿昙姓。唯愿为我忏悔此罪。我亦不能久住毒身今入涅槃。时憍陈如即往佛所作如是言。世尊。婆私吒比丘生惭愧心自言。顽嚚触犯如来称瞿昙姓不能久住是毒蛇身今欲灭身寄我忏悔。佛言。憍陈如。婆私吒比丘已于过去无量佛所成就善根。今受我语如法而住。如法住故获得正果。汝等应当供养其身。尔时憍陈如从佛闻已。还其身所而设供养。时婆私吒于焚身时作种种神足。诸外道辈见是事已高声唱言。是婆私吒已得瞿昙沙门咒术。是人不久复当胜彼瞿昙沙门

尔时众中复有梵志名曰先尼。复作是言。瞿昙有我耶。如来默然瞿昙无我耶。如来默然。第二第三亦如是问。佛皆默然。先尼言。瞿昙若一切众生有我遍一切处是一作者。瞿昙何故默然不答。佛言。先尼。汝说是我遍一切处耶。先尼答言。瞿昙。不但我说一切智人亦如是说。佛言。善男子。若我周遍一切处者。应当五道一时受报。若有五道一时受报。汝等梵志。何因缘故不造众恶为遮地狱。修诸善法为受天身。先尼言。瞿昙。我法中我则有二种。一作身我。二者常身我。为作身我修离恶法不入地狱。修诸善法生于天上。佛言。善男子。如汝说我遍一切处。如是我者。若作身中当知无常。若作身无云何言遍。瞿昙。我所立我亦在作中亦是常法。瞿昙。如人失火烧舍宅时其主出去。不可说言舍宅被烧主亦被烧。我法亦尔。而此作身虽是无常。当无常时我则出去。是故我我亦遍亦常。佛言。善男子。如汝说我亦遍亦常。是义不然。何以故。遍有二种。一者常。二者无常。复有二种。一色二无色。是故若言一切有者。亦常亦无常。亦色亦无色。若言舍主得出不名无常。是义不然。何以故。舍不名主主不名舍。异烧异出故得如是。我则不尔。何以故。我即是色色即是我。无色即我我即无色。云何而言色无常时我则得出。善男子。汝意若谓一切众生同一我者。如是即违世出世法。何以故。世间法名父子母女。若我是一。父即是子子即是父。母即是女女即是母。怨即是亲亲即是怨。此即是彼彼即是此。是故若说一切众生同一我者。是即违背世出世法。先尼言。我亦不说一切众生同于一我。乃说一人各有一我。佛言。善男子。若言一人各有一我是为多我。是义不然。何以故。如汝先说我遍一切。若遍一切一切众生业根应同。天得见时佛得亦见。天得作时佛得亦作。天得闻时佛得亦闻。一切诸法皆亦如是。若天得见非佛得见者。不应说我遍一切处。若不遍者是即无常。先尼言。瞿昙。一切众生我遍一切。法与非法不遍一切。以是义故。佛得作异天得作异。是故瞿昙。不应说言佛得见时天得应见。佛得闻时天得应闻。佛言。善男子。法与非法非业作耶。先尼言。瞿昙。是业所作。佛言。善男子。若法非法是业作者。即是同法云何言异。何以故。佛得业处有天得我。天得业处有佛得我。是故佛得作时天得亦作。法与非法亦应如是。善男子。是故一切众生法与非法若如是者。所得果报亦应不异。善男子。从子出果是子终不思惟分别。我唯当作婆罗门果。不与刹利毗舍首陀而作果也。何以故。从子出果终不障碍如是四姓。法与非法亦复如是。不能分别我唯当与。佛得作果。不与天得作果。作天得果不作佛得果。何以故。业平等故。先尼言。瞿昙。譬如一室有百千灯。炷虽有异明则无差。灯炷别异喻法非法。其明无差喻众生我。佛言。善男子。汝说灯明以喻我者。是义不然。何以故。室异灯异。是灯光明亦在炷边亦遍室中。汝所言我若如是者。法非法边俱应有我。我中亦应有法非法。若法非法无有我者。不得说言遍一切处。若俱有者何得复以炷明为喻。善男子。汝意若谓炷之与明真实别异。何因缘故。炷增明盛炷枯明灭。是故不应以法非法喻于灯炷。光明无差喻于我也。何以故。法非法我三事即一。先尼言。瞿昙。汝引灯喻是事不吉。何以故。灯喻若吉我已先引。如其不吉何故复说。善男子。我所引喻都亦不作吉以不吉随汝意说。是喻亦说离炷有明即炷有明。汝心不等故说。灯炷喻法非法明则喻我。是故责汝。炷即是明离炷有明。法即有我我即有法。非法即我我即非法。汝今何故但受一边不受一边。如是喻者于汝不吉。是故我今还以破汝。善男子。如是喻者即是非喻。是非喻故于我则吉于汝不吉。善男子。汝意若谓若我不吉汝亦不吉。是义不然。何以故。见世间人自刀自害自作他用。汝所引喻亦复如是。于我则吉于汝不吉。先尼言。瞿昙。汝先责我心不平等。今汝所说亦不平等。何以故。瞿昙。今者以吉向己不吉向我。以是推之真是不平。佛言。善男子。如我不平能破汝不平。是故汝平我之不平即是吉也。我之不平破汝不平。令汝得平即是我平。何以故。同诸圣人得平等故。先尼言。瞿昙。我常是平。汝云何言坏我不平。一切众生平等有我。云何言我是不平耶。善男子。汝亦说言。当受地狱当受饿鬼当受畜生当受人天。我若先遍五道中者。云何方言当受诸趣。汝亦说言父母和合然后生子。若子先有云何复言和合已有。是故一人有五趣身。若是五处先有身者。何因缘故为身造业。是故不平。善男子。汝意若谓我是作者。是义不然。何以故。若我作者。何因缘故自作苦事然今众生实有受苦。是故当知我非作者。若言是苦非我所作不从因生。一切诸法亦当如是不从因生。何因缘故说我作耶。善男子。众生苦乐实从因缘。如是苦乐能作忧喜。忧时无喜喜时无忧或喜或忧。智人云何说是常耶。善男子。汝说我常。若是常者云何说有十时别异。常法不应有歌罗逻时乃至老时。虚空常法尚无一时况有十时。善男子。我者非是歌罗逻时乃至老时。云何说有十时别异。善男子。若我作者。是我亦有盛时衰时。众生亦有盛时衰时。若我尔者云何是常。善男子。我若作者。云何一人有利有钝。善男子。我若作者。是我能作身业。口业口业若是我所作者。云何口说无有我耶。云何自疑有耶无耶。善男子。汝意若谓离眼有见。是义不然。何以故。若离眼已别有见者何须此眼。乃至身根亦复如是。汝意若谓我虽能见要因眼见。是亦不然。何以故。如有人言须曼那花能烧大村。云何能烧因火能烧。汝立我见亦复如是。先尼言。瞿昙。如人执镰则能刈草。我因五根见闻至触亦复如是。善男子。人镰各异是故执镰能有所作。离根之外更无别我。云何说言我因诸根能有所作。善男子。汝意若谓执镰能刈。我亦如是。是我有手耶为无手乎。若有手者何不自执。若无手者云何说言我是作者。善男子。能刈草者即是镰也。非我非人。若我人能何故因镰。善男子。人有二业。一则执草。二则执镰。是镰唯有能断之功。众生见法亦复如是。眼能见色从和合生。若从因缘和合见者。智人云何说言有我。善男子。汝意若谓身作我受。是义不然。何以故。世间不见天得作业佛得受果。若言不是身作我非因受。汝等何故从于因缘求解脱耶。汝先是身非因缘生。得解脱已亦应非因而更生身。如身一切烦恼亦应如是。先尼言。瞿昙。我有二种。一者有知。二者无知。无知之我能得于身。有知之我能舍离身。犹如坏瓶既被烧已失于本色更不复生。智者烦恼亦复如是。既灭坏已终不更生。佛言。善男子。所言知者。智能知耶我能知乎。若智能知何故说言我是知耶。若我知者何故方便更求于智。汝意若谓我因智知同花喻坏。善男子。譬如刺树性自能刺。不得说言树执刺刺。智亦如是智自能知。云何说言我执智知。善男子。如汝法中我得解脱。无知我得知我得耶。若无知得当知犹故具足烦恼。若知得者当知已有五情诸根。何以故。离根之外别更无知。若具诸根云何复名得解脱耶。若言是我其性清净离于五根。云何说言遍五道有。以何因缘为解脱故修诸善法。善男子。譬如有人拔虚空刺。汝亦如是。我若清净。云何复言断诸烦恼。汝意若谓不从因缘获得解脱。一切畜生何故不得。先尼言。瞿昙。若无我者谁能忆念。佛告先尼。若有我者何缘复忘。善男子。若念是我者。何因缘故。念于恶念念所不念不念所念。先尼复言。瞿昙。若无我者谁见谁闻。佛言。善男子。内有六入外有六尘。内外和合生六种识。是六种识因缘得名。善男子。譬如一火因木得故名为木。火因草得故名为草火。因糠得故名为糠火。因牛粪得名牛粪火。众生意识亦复如是。因眼因色因明因欲名为眼识。善男子。如是眼识不在眼中乃至欲中。四事和合故生是识。乃至意识亦复如是。若是因缘和合故生。智不应说见即是我乃至触即是我。善男子。是故我说眼识乃至意识。一切诸法即是幻也。云何如幻。本无今有已有还无。善男子。譬如酥面蜜姜胡椒荜茇蒲萄胡桃石榴桵子。如是和合名欢喜丸。离是和合无欢喜丸。内外六入是名众生我人士夫。离内外入无别众生我人士夫。先尼言。瞿昙。若无我者。云何说言我见我闻我苦我乐我忧我喜。佛言。善男子。若言我见我闻名有我者。何因缘故世间复言。汝所作罪非我见闻。善男子。譬如四兵和合名军。如是四兵不名为一。而亦说言我军勇健我军胜彼。是内外入和合所作亦复如是。虽不是一亦得说言我作我受我见我闻我苦我乐。先尼言。瞿昙。如汝所言内外和合。谁出声言我作我受。佛言。先尼从爱无明因缘生业。从业生有从有出生无量心数。心生觉观觉观动风。风随心触喉舌齿唇。众生想倒声出说言。我作我受我见我闻。善男子。如幢头铃。风因缘故便出音声。风大声大风小声小无有作者。善男子。譬如热铁投之水中出种种声。是中真实无有作者。善男子。凡夫不能思惟分别如是事故。说言有我及有我所我作我受。先尼言。如瞿昙说无我我所。何缘复说常乐我净。佛言。善男子。我亦不说内外六入及六识意常乐我净。我乃宣说灭内外入所生六识。名之为常。以是常故名之为我。有常我故名之为乐。常我乐故名之为净。善男子。众生厌苦断是苦因。自在远离是名为我。以是因缘我今宣说常乐我净。先尼言。世尊。唯愿大慈为我宣说。我当云何获得如是常乐我净。佛言。善男子。一切世间从本已来具足大慢能增长慢。亦复造作慢因慢业。是故今者受慢果报。不能远离一切烦恼得常乐我净。若诸众生欲得远离一切烦恼先当离慢。先尼言。世尊。如是如是诚如圣教。我先有慢因慢因缘故称如来祢瞿昙姓。我今已离如是大慢。是故诚心启请求法。云何当得常乐我净。佛言。善男子。谛听谛听今当为汝分别解说。善男子。若能非自非他非众生者远离是法。先尼言。世尊。我已知解得正法眼。佛言。善男子。汝云何言知已解已得正法眼。世尊。所言色者。非自非他非诸众生。乃至识亦复如是。我如是观得正法眼。世尊。我今甚乐出家修道愿见听许。佛言。善来比丘。即时具足清净梵行证阿罗汉果。外道众中复有梵志姓迦叶氏。复作是言。瞿昙。身即是命身异命异。如来默然。第二第三亦复如是。梵志复言。瞿昙。若人舍身未得后身。于其中间岂可不名。身异命异。若是异者。瞿昙。何故默然不答。善男子。我说身命皆从因缘非不因缘。如身命一切法亦如是。梵志复言。瞿昙。我见世间有法不从因缘。佛言。梵志。汝云何见世间有法不从因缘。梵志言。我见大火焚烧榛木。风吹绝焰堕在余处。是岂不名无因缘耶。佛言。善男子。我说是火亦从因生非不从因。梵志言。瞿昙。绝焰去时不因薪炭。云何而言因于因缘。佛言。善男子。虽无薪炭因风而去。风因缘故其焰不灭。瞿昙。若人舍身未得后身。中间寿命谁为因缘。佛言。梵志。无明与爱而为因缘。是无明爱二因缘故寿命得住。善男子。有因缘故身即是命命即是身。有因缘故身异命异。智者不应一向而说身异命异。梵志言。世尊。唯愿为我分别解说。令我了了得知因果。佛言。梵志。因即五阴果亦五阴。善男子。若有众生不然火者是则无烟。梵志言。世尊。我已知已我已解已。佛言。善男子。汝云何知汝云何解。世尊。火即烦恼能于地狱饿鬼畜生人天烧然。烟者即是烦恼果报。无常不净臭秽可恶。是故名烟若有众生不作烦恼。是人则无烦恼果报。是故如来说不然火则无有烟。世尊。我已正见唯愿慈矜听我出家。尔时世尊告憍陈如。听是梵志出家受戒。时憍陈如受佛敕已。和合众僧听其出家受具足戒。经五日已得阿罗汉果。外道众中复有梵志名曰富那。复作是言。瞿昙。汝见世间是常法已说言常耶。如是义者实耶虚耶。常无常亦常无常非常非无常。有边无边亦有边亦无边非有边非无边。是身是命身异命异。如来灭后如去不如去。亦如去不如去。非如去非不如去。佛言。富那。我不说世间常虚实。无常亦常无常非常非无常。有边无边亦有边无边非有边非无边。是身是命身异命异。如来灭后如去不如去。亦如去不如去。非如去非不如去。富那复言。瞿昙。今者见何罪过不作是说。佛言。富那。若有人说世间是常。唯此为实余妄语者是名为见。见所见处是名见行是名见业。是名见着是名见缚是名见苦。是名见取是名见怖。是名见热是名见缠。富那。凡夫之人为见所缠。不能远离生老病死。回流六趣受无量苦。乃至非如去非不如去亦复如是。富那。我见是见有如是过。是故不着不为人说。瞿昙。若见如是罪过不着不说。瞿昙。今者何见何着何所宣说。佛言。善男子。夫见著者名生死法。如来已离生死法故。是故不着。善男子。如来名为能见能说。不名为着。瞿昙。云何能见云何能说。佛言。善男子。我能明见苦集灭道。分别宣说如是四谛。我见如是故能远离一切见一切爱一切流一切慢。是故我具清净梵行无上寂静获得常身。是身亦非东西南北。富那言。瞿昙。何因缘故。常身非是东西南北。佛言。善男子。我今问汝随汝意答。于意云何善男子。如于汝前然大火聚。当其然时汝知然不。如是瞿昙。是火灭时汝知灭不。如是瞿昙。富那。若有人问。汝前火聚然从何来灭何所至。当云何答。瞿昙。若有问者我当答言。是火生时赖于众缘。本缘已尽新缘未至是火则灭。若复有问是火灭已至何方面。复云何答。瞿昙。我当答言。缘尽故灭不至方所。善男子。如来亦尔若有无常色乃至无常识因爱故然。然者即受二十五有。是故然时可说是火东西南北。现在爱灭二十五有果报不然。以不然故不可说有东西南北。善男子。如来已灭无常之色至无常识是故身常。身若是常不得说有东西南北。富那言。请说一喻唯愿听采。佛言。善哉善哉随意说之。世尊。如大村外有娑罗林。中有一树先林而生足一百年。是时林主灌之以水随时修治。其树陈朽皮肤枝叶悉皆脱落唯贞实在。如来亦尔所有陈故悉已除尽。唯有一切真实法在。世尊。我今甚乐出家修道。佛言。善来比丘。说是语已。即时出家漏尽证得阿罗汉果

复有梵志名曰清净。作如是言。瞿昙。一切众生不知何法。见世间常无常亦常无常非有常非无常。乃至非如去非不如去。佛言。善男子。不知色故乃至不知识故。见世间常乃至非如去非不如去。梵志言。瞿昙。众生知何法故。不见世间常乃至非如去非不如去。佛言。善男子。知色故乃至知识故。不见世间常乃至非如去非不如去。梵志言。世尊。唯愿为我分别解说世间常无常。佛言。善男子。若人舍故不造新业。是人能知常与无常。梵志言。世尊。我已知见。佛言。善男子。汝云何见汝云何知。世尊。故名无明与爱。新名取有。若人远离是无明爱不作取有。是人真实知常无常。我今已得正法净眼归依三宝。唯愿如来听我出家。佛告憍陈如。听是梵志出家受戒。时憍陈如受佛敕已。将至僧中为作羯磨令得出家。十五日后诸漏永尽得阿罗汉果

大般涅槃经卷第三十九大般涅槃经卷第四十

        北凉天竺三藏昙无谶译

    憍陈如品第十三之二

犊子梵志复作是言。瞿昙。我今欲问能见听不。如来默然。第二第三亦复如是。犊子复言。瞿昙。我久与汝共为亲友。汝之与我义无有二。我欲咨问何故默然。尔时世尊作是思惟。如是梵志其性儒雅纯善质直。常为知故而来咨启不为恼乱。彼若问者当随意答。佛言。犊子。善哉善哉。随所疑问吾当答之。犊子言。瞿昙。世有善耶。如是梵志。有不善耶。如是梵志。瞿昙。愿为我说令我得知善不善法。佛言。善男子。我能分别广说其义。今当为汝简略说之。善男子。欲名不善。解脱欲者名之为善。嗔恚愚痴亦复如是。杀名不善不杀名善。乃至邪见亦复如是。善男子。我今为汝已说三种善不善法。及说十种善不善法。若我弟子能作如是分别三种善不善法。乃至十种善不善法。当知是人能尽贪欲嗔恚愚痴一切诸漏断一切有。梵志言。瞿昙。是佛法中颇有一比丘能尽如是贪欲嗔痴一切诸漏一切有不。佛言。善男子。是佛法中非一二三乃至五百。乃有无量诸比丘等。能尽如是贪欲恚痴一切诸漏一切诸有。瞿昙。置一比丘。是佛法中颇有一比丘尼能尽如是贪欲嗔痴一切诸漏一切有不。佛言。善男子。是佛法中非一二三乃至五百。乃有无量诸比丘尼。能断如是贪欲。嗔痴一切诸漏一切诸有。犊子言。瞿昙。置一比丘一比丘尼。是佛法中颇有一优婆塞持戒精勤梵行清净度疑彼岸断于疑网不。佛言。善男子。我佛法中非一二三乃至五百。乃有无量诸优婆塞。持戒精勤梵行清净断五下结。得阿那含度疑彼岸断于疑网。犊子言。瞿昙。置一比丘一比丘尼一优婆塞。是佛法中颇有一优婆夷持戒精勤梵行清净度疑彼岸断疑网不。佛言。善男子。我佛法中非一二三乃至五百。乃有无量诸优婆夷持戒精勤梵行清净断五下结。得阿那含度疑彼岸断于疑网。犊子言。瞿昙。置一比丘一比丘尼尽一切漏。一优婆塞一优婆夷持戒精勤梵行清净断于疑网。是佛法中颇有优婆塞受五欲乐心无疑网不。佛言。善男子。是佛法中非一二三乃至五百。乃有无量诸优婆塞断于三结得须陀洹。薄贪恚痴得斯陀含。如优婆塞优婆夷亦如是。世尊。我于今者乐说譬喻。佛言。善哉乐说便说。世尊。譬如难陀婆难陀龙王等降大雨。如来法雨亦复如是。平等雨于优婆塞优婆夷。世尊。若诸外道欲来出家不审如来几月试之。佛言。善男子。皆四月试不必一种。世尊。若不一种唯愿大慈听我出家。尔时世尊告憍陈如。听是犊子出家受戒。时憍陈如受佛敕已。立众僧中为作羯磨。于出家后满十五日得须陀洹果。既得果已复作是念。若有智慧从学得者。我今已得堪任见佛。即往佛所头面作礼。修敬已毕却住一面。白佛言。世尊。诸有智慧从学得者我今已得。唯愿为我重分别说。令我获得无学智慧。佛言。善男子。汝勤精进修习二法。一奢摩他。二毗婆舍那。善男子。若有比丘欲得须陀洹果。亦当勤修如是二法。若复欲得斯陀含果阿那含果阿罗汉果。亦当修习如是二法。善男子。若有比丘欲得四禅四无量心。六神通八背舍八胜处。无诤智顶智毕竟智四无碍智。金刚三昧尽智无生智。亦当修习如是二法。善男子。若欲得十住地无生法忍无相法忍不可思议法忍。圣行梵行天行菩萨行。虚空三昧智印三昧。空无相无作三昧。地三昧不退三昧。首楞严三昧金刚三昧。阿耨多罗三藐三菩提佛行。亦当修习如是二法。犊子闻已礼拜而出。在娑罗林中修是二法。不久即得阿罗汉果。是时复有无量比丘欲往佛所。犊子见已问言。大德。欲何所至。诸比丘言。欲往佛所。犊子复言。诸大德。若至佛所愿为宣启。犊子梵志修二法已得无学智。今报佛恩入般涅槃。时诸比丘至佛所已。白佛言。世尊。犊子比丘寄我等语。世尊。犊子梵志。修习二法得无学智。今报佛恩入于涅槃。佛言。善男子。犊子梵志得阿罗汉果。汝等可往供养其身。时诸比丘受佛敕已。还其尸所大设供养

纳衣梵志复作是言。瞿昙。如瞿昙所说无量世中作善不善。未来还得善不善身。是义不然。何以故。如瞿昙说因烦恼故获得是身。若因烦恼获得身者。身为在先烦恼在先。若烦恼在先谁之所作住在何处。若身在先云何说言因烦恼得。是故若言烦恼在先是亦不可。若身在先是亦不可。若言一时是亦不可。先后一时义俱不可。是故我说一切诸法皆有自性不从因缘

复次瞿昙。坚是地性湿是水性。热是火性动是风性。无所挂碍是虚空性。是五大性非因缘有。若使世间有一法性非因缘有。一切法性亦应如是非因缘有。若有一法从于因缘。何因缘故五大之性不从因缘。瞿昙。众生善身及不善身获得解脱。皆是自性不从因缘。是故我说一切诸法自性故有非因缘生

复次瞿昙。世间之法有定用处。譬如工匠云如是木任作车舆。如是任作门户床机。亦如金师所可造作。在额上者名之为鬘。在颈下者名之为璎。在臂上者名之为钏。在指上者名之为环。用处定故名为定性。瞿昙。一切众生亦复如是。有五道性故有地狱饿鬼畜生人天。若如是者云何说言从于因缘

复次瞿昙。一切众生其性各异。是故名为一切自性。瞿昙。如龟陆生自能入水。犊子生已能自饮乳。鱼见钩饵自然吞食。毒蛇生已自然食土。如是等事谁有教者。如刺生已自然头尖。飞鸟毛羽自然色别。世间众生亦复如是。有利有钝有富有贫有好有丑。有得解脱有不得解脱。是故当知一切法中各有自性

复次瞿昙。如瞿昙说贪欲嗔痴从因缘生。如是三毒因缘五尘。是义不然。何以故。众生睡时远离五尘。亦复生于贪欲嗔痴。在胎亦尔。初出胎时未能分别五尘好丑。亦复生于贪欲嗔痴。诸仙贤圣处在寂处无有五尘。亦能生于贪欲嗔痴。亦复有人因于五尘生于不贪不嗔不痴。是故不必从于因缘生一切法。以自性故

复次瞿昙。我见世人五根不具。多饶财宝得大自在。有根具足贫穷下贱。不得自在为人仆使。若有因缘何故如是。是故诸法各有自性不由因缘。瞿昙。世间小儿亦复未能分别五尘。或笑或啼笑时知喜啼时知愁。是故当知一切诸法各有自性。复次瞿昙。世法有二。一者有。二者无。有即虚空无即兔角。如是二法一是有故不从因缘。二是无故亦非因缘。是故诸法有自性故不从因缘

佛言。善男子。如汝所言如五大性一切诸法亦应如是。是义不然。何以故。善男子。汝法中以五大是常。何因缘故一切诸法悉不是常。若世间物是无常者。是五大性何因缘故不是无常。若五大常世间之物亦应是常。是故汝说五大之性有自性故不从因缘。令一切法同五大者无有是处

善男子。汝言用处定故有自性者。是义不然。何以故。皆从因缘得名字故。若从因得名亦从因得义。云何名为从因得名。如在额上名之为鬘。在颈名璎在臂名钏在车名轮。火在草木名草木火。善男子。树初生时无箭槊性。从因缘故工造为箭。从因缘故工造为槊。是故不应说一切法有自性也。善男子。汝言如龟陆生性自入水。犊子生已性能饮乳。是义不然。何以故。若言入水非因缘者。俱非因缘何不入火。犊子生已性能[口*束]乳不从因缘者。俱非因缘何不[口*束]角。善男子。若言诸法悉有自性。不须教习无有增长。是义不然。何以故。今见有教缘教增长。是故当知无有自性。善男子。若一切法有自性者。诸婆罗门一切不应为清净身杀羊祠祀若为身祠。是故当知无有自性。善男子。世间语法凡有三种。一者欲作。二者作时。三者作已。若一切法有自性者。何故世中有是三语。有三语故。故知一切无有自性。善男子。若言诸法有自性者。当知诸法各有定性。若有定性甘蔗一物。何缘作浆作蜜石蜜酒苦酒等。若有一性何缘乃出如是等味。若一物中出如是等。当知诸法不得一定各有一性。善男子。若一切法有定性者。圣人何故饮甘蔗浆石蜜黑蜜酒时不饮后为苦酒复还得饮。是故当知无有定性。若无定性云何不因因缘而有。善男子。汝说一切法有自性者云何说喻。若有喻者当知诸法无有自性。若有自性当知无喻。世间智者皆说譬喻。当知诸法无有自性无有一性。善男子。汝言身为在先烦恼在先者。是义不然。何以故。若我当说身在先者。汝可难言汝亦同我身不在先。何因缘故而作是难。善男子。一切众生身及烦恼俱无先后一时而有。虽一时有要因烦恼而得有身。终不因身有烦恼也。汝意若谓如人二眼一时而得。不相因待左不因右右不因左。烦恼及身亦如是者。是义不然。何以故。善男子。世间眼见炷之与明。虽复一时明要因炷。终不因明而有炷也。善男子。汝意若谓身不在先故知无因。是义不然。何以故。若以身先无因缘故名为无者。汝不应说。一切诸法皆有因缘。若言不见故不说者。今见瓶等从因缘出何故不说。如瓶身先因缘亦复如是。善男子。若见不见一切诸法。皆从因缘无有自性。善男子。若言一切法悉有自性无因缘者。汝何因缘说于五大。是五大性即是因缘。善男子。五大因缘虽复如是。亦不应说诸法皆同五大因缘。如世人说一切出家精勤持戒。旃陀罗等亦应如是精勤持戒。善男子。汝言五大有定坚性。我观是性转故不定。善男子酥蜡胡胶于汝法中名之为地。是地不定或同于水或同于地。故不得说自性故坚。善男子。白镴铅锡铜铁金银。于汝法中名之为火。是火四性流时水性动时风性热时火性坚时地性。云何说言定名火性。善男子。水性名流若水冻时不名为地故名水者。何因缘故。波动之时不名为风。若动不名风冻时亦应不名为水。若是二义从因缘者。何故说言一切诸法不从因缘。善男子。若言五根性能见闻觉知触故。皆是自性不从因缘。是义不然。何以故。善男子。自性之性性不可转。若言眼性见者常应能见。不应有见有不见时。是故当知从因缘见非无因缘。善男子。汝言非因五尘生贪解脱。是义不然。何以故。善男子。生贪解脱虽复不同五尘因缘。恶觉观故则生贪欲。善觉观故则得解脱。善男子。内因缘故生贪解脱。外因缘故则能增长。是故汝言一切诸法各有自性。不因五尘生贪解脱无有是处。善男子。汝言具足诸根乏于财物不得自在。诸根残缺多饶财宝得大自在。因此以明有自性。故不从因缘者。是义不然。何以故。善男子。众生从业而有果报。如是果报则有。三种。一者现报。二者生报。三者后报。贫穷巨富根具不具是业各异。若有自性具诸根者应饶财宝饶财宝者应具诸根。今则不尔是故定知无有自性皆从因缘。如汝所言世间小儿未能分别五尘因缘亦啼亦笑。是故一切有自性者。是义不然。何以故。若自性者。笑应常笑啼应常啼。不应一笑一啼。若一笑一啼当知一切悉从因缘。是故不应说一切法有自性故不从因缘。梵志言。世尊。若一切法从因缘有。如是身者从何因缘。佛言。善男子。是身因缘烦恼与业。梵志言。世尊。如其是身从烦恼业。是烦恼业可断不耶。佛言。如是如是。梵志复言。世尊。唯愿为我分别解说。令我闻已不移是处悉得断之。佛言。善男子。若知二边中间无碍。是人则能断烦恼业。世尊。我已知解得正法眼。佛言。汝云何知。世尊。二边即色及色解脱。中间即是八正道也。受想行识亦复如是。佛言。善哉善哉。善男子。善知二边断烦恼业。世尊唯愿听我出家受戒。佛言。善来比丘即时断除三界烦恼得阿罗汉果

尔时复有一婆罗门名曰弘广。复作是言。瞿昙。知我今所念不。佛言。善男子。涅槃是常有为无常。曲即邪见直即圣道。婆罗门言。瞿昙。何因缘故作如是说。善男子。汝意每谓乞食是常别请无常。曲是户钥直是帝幢。是故我说涅槃是常有为无常。曲谓邪见直谓八正。非如汝先所思惟也。婆罗门言。瞿昙。实知我心是八正道悉令众生得尽灭不

尔时世尊默然不答。婆罗门言。瞿昙。已知我心我今所问。何故默然而不见答。时憍陈如即作是言。大婆罗门。若有问世有边无边。如来常尔默然不答。八圣是直涅槃是常。若修八圣即得灭尽。若不修习则不能得。大婆罗门。譬如大城其城四壁都无孔窍唯有一门。其守门者聪明有智能善分别。可放则放可遮则遮。虽不能知出入多少。定知一切有入出者皆由此门。善男子。如来亦尔。城喻涅槃门喻八正。守门之人喻于如来。善男子。如来今者虽不答汝尽与不尽。其有尽者要当修习是八正道。婆罗门言。善哉善哉。大德憍陈如。如来善能说微妙法。我今实欲知城知道自作守门。憍陈如言。善哉善哉。汝婆罗门。能发无上广大之心。佛言。止止憍陈如。是婆罗门非适今日发是心也。憍陈如。乃往过去过无量劫有佛世尊。名普光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是人先已于彼佛所发阿耨多罗三藐三菩提心。此贤劫中当得作佛。久已通达了知法相。为众生故现处外道示无所知。以是因缘。汝憍陈如。不应赞言。善哉善哉。汝今能发如是大心

尔时世尊知已即告憍陈如言。阿难比丘今为所在。憍陈如言。世尊。阿难比丘在娑罗林外。去此大会十二由旬。而为六万四千亿魔之所娆乱。是诸魔众悉自变身为如来像。或有宣说一切诸法从因缘生。或有说言一切诸法不从因生。或有说言一切因缘皆是常法。从缘生者悉是无常。或有说言五阴是实。或说虚假入界亦尔。或有说言有十二因缘。或有说言正有四缘。或说诸法如幻如化如热时焰。或有说言因闻得法。或有说言因思得法。或有说言因修得法。或复有说不净观法。或复有说出息入息。或复有说四念处观。或复有说三种观义七种方便。或复有说暖法顶法忍法世间第一法。学无学地菩萨初住乃至十住。或有说空无相无作。或复有说修多罗祇夜毗伽罗那伽陀忧陀那尼陀那阿波陀那伊帝目多伽阇陀伽毗佛略阿浮陀达摩优波提舍。或说四念处四正勤四如意足五根五力七觉分八圣道。或说内空外空内外空有为空无为空无始空性空远离空散空自相空无相空阴空入空界空善空不善空无记空菩提空道空涅槃空行。空得空第一义空空空大空。或有示现神通变化身出水火。或身上出水身下出火身下出水身上出火。左胁在下右胁出水右胁在下左胁出水。一胁震雷一胁降雨。或有示现诸佛世界。或复示现菩萨初生行至七步。处在深宫受五欲时。初始出家修苦行时。往菩提树坐三昧时。坏魔军众转法轮时。示大神通入涅槃时。世尊。阿难比丘见是事已作是念言。如是神变昔来未见谁之所作。将非世尊释迦作耶。欲起欲语都不从意。阿难比丘入魔罥故。复作是念。诸佛所说各各不同。我于今者当受谁语。世尊。阿难今者极受大苦。虽念如来无能救者。以是因缘不来至此大众之中。尔时文殊师利菩萨摩诃萨白佛言。世尊。此大众中有诸菩萨已于一生发阿耨多罗三藐三菩提心。至无量生发菩提心。已能供养无量诸佛其心坚固。具足修行檀波罗蜜乃至般若波罗蜜。成就功德久已亲近无量诸佛。净修梵行得不退转菩提之心。得不退忍不退转持。得如法忍首楞严等无量三昧如是等辈闻大乘经终不生疑。善能分别宣说三宝同一性相常住不变。闻不思议不生惊怪。闻种种空心不怖懅。了了通达一切法性。能持一切十二部经广解其义。亦能受持无量诸佛十二部经。何忧不能受持如是大涅槃典。何因缘故。问憍陈如阿难所在。尔时世尊告文殊师利。谛听谛听。善男子。我成佛已过二十年住王舍城。尔时我告诸比丘言。诸比丘。今此众中谁能为我受持如来十二部经。供给左右所须之事。亦使不失自身善利。时憍陈如在彼众中来白我言。我能受持十二部经。供给左右不失所作自利益事。我言。憍陈如。汝已朽迈当须使人。云何方欲为我给使。时舍利弗复作是言。我能受持佛一切语供给所须。不失所作自利益事。我言。舍利弗。汝已朽迈当须使人。云何方欲为我给使。乃至五百诸阿罗汉皆亦如是佛悉不受。尔时目连在大众中作是思惟。如来今者不受五百比丘给使。佛意为欲令谁作耶。思惟是已即便入定。见如来心在阿难许。如日初出光照西壁。见是事已即从定起语憍陈如。大德。我观如来欲令阿难给事左右。尔时憍陈如与五百阿罗汉。往阿难所作如是言。阿难。汝今当为如来给使请受是事。阿难言。诸大德。我实不堪给事如来。何以故。如来尊重如师子王如龙如火。我今秽弱云何能办。诸比丘言。阿难。汝受我语给事如来得大利益。第二第三亦复如是。阿难言。诸大德。我亦不求大利益事。实不堪任奉给左右。时目犍连复作是言。阿难。汝今未知。阿难言。大德。唯愿说之。目犍连言。如来先日僧中求使。五百罗汉皆求为之。如来不听。我即入定见如来意欲令汝为。汝今云何反更不受。阿难闻已合掌长跪作如是言。诸大德。若有是事如来世尊与我三愿。当顺僧命给事左右。目犍连言。何等三愿。阿难言。一者如来设以故衣赐我听我不受。二者如来设受檀越别请听我不往。三者听我出入无有时节。如是三事佛若听者。当顺僧命奉给如来。时憍陈如五百比丘。还来我所作如是言。我等已劝阿难比丘。唯求三愿若佛听者当顺僧命。文殊师利。我于尔时赞阿难言。善哉善哉。阿难比丘。具足智慧预见讥嫌。何以故。当有人言汝为衣食奉给如来。是故先求不受故衣不随别请。憍陈如。阿难比丘具足智慧。入出有时则不能得广作利益四部之众。是故求欲出入无时。憍陈如。我为阿难开是三事随其意愿。时目犍连还阿难所语阿难言。吾已为汝启请三事。如来大慈皆已听许。阿难言。大德。若佛听者请往给侍

文殊师利。阿难事我二十余年。具足八种不可思议。何等为八。一者事我已来二十余年。初不随我受别请食。二者事我已来初不受我陈故衣服。三者自事我来至我所时终不非时。四者自事我来具足烦恼随我入出诸王刹利豪贵大姓。见诸女人及天。龙女不生欲心。五者自事我来持我所说十二部经。一经于耳曾不再问。如写瓶水置之一瓶。唯除一问。善男子。琉璃太子杀诸释氏坏迦毗罗城。阿难尔时心怀愁恼发声大哭。来至我所作如是言。我与如来俱生此城同一释种。云何如来光颜如常我则憔悴。我时答言。阿难。我修空定故不同汝。过三年已还来问我。世尊。我往于彼迦毗罗城。曾闻如来修空三昧是事虚实。我言。阿难。如是如是如汝所说。六者自事我来虽未获得知他心智。常知如来所入诸定。七者自事我来未得愿智而能了知如是众生到如来所。现在能得四沙门果。有后得者。有得人身有得天身。八者自事我来如来所有秘密之言悉能了知。善男子。阿难比丘具足如是八不思议。是故我称阿难比丘为多闻藏。善男子。阿难比丘具足八法。能具足持十二部经。何等为八。一者信根坚固。二者其心质直。三者身无病苦。四者常勤精进。五者具足念心。六者心无憍慢。七者成就定慧。八者具足从闻生智。文殊师利。毗婆尸佛侍者弟子名阿叔迦。亦复具足如是八法。尸弃如来侍者弟子名差摩迦罗。毗舍浮佛侍者弟子名优波扇陀迦罗。鸠村驮佛侍者弟子名曰跋提。迦那含牟尼佛侍者弟子名曰苏坻。迦叶佛侍者弟子名叶婆蜜多。皆亦具足如是八法。我今阿难亦复如是具足八法。是故我称阿难比丘为多闻藏善男子。如汝所说此大众中虽有无量无边菩萨。是诸菩萨皆有重任。所谓大慈大悲。如是慈悲之因缘故。各各匆务调伏眷属庄严自身。以是因缘。我涅槃后不能宣通十二部经。若有菩萨或时能说人不信受。文殊师利。阿难比丘是吾之弟。给事我来二十余年。所可闻法具足受持。喻如写水置之一器。是故我今顾问。阿难为何所在。欲令受持是涅槃经。善男子。我涅槃后阿难比丘所未闻者。弘广菩萨当能流布。阿难所闻自能宣通。文殊师利。阿难比丘今在他处。去此会外十二由延。而为六万四千亿魔之所恼乱。汝可往彼发大声言。一切诸魔谛听谛听。如来今说大陀罗尼。一切天龙乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。山神树神河神海神舍宅等神闻是持名。无不恭敬受持之者。是陀罗尼十恒河沙诸佛世尊所共宣说。能转女身自识宿命若受五事。一者梵行。二者断肉。三者断酒。四者断辛。五者乐在寂静。受五事已至心信受。读诵书写是陀罗尼。当知是人即得超越七十七亿弊恶之身。尔时世尊。即便说之

阿摩[(匕/示)*(入/米)]　毗摩[(匕/示)*(入/米)]　涅磨[(匕/示)*(入/米)]瞢伽[(匕/示)*(入/米)]醯摩罗若竭鞞　三曼多跋提[(匕/示)*(入/米)]　娑婆罗他娑檀尼　婆罗磨他娑檀尼　磨那斯阿步提　毗罗氏　庵摩赖低　婆岚弥　婆岚摩莎[(匕/示)*(入/米)]　富啰泥富啰那摩奴赖绨

尔时文殊师利从佛受是陀罗尼已至阿难所。在魔众中作如是言。诸魔眷属谛听。我说所从佛受陀罗尼咒。魔王闻是陀罗尼已。悉发阿耨多罗三藐三菩提心。舍于魔业即放阿难。文殊师利与阿难俱来至佛所。阿难见佛至心礼敬却住一面佛告阿难。是娑罗林外有一梵志名须跋陀。其年极老已百二十。虽得五通未舍憍慢。获得非想非非想定。生一切智起涅槃想。汝可往彼语须跋言。如来出世如优昙花。于今中夜当般涅槃。若有所作可及时作。莫于后日而生悔心。阿难汝之所说彼定信受。何以故。汝曾往昔五百世中作须跋陀子。其人爱心习犹未尽。以是因缘信受汝语。尔时阿难受佛敕已。往须跋所作如是言。仁者。当知如来出世如优昙花。于今中夜当般涅槃。欲有所作可及时作。莫于后日生悔心也。须跋言。善哉阿难。我今当往至如来所。尔时阿难与须跋陀还至佛所时须跋陀到已问讯作如是言。瞿昙。我今欲问随我意答。佛言。须跋。今正是时随汝所问。我当方便随汝意答。瞿昙。有诸沙门婆罗门等作如是言。一切众生受苦乐报。皆随往日本业因缘。是故若有持戒精进受身心苦能坏本业。本业既尽众苦尽灭。众苦尽灭即得涅槃。是义云何。佛言。善男子。若有沙门婆罗门等作是说者。我为怜愍常当往来如是人所。既至彼已我当问之。仁者。实作如是说不。彼若见答我如是说。何以故。瞿昙。我见众生习行诸恶。多饶财宝身得自在。又见修善贫穷多乏不得自在。又见有人多役力用求不能得。又见不求自然得之。又见有人慈心不杀反更中夭。又见喜杀终保年寿。又见有人净修梵行精勤持戒。有得解脱有不得者。是故我说一切众生受苦乐报。皆由往日本业因缘。须跋我复当问仁者。实见过去业不。若有是业为多少耶。现在苦行能破多少耶。能知是业已尽不尽耶。是业既尽一切尽耶。彼若见答我实不知。我便当为彼人引喻。譬如有人身被毒箭。其家眷属为请医师令拔是箭。既拔箭已身得安隐。其后十年是人犹忆了了分明。是医为我拔出毒箭。以药涂拊令我得差安隐受乐。仁既不知过去本业。云何能知现在苦行定能破坏过去业耶。彼若复言。瞿昙。汝今亦有过去本业。何故独责我过去业。瞿昙。经中亦作是说。若见有人豪贵自在。当知是人先世好施。如是不名过去业耶。我复答言。仁者。如是知者。名为比知不名真知。我佛法中或有从因知果。或有从果知因。我佛法中有过去业有现在业。汝则不尔唯有过去业无现在业。汝法不从方便断业。我法不尔从方便断。汝业尽已则得苦尽。我即不尔烦恼尽已业苦则尽。是故我今责汝过去业。彼人若言瞿昙我实不知。从师受之师作是说我实无咎。我言。仁者。汝师是谁。彼若见答是富兰那。我复言曰。汝昔何不一一咨启。大师实知过去业不。汝师若言我不知者。汝复云何受是师语。若言我知复应问言。下苦因缘受中上苦不。中苦因缘受下上苦不。上苦因缘受中下苦不。若言不者。复应问言。师云何说苦乐之报唯过去业非现在耶。复应问言。是现在苦过去有不。若过去有过去之业悉已都尽。若都尽者云何复受今日之身。若过去无唯现在有。云何复言众生苦乐皆过去业。仁者。若知现在苦行能坏过去业。现在苦行复以何破。如其不破苦即是常。苦若是常云何说言得苦解脱。若更有行坏苦行者。过去已尽云何有苦。仁者。如是苦行能令乐业受苦果不。复令苦业受乐果不。能令无苦无乐业作不受果不。能令现报作生报不。能令生报作现报不。令是二报作无报不。能令定报作无报不。能令无报作定报不。彼若复言瞿昙不能。我复当言。仁者。如其不能何因缘故受是苦行。仁者。当知定有过去业现在因缘。是故我言因烦恼生业因业受报。仁者。当知一切众生有过去业有现在因。众生虽有过去寿业。要赖现在饮食因缘。仁者。若说众生受苦受乐。定由过去本业因缘。是事不然。何以故。仁者。譬如有人为王除怨。以是因缘多得财宝。因是财宝受现在乐。如是之人现作乐因现受乐报。譬如有人杀王爱子。以是因缘丧失身命。如是之人现作苦因现受苦报。仁者。一切众生现在因于四大时节土地人民受苦受乐。是故我说一切众生不必尽因过去本业受苦乐也。仁者。若以断业因缘力故得解脱者。一切圣人不得解脱。何以故。一切众生过去本业无始终故。是故我说修圣道时是道能遮无始终业。仁者。若受苦行便得道者。一切畜生悉应得道。是故先当调伏其心不调伏身。以是因缘我经中说。斫伐此林莫斫伐树。何以故。从林生怖不从树生。欲调伏身先当调心。心喻于林身喻于树。须跋陀言。世尊。我已先调伏心。佛言。善男子。汝今云何能先调心。须跋陀言。世尊。我先思惟欲是无常无乐无净。观色即是常乐清净。作是观已欲界结断获得色处。是故名为先调伏心。次复观色色是无常如痈如疮如毒如箭。见无色常清净寂静。如是观已色界结尽得无色处。是故名为先调伏心。次复观想即是无常痈疮毒箭。如是观已获得非想非非想处。是非想非非想处即一切智寂静清净。无有堕坠常恒不变。是故我能调伏其心。佛言。善男子。汝云何能调伏心耶。汝今所得非想非非想定犹名为想。涅槃无想。汝云何言获得涅槃。善男子。汝已先能呵责粗想。今者云何爱着细想。不知呵责如是非想非非想处。故名为想如痈如疮如毒如箭。善男子。汝师郁头蓝弗利根聪明。尚不能断如是非想非非想处。受于恶身况其余者。世尊。云何能断一切诸有。佛言。善男子。若观实相是人能断一切诸有。须跋陀言。世尊。云何名为实相。善男子。无相之相名为实相。世尊。云何名为无相之相。善男子。一切法无自相他相及自他相。无无因相无作相无受相。无作者相无受者相。无法非法相。无男女相无士夫相。无微尘相无时节相。无为自相无为他相无为自他相。无有相无无相无生相无生者相。无因相无因因相。无果相无果果相。无昼夜相无明闇相。无见相无见者相。无闻相无闻者相。无觉知相无觉知者相。无菩提相无得菩提者相。无业相无业主相。无烦恼相无烦恼主相。善男子。如是等相随所灭处名真实相。善男子。一切诸法皆是虚假。随其灭处是名为实是名实相。是名法界名毕竟智。名第一义谛名第一义空。善男子。是相法界毕竟智。第一义谛第一义空。下智观故得声闻菩提。中智观故得缘觉菩提。上智观故得无上菩提。说是法时十千菩萨得一生实相。万五千菩萨得二生法界。二万五千菩萨得毕竟智。三万五千菩萨悟第一义谛。是第一义谛亦名第一义空。亦名首楞严三昧。四万五千菩萨得虚空三昧。是虚空三昧亦名广大三昧。亦名智印三昧。五万五千菩萨得不退忍。是不退忍亦名如法忍。亦名如法界。六万五千菩萨得陀罗尼。是陀罗尼亦名大念心。亦名无碍智。七万五千菩萨得师子吼三昧。是师子吼三昧亦名金刚三昧。亦名五智印三昧。八万五千菩提得平等三昧。是平等三昧亦名大慈大悲。无量恒河沙等众生发阿耨多罗三藐三菩提心。无量恒河沙等众生发缘觉心。无量恒河沙等众生发声闻心。人女天女二万亿人现转女身得男子身。须跋陀罗得阿罗汉果

大般涅槃经卷第四十

  阿摩隶(一)毗磨隶(二)涅磨隶(三)瞢伽隶(四)醯　磨罗若竭捭(五)三曼那跋提(六)娑婆陀　裟檀　尼(七)波罗磨他　娑檀尼(八)摩那斯(九)阿拙啼(十)　毗罗只(十一)庵摩赖[土*(系-小)](十二)婆岚弥(十三)婆岚摩(十四)莎　隶富泥富那(十五)摩奴赖绨(五十)

      高　野　山　出　涅　槃　经　梵　文　断　片

                        【表】

1. 1. mama s/ra^vaka^ maha^ya^nnaka^m!ks!ita^s tada^ s!ad!rasavan maha^bhojanam iva ma-

      ha^parinivva^n!am! maha^su^tram! des/aya^mi.

1. 2. tatra katame s!ad!rasa^ duh!kham a^m!vlam [a^mlam][a-]nityam! lavan!am ana^tma-

      kam! kat!ukam! sukham! madhuram! sa^tmakam! kas!a^yam! nityan ti-

1. 3. ktam iti ime s!ad!rasa^h! kles/endhanena ma^ya^-agnina^ paripa^citam! bhojanam!

      maha^parinirvva^n!am! tatva^nnamr!s!t!am!

1. 4. mama s/ra^vaka^ bhun~jante. punar aparam! bhagini yatha^ yu^yam! para^mantran!ena

      paracu^d!a^karan!animittena va^

1. 5. paragra^mam! gantuka^ma^ dus!putra^n utsr!jya satputra^n!a^m! guhya^bhinidha^na^ni

      dars/ayasi. a^ma bhagavan dus!-

1. 6. putra^ ana^ca^ra^h! anarthabha^ginas tes!a^m! mityartham! na dars/aya^mi. satputra^s

      tu kuladhara^h! kulanissaraka^h!

1. 7. te dravya^rha^h! tes!a^m! dars/aya^mi. evam aham! bhagini maha^parinirvva^n!a-gama-

      nakriya^m! yada^ karomi, tada^ tatha^-

                        【里】

1. 1. gatavividhaguhyam! sandha^vacanam! s/ra^vakebhyo niravas/es!am! kathayis!ya^mi. adya

      putrebhyas/ cchandam! da^sya^mi yatha^ tva^m! bhagi-

1. 2. ni prava^sagata^m! dus!putra^ mr!teti kalpayanti na ca^pi mr!ta^ a^ma bhagavan punar

      apy a^gata^nte pas/yanti evam e-

1. 3. va bhagini maya^ ma^ 'nitya-sam!jn~a^ ka^rs!i^t. adya tatha^gatah! parinirvva^syati^ti

      nevam! kalpayitavyam! mr!tasam!jn~a^-

1. 4. vat ye sada^ nityodbruvah! s/a^s/vatah! tatha^gata iti dha^rayanti tes!am! tatha^gato

      gr!he tis!t!hati. es!a

1. 5. para^ddhya^s/ayo [adhya^s/sya*] na^ma pr!ccha^vas/a^ na^ma iha kas/cit tatha^gatam arh-

      antam! samyaksambuddham! paripr!cchet katham a-

1. 6. ham! bhagavan ki^rttim! pra^pnuya^t loke da^yako vis/ruta iti na ca dadya^t kasmim!s/

      cit[ta] tatha^gatam evam vadet nih!-

1. 7. sam!gam prava^raya da^si^da^saparigrahen!a atyantabrahmaca^rin!am! kuma^ri^da^nena

      ama^m!sa-bhojinam! ma^m!sabha。


大悲经

    No. 380

大悲经卷第一

        高齐天竺三藏那连提耶舍 译

    梵天品第一

如是我闻。一时佛在拘尸那城力士生地娑罗双树间。尔时世尊临般涅槃。告慧命阿难言。汝可于娑罗双树间安置敷具。如师子王右胁卧法。吾今后夜当般涅槃。阿难。我已究竟涅槃。断除一切有为言说。我已作佛事已。说甘露无有窟宅。寂灭定甚深微妙难见难觉难可测量。明智所知诸贤圣法。我已三转无上法轮。若有沙门婆罗门。若天若魔若梵若人。以世共法无能转者。我已击法鼓吹法蠡建法幢。置法船作法桥降法雨。我已光照三千大千世界灭除大闇。开示众生解脱正道充益天人。所应度者皆悉已度。我已降伏一切外道及诸异论。动魔宫殿摧魔势力。大师子吼作诸佛事。建丈夫业满本誓愿。护持法眼教大声闻授菩萨记。为于未来佛眼不断故。阿难。我今于后更无所作唯般涅槃

尔时阿难闻是语已。为忧箭所射极大愁恼。悲泣流泪白佛言。世尊婆伽婆。涅槃太速。修伽陀。涅槃太速。世间眼灭世间孤独。世间无救无有导师。尔时佛告慧命阿难。止莫忧悲。阿难。生法有法有为法坏法。若不灭者无有是处。我昔告汝。一切所爱称意等事必有离散。阿难。汝已慈心不二。心无恶心及与身业。孝养随顺而无限量侍养于我。阿难。若复天人阿修罗等。给侍供养声闻缘觉。若减一劫若满一劫。若复给侍供养如来。于一念顷其福多彼。汝已供养大神通佛乃至般涅槃。当得大福广大功德。犹如甘露第一甘露。最后甘露究竟涅槃。是故阿难。汝莫忧悲

尔时阿难忧悲抆泪。即为如来于双树间。犹如师子右胁卧法安置敷具。即时三千大千世界。所有树木药草丛林。皆向如来涅槃方所。有欲倒者。有伛偻者。有欲至地者。有躄地者。于此三千大千世界。所有众流大河小河泉池陂湖。佛神力故止不流动。三千大千 世界所有禽兽。佛神力故默然而住不鸣不食。三千大千世界所有日月星宿。火光明珠乃至荧火。佛神力故皆不显现。无有光明不能照曜。三千大千世界所有猛火。佛神力故皆悉止息。不然不热不能烧炙。三千大千世界所有一切地狱猛火。佛神力故皆悉清凉。彼诸地狱所有众生于刹那顷。佛神力故皆得安乐。三千大千世界所有畜生。一切皆起慈心愍心。不相嗔恼加害断命。一切饿鬼皆不饥渴。一切众生佛神力故。身心踊悦离苦得猗。具足称意第一安乐。当于世尊右胁卧时。三千大千世界于中所有须弥山王。铁围山大铁围山。目真邻陀山。香山雪山及诸黑山大地大海一切皆悉六种震动。所谓动踊起震吼觉。三千大千世界一切风轮皆不鼓动。一切众生于刹那顷。舍诸作业得猗而住。离于睡眠心无散乱。欲作皆息默然无声。三千大千世界所有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。梵天释天护世王等。佛神力故各见宫殿床座园林。皆悉闇昧无复威光不生爱乐。彼等眷属忧烦不乐。千世界主梵天王。三千大千世界主大梵天王。高心自恃作如是念作如是解。念此世界及诸众生。是我所作是我所化。彼三千大千世界主大梵天王。佛神力故见己宫殿及床座等。闇昧无光不生爱乐。摩醯首罗净居天等。亦复如是。尔时三千大千世界主大梵天王。作如是念。是谁力故而现此相。令我不乐宫殿床座。是时大梵天王。遍观于此三千大千世界中。造作富贵大自在主。如来应供正遍知。今日后夜当般涅槃。是故现此神力变化不可思议未曾有事。此之神力正是如来入涅槃相。时大梵王作是念已。忧愁不乐战悚毛竖。极疾匆匆梵众围绕共诣佛所。其三千大千世界诸余梵天。皆悉已曾信受圣法安住圣法

尔时三千大千世界主大梵天王。到佛所已头面作礼而白佛言。唯愿世尊。教敕于我。云何而住云何修行。作是语已。如来即问大梵王言。梵天。汝今实作如是念言。我是大梵天我能胜他他不如我我是智者。我是三千大千世界中大自在主。我造作众生化作众生。我造作世界化作世界不。大梵天言。如是婆伽婆。如是修伽陀。佛言。梵天。汝复为谁所作为谁所化。时彼梵天默然而住。佛见梵天默然住故。而复问言。梵天有时三千大千世界为劫火焚烧炎炽洞然。于意云何。是汝所作是汝所化耶。时大梵天而白佛言。不也世尊。佛言。梵天。如此大地依水聚住。水依风住。风依虚空。如是大地。厚六百八十万由旬。不裂不散。梵天。于意云何。是汝所作是汝所化耶。梵天言。不也世尊。佛言。梵天。此三千大千世界百亿日月流转之时。梵天于意云何。是汝所化耶。梵天言。不也世尊。佛言。梵天有时日月天子不在宫殿。宫殿空虚。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。如是春秋冬夏时节。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。如是水镜苏油摩尼颇梨。及余净器现诸色像。所谓大地山河树林园苑。宫殿舍宅聚落城邑。驼驴象马獐鹿鸟兽。日月星宿。声闻缘觉菩萨如来。释梵护世人非人等种种色像。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。如是山崖深谷。大小诸鼓歌舞等戏。獐鹿鸟兽人非人等所出音声。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。如诸众生于其梦中。见种种色闻种种声。嗅种种香尝种种味。觉种种触知种种法。作种种戏种种啼哭呻号怖畏苦乐等受。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。如四姓人端正丑陋。贫穷巨富福德多少。善戒恶戒善慧恶慧。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。一切众生所有怖畏苦切恼害。所谓。水火刀风崖岸毒药。恶兽怨仇人非人畏。及以种种加害。于他常有怖畏。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有种种疾病。所谓风冷热病及诸杂病。时节代谢四大相违。若他所作若先业报。所谓眼耳鼻舌身病。若复众生种种心意热恼等苦。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有旷野崄贼水灾等难。或复中劫刀兵疫病及以饥馑。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有爱别离苦。所谓父母兄弟姊妹宗亲善友离别之苦。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所作种种恶业。所谓贩卖生口酒麴紫矿押油之具。若入大海旷野崄处游行诸方。若诸仙方术及余种种断事之法。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所作种种业道。以是业因。受于地狱畜生饿鬼人天之报。众生所有若身口意善行恶行。及世间所有十恶业道。于诸众生都无慈愍。作诸苦恼不利益事堕恶道因缘。所谓杀生偷盗邪淫妄语两舌恶口绮语贪嗔邪见。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有种种苦事。所谓斩首截其手足。刵劓耳鼻。节节支解。热油所灌。火灸 熬煮 。刀剑鉾槊斫刺鞭打。系闭牢狱斗诤言讼。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所作淫欲邪行。或淫母女姊妹净持戒者。及余恶业。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有种种杀害。厌虫起尸咒术方药鬼魅所著。及余种种恶业方便断命因缘。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。世间所有生老病死忧悲苦恼。无常法尽法变易法。于四姓人无所忌难。能令一切所爱无厌。种种之物败坏离散。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。众生所有贪嗔痴障。结使缠缚及余种种苦恼所缚。以是因缘。令诸众生坚着嗔怒迷惑心故。造作无量种种业行。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。所有三恶趣地狱畜生饿鬼。其处众生为种种事受诸苦恼。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。一切所有若种子生无种子生。树木药草。若水陆生华果香树。种种胜味甘苦碱辛酸涩之味。随诸众生所喜不喜作损益者。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也世尊。佛言。梵天。五道流转生死成坏。所有众生无明覆盖与爱结相应。驰走流转始终难知。及未来生死流转不断其处。人天若魔若梵沙门婆罗门。此等世间如乱丝缠缚。常驰流转彼此往来。此诸众生于流转中不知求出。梵天。于意云何。是汝所作是汝所化是汝所加耶。梵天言。不也婆伽婆。佛言。梵天。汝从何因作是念言。此诸众生。是我所作。是我所化。是我所加。所有世界。是我所作。是我所化。是我所加耶。梵天言。世尊。我以无智邪见未断颠倒心故。常于如来所说正法不听受故。我本曾作如是恶见如是恶说。此诸众生。是我所作是我所化。所有世界。是我所作是我所化。世尊。我今还复问佛此义。所有世界。是谁所作。是谁所化。一切众生。是谁所作。是谁所化。是谁所加。是谁力生。佛言。梵天。所有世界是业所作。是业所化。一切众生。是业所作。是业所化。业力所生。何以故。梵天。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。故有如是大苦聚集。梵天。无明灭乃至忧悲苦恼灭。更无作者使作者安置者。唯有业有法。和合因缘故有众生。若能离此业法和合。当知是人则能远离生死流转。梵天。如是世间业尽。烦恼尽苦尽苦息。如是出离。是名得于寂定涅槃。梵天。于彼谁得涅槃。若业是业尽。若烦恼是烦恼离。若苦是苦息。如是等法。以诸佛神力故。诸佛所加故有。何以故。梵天。若非诸佛出世显说。则不闻有如是等法。梵天。若诸佛世尊出兴世时。得有显说如是寂定甚深难觉光明法门。若诸众生得闻生法。从生得解脱。得闻老病死忧悲苦恼法。从彼老病死忧悲苦恼法而得解脱。梵天。是故诸佛现作是加。梵天。诸佛作是开示显说。所谓诸行犹如光影。无常动转不定不究竟。尽法变易法。假使诸佛灭度之后正法隐没。亦复如是。示现所加。所谓诸行犹如光影。若佛不现。一切诸行于刹那顷如光影者。则不应说一切诸行犹如光影如梦如响。梵天。诸佛以知一切诸行犹如光影如梦如响。无常动转尽法变易法故。说言诸行犹如光影如梦如响。智者于彼观其相已。以其相以其攀缘因缘义故。得知诸行无常动转尽法变易法。破坏离散时节代谢。于刹那顷乃至日夜半月。乃至一月一岁乃至百岁。一劫乃至百劫一切尽坏。有大火聚然已还灭。有大水聚流已还止。有大猛风吹已还息。世界大地有已还无。有诸大山所谓铁围山大铁围山。须弥山及诸黑山等有已还无。日月星宿及诸眷属有已还无。不明不照而复堕落。诸天宫殿有已还灭。诸有王都城邑聚落树林园池可乐之事生已还灭。诸天人等生已还灭灭已复生。诸有智者见其相已心生厌离。以此诸行无常离坏变易尽故。以平等信心舍家出家。得知诸行犹如光影如梦如响。及见水中日月星宿等诸光影已。以彼相以彼攀缘因缘义故得到菩提。有诸智士蒙佛教敕及善友教授。或自思惟得知诸行犹如光影如梦如响。生于信心舍家出家。或有得证须陀洹果斯陀含果阿那含果阿罗汉果。若大乘人或得初忍或得第二第三忍。及能得到无上菩提。假使诸佛灭度之后。于世间中亦复如是说法流行。若诸众生得闻法已。于三乘得度。所谓声闻辟支佛乘。一切种智无上大乘。梵天。汝应当知此法次第。亦是诸佛之所加也。是故智者见其相已心生厌离。能知诸行是无常苦动转不定尽法变易法。犹如光影如梦如响。梵天。此等亦是诸佛境界诸佛所加。有诸众生已曾修行因成就者。得闻如是正法声已。于如来所思念敬信。一切诸行无常坏灭。犹如光影如梦如响。有诸众生于诸佛所曾修梵行者。或有在家受禁戒者。以是因缘解知如是一切诸行无常坏灭。犹如光影如梦如响。知已生信舍家出家。诸佛世尊虽未出世。以有如是诸佛加故。以诸佛所种善根故。得到菩提。梵天。应如是知。此等皆是诸佛境界诸佛所加。梵天。此三千大千世界非梵刹土。亦非外道六师刹土。唯是我等诸佛刹土。梵天。我昔于此无量百千亿那由他阿僧祇劫修菩萨行。无量阿僧祇诸如来所种无量阿僧祇善根。净持禁戒苦修梵行。及修无量百千亿那由他难行苦行。摄此佛土修治令净。如诸众生所修善根。随其所堪而清净者随其时器应得度者。我于长夜以四摄事摄此众生。所谓布施爱语利行同事。彼等以我誓愿力故。生此佛土闻我说法即能信解。不复归信梵释护世诸天王等。梵天。应如是知。此是佛土。非是梵释护世刹土。亦非外道六师刹土

尔时娑婆世界主。大梵天王及百千梵众。现忧愁相作如是言。诸佛世尊通达希有胜妙之法。是三千大千世界主大梵天王。于如来所生希有心。诸佛希有乃有无量不可思议无尽境界。大梵天王即时归依为佛弟子。于世尊所请求教敕作如是言。婆伽婆是我大师。修伽陀是我大师。唯愿世尊。教敕于我。云何而住云。何修行。佛告梵天。此三千大千世界是我佛土。我今以此付嘱于汝。汝当顺我勿使真道善眼令有断绝。无上佛眼法眼僧眼令有断绝。莫作末后灭法人也。梵天。当有长子童真弥勒菩萨摩诃萨。从佛口生从法化生。大悲怜愍为欲利益一切众生。欲令得乐欲令安隐。彼亦于此三千大千世界如法补处。如我居此等无有异。汝既现在随顺我教。亦应顺彼勿令如是真道法母佛眼法眼僧眼而有断绝。何以故。梵天。乃至如是法母不断者。随其时节佛眼法眼僧眼得不断绝。释梵天眼人眼解脱眼乃至涅槃眼得不断绝。梵天。是故我今付嘱于汝我此佛土三千大千世界。梵天。我已教敕汝应随顺。莫作末后灭法人也。尔时三千大千世界所有梵天大梵天。彼等一切先于圣法已得正信。彼三千大千世界主大梵天王。即时于圣法中深得正信

    大悲经商主品第二

尔时有魔子名曰商主。已于佛所深得敬信。闻佛涅槃心怀忧恼战悚毛竖。速诣佛所到已顶礼。退住一面而白佛言。唯愿世尊。怜愍众生安乐众生救护世间。怜愍利益诸天人故。住世一劫莫入涅槃。我亦怜愍诸天人故如是劝请。世尊。勿使众生盲冥太速无有说者无导无救无依无趣。尔时商主作是语已。佛即告言。商主。汝父波旬。先已请我令入涅槃作如是言。婆伽婆。入般涅槃。修伽陀。入般涅槃。婆伽婆。今者正是入涅槃时。商主。汝父波旬如是请我。我随彼意许入涅槃。商主。以是因缘。我今时至称其所许故入涅槃。商主复言。世尊。是魔波旬非是我父非我善友。常求杀害是我怨家大恶知识。常欲令我不。得乐事和合安隐。但作毁坏不欲利益世尊。是魔于我极欲作恶。毁谤天人作大怨仇。常于如是慧炬慧光大智明灯求欲灭之。世尊。若有正实语人作如是言。诸天人中有一极毒恶人出于世者。当知即是魔波旬也。世尊。若有正实语人作如是言。有人不为益己身故。不益他故不益多众生故而发心者。当知即是魔波旬也。世尊。若复有正实语人作如是言。有人不为怜愍利益天人魔梵阿修罗沙门婆罗门一切世间故。又不欲令和合安隐故。欲令退落受苦恼故而发心者。当知即是魔波旬也。世尊。我亲从佛闻如是说。有二种人。一者如法。二者非法。当知世尊所许波旬入涅槃者。是不如法。唯愿世尊。于此所许莫生坚着。但为怜愍利益安乐诸天人等一切众生。舍此所许住世一劫。若佛久住诸天人等利益安乐。是故世尊莫速涅槃。佛告商主。善哉善哉。若令众生得利益者正应如是。商主。若人供给灌顶登位刹利大王。或有供给王子大臣。或有防护国土城邑聚落等者。是人从其刹利王所。得大荣爵受于福禄。其刹利王常于此人及其子孙亲友眷属。亦宠福禄拥护荫覆。商主。汝今若于如来应供正遍知无上法王所心生净信。以净信故。如来则当慰喻于汝与汝福报。我今慰喻汝者。以汝佛所心生净信种善根故。如是应知商主。汝当以此净信善根。于我灭后未来世中作辟支佛。名曰悲愍商主。我涅槃后正法灭已。是魔波旬得大喜悦。以喜悦故坠落魔宫。堕于阿鼻大地狱中。具受无量种种苦恼。何以故。以魔波旬于是大胜慧灯慧光隐灭之时生大喜故。商主。若有正实语人作如是言。有人为自害故。为自坏故。与己作恶故而发心者。当知即是魔波旬也。何以故。商主。我灭度后乃至有是正法住世。随其时节是魔波旬得住魔宫。我法灭已是魔极大喜踊欣庆得大称意。于刹那顷坠落魔宫堕阿鼻地狱。商主。譬如有人上于大树。其树花果悉以具足。是人取其称意花果。既受用已还复折其所住之枝。商主。于意云何。是人尔时住彼折枝得住树不。又于其树受安乐已还折其枝。可名有智不。商主言。不也婆伽婆。不也修伽陀。佛言。商主。魔亦如是。常希如来应供正遍知入涅槃故。常乐隐灭如来所说正法毗尼故。商主乃至正法住世。是魔波旬于其时节得住魔宫。我法灭时其魔波旬生大踊悦喜庆称意。故坠落魔宫堕阿鼻地狱。商主。喻如彼人于其树上而自害故勤作是事。魔亦如是。为自害故。为害他故。而勤发心。商主。魔于后时堕阿鼻地狱受大苦痛。如夺命苦。为苦触已。当念我言如来应供正遍知。是真语者。实语者。不异语者。不虚语者。如是善说。善哉身律仪。善哉口律仪。善哉意律仪。是身善行。是口善行。是意善行。获得可乐可欲可爱称意果报。是身恶行。是口恶行。是意恶行。获得不可乐不可欲不可爱不称意果报。我昔与彼身恶行相应口恶行相应意恶行相应。以是业报今堕地狱。受如是等极痛极切极苦极恼。极不可忍如临死之苦。是魔波旬当于尔时。忆我所说得净信心。得净信已即时于彼地狱命终生三十三天。何以故。商主。若其恶心于如来所作诸过失。身坏命终堕大地狱。若复慈心供养如来不求过者。身坏命终得生善道天人之中。彼以善根得值诸佛。值诸佛已复种善根。种善根已次第当得无漏涅槃。商主。汝于如来应供正遍知心得净信。以此善根弥勒出世当得值遇。值弥勒已则能觉悟睡眠放逸诸众生等。作如是言。诸众生辈应当勇猛勤作善业。如来应供正遍知出世甚难。如忧昙华时乃一现。如来亦尔时乃一出。无窟宅涅槃。时有说者人身难得八难难离。得值佛世生于中国亦复甚难。是故汝等慎莫放逸。当勤修行于后莫悔。商主。汝于弥勒佛所禀受法教。摄彼弥勒无上法王国土人民。常以慈心无恶心无怨仇心愍心乐心普覆心护持养育。以此善根于魔宫殿次补魔处。具大富贵为自在主。商主。若有众生于如来所种诸善根。乃至得发一念净心。彼等众生以此善根得近甘露。第一甘露最后甘露。商主。汝以善根于彼广受人天报已。经八十劫于末后身作辟支佛名曰悲愍。何以故。商主。以汝闻我涅槃声已。便于我所生净信心。于众生所生悲愍心。为诸众生得安乐故。求请我住不般涅槃。汝复于彼弥勒法中悲愍众生。觉悟睡眠放逸众生。令得忆念而不放逸。教以善法。以是因缘得辟支佛记。商主。我当与汝如是善报。应当深心喜悦称意。商主。此等是汝劝请如来善根因缘。如来即以法施荫覆报汝善根。尔时商主复白佛言。世尊。若佛不受我所劝请入涅槃者。愿我从今乃至法住。离于五欲专持孝道。不乐游戏不着异衣。不用华鬘涂香末香。及不受用诸天胜报。何以故。如是世尊众生之宝明。当与我别离异处。更不合会。更不复有。毕竟不可见。世尊。我有何乐有何戏笑。有何可乐。有何称意。如是最大慧炬慧灯大智光明。若隐灭者我当有何踊悦称意喜庆等事。是大智日有无量百千光炎眷属。灭除无明大黑闇者。作大智明者。如是灭没。我当有何踊悦称意。有何可乐。有何戏笑。我于如是众生之宝有别离故。测量众生不缺减众生。与明众生无罪众生。无痴众生。无上众生。最上众生。无似众生。无等众生。无等等众生。能救一切众生。众生妙众生。众生所供众生。共乘众生。调伏众生者。怜愍众生者。真语者。实语者。时语者。应时语者。不异语者。如说修行者。住大慈悲者。于诸众生心无挂碍者。于诸众生平等心者。无戏论者。无我我所者。无积聚者。无窟宅者。无依倚者。无荒崄者。无垢者。救济者。引导者。化度者。预备者。解缚者。养育者。令众生忆念者。令惺悟者。教诲者。于战斗胜者。拔镞者。医王治心者。施大良药者。究竟度苦者。说法者。商主将去者。示浅处者。持梢尾者。持炬者。作明者。作光者。照曜者。施目者。示导者。令到安隐国土者。远离一切荒崄垢者。无渴爱者。离诸使者。离诸结者。离贪嗔痴者。离诸烦恼者。离憍慢怒者。如是大丈夫。妙丈夫。极丈夫。健丈夫。猛丈夫。莲华丈夫。芬陀利丈夫。龙丈夫。师龙丈夫。师子丈夫。上首丈夫。凶丈夫。雄丈夫。象丈夫。无上丈夫。无上调御丈夫。共乘者。具一切力者。具十力者。得四无所畏者。具十八不共法者。得大福智力者。满足无量法藏者。无嫉妒者。悦豫一切众生者。无上大施主最胜施主。心无嫌恨者。得大禅定者。得诸禅三昧三摩跋提境界者。无量慧者。无障慧者。得无等慧境界者。摧魔幢者。渡淤泥者。到彼岸者。住彼岸者。到无畏处者。除一切众生怖畏者。安慰一切众生者。大众生坚固者。于今后夜当有别离更不可见。世尊。如来常于诸大众中。正师子吼更不得闻。我当有何踊悦称意。世尊。譬如有人于其灌顶刹利王所得福禄者。王命终后生大忧苦。知王恩养。念王恩养。赏王恩养。彼诸众生为其王故专持孝道。或一日二日乃至七日。若半月乃至一月忆念流泪。世尊。我亦如是。如来灭后乃至正法住世。随其时节舍离五欲专持孝道。不乐戏笑。不着异衣。不用华鬘涂香末香。及不受用诸天果报

    大悲经帝释品第三

尔时释提桓因往诣佛所。到已顶礼退住一面而白佛言。唯愿世尊。教敕于我云何修行。世尊。昔于一时。四大阿修罗王。严驾着铠将诸眷属。来诣三十三天所欲共斗战。当于尔时圣者目连仍住在世。如是诸天共阿修罗对阵之时。圣者目连到四阿修罗所。以如法伏之。如是诸天及诸阿修罗悉得安隐。无复斗战之苦共相违反毁呰诤论。世尊。是大目连既已灭度。如来今复欲般涅槃。我等如是于后数数当复斗战共相违反。愿垂教敕。若四阿修罗王与我战时。我于彼等作何方计。佛告释提桓因言。憍尸迦。止。莫忧悲莫愁莫虑。若持戒者所愿必成。唯净戒者成。非不净戒。梵行者非不梵行。离欲者非不离欲。离嗔者非不离嗔。离痴者非不离痴。智慧者。非不智慧。而得成也。憍尸迦。我从今后当作加被。憍尸迦。乃至我之正法未灭。若有诸天阿修罗等共相斗战。随其时节称我名故诸天得胜。尔时四大阿修罗王。闻佛说是加护声已。其心忿恨毛竖怖畏来诣佛所。到已顶礼却住一面白佛言。世尊。何故如来作是加护。佛告四大阿修罗言。汝等。莫忧莫虑。有时汝等得大自在。过彼三十三天。无复斗战。无诤无竞无相违反。是故汝等。慎莫斗战。莫相毁呰莫相诤论。勿作违反心。当作慈心愍心。得众欲具足。诸仁者。命不久停。为自在主亦复无常。诸仁者。世间所有具足合会必归离散。诸仁者。当观如来穷无常际。于诸众生无所怨仇。无违无竞常为和合。一切众生平等发心。何况汝等薄少善根。彼此迭相乐斗诤者。诸仁者。若有发心恼害他者。是人长夜还得恼害。诸仁者。若人喜杀。是人还得短寿之报。若喜斗诤。是人常有怖畏死报。不具大眷属。无大势力。诸仁者。善恶二业终不败亡。是故汝等。从今已后各住慈心。住身业慈口业慈意业慈。莫斗莫竞莫相毁呰。以是因缘。汝等长夜得利益安乐。后则不悔。作是语已。四阿修罗王白佛言。世尊。如是婆伽婆。如是修伽陀。我等如是依如来教。如是修如是住。世尊。我从今后。一切当舍斗战之具各修慈心。尔时释提桓因。闻佛涅槃为忧箭所射极大愁恼。悲泣流泪而白佛言。世尊。我从今日乃至法住。不受五欲。不入内宫。不着异衣。大德婆伽婆。譬如家长丧亡。是人知识得恩养者。心生苦恼忆念旧恩。念恩养故悲泣流泪专持孝道。世尊。我亦如是乃至法住。随其时节悲泣流泪专持孝道。不行五欲。不入内宫。不着异衣。何以故。无上导师明当别离。不可得见更不合会。释提桓因作是语已。即便伏面啼哭而住

大悲经卷第一大悲经卷第二

        高齐天竺三藏那连提 那舍译

    罗睺罗品第四

尔时大德罗睺罗作如是念。我今有何喜悦。有何称意。有何欣庆。而能堪忍面见世尊入般涅槃。作是念已。东北方去此十佛国土。彼有世界名摩离支。佛号难胜如来应正遍知。尔时慧命罗睺罗。从拘尸城力士生地没。向东北方难胜如来应正遍知所。到已稽首作礼却住一面忧愁不乐。尔时难胜如来告罗睺罗言。罗睺罗。汝莫忧悲。罗睺罗。一切所爱称意等事。有为和合必皆离散。罗睺罗。凡是事法尔。诸佛世尊作佛事讫皆般涅槃。罗睺罗。汝可还彼。今释迦牟尼如来应正遍知。力士生地娑罗双树间。如师子王右胁而卧。今日后夜于无余涅槃界而般涅槃。罗睺罗。汝必须往。若佛如来入涅槃后汝必忧悔。作是语已。时罗睺罗白难胜佛言。世尊。我不忍闻释迦牟尼如来应正遍知入涅槃声。况能忍见彼佛世尊入般涅槃。是故我不堪忍往彼。尔时罗睺罗答彼难胜佛已。即于彼没。往诣上方过九十九世界到第百世界。彼有如来应正遍知。号曰商主。今现在世。尔时罗睺罗到已。头面作礼悲泣流泪。忧愁啼哭却住一面。住一面已。时商主佛告罗睺罗言。止。罗睺罗。汝莫忧悲。罗睺罗。一切诸法。生者不生。老者不老。病者不病。死者不死。尽者不尽。无有是处。罗睺罗。过去诸佛声闻缘觉。寂灭离而般涅槃。未来诸佛声闻缘觉。寂灭离而般涅槃。现在诸佛声闻缘觉。寂灭离而般涅槃。罗睺罗。假使如来住世一劫若百劫。必当如是入般涅槃。罗睺罗。诸佛世尊更无余法。唯是究竟寂灭涅槃。罗睺罗。究竟寂灭者。是究竟定。究竟清凉。究竟尽。究竟乐。究竟安隐。所谓无窟宅涅槃界。罗睺罗。生苦老苦病苦死苦。恩爱别离怨憎合会。所求不得五阴重担。如是皆苦。罗睺罗。唯涅槃是乐。罗睺罗。汝亦不久当般涅槃。罗睺罗。汝及释迦牟尼佛入涅槃处。无生无老无病无死。无爱别离。无怨憎会。无不适意。罗睺罗。汝莫悲恋莫忧莫愁。罗睺罗。汝当思惟。谁是生者。谁是老者。谁是死者。谁是流转。谁复还生。罗睺罗。皆是虚妄颠倒取着。未闻圣法。诸凡夫等。未见诸圣。未信圣法。未学圣法。未解圣法。未知圣法。未住圣法故心颠倒想颠倒见颠倒。以颠倒故生。生故老。老故死。死已还生。驰走流转枯焦败坏。爱恋忧愁椎胸号哭。罗睺罗。一切圣人唯以此法毗尼息一切行。于上更无所作。罗睺罗。如是导师所作已讫。声闻弟子所作者已作。于上更无所作。罗睺罗。汝莫悲恋莫忧莫愁。罗睺罗。彼释迦牟尼佛。无上法王于释种中尊。汝当往彼最后礼拜供养恭敬。若涅槃后汝必忧悔。罗睺罗。彼释迦牟尼佛。今在力士生地娑罗林间。如师子王右胁而卧。思欲见汝罗睺罗。汝必须往。作是语已。慧命罗睺罗白商主佛言。世尊。我不忍闻释迦牟尼如来应正遍知入涅槃声。况能忍见彼佛世尊入般涅槃。作是语已。身心闷绝不自胜持。复作是言。而彼世尊释迦牟尼。于释种中尊。无上法王。众生中宝。我今何能忍见彼佛入般涅槃。怜愍一切世间者。一切世间形相无与等者。与一切世间作灯者。与一切世间作眼目者。与一切世间作慧炬者。照曜一切世间者。明日离散当无所有。作是语已。时商主如来告罗睺罗言。止。罗睺罗。汝莫忧悲。罗睺罗。汝可不闻彼佛世尊说如是法。一切行无常。一切行苦。一切法无我。寂灭涅槃。罗睺罗。彼佛世尊说如是偈

  诸行无常　　是生灭法
  生已还灭　　灭彼为乐

罗睺罗言。如是世尊。佛告罗睺罗。彼佛世尊昔可不作如是说也。一切所爱称意等事。必归磨灭不久离散。假使久住会亦有离。罗睺罗言。如是婆伽婆。如是修伽陀佛言。罗睺罗。有为诸法生法有法。觉知法分别起法。从因缘生。若不灭者。无有是处

尔时罗睺罗。忆念己父释迦牟尼如来应正遍知已。流泪而言。我于明日更不见佛诸比丘众围绕说法。如大海中须弥山王。众相庄严起光明照。犹如满月众星围绕。如日千光处空照曜。如深大海无量众宝所藏积处。如转轮王无量眷属而共围绕。如雪山王根力觉花之所开敷。如铁围山一切恶风所不能动。如是世尊。一切外道诸论议风不能倾动。犹如莲花处在池中。不为世法之所能染。犹如大梵具梵眷属。犹如帝释有千眼目。如师子王坐师子座无所恐惧。离诸怖畏能师子吼。我于明日更不得见。时罗睺罗作是语已。默然悲泣思惟而住。尔时商主如来告罗睺罗言。汝今速可诣彼佛所。彼佛如来思欲见汝。罗睺罗。汝当速去莫更重问致有稽留。慎莫劳扰彼佛世尊。罗睺罗。汝必须往。何以故。罗睺罗。诸佛法尔。佛以慈悲思欲见汝。不入涅槃。尔时罗睺罗头面礼彼商主佛已。譬如壮士屈伸臂顷。复如伸臂屈顷时。罗睺罗即于彼没。诣拘尸城力士生地娑罗双树间。到如来所亦复如是。到已头面礼足右绕三匝却住一面。忧愁悲泣合掌流泪。尔时世尊告罗睺罗言。罗睺罗。汝莫悲恋忧愁啼哭心生热恼。罗睺罗。汝于父所作父事讫。我亦汝所作子事讫。罗睺罗。汝莫生恋忧愁悲悔。罗睺罗。我与汝等俱为一切众生。得无畏故发勤精进。不作怨仇不作恼害故发大精进。罗睺罗。我今般涅槃已。更不与他作父。罗睺罗。汝亦当般涅槃。更不与他作子。罗睺罗。我与汝等二俱。不作恼乱不作怨仇。尔时罗睺罗白佛言。世尊。婆伽婆莫般涅槃。修伽陀莫般涅槃。唯愿世尊。住世一劫。为于多众安隐乐故。怜愍世间故。利益安乐诸天人故。作是语已。佛告罗睺罗言。罗睺罗。如来应正遍知尽知诸法。于世间中得名为佛。罗睺罗。然彼佛法。不消不尽。不生不灭。不来不去。不成不坏。不坐不卧。不合不散。何以故。罗睺罗。如是法住。毕竟不生毕竟不灭。毕竟空毕竟无自性。寂定涅槃不入众数无窟宅。不可说非语言道。此是诸佛法。所谓毕竟住故。毕竟灭故。毕竟寂灭故。毕竟离故。毕竟离欲故。毕竟不和合故。毕竟不作故。毕竟尽故。罗睺罗。我随宜说此法。假使诸佛若出世若不出世。如是诸法住。诸法如法尔故。法不变易故。法离欲故。法无自性故。罗睺罗。如是如来不将戒聚入般涅槃。不将定聚慧聚解脱聚解脱知见聚入般涅槃。罗睺罗。汝莫悲恋莫忧莫愁。罗睺罗。一切诸行无常无定。无所悕望。无常尽变易法。罗睺罗。乃至息一切行厌舍不着唯求解脱。罗睺罗。此是我之教法。佛为罗睺罗说此见实谛品时。大德比丘六十人。皆尽诸漏心得解脱。二十五比丘尼。亦心解脱得尽诸漏。无量天人远尘离垢得法眼净。六万八千诸菩萨得无生法忍。一切皆悉欢喜踊跃。叹言佛法不可思议。彼等皆悉以优波罗花波头摩花。拘牟头花芬陀利花。而散佛上各作是言。我于来世亦当如是作天人师出兴于世。说如是法世间无上无相涅槃。如是以大涅槃而般涅槃。彼诸菩萨作是语已。默然而住

    大悲经迦叶品第五

尔时阿难。在佛床边悲啼流泪闷绝躄地。犹如临崖斫断大树。作如是言。婆伽婆涅槃太速修伽陀涅槃太速。众生中宝大慈悲者隐没太速。世间大灯世间大炬天人中最隐没太速。众生芬陀利于世间中隐没太速。众生龙象善自调者。复调众生未调者令调隐没太速。无上导师能示世间安隐道者隐没太速。世间慧眼大光普照能示世间隐没太速。世间盲冥无引导者。众生父母于世间中隐没太速。世间孤独无所恃怙。众生中宝。云何明日我更不见。唯有名在。尔时世尊告阿难言。止。阿难。莫忧悲。我曾告汝一切所爱称意等事。和合之法必有离散。阿难。有为诸法生法有法觉知法因缘法灭坏法。若不坏者。无有是处。彼若得住。亦无是处。阿难。假使久住法当如是必亦有离。是故阿难汝莫忧悲。尔时阿难。瞻仰尊颜目不暂舍思惟是已。亦复躄地。犹如临崖斫断大树。佛复告言。阿难。止。莫忧悲。不以忧悲令我住世。阿难。我曾告汝一切所爱称意等事。有为和合必当别离。假使久住会亦当灭诸行法尔。阿难。汝以身口慈孝如来。无量安乐心无有二。无嗔无恨无有怨仇。尔时阿难。从地而起抆泪而言。世尊。我何得不愁。何得不悲。我与如是大慈悲者。出一切世间者。怜愍一切世间者。一切世间所爱惜者。一切世间所归趣者。导引一切世间者。利益一切世间者。安乐一切世间者。如是大宝众生明当别难。尔时阿难。大号哭已抆泪而言。奇哉奇哉。诸行是尸而作欺陵。能令如是大灯大炬。大日光明无量光炎。百千亿那由他炎幢眷属。普现世间见知念慧境界。普照大宝众生隐没太速。大智慧者。大光明者。今于世间隐没太速。世间孤独。作覆护者隐没太速。如来具足神通变化。今于世间隐没太速。世尊。我何得不愁。何得不悲。世尊。我今自怪心不破裂以为百分。世尊。我亦自怪不于佛前而取命终。必是世尊神力加我。以是义故不取命终。何以故。我于佛所亲承面受。八万四千诸法宝藏受持不忘。未广流布在于十方诸天人故。世尊。我为如来神力所加以是义故我不命终。世尊。我何得不愁。何得不悲。世尊。我到迦毗罗城世尊生处。释种集时作何等语。可言日种释迦牟尼佛释种中尊。无上法王般涅槃耶。我到王舍城毗提希子阿阇世王所。作何等语。可言大师佛日隐没。能拔世间无间业箭医王去耶。我到舍婆提城。作何等语。可言大悲怜愍世间者隐没去耶。我到只陀林给孤独长者。而问我言。如来何时来住只陀林给孤独园。作何言答。我到毗舍离城诸离车子前。当作何言。可言怜愍世间最大尊师隐没去耶。诸方所有善男子善女人来问义者。作何言答。可言是大智人世间智者。断一切疑者。隐没去耶。诸方所有诸比丘众。为欲见佛供养礼拜。问讯世尊为布萨故。来问法者。来问义者。我更不见不闻彼说得上人法。世尊灭后有如是等神通变化修梵行者隐没于世。我何得不愁。何得不悲。作是语已。佛告阿难言。阿难。止。汝莫忧愁。我之梵行当广流布。久住世间利益天人。阿难。我灭度后过四百年。迦叶共汝及诸弟子。展转相承作神通变化。修行梵行利益天人。阿难。汝莫忧悲。我之正法当广流布。久住世间利益天人。阿难。我涅槃后。迦叶比丘共汝发心。令我阿僧祇亿那由他劫所集。无上三藐三菩提法。增益诸善使不退失。何以故。阿难。是迦叶比丘。少欲知足远离精进。乐不忘念乐不戏论定慧现前。阿难。迦叶比丘。能于大众示教利喜。于诸梵行说法不惓犹如父母。阿难。迦叶比丘。于诸四众所见悬远怜愍世间。为欲利益安乐众生诸天人故。发如是心。尔时阿难白佛言。世尊。迦叶比丘。如是发心。利益安乐几许诸天人众。佛言。阿难。迦叶比丘。入涅槃时作是誓愿。愿我灭后以我神力所加持故。令我身衣不变不坏。发毛肤色诸根支节亦不变坏。乃至弥勒如来应正遍知出兴世时。令我此身见彼世尊。共作初会。如是第二第三大会。以我愿力所加持故。当令多百众生。多千众生。多千万众生。多百千亿那由他众生。得圣道果。若弥勒佛见我身衣不变。不坏。三会声闻亦见我身不变不坏诸根支节及袈裟已。然后我身住在空中。以己身火阇维其身。阇维身已灰炭不现。阿难。是为迦叶发心利益安乐众生。阿难。迦叶比丘。如是愿力所加持故。成熟如是诸众生已而般涅槃。阿难。迦叶比丘。般涅槃已有四石山当来到迦叶所。覆障其身合成为一。阿难。是迦叶身在彼四石山中身不变坏。至弥勒佛出兴于世随尔许时。迦叶比丘身住不坏。及袈裟衣亦住不坏。何以故。阿难。持净戒者。修梵行者。有智慧者。所愿能成。非戒不净不修梵行无智有欲所能成也。阿难。迦叶比丘。先以愿力所加持故入般涅槃。入涅槃已。彼迦叶身常不变坏。发毛血肉诸根支节。及以衣服亦不变坏。身亦不臭。乃至弥勒。阿难。彼弥勒佛出兴世时。共彼初会九十六亿诸比丘众到迦叶所。阿难。是弥勒佛。以迦叶身示彼九十六亿诸比丘众。作如是言。诸比丘。此迦叶比丘。于释迦牟尼如来法中。作大声闻住胜头陀。少欲知足远离精进。乐不妄念乐不戏论定慧现前。能于多众示教利喜。于诸梵行说法不倦犹如父母。诸比丘。是迦叶比丘。于诸四众所见悬远。毕竟无疑随顺多众。诸比丘。汝观迦叶怜愍世间。为欲利益安乐一切诸人天故发如是心。阿难。弥勒如来应正遍知。第二会时共九十四亿诸声闻众来到其所。第三会时共九十二亿诸声闻众亦来到迦叶所。阿难。彼弥勒佛。示彼九十二亿比丘众言。此迦叶比丘。于释迦牟尼如来法中。最大声闻住胜头陀。少欲知足乃至发心。为欲利益安乐一切诸天人故。阿难。弥勒如来当于彼时。舒金色右手摩迦叶顶。观察诸比丘言。诸比丘。是迦叶比丘。于释迦牟尼佛灭度之后广持正法。而此众中无有一人于我灭后广能如是持我正法如迦叶者。阿难。是迦叶比丘。于彼第三大会。以本愿力所加持故。住虚空中现种种神通种种变化已。以己身火阇维其身。阇维身已灰炭不现。时弥勒佛当于彼时发起迦叶已。为彼九十二亿诸比丘众数数说法。多百多千多亿那由他百千天人。得圣道果。阿难。迦叶比丘。发心利益多众生故。汝亦发心利益安乐多众生故。如是阿难。迦叶比丘及汝发心故。过四百年能持我之正法。及作神通种种变化修行梵行。各能增益诸天人众

    大悲经持正法品第六

尔时世尊复告阿难。汝莫忧悲。我之梵行当广流布。各能增益诸天人众。阿难。我灭度后摩偷罗城优楼蔓茶山。有僧伽蓝名那驰迦。于彼当有比丘名毗提奢。有大神通具大威力。正智得道多闻无畏。持修多罗。持毗尼。持摩多罗迦。于诸梵行示教利喜说法不倦。彼亦当作神通变化修行梵行。广行流布我之正法增益天人。阿难。汝莫忧悲。我灭度后还于优楼蔓茶山。那驰迦僧伽蓝。当有比丘名提知迦。有大神通具大威力。于诸梵行说法不倦。能令我法广行流布增益天人。阿难。汝莫忧悲。我灭度后还于优楼蔓茶山傍。有山名优尸罗。彼有四万比丘集会。有 神通有大威力多所堪能。正智得道多闻无畏。持修多罗。持毗尼。持摩多罗迦。各能于诸梵行示教利喜说法。不倦。彼等比丘神通变化修行梵行。令我正法广行流布。各能增益诸天人众。阿难。汝莫忧悲。我灭度后还于优楼蔓茶山傍。当有比丘名优波鞠多。有大神通具大威力。乃至亦能神通变化修行梵行。令我正法广行流布增益天人。于彼当有千阿罗汉。集八万八千诸比丘众。共一布萨作一羯磨。心不欺诈共相授记。彼等皆能神通变化修行梵行。令我正法广行流布。各能增益诸天人众。阿难。汝莫忧悲。是优波鞠多及诸弟子。各各能令我之正法广行流布。于诸天人能正显说。阿难。汝莫忧悲。我灭度后于波离弗城。有僧伽蓝名跋多尼。彼有比丘名阿轮婆鞠多。三明六通具八解脱。禅智二分解脱自在。有大神通具大威力。乃至彼等亦能神通变化修行梵行。令我正法广行流布增益天人。阿难。汝莫忧悲。我灭度后还于波离弗城。有僧伽蓝名鸠鸠吒。当有比丘名郁多罗。有大神通具大威力。乃至亦能神通变化修行梵行。广行流布我之正法增益天人。阿难。汝莫忧悲。我之梵行当广流布。各能增益诸天人众。阿难。我灭度后于鸯伽国。当有我诸声闻作般遮跋瑟伽会。彼处当有过一万三千阿罗汉集。彼等一切有大神通。具大威力有多堪能。乃至于诸梵行说法不倦。彼有上座名设陀沙茶。有大神通具大威力有多堪能。于诸梵行说法不倦。彼等亦能神通变化修行梵行。令我正法广行流布。各能增益诸天人众。阿难。汝莫忧悲。我灭度后金钵悉陀城。当有二比丘。于婆罗门种中出家。一名毗头罗。二名删阇耶。各有神通具大威力有多堪能。乃至亦能神通变化修行梵行。令我正法广行流布增益天人。阿难。汝莫忧悲。我灭度后婆鸡多城。当有比丘名大精进。有大神通具大威力。乃至亦能神通变化修行梵行。令我正法广行流布于诸天人。阿难。汝莫忧悲。我灭度后当有比丘名末田提。三明六通具八解脱。禅智二分解脱自在。有大神通具大威力。乃至于诸梵行说法不倦。北天竺国罽宾川中。当有无量诸龙夜叉乾闼婆等。具大身力依住彼川。是末田提比丘到于彼处。为彼诸龙夜叉乾闼婆等来共斗诤。是末田提比丘神通变化。以法降伏诸龙夜叉乾闼婆等令得敬信。得敬信已令人住在彼罽宾川。建立诸僧伽蓝多有声闻。多百多千声闻众集。阿难。是末田提比丘。于一切时令彼住处具诸善事。阿难。我若具足称扬广说彼末田提所有功德。不能穷尽。阿难。是末田提比丘。具诸功德能令我法毗尼神通梵行。于诸天人广行流布。阿难。汝莫忧悲。我灭度后于北天竺乾陀罗国。当有比丘名曰迦叶。有大神通具大威力有多堪能。正智得道多闻无畏。持修多罗。持毗尼。持摩多罗迦。乃至亦能令我正法广行流布。阿难。汝莫忧悲。我灭度后北天竺国。有城名得叉尸罗。彼有长者名阇知迦。名震诸方具大豪富。多饶财宝具足功德智慧相称。端正可爱相好第一。彼阇知迦长者。深信于我及诸声闻。供养恭敬尊重赞叹。次第积集菩提善根。于未来世满千劫已。成阿耨多罗三藐三菩提。佛号普光。劫名造贤。世界名具大庄严。阿难。彼阇知迦长者。于诸天人广行流布我之正法。阿难。汝莫忧悲。我灭度后北天竺国。当有王都名富迦罗跋帝。人民炽盛丰乐安隐。彼处多有诸婆罗门长者居士。随顺修多罗。深信于我及诸声闻。供养恭敬尊重赞叹。彼有无量声闻弟子。有大神通具大威力有多堪能。阿难。于彼多有长者居士。正智得道多闻无畏具大智慧。阿难。彼富迦罗跋帝王都。所有在家诸白衣等。彼命终已生兜率天。诸出家者悉堕地狱。何以故。彼不住戒不住律仪故。阿难。彼富迦罗跋帝王都。所有婆罗门长者居士等。当作是念。释迦牟尼佛之正法必当隐没。何以故。诸比丘等。于诸利养增上贪求。多毁禁戒其心散乱不乐闲林舍离禅乐。与诸四众数相往来破戒违道。共诸婆罗门长者居士等。亲友交通不相敬重。饮食花果迭相赠遗。不依律仪无有惭愧淫彼女妇。彼诸婆罗门长者居士等。见闻彼诸比丘作非法已。生大惊怖心甚忧恼作如是言。佛之正法可隐没耶。当于彼时还于富迦罗跋帝王都。当有优婆塞名曰法增。有大神通具大威力有大福德。正智得道多闻无畏。持修多罗摩多罗迦善巧方便。是优婆塞。为欲令彼婆罗门长者居士等生敬信故。上升虚空示教利喜而作是言。汝等诸人。慎莫怖畏莫疑莫虑。彼释迦牟尼佛之正法犹住在世。汝可发勤精进作诸善业。未得者令得。未证者令证。未达者令达。圣法今在宜可速求。时婆罗门长者居士等。心皆喜悦而行布施作诸功德。于我舍利装饰严持。及诸声闻勤作供养。听受读诵转为他说。受持禁戒勤修禅定。彼诸婆罗门长者居士等。为彼法增示教利喜。皆趣善道及涅槃道。阿难。彼优婆塞。亦能令我正法广行流布增益天人。如是阿难。于我灭后亦当多有俗人。于我法中深得敬信。曾于过去供养多百多千无量诸佛殖诸善根。于我舍利勤修庄严。及诸声闻供养恭敬尊重赞叹。阿难。彼等亦令我之正法。广行流布增益天人。阿难。我灭度后于未来世北天竺国。当有比丘名祁婆迦出兴于世。曾于过去无量百佛殖诸善根。供养恭敬深信具足安住大乘。为欲怜愍利益安乐诸众生故。发如是心多闻持菩萨藏。称扬大乘显发大乘。是比丘。见我舍利形像塔庙有破坏者装校修治。以金庄严竖立幢幡。宝盖铃网出微妙音。兴造如来无量形像及诸塔庙。其诸塔庙皆以半月师子庄严。能令诸天人众心生信乐。为欲满足菩提善根故。怜愍众生故。护持养育故。摄受我法故。为不敬信者令敬信增修故。亦令多众种善根故。作般遮跋瑟迦会。阿难。当于尔时多有比丘。不持禁戒多作非法。不乐闲林舍离禅乐。破戒违道共相言讼。贪惜积聚独占一房。与诸俗人互相往来舍离佛法。于诸梵行不生敬重形似沙门。当于尔时有少比丘。发勤精进远离愦闹。系念现前定慧一心。安住善法少欲知足乐修乞食。安住圣种多闻无畏。持修多罗。持毗尼。持摩多罗迦。当于尔时祁婆迦比丘。令诸比丘着袈裟者。其心柔软诸根无缺。具足深信第一敬重。于彼所有着袈裟者。起持戒想。作福田想。而行布施修诸善根。彼祁婆迦比丘。修集无量种种最胜菩提善根已。而取命终。生于西方过亿百千诸佛世界无量寿国。于彼佛所种诸善根。复经八十亿诸如来所修诸梵行。以此善根于未来世过九十九亿劫而成正觉。佛号无垢光。世界名一切功德庄严。阿难。彼祁婆迦比丘。令我正法于诸天人广行流布。阿难。汝莫忧悲。我之梵行当广流布天人信乐。阿难。我灭度后于未来世。当有边国名曰舍摩。彼有国王名曰大施。而于我法心生净信。于我舍利及诸声闻。勤修供养称扬赞叹。阿难。彼大施王。于舍摩国集我声闻诸比丘众尊重供养。于彼当有过三千阿罗汉。皆有神通功德威力。乃至于诸梵行说法不倦。阿难。彼等亦能令我正法于诸天人广行流布阿难。汝莫忧悲。我灭度后北天竺国。有城名兴渠末但那。彼得我舍利尊重供养。当以花鬘涂香末香音声伎乐幢幡宝盖衣服卧具众宝金银以用庄严。阿难。时彼精舍当有多人以信出家。受持禁戒修行善法。诸俗人等修行善法亦复无量。阿难。彼有持戒多闻有智。于我法中深得净信。于我声闻及我舍利。勤修装饰严治供养。于佛法僧供养加护。以此善根于天人中受福报已。有得阿耨多罗三藐三菩提者。有得缘觉乘者。有得声闻乘而涅槃者。阿难。彼以如是种种供养。当得如是神通威力。阿难。是等诸人开示演说。令我正法于诸人天广行流布。阿难。汝莫忧悲。我之正法当广流布增益天人。阿难。我之舍利及我形像遍阎浮提。何况人不见处。所谓天龙夜叉罗刹乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽鸠槃茶等。宫殿之中所造形像。阿难。汝莫忧悲。我法毗尼于诸天人当广流布

    大悲经舍利品第七

尔时世尊复告阿难。我灭度后。若有善男子善女人。若在家若出家。乃至供养我之舍利如芥子等。恭敬尊重谦下供养。我说是人以此善根一切皆当得涅槃果尽涅槃际。阿难。若我灭后。所有善男子善女人心生敬信。为我造立形像塔庙。阿难。应生深信慎莫疑惑。我说是人以此善根一切皆当得涅槃果尽涅槃际。阿难。且置现在供养我者。且置我灭度后供养如芥子等舍利者。且置为我造立形像及塔庙者。阿难。若有信心念佛功德。乃至一花散于空中。我说是人以此善根一切皆当得涅槃果尽涅槃际。阿难。若复有人见佛世尊神通威力。为供养故。乃至一花散于空中。犹能得涅槃果。何况亲承如来而供养者。及我灭后供养舍利者。阿难。诸佛境界不可思议。若复有人能供养者。所得福德亦不可思议。阿难。若人念佛乃至一花散于空中。我以佛智见知是人所得果报不可思议。汝应当信。何况未来所有佛子。深得敬信思惟佛功德求佛智者。尔时阿难闻佛语已。心怀踊跃生大欢喜而白佛言。希有婆伽婆。希有修伽陀。今正是时。唯愿世尊。说其念佛乃至一花散于空中而供养者所得果报。诸比丘等从佛所闻读诵受持。以是当得怜愍世间。利益安乐诸天人故。于现在世及未来世。所有众生从彼闻者。复得数数种诸善根。心生敬信得大称意。彼作是念。释迦牟尼。于释种中无上法王大慈悲者。怜愍世间者。劝喻我等令我生念发大精进。作是语已。佛告阿难。谛听谛听。善思念之。吾当为汝分别解说所得果报。阿难白言。如是世尊。愿乐欲闻。佛告阿难。若有众生。以念佛故。乃至一花散于空中。如是福德所得果报不可穷尽。阿难。如是众生从前际来。劫数长远生死流转不可得知。于未来际亦复如是。若有众生以至诚心念佛功德。乃至一花散于空中。于未来世当得释天王梵天王转轮圣王。于其福报亦不能尽。以其善根福报边际不可尽故。要当入般涅槃。何以故。阿难。施佛福田不以有为果报所能尽边。我说是人必得涅槃尽涅槃际。阿难。且置亲承供养我者。且置供养我如芥子等舍利者。且置为我造立形像及诸塔庙而供养者。且置以念佛故乃至一花散于空中而供养者。若复有人。在于室内以念佛故。乃至一花散于空中。阿难。我说是人当得涅槃。得第一涅槃。尽涅槃际。最胜涅槃。妙涅槃。清净涅槃。安住涅槃。阿难。以是因缘。诸福田中佛为最佛为王。何以故。施佛田者。非谓世间果报所能尽也。以是因缘。于佛福田为最第一。阿难。诸佛如来顺正道者。能作无上究竟福田。于佛福田所有施者。必穷尽涅槃际。得第一涅槃。阿难。且置如是以花散佛所得功德。若复有人但心念佛一生敬信。我说是人亦当得涅槃果尽涅槃际。阿难。且置人中念佛功德。若有畜生于佛世尊能生念者。我亦说其善根福报。当得涅槃尽涅槃际。阿难。汝今当观诸佛世尊。与诸众生作福田者。能令众生当得如是神通威力。是故阿难。汝莫忧悲。若有善男子善女人。乃至畜生诸众生等于佛生信。当得如是神通果报广大功德。譬如甘露第一甘露尽甘露际。阿难。汝以身口慈孝如来。无量安乐心无有二。无嗔无恨无有怨仇。阿难。若有三千大千世界满中须陀洹斯陀含阿那含阿罗汉。如甘蔗竹[竺-二+韋]若麻若草。若有善男子善女人。若一劫若减一劫。以诸称意一切乐具。恭敬尊重谦下供养。阿难。于意云何。是善男子善女人。所得福德宁为多不。阿难言。甚多婆伽婆。甚多修伽陀。佛言。阿难。若复有人。于诸佛所但一合掌一称名。如是福德比前福德。百分不及一。千分不及一。百千亿分不及一。数分不及一。迦罗分不及一。何以故。阿难。以佛如来诸福田中为最无上。是故施佛成大功德神通威力。阿难。且置三千大千世界所有声闻阿罗汉等。若复三千大千世界满中辟支佛。如甘蔗竹[竺-二+韋]若麻若草。若有善男子善女人。若一劫若减一劫。以诸称意一切乐具。恭敬尊重谦下供养彼辟支佛。若辟支佛灭度后起七宝塔。若有善男子善女人。乃至尽形以诸香花涂香末香衣服卧具宝幢幡盖。恭敬尊重谦下供养。阿难。于意云何。是人于彼所得福德宁为多不。阿难言。甚多婆伽婆。甚多修伽陀。佛言。阿难。若复有人。于如来所起一净信思惟信解。作如是言。诸佛智慧不可思议。以此信解善根功德。比前供养彼辟支佛所得功德。迦罗分不及一。乃至优婆尼沙陀分不及一。何以故。阿难。诸佛世尊。无量大慈。无量大悲。无量戒。无量定。无量慧。无量解脱。无量解脱知见。无量修集。无量达证。阿难。诸佛世尊智慧不可思议。诸佛境界亦不可思议。若有供养不可思议者。当得不可思议报。阿难。汝莫忧悲。汝当得大神通功德利益。何以故。阿难。汝以身口意慈。供养我来过二十年。受持如来八万四千诸法宝聚。于诸多闻最为第一。巧言辩慧问答中最。正智得道多闻无畏。持修多罗。持毗尼。持摩多罗迦。于诸四众说法不倦。阿难。我灭度后汝共大德摩诃迦叶。当作第一最大导师大作佛事。阿难。汝莫忧悲。汝当得大神通功德利益

大悲经卷第二大悲经卷第三

        高齐天竺三藏那连提耶舍译

    礼拜品第八

尔时世尊复告阿难。若有众生闻佛名者。我说是人毕定当得入般涅槃。阿难。若有称言南无佛者。此有何义。阿难白言。佛是一切诸法之本。佛是眼目能引导者。佛是演说一切法者。善哉世尊。愿为比丘解释此义。我今亲承得闻持受。尔时世尊复告阿难。谛听谛听善思念之。吾当为汝分别解说。尔时阿难闻佛语已。而白佛言。愿乐欲闻。佛言。阿难。所言南无佛者。此是决定诸佛世尊名号音声。阿难。以是决定诸佛名号音声义故。称言南无诸佛。阿难。我为是义故说譬喻。令诸众生于此法。中增益信心。复令一切诸善男子善女人。闻佛世尊名号音声深得敬信。阿难。曾于过去有大商主。将诸商人入于大海。到彼海已。其船卒为摩竭大鱼欲来吞噬。阿难。尔时商主及诸商人。心惊毛竖忧愁不乐。恐命不济。无救无护无归无趣。各皆悲泣呻号忧悔。种种悲叹呜呼痛哉。彼阎浮提如是可乐如是希有。世间人身如是难得。我今当与父母离别。兄弟姊妹妇儿亲戚朋友别离。我更不见。亦不得见佛法众僧。极大悲哭忧悲不乐。各皆祈请诸尊神天欲求自济。阿难。尔时商主正见明远。于佛法僧心得净信。更不信事诸余天神。尔时商主告诸商人。诸人当知。若欲存济免此危难得解脱者。汝等应当一时同声随我所说。假令我等不得解脱后生善道。时彼商人闻此语已。各言商主。我当从教。唯愿速说。阿难。尔时商主。偏袒右肩右膝着地住于船上一心念佛合掌礼拜。高声唱言。南无诸佛。得大无畏者。大慈悲者。怜愍一切众生者。如是三称。时诸商人亦复同时合掌礼拜。异口同音唱言。南无诸佛。能施无畏者。大慈悲者。怜愍一切众生者。如是三称。尔时彼摩竭鱼闻佛名号礼拜音声。生大爱敬得不杀心。时摩竭鱼闻即闭口。阿难。尔时商主及诸商人。皆悉安隐得免鱼难。船及商人所愿得称。安隐而还到阎浮提。时摩竭鱼闻佛音声心生喜乐。更不啖食余诸众生。因是命终。彼命终已得生人中。生人中已于其佛所闻法毗尼。深得净信舍家出家。得出家已近善知识。谦下供养得阿罗汉道。具足六通于无余涅槃界而般涅槃。阿难。汝观彼鱼生。生畜生道得闻佛名。闻佛名已得生人道。因生人道便得出家。得出家已。即便得证阿罗汉果得阿罗汉已便般涅槃。阿难。汝观诸佛神力。如是。彼鱼闻已获得神通。名号称誉毕定利益。何况有人得闻佛名听闻正法。亲于佛所种诸善根。而不毕定利益。阿难。如我昔说。作少善根得少分报。满分善根得满分报。阿难。所言少分善根者。是人为欲速成熟故。种声闻种子作声闻乘。以是善根得满声闻地种缘觉种子作缘觉乘。以是善根得满缘觉地。阿难。以是因缘我说少分行。阿难。言满分行者。是人从无始来。于诸佛所种佛种子。一切善根久远修行。以是善根因缘力故得值诸佛。值诸佛已为欲积集满足菩提诸善根故。满足菩提诸善根已得成佛道。所谓如来应供正遍知声震于世。是名满分行。阿难。此满分行。如我诸经昔已广说。如是次第汝应当知。若少分行得少分果。若满分行得满分果

阿难。如我经中亦复说言。乃至受持四句偈等。如是说者。我为钝根薄德少智诸众生故。随宜而说。阿难。我为一切无归众生为作归趣。无舍众生为作舍宅。无护众生为作救护。无明众生为作灯明。盲无目者为作眼目。阿难。一切外道痴冥无智不能自救。何能救他正作归趣。阿难。我为一切天人教师。怜愍一切诸众生者于当来世法欲灭时。当有比丘比丘尼于我法中得出家已。手牵儿臂而共游行。从酒家至酒家。于我法中作非梵行。彼等虽为以酒因缘。于此贤劫一切皆当得般涅槃。阿难。何故名为贤劫。阿难。此三千大千世界。劫欲成时尽为一水。时净居天。以天眼观见此世界唯一大水。见有千枚诸妙莲华。一一莲华各有千叶。金色金光大明普照。香气芬薰甚可爱乐。彼净居天因见此已。心生欢喜踊跃无量而赞叹言。奇哉奇哉。希有希有。如此劫中当有千佛出兴于世。以是因缘。遂名此劫号之为贤。阿难。我灭度后此贤劫中。当有九百九十六佛出兴于世。拘留孙如来为首。我为第四。次后弥勒当补我处。乃至最后卢遮如来。如是次第汝应当知。阿难于我法中但使性是沙门污沙门行。自称沙门形似沙门。当有被着袈裟衣者。于此贤劫弥勒为首。乃至最后卢遮如来。彼诸沙门如是佛所。于无余涅槃界次第当得入般涅槃。无有遗余。何以故。阿难。如是一切诸沙门中。乃至一称佛名一生信者。所作功德终不虚设。阿难。我以佛智测知法界非不测知。阿难。所有白业得白报。黑业得黑报。若有净心诸众生等。作是称言南无佛者。阿难。彼人以是善根必定涅槃得近涅槃。流注相续入涅槃际。何况值佛在世亲承恭敬。谦下迎送尊重供养。及佛灭后供养舍利者。阿难。彼沙门性污辱沙门。自谓沙门形似沙门者。乃至应有一称佛名。何况余心能生敬信种诸善根。阿难我为是义说如是偈

  诸佛如是不思议　　佛之正法亦复然
  若能敬信不思议　　必当获得不思报
  过去一切诸如来　　能作光明悲愍者
  亦曾供养大势佛　　悟胜菩提不可数
  我昔与檀常相应　　布施愍济诸众生
  净信根深勤精进　　以勤精进化一切
  爱重众生如父母　　兄弟亲戚诸知识
  于诸亲戚无嗔恨　　悟胜菩提不可数
  我求安乐菩提时　　于无量劫行布施
  悲心怜愍众生故　　舍身头目肌肉血
  亦舍无量重王位　　所爱妻妾及男女
  无量宝乘象马车　　为求最胜菩提故
  无量千万亿劫时　　数数精勤而驰走
  净心无量行布施　　为求此胜菩提故
  忍受无量众苦恼　　冰寒毒热及饥渴
  发勤精进死不舍　　为求最胜菩提故
  我若百年及一劫　　说其行相不可尽
  悲愍一切众生故　　为求安乐胜菩提
  轮回生死常值遇　　百千亿数诸如来
  彼诸如来大势力　　常以金花而奉献
  肴膳饮食及衣服　　涂香末香众花鬘
  多亿宝幢胜幡盖　　供养如是诸如来
  无量多亿诸众生　　轮回生死无有边
  我常到彼而安慰　　胜檀广益一切众
  尸罗羼提勤精进　　禅定三昧慧方便
  身等念处四正勤　　善修习行四神足
  亦修五根及五力　　七菩提分八圣道
  一切助道我修习　　悕求此胜菩提故
  我以正智修诸业　　无有一切诸不善
  常不放逸修诸行　　曾无一毫之过恶

    大悲经善根品第九

尔时世尊复告阿难。若有众生于诸佛所一发信心。如是善根终不败亡。何况复作诸余善根。阿难。我为众生知彼义故而作譬喻。诸有智者以喻得解。阿难。譬如有人析破一毛以为百分。取一分毛沾一渧水。持至我所而作是言。瞿昙。我以此水寄付瞿昙。莫令此水而有增减。亦复莫令风日飘曝干竭此水。不令鸟兽饮之令尽。勿使异水而有和杂。以器盛持莫置在地。如来尔时即受彼寄。受彼寄已置恒河中。不令入回。亦复不令余物揩突。如是水渧在大河中随流而去。使不入回复无遮碍。诸鸟兽等亦不饮尽。如是水渧不增不减一等如故。共大水聚渐入大海。若是水渧。毗岚风起坏世界时。假使是人住世一劫。我亦如是得住一劫。彼人尔时至劫尽时。而来我所作如是言。瞿昙。我本寄水。今有无耶。阿难。如来尔时知彼水渧在大海中见知住处。不与余水共相和杂。不增不减平等如故。持还彼人。阿难。如是如来应正遍知。有大神通有大威力。有多堪能清净大智。不可量智无碍知见。如是等事明了无障。于受寄人中最尊最胜。若于佛所寄付如是微细水渧。经于久远而不亏损。此义应知。阿难。细毛端者。喻心意识。恒河者。喻生死流。一渧水者。喻一发心微少善根。大海者。喻佛如来应正遍知。所寄人者。喻彼清信婆罗门长者居士等。住一劫者。喻佛如来受彼寄水终不亏损。亦如彼人寄彼水渧经于久远不亏一毫。如是阿难。若于佛所一发信心善根不失。何况诸余胜妙善根。我说是人一切悉是趣涅槃果。乃至尽涅槃际。阿难。设复有人于如来所。得一发心一生敬信。以余不善恶业障故。堕在地狱畜生饿鬼。以本造业自作自受。若大慈悲诸佛世尊出兴于世。以无障碍智。知此众生本作善根。以余不善恶业障故堕在地狱。佛知是已。从彼地狱拔之令出。安置岸上无所畏处。安置岸已。复令众生忆念往昔所作善事。而教之言。善男子。汝等应当忆念往昔所种善根。如是善根。在于某时某世界中。于某佛所修行种殖。彼诸人等。承佛威力即得忆念。得忆念已作如是言。如是婆伽婆。如是修伽陀。佛复告言。善男子。汝等昔于诸如来所种少善根。不亏不损于彼得利。所谓息一切苦得一切乐。善男子。汝得来此是佛境界。汝于长夜行非境界。从无始来生死流转。汝于佛所种少善根终不亏损。譬如王子若王大臣。设有余过闭在牢狱。说本事缘令其改悔放之令出。如是阿难。彼诸众生本于如来所种善根。设作余恶不善业故。若堕地狱畜生饿鬼诸恶道中。若大慈悲诸佛世尊出兴于世。本以发心善根因缘所加持者。佛皆见知于地狱中拔之令出。安置涅槃清凉岸上无所畏处。置无畏处已。令其忆念而教之言。善男子。汝当忆念。以本造作善根因缘得如是报彼。诸众生作如是言。如是婆伽婆。如是修伽陀。我等承佛威神加故。如是忆知

    大悲经布施福德品第十

尔时世尊复告阿难。汝应当知。如是等辈。作少善根终不虚设。乃至发心生一念信。我说是人皆得涅槃尽涅槃际。以是义故。故作譬喻。令诸清信男子女人深得净信。转复敬重生大爱乐欢喜踊跃。阿难。如捕鱼师。为得鱼故在大池水。安置钩饵令鱼吞食。鱼吞食已。虽在池中不久当出。何以故。如是等鱼为彼坚牢钩绳所中。虽复在水当知是鱼必在岸上。何以故。如是钩绳系岸树故。时捕鱼师来到其所。即知得鱼。便牵钩绳安置岸上随意所用。如是阿难。一切众生于诸佛所得生敬信。种诸善根修行布施。乃至发心得一念信虽复为余恶不善业之所覆障。堕在地狱畜生饿鬼及诸难处。若佛世尊出兴于世。以佛眼观见诸众生。行菩萨乘若缘觉乘若声闻乘。此诸众生种诸善根。此诸众生断诸善根。此诸众生堕在退分。此诸众生在胜进分。此诸众生种诸种子置贤圣地。于佛福田乃至发心。一生敬信修行布施。以此善根。诸佛世尊以佛眼观见此众生发心胜故。从于地狱拔之令出。既拔出已置涅槃岸。置涅槃已。令其忆念本于某佛种诸善根。彼忆念已作如是言。如是婆伽婆。如是修伽陀。佛言。善男子。汝等以此善根。得大果报得大利益。以于佛所修行布施种善根故。善男子。如是寄者终不亏损。假使久远乃至百千亿那由他劫。彼一善根必得涅槃尽涅槃际。阿难。所言鱼者。喻诸凡夫。池者。喻生死海。钩喻佛所殖一善根。绳喻四摄。捕鱼师者。喻佛如来。随意用鱼。喻诸如来安置众生于涅槃果。阿难。如是次第。汝应当知。若施佛田。假使久远终不败亡。终无穷尽无有边际。必当趣涅槃果。阿难。我今当复更作譬喻。若施佛田得第一涅槃尽涅槃际。阿难。若有众生贪世间报。行世间行爱乐世间悕求世间。于诸佛所修行布施。以此善根回向悕求人天善道。复有众生于诸佛所种诸善根。作如是言。以此善根愿我世世莫入涅槃。阿难。是等众生以此善根不入涅槃。无有是处。何以故。阿难如是诸佛无上福田。无诸荒秽亦无棘刺。离欲垢过极甚清净。如是田中种少善根福德种子。于余田中不生长者。于三种菩提能作种子。若无上菩提。若缘觉菩提。若声闻菩提。彼诸善根终不差失。以是布施心生敬信增上因缘。得趣善道及清净法必入涅槃。阿难。譬如长者营田之时。地不荒秽无诸荆棘及以瓦砾。粪坏肥良垦治调柔。以新种子盛以宝器不腐不败。依于时节下种田中。随时溉灌锄治料理。于一切时常善护持。阿难。若是长者营田之士。于余时中到彼田所。住在田畔作如是言。咄哉种子。汝莫作种莫生莫长。我不求利亦不求报。阿难。于意云何。可以田夫语故种子不生不作种也。阿难言。不也婆伽婆。不也修伽陀。彼必作果非无果实。佛言。如是如是。阿难。若有众生乐着生死三有爱果。于佛福田种善根者作如是言。以此善根愿我莫般涅槃。阿难。是人若不涅槃。无有是处。阿难。是人虽不乐求涅槃。然于佛所种诸善根。我说是人必得涅槃尽涅槃际。乃至佛所得一发心。一生敬信种善根者。一切皆当得般涅槃尽涅槃际。阿难。于当来世有边地王。彼虽不解佛法功德。见佛精舍及见形像心生信者。我昔曾于五道之中处处受生。修行一切菩萨行时。以四摄法。布施爱语利行同事。摄彼边王。阿难。彼边地王。见我精舍及见形像心生敬信。以此善根必得涅槃尽涅槃际。阿难。彼边地王。当有群臣并诸王子大臣辅佐。亲戚骨血及诸伴侣。于我灭度后见我精舍及见形像。虽不解知诸佛功德及佛正法。少修善根心生信者。我本修行菩萨行时。亦曾以四摄法摄护彼等。以是善根所加持故。当得涅槃尽涅槃际。阿难。我于长夜怜愍众生。以四摄法长夜摄受。以诸佛法利益养育。阿难。汝观如来在路行时。能令大地高处令下。下者令高。高下诸处悉得平正。如来过后地辄还复。一切树林倾侧向佛。树神现身低头礼拜。如来过后树辄还复。丘陵坑坎屏厕臭秽。荆棘丛林一切瓦砾皆悉扫除。严治平正清净无秽。馨香芬烈甚可爱乐。众华布地庄严光丽。如来足履蹈上而过。阿难。汝观如来本所修行诸善功德在路行时。无有众生而不倾侧稽首礼者。无情诸物大地山崖树林药草。于佛行处无不倾侧。何以故。阿难。我本修行菩萨行时。于诸师所倾侧礼拜。亦于父母第一尊重倾侧礼拜。耆年长宿中年少年亲友骨血无不倾侧。于佛菩萨善知识所。声闻缘觉及以外道。五通诸仙沙门婆罗门。如是一切应受供人。诸佛菩萨及善知识。声闻缘觉外道诸仙。沙门婆罗门。父母兄弟亲友骨血。及余耆年中年少年同师等侣。无不倾侧谦下礼敬。阿难。我以如是善业报故。于无上菩提得成佛已。彼诸事物有情无情。如来行时无不倾侧低头礼拜。阿难我本曾以清净微妙称意资产。至心自手施诸师长及余众生。阿难。以是业报。如来行时大地平正。扫洒严治清净无泥。又无瓦砾。阿难。我于无量诸如来所。菩萨知识声闻缘觉外道诸仙在路行时。我昔曾与扫治道路泥治房舍。若行若住于佛精舍。我以慈心平等心无高下心无谄曲心清净心扫治令净。于一切时常求阿耨多罗三藐三菩提。为一切众生故。安乐一切众生故。怜愍一切众生故。利益安乐诸天人故。阿难。以是善根。若佛如来在在处处若行若住若坐。若思惟念欲行来路首。自然街巷清净地平如掌。阿难。如来所有身业功德。殊胜难知不可得边。阿难。我今为欲满此义故。当有清信善男子善女人。于如来所深生敬信得未曾有。阿难。须弥山王高八万四千由旬。在大海中亦八万四千由旬。阿难。假使我灭度时。如此坚固高大山王无不倾侧。何况诸余黑山药草丛林。若不倾者。无有是处。阿难。且置坚固须弥山王。所有铁围山高十六万八千由旬。彼等亦是金刚坚固。佛涅槃时无不倾侧低头礼敬。若欲远避不倾侧者。亦无是处。何以故。阿难。我本修行菩萨行时。一切众生所作事业终不别离。若有众生嗔恚乖张我令和合。昔不和者能令和合。坚固安住具足不坏。各生慈心愍心。阿难。以是善根因缘力故。如来获得不可坏身。亦令眷属坚固不坏。阿难。如来复获眷属坚固不可坏法。所谓四念处四正勤四如意足五根五力七觉分八圣道分。阿难。此三十七助菩提法。是佛如来大眷属。所有诸佛声闻缘觉安住其中。一切世间诸天人众所不能坏。何以故。阿难。佛以是法。一切世间诸天魔梵。沙门婆罗门及诸眷属。天人阿修罗。及须弥山大铁围山大地草木。佛涅槃时。无不低头倾侧而向。何能破坏。若有坏者。无有是处。何以故。阿难。如来身者不可破坏。佛之舍利亦不可坏。阿难。如来怜愍一切众生。以本愿故碎此舍利令如芥子。为令佛法增广流布。阿难。如来本修菩萨行时发如是愿。我于阿耨多罗三藐三菩提成正觉已。般涅槃后令我舍利增广流布。阿难。以本愿故我灭度后。令此舍利增广流布。彼诸众生见佛如来般涅槃故得圣道果。佛为怜愍彼等众生。分此舍利令如芥子。阿难。如来应正遍知临般涅槃时。怜愍世间诸众生故。入如是三昧分此舍利令如芥子。然如来身不受苦痛。一切支节分散解时。能令舍利犹如芥子。时佛如来无有苦痛。乃至如是怜愍摄受彼诸众生。及摄未来诸众生故。令得安隐诸善道故。供养舍利。尊重迎送谦下供养。种种庄严种种华香。涂香末香衣服幢幡。及众宝盖歌舞音乐。我说彼等当得涅槃果乃至尽涅槃际。阿难。我灭度后一百年中于波离弗城。当有国王名阿输迦。于孔雀户种姓中生以法治世。彼于我法当得敬信。得敬信已令我舍利增广流布。一日一时起八万四千塔安我舍利。阿难。汝莫忧愁。我之舍利于天人中当广流布。阿难。且置现在供养如来。且置我灭度后供养舍利如芥子者。阿难。若有梦中见佛精舍。心生敬信。我说彼人。以此善根当得涅槃。得第一涅槃尽涅槃际。阿难。于未来世所有诸佛出兴于世。是诸如来无不称我功德行者。亦如我今称赞过去诸佛功德。未来诸佛称我名字亦复如是。阿难。我说法时凡诸众生。远尘离垢得法眼者。阿难。彼诸众生。我本修行菩萨行时。一切皆悉先已成熟。阿难。若施僧田功德有尽。施四方僧功德亦尽。施辟支佛所作功德于中不尽。若于佛所作功德者不可穷尽。复次阿难。如我前说。诸福田所作功德者。皆悉当得涅槃果尽涅槃际。阿难。且置亲承供养我者。且置我灭度后供养我舍利者。阿难。若有念佛。乃至一华散于空中。我以佛智见彼善根。不可量不可说。阿难。彼等众生所作善根。以念佛心。乃至一华散空中者。尽此劫来驰走流转。从初至末不可得知。于流转时。于如来所奉散一华。所得果报不可称说。或作梵天王释天王转轮圣王。以其善根不可尽故。必得涅槃尽涅槃际。何以故。阿难。如是诸佛大神通所奉施一华。得如是等无量福报广大利益大功德聚。不可称量无有边际。必当趣涅槃界。阿难。若于佛所作功德者。当得如是不可称量无边福报。乃至佛所得一发心生一念信者。我说是人梵行究竟。安隐究竟尽究竟际。是故。阿难。若有善男子善女人。欲求梵天王转轮圣王护世四天王。三十三天夜摩天兜率陀天化乐天他化自在天。及余诸天诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切世间主得自在者。应当如是尊重迎送。恭敬供养诸佛世尊。若欲悕求声闻地者辟支佛地者。及求无上三藐三菩提者。如是善男子善女人。亦应如是恭敬尊重谦下供养。阿难。我昔为求阿耨多罗三藐三菩提时。于无量佛无量百佛无量百千佛。乃至无量亿那由他百千佛所。恭敬尊重谦下供养。衣服饮食床座卧具病瘦因缘所须汤药。若行若住若坐若卧。以诸华鬘涂香末香栴檀沉水。憧幡宝盖供养彼佛。彼佛灭后起立塔庙种种庄严。以诸香花涂香末香。歌舞嬉戏百千伎乐。恭敬尊重谦下供养。怜愍世间诸众生故。利益安乐诸天人故。未得度者欲令得度。未解脱者令得解脱。未安隐者令得安隐。未涅槃者令得涅槃故。阿难。我以五茎优波罗华散然灯佛。于彼即悟无生法忍。如是善根是少分报。阿难。我以然灯如来应正遍知所散五茎华。及余善根少分福报。汝欲知不。阿难白言。如是世尊愿乐欲闻。如是婆伽婆。如是修伽陀。今正是时。唯愿世尊分别显示。于然灯佛种少善根所得果报。尔时世尊舒金色右臂。以一小指放天优波罗华香。遍满三千大千诸佛世界。百亿日月所流行处无不周遍。尔时世尊于诸天人阿修罗中。现此奇特未曾有法。于诸佛所种少善根。所得福报示现不虚。不亏损故。尔时世尊。而说此偈

  诸佛不思议　　如来法亦然
  能信不思者　　必获不思报
  有想无想等　　一切诸众生
  无量百亿劫　　一切悉供养
  所有辟支佛　　无漏阿罗汉
  不可思议劫　　供养彼一切
  正觉若住世　　若佛涅槃后
  乃至一合掌　　此福胜于前
  佛戒无缺漏　　三昧得自在
  于法无疑惑　　佛眼无不了
  若于善逝修慈者　　若昼若夜少时间
  如是供养福无量　　三界无等无有比
  过去阿僧祇劫中　　于诸世间导师所
  诸天人中作光明　　修诸善业不可数
  阿僧祇劫流转时　　受彼福报不可尽
  我以彼福为因缘　　能得如是胜菩提
  我昔怜愍众生故　　无量百千亿佛所
  世世常修胜供养　　佛不与我授记莂
  彼佛世尊人中上　　知我善根未纯熟
  虽行诸善不得记　　以我无是胜忍故
  我又见彼然灯佛　　奉散五茎优波罗
  布发淹泥令佛蹈　　即悟无生胜法忍
  时彼导师然灯佛　　即授我记升虚空
  汝于来世阿僧祇　　当得成佛号释迦
  从此生死流转来　　修行无量诸善业
  愍众生故受诸苦　　为求如是胜菩提
  我见世间孤独苦　　悲心怜愍常布施
  彼福无限无有量　　导师广说不能尽
  我为菩萨修行时　　于诸善逝佛世雄
  昼夜称名而供养　　无量亿劫不可数
  一二三四五至十　　二十三十略称名
  愍诸众生故修行　　最胜佛本所供养
  如我本修苦行时　　无量众苦我忍受
  世世不舍菩提心　　一切诸佛无能比
  我于世世流转时　　弃舍百千万亿头
  舍宝国土及王位　　为求闻法多善说
  我为无上正法时　　深心乐求不可量
  布施持戒及忍辱　　精进觉悟胜菩提
  诸佛势力不思议　　以诸功德所建立
  能演正法不思者　　亦能显示胜菩提

    大悲经殖善根品第十一

尔时世尊复告阿难言。我从然灯佛来。次复值佛名莲华上。我以金华奉散彼佛。为求阿耨多罗三藐三菩提故。次复值佛名一切世间最胜自在。我以银华奉散彼佛。为求如是一切种智。次复值佛名极高行。我把宝钱奉献彼佛。为求如是不可知智。次复值佛名曰上誉。我把众宝奉献彼佛。为求如是无障碍智。次复值佛号释迦牟尼。我以杂华散彼佛上。为求如是无上菩提。次复值佛名曰帝沙。我以赤旃檀末涂散彼佛。亦复为求无障碍智。次复值佛名曰弗沙。我以深信七日七夜目不暂瞬。以无量偈赞彼世尊。次复值佛名毗婆尸。我复以豆散彼世尊。次复值佛名曰尸弃。我以无价宝衣奉上彼佛。次复值佛名毗舍浮。我以肴膳饮食供养彼佛世尊。阿难。此贤劫初次有佛兴名拘留孙。我于彼所净修梵行。为求如是自然智故。次复值佛名拘那含牟尼。我于彼佛修行梵行。次复有佛名曰迦叶。时我于彼亦修梵行。我于是等一切佛所。为求阿耨多罗三藐三菩提。为自度亦为度未度者。自得解脱。亦为未解脱者令得解脱。自得涅槃。亦为未涅槃者令得涅槃。汝今观我供养尔许无量阿僧祇诸佛世尊。恭敬尊重谦下供养。具足无量诸善功德。为求如是阿耨多罗三藐三菩提故。阿难。如是次第汝应当知。虽于佛所种少善根。当得如是大神通大利益广大功德。阿难。我于佛所种殖如是不可思议菩提善根。今得如是不思议报。无等无敌无有边际。汝应当信。尔时世尊。重说偈言

  我于然灯两足尊　　值遇修行菩萨行
  五茎青莲散彼佛　　即时记我无上道
  次有佛名莲华上　　我时亦复得值遇
  以金宝华散彼佛　　为求最胜菩提故
  次复有佛大导师　　名诸世间最自在
  极高上行及上誉　　释迦帝沙弗沙佛
  毗婆尸弃毗舍浮　　拘留孙佛拘那含
  迦叶佛等皆供养　　为求最上胜菩提
  此等及余过去佛　　我皆修行胜供养
  悲愍一切众生故　　为求无上胜菩提
  彼佛千亿皆供养　　积集善根已满足
  降魔势力及眷属　　获得无忧安隐道
  我转无上大法轮　　为众生故显正法
  天人龙等紧那罗　　应菩提器我度竟
  我已显示安隐道　　未来诸佛及声闻
  若欲救度诸苦者　　应当修习我德行

大悲经卷第三大悲经卷第四

         高齐天竺三藏那连提 耶舍译

    以诸譬喻付嘱正法品第十二

尔时世尊复告慧命阿难言。且置我今得菩提时功德利益。若我本行菩萨道时功德利益。缘觉尚无。何况声闻及余众生。阿难。我菩萨时久修苦行。弃舍王位妇儿妻子。及诸婇女身命手足。头目耳鼻血肉骨髓。及受种种无量苦痛。彼等一切悉为汝等。悕求阿耨多罗三藐三菩提故。阿难。一切难舍我悉已舍。所受众苦悉为众生。阿难。此等功德。若我广说则不可尽。如有闻者心则迷闷况有说者。阿难。若有众生起一念心悲愍。释迦牟尼如来应供正遍知。本昔修行菩萨苦行作如是言。为我等故具受无量种种苦痛难为之事。阿难。我说彼等一发心者。必定当得最后涅槃。何况我所种善根者。阿难。或有愚人漫捍无信。闻我本修菩萨苦行。乃至不生一念悲心。不言如来有大利益。亦不敬信。是故所有殊胜行者。能得涅槃。阿难。如是功德利益胜法。缘觉所无。何况一切声闻凡夫所能有也。阿难。诸有修行菩萨行者所得大悲。亦非缘觉所能有也。阿难。若有如我修菩萨行者得于大悲。得大悲已悉皆当得阿耨多罗三藐三菩提。是故此法大慈大悲之所摄也。以是因缘缘觉所无。以是义故。彼不得作如来应供正遍知。不具十力四无所畏大慈大悲。阿难。我知本昔修菩萨行推求善法。于彼生死心常惊怖。于诸众生修大悲心。而于梦中见大铁围有崩倒处。世界中间有诸众生在大地狱。为彼狱卒之所逼切。身体碎坏。周遍炽然犹如火聚。受大苦切如夺命苦。我诣其所。彼诸众生合掌礼拜而作是言。仁者。汝今受乐我等今受地狱之苦楚毒难忍如夺命苦。无救无护无归无趣。大丈夫。若欲救我如是苦者必定堪能。阿难。我时于彼地狱众生起大悲心。即于梦中悲泣流泪如恒河水。我时安慰彼众生言。诸仁者。莫生怖畏。我令汝等脱是苦聚。阿难。我时令彼地狱众生集在一处。以其右手普摩其顶而告之曰。诸仁者。莫生怖畏。我当必定救度汝等。作是语已。地狱火聚即时得灭。其诸众生于刹那顷得受安乐。阿难。我于尔时从梦悟已。振衣取泪以器盛置。阿难。我本如是具大悲法修菩萨行。何况今得阿耨多罗三藐三菩提。阿难。汝应当知如是之法。亦非缘觉所能有也。何况声闻凡夫人等。阿难。若有此法者。是修菩萨行。阿难。当观如来本昔所修菩萨行时。于诸众生具足如是怜愍利益大悲之心。如是功德。若我具以口业宣说不得边际。阿难。过去之世有大商主为采宝故。将诸商人入于大海。彼所乘船众宝悉满。至海中间其船卒坏。时彼商人心怀怖畏极生忧恼。其中或有得船板者。或有浮者有命终者。阿难。我于尔时作彼商主在大海中。用以浮囊安隐而渡。时有五人呼商主言。大士商主。唯愿惠施我等无畏。说是语已。尔时商主即告之言。诸丈夫。勿生怖畏。我令汝等从此大海安隐得渡。阿难。彼时商主身带利剑而作是念。大海之法不居死尸。如其我今自舍身命。此诸商人必能得渡大海之难。作是念已。即唤商人置己身上令善捉持。彼诸商人有骑背者。有抱肩者有捉髀者。尔时商主为欲施彼无怖畏故。大悲修心起大勇猛励身心力。即以利剑断己命根速取命终。于时大海漂其死尸置之岸上。时五商人便得渡海安隐受乐。平吉无难还阎浮提。阿难。彼时商主岂异人乎。我身是也。五商人者。今五比丘是也。是五比丘。昔于大海而得渡脱。今复于此生死大海而得渡脱。安置无畏涅槃彼岸。阿难。汝今当观修何苦行具足。云何无量功德得为菩萨摩诃萨也。阿难。如是功德次第应知。亦非缘觉所能有也。阿难。如诸菩萨功德如是。诸辟支佛无此法故。不作如来应供正遍知。不成阿耨多罗三藐三菩提。阿难。以能如是修诸苦行。得为菩萨大悲怜愍一切众生。阿难。复有愚人于我佛所不生敬信。以是因缘不得作阿耨多罗三藐三菩提根本种子。亦不得证无上涅槃。彼若于我心生敬信。即便得作菩提种子能证涅槃。阿难。修少分行得少分功德。修满足行得满分功德。阿难。我当更说余行决定。若有众生乃至能发一念敬信。以此善根得为种子。何况复种胜上善根。阿难。若于佛所种善根者。乃至一念发心念佛。我说彼等犹如甘露最后甘露。阿难。行者应当以一切种而念如来。所谓念于如来所念。念如来善根。念如来姓日。姓不相似以甘蔗种上姓生故。姓日者。为离诸闇而作光明。阿难。我生释种故种姓清净。阿难。当念如来生。念如来种族。念如来姓。念如来积财具足。念如来端正。念如来所生国土。念如来相。念如来随形好。念如来十力。念如来四无所畏。念如来十八不共法。念如来所生具足。念如来可美。念如来无愚痴。念如来本行具足。念如来愿具足。念如来戒定慧解脱解脱知见具足。念如来慈悲喜舍具足。念如来威仪具足。阿难。若有人随所念佛彼彼功德。得大神通大利益广大功德。犹如甘露第一甘露最后甘露。阿难。我于往昔为菩萨时行檀波罗蜜。我以佛智观彼功德不得边际。何况所修尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜如是等诸余功德。若彼菩萨未得授记所有功德。佛智观察不得边际。何况授记所有功德。乃至何况得成佛时一切功德。于百千亿那由他劫。观察宣说不得边际。何以故。如来应供正遍知功德无量。阿难。我以实智观此利益如是说也。若有忆念我菩萨时功德利益心生敬信。以此善根悉皆当得后际涅槃。是故阿难。汝莫忧悲。我为令汝与诸天人。作大利益作大摄受已说道法。令彼得向无上安隐后际涅槃。汝等于此勤修方便慎莫放逸

尔时世尊告诸比丘言。吾今后夜当般涅槃。汝等。今者最后见我。最后受化。最后合会。汝等。从今更不见我。我亦不复见于汝等。汝诸比丘。止莫忧悲。一切所爱称意之物皆当离散。诸比丘。生法有法有为法。差别法觉知法。因缘所生败坏之法。若不灭者。无有是处。诸比丘。假使久住会当去矣。诸比丘。凡有生者无不有死。一切诸行无有常定。究竟不变。诸比丘。生死是苦涅槃是乐。汝若欲令未得者得。未达者达。未证者证。当勤求之。诸比丘。勤修方便慎莫放逸。诸佛世尊以不放逸故。得阿耨多罗三藐三菩提及余一切助道善法。是故汝等当受我化

尔时大众比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释天梵天四天王等。得闻如是最后教已。愁苦不乐为忧箭所射啼哭流泪。极大号叫作如是言。婆伽婆入槃涅槃一何驶哉。修伽陀。入般涅槃一何驶哉。世间眼灭世间盲冥。一何疾哉。我今云何与众生宝别离太速

尔时阿难闻是语已。瞻仰如来目不暂瞬。即便思惟悲号啼哭放身投地。犹如斫倒临峻大树

尔时世尊。告阿难言。止。莫忧悲。我向岂不如是语汝。一切称意所爱之事皆当别离。生法有法有为法。差别法觉知法。因缘所生败坏之法。若不灭者无有是处。慧命阿难。闻是语已即白佛言。婆伽婆。我何得不愁。修伽陀。我何得不悲。我与如是众生之宝。众生共乘。众生导师。世间所求。世间归趣。天人大师。当有别离。是故婆伽婆。我何得不愁。修伽陀。我何得不悲。世尊。我与如是大悲怜愍一切众生世间亲友。一切世间眼目之宝作光明者当有别离。而我自怪心不破裂以为百分。世尊。我复自怪而得住此不取命终。世尊。又我自怪身不破坏犹如麦[麥*戈]。世尊。我复思惟。今得如是不命终者皆由如来神力加故。婆伽婆。我那得不愁。修伽陀。我那得不悲。今者如是众生共乘世间导师。怜愍世者。明当不住更不可见

尔时佛告慧命阿难言。汝爱我耶。阿难言。甚爱婆伽婆。甚爱修伽陀。佛言。阿难。云何爱我。阿难言。我爱世尊。非以口业言说可尽。亦不可以喻况能尽。婆伽婆。我爱如是。修伽陀。我爱如是。世尊。我为如来弃舍身命亦无吝惜。婆伽婆。我爱如是。修伽陀。我爱如是。世尊。我爱如来唯佛证知。婆伽婆。我爱如是。修伽陀。我爱如是

尔时世尊复告阿难。汝若爱我申汝右手来。尔时阿难即舒右手。于时世尊。以金色右手其掌柔软色如紫矿。执阿难手而作是言。阿难汝若爱我应当为我而作爱事。何者为我所作爱事。我于无量百千亿那由他阿僧祇劫。所习阿耨多罗三藐三菩提。大法宝藏付嘱于汝。汝当随顺如我所转。当如是转令得广行而不断绝。莫作中间灭法人也。阿难。我今为汝当作护持。令佛所说正法毗尼而得增长。不退减故不失坏故。我今说喻。诸有智者从喻得解。譬如贵族巨富长者豪富饶财多诸库藏。所须之物无不具足。如是财宝不共他有。种姓具足籍胄渊远。所生因缘悉亦具足。如是长者生育一子。子既长大。勤教令学历算书印。及余种种深密工巧深密智慧。子既学已。后时长者语其子言。我今于汝所作已竟。汝既学得历算书印深密工巧深密智慧。今日是我最后教敕。一切财宝是我所有。我今悉当付嘱于汝。汝从今日当学三事可得存我门族旧业。何等为三。一者欲。二者精进。三不放逸。如是豪贵巨富长者。如是善巧教其一子。而彼一子狂惑放逸。父母财产费用皆尽。阿难。于意云何彼长者子受父教不。阿难言。不也婆伽婆。不也修伽陀。佛言。阿难。如是长者。为与其子作父事不。阿难言。作也婆伽婆。作也修伽陀。佛言。阿难。如来则为世间之父。汝如一子。今日是我最后教诫付嘱于汝。我此百千亿那由他阿僧祇劫。所习无上法宝库藏。汝等亦应学于三事。何等为三。一者欲。二者精进。三不放逸。如是汝等若住三事。我此阿僧祇劫所习无上法宝库藏则得久住。未达善法者令得通达。已通达者令不退失是故汝等。应当坚持我此阿僧祇劫所习阿耨多罗三藐三菩提法宝库藏。未住三事者令住三事。未达善法令得通达。已通达者令不退失。何以故。我为慈悲怜愍利益诸世间故。为令彼等得安乐故。阿难。我与世间已作父事亲友事竟。我于汝等应作已作。复次阿难。我于阿僧祇劫所习。阿耨多罗三藐三菩提法。三事因缘当有隐没。何等为三。一者无信。二者不住决定之行。三者不忏悔。是故阿难。今当护持正法宝藏。为住深信决定忏悔。应作欲进不放逸等三事方便。如是汝等。于我法尊世间之父。如其子事应作已作。阿难。以是义故。我复说喻。令此无上正法宝藏。而得成就增上付嘱。以此喻故。诸有智者闻说得解。复得增上深爱敬信便生念言。彼释迦牟尼如来应供正遍知。为我等故临涅槃时。以其右手执阿难手。付嘱于此阿僧祇劫所习阿耨多罗三藐三菩提法。譬如商主远游道路。所应作者皆已作讫。阿难。于意云何。而彼商主。为当还家为在道住。阿难言。世尊。彼来还家不在道住。阿难。如是如来世间之父。世间亲友。世间导师。是大商主。以阿耨多罗三藐三菩提智所应作者皆已作讫。更无佛事而可作也。一切众生所应度者皆已度竟。所应度者无不善调。阿难。有于三事不满不得。如来应供正遍知不般涅槃。何等为三。所谓菩萨摩诃萨未得住于不退转法。若于如来无上正法隐没之时。或经一劫百劫千劫。或百千劫百千亿那由他劫。未能得成阿耨多罗三藐三菩提。诸佛世尊虽涅槃时至。见此菩萨善根未熟。为令成熟住不退故。以神通力加其自身住世不灭。待此菩萨得不退已。即时授其次第补处阿耨多罗三藐三菩提记是佛。如来然后入于无余涅槃。是故我今与弥勒等。无量百千亿那由他菩萨摩诃萨。授阿耨多罗三藐三菩提记。令其住于阿毗跋致。此是诸佛怜愍众生应作已作。复次阿难。若诸众生。应于如来当得解脱而未度者。如来终不入于涅槃。若佛世尊。知彼无量百千亿劫。余佛世尊未出于世若自世界若余世界。于五道中所有众生。或经一岁或百岁千岁。或百千岁或百千亿那由他岁。乃至一劫若过一劫。是等于我应得度脱。不于一切声闻缘觉而得度脱。以佛智慧。如是知已。彼佛世尊。虽涅槃时至怜愍彼故。以神通力加其自身住世不灭。乃至令彼得成熟已然后度脱。阿难。此是第二诸佛世尊应作已作。然后入于无余涅槃

复次阿难。如来所说。若修多罗。若毗尼。若摩得勒伽。所有深义。非学无学声闻大众共议能知。于其众中设有比丘生疑欲问。敬重佛故恐畏恼乱不敢辄问。于是如来应供正遍知佛智知已。化作一比丘至如来所问言。世尊。此所作事云何而作。佛即告彼化比丘言。比丘。此所作事应如是作。阿难。此是三事诸佛世尊必定须作。其事不满不入涅槃。彼等一切我于今者已作已满。更无所作更无所说。阿难。我今已为诸声闻说。修学毗尼波罗提木叉。为尽苦故示于正道。说行决定正作其事。是故阿难。汝等。从今我不说者。慎莫说之。我所说者勿令断绝。阿难。如我所说应如是学应如是作。慎莫放逸乐。不放逸故则得道果。以是义故。教敕汝等莫忧莫悲。阿难。吾今后夜当般涅槃。我今当舍己之国土己之境界。更不复来至此世界。亦复不到他世界也(他世界者后世生处)。汝等。从今更不见我。我亦不复见于汝等。阿难。我当入于无余涅槃。如是涅槃。寂静清凉无尘离垢。一切苦息舍于窟宅。无生无老无病无死。无忧无悲无苦无恼。无不称意无诸悔恨。无怨憎会无爱别离。如恒河沙等诸佛世尊。及与一切声闻缘觉。皆悉已去今去当去。阿难。汝今当观我犹爱彼无余涅槃。有诸愚痴凡夫之人。而不爱彼胜妙寂静安乐涅槃。亦复不能一念发心随顺解脱。是人若能一念发心。以是因缘即为种子当得涅槃。阿难。一切凡夫何有是力。一切凡夫羸劣无力。阿难。我观一切愚痴凡夫犹如麦[麥*戈]。是故阿难。愚痴凡夫。何得有力何得有安。所有不能一念发心顺解脱者。若能发心决定得为涅槃种子。阿难。一切愚痴凡夫之人。无有戒力定力慧力。阿难。我已具足无量佛力。具足阿僧祇不可思议无量无等。戒定慧解脱解脱知见力。惭力愧力久积集力。智力舍力福力慧力。根力加力具足十力。犹故爱彼无余涅槃。阿难。有诸凡夫闇钝无智少于知法。乐着生死牢狱缠缚。乃至不能一念发心随顺解脱。当令彼等得为涅槃根本种子。阿难。如是如来所赞所说。诸修多罗留在未来。若佛灭后未来世中。有人得闻闻已发心。则便得入正法宝藏无余涅槃界。阿难。我当说喻令得增上深解其义。阿难。譬如商主将诸商人。涉于广大旷野崄路。免诸贼难到无畏城。其中有人失伴在后。极甚怖畏寻迹而去逐诸商人甚大苦恼。得过崄路见诸商伴。阿难。如是如来成阿耨多罗三藐三菩提已。演说如是诸修多罗留在未来。于佛灭后有诸善男子善女人等若得听闻。闻已发心。到我所留正法宝城无余涅槃界。到正法城已思惟忆念。护持显说我法宝藏。阿难。我为一人尚当付此无上正法令汝坚持。何况无量百千众生。是故我今以此亿那由他阿僧祇劫所习。阿耨多罗三藐三菩提正法宝藏付嘱于汝。汝等应当善诵坚持。为诸净信四部大众开示分别。莫作中间灭法人也。阿难。当来之世有诸众生。不闻如是修多罗义而生退没。是故阿难。我当说喻。譬如豪贵巨富长者。多饶财宝库藏盈满。资生所须皆悉具足。然彼长者唯有一子远行他方。时彼长者。身遇重病痛苦极甚。临命终时。以多宝物摩尼真珠琉璃珂贝金银钱财。寄余长者作如是言。汝应当知。我子既已远行他方。然我今者身遇重病。不久命终。为我子故以是无量库藏财宝寄付于汝。如其我子他方来还。为我教之令莫放逸。当令坚住不放逸法。然后付此库藏宝物。当付宝时应作是言。童子。汝父往日临命终时。为于汝故以此宝物寄付于我。今我还汝是汝己物。应当领受慎莫放逸。坚持守护勿令损失。尔时豪贵巨富长者作是语已。即以所有众多宝物而寄付之。彼余长者即便领受。受已不久其长者子他方而还。彼余长者所受寄物悉不还之。阿难。于意云何。是谁过也。慧命阿难白佛言。世尊。受寄者过。非余人也。何以故。其受寄者。亲自受彼豪贵长者众多宝物。不还彼子故。佛言阿难。豪贵长者。喻如来也。临命终者。喻于如来欲入涅槃。言一子者。喻未来世有诸净信善男子善女人等。远行他方者。喻流转五道。大宝藏者。喻于如来亿那由他阿僧祇劫所习无上大法宝藏。受寄长者。喻于汝等诸大声闻菩萨摩诃萨护正法者。阿难。如是亿那由他阿僧祇劫所习。无上大法宝藏。为未来世诸善男子善女人等。寄付于汝及大迦叶弥勒等诸大菩萨。汝等。若能顺我付嘱。彼未来世所有受化净信佛子。应以法宝而授与之。何以故。阿难。有诸众生是我往昔为菩萨时所成熟者。以恶业故堕于地狱畜生饿鬼。如是众生如来灭后。得出恶道生于人中。所有诸根增长成熟故。于我法中以少因缘能生敬信。其中或有得出家者。闻我所说诸修多罗当发胜行。或于声闻乘。或于缘觉乘。或于大乘而般涅槃。阿难。我为未来诸善男子善女人等。付嘱于汝我此百千亿那由他阿僧祇劫。所习无上大法宝藏。令彼得闻。何以故。彼等众生。若不闻此真道正法。当有退没。是故我今为彼未来善男子等付嘱于汝大法宝藏。若彼得闻则无有退。以是因缘我复说喻。阿难。譬如转轮王广开库藏。敕诸典臣诸丈夫。汝当布施一切沙门婆罗门。贫穷乞人及行路者。随其所须。求食与食须饮与饮。须乘与乘。及以华鬘涂香末香。衣服卧具清净房舍活命之具。诸库藏臣。得王敕已而不行施。阿难。于意云何是谁过也。阿难言。大德婆伽婆。诸藏臣过。非轮王也。佛言。阿难。如是如是。我为法王。于亿那由他阿僧祇劫。广集如是大法库藏。自觉悟已。欲令增广。于天人中开示显说。乃至为汝所开示者。为诸敬信沙门婆罗门一切凡夫求法义者悉令得闻。是故阿难。我今以此大法宝藏。已广开显付嘱于汝。汝若不为净信沙门婆罗门长者居士。及诸凡夫乐法义者广宣分别。则于如来当有过失。何以故。阿难。我为无上法转轮王。多有法宝功德库藏。多诸助道七觉法财。十力无畏皆悉具足。于诸法中而得自在故名法王。汝持我此八万四千正法宝藏。为诸净信沙门婆罗门长者居士。净信凡夫诸法师等求法义者。具足演说勿生分别。莫作中间灭法人也。是故阿难。汝若以我亿那由他阿僧祇劫所习。阿耨多罗三藐三菩提无上法宝。能为四众而显说者。则于如来无诸过失。若不说者有大过也

复次阿难。若漏尽阿罗汉比丘。证无为故不能为他分别显说。是人不益如来导师。亦不护持我之正法。是故我今付嘱汝法。何以故。阿难。譬如有人于大黑闇执持草炬还归舍宅。复有多人欲度黑闇其执炬者。依此草炬得度黑闇到己舍宅。到已除灭而不与他。阿难。于意云何。是人既知草炬未尽。及知大众皆欲度闇。自用此炬而不与他。可名正作为好不也。阿难言。不也婆伽婆。不也修伽陀。佛言。如是如是。阿难。若有比丘得阿罗汉果。证无为法已。亦知大众度生死闇。而不为他分别显说。我阿僧祇劫所习法宝令得增广。是人不名利益导师。不名摄受我之正法。是故阿难。我今以此亿那由他阿僧祇劫所习法宝付嘱于汝。乃至坚持为他广说。勿令断绝如是真道。莫作末后灭法人也。阿难。若有比丘比丘尼优婆塞优婆夷。于此法宝自安住已。必能为他分别显说我此亿那由他阿僧祇劫所习法宝。应付彼等当与其分。是故阿难。我此亿那由他阿僧祇劫所习善法。第二付嘱为于未来诸众生故。勿令如是诸众生等不得听闻而有退失

复次阿难。譬如豪贵巨富长者多诸库藏。摩尼真珠珊瑚珂贝。资生所须皆悉具足。时有怨家烧其库藏。如是长者。复有诸怨及怨亲友。于长者所。心常乐作不利益者。有不乐彼得喜乐者。有不乐彼得安隐者。如是诸怨。见其大火烧库藏时。舍之默住不灭此火。而彼长者。复有亲善常欲怜愍利益心者。欲令安隐者。见其火已舍而默住不欲灭之。阿难。于意云何。如是亲友。可名正发随顺理不。阿难言。不也婆伽婆。不也修伽陀。佛言。阿难。彼等亲友。见其大火焚烧库藏。舍而不救故复加增炽。尽烧一切库藏不耶。阿难言。如是婆伽婆。如是修伽陀。佛言。如是如是。阿难。我于亿那由他阿僧祇劫所习无上善根法宝坏灭之时。有诸比丘心无敬信。毁破净戒习行恶法。于歌舞处能为上首。不乐离欲修行禅定。心多散乱懈怠懒惰。少于闻法不乐读诵。何能为他分别显说。令人得闻住持法宝

复次阿难。譬如灌顶刹利大王。唯有一子远行不在。其刹利王身遇重病。既得病已。以诸宝藏种种杂物。持往寄付大臣长者。作如是言。若我子还。汝当置立令绍王位。以诸库藏悉皆付之。诸臣长者。各各别受彼王所寄。既受寄已王便命终。王命终已其子行还即绍王位。既登位已具得自在。诸臣长者。而不还彼宝藏财物。作如是言。善哉大王。正法治化以此宝物赐与我等。阿难于意云何。其所受寄大臣长者。于彼王所有过不耶。阿难言。如是婆伽婆。如是修伽陀。彼有过也。佛言。阿难。其远行者。喻五道众生。病者。喻佛欲入涅槃。多宝藏者。喻三十七助道善法。大臣长者。喻诸阿罗汉。付宝物者。喻我以此亿那由他阿僧祇劫所习法宝付嘱于汝。乃至如是为彼未来诸弟子故。阿难。当来之世有诸众生。我于往昔所成熟者。以恶业故生于地狱畜生饿鬼。我灭度后于彼命终得生人中。所有诸根增长成熟。于我法中心生敬信。有得出家者。有在家者。有得须陀洹者。乃至有得阿罗汉者。有于学地而命终者。有于佛地发深信者。有种人天诸善根者。如是当得具足利益。有得如是敬信心者。作如是言。彼世间父善付我等。复得生于增上敬信。阿难。我为彼故。以此法宝付嘱于汝。乃至令彼得闻如是法宝藏故。是故阿难。汝当以我大法宝藏。令彼净信诸善男子善女人等而得闻也。阿难。若不令彼而得闻者。汝于如来则为有过。何以故。阿难。彼善男子善女人等。若闻如是大法宝藏。或有得成殊胜之行。或有得生大爱乐心。或有闻时流泪毛竖。阿难。若复有人闻是法门。念佛功德流泪毛竖者。我记彼等。以此善根皆得涅槃

大悲经卷第四大悲经卷第五

         高齐天竺三藏那连提耶舍译

    殖善根品第十三

复次阿难。若有比丘受持如是诸法门已。有诸清信善男子善女人等。乐闻法故有来听者不为演说。是人则为如来怨仇。何以故。是诸人等应为法器。乐欲闻法。不为说故彼不得闻。以不闻故即便退失己之善根。亦复退失他人善根。所以者何。是人不知应可为说不可为说。阿难。我以是义。欲令明了故说譬喻。犹如商人多赍宝货。至大旷野崄难路中。开诸宝货布之在地。唤诸群贼而告之言。我此宝货希有难得。汝与我价。我以此宝当卖与汝。阿难。时彼群贼。即于旷野执持刀杖。打诸商人夺其众宝。阿难。于意云何。是诸商人。可于旷野布众宝物。唤诸群贼言买物不。阿难白言。是诸商人。犹尚不应旷野崄路开诸宝货。况唤群贼。世尊。如是商人。应自牢藏众珍宝物。着铠持仗以自防卫。于旷野处安隐而度。此事应尔。尔时世尊复告阿难。复有商人。亦持诸宝从远方来。到诸城邑王都聚落。到已开诸宝物布之在地。彼有好人来买宝物。是诸商人方执刀仗。共买宝者而共斗战。阿难。于意云何。是诸商人得名黠不。阿难白言。不也婆伽婆。不也修伽陀。世尊。是诸商人应作是言。我此宝物希有难得。汝与我价当卖与汝。世尊。是诸商人应当如是。不应布诸宝已。着铠持仗共相御逆。佛言。阿难。有诸比丘。受持流通诸法宝藏。所谓修多罗。祇夜。伽陀。毗耶迦罗那。优陀那。尼陀那。阿波那。伊帝毗利多迦。阇多迦。毗弗略阿浮陀达磨。优波提舍。而于彼等应为法器。不为说故彼不得闻。以不闻故。信等乐欲善心不生。以不生故。不得种诸善根修殊胜行而般涅槃。彼诸不应为法器者而为演说。彼得闻已信等乐欲善心不生。以不生故不得解脱。是人便生诽谤毁呰。作诸罪业堕三恶道。阿难。犹如彼愚痴商人。应开宝处而不为开。不应开处而便强开。应可与处而不肯与。不应与处而便强与。阿难。若有清信善男子善女人。善心清净乐欲闻法。应为法器来听法者。应可为说而不为说。不应为说而便强说。是故阿难。若有如是堪为法器。深信乐欲求涅槃者。应当为说。若有不堪为法器者。无信乐欲求其过失。破戒恶行伺求他过。为欲违反佛正法眼。不随顺故不应为说。何以故。勿令彼诸愚痴人等。闻此法已生增上过。是故阿难。当如是学。若有善男子善女人应为法器乐闻法者。勤心为说。诸有听者亦复应当摄心专听。阿难。彼若如是。俱能广生无量阿僧祇大功德聚。阿难。于意云何。所有地界及众生界。何者为多。阿难白言。如我解佛所说义。众生界多非地界也。佛言。阿难如是如是。如汝所说众生界多。非彼地界亦非水火等界。阿难。及余三千大千世界所有众生。有可知者有不可知者。有可见闻有不可见闻。是等一切于一刹那一罗婆一摩。睺多顷。假使俱时得作人身悉。成男子于一刹那一罗婆一摩睺多顷。皆悉得成缘觉菩提。阿难。乃至无量无边诸世界中所有地土。是诸地土边际不可知。如是地土悉作微尘。彼诸微尘假使皆悉得作人身悉成男子。彼作人已于一刹那一罗婆一摩睺多顷。皆悉得成缘觉菩提。阿难。若复无量无边诸世界中。有须弥山铁围山大铁围山。雪山香山及余黑山。乃至三千大千世界。所有药草树木丛林悉为微尘。有可知者不可知者。有可见闻有不可见闻。皆得人身悉成男子。于一刹那一罗婆一摩睺多顷。假使一时皆悉得成缘觉菩提。阿难。彼诸缘觉假使寿命从过去际尽未来际。寿命住世不可得知。彼众生中惟有一人。独不得成缘觉菩提。然彼一人为大长者。亦从过去尽未来际。于中住寿不可得知。时彼长者亦随住寿。供养尔数诸辟支佛。饮食衣服床座卧具病瘦汤药。一切供身称意乐具。恭敬尊重谦下供养彼辟支佛。若辟支佛般涅槃后起七宝塔。以诸天人宝幢幡盖。种种花鬘涂香末香及以烧香。衣服歌舞音声伎乐。尽天人中最上供具。恭敬尊重谦下供养。阿难。于意云何。彼大长者得福多不。阿难白言。如我解佛所说义。若能供养恭敬尊重一辟支佛。所得福德尚多无量不可算数。无等无限不可思议。何况供养尔许辟支佛随其住寿。若灭度后恭敬尊重谦下供养。尔时世尊复告阿难。我今以实告汝。彼辟支佛具足戒定慧解脱解脱知见聚。受彼长者种种供养。有一如来应正遍知出兴于世。不受长者衣服饮食床座卧具病瘦汤药。亦不说法。然彼长者但见如来应正遍知。凡常威仪示现于世。所得福德多于供养彼辟支佛。具足戒定慧解脱解脱知见者。百千亿那由他倍。不及长者见佛如来凡常威仪示现于世。所得福德。何以故。以佛如来具足无量阿僧祇不可思议大功德故。阿难。诸佛如来但以威仪福德善根。犹尚不能穷其边际。何况如来所有无量诸善功德。阿难。若于辟支佛所修行布施所得福德无量阿僧祇。若于佛所修行布施。所得福德亦复无量无有限者。有何差别。阿难。彼所布施非无差别。阿难。譬如有人为求利故诣于他方。彼得利已即便回还。阿难。若施辟支佛所得福德。比佛如来亦复如是。阿难。若复有人于诸佛所修行布施。所得福德不可为譬。何以故。阿难。若于佛所修行布施。所得福德无量阿僧祇。不可思议无等无匹。无有边际不可穷尽。阿难。若于佛所修行布施所得福德。我当为汝而作譬喻。诸有智者以喻得解。阿难。譬如画师画虽精好。其中犹有少许鄙拙不端严处。复有画师所作端正转更胜前。如是阿难。若于辟支佛所修行布施所得福德。比于佛所修行布施所得福德。亦复如是。何以故。阿难。彼辟支佛。以其智故得名辟支佛。此辟支佛智皆从如来智慧而生。诸佛如来一切种智转更胜前。是故阿难。若于佛所乃至尽形。衣服饮食床座卧具病瘦汤药。恭敬尊重谦下供养。所得福德宁为多不。阿难白言。如是婆伽婆。如是修伽陀。若于佛所乃至尽形恭敬供养。所得福德甚多无量。世尊。若于佛所乃至发心一生敬信。所得福德尚多无量。不可思议不可算数。何况有人于如来所乃至尽形。恭敬尊重谦下供养。作是语已。佛告阿难。且置供养一佛如来以一切乐具。乃至尽形而供养者。且置供养二三四五乃至十佛。若二十三十乃至百佛千佛百千佛。亿佛百亿佛千亿佛百千亿佛。亿那由他百亿那由他。千亿那由他百千亿那由他。乃至遍满阎浮提如来应正遍知。尽四天下千世界。二千世界三千大千世界。其中百亿日月百亿须弥山。百亿铁围山百亿大海。百亿阎浮提。百亿郁单越。百亿弗婆提。百亿瞿陀尼。八万州渚并诸眷属。百亿四天下百亿四天王天。百亿三十三天。百亿须夜摩天。百亿兜率陀天。百亿化乐天。百亿他化自在天。百亿梵天乃至阿迦贰吒天。此名三千大千世界。彼悉满中诸佛如来应正遍知。譬如甘蔗若竹若[竺-二+韋]若佉陀利林若迦赊林。彼诸如来。寿命长远如恒河沙劫。时有长者。寿命住世亦复如是。乃至尽形衣服饮食床座卧具病瘦汤药。恭敬尊重谦下供养彼诸如来。若佛灭后起七宝塔。以天幢幡诸妙宝盖。种种香华涂香末香。一切花鬘诸妙莲花。优波罗花。拘牟头花。芬陀利花。一切歌舞种种音乐。以如是等一切乐具。恭敬尊重谦下供养。阿难。于意云何。彼大长者。所得福德宁为多不。阿难白言。如是婆伽婆。如是修伽陀。彼大长者。于一如来以诸肴膳饮食供养。所得福德尚多无量不可算数。何况如是于诸佛所住恒河沙劫。而设供具恭敬尊重谦下供养。彼佛灭后起七宝塔种种供养。所得福德不可为譬。作是语已。佛告阿难。我今以实告汝。若彼长者。于诸佛所随其寿命。恭敬尊重谦下供养。彼佛灭后起七宝塔。以诸胜妙种种供养所得福德。阿难。若有善男子善女人。于诸如来分别演说菩提道时。信解乐欲具足深信。法是善说僧是发心善修行者。信解诸行一切无常一切苦一切空一切法无我。寂灭涅槃。阿难。以此信解所得福德转复胜前。阿难。若复有人信解如是诸法宝藏转为他说。所得福德如是广大如是无量。如是阿僧祇如是不可思议。如是无等如是无限。何以故。阿难。如是法宝无上法藏初中后善。若有修行如是布施。所得功德比此法藏犹如草芥。应如是知。何以故。阿难。如是布施世间有漏是生死法。阿难。我此无量阿僧祇亿那由他劫所集法藏。断除生死离诸杂食流转故有。阿难。若有众生闻此法藏。从此生法而得解脱。乃至老死忧悲苦恼法而得解脱。阿难。我观此义故作是说。有二种人得大福德。一者勤心为说。二者至心专听。作是语已。慧命阿难白佛言。世尊。若有善男子善女人。深信具足如实修行。分别诸法信解乐欲。法是善说僧是发心善修行者。信解一切诸行无常若苦若空一切法无我。寂灭涅槃。如是善思深正念者得几许福。佛言。阿难。若复有人。但知法是善说僧是发心善修行者。如是善男子善女人。深正思惟摄心专听。得闻法已乃至一弹指顷深正思惟。法是善说僧是发心善修行者。是人于彼所得福德无量无边。何况善男子善女人。深正思惟摄心专听。听闻法已乃至一弹指顷如实修行。解知诸行一切无常一切苦一切空诸法无我。寂灭涅槃。阿难。若于无量无边诸世界中。所有一切诸众生界。于一刹那一罗婆一摩睺多顷。假使一时俱得人身。彼得人已于一刹那一罗婆一摩睺多顷。假使一时于阿耨多罗三藐三菩提成等正觉。彼诸如来假使寿命从过去际不可得知。于未来际亦复如是。阿难。假使是等诸众生中惟有一人。于阿耨多罗三藐三菩提不成正觉。然彼一人为大长者。亦随寿命从过去际不可得知。于未来际亦复如是。尔时长者。乃至尽形恭敬尊重谦下供养彼诸如来。以诸乐具衣服饮食床座卧具病瘦汤药而以供养。彼诸如来入涅槃后起七宝塔。起宝塔已宝幢幡盖。一切花鬘涂香末香。尽世所有恭敬尊重谦下供养。阿难。于意云何。时彼长者。所得福德宁为多不。阿难白言。若彼长者。恭敬尊重谦下供养一佛如来。所得福德甚多无量。不可算数不可思议无等无限。何况如是于诸佛所。随其寿命恭敬尊重谦下供养。所得福德不可思量。佛言。阿难。如是如是。如汝所说。如是长者。所得福德不可思议。是故阿难。我今以实告汝。若彼长者于诸佛所随其寿命。恭敬尊重谦下供养所得福德。若复有人深正思惟摄心专听。得闻法已乃至一弹指顷。信解乐欲法是善说僧是发心善修行者。信解诸行一切无常一切苦一切空诸法无我。寂灭涅槃。所得福德不可譬类所能知也。阿难。如我先说有二种人得福甚多。一者至心为说。二者专心勤听。尔时世尊说是偈言

  为于二种义　　应听佛所说
  一切漏行尽　　近圣成菩提
  若有说法者　　及听佛正法
  二俱得福多　　能建诸仙幢

尔时世尊复告阿难。有二种人共魔波旬极大战诤。何者为二。一者至心为说。二者专心勤听。何以故。阿难。如是梵行得满足者。谓善知识及善等侣善心流注。何以故。阿难。若有众生遇善知识。遇知识已从生得解脱。乃至老病死忧悲苦恼法而得解脱。阿难。此事我昔告诸声闻。有二因缘能生正见。一者从他闻法。二者内正思惟。从他闻者当知从佛所闻。内正思惟者亦从佛知。何以故。阿难。如诸凡夫佛未出时。自无内正思惟。佛出世已。教诸凡夫作如是事。阿难。我观是义故作是说。内正思惟亦从佛生。尔时世尊说是偈言

  善哉妙丈夫　　得见增诸智
  若有断疑者　　令凡得明慧
  见圣者得乐　　共居亦得乐
  不见诸凡愚　　如常有乐者

是故阿难。我为是义随宜演说梵行满足者。诸善知识及善等侣。能生善心相续流注。何以故。阿难。若有众生遇善知识得生善心。生善心已心则得信。心得信已所作皆善。所作善已则得善法。得善法已安住善法。住善法已。于佛世尊深得敬重。于法僧所亦深敬重。当得圣所爱戒。自在戒。智所赞戒。趣涅槃戒。阿难。如云降雨小坑满。小坑满已大坑满。大坑满已小河满。小河满已大河满。大河满已大海满。如是阿难。若有善男子善女人。于诸佛所闻佛说已得善根力。得善根已近善知识。近 善 知识已得善等侣。得善等侣已得善流注。得善流注已得最胜善。得最胜善已得善心。得善心已乃至如法顺法发心修行。究竟转究竟无垢。究竟梵行究竟最后。阿难。汝观如是一切外物同时生长。花果成时无有违失。何况汝等所作善行岂有违失。若有违失无有是处。是故阿难。汝等应当修行善行。无有众生修行善行。而不得果有违失者。阿难。我亦曾修一切善行无有违失。阿难。我本修行菩萨行时。所修一切诸善功德。所得果报无有违失。阿难。汝观如来所行道路。于彼所有丘陵坑坎高下平正。屏厕臭处清净香洁。株杌荆棘薮林丛草。秽恶隐没善好低首。树神现身倾侧礼拜。城邑巷路所有众生。见佛如来随佛而行。如来过后各还如故。阿难。汝观如来于过去世诸佛菩萨善知识所。声闻缘觉师僧父母。耆年长宿沙门婆罗门。倾侧稽首获得如是最胜果报。一切外物见诸佛已应低首者即便低首。高者令下下者令高。高下诸处皆悉平正。阿难。汝观一切愚痴凡夫。于诸尊长不修恭敬。亦不礼拜憍慢自恃。为慢所害为慢所缠。阿难。汝观如来网缦手足。一切皆以善行所得。阿难。汝观如来本修善行。布施爱语利行同事。以此善行摄护众生。不作分别此是我父此是我母。兄弟姊妹亲戚善友。阿难。我于众生一味平等心无差别。阿难。我于久远无有众生。而不摄受布施爱语利行同事。如是摄护愚痴凡夫。然彼不知以已善根福德因缘。生死本际受诸果报。阿难。我于众生与其善根所得福乐。多于自身修诸善业所得果报。阿难。一切世间所有乐具。皆悉无常是变易法。如此乐具是无常故。我本修行菩萨行时。为诸凡愚成熟佛道。令得无为圣无漏乐。是无漏乐。常不变易更不败坏。是故阿难。如是圣智当修诸业。如是圣智修诸业者。是名正业。如是阿难。我本亦曾以此圣智修诸善业。阿难我亦更说诸余善行。若有众生为涅槃故。乃至发心作少善根种诸种子。闻佛如来说诸妙法。深解义趣忆念如来。心生爱敬有抆泪者。长叹者毛竖者。若堕地狱畜生饿鬼。无有是处。若于菩提不得究竟。亦无是处。阿难。复有众生忆念如来。于法觉悟有流泪者。毛竖者叹息者。阿难。莫作异观。彼诸众生堕于恶道地狱畜生饿鬼中者。无有是处。是故阿难。汝莫放逸。应勤方便修诸善业。阿难。诸佛世尊以不放逸得证菩提。及助道法亦以不放逸故得。阿难。若有如是善受教者。求利益者。求安乐者。求怜愍者。起悲愍心。应如是作。所应作者我已作竟。汝等今者亦应当作。勿令如是真道断绝。又复勿令佛正法眼而有隐没。阿难。汝应如是令佛法眼使得久住。各于人天广行流布。阿难。我今以是正法宝藏。付嘱于汝勿令毁灭。应如是作。是我教法

    大悲经教品第十四

尔时慧命阿难白佛言。世尊。我今云何修行法眼。若我修行佛正法眼。云何久住于诸天人广行流布。世尊。我复云何结集法眼。云何显说。作是语已。佛告阿难。我灭度后。有诸大德诸比丘众集法毗尼时。彼大德摩诃迦叶最为上首。阿难。时彼大德诸比丘众。当如是问。世尊何处说大阿波陀那。何处说摩诃尼陀那。何处说大集法。何处说五三法。何处诸天来问。何处天帝释问。何处诸天来下。何处说梵网经。如是次第。彼诸比丘复当问汝。阿难。佛在何处说修多罗。何处说祇夜。何处说毗耶迦罗那。何处说伽陀。何处说忧陀那。何处说尼陀那。何处说伊帝毗利多迦。何处说阇多迦。何处说毗弗略。何处说阿波陀那。何处说阿浮陀达磨。何处说忧波提舍。阿难。佛在何处说声闻藏。佛在何处说缘觉藏。佛在何处说菩萨藏。阿难。时彼比丘如是问已。汝应如是答。如是我闻。一时佛在摩伽陀国菩提树下初成正觉。如是我闻。一时佛在伽耶城。如是我闻。一时佛在摩伽陀国。阿阇波罗尼拘陀树下修苦行处。如是我闻。一时佛在波罗捺仙人住处鹿野苑中。如是我闻。一时佛在耆阇崛山。如是我闻。一时佛在毗富罗山。如是我闻。一时佛在摩伽陀国鞞提诃山。如是我闻。一时佛在王舍城仙人山中大黑方石。如是我闻。一时佛在舍卫国祇树给孤独园。如是我闻。一时佛在毗舍离城庵罗树园。如是我闻。一时佛在毗舍离猕猴池边。大林精舍重阁讲堂。如是我闻。一时佛在瞻波城竭伽池边。如是我闻。一时佛在伽耶城伽耶山顶。如是我闻。一时佛在拘睒弥国瞿师罗园。如是我闻。一时佛在 娑枳 多城阿踰阇园迦罗迦林。如是我闻。一时佛在释种住处迦毗罗城尼拘陀园。如是我闻。一时佛在波离弗城鸠鸠吒园。如是我闻。一时佛在摩偷罗城频陀林中。如是我闻。一时佛在拘尸那城力士生地。阿利罗跋提河边娑罗双树间。阿难。以如是次第在在处处佛所说法。在在处处大众所集。随其时节随其句义随其因缘。随其问答发起因缘。随所为人随所为事。为欲分别显其智故。随其名味句义次第种种演说。随彼由绪有因有缘。善义善味广为人说。佛说经已。一切大众皆大欢喜顶戴奉行。阿难。汝应如是结集法眼。如是分别种种显说。如来应供正遍知。说如是语。如是我闻一时已大地极恶六种震动。甚大可畏令人毛竖。当于尔时此三千大千世界。六种震动现十八相。东踊西没。西踊东没。南踊北没。北踊南没。中踊边没。边踊中没。十八相者。动遍动等遍动。踊遍踊等遍踊。震遍震等遍震。吼遍吼等遍吼。起遍起等遍起。觉遍觉等遍觉。当于尔时无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵护世人非人等。悲啼流泪作如是言。婆伽婆涅槃太速。修伽陀涅槃太速。世间眼目隐没太速。世间盲冥无目太速。慧命阿难。悲啼流泪亦作是言。婆伽婆涅槃太速。修伽陀涅槃太速。世间眼目隐没太速。世间盲冥无目太速。世间导师隐没太速。尔时世尊复告。阿难。汝莫忧悲。一切有为生法有法。分别法觉知法。因缘生法灭坏法。若不坏者无有是处。阿难。汝于长夜以身口意慈孝如来。无量安乐心无有二。无嗔无恨无有怨嫌。阿难。汝以如是当得大神通大功德。广大无量犹如甘露第一甘露尽甘露际。是故阿难。汝于梵行亦复应当以身口意恭敬供养。亦当如我应如是学。何以故。阿难。我灭度后于未来世。法欲尽时最后五百年。持戒朋党正法朋党将欲尽灭。破戒非法朋党炽盛。诽谤正法寿命短促。众生坏时。法灭坏时比丘僧坏时。阿难。当于尔时惊畏恐惧。有诸比丘。不修身不修心。不修戒不修慧。彼等不修身戒心慧者贪着六处。何等为六。一者贪着钵。二者贪着衣。三者贪着食。四者贪着床座。五者贪着房舍。六者病瘦因缘贪着汤药。彼等贪求胜妙衣钵。乃至上好众味药故。更共斗诤迭相言讼。上至官司口如刀剑。互相诽谤迭共憎嫉。如是为彼衣钵饮食床座房舍汤药因缘。共相憎嫉心不纯熟浊心相向。是故阿难。汝于梵行身口意慈。当好供给具足供养。于诸梵行。若见若闻若粗若细若信若行。当于彼所莫起恼乱。应如是学。何以故。阿难。当于尔时极大怖畏。命浊劫浊众生浊见浊烦恼浊。俗人尔时极受诸苦。为苦所中为苦所恼。为极饥馑为极病疫。为贼所恼亢旱水灾。为诸螽虫种种恼触。阿难。时彼婆罗门长者居士。虽复如是为苦所恼为苦所切。犹有净信恭敬尊重于佛法僧。数数得生具足深信。彼以信佛法僧因缘。于一比丘亦生深信。修行布施作诸功德。受持禁戒读诵受持。为人解说有听受者。得闻法已心生爱敬欢喜踊悦。如法修行种诸善根。以此善根身坏命终。得生善道诸天人中。阿难。汝观如是诸恶比丘。当以信心舍家出家。得出家已贪着衣钵。六种因缘堕三恶道。在家俗人为苦所恼尚生敬信。以信善根得生善道。是故阿难。应正身律仪口律仪。意律仪。当作是念。愿我敬信速得具足。愿我深心正直具足。愿我身心具善思惟。何以故。阿难。身口意业不善思惟。有五种过。何者为五。一者妄语。二者两舌。三者绮语。四者贪欲。五者身坏命终。堕三恶道生地狱中。阿难。善思惟者。当得五种功德利益。何者为五。一者不妄语。二者不两舌。三者不绮语。四者不贪欲。五者身坏命终。得生善道诸天人中。复次阿难。若人斗诤毁呰言讼违竞相对。心不调柔浊心变坏者。有五过失。一者妄语。二者两舌。三者于诸持戒不生敬信。四者昼夜忧苦恶意而住。五者身坏命终堕三恶道生地狱中。阿难。若复有人心住慈善。当得十一种功德利益。何者十一。一者睡眠得安隐。悟则心欢喜。二者不见恶梦。三者人非人爱。四者诸天拥护。五者毒不能害。六者刀箭不伤。七者火所不烧。八者水所不溺。九者常得好衣肴膳饮食床座卧具病瘦汤药。十者得上人法。十一者身坏命终得生梵天。阿难。心住慈善。得此十一功德利益。是故阿难。若我现在及灭度后。自然法灯自作法归。莫求他灯莫求他归。阿难。云何比丘自然法灯自作法归。不求他灯不求他归。阿难。若有比丘观内身。循身观勤精进。系念一心除世贪忧。如是观内身。循身观观内受内心内法。勤精进系念一心除世贪忧。阿难。是为比丘自然法灯自作法归。不求他灯不求他归。是故阿难。我为导师于诸声闻。所应作者我已作竟。汝等今者应如是作。此是我之教法。当于阿兰若处。冢间树下空舍露地。应当一心勤修止观。思灭苦本慎莫放逸。汝若放逸后必忧悔。尔时世尊。说是偈言

  我已说正道　　拔诸无智箭
  汝今应勤修　　诸佛所说法
  为净诸见故　　除此更无道
  修者得解脱　　能断诸魔缚
  若能修此行　　如佛之所说
  能度一切苦　　得满诸佛愿

尔时世尊说是经已。慧命阿难及诸比丘诸来大众。及诸天人阿修罗乾闼婆一切世间。闻佛说已随顺悲喜。举手拍头椎胸号叫。悲啼流泪顶戴奉行

大悲经卷第五


大方等无想经

    No. 387

大方等无想经卷第一

        北凉天竺三藏昙无谶译

    大云初分大众健度第一

如是我闻。一时佛在王舍城耆阇崛山中。与大比丘僧九万八千。大迦叶等而为上首。一切皆是大阿罗汉。诸漏已尽皆得自在。其心调柔如香象王。随顺善道心得解脱。智慧无碍舍离重担。所作已办永断诸有。所修禁戒清净微妙心到彼岸。威德巍巍有大名称。具足成就得八解脱。皆于晨朝从禅定起往至佛所。头面礼佛合掌恭敬右绕三匝。修敬已毕却坐一面。复有比丘尼众六万五千。摩诃波阇波提比丘尼而为上首。亦于晨朝从禅定起往至佛所。头面礼足合掌恭敬右绕三匝。修敬已毕却坐一面。复有菩萨摩诃萨六万八千。一切皆是大香象王。其名曰大云密藏菩萨摩诃萨。大云得志菩萨摩诃萨。大云电光菩萨摩诃萨。大云雷震菩萨摩诃萨。大云勤藏菩萨摩诃萨。大云爱乐菩萨摩诃萨。大云欢喜菩萨摩诃萨。大云性菩萨摩诃萨。大云金刚首菩萨摩诃萨。大云宝首菩萨摩诃萨。大云吼菩萨摩诃萨。大云名称菩萨摩诃萨。大云愿华菩萨摩诃萨。大云施雨菩萨摩诃萨。大云不轻菩萨摩诃萨。大云勤行菩萨摩诃萨。大云师子吼王菩萨摩诃萨。大云满雨心王菩萨摩诃萨。大云普光菩萨摩诃萨。大云正见菩萨摩诃萨。大云遍雨王菩萨摩诃萨。大云身通王菩萨摩诃萨。大云上妙菩萨摩诃萨。大云自在菩萨摩诃萨。大云大海菩萨摩诃萨。大云一切自在菩萨摩诃萨。大云福田菩萨摩诃萨。大云一切施安菩萨摩诃萨。大云日光菩萨摩诃萨。大云月光菩萨摩诃萨。大云琉璃光菩萨摩诃萨。大云无量贾菩萨摩诃萨。大云常见菩萨摩诃萨。大云我见菩萨摩诃萨。大云净见菩萨摩诃萨大云乐见菩萨摩诃萨。大云无碍菩萨摩诃萨。大云常胜菩萨摩诃萨。大云净光菩萨摩诃萨。大云得称菩萨摩诃萨。大云爱命菩萨摩诃萨。大云贾主菩萨摩诃萨。大云顺师菩萨摩诃萨。大云现道菩萨摩诃萨。大云护子菩萨摩诃萨。大云胜分陀利菩萨摩诃萨。大云火光菩萨摩诃萨。大云波头摩菩萨摩诃萨。大云优钵罗香菩萨摩诃萨。大云威德王菩萨摩诃萨。大云动摇菩萨摩诃萨。大云无所畏菩萨摩诃萨。大云多摩罗跋树叶凉菩萨摩诃萨。大云赤栴檀树凉菩萨摩诃萨。大云极深菩萨摩诃萨。大云知善师菩萨摩诃萨。大云那罗延大喜菩萨摩诃萨。大云大牛王菩萨摩诃萨。大云大树王菩萨摩诃萨。大云大法分陀利敷菩萨摩诃萨。大云执持法光菩萨摩诃萨。大云称王门菩萨摩诃萨。大云金山有德王菩萨摩诃萨。大云无怖王菩萨摩诃萨。大云大医王菩萨摩诃萨。大云大身王菩萨摩诃萨。大云虚空王菩萨摩诃萨。大云修发王菩萨摩诃萨。大云坏云王菩萨摩诃萨。大云坏风王菩萨摩诃萨。大云坏雨王菩萨摩诃萨。大云俾倪王菩萨摩诃萨。大云断闇王菩萨摩诃萨。大云断雹王菩萨摩诃萨。大云迦叶菩萨摩诃萨。如是等菩萨摩诃萨。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有五万八千梨车童子。其名曰师子光梨车。法德梨车。法羡梨车。释德梨车。释幢梨车。释幡梨车。师子吼梨车。宝铃声梨车。爱德梨车。名贵德梨车。金刚须梨车。佛奴梨车。如来奴梨车。世尊奴梨车。婆伽婆奴梨车。正觉奴梨车。世尊月奴梨车。大手梨车。大精进梨车。恒河得梨车。文殊师利梨车。弥勒梨车。大龙梨车。龙护梨车。法护梨车。广称梨车。虚空云梨车。恒河护梨车。金华梨车。电光梨车。大广面梨车。性广梨车。净光梨车。自在得梨车。自在地梨车。地鬘梨车。方等奴梨车。金刚奴梨车。如是等梨车。一切皆发阿耨多罗三藐三菩提心。守护大乘爱乐大乘。其所教化悉向大乘。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬毕已却坐一面复有四万四千天王。其名曰爱见天王。一切爱天王。月发天王。日色天王。长耳天王。青色天王。精进天王。深目天王。大黑天王。远慧天王。虚空目天王。爱德天王。爱须天王。爱称光天王。爱面光天王。一切喜念天王。琉璃光天王。光爱天王。半月天王。大声微妙天王。勇坏烦恼天王。一切爱天王。童子爱天王。曼陀罗华天王。无常天王。属昴星天王。如是等诸大天王。爱乐大乘广说大乘护持大乘。受持一切三昧总持。惠施众生安乐之事。亦于晨朝从禅定起往至佛所。头面礼足合掌恭敬右绕三匝。修敬已毕却坐一面。复有三万八千龙王。其名曰莲华龙王。德叉迦龙王。迦迦罗龙王。和修吉龙王。爱德鬘龙王。大地龙王。牙利龙王。净目龙王。师子龙王。蠡声龙王。鼓声龙王。金光龙王。金色龙王。黑须龙王。持大雨龙王。大海龙王。枳罗婆龙王。梵龙王。愿爱龙王。伊罗钵龙王。陀毗罗龙王。恒河龙王。辛头龙王。博叉龙王。私陀龙王。有德龙王。阿耨达龙王。钵售那龙王。人龙王。非人龙王。人头龙王。吉龙王。勋律龙王。毗舍罗龙王。蠡龙王。黄色龙王。难陀龙王。优波难陀龙王。毗楼勒叉龙王。提头赖吒龙王。毗楼博叉龙王。毗沙门龙王。半阇罗龙王。摩那斯龙王。如是等龙王。乐欲听受大乘经典。既得闻已欲为一切广宣分别。欲持正法守护正法。为护法故坚持禁戒荷法重担。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有三万六千夜叉神王。其名曰毗沙门鬼王。虚空鬼王。爱德鬼王。毕施鬼王。大璎珞庄严鬼王。一向视鬼王。动大地鬼王。善毛鬼王。善爱家鬼王。摩尼跋陀鬼王。满城鬼王。莲花光鬼王。车轮台鬼王。大海胜鬼王。如是等夜叉鬼王。随顺阿閦如来道行。为护正法受持禁戒。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬毕已却坐一面

复有四万九千金翅鸟王。其名曰力等香象金翅鸟王。坚固金翅鸟王。鼓声金翅鸟王。坏一切龙王力金翅鸟王。火光金翅鸟王。斑翅金翅鸟王。轮面金翅鸟王。恶性金翅鸟王。坏和修吉龙王眷属金翅鸟王。 坏和修吉眷属 大喜金翅鸟王。实见金翅鸟王。喜说大慈金翅鸟王法喜金翅鸟王。金翅爱金翅鸟王。如是等金翅鸟王。一切无有憍慢放逸。皆得爱护大乘之心。守护一切诸佛正法。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有六万八千乾闼婆王。其名曰喜乾闼婆王。自在歌乾闼婆王。现在爱乾闼婆王。牛王得乾闼婆王。云覆乾闼婆王。命命乾闼婆王。名名声乾闼婆王。如是等乾闼婆王。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有九万八千紧那罗王。其名曰善见紧那罗王。长鼻紧那罗王。引心紧那罗王。妻爱紧那罗王。坏烦恼紧那罗王。坏怨紧那罗王。魔王女爱紧那罗王。坏魔眷属紧那罗王。慧藏紧那罗王。深目紧那罗王。净贵德紧那罗王。调根紧那罗王。远见紧那罗王。如是等紧那罗王。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却座一面复有一万八千罗刹王。其名曰煮灰罗刹王。水牛头罗刹王。黄发罗刹王。差齿罗刹王。髑髅耳罗刹王。贪蜜罗刹王。蜜色罗刹王。大咽罗刹王。大饮罗刹王。以发覆身罗刹王。大力罗刹王。可畏色罗刹王。如是等罗刹王。一切皆断罗刹之想。纯以大乘调伏其心。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有三万八千陀那婆神王。其名曰象面陀那婆王。牙陀那婆王。支足陀那婆王。驴声陀那婆王。华耳陀那婆王。宝耳陀那婆王。鼠得陀那婆王。狸得陀那婆王。鼠狼疑陀那婆王。猕猴面陀那婆王。月面陀那婆王。如是等陀那婆王。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有七万八千鸠槃茶王。其名曰象耳鸠槃茶王。箕耳鸠槃茶王。大肥鸠槃茶王。如是等鸠槃茶王。皆已舍离鸠槃茶想。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有三万八千饿鬼王。其名曰电光明王。大施王。一切羡王。箭王。大海涛波王。如是等王。悉皆爱乐大乘经典护持正法。常为众生广宣分别。渴仰大乘饥虚大乘贪慕大乘。纯以大乘以自庄严。常发誓愿得戒得慧。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有八万八千阿修罗王。其名曰毗摩质多阿修罗王。富娄那阿修罗王。念国阿修罗王。净恒河毗纽阿修罗王。利安阿修罗王。象咽阿修罗王。三角山阿修罗王。灰发阿修罗王。大恶性阿修罗王。火光阿修罗王。如是等阿修罗王。皆悉舍离阿修罗想。其心调伏永离憍慢无有放逸。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有六万五千大神咒王。其名曰宝持王。无尽意王。无尽财王。无碍王。不对王。如是等大神咒王。爱重大乘。乐说大乘。拥护大乘。渴仰大乘。贪慕大乘。得大乘定。具平等行。常欲除断所有疑心。为护正法受持净戒。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有九万九千五通 仙人 。其名曰那罗他仙人。锐浮罗仙人。跋弥迦仙人。善奴仙人。竭伽仙人。太白仙人。荧惑仙人。鹿角仙人。鹿目仙人。离慢仙人。婆私吨仙人。欢喜仙人。五阴仙人。劫初仙人。大云色衣仙人。天衣仙人。憍尸迦仙人。颇罗堕仙人。龙声仙人。有德得仙人。断肉仙人。施一切命仙人。如是等五通仙人。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有天帝释与无量无数三十三天。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有四天王。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有舍卫国主波斯匿王。与诸小王庄严四兵。是诸王等。爱重大乘。乐说大乘。渴仰大乘。为护正法受持净戒。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有五万三千诸大长者。须达多等悉受五戒。皆发阿耨多罗三藐三菩提心。爱重大乘。渴仰大乘。贪慕大乘。为护大乘受持净戒。为众生故随顺菩提。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却住一面

复有瞻婆国主名曰月护。与诸小王受持五戒。一切皆发阿耨多罗三藐三菩提心。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有十六大国。鸯伽陀国。摩伽陀国。迦尸国。拘萨罗国。跋耆国。摩罗国。分陀国。须摩国。阿摩国。阿槃提国。拘留国。半时罗国。 跋嗟 国。首罗先那国。夜槃那国。剑 蒲 阇国。如是十六诸大国土。其中所有一切众生。皆发阿耨多罗三藐三菩提心。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有末利夫人。与一万六千诸夫人等。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有一万八千。优婆夷毗舍佉等。一切皆发阿耨多罗三藐三菩提心。爱乐大乘。渴仰大乘。为护正法受持净戒。为欲集助无上道法修菩提道。一切皆得不退转心。为度众生现受女身。常乐宣说大乘经典。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有自在天子。与无量天众现大神变放五色光。所持诸华如须弥等。所谓优钵罗波头摩拘勿头分陀利。香华大香华。微妙华大微妙华。爱见华大爱见华。时华常华。曼陀罗华摩诃曼陀罗华。及持诸香。所谓栴檀香花香馥迦香。及诸伎乐。复持诸华大如车轮。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有梵天[髟-(彰-章)+累]髻梵等。无量梵俱放五色光。其光能坏耆阇崛山所有众生贪欲黑闇。持种种香杂华伎乐来至佛所。王舍大城耆阇崛山迦兰陀竹林。其地纵广足一由旬。天衣遍覆间无空处。所谓憍尸迦衣。迦陵伽衣。刍摩衣。拘锐婆衣。复敷七宝师子之座。座高百万八千由旬。设此供已右绕如来满三十匝。脱身宝衣以覆佛上。发如是言。唯愿世尊。为众生故当雨法雨。时虚空中复出大声。世尊。一切众生虽得听闻常乐我净。而不能解。唯愿如来。敷演解说。复有无量鹅王。师子鹅王等。持诸种种华香供具。以用供养宝师子座。复有无量孔雀王。善目孔雀王等。持诸香华微妙妓乐。以供养佛。复有无量拘枳罗鸟王。善行王等。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有雪山迦兰陀鸟王莲华王等。持诸香华。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有无量命命鸟王无碍王等。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

复有无量山王须弥山王。而为上首。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面复有香山诸药草王忍辱王等。亦于晨朝从禅定起往至佛所。头面作礼合掌恭敬右绕三匝。修敬已毕却坐一面

尔时所有一切树木常出华果。一切伎乐无掁触者。自然演出微妙音声。时雪山中所有师子诸恶兽等。慈心相视如母如子。复有一切蚊虻毒虫。皆得慈心亦如一子。诸恶鸟等亦复如是。复有四种毒蛇。所谓视毒嘘毒啮毒触毒。亦得慈心。及十六种诸恶律仪亦复如是。诸恶众生悉受五戒。尔时一切大众。悉共受持清净戒行。乐欲听受大乘经典。恭敬大乘拥护大乘。呵责诽谤大乘经者。见有受持恭敬供养

尔时大云密藏菩萨摩诃萨。即从坐起偏袒右肩为佛作礼长跪合掌白佛言。世尊。此诸大众咸有疑心。我今欲问。唯愿听许。佛言。善哉善哉。善男子。我今能破此众疑心。恣汝所问。大云密藏菩萨言。世尊。菩萨摩诃萨云何修行得陀罗尼。云何能得大海三昧。云何能解诸佛实语。云何得知具足法味。云何得见微密之藏。云何得入安隐之处。亦得睹见如来常住。云何能得如来宝藏。永断众生贫穷困苦。云何能解诸佛如来甚深之义。云何能到诸佛如来大海彼岸。云何菩萨得入诸佛如来境界。云何菩萨护持诸佛所有幻法。云何菩萨得如来法得已能说。云何能知一切法界。云何得佛日身月身彗星之身。云何得尽如来边际。云何能得诸佛净业。云何逮得如来所行。云何得佛甚深净池。云何得佛分陀利华。云何得佛自在之力。云何能得诸佛财货。云何能见如来实相。云何见佛常住不变。云何能得如来金色。云何菩萨得佛法王。云何能得金刚法身。云何得佛常身常声。云何菩萨得到如来所安之处。而无安想。云何见于诸佛如来常乐我净。而非恶见。云何如来真实生身。真实法身。云何如来金刚之身。破坏杂身。云何见坏身而名为真见。云何如来身不名为血肉筋骨所成立。若有如是身。云何为空见如来说法时。云何有所获。云何说法时。俱闻无所获法。若无所有。云何复得说如来真实常。云何入于涅槃若不入涅槃。云何名实语戒。若无净秽。云何赞持戒者。佛法若无灭。云何说法灭。复言法灭时多有毁禁者。如来佛性净上净毕竟净。其性如是者。云何乐生死。云何诸菩萨常说生死乐。云何诸菩萨乐见如来性。云何烦恼常。云何爱烦恼。云何复得入一切烦恼门。云何能得修一切佛土业。云何得善知烦恼之根本。云何诸菩萨善能得除灭于佛所起疑常乐我净心。若无疑心者。云何畏生死。若畏于生死。云何复乐着。云何得佛道。云何转法轮。云何度众生知不断佛性。云何治魔众使离魔境界。云何度众生生死大苦海。云何说生死示导生死道。云何得生死无量之大海。云何求生死渴仰生死道。云何贪生死吝惜不放舍。云何开生死犹如分陀利。云何烦恼结犹如四大海。云何诸烦恼常起如发愿。云何而得地狱之心。云何常求地狱之心。云何修集地狱戒禁。云何滋息地狱业行地狱之身。刀剑弓箭锥銏轮火。云何能破坏众生地狱果。云何为地狱众生作安乐。云何注大雨能灭地狱火。云何处地狱而不受其报。云何为地狱而作船导师。云何为地狱而作大良药。云何而能得闭塞地狱道。云何作慧灯坏于生死闇。云何在生死烦恼毒不污。虽住无所住。而不同空住。能消诸烦恼。犹如日照雪。见于如来常乐我净。其心安住如须弥山。不动不转如帝释幢。如来实不毕竟涅槃。亦说如来入于涅槃。其心不坏犹如金刚。云何得惭愧。云何得好身。云何复能得众所爱敬身。云何得不贪。云何得不嗔。云何能得微妙光明。云何得正性。云何得自在。云何能得大众眷属。云何能得不坏眷属。不退不失不贪饮食。常修知足终不食肉。于诸众生常生爱心。常为世间之所恭敬。得名一切大施之主。得名大力。得名健行。大慈大悲大舍大喜。大慧总持。随顺世间。为安世间。为乐世间。云何而得世间无上世间无胜世间无边。常行正语修行梵行。行大悲行喜行圣行。见空法界随顺而说。见不空界说亦如是。说佛法相见佛真法。得净自在持戒之财。德财法财不食之财。为贫众生得财藏身。为诸众生得三种定空无相愿。欲生净土得随愿身。虽为众生受此阴身。不于众生求其恩报。赞叹持戒呵破戒者。不为群邪之所沮坏。虽读外典不随其义。其所说法句义不断。虽名沙门及婆罗门。终不生于沙门之想婆罗门想。虽复晓了算数咒术。心初未曾有贪着想。虽为众生示入天寺。供养恭敬依止礼拜。而其内心常依法界。现行十恶实是梵行。诸佛护念如视一子。善能护持诸佛法身。能转一切诸佛法轮。深见诸佛甚深法界及真实相。其所修行等诸佛行。得无量身及无量行。善解诸佛所有语密。除去憍慢犹如诸佛。善说法界深密之义。虽说憍慢无憍慢想。亦不教他生于憍慢。心无贪恚愚痴怖畏。犹如诸佛。其行无量微密无量。诸法无量。乐说无量。性相无量。真实无量。见真见实见性见法。为诸众生断烦恼故而演说法。常得知见诸佛世尊。永度烦恼诸结大海。为度众生故说度烦恼诸结海法。自得度已度未度者。自得脱已脱未脱者。自得安已安未安者。未涅槃者令得涅槃。自见法界了了真实。或为众生说实不实。于无量劫已坏四魔。为众生故现处道树方降魔众。内实知见久破诸魔。为众生故唱言今坏。以善方便转于法轮。以善方便现入涅槃。云何能得诸佛神通。云何得佛如来法王。云何得佛微密法藏。云何得佛不可思议。云何能得诸佛无量无称无数无胜无边。云何能施一切众生甘露法味

尔时世尊告大云密藏菩萨言。善哉善哉。善男子。汝今所问甚为快善。为欲安乐世间众生故发斯问。一切众生无明所盲。而不能知诸佛所有真实功德。善男子。汝今欲令一切众生。悉得智慧眼常眼常光。永度生死烦恼大河。了知诸佛菩提之行。欲坏众生无明结[穀-禾+卵]。示导无上菩提之行。一切众生。常乐演说无常无我无乐无净。而今欲开常乐我净。如来毕竟入于涅槃。无常无我无乐无净。而今欲开诸佛世尊不毕竟灭常住不变。善男子。一切众生。常于法界妄生分别。而法界性实无分别。汝今欲问无分别义。是故发问。善男子。一切众生。常为邪毒之所涂染。如来世尊为大良医。汝意欲令如来医王说咒授药疗其所苦。善男子。如遮罗迦梵志及尼干子诸婆罗门。实非罗汉作罗汉想。非圣圣想。非天天想。实非常乐我净之法。而作常乐我净之想。汝今欲为如是众生拔邪毒箭。解邪缚破邪狱出邪网。施法味食甘露。安寝四禅涂净戒香。四等为华惭愧为衣。故发此问。善男子。一切众生不知总相不知别相。相无相。非相非无相。非相相非无相相。不可知非不可知。非此非彼。非手非指。非此彼中。非作非不作。非示非不示。非因非不因。非瞬非不瞬。非知非智知。非识非识识。非住非不住。非闇非明。非相非名。非轻非重。非羸非力。非处非不处。非净非不净。非有为非无为。非有非无。非可说非不可说。非取非舍。不生不退。非实非虚。非正非邪。非毕竟非不毕竟。非福田非不福田。非时非不时。非可净非不可净。非作非能作。非生非灭。非冷非热。非阴入界。非结因非业因。非生非堕。非长非增长。非有堕落毕竟无堕。非是有法永断诸有。非过去非未来非现在。非实非不实。非性非不性。非色非受想行识。非尽非不尽亦不可尽。非等非无等亦无与等。非地水火风。一切法界实无有身。实相之相毕竟真实。是名如来。无量无边不可思议。诸大功德之所成就。如是身者。即是诸佛真法身也。其义甚深不可思议。如来法界深邃幽远。不移本处宣说正法。十方诸佛皆得闻知。所以者何。如来自在神力行故。如是深语。声闻缘觉所不得闻。善男子。诸佛何故。不为彼说令彼得闻。善男子。声闻缘觉乃至不解一字之义。犹如生盲饮毒狂人。如蚕处茧。如被毒箭。如病痰饮。是故诸佛不为说之。善男子。一切众生。常为诸结烦恼所病。诸佛如来能施法药。以妙咒术拔其毒箭除其肤翳。众生真实不知如来常住不变。如来为然智慧法灯。悉令得见常乐我净。譬如日出。悉令众生普见大地高下等相。如来亦尔。一切众生。不知方等。亦不能得总持三昧。不知佛时。不知佛财。不见佛身。不解如来涅槃之相。不知佛法灭与不灭。而言如来无常无乐无我无净。有烦恼箭是杂毒食。是故我为如是等人。演说诸佛常乐我净。欲除此人无明黑闇。善男子。善哉善哉。声闻缘觉未曾得闻是一字义。汝今欲令彼得闻故。故发是问。谛听谛听。善思念之。吾今为汝分别解说。有大方等甘露经王。开大宝藏赈给贫穷。启发诸佛功德之藏。一切众生皆有佛性其性无尽。昔来隐蔽今欲显示。诸佛如来然大慧灯。令诸众生了了明见。善男子。吾将欲说汝便发问。副汝昔来所发誓愿。大云密藏菩萨摩诃萨言。世尊。我从昔来实无此愿乃是世尊大慈愍事神通力故。为度众生令我发问。欲破众生贫穷困苦。令诸众生意无尽故。如来今说。则能消灭一切众生无明大闇得智慧宝。令诸众生明见佛性。得见如来常乐我净。佛言。善哉善哉。善男子汝今所问其义甚深。为度众生生死海故。为广流布方等经故。为常法故。惠施一切甘露法味。除断众生贫穷苦故。谛听谛听。吾当为汝分别解说。令诸众生得安乐故。汝今当为一切众生善持是义。善男子。一切如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。等有一法名曰法界。以此法界诸佛世尊等有常慧。以常慧水净自洗浴。服甘露味并以惠施一切众生。修集一切诸佛所行。汝今当服是甘露味。汝既服已复当转施。我今当说汝便善听。初语亦善。中语亦善。后语亦善。其义真实言辞巧妙。其音清净纯一无杂。具足清白梵行之相

大方等无想经卷第一大方等无想经卷第二

        北凉天竺三藏昙无谶译

    大云初分大众健度余

善男子。有大云经总持大海三昧大海。如来法印诸佛法城。法界甚深常住不变。不可思议常乐我净。善男子。若有受持书写读诵解说之者。则能破坏众生烦恼。断除一切贫穷困苦。若遭饥荒谷米勇贵。读诵是经则得丰壤。若时焰旱天则降雨。若有饥虚渴仰法食。读诵是经则得总持甘露法味。若欲具足大神通者。当受是经。欲雨法雨润渍枯槁。当读是经。若遭大病亦当受持。所以者何。此经即是一切大病之良药也。此经能断一切诸毒。大陀罗尼是大三昧。此经即是涂末烧香微妙净华。善男子。汝今当然大智慧灯。破诸众生狂愚黑闇。而诸众生常言。如来无常无我无乐无净是磨灭法。如是众生即是饮毒被大毒箭。澹饮发动狂醉失心无明所覆。声闻缘觉如羸老牛。是故汝当广宣分别如来功德。以实相油润益慧灯。开发慧眼除无明闇。若言如来真实出生输头檀舍。出家学道修集苦行坏魔兵众。坐于道场成菩提道。当知是人即是谤佛。宁当断首拔出其舌。不应出此虚妄之言何以故。非是善解诸佛如来秘密语故。若经中言沙门瞿昙。当知是语即是密语。善男子为众生故示现神足。当知即是佛之真子。善男子。汝则已为得大果报。授与声闻辟支佛等。吐药下药熏药眼药治诸病药。何等是药。所谓大乘方等经典。当知是经即是诸经转轮圣王。何以故。是经典中宣说众生实性佛性常住法藏。众生不解乃至一句一字。汝今当听。听已即当为汝法藏。汝复当观是经境界。善男子。此经中有诸佛菩萨四百不可思议解脱法门。善男子。此经中有诸法宝藏神通王三昧门。善男子。此经典中有诸菩萨三十六不退智慧宝藏陀罗尼门。善男子。此经复有诸佛菩萨三十三种入众生音大行方便解脱法门。善男子。此经复有诸佛菩萨十种神足入密行藏大行光王法门。此经复有诸佛菩萨十种生死行业道地。得心定解脱慧愿藏法门。此经复有诸佛菩萨十智不灭入思惟神通王法门。此经复有诸佛菩萨十种不生思惟法藏得入神足王法门。此经复有诸佛菩萨甚深十智入无畏行法王法门。此经复有诸佛菩萨十种大云见法不可思议功德藏法门。此经复有诸佛菩萨入十种众生语言修大行法方便不断解脱法门。此经复有诸佛菩萨十种神通所入生行有行行藏光王法门。此经复有诸佛菩萨十种生死烦恼业行心住三昧解脱誓愿法藏法门。此经复有诸佛菩萨十种智住不可思议所入神足王法门。此经复有诸佛菩萨十种不生不可思议通达密藏神足王法门。此经复有诸佛菩萨十智甚深入精进行法门。此经复有诸佛菩萨十智大云众法和合神足王法门。此经复有诸佛菩萨大云光明眼目法门。此经复有诸佛菩萨十种大云电光具足入行法门。此经复有诸佛菩萨通畅大云大乘经法门。此经复有诸佛菩萨神足变现灯明法门。此经复有诸佛菩萨十种法雹说神足王所入法门。此经复有诸佛菩萨十金刚智入藏法门。此经复有诸佛菩萨十种正行性入法门。此经复有诸佛菩萨十无尽行神通王所入法门。此经复有诸佛菩萨十种甚深微尘业行所入法门。此经复有诸佛菩萨十种师子吼所入法门。此经复有诸佛菩萨十生和合行入世间业狭心法门。此经复有诸佛菩萨十神通宝所入法门。此经复有诸佛菩萨十金翅鸟神通所入法门。此经复有诸佛菩萨十大施时微妙王法门。此经复有诸佛菩萨十无所畏大力神通所入法门。此经复有诸佛菩萨十大海行所入法门。此经复有诸佛菩萨十种至心所入法门。此经复有诸佛菩萨十勇猛王大力微妙法门。此经复有诸佛菩萨十种善行大神通王所入法门。此经复有诸佛菩萨十二神通藏得开示法门。此经复有诸佛菩萨十智宝藏法门。此经复有诸佛菩萨十智境界行所入法门。此经复有诸佛菩萨十正智微妙宝藏法门。此经复有诸佛菩萨十种福田种子法门。此经复有诸佛菩萨十种真实神通安乐之王所入法门。善男子。汝观是经不可思议。功德境界亦不可思议。乃是诸佛菩萨不可思议不可量法藏。亦是众生不可思议无尽宝藏。复次善男子。此经境界不可思议。善男子。此经复有诸佛菩萨陀罗尼藏法门。此经复有诸佛菩萨如来微密宝藏法门。此经复有诸佛菩萨如来大海法门。此经复有诸佛菩萨如来时藏法门。此经复有诸佛菩萨如来世藏法门。此经复有诸佛菩萨如来日藏法门。此经复有诸佛菩萨如来月藏法门。此经复有诸佛菩萨如来境界法门。此经复有诸佛菩萨甚深法门。此经复有诸佛菩萨如来无所畏法门。此经复有诸佛菩萨如来 勇揵 法门。此经复有诸佛菩萨如来地法门。此经复有诸佛菩萨如来法门。此经复有诸佛菩萨阿梨呵法门。此经复有诸佛菩萨如来聚法门。善男子。汝观此经大法陀罗尼。即是一切众生无尽福藏。是即诸佛不可思议解脱三昧陀罗尼门。非是汝等所知境界。诸佛世尊随世故说。其义甚深难可消服。唯是如来之所知见。我今当说如来如是甚深境界。至心谛听。汝从昔来于是事中。乃至未闻一字一句。大云密藏菩萨摩诃萨言。实如圣教。世尊。我犹虻蚁。常为一切无明所闇。唯愿如来。开慈愍心广及众生。宣说一句乃至一字。如来法王不可思议。世尊。声闻缘觉犹如老牛。盲聋喑哑如婴孩儿。我亦如是。从昔已来实未曾闻如是一句乃至一字。唯愿如来。广开大慈为众生故。诸佛如来所有境界不可思议。常住无变通达诸法。 惟 愿如来。为我等故及诸众生。开阐如是秘密之藏。乃至一字一句之义。令我等辈及诸众生知见如来常恒不变。佛言。善哉善哉。善男子。汝今已为善解诸佛所有密语。善男子。是方等经不可思议。汝所发愿亦不可思议。诸佛如来陀罗尼法不可思议。此经境界亦不可思议。甚深智光不可思议。善男子。如汝所言。我于是经不能解了。犹如老牛盲聋喑哑婴孩小儿。善男子。汝今不应生此忧惧疑虑之心。善男子。若行若住若坐若卧。常应系念如是经典。若遇水火盗贼诸难。亦应坚持慎勿放舍。所以者何。是经典中有五文字其义甚深。一者如来二常三乐四我五净。是名如来无上功德不可思议。复次善男子。假使恒河沙等十方世界满中大火。有人在中念是经者火不能烧。常应供养尊重三宝。勿令其心中有忘失。汝今所有微妙功德。已为诸佛之所赞叹。所谓能问所未曾闻。一句一字甚深之义。汝等不久亦复当得知见是义。汝若欲知诸佛如来常恒不变。应当受持如是经典。读诵书写解说其义。何以故。是经所说不可思议。如来常恒无有变易。终不毕竟入于涅槃。汝当广为一切众生。敷扬解说常乐我净。诸佛如来无有毕竟入涅槃者。法僧常住亦无灭尽。尔时毗蓝大毗蓝风王。所受乐报如天无别。放清凉风六时无变。华果常有无时暂替。赍持供具来至佛所。头面作礼合掌恭敬。右绕三匝却坐一面

尔时世尊神通力故。起四黑云甘水俱遍。兴三种雷。谓下中上。发甘露声如天伎乐。一切众生之所乐闻。尔时世尊即说咒曰

竭帝　波利竭帝　僧竭帝　波罗僧竭帝波罗卑罗延坻　三波罗卑罗延坻　婆罗婆罗　波沙罗　波娑罗　摩文阇　摩文阇　遮罗帝　遮罗坻　波遮罗坻波遮罗坻　三波罗遮罗坻比提嘻利嘻梨　萨隶醯　萨隶醯　富嚧富嚧莎呵

若有诸龙闻是神咒。不降甘雨头破七分。尔时十万亿那由他阿僧祇等。诸佛世界六种震动。尔时众生因是地动。各各相见展转相动。乃至净居。净居动已龙云俱动。龙云动时降澍大雨。时阎浮提所有九万八千大河七宝盈满。一切泉池具上药味。雨虽七日无所伤损。众生快乐如服甘露。诸河盈满八功德水。所谓美冷轻软清净香洁。饮时调适。饮已无患。一切水虫出微妙声。时王舍城耆阇崛山。七宝遍地无空缺处。虚空复雨七宝所成优钵罗华波头摩华拘勿头华分陀利华。水性之属悉发阿耨多罗三藐三菩提心。畜生众生贪乐大乘渴仰大乘。慈心相向犹如一子。皆共同心供养于佛。尔时大众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。持诸供具华香伎乐供养于佛。时虚空中复雨种种香华宝衣。伎乐幡盖供养于佛。善男子。此经乃是无量功德之所成就。是故能致如是瑞应。尔时大众作如是言。世尊。我今始知诸佛如来常乐我净。惟愿如来。慈哀矜愍。受我所献优多罗僧。即叹颂曰

  如来真实常　　无量德所成
  我今为常乐　　是故稽首礼
  诸佛舍无常　　故得无边身
  无上天中天　　大力难思议
  如来常无变　　勤进无边身
  为众雨法雨　　犹如大云王
  佛自得安乐　　为众说安乐
  自获诸功德　　诲彼令同己
  如来慧无胜　　常住如虚空
  为众作福田　　常行于圣行
  怜愍诸众生　　亦知其行业
  开示秘密藏　　清凉如初月
  今宣大云经　　端严如满月
  定知无量众　　发起菩提心
  世尊号法王　　于法得自在
  是故名真我　　成就无上乐
  如来升宝座　　而作师子吼
  宣说诸众生　　一切有佛性
  譬如香山中　　常生忍辱草
  如来神力故　　普令一切众
  见此鹫头山　　悉是七宝成
  尔时大众会　　睹已甚爱乐
  犹如四天王　　乐住须弥山
  如来大福田　　其力不可量
  能除众生结　　烦恼诸闇障
  一切诸众生　　不退菩提心
  犹如诸世尊　　安乐不倾动
  众生断恶业　　成就妙善戒
  修行菩提行　　决定见佛性
  若得闻此经　　乃至一字义
  即得菩提道　　随顺行梵行
  惟愿无上尊　　演说于一句
  普使一切众　　咸得解其义
  我等诸众生　　钝根无智慧
  如来怜愍故　　愿开令得解
  一切诸众生　　虚乏于法食
  惟愿大慈哀　　施之令满足
  我等得受已　　复当转施他
  亦令一切众　　皆悉得充足
  一切诸众生　　贫穷无福德
  无常无有我　　亦无归依处
  如来所成就　　无上大功德
  惟愿大慈尊　　施我及一切
  如来为法主　　如海众流尊
  众生不知依　　我今得依止
  为众作依止　　犹如慈父母
  施众甘露味　　普使断烦恼

世尊如来正觉不可思议。怜愍众生亦不可思议。所说秘密难可图度。诸佛世尊三昧之王。大船师王。不可称计不可数量。如是境界非诸声闻缘觉所知。如来月王常无增减。是诸功德之大猛将。无量福报珍宝之聚。是大光明无上日王。等视众生同罗睺罗。所成大力以施一切自无所畏。复令众生成无所畏。自破无明复除众生无明重闇。世尊。我亦无知无明所障。不知如来常乐我净。一切众生无明覆故。妄说如来无常无我无乐无净。是故流转三恶道中。若言如来永灭涅槃。当知是人必堕地狱。世尊。我今始知诸佛如来不毕竟灭。知已则得无上大宝。以佛力故复令我知诸佛实性。得服无上甘露法味。永断一切诸结烦恼。昔来所有狂聋喑哑今悉除愈

    大云初分三昧 健 度第二

尔时大云密藏菩萨摩诃萨言。甚奇世尊。如来正觉不可思议。今说此经令无量众生发阿耨多罗三藐三菩提心。是经境界不可思议。乃为一切无量众生现大神通雨诸宝味。众生闻者得遇无上甘露法雨。是故如来不可思议。是经境界亦不可思议。一切众生成大功德乃得值遇。众生业报不可思议。世尊。今日众生所受快乐如第三禅。形貌瑰玮如天无别。如来今日说此经藏。即是众生无尽之藏。降大法雨。所谓如来常住不变三昧总持。所言云者。谓诸菩萨摩诃萨也。震大雷者。谓破烦恼诸结业等。电光明者。谓诸众生皆有佛性。声者。谓诸菩萨为众生故。说有为法无常无乐无我无净。雹者。谓八圣道分。能坏一切诸结烦恼。又有雹者。所谓此经能坏声闻辟支佛心。是即名为雨大法雨。充饱众生饥虚渴乏。所谓如来常住不变。是名甘雨。佛言。善哉善哉。善男子。汝今善解如是法雨。善男子。若诸菩萨欲雨法雨润益一切。当受是经修行读诵书写供养解说其义。善男子。谛听谛听。如是经典不可思议中有解脱住入宝藏。神足法王四百三昧。我今当说。善男子。此经复有诸佛菩萨深猛大海眼目三昧。若有菩萨成就具足是三昧者。得具菩萨多闻大海多闻宝藏。于阿耨多罗三藐三菩提心无疑碍。言无碍者。所谓身得无碍遍生诸佛净妙世界。又无碍者。得宿命智。为诸众生转于五有。又无碍者。不贪着业而得果报。又无碍者。若一见佛心生欢喜。则于后世得端严身众所爱身。无贪身无恶身。大身上族身大富身。眷属不坏身不破坏身。不退身不灭身。所修行愿念喜作业。悉向阿耨多罗三藐三菩提。成就惭愧破诸憍慢。勤修精进慈悲喜舍。空无相愿以熏其心。又无碍者。愿生他土即得往生。诸邪异见所不能坏。其所乐说句义无尽。若天若魔梵沙门婆罗门。不能惑乱令其心动。虽读外典心无贪着。不贪天龙夜叉等身。乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽身。又不贪着房舍卧具衣服饮食。天魔波旬不得其便。所行善法终不中忘。凡所言说人所敬受。其心弘旷犹如大海。所有智慧亦复如是。具足圆满犹如盛月。能坏黑闇如日如灯。不可捉持如虚空性。不着世间如华处水。于一切有心无贪着。能坏法界犹如金刚。持诸法界如须弥山。其性清净如琉璃宝。得如来戒慧心念明。性力幻化不动不住。善男子。是经复有第一甚深解脱宝幢三昧。若有菩萨具是三昧。则得名为多闻大海多闻宝藏心无疑碍。乃至幻化不动不住。善男子。此经复有净智甚深法门三昧。若有菩萨能具足者。则得名为多闻大海多闻宝藏心无疑碍。乃至幻化不动不住。善男子。此经复有佛根香象王解脱三昧。首楞严三昧。勇力三昧。勇胜三昧。健勇三昧。好香三昧。正光三昧。无我光三昧。甚深行藏三昧。行深解脱三昧。行力解脱三昧。一切法行三昧。恒河沙等行三昧。一切解脱三昧。一切三昧王三昧。正上三昧。大海潮三昧。本解脱三昧。坏魔亿众三昧。住戒电光三昧。火光三昧。无尽意王三昧。云尽意三昧。海王神足三昧。大高意三昧。种子三昧。住大海三昧。无碍三昧。无碍戒三昧。高解脱三昧。因缘意三昧。业作三昧。健行王三昧。大力三昧。甚深琉璃王三昧。须弥山三昧。师子吼三昧。甘露味三昧。庄严三昧。火光三昧。莲华光三昧。国土喜三昧。一切身三昧。动大海王三昧。动大地王三昧。一切三昧母三昧。坏一切女身三昧。师子行王三昧。圆王三昧。细行三昧。鼓声微妙三昧。增长三昧。断有三昧。流三昧。广慧三昧。变化三昧。光明三昧。坏闇三昧。大海智慧三昧。赞叹三昧。大赞叹三昧。时三昧大时三昧。现在解脱三昧。合散三昧。分陀利华三昧。轻三昧。大乐三昧。虚空三昧。解脱身三昧。断语三昧。断声三昧。无爱三昧。无胜三昧。一切三昧。鬘三昧。龙王三昧。风三昧。风行王三昧。无边三昧。无色三昧。无边色三昧。法意三昧。微妙香三昧。身意三昧。首楞严三昧。坏恶三昧。莲华意三昧。大力翅三昧。坏无明三昧。菩提树三昧。宝命命三昧。大力命三昧。日光三昧。月光三昧。大海门三昧。一切法界三昧。结使根三昧。戒雨三昧。戒云三昧。庵罗果三昧。庵罗华三昧。净三昧。水三昧。蠡三昧。时三昧。时王三昧。众三昧。无身三昧。界三昧。善界三昧。地三昧。地神足三昧。水等三昧。青莲华三昧。甘露味三昧。无系三昧。鸳鸯三昧。车轮三昧。转轮圣王三昧。不动三昧。不轻三昧。不长三昧。怜愍三昧。净意三昧。一切功德意三昧。伊罗钵罗三昧。无疑解脱三昧。风神足王三昧。无量幢三昧。虚空界三昧。无彗星三昧。光宝三昧。雹时三昧。童子三昧。王子三昧。断毒三昧。法灯三昧。国土王三昧。施世界三昧。法贵德三昧。法力三昧。上华三昧。喜三昧。大喜三昧。知大力三昧。镇头迦果三昧。精进三昧。称三昧。白鹅王三昧。身光三昧。无尽力三昧。无尽力解脱三昧。增长名三昧。端正三昧。能破坏三昧。摩楼迦华三昧。善行王三昧。善光三昧。宝地三昧。白三昧。白种三昧。净行意三昧。爱光三昧。虚空心三昧。天冠三昧。转轮圣王冠三昧。念菩萨三昧。护意三昧。护甚深三昧。力乘三昧。力乘光三昧。力士三昧。力士精进三昧。阎浮国三昧。错鱼三昧。蟒蛇三昧。境界王三昧。净境界三昧。使心三昧。朝青三昧。有德意三昧。大青三昧。大海色三昧。大安三昧。眴三昧。无眴三昧。金刚意三昧。世尊目三昧。须弥山王三昧。雪山王三昧。世尊现行三昧。胜三昧。莲华三昧。拘勿头华三昧。月藏三昧。月乐藏三昧。华敷三昧。地鬘三昧。现在念世尊王三昧。胜住三昧。善住三昧。善行三昧。大海三昧。一切入平等三昧。入一切疑三昧。大药三昧。大药力三昧。甘露药王三昧。大药力三昧。大药王三昧。大冷三昧。大海三昧。大冷王三昧。无冷无热三昧。安三昧。安力三昧。一乘三昧。三乘三昧。释彗星三昧。有德三昧。宝圆王三昧。无定色三昧。定华三昧。六入真净三昧。大界三昧。能坏欲界三昧。璎珞三昧。金色三昧。智爱三昧。智圆王三昧。智子三昧。分陀利华三昧。日光王三昧。月爱三昧。光王三昧。光圆王三昧。净光王三昧。光藏三昧。青光三昧。时光三昧。断闇三昧。光潮三昧。箭光三昧。一切善根三昧。婆罗那香象王三昧。未生恶王三昧。调柔三昧。能坏憍慢三昧。妙德三昧。妙声三昧。贪味三昧。圆地王三昧。神通王三昧。神通根三昧。转轮圣王幡三昧。转轮圣王幢三昧。师子头三昧。日神通三昧。法护三昧。广三昧。知业神通王三昧。高三昧。无上三昧。灯王三昧。舍宅三昧。多喜三昧。初地三昧。戒地三昧。大海喜王三昧。大海慈王三昧。大海悲王三昧。大海舍王三昧。忍辱王三昧。忍辱力界王三昧。神通至心三昧。八解脱门三昧。法界毕竟三昧。无界三昧。无性三昧。大田种子三昧。智池三昧。海三昧。海力三昧。佛眼三昧。佛门三昧。智行三昧。佛面三昧。一切亲三昧。一切福德王三昧。虚空藏三昧。虚空幻三昧。佛幻三昧。恶性三昧。治毒三昧。眠三昧。觉三昧。梦三昧。得三昧。神通王三昧。无我神通三昧。胜见三昧。胜喜三昧。随世三昧。佛面住三昧。正见三昧。一切微尘三昧。语无碍三昧。净三昧。身光三昧。身灯三昧。不痴三昧。不狂三昧。一切胜光三昧。水意三昧。漂三昧。水沫三昧。无胜三昧。无胜智三昧。无胜身三昧。精进三昧。恒河沙等胜王三昧。知见圆光王三昧。断畜生三昧。愿生畜生有三昧。畜生神通三昧。乐畜生三昧。不染畜生业三昧。入地狱三昧。喜地狱三昧。不染地狱业三昧。不染地狱业行神通王三昧。安乐行体三昧。有德河三昧。有德海三昧。净河三昧。净行功德三昧。福德三昧。福德青三昧。净福德闻三昧。有德梦三昧。赞叹三昧。有德梦得三昧。有德梦行三昧。正有德三昧。正有德王三昧。净增长三昧。智雨三昧。风同行三昧。吉三昧。吉庄严三昧。吉神通三昧。吉神通王三昧。无戒三昧。杂色三昧。受戒三昧。赞戒三昧。戒实三昧。智灯三昧。得戒实三昧。常戒三昧。常戒入藏见三昧。心三昧。心王三昧。常戒喜三昧。常乐戒三昧。戒璎珞三昧。戒天冠三昧。戒具足三昧。戒鬘三昧。戒香三昧。戒华三昧。戒涂末香三昧。戒神通王三昧。一切昧三昧。一切华三昧。一切香醉三昧。断一切虚空三昧。受安乐三昧。断一切世法王三昧。常三昧。恒三昧。不变三昧。地三昧。无刺地三昧。无石沙三昧。地等三昧。大云琉璃王三昧。声鼓三昧。大云电三昧。大云瀑水王三昧。大云水藏三昧。大云水鬘三昧。大云安水三昧。大云 水凝 三昧。大云智海三昧。大云胜力三昧。大云水光持王三昧。大云水潮海三昧。大云海种三昧。大云不动水三昧。大云水不动神通王三昧。大云端正王三昧。大云一味三昧。大云一乘三昧。大云安水流三昧。大云多水三昧。大云冷水三昧。大云不冷不热神通王三昧。大云月王三昧。大云有德三昧。大云初力三昧。大云渴三昧。大云乐三昧。大云水行王三昧。大云虚空行三昧。大云水宝三昧。 大云 喜三昧。大云宝种三昧。大云护三昧。大云水净王三昧。大云水归依印三昧。大云法印三昧。大云水净光三昧。大云大水藏王三昧。大云水定三昧。大云莲华三昧。大云水界三昧。大云水等三昧。大云夜行三昧。大云水清三昧。大云海无尽意三昧。大云放光三昧。大云藏三昧。大云水聚三昧。大云水柱三昧。大云师子王三昧。大云乐三昧。大云净三昧。大云贪三昧。大云幢三昧。大云甚深三昧。大云雷三昧。大云增长水三昧。大云药王三昧。大云醉味三昧。大云师子行三昧。大云大香象王三昧。大云安乐三昧。大云风三昧。大云水行不动三昧。大云无畏三昧。大云水顺三昧。大云无尽意三昧。大云漏难数三昧。大云雷大力三昧。大云水喜三昧。大云海水圆三昧。大云水幡三昧。大云甘露雨三昧。大云栴檀凉三昧。大云吉三昧。大云毕竟三昧。大云无终始三昧。大云罗网三昧。大云宝雨三昧。大云秘密三昧。大云彗星三昧。大云意密三昧。大云大动三昧。大云灭三昧。大云微妙音三昧。大云恒河沙等三昧。大云水健三昧。大云鹅王三昧。大云水行三昧。大云命三昧。大云狂王三昧。大云诳三昧。大云首楞严三昧。大云马王三昧。大云拍树三昧。大云无尽云三昧。大云一切等三昧。大云一切雨三昧。大云一切和合三昧。大云庵罗树果三昧。大云山埠三昧。大云坚鞕三昧。大云密行三昧。大云密实三昧。大云鹅王行三昧。大云不可思议三昧。大云入住神通王三昧。善男子。若有菩萨具足如是诸三昧门。则得菩萨多闻大海多闻宝藏。于阿耨多罗三藐三菩提心无疑碍。终不堕落于三恶道。不生边地得宿命智。造生死业乐于生死。常得值遇佛法僧宝。乃至梦中亦不舍离。得端正身人所爱身。无贪身无恶身大身种姓身。眷属和乐不可沮坏。不退不灭不堕不没。其所修行深心念慧。悉皆趣向阿耨多罗三藐三菩提。得惭愧力断除憍慢。勤修精进慈悲喜舍。空无相愿以熏其心。愿生净土即得往生。众邪异见所不能坏。说法次第句义不断。虽读外典心不贪着。终不愿求天身龙身夜叉乃至转轮王身。亦不造作生死行业。不求世间供养恭敬。护持正法魔不得便。见持法者深生恭敬。所得智慧犹如大海。不增不减如月盛满。除众闇冥如日如灯。不受烦恼犹如虚空。烦恼不染如华处水。住无所住如空无别。破散诸法如真金刚。持一切法犹如雪山。定知如来常不变易。其智清净如琉璃宝。得如来戒势力大海。其心慈哀怜愍众生。不动不转如帝释幢。坏诸恶法得上妙味。犹如美妙迦陀迦果。随顺世法无所违逆。善男子。是则名为初三昧门。善男子。若有成就具足如是四百三昧。当知是人善护法藏。尔时众中有一天子名曰净密。与万八千诸天子俱来至佛所。头面作礼合掌恭敬。雨天华香幢幡伎乐。以供养佛。右绕三匝。即说赞曰

  如来不思议　　法僧亦复然
  我见三昧雨　　如世睹甘露

大方等无想经卷第二大方等无想经卷第三

        北凉天竺三藏昙无谶译

    大云初分陀罗尼健度第三

尔时大云密藏菩萨白佛言。世尊。若有众生未入如是方等经者。当知是辈犹如盲聋此经中有三十六种不退智宝。无边心行意入陀罗尼门。即是一切诸法初门。唯愿如来。为是等故广宣分别。佛言。善哉善哉。善男子。谛听谛听善思念之。今当为汝分别解说。此经中有诸佛菩萨不退宝轮藏陀罗尼门。此经复有诸佛菩萨大云不退清净密水陀罗尼。复有诸佛菩萨大云不退秘密光明陀罗尼。复有诸佛菩萨大云不退大雨陀罗尼。复有诸佛菩萨大云不退流水陀罗尼。复有诸佛菩萨大云不退尽意陀罗尼。复有诸佛菩萨大云不退电光陀罗尼。复有诸佛菩萨大云不退凉电陀罗尼。复有诸佛菩萨大云不退净光陀罗尼。复有诸佛菩萨大云不退彗星意陀罗尼。复有诸佛菩萨大云不退密藏光意陀罗尼。复有诸佛菩萨大云不退大咒意陀罗尼。复有诸佛菩萨大云不退有德意陀罗尼。复有诸佛菩萨大云不退虚空藏王陀罗尼。复有诸佛菩萨大云不退大药王陀罗尼。复有诸佛菩萨大云不退大雨王陀罗尼。复有诸佛菩萨大云不退称意陀罗尼。复有诸佛菩萨大云不退抧罗娑山意陀罗尼。复有诸佛菩萨大云不退意行陀罗尼。复有诸佛菩萨大云不退上高王陀罗尼。复有诸佛菩萨大云不退潮王陀罗尼。复有诸佛菩萨大云不退鹅王目陀罗尼。复有诸佛菩萨大云不退大海智陀罗尼。复有诸佛菩萨大云不退甚深意王精进陀罗尼。复有诸佛菩萨大云不退雨种陀罗尼。复有诸佛菩萨大云不退地鬘陀罗尼。复有诸佛菩萨大云不退欢喜陀罗尼。复有诸佛菩萨大云不退世意陀罗尼。复有诸佛菩萨大云不退不动意陀罗尼。复有诸佛菩萨大云不退地陀罗尼。复有诸佛菩萨大云不退积聚陀罗尼。复有诸佛菩萨大云不退水光陀罗尼。复有诸佛菩萨大云不退无尽水藏陀罗尼。复有诸佛菩萨大云不退水性月光陀罗尼。复有诸佛菩萨大云不退水光体陀罗尼。复有诸佛菩萨大云不退不可思意大海王陀罗尼。善男子。是名三十六种不退智宝无边心行意入陀罗尼。尔时众中有一天女名曰宝鬘。上升虚空高七多罗树。雨种种华涂香末香幡盖伎乐以供养佛。说偈赞曰

  如来大医王　　金刚身不坏
  意等慧殊胜　　戒净愍众生
  除断诸烦恼　　犹如日破闇
  今说陀罗尼　　如云降大雨

    大云初分密语健度第四

尔时大云密藏菩萨言。世尊。一切众生无明所盲。唯愿如来。广开显示诸佛密语。然深智灯作大明导。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝然大法灯。此经中有诸佛菩萨二十三种密语道迹。入不狂行大法方便解脱门。断我我所密语所入行解脱门。可畏色不可畏色下色密语所入解脱门。贪求不得密语所入解脱门。断界有界无界密语门。有无明无无明有无无明密语门。有贪无贪者断贪密语门。有爱无爱者断爱密语门。有系无系者断系密语门。有嗔无嗔者断嗔密语门。有闇无闇有光密语门。有钝无钝有利大利密语门。有破有析有坏密语门。有苦有乐无有受者密语门。有慈无慈 无愍 密语门。有施无受者有大施主密语门。有骂无受者断骂密语门。有净无净断一切净密语门。有等无等断一切等密语门。有放逸无放逸断放逸不放逸密语门。空不空非空非不空如来密语门。常无常非常非无常如来密语门。我无我非我非无我如来密语门。爱无爱非爱非无爱如来密语门。善男子。是名二十三种密语道迹。入不狂行大法方便解脱门。尔时众中有一天子名曰众爱。与无量天子。上升虚空高十七多罗树。雨诸华香幡盖伎乐以供养佛。说偈赞曰

  如来深密语　　二乘所不解
  为众故宣说　　悉令得安乐

    大云初分转生有藏健度第五

尔时大云密藏菩萨言。世尊。有十神通行入有生行藏微妙光王法门。唯愿如来。分别广说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝广宣分别。此经中有诸佛菩萨十有生乐王法门。复有有生求喜法门。复有有生虚渴法门。复有有生乐说法门。复有有生安法门。复有有生愿法门。复有有生称法门。复有有生体王法门。复有有生善王法门。复有有生无善不染行藏微妙法王法门。善男子。是名十神通行入有生行藏微妙光王法门。时大众中有一天女名曰爱光。以诸天华种种杂香幡盖伎乐以供养佛。而赞叹曰

  我今稽首礼　　不生于诸有
  方便行诸趣　　普为一切众
  如来心自在　　是故其身常
  为众转生死　　如华无所染

    大云初分得转生死业烦恼健度第六

尔时大云密藏菩萨言。世尊。有十生死烦恼业田。得心定愿藏法门。唯愿如来。广为众生分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝开示解说。此经中有得生死烦恼田果实法门。复有生死田乐王法门。复有生死庄严住心法门。复有生死喜地法门。复有生死期地法门。复有生死正见法门。复有生死眴法门。复有生死衣法门。复有生死久住法门。复有生死光明法门。善男子。是名十生死烦恼业田。得心定愿藏法门。尔时众中有龙王名曰无毒。以诸杂香上妙诸花幡盖伎乐供养于佛。即说赞曰

  为诸众生故　　显示生死义
  佛无烦恼业　　为众故处之

    大云初分智狂入健度第七

尔时大云密藏菩萨言。世尊。有十种智狂不可思议神通王所入法门。唯愿如来。广开分别。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。此经中有得大安隐法门。无胜胜神通王法门。无称称光所入法门。无量量光所入法门。菩提时法门。期光法门。高梯法门。宽腹法门。持一切众生法门。现在光法门。善男子。是名十种智狂不可思议神通王所入法门。于是众中有一天女名曰善鬘。以种种杂华上妙诸香幡盖伎乐以供养佛。即说赞曰

  佛心难思议　　智身亦复然
  为化众生故　　广开此法门

    大云初分解脱转福德藏法门健度第八

尔时大云密藏菩萨言。世尊。有十智甚深入无畏行法王法门。唯愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有解脱一切恶法法门。虚空藏法门。甚深安入法门。细针法门。海不动法门。智灯法门。身口法门。断入一切烦恼法门。坚意入法门。净意无碍法门。善男子。是名十智甚深入无畏行法王法门。时大众中有一天女名金光明。以种种杂华上妙诸香幡盖伎乐以供养佛。即说赞曰

  如来金色身　　智宝为璎珞
  善法之宝聚　　犹须弥草木

    大云初分解脱有德转藏健度第九

尔时大云密藏菩萨言。世尊。有十种大云见流不可思议功德宝藏法门。唯愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别演说。有乐慈藏法门。乐悲藏法门。乐喜藏法门。乐舍藏法门。宝水流藏法门。大海行法门。如来所说法流法门。时入藏法门。想意宝藏入法门。一切大法聚法门。善男子。是名十种大云见流不可思议功德宝藏法门。时大众中有一天子名智爱乐。以种种杂华上妙诸香幡盖伎乐以供养佛。即说赞曰

  如来无生灭　　佛法难测量
  众生无明覆　　广演于法界

    大云初分转功德行健度第十

尔时大云密藏菩萨言。世尊。有十种雨流不可思议功德藏法门。唯愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝广宣分别。善男子。有雨网法门。有宝王法门。有雨大海王法门。有雨尘法门。有雨断毒法门。有雨满安乐法门。有雨体法门。有雨种种正见法门。有雨功德法门。有雨凉药法门。善男子。是名十种雨流不可思议功德藏法门。时大众中有一天子名虚空雷。持诸华香幡盖伎乐以供养佛。即说赞曰

  诸佛如来说　　上妙微密藏
  能令一切众　　永度烦恼流
  断灭生死苦　　一切永无余
  深自觉悟得　　涅槃常乐俱
  如来天中天　　成就无量德
  今说大云经　　为众发道心

    大云初分云虚空生健度第十一

尔时大云密藏菩萨言。世尊。有十种大云得虚空定法门。唯愿如来。善分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有善法王法门。见性法门。智无胜王法门。无憍慢法门。无尽意法门。不可思议法门。无碍法门。甚深法门。质直法门。虚空相法门。善男子。是名十种法门。时大众中有一天女名妙族姓。持诸香华幡盖伎乐以供养佛。即说赞曰

  如来深密藏　　众生所不解
  唯愿为一切　　分别令浅易

    大云初分电光转健度第十二

尔时大云密藏菩萨言。世尊。有十种大云电光法门。唯愿如来。广分别说。佛言。善哉善哉。善男子谛听谛听。善思念之。吾当为汝分别解说。有六通法门。功德法门。宝光法门。虚空精进法门。藏法门。戒调法门。功德藏法门。断疑法门。琉璃意法门。清净法门。功德甚深大海法门。坏一切结法门。金垢法门。(梵本长三)善男子。是名十法门。时大众中有一天女名曰善喜。持诸花香幡盖伎乐以供养佛而赞叹曰

  如来大医王　　无身方便身
  无碍如虚空　　广说大云经

    大云初分电转健度第十三

尔时大云密藏菩萨言。世尊。有十种宝电行法门。唯愿如来。广开分别。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有电光宝王法门。利智慧法门。智慧能坏法门。初智法门。智海法门。法疑法门。吉祥法门。法鼓法门。须弥山法门。能坏闇法门。风等行法门( 梵本长一 )善男子。是名十法门。尔时众中有一天女名恒河神。持诸香华幡盖伎乐以供养佛。而赞叹曰

  无畏无我心　　无贪愍众生
  以大方便故　　而为一切世
  如来功德力　　故令我得知
  无上无边身　　不可得思议
  我闻是经已　　永断诸烦恼

    大云初分神通健度第十四

尔时大云密藏菩萨言。世尊。有十种大云电光幻法门。惟愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。善男子。有调幻法门。调藏法门。乐法法门。求法法门。烧结法门。生一切法法门。断诸诤讼法门。能消烦恼法门。上高法门。念无尽法门。度一切众生法门。(梵本长一)善男子。是名十法门。时大众中有一天女名曰大喜。持诸华香幡盖伎乐以供养佛。以偈赞曰

  如来大神通　　其身无动转
  为众断生死　　故说大云经

    大云初分宝雹健度第十五

尔时大云密藏菩萨言。世尊。有十种大神通法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。今当为汝分别解说。善男子。有宝雹法门。雹等法门。雹庄严王法门。雹灯法门。雹药法门。雹同法门。雹无尽意法门。雹上上法门。雹上容法门。雹甚深法门。善男子。是名十种法门。尔时众中有一天女名曰严饰自喜。持诸香华幡盖伎乐以供养佛。即说赞曰

  世尊大雹王　　天中天满雨
  知诸烦恼业　　而能永断之
  凡夫结无边　　轮转受生死
  菩萨无烦恼　　故不至诸趣

    大云初分金刚智健度第十六

尔时大云密藏菩萨言。世尊。有十智金刚行入智法门。惟愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有神通宝聚法门。喜王法门。神通平等法门。白鹅声法门。虚空无碍法门。药王法门。法幢法门。甚深大海法门。不动法门。无边光法门。不可思议法门。无量劫法门。(梵本长二)善男子。是名十法门。时大众中有一天女名深智爱。持诸香华幡盖伎乐以供养佛。即说赞曰

  如来无上王　　无生亦无灭
  为诸众生故　　示现于生灭
  真实常不变　　为众说无我
  其身如金刚　　不可得沮坏

    大云初分无尽健度第十七

尔时大云密藏菩萨言。世尊。有十无尽意入神通法门。惟愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有甘露意入法门。安宝法门。乐法门。喜法门。甚深精进法门。意行法门。无尽乐法门。常喜乐法门。善男子。是名十法门(梵本少二)尔时众中有一天女名大宝轮。持诸香华幡盖伎乐以供养佛。即说赞曰

  如来无贫富　　其身无触碍
  怜愍一切故　　乐说大乘经

    大云初分正行健度第十八

尔时大云密藏菩萨言。世尊。有十正道法门。惟愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别宣说。有深广行法门。健行法门。现力法门。健胜法门。一切天人法门。入一切时法门。不染一切时法门。一切道喜法门。断一切恶道法门。大海常潮法门。大海神通法门(梵本长一)善男子。是名十法门。尔时众中有一天女名曰善得。持诸香华幡盖伎乐以供养佛。即说赞曰

  如来无上尊　　修集于正道
  虽成坚固藏　　其心初无吝
  慈愍于众生　　及为我等故
  今于此宝座　　宣说如是经

    大云初分师子吼健度第十九

尔时大云密藏菩萨言。世尊。有十种甚深师子吼行法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有一切味吼法门。一切味喜法门。时神通王法门。莲华法门。喜地法门。大喜地法门。四威仪法门。圣行法门。净法门。一切法体法门。善男子。是名十法门。时大众中有一天女名微妙声。持诸香华幡盖伎乐以供养佛。而说赞曰

  无上智微妙　　犹如大海水
  其力难思议　　故能师子吼
  为诸众生故　　生于怜愍心
  今说方等经　　其意无所畏

    大云初分师子吼神通健度第二十

尔时大云密藏菩萨言。世尊。有十师子吼神通法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有光法门。法蜂法门。法鼓法门。法宝法门。法藏法门。法力法门。法动法门。三匝法门。大地法门。难近法门。一切缨络法门(梵本长一)善男子。是名十法门。时大众中有一天子名师子吼。持诸香华幡盖伎乐以供养佛。而说赞曰

  如来无因喻　　无胜无有边
  为诸众生故　　方便师子吼

    大云初分善方便健度第二十一

尔时大云密藏菩萨言。世尊。有十入世间方便法门。惟愿如来。广分别说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有生王入法门。毕竟多方便入法门。信心入法门。师子神通法门。世界非世界法门。时一入法门善不善法门。能调恶人法门。有德王入法门。得一切恭敬法门。下业行法门(梵本长一)善男子。是名十法门。是时众中有一天子名婆罗呵迦。持诸华香幡盖伎乐以供养佛。而说赞曰

  如来方便入涅槃　　其身不动亦不灭
  所入禅定难思议　　众生不解谓永灭

    大云初分神通健度第二十二

尔时大云密藏菩萨言。世尊。有十神通宝藏入法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有法周罗法门。大神通法门。宝香藏法门。师子吼入聚法门。破法相法门。栴檀凉法门。无相法门。无语法门。莲华法门。称法门。善男子。是名十法门。是时众中有一天子名增长有德。持诸华香幡盖伎乐以供养佛。即说赞曰

  三千大千界　　佛于法自在
  法身不可见　　为众现相好

    大云初分金翅鸟健度第二十三

尔时大云密藏菩萨言。世尊。有十金翅鸟神通所入法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别宣示。有能坏婆修吉龙王力神通王法门。自在力入法门。喜入法门。开勇入法门。大海时入法门。能坏大山法门。能坏风力法门。长见法门。能坏一切毒法门。得宝嘴法门。善男子。是名十法门。是时众中有一天子名深净行。持诸华香幡盖伎乐以供养佛。即说赞曰

  如来大法王　　慧眼喻千日
  定根金刚手　　能坏诸烦恼

    大云初分大舍健度第二十四

尔时大云密藏菩萨言。世尊。有十大舍时微妙神通王法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有无碍力甚深法门。戒住法门。戒广王法门。戒界王法门。宝乳流法门。功德流微妙法门。慈力流法门。忍辱流法门。喜力流法门。舍力流法门。善男子。是名十法门。是时众中有一天子名宝贵德。持诸花香幡幢伎乐以供养佛。即说赞曰

  礼佛无量力　　常住不坏身
  为诸众生故　　说种种法界

    大云初分无畏健度第二十五

尔时大云密藏菩萨言。世尊。有十无所畏大力神通所入法门。惟愿如来。分别解。说佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有无所畏力神通法门。不悕乐根法门。宝聚法门。十有德法门。净浣法门。净光行法门。净宝光法门。喜入法门。净等法门。电光法门。善男子。是名十法门。是时众中有一天子名宝彗星。持诸华香幡盖伎乐以供养佛。即说赞曰

  如来秘密藏　　甚深如大海
  为诸众生故　　净行于法界

    大云初分入行健度第二十六

尔时大云密藏菩萨言。世尊。有十入行法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有入藏法门。正行法门。正实法门。吉称法。门。称法门。常喜法门。日须法门。悲力法门。忍辱法门。常净法门。善男子。是名十法门。是时众中有一天子名宝正光。持诸华香幡盖伎乐以供养佛。即说偈赞曰

  如来智慧海　　甚深难可测
  普为众生故　　今说大云经

    大云初分至心健度第二十七

尔时大云密藏菩萨言。世尊。有十种至心所入法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有住善界法门。大海智法门。智潮法门。神通行法门。虚空神通法门。无热法门。初成法门。随行法门。施喜法门。善至心法门。善男子。是名十法门。是时众中有一天子名波头摩智。持诸华香幡盖伎乐以供养佛。即说赞曰

  如来无见顶　　无胜无有上
  今放大光明　　广为诸众生

    大云初分勇力健度第二十八

尔时大云密藏菩萨言。世尊。有十勇王大力微妙法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别宣说。有健胜田行法门。首楞严法门。勇健神通法门。健力法门。健归法门。众生具足法门。智坚健行法门。坏懒堕法门。广力法门。健调光法门。健意法门(梵本长一)善男子。是名十法门。是时众中有一天子名曰勇武。持诸花香幡幢伎乐以供养佛。即说赞曰

  眷属不可坏　　犹如金刚宝
  摧伏魔官属　　为众说是经

    大云初分善健度第二十九

尔时大云密藏菩萨言。世尊。有十种善行大神通王所入法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别说之。有善宝调法门。善聚法门。善堂法门。善行法门。善意法门。善德法门。善净法门。善调光法门。一切善行璎珞法门。(梵本少一)善男子。是名十法门。是时众中有一天女名曰善护。持诸香华幡盖伎乐以供养佛。即说赞曰

  成就于善相　　安坐善妙床
  广为诸众生　　敷演无上法

    大云初分神通健度第三十

尔时大云密藏菩萨言。世尊。有十三神通藏得开示法门。惟愿如来分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别宣示。有乐神通窟法门。喜神通窟法门。大喜神通窟法门。行神通窟法门。师子神通窟法门。等神通窟法门。示神通窟法门。悲神通窟法门。舍神通窟法门(梵本少四)善男子。是名十三法门。是时众中有一天女名大海意。持诸华香幡盖伎乐以供养佛。即说赞曰

  菩提树常住　　弟子乐依止
  安根不动摇　　故得生定牙
  获果常不变　　是故稽首礼

    大云初分智健度第三十一

尔时大云密藏菩萨言。世尊。有十智初行法门。惟愿如来。分别说之。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有法增长法门。喜食法门。无尽意法门。贪神通法门。施舟法门。不乐世间法门。庄严地法门。庄严界法门。乐调法门。住时法门。善男子。是名十法门。是时众中有一天女名须曼那华。持诸华香幡盖伎乐以供养佛。即说赞曰

  如来戒无上　　智慧无上上
  怜愍众生故　　广说大云经

    大云初分智宝藏健度第三十二

尔时大云密藏菩萨言。世尊。有十智宝藏法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别宣示。有善持宝藏法门。法持法门。恭敬法门。心持法门。调王法门。正精进法门大海宝藏法门。乐吉法门。智果法门。大吉法门。成就功德法门。端正法门。持戒精进法门(梵本长三)善男子。是名十法门。是时众中有一天女字连华鬘。持诸华香幡盖伎乐以供养佛。即说赞曰

  如来大智海　　我今至心礼
  深定秘密藏　　大悲故宣说
  如来既自获　　常乐我净等
  亦复令众生　　同己之所得

    大云初分施健度第三十三

尔时大云密藏菩萨言。世尊。有十正知微妙宝藏法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有宝藏法门。净藏法门。净乐法门。施乐法门。施目法门。深藏法门。深法庄严法门。正见法门。愍一切众生法门(梵本少一)善男子。是名十法门。是时众中有一天女字法宝乐。持诸花香幡盖伎乐以供养佛。即说赞曰

  如来大施主　　庄严大施聚
  施一切众生　　不观田非田

    大云初分福田健度第三十四

尔时大云密藏菩萨言。世尊。有十种福田种子法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有宝行胜法门。宝流雨法门。宝行聚法门。宝功德聚法门。宝正意法门。宝目法门宝意法门。宝光法门。宝灯法门。宝电法门。无尽意法门。宝住法门。一切宝田法门。(梵本长三)善男子。是名十法门。是时众中有一天子名曰宝雨。持诸香华幡盖伎乐以供养佛。即说赞曰

  诸佛等正觉　　是世之福田
  大慈悲怜愍　　一切诸众生
  能了田非田　　故名阿梨呵

    大云初分正法健度第三十五

尔时大云密藏菩萨言。世尊。有十种真实神通安乐乐王所入法门。惟愿如来。分别解说。佛言。善哉善哉。善男子。谛听谛听。善思念之。吾当为汝分别解说。有不动法门。住貌法门。不动乐法门。深住法门。不可思议聚法门。不可思议聚解脱法门。乐意法门。不可思议住法门。如来智印法门。一切大海无尽意法门。善男子。是名十法门。是时众中有一天子名曰大光。持诸香华幡盖伎乐以供养佛。即说赞曰

  诸佛婆伽婆　　所说微妙法
  所为诸众生　　悉皆难思议

大方等无想经卷第三大方等无想经卷第四

        北凉天竺三藏昙无谶译

    大云初分如来涅槃健度第三十六

于是众中有大梵王名曰健行。持诸供具供养于佛。合掌恭敬右绕三匝。上升虚空高七多罗树。白佛言。世尊。大乘经典凡有几种三昧总持。所修行道秘蜜之藏。乐说无碍如来境界。国土世间复有几种。如来大慈怜愍一切。故我今日敢生此问。愿二足尊哀矜宣说。说已我当顶戴受持。时有天子名无尽意在大众中承佛威神。即为梵天而说偈言

  善哉大梵王　　问佛真实义
  佛当如实答　　广度诸众生
  应当至心听　　恭敬而尊重
  一一方等经　　恒沙义难解
  如来大法王　　广开阐法界
  佛得总持法　　非二乘所解

大梵。大乘经义非惟一种乃至万种。假使有人智如阿难。所得寿命如恒河沙。不能受持知其义理。复使是人其舌辩利。数如恒沙说亦不尽。何以故。是大乘经其义深邃不可思议。不可称量境界难知。过去未来现在诸佛。说其句义犹不可尽。梵天。譬如医师为疗病故。所说药方亦不能尽。诸佛世尊亦复如是。梵天。譬如女人惟有一子。欲令长大渐令服苏。诸佛世尊亦复如是。梵天。已为众生兴发此问。我当至心听受其义

尔时大云密藏菩萨白佛言。世尊。此经中说四百三昧。其义甚深难可得解。惟愿如来分别解说。佛言。善哉善哉。善男子。如汝所问。欲疗众生杂恶秽垢。令得忍辱正信之心。正精进心念心定心。欲令未来薄福之人生福德故。故发此问。善男子。若有国土城邑聚落四部之众。受持读诵书写解说如是经者。时旱则雨。雨过则止。善男子。随有国土其中众生受持读诵书写解说听此经者。当知是人得金刚身。何以故。是经典中。有神咒故。为众生故。三世诸佛悉共宣说

郁究隶　牟究隶　头坻　比头坻　陀尼羯坻　陀那赖坻　陀那僧塔兮

若有四众读诵此咒。则为诸佛之所称赞。若有国土欲祈雨者。六斋之日其王应当净自洗浴。供养三宝尊重赞叹称龙王名。善男子。四大之性可令变易。诵持此咒天不降雨。无有是处。汝先所问四百三昧义。至心谛听。当为汝说。善男子。此经中有诸佛菩萨甚深净水大海三昧。非诸声闻缘觉所知。故名甚深。能断一切生死渴乏。故名净水。边不可得。故名大海。诸佛世尊同平等故。故名三昧。若有菩萨具是三昧。则得常乐我净之身。得多闻海多闻宝藏。于菩提心无有动转。不退佛慧常住之身。无有变易心无疑碍。不离法雨常遇三宝值善知识。成就一切真正福德。善男子。汝当受持如是三昧。持已则得具足成就无量功德。复次善男子。复有甚深净水大海所入三昧。无有三昧而能宣说是三昧相。故名甚深。洗濯生死。故名为水。无能得底。故曰大海。得不动身常乐我净。故名为入。毕竟故故名三昧善男子。若有菩萨具是三昧。则能变为诸天形像。见事梵者即作梵像。为破梵事而心不着。见事自在天作自在天像。见事八臂作八臂像。见事建驮作建驮像。见事天母作天母像。见事鬼者即作鬼像。虽示如是种种形像。为坏彼见心实无著。见有屠者即现屠像。为欲化彼令不杀生。酒家乃至旃陀罗像。亦复如是。见有博弈戏笑之处。悉现其像为断贫穷。现畜妻息奴婢仆从。而其内心常修梵行。虽服宝饰心常清净。示现服食甘美众膳。内常法喜以自充润。入诸淫舍为化欲恶诸不善者。博士卜噬鸟鹫之身。乃至一切畜生杂类。亦复现入一切形残身不具足。为欲宣说身过患故。乃至九十五种邪道。随示其像破彼见故。示现自身四百四病。为治众生内外病故。读诵外书解种种语。示现奴婢仆从男女老少之像。及示生老病死等像。为欲调伏诸众生故。能解一切鸟兽等语。现作香华药草果蓏。或示王身王子大臣长者身像。或示沙门婆罗门像。帝释天王转轮圣王日月等像。所以示现四大天王。为欲拥护四天下故。示现诸佛自在神通。终不毕竟入于涅槃。变作众色不坏色性。虽得往生诸佛净土。终不分别国土之相。获得诸佛甚深三昧。而于法界无所分别。为人天主心无憍慢。虽说梦事不见梦相。外现魔事实无魔业。行于世间世法不污。犹如莲华处污不染。善男子。如是之果。名为成就甚深大海所入三昧。尔时众中有婆罗门名曰善德。白佛言。世尊。如来之法甚深秘密。为诸众生分别演说。而是薄福钝根愚痴提婆达多。不听不受不知恩分。纯与六群弊恶比丘同其所行。增长地狱。出佛身血。破坏众僧。生于释种增长憍慢。实非人类强名为人。察其行迹畜生无别。复从无量阿僧祇世。常于如来生恶逆心。其有施者无有果报。自所修善亦不成就。如尼干子等无差别。尼干子说无受无施。提婆达多亦复如是。真是魔党非佛眷属。何以故。常于如来起害心故。虽名沙门无沙门义。犹如袈裟裹覆利刀。实是秃人名为无命。所有徒众亦复如是。实非世尊作世尊想。世尊如来若是一切智者。何故听此弊恶之人。出家剃发受具足戒。如来所说普令众生生于善根。是人何故独不得生。如来慈哀常以乐说。为诸众生广宣正法。闻者蒙润善根开敷。提婆达多。何故不得预斯利益。如来性净身净心净。眷属应净。何故众中而有此辈。尔时大云密藏菩萨。承佛神力语善德言。善哉善哉。大婆罗门。一切声闻辟支佛等。于是事中都不能问。汝今乃能咨问是义。至心谛听。我当承佛威神道力为汝广说。汝不应言提婆达多不知恩分。是人知恩。非不知也。虽与六群同其所行。不名为恶。提婆达多不可思议。所修业行皆同如来。如来业行即是提婆达多业行。一切众生不能开显如来世尊真实功德。提婆达多能开示人。令阿僧祇无量众生安住善根。如来业行非地狱种。云何而言提婆达多是地狱人。汝言同于六群所行。汝今当知六群比丘。实非弊恶所行之法亦同佛行。大婆罗门。如来身血实无有出。提婆达多亦不能出。若言树影有出血者。无有是处。如来之身亦复如是。若言出血。当知即是善权方便不可思议。大婆罗门。释迦如来种性清净如绀琉璃。所有弟子无有毁禁。我亦不见如来弟子有破戒者。如来所说无上正法。实令闻者生于善根。非不生也。如来大众成就持戒悉入佛境。徒众眷属如栴檀林纯以栴檀而为围绕。不可沮坏如金刚山。亦不见有能得坏者。有怖畏者则可破坏。如来弟子永无忧怖。若无忧怖云何可坏。不可破坏如师子群。如来法王如师子王。纯以师子而为眷属。如是眷属难可测度。非是声闻缘觉境界。不可毁灭如灰覆火。如来无上一切智人。若听剃发受具戒者。终无毁禁一切众生。皆入如来所知境界。是故如来名一切智。提婆达多。具足如是不名坏僧。大婆罗门。假使千万无量诸魔亦不能坏。若言弊恶提婆达多坏众僧者。当知即是善方便也。云何而言行同畜生。提婆达多。真实生于释迦如来净种姓中。不生畜生。若言释种作诸恶者。无有是处。提婆达多所行恶行。为欲显示释迦如来功德力故。释种中生名秃人者亦无是处。提婆达多。善能护持解脱净戒。云何而言尼干子耶。有恶欲者乃名恶人提婆达多心无恶欲。云何而言恶比丘耶。修行如来善方便者。提婆达多即其人也。大婆罗门。若有人言提婆达多集地狱业。当知即是菩萨业也。菩萨业者即是神通。为化众生故在地狱。当知实亦不处地狱。譬如二人道路共行。后各别去一东一西。若言是人故和合者。亦无是处。若言如来提婆达多相远离者。亦无是处。大婆罗门。有人杀生造作恶业。法应无量百千世中地狱受果。有人修善法。应无量百千世中天上受报。有修善者地狱受果。行恶之人天上受报。此乃诸佛如来境界。非诸声闻缘觉所知。如来成就无量微妙真实功德。云何而言提婆达多能坏佛身。实无量世中于如来所生恶逆心。提婆达多实无害心。何以故。是人真实决定了知善恶报故。知一念恶无量世中地狱受报。以是义故。提婆达多终不造恶。如来已于无量世中永断诸恶。云何众生能于如来起恶心耶。若言提婆达多是地狱人。云何得与如来法王同一种姓。地狱众生得与如来同眷属者。亦无是处。若言提婆达多无量世中造作诸恶。应无量世地狱受报。云何得与如来一处。若与如来同一处者。当知是人非是弊恶。若提婆达多真实恶人。云何得与如来和合。如彼二人东西路乖理无和合。提婆达多随顺佛语。闻东则东。不违圣旨。云何当名地狱人耶。若令至东故违西去。则不得名非地狱人。若言提婆达多地狱人者。是无恶人。所以者何。地者名人。狱者名天。往来人天名地狱人。复次地者名常。狱名无相。提婆达多亦常无相。故名地狱。复次地名为乐。狱者名断。乐断生死。故名地狱。复次地者名善方便。狱名能说说善方便。故名地狱。大婆罗门。如来世尊有善方便。复能宣说不名地狱。云何得名提婆达多为地狱人。提婆达多所有境界。实非声闻缘觉所知。大婆罗门。如来世尊常所称赞。黄头大士即是提婆达多比丘。六群比丘亦大菩萨。提婆达多与共同行。云何得名地狱人耶。如栴檀树栴檀围绕。如香象蹴踏非驴所堪。还是香象之所能忍。大婆罗门。如来世尊大香象王亦复如是。所说深义非是二乘之所能知。还是香象诸大菩萨乃能受持。提婆达多成就如是无量功德。汝应忏悔恭敬供养尊重赞叹。大婆罗门。比丘比丘尼优婆塞优婆夷。能知提婆达多功德了了不疑。当知是人真佛弟子。得佛功德二分之一。得佛一目。得佛半身。大婆罗门。提婆达多所有功德。一切众生所不能知。如来功德所有境界。一切众生亦不能知。复不能见如来法身。大婆罗门。提婆达多。真实能知如来所有微妙功德。声闻缘觉实所不知。惟有提婆达多了了不疑。亦能示现如来所现无量神通。能示众生如来所行。知佛如来所有国土。提婆达多是大丈夫。如来所游在在处处。提婆达多亦随逐行。以是义故名大丈夫。诸佛如来境界甚深。秘密之言不可思议。惟有提婆达多比丘能得了知。如来今者当开密语。仁可善听。尔时大众异口同音。而赞颂曰

  假使魔波旬　　其数无有量
  尽其神通力　　不能坏众僧
  如来无上尊　　大慈怜愍心
  为诸众生故　　示现业果报

尔时世尊。赞叹大云密藏菩萨摩诃萨言。善哉善哉。汝今快说提婆达多真实功德。一切声闻辟支佛等不能解了。大乘方等功德势力。汝将欲坏一切众生所有疑心。是故开显提婆达多菩萨功德

复次善男子。此经复有诸佛菩萨深进大海水潮三昧。若有菩萨成就具足是三昧者。须弥山王高大坚鞕能以口吹令其碎破。犹如微尘入葶苈糩。而亭历糩亦不增长。四大天王亦不惊怖不破不坏。不自觉知所安之处。三十三天亦复如是。善男子。是名菩萨成就具足深进大海水潮三昧。复次善男子。若有菩萨成就具足是三昧者。以四大海水入一毛孔。不娆鼋鼍龟龙鱼鳖水性之属。寿命如常无有损夭。诸龙王阿修罗乾闼婆。不自觉知所至之处。能以三千大千世界安置右掌。断取大地如陶家轮。掷置他方恒沙界外。其中众生都不觉有往来之想。取彼世界安置此土亦复如是

尔时善德以诸香华幡盖伎乐供养于佛。合掌恭敬白佛言。世尊。大慈怜愍一切如罗睺罗。今欲启请。惟愿听许。尔时世尊默然不答。是时众中有梨车童子。名曰一切众生乐见。语善德言。如来默然已不相许。我今当答随疑致问。婆罗门言。梨车。我曾从他闻如是义。若能供养如来舍利如芥子许。福报应得忉利天主。梨车。是大云经其义甚深。如来密语难可得解。非诸声闻缘觉所知。何况我等边地之人。我今欲得如来舍利如芥子许。恭敬礼拜冀处忉利为彼天主。我从昔来常有此愿。尔时梨车。即说偈言

  假使恒河中　　驶流生莲花
  拘抧罗鸟白　　舍利乃可得
  假使龟生毛　　任作僧伽梨
  冬日能消冰　　舍利乃可得
  假使蚊子脚　　堪任作桥梁
  能度一切众　　舍利乃可得
  假使水中蛭　　忽然生白齿
  大如香象牙　　舍利乃可得
  假使兔生角　　堪任作梯橙
  高至净居天　　舍利乃可得
  假使鼠虫等　　缘于兔角梯
  在上而食月　　舍利乃可得
  假使蝇能饮　　钟石淳好酒
  迷荒而耽醉　　舍利乃可得
  假使驴口唇　　形如频婆果
  善能歌咏舞　　舍利乃可得
  假使乌角鸱　　同共一树栖
  饮食不相离　　舍利乃可得
  假使棘刺叶　　周遍覆三千
  大千世界上　　舍利乃可得
  假使小舟船　　能载须弥山
  度于大海水　　舍利乃可得
  假使小鸟雀　　嘴衔大香山
  移置于他处　　舍利乃可得

时婆罗门即说偈颂答梨车言

  善哉梨车子　　能知深方便
  今当至心听　　我说佛功德
  佛境难思议　　所得已毕竟
  诸佛常无变　　是故无生处
  诸佛色平等　　是名佛法界
  如来非作法　　亦复非有生
  如来金刚身　　不可得破坏
  以是故舍利　　真实不可得
  如来无舍利　　乃至如芥子
  无有血肉骨　　云何有舍利
  如来为众生　　现受方便身
  诸佛身常住　　法界亦复然
  随应诸众生　　方便为说法
  亦随其所宜　　而现种种身
  若佛有慈愍　　普及诸众生
  何故不见为　　分身施舍利

尔时众中有一天女名曰净光。复以香华幡盖伎乐供养于佛。合掌恭敬白佛言。世尊。如是二贤成就甚深微妙智慧。能开如来秘密之藏。从何处来惟愿演说。佛言。善哉善哉。天女。汝为众生故问是义。谛听谛听吾当说之。如是二人是佛真子。如香象王是大丈夫。为众生故乐处生死。知恩报恩我所护念。善能护持诸佛种姓。为佛重任炽燃法灯。天女过去无量亿那由他阿僧祇劫。尔时有佛号同性灯如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。时阎浮提多有众生。无量无边不可算数。悉皆成就安隐快乐。无诸饥渴苦恼等患。其地广博清净严事。广纵六万八千由旬。多有诸城七万八千。一一大城七宝所作。其城四壁有九万却敌

尔时大城名曰宝聚。即是今之王舍城也。时宝聚城有八万千亿人。同姓灯佛出生彼城。彼城所有无量众生悉发阿耨多罗三藐三菩提心。成就神通人中象王。天女。尔时如来在大众中作师子吼。宣说如是大云经典。时彼城中有王名曰大精进龙王。王有夫人名曰护法。有一大臣名法林聚。尔时国王与其夫人及其大臣。往彼佛所供养恭敬合掌作礼。右绕三匝却坐一面。尔时同姓灯佛知大精进龙王心中所念。放大光明名无所畏。王遇此光心得法喜。尔时大臣承佛神力。白佛言。世尊。如来舍利为可得不。尔时世尊默然不答。天女。尔时大王为正法故。即共大臣翻覆往反论讲舍利。时佛闻已即赞叹言。善哉善哉。彼佛众中有大弟子字摩诃男。心生善欲而作是念。善哉大王。善解如来甚深法界。时佛即为时会大众。说王所解深法妙义。大众已闻皆生惊疑。时佛即告诸大众言。此王功德不可思议深不可测。非是汝等所能得解。尔时大王闻佛称赞己之功德。心大欢喜即起供养。右绕千匝以采宝华用散佛上。而复赞叹即发愿言。未来当有释迦如来兴出于世。以大方便示法灭时。我当于中出家修道。受持净戒具大势力。见有破戒行恶比丘。我当驱摈至于边方无佛法处。为正法故不惜身命。尔时大臣复作是愿。释迦如来以大方便现涅槃已。我当于中作大国王。护持如来无上正法。见恶比丘唱令驱出。有持法者恭敬供养。是时夫人复作是愿。释迦如来出现之时。令我势力能伏邪见。时摩诃男复作是愿。使我尔时为彼如来。作大弟子得大神通。于佛功德能师子吼。天女。如是四人今于我世为法重任。不但今日方于未来。复当护持我之正法。是时天女。即白佛言。我今未知。如是四人斯为是谁。惟愿如来其名说字。佛言。善哉天女。至心谛听谛听。吾当为汝分别解说。尔时大臣。即今善德婆罗门是。是婆罗门于我灭后百二十年。王阎浮提字阿叔迦。住于波梨弗罗城中。姓无邪氏得转轮王。所有福德二分之一。于阎浮提得大自在。护持正法大师子吼。为法流布大得舍利。供养恭敬尊重赞叹。见恶比丘治令修善。天女复言。惟愿解说。尔时佛告天女。且待须臾。我今先当说汝因缘。是时天女闻是说已。即生惭愧低头伏地。佛即赞言。善哉善哉。夫惭愧者。即是众生善法衣服。天女。时王夫人即汝身是。汝于彼佛暂得一闻大涅槃经。以是因缘今得天身。值我出世复闻深义。舍是天形即以女身当王国土。得转轮王所统领处四分之一。得大自在受持五戒作优婆夷。教化所属城邑聚落男子女人大小。受持五戒守护正法。摧伏外道诸邪异见。汝于尔时实是菩萨。为化众生现受女身。是时王者。即今一切众生乐见梨车子。是深达正法甚深之义。能开如来微密法藏。护持佛法无所亏损。时摩诃男者。即今大云密藏菩萨是。得我真身二分之一。知恩报恩护持正法。能答深义无所滞碍。天女。我今此众虽有上智大迦叶等。不能宣辩甚深之义。如大云密藏菩萨摩诃萨也

尔时众中有一天子字曰奇才。与千天子即起向佛。以诸华香幡盖伎乐供养于佛合掌恭敬。以偈赞佛

  大海可度量　　须弥可称知
  如来法境界　　难可得思议

说是法时无数千人发阿耨多罗三藐三菩提心

尔时如来告善德言。善哉善哉。大婆罗门。汝今善发欢喜之心得无上果。大婆罗门。从是南去度三十万恒河沙等世界。彼有世界名须曼那。有佛世尊号净光秘密如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。常住在世为化众生转正法轮。从彼南去复度五十万恒河沙等世界。彼有世界名法喜宝。佛号法藏如来。应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。常住在世为化众生转正法轮。从彼南去复过六十万恒河沙世界。彼有世界名一切池。佛号师子吼神足王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。常住在世为化众生转正法轮。从彼南去复过三十六万恒河沙等世界。彼有世界名曰华幡。佛号高须弥十号具足。乃至转正法轮。从彼南去复过八十万恒河沙等世界。彼有世界名曰宝手。佛号法护十号具足。乃至转正法轮。大婆罗门。如是诸佛世界严净其土。无有山陵堆埠石沙秽恶。其地柔软如迦陵伽衣。世无五浊亦无女身二乘之人。乃至无有二乘之名女人名字。纯诸菩萨摩诃萨等。甘乐大乘护持大乘乐说大乘。大婆罗门。若有善男子善女人。受持如是诸佛名号。堕三恶道者无有是处。必定当得阿耨多罗三藐三菩提。大婆罗门。以是义故。我涅槃后是经当于南方国土广行流布。正法欲灭余四十年当至北方。北方有王名曰安乐。见有受持书写经卷读诵说者。随时给施四事无乏。尔时北方当有八万四千众生受持是经卷。善男子。若有人闻如是经已。舍放远离无有是处。若有善男子善女人。顶戴受持诸佛名号。若中兵毒水火盗贼无有是处除其宿业。复次 大 婆罗门。若内四部若外众生。为供养故为怖畏故为坏法故。奉持如是诸佛名号。终不堕于三恶道中。若至三恶无有是处

尔时善德复作是言。世尊。若有众生闻是经名。尚得如是无量善利。况有受持读诵书写解说之者。若得闻彼诸佛名号。则为已得无上大宝。阿耨多罗三藐三菩提已在其手。诸佛如来已到其舍。其地金刚其身亦尔。心坚不动不可移转。世尊。我今亦当恭敬供养如是之人。佛言。善哉善哉。大婆罗门。汝今善知善解如来功德之力。若有众生闻彼佛名。敬信不疑无诸怖畏。所谓王怖人怖鬼怖无诸疾病。常为诸佛学道弟子八部鬼神。及其眷属之所守护。诸佛所念

尔时众中有乾闼婆王名曰喜见。从座而起往至佛所。合掌恭敬白佛言。世尊。如来灭后何等众生。能受持是经广令流布。何等众生。不能受持令法毁灭。尔时如来默然不答。时大迦叶语喜见言。善男子。如来真实无有涅槃法无灭尽。云何而言如来灭后谁受是经。喜见王言。大德。一切众生狂愚无智。惟愿大德。宣说如来所以不灭。一切众生痴闇所覆。愿燃法灯令得开明。我于未来亦当广为一切众生开发是义。惟愿大德。哀愍故说。大迦叶言。善男子。如来法身不名肉身。佛身金刚非破坏身。成就具足无量功德。方便之身不名食身。如是之身云何言灭。喜见王言。大德。我今定知如来世尊。方便涅槃非毕竟灭。尔时迦叶赞喜见言。善哉善哉。实如所说。善男子。大海可量如来功德不可称。知喜见王言。如来何时当毕竟灭。大迦叶言。假使一切所有众生乃至蚊蚁。悉得阿耨多罗三藐三菩提入于涅槃。如来尔时乃当涅槃。喜见王言。大德。如来成就如是无量无边功德。一切众生何故不发阿耨多罗三藐三菩提心。苦哉苦哉。众生薄福不知如来常住不变金刚之身非杂食身。大德。如是之身惟佛能知。非诸声闻缘觉所及

迦叶复言。善男子。一切众生悉有佛性得菩提心。说是法时二万二千天子。发阿耨多罗三藐三菩提心。异口同音。而说偈言

  如来不涅槃　　真法无有灭
  为诸众生故　　示现有灭度
  如来常不灭　　为众方便说
  如来不思议　　法僧亦复然

大方等无想经卷第四大方等无想经卷第五

        北凉天竺三藏昙无谶译

    大云初分增长健度第三十七之一

尔时南方有诸天子其数无量。从黑山中来至佛所。以诸香华幡盖伎乐供养于佛。头面作礼右绕三匝白佛言。世尊。如来今日说是经典。南方世界无量无边恒河沙等诸佛世尊亦说是经。世尊。如是经典名字何等。善男子。如是经典凡有三名。一名大云。二名大般涅槃。三名无想。大云密藏菩萨所问故名大云。如来常住无有毕竟入涅槃者。一切众生悉有佛性。故得名为大般涅槃。受持读诵如是经典。断一切想故名无想。善男子。有人亲近无量恒河沙诸佛世尊。于诸佛所受持净戒。供养恭敬尊重赞叹成大功德。然后乃得闻是经典。虽得闻受不能广说。若于不可计不可数恒河沙等诸佛世尊。受持净戒乃至成大功德。闻已则能分别广说。善男子。正法欲灭是经当于阎浮提中具足流布。佛涅槃后初四十年亦当流布。正法垂灭余四十年复当流布。行恶之时。谤方等时。恶王治时。我诸弟子毁禁戒时。遭值荒乱世人轻时。四部弟子。不修身不修戒不修心不修慧。无明狂痴习放逸时。凡所造作同畜生时。不随和上师长教时。违反上座耆宿长老。当尔之时我诸弟子。于是经中不能信受。轻笑讥呵互相呰篾。云何邪见说为方等。剃头之人名为沙门。云何反读邪见经书。实非佛语为利养故说为佛语。公于众中唱如是言。如此经者真是邪见非佛所说。慎勿读诵书写受持。尔时大众即共答言。大德。莫作是语。此经相义实是佛说。我今为经当相供给。我此弟子。为供养故素无信心受持诵说。是名灭法。复次天子。未来之世法欲灭时。我四部众薄福少智不知厌足。退失善根贫于法财。无心亲近佛法僧宝。为衣食故剃头染衣。其心粗穬如秃居士。畜养奴婢金银珍宝钱财珂贝琉璃颇梨。贮聚谷米牛马畜生田宅屋舍。杂色卧具食肉嗜味。背舍诸佛成就十六不善律仪。亲近国王大臣长者。受使邻国通致信命。受人供养反生恶心。成就一切非沙门法非婆罗门法。天子。如是恶世恶比丘时。尔时我当有一弟子。持戒清净少欲知足如大迦叶。善能教化阎浮提内。我弟子中习行恶者。说真正语不惜身命。广开如来深密秘藏。赞叹持戒行头陀者。成就具足波罗提木叉。称美知足粪扫衣服。广为恶人说如是言。诸大德。世尊不听受畜一切不净之物。贪味食肉。如来常赞持净戒者。呵责毁禁。大德。汝今若不受我语者。我有大力势能相降伏。我此弟子福德力故。咸令一切信伏无违。何以故。是人已曾亲近无量诸佛世尊。广修慈悲贪乐大乘护正法故

尔时常有五万八千诸善鬼神。随从侍卫为欲守护佛正法故。天子复言。世尊。我等未来亦当护是持法比丘。佛言。善哉善哉。天子。如汝所说。法欲灭时当勤守护。天子。当尔之时。我亦能以威神道力。摧伏恶魔治恶比丘。尔时十方无量诸佛。亦同赞叹我此弟子。尔时一切南方天子。复以华香供养世尊白佛言。世尊。如是弟子。何时当出在何国土名字何等。佛言。善男子。我涅槃后千二百年。南天竺地有大国王。名娑多婆呵那。法垂欲灭余四十年。是人尔时当于中出讲宣大乘方等经典。拯拔兴起垂灭之法。广令是经流布于世。教人具足执持读诵书写解说听受其义。尔时若有不能如是。受持解说是经典者。当知是人非我弟子魔之眷属。尔时乐见乾闼婆王白佛言。世尊。唯愿矜哀解说。未来持法弟子如迦叶者。成就大慈具足净戒。种性眷属无可讥呵。佛言。善男子。谛听谛听当为汝说。我此弟子守护正法持佛种姓。一切众生所乐见者。善男子。是南天竺有小国土名 须赖吒 。其土有河名善方便。其河有村名曰华鬘。华鬘村中有婆罗门产一童子。即是今之一切众生乐见梨车。后时复名众生乐见。是大菩萨大香象王。常为一切恭敬供养尊重赞叹。其年二十出家修道。多有徒众修持净戒称咏诸佛大乘经典。为护正法不惜身命。其诸弟子亦复如是。若有比丘比丘尼优婆塞优婆夷。闻是比丘所说正法。必定当得阿耨多罗三藐三菩提。尔时国王大臣长者及一切人。为此经故供养恭敬是持法者。是经力故令彼国王得大势力。所有国土无能侵陵。我此弟子魔不得便

尔时若有受持读诵书写是经。则得名为大菩萨也。名为福田在净僧数。乾闼婆王。当于尔时我诸弟子。多有信受如是经典。得解脱者亦复不少。善男子。若有人能成就四事则能受持如是经典。一者得闻深进大海水潮三昧。二者得闻南方佛名。三者亲近于善知识。四者至心信佛法僧。尔时若有不能信受是经典者。是魔眷属。若有信者是佛弟子。善男子。未来之世有信心者。名为亲近诸佛世尊。何以故。如是经典诸佛封印。所谓印者。一切众生悉有佛性。如来常住无有变易。善男子。若有人能信是经者。当知是人真佛弟子。有能恭敬是持法者。是人当为未来诸佛徒众眷属。何以故。无量诸佛已于是人生已有心故。所以者何。是持法比丘不可思议。已于过去同然灯佛发大誓愿。未来之世释迦如来法垂欲灭。我当于中出家修道。为护正法不惜身命。时王精进龙王者。即今乐见梨车。是乐见梨车。即是未来护法比丘。善男子。汝善观察我此弟子未来功德。若有人能恭敬供养我此弟子。当知是人即为十方三世诸佛之所恭敬。若未来世比丘比丘尼优婆塞优婆夷。信受如是持法比丘所可演说。即是信受十方诸佛所有言说。若有比丘比丘尼优婆塞优婆夷。爱敬如是持法比丘不惜身命。即为十方三世诸佛之所爱念增长寿命。若未来世比丘比丘尼优婆塞优婆夷。恭敬供养是持法者。专心系念听其所说不求其短。当为十方三世诸佛之所推觅。护念守持如罗睺罗护念禁戒。善男子。未来之世薄福众生。比丘比丘尼优婆塞优婆夷当作是言。咄哉咄哉。如是众生乐见比丘。实非比丘作比丘像。远离诸佛所说经典。自说所造名大云经。远离诸佛所制禁戒。自为众生更制禁戒。诸大德。各各谛听。若言贮畜金银珍宝名为破戒。不贮畜者名为持戒。如来何处当作此说。此非佛语说为佛语。我当云何不惜身命。恭敬供养如是恶人。宣说恶语以为佛语。唱说恶戒以为佛戒。诸大德。我实不能信受如是恶比丘言。若有供养如是人者。唐捐其功终无果报。尔时诸人闻是语已。所有信心各各坏灭。若有信受是恶语者。当知是人从闇入闇。若不信受是人。则得从明入明。善男子。若有随顺是恶语者。是魔眷属。若不随顺真我弟子。善男子。是大云经其义幽隐难可解了。若未来世有四部众福德纯厚。得菩提心勤修行者。作如是言。善哉比丘真佛弟子。善住大地是大菩萨。勇猛大士非下人也。下劣之人不能如是回转大海。诸大德。汝等可来当共供养如是比丘。诸大德。我今见是持法比丘。即是过世无量功德之果报也。随是比丘所住之处。当知其地及其众生。功德成满安乐无患。若得睹见是比丘者。当知是人已得天眼法眼具足。我为是人不惜身命。若闻其言宁舍身命终不忘失。我今宁为如是一人不惜身命。终不能为非法徒党百千万人舍于身命。善男子。如是恶法兴出之时。我此弟子。当于是中护持我法。善男子。未来之世法欲灭时。若有比丘比丘尼优婆塞优婆夷。为护法故不惜身命。是则名为炽然慧灯度脱众生。修行一切诸佛所行。得法翅羽破魔境界。身得自在心得自在身不可思议。为诸众生之所爱敬。善男子。法欲灭时是持法者。一日一夜六时唱令告诸众生。汝等当共受持正法。诸恶比丘闻是语已心不甘乐。不甘乐故便作是言。大德。如是邪法谁当信受。默然者善。若不默然当夺汝命。是持法者复作是言。我宁舍命终不默然。诸恶比丘寻共害是持法比丘。善男子。如是人者是我最后持法弟子。当知尔时我法则灭。若言尔时我弟子中更有如是护持法者。无有是处。乾闼婆王言。是持法者。舍是身已更得何身。佛言。善男子。舍是身已。当得佛身无边之身。乾闼婆王言。唯愿世尊。为诸众生说是比丘云何舍身而得佛身。佛言。善男子。善哉善哉。听我说此持法弟子功德之事。过此贤劫千佛灭后。具满六万二千劫中空过无佛。尔时当有无量亿那由他诸辟支佛在世教化。过是劫已有七佛出。是七如来般涅槃已。此国尔时转名喜光。是喜光国当有佛出号智聚光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是佛世界所有人民。颜貌端正信心成就。若有人能于我法中没命护持。悉当生于彼佛世界。而为彼佛作大弟子。大弟子者即是菩萨摩诃萨也。真大丈夫大香象王。彼界人民一切无有贪欲恚痴。皆悉成就清净信心。智聚光佛寿十五中劫。为诸弟子开三乘教。虽开三乘多说菩萨一乘之行。尔时虽有魔王魔子。悉发阿耨多罗三藐三菩提心。一切众生悉得大慈大悲之心。皆得远离三恶道苦无有八难。世界常净犹如北方郁单越土。天魔波旬不得其便永断邪见。彼佛如来入涅槃已。法住千亿然后灭尽。说是语时。一切大众诸天龙神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。持诸华香微妙伎乐供养于佛。大迦叶等诸大弟子。欢喜赞叹恭敬作礼。诸大菩萨复持妙华大如须弥。供养于佛悉共发愿。愿我未来生彼佛世

尔时大云密藏菩萨白佛言。世尊。唯愿如来。为未来世薄福德众生。演说如是深进大海水潮三昧。佛言。善男子。汝今不应作如是言。何以故。佛出世难。此大云经闻者亦难。若有书写受持读诵一句一字亦复难得。云何偏为未来之人。吾当普为三世众生广开分别。善男子。我以未来薄福众生罪根深重。是故唱言此经当于未来流布。善男子。未来之世若能于此大云经中。信心不疑读诵一偈。如是之人甚为难得。世尊。如来何故作如是言。善男子。我亦不独为未来说。何故而生如是疑心。若有能听如来所说一偈一句。不生疑心。于三世中亦复难得。何以故。三世众生难得三昧陀罗尼门知恩报恩。未来众生不知恩分不能报恩。不知恩故信心难得。信难得故是故我言为未来世说此经典。若能读诵受持是经一偈一句是人难得。未来众生薄福罪重。是故复言为未来世说此经典。大云密藏菩萨言。世尊。若有菩萨安住如是深进大海水潮三昧。成就无量无边功德。非是声闻缘觉所知。佛言。善哉善哉。善男子。住是三昧诸菩萨等深不可测。譬如大海众流所归不可量数。善男子。如是大海犹可量数。而诸菩萨不可量数。何以故。安住如是深三昧故

复次善男子。若有菩萨住是三昧。能以足指一毛。举此恒河沙等三千大千诸大世界。高至上方无量世界。令诸众生无有怖畏往反之想。而今他方一切悉见为化度故。乃至十方亦复如是。世尊。如是三昧乃为无量无边功德之所成就。是故佛说普为三世。善男子。善哉善哉。实如所言。善男子。譬如大海总摄一切诸河泉流。此大云经亦复如是。总摄一切无量经典。复次善男子。若诸经典有如是等无著三昧。当知彼经已为摄在此经典中。一切声闻辟支佛等所得三昧。比此三昧不可为喻。何以故。声闻缘觉无常无我无乐无净。无著三昧广开如来常乐我净无有变易。是故此二不得相喻。善男子。若闻如来常不变易信心清净。当知是人得阿耨多罗三藐三菩提心修菩提道。善男子。若男若女欲得常住无有变易。应当受持读诵书写演说是经。若能如是受持演说是经典者。当知是人不久当得阿耨多罗三藐三菩提。若有人闻如来常住无有变易心生疑怖。当知是人不见如来真实之相。真实相者。所谓如来常恒不变湛然安住。是故闻者不应疑怖。应当受持广为人说。如是说者。当知佛法常住无灭。善男子。如一切众生迹入象迹中。一切三昧亦复如是入此经中。善男子。如阎浮提一切山河丛林树木。及四天下山河树木日月星宿。悉皆入于三千大千世界之中。一切凡夫声闻缘觉诸佛菩萨所有功德。禅定三昧亦复如是。皆悉入此大云经中。若有众生能于一念。念诸如来常住不变。当知即得阿耨多罗三藐三菩提。善男子。譬如秋月无诸云雾。虚空清净日初出时。光明端严人所爱乐。除破一切幽闇黑冥。是大云经亦复如是。演出如来常恒不变猛盛之日。处在清净密语虚空。破除众生无常无我无乐无净一切暗障。端严爱乐者。喻于如来终不毕竟入于涅槃

复次善男子。譬如有人身轻行疾喻四风王。寿命满足天数千年。飞行周游十方世界。遍已还到本所住处。如是行处满中七宝。并以己身供养三宝。复满无数千年之中。善男子。如是福德可数量不。不也世尊。善男子。如是福德不比有人一念之中。念如来常法僧不灭。善男子。若复有人为利养故为恐怖故为亲近故。演说如来常恒不变一字一句。所得福德比前功德。百分不及一分。千分百千万分。乃至算数譬喻所不能及。善男子。譬如药树。若有众生取枝取茎取叶取华取果取皮。是树亦不生念取枝莫取茎。取茎莫取叶。取叶莫取华。取华莫取果。取果莫取皮。而令一切众病除愈。随上中下众生所用。若以合水若以合苏。若末若丸若涂若服。悉能愈病。是大云经亦复如是。不观众生若举一偈若半偈。一名一义一句半句。信受二字言如来常。亦不观察众生有修深进大海水潮三昧。大慈大悲及不修行。悉能令断三恶道病。如来亦不观察众生取一偈不取半偈。取半偈不取名。取名不取义。取义不取句。取句不取半句。取半句乃至二字。皆悉能令四部之众离三恶道。善男子。未来之人不修身不修戒不修心不修慧。轻笑贱慢为求过失及以利养。少多读诵书写听受。亦得远离无量恶。业。永断贪欲恚痴等病。善男子。如日出时能消冰雪。是大云经亦复如是。说如来常。能消一切无常冰雪。复次善男子。譬如虚空猛风起时吹众生身入诸毛孔。能令热病一切除愈身得清凉。虚空者喻大云经。猛风起者喻如来常。风入毛孔者喻诸众生悉有佛性。除热病者喻断声闻辟支佛心。复次善男子。若有人能读诵受持如是经典。终不为于须陀洹果。护持禁戒终不为向斯陀含得斯陀含。向阿那含得阿那含。向阿罗汉得阿罗汉。护持禁戒若为向佛取无上果。是则名为真持禁戒。非为三十二相八十种好护持禁戒。若为如来不可思议乃名护戒。如来非为住心修集无量三昧。亦复不为住心修集与诸佛等。亦复不为住心修集无量因果。不为住心修集诸佛无量功德。如来住于无所住者。是为实相。若欺如来无上印者。不名护戒。若言如来为是印故。名护戒者。汝于此中慎勿生疑。如来无相故名为护戒。若言如来为于相故名护戒者。亦勿生疑。如来无种好故名为护戒。若言如来为种好故名持戒者。亦勿生疑。如来非神通因缘故名为护戒。如来非密藏故名为护戒。如来非无上福田故名为护戒。如来非为如来藏故名为护戒。如来为断一切众生生老病死众苦逼切名为护戒。为欲安乐诸众生故名为护戒。为断众生生死缚故名为护戒。为令众生专向无上菩提道故名为护戒。为诸众生得阿耨多罗三藐三菩提故名为护戒。欲为众生转法轮故名为护戒。为令众生一切皆得圣僧名故名为护戒。为令众生不断如来圣。种姓故名为护戒。为令众生一切不断法僧种故名为护戒。为令众生一切悉得三昧禅定智慧解脱故名为护戒。为令众生悉得净戒具足无缺故名为护戒。如来无戒故名护戒。断一切戒故名护戒。如来非有此戒故名护戒。非无此戒故名护戒

尔时大云密藏菩萨摩诃萨白佛言。世尊。若言如来不护戒者。其义云何。若复有言菩萨住是深进大海水潮三昧不护戒者。其义云何。如来非为无上印故名护戒者。义复云何。佛言。善男子。菩萨摩诃萨自从住是三昧已来。初不曾住有为法中。具足成就一切佛法。何以故。如是三昧悉已摄取一切佛法故。善男子。如大宝聚有青琉璃其色清净。人见之者不生疑心。菩萨摩诃萨从得住是三昧已来。即见佛性了了无疑。何以故。见了了故若有疑者无有是处。如来境界不可思议。善男子。菩萨住是三昧已。成就具足诸佛功德。世尊。菩萨摩诃萨住是三昧得毕竟不。善男子。汝不应言如是菩萨得毕竟不。何以故。若一切众生得是三昧。悉成阿耨多罗三藐三菩提尽毕竟已。然后乃当问是菩萨得毕竟不。世尊。如是三昧甚为希有。若诸众生不得闻受甚可怜愍。若得闻者当知是人得大饶益。佛言。善哉善哉。若有闻是三昧名者。当知是人人中之上。譬如族姓端正王子。威猛勇健心无悭吝。持戒清净无可讥呵。人所乐见眷属敬念。统领国土人民归顺。菩萨摩诃萨住是三昧。亦复如是。皆悉成就诸佛功德。善男子。如旃陀罗终不作王。若作王者无有是处。何以故。诸上族等所蚩笑故。若有众生不能受持读诵书写如是三昧。欲得成就诸佛所有微妙功德。亦无是处。何以故。当为一切诸菩萨等所蚩笑故。善男子。汝今观是安住三昧诸菩萨等。能知如来常恒不变。若有不能住是三昧。则不能知如来常恒无有变易。菩萨摩诃萨为众生故。受持读诵如是三昧。则得具足檀波罗蜜。何以故。如是菩萨见有求索头目髓脑支节手足国城妻子奴婢仆从象马七珍。则能随彼种种给施。尚以身施况复外宝。施时欢喜施已无悔。于阿耨多罗三藐三菩提。若得不得心无疑虑。终不为报而行布施若言为报行布施者无有是处。不为贪故而行布施。为怜愍故而行惠施。为如来常故为护法故。为欲具足檀波罗蜜。演说如来常恒不变故行惠施

复次善男子。菩萨摩诃萨住是三昧已。则能少知一切众生悉有佛性。如来常恒无有变易。住是三昧菩萨摩诃萨常作是观。我今此身空无所有。已得无上大利益事。我今以此支节手足头目髓脑肌皮血肉。布施于人未来当得阿耨多罗三藐三菩提。世尊。菩萨摩诃萨住是三昧。云何而作如是观身。善男子。是菩萨摩诃萨不见是身去来坐卧犹如空瓶。是故菩萨观身空寂血肉骨髓名为空身。住是三昧诸菩萨等。得非血肉骨髓之身。成就法身不名食身。世尊。如来法身不名食身。其义云何。法身无像不可睹见。云何而得教化众生。如来常于诸经中说。如鸟飞空无有足迹。如来法身亦复如是。无有去来无转无说不可破坏

大方等无想经卷第五大方等无想经卷第六

        北凉天竺三藏昙无谶译

    大云初分增长健度第三十七之余

佛言。善男子。勿作是语。如来常所化众生身。是名化身。世尊。其义云何。世尊。如佛所说住是三昧则得法身。云何复言是变化身。如来法身。若为教化作杂食身。云何此身非虚妄耶。真法身者。云何复作杂食之身。若作 食身是义不然。佛言。止止勿作是语。住是三昧菩萨摩诃萨。若有化身是名幻身。世尊。何故颠倒以此非身而名为身。无物者名之为幻。若是幻身。云何而得不诳众生。佛言。善男子。莫作是观。住是三昧菩萨摩诃萨无有住身。虽无住身如药树王。如草木瓦砾。我身亦尔。何以故。我身无我无有我所。无命无语无心无实无阴界入。犹如药树能除众生一切病苦。我身亦尔。除灭众生无量病苦。何以故。身如幻故。复次善男子。譬如药树终不生念取叶莫取枝。菩萨摩诃萨亦复如是。终不生念取手莫取足。何以故。是三昧力故。亦能除断一切众生贪欲嗔恚愚痴等病。住是三昧菩萨摩诃萨。无内身无外身无内外身。无死生身得甘露身。甘露身故。能断众生贪欲嗔恚愚痴等病。复次善男子。住是三昧菩萨摩诃萨作变化身。为断一切诸恶鸟兽及三恶道。犹如药树。若有人言诸恶鸟兽遇菩萨身到三恶道。无有是处。若言舍身转至人天见诸佛者。斯有是处。复次善男子。若言四众住是三昧。则得亲近无量诸佛。亦有是处

复次善男子。比丘比丘尼优婆塞优婆夷。若欲修习是三昧者。先当思惟如来常恒无有变易佛法不灭。无有毕竟入涅槃者。复作是念。一切众生种种所须我当给施。若脚若手若头若目。为正法故悉舍所有。舍时欢乐舍已无悔。何以故。我此身者犹如药树。若能作是一念思惟。当知不久得是三昧。复次善男子。譬如骏马髦尾纤长。于十五日布萨之时。在大海中悲鸣三唱。谁欲度海谁欲度海。若有诸人乘其背者。及捉髦尾颈项首脚。悉得到于大海彼岸。是大云经亦复如是。若有人能受持读诵解说书写。乃至一句一字二字。一切皆度三恶彼岸永得解脱。复次善男子。比丘比丘尼优婆塞优婆夷。若有得闻是三昧名。生生常得转轮圣王帝释梵王。终无退转常得亲近佛法圣众。于菩提心坚固不动。不舍大乘方等经典。世尊。云何菩萨摩诃萨住是三昧。于一切法所见真正。佛言。善男子。若有成就是三昧者。见于如来无常无乐无我无净毕竟涅槃。则不得名所见真正。若见如来常乐我净终不毕竟入于涅槃。如是乃名所见真正。世尊。如佛所说若见如来常乐我净其义云何。善男子。常乐我净即是如来真实之性。世尊。若如是者。一切凡夫亦得成就如是实性。何以故。凡夫之人亦复计于常乐我净。善男子。汝今不应作如是说。我言具是三昧菩萨。乃能见于常乐我净。不说凡夫所计颠倒常乐我净。世尊。如佛所说若见诸法无常无乐无我无净。是人则见上道下道得须陀洹果。乃至得阿耨多罗三藐三菩提。若见诸法常乐我净。则不能得须陀洹果。乃至阿耨多罗三藐三菩提。云何世尊言。菩萨成就是三昧已。则得见于常乐我净。又如佛言。真解脱者犹如虚空。如是解脱即是涅槃。云何如来说言涅槃常乐我净。一切众生亦如虚空。水月梦幻芭蕉云电。空无性相不得暂住。犹如画水随画随合。见觉无常无乐无我无净。见如是相则名真见。真见者得须陀洹果。乃至阿耨多罗三藐三菩提。云何如来说言菩萨成就是三昧。乃得见于常乐我净。如佛先说诸佛如来观一切法无常无乐无我无净。无有寿命士夫众生空无所有。是名诸法真实之性。今者复言见一切法常乐我净。是义云何。善男子。止止莫作是言。善男子。若有菩萨成就具足是三昧已。则不复与诸法和合。不和合故得名护戒修习三昧菩萨摩诃萨。不见诸法断常之相。不见断故不生喜悦。不见常故不生忧戚。为知法印不为护戒。亦不得名修习三昧。如来不着护戒毁戒常无常。觉不觉作不作。净不净空不空。戒非戒知非知。名非名取非取。怖非怖畏非畏。因非因灭非灭。菩提非菩提。解脱非解脱。涅槃非涅槃。一切诸法无有怖畏。为解脱故护持禁戒修习三昧。一切诸法无有退灭。菩萨知已其心甘乐。修是三昧为诸众生说。佛如来常恒不变正法不灭。是故护戒修习三昧。复次善男子。若有欲得如是三昧。应当修习常想我想命想人想。习此想已则得成就具是三昧。若言不得无有是处

世尊。如来或说无常无乐无我无净。或时复说常乐我净。其义云何。善男子。世俗之道。谬见诸法常乐我净。是故我说无常无我无乐无净。世尊。出世之法。颇复得有常乐我净不。善男子。若有菩萨住是三昧。欲说我时先说五事。何等为五。一者谷子。二者树子。三者肥味。四者伏藏。五者蛇蜕。善男子。如谷子者。芽时茎时叶时华时。名为无常。若收果实众生受用。则名为常。菩萨摩诃萨若未成就是三昧者。无常无我无乐无净若已成就则得名为常乐我净。未能度脱一切众生。名无常无我无乐无净。若能度脱则得名为常乐我净。不能破坏一切邪见。名无常无乐无我无净。若能破坏则得名为常乐我净。不能永断诸烦恼故。名无常无乐无我无净。若能永断是则名为常乐我净。善男子。是名谷子。复次善男子。如庵罗树未得果时。名无常无乐无我无净。若得果实众生受用。是则名为常乐我净。菩萨摩诃萨未得成就是三昧者。名无常无我无乐无净。若成就已则得名为常乐我净。未能度脱诸众生故。名无常无乐无我无净。若能度脱则得名为常乐我净。不能破坏一切邪见。名无常无乐无我无净。若能破坏则得名为常乐我净。不能永断诸烦恼故。名无常无乐无我无净。若能永断则得名为常乐我净。善男子。是名树子。复次善男子。如胡麻子未成油时。不能消除众生病苦。名无常无乐无我无净。若成油已能除众生所有病苦。是故得名常乐我净。菩萨摩诃萨未得成就是三昧者。无常无乐无我无净。若成就已则得名为常乐我净。未能度脱诸众生故。名无常无乐无我无净。若能度脱则得名为常乐我净。不能破坏一切邪见。名无常无乐无我无净。若能破坏是则名为常乐我净。不能永断诸烦恼故。名无常无乐无我无净。若能永断是则名为常乐我净。善男子。是名肥味。复次善男子。如有宝藏隐伏地中。不能润益一切众生。故名无常无乐无我无净。若出地已众生受用为大利益。是则名为常乐我净。菩萨摩诃萨若未成就是三昧者。名无常无乐无我无净。若成就已则得名为常乐我净。未能度脱诸众生故。名无常无乐无我无净。若能度脱则得名为常乐我净。若不能坏一切邪见。名无常无乐无我无净。若能破坏是则名为常乐我净。不能永断诸烦恼故。名无常无我无乐无净。若能永断则得名为常乐我净。善男子。是名宝藏。复次善男子。如蛇脱皮。未脱皮时名无常无乐无我无净。若脱皮已则得名为常乐我净。菩萨摩诃萨未得成就是三昧者。名无常无乐无我无净。若成就已则得名为常乐我净。未能度脱一切众生。名无常无乐无我无净。若能度脱则得名为常乐我净。若不能坏一切邪见。名无常无乐无我无净。若能破坏则得名为常乐我净。不能永断诸烦恼故。名无常无乐无我无净。若能永断则得名为常乐我净。又断众生于佛所起四种疑心常乐我净。善男子。是名蛇蜕。善男子。菩萨摩诃萨住是三昧。以此五事演说如来常乐我净。能说我人寿命众生士夫。能如是见名为正见。世尊。如来所说如是五事。是义不然。何以故。如来常于诸经中说。诸法无常如向五事。因亦无常果亦无常。若使菩萨住是三昧如五事者。亦应无常。以是义故。一切诸法无非无常。世尊。有因必有果。有果必有因。一切众生及诸菩萨亦复如是。有生必有死。有死必有生。若如是者常亦无常。无常亦常。以是义故一切诸法悉有二性常与无常。不应定言世法无常出世法常。如来实语云何出是虚妄之言。善男子。汝今何故如蚕自裹。善男子。若有人言端正之人犹如满月。香象姝白犹如雪山。人实非月。象非雪山。少有相似故引为喻。善男子。世间五事亦复如是。有少常故故以为喻。诸佛如来实不可喻。犹引喻为喻。世尊。若如来常者。何故复于余经中说。犹如灯灭解脱亦尔。世尊。如来若常云何得灭。如其灭者云何言常。如来若言亦常亦灭。如是之言非虚妄耶。又如佛言。一切诸法犹如水月。诸法若常。云何复言犹如水月。善男子。我说有为如水中月。是故我说。余法有常余法无常。若有众生未得解脱。未断烦恼未断名相未断众生相。不得法相未得修习如是三昧。是名无常。若有众生已得解脱。永断烦恼名相众生相。得于法相修习三昧。是名为常。是故我说。余法有常余法无常。世尊。若尔者如来何故说。佛涅槃犹如灯灭。如灯灭者为喻身灭为喻结灭。如膏不离灯灯不离膏。众生亦尔。身不离结结不离身。云何言灭。佛言。善哉善哉。善男子。若如是见名为正见。善男子。身有二种。一者烦恼身。二者法身。烦恼身灭犹如灯灭。是故我说余法无常。法身无灭犹如虚空。是故我说余法是常。断烦恼器名为解脱。得解脱已无常身者。诸佛世尊则是断见。若烦恼气常不灭者。诸佛世尊则是常见。诸佛世尊定无有此断常二见。诸佛世尊已于无量阿僧祇劫断此二见。如来若有众生相者则应无常。如来已于无量劫中断众生相。若言如来有众生相无有是处。善男子。譬如大王出入游巡。若在外时内则不见。内虽不见不得言无。外亦如是。菩萨摩诃萨住是三昧无常已断。为众生故受无常身。若言如来身无常者无有是处。是故我说常与无常。说我无我。说众生非众生。说人非人。说命非命。说士夫非士夫。如来常说。有为之法皆是无常终不言常。若言常者无有是处

复次善男子。菩萨摩诃萨住是三昧。则得断除世见命见声闻缘觉见。无有贪爱无取无求常不变易。成就安住得无所畏。无有憍慢垢不能污。是故我说常乐我净。善男子。我说声闻辟支佛乘。一切世人之所不解。虽世人不解终不得。言慧者亦尔。世间之人虽见如来无常无乐无我无净。亦不得言有智慧者。同于彼见。薄福钝根行邪道者作如是言。如来无常永灭涅槃。若言如来永灭度者。当知是人不离三恶。善男子。譬如深汪其水浑浊。中有宝珠人所不见。有人唱言。此浊水中有大宝珠。众人闻已竞共求觅。或得瓦石沙砾草木。然无有能得真宝者。以不得故便言虚妄。复更有人善知方便。以无价珠置之浊水。水即为清。众人因是悉见真宝。善男子。声闻缘觉不解如是三昧力故。说言如来无常无乐无我无净空无所有。不知如来常恒不变轮转生死。菩萨摩诃萨住是三昧。善解如来所有密语。是故以此无价宝珠喻于三昧。善男子。若男若女欲见如来常恒不变。应当修习如是三昧。菩萨摩诃萨住是三昧。则见如来常恒不变。解脱亦尔。善男子。譬如树荫行路之人因之憩息。住是三昧诸菩萨等亦复如是。为诸众生而作荫覆善男子。若有人言如来无常永涅槃者。是魔弟子。若不如是真我弟子。若言如来毕入涅槃。当知是人污辱我法。若有信受如是语者甚可悲伤。说是语时于会右面出大光明。其光金色遍照三千大千世界。悉蔽日月梵天之明。惟不能障佛之光明。其余光明黤黮不现。大小须弥草木丛林。二国中间幽闇之处无不大明。地狱众生遇斯光已。苦痛休息身得安乐。尔时一切大众之前。即时出生六万亿莲华。其华微妙色香具足。千叶盛满四宝为质。一一莲华出微妙香。遍满三千大千世界。其中所有天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释梵魔天沙门婆罗门。一切众生闻香气已。皆得爱法心乐大乘。乐欲听法断诸烦恼。是华成就如是功德微妙之香

尔时大云密藏菩萨摩诃萨。在大会中见是神变。即从座起合掌恭敬白佛言。世尊。是何相貌谁之德力。是大众中有是妙华出无量香。于是净光天女。语大云密藏菩萨言。善男子。一切诸法皆悉无相。云何问言是何相貌。诸法如梦。何故颠倒如狂所问大云密藏言。善哉善哉。天女。我非不见诸法如梦。为欲断彼着相故问。天女言。大德。何故见于着相而生此问。天女。是故我先言为众生故。欲令度脱是故而问。大德。若不自断我见我疑。云何而能度脱众生。若不自断我见我疑。欲为众生除断见疑无有是处。佛言善哉善哉。善男子。实如天女之所宣说。菩萨摩诃萨住是三昧。惟见无相。善男子若男若女欲见无相。应当精勤修是三昧。菩萨摩诃萨住是三昧。能于三千大千世界现种种身。世尊。云何菩萨住是三昧。能于三千大千世界现种种身。善男子。若有幻师若幻弟子。于大众中能作种种若男若女。若大若小若生若死若去若来。若舍若林若象若马。若断若折若破若坏若续若绝。大众见已不生惊怪。何以故了知幻故。菩萨摩诃萨亦复如是。住是三昧修习正道。于此三千大千世界化种种身。为度众生故住是三昧。诸菩萨等见是化已。不生惊怪无有疑心。随顺于义无有违逆。何以故。定知即是三昧力故

复次善男子。菩萨摩诃萨住是三昧。能于三千大千世界。随诸众生种种所行处处现身。或阎浮提现处母胎。一切众生实见菩萨处在母胎。而是菩萨实不在胎。或阎浮提现出母胎。众生亦见菩萨出胎。而是菩萨实不出胎。或阎浮提现初剃发造制周罗。一切众生皆见如是。而于菩萨实无是相。或阎浮提现诣学堂习诸伎艺书疏算计。一切众生皆见菩萨始初习学。而是菩萨已于过去无量劫中悉修学已。或阎浮提现行如人师子白鹅。一切众生皆见菩萨现行如人师子白鹅。而是菩萨都无此相。或阎浮提示有妻子五欲相乐。一切众生皆见是相。而是菩萨已于昔劫久远离之。惟以法乐而自娱乐。或阎浮提示大小便。一切众生亦见是相。而此菩萨得真法身非杂食身。云何而有大小便利。咀嚼杨枝着衣洗手。履践革屣执持伞盖。身服缨络饮食饥渴。生老病死行檀波罗蜜。得转轮王奴婢仆从男女大小。或作人天头陀苦行。现为比丘福利众生。现须陀洹果斯陀含果阿那含果阿罗汉果。破坏众僧听法说法食啖毒饭。犯四重禁作五逆罪。作声闻像辟支佛像。出家学道菩提树下。转正法轮现大神足入于涅槃。或作释梵天魔波旬。流转诸有犹如车轮。亦复如是。善男子。菩萨摩诃萨虽作如是随顺世间种种诸行。为欲度脱终不生于众生之相常修法相。何以故。是三昧力故。菩萨摩诃萨无有着处。不着声闻不着缘觉。为欲怜愍一切世间度众生故。在在处处随其所乐而现其身。是故菩萨修习无相见于无相。若人能见如是无相。是名正见净光天女亦修无相。诸佛世尊住是三昧。故不可思议。世尊。是净光天女。成就具足甚深智慧。若无相境界不可思议。其修习者亦不可思议。尔时世尊熙怡微笑。从其面门出无量光。其光五色遍照无量无边世界。上至梵世一切周遍绕身三匝还从口入。尔时大地六种震动。庄严清净如郁单越。三千大千世界亦复如是。一切众生佛神力故悉得睹见。尔时大云密藏菩萨复从座起。整衣服合掌恭敬白佛言。世尊。何因缘故放是光明。佛言。善男子汝向所疑我今欲答。是故放是瑞相光明。善男子。于此西方有一世界名曰安乐。其土有佛号无量寿。今现在世常为众生讲宣正法告一菩萨。汝善男子。娑婆世界释迦牟尼佛。为诸少福钝根众生说大云经。汝可往彼至心听受。是彼菩萨。欲来至此故先现瑞。善男子。汝观彼土诸菩萨身。满足五万六千由旬。世尊。彼来菩萨字号何等。复以何缘而来此土。将非为度众生故来。惟愿如来。为诸众生分别解说。善男子。彼土菩萨欲闻净光授记别事。并欲供养如是三昧是故而来。善男子。是菩萨名无边光。通达方便善能教导。世尊。惟愿如来说是天女。在何佛所发阿耨多罗三藐三菩提心。何时当得转此女身。善男子。汝今不应问转女身。是天女者。常于无量阿僧祇劫。为众生故现受女身。当知乃是方便之身非实女身。云何当言何时当得转此女身。善男子。菩萨摩诃萨住是三昧。其身自在能作种种随宜方便。虽受女像心无贪着欲结不污。世尊。惟愿如来。为诸众生。说是天女未来之事。善男子。汝今谛听我当说之。以方便故我涅槃已。七百年后是南天竺。有一小国名曰无明。彼国有河名曰黑闇。南岸有城名曰熟谷。其城有王名曰等乘。其王夫人产育一女。名曰增长。其形端严人所爱敬。护持禁戒精进不惓。其王国土以生此女故谷米丰熟快乐无极。人民炽盛。无有衰耗病苦忧恼恐怖祸难。成就具足一切吉事。邻比诸王咸来归属。有为之法无常迁代。其王未免忽然崩亡。尔时诸臣即奉此女以继王嗣。女既承正威伏天下。阎浮提中所有国土。悉来承奉无拒违者。女王自在摧伏邪见。为欲供养佛舍利故。遍阎浮提起七宝塔。赍持杂彩上妙幡盖。栴檀妙香周遍供养。见有护法持净戒者。供养恭敬。见有破戒毁正法者。呵责毁辱令灭无余。具足修习十波罗蜜。受持五戒拯济贫穷。教导无量一切众生。说大云经以调其心。若闻大乘方等经者。恭敬供养尊重赞汉。满二十年受持读诵书写解说是大云经。然后寿尽。是时乃当转此女身。为众生故示大神通。为欲供养无量寿佛故。故生彼界。世尊。是女王者。未来当得阿耨多罗三藐三菩提不耶。善男子。如是女王。未来之世过无量劫当得作佛。号净实增长如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。此娑婆世界尔时转名净洁浣濯。有城名曰清净妙香。其城纯以七宝庄严。最胜无上犹忉利宫。其城凡有九万亿人。土地平正无有荆棘土沙砾石。其土人民不生邪见爱重大乘。无有声闻缘觉之名。一切纯是菩萨大士。修习慈悲喜舍之心。成就忍辱寿命无量。善男子。若有众生得闻彼佛如来名号。不堕三恶转生人天。说是经已。无量众生得阿毗跋致

大方等无想经卷第六


大云无想经卷九

    No. 388

大云无想经卷九

盲今已□□□□□□□□□□□□□□以怜愍心。受我等□□□□□□□□□□于先所。作众罪心。□□□□□□□□□□重罪得灭。渐生善法。□□□□□□□□□量众生。得无根信。无量□□□□□□□□众生发阿耨多罗三藐三菩提心。□□□□

尔时会中。有一梵志。名曰直道。即从坐起。惊愕举手。而作是言。大众尽知瞿昙沙门是大妄语。先常说言作五逆罪。诽谤正法。毁呰圣人。用招提僧物及佛法物。犯四重禁。污比丘比丘尼。邪见。是十种人是地狱种。现在不能断欲界结。证沙门果。不能增长无上正法。今者乃说有正信心。悔先所作。罪则得灭。还能增长如来正法。不信之者。名地狱人有正信者。名如法住。云何瞿昙作二种说。信我法者。名为正见。不信我法。名为邪见。瞿昙沙门不观先言。复说是语。如是一切。云何得名一切智也。瞿昙沙门非一切智。非一切见。说一切见。诸外道等。亦作是说。我一切智。我一切见。信我道者。名为正见。信瞿昙者。名为邪见。如是二语。有何差别。若无差别。云何分别是正是邪。尔时世尊。告大云密藏菩萨摩诃萨言。善男子。谛听谛听。一切众生。为四颠倒之所围绕。复有四不具法。所谓戒见威仪正命。因是八法。能令众生行黑闇处。不能分别邪之与正。法与非法。善男子。是道梵志。于大众中。惊举手言。沙门瞿昙。作虚妄语。是言即虚。善男子。一切法虚。如来能说。是故如来不为妄语。一切诸法。无性无定。无体无缘。不可定说。空无出灭。不名为物。无净不净。如梦如幻。如水中月。如热时炎。如[口*兮]声向。如乾闼婆城。龟毛兔角。贪嗔痴体。无有真实。因恶觉观。而便出生。本无今有。以有还无。善男子。一切众生。不知是相。是故唱言。沙门瞿昙。作二种语。虚妄而说。如来虽说十种众生。信者则能除灭众罪。不生信者。则入地狱。善男子。若有罪人。能作如是观法相者。是人名信。能灭众罪。如其不能如是观者。名为无信。是地狱人。善男子。有师子吼无上梯智回复无生忍无边神足法门陀罗尼。菩萨摩诃萨。若有成熟是陀罗尼。于大会中。宣说一偈。则能摧灭一切邪见。破颠倒心。及心数法。离一切疑。能破悭贪嗔恚痴垢。善男子。若复有人。具无量罪。闻是持已。于七日中。至心念佛。不念一切世间之事诸烦恼结。是人即见一切三界三世阴入界。犹如大风。是人尔时。心如风等。观一切法。三界三世诸阴入界。都无所著。不可宣说。是人名为不着三界诸阴入界。作是观时。于三界中。不名清净。不名不净。不名解脱。不名系缚。不名为此。不名为彼。不名凡夫。不名圣人。不名为去。不名为住。是人终不为凡夫法之所诳惑。断一切想。见倒心倒。见五欲乐。如风如空。虽从世法。说有五欲。而其内心。都不染着。不生不灭。而能断除一切恶法。如先所说。十种众生。善男子。是梵志者。以不解故。唱如是言。沙门瞿昙。作二种言。虚妄所说。善男子。若人能观如是法相。是人即得无生法忍。若得是忍。当知是人决定得成无上道果。若有善男子善女人。获得如是陀罗尼门。心喜赞诵。惠念三宝。至心供养。是人则为一切人天之所恭敬。亦为天人四大天王之所拥护。虽未解脱。亦能除灭一切重罪。业障烦恼障。报障法障。乃至梦中。终不失于菩提之心。具足获得四无碍智。不为世法之所染污。犹如莲花。离诸怖畏。四魔大怨。不能为恶。能增长善法。凡有所说。众乐听受。见皆生怜。怜已能救。远离邪书。不善恶友。身无四百四病。能济众生一切患苦。常施众生。欢喜快乐。随所生处。诸根完具。四无量心。无能动转。见怖畏者。心生愍念。如亲父母。常为众生。乐见爱念。虽不贪利。而为一切之所供养。远离五盖。乐顺善法。若客因缘。暂时睡眠。梦中则见十方如来诸菩萨等。如是菩萨初未闻法。悉皆得闻。分别十善及十恶法。示生死苦。开大方便。说菩萨戒。即闻法已生喜信。以是因缘。舍命之时。心不退转。不生怖畏。见十方佛。所言不错。舍身即得生净妙土。见佛闻法。常亲近佛。修五神通。习自然生。不由他得。常得化生。不由三恶。不失见佛。乐闻正法。供养众僧。何以故。善男子。是陀罗尼法门。乃是一切过去诸佛之所宣说。为灭恶世众生罪故。过去诸佛。了了喜见。未来之世。诸恶众生。不能亲近诸善知识。远离正道。行于黑闇。修习邪见。常住烦恼重病之中。去菩提道。以是因缘。过去诸佛。悉共演说是陀罗尼。善男子。若有现在十方诸佛。亦共宣说是陀罗尼。若有未来十方诸佛。亦共宣说是陀罗尼。皆共为灭直道梵志等逆罪故

尔时世尊。告直道梵志善男子。汝说众生五大身者。是名五阴十二入十八界。是五阴中。乃至十八界中。众生颠倒。生于我想。因我想故。流转生死。犹如车轮。众生以是四倒因缘。盲生盲死。受无量苦。离人天乐及无上乐。心无惭愧。正信智慧。是故便说四大五阴十二入十八界是我我所。善男子。我今问汝随汝意答。汝法地大。即是我我所邪。不也世尊。因是地大。则便有我。善男子。若从地大而有我者。我即是地。地即是我。是故地亦名地。亦名为我。亦名众生。亦名寿命。亦名欲器。亦名增长。亦名士夫。亦名摩纳。亦名为作。亦名使作。亦名为起。亦名使起。亦名说者。亦名使说。亦名为受。亦名使受。亦名为知。亦名使知。其余诸大及法入界。亦复如是。善男子。一切诸大阴入界等。悉不名我。乃至使知。悉不名我。善男子。一切诸大阴入界等。过去未来现在。非我我所。是故诸大阴入界等。不可取持。不生不灭。不作不可见闻。善男子。眼空色空眼识空。三法因缘触亦空。四法因缘受亦空。是故一切诸法无主。不得自在。无此无彼。善男子。如是诸大阴入界等。非男非女。心心数法。不名为男。不名为女。以是因缘。一切诸法。皆如虚空。念念生灭。无自性故。犹如电光。不可宣说。若人杀人。得杀罪者。是人为以现在身心得罪。为以过去身心得罪。为以未来身心得罪。梵志言。世尊。过去已灭。未来未生。现在无住。佛言。以是因缘。应无杀罪。若言有杀。云何名杀。地不杀地。余一切大阴入界等。亦复如是。梵志言。世尊。因缘恶心故。名之为杀。佛言。善男子。汝云何言。因恶心故。得名杀者。如是恶心。住在何处。为在欲界。为在色界。无色界耶。虚空耶。意界耶。有为界耶。无想界耶。有漏界耶。无漏界耶。有界耶。无界耶。善男子。若有人发于恶心。作五逆罪。谁是发耶。如是心者。以何为性。谁转是心。作善不善。住在何处。而作此转。若无作者。及无受者。汝云何言。有我我所。尔时梵志默然不言。善男子。以何因缘。默然不答。梵志言。世尊。我今已得入是法门。见一切法。无作无取。无住无性无体。不可宣说。犹如虚空。热时之炎。梦幻水月。世尊。一切诸法。无有住处。无彼无此。是故我今默然无言。佛言。善哉善哉。善男子。是名师子吼无上梯智回复无生忍无边神足法行陀罗尼法门。断一切苦入大智门。是菩提道之初行也。断二种生。远离烦恼尘埃。如是法门。不与一切声闻辟支佛共。善男子。汝等虽复杀父杀母。唯得重业。不得逆罪。汝今复得入是法门。生大信心。渐渐当得。消灭无余。梵志闻已。心大欢喜。即前礼佛。长跪叉手。白佛言。世尊。我顽闇谤佛所说。今以逆罪。并谤佛咎。于如来前。诚心忏悔。善男子。汝今此罪。欲留余不。世尊。云何名为余。善男子。虽生惭愧。发露忏悔。若不发阿耨多罗三藐三菩提心。是名为余。若能怜愍一切众生。发阿耨多罗三藐三菩提心。是名无余。是人亦能断四颠倒。亦得圣智。亲近梵住。增长善法。善根坚固。虽有冰缘。不能令退得无碍智。尔时直道梵志等。无量那由他众生。白佛言。世尊。我等今者。至心怜愍。为一切众生故。发阿耨多罗三藐三菩提心。悔先所作。唯愿如来大慈怜愍。受我重忏重愿。如来为我等故。说师子吼无上梯智。回复无生忍无边神足法门陀罗尼。是陀罗尼。不与声闻辟支佛共。虽有共者。我所不求。我今所求如来第一义无上智陀罗尼。能庄严一切善法一切世法佛无上智无畏施等陀罗尼。为大众增长善法。不忘不失。至心受持。能破四倒。成菩提道。坏一切结。及诸恶业。是陀罗尼。是诸菩萨摩诃萨等之大宝聚。无上三昧。以是因缘。能令菩萨。乃至梦中。心无退转。有所至处。若沙门众。婆罗门众。刹利众中。心无所畏。常乐惠施。勤行精进。远离一切恶不善业。能令怨敌。生欢喜心。离诸放逸。邪书邪见。及恶知识。亦能调伏如是等人。常能演说无碍法门。令说法者。无有病苦。及诸恶事。不为诸魔之所得便。常知宿命。得化生身。离诸恶有。常得亲近十方诸佛。听受正法。供养众僧。世尊。是陀罗尼。名为一切菩萨摩诃萨秘密之藏。唯愿如来。生怜愍故。分别解说。佛言。善哉善哉。善男子。是陀罗尼。悉能成就无量善法。如法所说。谛听谛听。当为汝

说。尔时世尊。即为说之　波囄　迦囄　啵迦囄　多迦囄　陀逻毗[口*伐]提　波逻半遮那目呿　波逻朱那坭　波逻坭　毗喏[口*((局-口+、)/一)][口*伐]提　扇[口*((局-口+、)/一)]　波逻[口*(罩-卓+(口/田))]那因提梨　远离色香味[口*((局-口+、)/一)]　远离颠倒　能烧一切毒　能远离一切恶鬼恶道病　无碍法门　具足法门　真实智法门　无碍心　大法施　具足法施　能破五盖莎呵

善男子。若佛弟子。比丘比丘尼。优婆塞优婆夷。受持如是陀罗尼咒。读诵书写。若月八日。净自洗浴。着新衣服。净其内心。在佛前像前塔前舍利前。千遍读诵。以劫贝缕一百八结。以用系头。是人若与恶众共行。能令一切。不见其形。卧无恶梦。是名陀罗尼一句。善男子。

复有一句。所谓　虽埿　优牟埿　颇蓝牟埿　优波阇[仁-二+兮]　拘嘶　[口*伐]阇　不失意心坚[革*卬]　电心如法住　次等住　能生如来智光　未[口*((局-口+、)/一)]　毗头末[口*((局-口+、)/一)]　薮钵[口*((局-口+、)/一)]　[口*(仁-二+質)][口*((局-口+、)/一)]　无碍寂静　念心增长　莎呵

若有善男子善女人。受持如是陀罗尼句。读诵书写。当于佛前像前塔前舍利前。千遍读诵。饮黑蜜莲化鬘浆。一日之中。能诵千偈。得他心智。善男子。若有善男子善女人。比丘比丘尼。优婆塞优婆夷。在寂静处诚心如法。行是陀罗尼。是人不过七日。获得四禅。坏欲界结。见十方佛。得如证意三昧。能化众生。灭一切障。所谓业障。报障烦恼障。能净众生所谓诸根。能燋众生一切烦恼颠倒等结。亲近住于贤圣之道。无能令其退转菩提。亲近一切智。不从他因。而生智慧。得一切佛三世无碍无畏法门。以是三昧因缘力故。得发愿力。能净一切诸恶众生。速得阿耨多罗三藐三菩提。说是陀罗尼时。是大会中。八万四千那由他众生。得是陀罗尼。八那由他众生。除重业因缘。得如法忍。无量众生。未发声闻心令发。未发缘觉心令发。无量众生。未发阿耨多罗三藐三菩提心令发。无量众生。于菩提心。得不退转

尔时大云密藏菩萨摩诃萨。白佛言。世尊。未来之世。若有比丘比丘尼。优婆塞优婆夷。受持读诵是大云经。是等当得何等功德。复能灭除何等烦恼。复能远离何等果报。复得何等智慧之力。何时当得大乘智慧。能度无边生死大海。何时当转无上法轮。施诸众生清净法眼。佛言。善男子。如是义者。悉不应答。大云菩萨。如是三请。佛亦不答。尔时文殊师利。白佛言。世尊。如是经典。当付嘱谁。调伏未来诸恶众生。世尊。未来之世。有刹利旃陀罗。婆罗门毗舍首陀旃陀罗。或有未闻如是经时。或以恶事。加于四部。以是业缘。无量岁中。于三恶道。受是果报。唯愿如来。为灭如是旃陀罗等恶业果故。以是果故。经典付嘱侍者。佛言。文殊师利。我涅槃后。此佛世界。真正王种。断灭无余。弊恶之人。当为王者。如是恶人。断正王法。憍慢嫉妒。心无惭愧。多行放逸。非归依处。而作归依。如是国土。所有大臣长者沙门婆罗门等。亦复如是。破戒悭贪。心无惭愧。具十恶法。不信三宝。无供养心。不能求请常乐宣说无因无果。菩萨摩诃萨。见是国土所有众生。如是习恶。即便移至他方净土。诸菩萨等。既移去已。此之世界。恶世恶时。即便炽盛。众生多病。谷米勇贵。四兵竞起。互相抄劫。皆由众生不知足故。善男子。我当付谁如是经典。谁能于是恶众生中。分别解说。善男子。若有人能堪忍饥渴种种苦恼骂詈挝打。不惜身命。是人乃能流布是典于未来世。若有是者。我当以是无上正典。而付嘱之。尔时会中。有一菩萨。名曰无畏功德疾行。即从坐起。头面作礼。长跪白佛言。世尊。我能于是无量世中。受无量苦。若刖手足。破头出目。饥渴寒热。挝打骂詈。乃至三恶道苦。当为流布如来是经。我能通于如来世界所有大城村邑聚落。若龙若鬼。流布是经。为断众生四颠倒故。令其持戒。勤行精进。正见具足。成就六波罗蜜。得无上菩提故。佛言。善哉善哉。善男子。如汝所愿。汝悉能作。令无量众生。施作佛事。善男子。汝所愿者。能得具足六波罗蜜。速成阿耨多罗三藐三菩提。善男子。虽有无量大众。如汝等辈。实为难得。未来世中。受汝语者。亦复难得。难有受者。生于重信。持读诵说。分别示教。亦复难得。若未来世中。有能受持读诵解说书写乐教。是人则得十事功德。身常无病。不求供养衣服饮食卧具医药。自然而得不求善友。而得亲近。十方诸佛。所共爱念。凡所说法。人乐听受。得舍摩他毗摩舍那。具足世义及出世义。身心寂静。增长三宝。得无上陀罗尼。善男子我。虽说其十事功德。若能教人忏悔。除灭无量恶罪。亦复获得无量福德。复次善男子。如是之人。若能至心。于未来世。受持读诵。广为人说。得无量福。是人舍命。了了得见十方诸佛。诸佛各言。汝善男子。生我世界。听我正法。断于四倒。灭诸恶法。成就圣智。住于梵住。受我法已。常得化生。断三恶道。速得阿耨多罗三藐三菩提。乃至得入大般涅槃。是人闻已。生欢喜心。即得生彼诸净佛土。善男子。如是之人。受是法已。所在生处。诸根具足。得上妙色。一切众生之所乐见。得三宝信。能设供养。若闻正法。即得解脱。坏一切业。所受正法。坚持不失。获得一切陀罗尼门。声闻缘觉菩萨三昧。能过声闻辟支佛道。复能教化无量众生。住于梵住。若有未来受持是语。当得成就如是功德。文殊师利白佛言。世尊。是菩萨能发如是难得之心。正应当以是经付嘱。尔时世尊。告无畏功德疾行菩萨。今以此经。付嘱于汝。尔时无畏功德疾行菩萨。与无量菩萨。敬承佛教。受是经典。梵住等无量梵天。绀目等无量帝释。四天王等无量鬼神。难陀婆难陀等无量龙王亦共受持。无量众生。发阿耨多罗三藐三菩提心

大云无想经卷第九　　　　清信女张宣爱所供养经

          岁在水卯正月十一日写讫


等集众德三昧经

    No. 381 [No. 382]

等集众德三昧经卷上

        西晋月氏三藏竺法护译

闻如是。一时佛游于维耶离大树重阁精舍。与大比丘众俱。比丘一万皆学戒具足晓了圣达。菩萨二万悉不退转。逮诸总持辩才无碍。悉得神通分别解畅。定意所行心性进止。而甚坚强怀来智慧。善权方便度于彼岸。其名曰意行菩萨。吉意菩萨。上意菩萨。持意菩萨。增意菩萨。金刚意菩萨。无限意菩萨。法意菩萨。慈氏菩萨。溥首菩萨。钩琐菩萨。释梵四王天及诸天子。万四千人亦皆来会

尔时世尊与无央数百千之众眷属围绕而为说经。欲放躯命自期三月当取。灭度。钩琐菩萨即从坐起。更整衣服偏袒右肩长跪叉手而白佛言。甚哉如来欲舍寿命。期于三月当般泥洹。世尊。唯说诸菩萨护。菩萨救摄。菩萨所说。菩萨所现。菩萨所殖众德之本。不断佛教将济法眼。恩惠圣众不舍群生。为讲说法超无为道。如来灭后法泽广被菩萨大士。不废无上正真之道。常不离佛听经供僧而立要志。心意坚固遵法散谊。其念所趣靡不觉达。体解所归多所殊越。恒怀惭耻自净无犯。所虑慷慨威仪具足。所建勇猛降制劳秽。伏诸欲垢无所畏惮。游于众会而不忌难毛衣不竖。唯天中天。云何菩萨大士。进益众德不乏智慧不违禅定。所慕道心未尝缺废。内性弘毅结友究竟至于灭度。言行相副所遵佛法无有邪伪。常护正戒所闻不惑。摄净三禁而尚忍辱。每行等心无有暴慢向于黎元。善修精进心无懈厌。诸所应行一切成办。一心行禅其意安详。晓了正受一切所奏。志建智慧离于邪见六十二疑。于诸训典明练光达。所当救纳而行四恩。弘济多护天上世间。远离所乐常念无常。心如门阃住诸通慧。意不存慕声闻缘觉。光阐法教降制魔怨及诸外道。念宣法王所讲风化。崇顺法诲不求天人。如佛之教以法为业。不贪衣食无有爱欲。广度一切释除恚恨。愍哀群生消却愚痴。不一切法诸魔埃垢。行权方便无边之慧部分普劝

佛告那罗延( 晋 名 钩 琐 力士 )菩萨曰。善哉善哉。多所哀念多所安隐。伤愍诸天世间人民。乃问如来如斯之谊。谛听谛听善思念之。当为仁说。菩萨大士所行殊特无量之德。钩锁白佛。愿乐欲闻。钩锁菩萨及与众会受教而听。佛言。有三昧名等集众德。假使菩萨逮斯定者。众德进益不乏智慧不违禅定。所慕道心未曾阙废。心性弘毅未曾离佛。恒闻经法供养圣众行于四恩。彼如是已不舍群生。于时世尊。咨嗟等集众德三昧。宣扬其名默然无言是时维耶离大城中有大力士。名维摩罗[口*(甚-其+庚)]移。(晋言离垢威)心自念言。吾为力士。于斯天下力势强盛无有伦匹。曾闻沙门瞿昙。猛势无量其力巍巍总要有十。体诸骨解犹如钩锁而得自在。吾欲往试观铨其道。于我孰踰念已。寻出维耶离城。往诣大树重阁精舍欲觐世尊。而见如来与无央数百千之众眷属围绕而为说经。照临大会犹如须弥超现大海。瞻睹威容神曜光光。心怀踊跃不能自胜。稽首佛足却坐一面。佛知力士心之所念。欲为疗除憍慢贡高自用之秽。便告贤者大目干连。吾忆往昔为菩萨时。兄弟挽射弯弓放箭。箭所至处尔今摄取。释女瞿夷欲充所用。目连对曰。唯然世尊。于时不见箭何所奏。佛放右掌光。光照三千大千世界。于斯佛土镇世铁山大铁围山。箭彻其中。目连寻光乃见箭处。佛告目连。宁见箭乎。对曰已见。又而告曰。往取箭来。时目干连自现神足一切众会莫不见者。如勇猛士屈伸臂顷。斯须即到大铁围山。欲拔佛箭。三千大千世界皆为震动而箭不摇。一切诸会天龙鬼神帝释梵王靡不肃惊。阿难。整服长跪问佛。地何故动普世惶悸。佛告阿难。忆吾往古挽射放箭。箭彻太山。使目连取。尽其神力箭不可拔。三千大千世界乃为之动而不能得。阿难启曰。唯垂尊援。佛即许之援以道力。则承圣旨揽拔。得箭还用进佛。目连白佛。云何世尊。为菩萨时挽射放箭。箭彻铁山。用父母力神足力乎。佛告之曰。是父母力非神力也。假用神力。其箭当达无量无限诸佛世界。目连又曰。云何菩萨以父母力射箭乃入铁围太山。道力功德而佐摄取。何以为喻。佛告目连。十凡象力。则不如一正象之力。十正象力。不如一龙象力。十龙象力。不如一大象力。十大象力。不如一术事象力。十术事象力。不如一青象力。十青象力。不如一普妙象力。百普妙象力。不如一大臣象力。百大臣象力。不如一力士力。百力士力。不如一大力士力。百大力士力。不如一上力士力。百上力士力。不如半钩锁力士力。百半钩锁力士力。不如一具足力士力。百具足力士力。不如一大钩锁力士力。百大钩锁力士力。不如一法忍菩萨力。百法忍菩萨力。不如一究竟菩萨力。百究竟菩萨力。不如一生补处菩萨功德之力。适生堕地则行七步。佛言目连。他方世界现在诸佛建立伦土。究竟菩萨之所游处。适生堕地行七步者。其地下至六百八十万由延。尽斯下已乃得水界。各各分别其水渧如车釭。上至梵天承佛威神愍哀众生。世界不损无所娆害。究竟菩萨威神势力巍巍如是。十究竟菩萨力。不如如来至真等正觉力。是谓世尊父母之力。其诸菩萨宿命德本所受之决。亦非神足道力变化。设使菩萨示现神变功德之力。往诣道场坐佛树下。以神足之力一足指。举江河沙等世界先以目前。用置殊异无量无限诸佛国土。其于众生无。所娆害。是为菩萨神德变化足一指力。如来神足变化之力。复过于是无量无极不可思议。假令如来普具示现神变威佛。汝等睹之则不能信。何况外术众邪异学。又目犍连。菩萨往至佛树下时。摄四大种立为一种。已立一种在于世界无有增减。于时弊魔行到道场。与无数亿百千官属凶悖难当。如来一切寻摧伏之。何以为一谓平等力。有十力常加大慈哀。诸众生无所毁触。何等十力。有非处处有限无限。如审悉知。过去来今如审悉知。一心脱门定意正受。如审悉知。见诸人根种种别异。如审悉知。见他群生心意所念。如审悉知。若干种身无数形体。如审悉知。众庶所行所行者好丑不同。如审悉知。道眼彻睹终始所趣。此没生彼彼没生此。名字种姓父母兄弟。其身口意行恶。诽谤圣贤邪见颠倒终堕恶趣。其身口意行善。不谤圣贤正见奉顺终隧善处。如审悉知。道耳洞听天世间。地狱饿鬼蜎飞蠕动蚑行喘息。十方诸佛世界。若此言声亦无音响亦无所著。如审悉知。心睹五趣一切本际。诸漏已尽无有尘垢。终始悉断神真圣达解名色原。如审悉知。是为十力。如来之力复过于此不可思议。畅彻十方无去来今。于是离垢威力士从佛世尊闻斯菩萨父母诸力。欢喜踊跃怪未曾有。善心生焉即从座起偏袒右肩。长跪叉手白佛言。今我听受世尊所说。为菩萨时父母之力及十种力。屏除贡高憍慢自大。归命三宝愿发无上正真道意。愍伤众生使获大安。哀令我得十种诸力。如天中天具足无异。时会大众闻斯力士誓愿弘广。满十千人发无上正真道意。同时举声。而歌颂曰

  侥令我等　　逮得道力
  亦如如来　　至真等正觉

于是钩锁菩萨白世尊曰。今者大圣。何故称叹等集众德三昧。而便默然。唯愿如来。分别讲演等集众德定意。宣畅菩萨大士诸行。使发意者逮得斯定。佛告力士。菩萨初发意者。欲至无上正真之道当受尊定。所以者何。若初发意受持尊定。寻具普入一切众德。譬如力士。川流泉原江河大流悉归于海。所殖功德布施持戒。所习平等思惟道慧。有漏无漏俗业度世。天上人中所立福祚。皆来归凑于初发意菩萨之行。是故族姓子族姓女。欲摄众福当发无上正真道意。譬如须弥大山铁围山雪山黑山。诸药草木及余丛林。洲域大邦郡国县邑。并四天下日月运照。苞在三千大千世界。如是力士。其凡庶履迹无著缘觉。休祐菩萨如来大圣之德。其初发意为菩萨者。悉得通入于此福祚。以是之故当作斯观。若发无上正真道意。则悉该揽于诸德矣

佛告力士。譬如四域群生之类。转轮圣王居为尊上功祚殊胜。使四天下众庶人民福。如转轮圣王之德等无差异。合集斯福巍巍之德为一圣王。使三千大千世界众生之德。各各皆如转轮圣王。一一圣王使倍三千大千世界众生之数。总集诸福为一人德。使江河沙等诸佛世界所有人民。各各履祚如彼一人。于钩锁意云何。宁能限量斯福德乎。钩锁对曰。唯天中天。计圣王德不可思议。何况一切为转轮德莫能称限。世尊告曰。正使撰合此众生德无量之祚。以比一发意菩萨。百倍千倍万倍亿倍。巨亿万倍计空不及无以为喻。是为初发意菩萨。等集众德三昧第一所入。佛告钩锁。譬诸梵天于千世界悉乐行慈。若复有人皆以七宝满千世界。以用布施。比千世界梵天行慈。行慈之福其德殊胜。若三千世界至于五千十千。若至百千世界梵天普共行慈。若以七宝周遍充满百千世界。以用布施所殖德祚。以比百千世界梵天行慈。行慈福多不可称限。正使三千大千世界众生之畴。其福德如百千世界梵天行慈。行慈心普向于群萌。计其福德。比初发意行者所尊慈祚。百倍千倍万倍亿倍巨亿万倍。计空不及无以为喻。所以者何。其初发意志于无上正真道者德不可限。以是之故。当作是见当作是知。假使能发大道意者。则为具足一切众德。若族姓子族姓女。欲得周满无量之祚。当发无上正真道意。佛言。力士。是为等集众德定意第二所入

佛告钩锁。东方虚空所覆世界。空之远近可限量乎。答曰。世尊。无限无量不可计数无有边际。天中天。佛言。如何引喻智者解趣。十方世界虚空所覆不可尽极。犹若等集众德定意福祚功德。超彼无量转加具足。为众生故以诸道德将护其心。以大精进成满所行。假使有人于此三千大千世界。下尽水际上至三十三天。满中芥子。一一芥子为一佛国。过于东方若干佛土著一芥子。各各如是令芥子尽。不能穷极东方世界。设令江河沙等世界满中芥子。有人尽取芥子一一破碎。各如江河沙数芥子之限。于钩锁意云何。宁有人能筹计分别。知所破碎芥子数乎。钩锁答曰。唯天中天破。一芥子所分之限。假使智慧如舍利弗。周满天下阎浮提土。一劫之中筹之计之。不能称量芥子之数。何况欲知江河沙等世界破芥子数。设令有人过诸 芥子佛土 着一芥子。如是之比令破芥子悉尽无余。东方世界不可穷极得其边际。南方西方北方。东南方西南方西北方东北方。上方下方亦复如是。如是钩锁。如十方界所有虚空。诸佛国土皆以七宝遍布其中。悉令充满尽用布施。所得功德岂多不乎。钩锁白佛。甚多天中天。无量也。世尊告曰。其初发意菩萨行慈之德过于彼施。满于东方无限世界七宝之福。百倍千倍万倍亿倍巨亿万倍。计空不及无以为喻。譬如虚空无有能度得边际者。菩萨之慈犹如虚空无所不覆。菩萨如是所行大慈所盖无际。譬如众生受形立体。所周佛土所在世界若干之数。菩萨行慈使此群萌皆得成就为转轮王。具足功德如释如梵践祚之数。又计菩萨大士建立净性质直无谄。欲度众生住于大哀。常行慈愍所行七步。摄取功勋超诸群黎。为释为梵转轮圣王之福庆也。百倍千倍万倍亿倍巨亿万倍。计空不及无以为喻。是谓等集众德定意第三所入佛告钩锁。三千大千世界一切众生威神功德。皆令巍巍如转轮王。如释如梵功德之庆。不比初发意菩萨之慈。正使一切十方众生皆为释梵转轮圣王。百千万倍不比菩萨行大慈哀。又使三千大千世界众生之畴一切皆使如清信士所有功德。比舍利弗福慧之明。百倍千倍万倍亿倍巨亿万倍不相及逮。正使三千大千世界满中人。众如舍利弗智慧功德等无有异。以方比于缘觉智慧功德。百倍千倍万倍亿倍巨亿万倍。计空不及无以为喻。纵使三千大千世界游居众生。一切成具缘觉之德智慧功德等无差特。欲比五劫生行菩萨。百倍千倍万倍亿倍巨亿万倍。计空不及无以为喻。是为等集众德定意第四所入

说是经时二万二千人。皆发无上正真道意。三千大千世界六反震动。其大光明普照世间亿百千垓。诸天伎乐不鼓自鸣。而雨天花覆盖道场。纷葩佛上周遍众会积至于膝。释梵四天王天龙鬼神皆歌叹言。唯然世尊。族姓子族姓女。心怀至诚而发无上正真道意。如向大圣所讲说者。我等禀谊。假使不发大道意者。终不逮成等集众德定意正受。况当能致一切功祚无量也

是时离垢威力士白佛言。唯然世尊。当行何法。而能成就逮得等集众德之定乎。佛告族姓子。有一法修致斯定。何谓一。发心调习诸通之慧。是为一法逮得斯定。复有二法修获斯定。何谓二。若听闻法咨禀无厌。如所听受思察其谊。是为二。复有三法修获斯定。何谓为三。消损诸恶。劝集善业。殖众德本。是为三。复有四法修获斯定。何谓四。禁戒清净。所见清净。其心清净。智慧清净。是为四。复有五法修获斯定。何谓五。所言至诚。志性坚固。其意质朴而无谀谄。其心清净建立无差。常以等心一切众生是为五。复有六法修获斯定。何谓六。归附善友。远离恶友。舍废众会。习寂燕坐。顺行大慈。愍伤众生。是为六。复有七法修获斯定。何谓七。建立寂然分别。惟观除于报应。将御缘起离求所见。晓了罪福悉由牵连。道利结碍使至平等。入于道諠用道法故。忍于恚骂而无恨心。是为七。复有八法修获斯定。何谓八。身行澹泊。口言静默。心惟寂寞。观痛痒察诸法。恶本夫起而不想念令不复兴。恶本盛发随念蠲除。善本未起思顺令滋。善本熙隆将养护之。是为八。复有九法修获斯定。何谓九。观过去法而知无常。于当来法而无所生。今现在法而无有二。逮入三世而悉平等。一切诸法犹如法忍。不着于空。分别无想。离于所愿。设使所生有所救护。是为九。复有十法修获斯定。何谓十。脱于无我。忍于无命。了于无人无常句迹。一切所生皆为苦患。无为寂然则为救护。离颠倒。度众生。顺典诰。如所闻法寻即奉行。佛告离垢威。是为十法菩萨所行。因此逮得等集众德三昧之定。离垢威白佛言。菩萨大士积累功效无极大德。乃得逮闻斯定意耳。欲决诸德正真之行。当闻斯定。欲得获畅不可思议功祚之福。当闻斯定。欲令大赖无有尽耗。当学斯定。离垢威复白佛言。菩萨大士。以何疗得无尽之福德如大海。庆不可议功祚不废。佛告离垢威。菩萨有三事。逮无尽福德如大海。庆难思议功祚不废。何谓三。一曰好喜布施。二曰护持禁戒。三曰博闻不惓。是为三。彼族姓子。何谓菩萨好喜布施。不当贪财。不当以物诱进教化。假使有物不肯施与。受者不当受其物也。设使受者不舍所取。不当劝御彼等眷属。设使乞者有所求索发无受心。不可劝化国王财宝产养之业屋宇舍宅。假使乞者有所求索其心无异。又族姓子。菩萨大士当发此心。我为一切众生之故。惠施躯命。若有人来欲有所得。象马车服头目髓脑。眼耳鼻口支体手足肌发肉血。随其所求各各施与。心不怀恨忍辱施与。既有所施不望其报。所可惠舍无所贪慕供给众生。众生获恩得给所乏。从是已往所欲摄取群萌之类。得佛道时为说经法令得速解。说族姓子。若有菩萨发心如是。是谓菩萨不惜身命。不惜身命若没其体不犯众恶。不害生命以养其身。不以命故犯于不善。不以财业越毁他人。不以眷属炽盛怨讼斗诤。不危他子以育妻息。己所不喜无加于人。已知止足则发一心。志不喜乐诸不善事。况当复犯若干之非。除贪嫉弃众恶。常知止足行于正真。无有异心则逮平等。逮平等已无有众邪则获慈心。已习慈心便遇善友。已得善友则便得闻寂然之法。已闻寂然便建立行。已建立行则化众生。化众生。已则便讲说立寂然谊。假使菩萨不为众生不修寂然。则不微妙。已不微妙不获道眼。不得道眼不至善权。不能睹见一切众生根本所趣。是族姓子。菩萨好喜行布施者。得广名闻。复过于斯不可称限

复次族姓子。观内外法念之一等。察其内地及省外地而无有二。所以者何。是身如草木瓦石之类。无要无人无有想念。无有坚固四大合成。假令有人断截破坏取拨持去。不得自在莫起想念。勿得贪身无惜寿命。吾不恨彼于其人所起恚意也。益加慈哀向彼众生。譬如族姓子有大药树。掘取其根茎节枝叶花实。树不念谁取我根茎枝叶花实。亦不念言莫取我根茎枝叶花实。其药树者。一切无念亦无所想。亦于众人无所恚恨。其疾病者服药则愈。如是族姓子。行菩萨者。当自观身四大为家。犹如药树。其有众生。欲得我身头眼体节枝干手足髓脑血肉。恣意与之。如是族姓子。菩萨所施其德无尽。作是施已。为悭贪者。欲令惠施故劝助之。其贫穷者化示大财。其少福者化具足德。未发道意令行菩萨。劝诲善本欲令清净。一切福庆劝化众生。导以清净以是布施。疾近于道得至无尽。何谓布施尽。菩萨布施有四事尽。何谓四。不好劝助。不喜说法。愿生卑处。乐近恶友。是为四。复有四行。菩萨布施疾近于道。何为四。多所劝助。行权方便。建立于法。习近善友。是为四。复有三法。菩萨布施不为虚妄。何等为三。发菩萨意多所愍哀。摄护一切众生之类。谛奉行如来教命。是为三菩萨欲施当建三法。何谓三。住佛法立。精讲劝众生便存大安。是为三。菩萨复有二事。不为虚妄诚审布施。何谓二。大慈大哀。是为二。菩萨复有二事有所收施。何谓二。悭贪嫉妒。是为二。菩萨复有二法布施有所归。何谓二。智慧具足。圣达周满。是为二。菩萨复有二法布施有所趣。何谓二。至无尽慧。趣无起慧。是为二。菩萨所施有四法。何谓四。布施等与亦不想报。调定安寂。所施具足。欲成其道。是为四。菩萨所施以是之故。自然得趣无尽德海。若有菩萨欲备海德。则当习行如是像施精进之行。离垢威力士白世尊曰。未曾有也。天中天。如今如来分别讲说诸菩萨法。诸佛经典之所持护。菩萨大士作是行者。终不毁失正达慧德。假使有人如是布施。功德之福具足成满。亦当若兹。佛言。是族姓子。审如所云。其有发意行施如斯。则便归趣无尽海德。则不贫匮。于圣贤业则致大财。此之等类具足法财。则致大富。具足七宝无极之德。致百福相以庄严身。为诸群萌福庆之田。以给众生

尔时世尊告离垢威。何谓菩萨戒德之禁。护于禁戒未曾违舍。见犯戒者为兴悲哀。见奉禁者遵行坚固。净身三护口四净心三。当顺奉行此十善事。以斯戒法开化他人。不自称叹不毁他人。不以禁戒而自褒誉。亦不以戒而自憍慢。常以禁戒而自调定。不释节限而知止足。住于圣贤自护其心。见懈废者不观其隙。劳来病瘦所施不惓。无所悕望不以究竟。行如所言无所侵犯。于诸所行生死之事。无所适莫蠲所求望。常近于佛而遵慈心。若有行慈及无慈者。普等救护不失其心。不差戒品不志余乘。以斯道乘劝发他人。无有安不事于天。一切远离诸犯戒禁。动不安者劝慰使安。疗除狐疑令不怀恨。所生之处而得自在而无适莫。所可游至无所阙减。假使所生不以为厌。修建精进摄心自捡。所行不乱学无所乐亦无所畏。是族姓子。菩萨所行戒品之业。设危身命终不毁戒。不以国故而护禁戒。不为释梵天上之尊。不以财利报应之验故。及以眷属傲贵颜貌褒叹名称。亦复不为势力床榻座具病瘦医药故而护禁戒。不倚于天贪所生。不依内外不慕他人。不冀后世。不自着己不着他人。亦不贪色痛痒思想生死识。亦不怙眼耳鼻口身心。亦复不倚阴种诸入而护禁戒。不畏地狱而求济护。不惮畜生不惧饿鬼不为鬼神。不以人间穷乏厄匮故而护禁戒。志唯在于建立佛道。若闻法者念欲奉行。则已效立圣众之德。常欲度脱除生老死忧病懊恼勤苦之患。而护禁戒。不以财业而护禁戒。欲安众生隐群萌。度黎庶脱[番*去]党。乐佛法致差特。慕转法轮将养圣众。不断佛教不废法诲不怀众议。而护禁戒也。戒定慧解度知见品故而护禁戒。应寻神通六达之故也。所遵之戒。不犯不缺不毁无有邪业。顺佛之教无所亡失。而当平等顺行三昧。智者所叹佛所咨嗟无所乖违。随法所化奉行为要。其人如是遵常戒品而悉具足。不失菩萨十法之事。何谓十。然后当得转轮圣王之位终不差错修圣王教。奉宣佛道而不放逸临据帝释而不邀迭。常受佛道而不放逸。升生梵天而不诡异。在于梵天愿欲见佛而不差互。常值世尊心怀悦豫。所闻经典未曾断绝。听受佛法未曾中忘。如所闻者即能奉行。识念菩萨圣众之慧无所亡失。辩才无量未曾空乏。菩萨之本所愿者。得所立之事则有报应常为诸佛正士之等。不见毁呰其佛弟子。疾获神通具诸敏慧。护于戒禁能如是者。是为菩萨十法之行。不退不转菩萨大士护斯戒品。诸天龙神所共营卫。将护歌叹守禁戒者。诸鬼神众悉归奉事。神龙悉敬。世间人民等而供顺。诸佛世尊常欲见之。诸明智者而俱宗仰。愍伤世间而行慈心。而为众生护斯禁戒。于是菩萨不归四趣。何等四。不归于据无闲之处。亦不归于无佛之土。不生邪见归闇塞家。亦不随归一切恶趣。菩萨若护于戒品者。逮获斯德。复有四法无所忘失。何等四。不忘佛道。心不舍佛。如所闻法终不中废。不失禅定意念无数无量诸劫。菩萨若护于此戒品便逮斯德。菩萨复有四法逮得光观。何谓四。寻时逮得观于明法。获致人明毒刀恐惧疾病。闇冥之想悉为辟除。诸功德无能乱者。是为四

假使菩萨能护禁戒顺斯教者。超度十畏。何谓十。远离地狱畜生饿鬼贫匮无称世界魔畏。声闻缘觉所趣寂灭。所受脆生诸天人间。及龙鬼神犍沓和阿须伦真陀罗摩休勒。诸所恐难。毒刀杖火蛇蚖师子虎狼诸难。度于邪见能护戒品。如是行者菩萨之法。是为十勉越斯难。又族姓子。戒立佛法以为光明。佛法则立于戒菩萨之道。若能奉戒则近定意缘。从禁戒得至智慧解脱之行度知见事。何谓为戒皆能永脱一切尘劳。何谓尘劳罪福所连。三界所著斯则尘劳当以何度此诸尘劳。无念无想无思无住。而无所行无所兴立亦无所惟。于一切法而无所求。斯则名曰度诸尘劳。若族姓子。菩萨大士未远尘劳。则为无有清净戒品。所以者何。正使往至于梵天者自以欲尘。假令上至三十三天亦为欲尘。以是之故。族姓子。当作斯观。处三界者则为无有清净戒品。离垢威白佛言。设在三界悉尘劳者。而世尊云则为不顺清净戒品。云何菩萨离于欲尘逮清净戒。住于三界而不沾污。世尊告曰。族姓子。知乎。为菩萨者无身尘劳。亦无毁戒亦无所住。见众庶人着于三界故。则为犯戒。是菩萨以二事故行善权法。欲除三垢故处三界善权方便。菩萨大士自无尘劳。现在三界欲以开化群萌之类。譬离垢威。而有男子。画于虚空若书文字。现之悉现宁为难不。答曰甚难。天中天。佛言。菩萨所兴又难于彼。自无尘劳现于三界开化众生。时离垢威而叹颂曰

  唯天中天　　菩萨所兴　　具足无极
  而行大悲　　已现脱门　　转复反入
  所有城廓　　教授众生　　挂痴之网
  譬如有人　　身生疾病　　疗除危害
  非他人也　　等无有异　　如是世尊
  今日去害　　近世清净　　于道菩萨
  因此解脱　　以是之故　　劝化众生
  及诸异学　　由斯方便　　救济众生
  唯天中天　　菩萨大士　　发大悲心
  声闻缘觉　　所不能及　　所以者何
  声闻缘觉　　无有大悲　　善权方便
  具足之行

等集众德三昧经卷上等集众德三昧经卷中

        西晋月氏三藏竺法护译

尔时世尊复告离垢威力士言。族姓子。菩萨若闻如此行迹当勤奉行。云何求闻禀听尊长。常行恭敬弃捐憍慢。言语柔和志性仁调。观念于法犹如医药。于师和上设世尊想。自察其身思撰法药发医王想。于诸众生为疾病想。若务求法不当爱身。不贪命不倚寿。不慕于容被服。常好经典以法为本。一切所有施而不吝。志利法谊放忽财利。将护法宝离俗所珍。以利法故灭除一切世间财贿。以法宝利蠲除凡俗所慕之珍。欲除众生尘劳爱欲一切之瑕。常当慕求正法之典。欲度一切众生之类皆至灭度。便当护持导以正法。以能导护正法典者。则能普获将养一切所行德本。以是之故。假使有人欲求佛道。若欲逮成最正觉者。欲得竖立于法柱者。当学博闻。譬如族姓子。须弥山王为天大柱若天上柱。则为巍巍多所覆盖。所在严饰于忉利天。佛言。如是菩萨大士博览广闻则为慧柱。所可游居天上世间光色巍巍。设族姓子。若有菩萨志愿佛道我当成佛。则当晓了权便博闻常修精进。一切众生在于邪智。则为然设智慧灯明。假使菩萨入博闻时精勤求慧。则为具足众生之智所作已辨。尔时诸天则为其人举声咨叹。欢喜善心生焉。今此正士如是谊像。博闻之力逮十种力。致最正觉诸根明达。如是利谊为菩萨行。执智慧刀割截一切尘劳之欲。若有菩萨如是像谊。堪任明慧所说经法。则能蠲除众生尘劳危厄。若有菩萨如是像谊。便能说法灭除爱欲。如是菩萨则能归趣往古世尊所可游居。如是谊像则能降伏魔及官属。如是堪任以十二事法轮为转。如族姓子。菩萨大士精勤博闻立于圣达。应时即普三千大千世界所有众魔。皆为忧愁悒戚难可。今此菩萨不从我教违吾本心。皆见弃捐不得自由。所以者何。族姓子。从闻获智。智于尘劳为最尊。其无尘欲魔不得便。以是之故当作斯观。假使菩萨开入博闻分别经典好乐于法。从是已往所可教授。降制众魔尘欲魔阴盖魔起灭魔天魔官属。是为四魔自然为伏。又族姓子。犹如往古诸菩萨者。所入博闻分别法谊好乐经典。今当粗举略说其要。乃至曩昔久远世时。无央数劫不可称限。广普无量不可思议。彼时劫中有一仙人名曰郁怛。处在林树得五神通。常行等心慈悲喜护。游居幽薮心自念言。吾行慈心其身柔濡常悦安隐。不可以慈灭除众生自在爱欲。亦不可去嗔恚愚痴。旷绝邈路尘劳之欲。不以此慈能致圣贤之正见也。不可致福。安能逮成贤圣等观。复自念言。常以二事可缘致贤圣正见。何谓二。听省他音因缘。思惟静志在行。寻即欢喜发大精进。亦复入于法。我于何所得闻是说。则以法故欲求经典。入于郡国县邑丘聚。欲求经卷永不可闻。时魔天人往至其所言。族姓子。吾有佛名将护读诵。假族姓子。自逼迫身日自暴炙。 自闻其 身所 护音声。然后乃书如是诸颂。尔乃令仁得闻此颂四句之绝。于时族姓子。郁怛仙士心自念言。我从无数难限劫来弃捐此身乐于牢狱。挝杖鞭挞或以利刀。段段解身形体离散肌肉断绝。以爱欲故致得系缚。遭是众患不可称数。不用此身不用危痛痒。未曾以身加益一切。假使能已导利群生。吾当以此无坚固身求得经典。我获善利心怀悦豫。当从天人逮得闻典志未曾有。兴世尊心而怀恭恪。则取利刀自割其身。日中自炙从耳听闻。而谓天言。愿天演说佛名。将护读诵。吾恭敬法故放舍身不惜寿命。以是因缘等集所闻。时族姓子。睹见上仙恭恪乐法巍巍如是。颜色黮黤憔悴。功德难睹即没不现于是上仙心自念言。将无试吾闻此偈乎。为之恭敬奉顺法故。自舍其身不惜寿命得闻之耶。吾所合集恭敬经典。所殖德本不失其功不见欺惑。假使我身至诚不虚。质直无谄愍哀众生。不贪身命舍其体寿。闻此法者由是诚谛。于此现世他方佛国奉修法者。斯等之人令现面像。使我见之得闻经法。这立此愿口复说言。应时下方过三十二诸佛国土。有世界名普等离垢。彼佛号曰无垢称王如来至真等正觉。今现在说法。于时其佛即见上仙心之所念。又欲教化阎浮提人。譬如勇士屈申臂顷。彼佛如是斯须之顷。从己佛土忽然不现。即住止于上仙之前。及与菩萨五百俱。其如来这现世间。自然大光普有所照。而取天花亿百千伎乐不鼓自鸣。诸菩萨会于彼林薮。于时岩树一切根株茎节枝叶华实皆出法音。上胜仙士。适闻彼佛见其形像心无所畏。即时其体平复如故无有疮疣。于是族姓子。上仙见无垢称王如来至真等正觉。相好巍巍犹须弥山。威神光明踰于日月。神妙圣达为天人尊。诸根寂定若虚空不增不减。欢喜踊跃善心显发。即从坐起更整衣服。偏袒右肩右膝着地。叉手白佛。是我世尊。安住大圣。我归命佛及法圣众。唯佛世尊。为我说法。若闻经者建立奉行。蠲除众生所贪受行。兴于正见而说经典。时族姓子。彼无垢称王如来至真等正觉。缘仙士故为诸天子及诸菩萨。分别说此等集众德三昧之定。于众会中八千天子往古造行修治谊理。即逮法忍。上胜仙士闻是三昧。踊跃欢喜入于微妙。寻时逮得无尽辩才。时彼如来。说八章句又复摄取。何等为八。一切诸法皆为本净。从想着致原自然净也。诸法无漏。一切诸漏皆为尽故也。诸法无著。皆度一切诸所著故也。诸法不虚。亦无有明吾我及人。平等一切诸法门故也。诸法何门。普现一切诸法门故也。诸法无来亦无往也。诸法怀来。断除一切诸所趣故也。诸法平等。于三世无去来今故也。而无有二是为上胜。八章句说。一切启度厌诸所有无有众患

佛告上胜仙士。有八门句。至无有二。何谓八。诸法假号倚名故也。诸法像色犹从名兴故也。诸法合会依着字故也。诸法识自由恣故也。诸法自然则以无明自然故也。诸法为尽习行愚故也。诸法无处立于门者住无常故也。诸法平等以一精进趣于门故也。是为上胜八句门也。本无有二而致于二

佛告上胜。复有八精进句。至无有尽而得自在。何谓八。无者。修精进事。劝助咒愿所修经典为现无处。彼者。行精进句。便能示现究竟法谊。不者。遵精进句。为除名色为示现法。所说经法悉令蠲除。他者。奉于精进现寂然法。六者。志于精进讲说经法。超度一切诸所挂碍。无本者。念精进句。为现如来无本之法。因者。精进为现一切缘法罪福为尽。等者。精进三昧示现诸法分别所趣。是为上胜。八精进句无尽辩才

佛告上胜。复有八法为妙法句。觉了诸法为志平等。何谓八。空为印句。而无所倚而为现法。无想印句。无所建立而现经典。无愿印句。不依不倚不着不求而为现法。本际印句。为本空句。而等御之为现经典。法界印句。等御诸法而为本现。无本印句。现入诸法。犹如印句。蠲除去来今所本现法。灭尽印句。究竟灭尽永除诸法之所本现。是为上胜。八印句也。皆悉分别平等诸法而得成就是故于斯上胜。自在之句及所问句。精进句并诸印句。常当安祥顺行其句而精进学。如是族姓子。于彼无垢称王分别所问。于此遣智至彼世界。及余菩萨五千亿百千垓菩萨。斯须之间如发意顷自还佛土。虽还本土无去无来。其土人民不见如来为去为来。于是族姓子。上胜仙士。获无尽辩意不疑妄。亦无所失。得为诸天之所拥护。救护诸天降伏众魔及外异道。行入郡国县邑州域大邦。为一切人讲说经法。分别演斯等集众德三昧。具足千岁宣现此典。开化八万四千群萌之类住于声闻。发起八万四千众生志于缘觉。八万四千黎庶皆发无上正真道意。劝助八万四千蒸民后悉当为转轮圣王。八万四千建立帝释梵天慈悲喜护。无央数人得生天上。上胜仙士。至于末后仙没之时。生于无垢称王如来至真正觉之土。在于普等无垢世界。与万四千天子俱。佛言。族姓子。欲知尔时上胜仙士为异人乎。勿造斯观。所以者何。则吾是也。吾以至诚建立心愿。即致下方所在世界无垢称王如来至

以是之故。族姓子。当作是观。于乐法菩萨。如来未曾取灭度。正法之教亦无灭尽。其好乐法为菩萨者。他方世界诸佛世尊则现目前。乐法菩萨。若在岩处若在树下。独闲居者若中间坐。即时得见受总持门。置于手掌若现裓上。若在头上若在顶上近而不远。乐法菩萨已为曾见过去诸佛。又诸天人发其辩才。亦复从受辩才之慧。乐法菩萨于此经典无有穷尽。诸佛世尊及诸天人不夺其愿。道所建立犹得自在欲得住立百岁千岁一劫过劫。亦得由己。乐法菩萨除老病死兴发其心。其意所在坚强久固。御于大智辩才之慧。乐法菩萨未曾发意犯于他人。以是之故。离垢威。闻斯博闻所积行者。遵奉精进便当逮获于此名德。当复过是复倍无数。若有菩萨欲得获致福藏德普。庆无终既禄无穷已。菩萨所厚功祚无量。不可称限无能尽极其边际者。离垢威。知其大海水尚可数渧。测知限量得其底泥。菩萨所兴三事戒闻施惠。不可胜限得其边际。三千大千世界尚可称量知其铢两尽其边际。欲尽菩萨所兴三事。戒闻施道不可限量。是为族姓子。三事行品。三事之中博闻为尊。为胜为长为无畴匹。譬如须弥山王。持戒施惠。犹如芥子在须弥山侧。当观博闻则须弥山王也。譬如飞鸟翱翔虚空足影所翳。宁几如乎。持戒施惠犹如斯也。譬如虚空弘普无际。博闻之德其若兹矣。所以者何。族姓子。施有二益。离贫匮得大富。戒有二益。度恶趣生升天。闻有二益。得圣慧除邪疑。其布施者。不离诸漏所受之阴。其持戒者。所受诸阴亦与漏俱。其博闻者。无有诸漏亦不受阴。以是之故。离垢威。斯谓菩萨博闻之应。佛说施戒博闻之时。三万二千群生殖众德本。皆发无上正真道德。五百比丘漏尽意解得法眼净

于是离垢威力士白佛言。菩萨几法行疾得不起法忍。佛言。族姓子。菩萨有四法行。疾得不起法忍。何谓四。一观身如影而得解脱。二入于诸法如呼声响。晓了其心犹如幻化。察一切法皆归尽灭。是为四。菩萨疾得不起法忍。复有四法。何谓四。普修弘慈加诸众生。设使学者起于人想劝使晓解。一切诸法令知尽无不造有事。普皆睹见诸佛之法。不以肉眼亦非天眼。亦非法眼无所依倚。分明晓了心之所入。亦无有心亦不见心亦无缘会。是为四。复有四。何谓四。一切所有施而不吝。弃捐邪见。奉清净禁。寂除尘劳。是为四。复有四。何谓四。遵忍辱力入于诸法。悉知尽索。而崇精进。好澹泊法。是为四。复有四。何谓四。逮得禅定则无所倚。察于智慧亦不轻戏。摄权方便不着众生。皆具所行入无等伦。是为四。复有四。何谓四。常行大慈导利众生。具足大悲不厌终始。行于大喜欣乐于法。行于大护除诸倚着。是为四。复有四。何谓四。证明部分于三脱门。除诸三世过去来今。超度三界。观一切法本净无秽。佛言。离垢威。是为四法行。菩萨大士疾得不起法忍佛说此时。离垢威菩萨逮得不起法忍。欢喜踊跃升处虚空。去地四丈九尺。三千大千世界六反震动。其大光明普照世界。而雨天花百千伎乐。不鼓自鸣。于时世尊。知离垢威菩萨所念。寻时欣笑五色光从口出。照于十方无数佛国。还绕三匝从顶上入。贤者阿难。即从坐起更整衣服。偏袒右肩右膝着地。叉手白佛以偈赞曰

  得尊净智慧　　其目清明好
  诸根为寂定　　澹泊度无极
  光明照七尺　　金容神巍巍
  何故现欣笑　　唯愿为分别
  知诸天人行　　心意所归趣
  三世之清净　　睹之所像类
  其慧常通达　　未曾有挂碍
  何故现欣笑　　月姿哀为说
  过世天中天　　将来之世尊
  今现十方佛　　智慧畅无量
  修行悉清白　　疗愈若干病
  一切靡不了　　愿为分别说
  其身普周遍　　于此诸佛国
  言音悉畅达　　无数之刹土
  心向一切人　　常垂弘大慈
  最胜哀为说　　敷演斯笑意
  所在究练法　　寂然如月游
  无喻如幻化　　自然若如梦
  所获致得利　　常如雨泡起
  何故现欣笑　　无师子师子
  解空无有想　　超度愿脱门
  诸法为自然　　了现究竟谊
  寂默常调定　　游步如虚空
  愿佛分别意　　今笑何感疗
  孰为发妙心　　志愿尊觉慧
  谁令力除魔　　应坐树王下
  最胜今日谁　　而为超拥护
  何故现欣笑　　大雄发遣说
  诸声闻之众　　不能蹈斯地
  一切之缘觉　　莫敢逮此道
  是诸佛境界　　其德如大海
  何感而欣笑　　世胜哀说之

佛告阿难。尔为宁见离垢威。踊在虚空去地四丈九尺乎。对曰已见。天中天。佛言。离垢威力士菩萨。过三百不可计会劫。当逮得无上正真。为最正觉号力严净王如来正真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。在于东方世界名清净。劫名净叹。力严净王如来清净世界。富乐炽盛人民安隐米谷平贱。快乐难及诸天人播殖无数。彼国人民被服饮食居止舍宅。譬如第四兜率天上。其佛说法无有奇特异种之说。唯但宣畅菩萨箧藏其佛国土无有声闻缘觉之名。皆纯菩萨逮得法忍。诸菩萨众甚多无极。其佛寿命无有限量。其土无有八据之难。降伏众魔抑制怨敌。无有群邪诸外异道。其佛世界地绀琉璃。紫磨黄金分错其间。于是离垢威菩萨。从虚空下稽首佛足归命世尊。从佛请求欲得出家。尔时钩锁菩萨前白佛言。唯天中天。怪未曾有。如今大圣讲说经典。其有诸天在于虚空。名德高妙皆诣如来。适见如来寻时欢喜。弃捐贡高自大之念。稽首世尊投身自归。大圣。乃能开化于此离垢威力士憍高自大。来诣佛所逮得大法。当为无量不可思议众生之类。演说经法令除慢恣。唯然世尊。其离垢威菩萨大士。为从几佛如来至真等正觉殖众德本。乃能疾逮如是神通。世尊告曰。钩锁。欲知其离垢威力士菩萨。已曾得供养六十二亿诸佛大圣。殖众德本建立无上正真之道。常复奉事无数诸佛净修梵行。钩锁。又问。唯然世尊。以何所殖无德之本而忘道意。心怀憍慢自大之性。来诣世尊欲有所试。佛告钩锁。有四事法。为菩萨行而忘道意。何谓四。心怀憍慢。不恭敬法。轻易善师。从后谤议。是为四。复有四法。何谓四。而复习乐声闻之众。与同所归。志乐下度。诽谤菩萨。忘法师恩。是为四。复有四。何谓四。其行谀谄。于法慢诞。二事自活。求于利养而着奉侍。是为四。复有四。何谓四。不觉魔事。为罪所盖缠绵蔽法。志性怯弱。钩锁。是为四法菩萨忘失道意。钩锁又听。离垢威。用何等故。为菩萨行而忘道意。往古世时。此贤劫中初始有佛。号曰拘娄秦。如来至真等正觉兴出于世。于彼世时。有善财大势贵姓极富梵志。时有一子。魔所惑立自发贡高。不欲往诣于如来所长益法。与沙门梵志诸长者俱。斗诤骂詈多所诽谤。不肯受法亦不见法。不得法师亦不恭敬承顺其教。当尔现世违失五法。何谓五。则离于佛不复相见不得闻法。不复建立菩萨之业不复咨问。所当行者而复忘失众德之本。无坚固意在于道心。摄取不善寻时则离于道行心。尔时寻离此五法行。佛言。钩锁。欲知是时所名善财大势贵姓梵志子乎。岂是异人勿作斯观。所以者何。则今离垢威菩萨是也。于彼世时心怀自大。寻则忘失所修道意。久复将护宿命德本诸通慧心。又有余福不复诽谤于诸通慧。故为力士而有大势。承佛圣旨不为众恶。闻佛音声便自发来。自以己力欲比如来。又闻世尊说菩萨力。寻即弃捐贡高慢恣。往古所殖众善之本。则现目前便逮法忍。威神通慧无所想念。尔时力士钩锁菩萨谓离垢威。唯族姓子。兴发何法逮得法忍。离垢威答曰。发起一切凡夫之法。又问云何而发。答曰。所发起者。至后究竟永无所有。亦非不异其所发起。常不复令有所依倚。亦无所证。钩锁又问。族姓子。凡夫之法及与佛法。有何差别。宁有若干乎。即便答曰。假号而名。因有若干。其谊无异。又问。唯族姓子。其凡夫法。以何解谊。答曰。无常亦无想念。无颠倒谊。又问。族姓子。所谓谊者。何所归趣。答曰。钩锁。其达谊者。亦不蠲除凡夫之法。亦不获于佛道法。又问族姓子。何谓法谊。答曰。无有二谊为诸法谊。又问不。曰其正见者。有二因缘。从他闻若思惟。厥行犹具。又问钩锁。如来不说但归要谊之故。谊则成要。因此何缘要得谊乎。不取美辞。又问钩锁。答曰。教不但取要谊。终不毁坏为菩萨美辞乎。则无有失自损毁也。假使有得美辞谊者。彼所逮者亦无所获。其菩萨者。不归于要谊而说法谊。以聪哲故。其不逮得不用谊报。一切诸法犹得自在。为尊为长为无等伦。所可分别限时消灭究竟灭度。本末永寂则为相谊。世尊所说以故。钩锁。其归命谊则不御法。亦无所念亦无御者不舍不御。其无所念则为坚要。其要坚者彼乃谓谊。钩锁又问。唯族姓子。岂有方计其归要谊。彼则归要一切法乎。答曰。有族姓子。又问以何因缘。答曰。诸法无本。一切悉空诸法澹泊。假使归要于空谊者。要澹泊谊亦复如斯。以是之故。族姓子。其归要谊则为道归一切诸法。答曰。族姓子。佛不言曰了一切诸法。悉归要御。答曰。如斯。以是之故。一切诸法推究本谊根原。所归要者其究竟谊。是等之门则第一谊。如云何当求所如所也。求如是行者。设无有法亦非法。亦无所起亦无所灭。诸贤圣道无有二道。亦无所作亦非不作亦非无造。如是则造菩萨之道。道无所造亦不求谊。亦仪不错乱。离垢威说是语时。五百比丘八百天子。远离尘垢得法眼净。离垢威菩萨谓钩锁曰。族姓子。如来所说但归要谊不取美辞。计此谊者无有二行。究竟其谊亦无所生。是故如来说此谊耳。但归要谊不取美辞。其归要谊并及美辞。本净平等志性自然无所超越。如来故曰。但归要谊不取美辞

复次族姓子。如来所以说此言者。何以二事故兴于正见。何等为二。听察他音缘省思惟。其不博闻于法律者。顺以三昧在于终始堕于贡高。类斯之故。世尊告曰。听省法律乃为博闻多所劝助。以听经法悉以奉行。净于所疗至贤圣道。又问。云何比丘思惟疗行。答曰。以法疗行亦无所行。是为思惟要事有疗行。族姓子。是为疗行之所谓者。复次族姓子。假使菩萨疗行。不发音声不起吾我。有所讲说诸行处者。若说去者若说还者。一切皆亦无住亦无所得。亦无过去亦无当来亦不现在修此诸事。是谓思惟要者而以疗行。设见诸法一切自然悉归灭尽。设受诸法思观要净。假令察见一切诸法本净同像。亦睹要净设见一切诸法。诸法自然从本净起。亦观要净设使观见一切诸法本末不生。究竟无起究竟无灭。亦观要净设使观见一切诸法本净灭度。亦观要净亦不寂然亦无所观。是谓为观。是所观者。亦无所观亦无所见。假使无见无所观者。所见如是亦不见。则不名曰有所见也。于是世尊。赞离垢威菩萨曰。善哉善哉。族姓子。有所说者。当如仁说。其思要净为菩萨者。法不虚妄。其思要净为菩萨者。法无阴盖。其思要净为菩萨者。无有此法亦无脱门。其思要净为菩萨者。所行法者亦无所除。亦无所行亦无去来。是则等观为正见也。见一切法以平等故。亦不不等如有所见。又问。云何一切诸法而不等。如有所见如无所见。又族姓子。此诸法者。亦无欣见亦无不见。本末平等亦无所生。此之谓也。亦无所生亦无所有。不越所见不入寂然。此谓平等。亦不不有亦无所有。亦非自然非不自然。是谓平等。是所言者。亦无所说行无所生。亦无有见亦无越度平等寂然。斯谓等观。以能入于平等故也。又复重问。何故名曰平等入寂然乎。答曰等于吾我亦等非我。一切诸法亦无形像亦无毁呰。是谓平等入于寂然。于是钩锁菩萨白佛言。唯然世尊。至未曾有正入寂然。所由相者本净灭度。菩萨皆知如是诸法。若复闻者乃能信解。有所游居亦不中半而取灭度。佛告钩锁。以故菩萨。善权方便而以为乐。以权方便修具足行。发一切心归于游处四法。何等四。行大慈。无极哀。为诸通慧。不断佛教。是为四。假使能奉宣修此法。则入寂然所趣之相。一切本净悉为灭度。以至寂寞诸法之行。这闻此已则便信乐。所可游居亦不中半而取灭度。是故分别诸法之原。彼则寂寞亦无澹泊亦不堕落。所以者何。不欲弃舍一切众生。离垢威菩萨白佛言。何所菩萨纯淑。如佛所言不堕寂灭。世尊告曰。族姓子。假使菩萨无有诸见亦无想念。是为纯淑。于诸声闻一切众生。不修平等离佛法教。亦不劝乐大乘之行。疑诸通慧离于无愿。亦不灭度入于寂灭。则于其中证菩萨心。志在声闻缘觉而入灭度。又族姓子。菩萨若能入于寂然相者。皆能分别一切诸法。有所兴发悉为一切顺佛法众。遵修大乘为诸通慧之所兴居。愍伤一切群萌之类。普见一切与志愿俱。未曾断绝他人所侥。以是之故。族姓子。当作斯观。计于菩萨而皆纯淑游于寂然。离垢威白佛言。未曾有。世尊。菩萨所行而有差特。悉非声闻缘觉之地所能及也。于是钩锁菩萨白佛言。今此溥首童真者。在是会中静然而坐。亦不讲说于此三昧。世尊。寻见文殊师利心之所念。以心请观溥首童真。溥首童真谓钩锁菩萨。菩萨所行不以功德遵修佛道。不以利养不以生天。不以财业不以名闻。嗟叹德称宣畅其绩。不以衣食床卧病瘦医药。生活之业。不以国王大臣赏赐故。钩锁又问溥首菩萨。以何等故行菩萨道。溥首答曰。为众生故如愍伤之。故以法之谊开化群黎。志大乘故除于虚妄诸勤劳患。生寂然故已忍劳苦。欲安众生令得所愿。无所狐疑无悕望故。则无所著亦无所倚。亦无所受亦不专处。亦不究竟无有善哉。亦不吾我无有斯念。亦不退转亦不还反。设使诸法无所动转。亦不肃震无有将往。无所危害无有欢喜。亦不愁戚己独勇猛。无能胜者无能伏者。莫能踰者亦不憔悴。无所畏难不恐不惧。不卒不暴无有自大。亦无心意常处寂寞。常住无念同谊一乘。一教同像常作等行。悉欲救度众生之故。溥首言。族姓子。菩萨所行如斯比类。是故造行。钩锁又问溥首。何所施造为菩萨行。溥首答曰。设族姓子。其为菩萨不行于尽。亦无所起亦无不起。究竟诸尽尽所当尽。不念诸本末无起亦无所生。亦无聪明造行。如是为菩萨行乃应道行。复次钩锁。菩萨大士。不行尽过去意。于当来意无所起行。于现在意而无所住。亦无所行。心亦不着去来今也。遵修如是为菩萨行乃应道行。复次钩锁。布施道心众生如来则无有二。持戒忍辱精进一心智慧。道及众生至于如来则无有二。假使菩萨常遵此六度无极有所行者。所行之相不忧终始。遵修如此为菩萨行乃应道行

等集众德三昧经卷中等集众德三昧经卷下

        西晋月氏三藏竺法护译

复次钩锁。菩萨所遵不行色空。色者自空。亦不空痛痒思想生死识行识自然空。亦不教人行色为空。色者则空。本末尽无则曰自然。痛痒思想生死识则亦为空。若欲尽者本末尽空。故曰识空亦曰自然。若已尽者一切诸法亦当复尽。若诸法尽色亦当尽。痛痒思想生死识。识以便尽。假使一切诸色尽者。一切诸法亦当复尽。设使诸法尽者识亦当尽。假使菩萨遵修如是。为菩萨行则应道行。复次钩锁菩萨。菩萨所行亦不断除凡夫法行。至于佛法亦不殷勤度生死行也。亦不具足于灭度事。亦不睹见不善法兴。亦不观察于诸善法之所由来。不以惠故亦不见识。不用识故而见于慧。亦不破坏诸法界行。有所信喜至于解脱也。假使菩萨遵修如是。为菩萨行则应道行。复次族姓子。菩萨大士若造行者。法界无量人界无限。而悉信解法界无限慧界人界悉尽。所行法界人界则无有二。不以法界而有所损亦无有尽。想亦如是人界亦然。人界有相法界无相。及与人界如此相者。则无有相。其无有相。睹一切法悉无有相。不尽人界行无所畏。益从无要思想而兴起发也。颠倒之事诳诈化惑相处其中。其所行者不除欲尽不慕所生。亦不名闻亦不计常亦无所坏。亦不灭除我人寿命。假使菩萨遵修如是。为菩萨行则应道行。说是菩萨所行者品时。百千天子逮得法忍。尔时离垢威菩萨。即寻启受举大音声而叹颂言。使一切人群萌之类。所愿皆得普获利谊。如佛世尊悉令信乐此三昧定

尔时魔王波旬谓溥首童真曰。我为堪任叹菩萨道如菩萨行乎。溥首答曰。可行也。时魔言曰。一切人行则菩萨行。诸声闻缘觉行则菩萨行。下一切居家所习荫担之行则菩萨行。一切魔行则菩萨行。所以者何。菩萨皆当同处其中。一切悉学是菩萨学。钩锁菩萨往诣魔所而谓之曰。云何菩萨而悉普学。魔答曰。八万四千种众生之行。二万一千则属贪欲行。二万一千属嗔怒行。二万一千属愚痴行。二万一千属等分行。是等之类皆悉遍入菩萨之行。是故钩锁。行贪欲行而离于欲行。嗔怒行而离于怒。行愚痴行而离于痴。行等分行而离等分适无所著。又族姓子。若有菩萨普遵一切众生之行。则能遍察群萌之行。开化一切黎庶之类。若有菩萨所修如是。为菩萨行则应道行。又问魔曰何谓一切魔行为菩萨行。答曰。菩萨皆当入诸魔心之所行故也。不以起为起。不随魔事之所教也。觉了魔行化众生行。观其所行不修彼行。独于魔众而示现不行魔行。又当修学魔之治化。虽在魔中而无魔事。又问魔曰。何谓一切声闻缘觉行为菩萨行。答曰。族姓子。假使菩萨为诸声闻缘觉。讲说经法具足所愿。在于彼行遵崇长益精进之行。当求斯惠。不用彼乘而取灭度也。复次族姓子。一切诸行皆自然行为泊澹。行菩萨所当信乐行者。其行已过一切所行如审谛行。一切诸行无所住。一切诸行悉无为行。亦无合会无所起行无所住行。菩萨当崇如是之行。魔王又问溥首。仁可垂恩重。复说此诸所行乎。溥首答曰辩才堪任皆度一切。所有境界为菩萨行。所以者何。其彼行者。不与眼界而俱合也。不与色界而合会也。不与耳声鼻香舌味身更意法意界。而俱合也。以是故。魔当作斯观。假使能度诸境界者。号曰正士。复次天子。菩萨设能如是行者。不为欺惑诸佛世尊。如是行为菩萨行则应道行。又问。何谓溥首。菩萨所行。而不欺惑诸佛世尊及一切法。溥首菩萨答曰。如来所说诚谛解诸法空。一切悉无逮最正觉。假使菩萨依倚见身及诸佛法。并见泥洹则为欺惑诸如来也。天子。欲知如来行者。于一切法而无想着乃逮正觉。假使菩萨于一切法。有所想求与想游居。则为欺惑于如来也。天子。如来审实诚谛无所从出。亦无所生亦无所起。亦无所有亦无所倚。亦无有相来无所来亦无所住。本性清净本性明达本净灭度。犹如虚空无有形貌。解一切法亦悉如是乃逮正觉。假使菩萨在于诸法。有往如来有入有出。若所起忽然现者。出于所有依因于相。若有往返若有所立。无有清净。若有尘劳终始周旋。获色所有而为放逸。有所思念即为欺惑如来。假使天子。若有菩萨等御解空了一切法。皆于诸见而无思想。等御所行解一切法悉除诸想。等御无愿分别诸法度于三界。等御如空解一切法不着本净。遵修如是为菩萨者。不为欺惑诸佛世尊。于时大圣赞溥首曰。善哉善哉童真。如是行者为菩萨行。若有菩萨所行如是疾得受决。佛言溥首。吾忆往古锭光佛时。己身劝助行清白法。所行无行亦不寂灭。得受决也。所以者何。处一切行名曰所现光。这睹斯已何为想行。时有色莫若而志利义适。从锭光如来大圣受决则了本净。即时普解一切诸法悉无所起。然后锭光如来所见受决。仁于来世当得作佛。号曰能仁如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。于彼世时寻逮得不起法忍。以是之故。溥首。若有菩萨欲疾逮得不起法忍。当修此行救诸退转。心无所著不以利业精进。行法无所脱度无所。度无所度乃得解脱。溥首又问佛言。唯然世尊。得法忍时为何所逮。世尊告曰。不得于色乃逮法忍。痛痒思想生死识。亦无所得乃逮法忍。不得阴种诸入乃逮法忍。不得计常空净安隐及与我身乃逮法忍。又复永睹不得一切诸法乃逮法忍。佛言。溥首。诸法悉尽故曰为无所得。溥首。法忍无逮亦无所得。随习俗行故名曰得。非凡夫法亦非学法非不学法。非缘觉法非菩萨法。亦非佛法有所行也。于一切法都无所行。故名曰尽逮得法忍。一切诸法亦不可得。是故曰尽逮得法忍。假使法忍空无所有。于一切想诸所行者而无所畏。故曰尽索逮得法忍。彼无有眼亦无眼识。无有耳亦无耳识。无有鼻亦无鼻识。无有舌亦无舌识。无有身亦无身识。无有意亦无意识。诸畏无尽则曰法忍。无为界则谓法忍。无有意界乃谓法忍。皆悉尽索乃得法忍。说是法忍诸法尽索时。五百菩萨得不起法忍。同音举声白佛言。唯然世尊。我等当具等集众德三昧。亦当普备于一切法逮无所起。是深妙法诸菩萨学所当承顺若有闻者当欢喜信受持读诵如法奉行。于是钩锁菩萨谓溥首曰。有所言曰。所作已办众事成就。菩萨当以几法所作众事究竟成办。溥首答曰。族姓子。若有菩萨知一切法而无所作。如是菩萨所作已办究竟成就。一切诸法悉无所有亦无所行。晓了诸法能如斯者。所作已办究竟成就。亦不有智亦无有二。所作已办究竟成就。亦不离作亦非不作亦无不作。所作已办究竟成就。有所者有宣扬所作已办究竟成就。若得恩者报所得恩。所作已办究竟成就。遭无反复加以反复。所作已办究竟成就。当供养者为之谦卑自屈施礼。所作已办究竟成就。知反复者若离反复者。若能办事离不办事。所作已办究竟成就。若轻易者而见忽损稽首为礼。所作已办究竟成就。有所作者不得所作法之所行。有所遭睹不得所过。所作已办究竟成就。若布施者劝使入道。所作已办究竟成就。亦不得施亦不得道。亦不得我亦不得人亦不得他。所作已办究竟成就。不护禁戒忍辱精进一心智慧。亦无所护劝使趣道。所作已办究竟成就。若有施与持戒忍辱精进一心智慧劝使入道。所作已办究竟成就。非智非愚无我无他亦无所得。所作已办究竟成就。身行口言意念奉行众善分别此事。若身口意所行众善。亦无所得亦无所著。是则名曰所作已办究竟成就。尔时常坚精进菩萨谓溥首曰。我为应 往 说菩萨所作已办究竟成就乎。溥首答曰。堪任。族姓子白溥首曰。若劝一人令闻道音所作已办。菩萨箧藏应时自恣。若令得佛音法音圣众之音。则当察之所作已办。若化一人使受戒禁。使归命佛及法圣众志在三宝。所作已办具足菩萨箧藏供养。若所游居若有施者若有受者。劝助志道此二事者。则是菩萨清净众祐。若有施者及有受者已斯法行。而劝化之此二事者。悉是菩萨清净众祐。假使菩萨思惟念佛。若复思念经法圣众菩萨众生。所作已办菩萨箧藏而受供养。假使菩萨修行慈心悲喜护心。若值一人下劣贫匮盗贼屠魁。骂詈冲口而能忍之。不以嗔怒续行慈心。欢悦之意以待其人。欲益利谊益加精进所作已办。若获百利若千利若百千利亿百千利。若以珍宝满阎浮提得斯利者。未曾以宝而发两舌。又复咨启问他人慧。宁失身命不从其后而说恶也。不忘于法不承非法。观此菩萨所作已具究竟成就。复次溥首。假使菩萨七日断供而不得食。若复有人受饮食者。其人则近诸通慧心不为虚妄。又欲度脱一切众生。欲念救济群萌之类。观此菩萨所作究竟。假使天下普遍满水周匝其地。当越度此行求听法。若遍满火亦当越度行求闻法。亦不惜身亦不贪命亦不爱寿。而造斯观阴种诸入易易得耳。诸佛世尊难得值遇。经法难闻。恭恪于法亦复难遭。若入此数观斯菩萨究竟成就。复次菩萨若闻四句之颂欢喜踊跃。不愿享祚为转轮圣王。宁以四句颂令人得闻熙怡豫悦。不乐帝释位。宁立众施诱化狗犬禽兽龙神。不生梵天欣乐诸通慧心。不贪三千世界之七宝。喜踊愿志殖一德本。不侥一切众生供养之利。菩萨所行修如斯者。当观菩萨成就究竟。常坚精进菩萨复谓溥首。有菩萨常坚精进常求博闻。心当念此。假使有人段段节节解其身者。当发欢喜以自劝勉。是皆俗法之所致也。专志修行念于佛道。宁失躯命终不犯戒不舍大乘。不为愚心不兴邪力。致忍辱力口言不粗悉能堪任。终不懈怠修精勤行。严净佛土而救众生不为非法。普求一切诸度无极。不求伴党不望众生。坚住智慧不断佛教。志性强猛一切所作无不成办。其意仁和弃捐 偷[焰-火+女] 无所贪慕不惜身命晓练便宜。不久立者令得自归奉戒清净。先人问讯语言柔软辞不绮饰。譬若如地离于所求。无所求无所结倚性行纯善。所答安隐所说常快敬受善谏。弃除贡高常逊卑意。所言至诚无有忿讼。所说如实无有谗谀。言行相应遵尚等心。愍于众生常有慈心。向诸群萌志于大哀。为黎庶故无有瑕疵。建立一切众德之本而怀欣豫。一切所有施而不惜。当以行护救济所欲。及得财业当行安隐。放舍一切诸所贪爱。无有我所不倚所有。终不自大蠲除三垢。志求解脱离于想念。所思所著不堕诸见。无六十二当行博闻。具足七财心常强勇。所闻晓解未曾有厌。当学智慧有所建立。住于勇猛降伏尘劳。离于欲垢疗治一切众生之病。常为众祐未曾舍离。诸通慧心成就福田。令诸众生悉得蒙恩。行如莲花于诸世俗而无所著。犹如船师度诸群生四病之患。志如王路不得轻慢贵贱中间之人。当如泉源川流江河。所说经典而不可尽。行如大海所闻智慧苞无崖底。无量之德之所积聚。性如须弥起现于世峻极而高。常乐精进志性慷恺。心不怯劣心如门捆。志愿坚固意如鹤毛。调和其性当行尊心。济导众生修于自在。劝助其意志存奇雅。微妙解脱行如天帝。怀来众生遵如梵天。分别权宜清净之行。于一切法而得自在。常当行慈究竟灭度。行如终没若有触犯。作与不作悉能忍辱。心如严父所受至重。志如伴党作诸德本而无所著。意无所倚于诸境界。行无危害而修慈仁。所在吉祥于所生也。为布施士谓法施也。断除一切诸不善法。奉行一切众善之法。遵无放逸除于自恣憍慢之事。学戒精进所行坚强。为无放逸修菩萨行。乃能致得无上正真之道为最正觉。于时世尊赞常坚精进菩萨曰。善哉善哉。族姓子。说菩萨行快乃如是建立众德。若有菩萨设欲逮得等集众德三昧。普当分别一切功德离诸罪衅

尔时钩锁菩萨前白佛言。若有菩萨逮得于是等集众德三昧。功德瑞应比类若何。佛告钩锁。令此等集众德三昧。菩萨大士获此定者。则能远离恶趣之地。无有八据厄难之处除断穷窭。供膳丰沃自然为乐。诸根具足便能成就三十二大士之相。法无穷尽逮得辩才。获于总持常不失意。于一切福德自在。成转轮王无所倚碍。为诸群黎之所奉事。为天帝释所见咨嗟。梵天稽首而为作礼。逮获神通靡不明达。得其本愿自在所生。行权方便进退智慧。不随禅教遵修智慧。离一切见极尊特贵。声闻缘觉所不能及。离诸恐畏声闻缘觉智慧分别。诸根晓了众生本末娱乐诸见。志于一心脱门之事。住无处所常顺所施。建立于戒护三清净。分别忍辱竟无有形离谄伪想。讲说精进志无懈惓。解说禅定常度寂然。敷演智慧目常睹见而悉分别。目无所著而常弃捐。除于六径未曾违远。常见诸佛好乐听法。奉事圣众殷勤修行。不离于空无想无愿。所闻经典歌颂一切诸佛功德。悉受佛诲即以咨受。善为众生分别说之。在兜率天未曾舍离不退转法。若欲游行一切佛土。无有挂碍普见诸佛。降伏魔怨无有四魔。见深法忍处不退转法。逮明神通在于道业。法靡不博怀来。寂然清白睹见所行具足佛法。现不退转行之所趣。除一切着所可挂碍。见吾我色犹如幻现。观察悉见一切身复无能胜者。谓诸异道受护正法。诸佛尊典。不惜身命其行殷勤持御正谊。现佛境界常无永绝。虽已泥洹而不灭度。得无所畏游在众会而无恐难。聪明睿达随其所作而善蠲除。去于一切贡高自大。修大庄严以幻三昧有所感动。若放光明而悉覆蔽日月星明。火电得坚强力身如钩锁行如金刚。皆度一切诸恶所乏。普道场净游无量佛土普闻其声。佛所建立身口意净降伏魔兵。神足变化度于无极。震动一切诸佛国土。得聪明慧分别法谊之所归趣。辩才具足慧无挂碍。为诸众生遵行精进。兴显佛事而无放逸。于诸通慧现佛境界。如是钩锁。若有菩萨逮得于斯等集众德三昧。是诸菩萨瑞应因缘仪像。众德名闻之事巍巍如是。钩锁白佛。皆令一切众生之类。俱共逮此等集众德三昧。所以者何。唯然世尊。若有逮得于此定者。众德名闻堂堂乃尔。声闻缘觉所不能及。假使有人闻此三昧而不信者。则当知为魔所娆固。佛言。如是如是。钩锁。诚如所云。假使有人信是三昧。名德之勋不可思议。为佛所护。于是钩锁。又问溥首曰。若有菩萨意欲逮得等集众德三昧。当行何法。溥首答曰。若有菩萨意欲逮得等集众德三昧。未曾毁坏凡夫之法当修斯行。所造行者于佛道法亦无所得。若欲行者当作此行。无法无见亦无所忧

复次钩锁。若有菩萨欲得斯定誓叹终始。不为生死之所沾污得于无为。不于声闻缘觉之乘而取灭度也。复次钩锁。菩萨欲得斯定意者。具足众德当学所学之禁戒也。亦不想念有漏之福。无漏之德无罪不罪。不有不无不着不舍。不去不来世不度世。未曾怀念如此诸想。等御法界信乐众德。有福无福有常无常有念无念。不入终始所著之相。为一切人游入众德。不为一人处游福祐。以一人德普入众生之所。有福若漏无漏。不复分别不以此教。一切佛德则一佛德。当作斯念。所可教化说诸佛法无有差特。当信知此。其所学福无所学福。若缘觉福若菩萨福若如来福。此则无常亦无形貌色像也。当喜信乐一切诸德福之所凑。譬如钩锁。诸有形色皆有四大。亦复如是诸菩萨法。皆度众生至于脱门奉行等福。当所为者所兴盛者无常尽法

复次钩锁。若有菩萨欲得此定意。于四无量不怀恐惧。何等四。人界无量。佛土无限。佛慧无边。众生之行无有[邱-丘+互]。是为四。复次钩锁。若有菩萨欲得此定。常当劝助四不可思议。何等四。罪福报应不可思议。众生之行不可思议。而所趣路无有差特。诸菩萨慧不可思议。神足力势脱门。诸菩萨之所归趣不可思议。所生清净。是为四。是故钩锁。若有菩萨于此三昧见无尽。当行四法。何等四。于斯建立菩萨之福住不可尽。具足众行亦不可尽。无碍辩才亦不可尽。智慧所达亦不可尽。是为四。复有四事。何等四。勤精于法积众德。本而无厌极。当念勤行入闻无厌而说经典。当念勤行劝助无边众善之德。观诸佛土所见庄严。以入己土而成清净。是为四钩锁菩萨谓溥首。譬如琉璃明月珠宝所著器中。若在金器银器水精器车磲器。则以琉璃明月珠宝器威德之故。不失自然。如是溥首。若有菩萨住是三昧。若在居家若复出家住在沙门。计于法界自然之行无二脱门。又溥首。菩萨何行有所遵修。不失三昧有所逮得德慧无尽。溥首答曰。钩锁。欲知菩萨当行四事。何谓四。不惜身寿命不求一切供养之利。行空无想无愿不志声闻缘觉之乘。欲得佛慧思惟其行。于诸通慧放舍所思所想可应不应。一切众生等入行度我人寿命亦不可得。是为四。钩锁又问溥首。此三昧者然后归趣何所。菩萨若取经卷着在身怀若兴忍辱。设使居家若出家学因缘学行乎。溥首答钩锁曰。后若有得此三昧者。假使有人逮闻其名。则非居家出家因缘。所以者何。是故钩锁。若有菩萨住三昧。则离二想所在游行。其寿智慧不可尽极无所忘失。开化众生不以为厌。不自示现菩萨形类。又在所奏一切无边亦无因缘。譬如钩锁。日月所游一切无边。菩萨如是观无倚行。若在家地随家依。倚亦不出家为出家。行亦复不着出家之德于斯二事亦无所慕。所以者何。菩萨所出悉无所著。譬如钩锁。无所得者乃成正觉。于此菩萨有四事行。何等四。为尊为上而为最胜。弃除一切诸所见事。及入一切诸佛之法。是为四。钩锁又问溥首。云何菩萨处于游居。溥首答曰。菩萨有四事行。何等四。慈悲喜护。是为四。其有奉行是四梵行。吾乃谓斯为游居。复有四。何等四。若复游处聚落舍室则为游居。假使复在于闲居行。若在棚阁重屋作行。则亦处于游居。是为四。溥首复谓钩锁曰。其不奉修此四梵行。而自念言我处游居。其人则为欺诸天人。所以者何。诸佛世尊说四梵行乃谓游居。其四梵行则处其顶。是清净行而处游居。在于国土受分卫食威神在顶。是故钩锁。其有不见四梵行者。则为远离四等心行若复有修梵净行。皆悉因从四梵行起得贤圣慧。不为世间自见身也。贡高自大不除人想。钩锁又问溥首。云何菩萨奉慈心行。何谓悲。何谓喜。何谓护。溥首答曰。则以幻事救护一切众生之类。则为行慈。而以幻事度脱众生。则为行悲。若以幻事安隐群萌。则为行喜。说以幻事令诸黎庶逮得灭度。则为行护。复次钩锁。信解众生界空。则为行慈。信解法界众生之界无作非不作。则为行悲。信解了知诸群萌界无著无脱。则为行喜。信解了知黎庶之界来无所来。则为行护。复次钩锁。一切众生无有吾我亦不恐怖。则为行慈。一切众生悉为澹泊亦不畏懅。则为行悲。一切诸法法界平等亦不怀惧。则为行喜。信解分别一切佛土无尽之国。则为行护。复次钩锁。无危害相则谓为慈。无等伦相则谓为悲。无有二相则谓为喜。无有名无所著相则谓为护。复次钩锁。无所住慈不为大慈。无所住悲不为大悲。彼何谓不为大慈。犹如声闻发是念言。令诸众生皆获安隐。是声闻慈不为大慈。何谓大慈。假使等心于群萌类。而皆度脱众恼之患。是为大慈。彼何谓悲不为大悲。黎庶之类生在五趣。愍伤哀之。于生死中而欲拔济。是谓为悲不为大悲。何谓大悲。见于五趣生死 蒸庶 。所生之处而行愍哀。自舍身安救护五趣。便能济拔众生之界。寻时建立于平等道。是谓大悲。是故钩锁。当作斯观。声闻有慈不为大慈。亦复有悲不为大悲。是故钩锁。若有菩萨当具足行大慈大悲。溥首说是语时。八千天人皆发无上正真道意。俱共叹言。唯然世尊。我等亦当奉修此行。如今向者溥首所说。百千天人逮得是三昧。八千菩萨得不起法忍。于是钩锁菩萨白佛言。如来愿说。百福之相作何功德。而佛世尊成斯相乎。时佛告曰。譬如钩锁。江河沙等诸佛世界悉共合集。满中众生功德具足。为转轮王一身之德。是诸众生所有功德皆如转轮圣王。悉共同合。为天帝释一身之福。复有别异江河沙等诸佛世界。一切众生使其福德具足成就如天帝释。悉复合集此众生福如帝释福。尔乃及于一梵天福。复有别异江河沙等诸佛世界众生之类。其福各各譬如梵天悉备具足。是诸众生其福各各等如梵天。合集此福以为成一声闻之福。复有别异江河沙等诸佛世界。众 生之类。各各功德如声闻者。悉合此福令具足备。尔乃合为一缘觉福。复有别异江河沙等诸佛世界一切众生。其福如缘觉者悉备具足。尔乃合为一菩萨福。菩萨之福则过于彼不可称限。假使逮得等集众德三昧定者。正使三千大千世界满中众生。悉令逮得等集众德三昧定者。合集于此众生三昧之德。以为一无挂碍祠无瑕之慧无想着慧。是故钩锁。如是比慧所可祠祀。皆悉合集而为法祠。撰合斯福乃为如来一大人相。如是比类三十二相。各各若兹乃成如来具足身相。一切众生不能思议。是故名曰不可思议如来之身百福之相。佛说此百福功德大人相时。三千大千世界六反震动。其大光明普照世界而雨天花。百千伎乐不鼓自鸣。诸天世人。怪未曾有踊跃欣喜。各各叉手为佛作礼。举声而叹俱白佛言。若族姓女其发无上正真道意。为得善利无极之庆。乃当逮得如是之比百福之相。悉具足备。则为超过释梵四王一切声闻及诸缘觉。唯然世尊。其有闻此等集众德三昧。快哉快哉。为得菩萨利。若得闻名其德难及。何况其人闻信乐奉行。假使有人持是三昧所游之处。则为拥护其土众生。令此经典所游之处。计其土地佛所建立。假使世尊江河沙等诸佛世界。满其中火当入中过。求闻是法闻是经者。则归大安。世尊告曰。如是如是。天子。诚如所云假使有人闻是三昧。而不信乐不能闻受。为魔所固。其有菩萨不得逮闻是三昧者。亦不受持讽诵说者。吾不名之为闻多智。天子白佛。唯佛世尊。如来圣旨建立此法。令于后世遍得宣布。尔时世尊放眉间相及髻相光。其光普照无量无边诸佛世界。寻其光明自然出声。而叹颂曰。如来已为建立斯法

尔时世尊告贤者阿难。今吾不久当般泥洹。余有三月。佛语阿难。已为劝助吾嘱累汝于此经典。汝当受持为诸 众会广分别说。若有人及菩萨学持三昧。则为其人佛不灭度法不灭尽。所以者何。其有阿难受行其法。则为见佛。若为众会讲论说者。此为护法。时贤者阿难。泪出而白佛言。唯然世尊。愿住一劫复过一劫。多所愍伤多所哀念。多所安隐天上世间。世尊告曰。阿难。且止莫忧勿愁。向者吾不说乎。具足是法者佛则永存。亦复不离诸佛世尊。所以者何。不当以色观如来也。亦非相好。若睹此法则为见佛。佛说如是。钩锁菩萨。溥首菩萨。离垢威菩萨。及诸菩萨。贤者阿难。及大声闻一切众会。诸天龙神干沓和世人阿须伦。莫不欢喜稽首作礼

等集众德三昧经卷下


佛垂般涅槃略说教诫经

    No. 389

佛垂般涅槃略说教诫经(亦名佛遗教经)

        后秦龟兹国三藏鸠摩罗什奉　诏译

释迦牟尼佛初转法轮。度阿若憍陈如。最后说法度须跋陀罗。所应度者皆已度讫。于娑罗双树间将入涅槃。是时中夜寂然无声。为诸弟子略说法要。汝等比丘。于我灭后当尊重珍敬波罗提木叉。如闇遇明贫人得宝。当知此则是汝大师。若我住世无异此也。持净戒者不得贩卖贸易。安置田宅。畜养人民奴婢畜生。一切种殖及诸财宝。皆当远离如避火坑。不得斩伐草木垦土掘地。合和汤药占相吉凶。仰观星宿推步盈虚历数算计。皆所不应。节身时食清净自活。不得参预世事通致使命。咒术仙药。结好贵人亲厚媟嫚。皆不应作。当自端心正念求度。不得苞藏瑕疵显异惑众。于四供养知量知足。趣得供事不应 蓄 积。此则略说持戒之相。戒是正顺解脱之本。故名波罗提木叉。依因此戒得生诸禅定及灭苦智慧。是故比丘。当持净戒勿令毁犯。若人能持净戒是则能有善法。若无净戒诸善功德皆不得生是以当知。戒为第一安隐功德之所住处

汝等比丘。已能住戒当制五根。勿令放逸入于五欲。譬如牧牛之人执杖视之。不令纵逸犯人苗稼。若纵五根。非唯五欲将无崖畔不可制也。亦如恶马不以辔制。将当牵人坠于坑陷。如被劫害苦止一世。五根贼祸殃及累世。为害甚重。不可不慎。是故智者制而不随。持之如贼不令纵逸。假令纵之。皆亦不久见其磨灭。此五根者心为其主。是故汝等当好制心。心之可畏甚于毒蛇恶兽怨贼大火越逸。未足喻也。动转轻躁但观于蜜不见深坑。譬如狂象无钩。猿猴得树腾跃跳踯难可禁制。当急挫之无令放逸。纵此心者丧人善事。制之一处无事不办。是故比丘。当勤精进折伏其心

汝等比丘。受诸饮食当如服药。于好于恶勿生增减。趣得支身以除饥渴。如蜂采花但取其味不损色香。比丘亦尔。受人供养取自除恼。无得多求坏其善心。譬如智者筹量牛力所堪多少。不令过分以竭其力

汝等比丘。昼则勤心修习善法无令失时。初夜后夜亦勿有废。中夜诵经以自消息。无以睡眠因缘令一生空过无所得也。当念无常之火烧诸世间。早求自度勿睡眠也。诸烦恼贼常伺杀人甚于怨家。安可睡眠不自惊寤。烦恼毒蛇睡在汝心。譬如黑蚖在汝室睡。当以持戒之钩早摒除之。睡蛇既出乃可安睡。不出而眠是无惭人也。惭耻之服。于诸庄严最为第一。惭如铁钩能制人非法。是故比丘。常当惭耻。无得暂替。若离惭耻则失诸功德。有愧之人则有善法。若无愧者。与诸禽兽无相异也

汝等比丘。若有人来节节支解。当自摄心无令嗔恨。亦当护口勿出恶言。若纵恚心则自妨道失功德利。忍之为德持戒苦行所不能及。能行忍者乃可名为有力大人。若其不能欢喜忍受恶骂之毒如饮甘露者。不名入道智慧人也。所以者何。嗔恚之害能破诸善法坏好名闻。今世后世人不喜见。当知嗔心甚于猛火。常当防护无令得入。劫功德贼无过嗔恚。白衣受欲非行道人。无法自制。嗔犹可恕。出家行道无欲之人。而怀嗔恚甚不可也。譬如清冷云中霹雳起火非所应也汝等比丘。当自摩头。已舍饰好着坏色衣。执持应器以乞自活。自见如是。若起憍慢当疾灭之。谓长憍慢尚非世俗白衣所宜。何况出家入道之人。为解脱故自降其心而行乞耶。汝等比丘。谄曲之心与道相违。是故宜应质直其心。当知谄曲但为欺诳。入道之人则无是处。是故汝等。宜应端心以质直为本汝等比丘。当知多欲之人。多求利故苦恼亦多。少欲之人无求无欲则无此患。直尔少欲尚应修习。何况少欲能生诸善功德。少欲之人则无谄曲以求人意。亦复不为诸根所牵。行少欲者心则坦然无所忧畏。触事有余常无不足。有少欲者则有涅槃。是名少欲汝等比丘。若欲脱诸苦恼。当观知足。知足之法即是富乐安隐之处。知足之人虽卧地上犹为安乐。不知足者虽处天堂亦不称意。不知足者虽富而贫。知足之人虽贫而富。不知足者常为五欲所牵。为知足者之所怜愍。是名知足

汝等比丘。若求寂静无为安乐。当离愦闹独处闲居。静处之人帝释诸天所共敬重。是故当舍己众他众。空闲独处思灭苦本。若乐众者则受众恼。譬如大树众鸟集之则有枯折之患。世间缚着没于众苦。譬如老象溺泥不能自出。是名远离

汝等比丘。若勤精进则事无难者。是故汝等。当勤精进。譬如小水常流则能穿石。若行者之心数数懈废。譬如钻火未热而息。虽欲得火火难可得。是名精进

汝等比丘。求善知识求善护助而不忘念。若不忘念者。诸烦恼贼则不能入。是故汝等。常当摄念在心。若失念者则失诸功德。若念力坚强。虽入五欲贼中不为所害。譬如着铠入阵则无所畏。是名不忘念

汝等比丘。若摄心者心则在定。心在定故能知世间生灭法相。是故汝等。常当精勤修集诸定。若得定者心则不乱。譬如惜水之家善治堤塘。行者亦尔。为智慧水故善修禅定令不漏失。是名为定

汝等比丘。若有智慧则无贪着。常自省察不令有失。是则于我法中能得解脱。若不尔者既非道人。又非白衣。无所名也。实智慧者则是度老病死海坚牢船也。亦是无明黑闇大明灯也。一切病苦之良药也。伐烦恼树者之利斧也。是故汝等。当以闻思修慧而自增益。若人有智慧之照。虽无天眼而是明见人也。是为智慧

汝等比丘。若种种戏论其心则乱。虽复出家犹未得脱。是故比丘。当急舍离乱心戏论。若汝欲得寂灭乐者。唯当善灭戏论之患。是名不戏论

汝等比丘。于诸功德常当一心舍诸放逸。如离怨贼。大悲世尊所欲利益皆以究竟。汝等但当勤而行之。若在山间若空泽中。若在树下闲处静室。念所受法勿令忘失。常当自勉精进修之。无为空死后致忧悔。我如良医知病说药。服与不服非医咎也。又如善导导人善导。闻之不行非导过也。汝等若于苦等四谛有所疑者。可疾问之。无得怀疑不求决也

尔时世尊如是三唱。人无问者。所以者何。众无疑故

尔时阿[少/兔]楼驮观察众心而白佛言。世尊月可令热。日可令冷。佛说四谛不可令异。佛说苦谛真实是苦。不可令乐。集真是因。更无异因。苦若灭者即是因灭。因灭故果灭。灭苦之道实是真道。更无余道。世尊。是诸比丘于四谛中决定无疑。于此众中。所作未办者。见佛灭度当有悲感。若有初入法者。闻佛所说即皆得度。譬如夜见电光即得见道。若所作已办已度苦海者。但作是念。世尊灭度一何疾哉。阿[少/兔]楼驮虽说是语。众中皆悉了达四圣谛义。世尊欲令此诸大众皆得坚固以大悲心复为众说

汝等比丘。勿怀忧恼。若我住世一劫会亦当灭。会而不离终不可得。自利利人法皆具足。若我久住更无所益。应可度者若天上人间皆悉已度。其未度者皆亦已作得度因缘。自今已后。我诸弟子展转行之。则是如来法身常在而不灭也。是故当知。世皆无常会必有离。勿怀忧也。世相如是。当勤精进早求解脱。以智慧明灭诸痴闇。世实危脆无牢强者。我今得灭如除恶病。此是应舍罪恶之物。假名为身。没在生老病死大海。何有智者得除灭之如杀怨贼而不欢喜

汝等比丘。常当一心勤求出道。一切世间动不动法。皆是败坏不安之相。汝等且止。勿得复语。时将欲过我欲灭度。是我最后之所教诲

佛垂般涅槃略说教诫经


佛临涅槃记法住经

    No. 390

佛临涅槃记法住经

        大唐三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。在拘尸城力士生地娑罗双林。与无量无数声闻菩萨摩诃萨俱。并诸天人阿素洛等。一切大众前后围绕时薄伽梵临般涅槃。愍众生故。以慈软音告阿难曰。吾今不久当般涅槃。一切有为无不悉舍。一切佛事皆已究竟。我已宣说离窟宅法妙甘露法最自在法极安乐法。是法深妙难解难知。不可寻思超寻思境。诸大圣者自内所证。我又三转无上法轮。其轮威猛具十二相。诸余沙门或婆罗门天魔梵等。皆无有能如实转者。我已为诸天人吹大法蠡。击大法鼓。觉悟长夜无明睡眠。我已为诸天人建大法幢。然大法炬。普照一切除灭暗冥。我已为诸有情作大法桥。为大法船。济渡一切暴流所溺。我已为诸有情注大法流。降大法雨。一切枯槁皆令润洽。我已开显解脱正路。引诸世间迷失道者。若诸有情我应度者皆已度讫。诸未度者皆亦为作得度因缘。我已降伏一切外道。我已摧灭一切邪论。我已倾覆诸魔宫殿。我已破坏一切魔军。正师子吼作大佛事。圆满丈夫本所誓愿。护持法眼令无毁缺。化诸声闻。授菩萨记。为未来世无上佛眼。开照世间常无断绝。阿难。汝等当于如是无上正法勤加护持令不灭没。阿难。我今更无所作。唯大涅槃是所归趣

尔时阿难闻佛语已悲慕感绝。良久而言。未审如来为诸有情。三无数劫勤苦所得无上正法。于佛灭后住世几时。饶益天人阿素洛等。当渐隐没

尔时世尊重以慈音告阿难曰。诸佛化迹法皆如是。勿复忧悲。无上正法于我灭后。住世千年饶益天人阿素洛等。从是已后渐当隐没

阿难当知。我涅槃后第一百年。吾圣教中圣法坚固。我诸弟子聪慧多闻。无畏辩才能伏邪论。具大神力。于诸有情多所饶益。由是义故。天龙欢喜勤加守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹。一百年末有大国王。名阿输迦。出现于世。具大威力王赡部洲。建窣堵波高广严饰。其数满足八万四千。供养吾身所留舍利。令无量众见闻欢喜。皆树生天解脱之业

我涅槃后第二百年。吾圣教中寂静坚固。我诸弟子聪慧多闻。如天人师具大威德多所饶益。以是义故。天龙欢喜常加守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹

我涅槃后第三百年。吾圣教中正行坚固。我诸弟子证慧解脱俱分解脱。身证见至无量百千。由是多人得圣果故。天龙欢喜常加守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹我涅槃后第四百年。吾圣教中远离坚固。我诸弟子乐住空闲勤修寂定。以是义故。天龙欢喜常随守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹

我涅槃后第五百年。吾圣教中法义坚固。我诸弟子爱乐正法。精勤修学论议决择。由是义故。天龙欢喜常勤守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹

我涅槃后第六百年。吾圣教中法教坚固。我诸弟子多于教法。精勤诵习心无厌倦。能多饶益无量有情。以是义故。天龙欢喜勤加守护。国王大臣长者居士亦复如是。善识福田。于佛法僧深生净信。供养恭敬尊重赞叹。然于义趣多有怀疑

我涅槃后第七百年。吾圣教中利养坚固。天龙药叉阿素洛等。于佛法僧供养恭敬尊重赞叹。我诸弟子多着利养恭敬名誉。于增上学戒定慧等不勤修习

我涅槃后第八百年。吾圣教中乖争坚固。我诸弟子多相嫌嫉结构恶人。尘坌讪谤轻诃持戒。鄙贱多闻不念六和。专思乖争见不善巧。不敬师长不正知住。欺诳谄曲言词粗犷如栴茶罗。依附国王大臣长者。方便损费三宝财物。结恶朋党折挫善人

我涅槃后第九百年。吾圣教中事业坚固。我诸弟子多营俗业耕种商估。通致使命以自存活。于诸如来所制学处。慢缓毁犯

我涅槃后第十百年。吾圣教中戏论坚固。我诸弟子多勤习学种种戏论。舍出世间诸佛正教。所谓契经应颂记别讽诵自说缘起譬喻本事本生方广希法及与论义。精勤习诵世间戏论。所谓王论贼论战论食论饮论衣论乘论我论淫论男论女论诸国土论诸河海论诸外道论。由乐此等种种戏论。令诸沙门婆罗门等轻毁退失我之圣教。于我正法毗奈耶中。当有如斯诸恶苾刍苾刍尼等。不善修习身戒心慧。更相忿争谋毁诽谤。耽着妙好种种衣钵房舍敷具。由与诸恶徒党集会。虽经多年守护净戒。于须臾顷悉皆毁犯。虽经多年集诸善本。由多忧恚悉皆退失。以是因缘天龙等众。悲伤懊恼舍不守护。国王大臣长者居士。于三宝所不生净信诽谤轻毁。由是因缘令正法灭

从是已后诸苾刍等造恶转深。国王大臣长者居士益不恭敬。三宝余势犹未全灭。故于彼时复有苾刍苾刍尼等。少欲知足护持禁戒。修行静虑爱乐多闻。受持如来三藏教法。广为四众分别演说。利益安乐无量有情。复有国王大臣长者及居士等。爱惜正法。于三宝所供养恭敬尊重赞叹。护持建立无所顾恋。当知皆是不可思议诸菩萨等。以本愿力生于此时。护持如来无上正法。与诸有情作大饶益。尔时阿难。声闻菩萨。天龙药叉人非人等一切大众。闻薄伽梵悬记当来法住时分诸苾刍等行业差别。皆增悲叹。信受奉行

佛临涅槃记法住经


佛灭度后棺敛葬送经

    No. 392

佛灭度后棺敛葬送经 (一名比丘师经)

        失译人名今附西晋录

闻如是。一时众祐。游于华氏国。阿难以人定时。白众祐言。众祐灭讫之后。棺敛尊身其礼云何。众祐曰。且自忧身无忧佛也。吾灭度后。当有梵志理家尽礼葬送。阿难言。其礼云何。众祐曰。如飞行皇帝送丧之仪。重曰。愿闻仪则。众祐曰。圣帝崩时以劫波育[疊*毛]千张缠身。香泽灌上令泽下彻。以香[卄/積]身。上下四面使其齐同。放火阇维捡骨香汁洗盛以金瓮。石为[番*瓦]瓳。纵广三尺厚一尺。四边上下各安一枚。金瓮置中。跱刹悬缯具供所应。起土为塔华香供养。佛当踰彼。所以然者。吾自无数劫。以四等弘慈行六度无极。经纬十方拯济群生。功德隆赫。成斯如来无所著正真道最正觉道法御天人师至尊难齐。各以把土。供养塔者。其福无量。末世秽浊。民有颠沛之命。财有五家之分。吾以是故。留舍利并钵。以穰世颠沛之祸。安祐众生。为宗庙像。令民睹则沙门以经导化未闻。令生者永去牢狱之酷。死者免三涂之罪。必获升天。若为佛庙。当令踰彼矣。阿难言。钵当如之。佛言。吾钵者四天大王之所献也。合四以为一。佛所食器。群生慎无以食矣。灭度之后。诸国诤之。民心邪荒。贱命贵淫。背孝尊妖。钵当变化现五色光。飞行升降。开化民心。黎庶睹之。追存佛德。去愚即明。顺 用 正教。皆兴 庙 寺。旌表佛德。转当东游。所历诸国。凶疫消歇。君臣康休。谷帛丰穰。欣怿无患。终远三涂。皆获生天。极东国王。仁而有明。钵当翔彼。王崩之后。其嗣淫荒。废真从邪。民心亦尔。睹钵无肃敬之礼。天龙见之。悲喜迎钵。还海供奉。王亡尊钵。忧忿交胸。布告诸国。购钵千金。连年募之。令出首尾。民贪重赏。遍索不得。时有贱人。其名曰师。伪作比丘。饕餮酒食。妻居育子。当醉提儿诣宫门言。吾知钵处。王闻大喜。请沙门入。曰钵所在乎。对曰。先以金来。王赐金千斤。师曰。唯沙门当盗之耳。即下书考推诸沙门。其毒酷烈。臣民睹之。靡不怨王。王曰。尔为谁沙门乎。答曰。吾师事佛。王曰。佛有何戒耶。师曰。有二百五十戒。王曰。首戒云何。答曰。第一当遵慈仁。普惠恩及群生。视天下群生身命。若己身命。慈济悲愍恕已安彼道喜开化。护彼若身。润逮草木。无虚[木*瓦]绝也。王曰。善哉佛之仁化。怀天裹地。何生不赖焉。二当遵清。无积秽宝。尊荣国土。非有无篡。草芥之属。非惠不取。王曰。善哉斯可谓清白者也。三当遵贞。心无存淫。口无言调。伪声邪色。一不视听。睹彼妇人。以母以姊。以妹以女。宁就燔身无为淫乱。王曰。善哉摸真景净。佛化为首矣。四当慎言无两舌恶骂。妄言绮语。前誉后毁。证入无辜。蛊道鬼妖厌祷咒咀。宁就吞炭。不出毒声也。王曰。善哉佛化。惴惴慓慓。慎言乃如兹乎。五当绝酒夫酒者。令君不仁。臣不忠。亲不义。子不孝。妇人奢淫。厥失三十有六。亡国破家。靡不由兹。宁饮毒而死。不酒乱而生矣。王曰。善哉佛之明化。令吞德怀道。灭于众恶。兴于诸善。清净为身。淡泊为志。经化令仁。而尔教吾令杀。戒云守清净无贪。而尔偷金。戒云无淫。而尔畜妻。戒当尽诚而尔虚谮。沙门云。其盗钵令吾罪无辜。戒无嗜酒。而尔醉来。外诸沙门。有具斯五德为高行者不乎。答曰。其为凶秽。甚于吾矣。王问有司。诸沙门何以为业。对曰。分卫无度。其为众秽。甚于彼师矣。王曰。佛戒有二百五十。仁过仁仪清等太素。贞齐虚空。信若四时。明跨日月。缘得斯类。篡法服。偷应器。伪为沙门。乱正真乎。一戒不奉。而云二百五十。敕有司曰。佛清净庙。贤圣所宗非鸟兽之巢窟。逐出秽浊者。无令止佛庙矣。国之君子。欲兴利庙。惟无快贤处中宣佛神化者。抆泪而止。自斯大道陵迟。神化日衰。佛告阿难。吾虽灭度后。留钵及舍利。若有贤者。肃心奉养。终皆升天阿难言。千岁之末。钵现神德。变化若兹。岂况无上正真道最正觉之灵化乎。佛说经时。天龙鬼神。王臣四辈。靡不哽咽。稽首而去

佛灭度后棺敛葬送经


佛入涅槃密迹金刚力士哀恋经

    No. 394

佛入涅槃密迹金刚力士哀恋经

        失译 人名 今附秦录

牟尼世尊在拘尸那城娑罗林间。北首而卧。初入涅槃时。密迹金刚力士。见佛灭度悲哀懊恼。作如是言。世尊成就最胜无上十力。云何于今乃为羸弊无常气势微劣之所摧败。如来舍我入于寂灭。我从今日无归无依无覆无护。衰恼灾患一旦顿集。忧愁毒箭深入我心。密迹金刚作是语已恋慕世尊愁火转炽。五内抽割心膂磨碎。躄踊闷绝。譬如岩崩颠堕于地。久乃醒悟即起而坐。涕哭哽噎歔欷而言。怪哉怪哉。死魔大恶。无量功德波罗蜜聚。为彼死魔之所灭坏。复作是言。唯愿真济请为我起。我今薄祐无依凭处。云何世尊。舍弃于我独入寂灭。自今已后永离哀颜。世尊寂静身口意业。更不可睹。更不得见。佛婆伽婆入于佛住。如来昔日入于佛住三昧之时。威德光显倍常殊妙。佛面鲜泽过于莲华新开敷时。如日初出照于朝阳。如是胜面更不可见。如来处于大众。出大雷音微妙之声。更不可闻。诚言无二。离过患说。无谄伪说。易解了说。众所爱说。世界之中灭除诸恶。至甘露城无过佛法。咄哉真济永入涅槃。使诸众生无有救护。处于生死大旷野中。又无眼目离于导师谁示其道。如来密云能雨甘露。为无常风之所吹灭。一切众生爱火所烧。而于今者佛入涅槃。谁雨法雨灭其爱火。如来于今灭于有为得无上道。为于众生作大医王。一切世界为烦恼病之所患苦。今入涅槃。谁当矜愍化以正道。疗诸众生结使之疾。如来世尊名为知恩念于恩者。我从处胎以来。随逐如来如影随形。调和奉顺不曾违阙。云何不感我之至心。便见孤弃如背恩者。呜呼怪哉。咄哉大苦。此金刚杵当用护谁。即便掷弃。自今以往当奉侍谁。谁当慈愍训诲于我。更于何时得睹尊颜。护世之王为显甘露。故遣我来拥护于佛。如何今日卒舍我等入于涅槃。我所有命依佛而存。一旦舍我。当依于谁得存此命。咄哉真济矜愍一切。常说妙法教照愚冥。何故今者而卒不言。如来所知一切种智过一切上。恒于众生有缘之者思欲利益。即于今日何处去耶。而于今日便自闭默。更不救济受化之徒。诸魔恶人见佛涅槃皆大欢喜。如来世尊生死海中作大船师。而于今日永舍济度。是诸众生无量劫来顺生死流。唯有如来能以正道。令诸众生皆得返流。如来世尊永断烦恼。为于愚冥众生作大照明。今日涅槃。世间众生增长黑闇。永为无明之所覆蔽。金刚密迹哀呼悲恼。复作是言。世尊诸相。三十二百福大人相悉皆具足。如何灭坏永不可睹。哀哉破坏魔者。哀哉转法轮者。哀哉灭一切外道萤火光者。哀哉能坏有身者。哀哉诸智慧城者。哀哉法灯为无常风之所吹灭。哀哉法月为死罗睺之所吞灭。复作是言。大寂真济愿为我说。即于今者为何处去。至何方所为适何国。为至舍卫及王舍城。迦毗罗卫波罗奈耶。于此诸国为何处住耶。今为在何林。为在迦兰陀竹林。庵婆罗林只陀林。于此诸林为在何处。为在何山。为在自善山。毗堤醯山耆阇崛山。于此诸山为在何山。愿语于我。实在何处。诸八部众天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽。如是等以见于我常随从佛。设当问我佛何处去。我当何辞以对于彼。世尊昔日教化众生。若小疲倦暂寝息时。系心在明为益众生。云何今者舍于一切。永入涅槃更不利益。真济愿为我起。我忧悲火炽然胸中命将不全。愿赐一言。犹如冷水灭我炽火。我今为忧苦毒蛇之所蛆螫。愿赐我法阿伽陀药以除我毒。忧愁毒箭深入我心。愿赐语钳为我拔出。一切众生爱别离苦。如来常为说种种法除其苦恼。云何独不愍我为我灭此众苦。如我今者。哀逆闇塞不能推理。而自释割忧心内病。种种讇语。云何世尊不见慰喻。我之恭顺心不疲怠。乐见慈颜无有厌足。投身于地愿一瞻睹。如何世尊不见哀矜。灭结牛王常挟持我。何不将我入于涅槃。独见孤弃。我失如来。诸苦所切无量无边。又不见谛。何故独见放舍入于涅槃。怪哉怪哉。如来一睡更不起耶。如来已去不复还耶。犹如灯灭更不复明。如宝楼崩更不建立。如宝藏没不可还出。举手大叫发声悲哭。如帝释幢所持绳绝倒地不起。宛转啼哭心肝咽喉唇舌悉皆干燥。荒迷躄地。良久乃稣。爱恋如来功德之身。捉相轮足急抱不放。而作是言。如来之足如优钵罗华。如日初出清净柔软。安立之足千辐轮足。极妙工巧不能画作。转轮圣王虽有是相。相不明了。如来相轮辐毂具足炳然显著。其指纤长。附顺相着不稀不疏。其爪红润犹如赤铜。手足网缦犹如鹅王。肌体丰满无筋脉皮皱。天王人王诸鬼神王及以龙王。咸以天冠顶礼佛足。为化一切诸有缘者。以相轮足遍行世界。而今此足更无有用。我于昔日心常喜乐。一旦涅槃。更不令我生于喜乐。而此无常极为大恶。能坏无量功德不思议色。如来威势能令见者身心欢喜。无量福力持如来身。无常之力实为最大。能使如来至于死处。如来以父母乳哺之力禅定力智慧力神通力。以此诸力不能于无常力中而自拔济。阿难昔日劝请世尊住寿一劫。如来何故不受其请。真济往昔不于三阿僧祇劫中。作百千苦行难舍之事一切能舍。无数劫中历侍诸佛。奉事供养求一切智欲济众生。于少许时所度未几便入涅槃。如来往日为菩萨时。化于众生犹不疲极。而于今者可疲倦耶。浊法众生如新生犊满十二由旬。云何断乳而弃之去。请为我起与浊法犊饱足甜乳。于时帝释数亿诸天。来欲问难。云何而不为其解说。千世界主梵天王合掌请法。今日何不为说法要满其所愿。毗沙门王数千万夜叉而自围绕。提头赖吒乾闼婆众而自围绕。毗留勒叉究槃荼众而自围绕。毗留博叉诸龙之众而自围绕。如是等众皆为饮法甘露而来至此。如来何不以良药救诸疾者。外道诸众毁呰于法。何不速起坏彼邪论。欲界之主处处坏乱何不降伏。如来诸声闻。少于智慧。不勤习诵。厌于广博。何不速起为说略要令知正道。然今阿难是佛所亲。奉侍世尊。未断结使尽于根本。何不教授令尽诸结使呜呼怪哉。如此坚实大福德人。一旦灭坏而此无常。如护财象残害无数。此护财象身大如山。如来往昔犹能调伏如是大象。云何今者反为无常之所调伏。乃至灭尽。如阿婆罗龙能坏摩竭提。兴大云雷电光炽然。降注大雹摧折树木。如来能伏彼大力龙。而于今者反为无常之所乘服。如鸯掘魔暴虐残害。犹能调彼刚强恶人。调彼不调牟尼世尊。今为无常之所摧坏。如旷野恶鬼残杀一切令国空虚。犹能调彼使受持戒。而于今者入无常罥摧灭无余。如优楼频螺迦叶染着于我。没于邪见榛林之中难可拔出。如来犹愍。能现十八种神足变化能令调伏。今为无常之所倾倒。一切众生薄于福祐。大智之海为无常日之所干竭正智须弥为无常金刚杵之所摧碎。佛功德树觉意妙华道果充满。为无常斧之所斫坏。广大智光名称周闻遍于世间。能烧一切有生之薪。为无常水之所浇灭也。盛力无常无有法教。不为智者之所禁制。非是精进瞻勇猛健势力名称柔心调根寂定之所能免。咄哉无常酷暴乃尔。不别好恶有德无德等能摧坏。作是语时大地震动。山顶崩坏。大星陨落。四方火起。日月诸宿无有光色。一切天人皆无欢乐。我今形体不自胜举欲没入地。靦眩黄黑心意错乱。忘失所念唇干舌燥。语言错误声音嘶碎。去死不远命终今必绝。逮佛舍而去。如是等多众种种哀呼。百千种言恋慕于佛。帝释语言。止止已足。汝今可不忆念大仙少语。佛告比丘。诸行无常。无得住者。不可体信。是变易法。一切聚集。归散会灭。高者必堕。合会必离。有生必死。一切诸行犹如河岸临峻之树。亦如画水寻画寻灭。亦如泡沫。如条上露不得久停。如乾闼婆城暂为眼对。人命迅速疾于射箭。速行天下疾于日月。人命速疾过于是天。无常败坏应当解知。若于佛事有不足者不入涅槃。佛事周讫乃入涅槃。以此佛法付嘱人天。以此重事与声闻弟子。向无畏寂灭处去。诸有苦尽更不受生。汝等不应生大忧恼

佛入涅槃密迹金刚力士哀恋经


佛说大般泥洹经

    No. 376 [Nos. 374(1-6), 375(1-18)]

佛说大般泥洹经卷第一

        东晋 平阳 沙门法显 译

    序品第一

如是我闻。一时佛在拘夷城力士生地。熙连河侧坚固林双树间。与八百亿比丘前后围绕。二月十五日临般泥洹。时诸众生各各悦乐。自计清净无疑厌想。忽自觉悟今日如来应供等正觉。哀愍世间覆护世间为世间。归等观众生如视一子。恬淡寂灭大牟尼尊。告诸众生今当灭度。诸有疑难皆应来问。为最后问。如是觉已各怀忧戚。尔时世尊从其面门放种种光青黄赤白颇梨红色。明耀殊特普照三千大千世界乃至十方一切佛土。六趣众生其蒙光者。罪垢诸恼皆悉除灭。咸皆悲恸泪下如雨。更相谓言。怪哉仁者世间虚空。怪哉仁者众生福尽。怪哉仁者苦法增长。如来不久当般泥洹。一何駃哉世间虚空。一何駃哉世间眼灭。我等当共疾往诣佛礼拜供养。劝请世尊不般泥洹。住寿一劫若过一劫。若佛泥洹谁为我等亲善慈导。谁为我等救诸厄难。是故仁等。有所不了当诣如来咨决所疑。尔时大地六种震动。时八百亿比丘皆阿罗汉心得自在。所作已办离诸烦恼。降伏诸根譬如大龙。成就空慧逮得己利。如栴檀林以为眷属。功德具足为佛真子。其名曰尊者迦旃延。尊者薄拘罗。尊者优波难陀等。是诸比丘晨用杨枝澡漱清净。时有妙光来照其身。如日初出照青树叶赤脉悉现。此诸比丘亦复如是。举身支节一切毛孔血流如雨心大苦痛。哀愍安乐诸众生故。欲发大乘方便密教故。教化因缘故。疾 澡 漱讫来诣佛所。稽首礼足绕百千匝。恭敬问讯于一面住。复有二十五亿比丘尼。皆阿罗汉心得自在。所作已办离诸烦恼。降伏诸根譬如大龙。成就空慧逮得己利。其名曰拘邻女须跋陀罗比丘尼。优婆难陀比丘尼。海智比丘尼等。如日初出照青树叶赤脉悉现。此诸比丘尼亦复如是。举身支节一切毛孔血流如雨心大苦痛。哀愍安乐诸众生故。欲发大乘方便密教故。教化因缘故。来诣佛所稽首礼足绕百千匝。恭敬问讯于一面住。复有诸比丘尼。皆是菩萨人中雄猛得十地行。教化因缘故现为女身。游四无量能现为佛种种变化。复有一恒河沙菩萨摩诃萨。人中雄猛一切功德皆已具足。以方便身深乐大乘。 正 向 大乘 饥虚大乘。贪求大乘渴仰大乘。善能随顺一切世间。未度者度未脱者脱。于无数劫修习净戒度脱众生。于无数劫修习净戒安慰众生。于无数劫修习净戒兴隆三宝。于无数劫修习净戒转正法轮。于无数劫修习净戒成大庄严。于无数劫修习净戒行处坚固。如是等无量功德皆悉成就。等观众生如视一子。其名曰海德菩萨。无尽智菩萨等。如日初出照青树叶赤脉悉现。此诸菩萨亦复如是。举身支节一切毛孔血流如雨心大苦痛。愍念安乐诸众生故。欲发大乘方便密教故。教化因缘故。来诣佛所稽首礼足绕百千匝。恭敬问讯于一面住。复有二恒河沙五戒优婆塞。深乐一切诸对治法苦乐常无常。我非我空非空依无依。众生非众生。恒非恒吉非吉。有为无为泥洹非泥洹。深乐如是对治之法。欲闻妙义阐扬大法。于无数劫净修梵行而无毁失。欲行大乘为人广说。修习净戒欲学坚固大乘。欲学随顺世间。欲学度脱世间。欲学兴隆三宝。欲学转法轮。欲学大庄严。如是无量功德具足。等观众生如视一子。其名曰光无垢称王优婆塞。善德优婆塞。如是等二恒河沙优婆塞。于晨朝时为供养如来故。人人各作五千栴檀床帐沉水床帐。众宝床帐天香床帐。郁金香华床帐等。其诸床帐悉以牛头栴檀香薰庄严种种奇妙七宝。校饰金绳罗网以覆其上。青色青光黄色黄光赤色赤光白色白光红色红光。颇梨色颇梨光。如意珠色如意珠光。以如是等杂色庄严。殊胜希有周匝障幔。皆以七宝罗网罗覆其上。周回四面悬众宝幡。种种杂香以涂其上。金镂织成以为垂带。其宝帐内种种异色庄严如上。七宝织成以为茵蓐。柔软香薰以敷其内。一一床帐各载以宝车。其车严好七宝庄严。前后皆有宝幢幡盖。一一幡盖皆以七宝罗网。青黄赤白七宝庄严。及四种华优钵罗钵昙摩拘牟头分陀利。亦以七宝校饰如前。结众杂宝以为华鬘。鲜好白[疊*毛]图画如来本生之像。表现菩萨从初发意至于成佛。中间受身种种苦行无不记列。侠道两边作众伎乐。其诸乐器皆用七宝。其音和雅皆出无常苦空之音。咸言怪哉世间虚空。悲号泣泪声振天地。为供养故各赍名华细末杂香又办种种上味之食。用山涧水然以香薪。令食细软香味具足。又于坚固林内外扫洒布七宝沙。香薰宝衣以覆其上。周回敷置三十二行师子之座。皆以七宝庄严。雕文刻镂五色晃曜。众妙杂香用薰其座。七宝茵蓐以敷其上。众事办已而作是念。一切众生 有所须欲 我悉施与。衣服饮食财物珍宝国城妻子。头目髓脑血肉肌体。贫富贵贱随其所须各令充足。唯除色欲毒药及害生等不净之施。是诸优婆塞发菩萨心而作是念。我等持是床帐宝车众物供具。施佛及僧是为最后供养大施。各作是念。佛及大众受我供已。今日如来当般泥洹。作是念已其心悲乱。譬如日出照青树叶赤脉悉现。诸优婆塞亦复如是。举身毛孔血流如雨。身心毒痛悲泣流泪。又于坚固林侧施大帐幔七宝庄校。高广严好上际虚空。于其帐内立七宝舍馔具毕已。来诣佛所稽首佛足。幢盖供养遍满虚空。烧香散华犹如云雨。咸皆悲慕哀动天地。抚臆号叫泪下如雨。更相谓言。怪哉仁者世间虚空。一何駃哉世间眼灭。头面着地同声请佛。愿佛及僧哀愍我等。与诸大众俱受我请。受我请已当般泥洹。令我等饭佛大众得最后施福。世尊知时默然不受。如是三请佛亦默然。时诸优婆塞一切望绝愁忧苦恼。犹如慈父唯有一子。卒病命终送殡而还愁忧苦恼。诸优婆塞愁忧苦恼亦复如是。作礼而起于一面住。复有三恒河沙优婆夷。皆持五戒功德具足。现为女像化度众生。呵责己身犹如四蛇。八万户虫侵食其体。是身嗅秽贪欲所惑。譬如死尸无一可乐。是身不净九孔常漏。血肉筋骨共相依假以为伪城。手足支节以为却敌。爪齿耳目以为寮孔。幻伪心法以为寮障。放逸调慢以为楼观。恶贼意王居其城内。贪利荡逸驰骋六境。如此贼城诸佛所弃愚夫所乐。贪欲嗔恚愚痴罗刹依止其中。如伊兰丛林无可爱乐聚沫芭蕉无有坚固。电光野马呼声之响。水月幻化如海涛波。駃流立草须臾不住。丘冢丛林秽恶充满。狐狼雕鹫鸟鸱饿狗。诸恶虫辈竞止其中如此秽身安可堪处。若以一毛渧大海水尚可知数。此毒树身四百四病。无量众秽不可称计。如世尊说譬喻。天下草木斩以为筹。大地土石末为微尘犹可知数。此身不净无量杂恶其数过是。是身暴害灭诸善法。是等优婆夷。能舍此身犹如弃唾。习行空行无相无作。深乐大乘常为人说。其名曰耆婆尸利优婆夷。胜鬘优婆夷。毗舍佉优婆夷等。于晨朝时光明照已即觉斯瑞。便各疾办众供养具倍胜于前。来诣佛所头面着地。请佛及僧世尊不受。愁忧苦恼在一面住。复有四恒河沙诸离车童子。在毗舍离城内并外来者。及阎浮提边国诸王大臣。俱乐正法淳修戒行。众德成就。伏诸异学及乱法者。普能惠施无畏之法。为众演说无尽法藏。悉能修习诸佛所说甘露妙法。摧伏众魔外道邪论。自持律行令持戒僧得力安隐。自持律行乐听大乘为人广说。普慈愍伤一切众生德皆如上。其名曰净离垢藏离车童子常快净离车童子。恒水离垢净离车童子等。是诸离车各办八十四亿栴檀床帐。沉水床帐。郁金床帐。柏木床帐。兜楼香木床帐。亦各八十四亿雕文刻镂。七宝庄严五色光耀严饰如前。各办八万四千宝马。八万四千大象王。八万四千四马宝车。悉以神珠明宝绞络庄饰。端严姝妙行如疾风。又办八万四千明月神珠昼夜常明。幢盖幡华大宝帐幔。白叠图像次第如前。其宝华盖广一由旬。彩画细叠以为图像三十二由旬。其幔高显各百由旬。其幡各长一千由旬。七宝庄校严饰如前。其饭香气薰一由旬。敷置床座于坚固林供具悉备。来诣佛所稽首请佛。头面礼讫于一面住。复有阎浮提内大长者五恒河沙。深乐正法淳修戒行众德成就。伏诸异学及乱法者深乐大乘。其名日月光王薝卜华首长者。法首长者。如是等长者子及长者女五恒河沙。于晨朝时承佛威神。办众供具倍复胜前。来诣佛所稽首请佛头面礼足于一面住。复有毗舍离王内外眷属。及阎浮提主大小城邑聚落野人君主。除阿阇世其余诸王。月离垢藏王日离垢王等。六恒河沙各将一百八十万亿眷属。皆悉勇健力如龙象行如疾风。深乐正法淳修戒行。众德成就伏诸异学及乱法者。所作供具转倍胜前。来诣佛所稽首请佛。头面礼足于一面住。复有阎浮提主大小诸王。夫人婇女七恒河沙。除阿阇世王。夫人婇女皆厌患女身。修行空行深乐大乘。广为人说所修功德悉如前 说。诸优婆夷其名曰三界妙夫人念 德 夫人等 。所作供具倍复胜前。于晨朝时来诣佛所稽首请佛。头面礼足于一面住

复有八恒河沙诸天众俱普明天子等。皆乐大乘广为人说。修行净戒渴仰大乘。诸众生类乐大乘者。以大乘法断其渴仰。修行净戒贪乐大乘。坚固大乘觉悟大乘。于大乘法不起嫉慢。伏诸异学及乱法者。护持正法修行净戒。随顺世间。未度者度未脱者脱。欲转法轮欲兴隆三宝永使不绝。欲建大庄严。如是等无量功德皆悉具足。等慈众生犹如一子。是诸天等于晨朝时。光明照已觉斯瑞相。咸作是念。如来不久当般泥洹。来诣佛所见众供具各相谓言。汝等观彼人间供养。庄严殊特与天无异。供养如来为最后供。种种饭食供佛及僧最后大施。而今世尊悉皆不受。诸仁者。我等今日亦当为佛及僧并诸眷属。为最后施成大施度。如来及僧并诸眷属。哀受我等最后供施当般泥洹。佛世难值最后施度倍复甚难。怪哉仁者世间虚空。一何駃哉世间眼灭。是诸天众咸作是念。我等亦当供养如来。即办供具倍胜人间。床帐车乘幢幡华盖图像帐幔。悉以天香天缯天宝庄严校饰供具办已。来诣佛所稽首礼足绕百千匝。恭敬问讯于一面住。复有九恒河沙诸龙王从四方来。其名曰和修吉龙王。难头优钵难陀龙王等。众德具足哀愍世间。于晨朝时光明照已。各作是念。如来不久当般泥洹。办众供具倍胜人天。来诣佛所稽首请佛。绕百千匝于一面住。复有十恒河沙诸鬼神王毗沙门等。一切鬼王。所作供养悉皆如前。来诣佛所稽首请佛。绕百千匝于一面住。复有二十恒河沙伽留罗王。龙怨伽留罗王等。三十恒河沙揵闼婆王。那罗达揵闼婆王等。四十恒河沙紧那罗王。快见紧那罗王等。五十恒河沙摩睺罗伽王。大快见摩睺罗伽王等。六十恒河沙阿修罗王。游空阿修罗王等。七十恒河沙陀那婆王。法水离垢胜王等。八十恒河沙罗刹王。广怖畏罗刹王等。九十恒河沙丛林主王乐香丛林主王等。千恒河沙持咒王。大幻持咒王等。一亿恒河沙欲色众善现欲色等。百亿恒河沙天女众蓝婆天女等。千亿恒河沙负多王宿君坻负多王等。百千亿恒河沙天子四天王等。百千亿恒河沙风神王。一亿恒河沙乐云雨神王。一切世间寂静云雨王。是诸王等于晨朝时光明照已觉斯瑞相。各作是念。如来不久当般泥洹。雨众供具倍胜人天。来诣佛所稽首请佛。绕百千匝于一面住。复有二十恒河沙香象王金色绀眼象王等。是诸象王随其力能于雪山中取众香药草。及诸名华优钵罗钵昙摩拘牟头分陀利华等大如车轮。及山川水陆所生诸华。以用庄严床帐供具。悲鸣号吼声震天地。一何駃哉世间虚空。一何駃哉世间眼灭。来诣佛所头面礼足于一面住。复有三恒河沙师子王大震吼师子王等。皆于众生普施无畏。及诸鸟王迦兰陀鸟迦陵频伽鸟王等。所作供养悉如象王。复有诸牛羊王。诣坚固林出好香乳。一切坑池乳皆流溢。复有诸蜜蜂王皆以香蜜盈满其中。如是等比数如恒河沙。悉诣佛所头面礼足于一面住。复有万恒河沙五通神仙。与四天下一切众仙俱。忍辱仙人等作种种神力。所作供养悉倍胜前。来诣佛所以发布地。稽首佛足于一面住。尔时十六大国比丘比丘尼。唯除尊者大迦叶尊者阿难二众。余者悉集满一由旬悉皆如前。比丘比丘尼众于晨朝时。来诣佛所稽首佛足绕百千匝于一面住。复有万恒河沙诸小山神王大山神王。世界中间诸鬼神王须弥山神王。食诸树叶华果种种生类。皆有神力放大光明。来诣佛所稽首礼足于一面住。复有百千万恒河沙八大河大海大地诸神天子。大小诸王皆有神力。放大光明蔽于日月。于坚固林出甘露水。满熙连河微流清彻。处处皆作七宝阶道。令诸会众饮之无厌。尔时力士生地北面南向。有自然善法重阁讲堂。文饰刻画七宝庄严五色光耀。清泉浴池华果园林亦自化成。譬如忉利天欢喜之园甚可爱乐。其诸天人阿修罗悉睹如来泥洹之相。咸皆悲感愁忧叹息。复有一亿阿僧祇四天王诸天子皆悉来会各相谓言。汝等观此天人阿修罗。为最后供养如来故。作此胜妙殊特供具种种饮食。佛与大众受彼施已当般泥洹。我等亦当办众供具倍胜于彼。皆用天华天香天食。曼陀罗华摩诃曼陀罗华。迦拘罗花摩诃迦拘罗华。曼殊沙花摩诃曼殊沙花。散多那华摩诃散多那华。如是等种种天花及诸天香。以成供具来诣佛所。稽首请佛于一面住。释提桓因与阿僧祇三十三天众所作供养。乃至第六天王与诸眷属所作供养转倍胜前。除四无色及色有无想天。其余诸天亦办供具转倍胜前。尔时娑婆世界主梵天王。与诸梵天子无量眷属。各放身光遍四天下。欲界人天身诸光明皆蔽不现。普雨天衣及天名华供办天食。一一天幢天幡天盖。从坚固林上至梵天。办众具已来诣佛所。稽首请佛于一面住。复有毗摩质多罗阿修罗王。与无量阿修罗眷属俱。放身光明遍四天下。释提桓因及诸梵王身诸光明皆蔽不现。亦办饭食及众供具。其诸宝盖悉皆弥覆小千世界办众供已来诣佛所。稽首请佛于一面住。尔时天魔波旬与无量魔天女众俱。即以神力普开一切诸地狱门。随彼地狱众生有所愿乐皆给济之。又复普告地狱众生言。汝等。当念如来应供等正觉作最后随喜。此是汝等力所堪能修行福利。当令汝等长获安乐。永得解脱地狱楚毒。以如来威神故。令魔波旬心转调伏。与眷属俱皆悉庄严兵仗刀剑弓箭金锤钺斧罥索长钩斗战众具。地狱众生长夜痴冥。远离正法受诸苦痛。城郭门户盛火炽然。兴云大雨令火悉灭。尔时地狱众生离苦获安。离苦获安已一一诸魔与其眷属。办众供具倍胜于前。来诣佛所稽首请佛。唯愿世尊。哀受我供。受我供已。其有善男子善女人。称摩诃衍名者若真若伪。我等皆当为是人等作无畏之护。而说是咒 侘趐 吒吒罗。佗趐鲁楼丽。摩诃鲁楼丽。阿逻。摩逻。多罗。悉波呵是咒能令诸乱心者得深妙定。是咒能令诸恐怖者离诸恐怖。是咒能令为法师者辩才无断。是咒悉能降伏外道。诸有能护正法者。为是咒所护如佩神。我此咒术所说诚谛。其有人能持此咒者。若在旷野凶害毒兽水火难等。若持若说众难悉除如龟藏六。我等今日皆悉以离诸魔谄曲。惟愿世尊哀受我供。愿并印可所说神咒。尔时世尊即告魔言。我不受汝饭食供养。为安隐一切众生故。今当受汝神咒法施。如是三请。世尊亦三默然不受。时魔波旬及魔天女。稽首佛足于一面住。复有大自在天王。与无量大力诸天子俱。放大光明遍照三千大千世界。梵释诸天乃至阿修罗众身诸光明悉蔽不现。办众供具倍胜于前。华盖光明遍照三千大千世界。百亿日月悉如聚墨光明不现

     大般泥洹经 大身菩萨品第二

东方去此无数阿僧祇恒河沙佛土微尘佛刹。有世界名意乐美音。佛号虚空等如来应供等正觉。在世教授告第一声闻菩萨名曰大身。善男子。西方有世界名曰娑婆。佛号释迦牟尼如来应供等正觉。临当灭度。持此国土满钵香饭。香彻三千大千世界。并以我心现彼大众。彼如来受我饭已当般泥洹。又持众宝床帐供具献彼如来。汝等并自请决所疑。是时大身菩萨。稽首佛足右绕讫合掌受教。与无数阿僧祇菩萨摩诃萨俱。来向此娑婆世界。尔时三千大千世界地普大动。时会大众释梵四天王魔王阿修罗。及大力诸天见此地动举身毛竖。各自见身光明不现悉如聚墨。尔时大众一切惊起。文殊师利童子。告诸释梵护世魔王诸天王言。汝等勿怖汝等勿怖。东方去此无数阿僧祇恒河沙国土微尘佛刹。有世界名意乐美音。佛号虚空等如来应供等正觉。告第一声闻菩萨汝行诣娑婆世界。有佛号释迦牟尼如来应供等正觉临当灭度。供饭彼佛及比丘僧。汝等并自请决所疑。即时大身菩萨稽首佛足右绕讫合掌受教。与无央数阿僧祇菩萨摩诃萨俱来诣此娑婆世界。放身光明故令汝等光明悉蔽不现。彼虚空等如来应供等正觉。供养世尊故遣菩萨来。汝等皆当一心随喜。时释梵天王及诸大众即复叹曰。何其怪哉世间虚空。如来不久当般泥洹。一何駃哉世间眼灭。皆悉举声哀号悲哭。时彼大身菩萨摩诃萨。与无量阿僧祇诸菩萨俱从意乐美音佛土。各各遍身放大光明来诣娑婆世界。其大身菩萨举身毛孔光明。化为无量杂种莲华。一一华上各有七百八十万城。高广严好其城七重。城各七宝阎浮檀金以为却敌。其却敌上列植宝树。其树悉生众宝莲果。皆以金绳连绵树间。以七宝网重罗树外。微风吹动作五音声。其音和雅犹如天乐。人民安隐快乐自在。其城外有七宝池周匝围绕。八功德水湛然充满。不冷不热微流清净皆生四种七宝莲华大如车轮。青黄赤白五色光耀。乘七宝船游戏其中。又其城内亦有浴池。四种莲华大如车轮。五色严好其池四边。以黄金白银琉璃颇梨。面各一宝互相映发。玫瑰为底布以金沙。一一浴池各有十八黄金梯陛。种种杂宝校饰庄严梯陛中间皆以阎浮檀金。为芭蕉树列植道侧。天优钵罗钵昙摩拘牟头分陀利华。大如车轮遍覆池上。异类众鸟游戏其中。其浴池上悉有种种天香华树。四方风吹遍散池上。其水香净如天栴檀。其城内外有八万四千大王。一一诸王各有无量夫人婇女五欲自娱。人民舍宅各四由旬。垣墙七重悉皆七宝。亦各自有园观浴池。五欲快乐随意游居无有适主。其地柔软散五色华薰以天香。又复彼处无有声闻缘觉之名淳一大乘。一一华上皆有大王。处师子座宝机承足。众宝帐幔弥覆其上。以大乘法化度众生。其诸众生悉在华上听受大乘。书持诵念如说修行。大身菩萨毛孔光明神通变化。其余菩萨亦复如是。时诸众生无有欲乐。但有忧恼悲泣。随路渐渐行诣拘夷大城各相谓言。汝等观此天人供养殊特之事。诸来菩萨亦办供具。众味饭食鲜洁香美无可为喻。大身菩萨与诸眷属。从身毛孔出宝莲华。所赍饭食供佛及僧。其饭香气普薰三千大千世界。众生闻者一切烦恼皆悉除灭。莲华宝帐幢幡华盖。一切供具无可为喻。从其本国来向此土。乘虚而至犹若高台。一切众生无不悉见。大身菩萨及诸眷属设众供养倍过诸天。唯除如来光明。梵释诸天光蔽不现。彼诸菩萨其身毛孔皆雨莲华。其花香薰普遍三千大千世界。诸闻香者罪垢消除发菩提心。大身菩萨身大无量遍满虚空。自舍如来余无能测。稽首奉献饭食众供于一面住。南方世界诸来菩萨其身毛孔出宝莲华。如阎浮提从莲华上起七宝城倍胜。东方西方世界诸来菩萨。毛孔莲花如四天下。城等众具转倍胜前北方世界诸来菩萨。毛孔莲华如小千世界。城郭浴池亦倍胜前乃至十方世界无量阿僧祇诸来菩萨。皆如大身菩萨身满虚空。毛孔莲花犹如三千大千世界。雨种种花及众供具。自舍如来其身光明悉蔽众会。稽首奉献于一面住。尔时坚固林侧为大吉祥地。周回敷座三十二行。其处狭小而诸菩萨身大无量诸天世人皆悉云集而不迫迮。有座如针锋处者。有座如毛端处者。有座如豪铓处者。有座如微尘处者。随身大小各得安立而不苦患。乃至十方微尘数世界六种大动。神通变化现希有相。各各随力设供如前。时阎浮提唯除尊者大迦叶眷属尊者阿难眷属阿阇世王眷属。其余众生无不来会。尔时虺蛇毒螫诸恶虫类。魔鬼罗刹杂咒蛊道。皆生慈心不相侵害如视一子。唯除一阐提辈。尔时佛威神故。此三千大千世界地皆柔软。无有丘墟沙砾荆棘毒草。众宝庄严犹如西方极乐国土。时会天人阿修罗众。尽见十方微尘数世界。其中所有悉在目前如观镜像。尔时如来从其面门出种种光明耀殊特。诸来会者其身光明皆蔽不现。一切众生稽首劝请。所应作已还从口入。时诸天人阿修罗等。即大恐怖身毛皆竖各相谓言。如来光明遍照十方无量世界。所应作已还从口入更无余事。必是最后泥洹之相。天人奉献皆悉不受何其怪哉。四功德牙一旦废舍。圣慧日光从今永灭。慈悲宝船于斯沉没。呜呼痛哉众生望绝。悲号啼哭血泪如雨。譬如大云普雨世界。时诸大众啼哭流泪。亦复如是

    大般泥洹经长者纯陀品第三

尔时会中有拘夷城长者名曰纯陀。与五百长者子俱威仪庠序。观察众会皆已来集。更整衣服为佛作礼心怀忧戚。如日初出照青树叶赤脉悉现。时彼长者亦复如是。举身血出泪下如雨。绕百千匝合掌白佛。唯愿世尊。与诸大众哀受我等最后供养。当令我及一切众生悉蒙解脱。譬如田家贫子仲春之节耕田下种仰悕天雨。今我如是身口意患烦恼众垢。始蒙少习厌离之想。唯愿世尊。当惠法雨与诸大众哀受我请。枯旱之田得蒙慈泽。尔时世尊一切种智知一切时告淳陀言。如来应供等正觉与诸大众当受汝请最后供养。时诸天人阿修罗。闻如来应供等正觉受长者纯陀最后供养。一切大众内怀欢喜。异口同声叹未曾有。善哉善哉。纯陀长者。德愿满足。甚奇纯陀。生人道中难得之利汝今已得。如优昙钵华世间希有。佛出于世难值于此。信心难得闻法亦难。佛临泥洹最后供养复难于彼。又复纯陀。譬如春月十五日夜。纯净圆满无诸云翳。一切众生莫不瞻仰。汝亦如是。如来应供等正觉。与诸大众受汝最后檀波罗蜜。善哉纯陀。是故说汝如月盛满。一切众生无不瞻仰。奇哉纯陀。为佛真子。虽生人道今皆谓汝为天中天。是故我等当稽首礼。咸共举声。而赞颂曰

  虽生人道中　　天相悉具足
  我及一切众　　今当稽首请
  今若哀许者　　当宣微心愿
  若欲度众生　　唯应速劝请
  今日天中天　　人中调御士
  圆应神通眼　　无量功德相
  为众生哀请　　舍涅槃方便
  天中天住世　　广说甘露法
  久远生死苦　　从是获安隐

尔时纯陀长者欢喜踊跃。犹如有人卒丧父母忧 悲顿 至 。临送墓所忽然还活。瞻奉悲喜倍增敬情。纯陀长者及诸眷属。欢喜踊跃亦复如是。五体投地叉手合掌。以偈颂曰

  快哉我今得大利　　人中妙果悉已获
  快哉我今得大利　　永闭泥犁恶趣门
  快哉我今得大利　　生世得值无上果
  犹如沙中求妙宝　　忽遇金刚大欢喜
  快哉我今得善离　　在在处处畜生惑
  快哉我今得大利　　优昙钵华坚固信
  快哉我今得善离　　饿鬼悭贪饥渴苦
  快哉我今得大利　　难得施度到彼岸
  从今永闭诸恶趣　　阿修罗王究竟离
  快哉我今得大利　　如来出世甚难遇
  忧昙钵华今得值　　亦如芥子投针锋
  快哉我今得善离　　四天大王计常想
  快哉我今得大利　　法王大宝今悉见
  乃至欲天十生处　　谛了分明不染着
  快哉我今得大利　　世雄难遇今奉觐
  犹如芥子投针锋　　值佛甚难复过是
  尽三界源二十五　　针锋为喻亦复然
  快哉我今得大利　　值遇如来愿满足
  摧灭一切诸凶恶　　无量痴冥无知贼
  快哉我今得大利　　生值离垢莲华尊
  快哉我今永得离　　弥沦涛波生死海
  快哉生世值如来　　如海盲龟遇浮木
  快哉我今永得离　　生死大海盲龟惑
  快哉我今得大利　　世未曾有无伦匹
  天人哀请悉不受　　难请之宝我今得
  快哉我今得大利　　天人修罗所尊奉
  快哉今得现法果　　大仙受我最后请
  快哉我今得大利　　与诸天人俱劝请
  舍彼天人上妙馔　　哀愍受我粗涩供
  快哉我今得大利　　天人献供愿不果
  我供粗涩如伊兰　　如来大慈哀愍受
  诸天人民阿修罗　　愁忧号泣稽首请
  如来大悲普慈愍　　等视众生如一子
  假令不受众饭供　　愿哀天人不灭度
  彼诸天人无余求　　唯愿如来永住世
  犹如须弥处大海　　时金刚轮安不动
  山水映发端严好　　如来如是处大会
  法王威光曜四众　　犹如重云举世闇
  日光显出除众冥　　今诸天人亦如是
  久远忧悲痴冥闇　　唯愿如来久住世
  圣慧日光悉除灭　　愿长住世大智尊
  愿长住世大雄士　　令我等心离忧怖
  犹若须弥安不动

尔时世尊告纯陀曰。如是纯陀。佛兴于世甚难得值。犹如海沙一金刚粟。人身难得又复过是。具足信心心亦复甚难。犹如盲龟值浮木孔。得遇如来临般泥洹。最后所供檀波罗蜜复难于彼。如优昙钵华时一现耳。汝今纯陀。莫生忧恼应大欢喜。所以者何。当作是念。今日如来与诸大众受我最后大施供养。以是善利故应欢喜。汝今纯陀。勿请如来长住此世。当观世间皆悉无常。一切众行性亦如是。尔时世尊即为纯陀。而说偈言

  正使久在世　　终归会当灭
  虽生长寿天　　命亦要之尽
  事成皆当败　　有者悉磨灭
  壮为老所坏　　强者病所困
  人生皆有死　　无常安可久
  无色无强力　　亦无有寿命
  妻子及象马　　钱财悉复然
  世间诸亲戚　　眷属皆别离
  三界大恐怖　　乃至恶道苦
  斯等悉归灭　　安可不厌患
  有有生老相　　所谓惭耻法
  计常所侵欺　　而谓为长存
  清凉殊胜法　　远离于恐怖
  亦得离生老　　病死之大患
  乱心愚痴垢　　此等谓皆度
  无量无有余　　妙胜之寂灭
  其义实无常　　亦非荫护法
  但是众苦聚　　虚伪非坚固
  无堪无所忍　　亦非可常保
  斯等如蚕虫　　结网而自缠
  轮回三界中　　无一可乐处
  唯有生老苦　　病死之大患
  知义者能见　　寿命日夜流
  衰减欺诳法　　恐怖无暂欢
  疾病忧悲恼　　诸非义盈满
  欲火轮炽然　　众难竞来集
  智者永不住　　受斯大苦痛
  晓了五欲患　　是非功德利
  离欲无所贪　　明了见真实
  是为解脱观　　舍除诸生者
  呵责害结怨　　究竟弃诸有
  从此疾离一切数　　犹如薪尽盛火灭
  妙色湛然常安隐　　不为衰老所灭磨
  无量疾苦不逼迫　　寿命长存无终极
  无边苦海悉已度　　不随时节劫数迁
  快哉如来超三界　　生死轮回不复惑
  汝莫观我永灭度　　犹如须弥跱大海
  纯陀我今当泥洹　　平等正法永安乐
  诸明智者闻斯义　　谛了分明不忧戚
  莫以生死危脆身　　微浅智慧测量佛
  我身真实处安隐　　唯是天尊能谛了

尔时纯陀白佛言。善哉善哉。世尊。我等凡劣得知如来泥洹不可思议。世尊。我今便得与彼大人诸菩萨众及诸罗汉等无有异。如文殊师利童子及阿罗汉。此等众中若有最初受戒。即受戒曰得在僧数。我今凡劣亦复如是。蒙佛威神得同斯等大贤众数。唯然世尊。愿使如来长存于世不愿泥洹如燋败种。文殊师利语纯陀言。莫作是愿。所以者何。当作是观。有为行法性自如是。如是观者空慧具足。欲求正法当作是觉。纯陀答曰。文殊师利。夫如来者是人中尊为天中天。名为应供岂是行耶。若是行者为生灭法。譬如水泡速起速灭。往来流转犹如车轮。若使如来是行数者。终不得出人天之上。非天中天亦非应供。复次文殊师利。汝岂不闻有天长寿。而今如来不满百岁。云何生死之法。称人天上为天中天名曰应供。文殊师利。譬如有人作聚落主。随其功勋渐渐迁转得为高位。众人所敬财力自在。受福既尽还为贫贱人不齿录。若使如来是行数者。亦复如是。非人中上非天中天。亦非应供转为下劣。所以者何。起灭法故。是故文殊师利。莫作是观。如来应供等正觉是行数也。复次文殊师利。为知而说为不知而说。如何妄想而谓如来是行数耶。若如来是行数者。不名三界自在法王。所以 者何。譬如有王勇猛多力一人当千。时人号名千力士王。以能降伏千力士故。如来应供等正觉。亦复如是。降伏烦恼魔阴魔死魔自在天魔。如是诸魔力士憍慢悉伏。是故如来应供等正觉。得为三界自在法王。若使如来是死法者。无实功德如千力士王也。是故文殊师利。汝莫于如来起行数妄想。复次文殊师利。譬如巨富长者唯生一子。相师占子有短寿相。父母闻之心大愁 戚 。我等薄相居门不吉。生短寿子不复爱重。所以者何。夫天人婆罗门中有短寿者。斯等同辈自不爱敬以短寿故。如是文殊师利。若当如来同世人寿者。亦如世人不为父母之所爱敬。如来应供等正觉是行数者。亦复不为人天阿修罗之所爱敬。现见转变故。所以者何。同一切法退败知见。而为众生说解脱教。如是义者何名正觉。是故文殊师利。莫于如来起行数妄想也。复次文殊师利如贫女人无有居止加复疾病。游行乞丐止他客舍寄生一子。其客舍主驱遣令出。抱儿随道向丰乐国。于路困乏蚊虻毒虫唼食其身。经由恒水抱子而渡。水流漂急不放其子。遂至没溺母子俱死。由是慈心救子功德。身坏命终生净妙天。所以者何。以不惜命救护子故。文殊师利。菩萨如是欲护正 法者。不于如来而造行观。造行观者当知是人盲无慧眼。于世尊所应正观察不可思议。当知如来非有为法。以是现化安乐众生。彼贫女人救护其子。不惜身命故生净妙天。护法菩萨亦复如是。能知如来非有为法。是长存法是久住法。因此护法得现法果速成解脱。复次文殊师利。譬如丈夫远行寄止他舍疲极而卧。大火卒起焚烧此家。惊觉见火烧逼其身欲出火难。衣服烧尽自愧裸身。不出火宅遂至烧死。以惭愧功德故。身坏命终。八十千返为三十三天王。复百千返为梵天王。来生人中常为转轮圣王。不堕恶趣永处安乐因惭愧故如是。文殊师利。当知如来是方便行。应如彼丈夫惭愧而死。宁同外道玩习邪见。不为持戒比丘于无为如来作有为想知而妄语。若于如来作有为想者。当知是人阿鼻地狱常为室宅。是故莫于如来作有为数。能于如来作无为想者。从是得度智慧大海。不为死尸之所迷惑。是为甚深智度成就。以此智果疾逮如来具足相好

尔时文殊师利谓纯陀言。善哉。善男子。应如是知。如来常住无为非变易法。汝善男子。有是智者亦能如佛隐覆有为方便示现。汝今不久当成佛道。如此胜妙奇特功德。唯佛世尊乃能叹说。复次纯陀。应时施及法施。出于一切众施之上应时施者。若比丘比丘尼优婆塞优婆夷。若远行来若在道路。随其力能疾应所须。是檀波罗蜜种子生大果报。纯陀汝今随其力能为佛及僧施最后供。宜知是时。世尊灭度垂至。纯陀答曰。文殊师利。何烦催此垢秽食为。如来宁当待此食耶。如来六年在道树下难行苦行。日食麻米犹自支持。况今须臾岂不能耶。汝谓如来食此食乎。如来法身非秽食身。尔时世尊告文殊师利。纯陀所说真实说也。又语纯陀。汝成大智明解大乘。文殊师利谓纯陀言。汝今便为称可如来为佛所念。纯陀答言。如来。岂偏念耶。一切众生悉平等念。汝莫作此颠倒想说。念可念者是二悉无当作是行。夫爱念者。譬如乳牛虽复饥渴行求水草。若足未足忽念其子便疾还归。诸佛世尊无此苦念。视一切众生皆如一子。是智慧念诸佛境界。又文殊师利。譬如象马宝车迟速不同。如是我等九部之乘。不能等问如来智慧。又文殊师利。譬如金翅鸟王陵虚而飞。经由大海影现水中其身长大。水性之类莫能测量其形大小。如婴儿病不堪大药。文殊师利言。如纯陀所说然。我为诸菩萨故。于甚深功德而立此论。尔时世尊。从其面门复放种种色光。文殊师利童子。见此光明知如来泥洹时至。便告长者纯陀言。汝为如来临般泥洹施最后供。其时已到宜应速设。纯陀。当知如来不以无事而放光明。其义有以。宜速宜速。莫令失时如过采之华。长者纯陀默然而住。佛告纯陀。如来须臾泥洹。汝供养僧今正是时。如是再三。纯陀怅 悢 举声叹曰。何其怪哉世间虚空。如来长逝悲号流泪。而复启请愿哀久住。世尊告曰。纯陀。汝莫啼哭自乱其心。当正思惟修野马观。芭蕉梦幻电光坏器等无有坚实。当知有为为灾患宅。纯陀白佛。如来。不哀住世。世间虚空。我等焉得而不啼哭。佛言。纯陀。今我哀汝及一切众生而般泥洹。诸佛法尔。有为之法性亦复然。汝于一切诸有为行。当思我昔说无常偈苦偈空偈非我之偈。我说此身为灾患偈。如水上泡生灭之偈。莫但忧悲如凡人法。纯陀白佛。如是世尊。诚知如来方便泥洹。我故悲恼不能自持。佛告纯陀。善哉善哉。善男子。应知如来方便泥洹。当知佛经如涉大海。长寿非长寿。起法灭法幻法方便法。 时非时性 非 性 。如是等尽应知。纯陀。汝欲疾度三有海者。可速设供诸天人阿修罗所赍供具。今当得为最后供养。令一切众生从我得不动快乐。汝及余人值良福田。汝于如来等正觉所设檀波罗蜜。不留难者亦当自成如来福田

时纯陀长者欲度一切众生故。低头泣泪犹如雨下。譬如日出照青树叶赤脉悉现。纯陀长者亦复如是。血泪俱下而白佛言。唯然世尊。今当从教。然如来泥洹甚深之义。非我凡细所能测量。亦非声闻缘觉所知。唯佛世尊智慧境界

尔时纯陀与诸眷属。为度一切众生故。稽首佛足右绕毕烧香散华供养世尊。并复供养文殊师利。以供办饭故还归其家

大般泥洹经卷第一大般泥洹经卷第二

        东晋 平阳 沙门法显 译

    哀叹品第四

是时普地六种震动。其中聚落城邑山海。乃至十方皆悉大动。时诸众生各大恐怖。天人阿修罗举声悲叹。稽首礼足供养毕。咸皆同时以偈颂曰

  稽首人中雄　　哀我今孤露
  投身尊足下　　眷仰妙功德
  听我说生死　　种种无量苦
  诸天人闻者　　莫不生厌离
  譬如孤茕子　　困病自婴身
  虽遇良医治　　其疾犹未差
  而医忽中道　　舍之适他方
  我等及一切　　穷苦亦如是
  始蒙方便治　　众邪烦恼见
  世尊大医王　　忽当舍我去
  便如穷病子　　失医无所怙
  呜呼此世间　　从今永虚空
  亦如国荒乱　　复失贤明主
  哀哉诸天人　　皆当罗刹患
  犹如谷贵劫　　民遭饥馑苦
  哀哉诸天人　　永失甘露味
  譬如盛火起　　众生皆烧死
  哀哉诸天人　　恶道永炽然
  哀哉诸天人　　长夜受大苦
  轮转生死流　　如象溺深埿
  哀哉今天人　　血流从身出
  忧悲增苦恼　　恋慕心如是
  世尊犹灭度　　行业难复测
  日月隐重云　　慧光从此灭
  哀哉天人众　　长夜处幽冥
  是故怀忧苦　　非物所能喻
  视身无可乐　　欲舍如弃唾
  不欲常在世　　闻佛泥洹声
  唯愿大智尊　　住世说甘露
  云除日光显　　重冥皆悉灭
  如来慧日光　　永消生死障

尔时世尊告诸比丘。汝等比丘。莫如凡夫诸天人辈愁忧啼哭。当勤精进奉持如来所说实法专念守行。时诸天人阿修罗等。闻佛为诸比丘说法已。愿请望断忍割悲恋。譬如孝子慈母新丧祖送丘墓长诀而还。哀感懊恼强自抑止。于是世尊。而说偈言

  汝等当开意　　诸佛法应尔
  各各还复坐　　谛听我所说
  摄心莫放逸　　守持于净戒
  定诸乱意想　　善自护其心

复次诸比丘。若有疑惑今皆当问。若空不空常无常。归无归依无依。恒无恒众生非众生。实不实谛不谛。泥洹非泥洹。密不密二法不二法。如是等种种法中诸有疑惑今皆应问。当为汝等随顺说之。当为汝等开不死门然后灭度。是故汝今现心所疑各各当问。所以者何。佛兴难值人身难得得信亦难。离八难处及持戒具足此复益难。犹恒沙求金粟。亦如优昙华。复次比丘。百谷药木及诸珍宝皆从地出。 一切众生依得生长 如。来如是出生妙善诸甘露法。众生因此长养法身。是故比丘当问所疑。如来悉为说决定义然后泥洹。安乐一切诸众生故。时诸比丘闻如来决定泥洹已。心怀悲怖身毛皆竖。如日初出照青树叶赤脉悉现。其身如是举体支节血泪交流。稽首佛足右绕毕白佛言。善哉世尊。快说非常苦空之教。如一切众生迹象迹为上。如是世尊。说无常想于诸想中最为第一。精勤修习能离一切欲界贪爱色爱有爱。无明憍慢从此永灭。又复世尊。譬如田夫于秋月时。草实未熟深耕其地。春殖五谷草秽不生。行者如是深念无常想精勤修习。能离一切欲界贪爱色爱有爱。无明憍慢永不复生。夫田家子以秋耕为上。世尊。法中以无常想为第一。又如帝王知命将终。恩赦天下狱囚闭系。悉蒙解脱然后命终。今日世尊亦复如是。临欲灭度说甘露法惠利众生。贪爱牢狱皆悉解脱然后泥洹。如人为恶鬼所持。遭遇咒师便得解脱。如是众生为贪爱罗刹所持。幸蒙如来圣慧大咒。得脱众邪恩爱罗刹。如人疟病遇良医药苦患悉除。我等亦然。无量身病邪见烦恼。得世尊法药皆蒙除愈。如人醉酒不识亲疏尊卑长幼。寻后醒悟心怀惭愧深自克责。我等如是于无边生死中。醉于情欲迷于邪见始蒙醒悟。犹如芦草及伊兰树无有坚实。此身如是我人寿命等无有坚固。佛告比丘。汝等如是修无我想耶。诸比丘答曰。唯然世尊。我等常修无我想。余人亦修无常苦空非我之想。世尊。如人言日月星宿山地转。此非为转但众生眩惑谓之为转。如是人言无常苦空非我。当知此等众生亦是世俗眩惑。我等所修是平等修。佛告比丘。如汝说喻此譬喻中说味说义汝犹未解。我当更说如人言日月山地转。此非为转但眩惑谓之为转。如是众生愚痴颠倒计我计常计乐计净。然彼佛者是我义。法身是常义。泥洹是乐义。假名诸法是净义。汝等比丘。莫眩惑想而言我于一切法。修无常苦空不净想也。比丘白佛言。世尊。我等亦修三种修净佛告比丘。此三种修于我法中亦无实义。间间苦修性升降故。苦乐想颠倒乐苦想颠倒。无常常想颠倒。常无常想颠倒。非我我想颠倒。我非我想颠倒。不净净想颠倒。净不净想颠倒。如是四颠倒想者。不识平等于此所修非为正修。苦不苦修。无常常修。非我我修。不净净修。此四种修是世间乐常我净。离世间亦有四种乐常我净。汝等当知名味者世间法。义者出世间法。时诸比丘白佛名。世尊。我当云何如世尊教。修三想见四颠倒者。唯愿如来住世一劫若过一劫。如世尊教我当修行。若当如来不住世者。我等何能久与毒蛇同其窟宅永违如来。谁当住世任持正法。当随如来入于泥洹。佛告比丘。莫作是语莫作是语。比丘当知。如来正法付大迦叶。大迦叶者当为汝等作归依处。亦普救护一切众生如佛无异。比丘当知。譬如大王典领诸国。若欲游行余国。要立一大臣兼知国事如王在时。我亦如是于此世界寻当安立摩诃迦叶。但汝等比丘。先所修习无常苦空非我想者非真实修。譬如春月诸商人辈至欢会时游戏水边。众中一人有失琉璃堕深水底。时诸商人各各入水为求宝故。或得瓦石沉木谓为是宝。欢喜持出乃知非真。彼琉璃珠故在水中。光色彻照明踰日月。众人见光知是名宝。叹其奇特各欲求取。时有一人巧智方便取得真宝。如是比丘。汝于一切苦空无常不净。作尽想受言我修习。犹如彼人手执非宝而自欺诳。汝等比丘。莫如彼人空自欺诳。当如商人有黠慧者。比丘。当知有我有常有乐有净。汝等所修一切摄受皆是颠倒。如彼不识琉璃宝珠。汝等比丘。修真实法如得宝珠。于不真实法修无常想。诸比丘言。如世尊说一切诸法皆悉无我。当如是修。如是修时我想即灭。我想灭已正向泥洹。此有何义。唯愿世尊哀故更说。佛言。善哉善哉。诸比丘。汝等欲除吾我惑者。应如是问。譬如有王闇钝少智。时有药师亦不明了。欺诳天下受王奉禄。唯知乳药复不善解。而常以此疗治。国人又复不知风痰唌唾病之所宜。而闇钝王谓为上医。时有明医晓八种术。从远方来语旧医言。汝为我师我为弟子当从汝学。旧医言。善哉当教汝不死药法。汝当勤学四十八年。令汝尽知无上医术。便将后医出入王宫。是闇钝王亦相爱乐。彼后医便白王言。大王。应当学诸技艺。王大欢喜便从受学。智慧渐增乃知旧医无智欺诳。驱令出国加敬后医。彼后医知时已至复白王言。欲有所请当随我意。王答言尔。医言。大王。先医乳药毒害危险。不复可服应舍此法。王即从教普下国内。自今已后服乳药者当重罚之。尔时后医以五种药甘酢碱苦辛等五味用疗一切。时王得病请医治之。医观王病应用乳药。便白王言。唯有乳药能令不死。王语医言。汝今狂耶。先言是毒令我驱彼。而今复言应服乳药。后医答言。不也。大王。此言有意。譬如板木有虫食迹似王名字。不善书者谓是真字。其善书者乃知非真。先医如是虽合乳药。不知分别时节所应。当知乳药有能杀人亦不杀人。不杀人者养乳牛时放在旷野无毒草处择水而饮不加杖捶出入以时。构彼乳时泡沫不起。当知此乳救一切病为不。死药王言。大善便服乳药。时国人民闻王服乳皆悉惊怖。来诣王所咸言。此师将非鬼耶。先言杀人今令大王还服乳药。时王即为人民广说乳之升降。王及人民增加恭敬供养后医。奉用其法常服乳药。比丘当知。如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。为大医王出兴于世。为坏外道邪医术故。与众生王渐相习近。知爱乐已。便教令舍外道邪受而语之言。无有吾我众生寿命。似彼虫食为书。诸异道辈受吾我故而言无我。一切众生承如来言展转相教皆说无我。此是如来知时方便济众生故。说一切法其性无我。非如世间所受吾我。故说一切法其性无我。时复说我。如彼良医明乳药法。当知我者是实。我者常住非变易法非磨灭法。我者是德我者自在。如善乳药医。如来亦然为诸众生说真实法。一切四众当如是学。尔时世尊复告比丘。于诸法律若有疑惑当问如来。诸比丘言。唯然世尊。我等已修诸修之上。解知身相皆悉空寂。佛告比丘。汝等莫如一切智说而言。我修一切身相皆悉空寂。复告比丘。汝于法律犹有疑惑应当更问。诸比丘言。世尊。如来应供等正觉平等之义。非我境界岂敢重问。诸佛所说不可思议。诸佛所行不可思议。是故我等及诸众会。皆悉不堪重问如来。世尊。譬如有人年百二十。身婴长疾委在床蓐。有一丈夫无有智慧财富无量。来诣其所就彼床上执病人手而语之言。善男子。汝当取我珍宝库藏。我欲余行远至他国。或经十年或二十年。我后还时悉当归我。时彼病人无有子息又无眷属。病转增笃遂便命终。所寄财物皆悉散失。财主后还欲往求索不知所在。如是世尊告我等言。于诸法律若有所疑今皆当问。若使声闻问如来者。恐此正法不得久住。又复不知何者应问。能令一切众生咸蒙其庆。是故世尊。我等今者不堪重问。如有士夫相师占之。年百二十眷属成就财富无量。复有人来语士夫言。我有财宝今以寄汝。汝当为我出入息利。或经十年或二十年还悉归我。彼时士夫即取财物为其生利。主后来索悉皆还之。如是世尊。尊者阿难诸声闻等。护持如来所说法藏。欲令长存无有是处。所以者何。以声闻乘故。唯诸菩萨摩诃萨迦叶等。应令咨受百千万劫堪任奉持如来法藏。一切众生悉当蒙庆。是故世尊。当令菩萨为众生故请决所疑。非是我等凡品所堪。尔时世尊告诸比丘。善哉善哉。汝等比丘。得无漏法成阿罗汉。故能作此真实之说深解我意。有二因缘当令菩萨任持正法。能使大乘法藏久住。又使一切众生悉蒙其庆

    大般泥洹经长寿品第五

尔时世尊普告大会。诸善男子善女人。于三法中及诸律教有所疑者。今皆应问如是至三。尔时座中有那罗聚落菩萨。姓迦叶氏婆罗门种。承佛威神从坐起。整衣服偏袒右肩。稽首佛足绕百千匝右膝着地。以天香花供养毕白佛言。世尊。欲有所问唯愿世尊慈愍敷演。佛告迦叶菩萨摩诃萨言。如来应供等正觉。恣汝所问当为汝说。迦叶菩萨白佛言。世尊。我所问者皆承如来威神力故。亦因一切众生善根故。今日如来四大贤众以为眷属。诸大师子以为眷属。诸金刚士以为眷属。妙智大海以为眷属。其会菩萨皆悉成就无量功德。如是等众以为眷属。我等凡劣欲有所问。不蒙如来神力加助不能发问。是故我今敢有所问。当知皆是如来神力。即于佛前。以偈问曰

  何因得长寿　　金刚不坏身
  云何受持此　　契经甚深义
  菩萨化众生　　说法有几种
  何等人能堪　　名为真实依
  虽非阿罗汉　　量与罗汉等
  天魔如来说　　云何能分别
  云何知平等　　四圣真谛义
  及四颠倒相　　苦空非我行
  云何见菩萨　　如来难见性
  云何得具足　　晓了半字义
  云何善化现　　如雁鹤舍利
  云何得智慧　　如日月宿王
  云何为菩萨　　愿哀决定说
  如此诸法门　　无量甚深义
  我等所应知　　故能发斯问
  岂敢问如来　　诸佛之境界

佛告迦叶。善哉善哉。善男子。渐阶如来一切种智。乃能问斯甚深经义。一一方面阿僧祇恒沙诸佛。从本已来自于世界坐道树下成等正觉其数无量。本为菩萨得菩提道次第开觉。皆悉因问如来深法藏故。汝等今日亦复如是。能以一切种智境界而问于我。安乐一切众生。迦叶 菩萨 白佛言。世尊。我不堪任请问世尊一切种智境界。譬如蚊蚋不能飞过虚空大海彼岸。亦复不能悉饮海水。我亦如是不堪世尊虚空大海甚深智慧而得无畏。世尊。又如大王髻中明珠。其守藏者增加守护如护其顶。我亦如是今问如来甚深正法。如来广说决其疑网。佛告迦叶。善男子。我今当说长寿之业菩萨摩诃萨行此业者。为等觉因。汝等谛听善思念之。听彼行本广为人说因生等觉。善男子。我亦因行彼业广为人说。故得阿耨多罗三藐三菩提。譬如大王其子犯罪闭在牢狱。为其子故普赦诸囚以救其子。如是菩萨修长寿业。一切众生如一子想。于诸众生大慈大悲大喜大舍。受持净戒不害众生。立一切众生于五戒十善业迹。随其力能济诸地狱饿鬼畜生为断一切恶趣业缘。未脱者脱未度者度。志念坚强成方便智。因此业行 得依果报果。长寿无极 成大妙智无畏自在。菩萨如是永离死法。迦叶菩萨白佛言。如世尊说。菩萨摩诃萨等视众生犹如一子此有何义。若言菩萨摩诃萨 等视众生如一子者无有是处 。所以者何。于佛法中或有犯戒作五逆罪诽谤正法。于是众生皆当修习一子想耶。世尊告曰。如是迦叶。我视一切众生如罗睺罗。迦叶白佛。若当尔者。云何一时月十五日布萨大会众僧清净。有一未受具足戒者。盗入听律。时金刚力士瞻佛神旨。持金刚杵碎令如尘。云何一切等视如子。佛告迦叶。莫作是语。彼童子者。是化作耳。欲明正法犯罪应弃。以肃将来令怀盗心者。及一阐提辈恶心潜伏。如王大臣执犯法者。随罪治之。佛亦如是有坏法人以理惩罚。令犯恶者自见罪报。如来常以自身光明安慰众生不恐不害。虽有众生不蒙光明而至死者。如来于彼不舍大悲。复次迦叶。汝等若能善解如来微密义者。今当更说。譬如迦叶。他方有诸比丘。持戒清净道德淳一威仪具足。彼方如来已般泥洹。诸比丘众无任持者。以彼众僧无大师故。无道之人恼诸比丘。时有国王好乐佛法。害彼恶人或逐出国。以逐彼恶人安立正法故获福无量。所以者何。罚其重过立大法故。又如人家生诸毒树应速翦灭。如是法中犯戒乱法。如害主奴皆应逐出。若不逐出当知是辈去我法远。若逐出者是我弟子。迦叶菩萨白佛言。以是义故。不等众生同一子也。涂割等观此言乖矣。若言如来治坏法人何有此义。佛告迦叶。如王大臣长者居士。生子端正聪明黠慧。举世无双众所爱重。父将其子往诣师门学诸技艺白彼师言。我虽生此子福德端正。未学技艺为我教学必令成就。若不如法勤加杖策。我有四子皆就君学。正使三子由杖而死。余有一子故当苦治。要令成就我犹不恨。佛告迦叶。于意云何。父母及师苦教其子乃至失命。父母及师犯杀罪耶。迦叶白佛。不也世尊。爱念子故欲令成就。虽加杖楚无憎害意。其福无量无有杀罪。如是善男子。如来亦然。其有坏法犯戒之人。等视如子慈愍教诫。欲令成就坏法犯戒。应当苦治无有过也。是故当知。菩萨摩诃萨等视众生如一子想。修习如是平等三昧心不怀害。是为菩萨长寿之业智慧自在。迦叶菩萨白佛言。一切众生如一子想。菩萨摩诃萨修行此想得长寿耶。佛言如是。迦叶菩萨复白佛言。唯愿世尊。勿说此义如戏儿法两种语也。世尊。譬如戏儿于大会中。叹说种种供养父母。自还其家反逆不孝。恼乱二亲不报恩养。世尊亦复如是。言菩萨摩诃萨视一切众生如一子想。缘是功德便得长寿。智慧自在常住不死。而今世尊同人间寿。得无世尊无数劫中。常于一切众生怀刀剑想耶。怪哉世尊。受斯短寿害众生果同其世人百岁寿命。尚非菩萨况复如来。佛告迦叶。莫于如来应供等正觉前发斯粗言。汝善男子。当知如来长寿无量。当知如来是常住法。当知如来非变易法。当知如来非磨灭法。迦叶菩萨白佛言。云何得知如来长寿。佛告迦叶。如阎浮提八大河及诸泉流悉归于海无有尽极。当知大海泉流之器。如来亦然。诸天世人一切寿命。皆归如来寿命大海。以是义故。当知如来其寿无量。又复迦叶。譬如虚空常住不变。如来常住亦复如是。亦如醍醐清凉之药能除热恼。如来应供等正觉常以清凉醍醐法药。广为众生除诸患难。是故如来常住清凉无诸患恼。迦叶菩萨白佛言。世尊。若当如来长寿无量。又欲安乐一切众生者。今日世尊。应当住世一劫若过一劫。以清凉法水普雨众生。唯愿世尊。哀愍住世。佛告迦叶。莫于如来作尽灭想。若比丘比丘尼优婆塞优婆夷。及诸外道尚有五德。能住寿一劫若过一劫。经行虚空坐卧自在。左胁出火右胁出水从身出烟。能令自身大而无极细入无间。有此五德便得如是自在神力。岂况如来成就一切无量功德。而力不能住世一劫若过一劫。是故当知如来常住。非变易法非磨灭法。当知此身非秽食身。于此世界应化之身。如毒药树今当舍之。是故迦叶。当知如来法身常住。非变易法非磨灭法。广为人说。迦叶菩萨白佛言。世尊。世间者出世间者有何等异。佛言。如来常住世人亦言常住。我迦叶种说。先师梵天其神有常周游往来。若如来常住者。世间法离世间法未见其异。佛告迦叶。譬如长者有一乳牛付牧牛者。令其养饲别放旷野无毒草处。不与群牛共系一厩。爱护饲养欲得好酥以给眷属。如是不久其人命终。彼牧牛者寻后复死。时有野人游行泽中得此乳牛。便构其乳以自给活。欲作酪酥不知法用。盛以弊器冷暖不适。竟不成酪亦不得酥。复坏乳味坏乳凝浊谓是酪酥。作酪酥想而取食之。众生愚痴亦复如是。正法淳泽深广妙义。佛既灭度如牛主死。彼诸众生在生死旷泽如彼野人。以世俗智于佛正法淳泽律仪作颠倒想。言有众生我人寿命。此是解脱此是常生。是诸众生邪惑所覆。 不识解脱不识常住 。习诸异见不得出要。远离真谛律仪行处。不知如来是常住法。如愚野人不得牛乳五种时味。自谓食酥而实不得五种味中一种味也。但着世俗梵天造化。言是常是众生是解脱。因求梵天修少梵行。离邪淫故孝养父母故。少得生天自然乐食。如彼野人食其坏乳。善男子。世俗梵行供养父母不知三归。当知此果 非有常也 。供养父母不邪淫等。可得如佛所化无常糠糩世俗法耳。唯有如来常住不灭。是故善男子。当作方便离诸狐疑。勤思如来是常住法。复次善男子。是时野人畜彼乳牛。会遇转轮圣王出兴于世。转轮王法应有乳牛王德力故令彼野人舍牛。余行牛自然往转轮圣王主藏臣所。主宝藏臣知此乳牛必出五时精味之乳。定是圣王福德感应。佛为法王出世之时亦复如是。如彼乳牛世间所受常法音声。迁为如来常法之音。凡俗野人摧伏破散舍牛而去常法乳牛之音。便往如来弟子宝臣前住。众生福力故令常法乳牛出常香乳。是故善男子。当知如来常法非变易法。世间凡愚所不能了。皆因如来常住音声故得知耳。彼诸世间应作是念。夫常法音即是如来常法音也。从此音声当知如来无数无量。如是善男子善女人。若持如来常住二字历劫修习。是等众生不久当成等正觉道如我无异。汝善男子。慎勿放逸常修二字坚固受持。今日如来当般泥洹。此是一切诸佛定法。迦叶菩萨白佛言。世尊。何等为法法有何义。愿闻定法其性云何。佛告迦叶。汝今欲闻法性耶。迦叶白佛。愿闻广说。佛告迦叶。法性者舍身。迦叶白佛。舍身者增疑论。佛告迦叶。莫作是观谓如来舍身更受身也。迦叶白佛。不问受身。佛告迦叶。莫作是说诸法断也。复次迦叶。如非想天彼无色阴。其诸众生。云何住云何死云何现。彼诸心想云何回转。是佛境界汝应当问。亦应当问我更受身。若人问汝彼无想众生形想住处受乐云何。以何答乎。但非声闻缘觉菩萨境界所及。唯是如来境界行处。又善男子。如来身者方之于彼倍复难知。非诸声闻缘觉菩萨境界所及。如来为何处住云何现。如来不可思议方便身。非汝境界。善男子。汝于我所但作是念。如来常住法僧亦然。此三事者非无常法。常住不变清凉真实离诸恼患。若不尔者。彼善男子善女人清净三归悉不成就。应如是修不可思议常住之法。善男子。譬如有此树者必有此影。若无彼树亦无彼影。若不见树而言见影。无有是处。如是既有如来必为一切常作大树。覆护众生为众生依。若使如来是无常者。不名应供为诸天人作最上依。迦叶白佛言。云何世尊。夜闇冥中树影现耶。佛言。有影既有其树云何无影。但非肉眼所能见耳。是故当知。既有如来则为常住。非变易法非磨灭法。如彼树影闇冥之中肉眼不见。佛泥洹已常住不变。肉眼不见亦复如是。而彼妄想于如来所作无常念。若善男子。汝等父母及所尊重。于佛法僧作非常想者。悉于三归皆不清净。汝今当以三法常住而劝教之。令于三法得成菩萨三归之名。迦叶白佛。唯然世尊。我从今日始当以佛法僧三法常住。启悟父母乃至七世。皆令奉持常住之法。奇哉世尊。三法常住我当受学广为人说。若彼不受此真妙教。当知是等无常惑者。然我当日日三时为说令其亲近。佛言。善哉善哉。善男子。护持正法应当如是。亦常修习不害慈心。彼不害果便得菩萨长寿无极智慧自在

     大般泥洹经 金刚身品第六

尔时世尊复告迦叶。善男子。如来身者。是常住身是不坏身是金刚身非秽食身。是则法身当作是观。迦叶菩萨白佛言。世尊。非我凡品所能观也。所以者何。若当如来般泥洹者。便是破坏身尘土身秽食身。若当如来永不泥洹。应当随顺修平等观。佛告迦叶。善男子。莫谓我身与世人同危脆破坏。长夜劫数轮转生死。如来身者是不坏身。非世人身亦非。天身。非秽食身是非身身。亦不生亦不灭。不集起不流转。无边际无足。非智非行本性清净。无所有无所受无来去不住不动不味不触。无识无思无等无上。非趣趣趣永断非断法。非事非实非觉非想。非始造非终成非建立非盈满非方处非舍宅非止息非寂静。广净离诸烦恼。非取非染着非诤离诤。常住非住故不伏不死。非法非非法非田非非田非可尽。非比丘非非比丘。离名字离赞叹。离言说离修习离思愿。非和合非不和合。非量非非量。非到非不到。非通非碍非相离相。相相庄严非持非有离有。能为福田实不可见不可示如如真实。度一切众生而无所度。脱一切众生而无所脱。净一切众生而无所净。覆一切众生而无所覆。教授众生而无有二。无等无等等。无量等虚空等无处等无生等。无所有等无等离等。寂灭非断行不转转究竟。一切摄受断甚深妙。现不二教不舍自性。非成非长非短。非阴非界非入。非有为相非无为处非长养。不高不下。非藏积非非藏积。非地非非地。如是无量不可思议功德为如来身。无有知者无有见者。无有说者无有论者。非世间所摄受。非因非无因。一切妄想取相言泥洹无以为比。如是无量功德成就名如来身。如是迦叶。如来身相者。作声闻辟支佛所知。如是成就如来身者。是为法身非秽食身。云何当有若病若恼若坏如坏器耶。随受化者现老病死。如来法身金刚难坏。迦叶。汝从今日当作是知。如来身者非秽食身。广为人说从妙因生则为法身。为金刚身为淳厚身。当作是知常住法也。迦叶菩萨白佛言。世尊。如来功德具足如是。云何当有若病若死。我从今日当观如来法身常住非变易法。善胜寂灭为人广说。唯然世尊。如来法身金刚不坏。而未能知所因云何。佛告迦叶。护持正法功德为因。迦叶白佛。云何护法。佛告迦叶。其护法者。非为五戒亦非习行贤者律仪。于恶世中不惜身命。执持利器防护法师诸持戒者是为护法。迦叶白佛。比丘与彼持器仗人共俱行止。将无非比丘耶。佛言不也。迦叶菩萨复白佛言。此则剃头居士耳。佛告迦叶。莫作是语。所以者何。若有独处闲居修行头陀九法。乞食少欲静默禅思观身经行。亦为人说施戒修德行业因果。而不能广宣无畏。亦复不能降化诈伪恶人。当知是人不能自度。亦不度彼修持梵行独善而已。若复比丘行头陀法兼得无畏。广宣九部修多罗祇夜授记伽陀因缘如是语本生方广未曾有。以化众生自度度彼。又为人说契经要句。言某经所说不畜奴婢牛马畜生及不应法物。若当畜者非出家法。是人犯制罢道驱出。诸犯戒者闻作是说。群党嗔恚害彼法师。彼虽命终犹能自度亦能度彼。是故迦叶。诸优婆塞若王大臣当护持法。亦当降伏剃头居士。复次迦叶。过去久远阿僧祇劫时。世有佛名难提跋檀如来应供等正觉出兴于世。亦常于此拘夷城住。时此世界广博严净。譬如西方极乐国土。其诸众生皆悉安乐无饥渴想。纯诸菩萨。彼佛在世无量亿劫而般泥洹。遗法住世亦复无量亿劫。如是余四十年佛法未灭。时有比丘名佛度达多。出于世间大众眷属前后围绕。成就无畏而为说法。以九部经教诸比丘言。其契经说。不得畜养奴婢畜生及不应法物。诸犯戒者便起嗔恚。群党相助欲害法师。时彼国王名婆伽达多。闻彼恶人欲害法师。为护法故即执利器。与共苦斗摧灭恶人。王身被疮诣法师所。法师为王说护法功德。王闻法已寻便命终生阿閦佛国。时王眷属共护法者。命终次第皆得往生阿閦佛国。发心随喜者皆成菩提。佛度达多寻复命终。亦生彼国为阿閦佛第一弟子。婆伽达多王为第二弟子。佛告迦叶。时国王者岂异人乎我身是也。时法师者迦叶佛是。迦叶。当知护持正法功德无量。我本以不惜身命护正法故。得此金刚不坏法身。迦叶菩萨白佛言。如世尊说。如来法身真实常住非磨灭法。我意谛信犹如画石。佛告迦叶。是故善男子。若比丘比丘尼优婆塞优婆夷当勤方便护持正法。亦当广说护法果报。又复迦叶。夫为法师持净戒者常应自护无自防具勿轻举动。若优婆塞不受具戒而学大乘。为护法故持器仗者。当依是等以为伴侣。迦叶菩萨复白佛言。世尊。已说与持杖俱为非律仪。佛告迦叶。我般泥洹后浊世之中。因谷贵疾疫。诈形利养众多无数。时有法师持戒持律威仪具足。为彼驱逐若害若杀。当尔之时持戒法师。游诸城邑险难旷野。我听与彼国王大臣野人居士旃陀罗等。不受具戒能护法者以为伴侣。彼诸人等虽不受戒。护法功德果报无量胜受戒者。其法师者奉持戒行清净威仪。深乐大乘为人广说能以香油幡华供具。与诸国王大臣长者。更相献遗。而不毁失沙门法行。是名法师持戒者自身摄持真实之法犹如大海。威仪具足是名持戒。若复持戒不乐快乐。不喜名誉厌恶利养。常为人说少欲知足。如是等比己利损减眷属不悦不名法师。于自徒众起厌惓想。自坏眷属亦名坏僧。僧有三种。犯戒僧。童蒙僧。清净僧。于三种中坏犯戒僧及童蒙僧不坏清净僧。犯戒僧者。愚騃凡夫顺犯戒者。不相捡察为贪浊故而共和合。是名犯戒僧。正使自身能持戒者。亦复名为犯戒数也。如是等僧不应行而行。若能化此诸非法者。名为法师。童蒙僧者。习行无事钝根愚痴。设得利养自供眷属各各修立不共和合。自恣布萨亦复不与犯戒者同。若能化此愚痴非法。是名法师。如法律僧者。如是等僧众魔百千不能沮坏。若菩萨僧性常清净。彼二种僧是师犯戒持律师者。善教化知时知重知轻。不断非律亦不断当。如法律者。云何名为善教化知时。所教化者或是菩萨或是童蒙。若菩萨教者为护法故。亦不观察时非时余无余。若开若制随其所应。聚落冢间自在游止。护法心故无所违犯。唯除伎儿寡归淫女诸童女家。学声闻处所不应行。余一切处护法菩萨。来往周旋终日无过。是名法师知时教化。知重者。若见如来制戒初始所因起事轻慢心犯及四重法不名出家。是名知重。知轻者。若见比丘一一缘起所犯轻戒。心亦不重或自忆念。如如来戒犯事不满。是名知轻。不断有余律者。若畜奴等诸不净物。于律有余不应断。当常不欲与犯戒者诤。是名非律不应断当。虽非戒律余经中说与戒律同者。是亦名律不应断当。随言说者是名守文不解一字。若能解者三世诸佛所说经中心得无畏。如是佛教深广无量能护持者。逮成如来法王不可思议。于是迦叶菩萨白佛言。唯然世尊。如来法王不可思议。如来常住非变易法。我当奉持广为人说。佛言。善哉善哉。迦叶。奉持金刚不坏法身。欲学等观如来身者。当修金刚不坏法观。菩萨摩诃萨如是修者。便得等观无上法身

     大般泥洹经 受持品第七

复次善男子。持此甚深契经功德我今当说。其有众生闻是经者。生生不堕四趣之中。在所生处常近诸佛。迦叶菩萨白佛言。当何名斯经云何奉持。佛告迦叶。是经名为大般泥洹。初语亦善中语亦善后语亦善。善义善味淳一满净。金刚宝藏我今当说。善男子。如阎浮提八大河水皆归大海。其水无尽大般泥洹亦复如是。灭烦恼降众魔。背生死舍离化身。故名泥洹。一切诸佛同此妙法无有尽极。又如医法有微密术者名为大医。一切方药悉入其中。如来所说微密法藏亦复如是。一切九部悉入其中。故名大般泥洹譬如夏月耕田下种常有悕望。既收其实众望都息。行者如是。于一切经修习禅定常有悕望。学此经已速成解脱超三界有。复次善男子。如人重病如服醍醐次服八种甘味之药其药最良。如是众生于佛密教有惑乱病。渐以大乘经而教化之。然后为说大般泥洹八味法药。八种味者。常住法寂灭法不老不死清凉虚通不动快乐。是八种味名大般泥洹。若有菩萨住此大般泥洹者。常能处处示现泥洹。是故名为大般泥洹。若善男子欲于大般泥洹而般泥洹者。当作是学如来常住法僧亦然。其有善男子善女人。行此大般泥洹经者。当于如来作常住学。迦叶菩萨白佛言。世尊。如来法身不可思议。所说妙法不可思议。众僧功德不可思议。此经不可思议。我从今日其诸众生心刚强者。当为彼灭长夜生死无知余冥

大般泥洹经卷第二大般泥洹经卷第三

        东晋 平阳 沙门法显 译

    四法品第八

佛告迦叶。善男子。菩萨摩诃萨成就四法。能为人说大般泥洹经。何等为四。能自专正。能正他人。能随问答。善解因缘。是为四法。自专正者。闻佛切教能随厌怖身毛皆竖。如佛所说宁抱炽燃枯树举身焦烂。不于如来方便密教其心未悟。闻说有常便起诽谤。而言魔教世论歌颂。说无常者而谓真实。宁以舌舐炽燃枯树。不说如来真实无常。若闻他说辄便惊怖。于说法者而起悲念。深信如来法身长存。老病死法所不能坏。当知世尊不可思议。教法亦然。如我所说枯树经等善自执持。是为菩萨能自专正。能正人者。如世尊说法。有一女人乳养婴儿来诣佛所。稽首佛足有所顾念。在于一面思惟而住。尔时世尊知其所念。即以其子为喻而说法言。譬如母人善养其子。初以指爪而含凝苏。令其消已渐复更增。时彼女人心即开解。便白佛言。世尊。大圣知我心念而作是说。我今晨朝多与儿苏将无损寿。佛言。不也。此儿已大堪食无患。女人欢喜而白佛言。奇哉世尊。善说随顺消不消法。为受化者先说无常苦空不净。若当众生信心未固。便为彼说常住法者。坏彼信根。常苏不消。佛言。善哉。善女人。应如是学。初养子法渐与易消柔软之食。年既长大与坚实者能消无患。我亦如是。为诸弟子先说不净无常苦空柔软之食。 道心既增堪受大乘。然后为说此摩诃衍大般泥洹。甜苦辛酢咸淡六味坚实之食。以苦酢味。无常碱味。非我苦味。悦乐。甜味。吾我淡味。常法辛味。以烦恼薪燃幻行火。熟大般泥洹甘露法食。复次善女人。譬如姊妹有诸缘事舍家出行。诣他聚落或久不还。汝有二子。一者纯善。一者弊恶。临欲行时珍宝秘藏不语恶子而付善子。女人白佛。实尔。世尊。佛问女人。何故宝藏不语恶子。女人白佛。彼恶子者。所作非义为放逸行食用无度。是故不语。其善子者。能立门户荣显宗族。是以付之。佛言。应尔。我法亦然。欲入方便般泥洹时。如来宝藏秘密法要悉付弟子。不授犯戒诸邪见者。汝今于我为作灭想为作常想。女人白佛。我于如来作常住想。佛言。姊妹。如汝所说应作是观莫作灭想。当知如来是常住法。非变易法非磨灭法。其有众生于如来所修常住想者。当知是等家家有佛。是名能正他人。能随问答者。犹若有人来问如来。我当云何得大施之名流闻天下而不舍财。佛告族姓子。唯有清素不畜童仆修持梵行。而乐施彼奴婢妻妾。断除肉味而乐施以肉 。避酒不饮而乐劝以酒。常习时食而施以非时。离诸香华严具器物。悉以香花庄严之具而施与之。如是等类随其所施皆悉归已为大施主。若如是者便得大施名闻天下。未曾损己一毫之费。如是比说能随问答。尔时迦叶菩萨白佛言。如世尊说。不食肉者而以肉施。其食肉者得无大过。岂不增长外道邪见。是故应立不食肉法。佛告迦叶。善哉善哉。善男子。善察佛意。护法菩萨法应如是。善男子。我从今日制诸弟子不听食肉。设得余食常当应作食子肉想。云何弟子而听食肉。诸佛所说其食肉者断大慈种。迦叶菩萨白佛言。云何世尊。听食三种净肉。佛告迦叶。此三种肉随事渐制故作是说。迦叶复问何因。佛言。有九种受离十种肉。佛告迦叶。此亦渐制。当知则现不食肉也。迦叶菩萨又白佛言。云何世尊。称叹鱼肉以为美食。佛告迦叶。我不说鱼肉以为美食。我说甘蔗粳米石蜜及诸甘果以为美食。如我称叹种种衣服为庄严具。又叹三种坏色之服。当知鱼肉随顺贪欲腥秽食耳。迦叶菩萨白佛言。若世尊制不食肉者。彼五种乳麻油缯绵珂贝皮革亦不应受。佛言。异想莫作外道尼揵子见。迦叶菩萨白佛言。世尊。今当云何。佛告迦叶。善男子。我从今日制诸弟子。不听食三种净肉。及离九种受十种肉。乃至自死一不得食。所以者何。其食肉者。若行住坐卧一切众生见皆怖畏。闻其杀气如人食兴蕖及蒜。若入众会悉皆憎恶。其食肉者亦复如是。一切众生闻其杀气恐怖畏死。水陆空行有命之类见皆驰走。是故菩萨未曾食肉。为化众生随时现食。其实不食。复次善男子。我般泥洹后久远世时。当有比丘虽为学道而自贡高言。我是须陀洹斯陀含阿那含阿罗汉。于恶世中流离贫乏困苦出家。种种妄解名字比丘。为利养故恭敬白衣。形状憔悴如放牧者。身着袈裟如猎师像。悕望世利如 猫 捕鼠。病瘦疥癞身体不净。而被牟尼贤圣被服。形如饿鬼贫穷寒悴。非真沙门为沙门像。于当来世正法坏时。于我所制法律行处。经典正论皆悉违反。各各自造经论戒律言我戒律食肉清净是佛所说。自造颂论各相违反。皆称沙门释迦弟子。复次善男子。我说教法受生谷米。及食鱼肉自手作食则非清净。习押油业学诸技术。工巧木匠皮革之师。往来国王观星历造医方。学音声论巧世文辞。畜奴婢聚钱财。金银珊瑚珂贝玉石真珠宝物。畜养师子虎豹[狂-王+由]鼠猫狸。居毒药持咒术。作画师造书牒。茂罗业起蛊道。歌舞幻惑捔力。染齿香熏涂身。着花鬘治形体。及余种种非法像类非法器服。我说斯等非清净法。迦叶菩萨白佛言。世尊。若有国土多食肉者。一切乞食皆悉杂肉。诸比丘比丘尼优婆塞优婆夷。云何于中应清净命。佛告迦叶。善男子。若食杂肉。应着水中食与肉别。然后可食非越比尼。迦叶菩萨复白佛言。若食与肉不可分者。此当云何。佛告迦叶。善男子。若常食肉国一切食皆有肉现。我听却肉去汁坏其本味然后可食。若鱼鹿肉等自分可知。食者得罪。我今日说有因缘者制不食肉。无因缘者因说大般泥洹。亦复制令不应食肉。是名能随问答。善解因缘者。若比丘优婆塞问如是义。云何世尊如来应供等正觉。初出世时不为弟子一一制戒。不一一说如是法门。不究竟说波罗提木叉者。其义云何比尼有何义。善男子。听我分别波罗提木叉义。波罗提木叉者。少欲知足成就威仪。不多受畜离诸染着。于一切净命堕者。堕四恶趣泥犁烧煮。彼威仪少欲不受畜一切净命堕。言非堕者。堕阿鼻泥犁中。是名为堕。布萨者。长养二种义。波罗提木叉者。离于邪说比尼者。微细教诫调伏威仪。又不受非法物亦不施人。是名比尼。其中有犯四重法者。有犯十三有余法。有犯三十舍堕法。有犯九十一堕法。有犯四悔过法有犯众学法。有犯二不定法。有犯七灭诤法。有谤毁经教及一阐提辈。有是等罪不向明者发露悔过。一向覆藏如龟藏六。犯戒之罪日夜增长。云何世尊知有是罪而不结戒。令彼众生堕恶趣中。犹如有人将多人众欲至他方示其要路。其中有人迷失正道堕非道行。彼黠慧者追唤令还得本正路。如来教法亦复如是。初说直道。若诸比丘多作诸过。然后为说犯罪果报。为其制戒。如是世尊。示真谛路为众生说十善功德。天中之天正法之王。普哀众生说十善功德。等观众生如视一子。若一众生在地狱中。为度其人免地狱故。在地狱中住寿一劫若过一劫。云何令彼犯戒比丘长堕恶道。譬如织师织成新衣。后破坏已复更补治。譬如转轮圣王初以十善教化人民。众生后时恶行转增。复因自在金轮神宝。往制法律令其调伏。世尊亦复如是。初时未结波罗提木叉戒。后诸比丘犯罪转增。然后以犯戒因缘为根本已而为制戒。其诸众生乐修法者。见彼所起因缘为证信心增长。乃至等观四谛甚深微妙之义。如转轮王金轮自在。诸佛法轮亦复如是。是则无量诸佛教法。是诸佛不可思议。所说教法不可思议。闻此法者不可思议。能信此经亦不可思议。是名善解因缘。是为菩萨摩诃萨成就四法。能为人说般泥洹经。说现因缘及大般泥洹因缘。是大般泥洹经因是为善解因缘。自专正者。说已诚向自己。专向此大般泥洹经。当知是名能自专正。能正他者。知诸比丘意所诚向。而为说此大般泥洹经。言如来长存。当知是为能正他人。随问答者。如我为汝迦叶说。菩萨摩诃萨微妙利智。种种秘要方便密教。非诸声闻缘觉所测。所谓大般泥洹经。当知是名能随问答。随彼众生心想所应。而为说法非为虚妄。譬如有人说虚空多名。为空为虚为无所有为无数。如是等说皆非虚妄如来说法亦复如是。大般泥洹经四种说者。悉有所应非为虚妄。迦叶菩萨白佛言。若当如来长存者。与佛所说契经相违

  譬如烧铁丸　　投之于冷水
  热势渐消灭　　莫知所归处
  如是等解脱　　度诸生死渊
  安快永不动　　莫知其所之

佛告迦叶。汝善男子。莫于此偈而作妄解于如来所起永灭想。非铁丸投水热势渐灭。诸佛如来泥洹永灭。亦复如是。如铁丸投水热势消灭。如来亦然。无量烦恼结患消灭。如铁丸投水火势虽灭铁性犹存。如是如来无量劫数烦恼盛火皆悉消灭。如来金刚其性常在。非变易法非磨灭法。如是等解脱度诸生死渊者。彼无量劫生死烦恼河。如来已度入于泥洹。诸趣永灭处不可知。是故说言

  如是等解脱　　度诸生死渊
  安快永不动　　莫知其所之

迦叶菩萨白佛言。云何世尊。如铁丸投水热势消灭。犹可更使入于火中。如来泥洹其实常住。更为众生入于无量生死盛火。断除一切众生结患。善哉世尊。如来长存为决定说。佛告迦叶。如是如是。善男子。譬如转轮圣王入后宫中婇女娱乐。须臾复游园观浴池快乐自在。宫中不现莫呼永失。诸佛世尊舍阎浮提示现无常。亦复如是莫呼永灭。如彼国王舍于深宫。游戏园林快乐自在。如来亦然。舍于无量烦恼深宫。入总持园七觉华池游观快乐。乘方便智自在现化。无量结患久已消灭。迦叶菩萨白佛言。如世尊说。无量无数劫生死烦恼患。如来悉磨灭已度五欲海。何故如来为菩萨时。在于深宫婇女自娱。为罗睺罗父。是故当知不尽结患度诸欲海。佛告。善男子。莫于如来应供等正觉而作是言。所以名大般泥洹者。能建大义。汝今谛听。广为人说勿生疑怪。菩萨摩诃萨住是大般泥洹者。能以须弥山王入一粟[禾*會]。其诸众生依须弥山住者无所娆害。来去住止不知谁为。其余众生有知见者。知是住大般泥洹菩萨。安置须弥在粟[禾*會]中然后还复。住大般泥洹菩萨摩诃萨境界如是。复次善男子。住大般泥洹菩萨摩诃萨。取此三千大千世界大地置粟[禾*會]中。其中众生无所娆害。各不自知谁持来去谁安在此。其余众生有知见者。知是住大般泥洹菩萨。取此三千大千世界置粟[禾*會]中然后还复。复次善男子。住是大般泥洹菩萨。复取三千大千世界安置己身一毛孔中。于彼众生而无娆害。各不自知谁持来去谁安在此。其余众生有知见者。知是住大般泥洹菩萨。取此三千大千世界置于自身毛孔之中然后还复。复次善男子。住大般泥洹菩萨。住此世界能举十方诸佛国土置于针锋。如以针锋擎持枣叶。徙着他方异佛国土。于诸众生无所娆害。各不自知谁持来去谁安在此。其余众生有知见者。知是住大般泥洹菩萨神力所为。复次善男子。住大般泥洹菩萨持十方国土。置其右掌如陶家轮。掷着他方微尘世界。于诸众生无所娆害。各不自知谁持来去谁安在此。其余众生有知见者。知是住大般泥洹菩萨神力所为。复次善男子。住大般泥洹菩萨者。取十方世界内一尘处。于诸众生无所娆害。各不自知谁持来去谁安在此。其余众生有知见者。知是住大般泥洹菩萨力之所为。如是善男子。住此大般泥洹菩萨摩诃萨。有大神力种种示现。是故名为大般泥洹。住大般泥洹菩萨在所为作。一切众生不能测量。汝今云何能知如来习近五欲为罗睺罗父。复次善男子。我住此大般泥洹能为大事。于此三千大千世界百亿日月百亿阎浮提。种种现化如首楞严三昧所说于三千大千世界阎浮提。以大般泥洹示现泥洹。而无毕竟般泥洹者。复于阎浮提五欲之中现受胎生。其诸父母谓我为子。而我过去无数劫来爱欲永尽无染污身无秽食身。清净法身诸生已断。以方便智随顺世间。于阎浮提生现为童子。北行七步而自称言。我于天人阿修罗为无上尊。父母欢喜举声叹曰。我生童子堕地行七步世未曾有。时诸众生皆言奇特。而我未曾为童子也。无数劫来离婴儿行。清净法身非为骨肉秽食所长。法身示现而为童子随顺世间。南行七步现为一切无上福田。西行七步现究竟断生老病死。于一切众生为最后边。东行七步现为一切众生前导。向于四维行七步者。现断众邪烦恼魔行。自在天子皆悉降伏。当成应供等正觉道。上方蹑虚行七步者。现如虚空无能染者。又向下方行七步者。现灭一切泥犁盛火。兴大法云霔大法雨安乐众生。雨大法雹破诸恶戒。生阎浮提现遗顶发。欲令众生知此童子顶发俱生诸天世人无能执刀临其顶上为剃发者。于无数劫已离顶发现有顶发。随顺世间现入天祠。大力天神释梵护世稽首奉敬归命礼足。于无数劫为天人尊。现入天祠随顺世间。于阎浮提或现穿耳。实无有人敢穿其耳。垂发右旋如师子发。一切人民皆见童子垂师子发。于无数劫已离垂发。现垂右旋师子之发随顺世间。于阎浮提现入书堂。于三界中莫能为师。唯我应为天人作师。是故名为一切种智。于无数劫已曾学书。成阿耨多罗三藐三菩提。现行学书随顺世间。现乘象马宝车畜诸宝藏。身处深宫婇女自娱。领理国事实无染着。久已舍离犹如弃唾。现受五欲领理国事为转轮王王阎浮提。于无数劫已舍王位。能转无上甘露法轮。现转轮王随顺世间。于阎浮提现老病死。弃舍中宫种种欲乐。出家学道众人皆见童子出家。为度人故而现出家随顺世间。现为须陀洹斯陀含阿那含阿罗汉四沙门果。九次正受修四真谛。众生悉见而我疾成无上罗汉。已无数劫究竟罗汉。为度人故示现初成。往诣树下现坐草蓐。降伏众魔成无上道。于无数劫众魔诸恼皆已降伏得甘露法。现出入息大小便利。清净法身无此诸患。现于人法随顺世间。现受饮食为众生故。其实无有饥渴之想。为现饮食随顺世间。于无数劫常得甚深诸波罗蜜。不随时节现居舍宅。其实无有睡眠哕患欠呿频申身诸苦痛。现依舍宅随顺世间。示现坐卧经行瞻视顾眄屈伸俯仰。真实法身无此形类。示现洗浴麻油涂身杨枝澡漱着明目药。斯非清净法身所须。手足柔软如莲华叶。口气香洁如优钵罗。其目清净犹如明月。示现此法随顺世间。现行少欲乞食粗疏着粪扫衣。于无量劫沙门苦行悉已究竟。现处人间为罗睺罗父。净饭王子其母摩耶。眷属成就能厌世乐。出家学道处林树间。现欲之优劣乐之差降。舍王太子瞿昙大姓。现行出家度众生故。非为如来染着五欲为罗睺罗父。现有父母随顺世间。其诸众生谓为世人。其实如来非天非人。复于阎浮提现般泥洹而不毕竟入于泥洹。众生皆谓如来永灭。而今如来法身常住。非变易法非磨灭法。诸佛常法示现泥洹。又为比丘犯四重法众人悉见。其实不为懈怠之行。或复现为一阐提行或现破僧。众人悉见作无间业。其实无有坏僧之心。亦无有僧而可坏者。于阎浮提护持正法。众生悉见护法大士。此则诸佛菩萨常法。于阎浮提现为天魔众生悉见。其实不为众魔之业。于阎浮提现为女像。众生见已悉皆叹曰。奇哉今日女人作佛。其实如来非为女身。称彼所欲各随因缘。现男女像随顺世间。于阎浮提现生四种畜生趣中。众生皆谓真实畜生。其实不为彼畜生行。现入畜生随顺世间。入梵天中现为梵天而作师长。其诸众生事梵天者。方便诱进使入正法不习彼业。现梵天像随顺世间。现入淫舍度诸淫种不兴欲想。心如莲华尘水不污。庄严其身游诸四衢。方便诱化染心众生。入诸妓舍现为女人化以正法入学书堂现为师长化诸童蒙。或入酒会博弈戏处。为教化故不同彼业。往诣冢间度诸鸟兽不取见想。入诸长者授以正法。入大臣中教令正治。入诸王子化令护法。入诸王者化以先王正法治国。现疾疫劫为之设药。令诸病者厌离身苦导以正法。众生谓是真疾疫劫。现谷贵劫饥乏众生施甘露食导以正法。众生谓是真谷贵劫。现刀兵劫众生各各共相伤害。化令和同导以正法。众生谓是真刀兵劫。现为劫烧计常众生示无常相。众生谓是真实劫烧。于一切众生各同其语。音声微妙胜彼彼类。乐音众生因而得度。现为四种地水火风。一一随种染着众生因斯得度。现为药树救疗众生因斯得度。入诸邪道而现出家。各为彼众而作导师。于无数劫已离外道。示现出家导以正法。现为工巧医方咒术。一切众生及诸外道各怀憍慢。故于其中种种现化。降伏众邪憍慢贡高导以正法。众生见已谓为世人。如来常住离世间法。乃至现为下贱仆使随类度人。于阎浮提种种异业无不现化。其实如来不与同事。现为其像随顺世间。北郁单曰。西拘耶尼东弗于建二十五处乃至三千大千世界。于中现化随顺世间。如首楞严三昧广说。如来成就大方便智。一切所为无不现化。是故名曰大般泥洹。菩萨摩诃萨住是功德。悉能随类种种变化自在无畏。不应复疑罗睺罗父。当知如来于无数劫。已离生死爱欲大海。是故如来为常住法。非变易法非磨灭法。迦叶菩萨白佛言若使如来是常住法非磨灭法非变易法者。云何如来称叹泥洹。譬如灯灭。其所至处莫能知者。佛告迦叶。我现此喻非如是说。善男子。譬如器盛酥油燃灯。酥油既尽名为灯灭。其器犹存。如来亦然。酥油烦恼炽燃悉灭。如来灯器常存不灭。若当酥油与器俱尽者。如来泥洹亦当俱尽。灯灭器存。是故如来。不没不生泥洹快乐。复次善男子。我说灯灭喻阿罗汉。非谓泥洹。阿罗汉者得增上果。世间秽食贪欲悉灭究竟欲食。譬如灯灭。阿那含者其义亦然。故我方便说微密教。非说泥洹。迦叶菩萨白佛言。阿那含者有何等义。佛告迦叶。不还受身名阿那含迦叶菩萨白佛言。云何世尊。如来亦有隐秘之法如幻师耶。佛言不也。我所说法譬如秋月盛满之时。离淫怒痴无诸障蔽亦无隐秘。又如长者钱财巨亿。唯有一子情所爱重。将诣师门教学半字。时节未久惧不速成。父自追还昼夜殷勤教学半字。云何善男子。其父教子学半字时。宁能悉知一切记论不。若能悉知一切记论。其父云何教学半字。岂于爱子有所隐覆不教记论耶。迦叶答曰。不也世尊。其子童蒙未能知论故不教学。若当秘吝名为隐覆。虚心劝励随力渐教不名隐覆。佛告迦叶。善哉善哉。善男子。如汝所说。恚恨悭惜而秘吝者名为隐覆。我于一切众生慈心爱念如一子想。以其童蒙未堪深法故不为说。如彼教子初学半字。我亦如是说九部经。十种智力四真谛法。八圣道分甚深记论。方等大乘悉不为说。复次善男子。譬如长者教其爱子。先学半字。半字既正。次第教学甚深记论令子成就。我亦如是。但为弟子说九部经。知其堪受然后为说大乘记论。如来长存非变易法。令诸众生慧眼开广。又善男子。譬如夏时兴云雷电必雨大雨。百谷草木悉蒙润泽。如来今日亦复如是。兴大泥洹微密法云震大法音。必雨甘露法雨安乐众生。迦叶菩萨白佛言。如世尊说无所藏积晓了抟食。如鸟飞空足迹难寻。此有何义。佛告迦叶。积者聚积义。受取增益义。藏者库藏义。藏有所受。故曰藏积。藏积有二种。有为藏积。无为藏积。有为藏积者谓声闻。无为藏积者谓如来。僧有二种。等僧无等僧。等僧者声闻僧。声闻僧者。亦无藏积。而今云何受畜僮仆钱财仓库。麻油盐等尚不藏积。如来岂听畜僮仆等。作是说言如来听者。世世当堕拔舌地狱。声闻等僧无藏积者。能了抟食。不怀抟食贪味之想。斯等至处足迹难寻。速成无上等正觉道。足迹难寻故名如来。若有为僧尚不藏积。况无为僧。无为僧者诸佛如来。诸佛如来岂有隐密。若有隐密便是藏积。其难寻者谓是不动快乐泥洹。无彼虚空日月云雨地水火风生老病死烦恼诸相。常住不变快乐不动。故名泥洹。因得泥洹故名如来大般泥洹。其为大者办大事故。所谓大者有为数名。若有一人寿命无量。名为大人。人能行法为人中大。若复成就八大人念。是名大人。是故大者有为数名。泥洹者离诸疮疣。故名泥洹。譬如有人身被毒箭遭大苦痛。得遇良医为治疮患苦痛悉除。其善男子。得离疮 疣 。复游诸国普为众生疗治疮患。如来应供等正觉亦复如是。阎浮提中一切众生。于无量劫淫怒痴等烦恼毒痛。为说大乘甘露法药疗治疮患。于此众生离 疮 患已。复现余国为诸众生疗治众病。是故名为大般泥洹。真实之义及方便义。皆悉名曰大般泥洹。现入诸趣及入解脱。随彼受化于处处现。此为要义。是故名曰大般泥洹。迦叶菩萨白佛言。云何世尊。为良医法能治一切疮患。差已复现余方治诸病耶。佛言如是。善男子。能疗一切悉令离病。唯除重病不可治者。诸佛世尊亦复如是。除一阐提。诸余一切众病悉治。迦叶复问。解脱者为何等类。佛告迦叶。其解脱者色无色。无色者声闻缘觉解脱。色者如来解脱。解脱虽色不说是色。何以故。如非想非非想行天色无色亦不是色有。问非想非非想天色无色亦不是色。云何住云何乐。此事应说。是佛境界非诸声闻缘觉所知。迦叶菩萨白佛言。唯愿世尊。重说如来大般泥洹解脱之义。佛告迦叶。其解脱者。于一切缚和合悉离。离和合者不生之生。如因父母而生其子是名为生。其解脱者则不如是。犹如醍醐本性清净。不因父母爱欲长养。度众生故示现有生。是故解脱不生之生。又其生者。譬如种谷而生萌牙。其解脱者则不如是。是故说曰解脱不生。其解脱者即是如来。是故如来不生之生非作所作。其实作者。如城郭楼观有人造作。其实解脱则不如是。是故解脱无有作者者其解脱者即是如来。是故当知如来非作。是名无为。其有为者。譬如陶家埏埴作器有作有坏。其实解脱则不如是。亦无有作亦无有坏。是故解脱无作无坏。其解脱者即是如来。当知如来不生不死。是故如来是无为法。故说如来入大泥洹无衰老相。形枯体瘦发白齿落。是为老相。其实解脱则不如是。永离一切老毁变故。名为解脱。其解脱者即是如来。是故如来无衰老相。 故曰 无病。其名病者。有四百四病。其余横疾数不可称。离此诸患。故名解脱。其解脱者即是如来。法身清净无病。是故说曰如来无病。以无病故无死。众生常死无解脱故有尽有死。永离死名故说解脱。其解脱者即是如来。如来成就如是无量上妙功德。言有死者无有是处。金刚法身清净不坏。岂有无常变坏之相。是故不死离诸垢秽。譬如鲜好白叠苏油所污。其实解脱则不如是。犹白莲华清净无垢。如来解脱亦复如是。永离爱欲诸尘垢秽。是故如来名曰无垢。离诸限碍如有主制。谓之限碍。其实解脱无诸限碍。其解脱者即是如来。是故如来无碍清凉。清凉处者。世俗天庙谓为清凉。是则妄说。唯解脱者真实清凉。其解脱者即是如来。是故如来清凉安隐。其安隐者。譬如道路无诸盗贼。谓之安隐。真解脱者则不如是。其性无畏。谓之安隐。其解脱者即是如来。是故如来安隐无畏离诸恐畏。其恐畏者。譬如国王常畏怨敌。真解脱者永无此畏。譬如转轮圣王无诸恐畏。真解脱者亦复如是。其解脱者即是如来。如来法王转无上轮无诸怨敌。是故如来无畏无忧。其忧畏者。譬如国王有谋逆者。不能降伏常怀忧畏。真解脱者无此忧畏。譬如国王降伏怨家无忧快乐。其解脱者即是如来。如来无忧离诸尘秽。其尘秽者譬如春风起诸尘坌。真解脱者离诸尘坌。如转轮王髻中明珠无诸尘垢。其解脱者即是如来。是故如来离诸尘秽离诸虚伪。其虚伪者喻如坏瓶。真解脱者则不如是。犹如金刚无有虚伪。其解脱者即是如来。是故如来无诸虚伪离不自在。不自在者如贫穷人负他财物。财主制持不得自在。真解脱者则不如是。其解脱者即是如来。是故如来自在无碍无诸侵患。诸侵患者如人春时涉热夏时饮酒冬日涉寒。则伤其身自生侵患。真解脱者则不如是无诸侵患。其解脱者即是如来。是故如来无诸侵患。离诸墋浊。譬如虚空无诸墋浊。真解脱者亦复如是无诸墋浊。其解脱者即是如来。是故如来无诸墋浊无诸缠绵。其缠绵者朋友眷属。真解脱者无此缠绵。如转轮王独善无侣。其解脱者即是如来。是故如来独善奇特。如水莲华此非奇特。火生莲华乃为奇特众人爱乐。真解脱者亦复如是众人爱乐。其解脱者即是如来。是故如来希有奇特无能为者。譬如婴儿其齿未出不能令生。真解脱者亦复如是。非时得者。无有是处。如一阐提懈怠懒惰尸卧终日言当成佛。若成佛者。无有是处。假使信法诸优婆塞。欲求解脱度彼岸者。亦无是处。况彼尸卧。所以者何。性非他成故。是故解脱无能为者。其解脱者即是如来。是故如来无能为者。无量无数。譬如大海尚可知量。真解脱者无数无量。其解脱者即是如来。是故如来无量最胜。其最胜者莫能为比。譬如大海无以为比。其解脱者即是如来。是故如来最胜高显。其高显者譬如虚空无有过者。其解脱者即是如来。如来高显众圣中王。譬如师子为诸兽王。真解脱者诸法之王。解脱光明照一切法。其解脱者即是如来。为最为上。譬如诸方以郁单曰为上。解脱最上亦复如是。其解脱者即是如来。是故如来最上无上。譬如诸方郁单曰最为无上。解脱无上亦复如是。其解脱者即是如来。是故如来无上常法。如诸天人死为常法。解脱常法则不如是。其解脱者即是如来。是故如来常住坚固。芭蕉泡沫无有坚固。真解脱者则不如是。其解脱者即是如来。离诸弊漏。夫朽墙者蚊蚋所止。其解脱者则不如是。譬如画墙无能止者。解脱如是一切恶法所不能染。其解脱者即是如来。无有边际。如聚落国土而有边际。真解脱者则不如是。譬如虚空无边快乐。其解脱者即是如来。微妙不现如鸟飞空足迹不现。解脱不现亦复如是。其解脱者即是如来。甚深难测。父母生养恩德甚深无能测者。真解脱者亦复如是。其解脱者即是如来。甚深难见。如诸众生各各自身有如来性微密难见。真解脱者微密难见亦复如是。其解脱者即是如来。无能见者。犹如顶相无能见者。解脱如是非诸声闻缘觉所见。其解脱者即是如来。无有窟宅。其窟宅者所居止处屋舍名称。真解脱者则不如是。譬如虚空。二十五处生死所居永不可得。其解脱者即是如来。无有所取。其名取者。犹如手执阿摩勒果。真解脱者则不如是。犹如幻师所作变化无能取者。其解脱者即是如来。离诸杂秽。其杂秽者。犹如杂色疥癞牛皮以为衣服。真解脱者则不如是。犹如时乳一色一味。真解脱者微妙一相亦复如是。其解脱者即是如来。其性清净。淤泥浊水谓不清净。真解脱者则不如是。如空中雨一味清净。其解脱者即是如来。其性真妙。犹如满月无诸云曀。解脱如是无垢真妙。其解脱者即是如来。真妙恬静。如救头然则不恬静。其解脱者永灭炽燃烦恼灾患。其解脱者即是如来。其性平等其不等者。如二狂夫其性不等。真解脱者则不如是。其性平等犹如母子。其解脱者即是如来。其性寂灭。得最上处无余求想。犹如饥人得香美食饱足意满无余求想真解脱者亦复如是。其解脱者即是如来。其性已断。譬如钩饵钩绳已断。真解脱者亦复如是。其解脱者即是如来。度于彼岸。譬如河流有彼此岸。无量生死名为此岸。真解脱者名为彼岸。其解脱者即是如来。清净渊渟。其渊渟者非诸河水犹如大海。其解脱者亦复如是。其解脱者即是如来。其味淳美。如种居舍子其味转苦。真解脱者则不如是。其解脱者即是如来。离诸放逸。其放逸者耽乐五欲。真解脱者则不如是。其性清净离淫怒痴。其解脱者即是如来。伏诸渴爱。爱有二种。有念爱有法爱。法爱者哀念众生。真解脱者无有念爱离我我所。其解脱者即是如来。其性灭尽。一切生死习气钩锁悉灭。是名解脱。其解脱者即是如来。为世间舍。度一切有为作覆荫。其解脱者即是如来。为世间依犹如国王游诸国邑。真解脱者则不如是。不动快乐是名解脱。其解脱者即是如来。其处常安。譬如旷野险难恐怖。真解脱者则不如是。犹师子王于诸兽类无诸恐怖。其解脱者即是如来。离诸逼迫。犹如有人为恶兽所迫。无诸救护令度厄难。真解脱者则不如是。犹如船师得牢坚船能度大海。其解脱者即是如来。离诸滓浊。譬如从乳出酪。从酪出生苏。从生苏出熟苏。从熟苏出醍醐。唯有醍醐自性清净离诸滓秽。解脱如是。其解脱者即是如来。伏诸高慢。譬如国王高慢自大谓无与等。其解脱者则不如是。离诸高慢无我我所。其解脱者即是如来。灭除无明。譬如乳酪展转相生乃至醍醐。其醍醐者离诸滓秽自性明净。解脱如是。其解脱者即是如来。离欲闲静无有伦匹二法等者。独行独步如空野象。解脱如是。其解脱者即是如来。离诸欺诳解脱我所入如来藏。其诸天人阿修罗身无有坚实。犹如伊兰芦苇芭蕉。无有坚实离如来藏。真解脱者入如来藏。离诸虚伪断一切有。解脱如是。其解脱者即是如来。入佛正法。非正法者如百叶华。真解脱者则不如是。其解脱者即是如来。入于一性种种性者。一切众生性。种种寿者。一切众生寿。真解脱者则不如是。其解脱者即是如来。入于一处。于诸入门无有我所。解脱如是。其解脱者即是如来。是为善法。譬如孝子孝于父母。解脱如是。其解脱者即是如来。出于世间。于一切法出过其上。一切味中真解脱味为最第一。其解脱者即是如来。湛然不动。其名动者如海涌波。真解脱者则不如是。如因陀罗幢四方风吹不能动摇。其解脱者即是如来。升于法堂。世间堂者如王殿堂。真解脱堂则不如是。其解脱者即是如来。光明照曜如炼真金。解脱如是。其解脱者即是如来。止息快乐。譬如国王敌国新伏身心快乐。真解脱者舍诸苦阴泥洹快乐。其解脱者即是如来。无余毕竟离诸结缚生死牢狱。譬如囚徒罪毕出狱。解脱如是。其解脱者即是如来。离诸结毒。无量烦恼毒蛇结患悉已解脱。息一切有离一切苦。得一切乐长息解脱。其解脱者即是如来。离淫怒痴。一切烦恼永已除尽。拔三毒根无余解脱。其解脱者即是如来。离一切有。一切诸有于斯永灭。入于泥洹究竟解脱。其解脱者即是如来。超越诸阴。超越一切诸不善法长处解脱。其解脱者即是如来。离于自在。离诸我所世俗非我。真实无我佛性显现。其解脱者即是如来。其性虚空。其虚空者。所有无所有皆不可得。如尼揵等有无所有。真解脱者则不如是。又其空者如苏蜜瓶。无苏蜜故名为空瓶。其实不空。因无物故。形色犹存当知非空。解脱不空亦复如是。有形有色。故说不空。无量烦恼二十五有生死轮转。世界行处往来永绝。如无苏蜜名为空瓶。灭诸过患。故名为空。如瓶色像。离世间法周旋行处。不动快乐常住不变。然彼瓶色是无常法。真解脱者常住不变。是故名曰不空之空。其解脱者即是如来。离处所著。处所著者。乐为帝释大力梵王觉慧成满。是诸爱着皆悉解脱。其解脱者即是如来。无贪灭尽。一切有求贪欲永尽。脱诸习着是名为灭。其灭尽者即是解脱。其解脱者即是如来。泥洹快乐。其泥洹者。譬如群鹿遇诸猎师危怖殆死。逃走山野值仙人窟。便得苏息安隐快乐。苏息快乐是名泥洹。其泥洹者非为尽灭。于一切有无量生死颠倒烦恼怨家解脱。方便逃避得入正法仙人窟宅。牟尼止处第三归依。苏息快乐无量众生。苏息快乐名为泥洹。非为尽灭。若诸众生得三归依名为泥洹。岂况如来一切种智。永舍此身而非泥洹安隐快乐。入泥洹者。如人迷醉。有人来问为安乐不。彼醉解已答言安乐。如是众生于无数劫迷醉生死二十五有。得正觉时泥洹快乐。安隐常住不动解脱。非为灭尽。其解脱者即是如来。尔时迦叶菩萨白佛言。世尊。不生不起即是解脱。是如来耶。佛告迦叶。如是如是。善男子。不生不起。即是解脱。亦是如来。迦叶菩萨复白佛言。彼虚空性不生不起。亦是如来耶。佛告迦叶。究竟解脱。非如虚空。复次善男子。如加陵毗伽及命命鸟。其声清彻宁同鸱枭。迦叶白佛。不也世尊。其声各异不可为比。有因缘故诸佛如来方便说喻。佛告迦叶。善哉善哉。善解音声甚深之义。是故解脱即是如来。其如来者即是解脱。其解脱者无可为喻。诸天世人阿修罗等一切无能非喻为喻。唯有如来。为教化者能方便说。非喻为喻说解脱喻。所以者何。其解脱者即是如来。其如来者即是解脱。无二无异。所谓非喻为喻者。面如满月。其大白象。犹如雪山。诸佛世尊亦复如是。说诸非喻为解脱喻。化众生故方便说法及说实法。迦叶菩萨白佛言。以何等故。二种说法。佛告迦叶。善男子。譬如有人于如来所起嗔恚心。便以刀剑加害如来。然其如来无有痛想。云何善男子。彼人当成无间罪不。迦叶白佛。不也世尊。所以者何。于长养身不伤坏者无无间罪。如来无有长养之身。名自在法身。云何伤害。以彼发心恶方便故得无间罪。是名方便法性真实

佛言。善哉善哉。善男子。我所说法亦复如是。复次善男子。如有恶人欲害其母。其母觉已远离本处。其人不知来诣本处。加其刀杖谓为已死。其实不死云何善男子。此人宁得无间罪不。迦叶白佛言。不也世尊。若杀事满足名无间罪。而今其母阴界诸入无所伤损非无间罪。应得相似无间罪报亦名无间。 是名方便法 之 真实。迦叶菩萨白佛言。善哉善哉。世尊。善说方便应以不应

佛告迦叶。有因缘故 宣 说解脱。有因缘故广说诸喻。如是无量功德成就。名为泥洹。亦名如来。是则趣彼大般泥洹。今日如来当入泥洹。以是义故。名大般泥洹。迦叶菩萨白佛言。世尊。是为如来不趣灭尽。当知如来其寿无尽

佛告迦叶。善哉善哉。善男子。护持正法应当如是灭诸狐疑学决定智。善男子。是为菩萨摩诃萨成就四法善说方等般泥洹经

大般泥洹经卷第三大般泥洹经卷第四

        东晋 平阳 沙门法显 译

    四依品第九

佛复告迦叶。有四种人。于此大般泥洹经。能趣正法护持正法能为四依多所度脱多所饶益出于世间。何等为四。一者凡夫未离烦恼出于世间。多所度脱多所饶益。二者得须陀洹斯陀含果。三者得阿那含。四者得阿罗汉。是四种人为真实依。多所度脱多所饶益。彼凡夫人者。自持戒德威仪具足。为护法城于如来所听受正法。诵持义味广为人说能自少欲。复为人说大人八念。化诸犯戒悉令悔过。善知众生种种语言。习行菩萨护法功德。是名第一凡夫菩萨。此诸凡夫未为如来之所记别为菩萨位。彼须陀洹斯陀含者。已得正法离诸疑惑。不为人说非法经书离佛契经世间歌颂文饰记论。畜养奴婢非法等物。是名须陀洹菩萨。虽未得第二第三菩萨住地。已为诸佛面前授记。阿那含者。已得正法离诸狐疑。不为人说非法典籍离佛契经世间歌颂文饰记论。受畜奴婢非法等物。未起诸结能即觉知。过去诸结永不复缚。有所说法不断佛性。德行清净身无外病。四大毒蛇依起诸病所不能中。善说非我度我见者。离世间我而行方便随顺世间。常大乘化不说余道。身中无有八万户虫无量灾患。心离爱欲无恶梦想。离一切有生死恐怖。行如是者。是为第三阿那含人。不复还有名阿那含。习诸德本久远过恶所不能染。名阿那含。是名阿那含菩萨发心受决。发心受决者。其人不久当成佛道。阿罗汉者。烦恼已尽离诸重担。所作已作具足十地。已得记别甚深法忍。一切色像悉能化现。于诸方面随意所欲。为如来应供等正觉。如是功德皆悉具足。名阿罗汉。是为四种人于此大般泥洹经多所度脱多所饶益出于世间。为天人师。如诸如来。是四种人为真实依。迦叶菩萨白佛言。世尊。是四种人为真实依不可信也。所以者何。如世尊为长者瞿师罗说。若天魔梵现身为佛。三十二相八十种好。圆光一寻现眉间相。来诣汝者。汝当觉知令彼降伏。我今听汝伏彼弊魔。所以然者。非阿罗汉而自称罗汉故。若使弊魔坐卧空中。左胁出火右胁出水。或举身 烔 然而出烟云种种变化。又复能说九部契经犹不可信。是故汝当伏彼弊魔莫生疑惑。譬如有人于夜冥中贼狗入舍。其人觉知贼狗入舍。便即骂言贼狗出去。莫令我今须臾杀汝。于是贼狗便疾走出不敢复还。弊魔波旬亦复如是。变化来者。汝当以我五系之法而系缚之。被五系已弊魔波旬驰走恐怖。譬如贼狗。如是佛为瞿师罗长者说。汝今若能降弊魔者渐近泥洹。以何等故。世尊。今日说四种人为真实依。是故我今不生信心。佛告迦叶。如是善男子。我说是法皆因声闻诸肉眼辈说应降伏。非为受行摩诃衍者。诸声闻中虽有天眼。我说是等为肉眼数。正使肉眼信摩诃衍者。我说是等为佛眼数。所以者何。是人能持摩诃衍经为佛乘故。复次善男子。犹如大将善知兵法。教怯劣者学其武术语其人言汝。应如是执持刀剑斗战之具。当正其心如火炽然慎莫反顾。及至临阵各执器仗攘臂大呼。犹如猛火贼兵必退。世雄导师为三界将。教诸声闻降伏众魔亦复如是。复次善男子。譬如有人种性勇猛。承习战法无有怯劣。于诸战士最为先首。如是善男子。习学大乘闻摩诃衍甚深契经微密之教不生恐怖。当知是人已曾供养无量诸佛。受学大乘信根坚固。亿百千魔种种现化终无恐怖。亦不于彼起豪发想。而彼魔众见有人学摩诃衍者。则生恐怖如怯劣夫。譬如毒蛇见诸咒药则生恐怖。天魔波旬亦复如是。亿百千魔得闻如是摩诃衍经音声香气光明所照离诸憍慢贡高自大。复次善男子。犹如有人若见恶龙毒蛇师子虎豹豺狼皆悉恐怖。或闻其声亦生恐怖。或复有人能伏恶兽如彼丈夫。见彼恶兽生恐怖者。当知一切声闻缘觉亦复如是。若见诸魔便生恐畏。则为诸魔之所得便。如彼丈夫能伏恶兽。当知是学摩诃衍者亦复如是。能伏众魔。既降伏已而为说法。如彼毒兽。魔波旬辈心已调伏便作是言。我从今日于佛正法生信乐心不复娆乱。当知声闻故有烦恼习气恐怖。摩诃衍者恐怖永断。摩诃衍者大精进力。是故我说诸声闻辈应当降伏莫生恐怖。如是善男子。此摩诃衍大般泥洹经甚为希有。若闻是经如来长存。能信受者奇哉希有。如优昙钵花难得值遇。此大乘经亦复如是。奇哉希有。我泥洹已遇此大乘经亦复如是。奇哉希有我泥洹已。诸众生等闻此经者。亦甚希有。何其怪哉。善男子。当来之世。当有众生谤斯经者。迦叶菩萨白佛言。世尊。久如当有诸众生等谤斯经者。为何等人于当来世护持此法。佛告迦叶。我灭度后四十年中此法流布。然后便没。善男子。譬如世间甘蔗粳米酥油乳酪以为饮食。有诸众生服食此食而更生病。反食粗涩草木果实。如彼粳粮酥油美食等。摩诃衍经不欲听闻。反食粗涩草木果实。诸声闻乘永舍如是大般泥洹经法美食不欲听闻

复次善男子譬如有王居深山中。无有粳粮酥油等食。其诸人民有诸美食皆送奉王。自食粗涩草木果实。其有诸人亲近王者。承王力故。初未曾见斯等食比而得食之。如是善男子。彼四种人于佛法中为勇猛将。彼诸菩萨摩诃萨中。若有一人出兴于世在所至处。以大般泥洹摩诃衍经教化众生。便自书持。若教人书。书其经卷施诸众生。或有众生于彼菩萨摩诃萨边。闻般泥洹大乘法食。皆是菩萨光明神力故。使得闻此未曾有法文字句义乃至一字。如彼众生蒙王力故得诸美食。是故善男子。大般泥洹摩诃衍经在所至处。当知此地悉为金刚。其有众生闻此法者。书持诵说乃至一字。当知举身亦是金刚。其诸众生薄德少福。而此大乘摩诃衍经。于自国土正法流布而不听受。如彼众生自国土出种种上味而不得食。哀哉众生。闻真实义而不听受。迦叶菩萨复白佛言。世尊。如来灭后四十年中此法兴世。然后便没其后久如复当流布。佛告迦叶。善男子。我后正法欲没之余八十年在。此大乘经当复流布于阎浮提。经四十年此经复没。迦叶菩萨复白佛言。如世尊说。此大般泥洹经法欲灭时当复兴世。当尔之时持戒者少犯戒者多。正法欲灭正趣损减。何等人能听受此法。能持能读能诵能供养能解说能自书能教人书。唯愿世尊分别解说。令一切众生因此得度。有诸菩萨乐学深法。闻世尊说当随其教。佛告迦叶。善哉善哉。善男子。若有众生于熙连河沙等数诸如来所发菩提心。是等众生能于正法欲没之时起菩萨心。虽未决定于无上道。能不诽谤此方等经。一恒河沙诸如来所发菩提心。能于正法欲灭之时。于此方等不起诽谤得信乐心。而未能为众生广说。二恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤身自受学。亦复未能为人广说。三恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤。能受能说能书。而未能解 义。四恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤。能受能说解深法义十六分之一。五恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤 能受 能说能书能持。解深法义八分之一。六恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤。能受能说能书能持。解深法义四分之一。七恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤。能受能说能书教人书能持。解深法义二分之一。八恒河沙诸如来所发菩提心。能于正法欲灭之时。于方等经不起诽谤。能受 能书教人书。能持能读诵说能转。 能善隐密。亦能守护。亦能显示。哀愍世间。普令恭敬供养经卷。转教他人令其供养。智慧满足解深要义。善知如来是常住法。非变易法非磨灭法。安隐快乐善解众生各各自分有如来性。普为开发。是诸菩萨历事过去无量诸佛。故能护持如来正法。若复今日发菩提心者。彼于来世亦当堪能护持正法。此等及余诸众生辈。汝善男子。当作是观。于今现在及未来世。其有乐法发菩提心。当知是人为护法者。又善男子。有诸外道。为利养故。闻佛泥洹。呼谓长死而不忧戚反更欢喜。有当来世假被袈裟。于我法中出家学道懒惰懈怠。诽谤斯等方等契经。当知此等皆是今日诸异道辈。如是无量功德成就。信此方等大般泥洹乐深法者。正使是善男子。过去曾作无量诸罪种种恶业。是诸罪报头痛则除。或被轻易。或形状丑陋。衣服不足饮食粗疏。求财不利。生贫贱家及邪见家。或遭王难及余种种人间苦报。现世轻受。斯由护法功德力故。善男子。譬如霜雪日未出时凝积不减。日光既出皆悉消尽。如是众生造无量恶。此大般泥洹经日光未出。无量恶报凝积不减。此大般泥洹日光出已。无量恶报皆悉消灭。复次善男子。譬如有人出家学道。虽不持戒得与如来大众共俱。在在处处假被袈裟受人供养。名字得入如来僧数。如是善男子。若有菩萨摩诃萨十地成满。及诸外道能信受此摩诃衍经一言历耳。斯等皆入如来菩萨大众之数。正使利养为名誉故。读诵此经但不诽谤。如是等辈。皆悉当成如来应供等正觉道。是故我说彼四种人为真四依。彼四人中但使一人能自决定。不以世俗外道记论名如来说。是故名为真实四依。当加供养受学护法。云何供养。若有此人于摩诃衍经能受持者。应随是人尽其形寿受学护法。从其学已增加供养。是故我说此偈

  若知正法者　　不问其长幼
  尽心加供养　　如人事火法
  若人知法者　　不问其长幼
  尽心恭敬礼　　如天奉帝释

迦叶菩萨白佛言。世尊。如佛所说。于诸师长应加恭敬礼事供养。假使长老从少者学。亦应恭敬为作礼不。若复长老虽知经法不持禁戒。年少弟子能持戒行。当敬礼不。又复白衣善知经法。出家之人从其受学。恭敬承事法应云何。佛告迦叶其出家人于白衣所不应礼拜。非福田故。其出家人凡是长老一切福田。应当敬礼。若犯戒者是所不应。所以者何。长养草秽害谷苗故。迦叶菩萨复白佛言。如世尊说。尽心恭敬礼。如天奉帝释。如是二偈与义相违。若当一切礼敬长老者。诸持戒比丘多有犯罪。云何世尊。而说是偈。又复如来于此契经说犯戒者应当降伏。佛告迦叶。我为当来菩萨故说。至心恭敬礼。如天奉帝释。此二偈说为菩萨故非为声闻。善男子。我般泥洹后。如来正法欲灭之时。持戒众减犯戒众增。其诸清净得解脱者皆悉潜隐。诸出家者受非法财畜养奴婢。当尔之时四种人中。若有一人出兴于世信家非家出家学道。亦现同彼受非法财畜养奴婢。然是人者自能分别是法非法是律非律。悉知他人不持戒行。亦知自己所犯轻重。能知如来所应行处。解知时节方土法用。诵读如来九部经典时。有诵习九部经典犯戒违律。是人虽知彼犯重罪。为护法故方便默然不说其过。而自谦卑从彼受学。于护法心而无所坏。当知是人为护法故出现于世。善男子。譬如有国其王命终。王子幼弱未能治国。有一野人旃陀罗种。以强力故为彼国王。时诸长者婆罗门等而作是念。今旃陀罗主领此国。我等何缘往返承顺。便舍逃走外奔他国。彼旃陀罗王遣人追逐断其径路。旃陀罗王击鼓宣令。告诸长者婆罗门等。汝等莫去。我当与汝分国半治。国中人民有不走者。王复语言。诸婆罗门。汝等各各转相告语言。却后七日婆罗门等及诸士人。为旃陀罗王施设大会。当共相与往诣王所。与彼国王及其亲族旃陀罗辈饮食宿止。若有一人不从教者我当苦治。又复语言。我家中有三十三天甘露之药。其服食者能令不死。并有方论当持相与。尔时有一萦发梵志。专修净行。闻王教已来诣王所。头面礼足而白王言。大王。当知能行不忍天下大恶则我是也。王当与我官爵奉禄。我能唱令。王即听许。时彼梵志。即受王命唱令国内。是时国中诸婆罗门。皆悉嗔恚呵责骂之。然其梵志犹与彼王共知国事。至于后时。大臣梵志便白王言。我与大王共同国事至于今日。犹未体信而不见教学一术法。王告梵志。我当徐徐教汝术法。今我家有先王之余甘露味药。当共汝食。即便以此甘露味药。并其方术与彼梵志。梵志大臣得此甘露及方术已。为彼王合随食之药。王服彼药即便命终。时梵志大臣即立先王太子。还绍王位护持先王正法治化。如是梵志大臣。非舍婆罗门法习旃陀罗法。故是梵志修行菩萨拯济之业。国土人民叹言。善哉。此婆罗门护持王法。是时菩萨持正法故。为婆罗门作诸方便。立彼王子以为国王。宫中内外及诸大臣皆受正法。旃陀罗王妻子眷属。皆与毒药令其迷闷。然后驱出。菩萨摩诃萨亦复如是。现犯戒相畜养奴婢受非法财。诣彼犯戒恶比丘所。承事受学书其经卷。书经卷已转来教授持戒者故。与彼恶人同其止宿。周旋饮食自手作食人不授食。护正法故便作方便。以诸八种非法之事而降伏之令其迷闷。不复与彼同其自恣布萨和合。降伏一切诸犯戒者。与诸清净和合之众布萨自恣。以摩诃衍方等术法。广为人说安隐济度无量众生。是为菩萨护持正法。我为是等而说斯偈。若有比丘闻我所说无护法心。而欲方便效彼菩萨。起诸过者佛所不听。自言菩萨而实宽纵作过恶者。我说是等为懈怠辈。我此方便微密之教。为护法菩萨故说此偈

  若知正法者　　不问其长幼
  尽心加供养　　如人事火法
  若人知法者　　不问其长幼
  尽心恭敬礼　　如天奉帝释

迦叶菩萨白佛言。世尊。如是菩萨慢纵懈怠。于具足戒得清净不。佛告迦叶。善男子。彼具足戒若忏悔者当言清净。善男子譬如坡塘破坏其水流出。所以者何。不勤修故。然善男子。坡塘破坏更修治者。其水还复。彼懈怠者亦复如是。于具足戒布萨自恣所破坏处戒水流出。所以者何。精进损减懈怠增故。然是比丘戒行损减应更修治。从彼护法诸菩萨所。改励忏悔令得清净。迦叶菩萨白佛言。犹如世尊阿摩勒果喻经所说。持戒犯戒其相难知。云何分别。佛告迦叶。善男子。持戒犯戒欲知其相。依大般泥洹经能善分别。善男子。譬如田夫种植五谷。除粗草秽名为净田。故有[禾*秀]稗似善谷苗。至其成实草谷各异。后后方知真伪有别。护法菩萨亦复如是修田之法。先除八种粗恶罪行。除粗过已名为肉眼清净众僧。良福田数乃至圣果。肉眼之外名清净僧。但除八种毒蛇大过。名为众僧良福田数。虽未都净已为天人之所供养为良福田。况复终成贤圣妙果清净福田。出彼肉眼所见之表。复次善男子。譬如国中有二果树。一名迦留。二名沾牟。迦留树者是苦果树。沾牟树者是甜果树。华叶果实状类相似。有人不识杂取其果。诣市卖之食者多死。时有智人疑是毒果便往问之。汝等何处取是果来。答言某方。便语彼人此必杂毒。故多杀人宜速弃之。如是善男子。懈怠之僧成就八恶。时有持戒在其中者。如彼甜果在毒树林。护法菩萨教令弃舍。不令信心诸弟子等。礼拜供养恭敬亲近。断慧命根堕地狱中。是故信心优婆塞等。当善分别莫见形服便相习近。当悉问之彼为成就八种法不。自恣布萨为和合不。若彼已离八种恶法。如是等僧世尊亦受哀众生故。于只桓林与共和合如真金聚。当知是等所应供养。若言不受不共和合布萨自恣。当知是等非是天人所应供养。是诸比丘不应与共布萨自恣。若其问讯犹不能知。当依如来真实契经而分别之。若使愚夫不善分别而便恭敬。供施所须与相习近。我说是等当堕恶道。复次善男子。譬如雪山有好甜药。时诸商人合持诸药游行而卖。时有一人不识诸药。问彼商人。汝有雪山甜药草不。答言我有。便从其买。而彼商人辄与苦药。其买药者求甜药故反得苦药。清净众者如雪山药。与彼懈怠犯戒比丘而共和合。其信心者供养礼事。当知是等肉眼凡夫。犹如彼人不识甜药。清净犯戒其相难知。凡夫肉眼不能分别。唯天眼者乃能别知。是故成就八种恶法。虽着法服。不应受人礼拜供养。若能改悔除八种过名清净僧。迦叶菩萨白佛言善哉善哉。世尊。快说斯法。我当顶受是金刚宝。尔时迦叶菩萨复白佛言。如世尊说。告诸比丘有四依法。何等为四依。于法不依人依决定说不依未定。依于智慧不依于识。依于义不依文字。我等信此为四种依。不信四人为真实依。佛告迦叶。其名法者。即是如来大般泥洹。一切诸佛皆同此法。诸佛如来得此法已。常住不变非磨灭法。若于如来作无常想者。我说斯等非知法人为不可信。如我所说四种人者。善解如来方便密教。知诸如来是常住法非变易法非磨灭法。诸佛如来亦复在彼。四种人数及余众生。于如来常住方便密教善解其义。我说斯等为根本依。当知可信。以是义故。说四种人为真实依。依于法者。是诸声闻大德智慧。于正法中心不失念。其正法者。如来常住于此正法精勤方便。名为依法。不依人者。若当此人犯戒贪浊。复说如来是无常法。彼非可信。是故我说不依于人依决定义。决定义者。是菩萨也。诸声闻等于此如来方便密教疑惑不信。大乘智海令其决定离诸疑惑。又决定者。是大乘智永离诸碍。 碍 者是声闻智。其诸菩萨能以决定大乘智慧。解诸如来是常住法。是故菩萨所言可信。未决定者。是声闻智。言诸如来秽食之身泥洹灭尽。譬如火灭则不可信。所以如来说斯等经方便教化如或二道诸众生辈。声闻智者。是则有余为非决定。是故诸声闻名不决定数。以彼智慧不了如来大圣尊说。是故说彼为不可信。是故佛说决定义者。是真四依依于智慧。其智慧者。即是如来法身可信。方便身者则不可信。云何但见如来方便身已。而谓实有阴界诸入。若其无者为何处来。而今现有舍利积聚。以有舍利现于世故。谓其法身是秽食身。妄作是想。以是之故识不可信。识不可信故作识想者。当知其人亦不可信。依于义者。义者正义。正者满义。满者不消减义。不消减者如来常义。如来常者是法常义。其法常者众僧常义。是则佛说名为依义。若有谄曲凡夫。得蒙如来慈心荫覆。出家学道而便懈怠放舍禁戒。言佛听我受畜奴婢诸非法财。若饥俭时言我诸弟子莫自苦困。我听受畜奴婢钱财金银宝物牛马谷米买卖生利。彼作如是种种文辞。说经律者皆不可信。信是说者当知其人亦不可信。以是义故说名依义。其非义者。言此三法是皆无常变易磨灭。是名非义。是名文字。是故说言依义不依文字。正使外道所说经义合摩诃衍者。是皆可信非为文字。是故四依乃至肉眼四种人数为真实依。善男子。是为四依。当作是学

     大般泥洹经 分别邪正品第十

佛告迦叶。有四种法。有魔说经。有佛说经。有诸众生随魔教者。随佛教者。迦叶菩萨白佛言。世尊。我当云何而分别知。愿欲闻之。佛告迦叶。善男子。我般泥洹七百岁后。如来教法从此渐灭。魔作比丘坏乱正法。为猎师相而自覆藏。作比丘像比丘尼像。优婆塞像优婆夷像。须陀洹像斯陀含像。阿那含像阿罗汉像。及作佛像。是魔波旬。作离俗相而行俗法坏乱我教。波旬说言。如来从兜率天没。降神来下净饭王家。摩耶夫人爱欲和合而从彼生。若言不从爱欲生者。无有是处。同人间法。而为诸天世人阿修罗等恭敬供养。所以者何。以其宿世殖众德本自身妻子种种施与。故得为佛。如是相 貌 。当知是为魔说经律。所以者何。如来应供等正觉。化众生故出现于世。非为如来从其父母习爱欲生。现斯相行随顺世间。如是相貌。当知是为佛说经律。若有众生于魔经律从而信者。当知是辈为随魔教。若于如来所说经律从而信者。当知菩萨。又说如来出生于世。周向十方各行七步。非为示现言示现者是不可信。是等经律当知魔说。若言如来初生于世周向十方各行七步。是则如来方便示现。是等经律经知佛说。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。又说如来往诣天庙恭敬礼拜。非是天神礼拜菩萨。所以者何。天神在前如来在后故。如是当知魔说经律。如来方便现入天庙。诸天释梵皆悉恭敬礼侍菩萨。如是相貌为如来说。魔说经律从而信者。当知是辈为随魔教。佛说经。律从而信者。当知菩萨。又说如来为王太子。宫人婇女五欲自娱。当知是为魔说经律。言彼如来现处深宫婇女娱乐。如弃涕唾舍家学道。如是说者当知是为如来经律。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。又说如来应供等正觉。在于祇树给孤独园。受畜钱财金银宝物奴婢。象马牛羊鸡狗猫狸狖鼠。铜铁琉璃真珠珂贝。金银宝玉珊瑚虎珀。种种杂物种种田宅。种种贩卖。畜养男女积聚谷米。如此诸物哀愍世间故皆悉受之。如是像类当知魔说。如来应供等正觉。哀愍一切诸众生类。住那罗林为弥罗耆罗婆罗门。及波斯匿王说言。大王。我诸弟子受非法物。无有是处。若畜金银奴婢象马牛羊鸡狗猫狸[狂-王+由]鼠。铜铁琉璃金银真珠珂贝玉石珊瑚虎珀。种种杂物种种田宅种种贩卖。畜养男女积聚谷米。自熟教熟学相学咒学众鸟语。推步盈虚日月博蚀。仰观历数。学结华鬘工巧木作。学书占梦六十四术。服诸消食治唇齿药。花鬘涂身谄曲徐步。现知足相而实无厌。戏笑谈话。贪味饮食鱼肉肴膳。合诸毒药合诸香油。作诸乐器革屣伞盖。竹作织作刻画文绣。服种种药合和诸香。学造王家谈语坐起言笑宴默学作女人华严饰具。调戏语言杂色衣服造金楼阁。入酒会处及淫女家。如是种种非法之物。或作或受或持施人。如是大王。是诸像类我所不听。所以者何。此等非法犹如草秽害善谷苗。我听苦治驱摈令出。如是说者。当知是为如来经律。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。又言如来不能示现入于天庙。亦复不能降伏于彼诸天人辈。亦复不能于九十六种道中出家。不能现劫成败。不学一切诸医方术。亦不能现为人仆使男女药树若王大臣。若使如来为是事者。非为如来是邪见辈。如来平等涂割处中。无怨无爱亦非有此。如是相貌当知是为魔说经律。现入一切诸天神庙。于九十六种而现出家。现劫成败。入诸咒术学书之堂。现为仆使为男为女。或为药草国王大臣。现入淫舍。或为长者居士梵志贫穷男女及诸不男。周遍一切二十五有种种现化。不为彼彼之所惑乱。犹如莲华不着尘水。当知化度诸众生故。随顺世间。如是相貌。当知如来所说经律。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。言我经律世尊所说是罪是恶是轻是重。是名粗罪。是为性罪。是为制罪。我说戒律为是真实。汝说为实。宁舍我说取汝说乎。汝谓此律世俗论耶。我此经律如来所说九部契经已印封竟。九部印中我未曾闻有方等经一句一字片言之音。如来说经有十部耶。方等经者其部无量。当知皆是调达所作。坏一切义而作虚说。言方等经出意妄造我所不信。佛告迦叶。如是说者乱我法教。诽谤如来方等契经。如是说者。当知是为魔说经律。当来之世有如是辈。各各自言我有经律。邪说经律而共诤论。有诸比丘于九部经。表知我别说此摩诃衍方等大经有信向心。不于戒律执着邪见。不净威仪悉能舍离。于我法律清净具足。犹如满月。知一一经一一法律一一戒行。其数恒沙不可称计。真实之义种种之义皆是佛说。若言我经律无有是戒。当知是戒非佛所说。言我限数持是戒者。当知是等为犯戒人。其有经说少欲清素合于佛语。当知此义皆是摩诃衍经之所宣说。若言如来安隐济度一切众生。故说如此大乘泥洹方等经者。当知此等是我弟子。其有异者我非彼师。不于我所出家学道。皆是邪见外道弟子。如是相貌当知是为佛说经律。魔说经律从而信者。当知是辈为随魔教。若于如来所说经律从而信者。当知菩萨。如来成就无量功德得空无慧。为众生说苦空非我。今已无常入于泥洹。亦不示现随顺世间。如是说者当知魔教。当知如来不可思议。无量无数功德成就为佛世尊。是常住法非变易法。非是一切如截多罗树。而世尊说四不度法如截多罗树。复说一一不度犹如析石。说过人法者无间等上。是过人法未得言得故。有一比丘少欲知足又多知识。若王大臣及余世人。见皆恭敬。而说偈颂赞彼比丘种种功德。言是尊者。舍此身已当成佛道。比丘闻已便作是言。汝等莫于未得果人以道果赞叹。是多欲名字佛所不许。汝等默然莫尽形寿。为我乐法之人作多欲名字。未得道果我自知之。而彼国王及诸大臣语比丘言。今汝尊者便为是佛举世悉闻。皆从汝学律经记论。当知彼王及诸大臣。偈颂赞叹功德无量。然彼比丘修持梵行无所违犯。非为不度不犯自称得过人法。复有比丘广说如来藏经言一切众生皆有佛性。在于身中无量烦恼悉除灭已。佛便明显。除一阐提时有国王及诸大臣问比丘言。汝当作佛不作佛耶。汝等身中皆有佛性。彼比丘言。不知我当得作佛不。然我身中实有佛性。复语比丘。汝今莫作一阐提辈。而自计数我当作佛。比丘言尔。但我身中实有佛性。然彼比丘虽作是说。非为自称得过人法。实有佛性施戒生故。复有比丘作是思惟。我当成佛决定无疑。作是思惟。虽未得道果其福无量。以是义故。一切比丘皆应修行是思惟法。所以者何。八十亿种不清净法从是得离。清净少欲悉得成就。如来真性由斯显现。逮得百千诸法宝藏。大悲世尊而作是说。如是相貌当知如来所说经律。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。又复说言。亦无四堕十三僧残三十舍法九十一堕法。众多学法四悔过法。二不定法七灭诤法。无越比尼亦无粗罪。亦无五逆无谤经法。无一阐提。亦无犯此诸戒果报堕泥犁中。其诸比丘及与外道皆当生天。然佛世尊恐怖人故说斯戒律。若欲恣心极世乐者。当舍法服还受五欲。厌五欲已悔过修善。如来在世亦有比丘。受习五欲得生天上亦得解脱。古今有是。非我独造。犯四堕法乃至五戒。及诸一切不净律仪。受非法物皆得解脱。若作是说越比尼罪。如忉利天日月岁数。八万四千岁堕泥犁中。诸余篇罪差降转重。是诸律师虚诳妄说假称佛教是不可信。如是相貌。当知是为魔说经律。越比尼罪最为微细。若有比丘犯此一一微细律仪。知而藏覆如龟藏六。当知是辈不可习近。如我说偈

  若犯微细罪　　默然妄语者
  不计于后世　　无恶而不为

斯等皆是如来教诫决定之说。况犯粗罪。戒无粗细当坚固持。为佛性故。若言九部不说众生皆有佛性。又方等经亦说非我。是为诽谤九部契经。云何不起众生见耶。九部经中一切众生皆有佛性。未所曾闻我当何取。或能自称说过人法。当知是等如言大海无种种宝。彼虽受学九部契经。方等要藏摩诃衍海种种法宝非彼境界。然佛所说法非为一切声闻缘觉。悉非其境界。见佛所说因缘相貌。亦复能知一切众生有如来性。不坏吾我寿命之相。心存中道言我身中皆有佛性我当得佛。我今但当尽诸烦恼。如是说者是我声闻。若异此者名为自称有过人法。又复说言。我已作佛我已见法住于佛地。是为自说得过人法。其不尔者。是等不久当成佛道。如是决定甚深佛教。而诸比丘于中自说得过人法。为利养故谄曲徐步现行乞食。愚痴犯戒未得道果。而言得果向人称说。普共闻知恭敬承事。转增贪着伺望供养。不修法念示现威仪取悦人意。我说是辈为自称说得过人法。复有比丘。护持正法故现求利养贪著名声。作是思惟。当令一切人所知识称叹善哉恭敬承事。我当因是降伏外道诸犯戒者。光扬如来天尊之德。广宣方等般泥洹经开导众生善解如来所说经律及律眷属。长养自身如来种子。速令佛性开发显现。无量结患一时除灭。告诸众生汝等皆成如来之性灭诸烦恼。心在护法而作是说。我说斯等为菩萨也。以护法故无有自称得过人法越比尼罪。如忉利天数八万四千岁在泥犁中。何况粗罪。其摩诃衍有粗罪者皆当驱出。有所取者便是粗罪。人所受护塔物取如芥子。及不问主而取经卷者皆是粗罪。贼心坏塔。亦犯粗罪。悉应驱出。若王大臣有故塔寺。欲作供养为舍利故。或恭敬故立一比丘为经营王付其钱物。而彼比丘辄取自用令主呵责。是等比丘亦应驱出正使不男及二根者皆应驱出。所以者何。越五戒故。乃至蚁子皆当慈心施以无畏。是沙门法。设有酒香亦随远离。是沙门法。正使梦中犹不妄语。是沙门法。梦中不与女人同处。是沙门法。若于梦中与共同处。虽不犯戒。如香华等令人宽纵。心起放逸。皆由昼见心随生故则有梦想。彼梦觉已亦增乱念。以食子想而行乞食。云何而令恣心得生。梦中生心应速除灭。如是相貌当知是为如来经律。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。言如来听受大人坐法。行止威仪受不言法。投岩饮毒断食杀生。系缚众生自治身体。作茂罗业咒术蛊道。旃陀罗等不男二根支节不具皆听出家。愍众生故。乳蜜绵缯珂贝皮革诸谷米等悉不服食。于诸草木作寿命想。慈悲心故。泥洹长灭。如是相貌。当知是为魔说经律。除大人坐四种威仪。若言我听饮毒入火断食投岩残杀众生。作茂罗业咒术蛊道。乳蜜绵缯珂贝谷米作熟肉想。一切草木作寿命想。如是说者我所不听。作是说者。当知是辈外道弟子。随我所听而能行者。是我弟子。不说四大有寿命想。如是说者。当知是为佛说经律。如是比说众多无量。魔说经律从而信者。当知是辈为随魔教。佛说经律从而信者。当知菩萨。善男子。如是所说是为魔所说经。佛所说经差别之相。当分别知。迦叶菩萨白佛言。善哉世尊。我等今日始解如来甚深之说。佛告迦叶。善哉善哉。善男子。当作是学。是为黠慧

大般泥洹经卷第四大般泥洹经卷第五

        东晋 平阳 沙门法显 译

    四谛品第十一

尔时佛告迦叶。善男子。若使是苦名苦谛者。地狱畜生皆有苦谛。名苦谛者。谓知如来常住法身非秽食身。众生不得如来尊智知苦故以非法为法。久远痴爱烦恼结缚。弥劫生死苦轮常转。假使如来常住二字暂经耳者。欲生天上及求解脱。必得圣果自然快乐。智者自知。皆由如来常住之音暂经耳故得此妙果。久远以来不知如来常住法故。往返无量生死苦惑。如是知苦为知苦谛。若异此者非知苦谛。苦集谛者。诸法之实。不知实故增其爱集。畜养奴婢诸非法物。非法为法而生妄取。正法则灭。以无智故长处生死轮转苦惑。当知是等为坏正法。终不得果生天解脱。不知苦集真实相故为坏正法。妄说之报亦复长夜生死苦恼。如是知者为知集谛。若异此者不名知集。苦灭谛者。若修行空一切尽灭坏如来性。若修行空名灭谛者。彼诸外道相违义者。亦修行空得灭谛耶。当知一切皆有如来常住之性。灭诸结缚烦恼永尽。显现如来常住之性。起于一心便得妙果。常乐自在名法自在王。是为修行苦灭圣谛。若复修行于如来性作空无我相。当知是辈如蛾投火。名灭谛者。是如来性。是如来实。灭除一切无量烦恼。所以者何。是如来性因故。如是知者为知如来平等灭谛。若异此者不名知灭。苦灭道者。如来法僧解脱之性。此四种法名为道谛。于四种法不知实故。长处生死无量苦惑。于生死中能勤修行。了知如来法僧解脱。是常住法。非变易法。非磨灭法。不尽不坏。起于一心得微妙果快乐自在。于此常住不空四法作非法想者。当知是辈得邪见果报。苦灭道者。于此三法作常住修者。是则名为知苦灭道谛。如是修行常住想者。当知是等是我弟子知四真谛。是为菩萨知四真谛。迦叶菩萨白佛言。世尊。我今始知修四真谛

    大般泥洹经四倒品第十二

佛复告迦叶。所谓颠倒。苦有乐想。如来无常灭尽泥洹。如薪尽火灭则为大苦。而作是想。如来无常。是为颠倒。乐有苦想。于如来长存作众生见。是为颠倒。于三有苦而作乐想。是亦颠倒。是为第一颠倒。无常常想颠倒。常无常想颠倒。常无常想者。如来泥洹修极空想。是为颠倒。修极空已。短寿众生便得长寿。于是修果谓常存法。名为颠倒。是名第二颠倒。非我我想颠倒。我非我想颠倒。言一切世间有我。是为颠倒。佛说如来性是真实我。而于此义作非我修。是名第三颠倒。净不净想颠倒。不净净想颠倒。如来常住非秽食身。而肉眼者言秽食身非清净法。法僧解脱亦当灭尽。是名颠倒。诸不净身无一净想。愚痴倒惑而起净想。是名第四颠倒。如是善男子。是名四颠倒。迦叶菩萨白佛言。善哉世尊。我从本来常着颠倒。而今始知如来正见

    大般泥洹经如来性品第十三

迦叶菩萨复白佛言。世尊。如来有我。二十五有。为有为无。佛告迦叶。真实我者是如来性。当知一切众生悉有。但彼众生无量烦恼覆蔽不现。譬如贫家舍内有珍宝藏而不能知。时有一人善知宝相语贫子言。汝为我作我当与汝钱财宝物。贫子答言。我不能去。所以者何。我先家中有珍宝藏不能舍去。彼人复言。汝愚痴人不知宝处。且与我作给汝珍宝。用之无尽。便从其语。然后彼人出其宅中珍宝与之。贫人欢喜起奇特想。知彼士夫实可依怙。一切众生亦复如是。各各皆有如来之性。无量烦恼覆蔽隐没不能自知。如来方便诱进开化。令知自身有如来性欢喜信受。复次善男子。譬如母人生子尚小而便得病。药师方便为合良药苏乳石蜜令子服之。语其母言。慎莫与乳。令子药消然后与之。复合苦药涂其乳上。子欲饮乳闻苦药气即便舍去。知其药消然后洗乳令子乳之。如是善男子。如来诱进化众生故。初为众生说一切法修无我行。修无我时灭除我见。灭我见已入于泥洹。除世俗我故说非我方便密教。然后为说如来之性。是名离世真实之我。迦叶菩萨白佛言。世尊。人初生时智慧尚少。渐渐长大智亦随明。若有我者始终应一。以彼智慧渐渐增故。当知无我。又复我者应无生死。而有生死当知无我。若使一切皆有如来性者应无有异。而今现有长者梵志刹利居士旃陀罗等。诸众生类种种异业受身不同。若使众生有如来性者应当同等。而今不同。故知无有如来之性。若复真实有如来性。不应杀盗作诸种种不善恶业。若当众生有如来性。聋者应听盲者应视哑者应言。若使各有如来性者为住何所。彼和合身青黄赤白于种种色。为住一处为遍身中。佛告迦叶。譬如国王有大力士摩尼宝珠能除毒痛。系着头上与敌国共斗。为彼所系摩尼宝珠陷入身中。血肉皮覆遂失宝珠。求觅不得便作失想。时有良医。来为治病。因语医言。我有宝珠遂便忘失。处处求觅不知所在。当知财宝非常之物如水上泡。速生速灭虚诳如幻。如是永作失宝珠想。良医答言。宝珠不失莫作失想。汝因斗时珠入身中。血肉皮覆是故不现彼人不信而谓医言。血肉之中何处有珠。是虚言耳。时彼良医即为出珠。彼得珠已方信良医所知奇特。一切众生亦复如是。各各皆有如来之性。习恶知识起淫怒痴堕三恶道。乃至周遍二十五有种种受身。如来之性摩尼宝珠。没在烦恼淫怒痴疮。不知所在。于世俗我修无我想。不解如来良医方便密教。作无我想而不能知真实之我。于是如来复为方便。令灭无量烦恼炽然。开示显现如来之性。复次善男子。譬如雪山有好甜药名为上味。转轮圣王未出世时隐没不现。其诸病者皆诣药所。掘地埋筒以承药汁。或得甜味或得苦味。或得辛味或得酢味。或得碱味或得淡味。而诸病者得此诸味。不得真实上味之药。掘地不深薄福德故。转轮圣王福德力故。出于世时便得真实上味之药。如是善男子。如来性者多种之味。无量烦恼愚痴覆蔽。是故众生不得上味如来之性。种种行业处处受身。 彼如来性 无可杀害。其诸死者名为寿短。如来之性名为真寿。不断不坏乃至成佛。如来之性无害无杀唯长养身。有害有杀如诸病人作众邪业。种种报应刹利梵志。乃至生死二十五有。不得真实如来性故。复次善男子。如人穿地求金刚宝。手执利凿凿坚土石悉能令碎。唯有金刚莫能断截。如来之性亦复如是。天魔利剑所不能伤。唯长养身受其伤坏非如来性。是故当知如来之性无害无杀。是为如来决定之教方等契经甘露毒药。迦叶菩萨白佛言。世尊。方等契经甘露毒药义何所趣。佛告迦叶。善男子。汝今谛听当为汝说。尔时世尊。即说偈言

  或有食甘露　　而得长仙寿
  有人服甘露　　伤寿而早夭
  或因饮毒死　　或缘饮毒生

其甘露者。是摩诃衍无碍之智。其毒药者。亦是摩诃衍无碍之智。犹如醍醐 苏油石蜜。食之不消名为毒药。 食之消者 名为 甘露 。无智众生不解方等大乘密教。则于是人名为毒药。声闻缘觉住大乘法。及诸菩萨人中之雄名为甘露。譬如乳牛虽色不同其乳一味。如是迦叶。当知菩萨成无畏者之所归依如来法性。彼性我性皆同一味。于是迦叶菩萨。即说偈言

  我今归三宝　　甚深如来性
  自身如来藏　　佛法僧是三
  如是归依者　　是名最上依

尔时世尊复为迦叶。而说偈言

  不知三宝者　　何名知归依
  依义尚不了　　云何知佛性
  若以归依佛　　是为最吉安
  复有何因缘　　而复归依法
  归依于法者　　是为自心想
  复有何因缘　　而归于众僧
  不信归依佛　　决定真实者
  三宝如来性　　何由能悉知
  云何未知义　　而生豫计想
  佛法比丘僧　　三宝之梯橙
  犹如不怀妊　　而作生子想
  如是思惟者　　但增其惑乱
  如人寻空响　　离真优婆塞
  当勤求方便　　大乘决定义
  如来随顺说　　令汝除疑网

迦叶菩萨复说偈言

  为优婆塞法　　归依于佛者
  一切诸天神　　不生归依想
  为优婆塞法　　归依于法者
  不以害生法　　而为非法祠
  为优婆塞法　　归依于僧者
  不于众邪道　　请求良福田
  是故归三宝　　除俗三非法
  此三归法者　　亦是如来说
  我昔由此法　　今得安隐处
  汝等亦当行　　终归至我所
  如是平等路　　汝等随行者
  疾得免众苦　　轮回生死惑
  如来之性者　　亦从世尊说
  我及诸众生　　同此如来性
  诸佛随顺道　　我等悉由之
  乃至诸魔天　　亦有此甘露
  终归同诸佛　　离有牟尼尊

尔时世尊复为迦叶重说偈言

  汝莫如声闻　　童蒙之智慧
  唯是一归依　　当知非有三
  如是平等道　　佛法僧一味
  为灭痴邪见　　故立此三法
  汝今欲示现　　随顺世间者
  应当从此教　　归依于三宝
  若人归依佛　　便为归依我
  归依等正觉　　正觉我已得
  分别归依者　　则乱如来性
  当于如来所　　而作平等心
  合掌恭敬礼　　则礼一切佛
  我与诸众生　　为最真实依
  清净妙法身　　我已具足故
  若礼舍利塔　　应当敬礼我
  我与诸众生　　为最真实塔
  亦是真舍利　　是故应敬礼
  若归依法者　　应当归依我
  清净妙法身　　我已具足故
  我与诸众生　　为最真实法
  若归依众僧　　亦当归依我
  诸余一切众　　皆佛僧所摄
  我与诸众生　　为最正觉僧
  无目众生类　　为之生道眼
  是故声闻众　　及诸缘觉僧
  如来僧悉摄　　归依最真实

佛告迦叶。如是善男子。菩萨摩诃萨当作是念。正使不善无知积聚。应作是知我有佛性。如彼健士斗战之时。当知我为军中之将。为一切众所依怙者。譬如王子为太子时。应当自知我为一切王子之上。当绍王位为诸王子作真实依。终不生心作下劣想。善男子。菩萨摩诃萨亦复如是。立金刚志超彼三法。如彼王子成就无畏。于三法中离种种想。如来最上犹如顶相最为第一。非佛非法非比丘僧。种种差别如梯橙也。为世间依度世间故。于真实法示现种种。而为三法诱化童蒙无知众生。令入大乘深利智慧。迦叶菩萨。复说偈言

  知此真实义　　而问于如来
  欲显发菩萨　　勇猛离垢故
  善哉世尊说　　菩萨之所行
  大乘深利智　　如练金刚慧
  善哉世尊说　　安立诸菩萨
  如来善显示　　我今亦当然
  一切众生类　　悉应自观察
  自身如来藏　　皆是三归依
  一切众生类　　信受此经者
  若已离烦恼　　及诸未离欲
  皆当归自身　　如来微妙藏
  唯是正归依　　无二亦无三
  所以然者何　　世尊广分别
  各各自身有　　如来微妙藏
  以知此义故　　不复归于三
  我已为一切　　世间真实依
  法及比丘僧　　一切摄受故
  声闻辟支佛　　皆悉当敬礼
  以是诸菩萨　　正向大乘道
  如是如来性　　为不可思议
  具三十二相　　八十种好故

佛告迦叶。善哉善哉。善男子。其诸菩萨应如是学甚深利智。复次善男子。我当更说入如来藏。即说偈言

  有我长存者　　终不经苦患
  若使无我者　　空为修梵行
  一切法无我　　是名断灭教
  言我长存者　　则为计常说
  一切法无常　　是则为断说
  一切法常者　　是则为常说
  一切法 是苦 　　是则断灭说
  一切法是乐　　是则计常说
  一切修常想　　是疾得断说
  一切修无常　　是疾得常想
  譬如拆楼虫　　得一速望二
  如是修常者　　是速得断灭
  若修断灭者　　亦疾得常想
  如是所说喻　　得一更求余
  异法修苦者　　则说不善分
  异法修乐者　　是则说善分
  异法修无我　　无量诸烦恼
  异法修常存　　佛性及涅槃
  异法修无常　　则身不坚固
  异法修常者　　如来等三宝
  及平等解脱　　是诸法真实
  如来之所说　　不同于彼喻
  当知除二边　　处中而说法
  计常及断灭　　是见二俱离
  世间凡愚辈　　于佛说迷惑
  喻如羸病人　　顿服苏迷乱
  有无增其患　　譬如重病人
  四大互增损　　而不等和合
  痰癊增不息　　风种起烧然
  风癊已违诤　　涎唾亦复增
  如是不和合　　举体发狂乱
  良医善方疗　　随顺安四种
  除灭一切病　　悦乐全身强
  如四大毒蛇　　无量烦恼患
  良医善方疗　　平等性安隐
  其平等性者　　是名如来藏
  得闻如来性　　离于一切界
  常住不变易　　有无等不着
  凡愚而妄说　　不了微密教
  如来为众生　　方便说身苦
  凡愚不能了　　谓我身断灭
  慧者了真谛　　不总一切受
  能知我身中　　有安乐种子
  闻我为众生　　方便说无常
  凡愚谓我身　　如陶家坏器
  慧者能谛了　　不总一切受
  能知我身有　　微妙法身种
  闻我为众生　　力便说非我
  凡愚谓佛法　　一切无我所
  智者能谛了　　非尽假名说
  不惑于清净　　如来真法性
  闻佛为众生　　方便说空教
  愚夫不能知　　谓悉言语断
  慧者能谛了　　不总一切受
  知如来法身　　长存不变易
  闻我为众生　　方便说解脱
  愚夫谓佛身　　解脱悉磨灭
  慧者能谛了　　不悉往来断
  如来人师子　　自在独游步
  我为众生说　　无明缘诸行
  凡愚不能知　　谓是为二法
  慧者能谛了　　明非明虽异
  解脱真实法　　则无有二相
  缘诸行生识　　凡愚谓为二
  慧者知行缘　　虽二而不二
  十善及十恶　　凡愚随二相
  慧者能谛了　　虽二而不二
  有罪及无罪　　凡愚谓为二
  慧者能谛了　　自性则不二
  清净不净相　　凡愚谓为二
  慧者能谛了　　自性则不二
  作者及不作　　说一切诸法
  凡愚不能知　　谓为是二法
  慧者能谛了　　自性则不二
  说一切诸法　　为苦及乐分
  凡愚不能知　　谓为是二法
  慧者能谛了　　自性则不二
  我为众生说　　一切行无常
  凡愚不能知　　总修如来性
  慧者能谛了　　自性则不二
  我为众生说　　一切法无我
  凡愚不能知　　谓佛说无我
  慧者了自性　　我非我无二
  无量无数佛　　说是如来藏
  我亦说一切　　功德积聚经
  我非我不二　　汝等善受持

善男子。 当忆念一切功德聚经。我说般若波罗蜜大经不二。彼如是说我非我不二。譬如从乳出酪从酪出生苏从生苏出熟苏从熟苏出醍醐。为始终是一。为从余处来。若即是一者即作本事。若乳即为酪者。然今乳时而无酪相。如是因缘展转相生。非已有故而言展转。若余处来者。彼在何处住。当于乳时不见酪等从余处来。彼一切分皆有醍醐自性。但诸过覆故异分现。牛食过故乳则血气。牛食甘草乳则甜香。牛食苦草乳有苦味。于雪山下有甘泽草。牛食是草出成醍醐不作余色。当如牛食种种味草。则有种种异色。明及无明不二之法。亦复如是。行业过故明非明转。一切善法及不善法皆无有二。是故当知。如来之性如彼醍醐。自性清净烦恼过故。有异相现。譬如人言大海水碱非为一切其水悉碱。其中亦有八味之水。譬如 雪山多诸毒草。而彼雪山先有良药 。一切众生身亦如是。四大 和合譬如毒蛇。 然 此身中 先有佛性。如彼良药其如来性始终常有非作所作。但无量烦恼中间竞起。凡诸众生欲求佛者。当除无量烦恼结患。譬如春月兴大云雷而未降雨。草木华果皆未萌芽。夏时大雨一切扶疏。如来之性亦复如是。无量烦恼结患所覆。虽闻契经及诸三昧。犹故不知如来之性。以不知故而起于我及非我想。大般泥洹方等契经。密教法藏闻于世间。众生闻已如来之性皆悉。萌芽能长养大义。是故名为大般泥洹。如是善男子。其有众生学此方等般泥洹者。名为毕报如来之恩。迦叶菩萨白佛言。善哉世尊。如来之性于诸声闻及辟支佛。甚为难见难得之宝。佛告迦叶。如是如是。善男子。我亦常说甚为难见。譬如有人肤翳覆眼不见五色。就彼良医为治其目翳。便为除少分肤肉。而以一物示之令见。彼视惑乱谓二谓三。久久谛视仿佛见之。如是善男子。菩萨摩诃萨净治道地成就十住。于自身中观察如来真实之性。犹为无我轮之所惑。况复声闻及辟支佛而能知之。当知善男子。如来之性难见如是。又如有人仰观飞鸟。远则不识为是为非。极明其目仿佛识之。十住菩萨亦复如是。于自身中观如来性。犹生惑想久乃仿佛。况复声闻及辟支佛。又复如人痰癊增故。迷于诸方欲有所至。心心相续专念记识犹失径路。十住菩萨亦复如是。于自身中观如来性。专心方便犹有惑乱。况复声闻及辟支佛。复次如人远行旷野热渴所乱。远见野马或谓为水。或谓林树或言聚落。十住菩萨亦复如是。于自身中观如来性亦生惑想。复次譬如有人登高临下远观佛塔。或作水想或谓虚空或谓屋舍。或谓野马山石草树。方便谛观乃知是塔。十住菩萨亦复如是。于自身中观如来性犹生惑想。方便极视乃知真实。复次如人船行大海。远见城郭而生惑想。或谓虚空或言物像。十住菩萨亦复如是。于自身中观如来性。亦生惑想。复次譬如王子竟夜观伎。至日光现见人生惑亲作他想。十住菩萨亦复如是。于自身中观如来性。亦生惑想。复次譬如大臣往诣王所咨详王事。夜闇还家于电光中。若见白牛而生惑想。或谓屋舍或谓丘冢。十住菩萨亦复如是。于自身中观如来性。亦生惑想。复次譬如持戒比丘自漉净水。复重谛视若见微毫。或谓为虫或谓尘末。十住菩萨亦复如是。于自身中观如来性。亦生惑想。复次如人观高山顶。若有行人或谓禽兽。十住菩萨亦复如是。于自身中观如来性。亦生惑想。如人目患夜闇观画。或谓人像或谓神像。或谓佛像或谓释梵诸菩萨像。十住菩萨亦复如是。于自身中观如来性。亦生惑想。如是善男子。如来之性甚深难见唯佛境界。非诸声闻及辟支佛所能知见。如是善男子。如来教法。慧者所知应当信受。迦叶菩萨白佛言。如世尊说。如来之性甚深微妙。诸肉眼者云何得见。佛告迦叶。譬如非想非非想天。唯佛境界一切声闻及辟支佛云何能见。但彼随顺如来契经。信心方便然后等观。如是善男子。一切声闻及辟支佛。当于方等般泥洹经而生信心知其自身有如来性。是故当知如来之性唯佛境界。非诸声闻及辟支佛。迦叶菩萨白佛言。世尊。世间众生皆言有我。比义云何。佛告迦叶。譬如一时二人为友。一是王子。一贫穷人。结好往来。其王子者有调伏兕。贫人见之。彼于后时共至他国。于一客舍暮共止宿。而彼贫者于梦中言。兕来兕来声彻于外。时有人闻将至王所。以其所闻具白国王。王即问言。何处有兕。时彼贫人便白王言。我无兕也。善知识有我曾见之。王即复问其状云何。复白王言。其角似羊。作是语已王语贫人。汝自还去何处有兕。彼亦无有为虚说耳。而兕似羊传于天下。如是不久其王命终。太子即位亦访求兕而不能得。次后其子续立为王。亦复如是求兕不得。展转相传恒于兕上而作羊想。如是菩萨摩诃萨出于世时。为众生说真实之我。其无知者闻一切众生皆有佛性。不知其真便妄想说。我如寸灯在于心中。种种众生我人寿命。如彼梦说展转相承皆起邪见。计有吾我求吾我性。不得实我作无我说。而诸世间一切众生常作妄想计有吾我及无我想。如是善男子。我说如来之性最为真实。若世间说我随顺法者。当知是则为离世俗。当知皆是菩萨变化现同俗说

大般泥洹经文字品第十四

佛复告迦叶。一切言说咒术记论。如来所说为一切本。迦叶菩萨白佛言。世尊。其义云何。佛告迦叶。初现半字为一切本。一切咒术言语所持真实法聚。童蒙众生从此字本学通诸法。是法非法知其差别。是故如来化现字本不为非法。迦叶菩萨白佛言。世尊。云何字本。佛告迦叶。初十四音名为字本。是十四音常为一切不尽之本不尽有何义。不破坏义不漏义如来义名不尽义。如来法身金刚不坏。故名不坏。如来无有九道诸漏。故名不漏。如来常住故说不尽无作之义。初短阿者吉义。吉者三宝义。次长阿者现圣智义。其名圣者离世间数。清净少欲能度一切三有之海。故名为圣。圣者正也。能正法度行处律仪及世间法度。是其义也。复次阿者。有所长养皆依于圣。一切真实正行之本。孝养二亲皆依是知。晓了正法住摩诃衍。善男子善女人持戒比丘及菩萨。如是所行皆名依圣。又复阿者。世界言语法之所依。如言善男子阿伽车。如言男子莫作阿那遮逻。是故阿者亦是世间言语所依。短伊者此也。言此法者是如来法。梵行离垢清净。犹如满月显此法故。诸佛世尊而现此名。又复伊者。言此是义此非义。此是魔说此是佛说。依是分别故名为此。其长伊者。名为自在名大自在。自在梵王能于如来难得之教以自在力护持正法。以是之故名为自在。又复伊者。于此自在大乘方等般泥洹经。自在摄持。令此教法自在炽然。令余众生自在受学此方等经。又复伊者。自在。方等能除伊者嫉妒邪见。如治田苗去诸秽草。如是等比。是故如来说伊自在。短忧者。上也。于此契经说最上义。其诸声闻及辟支佛。所未曾闻一句一字片言历耳。譬如诸方郁单越为福德之上。大乘方等亦复如是。一言历耳。当知是等人中之上为菩萨也。是故如来说此忧字。长忧者如香牛乳。其乳香味是大乘经最为上味。广说如来真实之性。非法憍慢皆悉消灭。又复忧者。名为大忧。于如来藏慧命根断着无我说。当知是等名为大忧。是故说忧。咽者是也。言是佛法。如来泥洹。亦说是法。咽者如来也。有来去义。以是故说如来如去。乌者下也。下贱烦恼悉除灭已名为如来。是故说乌。炮者是摩诃衍。于十四音炮为究竟。是故说名为摩诃衍。于一切论为究竟论。是故说炮。安者一切也。如来教法离于一切钱财宝物。安者遮义。一阐提义。最后阿者。尽也。一切契经摩诃衍者。最为穷尽。迦者一切众生如一子想。于诸一切皆起悲心。是故说迦。呿者掘也。发掘如来甚深法藏。智慧深入无有坚固。是故说呿。迦者藏也。一切众生有如来藏是故说伽。重音伽者吼也。常师子吼说如来常住。俄者脆也。一切诸行速起速灭。故说为俄。遮者行也。成就众生故名为遮。车者照耀。如来常住之性。是故说车。阇者生也。生诸解脱非如生死危脆之生。是故说阇。重音阇者烧也一切烦恼烧令速灭。故说为阇。若者智也。知法真实是故说若。吒者示也。于阎浮提现不具足。而彼如来法身常住。是故说吒。吒者示满足也。平等满足是故说侘。茶者轻仙不没。是故说茶。重音茶者。不知惭耻。重恩不报是故说茶。挐者不正可如诸外道。是故说挐。多者遮一切有令不相续是故说多。他者无知也。如蚕虫作茧。是故说他。陀者于摩诃衍欢喜方便。是故说陀。重音陀者持也。护持三宝如须弥山不令沉没。是故说陀。那者如城门侧因陀罗幢。竖立三宝。是故说那。波者起颠倒想。三宝沉没而自迷乱。是故说波。颇者世界成败持戒成败自己成败。是故说颇。婆者力也。如诸如来无量神力非但十力。是故说婆。重音婆者。能檐正法为菩萨道。是故说婆。摩者限也。入菩萨法限自强其志为众重檐。是故说摩。耶者习行菩萨四种功德。是故说耶。罗者灭淫怒痴入真实法。是故说罗。轻音罗者。不受声闻辟支佛乘受学大乘。是故说罗。和者一切世间咒术制作。菩萨悉说。是故说知。赊者三种毒刺皆悉已拔。是故说赊。沙者满义。悉能闻受方等契经。是故说沙。娑者竖立正法。是故说娑。呵者惊声也。怪哉诸行悉皆究竟。怪哉如来而般泥洹离诸喜乐。是故说呵。罗(来雅反)者魔也。天魔亿千无能破坏如来正僧。随顺世间而现有坏。又复随顺世间现为父母诸宗亲等。是故说罗(来雅反)。厘厘楼楼。此四字者。长养四义佛及法僧。示现有对随顺世间。示现有对如调达坏僧。僧实不坏如来方便示现坏僧。化作是像为结戒故。若知如来方便义者。不应恐怖。当知是名随顺世间。是故说此最后四字。吸气之声舌根之声随鼻之声。超声长声。以斯等义和合此字。如此诸字和顺诸声入众言音。皆因舌齿而有差别。因斯字故。无量诸患积聚之身。阴界诸入因缘和合。休息寂灭入如来性。佛性显现究竟成就。是故半字名为一切诸字之本。若观法实及如来解脱。亦无文字言语之相。字相味相皆悉远离。是故一切远离名为解脱。其解脱者即是如来。因是半字能起诸法。而无诸法因字之想。是名善解文字之义。若异是者不解文字分别诸法是法非法。如来之性三宝解脱。而不能知是经非经是律非律魔说佛说。悉不能知我说。是等不知字故。是故善男子。汝等应当善学半字。亦当入彼解文字数。迦叶菩萨白佛言。世尊。我当善学斯等半字。今我世尊。始为佛子得最上师。我今始入学书之堂。佛告迦叶。善哉善哉。善男子。乐修正法应当如是

大般泥洹经鸟喻品第十五

佛复告迦叶。雁鹤舍利鸟者。所谓种种无常苦空非我等法。如众雁鹤舍利之鸟。迦叶白佛。此义云何。佛告迦叶。有法无常有法是常。有法是苦有法是乐。有法是我有法非我。譬如田夫种殖五谷及诸果树。从其萌芽乃至华叶。其人恒作非常之想。至其成熟收其果实。得受用时而生常想。所以者何。真实现故。迦叶菩萨白佛言。世尊。云何五谷之常。与如来同不磨灭耶。佛告迦叶。犹以如来喻须弥山。其须弥山世界败时岂不坏耶。善男子。莫于譬喻而生是问。一切诸法悉归磨灭。唯有泥洹是常法耳。随世言说以彼为喻。迦叶菩萨白佛言。唯然世尊。善哉斯说。佛告迦叶。如是善男子。一切契经修诸三昧。乃至未闻大般泥洹方等契经。诸众生等修无常想。闻此经已。若善男子善女人。所怀烦恼疑结永离。晓了常法。所以者何。各于自身如来之性。得显现故。复次善男子。譬如金师销镕其金。至器未成作非常想。宝器成已常得受用。如是善男子。一切契经修诸三昧。乃至未闻大般泥洹方等契经。其诸众生修无常想。闻此经已。所怀烦恼疑结永离。晓了常法。所以者何。各于自身如来之性。得显现故。复次善男子。譬如有人种甘蔗胡麻乃至未熟。常作种种诸味之想。麻油石蜜成已乃知真味。如是善男子。一切契经修诸三昧。乃至未闻大般泥洹方等契经。其诸众生修无常想。闻此经已。所怀烦恼疑结永离。晓了常法。所以者何。各于自身如来之性。得显现故。譬如百川皆归于海。如是一切契经及诸三昧。悉归方等般泥洹经。所以者何。如来之性究竟说故。是故我说有法无常有法是常。如舍利鸟。忧悲剑刺如来已断。而于此论多有疑者。然其如来现有忧悲。非如人天及余众生之忧悲也。如非想处云何有想。若无有想不应有寿。有寿无想。何有想阴界入之名。又如林树皆有神依。若神依树。为依根茎为依枝条。如是诸处悉皆不现。为依何住。如是如来教法甚深。当知如来现有忧悲。于罗睺罗而起慈心。乃至非想非非想处亦复如是。唯佛与佛乃知此义。斯等皆是诸佛之法。尚无心意何有忧悲。忧悲若无教法相违。如一子想是则空言。说一切法皆不可信。但如来所说不可思议。诸佛教法亦不可思议。 如来佛法不可思议 。是为真实。譬如虚空不可于中造立宫室。而诸幻士能于中造。凡愚见已而作是念。云何空中而得安立如心意转。如是所说尚无心意何有忧悲。忧悲若无。罗睺罗喻是则不实。如虚空中如来忧悲则不可得。如其幻化随心意转。如来则有忧悲之想。闻般泥洹而作是念。何有忧悲。闻其转者常有忧悲。是故如来常住。若无常者无有忧悲。而今如来非是无常。如来忧悲及无忧悲悉不能知。下者知下不知中上。中者知中下不知其上。唯有上者一切悉知。其诸声闻及辟支佛各各自知。而不能知如来境界。如来悉知是故名为离诸障碍。譬如幻士种种现化。如来亦然。种种示现随顺世间。能知是者名为黠慧。肉眼凡夫无想之想非其境界。而于如来作忧无忧想。是故我说。有法是我有法非我如舍利鸟。复次善男子。譬如雁鹤及舍利鸟。于夏月雨时江河漫溢。选择高处而安其子然后游行。如是如来出兴于世。化无量众令入正法。为受化者方便说法。或说苦法或说乐法。有为诸行是名为苦。泥洹极乐离有为行说名为乐。迦叶白佛。其义云何。佛告迦叶。所谓如如。迦叶白佛。云何众生得泥洹乐。佛言。迦叶。如我先说一切诸行无生老死。所谓

  若无放逸　　是处不死　　若其放逸
  是为死径　　无放逸者　　得不死处
  若放逸者　　常处生死

若放逸者是有为行。彼有为行则为苦法。非泥洹者是为死处。若作放逸是名作行。当知是行则为大苦。不趣泥洹是为死径。无放逸者是不作行。虽复作行亦不生死。是名金刚不坏之身。其世俗者是名放逸。离世俗者是无放逸。离生老死泥洹快乐。是故如来有说苦法有说乐法有说非我有说是我。如鸟飞空不见其迹。无有天眼烦恼未断。不自见身如来之性。是故我说有法无我。为烦恼故说微密教。其诸众生无有天眼而计吾我。无量烦恼造有为行。故为彼说诸法无常。是故我说有法无常

  犹如明目住山顶　　谛了其地愚夫等
  如来道眼升慧台　　无忧忧念群生类

如是无量烦恼悉灭。名住山顶。观其无量烦恼炽然。下劣众生谁为登慧台。何名为无忧。若无忧者。云何名为忧念世间。若泥洹灭尽。何有观愚者。若使如来泥洹灭尽。云何能升智慧高台。若当泥洹。云何山顶能观其下。智慧台者。谓灭尽泥洹无忧忧念者。谓是如来忧念世间无量群生。山顶者谓解脱。住者行人。地者有为行。愚者无巧方便说。谛了者正觉也。如来者。忧苦永离是常法故。以自离忧见被利刺。忧恼众生为之生忧。若使如来永离忧者不名正觉。随彼众生应受化者。如来等正觉即为彼现。是故当知如来常住。种种示现犹如雁鹤舍利之鸟

     大般泥洹经 月喻品第十六

佛复告迦叶。善男子。如月不现人谓为没。一切人民皆作没想。于余方现余方人民皆谓月出。然其彼月不没不出。因须弥山故现有出没。如是如来应供等正觉。于大千世界或阎浮提。依因父母现生为子。阎浮提人皆作生想。又阎浮提现般泥洹。而此众生皆作灭想。其实如来不生不灭。复次善男子。如月余方现满 。彼方众生皆作满想。此阎浮提现有初生。此方人民作初生想。渐渐增长乃至月满便作满想。然其彼月不增不减。因须弥山现有增减。如来应供等正觉亦复如是。或于阎浮提现有泥洹。而诸众生皆作灭想。或于阎浮提示现出生。犹如初月。阎浮提人作婴儿想如月三日。现行游步如月四日。现行学书如月八日。现行出家乃至月满。现大光明破坏无量众魔。闇冥现般泥洹。三十二相八十种好庄严其身。犹如明月列宿围绕没而不现。阎浮提人或作生想或作灭想。其实如来不增不减常如满月。是故当知如来常住。复次善男子。犹如明月一切皆见处处城邑聚落山泽。随器大小是诸水中一切悉现。若人游行百千由旬而月常随。彼诸人等而作是想。为是本月随我而来为是异月。 愚人见月犹如镜面。中人见月犹如车轮。上人见月圆五由旬。及余众生随力所见 。如来明月亦复如是。一切悉见。而诸众生各作是念。谓佛世尊哀愍我故在我舍住。及畜生道亦复如是。聋盲喑哑及诸癃残。各谓如来为己像类种种语种种书种种身。皆作是念诸佛如来唯作我语我书我身我食。又作异想或谓声闻或谓缘觉。或谓种种异道出家。或谓如来为我兴世。然其如来法身真实无有变异。为众生故以方便身。现种种相如良药树。如来亦然。为众生故现百千变随顺世间。是故如来是常住法。复次善男子。如罗睺阿修罗捉日月时。其诸众生谓彼蚀月。彼舍月已谓为吐月。彼障月光世间不现便作蚀想。彼舍月已世间还现谓为吐月。然其彼月若隐若显实无增损。如来应供等正觉亦复如是。如彼调达伤坏佛身。作无间业等乃至一阐提辈。皆为当来诸众生故。现伤佛身坏法破僧。如来法身实无伤坏。正使天魔亿百千数。亦不能得断法坏僧。是故如来法身真实无有损坏。现损坏相随顺世间。譬如二人共斗随其伤坏量罪轻重。诸佛如来亦复如是。现伤坏相表无间罪为制法律以戒将来。复次善男子。譬如良医善教其子令学医方。识诸药草根茎华叶香味色像悉令晓了。命终之后其子续立善知医法。诸佛如来亦复如是。种种变化疗治众生。现五逆罪谤毁经法。乃至一阐提辈皆悉化现。为当来故。般泥洹后令诸比丘随顺经律。如如来说。知罪轻重以自戒慎。复次善男子。如人间月六月一食。而上诸天日见月食。或复见月须臾而食。所以者何。天日月长人间短故。诸佛如来亦复如是。或谓长寿如六月食者。及至须臾般泥洹者。为烦恼魔阴魔死魔自在天魔。亿百千种所不能坏现无量生随顺世间。如来之寿实无有量。是故如来是常住法。复次善男子。譬如明月一切众生皆悉爱乐。如来应供等正觉亦复如是。乐法众生悉皆爱乐。复次善男子。譬如日出有三时变春夏冬异。冬日则短春日处中夏日极长。如来应供等正觉日亦复如是。现三种寿。为诸众生声闻缘觉现短寿相。斯等见已心则悲叹。一何怪哉如来短寿。为诸菩萨现其中寿。若至一劫若过一劫。唯佛观佛其寿无量。复次善男子。如来所说方等大乘微密之教。示现世间雨大法雨。于当来世其有众生。以此正法摩诃衍品开示世间。当知是等为真菩萨犹如夏雨。犹如冬日多有冷患令人损寿。声闻缘觉闻佛方便微密之教。为其示现短寿之报。犹如冬日。诸菩萨等成微妙慧。而为彼现如来常法。喻如春日。如是如来随顺世间现三时寿。譬如众星昼日不现其实不没。如是如来与诸声闻及辟支佛。俱出于世俱现泥洹。非独一切声闻缘觉有无常也。当知亦是常住之法如昼星也。复次善男子。犹如天阴日月不现。愚夫谓言日月没失。如来正法灭尽之时三宝现没亦复如是。非为永灭。当知如来是常存法。亦不变易亦不磨灭。非彼诸过所能染污。复次善男子。只如斗星月尽后夜明闇中间暂现光明。众人见已寻即还灭。人谓其灭而实不灭。如是善男子。如来正法灭尽之时。诸辟支佛出兴于世。开示教化无量众生。立于正法寻即灭度。其实长存而不永灭。但诸众生不能悉见。复次善男子。譬如日出众冥悉除。如是善男子。此摩诃衍般泥洹经出兴于世。其有闻者。无间罪业无量积聚皆悉消灭。如是善男子。此摩诃衍大般泥洹甚深境界不可思议。善说如来微妙之性。若善男子善女人。欲知如来是常住法。正法无尽僧宝不灭。当勤方便修学此经。我说此人为近佛地

大般泥洹经卷第五大般泥洹经卷第六

        东晋平阳沙门法显译

    问菩萨品第十七

迦叶菩萨白佛言。何等为菩萨摩诃萨。佛告迦叶。已发意者及未发意。是等一切悉为菩萨。善男子。譬如冬日苏油凝结无有津泽。如是修习一切契经诸余三昧。发心望果而求菩提。是辈名为未发道意。不能速成菩萨之道。所以者何。无勤方便如冬日故。又善男子。如春时日其热猛烈。一切苏油悉皆津泽。其余水结一切镕销。湖池诸水亦复消竭。如是迦叶。若善男子善女人内道外道。若有至心及名闻利养。听此方等大般泥洹戢心历耳。有发菩提未发心者。如斯之等一切身中悉皆津泽为菩提因是故我说。是善男子善女人悉为菩萨。如是方等般泥洹经。功德积聚觉慧无尽。是故我说名为春泽。所以者何。开发如来常住法故。复次善男子。譬如日月光明照曜。诸余光明 悉不复现。如是大乘般泥洹经光明照曜。诸余契经及诸三昧。功德光明悉不复现。是故善男子善女人。闻是方等大般泥洹。虽未 能发无上道心。泥洹日光 已入身中为菩提因。是故名为大般泥洹。迦叶菩萨白佛言。世尊。一切众生必有菩提因缘入身中者。以何等故。世尊。说犯四堕法作无间罪诽谤经法及一阐提。于正法中作毒刺耶

如佛所言。若未发意有菩提因者有何差别。彼四种人应无恶罪。佛告迦叶。除一阐提诸余众生其有闻此大般泥洹方等契经。为菩提因者。当知是等已曾供养无量诸佛故。得闻此经。其余诸罪无能为也。所以者何。此摩诃衍大方便力。开发一切如来性故。迦叶菩萨白佛言。世尊。未发心者。无有乐向闻则背舍。何由得为菩提之因。佛告迦叶。未发意者。虽不乐向而背舍去。犹忆此经心不忘失卧则梦中见大鬼神现恐怖相。咄善男子。当念菩提。若不乐向我当杀汝。彼即惊怖便念菩提。乃至觉已心犹续念。又复彼人命终之后堕泥犁中。见其罪报亦复忆念。堕饿鬼中及生天上亦皆忆念。于彼能发菩提之心。于此大乘般泥洹经。不乐之心从是永灭。如是则为菩提之因。如是为因如是为缘即立菩提。复次善男子。如虚空中兴大云雨。雨于大地枯木山石及诸高源。其水不住流澍下田陂池悉满。众生受用此摩诃衍大乘法雨。雨一阐提如雨木石高源之地。不受菩提因缘津泽。复次善男子。譬如种子熬令干焦。虽复时雨百千万劫不能令生。一阐提辈亦复如是。于此方等般泥洹经。虽百千劫闻。终不能发菩提萌牙。所以者何。如焦谷种善根灭故。复次善男子。譬如明珠着浊水中水即澄清。投之淤泥不能令清。此摩诃衍般泥洹经亦复如是。着诸众生五无间罪犯四堕法浊水之中。犹可澄清发菩提心。投一阐提淤泥之中。百千万岁不能令清起菩提因。所以者何。无善根故。复次善男子。譬如药树名曰药王无所不治。根茎华叶若汁若香。或有人服或复涂身或但闻香。意乐不乐其病悉除。唯除必死之病不能令差。如是善男子。此摩诃衍般泥洹经。一切众生恶业重病悉能疗治。若四堕法无间罪业。及诸外道不乐菩提。闻斯方等一经耳者为菩提因。所以者何。此摩诃衍般泥洹经一切诸恶无不治故。唯除一阐提。所以者何。无菩提因故。犹如人身有伤坏处。苪药得行除众疾病。若不伤坏 苪 药不行。一阐提辈亦复如是。不可伤坏受菩提因。复次善男子。譬如金刚能坏众宝。而力不能坏白羊角。是摩诃衍般泥洹经。成就一切诸恶之法。皆能破坏立菩提因。唯不能破一阐提恶起菩提因。复次善男子。譬如诸树断其枝干寻生如故。如是众生作诸罪业。闻摩诃衍般泥洹经生菩提因。如多罗树断则不生。一阐提辈亦复如是。终不能生菩提柯叶。复次善男子。譬如空中兴大云雨。而彼雨渧不住空中。此摩诃衍般泥洹经普雨法雨。于一阐提雨则不住

  不修真实亦不来　　彼究竟处莫能见
  谓彼诸恶不善业　　则为世间大鄙陋

其善修者谓修菩提。不来者。若自不修终不自得。真实者微密胜业。如是胜业于谁不来谓一阐提。永离善心名一阐提诸增上慢一阐提辈以何为本。诽谤经法不善之业以是为本。诽谤经法凶逆暴害。当知是等智者所畏。譬如险道多诸盗贼。暴慢愚夫不知恐畏。肆意直往为贼所害。大力法王游行此路无有恐畏。不见究竟处者。永不见彼一阐提辈究竟恶业。亦不见彼无量生死究竟之处。我略说彼诸恶积聚。若具闻者甚可怖畏。假令一切众生一时发意成无上道。此诸正觉犹不见彼一阐提辈诸恶究竟。成正觉时复于何等不见究竟。一切众生 破坏生死皆成佛 道。不见诸佛无余泥洹。无常灭尽如灯火灭。谓彼诸恶业世间大鄙陋者。一阐提辈永离菩提因缘功德。斯等名为世间鄙陋。于此大乘最后觉悟得为佛。名是亦鄙陋。诸佛法尔

  已作恶业者　　如萨阇乳酪
  愚者轻被烧　　如灰覆火上

有似阿罗汉一阐提而行恶业。似一阐提阿罗汉而行慈心。有似阿罗汉一阐提者。是诸众生诽谤方等。似一阐提阿罗汉者。毁呰声闻广说方等。语众生言。我与汝等俱是菩萨。所以者何。一切皆有如来性故。然彼众生谓一阐提。而言如来授我等决。汝亦如是。我与汝等皆当俱离无量烦恼众魔恶业如坏水瓶。于此契经必成菩提勿复生疑。譬如烈士奉王使令。至他国中称叹王德。宁失身命要不移易。我等今日亦复如是。如来记说一切众生皆有佛性。我等要当不惜身命。于凡愚中广说此经。是名似一阐提摩诃萨也。若阿练若愚痴无智。状似阿罗汉而诽谤方等。愚騃凡夫谓真阿罗汉谓是大士。是恶比丘示现空闲阿练若处。而自处置似真阿罗汉。于阿练若行永不随顺。而作异说起四因缘。言方等经皆是魔说。言摩诃衍者是诸黠慧正法刺剑。诸佛世尊皆当无常而说常住。当知是为毁灭正法破僧之相。作是说者名一阐提。是故说言

  已作恶业者　　如萨阇乳酪
  愚者轻被烧　　如灰覆火上

如是善男子。当知方等般泥洹经。诸佛如来决定之说。摩诃衍者。最为无上如摩尼珠明净离垢。复次善男子。譬如莲华日光照已无不开敷。一切众生亦复如是。此摩诃衍般泥洹经。一闻经耳。若未发意不乐菩提。是等必为菩提之因。彼一阐提于如来性所以永绝。斯由诽谤作大恶业。如彼蚕虫绵网自缠而无出处。一阐提辈亦复如是。于如来性不能开发起菩提因。乃至一切极生死际。复次善男子。如优钵罗钵昙摩拘牟头分陀利生淤泥中。而不为彼淤泥所污。若有众生修摩诃衍般泥洹经亦复如是。不为烦恼之所污染。所以者何。如来之性不受染故。复次善男子。譬如国土清凉风起。一切众生身诸毛孔。遇斯风者热恼悉除。如是善男子。此摩诃衍般泥洹经甘露法味。一切众生无不蒙润发菩提因。除一阐提。复次善男子。譬如良医解八种术。一切诸病皆悉能治。唯除阿萨阇病。如是善男子。一切契经及诸三昧。能治一切淫怒痴等诸烦恼病。而不能治犯四重禁无间罪业。善男子。复有良医过八种术。一切众生诸有疾病。命行未尽悉能疗治。唯命行尽不能令差。此摩诃衍般泥洹经亦复如是。一切众生诸烦恼患。乃至不乐菩提未发心者。悉皆能治令发菩提。唯除一阐提辈。复次善男子。譬如盲人不见五色。良医能治令目开明。唯不能疗彼生盲者。此摩诃衍般泥洹经亦复如是。一切众生声闻缘觉。不乐菩提未发心者。悉皆疗治令开慧眼发菩提心。唯除生盲一阐提辈。复次善男子。譬如良医过八种术。一切众生有疾病者。书其咒术着于身上。能令诸病悉得除愈。此摩诃衍般泥洹经亦复如是。一切众生诸烦恼患。不乐菩提未发意者。及四重禁无间罪业。皆能除灭安立菩提。迦叶菩萨白佛言。世尊。犯四重禁及无间罪。如截多罗树。及不乐菩提未发心者。云何能令发菩提因。佛告迦叶。是诸众生若于梦中若命终时。堕泥犁中而生悔心。哀哉我等毁犯正法自招此罪。而生誓心。于此得免生余处者。在在处处要当发心为菩萨道。是摩诃衍般泥洹经威神力故。是等众生生天人中。必得发心为菩提因。是故我说犯四重禁及无间业。皆得发心为菩提因。复次善男子。譬如良医合和诸药名阿伽陀。如此良药。在所著处。一切诸毒皆悉消歇。唯除一种增上毒蛇。不能消伏。此摩诃衍般泥洹经亦复如是。一切憍慢四种毒蛇。犯四重禁及无间业。不乐菩提未发意者。皆悉安立于菩提道。所以者何。此摩诃衍般泥洹经。最为无上第一良药故。唯除增上毒蛇一阐提辈。复次善男子。譬如良医合和诸药以涂其鼓。若有众生斗战被疮。闻彼鼓声一切悉愈。唯除命尽必应死者。此摩诃衍般泥洹经。法鼓音声亦复如是。一切众生闻其音声。淫怒痴箭不乐菩提未发意者。犯四堕法及无间罪一切除愈。唯除一阐提辈。复次善男子。譬如夜闇阎浮提人一切家业皆悉休废。日光出已其诸人民得修家事。如是众生闻诸契经及诸三昧。犹如夜闇闻此大乘般泥洹经微密之教。犹如日出见诸正法。如彼田夫遇夏时雨。摩诃衍经无量众生皆悉受决现如来性。八千声闻于法华经得受记别。唯除冬冰一阐提辈。复次善男子。犹如有人为非人所持。若被恶毒。而得良医。或遣咒术或遣咒药彼患即消。如是善男子。此摩诃衍般泥洹经。若比丘比丘尼乃至外道。在在处处若书经卷为人演说。其有众生若读若闻。斯等皆为菩提之因。不乐菩提未发道意。及四重禁五无间罪。诸邪恶毒皆悉消灭。唯除一阐提辈。复次善男子。犹如大王身中有虫密食其肉而王未觉。时有良医知其病相。语彼王言。身中有患应疾治之。时王不信不欲令治。其师畏怖不敢与药。密加咒术令虫自落。王见病已乃信师语厚相待遇。诸众生等亦复如是。闻摩诃衍般泥洹经。不乐菩提及未发意。诸佛菩萨方。便为说。虽不即受。而于梦中若命终时。便自觉悟发菩提因。除一阐提。复次善男子。譬如良医善教其子学八种术。上要秘方隐而未授。知八种术善通达已。然后悉教上要秘方。如来应供等正觉亦复如是。教法王子比丘比丘尼优婆塞优婆夷。先学灭除无量烦恼。于身修习不坚固想。众苦积聚无常变坏空无我所。又复教学九部契经令善通利。然后教学此摩诃衍般泥洹经。令知众生有如来性是常住法。悉发无上菩提之因。除一阐提。如是善男子。此摩诃衍般泥洹经。无量无数不可思议。当知此经无上之术良医秘要。复次善男子。譬如船师乘船度人。到彼岸已还度余人。诸佛如来亦复如是。乘摩诃衍般泥洹船。随彼众生应受化者而济度之。般泥洹已复于余处度诸众生。是故如来名大船师。是故如来为常住法。为度人故现有出没。复次善男子。如人乘船欲度大海。若得利风速到彼岸。若不得风。或经年岁。或能溺死。如是众生得摩诃衍般泥洹风。速度生死到菩提岸。若不得者永溺生死轮回苦海。复次善男子。如人入海遇值波浪。计无济理端坐待死。忽遇风王吹到一国不觉闇至。欣庆无量生奇特想。如是此摩诃衍般泥洹经为大风王。众生不知而不乐向发菩提心。般泥洹风密吹令至菩提境界。方知真实生奇特想。复次善男子。如蛇脱皮更游余处而实不死。如是善男子。如来泥洹舍彼故身如脱皮去。是故如来名为善逝。舍毒药树方便之身。或复于余阎浮提方便现化。是故善男子。当知如来是常住法。复次善男子。譬如金师得好真金。随意能造诸庄严具种种器服。诸佛如来亦复如是。随彼受化于二十五有。悉能现身而度脱之。是故如来名无量身。亦名常住。复次善男子。如庵罗树及阎浮树于三时变。有时茂叶有时华果有时衰落。非为彼树枯而更生。如是善男子。如来应供等正觉方便之身。为教化故亦三时现。示有出生成佛现般泥洹。其实常存而不灭尽。善男子。如来密身其如此也。如来密口方便密教亦复难知。方便密教者。善男子。譬如大王命诸群臣。亦有如是隐密之教。如有时言持先陀婆来。而先陀婆一名四实。一者盐。二者澡槃。三者马。四者剑。是四种物皆名先陀婆。若王食时命其左右索先陀婆。诸臣应知王必索盐。若王食已索先陀婆。诸臣应知必索澡槃。欲诣林园索先陀婆。诸臣应知王必索马。临阵斗时索先陀婆。诸臣应知必索利剑。王有如是隐覆之言。诸臣亦应知其旨趣。如是善男子。此摩诃衍隐密之教。亦有四种如说无常。其诸善男子。应知如来生阎浮提。当现泥洹是摩诃衍修无常想。若当如来说正法灭。其诸弟子应作是知。如来说苦此摩诃衍修行苦想。如来说身为众患器。又言僧宝亦当归灭。其诸弟子应作是知。佛说无我此摩诃衍修无我想。若说无想空无所有及解脱者。其诸弟子应作是知。此摩诃衍说二十五有而得解脱。是故说空。众苦悉灭说无所有。极乐无想无常变易所不能坏。是故名为常住非变易法。当知解脱即是如来。其如来者即如来性。一切众生身中悉有。如是知者是我弟子。善解如来微密之教。复次善男子。譬如天旱。药草香华甘果树木。皆悉萎悴不成果实。诸余一切水陆草木。亦皆枯干而无光泽。又于来年复难生长。如是善男子。此摩诃衍般泥洹经。我灭度后。其诸弟子。如旱天华果不能成实。如被贼城亡失真宝守糠[禾*會]聚。众恶比丘既失宝已。抄略撰集不善解义宽纵慢堕。哀哉大险。当来之世甚可怖畏。快哉大利。当来众生此摩诃衍般泥洹经得闻其耳。随所闻经受持讽诵。解其义趣广为人说因斯当得真实菩提。复次善男子。如有国土城邑聚落有卖乳者。或持水杂欺诳他人而求财物。其贩乳者亦复如是。以水杂卖展转相欺。人买食之无有乳味。如是善男子。我泥洹后正法未灭八十余年。此摩诃衍般泥洹经于阎浮提流行于世。诸恶比丘宽纵懈怠。众魔伴党坏乱正法。自造经论偈赞颂叹。以非为是。以是为非。抄略增损。为利养故欲多畜积非法财物。坏乱正味令法薄淡。加复邪说文字不正。误受学者。亦不尊重供养恭敬。内怀邪谄。为利养故现乐法相。此摩诃衍般泥洹经。当于尔时为斯等辈之所毁辱。复次迦叶。以斯义故。善男子善女人于摩诃衍般泥洹经当勤方便立丈夫志。所以者何。如来性者丈夫法故。女人志者于一切法多生染着。力不堪任发摩诃衍深经妙味。善男子。譬如蚊蚋身出津泽。不能令此大地润洽。其女人法犹如大地多诸渴爱。譬如大海一切天雨百川众流皆归于海。而彼大海未曾满足。女人之法亦复如是。贪受五欲而无厌足。是故迦叶。若善男子善女人欲得方便离女人法。当勤修习此摩诃衍般泥洹经。所以者何。此摩诃衍般泥洹经说如来性丈夫法故。若有众生不知自身有如来性。世间虽称名为男子。我说此辈是女人也。若有女人能知自身有如来性。世间虽称名曰女人。我说此等为男子也。如是善男子。此 摩诃衍般泥洹经。无量无边功德积聚。广说众生有如来性。若善男子善女人欲得疾成如来性者。当勤方便修习此经。迦叶菩萨白佛言。善哉世尊。我今修习般泥洹经。始知自身有如来性。今乃决定是男子也。佛告迦叶。善哉善哉。善男子。当勤方便学此深法。如蜂采华尽深法味。譬如迦叶。蚊虫津泽不能令此大地沾洽。如是善男子。当来之世众恶比丘坏乱经法。无数无量如高旱地。非此大乘般泥洹经所能津润。所以者何。当知正法灭尽衰相现故。复次善男子。譬如夏末冬初秋雨连澍温泽潜伏。如是善男子。此摩诃衍般泥洹经。我般泥洹后正法衰灭。于时此经流布南方。为彼众邪异说非法云雨之所漂没。时彼南方护法菩萨。当持此契经来诣罽宾潜伏地中。及诸一切摩诃衍方等契经于此而没。哀哉是时法灭尽相。非法云雨盈满世间。修习如来恩泽法雨。护法菩萨人中之雄皆悉潜隐。尔时迦叶菩萨白佛言。世尊。诸佛如来声闻缘觉性无差别。唯愿广说令一切众生皆得开解。佛告迦叶。譬如有人多养乳牛。青黄赤白各别为群。欲祠天时集一切牛。尽 [穀-禾+牛] 其乳着一器中同一珂色。 如是善男子。诸佛如来声闻缘觉。其性清净皆同一色。所以者何。同漏尽故。譬如金师取其金矿种种异色。销镕精炼纯一金色。所以者何。无量无数粗矿烦恼皆消灭故。是故当信此摩诃衍般泥洹经。一切众生皆有真实如来之性悉同一色。迦叶菩萨白佛言。如世尊说。一切众生皆有佛性而无差别。于此未了。且置众生。如世尊说。声闻缘觉及诸菩萨不得大般泥洹。唯有如来得此大般泥洹。是故当知非声闻缘觉及诸菩萨同如来也。若无差别。云何世尊独于无量阿僧祇劫。修行方便积累功德。佛告迦叶。我先所说。是则如来方便密教。言诸声闻不得泥洹。是故当知一切皆以此大般泥洹经。而般泥洹 唯佛境界 。是故此经名大般泥洹。迦叶菩萨白佛言。世尊。是则为异。如佛所说声闻缘觉及诸菩萨。皆当悉归如来泥洹。犹如百川归于大海常住之法。佛告迦叶。我最常也。迦叶白佛。云何世尊。如来之性不异异耶。佛言。有异。迦叶白佛。云何为异。佛告迦叶。譬如牛乳。一切声闻如来之性亦复如是。犹如成酪。一切缘觉如来之性亦复如是。犹如成苏。菩萨摩诃萨如来之性亦复如是。犹如醍醐。诸佛如来其性亦然。如是善男子。此摩诃衍般泥洹经四种差别。迦叶菩萨白佛言。世尊。一切众生其性云何。佛告迦叶。如乳未成与水血合。无量烦恼覆蔽如来真实之性。迦叶菩萨白佛言。如世尊说。拘夷城有旃陀罗。名曰欢喜。当成佛道于此世界千佛之数。世尊记别一发念顷便成佛道。以何等故。世尊不记尊者舍利弗目揵连等速成佛道。佛告迦叶。或有声闻及辟支佛诸菩萨等不发速愿。护持正法有速愿者。斯等发愿有差降故。因菩提力世尊记别速成佛道。复次善男子。譬如商人载摩尼宝。道路经由野人聚落唱卖珍宝。诸野人辈。闻声来看见宝不识。即便大笑谓为塼石。如是善男子。如来记别诸声闻等。当成佛道得最胜处。当来之世有诸比丘。宽纵懈怠不识真宝犹如野人。疾病困苦贫穷出家。信心浅薄邪命谄曲。若闻如来授声闻决即便大笑。当知是辈为沙门像非真沙门。是故善男子。或有发愿速持正法。又复不发速持愿者。是故如来随其迟速而授彼记。迦叶菩萨白佛言。世尊。菩萨摩诃萨云何当得不坏眷属。佛告迦叶。勤修方便护持正法。是为菩萨摩诃萨人中之雄不坏眷属。迦叶菩萨白佛言。世尊。何等众生不知六味。佛告迦叶。不知三宝始终长存。是等众生不知六味。如人口爽不知甜苦辛酢咸淡六味差别。一切众生亦复如是。愚痴无智不知三宝是长存法。是故名为不知味者。复次善男子。其诸众生不知如来是常住法。我说斯等名为生盲。肉眼众生知如来性是常住者。我说是等名为天眼。若有众生闻摩诃衍能信乐者。我说是等亦名天眼。正使众生有天眼者。不知如来是常住法。我说斯等名为肉眼。所以者何。如来之性常住真实。而彼不能勤修习故。复次善男子。当知如来为一切众生而作父母。所以者何。一切众生种种形类悉能化现。同其境界而为说法。一音说法彼彼异类各自得解。叹言善哉。如来以我音声说法。复次善男子。如人生子始十六月言语不正。而彼父母欲教其语。先同其音渐渐教学。当知父母非实不正。诸佛如来亦复如是。为教化故同彼形类音声语言。然其如来不实同彼。方便示现随顺世间

    大般泥洹经随喜品第十八

尔时世尊。从其面门放种种色光普照四众。光明照已。纯陀长者便疾奉施如来大众最后供养。尔时纯陀与诸眷属得大欢喜举声叹曰。哀哉希有。供养如来难复再遇。即以种种众宝之钵。盛上味饭持来向佛。当于尔时有大威神天而遮其前。谓纯陀言。勿便供养。愿令我等复得须臾瞻睹如来。尔时世尊复放光明照彼天子。时彼天神承佛圣旨听纯陀前。尔时天人及诸众生种种杂类。各异音声内怀悲感哀声动地。与纯陀俱供佛及僧。奉施最后檀波罗蜜。尔时世尊欲令比丘比丘尼及诸众会知时到故。复放光明悉照众会。时诸比丘知时已至。各整威仪执持应器如受施法。纯陀长者为佛及僧布置种种众宝床座。悬缯幡盖香华璎珞。尔时三千大千世界庄严殊妙。犹如西方极乐国土。纯陀长者住于佛前忧悲怅怏重白佛言。唯愿世尊犹可哀愍住寿一劫若过一劫。佛告纯陀。汝欲令我久住世者。宜知是时当疾供设最后檀波罗蜜。纯陀白佛。唯然世尊。尔时一切众生异类。天人菩萨同声唱言。奇哉纯陀。为最后施。奇哉纯陀。为极大施。然今我等所设供具。于兹便成无用之物。各各叹恨愁忧苦恼

尔时世尊。自身毛孔一一皆出无量化佛。一一皆有比丘眷属。应彼一切令得供养。时诸众生皆大欢喜。尔时纯陀所设供具承佛威神。诸来大会皆得充足。纯陀欢喜而自念言。今日如来一切大众。皆悉受我最后供养。然后如来当般泥洹。其余众生亦作是念。今日如来与诸大众。受我最后饭食供养。然后泥洹不受余请。是时坚固林侧其地狭小。以佛神力故。如针锋处皆有无量诸佛。及其眷属于中坐食。尔时天人阿修罗众。皆大悲叹而作是言。今日如来受我最后饭食供养当般泥洹。我等复当何所奉事。哀哉我等孤无荫护。尔时世尊。即为一切而说偈言

  汝等莫悲叹　　诸佛法应尔
  虽曰为泥洹　　亦未究竟尽
  如来常住法　　永处最安隐
  诸有狐疑者　　谛听我今说
  我已离食想　　身无饥渴患
  我今当为汝　　说其随喜法
  令一切众生　　得安隐快乐
  诸佛如来性　　真实常住法
  今汝等闻已　　当勤方便修
  如乌及鸱鸟　　其性甚相违
  能令同群游　　止宿相娱乐
  如来视一切　　犹若罗睺罗
  应当舍慈悲　　永入于泥洹
  能令盛毒蛇　　兔罗同其穴
  如来舍慈悲　　永入于泥洹
  能令伊兰树　　同百叶华香
  如来舍慈悲　　永入于泥洹
  能令迦留果　　味同耽摩罗
  如来舍慈悲　　永入于泥洹
  能令一阐提　　悉成平等觉
  如来舍慈悲　　永入于泥洹
  若一切众生　　一时成佛道
  如来舍慈悲　　永入于泥洹
  假使蚊蚋水　　浸坏此大地
  百川皆流溢　　大海悉盈满
  如来舍慈悲　　永入于泥洹
  汝等诸众生　　深乐正法故
  谓如来永灭　　忧悲而愁叹
  从今于如来　　莫念非常想
  当知如来性　　长存不变易
  法僧亦复然　　皆非磨灭法

如是善男子。此三法者常住不变真谛之言。一切众生遭诸恐怖。此真谛说能令安隐。欲度一切险难旷野。此真谛说能令得度。此真谛说能令枯树更生华叶。若此四众闻是三法常住随喜说者。设未发意不乐向者。斯等皆为菩提之因。三法常住。是为如来最妙随喜诚谛之说。若比丘比丘尼能为一切众生解说三法常住。当知是等堪受一切罗汉供养。若异此者则不堪受。乃至一切旃陀罗等。乐闻如来随喜说者。亦复得离诸忧恐怖。尔时天人阿修罗等。闻说如来为常住法。心得欢喜。心得柔软。心得真实。心离阴盖。心得清净。颜貌怡悦如莲华敷。散诸天华烧众名香。鼓天伎乐供养如来及比丘僧。尔时世尊告迦叶言。善男子。汝见何等希有之事。迦叶菩萨白佛言。唯然世尊。我见奇特未曾有事。见一切诸天人民阿修罗等设供具者。各得如来与诸大众受其饮食。又见是中其地狭小容诸如来大众床座。一针锋处乃有无量诸佛眷属。而受供食说随喜偈。彼诸众生各不相知。而谓如来独受我请。而今世尊与诸大众哀愍纯陀。受彼最后檀波罗蜜。佛神力故令此大众皆得满足。然其世尊实不揣食。唯诸菩萨摩诃萨。文殊师利法王子等人中之雄。能知如来方便现化。为此奇特未曾有事。声闻缘觉所不能知。甚奇世尊。无数无量如来常法。尔时世尊告纯陀言。汝见奇特未曾有不。纯陀白佛。唯然已见。向见如来三十二相八十种好庄严其身。如是如来无量无数。与诸菩萨眷属围绕。今见世尊真实之身。独处大众犹如药树。与诸菩萨前后围绕。佛告纯陀。向者诸佛皆是现化。哀愍安乐一切众生开其意故。令彼功德不可得尽作此现化。而诸众生悉不能知。唯诸菩萨成就无量菩萨功德。人中之雄。能知如来方便现化。汝今纯陀。亦复成就菩萨功德十地之行。纯陀白佛。如是世尊。我等皆当修习菩萨一切随喜。佛告纯陀。莫随贪果如余契经。纯陀白佛。诸余契经为非经耶。佛告纯陀。彼说有余。纯陀白佛言。其义云何。佛告纯陀。如我所说

  一切叹布施　　无有呵施者
  施犯戒福少　　施持戒福增

我说是契经。虽叹一切施而施有差降。施犯戒者无毫厘福。布施持戒获其大果不必悉同。纯陀白佛。云何世尊。而说斯偈一切赞叹布施功德。佛告纯陀。除一种人叹一切施。纯陀白佛。除何等人叹一切施。佛告纯陀。除一阐提犯戒谤法。叹一切施。纯陀白佛。何等名为一阐提。佛告纯陀。若比丘比丘尼优婆塞优婆夷。诽谤经法口说恶言永不改悔。于诸经法心无归依。如是等人向一阐提道。若复众生犯四重禁作无间罪。不自改悔而无惭耻。彼于正法永无护惜。不与护法之人以为知识。于诸善事未曾赞叹。若复邪见无佛法僧。我说斯等向一阐提道。除斯等类叹一切施。纯陀白佛。何名犯戒。佛告纯陀。犯四重禁五无间业诽谤正法。纯陀白佛言。如此重罪有差降耶。佛言。有差降。彼虽犯戒尚服法衣而生惭愧。咄哉我今犯斯重罪。何其怪哉造斯大苦。而怀恐怖生护法心。我当赞叹护诸法者。当复降伏诸非法者。于方等经诸禅三昧方便勤修。若如是者我说斯等为不犯戒。所以者何。如日光出微尘障翳皆悉不现。如是修习此摩诃衍契经日光。无数无量众罪积聚皆悉消灭。是故此经说护法者得大果报。若不尔者。是则名为最大犯戒。若施此等无毫厘福。复次善男子。犯四重禁能知真实如来之性兴护法心。若施此等所以得大果报者何。譬如有女人国土荒乱。将一婴儿欲至他国。道遇大水泛涨流漫携儿而度水流漂急。不舍其儿母子俱溺。然彼女人曾作大恶。以护子功德命终生天。如是善男子。犯四重禁五无间业。深自悔责兴护法心。本作不善获恶之业。以护法故得为福田堪受信施。护法功德亦得大果。纯陀白佛言。世尊。若一阐提还生信心悔过三尊。若人施与得大果不。佛告纯陀。莫作是语。譬如有人食庵罗果。并取其核坏而食之。持彼空核种着地中。虽复溉灌终不得生。彼一阐提亦复如是。坏善种子欲令改悔生其善心。无有是处。是故名为一阐提也。布施持戒得大果者果亦不同。所以者何。布施声闻及辟支佛。所得果报皆有差别。唯施如来获最上果。是故说言。非一切施得大果报。纯陀白佛言。何故世尊而说此偈。佛告纯陀有因有缘。时王舍城有不信优婆塞奉事尼揵。而来问我布施之义。我摄彼故为说斯偈。当知如来方便密说为菩萨故。非是一切。悉能了知。是故菩萨人中之雄。当于如来有余说中分别其义。降伏一切诸犯戒人。如除稊稗害善苗者。复次善男子。如我所说偈

  一切江河必回曲　　一切丛林必树木
  一切女人必谄伪　　一切大力必安乐

尔时文殊师利。即从坐起整衣服为佛作礼。而说偈言

  非一切河必回曲　　非一切林必树木
  非悉女人心谄伪　　非为大力悉安乐

如是世尊略说法门非决定说。所以者何。此三千世界中阎浮提外余阎浮提。有正直河。其直如绳。从其西海直至东海。如方等阿含中说。是则如来有余之说。一切丛林必树木亦有余说。所以者何。林有二种。亦有金银琉璃宝树之林。一切女人必谄伪者亦有余说。有诸女人持戒清净其心质直。一切大力必安乐亦有余说。如来法王最为大力名为安乐。转轮圣王及诸天神。亦名大力而不安乐。是故当知非一切大力皆为安乐。唯有常住非变易法大力泥洹安隐快乐。譬如良医与彼病者醍醐令服。时彼病者请良医言。更与我药我堪食之。良师答言。但食尔许消已更食。若顿食不消或能杀人。时彼良师实哀病者恐其死故。如是如来慈哀愍伤。欲灭波斯匿王大臣夫人高慢心故。说此偈言

  一切江河必回曲　　一切丛林必树木
  一切女人必谄伪　　一切大力必安乐

当知世尊言无漏失。如此大地可令反覆。如来之言终无有失。是故一切有余无余。皆是如来摄众生故。佛言。善哉善哉。文殊师利。哀愍一切诸众生故。广说如来有余无余。尔时文殊师利复于佛前。而说偈言

  于他善随顺　　不观作不作
  但自观身行　　谛视善不善

如是世尊。说此正法亦复非为究竟之说。所以者何。众邪外道皆向泥犁。然佛世尊教诸弟子皆向泥洹。若生天上此则名为毁誉之说。如是种种不随顺说。云何世尊。偈中说言。于他善随顺。尔时佛告文殊师利。我所以说善随顺者。有因有缘。时阿阇世王害父王已。来诣我所而问我言。云何世尊。为一切智非一切智耶。若一切智者。提婆达多于百千生中于如来所常怀恶心。云何听使而得出家。我即为彼而说此偈。于他善随顺。彼阿阇世王。有害父罪而不自觉。如来欲使自省己过令其罪轻。是故说言。但自观身行。谛视善不善。汝今云何见不随顺。若有持戒修行慈心而观彼过。是则诸佛如来之法。欲令己身及诸众生悉皆安乐。是以应观他作不作己身亦然。常作是观是我弟子。尔时世尊。复语文殊师利言。如我说偈

  一切皆惧死　　莫不畏杖痛
  恕己可为譬　　勿杀勿行杖

尔时文殊师利复于佛前。而说偈言

  非一切惧死　　一切畏杖痛
  亦不悉喻己　　而恕彼众生

如是世尊。略说法门亦非究竟。所以者何。如阿罗汉转轮圣王玉女象马大臣之宝。若诸天人及余众生能加害者无有是处。勇士烈女野马兽王持戒比丘。虽有对至而不恐怖。一切皆惧死莫不畏杖痛。是则有余说。又复不可以己喻彼。所以者何。若阿罗汉以己喻彼则为命想。若命想者此非上士。计命想者愚夫邪见向恶趣门。又复罗汉我及众生空无所有。谁死谁杀。起害想者。无有是处。而彼所说我为喻者。为有我喻。为无我喻。若是我喻则为下劣。若无我喻是阿罗汉无有譬喻。然佛世尊。不以无因而妄说法。有王舍城大猎师主杀生。供施请佛及僧唯愿哀受。然佛世尊未曾食肉。等视一切如罗睺罗。即为猎师。而说此偈

  当观长寿者　　不害众生故
  一切皆惧死　　莫不畏杖痛
  恕己可为喻　　勿杀勿行杖

佛言。善哉善哉。文殊师利。人中之仙安慰众生。善说如来方便密教。尔时文殊师利。复说偈言

  恭敬于父母　　增加其供养
  缘斯孝道故　　死堕无择狱

世尊。此偈说无明恩爱以为父母。众生随顺令其增长造诸恶业。死即当堕无择地狱。尔时世尊复告文殊师利。如我所说偈

  一切因他势力苦　　一切己力自在乐
  一切憍慢势暴害　　一切贤善人所爱

文殊师利。复说偈言

  非一切因他力苦　　亦非己力自在乐
  非一切慢势暴害　　非一切贤人所爱

此是世尊。略现法门非究竟说。所以者何。如庶民子从师而学。俯仰进止悉由于师。道艺既成永得安乐。如王者子己力自在。不随他教愚闇常苦。所以如来说此偈者。其诸众生为魔所持不得自在。如来为彼而说此偈。是故当知非为一切他力故苦。亦非一切己力故乐。一切憍慢势暴害者。此亦有余说。非一切慢为尽暴害。犹如有人憍慢傲俗。出家学道或计福德持戒清净。当知是等虽为憍慢非为暴害。一切贤善人所爱者。亦有余说。如内法中犯四重禁。能自克励执持威仪虽修贤行。以破正业人所不爱。何因世尊而说此偈。尔时佛告文殊师利。诸佛如来不以无因而妄说法。时王舍城有拘邻女名须跋陀罗。恶厌世俗。来诣佛所欲求出家。女人之法不得自在制由男子。自归三宝。佛知其意。亦知是时而说此偈。一切由他势力苦。善哉善哉。文殊师利人中之仙。能问如来方便密教。文殊师利。复说偈言

  一切众生类　　皆依饮食存
  一切诸婴儿　　悉无吝惜心
  一切诸世间　　揣食增其病
  一切行法者　　同止得安乐

如是世尊。今受纯陀饭食供养将无增患。尔时世尊复为文殊师利。而说偈言

  非一切众生　　皆依饮食存
  非一切婴儿　　悉无吝惜心
  非一切世间　　揣食增其病
  非一切行法　　同止得安乐

汝文殊师利。所得病者我当得病。诸阿罗汉及辟支佛菩萨如来悉不揣食此则诸佛如来定法。若言罗汉及辟支佛菩萨如来曾揣食者。坏大士义。而受众生百千布施。赞叹一切布施功德。欲济众生度三恶道无边苦海。虽不揣食而常叹施。欲令众生成檀波罗蜜。端坐树下六年苦行。岂谓不食而形瘦耶。勿谓如来众生同数。如来已度爱欲诸流。不同世人境界行处。如来境界不可思议。声闻弟子亦复如是。言揣食者是有余说。一切婴儿离悭惜者。亦有余说。乃有无量永离悭心无动快乐。一切揣食增其病者。亦有余说。外来之病剑刺疮疣其数无量。一切行法同止安乐者。亦是如来有余之说。其法多种。亦有修习世俗善法。身口意业种种净法种种信心。而共同止不相随顺。是故当知诸佛如来。不以无因缘故违义而说。以教化故方便说法。时有半头梵志。与诸同止修天祠斋法。来诣佛所。为降伏彼令舍异见。而说此偈。尔时迦叶菩萨白佛言。云何世尊。诸余契经皆是如来有余说耶。佛言不也。善男子。若有众生功德成就善解深法。如来为说常住安乐无余之法。诸余众生乐闻法者。如来为彼或有余说或无余说。迦叶菩萨即大欢喜白佛言。奇哉世尊。等视众生犹如一子。佛告迦叶。善哉。善男子。应当如是谛解深法。迦叶菩萨白佛言。世尊。唯愿如来。说此方等般泥洹经所得功德。佛告迦叶。此摩诃衍般泥洹经。闻其名者所得功德。非是声闻及辟支佛能究竟说。此摩诃衍般泥洹经所生功德不可思议。唯是诸佛如来境界。尔时诸天世人及阿修罗。即于佛前一心同声。以偈颂曰

  如来天中天　　甚深难思议
  如来之所说　　方等泥洹经
  出生诸功德　　亦不可思议
  正法难思议　　僧宝亦复然
  唯愿天中天　　哀愍小留住
  上座尊迦叶　　眷属须臾至
  尊者阿难陀　　多闻大仙士
  及摩竭提王　　国王阿阇世
  斯等于如来　　最亲密弟子
  彼诸正士等　　必怀疑惑想
  如来为泥洹　　为当长存世
  此等心怀疑　　于何而取定
  愿哀须臾住　　待至为决疑

尔时世尊为诸大众。而说偈言

  诸怀疑惑者　　汝等勿忧虑
  我法生长子　　上座大迦叶
  阿难多闻士　　是等须臾至
  要令彼见我　　我当般泥洹
  如斯智慧士　　观如来双足
  彼自知我身　　常无常真实

尔时一切大众眷属。供养如来天缯华盖。烧众名香作天伎乐。其数无量不可为喻供养佛已。万恒河沙诸众生等发阿耨多罗三藐三菩提心。住于菩萨最初住地。纯陀长者欢喜踊跃。菩提甘露以灌其顶。尔时世尊告文殊师利法王子迦叶菩萨纯陀菩萨。汝善男子。自修其心慎莫放逸。我今背疾举身皆痛欲须燕卧。汝文殊师利。当为一切四众说法。如来正法今付嘱汝乃至上座摩诃迦叶及阿难到。汝当广说。于是世尊。化众生故现身有疾。右胁着地系念明想

大般泥洹经卷第六


佛说当来变经

    No. 395

佛说当来变经

         西晋月氏国三藏竺法护译

闻如是。一时佛在舍卫国祇树给孤独园。与大比丘众俱。比丘五百及诸菩萨

尔时世尊告诸比丘。将来之世当有比丘。因有一法不从法化。令法毁灭不得长益。何谓为一。不护禁戒。不能守心。不修智慧。放逸其意。唯求善名不顺道教。不肯勤慕度世之业。是为一事。令法毁灭

佛告比丘。复有二事令法毁灭。何谓为二。一不护禁戒。不摄其心不修智慧。畜妻养子放心恣意。贾作治生。以共相活。二伴党相着。憎奉法者欲令陷堕。故为言义谓之谀谄。内犯恶行。外佯清白。是为二事。令法毁灭

佛告诸比丘。复有三事。令法毁灭。何谓为三。一既不护禁戒不能摄心不修智慧。二自读文字不识句逗。以上着下以下着上。头尾颠倒不能解了义之所归。自以为是。三明者呵之不从其教反怀嗔恨。谓相嫉妒。识义者少。多不别理咸云为是。是为三事。令法毁灭

佛告诸比丘。复有四事。令法毁灭。何谓为四。一将来比丘 已舍家 业 在空闲处不修道业 。二喜游人间愦闹之中行来谈言。求好袈裟五色之服。三高听远视以为绮雅。自以高德无能及者。以杂碎智比日月之明畜已。四不摄三事。不护根门。行妇女间。宣文饰辞。多言合偶。以动人心。使清变浊。身行荒乱。正法废迟。是为四事。令法毁灭

佛告比丘。复有五事。令法毁灭。何谓为五。一或有比丘。本以法故出家修道。废深经教十二因缘三十七品。方等深妙玄虚之慧。智度无极。善权方便。空无相愿至化之节。二反习杂句浅末小经。世俗行故。王者经典乱道之原。好讲此业。易解世事。趣得人心令其欢喜 。因致名闻 三 新闻法人。浅解之士意用妙快。深达之士不用为佳。四天龙鬼神不以为喜。心怀悒戚口发斯言。大法欲灭故使其然。舍妙法化反宣杂句。诸天流泪速逝而去。五由是正法稍稍见舍无精修者。是为五事。令法毁灭

佛告比丘。吾灭度后。有此邪事十五之乱令法毁灭。一何痛哉。若有比丘欲谛学道。弃捐绮饰不求名闻。质朴守真宣传正经。佛之雅典深法之化不用多言。案本说经不舍正句。希言屡中不失佛意。粗衣趣食。得美不甘得粗不恶。衣食好丑随施者意不以嗔喜。摄身口意守诸根门不违佛教。念命甚矩恍惚以过。如梦所见觉不知处。三涂之难不可称计。勤修佛法犹救头然。五戒十善六度无极。四等四恩智慧善权。咸可精行。虽不值佛世出家为道学不唐捐。平其本心愍念一切十方蒙恩。佛说如是。诸比丘悲喜前自归佛。作礼而去

佛说当来变经


佛说法灭尽经

    No. 396

佛说法灭尽经

         僧祐录中失译经人名今附宋录

闻如是。一时佛在拘夷那竭国。如来三月当般涅槃。与诸比丘及诸菩萨。无央数众来诣佛所稽首于地。世尊寂静默无所说光明不现。贤者阿难作礼白佛言。世尊前后说法威光独显。今大众会光更不现。何故如此。其必有故。愿闻其意。佛默不应。如是至三佛告阿难。吾涅槃后法欲灭时。五逆浊世魔道兴盛。魔作沙门坏乱吾道。着俗衣裳乐好袈裟五色之服。饮酒啖肉杀生贪味。无有慈心更相憎嫉。时有菩萨辟支罗汉。精进修德一切敬待。人所宗向教化平等。怜贫念老鞠育穷厄。恒以经像令人奉事。作诸功德志性恩善。不侵害人捐身济物。不自惜己忍辱仁和。设有是人。众魔比丘咸共嫉之诽谤扬恶。摈黜驱遣不令得住。自共于后不修道德。寺庙空荒无复修理转就毁坏。但贪财物积聚不散不作福德。贩卖奴婢耕田种植。焚烧山林伤害众生无有慈心。奴为比丘。婢为比丘尼。无有道德淫劮浊乱男女不别。令道薄淡皆由斯辈。或避县官依倚吾道。求作沙门不修戒律。月半月尽虽名诵戒。厌倦懈怠不欲听闻。抄略前后不肯尽说。经不诵习。设有读者不识字句。为强言是。不咨明者贡高求名。虚显雅步以为荣冀望人供养。众魔比丘命终之后。精神当堕无择地狱。五逆罪中。饿鬼畜生靡不经历恒河沙劫。罪竟乃出生在边国无三宝处。法欲灭时女人精进恒作功德。男子懈慢不用法语。眼见沙门如视粪土无有信心。法将殄没。登尔之时诸天泣泪。水旱不调五谷不熟。疫气流行死亡者众。人民勤苦县官计克。不顺道理皆思乐乱。恶人转多如海中沙。善者甚少若一若二。劫欲尽故日月转短人命转促。四十头白。男子淫劮精尽夭命。或寿六十。男子寿短女人寿长。七八九十或至百岁。大水忽起卒至无期。世人不信故为有常。众生杂类不问豪贱。没溺浮漂鱼鳖食啖。时有菩萨辟支罗汉。众魔驱逐不预众会。三乘入山福德之地。恬怕自守以为欣快寿命延长。诸天卫护月光出世。得相遭值共兴吾道。五十二岁。首楞严经。般舟三昧。先化灭去。十二部经寻后 复灭。尽不复现。不见文字 。沙门袈裟自然变白。吾法灭时譬如油灯。临欲灭时光明更盛。于是便灭。吾法灭时亦如灯灭。自此之后难可数说。如是之后数千万岁。弥勒当下世间作佛。天下泰平毒气消除。雨润和适五谷滋茂。树木长大人长八丈。皆寿八万四千岁。众生得度不可称计。贤者阿难作礼白佛。当何名斯经。云何奉持。佛言。阿难。此经名为法灭尽。宣告一切宜令分别。功德无量不可称计。四部弟子闻经悲惨惆怅。皆发无上圣真道意。悉为佛作礼而去

佛说法灭尽经


佛说方等般泥洹经

    No. 378 [No. 379]

佛说方等般泥洹经卷上

        西晋 月氏 三藏竺法护译

    哀泣品第一

闻如是一时。佛游鸠夷那竭国双树间力士所生处。时佛欲般泥洹。告贤者阿难言。多陀竭出于山间。般泥洹时本瑞云何。如今日宁见闻丛树间感应不乎。答吾所问。尔时阿难以偈答佛言

  愿听我所梦　　其色近可怪
  忆夜之所见　　心窃为危惧
  梦此阎浮提　　有树生甚奇
  七宝杂校成　　花实常丰茂
  覆盖佛世界　　其荫清且凉
  开发踊跃意　　灭除众忧病
  上行高无极　　姿好亦无数
  见者眼清净　　闻者耳彻听
  树出无量音　　清净之法音
  具足空寂灭　　则令一切安
  其树奋大光　　遍照东方刹
  其数如恒沙　　诸佛之国土
  亦照于十方　　蠕动荷救护
  一切蒙光者　　安隐难思议
  树出众名香　　器有百种分
  其有闻香者　　终不归恶道
  地狱以畜生　　及在饿鬼路
  于彼闻是香　　疾得生善处
  大树德如是　　苞润众生类
  忽然于树间　　没于力士地
  于时无数千　　群萌不可计
  悲泣悉哀慕　　如盲失其目
  不复听其声　　亦不见树形
  犹不闻其香　　虚劣若饥人
  恐惧衣毛竖　　畏怖情使然
  于夜梦如是　　愿尊为解说

尔时净居天子。释梵四天王魔子导师。各与八十那术之众。俱到力士所生处丛树间。前诣佛所稽首作礼却住一面。同时举声为贤者阿难。说偈言

  尊天今灭度　　阿难岂知耶
  呜呼感恋毒　　佛将般泥曰
  大铠翳无明　　佛今欲灭度
  世尊般泥洹　　违远于拥护

于是佛为诸天子释梵四天王魔子导师。说偈言

  汝等勿愁忧　　所梦无有异
  我于双树间　　今当般泥洹
  树中之最树　　奇妙难可量
  光香甚殷盛　　没于丛树下
  世尊譬大树　　复在丛树中
  寝处无有识　　如火得水消
  万物皆无常　　法起当有灭
  世雄之所了　　是故为人说
  阿难知之乎　　佛尊犹泥曰
  造迦利比丘　　智通度彼岸
  阿难汝今往　　告敕释须檀
  尊者阿那律　　彻视度无极
  阿难行告语　　拘絺迦旃延
  分褥文陀弗　　菩提及摩夷
  须菩提面王　　善来觉薄拘
  难陀罗云停　　度知际马师
  一切诸比丘　　来度恐畏者
  疾去悉告语　　令知我泥曰

尔时阿难。以偈答世尊言

  我身已疲极　　譬如饥羸人
  闻佛泥曰故　　愁惨不自胜
  其身无有力　　口亦不能言
  志意加怯劣　　世眼云何行
  不任告尊者　　今世不可念
  适见便不现　　永失于拥护
  无护甚勤苦　　何忍任往告
  尊老闻此问　　安能堪惶懅
  世间大光明　　灭尽为甚疾
  弃世亦何速　　厄难遂盲冥
  不任诣长老　　陈此酸毒事
  正觉愿更遣　　无有愁戚者

于是佛为阿难说偈

  阿难巨亿大　　啼泣感悲哀
  宫殿难檀庐　　空虚无人天
  宣告诸比丘　　侍者之常业
  泥曰后来者　　得无益哀酷

尔时贤者阿那律于须弥山顶。为忉利诸天广讲法语。见诸大尊神妙天子。各从宫殿遑遑不安。阿那律心念言。此诸天子。何故弃舍天妓之娱。扰扰上下或飞或走。眷属离散其处空虚忽不复现。时阿那律从须弥顶。遥见宝积山下之地。于是阿那律立须弥顶。举声以偈赞叹佛言

  导利于群梨　　施世之安隐
  正觉为众祐　　云何便泥曰
  呜呼世尊喻父母　　为世之眼除诸冥
  为世良医疗众病　　今世尊雄便泥曰
  见淫怒人如放逸　　觉悟愚痴断生死
  为法尊上伤悭贪　　令离嗔诤立大道
  天中天尊右金臂　　枚拭一切授正戒
  佛动是国六震地　　周遍世界闻大音
  如大石山一旦崩　　其音宣广闻者悸
  世雄如是今泥曰　　音畅遐方闻摧悴
  魔兵兴恶若干变　　金刚器械不可数
  有戴大山或持火　　世雄威光毛不动
  降伏怒害魔官属　　得甘露迹无忧惧
  便转法轮解四谛　　今日尊雄便泥曰
  世尊见化无数种　　三千世界如一毛
  能令众生无毁害　　今日尊雄便泥曰
  今天中天为来入　　至于力士所生地
  五百眷属围绕佛　　于双树间便泥曰
  佛天中天百世来　　奉行四禅开度人
  所修行道阐甘露　　我最后见佛泥曰
  所游往来无生死　　其惠布施无悔恨
  其奉正戒无谀谄　　我最后见佛泥曰
  于亿劫中那术数　　所为精进无过者
  忍辱无量譬若地　　我今后见佛泥曰
  佛天中尊所生处　　供养诸觉亿那术
  致甘露迹志惟壹　　我今后见佛泥曰
  佛天中尊所生处　　智慧第一了三达
  十方世雄无挂碍　　今我后见佛泥曰
  大力有十等一切　　通无与等立金刚
  求比难比无殊者　　我今后见佛泥曰
  十力世雄相严身　　所周旋处光巍巍
  进止所历如金摸　　我今后见佛泥曰
  化亿那术立道证　　消尽诸欲无尘垢
  济人生死烧勤苦　　我今后见佛泥曰
  天亿那术立虚空　　雨种种色拘文华
  雨杂名香天芬薰　　我今后见佛泥曰
  佛人中尊行住立　　若入都邑蹈门阃
  盲者得眼睹诸色　　我今后见佛泥曰
  佛人中尊蹈门时　　病者得愈怀喜踊
  一切安隐脱勤苦　　我今后见佛泥曰
  佛入城时拘闭解　　长得安隐自欢娱
  愁苦休除慧最上　　我今后见佛泥曰
  身不知老无死忧　　已脱众碍智无双
  为人泰祖无过佛　　我今后见佛泥曰
  十力世尊上忉利　　度母摩耶立妙道
  化那术天不可计　　我今后见佛泥曰
  第七梵天住众疑　　佛刹其罔授道真
  彼王自投来稽首　　我今后见佛泥曰
  有凶暴贼罪力强　　降立害者甘露道
  纳邪术人无央数　　我今后见佛泥曰
  调达怀毒凶恚盛　　驱作醉象力难当
  佛于大城令调伏　　我今后见佛泥曰
  佛于众会法导人　　能动天地震山陵
  大海波荡水居扰　　我今后见佛泥曰

是时阿那律说此偈已。应时佛放威神令阎浮提所在比丘。除大迦叶眷属余尽来会。三千大千世界诸天龙神。揵沓和阿须伦迦留罗真陀罗摩睺勒众等。共到力士生地。诣佛所稽首作礼。皆大啼哭举声呼佛。思慕崩绝如丧父母。各各相牵共悲泣者。还顾相视共泪出者。或手相搏拍膑拍头。或开目闭目诸根变异。面颊憔悴肥色困皱。或有却行右膝着地。呼嗟抆眼涕泣交横。悲哀叹佛皆言毒痛。呜呼世雄。呜呼大医。呜呼师子。呜呼法王。呜呼日月王。呜呼觉正觉。呜呼大光明施甘露。无量迹如是号啕。或有自扑而擗地者。或有覆面拍地者。尔时阿难从座起下胡跪累膝。两手据地仰向视佛。而说偈言

  见人众号慕　　皆与悲毒俱
  各各号哭哀　　益令我酸毒
  譬如贾客行　　中道逢剧贼
  逢见大火光　　若草惧焦然
  因见炽火故　　其心为恐惶
  意以怀悚栗　　拜天从求哀
  我情勤无极　　忧郁焉可胜
  又见蒸庶人　　悲叫举两臂
  惟虑去来事　　愿佛住一劫
  今日何忍见　　尊人般泥曰
  我常行求佛　　不见天中天
  祇洹用丘空　　但睹于余人
  若入维耶离　　豪右问讯佛
  无上尊所生　　我当云何答
  无央数千人　　泣涕泪流面
  无上释师子　　仁今使安在
  诸人哀哭摧　　无不思见佛
  云何入大城　　违远人中尊
  当立于谁后　　当为谁持钵
  为谁掌衣被　　谁当亲劝我
  谁当为我说　　闻持是何谓
  谁解我疑言　　阿难知如海
  从谁闻正法　　深奥难解句
  我当从何受　　无量兴妙法

尔时佛告阿难。汝为如来于双树间敷师子床。所以者何。多罗竭于夜半时乃般泥洹。与本愿合故也。于是阿难啼从座起。于力士地双树下敷师子床。令北首敷已。说此偈言

  今为大神通　　最后敷此床
  终始不能得　　复安清净座
  我当何忍人　　于是双树间
  光明今灭度　　远离于至尊

于是阿那律为阿难说偈言

  佛从本已说　　万物尽无常
  独不得自在　　于是何为啼

尔时阿难以偈答阿那律言

  云何说是谈　　仁便答我意
  见尊般泥洹　　仁岂无忧耶

于是阿那律以偈答阿难言

  我见人哀危　　动与忧恼俱
  我泪流满目　　悲涕潺横流
  我亦察天人　　以天眼涕泣
  我亦用是故　　悲叫憎悒毒
  不用啼哭故　　便可有所得
  是故勉喻人　　莫啼亦勿愁

    四童现生品第二

尔时世尊从座起入双树间。于师子床上右胁倚卧卧已。应时东方去此百亿万佛国有佛。号师子向作如来。今现在说法。其世界名解脱华。佛告阿难。彼之世界何故名曰解脱华乎。常以七宝华遍布满地无有空缺。其花柔软色甚鲜好出一切香。有七宝树以宝合成。有栴檀树以诸栴檀共相装挍。其色妙绝种种无数。有树常出伎乐之音。音节和雅无量调合。有树常出七宝之器种种具足。有树常出众宝璎珞无量之饰。其国土有无数宝园。以众七宝转杂相成。如天所有所止宫殿。以诸如意摩尼天珠。紫磨黄金挍镂相成。譬如第六天上所居宫殿。其菩萨大士生彼佛国者。皆离世会专尚法讲。神通大圣度于无极。得诸佛法高明之慧。所问能答及离世间。所语所念常志法事。以善方便现于内明。远诸谀谄得法会离。诸想得智慧度无极。度彼岸已具足学善权方便。常供事诸佛离于世语。但说不退转菩萨法事。是诸菩萨不乐余话。但议菩萨陀邻尼金刚行法三品清净。佛功德力无所畏。是故彼界名解脱华。彼有菩萨名善思义。忽迁神命生阎浮提罗阅只国。为王阿阇世作子适生。即便结加趺坐。而说偈言

  吾今所以从　　师子向刹来
  欲见释师子　　正觉为在不

于是有他天。为童子说此偈言

  今日人中尊　　释师子垂衣
  当于双树间　　寂然定泥曰

尔时童子以偈答天言

  吾从东方来　　经百亿万刹
  至于释师子　　欲听闻上法
  今日人中尊　　当寂取泥曰
  至此吾有缘　　不以无缘到
  今日吾来至　　佛当般泥曰
  天上及世间　　当忧何况我
  发意顷不住　　即欲往见佛
  吾来至于此　　有益不唐举
  佛兴难可值　　故启大王言
  无得为放逸　　当诣多陀竭
  亿百千劫中　　时有一佛起
  于德化当知　　佛枉众庶民
  今日于大王　　谏寤国之尊
  放意从欲故　　云何绝父命
  习近恶知识　　调达则大贼
  王从受彼教　　断绝父之命
  起于吾我想　　痴欲造逆害
  王父为法行　　则佛之子孙
  王已得其罪　　为犯于逆事
  以故堕沉冥　　阿鼻摩地狱
  喜意净信佛　　便当得解脱
  然后为人尊　　即可得正觉
  佛般泥曰已　　正觉虽复见
  但能得供养　　于无我舍利
  吾不以欲故　　来到于此国
  大王见忍从　　我欲往见佛
  今日夜半时　　世尊当泥曰
  吾从师子向　　闻佛说如是
  我欲见佛故　　故至此忍界
  敬谢中外亲　　诸家且自安
  我当往觐佛　　神通生死尽
  欲见佛者俱　　前侍尊泥曰

于是王阿阇世以偈告子言

  子汝且忍于是夜　　我当求勇并力往
  力士之土去此远　　不可便以车乘至

尔时童子以偈答父王阿阇世言

  我精进力甚众多　　发意之顷便能来
  是夜能越无数劫　　我不懈怠如大王
  我今日夜所从来　　亦不可计甚长远
  超越中间无数国　　力士之处何足言

尔时童子从座下步。行出罗阅只大城。便说偈言

  其欲生天离地狱　　欲得名闻为尊雄
  可疾随我后从来　　当前诣佛最泥曰

童子适出罗阅只大城说此偈已。应时城中二万人无数亿天龙鬼神。揵沓和阿须伦迦留罗真陀罗摩睺勒来会于是。与若干之众围绕。共到力士生地双树间至佛所

尔时佛于师子床上右胁倚卧。时南方去此五十万佛国有佛。号宝积示现如来。今现在说法。其世界名宝种。彼有菩萨名曰喜信净。忽迁神命生阎浮提舍卫大城。为师子长者作子适生。即便结加趺坐。说此偈言

  所以手足施　　及用耳与鼻
  至于亿世中　　忍以头为惠
  勇惠施无惧　　妻妇及男女
  欲度一切故　　释尊岂在不
  所以亿劫中　　肌肉施于人
  欲度众生故　　世眼为在不

于是师子长者即恐惧衣毛为竖。以偈问子言

  为天揵沓和　　鬼神真陀罗
  婴孩能赞叹　　辩才说妙言
  中外皆怪怖　　小大驰四散
  吾用闻佛声　　是故独不去

尔时童子以偈答父言

  我为天亦龙　　亦鬼真陀罗
  我为天中天　　亦为人长者

于是师子长者以偈问子言

  用闻是语故　　子益令我疑
  所叹乃如是　　使我增恐惧
  云何为天龙　　何鬼揵沓和
  何谓天中天　　何谓子为人

尔时童子以偈答父言

  南方有佛名　　宝积如来尊
  我从彼刹来　　今至此佛国
  怒害我为释　　为六天亦然
  若苦则为梵　　亦作转轮王
  于彼咸龙像　　为神至于此
  鬼色揵沓和　　长者当了是
  我当为一切　　哀伤设拥护
  致得天人尊　　觉则为上度
  我所化亦久　　从劫至亿劫
  终无有尽时　　长者我欲去

童子白父言。宝积示现如来所说当学。不当习诸入之事。所修当念行广大之业。菩萨有三法行。疾得阿惟越致无上正真道何等为三。一者种种深觉。二者入无数意。三者念要句三昧。是为三法行。菩萨疾得阿惟越致无上正真道。于时师子长者告子言。我未知是处

童子以偈现说其处

  深慧难晓亦难了　　世间皆疑于是句
  一切了知是义者　　唯独有佛多陀竭
  佛所解句无瑕秽　　已有无想为上智
  其无思念清净道　　不行想行是谓智
  无央数意无有意　　心之所入志寂定
  无所入者是谓意　　此意则为见一切
  金刚三昧得上觉　　于是之句无入句
  我立于信妙金刚　　此之句迹谓上要
  彼断要者不为信　　佛赞信法为持最
  是一切法为如空　　习行三昧得为佛
  一切所知无有智　　一切所行无有行
  一切所学无有学　　一切所说无有说
  深入慧者无法想　　入于寂定无寂想
  虽成觉道无觉想　　度脱人民无人想
  是之勇猛离见罔　　皆觉了究深道事
  入于一切生死海　　度脱群萌诸起灭

于是童子说此偈已。师子长者及二百人。具足发无上正真道意。应时得不起法忍。八亿天发无上正真道意。即立不退转地。成无上正真道。四那术人远尘离垢得诸法眼净。尔时童子便说偈言

  吾不徒尔来　　有劝释尊教
  度脱无亿数　　令发佛道意
  于释师子法　　怀来宣善义
  立人于忍地　　无得不退转
  我立父兄弟　　诸家于佛道
  八亿诸天人　　皆命 悉 大乘
  我为一切人　　除其贫窭行
  我为得法利　　难计难思议

尔时童子说此偈已。与父母及百千亿人。无数亿天龙 神揵沓和阿须伦迦留罗真陀罗摩睺勒眷属。围绕往到力士生地诣佛所是时佛于师子床上右胁倚卧。时西方去此八十亿万佛国有佛。号妙乐如来。今现在说法。其世界名乐园。彼有菩萨名曰空无。忽迁神命生阎浮提。于波罗奈城为须福长者作子适生。便结加趺坐。说此偈言

  法本为空无　　欲有则为着
  不得脱勤苦　　常立于愦恼
  法为不可得　　是谓为定止
  亦尽亦无尽　　彼为悉无有
  空者不智习　　亦不无有习
  彼若无因缘　　何从有所缘
  彼所可说法　　深寂亦难解
  释师子人尊　　正觉为在不
  大师子震吼　　梵音无起灭
  今日于树间　　光日没不现
  佛于众僧中　　譬如月盛满
  诸人不复见　　世雄说法时
  佛于众僧中　　如踞须弥顶
  世尊不复乐　　出入于城中
  为天世吼道　　说空无我法
  一切不复得　　闻服大音声
  离吾无有我　　赞唱于空法
  今世尊泥曰　　寝疾于树间

尔时童子说此偈已。应时波罗奈大城中十万人。同时举声俱赞叹言。未曾有也。此幼童子乃能有是深智慧意智慧入。智慧光明智慧清净智慧高明。说上妙偈生而逮忍向慧权慧。其处难及所未尝有。其身未长乃有大力。譬如目见如来正觉。愿令我等智慧如是。童子曰。仁等。真愿是智慧。当愿如佛之智慧。微妙无合会寂无与等者。离诸所有高明无损。致诸行法一切善本。一切诸佛力无所畏。立于大慈大哀。仁等。当愿得此智慧。我今与仁当共发无上正真道意。应时大众俱发无上正真道意。寻为说法皆立不退转。成无上正真道。仁等。已发大道意。便可共往见如来无所著等正觉。于是童子与父母及十万人。无数亿天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒眷属围绕。到力士生地诣佛所。是时佛于师子床上右胁倚卧。时北方去此六十四万亿佛国有佛。号觉迹如来。今现在说法。其世界名华迹。彼界及树华实。昼夜常出觉华行之音。诸天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒。其闻音者。皆立觉迹之道行。彼如来有是德。其有人见觉迹行光明者。皆得不退转无上正真道。彼如来本愿之所致。佛语阿难。觉迹如来华迹世界无求二道者。亦不教人求。亦不为弟子缘觉之乘也。但学大乘亦教劝人。佛言。觉迹如来作佛已来六十万四千劫无弟子缘觉众。唯有菩萨众。譬如转轮圣王其子众多。以子为臣。子为门监。子为侍者。觉迹如来国亦如是。唯以诸菩萨为辅弼。以诸菩萨为元首。以诸菩萨为珍宝。以是故。其佛国诸菩萨充满具足为佛境界。阿难。觉迹如来世界所有。丰殖炽盛安隐快乐。菩萨辐凑周遍清净。无不神通者也。以诸金刚为财物。合会所闻闻无疑结。其会所闻皆精进行。以法意会皆勤力行。勉修定意一切尊习。诸惣持门积于智慧平等之要。彼有菩萨名神通华。忽迁神命生阎浮提维耶离大城中。为师子主兵臣作子适生便结加趺坐。说此偈言

  于释释中尊　　善说上妙法
  度脱亿亿人　　正觉为在不
  法意所随起　　其意不可得
  三界无与等　　正觉为在不
  无世尊无色　　于人无所比
  无有与等者　　明眼为在不
  精进度无极　　一心禅三昧
  智慧譬如海　　正觉为在不

于是觉迹如来化作天象童子。说偈言

  正觉住一劫　　当复过是数
  正觉后故在　　可住自娱乐
  童子且习欲　　是为大王家
  鼓乐弦清曲　　箫成以自娱

尔时童子以天意想说偈。报觉迹如来言

  其有随欲者　　此人则为痴
  不了解正觉　　及佛之教诫
  猪马及骆驼　　狐狼之与驴
  是辈为习欲　　非佛子所行
  盲聋无所知　　喑哑不能言
  是辈为习欲　　非佛子所行
  飞蛾蜜蜂蝇　　马畜不自知
  是辈为习欲　　非佛子所行
  假使阎浮利　　合满其中火
  宁堕于其中　　不习于欲事
  乐欲以为上　　于欲何足习
  其有称誉欲　　是为不知法
  不以贪欲故　　彼蒙见识别
  佛化来问我　　我谓为是天
  我从佛所闻　　法王说如见
  今日夜半时　　世尊当泥洹
  我当往见佛　　神通无起灭
  欲往可共俱　　诣于尊泥洹
  觉迹天中天　　人中尊说尔
  得善度无极　　以光导御人
  于百千劫中　　所建功德事
  不如泥洹曰　　世尊之所度
  矜覆一切者　　是世为拥护
  今佛当泥洹　　众生复勤苦
  佛为一切眼　　今日当泥洹
  是世当更遇　　值于大闇冥
  医王灭众病　　今日当泥洹
  已无人中尊　　世间甚勤苦
  能断一切疑　　今日当泥洹
  是世狐疑者　　当复转盛火
  佛除淫怒痴　　今日当泥洹
  是世当复值　　三火之兴炽
  为一切所敬　　天人所钦奉
  今没是树间　　众庶永无见

    四童品第三

是时佛于师子床上右胁倚卧。应时四方有四童子。以大功德而自庄严。动为感应往诣佛所。此四童子所至郡国城郭县邑。一切人民无远无近。皆倾侧瞻仰无不欣戴。此四童子经行之时。上诸天众从四方来。雨于天华遍满其地。于虚空中鼓亿那术百千伎乐。佛尔时于四面现四师子座。于时阿难见大变化在所色像。以偈问佛言

  世间之光明　　谁于是四方
  右敷师子座　　愿尊为我说
  世间之光明　　谁于是四面
  震动一切地　　名山及大海
  世间之光明　　谁于是四方
  四童子之来　　为僧那大铠
  世间之光明　　谁于是四面
  譬如夜半时　　月出奋其耀
  世间之光明　　谁于是四方
  人物一切动　　江河水波荡
  世间之光明　　谁于是四面
  一切之音声　　皆随四童后
  世间之光明　　谁与天神俱
  譬如日月住　　在于虚空中

佛告阿难。汝宁见四方四童来不。其威德光类面貌殊妙。神明昭耀端正无量。其行具足有四种梵音。入深施义有愧吉祥。常自羞惭以自勉成。其所至到辄度人民。有智黠眼有威神德。有布施戒忍精进一心智慧。神通诸度无极。皆起一切戒善法义。譬如优昙钵华。亿那术百千劫难值难见。奉行无数诸佛之行。于无量亿那术百千佛所殖诸德本。各从四方诸异佛刹天中所来生。此阎浮提闻我身当般泥洹。欲见我般泥洹。今日夜半如来当于力士所生地般泥洹。定般泥洹佛告阿难。见此童子从东方来者不乎。姿颜温雅光色闲妙。与无数亿那术百千之众眷属围绕。为亿天所供养天华伎乐。来诣如来者。阿难。此童子于师子向作如来国来。常于彼国作转轮王与主千世界。为一切天人讲说法事。以神通慧圣贤之智。往来周旋曾无断绝。治国积十八亿岁。于十八亿岁中教授十八亿那术菩萨。令始发意立无所从生法忍。应时舍家行学。八十一亿岁常修梵清净之行。八十一亿岁未曾知坐。八十一亿岁未曾睡卧。未曾念欲未曾念诤说。未曾念毁害。亦无欲想亦无事想无毁害想。亦无地水火风想。亦无说想亦无虚空想。亦无男子想亦无女人想。亦无饥想亦无渴想。亦无树想亦无我想亦无我人想。亦无城郭想。亦无起灭想。所以者何。是菩萨大士得灭诸想三昧空无相无愿。得无起行三昧无灭三昧。得一切菩萨三昧。得越一切陀邻尼门三昧。皆得一切善权方便。得神通智慧度无极。得一切菩萨大慈哀行。于一切世界转法轮。立一切人于无上正真道所。愿转于不退转法轮。如是于一切有大哀令一切安隐。童子之德无数具足如是。为复精进更行上二法。何等为二。离于肉眼行彼亦无离行。说于法会行亦无说之想。如是之比曾无杂言。但咏菩萨法品。于八十亿岁教授八十亿那术菩萨。立于无上正真道。皆始发意悉立于不起法忍。应时八十一亿那术菩萨。各各去至他方佛国天中天所。是诸佛一等以今日夜半同时于师子床上右胁倚卧。是诸世尊皆名释迦文。皆于五浊恶世作佛。是诸佛天中天。今日中夜皆于力士生地双树间当般泥洹。阿难。如来皆知皆见不以肉眼见也。复过见无央数。不啻一切弟子缘觉所不及也。阿难。若比丘比丘尼清信士清信女。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒人非人。其有闻是经法欢喜信一发意顷。胜于供养那术佛终竟那术劫也。阿难。此童子其智慧意如是。今日于我法中。一夜所开度蠕动之类。胜舍利弗及一切弟子从本已来所教授。若一劫寿说法所不能及也。此童子所度人民功德无量乃如是。佛告阿难。宁见。此童子从南方来者不乎。譬如夏日之光照于水中。如月盛满有盛明也。如持宝杖捶地已出大音。譬如良工作金银钵。其形圆好无有瑕秽。已离于垢出五品具足音。十品因缘音。离六十二尘音。百一品具足音。五十种具足音。十品手具足音。十品眼清净音。奉行十六善音。八部具足音。十二事具足音。千品金银清净音。所信所生辄胜音。寂生金色音。离一切诸瑕音。以香作成音。所作广生音。六品男子清净微妙音。其种具足音。五亿柔软音。有安隐想除勤苦音。念如来如欢喜想音。降伏魔力音。坏见罔音。灭诸尘劳音。有踊跃于佛想音。安隐无生想音。不退转法轮音。安隐寂音觉音。一心法门三昧三摩越音。十力无畏音。大慈大哀音。出十向音。宝杖捶地出是辈声。阿难。南方去是五十万佛国有佛。名宝积示现如来无所著等正觉。今现在说法。其世界名宝种。彼世界所以名宝种。其国无众邪异道。皆审发无上正真道真人国也。其国不闻秽浊尘劳之名也。亦不闻三念名谓淫怒痴念也。亦无男女想。所以者何。皆修清净梵行。彼国不以揣食养身。其人唯有二食。何等为二。乐欢喜说一切智以为食。彼亦无说二事弟子缘觉乘也。但说一切智事。如是专行一行菩萨法品。天人亦讽诵此事。阿难。彼世界以是名宝种。若他方世界菩萨生彼佛国者。适生即立不退转地及无上正真道。见无央数那术菩萨。说如来一切事。广议菩萨法句。适生一切佛国。皆闻今日某菩萨生此佛国。阿难。我若一劫亿那术劫。说宝种世界一一人所行功德尚未竟。亦不可以喻说尽也。我但粗略为汝说宝种世界之德耳。喜信净菩萨于彼神变。生阎浮提土。欲见我般泥洹时。亦欲叹其本国功德。宣彼佛之名字。为诸求菩萨道者。故来自观意无想也。阿难。是喜信净菩萨。本行菩萨道时。于提桓竭如来世时。转轮圣王名秖世多。从日出至早食时。授教开度三十六亿菩萨。皆令发意立不起法忍。提桓竭般泥曰已后。出下须发具足。千岁中转法轮度无数人。然后日欲入时开导具足。六十亿菩萨令初发意立不起法忍。应时令七十那术人漏尽意解。阿难。般泥洹经所益义如是。我若为汝说喜信净菩萨之功德。那术劫尚未竟也。汝为喜信净菩萨于我前敷座。所以者何。此童子行道已久心不罢厌。其有闻喜净信菩萨名。欢喜者如值佛世。何况面自见踊跃者。阿难。其有比丘比丘尼清信士清信女。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒人非人。闻是经能一发意顶戴欢喜。如来皆见是辈。吾预记是等。皆当见宝种示现如来。及宝种世界诸菩萨。阿难。默持是经勿妄轻传。所以者何。阎浮提人未曾闻是经。未畅菩萨无限之法故也

佛告阿难。宁见此童子从西方来者不乎。舞其两足叵俄其身。地为二反大震动。见者肃然衣毛为竖。降伏一切众邪外道。尽却一切诸魔官属。坏诸往见。令一切安除诸勤苦。令一切欢喜。消诸地狱饿鬼畜生。度脱一切令归善道。以大音救济众生。又见西方大香交露帐来不。唯然天中天。已见。阿难。从西方来香交露者。是谓导御一切菩萨之香也。汝岂复闻西方有大音声出不。空声光明声寂定声佛声唯天中天。已闻。阿难。此之所出四大音者。是空无菩萨缘身毛孔之所出也。四大音声柔软可意微妙无瑕。出是声时令六十八亿那术百千人漏尽意解。六十八亿那术百千人立不起法忍。九亿人立不退转地。为无上正真道使诸佛国。各二那术天。远尘离垢诸法法眼净。阿难。西方去此八十亿万佛刹。有佛名妙乐如来无所著等正觉。今现在说法。其世界名乐园。阿难。彼世界所以名乐园。一切皆以佛法为乐。珍宝为人光明清净。不退转菩萨大士所居。清净诸菩萨无数。无有弟子缘觉二乘也。唯学一切智乘但行佛道。诸天皆立一切智。其得音安谛。解知一切法界往来。供养诸佛天中天以万种物。降伏众魔力化堕见人。灭尽一切尘劳。裂坏一切魔罗网。志于法品令一切立不退转地。不说余说但讲一切智事。转菩萨法品。超诸尘劳之界。无复魔行意无恚怒。行慈悲喜护一切。一一诸毛孔出此六百不退转法声。菩萨法品之义得三脱门。过于弟子缘觉之事。度于三界行一切法界。于彼世界住皆见诸佛。越一切总持法门。得诸佛之觉智。得诸菩萨之三昧。离诸恶智断诸疑结。得诸佛身智之智。得神通度无极离于谀谄。所愿转得供养诸佛。立一切人于无上正真道。令多愿人得无起度无极智。当来劫菩萨之行所立无瑕秽。发意顷现生一切诸佛前。无复生老病死啼哭愁忧。已得寂善权现三十二相装挍其色。已得法身现于凡身。供养奉事一切诸佛。心意踊跃娱乐。智慧度于无极。乐此之乐令余人亦然。其世界诸菩萨所行所乐如是。以故名曰乐园。复次其乐园世界。有八种交道七宝浴池。中有八味水满其池。其水底有七宝沙。中有四种莲华。青曰优钵。红曰波昙。黄曰拘文。白曰分陀利。其光色具好有无数耀。其国有八重宝树。金树银树。琉璃树水精树。车磲树码瑙树。象瑙宝树。吉祥宝树。觉转宝树。舍罗塞宝树。碧英宝树。月光宝树。踰日月宝树。杂玉宝树。阿牟勒宝树。鸠弥勒味宝树。赤青白色真珠树。赤栴檀青栴檀黄栴檀。蒲萄酒栴檀。乐会天栴檀。作味栴檀。污勒栴檀树。蜜香黑妙。香树根香茎节。技叶华实各各炽盛。有果树器树衣树。璎珞装饰树伎乐树。其枝叶华实各亦炽盛。树香之气芬馥甚美。如天上所有。阿难。其世界如是。以金为交露。出柔软音声。其余不可计功德亦出柔软音。世界是故名乐园。空无菩萨于彼神变。来生于此阎浮提。欲见我般泥洹。适生度无央数人。以为佛事转于法轮。空无菩萨从无数劫来。身体诸毛出是四大音。柔软可意微妙无瑕。佛言。阿难。乃往去世有佛名无垢眼。尔时有比丘名慧乐。其比丘从佛闻四大音义。无数慧句。勤力句处处句。眼句天句音句信句。佛句法句僧句。师子句金刚句。乐慧句因缘句。导御句远现句。苦谛句苦习句。苦尽句向道句。彼于七夜常念不离是句。远于异讲心念四义。无所舍无所起。清净志观坏诸见。从亿数佛受是四大无数义句。住于法说至诸郡国县邑。在人家六年于众中讲法。度无数人。阿难。尔时有魔名曰耆陀。化作龙象其众无数。雨浇金刚堕此比丘身上令其命过。阿难。其慧乐比丘者。空无菩萨是也。用彼精进多智。六年于众会中说法。故从无数劫已来。毛孔出此柔软可意微妙无瑕四大音声。其一一毛度无数人。阎浮提人其闻空无菩萨名者。为得大利善庆。何况面见欢喜者。空无菩萨得无数诸度无极。故来欲见如来般泥洹。阿难。汝为空无菩萨于我前敷座。从是当得大智慧尊。于是阿难。即受教于佛前为空无菩萨敷座。佛言。汝用敷是座故。我般泥洹后汝于座上。当一心得六通。福若不志为现清净行者。数座之福可得恒沙之数转轮圣王。一作圣王当一见佛。得为无上正真道最正觉。其有比丘比丘尼优婆塞优婆夷。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒。及余含气蠕动之类。闻是大清净法。若今日见现在如来。若如来般泥洹后。为法师比丘敷座。适敷当得十座功德。何等十。一者尊者座。二者转轮圣王座。三者释座。四者梵座。五者第六天座。六者法师比丘座。七者在所座处当得法座。八者菩萨大士诣佛树下时当得佛座。九者得转法轮度脱无数亿天人。一切世界普闻音座。十者作如是般泥洹时。天龙鬼神揵沓和等眷属围绕。然后得如来师子座。是为十。阿难。汝为空无菩萨叉十指。说是偈言

  其 离 根为寂定　　空无出大光明
  我为勇猛叉手　　为师子大吼礼
  志一心及精进　　积智慧以具足
  我为真善叉手　　礼无有与等者

于是佛为贤者阿难。说偈言

  为空无菩萨　　汝一心叉手
  所当得福者　　且听我所说

佛告阿难。汝用是叉手福德。我般泥洹已后六月中。当独作佛。天上天下人。皆当稽首向汝作礼。若行道入郡国若住精舍。男子女人小男小女。诸邪异道沙门梵志。诸王大臣。讲堂交露及鼓山谷。师子虎野牛象骆驼牛马驴猕猴。揵沓和阿须伦迦留罗真陀罗摩睺勒天龙鬼神女鬼。树木枝叶华实诸药草。有想者无想者。皆当揖让恭敬礼汝。佛告阿难譬如如来无所著等正觉。得佛道之门时。诸树乐树有想无想者。皆揖让低仰向佛树。阿难。其有比丘比丘尼优婆塞优婆夷。天龙鬼神揵沓和等。及余含气有命之类。有说是大清净法语者。如来今现在若泥洹后。以 宣 心无谀谄之意。一心叉手向说法者。诸佛天中天。皆当授其决。及少功德者。皆当具足得是法。何况乐喜无瑕秽者。佛所语无异。闻是大清净法语。少有欢喜信者。多不乐闻其有闻说信欢喜。如来已豫见知其人。不于一佛所殖诸德本。为悉于亿那术佛所。积累功德皆见。我说是大般泥洹会。当复供养弥勒如来。见弥勒佛来下作佛时。当复闻说大般泥洹经。当复见空无菩萨身毛孔出音大音声。当复得方等经。当复闻见四童子尔时说是经。天人阿须伦诸世间人。当复恭敬揖让叉手作礼。亦当得师子座。于是佛告贤者阿那律。汝宁见四十亿天于虚空中闻是经法叉手向我者不。对曰。唯然天中天。已见。佛告阿那律。是四十亿天用是叉手福亿。阿僧祇劫不归三恶道。各各当一恒沙数更作转轮圣王。一一作圣王常值见佛。更是数已然后得作佛。号愿寂如来无所著等正觉。皆同一字。尔时于众会中有力士。一名那尼二名罗提。三名首罗颰四名叉摩迦楼。五名覆呿速。六名波囚遮。七名阿比他。八名维那提。九名优多罗。十名浮浮楼遮。十一名和利前。十二名醘犁阇。十三名醘梨陀楼。十四名叉摩遮。一一力士与五百之众俱悲啼哭。往诣佛所稽首作礼泣下交横。白佛言。唯世尊。我等为空无菩萨。善思议菩萨。喜信净菩萨。神通华菩萨。及大会诸菩萨。及此大经诸大弟子众。叉手揖让恭敬作礼。持是功德求无上正真道。时佛便笑。贤者阿难以偈问佛言

  佛为世光明　　今何因缘笑
  善为我等解　　无数亿人疑

于是佛为阿难。说偈言

  阿难汝为见　　诸力士之众
  各五百眷属　　发大道意不
  为我叉手恭　　及空无童子
  一切诸菩萨　　于是经尊法
  劝助大道意　　哀念于一切
  各与五百众　　皆当得佛道
  无央数亿劫　　终不归恶道
  观于叉手者　　其福乃如是
  我忍住一劫　　及数亿百劫
  诸佛得道时　　其国甚快乐
  所行至辄尊　　其国则丰盛
  我忍住一劫　　说得未能竟
  阿难我今日　　于夜中半时
  汝为最后说　　见佛人中尊

佛告阿难。汝宁见此童子从北方来。有大金光耀来者不。其威神照于北方草木药树。树木茎节枝叶华实。宫殿交露山陵溪谷。及人非人。皆同现为金色。对曰。唯然。天中天。已见。阿难。汝见北方七宝交露精舍来不。对曰。唯然。天中天。已见。阿难。汝见金交露中结加趺坐者不。对曰。唯然。天中天。已见。佛告阿难。北方去此六十四亿万佛国。有佛名觉迹如来无所著等正觉。今现在说法。神通华菩萨于彼神变。来生此阎浮提。欲见我般泥洹。时光明所照谓是如来光明威神。其七宝交露谓华迹世界。其七宝金交露帐中坐童子谓如来也。自然作是世界坐。此七宝金交露帐中令无央数人具足于德本。阿难。此佛国有无央数亿百千人。与此童子殖众德本。是童子适生于是佛国。悉当令其同辈之众漏尽意解得住学地。于无上正真道得不退转。于是四菩萨往诣佛所。同一时前稽首佛足。佛告阿难。如来所当作者。及如来弟子以令一切具足得其所。是神通华菩萨。以此金交露之变化。令七十亿人得阿罗汉。七十亿那术人住学地七十亿百人立无上正真道。七十亿那术人得不起法忍立。无数人当值弥勒时

佛说方等般泥洹经卷上佛说方等般泥洹经卷下

        西晋 月氏 三藏竺法护译

    嘱累品第四

尔时贤者阿难白佛言。唯世尊。住一劫复过一劫。所以者何。唯天中天。如来无所著等正觉。在于世者是诸正士来至此。我等得见跪拜承事。如来般泥洹已后。我曹永绝于三处。何等为三。佛法僧。是等正士为离三处。于是阿难。说此语已啼泣躄地。于时善思义菩萨为阿难。说此偈言

  阿难仁莫啼　　万物皆无常
  合会有别离　　况人焉可常
  于是空无法　　阿难何为啼
  咸有聚会者　　诸会难得久
  佛道亦无得　　阿难何为悲
  所合会为空　　慧慧亦复空
  若念若不念　　一切法无念
  无获空无有　　譬若如野马
  又如化象马　　园果树木华
  巧幻师所现　　佛弟子如是

于是阿难以偈答善思义菩萨言

  实然如仁言　　诸法无所念
  我今日当离　　违远于世尊
  云何入舍卫　　彼问以何答
  正觉为在不　　法眼当来不
  若入香积山　　不见人中尊
  但见其空座　　何忍住于彼
  若出香积山　　入迦利精舍
  人中尊在中　　广说于四谛
  见迦利罗空　　无世雄光神
  若入音声园　　于中独啼哭
  用不见正觉　　驰走趣四方
  其泪充满目　　何忍住于彼

尔时喜信净菩萨为贤者阿难。说偈言

  若亿岁愁忧　　安可有所得
  阿难且观是　　法界甚难得
  譬如芭蕉树　　叶叶分解之
  获之无所得　　万物皆如是
  譬如天雨时　　水中之有泡
  适起便复漂　　万物亦如是
  譬如水之沫　　但可以眼观
  获之不可得　　四种亦如是
  譬如明镜净　　影现不可得
  三界亦如是　　阿难何为啼

于是阿难以偈答喜信净菩萨言

  非为不知是　　不为不见是
  三界无所有　　经常载说此
  见是亿人众　　泪下皆交流
  至我所愁泣　　用是益感戚
  今世尊当去　　人上忽不现
  当于何求索　　谁复为我护
  当从谁闻法　　深奥难解句
  当入何所难　　呜呼佛难值

尔时空无菩萨为阿难。说偈言

  阿难起莫忧　　观于法非法
  法为不可得　　何缘当有灭
  如诸佛生时　　得道亦如是
  如佛转法轮　　泥洹亦如是
  生不生于生　　佛道亦无灭
  于无生之法　　阿难何为啼
  观我身毛孔　　诸所讲说业
  佛说空无有　　法界亦如是

于是阿难以偈答空无菩萨言

  仁等各当去　　于诸界无忧
  当见亿诸佛　　讲说上妙法
  我等及亿天　　周匝相围绕
  比丘比丘尼　　共举举吁嗟
  或从数千里　　皆来至我所
  号呼声远闻　　释师子所在
  忉利及焰天　　兜术泥摩罗
  世尊为至梵　　何时当来下
  在闲居三月　　人中尊一心
  世雄何时起　　当复击法鼓

尔时神通华菩萨为阿难说偈言

  我为以知是　　自期于三月
  示现于仁前　　阿难可勿啼
  我当故为汝　　启白于如来
  令转第一法　　用离释尊故
  诸佛有大哀　　当来至人所
  阿难勿得悲　　人中尊以起
  诸天龙尚忧　　何况于汝身
  如是之光明　　乃于世灭尽
  佛为以说是　　面从世尊闻
  虽住于亿劫　　诸会犹别离

于是阿难起住佛前三举声。说此偈言

  佛为一切护　　今日当泥洹
  世间当复冥　　为以失眼明
  国王及尊者　　畀褫国勤苦
  何忍闻是言　　佛当般泥洹
  力士力士妻　　力士子俱来
  悲哀皆啼泣　　最后见世尊
  诸天龙之类　　周匝五由旬
  涕流至于膝　　除余诸人民
  难头和难龙　　六十亿龙俱
  皆来共啼哭　　最后见世尊
  和陵摩奈龙　　娑竭有大力
  泪啼一由旬　　往诣于佛所
  阿耨达龙王　　百亿众围绕
  泪涕如车轮　　往至于佛所
  伊隶钵龙王　　化作大身来
  啼泣发洪音　　往到于佛所
  千亿诸鬼神　　及百那术众
  前稽首佛足　　最后见世尊
  诸释有亿千　　其众百那术
  前行礼佛足　　明眼莫泥洹
  于是亿梵天　　明昭是天地
  前礼于佛足　　愿尊住一劫
  魔子于彼来　　导师自言在
  哀念一切故　　愿尊住一劫

尔时空无菩萨。为释梵天龙鬼神犍沓和魔子导师。说偈言

  汝等皆无知　　但作强法语
  已为放逸行　　于今甫啼泣
  譬如诸嵩貔　　所住于无黠
  若人以刀击　　即便懅悲唤
  卿等亦如是　　一切皆啼泣
  若正觉在者　　故行放逸行
  今日光当去　　其智譬如海
  卿等当何作　　释尊已泥洹

是时佛告贤者。阿那律大迦旃延分耨文陀尼弗鸠摩迦叶须菩提目呵罗耶大拘絺。汝等。皆伸臂授如来掌。应时十万比丘伸臂授世尊掌。佛以左手授诸比丘掌。右手持阿难罗云掌。着诸比丘手中。我所以亲敬阿难罗云嘱累汝等。尔时即如其像有大自然音。其音遍告一佛国。其千比丘闻所嘱累。欲放身命言。我等当先没泥洹。不忍见世雄般泥洹时也。于是佛伸臂向北方。应时他方世界五百佛。伸手授佛掌。佛便持阿难罗云手。着诸佛掌中我持所亲阿难及子罗云累诸世雄。尔时佛便说偈言

  我持子罗云　　及侍者阿难
  面以此嘱累　　诸佛之世尊
  谁为无护者　　能为作拥护
  独诸佛世尊　　其智无挂碍
  今日之夜半　　天龙世人民
  在阎浮提者　　不复得见我
  遍观诸世界　　无量难思议
  都不见一人　　当为住度者
  无央数亿劫　　譬如恒边沙
  能以一人故　　忍住尔所劫
  其奉敬佛法　　我义度此人
  以无恭恪者　　亿佛不能疗

尔时五百佛各欲还其国土。授阿难罗云掌已。便说偈言

  其奉敬诸佛　　佛义度此人
  所示现济脱　　辄广弘法鼓
  释师子世尊　　涤除诸忧患
  饱满亿数人　　如天雨润地

于是阿难罗云。为诸佛跪啼泣悲诉。说偈言

  愿诸大勇猛　　劝尊住一劫
  诸佛之威神　　令明住一劫
  令无数亿人　　得义住正谛
  天龙诸鬼神　　皆发大道意

尔时五百佛各各还其世界已。告贤者阿难罗云言。止。阿难罗云。无忧无悲。诸佛天中天法伸臂者。为已竟。若放光明及来若住。是为诸佛之示现也

    度地狱品第五

于是佛便三昧。右足大指放亿那术百千光明。一一光明端化作亿百千莲华。一一莲华上化作亿百千座。一一座上有一化如来坐说法。一一如来令亿那术百千人。立不起灭地。时佛复以左足大指放亿那术百千光明。十足指放十亿那术百千光明。十手指放十亿那术百千光明。两膝放二亿那术百千光明。两膑放二亿那术百千光明。阴马藏放亿那术百千光明。齐中放亿那术百千光明。两肩肘放二亿那术百千光明。脑户放亿那术百千光明。左右胁放二亿那术百千光明。四十齿放四十亿那术百千光明。面放亿那术百千光明。顶相放亿那术百千光明。三十二大人相放三十二亿那术百千光明。两眉间相放亿那术百千光明。八十种好一一好。各放亿那术百千光明。一一光明端有化亿那术百千莲华。一一莲华上有化亿那术百千座。一一座上各有坐如来说法。是诸佛世尊不讲异义。但咏菩萨法品摠持金刚行三品清净力无所畏。一一化如来令亿那术百千人立不退转法。佛尔时便于双树间更化作佛。往至先儒大泥犁放光明。其光遍昭思想大狱中。佛尔时便说偈言

  是诸人已解脱　　复数数有思想
  用习起思想故　　令其生于苦恼
  于世间有得道　　佛世尊放光明
  其所说于正法　　令灭尽诸苦恼
  无所尽无所得　　无有起亦无灭
  其有知是法者　　终不归于恶道

佛适说是偈竟已。应时具足亿那术百千人于思想地狱得脱。即生忉利天上。时佛便复往忉利天上。便重说此偈言

  是诸人已解脱　　复数数有思想
  用习思想之故　　令其生苦痛中
  于世间有得道　　佛世尊放光明
  其所说于正法　　令灭尽诸苦恼
  无所尽无所得　　无有灭亦无起
  其有知是法者　　终不归于恶道

世尊说是偈适竟。应时具足亿那术百千人。闻是法得须陀洹道。得神通已。便说此偈言

  无有起亦无尽　　无有生亦无灭
  吾之等解于法　　得忍道之灭度
  其智慧如光明　　昭知人诸根本
  现因缘为解脱　　辄于彼脱人民
  灭愁苦得大智　　疗治于一切人
  诸一切佛所疗　　终不归于恶道
  大光明为甚疾　　于世间而灭尽
  亿人民被烧炙　　令度脱想地狱

于是佛复至烧炙缹煮叫唤雨黑沙烧人四大地狱中。施金色光明遍于一切光明。于佛之光明柔软可意。以哀眼视一切。施眼令安隐。慧戒使清凉。作寂定光明皆遍其中。其威神尊清净第一。于垢无所染远离于垢。施与于智行。大慈念大哀施。无限安乐施慧无碍之眼。施戒之香昭于一切。施于法味达于一切。已示现于法身。施法心之眼。断一切不善之本。授与一切清白之法。悉坏魔力悉令怖惧。使邪异道皆断诸见。令众一切得安隐想。开于天门闭塞于恶户。以无尽之德代诸勤苦。一心精进行慈悲喜护。常导众人于大无为。施眼耳鼻口身意身。一切诸毛孔放大光明。说经法柔软可意。悲哀口说尊语

  我为施安于世　　我为脱诸苦痛
  我为众勤劳者　　除若干之苦尘
  我之所可说法　　昭尊光清净安
  一切人闻是法　　皆弃捐诸恶道
  其有人归命佛　　彼则为得大利
  于亿劫生死数　　终不堕诸恶道

佛说是偈已。应时大地狱一一地狱具足各各亿那术百千人。得脱生兜率天上。用闻是法故悉得阿那含道。得神通已。便说此偈言

  譬如在厄道　　有智慧导师
  令大众贾人　　度怨贼鬼神
  佛所度如是　　以光明为道
  免脱亿人民　　离厄淫怒痴
  我等归命佛　　导师放光明
  已发慈悲意　　得济诸勤苦
  当归命于法　　抚养于我身
  僧为尊重宝　　其德难思议

尔时佛往诣合会大合会不可意三地狱中。放金色五百万亿那术种光明。遍昭其中以寂定无人。无有万物无起无灭。以布施持戒忍辱精进一心智慧诸度无极。用大慈大悲大喜大护。以四恩行。用如来十力四无所畏诸佛十八法不共如来尊行世慧。神足变化说法变化教授变化以用大慧。以根力觉意三昧三摩越。用一切菩萨之行。以无碍佛慧。以无碍佛眼。以无碍法眼。以无碍慧眼。以无碍天眼。以无碍肉眼。以大慈大哀。于一切用一切佛法无上之德。用一切如来觉法。于彼八亿那术百千有命之类。悉蒙五百万亿那术种光音。除诸勤苦皆得安隐。出彼合会大合会不可意地狱。得生波罗尼蜜和耶越天。闻是法已着志得阿那含道。于是佛便住于梵天。说偈言

  诸人无勤苦　　则为第一安
  为说勤苦应　　诸想无有念
  一切无所想　　如于此所说
  在三界岂安　　数数有生死
  其有解空空　　彼空乃为空
  其说深缚者　　彼能解于空
  空者无有起　　思想无有界
  已见非我法　　则为佛之子
  是法为非吾　　亦不可得我
  已无吾我者　　于何复有喜

佛说是偈已。应时彼亿那术百千人闻法者心。悉断一切尘劳。生死已尽得阿罗汉证。便放身命般泥洹。我等。不忍见世尊般泥洹时

     现诸佛品第六

尔时佛于梵天忽然不现。即住双树间。佛心念言。今日夜半如来于是当般泥洹。人民最后见佛终竟。我聊复令众庶欢悦。得安隐想断诸秽毒。令念如来作大善本想。离大众恼得无极庆。发大慈大悲弃诸魔事。怀来诸佛法。皆除裂诸见网。悉灭诸尘劳。悉舍诸谀谄。悉损诸大见。来诸度无极。叹咏菩萨之行。现诸如来令一切目见。作大变化说于佛法

于是世尊。于师子床上右胁倚卧。如师子无恐惧。大尊雄周观十方。以足指案地六返震动十方境界。佛即如其像三昧正受。一一毛孔出恒边沙等数之光明。一一光明昭恒沙等佛国。一一光明。终不相错以是之数一切诸毛孔。各各放恒边沙数之光明。放已即如其像三昧正受。令一切人眼还得佛眼。皆见诸佛国土所有。尔时佛告诸比丘言。汝等。宁见东方纵广上下各十万由旬满其中尘。东方诸佛其数如此尘一尘为一佛。皆右胁倚卧所见变化亦如是。一切诸佛其所教度皆已周毕。悉入力士生地双树间。皆名为释迦文。一切皆于师子床上卧。皆当于今日夜半般泥洹。汝等宁见东方不可计不可数不可思议。无有量诸菩萨行具足往诣佛树下。宁复见无央数得佛道者不。宁复见余无央数转法轮者不。复见余无央数说法者不。复见无有量放寿命者不。复见无有限右胁倚卧于师子床上如我卧者不。众会对曰。已见。不知其数。佛言。譬如三千大千世界。上至三十三天下尽地际。满其中尘。于汝等意云何。宁能有知是尘数者不。唯天中天。不可计不可量不可称不可数。佛言。譬如是三千大千世界。更有如是比亿百千三千大千世界满其中尘。有如此尘数东方佛国。菩萨名释迦文。来诣佛树下得佛道者数亦如是。转法轮者数亦如是。教授说法者数亦如是。放身命者数亦如是。如我右胁倚卧者。数亦如是无起。余于泥洹界般泥洹者其数如是。皆名为释迦文母名摩邪。父名悦头檀。其国名迦维罗卫。其世名忍界。舍利弗。摩诃目犍连。尊弟子阿难为侍者。如东方之所有。九方亦如是。皆为释迦文。如释迦之数。名提桓竭者亦如是。名曰提名多罗者亦如是。名维卫者亦如是。名式者亦如是。名随叶者亦如是。名拘楼秦者亦如是。名拘那含者亦如是。名迦叶者亦如是。是诸佛天中天如是。柔软微妙为名号出柔软音声。皆同一号为释迦文。如来皆以具足肉眼见是尚不足言。其所见广大过此无央数。其有居家修道。若出家学道。令一佛国诸菩萨皆得作佛。具足一劫供养此诸佛名。复有闻是说现诸佛经品。闻已须臾乐欢信。胜于三千大千世界人民皆得佛共供养具足。一切诸菩萨已慧解如是。疾近无上正真道。说是经时。六十二亿菩萨得难具足法。如是得护不可思议意不退转。立于无上正真道。十那术菩萨初发大道意。立不退转地无上正真道。三十二亿菩萨得不起法忍。恒沙数等人断一切尘劳。灭生死证说。无央数人当与弥勒会。于时弊魔怀毒恨心垂泪白佛。唯世尊。我本愿欲使如来早般泥洹。欲令人民不出我界。如来无著等正觉。所度遂益多。若住其寿命令至一劫。所度之数不能复过今日之所度也。今天中天已空我界。于是佛以手两指取地土用着爪上。告弊魔言。于汝意云何。如来爪上土多大地土多。魔白佛言。如来爪上土少。大地土多不可计也。佛言。波旬。我之所度立于无为。其数如爪上之土。其从汝之教者。复多于大地土。汝当欢喜怡怿。人之种如是不可尽无有数。佛告波旬。汝欲求人种如求空。于是波旬。卿所当作者便为之。今日夜半如来当般泥洹。尔时佛告诸比丘。置是诸佛世尊之数。置是诸佛世尊国土所有快乐。置是诸菩萨之兴盛。对曰。唯然。天中天。悉在耳。佛告阿难。若我从一劫至那术劫。作譬合会挍计说譬喻法。讲义说诸佛。无有竟时不可竟也。无央数诸佛天中天。现在者如是。如来皆以具足肉眼见。复过是。所见不可限。于是佛告诸比丘。如来为一切所当为者以度一切矣。无有不度之想名如毛发。所以者何。故告汝等尔时佛即如其像三昧现神足。令是诸佛世尊所说经。悉使此刹人闻。闻是法者。恒沙等人立于三乘。十亿百千人得无上正真道。十亿千人立缘觉道。其余者皆放身命

     佛国净品第七

尔时佛以三十二大人相八十种好。及八千种好。十亿声。六十亿那术百千种语。无限亿那术百千种具足音。受持诸佛法之相。如来寂定。如来十力。如来四无所畏。如来四神足。如来四解智。诸佛十八法不共。如来世上行。悉令面见诸法。于是佛所说法即现。是三千大千之世界。平等如掌无沙砾石。但有摩尼真珠琉璃虎珀砗磲金银。三千大千世界周匝有诸宝殿。无央数宫珍宝交露。摩尼宫殿交露。遍有明月珠树。明月珠盖。明月珠幢幡。明月珠舍。明月珠座。具足三千大千世界。周遍八方有八交道。以金银琉璃水精车磲马瑙象瑙虎珀宝。赤车釭宝。吉祥福宝。月光明宝。踰日宝。阿牟勒宝。鸠弥勒宝。味宝。碧英宝。以此众宝转相庄挍。为树为盖幢幡。其树根茎节枝叶华实炽盛。幡盖丽妙有器树衣树。璎珞庄饰被服果树。满无空缺。有赤栴檀红栴檀汁勒栴檀蜜香黑妙音。有曼陀勒花大曼陀勒花。巾迦勒花大巾迦勒花。粗花大粗花。柔软华大柔软华。度昼花大度昼花。波罗犁花大波罗犁花。善优波罗犁花。月华大月花。周遍月华。摸花大摸花。周遍摸花。善敬摸花。盖华大盖花。周遍盖花。惧生花大惧生花。周遍惧生花。周匝遍满是三千大千世界无空缺。皆有珍宝莲华。有九十九亿那术百千殿舍。青琉璃黄金琥珀马瑙以为殿舍。吉祥福宝摩尼宝以为车有软妙衣垂桂车上。周匝遍是三千大千世界。三千大千世界有敷自然师子之座。一切树下皆有自然师子座。以好綩綖锦绣绫绮上妙衣服。以为座具。有杂色网幔。其文交错状如绶纷。或以黄金焰光摩尼。以为庄挍。一切诸师子座。有坐菩萨三十二相严饰其身是三千大千世界周匝遍布赤珠青珠白珠。有赤栴檀之瓣香蜜香黑妙香。散以粟金

于是三千大千世界上虚空中。遍有摩尼珠网幔。出天之伎乐音声。以珠桂诸幔上以妙贯珠宝贯珠师子赖珠颰蹉赖买珠。以金缕交错为系。以金种种庄严为宝帐幔。以纯金为帐幔。是三千大千世界周匝。下尽地际上至三十三天以摩尼宝。遍以紫磨金周匝为庄严。从黄金帐出无央数亿那术百千之好音声。空无相无愿声。非常苦空非身之声。寂定戒三昧智慧解脱度知见声。调损忍辱惭愧声。慈悲喜护安详奉行声。布施声布施度无极声。持戒声持戒度无极声。忍辱声忍辱度无极声。精进声精进度无极声。一心声一心度无极声。智慧声智慧度无极声。神通声神通度无极声。菩萨行声。怀来菩萨使至不退转地声。菩萨得不起法忍声。一切诸佛法声。如须摩提国阿弥陀佛光明。如阿[禾*(凶-乂+(乖-北+(乂*乂)))]佛世尊。及与香王国所有为上妙。如宝香天中天。如法焰光佛国土之世雄。如摩尼王世尊。如日宝藏又若日宝藏。如音响王佛。如善觉佛。如须弥劫正觉佛国兴盛安乐。释师子国土兴乐亦如是。用哀一切故示现般泥洹。人得知无疑。世尊刹贫穷。用哀是等故示现国快乐。如一切诸佛尊行佛道事。释师子刹如是。毛发无异无增无减。又若一切佛国土之快乐严净好。释师子刹如是。毛发而不差异

     天菩萨品第八

尔时贤者阿那律啼泣悲哀。便说是偈言

  好如月盛住虚空　　若日柔软千光明
  譬火摩尼照一切　　世尊不复入教授
  谁当复护诸世间　　无央数人流生死
  一切世间复盲冥　　用世尊入树间故
  一切三界群生类　　诸所得安及快乐
  悉蒙佛法及尊僧　　用荷哀伤得抚养
  善释师子巧医王　　疗治忧苦度彼岸
  勉济一切诸勤苦　　法王入于双树间
  一切世间当狂乱　　用不见佛释师子
  除无央数淫怒痴　　人民眄眩顿躄地
  天中之天灭生死　　金翅龙鸟皆归命
  鬼阿须伦摩睺勒　　世尊去后皆堕冥
  无有淫欲离慢尘　　照四方明为已灭
  一切世间当大冥　　佛般泥洹当奈何

阿那律说此偈已。应时有诸异天乘车来者。独乘者。乘象者。乘马车者。在交露车者。在座上者。在殿上者。在窗牖者。在父露帐者。在户上者。在半月上者。在梯陛上者。各从所乘各从在所下。下已啼泣呼嗟。往诸力士所生地。到佛所稽首佛足。或有天散优钵青莲黄白诸花。或有散杂栴檀。或有天自取宝冠宝珥手着之宝及以天衣。持散佛上供养于佛。于是贤者罗云啼泣悲哀。说偈言

  功德特异慧无量　　为众所奉开迷乱
  除一切恶勤劳忧　　入于力士所生地
  佛为福地众所仰　　尊为医王灭诸病
  尊相好好如莲华　　尊今寝卧于树间
  佛踰日月诸世间　　无量之曜消天光
  佛为法主过须弥　　度脱亿人勤苦恼
  佛入空法寂无有　　第一无想度彼岸
  尊弃一切世间愿　　法王已入诸树间
  世尊之眼灭世冥　　三达无碍去来今
  佛为导师度生死　　佛用哀故寝树间
  尊师子吼出妙声　　佛所语明如月照
  佛软音响众喜乐　　佛用哀故寝树间
  贤者罗云赞十力　　即便眄眩寻躄地
  于地婉转自擗扑　　法王加哀莫泥洹

尊者罗云说此偈已。应时东方不可议无央数不可称无崖际世界。诸佛天中天。国不可计无央数不可思议。无有限诸菩萨。启辞诸佛来至此刹。欲见如来般泥洹及诸大会菩萨。欲见如来稽首跪拜承事供养。诸菩萨来所经世界无数无量。一切天宫天伎乐不鼓自鸣。雨于天香天华。彼诸世界诸天子。有大德学大乘者。及诸天王龙王鬼神阿须伦王迦留罗王甄陀罗王摩睺勒王。皆侍从诸菩萨来供养者。菩萨以诸宝自庄挍来者。或以天子被服来者。或以第六天子被服来者。或以梵天被服来者。或以自在天子被服来者。或以善化天子被服来者。或以兜术天子被服来者。或以天帝释被服来者。或以日天子被服来者。或以月王被服来者。有菩萨入摩尼宝殿舍中结加趺坐来者。或入摩尼宝宫中坐来者。或入摩尼宝交露帐中坐来者。复有菩萨入香殿香宫香交露帐中。结加趺坐来者。或入紫磨金殿。或入一切宝殿。或入一切宝交露帐中。结加趺坐来者。复有菩萨入赤栴檀殿。入一切栴檀殿舍中。结加趺坐来者。复有菩萨入七宝花殿。或入月光焰明踰日月摩尼宝殿。或入如意宝珠殿。或入如意宝珠宫。或入如意摩尼宝交露帐中结加趺坐来者

诸菩萨以三十二相庄严其身。有无数光明不可思议之光曜。无数广大光明。其光明除一切人勤苦。令一切得善想光明。除一切地狱饿鬼畜生光明。将一切诣善道光明。令身有福功德相端正姝好。见者欢喜。爱其色则无与等者。其色为一切所观视。有梵声柔软音响。令诸道欢喜音。恐诸魔音。益一切人音。出诸法诸福德音。灭除一切恶出无量法明音。彼有菩萨大士。雨诸宝天花遍三千大千世界。往诣如来或雨或衣者。或雨璎珞庄饰者。或雨盖者或雨幡彩。或者雨杂栴檀者。或雨紫磨金者。或雨莲华者。或雨如意珠者。或雨踰天所有诸宝者。遍三千大千世界下诣如来。或有菩萨化作诸宝庄饰盖。如三千大千世界。踰诸天宝用供养如来。或有菩萨以诸璎珞庄严。如三千大千世界。化作莲华细根青琉璃车磲虎珀吉祥藏宝。以为车如意珠车皆悉周遍。焰光珠摩尼黄金以一切为庄饰。或有化作一宫殿如三千大千世界。或有化作踰天诸宝交露帐。如三千大千世界。以焰光珠黄金一切为庄挍。或有化作清净处。如三千大千世界甚大。不可计无央数。不可思议无有量无崖底。所化乃如是。以供养如来无所著等正觉。八方上下来如是。不可计不可数不可思议。无有量诸菩萨来供养佛。是诸菩萨皆同时前。稽首佛足绕世尊三匝。各从其所方来。化作大莲华师子座。诸宝焰光珠黄金为庄挍座。一一菩萨各为佛于双树间化作师子座。以无量清净踰天衣敷其上。以无央数种种色无量色不可计色。不可计亿那术百千色。踰天上诸所有以为庄挍。焰光珠黄金诸宝紫磨金。以为帐而庄严。踰天上香而为芬熏。令诸恶道为善本想。令一切欢喜怡怿。如一菩萨所作庄饰。诸菩萨皆亦如是。一一菩萨各各所化不相杂错。所以者何。寂定无谀谄。于诸法无所著。譬如如意珠于诸尘垢无所染污。学善权方便于诸法所念清净。得诸尊慧法。如身所行口亦如是。为大布施主住于法无所著。是诸菩萨皆叹如来本求道。不可计无央数。不可量不可称勤苦行。以义示现

     如来化说法品第九

尔时贤者阿难以偈赞佛言

  眼明净好如月满　　十力神足慧无尘
  为天龙王所供事　　今日世尊入树间
  若佛众摠入大城　　世雄以足蹈门阃
  则动天地至六返　　放其光明遍佛国
  琴瑟箫鼓诸乐器　　不鼓自出柔软音
  师子虎鹿及野牛　　诸龙大象止雪山
  哮吼咆陆心欢喜　　皆有慈意向如来
  其声可乐胜众宝　　诸牛那术及百千
  见佛光明皆踊跃　　得安无量乐无数
  鴹鸭鸬鹚雁拘逸　　又罗瞻无无数众
  于铁围山鸟鹦鹉　　鸣喜欣欣至佛所
  人本所失诸宝藏　　皆还得之至世尊
  诸嗔恚者悉慈心　　以清净意奉事佛
  天住虚空雨天华　　又罗莲花有千叶
  诸宫采女及天子　　各为供养于世尊
  色净如是当不现　　佛今泥洹当奈何
  譬如犊子断母乳　　断绝拥护为甚剧
  十方从本无尘垢　　已离生死为众祐
  诸世雄界为自在　　其受得住不减劫
  谁为光王踰日月　　谁当有力踰铁围
  谁当忍辱等如地　　世尊导人使离尘
  当以精进及一心　　智慧示现度一切
  若子亿世与母离　　暂得一会便复别
  子愁思亲四方求　　世尊泥洹我亦尔
  愁忧勤苦无复乐　　见佛经行及坐处
  及见讲堂以精舍　　奈何断无吉祥得
  赞叹十方法施人　　无量勤苦贤释子
  即便躄地蓬婉转　　我最意见月善月

尔时世尊以一切持句三昧。正受作安隐行现三昧。善说三昧。雷雨三昧。师子响三昧。光耀响三昧。威神光明三昧。放光明三昧。微妙句三昧。力三昧。力句三昧。无量力三昧。意持昭明三昧。起世有三昧。鼓响三昧。月三昧。大月三昧。周匝月三昧。月响三昧。上月三昧。藏三昧。谛藏三昧。琉璃藏三昧。观视三昧。无量观视三昧。遍照一切十方三昧。除一切疑光明三昧。至诚三昧。谛至诚三昧。至语三昧。说一切行三昧。所说谛至诚三昧。无量三昧。寂定三昧。寂定句三昧。谛寂定语三昧。布施三昧。谛布施三昧。大布施士三昧。光明三昧。善光明三昧。大光明三昧。无量光明三昧。照明句三昧。断一切疑光明三昧。说诸善本三昧。除说诸疑结三昧。谛说见三昧。于是断疑三昧。善施废解三昧。作诸佛三昧。现说一切行三昧。善说一切行三昧。善说转法轮三昧。善开度其处三昧。以是善说现在诸佛慧三昧。正受所住处。一一毛出不可计不可议。不可称不可量。无崖底亿那术百千光明。一一光端化无央数不可计议无量浴池。一一浴池化作不可计议无数无限亿那术百千莲花。一一莲华上化作不可计议无数无限亿那术百千座。一切诸座上皆有如来坐说法。一一化如来所开导人。使立不退转地住于佛法。其数如莲华上所坐化佛。得须陀洹斯陀含阿那含阿罗汉。一一各如是缘觉之数。及不退转立善本者其数亦尔。生天上者数亦如是不复随苦。诸浴池际各有四宝树。无数茎节枝叶华实。一一茎节枝叶花实上。化作无数不可计议不可称量如来。化出坐师子座上说法度脱一切。其数如化树上如来之数。开度一切已。便说此偈言

  众祐人中尊　　谛觉于一切
  人见欢喜者　　皆弃捐恶道
  其久有神通　　世雄难得值
  如优昙钵花　　其色可意好
  其欲供养佛　　及奉事我身
  彼闻是经法　　其心当欢喜
  其欲见现在　　世尊人中上
  世光明威神　　当信乐吉祥
  其当来诸佛　　以光导御人
  欲见是世尊　　当信是吉祥
  其有求大乘　　彼则有大利
  闻是经法已　　则奉侍于佛
  其目得清净　　及耳鼻之根
  身口意诸根　　为断无所受
  三昧戒清净　　智慧解脱净
  解脱示现智　　脱现为至诚
  解于一切法　　于我无所起
  所知无所灭　　即不忧诸响

诸化如来说此偈已。应时不可计人立于三乘。无数世界人民皆得一心。无数佛国诸地狱皆灭尽。诸畜生皆脱勤苦。饿鬼皆得安隐。尔时佛入量宝三昧正受。如来住是三昧者。随一切人所欲。得宝则如其意。见佛国宝皆悉在前。见诸佛树以宝庄饰。随意所好所欲。见色则见诸郡国县邑及国人民。即如意见满诸佛国。尽形寿见所欲庄饰。则如意见男子女人小男小女璎珞庄饰。亦复见诸天龙鬼神犍陀罗阿须伦迦留罗真陀罗摩睺勒。所欲服饰。所欲食饮。所欲舍宅。如意所好皆见皆得。佛告阿难。有三昧名慧行。诸佛世尊住是三昧。随人所欲得三昧。如意即见一切人愿。阿难诸佛世尊有三昧。名无量过度三昧。吉祥威神随人所欲。得万物即如意在前。得万物已供养如来。阿难。诸佛世尊有三昧名眼。住是三昧时。令一切人不复习欲。乐道德欲。于淫欲不净想不复习也。于梦中亦不乐。阿难。诸佛世尊有三昧名意惭愧。住是三昧时。令诸佛国中人民皆有愧心无恚乱意。阿难诸佛世尊有三昧名目主。住是三昧盲者得目。阿难。诸佛世尊有三昧名无忧主。住是三昧时。若入城令一切人无复忧患。阿难。诸佛世尊有三昧名神通主。住是三昧。令无神通者飞行虚空。神足能高七树。阿难。诸佛世尊有三昧名世光耀。住是三昧时。盲者得见世尊。阿难。诸佛世尊有三昧名受清净。住是三昧时足蹈门阃。令诸天龙鬼神犍陀罗王阿须伦王迦留罗王真陀罗王摩睺勒王释梵于彼稽首礼佛。阿难。诸佛世尊有三昧名过师子英。住是三昧时。诸外异道这见如来威神。皆降伏自归。阿难。诸佛世尊有三昧名金刚光明。住是三昧足蹈地时。三千大千诸铁围大铁围山。须弥山王及黑山。诸沟坑溪谷山林及地皆正。高者为卑丘墟为平。其地柔软譬如好衣。阿难。诸佛世尊有三昧名伏诸魔力。住是三昧时。令诸魔恐惧怖懅不安。各各不乐其宫舍怖懅不止。至于见佛归命如是稽首佛足。阿难。诸佛世尊有三昧名无恐惧。住是三昧时。令一切人无伤害意。相向无诸恐惧亦无憍慢。阿难。诸佛世尊有三昧名妙句。住是三昧时。令诸世界人无有食者得诸无数种种之味。阿难。诸佛世尊有三昧名颜色。住是三昧时。令一切人得好妙色不复多病。阿难。诸佛世尊有三昧名为他故令无衣者得自然衣。住是三昧时。拘闭狱者皆得解脱。诸在厄难者。令免难苦得诸安乐。悭贪者喜布施。恶戒者住净戒。恚怒者立忍辱。懈怠者使精进。断诸不善法习增善法。乱意者令得一心。恶智者得净智慧。阿难。诸佛世尊有三昧。名说无意行善说句。住是三昧时。诸忧愁者悉令喜踊。阿难。诸佛世尊有三昧名二光。住是三昧时。于去来今诸法无所挂碍。无有不等示现智慧。阿难。诸佛世尊有三昧。名于诸法无谀谄便去。住是三昧时。令诸菩萨大士得不起法忍。佛说如是。贤者阿难。诸尊弟子。十方诸会菩萨。诸天龙神世间人民。为佛作礼而去

佛说方等般泥洹经卷下


集一切福德三昧经

    No. 382 [No. 381]

集一切福德三昧经 卷上

        姚秦三藏鸠摩罗什译

如是我闻。一时佛在毗舍离庵罗树园大法讲堂。与大比丘众十千人俱。皆阿罗汉诸漏已尽无复烦恼。心得自在心得好解脱慧得好解脱。其心调柔如大龙王。所作已办舍离重担逮得已利。尽诸有结到于彼岸。菩萨摩诃萨二万人俱。皆不退转得陀罗尼及无碍辩。获大神通善能出生诸深三昧。念慧坚誓智慧方便到于彼岸。其名曰行志菩萨摩诃萨。师子志菩萨摩诃萨。妙色志菩萨摩诃萨。增去志菩萨摩诃萨。增长志菩萨摩诃萨。无量志菩萨摩诃萨。法志菩萨摩诃萨。弥勒菩萨摩诃萨。文殊师利童子菩萨摩诃萨。那罗延菩萨摩诃萨。如是上首二万菩萨。复有四万天子皆向大乘。及余无量释梵护世。尔时世尊与无量百千万亿大众。恭敬围绕而为说法。尔时世尊却后三月。当舍身命入般涅槃。当于是时佛法胜妙极为增盛。隐蔽一切诸外道等

尔时千世界主那罗延菩萨。从坐而起整于衣服。右膝着地合掌向佛白言。世尊。如来不久当舍身命毕竟涅槃。今如来法极为最上。能悉隐蔽一切外道无信敬者。善哉世尊惟愿如来护诸菩萨。令得现生一切诸善。善根增上其心欢悦。增益威德不断佛种。护持法眼及与僧眼。惟愿如来摄救一切诸众生等。分别演说向涅槃道。所说正法若佛灭后。令诸菩萨流通不断。及阿耨多罗三藐三菩提久住于世不离见佛闻法供养僧。增益念力不忘诸法。增益慧力觉了深法。增长进力得进解义。得具惭力净自心故。具足愧力舍离一切诸恶法故。得坚固力威仪具足故。有牢强勇健除断一切。诸结使故。有大雄猛所住无畏故。世尊。云何菩萨摩诃萨不失功德。不失正法。不失慧。不失智。不失菩萨心。志念坚固亲友究竟。令诸众生乃至涅槃。如说如作不诳众生住满佛法。不求自施悉舍于一切。自如教住住三净戒。自住净忍心无粗犷。于诸众生其心平等。自住精进作一切业。自住诸禅具三善戒。自善住慈不依着于一切禅定。自住明慧离诸邪见。一切法中得于照明。以四摄法摄取众生无有疲惓不求恩报。常念修行一切人天所有善处。住一切智心如门阃。心不趣向声闻缘觉。心常趣法不趣于欲。为法王利非人天利。行智慧行佛智所说。以法养命非饮食活。远离贪欲摄受一切。远离嗔恚于诸众生无侵害心。远离愚痴离诸法闇。出过众魔离诸结恼。善巧方便善趣诸门。如是问已。尔时世尊告千世界主那罗延。善哉善哉。那罗延汝今乃能为诸菩萨。问于如来如是之义。那罗延。汝今谛听善思念之。当为汝说。菩萨摩诃萨如是诸行。所得功德复过于是。时那罗延菩萨欢喜白言。善哉世尊。受教而听。佛告那罗延。菩萨摩诃萨有三昧名集一切福德。菩萨成就是三昧者。不失功德。不失正法。不失于慧。不失于智。不失见佛闻法供僧。勤修四摄自住布施。乃至自住于善方便。成就此功及余功德。尔时世尊敷演说是集一切福德三昧名已即便默然

尔时有大力士名曰净威。成就大力。居毗舍离大城作如是念。我大力士成就大力。阎浮提中所有众生。无有大力与我等者。我先闻有沙门瞿昙。成就大力具足十力那罗延身。复作念言。我当往观沙门瞿昙何如我也。尔时净威力士出毗舍离大城。趣庵罗园大法讲堂。到已瞻睹如来应正遍觉佛大威德。百千万众恭敬围绕而演说法。犹如须弥显于大海。周匝端严极为微妙。当初睹见于如来时。得大信乐爱敬之心。即前投地礼如来足。右绕三匝却住一面。合掌顶上一心观佛。是时世尊知是净威力士心已欲降伏故告大目连。目连。汝往取吾昔菩萨时为娉瞿夷释种女故捔力时箭。尔时目连白世尊言。我都不见知在何处。尔时世尊从于右足放大光明名曰照明。是光遍照三千大千此佛世界。时三千大千世界之下。大金刚轮箭在彼竖。尔时世尊告大目连。汝见此界大金刚轮箭在彼竖不。目连白言。已见世尊。佛告目连。汝取持来。时大目连即下至彼。如大力士屈伸臂顷。一切大众皆见其去。即便持来授与如来。作如是言。世尊。是菩萨时父母生力为神通力。佛言是菩萨时父母生力非神通力。目连。菩萨若以神通之力。是箭即过无量无边诸佛世界。大德目连白言。世尊乃是菩萨父母所生福德之力。佛告目连。如十人力等一健牛力。十健牛力等一青牛力。十青牛力等一凡象力。十凡象力等一罗迦象力。十罗迦象力等一迦尼象力。十迦尼象力等一香象力。十香象力等一毗陀象力。十毗陀象力等一无斗象力。十无斗象力等一伊沙陀象力。十伊沙陀象力等一安禅象力。十安禅象力等一婆摩象力。十娑摩象力等一青象力。十青象力等一黄象力。十黄象力等一赤象力。十赤象力等一白象力。十白象力等一赤莲花象力。十赤莲花象力等一红莲花象力。十红莲花象力等一香象力。十香象力等一大香象力。十大香象力等一系罥师子王力。十系罥师子王力等一力士力。十力士力等一大力士力。十大力士力等一遮[少/兔]罗力。十遮[少/兔]罗力等一大遮[少/兔]罗力。十大遮[少/兔]罗力等一波建提力。十波建提力等一大波建提力。十大波建提力等一地天子力。十地天子力等一堂天子力。十堂天子力等一持风天力。十持风天力等一持鬘天力。十持鬘天力等一常醉天力。十常醉天力等四天王中一天子力。一切四天中天子力等一天王力。十天王力等三十三天中一天子力。一切三十三天中天子力等一帝释力。十帝释力等焰天中一天子力。一切焰天中天子力等一焰天王力。十焰天王力等一兜率陀天中一天子力。一切兜率陀天中天子力等一兜率陀天王力。十兜率陀天王力等化乐天中一天子力。一切化乐天中天子力等一化乐天王力。十化乐天王力等他化自在天中一天子力。一切他化自在天中天子力等一他化自在天王力。十他化自在天王力等魔天中一天子力。一切魔天中天子力等一魔王力。十魔王力等半那罗延力。十半那罗延力等一那罗延力。十那罗延力等一大那罗延力。十大那罗延力等一百劫修行菩萨力。十百劫修行菩萨力等一千劫修行菩萨力。十千劫修行菩萨力等一万劫修行菩萨力。十万劫修行菩萨力等一十万劫修行菩萨力。十十万劫修行菩萨力等一百万劫修行菩萨力。十百万劫修行菩萨力等一千万劫修行菩萨力。十千万劫修行菩萨力等一百千万劫修行菩萨力。十百千万劫修行菩萨力等一千千万劫修行菩萨力。十千千万劫修行菩萨力等一百千千万劫修行菩萨力。十百千千万劫修行菩萨力等一千千千万劫修行菩萨力。十千千千万劫修行菩萨力等一百千千千万劫修行菩萨力。十百千千千万劫修行菩萨力等一万千千千万劫修行菩萨力。十万千千千万劫修行菩萨力等一无生法忍菩萨力。十得无生法忍菩萨力等一十地菩萨力。十十地菩萨力等一后身菩萨力。是故目连。菩萨成就如是力故。生便即能行于七步。目连。若此世界佛不持者便坏不住。何以故。菩萨摩诃萨当其生已行七步时。此界大地从广六十八千由旬。菩萨生已当下足时。便当 却 没深百千由旬。还举足时复当踊出百千由旬。以佛持故令是世界不动无坏众生无恼。最后身菩萨始初生时。则便具有如是力。目连。十初生菩萨力等一盛年菩萨力。目连。菩萨摩诃萨成就是力。趣向道场觉于菩提。如是当趣道场时力。比道场上座时之力。超过百千。复以如是无量无边阿僧祇不可得不可坏力。成就具足乃至成阿耨多罗三藐三菩提。目连。假使一切世界众生。悉得具足垂成菩提菩萨之力。比于如来处非处智力。百千万亿分不及其一。乃至算数譬喻所不能及。得具如是十种之力。名为如来应供正遍觉。是故目连。如来之力为本善根之所护持无增无减。此中不明菩萨通力。菩萨若用神通力者。能以恒河沙等世界。置于足指一毛端上。掷过无量无边恒 河 沙世界。如是往来不令众生有于苦恼。如是神力无量无边。不可思议不可称量。不可数知无等等。若当如来尽现所有神通力者。汝等声闻尚不能信。况复其余诸众生也。目连。菩萨趣诣道场上时。观于地大水火风大悉为一界。所谓空界。是故大地而不坏败众生无恼。时净威力士从如来所。闻说菩萨父母生力。闻已惊怪身毛皆竖生希有心。从坐而起正于衣服。右膝着地合掌向佛白言。世尊。我今憍慢悉皆摧灭。从如来所闻菩萨力故。世尊。我今归依佛法众僧。发于无上正真道心。为欲安乐一切众生。愿得具足如来之力。尔时复有十千天子。闻净威力士作如是语。皆发无上正真道心。亦作是念。世尊。愿令我等得如是力。如今如来应供正遍觉。尔时那罗延菩萨白言。世尊。云何名为菩萨所修集一切福德三昧。如来先说是名字已即便默然。世尊。今当敷演解说是集一切福德三昧。云何菩萨得是三昧。尔时世尊告千世界主那罗延。菩萨。那罗延。无有菩萨发于无上正真道心而不随是集一切福德三昧者。何以故。一切福德无有不入初发心中。那罗延。犹如江河一切诸流无有不入大海中者。如是那罗延。所有福德若施戒修。有漏无漏世间出世间。若天若人所有福德。皆悉摄在发菩提心中。是故那罗延。若善男子善女人欲集一切诸福德者。当发无上正真道心。那罗延。犹如宝山。所谓须弥。目真邻陀摩诃目真邻陀。轮围山大轮围山。及诸余山药木丛林。村邑聚落大小诸城。阎浮提弗婆提瞿耶尼郁单越。诸四天下。及千世界二千世界三千大千世界。欲界色界无色界。日月星宿若日月蚀。一切皆摄三千大千世界之内。乃至百亿四天下皆悉在中。如是那罗延。所有一切诸凡夫福。若学人福无学人福。若菩萨福若如来福。一切皆摄在于菩萨初发心中。是故那罗延。若欲摄取一切福德。当发菩萨阿耨多罗三藐三菩提心。那罗延。若四天下一切众生。悉具转轮大王福德。若有初发大乘道心。福德智慧殊胜于彼。那罗延。如四天下一切众生。乃至三千大千世界所有众生。是众生界之所摄者。是一一众生皆具转轮大王福德。是诸转轮大王福德。为一转轮大王德聚。是一一众生复具是德。于意云何。是诸福德宁为多不。那罗延言。是一人福尚多无数。况复无量阿僧祇人所有德聚。佛言。那罗延。置是三千大千世界所有众生。乃至恒河沙等世界所有众生。悉具转轮大王福德。那罗延。于意云何。是诸德聚宁为多不。那罗延言。世尊。若一三千大千世界众生。具足转轮大王所有德聚。尚多无量无边阿僧祇。况复无量无边世界众生。具足转轮大王福德之聚。那罗延。我今知已而唱是言。有初发菩提之心。所有德聚比前德聚。百分不及其一。千分百千分百千万亿分。乃至算数譬喻所不能及。那罗延。是名初说入集一切福德三昧。复次那罗延。如千世界梵王慈心。普遍满此一千世界。那罗延。有人复以满千世界七宝布施。于意云何。是人施福梵王慈福何者为胜。那罗延言。世尊。梵王慈福无量无边。那罗延。置是千世界梵王慈心。若二千世界梵王慈心。普遍满此二千世界。那罗延。若复有人以满二千世界七宝持用布施。汝意云何。是人施福梵王慈福何者为胜。那罗延言。世尊。梵王慈福无量无边。那罗延。如三千大千世界梵王慈心。普遍满此三千大千世界。若复有人以满三千大千世界七宝布施。于意云何。是人施福梵王慈福何者为胜。那罗延言。世尊。梵王慈福无量无边。那罗延言。世尊。施福比慈百分不及一。千分百千分乃至算数譬喻所不能及。佛言。如是四千世界梵王慈心。亦遍满此四千世界。五千世界梵王慈心。亦遍满此五千世界。十千世界梵王慈心。亦遍满此十千世界。百千世界梵王慈心。亦遍满此百千世界。那罗延。若人以满百千世界所有七宝持用布施。所得福聚比慈福德慈福为胜。那罗延。正使是等三千大千世界之中一切众生各具慈心。如百千世界大梵天王所有慈心。是诸慈心福德之聚。欲比菩萨初发道心专志增上。为脱一切所有众生无幻无伪。实为一切众生修行慈心福德。百分不及一。千分百千分亿分百亿分千亿分。乃至算数譬喻所不能及。那罗延。是故当知。若欲修集一切福德。是善男子善女人应发阿耨多罗三藐三菩提。今发当发。具足如是无量无边福德之聚。是第二说入集一切福德三昧。复次那罗延。汝意云何。东方虚空为普遍不。南西北方四维上下所有虚空为普遍不。那罗延言。世尊。东方虚空尚不得边。何况十方不可说无量无边随有世界虚空普遍。佛言。那罗延。假令有人乃至百千万亿劫中。引诸喻说欲尽虚空。得其边际不得其边。那罗延。我今引喻以明斯义。为欲成满是集一切福德三昧故。亦令增益诸有修集福德众生增长志欲。令向大乘菩萨摩诃萨满大精进。那罗延。若以芥子盛满三千大千世界。乃至非想非非想处满中芥子。假令有人持过东方百千恒河沙等世界下一芥子。如是东行尽是芥子。犹不能得世界边际。南西北方四维上下亦复如是。那罗延。若复恒河沙等世界满中芥子。那罗延。颇有人天能数如是一切芥子知其数不。时那罗延白言。世尊。若四天下一切众生成就智慧如舍利弗。于一劫数犹尚不能数其一分。况能数尽大芥子聚。那罗延。假令有人过于东方恒河沙世界着一芥子。如是东行尽是芥子。犹故不得世界边际。南西北方四维上下亦复如是。那罗延。如是世界虚空普遍。设有人天以满中七宝持用布施。那罗延。于意云何。是福德聚宁为多不。那罗延言。无量世尊。无边世尊。佛言。那罗延。是人所有福德之聚。欲比初发道心菩萨成就志欲无幻无伪勤修精进为脱一切众生起大慈大悲所集德聚。是施德聚百分不及一。乃至算数譬喻所不能及。那罗延。十方一切所有诸物虚空皆悉周遍。那罗延。菩萨慈心亦复如是。遍满十方诸佛世界。所有众生皆悉普遍。那罗延。是菩萨慈心所及众生。令悉具足转轮大王所有福德。如是帝释所有福德。如是梵王所有福德。若有菩萨初发道心。专志趣向无幻无伪勤修精进。为脱一切所有众生。起慈悲心而趣向之。行于愍悼所得福德。是福胜彼。一切众生具转轮王帝释梵王所得功德。那罗延。是第三说入集一切福德三昧。复次那罗延。假令三千大千世界所有众生。皆具转轮大王福德。比帝释福德。百分不及一。乃至算数譬喻所不能及。那罗延。假令三千大千世界所有众生皆为帝释。比梵王所有福德。百分不及一。乃至算数譬喻所不能及。那罗延。假令三千大千世界一切众生皆悉具足大梵天王所有福德。比一断欲优婆塞所有福慧。百分不及一。乃至算数所不能及。那罗延。假令三千大千世界所有众生皆为断欲优婆塞所有福慧。比舍利弗所有福慧。百分不及一。乃至算数譬喻所不能及。那罗延。假令三千大千世界所有众生福德智慧如舍利弗。比一缘觉所有福慧。百分不及一。乃至算数譬喻所不能及。那罗延。若令三千大千世界所有众生悉具缘觉所有福慧。比一五百劫中修行菩萨所有福德智慧。百分不及一。入集一切福德三昧应如是学。说是法时三万二千众生皆发无上正真道心。此三千大千世界六种震动。人天伎乐同时俱作。人天雨花积至于膝。天龙夜叉乾闼婆释梵护世皆作是言。世尊。是初发心者悉胜我等。世尊。我等亦当利是善男子善女人已发今发当发阿耨多罗三藐三菩提心者。如我等解佛所说义。若有众生不发无上正真道心。则不能趣是集一切福德三昧。不能正入。若有众生发于无上正真道心。则能得趣是集一切福德三昧。亦能正入。尔时净威力士白言。世尊。以何等法能得成就摄此集一切福德三昧。佛言。善男子。成就一法摄此集一切福德三昧。何等一法。谓不舍于一切智心。善男子。是名成就一法摄此集一切福德三昧。复次善男子。复成就二法摄此集一切福德三昧。谓闻法无厌闻已修行。善男子。是名成就二法摄此集一切福德三昧。复次善男子。复成就三法摄此集一切福德三昧。何等三。谓离诸恶。修行善法。善巧回向。善男子。是名成就三法摄此集一切福德三昧。复次善男子。复成就四法摄此集一切福德三昧。所谓戒净见净心净慧净。善男子。是名成就四法摄此集一切福德三昧。复次善男子。复成就五法摄此集一切福德三昧。何等五。所谓专意发菩提心。常真实语。无有谄伪。无有嫉妒。于一切众生心常平等。善男子。是名成就五法摄此集一切福德三昧。复次善男子。复成就六法摄此集一切福德三昧。何等六。所谓亲近于善知识。离恶知识。远离众闹。闲居寂静。不舍大慈。于诸众生起大悲心。善男子。是名成就六法摄此集一切福德三昧。复次善男子。复成就七法摄此集一切福德三昧。何等七。所谓修定。善于智慧。善知于因。善知于缘。正直而住。修集于道。修行道时无有懈怠。善男子。是名成就七法摄此集一切福德三昧。复次善男子。复成就八法摄此集一切福德三昧。何等八。谓调柔身。调柔心。观受。观法。未生恶法令其不生。已生恶法断之令灭。未生善法方便令生。已生善法护令增长。善男子。是名成就八法摄此集一切福德三昧。复次善男子。复成就九法摄此集一切福德三昧。何等九。观过法无尽。现法无尽来法无尽。观法如幻。等觉三世。如一切法知而忍之。不谤于空。不分别无相。不愿诸有。善男子。是名成就九法摄此集一切福德三昧。复次善男子。复成就十法摄此集一切福德三昧。何等为十。谓解无我。忍于无命。不疑无人。缘法无常于诸生处如地狱想。观四大如毒蛇。观入如空聚。观阴如魁[魅-未+會]。流出诸有想。乐修解脱。善男子。是名成就十法摄此集一切福德三昧。尔时净威力士白佛言。世尊。若菩萨摩诃萨欲成就一切福德庄严者。应听是三昧。菩萨摩诃萨欲集一切福德者。应听是三昧。若菩萨摩诃萨欲得不思议福德者。应信是三昧。应听是三昧。若菩萨摩诃萨欲得无尽福德者。应当修行于是三昧。若菩萨摩诃萨欲到一切福德大海者。应当受持读诵修说于是三昧。若菩萨摩诃萨欲得百福相者。应当修行于是三昧。尔时净威力士复白佛言。世尊。菩萨摩诃萨何法相应成就。满此一切福德庄严修集一切福德不可思议福德无尽福德大海福德满百福相。尔时佛告净威力士。善男子。有于三法为福德柱。福德庄严福德来集。福德增广。福德无尽。福德大海。福德叵思。何等三。谓一布施庄严。持戒庄严。多闻庄严。善男子。云何菩萨摩诃萨修行布施庄严。善男子。菩萨摩诃萨应生是心。若布施时不见施心。不见所施及以受者。不见眷属。若有乞者来有所求。为摄护故。不以王位封邑财物诸珍宝等而有吝惜生于异心。善男子。是菩萨摩诃萨作如是念。今我此身悉已给施一切众生况余财物。若已施者终无悔心。须财施财。须食施食。须饮施饮。须眼施眼。须肉施肉。须血施血。须髓施髓。须于支节施与支节。须头施头。我悉当施。况余财物。谷米金银衣服璎珞象马车乘国城王宫男女妻妾奴婢眷属无不舍者。若有众生随其所须而求索之。我随所有悉当施与。无有忧悔不望其报。起慈悲心为摄众生。摄取众生乃至成佛终无有尽。善男子。若有菩萨发如是心。名菩萨布施庄严。复次善男子。菩萨不自观计身命。宁舍身命终不为恶。不为养身邪命自活。宁舍身命不恼于他。不为封邑造行诸恶。不为眷属炽然诤讼。不为妻妾及以男女嫉利他财。不生悭心常恒少欲。乃至不生一念恶心。况复多也。为断悭贪不生嗔恚。无嗔恚故正行相应。正行想应故到于正处。到正处故正戒相应。正戒相应故亲善知识恭敬供养。恭敬供养善知识故得闻正法。闻正法已如说修行。如说修行已则能利益邪道众生。不作众恶随顺善法。得知方便知众生根。善男子。而是菩萨行施庄严得是功德。复次善男子。菩萨摩诃萨不生内外想。若内地大若外地大等无异想。何以故。身犹如墙壁草木如影如炎。无知无思无作无坚四大所摄。若有斫截刀杖瓦石挝打之者终不生报。不观计身不爱寿命。于诸众生不起嗔恚。彼众生所修慈悲心。善男子。犹如药树。若有取根茎节枝叶花须及果。终不作念取根莫取茎。取茎莫取根。如是乃至枝叶果实亦尔。而是药树都无想念。然能寂灭一切众生。若上中下所有病患。如是善男子。菩萨摩诃萨于四大身生药树想。随诸众生须手与手。须脚与脚。须眼与眼。须肉与肉。须血与血。须骨与骨。须髓与髓。须头与头。须支节者施与支节。善男子。若是菩萨以如是心行施庄严趣向无尽。菩萨摩诃萨行布施时。为悭众生令成满施。少福众生具满福德。贫穷众生满大封邑。若舍支节为令众生具满支节。如是布施不向三处。何等三。不求王位自在。不求大富自乐。不向声闻缘觉菩提。如是布施为满四净。何等四净。谓佛土净。菩萨僧净。化众生净。回向一切智净。菩萨摩诃萨应当如是回向四净。复次菩萨摩诃萨施住无尽。何等名为菩萨施住。善男子。菩萨摩诃萨有四法布施。是施有尽。何等四。谓不回向。无有方便。所为下劣。近恶知识。善男子。是名菩萨四法布施是施有尽。善男子。菩萨有四法布施施住无尽。何等四。谓回向菩提。有巧方便。为得法王。近善知识。善男子。是名菩萨四法施住而不可尽。复次善男子。菩萨摩诃萨应念三法而行布施。谓念不离菩提之心。怜愍一切所有众生。不违佛语不望果报。善男子。是名菩萨念于三法而行布施。复次善男子。菩萨摩诃萨安置众生于三法中而行布施。何等三。谓安众生菩提道中而行布施。为安众生善赞法中而行布施。为安众生着无上门中而行布施。善男子。是名菩萨摩诃萨安置众生于三法中而行布施。复次善男子。菩萨摩诃萨悕望二法而行布施。何等二。所谓悕望有大封邑。能行舍心。善男子。是名菩萨悕望二法而行布施。复次善男子。菩萨摩诃萨为满二法而行布施。谓智与慧。善男子。是名菩萨摩诃萨为满二法而行布施。复次善男子。菩萨摩诃萨进趣二法而行布施。何等二。谓尽智。无生智。善男子。是名菩萨摩诃萨进趣二法而行布施。复次善男子。菩萨摩诃萨修行四施。何等四。谓等心行施。不望果报施。向菩提施。满诵寂施。善男子。是名菩萨修行四施。是故善男子。菩萨欲趣至无尽福。应当修行如是布施。尔时净威力士即白佛言。希有世尊。如来说施摄取一切佛之正法。世尊。若有菩萨成就是施。无有能量是菩萨福

佛言。如是如是。善男子。若有菩萨成就具足如是布施。知是菩萨成就具足无尽福德大海福德。不贫圣法成大封邑。住在法流获得大财。具足七财成大福德。持百福相为大福田。养育一切诸众生等

集一切福德三昧经卷上集一切福德三昧经卷中

        姚秦三藏鸠摩罗什译

尔时佛告净威力士。善男子。云何菩萨摩诃萨净戒庄严。谓戒净无缺不舍学戒。愍于毁禁极敬持戒。净身三业净口四过净意三业。自成十善教他十善。不自称誉不起戒慢勤进修戒。头陀德中心不动转。住于圣种自护己心。不见他过不作众恶。不愿诸有亦不喜乐。劝他修善勤营助他。不悕望乐劝人布施。不舍阿练若处。为病给使。作已欢喜。如说如作。失利不忧得利不高。毁誉称讥及与苦乐心不倾动。断除爱恚不怀怨嫌。修行慈心视怨如亲。不以戒自高。不向余乘不礼余天。舍离诸见盖覆使缠断除灭悔。舍财无悔心生欢喜。不生诸有心不愿乐。忍于疲苦善护进心。远离着心不惊怖畏无生法忍。善男子。菩萨摩诃萨为集此戒。乃至失命终不毁犯。不为王位护持禁戒。不为生天不为帝释。不为梵王护持禁戒。不为封邑不为自在。不为妙色护持禁戒。不为端正不为名称。不为赞叹不为利养。不为恭敬不为活命。不为饮食不为卧具。不为病药护持禁戒。不为眼色不为耳声鼻香舌味身触心法护持禁戒。不依倚色不依受想行识护持禁戒。不依欲界色界无色界护持禁戒。不畏地狱饿鬼畜生。不为救护护持禁戒。不畏人道贫穷困苦护持禁戒。不畏天道贫穷苦故护持禁戒。不畏天龙夜叉乾闼婆阿修罗紧那罗迦楼罗摩睺罗中贫苦恼故护持禁戒。为佛种故护持禁戒。为住听法如闻而行护持禁戒。为僧种故护持禁戒。为欲出过生老病死忧悲苦恼故护持禁戒。为欲解脱诸众生故护持禁戒。为安乐利益诸众生故护持禁戒。欲住佛法故护持禁戒。欲转法轮故护持禁戒。为集圣种故护持禁戒。为不断佛法僧种故护持禁戒。为妙神通故护持禁戒。为戒定慧解脱解脱知见故护持禁戒。为神足变化应现无方护持禁戒。如是持戒不毁不缺不穿坚实。无所作为具足成就。精妙无染清净香洁。智者所赞诸佛所叹。如法修行坚固真实。若菩萨成就如是持戒。不失十法。何等十法。谓不失于转轮王位。既在是位不生放逸。悕望欲得无上菩提愿得见佛。不失帝释既得是处不生放逸。悕望欲得无上菩提愿得见佛。不失梵王既生是处不生放逸。悕望欲得无上菩提愿得见佛。净信正真不失闻法。如所闻法善能分别。不失摄取菩萨智慧。不失无断无碍辩才。不失集聚一切善根。不失一切诸佛声闻缘觉所赞。不失疾能通达一切诸佛智慧。若菩萨成就如是持戒。不失此十法。菩萨成就如是戒聚。诸天常礼诸龙宗敬。夜叉常供诸乾闼婆亦常供养。阿修罗敬侍。诸王婆罗门长者居士皆尊重之。智者常趣诸佛常念。诸天世人常师事之。常愍众生。若菩萨如是净持戒聚。不生四处除化众生。何等四。不生边地。不生无佛国。不生邪见家。不生恶道。菩萨如是净持戒聚不生四处。复次善男子。菩萨如是净持戒聚不失四法。何等四。所谓不失菩提之心。不失念佛。不失闻法。既闻法已。乃至无量阿僧祇劫而不忘失。是为菩萨净持戒聚不失四法。善男子。若菩萨如是净护戒聚不值四处。不值法灭。不值刀兵劫。不值饥饿劫。不值劫烧。菩萨如是净持戒聚不值是四。复次善男子。菩萨如是净持戒聚得四胜法。所谓不诳佛。不诳诸天。不诳众生。不诳自心。菩萨如是净持戒聚得四胜法。复次。善男子。菩萨成就护持戒聚离十种畏。何等十。离地狱畏。离畜生畏。离饿鬼畏。离贫穷畏。离不称赞畏。离诸缠畏。离诸声闻缘觉位畏。离天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽拘办茶罗刹等畏。离魁脍刀杖火毒等畏。离诸师子虎豹熊罴。及多勒叉狐狼蟒蛇。猫鼠百足毒蛇[虫*旦][虫*賴]王贼等畏。菩萨如是住净戒聚离十种畏。善男子。菩萨持戒则能发起一切佛法。乃至起于无上菩提。何以故。若有持戒便有三昧。若有持戒便有智慧。若有持戒便有解脱。若有持戒便有解脱知见。善男子。云何名戒。戒者名为寂调结使。以何缘故名为结使。以染污三有诸众生故。名为结使。云何名寂。无妄想无分别无起着。永不思念一切诸法。是名寂调一切结使。善男子。若菩萨摩诃萨不能如是知寂调结使。是不名为戒聚清净。何以故。若不能知寂调结使。虽生梵世犹为结染。乃至非想非非想处犹为结使。善男子。是故当知寂三界结名净戒聚。尔时净威力士白佛言。世尊。若离三界诸结使染名净戒聚。世尊何故。为菩萨时离三界结还生其中。尔时世尊告净威力士。善男子。菩萨摩诃萨不以自结生于三界。以方便故同在三界。无三界结化众生故。善男子。假使人天能画虚空现诸色像。于意云何。为希有不。如是世尊。如是善逝。是人所作甚为希有。佛言。善男子。菩萨舍离一切结使处在三界。现三乘化是乃希有。净威力士言。世尊。是菩萨成就住解脱门。怜愍众生还住三界。世尊。譬如有人从魁脍所得全身命。既得脱已。复还其所而语之言。汝今杀我莫杀余人。世尊。是三界者如魁脍舍。一切众生喻应死者。生死诸行犹如魁脍。从得脱者犹如菩萨脱三界已为化众生为脱众生还住三界。世尊。是菩萨大悲。诸声闻缘觉所不能及。何以故。声闻缘觉无是大悲。无善方便。无净戒庄严。世尊复告净威力士。善男子。云何菩萨摩诃萨善能修集多闻庄严求学多闻。善男子。菩萨摩诃萨于诸和上阿阇梨所。恭敬供养尊重赞叹随教而行。除舍憍慢速受教诲。于正法中生起药想。于和上阿阇梨所生起佛想。于自身所起病人想。于说法者起明医想。为集佛法不爱身命。于诸财物衣钵之余起恼结想。虽具封禄不生爱着。为重法故一切悉舍。为护正法应舍一切世间珍宝。为得法 故 应舍一切名誉赞叹。为得法王舍诸王位。为舍一切诸结使故。应当勤修集法相应。为救一切诸众生故。应当勤修集法相应。菩萨摩诃萨修集诸法者。一切善根自然而得。是故善男子。菩萨摩诃萨欲成菩提欲竖立智柱。应修多闻。善男子。如帝释堂因柱得住。三十三天在中欢乐。如是善男子。由菩萨智柱。一切诸天世人悉蒙受乐。善男子。若有菩萨发菩提心菩提所摄言欲作佛。于多闻中而不勤修。诸众生中最为无智。是故善男子。菩萨摩诃萨应勤精进修集多闻。诸众生中为多闻柱。是时诸天欢喜踊跃。是善丈夫。坚牢精进修集智慧。必能获得于佛十力。是善丈夫。当以慧力断诸结网。是善丈夫。当演说法断于一切众生结使。是善丈夫。当往至彼菩提树下诸佛坐处。是善丈夫。当以自力降一切魔。是善丈夫。当转十二行相法轮。善男子。若有菩萨修多闻时。一切魔宫皆悉闇蔽。三千大千世界魔王皆悉忧恼作如是言。是人今者胜过我等。其余魔天各作是言。是人降伏于我等主。我等一切悉属是人。何以故。善男子。由是菩萨集多闻慧能寂结使。以无结使魔不得便。已有多闻则能分别。既能分别则能修行。已能修行魔不得便。修多闻者远离邪见得住正见。已能正住魔不得便则能正修。已能正修能分别义。离诸非义便能正度义及非义。善男子。以是缘故应如是知。善男子。菩萨修集是多闻时除四种魔。所谓阴魔烦恼魔死魔天魔。善男子。如本菩萨集多闻时。欲法利法善住于法。我今少说。善男子。乃往过世阿僧祇劫无量无边不可思议。尔时有大仙人名曰最胜。住山林中具五神通。常行慈心作如是念。我今山中修行慈心无所利益。不但慈心能灭众生无量劫中所集烦恼。非此慈心能起正见。复作是念。因于何事能起正见。作是念言。有二因缘能起正见。谓从他闻。闻已正思。以是二法能生正见。是时便生求多闻心。当从何处得闻善说。为法因缘集法相应。尔时仙人至诸聚落封邑郡县王城。处处推求多闻。了不能得说法之师。时魔天子来至其所。作如是言。我今有佛所说一偈。是最胜仙。闻佛偈名即语之言。为我演说。时天报言。汝今若能剥皮为纸。以血为墨折骨为笔。书写此偈。乃当相与佛所说偈。善男子。时最胜仙作是念言。今我此身无量生死。在在生处贼兵魁脍。百千劫中常以无事堕在彼手。利刀割截分解支节。或为欲故。或财利故。杀缚捶打系闭诃骂。受无量苦都无利益唐受割截。我今当以此不坚身易得妙法。欢喜踊跃我得大利闻是法语。于此天所生师宗想。即以利刀自剥身皮干以为纸。复刺出血用以为墨。复折其骨削以为笔。合掌向天而作是言。天为我说佛所得偈。如先所敕。剥皮为纸出血为墨折骨为笔。我悉作已。善男子。时魔天子。见最胜仙恭敬为法。见已愁悴即便隐去。善男子。时最胜仙。见天没已作如是念。我今为法生恭敬心。剥皮为纸折骨为笔。我今如此恭敬求法。而是善根终不败亡。若我此言诚实不虚。起慈悲心为诸众生不惜身命。剥皮为纸出血为墨折骨为笔。若我至心诚实不虚。余方世界大慈大悲能说法者。当现我前。善男子。最胜大仙作是语时。一念之顷。东方去此佛土三十二佛刹。彼有国土名普无垢。是中有佛号净名王如来应供正遍觉。今者现在。知最胜仙心念所作亦欲教化是阎浮提诸众生故。譬如壮士屈伸臂顷。乘空而来到是最胜仙人前住。及五百菩萨。是净名王如来放大光明遍照彼林。天雨众花。时彼树林枝叶花果皆出法音。尔时无量百千万亿诸天来集。是时彼仙得净名王佛光触身已。苦痛悉除还复如故。无有疮瘢。尔时彼仙头面敬礼佛世尊足。右绕三匝合掌顶上。白净名王佛而作是言。世尊。是我师善逝。是我师世尊。我今归依佛归依法归依僧。惟愿世尊。为我说法。我闻法已。不信众生行邪见者。坏正见者。行黑闇者。导示正故而为说法。善男子。尔时净名王佛。因最胜仙。及诸天子诸菩萨等。为其演说此集一切福德三昧法。彼天众中八千天子。本种善根皆发无上正真道心。最胜大仙得大喜悦。生于大信得无碍辩。彼佛如来复为演说八金刚句。何等八。一切诸法性本净句。一切诸法离结使故。一切法无漏句。尽诸漏故。一切法离巢窟句。过巢窟故。一切法无门句。无有二故。一切法普遍句。示解脱门故。一切法无去句。无去处故。一切法无来句。断诸来故。一切法三世等句。去来现在无二相故。彼净名王佛。演说如是八金刚句。是中开解一切法义。复更演说余八法门。令菩萨摩诃萨疾成就智。何等八。谓一切法名字门。以名分别一切法故。一切法音声门。以言分别令欢喜故。一切法共要门。一切诸法决定相故。一切法言说门。虚妄自在故。一切法自相门。离他相故。一切法毕竟尽门。无所有故。一切法分别门。从分别有故。一切法平等门。等一味故。最胜。是名八法门疾成就智。最胜。复有八字种子门。能成就于无尽辩才。何等八。一切法阿字种子门。示法无生故。一切法蛇字种子门。示第一义法故。一切法那字种子门。示字名色故。一切法遮字种子门。示现一切法调伏故。一切法婆字种子门。示一切法入平等故。一切法多字种子门。示如不坏故。一切法迦字种子门。灭苦业故。一切法摩字种子门。究竟成就断一切法故。是名八字种子门。能成就于无尽辩才。是故最胜。是八字种子句门。八法句门。八金刚句门。正念修行常离愦闹恒善思惟。观察修集功德之利。善男子。净名王如来说是法已。放大光明遍照世界。震动大地即没不现。与诸菩萨还至彼土。彼诸众生都不觉知佛来去时。善男子。尔时最胜大仙成就圣辩。诸天侍卫。诸天守护。为降魔故至诸聚落诸城国邑。为诸众生广敷演说此集一切福德三昧。满于千岁常演说法。令八万四千众生住声闻乘。八万四千众生住缘觉乘。八万四千众生住于大乘。八万四千众生作转轮王。八万四千众生作释提桓因。八万四千众生得作梵王。八万四千众生修行于慈。八万四千众生修行于悲。八万四千众生修行于喜。八万四千众生修行于舍。无量众生得生天上。是最胜大仙。后乃命终即往生彼净名王佛普无垢土。及八万四千天子亦生彼土。善男子。于意云何。尔时最胜仙者。岂异人乎。汝勿有疑。即我身是。我本如是欲法敬法说诚实言。便能敬感彼净名王佛来至我所。是以当知。若有菩萨恭敬求法。则于其人佛不涅槃法亦不灭。何以故。净威。若有菩萨专志成就求正法者。虽在异土常面睹佛得闻正法。净威。若菩萨摩诃萨欲法敬法。令诸山岩树木林薮。出诸法藏陀罗尼门。及诸经卷自来在手。净威。诸有菩萨敬法欲法。若有诸天曾见佛者来至其所。从于佛所得闻诸法具为演说。净威。利法菩萨若其寿尽。诸佛世尊增益其寿。佛力持故欲住千岁。即便能住。二千三千四千五千。乃至一劫若减一劫随意得住。净威。若有菩萨敬法欲法。不老不病得忆念力。进趣智慧得于辩才。若有菩萨敬法欲法。得见佛已舍离诸见趣入正见。净威。若有菩萨敬法欲法。一切众生无能侵害。是故净威。是大众生应当勤修多闻庄严。所获功德复过于是。净威。若有菩萨住是三。福庄严福柱广福增。福无尽福不思议。无有能得是福边者。净威。可以一毛数大海渧。无有能尽是菩萨庄严福聚净戒多闻慧聚得其边者。净威。能称三千大千世界草木山林。及诸众生得其轻重。不能称量如是菩萨庄严福戒多闻慧聚得其边者。是名解说智庄严已。尔时净威力士白佛言。世尊。布施庄严。净戒庄严。多闻庄严。是三庄严。何者为最。何者为胜。佛言。净威。三庄严中多闻庄严最可称叹。最胜尊上无上无上上。善男子。如须弥边着一芥子。而是施福及净戒聚亦复如是。犹如芥子。多闻庄严如须弥山。善男子。如一小鸟所住虚空。施戒庄严亦复如是。多闻庄严如余虚空。善男子。布施庄严能作二事。何等二。能除贫穷成大封禄。净戒庄严亦作二事。何等二。一离恶道。二至善处。善男子。多闻庄严亦作二事。何等二。谓能除去一切诸见。能集一切智慧庄严。善男子。布施庄严是有漏报。净戒庄严亦有漏报。善男子。多闻庄严无漏无报。是故善男子。菩萨摩诃萨应勤精进修多闻慧。说是施福净戒多闻庄严法时。三千众生本种善根。便发无上正真道心。五千天子于诸法中远离尘垢得法眼净。净威力士得无生法忍。尔时净威力士白佛言。世尊。菩萨摩诃萨成就几法。疾能获得无生法忍。佛言。善男子。菩萨成就四法。疾能获得无生法忍。何等四。谓解知身犹如镜像。解知言说犹如响声。解心如幻。解诸法无二。净威。当知菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨摩诃萨成就四法。疾能获得无生法忍。何等四。谓慈悲普覆遍一切众生无众生想。解诸法空不见所解。观见佛净不以肉眼住于慧眼。善分别心而不见心不依猗心。善男子。菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨成就四法。疾能获得无生法忍。何等四。所谓不舍一切众生。舍离诸见。护持净戒。寂一切结。善男子。菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨成就四法。疾能获得无生法忍。何等四。谓有忍力。法转增胜。勤行精进。解法寂静。善男子。菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨成就四法。疾能获得无生法忍。何等四。所谓得禅而不依禅。以慧分别无有戏论。成就方便摄取众生。增长诸行善知诸行。善男子。菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨成就四法。疾能获得无生法忍。何等四。谓以大慈救诸众生。谓以大悲不厌生死。谓以大喜欣乐于法。谓以大舍断一切爱。善男子。菩萨成就是四法者。疾能获得无生法忍。复次善男子。菩萨成就四法。疾能获得无生法忍。何等四。谓得三解脱门。解知三世。超过三界。信法性无生。善男子。菩萨成就是四法者。疾能获得无生法忍。演说如是诸四法时。净威力士得无生法忍。欢喜踊跃上升虚空高七多罗树。尔时三千大千世界六种震动。人天伎乐同时俱作。天雨花云。大光普照遍此世界。尔时世尊即便微笑。诸佛常法若微笑时。若干百千青黄赤白红。紫等光。从面门出。遍照无量无边世界。上过梵世。还绕身三匝从顶相入。时大德阿难即从坐起。整衣服偏袒右肩右膝着地。合掌向佛白言。世尊。佛不妄笑。今者世尊何缘而笑。说偈问曰

  得无上智无垢眼　　诸根寂静到彼岸
  大光须弥金山色　　导师以何因缘笑
  善知众生诸根行　　净慧相应知三世
  得于无想最上智　　面如满月说笑缘
  如过去佛及未来　　现在诸佛尊亦尔
  种种真实清净行　　善知一切如实义
  其身普遍诸佛界　　音声亦满诸佛界
  慈心普遍诸众生　　愿说谁与智相应
  自在知法如水月　　如幻化相亦如梦
  如空如电清净法　　今人师子何缘笑
  解空无相无愿法　　善知实性常调心
  如风游行虚空中　　惟愿演说何缘笑
  今佛智慧知谁心　　谁应道树下降魔
  谁当坐于金刚座　　人仙今者何缘笑
  非是声闻之境界　　亦非缘觉之所及
  是佛大海智境界　　愿说所为之因缘

尔时佛告阿难。汝今见是净威力士住虚空不。阿难。是净威力士。过三百亿阿僧祇劫。当得作佛号多庄严王出现于世如来应供正遍觉明行足善逝世间解无上士调御丈夫天人师佛世尊。于此东方国名严净。劫名梵叹。阿难当知。是多庄严王佛严净国中当得成佛。其土丰乐安隐炽盛。是诸人众所受用物如兜率天。是庄严王佛。不说余法惟菩萨乘。乃无声闻缘觉乘名。纯菩萨僧皆得法忍。无诸八难无有魔怨及诸外道。彼佛寿命无有限量。琉璃为地阎浮那提金花以间错之。尔时净威力士。从空而下顶礼佛足。合掌向佛求索出家。佛即听许。尔时那罗延菩萨白言。世尊未曾有也。善逝未曾有也。乃能以是胜妙善法善调众生。乃至能令如是憍慢竞胜众生。是等当见佛如来时。即得欢喜除舍憍慢礼如来足。如此净威大慢力士。除舍慢已得胜上法。复当调伏无量众生除舍憍慢。世尊。是净威力士。为曾供养几佛世尊种诸善根。乃能如是速疾开解。尔时佛告那罗延菩萨。那罗延。是净威力士。曾于过世供养六十二亿诸佛。种诸善根。从今已后当复值遇无量无边阿僧祇佛。恭敬供养尊重赞叹净修梵行。那罗延言。世尊。是净威力士。复以何缘怀大憍慢求佛竞胜。佛告那罗延。菩萨摩诃萨有四法忘菩提心。何等四。谓增上慢。不敬重法。轻善知识。说不实语。那罗延。菩萨有此四法忘菩提心。那罗延。菩萨摩诃萨复有四法忘菩提心。所谓赞叹趣向声闻缘觉乘者。呵向大乘。毁呰菩萨。吝惜于法。那罗延。菩萨有是四法忘菩提心。那罗延。菩萨复有四法忘菩提心。何等四。于诸众生行幻惑术。诈伪亲近。于善知识合偶言说。为利养故。那罗延。菩萨有是四法忘菩提心。那罗延。菩萨复有四法忘菩提心。何等四。不觉魔事。不除业障。志意羸弱。无方便慧。那罗延。菩萨有是四法忘菩提心。那罗延。是净威力士。本造恶。业忘菩提心。我今当说。汝善听之。乃往过世。此贤劫中。有佛出世号迦迦孙。是佛法中有大婆罗门名曰善财。起大憍慢得增上慢不往佛所。憍慢增上与说王法。诸婆罗门而共诤竞。是憍慢故。获得现报退失多事。谓不见佛不闻正法。亦不得闻趣向菩萨大乘之法。亦不得闻诸天净法。亦不得闻功德善根。回向菩提而不坚固。为此五恶法遮持故离菩提心。那罗延。于意云何。尔时善财婆罗门者。岂异人乎。汝勿有疑。即今净威力士是也。以憍慢故忘菩提心。以菩提心本善根故不堕恶道。虽成大力犹有憍慢。佛力所持得闻佛力及菩萨力。舍离傲慢将来见佛。不作众恶因本善根。今现发起速疾得是无生法忍。尔时那罗延菩萨语净威力士。汝住何法得无生忍而受记别。净威答言。我以生起诸凡夫法得受记别。那罗延言。云何而生。净威答言。生如不生。如是生。灭如不灭。如是灭。如是而生亦复不住。那罗延言。善男子。若其尔者。佛法凡夫法。有何差别。净威答言。以文字故有差别耳。若以其义则无差别。那罗延言。是凡夫法有何义也。净威答言。无妄想无分别。是凡夫法义。那罗延言。是义何趣。净威答言。而是义者。离凡夫法趣于佛法。那罗延言。佛法有何义。净威答言。不作二是佛法义。那罗延言。善男子。如佛所说。依法不依人。又复说言。有二因缘起于正见。何等为二。因外言声。内善思惟。如是之义即是文字。净威答言。那罗延。依法菩萨不取文字不取非文字。若得文字是即为义。而是义者是不得义。是故不依于义。一切诸法都无有义。何以故。一切诸法不可得故。非方不离方。随所住处即处自灭。如佛所说。毕竟灭想是名为义。是故那罗延。依义者。无法可依无不可依。若依非依是名为义。那罗延言。善男子。颇有依义即是依于一切法也。净威言。有。那罗延。一切法空。一切法寂。一切法空。依亦如是。一切法寂。依亦如是。如是那罗延。若依是义即依诸法。那罗延言。净威。若如是者。一切诸法常自是依。净威答言。如是如是。那罗延。一切诸法皆第一义。依第一义者彼得安乐。彼应当求于第一义。若能不起法及非法。不求二不求不二。是名为圣分别选择。而是选择无作无不作。若无作无不作。是名为作所求。求者义不相违。净威力士说是法时。五百比丘不受诸法。漏尽心得解脱。八千天子远离尘垢得法眼净。尔时那罗延菩萨语净威力士。如佛所说。依义不依文。然此众生不解是义行于二行。是不解文亦不解义。为是不解。故说依义不依于文。依文依义。是义出过于诸文字。善男子。如佛所说。有二因缘能生正见。谓彼有人不闻正法调伏法中。以少缘故便生欢喜。言我出生死。彼是增上慢。本是增上慢。为劝是人令勤修行。彼闻法已。即便修行趣于正道。是故佛说 闻已得知法闻已不作恶闻已离无利闻已得涅槃

那罗延言。云何比丘念法相应。净威答言。无相应无不相应。若能如是念法相应。那罗延言。彼修行者是语相应。复次那罗延。若有比丘与念法相应。则不起嗔不起憍慢。是名正思惟。若有观察说法去来现在。若解所说。为断故说。为解故说。为修故说。不得过去世之所作。不得未来世之所作。不得现在世之所作。是正修行。若正观一切法性常灭。是名正修思惟所见。若见一切法性常寂。是名修正思惟所见。若正观一切法性常定。是名修正思惟所见。若正观诸法毕竟不生。是名修正思惟所见。若正观一切法实无常。是名修正思惟所见。若正观一切法无常灭。是名修正思惟所见。若彼见者及以所见。都不可见如如见如不见。如是名为说示思惟。是时世尊赞净威力士。善哉善哉。善男子。汝之所说如是相应。若能如是。则于诸法无有愚痴。如是修行则无有障。正修行者。无缚无解。何以故。正思惟者。于一切法无断无趣。若如是者。名为正见见一切法。如是正见。云何正见。谓不见法。所言见者。是说无生不实之言。语不实者说无生名。如我所说。诸法无生以慧初见。若至正位名为正见。若如是见名至正位。以何因缘名为正位。我与无我二俱平等。如无我等诸法等起。是名正位

集一切福德经卷中集一切福德三昧经卷下

        姚秦三藏鸠摩罗什译

尔时那罗延菩萨即白佛言。希有世尊。希有善逝。诸法如是性常寂灭。菩萨摩诃萨能听是法。能知是法。能信是法。不中涅槃。佛告那罗延。菩萨方便力能如是。若菩萨成就善方便者。于念念中能得四法。何等四。谓大慈大悲知一切智佛出于世不断法种。如是四法修行诸法。知众生界是正位相。知一切法性常寂灭。闻知信解不中涅槃。是名调伏法知利众生。知已而见乃至不见。何以故。不舍一切诸众生故。尔时净威力士白言。世尊。菩萨摩诃萨如佛所说不堕正位。佛言。善男子。是菩萨摩诃萨。不作诸见。然事无不办。声闻之人不缘一切众生。不缘佛种。不缘法种。不缘大乘。舍一切智。不观一切智。不愿一切智。灭有为法入声闻位。菩萨摩诃萨缘一切众生。缘不断三宝种。缘于大乘。观一切智不观于命。知诸法一相不入正位。缘诸众生游戏诸禅。不堕声闻位。善男子。是故当知菩萨摩诃萨。常恒无我不堕正位尔时净威力士白佛言。希有世尊。希有善逝。菩萨所行。一切声闻缘觉之人所不能及。尔时文殊师利法王子在会而坐。那罗延菩萨白佛言。世尊。是文殊师利法王之子。在此会坐。乃能于是集一切福德三昧而无所说。尔时文殊师利语那罗延菩萨言。善男子。菩萨摩诃萨不为福德故修行菩提。菩萨不为利养名称。不为生天不为封邑。不为眷属不为赞叹。不为自乐。修行菩提。那罗延言。文殊师利菩萨以何而行菩提。文殊师利言。善男子。菩萨为悲诸众生故修行菩提。为于法故。为脱一切众生苦故。为断不实诸烦恼故。忍自苦故。无所为故。修行菩提不惜身命。观知无主无宰无居无相无思。无转无坏无迁流转。无侵毁害勇健无降。无知解无懒堕。无怖无畏无惊无恐。无高无下无谄曲。坚住不动。乐寂独一。一道一趣。住于一道修行一道。为度一切诸众生故。为如是利故。菩萨摩诃萨修行菩提。又问文殊师利。菩萨云何修行菩提。文殊师利言。善男子。菩萨摩诃萨无生无灭。非无生灭行毕竟灭。无有余生无所言说。菩萨如是修行菩提。复次那罗延。菩萨知过心已灭无所能行。未来心未至无所能行。现心不住无所能行。不着去来现在之心。菩萨摩诃萨能如是行。名修行菩提。复次那罗延。菩萨若知施及菩提众生如来等无二行。持戒菩提众生如来等无二行。忍辱菩提众生如来等无二行。精进菩提众生如来等无二行。禅定菩提众生如来等无二行。智慧菩提众生如来等无二行。菩萨如是行六波罗蜜。则不坏败行之性相。菩萨如是修行菩提。复次那罗延。菩萨观色空无有行。如观色空。观受想行识空无有行。色空无尽色毕竟尽。以其空故。受想行识。识空无尽识毕竟尽。以其空故。如其性尽一切法尽。色无尽受想行识无尽。若有菩萨如是行者。是名为修菩提之行。复次那罗延。菩萨勤断凡夫法行。不生佛法行。不出生死行。不满涅槃行。不见一切不善法成。不集善法不异处观。如是解知不坏行性。是菩提行。那罗延。菩萨如是行。是名为修菩提之行。复次那罗延。菩萨摩诃萨解众生界无量法界无量。众生界法界无尽灭行。何以故。众生界法界无有二故。无有二作。无有二相。不增不减法界。不增众生界。不减众生界。如法界相众生界相亦复如是。又菩萨解知诸法无相。不尽法界行。不尽众生界行。不尽法界行。不增法界行。不尽众生界行。不增众生界行。亦不住余妄想颠倒所起结使。如是正观善知诸行。不坏诸有行。不坏我众生寿命行。那罗延。菩萨如是行名修菩提行。文殊师利法王子。演说如是诸行法时。十六天子先向大乘。今者逮得无生法忍。尔时净威力士。欲为供养守护是经。便作是言。世尊若有众生信解是经。当得一切诸善吉利。尔时离魔菩萨语文殊师利。我亦欲说菩萨所行。文殊师利言。善男子。今正是时。汝可演说。离魔菩萨言。文殊师利。行一切法行是菩萨行。行一切魔行是菩萨行。行一切众生行是菩萨行。若行学行无学行是菩萨行。行缘觉行是菩萨行。何以故。菩萨摩诃萨应遍学故。尔时那罗延菩萨问离魔天子。云何菩萨学行一切诸众生行。天子答言。那罗延。菩萨应学八万四千行。何等八万四千行。谓二万一千是贪欲行。二万一千是嗔恚行。二万一千是愚痴行。二万一千是等分行。菩萨悉应入是诸行行。于贪欲断离贪欲行。于嗔恚断离嗔恚行。于愚痴断离愚痴行。于等分断离等分行。菩萨行一切众生行。不染众生行。现行一切诸众生行。为化众生故。是名菩萨行菩提行。那罗延言。天子。云何一切魔行是菩萨行。天子言。一切魔行入菩萨心。菩萨应觉随所起魔业而不随之。不为魔行之所系缚。入一切行而修行之。应示魔天令不得便。当教化魔离于魔业。那罗延言。天子。云何学声闻缘觉行是菩萨行。天子言。善男子。如是一切行。是实性行。是无报行。是无住行。是无趣行。是无生行。解知自行。菩萨应当如是修行。离魔天子如是说已。语文殊师利法王子。善男子。汝今复说如是之行。文殊师利言。天子。菩萨所行过诸境界。何以故。此行非是眼境界数。亦非色声香味触法境界之数。天子。是故当知。是善丈夫所行诸行。过诸境界。复次天子。若菩萨摩诃萨如是修行。则是诸佛之所许可。无有过咎。若如是行。是名菩萨修行正行。天子言。文殊师利。菩萨云何修行。诸佛所许可行。文殊师利言。天子。一切诸法实际自空。如来如是而觉知之。若菩萨住如是法行。佛所许可。若乃至涅槃。生见着行。则诳诸佛。天子。一切诸法实际无相。如来世尊如是觉知。若有菩萨为诸法作相。与相俱住。则诳诸佛。一切诸法实际无愿。如来世尊如是觉知。无行无实无生无起无所有。无形无相亦非无相。无来无去无住。本性清净。本性明了其性常灭。一切诸法犹如虚空。如来世尊如是觉知。若是菩萨于诸法性若有少得。则诳如来应正遍觉。天子。若是菩萨共空俱住。生于见着。是菩萨共无相俱住。生于见着。若是菩萨共无愿俱住。生于见着。则诳诸佛。若是菩萨出过三界。知一切法无实无生无起。无有无形无相。无来无去无住。本性清净。本性照明。本性常灭。同如虚空本性无垢。若如是知。是名菩萨不诳诸佛。尔时世尊赞文殊师利。善哉善哉。文殊师利。快说此语。若是菩萨如是修行。名菩提行疾得受记。文殊师利。我昔过去于然灯佛前。所住诸行都不得记。何以故。我有相行有所依行有所著行。我于是后见然灯佛得过诸行。当初见时离诸行见。知一切法自性不生。时然灯佛授我记言。汝于是后当得作佛。号释迦牟尼如来应正遍觉。我于是时得无生忍。是故文殊师利。若有菩萨欲速疾得无生法忍。于是品中应如是修。不着诸法尔时文殊师利白言。世尊。菩萨摩诃萨为缘何法得无生忍。佛言。文殊师利。缘阴界入得无生忍。彼得一切诸法之忍亦复缘于常乐我净。彼得法忍。文殊师利所言忍者。名缘一切诸法无尽。所言忍者。名之为正。文殊师利。忍之所缘。非与世法而共俱行。非凡夫法。非学法非无学法。非缘觉法。非菩萨法。非佛法。而俱共行。不与一切诸法俱行。名为得忍舍于一切诸法想着。名之为忍。是忍亦不在于眼色耳声鼻香舌味身触意法数中。无尽不尽名之为忍。是忍亦复不离是界。是名为忍。说是忍时有五百菩萨本先佛所种诸善根。得无生忍。作如是言。此集一切福德三昧。能令我等住于所住。亦令我等满无量法。世尊。菩萨摩诃萨应至心听甚深诸法应当修集。尔时那罗延菩萨问文殊师利。云何菩萨于是深法所作已办。文殊师利言。若有菩萨知一切法无作无不作。是名菩萨所作已办。若知一切诸法无行作已不执不作无忘。是名菩萨所作已办。若是菩萨随所作无恩。是名知恩。有为无为不生高下。不得作者亦有所作。谓作布施住于回向。亦不得施不得菩提不得自他。是名菩萨所作已办。守护净戒回向菩提亦不得戒。修行忍进禅定智慧亦不得慧。是名菩萨所作已办。若不得身口意善业。知是菩萨所作已办。若不得身不得口意所集庄严知是菩萨所作已办。尔时常精进菩萨语文殊师利。我亦欲说菩萨摩诃萨所作已办。文殊师利言。善男子。今正是时汝便可说。常精进菩萨语文殊师利言。若菩萨能令一众生入佛法中。如是菩萨所作已办。若有菩萨受众生食若施与他。不以畏故皆悉。摄在无上菩提。是名菩萨福田清净。若彼施者及与受者如法而作。是名菩萨二俱清净。若是菩萨以佛音声令他得闻。自住施戒忍进禅慧作正忆念。于大众中说六波罗蜜。令他得闻忆念受持如此善根。知是菩萨所作已办能消供养。若是菩萨修行忍辱。若为怨贼旃陀罗等之所骂辱。不嗔不恼。为是众生令生信喜。勤修精进住精进力知是菩萨所作已办。若是菩萨以真金宝满四天下。不贪是宝而作妄语。若他问法不相朋党说言非法。知是菩萨所作已办。若有菩萨七日绝食。若有人来作如是言。汝若能舍菩提之心。杀诸众生当与汝食。而是菩萨终不为之。知是菩萨所作已办。复次文殊师利。若是菩萨见满世界利刀猛火。当从中过而往听法。不爱身命作如是学。念阴入界易得。佛难可遇法难可闻。敬法众生甚亦难得。作是念已入众听法。知是菩萨所作已办。复次文殊师利。若是菩萨从他人闻一四句偈。若戒若施心生欢喜。胜得转轮立大王位。若以此偈令一人闻。胜得帝释及梵王处。知是菩萨所作已办。复次文殊师利。若是菩萨能住众中。在多闻中生大喜悦。以此多闻向一切智。不得满三千大千世界珍宝生大欢喜。以自善根为一众生回向佛道用为欣庆。知是菩萨所作已办。复次文殊师利。菩萨为化诸众生故应勤精进。坚自庄严修集多闻舍身支节。于世八法其心无异。若是菩萨为佛慧故。宁舍身命不舍持戒。菩萨应当作于忍辱。能忍诸恶不善音声。菩萨应当勤加精进庄严佛土。菩萨应当独一寂处。为不败失菩提道故。菩萨应当不失正念。为修集六波罗蜜故。菩萨应当无所执着。勤进戒满已作善业。不舍一切诸众生故。菩萨应当坚誓庄严。为佛法种故。菩萨应当离诸谄伪。身口意法善质直故。菩萨应当自净志欲。为救归依诸众生故。菩萨应当无所观作。不着身命故。菩萨应当甘软好语。善来问讯故。菩萨应当常先意语。无有嗔愤不言说故。菩萨应当犹若如地。无爱憎故。菩萨应当柔和善软。同心欢乐故。菩萨应当善易教诲。速受教故。菩萨应当除舍憍慢。谦下一切诸众生故。菩萨应当犹之如狗。不诳一切众生。不违本誓故。菩萨应当诸众生中起大慈心。一切空故。菩萨应当诸众生中起大悲心。为诸众生作大利故。菩萨应当生于大喜。欣乐修集诸善根故。菩萨应当修行大舍。不观一切五欲乐故。菩萨应当不贪悭惜自舍身故。菩萨应当不着我所。不贪一切诸财物故。菩萨应当修大舍心。舍一切妄想故。菩萨应当具满大财。圣七财故。菩萨应当牢坚志。固一切善根故。菩萨应当无有满足。修集无量佛功德故。菩萨应当智慧勇健。摧四魔故。菩萨应当作大医王。善治一切烦恼病故。菩萨应当为作应供。不舍菩提心故。菩萨应当作于福田。为诸众生作光明故。菩萨应当犹如莲花。不为世泥所染污故。菩萨应当犹如船筏。度诸众生故。菩萨应当犹之如桥。于上中下一切众生无别想故。菩萨应当犹如大池。专意正法水无尽故。菩萨应当犹如大海。一向多闻无厌足故。菩萨应当犹如大山。无能动故。菩萨应当善安止住。如门阃故。菩萨应当无所染着。一切所有诸财物故。菩萨应当令心自在。不退转故。菩萨应当犹如大王。为尊胜故。菩萨应当犹如帝释。一切众生所尊贵故。菩萨应当犹如梵王。自在法王故。菩萨应当安乐一切诸众生等。究竟安乐至涅槃故。菩萨应当为作父母。与诸众生衣服利故。菩萨应当无所伤损。一切善不善法故。菩萨应当无所侵害。亲非亲中心平等故。菩萨应当不亲不信。所生诸入故。菩萨应当为法施主。一切悉舍故。菩萨应当离于一切放逸懈怠。为集菩提故。文殊师利。菩萨常应牢强精进。修集一切诸戒德行。为得无上正真道故。尔时世尊赞常精进菩萨摩诃萨。善哉善哉。善男子。善说诸行所应住想。善男子。若菩萨摩诃萨欲逮得此集一切福德三昧者。应当勤修一切福德。不应舍离一切福德。尔时那罗延菩萨白言。世尊。若有得此集一切福德三昧者。不堕恶道不生八难。断诸贫穷心常自在。诸根具足以三十二大丈夫相善自庄严。得大辩才及无尽法。得陀罗尼得不忘念。起一切福转法轮故。得灌顶位。释梵护世一切众生所供养故。得具诸通达一切死此生彼故。得大自在在在所生诸所入故。得大封邑增长诸法故。得智光明离恶邪见故。得大称赞。一切声闻缘觉地故。得大调伏。一切声闻缘觉人故。善分别诸根。教化众生故。神通自在。诸禅解脱三昧门故。得无作施。解知施故。得无住戒。三戒净故。有无量忍。慈心普遍诸众生故。修行精进。心无疲惓故。得禅波罗蜜解知寂静。为化众生生欲界故。净慧庄严。善观音声故。是名净眼能见道故。不离见佛及与闻法。不离于空无相无作。能持一切佛所有法不离睹见。得不退转菩萨之僧。去无障碍一切佛土诸功德故。降伏诸魔胜四魔故。得深法忍不退转法故。疾能通达满足佛法。所未闻法自来入耳。欲愿具足取一切佛土诸功德故。彼得安隐离诸习故。得自在身。普遍三界而示现故。一切外道不能降伏。善守护法于诸佛所。舍失身命守护正法故。见佛境界而不毕竟入涅槃故。得无所畏在众无畏故。有所在作为以智为首。心无所营故。现大庄严。神通变化故。得大势力过诸害故。净音声扬。遍闻一切诸世界故。心大勇健。摧伏一切诸魔军故。到神通彼岸。能动一切佛世界故。得大辩才。法辞及义无碍滞故。知解无碍而无放逸。住作佛事示诸众生一切智故。那罗延。若菩萨入是集一切福德三昧。得于如是相貌事像无量功德。尔时那罗延菩萨白言。世尊。愿诸众生得集一切福德三昧如此。菩萨得是三昧所有功德。令诸众生得是功德。一切声闻及诸缘觉之所无有。世尊若有菩萨不得闻于是三昧宝。虽闻不解。当知是人为魔所持。佛言。那罗延。如是如是。如汝所说。若有菩萨闻是三昧所生功德。若已生若今生若当生无量无边。尔时那罗延菩萨问文殊师利。若有菩萨欲修集行是三昧者。当行何法。文殊师利言。菩萨欲得是三昧者。不舍凡夫法为持佛法。如是修行不与法相应。不与非法相应。如是修行虽流转生死。不学生死法。不为生死所染。虽学涅槃不入声闻缘觉涅槃。复次那罗延。若有菩萨欲学此三昧。应益增长集一切福德。不于有漏无漏诸功德中生起妄想。若善不善有为无为世间出世间。若罪若福起于分别。解一切福德皆入法性。若福法行若罪法行若无记法行皆入法性。应如是见诸众生福等不实起。是众生福佛福悉皆同等不见差别。法界无异起无差别。若凡夫福学福无学福。缘觉福菩萨福正觉福。悉皆不实无有物故。无有方处无非方处。应如是知应解福性众生同等。善男子。如一切色皆依四大。菩萨之福亦复如是遍一切处。终不起于福德狂逸。应知无常尽灭之法。那罗延。若菩萨欲得此三昧者。于四法中而不惊畏。何等四。于诸众生大悲无边。佛刹无边。佛智无边。入一切众生心行无边。那罗延。菩萨于此四无边中不应生畏。又复菩萨应当解知四不思议。何等四。业及业报不可思议。一切众生种种诸行若干差别不可思议。佛如来行不可思议。菩萨生起诸清净行不可思议。那罗延。是名为四不可思议。应当解知。善男子。菩萨解知得四无尽。何等四。福德无尽。满誓无尽。乐说无尽。究竟智无尽。那罗延。是为菩萨得四无尽。那罗延。菩萨应当修行四法。何等四。庄严善根无有满足。方便回向一切无尽无有满足。一切佛土诸庄严事。取以庄严自己佛土无有满足。(梵本中少一)那罗延。菩萨应当如是修集行是四法。尔时那罗延菩萨复问文殊师利。此集一切福德三昧经。当至何等菩萨之手。若是经卷若至舍宅。若禅若忍若在家若出家。文殊师利言。那罗延。若菩萨摩诃萨闻是三昧。若至于耳若至其手若至舍宅。彼人若当不起诽谤。如是之人我不名之为在家者。当名是人为出家者。何以故。由是菩萨勤修分别是三昧故。彼人当能除一切想。在在住处一切福德及与智慧。无尽无散。那罗延。菩萨为化诸众生故。示现种种形色相貌。那罗延。是人遍至一切诸处。犹如日月照四天下一切悉现。如是那罗延。菩萨亦尔不依诸难。虽在家中而不依家。亦非出家不依沙门法二俱叵说。何以故。菩萨不依一切所有及诸入故。那罗延。如琉璃宝器随所在处不失其性。如是那罗延。若有菩萨住是三昧。虽复在家当说是人名为出家。能不失是法界体性。尔时那罗延问文殊师利。菩萨摩诃萨住在何处。而能不失是集一切福德三昧。得于如是无尽福德智慧庄严。文殊师利言。菩萨摩诃萨有四住处。何等四。所谓菩萨不住身命及诸利养。尊重赞叹住空无相无愿三昧。不住声闻缘觉正位。悕望佛智及无碍辩。而无贡高妄想分别。亦不执着如是住处。是菩萨住解脱一切所有众生。不住我人众生寿命及与丈夫。那罗延。是为菩萨四所住处。最胜住处庄严无尽。大福德聚庄严无尽。大智慧聚断一切见。成就具足起诸佛法。那罗延问文殊师利。菩萨云何得是住处得名出家。文殊师利言。那罗延。菩萨有四法得是住处。谓住慈住悲住喜住舍。那罗延。是为菩萨住四住处。那罗延。菩萨若住村邑聚落。若住空处。若住是四梵行住处。名正住处。若离是四梵行住处。虽正殿堂楼阁中住。不名住处。那罗延。是人名为欺诳一切人天阿修罗虚食供养。那罗延。菩萨若住余诸梵行。皆摄在此四梵行中。何以故。那罗延是梵行住处甚难得故。若有不见是四梵行缘圣禅者。是世身见不断于慢。那罗延言。文殊师利。云何菩萨得名住此慈悲喜舍。文殊师利言。那罗延。若有菩萨作如是念。我要当度一切众生。是名住慈。我要当脱一切众生。是名住悲。我要当令一切众生得住佛法。是名住喜。我要当以出世间法寂静一切诸众生等。是名住舍。复次那罗延。菩萨若解诸法界空。是名住慈。菩萨若解诸法界寂。是名住悲。菩萨若解一切法界无著无缚无解。是名住喜。菩萨若解一切法界无去无来。是名住舍。那罗延。是名菩萨住慈悲喜舍。复次那罗延。菩萨若见无我之法而不惊畏。是名住慈。若见一切众生寂灭而不惊畏。是名住悲。若闻一切佛法同等如一佛法而不惊畏。是名住喜。若闻一切刹无尽而不惊畏。是名住舍。复次那罗延。无所碍滞是名为慈。救众生苦是名为悲。悉无所恼是名为喜。不高不下是名为舍。复次那罗延。有慈悲非大慈大悲大慈大悲。声闻缘觉之所无有。声闻缘觉所有慈悲。不能安乐一切众生。是名慈悲非大慈悲。云何名为大慈大悲。若于一切众生等。起平等心脱其苦恼。是名菩萨大慈大悲。若生五道为诸众生。自舍己乐作如是念。是诸众生堕在邪道我当安止令住正道。是名菩萨大慈大悲。那罗延。是故当知声闻缘觉有慈有悲。无大慈大悲。那罗延。是故菩萨应当修满大慈大悲。说是大慈大悲法时。八千众生发阿耨多罗三藐三菩提心。作如是言。我等亦当住如文殊师利所说大慈大悲。八千菩萨得集一切福德三昧。八千众生远离尘垢得法眼净。尔时那罗延菩萨白言。世尊。如来世尊名百福相。以何因缘得如是相。佛告那罗延。若于十方各如恒河沙等世界。所有众生皆成转轮大王。所有功德福聚。等一帝释所有福德。十方恒河沙等世界。所有众生成就福聚皆如帝释。是诸帝释所有福聚。等一梵王所有福聚。那罗延。若恒河沙等世界所有一切众生。成就福聚皆如梵王。是诸梵王所有福聚。等一声闻所有福聚。那罗延。若恒河沙等世界所有一切众生。皆成声闻所有德聚等一缘觉所有福德。那罗延。恒河沙等世界所有一切众生。皆悉成就缘觉德聚。那罗延。是诸一切声闻缘觉所有德聚尽合为一。菩萨成就是集一切福德三昧。有如是福所有德聚。复过于是。那罗延。是菩萨所成福德善根无量无边。那罗延。若使十方如恒河沙等世界所有一切众生。皆悉逮得是集一切福德三昧福德之聚。是诸德聚复百千倍。犹不等佛一相福。是名如来百福德相。一切众生无能思量。是故如来名不思议百福德相。说是百福德相法时。而此三千大千世界六种震动。大光普照。百千。伎乐不鼓自鸣。天雨妙花。一切世间诸天世人阿修罗等。叹未曾有大声唱善。五体投地礼世尊足作如是言。若有众生发于无上正真道心快得善利。当得如是百福德相庄严之身。胜诸一切释梵护世声闻缘觉所有德聚。其有众生得闻此集一切福德三昧宝者。得大利益。既得闻已当如说行。世尊。所在国土有是经处。当知是中善男子善女人。佛力所持能流通此经。世尊。若使满于世界大火。当从中过往听是经。佛言。如是如是。善男子。如汝所言。若有善男子善女人不闻是经。当知是人为魔所持。善男子。若菩萨闻此三昧经不能受持。我不说彼名为得闻。若闻不持不读不诵不转。不于大众广分别说。不名多闻。尔时大众皆共同声白言。世尊。愿护是经名集一切福德三昧令广流布。尔时世尊放于白毫藏相光明。遍照无量无边世界。是光明中出如是音声。如来应供正遍觉已护是经。尔时佛告大德阿难。阿难。如来不久当般涅槃。却后三月入无余涅槃。阿难。我今以此三昧经典付嘱于汝。受持读诵广分别说阿难。若有众生持是经者。则于其人佛不涅槃法亦不灭。何以故。阿难。若有开示是经典者。当知是人则为见佛。若大众中分别演说显示文义。当知是人守护正法。尔时阿难悲泣流泪白言。世尊愿住一劫若住百劫若住千劫。多所安隐多所饶益利安人天。佛告阿难。汝勿悲泣。汝若受持是经读诵。令广流布使不漏失。随尔所时常为见佛。何以故。佛如来者。都不可以色身所见。不可以三十二相所见。不可以诸好而见。阿难。若有得见如是等经则为见佛。说是经已。文殊师利法王子。那罗延菩萨。净威力士。及大菩萨僧。大德阿难等。声闻大众。一切人天诸龙夜叉乾闼婆阿修罗世间人民。闻佛所说皆大欢喜

集一切福德经卷下


迦叶赴佛般涅槃经

    No. 393

迦叶赴佛般涅槃经

        东晋西域沙门竺昙无兰译

昔佛在世时。摩诃迦叶。于诸比丘中。最长年高才明智慧。其身亦有金色相好。佛每说法。常与其对坐。人民见之或呼为佛师。于是迦叶乃辞佛到伊筛梨山中。一山名普能。周旋数千里。去舍卫国二万六千里。多出七宝。甘果不訾。名香好药栴檀三种。其一种芳香。一种治人百病。一种可用染五色。众香杂药不可称数。亦有走翔鸟兽师子虎狼白象骐驎朱雀凤凰。或有清净异学道士。时有方石平正。其色如琉璃。纵广百二十里。奇树荫凉华叶五色。冬夏茂盛列生石上。迦叶前后教授二千弟子。皆清净高行得罗汉者。常坐此石上。诵经行道。又有清净甘香泉水。周旋四十里。其水中则有优昙华。绀色华红色华紫色华。迦叶弟子七人同夕得梦。其一比丘。梦见其所坐方石中央分破树皆根拔。复一比丘梦见四十里泉水皆干竭华悉零落。一比丘梦见拘罗边坐皆倾毁。一比丘梦见阎浮利地皆倾陷。一比丘梦见须弥山崩。一比丘梦见金轮王薨。一比丘梦见日月堕地天下失明。晨起各以所梦启迦叶。迦叶告言。我曹前见光明地时大动。卿等复得是梦。佛将般泥洹。即敕诸弟子往赴俱夷那竭国。道见一婆罗门。持文陀罗华。迦叶即问言。卿从何来。欲何所至。那得是天华。答言。我从俱夷那竭国来。时佛般泥洹已经七日诸天往赴。悉持天华天香供养佛身。此华即是。迦叶闻是语。便自投于地啼泣而言。佛今般泥洹。三界失明。将复何依恃。便帅将诸弟子进道。未到数百里。便见四天王及梵释诸天。皆持七宝盖名香好华。悉往供养佛。诸天作十二部音乐。亦有阿须轮王诸大鬼神侧塞空中。又见俱夷那竭国王。及诸邻国王。各从其群僚数百万人。见迦叶将诸弟子到。是时国贵末罗弗王。则敕国人民皆令避道。使迦叶及诸弟子得进。阿那律出迎相见言。佛般泥洹已七日。耶维火不然。但待贤者到耳。阿难见迦叶。便自投地啼哭不自胜。有一老比丘名波或。即止阿难言。止止。佛在时常禁制我等不得自由。佛今般泥洹。吾等得自在。莫复啼哭。时有天闻波或语。即举手搏之。迦叶便前接持天止之。谓波或言。佛今般泥洹。一切失所恃。汝独愚痴而反喜快。波或闻是语意解即得阿罗汉道。迦叶便与诸弟子头面着地。作礼绕棺三匝悲哀而言。我等今日不知佛头足所在。 佛威神则为出足。诸天人民莫不感伤。于是摩诃迦叶乃说偈赞佛言

  佛为三界乘　　度于生死渊
  澹泊升泥洹　　微妙越世间
  佛为无量明　　照于愚痴冥
  愿为一切人　　显耀现威灵
  佛为大慈哀　　所度无央数
  尊体处金棺　　清净寂然安
  愿用优和德　　见身色相光
  普令天及人　　兴起无量福
  佛为开现法　　众生受润泽
  得止生死轮　　或者入正谛
  已蒙如来恩　　头面礼佛足
  今但睹金棺　　心为悲感伤
  佛虽就无为　　圣达靡不实
  见后有疑谛　　出足于金棺
  起分是生死　　佛以不复愁
  法身慧常存　　莫呼永泥洹

迦叶赴佛般涅槃经


莲华面经

    No. 386

莲华面经卷上( 大乘修多罗藏 )

        隋 天竺 三藏那连提耶舍译

如是我闻。一时佛住毗舍离猕猴池岸上大重阁中。如来不久当舍寿命。尔时佛告阿难。我今共汝往波波城。彼有长者名毗沙门德。吾欲化之。阿难言。唯然受如来教。即随佛行。未入彼城有跋提河。佛告阿难。我今疲极可入河浴。尔时世尊脱郁多罗僧。置河岸上入河澡洗。佛告阿难。汝可至心观如来身三十二相。以自庄严如是之身。却后三月当入涅槃。复告阿难。汝当更观如来之身。如优昙花久远乃现。时时一出难出难见。如是佛身过于彼花百千万倍。难出难见。如是之身却后三月更不复现。复告阿难。汝当更观如来之身。如花鬘师取贯花线。种种色花及种种香。结作花鬘。彼鬘成已睹者欢喜。如来身者三十二相八十种好以自庄严。阎浮提金光色明炎圆光一寻。如是身者却后三月当般涅槃。复告阿难。汝当更观如来之身。如三十三天所住之地百宝庄严。复有种种音乐快乐。彼诸天等。于彼宝地及天音乐不能暂舍。亦不能记彼地宝色。如是佛身三十二相不可遍观。何以故。观一一相心不能舍。如是身者却后三月当般涅槃。复告阿难。汝当更观如来之身。譬如日月有大威德神通光明。在佛身边悉蔽不现。是故佛身过彼日月最尊最胜。如是之身却后三月当般涅槃。复告阿难。譬如师子诸兽中王。如天帝释大伊罗钵象诸象中王。佛身亦尔。具大势力独步无畏。如是之身却后三月当般涅槃。复告阿难。汝当更观如来之身。如须弥山王四宝所成。处于大海安住不动。其体坚实无有瑕隙。如来之身过那罗延力。百千万倍不可为比。如是之身却后三月当般涅槃。复告阿难。如来之身于无足二足多足众生。有色无色有想无想。非有想非无想众生之中。如来色身最尊最胜。如是之身却后三月当般涅槃。复告阿难。如小千世界。千日千月千须弥山。千弗于逮千瞿耶尼千郁怛罗越千阎浮提。千四天王千三十三天千帝释天王。千炎摩天千炎摩天王。千兜率陀天千兜率陀天王。千化乐天千化乐天王。千他化自在天千他化自在天王。千梵身天千 大梵 天王。如是小千世界满中诸天。欲见如来面貌周尽不能得见。何以故。如来面光如百千电炎。出过世间所有光明。百千万倍。是故帝释大梵天等。常赞叹佛光明殊胜。如是之身却后三月当般涅槃。复告阿难。莫作是念。如来不尽贪嗔痴故自赞己身。如来身者。贪嗔痴使及彼习气永尽无余。如是阿难。如来应供正遍知有大威德。汝常供侍如来生身。以是因缘所得功德。不可量不可数不可思议。无量无边阿僧祇。阿难。汝今欲闻如来灭后未来众生供养如来碎身舍利因缘事不。尔时阿难。偏袒右肩右膝着地。合掌白佛言。世尊。今正是时。大德婆伽婆。今正是时。唯愿如来。为我宣说佛涅槃后诸众生等供养如来碎身舍利因缘等事。我闻是法。至心受持广为他说。佛告阿难。汝善谛听。我今当说。阿难。如来入涅槃时入金刚三昧。碎此肉身犹如芥子。如是一分舍利向诸天所。尔时帝释天王及诸天众。见佛舍利知佛涅槃。即雨天曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。供养舍利。如见佛身礼拜右绕。有种阿耨多罗三藐三菩提善根。有种声闻善根。有种辟支佛善根。有一分舍利向龙世界中。尔时娑伽罗龙王无量龙等。见佛舍利大设供养。以因陀罗宝摩诃因陀罗宝。火珠宝清水宝。如是无量种种诸宝。持用供养碎身舍利。礼拜右绕作供养已。是时龙等各自发愿。有发阿耨多罗三藐三菩提愿者。有发声闻菩提愿者。有发辟支佛菩提愿者。有一分舍利向夜叉世界。尔时毗沙门王及余无量大夜叉将。见碎身舍利。以种种花末香烧香灯明音乐。如是无量供养舍利。礼拜合掌右绕恭敬。有发无上大菩提愿者。有发声闻愿。有发辟支佛愿。彼余舍利在阎浮提。当来有王名阿输迦。统一阎浮提。此王为供养舍利故。造作八万四千塔。置此舍利而供养之。此阎浮提复有六万诸王。亦当供养碎身舍利。以诸花鬘种种香等灯明音乐。供养礼拜右绕恭敬。有种无上大菩提善根。有种声闻善根。有种辟支佛善根。有即舍家出家。于佛法中信心清净。剃除须发而披法服。精勤修道皆悉漏尽而般涅槃。如是阿难。如来应供正遍知有大威德。以彼法身依生身故。供养生身舍利因缘所得功德。无量无边阿僧祇。不可数不可说。尔时如来作如是念。我此三阿僧祇劫勤苦所成佛法。欲令久住于世间故。当往诸天诸阿修罗诸龙迦楼罗摩睺罗伽等所住之处。付嘱佛法。尔时如来即于阎浮提没。三十三天中出。尔时帝释天王见世尊已。即敷高座奉迎如来白佛言。世尊。愿受此座。尔时世尊即坐其座。帝释天王与百千万众。顶礼佛足住在一面。佛告帝释言。汝今当知吾亦不久当般涅槃。以此佛法嘱累于汝。汝当护持。如是至三。帝释天王悲泣雨面收泪而言。世尊涅槃一何疾哉。如来涅槃何其太速。世间法眼于兹永灭。如佛所教是我力分。即当护持恭敬供养。如来昔于兜率陀天降神母胎。我于尔时与忉利众常作守护。及佛生时亦与诸天共来守护。如来坐于菩提树下破八千万亿魔军。得阿耨多罗三藐三菩提时。我与诸天亦常守护。佛于波罗奈鹿野苑中。三转十二行法轮时。我与天众亦常守护。我今无力能使如来不入涅槃。无力能护。尔时世尊种种说法。劝喻安慰示教利喜帝释诸天。令护佛法。从天上没即于娑伽罗龙王宫出。尔时龙王见如来至。即时敷座。佛坐其座告龙王曰。汝今当知如来不久入于涅槃。我以佛法嘱累于汝。汝当守护无令断绝。龙王当知。此龙世界有诸恶龙。多生嗔恚不知罪福。为恶卒暴破坏我法。是故我今以此佛法嘱累于汝。尔时龙王悲泣雨面收泪而言。世尊。我诸龙等盲无慧眼。是故今者生畜生中。若佛灭后龙世界空。我等舍命。不知未来当生何处。诸佛如来是众生宝。云何今者欲般涅槃世间眼灭。尔时世尊示教利喜娑伽罗王令护佛法。在龙宫没于德叉迦龙王宫出。尔时龙王为佛敷座。佛坐其座。龙王复与百万亿龙。顶礼佛足却住一面。佛告龙王。汝等当知如来不久入无漏界而般涅槃。今以佛法嘱累于汝。至心守护。尔时龙王悲泣雨面。以手收泪而白佛言。如来灭度世间眼灭。诸佛如来是众生宝。若佛灭度我今不知当生何处。佛为龙王种种说法示教利喜。即从彼没于黑色龙王宫中出。尔时龙王为佛敷座。佛坐其座。黑色龙王与百万亿龙众。顶礼佛足却住一面。佛告龙王。汝等当知如来不久入般涅槃。我以佛法嘱。累于汝。汝当至心而守护之。尔时龙王悲泣雨面扪泪而言。如来灭度世间眼灭。诸佛如来是众生宝。若佛灭度我今不知当生何处。佛为说法示教利喜。即从彼没于夜叉世界出。尔时毗沙门王。为佛敷座。佛坐其座。毗沙门王与百万亿夜叉之众。顶礼佛足却坐一面。尔时毗留勒叉天王。与百万亿鸠槃荼众。顶礼佛足却坐一面。尔时毗留博叉天王。与百万亿诸龙之众。顶礼佛足却坐一面。尔时提头赖吒天王。与百万亿乾闼婆众。顶礼佛足却坐一面。尔时大夜叉将。般脂迦槃折逻旃荼娑多耆利兮摩跋多摩尼跋陀富那跋陀。如是一切诸夜叉将。顶礼佛足却坐一面。尔时佛告四天大王。及夜叉将。乾闼婆将。鸠槃荼将诸龙将言。汝等当知如来不久入般涅槃。我以佛法嘱累于汝。当好守护。第二第三亦如是说。汝等当知夜叉国中诸恶夜叉。鸠槃荼国恶鸠槃荼。乾闼婆国恶乾闼婆。诸龙国土有诸恶龙。如是众生多起嗔恚。不知罪福为恶卒暴。破我三阿僧祇劫勤苦所修无上佛法。是故我今嘱累汝等。时四天王及夜叉将乃至龙将。悲泣雨面扪泪而白佛言。世尊涅槃何其太速。如来灭度一何疾哉。为死摩竭之所吞噬。尔时世尊种种说法示教利喜。即从彼没阎浮提出。尔时世尊作如是念。我所作事今已作竟。诸恶众生今已调伏。可入安隐寂灭涅槃。佛告阿难。生死可厌吾今不久欲入涅槃。尔时阿难生大苦恼。悲泣雨面如箭入心。闷绝倒躄宛转于地。而作是言。世尊涅槃何其太速。如来灭度一何疾哉。世间眼灭。我复更当与谁持钵。更复持扇在谁边立。不复更闻甘露之法。谁复与我说甘露味。我今更复随谁后行。不复更见殊胜日月圆满之面。尊者舍利弗等大智慧人已入涅槃。而佛如来今复灭度。世间闇冥失智慧眼。智须弥王今欲崩散。佛树欲倒。法桥欲绝。法舡欲沈。法炬欲灭。正法日月将坠于地。解脱之门今欲闭塞。三恶道门今将欲开。三阿僧祇劫所集法聚将没不久。尔时佛告长老阿难。汝莫忧愁。莫复啼哭。莫大叫唤捶胸哽咽闷绝躄地。何以故。世间生者是有为法。会归无常。欲令此法不失不坏而常住者。无有是处。尔时世尊种种说法。安慰劝喻示教利喜。嘱法藏已默然而住。尔时世尊复作是念。阿难比丘为忧愁刺深入其心。我今当拔彼忧愁刺。告阿难言。汝今欲见未来事不。我见来世如观现在。当为汝说。尔时阿难偏袒右肩右膝着地。合掌向佛顶礼佛足而白佛言。大德世尊。当为我说。今正是时。我闻法已当奉受持广宣流布。佛告阿难。谛听至心。我今当说。阿难。未来之时有诸破戒比丘。身着袈裟游行城邑。往来聚落住亲里家。彼非比丘又非白衣。畜养妇妾产育男女。复有比丘住淫女家。复有比丘淫比丘尼。复有比丘贮畜金银。造作生业以自活命。复有比丘通致使驿以自活命。复有比丘专行医药以自活命。复有比丘围棋六博以自活命。复有比丘为他卜筮以自活命。复有比丘为他咒彼死尸令起。遣杀怨家以自活命。复有比丘为他诵咒驱遣鬼神。多取财物以自活命。复有比丘专行杀生以自活命。复有比丘住僧伽蓝。私自费用佛法僧物以自活命。复有比丘内实犯戒外示护持。受人信施。复有比丘虽不破戒。而怀悭惜衣服饮食。及以鄙吝众僧之物不与客僧。复有比丘虽不破戒。吝惜众僧房舍床座不与客僧。复有比丘虽不破戒。为诸檀越供养礼拜多得财利。其心不欲令余比丘受人信施。唯欲自受。复有比丘实非罗汉。而常诈称得罗汉果。欲令人知我是罗汉。复有比丘多受檀越四事供养。内无实德唯增贪心。但为活命不为修道。复有比丘兴利商贾以自养活。复有比丘专行偷盗以自养活。复有比丘畜养象马駊驴牛羊。乃至卖买以自养活。复有比丘贩卖奴婢以自养活。复有比丘屠杀牛羊以自养活。复有比丘受募入阵。征战讨伐多杀众人以求勋赏。复有比丘穿踰墙壁。盗他财物以自活命。复有比丘专行劫夺。攻破城邑及与聚落以自活命。复有比丘毁坏佛塔。取其宝物以自活命。如是无量地狱因缘。舍命之后皆堕地狱。阿难。譬如师子命绝身死。若空若地若水若陆。所有众生不敢食彼师子身肉。唯师子身自生诸虫。还自啖食师子之肉。阿难。我之佛法非余能坏。是我法中诸恶比丘犹如毒刺。破我三阿僧祇劫积行勤苦所集佛法。阿难。譬如有人入于大海。至宝渚中多取宝物置于船上。欲渡大海于中沉没。佛之正法如彼宝船。当来破戒诸恶比丘多乐造作种种恶业。灭我佛法沉没不现。阿难。如来涅槃不久之间正法当乱。正法乱已。复有种种诸恶比丘出现于世。不信如来得证无漏寂灭涅槃。况复信有世间余人。得阿罗汉入涅槃者。阿难。如来所有正法名味句义所谓修多罗祇夜。鞞迦曷罗。迦陀。忧陀那。尼陀那。阿波陀那。伊帝鼻利多伽。阇多迦。裴富略。阿浮陀达摩。优波提舍。十二部经为恶比丘之所毁灭。彼诸人等。乐作文章绮饰言辞。多有如是诸恶比丘。破我佛法。尔时阿难白佛言。世尊。当来之世。如是破戒诸恶比丘而出生耶。佛言。如是如是。阿难。未来之世当有如是诸恶比丘出现于世。虽披法服剃除须发破我佛法。尔时阿难作如是念。以佛力故。可令我见未来之世如是事不。尔时如来以神通力。即令阿难悉见未来诸恶比丘。以儿坐膝置妇其傍。复见种种诸非法事。尔时阿难见此事已。心大怖畏身毛皆竖。即白佛言。世尊。如来速入涅槃。今正是时。何用见此未来之世如是恶事。佛告阿难。汝意云何。如来向说诸恶比丘恶业报果。岂是余人所能知不。阿难白佛言。世尊。唯有如来。乃能知此未来之世诸恶业报。佛言。善哉善哉。阿难。实如汝说。唯有如来乃能知之。阿难。汝今颇见佛未涅槃诸恶比丘围绕如来为说法不。阿难白言。无如是事。佛言。阿难。善哉善哉。如汝所说。如来现在实无如是诸恶比丘围绕如来佛为说法。佛言。阿难。未来之世。多有在家白衣得生天上。多有出家之人堕于地狱饿鬼畜生。复告阿难。善恶之业终不败亡。我于过去曾作商主。入于大海活多人故手杀一人。以是业缘乃至成佛。犹尚身受金锵之报。尔时帝释天王与三十三天众。疾至佛所。顶礼佛足却住一面。炎摩天王与百万亿炎摩天众。疾至佛所。顶礼佛足却坐一面。删兜率陀天王与百万亿删兜率陀天众。疾至佛所顶礼佛足却坐一面。化乐天王与百万亿化乐天众。疾至佛所。顶礼佛足却坐一面。他化自在天王与百万亿他化自在天众。疾至佛所。顶礼佛足却坐一面。尔时毗摩质多罗阿修罗王与百万亿阿修罗众。疾至佛所。顶礼佛足却坐一面。尔时娑伽罗龙王与百万亿龙众。疾至佛所顶礼佛足却坐一面。皆于一念一刹那一无虚律多顷。诸天阿修罗迦楼罗乾闼婆紧陀罗摩睺罗伽等。于虚空中遍满十二由旬。皆为最后见如来故

尔时佛告阿难。此道场菩提树最胜殊妙。过去诸佛皆于此处。证阿耨多罗三藐三菩提。未来诸佛亦于此处。得阿耨多罗三藐三菩提。现在我身又于此处。破十八亿魔军得阿耨多罗三藐三菩提。如是阿难。我今不久当般涅槃。复次阿难。蓝比尼园最胜最妙。是佛如来最后生处。复次阿难。摩耶夫人是大福德。乃能生出人中之宝。复次阿难净饭国王是大福德。乃作一切诸众生中最胜宝父。复次阿难。毗舍离城比嗜离国最胜最妙。王舍大城摩伽陀国最胜最妙。七庵婆罗树处亦妙。瞿耽摩若尼俱陀树处亦胜亦妙。裴啰多豆啰多豆啰尼憩处亦胜亦妙。力士生地。乃是过去转轮圣王解宝天冠。在此安置辟支佛塔。是我焚身最胜妙地。复次阿难。此阎浮提最胜好处。众生于中乐贪寿命。是故我今于此涅槃。我于三阿僧祇劫所集之法不久当灭。尔时世尊慰喻阿难。令心欢喜除其愁刺。付嘱法已。告阿难言。吾今与汝可往诸国。阿难唯然受如来教。尔时世尊至波波城。所应度者皆悉度讫。复往诸国教化无量百亿那由他众生。皆成就已。尔时阿难随从佛行。如是次第至摩伽陀国道场菩提之树。世尊绕树作六匝已。即于树下结加趺坐。佛告阿难。如来不久后十五日当般涅槃。尔时诸天阿修罗迦楼罗乾闼婆紧那罗摩睺罗伽等。作如是念。如来不久于十五日当般涅槃。我等皆当最后礼拜。佛告阿难。莫作是念。谓佛世尊有贪嗔痴赞叹于此阎浮提处。而如来者离贪嗔痴。此三界处是众生生处。于三界中而此欲界。是诸众生习三恶业。又造人身及与天业。色界无色界业。乃至非想非非想业。说此语已。佛起于座。即时此地六种震动。无量百千万亿那由他诸天。于虚空中忧愁啼哭作如是言。如是众生中。宝不久当灭

莲华面经卷上莲华面经卷下

        随 天竺 三藏那连提耶舍译

尔时世尊离菩提树。毗沙门王共百万亿夜叉之众。同时举声悲啼雨泪以手抆泪。而说偈言

  如来容色甚微妙　　超胜众生无比者
  如是庄严殊特身　　不久之间当灭度

尔时帝释天王。复与百千亿三十三天众。同时举声悲泣雨泪以手抆泪。而说偈言

  如来面相正圆满　　形色殊胜于日月
  一切人天应供者　　我等不复得瞻见

尔时须焰摩天王。与百万亿须焰摩天众。同时举声悲泣雨泪以手抆泪。而说偈言

  人中精进最雄猛　　威力能破诸魔军
  甘蔗种中释师子　　今为无常所食啖

尔时删兜率陀天。复与百万亿删兜率陀天众。同时举声悲泣雨泪以手抆泪。而说偈言

  见者无厌如药王　　出世犹如大明灯
  如是智眼今灭度　　世间当复皆闇冥

是时化乐天王。复与百万亿化乐天众。同时举声悲泣雨泪以手抆泪。而说偈言

  安步不动胜师子　　面貌圆满过月形
  更不履行于此地　　千辐相迹不复见

是时魔王他化自在天王。心大欢喜安隐快乐。复与百万亿他化自在天众。疾至佛所合掌向佛。而说偈言

  诸恶众生已调伏　　大粗犷尽永无余
  何故犹住于世间　　唯愿如来速涅槃

是时大梵天王。嗔彼魔王作如是言。咄哉魔王大恶众生。诸佛如来是最胜宝。汝今云何。欲令世尊速入涅槃。尔时大梵天王。复与百万亿诸梵天众。同时举声悲泣雨泪以手抆泪。而说偈言

  于此现在及未来　　梵天世界余天处
  初未曾见如佛身　　清净满足端严面

尔时毗摩质多阿修罗王。复与百万亿阿修罗众。同时举声悲泣雨泪以手抆泪。而说偈言

  佛色功德无有量　　无有能尽其边际
  利益修罗及余趣　　今若灭度世间空

是时娑伽罗龙王。与百万亿诸龙众等。同时举声悲泣雨泪以手抆泪。而说偈言

  伊罗钵象数满千　　不比如来一节力
  如是大力雄猛者　　今为无常所破坏

是时毗留勒叉天王。与百万亿鸠槃荼众。同时举声悲泣雨泪以手抆泪。而说偈言

  南无大觉妙莲花　　从彼清净戒池生
  示现无常不久相　　今当倾坠永寂灭

是时毗留博叉天王。与百万亿诸龙众等。同时举声悲泣雨泪以手抆泪。而说偈言

  如来面形如满月　　光明照曜犹日轮
  如是不久住于世　　示为无常所吞食

是时毗沙门天王。与百万亿夜叉众。同时举声悲泣雨泪以手抆泪。而说偈言

  佛身金色最殊妙　　三十二相自庄严
  不久当为无常力　　破坏清净大牟尼

尔时提头赖吒天王。与百万亿龙众。同时举声悲泣雨泪以手抆泪。而说偈言

  如来身色甚希有　　于三界中无有比
  如是不久当灭度　　为彼无常之所罥

尔时大夜叉将名般脂迦。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  佛声殊胜踰梵天　　出过迦陵频伽声
  如来不久当涅槃　　不复更闻甘露法

尔时夜叉大将名般遮罗。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  世尊金色光明身　　功德庄严满月面
  眉间白毫殊特相　　我今最后归命礼

尔时大夜叉将摩尼跋陀罗。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  三十有二上妙相　　八十种好自庄严
  当为无常金刚主　　摧碎大圣牟尼尊

尔时大夜叉将富那跋陀。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  过去世中一切佛　　及以未来诸世尊
  大力释种师子王　　无常师子之所害

是时大夜叉将摩俟利地迦。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  我今最后见牟尼　　于是不复更奉觐
  最后礼佛千辐轮　　丘墟悉平脚足者

是时大夜叉将佉陀罗迦。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  咄哉大恶无常相　　破坏一切诸众生
  如是众生无上宝　　亦入寂灭不久住

是时大夜叉将名金毗罗。与百万亿夜叉众等。同时举声悲泣雨泪以手抆泪。而说偈言

  我今归依礼佛树　　生于持戒大地中
  乃为无常之斧钺　　不久斫倒大牟尼

尔时大夜叉将娑多姞利。与百万亿夜叉众。悲泣雨泪以手抆泪。而说偈言

  眉间白毫相　　照曜如月轮
  目净如青莲　　希有不复见

尔时地神天。与百万亿夜叉众。悲泣雨泪以手抆泪。而说偈言

  我今礼雄猛　　人中最殊胜
  两足中最上　　南无大牟尼

尔时菩提树天。悲泣雨泪以手抆泪。而说偈言

  此处破魔王　　及破魔眷属
  大牟尼不久　　无常魔所灭

尔时祇林神。悲泣雨泪以手抆泪。而说偈言

  只神林当空　　竹林亦如是
  无常坑极深　　如来入不现

尔时金刚密迹。与百万亿夜叉众。悲泣雨泪以手抆泪。而说偈言

  如是最胜城　　亦是大丰地
  舍释迦种姓　　当向何方所

尔时蓝毗尼林神。悲泣雨泪以手抆泪。而说偈言

  净饭国王先已灭　　摩耶夫人亦灭度
  如来今欲入涅槃　　如是寂灭不可见

尔时迦毗罗城神。疾至佛所悲泣雨泪。宛转在地作如是言。如来涅槃何其太速。世尊涅槃一何疾哉。世间眼灭。而说偈言

  蓝毗尼园佛生处　　长大在于迦毗城
  其光出过于千日　　今最后见更不见

尔时菩提树神。与诸天阿修罗迦楼罗紧陀罗摩睺罗伽。于虚空中出大音声。悲啼号哭而作是言。佛是众生最胜之宝。不久当没。尔时世尊出乎梵音。而告诸天阿修罗迦楼罗乾闼婆摩睺罗伽众言。汝等莫啼。莫作异语。莫生忧恼以手椎胸令心迷闷。何有世间而受生者因缘和合有为之法而得久住。若欲强令无常之法不灭坏者。无有是处。尔时世尊示教利喜诸天阿修罗迦楼罗乾闼婆摩睺罗伽等。生欢喜已。是时诸天乃至摩睺罗伽等。右绕世尊还向本处

佛告阿难。我昔于彼阿波罗龙王处。记罽宾国。我涅槃后其国炽盛安隐丰乐如郁怛罗越。佛法炽盛多有罗汉而住彼国。亦有无量如来弟子。此阎浮提所有罗汉皆往彼国。犹如兜率天处。如来所有名身句身。谓修多罗　祇夜　鞞迦曷罗那　伽他　优陀那　尼陀那　阿波陀那　伊帝鼻利多剑伽阇多迦裴富略　阿浮陀达摩　优波提舍彼诸罗汉。结集如来十二部经广造诸论。彼罽宾国犹如帝释欢喜之园。亦如阿耨清凉之池。复有颇罗堕逝宾头楼等。皆乐住彼罽宾国土。不退佛乘阿罗汉等。亦住彼国。复有因陀罗摩那阿罗汉白项阿罗汉等。复于如来所说法藏。有漏无漏之法。皆悉撰集广行流布。阿难。我涅槃已最后法身。彼等建立于未来。复有金毗罗等五诸天子生罽宾国。广令我法流布于世。大设供养。我诸弟子于阎浮提。初未曾有如是大会。佛告阿难。于未来世罽宾国土。当作如是大法之会。阿难。彼五天子灭度之后。有富兰那外道弟子。名莲花面。聪明智慧善解天文二十八宿五星诸度。身如金色。此大痴人。已曾供养四阿罗汉。当供养时作如是誓。愿我未来破坏佛法。以其供养阿罗汉故。世世受于端正之身。于最后身生国王家。身为国王名寐吱曷罗俱逻。而灭我法。此大痴人破碎我钵。既破钵已生于阿鼻大地狱中。此大痴人命终之后。有七天子次第舍身生罽宾国。复更建立如来正法大设供养。阿难。以破钵故。我诸弟子渐污净戒。钵初破时。诸比丘等虽污清净戒。智如牛王能破外道。经第二时此阎浮提诸比丘等。破清净戒乐作不善。身行偷盗耕田垦植。多贪贮畜好衣好钵。不乐读诵修多罗毗尼阿毗昙。如是阿难。乐读乐诵智慧之人悉皆灭度。是时多有诸比丘等。谄曲嫉妒多起非法。以诸比丘不如法故。诸国王等不依王法。以王不如王法治故。其国人民多行增上十不善业。以恶业故。此地多生荆棘毒草土沙砾石。阿难。当于尔时此阎浮提。五种精味失力失味。所谓酥油盐石蜜蜜。如是五种失力味故。尔时众生复更多行增上恶业。以其多行恶不善故。佛破碎钵当至北方。尔时北方诸众生等。见佛破钵大设供养。以种种花烧香涂香灯明华鬘种种音乐。供养此钵。有发阿耨多罗三藐三菩提心者。有发声闻心者。有发辟支佛心者。彼破碎钵当向波罗钵多国。彼国人民见佛碎钵。以种种花烧香末香涂香灯明花鬘种种音乐。供养此钵。有发阿耨多罗三藐三菩提心者。有发声闻心者。有发辟支佛心者。阿难。此佛碎钵以佛力故。亦是众生善根感故。我此碎钵自然还复如本不异。于后不久我钵即于阎浮提没。现于娑伽龙王宫中。当没之时。此阎浮提七日七夜皆大黑闇。日月威光悉不复现。地大震动。恶雷掣电于虚空中而出恶声。黑风卒起极大怖畏。天人阿修罗迦楼罗乾闼婆摩睺罗伽等。皆大号哭泪下如雨。如是阿难。此钵当尔初没之时。如来法律亦没不现。尔时魔王见法律灭。心大欢喜心大安隐。于虚空中作如是言。瞿昙法灭。我当教化诸众生等。自作诸恶亦教他作。以魔教故。城邑聚落迭相杀害。尔时魔王以教众生广作恶故。生身陷入阿鼻地狱。尔时娑伽罗龙王见佛钵已。以种种宝因陀尼罗宝摩诃尼罗宝火珠宝清水宝。如是大宝。大设供养。至于七日礼拜右绕。是诸龙等。有发无上菩提心者。有发声闻心者。有发辟支佛心者。尔时娑伽罗龙王以手捧钵。而说偈言

  诸相庄严手　　受种种味食
  盛置于此钵　　如是持用食

佛告阿难。如是我钵于娑伽罗龙王宫没。于四天王宫出。尔时四天王。毗留勒叉毗留博叉毗沙门提头赖吒。七日七夜大设供养。以种种花种种华鬘。种种涂香种种烧香。种种灯明种种音乐。供养礼拜已。时诸天众有发无上菩提心者。有发声闻心者。有发辟支佛心者。尔时毗留勒鸠槃荼王以手捧钵。而说偈言

  如来最后食　　在于铁师家
  钵为化众生　　而来于此处

佛告阿难。如是我钵过七日已。于四天宫没。三十三天宫出。尔时佛母摩耶夫人。见佛钵已忧愁苦恼。如箭入心难可堪忍。宛转于地犹如圆木。作如是言。如来涅槃一何疾哉。修伽陀灭何其太速。世间眼灭。佛树倾倒。佛须弥山崩。佛灯亦灭。法泉枯竭。无常魔日萎佛莲花。尔时佛母摩耶夫人。以手捧钵告于一切诸天。阿修罗迦楼罗乾闼婆紧那罗摩睺罗伽等言。诸天谛听。此是释迦如来常受用钵。第一勇猛面貌圆满过日月者。影现此钵。复次诸天。如是之钵复于王舍大城之中。受于尸利堀多毒食。诸天谛听。释迦牟尼大雄猛者。满腹城内修摩伽陀家用此钵食。诸天谛听。如来为化优楼频螺迦叶及大毒龙。以彼恶龙内此钵中。诸天谛听。以业缘故。于裴连多国。四月之中。复以此钵受马麦食。天众谛听。释迦如来以大悲故。复以此钵受于最下极贫者食。诸天谛听。释迦如来复以此钵。于娑伽罗龙王宫内受种种食。诸天谛听。释迦如来于夏四月。复以此钵受我等食。诸天谛听。释迦如来复以此钵。覆于诃利鬼母最小之子。名必利盐迦罗夜叉。以其恶心常食人血故调伏之。于时佛母摩耶夫人以手捧钵。而说偈言

  随佛心欲受　　皆入于钵中
  佛于我腹内　　满足于十月

尔时帝释天王。七日七夜以种种天花天香天栴檀香。大设供养礼拜右绕。作是供已。时诸天众有发无上菩提心者。有发声闻心者。有发辟支佛心者。尔时天王以手捧钵。而说偈言

  今此殊胜钵　　能长众生智
  佛身亦如是　　成就诸功德

佛告阿难。如是我钵过七日已。于三十三天中没。焰摩天中出。尔时焰摩天主见佛钵已。七日七夜种种供养。以天曼陀花天栴檀香种种花种种音乐。供养佛钵礼拜右绕。是时诸天有发无上菩提心者。有发声闻心者。有发辟支佛心者。尔时焰摩天主以手捧钵。而说偈言

  千万亿众生　　见钵皆欢喜
  能生胜妙果　　牟尼使来此

佛告阿难。如是我钵过七日已。于焰摩天没。兜率陀天出。尔时兜率陀天王见佛钵已。七日七夜以天曼陀华摩诃曼陀华。及余种种妙华种种香种种音乐。大设供养礼拜右绕。以手捧钵。而说偈言

  上中下众生　　佛起慈悲心
  此钵受食已　　佛使至于此

佛告阿难。如是我钵过七日已。于兜率天没。化乐天出。尔时化乐天王见佛钵已。七日七夜以种种天花种种天香种种天音乐。大设供养礼拜右绕。是时天众。有发无上大菩提心者。有发声闻心者。有发辟支佛心者。尔时天王以手捧钵。而说偈言

  希有大道师　　悲愍于众生
  为利众生故　　使钵来于此

佛告阿难。时诸天阿修罗迦楼罗乾闼婆紧陀罗摩睺罗伽。以天曼陀花摩诃曼陀花。及余种种华种种香天栴檀香末香。供养钵已。即以此钵送至娑伽罗龙王宫中。佛言阿难。此阎浮提及余十方。所有佛钵及佛舍利。皆在娑伽罗龙王宫中。佛告阿难。如是我钵在我舍利。于未来世于此地没。直过八万由旬住金刚际。阿难。我今语汝。未来之世诸众生等。寿命八万四千岁时。弥勒如来应供正遍知。三十二相八十种好。身紫金色圆光一寻。其声犹如大梵天鼓迦陵伽音。尔时我钵及我舍利。从金刚际出。至阎浮提弥勒佛所。钵及舍利住虚空中放五色光。所谓青黄赤白颇梨杂色。如是阿难。彼五色光复至其余一切天处。到彼天已。于其光中。出声说偈

  一切行无常　　一切法无我
  及寂灭涅槃　　此三是法印

其光复至一切地狱。而说偈言

  一切行无常　　一切法无我
  及寂灭涅槃　　此三是法印

佛告阿难。佛钵舍利所放光明。复更至于十方世界。于其光中。而说偈言

  一切行无常　　一切法无我
  及寂灭涅槃　　此三是法印

佛告阿难。如是我钵及我舍利所放光明。十方世界作佛事已。还至本处在于舍利佛钵之上。于虚空中成大光明云盖而住。阿难。舍利及钵现大希有如是等事。现此神通希有事时。八十百亿众生得阿罗汉果。千亿众生剃发出家信心清净。一万众生发阿耨多罗三藐三菩提心皆不退转。阿难。此钵舍利广行教化诸众生已。于弥勒前虚空中住。尔时弥勒佛。以手捧钵及佛舍利。告诸天人阿修罗迦楼罗乾闼婆紧那罗摩睺罗伽言。汝等当知。此钵舍利。乃是释迦牟尼如来雄猛大士信戒多闻精进定智之所熏修。汝等当知释迦牟尼雄猛大士。能令无量百千那由他亿诸众生等住涅槃城。出过优昙钵花百千亿倍。钵及舍利故来至此。尔时弥勒三藐三佛陀。为我此钵及我舍利起四宝塔。以舍利钵置此塔中。尔时弥勒佛及诸天人。阿修罗迦楼罗乾闼婆紧那罗摩睺罗伽等。大设供养恭敬礼拜钵舍利塔等

佛告阿难。如来应供正遍知。舍利及钵有大威德。阿难。汝以给侍如来生身。所生功德。无量无边不可思议阿僧祇尔时佛为阿难说未来事已。复告阿难。吾当与汝往诸国土。如来不久却后七日当入涅槃。阿难白佛言。唯然受教。尔时佛与阿难。次第至诸国土城邑。度脱无量百千万亿那由他诸众生已。往铁师子纯陀之家。此是如来最后食处。尔时世尊受其食已。而说偈言

  我今最后食　　在于纯陀家
  如是五众身　　不久当灭度

尔时佛与阿难。至拘尸那城。种种方便教化拘尸那力士已。从拘尸那城出。至优波跋多那娑罗双树间。尔时世尊北首而卧。时须跋陀罗来至佛所。顶礼如来向佛而坐。佛为说法得阿罗汉果

莲华面经卷下


摩诃摩耶经

    No. 383

摩诃摩耶经卷上(一名佛升忉利天为母说法)

        箫齐沙门释昙景译

如是我闻。一时佛在忉利天欢喜园中波利质多罗树下三月安居。与大比丘众一千二百五十人俱。又与无量百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。并余无数比丘比丘尼优婆塞优婆夷前后围绕。尔时如来结加趺坐。身毛孔中放千光明。普照三千大千世界。一一光中有千莲花。其一莲花有千化佛结加趺坐。如释迦牟尼。当于尔时日月星辰。所有威光隐蔽不现。皆悉来入如来光中。令波利质多罗树如真金色。譬如虚空净无云翳。日月威光极为明显。如来在于忉利天上所放光明亦复如是。倍更照耀不可譬类。是时日月星辰诸天子等。见此相已。其心战怖不能自安。不知何缘而有斯事。尔时佛告文殊师利童子。汝诣母所道我在此。愿母暂屈礼敬三宝。并以此偈向母说之。尔时世尊而说偈言

  释迦大仙师　　成就一切智
  在于阎浮提　　犹如千眼天
  殷勤情渴仰　　久欲觐慈颜
  本昔王宫中　　生我七日已
  神升受天福　　姨母长乳养
  致得成正觉　　应供度众生
  今故至于此　　说法报往恩
  愿母与眷属　　屈来到此处
  敬礼佛法众　　并受真净法

尔时文殊师利童子。受佛教敕。即便往至摩诃摩耶所。具以佛言而往白之。并诵如来所说之偈。时摩诃摩耶闻斯语已。乳自流出。而作是言。若审决定是我所生悉达多者。当令乳汁直至口中。作是语已。两乳乳出犹白莲花。而便入于如来口中。时摩诃摩耶既见此已。踊跃遍身容色怡悦。如千叶莲花日照开荣。摩诃摩耶妙色亦尔。于时三千大千世界普皆震动。诸妙花果非时敷熟。即语文殊师利童子。我从与佛为母子来。欢喜安乐未曾如今。譬如有人极苦饥渴。忽值甘膳食之丰乐。今我欢悦亦复如是。无复诸余杂乱念想。说此语已。即与文殊师利童子俱趣佛所。尔时世尊。遥见母来内怀欣敬。举身动摇如须弥山王及四大海鼓动之相。于时如来既见母至。便以梵音而白母言。身所经处与苦乐俱。当修涅槃永离苦乐。尔时摩诃摩耶闻佛此语。合掌低头一心思惟。长跪佛前五体投地。专精正念诸缠消伏。即于佛前以偈赞曰

  汝从无数劫　　恒饮我乳汁
  故离生老死　　得成无上道
  宜应报恩养　　断我三毒本
  归命大丈夫　　无贪惠施者
  归命调御士　　最上无能过
  归命天人师　　永离痴爱缚
  日夜各三时　　念想不断绝
  稽首头面礼　　无上大法王
  今于汝福田　　欲长功德芽
  唯愿施慈悲　　速令成妙果
  久有此大志　　故生大王宫
  巨身紫金色　　光明照十方
  面貌悉圆净　　犹如秋满月

尔时世尊即白母言。谛听谛听。善思念之。初中后善其义深远。其语巧妙纯一无杂。具足清白梵行之相。摩诃摩耶闻此语已。佛神力故即识宿命。并以善根纯熟时故。破八十亿烟燃之结。得须陀洹果。即起合掌而白佛言。生死牢狱已证解脱。时会大众闻此语已。异口同音而作是言。愿一切众生皆得解脱。如今现在摩诃摩耶。时摩诃摩耶而白佛言。譬如猛火烧于热铁。若有触者身心焦痛。世间生死亦复如是。所往来处皆是苦聚。凡集苦本皆由心意。随欲轻躁戏弄众生。轮转五道疾于猛风。犹如 拍 鞠。时摩诃摩耶。即于佛前而自克责其心意言。汝常何故作非利益。游六尘境而不安定。乱想牵挽无时暂停。所可缘虑皆非吉祥。何故惑我而便集彼。譬如有人恒 垦 于地。而彼大地未曾损益。然其耕器日就消毁。在生死海亦复如是。恒弃身命不可称载。而我神识初不增减。汝能令我作转轮圣王。统四天下七宝具足。须臾令我退为虾蟆。须臾令我作贫贱人。东西驰走求乞衣食。须臾令我作大富长者。积财巨亿名称普闻。须臾令我在天宫殿。饮食甘露五欲自恣。须臾令我居止地狱。饮于融铜吞热铁丸。我但过去曾经牛身。积聚其皮高须弥山。犹于生死未得解脱。须臾复获无量名字。或曰大家。或曰仆使。或曰转轮圣王。或曰帝王。或曰天龙夜叉乾闼婆。阿修罗迦楼罗紧那罗摩睺罗伽人及非人。或曰畜生。或曰饿鬼。或曰地狱。众生有如是等种种名号。汝痴心意。虽复曾经具世五欲。金银诸珍妻子奴婢。象马车乘屋舍田宅人民聚落。寻皆散灭共就无常。暂为己有会归磨灭。犹若旅舍憩无定主。上至诸天五欲自在福尽临终。五相现时徘徊顾恋心怀愁苦。及在人中贫穷下贱为人所使。若居王位互相讨伐。君臣父子竞共残灭。下至地狱屠割烧煮。畜生之中更相吞害。皮肉筋力偿其宿债。为业所逼不得自在。饿鬼之中饥渴所逼东西驰走。唯见火聚及热铁轮长随其后。五道生死有如是等种种众苦。不可称计。汝痴心意。往昔已来长牵于我去来诸处。恒相顺从初未违异。我于今日欲专听法。勿复恼乱而为障碍。亦宜自应厌离诸苦。速求涅槃疾获安乐。时摩诃摩耶即于佛前。而说偈言

  唯愿霔法雨　　洽润于枯槁
  普生法萌芽　　开发渐滋长
  令我及众曾　　善根普纯熟
  或于诸道果　　次第随所获
  愿时施甘露　　消灭贪恚原
  我等长夜来　　缚着无明狱
  惛迷无智慧　　不知求道处
  愿示解脱路　　疾至常乐城

尔时摩诃摩耶。说此偈已复于佛前。重偈赞叹

  世尊处大众　　光显踰须弥
  我今头顶礼　　并及法与僧
  四众八部等　　渴仰诚殷勤
  一心谛观佛　　如天眼不瞬
  唯悕庄严师　　饰以妙法鬘

尔时摩诃摩耶。说偈赞已而白佛言。诚知如来诸弟子众。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。国王大臣长者居士婆罗门等。其数无量所说偈赞。歌颂如来微妙功德亦不可量。然我今者智慧微浅。犹欲于佛功德大海少分称赞。唯愿垂许。即于佛前。而说偈言

  智慧高广山　　峰岭极严峻
  溪谷深且旷　　清泉常流满
  疗疾诸药草　　滋茂生其侧
  若有服之者　　长乐无穷已
  譬如甘蔗种　　内性常自甜
  智者善压之　　便获甘美味
  世尊所演法　　从本自清净
  若人信乐受　　福报无穷尽
  一切诸众生　　愿乐无边际
  唯有牟尼尊　　能令皆满足
  众生烦恼患　　无始恒炽盛
  如来大医王　　应病投良药
  生死邪曲路　　艰崄难登履
  憍陈等五人　　游涉不知返
  如来大慈悲　　躬趣波罗奈
  为其转法轮　　悉得道果证
  八万诸天子　　于空获法眼
  自非大导师　　孰能回此等
  舍利弗目连　　迦叶迦旃延
  此四大声闻　　昔未出家时
  高才智通博　　憍慢轻世间
  举国皆宗敬　　名德莫能伦
  一见闻甘露　　降伏成罗汉
  渐次助大师　　随顺转法轮
  如尼俱类树　　种子甚毫微
  繁茂随时长　　柯条远垂布
  世尊所化度　　增进亦如是
  如央掘摩罗　　多杀诸众生
  世尊亦矜愍　　化令入佛道
  彼提婆达多　　造作五逆行
  使鬼举大石　　而欲害如来
  世尊平等视　　犹如罗睺罗
  又彼鬼子母　　恒啖于人儿
  以佛怜愍故　　藏其子不现
  慞惶竞求觅　　莫知所在处
  回来问世尊　　求示子所在
  如来以方便　　即事反诘之
  汝自念子故　　驰走急求觅
  云何无慈心　　恒啖他人儿
  恕己可为譬　　勿杀勿行杖
  若能改此心　　汝子今可见
  其闻是语已　　惭喜头面礼
  亦兼为子故　　合掌白佛言
  从今尽形寿　　舍离贪害心
  即前受五戒　　乃至得道果
  如彼鬼子母　　自爱其子故
  广及于他人　　究竟永断杀
  唯愿大悲尊　　今者亦如是
  以愍所生母　　普及余一切
  愿速开正法　　悉令众听受

尔时摩诃摩耶。说此偈已而白佛言。世尊。一切众生在于五道。皆由烦恼过患所致。故有结缚不得自在。愿我来世得成正觉。当断一切此患根本。唯是大师。慈念世间生老病死忧悲苦恼。无常之火恒烧众生。长夜炽然未曾休息。而呼弟子令归其所。显示生死根本之患而语之言。汝等何故。长眠三界火轮床上。无常杀鬼伺捕求便。诸病风刀欲断人命。譬如盗贼见珍宝藏。执持器杖而来攻伐。百千亿劫受余杂形。修行十善方得人身。虽得人身长寿亦难。无常恶贼复加逼迫。宜应防慎。犹自放逸愚痴之人。虚计日月年岁多少谓为定期。不觉念念变移潜逝。及至寿终随业所生。室家眷属悲哭相对。传互如此无有穷已。人在世间犹如电光。又于其中生起憍慢。或有称言。我是国王统领天下势力自在。或有称言。我是大臣助理国事抂直由己。或有称言。我富长者多饶财宝所欲随意。或有称言。我婆罗门族姓高贵聪明博达。先祖相承为刹利师。世尊。此等诸人在世之时。种种快乐恣意自在初无忧虑。一旦死至方怀悔恨何所复及。强壮之时亲戚相随。嬉戏纵逸不造微善。无常卒至各散五道。千万亿劫难复相值。生死无实如乾闼婆城。乃至辟支佛等。尽诸结漏具大神力自在无畏。身上出火身下出水。身上出水身下出火。飞腾空中行住坐卧。去来迅疾石壁无碍。形貌端正诸相具足。能为众生作大福田。犹亦未免无常之患。如以大水用灭小火。世间之人犯于王法。罪应及死闭在囹圄。犹可嘱救而令得脱。无常之法不可嘱及。贤圣之力尚不能免。岂况凡夫而无忧惧。五通仙人名曰逮波耶那。又有仙人名郁陀罗翅。又有仙人名毗失波蜜多罗。又有仙人名阿罗逻。又有仙人名波罗舍逻。又有仙人名应祁罗舍。又有仙人名阿私陀。又有仙人名曰波萨。有如是等诸大仙人。威力具足有大名称。能以咒术成毁国邑。斯等今者为在何许。以无常火曾烧众生。仍还自焚俱就消灭。大梵天王释提桓因。摩醯首罗六欲魔王。及毗纽天阎罗王等。罗婆奈神。罗婆泥神。比沙泥神。迦楼泥神。波楼泥神。斯等大力皆被无常之所执捉。顶生圣王。那罗延力士王。支夜多罗帝王。马鸣王。毗尼罗翅王。此等诸王统摄众国。颜容端正聪明超世。身力勇健莫能当者。无常所碎不知何在。娑伽罗龙王。修陀利舍那鬼王。毗摩质多罗阿修罗王。舍脂迷那天后。阿伽。蓝波天后。郁波尸天后。胝舍罗鸡尸天后。阿葛逻天后。阿留波底天后。藐底天后。藐底梨沙天后。此诸杂王具大威力。及众天后容貌绝世。若有见者即失正念。邪意散乱如非人持。设复良医种种疗治。不能回改令还正念。此等亦皆归就无常。譬如猎师围逐诸兽。无常之法亦复如是。驰逼众生至阎罗王所。而使业象随次蹈之。无常群虎恒伺众生。若得其便而共残食。如旃陀罗欲屠羊时。倒悬两足不得跳踉。无常旃陀罗亦复如是。执诸众生不得动转。无常之法如阿阇迦罗陀。若见人时两头缠绕。无常之法如风中幢。聚会之时而便倾倒。无常之法亦如黑月。渐就缺尽转近昏冥。时摩诃摩耶说此语已。复偈颂曰

  譬如旃陀罗　　驱牛就屠所
  步步近死地　　人命疾于是

时摩诃摩耶说此颂已。即于佛前语时会大众言。诸法兄弟及以姊妹。汝等宜应勤修戒行。今者幸值无上导师。又执法炬照于行者。并给衣粮无所乏少。若欲往至安乐城所。宜速咨问能示正路。若有值遇如是善导。而不归依不随顺者。当知此人极为刚强。必能造作五逆重罪。生死苦海甚可怖畏。一劫之中所经杂身。积集其皮如须弥山。及在胞胎眠卧污露。出入去来不可数计。并乳哺中屎尿涕唾。乃至老死诸苦难量。况复三涂楚毒之时。是故我今普语汝等。勤于长夜念求解脱。尔时摩诃摩耶。即从坐起顶礼佛足。长跪合掌而白佛言。世尊。一切众生所以沉沦在于生死而不能知出要之道。尔时世尊答摩诃摩耶言。众生所以不得解脱。皆由贪欲嗔恚愚痴。是故致令恒在生死。乃至欲求生天亦难。何况悕望离生死耶。在世亦复失好名称。朋友亲属皆共疏弃。如视草土无复爱念。临命终时极大怖惧。神识恍惚方自悔责。如此皆由三毒患故。若人欲求解脱妙果宜断苦本。彼愚痴凡夫为结所缚。犹如恶马被于[羇-革+馬]靽不得动摇。谓色集色灭色着不如实知。受想行识不如实知。不得解脱生老病死忧悲苦恼。若能于色而得解脱。如实究竟知者。则于受想行识亦如实究竟知。而得解脱生老病死忧悲苦恼。此则名为断于苦本。断苦本已则离妄想。离妄想已则无攀缘。不复贪着色声香味触法。离我计着及以我所。汝等从今可以此法互相开示长获利益。汝等今者听我所说。我于过去无数劫来。为诸众生广修苦行。得成阿耨多罗三藐三菩提。慈悲一切犹如赤子。所应化度其缘垂毕。三世诸佛法皆善逝。无复还出世间之期。我从此没踪迹难寻。不还作彼阎浮提主。亦复不作彼瞿耶尼主。亦不作彼弗婆提主。亦复不作彼郁单越主。亦复不作彼转轮圣王。亦复不作释提桓因。亦复不作大梵天王。如是三界悉已舍离。我久安立法王自在。不以刀兵杻械枷锁用伏人民。但以正法而施众生。普使一切皆得解脱。会必有离诸行力尔。须弥宝山劫尽消灭。四大海水亦有枯涸。如来出世为度众生。因缘事穷不得停住。无常弊恶犹如鼋鼍。若啮人时终不放舍。时会大众闻此语已。悲号懊恼俱共同声。而说偈言

  佛日出于世　　光显恒明耀
  今者欲潜隐　　入于无常山
  导师天中天　　无比最上士
  如何将为彼　　诸行贼所侵
  薄福诸众生　　长夜方昏冥

尔时世尊。于忉利天为诸八部及以四众。种种说法至三月尽。将欲还下于阎浮提。即便命彼王舍城中大臣之子。名鸠摩罗。聪明辩慧而语之言。汝今可下至阎浮提遍语诸国。普令闻知如来不久当入涅槃。并以此偈广宣示之。尔时世尊而说偈言

  举世今盲冥　　失于智慧眼
  三毒根转深　　无有医王故
  又将欲往彼　　涅槃幽远城
  今在忉利天　　说法化众生
  仁等宜速请　　还下阎浮提

时鸠摩罗。受佛敕已下阎浮提。周遍宣示一切诸国。并说如来所授之偈。于时众生闻鸠摩罗所说语已。极大愁恼。皆悉头顶而礼其足。作如是言。我等顷来失于慈荫。世间毒火转更增炽。咸皆不知大师所在。今者乃在忉利天上。又复不久欲入涅槃。何其苦哉。世眼将灭。我等罪身天人殊绝。无由升天恭敬劝请。唯愿仁者。普愍我故还归天上。启白佛言。阎浮提中一切众生。遥共顶礼世尊足下。久违圣化莫不仰恋。四方推求不知所在。始闻在彼忉利天上。广大饶益诸众生等。又闻不久当入涅槃。世间方当失于慧眼。唯愿愍念阎浮提人。时速还下为惠法药。时鸠摩罗闻此语已。即还升天往至佛所。具以阎浮提人所说之言。向佛广述。尔时世尊闻此语已。而便放于五色光明。青黄赤白颇梨红色。其光遍照阎浮提内。于时人民男女大小。见此光明皆悉惊喜叹未曾有。各相谓言。今者何忽有此异相。非是日月星宿之光。亦复不似五通仙人及婆罗门神力咒术所能为者。又有人言。如我今者察此光相。决定非是余力所作。必是大慈无上医王。愍世间故而放斯瑞。我等或能蒙获安济。时天帝释知佛当下。即使鬼神作三道宝阶。中央阶者用阎浮檀金。右面阶者用纯琉璃。左面阶者用纯马瑙。栏楯雕镂极为严丽

尔时世尊白摩诃摩耶言。生死之法会必有离。我今应下还阎浮提。不久亦当入于涅槃。时摩诃摩耶。闻此语已。即便垂泪。而说偈言

  世尊于旷劫　　慈愍一切故
  舍头目髓脑　　今得成正觉
  三界诸众生　　长迷痴爱海
  方应施法船　　云何而背舍

尔时世尊以偈答言

  诸佛出于世　　非是无缘故
  缘尽岂得住　　三世佛法然

尔时世尊说此偈已。为欲报于所生恩故。兼愍一切诸众生等。即于摩诃摩耶前。而说此咒

南无佛陀　南无达摩　南无僧伽　南无萨多那三藐三佛陀声闻僧伽　南无弥帝利婆罗目佉那　南无须陀洹　南无斯陀含南无阿那含　南无阿罗汉多　南无卢迦三藐迦陀那三藐波罗底拌那奈　低沙那摩己栗多和波罗婆叉寐摩诃摩由利鞞阇罗阇　婆摩鼻阇三鼻阇帝　牧楼兜迷移枳(久斯反)至波罗帝毗遮利遮罗遮罗提婆那伽夜叉阿修罗迦楼罗紧那罗摩睺罗 伽夜叉罗 刹毗奢遮悉犍陀　呕摩悉没罗迦牧楼拏兜迷浮陀伽那　移枳至婆罗　帝毗遮罗遮罗遮罗劫波阿诃罗楼提(徒利反)多阿诃罗曼(无干反)蹉阿诃逻迷多阿诃逻萨婆阿诃罗阿突遮阿诃逻耆(是梨反)毗多阿诃逻咄(都勿反)吒质多波婆质多屈(久勿反)比陀质多揵逻(吕耶反)健罗那质多　佛陀婆达摩婆僧伽婆婆逻先奈迦(俱安反)跱(竹利反) 迦 槃 跱 ( 竹利反 )鸠槃跱(竹利反)声弃尼　阎摩罗刹阎摩头谛　蓝婆波罗蓝婆迦罗波舍阿履帝阿利枳 试 阿利帝　阿利宾伽利蓝婆毗蓝婆迦罗波尸阿利帝

我今为母报所生恩及护一切而说此咒。若有善男子善女人至心乐欲受持读诵摩诃摩耶夫人所说及此咒者。先净洗浴着新洁衣。香埿涂地烧香末香。散众妙花缯盖幢幡。作唱伎乐种种供养。七日七夜持八戒斋。断于五辛诸不净味十种之肉。一皆不啖。叉手合掌归依三宝。并称摩诃摩耶名而读此咒。以咒力故。能除众生热病疟病颠狂干消鬼魅所著咒咀祷说。卧见恶梦数厌寱语水肿短气。及以小儿惊痫啼唤。魑魅魍魉四百四病皆能消除。又于世间得好名称。恒为一切之所 恃赖 持此咒者。亦应称唤东方天王提头赖吒。南方天王毗楼博叉。西方天王毗楼勒叉。北方天王毗沙门。东方天王第一辅臣。名摩尼跋陀罗。二名富那跋陀罗。三名金毗罗。统领一切诸鬼神等。南方天王第一辅臣。名槃遮罗立不帝厕摩诃耆罗阇那。各各将领五亿鬼神。护振旦界( 振旦者汉国也 )及阎浮提。一切诸鬼不得乱行。西方天王第一辅臣。跋檀那等兄弟六人。北方天王第一辅臣。迦毗罗夜叉。金发大神。母指大神。散脂修摩罗神。有如是等诸大鬼神统四天下。若有读诵摩诃摩耶所可演说及此神咒。是诸善神又闻唤名。皆来亲近拥护随侍。一切诸患皆悉除灭。尔时世尊说此咒已。而说偈言

  若有恶众生　　不随顺此咒
  犹如诸商人　　漂没罗刹国
  五百诸罗刹　　争取吞啖之
  若人善诵持　　如此神咒者
  譬如诸商人　　大海安隐还
  多获众珍宝　　七世无穷尽
  我于无量劫　　舍头目髓脑
  骨肉及手足　　国城及妻子
  累积菩萨行　　勤修波罗蜜
  广愍一切故　　非为自己身
  令得成正觉　　拔济苦众生
  说此陀罗尼　　拥护于世间

尔时世尊说此偈已。与母辞别下蹑宝阶。大梵天王执盖随从。释提桓因及四天王侍立左右。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人及非人。比丘比丘尼优婆塞优婆夷。并余种种诸杂鬼神。前后围绕充塞虚空。作诸妓乐歌呗赞叹。烧众名香散诸妙花。导从来下趣阎浮提。时阎浮提诸国王等。波斯匿王。优陀延王。频婆娑罗王。勿陀伽王。弗迦罗娑罗王。并余一切诸王。大臣长者居士婆罗门等。各严四兵。象兵马兵车兵步兵。青黄赤白杂色照耀。如忉利天出游观时。并余比丘比丘尼优婆塞优婆夷。集在宝阶而来迎佛。时舍卫国主波斯匿王。即敕诸臣。令于只桓更办种种饮食衣服卧具汤药。凡有所须皆使供办。尔时世尊到阎浮提已。诸王大臣长者居士及以四众。恭敬礼拜歌颂赞叹。随从世尊入于只桓。尔时一切诸人民等。既闻如来从忉利天还在只桓。皆悉驰竞盈塞道路。只桓精舍四门充溢。往来者众不可称计。尔时世尊坐师子座。四众八部前后围绕。时波斯匿王。既见世尊在师子座。欢喜踊跃不能自胜。即于佛前。而说偈言

  我等今归命　　无上功德聚
  巧拔诸苦本　　能殖众善根
  慈悲福众生　　最胜调御士
  相好端严容　　无比丈夫身
  导师良福田　　功德超梵释
  议论广降伏　　神力得自在
  我今头顶礼　　无譬天人师

时波斯匿王。说是偈已而白佛言。世尊。今者众生沈于生死。饮服毒药莫能疗者。唯愿大仙。降霔甘露。尔时世尊告诸大众。当知一切生死源本。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。若无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死灭。老死灭则忧悲苦恼灭。汝等宜应长勤修习。速得离于三界苦海。汝等又听。生死法中恒为八苦之所缠缚。皆由积集身口意业流转不绝。若能断于诸集根本。则灭众苦。行八正道无为正路。若能 审谛如 是 观者。则可出于诸有之际

摩诃摩耶经卷上摩诃摩耶经卷下( 一名佛升忉利天为母说法 )

        箫齐沙门释昙景译

尔时世尊。为波斯匿王及诸大众说妙法已。与比丘众前后围绕。从舍卫国渐次游行村邑聚落。所应度者皆悉周遍。乃至到于尼连禅河。于时世尊。既至河已着于浴衣入河洗浴。时无量百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。既见如来在河澡浴。各持种种涂香末香而来供养。时尼连禅河侧。水陆虚空一切众生。见如来身犹如明镜。睹妙形像皆生欢喜悉起慈心。三毒消伏不相吞食。咸发阿耨多罗三藐三菩提心。尔时阿难即白佛言。今此水陆虚空之中诸众生等。见佛身已尚生欢喜发菩提心。而提婆达多生在释宫。佛之亲属。又作沙门。口常读诵深妙经典。而于如来恒造逆事。破和合僧。出佛身血。教阿阇世杀害父王。日日招集丰美饮食。而自憍慢谓与佛等。为小利养以火自烧。设令诸佛欲救拔之不能为益。如骡怀妊会丧身命。尔时世尊告阿难言。如汝所说。提婆达多。恒于我所生怨害心。自造阿鼻地狱因缘。一切诸佛不能救脱。我于提婆达多极生慈愍。但其不久苦业所逼。时提婆达多。在佛左右闻此语已。心大嗔恚即舍于佛。与其弟子往摩竭提国投阿阇世。而于中路有诸群鸟。急声鸣唤翻飞乱扰。又逢恶牛欲触蹈之。其诸弟子见此相已。而语之言。我等今者观此诸瑞非为吉祥。若所去处必无利益。提婆达多而答之言。汝等愚痴何所知耶。但急随我不须多云。既到摩竭提国语守门者。汝入白王道我在此。时守门人即入白王。阿阇世王。闻提婆达多来在外已。心大嗔恚而作是言。乃至不欲闻其名字。何况而应眼见之耶。譬如雨雹摧折草木在地不久还自消散。如此恶人亦复如是。教人行恶坏他善根。复还自败善根种子。敕守门者勿听其前。时提婆达多。见阿阇世王不许前已。心大苦恼举手拍头切齿骂詈。时优波罗比丘尼从王宫出。而于门外见提婆达多。即呵之言。汝今释种不得炽盛。于佛法中作大留碍。时提婆达多。闻此语已极大忿恚。即以手卷而打其头。彼比丘尼寻便命终。提婆达多。又害罗汉比丘尼故。地即开裂有大猛火。缠绕其身牵入地狱。尔时世尊澡浴讫已。向诸比丘而说偈言

  譬如行恶道　　登涉长忧怖
  若到平坦处　　安隐无愁患
  生死险隘路　　众生恒恐怖
  唯有涅槃道　　行者获安隐
  我今欲至彼　　功德常乐处

尔时世尊说此偈已。与阿难俱至王舍城。为众比丘广说诸法。渐次到巴连弗邑。为诸人民长者居士及梵志等。广说诸法。渐次复到毗耶离城。为众离车及奈女等。广演诸法。尔时世尊。举身疾生处处皆痛。即便顾语尊者阿难。我于今者身体皆痛。唯欲舍此朽故之身。阿难当知。若比丘比丘尼得四神足。则能住寿一劫在世若灭一劫。况复如来所欲自在。是时阿难魔所蔽故。默然无答。乃至再三亦皆默然。尔时世尊语阿难言。汝今可往到一树下。专精思惟正观诸法。时魔波旬。即来佛所稽首礼足而白佛言。我于往昔。劝请世尊入于涅槃。于时世尊而答我言。我诸弟子比丘比丘尼优婆塞优婆夷未具足故。所以未应入于涅槃。世尊今者诸四部众皆悉具足所度已毕。唯愿善逝速入涅槃。尔时世尊即答魔言。善哉波旬。当知如来却后三月入于涅槃。时魔波旬见佛许已。欢喜踊跃不能自胜。顶礼佛足还归天宫

尔时如来既许天魔。却后三月当入涅槃。即便舍于无量之寿。以神通力故住命三月。于时大地六种震动。日无精光风雨违常。天龙八部莫不骇怖。来至佛所侧塞空中。时尊者阿难见此相已心惊毛竖。疾诣佛所而白佛言。今者何缘忽有此相。佛告阿难。恶魔波旬向来我所。劝请于我令入涅槃。我已许之即便舍寿。以神力故住命三月。阿难白佛言。世尊常说。四神足人则能住寿一劫若减一劫。随意自在。云何如来。不久住世同于诸行。于时如来答阿难言。我向为汝说如此语。魔蔽汝故不知请住。我已许之。云何住寿。阿难当知。一切诸行法皆如是不得常存。尔时阿难闻佛此语。迷闷懊恼不能自胜。悲号啼泣深追悔责。尔时世尊与阿难俱。渐次游行到诸国界村邑聚落广说诸法。所可化度不可称计。渐次复到鸠尸那竭国力士生地。熙连河侧娑罗双树间。而语阿难。可安绳床而令北首。我今身体极大苦痛。入于中夜当取涅槃。阿难受教。施绳床已。佛即就卧右胁着地。尔时阿难见佛卧已隐于佛后。悲泣流泪极大苦恼。世尊即便问诸比丘阿难今者为在何许。诸比丘言。近在于佛后垂泪忧恼。如来即以大悲梵音告阿难言。汝今不应犹如婴儿而自啼泣。所以者何。生死之中皆悉如此。但当专念思惟诸法。汝从往昔看侍我来。身口意业极为纯善。未曾见汝有毫过失。今者宜应勤求解脱。忍割悲心勿自煎恼。尔时阿难而白佛言。如来入于般涅槃后。阇维之法当云何耶。佛告阿难。阇维之法如转轮圣王。取于千端新净之[疊*毛]用缠佛身。香油洒灌内金棺中。又以金棺内银棺中。又以银棺内铜棺中。又以铜棺内铁棺中。积众香薪而用阇维。收拾舍利起立塔庙。表刹幡盖种种供养。尔时世尊告阿难言。汝今入城告诸力士。道我在此夜入涅槃。若欲来者宜自知时。阿难受敕即便入城。街巷道路高声唱言。三界大师如来应供今近在于双树之间。当于中夜而取涅槃。诸人若欲礼拜供养并欲咨决。宜知是时。时诸力士闻此语已。皆大懊恼问阿难言。世尊灭度一何驶哉。我等从今无所依怙。涕泪缘路往诣佛所。时熙连河侧娑罗双树。周匝纵广四百八十里。天龙八部充塞盈满间无空缺。莫不恋慕悲号苦恼。咸言世间失于慈父。各相谓言。我等从今方沦生死。谁拔济者。尔时城中有一梵志。名须跋陀罗。年百二十岁。闻佛近在双树之间。当于中夜而入涅槃。即往佛所白阿难言。我闻如来一切智者。当于中夜而入涅槃。欲少决疑。唯愿听前。是时阿难心自念言。今此梵志。久习异见。必于今者与佛论议。世尊身痛而作扰乱。即便默然不听许之。乃至三请亦复如是

尔时世尊天耳遥闻。语阿难言。汝可听是老梵志前。此即是吾最后弟子。须跋陀罗既见佛已。欢喜踊跃头面作礼。尔时世尊随应为说八正道法。即于座上得罗汉果。而白佛言。生死苦海已蒙得过。不忍当见大师涅槃。我今当先而取灭度。即于佛前入般涅槃。尔时世尊。为诸八部一切大众说妙法已。既至中夜涅槃时到。而说偈言

  我于诸众生　　应度缘今毕
  夜静气恬和　　涅槃时已到

尔时世尊说此偈已。即入初禅。入初禅已复入二禅。入二禅已次入三禅。入三禅已次入四禅。入四禅已次入空处。入空处已次入识处。入识处已次入无所有处。入无所有处已次入非想非非想处。入非想非非想处已次入灭尽正受。时会大众既见如来诸根不动。即便问于阿那律言。世尊今者入涅槃未。时阿那律语诸人言。世尊今入灭尽正受。尔时如来出灭尽正受。还入非想非非想处。出非想非非想处还入无所有处。出无所有处还入识处。出于识处还入空处。出于空处还入四禅。出于四禅还入三禅。出于三禅还入二禅。出于二禅还入初禅。即于初禅还入二禅。出于二禅而入三禅。出于三禅而入四禅。出于四禅而入空处。出于空处而入识处。出于识处入无所有处。出于无所有处入非。想非非想处。出非想非非想处入灭尽正受。则于彼处而般涅槃。当于尔时大地震动。天龙八部悲泣骚扰。时天帝释及梵天王。而说偈言

  生死无真实　　虚诳诸众生
  今者牟尼尊　　弃之犹涕唾

时诸众生共相谓言。如来灭度何其驶哉。三界牢狱谁为解脱。其中或有宛转于地。或有牵绝衣服璎珞。或拔头发捶胸大叫。尔时阿难即便入城普告力士如来昨夜已入涅槃。汝等宜应供养阇维。诸力士等闻此语已心大苦痛。皆悉相随至双树所。既见世尊已般涅槃。闷绝震恸不能自胜。即问阿难。我等不知云何阇维如来之身。阿难答言。我于昨日已咨问佛。世尊遗敕令如转轮圣王阇维之法。阿难具为次第说之。诸力士众闻此语已。即便严办供养之具。事事皆依阿难所说。如转轮圣王棺殡之法。尔时摩耶即于天上见五衰相。一者头上花萎。二者腋下汗出。三者顶中光灭。四者两目数瞬。五者不乐本座。又于其夜得五大恶梦。一梦须弥山崩四海水竭。二梦有诸罗刹。手执利刀竞挑一切众生之眼。时有黑风吹。诸罗刹皆悉奔驰归于雪山。三梦欲色界诸天忽失宝冠。自绝璎珞不安本座。身无光明犹如聚墨。四梦如意珠王在高幢上。恒雨珍宝周给一切。有四毒龙口中吐火。吹倒彼幢吸如意珠。猛疾恶风吹没深渊。五梦有五师子从空来下。啮摩诃摩耶乳入于左胁。身心疼痛如被刀剑。时摩诃摩耶见此梦已。即便惊寤而作是言。我于向者眠寝之中。忽然见此非吉祥事。令我身心极为愁苦。往昔在于白净王宫。因昼寝中得希有梦。见一天子身黄金色乘白象王。从诸天子作妙妓乐。观日之精入我右胁。身心安乐无有痛恼。即便怀妊悉达太子。光显宗族为世照明。今此五梦甚可怖畏。必是我子释迦如来入般涅槃之恶相也。即便向余诸天子等。广说梦中所见诸事。尔时尊者阿那律。既见棺殡如来身已。即便升于忉利天上。往摩诃摩耶所。而说是偈

  大师最胜天中天　　善导一切世间者
  今已为彼无常海　　摩竭大鱼之所吞
  在于鸠尸那竭国　　娑罗林中双树间
  不久当出城东门　　种种供养而阇维
  天人八部众盈溢　　号哭震动彻三千

时阿那律说此偈已。即便还下如来棺所。尔时摩诃摩耶。闻阿那律说此偈已。闷绝躄地。诸天女等。以冷水洒面。良久乃稣。自拔头发绝庄严具。悲泣垂泪而作此言。我于昨夜得五恶梦。决定当知佛入涅槃。今者果见阿那律来云已灭度在双树间。不久便应而就阇维。何其苦哉。世间眼灭。何其疾哉。人天福尽。昔日在于白净王宫。始生七日。我便命终。竟未抱育展母子情。付嘱摩诃波阇波提。令其姨母而乳养之。及已长大至年十九。便于中夜踰城而出。举宫内外莫不悲恼。既成道已开世慧眼。覆护一切犹如慈父。如何一旦便入涅槃。无常恶贼极为凶暴。而能害我正觉之子。即于众中。而说偈言

  于无量劫来　　常共为母子
  汝既成正觉　　此缘方永断
  而复于今者　　便入般涅槃
  譬如高大树　　众鸟依共栖
  晨旦各分离　　到暮还归集
  与汝为母子　　共在生死树
  既得成道果　　长绝此源本
  又复取灭度　　无有会见期

时摩诃摩耶说此偈已。涕泣懊恼不能自胜。与于无量诸天女等眷属围绕作妙妓乐。烧香散花歌颂赞叹。从空来下趣双树所。到娑罗林中已。遥见佛棺即大闷绝不能自胜。诸天女等以水洒面。然后方稣。前至棺所头顶作礼。垂泪悲恼而作此言。昔于过去无量劫来。长为母子未曾舍离。一旦于今无相见期。呜呼苦哉。众生福尽。方当昏迷。谁为开导。即以天曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。用散棺上。而说偈言

  今此双树间　　天龙八部众
  惟闻啼哭音　　不知何所说
  譬鹦鹉乱鸣　　 不 能解其语
  充塞在于地　　犹如 折 翮鸟
  不能起飞趣　　如来涅槃林
  旷劫积恩爱　　似遮迦罗鸟
  今者无常风　　吹散各异处
  在苦诸众生　　悕望法甘露
  犹 如 兰提鸟　　渴仰待天雨
  何故便于今　　而速入涅槃
  潜身重棺中　　知我来此不

尔时摩诃摩耶说此偈已。顾见如来僧伽梨衣。及钵多罗并以锡杖。右手执之左手拍头。举身投地如太山崩。悲号恸绝而作是言。我子昔日执着此等。广福世间利益天人。今此诸物空无有主。呜呼苦哉痛不可言。时诸八部及以四众。见摩诃摩耶忧恼如是。倍更悲感泪下如雨。帝释力故变成河流

尔时世尊以大神力故。令诸棺盖皆自开发。便从棺中合掌而起。如师子王初出窟时奋迅之势。身毛孔中放千光明。一一光明有千化佛。悉皆合掌向摩诃摩耶。以梵软音问讯母言。远屈来下此阎浮提。诸行法尔愿勿啼泣。即便为母而说偈言

  一切福田中　　佛福田为最
  一切诸女中　　玉女宝为最
  今我所生母　　超胜无伦比
  能生于三世　　佛法僧之宝
  故我从棺起　　合掌欢喜叹
  用报所生恩　　示我孝恋情
  诸佛虽灭度　　法僧宝常住
  愿母莫忧愁　　谛观无上行

尔时世尊说此偈已。摩诃摩耶小自安慰。颜色渐悦如莲花敷。于时阿难见佛起已。又闻说偈。垂泪鸣咽强自抑忍。即便合掌而白佛言。后世众生必当问我。世尊临欲般涅槃时。复何所说。云何答之。佛告阿难。汝当答言。世尊已入般涅槃后。摩诃摩耶从天来下至金棺所。尔时如来为后不孝诸众生故。从金棺出如师子王奋迅之势。身毛孔中放千光明。一一光明有千化佛。悉皆合掌向摩诃摩耶。并又说于如上诸偈。阿难又言。当何名此经。云何奉持。佛告阿难。我于昔日忉利天上为母说法。及摩诃摩耶夫人自有所说。今复在此母子相见。汝可为后世诸众生辈。次第演说此经。名曰摩诃摩耶经。亦名佛升忉利天为母说法经。又名佛临涅槃母子相见经。如是奉持。尔时世尊说此语已。与母辞别。而说偈言

  我生分已尽　　梵行久已立
  所作皆已办　　不受于后有
  愿母自安慰　　不须苦忧恼
  一切行无常　　住是生灭法
  生灭既灭已　　寂灭为最乐

尔时世尊说此语已。即便阖棺。三千大千世界普皆震动。摩诃摩耶及众八部。悲泣懊恼不能自胜。摩诃摩耶问阿难言。我子悉达。临灭度时有何教敕。阿难白言。世尊中夜。为诸比丘略说教诫。又以所说十二部经。付嘱尊者摩诃迦叶。亦复敕我令助宣布。时摩诃摩耶闻此语已。又增感绝。即问阿难。汝于往昔侍佛以来闻世尊说。如来正法几时当灭。阿难垂泪而便答言。我于往昔曾闻世尊说于当来法灭之后事云。佛涅槃后。摩诃迦叶共阿难结集法藏。事悉毕已。摩诃迦叶于狼迹山中入灭尽定。我亦当得果证。次第随后入般涅槃。当以正法付优婆掬多。善说法要如富楼那广说度人。又复劝化阿输迦王。令于佛法得坚固正信。以佛舍利广起八万四千诸塔。二百岁已。尸罗难陀比丘。善说法要。于阎浮提度十二亿人。三百岁已。青莲花眼比丘。善说法要度半亿人。四百岁已牛口比丘。善说法要度一万人。五百岁已宝天比丘。善说法要度二万人。八部众生发阿耨多罗三藐三菩提心。正法于此便就灭尽。六百岁已。九十六种诸外道等。邪见竞兴破灭佛法。有一比丘名曰马鸣。善说法要降伏一切诸外道辈。七百岁已。有一比丘名曰龙树。善说法要灭邪见幢然正法炬。八百岁后。诸比丘等乐好衣服纵逸嬉戏。百千人中或有一两得道果者。九百岁已。奴为比丘。婢为比丘尼。一千岁已。诸比丘等闻不净观阿那波那嗔恚不欲。无量比丘。若一若两思惟正受。千一百岁已。诸比丘等。如世俗人嫁娶行媒。于大众中毁谤毗尼。千二百岁已。是诸比丘及比丘尼。作非梵行。若有子息。男为比丘。女为比丘尼。千三百岁已。袈裟变白不受染色。千四百岁已。时诸四众犹如猎师。好乐杀生卖三宝物。千五百岁。俱睒弥国有三藏比丘。善说法要徒众五百。又一罗汉比丘。善持戒行徒众五百。于十五日布萨之时。罗汉比丘。升于高座说清净法云。此所应作此不应作。彼三藏比丘弟子答罗汉言。汝今身口自不清净。云何而反说是粗言。罗汉答言。我久清净身口意业无诸过恶。三藏弟子闻此语已倍更恚忿。即于座上杀彼罗汉。时罗汉弟子而作是言。我师所说合于法理。云何汝等害我和上。即以利刀杀彼三藏。天龙八部莫不忧恼。恶魔波旬及外道众踊跃欢喜。竞破塔寺杀害比丘。一切经藏皆悉流移至鸠尸那竭国。阿耨达龙王悉持入海。于是佛法而灭尽也。时摩诃摩耶闻此语已。号哭懊恼。即向阿难。而说偈言

  一切皆归灭　　无有常安者
  须弥及海水　　劫尽亦消竭
  世间诸豪强　　会必还衰朽
  我子于往昔　　勤苦集众行
  故得成正觉　　为众说经藏
  如何于尔时　　皆悉潜没尽
  呜呼生死法　　可畏可厌离

尔时摩诃摩耶说此偈已。语阿难言。如来遗敕。既以正法付嘱尊者及摩诃迦叶。宜应精勤护持诵说。我今不忍见于如来阇维之时。即礼佛棺右绕七匝。涕泪号叫还归天上。于时娑罗双树间。天人八部比丘比丘尼优婆塞优婆夷。既见如来母子相见及闻所说。有发无上道心者。有得须陀洹者。斯陀含者。阿那含者。阿罗汉者。或有发于辟支佛心。一切大众受持佛语。顶戴奉行

    摩诃摩耶经八国分舍利品第二

尔时波婆国末罗民众。闻佛灭度皆自念言。今我宜往求舍利分起塔供养。即下国中严四种兵。象兵马兵车兵步兵。到拘尸城遣使者言。闻佛众祐止此灭度。彼亦我师。敬慕之心来请骨分。当于本国起塔供养。拘尸王答。如是如是。诚如君言。但佛世尊垂降此土于兹灭度。国内士民当自供养。远劳诸君遗形舍利未得相与。尔时遮罗颇国诸跋离民。罗摩伽国拘利民众。毗留提国婆罗门众。迦维罗卫国释种民众。毗提罗国离车民众。及摩竭王阿阇世等。闻佛如来于拘尸城双树林间而取灭度。皆自念言。今我宜往求舍利分。时诸国王阿阇世等。各下国中严四种兵。进渡恒水。即敕婆罗门香姓。汝持我名入拘尸城致问彼王。诸末罗等。起居轻利游涉强耶。吾于贤者每相崇敬。邻境义和曾无诤讼。我闻如来于君国内而取灭度。唯无上尊实我所天。故从远来求请骨分。欲还本土起塔供养。设以我者。举国重宝以居共之。时香姓婆罗门受王教已。即诣彼城语诸末罗。末罗门已报香姓曰。诚如君言。但为世尊垂降此土于兹灭度。国内士民自当供养。远劳诸君舍利叵得。尔时诸国王等。则集群臣众共立义。而作颂曰

  法王无上尊　　在我国涅槃
  我今庄严塔　　安处而供养
  令具妙舍利　　光明遍十方
  所可化众生　　云何得分析

尔时诸国王说此偈已。各自思惟。我承如来遗形舍利。得禀未来天人果报当获多福。而复告曰。吾等和议远来拜首逊言求分。如不见以。四兵在此不惜身命。义而弗获当以力巨。时拘尸国即集群臣众共立议。以偈答曰

  如来大师在我国　　不期登趣证灭度
  遗留舍利如佛在　　昼夜勤心常恋仰
  情存法海度众生　　冀得我今长供养
  远劳诸君屈来拜　　求觅舍利真叵得

尔时香姓婆罗门于诸王前立在一面。长跪合掌而说偈答

  如来智慧大慈悲　　哀愍三千大千界
  其中说法遍十方　　乃至阿僧不可说
  怜愍众生如一子　　恒河沙数心无息
  菩萨眷属常往游　　声闻弟子恒来我
  说法演音如共闻　　围绕纷纶同一说
  天人八部众皆寻　　故我现今清净海
  如来涅槃有舍利　　八分分之不得惜

时诸国王闻此偈已。心犹怅怏默然不许。时香姓婆罗门更晓众人。诸贤长者。受佛教戒口诵法言。一切众生常念欲安。云何乃为诤佛舍利共相残害。如来遗形广以利益无量众生。非止君等。舍利今在。唯当分之。何应如是。众人闻之。咸称曰善。寻复议言。谁能堪为分舍利者。皆曰香姓婆罗门。仁智平均可使分之。时诸国王即命香姓。汝为我等分佛舍利均作八分。于是香姓即到骨所。头面礼毕。取佛上牙别置一面。寻遣使者赍牙往诣阿阇世所。语使者言。以我所咨上白大王。起居轻利游涉强耶。舍利诸国咸然以共。今付使者如来上牙。并可供养以慰企望。明星出时集众分之。当自奉送。是时香姓别置一瓶容受石许。而分舍利均为八分。诸国纳已则告之言。愿持此瓶众议见沾。自欲于舍起塔供养。咸共以之。时有毕钵村人来白众言。乞地焦炭起塔供养。皆亦以之。尔时拘尸国。波婆国。遮颇国。罗摩伽国。毗流提国。迦维罗卫国。毗舍离国。摩竭国王阿阇世等。得舍利分。各归其国起塔供养。香姓婆罗门。持舍利瓶而归起塔。毕钵村人。得地焦炭起塔供养。后有衔国异道道士求得地灰。亦还本国起塔供养

摩诃摩耶经卷下

此经末元有八国分舍利品约二纸半准校勘大藏竹堂讲师批该此段经文自是涅槃后分经文不当在此然此已毕顶戴奉行下竺本无当与削去奉此已除各请详悉至元二十年三月望后二日题记

经末有八国分舍利品准校勘大藏竹堂正法师云是涅槃后分不当在此下竺藏本元无今削去至元二十年三月记


菩萨从兜术天降神母胎说广普经

    No. 384

菩萨从兜术天降神母胎说广普经卷第一

        姚秦凉州沙门竺佛念译

    天宫品第一

如是我闻。一时佛在伽毗罗婆兜释翅授城北双树间。欲舍身寿入涅槃。二月八日夜半。躬自襞僧伽梨郁多罗僧安陀罗跋萨。各三牒敷金棺里。衬身卧上脚脚相累。以钵锡杖手付阿难。八大国王皆持五百张白[疊*毛]栴檀木榓。尽内金棺里。以五百张[疊*毛]缠裹金棺。复五百乘车载香苏油以灌白[疊*毛]。尔时大梵天王将诸梵众在右面立。释提桓因将忉利诸天在左面立。弥勒菩萨摩诃萨及十方诸神通菩萨当前立。尔时世尊欲入金刚三昧。碎身舍利。善哉不思议法。于娑婆世界转此真实法。尔时世尊作是念已。十方世界皆六返震动。尔时世尊从金棺里出金色臂。即问阿难。迦叶比丘今来至不。对曰。未至。世尊重问。牛齝比丘来至未耶。对曰。于彼天上般涅槃。三衣钵至。佛告四众。吾今永取灭度。即复捡[疊*毛]入金棺里。寂然不语。如是再三出手须臾。佛问阿难及诸四众比丘比丘尼优婆塞优婆夷八大国王。天龙鬼神阿修罗迦留罗紧陀罗摩睺罗伽乾闼婆人与非人。云何阿难。吾前后所出方等大乘摩诃行经。汝悉得不。对曰。唯佛知之如是再三。佛告阿难。吾于忉利天宫与母摩耶说法。汝亦知不。对曰。不知。云何阿难。吾于龙宫与龙说法。无数亿千诸龙子等皆令得道。留全身舍利百三十丈。汝亦知不。对曰不知。云何阿难。吾处母胎十月。与诸菩萨说不退转难有之法不思议行。汝复知耶。对曰。不知。佛告阿难。谛听谛听善思念之。吾今与汝一一分别菩萨大士难有之行。阿难白佛言愿乐欲闻。佛告阿难。去此东南方一亿一万一千六十二恒河沙刹。彼有世界名曰思乐。佛名香焰如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊于彼现般涅槃而来至忉利天宫。经历无数阿僧祇劫。三十六返作大梵天王。三十六返作帝释身。三十六返作转轮王。所度众生无堕二乘及诸恶趣。何以故皆是诸佛神智所感。云何阿难。如来世尊有胎分耶。无胎分耶。阿难白佛。如来之身无有胎分也。佛告阿难。若如来无胎分者。云何如来十月处胎教化说法。阿难白佛。有胎分者此亦虚寂。无胎分者亦复虚寂。尔时世尊即以神足。现母摩耶身中坐卧经行。敷大高座纵广八十由旬。金银梯梐天缯天盖悬处虚空。作唱妓乐不可称计。复以神足东方去此娑呵世界万八千土。菩萨大士皆来云集。南方西方北方四维亦尔。复有下方六十二亿刹土。诸神通菩萨亦来大会。上方七十二亿空界菩萨。亦来云集入胎舍中。尔时文殊师利菩萨。即从坐起白世尊曰。此诸菩萨大士云集。欲听世尊不思议法。诸三昧门。陀怜尼门。一相三昧。闻空三昧。道性三昧。真实三昧。虚空王三昧。逝习绪三昧。受性三昧。行迹三昧。降魔三昧。除秽污三昧。如是三昧亿千那由他。如今如来。入何三昧居于胎舍。与诸大士说不思议法。佛告文殊。汝今观察。一住二住乃至十住一生补处。诸方菩萨各当其位勿相杂错。所以者何。吾今欲与诸大士说不思议法。今此大众清净无杂。寄生枝叶亦无秽恶。尔时世尊以清净音。即说颂曰

  昔来无数劫　　成佛身无数
  今复入胎舍　　欲度诸众生
  身净无恶行　　口行无虚妄
  意行常慈悲　　清净菩萨道
  愍彼众生类　　恒处四驶河
  计常及断灭　　回向菩提道
  勤苦获此身　　勿兴秽污想
  计身如丘墓　　野干之所伺
  愚者深染着　　耽爱不能舍
  此身无反复　　昼夜欲唼[口*束]
  九苦为关楗　　如画瓶盛粪
  欲渴之所逼　　何为生苦恼
  如海吞众流　　愚者以为宝
  身非金刚数　　莫为众恶行
  受身要当殒　　何不速行道
  若人寿亿劫　　彼亦应舍欲
  况寿不满百　　何不知止足
  愚者恒自称　　宿福获此身
  应当快自恣　　未乐便当终
  此欲无牢固　　非智而能守
  夫人欲舍欲　　十慧无想观
  欲非真实法　　起灭如水泡
  幻师之所造　　变现若干像
  愚者谓为实　　求实无所得
  空性本自空　　终始无起灭
  分别无想定　　能尽众生漏
  文殊汝今知　　十方无漏会
  我入琉璃定　　广演方等法
  十方恒沙佛　　如我说无异
  愍此群萌类　　永处焰火舍
  舍胎复受胎　　往彼复来此
  十方诸菩萨　　积行恒河劫
  虽处娑婆界　　五苦五恼劫
  如我十方界　　方比于此土
  周旋五道中　　受罪此最剧
  解空无定相　　亦复无本际
  究竟一相义　　性自本虚寂
  常想无起灭　　有余及无余
  昔我弘誓愿　　遍受五道胎
  化湿卵胎中　　亦说难有法
  染着五阴者　　与说无所有
  十二牵连法　　痴行生死本
  坠堕四颠倒　　为说四真实
  苦谛无有谛　　习尽道亦尔
  欲我戒见受　　亦及于四爱
  分别真实性　　虚无寂寞要
  虽度生死岸　　不处于涅槃
  今处于母胎　　说法悟群生
  娑婆国土中　　无数恒河沙
  处胎说法者　　济度阿僧祇
  虚空无边界　　佛国亦如是
  众生受识神　　真实性不同
  明慧所教化　　随类而度之
  或见身而度　　闻声得解脱
  或复思惟苦　　集谛尽道本
  思惟四意止　　断意四神足
  五根及五力　　七觉以为花
  贤圣八品道　　以用璎珞身
  分别彼我空　　无想寂灭慧
  不愿有所求　　永处空无慧
  初入有觉定　　三十不净观
  逆顺知有觉　　入定解无观
  九次入初定　　分别无觉观
  又乐灭尽道　　初定不 (丹五) 行法
  喜乐意已灭　　安隐入四法
  通慧诸大士　　不以此为行
  为诸烦恼故　　应适前众生
  禅定经历劫　　形枯如槁木
  三禅香气熏　　五枝不凋落
  佛慧不可量　　于有亦不有
  无上最正觉　　无生死亦无
  吾从成佛来　　游观于三禅
  设当入四禅　　无说而得度
  我观虚空界　　众生无有依
  诸佛神力智　　乃能尽原本
  断漏诸学人　　未能悉分别
  道品甚深妙　　二乘所不及
  吾以天眼观　　慧眼及佛眼
  四识所受形　　亦复于中化
  亦无地水火　　形色可观见
  唯佛大神力　　皆令至彼岸
  十方诸佛土　　恒沙阿僧祇
  亦以道慧本　　游处虚空界
  设当以肉眼　　观空界众生
  欠口出入息　　无数众生入
  尔时此等辈　　各得成道迹
  当知佛法身　　真实不思议
  佛为三界将　　愍而济一切
  欲色无色有　　令受道慧证
  彼亦无淫怒　　及痴眷属众
  睹形即入道　　岂须学无学
  无量诸佛刹　　成道各各异
  或从有想成　　或从无想成
  不复修习此　　真如四圣谛
  菩萨清净观　　入禅无碍道
  罗汉辟支佛　　入定各不同
  生生不见生　　岂当有生本
  愚惑染着人　　谓为生是我
  吾我自称我　　不见有吾我
  菩萨四禅行　　缘觉亦不知
  菩萨入初禅　　三十无漏行
  百七三昧定　　出入息具足
  二定七十二　　自观无我想
  虽经累劫苦　　不离于禅行
  四住断诸漏　　乃逮此二禅
  六住故犹豫　　入定如水波
  八万四千行　　犹尚不自制
  我本于六住　　十二劫退转
  常想起乐想　　轮转生死渊
  大圣定光佛　　记别心坚固
  立志不退转　　尔乃逮三禅
  断除七万垢　　永灭无根本
  无畏师子步　　阐扬大法典
  广游诸佛刹　　礼事常供敬
  过去阿僧祇　　诸佛世尊等
  各各于本刹　　誓愿行佛事
  心虽不退转　　常恐堕下劣
  亿千魔徒众　　不能动一毛
  超越八住行　　进入于菩提
  可乐所恋着　　永除无想念
  除师尊父母　　余者不顾恋
  方成一禅行　　名施度无极
  习观无等伦　　九地通慧本
  不复入灭尽　　移坐即成佛
  为缘众生故　　往诣佛树下
  广及阿僧祇　　普集在道场
  十方无量界　　诸佛世尊等
  各各舒右手　　善哉大师子
  十力无所畏　　坚固入四禅
  慈愍群萌类　　愿速从禅觉
  未度者使度　　未脱者使脱
  四识处幽冥　　渴仰禅悦味
  不达诸佛教　　辄便自称扬
  复自内思念　　用此身累为
  毕取于涅槃　　用度众生为
  诸佛各面现　　善哉释迦文
  建立弘誓意　　勿起退转心
  转无上法轮　　击于大法鼓
  闻者速解脱　　不经劫数难
  捷智无阂智　　辩智通达智
  道智明慧智　　断智无生智
  不起尽灭智　　消智九次智
  无畏师子智　　雷吼音响智
  端坐不动智　　大悲无碍智
  身相庄严智　　拔苦愍护智
  结解无缚智　　受别取证智
  降魔破军智　　成无我慢智
  意勇精进智　　施不望报智
  行忍受辱智　　金刚十力智
  住劫不动智　　集众和合智
  最上导师智　　惭愧法服智
  菩萨誓愿智　　神足变现智
  境界无碍智　　断意灭结智
  清净照明智　　自识宿命智
  玄鉴他心智　　父母真净智
  分身刹土智　　处胎无秽智
  识定不乱智　　一向信受智
  入定观察智　　分别身相智
  三十不净智　　灭灾除患智
  菩萨次第智　　超越教化智
  灭十二缘智　　缘觉时悟智
  闻声受化智　　出十二入智
  观慧无碍智　　受道玄鉴智
  一夜为劫智　　以劫为日智
  念佛佛现智　　刹土清净智
  无有二乘智　　独步无畏智
  悦可众意智　　所作已办智
  不造前后智　　灭故无新智
  入定除想智　　观内外身智
  如来受慧智　　贤圣默然智

尔时世尊说此偈时。亿百千众无量众生。皆悉发趣立尽信地。复有菩萨十二那由他。在观行地不住三住。成就国土在右分中。七万七千亿众生逮阿惟越致。佛复告文殊。今此座上无有一人杂垢秽恶有退转者。所以者何。皆是利根不处生死。无缚无著无灭无生。修道清净受证成就。愿乐欲闻诸佛不可思议正法。降伏众魔除去憍慢。外虽教化诸佛刹土阿僧祇众生。内心游戏无量百千三昧。其三昧者。师子奋迅三昧。超行登位三昧。广进超步三昧。童真乐法三昧。四道生灭三昧。无想等行三昧。往诣不退道场三昧。观察众心三昧。念一生补处三昧。无形像三昧。地中踊出三昧。解缚战斗三昧。顶受最胜三昧。众生喜见三昧。入不思议三昧。佛界不思议三昧。法界除秽不思议三昧。圣众不思议三昧。众生起灭不思议三昧。龙力兴降不思议三昧。在众上中王不思议三昧。勇猛降伏怨不思议三昧。寿命无量不思议三昧。在五道能受苦不思议三昧。诸佛现在不思议三昧。四事供养不思议三昧。如是三昧一亿一千庄严其身。复有名速疾。一日中出家行道往诣树下成佛。教化众生净佛国土。不思议三昧。复有留住待缘不思议三昧。如来缘是三昧。住寿无量阿僧祇劫。为有缘众生得度于无余涅槃界。不取涅槃更造因缘行菩萨道。复有佛力不思议三昧。从一佛刹至一佛刹。如人合掌弹指顷授无量无限恒河沙数众生记别。亦复使彼一日成佛。处胎菩萨神力如是也

     菩萨处胎经 游步品第二

尔时弥勒菩萨即从坐起。整衣服偏袒右臂。右膝着地白世尊言。善哉善哉。如来说不思议法。今此众中有践迹者未践迹者。有住信地未住信地者。或有菩萨从光音天廅天波刹陀天陀波魔那天阿会亘修天道呵天须干天须室只褥天告那天。乃至一究竟天化自在天他化自在天。或有菩萨空处识处不用处。乃至非想非非想处。云何于彼入胎教化。世尊告曰。勿作斯问。何以故。如来终不说此义。我今问汝。汝当报我。云何弥勒。空有形质无形质耶。对曰无也。世尊告曰。云何弥勒。若空无形质。云何众生有生有老有病有死耶。弥勒白佛言。于第一义无生老病死。以是故空无形质。佛告弥勒。若无形质。此众生等谁有授决。谁有受决者。云何菩萨往诣树下。或时经行或时入定。云何菩萨自观身相观他身相。云何菩萨现行七步。自称成佛降伏众魔。云何菩萨修治道场。请召十方诸众生耶。弥勒白佛言。此亦空寂无形无质。如来身相亦是假号。乃至一究竟义。悉空无所有。佛复告弥勒。行空菩萨。云何游至十方刹土教化众生。弥勒白佛言。行空菩萨。不见刹土亦无有佛。佛自无佛。云何有佛地水火风识界。我人寿命皆悉空寂。以是之故无有胎分。佛告弥勒。汝在三十三天。与诸天人说空行法。于彼座中有践迹耶。无践迹耶。弥勒白佛言。彼诸天人。常想乐想净想计我为我想。以是无有践迹无践迹也。佛复告弥勒彼诸天人。有色行阴无色行阴。有报应阴无报应阴。有破有阴无破有阴。有受入阴无受入阴。有声响阴无声响阴。有中间阴无中间阴。有彼此阴无彼此阴。有究竟阴无究竟阴。有默然阴无默然阴。云何弥勒。汝在天宫与诸天人说真法。言有此诸阴名号耶。弥勒白佛言。无也。世尊言。云何弥勒。十方诸佛授汝记莂。成无上正真道。为有正真道。为无正真道耶。弥勒对曰。无耶。世尊言。有道者斯亦假号。言弥勒者亦是假号。如自性本际亦是假号。如来色身身自空。相相自空。本末本末空。彼此彼此空。云何自知号弥勒决。言性性自空。言有有自空。言无无自空。无自常住。无能令不住。言住住自空。言自相自相空。言阴阴自空。言胎胎自空。乃至道场言行行阴空。以是故。世尊。无有践迹无践迹也。佛复告弥勒。有践迹者无践迹者。有果证。无果证耶。是有为性非有为性耶。是有为中无为性耶。是无为中无为性耶。是有漏中无漏性耶。是无漏中无漏性耶。是欲界中有尽性耶。是欲界中无尽性耶。是色无色界中有尽性耶。是色无色界中无尽性耶。是空界灭识性耶。是空界非灭识性耶。乃至有为空无为空自性空。有以有为空。无以无为空。大空取空一相无相空。有余涅槃空。无余涅槃空。是践性耶。非践性耶。弥勒白佛言。践法非法。非法亦非践。云何弥勒。有为法非无为。无为法非有为。云何汝言。有践法无践。无践法亦无践。弥勒白佛言。最第一义。有相无相法中。求有为非无为。求无为非有为耶。佛告弥勒。吾今问汝。真实根论非无根论。有为无为从何而生。有何名号。弥勒白世尊言。虚空寂灭性。字义名号皆非真实。是无根论非有根论。佛告弥勒。根义云何生无根论。弥勒白佛言。于世俗义。根为法性。无根为证静。不动亦不不动。一相无相。乃至有为无为法。有漏无漏法。有对无对法。色法无色法。可见法不可见法。不住亦不不住。是无根义。佛言。善哉善哉。弥勒。空行菩萨晓了无根。不生亦不不生。未来无对。现在不住。过去已灭。无著无断不住。亦不不住。尔时座中有菩萨。名分别身观。白佛言。今闻如来说无根义。说有身相说无身相。说有自性空。说无自性空。说无根义者。从如中来耶。不从如中来耶。无根义者。有生灭耶无生灭耶。有对法耶无对法耶。有色法耶无色法耶。有为法耶无为法耶。有漏法耶无漏法耶。有相法耶无相法耶。有身观耶无身观耶。佛告分别身观菩萨曰。何者是身。何者是观。身谁为行此观。分别身观菩萨白佛言。地水火风名身阴也。识分别名观也。佛告曰。言地地自空。言水水自空。言火火自空。言风风自空。言识识自空。言空空自空。何者是身。云何是观。身观菩萨白佛言。如佛所说。虚空法界皆悉空寂。无佛言佛。无法言法。无僧言僧。无今世后世。无罪无福。将不与大师同耶。佛告分别身观菩萨曰。汝入灭尽定时。颇见眼观色。乃至意观法不。身观菩萨白佛言。不也世尊。所以者何。灭尽定中无生无灭。佛告身观菩萨。如是如是。如汝所言。眼观色。色非我色。我非彼色。识非我识。我非彼识。乃至声香味触法。亦复如是。法非我法。我非彼法。于无根义无增无减。根清净道亦清净。相空清净。乃至究竟空。亦复清净。一清净而无二。五阴净行净。道亦清净。有对净无对净色净。道亦清净。菩萨观净六尘净。道亦清净。眷属净性净。道亦清净。地净住净。道亦清净。是为菩萨摩诃萨无根义。佛复告身观菩萨曰。苦净不苦不乐净。道亦清净。门净种净生净。道亦清净。是为菩萨摩诃萨无根义。佛复告身观菩萨曰。道场净国土净众生净。道亦清净。是为菩萨摩诃萨无根义。根净力净觉意净道品净。道亦清净。云何身观菩萨。我今问汝。汝当报我。如来修治道场坐树王下。云何分别众生之类。用有记法耶。无记法耶。有记法者尘劳之垢。无记法者亦是尘劳之垢。以何无记而授众生决。身观菩萨白佛言。有记之法非尘劳垢。无记之法亦非尘劳。何以故。尘劳垢者是卑贱法。有记无记法是上尊法。无以无记对于尘劳。何以故。尘劳法者如来种也。佛告身观菩萨。止止莫作此语。汝言尘劳是生死法。今复言如来种耶。身观菩萨白佛言。如来身者。为是化非众生耶。若是化者。无有尘劳众生之趣。设从众生有如来身者。尘劳之垢非如来种乎。佛告身观菩萨曰。如是如是。如汝所言。以假号名字而有尘劳。第一义中无有尘劳。佛复告身观菩萨。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。常以天眼观十方世界阿僧祇众生意识生念。有欲心多者无欲心多者。有恚心多者无恚心多者。有痴心多者无痴心多者。有解脱心者无解脱心者。有增上慢者无增上慢者。有易究竟者难究竟者。菩萨悉知悉观而往度之。云何菩萨以天眼观。知少欲者知多欲者。于是菩萨在彼众中。现淫女形与说淫欲。快乐难忘视无厌足。使彼欲意倍生喜乐。后渐与说身为秽污无常无我苦空非身。欲为火坑烧煮心识。使令厌患令无淫欲。此众生等。即于胎中受无上记。身观菩萨。汝当知之。如此众生。无嗔恚痴断欲得道。或有菩萨在彼众中共为善友。与说杀业快乐难忘。快哉杀生减汝寿命增我寿命。后渐渐与说杀生受罪极重。与说百八杀生重罪为苦为恼。引令入于得在道捡无有欲痴。即于胎中成无上道。或有菩萨在彼众中共为朋友。说十不善道。亦身教口意教不善。以真为虚。无常谓常。空谓有实。无身谓有身。苦谓有乐。无世谓有世。后渐渐与说广大深智无量辩才。燃法炽法为竖法幢。渐渐引入智慧丛林。诸人当知。若有狐疑于我所者。当以智慧火烧汝狐疑心。若人布施手执财物。有人受者。解了三事空无所有。即于胎中成无上道。见人持戒戒品成就毫厘不犯。解了虚寂而无所有。即于胎中成无上道。或有众生忍心不起。若有人来杀害割截心无恚想。头目髓脑无所爱惜。即于胎中成无上道。若有众生心若金钢不可沮坏设当有人软语诱导。劫数难量。流转生死难可勉济。何不于此自度。而已为彼众生唐劳勤苦。菩萨心进终不退转堕落生死。即于胎中成无上道。若人行禅心识不移。弊魔波旬在虚空中雷吼电烈。不能令彼动于一毛。何况使彼退于禅道。即于胎中成无上道。若有众生分别诸行。此则可行此不可行。若人贪着爱乐身者。即便为说四意止法。一一分别诸法要藏。畅达演说无量法界。即于胎中成无上道。或有菩萨入慈三昧。遍满东方无限无量阿僧祇恒河沙等刹。众生之类。慈愍爱念欲令解脱。譬如恒河沙中取一沙。过恒河沙国土下一沙。如是尽恒河沙慈心不尽。菩萨发愿坚固难动。设有人来取菩萨身脔脔割截。即时弥满三千大千国土。血变为乳如母念子。是为菩萨行慈三昧。即于胎中成无上道。或时菩萨入悲三昧。遍满南方无限无量阿僧祇恒河沙等刹众生之类。悲念欲令解脱。以恒河沙中取一沙。过恒河沙国土下一沙。如是尽恒河沙悲心不尽。堪任代彼众生受苦。皆是菩萨坚固誓愿。众生见者以清净心。远离众恶妄想已断。即于胎中成无上道。或时菩萨入喜三昧。遍满西方无限无量阿僧祇恒河沙等刹众生之类。喜念众生欲令解脱。以恒河沙中取一沙。过恒河沙乃下一沙。如是尽恒河沙喜心不尽。若彼众生入喜令自娱乐。皆是菩萨发意坚固。即于胎中成无上道。或有菩萨入舍三昧。遍满北方无限无量阿僧祇恒河沙等刹众生之类。恐彼众生有缺漏行。将养拥护不令没溺。取恒河沙中一沙。过恒河沙国土下一沙。如是尽恒河沙舍心不尽。皆是菩萨誓愿坚固。即于胎中成无上道。于时菩萨真实法明修大慈大悲。非罗汉辟支佛所行。遍满四方欲令众生一闻音声寻声即至。皆是菩萨誓愿坚固。即于胎中成无上道

    菩萨处胎经 圣谛品第三

佛告菩萨摩诃萨。比丘比丘尼优婆塞优婆夷。天龙鬼神阿修罗迦留罗紧陀罗摩睺勒毗舍遮鸠槃茶富单那摩[少/兔]舍阿摩[少/兔]舍等。吾今为汝说菩萨摩诃萨贤圣谛。谛听谛听善思念之。所以者何。吾从无数阿僧祇劫修习道果。此没生彼周流五道。不舍菩萨贤圣谛。云何菩萨修习圣谛。或时菩萨从初发意。乃至道场行无阂法。不取禅证灭诸恶想。或有菩萨入初禅地见清净行。耻而厌患舍而进趣。欲登六住殷勤进业。入二禅地心豁然悟如月云除。自观身中心发誓愿。为坚固耶不坚固耶。自以己心复观众生心。易度难度皆悉知之。时菩萨心极大欢喜。吾将成佛审然不疑。刹土清净除众生垢。降伏于魔转于无上贤圣法轮。快哉福报所愿知成。尔时菩萨入不乱定。以心举心以身举身。即得成就神足圣道。从一佛刹至一佛刹。礼事供养诸佛世尊。听受深法不难不畏。转入三禅观诸色像悉空无所有。住于三禅观众生类悉能分别。彼没生此此没生彼自识宿命。亦复知彼所从来处。刹利种婆罗门种。居士种长者种。斯应行人不应行人。应受果不应受果。出入息非出入息。斯四意止四意断。根力神足觉意八道。斯人受决某国某处。某众生中成佛。皆悉知之。是谓菩萨于三禅地得清净心。复次菩萨摩诃萨于三禅地上望八住。虽望而不得。昼夜勤精进求清净心。入四禅中面自见十方诸佛。为说四禅不退转法。无碍解脱行四神足。能分一身为无数身。以无数身合为一身。入火光三昧。遍满三千大千世界。令彼众生见火光三昧。心意恐惧衣毛皆竖。自来归依于菩萨所。因三昧力而得度脱。尔时于四禅中。分别世界真如法性。心退还堕习六住行。菩萨自念。我今未得不退转地。云何当得八住。于四禅中殷勤修习。净众生行代其执苦。虽行此法不自称誉。除去憍慢无有吾我。修六思念。虽复行道在九众生居。心不染着恋慕生死。心豁然悟逮不退转。是谓菩萨摩诃萨于圣谛得清净心。于是菩萨入空处三昧。观此三千大千世界众生之类心识。修净法离缚着无所恋慕。能自住寿一劫二劫至无数劫。于某劫中教化众生。生者灭者渐渐将导获清净道。即于胎中成无上道。或时菩萨入识处三昧。观此三千大千世界识神所趣。天道人道饿鬼道畜生道地狱道。易度难度皆悉知之。即于胎中成无上道。或时菩萨入不用处三昧。观此三千大千世界众生之类。青黄赤白有多有少。即自厌患不用久住。即于胎中成无上道。或有菩萨入非想非不想处三昧。观此三千大千世界众生识神所趣。生者灭者。青黄赤白有长有短。令彼众生使知寿尽。即于胎中成无上道。于是菩萨入大虚空大寂定三昧。观此三千大千世界。上至无边无尽刹土。众生之类识神所趣。思惟分别空无之法。是谓菩萨摩诃萨即于胎中成无上道。于是菩萨入无形界三昧。普观三千大千世界众生之类。心所系缚亦无有缚。识神无形所观识法亦复无形。于无形法即于胎中成无上道

菩萨从兜术天降神母胎说广普经卷第一菩萨处胎经卷第二

        姚秦凉州沙门竺佛念译

    佛树品第四

尔时世尊将欲入无余涅槃界。集诸神通大德菩萨。神足变化说不思议法。今我宁可化作七宝树。度此长流永在生死没溺者。令得解脱。即入琉璃定无形三昧。东方去此忍界。六十四亿恒河沙刹。化作七宝树遍满其中。诸宝树上茎节柯枝叶果实。各各有七宝宫殿。宫殿有佛。诸佛各说四非常法。后园浴池众鸟聚集。娱乐其中快乐难胜。其池水中生优钵莲华。须干提花。末干提花。于彼陆地生瞻卜花须曼罗花。牛头栴檀捣香末香。天缯幡盖悬处虚空。尔时风神王名曰随意。放大香风吹七宝树叶。柔软香熏枝叶相 掁 。皆出自然八种音响善哉出大光明。如来八种音声。将欲度未度者。谁现是瑞应。昔我不闻此亦复不现睹见。起灭无常相将非幻化耶。尔时树叶上七宝宫殿中。诸如来至真等正觉。发大音声阐扬不思议难有之法。欲说八地中庄严诸佛刹。犹如有人欲睹大海水。去海百由旬不见诸生木。遇见涝水尝之知海尚远。即自办入海之具。不见形相念定如空始至海岸。以无畏心自庄严身。善哉大圣。我所求者今乃获之。欣之乐之心无疲惓。即时舍所资生尽入海中。随本所愿皆悉在前。菩萨摩诃萨亦复如是。能断一住至六住地。尽众生结使永尽无余。今我成佛必然不疑。是谓菩萨摩诃萨于胎中庄严佛树。复次菩萨摩诃萨欲自庄严身相。具足三十二大人之相为真实不。从顶至足。足有千轮轮有千辐。辐有千相相有六度无极所成。无见顶相者。破憍慢山得成肉髻相。吾从无数阿僧祇劫得不犯淫欲果报。得阴马藏相。阴马藏相者坏彼邪见。放相光明遍满十方恒河沙刹。一一光明皆有化佛。一一化佛皆坐七宝高座。发大音声演说六度无极。如诸如来常所说法苦集灭道。施戒忍精进禅般若波罗蜜。善巧方便解了诸法。空空大空无量空。内空外空最空行空。相空报空灭三灾空。三明报空。三慧空三达空。三等空三世空。三分法身空。三界寂灭空。过去当来现在空。自相空。是谓菩萨摩诃萨不犯淫报相。吾从阿僧祇劫常修口净。不从彼闻此说。不从此闻彼说。得广长舌相。遍满十方阿僧祇恒河沙刹。放舌相光明。一一光明皆有化佛。一一化佛皆坐七宝座上。以清净音声演说无量口行。清净报业真实所作。成办四事无畏。晓了诸法无来无去音响清净。以度生死畏地无所挂碍。分别众生一一音响。演说无量智慧辩才。度五道渊法法成就。以九解脱而自璎珞。十力具足空性无形不可沮坏。其闻法者悉皆信解。是谓菩萨摩诃萨口净舌相果报。吾从无数阿僧祇劫得音响相。遍满三千大千刹土。柔软和雅所说不粗。出言成就不从彼受。其声音者无不悦满。此音响中亦有无数清净所说。如诸如来常所说法。十二因缘痴行生死。自观其身观他身观内外身。息长亦知息短亦知。化彼众生越次取证亦不住证。发声响相光明。一一光明皆有化佛。一一化佛皆坐七宝高坐上。普与众生说无量法门。心趣解脱空无相愿。观了诸法悉无所有。常以四事慈悲喜舍。四禅四谛众智法门。得总持法门。捷疾法门。应声法门。辩才法门无量法门常现在前。心常游戏无量百千三昧。是谓菩萨摩诃萨音响相。吾从无数阿僧祇劫。恒修心清净。所念专正所行惭愧。执心一向无他异想悉无尘垢。若有人毁不生忧戚。设当称誉不以为欢心不移易。所行坚固难动如地。从无数劫承事诸佛。与诸众生说微妙法。所行不伪一向趣道。有佛法僧处辄身往化。讲论无量总持法门。所谓论者。施论戒论生天之论。欲是不净涅槃是乐。引导众生入定三昧。分别苦谛去离四缚。蠲除集法灭大分结。道除杂糅不起法忍。住不退转得清净观。知彼众生心之所念。随类开化得成道果。犹如新成白[疊*毛]易染为色。自常摄心不讥彼阙。常乐闲静不处愦闹。入比丘众威仪具足。若入禅定系意在明。经行往来心无懈慢。于大众中能师子吼。分别空性悉无所有。是谓菩萨摩诃萨心清净门。吾从无数阿僧祇劫。修总持法门不可沮坏。闻一得百闻百得千闻千得万。诸佛所说句义字义。皆悉总持而不忘失。是谓菩萨摩诃萨成就总持法门。吾从无数阿僧祇劫。常自修习无常观行。一切诸法皆归无常生者有灭。在在处处兴隆法乐净治佛土。所说诚谛自识宿命所经历处。为说法化心识坚固。神足无畏不可思议。从无数劫积诸苦行。所发誓愿不违本行。游戏诸法自在无疑。是谓菩萨摩诃萨成就总持法门。吾从无数阿僧祇劫修眼神通。遍知十方众生之类。有应空行不应空行。有定意无定意者。有乱意无乱意者。有金刚志无金刚志者。有思惟定无思惟定者。天道人道饿鬼道畜生道地狱道。以天眼悉见悉知。见此众生趣有余涅槃无余涅槃者。亦知此众生于中阴取涅槃。亦悉知之。知此众生向须陀洹得须陀洹果。向斯陀含得斯陀含果。向阿那含得阿那含果。向阿罗汉得阿罗汉。果。向辟支佛得辟支佛果。亦观众生出家苦行不舍本誓。剃除须发身被法服。入师子游步三昧。在树王下思惟观树。或一日二日乃至七日。或一岁二岁乃至七岁。或一劫二劫乃至七劫。是谓菩萨摩诃萨成就天眼通。吾从无数阿僧祇劫修耳神通。遍闻十方众生行报。黑有黑果报。白有白果报。不黑不白果报。有漏有漏果报。无漏无漏果报。闻彼众生清净音响。不男声不女声。不男不女柔软声。不长不短声。不非人声。梵声清净声。伽罗毗罗柔和声。不粗声不细声。复以天耳闻彼众生除垢断缚。不住有为相。不住无为相。不住过去当来现在相。住亦不住。不住亦不不住。吾我不住。不住亦不不住。成佛不成佛者。成道不成道者。生天不生天者。生人不生人者。生饿鬼不生饿鬼者。生地狱不生地狱者。生畜生不生畜生者。分别五道以天耳听。悉闻知之。是谓菩萨摩诃萨成就天耳通。吾从无数阿僧祇劫修鼻神通。遍嗅十方无量众生。悉知分别善香恶香。粗香细香。火香水香。俗香道香。乃至菩萨坐树王下香。戒香定香慧香解脱香解脱知见香。教授众生大慈无边香。悲愍众生香。喜悦和颜香。放舍周遍香。神足无畏香。觉力根本香。破慢贡高香。自然普熏香。庄严佛道香。趣三解脱门香。相相殊胜香。明行果报香。分别微尘香。光明远照香。集众和合香。五聚清净香。持入不起香。止灭众垢香。观灭众垢香。闻戒布施香。惭愧无慢香。仙人法胜香。说法无碍香。舍利流布香。封印佛藏香。七宝无尽香。尔时世尊便说颂曰

  摩伽山所出　　花香及栴檀
  三界所有香　　不如戒香胜
  戒香灭众垢　　往来入无间
  菩萨不退转　　涅槃香第一
  譬如善射人　　仰射于虚空
  箭势不尽空　　寻复堕于地
  德香远无际　　终不有转还
  今说佛身香　　戒定慧解度
  于亿百千劫　　不能尽佛香
  若于千万劫　　佛赞佛功德
  大圣不能尽　　佛身戒德香
  诸佛威仪法　　授前补处别
  口中五色香　　上至忉利天
  还来至佛所　　绕佛身七匝
  诸天散花香　　称叹未曾有
  定香远流布　　济度阿僧祇

尔时世尊说此偈已。于彼会中十二那由他众生。心识开悟皆悉发意。愿乐欲生香积佛刹。是谓菩萨摩诃萨成就鼻通。吾从无数阿僧祇劫修口神通。言教往来终不中滞。有所言说言则有光。唇唇有光齿齿有光舌舌有光。如来于大众中说甚深法。所有法者一名阿。阿者无有千万义。无有千万义中。取一无义度无量众生。二名罗。罗者除垢。除垢有千万义。千万义中取一除垢义。除无量众生垢。三名波遮。波遮名果熟。果熟有千万义。千万义中取一果熟义。使无量众生皆悉果熟。四名那。那者非常义。非常义有千万义。千万义中取一非常义。使无量众生悉解非常义。五名茶。茶者尽无。名尽无。名言有无有。言无亦无无。无尽义有千万义。千万义中取一无尽义。使无量众生得解于尽。是为茶尽义。十方无量恒河沙诸佛。受食威仪。从阎浮提上至十八天。皆见如来食。从一住至四住菩萨。见如来身琉璃咽喉。不退转菩萨乃至九地见健疾天子接如来食。乃至他方施行佛事。是为如来神口果报。如来现食味。次第味味不动味。不哊咽不[口*專][口*集]。世尊举饭向口时。心念十方诸五道众生等同此味。即如念皆悉饱满。犹如比丘得九次第禅心软美饱。是谓菩萨摩诃萨口通清净。吾昔无数阿僧祇劫修身神通。分别身中净不净想不净净想。三十六物污露不真。发毛爪齿骨血涕泪。反复思惟以己身法。观众生身亦复如是。自化其身膖胀臭烂脓血流出。或复现身白骨灰色。青瘀色燋黑色。与地同色。无量众生见此身者。皆生苦空无常无我想。复与众生说身业报法。此身非身何者是身。一一分别从头至足悉无所有。以无有身则无有识。众生闻此自思惟身秽恶不净。犹如光音清净天。下观阎浮提臭秽。恶气上熏七千万里。是以菩萨不生光音天。身通菩萨入金刚三昧碎身如尘。一一尘皆作化佛。济渡无量阿僧祇众生之类。现身色相。身上出火身下出水。身下出火身上出水。东踊西没西踊东没。现如来十八神变。众生之类见如来变寻时觉悟。众结永尽入无为道。微尘化佛现身教化。济渡无量阿僧祇众生。是为如来身密教化而不说法。吾从无数阿僧祇劫修习意识。成菩萨神通。摄意入定游至无量诸佛刹土。犹如力人屈伸臂顷还来故处。意识菩萨亦入化生胎生湿生卵生。现不思议神变教化。即于彼处成无为道。意识菩萨于诸通中最上最胜。非辟支佛阿罗汉所能思议。何以故非彼境界

     菩萨处胎经三世等品第五

尔时坐中有菩萨名曰喜见。辩才无碍登蹑十住。如来所行悉能总持。即从座起偏露右臂右膝着地。叉手合掌前白佛言。善哉世尊。今闻此法至未曾有。过去无数恒沙如来。有入涅槃不入涅槃。若入涅槃欲界众生云何得度。若如来不入涅槃。彼诸如来住何佛界。佛告喜见菩萨。善哉善哉。乃能于如来前作师子吼。谛听谛听善思念之。吾今与汝一一分别说之。喜见对曰。如是世尊。愿乐欲闻。佛言过去恒河沙诸佛世尊。名字假号不可胜记。亦如众生生生不灭。无边无际亦无端绪。诸佛要集心如空界。涅槃者即众生是也。是故如来不入涅槃。何以故。为众生故。喜见菩萨白佛言。过去多萨阿竭阿罗呵三耶三佛所度众生。有灭度无灭度耶。佛告喜见菩萨。云何喜见。汝从无数阿僧祇劫。承事诸佛礼事供养香花幡盖。颇见如来取般涅槃不。对曰。不也。云何喜见。我号释迦文多萨阿竭阿罗呵三耶三佛陀。今处母胎为涅槃为非涅槃。对曰。不也世尊。云何喜见。菩萨众生受别当成无上正真道。是真实道非真实道。对曰。是道非真实道若真实道。何以故。有佛有说法见化众生。以是故。是道非真实道。缘缘众生是道缘缘尽众生是真实道。过去缘缘尽众生。于现在非真实道。现在缘缘尽众生。于过去非真实道。过去现在缘缘尽众生。于未来非真实道。未来缘缘尽众生。于过去现在非真实道。何以故。是道非真实道。过去缘缘尽众生。现在缘缘尽众生。未来缘缘尽众生。是真实道。菩萨摩诃萨知而见之不处不入。何以故。犹如九行不尽。所谓九行者。上上。上中。上下。中上。中中。中下。下上。下中。下下。上上缘尽。上中缘不尽。非真实道。上中缘尽。上下缘不尽。非真实道。上下缘尽。中上缘不尽。非真实道。中上缘尽。中中缘不尽。非真实道。中中缘尽。中下缘不尽。非真实道。中下缘尽。下上缘不尽。非真实道。下上缘尽。下中缘不尽。非真实道。下中缘尽。下下缘不尽。非真实道。下下缘尽。是真实道。菩萨摩诃萨于真实性。不取不舍。不住不不住。过去当来现在等。道等涅槃等。一等无有二法。性等自然相等。众生等垢等五阴等。缘等痴行等。道行清净不一不二。欲行缘尽。非色行缘尽。色行缘尽。非无色行缘尽。无色行缘尽。色行缘尽。欲界行缘尽。是谓菩萨等非一非二。尔时佛告喜见菩萨曰。汝欲知过去诸佛灭不灭刹土不耶。尔时世尊即以神力入无畏空界三昧。使一切众尽见释迦文身。寂然无言身相具足。菩萨当知我过去身。其数不可称不可量。即以神足入湿生界众相具足。与无数阿僧祇为湿识众生说法。令彼湿识随意所愿各得解脱。复以神足入化生众生现身色相。与无央数阿僧祇众生说法。令彼化识随意所愿各得解脱。尔时世尊即以神足入卵识众生现身色相。与无央数阿僧祇众生说法。令彼众生随意所愿各得解脱。尔时世尊复以神足现当来世界。人四生中现身色相。与无央数阿僧祇众生说法。令彼四生众生随意所愿各得解脱。如我今日在母胎中。与诸十方神通菩萨。说不退转难有之法。亦以神通入天四生。入地狱四生饿鬼四生畜生四生。于四生中胎化二生尽漏疾。湿生卵生尽漏迟。化生胎生是利根人。湿生卵生是钝根人。尔时世尊复以神足现寂寞世界。使彼大众皆悉知见。亦无言教苦集灭道之名。何以故。彼土众生皆是胎化利根人。佛复以神足现下方照光世界视彼众生禀受读诵。经历劫数乃成道果。知此众生湿生卵生是钝根人。佛复以神足现不死刹土。使彼大众知彼众生不闻死名。知此众生大慈誓愿利根中胜根。佛复以神足现中夭刹土。使彼大众皆悉知见。见彼众生有中夭者。由彼众生自造苦本。本寿极长今寿转短。彼世界王名曰除忧。剥死人皮以用作鼓。百岁一打使彼众生皆知死名。寿命转减至于百岁时有出者。吾今舍寿八十有四。出五浊世胎生化生是我利根分。汝等当知。命不久存非佛神力所能留住。此身如泡势不久立。是身如雾常乱人想。是身如梦增益嗔恚。是身如幻诳惑世人。是身如响求对无形。是身如影眼见不获。如是我身于此灭尽更不复生。何者不生。不于此阎浮提生。复于十方三十二垓佛刹。遍满彼刹施行佛事。此非过去者。以是之故。缘缘尽缘缘不尽。无有涅槃者

尔时弥勒菩萨摩诃萨即从坐起整衣服偏露右臂。右膝着地前白佛言。甚奇世尊。世界若干众生不同。善恶行报各各别异。如来说法空无寂寞。不可思议入何三昧。威神惑动如是难测。有识众生咸可易化。山河石壁生树草木。皆变人形。为有识众生无识众生。佛告弥勒。汝昔与我共越山海。见一恶兽应食十住菩萨肉耶。弥勒白佛言。不也。何以故。正使三千大千刹土满中恶兽。欲食菩萨肉者。是事不然。吾昔劝汝谁能先进。汝及文殊皆言不能当。吾尔时即以神力。以甘露味示彼饥兽。执意坚固得成无上正真等正觉。汝说权退在后。悉是有识教化。非无识教化。佛告弥勒。汝岂不忆古昔无数阿僧祇劫。去此西北六十二恒河沙刹。佛名平等。其刹名无形。如今现在说法。无有辟支佛声闻乘。无有日月时节劫数多少。彼佛教化尽一佛界。现界众生尽得成佛。更不移处他佛世界。云何弥勒。当名彼佛为过去未来现在耶。弥勒白佛言亦过去现在未来。何以故。皆从诸刹往至彼土。诸缘尽众生尽。得度脱故现有现在。佛告弥勒。汝今现在耶。对曰。不也世尊。名虽现在行不现在。前行过去后行未至。识念思惟三事成就。是故无现在。佛即问弥勒。心有所念几念几想几识耶。弥勒言。拍手弹指之顷。三十二亿百千念。念念成形。形形皆有识。识念极微细不可执持。佛之威神入彼微识皆令得度。此识教化非无识也。复次微识极微细过于微尘。此微尘识不可睹见。如来威神入彼教化皆令得度。弥勒当知未有狐疑。此微尘识亦受四气亦有四生。何以故。众生无边。边亦无边。如来亦无边。道亦无边。一切言有。有亦无有。无界无处无住。亦无教授化众生者。此名逆顺三昧。不住不不住一相无相。不着不缚亦无真际。修治道场净佛境界。权变无数非下劣所及。尔时世尊将欲解释弥勒狐疑。即现身色柔软色。无厌足色。内外清净无瑕秽色。吾从无数阿僧祇劫修眼清净。内外无阂今获色身。身亦无身色亦无色。知身空色空。身色俱空。知身色俱空者。此空空空。知无身空无色空。知无身无色俱空。知无身无色俱空者。此空空空。知过去身空。知过去色空。知过去身色俱空。知过去身色俱空者。此空空空。知未来身空。知未来色空。知未来身色俱空。知未来身色俱空者。此空空空。知现在身空。知现在色空。知现在身色俱空。知现在身色俱空者。此空空空。知过去无身空。知过去无色空。知过去无身无色俱空。知过去无身无色俱空者。此空空空。知未来无身空。知未来无色空。知未来无身无色俱空。知未来无身无色俱空者。此空空空。知现在无身空。知现在无色空。知现在无身无色俱空。知现在无身无色俱空者。此空空空。知欲界身空。知欲界色空。知欲界身色俱空。知欲界身色俱空者。此空空空。知色界身空。知色界色空。知色界身色俱空。知色界身色俱空者。此空空空。知无色界身空。知无色界色空。知无色界身色俱空。知无色界身色俱空者。此空空空。知欲界无身空。知欲界无色空。知欲界无身无色俱空。知欲界无身无色俱空者。此空空空。知色界无身空。知色界无色空。知色界无身无色俱空。知色界无身无色俱空者。此空空空。知无色界无身空。知无色界无色空。知无色界无身无色俱空。知无色界无身无色俱空者。此空空空。知缘缘身空。知缘缘色空。知缘缘身色俱空。知缘缘身色俱空者。此空空空。知缘缘无身空。知缘缘无色空。知缘缘无身无色俱空。知缘缘无身无色俱空者。此空空空。知胎生身空。知胎生色空。知胎生身色俱空。知胎生身色俱空者。此空空空。知胎生无身空。知胎生无色空。知胎生无身无色俱空。知胎生无身无色俱空者。此空空空。知化生身空。知化生色空。知化生身色俱空。知化生身色俱空者。此空空空。知化生无身空。知化生无色空。知化生无身无色俱空。知化生无身无色俱空者。此空空空。知湿生身空。知湿生色空。知湿生身色俱空。知湿生身色俱空者。此空空空。知湿生无身空。知湿生无色空。知湿生无身无色俱空。知湿生无身无色俱空者。此空空空。知卵生身空。知卵生色空。知卵生身色俱空。知卵生身色俱空者。此空空空。知卵生无身空。知卵生无色空。知卵生无身无色俱空。知卵生无身无色俱空者。此空空空。知未至禅身空。知未至禅色空。知未至禅身色俱空。知未至禅身色俱空者。此空空空。知未至禅无身空。知未至禅无色空。知未至禅无身无色俱空。知未至禅无身无色俱空者。此空空空。知初禅身空。知初禅色空。知初禅身色俱空。知初禅身色俱空者。此空空空。知初禅无身空。知初禅无色空。知初禅无身无色俱空。知初禅无身无色俱空者。此空空空。知中间禅身空。知中间禅色空。知中间禅身色俱空。知中间禅身色俱空者。此空空空。知中间禅无身空。知中间禅无色空。知中间禅无身无色俱空。知中间禅无身无色俱空者。此空空空。知二禅身空。知二禅色空。知二禅身色俱空。知二禅身色俱空者。此空空空。知二禅无身空。知二禅无色空。知二禅无身无色俱空。知二禅无身无色俱空者。此空空空。知三禅身空。知三禅色空。知三禅身色俱空。知三禅身色俱空者。此空空空。知三禅无身空。知三禅无色空。知三禅无身无色俱空。知三禅无身无色俱空者。此空空空。知四禅身空。知四禅色空。知四禅身色俱空。知四禅身色俱空者。此空空空。知四禅无身空。知四禅无色空。知四禅无身无色俱空。知四禅无身无色俱空者。此空空空。知空处身空。知空处色空。知空处身色俱空。知空处身色俱空者。此空空空。知空处无身空。知空处无色空。知空处无身无色俱空。知空处无身无色俱空者。此空空空。知识处身空。知识处色空。知识处身色俱空。知识处身色俱空者。此空空空。知识处无身空。知识处无色空。知识处无身无色俱空。知识处无身无色俱空者。此空空空。知不用处身空。知不用处色空。知不用处身色俱空。知不用处身色俱空者。此空空空。知不用处无身空。知不用处无色空。知不用处无身无色俱空。知不用处无身无色俱空者。此空空空。知非想非不想处身空。知非想非不想处色空。知非想非不想处身色俱空。知非想非不想处身色俱空者。此空空空。知非想非不想处无身空。知非想非不想处无色空。知非想非不想处无身无色俱空。知非想非不想处无身无色俱空者。此空空空。佛告弥勒。今当与汝说生义根义。谛听谛听善思念之。云何生义。生者七九是也。根者连着义也。如来无所著。已知未知无知。已知根者。过去当来现在。未知根者。结使障碍。无知根者。如来至真等正觉。过去当来现在诸佛。成就此根分别诸根。无根亦不无根。无说无义。分别字义空无所有。是根义也。从初发意乃至坐树王下。转无上法轮集诸法门。行无行法门。思议法门。总持根法门。虚空法藏法门。此是诸佛要集三昧。弥勒当知。汝复受记五十六亿七千万岁。于此树王下成无上等正觉。我以右胁生。汝弥勒从顶生。如我寿百岁。弥勒寿八万四千岁。我国土土。汝国土金。我国土苦。汝国土乐。尔时世尊即说颂曰

  如来十力尊　　虚空无边际
  忍慧福业力　　誓愿力最胜
  汝生快乐国　　不如我界苦
  汝说法甚易　　我说法甚难
  初说九十六　　二说九十四
  三说九十二　　我初说十二
  二说二十四　　三说三十六
  汝所三说人　　是吾先所化
  汝父梵摩净　　将八万四千
  非我先所化　　是汝所开度
  九十六亿人　　受我五戒者
  九十四亿人　　受持三归者
  九十二亿人　　一称南无佛
  初说千比丘　　二十四亿天
  三三十六亿　　所度诸众生
  汝乐我勤苦　　汝怠我清进

当佛说此偈时。苦行众生七十二亿。即于座上不动。得不起法忍

菩萨处胎经卷第二菩萨处胎经卷第三

        姚秦凉洲沙门竺佛念译

    想无想品第六

尔时世尊告弥勒菩萨。今此座中无有异类。纯一生补处。今当说识想受。无识无想无受。是时菩萨云何说识想受。于是菩萨分别说识想受。识非想非受。受非识非想。想非受非识。想非过去非未来非现在。受非过去非未来非现在。识非过去非未来非现在。非识非过去非未来非现在。非想非过去非未来非现在。非受非过去非未来非现在。云何识非过去未来现在。于是菩萨入无阂定。化受识众生。从有住地至无住地。此识非过去非未来非现在。复次菩萨摩诃萨。化想众生。从住地至无住地。菩萨化受众生。从住地至无住地。尔时尊者大迦叶即从坐起偏露右臂。右膝着地前白佛言。世尊。意心识受想。有何差别。佛告迦叶。知身即知差别。为众生故。从足至头支节各各别名。如树喻经说。根皮茎节枝叶故名为树。心意识受想亦复如是。大迦叶白佛言。想是外法受是内法。云何为一。佛告大迦叶。想从外来从内出也。迦叶白佛言。想从外来。何以故知。若外无形。内想何由得生。若外物不害。内何由知痛。佛告迦叶。此事不然。何以故。此识非外非内非两中间。识住处非识住处。外想外受。即是内法非外法也。菩萨摩诃萨信解甚深。内外中间法。乃能解了识所住处。此是众生此非众生。乃至有无法非此非彼。便入无碍独步三昧。迦叶白佛言。今闻说法增益狐疑。何以故。如佛所说。想亦是受。受亦是想。识法分别识亦是想。亦是受想。想自空受。受自空识。识自空想。空非识空。识空非受空。受空非想空。如树喻者是事不然。佛告迦叶。我当与汝说喻。智者以喻得解。往昔有王。王名特异。王有四子。一名喜悦。二名长寿。三名百岁。四名无畏。彼长寿子。不满月数即便命终。喜悦子者。身生疮痍见者恶贱。父母厌患常无欢心。百岁子者。不满百日复取命终。无畏子者。唇骞鼻嵃反齿横牙。人见恐畏。此亦如是想受识。无若干差别。佛告迦叶。吾今与汝说识想受一一分别。过去九十一劫有王名智慧。专行十善以法治化。无有烦恼察众生意行。知彼众生所念不同。即遣侍臣案行国界。诸有盲人尽仰来集宫庭。臣受王教。即出巡行国界。得五百盲人将诣庭内。王复以五百白象罗列殿前。一一令诸盲人自在捉象。是时盲人。或捉象鼻。或捉象耳。或捉象头。或捉象脚。或捉象腹。或捉象尾。王问诸盲人曰。象何所像类。盲人答白。捉鼻者言如角。捉头者言如瓮。捉耳者言如簸箕。捉腹者言如箪捉脚者言如柱。捉尾者言如橛。时傍观有目之士。笑彼盲者不得象具相。盲人屏处自共论说。各言已是而共诤竞。此众生类亦复如是。识想受法各各不同。佛告迦叶。犹如有人设百味食。粳米豆麦大小麻子。当其所得得粳米者。不知有余豆麦之属。迦叶此亦如是。识想受法各各不同。观诸法性无异无别。尔时世尊即与迦叶。而说颂曰

  见额知有头　　视烟知有火
  睹云知有雨　　观行知体性
  空 雨 无 两足 　　水影不可捉
  言议尽法师　　结使尽涅槃
  想尽在无想　　受灭亦无受
  识灭无有识　　梵行无上道
  吾从无数劫　　常为识所惑
  今世及后世　　不遇安乐处
  我今现在胎　　分别诸法相
  不见想受名　　况当有识法

尔时世尊说此偈时。五百比丘得不起法忍。有千众生心乐空行。于无余涅槃界心得自在

     菩萨处胎经 住不住品第七

尔时座中有菩萨名曰无住法行。即从坐起偏露右臂。右膝着地叉手前白佛言。善哉善哉。此诸大会快得善利。得闻如来无量法义。昔所誓愿今乃得闻。即于佛前以偈叹曰

  虚空无边界　　演出无量义
  有无不生灭　　惔怕无受想
  过去诸佛等　　修施戒忍辱
  入定心不乱　　慧光照世间
  其德不可量　　非有亦非无
  音响极清妙　　无等无俦匹
  一音报万亿　　由是得成佛
  法鼓声远闻　　声声各各别
  犹如转轮王　　念则雨七宝
  佛声极远振　　雨七觉意宝
  修治佛道场　　庄严道树果
  不住不不住　　慈悲护众生
  心念身相具　　不辞劫数难
  十方诸如来　　发印开法藏
  我等今得闻　　得住无为岸
  善哉如来力　　旷大无崖底
  解缚不处有　　真际实相法
  欲界烦恼世　　教化诸愚痴
  佛秘深藏义　　布现示众生
  疆界无边际　　皆得无上道

尔时无住菩萨说此偈赞佛已。前白佛言。过去当来现在五阴清净。不住不不住。乃至三十七品梵行不住不不住前后中间境界究竟净不净空。不住不不住。我不造非不造。非梵行非不梵行。唯愿世尊说住不住。佛告无住菩萨曰。色相不住不不住。受相不住不不住。想相不住不不住。行相不住不不住。识相不住不不住。内法清净不住不不住。外法清净不住不不住。内外法清净不住不不住。从初发意乃至道场。断除诸想净一切智。不住不不住。除众生垢清净不住不不住。庄严佛土清净不住不不住。入金刚三昧坚固其志。清净不住不不住。碎身舍利清净不住不不住。游戏百千三昧。清净不住不不住。不在凡夫地不入贤圣空清净不住不不住。不自称已我成道果。清净不住不不住。三十二大人之相。放大光明远照十方无量世界。一切众生寻光来至。得闻如来深奥之法。随彼所念上中下语。悉令充足分别诸法。住亦不住。不住亦不住。色受想行识。十二因缘。四无阂慧。空无想愿。四禅四无量慧。清净不住不不住。以神足力入于五道。清净不住不不住。入解脱门戒身定身慧身解脱身解脱知见身。清净不住不不住。佛告迦叶。今当说八清净甘露法味池。何等为八。如我今日坐自在讲堂。东视清净浴池周匝栏楯七宝所成。当于尔时亦不与众生说苦集灭道。饮此池水皆成道果。是谓菩萨神力所作。在南西北方亦复如是。我本成佛四方以右不从四维成佛。四维成佛者。示现成佛不实。何以故。从无数阿僧祇劫成就八味法。何谓为八。一为喜味。二为尽味。三为定味。四为到味。五为静味。六为相味。七为不动味。八为不究竟味。是为浴池八味。若菩萨摩诃萨饮此甘露浆者。不入地狱饿鬼畜生。成无上道。从初发心乃至道树。洗除心垢永尽无余。何者七觉意池八解脱水。初心解脱未至中间已至。已至中间住二地。尔乃得名菩萨。若复菩萨从八池水分别气味。此味非味。此道非道。耳不别声。鼻不别香。舌不别味。一一分别无所有。诸法聋故。是为菩萨摩诃萨净修清净行

     菩萨处胎经八种身品第八

佛告诸来会菩萨摩诃萨。学无学及四部众。比丘比丘尼优婆塞优婆夷。一切众生所可供养。或有众生。见地。薄地。净地。如来地。辟支佛地。不退转地。道场地。说法地。由此八地成无上等正觉。云何见地。菩萨发意趣向阿耨多罗三藐三菩提。复有菩萨摩诃萨。从初发意乃至坐道树。自伏其心欲降伏诸魔。即于坐上入三昧定。其三昧者。去嫉妒三昧。心胜三昧。秘藏三昧。除痴三昧。威神伏三昧。如诸佛世尊无言教三昧。示现变化三昧。是时弊魔波旬来扰佛者。非自己力所能来至。皆是如来威神之所感致。所以者何。欲现世法为劣第一义胜。何以故。如弊魔波旬起怒害心声响震地。佛以忍三昧不动不摇。使无央数弊魔众等。颠倒堕地。犹如蛄蟥蚁子及蝇不能得动。弊魔波旬亦复如是。若魔来者不能动我一毛。尔时世尊即以威神入三昧定。感动一佛境界满中弊魔。令此诸魔恶声流布。拘昙沙门。执心懦弱无丈夫意。在此大畏之处欲求佛道。佛告大众。弊魔波旬是我所作。彼魔心者。为是恶心为是善心。尔时有天子名曰拘毗。白佛言。佛降伏魔。非是魔力是佛神力。何以故。彼众生类不解俗法及以道法。以是欲化众生故降致魔来。其有众生见诸魔者。心不愿乐如千眼比。数千万众心立不退转地

复次菩萨摩诃萨。从忉利天生十方刹。不因湿生卵生化生胎生。教化众生。此菩萨等成就无记根。所化众生亦成无记根。何者是。阿閦佛境界是。或有菩萨摩诃萨。从忍世界生北方光影佛土。成就有记无记根。教化众生皆成就有记无记根。欲乐世界妙光佛土众生是也。或有菩萨摩诃萨。从初发意乃至成佛。执心一向无若干想无嗔无怒。愿乐欲生无量寿佛国。一切众生其生彼者。四部众比丘比丘尼优婆塞优婆夷。皆同一金色。西方去此阎浮提十二亿那由他。有懈慢界。国土快乐作倡伎乐。衣被服饰香花庄严七宝转关床。举目东视宝床随转。北视西视南视亦如是转。前后发意众生。欲生阿弥陀佛国者。皆染着懈慢国土。不能前进生阿弥陀佛国。亿千万众。时有一人能生阿弥陀佛国。何以故。皆由懈慢执心不牢固。斯等众生自不杀生。亦教他不杀。有此福报生无量寿国。或有菩萨摩诃萨。具足六度施戒忍精进禅定解脱智慧。生南方踊跃佛刹。去此阎浮提一亿佛国。彼众生等无有痴爱淫欲之想。何以故。皆从欲界断三十六种淫欲行灭。种性成就所行清净。如日光明无有尘翳。彼土众生行十三苦行。云何十三。昼夜三时不失时节。经行坐禅。或在树下。或在冢间。或在空地。或在岩石无人之处。或依泉源。或时一食。或不用食。法服齐整不失威仪。或时说法或不说法。周旋经行知足知满。所可说法。少欲真道多欲非道。息心定意解空无想不愿之法。是谓踊跃世界菩萨所行。彼土众生纯一乘学。无有罗汉辟支佛乘。相好具足称誉正法。解空无我。尔时世尊即说颂曰

  一切行已灭　　识为是外法
  生者都归尽　　涅槃最为乐
  归命踊跃佛　　法王最第一
  坐阎浮树下　　最初破欲网
  说法度人民　　供养诸福田
  树下坐思惟　　梵王来劝请
  愿尊从禅觉　　愍念愚惑人
  时大梵天王　　手执琉璃琴
  叹说佛功德　　柔软和雅音
  于亿百千劫　　时有发道心
  道心菩萨本　　亿劫时乃有
  愿速从禅起　　转无上法轮
  如优昙钵花　　时时乃一有
  佛出照世间　　除诸尘劳冥
  踊跃佛世界　　闻戒施清净
  不似能忍土　　刚强难可化
  思惟禅定道　　灭身不受证
  三转五碍法　　十二牵连缚
  道业三十二　　十六慈哀心
  古昔无量劫　　誓愿金刚志
  演放大光明　　遍照诸佛刹

尔时佛说偈已。告诸会者。东北方去此能忍世界五百恒河沙刹土。国名果熟。佛名花英如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。上语亦善中语亦善下语亦善。义味深邃等同梵行。彼土众生无有胎生化生湿生卵生。从莲花生。慈悲喜舍。百七难有神足定意。皆共修习三昧王三昧。所有三昧者。首楞严三昧。觉道三昧。威仪禁戒三昧。除众生苦本三昧。自照光明三昧。觉味众生三昧。如此等百七三昧。内观身外观身。内外观身。内法外法内外法。内定外定内外定。思惟分别观了无形无想无念。菩萨摩诃萨入解脱门。观一切法空寂无形。尔时世尊。即说偈曰

  虚空无边际　　音响说妙法
  果熟刹土人　　花英最胜尊
  不由四胞胎　　自然莲花生
  无我无彼想　　寿命不可量
  国土七宝成　　亦如阎浮提
  转轮七宝王　　象马玉女宝
  典藏四种兵　　摩尼金轮宝
  所至无挂碍　　彼界摩尼宝
  普照一佛刹　　彼无日月照
  星宿及火光　　分别四妙谛
  无常苦空道　　令彼众生类
  无生断灭想

尔时佛说偈已。告诸会者。西北方去此阎浮提七万恒河沙刹国。名宝琉璃佛。名慧成就如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。初语善。中语善。竟语善。彼土众生受性柔软。观道无常去离三患。无淫怒痴。无三恶道地狱饿鬼畜生。尔时世尊。与诸大众。而说偈曰

  诸入烦恼道　　及与四颠倒
  一切永除尽　　如空无形像
  寿命无央数　　无有中夭者
  行四无畏法　　成果不动摇
  其生彼土者　　行慈三昧报
  如我释迦文　　勇猛超劫数
  国财妻子施　　去想无所恋
  汝等诸佛子　　发愿得生彼
  亦无声闻法　　因缘各佛道
  于此百千劫　　勤苦修道德
  于此十六分　　未能获其一
  法性观诸法　　通达慧无碍
  尽灭吾我心　　即住无生地
  彼土诸众生　　建志坚固法
  破有不住有　　补处之所学
  汝等诸佛子　　晓了无所行
  舍禅入初禅　　始知众生苦
  中间九无碍　　禅相不可量
  众生心清净　　各各念不同
  已离五道渊　　佛日照三界
  善哉获大利　　感动诸天宫
  童真一切智　　开化而无倦
  众生得慈心　　恋慕无上道
  从无央数劫　　舍身复受身
  轮转生死中　　于缚得离缚
  四谛栴檀香　　木榓细捣香
  三昧智慧力　　破坏魔兵众
  过去一念结　　以何三昧断
  未来二念结　　何定何道除
  现在三念结　　除尽要有本
  过去一念结　　九万亿尘垢
  以空清净定　　得至空无岸
  未来无九结　　定意无想念
  寂然至佛道　　永处无所住
  现在三九结　　愿法无挂阂
  蠲除心意识　　渐住至无碍

佛说此偈已。告诸大众。西南方去此能忍世界三十二恒河沙。 刹 名无想。佛名一住如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。初善中善竟善义味深邃。分别五阴色受想行识六情六尘。修无常想系意在前。初法思惟坏破身惑。此身非有四蛇为家。此身如毒坏人禅道。是身如乌心无满足。是身如龙乐住深渊。佛道无为清净无瑕。如水莲花尘垢不染。日照天地蔽翳萤火。众山岳峙须弥为上。众星微光明月为最。如来出世法灯第一。尔时世尊。而说偈言

  断垢灭除想　　缚着心得离
  意念寂然定　　净行得具足
  一意一念中　　断灭结使迹
  除去永劫苦　　令尽无复生
  空寂无上道　　如有如不有
  彼我及诸识　　如梦影幻想
  菩萨积苦行　　劫数难可量
  欲说尽根本　　非一非二形
  若有智慧人　　口演无量义
  一义有亿句　　句句各各异
  虚空可填满　　其义不可尽
  吾昔从本来　　行六度无极
  布施除贪想　　禅定亦如是
  劫烧心不动　　不到余佛刹
  神力之所感　　住劫而教化

尔时世尊说此偈已。即以定意自庄严身。告众会者。东南方去此能忍世界三十三恒河沙。其刹名琉璃。佛名信解如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。初善中善竟善。分别四道吉祥之行。七生更三不复往来。即于现法般涅槃。断苦集灭取道成证。时有天子名曰眼净。在彼众中心怀狐疑。今我宁可问如来义。及我同类悉得开悟。尔时天子即从坐起。长跪叉手前白佛言。唯愿世尊。与我等说平等大乘淫怒痴业。何等过去未来现在痴冥众生。入解脱门。佛告眼净菩萨曰。善哉善哉。乃为一切开示眼目。汝今谛听谛听善思念之。吾当与汝一一分别。云何眼是色耶。答曰非也。又问非色耶。对曰非也。又问是色非色耶。对曰色无住处也。佛告眼净菩萨。如卿所说。是色非色色非色。无住处者。云何立字名曰色。眼净菩萨白佛言。色性久败。现灭不住过去不现。此世后世永尽无余。故曰无余涅槃。佛告眼净。此识从本已来为从何生。今日四众灭三世垢去至何处。眼净白佛言。本从空来今还于空。佛言。前空后空复有何异也。对曰无也。当知诸法实相。前不可穷后不可尽。佛告眼净菩萨。吾从无数阿僧祇劫积行福业。普念一切沉溺众生。悲念哀苦欲令度脱。所以者何。吾今处胎所欲灭者。都已灭尽。果愿成报今日已获。彼土众生。不以成佛不成佛以此为累。所以者何。彼土众生建意勇猛。不处有胎不处无胎不处化生。功德成就非觉非不觉。何者是觉。云何非觉。一切众生愚痴者。我悉觉之是觉。一切学人断结使者。是非觉。尔时世尊。即说偈言

  觉佛出世间　　远放大光明
  苦集灭结使　　独立无敢近
  正使地振动　　三界犹若尘
  执心入定意　　众相各不异
  如来至真念　　除想不入定
  还入众生中　　因造更造缘
  精进勇慧智　　化导愚痴人
  导引众生类　　可度不度者

    菩萨处胎经全身舍利品第九

尔时世尊告诸来会者。念我古昔所行功德。舍身受身非一非二。今当为汝说一形法。云何名一形法。此大地种。厚八十四万亿里。乃有利风。厚八十四万亿里。风下有水。厚八十四万亿里。水下有火。厚八十四万亿里。火下有沙。厚八十四万亿里。沙下有金钢刹。厚八十四万亿里。诸佛全身舍利。尽在彼金钢刹中。金刚刹复厚八十四万亿里。下有诸佛碎身舍利。尽在彼刹。彼有佛刹名曰妙音( 丹本香 )佛名不住如来十号具足。今现在说法。初善中善竟善。净修梵行国土成就彼佛舍利极小微细。能现佛身弟子眷属周旋授化。如我今日处胎说法。彼诸众生不见我。我此众生不见彼。破有至无永寂寞性住无疑处。是谓一舍利之所感也。佛复告诸来会者。碎身舍利下。厚八十四万亿里。国土名清净。佛名遍光十号具足。彼佛今现在说法。初中竟善净修梵行。彼佛光明色色各异。一一光明皆成就佛。一一诸佛尽说六度无极。何谓六度。布施持戒忍辱精进禅定智慧。善权方便降伏心识。不生愚痴无淫无欲。晓了观法如月除云。复自观身彼我无异。心得空定皆悉成就。端坐道场称扬正法无怯弱心。去此下方光明佛刹。八十四万亿里。有土名曰施无尽藏。佛 号观 ( 丹乡劝 )助如来十号具足。今现在说法初中竟善。常修梵行所施惠物。有人执持便得道果。是谓如来一未曾有施。无尽世界下有法鼓世界。厚八十四万亿里。佛名善见十号具足。今现在说法。彼土众生。尽同一姓一字无若干名。闻法则解不重思惟。彼土乃有全身舍利。过去亿千万佛皆留舍利。彼土舍利。我亦有分非一非二。彼佛舍利不住一处非不住。周旋往来恒河沙刹土。光相具足随众生化无懈怠者。三十一亿结使断灭。妄想缠连二万二千。十八持胜不共之法。示现教化受无畏证。尔时世尊。即说偈言

  吾从无数劫　　往来生死道
  舍身复受身　　不离胞胎生
  计我所经历　　记一不说余
  纯作白狗形　　积骨亿须弥
  以针刺地种　　无不值我体
  何况余色狗　　其数不可量
  吾故摄其心　　不令道放逸
  如人立须弥　　执不死药执
  下人以瓶承　　注药不遗落
  中间诸艰难　　随岚风所吹
  凡夫身如尘　　唯除入住人
  此二持瓶人　　何者为最妙
  下人执心正　　恒恐东西波
  受药不失义　　故名神足道
  上有大慈心　　一说不寻究
  意识各各异　　成道亦如是
  我此苦忍界　　成佛由下人
  积行阿僧祇　　乃能成佛道
  从刹至一刹　　如是数千亿
  如针投于海　　舒手便得之
  无慧抒水求　　积劫不能得
  世间愚惑人　　不别善恶行
  须弥四宝山　　谓为灰堆聚
  金翅飞鸟王　　谓呼蚊蚋是
  夏热牛迹虫　　不睹海广大
  日光实野马　　愚者谓火焰
  彼法非我造　　愚惑行自成
  出入识无间　　炼精道术成

尔时世尊即说咒曰

伊祢魔祢　茶譬茶离譬　淳同　翅离翅

尔时毗沙门大天王。即从坐起头面礼佛足。我当拥护行法善人善男子善女人。拥护其身三光三影何等为三光三影。如我今日领罗刹众。身影。身身影。影影。何等为身影。何等为身身影。何等为影影。尔时世尊。即以偈说曰

  身为四大聚　　地水火风成
  来往周旋处　　住亦不见住
  身及身身者　　周生年蜕身
  影影三句义　　如佛留神光
  白[疊*毛]裹魔只　　香去处故香
  诸佛此要法　　清净无瑕秽
  身身影教化　　度不得度脱
  或见身相法　　入定身身念
  影影无狐疑　　悉成无上道

尔时提头赖吒。欲得拥护诸法师。即说咒曰

伊醯　魔醯　阎浮　阎岚浮突突勒翅

我当拥护法师。亿千百万由旬内。令无娆乱者。毗楼勒叉天王。即从坐起前白佛言。我亦拥护真实法师。即说咒曰

伽梨　伽罗梨　尼稚　究槃稚

令亿百万由旬内无有触娆者。毗楼搏叉天王。即从坐起头面礼足前白佛言。世尊。我当拥护真实法师。即说咒曰

舍弥　舍弥　钵婆大磨楼醯

令百亿由旬内无有触娆者。尔时世尊。即说偈曰

  花香色极妙　　感动诸佛国
  佛从无想念　　成佛一向道
  忍力无疆界　　破有无二乘
  全身舍利相　　及与微细尘
  拯济恒沙等　　不堕三恶趣
  佛出勤苦劫　　覆护行大慈
  众生无边际　　令成无上道

尔时座中三十二亿众生。即发无上平等道意

    菩萨处胎经常无常品第十

尔时座中有菩萨。名曰观见无常。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。善哉善哉。世尊。快说斯义。诸佛正法不可思议。非罗汉辟支佛所能及。本无真性不可穷尽。如来降形出一入一变化无方。或碎身舍利。或全身舍利。或隐没不现。或流布世间。或现一佛境界。或现若干诸佛境界。神足变化道力自在。甚奇甚特如虚空界。常亦无常。无常亦无常。住亦无住。无住亦无住。变易非一。愿从如来闻说常无常义。如我今日在于九地。为是常耶。为是无常耶。尔时世尊。告常无常菩萨曰。我今问汝。汝当以真性报我。云何族姓子。色为常耶。对曰非也。世尊。色无常耶。对曰非也。色常无常耶。对曰非也。色非常非无常耶。对曰非也。云何族姓子。色有余耶。对曰非也。色无余耶。对曰非也。色有余无余耶。对曰非也。 色非有余非无余耶。对曰非也 。佛告族姓子。受想行识常耶。对曰非也。受想行识无常耶。对曰非也。受想行识常无常耶。对曰非也。受想行识非常非无常耶。对曰非也。受想行识有余耶。对曰非也。受想行识无余耶。对曰非也。受想行识有余无余耶对曰非也。受想行识非有余非无余耶。对曰非也。佛问常无常菩萨曰。涅槃净耶。对曰非也。涅槃不净耶。对曰非也。涅槃净不净耶。对曰非也。佛告常无常菩萨曰。涅槃实性正何所立。对曰立无所立。又问。非有众生非无众生耶。对曰非也。缘未断从五聚性。乃至三十七品。空无想无愿。缘未断无离无不离。无生无不生。故曰立无所立。何以故。性自然空。此空彼空内空外空涅槃空。如来出现于五浊世。不见有生灭着断。不见有定有乱。不见持戒犯戒。不见有忍有嗔。不见精进懈怠。不见有烦恼定意。不见有愚痴智慧。不见有意识思想。不见是道是俗波罗蜜。不见佛土清净。不见净修道场。不见有断垢众生。是谓菩萨立无所立。尔时世尊。即说偈曰

  梵行心清净　　破坏魔境界
  忍力无上道　　寂定不思议
  吾从无数劫　　常处立无立
  一向入空慧　　众想庄严身
  当来族姓子　　及诸现在者
  悉当立无立　　解常无常性
  尘垢诸障碍　　坏我善业行
  蠲除尘垢尽　　如金无瑕秽
  慧为世间将　　示道开无目
  乃令愚惑人　　深解真如法
  无为因缘道　　开进六神通
  无尽大法藏　　给施下劣人
  贪爱三解脱　　三世无所著
  现在一切法　　垢尽入佛定
  如来大慧光　　断除狐疑法
  痴相澄然净　　解空无常道
  一切计常人　　贪着在生死
  不离有为法　　烦恼所系着
  六度三慧法　　珍宝及妻子
  割爱无所惜　　出家道得成
  人有善恶念　　初中下品等
  轮转五道中　　生灭无真性
  苦本无央数　　生生不休息
  法鼓振大千　　动彼魔境界
  汝等群生类　　依凭六神通
  心念身则随　　所至无挂碍
  岁月修行道　　昼夜不失时
  积德如须弥　　成就佛果证
  生灭如幻化　　亦如镜影像
  受入三十六　　入定乃成道
  如来真实法　　无染无所著
  行慈起七度　　众宝自璎珞
  三十二亿结　　缚着难可解
  要以智慧剑　　割除无所有
  复以八解脱　　甘露法味浆
  令彼渴爱者　　充满无思想
  昔我未行禅　　恒处愚痴聚
  连着四颠倒　　求解难可获
  游四无碍禅　　自在无怯弱
  定意心坚固　　尽生受不受

尔时世尊说此偈已。八十四亿众生。发无上正真道意。立信行不复退转

菩萨处胎经卷第三菩萨处胎经卷第四

        姚秦凉州沙门竺佛念译

    随喜品第十一尔时会中有菩萨名曰顶王。将二万五千人。从东方安住世界来。至佛所头面礼足在一面坐。须臾退坐前白佛言。吾闻如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。无量神变在胎教化。七宝宫殿众宝成就。诸佛世尊宗奉恭敬。过去诸佛世尊及当来现在。未曾说此难有之法。真际法相不可穷尽。从无数劫积行勤苦。于其中

间有生有灭。愿乐欲闻如来神德所化多少国土差别。众行平等入无为道。八解童真清净梵行。使我等永无犹豫。佛言。善哉善哉。顶王大士。汝所问者甚深难量。多所利益济度愚惑。福不可尽。尔时世尊。即以三昧禅定之力。舒金体臂 下 方 过二十二亿佛刹。抄举式弃如来七宝神塔。纵广一万八千由旬。外郭绕塔七宝栏楯。池水园果皆七宝成。后园浴池金银梯梐。彼池水中。自然八味甘露水边凫雁鸳鸯奇类众鸟数千百种。鸟声悲鸣共相娱乐极乐难胜。尔时世尊即与顶王菩萨。而说偈曰

  过去式弃佛　　神塔七宝成
  花树若干色　　金花银为茎
  浴池水八味　　充饱饿渴者
  供福获果报　　在胎功德成
  次复佛灭度　　随式本元尊
  彼佛七宝塔　　遍满恒沙刹
  众宝相杂厕　　快乐亦难胜
  次佛取灭度　　最尊第一胜
  亦有七宝塔　　遍满虚空界
  明眼有识人　　恭奉心恭敬
  除慢不贡高　　不贪着利养
  七宝池水果　　想断无所著
  亦现处胎化　　流布无数劫
  次佛般涅槃　　拘那含牟尼
  神德大通达　　所度倍三佛
  教化诸弟子　　三乘不断绝
  去此东方刹　　在胎现变化
  劝恤后来者　　将导入闲静
  次佛 迦叶 尊　　端坐亿百劫
  诸天为眷属　　寂静不移动
  亦有七宝塔　　在金刚佛刹
  救护诸堕落　　不使堕邪道
  我今释迦文　　勇猛独特出
  一向执意志　　不着生死道
  佛土虽弊恶　　所度不可量
  今处母胞胎　　神变自娱乐
  欲界众生等　　堕落入镬汤
  将导引令出　　如蛾投火焰

尔时世尊即以神力。变此三千大千世界晃然金色。使令众会见乐世界。彼诸菩萨皆坐七宝莲花上。弟子眷属斯皆金色。所啖饮食禅定解脱。戒律威仪未常违失。云何顶王菩萨。向所现国刹土佛所游化。供养承事其福宁多不耶。顶王菩萨白佛言。甚多甚多。世尊。何以故。供养一佛刹其福难量。况尔所佛刹。佛言。若有菩萨过不退转在一生补处。令在胎中现神变化。敬此菩萨者。其德最胜。何以故。此菩萨者即行佛事不可思议。佛复告顶王菩萨。吾今与汝说八正道去八颠倒。满十方恒沙诸佛刹土。满中七宝塔。不如此供养八正道菩萨。衣被饮食床敷卧具病瘦医药。捣香杂香栴檀末香。缯彩花盖便身之具。其福最多。若有菩萨摩诃萨。能于胎化湿卵。分别四意止。一日二日乃至七日。一月二月乃至七月。一岁二岁乃至七岁。一劫二劫乃至七劫。若有众生。承事供养前七宝塔。乃至八正道菩萨。不如此人供养四意止菩萨。其福最多。若一生补处菩萨。在母胎中转无上法轮。包容一切变易无数神德大士。周旋往来无有障碍。还合为一无觉知者。若有众生供养承事便身之具无所爱惜。如我今日从三阿僧祇劫断除灭想。今最后身一入胎舍教化。果证神通悉令得解脱。犹如果熟变易不住。佛身空无戒定慧解。而自香熏道德威仪不失十二头陀之行。此一分苦是我境界。尔时顶王菩萨即从如来前。而赞颂曰

  识是生死本　　亦为涅槃径
  中息在胞胎　　游戏无量界
  四生成佛土　　十六神足降
  本无一相道　　誓愿各各同
  以众生缚着　　现有优劣人
  无形不可见　　今乃得观察
  过去诸佛身　　遗教无边际
  八道无上法　　一向度群萌
  经法舍利形　　神通流布世
  今我所将从　　得闻不思议
  六佛神宝塔　　宝藏七宝台
  一一深分别　　义味不可量
  佛本所行道　　如空无所著
  今处神母胎　　受化非一类
  得佛真如性　　亦如实相住
  除去憍慢心　　今礼空无性
  一一舍利光　　遍照诸佛刹
  受化如恒沙　　是佛神德感
  刹土去此远　　受佛甘露道
  今欲还本国　　宣扬如来法

尔时顶王菩萨。说此偈赞佛已。右绕三匝礼佛而去

    菩萨处胎经五道寻识品第十二

尔时世尊。将欲示现识所趣。向道识俗识。有为识无为识。有漏识无漏识。花识果识。报识无报识。天龙识。鬼神阿修罗迦留罗紧那罗摩睺罗伽。人非人识。上至二十八天识。下至无救狱识。尔时世尊。即于胎中现钩锁胎骨。遍满三千大千世界。佛告阿私陀。汝能别此骸骨识耶。对曰不别。何以故。未得通彻行力未至。佛告弥勒菩萨。汝此天中。未得神通耶。弥勒白佛言。有成就者。有不成就者。佛告弥勒。汝观钩锁骸骨。令一切众生知识所趣。分别决了令无疑滞。尔时弥勒菩萨即从坐起。手执金钢七宝神杖。敲钩锁骸骨听彼骨声。即白佛言。此人命终嗔恚结多。识堕龙中。次复敲骨。此人前身十迹行具。得生天上。次复敲骨。此人前身破戒犯律。生地狱中。如是敲骨。有漏无漏有为无为。上从二十八天。下至无救地狱。知识所趣善恶果报白黑行报。有一全身舍利无有缺减。尔时弥勒以杖敲之。推寻此识了不知识处。如是三敲。前白佛言。此人神识了不可知。将非如来入涅槃耶。佛告弥勒。汝绍佛位于当来世。当得作佛成无上道。何以敲舍利。而不知识处耶。弥勒白佛言。佛不思议不可限量。非我等境界所能筹量。今有狐疑。唯愿世尊。当解说之。五道神识。尽能得知彼善恶所趣。不敢有疑。于如来所今此舍利无有缺减。愿说此识令我等知。佛告弥勒。过去未来现在诸佛舍利流布。非汝等境界所能分别。何以故。此舍利即是吾舍利。何能寻究如来神识。今当与汝分别如来上中下识。至萨芸然各各不同。初住菩萨未立根德力虽得神通。二住菩萨以天眼观知识所趣退不退地。亦复观见欲界色界无色界者。或复观见生东方无数恒河沙佛刹。供养诸佛奉律无碍。亦复知彼受记劫数。一劫乃至百千亿劫。或有菩萨于三住地。观见舍利知识所趣于余涅槃无余涅槃。然复不见四住所行识所趣向。四住菩萨见一见二三住识法。然复不见五住舍利识法所趣。佛告弥勒。五地菩萨分别下品。于六住分或见或不见识法所趣。不退转菩萨上至一生补处。不见如来上足下足心识所向。次第菩萨见八七六。然复不见一生补处举足下足。况欲敲钩锁骸骨欲分别之。此事不然。佛告弥勒。汝当知之。十号如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。唯佛知佛神识所念。尔时世尊与诸大众。而说颂曰

  周旋五道渊　　唐劳其识神
  耳鼻身心垢　　不能自去离
  识想结重垢　　刬以智慧刀
  慧能照愚冥　　得至无畏场
  佛识悉遍见　　舍利钩锁骨
  正使碎如尘　　微细不可见
  如来一一别　　报应善恶法
  佛识甚微妙　　非为非不为
  一说度万亿　　阿僧祇众生
  弥勒复成佛　　亦当舍舍利
  于本所生母　　胎法亦如今

尔时弥勒菩萨闻佛所说。绕佛七匝头面礼足。还就本位

    菩萨处胎经诸佛行齐无差别品第十三

尔时世尊即复示现奇特像。变一切菩萨尽作佛身光相具足。皆共异口同音说法。分别无常生生归尽。其德难量互相敬奉。威仪礼节虽说妙法。无有揖让屈伸低仰。各坐七宝极妙高座罗縠帐幔。初一说法度于无数纯男无女。第二说法纯女无男。第三说法纯度正见人。第四说法纯度邪见人。第五说法男女正等。第六说法邪正亦等。当尔之时法法成就。而无吾我道果成熟。诸佛常法法说议说。神足第三。八万四千空行法门。八万四千无想法门。八万四千无愿法门。一一法门有无量义。犹如黠慧之人。身有千头。头有千舌。舌有千义。欲得究尽三法门义。于百千分未获其一。此是诸佛秘要之藏。皆由前身宿学成就。尔时诸佛异口同音。说偈颂曰

  我等本所愿　　今者已果成
  金体柔软响　　众相悉具足
  欲求无极慧　　毕竟无有疑
  善哉三界尊　　最胜无能过
  吾昔兜术天　　选择受生处
  来降入母胎　　集诸如来等
  外无缘众生　　谓吾不成道
  因胎化众生　　倍于成佛时
  前后所说经　　八十四亿象
  象力及人力　　荷载不能胜
  令我欢喜子　　强记不漏失
  遗法不成道　　流布胎正法
  佛行无差别　　平等无若干
  唯佛能知佛　　功德多少义
  欲得思议佛　　所行奇特事
  从劫无数劫　　不能得毫分

尔时诸佛说此颂已。初一说法纯男无女者。即于座上立不退转。信心不可沮坏。尔时释迦牟尼。还摄威神如前无异。即说颂曰

  八正道果证　　无师自然悟
  独步三界将　　自得涅槃道
  本无一相法　　捷疾辩才义
  我今已果获　　无爱无所染
  五阴法性本　　不见有善恶
  神力拔济苦　　坦然寂灭道
  汝等诸会者　　所愿已成办
  未得今已得　　快哉此利业
  因缘缚着碍　　永除无处所
  吾我罗网法　　自然得毁坏
  愚惑不见真　　自堕四色缘
  未得密谛观　　分别苦相本
  如我今成道　　功夫不足言
  后佛师子吼　　炽焰恶剑劫
  陶冶苦众生　　随色染其素
  忍辱受其害　　对至终不报
  执心如虚空　　变易不久住
  当于尔时世　　五逆苦恼罪
  难化不可度　　诸佛所不救
  寻为现缘本　　将示无为处
  破彼刚强心　　专一得解脱
  初说一法教　　无生无起灭
  皆趣向佛道　　不令有遗落

尔时世尊说此颂已。男众女众正众邪众。皆得尽信得不退转地。佛复告菩萨摩诃萨。汝等。欲见如来神力化不思议道。法性纯熟无男无女。善权义说受女人身无佛记别。魔释梵王无真实相。汝等。欲知此四众者受别成佛乎。尔时有菩萨名曰无尽意。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。未曾闻如来说法。此四种人得成佛者。今日乃能开演大义。即重白佛。舍身受身即身成佛耶。佛告无尽意。谛听善思念之。今当与汝一一分别过去九十一劫有梵天王。名大辩才。分别古今常乐闲居坐天宫内。今我宁可化此宫女及诸梵天。我得成佛诸天翼从。剃须发着法服。一时成道不亦快乎。作是念已。即于天宫诣昼度树。端坐思惟一意一心。系念在前无他异想。即得成佛三十二大人相八十种随形好。诸天眷属修行比丘正法。得阿罗汉皆是利根。彼天女众有得须陀洹斯陀含阿那含不往还此间。即于彼般涅槃。是谓梵天王不舍身受身现身得成佛道。佛告无尽意菩萨。过去七十六劫有第六天王。典领三千大千世界。名曰害恶。从六天以下自在无阂。在彼天宫经历无数久久思惟。悔本所作谤毁三尊遮截道果。设我受报坠堕三涂不离恶道。我今宁可改心恶行。并此天宫诸天眷属。共修梵行求无上道。进前成佛不亦乐乎。复自思惟。所典境界无量无限天女娱乐乐岂过是。设我成佛与此国界正等无异。渐渐懈慢。复更劫数魔有知识。行登十住说佛功德。出家修道众相具足。魔心开解改心入定。无若干想利根捷疾。即于天宫三明通达。庄严佛土不更受身。便成无上至真等正觉。放大光明普照魔界。莫不眼见见魔成佛。有三亿天子心自生念。谓魔幻化非真实佛。尽退还宫。十六亿天子皆来影附。承事供养如佛无异。寻于坐上皆成四果。是为害恶大天王。不舍身受身而成佛道。佛复告无尽意菩萨。过去六十一劫东方有释天子。修天眼净心乐禅定。常欲求出家进向佛道。彼诸天法有衰瑞应不久命终。诸天翼从转转减少。贪着睡眠身体尘垢。花自萎枯。不乐宝座。所食不甘。即出到后园中沐浴澡洗。今我天身眼能彻视。何方有佛当往礼省恭奉供养受佛禁戒。即以此身得成佛道。作是念已端坐思惟。以天眼视上方有佛。名无量空行。世界名清净。今现在说法初中竟善。即以神力如人屈伸臂顷。到彼佛所头面礼足在一面立。即以此偈赞叹佛德

  光相照十方　　降伏众魔怨
  为说道径路　　断疑永无惑
  梵行清净人　　皆蒙最胜行
  随类说真法　　不违本行法
  我为诸天主　　欲修清净道
  唯佛垂愍念　　得至安隐处

尔时世尊即告释曰。善哉善哉。发心广大欲得拔济众生之苦。未得者得。未获者获。未成者欲令成就。欲令盲者见明。聋者闻声。偻者得申。无手足者令得手足。汝还本宫坐道树下。分别众行聚法散法。释闻语已即前礼佛。于彼不见还至天宫。诸天眷属皆来归附功德转盛。衰耗之相永灭无余。端坐摄身心意不动。得成无上至真等正觉。所将天女九十三亿成四道果证。是谓天帝释不舍身受身而成佛道。佛告无尽意菩萨。过去五十四亿恒河沙劫。有世界名曰火焰。佛名无欲如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。说法度人善修梵行。四审谛法施惠一切。彼土人民悉受女身。解了无常苦空非身。分别受入无诸烦恼厌患身苦。齐同一愿发大弘誓。着无畏铠欲度众生。净佛国土蠲除秽恶。立志坚固乐不退转。时有七十万二千亿女。在大旷野非人行处。齐同一行解空无相无愿之法。一日一时三等通达。即成佛道众相具足。存亡自在以小受大以大入小。即于彼日度阿僧祇无量众生。于无余涅槃化度众生。是谓不舍身受身而成佛道。尔时世尊欲重宣此义。而说颂曰

  法性如大海　　不记有是非
  凡夫贤圣人　　平等无高下
  唯在心垢灭　　取证如反掌
  道成王三界　　阐扬师子吼
  分别本无法　　无有男女行
  今在五浊世　　现有受身分
  断灭计常者　　障阂经劫数

尔时世尊说此偈时。八万四千亿众生立志坚固。皆愿成佛不经后身

    菩萨处胎经行定不定品第十四

尔时座中有菩萨。名曰常笑。六通玄鉴德力自在辩才无畏。尽生死分四无所著所说信用。解诸法空。如化如梦如热时焰。如赤叶在水。愚兽谓肉水尽不获。如山中响。解了诸法不起不灭。欲断一切众生狐疑。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。唯然世尊。有少疑滞。若见听者乃敢宣白。如来大圣神智无碍。前知过去因缘系缚众行集聚。后明未来成败所趣因缘合散。善恶行业发心不同。今闻如来胎化众生行有差别。有对无对有报无报。有黑白行无黑白行。复有众生。从初发意经历劫数不得成就。或有众生朝发道心即得成佛。愿乐欲闻唯世尊说。尔时世尊告常笑菩萨。汝所问义。皆是如来威神所感。欲成就诸法。不断前后如来实性。何以故。如来法性不可获持。亦非罗汉辟支佛所知。尔时世尊。即以神力出广长舌。舌相光明照东方无极阿僧祇佛刹土。使五道众生见光明者。寻光来至到如来所。尔时世尊。复以眉间出白毫相光明。上照八十四亿恒河沙刹土众生。至如来所。尔时世尊即告常笑菩萨。而说颂曰

  三十一音响　　业报有清白
  四十八尘垢　　天行五十五
  菩萨七宝发　　发起众生心
  四种道果树　　心识定不乱
  鲜智无福人　　口业获报多
  于食知止足　　行步威仪法
  等心愍一切　　乃称菩萨道
  三有五浊世　　颠倒着魔界
  破坏善业根　　如影不相离
  根性有利钝　　进退念不定
  发愿度众生　　功德充足满
  十力成就身　　世俗有为法
  思惟难可量　　一灭一复生
  如火焚山林　　心念然炽法
  广及阿僧祇　　身被僧那铠
  勇猛伏难化　　人身诸毛孔
  六十有四万　　慧能辩分别
  诸毛行报业　　阎浮提利人
  受形极丑陋　　孔孔毛毛生
  疏漏不密致　　如来金刚身
  孔毛三十七　　密致不疏漏
  不为火所烧　　魔及魔天等
  沙门婆罗门　　梵天及释众
  神力鬼神等　　欲断佛毛发
  此事终不能　　虚空为地界
  日月可堕落　　欲断佛毛发
  此事终不然　　此是俗法业
  非是无为相　　受行报业果
  众相各不同　　佛身金刚体
  外相业报行　　亦是世俗报
  去离无为远　　佛相真实法
  终不露现外　　欲知佛内相
  神足感动是

尔时世尊说此颂已。告常笑菩萨。缘报缘缘报。至道无碍报。三宝真性报。行趣涅槃报。世俗无著报。一向究竟报。是谓菩萨摩诃萨最第一义。无染无著不可获持。不着欲界亦不离欲界。过有当有现有。非过有非当有非现有报。无生无灭。菩萨摩诃萨从百千劫通达不障碍。令等分众生解空本报。口业成就音响通达。或有菩萨摩诃萨一时之顷。能令三千大千刹土即为水界。犹如得禅比丘观无量水界。水性之虫鼋鮀龟鳖无所触娆。积劫功勋不败不朽。是谓菩萨摩诃萨入水界三昧。或有众生见菩萨入定谓为是水。或持瓦石草木投水入定菩萨心如虚空。不觉有触娆者。是谓菩萨摩诃萨入水界之力。或有菩萨摩诃萨禅定摄意入火界三昧。令此三千大千刹土烔然为火。愚惑众生谓为菩萨遭火劫烧。奔驰四方不离火光清净无热。是谓菩萨摩诃萨入火光三昧。三昧威神难可测度。亦非罗汉辟支佛所能寻究。复有菩萨摩诃萨入五分法身难动定意。亦使三千大千刹土。蜎飞蠕动之类下至蚁虫。以威神接不遭烦恼七日安隐。后寿终时皆生天上。如我今日在在说法处处现化。其有睹见如来神德。诸尘垢尽随愿所生。或生他方诸佛刹土。是为菩萨摩诃萨五分法身定意所感。复次菩萨摩诃萨入不动师子奋迅三昧。能令三千大千刹土六反震动。其中众生咸悉归。修清净行。披惭愧衣除去憍慢。引致众生至八正道。去吾我想七十七心。尘累染垢一时除尽是谓菩萨摩诃萨奋迅无畏之所感动。复次菩萨摩诃萨入散身定意。分别识聚为从何来去至何所。一一分别空无寂然。前后中间无有端绪。是谓菩萨摩诃萨入散身定意之所感动。复次菩萨摩诃萨入忍顶三昧。能令此身作无手脚虫遍满三千大千刹土。众生见者不能名字。谓为肉聚。其取食者味若甘露。悉能充饱众生饥渴。是谓菩萨摩诃萨入忍顶三昧之所感动。或有菩萨摩诃萨以三昧力。令此三千大千刹土山河石壁。化为甘露状如石蜜食无厌足。令彼众生四使重病永除无余。众生发愿愿乐欲生无尽世界。是谓菩萨摩诃萨神力之所感动。复次菩萨摩诃萨入独步三昧。使此三千大千世界一切众生。见菩萨行举足下足。其遇菩萨见行步者。能制罪人不入地狱饿鬼畜生。皆由菩萨身口意净。发愿济度要至究竟终不退还。是谓菩萨摩诃萨无量善福心愿所感。复次菩萨摩诃萨以神通定入乐法三昧。令此三千大千世界诸众生类。皆来归趣到菩萨所求请出家。修无上梵行发意齐同。剃除须发被着法服。如诸佛常法威仪禁戒教授法。则能一时在明慧地。明慧地者。八住菩萨之所行法。非是二乘所能修习。是谓菩萨摩诃萨神力所感。复次菩萨摩诃萨以佛大慈入无碍定。令此三千大千刹土群萌之类。与作父母兄弟朋友种族知识。无财与财给施所须。乃至国财妻子象马。金银珍宝车磲玛瑙白珠琥珀水精琉璃碧石杂珍。衣被饮食床褥卧具病瘦医药。香花芬熏皆令充足。于中教化各令满足。发起众生在乐法之地。云何乐法之地。导引彼众应须陀洹道。与说真要断三见法。应斯陀含者。与说七生久久成道。应阿那含者。与说善法无五阴覆蔽。应阿罗汉者。与说涅槃受证无疑。应菩萨道者。与说六度顶忍之法发意进趣。向佛道者。与说究竟净一切智。修治佛土教化众生。从一佛国至一佛国。供养礼事诸佛世尊得六神通。眼能彻视耳能彻听。自识宿命知他人心。身能飞行诸尘垢尽。不复狐疑于佛法众。是谓菩萨摩诃萨入乐法三昧神力所感。复次菩萨摩诃萨入金刚三昧。能令三千大千刹土。变为七宝赒穷济乏。求浆与浆求食与食。即便与说悭贪之果。夫人贪着死入恶道饿鬼畜生。贫穷裸跣衣不盖形为人所憎。或为奴婢为人走使。或堕畜生荷负重担。或时菩萨为说生天不淫之行。淫为秽恶死入恶道。刀山剑树火车炉炭。铁嘴地狱。黑绳地狱。沸屎地狱。冰山碓臼受苦无量。或入莲花优钵狱中。风吹火炙骨节分离。菩萨于中与说无常。身非久居琢石见火。雷电过日幻化非一。何为受苦精神腐烂求出无期。如是菩萨为说真要。令受罪人尽得拔苦至无苦地。是谓菩萨摩诃萨以佛大慈三昧定意之所感动。尔时世尊即说颂曰

  众生欲出离　　三界五道阂
  精进不懈怠　　安住无为道
  如人起屋舍　　非材木得成
  要先修治地　　次立墙壁柱
  佛道如大空　　不由一行成
  执志要坚固　　放心无恋慕
  过佛如恒沙　　来者不可尽
  或有次第成　　亦有超越者
  我今悟未悟　　令至八正道
  闻辄不再受　　此法由谁造
  昔吾舍身想　　劫数不以难
  无师而自觉　　得为一切导
  导师出现世　　非缘不降神
  要度未度者　　示现无为城

尔时世尊说此颂时。五十六亿恒河沙众生 妄 断想尽。不复愿乐在俗家业。 同 时发愿求无上道

菩萨处胎经卷第四菩萨处胎经 卷第五

        姚秦凉州沙门竺佛念译

    入六道众生品第十五

尔时世尊入无量遍观定意。观察众会心怀犹豫。将欲决疑现以真实。即出右脚指蹈此地界。使六趣众生各各显行罗列跱立。尔时世尊告众会者。汝等见此六趣众生不乎。对曰。唯然见之。时彼会中有菩萨名曰自在。得虚空藏无尽法门。神智辩才应对无阂。此贤劫中十六圣子。最大者是。游十方刹施行佛事。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。今如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。愿欲闻说六趣众生行业果报。所问微浅愿时发遣。尔时世尊于大众中和颜悦笑。诸佛如来常法。佛不妄笑笑有因缘。若有众生生梵天者。尔时佛微笑。有应作转轮圣王者。佛复微笑。有作狱卒者阎罗王者。时佛亦笑。有受饿鬼身者。佛即时笑。有作畜生王者。佛即亦笑。尔时世尊面门出五色光。普照三千大千刹土。即还摄光从顶上入。即告自在菩萨。汝所问者。乃是如来威神所接。亦是十方诸佛所护。能发此问。今当与汝一一分别诸六趣众生行业因缘。谛听谛听善思念之。唯然世尊。愿乐欲闻。佛告自在菩萨。汝今举目观东方梵天大梵天清净梵天乃至色究竟天。此诸天人先修梵行。皆是佛种修诸功德。以贪福报染着五乐。因缘道果皆受天身。计梵天福称量测度。今当与汝一一说之。满此三千大千刹土转轮圣王七宝导从。所谓七宝者。一者象宝。三十二牙毛色纯白。脚蹑莲花身能飞行。二者马宝。身绀青色髦鬣朱色。身能飞行所至无碍知人心念。三者珠宝。光明彻照遍满虚空。及四天下皆悉遍照。四者轮宝。轮有千辐雕文刻镂视之无厌。此第四无识。五者玉女宝。女中殊妙性行柔和。端正殊妙世之希有。不长不短不白不黑。身作优钵罗莲花香。口作牛头栴檀香。恭肃谦下知圣王志趣。六者典藏宝臣。王须宝时手执神器。用以[戀-心+廾]空泻则成宝取止随王。七者典兵宝。圣王出游须四种兵。王告之曰。吾今欲出巡游国界。速集兵众集我殿前勿令影移。即受王教回身东顾。象兵已集行列在东。回身南眄马兵已集行列在南。回身西顾车兵已集行列在西。回身北望步兵已集行列在北。转轮圣王随意所乘或马或象。或至弗干提郁单曰提拘耶尼提。游行四方足不蹈地。或百岁千岁数千百岁食福自然。计转轮圣王身满四天下。不如帝释身。何以故。帝释所领七宝宫殿玉女眷属。坐七宝殿堂天乐自娱。视东忘西视南忘北。快乐不可言。如彼释身不如第六天王。身有三十相神德自在。随形变化心念则成。所将兵众不可称数。功德福业布施无碍。如六天王等满四天下。不如一大梵天功德广大。典领三千大千刹土。诸梵天众无量无限不可称数。寿命极长过一贤劫其命乃终。尔时世尊告自在菩萨。汝今举目南看是无央数转轮圣王列住南方。转轮圣王功德多少如上所说。五戒十善恭奉贤圣持仙人戒八清净斋。根相连属为人慈愍无伤害心。受业果报其福难量。故得绍继转轮王位。佛告自在菩萨曰。汝今举目西看见师子王列住西面。以常六事跱立不动。毛色纯白胸臆方正皆由先身德行福报。虽受畜身分别善恶。足蹈莲花尘垢不染。终不杀生食肉饮血。师子一吼飞落走伏。斯亦五戒不犯三过故获斯报。虽堕畜生转身成道。佛告自在王菩萨。汝回目北顾视饿鬼七宝宫殿。左右眷属皆食自然甘露法味。虽名在饿鬼皆缘人中积善拥护。亦有神足到诸佛刹。礼敬诸佛禀受正要。可行知行可住知住。感动随时不守常法。游此忍界众善普会。转则成道亦复不久。佛告自在菩萨。汝回目下顾见阎罗王。以五事治化无有阿曲。云何为五。罪人在前即面诘问汝在人间知有佛有法有比丘僧有父有母耶。罪人报曰。实有大王。尔时圣王以偈问曰

  杻械铁锁靽　　镬汤热铜柱
  洋铜热钳叉　　偿对今不久
  自造因缘本　　报业无人作
  非父母兄弟　　谁能代受苦
  我愿出家学　　守戒不妄犯
  行正法平等　　犹尚日三煮

尔时阎罗王以五事问。即敕狱卒随罪轻重付令治之。彼罪人中闻佛法声罪灭福生。还复人身修治清净行。是谓菩萨六趣众生报应如是。自在菩萨礼佛足已还在本位。时彼会中有八千亿众生。不乐处苦堕六趣道。尽发无上寂灭空无去离生死

    菩萨处胎经转法轮品第十六

尔时世尊将欲示现诸佛无量遗体报应。令一切会神通菩萨学无学等。比丘比丘尼优婆塞优婆夷四众围绕。现生受报转大法轮。非沙门婆罗门魔若魔天所能转者。即以神足定力。放诸身节毛孔光明。远照十方诸佛刹土。一一光明皆有三千大千佛国。一一佛国皆有化佛。一一化佛皆有三千大千众生之类。一一诸佛与彼诸会者。说无尽法藏无量奇特无与等法。真际甚深所说法者。初中竟善除淫怒痴。以八解水洗除心垢。尔时诸佛于池水中化作七宝高台去池七仞。彼宝台上敷宝高座。于四角头皆悬金铃。众宝杂厕其间。悬缯幡盖五色赤黄。快乐不可言。尔时众生在座。闻法无尽之藏。端坐思惟心不错乱。皆愿欲闻如来秘要。尔时世尊如诸佛常法。复放肉髻光明。上至无数亿佛刹土。空界佛刹。佛名宝如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。见释迦 文尼 肉髻光明。即告彼土诸会菩萨。下方有佛。释迦文尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊今在母胎广说深要无上法藏。引致十方诸神通菩萨。汝等可往礼敬问讯。并持我名问讯释迦文尼。德化日进游步康强耶。彼土众生易受化耶。汝等诣彼摄持威仪彼土众生。多诸恼害憍慢炽盛。尔时彼土菩萨。齐整法服五千七万二亿菩萨。礼彼佛足忽然不现来至忍土。释迦文尼佛复以定意神力。令彼来菩萨不见释迦文尼。说法道场周障四面。从阎浮提遍三千大千刹土。推求忍土释迦文尼佛。彼诸菩萨各各自相谓言。上虚空界我等刹土去此极远。向所见光将无释迦文尼佛取般涅槃放斯光耶。我等得无失天眼通耶。何以故。游至十方遍诸世界不知所在。各各发心内自思惟。我等宁可还至本界。作是念已各各不能至本佛刹。各怀恐惧衣毛皆竖。谓失神足疲厌心生。不能究尽无尽法藏。所以者何。皆是释迦文尼威神使然。佛悉知彼诸菩萨心。即以神足接诸菩萨在母胎中。尔时诸菩萨等加敬作礼。兼以佛遣问讯各一面坐。尔时释迦文尼名怛萨阿竭。复以神足之力放大光明。照东方炎世界。国名奇特。佛名深义如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。现在说法初中竟善。见大光明告诸菩萨。汝等庄严诣忍世界释迦文尼佛所。听无尽法藏多所饶益。何以故。彼土菩萨皆一生补处。必有奇特难思议法。诸菩萨等敬承佛教。礼彼佛足忽然不现。来至忍界释迦文尼佛所。头面礼足各坐一面。佛以神德召魔波旬。将有所感动故致魔来。尔时世尊知众生集。诸天作乐赞颂如来无量福业。佛告文殊师利。止诸天乐吾欲说法。佛告诸来会者。佛出于世亿千万劫时。时乃有如优昙钵花。菩萨摩诃萨漏尽神通根本法者。除想去念是谓有尽。不见漏尽无想法者。是谓无尽。菩萨摩诃萨计身缚着不至彼岸。是谓有尽。能去身想不在彼此。是谓无尽。菩萨摩诃萨缚结已解不住真际。是谓有尽。不见缚结空无我想。是谓无尽。菩萨摩诃萨入出入息观诸世界了无所有。是谓有尽。分别虚无不见有度无度。国界无若干。是谓无尽。菩萨摩诃萨修行十六殊胜之法。济度阿僧祇众生。是谓有尽。十六殊胜自性空寂。不见度不见不度。是谓无尽。菩萨摩诃萨广修刹土。为众生执苦不以为劳。是谓有尽。不见众生刹土清净不一不一。是谓无尽。菩萨摩诃萨奉戒修法入三脱门。是谓有尽。不见众生缺戒全戒。是谓无尽。菩萨摩诃萨晓了分别句义字义应适无方。是谓有尽。不见句义分别字义。是谓无尽。菩萨摩诃萨分别天道人道畜生饿鬼地狱。于中拔济使得解脱。是谓有尽。虽处五浊不染无所染亦无所著。是谓无尽。菩萨摩诃萨除贪贡高无增上慢。亦不自下修清净行。是谓有尽。法性空寂无自大心。不见慢惰于法有失。不见精勤受道果证。是谓无尽。菩萨摩诃萨庄严佛树演畅无数。音声清净普闻十方。破坏贪着使行布施。是谓有尽。不见世界成败起灭有贪著者。是谓无尽。菩萨摩诃萨以金刚心破三界结。从初发意至不退转。不见断灭有碍众生。是谓有尽。吾我贪着无吾无我。云何我我自无我亦无有我。是谓无尽。菩萨摩诃萨灭种姓名不着俗法。言是我所非我所。是父是母是兄是弟。我姓最胜彼姓不如。我族姓子彼非是族姓子。计名号者。是谓有尽。从初发意乃至成佛。不见有成亦不见佛。假号名字悉皆空寂不见有空。云何为空谁造此空。空自无空云何言空。是谓无尽。菩萨摩诃萨法说义说句说字说。从无明至行乃至生死。无明爱取法因缘不尽。迷惑颠倒无明所系。从冥入冥能拔济出。是谓有尽。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。缚着系恋蠲除。无所著无明灭。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。老死忧悲苦恼缘生。生缘有。有缘取。取缘爱。爱缘受。受缘触。触缘六入六入缘名色。名色缘识。识缘行。行缘无明。老死忧悲苦恼灭则生灭。生灭则有灭。有灭则取灭。取灭则爱灭。爱灭则受灭。受灭则触灭。触灭则六入灭。六入灭则名色灭。名色灭则识灭。识灭则行灭。行灭则无明灭。解了法性种种灭不灭。亦不见灭亦不见不灭。云何为灭灭无灭。是谓无尽。菩萨摩诃萨分别晓了起法尽法。起不知所从来。尽何知所从去。起亦无起尽亦无尽。是谓无尽。晓了起尽悉无处所如空无著。云何无著不见无著。无著无此无著。是谓无尽。菩萨摩诃萨欲得总持三昧四无碍慧。昼夜经行举身轻重。初习法观去地。初如阿摩勒果。渐如鞞醯勒果。转如呵梨勒果。去地如指影等。渐渐去地七人影等。此是俗禅凡夫仙学。菩萨于是学而不住。是谓有尽。心通无碍不住五通非不住通。解了诸法法性自然。无明真际皆悉自然亦无自然。云何自然。不见自然无自然。是谓无尽。菩萨摩诃萨以空灭想于色无受。等分众生不见差降。在闲靖处思惟识念。不见造色不见无造色。一向究竟向涅槃门。是谓有尽。念身非常施戒定意。不畏堕落没溺生死。虽处生死如鸟飞空不见形影。悉知无所有。是谓为火灭灰聚无有热气。求火主质无人无我无寿无命。观察分别谁所造作。识亦无识。十八界入推寻无本。百八爱着悉无所有。通达往来不见不可见。不可护持不见有持者。云何为持持无所持。是谓无尽。尔时座中有菩萨名曰金色。六通清彻深解佛慧。功德无量权变非一。欲问如来无尽之义。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。齐何名为无尽义耶。佛告金色。菩萨摩诃萨无尽 法 者。无言无 说 。云何见问说无尽义。尔时世尊即与金色菩萨。而说颂曰

  虚空无色像　　寻生亦无本
  胎分无有量　　如河注乎海
  无尽法宝藏　　三世佛父母
  欲得求尽本　　正可生惑心
  解了法相空　　尘垢灭无余
  成佛金刚身　　庄严众相具
  分别佛身空　　内外无所著
  虽演无尽宝　　亿万不说一

尔时如来说无尽宝时。现坐菩萨学无学等。发意趣向无尽法藏。诸天龙神人与非人。皆发无上立不退转

    菩萨处胎经五神通品第十七

尔时座中有菩萨名曰妙胜。具足六度善权方便。所在教化靡不周遍。处处入众见靡不喜。正观定意为世福田。若善男子善女人遭此菩萨摩诃萨。诸恶除尽普发福庆。思惟平等不二法门。恒以如幻如化如梦法。济渡群生修治佛道无有彼我。尔时妙胜菩萨即从坐起。叉手合掌前白佛言。善哉世尊。五神通菩萨云何得知分别其行。修习何法得神通道。佛告妙胜。谛听谛听善思念之。吾当为汝分别通慧。唯然世尊愿乐欲闻。佛言。妙胜。此欲界中善男子善女人。不须眼通生便彻见一阎浮内众生之类。粗细好丑青黄赤白。城郭屋舍山岩树木。或有善男子善女人。眼能观二天下三天下四天下。不须眼通生便观见。或有善男子善女人。不须眼通耳通清彻。闻一天下男声女声马声车声。所闻声响即能别知。不修耳通一一晓了。或有善男子善女人。不习不学自识宿命。吾从某处来生此间。父姓某母姓某。兄弟姊妹名姓种族尽能别知。或有善男子善女人。不修习神通。知他人心行善行恶。斯趣恶道斯趣善道。此生天上此生人中。此生饿鬼此生地狱此生畜生。此是有缘众生。此是无缘众生。或有善男子善女人身能飞行。周旋往来不修身通。身便能飞无所触碍。履空如地履地如虚。佛告妙胜。此五种人非实神通退法众生。或有善男子善女人修眼圣通。除色断垢念不移易。究竟道门。何谓道门。三空定是。便能得见一千天下二千天下三千大千天下。或有善男子善女人修耳圣通。寂然入定清净闻一天下千天下二千天下三千大千天下。男声女声象声马声车乘钟鼓之声。一一分别知声好恶。此声生天知声生人。知声生饿鬼知声生畜生知声生地狱。知声有缘众生。知声无缘众生。皆悉分别一一晓了。或有善男子善女人清净修道。除去识垢内外无瑕。得意圣通自识宿命。一生二生三生四生。乃至无数阿僧祇劫所从来处。父母兄弟国土清净。悉能识知。或有善男子善女人。修六神通解知法性。强记不忘意止觉道。分别三明定意不乱。便能得知他人心念。一生二生三生四生。乃至无数阿僧祇劫所从来处。皆悉知之。父母兄弟国土清净名姓种族皆悉知之。或有善男子善女人思惟法观。以心持身以身持心。食知止足睡眠觉寤。意想如空于淫怒痴亦不殷勤。计身无我心法清净。意识以定便能举身。一鼓二鼓乃至七鼓渐渐习定。游一天下二天下乃至三千大千刹土。入地如空山河石壁无所挂碍。或有善男子善女人临当成佛。以智慧力除众生垢。坐树王下端坐思惟。自发誓愿吾不成佛不起于坐。如我曩昔坐阎浮树下。三十八日观树思惟。发此誓时感动天地六返震动。弊魔波旬。将诸兵众雨沙砾石雷电震吼。不能令吾动于一毛。何以故。慈润普遍愍众生故得成作佛六通清彻。尔时世尊即说颂曰

  凡夫所得通　　犹如诸飞鸟
  有近亦有远　　不离生死道
  佛通无碍法　　真实无垢秽
  念则到十方　　往反不疲惓
  以慈念众生　　得通无挂碍
  仙人五通慧　　转退不成就
  我通坚固法　　要入涅槃门

尔时世尊与妙胜菩萨说此法时。有百七十亿众生。舍俗五通得六通慧

     菩萨处胎经 识住处品第十八

尔时座中有菩萨名曰普光。大慈大悲神足自在。好乐深奥功德成就从无央数阿僧祇劫。拯济众生拔苦根本得六神通。所经过处佛事不断。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。既闻如来分别六通无所挂阂遍满十方诸佛世界。假令诸佛正法平等无有差别。今此识法住无所住。六通识法识是一法为若干。若识是一法。如来金色神足道场得游诸佛刹土。为识致身。为身致识。若身致识则无六通。若识致身此名一法无身无识。唯愿世尊。报我此义。佛告普光菩萨。汝所问义。为第一义问。为世俗义问。若俗义问。识法若干无有定相。第一义问。则无身无识。何以故。分别识法自性空寂。无来无去亦无染着。汝问金色。此有为法五阴成就。非自然法非第一义。佛色身法。于第一义则为有失。我今为汝说识相法。菩萨行六通。身识共俱。非识先身后。非身先识后。何以故。相法自然。识不离身身不离识。犹如二牛共一轭。若黑牛前白牛后。则种不成就。若白牛前黑牛后。种亦不成就。非黑牛前白牛后。非白牛前黑牛后。则种成就。神足道果亦复如是。身识共俱无有前后中间。如来色身有前有后有中间。此世俗法非第一义。于虚寂法无有若干。尔时世尊即说颂曰

  如来金色体　　三世所奉敬
  为人作重任　　无上无极尊
  忉利诸天人　　昼夜散花香
  梵天及营从　　作乐而娱乐
  于百由旬内　　遍满虚空界
  高声称善哉　　佛识不可见
  无内外中间　　为世愚惑故
  现有六通法　　过去无数佛
  光相亦如今　　欲求识法本
  寂灭不可见　　菩萨六通道
  现尽无有尽　　出息入息念
  不着三界有　　观身内外净
  金色空无著　　识法亦如是
  无去来现在　　五阴性清净
  无今身后身　　一一分别相
  永到安隐处　　识相有六事
  亦名六障法　　六识所住处
  生灭不可尽　　犹如水上泡
  一灭 已 复生　　识法自然空
  流驰满诸方　　我本所造行
  身识二事俱　　独步无等侣
  说法无上道　　诸法识为本
  所向随身相　　虽住亦不住
  教化苦恼者　　眼见前色法
  识在中间障　　非色来入眼
  亦不眼就色　　分别此彼法
  由识知善恶　　识自无识法
  耳声鼻香别　　六业自生缘
  故造善恶行　　声不来就耳
  鼻口意亦尔　　法法相因缘
  无著空无法　　贤圣八品道
  三十七行观　　虚空寂然界
  无相无有愿　　行有白黑报
  受对识分别　　欲求识实相
  不见有住处　　庄严佛刹土
  四等无所畏　　解了诸法空
  识灭行亦灭　　菩萨成道果
  无去来今法　　识如幻化道
  不住于彼此　　识灭归虚空
  假号无真实　　初入四空定
  除想无系着　　竖显高法幢
  演畅识相法　　前识非后识
  亦不离于识　　三界第一尊
  乃能究识性　　如人在山顶
  通达见四远　　分别善恶行
  天眼通第一　　远见十方界
  有黠智慧人　　如掌观明珠

尔时世尊说此颂时。八十四亿众生。欲得远离六识法相。不乐生死流转五道。发弘誓心住无识地

    菩萨处胎经善权品第十九

尔时座中有菩萨名曰举手。前白佛言。世尊。愿闻菩萨摩诃萨权变无数不可称计。佛言。菩萨摩诃萨常行善权。非此非彼非两中间。随前适化义说句说思惟义。趣庄严佛土六度无极乃至相知灭。方便导引无所挂阂。不自贡高亦无憍慢。容貌端正法服齐整。受前信施非度不舍。光相端严言说清净。为一众生住寿亿劫。留形在后余方教化。如是分身难可思量。所可游化无觉知者。在鬼神界现大神力。亦使彼鬼度化众生。展转相教不失道教。复次权变作佛形像光相炳然。其有睹见及闻所说法。初中竟语安隐快乐。禅定觉道明慧解脱。契经偈经记经授决经。处经出要经。广长经聚经生经广普经。未曾有经现经转经。譬喻经因缘经。随所趣向与说深法解空无我。众生所念各各不同。能令一切入解脱门。譬如众源陂池。五河驶流各各有名。悉归于海便无本名。亦如须弥跱立难动。杂色众鸟往依附止。皆同一色便无本色。菩萨摩诃萨教化众生净佛国土。亦复如是。众生心识所念不同若干思想。能令一切至解脱门想定意灭。便无本念同一解脱。是谓菩萨摩诃萨权变适化不可测量。尔时世尊即说颂曰

  譬如田农夫　　选择良美地
  下种不失时　　溉灌以时节
  长养苗成就　　不霜虫蝗灾
  究竟获果实　　收藏无忧畏
  菩萨真实法　　六度无极田
  消除悭贪心　　溉以甘露水
  善权方便道　　明了去就法
  导引众生类　　得至不灭处
  生老病烦恼　　烧诸心善根
  善权方便护　　解了去就法
  夫人欲出家　　禁戒以为首
  不着饰好法　　行权菩萨道
  毕命不惜身　　不犯如毫厘
  身如草土粪　　随人所爴割
  忍如安明山　　坚固不可沮
  护戒方便道　　毁誉无增减
  出冥在明处　　菩萨善权道
  现身在人间　　哀愍一切故
  或现微细形　　出入无挂碍
  道场诸佛坐　　灭结更不生
  其有至道场　　结尽永无余
  亦如大导师　　将诸商贾等
  入海采珍琦　　珊瑚琥珀珠
  明月随意宝　　安隐还本国
  父母诸兄弟　　眷属奴婢使
  和悦心欢喜　　如定除去想
  行权菩萨等　　搜求无尽藏
  了别珍琦妙　　自用璎珞身
  善权导师长　　六度为妻息
  四等心覆盖　　尘垢不着心
  世多愚惑人　　守悭不布施
  积财千万亿　　称言是我有
  临欲寿终时　　眼见恶鬼神
  刀风解其形　　无复出入息
  贪识随诸恶　　受报甚苦辛
  将至受罪处　　变悔无所及
  佛以权智度　　就彼而说法
  利根自省罪　　悔心不藏匿
  闻法得度脱　　菩萨善权道
  如人生便盲　　不识玄黄色
  遭遇圣巧匠　　疗治以法药
  昔闻有五色　　青黄赤白黑
  既得明眼识　　不别青黄赤
  菩萨善权道　　分别至究竟
  荡除八难法　　不生亦不灭

尔时世尊说此颂已。有百亿居士行善权道。毕竟无为住无住地

菩萨处胎经卷第五菩萨处胎经 卷第六

        姚秦凉洲沙门竺佛念译

    无明品第二十

尔时座中有菩萨名曰智清净。分别空无生老病死。淫怒痴多者。淫怒痴少者。分别众生三品差别。于等分中何病最重。所谓重者邪见是。智清净菩萨即从坐起偏袒右肩右膝着地。长跪叉手前白佛言。如来无所著等正觉。无所不知无所不见。过去当来今现在。蚑行喘息人物之类。心所念法。口所言说。身行善恶。甚深禁法威仪戒律。知多知少知重知轻。今我所问。非空非不空。非有非不有。非有空非有有。三聚众生。何者为轻。何者为重。何者现报。何者生报。何者后报。云何想知灭。云何涅槃。云何无余。佛告智清净菩萨。善哉善哉快问斯义。愍诸一切多所饶益。乃能于佛前问平等法。汝还复坐吾当与汝解说句义初中竟品。黑业受黑报。白业受白报。一一分别令汝知之。尔时世尊即说颂曰

  如人种果树　　子苦果亦苦
  为罪得黑报　　经历劫数苦
  种甘得甘果　　还受甘果报
  香洁甚香美　　得受清白报
  如人在池水　　内外清净彻
  无风无尘秽　　香美得清凉
  其有众生见　　娱乐不能离
  佛道清净行　　与彼无有异
  黑报众生等　　坠堕三涂难
  高下随駃水　　漂流厄难处
  当时烦恼苦　　独受无人代
  破骨入髓脑　　烧煮不可量
  已至无救狱　　意悟求解脱
  无明所覆盖　　不见慧光明
  如人行路迷　　举南以为北
  终日心不悟　　虽闻亦不信
  受罪重苦恼　　毒痛加其身
  久后罪虽毕　　世人所恶贱
  形体腥臊丑　　如猪卧深溷
  宛转入镬汤　　死而复更生
  愚痴本所造　　受报如影响
  善恶二俱等　　等分众生义
  无道无偏党　　行亦有高下
  持戒生天人　　不施福最少
   抟 食畏人见　　惭愧不露出
  虽有天女众　　音乐不和雅
  时时出游观　　畏逢神妙天
  若戒布施具　　甘露衣食至
  前后伎乐绕　　如月星中明
  久久出游观　　营从自庄严
  天乐自然作　　斯由此人间
  持戒布施具　　福报如影随
  诸天虽受福　　亦有劫数难
  临欲命终时　　乃知衰耗法
  善念转欲微　　当复更受身
  轮转五道中　　经历无数劫
  善恶受对时　　不避豪贵贱
  于中能独拔　　如我释迦文

尔时世尊说此偈已。于大众中诸天及人。七万七千亿那由他。皆发无上正真道心。尔时世尊告智清净菩萨曰一生补处菩萨大士。以权方便在卑贱家生。欲得示现除无明结。十月在胎临生之日现无手足。父母睹见谓为是鬼捐弃旷野不使人见。所以者何。菩萨权化欲令愚痴父母眷属睹见道明。其后数月母复怀娠。具满十月生一男儿。端正姝妙世之希有昼生夜死。父母号哭 椎胸 向天。山神树神何不怜我。先生一子而无手足捐弃旷野。今生一子端正无比状如天神。今复昼生夜死。心肝断绝当复奈何。复经数月母系怀妊。十月具满生一男儿。三头八脚四眼八臂。睹者毛竖。父母眷属舍而欲去。菩萨权现令不得去。父母问曰。为是天耶。为是龙鬼神阿修罗乾闼婆伽楼罗紧那罗摩睺罗伽人与非人耶。尔时所生男儿。即以偈报父母曰

  非天夜叉鬼　　须伦迦楼罗
  为母除愚闇　　权生父母家
  先无手足子　　亦复是我身
  朝生若暮死　　八住无上尊
  我今受形分　　三头八手脚
  何为舍我去　　经向地狱门
  地狱众苦备　　十八镬汤沸
  一一镬汤者　　十六隔子围
  受苦无量劫　　求出甚为难
  父母愚惑人　　不识真法性
  邪见祷神祠　　谓当脱苦难
  如火焰炽盛　　益以干薪草
  焚烧善根本　　求灭亦欲难
  今我还复体　　现本端正形
  道本心坚固　　修习三通慧
  从阿僧祇劫　　誓度不度者
  守戒不失愿　　托生父母家
  前后舍身命　　其数如微尘
  所可经历处　　靡不蒙福祐
  群品若干种　　行迹各不同
  应与欢悦度　　亦以恐畏化
  随彼众生念　　令复心所愿
  众生病非一　　投以甘露药
  趣使入道捡　　不令入邪径
  诸天受福乐　　甘露除病乐
  不违圣教乐　　解脱涅槃乐

尔时菩萨说此偈时。父母宗族及诸来会者。皆发无上平等度意

     菩萨处胎经 苦行品第二十一

尔时诸会菩萨。天龙鬼神阿修罗乾闼婆迦留罗摩睺罗伽紧那罗人非人。学无学及四部众。比丘比丘尼优婆塞优婆夷。如来观察知诸众生心之所念。欲使如来说究竟成就苦行无量。齐何发意得成佛道。佛知彼心。即与说本勤苦之行。佛告诸来会菩萨摩诃萨。听我所说真实法相。亦不由俗数得道。亦不离俗数得道。不从真道亦不离真道。何以故。黑中白妙俗中道妙。苦乐甘胜。所以者何。吾昔学道直信不疑作日月王。日宫殿者。纵广五十一由旬。月宫殿者。纵广四十九由旬。日放光明一亿一千光 明 。月放光明一亿光明。吾为日月天子。谓为常住不朽不败。经历恒河沙亿千万国土。作日天子作月天子。命尽乃知非实非真。后寿转减。作日月大臣。名曰荷伽罗。宫殿纵广二十五由旬。次复作毗梨呵波提。宫殿纵广二十由旬。次复作鸯伽罗。宫殿纵广十九由旬。次复作醘谋。宫殿纵广十九由旬。次复作含尼。宫殿纵广十五由旬。此五大臣日月左右。于无央数百千劫。作此五星寿尽堕落。亦不真实其寿转减。吾曾为昴宿。同伴六人度数三十。吾曾作毕宿。朋党五人度数四十五。吾曾为觜宿。朋党三人度数三十。吾曾为参宿。单独一己度数十五。吾曾为井宿。朋党二人度数四十五。吾曾为鬼宿。朋党三人度数四十。吾曾为柳宿。朋党四人度数十五。菩萨当知此七宿者。跱立东方。吾曾为星宿。朋党五人度数三十。吾曾为张宿。朋友二人度数三十。吾曾为翼宿。朋友二人度数三十五。吾曾为轸宿。朋友五人度数三十。吾曾为角宿。单独一己度数三十。吾曾为亢宿。亦独一己度数十五。吾曾为 氐 宿。朋友二人度数三十五。菩萨当知此七宿者。跱立南方。吾曾为房宿。朋友四人度数三十。吾曾为心宿。朋友三人度数十五。吾曾为尾宿。朋友三人度数三十。吾曾为箕宿。朋友四人度数三十。吾曾为斗宿。朋友四人度数三十五。吾曾为牛宿。朋友三人度数十六。吾曾为女宿。朋友三人度数三十。菩萨当知此七宿者。跱立西方。吾曾为虚宿。朋友四人度数三十。吾曾为危宿。单独一己度数十五。吾曾为室宿。朋党二人度数三十。吾曾为辟宿。朋友二人度数三十五。吾曾为奎宿。朋友二人度数三十。吾曾为娄宿。朋友二人度数三十。吾曾为胃宿。朋友三人度数三十。菩萨当知此七宿者。跱立北方。吾从无数阿僧祇劫。或为日月王。或为臣佐。周旋往来形骸朽败。无真实道。后来人间或为转轮圣王杂散小王。或为长者居士。求清净道谓为真实。皆是虚行不合真道。吾昔一时入山求道。见诸仙学五千人俱集在一处。或翘一足叉手合掌随日转身。或有事月叉手合掌随月转身。或卧棘刺或服沙石。或持土枭牛马鹿戒。或在山顶投身深壑。或抱石自沉入于深水。或五火自炙求生梵天。或解身支节求神所在。或发头顶以脑燃灯持供养天。或投身沸油酥。或江右杀无量众生。或江左烧香。令命过众生尽得生天。或自念言。曼我今在先度父母。即以父母掷于火中唱生梵天。或食牛粪或食果蓏。或七日一食。或时不食形骸枯燥。或编树叶以为衣服。或连髑髅以为衣服。或以髑髅以为食器。或服刺针。刺心持心令住。或时聚会一处。互相破腹洗肠去垢。唱生梵天。吾昔苦行不可称计。于树王下六年学道。日食一麻一米。青鸽飞雀顶上生乳 (丹本卵) 。蛇虺缠身。牧牛猎师瓦石撩掷。或时斫刺破坏形体。或时以杖柱腹乃至于脐。遭此百千万痛不以为苦。何以故。吾当于尔时。谓为是道实非真道。于虚空有天叉手白菩萨言。忍力最大破碎结使。念垂成佛慎勿退转。过去恒河沙诸佛世尊。不如菩萨断食求道。天神所感使弥家女奉上乳糜。食已气力充足。七日思惟降伏魔怨。梵天下请得成为佛阐扬大法。可谓真道无过涅槃。涅槃无生老病死。吾昔所更苦行如是。尔时众会菩萨叹未曾有。皆发无上平等道心

    菩萨处胎经四道和合品第二十二

尔时座中有菩萨。名曰遍光。神智通达住不退转。弘誓之心不可沮坏。诸佛所称非一非二。乃至恒河沙佛功德无量积行无畏。恒游行无量诸佛世界。同学八人。一名不邪见菩萨。二名直意菩萨三名众相菩萨。四名屈伸菩萨。五名解脱菩萨。六名解缚菩萨。七名印可菩萨。八名得誓愿菩萨。从无央数劫已住尽地得不退转。尔时遍光菩萨白佛言。云何菩萨摩诃萨入四种道无有前后。得成无上等正觉道。于是菩萨昼夜思惟见欲如火。想知念尽颠倒行法。见初利法授阿那含。即彼天宫取道明证。如是不久。或时菩萨在上分地。下观欲界犹如聚沫。断三结使远离三恶于有无有。或有菩萨得根得力立志自在。破有灭无无四等心。等彼此无我想。非去来今亦非等正觉。今此众生于无上道有何差别。佛言。善哉斯问。吾当与汝具分别之。云何菩萨因缘因缘。云何名因缘因缘。两臂钏相掁故名为因缘因缘。彼教我受承声受化。是谓声闻。无师无智不因彼此。故名觉佛。复次菩萨摩诃萨此道彼道共相授决。处证无证周流五道。是谓为觉。亦不见觉。亦不见不觉。不一不二是不二入。菩萨摩诃萨本行习尽解了缘觉。有余无余结使永尽。是不二入。等分众生解了无常。身非我有。内外尽空。是不二入。佛恩流布广普无边。以苦集道得至无为。是不二入。大慈四等覆盖一切。愚惑众生得至真实。是不二入。尔时世尊即说颂曰

  声闻辟支佛　　假号音 响名
  犹彼大战师　　腾怨乃为上
  佛为无等伦　　独步三界尊
  服心降魔兵　　忍力至涅槃
  轮转生死苦　　命如琢石火
  经历亿百千　　求脱无有期
  佛本无号字　　随人所尊重
  罗汉辟支佛　　本一无有二
  如彼定光佛　　授我无上决
  却后九十一　　于此贤劫中
  第四最胜尊　　号曰释迦文
  五浊鼎沸世　　不孝顺父母
  杀害阿罗汉　　不奉二尊教
  我所经历处　　非一非二道
  六趣烦恼中　　经历无央数
  初中后不寐　　经行修道德
  敬心自觉悟　　去离三有着
  昔佛所行愿　　不舍取灭度
  一身一识神　　与己无别异
  勤苦数劫中　　精神腐朽败
  为彼不自己　　故得成佛道
  我为一切智　　遍教不教者
  通慧无所著　　一音除狐疑
  三生须陀洹　　得至无为道
  况复第一者　　取佛无有疑
  我今诸弟子　　有学及无学
  四等拔济苦　　无起无生灭
  本从思想生　　还从思想灭
  非我思想生　　非我思想灭
  行本自有根　　流驰非一端
  根断无思想　　无复根本念

尔时世尊说此颂时。十二那由他众生。皆发无上平等道心

    菩萨处胎经意品第二十三

尔时座上有菩萨。名曰根莲花。惠施无碍行四等心坚固难沮。进止行来不失威仪礼节。从无数劫来常修梵行禅定不乱。分别善恶观察众生。有淫怒痴心。无淫怒痴心。若多若少皆悉知之。游诸佛国供养承事诸佛世尊。善权方便示现无常无我无身无命无人。可行知行可住知住慈愍一切。时根莲花菩萨即从坐起。偏露右臂右膝着地。叉手合掌前白佛言。善哉世尊。四道所趣意何所在。为有意耶。为无意耶。意是果耶。为非果耶。意是有对无对耶。意可见不可见耶。意是过去未来现在耶。非过去未来现在耶。意是仙人法。非仙人法耶。意是有为法耶。无为法耶。意是有漏法无漏法耶。于三法 报 意何所在耶。意在黑黑报耶。意在白白报耶。意在不黑不白不白不黑报耶。意在不粗行法细行法耶。尔时世尊告根莲花菩萨言。善哉善哉。根莲花菩萨。汝所问义愍念一切。开化众生心意识法。为盲冥者示现光明。汝今谛听谛听善思念之。尔时世尊即说颂曰

  最胜无等伦　　清净无瑕秽
  眼净如莲花　　不为尘所污
  处世有为法　　坠堕三有难
  我空彼亦无　　意寂无心识
  如水在器中　　规矩随前物
  过去非本有　　现在善恶行
  未来当坏法　　此意非本意
  菩萨行大慈　　亦现对无对
  洗除垢秽病　　安处究竟道
  人有五盖蔽　　令心有障碍
  如日照天下　　恒有五事蔽
  须伦烟雾尘　　闭塞根门法
  意本无善恶　　随行之所造
  寂灭空无法　　如果繁折枝
  譬如芭蕉树　　叶叶空无实
  四大成人身　　求意无意根
  意在去来今　　去来今无意
  分别识心法　　求实无所有
  意法无形貌　　不可言是意
  心念若干事　　生灭不断绝
  过念善恶事　　未来当受对
  现在行已满　　意造非他为
  一念九十亿　　有善有恶行
  一念之所造　　蠲除不可尽
  况复日月劫　　所造善恶行
  智者将护身　　坚固不倾动
  如彼犯罪人　　擎持满钵油
  若弃油一渧　　罪交入大辟
  左右作众伎　　惧死不顾视
  菩萨修净观　　执意如金刚
  毁誉及恼乱　　心意不倾动
  解空本求净　　无彼此中间
  真如四谛法　　趣向涅槃门
  本我所造行　　牵连身根本
  非算师弟子　　所可能筹量
  无数亿千劫　　以身偿罪对
  象马六畜形　　除人不在次
  虽得为人身　　聋盲喑哑偻
  佛出照世间　　边地不见佛
  苦恼五鼎沸　　纯恶不闻善
  颠倒邪法兴　　真性中道衰
  我于无数劫　　持行如油钵
  爱身自将护　　引致无畏处
  九十六种兴　　如夜见萤火
  佛日照世间　　除去诸闇冥
  佛出世人乐　　医出病人乐
  宝出贫人乐　　得佛涅槃乐
  苦行忍辱乐　　我不着色乐
  悭贪布施乐　　持戒不犯乐
  面受圣教乐　　思惟禅定乐
  有无平等乐　　难遭值遇乐
  地狱八难苦　　无救第一苦
  种子腐败苦　　生苗不成苦
  生天入罪苦　　正见颠倒苦
  难陀拔难陀　　绕着须弥苦
  劫烧火炽苦　　心悔求佛苦
  一行向一道　　一心意不回
  一身修道德　　终竟成一宝
  修一不离一　　端严一识一
  守一不离一　　故名独一步

当其世尊说此颂时。十六那由他众生初行道迹。除去尘垢得法眼净。于无所著入空三昧

    菩萨处胎经定意品第二十四

尔时座中有菩萨。名曰持空。相好具足入四法门。辩才第一修持佛土。一一佛土留身教化。现生现灭随人高下。言语音响有甜有苦。说去知来现在明了。前人问一报以万亿。义味深邃难可思量。尔时持空菩萨即从座起。偏袒右臂右膝着地。前白佛言。云何菩萨度苦众生。佛告持空菩萨。能使众生闻苦声响苦行菩萨断苦灭苦不见苦本。一道推苦由恩爱而生。集结恩爱缚着人心。以药疗治二十八行无从苦本。积行累劫灭以复生。邪见众生称言真道。转入清净三昧定意。清净无瑕无彼无此。心识开悟暂得定意。善哉我利。安隐快乐无过此胜。意识心结当时渐解。谓是真道此非真实。何以故。虚伪诳法非佛本行。古昔诸佛所行真实。非我非过佛所行法真实。四不思议。何谓为四。持意菩萨能令佛土三千大千刹土尽为七宝。还复如故。是一不思议。如我今日处母胞胎。引及无量阿僧祇众生。不度者度不到者到。除垢至无垢。是二不思议。我本誓愿要度苦人到无苦处。一苦不度吾终不取涅槃。是三不思议。佛身无量非东西南北方之所能受。独一无侣自性法空。观别众生自观己性。此好此丑。此净此不净。此地水火风。此我所此非我所。此苦此非苦。此乐此非乐。此常此非常。此今世此后世。作福得福作罪得罪。尔时世尊即说颂曰

  身如灰土粪　　四大和合成
  无风水庄严　　地大各自离
  火灭在斯须　　识无住处所
  多罪积苦本　　此是识所为
  我今知识本　　舍汝不有汝
  五色玄黄彩　　坏败人心意
  如人出入息　　行法不久停
  解知非常苦　　无我彼中间
  一音报万亿　　兴显第一教
  无常苦空身　　晓了诸法相
  一还住六净　　解空无相愿
  了身非我有　　如佛教化众
  留身心识离　　若佛无此神
  云何分身化　　随前罪福报
  各令充足愿　　今受后不受
  现在亦如是　　杀害父母罪
  亦现亦不现　　犹如拍鞠报
  神识之所染　　或逆或变悔
  一意向清净　　无为大导师
  舍身去俗累　　本无因缘法
  其报如影响　　如有亦不有
  邪见言真实　　痴网所缠裹
  从黑还入黑　　不别清白法
  戒忍有五行　　无畏无所惧
  定力动大千　　降魔如使兵
  人求无上道　　有退有进者
  如河趣大海　　往多达者少
  遭遇大悲缘　　善权渡彼岸
  佛为一切智　　无染无所著
  我本行苦业　　舍国城妻子
  除父母师长　　不惜身体命
  如人行旷野　　渴乏须浆水
  遇河泉池井　　自济无渴乏
  人受四大身　　有定不定处
  况识无善恶　　受报识明白
  持戒七宝堂　　天女数百万
  天乐自娱乐　　念念无愁想
  佛力一切智　　遍润一切人
  先进五神通　　甘露法自润
  称扬四句义　　无前后中间
  法法然炽法　　法性内外通
  如我本所造　　爱使之所缚
  展转五道中　　以为屋舍堂
  天道琢石光　　寻究无有尽
  盲龟浮木孔　　时时犹可值
  人一失命根　　亿劫复难是
  海水深广大　　三百三十六
  一针投海中　　求之尚可得
  一失人身命　　难得过于是
  奉律持戒人　　处世难可值
  于亿千万劫　　佛如优昙花
  有缘众生等　　受化于佛道
  断灭除结使　　永尽无想着

当佛说此颂时。十二那由他众生。信根坚立无有倾邪。皆发无上正真道意

    菩萨处胎经光影品第二十五

尔时世尊于母胎中广说大乘不可思议。将欲灭度示现光影神德。令诸会者皆同一色。如佛金色无若干差别。诸天龙神阿修罗迦留罗紧那罗摩睺罗伽人与非人。及四部众比丘比丘尼优婆塞优婆夷。或有向或有得果。悉令同色。欲闻如来光影定意建立功德。解脱无碍四辩才智应对捷疾。想知灭尽所可救济。为人重担行来进止。不失威仪如诸佛法。常所讲说苦集灭道。导引众生入四意止。法成就断意觉力师子无畏。贤圣八道空无想愿。时会中有菩萨。名曰贤光。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。放此光明普照三千大千世界。此光明所化如佛化不。佛力功德非一非二。光明所接不可穷尽。此二德行有何差别。唯愿世尊。解释疑结。使未信人永无狐疑。尔时世尊告贤光菩萨曰。汝所问者。皆是如来神力。何以故。如来神光济度众生无所挂碍。从阎浮提上至果实天。光明远照演说六度无极。布施持戒忍辱精进禅定智慧。如佛神口度脱众生无彼无此。济度无数阿僧祇众生。皆是佛光荫凉覆盖。尔时光明有自然音响。而说颂曰

  过去无数佛　　靡不放光明
  一一诸光明　　说六度无极
  戒忍解脱门　　乐法以自娱
  初说三空定　　以次成就道
  三毒等分人　　无缚无所著
  结结四十八　　无救罪门无
  非真行道人　　所可经历处
  三活欢喜门　　神人迹可贵
  上胜所经过　　得至无为岸
  立行不退转　　无畏神力威
  神光所接度　　非百亿万倍
  如彼一光明　　分为微尘数
  一尘作诸刹　　无数不可称
  佛力不可尽　　非有亦非无
  一光演说法　　度脱阿僧祇
  法身自然空　　内外清净行
  烦恼八万四　　定意不起乱
  昔吾九十二　　劫数难可尽
  端坐树王下　　行道不中退
  人天须伦鬼　　劝请问我义
  神光远接度　　度脱无央数
  过去式弃佛　　留光后教化
  得入彼光里　　消灭三毒患
  次佛惟卫尊　　神德不可量
  亦复留光明　　拯济苦恼人
  拘那含牟尼　　特出三界尊
  今在仙人山　　光影炳然着
  句楼天中天　　无著无所染
  寂灭入涅槃　　留光在后化
  迦叶本无尊　　所度不可量
  亦以光明德　　令度不度者
  我释迦牟尼　　处胎而说法
  身此光明彼　　遍满诸佛刹
  此非小节人　　所可能筹量
  唯佛能量佛　　功德无差别
  当来诸佛等　　皆以光明化
  现可度众生　　先光而后法

尔时世尊说此颂已。当其座上百七十亿众生。闻佛说此光明神德。皆发无上平等度意

菩萨处胎经卷第六菩萨处胎经 卷第七

        姚秦凉州沙门竺佛念译

    破邪见品第二十六

尔时世尊入正定三昧。分身变化放大光明。欲令菩萨摩诃萨。及四部众比丘比丘尼优婆塞优婆夷。破魔境界住于正地。告诸会者。吾念过去九十一劫。在清明城北雪山南界。师宗五千人山中苦行。我于彼众最小弟子。讽诵经典算数技术。天文地理靡不综练。彼众常法。其有弟子所学已成当报师恩。时我一己亦无财物宝货可奉上师。即跪拜谢欲下山人中乞索。师不见听。如是再三求哀乞索。师复不听。何以故。以我明晓经典众中最胜。师告我言。吾有秘要宝藏经典。卿未讽诵。何为舍吾人间乞求。尔时师即以秘要一句五百言。使我讽诵。未经数日诵习已讫。即前白师。见听下山乞求欲报师恩。师复不听而告我言。汝当学问秘谶文书。日月星辰灾怪祸福山移地动。汝亦未知。何为欲舍我人间乞求。复更出经一句千言。敕教我诵读。又未经几日复得成就。白师求乞欲报师恩。师复不听。吾更有经一句万言。经中众宝卿亦未诵读。何由欲舍吾乞求。即复出经使诵读。未经几日已复通达。技术灾怪众星运度皆悉明了。时师殷勤欲得留住。更无异经可以学者。即辞师下山诣村乞求。见异学梵志众五千余人。于大聚落而共祠天。彼祠天法杀五百牸牛。五百羯羊。五百骆驼。五百匹马。象中精健六牙成就。五百女人。金杖一枚金澡罐一枚。白[疊*毛]千张。金银钱各五万。此诸宝物祠天讫当入于师。时我下去衣裳尘垢。先在山中苦行积年披鹿皮衣。闻彼聚中异学梵志师宗五千人设大坛会我即过之。时彼师长问吾。经典技术多者得为上座。经典少者乃处下座。彼师所知。不能通达秘要谶记。以我为上座。彼师嗔恚此为何人。珍宝杂物今应属我。此人见夺。若当更生共相值遇。要当报怨。如今夺我无异。时我即说。邪见颠倒非真非实。分别有无为说涅槃。无生老病死无彼无此。中间自相法观清净四无所畏。为福生天为罪地狱。悭贪饿鬼抵债畜生。善恶之报如影随形。时五千人心识开悟。即请我为师。时象马牛羊骆驼尽应杀之。而我不杀。金杖澡罐我应取之。我即以与上座嗔者。五百女人还寄祠祀之主。五万金钱吾取五百。五万银钱吾取五百。余寄祠主。吾从村至村。从国至国。渐渐至清明城东门外。见五百梵志耆年宿德。学道日久日曝火炙形貌丑秽。吾即以五百金钱各与一枚。辞别入城。见城中人香水洒地除去尘秽。悬缯幡盖行列端严皆欲出城。我小前行见一女人持花七枚。我时左右顾视。求香觅花了不能得。即问此女。汝花可得者。吾欲买之。女报我言。此花王花。佛当入城将用上佛。不可得也。菩萨复以善权方便。更告语女。吾有宝钱五百枚。一花百钱若见与者。出钱相付。女贪得宝即以五花与之。行数十步女自念言。此人颜貌端正身披鹿皮衣。贪我五枚花不惜银钱。此必有以。回头唤言。男子卿用花为。报言上佛。时女闻佛名。即以二花持用寄我。我即出城遥见佛来。诸天人民填塞道路。无有空缺地可礼拜。佛前有一汪水可受一人。吾即解发布发水中。即以此偈而赞叹佛

  破爱憍慢心　　能灭欲怒痴
  第一光相足　　唯佛照我心
  昔我所求愿　　今日得见佛
  今散五茎花　　愿得不退转
  余二非我花　　王女寄上佛
  无上大导师　　见愍蹈我发

时光明如来。见我心发大弘誓不可沮坏。即以偈而赞我言

  摩纳发大心　　旷济无数人
  弘誓不自为　　殖众功德本
  却后无数劫　　五鼎五浊世
  成佛度众生　　号字释迦文
  光相三十二　　奇特人中尊
  受慧称佛竟　　地六反震动
  诸天世人民　　见我得记别
  常想众结灭　　皆愿生我世

尔时光明如来。即以足蹈我发上过。佛以神力接我五花及以我身。即在虚空。余有二花在佛左右肩上。吾昔所行。破五千梵志祠天事火之具。使行正见八平等法。坐卧经行步步饶益度脱众生。从此以来未曾坠堕三涂八难世智辩聪边地佛后。尔时座上魔界众生。计常断灭。言苦有乐。无常谓有常。无身谓有身。习四颠倒不识明慧。五盖自覆贪着利养。尔时世尊欲度斯等。邪见之人。重说颂曰

  邪见非真道　　如彼铁嘴虫
  破骨入髓脑　　苦痛无央数
  利养坏道德　　智者所不习
  躬行坚固心　　净除无明法

尔时世尊说此邪见句义味义字义。说真实法。无央数百千众生。皆发无上正真道意

    菩萨处胎经文殊身变化品第二十七

尔时世尊无所著等正觉。入上尊定意三昧。观察过去当来今现在菩萨摩诃萨劫数多少。应从一劫二劫乃至百千无数亿劫。应取般涅槃者。或有菩萨摩诃萨供养诸佛功德成就。教化众生净佛国土。或有菩萨摩诃萨行八住童真。不取妻息除淫欲想。自住其地无父母兄弟。得成无上正真等正觉。佛告文殊师利现汝古昔七十九劫于花光世界。在胎说法全身舍利。其土人民身长千由旬。佛身万由旬。东西南北四维上下。无量无限不可称计。非算师算师弟子所能筹量。根本清净汝本在彼。佛身光相示现神足。令此大会得一睹见。于如来种利益众生。尔时世尊即说颂曰

  文殊本成佛　　在胎现变化
  方身万由旬　　光明相炳着
  目如青莲花　　唇口珠火明
  方白四十齿　　眼眴上下迎
  诸天龙鬼神　　香花归命礼
  今我处此胎　　比方汝彼刹
  于十六分中　　不得如毫厘
  如来神德化　　通达无所碍
  禁戒香远布　　诸佛悉叹誉
  此今诸来会　　欲问难有法
  软首现汝力　　蠲除疑网结

尔时文殊师利菩萨摩诃萨。不离本座即以神足定力。犹大力人屈伸臂顷。接华世界。内娑诃世界释迦牟尼母胎会中。二佛世界不相障碍。现身佛相众好具足坐树王下。敷演深奥最胜之法。彼土菩萨亦来亲近释迦文佛。供养承事香花幡盖。释迦文尼菩萨弟子亦彼至彼礼事供养。彼此音响说甚深妙法。共相开通无有挂碍。彼说无生此亦如是。我说意止彼亦如是。意断根力觉道彼此无异。彼说苦空非身此亦如是。尔时文殊师利即说颂曰

  观内外清净　　缘灭想亦然
  十方诸佛刹　　神德无有异
  皆由众生根　　现有妙不妙
  计我成佛身　　此刹为最小
  座中有疑故　　于胎现变化
  我身如微尘　　今在他佛国
  三十二相明　　在在无不现
  本为能人师　　今乃为弟子
  佛道极广大　　清净无增减
  或欲见佛身　　二尊不并立
  此界现受教　　我刹见佛身
  此刹有劫烧　　我土无坏败
  佛力悉周遍　　众生心非一
  众会听我说　　除此更有余
  佛刹名无阂　　佛名升仙尊
  国土倍复倍　　清净无瑕秽
  国城皆七宝　　水精琉璃地
  八解甘露池　　洗浴去尘垢
  令住无碍处　　[火*霍]然睹大明
  彼升仙佛者　　勿谓为异人
  众会欲知者　　我身软首是
  置此更有余　　刹土名究竟
  佛名大智慧　　过诸菩萨量
  彼无二乘学　　辟支声闻等
  菩萨摩诃萨　　无有欲怒痴
  根败叶不生　　况复有果实
  大人相具足　　先救后自济
  命如五河流　　五使五缠结
  五盛阴唼嗽　　轮转五道中
  七使勋坚着　　不离七生处
  无为八正道　　除去八邪业
  八慧清净观　　洗以八解水
  八住八除入　　有为八法道
  苦法有九分　　六趣众生行
  究竟九无阂　　庄严佛道树
  十力无畏法　　被慈弘誓铠
  手执智慧剑　　芟除结使林
  此界诸众生　　贪着生贡高
  重病离良医　　疗治方更剧
  犹如野火炽　　焚烧山林泽
  随岚大风吹　　焰炽何时灭
  今我等世界　　广演大智慧
  我如今日身　　大智如来是

尔时文殊师利说此颂已。无量阿僧祇众生。皆悉愿乐生花刹土。时文殊师利还摄神足。现释迦文佛菩萨弟子。国土多少还复如故

    菩萨处胎经八贤圣斋品第二十八

尔时座中有菩萨。名曰智积。于过去佛造众德本降伏魔怨。善权变化庄严佛土。于无央数修行忍辱。忍心不阙禅行 不废 。于大众中为师子吼。独步三界随时上下。靡所不入应适无方。能使山河石壁皆为七宝。给施贫穷四事不乏。解了空观法性清净。分别三世威仪法则。如幻如化如镜中像。如热时焰如空中响。所将眷属根本成就。奉持禁戒不犯毫厘。即从坐起偏露右臂右膝着地。叉手合掌前白佛言。快哉世尊。如来所化无不周遍。天龙人鬼皆至道场。空界众生及以胎化。所可济度不可称量。唯愿世尊。分别六趣善恶之行威仪禁戒。初中竟善一一分别。使未学者学未知者知。佛告智积菩萨。善哉善哉。能问如来甚深之义。今当与汝分别善恶禁戒所趣。谛听谛听善思念之。吾昔一时无央数劫为金翅鸟王。七宝宫殿后园浴池皆七宝成。游戏园观心得自在。所行法则如转轮圣王。内宫妇女状如天人。于百千万劫。时乃入海求龙为食。时彼海中有化生龙子。八日十四日十五日。受如来斋八禁戒法。不杀不盗不淫不妄言绮语不劝饮酒。不听作倡伎乐香花脂粉高广床。非时不食。奉持贤圣八法。时金翅鸟王身长八千由旬。左右翅各各长四千由旬。大海纵广三百三十六万里。金翅鸟以翅斫水取龙。水未合顷衔龙飞出。金翅鸟法。欲食龙时先从尾而吞。到须弥山北有大缘铁树。高十六万里。衔龙至彼欲得食啖。求龙尾不知处。以经日夜。明日龙出尾语金翅鸟。化生龙者我身是也。我不持八关斋法者。汝即灰灭我。金翅鸟闻之悔过自责。佛之威神甚深难量。我有宫殿去此不远。共我至彼以相娱乐。龙即随金翅鸟至宫殿观。看今此眷属不闻如来八关斋法。唯愿指授禁戒威仪。若寿终后得生人中。尔时龙子具以禁戒法使读诵。即于鸟王宫。而说颂曰

  七宝宫殿舍　　庄严极快乐
  行满戒不具　　受此金翅身
  我是龙王子　　修道七万劫
  以针刺树叶　　犯戒作龙身
  我非胎生龙　　湿生及卵生
  转身不退转　　兴显佛法众
  汝今受八斋　　化汝眷属等
  奉禁无所犯　　必得生善处
  我宫在海水　　亦以七宝成
  摩尼颇梨珠　　明月珠金银
  可随我到彼　　观看修佛事
  复益善根本　　滋润悉周遍

尔时金翅鸟闻龙子所说。受八关斋法口自发言。自今以后尽形寿不杀。如诸佛教金翅鸟眷属。受三自归已。即从龙子到海宫殿。彼宫殿中有七宝塔。诸佛所说诸法深藏。别有七宝函满中佛经。十二因缘总持三昧。见彼龙子及诸龙女。香花供养礼拜承事。犹如天上难檀婆那罗金殿无异。龙子语金翅鸟。我受龙身劫寿未尽。未曾杀生娆乱水性。尔时龙子复与金翅鸟。而说颂曰

  杀是不善行　　减寿命中夭
  身如朝露虫　　见光则命终
  持戒奉佛语　　得生长寿天
  累劫积福德　　不堕畜生道
  今身为龙身　　戒德清明行
  虽堕六畜中　　必望自济度

是时龙子说此颂时。龙子龙女心开意解。寿终之后皆当生阿弥陀佛国。佛告智积菩萨。我宿命所行戒德完具。得成菩萨化现自在无所不入。亦入于金翅鸟亦入于龙子。亦入于鱼鳖鼋鼍所化如是

     菩萨处胎经 五乐品第二十九

尔时世尊。观察众生心识所念。欲知如来所经历处。曾生金翅鸟中受龙子教诫。所度无量不可称计。齐是更有余愿闻其意。佛知众生心中所念。将欲示现本所造行身口意法。诸族姓子族姓女。听我所说。昔有天帝释。去世已来经无数劫天福自然。于三千大千诸释之中最尊第一。罗睺罗阿修罗王。生女端正。具足女法六十四能。行步进止不失仪则。面如桃花色。口出言气如优钵莲花香。身作牛头栴檀香。不长不短不白不黑。不肥不瘦具足女法。时释提桓因内自思惟。我今此宫天女众多。颜貌端正诸天中胜。然不如彼阿须伦女。今我宁可集诸兵众与彼共斗。可得彼女给我使令。作是念已即召诸天论说斗事。诸天白帝释。诸天斗战必不如彼。权 可遣执乐神等。手执琉璃九十九弦琴及一弦琴。歌叹我天受福。快乐无量功德。诸天称善此语可从。即敕执乐天子般遮翼等。严办乐具即于天上忽然不现。如有力士屈伸臂顷。已至阿须伦王婆呵前立。弹琴出声作如是颂

  我是天帝释　　绝妙弹琴师
  歌曲音相和　　清净声极妙
  如我彼天乐　　无有忧畏想
  念则衣食至　　七宝甘露珍
  金银床玉机　　转关身回旋
  视乐无厌足　　天中尊第一
  今遣我等来　　欲说无诤行
  并献甘露食　　求欲作婚姻
  我主彼宫殿　　琦珍不可量
  天女为眷属　　非千万亿数
  知婆呵有女　　应与我给使
  若不见与者　　正尔兵众征
  须伦闻此语　　嗔恚极炽盛
  小物兴大意　　乃欲有所为
  我虽无甘露　　豫以自充饱
  亦有大兵众　　足得相距逆

尔时般遮翼等。闻此语已即还。以此语具向天帝释说。时婆呵阿须伦王。即敕左右促集兵众。吾有所伐正尔令办各勿有疑。即以此偈向所敕说

  豪贵天帝释　　遣使般遮翼
  歌颂出五音　　求我为婚姻
  及彼未集兵　　我宜先集众
  往攻不用力　　万得不一失

时彼阿须伦臣佐。闻此教已即集四兵。往诣须弥山腹。坏曲脚天宫。次坏风天宫。次坏马天宫。次坏庄严天宫。时有天子名曰大力。诣释提桓因所。天王。当知阿须伦婆呵集诸兵众。已坏四门天子。天王。今欲如何。时天帝释忆本所诵。口说颂曰

  诸佛威神力　　救护我今厄
  忍慧破恚怒　　解脱安隐处
  昔我无睡眠　　昨日忽眠寐
  此睡非吉祥　　须伦侵我境

尔时天帝释忆佛功德。须伦兵众渐渐却退。从四门后园。入池水中藕茎糸孔中藏。时释提桓因即敕大臣。汝速集兵众。吾欲逐阿须伦兵众。尔时帝释诸臣受天王教。即集天众从四门求觅。但见刀铠弓箭在地。不见须伦众。转转前进直入阿须伦宫殿。见婆呵阿须伦女数千万众。不见阿须伦身。将诸女众归诣忉利天宫。时诸阿须伦等。求哀归命向释提桓因。我等愚惑。不知佛弟子神力巍巍如是。我等先祖信奉如来。闻佛有戒不取他物。今天王释。将我眷属尽填天宫。非佛弟子所行法则。帝释闻之怅然不乐。须伦此语。证我犯不与取戒。我宁当奉禁不犯偷盗。即还诸女。尔时阿须伦王。即以最所敬女奉天帝释。天帝释。即以美甘露与须伦。须伦与天和合共修行善。不杀不盗不淫不欺不饮酒不香花脂粉非时不食。奉持如来三归依法。吾昔所行无数生中作转轮圣王。无数生中作天帝释。无数生中作梵天王。奉持贤圣八关斋法度难救厄。设四天下满中火焰譬如劫烧。一心归命称如来名。持八关斋法投身入火焰不能烧。若满中水水不能溺。八关斋者诸佛父母

    菩萨处胎经紧陀罗品第三十

尔时座中有菩萨名曰信解脱。过去无央数阿僧祇劫为紧陀罗王。须弥山北过琉璃山。琉璃山北过小铁围山。铁围山北有大黑山。紧陀罗王在中治化。过去无数恒沙诸佛。亦不睹见亦不闻法。亦无有圣众教化。无日月星辰光明所照由昔积福一施之报。居在七宝宫殿寿命极长。何以故。本在人间值遇良田。有大长者造佛塔庙。此紧陀罗。布施一刹柱成办庙寺。复以净食施彼工匠。寿终命尽作胸臆神王。在两山中间。自然七宝宫殿屋舍。昔在人间居财无量。有一沙门中时持钵乞食。妇见沙门在门乞食。即擎饭施与。长者见妇与沙门食。即便嗔恚。此何乞人瞻视我妇。当令此人手脚破坏。寿终之后受此丑形。八十四劫恒无手足。在人间时学仙人法在深山中。诵习咒术能移动日月。以夜为昼以昼为夜。呼吸之顷能吐出金银七宝。能使枯树悉生枝叶花果。能使海水消竭。在火不烧身能飞行。眼能彻视自识宿命。知他人心耳远闻声。眷属弟子五百人闻佛出世。佛名清净光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。说微妙法初中竟善。大慈平等功勋难量。我将诸弟子从深山出。飞行经过王宫后园浴池。见诸采女在池洗浴。我及弟子。下见妇女生染爱心皆失神足即堕园中。时我嗔恚故来求佛失我神足。时采女众见五百丈夫尽在园中。寻入白王。王敕左右。将彼人来。我欲问之。寻将诣王。王问言。卿等何人。答曰。我等在山学仙道人。山中诵习咒术。能移动日月。以夜为昼以昼为夜。乃至耳远闻声。眷属弟子五百人。闻佛出世佛名清净光。我将诸弟子从深山出。飞行经过王宫后园浴池。见诸采女在池洗浴。我及弟子。下见妇女生染爱心。皆失神足即堕园中。时王告之曰。汝等在深山学仙道来为久近耶。答曰。二十二小劫。王复问曰。积劫学道心如死灰不动不摇。云何欲心而失神足。答曰。本谓真道神灵第一。踊没自在所念皆成。不图今日忽然失道。惭愧圣王随王刑罚。王告之曰。汝本学道二十二小劫。形枯心疲所习不真。如愚惑人空中求宝。于真际法不获实相。汝所求师如来等正觉者。近在岳跱山中。我当将汝等往至佛所。若佛有所说当奉行之。尔时大王。即严驾羽宝之车具五威仪。将诸眷属及五百仙学人等。往诣岳跱山。王即下车解剑去盖。却五威仪步至佛所。头面礼足在一面坐。尔时国王须臾退坐。前白佛言。此五百人。在山学仙二十二小劫。闻佛出世欲来见佛。飞过后宫贪着欲爱即失神足。唯愿世尊。与说微妙之法。当令还复五神通道。佛告大王。此五百人所行善根。成便坏败终不究竟。本为长者。比丘乞食嗔恚言。使汝无手足。无数劫中作胸臆神王。在大铁围黑山中间。虽复受报日月所不照。先在人间以刹柱施人。以一施之惠与辟支佛。后得人身于山中学仙。欲心炽盛还失神足。此缘久有非适今也。此五百人于今世命终。皆当生无怒佛所。彼佛与说生老病死十二因缘。苦无苦本集灭道果。亦复如是。佛说是时王意开解。亦乐欲生无怒佛所。尔时国王及五百仙人。即从座起礼佛而去

    菩萨处胎经香音神品第三十一

尔时世尊知诸众会心中所念。便入定意无形三昧。随众生音而济度之。昔我人间为香音神王。一阎浮提二阎浮提。乃至无数恒沙阎浮提。男女眷属以香为食。衣被服饰皆悉香熏。或生北方郁单曰土。拘耶尼。弗于逮。在在所生为香音王。或寿一劫二劫三劫。乃至无数阿僧祇劫。知有佛有法有比丘僧。心常远离而不亲近。何以故。贪着五乐以善香为乐。于善香中不闻余音。但闻五欲歌叹戏乐。终日竟夜不知厌足。有善知识昔修善根。从地踊出半身人现。而告我言。此处乐耶。何为贪着。此非真实清净之行。除去香熏可得安隐处。此香为灾为幻为化。今佛在世可往受教。得清净香遍满诸方。香音神王闻之极大欢喜。善哉善哉。善知识。欲导引我示清净香。今正是时佛为所在共往礼拜。尔时踊出地神。即以偈告香音神曰

  如来无所著　　今在南方界
  在胎清净观　　眷属无央数
  烧诸众妙香　　悬缯花盖幡
  供养如恒沙　　戒德甚深香
  遍满十方界　　其有闻香者
  尽得无上道　　汝可将眷属
  往到阎浮提　　一心归依尊
  当自面见佛　　佛德无边岸
  各随本所行　　一闻三句义
  成道不移坐　　三空慧定力
  十八不共法　　大人相好具
  汝后必获之　　紫磨金色体
  软细不受尘　　法身智慧定
  汝当悉具得　　到彼勿怀惧
  正心莫生疑　　勇猛不怯弱
  便逮师子步　　分别身心观
  悉解空自然　　眼识无色本
  除对不造垢　　当行三法门
  现后及中间　　获净三通慧
  总持无碍法　　无常无乐想
  劫数造不善　　慧火弹指烧
  金银宝琉璃　　须弥四宝成
  劫烧火所焚　　行报不可灭
  如来在世化　　愍彼不为己
  处处在在生　　尽缘缚着人
  如人射虚空　　箭穷还到地
  供养诸福田　　不选必贤圣
  亦如服毒药　　处处求解具
  毒气转隆盛　　命终亦不久
  宿有善知识　　授以解药具
  次第不选择　　会值解药法
  行施作福业　　不选择高下
  此福圣所誉　　最尊为第一

时香音神王。闻踊出地神语。心开意解五体投地。汝为我师化我童 蒙 。我今愚惑不别真伪。受我悔过如痴如愚。尔时地神即从地踊出。现佛金色身三十二相放大光明。以神足力接香音神至于胎观。彼诸会众无觉知者。佛告诸来会者。吾从无数阿僧祇劫。能大能小入细无碍。或在天上劫数教化。或在人中代彼受苦。或在畜生饿鬼地狱。分身教化无所不入。时香音神王。及七十二亿眷属。寻发无上住不退地

    菩萨处胎经地神品第三十二

尔时座中有菩萨名曰善业。即从座起偏露右臂右膝着地。叉手合掌前白佛言。欲问所疑听者敢说。佛告善业。恣汝所问。吾当为汝一一分别。善业白佛言。云何世尊。六大众神何者为 妙 。地水火风空识耶。尔时世尊即以神足。令彼地神从地踊出在地界立。水神从水踊出水中立。火神从火踊出火中立。风神从风踊出风中立。空神从空踊出空中立。识神从识踊出识中立。佛告善业。此六诸神汝自问之。善业菩萨即问地神。于六大中汝为妙不。地神报言。于六神中我为最胜。所以者何。所生万物山河石壁树木花果。皆依我住。一切众生有形之类。依而得存。以是义故我为最妙

尔时善业菩萨问水神曰。汝于六神为最妙不。水神报言。于六神中我为最胜。所以者何。若无水者。地为枯干无有滋润。草木花果皆为枯燥。众生之类有形之属皆当渴死。以是义故我为最胜。尔时善业菩萨次问火神。六神之中汝为最胜不。火神报言。于六神中我为最胜。所以者何。若无火者。万物滋长云何成熟。若遇霜雹冰寒雷电。一切众生有形之类皆当冻死。以是义故我为最胜。尔时善业菩萨次问风神。六神之中汝为妙不。风神答曰。于六神中我为最妙。所以者何。若无风者。树木花果根芽茎节不得成熟。一切众生有形之类。进止动摇皆是我风。以是义故我为最妙。尔时善业菩萨次问空神。于六神中汝为妙不。空神报言。于六神中我为最妙。所以者何。山河石壁树木花果。一切万物有形之类。行来进止我能含容。使得调畅通达往来。以是义故我为最妙。尔时善业菩萨次问识神。于六神中汝为妙不。识神答曰。于六神中我为最妙。所以者何。此五大神是我仆从我是其王。行来进止若好若丑。可避知避可就知就。彼皆盲冥我为眼目。以是义故我为最妙。尔时地神白善业菩萨言。此事不然。何以故。恒为识神之所诳惑。不示径路。我欲得坚[革*卬]反与柔软。时复须软反与我[革*卬]。我欲诣南反将至北。贼中之贼不过识神。自称为王此事不然。尔时水神白善业菩萨言。识神所说是事不然。何以故。水能润渍成长万物。我性须冷反与我热。烧炙消尽永无冷性。为识所诳。以是义故识言非也。尔时火神白善业菩萨言。识言非也。何以故。火能熟物亦为光明。树木华果随时成长。若无火者识何所依。以是义故识言非也。尔时风神白善业菩萨言。识言非也。何以故。万物成长行来进止动摇。识制止于我不令动转。以是义故识言非也。尔时空神白善业菩萨言。识言非也。何以故。我空法无物不含。含容万品进止行来。通达无阂皆是我空。若非空者识何所依。以是义故识言非也。尔时世尊问善业菩萨。此六大所论有句义耶。无句义耶。有味义耶。无味义耶。有字义耶。无字义耶。善业菩萨白佛言。世尊。如五大性各各均等。何以故。地界多者水界少者则不成就。水界多者火界少者则不成就。火界多者风界少者则不成就。风界多者空界少者则不成就。空界多者识界少者则不成就。五界等者识不分别则不成就。尔时善业菩萨即说颂曰

  识神无形法　　五大以为家
  分别善恶行　　去就别真伪
  识示善道处　　永到安隐道
  识为第六王　　余大最不如

佛告善业。汝所问者皆是如来威神力故。尔时座上百七十亿众生解识深法。悉发无上正真道意

    菩萨处胎经人品第三十三

尔时座中有菩萨名曰法印。闻如来说六大众生受五阴形。分别内外解了空无。内心生疑。识为乱想非真实法。何者是人。云何是人。人从何生。佛告法印菩萨。善哉善哉。汝所问者。皆是诸佛威神所接。所以者何。过去无数阿僧祇恒河沙诸佛。及当来无数阿僧祇恒河沙诸佛。分别人本假号名字不可思议。非彼二乘罗汉辟支所能筹量。汝今谛听谛听善思念之。吾当与汝具分别说。犹如此娑呵世界阎浮提出众生种。此事不然。何以故。非真实性故非人种。东弗于逮亦非人种。北郁单曰亦非人种。西拘耶尼亦非人种。除无量寿佛及阿閦佛国。除庄严刹土虚空际佛。除我今日诸坐菩萨余诸尽非人种。何以故。从本已来乃至成佛于其中间。初不为恶此是人种。犹如有人修身口业于不修者。是谓人种。受三依法于不受者。是谓人种。奉持五戒于不奉者。是谓人种。修行十善于不行者。是谓人种。向须陀洹于不向者。是谓人种。得须陀洹于不得者。是谓人种。向斯陀含于不向者。是谓人种。得斯陀含于不得者。是谓人种。向阿那含于不向者。是谓人种。得阿那含于不得者。是谓人种。向阿罗汉于不向者。是谓人种。得阿罗汉于不得者。是谓人种。向辟支佛于不向者。是谓人种。得辟支佛于不得者。是谓人种。向佛道者于不向者。是谓人种。得佛道者于不得者。是谓人种。故号人尊如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是谓人种。佛告法印菩萨如今善听。过去诸佛于现在未来。是谓人种。现在于未来。是谓人种。未来于过去现在。是谓人种。于三世法。现在于过去未来。最为第一。何以故。如来于现在中能行过去未来法。何以故。胜过去已灭未来未至法性自然。非过去能灭现在未来。非未来能灭过去现在。尔时世尊即说颂曰

  过去等正觉　　遗教度众生
  分别人根本　　上中下微妙
  现在最胜佛　　明过知未来
  除灭前后结　　独照如日明
  苦行众生等　　两足及四足
  为说甘露法　　充满除众想
  诸天十善行　　从一二十二
  上天下非天　　功德之差降
  如来众相具　　行善无瑕秽
  积德如安明　　清净行无垢
  若人生诽谤　　言佛非真道
  死入阿鼻狱　　诸佛不能救
  口气腥臊臭　　支节烦恼热
  恶念遂炽盛　　斯由诽谤罪
  行善修功德　　识神向善处
  如人入池洗　　清净无尘垢
  罗汉辟支佛　　断灭永不生
  不念吾我身　　去离五道苦
  佛本所行法　　得诸佛印可
  今得为人尊　　故号天中天

世尊说此颂已。语法印菩萨。是谓人种。尔时法印菩萨即从座起偏露右臂右膝着地。叉手合掌前白佛言。善哉世尊。快说斯义。我等众会。于如来所则非人种。云何示现得为人种。佛告法印菩萨。解知诸法空无所有。无彼无此不见彼此者。是谓人种。观察法性无去来今。解知法性空寂无二。是谓人种。于四道果有成就者无成就者。不见有一亦不见二。是谓人种。于众相法。不见庄严亦不见不庄严。解了空寂非一非二。是谓人种。佛国清净除欲怒痴。亦不见净亦不见不净二事虚空。是谓人种。分别道性三十七品。有成有败。不见俗界有人无人。是谓人种。发意弘誓不自为己。安处众生住在无畏。不见有住不见无住二事平等。是谓人种。分别禅定心无染着。执意如空无能移动。亦不见定亦不见不定。是谓人种。众生邪见导示善处。以八正法洗除心垢。亦不见正亦不见不正。是谓人种。于四部众比丘比丘尼优婆塞优婆夷。道心坚固无所恋着。不见戒行有犯不犯。是谓人种。如是法印于如来法。则为饶益利益众生。于佛有反复修诸功德不唐捐弃。尔时座上百七十亿众生。皆发无上正真道意。修于人种不退转行

    菩萨处胎经行品第三十四

尔时座中有菩萨名曰造行。即从座起偏露右臂右膝着地。叉手合掌前白佛言。善哉世尊。快说人种。非前非后非两中间。行业果报以何得知。或过去身非今现在。或未来身非过去。或现在身非过去未来。或内作行受外报。或外作行受内报。或凡夫身作行。须陀洹身受报。或须陀洹身作行。斯陀含受报。或斯陀含身作行。阿那含受报。或阿那含身作行。阿罗汉身受报。或有众生得慈三昧无悲喜舍。或有众生得悲无慈喜舍。或有众生得喜无慈悲舍。或有众生得舍无慈悲喜。或有众生从凡夫地不向信地法地。取须陀洹。或有众生不向信地法地须陀洹。取斯陀含。或有众生不向信地法地须陀洹斯陀含。取阿那含。或有众生不向信地法地须陀洹斯陀含阿那含。取阿罗汉。或有众生不向信地法地须陀洹斯陀含阿那含阿罗汉。取彼此阿罗汉。或有众生向辟支佛。还自坠落堕凡夫地。或有众生向阿罗汉。还自坠落堕凡夫地。或有众生向阿那含。还自坠落堕凡夫地。或有众生向斯陀含。还自坠落堕凡夫地。或有众生向须陀洹。还自坠落堕凡夫地。或有众生于法地退堕凡夫地。或有众生于信地退堕凡夫地。此诸众生于如来所皆有狐疑。唯愿世尊。一一分别令诸会者[火*霍]然开悟。尔时世尊告造行菩萨曰。善哉善哉汝所问义。皆为当来过去现在。亦是诸佛行业果报。吾今一一分别。谛听谛听善思念之。云何造行菩萨。欲使如来说过去无量阿僧祇劫行业果报耶。欲使如来说未来无量阿僧祇劫行业果报耶。欲使如来说现在无量阿僧祇劫行业果报耶。尔时造行菩萨白佛言。世尊。且置过去未来行业果报。欲闻如来现身行业果报。佛告造行菩萨。过去无数阿僧祇劫行业果报。亦是现在作。未来无数阿僧祇劫行业果报亦是现在作。现在所作行业果报。亦是过去未来受对因缘。今当与汝说之。昔我所更苦行无数。或修净行或修不净行。或修天行或修人行。初求佛道诸漏已尽。神通变化[火*霍]然大悟。三界都苦唯我为乐。于尼连水边六年苦行。日食一麻一米。斯由曩昔向一缘觉犯口四过。断绝一施今受斯报。我既成佛为五百摩纳子。恶声诽谤骂詈。在诸街巷称言。佛道非真。时诸国人民有信不信。信者信地法地。不信者外凡夫。如此人等根力成就不可沮坏。佛出于世光明普照。地狱休息饿鬼饱满。在畜生者不复荷负重担。如我弟提婆达兜以石打佛脚指出血。吾时避走东至弗于逮北至郁单曰西至拘耶尼。吾复避之从忉利天上至三十二天。此石故随逐吾。吾复避之还至故处。为石所伤。吾在摩竭国界昼闇园中。闲居经行。时有长者名尸利掘。请我供养我即受请。将阿难一人寻从我行。彼长者舍有七重门。门各有守者。过去未来现在诸佛常法。默然受请不受余请。凡我弟子出家为道行亦应尔。我至彼门。尸利掘长者。于内作倡伎乐自恣。忘我在外已经日夜。佛语阿难。汝行乞食我住此处。时马将从佛边过。佛从乞食。马将言。我无食唯有熟麦当持相与。即持熟麦施与佛。佛即受食之。时彼马将谓为佛食。尔时有天子名曰练精。即接食去。诸人见者谓为佛食。然佛不食为度彼故。故现受食。如是九十日在门里住。阿难。亦九十日乞食。如来威神不令国王及群臣长者知佛住此。何以故。恐彼生慢兴诽谤心。佛无威神余人何望。尔时尸利掘长者。有小因缘出外游戏。见佛在门方问佛言。何时至此。佛告长者。卿前请我。我即来此。汝在内快自娱乐。今已经九十日。欲还昼闇园中。得君供养食马熟麦。时尸利掘长者。极怀惭愧五体投地。唯愿世尊。垂恕不及听我悔过。佛告长者。此缘久有非适今也。尔时长者。请佛入宫舍四事供养。佛为说法诸尘垢尽得法眼净。吾昔一时在毗舍离城。初成佛道未久六师兴盛。吾有弟子千二百五十人。一千一人皆得罗汉六通清彻。时有旃遮摩那耆女。是阿阇罗翅舍钦婆罗弟子。受师明教日来佛所。外现清信女法。内受邪师教。来往周旋欲令人见。以草作腹日渐令大。后以木盂系腹。状如临产妇女。时邪师问言。汝那得此娠。报言。我日往瞿昙沙门所。故有此娠。师便嗔言诳我弟子垂当生梵天。毁辱我弟子乃至于此。时邪师将诸弟子并此女人。往至佛所。当于尔时。如来与无央数众而为说法。梵志至佛所高声唱言。此沙门瞿昙。犯于淫欲实不得道。自称言得道。所作变化皆是幻术。非真实道。指此女人言。众人皆见不也。爱我此女使令有娠。发此语已。时天帝释化作一黄鼠。在女裙里啮盂绳索令盂堕地。众人皆见呵责骂言。汝等师徒谤毁圣人。促出国去。吾昔一时在锦毗梨国。在一树下禅定行道。九十日不移处所。时彼六师名金那金离。有女弟子酸陀难提。兴嫉妒心欲障佛功德自显师道。女言。我能使人不供养佛。令师名声流布无外。时彼女人怀此谋心。日往佛所经数日中。杀身埋精舍后园中。后来出死尸言。佛杀人谤名流布国人皆知。吾昔一时左胁患风。使耆域令治。耆域言。当须牛乳象尿。舍利沙毕钵尸利沙胡椒。煮以为汤服之则差。吾昔一时在他村中游行教化。吾为马枪刺脚。孔上下彻疼痛无量。复使耆域治之。吾昔一时患头痛。犹如两须弥山压头疼痛。痛不可处。今虽成佛诸漏已尽。诸善普集本行不朽。从无数劫修清净行。行业果报。难可得离佛身如是。何况阿罗汉辟支佛。能免行报耶。尔时世尊与造行菩萨。而说颂曰

  最胜四神足　　住寿无数劫
  天地悉坏败　　须弥如灰尘
  行业追逐身　　无处可隐藏
  我成最正觉　　三界无等伦
  故受九报对　　宿行牵连缚
  我有三昧力　　金刚不可沮
  不能避报业　　舍而不受对
  我今生缘尽　　齐是更无分
  永与生死别　　更不造彼行
  人多贪五欲　　不谨慎放逸
  今世亦后世　　常堕有忧处
  涅槃无所著　　示现有为法
  设复不现化　　众生难可度
  八等无为道　　贤圣所行路
  去离诸缚着　　无有生灭法
  道从无常观　　思惟不净法
  一心不移动　　成就诸相好
  罗汉辟支佛　　偿对复甚我
  行业所追逐　　何处可得免
  智慧舍利弗　　常行佛功德
  下肠取灭度　　此是明白证
  神足目揵连　　步步登须弥
  执杖梵志打　　骨碎如芥子
  娑竭阿罗汉　　降伏难陀龙
  临取灭度时　　眼 睛 堕无数
  金花比丘尼　　神德难可量
  化作转轮王　　统领四天下
  舍寿入无为　　支节刀剑解
  辟支名光明　　无佛法出世
  随世尽其寿　　镬汤取灭度
  我今说现在　　此等诸业报
  设当说过去　　阿僧祇佛行
  以劫数至劫　　业报不可尽
  当来复有佛　　令在此座上
  亦当说业报　　如今无有异
  菩萨摩诃萨　　精进不懈怠
  当急离业报　　不与彼共俱

尔时造行菩萨。闻此偈已衣毛皆竖。不乐生死周旋五道。皆发无上住不退转地

    菩萨处胎经法住品第三十五

尔时世尊。见众会寂然清净纯一无杂。出广长舌左右舐耳。放大光明上至无量阿僧祇刹土。众生见光欣然踊跃叹未曾有。尔时世尊还摄光明。佛告弥勒菩萨摩诃萨。吾从无数阿僧祇劫已来。身口意净无有瑕秽。得此实相光明之报。斯由不欺妄故。佛复告弥勒菩萨摩诃萨。我今嘱累于汝菩萨胎化经典。汝当宣传广宣布之。若有善男子善女人讽诵此经。香花供养捣香末香缯彩花盖作倡伎乐。其功德福甚多甚多。若有善男子善女人不能究竟旦暮讽诵。弹指之顷心念此经者。其功德福不可称量。何以故。此胎经者。诸佛之父母众经中长。过去当来诸现在佛。要在母胎经中所化度众生过于色身。百倍千倍巨亿万倍不可称量。佛复告弥勒菩萨摩诃萨。若有善男子善女人礼事供养此经典者。欲得面见十方诸。佛一心归命无他异想。即时得见十方诸。佛若有善男子善女人发大誓愿。我今欲使地狱休息。饿鬼畜生无烦恼病一心归命讽诵此经诸苦恼众生皆得解脱。佛复告弥勒菩萨摩诃萨。我今缘尽无教化处。此经留住或千年。或至二千年或至三千年。令分为三分。一分付与阿难。度我遗法弟子。一分与难陀优钵罗龙王。余一分者弥勒与我宣传。使一切众生普得闻知。无得中断。弥勒。汝作佛时。汝当宣布此经。十方天下众生。蠕动喘息蚑行人物之类。皆蒙此经悉得解脱。弥勒。汝般涅槃后。此经二十一劫流布在世。然后乃断。若有善男子善女人讽诵此经。心不错乱发大弘誓。欲令众生悉同我愿。同时俱生清净国土。承事礼敬诸佛世尊。如愿得之而无挂碍。佛复告弥勒菩萨摩诃萨。汝当承受我教。当念佛恩欲报佛恩者。常当一心奉持供养胎化经典。此功德福无能宣畅。何以故。此胎化经典。诸法宝藏诸佛封印。唯有如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。能开发此印封示现众生。弥勒。当知我前后所说。三昧总持甚深经典。汝忘一字一句此过少耳。若于此胎化经典。忘失一字一句其过甚多。何以故。此诸佛世尊之父母也。尔时世尊说是语时。普地六反震动。时座菩萨各各自相谓言。释迦文佛离法性不久。必当还现如本色相。时座上有八十四亿垓众生。皆发无上住不退转时诸菩萨。忽然不现各离胎化。供养释迦文佛金棺舍利

    菩萨处胎经复本形品第三十六

尔时世尊还摄威神。在金棺里寂然无声。诸天烧香散花供养。时大迦叶将五百弟子从摩伽提国来至佛所。闻佛今日当取灭度。悲啼[口*睪]泣不能自胜。尔时世尊以天耳闻迦叶来至。即从棺里双出两足。迦叶见之手捉摩扪。啼泣不能自胜。尔时迦叶普说颂曰

  一切行无常　　生者必有死
  无生亦无死　　此灭为最乐
  佛所教化人　　所度已周遍
  我行道迥绝　　深恨不见佛
  法界悉皆空　　色身亦当尔
  无有老病死　　无为无所生
  住寿百恒沙　　亦当归灭度
  况我天尊师　　处世着秽污

尔时迦叶及五百弟子。皆绕金棺七匝在一面立。尔时阿难捉棺西北角。难陀捉东北角。诸天在后侍直北。出去双树四十九步。安厝金棺随沙门法。以牛头栴檀香积金棺上。诸梵天王释提桓因。将诸天众在虚空中散花供养。尔时尊者迦叶。手执火然栴檀薪而耶维之。八大国王争分舍利随力多少。各持归供养

    菩萨处胎经起塔品第三十七

尔时八大国王。优填王顶生王恶生王阿阇世王。四大兵马主最豪兵马主容颜兵马主炽盛兵马主金刚兵马主。此八大王共诤舍利。各领兵众列住一面。八大王各各言。佛舍利我应独得之。有一大臣名优波吉。谏言诸王。莫[口*爭]佛舍利。应当分之普共供养。何为兴兵共相征罚。尔时释提桓因。即现为人语诸王言。我等诸天亦当有分。若共[口*爭]力则有胜负。幸可见与勿足为难。尔时阿耨达龙王文邻龙王伊那钵龙王语八王言。我等亦应有舍利分。若不见与力足相伏。时优波吉言。诸君且止。舍利宜共分之。即分为三分。一分与诸天。一分与龙王。一分与八王。金瓮受一石余。此臣密以蜜涂瓮里。以瓮量即分舍利。诸天得舍利还于天上。即起七宝塔偷婆。龙得舍利还于龙宫。亦起七宝塔偷婆。八王得舍利各还本国。亦起七宝塔偷婆。臣优波吉得着金瓮舍利三斗并瓮。亦起七宝塔偷婆。灰及土四十九斛。起四十九七宝塔偷婆。当耶维处亦起七宝塔偷婆。高四十九仞。香花供养悬缯幡盖。终日竟夜音乐声不断。佛之威神令诸七宝塔各各有光明。或夜放光明与昼无异。或昼放光明与夜无异。诸护塔善神各各来营护。不令恶人有触犯者

    菩萨处胎经出经品第三十八

尔时佛取灭度已经七日七夜。时大迦叶告五百阿罗汉。打揵椎集众。卿五百人尽诣十方诸佛世界。诸有得阿罗汉六通清彻者。尽集此阎浮提诣双树间。释迦文尼佛今以舍寿取般涅槃。耶维已讫起七宝塔。今集众欲得演出真性法身。汝等。速集听采微妙之言。尔时五百阿罗汉受大迦叶教。以神足力如人屈伸臂顷。即到十方恒河沙刹土。集诸罗汉得八亿四千众。来集到忍界听受法言。尔时迦叶见众已集语优波离。卿为维那唱阿难下。即受教唱下阿难。卿是佛侍者。今有大过于我等所。卿自知不也。阿难白大迦叶言。不审有何大过于圣众所。迦叶告阿难言。云何阿难。佛所说经。若有得道罗汉六通清彻者。修四神足多修多行。能住寿一劫有余。卿何故默然而不报佛。时阿那律将阿难出在外。须臾复唤阿难前。还旧事具责阿难。尔时阿难心意荒乱内自念言。佛灭度未久耻我乃尔。即思惟四意止四意断四神足五根五力七觉八道。分别苦本集灭道果。即于众前成阿罗汉。诸尘垢灭朗然大悟。圣众称善诸天歌叹。当于尔时地六反震动。诸天散花作倡伎乐。色身灭度法身出世。利益众生多所润及。即使阿难升七宝高座。迦叶告阿难言。佛所说法一言一字。汝勿使有缺漏。菩萨藏者集着一处。声闻藏者亦集着一处。戒律藏者亦着一处。尔时阿难发声唱言。我闻如是一时。说佛所居处。迦叶及一切圣众。皆堕泪悲泣不能自胜。咄嗟老死如幻如化。昨日见佛今日已称言灭为闻。最初出经胎化藏为第一。中阴藏第二。摩诃衍方等藏第三。戒律藏第四。十住菩萨藏第五。杂藏第六。金刚藏第七。佛藏第八。是为释迦文佛经法具足矣。二月八日成佛。二月八日转法轮。二月八日降魔。二月八日般涅槃

菩萨处胎经卷第七


四童子三昧经

    No. 379 [No. 378]

四童子三昧经卷上

        隋北印度健陀罗国三藏阇那崛多译

如是我闻。一时婆伽婆在俱尸那国力士居地娑罗林所二双树间。尔时如来思惟。今日涅槃时到应当取灭。长老阿难即于其夜欻得恶梦。惊怖忧恼驰向佛所。愁惨合掌瞻仰世尊目不暂舍。尔时佛告长老阿难瞿昙弥子。何故如是熟视于我眼不暂瞬。尔时阿难即白佛言。世尊。我于昨夜忽然见梦。身毛为竖甚大怖惧。必是如来涅槃先相。世尊。我既见是非吉梦已。心无情赖深生忧恼。恐畏世尊速入涅槃。佛告阿难瞿昙弥子。故见何梦。知是如来涅槃先相而生惊怖。尔时如来即以此偈问阿难曰

  汝梦何所见　　在娑罗林所
  谓涅槃先相　　彼相为我说

尔时阿难即以偈颂白世尊曰

  昨夜所见梦　　可畏身毛竖
  恐怖心大惊　　世尊今当听
  忽于世界中　　出生广大树
  微妙甚可观　　常有诸花果
  普覆众生界　　其荫甚清凉
  若蒙在树下　　受乐除忧患
  观树得净眼　　闻声得净耳
  成就多功德　　高至于有顶
  彼树出妙声　　具说诸法相
  微妙义具足　　安乐诸众生
  彼树出光明　　如恒河沙数
  充满如是刹　　所照无不遍
  诸有十方界　　无量难思议
  光明所触者　　必当得利益
  彼树出妙香　　普熏十方刹
  若闻此香气　　不堕诸恶道
  亦不堕地狱　　及不堕畜生
  饿鬼阿修罗　　皆至于善趣
  如是大妙树　　安乐诸众生
  摧折力士地　　卧于双树间
  尔时千数众　　无量不思议
  见此大树倒　　悲号而哀泣
  忽不闻彼声　　亦复不闻香
  各不能自起　　我亦迷闷倒
  我昨梦如是　　无量可畏相
  如我所见事　　具眼为我说

尔时净居诸天子。及娑婆世界主大梵天王。并商主魔王子。天主憍尸迦。四天王等并诸眷属。各于住处闻佛世尊涅槃之相。各及八十余那由他眷属诸天子等。前后围绕往诣佛所顶礼佛足。皆悉同声悲号懊恼。忧愁泣泪即向阿难而说偈言

  呜呼大苦哉　　阿难汝具知
  如来双树间　　欲取于灭度
  无灯为作灯　　无归为作归
  欲入于寂静　　无余大涅槃

尔时世尊向慧命阿难及诸天众。而说偈言

  汝贤莫忧苦　　如所见无异
  今夜取涅槃　　在于双林下
  彼之大树者　　枝茎不思议
  具光明香气　　摧折双树间
  如树佛亦然　　今欲诣彼所
  入无余灭度　　如水灭大火
  舍利目连等　　神通智慧最
  二人已灭度　　汝今岂不知
  诸行皆如是　　无常生灭法
  佛知如是相　　知已为众说
  阿难汝当告　　我诸声闻等
  上座尼娄陀　　天眼最第一
  上座迦旃延　　上座俱絺罗
  富娄须菩提　　难低及牛齝
  输那摸伽王　　着粪扫衣者
  难陀罗睺罗　　及余诸声闻
  学无学人等　　及诸余凡夫
  一切速告知　　不久我灭度
  勿于涅槃后　　而生彼苦恼
  有学及凡夫　　不见大生苦
  我慰喻彼等　　晓示真法相
  诸行皆如梦　　无常汝莫忧

尔时世尊如是说已。慧命阿难即以偈颂。白世尊曰

  世尊我迷方　　举身皆战栗
  闻佛欲灭度　　我愁忧不少
  体畏无欢喜　　心益增悲悼
  离欲亦如是　　其眼云何去
  云何告上座　　诸眼第一者
  今日大悲尊　　见已更不见
  我今自忧苦　　云何告彼苦
  上座云何闻　　苦恼大怖事
  学人云何住　　及余诸凡夫
  忧悲箭所射　　愿尊住一劫
  云何于四众　　宣说世尊灭
  世尊为我说　　愿尊住一劫
  大炬逝速疾　　灭没于世间
  世间大黑闇　　世间永盲冥
  我不能告彼　　世间大苦事
  世尊更遣余　　无有忧苦者

佛告阿难瞿昙弥子。汝莫忧苦。诸行性相悉皆无常。尔时世尊即说偈言

  阿难亿诸天　　闻佛欲涅槃
  悉舍天宫殿　　忧愁大苦恼
  侍者汝正业　　汝去告比丘
  我涅槃之后　　懊恼不见我

尔时慧命阿尼娄陀。在须弥山顶为三十三天正当说法。是时即以清净天眼过于人眼。观见大威德诸天子等舍于宫殿。复闻诸天叫唤大声悲号啼哭。复见已之徒众眷属。悉皆四散。时阿尼娄陀正念甚深天眼之明。重复观察诸天子等各及眷属。舍陀欲乐忧悲苦恼。速疾舍离相续而去。时阿尼娄陀更复观见须弥山王及诸山峰。或高百由旬或二百由旬。三百由旬。四百由旬。摧剥崩倒。或五百由旬。或复无量须弥山峰。崩倒堕落大海水中。于彼众生无所损恼亦无伤害。尚不损恼于一众生。况多众生。亦不伤害于一众生。况当伤害于多众生。彼须弥山王所有依住。天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽。闻于如来欲入涅槃。悉皆忧悲生大苦恼。同时趣向俱尸那城速疾急行。当速行处。须弥山峰而自崩倒。音响震动并出声言。今大释种释迦牟尼释中胜王。于阿僧祇亿劫苦行修诸善根。今于力士所生之地。娑罗林所在双树间。欲入无余寂灭涅槃。诸天人等皆当眼灭。彼皆匆遑速疾而行。大须弥山及大海水皆悉挠动。以是事故。此大须弥山王之峰及大山谷。崩倒坠落没入大海。尔时阿尼娄陀正住须弥山顶即发大声。而说偈言

  世间大商主　　众生大福田
  与世间乐报　　此仙今涅槃
  往昔能作大功德　　是大医王治众病
  拔刺无碍无所著　　彼仙今欲入涅槃
  见诸众生多欲患　　轮转无明生老死
  处在牢狱颠倒见　　起大慈悲为说法
  动诸魔众嗔恚来　　猛 毅 锋刃欲加害
  或执大石及山崖　　示现种种恐怖事
  如是等众甚可畏　　见之身毛不惊动
  彼尊能破如是魔　　今欲入灭双树间
  右手舒展指于地　　掁吼聚落及诸山
  彼仙自在大法王　　今欲涅槃双林间
  能打大地出大声　　闻不思议十方界
  彼胜众生大智者　　今欲涅槃双林间
  昔魔兵众大可畏　　已得难动无畏处
  彼大仙人为众说　　转于四谛大法轮
  现诸神通无与等　　一切世界置毛端
  众生不知亦不觉　　彼尊今欲入涅槃
  今已到于力士地　　在于娑罗双林间
  入大寂静三昧中　　欲趣涅槃如火灭

尔时尊者阿尼娄陀说此偈已。以佛神力阎浮提内所有比丘比丘尼优婆塞优婆夷。惟除上座摩诃迦叶及诸弟子徒众眷属。自余二百四比丘众。诸余所有四部众等。驰趣娑罗双树林间。同来聚集礼世尊足。各作是念。我等今者即是最后觐见世尊。时阿尼娄陀说是偈已。应时三千大千世界所有大威德诸天人等。及诸天天子天女。诸龙龙子龙女。及诸夜叉夜叉男女。毗舍遮毗舍遮男女。一切诸天人阿修罗迦楼罗紧那罗摩睺罗伽人非人等。星宿行处。如是等一切大众皆悉号啕。流血洒地面泪满目。心皆迷毒叫唤举声。哀恸大吼骇动天地。忧箭所射心无情赖。惋叹感伤喐吚咨嗟。诸根悲塞顿闷断绝。宛转于地举身战栗。手足垂跢受大苦恼。其间或有相视而哭。或以手拳自拍头顶。掴裂躯面而大号哭。或有转眼或复转膝而大号哭。或按两髀如烧脚足而大号哭。或复唱言呜呼佛陀呜呼佛陀而大号哭。或手拭眼或手扪面而大号哭。苦箭入心号啕哽绝。痛哀悲恼不能自定而大号哭。如是无量千亿众生泪堕如雨。长歔叹息绝而复稣。或合爪掌涕泪交流而复号哭。或以右手搘头涕泪低顿躄地而大号哭。或以左手扣头怅怏忧火所烧而大号哭。或身体萎悴宛转烦惌而大号哭。或掷两手面失本色。迷闷哽塞而大号哭。尔时彼诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。各及眷属驰趣佛所。到佛所已在于佛前。皆悉扑地如斫树倒。或礼佛足或大叫唤。或大号啕宛转于地。或在佛前举双两臂递相攀挛。叫呼号哭并唱是言。呜呼佛陀呜呼大尊。呜呼达摩呜呼大慈。呜呼大宅呜呼大归。怜愍我等救护我等。三界之眼。失路示路。一切世间当成空旷。一切众生当盲无目。大智炬明今日永灭。互相执挽如丧父母亲戚兄弟姊妹儿女。如是种种号啕悲哽呼声大哭。或如是言。呜呼我尊。呜呼我等大善知识。呜呼巧说微妙美言。呜呼行步如师子王。呜呼行步如大牛王。呜呼行步如大象王。呜呼演畅甘露法王。如是种种无量哀辞。悼伤痛切而大号哭。或从虚空扑身堕地。闷绝宛转悲哽号哭。尔时阿难闷绝扑地如斫树倒良久乃稣。在于佛前两手据地。瞻仰世尊目不暂舍。而说偈言

  倍生我苦恼　　以见众生等
  被苦箭所射　　悲号大哭泣
  譬如绝闇路　　商人被劫贼
  忽见大火明　　照于众人前
  更增彼大怖　　无方得驰走
  触处无依怙　　以见火聚故
  以如来灭度　　多众皆悲苦
  如是无救者　　更被苦箭射
  世尊不住世　　余者复涅槃
  最胜人灭度　　我见云何忍
  放炽大光明　　如薪尽火灭
  堕于力士地　　我云何忍见
  今更不复见　　在于竹林下
  及在只陀园　　如常说法时
  云何入毗耶　　离车最胜城
  向诸离车语　　最胜人灭度
  云何入迦毗　　释种最胜城
  告彼不喜言　　最胜人灭度
  云何诣阇世　　摩伽陀胜王
  云何说此言　　如来入灭度
  多数千众生　　数数而哀泣
  云何慰喻彼　　释师子灭度
  比丘比丘尼　　及诸在家众
  云何告此言　　汝释王灭度
  或在经行所　　及入大禅定
  天龙所问时　　无畏云何说
  阿难佛何在　　福田最胜人
  诸上座问已　　世尊我何报
  我为谁敷设　　师子大法座
  复为谁敷设　　大师子卧床
  众中无所畏　　如大师子吼
  复更谁边闻　　甚深无比法
  与谁洗足水　　为谁执袈裟
  最胜人灭后　　更为谁执捉
  谁复大众前　　赞叹我勤劬
  谁复赞叹我　　多闻大智海
  智慧大辩才　　无边众欢悦
  我更对谁闻　　微妙软美言
  彼闻持佛子　　如是伤叹已
  在于佛足边　　闷绝而倒地

尔时世尊告阿难言。瞿多弥子。莫过愁毒莫大迷闷。我于前时已曾语汝如此之义。一切恩爱悉有别离。一切诸行并皆无常。如梦如幻如焰如泡如沫如露。虚妄不实诸行亦尔。汝已知之。瞿多弥子。汝时可起但当速去。可为如来于双树间安置床铺。头向东首高如牛头。面正向北右手搘颊。双树之下偏约南边。如来世尊今后夜分当入涅槃。灭除无余有为身分此之涅槃

尔时阿难啼哭号啕愁毒懊恼泪下满面。奉世尊敕。敷师子床于彼娑罗双树林所。舒安讫已。而说偈言

  我今最后设　　大仙师子床
  于后更不敷　　最胜人卧铺
  我云何忍见　　空林双树间
  最胜人灭后　　寂不见世尊
  诸护林神等　　空守于长夜
  更不见如来　　云何乐住此
  呜呼无常行　　如幻如梦泡
  丈夫教导师　　今日当灭度

尔时尊者阿尼娄陀。即便说偈。告阿难言

  如来先已说　　诸行悉无常
  因缘不自在　　汝强心莫忧
  岂以汝忧悲　　及以啼哭故
  无常事已尔　　智者莫迷闷

说此语已。是时阿难即复以偈。报大尊者尼娄陀言

  无畏尼娄陀　　愿莫作是语
  睹胜人灭度　　尊岂无忧愁

是时尊者阿尼娄陀复更以偈。报阿难曰

  我眼岂无泪　　为之以裁忍
  见万类众生　　多为爱所逼
  又我天眼见　　诸苦恼众生
  为彼等大悲　　是以应号哭
  为利于世间　　不以懊恼故
  是故我语仁　　莫忧当念法

尔时世尊从座而起。一切天人诸龙夜叉乾闼婆紧那罗摩睺罗伽阿修罗迦楼罗等。百千亿众围绕世尊诣娑罗树林。至已右胁卧师子床。世尊卧彼师子床已。时虚空中即雨天华及天末香。作诸天乐亿百千种。又赍世间种种人华种种末香种种涂香种种音声。供养世尊。植诸善业。各口唱言。此是世尊多陀阿伽度阿罗诃三藐三佛陀最后而卧。亦是我等最后观见世尊。于彼刹那罗婆牟休多间。是时东方有一世界名宝鸣主。去此佛刹十千俱致。彼国土中有佛。名曰师子鸣声多陀阿伽度阿罗诃三藐三佛陀。其世界中有一菩萨名善思义。从彼应托来到此土王舍城中摩伽陀国。韦提希子阿阇世王宫内化生。结加趺坐彼既生已。说此偈言

  我从师子吼　　如来刹土来
  闻此有世尊　　释师子在世

尔时空中有一天子。以偈报彼善思义菩萨言

  今者彼人王　　世尊释师子
  于娑罗双树　　欲入于涅槃

说是语已。时善思义菩萨摩诃萨即便以偈。报彼天言

  难计诸佛刹　　百千俱致数
  我从彼土来　　听释师子法
  值彼欲灭度　　当趣双树间
  我不实空来　　到于斯刹土
  我今已来此　　彼尊当涅槃
  诸天等世间　　悉愁况于我
  一念此不住　　应速见世尊
  勿令我空来　　而不得见佛
  善思义劝谏　　摩伽陀国王
  发哀美善言　　令彼心欢悦
  大王听我语　　大人出世间
  王莫放纵心　　速诣于佛所
  于数千亿劫　　或当一遇时
  今既值彼师　　智者莫空过
  愿王勿疑意　　谓我小儿痴
  我非痴小儿　　王自小儿耳
  贪于世欲乐　　杀父造逆殃
  此是小儿痴　　当堕于恶道
  王近恶知识　　调达斗乱人
  随顺彼逆心　　故杀无过父
  王如法无比　　真是佛子俦
  但以有我心　　无智故兴逆
  如此大恶逆　　恐怖事非轻
  以是王必当　　堕大阿鼻狱
  及佛今现在　　未入涅槃间
  当兴供养心　　佛诸舍利骨
  愿王施欢喜　　我欲诣佛边
  来生此土中　　不为受诸欲
  我以闻本土　　师子鸣如来
  称此大仙人　　犹师子灭度
  欲得奉见故　　来生此土中
  诸刹利宗亲　　一时诣向佛

尔时阿阇世王即以偈。告彼童子言

  力士生地去此遥　　不可轻往须严驾
  童子汝但今夜待　　明整兵马安乐行

尔时善思义童子还复以偈。报阿阇世王言

  大王慎莫生懒惰　　我神通力不思议
  我今若欲过东方　　无量佛刹无限碍
  元从所来佛刹土　　经历无量无有边
  其间佛国如恒沙　　力士生地竟何远

尔时童子从阿阇世怀里而起。徒步而行。发王舍城安庠而出。说此偈言

  欲睹清净无过佛　　大力能降最胜人
  汝等随我速往见　　及彼释仙未入灭

尔时童子从王舍城徒步出已。当彼刹那罗婆时顷。有于七万二千人众集聚围绕。复有无量无边百亿那由他诸天众。随彼童子往诣佛所。为欲顶礼如来足故

尔时世尊作人师子右胁卧已。于彼刹那罗婆牟休多间。从彼南方去此佛刹。五百千亿佛之世界有一佛刹。彼佛号曰宝积善现如来十号具足。彼有菩萨名寂静转。从彼刹没。于此世界阎浮提地舍卫城内。生大居士似师子家。即于初生。而说偈言

  于何数亿劫　　割舍其手足
  挑眼破身分　　断截无量头
  妻妾男女等　　一切诸财宝
  于千亿数劫　　求无上菩提
  为度诸群生　　布施广修福
  无量百亿劫　　彼眼者希有

尔时似师子居士。以偈报童子言

  汝为是天龙　　为夜叉罗刹
  汝即生之顷　　分明出语言
  我眷属悉怖　　驰走散诸方
  我闻佛名声　　是故我不走

尔时童子。以偈报居士言

  我非天非龙　　非夜叉罗刹
  汝居士不知　　谓我是世人
  言天龙夜叉　　紧那摩睺罗
  我是天中天　　居士汝当知

尔时似师子。复以偈答童子言

  我心复有疑　　童子我复惊
  闻汝如是言　　同于智者说
  云何天及龙　　夜叉紧那罗
  云何天中天　　童子更重说

尔时童子。以偈报居士言

  去此南方界　　有佛名宝积
  现在如师子　　我从彼处来
  百过作帝释　　自在亦作来
  百过作梵天　　亦作转轮王
  我欲多时说　　一劫或亿劫
  不可得说尽　　智者速诣佛

唯然大居士。汝常应修如此法行。亲近心念广作显示。大居士。何者法行。如来当说。彼宝积善现如来十号具足。有诸菩萨摩诃萨等成就三法。于菩提心得不退转。复当速证无上菩提。何等为三。一者入无边心。二者入甚深智。三者入坚固修行三昧。尔时彼童子欲重宣此义。而说偈言

  若欲入于甚深智　　诸天世人所爱重
  惟有诸佛大名称　　善能知因及非因
  彼句无非菩提者　　此智无有染着处
  舍诸着已离毒箭　　证法智已得作佛
  念心无边无有心　　入如是心得寂静
  随顺是心名为入　　此心名为遍一切
  若破若斫彼不坚　　无破诸法如来说
  诸有犹如虚空体　　如是真如如金刚
  应知如是自性空　　若能修此无所著
  彼即出离烦恼网　　当成正觉离诸有
  当知一切无有知　　当证一切无所证
  当觉一切无所觉　　一切闻声无取着
  入甚深法无法想　　解脱众生无脱想
  广寂无有广寂想　　得证菩萨无道想
  彼真健人除毒箭　　了达众生诸所趣
  知一切故名为佛　　难可辄近无所著

尔时童子说此偈已。于刹那罗婆牟休多时。似师子居士即与眷属二百人俱左右围绕。便发阿耨多罗三藐三菩提心。回向菩提于诸法中得无生忍。十八亿诸天子等。亦发阿耨多罗三藐三菩提心。究竟菩提无有退转。复有四那由他众生。于诸法中远离尘垢得法眼净。尔时童子。复说偈言

  我今不空来　　往释师子所
  于生死怖中　　度那由他众
  有多众生数　　已发菩提心
  住无上平等　　证得无生忍
  我父住法忍　　我母兄眷属
  十八亿诸天　　皆住菩提道
  我得大财宝　　无量不思议
  于佛法转近　　去贫穷稍远

尔时寂静转童子。化其父母及眷属已。出舍卫大城。共其父母并诸眷属。无量百千诸众生等。左右围绕在于众前。趣向力士所生之地娑罗林。所欲礼佛足觐见世尊。尔时如来在于师子床上右胁卧时。于彼刹那罗婆牟休多时。西方去此过八亿百千佛刹。有佛名号乐音如来十号具足。彼佛刹土有一菩萨摩诃萨名无攀缘。从彼佛刹隐灭身已。于此佛刹阎浮提地波罗奈国大城之内。有大居士名善鬼宿。于其家内而忽化生。时无攀缘童子即于生时。而说偈言

  诸法无攀缘　　愚痴觉所转
  彼不脱众苦　　增长诸忧恼
  诸法无处所　　求之不可得
  若尽及不尽　　一切无所有
  虚空无所依　　非空亦无依
  空法因缘无　　因缘亦不无
  彼诸所说法　　深隐难知见
  颇有能说者　　人尊释师子
  大象大师子　　如梵无诸欲
  今日于双林　　将灭世间眼
  在于大众中　　如月十五日
  为众说妙法　　彼更不可见
  比丘众围绕　　如帝释山顶
  自今更不入　　一切诸妙城
  天人中极尊　　法鼓最胜者
  发音令众悦　　我等不复闻
  无我无作者　　如来说是法
  今欲入灭度　　娑罗双树间

尔时无攀缘菩萨说此偈已。波罗奈城一千徒众作如是言。此童子者甚奇希有。智慧辩才无畏深入。生已乃能忆知宿命生生之事。复能巧说种种妙偈。乃有如是大力智慧。无畏难伏净妙辩才。愿令我等得如是智若此童子。尔时无攀缘童子。欲令大众入不退地。世间所无不共之法。希有难得无量无边令彼得入。亦令得入无生忍法。尔时大众白童子言。善哉童子。我等今者随童子去。往诣彼所觐见世尊并欲供养。尔时无攀缘菩萨摩诃萨。共彼眷属徒众百千围绕恭敬在于彼前。从波罗奈大城而出径诣佛所。为欲觐见及供养故

尔时于彼刹那罗婆牟休多时。从于北方去此佛刹。过六万四百千亿佛土。有佛名曰住菩提。分转如来十号具足。于彼佛刹有菩萨摩诃萨。名曰开敷神通德。从彼没身生此刹土阎浮提中毗耶离大城大将师子。于彼家内忽然化生。尔时开敷神通德菩萨摩诃萨生彼家已。即说偈言

  颇闻佛世尊　　增长释种家
  度脱诸厄难　　无量百千亿
  颇闻佛世尊　　无边智慧海
  精进及禅定　　甚深达彼岸
  如来拔毒箭　　得忍心调柔
  为众常说法　　亦不着法相
  颇闻佛世尊　　不着于三界
  世间行不行　　智慧遍一切
  欲界及色界　　乃至无色界
  能以智称量　　彼眼者在不

时大将家有一天女名转菩提分。化作人形现童子前。以偈报童子言

  世尊住一劫　　或复过一劫
  汝后当见佛　　今且受五欲
  食胜妙福禄　　犹如大王家
  种种妙音声　　歌舞作倡等

尔时童子具知如来已益众生。诸天人等善根成就。以偈报天女言

  彼愚痴众生　　乐于五欲乐
  不闻正遍知　　及诸佛教法
  我不受五欲　　五欲无坚牢
  五欲如刀剑　　谁能信五欲
  猪狗及野干　　骡马牛驴等
  此辈贪五欲　　诸佛声闻诃
  盲瞎根残缺　　痤陋及挛跛
  如是等贪欲　　诸佛声闻诃
  蚍蜉蛱蝶蝇　　俱[翅-羽+只]罗孔雀
  如是等行欲　　我胜彼故诃
  譬如大火坑　　炽然阎浮满
  彼如盲坠堕　　贪欲亦如是
  诸欲无常苦　　智者所呵责
  若人不知过　　此等为欲转
  我不受五欲　　世尊已证知
  能闻此义者　　当知彼如佛
  我从佛边闻　　彼须弥山王
  于后夜分时　　彼佛当灭度
  我等速往诣　　尽诸结使者
  欲见者可去　　恐彼世尊灭
  转菩提分尊　　最胜人所说
  于亿千数劫　　难逢种善根
  若于涅槃所　　觐见释种尊
  闻释师子法　　当生善种子
  若天人夜叉　　往至如来所
  若爱释种幢　　速见大名称

尔时开敷神通德童子菩萨摩诃萨。说此偈已与诸众生无量百千左右围绕最居众首。从毗耶离出径诣佛所。欲礼佛足亲觐供养

四童子三昧经卷上四童子三昧经卷中

        隋北印度健陀罗国三藏阇那崛多译

尔时世尊。右胁卧于师子床上。时四童子从四方来。各与大众前后围绕。导在众首悉皆平等。智慧神通威德法行。无所差别不乖毫毛。共趣佛所往到佛前恭敬合掌。彼四童子到佛边时。各随城邑所从眷属。一切天人百千众生杂类。皆悉合掌一切静心。欢喜踊跃曲躬瞻仰向四童子。彼四童子当于来时。四方纵广满一由旬。诸天雨华遍满于地。鼓天音乐种种百千。诸天歌咏赞叹无量。尔时多陀阿伽度阿罗诃三藐三佛陀。普于四方自然显现四师子座。尔时尊者阿难。以偈白佛言

  世尊何因缘　　一切智四边
  右胁现四床　　师子广大敷

作是语已。佛告阿难。阿难。汝见此四童子已不。从四方来面如满月。过日光明蔽四天下。威德特尊齿白明耀。发智慧光得大精进。入甚深智成就功德。识智了达有深信行。谦卑惭愧行业满足。意见深远得正念定。智慧善巧有大方便第一总持。为诸众生随顺说法增长善本。于无量亿百千佛所种诸善根。各住四方各于佛刹闻我涅槃。各从彼刹诸如来所。咨发启请生此刹土。欲闻见我及我名称。说法利益功德之事。观看今日如来后夜分时。于力士生地娑罗双树间。当入无余涅槃。不思议涅槃。一切世间无等涅槃。一切世间希有涅槃。一切世间安乐涅槃。一切世间难伏涅槃。一切世间断离诸趣清净涅槃。如来当取如是微妙最上涅槃。阿难。此东方来童子者。其色微妙具大功德端正可喜。光明遍照威德炽然。犹如盛火放大光明。以多百千徒众围绕。及以亿数诸天之众。所共供养受天雨华。来诣佛所欲供养佛。阿难。此童子者。于彼师子音鸣声如来国土。曾作转轮圣王领千世界而得自在。诸天人等之所供养。彼治化时于欲界天上及于人间。恒多讲法受持句义。为于无量百千众生解说妙趣。成就彼等种诸善根。得诸神通达解法行。众圣咨嗟无边无断。最上微妙得无畏力。深入法相成就辩才。智慧善巧得到无边智慧彼岸。满足如是诸法行已。于十八亿年如法治化。不用刀杖恼乱众生。不为受欲贪于王位。于彼十八亿年成熟十八那由他众生。令住阿耨多罗三藐三菩提。于菩萨法得不退地。彼善男子。从初发心得不退地已。乃至毕竟成就阿耨多罗三藐三菩提。彼王如是。于后一时剃除须发。着袈裟衣舍家出家。即出家已。于八十一亿年行于梵行。从出家已未尝坐卧况复睡眠。于八十一亿年中。乃至不起一念欲想及于嗔心。况有杀害恼乱等心。无不善事及憎爱想。亦复不念修行不修行想。常住二法。何等为二。一者虽得肉眼无肉眼想。虽能分别知诸法聚。而不取着法聚之想。于彼八十一亿年中。更不论说诸无利益。他余事想。若地想水想火想风想。若虚空想及识想。若妇女想及丈夫想。饥渴想聚落想。空闲处想城邑等想。违逆之想不违逆想。远离想禅定想。自我想他我想。色想无色想。边想中想。生想灭想。少想多想。如是等诸余乱想。皆悉寂灭不生分别。惟除二十箧藏法本。思量修习其间成熟八万那由他众生。决定于阿耨多罗三藐三菩提。彼诸众生皆初发心于如此刹。即刹那罗婆时。于彼佛刹自在而去。各更别往诸余佛刹。到彼诸刹世尊所奉觐承事。于彼世界一一佛刹。一一身到一身一事无二并者。彼诸刹土一一诸佛皆同。于此一刹那罗婆时右胁而卧。同于此日后夜分中当入涅槃。悉在娑罗双树之间力士生地。皆如如来彼诸佛等。同名释迦牟尼十号具足。彼诸佛等亦同出于五浊恶世。阿难。我以如是无量无边无碍肉眼正知正见。非诸声闻辟支佛等之所能入。非境界故。阿难。若有比丘比丘尼优婆塞优婆夷闻此法门。闻已生信。羡我肉眼正知见智。欲得此智乃至满足一切种智。及发一念正信之心相续不舍。适发心已即生无量福德之聚。况得无量无边大功德聚。阿难。若有善男子善女人。于十八那由他诸如来所。复于十八那由他亿年。以一切乐具供养恭敬尊重赞叹。亲承奉事彼诸如来。于十八那由他年。所得功德虽复无量。犹故不及闻此法门羡愿之心生功德者。不可譬喻。阿难。此童子者。于我法中一日一夜教化利益无量众生。何况多时所作利益。若舍利弗目犍连等及余声闻。不能如是多作利益度脱如是无量众生。阿难。假使汝等一切寿命。多诸众生说法教化。不念余事昼夜不休。虽作如是教化利益。但自汝等于我法中。不能荷负佛法重担。如今所见此来童子所荷负者。又复告言。如是阿难。如是童子。为诸众生作大利益具足怜愍。念诸众生饶益众生。而此童子有无量功德。阿难。汝见从南方来童子已不。如秋满月十五日夜光明炽盛。右手执持众宝。庄严杖打此大地。打大地已出如是声。譬如摩伽陀国有一宝器。或用金作或用银作。作之成就善加莹治。无有尘垢无有瑕隙无有破漏。善好明净无有尘土无有脂腻。种种因缘众事所成。种种功能练精。明净五处具满十处。远离一千分观瞻。远离十二处金银烦垢。种性真正金性最胜。百练所成新成非故具。足八分一千巧匠。一心观瞻尘腻垢翳一切悉无。如是妙器打之出声。若闻声者能灭众苦。阿难。如是譬喻如是器声。我少说耳。而此童子。众宝间错严洁之杖。打此大地所出之声。亦复如是。阿难。此童子者名寂静转。是大菩萨摩诃萨也。从南方宝积现多陀阿伽度阿罗诃三藐三佛陀刹土而来。彼佛世界名宝庄严。阿难。于汝意云何。彼世界何故名宝庄严。阿难。彼佛世界。无一众生住不定者亦无邪定。阿难。彼诸众生。皆悉正定于阿耨多罗三藐三菩提。阿难。彼刹是菩萨刹。彼刹众生无男女想。阿难。彼诸众生皆悉梵行。无诸秽欲智行清净。乃至无有秽欲之名。阿难。彼庄严佛刹诸众生等。无有一切不善思想。亦无食想唯有二食。何等为二。一者以定慧为食。二者以法喜为食。阿难。彼佛刹不说五阴不说三乘。惟广演说一切智阴菩萨箧藏。阿难。以是义故。彼佛世界名宝庄严。阿难。此土所有他方佛刹众生生此土者。复有愿生彼佛土者。愿生之者彼众生等。皆得不退转于阿耨多罗三藐三菩提。阿难。或有菩萨从余佛刹来生彼者。生已即自能知彼佛刹内一切诸事。彼等菩萨亦生彼已。即于刹那罗婆牟侯多时。各各想己自身是佛。阿难。彼宝积现如来。为彼无量无边那由他诸菩萨摩诃萨等。广说一切种智及菩萨箧藏法门。不曾断绝更不说余。阿难。假使我于无量千劫。说彼佛刹功德之事。及一一分别菩萨摩诃萨等所得胜法。所谓发愿庄严佛刹不可得尽。阿难。我但略说彼佛世界功德名字。此寂静转菩萨摩诃萨。从彼方来为欲看我入般涅槃。复为怜愍无量无边诸众生等。令发无上菩提之心。复为欲显彼刹功德庄严之事。复为显彼宝积现佛利益名称。所谓显诸菩萨法行大事。亦说真实名称之事。欲令此刹无量无边诸众生等摄受正法故。来到此释迦佛刹。为令未来诸菩萨等生欢喜心。阿难。此童子者。于往昔时行菩萨行。值燃灯佛出现于世。尔时曾作转轮圣王名曰降怨。阿难。尔时降怨圣王。为无量亿无边众生。说于正法成熟善根。时彼圣王。从旦日初至于食顷。化度三十六亿众生住不退地。于阿耨多罗三藐三菩提。入正定聚证得无生忍法。而此圣王于彼燃灯如来般涅槃后。发大精进剃除须发舍家出家。既出家已满一千年。续燃灯佛转正法轮。然彼圣王利益无量无边众生。作利益已于后一时日没之顷。复化三万六亿众生。令住阿耨多罗三藐三菩提。还于日没之时。令七万那由他众生皆悉漏尽成阿罗汉。况当证道见谛学人不可称计。阿难。假使我欲以佛智慧。说此寂静转菩萨童子。往昔之时为诸众生作利益事。不可得尽。阿难。汝为此寂静转善男子。就于我前敷座安置。汝当得无量无边胜妙功德。若有众生闻此寂静转菩萨名者。彼等众生。如现在见佛等无有异。阿难。若有众生闻此功德庄严受记法本名字者。乃至一念发净信心。为欲见彼宝积现如来多陀阿伽度阿罗诃三藐三佛陀。为欲承迎礼拜亲近供养。有发心者欲闻法者。阿难。我今皆与彼等受记。往生彼刹奉觐如来闻于正法。彼佛刹中所生菩萨。亦欲同行彼诸法行。惟除愿力菩萨摩诃萨等。阿难。彼诸众生善得大利。若能闻此所说功德庄严法本名字。乃至经耳。何况闻已得净信心。阿难。如是等法句如实不虚。汝当善护善念忆持。所以者何。阿难。阎浮提人。未曾得闻如是等修多罗章句及以名字。阿难。若名字菩萨及谤法人。如是人等莫令得闻。何以故。以其谤法罪大深重故。阿难。汝见西方如是辇舆众宝庄严乘空而来。汝见已不。阿难白佛言。如是已见。佛复告阿难汝见其间一童子不。二足神通变化所作。腾空飞来动此大地。动大动震大震。大地动时所化众生怖畏毛竖。阿难报言。如是婆伽婆。如是修伽陀。我今见已。此童子者。神通游戏种种示现乘空而来。佛告阿难。如此辇誉众宝间错。在童子前而来。出于种种异妙之香。满此佛刹。阿难白言。如是婆伽婆。如是修伽陀。佛复告阿难言。此事还是彼善男子智力所现。能使辇舆出是妙香。阿难。汝听复能出于四种之声。所谓空声无所有声寂静声佛声。阿难白言。如是婆伽婆。佛复告阿难。还是童子毛孔所出如是等声。阿难。此声出时有六十八那由他众生大得饶益。复千世界诸众生数有多众生。于无为法心漏永尽便得解脱。阿难。闻一佛名。已有九亿菩萨住不退转地。得入圣道于阿耨多罗三藐三菩提。于此刹土人天世界。有二百千那由他天人得阿毗跋致地。决定住阿耨多罗三藐三菩提。阿难。此善男子所住。西方有佛名曰喜乐音多陀阿伽度阿罗诃三藐三佛陀。世界名乐毛。从彼刹来欲见如来入于涅槃。此善男子。然其来已为于无量无边众生作大利益。阿难。今善男子。来此刹时大作佛事。亦如如来转大法轮。彼亦如是转大法轮。阿难。此善男子。乃从阿僧祇劫已来诸毛孔中恒常出此四种之声。所谓空寂等声。于一一声中为无量无边众生作大利益。阿难白佛言。世尊。此善男子。往昔之时作何善根。乃能于诸毛孔出如是诸声。佛告阿难。我念往昔过去无量无数劫。时有佛出世名无垢眼善逝世间解无上士调御丈夫天人师佛世尊。此善男子。于彼佛所出家作大沙门。名曰智乐。净修梵行而彼沙门于彼如来。问于真理难知智慧甚深句义。所谓不生不灭。一切诸法空无所有。一切诸法本性寂静。一切诸佛皆同一体。而彼沙门七日七夜相续不断。不念疲惓不念余事不舍重担。于此四句躬自受持。善味讽习善持通利。善意贯穿研精己行。阿难。彼时沙门者。此童子是也。以此四句妙义亿数诸佛所共说之。入诸佛法摄诸众生。复自然得觉了之事。而彼沙门愍诸众生。缘诸村舍聚落城邑为彼说法。阿难。尔时法师智乐沙门者。以多闻知法义趣。复以真心六年为他宣说如是法句。以是因缘于阿僧祇劫。从诸毛孔出如是声神通。以是事故。此善男子。从身毛孔出如是四种法声。为多众生作大利益。如是次第。此童子者。于阿僧祇劫身毛孔中。成就如是四种妙声。阿难。阎浮提人得大善利得第一利。若闻此无攀缘菩萨名字者。已获善利况闻其法。阿难。若有善男子及善女人。或在天中或在人间。闻此无攀缘菩萨乃至名字已得净心。所得功德不可思议。何况瞻对觐觌见者。所以者何。阿难。此无攀缘菩萨摩诃萨。于诸菩萨地已得功德。不可思议不可称说。阿难。而此菩萨摩诃萨。故欲来见如来入般涅槃。阿难汝今可为彼大菩萨。施设床敷于如来前。用拟此善男子坐。阿难。汝当得大安乐利益。亦当速得胜妙神通。阿难。汝设此敷业因缘故。所获果报或坐或卧常得安隐。于一念顷。当现证得阿罗汉果无为圣法。阿难。汝于无漏声闻圣果未证入者。我今与汝授记当得。汝复应有诸功德分。回向阿耨多罗三藐三菩提。当得诸佛如来大法。阿难。若有比丘比丘尼优婆塞优婆夷。若天若龙若夜叉若犍闼婆阿修罗迦楼罗紧那罗摩睺罗伽人若非人。及余众生闻此寂静转所说授记。闻已得净深心及信解者。若复有人欲得闻此寂静说授记法门。或如来边闻。或声闻边闻。复能为彼法师。敷设床座所得功德。如彼法师坐此座上。复当说斯寂静说授记法门。如斯无异。所以者何。阿难。彼人敷设座已。当得十种敷设功德。何等为十。一者当得转轮圣王座。二者得帝释座。三者得梵天王座。四者得世主座。五者世世于诸佛所得法师座。六者菩萨地满既得位已。在道场菩提树下。坐于莲华师子高座。七者证一切智已。得无上菩提坐于佛座。八者转大法轮时。得无量亿数诸天所共庄严转法轮座。九者欲现大神通时。过出一切诸世间道。为得如来无上显现最大神通师子高座。十者欲现入于大涅槃时。得彼多陀阿伽度阿罗诃三藐三佛陀。令诸天龙夜叉犍闼婆阿修罗迦楼罗摩睺罗伽人非人等。心生欢喜得清净信。最后寂灭一切诸行。住金刚三昧得如来座。阿难。汝当得如是等十种师子高座果报。阿难。若有善男子善女人。净心闻此寂静说受记法本句偈之义。为于法师敷设法座。爱敬尊重彼法师故。以是因缘。彼彼成就十种师子敷座果报。以是义故。阿难。汝应可合掌向无攀缘菩萨边。汝应当得大利安乐大福德聚。因此功德汝速当得发于神通。尔时尊者阿难。为无攀缘善男子敷法座已。合掌向无攀缘菩萨摩诃萨。生清净心尊重心惭愧心。即于尔时。而说偈言

  合掌向健儿　　降伏龙入定
  大智众王者　　无攀缘光明
  得智及精进　　智慧禅定聚
  世间无等侣　　向无畏合掌

尔时世尊以偈告阿难言

  汝今敬合掌　　供养无攀缘
  所获诸果报　　我当为汝说
  阿难合掌敬　　自我涅槃后
  于村舍聚落　　及我弟子间
  或于入聚时　　或出彼村落
  及经行坐卧　　一切威仪中
  当作大佛事　　汝于诸世间
  所有众物类　　或识及无识
  悉皆向汝边　　恭敬而伛身

若男若女天男天女。及诸外道波利婆等。若沙门婆罗门。若王大臣若国师。若兵将及余官属。若长者居士。自余凡类但是有形。乃至六畜象马走兽及诸飞鸟。若见汝者皆得净信。一切树木药草苗稼所有华果。悉皆向汝伛身恭敬。一切台殿屋宇重阁。楼橹却敌窍孔车乘辇舆。以汝福德威光之力覆蔽于彼。皆悉如是向汝伛身。阿难。譬如多陀阿伽度阿罗诃三藐三佛陀。初证阿耨多罗三藐三菩提得无碍解脱时。一切苗稼树木药草及诸华果。乃至略说人非人等。周匝充满菩提道场。皆向如来伛身恭敬。阿难。如是如是。汝今以此于无攀缘善男子边合掌伛身因缘力故。汝于却后一切威仪随所在处。人非人等一切苗稼树木。药草皆当向汝伛身恭敬。阿难。若有善男子善女人。于如来涅槃之后。或于我今现前之顷。须臾闻此庄严说授记法本。乃至一合十指掌一念因缘。或以真心思惟此义发一信心。彼人尚得如是福报如我前说。如是阿难。当来之世少有众生得闻此法。亦复少有但闻如是法本名字。若一闻再闻尚不可得。何况闻已得真信心恭敬尊重不生诽谤灭除疑惑。思惟修习生实想者。我于如是善男子善女人等。复以佛眼悉皆现见。复以佛智悉皆现知。如是人等。非于一佛所修行供养。非一佛所种诸善根。阿难。今在此众集会我前。一切大众天人男女故来。欲见如来世尊入于涅槃。阿难。如是等众。于当来世弥勒菩萨初欲证于阿耨多罗三藐三菩提时。受智位已后乃至坐于菩提道场。设大供养尊重恭敬。如是次第乃至弥勒世尊入涅槃时。亦复观看。还于尔时在如来边。亦复得见此四童子如是听法。如今我前得见得闻无攀缘善男子。于毛孔内广闻大法微妙之声。得闻声已生大欢喜。是故阿难。汝今得闻说如是等微妙义趣。汝应数数伛身合掌净心敬信。所以者何。汝以如是净心敬信善业因缘。所在之处一切众生诸天世人。恭敬供养尊重赞叹躬伛汝边。乃至于汝涅槃之后。诸天世人起塔供养汝之舍利

尔时世尊告阿尼娄陀言。阿尼娄陀。汝见上界有四十亿诸天人众。闻此经典皆悉合掌伛身而住。阿尼娄陀白佛言。如是婆伽婆。佛复告阿尼娄陀。彼天人等。因闻此法信心合掌伛躬善根。于未来世阿僧祇劫不堕恶道。或在天上或在人间。于恒沙世流转生已。一一得作转轮圣王。一切生处恒值诸佛。于诸佛所成就善根。成善根已乃至得证阿耨多罗三藐三菩提。同一名号。名为一切众类伛身多陀阿伽度阿罗诃三藐三佛陀。说是语已。时大众中。有诸力士及其眷属各有五百。其名曰娱乐力士。头俱耶力士。大力力士。天威力士。胜天力士。郁干蹉力士。无畏力士。婆薮力士。真实力士。优多罗力士。婆俦力士。一切忍力士。如是等一一力士。各及眷属五百围绕。聚集来会在其众首。为欲供养向如来所。皆半伛身合掌悲泣。哀哽大叫流泪雨面。而白佛言。世尊。我等今者。为欲供养如来世尊。及无攀缘童子菩萨。并余无量大菩萨等。乃至一切大德声闻。此修多罗微妙句义清净法门。为供养故合掌伛身。世尊。我等以此一念善根。回向阿耨多罗三藐三菩提。尔时世尊即便微笑。诸佛法尔若微笑时。即从口出种种微妙杂色光明。所谓青黄赤白金色玻璃放斯光已遍至无量无边世界。光明所照乃至梵宫。还来旋绕世尊三匝从佛顶入。尔时慧命阿难。见是事已即以偈颂。而白佛言

  世灯何因放　　如此大光明
  善哉决我疑　　及余众生等

佛告阿难。汝见已不。此力士子。一心集聚合掌向我及无攀缘童子菩萨。并于此经至心净信。复发无上大菩提心。阿难白言。见已世尊。佛复告阿难言。此力士子。从今已后阿僧祇亿劫不堕恶趣。然后证得阿耨多罗三藐三菩提。尔时世尊。欲重宣此义。而说偈言

  阿难汝不见　　摩罗子集聚
  心生大欢喜　　曲躬而向我
  欢喜说此言　　当得无上道
  大智力士子　　此等供养我
  及于无攀缘　　于法生尊重
  我诸声闻等　　如是合掌已
  阿僧祇劫数　　当不堕恶道
  因此合掌业　　及向我曲躬
  假令一劫说　　或无数亿劫
  此等当证道　　成就诸佛土
  行于最胜行　　其数不可测
  于亿数等劫　　思量不能知
  阿难今不久　　于此后夜分
  吾共汝等别　　是最后相见

佛复告阿难。阿难。汝见从北方有大金光照耀来已不。彼之威光映蔽一切。其方所有树木苗稼药草华果。山崖堆阜台殿楼阁。辇舆车乘人非人等。于上虚空皆成一色。所谓金色。阿难白佛言。如是婆伽婆。佛复告阿难。汝见北方复有七阎浮檀金辇舆从彼来不。中央辇舆其上童子结加趺坐。威光最胜功德巍巍。阿难白佛言。如是婆伽婆。我今已见。佛复告阿难。北方去此刹土六十四百千俱致。有佛刹名曰俱苏摩拔坻(隋言多华)。彼刹世尊。号名菩提分转多陀阿伽度阿罗诃三藐三佛陀。彼佛刹中有此童子菩萨摩诃萨。名曰华敷神通德。从彼舍身来生此土。阿难。彼世界出诸法声。名曰菩提分音。彼处众生有闻声者。成诸善根。阿难。彼菩提分转如来。从证阿耨多罗三藐三菩提已来。六十四千劫现在说法。阿难。彼如来无有声闻众唯菩萨众。阿难。譬如灌顶转轮圣王多有诸子。彼诸子等。为作大臣。为作国师。为作诸小国王。如是如是。彼佛如来诸菩萨等亦复如是。亦名为子。亦名大臣。彼佛亦尔。有二菩萨最为殊胜。于诸菩萨独为侍者。还以菩萨而为僧宝。阿难。如是次第说彼佛刹。皆悉菩萨满彼国界。阿难。彼佛世界资生所须。皆悉丰足无所乏少。具足无畏安隐快乐。微妙可瞻人民充满。菩萨功德皆悉满足。住诸神通最为殊胜。以三昧力周旋往返。犹彼朋友智慧之聚。最为殊胜智藏满足。常能修习菩提之心。常能讲论一切智法。于诸菩萨一切深法。无量无边皆悉证得。阿难。如是等诸菩萨摩诃萨满彼世界。彼佛刹中此华敷神通德菩萨摩诃萨。善男子。来生此土阎浮提毗舍离城。彼善男子。今现神通而来此者。为欲顶礼如来足故。又欲观见如来世尊入大涅槃。阿难。此大光明现者。是彼如来多陀阿伽度阿罗诃三藐三佛陀威神之力。阿难。所谓此七阎浮檀金辇舆者。是彼如来。七菩提分助道法故为作化现。阿难。此阎浮提有无量千俱胝诸众生诸天人等。共此童子往昔已来同种善根而此童子亦生此间阎浮提时。令彼众生即得欢喜踊跃无量。复有众生当得漏尽。或有众生当得学地。或有众生得无学地。或有众生未发菩提心者。当能令发菩提之心。或有众生发于本性不退忍心。阿难。如此童子。处中辇舆加趺坐者所出光明。此之光明是彼如来神通威力之所现耳。从此光明出生彼之六辇舆也。阿难汝看以彼如来威神之力。此华敷神通德菩萨摩诃萨。能于此处现种种神通。又此光明之力。于此世界能为无量无边诸众生等。作大利益。所谓以彼正法共相摄受。尔时彼童子等。悉皆和合欢喜踊跃。复与无量百千众生前后围绕。于一刹那之顷雨种种华。诣向佛所到已顶礼佛足。尔时世尊告慧命阿难言。阿难。如来为诸众生所可作者。及如来长子诸菩萨摩诃萨等所应作者。我于今者皆已具足。我为众生所作利益者今已作竟。阿难。此华敷神通德菩萨摩诃萨。在于阎浮檀金辇舆中俨然而坐。所作神通以如是等。教化那由他众生证于阿罗汉果。复教俱胝那由他数众生已得学地。复有百俱胝数众生。令于三宝得生净信受持五戒。复有七百俱胝诸天。令得住于不退转地。决定当得阿耨多罗三藐三菩提。复有七俱胝众生令住无生法忍。复有无量阿僧祇那由他俱胝众生。当令值遇弥勒世尊初首法会

四童子三昧经卷中四童子三昧经卷下

         隋 北印度健陀罗国 三 藏阇那崛多 译

尔时慧命阿难白佛言。世尊。惟愿世尊。或住一劫或减一劫。怜愍此等诸众生故。所以者何。如来多陀阿伽度阿罗诃三藐三佛陀。若住世者。如是大事常现于世。又令是等真善大士。数数往返阎浮提内。我等众生复应于此如许时间。当见此等菩萨大众承事供养。又于此时。如是经典复应当得广行流布。复如许时。我等得闻合佛法义。如许时间。令我得见如来世尊及大士等种种现化神通之力。若如来今日不住于世入涅槃者。我等众生。于如来世尊灭度之后远离三事。何等为三。所谓不见佛。不闻正法。三者不见此等大士弘广之心。亦复不得承奉供养。有如是失。慧命阿难说是言已。悲号大哭忧叹懊恼。涕泪满目宛转在地。如斫树倒。并唱是言。我等速疾共佛别离。诸善知识亦复别离。尔时众中有菩萨摩诃萨。名曰善思义。以偈白慧命阿难言

  阿难莫忧恼　　诸行悉无常
  世法欲常者　　此处不可得
  若言有诸行　　此言不可得
  如是诸法空　　汝今何忧苦
  诸智皆悉空　　于佛智亦空
  佛尚不可得　　汝今何忧愁
  汝莫生分别　　智者舍分别
  诸有如虚空　　如阳焰似水
  亦如幻师化　　象马诸乘等
  园林众聚落　　树木诸花果
  世谛亦如是　　如幻化无实
  诸佛及声闻　　亦如是不异

尔时慧命阿难。以偈报善思义菩萨言

  如是如所说　　诸法无有相
  此最为胜法　　我今最后闻
  云何向舍卫　　所问我何报
  阿难佛何在　　世眼何时来
  我昔往彼处　　常见佛世尊
  今往彼处空　　大智我那住

尔时寂静转善男子。复向慧命阿难。以偈白言

  汝于亿年哭　　此事难可得
  阿难汝谛观　　法界难见处
  譬如芭蕉茎　　叶叶皆除去
  其间无有实　　法体亦如是
  犹如天降雨　　普下诸水渧
  泡起已还灭　　诸有为亦然
  如水沫揣聚　　有眼者观见
  此处无有实　　世相亦如是
  譬如镜中像　　其体无有实
  三界世相尔　　智者莫涕泣

尔时慧命阿难。以偈报寂定菩萨摩诃萨言

  我非不知此　　如汝智者说
  三相皆无常　　经中大仙说
  但此亿数天　　泣泪皆啼哭
  向我边叫唤　　以是生我苦
  世尊不久去　　舍我等眼者
  我等何趣向　　谁能救护我
  正法从谁闻　　寂静深无比
  我今供养谁　　呜呼佛难见

尔时无攀缘菩萨摩诃萨。以偈告慧命阿难言

  尊者阿难起　　但观法莫忧
  法无有来者　　亦无有去者
  譬如佛有生　　证菩提亦尔
  譬如转法轮　　涅槃亦如是
  诸佛不曾生　　亦复不曾灭
  如是真法中　　阿难何以哭
  汝闻我毛孔　　出如是诸声
  诸有空寂静　　佛等四种事

尔时慧命阿难。以偈白无攀缘菩萨摩诃萨言

  大士等不久　　各各别刹去
  彼国见诸佛　　说于甘露法
  汝闻彼佛法　　甚深诸妙义
  见彼佛徒众　　及诸菩萨等
  今我亿数天　　哭泣而围绕
  世尊涅槃已　　智者我那住
  优婆塞千数　　今日承听我
  大苦恼忧悲　　我云何慰喻
  三十三焰摩　　兜率及他化
  自在及梵天　　如是等天来
  云何令欢喜　　释牛王灭后
  云何宣彼法　　我口云何辩
  诸天问我时　　阿难尊何在
  彼问我何报　　人牛王灭后
  一切诸处所　　甚深如来住
  我于经行林　　今在何处所

尔时开敷华神通德善男子。以偈白慧命阿难言

  我以知汝行　　善于三月中
  数现身向汝　　阿难莫哭泣
  自余千数佛　　我告为汝故
  诸佛为汝说　　化作释种身
  诸佛有慈念　　以汝好事佛
  当来向汝边　　阿难莫大哭
  天等诸世间　　今日可忧悲
  如是大教师　　隐寂而不现
  如来昔曾说　　寿命住亿劫
  诸行念念灭　　我对教师闻

尔时慧命阿难。住于佛后三大叫唤而说偈言

  众生所归者　　能与彼等眼
  导师入灭后　　众生转盲冥
  胜王阿阇世　　闻此不善言
  导师入灭后　　忧苦云何住
  胜人今涅槃　　于后力士子
  如是等忧恼　　悲号大哭泣
  彼等集聚已　　最后见导师
  敬心而尊重　　合掌以曲躬
  天龙夜叉满　　纵广五由旬
  此处无空缺　　人类无入处
  雨微妙香华　　充满至于膝
  复雨诸末香　　供养最胜仙
  难陀优波陀　　及六十亿龙
  悉来涅槃处　　最后见导师
  摩那斯婆论　　娑伽罗大龙
  睺喽目真陀　　各百亿围绕
  起云雨香水　　散洒此大地
  降大雨而来　　最后见导师
  诸天雨天华　　及雨净香水
  天龙等敬心　　供养世尊故
  阿耨达龙王　　六十俱胝等
  雨种种宝雨　　到人牛王边
  伊罗钵啼哭　　须弥子大蛇
  供养世尊故　　最后奉见佛
  诸龙有百千　　亿数那由他
  起云震雷电　　来到导师所
  彼等澍大雨　　清净诸香水
  亦为供养故　　最后见世尊
  夜叉千亿数　　或百那由他
  念佛诸功德　　皆来欲见佛
  复有四天王　　悲泣满面泪
  来至导师边　　最后觐见佛
  释提摩那民　　诸天众围绕
  六十三千数　　已来到佛所
  彼等雨天花　　微妙曼陀罗
  及雨栴檀末　　供养最胜仙
  毗求螺髻梵　　二梵众围绕
  悲泣到佛所　　最后见如来
  净居天威力　　多百亿诸天
  号哭到佛所　　以佛今涅槃
  诸天百亿数　　种种悲哀泣
  劝请大导师　　愿住于一劫
  魔子大智慧　　名娑陀婆诃
  怆怏到佛所　　胜仙涅槃故
  捧执世尊足　　伛身劝请佛
  愿愍世间故　　释王住一劫
  世尊若住者　　为大仁诸天
  当不思议利　　请尊住一劫

尔时无攀缘善男子。以偈告彼一切诸天世人及诸梵天王商主魔王子等。而说偈言

  汝等悉不知　　小儿如猕猴
  恒常心放逸　　以何号啼哭
  譬如猪睡眠　　忽起失本念
  被刀斫剥时　　惊怖驰奔走
  我意如是见　　汝等皆如是
  昔不闻法者　　以贪放逸故
  今日智慧炬　　将灭而不现
  及佛犹现在　　汝应作善业

尔时世尊告慧命阿难及富娄那须菩提并不空见王童子迦叶上座大俱絺罗及诸上座。今告汝等诸比丘言。将汝右手来与我。彼诸比丘闻佛世尊如是言已。即白佛言。善哉世尊。尔时诸比丘等满一千人。各以右手奉授世尊。尔时世尊复以左手执彼一切诸比丘右手。执已复以右手执罗睺罗及阿难手。付与诸比丘手中。口遗嘱曰。汝等比丘。我阿难贤及罗睺罗上座。今付嘱汝等遗嘱汝等。于如是时出大叫声。如是叫声悲号啼哭。震动天地甚大可畏。而彼大声遍此佛刹。尔时罗睺罗阿难当付嘱时。众中五百比丘见是事已。便舍身命。所以者何。彼诸比丘不忍见佛入于灭度。彼作是念。宁使我等先入涅槃。不忍见此世间大灯世间导师大慈悲父最善知识怜愍众生常与世乐今入灭尽。我岂忍见。尔时于彼刹那罗婆浮休多时。五百诸佛各住自刹。皆伸右手与释迦牟尼。尔时世尊。又以手执阿难罗睺罗上座手。付嘱与彼如来手中。而说偈言

  此我罗睺子　　阿难我侍者
  今在诸佛前　　我付嘱此二
  于今后夜分　　我当入涅槃
  更不复见我　　天龙及人等
  亦无有归依　　救护怜愍者
  惟除诸世尊　　覆不思议慈
  我观诸世间　　不思议无量
  不见一众生　　今我为谁住
  无量千数劫　　犹如恒河沙
  我于如是劫　　为一众生住
  我已利众生　　有信敬心者
  自余无信心　　亿佛不能化

尔时五百诸佛异口同声。而说偈言

  尊已众生利　　尊作佛事已
  现种种神通　　击大法鼓竟
  已充亿众生　　如云雨润地
  拔众生毒箭　　释种大仙人

尔时长老阿难。慧命罗睺罗。两膝着地。以偈白彼诸佛曰

  大丈夫劝请　　令尊住一劫
  以佛威力故　　一切见眼者
  最胜二足尊　　大智住世故
  多有众生信　　得利不思议
  增长诸天人　　阿修罗减少
  声闻及菩萨　　多生不思议

尔时彼五百诸佛告慧命阿难及罗睺罗言。汝等善男子。莫大啼哭。莫大愁忧。本性如是。事尽如是。真实如是。诸行如是一切有为法。一切作法。一切世谛法。悉皆如是。尽际如是。已舍身命如来行乃无量。以世谛法如是故不得自在。又如来者。是法身。非有为身无住世法。汝等不应请如来住。诸善男子。汝等且止到我佛刹。释迦如来即时当伸右手。当放光明。彼之光明照我刹土。照彼土已。汝等还来见释迦佛在汝等前为汝说法。令汝等闻。是故汝等莫大忧愁

尔时世尊入于三昧。住三昧已即伸右手。于右手中乃至大拇指端。及于左手诸身节分。乃至千辐轮处足相之中。及手足柔软网缦相中。赤铜色瓜甲。及以十指妙色掌文宝手之间。皆悉放于百千亿光明。一一光明化生莲华百千亿数。一一华台化出化师子高座百千亿数。一一座上见一佛坐。一一化佛教化无量百千亿众生。其间或得漏尽。或得离欲地。如是一切诸相好中所放光明。事相皆亦如是。如是等脐轮之间及阴马藏相。亦复如是。面轮眉间亦复如是。尔时世尊从于顶上放百千种光明。一一光明端化出莲华百千亿数。一一花台化作师子台座百千亿数。一一座上化一佛坐为说妙法。彼诸如来不说余法。唯说菩萨密藏修多罗。及诸陀罗尼金刚章句。为人显说清净三轮如来诸力无畏法等。似彼法门一一化佛一一说法。能净无量无边众生令住不退转地。向于阿耨多罗三藐三菩提。尔时世尊于娑罗双树间。右胁师子卧床中。化现一佛右胁而卧。化已自身即至活大地狱中。到彼处已身放光明。放光明已其光遍照活地狱中。尔时世尊以此光明。照于活大地狱已。而说偈言

  此众生数死　　数数还复活
  又不舍彼想　　故生诸苦恼
  世有此圣出　　世尊能作明
  能说诸正法　　灭除诸苦恼
  无为亦无尽　　无灭亦无行
  若能如是解　　彼不堕诸趣

尔时如来说是偈已。于彼刹那罗婆摩休多时。令彼活大地狱三十亿数诸苦众生便得舍身。即舍身已生于三十三天。尔时世尊复至三十三天还说此偈。以佛神力声遍一切诸大地狱。彼地狱趣无量百千亿诸众生。舍地狱身生兜率陀天。得生天已。还复忆念前所说法。皆得阿那含果。尔时诸天子得法果已。证法证果入于诸法。共说偈言

  譬如大旷路　　有智慧商主
  度脱多众生　　被贼诸兽者
  世尊亦如是　　无上大商主
  能脱亿众生　　缚在生死中
  我等归依佛　　光明大商主
  于我起慈悲　　能脱诸苦恼
  我等归依法　　我等身已证
  我等归依僧　　功德难思议

尔时世尊以凉冷光明。普照阿鼻脂地狱处。作凉冷已除灭热恼一切苦毒。成就诸法千数亿分。能令一切得诸喜乐。愍哀润益一切众生。安慰柔软哀怜喜庆。利益众生合三空门无相无愿及以无作。告彼地狱诸众生等。而说偈言

  空法及无相　　无生及无灭
  若解如是法　　彼即脱恶道

尔时八百千亿众生得闻偈已。此偈所说三世无碍。是诸法分 成百千种。已至耳边清净微妙 。闻是声已从于阿鼻脂大地狱。舍地狱身即生他化自在天宫。尔时世尊住梵天宫。复说此偈言

  众生最上乐　　无有诸苦处
  名相所说处　　及诸颠倒想
  健儿应当舍　　即免诸苦恼
  诸想皆颠倒　　及着非色想
  三界何有乐　　数数流转生
  死已复更生　　增长相续苦
  能以智知空　　亦不着于空
  彼人即知空　　不着知空者
  此知法义已　　亦复无有我
  既不得于我　　此处何有苦
  空是无为法　　相亦不可得
  能见无我智　　此是真佛子

尔时彼百千亿数诸众生等。所生之处即得无漏天仙妙果。即便忆念宿命之时受地狱苦。复念如来丈夫功德。知报佛恩先取灭度。又复不忍见于如来多陀阿伽度阿罗诃三藐三佛陀入于涅槃。时诸天子已得果者。异口同声。而说偈言

  我等不忍见大慈　　调御丈夫入灭度
  能为众生作光明　　我不忍见先取灭

作是语已。即于此处入于涅槃

尔时世尊于彼刹那牟休多时。从梵天宫便自隐身。即至娑罗双树之间。尔时世尊作如是念曰。我于今日后夜分时入于涅槃。即是最后见于众生。我今当可令其欢喜灭一切苦而受快乐。显现如来大神通力。令彼众生即便得入安隐之门。欲显如来无余涅槃。合诸佛意故示神通。尔时世尊作是念已欹右胁卧。犹如师子心无所畏观察十方一切大众。犹大龙象。如是观已。即以右足第一拇指。按此大地出大音声。六种震动遍十方界。示现无碍不思议光照曜十方。尔时世尊从身诸相复放光明。放光明已。一一毛孔复出微妙恒河沙数微妙光明。一一光明遍照恒河沙等诸佛刹土。彼之光明不相杂入无所妨碍。如是数数从毛孔中。次第放诸微妙光明。如是毛孔各各次第复放光明。还复如是遍照如前。尔时世尊更复显现作诸神通。现神通已。以佛神力佛护持力。令诸众生皆得具足所见境界佛眼无异。彼诸众生住此佛刹。皆悉睹见如来光明所照一切诸佛刹土。尔时世尊告诸比丘。汝等见彼东方世界有城周圆纵广一千由旬。如是广大上下亦尔。以诸微尘百千亿数满此国城。汝等见不。诸比丘白佛言。如是婆伽婆。如是修伽陀。我等皆见。佛复告曰。汝诸比丘于意云何。此微尘数是为多不。诸比丘言。如是如是婆伽婆。佛复告言。诸比丘。若有人能于诸法中知如是等无为之法不生不灭无漏无为如是知者。彼诸众生得脱诸苦一切恶道。当于尔时有三十亿诸众生等。闻此法已即得阿那含果。既得果已。异口同声。而说偈言

  无为法无尽　　无漏亦不灭
  圣法如是知　　我等证寂灭
  知以如是得　　如实知诸根
  为怜愍众生　　示现因缘法
  如来化我等　　拔除毒箭病
  一切智与药　　及与于涅槃
  智炬今速疾　　智眼不久灭
  亿众苦逼切　　从活地狱出
  拔箭大医师　　治众生病者
  能救无数众　　令不堕恶道

尔时世尊立住黑绳大地狱岸上。放大光明遍照彼大地狱。拔于彼处无量众生置于天上。如是等热恼地狱大热恼地狱。亦皆如是。叫唤大叫唤大地狱。众合大众合地狱。拔出无量无边众生。安置善道及涅槃道。尔时世尊复以金色光明照八大地狱。其光明力能令众生所触身者皆得安乐。遍体润益身心欢喜苦恼消除。眼目所观心地欢庆。快得清凉从慈悲生令身安隐。光明遍照大地狱已。灭诸热恼和软流润。彼大地狱所有众生。在大火聚炽然中者。与彼乐故于诸毛孔。次第而放如是光明。尔时世尊以大光明。普覆一切无量众生。令心柔软堪任法器。具足无量百千功德。以微妙语。而说偈言

  我与世间乐　　解脱诸忧苦
  见诸苦逼切　　示现涅槃道
  我所说诸法　　寂静无畏乐
  若能知彼法　　此不堕恶趣
  能归依佛者　　彼人得大利
  百千诸劫数　　更不见诸苦

尔时如来说此偈已。即于刹那罗婆牟休多时。诸比丘众及诸众生多于前数。复有无量无边诸佛。右胁而卧师子床上。彼诸世尊从师子床起。还复示现如是神通。尔时彼四部众白佛言。世尊。此诸佛等。皆悉欲于刹那罗婆牟休多时。入般涅槃现神通耶。如今世尊所现无异。佛告诸比丘。如是如是。彼诸佛等。今日同欲舍最后身入于涅槃。彼诸佛等悉皆同名释迦牟尼。皆于力士所生之地娑罗双树。卧师子床。今后夜分当入涅槃。尔时世尊于南方及西南方。西方及西北方。北方及东北方。东方及东南方。上下二方。遍告十方诸比丘言。汝等比丘。见于东方无量无边诸佛世尊证得阿耨多罗三藐三菩提不。诸比丘言。如是如是。婆伽婆。我等皆见。以世谛故见非第一义。佛复告诸比丘。譬如四天下世界微尘悉满。乃至从金刚际至梵天宫。诸比丘。于汝意云何。颇有人知其数不。能以譬喻知其数不。诸比丘言。不也世尊。难可得知。佛复告诸比丘。譬如前所说微尘譬喻。如是等四天下世界。如是百千亿世界。皆悉充满彼微尘众。诸比丘。彼所有微尘如是等微尘。我以肉眼见此世界诸佛世尊所住在东方。如一步地。但以肉眼无碍无分别。见前世界如向所说。如是南西北方四维上下亦复如是。诸比丘。譬如四大天下诸世界。若百千亿数满彼微尘。从金刚际至梵天宫。所有微尘一一方面。各有若干诸佛世尊。一一方面我皆现见此诸世尊坐于道场。或有已坐或始坐者。彼等一切诸佛世尊。皆悉同名释迦牟尼。如是复有无量诸佛。与然灯佛同一名号。我复见有诸佛世尊名胜一切。亦同名号。如是一切诸佛同名莲华。上如是等上佛同一名者。如是上名称佛同一名者。如是拘楼孙佛同一名者。如是拘那含佛同一名者。如是迦叶佛同名号者。如是各各佛同名号者。我在于此皆悉现见。彼诸佛等各各名号。我于世间得最胜法微妙法无极之法。但有能称名者皆得善根。彼等诸佛各各名号如是无边。如是等诸佛世尊。我住于此皆悉现见。如是等现在世间种种名字。或入无余涅槃。或现住世转于法轮。我住于此悉皆现见彼佛世尊。于我肉眼无碍无妨皆现在前。诸比丘。如来如是复胜此知。更复胜知不可思议。更复不可思议无量无边。复有无量无边如是等无量知见。诸比丘。以是义故。如来智见无边。如是无边不可称量。如是不可称如是不可思议。但以肉眼。况复尽于诸佛智法。诸比丘。譬如此刹所有一切众生若在家若出家。彼诸众生假使悉成阿耨多罗三藐三菩提。具足十力四无所畏。彼诸世尊有一善男子。能以四事供养承事。足满一劫尊重恭敬。种种乐具诸庄严事。无量无边不可思议。复有善男子善女人等。能信我此显示一切诸佛所说法门。乃至一念顷能生实想不起疑心。彼人即于发心之时所得功德。近诸如来所有功德。复胜三千大千世界所有众生。证得诸佛一切智已。经劫供养得福虽多。不如于此法门生一念信福多于彼。若有菩萨信此智者。彼之菩萨即得近诸世尊阿耨多罗三藐三菩提。尔时世尊说此肉眼功德之时。有六十二亿诸众生。回向阿耨多罗三藐三菩提者还生退心。所以者何。佛阿耨多罗三藐三菩提难可证故。我等但于此处。灭尽诸苦取漏尽果。复有无量无边众生住于学地。复有十那由他菩萨成就最初发菩提心。复有三十二亿诸菩萨等得无生忍法。尔时魔王波旬。怆怏苦恼泣泪满面白佛言。世尊。我为何事欲令多陀阿伽度阿罗诃三藐三佛陀早入涅槃。乃令无量无边众生出我境界。今者世尊。东方黄晦日未现顷。所作佛事如住一劫若住一劫。未能过此利益度脱多数众生。所谓住于般涅槃道。如来今者。令我境界悉皆空虚。时魔波旬说是言已。佛告波旬。汝莫啼哭。波旬。汝犹大有不作善业及不信者。是汝朋友在汝境界。汝是彼伴。尔时世尊即以甲爪取地上尘。告魔波旬。于汝意云何。为我爪上土尘多耶。为此大地上尘多乎。作是语已。时魔波旬白佛言。世尊。指甲上土少不足言。如是语已。佛告波旬。譬如甲上土尘甚少。我所度众生入涅槃者。复少于此爪甲上土。波旬。譬如大地土尘甚多无量无边。在汝境界众生亦复如是甚多无量。波旬。汝莫忧愁应生欢喜。何以故。众生在汝境界多大地土故。波旬。然诸众生自作不善去涅槃远非汝所为。所以者何。但众生界无有边际。波旬。汝欲所作但当作之。如来今日于后夜分当入涅槃。尔时世尊告诸比丘。汝诸比丘。见此世界诸佛已不。诸比丘白佛言。世尊。如是如是婆伽婆。我等已见。佛复告诸比丘。此诸佛刹复多无量。汝等当知见诸佛刹庄严已不。复见诸菩萨庄严净土已不。复见诸声闻庄严已不。诸比丘白佛言。世尊。如是婆伽婆。如是修伽陀。佛复告诸比丘。如来如是知见。复倍上数知见无量。更复无量皆悉了知。诸比丘。假使我于一劫所说如是佛刹庄严之事。如我见于十方世界亦复如是。假使于一百劫。于一千劫亿载数劫那由他劫。更倍譬喻广分别说犹不可尽。然诸比丘。导师所作者。为诸声闻所作已讫于。于一切处我已说讫。示现内外诸法。真心示现皆已说竟。诸佛于法无有吝惜无不辩者。乃至一茎草等一毛发。许汝等比丘。从今已去应须如法勤而修行。我已为汝示现涅槃。我已为汝说涅槃道。已成就众生善根。我所证得阿耨多罗三藐三菩提。乃于往昔行大苦行及于难行。汝等。今者于彼大法具足受持勿令隐没。汝等。应作如是修行。尔时世尊现大神通。十方诸佛所有说法及说法处。此刹众生皆得闻知。彼诸如来所有教敕。所有众生承奉教敕皆已证知。复有恒河沙数众生住于三种智。复有十亿百千诸众生等。发菩提心住于阿耨多罗三藐三菩提。复有十百千亿那由他诸众生等。住于辟支佛地。自余诸众生等得漏尽证。如是次第无量无边阿僧祇。不可数不可量不可思那由他诸众生。闻此法已得大饶益。尔时世尊告诸比丘。汝等比丘。当知我今不久涅槃。汝等。应当护持如来教法。为自利为他利故。汝等诸比丘。应当如是修学。佛说经已。慧命阿难。及天人龙阿修罗揵闼婆等一切世间。闻佛所说顶戴奉行

四童子三昧经卷下


中阴经

    No. 385

中阴经卷上

        后秦凉州沙门竺佛念译

    如来五弘誓入中阴教化品第一

如是我闻。一时佛在迦毗罗婆兜双树北四十九步耶维处。八日夜半明星出时。尔时如来忽然离碎身舍利。如诸佛五弘誓法。当生之时天地六反震动。十方诸佛皆来扶助。是谓一弘誓法。云何为六反震动。东踊西没。西踊东没。北踊南没。南踊北没。四面都踊则中央没。中央踊则四面没。当其如来初举一足行七步天下大动。十方诸佛皆来扶助。是谓二弘誓法。如来往诣菩提树下结跏趺坐。吾不成佛不起于坐。尔时天地大动。十方诸佛皆来扶助。是谓三弘誓法。 如来之名波旬虽闻心不怯弱。誓愿力故 天地大动。十方诸佛皆来扶助。是谓四弘誓法。如来舍身寿命现取灭度。入于中阴教化众生。尔时天地大动。十方诸佛皆来劝赞。是谓五弘誓法。尔时世尊入火炎三昧。离碎身舍利去地七仞坐宝莲华。使无量无限那由他众生。天龙鬼神阿修罗甄陀罗乾闼婆迦留罗鸠槃荼富单那人非人。皆见如来坐宝莲华。尔时世尊向舍利。而说颂曰

  于无数劫中　　养汝地种界
  吾今离汝去　　如蛇脱皮乐
  五道生死中　　无处不有汝
  权时得相离　　寂灭无所著
  威神接地种　　非汝不得度
  咄嗟别离苦　　生死牵连着
  诸佛威神接　　所度阿僧祇

尔时世尊说此颂已。从脚心上至肉髻放八十四千亿光。普照三千大千世界。上至虚空界。其中众生皆见光明。或有寻光来者。或有诸佛遣诸菩萨。来至忍界者。尔时世尊内自思惟。此中阴形极为微细。唯佛世尊独能睹见。然此众生有学无学。一住二住乃至九住。非彼境界所能睹见。吾今以佛威神入照明三昧。令四部众比丘比丘尼优婆塞优婆夷睹此微形。尔时世尊次入无碍定。观此空界众生生者灭者。如诸如来所行禁戒。虚无寂寞观不净想。百七十行苦本因缘。乃至生死十二缚着。尔时世尊复说颂曰

  今当入微妙　　极细中阴形
  化彼众生类　　倍于阎浮提
  常相无所著　　乐相空无定
  建立道德根　　舍寿无所染
  本从阿僧祇　　济彼难度人
  况此微妙形　　无过此最难
  吾今弘誓心　　无杂无所染
  菩提道德根　　梵行究竟法

尔时世尊说此颂已。复放眉间白毫相光。普照东方无量无限那由他世界。南方西方北方亦尔。尔时世尊还摄光明。绕佛七匝从顶上入。尔时弥勒菩萨即从坐起。偏露右臂右膝着地。合掌叉手前白佛言。快哉世尊。昔所未闻昔所未见。中阴众生形质极细。寿命长短饮食好丑。为何等类。愿乐欲闻。世尊告曰。谛听谛听善思念之。吾当与汝一一分别。云何弥勒。阎浮提儿生堕地。乃至三岁。母之怀抱为饮几乳。弥勒答曰。饮乳一百八十斛。除母腹中所食血分。东弗于逮儿生堕地乃至三岁。饮乳一千八百斛。西拘耶尼儿生堕地乃至三岁。饮乳八百八十斛。北郁单曰儿生堕地坐着。陌头行人授指[口*束]指。七日成人彼土无乳。中阴众生饮吸于风。阎浮提众生寿命百岁。东弗于逮寿命五百岁。西拘耶尼寿命二百五十岁。北郁单曰寿命千岁。中阴众生寿命七日。阎浮提人面上广下狭。弗于逮人面正圆。拘耶尼人面上狭下广。郁单曰人面正方。中阴众生面状如化自在天。自此以还释迦牟尼名号已灭。妙觉如来出现于世。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。在虚空中坐宝莲花。放舌相光明照东方八十七亿恒河沙数。彼国名化。佛名坚固。十号具足一乘教化。见此光明告诸菩萨诸族姓子。汝等见此光明不乎。对曰唯然已见。世尊不审。此光何佛光明照此世界。彼佛告曰。西方去此八十七亿恒河沙数。世界名娑呵。佛号释迦牟尼。今取灭度舍身舍利。欲入中阴教化。是妙觉如来光明。汝等欲往今正是时。尔时彼土菩萨百三十亿。受佛教诫来至忍界。佛告之曰。汝到彼土礼事供养勿怀懈慢。持吾名号问讯妙觉如来。兴居轻利游步强耶。菩萨受教礼彼佛足。右绕七匝忽然不现。来至娑呵世界。 南方去此八十七亿恒河沙数。世界名解脱。佛号真净如来。十号具足。告诸菩萨。汝等见此光明不乎。对曰。唯然见之。不审此光是何佛光照 此 世界。彼佛告曰。北方去此八十七亿恒河沙数。世界名娑呵。佛号释迦牟尼。今取灭度舍身舍利。欲入中阴教化。是妙觉如来光明。汝等欲往今正是时。尔时彼土菩萨百三十亿。受佛教诫来至忍界。佛告之曰。汝到彼土 亲 事供养勿怀懈慢。持吾名号问讯妙觉如来。兴居轻利游步强耶。菩萨受教礼彼佛足。右绕七匝忽然不现。来至娑呵世界 。北方去此八十七亿恒河沙数。世界名琉璃。佛号雷音如来。十号具足。告诸菩萨。汝等见此光明不乎。对曰。唯然已见。不审此光是何佛光明照此世界。彼佛告曰。南方去此八十七亿恒河沙数。世界名娑呵。佛号释迦牟尼。今取灭度舍身舍利。欲入中阴教化。是妙觉如来光明。汝等欲往今正是时。尔时彼土菩萨百三十亿。受佛教诫来至忍界。佛告之曰。汝到彼土礼事供养勿怀懈慢。持吾名号问讯妙觉如来。兴居轻利游步强耶。菩萨受教礼彼佛足。右绕七匝忽然不现。来至娑呵世界。东北方去此八十七亿恒河沙数。世界名空净。佛号虚空藏。十号具足。菩萨百三十亿。东南方去此八十七亿恒河沙数。世界名炽然。佛号广显如来。十号具足。菩萨百三十亿。西南方去此八十七亿恒河沙数。世界名星宿。佛号月光如来。十号具足。菩萨百三十亿。西北方去此八十七亿恒河沙数。世界名坏魔。佛号勇猛伏如来。十号具足。菩萨百三十亿。上方去此八十七亿恒河沙数。世界名海迹。佛号上妙如来。十号具足。菩萨百三十亿。下方去此八十七亿恒河沙数。世界名通达。佛号无畏如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。告诸菩萨。汝等见此光明不乎。对曰。唯然已见。不审此光明是何佛光明照此世界。彼佛告曰。上方八十七亿恒河沙数。世界名娑呵。佛号释迦牟尼。今取灭度舍身舍利。欲入中阴教化。是妙觉如来光明。卿等欲往今正是时。彼佛土菩萨百三十亿。受佛教诫来至忍界。佛告之曰。汝到彼土礼事供养勿怀懈慢。持吾名号问讯妙觉如来。兴居轻利游步强耶。菩萨受教礼彼佛足。右绕七匝忽然不现。来至娑呵世界。礼事供养妙觉如来。头面礼足各一面坐。尔时妙觉如来出广长舌左右过耳。如优钵赤莲花色。吾从无数阿僧祇劫。行至清净无有虚妄。吾所度众生因缘已毕。如弃尸骸在旷野中。今复造缘更始立行。今此菩萨有立根得力。 有初发意者。复有四众未践迹者。当以佛力威神接引。令彼大众。知过去当来今现在。佛不可思议难有之法。尔时世尊即说颂曰

  世多愚惑人　　不入无漏捡
  还在五道中　　染污不净行
  我虽于忍界　　拔济五欲苦
  善哉昔所愿　　今日已成办
  如人唾于地　　智者谁能饮
  吾从无数劫　　修佛清净行
  舍身复受身　　非一劫二劫
  若有明智者　　把土画舍利
  况复睹我形　　有不解脱者
  生死昼夜长　　愚在五道长
  断灭无道长　　求佛泥洹长
  本号释迦文　　留身舍利化
  今当入空界　　中阴度萌类

尔时世尊说是颂时。八万四千那由他众生。厌患生死。皆发无上正真道意。复有七十亿众生。诸尘垢尽得法眼净。魔界菩萨七千万众。即从坐起收摄衣服。摩诃而去

    中阴经妙觉如来将诸菩萨入中阴教化品第二

尔时妙觉如来至真等正觉。察众坐定纯一无杂。应入中阴受禁戒法。多所饶益所度无量。建立弘誓施行佛事。尔时妙觉如来入无见顶三昧。使诸大众无数亿千那由他恒河沙数诸菩萨众。皆同一色如妙觉如来无有差别。尔时阎浮提大迦叶。诸比丘比丘尼。优婆塞优婆夷。天龙鬼神迦留罗甄陀罗摩睺罗乾闼婆鸠槃荼富单那人非人。八国王八亿百千众生。以神足力将入中阴。尔时世尊于其中间。而说颂曰

  中阴迷惑等　　迷荒无三尊
  转身向五道　　随行所牵往
  或堕二善道　　或入三恶趣
  善哉可愍伤　　今日如来至
  此类既得度　　我愿亦成办
  无形受形教　　断想断灭本
  三世诸佛等　　无不行此法
  色法自炽然　　灭以定意道
  如来真实相　　无生无起灭
  观身内外空　　解知非常法
  行由痴爱本　　如灰覆火上
  愚者谓为灭　　火本犹常存
  心为人毒本　　善恶随其形
  行善即趣善　　行恶即趣恶
  如人作恶行　　自谓后无报
  临其报至时　　非亲所能代
  犯戒无法行　　自称世无双
  裸形食果蓏　　奉事日月神
  自坠三恶趣　　不虑劫数期
  此等非佛子　　虽近离我远

尔时妙觉如来说此颂已。即以神力入中阴中。化作七宝讲堂七宝高座。悬缯幡盖金银梯梐琉璃为地。后园浴池皆七宝成。凫雁鸳鸯异类奇鸟悲鸣相和。尔时世尊复以神力。使彼众生应七日终者。六日五日四日三日二日一日终者。尽令住寿。尔时世尊观彼众生心所趣向。欲得分别各住在一面。四向四得各在一面。初发意九住各在一面。向辟支佛得辟支佛各住一面。尔时世尊化作七百亿那由他七宝高座。一一高座尽有化佛。一一化佛尽说四非常偈

  一切行无常　　识为外尘法
  起者必有尽　　彼灭最为乐
  不生老病死　　亦不处三有
  永处虚空界　　诸佛之堂室
  无畏无点污　　不为欲爱染
  香熏及五欲　　永尽无有余
  若断百八爱　　集法亦复然
  前灭后不生　　及生道果证
  佛法总要之　　三十七道品
  无愿无相空　　诸佛之径路
  利根众生等　　一闻不再受
  断以智慧剑　　如火焚山野
  难觉众生类　　亿佛在前立
  罪根深坚固　　虽愍而难济
  中阴受身等　　将导随言教
  虽非本发心　　闻法则得度

尔时化佛说此颂时。七十八亿百千那由他中阴众生。起无上正真道意。发菩提心。尔时妙觉如来。最在中央升无畏座。十方诸神通菩萨。在左面坐。阎浮提摩诃迦叶。并四部众比丘比丘尼优婆塞优婆夷。在右面坐。诸天龙鬼神及大国王。在佛后坐。从四天王忉利天王。炎天兜术天廅天波利陀天廅波魔那天阿会豆修天首呵天波利陀首呵天须滞天须滞只耨天乃至阿迦腻叱天在虚空中。散华供养作天伎乐。中阴众生在如来前听受法教。尔时世尊以佛威神。令众生等心自念言。唯佛为我说法不为余者。尔时世尊而说颂曰

  如来无量觉　　神变不可量
  出入山石壁　　如鸟游虚空
  本我阿僧祇　　积行累功德
  度彼不自为　　使发菩提心
  泥洹无去来　　亦不见受者
  本我双树间　　转身来适此
  我初发道心　　誓度众生类
  一人不度者　　吾要终不舍
  观此中阴人　　各有上中下
  但以三句义　　四谛真如法
  淫怒痴虽薄　　要须禅定除
  八百疮痏病　　八万四千垢
  施惠持戒忍　　精进禅智慧
  善权巧方便　　拔断三毒根
  色本非我有　　谁造此色本
  了知色无形　　可谓梵志行
  吾本未成佛　　为色之所惑
  堕四颠倒法　　没陷生死海
  今方究色本　　观色非真实
  受想行识法　　秽污非真道
  阴入十八界　　二十二根法
  一一悉分别　　寂然无所著
  欲界中阴人　　尘垢悉微薄
  犹如新成衣　　尘土所污染
  有目智慧人　　抖擞尘悉去
  中阴众生类　　譬之亦如是
  淫怒痴微薄　　闻法即得悟
  一向心不移　　即得须陀洹
  三转十二法　　复得斯陀含
  坐上下分灭　　即得不还道
  苦尽痴爱灭　　得成阿罗汉
  道迹八十亿　　频来得道人
  八万四千亿　　不还得道人
  百万二千亿　　罗汉二恒沙
  六通身清彻　　趣向各佛者
  八万四千亿　　趣向菩萨心
  其数如微尘　　吾本阎浮提
  苦行不可数　　国财妻子施
  头目血髓骨　　意坚如金刚
  不为魔所动　　快哉大福报
  何愿而不成

尔时坐上众生作是念言。佛独为我说法不为余者。趣声闻道者。得声闻道者。趣辟支佛道者。得辟支佛道者。趣菩提道者。得菩提道者

    中阴经妙觉如来入中阴分身品第三

尔时座上有菩萨名定化王。即从坐起偏露右臂右膝着地。长跪叉手前白佛言。善哉世尊。快说斯义晓了众生。音响所趣闻法易度。复有难度者。观见众生有淫怒痴薄者。无淫怒痴薄者。或在有对法者。或在无对法者。或在可见法者。或在不可见法者。或在有漏法者。或在无漏法者。或在有为法者。或在无为法者。或在可记法者。或在不可记法者。或在欲界法者。或在不可解法者。或在色界法者。或在无色界法者。或在中阴微形法者。或在中阴非微形法者。或在五色识法者。或在五色非识法者。或在非想非不想识法者。或不在非想非不想识法者。或在一住至九住者。有在一住非一住者。有在九住非九住者。唯愿世尊一一敷演。令诸菩萨永无犹豫。众生之类闻法解脱。尔时世尊以梵净柔濡之音。赞定化王菩萨曰。善哉善哉。族姓子。乃能于如来前作师子吼。今当与汝一一分别。谛听谛听善思念之。汝所问者。可见法不可见法者。为眼见色。为色入眼。定化王菩萨言。亦不眼见色亦不离眼。亦不色入眼亦不离色。佛告定化王菩萨。族姓子。眼非色色非眼。何者是观。定化王菩萨白佛言。识法实住观法乃起。佛告定化王菩萨。云何族姓子。识为有法。识为无法。定化王菩萨白佛言。识非有为不离有为。识非无为不离无为。佛告定化王菩萨。何谓有为。何谓无为。定化王菩萨白佛言。起者有为。住者无为。于第一义法。不见有起。不见在住。法性清净无色无识。于泥洹法无所染着。眼非色色非眼。无可见法无不可见法。过去眼过去色过去识。未来眼未来色未来识。现在眼现在色现在识。非有眼色识。非无眼色识。是谓泥洹清净法。尔时定化王菩萨。今欲闻如来说有对无对法。佛告定化王菩萨曰。族姓子。声为有对耶。无对耶。定化王菩萨白佛言。声亦有对亦无对。佛告定化王菩萨。声亦不有对亦不无对。云何族姓子。此声彼应为有为无为虚为实。云何族姓子。虚空可画得成字不。对曰。唯然世尊。不可得也。何以故。如来习行于阿僧祇劫。亦不见有亦不见无。亦不见有三世。亦不见无三世。乃至非想非不想。亦复如是。尔时定化王菩萨白佛言。上诸法观一一悉知。唯愿如来至真应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。说三微妙法。何者最妙中阴形耶。五色识形耶。非想非不想识耶。尔时世尊知众会心皆有疑即于座上。而说颂曰

  吾受三界苦　　愚惑痴爱心
  经历阿僧祇　　在有亦在无
  破坏生死劫　　今乃得成佛
  以本弘誓愿　　度于不度者
  佛力无等伦　　三界无比尊
  一向无二心　　自誓得成佛
  吾从政炷佛　　初发无等心
  欲缚所缠裹　　坚固难可拔
  空定无相愿　　分别三三昧
  先念出入息　　分别善恶道
  执心擎油钵　　行步不失仪
  犹人见劫烧　　焚烧重罪者
  福升光音天　　轻者于他方
  三品众生类　　中阴受形者
  受化不思议　　非我谁能说
  五色识众生　　不同于三界
  如来最胜尊　　入彼识教化
  一一分别说　　不遭百八爱
  应成须陀洹　　为说须陀洹
  应成斯陀含　　为说斯陀含
  应成阿那含　　为说阿那含
  应成阿罗汉　　为说阿罗汉
  应成辟支佛　　为说辟支佛
  应菩萨道者　　为说菩萨法
  得须陀洹者　　三十二亿人
  得斯陀含者　　四十二亿人
  得阿那含者　　五十二亿人
  得阿罗汉者　　六十二亿人
  得辟支佛者　　七十二亿人
  得菩萨道者　　八十二亿人

尔时世尊重说颂曰

  本我无心法　　现以教化众
  见烟知有火　　见云知有雨
  行步知君子　　见星知有月
  吾我心尽断　　不有我无我
  经历劫数期　　非月非日数
  佛以思惟得　　非凡夫所及
  善哉大圣尊　　普服诸十方
  去离欲界法　　处中阴教化
  此诸佛教法　　处阴不见阴
  此等众生类　　发愿各各异
  吾我自缚着　　我本彼亦尔
  佛以思惟本　　思惟本末观
  一意一念顷　　断垢不为难
  垢本胜于我　　坠我于三趣
  今我胜于垢　　灭汝入涅槃
  善哉大圣尊　　独步无二迹
  见我一迹者　　阎浮人得度
  身行有三事　　口行有四事
  意行有三事　　尘垢生死海
  九众生居处　　识之所经历
  分别我无我　　无我亦无彼
  诸佛世尊等　　心普无有边
  一意念众生　　所受不可限
  身净不行恶　　口言常清净
  心净如佛心　　是诸佛之法
  身为苦器法　　此非三世有
  非我谁能知　　谁知免此苦
  如来之功德　　诸相佣髀等
  师子胸臆相　　一一毛孔光
  掌相千辐理　　示以善恶道
  舌齿声光清　　济度阿僧祇
  眼耳鼻及发　　肉髻顶无见
  虚空犹可穷　　佛相不可量

尔时世尊说此颂已。八十亿中阴众生于无余泥洹界发金刚心。一一成佛与妙觉如来皆同一号。佛告定化王菩萨。所问有漏无漏。有对无对。可见不可见。当来过去现在法。当与汝说。定化王菩萨白言。世尊。愿乐欲闻。佛告定化王菩萨。谛听谛听善思念之。吾当与汝一一分别。云何定化王。何者是缘尽。何者非缘尽。六入尘垢重。染我痴爱法。观内外出入息法。八万四千度无极。生生不可灭。念念成其形。有漏八万四千。无漏三十七。有为无为法。此非泥洹道。身净不犯恶。口言无有失。心净与定合。四等遍一切。是谓菩萨行

    中阴经贤护菩萨问事品第四

尔时贤护菩萨即从坐起。偏袒右臂右膝着地。长跪叉手前白佛言。善哉世尊。欲色无色三分众生。其识难量。何者有漏量。何者无漏量。何者有为量。何者无为量。何者有色无色量。何者有欲无欲量。何者有记无记量。尔时世尊闻贤护菩萨所问事。即说颂曰

  处在胞胎中　　受形多种类
  前灭后已生　　其如恒沙数
  三分识众生　　尘垢非一等
  或闻声而度　　或见形得道
  今我妙觉佛　　降神入中阴
  一一分别了　　有漏无漏法
  得道成果证　　五色识易度
  斯等一部界　　不在有无漏
  众生在中阴　　如我身无异
  苦痛五阴形　　如转轮无尽
  吾我本无字　　声响亦无名
  观身三十六　　欲界有量法
  三分留二分　　此中阴众生
  五色识众生　　不染三界苦
  无明痴爱惑　　隐相非不相
  有漏苦谛本　　断结不及色
  集谛二十八　　寂然尘垢除
  三十七道品　　道谛为实果
  贤护汝今知　　有漏无漏法
  记法无记法　　今当与汝说
  有记善恶行　　无记痴盲法
  坠堕于生死　　非我无能济

当佛世尊说此语时。九十一亿众生。皆发无上道意。四十七亿那由他众生。尽得阿罗汉果

    中阴经道树品第五

尔时座上有菩萨名曰树王。即从坐起偏露右臂右膝着地。长跪叉手前白佛言。善哉世尊。如来所说甚奇甚特。未知如来欲说有漏耶无漏耶。唯愿世尊。句句说之。何者有漏。何者无漏。佛告之曰。有生有灭是谓有漏。无生无灭是谓无漏。有我有身是谓有漏。无我无身是谓无漏。眼是色对是谓有漏。无眼无色是谓无漏。有识有想有形是谓有漏。无识无想无形是谓无漏。三识处所住有身者。是谓有漏。一识一处有一形者。是谓无漏。有形非想非非想是量法有用。不用处三禅地。厌患生死故名不用。有愿不愿始发初禅。快哉斯乐心不倾动。念净喜安自守五行。成就有想有灭。斯出入法喜行。百八爱一念。一亿行中间。想想不可尽。况彼现在身。无彼无我想。吾从无数劫舍此就此。三识所经处非有亦无我。甚哉三界苦。受身生死难。譬如工幻法。以拳诳小儿。识神无形法。起灭无常定。我则无我身。况有识形法。想亦无想法。亦不见有识。四阴竟何在。由识而分别。苦阴有五行。非我非汝有。吾从无数劫。经历三识处。除天鬼神龙。何处无妙觉。我行众善法。誓度阿僧祇随形而教化。受化不可量。如来清净行。广普无边崖。神通内外照。观察于三世。有形无形类。思惟十想结。无复尘垢患。虚空无边际。不见有往来。心无中间念。忍辱功德成。积一成佛道。寂灭泥洹乐。起亦不见起。生亦不见生。况有起灭者。诸天世人民。能断至彼岸。缚着染三界。经历生死海。贪欲自缠裹。为色之所惑。永处三有中。佛力无所畏。威神接得度。为彼不自为。功德不可量。恒以四意止。五根五力。七觉意宝华。三十七助道法。空无相愿三昧。善权化生死。六度至彼岸。不以劫数期。周旋虚空界。度脱未脱者。得道如微尘。无我无彼想。一音演微法。受化无边崖。道心观察法。不见起灭者。分别内外身。系于安般息。息长亦知长。息短亦知短。乱想亦知乱。定想亦知定。一向无乱想。清净行正法。尔时世尊即说颂曰

  佛力之所行　　普润天世人
  学无学众生　　下及凡夫人
  心念断众相　　皆到无畏处
  分别空无相　　清净修道场
  庄严佛道树　　皆令同一色
  转无上法轮　　阐扬法鼓音
  非魔部界分　　之所能转者
  甘露法藏开　　普润一切众
  济 度 阿僧祇　　无量无等类
  最胜所接度　　无能量度者
  善哉不思议　　所度不可量
  我本所造行　　唯佛能称量
  不见吾我法　　法利利益人
  功勋过三界　　得入泥洹界
  清净无尘秽　　如月星中明

尔时世尊说此颂时。八十四亿那由他百千亿中阴众生。诸尘垢尽得法眼净。复有十千亿五色识众生。发心向菩提不退转道

中阴经卷上中阴经卷下

        后秦凉州沙门竺佛念译

    神足品第六

尔时妙觉如来。即以神足化此三千大千刹土。上至非想非非想天。下至无救地狱皆悉金色。皆如妙觉如来而无有异。三十二相八十种好圆光七尺。皆坐宝莲华高座上。坐演出梵音声闻三千大千刹土。一一诸佛说八万四千杂行。其睹光明者。淫怒痴病皆自消灭。异口同音而说颂曰

  经法本无体　　灭已今复兴
  断除有漏法　　独步于三界
  生死无数劫　　遭遇良福田
  金色普遍照　　蒙光得解脱
  神力不可尽　　观了本无形
  大慈大悲心　　拔济无明等
  五阴苦本源　　流浪得济渡
  四使生死河　　法船渡彼岸
  善权无碍道　　入彼无为境
  吾昔发誓愿　　要度未度者
  修身清净行　　口言无虚妄
  心念济八难　　诸恶何由生

尔时有菩萨即从坐起。偏露右臂右膝着地。长跪合掌叉手前白佛言。快哉世尊。神足无量不可思议。今欲所问。若见听者乃敢陈启。妙觉如来告彼菩萨。善哉善哉。族姓子。恣尔所问。吾当一一分别说之。时彼菩萨白佛言。世尊。如来神足不可究畅。令此三千大千世界烔然金色。是何三昧有此神变。佛告菩萨。此神变者。是三昧王三昧。唯有诸佛乃能变现。非声闻辟支佛所能。修行此三昧王三昧。将从八万四千。或有三昧名虚空藏。或有三昧名升法堂。或有三昧名月光清净。或有三昧名破有入无。或有三昧名一意不乱。或有三昧名除去尘雾。或有三昧名拔三毒根本。或有三昧名灭过去当来今现在病。或有三昧名开甘露法门。尔时世尊欲解斯义。宣说颂曰

  道力清净行　　身口意不犯
  誓愿阿僧祇　　没溺生死者
  金刚难败坏　　非二乘所及
  观身苦根本　　思惟四果证
  积行不退转　　闲静坐道场
  一切入定意　　二三至七劫
  地燋过劫烧　　其心亦不动
  坏破魔部界　　悉成无上道
  三昧定意力　　福报不可量
  令三聚众生　　得成无上道
  观察众生心　　难度易度者
  不令在没溺　　流滞生死海
  我本无此色　　紫磨金光体
  历劫勤苦行　　修定成此形

尔时妙觉如来说此颂时。诸佛世尊同时举手赞妙觉如来。以偈颂曰

  丈夫二足尊　　世雄不可量
  拔离三界苦　　淡然为一色
  今闻如来说　　定意神足道
  其闻法性相　　相相不可量
  八种清净音　　十六特胜法
  三十二行业　　利益一切人
  天人尊无比　　光明照众生
  久在饥渴道　　饮以八解脱
  无欲清净池　　化以七觉花
  不着五阴本　　犹如青莲华
  香熏远普闻　　如来五分身
  无处不流布　　吾昔求佛道
  誓愿同一时　　今日得果证
  不违昔所愿　　一相无相道
  分别微妙慧　　晓了善权道

当时世尊说此颂时。有百亿希望中阴众生。求佛身色紫磨金形。如我今日神变无量。要当来世皆当成佛。悉同一号号妙觉如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊

    中阴经破爱网品第七

尔时妙觉如来。将欲破爱结使。欲使四众自见证验。即入不动三昧。欲令彼众知欲爱色爱无色爱。尔时世尊重自思惟。此欲界众生。亦爱非爱。亦有漏无漏。亦有为无为。亦可记不可记。色界众生。非有非无。非想非不想识可见法。三界欲最重。染着不可离。中阴众生等要须圣教。五识众生有前有后。非想非非想识众生。有取涅槃无取涅槃者。云何中阴众生遇圣得证。彼有一病计无我。命恒计无常。前生非后生。后生非前生。此圣人语非本发心意。要须圣人如声闻法。五色识者根本未成。见佛识佛一一所著。多受福地堕者非一。不计吾我身是法非法行。三界为网所覆。欲出难得脱。犹如掷线丸。绪在犹复还。三界众生等。舍此复还此。尔时世尊即说颂曰

  三界为火宅　　火炎极炽盛
  爱心所染着　　将入三恶道
  前生非后生　　爱有轻重法
  五色识法者　　今世后易度
  生死八难道　　与泥洹对门
  无彼无此法　　最胜无等侣
  神足接众生　　见者无不度
  当来过去人　　乾闼阿须伦
  天龙鬼神等　　无不得济度
  善哉三界尊　　善说微妙法
  令受苦众生　　得至无为岸
  去身口意病　　寂然无移动
  如饥者得食　　如渴者得饮
  止观除爱结　　三脱甘露门
  我发无上道　　除爱无渴想
  于火炎拔济　　得成于世雄
  过去无数佛　　当来现在等
  如我今日化　　不计彼我想
  正法除邪法　　尘垢永已除
  无碍总持法　　思惟分别观
  于亿百千劫　　游戏诸三昧
  四空定意法　　往来不疲极
  诸佛所游处　　多益无减损
  举足下足顷　　所度不可量
  当我下足处　　有几众生等
  随类而得度　　遍满三界中
  随心得三道　　如是无穷已
  八解无碍法　　离舍寿命根
  不计三界想　　害彼五逆结
  汝生知汝生　　汝灭知汝灭
  汝上知汝上　　汝下知汝下
  中间无脱处　　过者何处去
  当知佛力大　　遍入总持法
  由本誓愿故　　未度者令度
  四等慈悲舍　　遍满诸十方
  佛指出甘露　　如慈母爱子
  又母非父慈　　又父非母慈
  三界四颠倒　　难化如金刚
  如物初入炉　　尘恶先燋灭
  真者不移动　　如淤生莲华
  佛道实真正　　无畏无所著
  不有想念累　　心亦无往来

尔时座上有一菩萨名曰炎光。即从坐起偏露右臂右膝着地。长跪合掌叉手前白佛言。如今世尊说真实之法。或言有法。或言无法。或言有为。或言无为。或言有记。或言无记。今众生受化者。以何法化而得度脱。尔时世尊以颂报曰

  诸法正有一　　无二亦无三
  爱识非爱识　　永离于胞胎
  破一缚着爱　　使众生爱尽
  如来神德力　　自识宿命本
  或在王天宫　　转轮王治处
  或在贫贱处　　下至无救狱
  一一分别了　　众生垢着心

尔时世尊说此颂时。六十八亿那由他中阴众生。即从坐起偏露右臂右膝着地。长跪合掌叉手前白佛言。咄嗟此苦乃是大苦。于众苦中此爱最苦。唯愿世尊听为出家。尔时世尊默然听之。尔时中阴众生闻佛说法。即得阿罗汉果

    中阴经三世平等品第八

尔时座上有菩萨名不厌患劫。即从坐起偏露右臂右膝着地。合掌叉手前白佛言。善哉最胜如来神力。极微妙不可思议。如来神德广长舌。不犯众生过。今此三聚众生。过去当来今现在。为过去耶。为未来现在耶。尔时世尊告不厌患劫菩萨曰。善哉善哉。汝之所问。于三聚众生。多所饶益多所润。及断无明本。身业得清净。非一佛所说。尔时世尊即说颂曰

  人本在胎时　　自识本宿命
  舍彼今就此　　三世炳然定
  前识非今识　　前身非今身
  但为愚惑迷　　不知趣道门
  念此在四使　　发起若干想
  咄嗟老病死　　坠堕在三世

尔时世尊欲解斯义。即说颂曰

  本我无此色　　受想识亦然
  我虚彼亦无　　岂有识想受
  无色名色法　　众生乱想法
  九品有差别　　分别三世道
  上上最妙道　　非去非未来
  上中最微细　　上下无觉观
  中上断三结　　中中灭三垢
  中下豁然悟　　此名为佛子
  下上虽为重　　如彼水上泡
  一生而一灭　　下中众生类
  苦本最为深　　非我谁能知
  下下众生类　　经历于劫数
  吾亦就彼化　　不见漏失者
  人心有若干　　座上心不悟
  或愿当来佛　　或愿现在者
  此等众生类　　难可济度者
  人本无形生　　还入虚空中
  生死相牵连　　何者名泥洹
  若言有众生　　身口意行净
  寂然入灭度　　无有老病患
  弘誓发一心　　亦不自为己
  虚空不可获　　何者名虚实
  如来梵天音　　分别实相法
  解了空无慧　　三界独步尊
  有觉空意法　　观身不恋着
  无觉在三禅　　进取不退道
  自我成佛来　　以此为本业
  成佛亦由此　　泥洹亦复然
  所以积功勤　　未获于实相
  闻四不离四　　此是诸佛印

尔时世尊说此颂已。无量无限那由他众生。及中阴五色识。非想非非想众生。欲得去离不乐三世。尔时世尊重说颂曰

  过去非今有　　现在亦复然
  当来弥勒身　　教化无差别
  我今说少少　　如人爪上尘
  欲说世界尽　　谁能究尽者
  今虽处中阴　　移坐无想天
  地狱对门人　　闻法乃得悟

尔时世尊。即以神力接中阴众生。至非想非非想识天。尔时世尊复以神力到彼。至非想非非想识界。施设庄严七宝高座皆有化佛。一一化佛皆有四众。一一众者。威仪法则悉皆成就。此众生中或有诵经说义。贤圣默然或有入定出定。尔时妙觉如来。复以神足十力接彼非想非非想识众生。如中阴形无有差别。尔时世尊。如诸佛常法威仪法则。令无量化佛合为一佛。或以一身变为无量。或在树下演说法教。或入初禅定意不乱。或在高岩闲静寂处。或坐处空作十八变。身下出火身上出水。身上出火身下出水。履地若空无有挂碍。或取灭度亦无灭度。或现无常身体膖胀。烂臭如白鸽色。或现手足各在异处。尔时非想非非想识众生。见此变易心怀恐怖。我本生心。谓呼定是泥洹。无病无老无诸痛苦。今观此法有生有老有病死痛。今遇如来降神在此。若不顺者。无择地狱即我舍宅。吾本宿世同要之人。先生彼识阿难陀迦兰陀。见佛礼拜善哉世尊。尊中无比降神此界。如遇优昙钵华。若佛不降神此者。我等永处边地。杀害无量迦兰陀身。复自宣白。今遭大圣如日消雪。若不遭圣。彼当堕坠作飞狸身。飞走尽害无有脱者。以此本誓愿得脱苦际。虚空无量界神德三界尊。辟支声闻等眼之所能见。尔时迦兰陀作是念。我等同生。生此识界罪福未分。或堕邪见受飞狸身。我本造身。不独三界。中阴五色及无色形。已生此念非想识众皆生苦心。我等诸人虽生此处。非得泥洹。非安隐处。今遇如来说真实法。断拔千万门。不去亦不来。贪欲本生我。我今还灭汝。为过所覆非。今世后世。生有老病苦。如影重有影。如月树叶影现于水。野干饮之终竟无获。我今三世尊。有实无实法化不变易。生者非有生。善哉世微法难度而度。世间愚痴人。计我为身实。当其舍寿时。钩锁骨相连。分别彼身中。何者命与寿。生死缠裹苦。舍彼复受此。处胎冷热苦。出有生灭忧。母虽乐育我。不生谁有患。落漠如水泡。识神染其形。轮转五趣中。所往无脱处。生死五道海。无往而不经。心为杀身本。汝灭我何患。虚空无本末。谁知常无常。彼无想之识。见阿兰迦兰陀。一为边地王。一为着翅虫。三界最为苦。本处非泥洹。如游旷野指东谓为西。今遭大圣。于一切众苦都得解脱。尔时非想非无想识众生。即于佛前寻声。而说颂曰

  吾本事五火　　烧炙身体烂
  卧在荆棘上　　身被髑髅衣
  翘足向日月　　无神不奉事
  今生非非想　　得见如来身
  自耻本所行　　在此无脱处
  特知正法化　　如来自降神
  得脱无择门　　永在安隐处
  五欲生死垢　　缠缚四流中
  心惑着三有　　烧以智慧火
  四趣五道人　　不见生本末
  着识吾我者　　如我今无异

尔时妙觉如来。复以颂报曰

  卿等本谓真　　八万四千劫
  无常生死本　　彼死还生此
  汝等众生类　　未曾老病死
  守一求泥洹　　此非真实法
  垢尽识不灭　　还在三恶中
  非我汝不悟　　谁能脱此难
  吾从无量劫　　誓度生老死
  非我前身造　　亦非后身受
  本得金刚定　　今乃教化汝
  地不可作空　　空不可作地
  水不可作火　　火不可作水
  一切愚惑人　　万物皆我有
  愚痴无明法　　谓为正真道
  如彼疲倦人　　懈息须臾间
  虽居八万四　　视之如一日
  为五苦众生　　何处不有我
  分别身法相　　分别空无法
  生者不见生　　死亦不见死
  问生根本道　　由行之所造
  三恶之重者　　痴病是其源
  名色六入法　　此是世之常
  触入更色法　　爱入更乐乐
  一切众生惑　　不识十二缘
  如蛾投火光　　妙觉如来说
  由汝垢重故　　则我心垢重
  如我成佛身　　经历不度界
  破坏心垢重　　识别想非想
  结使之根源　　无常谓为常
  以苦言是乐　　计空以为有
  无我以为我　　此想非想类
  习颠倒来久　　如蛾贪火光
  不避灭身难　　迷惑堕六趣
  生此非想天　　譬如斫伐树
  根在由复生　　迷惑四颠倒
  无明之所裹　　今开甘露门
  圣谛真如有　　拔苦之根本
  永尽无有余　　四使长流海
  生生生不断　　我今破三界
  将到至彼岸　　安隐无畏处

尔时世尊说此颂时。非想非非想识众生。皆发无上正真道意。于无余泥洹而不般泥洹。或有应生天者。与说十善法。应生人中为说五戒。或趣三恶道者。与说刀山剑树火车炉炭。如此等类。三百三十六亿那由他。厌患劫寿。闻清净法即成道果。尔时世尊。复以神足十力无畏。接彼非想非非想识众生。将至五色识界众生。修治道树庄严刹土放大光明。一一光明皆有化佛。一一化佛皆坐七宝高座。三十二大人之相。说六度无极。彼五色众生见如来变化。心垢缚着坦然除尽。不复愿乐染着生死。尔时世尊以清净梵音。而说颂曰

  苦本生死怨　　除之以善权
  四等大慈心　　超越无量界
  今此利根人　　一闻不再受
  睹佛色形相　　普入寂灭度
  乃知贤圣道　　无量难思议
  灭垢不复生　　尽同圣贤道

当其世尊说此颂时。无限无量五色识众生。尽同一号于当来世。号普广如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊

    中阴经无生灭品第九

尔时妙觉如来。将欲移到诸佛刹土。告三聚众生。发心趣向求泥洹道。今我现在与汝说法。若有所疑即来问我。泥洹有生有灭不耶。尔时三聚众生。闻如来语前白佛言。从欲界上至非想非非想。发意趣大乘不思议法。未曾闻有有为无为法。何者有余。何者无余。何者是上人法。何者非上人法。尔时世尊与三聚众生。分别句义字义及无相义。如来神力有三十二法。何者为三十二。亿本宿命中根本所生。知本所从一一所生。彼死生此此死生彼。以眼识通观察如掌中观珠。以耳通蝇行蚁步及微细声皆悉闻之。本有三界今无三界。汝等受道证。发心各各异。中间等变易。何者是三界。何者非三界。尔时世尊说此语时。三聚众生重生狐疑。尔时世尊知彼众生心之所念。欲得与说无相法观。以颂说曰

  何者名为头　　何者名为足
  何者名为华　　何者名为果
  人命在于头　　灭如灰土尘
  百草树木根　　拔去不复生
  观此众相法　　无头亦无足
  有余无余法　　等此而可知
  若言有泥洹　　我身命现在
  若言无泥洹　　何处有三聚
  佛以神力故　　令汝知有无
  我观三界苦　　此亦有亦无
  前念非后念　　前形非后形
  吾从无数劫　　举足及中间
  其中起大悲　　非二乘所及
  当我起大悲　　三涂受苦者
  如慈母乳子　　无不饱满者
  吾本一把施　　今得随所愿
  七宝众琦珍　　随念即时得
  何况四等具　　六度济众生
  此者谁能别　　唯佛佛知之
  今当与汝说　　分别有余无
  欲得观我界　　吾以神足从
  到彼逮作佛　　名曰释迦文
  七十二恒沙　　西南土庄严
  尽以一道化　　无辟支声闻
  其土甚快乐　　所念即在前
  不似此土界　　为淫怒痴缚
  一音遍四方　　闻者寻得度
  彼土七宝树　　风吹树叶时
  叶叶共相向　　皆说度无极
  我彼刹土中　　住寿阿僧祇
  现取灭度时　　遗法十二劫
  欲知劫长短　　贤劫为一日
  计此日月数　　以成十二劫
  汝等三聚人　　知我功德不
  适彼东方土　　八十亿由他
  其土名不终　　佛号名灭界
  我现弟子学　　剃除被袈裟
  长跪受圣法　　彼佛知我心
  彼等众生类　　见我着法服
  不乐于世欲　　同心乐出家
  威仪礼节具　　不失禁戒法
  当我屈伸时　　见者衣毛竖
  此皆本宿命　　同共誓愿者
  离欲无所著　　无有生灭相
  尽修于梵行　　以我佛神力
  于死得脱死　　念此无记等
  不解生以灭　　轮转于五道
  四圣甘露法　　充饱一切人

当其世尊说此颂时。见此初学弟子剃除须发受圣教。百七十亿众生。愿乐欲得思惟法观。不乐在家出为沙门。佛告三聚众生。我今东北方无限无量恒河沙数。彼有刹土名曰清明。佛名明月。彼土人民无淫怒痴。亦无憍慢我慢不如慢。彼土众生恒乐安静。独坐无为系念在前。初无乱想。雷电霹雳心无倾动。尔时妙觉如来。适彼刹土遇地而坐。彼众生见坐禅者悉共效之。佛以神力以无想法观。回众生心如手转物。令彼众生知有常无常。知生老病死苦。或有众生令知有念。或有众生令知有持。或有众生令知有安或有众生令知自守。佛将欲现四禅功德。即于三聚众生前。从初禅出入二禅三禅四禅。从四禅起入三禅二禅初禅。从初禅至三禅。从第四至第二禅。此名师子奋迅三昧。尔时世尊现此神足三昧定意。度无限无量那由他众生。皆共同发无上正真道。有愿乐须陀洹斯陀含阿那含阿罗汉。法眼净得辟支佛道。当于尔时妙觉如来忽然不现

    中阴经空无形教化品第十

尔时妙觉如来。舍中阴形入虚空藏三昧。以佛吼而吼出八种音声。何谓为八。非男声。非女声。非长声。非短声。非豪贵声。非卑贱声。非苦声。非甘露声。尔时世尊隐形不现。演出八万四千诸度无极。何谓八万四千度无极。想非想有爱入结使患本。如月云覆。一切众生为欲所牵。有四百病一生而一灭。人犯五逆欲离泥犁。去见八地狱衣毛皆竖。南西方北东亦尔。以闻响众生故演此诸法。当于尔时三聚众生。闻虚空语声无色无形。于其中间演出诸法。善哉诸佛。教无色形。难可思议。尔时三聚众生异形同音。以颂仰问虚空曰

  如来本在此　　三十二相具
  慈悲愍一切　　所润难可量
  为我说微妙　　八等圣道支
  隐形闻圣音　　万物皆无常
  如来黄金色　　本有今不见
  但闻音响声　　佛无我岂有
  计我生死本　　流转而不住
  但为色所惑　　福灭而罪生
  如来大圣尊　　示人行诸法
  忽然离形相　　音响来教化
  以本宿缘故　　形逝音接我
  老病生忧悲　　四蛇唼我身
  地种骨肉是　　水种润泽是
  火种枯燥是　　风种散法是
  无著三乘法　　离有故在有
  心垢久已离　　四种故存在
  如来大圣尊　　无彼此四大
  正言有四种　　亦复无四种
  正言无四种　　亦复有四种
  此是不定法　　谁能究竟者

尔时如来答彼音声。即说颂曰

  佛子知空不　　一切法无常
  人生非本生　　岂有本生缘
  我音及汝音　　可得不可得
  吾从无数劫　　不为一众生
  一念一息顷　　度少不以愁
  所度阿僧祇　　亦不以喜悦
  我本为一人　　闲静不度人
  后缘而对人　　不失本誓愿
  处此阎浮提　　四姓刹利胜
  除彼婆罗门　　余姓最不如
  以本法界观　　生老病死苦
  我无彼亦空　　何者有生死
  生者言有本　　生者从何至
  设知生死本　　泥洹在我前
  解知泥洹法　　无佛亦无我
  法从何处生　　去至何处灭
  佛以真实法　　现以有无相
  此生此灭处　　愚惑得见正
  言有亦非有　　言无亦非无
  轮转生死海　　为五欲所缚
  无驱无鞭策　　自坠生死渊
  尔乃知罪福　　知悔不悔者

尔时世尊说此颂时。八十七亿那由他三聚众生。解无形相法。发无上正真道意

    中阴经有色无色品第十一

尔时座上有菩萨。闻空中有如来声。仰观空中叹曰。甚哉。但闻其声不见其形。此色非本色。余阴亦复尔。此欲界众生难可免度。要须智剑剔除令无余。我本修梵行。非身口意造。非一非二。欲我从汝生。由汝堕三涂。一念欲灭众想。亦无去来今。过去诸如来教化群生类。说过去不说今未来。说未来不说过去现在。说现在不说过去未来。或言有三世。或言无三世。尔时世尊欲重解斯义。而说颂曰

  生老病死本　　诸如来尘垢
  要入中拔济　　何为地狱人
  不似妙觉尊　　在中阴教化
  于妙妙中最　　下劣所不及
  如人持钵乞　　随彼所施与
  持钵者思惟　　是有是无耶
  未证自谓证　　邪见之根本
  正法言非法　　流转五道渊
  正法分别法　　不失于法性
  若不失法性　　此是诸佛教
  法性无三事　　亦无去来今
  若言是现在　　现在何者是
  若言是过去　　过去何者是
  若言是未来　　未来何者是
  人能解此法　　晓了三世尊
  解本无杂想　　顺一大乘行
  有缘众生善　　济此无不度
  犹如负债人　　偿毕欲欢喜
  内外悉通达　　周旋不怯弱

尔时大势至观世音菩萨。承佛威神音响教化。即以神口而说颂曰

  生老病死本　　诸如来尘垢
  要入中拔济　　何处不往反
  我师无量寿　　永劫不灭尽
  本我所誓愿　　何为地狱人
  不似妙觉尊　　在中阴教化
  于妙妙中最　　下劣所不及
  愿我后成佛　　如妙觉无异

尔时观世音说此颂时。三亿众生发无上正真道意

    中阴经欢喜品第十二

尔时妙觉如来入寂灭三昧。将欲游行他方世界顾见所度。不可计众生心怀踊跃。犹如比丘入四禅法。心意淡然无饥无渴。善哉教化不失本愿心怀自庆。而说颂曰

  如来神足力　　离苦不善有
  处处分身化　　要度有缘者
  贤劫千佛等　　所度无有异
  亦在三聚中　　正法除非法
  甘露法门开　　掩闭三恶道
  称扬大智慧　　拔出愚痴根
  诸法自璎珞　　内外悉清净
  慈悲四等心　　无方不遍满
  摄持身口意　　超越生老死

尔时世尊说此颂时。群方三千大千世界满中三聚众生。承虚空中教。皆发无上正真道意。欢喜奉行作礼而去

中阴经卷下


阿差末菩萨经

    No. 403 [No. 397(12)]

阿差末菩萨经卷第一

        西晋月氏国三藏竺法护译

闻如是。一时佛在如来所游居土。于宝严净巍巍道场。悉是正觉之所建立。大德庄严而依积累神妙行业。成佛报应诸菩萨宫。宣扬无量如来变化。入无底慧游于殊胜。心怀悦豫。剖判普等。所修圣行。咨嗟当来。无际功勋名称无限。平等正觉以成佛道。善转法轮。开化无数诸学门徒。而于诸法常得自在。知众生性晓了诸根度于彼岸。随时方便除诸挂碍。佛事无处住无所住。与大比丘众六百万人俱。心行和安。消灭尘劳恩爱众弊。则是如来为法王子。修深奥法因正法生。威仪礼节进止光光。为大众祐亲归如来

复与无极诸菩萨俱。其数甚多不可称限。一切大圣神通已达。逮得总持辩才无碍。神智妙达不可攀喻。一心念顷游无量国。供养十方诸如来众。明识所奉听法无厌咨受奉宣。常怀勤修训诲群黎权智普备。所度无极立无盖门。皆越妄想无应不应。近一切智诸通慧地

其名曰天明菩萨。选战菩萨。照藏菩萨。除慢菩萨。勇步菩萨。眼根菩萨。离言菩萨。除冥菩萨。如是等类菩萨会者。浩浩皓皓不可思议德皆如是

尔时世尊。入诸菩萨所愿成行。其法名曰无阴盖门。净诸开士严妙道场。正觉法力具无所畏。圣慧之室游于诸法而得自在。摄总持印。晓了辩才。所入道门以大神通普至启明。讲畅分别不退法轮等御诸乘。通一法界无所破坏。颁宣众生诸根意性。敏达坚要决一切法。降伏魔场随应顺法皆能开化。尘劳结着迷惑邪见六十二疑。阐无碍智明解无际。所劝助业寻为发遣。入于诸佛平等道慧。无施无望无处所门。演说诸法如审真谛。等处有想及与无想。晓了深奥十二缘起。积功累德不可称限。庄严诸佛身口意行。志得由身所知无尽。修四圣谛。教授声闻身心静寂化缘觉乘逮一切智。具阿惟颜兴大乘学。入一切法恣已独步。叹咏如来功勋之德。随时宣示委靡抚恤训诲以渐。导阐法藏显其处所。除斯微翳开示明曜。世尊陶演讲释法教。使普流布周于十方

于时东方自然出现大金色光。其光照此宝净道场。及曜三千大千世界靡不周遍。大明韑晔皆蔽此土。日月释梵及四天王。所有威曜悉不复现。大神妙天诸尊巍巍。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒。光明悉歇。诸明月珠焰光宝珠。大火锭燎悉亦消灭。如来至真无极大光。诸阿惟颜菩萨身明独显现耳。其余一切所有光明皆没不现。此大千国回远悬绝窈隐闇冥。日月光明虽为广大。威神巍巍不能及逮。照于彼乡悉蒙光晖。其明不碍树木墙壁须弥大山雪山黑山目邻山大目邻山铁围山大铁围山。其明通过照于三千大千世界。至无择狱极于上方。地狱饿鬼畜生中者。其身皆荷此道明曜。众苦悉除恼痛休息身心为安。各相庆贺自谓遭时。于佛左侧宝净道场。寻自然生六十亿垓七宝莲华。其香芬馥普悉流布闻莫不欢。其华柔软大如车轮。光色炜晔叶无数亿。百千宝成其形正圆。而斯华上施交露帐校饰珠盖。其华所演甘美好熏。悉遍三千大千世界。此三千国诸天人民所有名香。值斯华香悉亦消索。天上世间所游居类。荷此华香咸乐法香不好爱欲

于时贤者舍利弗。睹如是像无极光明清净莲华。惊喜无量。即从坐起行诣佛所。长跪叉手问世尊曰。今者所睹为何瑞应。现如是像显大光明。清净莲华不可称计。自昔已来未曾见闻。佛告舍利弗。有一菩萨名阿差末从东方来。与六十亿菩萨俱。与眷属围绕欲至此土故前现瑞。佛说未久。阿差末菩萨应时现身。与六十亿菩萨俱进。则以菩萨无极威神显大神足。开士变化震动佛国。奋大晖曜雨众华香。亦复俱作百千伎乐。至于宝净广普道场。往诣佛所。住上虚空如处于地。叉手自归。以一音声请告三千大千世界。则以义偈。赞世尊曰

  圣雄舍贪欲　　鲜洁无垢染
  其慧除窈冥　　施以清净眼
  断三垢劳惓　　消尽众瑕疵
  永灭诸尘劳　　今故稽首佛
  弃去所破坏　　化裂愚痴网
  圣主有十力　　畏者悉降伏
  超越于众会　　舍寂三放逸
  独步如师子　　所游无恐惧
  其离垢光明　　无所不照曜
  普念于一切　　济度众瑕秽
  无明在蔽隐　　消除诸闇塞
  其光所照曜　　如日出于云
  见众人孤苦　　则为兴愍哀
  蠲除老病死　　无救为设护
  导师诱众生　　弘慈常愍哀
  其所修行业　　如医疗诸疾
  尊舍利御众　　化无明愚憃
  闻已他人患　　度之如船师
  化无数尘劳　　所兴众妄想
  其所游居处　　无著如莲华
  了一切诸法　　本净是寂寞
  口所演音声　　悉从因缘生
  无本横造作　　由习而致此
  愍世怀慈哀　　降训于众生
  归命如虚空　　见一切如此
  处在于世法　　不动如大山
  众生因无觉　　习行不要业
  虽游习居处　　皆度生死难
  道眼甚鲜明　　犹如青莲华
  其威神巍巍　　如月之盛满
  一切世间人　　咸共咨嗟德
  舍恼不乐俗　　以故稽首佛

于是阿差末。与六十亿菩萨。颂此偈赞佛已。从虚空下稽首佛足。绕圣七匝却坐莲华。时舍利弗。承佛威神而前问言。唯然世尊。阿差末菩萨为从何来。其佛所号。国土何类。世界远近去是几所。佛言。汝自以此问阿差末。当见发遣。时舍利弗问阿差末。仁族姓子。所从来处去此远近。其佛所号。世界云何。时阿差末报舍利弗。耆年续有去来想乎。舍利弗曰。唯族姓子吾想已断。阿差末曰。唯舍利弗。其想断者志不怀二。何缘兴念而发此问从何所来。唯舍利弗。其有来者为合会迹。假使去者为别离迹。若令不会无别离者。彼无去来。其无去来为圣道行。唯舍利弗。其有来者自然造相。若有去者罪福尽相。计罪福者为自然相。若于罪福尽诸相者则无有相。无往相者圣道所趣。唯舍利弗。其有来者谓所愿相。若有往者离于所愿。其所愿相离所往相则圣道相。唯舍利弗。其有来者为起生相。若有往者则为灭相。除生往相不起不灭。无所往者则圣道相。唯舍利弗。其有来者为训诲门。若有往者教授尽索。生无教授无尽之门则趣圣道。唯舍利弗。若有往来则堕于俗。无有去来乃谓为道。唯舍利弗。以消去来。除于当来及诸境界。乃趣圣道。唯舍利弗。其有来者为现在相。若有去者为是离相。至于现在及去离相。则趣圣道。唯舍利弗。其有来者为是报应缘起之相。若有去者尽报应相。无有报应不起不灭。至于无相乃趣圣道。唯舍利弗。其有来者随俗缘合而致径路。若有去者谓是音声。言教文字为径路也。设除音声文字因缘径路则趣圣道。时舍利弗问阿差末。唯族姓子。吾今以此仁有辩才故欲相问。所以然者。欲得听采本所未闻。犹族姓子。关尹主者。应得推问出入往反。设有重货。若复空行。欲得责税故宜难诘。卿何所赍以时输税。唯族姓子。吾亦如是鄙等徒类为声闻种。依猗他音而得解脱。合与缘响常宜咨受。诸正士等以用护斯将养大乘。从是出生声闻缘觉。以是之故。善哉族姓子为。分别说所从来处。去此远近。如来国土号字云何。阿差末曰。唯舍利弗。如来在前便可启问。当为发遣。众会被蒙决诸疑网。时舍利弗前问佛言。阿差末菩萨所从来处去是远近。其佛所号。国土何类。其闻名者无央数人。咸发道意被大德铠。佛言。舍利弗。谛听善思。彼世界名有称功勋。及如来号若有闻者。勿得怀疑悉共信之。如来至真无所挂碍亦无阴盖。一切敏达靡不通畅。咸言受教。佛告舍利弗。东方去此度十江沙。诸佛国土满中诸尘。过若干刹有世界。名阿尼弥沙。彼有佛号三曼跋陀如来至真等正觉。现在说法(阿尼弥沙者晋言不眴三曼跋陀者晋言普贤)。不眴世界无有声闻缘觉之名。世尊圣众纯诸菩萨。于往古世造行已备。布施调意。安庠圣哲。禁戒博闻寂无放逸。止足功勋建立闲静。以忍辱力心不怀害。坚固精进积功累德。每生自克。普皆禅思脱门三昧而正受矣。以神通慧而自娱乐。以无极智光明之曜随时分别。班宣一切章句义理。所怀慈心等如虚空。其哀坚强愍于众生。知其志性而开化之。其喜悦者。为雨甘露道法之味。雪除一切嗔恨怨结。其行护者离于二乘。以空无想立无愿法。拔济尘劳众魔秽浊危害之患。明识众生根本所趣十二缘起。观察其疾应病与药。执御斯心平等恒一。如地水火风无有憎爱。降弃一切众邪异学。若干法战坚跱幢幡。犹如勇将大军之师折伏严敌。入于深觉诸佛正法。十力无畏。离二品会。顺从因缘有无之业。超越诸见中间之行。弃捐吾我及人寿命有无处所。反真向伪倒见之本。诸经典门。如来法王法印印之。所演辩才无所挂碍。于无央数亿百千劫所畅音辞无能障塞使不通流。以佛神足感化无量佛国。周旋往反终而复始。晓了随时。蠲除一切恐惧嗔恚憍慢自大。所演音声如师子吼。亦如雷震。察于众生上中下行。坚固亲友永立究竟灭度之地。兴无极云感法雷震。畅慧解电雨甘露水。宣道法珍。不断三宝。志性清净如明月珠表里通达。正觉照曜相好殊胜。则以禁戒而自庄严。以百千德而文饰体。以诸佛法至阿惟颜一生补处。奉遵修行。笃信众生闻化解脱。随其志性令各得所。觉意总持为师子座严净道场。明识超入四无所畏。皆现诸佛所兴事业正觉圣体。取舍进退其心强勇而得自在。转于无上法轮之宝

尔时众会闻诸菩萨功勋之德。欢喜踊跃不能自胜明心生焉。则取天上青黄红白上好莲华及诸意华。佥共供养佛散阿差末诸菩萨上。同俱举声称扬威德。我等善利为获福庆。乃能遭值此等正士得睹晓遇。稽首归命而供养之。其有众生。得闻此党诸菩萨名德不可量。因斯所闻悉当兴发菩萨大心。于时于彼三万六千诸来会人。咸发无上正真道意。佛语舍利弗。阿尼弥沙土者。无地狱饿鬼畜生众恶诸苦。无奉戒敕亦无犯禁。不闻见女人。所以者何。皆由化生莲华交露。无有悭贪亦无淫恚离于痴畏。悉都无此三毒之名。何况余乎。其土人民无上中下好丑差别普等无殊。亦无是我及非我所。复不饮食。所以者何。喜法为食解义为浆。常自坦然。了不念渴亦无饥想。亦非我故亦无他故亦无众魔恐难之患。又其佛土甚极广大。一日月照六十亿四方之域。所以者何。诸菩萨本愿之所致也。由是之故共一日月。又其土地无有丘墟高下斜倾。普悉平正。皆绀琉璃皆以众宝而杂厕间。其地柔软如天綩綖。以十八事庄严国界。其树悉宝行伍相当。常生华实冬夏恒茂。无沙砾石众秽之瑕。黑山雪山其土诸山。皆以诸宝杂合而成犹如须弥

于彼佛土天上天下适等无异。舍于世业以法为土则无王者。唯以如来普贤至真而为法王。又其土法不用文辞告诲诸菩萨也。欲咨受经往诣佛所。观之无厌不以为惓。所以者何。其心欣然应时逮得佛心定意。寻则近至无所从生法忍。由是之故其土号曰不眴也。何谓得佛心定意。不以色相不以种好。亦复不以本宿行故而致是德。亦不悕望作是致是。所以者何。不念过去当来之者。亦复不念今现在世。亦不由从五阴六衰而致之也

何谓为五。其五阴者谓思六根。其六根者谓眼耳鼻口身意所别。其六衰者知色声香味细滑法。不用见闻心意识此众业之所致也。不以巧伪生灭之所致也。无等无邪亦不造意无所悕望。亦非以是亦非不是之所致也。亦不从一二三之所致也。不因心意识。亦不以晓内外众念妄想是非之事而致之也。亦不色痛想行识之所由致。亦不用戒定意慧解度知见。十力不护四无所畏诸佛之法。不可以意想知之。不用见闻故之所致。不以想相亦无我想。不以五阴六衰生灭之处。亦无所住亦无不住。无色痛想行识之处。亦不眼色耳声鼻香舌味身软心法之所致也。亦不得处。所以者何。不可以目而见众相。不可想处见不可见。不起不灭其不终者则不有始。斯住处者因缘所为乃致于是。消除归灭尘劳之秽。所以者何。用爱欲故。故曰当灭。由斯之故断于因缘。用吾我故以是当灭。其净咸明不增不减。亦复不念是安是苦。作是计者不离于欲。亦不用念而以为烦。诸想本脱故行备悉。已能备悉达如无身。色何可得无有痛者。何从有痒。常住如法。若不想道则非俗业。设无所闻何从有识。无所见者亦无所得。无所得者可谓脱矣。亦复不得意念普思心所惟法。亦不赍持无所生矣不睹来者不见往生。本不可得犹如诸法皆等无异。譬如有人上向瞻空。其目所睹不能别知何所是空。何非虚空。佛意如是。菩萨得佛心定意时。知诸佛法。众相种好悉具足成道慧备悉。如来所宣。诸菩萨等皆能解畅。则寻启受讽诵通利。普能周备晓诸佛法。佛告舍利弗。普贤如来。其所颁宣初无二言。何谓为二。一不讲着。二不说断。悉修平等无有适莫。何谓为无。未曾有念从人咨受。亦不自念己有所知。斯诸菩萨适见佛已。辄则具足六度无极。佛言。云何具足。舍众色想无所悕望。是则具足施度无极。不想佛身达之本无。则已备悉戒度无极。所以者何。不自想故以得成就三十二相。计于诸法假有号耳。相无有尽住是不起。是故名曰忍度无极。一切诸法普不可见亦无所闻。所以者何。菩萨大士。见善不悦见恶不戚心无适莫。是故名曰进度无极。心不想念。不可想者而寂恬怕。是故名曰寂度无极。解色相空。不以此相而怀自大。是故名曰智度无极。佛言。其诸菩萨在彼土者。因便具足六度无极。逮得无所从生法忍。遍察十方诸佛国土。众菩萨学少有能逮不眴刹土普贤所诲诸菩萨者

舍利弗谓阿差末菩萨。快哉仁者。彼之佛土诸菩萨众功勋难量。阿差末寻问舍利弗。贤者欲见不眴国土普贤如来乎。舍利弗报。唯欲见之。及众会者皆当被蒙咸荷福庆功德转增。时阿差末即于座上。三昧正受而现神足。所入三昧其号名曰遍见诸佛土。使诸会者及舍利弗。皆得尽见不眴佛国普贤如来。莫不欣然为未曾有咸共起住。佥为彼佛稽首作礼。佛之圣旨使舍利弗及众会者。于衣裓上自然有天华香。则取东向散彼佛上。其华至彼。于其国土在于佛上。遍诸菩萨普同佛界。彼土菩萨自问其佛。今此众华微妙殊特。为所从来光光若斯。普贤如来告诸菩萨。此之瑞应。是阿差末今到忍界。奉养咨受释迦文佛。十方菩萨咸往会彼。所以然者。讲大乘故。彼土菩萨复问佛言。此间显变何佛威神之所恩化。彼佛告曰。释迦文佛十方菩萨咸往会彼。所以者何。讲大乘故。彼土菩萨复问佛言。此间闻之。彼佛告曰。释迦文佛演畅分别大会缘品。时彼菩萨复问其佛。其忍世界去是远近。佛言西方去此如十江沙。诸佛国土满中诸尘。设举一尘着一佛土。如是尽取一一诸尘。次布西方诸佛世界。众尘悉索。过若干土。乃至忍界释迦文佛游居教处。彼土菩萨复白佛言。唯愿欲见能仁大圣兴隆道化。时普贤佛演身光明通照十方。彼诸菩萨及众会者皆睹此土。彼诸菩萨寻时皆起遥自归命。为释迦文佛一心作礼。彼众菩萨遥见忍界充满菩萨无空缺处。怪之惊喜自问其佛。彼佛告曰。十方佛国诸菩萨众不可称载。闻当颁宣大会缘品故往启受。舍利弗问阿差末菩萨。谁字仁者名阿差末(阿差末者晋曰无尽意)。答舍利弗。用诸法故曰不可尽。所以者何。一切诸法亦不可尽。舍利弗言。愿以不可尽法而解说之。阿差末言。本发意时亦不可尽。所以者何。悉遍诸欲淫怒痴醉而无所缚。所以者何。不与罗汉及缘觉乘而俱同尘故。发心已来坚固其志不可转移。所以者何。不为邪业之所迷误。一切众魔不能坏意。有是心者其诸功德悉为成办。游于无常而独总揽众之元首。所以者何。有计常者则生死业。所以特尊解道有常。名曰为尊。出无常故。从发心来其心坦然无所缚着。所以者何。不离诸佛功德业故。所修事业无能得短。所以然者一切众恶悉尽索故。其心永安。不可动故其心无侣。所以然者希有逮故心如金刚。所以然者。皆知一切诸法之故所不可尽。苞裹诸法道慧之故。从发心来强若金刚。等众生故。其心质直而无谀谄。故号曰正而无偏颇。从发心来常怀鲜明。所以然者本清净故。以去众垢悉消诸冥。其慧显曜窈隐皆明。从发心来沐浴众秽。所以然者。其信甚固无所舍故。发心甚大无有边崖。所以然者。心若虚空。发心旷然。所以然者。含受众生当因度故。发心无尽。所以然者。其慧玄旷无所挂碍。从初发心无所不入。所以然者。大慈无极亦无尽故。其发心行无能断者。所以然者。功德愿故。发心甚安极可爱敬。所以然者。为诸众生所喜乐故。发心特尊与众超异。所以然者。一切外学声闻缘觉之所奉故。其所发心无能知意。所以然者。非诸凡俗之所及逮。犹如农夫不能达知圣王之事。发种类心。所以然者。各各从其本种之业皆获其果。一切诸法常存在故。从初发心以为道本。所以然者。由是所致得大安故。发心已来而自庄严。所以然者。成功勋故。发心已来与众殊别。所以然者。达圣慧故。发心已来甚为微妙。所以然者。用广布施普及众生。发心已来建立至愿。所以然者。具足戒禁。其发心已来而无等侣。所以然者。无所不忍。其发心来无能抑制。所以然者。用精进行无懈废故。其发心来无所慕乐。所以然者。寂度无极致定意故。其发心来无所归趣。因其晓了智度无极。其发心来永无所住。所以然者。用无极慈故。其发心来根株坚强。所以然者。用行悲哀故。其发心来常怀悦豫。所以然者。于诸众生怀等心故。其发心来虽遇苦乐不以为动。所以然者。护一切故。其发心来为诸如来所见将养。所以然者。用顺十方诸佛教故。其发心来欲度一切五趣众难。所以然者。兴隆导化。其发心来不舍三宝无所违废。所以然者。将顺佛戒成圣众故

阿差末菩萨。复谓舍利弗言。一切智心宁可尽乎。舍利弗报言不也。犹如虚空不可穷极。其一切智心不可尽极亦复若斯。如来禁戒亦不可尽。所以者何。戒是根原故不可尽。如来定意由无有尽。智慧解脱度知见无根故不可尽。计于十力四无所畏。十八不共诸佛之法。斯则是根。此亦心本故不可尽。取要言之。一切诸佛法为元首。由斯心行故不可尽。三宝无断。因是之心故不可尽。犹如一切众生四大。何谓四大。地水火风亦不可尽。计是智慧用一切故。咸复晓了不可思议众生心行。本愿不断故不可尽。所以者何。修奉道愿故不可尽。皆无所生靡不恍惚。一切诸法根原无穷。故不可尽

阿差末菩萨经卷第一阿差末菩萨经卷第二

        西晋月氏国三藏竺法护译

阿差末菩萨谓舍利弗。发菩萨心永无穷尽。所以者何。不文饰故。亦不谀谄其心质直。故曰殊特。不为绮辞用清净故。平正无邪。其心柔软而无粗犷。笃信真要未曾变改。所立坚强而无动转正住不摇。无能憎嫉而娆害者。以何等故无能娆者。其行治业莫能逮故。有所建立无能诽者。所以莫能讥谤者何。敢所兴造无根原故。所以无根用中正故。所言至诚终无有异。有所兴功无所悕望不求名称。为众所叹咸共戴仰无能得短。所以无能得其短者。有所造作长安隐故。所以自致永安隐何。所兴功德无懈惓故。所以不厌用愍一切众生之故。所以愍念众生者何。用无极慈为懈惓者而兴精进。所以者何。欲以养育众生之故。所以养育众生者何。由斯之便成功德故。所修效力不悕望福。所以无求。其心净故皆蒙法恩故。无所求人亦有力。何谓为力。曰是佛力。以是之义护一切故。所以护之。欲令群黎各得其所。所以欲令各得所者。使无恨故。所以无恨。所作事业极安谛故。所以谛者由是之故。无能制止无能谏抑令止寂然。犹若紫金而无点污。所以喻之如紫金色以无有秽。所以无秽用本净故。所以为净本行去秽故。所以去秽内以净故。所以消瑕瑕已尽故由是清净。阿差末谓舍利弗。心已净者贪欲转消。其无贪欲是不可尽。其诸恶心不能复乱。又其心明护于恶意。由是之故曰不可尽。其心嗔怒有所众贪。汲汲于欲贡高自大。诸所不可皆悉尽索。将为菩萨常护是心。当晓是心而不可尽。舍无瞻势及诸垢浊。当达是心不令懈怠。则知其心为不可尽。若愦乱者随时将护。其无智者养育使成计于一切众生之党。有功德法无功德法。咸便度脱至于大安。则知其心而不可尽。训诲一切众生之等诸在厄难。皆令兴立无极功德。则知是心永不可尽

阿差末菩萨谓舍利弗。菩萨所习亦不可尽。所以者何。用所布施故不可尽。诸可惠与是名曰习施度无极。于一切物多少取足不以汲汲。是则名曰戒度无极。一切有娆于菩萨身。不起嗔心如毛发者。是则曰习忍度无极。所积功德常在众前而不在后。是则曰习进度无极。一切所学悉勤用心。是则曰习寂度无极。诸所听闻悉欲博达。是则曰习智度无极。菩萨当学修于大慈。何谓大慈。若有厄难来自归者欲求救济。宁亡身命不负要誓是则习慈。其行哀者等犹如称。若有加益不以忻悦。设诽谤者不以忧戚。是为菩萨随时等哀。菩萨所学则以三事。净身口心终不传恶。未曾念邪愚蠢之业。菩萨虽学独步无师亦不自大。其所学意不舍普智诸通敏慧。揽诸佛法菩萨之业。在人所求不逆其心无所短乏。致一切法而得自在。又习悔过。身有罪恶未曾藏匿。用无量福劝助功德。菩萨修学赞劝诸佛颁宣道义。奉习勤学正士之法。所以学此正士之法。欲成觉故。其心坚固不舍弘誓无极德铠。所以不舍欲化一切众生之故。阿差末菩萨谓舍利弗。菩萨有四为不可尽。何谓为四。一曰开示之心。二曰法施。三曰训诲众生。四曰积累功德。是为四。复有四。一曰习在闲居山岩独处。有施多少趣足而已。二曰于众功德而无厌足。三曰博学不惓。四曰所愿智慧不以为劳。是为四。复有四。一曰校计规度。二曰思惟本末。三曰智虑通达。四曰所念普具。是为四。复有四。一曰离于众恶而修上脱。二曰其上脱者是菩萨教。三曰解诸恶本。四曰念于微妙无上之脱。是为四。复有四事。一曰解于五阴。二曰。晓于四大地水火风。三曰了六衰之原。四曰其所睹见十二因缘无有边际。是为四。复有四事。一曰无常生死之语而不可尽。二曰苦痛之教。三曰无吾我训。四曰寂寞无为之业亦不可尽。是为四。阿差末谓舍利弗。举要言之。诸菩萨学皆近佛道。以是之故分别道俗悉不可尽

阿差末菩萨谓舍利弗。菩萨修行心不可尽。所以者何。于诸功德而不懈怠。从次转上成就其处。所云处者。菩萨十地。其所修行犹如大海所苞无厌。所以然者。多所救度一切众生。其所修行则为元首。所以然者出其上故。修行最上所可总揽。诸在下者令修专行一切法故若持众善。所以者何。用最尊故。所以修度因则受决。皆由专精用不退故自致具足。因其专精所愿辄成。以成大愿。其所修行永无所恃则是定意。依修柔软所造行者而不缺漏。修行伏意是其道业修行自守。所以者何。以不复与众恶从事故。专精布施。菩萨不以身心有所贪爱。转增上故。专精奉戒亦为甚难。所以然者。教犯戒者使不为恶故。专精忍辱亦为甚难。所以然者。虽在尊位财富极乐。不轻贫贱羸劣弱者。是为忍辱。所修专行精进难。及坐佛树下。若有人来。言起避去我坐其处。先取佛道即舍与处。是为精进。专精禅思所以难者莫能及逮。所修专精辄能成办。无所悕望故。是曰禅思。专智慧难。所以者何。积功累德不以劳烦。是为智慧。出入行步安庠和雅威仪备悉。所以然者。其功祚强无能危者。修无所畏晓了深法钩玄致远故奉修尊心。所以然者。其明极微无不达故行不可尽。所以者何。所住坚固。何谓专精。其意坦然常念一切。无所依者令得其依。若有闇冥使睹道明。无所归者悉受其归。其无善友为之善厚。其谀谄者令修质朴。见其粗犷显示忍辱柔软和雅。所以者何。以德化故在谲诡中而为列露真正之义。于校饰中不为绮大。在无反复行报恩德。在众恶处而修善行。在废退处奉修德祚。在欺慢处常行恭恪。在贡高处不怀自大。在求便处无能得短。不念人恶不宣缺漏。若在不正辄往将护使入正谛。一切众生皆来到所。见之欣然无嗔恚心。其有谏喻示进退宜当然不然。心无增减。笃信祸福所作归身。若在旷野山居岩处如法无异。不贪利害不惜身命。心净之故初不增减。常护其口不忘传语。不求奉敬。所以者何。恒知节限止足而已。其心柔和不随弊恶失礼义者。有功德故。度于生死息众苦患。所以者何。由是之故菩萨慧意永不可尽。生死往反亦不可尽。以权方便。明了随时训诲众生迷于终始。不可尽者。使求佛道明不可尽。舍利弗问阿差末言。乃有异不可尽乎。阿差末言有。问何所是。阿差末曰。菩萨布施复不可尽。所以者何。六度无极不可尽故。菩萨布施悉无有限。所谓限者某是某非。当施与某不施与某甲。施不普济不应为施。舍利弗问言。菩萨之法当云何施。阿差末曰。饥者食之。所以者何。人依衣食乃得存命便能苏息。坐起言语则为安隐。身体康宁气力强盛。渴者施浆除其消渴。所以者何。若在后世。周旋生死常不渴乏。有求车者辄随意与。由是之报后所生处。神足飞行在所至到。其无衣者因施与之。后世所生便不抵突常抱惭愧。若于冥处施之灯火。则得道眼通见十方。若于世尊师父寺舍二亲长老前。而作倡伎以娱乐之。后世所生得道耳听彻闻无极。若无香者则施与之。后世所生逮致戒香慧定解脱知见品香。是身为被德熏之香。若复有求杂香名熏。即与所好。后世所生身体香洁莫不悦豫。所有甘美殊异之味。人来求者辄从意与。后世所生常得肴馔。若不甘者入口即美。宿之所殖而得是相。其无手巾因施与之。后世所生清净无垢。为人所护。其无护者为之将护。犹若屋室。所以喻室覆盖人故。随其所乏而施与之。后世所生悉获所当寻得周给病与医药。后世所生身常无病不生不死。无有众患恒获安隐。一切备足靡所不主。其无仆使给与奴婢。后世所生自然具足。万乘帝主制上御下无所乏少。其求众宝则能与之。后世所生备悉成就三十有二大人之相。布施杂物若干种品。后世所生得八十种众好之姿。象马施者后得大乘无极之意。以田施与因得具足寂度无极。妻子施与惠所珍爱。后无异心当得佛道。所以者何。佛者极上尊无俦匹。假使有人从其菩萨。求满仓谷即能与之。未曾贪吝后逮法藏。充备道慧无所匮乏。菩萨设得为转轮王主四天下。七宝盈满。若有来求而不爱惜辄能尽施。后所生处逮一切智。诸通圣慧广济一切。以妙伎乐而施与者。后得经典乐以法乐莫不欢然。若为势位有忠羽翼行菩萨法。犹如王者之忠臣。有人来求以自辅政即能与之。由是之故后佛法教欲坐道场。于佛树下降伏魔兵。以手施人。后为一切道法之首。耳鼻施者。后身具足无一缺漏。以眼施者。后逮法眼为一切首道法之眼。以头施者。后所生处。三世特尊。独步无侣诸通敏慧。肌肉施者。后成佛道人来听经。舍诸不要皆获真正菩萨。破骨以髓施者。后得佛道身如金刚无能动摇

阿差末曰。菩萨不以色故而有所施用修正故。若来求多后人求少。悉遍与之使各得足。若施与时不恐不怖不畏不懅。无贪行施不怀悔恨心未曾变。菩萨无轻慢施专心而与。无谀谄施。不持恶物无所中者以与人也。菩萨布施。未曾观察某有福祚。甲有罪殃无有狐疑不别好丑。不中断绝遗漏施也。何谓中断遗漏施于大会中独与一人不与一人。悉欲遍济。所以者何。菩萨所施常怀笃信。不念懈惓无恼患施。菩萨布施不呼人至前。目自见面乃与之也。亦不思惟某善某恶。不必选求得成道者来者便与。施人之后不作是念。某已得道某不得道。菩萨施与见奉持戒人来受其物不以欣然。见无戒者亦无异心。其所施与不望还报。有所施者不求名称。使远近闻不自咨嗟。不恶诽谤菩萨施与。不行烦扰不怀恨施。无嗔恚施不欢喜施。菩萨布施不念后世当得其福。不起忿心骂詈愚施。有来求者不前却彼乃施与之。不轻易施。不倩他人持物往与。所以者何。手自斟酌。亦不念言值吾前施。不当前者不施与之。不挂碍施自用心施。不卒暴施手自授之。不沉吟施乍与乍不与。菩萨不念吾所可施疲惓劳极。施从来者不多不少。不选择物恶者与之好者留之。若有来求如本言要未曾减损。菩萨所施愍念众生弘无偏党。欲令受者常获安隐。若施与时则念其人是吾国界。所以者何。一切皆是菩萨之道地也。又所施者少不轻己多不欢喜。虽布施多不自察言。我今广施所与如法无悕望故。菩萨所施不念是福。当有所生受其功报。所以者何。施于一切众生蒙恩故。所施人者亦不念之。吾于天上天下人中独致尊势。其所施与普为众生。不以其福求慕四王释梵之位。亦复不贪转轮圣王。不习声闻缘觉之心。菩萨施与心不念言。所施具足亦不惟少。足与不足有所施者。使一切众不离于佛诸通敏慧。所施与者常得其时无有不应。不以兵仗毒药施与。以安施人不加娆害。菩萨布施从佛法教。所可惠施知一切空。所以施者以为因缘有所兴发。由斯之故而不可尽。所施与者悉晓无想。为诸想者建其因缘故不可尽。所可施者皆达无愿。为诸愿者作善因缘。由是之宜故不可尽。以道法意而有所施。其心坚强完具甚安无所破坏。菩萨所施其在三界无能逮者。所可施与欲令其福归流一切菩萨之业。其志常建一切智心。以是之故为不可尽。所施与者以脱诸想。总揽众魔令不自在。离诸烦苛故不可尽。菩萨所施与众超异。明泥洹故。所可施者决众疑心故不可尽。所施与者正住佛道不怀异心。所施等愿故不可尽。菩萨所施坐佛树下得成正觉。所施与者及无央数。不可称计众生之类。皆荷济度故不可尽。所施与者不可尽矣。其事广大。所施与者以得道处。无能动者无能超踰。况复施者故不可尽。所施与者其心坦然。如一切智故不可尽

舍利弗言。善哉善哉。仁者阿差末。叹菩萨施及不可尽。快哉乃尔。愿欲受听菩萨戒禁不可尽谊。阿差末曰。菩萨戒净亦不可尽。有六十四事。何谓六十四。菩萨行仁不怀害心加于众生。身亦不杀不取人物不犯他妻。若见菩萨及向众生。常行至诚未曾两舌。有诤讼者常和解之。终无骂詈不为恶口。所以者何。常有惭耻所言护舌不妄说事。于一切人不念嫉妒。不兴恚心向于众生。所以者何。由此能忍后世端正。常正其心不事余学。恒抱悦心在于佛道。所以者何。其心清净无有尘垢爱乐佛法。所以然者。解无异法能出上者。至心在道用慈仁故。若见沙门梵志辄以五体而自归礼。何谓为五。两手两膝及其头脑稽首足下。所以者何。因得佛道一切归故。心常柔软见人犯非慎己不为所不缺戒。无有声闻缘觉心故。于诸犯戒而无所犯。所以者何。后世不欲生在于鱼猎愚闇家故。常修精进而不懈怠。所以者何。不与邪恶共从事故。戒禁完具未曾阙漏。亲近智德解深法者。不违远故。笃信禁戒所奉正故。顺戒如法一切众生皆歌叹故。其护戒禁清彻至真。本心快故行持戒要。无能传非说其瑕秽。无邪心故。其戒完具。不复迷惑从六衰故。所奉戒行莫不宣闻诸佛正觉之所知故。戒无所求如己乐故。戒知止足无所贪故。其戒纯淑不杂众恶。身意坦然无所乐故。常好闲居未曾喜乐于众闹故。戒能备悉如道法训。不从他人有所受故。谨慎禁戒不以好服而为绮饰德无能逮誓如本愿。不以甘美而乱意也。所以者何。以有道力制众恶故。所行如戒诸天人民莫不悦故。行慈心戒护众生故。修悲哀戒忍众苦故。遵于护戒不解怠故。以等心戒为一切众。任于善恶无二心故。常察禁戒不为损耗。不听其心为驰骋故。戒不念恶不传人非护一切故。坚执持戒不听其意随所欲故。顺布施戒养育一切众生之故。为忍辱戒不起心故。志精进戒不回转故。禅思之戒得安定故。奉智慧戒博听正义无厌足故。修广闻戒觉要法故。随善师戒达诸法故。舍恶师戒离众邪学不真路故。无猗身戒知诸万物皆无常故。不贪命戒其功德业如紫金故。无悔恨戒其意净故。无虚饰戒学清净故。不烦苛戒其意鲜明无垢浊故。不焦然戒不烧身故。不迷惑戒不随欲故。不危烧戒无所害故。无抵突戒心不乱故。伏心之戒意无误故。通寂静戒不为俗业之所废故。顺真正戒智如教故。具诸愿戒本清净故。如如来戒。所以者何。随本要故。如佛定戒常怀等心度众生故。从一切智入道门戒。所以者何。不抱恨故。是为菩萨六十四事。清净禁戒而不可尽

阿差末菩萨复谓舍利弗言。菩萨复有净戒。不自贪身不念一切。不想我人不计寿命。不思名色痛想行识。不猗四种地水火风。各有四大戒。不有眼色耳声鼻香舌味身触心法。无身口心其戒向净。是相一心而不迷荒。谛观诸法戒以过空无想不愿。亦无形像过于三界。不着不缚。其戒不念尔故不为已生。所以者何。无所生故。所以为戒无作不作本无所造。由是之故戒无部界。此止中间亦无所止。意净为戒识无所住。所以者何。无想念故。戒无所拘。所以然者。无欲力故。亦不住色亦不无色。而俱同尘是名曰戒。离淫怒痴因愚冥脱是故曰戒。不着不断舍十二缘是故曰戒。不念我所除我不我。不住欲故是故曰戒。无作不求不住色想。亦不处在一切名色是故曰戒。不随因缘无烦无苛。无我非我不与疑合是故曰戒。亦不贪福不无功德。以越诸恶非法之事。所以者何。愚者非法是故曰戒。无有扰恼其身心止是故戒相。奉慎戒者如病得愈。不断诸佛经典正籍。法身坦然不可尽故不断法身。所以者何。无二业故。一者不着。二者不断。不断圣众因用脱故。不断诸学。所以者何。顺禁戒故

阿差末菩萨谓舍利弗。因本清净故不可尽。何谓俗戒。谓生死处亦有尽矣。所以者何。在于五趣故名曰尽。所以尽者。有往反故不住一处。其外神仙五通之戒世俗之智。求上长寿神足命尽。所以者何。戒禁尽故。人戒十善亦复有尽。所以者何违舍戒故。诸欲天子戒亦有尽。所以者何。功德毕故。诸色天子定戒亦尽。所以者何。其定乱故。无色天子寂戒亦尽。所以者何。寂意荒故。其道迹学无学罗汉戒亦有尽。所以者何。猗泥洹故。其缘觉戒亦复有尽。所以者何。无大哀故

阿差末谓舍利弗言。唯菩萨戒独不可尽舍利弗问。以何等故戒不可尽。阿差末曰。其戒尽者斯皆非戒。所以菩萨戒不可尽。其心不舍一切智故。是正真戒为不断种故不可尽。何谓果实道果无尽。所言种者谓菩萨心。所云果实则佛十力至不可尽。故曰菩萨戒不可尽

阿差末谓舍利弗言。菩萨忍辱亦不可尽。有三十二事。何谓三十二无尽。不着欲者不兴此念。是我妻子身皆不犯不令他犯。是故忍辱亦不可尽。不念众恶不恨一切。不恚众生不惟人恶。不与人诤不忘助人。有所毁击亦不掩戏。自护身行将护众人。慎己心不随。常思善德无爱欲意。得庄严身。信作善恶当得报应。口不妄语其心清净。菩萨心强不舍一切。谛自思计心所念邪。即觉知之。心和柔软。将护其心令恶不生。修清净行生于梵天。从天上下还在人间。具足德相众好八十。逮致和音犹如梵天。脱淫怒痴。不以恶颜恚恨向人。所作功德未曾亡失。降伏外学众邪异术。以舍众病不遭厄难。以顺具足诸佛道法。是为忍辱悉不可尽三十二。是菩萨忍辱。何谓忍辱。若骂詈身默不和之。若挝捶者不念报之。是谓忍辱。所以者何。不见挝者不睹己身杖本空故。若有嗔者亦不怀恨。言若幻化其起意来不生心逆。能伏意故。若念恶者心若不知自思惟之。斯人赍恶吾不宜效。有称誉者不用悸喜。所以者何。不生此念得利益也。降伏心故。若有衰耗不以忧戚己知足故。见人叹者不用为绮。若有诽谤不以为动。所以者何。智广大故。有恭敬者不自贡高修性安故。设礼拜者不用悦豫。亦不说言卿宜当然。若得势位不以自大。所以者何心不动故。愍哀众生虽在勤苦不以患厌。在于乐处不用欢喜。晓了俗事皆无常故。不以世八事而见倾动。所以者何。不处其中为人所娆。终不还报无敢犯者。假使有人节节解身悉能忍之。因欲具足菩萨业故。若害身者终无异意。了身四大合成散灭何足可贪。所以者何。缘是忍故当得佛身。悉忍众恼不可计难。所以者何。缘是得致建立大安至道力故。菩萨若在梵志学中。现身入火无所伤害。欲令其人知心清净。化于惑意使志反真因得上天。其梵志学好喜火祠。菩萨所现无所不变。道德超殊莫能逮者。所以者何。诸梵帝释四方天王。稽首菩萨皆为作礼。菩萨忍辱无有边底以是之故曰不可尽。其骂者忍不以为恨。亦不念之谁骂我者。因是寂然便入法忍。不思惟之骂吾眼耳鼻口身意。若骂心乎骂所在耶。则过诸衰便逮法忍不念一切谁来骂者。寻能得入无人之忍。是诸忍者悉不为忍。所以者何。假有号耳。谛计其忍犹山中响。有解此者入无常忍。不念得我及得他人。逮中和忍亦不自念。身随法教某不住法。是名曰忍。我独住道其余人者不建立道不兴斯念。我念空不念实。念无思想不念有想。念忍无余不念忍余。念忍无愿不念有愿忍无生死不有终始。忍为可无不可。忍为有德不为无德。念忍无生不念所生。忍度于世不与世合。忍为入道不为无道。念忍为脱不为无脱。解忍泥洹不为生死。菩萨忍辱不生此念。所以者何。不平等故。菩萨等忍为何谓也。解入空无所断无所著。是菩萨忍。亦不念生不念不生。不念化生。若无化生。不兴念言有之与无。晓了此义至不可尽。以是名曰不可尽。忍悉无所作。不思当然及与不然。无有现者无缚无脱。亦无所生无造起者。故无所生而不可尽。其忍如斯。是为逮得无所从生法忍。如计无所从生法忍。至于如来坐佛树下。入此忍者应得受决曰不可尽。说是法忍品时其在会者咸皆赞曰。善哉善哉。如阿差末所说诚无有异。时十万天。悉以天华名香幡盖。供养奉散阿差末身诸菩萨上。诸天伎乐自然为鸣以娱乐之。心各旷然怀宽弘意。一切皆言令诸众生普悉得明。若如来忍其闻此音。不恐不惧心不在懅。诸华名香幡盖充满。遍于三千大千佛土

阿差末菩萨经卷第二阿差末菩萨经卷第三

        西晋月氏国三藏竺法护译

佛告阿差末。仁者于今为能苞[果/衣]一切众生乎。阿差末言。承佛圣旨具悉任受。阿差末菩萨适入三昧。应时一切诸有色身。供养华香缯盖幢幡皆入脐中。其身如故不增不减。有一菩萨号曰大净。问阿差末所入三昧名曰何耶。显现变化乃能悉受一切色身华香幡盖。其身如故而不增减。阿差末曰。其定号名普受色身。大净复问。是三昧者但能受此复受余乎。阿差末曰。三千大千国土悉入于身不见所在。所以者何。以威神故无所增损。时诸众会诸天人民。菩萨声闻皆各有念。犹如久渴望想饮矣。欲见大士所化神变。佛知众心语阿差末。为一切人现是三昧。阿差末曰。辄奉圣教。应时十方诸会菩萨佛及众僧。悉自见身坐阿差末脐。阿差末脐现有国土名普庄严。诸菩萨服如庄严国众菩萨也。亦复皆现在其脐中。所显普严巍巍如是现威变已众会各坐续复如故。大净菩萨报阿差末。三昧圣恩威德超殊光光乃尔。阿差末曰。是不足言。所以者何。三千大千天地山陵。悉受色身为微末耳。受江沙土不以为迮。况其余耶。说忍辱品演神足时。七十垓仁和善人发大道心。万二千菩萨皆得无所从生法忍

舍利弗问阿差末。愿乐复闻菩萨精进而不可尽。阿差末曰。菩萨有八精进无尽。何谓为八。一曰被于弘誓大德之铠。是为精进而不可尽。二曰合集精进而无所退。三曰勤学长养一切功德。四曰常欲养育普及众生。五曰造立无数福庆之原。六曰心元无求诸度无极。七曰晓了智慧而无穷极。八曰欲得备悉一切佛法以故无尽。是八精进而不可尽。阿差末曰。所以名曰被弘誓铠。不以生死用为劳苦故。所以者何。不计劫数当成佛道。亦不思念于若干劫行菩萨业。所以名曰为弘誓者。不限长远无量劫故。菩萨犹为一切之本。方俗所更始数。一日至十五日。若三十日合为一月。十二月为一岁。如是转进至十万岁。若百千万岁发意求道。悉却是数犹若干载。乃见一佛。如是比数诸江河沙。初发意等一切众人。各皆发心各悉包容。江河沙等诸菩萨亦如是。无央数不可计一切人悉发意。意所知裁及一事。其未所知不可称计。犹如供养江沙等佛。然后乃具施度无极。戒忍精进一心智慧。三十七品亦复若斯。菩萨闻是其心不懈。不舍弘誓大德之铠。江沙等人皆发道意。合集此德乃能具足一大人相。一切如是各如前功。乃悉周备诸大人相。其大人者谓菩萨也。菩萨闻是不以为劳。所以者何。未曾违舍弘誓铠故。是为菩萨被弘誓铠而不可尽

何谓增长精进而不可尽。若有菩萨勤欲闻法。不计远近不恶水火。所以者何。无懈惓故。菩萨增长合集功德不用退却。合会劝助众功德故。何故合会。欲以开化众生之故。令其度脱使入泥洹故。而般泥洹不以懈慢。有坚固心无能回者。常求功祚不用厌惓。恒住大哀故曰合集。菩萨所至行步坐起不忘道心。如一念顷念佛法教。护于一切不以为烦。故曰合集而不可尽。何谓长养一切精进而不可尽。所立功德志愿常存于诸通慧。以故名曰为不可尽。犹如众龙还雨大海。不可别知渧数多少计之无尽。诸通慧者功德如是至不可尽。何谓造立无数功德。所作用心为一切故常怀等意。所立功祚不离通慧。所修福愿欲使众生皆共蒙恩。以故名曰立无数德。何谓心求诸度无极。众生四大悉不可尽。不可数者入此诸数。一曰悉教三千大千世界众生之类。如是比像不可称载。阿僧祇人皆开化之无限如斯。百倍千倍万倍亿倍。百亿万倍不可计喻。所教度者为少少耳。闻是不恐亦不畏懅为应精进。是谓造立无数功德而不可尽。何谓晓了智慧而无穷极。菩萨功德不可尽故。如是悉计一切普智诸众生本所作功德。乃及道迹往来不还。无著缘觉皆合此德。乃成于佛一毛功德合集计是。各各悉成体诸毛孔巍巍众德。乃能成佛两眉间相。若斯眉间千倍之福乃成顶相。所以者何。天上天下无能堪任见佛顶故。以是故曰德不可尽慧无穷极。又复何谓慧无穷极。正使三千大千世界众生悉笃信佛。如是信佛其信百倍。乃与奉信者同等功耳。设奉信等周满三千大千世界。其智百倍不及八等人。若八等人满三千大千世界。其智百倍不如道迹。若三千大千世界充满中人。求道迹业往来不还及与无著。其智百倍不如一缘觉智。若三千大千世界满中缘觉。犹不如一发意菩萨之智。正使三千大千世界。充满其中初发意菩萨。其智百倍不如阿惟越致。正使三千大千世界众生悉成不退转。其智百倍犹不如一一生补处菩萨之智。正使三千大千世界众生为一生补处。其智百倍不如一如来处处慧力合诸力无所畏入佛法游要慧所以者何。其一切智悉入佛意。菩萨闻是不恐不惧不畏不难。是则名曰习无穷慧而不可尽。何故习无穷慧而不可尽。用入一切众生心故。正使过去众生心念无限其发道意。一人明解悉晓了知此诸过去众生心念。等于众生犹如一人。如斯比像不可称计。众生之党皆淫怒痴之所覆盖。复有一人入淫怒痴惑乱之中。而为众尘见愦迷荒。菩萨发意恒以道慧皆知众生淫怒痴乱。是曰慧明之圣弘智。若诸众生悉各发意。善恶因缘因缘所为起者灭者。如是慧者虽处其中心不以烦。皆能畅达犹如虚空。其虚空者无不空处。圣慧者然。心所明解三世众生靡所不达。故名曰慧而无穷极亦不可尽。何谓一切佛法亦不可尽。悉具一切六度无极求诸佛法。若有菩萨从初发意所修方便。然后乃致坐佛树下。发心功德不可称计。普悉具足皆成佛法。故曰菩萨合诸佛法而不可尽

复有菩萨合集精进亦不可尽。身所立德不以为难。口演功祚亦不以惓。意惟勤修。其身口心三事精进则是元首。何谓意精进其意泰然。何谓泰然用求佛道。用求佛道为何谓也。恢弘其心寂无所为。何谓发是。发是意者谓发道心是。此则菩萨之大哀也。何谓菩萨地。信乐无我是曰为忍。何谓发是其发是者悉能总摄一切众生故。何谓为处。用得备悉具诸法故。不以生死为勤劳也。其发是者不着三界。其发是者身诸所有无所爱吝。又其处者所可施与。不叹宣已有斯德行。所谓处者。不以禁戒而自称叹意存自大。又其处者忍众苦恼不以是业而怀憍慢。所谓其处所获功德。转曰增益巍巍无量。所谓处者是志度脱。不离布施伏心制意。所谓处者学问无厌如法习教。所谓处者如所闻义。奉行不改无有异意。所谓处者习学思惟不可讲法。权谋方便不以为难。习无悕望所颁宣法。玩习讽诵念察晓了其义之所归趣。不用劳厌而懈废也。学修元元无所想报。是有四事是为菩萨之所修行。所以者何。其能发此慈悲喜护。又其处者所瞻察意普怀大哀。又其处者缘是之故。具足五通习无生死。又其处者得四意止逮于顺理。不当所思而不惟之。又其处者知四意断不废功德。亦不抑制无福庆人。所以者何。修中间行。又其处者神足所习。如佛法教无所悕望。又其处者习学善德诸根不乱。无限非法悉能分别。又其处者谓十种力。无有能胜心怀圣智。又其处者欲求佛觉。诸兴造行入众法义。而不自大成七觉意。又其处者求斯道德不念诸来。及住去者亦无所想。又其处者慕求肃敬。寂静其志而无愦乱。又其处者欲得正观。明察诸法求其所存。又其处者曾所博闻便能修习。常如法住务修身德行。又其处者求于法身而损众俗。妄想之着信达无形。又其处者谓彼音声常欲庄严。随时畅出通于十方。又其处者乐如道行。脱不脱者使至永安。又其处者谓不合非劝化四魔。何谓四魔。一曰身魔。二曰罪尘魔。三曰死魔。四曰天魔。又其处者离诸恶习修众德本。诸秽寂然而不兴乱。又其处者普见道慧察众缘起。又其处者见诸所入世俗所作。消息方便因济度之。又其处者咸睹道法而随时化。是意精进而不可尽。若有能具一切处者。终无诸难所作悉解。不以妄想住所行慧。亦不动转一切所行皆不离慧。何谓菩萨行不离慧。所行功德悉因是法。常为一切兴无极慈。无极慈者不尽世俗。因佛道慧不随无为。是名菩萨无尽精进。宣说精进不可尽时。九十六垓诸天世人。皆发无上正真道意。三万二千天子悉得无所从生法忍

舍利弗复问阿差末菩萨言。岂复有义施度无极不可尽乎。阿差末曰。用十六事而不可尽。声闻缘觉所不能及。何谓十六。一曰所施不怀异心。而悉具足如来法施。二曰所施不兴斯念。吾缘是故当获福报。三曰所施普愍一切不怀异心。四曰所施不念望得三昧正受。所以者何。不乐生于净居天上常好人间。五曰所施皆能达知众生心行。六曰所施其意清和。所以者何。欲使其心随己计故。亦令其身从心所念。七曰所施如受者意。所以者何。其德以过色无色天。八曰所施与寂寞俱亦复恬怕。所以然者。过诸声闻缘觉上故。九曰所施不协恨心。所以者何。欲使究畅至成就故。十曰所施威神巍巍无能制断。十一曰以智慧施普等众生立度一切。十二曰其所施者所施与人随意喜乐。而惠救之心常正安。所以者何。能御意故。十三曰其所施与不断三宝。所以者何。不舍如来至真之种。十四曰所施常明不怀犹豫而不迷惑。十五曰所施与者顺如法教。所以者何。所行随义。十六曰所施与无所不知。有所兴造乐智慧本。所以者何。欲令其智。无有穷极甚广大故。是为菩萨十六事业施度无极而不可尽

何谓为禅心寂静故。何谓神通慧具足故。何谓为慧所见诸色是则不通。睹诸色尽其意不随此名曰通。所以者何。而不中道行取证故。其所听闻皆在不通。诸可有音悉无逮得此名曰通。悉能晓知众生心行是则不通。心除此智不以尽心而造证矣。所以者何。不取罗汉此名曰通。能自知本因所从来是则不通。不于三世而有挂碍此名曰通。遍诸国土是则不通。虽遍诸国解无所有无刹土想此名曰通。信向诸法是则不通。达见一切诸法本末此名曰通。一切所作有妄想意是则不通。晓了众生无所悕望此名曰通。乐欲往生若过诸天释梵四王是则不通。菩萨皆知一切声闻缘觉所修圣慧。悉能总揽此名曰通。为众元首。所曰元首在于诸法最上之故。因是名曰通慧功德而不可尽。阿差末菩萨复谓舍利弗言。因诸乱意菩萨以故习自伏心。是曰为禅。其智慧者悉舍众恶是曰禅定。又菩萨行习住定意则无变心。所以者何。云修正住。修正住故习六度无极。正诸法故。习诸法者用正故学。习菩萨行等心众生。已等众生便等诸法。已等诸法知菩萨心。已知菩萨则能畅解众生志操。知众生已则知诸法。是名曰习弘等一切众生之类。悉等诸法而无适莫。等住诸法。是名曰定意为正受矣。空无想愿谓等生死。等生死者便等诸法。其已平等坦无偏党。心普等者等众生心。等众生心已乃谓平等。故曰普等。其心所行平若虚空。如地水火风无有爱憎。其心等者无忧无喜。其身已住不眴佛土。定若三昧。不以谀谄如本际住。而不自大亦不贱。己不痴不恶亦不多辞。唯欲晓了法之本原。是时非时常随时宜。不从一切世俗之秽越世八事。利衰毁誉苦乐有名失称。舍诸有为不好愦闹。随是法者不离三昧。所以者何。皆见天下所造立行。随其所行续在三昧莫能知者。是曰菩萨善权方便。深入智慧寂度无极。若欲三昧执御其心。由无极哀而随因缘。所以者何。用众生故。斯义名曰善权方便。寂然恬怕三昧之业。此为圣慧。已如三昧所建立者依仰佛慧是曰善权。而于诸法永无所求是曰智慧。奉执定意又以功德化护诸法是曰善权。其心坦然不坏法身是曰智慧。以三昧定住念佛身。诸相种好是曰善权。弘恩元元念佛法身是曰智慧。于三昧中念佛诸音。犹如梵声是曰善权。思知诸法无有言辞是曰智慧。住于三昧心如金刚是曰善权。虽获禅定不忘世俗众生群党是曰智慧。而于三昧念备本愿长育一切。是为处处随时善权。又于禅思解于众生悉无吾我是曰智慧。游于三昧不舍诸法是曰善权。晓无本末亦无根原是曰智慧。修于三昧思诸佛土悉为清净是曰善权。解诸佛土都无所有是曰智慧。在三昧住惟有佛树修之庄严是曰善权。身离众欲而无秽浊是曰智慧。又在三昧念转法轮是为善权。遵行禅定转无所转是曰智慧。住于三昧欲见菩萨。以相庄严是曰善权。以济众苦无有烦恼是如来禅。如来禅者了一切法。永不贪欲不想尘劳。知诸情乐除众法想名曰禅思。是为菩萨所生地慧。开士大士以诸一心与法不同尘是乃名曰不可尽禅。不为一切众魔得便。则为正觉造诸法器。所以者何。靡不含容。正士说此寂度无极不可尽时。四万菩萨得日明三昧。何谓日明三昧定者。犹日出时灯火炬耀。星宿月光闇蔽无明。菩萨已逮是三昧者。一切众圣咸为覆蔽。所以者何。其慧巍巍明弘广故。一切声闻缘觉智明皆为覆蔽。以故名曰日明三昧。菩萨已住寂度无极。悉能逮成诸三昧定。粗举都较。取要言之。演诸三昧名。有三昧名曰照明。有定名月光。有定名庄严。有定名严耀。有定名修严。有定名无极晖猛伏。有定名其明消冥。有定名如诸法教。有定名成光明。有定名无所忧。有定名立坚固。有定名等如太山。有定名法明。有定名法御。有定名法君。有定名法慧顺教。有定名感法宝。有定名法城总持御。有定名知人意行。有定名幢英弃众烦苛。有定名力制四魔。有定名已成十力。有定名断诸挂阂。有定名造灯光。有定名坚住若地。有定名如须弥。有定名犹安明。有定名智行光耀。有定名智不可计随具教。有定名心教柔软。有定名无所求脱。有定名如水日月光。有定名犹如佛身。有定名等诸无我。有定名调象随教。有定名见得诸佛念。有定名法意无碍。有定名无退不转。有定名众毒消净如月。有定名入空寂。有定名晓众想。有定名无愿。有定名住一心。有定名如金刚。有定名无极光莫能当。有定名自在净。有定名内诸劳烦尽。有定名广大如空。有定名入一切业。有定名心思得慧。有定名慧悦人无尽。有定名成圣慧。有定名总无所忘。有定名冥普见明皆多乐。有定名慈行。有定名心本净大哀。有定名入诸护。有定名心等入无所碍脱。有定名法法住。有定名智明达。有定名解畅。有定名不可数。有定名充饱众。有定名无不了。有定名脱慧随化众。有定名金刚莲华。有定名了无常。有定名尊智慧。有定名勇伏。有定名诸佛念。有定名随教明脱。有定名严佛土。有定名开辟静诸国。有定名入众生心喜。有定名正真直。有定名以菩萨道六度无极严。有定名觉解结。有定名觉意华。有定名施脱若天药。有定名光无不周。有定名明无住佛。有定名甚深妙。有定名积宝如海。有定名如山方面。有定名神足甚广无不总。有定名见无数佛。有定名总诸学。有定名如弹指顷无不知。有定名智不可限计如大海。如是等定亿亿巨垓。菩萨以住寂度无极普备斯定

阿差末菩萨复谓舍利弗言。智度无极而不可尽为何谓也。如所闻慧趣建立行故曰不可尽。应如斯行有八十事。何谓八十

顺所闻　寻如意　如教习　从善友命　不自大　所作不忘　常恭恪　从经业　如言从　数习智　勤心受　不失节　不忘念　意不乱　兴宝意　显药志　除诸病　是意器　乐忍辱　思乐谛　入慧意　学无厌　施无所慕　施无适莫　所闻谛思　欢喜启受　心悦身轻　其意清和　而无烦苛　所学如本　常喜说法　闻欲向道　法自守者　好闻正　不在异学

唯受雅智度无极　逮于菩萨方等经　但慕听权方便经　又好闻习四等心　复察解了无神通　如初意耳无异念　心务于谛善方便　唯欲听之无生法

不贪观　但悦慈　了十二缘　达无常　知于苦　畅无我　欲知寂　分别空　解无相　体无愿　晓生死　了功德　达众生　知无忘　严其音　若城郭　所闻勤执　乐听经宝　在俗知俗　启于中意　以为伴侣　欲闻降伏　诸事业

常志思侥　普入诸法　慕断贫乏　所云贫乏　谓智不足　念解遵通　晓解圣慧　悦受正道　晓无智者　悉化使知　了常遭苦　给不足者　别离一切　无功德业　明识其本　众恶不为　畅益身义　达利众生　解安隐行　乐不怀恨　欲别至尊　无极之事　念诸佛法　所因获致

是为名曰如所闻慧辄建立行

阿差末菩萨谓舍利弗言。菩萨有三十二事所入随时。何谓三十二。随音响入(一)。欲入于观(二)。入心所行(三)。入身求脱(四)。而济众生(五)。入不断无常(六)。入无所著(七)。入随因缘所可作为(八)。所入无人(九)。入于无寿(十)。入于无命(十一)。入去来今之所住处(十二)。入功德业(十三)。入空不懈(十四)。入于无想(十五)。而入无愿不废勤修。不以空取证无想不愿护已不堕(十六)。欲入三昧而修正受。悉向成就三昧正受。以故不生无色天。所以者何拥护所致(十七)。又入诸通智慧之原。虽尔不入尽灭之径(十八)。又入无生济诸所生(十九)。复入本际思惟其义(二十)。欲入无际而不取证。所以者何有将护故。所云无护则为声闻(二十一)。欲入众生解无吾我不舍大哀(二十二)。入一切畏生死之难(二十三)。所可游入虽有生死无为生故(二十四)。又入所厌众诸尘劳(二十五)。入厌欲者亦不堕落。所以者何不中取证(二十六)。又入不思贪欲之党入不舍法(二十七)。入诸犯法而不为非(二十八)。入权方便所以者何。由因众生意堕贪爱欲开化故(二十九本阙三十)。所入教授应病与药(三十一)。菩萨所度各得其所(三十二)。是为三十二事所导如事。所以者何不失节故。犹欲入城会从门入。欲畅众缘当眼察之。解缘业者则不诤讼。欲令无争莫如自守。欲知无言为隹快者不如莫语。所以者何。不喜语者自护身口。不欲所止勿在彼居。不欲动者慎勿得转。无悕望者亦无所想。是故曰等。欲不迷色当正坚住。已坚住者尔乃达至。不乐令变常自谨慎。若慕寂静将养己者勿得称己。不欲下者莫自矜高。不高不下具足正法。不喜损者无有能谴。若乐便安所作无失。无所失者则无有疑。无有疑者解无本故便无所失。等于三世而无差特。等三世者无所增损。不住于色痛想行识。亦无殊特。眼见色识则无所住。耳声识鼻香识舌味识身软识意法识。悉无所住。从本净行如法如慧。如审谛行如无吾我。见诸法行无我曰慧。解诸所有皆无所有。亦悉无本是名曰慧。不以身绮而怀自大是名曰慧。知于菩萨习正真慧。达为一切众生之故。众生故者心常不舍不离诸法。是乃名曰菩萨习慧

阿差末菩萨经卷第三阿差末菩萨经卷第四

        西晋月氏国三藏竺法护译

阿差末菩萨谓舍利弗言。菩萨习智入于诸法。故无所著是名曰慧。有十六事不与慧合。何谓十六。用无明故而起阴阳。从生老死皆不与慧同。诸所作为亦不同尘。亦复不与六十二见而杂错也。不自贡高亦不卑己。有利无利若誉若谤。若称失名若苦若乐。过世八事贡高自大谦卑恭慎。俗间有是二十一事。不与合同。去众烦恼不为愚冥。觉寤睡眠脱诸恐惧。不与罪合及诸心垢。不除五阴故至生死。身魔罪魔死魔天魔而共合也。一切众生我人寿命。无所悕望而造因缘。诸有悕望俗间之念。当尔不尔是与非事皆缚着业。有所贪慕与戒反矣。不奉禁戒。奉禁戒者。忍辱嗔恚精进懈怠。一心乱意智慧愚冥。以度无极贡高谦逊。皆离是事坚住不住谓梵志也。定意坚强功德刚柔。消一切念使无有余。便属无为。国土好丑众生吉凶一切善恶。愚慧识明生死灭度。谛与不谛离一切念。其智者无所睹。无有见无有相不想泥洹。何谓为慧。察之计校八法功德晓了八法。何谓为八。晓于五阴了四大。解六衰别四谛。达十二缘畅明三世。识分别一切罗汉及缘觉。至菩萨演诸法。何谓晓五阴。诸所生灭犹如幻化。梦中所见芭蕉野马山中之响镜中之像水中泡沫。观于诸色我人寿命。解色如此。痛如水泡。想若野马。生死如芭蕉。识者如幻计。水泡沫野马芭蕉幻化。所以者何。此微妙故。其微妙者无我无人无寿无命。是晓五阴我人寿命犹如幻矣。识亦如幻是晓五阴。五阴堕俗。世俗相者闪现便无。是为世相。其世相者非常苦空非身之业。其知是者曰晓五阴。何谓了四大地水火风。其法界者不为刚强。水者法界则无有水。火亦法界不以自热。风者法界不用动摇。其四大者谓眼所识计于法界。不以眼视。视悉知之。其法界者不以耳而听声。鼻不向香口不味味。身不细滑意不着法。悉解法界悉以具足。众生法界如讲授之。叹情志性法界平等平等如称。欲界法界亦等如称。色无色界法界悉等如称。生死之界。泥洹之界。法身之界。等称如空。法界亦如。所以者何。有德无德亦等如空而无有异。亦不可量悉叵称载。其泥洹界亦复若兹不可讲说。此入法界是名曰智号了四大。何谓解六衰。如解言曰。其眼亦空而无吾我。亦不无我是亦悉空。所以者何。解我空者在于诸衰而不为衰。是则名曰解于六衰。谛计六衰不着不断。是为菩萨解于六衰。眼色为衰所视不堕。所以者何。不中道取证。耳鼻口身意亦悉如是。是曰菩萨解于六衰。何谓六衰。其能分别六衰。别六衰已便入于道。不别衰者则非是道。又如菩萨用大哀故不近不远。以众生故不舍大道亦不离施。是曰菩萨解于六衰。何谓别四谛。知苦习尽道不得五阴处。是曰知苦所生为习。色现寻灭名曰为尽。得道无道心以等住故曰为道。菩萨知四谛而不取证。所以者何。护一切故。是曰别四谛。复有三事。何谓为三。其真谛相审解如本。其世俗言假有号耳。了真谛心不念有无。审解本者一切诸色悉为平等。所以者何。不中道取证。以相为应。是则名曰别于四谛。阿差末菩萨曰。其谛有一无有二也。所以者何。如来至真无所悕望。亦不想求色与无色。无所悕望这得其中。是别四谛。复有五阴苦者是恼之相。好解空者。是曰苦谛。畅达五阴所从缘起。是曰习谛所见万物皆有想求。别了其意而不贪慕。虽不求者亦复不忘。是曰等知尽灭之义。不与去来今现在事而俱同尘亦不住中。是曰尽谛欲致道者。了苦习尽不在二事。所谓二事犹豫结网。是曰尽谛。谛观察之知之为苦。是为菩萨别于四谛。一切所见苦乐善恶。心睹世间悉了本末。是曰知苦诸缘皆苦。是名曰习。解慕世苦不以为求。虽不求望不堕尽证。所以者何。不中取证故。是曰菩萨因知求道。犹欲渡水而不求船。不能横越思惟其便。若得板木乘骑其上可以得度。所以者何。不忧不度不愁在苦。作是行住如四谛教。不以色诤而堕取证。是曰菩萨别于谛矣。意察生苦苦从缘生亦不从缘。是曰知生。一切所生亦无所生无有起者。亦不灭尽不兴灭意。是曰意寂而苦灭矣。乐知求胜而伏其心意解入此。是曰知道不住其中。所以者何。慧无住故。是曰菩萨别知四谛

何谓达于十二因缘。谓因无明便致生死。如诸法教其有所生。了不可见亦不可知。所以者何。无有生故亦非不生。以了如斯因缘之事。缘求泥洹谛了众生。所行不等有上中下。缘作罪福故造行道。所当致者兴无生缘。修诸法业与道合者。是为名曰解十二缘。设无是缘则消除矣。所谓消除谓无明灭。无明灭者谓老病死灭。老死已灭。能达此者解十二缘。诸所有因悉法所总。诸所有缘皆法所合。其因缘合非我非彼。亦复不是我人寿命。悉无所入。如是入者不在一切诸所有也。其意普解是十二缘。菩萨悉欲具足诸法。具诸法已皆了无常不堕取证。所以者何。护众生故。是曰菩萨解十二缘。何谓明三世。悉知去意有德无德。观身他人等无有异。所以者何。身有误失他人有过。悉代悔之逮所作福。因此福祚发心求道。是为菩萨过去功德。其当来意所作功德。悉用发心立菩萨愿。诸所发心以护制持。执心坚固不受浊意。是当来福。今现在意所作求德。以正众缘是为功德。悉舍诸秽不随非教是不离德。所以者何。近佛道故。是现在福。察去来今。信三世空。观三世法。则以智慧无元劝助。去来今佛用善权故。曰则三世诸去法尽。所以者何。不可见故。不以去德而变其心。诸当来法视无所生不以是疑。察现在法亦无所住则无处所。所以者何。不舍道心。是故名曰明于三世普达智慧。过去已灭当来未至。现在无住智无破坏。菩萨兴德悉欲合同。是故名曰明于三世。以慧悉念过去功德。所以者何。今者所作皆前世福。因发来心当来发心故。斯智慧业具足所愿。其现作德不以为难。所以者何。菩萨愿故。是则名曰明于三世。为诸众生于过去世悉知作德。所以者何。护众生故。往古所教今续化之。所教训者欲令其人见当来佛神足变化于法道义便有增益。有增益已亦增福利益诸群黎。佛以兴世多所饶益。其所誓愿悉无挂碍。是则名曰明于三世

何谓明解罗汉及缘觉乘诸菩萨德。若无佛者则无罗汉。佛兴于世有罗汉法。罗汉法者因声听解。得闻声者便备戒禁。戒禁已备谓以如戒。已如戒者具戒定慧度知见品。是则名曰明解声闻。从是所缘得阿罗汉。知德无德而了非常。得脱生死在于三界。悉厌众欲达非常苦所以者何。诸法无常。其泥洹寂亦无所有不求所生。所以者何。畏生死故。畏生死者不信俗业。身如怨仇四大若蚖。六衰空野不愿所生。五趣周旋受泥洹护。如是行者明解声闻。何谓识解缘觉者菩萨皆知。云何缘觉所造立德。所兴功祚出罗汉上。所以者何。所行精进超越过上。施与持戒声闻不逮。所以者何。声闻所行其心局迮。所奉供佛慧不足言。既入佛法所学乐小不愚不慧。所以者何。闻众乐音而秽厌之。所学少少常喜怀恨。依大德勉而乐尊务。所兴施与思十二缘。由求得脱己身校计。独信守道从缘起行。而建立功德。是则名曰识解缘觉

何谓畅解大乘之业。所入晓德不可称载。其乘广大旷然无极。为众生党行权方便。其德庄严不以为难。皆惠众生之所钦乐。以度无极化成大乘。悉知一切人心所行。欲度脱之越众缘起。不谓佛道为难得也。复以光明照于众生。其心特尊卓然无侣。度一切苦晓了诸法。无有阴盖。降伏众邪皆令清和。总摄道法三十七品。威德殊特犹跱幢幡。游十二缘不着不断。诸所可见忧戚睡眠。淫恚调戏不可之事。悉远离之真以佛慧。诸相种好而为绮饰。以乘严己身口意行。所以者何。无有罪咎。是则名曰大乘功德。大乘功德则是天上天下众生之度。何谓一切众生之度。诸法悉合谓脱不脱。脱不脱者。菩萨大士充续功祚。是名曰脱。晓了生死所兴功德。谓身口心以明晓了口作功德身立福祚。身口心行三事生死。菩萨以缘晓知脱便。愿萨云若诸通敏慧。是曰明达。脱以复晓诸不脱者。五度无极入智度无极。谓为脱者不以为难。解度无极常悉总摄。菩萨善权皆蒙光明照于一切。所以者何。则以四事总及他人。无我无人无寿无命无执无舍。是故分别。用脱之故造菩萨愿明解度脱。谓于生死稍稍得进以无所断。无所断者不灭生死。不灭生死者是为菩萨无所破坏。所以者何。不与无瞻势者从事。以是故曰分别。未脱空无想愿。以此法察晓了诸见菩萨信故。所以者何。于三脱中能不堕者。是曰未脱谓不取证。在于三界而无所著。是名曰脱。虽在三界广施方便。所以者何。用明智故不堕取证。是则名曰晓了脱德。所造功法皆以具足诸通敏慧。已具通慧不离普智。是晓诸法。阿差末菩萨谓舍利弗。是八事法与智慧合而不可尽。是智慧法咸知分明以能分明。如佛法者无有殊异。所以者何。以去睡眠非法之故。是则愿力便逮道法。诸经慧相智慧光明照于本际。已入于慧。诸欲见者悉以晓了能至泥洹。总持慧故不舍道法。以信智慧众垢悉除。其大智者则是诸法之元首也。自然慧者无有师主。皆解诸欲而无所著。所以者何。因逮道明以慧断根故不可尽。众想悉空所以造根。由痴冥故欲致圣明。则以慧药教守道者咸得正住。其来学者以慧训诲各使得所。用智慧明悉照痴冥各令得明。其无眼者悉获法眼佥得彻视。无余慧明皆越诸色。真谛之慧无复结网。以慧教告。其不伏者悉令自降。为诸闇冥显智慧眼。不可尽慧靡所不入行莫不周。所以者何。畅十二缘。所宣智明。解诸缚著令无误失。不以生死而为迷荒。阿差末菩萨谓舍利弗。菩萨大士以慧总揽。入众生心随其所行。皆见心念明解分别群黎之党。无功德者以慧导利。菩萨智慧悉遍声闻缘觉之乘上至正觉。是为慧处。斯菩萨学名曰智慧而不可尽。演智度无极畅不可尽。说道品法时。三万二千菩萨悉得无所从生法忍

阿差末菩萨复谓舍利弗。慈氏菩萨而不可尽。所以者何。其慈旷大无边际故。仁若虚空不可限量。所以无边者犹若众生四大如空无所不周。以慈普覆亦如四大。地水火风不可称限故不可尽。菩萨弘慈亦复若兹不可穷极。故曰无际。犹空无边一切四大悉不可量。众生无尽仁不可限。故曰菩萨大慈无尽

尔时舍利弗问阿差末。众生四大数不可尽为何谓也。阿差末曰。地水火风其数过于药草丛林。时舍利弗复问。可为众生兴引譬乎。阿差末曰。可假借喻。不可以民庶为数极。舍利弗问。所喻云何。阿差末曰。犹如东西南北四维上下合为世界各如江沙十方佛土合为大海。取一切人尽住海边。各以一毛取海水数。举一渧水为一江沙人。举二渧水为二江沙人。如是渧数大海水尽。众生之限不可尽极。群黎四大亦不可数亦复若斯。菩萨大慈靡所不周。阿差末菩萨谓舍利弗。若能弘慈。其德福庆不可尽极。舍利弗言。实不可尽。阿差末曰。若有菩萨闻众生数不可穷尽。不恐不惧不以怀懅。尔乃应曰慈不可尽。阿差末谓舍利弗言。其弘慈者是菩萨护。复为众生有功效业。所以者何。无有失故。众恶粗犷悉永消除。伏众怒害及诸爱欲。其有见者莫不悦颜。所以者何。无有众邪。诸有恐惧咸悉尽爱。其道正端而无偏邪。悉能化导诸乱心者。其有危难往就慰济所以者何。欲度脱故。诸有系缚莫不解散。诸谀谄者修备质朴。唯学道要不慕世荣。悉为释梵之所钦奉。常以智慧靡所不睹。所以者何。护众生故。修四等心不怀异意。悉弃尘劳入佛道要总持慧业。以德自严以超众德。三十二相八十种好。皆以具足诸不备悉。度脱快哉快哉泥洹显导众生。不在八懅不闲之地。乐以法乐以法自娱。总摄众欲不贪王土。等心众生所行无异净此普慧。其犯戒者悉将护之。现忍辱力无得自用而怀慢恣。不舍精进禅思一心三昧正受。其心不乱以智慧业。诸所听受弘慈具足。自从身出不依仰人。不从魔教。所以者何。以获大安。因智慧解耻诸非法。悉愈众病覆护众生。常自安身亦安一切。罗汉法者但欲自护不护众生。当以大慈加哀一切。阿差末谓舍利弗言。慈有三事。何谓为三。一曰慈施一切晓了慈施法等。二曰慈正真等。三曰常以普慈加于众生。所谓等者发菩萨心。慈与法等谓成就业。与慈普等因成忍辱。是谓三事慈不可尽

阿差末谓舍利弗言。菩萨大士奉无极哀而不可尽。何谓为人。所云人者喘息为本。本者谓命。菩萨至行以哀为本。成大乘故。犹转轮王紫磨金轮以为始元。然后七宝辄来具足。菩萨大乘亦复若斯。以有大哀诸佛法宝普悉周备。犹如长者有一微妙清和之乐。其音哀美入于骨髓。菩萨大士逮致弘哀。愍念众生过于骨肉。犹如长者而有一子爱之无极。菩萨之业大哀为本然后具足。所以者何。为一切教大哀无谄。无谄行者有弘哀故。便不自大专自用意。亦不虚饰以至真行。心中至直而无有异。是为弘哀。所以者何。无有邪心以逮愍哀。其心敦诚亦无憍慢而自放逸。顺随一切诱进开化而度脱之。身无所损。以势力故不贪寿命。则自爱己众恶离散。覆护众生其心已净。不舍贫匮诸厄难者。所以者何。不以劳故其心坚固。是则愍哀。其心不退因入大道。菩萨真意能勤将护。是为大哀。若为诸佛作证解明。亦为自己证明供养。复至大哀其心清净所行无异。所以者何。能舍己安而安众生。见危厄者身欲代之。心不协恨荷负一切。不以为重坚志精进。是名曰哀。所以然者。能忍辱故。其羸劣者将护扶之。若有病者身体臭处其心不恶。欲以劳来众危难故。倩讲法者不以为惓。具足道心随人所喜。随人所喜者。谓入异学各得开解。常抱功德以为庄严。身诸根具而不堕苦。因成愍哀心等无余。以安一切所以曰哀。无人诤讼。所以者何。无所贪故乃能备哀。心无悔恨常护禁戒。悉乐导利一切众生。身若金刚不可毁伤。以身惠施无所吝惜。劝助他人令兴功德。是则愍哀。虽身立德而怀欣然。不如劝人建立福祚不用禅悦。所以者何。常为一切既在欲中。思察道慧不以为劳。是则愍哀。所造功德未曾懈惓。为无畏施舍贪吝心。欲使众生咸成所愿。思开达者辄令建立无极大哀。所以者何。为懈废护劝赞导首也。若有犯戒及诽谤人。菩萨静定不念是言。所以者何。常以佛戒教训十方。有行恶者心哀伤之。以如来忍诲无瞻势及愚冥党。所以者何。化令其人内入佛法。菩萨普教令学于佛三十二相哀。哀亦不可尽

阿差末复谓舍利弗言。菩萨大士一切所施以哀为本。故曰建立无极大哀。亦皆以应布施持戒忍辱精进一心智慧六度无极。亦复备悉三十七品。所以者何。独能游步无能为师。所行安谛而无瑕秽。以慧愍成一切众生。曰菩萨哀为不可尽。何谓菩萨喜不可尽。所由等心为不可尽。所以者何。思察法典其心悦豫。不以为劳舍诸音乐。不以为乐心普住法。以法自娱身意降伏。所谓伏者见人所作不应义理。衣毛为坚心悲雨泪。好菩萨道其心钦乐。愿如来身具诸种好。三十二相以为庄严。诸法功勋常欲听经未曾厌饱。恒执经文常欲坚持。以应法者不以世荣而在心怀。常以法乐而以自娱。等心一切随其所喜而开化之。所以者何。各令得所如佛法教。是曰行喜。执意觉弘不违如来至真之法。究畅威灵。其羸劣者心不慕法。诸贪餮者心不清净。虽在三藏不怀自大。能谨慎者代之欢悦。其犯非者加之愍哀显示道径。身心已越恶趣恐惧。坚奉戒法犹如来禁等无差别。若骂詈者心不协恚伏令柔忍。尊敬长老谦逊年幼。颜色常和心无错乱。应人随顺先人问讯未曾谀谄。是则名曰菩萨行护而不可尽

阿差末谓舍利弗。菩萨神通亦不可尽。何谓神通。一曰天眼。二曰天耳。三曰知他心念。四曰知往古。五曰飞行。六曰漏尽。何谓天眼计诸天眼龙揵沓和及诸鬼神罗汉缘觉目所见者。不如菩萨目之所睹。悉超于彼一切彻视无能及者。为尊为上为最殊妙巍巍无匹。菩萨眼者。靡所不达睹诸径路。其眼所见周于十方无边世界。诸有色像粗细大小远近广狭。悉以天眼见之明了一一分别。因彼天眼见十方已。睹于五趣所生住处。而察群黎生死所归。知其报应所当获果。识斯根原。亦复晓了诸根强弱。其十方界诸佛世尊国土功勋清净鲜明。咸亦睹之察其戒净。以此功勋劝助己土。常住禁戒所愿辄成。以此天眼则观诸佛。不退转地诸菩萨众这见斯义。正士之党学其所行。威仪礼节举动进止。安庠和雅立于法门。总持辩才智慧善权。随时方便教学具足。以真谛眼普见一切无所挂碍。察一切色悉为虚伪无一真正以至诚眼亦见解脱及与结缚。以至诚眼见之本净显曜鲜明。于诸境界悉无所著。以至诚眼不复起生尘劳结网。见若干冥不怀沉吟。以至诚眼不住颠倒一切蔽碍不慎之法。所视明彻用法光晖而照曜之。以至诚眼宣布圣慧。不慕饰着因缘诸行。未曾怀恨无结无望。不猗尘劳一切放逸。以至诚眼剖判劳惓。厌贤圣者随根所由而开化之。不违失相皆遣光明等照众生。以至诚眼其心清净。除诸根株永令无余。离于自大无有垢秽。心性清净而无所著。以至诚眼逮见佛眼。舍心自在而不驰骋。除去虚伪不安诸疾众结之党。以至诚眼达知义理进退所归。其法净者慧圣章句。行无挂碍执御众生。建立大哀刈弃乱法。谛度彼岸使无有挂。所见审谛亲近道场。无所依怙见乞求者不怀嗔恨。诲毁戒者护众恨心将养懈怠。其乱心者为现禅定。其邪智者施以慧眼。若失径者显以正路。志在小乘教以佛道微妙大法。令入普智顺从正觉不废神通。是为菩萨天眼彻视无尽神通

何谓天耳无尽神通。以此天耳普闻十方不可称限。诸佛世界所有形类。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒所说音声。人与非人言语所趣。一切贤圣诸佛声闻缘觉言辞。诸菩萨等所畅音教。以此天耳咸悉得闻。所听了了无一蔽碍。及复察闻地狱饿鬼畜生音声。么么小虫蚊虻蚊蜂。[肖*毛]拂音声皆得闻之。其心所乐善恶是非。皆从众生口之所演悉亦知之。口之所宣罪福报应。若有口说贪淫嗔恚愚痴系缚。或有怀结口辞粗犷。或口贪恚出现愚憃。或口讷钝所说粗犷弊恶之言。或口贪欲而演结染。或怀结怒演凶坚辞。或怀愚冥口演騃痴。或有心性清净和调口言侏张。或口言善心性怀害。或口柔和心性安隐所说清净。或身口意不相应者。悉天耳听神通无碍皆晓了之。以此天耳闻诸仁贤及诸不贤。于贤不贤亦无所著。耳听恶声不怀忧戚。常兴悲哀广大慈愍。若遇恶声致无极慈。悉知去来现在众生一切所行达如审谛。以此天耳闻十方佛所颁宣法。辄能受持念之不忘。如己所闻常乐道法。察如应器而训诲之。各令得所不但一反。闻如来法数数启受。无能妨废使心退忘。又其菩萨本行道时。皆从诸佛启奉道教。若干众会各各说法。悉察众生诸耳所听。辄能自然演其法教。彼若群生识经义者听所说法。不识义者不肯听之。假使耳根法界清净。其天耳界圣慧清净。设使耳界自然净者众生亦净。若察耳界随其音声。文字言义悉能听了。一切众生生在五趣。传若干响所语不同不可称载。随斯音畅而入说法。其耳所听皆从真谛。咸以劝助如来道耳不乐余乘。是为菩萨天耳所听无尽神通

阿差末菩萨经卷第四阿差末菩萨经卷第五

        西晋月氏国三藏竺法护译

阿差末言唯舍利弗。菩萨神通知他心念亦不可尽。何谓知心。达诸群黎过去所念当来所思现在所想。又其菩萨知心如幻。则随时宜劝诲众生。说报应行祸福所趣。某人心和所报善德。某人行中得中间报。某人行劣得劣弱报。某人志性心喜布施。某人好持戒忍辱精进一心智慧。某人志性爱乐慈心悲哀喜护。某人志性慕学大乘。某人志性好学声闻缘觉之乘。某人体性本殖所种各异不同。某人德本当以某药而疗治之。用修薄福故生贱处。某行净德心性不明。某人心净所行清某人心净所行了定。如是比类悉知众生古昔世时。心所念异所修不同。因其所行而为说法。是则名曰知他心念佛知当来众人所怀。某人当来因奉禁戒报应如是。布施所报亦复如是。忍辱精进一心智慧其亦若兹。所行俗业得俗事报。某人来世修学大乘。所行法则威仪礼节报应如是。众生当来举动进止。威仪诸业心念各异。后当报受所种果实悉晓了之。某人志性行不淳淑。当随颠倒众患之难。因其所知心行则解。从其法器而为演法。所宣法者终不倒错应病与药。若演法时无所置思。咸复达睹现在众生。心念是非审谛明了。知于某人怀贪欲心。某性多嗔某挟痴冥。知某无欲某无嗔恚愚騃之心。因其尘劳心性驰逸。悉解此等众生所念。缘其劳秽而为说法各令解达。所诣众会察其心本。应病与药各为宣畅。假使众人心怀犹豫。志不自决迷惑驰骋。虽有进退怀抱沉疑。不明智慧惑心恶行。行来所念不能卒解。觉了心性断除尘劳。又去挂碍离垢清净。光明显曜而无所受。无所造立舍于瑕疵。以法光明照于一切众生心行。随时入教而为说法悉令普达。是为菩萨知他心念无尽神通第三之业

阿差末言。菩萨念往古知不可尽。敢可忆念思逮了本。群黎之类皆悉荷蒙。如来圣旨坚住法界。熟惟真宜而不可动。性不卒暴备悉禅定。不怀怨望住而审谛。知十五十百世千世。识不可计亿载世事。天地成败合散进退。一劫十劫百劫千劫。了无数亿百千垓劫。名字种姓言语饮食所更苦乐。自知本原见他众际。古昔从来别已种德。众生善本身所立功。劝助佛道照众生心。使识善本劝发道意。前世宿命苦乐安危。忽已悉过皆归无常苦空非身。愚者迷惑。以色自倚贡高势富。憍恣眷属荒乱自大。恃怙贵位贪释梵职。慕四天王转轮圣帝。乐诸所趣终如五旋。好于爱欲尊高之处。喜为己身求想安隐。缘是欲得化于他人。设慕世位当察非常苦空非身。畅过去劫所行本末。其现在事无有处所。宁失身命不犯非义。古昔所立功德之本。咸用劝助悉具大道。现在善本执御众生。弃邪行业不断三宝。佛法圣众发一切智。是为菩萨知往古世而自证明第四神通不可尽谊。何谓菩萨神足飞行。神通已达不可尽者。自察己心而好精进摄受法典。所修业行辄能成就。恒得由己常谛奉行。于四神足现在目前。诸通悉达无所复为。以无数品显现神足。威变无量。则以一身化无数身。以无数身还复一体。飞行飘疾如一念顷。不碍墙壁铁围山川。经自通过如鸟游空。坐于虚空如处地上。履水而行如在陆土。出入无间如无门户。以是神足观察人根而开化之。从其众生因可训诲而显神足。为现端正颜色无比。或因毛孔而演大光。或立威神随其形类而开度之。应病与药各令得所。或声闻缘觉像色貌立之。或现佛身而开化之。或现释梵色像形貌。亦如四镇转轮圣王。种种异形教诲群生。或现畜生形貌像类。从其众人之所好喜。各为说法因而将养。势力坚强多怀毒害。嗔恚盛者因其所宜而阐慈心。或显大力或四征力。或半钩锁或具钩锁力。其力无极势不可限。须弥山王甚大巍巍。高三百三十六万里。广长入海其数亦等。以一指擎擎之挑掷他方佛国如投一果。其菩萨力终不损耗。又此三千大千世界。广长无边下尽地际。极于上方三十二天举着右掌。于若干劫擎之不劳。建神足力显其圣慧。以此威德圣慧所致恣意所欲。能举大海投之牛迹。在于牛迹亦不逼迮亦不漏逸。能变牛迹以成大海。假使劫烧天地欲坏。建立威神变为洪水。道化圣旨成为水灾。欲使为火辄如意念。取要言之在所显示无一蔽碍令变为幻。上中下法如意所欲无不成者。无能动移妨废之者。释梵魔天及与他方。所作如法辄从经教。舍诸佛道威神无尽。其余众人天上世间。无能作威移菩萨德。以此威力为诸民庶显若干变。悦豫功勋颁宣经道。有是神足其心坚强未曾退还。度魔境界尘劳之秽。入佛境土不烦扰人。应其所乏各令得所。往古宿世所造德本。诸魔官属不能毁之。是为菩萨神足变化。第五神通而不可尽

阿差末复谓舍利弗言。菩萨漏尽神通要者。不住有为不处无为。以大慈故不造生死。以大悲故不住灭度。欲成道德不着终始。欲现佛身不住灭度。顾恋一切不迷尘欲。化度十方不取灭度。行施戒忍精进一心智慧。随时不惑流润。行权方便不慕无为。欲具本愿志性清净。不违道慧方便开化。在于生死五道坦明。不乐无为六通平正。不难五趣六度四等。四恩四辩三十七品。疗生病死成其佛土。严净三场不处有无。生死无为皆观自然等如虚空无进无退。是为菩萨第六神通而不可尽

阿差末言。唯舍利弗。菩萨大士有四恩行而不可尽。何谓为四。一曰布施。二曰仁爱。三曰利益。四曰等与。其布施者谓有二品。一曰衣食金银珍宝车马人从。二曰法施。广布经典靡不周流。其仁爱者亦有二品。若有求者恣意与之。欲听经者为讲说法。其利益者亦有二品。自成己行具他人愿。其等与者亦有二品。如自己身所念思惟建立功德。来求衣食诸所可乏悉施与之。加复劝人令住道业。又所谓施。见乞求者踊跃与之。面色不变益加熙怡。彼仁爱者见来乞求愍如赤子。彼利益者劝诸来求。令住坦然平等之地。彼等与者假使有人。身行口言心念缺漏。训之令护三事相副令入大乘。复次舍心贪嫉则曰布施。精进不断名曰仁爱。有所利益志性清和后不怀恨乃曰利益。劝入大乘不堕小意是曰等与。复次慈心顺穷则曰布施。兴发欢悦怀恕恋心乃曰仁爱。兴大悲哀被戒德铠。为群黎故而忍众苦名曰利益。养护诸行令不损耗劝一切智是曰等与。复次若求法者亦能惠与。无所吝惜则曰布施。其仁爱者有所施与。兼以法教使得坦然。其利益者。亦为己身复为他人兴隆道化。其等与者。为一切故。寻发道意诸通慧心。复次内外所有皆能放舍。不怀妄想则曰布施。称誉一切功勋之慧。不违师友乃曰仁爱。舍身之安所便身谊。念忧他人名曰利益。合集要行若住苦恼。既自勤修思慧成道观之如掌。以惠他人不怀悒悒是曰等与。何谓法施如己闻法为他人说。兴仁爱者若有所演。不贪衣食利养之业。彼利益者若教他人讽诵经法。随时而授未曾劳惓。何谓等与。未曾违远一切智心。常随法训不以为患。何谓布施。爱喜法者不乏衣食。钵器履屣诸床卧具病瘦医药所当得者。他人所乏辄能与之。观其志性寻为说法各使得所。其等与者能加施人净三道场。不望想报则用劝助无上正真最正觉心。复次其法施者。于诸施中最第一尊。作是察已乃兴法施。其仁爱者斯心质朴显愍哀义。其利益者念道义理不受严饰。其等与者班宣佛法道慧具足。复次其布施者具足备悉诸度无极。其仁爱者成于戒禁忍度无极。其利益者进度无极。不堕颠倒退思补过。其等与者。广大禅思智度无极。复次其布施者。则应初发菩萨心行。其仁爱者。奉修正行顺菩萨本。其利益者。成不退转菩萨法教。其等与者。则谓一生补处菩萨之基业也。复次其布施者。立道根本。其仁爱者。喻于备悉牙茎枝叶稍成道教。其利益者。喻于道法究竟华茂芬葩炽盛。其等与者。究竟果实道德之业。是为名曰菩萨四恩

阿差末言。唯舍利弗。菩萨大士有四辩才亦不可尽。何谓为四。一曰义辩。二曰法辩。三曰应辩。四曰辞辩。何谓义辩。晓于诸法真谛之义。明己所达识报应慧。所知和雅不自修功。入因缘慧不坏法界。悉达本净入于无本。悉解本无了住本际。永无有际晓解空义。奉修无想在于无愿。晓无所求立无所行。明诸行者入一慧门。不计有人不见吾我。无寿无命道智则一。游正真慧知于过去无央数劫。晓于当来无边际义。识于现在一切众行。悉解五阴犹如幻化。四种如蚖诸入若空。灭寂内行外无所游。解诸国土无有境界。心意无形其所行至。为无所到观其志性。明识审谛苦无处所。于诸所习而无所造。其灭尽者自然之相晓入径路。分别诸法句义所趣。通入诸根畅达五力建立寂然。明察所观一切所有。如幻芭蕉野马形影梦中所见山中之响水中之月。悉虚无实。以若干相了为一相。知合会者必当别离。今欣欣者后会忧戚。晓声闻乘因音而解。知缘觉乘从十二缘寂静归一。畅大乘学。积累无量一切德本。乃成大道是谓义辩。复次其义辩者唯归仰义。一切诸法皆趣于义亦无所归。所以者何。一切诸法所归趣者悉皆空空是谓为义。一切诸法悉无有想。其解无想是谓为义。一切诸法悉无有愿。其无有愿是谓为义。一切诸法悉归澹泊。其澹泊者是谓为义。一切诸法悉无有人无寿无命。其无寿命是谓为义。若晓诸法分别如此。是谓义辩。其讲说法无所处当言有处所。彼土所讲则不可尽。所演辩才无能障翳。诸佛世尊之所言教。悉遥劝助所宣圣慧。真谛无异无有罪衅是谓义辩

何谓法辩。若了诸法随时而入。善恶祸福兴德罪衅。有漏无漏在世度世。苦乐危害尘劳嗔恨。各有品类。入于生死若处泥洹。分别法界方俗之业。是谓法辩。复次其法辩者。晓诸贪欲心所恋慕某人好色知当何药而疗治之。某淫泆盛某贪欲强或有少欲。某可除欲某不可除。或从往本欲应欲来。或当来世习贪欲相。或于现世习贪欲相。或复有人内怀贪欲外无恩爱。或复有人外抱贪欲内无恩爱。或复有人内外有欲。或复有人睹其颜色。而发情欲闻声不动。或复有人闻其音声。而兴贪欲不以色动。或复有人因其声像而兴色欲。或复因香诸味细滑。由心诸法而起贪欲。或复有人无色声香味细滑之念。是为贪欲众生所行。当作是入其贪欲门所习。或欲二万一千。其嗔恚行亦二万一千。其愚痴行亦二万一千。其等分行亦二万一千。若能解了于此诸行八万四千。便能随时而开化之无有损耗。其不入慧诱进令前。不失其节解知应器。殊特下劣有所颁宣无所侵抂。是谓法辩

何谓应辩。若能普入一切音词。诸天之声。世间人声。诸龙鬼神揵沓和阿须伦迦留罗真陀罗摩休勒人与非人所有音声。悉能得闻五趣众生所说之响。随其音响而为黎庶讲说经法。是谓应辩。如是随顺而为演法。是则应辩。晓了经典知其文字观所入义。如是品类解一种言十种百种。了男女言大小婴孩。亦知过去当来现在文字所趣。亦解一字。又了二字之所入处。亦知一字独而无侣。亦知二字而无有伴。是谓应辩。应于真谛言无缺漏。了了分明而无误失。讷隧之言义理备悉。所在众人皆悦其辞无怨望者。颁宣深义文辞至质合宜文饰。自察其心从佛之教。观于众生志性所趣。而为应义使心开解。欢然踊跃各得其所。是谓应辩

何谓辞辩。所说应时辞不乱错。言不中止无能制者。所可说义无能障塞。卒问寻对应机飘疾。答不迟晚如所问报。不失应节不违问者。辩才无诤所说辩才。应真谛法立忍辱力。所宣深妙演若干义。辩才次第不越来意。布施持戒忍辱精进一心智慧。分别一切章句义理。讲说意止意断神足根力觉意。发心成道观察寂然。解畅一切禅思脱门三昧正受。入于圣慧剖判三乘。悦可一切众生所念。言词和雅语无瑕秽亦无粗言。不合义者。口不卒暴舌不迷荒恶言之教。所语柔软清净无病。言语徐详无不实词。随时事义所传辄正。不卒不暴方便随意。无有异词亦无细言窃微盗语。所语列露无屏处言。极高举声言词安隐。有所说者无能得短。诸贤圣众所共咨嗟。所称扬者通流他国。其音微妙亦如梵声闻者悉达。口所言词不违法教。皆见一切众生根本应其心念而为说法。其闻法者。辄随平等断苦恼患。是为菩萨词辩无尽

阿差末言。唯舍利弗。菩萨辩才复有四事而不可尽。何谓为四。一曰取义不取识。二曰归慧不取所识。三曰归于要经而不迷惑。四曰自归于法而不取人。何谓为义何谓为识。入于世法是谓识着。度世之法乃谓为义。所谓识者布施调意明智安庠。所谓义者化于调定寂寞澹泊归于圣慧。所谓识者。咨嗟生死而不患厌。所谓义者。虽在生死不处颠倒。悉能越度终始之患。所谓识者。咨嗟泥洹功德之勋。所谓义者。一切诸法本净灭度不怀望想。所谓识者。随其本乘而为分别。所谓义者。入一法慧。所谓识者。一切所有皆能布施无所爱惜。所谓义者。净三道场归一大道。所谓识者。护身口意普学禁戒。叹誉止足功德之行。所谓义者。护身口意解不可得悉无所作。是谓禁戒能为清净。所谓识者见诸贡高自大憍慢放恣怀嗔含毒之士。为演安庠忍辱之德。所谓义者行能自致无所从生法忍。所谓识者。殷勤精进。分别一切德本之义。所谓义者。无应不应无双无只。所行精进而无所住。所谓识者解脱禅思脱门安庠三昧正受。所谓义者。晓了灭尽定意正受。所谓识者。一切所闻辄能受持智慧道原。所谓义者。观于智慧无有处所亦不可得。所谓识者。颁宣于斯三十七品道义之训。所谓义者。奉行遵修诸佛道法。因诸报应致道果证。所谓识者。剖判苦谛及习尽道。所谓义者。至于灭寂证明澹泊。所谓识者。因其所生悉由无明至老病死。所谓义者。以灭无明及老病死亦无永除所谓识者。讲说所观寂然之本根原所归。所谓义者。因其慧明而得解脱至微妙智。所谓识者。解淫怒痴分数适等本不可别。所谓义者。以得永消众恶诸想不念怀恨。所谓识者。解脱一切诸阴盖法挂碍之难。所谓义者。游无蔽碍解脱慧门。所谓识者。咨嗟三宝功德无量。所谓义者。以离于贪不与欲合奉宣功勋。所谓识者。若有菩萨从初发意常叹开士一切禁戒名称之美。所谓义者。一心念顷皆能晓了。寻得成就一切敏慧。取要言之悉能讲宣八万四千诸品法藏。是谓为识。于诸文字诸所识着。解无所得义无处所。是谓为义

何谓为慧何谓为识。住于识者则有四事。一曰识在于色心处其中。二曰而怀妄想处在缚着。三曰游于生死识在周旋。四曰迷惑识着不能自拔。是谓为四。何谓为慧。其识不处住五阴地。断诸阴盖色痛想行识。是谓为慧。复次所谓识者。晓了四大地水火风。假使识行不住四种。识不驰骋不坏法界是谓为慧。复次所云识者。眼色耳声鼻香舌味身触心法。所识之着是谓为识。设使消除外不游逸。慧之所导于一切法无所悕望是谓为慧。有所猗着则生识矣。亦从想念悕望多求而生识矣。是谓为识。若无所受亦无悕望。心不怀念无所慕乐。志不望报是谓为慧。有为行法则住于识。修无为行识无所住。奉无为明乃谓为慧。若住起分名谓为识。不起不灭识无所住乃谓为慧

何谓为取经义。何谓为取。殷勤元元求诸经典是谓为取。若于经典致入道果是谓取义。若于诸经成就众行是谓为取。若能分别诸经本末是谓取义。若在诸经入造行业是谓为取。若于诸经灭尽罪福。永除尘劳是谓取义。若于诸经采取要慧。而为他人说尘劳业是谓为取。若于诸经了了分别清净章句是谓取义。若于诸经厌生死难。愁戚不乐是谓为取。其于诸经观察生死及与灭度不以为二是谓取义。若于诸经但宣杂句严饰之教是谓为取。若于诸经爱乐深义钩奥致远坦然无为是谓取义。若于诸经想识无数心念众生是谓为取。若于诸经喜于识知。心无所生是谓取义。若于正经计吾我人及与寿命。含血之类怀可不可造立悕望。所可说者悉无有主。强立本末君长之主是谓为取。其于诸经解空无想无愿之法。不起不生悉无所行。不计吾我及与寿命。讲三脱门是谓取义。何谓为法何谓为人。若着人者何从修法是谓为人。若在于人不舍诸法。而住境界是谓取法。复次所谓人者。云诸凡夫凡庶性行乃谓为人。若于凡夫奉真人义。修于笃信执持经典合八等。人道迹人往来人。不还人无著人。缘觉人菩萨人。复有一人出现于世。多所愍伤多诸安隐。慈哀三界诸天世人及三恶趣莫不蒙济。名曰如来。如来正真普安一切。显示径路化于黎庶使入道义。假使有人依猗着求则无有护。因欲开化此等迷惑。故为说是当归于法莫取于人。计于法者无所造作。无有同像无作不作。住无所住亦无根本。普行平等等于正真。亦等邪业以邪等正以正等邪。邪正无二无所悕望悉无所行。于一切法逮致自然。其相究竟犹如虚空是谓为法。所开导法亦不思念以为恩德。若入于此法门义者观一切法皆为道法。悉御诸法不以劳惓。是诸菩萨四归之义而不可尽

阿差末菩萨经卷第五阿差末菩萨经卷第六

        西晋月氏国三藏竺法护译

阿差末言。唯舍利弗。菩萨功德业及圣慧业亦不可尽。何谓德业。若能布施出身所有。持戒之德道慧之业。常行慈心思惟定意。行无极哀奉众善本。为己身施亦为他人。合集功德劝施一切。三世众生普及诸学及与不学诸缘觉乘。亦复劝助诸初发意。学菩萨法逮入行者。不退转等一生补处。过去当来诸现在佛。普劝德本所行休祚。咸皆祝愿诸佛贤圣。讲经法师以是功德使得长存。寿命无极劝众德本。虽合福祚其不发意劝发道心。已发心者使度无极。若有贫匮救摄以财。其身病者给与医药。随时供养不怀谀谄。其羸劣者劝立忍辱。其蔽藏罪令不匿过。常怀羞耻列露殃舋奉敬现在诸过去佛。爱敬归命其师和上。常行法施化无师主。勤修精进求法不懈。见诸法师视之如佛听法无厌抱念心怀。闻远有经十四千里。故自举往不以为劳。虽说经法不慕利养。孝顺父母夙夜供养。不离左侧常念反复乳哺之恩。不以怀恨积德无厌。身行谨敕体无绮饰。常护口辞不演粗言。自守其意心不怀毒。建立佛寺讲说精舍。所获功报犹如梵天。何谓梵福。初成佛时寻欲灭度。诸天俨然皆来劝助。本为一切欲度十方。五江三源流泆不息。愿守本誓开度一切。迷惑盲冥颠倒上下六十二见沈塞闭在九十六径。唯须大圣以明济之。佛言善哉天王怀慈。五浊之世甚难开化。当分三乘开化诱进。然后能入无上大道。此梵天福不可称限。其兴佛寺功德亦然。积无量度。因此功勋具足诸相三十有二。奉行若干众善之本。由是周满八十种好。修行十善而不自大。庄严其身端正姝好。弃捐一切恶言粗辞。缘是庄严口演辩才。常有慈心不怀毒害。则庄严心净如明珠。庄严佛土神通变化。庄严经典为他人说。庄严众会令奉道教。弃除两舌恶口谗言斗人。咨受经典而观察之。以何开度令至大道。有所颁宣未曾越次。亦无所抂颜色和悦。众人见之莫不欢然。剪去阴盖一心听经。其意明利以为庄严。稽首归命诸佛正觉庄严道场遵众德本。以为元首净所生处。将护罪福爱欲尘劳。逮得宝掌皆能布施一切重宝故无所望。以无极财而施与者。得致无尽广大宝藏。面常和悦不兴戚颜。以故亲友伴党同学莫不喜欢。等心众生缘是得致平坦如掌不轻未学。喜然灯火贡上佛寺。父母师友得净光明靡所不照。积德奉戒行无点污。世世所生。在清净处不演他秽。若在胎藏常无垢染。奉行十善生于天上。还在人间未曾想念一切结网。以故独步而无虚妄。训无师法故于诸法。最极尊豪。志性清净普世众人视之无厌不惜身命未曾欺中无所侵枉。因本诸愿悉能具成诸佛道法。缘是之故备众德本。是舍利弗薄立德本。将育随时获福无量。复过于此不可称限。吾粗举要不悉敷之。何谓慧业所从因由。受其神识知五慧通。何谓为因何谓为由其多欲者常求佛法。明慧亲友常与其俱咨受奉敬。执御佛慧不求声闻缘觉之乘。离于自大奉如尊圣敬如正觉。志性和调睹诸亲友。遵于慧义不着言辞。见诸法师所行道品。不乐外形闻所说法勤修法教。斯行法者是为慧业

何谓法业。希求少欲不在汲汲少辞鲜言。常自觉悟修行精进。有所闻义思惟称量。饥虚于法未曾懈惓。其心鲜明不为五盖之所覆蔽。悔其罪舋消化众殃。其意质朴而无谀谄。以行为要爱法乐法。以法为本举动为法。恒求经义如救头然发索及肌。勤勤修身习行元元。未曾违远。驰趣殊胜捐弃乱会。独在一处乐于闲居。习仁贤行限节知足未曾退还。乐于法乐不慕世荣。求度世法志不忽忘。举动进止常乐要义。求柔顺业积累坚要。常怀惭耻修敏念慧。遣诸无智弃除愚痴。盲冥罗网慧眼清净。其所觉了极为旷远。以无为慧圣意远照。现在智慧当来功勋。不自扬名叹他功勋。善修圣业不离罪福净修道慧。复次其慧业者。有四事施而得致之。一曰施纸竹帛。二曰以笔施惠令写经本。三曰施与好墨及以上砚。四曰法师所演讲若干法。因从启受。一切世间诸可难致供养法师。或以颂偈施与于人。若有妙法授与法师。不怀谀谄至诚布施。施此四事得致慧业。逮于五事信戒慧解度知见品。将护四慧而得自在。何谓为四。一曰将护法师以为师主。二曰将护种姓不起乱心。三曰将护土地乡邑人意。四曰自守护心令不驰骋是为四事。复有四事亲近慧业令德成就。何谓为四。一曰以深经典奉进法师。二曰昼夜殷勤亲近慧义。三曰衣食供给所乏。四曰渐近道场而不退还是为四缘。是之故致五力慧。何谓为五。一曰信力。二曰解脱力。精进不废博闻无厌。三曰意力不舍道心。四曰定力等视诸法。五曰智力所闻不忘。是为五力。戒慧力业复有四事。何谓为四。一曰以法安谛奉行禁本。二曰思惟经典察义所归。三曰以法劝助于正真道。四曰务求要训以法为戒是为四慧。忍行业复有四事。何谓为四。一曰精进求法。若加恶者骂詈其身而皆忍之。二曰爱乐法者。若遇斗讼饥渴寒热悉能忍之。三曰奉敬善师顺和上命。四曰元元思法忍空无想不愿之义是为四。精进行业复有四事。一曰勤求听经不以劳惓。二曰闻则执持未曾遗忘。三曰精修说法不以懈废。四曰元元奉行以为正业是为四。禅定行业复有四事。一曰根心寂静而无愦闹。二曰常一其意苦乐无二。三曰一心精专求诸神通。四曰入于佛慧消除俗智是为四。智慧行业。复有四事。一曰不住断灭。二曰不处有常。三曰其心不迷晓了不乱缘起之本。四曰信无吾我是为四矣。善权慧业复有四事。一曰乐世法者随俗而化。二曰计有人者随之牵来。三曰复以经道因遂诱进。四曰修慧解者因明而度之是为四。道慧之业复有四事。一曰修六度无极而得至道。二曰以达归尽游于正化。三曰其学调心调七觉意。四曰常进遵行一切智慧之本是为四。无厌圣业复有四事。一曰闻法无厌。二曰颁宣经典而无懈难。三曰试恼察原不以为劳。四曰明达高节通利无惓是为四矣

阿差末复言。其能周入。若布施者当正观业。持戒忍辱精进一心智慧慈悲喜护。所以者何。菩萨一切虽未成就。演智慧首为圣土地。悉归于道住于正慧。化无慧义使归大乘。一切诸魔不得其便。皆为诸佛所见建立。至一切智无上正真。是为菩萨圣慧之业而不可尽

阿差末言。唯舍利弗。菩萨意止亦不可尽。彼自观身观他人身。观身本行成精进业。察身报应所从合成。知身无主无可贪者。犹如观外草木众果丛林刍草。从因缘生悉无主名。是身如是。犹如草木墙壁瓦石水中之影。五阴四大诸入所惑。观己身空无有吾我。不得久常无有坚固。危脆之物分离之法。以是之故不当计身是我所也。以此危脆无坚固身当求要义。何谓为要。如来身者乃谓真要。吾当勤求成佛圣体无极法身。犹如金刚不可破坏。超越一切三界俗身。纵使此体瑕疵无量。因是当除一切秽浊。当致如来空慧法身。以勤修力合集众德。真诚俱会察四大身。吾以此身皆为众生志求修道。犹如察外所有四大地水火风成若干形。门户井窖造立屋宅。生活之业以安众人。吾四大身亦复如是。以若干事而依怙之。兴若干便无量财货。尔乃得安养身之业。观身苦痛不可称限。观形无常生死往反。不当复贪无极受形。观身无我。而众生类不解本末。当训诲之令患厌此。观身寂然将至一定令修静默。当观身空无想无愿。便归澹泊清净本际。彼自观身观他人身。无所慕乐不计坚固。知不长存察内身行。不复听从内诸尘劳爱欲之患。又观外身。未曾得与外尘俱合。身无劳秽所行清净。身以清净然后遂致像好体严身像已成。为过诸天及世间人。颜容巍巍无有俦匹。是为菩萨自观己身。观他人身建立意止

何谓菩萨自观痛痒。观他人痛痒而得意止。菩萨发意观察如是。所可经历皆是苦恼。彼察痛痒采求圣慧。选择明智慕乐寂然。正使遭乐不系在欲。若存在欲缘致苦痛。见诸众生堕诸恶趣三涂之难。为兴大哀。不以结网而见系缚。虽身以值不苦不乐诸痛痒者。不为痴冥结网而见系缚。虽在痛痒意故寂定。从来所更不苦乐痛。则以圣慧显示众生。弃捐痛痒无益之义。蠲除一切众生痛痒。被澹泊铠心自念言。此等群黎归在痛痒。不自觉知。缚在众苦痛痒之地常怀忧戚。依猗不苦不乐之痛为之迷荒。以是之故不入智慧。摄大哀者入于智慧。晓了休息一切痛痒。因此大哀使诸众生免除众难为宣经典。何谓名之为痛痒也。心中怀恼或复成乐。何谓选择此无痛痒无我人寿。又彼菩萨不猗痛痒。亦无贪护。所受痛痒。无反覆行无倒痛痒。亦无妄想诸见痛痒。亦无眼耳鼻口身心之痛痒。亦无色声香味细滑之痛痒。眼所属者从因缘起。计于苦乐无苦无乐是谓痛痒。取要言之内外亦然。从因缘生以致痛痒。苦乐善恶不苦不乐。其一痛痒因一心识。二痛痒者谓有内外。三痛痒者随过去教。从当来行因现在识。四痛痒者谓从四种地水火风。五痛痒者从念五阴色痛痒思想生死识。六痛痒者从六衰故。七痛痒者从七识故。八痛痒者或从八邪而迷荒故。九痛痒者谓九神处。十痛痒者谓十恶业。取要言之。一切痛痒皆由贪乐。因从念欲而致众痛。是故言曰不可数人其痛无量。菩萨于彼观己痛痒观他人痛痒。知众群黎起分痛痒。当显慧业使诸众生因痛痒慧睹见德本除去诸罪。是为菩萨观己痛痒观他人痛痒心意止也

何谓菩萨自观己心。观他人心其意止也。其菩萨心未曾忽忘。举动行步常自将护而复察之。心适起已寻便消灭。无常住处不住在内。亦不在外不两间得。吾从初始发菩萨心已来。彼心尽灭离别星散悉无有处。其无无处不可处之。心在某处其心所集众德之本。是亦灭尽离别星散。无处不处不可分别。所可因劝发道意者亦复自然。以是故曰心者不知心。心者不见心。心心不相待。何谓其心而发无上正真道意成最正觉。其道心者不与善合。其善本心不与劝助。意共俱合。其清净心不舍道心。其人观此不恐不怖亦不怀懅。又复心念十二因缘。甚为深妙不失报应所种果实。心亦不着于一切法。假使因缘从报应致。一切诸法无有真谛亦无君主。恣其所欲而自迷惑。吾当精进执其一心使不回转。何谓心法何谓迷惑。心如幻化无能净者是为心法。假使皆舍解迷惑事。劝助佛国是亦迷惑。心如夜梦觉不知处是为心法。若于禁戒而行谨慎然后自劝。是五神通是为化变。心如野马本末灭尽是为心法。设以顺从一切忍力。安和正觉庄严其心而化变矣。用劝助之是为化变。心如水月究竟自然。寂静澹泊是为心法。若悉精进劝发具足。无数佛法是为化变。心不可持亦不可见是为心法。若复备悉禅思脱门三昧正受。愿佛定意是为化变。心者无形无比无教。亦无像色是为心法。若能颁宣分别智慧。劝助佛道推往古世是为化变。心无因缘终不起生是为心法。若能导御一切德本是为化变。设无有对心终不起是为心法。若因法报修于道心是谓为变。其心境界永离垢浊初无所生是为心法。若导御心得致报应。至于佛界是谓为变。菩萨自观己心观他人心。得神通已其心一定。寻见一切众生心念。因说罪福皆自然矣菩萨自见其心见他心已则兴大哀。已兴大哀教化众生不以劳倦。其心不灭亦复不尽。坚住其心不与生死。而俱同尘能自制心。以此圣慧通达之心。入于不起无所生法。不堕声闻缘觉之地。常自御心堪任具足诸佛道法。一心念顷以智慧心。逮得无上正真之道为最正觉。是为菩萨自察己心。观他人心得至意止

何谓菩萨自观其法。观他人法得法意止。以明智眼普见诸法。未曾中忘至成佛道。自观其法观他人法。是时菩萨悉见诸法。其想于空令脱空义。脱无想愿度无所生。亦无所灭而离诸行。等见诸法舍于缘起。十二牵连观法界行。菩萨察法不随非法。不计吾我亦不计人寿命处所是谓为法。何谓非法。自见吾我计人寿命。睹于断灭计有常存。而见有无合散之事。一切诸法皆亦是法。一切诸法亦复非法。所以者何。晓空无想及无愿义。是一切法皆为应法。自计吾我缚在诸见。是一切法悉为非法。彼自观法观他人法。菩萨行此不见诸法。何所佛法谁非佛法其无径路无有解脱亦无生死。皆能开导一切诸法。处于众生逮得无盖无极大哀。疗诸尘劳己心发念。是无尘欲亦无不尘。所以者何。是所趣者开度平等。不疑尘劳不畏贪欲。晓了是者乃名曰佛。尘欲自然道亦自然立心如是。虽有所住亦无处所。不住立意而名曰住。是谓为住。立于法界不住法界。不住人界则无所住名曰虚空。一切诸法等如虚空。若有菩萨自观身法观他人法。则能导御诸佛道法。一切诸法皆归解法。若晓了者乃能显发。尽于无为亦无所尽。道无生处不生之处。观察众生未曾舍离。无生本际趣法意止。意在诸法而令坚住。不着声闻缘觉佛法。何谓不着何谓处当。心所在处常能坚住。其住不迷未曾忽忘。观已来际其法所由。亦观他法而得意止。颁宣无量分别章句。所行无际等御佛法。可悦一切众生心念。降伏众魔得自在慧乃谓道义。是为菩萨自见己法。见他人法得至意止。何谓四意断而不可尽。身诸恶法未兴起者令不起生。以生寻灭而修精进。自摄其心所念顺义益加精勤。是谓平等奉精进行。不失顺节习修平均。以能摄心观于正谛此之谓也。所以者何所念顺义。恶不善法不复重来。何谓不善。毁戒乱定惑于智慧。何谓毁戒。欲生天上则谓毁戒。不从法教其缺戒品是谓毁戒。何谓乱定。违失礼谊行不专精。心在他念是乱定意。何谓惑于智慧。断诸邪见见若干品颠倒诸事。阴盖碍法其缺智慧是谓不善。假使诸恶如是像法兴起来者。而不听之是一意断。假使诸恶不善法兴即寻觉之。知之非法不善报应。了之损耗为行秽矣。名之冥室修奉顺义消不净欲。则以慈心而除嗔恚。解十二因缘而灭愚冥。其尽尘劳是谓为断。同因缘起观其所生。不得本末而无所断。一切诸法从习行致是二意断。设令善法未兴起者劝令兴发。显使精进自摄其心叹无量德。所以者何善法无量。菩萨大士所应修行。当乐慧根众德之本。皆由精进致诸福庆。显扬通致德祚之原是三意断。所可谓言善法若兴令得坚住。不畏失节不忽忘之。益乐元元夙夜精进。自摄其心以劝助道斯谓平等。所以者何。劝道心者德本不朽。所以者何。其心清净。虽处三界而无所著。若有劝助德猗三界则谓尽索。若能劝乐志一切智。谓通慧本终不损耗是四意断。何谓菩萨而修神足。神足有四。已自发乐殷勤精进。彼以何习兴神足本。当行四等慈悲喜护。常当遵习四无放逸。广大其心而不贪身。以能治心奉第一禅。如是至四以得禅定身心轻便。身心已便所谓入神通。以入神通。即生神足。勤修精进元元志道。以勤乐故辄亲道义。以精进故能成此法。以勤修故而致此义。一心观察以方便法。晓致神通故谓神足。常爱乐故能有所变。以精进故能使成就。以专精故能了广大。聊自修德辄成于道。有计于彼菩萨神足。缘是之故而得亲近。有心自在所欲至到无能违者。谛行所致究竟根原众行备悉。魔不能制等如虚空。彻视无边洞听无际。定意无限神足无底。见一切根自睹其原。是为菩萨行四神足而不可尽

何谓菩萨修于五根而不可尽。何谓为五。一曰信根。二曰精进根。三曰意根。四曰定根。五曰慧根。何谓信根常信诸法。何谓为法其正见者信游生死。随其神足以成彼行。不乐他神而解第一真谛之义。脱于深妙十二因缘。无吾我人空无想愿无所著相。普信诸法不堕诸见。信诸佛法信于十力四无所畏。不怀狐疑亦无犹豫。合集佛法令无限际是谓信根。何谓精进根。所信法者因此精进诸根益明踰日月光是精进根。所可用法修精进根。由是之故不失意根。其意广大不住崖际是谓意根。斯意静然不违意根意广如空。以之意根专精不乱是谓定根。其定意根常住寂名。而专守一是谓慧根观察晓了。若于此法如是色像。分别无我是谓慧根。如是五根能具足者具诸佛法。其能具者住受决地而不动移。犹如外学五通仙人虽视胎中不能豫别男女之根。诸佛世尊亦复如是。菩萨所学未成五根则不授决。五根已达然后受决。是为菩萨五根无尽

何谓诸力则有五力而不可尽。何谓为五。一曰信力。二曰精进力。三曰意力。四曰定力。五曰慧力。何谓信力。常怀笃心在一寂静而不迷荒。无有色像住见佛形。亦知他法一心寂静。所在信力未曾退转是谓信力。何谓精进力。设常元元修于精进。在在修德勤于经典。所生之处其心坚强。所修德本天上世间无能毁者。亦不能制令不增益。由是之故德本兴盛至无限量是精进力。何谓意力。所在念法心不懈废。爱欲众难无能犯者。以此意力越众尘劳。其菩萨者意之所念。天上世间无能乱者是谓意力。何谓定力。若在众会游愦闹中所在寂静。颁宣道力进止行步。第一禅者无能蔽碍。所修德本专精道行亦无能毁。第二禅者修于欢悦。内清澹泊而不有碍。第三禅者欲化众生。将护正法无所观察。逮于四禅者亦无所碍。以此四禅修禅品类无能踰者。所修定意无能乱者。定意自在是谓定力。何谓慧力。若处俗法及度世法悉能晓了。所生之处无能为师。悉知世俗章句文字。所造立业神仙异术。五经六艺方俗异书。菩萨不学自然知之。及度世法无所不通。菩萨以此圣明之慧。心能通畅天上世间独步无侣。随时颁宣。是谓慧力而不可尽

阿差末菩萨经卷第六阿差末菩萨经卷第七

        西晋月氏国三藏竺法护译

何谓觉意。菩萨所行有七觉意。何谓为七。一曰意觉意。二曰法觉意。三曰精进觉意。四曰喜觉意。五曰信觉意。六曰定觉意。七曰护觉意。何谓意觉意。所思念法而观察经。审于正典思惟经法。称扬专念自察其意。不得法相能晓了此。何谓诸法无有相者。其相自然诸法悉空。其能晓了如是觉念是谓意觉意。何谓法觉意。若能分别八万四千诸经法藏。选择诸法应于藏义。若不应藏归于正义。若无正义近义远义清义深义。若第一义晓了法力。合者散者决不决者。悉能选择知其本末是谓法觉意。何谓精进觉意。若以此意由是宣法。摄取信定所护圣慧。以微妙力乐于强识无能制远。精进修行此平等行是精进觉意。何谓喜觉意。所爱乐法笃信不离。常怀喜悦而不怯弱。其身口心常得休息。思务道法消化尘劳爱欲之患是谓喜觉意。何谓信觉意。若能所信永离身心。爱欲尘劳心住定意是谓信觉意。何谓定觉意。由以意定达了诸法。分别圣慧心以专精。明识诸法诸根通利。断众倒见所住无处。皆由定故能致此耳。解无吾我诸法平等是谓定觉意。何谓护觉意。若能思惟分别法界。心不驰骋猗在俗法心无边际。不为俗法之所迷惑。不住假号无能动者。无思无念无喜无戚。由是之故得至圣路柔顺法忍是谓护觉意。此七觉意而不可尽

何谓正见。贤圣度世不住吾我。不住人寿命无所猗见。不住有见及与无见不住德本。不堕邪见六十二疑是谓正见。何谓正念。凡夫所念淫怒痴病尘劳之弊。菩萨学者不想念此。唯念戒定慧解度知见事所示现品。常念道义恒一其志。谓心不邪是谓正念。何谓正语。所说言辞不自见身不见他人。言语柔和不演粗义。以此宣教入于圣道。不说世谈无益之言是谓正语。何谓正治。所修行者罪福众义不行此法。唯修正道平等之义是谓正治。何谓正业。演贤圣辞多所悦豫。而知止足不舍限节。不贪利养不怀谀谄。心不游逸所修辄善将养威仪。见他得供不怀嫉妒。己所得养安身而已。不犯殃衅随佛教训是谓正业。何谓正便。若修方便从其正教。不从淫怒愚痴爱欲而俱同尘。常远此便乐于圣道。至成灭度无为之义。常思念此是谓正便。何谓正意。其意所住真正不受不怀谀谄。而悉睹见生死之难一心思惟无为之道。不忘圣路是谓正意。何谓正定。以定意故乃谓平等。由是之故诸法悉等。其于正定而立平等。若有菩萨住此定者。等度众生不越正慧。是谓正定而不可尽。去来今佛皆游此路。若有菩萨顺从此教习学颁宣。是则名曰八道而不可尽

阿差末言。唯舍利弗。菩萨寂然所观察者亦不可尽。何谓寂然。其心澹泊寂寞定然。诸根不乱专精无想。作性安隐不卒不暴。庠序静思舍不顺念。乐于一义除众愦闹。好喜闲静其身寂寞。心未曾乱思于闲居。无有众恶不匿其过。不堕邪见而知止足。志性清净威仪备悉。不越礼节知其随时。举动应宜供养顺教。合集德力而不自大。不猗名称功勋远闻。其心专精乐于独处。一心禅思兴于慈悲。而行悲哀修于喜悦奉行观护。从第一禅至八不思议定意之门是谓寂然。又其寂然业不可量。若能通达于此业者是谓寂然

何谓为观。分别智慧奉修道法。无我无人无寿无命。观五阴身四大法种。观诸衰入犹如空聚。分别具成而观察知。十二因缘顺无所乱。舍离诸见睹诸报应。因缘果实晓识德果。所造证明入于正真。已能入中省众圣慧。所谓观者平等法明。所见诸法而正谛观。不见异法空无想愿。唯睹于此三脱之门。所谓观者。不见处所屋室之宅。亦复不无不见起分。不得颠倒妄想之业。所谓观者永无所见。设无所见是谓为观。于诸所见而无所见是谓为观。如是见者名真谛见。乃能晓了随佛之教。如是见者为菩萨故。不堕无行不住正行是谓为观。此则名曰菩萨寂然正观而不可尽

阿差末言。唯舍利弗。菩萨总持辩不可尽。何谓总持积累德本。思惟大业八万四千诸品法藏执持诵念。思之怀之不舍精进是谓总持。又总持者。皆能启受诸法所说。声闻缘觉诸菩萨众。一切群黎文辞言说。所讲义理悉能识念是谓总持。假使劫烧天地遇灾其身寿终。又彼菩萨虽遭此难。续识总持怀在心中。未曾忽忘亦不迷荒。以圣慧眼普见诸法如自察掌。是为总持亦不可尽

何谓辩才无有尽者。所谓辩者所说无碍。若讲谊时无能制者。辩才通利无能断者。音辩无限节。卒问寻对应机无难。通达如水无一质碍。前世宿命所造清净行。报应所致乃得此辩。诸佛所护诸天宿卫。所讲说者终不唐举。辞无所侵趣无为道。如是辩才皆为备悉。恭恪谦下相人之器而为宣法。其有闻者各得其所不豫思惟。有来问者吾当说此。所诣众会趣见人根。发生心念而为说法。本所从来生在人间。志性真正一劫宣经而不休息。所讲经典无所挂碍。是为菩萨辩不可尽

阿差末言。又有菩萨讲一切法。皆归无常物非我有。其慧所说而不可尽。一切皆苦诸法无我。菩萨宣此亦不可尽。何谓无常。观本末事悉归无常无有科律。其无常者不可令常。从始以来无不无常是谓无常义。何谓苦义。虽有欢乐会当归尽。愿不久存论说众苦悉趣空无。其空无者亦虚无实。虚空苦义正等无异。何谓非身。于我不我永无本末。彼亦为虚寂静无要。有计其空及空义者悉无有身。何谓寂义。于寂无寂乃谓为寂。所解脱者而于澹泊亦无澹泊是谓为寂。所谓脱者。修于静默除一切想。除诸想已斯曰无为泥洹之寂。此谓寂灭义。是为菩萨行四谛之法而不可尽

菩萨所行常修一道不遵他行。何谓一乘道。菩萨独步而无有侣。唯一己身得成无上正真之道为最正觉。被大德铠。自摄精进无极势力。其身独立不从他教。超诸俗力一己游步。被于坚固非常德铠。以此开化一切众生是谓教化。所训诲者诸贤圣教菩萨大士。所训诲者是谓教化。施非我伴我是施侣。持戒忍辱精进一心智慧。则非我伴吾是慧侣。亦复不住六度无极。吾顺奉行诸度无极四恩之行。不兴发我吾当建立摄诸四恩。取要言之。诸善德本不能立我。吾当建立摄诸德本。如是像法无有伴侣。当自独立而无二伴。住金刚场以己身力降伏众魔。一发心顷得成无上正真之道为最正觉。是为菩萨一乘之道而不可尽

阿差末言。唯舍利弗。菩萨善权亦不可尽。何谓善权。诸佛世尊随时便宜。道法自遇有所开化。以权方便亲近道心。其善权者因虚空生无有边际。志性随时令致殊特。其善权者皆能具足诸度无极。所生之处因权行戒布施忍辱。护身口心得至佛道不废精进。若无权者违失精进。善权一心转进圣慧。不尔心乱善权智慧。不舍生死周旋之难。善权慈者多所养护除诸不仁。善权哀者不厌生死开化一切。善权喜者不乐一切诸所好慕。善权护者修众德本而不回还。善权天眼得佛十眼。彻视十方而无边际。善权天耳得佛十耳。闻十方声心所念形。善权知心见众生根悉晓本末。善权方便念过世事。见于三世去来今义。善权神足在所至到而无限节。多所开化十方黎庶。善权方便知众生性。随以方便而诱[言*求]之。善权修行晓众人相本末终始。善权所度过于此际令至彼岸。善权入尘化众爱欲令度诸垢。善权下担去诸五阴所负重殃。善权行限而所颁宣不可称载。以诸有限说无边际。善权劝化诸弱劣根。诱进退者使广无极。以权方便知其时节。增减进退非时行时。以权方便因其正路。入于邪径众生之类。住于邪路化入正道。以权方便能使鲜少变为广大。其广大者能使无限。以权方便诸诤乱者伴侣相憎劝令和合。以权方便其在下士小乘之党。使住微妙。以权方便得至灭度。还入生死免此余人。以权方便解诸系缚闭塞罗网。以权方便能使坏结心志忍辱。以权方便常在寂静不堕灭尽。以权方便悉能解达一切所修。威仪礼节不失仪式。以权方便观诸众生。而不毁戒常顺正禁。以权方便有所摄取而不诤讼。以权方便兴隆道法宣布十方。以权方便独步三界而无患难。以权方便得至脱门致无所行。以权方便弃不贤行。虽在其中不与同尘。以权方便与道者俱入不违训。善权方便舍于无为。能入生死济脱众患。以权方便入于魔界。照诸尘劳爱欲之根。以权方便计于一切。无有一切亦不无有。是则名曰菩萨所行善权。方便入不可尽

阿差末言。是舍利弗。菩萨所行八十品第而不可尽。诸佛世尊皆由此法。八十无尽而出生矣。阿差末菩萨说是法门不可尽品时。七万八千人。从本以来未发道心。应时皆发无上正真道意。五万二千菩萨。寻时逮得无所从生法忍。一切众会咸取众华。若干种香诸宝华盖。以用供散如来至真。及阿差末诸菩萨上。奉敬归此无极经要。天于虚空鼓诸天乐。举声称叹佛者世尊。从无数劫所积德本。自致正觉广度一切。今阿差末菩萨大士。称举经典宣扬本末不可尽谊。若有人闻此不可尽经典要者。心不怀疑信持讽诵为他人说。笃佛言者。亦当逮得如是功德不可尽谊佛取体衣赐阿差末。一时嗟叹阿差末菩萨言。善哉善哉快说此经。如来所劝代之悦豫。十方江沙今现在佛亦共咨嗟。时阿差末取佛所赐。着其顶上而叹说言。此世尊衣当以顶奉夙夜承事。为是天上世间拥护至尊无量佛之所服。应时十方各有宝幢宝盖宝幡。各自然至。覆阿差末菩萨之上。宝衣宝盖宝幢幡中。自然演教而出音言。善哉善哉阿差末菩萨。快说此辞能讲颁宣无尽法门。十方诸佛咸共嗟叹

时舍利弗前问佛言。今此宝衣宝盖宝幢。从何所来乃演此音。佛告舍利弗。阿差末菩萨前所曾化众生之类。使发无上正真道意。各于十方皆成正觉。此如来等故遣此来。供养报恩正士本德。颁宣洪业大会之品。供养经典故覆其上。时诸众会见此变化。闻佛所说益复加敬。阿差末菩萨大士。欢喜踊跃。我等善利宿本禄厚。乃得值见阿差末菩萨。稽首咨讲其闻此法福不可量。假使有人闻阿差末菩萨名者。德无能限。况复面值得归闻经。其佛大圣嗟叹劝之。岂况凡庶。佛告舍利弗。若族姓子族姓女学菩萨乘。诸佛世尊住世一劫。咸共供养布施所有。奉修禁戒而无所毁。假使众人加之痛害皆能忍之。元元精进行如救头所火然炽。禅思一心不怀愦乱。观察智慧不失时节。奉敬诸佛如是终劫。复有族姓子族姓女。闻此经典笃信受持。而讽诵读专修奉行。进退在心。佛叹此等六度无极。皆为备悉疾逮无上正真之道为最正觉。所以者何。若有菩萨学此经典。心自发念我学斯经。具为人说颁宣悉周。是则名曰能悉备具施度无极。所以者何。受此经者计于法施。众施之上近于佛道。若具禁戒所度无极无所犯负。众行周悉无一缺漏。是故名曰戒度无极。所以者何。菩萨若宣此经典时普备禁戒。一切众生不能称载。功德之勋所不能逮。假使菩萨忍一切法。众所娆害而心不起。不如诵学此经典要。悉为人说以为行智。而得具足忍度无极。其身口心常行精进。欲度一切未曾懈废。是则名曰进度无极。其有专精于此经典。思惟不乱一心定意。是第一禅所度无极。若于此经现在察惠。拾取其义知行所趣。是则名曰智度无极。是舍利弗若有精学此经典者。因少行故具足菩萨六度无极。以是之故当作斯观。若有菩萨取此经典诵在心怀。若载竹帛上着经卷。为以得摄一切诸法。诸佛经典执在手掌。可使四大变之令异。无能作威转其道意。所以者何。是经名曰诸菩萨印当求斯印。假使有人奉是印者。则能遵奉一切佛法

时四天王与营从俱。皆执兵仗舍之一面。叉手白佛。我等四天是佛弟子。以得道迹能共堪任。供养此等诸族姓子及族姓女周匝宿卫。受是经典持讽诵者奉之如佛。所以者何。一切诸乘皆由此生

于是天帝前白佛言。数从如来咨受经典。其数百千未曾得闻如此经义。畅达进理无有遗疑。我曾往昔与忉利天。数数闻经初未值斯。若有郡国县邑村落州城大邦宣此经者。当诣其所听所咨讲。拥护法师益其气力。精进坚强勇猛不怯。辩才通利独步无畏。斯族姓子以无所畏独在众中。若在屏处广宣此经。佛言。善哉善哉拘翼。若发勇意欲护法师。乐令气力精勤无难。佛言拘翼。若护法师则护经典。以护经典则能将护一切众生。时梵忍天王前白佛言。吾当舍离梵天之乐。禅思等心往诣法师所说经处。拥护法师现四瑞应令觉知之。其梵天王来至斯会从诸天人。何谓为四。一者令见微妙光明。二者得闻天香。三者法师所说流利而无质碍。四者章句相次义不相越。是谓四事。说是经时心无所忘口语辩慧。一切众会悉欲来试无能乱者。心怀念法一心听经。以此四事所现惠意。当知梵天与诸眷属来诣彼会

时魔波旬前白佛言。因此经典令我羸劣无一势力。若有菩萨闻斯经典则为受决。所游诸国视之如佛。唯然世尊。我身于今见阿差末威神圣力。弃诸贡高不怀自大。所以者何以此经典当兴拥护宿卫法师。从今自制不敢违教。所在流布行此经典。遥将养之不敢娆乱

尔时世尊告阿难曰。汝当勤受于此经典。持讽诵读为他人说。当令正法永得久存。阿难白佛言。唯然世尊。我已启受讽诵已达。但不能堪令普流布如诸菩萨。佛告阿难汝且默安。自当有人普令流布。今此会中有诸菩萨。主护正法当令奉宣布此大化

干时彼会有六十亿诸菩萨众。寻从座起应护正法。前白佛言。唯然大圣。吾等俱共当受此经大会法品。随时流布遍于十方。及此忍界皆当蒙恩。弥勒菩萨护法王典。当广宣布斯经典要。佛灭度后若有菩萨。在于末俗五浊之世。得闻此经持讽诵读。当知弥勒之所建立。时佛赞告诸菩萨曰。善哉善哉诸正士众。汝等佛前而自咨嗟欲护正法。则为拥护十方江沙诸佛正法

时阿差末菩萨前白佛言。唯然大圣当见原恕。向者我身所讲经典。力少智薄所宣句谊或能不备。是故归佛见舍罪衅。及诸菩萨奉无尽法。佛告阿差末。卿所说法句谊相次。无一违理逮无挂碍。若有菩萨无阴盖者。所宣道教无有缺漏。分别经义审如所言。况今正士畅此经典。表里通达所度无极岂不及乎。今阿差末得四分别。辩才智慧所畅自在。而于大乘无所依仰独步无侣。宣决众疑度于彼岸。若有菩萨住此道地。其身口心终无缺漏。于一切慧以为元首无所不通。身口心行而皆备悉。十方无数百千亿佛。皆共咨叹卿所讲说。今佛相恕表里通达无一遗漏。十方诸佛亦复俱然

于是阿难前白佛言。此经典者所号云何以何奉持。佛告阿难。此经名曰阿差末菩萨之所讲说义理章句而不可尽。其要名曰阿差末品。阿难若有人受此经法者。其心转明强识义理。功勋之正转百千倍。为他人说则立佛事。佛说如此。阿差末菩萨。贤者阿难诸天龙神。莫不欢喜。稽首而去

阿差末菩萨经卷第七


拔陂菩萨经

    No. 419 [Nos. 416-418]

拔陂菩萨经

        僧祐录云安公古典是般舟三昧经初异译

闻如是。佛在罗悦只竹园多鸟树下。与众弟子五百比丘俱。皆是阿罗汉。所著尽。无余结。所作满。所求具。皆已下重担。悉至所愿。已断于故胎从政化度。皆悉度八禅。除一凡比丘。尔时拔陂菩萨。与五百菩萨俱。皆白衣身受五戒。皆从如来欲受正法。拔陂菩萨便起前到佛所。为佛作礼却坐一面。诸菩萨及诸比丘。悉以头面礼佛皆坐一面。佛尔时便取神足定意。使诸比丘在他郡国者。皆来会是竹园。悉为佛作礼。尔时过十余万众比丘皆来会竹园。佛复取神足定意。使大德比丘尼等。从三万余比丘尼。皆来会竹园。为佛作礼悉坐一面。佛复取神足定意。使罗檀迦篓菩萨从惟舍大国。及迦休头菩萨从占波大国。及那达头菩萨从波罗奈大国。及须深无菩萨从迦惟罗卫大国。及大大导众菩萨。及给孤独迦罗越从舍卫大国。及尊达菩萨从拘暹大国。及谩论调菩萨。从沙号大国。各从二万八千人皆会竹园。悉以头面礼佛足悉坐一面。尔时阿阇世王。与过十万众人俱。来到佛所。皆以头面礼佛悉坐一面。尔时第一四天王。及忉利天王。及梵天王。与无央数天众。悉来到佛所。为佛作礼悉坐一面。及诸遍净天无央数众。悉来到佛所。作礼皆住一面。及四阿须伦王。从无央数阿须伦众。皆来到佛所。作礼竟悉住一面。及难头和难龙王。及沙迦罗龙王。及摩奈师龙王。及阿耨达龙王。及伊罗钵龙王。共与无央数众龙俱。来到佛所。作礼竟悉住一面。尔时是三千日月间。无有空无人者。皆大神妙天龙神。及人非人从下并梵天。拔陂菩萨便起坐。整衣服右膝着地。向佛叉手便言。今欲有所问。愿佛演说解我所难。佛因言。拔陂恣意所问。如来今我悉能解汝所问。知汝意生灭形象。拔陂菩萨便言。云何得菩萨定意所闻如海多藏。所闻无有余疑。不忘生念亦不退亦不懈惰。于无上之道至德正觉。为佛转生。不落无法处。常识所从来生。未尝离本愿见如来至。便卧梦亦不离正。得形常端正。可爱见者。喜生于豪贵家。常持坚强意。自里所学。疾所知不忘。广计虑意坚固惭羞。具了理奇可多行慈。常有默觉。所对多威。神常精进不中悔。传放义。常入法。常入止。常入观。常入禅。常入定。空不入相。无形地法。不恐不惧。常乐说法。常乐受法。意所愿生不复违其本愿。本德多力。本意多力。本因缘强。五根强。所作常强。呵止恶常强。所观常强。于解所愿常强。难胜量譬如海。譬如月自具净满。譬如日稍尽阴冥。譬如火能现色。譬如虚空难可涂污无所著意已空。譬如明珠悉达正法。譬如石安住不动譬如根难摇动。譬如[狂-王+否]及溥软其意无所痏。譬如蜚鸟意以低伏。譬如乞儿不起。乐在县国乐山谷。譬如麋鹿亦猴猿不亲爱俗人。亦有学者常导众复牵众。无嗔恚在诸人不复化。悉诸魔随次解度。诸法无教导自意解。于觉法在禅坚不缘邪。有大慈力难可娆。所念常深不离正行。无能计其所得所念。得闻法数依堕泪。所忌常太。一切具佛所行思愿。众来欲采无数善念。愿取海清净信。增愿净洁。妒嫉嗔恚断常愿明在。一切知至光内欢喜。行愿以断不信忌。为黠所洒。满无数天愿行。一切庄饰世断绮可。便净好行戒净具为。能断弟子因缘觉地。心所求愿坚不转。所作竟成所求常无造。于天人道善法行不餍事。悉于菩萨成满具度不忧喜。一切于异学不倾邪。一切敬乐诸佛。悉见法光耀无能化坏。常悉会面于诸佛。譬如作幻人一切法非我。譬如化人未来于后法。譬如梦人过去当来现在事。譬如有光一切世悉见身。如双日亦不行。亦无所止因缘法。譬如景于生死。以住无胎。已断胎想过不取法。行远弃已忧法器。菩萨意已无数。一切于世一切无能转不堕。次近无所著。一切佛国界已度符节门。一切足解散善法。自上如法器。一切于诸佛。一切为如来所拜。以佛神住衣毛不动。能力如师子独吼。常见敬一切。能饱满世众不乱误。一切为诸佛所待知。如时觉行化。弃所疑。无彼受法。一切三世无不照知一切黠慧说无穷。常行慈以得哀。不留事说经明不慧弃住。悉于诸人不两随。身意同生直。心为世眼三界明。悉三界无能轻易者。行非我。世所有展转止。行不求众乐。独行信忆诚信。法不取不弃一切知演教。彼劝人住大学门。已至无恐怖。善说如来正法一切卷句。常行求见者莫不喜。悉众所从大乐得喜。在如来足下断莲。当乐善说一切佛法。乐行问不仇意着。于行于众止所受恐怖断。起力言行一切度转。常直取所住不动。一切羸彼助说法坐师子座。数数有悉诸佛所知。一切在世无所堕。悉说行在入知常尊法。悉依诸佛行。常愿法不倦解待愚。如来善交无处所行。在十方世常好行一切。为人弃罪成福。默为日增已得入法门。譬如天法身无形故常拏内人。为菩萨一切不断诸佛诸行。不住止欲。具菩萨弃已被人铠。虽多怨嫉欲胜一切。于佛数数愿。如来十种力地。一切想去已为知悉了。工校计知世聚散。一切行入生死。弃无所住亦不乱。已度于法海为藏贵宝。遍行于世一切已远世。已习行大变化佛力足致无比。聚一意愿见诸佛弃。不用一切世所生生异界。如来有住在者。正觉无所著。遥见佛及其国界。闻其法。见其比丘僧。亦不五达。亦不六达。菩萨亦不从是世致彼听视。犹故住是世耳。遥见正觉。亦闻明法。亦悉受行。譬如今面受奉行。令正等。使吾无疑。亦使如是。诸菩萨无懈怠。常面见佛善听法。至梦倾意不为邪。佛便谓拔陂菩萨言。善哉善哉拔陂。是为哀众辞。求众之安。愍念三世。见义见乐见安。于人天能以如是义问如来。先亦自有德。于过去佛已施众善福。已待遇众佛。坐法义座。愿法无所愿援。奉受梵行。少欲约可于无食。喜具戒起诸菩萨。常劝成菩萨。常愿尊菩萨。常愿菩萨意大。愿菩萨盛。愿菩萨得。其所求常慈有大。依一切等心。于人制意度无极。见佛常度理。如来语求佛意。譬如和夷铁无称量。悉人意所常善知觉于面行。是汝德。拔陂。吾已意具知。虽尔者有现在佛定。名为常住止。是定为定意。坚不堕。不失意。下耳根众不他怠。唯如来为我解说是定意。为众学作先。使众人得安。愿愍是世。为人天世及诸菩萨大愿者。皆当以是见光自照。佛便告菩萨拔陂言。常行一法。常作莫餍。奉行如上多益。作莫减如作车成便乘。便可随常所求。已具净。已谛念。已具坚。本力作一切善法。自致踰过便以有。何等为一法。见在佛定意。名为止定住者。所谓因缘。佛意作念。意不邪冥不乱。已默得持精进。不跌无形有待遇。常兴空厚睡卧。为剧怨且远避众会身常隐。避恶知识莫亲。随善政友可法道。直根莫妄占近餍。欲少食不愿贪。好法衣。不愿寿长。随本命慧身无所爱。不顾其亲属。本所生国速弃去。已亲慈心。已得哀意。已住喜意。已行护心诸盖。已弃诸禅。已习色想。已分别阴想不取诸入。不受诸大。不宥意。已不乱生受不住不净。已得一切舍向。一切脱人。一切于人如己身。一切人皆非我。一切法无所取。从戒无所愿常习欲定。多闻欲乐戒。阴不漏毁定。阴不动堕。于法无所复疑。与佛无诤。于法无所弃。于僧不诽谤。粗恶言以断止。待遇于有道过者。常远离世音无乐。不用过世音。常用爱乐畜生音。远弃辟六坚法。已习五度脱。常当习十恶作足已弃十善作足。亲习于九娆。能自解于八无势。悉违舍八精进。常已习九想行。已行八大人念。为已得诸禅莫取爱。莫以闻自大理可绮。下耳听常重法。常欲法色想。已别自想身无所取。想人已悉舍。虽生不为可阴想。已分别所有。已不住常求。欲泥洹愿。不用生死行。于生死恐惧想。于诸阴想如怨。于四大如蛇。于诸入已想空。想三界无所住。见泥洹而独乐。世作不复用。舍世随佛。令于人无诤。一切于世无所亲。一切诸佛常得面。有是身如梦见向脱。常净洁善作。常为求一切诸想。分别计三坚定。常着念一切诸佛。依怙着善本。常思愿一切诸佛。自在欲定。不自愿佛身相等。一切法不分别计世。知义不与诤。从受有能次第。随如来住地利得忍辱。已下入法身空身。为已知人身。不生不灭泥洹身。常以观黠慧眼已为净。一切法非我。愿佛意不堕不踰。一切于佛一其行。不念知欲求到。为无数识申直意。于为业不为彼。随佛智遇善友如见尊。一切于诸菩萨无异意。悉反魔所作。一切世所有如幻。一切诸佛如光。照见如来。常行求菩萨意度无极悉等。等亿诚信见诸佛一切等善法。拔陂。是为现在佛面住定意。亦用是法定意为具来。何等定意具将是法来。所谓现在。现在佛面住定意为何等。拔陂。若有比丘比丘尼优婆塞优婆夷。于戒常具足。常独处不与众。便起意念言。阿弥陀佛为在何方。常在说法如其所闻。便生念在西方。阿弥陀佛如来正觉所治也。去是佛国当过百千亿佛界。名须摩提国。众菩萨所聚。听尊说法已不乱意。常当念是国地。拔陂。譬如人卧梦见聚银若金及众宝。亲友知识极爱亲属。常乐欲见不餍。便与共戏乐。至意亲密谈。至寤尚识其所见。如事为人说。便为堕泪念识其想。拔陂。亦如是。菩萨白衣者若学者。闻阿弥陀佛所在国。常当念其方。无毁漏于戒。于戒阴莫用乱意。净心念一日一夜至七日七夜。如是七日七夜毕念便可见阿弥陀佛。或在梦中如来阿弥陀佛。如来当面自见。譬如上头梦男子。自想为住在空。不想夜亦不想昼。其眼根不为壁墙所遮。不为阴冥所蔽。拔陂。菩萨亦尔。作意行如是。如是于佛界中间。虽有须弥山。有遮迦谤摩呵遮迦谤山。及余黑山。不能遮其眼视。亦不能遮其意。菩萨亦未得天眼。视见阿弥陀佛。亦不得天耳。听闻阿弥陀佛说经。亦未得神足。得往到阿弥陀佛国。菩萨亦不从是下世往生彼。但自故住是世。见阿弥陀佛如来。亦闻其说法如闻奉行。菩萨便从是定意。寤如所闻法。便为人广说。拔陂。譬如人从随沙离闻有好女字须闻。复有第二男子。闻有好女字阿凡和利。复有第三男子。闻有好女名为莲华色。从闻展转着污转自作贪。是诸男子皆未见好女。但遥闻数数起意生念。便有淫起。从卧便梦见。便往到女处。是故罗阅只城中男子。如是起意。如是便见。与共会合。便乱习淫法。晓竟便寤故。识如问如知。拔陂。为汝说如是。从是因缘如是法说。从是不还受别。于无上觉道。我复为其说。当来于后久远。当名为善寤如来无所著正觉。其人但得恣意见想。如是正见如是菩萨。拔陂。亦如是住在是世间。彼有阿弥陀佛。已闻数数念。便见如来阿弥陀佛见在。佛面见住上定意。见便难问如来。从何法会菩萨得生是世。阿弥陀佛便为诸菩萨说言。常念佛意善习不舍。常行幻作便得生是佛国。何等常念佛念如来法不忘。今是如来无所著正觉。身有三十二大人相。紫磨金色身。如净明月水精珠身。譬如众宝所璎珞。在众弟子中独说法。如是为其诚说。何以无所坏故。何所不坏败者。地水火风神天梵王。是皆不亡色痛想行识。如有念如来。因缘如空。空便为已得。是为念佛意。菩萨常寤已舍其定。拔陂。汝用是便到彼所。从到便说是事。从有是如是法说。可使受别不复还堕。于无上得正觉。拔陂。亦汝及摩呵迦叶。及因陀达菩萨。及须深天子。亦及余。于是定意有得者。拔陂。过去久远有一男子。于旷野泽中便大饥复渴。于泽中便得卧。梦得好饭食极意饱食。所饥渴便饱。适寤自意身饱满。便自计是法。譬如梦食。其如是观便忍受别。于佛法菩萨亦如是。居家或学闻佛所在方。常至意当念其方。常愿欲见佛莫取想。于胎亦莫想自有身。常住空想。有想当想念佛。从以空想便以住。以能想念佛。净如琉璃宝中尊。如是念便见如来。拔陂。譬如人从本生国到他方。久久还念本所生国游戏所见。乐卧便梦还故国。便游戏生想如故所到处。于国中恣意戏。寤便为亲近及知识左右侍人说言。我往如是我见如是。我所到到所作到如是。拔陂。菩萨亦如是。居家及学闻佛所在方。常当念其方。愿常欲见佛。如是念菩萨。会见如来净如琉璃宝中尊拔陂。譬如观污露比丘。取半坏败色着其前。便见已青黑亦见坏亦见。空随如烟。但见白骨在前。是骨从何来谁持着。是谁所作。是皆意所作耳。拔陂。菩萨亦如是。持佛不归他。住在是定意。所向方便愿见佛。其方有佛者即见如来身。何以故。以倚着定故。复已持佛故住在是定。以佛威神复己定力。自复以宿功德作三令悉见如来。拔陂。譬如人年尚少。乐自抆拭净器受麻油。净器受清水新磨镜。若于水精器自观其身。悉于是中见其形。拔陂。汝宁谓是人形入油水镜水精器不。若已在其中耶。对言。如来不我谓内不可得。及麻油水镜水精悉见影住其前。亦不从光中来。亦不从身中出。佛言。善哉善哉。拔陂。实如是。以净色已分别。诸菩萨欲见佛易无难见。即能问得问能对。所闻内喜其复内尔。是诸佛从何来我到何所。是皆无从来。知如来无从去。云其自身其复生意尔。但意行是三界耳。我欲观天意即见天。以意作佛。亦以意见。但是我意。为佛如来但意耳。及我身意也。以意见佛。意不能见意。意不能知意。意想为无智。不想意为泥洹。是法无坚。皆从自可起。自可悉空。求自可亦无有。拔陂。菩萨亦如是住在其定。拔陂。有四法菩萨疾得是定。何等为四。一为无央信。二为精进无能逮。三为黠不受彼教。四为亲善友。拔陂。是为四法。菩萨用疾得是定。复有四法。菩萨疾得是定。常求见佛。常愿闻法。计无所住。求佛意不忘。菩萨用是四法疾得是定。复有四法。何等为四。不乐俗言不乐有人识不欲世乐不到睡卧试。但除大小便及饭食时及经行。不识会四辈及余众。常以法布施转增。不乐好色及待过利。是为四法。菩萨疾得是定。复有四法疾得是定。常作佛形像。次画作其好。常持是定意。亦以意乐是定住久长止。亦书受奉行。是定起。弃绮可意无绮可法。便住无上独尊道。常营护如来教令谛不忘。是为四法。菩萨用疾得是定。佛尔时知是义。便说偈言

  当生信于尊令　　莫畏法所空说
  行精进断截卧　　满三月当坐行
  常说法尊所言　　偏教令演其功
  莫乐着见待遇　　无所著得是法
  紫磨色相百福　　常作念佛在前
  欢喜光一切照　　形极好如金珠
  过去佛及未来　　常当念叉手住
  亦见在人天尊　　悉恭敬善法念
  常待遇于德王　　以华香散其形
  与饮食常净心　　求是定当阿难
  鼓吹增及琴瑟　　常作乐无量象
  造喜悦无数喜　　常愿求无极定
  常造作无比形　　好分别相具好
  金色身礼清净　　欲愿定是何难
  所念法常念作　　净洁戒闻欲求
  偕事聚坏散弃　　于是定得不久
  莫生娆于有形　　行慈心具依护
  且当观欲善苦　　求是定得不久
  生意喜于说法　　相侍尊常礼尊
  莫绮可弃贪悭　　于法说莫疾弄
  如是令善可待　　所生灭如来说
  无数佛悉所教　　所求定莫为难

拔陂。菩萨当于说法比丘恭敬。常当礼遇具作待如尊。于是定便为进。拔陂。菩萨有于说经比丘乱意。有念嫉怨恨无清净心。拔陂。众非义所载令许。菩萨得是定意至德尊满道义终无是。拔陂。譬如有眼男子。净夜无云雾。于夜半时仰头视上。便见无数星宿。拔陂。菩萨亦如是。受护佛法者观于意。在东方见无数佛。无数百无数千无数万无数亿百千。求见甚易眼精所观见。拔陂。譬如来正觉眼。一切知一切见。菩萨亦如是。于是见在佛住正定意。从幻闻具行。从精进无偕具行。布施具行。戒度具行。忍辱具行。禅意具行。黠度定具行。得脱黠具行。度无上黠具行。佛尔时解是义说偈言

  有眼观上视空　　于净月中夜起
  见无数亿千里　　虽晓明意在识
  定意尔菩萨得　　见无数千佛国
  从定寤意故识　　亦于众说国好
  定眼净次觉视　　无蔽障观十方
  胜可爱为觉眼　　是定净用见尊
  尊无时想观世　　观十方三世尊
  断毒净无胎相　　愿听善学上德
  亦听法快甚凉　　可疾念空止要
  我是法愿与俱　　安乐众愿为佛
  如无量菩萨色　　见佛国亿万数
  菩萨尔得定后　　见无央诸尊形
  有意学遍慈仁　　从我闻悉持行
  是定尔菩萨得　　无数百法不持
  信羞惭生想爱　　悉远弃世所可
  何不作世法施　　从是得净止地

拔陂。菩萨得定意。当起定意生精进。譬如船满中诸宝。已度大海粗及此岸。船近于岸边没。于是阎浮提人。当大举声称怨。称复悲哭。我曹已贫众不见好宝。拔陂。于是定意可闻已远。不复书不读不讽不行。亦不求义。比丘比丘尼及优婆塞优婆夷。其国处悉诸天世。皆大出声称怨。当复悲哭。我曹悉已空贫众不见是法施。世已有是深妙定意。亲佛所教。佛所称誉。佛所尊说。闻已不书取。亦不讽受。亦不读。复不行。亦不住。乐听绮满害智。不欲具闻。不取多智。虽闻不欲。亦不乐取是定。拔陂。譬如愚人少黠若有人来以栴檀授与之。痴人生不净想黠人便为其说是栴檀极好香。何为于是生不净想。何不嗅之。闻其好香何不视之。见其好色便自挟其鼻。不欲闻香故。闭其眼故。不欲视香色。说是定时亦如是。无戒者不乐欲远。不乐受已习。无慧痛亡其智。到禅便猗着胎归胎。是辈闻是定意。亦不信亦不用亦不随。亦不生内喜。复出声言。于众便作愿善哉。今学光明尚能尔。今世有高比丘。譬如阿难。是经譬如虞中大。去众于屏处更说非谛。是经欲闻巧乱耳。是非佛所说。拔陂。譬如贾人到愚冥人边。出绝好摩尼珠以视痴人。是痴人问主。是珠价直几所。其主言。如是珠于夜作光。以宝满其明处。则是珠于贾子曹便笑戏嘲珠主便度量摩尼珠。复言货主。是珠薄一牛宝则当是其价耳拔陂。亦如是。于后有是菩萨定。如有比丘。能持信坚多欲学。直于奉行惭于疑。欲求度多闻有黠。深念行慈得哀。是定自在处。说如是定为可久住。有痴者。于前过胜未尝有行。未尝有福德。自大多嫉用利自取。欲作世名少闻。本无善学。是曹辈闻是定。亦不持亦不信亦不行亦不乐受。复出声言。甚可怪。是曹比丘。何一不惭。是比丘何一不解。闻是曹世巧言雅辞强说言。是佛所道。拔陂。我已故为若重说。令汝明解及天人世。拔陂。若有人以是重三千日月。满中七宝施与诸佛如来正觉。不闻是定者。若有菩萨闻是定意。已闻复言。是福独多。佛尔时解是义。便说偈言

  一切是重三千　　悉施与满中宝
  愿作佛如是行　　常于世无双二
  其能有得此经　　善定意佛所尊
  闻便信受奉行　　及福快独极尊
  佞调意常自是　　收意邪无定根
  常求会恶知识　　转相教不信是
  漏无戒恶法具　　自可足坚住痴
  转相蹡谓可脱　　敢坏败胜所教
  是经非佛所说　　法王亦无是言
  敢出是恶声说　　恶作具不捡意
  有当见大雄尊　　三世将光无量
  是义出为是辈　　是皆为持法学
  已闻是深妙经　　闻便受内生喜
  是曹辈可莫疑　　不忧后不为佛
  有戒具清净行　　有信悉直无邪
  口说法如海流　　我所说为是贤　拔陂菩萨经


百千颂大集经地藏菩萨请问法身赞

    No. 413

百千颂大集经地藏菩萨请问法身赞

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

  归命礼法身　　住于诸有情
  彼由不遍知　　轮回于三有
  其性即生死　　净时亦复然
  清净是涅槃　　亦即是法身
  譬如乳相杂　　醍醐不可得
  如烦恼相杂　　法界不可见
  譬如净乳已　　酥精妙无垢
  如净其烦恼　　法界极清净
  如灯在其瓶　　光耀无所有
  如在烦恼瓶　　法界不照耀
  彼彼令一边　　其瓶若得穴
  由彼彼一边　　光明而外出
  以三摩地杵　　破坏烦恼瓶
  遍满于虚空　　普遍光照耀
  法界亦不生　　亦不曾坏灭
  一切时不染　　初中常无垢
  譬如吠琉璃　　常时极光明
  石藏以覆蔽　　彼光不照耀
  如是烦恼覆　　法界妙清净
  不照于生死　　于涅槃光明
  有性若有功　　则见于真金
  无性若有功　　困而无所获
  如糠覆其上　　不名为粳米
  烦恼覆其上　　亦不名为佛
  若得离于糠　　显现于粳米
  远离于烦恼　　法身得显现
  世间作譬喻　　芭蕉无坚实
  而有贞实果　　食味如甘露
  如无实生死　　流转烦恼海
  其果即佛体　　甘露施有施
  如是于诸种　　相似生其果
  无种亦无果　　智者必不信
  种子则其性　　诸法之所依
  次第若能净　　获得成佛位
  日月常无垢　　以五种覆蔽
  云雾与烟等　　罗睺手及尘
  如是心光明　　覆蔽以五垢
  贪爱嗔恚眠　　掉举与疑惑
  如火洗其衣　　种种垢不净
  若掷于火中　　烧垢不烧衣
  空类诸契经　　所有如来说
  一切断烦恼　　不曾坏其性
  譬如地下水　　常住而清净
  智隐于烦恼　　清净亦复然
  法界亦非我　　非女亦非男
  远离一切执　　云何分别我
  诸法无所著　　女男不可得
  贪盲调伏故　　示现男女相
  无常苦空性　　心净虑有三
  最胜心净虑　　诸法无自性
  如胞胎孕子　　有之而不现
  如烦恼所覆　　法实不可见
  分别有四种　　所生大造者
  分别我我所　　名想及境界
  一切佛大愿　　无所有无相
  自觉相应故　　诸佛常法性
  如言兔有角　　分别而非有
  如是一切法　　分别不可得
  分析如微尘　　分别不可得
  如初后亦尔　　智云何分别
  如是和合生　　和合亦灭坏
  一法自不生　　云何愚分别
  兔牛二角喻　　此名遍计相
  依住于中道　　如善逝法性
  如月及星宿　　现于清水器
  影像而显现　　如是圆成相
  初中亦为善　　常恒不欺诳
  彼无五种我　　云何我分别
  譬如热时水　　故名为热水
  是则其冷时　　则名为冷水
  覆蔽烦恼网　　是则名为心
  若离其烦恼　　则名为等觉
  眼识缘于色　　影像极清净
  不生亦不灭　　法界无形相
  耳识缘于声　　清净识三种
  以自分别闻　　法界无形相
  鼻依香而嗅　　无色亦无形
  鼻识是真如　　法界应分别
  舌界自性空　　味界性远离
  无依亦无识　　法界自性故
  清净身自性　　所触和合相
  远离于所缘　　我说为法界
  诸法意为最　　离能所分别
  法界无自性　　法界而分别
  能见闻而嗅　　是味及所触
  瑜伽法是知　　如是圆成相
  眼耳及与鼻　　舌身及末那
  六处皆清净　　如是彼之相
  心见有二种　　世间出世间
  我执为流转　　自觉是真如
  无尽是涅槃　　若尽贪及痴
  觉彼是佛体　　有情归依处
  一切于此身　　有智及无智
  系缚自分别　　由悟得解脱
  菩提不远近　　不来亦不去
  坏灭及显现　　于此烦恼网
  说于众契经　　住于自思惟
  照以智慧灯　　即得最胜寂
  菩提不远想　　亦无邻近想
  是六境影像　　皆由如是知
  如水与乳合　　同在于一器
  鹅饮尽其乳　　其水如常在
  如是烦恼杂　　智在于一器
  瑜伽者饮智　　弃舍于烦恼
  如是我我执　　乃至所取执
  若见二无我　　有种而灭坏
  是佛般涅槃　　常恒净无垢
  愚夫二分别　　无二瑜伽句
  种种难行施　　以戒摄有情
  一切损忍辱　　界增此为三
  于诸法精进　　静虑心加行
  常习于智慧　　复得菩提增
  方便共为慧　　以愿皆清净
  以力妙坚智　　界增为四种
  不应礼菩萨　　此为甚恶说
  不亲于菩萨　　不生其法身
  增于甘蔗种　　欲食于石蜜
  若坏甘蔗种　　无由石蜜生
  若护甘蔗种　　三种而可得
  糖半糖石蜜　　于中必得生
  若护菩提心　　三种而可得
  罗汉缘觉佛　　于中必得生
  如护于稻芽　　农夫必当护
  如初胜解行　　如来必作护
  如白十五日　　而见月轮形
  如是胜解行　　影现佛形相
  如是初月轮　　刹那刹那增
  如是入地者　　念念见增益
  如白十五日　　月轮得圆满
  如是究竟地　　法身而得生
  胜解彼坚固　　常当于佛法
  能发如是心　　得为不退转
  染依得转依　　得受为净依
  由分得觉悟　　名为极喜地
  常时于染污　　欲等种种垢
  无垢得清净　　名为离垢地
  灭坏烦恼网　　照耀得离垢
  无量之暗瞑　　离名发光地
  清净常光明　　远离世吉祥
  围绕智慧焰　　名为焰慧地
  一切明工技　　种种静虑饰
  难胜于烦恼　　得胜难胜地
  于三种菩提　　摄受令成就
  生灭于甚深　　名为现前地
  游戏于光网　　遍以帝释严
  超越欲暴流　　名为远行地
  一切佛加持　　预入于智海
  自在无功用　　不动于魔使
  于诸无碍解　　瑜伽到彼岸
  于说法谈论　　名为善慧地
  身以智所成　　如虚空无垢
  诸佛皆所持　　普遍如法云
  佛法之所依　　行果皆所持
  所依皆得转　　故名为法身
  离不思议熏　　及离流转习
  如汝思思者　　云何而得知
  超过诸语境　　一切根非境
  意识所取者　　如所有我体
  次第而积集　　佛子大名称
  皆以法云智　　微细见法性
  尔时洗濯心　　超渡生死海
  彼以大莲花　　安立为大座
  无量宝叶光　　宝光明为台
  无量亿莲花　　普遍为眷属
  先以十种力　　以无畏四种
  余佛不共法　　大自在而坐
  一切善皆集　　福智以资粮
  圆月在星宿　　遍满而围绕
  则以佛日手　　以宝光无垢
  灌顶于长子　　普遍皆令灌
  彼住大瑜伽　　皆见以天眼
  无明搅扰世　　恶习苦怖畏
  状如金光色　　从彼瑜伽光
  彼无知所覆　　得开无明门
  以福智感招　　彼获无执定
  随缘而圆寂　　心得皆变化
  诸法无自性　　自性于境界
  菩萨王妙见　　法身妙无垢
  皆以无垢身　　安住于智海
  即作众生利　　如巧摩尼珠
  一切瑜伽者　　大瑜伽自在
  佛影皆变化　　遍满而流出
  或有八臂者　　三目炽盛身
  彼皆瑜伽王　　普遍而流出
  皆以慈悲手　　胜喜执持弓
  射以般若箭　　皆断细无明
  以大力升进　　执持智慧棒
  一切无明[穀-禾+卵]　　普遍皆碎坏
  强力诸有情　　金刚炽盛身
  调伏有情故　　则为金刚手
  自为作业者　　示现种种果
  教诫如教理　　变为平等王
  饥渴猛炽身　　能施诸饮食
  常患诸疾者　　则为善医王
  魔王于营从　　魔女于庄严
  菩萨作亲友　　能施菩提场
  由如日月形　　彼光皆悦意
  流出如电光　　照曜俱胝刹
  由以一灯故　　遍照皆得然
  若一灯灭尽　　一切皆随尽
  如是异熟佛　　示现种种光
  一化现涅槃　　余佛示归寂
  一亦无灭度　　日光岂作暗
  常现于出没　　示现刹土海
  于无智暗世　　能净智慧眼
  往于俱胝刹　　矜愍化有情
  彼皆不疲倦　　由彼大慈甲
  一切于神足　　瑜伽皆彼岸
  皆观时非时　　令彼得流转
  刚强于谄曲　　暂时而弃舍
  无量调有情　　顿作令清净
  无量佛变化　　顿时得暂变
  于三界海中　　而掷调伏网
  舒展妙法网　　普遍令成熟
  则以调伏网　　普遍令成熟
  普遍令举出　　于中漂流者
  则如千有情　　普遍令度已
  度已令觉悟　　妙法不生疑
  世尊妙法铃　　普遍令得闻
  由此振声故　　除落烦恼尘
  增上无明人　　令净于一时
  以日光明威　　破坏众翳瞙
  随从暗烦恼　　及余罪身者
  令彼作利益　　积渐令清净
  彼彼人现化　　安住如水月
  烦恼搅扰心　　不见于如来
  如饿鬼于海　　普遍见枯竭
  如是少福者　　无佛作分别
  有情少福者　　如来云何作
  如于生盲手　　安以最胜宝
  云何而能见　　无上之法身
  俱胝日光身　　光网以围绕
  诸天以少善　　不能而得见
  上次于大天　　云何而得见
  彼色不能见　　诸仙离烦恼
  天修罗梵等　　云何余少慧
  然以佛威力　　清净自心故
  能见如是类　　获得一切盛
  有情福端严　　佛住彼人前
  光明照耀身　　三十二胜相
  彼如是丈夫　　当见如大海
  不经于多时　　即得智如海
  世尊彼色身　　安住于多劫
  能调可调利　　趣于戒种类
  广寿大瑜伽　　少寿何因故
  多人俱胝余　　示现增减寿
  无量俱胝劫　　以命命增长
  因缘皆无尽　　获得无尽果
  若有相应显此理　　唯身以慧作分析
  彼人生于净莲花　　闻法所说无量寿　百千诵大集经地藏菩萨请问法身赞


般舟三昧经卷上(一名十方现在佛悉在前立定经)

    No. 418 [Nos. 416, 417, 419]

般舟三昧经卷上(一名十方现在佛悉在前立定经)

        后汉月氏三藏支娄迦谶译

    问事品第一

佛在罗阅只摩诃桓迦怜。摩诃比丘僧五百人皆得阿罗汉独阿难未。尔时有菩萨名颰陀和与五百菩萨俱。皆持五戒。晡时至佛所前以头面着佛足却坐一面。并与五百沙门俱至佛所。前为佛作礼却坐一面。时佛放威神。诸比丘所在远方无不来者。即时十万比丘。俱相随来会佛所。前为佛作礼却坐一面。佛复威神。摩诃波和提比丘尼。与三万比丘尼俱相随至佛所。前为佛作礼却坐一面。佛复放威神。罗怜那竭菩萨从舍卫堕梨大国出。桥日兜菩萨从占波大国出。那罗达菩萨从彼罗斯大国出。须深菩萨从加罗卫大国出。摩诃须萨和菩萨与阿难邠坻迦罗越。俱从舍卫大国出。因坻达菩萨从鸠睒弥大国出。和轮调菩萨从沙只大国出。一一菩萨各与二万八千人俱来到佛所。前为佛作礼皆却坐一面。罗阅只王阿阇世。与十万人俱来到佛所。前为佛作礼却坐一面。四天王释提桓因梵三钵摩夷亘天阿迦贰吒天。各各与若干亿亿百千天子俱来到佛所。前为佛作礼却住一面。难头和难龙王。沙竭龙王。摩难斯龙王阿耨达龙王。各各与若干龙王亿亿百千万俱来到佛所。前为佛作礼却住一面。四面阿须伦王。各与若干阿羞伦民亿亿百千万俱来到佛所。前为佛作礼却住一面。时诸比丘比丘尼优婆塞优婆夷诸天诸龙诸阿羞伦民诸阅叉鬼神诸迦楼罗鬼神诸甄多罗鬼神诸摩睺勒鬼神诸人非人。无央数都不可计。颰陀和菩萨从坐起正衣服。叉手长跪白佛言。愿欲有所问。既问者欲有所因故。天中天听我言者。今当问佛佛告颰陀和菩萨。所因故者便问。佛当为若说之。颰陀和菩萨问佛言。菩萨当作何等三昧。所得智慧如大海。如须弥山。所闻者不疑。终不失人中之将。自致成佛终不还。终不生愚痴之处。豫知去来之事。未曾离佛时。若于梦中亦不离佛。端政姝好于众中颜色无比。少小常在尊贵大姓家生若其父母兄弟宗亲知识。无不敬爱者。高才广博所议作者与众绝异。自守节度常内惭色。终不自大常有慈哀。智虑通达于智中明无有与等者。威神无比精进难及入诸经中。多入诸经中。诸经中无不解安乐入禅入定入空。无想无所著。于是三事中不恐。多为人说经便随护之。在所欲生何所自恣。无异本功德力所信力。多所至到处其筋力强。无不欲爱力。无不有根力。明于所向力。明于所念力。明于所视力。明于所信力。明于所愿力。在所问如大海无有减尽时。如月盛满时悉遍照无有不感明者。如日初出时。如炬火在所照无所挂碍。不着心如虚空无所止。如金刚钻无所不入。安如须弥山不可动。如门阃正住坚。心软如鹄毛无有粗爽。身无所慕乐于山川如野兽。常自守不与人从事。若沙门道人。多所教授皆护视。若有轻娆者终无嗔恚心。一切诸魔不能动。解于诸经。入诸慧中。学诸佛法。无有能为作师者。威力圣意无有能动摇者。深入之行常随无所行常柔软。于经中常悲。承事于诸佛无有厌。所行种种功德悉逮及。所行常至所信常政。无有能乱者。所行常净洁。临事能决无有难。清净于智慧悉明。得所乐行。尽于五盖。智慧所行。稍稍追成佛之境界。庄严诸国土。于戒中清净。阿罗汉辟支佛心。所作为者皆究竟。所作功德常在上首。教授人民亦然。于菩萨中所教授无有厌。当所作者度无有极。一切余道无有能及者。未尝离佛。不见佛。常念诸佛如父母无异。稍稍得诸佛威神。悉得诸经。明眼所视无所挂碍。诸佛悉在前立。譬如幻师自在所化作诸法。不豫计念便成法。亦无所从来。亦无所从去。如化作。念过去当来今现在如梦中。所有分身悉遍至诸佛刹。如日照水中影悉遍见。所念悉得如向。亦不来亦不去。生死如影之分。便所想识如空。于法中无想。莫不归仰者。一切平等无有异。于经中悉知。心不可计。一切诸刹心不着无所适念。出于诸佛刹。无所复挂碍。悉入诸陀怜尼门。于诸经中闻一知万。诸佛所说经悉能受持。侍诸佛悉得诸佛力。悉得佛威神。勇猛无所难。行步如猛师子无所畏。于诸国土无不用言者。所闻者未曾有忘时。一切诸佛之议等无有异。悉了知本无经不恐。欲得诸经便自知说。如诸佛终无厌。为世间人之师无不依附者。其行方幅无有谄伪。诸刹照明朗不着于三处。所行无所挂碍。于众辈中无所适。于本际法中无所慕。持萨芸若教人入佛道中。未曾恐怖无有畏惧时。悉晓知佛诸经所有卷所在。众会中无不蒙福者。见佛极大慈欢喜。所学诸佛经通利。于大众中无所畏。于大众中无有能过者。名声极远。破坏诸疑难无不解。于经中极尊。于师子座上坐自在。如诸佛法教。悉晓知佛万种语。悉入万亿音。爱重诸佛经。常念在左右侧。未曾离于诸佛慈。于佛经中乐行。常随佛出入。常在善知识边无有厌极时。于十方诸佛刹无所适止。悉逮得愿行。度脱十方万民。智慧珍宝。悉逮得经藏。身如虚空无有想。教人求菩萨道。使佛种不断。行菩萨道未曾离摩诃衍。逮得摩诃僧那僧涅极旷大道。疾逮得一切智。诸佛皆称誉。近佛十力地一切所想悉入中。一切所计悉了知。世间之变悉晓知。成败之事生者灭者悉晓知。入经海宝开第一之藏悉布施。悉于诸刹行愿亦不在中止。极大变化如佛所乐行。心一反念佛悉在前立。一切适不复愿。适无所生处。十方不可计佛刹悉见。闻诸佛所说经。一一佛比丘僧悉见。是时不持仙道罗汉辟支佛眼视。不于是间终生彼间佛刹尔乃见。便于是间坐悉见诸佛。悉闻诸佛所说经。悉皆受。譬如我今于佛前。面见佛菩萨。如是未曾离佛。未曾不闻经。佛告颰陀和菩萨。善哉善哉。所问者多所度脱多所安隐。于世间人民不可复计。天上天下悉安之。今若能问佛如是。若乃前世过去佛时。所闻地行作功德所致。供养若干佛。以所致。乐于经中所致。作道行守禁戒所致。自守法行清白不烦浊。辄以乞丐自食。多成就诸菩萨合会教语诸菩萨。用是故极大慈哀。一切人民皆于等心。随时欲见佛即见佛。所愿极广大甚深之行。常念佛智慧。悉持经戒。悉具足佛种圣心如金刚。悉知世间人民心所念。悉在诸佛前。佛告颰陀和菩萨。若功德以不可复计。佛言。今现在佛悉在前立三昧。其有行是三昧。若所问者悉可得。颰陀和菩萨白佛言。愿佛哀说之。今佛说者。多所过度。多所安隐愿佛为诸菩萨现大明。佛告颰陀和菩萨。一法行常当习持常当守。不复随余法。诸功德中最第一。何等为第一法行。是三昧名现在佛悉在前立三昧

    行品第二

佛告颰陀和菩萨。若有菩萨所念现在。定意向十方佛。若有定意。一切得菩萨高行。何等为定意。从念佛因缘。向佛念意不乱。从得黠不舍精进。与善知识共行空。除睡眠。不聚会。避恶知识近善知识。不乱精进。饭知足。不贪衣。不惜寿命。子身避亲属离乡里。习等意得悲意心。护行弃盖习禅。不随色。不受阴。不入衰。不念四大。不失意。不贪性。解不净。不舍十方人。活十方人。十方人计为是我所。十方人计为非我所。一切欲受。不贸戒习空行。欲讽经。不中犯戒。不失定意。不疑法。不诤佛。不却法。不乱比丘僧。离妄语。助道德家。避痴人世间语。不喜不欲。闻道语。具欲闻亦喜。从因缘畜生生。不欲闻六味。习为五习。为离十恶。为习十善为晓九恼。行八精进。舍八懈怠。为习八便。为习九思。八道家念。又不着禅闻。不贡高弃自大。听说法。欲闻经。欲行法。不随岁计。不受身想。离十方人。不欲受。不贪寿。为了阴不随惑。为不随所有求无为。不欲生死大畏生死。计阴如贼计四大如蛇。十二衰计空。久在三界不安隐莫忘得无为。不欲贪欲。愿弃生死。不随人诤。不欲堕生死。常立佛前。受身计如梦。以受信不复疑。意无有异。一切灭思想过去事。未来事。今现在事等意。常念诸佛功德。自归为依佛。定意得自在。不随佛身相法。一切一计不与天下诤。所作不诤。从因缘生受了。从佛地度得可法。中法中得下。以了空意计人。亦不有亦不灭。自证无为黠眼以净。一切不二觉意不在中边。一切佛为一念入。无有疑黠。无有能呵。自得晓觉意故。佛黠不从他人待。得善知识计如佛。无有异意。一切在菩萨无有离时。纵一切魔不能动。一切人如镜中像。见一切佛如昼一切从法行。为入清净菩萨行。如是佛言。持是行法故致三昧便得三昧。现在诸佛悉在前立。何因致现在诸佛悉在前立三昧。如是颰陀和。其有比丘比丘尼。优婆塞优婆夷。持戒完具。独一处止。心念西方阿弥陀佛。今现在随所闻当念。去是间千亿万佛刹。其国名须摩提。在众菩萨中央说经。一切常念阿弥陀佛。佛告颰陀和。譬如人卧出于梦中。见所有金银珍宝。父母兄弟妻子亲属知识。相与娱乐喜乐无辈。其觉以为人说之。后自泪出念梦中所见。如是颰陀和菩萨。若沙门白衣。所闻西方阿弥陀佛刹。当念彼方佛不得缺戒。一心念若一昼夜。若七日七夜。过七日以后。见阿弥陀佛。于觉不见。于梦中见之。譬如人梦中所见。不知昼不知夜。亦不知内不知外。不用在冥中故不见。不用有所弊碍故不见。如是颰陀和。菩萨心当作是念。时诸佛国界名大山须弥山。其有幽冥之处悉为开辟。目亦不弊。心亦不碍。是菩萨摩诃萨。不持天眼彻视。不持天耳彻听。不持神足到其佛刹。不于是间终。生彼间佛刹乃见。便于是间坐。见阿弥陀佛。闻所说经悉受得。从三昧中悉能具足。为人说之。譬若有人。闻堕舍利国中。有淫女人名须门。若复有人。闻淫女人阿凡和梨。若复有人。闻优陂洹作淫女人。是时各各思念之。其人未曾见此三女人。闻之淫意即为动。便于梦中各往到其所。是时三人皆在罗阅只国。同时念。各于梦中到是淫女人所与共栖宿。其觉已各自念之。佛告颰陀和。我持三人。以付。若持是事为人说经。使解此慧至不退转地得无上正真道。然后得佛号曰善觉。如是颰陀和。菩萨于是间国土闻阿弥陀佛。数数念。用是念故。见阿弥陀佛。见佛已从问。当持何等法生阿弥陀佛国。尔时阿弥陀佛。语是菩萨言。欲来生我国者。常念我数数。常当守念。莫有休息。如是得来生我国。佛言。是菩萨用是念佛故。当得生阿弥陀佛国。常当念如是佛身。有三十二相悉具足光明彻照。端正无比在比丘僧中说经。说经不坏败色。何等为不坏败色。痛痒思想。生死识魂神。地水火风。世间天上。上至梵摩诃梵。不坏败色。用念佛故得空三昧。如是为念佛。佛告颰陀和。菩萨于三昧中谁当证者。我弟子摩诃迦叶。因坻达菩萨。须真天子。及时知是三昧者。有行得是三昧者是为证。何等为证。证是三昧知为空定。佛告颰陀和。乃往去时有佛。名须波日。时有人行出入大空泽中不得饮食饥渴而卧。出便于梦中得香甘美食。饮食已其觉腹中空。自念一切所有皆如梦耶。佛言。其人用念空故。便逮得无所从生法乐。即逮得阿惟越致。如是颰陀和。菩萨其所向方。闻现在佛。常念所向方欲见佛。即念佛不当念有。亦无我所立。如想空当念佛立。如以珍宝倚琉璃上。菩萨如是见十方无央数佛清净。譬如人远出到他郡国。念本乡里家室亲属财产。其人于梦中。归到故乡里见家室亲属。喜共言语。于梦中见以觉为知识说之。我归到故乡里见我家室亲属。佛言。菩萨如是。其所向方。闻佛名。常念所向方欲见佛。菩萨一切见佛。如持珍宝着琉璃上。譬如比丘观死人骨着前。有观青时。有观白时。有观赤时。有观黑时。其骨无有持来者。亦无有是骨。亦无所从来是意所作想有耳。菩萨如是持佛威神力。于三昧中立。在所欲见何方佛。欲见即见。何以故。如是颰陀和。是三昧佛力所成。持佛威神。于三昧中立者。有三事。持佛威神力。持佛三昧力。持本功德力。用是三事故。得见佛。譬若颰陀和。年少之人。端正姝好庄严。已如持净器盛好麻油。如持好器盛净水。如新磨镜。如无瑕水精。欲自见影。于是自照悉自见影。云何颰陀和。其所麻油。水镜水精。其人自照。宁有影从外入中不。颰陀和言。不也天中天。用麻油水精水镜净洁故。自见其影耳。其影亦不从中出。亦不从外入。佛言。善哉善哉。颰陀和。如是颰陀和。色清净。所有者清净。欲见佛即见。见即问。问即报。闻经大欢喜。作是念。佛从何所来。我为到何所。自念佛无所从来。我亦无所至。自念三处。欲处。色处。无想处。是三处意所为耳。我所念即见。心作佛。心自见。心是佛。心是怛萨阿竭。心是我身。心见佛。心不自知心。心不自见心。心有想为痴。心无想是泥洹。是法无可乐者。皆念所为。设使念为空耳。设有念者亦了无所有。如是颰陀和。菩萨在三昧中立者所见如是。佛尔时颂偈曰

  心者不知心　　有心不见心
  心起想则痴　　无想是泥洹
  是法无坚固　　常立在于念
  以解见空者　　一切无想念

    四事品第三

菩萨有四事法。疾逮得三昧。何等为四。一者所信无有能坏者。二者精进无有能逮者。三者所入智慧无有能及者。四者常与善师从事。是为四。菩萨复有四事。疾得是三昧。何等为四。一者不得有世间思想。如指相弹顷三月。二者不得卧出三月。如指相弹顷。三者经行不得休息。不得坐三月。除其饭食左右。四者为人说经。不得望人衣服饮食。是为四。菩萨复有四事。疾得是三昧。何等为四。一者合会人至佛所。二者合会人使听经。三者不嫉妒。四者教人学佛道。是为四。菩萨复有四事。疾得是三昧。何等为四。一者作佛形像若作画。用是三昧故。二者用是三昧故。持好疋素令人写是三昧。三者教自贡高人内佛道中。四者常护佛法。是为四。时佛说偈而叹曰。常当乐信于佛法。诵经念空莫中止。精进除睡卧。三月莫得懈。坐说经时安谛受学。极当广远。若有供养馈遗者。莫得喜。无所贪慕。得经疾。佛者色如金光。身有三十二相。一相有百福功德。端政如天金成作。过去佛当来佛。悉豫自归。今现在佛。皆于人中最尊。常念供养。当供养于佛。花香捣香饭食具足。当持善意。用是故。三昧离不远。持常鼓乐倡伎。乐于佛心。常当娱乐。为求是三昧者。当作佛像。种种具足种种姝好。面目如金光。求是三昧者。所施常当自乐。与持戒当清洁高行。弃捐懈怠。疾得是三昧不久。嗔恚不生。常行于慈心。常行悲哀。等心无所憎恶。今得是三昧不久。极慈于善师视当如佛。嗔恚嫉贪不得有。于经中施不得贪。如是教。当坚持诸经法。悉当随是入。是为诸佛之道径。如是行者。今得三昧不久

佛告颰陀和。如是等菩萨。当慈心常乐于善师。所视师当如佛。悉具足承事。欲书是三昧经时。若欲学时。菩萨敬师如是。颰陀和。菩萨于善师有嗔恚。有持善师。短视善师不如佛者。得三昧难。譬如颰陀和。菩萨明眼人夜半视星宿见星其众多。如是颰陀和。菩萨持佛威神。于三昧中立。东向视见若干百佛。若干千佛。若干万佛。若干亿佛。如是十方等悉见诸佛。佛告颰陀和。是菩萨如佛眼悉知悉见。如是颰陀和。是菩萨欲得今现在诸佛悉在前立三昧。布施当具足。持戒如是。忍辱精进一心智慧。度脱智慧身悉具足。时佛叹曰。如净眼人夜半上向视星宿不可计。昼日思念悉见。菩萨如是逮得三昧者。见不可复计百千佛。从三昧中觉以悉念见。自恣为诸弟子说。佛言。如我眼清净常见于世间。菩萨如是得三昧。以见不可复计佛。见佛不视身相。但视十种力。不如世间人有贪。消灭诸毒以清净不复想。菩萨逮功德如是。闻是经。遵是经如泥洹。闻是法空空。无有恐怖。我当作是说经。用众人民故。皆令得佛道。佛言。如我比丘阿难黠慧闻经即受持。菩萨如是逮得是三昧。以闻不可计经卷悉受持。佛言。如阿弥陀佛刹诸菩萨。常见不可计佛。如是菩萨得三昧。以常见不可计佛。所信常有哀心。譬如渴者欲得饮。常有极大慈。弃捐世俗事。常乐持经施。用是故清净得三昧不久

    譬喻品第四

佛告颰陀和。菩萨慈求三昧者。得是三昧已。不精进行者。譬如颰陀和。有人载满舡珍宝。欲持度大海。未至舡中道坏。阎浮利人皆大悲念。亡我尔所珍宝。如是颰陀和。是菩萨闻是三昧已。不书不学不诵不持如中法。一切诸天人民。皆为大悲忧言。乃亡我尔所经宝。用失是深三昧故。佛言。是三昧经者。是佛所嘱。佛所称誉。闻是深三昧经者。不书不学不诵。不守不持如法者。反复愚痴自用以为高耶。不受是经意欲高才。反不肯学是三昧。譬如颰陀和。愚痴之子。有人与满手栴檀香。不肯受之。反谓与之不净栴檀香。其货主语其人言。此栴檀香。卿莫谓不净乎。且取嗅之知香不。试视之知净不。痴人闭目不视不肯嗅。佛言。其闻是三昧者。如是不肯受之反弃舍去。是为不持戒人。反舍是珍宝经。是为愚痴无智。自用得禅具足为度。反呼世间为有。不入空。不知无。其人闻是三昧已。不乐不信。不入中。反作轻戏语。佛亦有深经乎。亦有威神乎。反形言。世间亦有比丘如阿难乎。佛言。其人从持是三昧者。所去两两三三。相与语云。是语是何等说乎。是何从所得是语乎。是为自合会作是语耳。是经非佛所说。佛告颰陀和。譬如贾客持摩尼珠。示田家痴子。其人问贾客。评此几钱。贾客答言。夜半时于冥处。持是摩尼珠着冥中。其明所照至直满其中宝。佛言。其人殊不晓其价。反形是摩尼珠言。其价能与一头牛等不。宁可贸一头牛想。是不复过此。与我者善。不肯者已。如是颰陀和。其人闻是三昧不信者。反形是经如是。佛言。如菩萨持是三昧。受信者便随行。四面皆拥护无所畏。持禁戒完具为得高明。黠慧深入为他人说之。菩萨当持是三昧分布语人。展转相传当令是三昧久在。佛言。痴人自于前世佛所。不供养。不作功德。反自贡高。多行诽谤嫉妒用财利故。但欲求名。但欲哗说。不得善师。亦不明经。闻是三昧已不信不乐不入中。反诽谤人言。是彼不知愧为自作是经耳。是经非佛所说。佛告颰陀和今我具语汝如是。颰陀和。求菩萨道者。若善男子善女人。持是三千国土。满其中珍宝。施与佛。设有是功德。不如闻是三昧。若有菩萨闻是三昧信乐者。其福转倍多。时佛叹曰。是三千国土。满其中珍宝施于佛。持用求佛。复有异人。持是三昧者。是佛所称誉。闻信者其福倍多。佛言。是迷惑自贡高人。不信者及与恶知识从事。闻此经不信不乐。是为于我经中怨家无异。是不持戒人。在自大中。其余人展转闻其言信随之。此为坏佛法。其人相告言。是经为非佛所说。直作是诽谤。佛言。有信是三昧者。其人宿命曾见过去佛。已用是故我为是信者说是三昧耳。是辈之人。常护佛法。闻是经信乐者。当作是知离佛不远。若持戒坚者。常正心恭敬于经。我用是故为是人说耳

佛告跋陀和。我所说无有异。尔故说是语耳。今见我说是三昧者。其人却后世时。闻是三昧终不疑。不形笑。不言不信。除在恶师边。正使在善师边。其功德薄少。如是辈人。复转与恶师从事。是辈人者。闻是三昧不信不乐不入中。何以故。其人未久学。所更佛少所信。智慧少故不信耳。佛告颰陀和。其有菩萨。闻是三昧。不形笑。不诽谤者。欢喜不中疑。不言乍信乍不信。乐书乐学乐诵乐持。佛言。我悉豫知豫见。已其人不独于一佛。所作功德不于二若三若十。悉于百佛所闻是三昧。却后世时闻是三昧者。书学诵持经卷。最后守一日一夜。其福不可计。自致阿惟越致。所愿者得。佛告颰陀和。听我说譬喻。譬如颰陀和有人。取一佛刹。悉破碎如尘。其人取此一尘。悉复破尽如一佛刹尘。都卢悉取一一尘。皆复尘碎尽如一佛刹尘。云何颰陀和。是尘其数宁多不。颰陀和言。甚多甚多。天中天。佛告颰陀和。我为汝曹引此譬喻。若有一菩萨。尽取是一尘置一佛刹。其数尔所佛刹。满其中珍宝悉持供养诸佛。不如闻是三昧。若复有一菩萨闻是三昧已。书学诵持为他人说。须臾间。是菩萨功德不可复计。佛言。持是三昧者。书学诵持为他人说。其福乃尔。何况守是三昧悉具足者。佛尔时颂偈曰

  三千大千之国土　　满中珍宝用布施
  设使不闻是像经　　其功德福为薄少
  若有菩萨求众德　　当讲奉行是三昧
  疾悉讽诵此经法　　其功德福无有量
  如一佛国尘世界　　皆破坏碎以为尘
  彼诸佛土过是数　　满中珍宝用布施
  其有受持是世尊　　四句之义为人说
  是三昧者诸佛慧　　得闻功德叵比喻
  何况有人自讲说　　受持讽诵念须臾
  转加增进奉行者　　其功德福无有量
  假使一切皆为佛　　圣智清净慧第一
  皆于亿劫过其数　　讲说一偈之功德
  至于泥洹赞咏福　　无数亿劫悉叹诵
  不能尽究其功德　　于是三昧一偈事
  一切佛国所有地　　四方四隅及上下
  满中珍宝以布施　　用供养佛天中天
  若有闻是三昧者　　得其福祐过于彼
  安谛讽诵讲说者　　引譬功德不可喻
  其人贡高终不起　　亦无有趋恶道时
  解了深法不疑结　　行斯三昧德如是
  学士为以见奉吾　　德重精进普不着
  增益信明为菩萨　　力学三昧佛所赞
  属累汝等常劝教　　力行精进无放逸
  自勖勇猛勤修行　　令得大道不复反
  其有诵受是三昧　　已为面见百千佛
  假使最后大恐惧　　持此三昧无所畏
  行是比丘以见我　　常为随佛不远离
  菩萨闻习三昧者　　义当受持为人说
  菩萨得是三昧者　　尔乃名曰博达慧
  为逮总持佛称誉　　疾成佛道智如海
  常恒诵说是三昧　　当从佛法世尊教
  闻其种姓得等觉　　如佛所说无有异

般舟三昧经卷上般舟三昧经卷中

        后汉月氏三藏支娄迦谶译

    无著品第五

佛告颰陀和。是菩萨三昧当云何譬。如佛今于若前说经。菩萨当作是念。诸佛悉在前立。当具足念诸佛端正。悉欲逮见一一想。当想识无有能见诸佛顶上者。悉具足作是想见诸佛。当作是念我身亦当逮得如是。亦当逮得身想如是。亦当逮得持戒三昧如是。当作是念。我当从心得从身得。复更作念。佛亦不用心得。亦不用身得。亦不用心得佛。亦不用色得佛。何以故。心者佛无心。色者佛无色。不用是心色。得阿耨多罗三藐三菩提。何以故。佛色以尽。佛痛痒思想。生死识了尽。佛所说尽者。愚痴不见不知。智者晓了之。作是念。当持何等念得佛。当持身得佛。当持智慧得佛。复作是念。亦不用身得佛。亦不用智慧得佛。何以故。智慧索不能得。自复索我了不可得。亦无所得。亦无所见。一切法本无所有念有因着。无有反言有亦着。是两者亦不念。亦不复适得其中。但用是故。亦不在边。亦不在中。亦不有亦不无。何以故。诸法空。是如泥洹。亦不坏亦不腐亦不坚。亦不在是间。亦不在彼边。无有想。不动摇。何等为不动摇。智者不计。是故不动摇。如是颰陀和。菩萨见佛。以菩萨心念无所著。何以故。说无所有。经说无所有。中不着。坏本绝本。是为无所著。如是颰陀和。是菩萨守是三昧。当作是见佛。不当着佛。何以故。设有所著为自烧。譬如大叚铁着火中烧正赤。有智者不当以手持。何以故。烧人手。如是颰陀和。菩萨见佛不当着。色痛痒思想生死识不当着。何以故。著者为烧身。见佛但当念其功德。当索摩诃衍。佛告颰陀和。是菩萨于三昧中不当有所著。不著者疾得是三昧。佛尔时颂偈言

  如新磨镜盛油器　　女人庄饰自照形
  于中起生淫欲心　　放逸恣态甚迷荒
  追不至诚虚捐法　　为色走使烧其身
  女人患害从是起　　用不解法非常空
  有想菩萨亦如是　　我当成佛逮甘露
  度脱人民忧恼患　　有人想故为不解
  求索人本不可得　　亦无生死及泥洹
  法不可拥如水月　　观察佛道无归趣
  黠慧菩萨当了是　　解知世间悉本无
  于诸人物无所著　　疾速于世得佛道
  诸佛从心解得道　　心者清净明无垢
  五道鲜洁不受色　　有解是者成大道
  一切诸法无色漏　　离想者空无想空
  绝去淫欲则脱心　　有解此者得三昧
  精进奉行求佛道　　常听诸法本清净
  无得行求无不求　　于是三昧不难得
  观察所有如虚空　　道意寂然审第一
  无想无作亦无闻　　是为解了尊佛道
  见一切色不想念　　眼无所著无往来
  常观诸佛等如空　　已度世间诸所求
  其人清净眼无垢　　奉行精进常寂然
  无量经法悉受持　　思惟分别是三昧
  行是三昧无所著　　除一切冥得定意
  不见世雄无贤圣　　诸外异道闻此惑
  超度思想当志求　　心以清净得见佛
  睹诸佛已不复见　　尔乃解是尊三昧
  于地水火莫能碍　　风种虚空亦不蔽
  行是精进见十方　　坐遥听受所化法
  如我于是讲说经　　乐道法者面见佛
  作行勤力而不着　　唯从世尊所说法
  行者如是无所念　　专听道义兴法施
  常念解了是三昧　　普谛受诵佛所讲
  过去诸佛皆论法　　当来世尊亦复然
  赞说宣布分别义　　皆共叹讲是三昧
  我亦如是为人尊　　在世无上众生父
  皆悉解知此道眼　　故解说示寂三昧
  其有讲受是三昧　　身常安隐意不荒
  是为诸佛无量德　　致尊佛道获不难
  广采众经不可议　　欲达一切诸佛化
  速疾去欲诸垢尘　　精进行是净三昧
  现世欲见无数佛　　乐从诸尊听受法
  速疾去色除所著　　行是清净寂三昧
  于是无贪及嗔恚　　舍离愚痴捐憎爱
  弃远无黠除狐疑　　如是得解空三昧

    般舟经四辈品第六

颰陀和菩萨白佛。难及天中天说三昧者。若有菩萨。弃爱欲作比丘。闻是三昧已。当云何学。云何持。云何行。佛言。若有菩萨。弃爱欲作比丘。意欲学是三昧者。诵是三昧者。持是三昧者。当清净持戒。不得缺戒大如毛发。何等为菩萨不缺戒。一切悉护禁法。出入行法。悉当护不得犯戒大如毛发。常当怖畏远离于谀谄。悉当护禁。作是护者是为清净持戒。何等为菩萨缺戒者。是菩萨求色。何等为求色。其人意念。持是功德。使我后世生若作天。若作遮迦越王。佛言。用是比此菩萨为缺戒。其人久持是行持是戒。持是自守福欲所生处。乐于爱欲中。是为毁戒。佛告颰陀和。是菩萨比丘。欲学是三昧者。清净持戒。完具持戒不谀谄。持戒当为智者所称誉。为罗汉所称誉。于经中当布施。当精进所念强。当多信劝乐。常承事于和上。当承事于善师。所从闻是三昧者。所可闻是三昧处。当视其人。如佛。佛告颰陀和。是菩萨视师如视佛者。得三昧疾。设不恭敬于善师。轻易于善师。欺调于善师。正使久学是三昧。久持久行。设不恭敬师者疾亡之。佛告颰陀和。是菩萨。若从比丘比丘尼。优婆塞优婆夷所。得闻是三昧当视如佛。所闻三昧处当尊敬。佛告颰陀和。菩萨所闻是三昧处。不当持谄意。向是菩萨不得谄意。常当乐独处止。不惜身命。不得悕望人有所索。常行乞食。不受请。不嫉妒。自守节度。如法住。所有趣足而已。经行不得懈。不得卧出。如是颰陀和。如是经中教其弃爱欲作比丘学是三昧者。当如是守。如是颰陀和菩萨白佛难及天中天所说法。若有后世懈怠菩萨。闻是三昧已不肯精进。其人自念。我当于后当来佛所索是三昧。耳。云何言我曹身羸极有病瘦恐不能求。闻是经已懈怠不精进。若复有菩萨精进者。欲学是经。当教之随是经中法教。用是经故。不惜躯命。不望人有所得者。有人称誉者不用喜。不大贪钵震越。无所爱慕。常无所欲。闻是经不懈怠。常精进。其人不念。我当于后当来佛所乃求索。自念使我筋骨髓肉皆使枯腐。学是三昧终不懈怠。自念我终不懈怠死也闻是经已无不欢乐。时佛言。善哉善哉颰陀和。所说者无有异。我助其欢喜。过去当来今现在佛悉助欢喜。佛尔时颂偈言

  如我今所说法　　悉受学独处止
  行功德自守节　　是三昧不难得
  常乞食不受请　　悉弃舍诸欲乐
  所从闻是三昧　　敬法师如世尊
  有诵行是三昧　　常精进莫懈怠
  不得惜于经法　　不求供乃与经
  其有受是三昧　　尔乃为是佛子
  学奉行如是者　　得三昧终不久
  常勤力不懈怠　　除睡眠心开解
  当远离恶知识　　然后从是法行
  去放逸不休息　　常舍离众聚会
  比丘求斯三昧　　随佛教当如是

颰陀和菩萨白佛。比丘尼求菩萨道。欲学是三昧。欲守是三昧。当持何等法。住学守是三昧。佛告颰陀和。比丘尼求摩诃衍三拔致。是三昧学守者。当谦敬。不当嫉妒。不得嗔恚。去自贡高。去自贵大。却于懈怠。当精进弃于睡眠不得卧出。悉却财利。悉当净洁护。不得惜躯命。常当乐于经。当求多学。当弃淫恚痴。出魔罗网去。当弃所好服饰珠环。不得恶口。不得贪爱好钵震越。当为人所称誉不得有谀谄。学是三昧时。当敬善师视如佛。当承是经中教守是三昧。佛尔时颂偈言

  比丘尼行恭敬　　不妒嫉离嗔恚
  除憍慢去自大　　行是者得三昧
  当精进却睡卧　　捐所欲不贪寿
  一心慈于是法　　求三昧当如是
  无得听贪淫心　　弃嗔恚及愚痴
  莫得堕魔罗网　　求三昧当如是
  设有学是三昧　　无调戏舍贪身
  一切捐众狐疑　　当至诚不虚饰
  舍小慈常大慈　　敬善师无己已
  当去离于众恶　　求三昧当如是
  行求法欲得者　　不贪着钵震越
  从人闻尔三昧　　视如佛等无异

颰陀和菩萨白佛。若有白衣菩萨。居家修道。闻是三昧已欲学者。欲守者。当云何于法中立。学守是三昧。佛告颰陀和。白衣菩萨。闻是三昧已欲学守者。当持五戒坚净洁住。酒不得饮。亦不得饮他人。不得与女人交通。不得自为。亦不得教他人为。不得有恩爱于妻子。不得念男女。不得念财产。常念欲弃妻子。行作沙门。常持八关斋。斋时常当于佛寺斋。常当念布施不念我。当自得其福。当用万民故施。常当大慈于善师。见持戒比丘不得轻易说其恶。作是行已。当学当守是三昧。佛尔时颂偈言

  有居家菩萨　　欲得是三昧
  常当学究竟　　心无所贪慕
  诵是三昧时　　思乐作沙门
  不得贪妻子　　舍离于财色
  常奉持五戒　　一月八关斋
  斋时于佛寺　　学三昧通利
  不得说人恶　　无形轻慢行
  心无所荣冀　　当行是三昧
  奉敬诸经法　　常当乐于道
  心无有谄伪　　弃舍悭妒意
  有学是三昧　　常当行恭敬
  舍自大放逸　　奉事比丘僧

颰陀和菩萨白佛。若有优婆夷。求摩诃衍三拔致。闻是三昧已欲学守者。当行何等法学守是三昧。佛告颰陀和。若优婆夷。求摩诃衍三拔致。闻是三昧已欲学守者。当持五戒自归于三。何等为三自归于佛归命于法。归命于比丘僧。不得事余道。不得拜于天。不得示吉良日。不得调戏。不得慢恣。不得有贪心。优婆夷常当念布施。欢乐欲闻经。力多学问优婆夷常当敬重于善师。心常不倦不懈。若比丘比丘尼过者。常以坐席宾主饮食待之。佛尔时颂偈言

  若有优婆夷　　诵是三昧者
  当从佛法教　　奉五戒完具
  守是三昧时　　当尊敬于佛
  及法比丘众　　恭敬其善师
  不得事余道　　勿祠祀于天
  行是三昧者　　见人立迎逆
  除去杀盗淫　　至诚不两舌
  无得向酒家　　当行是三昧
  心不得怀贪　　常当念施与
  除去谀谄意　　无得说人短
  常当恭敬事　　比丘比丘尼
  闻法语悉受　　学三昧如是

    般舟经授决品第十

颰陀和菩萨问佛。少有及者天中天怛萨阿竭。乃说是三昧。诸菩萨所乐精进行。无有懈怠于阿耨多罗三藐三菩提。佛般泥洹后。是三昧者。当在阎浮利内不。佛告颰陀和菩萨。我般泥洹后。是三昧者当现在四十岁其后不复现。却后乱世佛经且欲断时。诸比丘不复承用佛教。然后乱世时。国国相伐。于是时是三昧当复现阎浮利内。用佛威神故。是三昧经复为出。颰陀和菩萨。罗邻那竭菩萨。从坐起正衣服。叉手于佛前白佛。佛般泥洹后乱世时。我曹共护是三昧。持是三昧。具足为人说之。闻是经卷无有厌极时。摩诃须萨和菩萨。憍曰兜菩萨。那罗达菩萨。须深菩萨因坻达菩萨。和轮调菩萨。共白佛言。佛般泥洹去。却后乱世时。是经卷者。我辈自共护持。使佛道久在。其有未闻者。我辈当共为说。教授是深经。世间少有信者。我曹悉受之。时五百人从坐起。比丘比丘尼。优婆塞优婆夷。皆叉手于佛前往白佛。佛般泥洹后乱世时。闻是三昧悉自持护愿持。我五百人嘱累是八菩萨。时佛笑。口中金色光出。至十方不可计佛国。悉照明还绕身三匝从头上入。阿难从坐起更被袈裟。前至佛所为佛作礼。却住叉手。以偈赞曰

  其心清净行无秽　　神通无极大变化
  已过诸碍超众智　　光明除冥去垢尘
  智慧无量心普解　　佛天中天鹖鸭音
  一切外道莫能动　　何缘而笑出妙光
  愿正真觉为解说　　慈愍一切众生尊
  若有闻佛柔濡音　　解释达圣化俗行
  世尊所感非唐举　　众圣导师不妄笑
  今者谁当在决中　　世雄愿为解此意
  今日谁住道德坚　　谁当逮得兴妙行
  谁今受得深法藏　　无上道德众所归
  今日谁当愍世间　　谁当奉受是法教
  谁坚立于佛智慧　　世尊愿为解说之

佛尔时为阿难说偈言

  佛语阿难汝见不　　五百人等在前立
  其心欢然歌颂曰　　我等亦当逮是法
  颜色和悦敬视佛　　我等何时得如是
  皆悉竦立嗟叹佛　　我辈会当逮如是
  五百人等今现在　　名字虽异本行同
  常乐奉受是深经　　于当来世亦复然
  今我嘱累告汝等　　佛慧无量知彼本
  是等不独见一佛　　亦不立此得其慧
  彻照彼之宿世命　　以曾更见八万佛
  五百人等存在道　　常解经义勉行成
  劝助无数诸菩萨　　常行慈哀护经法
  劝化一切众人民　　悉令逮得大道行
  知见过去诸世尊　　睹八十亿那术数
  名德普大脱于心　　拥护是法三转行
  现世于此受我教　　分布供养是舍利
  安谛受习佛所化　　皆悉讽诵有所付
  着于塔寺及山中　　若付天龙乾陀罗
  各各转授经卷已　　寿命终讫生天上
  天上寿尽还世间　　各各而生异种姓
  当复取此佛道行　　分别是经如所愿
  用爱乐斯经法故　　求辄得之持奉行
  令无数人得听闻　　欣踊难量心无等
  是等黠慧不厌法　　非贪躯体及寿命
  降伏一切诸外道　　授与经法弘其志
  是经法者无能得　　及持讽诵讲说者
  今四辈人住我前　　五百之众能堪持
  是八菩萨颰陀和　　罗邻那竭那罗达
  摩诃须萨和轮调　　因坻须深憍曰兜
  比丘及尼清信士　　奉玄妙法上义句
  常以经道哀世间　　宣畅方等普流化
  颰陀和等八菩萨　　于五百众为英雄
  常当奉持方等经　　于世之俗无所著
  释一切缚解空慧　　紫磨金色百福相
  恒行慈哀度众生　　施以安隐灭诸尘
  寿终之后生法家　　不复归于三恶道
  世世相随常和协　　然后逮得尊佛道
  已弃捐于八难处　　远离一切诸恶道
  其功德行莫能称　　所受福祐无能量
  当复值见弥勒佛　　咸同一心往自归
  悉共供养等慈哀　　逮于无上寂灭句
  其心佥然而和同　　正意奉事人中尊
  不猗俗事得法忍　　疾逮无上大道行
  彼常奉持此经法　　夙兴夜寐而讽诵
  殖众功德修梵行　　睹弥勒时义若此
  于是贤劫所兴佛　　慈哀世间放光明
  每所在处普持法　　奉事去来现在佛
  皆悉供养诸世雄　　见三世尊无众毒
  当疾逮得尊佛道　　不可思议无有量
  中有前得佛道者　　后人展转相供养
  不可计劫那术数　　如是终竟乃断绝
  于是居士颰陀和　　罗邻那竭那罗达
  及须萨和憍曰兜　　曾见诸佛如恒沙
  常当奉事正法化　　宣布诸佛无亿教
  道行无量不可称　　至于无数亿劫中
  假使有人受持名　　所周旋处若梦中
  如是勇猛导世间　　皆当逮得无上道
  若有睹见及闻声　　其心欣然踊跃者
  皆得佛道不复疑　　何况奉受供养者
  若嗔恚之及骂詈　　持恶意向挝捶者
  于是八人威神恩　　尚使得佛况恭敬
  彼所受法不可议　　名称无量及寿命
  光明无限德无疑　　智慧无量行亦然
  常得面见无量佛　　清净之戒如恒沙
  于是广普行布施　　以用求索无上道
  无数亿劫说其福　　莫能齐限厥功德
  受是经法诵习者　　逮于大道不复难
  其有爱乐此经卷　　受诵讽持讲说者
  当知五百人中人　　其心爱乐终不疑
  假使施得是经法　　爱乐道义加精进
  行清净戒除睡卧　　逮是三昧终不难
  欲获安隐布经戒　　比丘受学在闲居
  常行分卫知止足　　逮是三昧终不难
  舍离众闹不受请　　口莫贪味弃爱欲
  所从闻是经法者　　敬如世尊常供事
  除去悭贪受是法　　断绝淫欲弃愚痴
  发起大道心无疑　　然后学行是三昧
  行无所著舍诸欲　　常自谨慎弃恚恨
  精进奉行佛法教　　然后受学是三昧
  不贪男女及所有　　远离憍慢并妻妾
  居家修道常惭愧　　然后学诵是三昧
  无贼害心行柔顺　　不乐谤讪舍诸恶
  不用色求得法忍　　当善讽诵是三昧
  若比丘尼学是法　　常当恭敬弃憍慢
  远离调戏及贡高　　得是三昧不复难
  常行精进除睡卧　　不计吾我诸人物
  爱乐法者不惜命　　然后学诵是三昧
  制淫劮意舍所著　　无嗔恚心弃谀谄
  终不复堕魔罗网　　持是三昧得如是
  于诸众生行平等　　除去放逸众尘埃
  性无卒暴及粗言　　然后学诵是三昧
  于钵震越及衣服　　不得须臾有贪爱
  尊敬善师视如佛　　然后学诵是三昧
  以逮善利离恶道　　一心信乐佛法教
  远离一切八难处　　持是经者得如是

    般舟经拥护品第八

颰陀和菩萨。罗邻那竭菩萨。憍曰兜菩萨。那罗达菩萨。须深菩萨。摩诃须萨和菩萨。因坻达菩萨。和伦调菩萨。见佛所说。是八菩萨皆大欢喜。持五百劫波育锦衣。持珍宝布施。持身自归供养佛。佛语阿难。是颰陀和等。于五百菩萨人中之师。常持中正法。合会随顺教莫不欢喜者。欢乐心。随时心。清净心却欲心。是时五百人皆叉手立佛前颰陀和菩萨白佛言。菩萨持几事得是三昧。天中天。佛言。菩萨有四事疾得是三昧。何等为四。一者不信余道。二者断爱欲。三者如法行。四者无所贪生。是为四。菩萨疾得是三昧。佛告颰陀和。若有菩萨学是三昧者。若持若诵若守。今世即自得五百功德。譬如颰陀和慈心比丘终不中毒。终不中兵。火不能烧。入水不死。帝王不能得其便。如是菩萨守是三昧者。终不中毒。终不中兵。终不为火所烧。终不为水所没。终不为帝王得其便。譬如颰陀和劫尽坏烧时。持是三昧菩萨者。正使堕是火中火即为灭。譬如大罂水灭小火。佛告颰陀和。我所语无有异。是菩萨持是三昧者。若帝王若贼若水若火。若龙若蛇。若阅叉鬼神若猛兽若大蟒若蛟龙。若师子若虎若狼若狗。若人若非人。若[狂-王+加]玃。若薜荔。若鸠洹鬼神。若欲娆人。若欲杀人。若欲夺人钵震越。若坏人禅夺人念。设欲中是菩萨者终不能中。佛言。如我所语无有异除其宿命所请。其余无有能中者。佛言。我所语无有异若有菩萨持是三昧者。终不病目。若耳鼻口。身体无病。其心终不忧终不厄。是菩萨。若死若近死。设有是患者。佛语为有异。除其宿命所作。复次颰陀和。是菩萨诸天皆称誉。诸龙皆称誉。诸阅叉鬼神皆称誉。诸阿须轮皆称誉。迦留罗鬼神。真陀罗鬼神。摩睺勒鬼神。若人非人皆称誉是菩萨。诸佛天中天。皆称誉是菩萨。复次颰陀和。是菩萨为诸天所护。为诸龙所护。四天王。释提桓因。梵三钵天。皆护是菩萨。阅叉鬼神。乾陀罗鬼神。阿须伦鬼神。迦留罗鬼神。真陀罗鬼神。摩睺勒鬼神。若人非人。皆共拥护是菩萨。诸佛天中天。皆共拥护是菩萨。复次颰陀和。是菩萨为诸天所敬爱。诸龙阅叉鬼神。乾陀罗鬼神。阿须伦鬼神。迦留罗鬼神。真陀罗鬼神。摩睺勒鬼神。若人非人。皆共敬爱时菩萨。诸佛天中天。皆无有爱欲。以道德故皆复敬爱是菩萨。复次颰陀和。是菩萨诸天皆欲见之。诸龙阅叉鬼神。乾陀罗鬼神。阿须伦鬼神。迦留罗鬼神。真陀罗鬼神。摩睺勒鬼神。若人非人。皆思乐欲见是菩萨。诸佛天中天。皆各各欲使是菩萨往到其所。用人民故欲使往。复次颰陀和。是菩萨诸天皆来至其所。诸龙阅叉鬼神。乾陀罗鬼神。阿须轮鬼神。迦留罗鬼神。真陀罗鬼神。摩睺勒鬼神。若人非人。皆来至是菩萨所。与共相见。诸佛天中天。菩萨不但昼日见。夜于梦中。若见诸佛身。若诸佛各各自说其名字。复次颰陀和。是菩萨所未诵经。前所不闻经卷。是菩萨持是三昧威神。梦中悉自得其经卷名。各各悉见悉闻经声。若昼日不得者。若夜于梦中悉见得。佛告颰陀和。若一劫。若复过一劫。我说是菩萨持是三昧者。说其功德不可尽竟。何况力求得是三昧者。佛尔时颂偈言

  若有菩萨学诵是　　佛说三昧寂定义
  假使欲叹其功德　　譬如恒边减一沙
  刀刃矛戟不中伤　　盗贼怨家无能害
  国王大臣喜悦向　　学此三昧得如是
  蚖蛇含毒诚可畏　　见彼行者毒疾除
  不复嗔恚吐恶气　　诵是三昧得如是
  怨仇嫌隙莫能当　　天龙鬼神真陀罗
  睹其威光皆嘿然　　学此三昧得如是
  山野弊狼及大蟒　　师子猛虎鹿[狂-王+加]玃
  无伤害心摄藏毒　　悉来亲护是行者
  弊恶鬼神将人魂　　诸天人民怀害心
  感其威神自然伏　　学此三昧得如是
  其人不病无苦痛　　耳目聪明无闇塞
  言辞辩慧有殊杰　　行三昧者速逮是
  其人终不堕地狱　　离饿鬼道及畜生
  世世所生识宿命　　学此三昧得如是
  鬼神乾陀共拥护　　诸天人民亦如是
  并阿须伦摩睺勒　　行此三昧得如是
  诸天悉共颂其德　　天人龙鬼真陀罗
  诸佛嗟叹令如愿　　讽诵说经为人故
  其人道意不退转　　法慧之义而无尽
  姿颜美艳无与等　　诵习此经开化人
  国国相伐民荒乱　　饥馑荐臻怀苦穷
  终不于中夭其命　　能诵此经化人者
  勇猛降伏诸魔事　　心无所畏毛不竖
  其功德行不可议　　行此三昧得如是
  妖蛊幻化及符书　　秽浊邪道不正行
  终无有能中其身　　用爱乐法达本故
  一切悉共歌其德　　具足空慧佛尊子
  然后当来最末世　　手得是经得如是
  常行精进怀喜踊　　同心和悦奉此法
  受持经卷讲讽诵　　今我以是为彼说

    般舟经羼罗耶佛品第九

佛告颰陀和。乃往昔时不可计阿僧祇劫。尔时有佛名羼罗耶佛怛萨阿竭阿罗诃三耶三佛。于世间极尊。安定于世间。于经中大明。天上天下号曰天中天。尔时有长者子名须达。与二万人俱。来至羼罗耶佛所。为佛作礼却坐一面。须达长者子问羼罗耶佛是三昧。羼罗耶佛。知须达长者子心所念。便为说是三昧。须达长者子闻是三昧已大欢喜。即悉讽受得作沙门。求是三昧八万岁。时长者子须达。从佛闻经甚众多。悉从无央数佛闻经。其智慧甚高明。长者子须达。其后寿终生忉利天上。以后复从天上来下生世间。尔时故劫中复有佛。名术阇波提怛萨阿竭阿罗呵三耶三菩。时佛在刹利家生。尔时长者子须达。复于佛所闻是三昧复求之。时长者子须达。其后复于故劫中复有佛。名赖毗罗耶怛萨阿竭阿罗呵三耶三佛。婆罗门种。时长者子须达。复于佛所受是三昧。求守八万四千岁佛告颰陀和。长者子须达。却后八万劫得作佛。名提和竭罗。尔时长者子须达。为人高明勇猛智慧甚广。佛言。见是三昧不。颰陀和。饶益乃尔。使人成就得佛道。若有菩萨得是三昧者。当学诵当持当教人当守。如是者得佛不久。若曹知不颰陀和。是三昧者是菩萨眼。诸菩萨母。诸菩萨所归仰。诸菩萨所出生。若知不颰陀和。是三昧者破去于冥。明于天上天下。若知不。颰陀和。是菩萨三昧者。是诸佛之藏诸佛之地。是珍宝渊海之泉。是无量功德之镇益。明哲之经。当作是知三昧所出。如是从是中出佛。闻经正立于四意止中。何等为四意止中。一者自观身。观他人身。自观身观他人身者。本无身。二者自观痛痒。观他人痛痒。自观痛痒观他人痛痒者本无痛痒。三者自观意。观他人意。自观意观他人意者。本无意。四者自观法观他人法。自观法观他人法者。本无法。佛告颰陀和。是三昧谁当信者。独怛萨阿竭阿罗呵三耶三佛。阿惟越致。阿罗汉。乃信之耳。有愚痴迷惑心者。离是现在佛前立三昧远。何以故。是法当念佛当见佛。佛告颰陀和。是菩萨当念佛当见佛当闻经。不当有着。何以故。佛本无是法无所因。何以故。本空无所有。各各行法念。是法中无所取。是法无所著。如空等甚清净。是法人所想。了无所有。无所有。是法假所因者空寂耳如泥洹。是法无所有本无是法无所从来。亦无所从去。人本无。是法不著者近。有著者远。佛告颰陀和。若有守是三昧者。因想入无想中。见佛念佛。守觉闻经念法。守觉不得念我。不得着法。何以故。有守觉。颰陀和有守觉不见佛。有所著如毛发不得法。施他人有所悕望为不施。持戒有所悕望为不净。贪于法不得泥洹。于经中有谀谄。不得为高明。乐于众会中。喜于余道。终不能得一行。于欲中念难。有嗔恚不能忍辱。有所憎恶不得说他人。善求阿罗汉道者。不得于是见。现在佛悉在前立三昧中不逮。无所从来。生法乐于中立。有所著不得空。菩萨终不得悭贪有懈怠不得道。有淫劮不入观。有所念不入三昧。佛尔时颂偈言

  是等功德不可计　　奉戒具足无瑕秽
  其心清净离垢尘　　行此三昧得如是
  设有持是三昧者　　智慧普大无缺减
  博达众义常不忘　　功德之行如月明
  设有持是三昧者　　解了觉意不可识
  晓知无量之道法　　无数诸天护其德
  设有持是三昧者　　常自面见无数佛
  闻无量佛讲说法　　辄能受持念普行
  设有持是三昧者　　恶罪勤苦皆灭除
  诸佛于世行愍哀　　悉共嗟叹是菩萨
  假使菩萨欲睹见　　当来无数佛世尊
  一心踊跃住正法　　当学讽诵是三昧
  其有持是三昧者　　其功德福不可议
  逮得人身最第一　　出家超异行分卫
  若有末后得是经　　逮功德利最第一
  得其福祐不可限　　住是三昧得如是

般舟三昧经卷中般舟三昧经卷下

        后汉月氏三藏支娄迦谶译

    请佛品第十

跋陀和菩萨政衣服。长跪叉手白佛言。我欲请佛及比丘僧。明日于舍食。愿佛哀受请。佛及比丘僧默然悉受请。跋陀和菩萨知佛已受请。起至摩诃波喻提比丘尼所。白比丘尼言。愿受我请。明日与比丘尼俱。于舍小饭。摩诃波喻提比丘尼即受请。跋陀和菩萨。语罗邻那竭菩萨。舍第。诸郡国其有新来人。悉请会佛所。罗邻那竭菩萨前至佛所。为佛作礼。长跪叉手白佛言。我兄请佛。所有新来人。悉欲请于舍食。愿哀受之。跋陀和菩萨。罗邻那竭菩萨。憍曰兜菩萨。那罗达菩萨。须深菩萨。摩诃须萨和菩萨。因坻达菩萨。和伦调菩萨。悉与宗亲俱。前以头面着佛足。及为比丘僧作礼。作礼已。竟从佛所去。归到罗阅只国。至跋陀和菩萨家。共相佐助作诸饭具。四天王。释提桓因。梵三钵。皆共疾来。佐助跋陀和菩萨作众饭具。尔时跋陀和菩萨。宗亲共庄严罗阅只国。持若干种杂缯帐。覆一国中。其街巷市里皆悬缯幡举一国中悉散华烧香。作百种味饭具用佛故。比丘僧比丘尼。优婆塞优婆夷。及诸贫穷乞丐者。其饭具适等。何以故。不有偏施于人民及蜎飞蠕动之类悉平等。跋陀和与八菩萨。与诸宗亲。以饭时俱往诣佛前。以头面着佛足。却白佛言。饭食具以办。愿佛可行。时佛与比丘僧。皆着衣持钵。俱诣来会者。皆随行佛入罗阅只国中。到跋陀和菩萨家。跋陀和菩萨作是念。今佛威神故。令我舍极广大。悉作琉璃。表里悉相见。城外悉见我舍中。我舍中悉见城外。佛即知跋陀和心所念。佛便放威神。令跋陀和舍极广大。举一国中人民。悉见于舍中。佛前入跋陀和菩萨家坐。比丘僧比丘尼。优婆塞优婆夷。各各异部悉坐于舍中。跋陀和菩萨见佛比丘僧坐已。自供养佛比丘僧。若干百种饭手自斟酌。佛及比丘比丘尼。优婆塞优婆夷。皆已乃饭。诸贫穷者悉等与。悉各平足。皆持佛威神恩使之足。跋陀和菩萨。见佛诸弟子悉饭已。前行澡水。毕竟持一小机。于佛前坐听经。为跋陀和菩萨及四辈弟子说经。莫不欢喜者。莫不乐闻者。莫不欲闻者。佛以经请比丘僧及诸弟子。佛起与比丘僧俱去。跋陀和菩萨饭已。与宗亲俱。出罗阅只国到佛所。前为佛作礼。皆却坐一面。及罗邻那竭菩萨。桥曰兜菩萨。那罗达菩萨。须深菩萨。摩诃须萨和菩萨。因坻达菩萨。和伦调菩萨。跋陀和菩萨。见人众皆安坐已前问佛。菩萨用几事得见现在佛悉在前立三昧。佛告跋陀和菩萨。菩萨有五事。疾得见现在佛悉在前立三昧。学持谛行心不转。何等为五。一者乐于深经无有尽时不可得极。悉脱于众灾变去。以脱诸垢中。以去冥入明。诸蒙眬悉消尽。佛告跋陀和。是菩萨逮得无所从来生法乐。逮得是三昧。复次跋陀和。不复乐所向生。是为二不复乐喜于余道。是为三。不复乐于爱欲中。是为四。自守行无有极。是为五。菩萨复有五事。疾得是三昧。何等为五。一者布施心不得悔。无所贪。无所惜。从是不得有所悕望。施人已后不复恨复次跋陀和。菩萨持经布施。为他人说经。所语者安谛。无有疑无所爱惜。说佛深语身自行立是中。复次跋陀和。菩萨不嫉妒。所作无有疑。却睡卧。却五所欲。不自说身善。亦不说他人恶。若有骂者。若有刑者。亦不得恚。亦不得恨。亦不得懈。何以故。入空行故。复次跋陀和。菩萨是三昧自学复教他人。书是经着好疋素上使久在。复次跋陀和。菩萨所信多乐。敬长老及知识。于新学人若得所施。当念报恩。常有识信。受人小施念报大。何况于多者。菩萨常乐重于经。弃捐无反复之意。常念有反复。如是者得三昧疾。佛尔时颂偈言

  常爱乐法在深解　　于诸习欲不贪生
  游步五道无所著　　如是行者得三昧
  好喜布施不想报　　所惠无著不追念
  所与不见有受者　　唯欲得解佛深慧
  愍伤众生行布施　　其心喜踊不悔恨
  常立布施及戒忍　　精进一心智慧事
  具足六度摄一切　　慈悲喜护四等心
  善权方便济众生　　如是行者得三昧
  若有兴施除悭贪　　其心欢踊而授与
  既施之后恒欣喜　　如是行者得三昧
  晓知经法分别句　　闻深要义佛所教
  讲说微妙道德化　　如是行者得三昧
  其人学诵是三昧　　具足解慧为人说
  令此经法得永存　　如是行者得三昧
  常不秘奥佛经法　　不望供养乃为讲
  唯求安隐佛道地　　如是行者得三昧
  除去所著弃诸盖　　捐去贡高及慢大
  不自称誉说彼短　　终不复起吾我想
  其有寂定意不起　　便能解是道定慧
  弃捐谀谄心清净　　用是速逮不起忍
  常行至诚无绮饰　　其愿具足无缺减
  殖众正德无邪行　　爱乐法者得道疾
  所诵习经常不忘　　常护禁戒清净行
  如是行者得佛疾　　何况奉是寂三昧

佛告跋陀和菩萨。往昔无数劫。提和竭罗佛时。我于提和竭罗佛所。闻是三昧即受持是三昧。见十方无央数佛。悉从闻经悉受持。尔时诸佛悉语我言。却后无央数劫。汝当作佛名释迦文。佛告跋陀和菩萨。我故语汝。今自致作佛。是三昧若曹当学。为知内法第一众所不能及。出众想去。其有于是三昧中立者。念得佛道。佛尔时颂偈言

  忆念我昔定光佛　　于时逮得是三昧
  即见十方无数佛　　闻说尊法深妙义
  譬有德人行采宝　　所望如愿辄得之
  菩萨大士亦如是　　经中求宝即得佛

跋陀和菩萨白佛。当云何守是三昧。天中天。佛告跋陀和菩萨。色不当着。不当有所向生。当行空。是三昧当守。何等为三昧。当随是法行。复次跋陀和。菩萨自观身无身。亦无所观。亦无所见。亦无所著。本亦无所盲。亦无所聋。如经中法。视住亦无所见。亦无所著。无所著为守道者。于法中无所疑。不疑者为见佛。见佛者为疑断。诸法无所从来生。何以故。菩萨有法疑想便为着。何等为着。有人有寿命有德有阴有人有对有想有根有欲。是为着。何以故。菩萨见诸法无所著。是法亦不念亦不见。何等为不见。譬如愚人学余道自用。有人谓有身。菩萨不作是见。菩萨何等为见。譬如怛萨阿竭阿罗诃三耶三佛。阿惟越致。辟支佛。阿罗汉所见。不喜不忧。菩萨如是见。亦不喜亦不忧。守是三昧者。亦不喜亦不忧。譬如虚空。无色无想。清净无瑕秽。菩萨见诸法如是。眼无所挂碍见诸法。用是故见诸佛。见诸佛如以明月珠持着琉璃上。如日初出时。如月十五日在众星中央时。如遮迦越王与诸群臣相随时。如忉利天王释提桓因在诸天中央时。如梵天王在众梵天中央最高坐。如炬火在高山顶烧。如医王持药行愈人病。如师子出独步。如众野雁飞行虚空中前有导。如冬月高山上积雪四面皆见。如天地大界金刚山却臭秽。如下水持地。如风持水。诸秽浊悉清净。如虚空等。如须弥山上忉利天为庄严。诸佛如是。佛持戒。佛威神佛功德。无央数国土悉极明。是菩萨见十方佛如是。闻经悉受得佛尔时颂偈言

  佛无垢秽离尘劳　　功德众竟无所著
  尊大神通妙音声　　法鼓导义喻诸音
  觉天中天脱诸慧　　种种香华以供养
  以无数德奉舍利　　幡盖杂香求三昧
  闻法普妙学具足　　远离颠倒喻灭度
  终不想着于空法　　当志解妙无碍慧
  清净如月日出光　　譬如梵天立本宫
  常清净心念世尊　　意无所著不相空
  譬如冬月高山雪　　若如国王人中尊
  摩尼清净超众宝　　观佛相好当如是
  如雁王飞前有导　　虚空清净无秽乱
  紫磨金色佛如是　　佛子念此供养尊
  去诸幽冥除闇愚　　即悉速逮净三昧
  捐舍一切诸想求　　无垢秽行得定意
  无有尘劳释垢秽　　弃去嗔恚无愚痴
  其目清净自然明　　念佛功德无挂碍
  思佛世尊清净戒　　心无所著不相求
  不见吾我及所有　　亦不起在诸色相
  舍离生死无众见　　弃舍贡高慧清净
  远除憍慢不自大　　闻寂三昧离邪见
  其有比丘佛子孙　　信比丘尼清信士
  除去贪欲清信女　　念精进学得是法

    无想品第十一

佛告跋陀和菩萨。若有菩萨。欲学是三昧疾得是。当先断色思想。当弃自贡高。已断思想。已不自贡高。已却当学是三昧。不当诤。何等为诤。诽谤于空是故不当共诤。不当诽谤空。却诵是三昧。佛告跋陀和。若有菩萨学诵是三昧者。有十事于其中立。何等为十。一者其有他人。若馈遗钵震越衣服者不嫉妒。二者悉当爱敬人孝顺于长老。三者当有反复念报恩。四者不妄语远离非法。五者常行乞食不受请。六者当精进经行。七者昼夜不得卧出。八者常欲布施天上天下。无所惜终不悔。九者深入慧中无所著。十者先当敬事善师视如佛。乃当却诵是三昧。是为十事。当如法。作是行者便得八事。何等为八事。一者于戒清净至究竟。二者不与余道从事。出入智慧中。三者于智慧中清净。无所复贪生。四者眼清净。不复欲生死。五者高明无所著。六者清净于精进自致得佛。七者若有人供养者不用故喜。八者正在阿耨多罗三藐三菩提不复动。是为八事。佛尔时颂偈言

  有黠慧者不起想　　弃捐贡高及自大
  常行忍辱无粗漏　　尔乃为学是三昧
  智者心明不诤空　　无想寂定是灭度
  不诽谤法莫诤佛　　如是行者得三昧
  明者于是无憍慢　　常念佛恩及法师
  坚住净信志不动　　尔时为学是三昧
  心不怀嫉远窈冥　　不起狐疑常有信
  当行精进不懈怠　　如是行者得三昧
  比丘学是常分卫　　不行就请及聚会
  心无所著不畜积　　如是行者得三昧
  设使手得斯法教　　及持奉行此经卷
  已具足意得如佛　　然后学诵是三昧
  住是至德行诚信　　设有学诵三昧者
  速逮疾得是八法　　清净无垢诸佛教
  其清净戒有究竟　　三昧无瑕得等见
  以为空净于生死　　住于是法得具足
  智慧清净无有余　　无秽行者亦不着
  博闻采智舍唐捐　　得行如是为黠慧
  志精进者无所失　　于供养利而不贪
  疾得无上成佛道　　学如是德为明智

    十八不共十种力品第十二

佛言。得是上八事者。便获佛十八事。何等为十八事。一者用某日得佛。用某日般泥洹。从初得佛日。至般泥洹日佛无难。二者无短。三者无忘。四者无不定时。五者终无生法想言我所。六者无有不能忍时。七者无有不乐时。八者无有不精进时。九者无有不念时。十者无有不三昧时。十一者无有不知时。十二者无有不脱见慧时。十三者过去无央数世事无有能止佛无所挂碍所见慧时。十四者当来无央数世事无有能止佛无所挂碍所见慧时。十五者今现在十方无央数世事无有能止佛无所挂碍所见慧时。十六者身所行事智慧。是本常与智慧俱。十七者口所言事智慧。是本常与智慧俱。十八者心所念事智慧。是本常与智慧俱。是为佛十八事。佛告跋陀和。若有菩萨。无所复着。求法悉护学是三昧者有十法护。何等为十法护佛十种力。何等为十种力一者有限无限悉知。二者过去当来今现在本末悉知。三者弃脱定清净悉知。四者诸根精进种种各异所念悉知。五者种种所信悉知。六者若干种变无央数事悉知。七者悉晓悉了悉知。八者眼所视无所挂碍悉知。九者本末无极悉知。十者过去当来今现在悉平等无所适着。佛告跋陀和。若有菩萨。无所从生法悉护。是菩萨得佛十种力。佛尔时颂偈言

  十八不共正觉法　　世尊之力现有十
  设使奉行是三昧　　疾速逮此终不久

    劝助品第十三

佛告跋陀和。是菩萨持有四事。于是三昧中助其欢喜。过去佛时持是三昧助欢喜。学是经者自致阿耨多罗三耶三菩阿惟三佛。其智悉具足。我助欢喜如是。复次跋陀和。当来诸佛。求菩萨道者。于是三昧中助欢喜。学是三昧者自致阿耨多罗三耶三菩阿惟三佛。其智悉具足。其皆助欢喜如是。复次跋陀和。今现在十方无央数佛。本求菩萨道时。于是三昧中者助欢喜。学是三昧者自致得阿耨多罗三耶三菩阿惟三佛。其智悉具足。其皆助欢喜福。令其与十方人民。及蜎飞蠕动之类。共得阿耨多罗三耶三菩阿惟三佛。持是三昧助欢喜功德令其疾得是三昧。作阿耨多罗三耶三菩阿惟三佛得不久。佛告跋陀和。是菩萨功德。于是三昧中四事助欢喜。我于是中说少所譬喻。譬如人寿百岁堕地行。至百岁无有休息时。其人行使过疾风。周匝四方上下。云何跋陀和。宁有能计其道里者不。跋陀和言。无有能计其道里者。天中天。独佛弟子舍利弗罗阿惟越致菩萨。乃能计之耳。佛告跋陀和。我故语诸菩萨。若有善男子善女人。取是四方上下诸国土。其人所行处。满中珍宝布施与佛。不如闻是三昧。若有菩萨闻是三昧。于是四事中助欢喜。其福出过布施佛者。百倍千倍万倍亿倍。若见不。跋陀和。是菩萨助欢喜。其福宁多不。用是故当知之。是菩萨助欢喜。其福甚尊大。佛尔时颂偈言

  于是经教中　　持有四事欢
  过去及当来　　现在诸世尊
  劝助功德行　　度脱诸十方
  蜎飞之蠕动　　悉逮平等觉
  譬如此周匝　　四方及上下
  人生行百岁　　尽寿行不息
  欲有计道里　　其数难度量
  独佛弟子知　　不退转菩萨
  满中珍宝施　　不如闻是法
  四事之劝助　　其福出彼上
  跋陀且观是　　四事之欢喜
  布施亿万倍　　不与劝化等

    师子意佛品第十四

佛尔时告跋陀和。乃去久远世时。其劫阿僧祇。不可计不可数不可量不可极阿僧祇。乃尔时有佛。名私诃摩提。怛萨阿竭阿罗诃三耶三佛。其威神无有与等者。安隐于世间。于经中之尊。天上天下。号曰天中天。于是国土空闲之处。是阎浮利国土丰熟人民炽盛乐。是时阎浮利内。广纵十八万拘利那术踰旬。是时阎浮利内。凡有六百四十万国。尔时阎浮利有大国名跋登加。其国中有六十亿人。私诃摩提佛在是国中。有遮迦越王名惟斯芩王。往到私诃摩提佛所。为佛作礼却坐一面。时私诃摩提佛。即知其王心所念。便为说是三昧其王闻是三昧助欢喜。即时珍宝散佛上。其心即念。持是功德令十方人民皆安隐。时私诃摩提佛般泥洹后。惟斯芩遮迦越王。其寿终已后。还生王家作太子。名梵摩达。尔时阎浮提有比丘高明名珍宝。是时为四部弟子。比丘比丘尼优婆塞优婆夷。说是三昧。梵摩达太子。闻是三昧助欢喜心。踊跃乐喜闻是经。持珍宝直百亿。散是比丘上。复持好衣供养之。以发意求佛道。时与千人俱。于是比丘所剃头须作沙门。即于是比丘所从索学是三昧。与千比丘共。承事师八千岁不休懈前后一反得闻是三昧。是比丘辈闻是三昧四事。助欢喜入高明之智。持是助欢喜功德。却后更见六万八千佛。辄于一一佛所闻是三昧。自守学复教他人学。其人持是助欢喜功德。其后得作佛。名坻罗惟是逮怛萨阿竭阿罗诃三耶三佛。时是千比丘。从得阿耨多罗三耶三菩阿惟三佛。皆名坻罗首罗郁沈怛萨阿竭阿罗诃三耶三佛。教不可计人民皆求佛道。佛告跋陀和。何人闻是三昧不助欢喜者。何人不学者。何人不为他人说者。何人不守者。佛告跋陀和。若有菩萨。守是三昧者疾逮得佛。跋陀和。若有菩萨在四十里外。闻有持是三昧者。菩萨闻之便当行求往到其所。但得闻知有是三昧常当求之。何况乃得闻学者。若去百里者。若远四千里。闻有持是三昧者。当行学到其所。但得闻知。何况乃得闻学者。佛言。去人远者常当自行求。何况去人十里二十里。闻有持是三昧者。不行求学。跋陀和。若有菩萨。闻是三昧欲行至彼。闻求是三昧者。当承事其师十岁百岁。悉具足供养占视是菩萨不得自用。当随其师教。常当念师恩。佛言。我故相为说之。若菩萨闻有是三昧处去四千里者。欲往到其所。设不得闻是三昧者。佛言。我告若曹。其人用精进行求故。终不复失佛道。会自致作佛见不。跋陀和。菩萨闻是三昧念欲求不离。其得利甚尊。佛尔时颂偈言

  我念过去有如来　　人中尊号私诃末
  尔时有王典主人　　至于彼佛闻三昧
  至意黠慧听此经　　心悦无量奉持法
  即以珍宝散其上　　供师子意人中尊
  心念如是而叹言　　我身于此当来世
  奉行佛教不敢缺　　亦当逮得是三昧
  用是福愿寿终后　　辄复来还生王家
  尔时见尊大比丘　　号曰珍宝智博达
  应时从闻是三昧　　踊跃欢喜即受持
  供以好物若千亿　　珍宝妙衣用道故
  即与千人除须发　　来志乐求是三昧
  同时具足八千岁　　常随比丘不舍离
  一反得闻不复二　　是三昧者譬如海
  执持经卷讽诵说　　其所生处闻三昧
  用积累是功德故　　当见诸佛大神通
  其所具足八万岁　　所见诸佛辄供养
  曾值诸佛六万亿　　加复供养六千尊
  闻所说法大欢喜　　然后得见师子佛
  蒙此功德生王家　　见佛号曰坚精进
  化无数亿诸人民　　度脱一切生死恼
  讽诵学是法以后　　便复见佛名坚勇
  天上世间诵其称　　闻三昧声得作佛
  何况受持诵说者　　于众世界无所著
  广宣分流是三昧　　未曾疑忘于佛道
  此三昧经真佛语　　设闻远方有是经
  用道法故往听受　　一心讽诵不忘舍
  假使往求不得闻　　其功德福不可尽
  无能称量其德义　　何况闻已即受持
  设有欲求是三昧　　当念往时彼梵达
  教习奉行莫退转　　比丘得经当如是

    至诚佛品第十五

佛言。乃往昔时复有佛。名萨遮那摩怛萨阿竭阿罗诃三耶三佛。时有比丘名和轮。其佛般泥洹后。是比丘持是三昧。我尔时作国王刹利种。于梦中闻是三昧。觉已便行求持是三昧。比丘即从作沙门。欲得于是比丘所一反闻是三昧。承事师三万六千岁。魔事数数起不得一反闻。佛告比丘比丘尼优婆塞优婆夷。我故语若曹。若曹当疾取是三昧无得忘失。善承事其师持是三昧。至一劫若百劫若千劫莫得有懈惓趣当得是三昧。守善师不离。若饮食资用衣被床卧。千万珍宝以用上师。供养于师无所爱惜。设无有者当行乞食给师。趣当得是三昧莫厌。佛言。置是所供养者此不足言耳。常当自割其肌供养于善师常不爱惜身。何况其余。当承事善师如奴事大夫。求是三昧者当知是。得是三昧已当坚持。常当念师恩。佛言。是三昧难得值。正使求是三昧至百亿劫。但欲得闻其名声不能得闻。何况得学者。转复行教人。正使如恒边沙佛刹。满其中珍宝持用布施。其福宁多不。不如书是三昧持经卷者。其福极不可计。佛尔时颂偈言

  我自识念往世时　　其数具足六万岁
  常随法师不舍离　　初不得闻是三昧
  有佛号曰其至诚　　时知比丘名和轮
  彼佛世尊泥曰后　　比丘常持是三昧
  我时为王君子种　　梦中逮闻是三昧
  和轮比丘有斯经　　王当从受此定意
  从梦觉已即往求　　辄见比丘持三昧
  即除须发作沙门　　学八千岁一时闻
  其数具足八万岁　　供养奉事此比丘
  时魔因缘数兴起　　初未曾得一反闻
  是故比丘比丘尼　　及清信士清信女
  持是经法嘱汝等　　闻是三昧疾受行
  常敬习持是法师　　具足一劫无得懈
  勿难千亿用道故　　当得闻是法三昧
  衣服床卧若千亿　　比丘家家行乞食
  以用供养于法师　　精进如是得三昧
  灯火饮食所当得　　金银珍宝供养具
  尚当自割其肌肉　　以用供养况饮食
  明者得法疾持行　　受学经卷有反复
  是三昧者难得值　　亿那术劫常当求
  所周旋处闻是法　　当普宣视诸学者
  假使亿千那术劫　　求是三昧难得闻
  设令世界如恒沙　　满中珍宝用布施
  若有受是一偈说　　敬诵功德过于彼

    佛印品第十六

佛于是语跋陀和。若有菩萨闻是三昧。闻者当助欢喜当学。得学者持佛威神使得学。当好书是三昧着素上。当得佛印印当善供养。何等为佛印。所识不当行。无所贪。无所求。无所想。无所著。无所愿。无所向生。无所适。无所生。无所有。无所取。无所顾。无所往。无所碍。无所有。无所结。所有尽。所欲尽。无所从生。无所灭。无所坏。无所败。道要道本是印中。阿罗汉辟支佛。不能坏不能败不能缺。愚痴者便疑是印。是印是为佛印。佛言。今我说是三昧时千八百亿诸天阿须轮鬼神龙人民。皆得须陀洹道。八百比丘皆得阿罗汉道。五百比丘尼皆得阿罗汉道。万菩萨皆逮得是三昧。皆逮得无所从生法乐。于中立。万二千菩萨不复还。佛语舍利弗罗摩目犍连。比丘阿难。跋陀和菩萨。罗邻那竭菩萨。憍曰兜菩萨。那罗达菩萨。须深菩萨。摩诃须萨和菩萨。因坻达菩萨。和轮调菩萨。佛言。我从无央数劫求佛道以来。今以得作佛。持是经嘱累若曹学诵持守无得忘失。若有跋陀和菩萨学是三昧者。当具足安谛学。其欲闻者当具闻。为他人说者当具说。佛说经已。跋陀和菩萨等。舍利弗罗摩目犍连。比丘阿难等。诸天阿须轮龙鬼神人民。皆大欢喜。前为佛作礼而去

般舟三昧经卷下


宝女所问经

    No. 399 [No. 397(3)]

宝女所问经卷第一

        西晋月氏三藏竺法护译

    问慧品第一

闻如是。一时佛游于如来宝净高座。则为如来之所建立。积无极德已为庄严。所游道场。佛慧报应蠲除所行。升菩萨宫讲无量颂。如来所叹显立威变。圣导无碍普有所入。志存微妙诱进权行。等过去慧于当来劫弘大究竟。其德无量。顺平等觉善转法轮。无限之首谛分别慧。于一切法而得自在。悉睹众生心之诸根。度于彼岸。晓了方便断除诸着邪业之行。为造佛事。莫不笃信化令寂定。与大比丘俱六百万。其心调和。消除挂碍尘劳之欲。乃为如来法王之子。修深妙法兴发道化。无有颠倒威仪显曜。成就圣路为大众祐。如来安详获善究竟。复与菩萨大圣众俱。无量无限不可思惟浩浩大会行无所拘。诸菩萨等斯须之间。寻能超越无量佛国。便设权宜供养奉事十方如来。有所咨启听受经典。不以厌倦。而常精勤劝化众生。智慧善权以用超殊。至于彼岸。得度无极而以建立无碍脱门。便得超越一切众想望报罗网。近一切智诸通之慧

其名曰明天菩萨。选游步菩萨。择战斗菩萨。照明藏菩萨。蠲慢意菩萨。踊步菩萨。眼观菩萨。雷音菩萨。离冥菩萨。如是等类诸菩萨众不可限量。无边无际不可引喻

尔时世尊叹咏菩萨所生道场。其法名曰无阴盖辞。一切菩萨径路清净。诸佛之法力无所畏。具足究竟圣慧之事。于诸法典而得自由。总持之门。所入法印敢可遭遇。决众法门圣通无极。超入于慧不退转轮。说不回还。诸乘平等所导无二。游无所坏一品法界。而分别说众生心根所入之慧。独步坚强决了诸法。灭除一切诸魔之场。已度众患随应顺法。律化众尘诸邪之见。入无限慧方便劝助。行无边际咨嗟权慧。十方诸佛所共宣畅。达无希望行无挂碍无处之门。分流兴隆一切诸法。决了如应而等普入。有想无想体解圣达。游于深妙缘起之事。显明道业无极德慧。佛身口意而以庄严。于此三事心行所归智慧无尽。越诸圣谛坏声闻乘。身心澹泊开演明哲。教化缘觉致诸通慧。导利大乘入于道品。于一切法而得信忍。宣扬如来所因兴德。讲说分别诵读宣现。智慧教授。开示流布靡不周遍

尔时世尊讲说于斯善慧法典。宣弘普诵。时众会中有一女人。名曰宝女。即从坐起。右手执持妙珠璎珞白世尊曰唯然大圣。如我所言至诚不虚。设此众会佛所说法大士所讲。吾能具足持斯经典。普于十方流布弘广。劝无量人。于此法宝建立无上正真之道。如是所誓不改易者。如来威神使斯贯珠显示圣旨。于时世尊。因众现变。令诸菩萨。皆于其上。化成棚阁珠交露帐。斯诸正士。然后来世成正觉时。如其佛土微妙严净佛道场树。当使于今现此瑞应。众宝棚阁珠交露帐令斯会者睹其严净悉皆悦豫。于时宝女。前诣佛所则散珠璎。散珠璎已。佛之威神。宝女之德誓愿至诚。在于佛上及诸菩萨上虚空中。化成棚阁珠交露帐。辟方弘广。若干种变奇特殊妙。周匝平等庄严校饰。分布安处正无倾斜。时诸菩萨各心念言。如我等身本往古时志所誓愿。当令吾等佛土严净。道场觉树亦复如是。斯诸菩萨如心所念。各各自见交露棚阁。适睹此已怪未曾有。前白佛言。甚为难及。天中之天。其宝女者所建立力。能为我等显现瑞应。无央数劫所发志愿。今此宝女。一心念顷悉令现矣。世尊告曰。如是正士。如汝所言。宝女发意如志所建。行道以来于六十二百千亿垓诸佛之所。殖众德本。乃致若兹至诚所建真实誓愿。以是之故。今斯宝女如其所誓。被德之铠寻使成立。诸正士等。又宝女者设欲志愿。于斯三千大千世界。普雨天华悉令周满。则如所言辄雨名香捣香泽香杂香衣服膳馔。设复欲令幢盖缯幡自然庄饰周遍虚空。寻如意成。若复欲令天地水灾自然兴者。若复火灾则如所言。便有水灾自然火灾。设复欲令水灾火灾蠲除。还复如其所言悉能致之。设欲令此一切众会。悉自然变形体被服如转轮王。寻悉能成。为四天王形体被服。天帝形像。梵天颜貌。大神妙姿容之像。比丘比丘尼清信士清信女色像颜貌。则如所言悉能成之。正使欲令变怪现化亿百千魔。一一魔者手各执持百种刀杖。令此众魔坚住不动。不设刀杖悉使化成若干品种诸珠璎珞。须缦众华思夷之华。皆辄如言。若复欲令玄绝旷野。自然变有饮食衣被。为大城郭。十八亿家游居其中。如其所言皆能致之。三千世界所有形像。欲令颜貌皆成如来。寻辄如志。若复欲令一切众会处在虚空。悉当如言。诸族姓子。斯宝女身欲令无量无限无有边际佛之境界。诸佛世尊所说经典。于虚空中皆为通达。具足众备普闻音声。如佛所言无有缺减。十方佛辞亦如所说但能宣畅。于是宝女。立愿之力神足变化。普示现之如此色像。则于佛前说是颂曰

  以宝为业　　执妙圣珍　　演说豪尊
  无量道德　　则以蠲除　　尘欲嗔结
  乃布惠施　　七觉之宝　　以宝光明
  照众窈冥　　若干品类　　明月珠曜
  尊上琦珍　　宝英最胜　　今以瑰珠
  恭奉安住　　假使玛瑙　　首藏明珠
  焰光之珠　　无垢藏珠　　日月之明
  所出光晖　　蒙尊所照　　而悉覆蔽
  观能仁身　　无能限量　　所荷之祐
  致获十力　　住立斯土　　极至上界
  观察圣体　　转显加倍　　一切众会
  各各见佛　　悉自念言　　尊在我前
  皆从方面　　悉见佛颜　　紫金纵容
  无比之貌　　正使坐时　　卧寐经行
  若复现在　　处众会中　　言辞若嘿
  乐立禅定　　威仪无比　　圣智无限
  一一毛孔　　所演光晖　　则能普照
  一切十方　　身如莲华　　最胜弘满
  犹如志性　　令意寂然　　常立诚谛
  所云真实　　如口所言　　尊行相应
  晓了分别　　诸法之谊　　稽首道备
  得度彼岸

尔时宝女以此颂偈赞佛德已。白世尊曰。我身今欲咨问如来。于斯经典章品之句志所趣向。设见听者乃当自陈。佛告女曰。恣所欲问。吾当为汝分别说之令心悦豫。于时宝女见佛听之欢喜踊跃。白世尊曰。何谓菩萨常怀至诚。云何如来为诸菩萨说真实辞。何谓菩萨而应顺法。云何如来为诸菩萨讲说经典。何谓菩萨寻应威仪。云何如来为诸菩萨而说议趣。何谓菩萨奉顺律教。云何如来为诸菩萨讲决律事

佛言。善哉善哉。宝女所问。欲畅仁贤真要辩才。谛听谛听善思念之。唯然世尊。愿乐欲闻。于时宝女受教而听。佛告宝女。菩萨有三法常怀至诚。何谓为三。未曾欺佛。不自欺身。亦不欺诳一切众生。何谓菩萨欺于诸佛而欺己身及与众生。假使菩萨兴发无上正真道意。志慕声闻缘觉之地。而誓求愿意甘乐之。是为菩萨欺佛己身及与众生。何谓菩萨不欺诸佛己身众生。假使菩萨发大道意。设令勤苦遭众恼患为诸众魔所见娆试。为诸外道所见逼迫。毁辱诽谤而戏弄之。百种骂詈挝捶危害虚妄之事而以加己。志性寂然不起怨结。不怀怯弱不成迷误。不恐不畏不以忧戚不以为恨。续秉一志志性坚强。平等之行不舍道意但执惠心珍宝之心。常怀道心。一切世间最尊第一。又复发心为诸众生。救护归命令得超度。所兴之心而无等伦无以为喻。不退不舍不在余乘。常立一志乐于佛道。导御法轮。令诸群萌悉得面见。现于诸力兴显如是。行步举动遵修精进。终不破坏他人言教。是为菩萨不欺诸佛不自欺身亦不侵欺一切众生。假使菩萨不欺诸佛不自欺己不诳众生。是为菩萨第一至诚。彼以四事不欺诸佛顺于坚固。而应威施。所为力强。精进殷勤。复以四事不自欺身。志性仁和。质直其心。无有谀谄。亦无虚訑。彼以四事不欺众生。方便应病。慈心愍哀。加以四恩。是为菩萨第一至诚。不舍道心而不违失往古之愿。佛复告宝女曰。菩萨至诚。谓口寂然护于言语。所说无缺口辞真谛。在于独处若大众中。言常至诚。不以国故而两舌也。不以珍宝具足货业而欺虚言。不以父母亲族贪财惜费而两舌也。佛语宝女。有三十二事口辞清净。何谓三十二。羞惭(一)。造德(二)。常怀耻愧(三)。等修于善(四)。不为劣恶(五)。不索讥谤(六)。不为卒暴(七)。教化诸天(八)。不兴恐惧(九)。烧诸恶趣(十)。开演善归(一)。贤圣所命(二)。恭奉明智(三)。其内清净(四)。善修于外(五)。而受言教(六)。分别言辞(七)。无[革*亢][革*卬]说(八)。口演柔软(九)。言语殊特(十)。口畅香洁(一)。而随教命(二)。无有欺诈(三)。无所热恼(四)。造业可爱(五)。内无有失(六)。外亦无误(七)。不为罪业(八)。造众祐地(九)。乐于佛道(十)。传语至诚(一)。言辄获利(二)。是为三十二事也

佛告宝女。所谓至诚求愿具足。所以者何。喜布施者为菩萨道。无悭贪故斯成志愿。一切所有设能慧施。睹是以后此则至诚。清净之诫为菩萨道。不为毁禁斯成所愿。假使戒禁具足清净。睹是以后此则至诚。建立忍力为菩萨道。志不怀结斯成誓愿。其忍辱者此为柔和。睹是以后则为至诚。遵修精进为菩萨道。不为懈废斯成所愿。设能普行一切德本。睹是以后则为至诚。建立禅定为菩萨道。不为乱心斯成所愿。设能怀来习一心者。睹是以后则为至诚。建立智慧为菩萨道。不为邪黠斯成所愿。晓了圣慧。睹是以后则为至诚。四意止行为菩萨道。不为放逸斯成所愿。意以寂定。睹是以后此则至诚。四意之断为菩萨道。不兴众恶心若灭除。斯成所愿。睹是以后此则至诚。四神足行为菩萨道。无有不达已能飞行。斯成所愿。睹是以后此则至诚。五根之事为菩萨道。诸根寂然无有错乱。斯成所愿。诸根澹泊。睹是以后此则至诚。五力之行为菩萨道。不为无势具足十力。斯成所愿。睹是以后斯则至诚。七觉之意为菩萨道。无所不了已能觉达。诸情不起斯成所愿。睹是以后此则至诚。八圣道行为菩萨道。无有邪径。设处圣路斯成所愿。睹是以后此则至诚。四恩之行为菩萨道。不为无救摄诸危厄。斯成所愿。睹是以后此则至诚。修四梵行为菩萨道。不为天人。慈悲喜护救济群黎。斯成所愿。睹是以后此则至诚。神通之慧三达之智。正观寂寞为菩萨道。无诸瑕秽众行普具。斯成所愿。睹是以后此则至诚。具足一切诸德法本。为菩萨道。不为无度。蠲除一切诸不善法。斯成所愿。设能宣备仁贤之法。睹是以后此则至诚。佛告宝女。菩萨亦当玩习奉行贤圣之谛。知于苦慧断于所习。晓了灭尽修行圣路。彼所谓知于苦者。分别五阴无所起故。断于习者。于五阴爱无所习故。究竟恩情无所习行。其为脱门。无所游居不怀所施。其无所怀则于过去而无所至。设于过去无所至者。彼则正法无所蠲除。已于诸法无所除者是为断习。彼知灭尽一切想着。所兴方便睹究竟尽。其灭尽者。为不复怀得于生死。等于所有终始均平。于一切法而无增减。已等观者。斯为晓了灭尽之慧。彼察平等于八正路则能等疗。无所想念而无邪想。求诸尘劳无有吾我。以无吾我便无所受。则无所生无造业者。悉能善修于一切法。是则名曰为圣路矣。假使于斯至诚之慧。晓了一切。皆畅众生。亦无有内亦无所证。是为菩萨之至诚也。佛说是至诚教时。一万菩萨。具足圣慧逮得法忍

佛告宝女。何谓菩萨应顺于法御行如法。则随法教思惟于法。法为志性恭敬于法。遵修法行欲慕于法。乐于法乐多存于法。法为妙英法为刀杖。被法之铠誓法自严。修法光明法之锭燎。常志法念以法为意。游步于法分别经典。方便应法游步法行。法为卧寐法为威仪。将护法事以法布施。法为财业法无有尽。普弘演法法为严辨。常修法身法为言辞。思惟法念而不放逸。如是比类遵修法行具足成就。而顺法主不为非法。彼为何谓顺法主者。设使如斯至诚真谛。被佛法铠以法为护。恭敬圣众殷勤听经乐于道意。积累众善不舍至真。志性本净而无所著。不违所应。见诸贤圣习众善友。常行恭敬随其示现。离于憍慢多所咨嗟。游在法会至心听经。慕求法典不以厌足。讲说道义则不懈倦。而于经法无能为师。念报恩慈以有反复。所作成办。处于闲居而无恐惧。贤圣之教无所犯负。不舍止足顺从十善。咨嗟布施劝助佛道。奉于禁戒忍辱为力。遵修精进而不怯弱。禅定寂然游入智慧。兴隆道化显扬善权。慈多所护入于愍哀。悦豫行喜护离二事而顺至诚。所可遭遇以善为业。兴发神通导利正法。在所游至以法惠施。于四意止不忘失志。四意断者遵修平等。四神足者现在究竟。诸根明达修治诸力。晓了诸觉超越径路。入于寂寞观察所行。真谛之惠圣明解脱。颁宣晖曜顺诸声闻。随其本地教化缘觉。咨嗟一切大乘之德。则以应谊而理缘起。便于空无无所恐畏。游于无想则无所著。观察无愿五阴如幻。观诸四种亦如虚空。又诸入者本净悉空。七财之业遵修六念。及乐于六行度无极。而获五眼第一之议。常自将护多所超度。善修道业等心一切众生之类。歌颂一切无量诸佛功德之法。佛言宝女。顺法菩萨。不言有我不计有人。亦不计命亦不念寿。不思断绝不睹有常不见所有。若复不离之所睹者。不释边际不猗中间。不从朋友亦无诤讼。亦无不和亦无偏党。不处颠倒不在邪见。越度狐疑蠲除阴盖诸所挂碍。不违远法亦不乱法。不诽谤经不轻慢道。不灭究竟一切诸法。顺道菩萨志存诸法。具足经典所言至诚为顺法矣。无所兴举。于诸异学顺法言者。奸难邪行悉以灭矣。于一切世而顺法言。菩萨顺空行无所获。则无邪想无嗔恚法。顺无愿教。而于三界悉无所行。殷勤专精睹诸瑕秽。顺法菩萨。则无所起亦无所灭。则不受生。本性清净义在寂寞。佛告宝女。所谓法者则不可获。无有文字而无言说亦无辞意。无色无见亦无所趣。无有言诲亦无所教。离心意识无有尘垢。以离瑕疵远于贪欲。无有窈冥无所积聚。则无吾我而无所受。亦无所取离于所受。无有境界便无差特。于十方界而无所著。则为澹泊。弃行身退亦不可睹。觉了玄旷亦无想念。亦无思行抑制圣贤。为明智者所蒙开化。亦无所遭亦无不遭。休息一切。所可遇者则如真谛。三世为空便无永没。亦无终亡亦无退还。亦无所生无所成就。亦无毁灭亦无所有。亦不不有亦无所成。亦不不成亦无所行。亦无所视亦无不见亦不离视。亦不成相亦无不相则为一相。亦复无相亦无所著。离于所著亦无有余。无著无缚亦无所脱。不是我所。亦无所属无所遵修。亦无诸漏则无等伦。亦无平等等无所等。亦无至诚亦不虚妄。不乐不苦。亦不精进亦无不勤。亦无所应亦不不应。亦不专精亦无不精。亦无名色。亦无所起。不为坚固亦无不固。无所破坏亦无不坏。不为金刚亦不坏相。则为真谛。不违至诚。而无别异亦无所远。亦无有像类无有伦比。无有处所亦无有想。亦无有此亦无有彼。亦无差特亦无有内亦无有外。亦无中间。亦无所乐不度彼岸。亦无所见亦无所闻。亦无所念亦无所教。亦无所知亦不无知。亦不有形亦不无形。亦不有作亦不无作。则离一切诸所有形。是谓为法。如是法者。则无音声亦无不声。亦无合会无言无说。是谓菩萨应顺于法也

佛告宝女。具足一切诸所言辞。则为顺法。其顺法者。未曾与人有所诤讼。其顺法者不轻慢他其顺法者。亦不轻易于未学者。亦不偏敬学成就者。其顺法者。不自称誉亦不显己。其顺法者不乱经典。其顺法者。不以供养而说道义。其顺法者。不为他人顺发狐疑。其顺法者。终不讼说他人之罪。其顺法者不轻慢经。其顺法者。终不妨废他人经道。其顺法者。终不睹见觉了诸法差特分数。其顺法者。不睹诸法离于空者。其顺法者。悉睹诸法不远无常。其顺法者。不睹诸法舍于无愿。其顺法者不坏法界。其顺法者不动无本。其顺法者。亦不超度于真本际。其顺法者。亦不导御随嗔恚也。其顺法者。亦不御念于诸神识。其顺法者。亦不导利有所猗着。其顺法者。亦不思念计有人也。其顺法者。不乱法议不违严饰。其顺法者。不迷神识不惑道义。其顺法者不毁正议。其顺法者不错法品。其顺法者不迷于人。其顺法者不造朋党。其顺法者。亦不顺于缘起之事。其顺法者则无有势。亦无有法清净因缘。其顺法者。亦无悭吝尘劳之秽。其顺法者不没禁戒。其顺法者。亦不舍于毁戒之人。其顺法者。无有懈厌嗔恚结恨。其顺法者。不与懈怠垢浊之人而俱同归。其顺法者不失道意。其顺法者。未曾违坏智慧之本。其顺法者。不求他人法之长短。其顺法者。不用憎人厌于经典。其顺法者。不用经典御于典籍。其顺法者不违律教。其顺法者不违法律。其顺法者。亦不遵修而有所应具法非法。其顺法者。不以心念而有所失。其顺法者不没经典。其顺法者不坏成就。其顺法者不取结缚。其顺法者不得生死。其顺法者不除无为。其顺法者。无有亲友怨仇之想。其顺法者。不毁报应所殖之果。其顺法者。亦不信乐罪福之应。其顺法者。若加恶言则不念报。其顺法者。不求斗诤之瑕缺也。其顺法者则不恣口。其顺法者。将身口心不为谀谄。其顺法者。不以自显欲令人见处于闲居。其顺法者。不以供养之所贪利而见少事。其顺法者。不以无欲而造凶伪。其顺法者。不用他人及与己身演说佛道。其顺法者不兴反教。其顺法者不以七财而为贪吝。其顺法者不以糇粮而为服食。其顺法者。亦不破坏严父族种。其顺法者不讥人短。其顺法者。亦不称誉己身之德。其顺法者。不分别说佛之道德而有限碍。其顺法者。咨嗟大乘不以懈厌。是为菩萨应顺于法也

佛告宝女。何谓菩萨寻应威仪。所谓议者。无求名闻非羸劣谊。遵修燎治一切德本积累善谊志性超异。兴发道意合集空谊。假使布施不望报谊。显扬一切诸安之谊。不毁戒谊。忍不忍谊。精进之行一切所造则超度谊。而以禅定为寂寞谊。则于智慧无犹豫谊。遵修慈者等众生谊。设为悲者则于众生一切演谊。其为喜者欢乐法谊。若为护者于诸苦乐无动摇谊。若布施者则无诲谊。欣乐所生无所害谊。造成谊者兴法愿谊。平等谊者。勤化众生志干大乘。而以四恩化黎庶议。一切万物非常苦谊。一切诸法无吾我谊。于诸尘劳至澹泊谊。而于识者晓圣慧谊。游严饰事为将御谊。一切经典则为帑藏导利典谊。计人命者化以法谊。若能了识睹达法谊。说谊无尽。分别经卷不坏法谊。若睹顺灭入无色慧。而遭辩才。随其众人应病说谊。设布施业不以厌谊。为持戒业具足愿故。博闻之业奉要行故。功德之业满诸相故。为惠业者。晓了一切群生根故。寂然之业将心事故。观察之业通达智故。四意止者制止志故。四意断者。兴显一切功德法故。为神足者游十方故。其五根者。不破他故亦不毁空。为五力者。而不错乱诸尘劳故。七觉意者。晓了一切诸法之故。游求路者。于一切法无结恨故。成神通者。究竟本末无缺漏故。在彼如斯。若兹像类顺法议者。则为究竟法谊之要。若应此谊寻应威仪。不为非谊。如是菩萨寻应威仪

佛告宝女。一切颠倒众邪见灭则为空谊。行空菩萨为顺谊矣。除一切想应以不应则无想故。无想菩萨便顺应谊。离于一切三界之愿则无愿谊。无愿菩萨便顺应谊。休息一切诸所造行则无行故。无行菩萨便顺应谊。舍远所生一切灭尽则无生故。无生菩萨便顺应谊。诸所起受以无所起则无起故。无起菩萨便顺应谊。而以蠲除苦习尽道则为尽故。灭尽菩萨便顺应谊。一切诸法无有人命则为无故。无人菩萨便顺应谊。一切言辞音响之谊而不可得则为故矣。无获菩萨便顺应谊。诸行清净则诚谛故。至诚菩萨便顺应谊。一切道品法无放逸则为故矣。无骋菩萨便顺应谊。一切所闻悉信奉行则为谊也。遵行菩萨便顺应谊。一切诸乘由大乘故。若有菩萨随大乘教便顺应谊

佛告宝女。无所坏者。无若干事则为谊矣。一品类者若一味者则为谊矣。无所动摇若无所尽则为谊矣。无所行者不生不起则为谊矣。无所来者亦无所去则为谊矣。无所生者亦无所灭则为谊矣。无有二事不举不下不高不卑则为谊矣。无所造作亦无有形则为谊矣。无所兴为亦无所有则为谊矣。无有同像无所劝教。亦无有知则为谊矣。去于三瑕净三道场。平等三世三垢永除而无三尘则为谊矣。无所游止无所毁失则为谊矣。无有怨敌为澹泊行。无有恼热则为谊矣。无燕居行则为谊矣。无所宣布无有摄取。常如应行则为谊矣。断去来今无有谀谄则为谊矣。亦不想念正法非法。除有限无限有常无常。平等之惠而超度去则为谊矣。于诸文字所应音声而悉晓了。一切本净无有言辞则为谊矣。晓心意识无所宣畅。而出家者则为谊矣。于淫怒痴尘劳之欲有想无想应与不应。悉分别之而无想着则为谊矣。等于诸法而无若干。不为差特则为谊矣。空无相无愿无所造作。亦无有形则为谊矣。晓了第一至诚事者。不有所信不仰他人。不知相处则为谊矣。亦无敕教不着诸相则为谊矣。相如虚空靖寂之相则为谊矣。无所著相无所造作。无所悦相则为谊矣。无所坏相如其本无真谛无异。无差特相则为谊矣。善开化相计阴如幻自然之相则为谊矣。其四种者为法界相。而不游出径行外相则为谊矣。布施戒惠寂然善权。无有相者则为谊矣。兴设至诚无欺诈相。一切所有为无所有则为谊矣。犹如金刚坚无坏相。处于世间无所诤相则为谊矣。所作极善而谛究竟。具足之相则为谊矣。一切普入而悉济相。无有阴盖所向门相则为谊矣。等于诸趣入于一切诸法之相则为谊矣。平等无邪睹于平均。无所有相则为谊矣。定意智惠因游生相。解度知见而为惠相则为谊矣。依于圣相若有所知。若教命相则为谊矣。如其真谛晓发遣相。等御一切诸法之相则为谊矣。假使菩萨如是具足所修之谊。能说若斯诸谊事者。则能分别一切众谊。故谓大士菩萨寻应威仪者也

佛告宝女。何谓菩萨奉顺律教。如来讲说而有二律。何谓为二。殃罪之律。决劳欲律。彼何谓殃罪之律。所言罪律。思想之本。不应顺本。无明之本。愚痴之本。颠倒之本。无实之本。虚伪之本。贪身之本。猗我之本。着人之本。懈怠之本。无所舍本。无所归本狐疑之本。慢恣之本。难致慧本。是谓殃罪之律。何谓决尘欲律。住无犹豫而无所念。无有罪处亦不说罪。不说方面。不乐王者。不为尘埃。无有悭贪。亦无所见心无所起。其志安雅离于灭尽。则无所有无有处所。亦无方面无有尘劳。无所吝惜亦无所睹。计如心者罪亦如之。如其罪者。一切诸法亦复如是。无有根本亦无所住。犹如心者不可攀引。清净鲜洁超诸所有。寂然澹泊趣于灭尽。断绝休息生死患难。信遵圣教而秉一心无有犹豫。志于同归无有殃舋。是则名曰决尘欲律

佛告宝女。何谓尘劳。何决欲律。所言尘者。谓淫怒痴无明恩爱。及以所受诸有十二所趣。有为因缘之行。是曰尘劳所决欲律。究竟开化一切诸法。所以者何。则以空事开化诸法。彼无欲行无恚恨痴。则以无相开化诸法。亦无玩习行众劳尘。则以无愿化于诸法。彼则习行诸德善事。于一切行而无所行。已无所有化于诸法。以无所行导利诸法。彼于所造而无所行。一切诸法依猗因缘。于一切见无所遵修。假使于此十二因缘有所归趣。平等诸法于一切劳则无欲尘。本末寂灭。所云空者俗与道空。以是之空。一切尘劳欲事亦空。假使以空等于道者。是决欲律。其有言曰。彼典主律自开化者。乃名曰律。其能知己自化身者。则能晓了开化欲律。何谓开化己身之律。其能分别于我不我知身自然。解己澹泊了己如实。晓于己身无所嗔恨。分别身空己无所有。晓己无本了己无获。分别己身而不动摇。分别己身无有伦比。晓己无生亦无所起。其有了己分别如是。则了尘劳而无有本亦复若斯。如无有我而想有我。彼则颠倒。设如是者。己无尘劳而起劳想。是为颠倒。又如吾我本净无身。如是欲尘则为本净无尘劳也。其有晓了如是观者。是决欲律。彼亦不化过去欲尘。亦无当来亦无现在。所以者何。不习诸行亦不复念尘劳欲尘。其于己身无所念者。则无过去亦无当来亦无现在。又如心者无有色像。则无有内亦无有外亦无所得。欲尘如是则无色像。亦无有内亦无有外亦无所得。无所得者则无嗔恨。亦无诤讼无所灭除。亦无所造无所不造。亦无所作亦复不作。一切欲尘其有游此。于诸欲尘了别恩爱。而无所有亦不离有。是则名曰决欲尘律。佛告宝女。假使菩萨晓了如是开化欲律。则能教导众人欲尘而说法矣。是则名曰奉顺律教。佛说是至诚真教之法随谊奉顺律事。一万菩萨得不起法忍。宝女欣然志怀踊跃善心生焉。前白佛言。未曾有如来。快说此至诚法叹咏谊律。设使菩萨奉行如斯。则为第一无所诤讼。便能蠲除众生所讼。则顺经典

宝女所问经卷第一宝女所问经卷第二

        西晋月氏三藏竺法护译

    发意三十二宝品第二

尔时贤者舍利弗问宝女曰。今者女身岂能修于至诚之法谊律行乎。宝女答曰。唯舍利弗。其至诚者无有言辞。法者无欲谊不可获。计于律者身心寂然。又如彼者不可发遣亦无所受。唯舍利弗。其至诚者则灭尽相。法憺怕相。仪离严饰律解脱相。以是之故不有言辞亦不可说。唯舍利弗。至诚无本法无差特。议无有二律无造谊。以是之故不有所说。亦无言辞不可赞咏。时舍利弗复问宝女。女所执宝为何等类。而尔名曰为宝女也。于是宝女答舍利弗。菩萨则以三十二事而现目前兴发宝心。一切声闻缘觉之乘所不能及。何谓三十二事。救济一切黎庶之类。皆令兴发诸通慧心不断佛教则发宝心。将护法教则发宝心。亦不断绝圣众之令则发宝心。劝导众生立贤圣安无极之珍则发宝心蠲除黎庶尘劳之欲。去诸恼患至于大哀则发宝心。一切所有琦珍异宝悉能舍施。内外所有瑰琦之物无所贪惜则发宝心。自能护己禁戒善行。能以救济毁戒之人则发宝心。忍辱之力和雅安详精进合集。令诸嗔诤患厌怒害。贡高自大怀结之众群黎之类。恃怙力势欲有所加。使兴忍辱。而令众生观于道法忍辱之力则发宝心。不怯不弱亦无懈怠。坚固殷勤永不回还。于大乘行而不懈倦。开化懈怠众生朋党令大精进则发宝心。心意专精而修一行。同等禅定三昧正受。所归差特开化众生。令于欲界而无所著。以权方便退还于禅则发宝心。智慧分别破坏一切诸窈冥法。犹如真正而无有二。入施一品感动圣达则发宝心。等心一切而无加害。道无若干寻以一味为诸通慧则发宝心。离诸结滞而以平等。有为无为有形无形。亦无欢欣不离寂然。无心熙怡善住安谛。意不动摇苦乐不移。将护群黎则发宝心。离于恐惧。于深缘起十二相连奥妙之谊而无所畏。所当度者晓了超越不取诸见则发宝心。积累功德而无厌足周满相好则发宝心。常志好乐欲见正觉。而不违远恒睹诸佛则发宝心。求闻经法听省典籍称量谊趣则发宝心。如所闻法可讲说者发无量心。所兴诸法无所师受则发宝心。建立所行睹毁戒者而以恩济则发宝心。其无所学志存新学而不轻慢则发宝心。舍于贡高自大甚慢邪憍之心。卑下谦顺而受教命。自屈稽首一切众生则发宝心。志存微妙诸根明达。蠲除卑贱下劣之乘。信乐大乘直心向道则发宝心。离于魔事除去劳尘。洁净清白而无垢浊便无瑕疵。贪欲染污乃以永除。乐处所有不以懈厌则发宝心。而常专精行在澹泊。秉闲居德身心寂然。澹虚之行亦不污秽。生死之难志于大哀则发宝心。于是菩萨。舍于己身一切之安。欲安天人开化众生遭苦患者。于众恼热不以懈惓则发宝心。斯菩萨者光明寂然。而如势力逮无漏法。观于解脱如察己事。假使欲令而不远舍所有之事。悉欲具足十方诸佛之法则发宝心。斯为菩萨。非常苦空无我非身。观斯诸法则无有厌不染尘欲。乐志无欲道品之法则发宝心。斯为菩萨空无想无愿。于一切法而无所行。则以观察睹见众生。便于诸法而不造证则发宝心。斯为菩萨。睹于诸趣恐惧之难。忽如失火烧其头发。精进具足不可计会。无央数劫游于生死。而不懈废诸通之慧则发宝心。是为菩萨。设使亲近于佛道者。渐渐加增微妙之身圣慧之业。彼时行者不舍大法。伏意乐顺随诸穷匮。不增秽之不以懈厌则发宝心。是为菩萨。假使劝化群黎之党。第一精勤乐于道谊不计吾我。坚固志性至于大哀则发宝心。唯舍利弗。斯为菩萨三十二事而发宝心。则为名曰无极妙珍宝一切菩萨之宝心也

于时世尊赞宝女曰。善哉善哉。甚快说此菩萨之行。所发宝心而得入道。又复宝女。斯诸正士有无量德所可叹咏。发于无上正真道意。所以者何。非声闻宝非缘觉宝。斯则名曰为佛道宝为菩萨宝。加复兴隆佛道之宝。因而生出声闻缘觉菩萨发心所兴之宝。皆悉出生一切诸宝

    聪明品第三

于是贤者舍利弗白世尊曰。至未曾有天中天。此宝女身所问辩才。分别解说如所了慧聪明之慧。本岂达乎演畅要事。世尊问曰。于舍利弗所念云何。斯宝女者。不以聪明慧演说法要。莫造斯观。此宝女者。已得聪明无断辩才。于时耆年舍利弗问宝女曰。女乐堪任分别聪慧。解脱缘便。宝女报曰。唯舍利弗。一切诸法悉而应说。皆归聪明所造之业。唯舍利弗。菩萨意者分别解说为聪明慧。所以者何。摄取一切诸谊之要故发道心。是为于谊聪明之慧。等御法界故发道心。是则名曰辩才之慧。彼所说者皆归灭除。是为灭尽辩才哲慧。一切顺旨为聪明慧。发此心已。至无碍颂无断辩才。是为辩才聪明之慧

宝女复谓。舍利弗。无所行谊无所著谊。心志大谊聪明了谊。而常善思法如幻谊。计其心者则为法事聪达之心。心了诸门有所归者。归于明哲不倚六情。心无所著辩才无碍。分别聪辩所有谊者则为非谊。见法澹泊所谓顺趣。假音声耳。其辩才者托于言辞。所云佛者无不觉谊。由是法生。缘斯顺应分别法矣。有辩才者分别自恣法谊为谊。无恣之法乃为法矣。应顺之法乃为顺矣。法之辩才乃为辩才。无所有谊无为之谊。合会之谊为聪明谊。合会法者一法味谊。圣众顺灭乃为顺灭。有所分别乃为辩才。是为舍利弗诸法讲说章句。常观此法则为聪明谊也

    问宝女品第四

尔时贤者舍利弗问世尊曰。其宝女者。发无上正真道意以来久如。为于何佛而志大道。佛告舍利弗。乃往过去久远世。不可计会无央数劫。尔时有佛。号曰维卫如来至真等正觉兴出于世明行成为善逝世间解无上士道法御天人师为佛众祐。世界曰清净佛土。衣被饮食居宅游观。皆如第四兜术天上诸菩萨众。又彼佛时。纯悉一类唯菩萨众菩萨之会七十六亿皆不退转。得诸总持出于辩才

佛言舍利弗。时维卫如来至真。有转轮王名曰福报清净。主千世界。帑藏珍宝不可称计福报清净。中宫之内夫人婇女八万四千。皆国中上真人玉女。王有千子悉皆力士威势难论。其王供养维卫大圣。三十六亿岁一切施安。而诸菩萨奉衣食床卧之具病瘦医药。舍利弗问曰。唯然大圣。维卫如来寿命几何。世尊告曰。寿十中劫。福报清净王供养维卫如来。不可称限。中宫诸子眷属枝党九十二垓。侍从围绕诣维卫佛稽首足下。明月珠璎其价百千奉上世尊。则而叉手白维卫佛。唯然大圣。吾身所有供养众备。宁有供养超过此者进如来乎。佛告舍利弗。维卫如来答福报清净王曰。大王欲知有异供养为尊为上为无俦匹。王所未施设。百倍千倍万倍亿倍巨亿万倍。超胜于王前所施与供养之具。又问何谓。维卫如来见彼大王心之所念。则说颂曰

  亿千诸佛国　　无数如恒沙
  至亿百千劫　　满中珍宝施
  而供养如来　　合集其福德
  不及愍众生　　而发道意者
  事亿千诸佛　　垓数如恒沙
  奉无数亿劫　　亦如江河沙
  佛道心哀胜　　七步为超殊
  斯供养诸佛　　最尊豪无上
  斯施为超越　　诫无量上忍
  此精进坚强　　定意慧无动
  其发道意者　　志愿于导师
  是福最无限　　所积不可尽
  名称远流布　　眷属巍巍妙
  财宝势力豪　　心念如侥获
  为转轮圣王　　威力天帝梵
  若志性欣豫　　断意诸通慧
  消灭诸恶趣　　悉无八难畏
  长益清净道　　常处天人路
  若人建立志　　离垢无上道
  诸根恒明达　　圣聪无闇塞
  睹诸佛奉事　　而听闻经典
  精求智慧圣　　常知弘道心
  心无犹豫结　　离谄常质直
  愍济众生故　　其志愿道意
  不乐诸欲乐　　志慕于法乐
  普世无所著　　行如水莲华
  不厌福德慧　　志求度无极
  发道心如是　　孰不建大道
  则以巨锭镣　　昭济诸群[黍-禾+利]
  为尊上明师　　众生大导师
  处世为最上　　施药除诸病
  建立于道意　　亿无量无尽

佛告舍利弗。福报清净王者。从维卫如来。闻发道意咨嗟功德不可限量。欢喜踊跃不能自胜。则发无上正真道意。时王中宫太子官属群臣百官。及诸小王眷属翼从。说此颂曰

  今以建立　　最尊道意　　兴发慈心
  愍伤众生　　假使欲得　　吾所敬重
  则发道意　　令其坚固　　生死本际
  而不可知　　坐行非事　　堕于苦恼
  殷勤精进　　志尚佛道　　为众生故
  行愍善哉　　则能长益　　辩才智慧
  具足供养　　圣达如是　　维卫之佛
  得不可量　　为通慧心　　所行若斯
  欲获天世　　之所安隐　　帝释梵天
  转轮圣王　　有为之安　　无为之乐
  则当遵修　　于斯道意　　思摄禅定
  不可限量　　度于彼岸　　道亦如之
  圣通之慧　　靡所不达　　诸一切智
  所行如是　　十力佛势　　不可思议
  四无所畏　　如来所有　　诸佛之法
  弘广无边　　从清净心　　而获致斯
  假使欲动　　亿千国土　　音声普告
  而悉闻知　　修清净行　　恢弘无垢
  有聪达者　　当发道意　　则为十力
  之所奉敬　　而诸如来　　悉咨嗟之
  为诸众生　　无请之友　　有聪慧者
  当发道意　　设使佛道　　现无慧慈
  说其功德　　无数亿劫　　佛之道意
  所有功祚　　不可尽极　　况欲限乎

尔时福报清净大王。适说此偈。九十二垓民人之众。及王后宫并千子。则发无上正真道意。三千大千世界六反震动。十四亿天演劝助音发大道心。然后彼王转轮圣帝则更恭肃。十亿载供养维卫如来之尊。一切施安。净修梵行清净之戒。常听如来所说经典。眷属俱往启受法教。则立长子而为国主。便下须发以家之信。离家为道行作沙门。作沙门已寻则学是四无尽句。次第咨嗟称限求趣。何谓为四。至诚章句。法典章句。妙谊章句。律令章句。具亿千岁入权方便。其王出家学此以后。于千世界三昧正受超度众生。悉于维卫如来之所而作沙门。佛告舍利弗。欲知尔时转轮圣王。福报清净者。岂异人乎。莫造斯观。则是宝女。斯宝女者于维卫佛。初发无上正真道意。时舍利弗问世尊曰。以何罪盖受女人身。佛告舍利弗。菩萨大士。不以罪盖受女身也。所以者何。菩萨大士以慧神通善权方便圣明之故。现女人身开化群黎。于舍利弗意趣云何。斯宝女者为女人乎。莫造斯观。承圣通力而有所变。则真菩萨也。当造斯观。无男子法无女人法。具足一切诸法之要。无来无去。此宝女者。处阎浮提开化教授。九万二千诸童女众。皆发无上正真道意。于时宝女谓舍利弗。耆年岂能现女人身。而为众生讲说法乎。舍利弗曰。如今吾者则不好乐男子之身。况当复受女人之像。宝女问曰。卿为秽厌于己身乎。便答女曰。实患厌之。宝女答曰。是故菩萨超越一切众生之类而无有侣。舍利弗曰。以何等故。其女答曰。唯舍利弗。声闻之家所可秽厌。其诸菩萨不以患难。声闻之家何所秽厌。五阴四大衰入之事声闻所患。菩萨执持五阴四大六入之事。不以为患。声闻秽厌所生周旋及受吾我。菩萨受身无所患厌。诸声闻众恶受生死。菩萨游入无量终始不以患厌。声闻秽厌所生众难。菩萨所生而无患难。声闻懈厌功德之业。菩萨积累众德。不以厌足亦无患难。声闻恶厌在于众会。菩萨开化群黎之党。不以患难。声闻秽厌郡国县邑。菩萨普入郡国县邑州域大邦。不以恶厌。声闻秽厌。己身尘劳菩萨不患。一切众生尘劳之欲。唯舍利弗。声闻之家所可秽厌。菩萨大士无所患难

    八力品第五

于是舍利弗问宝女曰。菩萨大士。承何威力无所秽厌。宝女答曰。唯舍利弗。菩萨八力无所患厌。何谓为八。一曰慈力无所加害。二曰哀力不舍群黎。三曰和性之力不为下劣。四曰慧力离于尘劳。五曰权力心无所厌。六曰德力行无所著。七曰圣力则无愚戆。八曰进力本志上愿。是为八力。菩萨周旋之所建立。道德之力无所患厌。耆年舍利弗问宝女曰。汝岂具足如斯力乎。若能平等往来周旋耶。宝女答曰。若以平等平等住者。设能如斯行诸平等。彼则无力亦不羸劣。其平等者。彼则不有亦复不无。无无所造不造所行。斯谓平等。平等犹空。一切诸法亦如虚空。其如空者则无虚空。空虚曰寂。便无言说若如旷野。一切诸法亦复如是。犹如虚空慌惚无形亦无言辞。如是平等则无羸劣亦无力势。唯舍利弗。菩萨羸劣则有势力。所以者何。假使若以尘劳爱欲而羸劣者。则以智慧而有力势。若悭贪劣则用布施致于坚强。设以犯戒而羸劣者。则以戒禁而坚强矣。设以嗔恚而羸劣者。则以忍辱为力势矣。其以懈怠为羸劣者。则以精进为力势矣。其以乱意为羸劣者。则以禅定为力势矣。设以邪智为羸劣者。则以正智为力势矣。斯一切法设使菩萨于不善德而羸劣者。则以德本为力势矣。于时世尊赞宝女曰。善哉善哉。若有欲言当作斯说。说是语时五百菩萨逮得法忍

    十种力品第六

宝女白佛。所可谓言如来十力。以何等力为十力乎。而得成就。佛告宝女。假令菩萨行菩萨道。未曾归于成立下乘也。终不兴造不善之业。彼则以斯坚固之力遵诣道场。宝女又问。何谓十力。佛告宝女曰。力达处处以处处力审如有知。有限无限审如有知。设令宝女。如来处处非处处事。有限无限审如有知。是为如来第一之力也。如来以斯于众会中而师子吼。解无著要转净法轮。沙门梵志天龙魔王梵天世人。巍巍之德莫能当焉。常如法故

复次宝女。行菩萨道。欲令余殃罪福之报未之有也。彼以得蒙遵修力势。逮成佛道。过去当来现在罪福悉知其原。设使如来知去来今罪福报应。善恶所趣审如有知。是为如来第二之力也。如来之力而于众会则师子吼。解无著处转净法轮。沙门梵志天龙魔王梵天世人。巍巍之德莫能当焉。复次宝女。行菩萨道。观众生根而为说法。知其原已而度脱之。若使应于众人之根。以此具足逮成佛道。为诸众生以精进根限了黎庶审如有知。假令宝女。如来现知众人根本而师子吼。是为如来第三之力。应如法故。复次宝女。行菩萨道入于众生人物之界。随人所好如其黎庶而建立之。彼入斯界究竟之力。逮成佛道。而晓世间无数之形若干种体。假令如来入众生界。各从信喜而开导之。是为如来第四之力。应如法故

复次宝女。行菩萨道。群萌之类志若欲脱。因其所信而得勉济。求于慧见。睹如慈信而不恶秽。彼则以是信解脱力究竟之事。逮成佛道。而知黎庶若干种信。无量之乐审如有知。假使宝女。如来了知仙人众生若干种信。所乐无量审如有知。是为如来第五之力。而于众中则师子吼。沙门梵志天龙魔王梵天。巍巍之德莫能当焉。复次宝女。行菩萨道显发遣慧。有为无为有形无形之所有法。求声闻乘缘觉之乘若复大乘。彼以斯慧具足之力逮我佛道。一切尽入究竟之慧。审如有知。假使宝女。如来普入众慧靡不周达。审如有知。独步众中而师子吼。天上世间。巍巍之德莫能当焉。常应如法。是为如来第六之力也

复次宝女。行菩萨道。未宝废失往古德本。而不放逸超越本愿。彼则以斯往古本德不忘失力。具足究竟逮成佛道。心念过去无数劫事审如有知。假使宝女。如来知己及他众生不可计量往古之事。悉诚念之审如有知。而于大众师子之吼。是为第七之力。沙门梵志天龙魔王梵天。莫能当焉常如应法故

复次宝女。行菩萨道。遵修禅定三昧正受心无所生。离于欲尘调隐柔仁。彼则以斯柔仁之力。具足究竟逮成佛道。了于黎庶一切禅思脱门定意正受之行尘劳怀结。审如有知。假令宝女。如来晓于黎庶一切禅思脱门三昧正受尘劳怀结。审如有知。是为如来第八之力。而于大众师子之吼。沙门梵志天龙魔王梵天。巍巍之德莫能当焉

复次宝女。行菩萨道。未曾覆蔽众生之功。不轻未学不慢不及。逮致显明照于众生。彼则以斯弘大光耀。究竟具足逮成佛道。天眼彻视如有悉知。假使宝女。如来至真道眼彻视靡不睹见。是为如来第九之力。独游大众而师子吼。沙门梵志天龙魔王梵天。巍巍之德莫能当焉

复次宝女。行菩萨道。不御众生至有漏法。则为黎庶说漏尽法不长诸漏。以无漏道求于众生。显示正路。彼此无漏笃信之力。具足究竟逮成佛道。普达一切尽诸漏慧。审如有知。假使宝女。如来悉尽诸漏慧者。开示一切无漏之慧。是为如来第十之力。如来以致斯真力者。则于众会而师子吼。了无著处转净法轮。沙门梵志天龙魔王梵天世人。莫能当焉。是为宝女如来十力。如来以是十种之力。具足成就乃得谓正觉。假使菩萨逮闻此力。以斯菩萨十种之力。而逮成就如来十力

    四无所畏品第七

宝女白佛。斯所可谓如来至尊。四无所畏十八不共诸佛之法。又彼菩萨则以何行。致四无畏十八不共诸佛之法。世尊告曰。行菩萨道。未曾于法违失师命。了知是像。常以等心愍于众生。一切所有施而不吝。等奉行法观察所归。无若干想以离众着。适成佛道则师子吼。吾以逮成平等之觉。汝等当知。吾以晓了于此之法。无不觉达。假使若有沙门梵志天龙鬼神魔王梵天及与世人。不能睹见如来瑞应弘雅威曜。设不能睹现应之德。欲求佛短都不睹见。而敢生意心自念言。佛不得成平等正觉。设有言尔。佛无恐惧行无所畏。独步大众而师子吼。知无著处转净法轮。沙门梵志天龙鬼神魔王梵天及与世人。巍巍之德莫能当焉。是为如来第一无畏

复次宝女。行菩萨道。知于内行别内外法。又复晓了挂碍之法。亦不习行废退之法。亦不顺从亦不自行。不以化人亦不宣布。见诸挂碍悉弃捐之。逮成佛道为师子吼。永不睹见沙门梵志天龙鬼神魔王梵天及余世人而讼理言。如来讲说挂碍之法而令人行。虽有斯言不以恐惧。行无所畏转弘法轮。于大众中而师子吼。是为如来第二无畏

复次宝女。行菩萨道而常奉行清白之法。无诤讼路讲说经典。净化一切众生之类。现在归趣超异之德。无数重担无为之业。则普得入净除结恨。而自积累无为之业。其佛劝化黎庶之原。逮成佛道则师子吼。吾以净除诸结恨事而讲说法。遵修此行悉得严净。永不睹见沙门梵志天龙鬼神魔王梵天及余世人而讼理言。如来讲说结恨之法。虽有斯言不以恐惧。行无所畏转大法轮。于大众中而师子吼。是为如来第三无畏

复次宝女。行菩萨道未曾处于甚重憍慢。吾有所知吾有所见。余人无知而无所见。志常谦逊而不自大。觉了众事不着恶行。彼遵此法悉令具足。逮成佛道则师子吼。当知我身以尽诸漏。如是蠲除生死之患。复为众生广说经典蠲除诸漏。永不睹见沙门梵志天龙鬼神魔王梵天及余世人而讼理言。如来讲说不除诸漏诸漏未尽。虽有斯言不以恐惧。行无所畏转大法轮。于大众中而师子吼。是为如来第四无畏

宝女所问经卷第二宝女所问经卷第三

        西晋月氏三藏竺法护译

    十八不共法品第八

复次宝女。行菩萨道。诸有众生常失路者。导示其路沟坑崄地高下邪径。治令平等而设桥梁。窈冥之处边旷之地。则立佛寺高旷弥弘。假令有人处狐疑罪。为无央数群萌之类。蠲犹豫罪。令不堕殃而有处所。亦不兴盛他人狐疑。不说人短言某有罪。知无央数群黎志性。灭除一切众生愿行。而说经法无有狐疑。亦不犹豫。则为兴显法之弘曜。而以授与大智慧明。劝助诸佛一切菩萨令说经典。以法施恩而无谀谄。造立善业转相劝化未曾轻人亦不调戏亦不易弈。不施加害亦不毁呰。国土所习亦不自大。一切言辞唯信佛言。随文字教而得自在知文字空。于诸言辞所有之事不睹瑕秽。不求其短不瞻其缺。设使菩萨行如是法逮成佛道。斯则名曰无有瑕缺。以无瑕缺则能具足一切智慧。若有问事分别解说。靡不通达普悉照曜。善修三昧善能晓了。咸入一切音声总持。常叹如来无缺之辞而说经法。皆于文字而无所造。是为宝女如来第一不共之法

复次宝女。行菩萨道。弃捐一切口之恶辞。所言至诚。以法为本以议为主。教化为业不为虚妄无所伤害。而悉舍离非贤圣辞。遵修贤圣寂寞之事无有诤讼。顺从沙门所造立法。若闻经典所求得议为他人说。皆为己身及与他人。志求精修灭定之事。未曾与人斗结怀怨无所讼理。不求口舌亦不着空。信解空行则无所著。度法名号笃信如来无业道慧。劝化余人众生之类使入此法。遵斯法已逮成佛道。谓无诤讼彼无音声。不以一字而有言辞。亦无所说不处诸业。劝化他人于斯正法。修是法已逮成佛道。则无言辞。以无音辞。不以一字而有所演。亦无所说无俗之业。为诸会者善说议理可众人意。所说音辞顺而应时感动国土。善修三昧分别晓了无量之行总持之门。则于如来一切顺节诸相具足。及一切好一切毛孔。演出无量不可思议佛法音声。能以一毛所畅音声。悉叙悦可诸会人心。讲说无量诸法之门。音自然出。乃是往古本愿所建势力所致。如来于彼无有思想。而常寂然无所业求。是为如来第二不共诸佛之法

复次宝女。行菩萨道。常不违失于六思念。而常念佛念法念众有思念天念行布施念行智慧。亦化他人令行六念。行此法已逮成佛道。常不失意救念众生。于一切法而得自在。善修三昧分别晓了法锭总持。又如来尊。悉念诸法未尝忘失。彼时则以未曾之行。察睹一切众生之类心意所念。欲来问事。如来悉了不复思念。若有问者而解说之。如是所言心根明达无所挂碍。皆能善说悦众人意。以一文字一时须臾而悉周至。是为如来第三不共诸佛之法

复次宝女。行菩萨道。而常将护他人之心。不令余人造嗔恨心。不令心动。不恼人心。不令心臭。未曾妨废他人德本。不断绝法而信其心犹若如幻。无念无想不以自恣。等心一切众生之类。等观诸法。处一法界入无所坏。行是法已逮成佛道则得常定。无有须臾心不定时。观行诸法一切自然。名等积三昧。而善分别普门总持如来常定。显示一切诸佛之事无有异业。是为如来第四不共诸佛之法

复次宝女。行菩萨道。无有颠倒诸想之念。心不反行不造邪见不为虚妄。则不自计有我有身。无有人想。亦无寿想。亦无命想。无士夫想。无人意想。无学志想无断绝想。无有常想。无诸见想。无三处想。亦无念离三处之想。亦无有善亦无不善。亦无有罪亦无不罪。亦无有漏亦无不漏。亦无世俗亦无度世。除尘劳根。无有生死及泥洹想。受聚会想。众生志性思想颠倒。蠲除此已遵修众善。则以远离凡夫之想。弃捐一切众邪之见。亦于中间而无所猗。观平等法。行斯法已逮成佛道。无若干想。名曰如来永无诸念。则能善修无想三昧。晓无尽藏总持之门。如来游步行无有想。则兴大哀愍伤群萌诸妄想者。其有黎庶缚着行者。劝化说法不失时节。是为如来第五不共诸佛之法

复次宝女。行菩萨道。心常观察游生死者。省诸尘劳苦恼法已。则寻导御令至普安。立于法观使不忧戚灭一切苦。于诸利求不以汲汲。则为蠲除恋慕之结。亦不贪惑一切供养所获之利。则于诸利有所忘失不以忧结。观诸万物一切无常悉为苦矣。不观身法信寂泥洹。而已观察于众黎庶。如是色像观察诸法。奉行己达遵修斯法。究竟具足逮成佛道。名曰无碍。不可计会所观察者。则为如来合会宣畅。善修三昧名离三观。晓了有数海印总持也。如来普为诸天龙神阿须轮迦留罗真陀罗魔休勒释梵四天王人非人。悉供养佛无不奉事。不以为厌亦无所著。一切异学诸外道奇术犯戒众生。来娆乱之。不以忧戚其心平等。解诸所有悉无所有。其心平等。譬若如地无所不忍。犹若如水洗诸秽浊。心若如火无所不烧。心若如风普无所著亦无恋慕。心如虚空亦无结恨。等心疗治一切众生。睹寂寞行则于斯法思惟观察修于人行。所观具足常兴大哀。遍入众生度无所度。开化群萌不舍时节。从人本行而为说法。不以动摇亦不懈怠。是为如来第六不共诸佛之法

复次宝女。行菩萨道。蠲除众恶殷勤修行。求于一切善德之法。好于微妙爱乐无极。喜于至深若干之种诸善之本。弃舍声闻缘觉之事。志于大乘而不退转。兴发大哀愍于众生。思惟正义未曾忘舍。除己身想为他人故。合集一切诸佛之法。彼则以斯好乐于法不能绝去。志慕佛道。睹诸魔众倚于颠倒反邪见者。故为斯等积累正法逮成佛道。因曰如来不失正乐。以能善遵所乐三昧分别晓了。金刚总持自在于法。所可应讲而为说之。所向一时须臾之间。所归时节有所持者。众生意性如其法器。各从所行而说经法。常不违失三昧之定。是为如来第七不共诸佛之法

复次宝女。行菩萨道。常行精进。恒不舍远不厌善本。合集应德而不违废。敬于一切尊于善友。诣诸法师诸佛菩萨。亲近咨受闻其经法。奉事侍从精进无量。游无数土摄护生死。开解无限众生之类。严净无量诸佛国土。供养无量诸佛正觉。揽持无量诸佛之法。觉达无量诸佛圣慧。入干无量众生之行。晓了无量讲诸法门。彼则以斯劝法之故。究竟具足逮成佛道。斯则名曰不失精进。如来精进无所忘失。善修于斯精进之行。三昧定意神足变化。如来神足感动变化不可限量。亦现殊特开化度脱无数群萌。坚固至诚无碍阴盖。游诸佛土无所损耗亦无所行。而普周至遍于虚空。是为如来第八不共诸佛之法

复次宝女。行菩萨道。意常专秉第一执志。又恒安详究竟具足真谛之心。未曾忘失一切世俗及度世法。遵修思惟于四意止。彼则自观内身之行。而专惟于非常苦空非身之事。又观外身身之所行非常苦空非身之行。观内外身非常苦空非身之事。观内痛痒见痛痒空专修于行。观外痛痒见痛痒空。观内外痛痒见内外痛痒。思惟知空。观内心行见其内心。惟念无想。观于外心见外心行。专惟无相。观内外心见内外心。专惟无相。观于内法见于内法。行无所愿。观于外法见于外法。专无愿念。观内外法见内外法。行无愿念。彼则于身得四意止。思惟非常苦空非身。具足成就如来之身。而不断绝身之善德。以解痛痒则获意止。思惟空行察于一切诸趣黎庶而令休息一切恶趣。以设大哀除其苦患。心以解达名曰意止。专修无相亦不违失菩萨之心。稽累遵修大乘之行而不懈废。心归于法名曰意止。专修无愿。不于无欲法而取证观察佛法。等御入于无量法界。修斯法已究竟显达逮成佛道。是则名曰不失道意。如来常定志未曾忘。蠲除众行善修三昧。如来讲说变化之事。见诸众生去来现在心之所念信解诸根。度脱尘劳爱欲之行。晓了结缚因缘之着非善行业。报应罪福生死终始。知诸佛土声闻合会。体解菩萨行受决时。自说父母亲族知识朋友。心根明达而不忘之。分别八处言无一虚。是为如来第九不共诸佛之法

复次宝女。行菩萨道。常遵智慧。智慧光明。智慧威曜。智慧显识。演智锭晖圣达之慧。深妙之明。厌欲之智。意不可喻。所兴之慧达于一切。声闻缘觉慧所不能及。未曾有慧。旷达窈窕无边之慧。趣异之慧。灭定已慧。念无所住无所著慧。求闻无厌志于圣达。畅于博闻而归智慧。睹于世间如首火然。殷勤志慕大学之慧。有所听闻犹如大海。闻能分别。好乐经典乐于法乐。彼求于法故行精进。以斯法乐无有形类于内于外。而悉放舍无所吝惜。小心恭顺奉敬尊旧常受言诲。于五阴苦靡不能忍。悉舍诸安所可娱乐。彼以好法殷勤为乐。闻一四句颂。不用具足千金之宝。宁欲得闻一句之法。不志获于转轮圣王。愿乐欲求闻度无极。不贪得致帝释梵天。宁乐为人说四句颂以法布施。则不奉赖江河沙等广说祠祀供一切乏。宁乐劝人发于道意。而不用致江河沙等转轮圣王。宁乐为人讲说经典。演度无极所可遵行。而不奉获江河沙等帝释梵王。其有性行。如是成就专精听经。一心而为他人说者。如是精进所受奉行。少有及者一切诸天所见敬奉。诸佛所念。其为诸天所见拥护。诸佛念已。俗间典籍度世正经自然现矣。不学悉达则能堪任。致于无尽智慧光明。行是法已究竟具足逮成佛道。以故名曰为如来也。不共智慧真谛圣达。其明巍巍无所挂碍无有阴盖。皆知一切群萌之等心所行念善恶所归。有言无言。有罪无罪。有漏无漏。世俗度世。尘劳嗔恨。生死泥洹。皆分别说。一切法门所入圣觉。晓了讲诵一切国土满中诸尘。其智慧明知于过去当来现在之事。无所挂碍无有阴盖。劫数如是一切悉了无有蔽碍。晓了本际当来之际诸去来世。说无边际入识察行。善修三昧教授变化。如来至真以一法门。悉能分别一切法门。使一法门入一切法门。是为如来第十不共诸佛之法

复次宝女。行菩萨道。未曾志慕于居家矣。亦复不乐于舍家。而复示于出家行学。多为沙门好喜澹泊。寂然为上靖默为业。遵修精进深妙之法。而复奉行斯三脱门空无想愿。一切诸魔及外仇敌所不敢当。一切颠倒及诸邪见无能犯者化诸想着众生之类。彼则以此三脱之门而专惟行。便致无盖解脱之门。自然兴发无碍慧明。以度魔界具足圣界。不复习行一切阴盖颠倒覆蔽所处邪见尘劳众想。便以晓了无阴盖门。以三脱门而自娱乐。则分别说深奥之法。但归要义不归严饰。但归要慧不归于识。归分别要不归多辞。但归于法不归于人所归导利一切众生。美辞严饰离诸想会。讲说分别归于要义而令解脱。于色想会讲说分别归于要慧而度脱之。在于多辞而合会矣。说色平等令归正说而度脱之。依于人会分别劝化。使归于法而度脱之。假使会在六十二见。为分别说譃无之要使度脱之。设集游在一切诸想因缘之惑。解脱无想而度脱之。游在三界分别无愿而度脱之。集在欲行。解脱空净而度脱之。集在嗔恚。分别慈心而度脱之。会游愚行。解说缘起十二相连而度脱之。入于贪会。分别现说施度无极而度脱之。在犯禁众。分别现说戒度无极而度脱之。在嗔恚众。分别现说忍度无极而度脱之。在懈怠众。分别解说进度无极而度脱之。在乱意众。分别现说禅度无极而度脱之。在邪智众。分别现说慧度无极而度脱之。在凡夫众。分别现说圣谛之议而度脱之。在四倒众。分别现说无常苦空非身之法而度脱之。在于一切阴盖之蔽颠倒邪见迷惑之众。分别解说无盖脱门而度脱之。在尘劳众。分别现说十方诸佛道品之法而度脱之。行是法已究竟具足逮成佛道。所以名曰如来不失度脱。以能不失于解脱者。则无嗔怒。究竟根原无有缺减。本末清凉游诸所趣入干深妙。所逮神智而不可及甚难当矣。过于声闻缘觉之乘。普能独步于诸佛道。离秽无垢则无瑕疵。究竟清净而庄严治。寂观之业志有所说。而不可尽无量无边。则于无为无所挂碍修行平等等如虚空。善修三昧号离垢藏。皆悉照曜一切诸法。晓了总持。如来说法悉解脱想。一切所归来亲近者。普以晖曜多所开明。向于无为而崇灭度至重泥洹。究竟具足得其边际。是为如来第十一不共诸佛之法。复次宝女。行菩萨道。以慧为尊慧为势力。归于要慧讲论慧土。超越诸慧所归趣者。严治圣道。兴显所行求于超异。净修神通成一切智。修行道意具足究竟。则得圣达至诸通慧。若有欲心知有欲心之所兴发。若无欲心知无欲心之所兴发。若有嗔恚心知嗔恚心之所兴发。离嗔恚心知离恚心之所兴发。若有愚痴心知愚痴心之所兴发。离愚痴心知离愚痴心之所兴发。若有尘劳心知尘劳心之所兴发。离尘劳心知离尘劳心之所兴发。若睡眠心知睡眠心之所兴发。离睡眠心知离睡眠心之所兴发。若合会心知合会心之所兴发。离合会心知离合会心之所兴发。若冀养心知冀养心之所兴发。离冀养心知离冀养心之所兴发。若贪他心知贪他心之所兴发。离贪他心知离贪他心之所兴发。若过上心知过上心之所兴发。若无上心知无上心之所兴发。若阴盖心知阴盖心之所兴发。若无阴盖心知无阴盖心之所兴发。若无决心知无决心之所兴发。若有决心知有决心之所兴发。若有恶心知有恶心之所兴发。若有善德心知有善德心之所兴发。若有罪心知有罪心之所兴发。若离罪心知离罪心之所兴发。若有漏心知有漏心之所兴发。若无漏心知无漏心之所兴发。若世俗心知世俗心之所兴发。若度世心知度世心之所兴发。若有着心知有着心之所兴发。若无著心知无著心之所兴发。若清净心知清净心之所兴发。若薄鲜心知薄鲜心之所兴发。若众愦心知众愦心之所兴发。若习更心知习更心之所兴发。若无更心知无更心之所兴发。若边际心知边际心之所兴发。若无际心知无际心之所兴发。取要言之若悭贪心布施之心。若犯禁心奉戒之心。若嗔恚心忍辱之心。若懈怠心精进之心。若乱意心禅定之心。若邪智心以正智慧度无极心。凡夫之心圣贤之心。趣邪见心趣正见心。声闻乘心缘觉乘心若大乘心。若复晓了大道之心。又知苦谛所因而有。是为习谛。是苦尽谛斯为苦尽。向道者谛审知如有。已能晓了苦谛如有。则知本净慧无所起。究竟本末无所习慧。而知苦谛审如所有。亦无所断亦无有信令永都尽。晓了径路一切普入。而以等御犹若虚空。无有吾我无所贪爱。又其处所本来悉净。彼皆了此四谛之原。审从而有无所造证。开化众生蠲除谛愿奉行明证。若为群黎讲说经法。以所说法得真柔顺。而不迷惑乱于缘起。弃捐一切众邪异见。处入中正观因缘法。则了诸法解报应缘。不在己土不在人土。不在寿土不在命土。亦复不在众生之土。知彼无明而致斯行。知从所行而致有识。知从所识而致名色。知名色缘而致六入。知六入缘而致习更。知习更缘而致痛痒。知痛痒缘而致恩爱。知恩爱缘而致所受。知所受缘而致所有。知所有缘而致于生。知所生缘而致老死啼泣哀戚勤苦之患。如是因缘致大阴体。悉晓了空。无明已尽。行识名色六入所更痛爱受有生老病死啼泣哀戚大阴之身便永尽矣。彼造斯观。其无明缘。非己身缘。亦非人缘。无寿无命。无众生缘。设使无我无人无命无众生者。斯则为空。已知空者不计有常。亦无断灭不计无常。况断灭者。则于过去而无所生亦无所起。设于过去而无所生无所起者。则于三世而无所著。已于三世无所著者悉无所获。则无所有为自然矣。已无所有自然寂者。便则越度去来之路。已能越度去来路者则第一议。以第一议则曰正真。已为正真彼佛真辞。已佛真辞则无所诤。已无所诤则寂志法。已寂志法自然若空。从斯慧行而晓了之。从习不顺则习无明。以习无明便致行识名色六入习更痛爱受有生老病死啼泣哀戚集大阴苦身恼之患亦不蠲除。所倚诸见悉究畅知。因缘报应而合会成。已能分别无我无人无寿无命。诸法自然不受边际。亦不不受亦无所得。不得际者则无根源。已无根源则睹中正。假使不得诸法根源。于彼何缘当有中正。其中正者为何等类。彼以超度无限正法。则离彼此中间之法。便能讲说无量中正经典之要。以能奉行如是法者。究竟具足逮成佛道。是故名曰如来至真终不违损度知见慧。设能不违度知见慧。以度知见慧寻能遵修力进三昧。晓了无量自在总持。而以等御无限中正之法界也。如虚空无有想念。便则讲说无形业慧。分别报应无所忘失。演畅平等去来今事。而目睹察一切众生诸根所趣。说其精进慧之所解。分别决了无央。数身不可计形。嗟咏解说世间之行。而善建立讲无尽事。宣布显现无量之信。若干种信又分别说。一切方面诸内分部。悉能周达决无限难。诸所游步说进退慧。演无思议诸法之门。宣示一切禅定脱门三昧正受。尘劳之欲嗔恚之结。构诸黎庶终始所趣善恶中间。而悉晓了过去无数无阴盖慧。普现无量若干之变。往古世事而皆念之。又咸观察靡所不睹。而悉晓了宣布无量无盖。天眼彻视而悉说之。一切诸碍悉无有余。已能解脱除诸碍慧。一切漏尽及为慧耳。设无所有已为慧者。讲无畏慧。皆无差特平等如称。不断佛事讲说大哀势力之慧。随人本行而叹说法。赞扬诸法无有处所。开化众生则转法轮无有懈怠。差特之慧宣布深奥若干殊异。超玄无底至化弥弘。智慧之力而为感动。一切声闻缘觉之乘所不能及。是为如来十二不共诸佛之法。复次宝女。行菩萨道。兴造圣业不求名号。则以己身兴智慧业。不复设造一切身秽谀谄欺诈。无凶害行无悭贪行。常修梵行。身精进事则顺道行。不为身患不逼他人。依度无极行大悲哀。常为众生身所遵修。若兹具足。彼以斯法奉行如是逮成佛道。斯谓如来身所行事德慧自在。以身解了一切慧明。等自在已睹一切形。悉能示现诸色三昧。晓了普入总持之要。如来现已无数之形若干种像颜容之类。一切天龙鬼神。揵沓和阿须伦迦留罗真陀罗摩休勒。释梵四王。梵志君子长者居士。农夫工师细民。比丘比丘尼。清信士清信女。又无数人不可称计百千之众。悉来会坐。佛现无量威仪礼节。颜貌形像而为最尊。为长为上为极大人为无量正。而为众会讲说经法。劝化发遣多所诱进。中间没身忽然不现。众人因解。是故大会各各相合。共坐说议众人欢喜。所演智慧寂然经行。若有睹者不以为厌。若所说者益用踊跃心逮悦豫。不复欢喜一切欲乐境界财业。设没不现靡不渴仰。欲得奉觐听说经典。设有睹者。贪欲之着恩爱之见。闻所说法好乐听受。因斯报应至于无漏。身口心定而无瑕疵。获斯行业。是为如来十三不共诸佛之法

复次宝女。行菩萨道。造圣慧业不求名闻。彼口所说惟兴慧事。不为一切瑕恶谀谄佞邪所迷。所言至诚而不两舌。亦无粗辞而不谗人。言辞柔润不为犷说言辄说法。其口所宣不令己身及与他人心怀恼热。口之所说如佛教法议归于善。口之所说言辞则可众生之心。无所中伤其慧安详。言辞具足不遵修名。以此行法究竟具足。逮成佛道。斯谓如来口言等慧智德自在。彼则以此口言等慧智德自在。善修宝事三昧之定。得达三品晓了总持。如来所入以一口辞。以一法言普入一切。宣畅诸音等悦一切众会之心。如来一切所演音声。则合于议不违法理。至诚柔顺观因缘法。除诸瑕秽而离爱欲。寂定游已必当获致至诚之报乃至灭度。是为如来十四不共诸佛之法

复次宝女。行菩萨道。假使常修造智慧业不慕名色。以心思念圣慧所兴。则令众生离于瑕恶所著邪佞无明嗔恚倒见之事。遵修正见而行慈悲。等心黎庶不舍道意。遵奉慧已究竟具足。不为自大亦无慢恣。行是法已逮成佛道。斯谓如来心之所念精修圣慧志所畅达心等慧事圣明自在。彼已达已。一切慧心等圣自在。善修现在诸佛目前显立三昧。所念清净晓了鲜洁之总持也。如来一心普知一切众生心念。已心等故则能普等一切黎庶。劝助平夷心等一切。则能等已所可劝助。心犹若幻。本性清净。一切诸心自然如空。道法等御一切众生身口心行。以众生法等入己身。所修道法一切诸身犹若现影。若能以慧等御诸身。一切众生入于己身。以能等御一切诸身入己身者。发意之顷令众生身化立佛身。斯所建立无能毁者。亦无能动无能转移。天上世间诸天人民。诸魔梵志沙门梵天无能进退。是为如来十五不共诸佛之法

复次宝女。行菩萨道。闻诸过去如来至真无挂碍慧。斯诸等正觉悉普周遍一切世界。无所挂碍无有阴盖。身所行业威仪法式而悉笃信。一切世界音声本寂。靡不得入无量无尽不可思议诸佛音声。分别演说无量法门。斯诸过去如来言辞。则无有二。十方国土诸佛正觉。及众正典。普诸黎庶一切菩萨。亦复如之。达诸声闻缘一觉众一切诸人因缘罪福。所可念行。则复笃信过去如来心之所行光明之曜清净无量无有阴盖。信斯过去诸如来者。不怀狐疑亦无犹豫。不恐不惧亦无畏难。诸佛境界不可思议。晓了众生如是比像。悉乐诸法因劝助之。以行此法究竟具足。逮成佛道。斯名如来过去无量无损智慧所现自在。彼以过去自在智慧。则复善修于勇猛伏三昧之定。分别晓了威曜总持。而知过去诸如来众。各各异名寿命之限。于其中间无边之慧。欲求根源悉能尽极。过去菩萨声闻缘觉亦复如是。众生群萌所可造行。人所修业善恶祸福。有如过去一切劫数。以何等劫成为正觉。觉未觉者。于某劫中。而有若干如来至真等正觉。斯诸如来亦于彼劫。说无限量无碍之际不可尽极之根源也。又了过去诸佛世界其名各异。若有杂秽若复清净。多少大小细软微妙。尘劳限数所入之处。如其顺应十方处所。金刚罗网分别所入。诸根罗网所入境界。一切过去无有边际。诸佛国土不可究竟得其边际。如来于此一切普说斯过去事。无有捐忘悉能决了。斯诸佛慧。如人观掌视五指矣。是为如来十六不共诸佛之法

复次宝女。行菩萨道闻诸如来至真等正觉慧无挂碍。斯诸正觉普则周旋一切世界。身无央数无有阴盖。身之所行威仪礼节悉笃信之。音声畅达靡不周遍。诸佛国土皆闻法教。乃入无限所说法门。信于当来如来言辞。十方国土诸佛正觉诸法众生。一切菩萨声闻缘觉。及诸凡夫所作罪福善恶之报。又复信知当来诸佛心之所归。光明威神清净无数无有隐盖。信斯当来诸佛之行。不怀狐疑亦无犹豫。不恐不惧亦无所难。而以笃信不可思议诸佛境界。则复于斯为诸众生劝助合集。如是像法究畅信乐。行此法已究竟具足逮成佛道。斯谓如来当来无数无所损失现慧自在。彼以当来无所损慧。现自在已。则便兴发大哀之力三昧之定。晓了分别师子雷音之总持也。则能了知当来正觉各各异名寿命限量。于其中间说无边际不可尽极。得其根原。又复识知当来菩萨声闻缘觉众生群萌之所行也。黎庶行业所当遭遇祸福报应。又知当来一切诸劫。而于某劫当成正觉觉诸未觉。又于中间说所历劫。无有边际不可尽极得其根原。当来世界各各有名。杂秽清净多少大小细柔微妙。如诸尘数所有齐限。如来知其无所捐忘。而柔顺行十方处所。根原罗网之所有分。悉能普入当来无数诸佛世界。斯诸如来悉分别说。观如手掌睹五指矣。是为如来十七不共诸佛之法

复次宝女。行菩萨道闻诸现在如来至真无挂碍慧。斯现正觉其身无数而无阴盖。诸佛境界身所行业。身之所趣咸仪礼节。又其音声咸遍诸国。无所挂碍声无覆蔽。皆笃信解不可思议诸佛音响。说于无量诸法道门。斯诸现在如来言辞。而悉信乐。口所宣畅。十方国土诸佛正觉及众经典。一切黎庶诸菩萨等。声闻缘觉一切人民选择分别。此诸如来心之所行。心所兴业光明清净。不可计数无有阴盖。皆复信此现在如来。不怀狐疑无有结滞。不恐不惧亦无怖懅。诸佛境界不可思议。又复劝化于他众生。如是色像信乐经典。行法若斯具足突竟逮成佛道。斯谓如来现在无数无所损失现慧自在。彼以无数现在如来无损智慧现已自在。则便善修离垢照印三昧之定。晓了分别金刚道场之总持也。如来现在普能分别。诸佛名号各各差特。寿命之限悉能宣布。中间回绝而无边际。不可尽极得其根原。现在一切诸菩萨众。声闻缘觉众生之行。群萌事业罪福报应。现在十方诸劫之数。于其劫中成为正觉。说其根原。现在十方一切国土。各各有名。杂糅清净多少大小柔软微妙悉得普入。如尘数限随其所顺。十方处诸谛根罗网。悉入现在十方世界。于其中间无限边际。不可尽极得其根原。如来于彼。所说分别无所损耗。此诸如来选择智慧。如观手掌察其五指。是为如来十八不共诸佛之法

是十八品。便得一切不共诸佛之法。何谓不共诸佛之法。无能睹见如来顶相。是为不共诸佛之法。身无限故。如来超殊一切诸形。是为不共诸佛之法。一切人中为最尊故。众生见佛瑕秽消除。是为不共诸佛之法。身如药故。如来之行英妙超殊。是为不共诸佛之法。无罪舋故如来无惧。是为不共诸佛之法。得无畏故如来独步。无有诸漏而得自在。是为不共诸佛之法。遵平等故。如来之心行无所坏。是为不共诸佛之法。晓了贤圣之教诫故。如来调定志性和雅。是为不共诸佛之法。坚住建立于己行故。如来之辩应时而对。是为不共诸佛之法。讲说经典无言教故。如来可悦一切众生心之所念。因曰如来。是为不共诸佛之法。无所进故。如来音声普闻众会。不溢在外。是为不共诸佛之法。讲说经法而不虚妄。开化应度。救济诸根令纯淑故。一切众会在于道场。亲近睹见如来颜貌。是为不共诸佛之法。变化感动无思议故。瞻察如来无有厌足。是为不共诸佛之法。如大德无极树宝柱。大圣体故。如来说法无所侵枉。是为不共诸佛之法。平等觉故。如来之身不可谛视。是为不共诸佛之法。威仪礼节无希望故。如来之身如师子步。是为不共诸佛之法。于大众中无所难故。如来游步无有虚妄。是为不共诸佛之法。智慧为本身造行故。如来之行音声真谛。是为不共诸佛之法。智慧元首口辞真故。如来之眼普视无边。是为不共诸佛之法。圣慧为上心明达故。如来教授言辞显曜。是为不共诸佛之法。卒对辩故。如来利养名闻流溢。是为不共诸佛之法。无上正真不可尽故。如来之福不可尽极。是为不共诸佛之法。第一分别了诸碍故。成为如来无能当者。是为不共诸佛之法。为大钩锁力士之身。而有十力四无所畏。第一最上度无极故。如来无倦常不退转所说不懈。是为不共诸佛之法。晓了一切众生根故。又如来者。为无数法而作圣师。是为不共诸佛之法。普于诸世独尊师故。寿命无量。是为不共诸佛之法。显法身故。其睹如来若闻音声。亲近稽首无有虚妄。是为不共诸佛之法。为究本末人稽首礼。即令众生至大安故。如来之慧无有结恨。是为不共诸佛之法。解达三世平等之故。如来讲说无有中间是为不共诸佛之法。顺法本故。如来蠲除一切挂碍。是为不共诸佛之法。诸不善法永无余故。如来无师。是为不共诸佛之法。已自然达诸法之故。如来普智。是为不共诸佛之法。分别诸觉晓了大道无有余故。是为皆得一切不共诸佛之法

宝女所问经卷第三宝女所问经卷第四

        西晋月支三藏竺法护译

    三十二相品第九

于是宝女问世尊曰。唯然大圣。今所可谓如来至真三十有二大人之相。前世宿命行何功德。而致逮得三十有二大人之相。遍布在体。佛告宝女。吾往古世行无量德合集众行。如来由是逮得三十有二大人之相遍布于体。今粗举要。如来之相。足安平立大人之相者。乃往古世坚固劝助而不退转。未曾覆蔽他人功故。如来手足而有法轮大人相者。乃往古世兴设若干种种施故。如来至真指纤长好大人相者。乃往古世则说经义救护众生令无患故。如来手足生网幔理大人相者。乃往古世未曾破坏他人眷属故。如来手足柔软微妙大人相者。乃往古世而以惠施若干种衣细软服故。如来而有七合充满大人相者。乃往古世广设众施供诸乏故。如来之膝平正无节[跳-兆+專]肠如鹿大人相者。乃往古世奉受经典不违失故。如来之身其阴马藏大人相者。乃往古世谨慎己身远欲法故。如来之身颊车充满犹如师子大人相者。乃往古世广修净业修行备故。如来至真常于胸前自然卍字大人相者。乃往古世蠲除秽浊不善行故。如来肢体具足成就大人相者。乃往古世施以无畏安慰人故。如来手臂长出于膝大人相者。乃往古世人有所作佐助劝故。如来身净而无瑕玼大人相者。乃往古世奉行十善无厌足故。如来脑户充满弘备大人相者。乃往古世其有病者。苦干种药瞻视疗故。如来师子步大人相者。乃往古世殖众德本具足备故。如来四十齿白大人相者。乃往古世志性等仁于众生故。如来牙齿无有间疏大人相者。乃往古世设人诤斗令合和故。如来颔牙大人相者。乃往古世则以微妙可意之物而兴施故。如来清白美好发眉大人相者。乃往古世善自护己身口心故。如来广长舌大人相者。乃往古世所言至诚护口之过故。如来舋舋大人相者。以无量福供养究竟。心行仁和与众生愿使得覆盖。如来梵声哀鸾之音大人相者。乃往古世言语柔和。与众人言护口节辞。无央数人闻其所语无不悦故。如来瞳子绀青色大人相者。乃往古世常以慈目察众人故。如来之眼如月初生大人相者。乃往古世无粗暴志心性和顺故。如来眉间白毫大人相者。乃往古世咨嗟歌诵闲居之德众人行故。如来顶上肉髻自然大人相者。乃往古世敬奉贤圣礼尊长故。如来肌体柔软妙好大人相者。乃往古世心念念集法品藏故。如来身形紫磨金色大人相者。乃往古世多施衣服卧具床故。如来之体一一毛生大人相者。乃往古世离于集会众闹之故。如来之毛上向右旋大人相者。乃往古世尊敬于师受善友教稽首从故。如来头发绀青色大人相者。乃往古世愍伤群黎。不以刀杖而加害故。如来之身平正方圆无有阿曲大人相者。乃往古世己身众生。劝化安之令定意故。如来之脊如大钩锁普有威曜巍巍之德大人相者。乃往古世为诸正觉。兴立形像缮修坏寺。其离散者劝使和合。施无畏惧。其诤讼者化令相顺故。女欲知之。吾往世时。行于无量不可计会众德之本。如来宿世奉行如斯。乃能致此三十有二大人之相

尔时宝女白世尊曰。至未曾有天中天。如来往古所造德本诚不可及。而分别说诸佛之法。佛告宝女。如是如是如汝所言。如来则为分别解说诸佛之法。若有菩萨逮得闻此如来往古所殖德本诸佛所讲。则获善利无极之庆。即当归趣于真谛行。咸能具足诸佛之法。佛说于斯如来十力四无所畏十八不共诸佛之法。及三十二大人之相法门品时。十方世界六反震动。甚大光明普照佛土。不可计量众生之类。皆发无上正真道意。二万五千菩萨得不起法忍。天于虚空百千之众。而雨天华鼓天上乐。琴笛箫瑟举声叹曰。其有众人。逮得闻此如来十力四无所畏十八不共诸佛之法三十二大人之相。功德具足无有罪咎。信乐不疑行如上教。则于大众天上世间天人之前演师子吼。犹如今日如来至真等正觉矣。天人之前而师子吼。所以者何。斯正典者终不归趣下劣少信。处于小乘众人之首。当归清净遵修法者。其人得此经典之要。爱敬可意欣悦踊跃

    法行品第十

于是宝女。白世尊曰。至未曾有天中之天。如来乃讲往古去世一切德本诸佛正典。何谓世尊。菩萨所行遵修经典为行法乎。善哉世尊。愿说菩萨所行之法。佛告宝女。志性清净则为菩萨所行法也。坚固亲友则为行法。有反覆者则为行法。能修加恩则为行法。能忍骂詈则为行法。又归命者而不弃损则为行法。其羸劣者能为忍辱则为行法。所难致者而能施与则为行法。慈哀诸身则为行法。志性愍伤则为行法。护于犯戒则为行法。思惟经典则为行法。将顺道教则为行法。好乐正典则为行法。将御诸经则为行法。而顺寂然则为行法。而乐独一则为行法。不厌闲居则为行法。等于屏处则为行法。舍于众会则为行法。护于众生则为行法。所睹无损则为行法。专修慈心则为行法。入于大哀则为行法。欢喜爱法则为行法。观于禅思则为行法。兴显道心则为行法。叹大乘法则为行法。弃捐重担则为行法。心不怯弱则为行法。思惟止足则为行法。弃捐贪余多欲之悭。则为行法。知节贤圣有足之德。而少言辞则为行法。无有诤讼斗乱怨恚。忍辱仁和则为行法。信知报应罪福之业。则为行法。信戒闻施惭耻智惠。顺此七财则为行法。奉敬尊长顺从善友。恭礼受命则为行法。心常谦卑恭顺自损。则为行法。不自毁身不呰他人。不叹己德不蔽他功。则为行法。蠲除尘欲弃捐嗔恚及愚戆冥。离于憍慢则为行法。威仪礼节所遵具足。则为行法。善听经典欢喜悦豫。则为行法。不离于佛笃信正典敬从圣众。则为行法。布施调意智慧出家净修梵行。则为行法。得利无利若誉若谤。有名无名若苦若乐不以动摇。以过世间之所有法。则为行法。若见亲友及与怨敌。先人问讯面色和悦而无愁悴。则为行法。无有调戏离于闇昧而无谀谄。不为邪性而无瑕玼。志性本末究竟清净。则为行法。而行四恩惠施仁爱。利仁等利一切合集救济众生。则为行法。行坚固法则为行法。念佛念法念于圣众。思念布施念奉禁戒思念诸天。则为行法。施度无极戒忍精进一心住慧所度无极。则为行法。善权方便劝助一切众德之本为诸菩萨。则为行法。身口意净护于十善。则为行法。非常苦空而无有身。无人无我无寿无命。信解如此则为行法。分别空行建立无想。晓了无愿。在于三界而无所著。则为行法。意止意断遵修神足。根力觉意而入径路观乎寂寞。则为行法。佛告宝女。其行法者。谓无有眼亦无眼行。无色想行。无有耳行亦无声行。不想响行。无有鼻行亦无香行。不想香行。无有舌行亦无味行。不想味行。无有身行无细滑行。不想细滑。而无意行亦无法行。不想法行。亦无色行则为法行。无色想行无色苦想。无我色行不寂色行。则为行法不空色行非色无想行。则为行法。非色无愿行。非色无造行。亦复非色恬怕之行。亦复非色清净之行。亦复非色如审之行。亦复非色无生之行。亦复非色无起之行。亦复非色无著之行。亦不究竟色之所行。亦非于色无本为行。是则行法。如是痛痒思想生死识行。则为行法。非识无常行。非识苦行。非识无我行。非识寂行。非识空行。非识无想行。非识无愿行。非识非无造行。亦复非识恬怕之行。亦复非识清净之行。亦复非识如审之行。亦复非识无所生行。亦复非识无起之行。亦复非识无著之行。亦复非识究竟尽行。亦复非识无本之行。则为行法。亦复非识睹空之行。亦复非识无想之行。亦复非识无愿之行。是则行法。亦非四种行。亦非诸入行。亦非欲色无色之行。是则行法。亦非有行亦非不行。亦复无行。是则行法。亦非往至亦非不行。亦无处所亦无所住。则为行法。无心意识之所行者。则为行法。是名曰为行法矣。其无有见不闻不知之所行者。是为行法。若使无身口心之行。是为行法。其不行法不行非法。是为行法。若无二行无若干行。是为行法。无过去行无当来行无现在行。是为行法。其无阴行无诸种行。无众入行。是为行法。无欲尘行无有结恨无所念行。是为行法。若无合行无财业行。无我人寿命行无有含血。若有所受同像之行。是为行法。其无发起分数之行。是为行法。其无吾我无己所行。是为行法。无断灭行不计常行。不得诸见崖底之行。不倚中行。是为行法。诸法若住若无所住。吾我之法处所自然。其处非处清净法处。一切法处皆无有处。空无之处究本末处至竟无处。一切诸法无动无著。不可尽极。亦无所有亦无所行。亦无轻戏亦无所依。亦无不依亦无所住亦无所受。其于是法晓了慧者。慧无所念。是曰谛。真谛无本则法之慧。设使宝女。菩萨如是晓了诸法。游在生死开化众生。亦不违失灭度之法。斯为菩萨等造法行。世尊说此行法之时。八千菩萨逮得法忍

    不退转品第十一

于时宝女。即以十亿百千贵价珠璎。贡上大圣口宣斯言。唯然世尊。其有菩萨遵修奉顺此法行者。则具佛法悉能普备。如兹受决处佛道场。降伏众魔怨敌之仇。以不退转印而印之。当造斯观。时舍利弗谓宝女曰。汝岂能知诸菩萨行不退转印所可印乎。于时宝女答舍利弗以偈颂曰

  人界及法界　　审谛解平等
  了斯无二际　　则不退转印
  其过去诸佛　　当来并现在
  法界皆平等　　逮成不退转
  诸所有境界　　并无为之界
  寂寞转空议　　觉成不退转
  本际无崖底　　不得其边畔
  一时等能解　　觉了不退转
  其有方俗法　　如行之所趣
  智慧观平夷　　觉了不退转
  如魔之境界　　佛界则平等
  相应为一类　　以是印见印
  其淫怒痴者　　欲尘不可限
  觉了诸想着　　达解不退转
  生死及无为　　道教则寂然
  等解于灭度　　觉了不退转
  五阴道如之　　有二分别慧
  犹如幻貌像　　明哲无思想
  计于四种者　　犹如虚空界
  晓了无可取　　真印而见印
  觉眼则为道　　解空无所著
  若眼道如之　　以等上平等
  诸入皆如是　　道空常平均
  当作是了知　　以此印见印
  众生之所念　　一心悉知之
  则无所挂碍　　斯故不退转
  一切群萌根　　卑劣妙中间
  于彼度无极　　逮成不退转
  辩才无挂碍　　无逝无所住
  亿劫中诵说　　其法不可尽
  虚空尚可尽　　风可尚执持
  彼明辩才慧　　则不可尽极
  总持行如斯　　揽摄一切法
  名德不违心　　不失于博闻
  其十方诸佛　　导师所说法
  皆得于总持　　慧心念不忘
  于过去千劫　　所闻大圣法
  咨问真谛教　　善学于总持
  斯等总持然　　辩才亦如之
  智惠及诸根　　逮成不退转
  以空印诸法　　无著无所拔
  以印印于空　　故曰不退转
  虚空印诸法　　清净无所有
  晓了此本际　　以印不退转
  诸因缘法无　　因缘其惟行
  因缘则非真　　谛相一切法
  诸法相犹幻　　犹如虚空相
  以是相印之　　印于不退转
  一切众生行　　色声之礼节
  一时普能现　　觉了不退转
  于施舍无量　　功德常无尽
  供养虚空界　　至诚命为一
  禁戒高无极　　怀来致佛戒
  无限无有量　　等游若虚空
  一切众生禁　　学不学缘觉
  及不退转戒　　十六分无伦
  忍辱悉尽极　　遵修无所生
  成就此忍辱　　逮成不退转
  精进无限量　　方便不可极
  悦可群萌类　　精进为大仙
  常为专志定　　无乱善谨慎
  普见一切法　　无诤定三昧
  逮无碍智惠　　净除所睹处
  得佛之尊行　　净土令成就
  慧飞度无极　　善学于善权
  以佛印见印　　遵修于道行
  其行不可知　　志性何所疗
  积行无边际　　开化于众生
  诸声闻缘觉　　一切魔异学
  缘不能及知　　大人之所行
  彼不着诸行　　感动神足定
  解空无所有　　皆读逮所兴
  来过而出生　　示现佛形像
  坐于佛树下　　则转于法轮
  普现诸国土　　面见十方佛
  譬若如日月　　等游于虚空
  示现取灭度　　随大信乐乘
  不违示斯印　　其印不退转
  无限如虚空　　智慧普若斯
  不退转之法　　晓了道如斯

于是宝女。说此颂已不退转印时。三千大千世界为大震动。五千菩萨得不退转受别之印。世尊则赞彼宝女曰。善哉善哉快说斯言。能演菩萨不退转印

    大乘品第十二

于是贤者须菩提白世尊曰。唯然大圣。如今斯女。不退转印而见印矣。不复疑也。乃能有斯如此像类上妙辩才也。设不尔者无缘讲说若兹深法。佛言。如是须菩提。诚如所云。如斯宝女。不退转印而见印矣。以逮法忍。乃得入斯大乘之行。于时宝女前问佛言。所云大乘为何谓乎。佛告宝女。所谓大乘弘广之乘。慰抚一切众生之类故。无有阴盖。示现一切众德异惠故离垢之乘。舍诸尘劳窈冥事故。普照之乘。一切所解脱门相故。显曜之乘无欲着故。随因缘乘脱所挂碍故。清净之乘护戒品故。等善住乘。而谛慎护定品之故。无漏之乘选惠品故。解脱乘者照解品故。等现一切诸法乘者。晓了度知见品之故。不进退乘者摄十力故。无惧乘者。四无所畏师子吼故。无所往至离处乘者。摄受诸佛十八不共殊胜法故。普平乘者。等行慈心加众生故。无害乘者。则以正法抑制一切诸外学故。消除乘者。降伏一切魔官属故。寂灭乘者坏尘劳故。降化乘者。伏阴魔故。离限乘者。越死魔故。殊胜乘者。弃天魔故。豪富乘者。则能具足施度无极故。无热乘者。戒度无极则具足故。弃怨乘者。忍度无极则具足故。坚无坏乘者。进度无极则具足故。断除一切诸所自在瑕玼之乘者。心离阴盖故。所修乘者。寂度无极则具足故。一切善德一切智惠世俗之事度世之法所遭乘者。智度无极则具足故。普御随行一切乘者。权度无极则具足故。至无至乘趣灭度故。归安乘者建八路故。其所至到无处乘者。遵修奉行观寂之故。根力觉意具志乘者。一切诸魔及诸异学无瞻颜故。四神足乘。则能普现诸佛国故。等能超度正谛住乘。蠲除一切诸不善法。遵修众行德善法故。善修谨慎意止乘者。无内怨故。假使不着三界乘者。奉无漏故。不著有为诸界乘者。逮得无为显曜界故。不舍道心御善住乘。不乐一切声闻缘觉所行惠故。超越乘者。则能施以无见顶故。庄严乘者功德成故。选择众生志性乘者。究竟慧故。阐门乘者。所可词祀无所逆故。一味乘者等佛惠故。洪音乘者十方闻故。一切诸天普礼乘者。善修业故。释梵四王所叹乘者。德无量故。其有悭贪能施乘者为元首故。若有犯禁施惠戒乘者。谓大乘故。志怀嗔怒施忍乘者。不加害心于众生故。其懈怠者施精进乘。被坚固铠未曾舍故。其乱心者施禅定乘。令心调定业仁贤故。其邪智者施正惠乘。博闻解故。惠施众安除苦患乘。不造一切众恶之故。佛之圣道无挂碍智无等伦惠所示现者。皆处一切诸乘顶故。以是之故为大乘也。佛讲说此大乘议时。万二千人发无上正真道意。口说斯言。吾等亦当乘斯大乘。令无数人众生之类。皆使得立于此大乘

于是宝女白世尊曰。唯然大圣。其大乘者。有何堑路。而不疾归诸通之惠。佛告宝女。行大乘者。有三十二挂碍堑路。以此堑故不疾得成诸通之慧。何谓三十二。乐声闻乘(一)。志缘觉乘(二)。求释梵处(三)。倚着所生净修梵行(四)。专一德本言是我所(五)。若得财宝悭贪爱吝(六)。以偏党心而施众生(七)。轻易戒禁(八)。不念道心专精之行(九)。嗔恚之事以为名闻(十)。其心废逸(十一)。而心驰骋(十二)。不求博闻(十三)。不察所造(十四)。贡高自大(十五)。不能清净身口心行(十六)。不护正法(十七)。背舍师恩(十八)。弃舍四恩(十九)。离坚要法(二十)。习诸恶友(二十一)。随诸阴种(二十二)。不劝助道(二十三)。念不善本(二十四)。所发道意无权方便(二十五)。不以殷勤咨嗟三宝(二十六)。憎诸菩萨(二十七)。所未闻法闻之诽谤(二十八)。不觉魔事(二十九)。习恃俗典(三十)。不肯劝化于众生类(三十一)。厌于生死(三十二)。是为三十二事违失大乘堕于堑路。其堕堑路不能疾成诸通之惠。又复宝女。其学大乘之威神德。以此之乘堕于堑路。所以者何。其于斯乘有为之秽。不如所乘为大乘者。则堕堑路。若以于彼无为之德。如斯行乘为大乘者。名闻之德。计于彼乘。于如来心即为尘劳一切不顺。于斯大乘悉堕堑路。其于斯乘着如来觉。德称之故。如是乘者大乘之德故堕堑路。是故宝女。菩萨大乘当弃尘劳所慕法乘。以斯之法致净大乘。当习此法思惟奉行合斯恢弘。何所是法净致大乘。有三十二法致净大乘。何谓三十二。于诸众生无请之友故。真谛究竟为他人故。志性坚强遵修众德行不以厌至德成故。心无愦乱志性净故。其身清净威仪礼节无想念故。口言清净言行相副故。其心清净不舍道心故。布施清净不望报故。戒行鲜洁护犯禁故。忍清净者不惜身命故。精进清净十力无畏具足故。禅定清净一切尘劳无杂错故。智惠清净蠲除一切挂碍之故。清净心者降伏一切众魔之故。坚固行者度诸愿故。习诸四恩不舍众生故。于佛反覆护正法故。以不懈惓则能具足道品法故。所闻无厌具圣智故。其欢喜者转加胜故无慢善圣以能致到无见顶故。于一切法无诤讼者。因缘报应所见和故。无贫匮者获七财故所以不仆由自在故。德慧成就不失通故。灭除众生之尘劳者。定于寂然成就之故。如来惠解所变化者具足观故。睹三脱门所示睹者。遵修于空无想愿故。澹泊内者。令诸众生觉了分别寂然惠故。兴尽惠者不起法忍故。修行一切诸法要者。致受别故。佛言宝女。是为三十二法净致大乘。说此三十二事法品典时。七万二千天与人。皆发无上正真道意。万二千菩萨得不起法忍。天于虚空百万之众咨嗟叹吒。雨于天华鼓诸伎乐。各各举声而歌颂曰。其有逮闻于此大乘名德之称。斯等众生振救建立诸佛之德。其闻信乐笃信以后。若执持者审谛奉行。复超此功

    嘱累品第十三

于是天帝释。梵忍迹天王。四大天王。白世尊曰。至未曾有天中之天。乃能善说深奥应议。讲斯经典多所导利。灭诸阴盖及众尘劳。化不顺议示导正义。以降魔怨。弃捐一切诸外异学。总摄一切诸佛之法。是故世尊。吾当受持于斯法典讽诵讲说。若诸法师。揽受奉持此经卷。归身手执若在其舍。书着竹帛宣布远近。诸天龙神及揵沓和。若信是经欲奉持者。当令斯袖宽弘无役。其不悦乐而察阴盖者当令谛受。而使斯等不犯法师不有所娆。于是世尊告天帝释梵忍迹天四大天王。善哉善哉诸仁者等。汝等乃欲将护法师。晓了志愿已能将护于法师者。诸仁者等则为拥护于正法矣。已能拥护于正法者。则为拥护一切群萌

尔时世尊告贤者阿难。汝当受此经卷之品宝女所问正法之典。受持讽诵为他人说。假使菩萨于百千劫。而行布施忍辱者。设有菩萨取是经法。受则上口而讽诵者为他人说。建立大哀欲度众生。具足大慈思惟经法立于忍辱。斯之获德出彼福上。速疾得归于此大乘。贤者阿难白世尊曰。吾寻奉受斯法典已。唯然大圣。斯之经法名曰何等。云何奉行。佛告阿难。斯之经法。名曰真谛晓了义律达门之品当持。又名无量之德发意所说当持。如来十力四无所畏十八不共诸佛之法分别诸相。菩萨应时遵修法行。说不退转轮印讲演大乘当奉持之。聚会之品宝女所问当奉持之。阿难。汝若能持此法门品为他人说。便获无量名德诸法法之光曜。则为众生建立佛事。所以者何。是为去来今现诸佛世尊究竟之法。佛说如是。宝女阿难一切众会诸天人民阿须伦世间人闻经莫不欢喜

宝女所问经卷第四


宝星陀罗尼经

    宝星经序

        唐释法琳撰

宝星经梵本三千余偈。如来初证觉道。度目连身子。及降伏魔王。护持国土。说此经也。自象化东渐。绵历岁时。三轮八藏之文。四树五乘之旨。显神光于石室。流梵响于清台。虽鞮译相寻尚多疑阙。我大唐皇帝。乃圣乃神。允文允武。乘机抚运。拯溺救焚。反上皇之风。行不言之信。去泰去甚。既揜顿于八弦。无事无为。乃朝宗于万国。瀚海天山之地。尽入提封。龙庭凤穴之卿。咸沾声教。仁踰解网。治踵结绳。大德闲闲。外齐八则。小心翼翼。内整四仪。临赤县而溢慈悲。寄玄扈而敷弘誓。每以诸有非乐。物我俱空。眷言贞要。无过释典。有中天竺国三藏法师波颇。唐言光智。誓传法化。不惮艰危远涉葱河。来游真丹。以贞观元年景戍。洎于京辇。既登上席。爰懋锦衣。有诏所司。搜扬硕德。兼闲三教。备举十科者。一十九人。于大兴善寺。请波颇三藏。相对翻译。沙门慧乘等证义。沙门玄謇等译语。沙门慧明法琳等执笔。承旨殷勤详覆。审名定义。具意成文。起贞观三年三月。讫四年四月。凡十卷十三品。用纸一百三十幅。总六万三千八百八十二言。归命一切佛菩萨

    No. 402 [No. 397(9)]

宝星陀罗尼经卷第一

        唐天竺三藏波罗颇蜜多罗译

    降魔品第一

如是我闻。一时婆伽婆。住王舍城竹林迦兰陀池边。与大比丘众一千人俱。皆阿罗汉。诸漏已尽。所作已办。舍诸重檐。逮得己利。尽诸有结。皆得正知。心善解脱。及大菩萨一万人俱。其名曰持须弥顶童真。水智童真。地智童真。胜智童真。空智童真。明智童真。电智童真。文殊师利童真。降伏胜童真。水天童真。无垢童真。弥勒菩萨摩诃萨等而为上首。一切皆得羼提陀罗尼三摩提。具足一切法无障碍智。于一切众生其心平等。过诸魔界。善入一切如来智境界。具足大慈大悲善解方便智。皆随佛住王舍大城竹林迦兰陀池边

尔时王舍大城有二外道。聪慧明达过十八明处。与五百人俱。一名优波底沙。二名俱利多。而为上首。共相谓言。契同甘露。尔时长老阿说示(唐言马胜)于日初分着衣持钵。入王舍大城乞食。时优波底沙。见阿说示生希有心。我未曾见如此沙门威仪庠序。更无有人如彼比丘。我应往问。今此长老以谁为师。依谁出家。依谁求法。尔时优波底沙即往彼所到已问讯。种种语已却住一面。白长老阿说示言。以谁为师。依谁出家。依谁求法。尔时长老阿说示答优波底沙言。有释种子。勇猛精进能大苦行。于一切处最上自在。已度生死无边大海。今以大悲欲度众生。号名为佛。觉悟众生干竭苦海无与等者。我常归依求无垢法。优波底沙言。彼师为汝说何等法。以何教示。时长老阿说示答优波底沙曰。善哉快哉。谛听谛听。当为汝说。便说偈言

  烦恼业因缘　　世间如是转
  烦恼业不生　　导师如是说
  生老死定坏　　彼解脱无上
  如彼勇牛王　　如来自悟说

尔时优波底沙闻此法已。远尘离垢法眼清净。得须陀洹果。而说偈言

  我证解实法　　永竭生死河
  所谓如来说　　难得甘露藏
  众生得息苦　　智慧能断除
  诸法种种修　　能作究竟道
  行此究竟道　　得无等涅槃

尔时优波底沙说此偈已。白长老阿说示言。长老汝师如来阿罗诃三藐三佛陀今在何处。阿说示答言。长老。我师如来。今在王舍城竹林迦兰陀池边。与大比丘众一千人俱。本是外道值佛出家。优波底沙言。我今辞善知识及诸眷属诣佛出家。尔时优波底沙礼阿说示足。右绕三匝辞已而去。往俱利多所。时俱利多见优波底沙从远而来。见已白优波底沙言。仁者。诸根清净颜色怡悦必得甘露。优波底沙言。如是长老。我于今者得甘露法。谛听谛听。今为汝说我所得法。尔时俱利多即从坐起。偏袒右肩。右膝着地。合掌恭敬。便说偈请

  说此吉祥无忧道　　此道疾度三界海
  分别诸阴大怨贼　　乘此道已不还有

尔时优波底沙以所闻偈。即为说之

  烦恼业因缘　　世间如是转
  烦恼业不生　　导师如是说
  生老死定坏　　彼解脱无上
  如彼勇牛王　　如来自悟说

尔时俱利多闻此偈已心大欢喜。重更赞叹请说前偈

  苦灭寂无垢　　牟尼说此法
  一切烦恼灭　　诸见无知断
  秽恶有为空　　无我不可信
  重说无垢句　　我闻得涅槃

尔时优波底沙。即便重为说所闻偈

  烦恼业因缘　　世间如是转
  烦恼业不生　　导师如是说
  生老死定坏　　彼解脱无上
  如彼勇牛王　　如来自悟说

尔时俱利多闻此偈已。远尘离垢法眼清净。得须陀洹果。复以偈赞

  如此真行法　　度流之疾船
  此智息三苦　　能度于世间
  诸阴烦恼魔　　知此能调伏
  解脱离怨诤　　干竭于苦海

时俱利多言。今佛世尊住在何所。优波底沙言。长老。我闻世尊在王舍大城竹林迦兰陀池边。与大比丘僧及菩萨众俱。我今定当与汝俱往至世尊所求佛出家。俱利多言。如是长老。可语弟子往世尊所相随出家。时优波底沙与俱利多往自众所。尔时恶魔于一念顷。闻中摩伽陀国有二外道。优波底沙共俱利多及诸眷属。聪明具足名称广远。是善丈夫。欲于沙门瞿昙法中出家学道。彼作是念。呵奇哉。若此二人于彼沙门瞿昙法中而出家者。空我境界。我应至彼二丈夫所。破其出家令着恶见。尔时恶魔于一念顷从自宫没。作阿说示形相威仪。便于中道现二人前。作如是说

  如我先所说　　试汝非决定
  如汝意所行　　宜速受欲乐
  一切黑白业　　因果悉皆无
  无生老病死　　亦无于后世
  福非福果业　　无有此因作
  释子为利说　　汝莫信故去

尔时优波底沙俱利多闻此说已咸作是念。此恶魔来欲坏我等出家之事。尔时优波底沙顾谓弟子作如是言。汝等今者当忆世间所有过患。便说是偈

  众生为老逼　　死苦之所缠
  应当断彼二　　决定当出家

尔时俱利多即以偈颂答魔王曰

  知无上善智　　持法灭三苦
  汝说不断贪　　我智终不动
  如是坚固心　　于余人所无
  我等出苦轮　　正智所不惑
  勿假师子像　　而作野干声

尔时见谛诸天住虚空中赞二丈夫言。善哉善哉。汝二丈夫。于一切众生中最为上首。此道胜妙。于一切世间最为第一。此道息一切苦。此道入一切如来行处。此道一切诸佛所共称扬。所谓依佛出家。是时恶魔心生忧苦便没不现

尔时优波底沙共俱利多。自观己众唤诸弟子作如是言。汝等应知。我等欲度老死苦海故依佛出家。汝等若不乐佛出家可于此住。时五百弟子咸作是言。我等解法皆依师学。二师决定大处出家。二师所依出家处。我等随师。亦依彼众出家学道

尔时优波底沙及俱利多。与五百徒众欲往佛所。是时恶魔知彼事已。于王舍城外化作大坑。深百由旬。令彼二人不得往诣佛世尊所。是时如来以神通力。令彼二人不见大坑直道而去。是时恶魔于二人前。复更化作高峻大山。高千由旬。峻崄坚岨无有穿缺。于彼山中复更化作一千师子。威猛可畏。是时世尊以神通力加彼二人。不见大山及彼师子。又无威猛可畏之声。直道而往诣世尊所。及彼无量百千之众。围绕供养说法之处

尔时世尊告诸比丘。汝等见彼二善丈夫为众上首。与诸徒众来至我所。汝等见不。诸比丘答。咸言我见。佛言。此善丈夫及诸徒众我边出家。一人于我一切声闻弟子之中智慧第一。一人于我声闻众中神通第一

是时众中有一比丘。以偈赞曰

  此二聪睿眷属俱　　利益上者佛已记
  具智神通无所畏　　故我承迎二丈夫

尔时彼比丘说此偈已即从坐起。与无量比丘众及出家优婆塞等迎彼二人。善言问讯。时彼二人往到佛所。到已顶礼佛足。右绕三匝住立佛前白佛言。世尊。我等今者求佛出家。受比丘戒修行梵行

佛言。善男子。汝二人名字何等。优波底沙言。底沙是父。舍利是母。我今从母。故名舍利弗。父母今者听我出家。俱利多言。憍陈如是父。目伽罗是母。我今从母故名目伽罗父母今者听我出家

佛言。汝等二人及诸眷属。可于我所出家具足修行梵行。作是语已。时此二人成具足戒。五百徒众未久之间。亦同二师得具足戒

尔时恶魔即自化身作摩醯首罗像。住立佛前说如是偈

  世间利智能议论　　方便胜智到彼岸
  彼等悉来顶礼我　　我是彼等大导师
  瞿昙弟子并眷属　　一切宜速归依我
  我今为汝当广说　　安隐寂灭善妙道

尔时世尊。以偈答曰

  汝所说道趣恶道　　众生行者沈苦海
  我道能令动不动　　世间苦海悉干竭
  何故骜慢耐无耻　　复作矜高野干声
  我今退破汝魔事　　不复于我能所作

尔时恶魔变摩醯首罗像。即没不现复作梵天王像。住于佛前。说如是偈

  烦恼有业芽　　智慧已斩除
  何故强于此　　勤苦利众生
  于世无自在　　以无堪道器
  牟尼病已除　　宜速入涅槃

尔时世尊。即以偈颂报魔王曰

  我观诸众生　　过彼恒沙量
  以大慈悲力　　教化令解脱
  上中下众生　　令世间解脱
  众生解脱已　　然后乃涅槃
  何故以恶惠　　诈谄请于我

尔时恶魔心生忧悔。于佛前没还自天宫。入忧恼室默然而坐。当于尔时一刹那顷。魔诸眷属互相推问。今我大王以何因缘。入忧恼室无人知者。尔时魔王五百妓女种种庄严。各持华鬘末香涂香。鼓天伎乐五百音声。第一微妙歌舞戏乐。甚可爱乐集魔王前

尔时魔王悲啼握手抑止悲声。如是作已暂时默住。诸妓女等复更歌舞。作欣悦状令魔欢喜。尔时魔王举手大叫作如是语。莫声莫声乃至七返。诸伎女等默然而住。尔时魔宫有一妓女名电可意声。至魔王所曲躬合掌。说如是偈

  汝今居自在　　如见死相忧
  为是担重担　　今乃生怖懅
  谁有胜力怨　　而忧不欢悦

是时魔王说偈报曰

  我有大怨调伏心　　善学幻术释迦子
  我无方便能坏彼　　如是不久欲界空

时彼妓女便说偈曰

  大家方便甚无量　　勤力坏彼必无余
  三有长缚谁能解　　贪海沉没谁能竭

是时魔王说偈报曰

  檀那及苦行　　悲愿为罥索
  持空无相弓　　器仗中第一
  能断于生死　　诸有尽无余
  以空为城林　　弟子居山谷
  精勤常修定　　尽诸有过患
  方便神通力　　慈悲为伴助
  优波俱利等　　牟尼悉降伏
  于彼三界中　　方便善调摄
  欲空我境界　　一切悉无余

尔时五百妓女于魔王边。闻叹如来所有功德。即得菩萨三昧。名离一切相电光三昧。时彼五百妓女。即以天上诸庄严具。雨天香华及天伎乐。遥向佛所供养世尊。于竹林上犹如雨下。以得如来神力加故。令彼天女遥见世尊及诸徒众。见已欢喜生清净信第一爱敬

尔时众中诸比丘等。见竹林间有如是相。便生疑怪。白佛言。世尊。我等昔来未曾见闻于竹林间如此瑞应香华等雨。将非舍利弗目揵连等现此相耶。何因缘故睹斯希有。尔时世尊告诸比丘。非此二人现神通相。此乃天魔五百妓女。于彼魔宫雨此香华及庄严具。持供养我。不久来此。皆于我边得受阿耨多罗三藐三菩提记。时彼魔王五百妓女遥闻佛记转复欢喜生清净信。以净信故即得不忘菩提心三昧。尔时魔王五百妓女。着一肩衣右膝着地。于魔宫中向佛方面。合掌恭敬说如是偈

  一切世间盲无眼　　唯佛一人名见者
  能竭人天渴爱河　　如来自度及一切
  我等云何速成佛　　人天恭敬能说者
  女身可厌宜应舍　　速近牟尼闻正法
  如来最上神通智　　开示我等为胜导
  持彼无上觉支宝　　无垢妙说如净灯
  胜力降魔无等伦　　觉悟我等当受记

尔时魔宫五百妓女。从坐而起至魔王所。异口同音而说是偈

  如来胜德终不动　　云何于佛而生嗔
  此身众苦之所逼　　更起醉慢而自涂
  应舍此嗔决定信　　拔彼生死憍慢泥
  众生体性佛所知　　我等应往慈悲所

尔时魔王念彼诸女。生于如是增上恶意。我今应以五种之缚。缚此五百诸妓女等。令住于此不往佛边。此五百女以得如来念力加故。而彼魔王所不能制

尔时五百诸妓女等。于彼魔宫欲往佛所。当发足时魔甚嗔恨。便作是念。我今自以境界之力制此诸女。即起非时毗岚大风遍满虚空。欲令诸女迷失诸方。还住我宫不见瞿昙。以佛力故尚不能起微细之风。乃至不能动一毛端。何况无量

尔时魔王转增忧苦。心生悔恼悲泣高声。唤其诸子及其眷属。一切魔宫大声遍满。而说偈言

  爱子眷属悉皆集　　我心热恼如毒树
  坏我神通境界力　　美言谄幻释师子

尔时魔王所有男女并诸眷属。闻此音声悉皆驰赴住魔王前。彼眷属中有一魔子名曰胜智。合掌住立说如是偈

  此非劫烧非死相　　何故种种忧恼生
  此无大力能胜怨　　何故异智似愚痴

尔时魔王说偈报曰

  今此释迦子　　坐彼林树下
  现前有大怨　　云何汝说无
  彼谄有胜力　　令我心荒怖
  我军并我子　　如炭入炽火
  名称胜丈夫　　聪睿多才艺
  现集及未集　　今悉归依彼
  我怨以诈亲　　谄智力甚诤
  高名胜智人　　悉为法钩牵
  今此诸侍女　　于我无悲心
  见舍昔所爱　　尽往沙门所
  指我以为证　　今日归依彼
  一切三有地　　谄幻悉令空
  彼虽有大力　　我破令作灰
  我辈一切众　　应当勤所作

尔时魔王一切诸子。并其内外所有眷属。悉皆合掌咸作是言。我等一切悉皆严驾。以神通力而自加被。以此境界示彼令知。退彼释子令碎如灰。若当胜者我等善好。若不胜者当归依彼。我等往昔大军围绕。诣菩提树面睹释子。独一无侣以神通力。我等军众尽皆退坏。况复今时无量徒众悉皆成就。时魔报言。且去子辈。若能杀彼沙门瞿昙。当须回还。若不能者亦须还宫而自守护。是时魔王即以左右十二万众。复过此数乃至八万四千由旬。所有兵众悉皆遍满。复以迅疾神通之力。现大黑风。吹大黑云。雨大炬火。悉皆遍满一切四洲。复以手击须弥山王。一切四洲悉皆震动。复出最恶可畏之声。须弥山王及诸山王。大地峰石一切惊动。由此震击小大池河。及大海水悉皆波浪。一切诸龙大龙夜叉大夜叉。见是事已踊上虚空。此诸魔众住须弥顶。复掷大石等由旬量。于中摩伽陀国如大暴雨振击惊动。复雨刀杵挝镵大石月钐曲撩短槊铁把虎牙大棒及大月箭犹如雨下

尔时世尊即入碎魔军场三昧。于虚空中所有兵仗及大炬火变成华雨。所谓优钵罗华雨。波头摩华雨。俱物头华雨。分陀利华雨。曼陀罗华雨。摩诃曼陀罗华雨。雨中摩伽陀国。复变可畏惊动之声。为彼种种微妙音声。所谓佛声法声僧声。波罗蜜声神通声。阿毗跋致声。受职声。四魔退声。往菩提道场声。乃至取俱声不取俱声。复变此四洲一切大地所有药草丛林山石土地皆成七宝。是时世界无有风尘一切恬静

尔时世尊现其身相过于梵世自在而转。从其身分一一诸相。乃至无见顶相出大光明。遍照三千大千世界。普皆大明。是时三千大千世界。所有天．龙．夜叉．乾闼婆．阿修罗．伽楼罗．紧那罗．摩睺罗伽．薜荔多．毗舍阇．鸠槃茶．人．非人．等。地狱畜生阎罗世界。如是一切悉见世尊及大光明。是时天龙夜叉人非人等。各与若干百千眷属。地及虚空来诣佛所散华供养。到已右绕赞叹礼拜。是时地狱及诸畜生阎罗世界。无量百千阿閦毗俱胝那由他等。各自忆念先种善根。称南无佛陀。恶趣终已生于天上

尔时魔王所有诸子二万二千并诸眷属。见佛神变如是相已。各于佛所得希有信。共彼五百魔王妓女礼世尊足。合掌恭敬以偈赞叹

  妙色净身映智海　　名称高远无不至
  金色光焰类须弥　　我等无怙归依彼
  众生失道无能见　　如来智日能明照
  养护众生永不退　　亲导我等归依彼
  积集智藏富无量　　解脱心性如虚空
  慈悲润泽随机说　　一切成就归依彼
  生死旷野难济越　　如来解脱能开示
  巧说因果能显了　　住第一慈归依彼
  境界幻炎如水月　　无智翳闇着诸欲
  佛为医王救世间　　是故我等归依彼
  佛真法桥渡四流　　富有七财恒资给
  世尊正道示世间　　大悲我亲应供养
  我等恶意向如来　　今悉忏悔第一觉
  所有诸恶能永断　　愿佛受我最上依
  我等悉舍魔部党　　共发无上菩提心
  普请一切众生类　　菩提大愿至无余
  佛能显示我胜行　　如我所行波罗蜜
  如来所说无异说　　几法具足到菩提
  所散佛华成华盖　　示现无量诸刹土
  我今顶礼两足尊　　愿涅槃乐利世间

尔时一切魔诸眷属并魔妓女。各持天华遥散佛上。以佛世尊神力加故变成华盖。遍覆十方无量俱胝那由他百千恒河沙诸佛刹土。复过此数变成华盖。遍覆十方现在诸佛。于虚空中邻盖佛顶。时彼魔王五百妓女并诸眷属。一切悉见十方无量阿僧祇诸佛刹土安隐说法。及见彼佛眷属围绕众坐微妙威仪炽盛。及见华盖住上虚空邻覆佛顶。彼彼诸佛皆同一色。形相示现悉皆同等。唯彼世尊在师子座。种种眷属功德庄严所现不同。又闻诸佛音声遍满句义说法。此魔眷属以佛世尊念所加故。得见如是神通变化。既见此已。第一爱乐生清净信。礼佛足已佛前听法

尔时魔王所有诸子。并诸眷属十二频婆罗。退还魔宫白魔王言。我等广作如此恶事。乃至不能毁坏瞿昙一毛孔等。尔时复有二万诸魔归依如来佛前听法

尔时魔王既失威德。复大嗔怒发如是言。我于今日无异觉意。乃至不能诛灭释种所生之子令彼灭坏。云何此住。便还魔宫。入忧恼室。默然而坐

宝星陀罗尼经卷第一宝星陀罗尼经卷第二

        唐天竺三藏波罗颇蜜多罗译

    本事品第二

时魔妓女及魔王诸子并其眷属白佛言。希有婆伽婆。我等今者志求如是相。如是乘。如是辩才智慧。如是神通大悲方便。希有婆伽婆。具足如是智慧方便神通等法。婆伽婆。具足几法能令菩萨摩诃萨远离恶友。速得阿耨多罗三藐三菩提。佛言。善男子。若菩萨摩诃萨能具四法远离恶友。速疾当得阿耨多罗三藐三菩提。何等为四。一者不取。二者不说。三者不见。四者空无分别。善男子。云何不取。所谓不取一切法。无一法可得。不受不舍。不可非不可。不建立不念着。不分别非不分别。所谓行檀波罗蜜。不取檀波罗蜜果。不受不舍。不可非不可。不立不着。不分别非不分别。乃至行般若波罗蜜亦复如是。不分别非不分别。复次善男子。云何不说。所谓不说众生可得。不说命者。不说寿者。不说人。不说众生界可得。不说有意有所取。乃至不分别非不分别。复次善男子。云何不见。所谓不见色声香味触法。不取色声香味触法。乃至不分别非不分别。复次善男子。云何空无分别。所谓一切三世三界阴界入等因缘果报。所缘之法无起无依。无有生相不取不舍。乃至不分别非不分别。何以故。舍离一切行一切持一切身。及分别不分别故。一切智智相应不可得故。当如是行。所以者何。善男子。一切法及一切智。乃至无声无相无字无愿。无生无灭无体无著无缘无我。不可见寂静。离相离念离灭。无闇无明无处所无境界。无根本无伴助。不可思不可量。无贪无悭无行无说。无深无浅无受无依。无识无取无影无一念顷。无分齐无所有毕竟无所有。何以故。一切智等犹如虚空。相应不可得故。不立相应。不取相应。不行相应。若相应若不相应。不分别非不分别。当如是行。善男子。是名具足四法能令菩萨摩诃萨远离恶友速疾当得阿耨多罗三藐三菩提。善男子。所有一切内外境界。若以一切智智。观察推求依持建立。着此二相以意分别。起二着故。彼便远离一切智也。云何二相。若观察入等取立相二是名远离一切智也。若取立行果是二分别。于诸众生有取立相是二分别。开示施设语言之道。建立总持音声之法。以智观察是断是常。是二分别。众生寿命养育人丈夫。作使作想建立依持。是二分别。此彼所有建立筹量不建立筹量。是二分别。若以一切智智观察三世。推求我作集业所作。彼此立取是二分别。若以分别有二相者。则不能得一切智也。善男子。如寒求火而返取地。如渴求饮而返取火。如饥求食而返取石。如庄求华而返取衣。如薰求香而返取尸。如行求衣而返取垢。如涂求香而返取空。如是如是。善男子。若行执着观察是身取立相二。求一切智者。徒捐精进无道无果。尔时众中有一菩萨名曰持智。从坐而起于世尊前。曲躬合掌作如是言。婆伽婆。若法不可说。彼不能得菩提。佛言。汝今当知。无得菩提。亦无菩提可说。善男子。谛听谛听。汝问如是。如汝所乐。随汝意说。若所有物。若一切智。有性有相有名字耶。持智菩萨白佛言。不也婆伽婆。若有言说即堕常见。若无言说即堕断见。乃至中道亦不可得。非有非无。不取不着。不生不坏。过阿僧祇不可量不可数。无闇无明。若如是观乃得菩提。电慧菩萨言。婆伽婆。无来无去。如是善知如是善入乃得菩提

毗卢遮那菩萨言。如是婆伽婆。法不到相非不到相。非得时非不得时。非作证非不作证。非灭非不灭。非三世非不三世。非三乘非不三乘。亦非行愿合集称量可得。如是知者乃得菩提

地慧菩萨言。婆伽婆。若一切法。非三界非三结。非三明非三乘。非阴界入。非分别非不分别。非减非增无有合集。如是知已乃得菩提

金刚慧菩萨言。凡夫法圣人法。学法无学法。声闻法辟支佛法。非分别非不分别。亦非合集称量之所能知。如是知者乃得菩提

坚慧菩萨言。如如寂静如如观察。不舍不住乃得菩提

宝手菩萨言。若一切法不生不到不时。无分别相乃得菩提

不思议慧菩萨言。若以观察三界心计入在心。是名二心。如是二心观察不可得者。以无所得乃得菩提

退怨菩萨言。若一切法。无著无贪无舍无碍无愿无痴无执无放。乃得菩提

莲华藏菩萨言。若罪福性等入是如法。深忍不着我我所作。非分别非不分别。如是观者乃得菩提

月光菩萨言。若观一切法聚散随缘无有自性。犹如水月。如是解已乃得菩提

虚空慧菩萨言。若一切诸法。有闇有明有生有灭有增有减。不于诸心数法而起分别。如是知者乃得菩提

无尽慧菩萨言。若修习三轮清净波罗蜜。相应不可得。不染非不染。如是修者乃得菩提

弥勒菩萨言。若不缘不受三界依止梵住依止乃得菩提

文殊师利菩萨言。婆伽婆。若解甚深一法门者。于一切法不染非不染。一法门者所谓无我。了彼一法不觉不观。无有将来亦无送去亦无可聚可散可明可闇可生可灭可增可减可解脱者。不应染浊无分别故。以一法门一切智智乃得菩提

坏爱乐菩萨言。文殊师利。如是一法门一切智智。悉入如法甚深空处。何故意有所作及修行方便。文殊师利言。舍离恶见修行正见不妄置立。舍谄曲心修质直行不妄置立。舍离十恶敬重三宝不妄置立。善说不妄置立。正命不妄置立。舍一切结不妄置立。大悲平等不舍一切众生不妄置立。三护不妄置立。无虚诳法不妄置立。不生不灭不妄置立。护持正法不妄置立。舍一切所有不妄置立。少力众生常作建助不妄置立。怖畏者得归依不妄置立。非道者示正道不妄置立。忍辱柔和不妄置立。不执着一切相不妄置立。舍离一切尘垢闇阴不妄置立。舍离一切回向果报不妄置立。善男子。此二十种方便能得一切智智。所有文字音声语言句义差别。一切皆如是名入一切智智方便。一切如来所说。及余外道所说。一切取舍生灭。乃至能知一切三解脱。依止因缘业行之法悉入于如。当知皆是一切智觉智方便也。坏爱乐菩萨言。如是如是。文殊师利。若解甚深法门者无一法可见。亦无所说法及以能说者。乃至文字句义皆应悉舍。若修行若识知无有相应。一切入如是名智觉智。佛言。善哉善哉。善男子。汝能善说此一法门。以一切智智乃得是法。云何一切法不妄置立。所谓不生不坏际不妄置立。生死涅槃际不妄置立。虚空涅槃际不妄置立。无生无说际乃至一切诸法亦复如是。示一切众生一切法无实际。示一切着物一切三世三界阴界入等无所有际。入三行空际。入法阴报阴聚散阴无实际。入空入真际。具足一切无说法义。是名菩萨摩诃萨入一切智智。复以一切智智而得受记。说是法时魔诸妓女及魔王子眷属二万。闻佛所说。同时皆得无生法忍。悉舍身意所有粗业得自性生身。复有二万八千众生得无生法忍。九十二万天人得菩萨种种三摩提陀罗尼无生法忍

尔时得无生法忍诸菩萨摩诃萨等。雨天众华散于佛上。缤纷而坠犹如雨下。头面着地顶礼佛足。作如是言。婆伽婆。我等若值不善恶友。与恶和合自在作恶。于一切众生一切功德善根之聚。终不能起一念善心。佛言。善男子。汝于过去无量亿劫。亲近供养无数诸佛。以此业缘今生爱乐还得值佛。我今为断众生疑故。当为汝说宿世因缘。善男子。乃往过去无量无数阿僧祇劫。有劫名曰具足大势。此阎浮提有转轮王名优钵罗华。得自在力统四天下。王及臣民皆寿六万八千岁。时世有佛。号月光明香胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼国众生虽居五浊。以修善故不染欲法。尔时彼佛常为四众宣说三乘相应之法。时优钵罗王严四种兵。与其夫人后宫眷属。往诣彼佛月光明所到已顶礼佛足。散种种华烧种种香。作众伎乐。供养佛已右绕三匝。并复顶礼比丘僧足。以此二偈赞问彼佛

  天龙所仰大功德　　过患永断无上尊
  以七法财利世间　　愿说得何等妙慧
  作大慈灯灭世闇　　降伏堕生老死忧
  能遮人天三恶趣　　说何等法脱魔道

善男子。尔时彼月光明香胜如来告优钵罗王言。大王。具足三法能得菩萨微妙智慧。何等为三。一者大悲如母能作一切众生极依止处。二者精勤。不息能灭一切众生苦恼。三者等观一切诸法无命无养育无人无种种相。大王。是名具足三法能得菩萨微妙智慧。大王。复有具足三法。能令不着魔罥。何等为三。一者所谓于一切众生。得不起嗔不求过短。二者平等观一切众生作福田想。三者能得一切法作一法观。所谓虚空等一切法。无作无种种无生无起无灭。一切空如实相。舍离不可得相应观。大王。是名具足三法令善男子不着魔罥永脱魔道。时优钵罗王第一夫人。名天孙陀利。共彼宫人婇女八万四千人俱。前后围绕往彼月光明香胜如来所。到已以种种华散彼佛上。顶礼佛足以偈赞曰

  烦恼翳障已永尽　　无比功德解脱尊
  云何教我转女身　　令我具足男子相
  速疾远离诸恶趣　　于法自在心调柔
  最上善逝天人师　　能与世间第一利
  如蒙世尊舍女身　　当得欢喜寂灭乐
  云何速说此丈夫　　自调调他利益者
  我得出离恩爱坑　　世间无等最第一
  念持广大功德聚　　能速调伏诸群生
  今我于此必取转　　唯愿速开甘露道

尔时释迦如来作如是言。善男子。彼月光明香胜如来告优钵罗王第一夫人孙陀利言。夫人有智方便当依修习。速转先世所种女身。乃至阿耨多罗三藐三菩提。究竟涅槃更不重受。除自发愿。夫人依何方便无量先世所种女业速尽无余。夫人有宝星陀罗尼建立大事。具大功德能大拥护。善灭女身三业恶行。一切苦报令无有余。若有女人闻此宝星陀罗尼至心诵念。尽此女形后生当得端正丈夫。一切身分悉皆满足。具质直行有大辩才。身口意业善相和顺。能令现在未来一切怨嫌悉皆退散。若有身口种种恶业。现在将来应受苦报。以闻宝星陀罗尼威神力故。所作恶业现世消灭无复遗余。置作五逆诽毁正法谤圣人者。以闻是经威德力故。至其身尽即舍命时。如是等罪亦皆随灭毕竟无余。若有女人身口所造恶业果报量等须弥。后世定受无量众苦。如是种种苦报种种业障种子余报。以闻经力尽灭无余。所以者何。由过去一切诸佛阿罗诃三藐三佛陀。说此宝星陀罗尼。受持读诵现前赞叹称扬随喜。是诸众生所有苦报。以经力故悉皆灭尽。所作善根随时增长。若十方刹土现在诸佛阿罗诃三藐三佛陀。为众生故各各方面。说此宝星陀罗尼。众生闻者欢喜爱乐。所有罪障无不消灭。所作善根皆令增长。若当来世十方刹土。一切诸佛说是经处。乃至一念生欢喜心。是诸众生皆得尽苦增长善根。我于今者亦说此经。若有闻者皆当随喜。十方现在诸佛世尊说是经处。当共称扬当共欢喜。夫人。若有已受玺印刹利王至他土境。得此宝星陀罗尼书持爱乐者。以经力故彼刹利王。威德高远有大名称。遍满十方无量国土。乃至一切欲色界天闻其德声。一切天龙夜叉乾闼婆等。无量俱胝那由他百千万亿刹利诸王。常所随逐所共守护。彼王国土所有一切斗诤饥馑。他方怨敌风雨寒热疫病过患皆得除灭。一切恶鬼夜叉罗刹师子象狼皆生慈心。虽在其国不为损害。其王国土亦无一切粗涩苦味恶触痛恼无不消灭。一切财宝。五谷果实。药草华叶。滋茂美味皆得增长。若受印刹利王。欲与敌国余刹利王共斗战时。应悬此经置自幢头。以经力故。彼怨敌王所有兵众。自然退散。若彼二刹利王受天印者共交战时。各悬是经置一幢头。以经威力。时彼二王便相钦爱共相和好。如是成就无量功德。利益安乐一切人王。是宝星陀罗尼随有之处。若城邑聚落。若人非人四足多足诸恶毒虫。无有能令闻是经者。疾病横死及故恼乱。若是经典所在之处。应当尽心设大供养。应以供养之具奉迎此经。亦以经卷置师子座。读是经人及听经者。应当至心清净洗浴。香油涂身着新净衣。受持梵行。散杂色华。烧众名香。种种美味。恭敬围绕供养是经。其人若有一切病苦横死之厄及以怖畏恶相之征。以经力故悉灭不现。若有女人为求男女。皆应澡浴着新净衣。修习梵行烧香散华。恭敬供养是妙经典。便生福德智慧男女。如是女人虽不为己。以经威重熏修力故。舍身之后。乃至阿耨多罗三藐三菩提。及得涅槃。毕竟不复受女身也。除自发愿成熟众生。夫人随有此经一偈一句一声经耳。乃至飞禽走兽闻此经者亦复如是。皆得舍彼畜生之身。亦令一切速得不退阿耨多罗三藐三菩提。善男子。彼过去月光明香胜如来说是经时。便以右脚栂指触地。而此世界六种震动。释迦牟尼如来。今说此经亦复如是。佛神力故。时此佛刹山河大地六种震动。十方无量阿僧祇。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。薜荔多毗舍遮鸠槃茶人非人等。皆生疑怪。一切佛刹大光遍满地平如掌。须弥山轮围大轮围树林墙壁悉隐不现。当地动时。彼诸天龙夜叉先怀疑怪。如来神力所加被故。诸天龙等。四方观望。去一箭道便见释迦牟尼如来。各各惊喜生希有心。一时合掌瞻仰世尊

尔时释迦牟尼如来。作如是言。善男子。过去月光明香胜如来说是经时。以脚触地六种震动。而此佛刹平如水面。一切天人皆生疑怪。四方观望去一箭道。便睹彼佛月光明香胜如来。见已合掌生希有心。善男子。彼月光明香胜如来。即于天龙大众之中。为众生故。说此宝星陀罗尼咒曰

哆侄他(一)阇卢计(二)阇卢迦慕计(三)阇梨阇罗阇梨儞(四)阇罗婆啰帝(五)阇呬利(六)婆啰布楼沙罗叉那娑摩娄呬耶(七)阿摩迷(八)阿摩迷(九)婆摩迷(十)婆摩迷(十一)那婆迷(十二)摩呵迷(十三)阇呵迷(十四)阇呵迷(十五)呿婆罗迷(十六)婆罗鞞(十七)婆婆鞞(十八)婆呵鞞(十九)傍伽鞞(二十)婆阇鞞(二十一元本少三句)阿罗阇呬离(二十五)禅都木[山*(奚-大+ㄆ)](二十六)婆呵啰(二十七)婆呵啰(二十八)悉陀哱啰帝(二十九)檀地罗(三十)檀地罗(三十一)檀地驮罗(三十二)苏利耶毗呵呿(三十三)栴达啰毗呵呿(三十四)折刍殊帝娑(三十五)毗呵呿(三十六)萨婆阿叉耶(三十七)悉帝唎埵苏啰毗呵呿(三十八)阇呿伽(三十九)阇呿伽(四十)苏啰呿伽(四十一)毗呵摩(　四十二)阿波利呿(四十三)阿没唎呿(四十四)阿没唎呿(四十五)阿没唎呿(四十六)阿没唎呿(四十七)阿没唎呿(四十八)阿没唎呿(四十九)阿没唎呿(五十)阿没唎呿(五十一)没唎呿(五十二)没唎呿(五十三)没唎呿(五十四)毗婆謑陀羯摩(五十五)度泥度泥(五十六)乌波陀毗耶謑陀(五十七)若那讫唎多(五十八)阿讷波陀呿伽例呶迦(五十九)鸯掘隶(六十)傍掘隶(六十一)毗薄俱隶(六十二)俱罗呵(六十三)因陀罗钵唎婆呵(六十四)毗婆謑陀揭婆(六十五)遮婆啰揥(六十六)遮婆啰揥(六十七)阿慕呵达唎舍奴(六十八)钵唎跋多婆沙咄摩(六十九)讫唎摩殊揥(七十)呿伽唎阇呬(七十一)阇呵(七十二)殊揥(七十三)儞虱迦(七十四)毗啰娑(七十五)毗啰娑(七十六)毗啰娑(七十七)毗啰娑(七十八)毗啰阇摩底唎啰摩婆婆(七十九)讫唎波(八十)摩呵讫唎波(八十一)呬隶(八十二)呬呬隶(八十三)阿喽拏婆啰帝(八十四)三摩耶儞瑟髻(八十五)陀摩驮那(八十六)咥地夜那(八十七)阿波啰没唎世(八十八)颇罗君茶罗薄[山*(奚-大+ㄆ)](八十九)儞跋唎多一悉揥唎婆婆(九十)羯摩叉耶钵啰突婆婆(九十一)布喽沙埵阿三摩三摩(九十二)三摩耶毗地阇若(九十三)哆他伽多(九十四)娑婆呵(九十五)

尔时释迦如来。说此宝星陀罗尼已。于时无间。而此大地复更震动。时彼魔王五百妓女。以闻宝星陀罗尼故。即转女形具丈夫相。及无量阿僧祇天女龙女。夜叉女乾闼婆女。阿修罗女迦楼罗女。紧那罗女摩睺罗伽女。乃至薜荔多毗舍遮鸠槃茶等一切诸女。闻此宝星陀罗尼故。亦转女形具丈夫相。亦令一切诸善男子。速得不退阿耨多罗三藐三菩提。乃至一切诸女人等。于未来世当受女身。以经力故来业即灭。尔时一切女人皆共合掌。头面礼足释迦如来。同时高声作如是言。南无南摩希有能作无上利益者。释迦如来阿罗诃三藐三佛陀。唯愿大悲广为我等说此本事。我今何故女人形相皆已灭尽。丈夫身分满足成就。以此希有转变深生庆喜。我今已发阿耨多罗三藐三菩提心。惟愿世尊说此本事。令无量天人皆得道果

尔时释迦如来。重告贤首善男子言。过去月光明香胜如来。为优钵罗王夫人天孙陀利。宣说宝星陀罗尼时。孙陀利并其后宫婇女眷属八万四千人等。女人相灭丈夫相现。无量无数阿僧祇诸天天女。乃至人非人等一切诸女。各转女形具男子相。及未来世应受女身之业亦灭无余

尔时优钵罗王舍其自在转轮王位。以四天下委授太子。即与夫人天孙陀利丈夫并其千子。共八万四千天孙陀利丈夫(唐言天爱)。及九万二千诸余民庶。于月光明香胜佛所。信家非家舍家出家。剃除须发而披法服。既出家已勇猛精进。读诵受持意乐寂静。时彼无量俱胝那由他百千众生皆生是念。何故转轮圣王出家入道。其着邪者各共相谓作如是言。此香胜如来勤乐魔业解作谄幻。或时转女人根成丈夫相。或时剃除须发随与染衣。或为生天上故说生天事。或为生人中故说人中事。或为畜生中生说畜生事。或为饿鬼中生说饿鬼事。或为地狱中生说地狱事。或说不生不灭之法。或复幻作女人之身。勤乐魔业具如上事。彼月光明作沙门像。我今决定离此住处。不忍见彼沙门形相。亦不欲闻所出语言。时彼众中鸠摩罗臣心生疑倒。向彼国人作如是言。我等所有妻妾侍女皆被沙门之所幻化。改其女形作丈夫质。变化一切剃发染衣。唯我独身怀忧得脱。我今当入深山崄谷无人之处。如仙人游避其妖幻。汝等一切共我和合可相随去。慎勿入彼沙门魔罥。鄙幻沙门。我今不欲闻其音声。何况目睹。而彼臣民未得心者。闻其所言一切欢喜。鸠摩罗臣说是语时。无量俱胝百千众生皆堕邪网。复为众生宣说邪法。无有生死亦无解脱。作善作恶未来亦无诸业报果。此虚诳沙门勤行魔业。若往见彼若礼拜彼。若听彼法惑乱人心。唯欲剃发舍家冢间修行。日唯一食以乞自资。乐寂静处入房少语。常厌五欲伎乐歌舞。舍离华鬘涂香散香严身之具。亦复不乐种种华饰醉酒昏淫适情之事。而彼沙门勤乐宣说行魔罥道。即是一切众生怨家。我本不见不闻沙门所作。令无量俱胝百千众生见如是相。往昔已来亦未曾睹此恶见者。善男子。复于后时。优钵罗大沙门闻其国人逃窜山谷。或复自行恶道。复教余人令着恶见。毁呰三宝谤正为邪。闻是事已即自思惟。若彼众生皆堕恶见。不得解脱不住正见。不利益者不安立者。我为沙门。云何令彼未来之世盲冥众生。离三恶道去四魔罥。未解脱者能令解脱。乃至究竟令得阿耨多罗三藐三菩提。尔时优钵罗大沙门作是念已。即白月光明香胜如来言。我于今者为众生故发大勇猛行大慈悲。便与无量百千众生。前后围绕往彼边地。城邑聚落空山崄处。为诸众生宣说正法。若彼众生堕恶见者。我今当遮令入正见。乃至教其安住阿耨多罗三藐三菩提。或有愿求辟支佛乘。或求声闻乘。或安立圣果。或令出家。或劝受持优婆塞戒。或八斋戒。或三归行。或为安立一切女人。具丈夫形断女根业。说此宝星陀罗尼咒。乃至无量百千万亿众生。于如来边曾生疑倒。如是一切着恶见者。我当遮断令其发露。作是教已。悉令安立阿耨多罗三藐三菩提。皆于月光明香胜佛所。俱共出家净修梵行。男子。鸠摩罗臣先作是愿。彼大沙门能说幻法。破我徒众诱我眷属。汝未来世当得佛时。我还于彼作种种魔事。所谓始处胎时。为童子时。盛年戏乐及出家时。菩提树下坐道场时。我当种种恼乱种种破坏。令其退失菩提之心。善男子。时大沙门倍加勤苦。勇猛精进游其本国。入彼山崄慈语爱语。种种譬喻开晓其民。彼诸众生咸见本王。闻其说法皆生欢喜。即回邪心断昔恶见。于沙门所求哀忏悔。同发阿耨多罗三藐三菩提心。鸠摩罗臣及其徒众。调伏邪心俱怀正信。便作愿言。若大沙门具大悲者。将来之世得阿耨多罗三藐三菩提时。愿垂为我授菩提记。善男子等。欲知往昔转轮圣王优钵罗者。岂异人乎今我身是也。其王夫人孙陀利者。今弥勒菩萨是。诽谤正法怀恶见臣鸠摩罗者。今魔王是。尔时无量那由他百千众生。闻我说法共舍恶见。住三乘道俱得出家。及无量女人以经力故成丈夫者。于今汝等大众之中四部弟子是也。善男子。汝等今当信受我语。闻说过去优钵罗王本事之时勿生疑惑。所以者何。忆念在昔鸠摩罗臣。见其眷属及彼无量百千众生。同舍魔业在佛法中出家为道。便起恶念。愿我当来兴魔兵众。破汝眷属还如今日。善男子。汝等曾于月光明香胜如来所。生不净信作不善语。以恶见报迷陷众生。值佛因缘而得解脱。由一念善出家力故。从是已来亲近无量百千诸佛。供养供给不生劬劳。于诸佛所发大誓愿心乐听法。乃至常行六波罗蜜。汝等昔来以身口意所行恶业。经无量劫常处三涂加诸苦恼。业障所引生魔道中。因我释迦牟尼如来。说此宝星陀罗尼。彼魔众中五百妓女。即转女身。同时皆得无生法忍。无量无数那由他百千众生。一切世间天人大众。咸发阿耨多罗三藐三菩提心。及得不退阿耨多罗三藐三菩提。复有无量无数那由他等百千众生。皆得不退声闻辟支佛乘

宝星陀罗尼经卷第二

多地也他阇卢计(一)阇卢迦慕计(二)阇梨阇罗(三)阇梨儞(四)阇罗婆啰帝(五)阇呬利(六)婆啰布楼沙罗叉那婆摩娄呬邪(七)阿摩迷阿摩迷(八)婆摩迷婆摩迷(九)那婆迷(十)摩呵迷(十一)阇呵迷(十二)阇呵迷呿婆罗迷(十三)婆罗迷(十四)婆罗迷(十五)婆罗迷(十六)婆婆鞞(十七)婆呵鞞(十八)傍伽鞞(十九)婆阇鞞(二十)婆罗多婆利筛(二十一)阇呵迷呿(二十二)婆啰鞞(二十三)阿罗阇呬离(二十四)禅堵离(二十五)祖堵母溪(二十六)婆呵啰(二十七)婆呵啰(二十八)迷陀哱啰帝(二十九)檀地罗(三十)檀地驮罗(三十一)苏利耶毗呵呿(三十二)栴达啰毗呵呿(三十三)斫刍殊底沙毗呵呿(三十四)萨婆叉耶(三十五)悉底履埵苏啰(三十六)毗呵呿(三十七)阇呿伽(三十八)阇呿伽(三十九)苏呿伽(四十)毗呵摩(四十一)阿没履呿(四十二)阿没履呿(四十三)阿没履呿(四十四)阿没履呿(四十五)阿没履呿(四十六)阿没履呿(四十七)阿没履呿(四十八)阿没履呿(四十九)阿没履呿(五十)没履呿没履呿没履呿(五十一)毗婆侈陀羯摩(五十二)度泥度泥(五十三)郁波陀毗耶侈陀(五十四)若那讫履哆(五十五)阿讷哆波陀(五十六)呿伽离纽迦(五十七)鸯咎隶(五十八)朋瞿隶(五十九)毗簿俱隶(六十)俱罗呵(六十一)因陀啰钵履婆呵(六十二)毗也婆侈陀揭婆(六十三)遮婆啰底(六十四)遮婆啰底(六十五)遮婆啰底阿慕呵达履舍奴(六十六)钵履跋多婆沙也呿摩(六十七)讫履摩殊底(六十八)呿伽履阇呬(六十九)阇呵殊底(七十)儞虱迦毗啰娑(七十一)毗啰娑(七十二)毗啰娑毗啰娑(七十三)毗啰阇(七十四)摩底履伽啰摩婆婆(七十五)讫履跛也摩呵讫履跛(七十六)呬隶呬呬隶(七十七)阿喽拏婆啰帝(七十八)三摩邪儞瑟计(七十九)陀摩驮那(八十)地夜那(八十一)阿波啰没履(八十二)颇罗君茶罗簿溪(八十三)儞跋多悉底履婆婆(八十四)羯摩叉耶钵啰突婆婆否喽沙哆梵(八十五)阿三摩三摩(八十六)三摩耶毗地阇若(八十七)哆他伽多(八十八)娑婆呵(八十九)宝星陀罗尼经卷第三

        唐天竺三藏波罗颇蜜多罗译

    魔王归伏品第三

尔时释迦牟尼如来。说此宝星陀罗尼经时。放大光明。遍照此娑婆世界百俱胝四天下处。悉皆大明。应时此间百俱胝处欲界诸魔。以佛力故皆起惊动。共睹此光所现因缘。咸作念言。决定是彼恶魔所为。于四天下有大威德。彼于我等大自在力故现此光。作是念时。观见恶魔坐忧恼室极生悒恨。尔时此界百俱胝魔。各舍魔宫到此四天下恶魔王所。作如是言。汝欲界主有大自在。放此光明普照一切。复何因缘坐忧恼室。尔时魔王即便遍答百俱胝处所有诸魔。汝等应知。此是沙门出于释种。第一谄幻放此光明。照于世界一切惊动。世间所有明慧之人。诸梵天王。及诸龙王。夜叉王。阿修罗王。摩睺罗伽王。迦楼罗王。紧那罗王。乃至其余人非人等。其中所有聪睿之士。一切归向供养于彼。乃至六年独坐无二。成就无相大幻之力。我以自力示现神通。严驾军众三十六俱胝周匝围绕。一切魔力用大勤劳。毕竟不能令彼首陀惊畏一毛。何况复能作余障碍动彼法坐。今此首陀成就如是无相之幻。所作示现动此大地并退我军。如诛大树根枝俱倒。一切魔界悉皆闇蔽。于彼坐处成就大明。从坐起已。为诸众生开示演说。此四天下所有众生聪明智慧。悉亦为幻钩所牵。我亦不知彼等之心。何处何趣。何时死何处生。今此六趣归依彼者。我尚不能惊动一毛。况复能令动彼信心。我此五百微妙妓女。及二万子并诸眷属。皆悉归依沙门瞿昙在彼前坐。我于今日不能遮制。汝等今者有力有福有智自在。当助于我断彼释子首陀罗命。所有众生归依彼者悉令破散。幻谄沙门黑闇部党悉令降伏。我等魔众白净部党悉令明显。从尔已后当受乐触

尔时有魔名曰光明。观此阎浮于法坐上见如来身。又闻梵音美妙说法。见闻此已毛竖惊起。向彼魔王。说如是偈

  一切刹土中　　此色最胜异
  功德及智慧　　久已净其身
  解脱诸烦恼　　长夜善相应
  解脱于诸有　　尽彼一切忧
  汝今勿复嗔　　自在所不容
  归依此处者　　三有第一归
  汝若于此处　　起于刹那嗔
  以彼愚痴故　　自得于乐坏

尔时众中。复有一魔名珊儞弭迦。向彼魔王。说如是偈

  彼大神通力　　最上功德相
  一切无所依　　依者趣解脱
  苦尽无有余　　能说苦尽道
  无量百千魔　　所不能恼乱

尔时魔王。说偈报曰

  我今所有自在人　　彼大自在悉归从
  如是不久空我界　　我无趣处复无得

尔时众中。复有一魔名曰新尘。向彼魔王。说如是偈

  第一势力汝先有　　自在勇健之所作
  汝今失力复无能　　无得共比一切智

尔时众中。复有一魔名曰刀月。向彼魔王。说如是偈

  慈悲众生无恶意　　自性清净无所依
  解脱三界游行处　　无趣无行无能害

尔时魔王。说偈报曰

  欲界所有诸众生　　迷醉倒情着诸欲
  于我所作常随转　　云何共汝不害彼

尔时众中。复有一魔名曰地水。向彼魔王。说如是偈

  诸有不坚如幻炎　　能知诸有断诸爱
  不着诸有如虚空　　云何于彼能逼恼

尔时魔王。说偈报曰

  彼虽自在于三界　　饮食衣服恒资用
  彼于三受所乐住　　云何将死不能害

尔时众中。复有一魔名曰舍爱。向彼魔王。说如是偈

  神通境界有所有　　恶魔天龙夜叉等
  种种恼佛无所触　　云何将死能害彼

尔时魔王。说偈报曰

  我等昔日断彼食　　于虚空中雨大石
  无边骂詈百种声　　我欲动彼所依处

尔时众中。复有一魔名曰知眼。向彼魔王。说如是偈

  汝于彼时作恼乱　　颇见少许嗔过不
  舒颜视汝不嚬蹙　　软音慰喻无恶声

尔时魔王。说偈报曰

  彼有智慧能常忍　　能断爱痴诸过失
  慈心一切诸众生　　聚集所行无不集

尔时众中。复有一魔名难降伏。向彼魔王。说如是偈

  三结若能罥缚者　　我等可应恼乱彼
  佛乃灭此痴罥障　　云何将死能恼彼

尔时魔王。说偈报曰

  汝等助我力　　装束莫放逸
  我变地为水　　束四山为鬘
  虚空雨大石　　又放铁沙聚
  月箭曲刀镩　　掷彼身即碎
  如是勤方便　　极作恼乱彼
  汝等相运助　　释子定为灰

尔时诸魔各各说偈。乃至百俱胝处所有诸魔。说偈问答皆亦如是

尔时彼众一切诸魔。同时发声作如是言。如是应去各各自宫庄严甲胄。并诸军众悉皆擐甲。若使我等神通之力。一切境界示彼令知。沙门瞿昙虽复勇猛。岂当我辈军众之锋。如是语时于刹那顷。百俱胝处所有诸魔。各从自宫甲胄庄严。一一魔军千俱胝众。着种种甲持种种器仗各别严驾。于夜分中下阎浮提。到中魔伽陀。各住虚空邻近于佛。乃至四洲天龙夜叉乾闼婆阿修罗伽楼罗吉那罗摩睺罗伽薜荔多毗舍阇究槃荼。各于佛边生不信心无恭敬意。于法僧边亦不信心。彼一切魔各遣军众。种种器仗擐甲庄严。大集彼处欲害如来。有一仙人名曰光味。于十八明处及神通境界学过彼量。而常承事摩醯首罗。与五百徒众住雪山边。尔时魔王即自变身作摩醯首罗像。住仙人前。说如是偈

  瞿昙姓种生　　大仙依通者
  聪慧住摩伽　　今王舍城乞
  汝当坚固心　　往共种种论
  汝极五神通　　当决定自在

尔时魔王。说此偈已即隐不现。还于魔宫自眷属所。说如是偈

  汝等今日我边听　　我今思得无比知
  释子所摄所共语　　神通加彼令具足
  彼幻示现自境界　　夺我魔之广大力
  如母向子常软语　　悉令弟子生喜乐
  恒日初分入城邑　　徐步摄持正威仪
  弟子所行所断欲　　彼彼自当我捉持
  美妙歌舞现其前　　令彼见闻生惑着
  弟子记闻惑着已　　应恼释迦大仙意

尔时众中。复有一魔。说如是偈

  我今化现可畏事　　师子驼象虎水牛
  速疾奔驰彼城邑　　惊动现威雷震声
  神通化现无量事　　复现兵器逼其前
  彼彼所弃诸欲者　　或时迷乱令忘失

尔时众中。复有一魔。说如是偈

  我今于彼四衢道　　化作楼观侠其前
  种种奇形丑恶面　　种种器仗逼动彼
  空中大声雨刀剑　　惊动可畏雷雹声
  于彼境界不自在　　速令消灭不现前

尔时魔王。以神通力一切严驾。广作如上一切境界。如来大慈威德力故。亦广如彼种种示现。即时变此三千大千佛之世界。令此地性犹如金刚。一切魔力不能改转。亦复不能更作恶声。及以火山四方猛焰。亦不能作非时黑云及恶风气。佛力持故。乃至无有一龙能运其身下一渧雨

尔时四大声闻日初分时。着衣持钵入王舍大城乞食。时尊者舍利弗。于城南门值魔童子其数五十。第一端正妙色庄严大人子相。同在街路歌舞而行。遥见尊者舍利弗来。即前共持尊者两手。谓尊者曰。汝舞沙门汝歌沙门。时舍利弗语童子言。汝当谛听。先所未闻当令汝闻。即为童子。说如是偈

  诸入可厌患　　杀处常欺我
  我今厌患已　　尽彼入边际
  诸阴可厌患　　杀处常欺我
  我今厌患已　　尽彼阴边际

尔时舍利弗为魔童子说此偈已。即说咒曰

哆侄也他(一)婆呵啰(二)婆呵啰(三)婆啰(四)婆啰(五)末利支婆呵(六)萨遮婆呵(七)阿磨婆呵(八)萨婆呵(九)

尔时舍利弗。于歌音中说如是偈及陀罗尼。时魔王童子五十人等。闻是法音得未曾有。甚大欢喜信心清净。向舍利弗说如是偈

  正导我等今忏悔　　为世间亲善说者
  说阴可畏教我离　　令我于此常证见

时魔童子说是偈已。头面着地礼尊者足。便于道中共坐听法。尔时尊者大目揵连。欲入王舍大城乞食。于城东门见五十童子。乃至于歌音中。说如是偈

  诸界可厌患　　杀处常欺我
  我今厌患已　　尽彼界边际
  诸受可厌患　　杀处常欺我
  我今厌患已　　尽彼受边际
  思惟可厌患　　杀处常欺我
  我厌思惟已　　尽思惟边际
  诸想可厌患　　杀处常欺我
  我今厌患已　　尽彼想边际

时大目连。于歌声中说是偈已。复说咒曰

多侄也他(一)阿磨婆(二)阿磨婆(三)阿磨婆(四)阿磨婆(五)阿啰阇(六)啰挐阇呵(七)奢藐他(八)奢藐他(九)奢藐他(十)他伽那婆摩(十一)娑婆诃(十二)

尔时长老大目揵连。为魔童子。说如是偈及陀罗尼。时五十童子。第一欢喜生净信心。说如是偈

  具足密神通　　圣主牟尼子
  生死道过患　　法灯普照示
  能断诸过恶　　故我生信乐
  今既归依佛　　法僧亦归依

尔时五十魔之童子。于街道中即便接足礼大目连。于彼前坐正仪听法

尔时长老富楼那弥陀罗尼子。于城北门入城乞食乃至街中。随彼童子所唱歌声。于歌音中。说如是偈

  诸触可厌患　　杀处常欺我
  我今厌彼触　　故尽触边际
  诸根增上主　　杀处常欺我
  我今厌增上　　故尽增上边
  惑业常流转　　杀处常欺我
  我今厌惑业　　尽惑业边际
  诸有可厌患　　杀处常欺我
  我今厌诸有　　尽诸有边际

尔时富楼那于歌音中。为魔童子说此偈已。告童子曰。人命轻速难可保住。犹如山水迅浪奔流。命甚于彼。愚痴凡夫都不觉知。复次童子。一切凡夫色酒所醉无觉知者。声酒所醉无觉知者。香酒所醉无觉知者。味酒所醉无觉知者。触酒所醉无觉知者。复次童子。人命轻速甚彼山水。愚痴凡夫都不见知。法酒所醉无觉知者。阴酒所醉无觉知者。界酒所醉无觉知者。封食所醉无觉知者。乐酒所醉无觉知者。生酒所醉无觉知者。欲酒所醉无觉知者。复次童子。人命轻速犹如山水迅浪奔流。命甚于彼。愚痴凡夫都不见知。乃至为彼一切情识取着之酒。为所迷醉都不觉知。即为童子。而说咒曰

多侄也他(一)揭伽婆(二)揭伽婆(三)揭伽婆(四)门致尼(五)阿伐多(六)毗伐多(七)呿伐多(八)跋啰磨阿啰他(九)殊底伐多(十)娑婆呵(十一)

尔时长老富楼那于歌声中。为魔童子说如此偈及陀罗尼句。时彼五十童子。第一欢喜生净信心。说如是偈

  汝今教我寂灭道　　诸界犹如彼幻炎
  世间唯从分别生　　故我身命归三宝

尔时五十魔之童子。于街道中即便接足礼富楼那。于彼前坐正仪听法

尔时长老须菩提。于城西门入王舍城次第乞食。于街道中逢值魔王五十童子。华年盛美颜色端正。容止庠雅大人子相。共戏街道歌舞而行。见须菩提即便趋往。各共捉彼尊者两手。作如是言。汝歌沙门汝舞沙门。须菩提言。谛听童子。汝先歌音所未闻者当令汝闻。汝且默然听我歌声。时须菩提。即为童子。说如是偈

  一切有为法　　动性皆无常
  如彼幻泡炎　　虽见不可得
  速疾生灭法　　唯智者乃知
  触受是苦担　　愚痴者随着
  有为逼迫苦　　一切悉无我
  更无一知识　　令脱于苦者
  如信菩提道　　亲近修一相
  谓离诸法想　　不净及无我
  一切行相应　　无实无性相
  诸法无命养　　无人无作者
  汝舍魔谄意　　发觉生净信
  诸识依本起　　如电依虚空
  触受思无我　　观察无有实
  愚痴凡夫聚　　此阴恒流转
  净心分别生　　作者不可得
  真际寂灭空　　能离一切边
  此法无无明　　故说菩提行
  如彼大船师　　普运到菩提

尔时长老须菩提。为魔童子说此偈已。即说咒曰

多侄也他(一)苏文第(二)毗文第(三)文陀(四)阇醯(五)赐离(六)赐离(七)赐离(八)阿婆赐离(九)阿婆呵赐离(十)多他多婆赐离(十一)步多俱胝赐离(十二)娑婆呵(十三)

尔时长老须菩提。为此童子于歌声中。说此偈辞及陀罗尼句。时彼五十童子。第一欢喜生净信心。说如是偈

  我依恶知识　　未闻如是法
  愚痴无智故　　造作此恶业
  我今发露悔　　愿尊证知我
  尊从胜法生　　故我发大愿
  愿我得作佛　　普利益世间

时五十童子。于街道中即便接足礼须菩提。于彼前坐正仪听法

尔时世尊以神通力。令此街道百由旬量。广博严净而为示现。时舍利弗北面而坐大目揵连西面而坐。富楼那南面而坐。须菩提东面而坐。四人住处共半由旬。应时于彼四大声闻坐处地中现大莲华。纵广正等五十肘量。阎浮檀金为茎。青毗琉璃为叶。胜藏宝为须。真珠为蕊。华气芬馥过彼天香。如此莲花是出世间善根所生。从此莲华出大光明。普照三千大千世界。于彼街道其华上踊。高三人量而为示现。乃至四天王天此莲华现。以彼天量高五由旬而为示现。乃至三十三天此莲华现。以彼天量高百由旬而为示现。阿迦尼吒天此莲华现。以彼天量高半由旬以为示现。于莲华叶宣示种种美妙句义。此地众生及彼诸天。皆闻华中如此偈颂

  唯佛清净生此刹　　退彼魔王并军众
  佛勇猛故转法轮　　世间因此故无疑
  诸有聪慧解义论　　知法求法求解脱
  一切世间聪睿人　　优波俱利最为上
  此为导师已调伏　　善巧说此妙大法
  一切世间上供养　　供养牟尼能说者
  具三世智能善说　　所学三学能开示
  能救世间人天者　　无量法义令解知
  利益世间教善行　　方便智灯照世间
  巧说妙法断三垢　　智慧利益无疲倦
  世间极苦令解脱　　无明闇蔽诸众生
  能与法眼不颠倒　　一切大众普已会
  此佛不久师子吼　　如来能示第一义
  妙色力具展转说　　见世沉没大苦海
  来处世间击法鼓　　六根护中住上护
  此六随行六通知　　六度上法佛所说
  决定说此六种子　　能杀六根居村者
  六无上事所念者　　佛调御主令彼念

于莲华中说是偈已。乃至于彼六欲诸天。于莲华中复为诸天说如是偈

  汝等和合游　　乐着贪诸欲
  放逸心迷醉　　爱盖之所覆
  愚痴常乐着　　诸欲酒所醉
  以彼放逸故　　不供养善逝
  诸欲无常坏　　如彼水中月
  死生坚牢罥　　众生无脱者
  此等无所依　　放逸着诸欲
  以乐诸欲故　　永不得涅槃
  常处放逸地　　与灭不相应
  不看先所作　　为净为不净
  为业受老死　　怖畏恒围绕
  汝等放逸故　　三恶地所行
  以施调系心　　恒修不放逸
  先所作善业　　应当勤护持
  念舍欲不净　　难得后边故
  汝等归善逝　　听彼说大义
  汝等修智慧　　解脱寂灭因
  与妙法相应　　听如是大义

如是莲华中说是偈已。乃至色界十六天。处于莲华中复为诸天说如此偈

  分别善法勤修习　　一心乐禅离愦闹
  寂静不乱求解脱　　慧所应作断嗔恚
  所有我相十三种　　分别为说修胜忍
  以此毕竟速解脱　　得至生死解脱处
  贪嗜色聚分别者　　我性坚固见湛然
  彼等不减所生法　　由见流转趣恶地
  观彼三界常无我　　不实无自空无作
  修忍分别随顺彼　　得彼一切趣解脱
  彼等不老不病死　　不怨憎会离恶趣
  一切诸法等虚空　　所修相应不二修
  毕竟净道最无上　　意无所著净诸根
  犹如释子降四魔　　应修无相一法性
  所有一切相皆离　　调顺威仪二种断
  此道为彼最上说　　一切法空分别修
  若能分别修此空　　无主无作受亦无
  如空自性解菩提　　远离悕求最无上

尔时如来于此净色莲华台中。出此大声句义法时。此世界中一切所有人非人等。普来街中绕莲华座。乃至无量无数阿迦尼吒天。悉下天宫绕莲华座瞻仰听法。是时魔王闻此偈已。周匝普观见王舍大城。街中莲华出此法声。及见无量无数百千俱胝那由他人。围绕莲华共坐听法。又见六欲诸天无量无数百千俱胝那由他等。一切诸天悉舍宫殿。随绕莲华而坐听法。见闻是已转过前量。加大忧苦悔恼缠心。毛竖战栗遍身流汗。走虚空中。以大音声唤余魔众。说如是偈

  汝等当听　　善摄外意　　我于境界
  无自在力　　此乃释迦　　最上胜力
  功德广行　　流布世间　　令彼众生
  坚固所作　　于莲华台　　出此法声
  人天诸子　　尽来无余　　决定善人
  咸皆渴仰　　专意善逝　　趣寂灭道
  最上功德　　第一无上　　沙门所作
  幻此三界　　迷惑一切　　令无余意
  人天大众　　围绕莲华　　疾放雨石
  作恐怖声　　以魔凶众　　往摧坏彼

尔时余魔对彼魔王。说如是偈

  汝听我等语　　此语能利益
  汝知何等法　　而不止息意
  如来胜持力　　魔军尽消灭
  我等见善逝　　心皆大迷闷
  佛为大船师　　光颜胜圆满
  置佛善归依　　更无胜归处

尔时复有余魔。对彼魔王举体掉动。面目嚬蹙悲泣极嗔。说如是偈

  汝失善道住恶道　　可不自知力所能
  汝无羞愧比导师　　魔力消灭由佛力
  世间和合莲华所　　听法怡悦净身心
  我等秽身失精进　　不去消灭刹那顷
  今者一切悉归依　　归依牟尼因陀罗

尔时复有诸魔。悉皆合掌向彼魔王。说如是偈

  汝舍法行乐作恶　　佛为恃怙利世间
  于诸众中佛众胜　　佛今已来于此城
  我等宜以清净眼　　以喜乐心速往彼
  归依三界之所尊　　一切众生妙良药

尔时此虚空中复有一魔。名曰智声。向彼魔王即便高声说如是偈

  汝等和合以信乐　　一切相应听我语
  发意言行断恶见　　曲躬合掌舍嗔恚
  以醒悟心当净信　　随喜如来最上说
  对佛归依难得归　　我当今日信供养

尔时诸魔无量无边。于刹那顷悉从空下。到王舍大城七宝之门。各持种种庄严供具来至佛所。为欲供养婆伽婆故。或有变作转轮王像。或有变作梵天王像。或有变作魔醯首罗像。或有变作自在天像。或有变作那罗延像。或有变作兜率陀形。或有变作焰摩天像。或有变作释提桓因。或有变作三十三天。或有变作童子之形。或有变作毗沙门像。或有变作毗楼勒叉。或有变作毗楼博叉。或有变作提头赖吒。或有变作四天王天臣佐之形。或有变作日天子形。或有变作月天子形。或有变作星宿天子大小之形。或有变作阿修罗像。或有变作伽楼拏形。或有变作紧那啰像。或有变作摩呼啰伽形。或有变作宝山之形。或有变作金聚之形。或有变作种种宝形。或有变作宝树之形。或有变作刹帝利像。或有变作余外道形。或有变作轮宝之形。或有变作摩尼宝形。或有变作伊啰婆荼象宝之形。或有变作婆罗呵马宝之形。或有变作女宝之像。或有变作主藏臣宝。或有变作主兵臣宝。如是种种各自现化。为供养故住于佛前。或有现于青色青身。以白色具庄严其身。各共执持赤盖幢幡真珠璎珞。以一多罗树量之高住虚空中。或有现于白色白身。以赤色具庄严其身。各共执持黄盖幢幡璎珞之具住虚空中。或有现于赤色赤身。以金色衣庄严其身。各共执持青盖幢幡行列而住。或有现于红色红身雨白真珠。或有现于白色白身雨红真珠。或有现作天仙之色。住虚空中雨于华雨。或有变作声闻之像。为供佛故种种天香雨虚空中。或有变作揵闼婆色击天伎乐。或有变作天女之色。种种宝器香水洒地。或有变作净金黑色烧种种香。或有变作诸天子像歌唱喜舞。或有变作种种之色。合掌瞻仰赞叹如来。或有魔众随佛方面一心瞻仰。各持种种摩尼之宝供养世尊。或有街衢殿堂楼阁窗牖门阙台上。四阶之道墙堞楼橹。门间树上重阁钩栏。各随所住合掌瞻仰供养如来

宝星陀罗尼经卷第三宝星陀罗尼经卷第四

        唐天竺三藏波罗颇蜜多罗译

    魔王归伏品之余

尔时魔王见彼一切所有魔众。各与眷属归依如来。是时魔王转加嗔怒过于前量。惊怖迷乱举声悲泣说如是偈

  我失胜威德　　无复有见助
  沙门胜神通　　夺我魔境界
  应更勤方便　　思后时所作
  斫断莲华根　　令众散诸方
  莲华根断已　　令大众迷乱
  若众迷乱已　　此我后愿力

尔时魔王说是偈已。如所思惟犹如疾风从空而下。至彼莲华所现之街。即便前进欲拔莲华。以佛力故尚不能触。何况侵拔。既不能拔。复欲擿彼莲华之叶及损华台又不能损。即欲举手遥拍彼华。是时魔王见彼莲华如电如影。虽对眼根不可损触。尔时魔王尽其神力如其所作。于彼莲华竟不能损。复欲惊动一切大众。即出高大可畏之声。声亦不出。复现威猛。以大力势即举两手。欲拍大地令地震动。是时大地犹如虚空。乃至不可以手摩触。况能令动。是时魔王见此大地不可得触。复生是念。今此大会所有众生。我当打之令使心乱。作是念时。乃至不见有一众生可得可触。况能加逼。以佛力故有如是相。是时魔王转加忧恼。遍身掉动如大风树。发声[口*睪]哭悲恨流泪。遍观四方说如是偈

  沙门以幻力　　普摄诸世间
  令我心昏醉　　迷乱一念顷
  境界功德力　　此是我所有
  彼以幻力故　　一切侵夺尽
  我今被所弃　　宜速还自宫
  乃至若不去　　复及我寿命

尔时魔王即欲还宫。虽生是念复不能去。转加惊哭。复作是念。我今于此神通尽也。为复瞿昙自在力也。莫复于彼怨家之前令我命尽。复作是念。我今可隐出此娑婆佛刹之外。宁死于彼。莫令于此佛刹有一众生见我死者。作是念时乃至不能离此方维。况能隐去。即时自见被五系缚。转复惊嗔高声悲哭。复作是言。呵哉爱子及诸亲属不复可见

尔时有魔名曰智声。即自变身作转轮王形。向彼魔王说如是偈

  汝意何故忧　　[口*睪]叫生悲恼
  世间最上者　　如来为上上
  佛为无所畏　　宜速求归依
  救护诸世间　　如灯照诸趣
  归依恃怙者　　毕竟脱三苦
  若亲近如来　　当得寂灭乐

尔时魔王作如是念。若我用彼智声语者。沙门瞿昙应当归依。我此系缚应得解脱。是时魔王随佛方面。曲躬合掌作如是言。南无无上人中丈夫。佛能解脱老病死者。我今归依。是时魔王以偈颂曰

  此缚甚崄大可怖　　我速归依求善逝
  归依如来得解脱　　今始归依第一众
  我以痴盲嗔正觉　　所造过失为最极
  今依汝语故忏悔　　置汝现前以为证

尔时魔王用彼智声善丈夫语。即于佛前归依世尊。应时自见身缚解脱。既解脱已。复念。欲还魔所住宫。即自见身复五系缚。于此众中无能去处。即时还复归依如来。生此念时。即于佛边复得解脱。作念欲去即见系缚。生念欲住即见解脱。如是如是乃至七遍。系缚解脱魔王自知。无所能为。便于佛边默然安坐

    宝星陀罗尼经大集品第四

时彼四大声闻入王舍大城乞食。逢魔童子执声闻手共走衢中。请四沙门非法歌舞。时大声闻在歌音中。为说涅槃相应道句。尔时于刹那顷大地震动。如是无量百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。先于佛教中得清净信者。面目流泪说如是偈

  最上导师现在世　　于圣教中恶怪起
  辱彼声闻令世见　　众生云何生净信

尔时无量百千俱胝那由他天龙夜叉罗刹。面目流泪往到佛所。到已于佛前住。说如是偈

  圣教现在此　　当善观今日
  智者勿放舍　　为护正法故

尔时世尊复说偈言

  我今自往彼魔所　　令魔军众悉降伏
  当作一切世间导　　普教同向涅槃城

尔时一切大众异口同音作如是言。世尊。勿往勿往。世尊先说。诸佛不可思议。诸佛境界不可思议。魔境界不可思议。龙境界不可思议。业及业境界不可思议。如是一切诸境界中。唯佛境界最胜无能及者。唯愿世尊不起此坐。令无量俱胝那由他等诸魔军众自然降伏。复能开示无量百千那由他等阴界诸法。竭烦恼海坏诸见网。能令无量那由他众生入智慧海。世尊。今日非是去时。佛言。所有众生界众生。彼一切众生尽变为魔。乃至大地尽为微尘。如是一一尘复变作魔。彼一切魔力欲来害我。乃至不能动我一毛。况能损坏我此身分。我坐此座能胜无量俱胝那由他魔。又能调伏。唯置此魔眷属难可调伏。虽然我今当往。所以者何。此魔以神通力。于王舍城已变作种种严饰之具供养于我。怜愍彼故我今当受。令彼魔心能发希有第一欢喜生清净信。当种阿耨多罗三藐三菩提善根种子。尔时世尊说是语已。从座欲起。时彼护竹林天名曰端正。往至佛所涕泪交流而说偈言

  世尊于今日　　非是入城时
  此城极广大　　魔众皆充满
  如是一一魔　　中心怀重恶
  咸与亿千众　　欲围绕世尊
  嗔火皆炽然　　毒意转狂乱
  竞持锐器仗　　争恼害如来
  唯愿释师子　　毕竟慎勿往
  或当被非命　　失我大归依

世尊闻已默然不答。即起法座。时彼护伽蓝天名曰持慧。顶礼佛足而说偈言

  恶魔大将有五千　　各各竞持精器仗
  纯怀恶心立待佛　　今日勿往牟尼尊

世尊闻已默而不答。将出伽蓝。时有药天名曰成慧。头面礼足而说偈言

  呵哉失正觉　　法门当破坏
  法舟俄欲沈　　慧灯奄不照
  世间法味减　　烦恼贼盈满
  于诸有界中　　我无少自在
  最上法散坏　　云何能住持
  彼魔军甚众　　住于恶法中
  各持利刀仗　　毒心争害佛
  善逝用我语　　为利世间故
  唯愿十力仙　　善步莫入城

世尊闻已默然不答。将发伽蓝。时大门内有一树天名曰持势。即于佛前大悲啼泣。以身投地向佛作礼而说偈言

  依怙三有当失眼　　满意所欲将灭坏
  空中刀箭如毒蛇　　伺求害佛愿莫去

世尊闻已默然不答。尔时守大门天名曰水光。举声号泣。头面着地顶礼佛足而说偈言

  城中名闻大梵志　　持月刀仗候待佛
  共怀毒害有二万　　在此城中愿莫去

世尊闻已默然不对。将入王舍城门。时彼守城门天。名曰多摩罗树叶坚固。于虚空中举声号哭。驰至佛所顶礼佛足。而说偈言

  此道师子象围绕　　起勇健心争害佛
  及恼比丘作障碍　　悲愍天龙愿莫去
  四道众中因陀罗　　见佛教灭生忧苦
  相与云集共一处　　怖畏战栗共相谓
  如来既是退魔者　　魔今变作极恶面
  恐大法灭世灾起　　日月失度星辰翳
  睹恶相现皆拍头　　奇哉善逝有退相
  日眼散坏法炬灭　　蹂践正觉竭法水
  世间妙法坏将至　　众魔恶党渐炽盛

世尊闻已默然不答。彼城门天谏佛不回。悲啼流泪复说偈言

  普观世间牟尼尊　　最上说者去当死
  莫近我城取死灭　　我被三界常毁呰
  愿听我说坚固者　　今日莫向城中灭
  怜愍众生此处侍　　解脱众生生苦怖
  如来当忆本誓愿　　得大菩提度众生
  无量众生为苦烧　　安隐众生最上医
  无量俱胝劫住世　　为诸着欲凡夫众
  说法令彼得寂灭　　谓入自性空相义

尔时世尊默然不答。欲入大门。时彼地天与大滋味天。并其同类一万天俱。被发两面共到佛所。合掌住立而说偈言

  佛忆昔行檀　　施血过四海
  头骨如铁围　　眼等恒沙数
  及种种妙宝　　妻子与象马
  衣食房卧具　　随病所须药
  作最上供养　　护戒不放逸
  数习多闻忍　　常孝养父母
  修难行苦行　　解脱苦众生
  汝昔所发愿　　成佛说上道
  济拔世苦海　　为众生说法
  令竭苦无余　　使入无畏城
  置于菩提道　　遍满众生界
  行恶失道者　　忏悔毁闻戒
  随顺昔所愿　　说法俱胝劫
  浴以八戒水　　令度烦恼河
  三界众生中　　更无如佛者
  自既得解脱　　复解脱世间
  运度诸众生　　于此三有海
  唯佛得如是　　世间第一觉
  唯佛是世亲　　愿布甘露法

尔时世尊入城门已。刹那之顷。时有无量亿那由他天龙夜叉八部鬼神。于虚空中各各雨泪而说偈言

  我见昔善逝　　调众安隐时
  说法作利益　　无如是恼乱
  大师出恶世　　自然成大觉
  说烦恼障法　　成熟世间故
  常作师子吼　　无量诸恶魔
  欲如是灭法　　佛今莫入城

时有余天复说偈言

  诸佛转法轮　　住一方利益
  今佛处处往　　无令得逢恶

尔时复有余天。同说偈言

  以悲为导师　　常行利众生
  莫独入城中　　如我见有损

彼时复有无量百千俱胝那由他天龙夜叉罗刹阿修罗摩睺罗伽等。面目雨泪从虚空中作行而下住于佛前。有无量种异形。或有被发或绝璎珞。或有宝盖幢幡皆悉倾倒。或复举身投地或捉佛足。或大哀号。或举两手捶胸懊恼。或有在佛足下躃踊悲哭宛转于地。或于佛前合掌赞叹礼拜。或散种种杂色妙华末香涂香华鬘刍摩缯彩严饰之具。或散织成宝服真珠璎珞种种异物。时余天众供养佛已。同时举声而说偈言

  佛所行苦行　　为利益世间
  生此末世时　　为众勿舍去
  作佛事未多　　天人得证少
  久住开示法　　度三有世间
  有行清净行　　成就甘露器
  应起悲教我　　救世间苦逼
  六趣旷野中　　生死失正道
  为彼示善路　　教圣法解脱
  此最希有悲　　愿大觉久住
  转无上法轮　　勿令世无怙

时有余天复说偈言

  导师若灭没　　世间悉盲冥
  八圣三解脱　　于此悉皆无
  我等已种善　　三业不放逸
  一切乐具足　　久住功德藏

尔时复有净居天众。与其眷属无量无边亿那由他集在一处。各共相谓而说偈言

  汝等勿怖佛无衰　　应于大觉当了然
  我忆往昔亲见佛　　欲界所有俱胝魔
  遍满三十六由旬　　利斧利剑并刀槊
  飘勇迅疾如云奔　　魔众雄猛声可畏
  至菩提树悉走散　　于刹那顷皆惊怖
  况今果圆名称广　　彼等何能为障碍

时有余天相与悲泣而说偈言

  昔一魔军无大力　　今有千亿俱大势
  来坏如来定无疑　　佛若灭没世皆闇

尔时梵释诸天护世间者。顶礼佛足而说偈言

  以我小智劝佛住　　用我等语悲愍者
  无量诸天忧火烧　　今为彼等洒法雨

尔时世尊以大慈眼遍观一切同来天众。出妙梵声普垂安慰而说偈言

  汝等勿怖今无畏　　一切魔众一时来
  彼等不能损动我　　乃至一毛况复身
  我今安慰一切众　　常于世间说妙法
  我于如是失道者　　当广分别示正道
  我昔已行难行事　　广施众生以饮食
  房舍医药不乏少　　谁能今日恼乱我
  我舍车乘与象马　　严饰宝具亦如是
  奴婢城廓及聚落　　谁能与我作恼乱
  妻妾男女并眷属　　爱重自在王种位
  我与众生利益故　　我身何故今当坏
  头目及耳鼻　　手足身皮血
  以命施众生　　谁能恼乱我
  无量俱胝佛　　自手普供养
  常乐戒多闻　　谁能散坏我
  作无量难事　　甚能摄伏心
  遍割身不嗔　　今谁能恼我
  烦恼已退成正觉　　于诸众生等慈心
  永无嫉妒及秽怒　　现前无有如我者
  我今破魔所有力　　能退无量俱胝魔
  决定与汝作解脱　　何故恐怖不入城
  所有十方及此土　　住此诸佛刹土者
  彼等一切我普请　　及大神通菩萨众
  愿令世间悉遍满　　及以福智薰世间
  共彼如佛法式住　　亦持诸佛所顺可

尔时无量百千万亿那由他阿僧祇天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽人非人等。俱来大众一时同声唱言善哉。复作是言。南无希有未曾有无数精进具足如今世尊。南无南无大希有未曾有无数精进具足如今世尊。安慰一切天人及众生类皆蒙度脱。退诸魔众散灭众生烦恼垢聚。破我慢山斫受生树。碎生死日除无明闇。生外道信竭四流水然正法炬示菩提路。授与众生柔和忍辱。游戏三昧处禅定乐。普令觉悟四圣谛道。大悲导师广度众生。于生死海引诸天人入无畏城。时诸天人阿修罗等。各以种种天妙华香涂香末香杂宝华鬘庄严之具散于佛上。为供养佛故扫饰衢巷。以天宝衣天妙华天绮縠遍覆道上。又雨曼陀罗．波卢沙．迦卢遮．大卢遮．优钵罗．俱物陀．分陀利等种种莲华。随佛所履布于足下。其道两边化作天树枝叶华果悉以七宝而严饰之。七宝树上复现种种妙宝天衣天冠耳珰环玔宝饰庄严之具。是诸树间有天华池。其池四边周匝七宝。清冷美水八德具足。众宝莲华及妙音鸟。杂色间发盈满其中

彼诸天众供养佛故。于虚空中各持七宝幢幡华盖。校以种种金绳露缦真珠璎珞。又雨金屑银屑毗琉璃屑。及散一切沉水末香。多伽罗末香。黑栴檀末香。多摩罗叶香。复雨牛头优罗伽栴檀香等。种种末香遍于道上。复雨金绳交络真珠璎珞摩尼珠璎珞如意珠璎珞。缤纷布濩于虚空中随风回转。其城内外有道上。悉以种种天庄严具而严饰之。乃至城中魔及眷属。亦以妙好天庄严具而严饰之。尔时世尊怜愍一切诸众生故。便入首楞严三昧。其心正受。以如所入定在道徐行。即现种种微妙色身。威仪相好光明希有。于其城内道中正立令彼道上一切众生悉见佛身。所有事梵天者。应以梵身而得解脱。世尊即现梵身而化度之。所有事释天者。应以释身而得解脱。即现释身而化度之。所有事那罗延者。应以那罗延身而得解脱。即现那罗延身而化度之。所有事摩醯首罗者。应以摩醯首身而得解脱。即现摩醯首身而化度之。所有事四天王天者。应以四天王身而得解脱。即现四天王身而化度之。所有事转轮圣王者。应以转轮王身而得解脱。即现转轮王身而化度之。所有事诸小王者。应以诸小王身而得解脱。即现诸小王身而化度之。所有事大神通者。所有事沙门者。所有事童男童女妇女身者。皆现彼身而化度之。及至所有事师子事龙事象事兔事阿修罗杂类身者。是诸众生应以彼身威仪色相而得解脱。如来悉皆现彼形相而化度之。世尊如是种种作示现时。彼一切道行众生。见是事已皆共合掌。头面着地礼拜赞叹。围绕如来得未曾有。所有事象事龙事阿修罗。乃至所有事兔神者彼等众生即见如来。同兔形相威仪在道而行。所有众生事于佛者。彼等众生即见如来。如佛威仪在道而行。彼等众生悉皆合掌赞叹礼拜。相与依随从佛后行

尔时雪山光味仙人。与其徒众五百人俱。为魔所遣诣王舍大城令至佛所。是时光味于城门内住待如来。见佛身相犹如仙人。威仪形相显发庄严。及见无量百千俱胝诸天围绕供养。见是事已复作是念。如此人者真大仙人有大加护。应受人天最上供养。及见一切身分庄严似圣智者。我等二人。谁为尊胜。智慧谁胜。我于今者如何了知。又作是念。我应近问。以何生类以何姓氏。受持何等以何志乐以何等行。光味仙人自观徒众。说如是偈

  今见多闻大福德　　能持大行应供者
  能知善道牟尼最　　大忍智义法具足
  汝等一切殷重心　　以大方便常供养
  我当于此功德者　　闻其善说度彼岸

尔时光味一切徒众摩那摩等。皆共同声作如是言。如是大师应如是作。时光味仙人并诸眷属往世尊所。到佛前已合掌住立作如是言。汝今是谁。世尊答言。我是婆罗门。仙人复言。汝姓何等。世尊答言。我姓瞿昙。仙人复言。汝何志乐世尊答言。三解脱门。仙人复言。行何等行。世尊答言。我行真际如。仙人复言。出家几时。世尊答言。如彼无明久如所起。我今出家亦复如是。仙人复言。如是大仙星宿应现。如所明记颇诵不耶。世尊答言。如彼平等我不忘置。彼何所有有何坚固。如此相者世间智知。仙人复言。为欲令诸智慧之人心生欢喜故作此说。世尊问言。云何名为星宿之句。仙人答言。二十八宿日月所依随转而行。各依彼人横手八指以为量法。彼十二八指以为身量。以一八指用为顶量。以一八指为足掌量。如是十四八指。应知是为星宿量法之句。若解如此更无异法。各随其人有靥记处以为定法。若不尔者大牟尼听。我今当说星宿之句。卯星生者。于面右边权下四指有赤黑靥。靥上有毛。名闻智慧爵禄相应威势炽盛。卯星生者有如是相。毕星生者。身上有疵若四指量。聪睿贞实心常守法。智慧惭愧爵禄具足。于一切时心常勇健能摧胜怨。参星生者。颈下四指中有黑疵。为性勇健爵禄具足。嘴星生者。从顶(丹项)量已下一搩手半左相有靥。性多嗔痴而有爵禄。富那婆苏(唐言井宿)星生者。于左胁下当有黑疵。财谷具足而少智慧牟尼今者富沙(唐言鬼宿)星生。有最上相手中轮相犹如日轮。上妙端正发相右旋。一切依住上身圆满。能破烦恼为大导师。阿失丽沙(唐言柳宿)星生者。胸有黑疵。好斗犯戒难与共住性多淫欲。(上七星是东方宿)莫伽(唐言星宿)星生者。若胸若背而有小疣。是善丈夫能如法行而多财货。初破求(唐言张宿)星生者。或脐左右必当有疵多悭短命。第二破求(唐言翼宿)星生者。脐下四指若见靥者。爵禄持戒皆悉失坏。阿萨多(唐言轸宿)星生者。脐关无下当有赤靥。性好作贼谄曲少智聪明薄福。质多罗(唐言角宿)星生者。男女阴上当有靥子。为性纯直而多爱欲复好歌舞。萨婆底(唐言亢宿)星生者。或男根头或在根下有黄靥生。受性多贪嗔恼大众而无智慧。苏舍佉(唐言氐宿)星生者。从跨已下八指量内随处而有赤靥生者。眷属具足多有僮仆。位居卿相聪明惭愧。勇健谋决能退怨敌。常受安乐命终生天(上七星属南方)。阿奴逻陀(唐言房宿)星生者。从膝已上八指量内若有小疣。持戒有法爵禄具足。逝瑟吒(唐言心宿)星生者。髀内有靥。短寿贫穷犯戒少慈为人憎嫉。暮罗(唐言尾宿)星生者。髀上当有小疵。此有福德而速灭门。初阿沙茶(唐言箕宿)星生者。膝盖有靥。性好舍施能知法道命终生天。第二阿沙茶(唐言斗宿)星生者。于右胫上当有青靥。性好斗诤人不依附而不信受。失罗婆(唐言牛宿)星生者。于右胫上必有两靥。常丰爵禄受身无病。人所爱乐命终生天。陀儞瑟吒(唐言女宿)星生者。胫上有靥多嗔少贪。虽有智慧而无爵禄(上七星属西方兀少虚宿)。舍多毗沙(唐言危宿)星生者。从膝已下十六指内当有黑靥为性愚痴溺水而死。第一跋陀罗跋陀(唐言室宿)星生者。从曲膝下八指内膊上必当有疵。令人嗔恼。愚痴贫穷好作贼盗

第二跋陀罗(唐言辟宿)星生者。于虎口内当有靥子。好施持戒念力强记。有智有悲性无所畏。丽婆底(唐言奎宿)星生者。为人卑下庸力自活。阿湿毗腻(唐言娄宿)星生者。足母指间当有青靥。身无病恼而常大力。婆逻尼(唐言胃宿)星生者。于足掌下当有靥子。受性无悲好为宰手。破戒恶行死入地狱(此北方星)。如上所说此即名为星宿之句。以此得知人之性行贫富好恶。若知此者能令众生到于彼岸

尔时世尊告仙人曰。此是愚痴凡夫所见。依心随着住分别行。凡夫热病之所妄见。如彼狗蛇鱼鳖之类。若复其余种种众生。此富沙星之所生者彼非乐分。如汝神通得定解脱。我复能为一切示者。汝今何故不问于我。时光味仙人生大欢喜以华散佛。即便以偈而赞请曰

  仙人人形相　　我见最上相
  不知彼种姓　　为天为人耶
  音声言语法　　犹如大梵天
  持行持色相　　久远仙相似
  昔所不闻见　　具足牟尼相
  所师何所说　　及说汝之姓

尔时世尊。即便以偈答仙人曰

  不知此彼岸　　故有相建立
  被缚一切苦　　汝非解脱器
  六度是我姓　　六通婆罗门
  说彼六和敬　　六根分别修
  三法三解脱　　平等知无我
  菩提心发时　　彼时我出家
  我相不可得　　善修于无相
  无人无寿命　　知无我亦空
  三受三行法　　分别修所空
  我度智彼岸　　此为无等说
  无所著如空　　菩提心作者
  彼忍力具足　　当得如是智
  不着于诸法　　得报者亦无
  如是解顺如　　菩提不难得
  不立于诸法　　及不依彼此
  真际分别修　　此当得如来
  无相无想相　　离于有所得
  诸法非和合　　此当得如来
  汝舍此等相　　自心惑亦舍
  汝觉等虚空　　如是当得佛

尔时世尊说此偈时。时中无间。光味仙人并诸眷属。即见世尊形相威仪。还如佛住复得忆念。自念久远先种善根而得现前。时光味仙人即得菩萨三昧。名曰宝星。所得三昧于菩萨三昧一切观见。如在高幢。观见一切三昧。自在境界无所系属。不依他见。无人能坏无人能夺。时光味仙人即于佛前合掌而住。两手捧华以偈赞佛

  无边称实说　　世间善依怙
  如来慧眼光　　照一切众生
  出过众生上　　精进常慈悲
  稽首坚固者　　导师尽诸着
  紫磨金色光　　触众生清凉
  觉一切众生　　以菩提功德
  佛转大法轮　　能破烦恼山
  最后所行讫　　今得菩提智
  众生中大医　　真实相庄严
  说我当得佛　　众生中导师
  割坏诸爱网　　自度亦度他
  久近得佛记　　当作人中上
  苦流漂众生　　令度于有海
  涅槃安隐处　　置立无漏道
  所有十方佛　　功德如大海
  彼为我作证　　回向菩提心
  一切诸众生　　苦触极恶恼
  三世及福德　　我本身口意
  及一切众生　　苦灭得佛乐
  众生普具足　　得常住涅槃
  众生病寂灭　　烦恼水枯涸
  得智等诸根　　自性常坚固
  众生到杀处　　及受众苦缚
  以我福德光　　普令速解脱
  一一众生界　　得如海功德
  得无量福智　　一切乐具足
  弃彼诸恶见　　速亲近正见
  忆念前生处　　众生得法行
  一切得法船　　度有海彼岸
  既度彼岸已　　得佛一切法
  久住无量劫　　普雨大法雨
  法云清净水　　净洗诸众生
  若我身口意　　一切所作恶
  我一切发露　　唯佛作证知
  我生敬重意　　莫复行恶业
  佛不可思议　　常得现前见
  若有一福德　　回向为菩提
  我因诸众生　　忍受一切苦
  我劝请众生　　行菩提上道
  净诸刹土劫　　及众生智海
  我得净刹土　　随彼证菩提
  得清净徒众　　净忍住诸地
  决定五神道　　我得师子说
  无著智示者　　导师当记我
  若定得佛时　　一切法调御
  我所散之华　　空中成华盖
  天龙人等众　　一切来作证
  我顶礼佛足　　令地大震动

尔时光味仙人所散之华。住处空中近佛顶上合为一盖。时光味仙人见此事已。倍复过量无余悕望。第一爱乐生大欢喜。即便稽首两膝着地礼世尊足。光味大仙礼佛足时。应时无间一切三千大千世界六种震动。所有无量阿僧祇众生。百千俱胝那由他等。普来集会悉皆悲喜。生大惊叹怪未曾有

是时如来随彼众生所应见者。现种种身。应以象形而教化者。即见如来如彼象形生爱乐心。又见大仙人所散之华。住上虚空变成华盖。及大地动。既见此已倍复过量生希有心。到世尊所顶礼佛足。所有众生应以佛身而教化者。彼见如来如佛身相生希有心。是时世尊即便起定。从首楞严三昧安详而起。无量众生所教化者。皆见世尊无余悕望。皆大喜悦生爱乐心。各如所得。华鬘衣服末香涂香。诸庄严具持散供养

尔时世尊。即为光味仙人说受记偈

  速起听受记　　导师今为说
  大仙得菩提　　地动华一盖
  住上虚空中　　无比加护故
  汝得两足尊　　自在利世间
  佛有无边福　　边量等虚空
  三界中坚固　　法灯照世间

尔时光味菩萨摩诃萨即前恭敬白佛言。世尊。我得佛刹似何等相。我于彼刹转大法轮。是时世尊告光味言。汝未来世过无量阿僧祇劫。于北方分有世界名开敷香。具足庄严有如是相。如今西方安乐世界。汝善丈夫于彼佛刹当得阿耨多罗三藐三菩提。号无垢香光胜如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛寿命十中劫量。唯诸菩萨摩诃萨俱。无有声闻辟支佛乘。纯说无上清净大乘。时彼大众闻佛世尊授彼光味仙人记已。各以所持供养之具供养仙人。时五百摩那婆等。及九十二那由他百千俱胝众生。发阿耨多罗三藐三菩提心。及得菩萨不忘菩提心三摩提

宝星陀罗尼经卷第四宝星陀罗尼经卷第五

        唐天竺三藏波罗颇蜜多罗译

    相品第五

尔时三千大千世界百亿诸魔生如是念。今佛世尊入王舍城门。我等应以最上庄严。严饰此城门之内及彼地方。如彼城外天龙夜叉之所庄严

尔时世尊以他心智知百亿魔心之所念。欲以神通最上色相庄严佛处。是时世尊以神通力。于王舍大城十二门内。一一门中皆有如来及诸大众。共入城门。时百亿魔即以神通种种庄严胜中胜者阿僧祇等诸庄严具。严饰城门及地方城壁诸树。地上虚空胜妙庄严而庄严之。时百亿魔并诸眷属。或有作于梵天之形。乃至作于大仙之形。于诸重阁窗门楼橹却敌树间诸处地及虚空各于中住。以种种华末香烧香金粟银粟。以摩尼真珠及种种庄严以严衣服。并诸绮绣庄严具等普雨供养。又以种种天之音乐击鼓拍手。种种赞叹歌咏如来无量功德。悉皆聚集供养世尊。以如是第一最胜庄严大希有相。所未曾有所未曾闻

尔时世尊住城门下。以右足指触城门阈。应时无间一切三千大千世界普皆震动。及此三千大千世界所有释梵日月护世大自在天。天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽等主。地天水天大海诸山城邑等天。及诸男女童男童女天仙等众。乃至阿迦尼吒天宫已来。所有众生得大滋味色貌光泽。彼一切众见地大动光照觉悟。于王舍大城地及虚空围绕而住。乃至华香黑栴檀末散佛供养。是时世尊释迦牟尼佛。以神通力令彼散华乃至末香普遍十方微尘等刹。一一方分所有清净及不清净。空不空等诸佛刹土。悉皆供养供给彼佛。彼彼佛刹此所散华。并诸末香庄严具等。皆出如是偈句之声

  汝等疾觉悟　　观不放逸行
  最上菩提因　　流转甚生死
  我今拔济汝　　宜速舍世事
  忆往昔誓愿　　时到熟相应
  各得菩提记　　牟尼因陀罗
  利益世间故　　今入王舍城
  大仙胜无忧　　已降百亿魔
  转清净法轮　　应当大欢喜
  如是利世间　　普示勇健事
  解脱世间苦　　今为摩利沙
  当得菩提故　　今授汝等记
  速往彼刹土　　见妙好庄严
  自然如是得　　入彼无忧城
  渐次菩提行　　决定当得佛

尔时十方微尘等一切佛刹彼彼大众。以佛力故。悉见此佛竹林大众菩萨摩诃萨各各三昧思量。是时竹林所有菩萨摩诃萨思惟住者。并诸声闻大声闻。皆见世尊于王舍城门调伏住待。彼诸大众随世尊后住。见大庄严具中出诸偈已。悉皆遍满十方一切微尘等净不净空不空一切佛刹。彼诸佛刹所有菩萨摩诃萨及住声闻。闻此声已作如是念。何处有此法声遍满如是可意声。如是美妙。如是可爱。如是可乐。如是可喜。如是劝发。如是大功德称扬之声。及见华末香雨。雨于十方无量庄严。无量华香细末之雨。时彼菩萨摩诃萨及大声闻。舍所作业皆大惊叹

尔时释迦如来即入三昧。名依佛庄严严饰三昧。入三昧已应时无间一切娑婆世界及十方一切微尘佛刹所有大众。悉见此佛刹中如是大庄严相。如彼未来世中普见如来净无染聚世界功德庄严。唯无一事。谓城壁等而自然庄严。一切十方诸佛刹土微尘等世界诸佛世尊。普见释迦如来住王舍大城。光明赫弈甚大端严。彼诸佛刹所有大菩萨摩诃萨等及大声闻。闻此偈已各皆忆念观于四方。见此世界如对目前。以一切诸佛境界力故。及见诸天种种庄严。时彼菩萨摩诃萨等及大声闻作如是念。我等决定往于彼土大集会中庄严之处。及彼佛刹功德庄严普观察之。见释迦如来已修行供养我等于彼佛所。得阿耨多罗三藐三菩提记。时彼十方一切佛刹微尘等世界。诸菩萨摩诃萨等及大声闻。释迦如来神力加故。各自佛刹。于刹那罗婆摸呼多顷。彼没此现到娑婆世界。时彼十方一一方分无量无数佛刹。微尘等菩萨摩诃萨。一切悉来到此佛刹。地及虚空遍满而住。彼诸菩萨摩诃萨等。各依菩萨种种善根若干力故。修营供养释迦如来。且置是事。或有菩萨于此佛刹。雨种种华一切遍满。为供养事供养世尊。或有雨于种种真珠。乃至或有金银毗琉璃颇梨。石藏宝摸萨罗。牛头栴檀。龙坚栴檀。多摩罗叶。悉以为末而满虚空。为供养事供养世尊。或有雨于种种严饰诸庄严具衣服绮绣。为供养事供养世尊。或竖种种幢幡华盖。为供养事供养世尊。或烧种种之香。或散种种宝鬘。或击种种伎乐。或有示现种种歌舞。或有种种香水雨此方地而洒润之。或有种种宝器盛种种宝。于世尊前捧持供养。或有种种宝器盛满香水。以华果叶而庄严之。于世尊前捧持供养。或有种种宝树种种天衣。华果庄严举手捧持。于世尊前为供养事。或有化作大梵天身合掌佛前。乃至广说如前所作。或有化作师子之形。于世尊前如是礼拜。彼诸众生以佛神力。及自善根加护力故。互相观视。于自眼根不取诸色。以佛世尊现如是相及魔王所作。大境界天之所作若干境界。及以如来自念处正断神足根力觉道。十八不共法诸佛境界若干变现。随世尊后入王舍大城。向彼中街莲华之所。世尊到已以右手掌摩莲华叶而挽住之。时彼莲华因挽动故。于此佛刹。一切魔宫魔所坐处悉皆振动。彼魔男女所有眷属。及诸徒众所居住者。皆生怖畏惊愕而住。自相谓言。无因无缘我此宫室如是震动。莫复我等魔王境界自失位耶。莫复我等所住宫室灭没之法于此起耶。我等今者决须观察

时彼诸魔。见此事已作如是念。此佛刹土昔是五浊。谁复今者能令如是微妙庄严甚可爱乐。时彼诸魔。于自境界所居住处。并诸眷属悉不复见。唯见释迦如来三十二相大人之相。具足庄严光明赫弈甚大显照。于此一切三千大千世界及一切佛刹。种种诸相色貌现住众生普遍。而无有一可识众生。时彼一切无量众生。于世尊前悉见修营为供养事。时彼诸魔作如是念。我等决定往彼释迦如来所。见已礼拜并诸所问。我等魔王并诸眷属。今日悉皆何处去耶。尔时此佛世界百俱胝魔。并诸眷属往世尊所。到已恭敬于佛前住。时彼魔王向佛曲躬。合掌恭敬说如是偈

  我以清净心　　归依于世尊
  速放我令去　　从今行法行

尔时世尊以偈答曰

  我不障一人　　来者及去者
  汝若能知道　　随汝欲所去

尔时魔王复说偈曰

  如我所欲去　　所乐自宫室
  今见五种缚　　瞿昙之所缚

尔时世尊以偈答曰

  我断诸分别　　自解脱世间
  我既解脱缚　　令他离恼害

尔时世尊。即以佛眼观视一切此佛刹土地及虚空众生遍满。而说偈言

  汝等今当听　　一切普来者
  弃舍诸疑惑　　且各默然住
  世间佛难值　　法僧值亦难
  具足净信难　　菩提行复难
  亲于世尊前　　得闻法甚难
  能修于诸忍　　此一时亦难
  调伏心为难　　及修于空行
  能断诸分别　　一切世间恶
  菩提行难得　　如我先所行
  我当为汝说　　但说一华分
  暗阴令灭坏　　示现无上道
  所得菩提者　　今当断三垢
  听大师善说　　度彼岸诸流
  舍诸大渴爱　　建立三解脱
  安立三护等　　三界诸烦恼
  散灭令无余　　汝为供三宝
  复为法故来　　世尊天及魔
  三世加护故　　三世惑覆心
  皆得最胜断　　得解脱三界
  灭烦恼之忍　　及四种颠倒
  颠倒诸凡夫　　分别无体性
  彼非有忍器　　眼等着诸色
  身口意覆翳　　彼无四禅定
  亲近于生死　　聪明智慧者
  能修于禅定　　彼今得解脱
  离于四颠倒　　及解脱众生
  自在拔四流　　解知诸起灭
  所有调柔者　　当得度彼岸
  菩萨具四行　　及以无所畏
  正智皆能断　　众生诸有缚
  能解知五阴　　无漏离罥缚
  不复数数生　　到有海彼岸
  汝等诸佛前　　速发露诸恶
  诸恶断无余　　到彼无畏岸
  所有生死苦　　随受有为者
  数数生诸有　　随遂于恶友
  当远离恶友　　断除于恶见
  忆念生死苦　　修习第一义
  当饮无上水　　应修习于空
  第一义无体　　无实亦无相
  六根犹如空　　此中无作者
  分别相如是　　唯分别无法
  六受及六爱　　六触为其本
  六触入如是　　亦须解知空
  观察无一切　　如法自体性
  无起亦无灭　　此中见无实
  诸法同法性　　三世无一物
  若知无热恼　　此道最无上
  离十三我相　　众生想分别
  如是修羼提　　此彼得解脱

尔时世尊。以无碍福力而无所畏。依种殖善根故能变现出大圆音声遍十方。说如此偈

尔时十方无量阿閦毗恒河沙譬喻等诸空不空五浊世界。悉皆闻此圆音演说。闻此声已彼刹那顷。如是一一无量佛刹。无量无数百千俱胝那由他等。所有众生甚无所欲。唯有清净爱乐之心。于往昔所得阿耨多罗三藐三菩提更不退转。或得种种三摩提羼提陀罗尼。于此佛所集无量无数众生。闻如此句义文字已即得阿毗跋致。复有无量无数众生。于三乘法各随得度

尔时光味菩萨摩诃萨。以己神力化作七宝阶。以华遍布其上为莲华座。欲令如来升此座故。向佛恭敬曲躬合掌。说如是偈

  佛一切智月　　观世老病死
  忧患所没溺　　世间动不动
  为彼作法桥　　佛观满刹土
  无量大众生　　悉皆合掌待
  分布施法会　　示现己所得
  破众生烦恼　　无比方便智
  于此普示现　　佛升莲华座
  普雨大法雨　　十方一切佛
  及余智大仙　　与佛作证明
  牟尼因陀罗　　降伏大魔王
  自性空无有　　知法如虚空
  忆念昔誓愿　　转无上法轮
  今当拔众生　　住于四流者
  人中师子王　　佛今知此法
  令度三有海　　佛说无等法
  除众生罪垢　　世尊大智慧
  利益诸众生　　安置善逝道

尔时世尊。如其所化宝阶之上钵头摩座升莲华台。如来坐已。遍观十方一切大众告魔王言。汝今于此应生欢喜。由汝因缘今得此处大集法门。说此法时。无量无数所有众生。今世来世皆得解脱。处胎殃横老死四流。普各得度住吉祥道。又复令得虚空等智。魔王汝今此处为首。令诸众生善根增长。魔王汝可请我说法。令此众中高慢众生。度诸流故而为说法。是时魔王说如是偈

  瞿昙若无过　　及无嗔慢者
  云何惊动我　　今此说大法
  若有此嗔慢　　云何得解脱
  我今未审知　　牟尼为我说

尔时世尊。即以偈颂答魔王曰

  我处十月胎　　同彼人中事
  汝魔欲害我　　我都无秽憎
  我忍度诸恶　　秽恶悉无余
  我既出生已　　汝复动大地
  雨石来害我　　复欲断我乳
  令乳速干竭　　无量不爱事
  何种而不作　　我住禅定时
  遣诸女恼我　　我又乞食时
  障他令不施　　请我作国王
  令我轮生死　　踰城出家时
  复令夜黑暗　　兵众围绕城
  是皆汝所作　　我乘神通往
  复放大风雨　　令地为沟坑
  沙石高满路　　我住寂静林
  现作畏恶声　　于彼苦行处
  吹作切寒风　　在河欲度处
  汝复放暴流　　现作猛师子
  复欲令杀我　　我欲饮食时
  汝以毒和食　　我往菩提树
  雨下金刚雹　　刀箭雨器仗
  袈裟法衣服　　悉欲令涂污
  我处金刚座　　利益诸众生
  彼时汝亦遣　　诸女来恼我
  汝并将军众　　不忆害我时
  我无微尘意　　于汝作恼乱
  我证无上道　　已曾降伏汝
  汝今乃无耻　　复说是恶语
  往以恶方便　　恼大迦叶等
  无量众生善　　汝皆所灭坏
  汝既无悲怜　　今复欲害我
  我入城乞食　　复放凶醉象
  调达放大石　　三月食大麦
  孙陀罗恶声　　火坑恶毒食
  是皆汝所作　　决定重恶业
  汝昔向道树　　威力并军众
  以无量刀箭　　持来欲害我
  不动我一毛　　何故复住此
  如为醉毒涂　　起发俱胝魔
  那由他众生　　来满此佛刹
  如是证知我　　我住慈悲心
  怜愍于一切　　而汝常于我
  极作恶障碍　　此诸牟尼尊
  因陀罗牛王　　悉现证知我
  我今于恶时　　施作于佛事
  我为众生故　　住于解脱心
  纵汝加诸恶　　我终不舍忍
  我无嫉妒意　　秽恶诸过患
  我为随摄汝　　如是常勤劳
  我欲寂灭汝　　今应请我说
  甘露第一法　　令三界寂灭
  为汝除恶业　　汝速清净意
  于我生依怙　　我常清净心
  欲令汝解脱　　汝常怀恶心
  应当舍恶见　　意作清净信
  汝今当觉知　　不久得授记

尔时魔王。复于佛所倍增嗔恨。从此欲去自知五缚。即欲出于可畏之声复不能出。以己嗔力发热毒气。其气猛盛欲害如来。是时世尊以慈善力。变此恶气为苏摩那华盖。普遍十方一切佛刹。于一切诸佛寿命安隐现说法者。苏摩那盖于虚空中近佛顶住。时彼佛刹所有菩萨摩诃萨各各请问。今此华盖从何而来。是谁神力之所变化。时彼诸佛各答所问。诸菩萨言。诸善男子。彼有世界名曰萨诃。五浊不净。有佛世尊。名释迦如来阿罗诃三藐三佛陀。以本愿力故。成阿耨多罗三藐三菩提已。现在说法。为欲摧灭诸魔境界力故。竖立一切诸佛力无所畏佛境界故。一切诸佛教法三宝种灯令久住故。一切善根增长故。以精进神力变化降伏一切外道之怨故。一切惊怖不吉诤论。恶梦恶相内外怨敌。斗诤系缚言讼不和。水旱荒俭非时之雨。寒热风湿疫气病疠。恶声销灭故。一切天龙夜叉人非人等悉令回向故。一切刹利亦令回向故。一切四姓诲以法义。然智慧炬示以正路故。一切家宅城邑聚落人主断事。国王王宫市廛之处。悉令回向故。一切星耀昼夜度数。半月一月时节年岁。悉皆正行故。一切五谷华果药草。悉皆成熟故。一切工巧生业处所不令散失所作成就故。一切身口意业过患悉得销灭故。善作筹量念慧总持。勇猛无畏色相乐说。悉皆增长故。一切法无障明觉四圣种法作受持故。光显大乘增长菩萨摩诃萨安慰阿毗跋致地金刚心作护持故。作十地一味故。解无生法忍受佛职建立菩提故。所化众生如所随摄转大法轮。大悲普覆一切众生。住波罗蜜。住无上道。雨于法雨。以法滋味充足众生故。满足一切诸佛之事。解脱一切四魔境界故。建立无余涅槃之界故。有陀罗尼印。名金刚摧碎心高缘法等句入差别记。欲说故。一切过去如来阿罗诃三藐三佛陀。名金刚摧碎心高缘法等句陀罗尼印入差别记。受持互相随喜。及现在十方诸佛住世寿命将养。一切诸佛亦说彼金刚摧碎心高缘法等句陀罗尼印入差别记。现说受持互相随喜。于未来世十方世界。诸余如来阿罗诃三藐三佛陀。所有诸佛当出于世。亦说此金刚摧碎心高缘法等句陀罗尼印入差别记。亦当说受持互相随喜

尔时彼诸佛刹所有菩萨各各请佛。白言世尊。此是何法。我昔未闻金刚摧碎心高缘法等句陀罗尼印入差别记。能作如是无量利益。能具足如是不可思议法利。能作一切法无障碍明。乃至寂灭。诸佛世尊说此金刚摧碎心高缘法等句陀罗尼印入差别记时。一切魔力境界磨灭。乃至于彼无余涅槃而般涅槃。于诸众生无量利益无量安乐。为欲怜愍一切世间。利益安乐无量天人众生聚故。时彼诸佛告彼菩萨作如是言。善男子。我亦共汝往彼娑婆世界释迦如来阿罗诃三藐三佛陀之所住处。所有十方现在世尊寿命将养。诸余世界彼诸世尊。共一切菩萨前后围绕。并声闻僧侠侍于前。彼诸世尊亦当往彼释迦如来大集会所。彼释迦如来共诸佛。亦当说此金刚摧碎心高缘法等句陀罗尼印入差别记。当共受持。当互随喜。利益众生遮恶业行。为满贤行满无上智故。一切诸佛今悉集彼。与诸菩萨声闻僧等围绕夹侍。今悉现前在彼佛所。若汝欲得此金刚摧碎心高缘法等句陀罗尼印入差别记。应往彼听。及欲供养无量无数恒河沙等之所譬喻一切佛刹诸佛世尊。一时现在及欲见彼。昔所未见诸佛境界。菩萨境界。诸天境界。诸魔境界。佛刹庄严之所严饰。及欲见彼昔所未见无量佛集者。今正是时。可共我等往彼世界释迦如来所住之处大集法会。时彼菩萨摩诃萨各白佛言。如是如是。大德世尊。我等当与如来俱往彼处娑婆世界释迦如来所集法会。于彼佛所昔所未闻。为听彼法金刚摧碎心高缘法等句陀罗尼印入差别记故。我等于彼无量无数诸佛世尊。一时一集住世将养者得供养故。及闻彼法。我等于娑婆世界。得见彼四种神通境界严饰普庄严事。及见彼大集法会庄严。我等若往彼佛刹说陀罗尼时。得容止处不。及得承事供养彼佛听法以不。又彼如是所集徒众菩萨摩诃萨得供养不。时彼诸佛各各告彼诸大菩萨摩诃萨及大声闻作如是言。诸善男子。汝等莫疑于彼世界有容止处不。何以故。诸佛境界入无边平等智巧。无边成熟众生。无边广博空处。诸善男子。彼释迦如来大巧方便具足。善男子。所有众生众生界所摄者。但界入所依处。彼诸众生。若一一众生。假使如须弥等身。彼释迦如来。能令一切无量众生。如是等身入芥子中。一一众生所居之处。皆得广博空处。远不相见一切众生。如是大身入一芥子。而不觉知有增减相。复次善男子。所有地界是坚[革*卬]者。释迦如来。悉能令彼一切地界入一最细邻虚尘中。彼大地微尘亦不觉知有增减相。是名如来巧方便智如是具足。复次善男子。一切水界所有津润。释迦如来。悉能令彼一切水界入一最细毛端之中。彼一毛端一切水界。亦不觉知有增减相。复次善男子。一切火界所有暖相。悉能令彼一切三世所有火界入一最细邻虚尘中。而彼火界入细微尘行自境界。犹如广博虚空之处。复次善男子。所有风界可觉者。释迦如来悉能令彼一切风界入一毛孔。彼一切风于一毛孔行自境界。犹如广博虚空之处。复次善男子。十方佛刹一切众生及彼四大。释迦如来悉能令彼入一最细邻虚尘内。一切众生并彼四大。行自境界所用之事。犹如虚空不相娆乱。亦不觉知彼一微尘有增减相。是名如来巧方便智如是具足。复次善男子。乃至三世所摄众生。六入行取愿持语言。音声文字言说三行。作业阴界分别长养。种种所作。彼一切众生往昔已来。三世所摄六趣生死起灭。乃至一切众生三世所摄。过刹那。罗婆。牟忽多者。乃至一切众生三世所摄。乃至及一切众生三世所摄受。所受苦乐觉知。彼一切一刹那顷。彼释迦如来悉能觉知。若干诸相悉具足知。而如来不分别。无分别无思念。如三世际悉知是相。善男子。诸佛入境界智方便。平等成熟众生方便具足。尔时诸佛说释迦如来如此相时。种种诸方彼诸如来各各徒众。无量无数百千菩萨。愿智神通胜妙境界。皆度彼岸

宝星陀罗尼经卷第五宝星陀罗尼经卷第六

        唐天竺三藏波罗颇蜜多罗译

    陀罗尼品第六之一

尔时于彼东方之分。有世界名可乐。佛名阿閦。与无量无数菩萨摩诃萨俱。诸佛境界种种加护神通力故。于一刹那顷从彼发来。到此释迦如来阿罗诃三藐三佛陀中四天下所住之处。时阿閦佛。如自所化坐莲华座。彼诸菩萨摩诃萨亦如己功德神通之力。化作莲华微妙法座。于莲华台向佛而坐。如是东方无量无数微尘等佛刹众首。诸佛世尊住世将养。于刹那顷一一如来。与无量无数菩萨摩诃萨。百千俱胝那由他声闻大众。从彼发来。到此释迦如来阿罗诃三藐三佛陀于中四天下所住之处。彼来大众如己神通。化作莲华微妙法座。于莲华台向佛而坐

尔时于彼南方之分。如来名宝星。乃至广说。于莲华台向佛而坐。尔时于彼西方之分。有佛名阿弥陀。乃至广说于莲华台向佛而坐。如是北方有佛。名曰鼓音。下方有佛。名毗卢遮那。乃至于彼莲华台上。广说如前。上方如来名曰智光。与无量无数百千俱胝那由他如恒河沙佛刹微尘等菩萨摩诃萨俱。以诸佛境界种种加护。于一刹那顷从彼发来。到此佛刹中四天下释迦如来阿罗诃三藐三佛陀所住之处。时智光佛到已。如自所化坐莲华座。彼诸菩萨摩诃萨等既到此已。各各如己所量功德神通之力。化作莲华微妙法座。于莲华台向佛而坐

时彼十方诸来菩萨普集会者。或有雨于阎浮檀金。为供养事供养世尊。乃至广作如前所说。或有右绕一切佛刹者。或有渴仰合掌佛前如法听者。或有以己常所行善根之分思惟住者。尔时须菩提童真恭敬合掌。以己神通及佛神力加护持故。于一切佛刹法声遍满。说如是偈

  一切疑断者　　牟尼月普来
  此昔未见闻　　众成就悉现
  一切诸佛满　　及净戒菩萨
  佛刹如塔庙　　一切皆礼拜
  佛今非无因　　牟尼佛日来
  此土五浊恶　　众生可秽污
  今当降伏魔　　黑暗党破坏
  摄受诸善行　　为此今故来
  听闻寂灭法　　魔众悉摧散
  生起清净意　　当得三佛陀
  行于大乘道　　汝应披忍铠
  及为尽诸惑　　汝听陀罗尼
  各坐莲华座　　同声请导师
  说此拥护法　　摄持一切法
  不退陀罗尼　　为正法久住
  一切障销灭

尔时无量无数得忍菩萨摩诃萨等。咸共同声作如是言。唯愿世尊坐莲华座。今大悲者为无上忍大慈所薰。依无畏说摄持一切法。除诸怖畏门。过诸魔道。摧倒魔幢。建立法幢。灭诸烦恼。降一切怨。断一切疑。入一切智。解脱怖畏。于诸护中为最上护。能示菩萨一切法。所谓若念若慧若道若持。若不忘若巧方便。乃至一切行安乐成就福德所依加护三摩提。羼提陀罗尼。入巧明智。乃至持三十七助道法心。为诸众生光色怡悦故。力名闻故。乐独住故。乐说辩念令增长故。闻持不忘故。一切怨退故。五谷成熟故。持净戒故。念器成故。行成就故。到菩提故

世尊今为我说此陀罗尼法。正法随摄久住故。三宝种不断故。示现无上菩提道故。真际如如虚空无差别故。一切明闇相此彼分别无分别故。众生寿命养育我人无差别故。不生不起不灭一切法平等相无体真际如如无差别故。地水火风虚空识界无差别故。诸佛世尊。我今说此一切法性出生道场陀罗尼时。无量无数百千俱胝那由他等众生即闻法时。无量众生于三宝中得不坏信。诸众生等为善知识共相利益。及无量无数众生当发阿耨多罗三藐三菩提心。得不退转而得受记

普请一切。诸佛世尊说大法故。彼诸佛等默受请已。即时于彼莲华台上端身正坐。即入如诸佛境界入平等愿三昧。入三昧已。欲令一切诸佛刹内。诸来会众一切众生。一切诸苦皆悉销灭。一切善根皆得圆满。及得信净念解成就。诸佛世尊即见如是。此佛刹内诸来众生。贪嗔痴等见慢醉高。身见疑取有爱沉下等过。诸心心数皆悉销灭。一一众生皆如是解。唯我一人于如来前正身听法。不为余人。唯我一人如来以一切思。观我一切心。一切热恼皆得销灭。更无余人为听法故请如来说

尔时所有此佛刹内。一切众生普来会者诸根猛利。合掌同声白佛言。世尊。为我等说法。大德善逝。为我等说法。我等当共随顺成就佛世尊法。尔时释迦如来。以香庄严最上胜妙出过一切。遍满一切诸佛刹土。为供养诸余佛世尊故住诸佛前。及一切诸佛刹内。诸来大众一切众生。复以种种宝。种种华。种种鬘。种种香。种种盖。种种幢。种种幡。种种庄严捧持满掬。现诸佛前以为供养。尔时释迦如来作如是言。诸佛世尊一心念我。所有现在十方世界各各世尊。余世界中普来问我。我于往昔本愿如是。于种种秽恶五浊世界。得阿耨多罗三藐三菩提。是诸众生失所依止。失三乘道。无明暗室烦恼暗翳。不善法聚缠绕一切。舍远善法趣三恶道。远离一切聪慧之者。作诸恶逆者。谤毁正法者。谤毁圣人者。依无慈悲者。我为慈愍此等众生故。发大悲力大精进力。于彼寒热疲劳诸苦我忍受之。城邑国土道路宫室足步游行。为欲利益诸众生故。乏少粗涩少味饮食。最可厌恶不喜之食。为诸众生殖善根故。忍受种种粗涩苦触。舍那劫贝粗麻衣服。以如是等粪扫之衣而取着之。山谷林薮空舍冢间依此止住。乃至受草舍那粗麻树叶。涩臭恶触诸恶卧具。以巧方便我着大悲精进之铠。为诸众生说示种种。为刹利王说自在法。为婆罗门说四毗陀星论等法。为诸大臣说于教导众生等法。为诸医师说诸药性所宜之法。为诸商人说卖买法。为诸农夫说田种法。为诸女人说于严饰养育自在无他行法。为诸沙门说忍辱柔和坐禅诵经劝营众事。为欲示诲成熟众生。未到者令到故。未证者令证故。未脱者令脱故。忍受种种诸苦恼事。成就众生故游于人间

我今犹被此诸众生。因嫉妒故骂詈毁呰。以淫欲法谤毁于我。复以恶言诽谤于我。道我诡言击赞诈谄幻伪妄言粗穬。共诸女人说爱欲语。复以恶事加害于我。尘土坌污刀毒火轮。铁捶箭槊钺斧大石恶器仗等雨害于我。狂象毒蛇师子虎狼水牛恶牛。以大力士悉共打掷来害于我

于我房舍止息之处及僧伽蓝。以不净臭秽污满其中。我诸声闻入城内时。此非法众生。以非法歌舞。劝请声闻为非法事。以无量百千方便欲害于我。为欲隐蔽正法故。欲灭法灯故。欲破法船故。欲散我法会故。欲倒我法幢故

尔时释迦如来作如是言。当观过去诸佛法式。如彼诸佛。于此秽恶五浊恶世。普大集会作妙法式。为令妙法久住故。于一切魔诸恶境界令摧碎故。三宝种不断故。为诸众生增长善根故。一切外道所有言论以法摧伏故。为诸众生饥馑荒乱斗讼疫病。他方怨敌禁缚言讼。不时寒。不时热。不时风。不时雨。身口意业诸过恶见令销灭故

为令一切天龙夜叉人非人等正回向故。一切家宅聚落城邑。衢路诸处悉拥护故。一切谄毒蛊道惛闷。恶梦灾相悉令坏故。一切五谷药草华果滋味令资养故。刹利婆罗门毗舍首陀诲示善行故。菩提心令滋茂故。勤修诸波罗蜜故。为令菩萨摩诃萨巧方便智念行勇猛乐说辩才得增长故。受佛职位安慰入智度彼岸故。如彼往昔如来阿罗诃三藐三佛陀。说此金刚法等因缘法心建立摧碎陀罗尼印句入差别记法门。演说受持互相随喜。善哉善哉。如是如是

于今现在所有十方诸佛世尊住世将养者。悉来到此娑婆佛刹五浊恶世。来问讯我各在华座。彼诸佛等拥护此佛刹内诸众生故。应说此金刚法等因缘法心建立摧碎陀罗尼印句入差别记法门。演说受持互相随喜。令妙法久住故。一切诸魔恶境界力令磨灭故。如前广说。乃至无障碍智度彼岸故。慈愍摄受及受我请故。为令此佛刹内说妙法门得久住故。一切外道不能过故。得不坏法及三宝种不断绝故。一切众生得受法味故。尔时一切诸佛世尊咸如是言。如是如是。我等决定作如是事。于此佛刹护持妙法令久住故。一切诸魔恶境界力令摧碎故。乃至无障碍智度彼岸故。我等当说此金刚法等因缘法心建立摧碎陀罗尼印句差别门记大持法门。汝等大众今当谛听。一切诸佛大集此刹。说如是咒

多地也他鸯伽逻鸯伽逻(一)崩伽逻(二)钵啰朋迦逻(三)婆耶弭呵弭哆蓝婆斯(四)阿[山*(奚-大+ㄆ)]阿佉门跋利度迷(五)徒曼帝(六)鸡跋哜鸡榆利(七)三摩婆呵泥(去音八)三曼多跋达利(九)达迷达迷(十)驮摩鸡(十一)闇破隶(十二)弭哆啰丑破隶(十三)破啰婆帝(十四)伽尼(腻宜反十五)伽拏婆蓝帝(十六)哂利底利(十七)哂啰呬啰鸡(十八)阇婆帝阇婆帝(十九)吒迦斯(二十)吒建帝(二十一)吒迦婆蓝(二十二)迦拏婆漠帝(二十三)哂蔺帝(二十四)始蔺帝(二十五)嫔头婆帝(二十六)衢婆(去音)醯(二十七)受离(二十八)弭多啰受离(二十九)受履(三十)阿伽离(三十一)阿婆迷(三十二)娑写多他当(三十三)呼卢哂离(三十四)栴涕隶(三十五)三摩达迷(三十六)驮迷(三十七)俱朱卢(三十八)谟朱卢(三十九)阿质吒(四十)至离(四十一)至离(四十二)遮婆呵(四十三)朱卢朱卢(四十四)弭多啰婆呵(四十五)俱卢俱卢(四十六)娑啰娑啰(四十七)俱[打-丁+朱]俱[打-丁+朱](四十八)摩呵萨啰(四十九)都[打-丁+朱]都[打-丁+朱](五十)磨呵萨底耶离驮耶哺涩箄(五十一)苏哺涩箄(五十二)度磨钵离呵隶(五十三)阿婆曳(五十四)卢至泥(五十五)迦乐差(五十六)阿婆耶磨萨都毗婆呵底隶(五十七)磨隶磨隶(五十八)钵湿缚呿(五十九)尸尸啰(六十)卢迦毗那耶迦(六十一)跋时隶(六十二)跋时跋时啰达离(六十三)跋时啰婆帝(六十四)跋时啰驮提(六十五)斫乞啰跋时隶(六十六)斫乞隶(六十七)遮婆泥(六十八)达隶达隶(六十九)婆隶婆隶(七十)布隶(七十一)吒隶(七十二)呼呼隶(七十三)傍伽嫔婆隶(七十四)舍邻舍(七十五)至离(七十六)朱离(七十七)慕隶(七十八)漫茶隶(七十九)漫茶泥(八十)伽伽离(八十一)慕茶泥(八十二)萨波谟茶泥(八十三)地地啰耶泥(八十四)磨醯湿缚啰(八十五)罗耶泥(八十六)离莘阇泥(八十七)驮婆婆至(八十八)栴茶罗栖迷(八十九)萨婆萨写呵地瑟魑(去音)多(九十)叱电都婆呵那磨弭泥(九十一)波罗啰底(九十二)乌阇恶伽隶(九十三)毗至泥(九十四)婆遮那啰呵(九十五)蒱隶蒱隶(九十六)瞿卢瞿卢(九十七)慕卢慕卢(九十八)哂离哂离(九十九)呵啰呵啰(一百)迦建茶婆呵(百一)哂哂当(百二)阿喻那建茶时缚罗婆栖(百三)揭驮泥(百四)阿陀阿泥(百五)末伽阿毗卢呵泥(百六)破罗萨底曳(百七)阿卢呵婆底(百八)哂离哂离(百九)耶陀婆阇耶萨缚恶伽啰(百十)耶陀波兰者离驮耶婆呵(百十一)萨底耶钵离婆婆(百十二)末伽避卢呵泥(百十三)阿遮罗勃提(百十四)驮驮钵啰遮啰(百十五)波遮耶(百十六)宾茶离驮耶(百十七)栴达啰遮啰拏(百十八)阿遮隶(百十九)输达泥(百二十)钵啰乞离底耶末伽(百二十一)伊罗伽离梨(百二十二)钵啰弊(百二十三)娑啰勃啰帝(百二十四)萨婆哆啰哆他多(百二十五)萨底耶阿奴伽帝(百二十六)阿那婆啰那勃啰帝(百二十七)阿罗多(百二十八)鸯瞿隶(百二十九)奢弥泥(百三十)毗勃啰磨婆喻哂(百三十一)阿哂多阿婆啰(百三十二)尼啰婆耶婆(百三十三)阿质啰末伽(百三十四)罗那罗瞿萨隶(百三十五)底离啰多那傍世(百三十六)达磨迦时缚罗[旃-方+示]达隶(百三十七)三没达啰婆底(百三十八)磨呵驮步多毗耶(百三十九)三没达啰鞞伽婆底陀罗尼没达隶拏(百四十)磨佡没达啰苏啰钵啰底三毗陀没达啰(百四十一)阿跋多尼(百四十二)三跋多尼(百四十三)三慕贺塞迦啰(百四十四)毗地喻多啰栖那厕底没达离都呬(百四十五)曳鸡质毕利地毗婆呵(百四十六)婆婆婆呵呵呵(百四十七)鸡吒迦婆吒(百四十八)世罗钵啰底底离多曳那没达离多(百四十九)陀啰尼(百五十)驮啰驮啰驮啰(百五十一)檀地罗檀地罗呼色(百五十二)迦萨婆离驮耶没达离都呬(百五十三)阇茶阇跋吒(百五十四)阇呿娑吒(百五十五)苏末底末底(百五十六)磨呵驮步多没达离多(百五十七)曳鸡质杀阿耶单那尼失离多步多(百五十八)伽尼弭尼(百五十九)萨遮尼(百六十)瞿沙萨遮尼(百六十一)没达离多(百六十二)遮离耶阿地瑟佗那(百六十三)婆迦钵他(百六十四)那阿溺他(百六十五)磨呵布尼(百六十六)没遮耶阿婆多啰(百六十七)磨呵迦卢拏耶(百六十八)没达离多(百六十九)萨婆三藐(百七十)钵啰底钵地(百七十一)至啰啰多蓝(百七十二)时缚罗都(百七十三)达磨泥底离(百七十四)萨鞞慕尼(百七十五)勃离娑婆(百七十六)磨呵迦卢拏(百七十七)三磨提(百七十八)若那罗婆跋隶那(百七十九)梅底离(百八十)底耶伽阿底毗离耶跋隶那(百八十一)阿地瑟魑多(百八十二)萨婆步都(百八十三)乌波遮耶也(百八十四)萨婆呵(百八十五)

尔时一切诸佛土中所有大众。至此佛刹普来会者。皆共同声作如是言。南无一切诸佛。南无一切诸佛。皆共三反作如是言。怪哉。牟尼众集甚大希有。大菩萨集甚大希有。大声闻集甚大希有。如是希有实未曾有。我昔未闻此金刚法等因缘法心建立一切法摧碎陀罗尼印句差别法门。一切教师正法住持。三宝种不断绝。悉能摧破魔境界力。断魔罥缚降伏魔怨。建立法幢护持法分。乃至能满诸佛境界故。今一切诸佛世尊说此陀罗尼印句差别法门记。是一切众生心印大希有行。调伏六入。乃至令一切众生得无上涅槃故。说此陀罗尼印记法时。三十恒河沙等菩萨摩诃萨。成就此陀罗尼得三昧忍

尔时月光童子即从坐起。合掌普观佛加护故。及自神通力出大法声。悉皆遍满此佛刹内。说如是偈

  佛月难得值　　值是众亦难
  聪慧众难得　　及菩萨行者
  如是妙法印　　第一难得闻
  如来大悲者　　能护持正法
  摧一切魔党　　及退诸怨敌
  三宝永不断　　诸佛受持故
  一切障坏破　　忍辱柔和增
  及众生回向　　护王并国土
  遮诸作恶者　　及断诸恶见
  安慰诸菩萨　　示现菩提道
  增长波罗蜜　　贤善行满足
  乐说方便智　　如是等增长
  皆受持佛语　　摄持诸白法
  拥护陀罗尼　　明净菩提道
  炽然证实法　　汝等一切众
  皆当断疑网　　信于陀罗尼
  此是满足道　　所谓得菩提
  我等复欲说　　拥护陀罗尼
  守护说法者　　增长闻慧故
  谁有与欲者　　菩萨大名闻
  及得无障故　　能令诸众生
  利益增长故

尔时恒河沙等童真菩萨摩诃萨。咸共同声作如是言。我等今者与此受持陀罗尼欲。若有善男子善女人。比丘比丘尼。优婆塞优婆夷。当净洗浴着净衣服。用种种华庄严为帐。烧种种香。设种种食。种种衣服安置敷设。严饰绮绣。竖立种种微妙幡幢。及诸华盖庄严道场。升软妙触师子之座。开示分别此陀罗尼者。于彼无有心乱者。四大乱身乱意乱。无有毒气嘘触其身。无有能令头痛者。内外身分及以四支悉无病恼。无有能令音声蹇涩。若彼法师。往昔所有不善之业。四大乱声乱者。若彼法师。读此陀罗尼故。一切业障尽灭无余得安隐住。有来听者亦无四大乱及以声乱。若有闻此陀罗尼者。彼不善业四大长病。及声乱者一切皆灭。是时月光童子。瞻仰无量恒河沙等诸佛世尊。诸大菩萨之所围绕。月光童子。曲躬合掌作如是言。诸佛世尊慈悲念我。当与我欲。今当说此陀罗尼咒。即于佛前说大明咒

多地也他羼帝(一)阿娑摩路卑(二)弥哆离(三)苏摩婆坻(四)缢呬娜婆军阇脾(五)娜婆军阇娜婆军阇脾(六)茂罗输陀泥(七)婆茶呿婆茶呿(八)婆茶呿摩啰婆(九)哆他多跛履侈陀(十)婆婆婆颇颇颇娑娑娑(十一)阿茂罗(十二)阿者离(十三)陀陀波啰者罗(十四)脾地离(十五)缢迦娜耶跛履侈陀(十六)栴陀那抵履尼(十七)菩萨离(十八)菩萨啰坻履尼(十九)呿伽薮啰抵履尼(二十)娑娜婆薮啰抵履尼(二十一)复哆句胝跛履侈陀(二十二)阇閜(来可反)阇閜呿呿(二十三)婆栘阇閜呿(二十四)娜摩佉沙呿(二十五)迦迦佉(二十六)呵呵呵呵(二十七)虎虎虎(二十八)娑波履奢脾陀娜(二十九)波履侈陀(三十)阿摩摩(三十一)儞也摩摩(三十二)弃也摩摩(三十三)娑母陀啰母陀啰婆佉(三十四)僧塞迦啰娘跋履侈陀(三十五)菩提娑(上音)乞史坻脾摩(三十六)摩诃脾摩(三十七)部(去音)哆句胝(三十八)阿迦舍始婆娑跛履侈陀(三十九)娑婆呵(四十)

尔时一切他方佛土诸佛世尊。菩萨摩诃萨及大声闻。释梵护世天龙夜叉乾闼婆等。诸大神王大威德者。咸共称赞善哉善哉。白诸佛言。世尊。此陀罗尼甚大迅疾有大力势。能遮一切怨敌怖畏病患诸难。恶梦恶相皆悉解脱乃至无障智无上智大福智聚之所依故。说此陀罗尼

尔时世自在主大梵天王。以大梵力境界庄严。变为女人。于无量寿佛前坐。第一端正色相圆满胜过于天。第一具足衣服庄严。华鬘涂香持用严饰。时世自在大梵天王。即从坐起合掌恭敬作如是言。世尊。当拥护我圆音演说。如是音声悉能遍满一切佛刹。普得闻知而无障碍。如我今者如此咒句。善能护持说法法师及听法者。若于后时若魔若魔眷属。若天若天男女。或龙龙女。或龙父母男女眷属。乃至毗舍遮女。毗舍遮父母男女大小并其眷属人非人等。于说法师及听法者伺求其短。实作怨家诈为亲友。于说法师及听法者。乃至恼害损触一毛。或夺精气。或毒气嘘。或恶心视。乃至一念顷。我于彼等人若非人。诸魔鬼辈禁止断除。令彼昏浊与其要誓。我当拥护诸佛世尊圆音演说。能以法声满诸佛刹。唯愿世尊当念助我。持无量寿佛默然受请。时大众中。有一释天名曰持髻。以金天冠胜妙光明庄严其身。在于佛前不远而坐

尔时持髻释天告自在如是言。姊妹。勿以染污之心于无量寿如来座前而坐。勿恼世尊。何以故。乐戏论者是凡夫法。如来世尊永无戏论。有为暂现是起尽相。一切名色句差别如如。汝若如是或倒如来。姊妹。如来平等无违无诤。一味如如等虚空界。虚空亦不妄置。三行尽相。如虚空不分别无分别。诸行如是。如来如是。诸欲功德。不为戏论。不分别无不分别。而无所住不受不取。如是无命无生者。无养育无人无阴界入。无取无戏论。姊妹。汝今云何于如来前而作戏论

尔时无量寿如来告天主言。汝应审谛然后发言。勿作不如法语。令汝得罪受不爱果。此是大善丈夫。为无量诸佛之所注意。于诸佛所种诸善根。又此善丈夫。为欲供养如来事故。现女人相妙饰庄严。汝勿于此说言是女。时持髻释天白世自在梵天言。善男子。当起慈悲摄受于我施我欢喜。莫令我今以此粗言得恶果报。尔时怀乐菩萨白无量寿佛言。世尊。若此释天不悔此语时得何果报。时无量寿佛告怀乐菩萨言。善男子。今此释天若不悔过。于未来世八万四千生中。作草驴身为他轻贱。是故善男子等。常须慎意护此口业

尔时佛告世自在梵天言。善男子。随汝乐说我已拥护汝所说也。世自在梵天。既蒙护念欢喜合掌。遍观十方作如是言。唯愿世尊一心念我。若佛菩萨及声闻众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。欲令正法久住世者。愿于此处同与我欲。若法师及听众。欲得随顺相应无恼乱者。当与我欲。若彼恶魔人非人等。未来之世于说法者及众生类。作恼乱时。我当遮障与彼要誓断其恶心。自在梵天作是语时。所出音声遍满一切诸佛世界。尔时一切诸梵天王。一时同声作如是言。我等亦以此陀罗尼同共与欲。所以者何。我等于后亦当受持此陀罗尼。亦当拥护未来之世善男子等。有能开示演说如是法门及听法众。我当令彼随顺相应得如所愿。我等今于佛世尊菩萨摩诃萨及大声闻众前。与此陀罗尼欲。时彼自在梵天作如是言。唯愿世尊。及菩萨声闻大弟子众。拥护于我。即说咒曰

多地也他(一)阿摩离(二)毗摩离(三)伽拏山地(四)呵离(五)毡地(六)摩呵毡地(七)遮弥(八)摩呵遮弥(九)苏弥(十)萨他弥(十一)阿婆呵(十二)毗婆呵(十三)鸯伽阇(十四)泥哆啰佉毗(十五)茂罗波履侈啼(十六)药叉毡驰(十七)毗舍遮毡驰(十八)阿跋哆泥(十九)三跋哆泥(二十)僧塞迦啰泥(二十一)讇波泥(二十二)摸呵泥(二十三)呕遮吒泥(二十四)呵摩呵(二十五)呵摩呵呵摩呵(二十六)阿军遮泥(二十七)佉伽舍婆(二十八)阿摩罗(二十九)阿茂罗(三十)茂罗波履跋坻(三十一)阿婆罗佉婆(三十二)娑婆呵(三十三)

世尊。若有男子女人。违逆不行圣众大集所说神咒者。眼睛堕落。头顶破裂。支节分散。复说咒曰

多地也他阿者者(一)阿婆呵者者(二)帚迦啰叉(三)遮遮吒(四)佉遮遮(五)那佉伽遮遮(六)遮遮遮遮(七)那遮呵茂罗遮遮(八)遮茂罗(九)遮遮呵摩茂罗遮遮(十)呵牟呵牟(十一)婆茶婆呵(十二)娑婆呵(十三)

尔时一切梵王乃至毗舍遮王。闻是说已皆唱善哉。作如是言。假使鬼神有大威力雄猛迅疾。所向摧碎力能过千。我今以此陀罗尼章句悉令罥着。如是一切诸恶鬼神。能与众生作不利者。皆使潜灭无逃活处。自在梵天复作是言。若有住恶无慈愍心。不知恩德恼众生者。若鬼若魔及其眷属常来伺求受灌顶职刹利王等。或伺求妃后王子王女及彩女等。乃至宰相官属并余民庶。于佛法中得清净信者。若男若女童男童女。优婆塞优婆夷乐听法者。比丘比丘尼禅诵精进不放逸者。如是鬼魔人非人等求其长短。我当拥护。乃至能令一刹那顷恶心不起。况复于彼一毛恼乱。若起恶心恼乱破坏。夺其精气以毒嘘身。如是伺求觅其过者。以此陀罗尼威神力故。若魔眷属人非人等头破作七分。眼精殒坠心水干枯。得白癞病其身臭烂。失本神通陷没于地。复为恶风所吹。掷置四方无人之处。尘土坌身狂迷心乱周慞驰走。所行之地地皆破裂随堕其中。深八万四千由旬。于彼命终。若是魔等违背此咒水行之类。于佛圣教得清净信者。勤营僧事比丘比丘尼等。彼诸鬼神作恼乱者。亦得如上所说恶报。头破七分及以命终。若是不退魔场陀罗尼。随所在处。我等当勤加护。所有一切乐法众生。我当勤心昼夜守护。及彼一切。恶毒夜叉富单那等。我当驱逐出其境界。若陀罗尼所在之处。一切国土斗诤饥馑他方怨敌。非时风雨寒热疫病。我当除断令无有余。亦令其国一切人民善根成就。随顺和合安隐丰饶。能令法师及听法者。名闻高远无有病苦。亦为劝励四辈檀越。利养供给

宝星陀罗尼经卷第六

多地也他鸯伽逻鸯伽逻(一)崩伽逻(二)钵啰朋迦啰(三)婆耶弭呵弭哆蓝婆斯(四)阿溪阿呿门跋利(五)度迷徒曼帝(六)鸡跋知鸡榆利(七)三摩婆呵泥(去音八)三曼多跋达利(九)达迷达迷(十)驮摩鸡(十一)阇破鸡(十二)弭多啰纽破隶(十三)破罗婆帝(十四)伽尼(腻宜切十五)伽拏婆蓝帝(十六)哂利底利(十七)哂啰哂啰鸡(十八)阎(时瞻切)婆帝婆帝(十九)吒迦斯吒建帝(二十)吒迦婆蓝帝(二十一)伽拏婆汉帝(二十二)哂蔺帝(二十三)始蔺帝(二十四)嫔头婆帝(二十五)衢婆(去声)醯(二十六)受离弭多啰受离(二十七)受屣阿伽离(二十八)阿婆迷(二十九)娑写多他当(三十)呼卢哂离(三十一)旃涕隶三摩达迷(三十二)驮迷(三十三)俱朱卢(三十四)谟朱卢(三十五)阿质吒至离(三十六)至遮婆呵(三十七)朱卢朱卢(三十八)弭多啰婆呵(三十九)俱卢俱卢(四十)娑啰娑啰(四十一)俱株俱株(四十二)磨呵萨啰(四十三)都株都株(四十四)磨呵萨底耶(四十五)奚离驮耶补数箄(四十六)苏补数箄(四十七)度磨钵离呵隶(四十八)阿婆移卢至泥(四十九)迦乐差脾(五十)阿婆耶磨萨堵毗婆呵(五十一)底底隶(五十二)磨磨隶(五十三)钵湿缚呿(五十四)尸尸啰(五十五)卢迦毗那耶迦(五十六)跋时隶跋时啰达隶(五十七)跋时啰婆帝(五十八)跋时啰驮提(五十九)斫迦啰跋时提(六十)斫迦啰跋时隶(六十一)斫迦隶遮婆泥(六十二)达隶达隶(六十三)婆隶婆隶(六十四)布隶(六十五)吒隶(六十六)呼呼隶(六十七)傍伽嫔婆隶(六十八)舍利舍利(六十九)至离朱离(七十)慕隶(七十一)曼荼隶(七十二)曼荼泥(七十三)伽伽啰尼(七十四)慕荼泥(七十五)萨波谟荼泥(七十六)地地啰耶泥(七十七)磨醯湿缚啰罗耶泥(七十八)奚离莘阇泥(七十九)驮婆婆至(八十)旃荼罗栖迷(八十一)萨婆萨写阿地瑟耻(去声)多(八十二)叱电堵婆呵那(八十三)磨弭泥(八十四)破罗啰底(八十五)乌阇伽隶(八十六)毗至泥(八十七)婆那啰呵(八十八)蒲蒲隶(八十九)瞿卢瞿卢(九十)慕卢慕卢(九十一)哂离哂离(九十二)呵啰呵啰(九十三)迦建荼婆呵(九十四)哂哂哆(九十五)阿喻那建荼(九十六)时缚啰婆栖(九十七)揭驮泥(九十八)阿陀呵泥(九十九)末伽毗卢呵泥(一百)破罗萨底(一百一)阿卢沙婆底(一百二)哂离哂离(一百三)耶他婆阇耶萨缚伽啰(一百四)耶他波兰者奚驮耶婆呵(一百五)萨底耶钵履婆婆(一百六)末伽毗卢呵泥(一百七)阿遮罗勃提(一百八)驮驮钵啰遮罗(一百九)波遮耶宾荼离驮耶(一百一十)旃达遮啰拏(一百一十一)阿遮隶输达泥(一百一十二)钵啰讫履底末只(一百一十三)伊罗伊离离(一百一十四)钵啰鞞(一百一十五)娑啰勃啰帝(一百一十六)萨婆哆啰哆他多(一百一十七)萨底耶奴伽帝(一百一十八)阿那娑啰那勃啰帝(一百一十九)阿罗哆(一百二十)鸯瞿隶(一百二十一)奢[珍-王+弓]泥(一百二十二)勃啰磨婆喻哂呵阿哂哆婆哂啰(一百二十三)尼啰婆耶婆(一百二十四)阿指啰末伽(一百二十五)罗那罗瞿萨隶(一百二十六)底履啰多那傍世(一百二十七)达磨迦耶(一百二十八)时缚罗旃达隶(一百二十九)萨母达啰婆底(一百三十)磨呵步驮毗耶(一百三十一)萨母达啰鞞伽婆底(一百三十二)陀罗尼没达隶(一百三十三)磨[仁-二+企]没达啰(一百三十四)苏啰钵啰底三毗陀没达啰(一百三十五)阿跋哆尼(一百三十六)三瞂哆尼(一百三十七)三慕贺塞迦啰(一百三十八)毗地喻多罗栖那(一百三十九)厕底没达离都死(一百四十)曳鸡质毕利地毗婆呵(一百四十一)婆呵婆呵婆呵(一百四十二)鸡吒迦婆吒(一百四十三)世罗钵啰底底耶奚离多曳那(一百四十四)没达离多陀罗尼(一百四十五)驮啰驮啰驮啰(一百四十六)檀地罗檀地罗(一百四十七)呼色迦萨婆奚驮耶(一百四十八)达离堵死(一百四十九)阇荼阇婆吒(一百五十)阇呿婆吒(一百五十一)苏么底么底(一百五十二)磨呵驮步哆达哆(一百五十三)质杀荼耶单那尼失离多步多(一百五十四)伊尼弭尼(一百五十五)萨遮泥(一百五十六)瞿沙萨遮泥(一百五十七)没达离多遮离耶阿地瑟侘那(一百五十八)簿钵他那阿溺他(一百五十九)磨呵布尼耶三没遮耶阿婆多啰(一百六十)磨呵迦卢拏耶没达离多(一百六十一)萨婆三藐波啰底钵指啰啰哆蓝(一百六十二)时缚罗堵达磨泥底离(一百六十三)萨鞞慕尼勃离沙婆磨呵迦卢拏三摩提(一百六十四)若那罗婆跋隶那(一百六十五)梅底离底耶伽底(一百六十六)毗离耶跋隶那阿地瑟魑多(一百六十七)萨婆步都乌波遮耶也(一百六十八)萨婆呵

多地也他羼帝(一)阿娑摩路卑(二)弥帝隶苏摩婆坻(三)缢哂娜婆军阇脾(四)娜婆军阇脾(五)娜婆军阇脾(六)茂罗输陀泥(七)婆荼呿(八)婆荼呿(九)摩啰婆哆他多(十)跛履侈陀(十一)婆颇娑婆颇娑(十二)阿茂罗(十三)阿者罗(十四)陀陀波啰者罗(十五)脾地隶(十六)缢迦娜耶跛履侈陀(十七)旃陀那蒂(都泥切)履尼(十八)菩萨离(十九)菩萨啰蒂履尼(二十)呿伽薮啰蒂履尼(二十一)娑娜婆薮啰蒂履尼(二十二)步多句胝跛履侈陀(二十三)阇攞(来可切)呿攞呿(二十四)婆曳阇蒂呿(二十五)娜摩去叉呿(二十六)迦迦佉(二十七)呵呵呵呵(二十八)虎虎虎虎(二十九)娑波履奢脾陀娜波履侈陀(三十)阿摩摩儞也摩摩(三十一)弃也摩摩(三十二)娑母陀罗母陀啰婆佉(三十三)僧塞迦啰娘跛履侈陀(三十四)菩提娑(上音三十五)乞史坻脾摩(三十六)摩诃脾摩(三十七)部(去音)哆句胝(三十八)阿迦舍始婆娑跛履侈陀(三十九)娑婆诃宝星陀罗尼经卷第七

        唐天竺三藏波罗颇蜜多罗译

    陀罗尼品之余

尔时众中。有一大梵天王名曰妙音。位居十住摩诃萨地。若于梵中诸梵中尊。若于魔中诸魔中尊。若于释中诸释中尊。乃至毗沙门。毗楼茶。毗楼博叉。提头赖吒。大自在。那罗延。阿修罗等。于诸天主天主中尊。是时妙音梵王。变作第一女人之形色相圆满威仪具足。以胜庄严而自庄严。于释迦如来前合掌而坐。以其两手捧如意宝珠为供养佛故。瞻仰尊颜目不异视。诸根寂然不以诸相而观如来

尔时世尊。告妙音梵天。汝今何故目不暂瞬。乃至无相观于我耶。善男子。颇有一法名为佛耶。颇有一物可为名耶。如贪嗔痴无明烦恼。有名物缘相。相缘无明。无明缘行乃至广说。相灭无明灭行灭亦复如是。妙音梵天言。诚如圣说。何以故。无明不可得。世尊。若无明不可得者。彼十二有支从何而起。可从虚空生耶。虚空复不可得。佛言。如是如是。善男子。一切法如虚空。所以者何。虚空无物无相。非闇非明。不分别无分别。无成无坏不可说。无一物无分齐断一切物。如是如是。善男子。佛法真际断。佛法如如。佛法不取此彼岸。佛法不减不增。佛法非阴界入。体无分齐。若实若物若相一切皆无。佛法无动无住不妄置立。佛法一切言语道断。说此法时。八万四千众生发阿耨多罗三藐三菩提心。时有恶魔作如是言。若佛法如虚空。非物不可说。汝以何等智慧精进。劬劳方便恼乱于我。破我境界。乃至夺我境界众生。复教众生不来不去无物幻术。汝若如是教众生者。不复见彼烦恼行起。汝以何故。为我于此娑婆世界。召集如是无量无数诸佛世尊。菩萨摩诃萨及大声闻。梵释护世摩醯首罗。有大神通有大加护。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等大众。普皆同来满于一切诸佛刹土。令此无慈大梵说如是咒。我等既闻普皆头痛受大苦恼。乃至令身上下烂臭。尔时复有六万八千诸魔王等。及其魔众无量无边。极恶夜叉罗刹鸠槃茶毗舍遮等。一切同声唱如是言。我等徒党即闻咒时。增益头痛身皆烂臭受极重苦。释迦如来告彼魔言。忆我昔日菩提树下坐道场时。汝魔军众遍在八十由旬及以虚空。皆悉充满欲来害我。乃至今日复将军众无量俱胝共来害我。我亦如是召集无量无数诸佛世尊菩萨摩诃萨。乃至人非人等普来集会。为欲令汝及余诸魔。人非人等悉降伏故。灭一切苦得大涅槃寂灭乐故。亦为教汝不来不去。无所有性如幻法故。一切趣一切灭一切起。生死爱流悉枯竭故。亦令汝等及一切邪见众生。入无余涅槃境界而般涅槃故。魔王。汝等今者。速发阿耨多罗三藐三菩提心。汝此头痛当得解脱。渐渐修习性空佛法当得现前。及得诸佛境界。胜魔境界获大利益。尔时六万八千诸魔。及其徒众同声唱言。世尊。我等今发阿耨多罗三藐三菩提心。云何当得自性空等佛法现前。乃至得佛胜妙境界希有利益。时有恶魔作如是言。纵复令我尽后边身得重头痛。我终不以如是谄幻发菩提心。尔时妙音大梵作如是言。我今亦于一切佛前。以此佛刹微妙教法勇猛受持。于此五浊世界。流布释迦如来尊重之教。从今已往乃至释迦灭度之后。我当令此法化常得炽然。随有国土正信众生。皆令不退速出魔网。若此法门。世间不流行者。我令流行。若已行处。令其信心倍复增广。所有城邑聚落善男子善女人等。我当拥护慈心将养。遮其非义示诲善义。随处有此不退魔场陀罗尼法门。乃至书持。亦随有法师之处升师子座。欲开示演说此法门时。先当于彼至心诵此陀罗尼章句。召唤于我并诸眷属。我当自往彼法师所为作拥护。令听法众得大吉祥。即于佛前。而说咒曰

多地也他阿婆弥阿婆弥(一)庵婆离庵婆离(二)跋履军阇那茶那茶(三)补沙迦啰婆呵(四)阇漏佉(五)摩佉耶(六)伊[黍-禾+利]弭[黍-禾+利](七)抧[黍-禾+利]弭黎(八)吉坻遮啰母陀离(九)母陀啰母跛(十)娑婆呵(十一)

世尊。随有法师说法之处。要当先诵此咒章句。我以清净天耳。在彼上界闻其音声。而不往彼作守护者。我即欺诳过去未来现在一切诸佛已。亦莫令我得阿耨多罗三藐三菩提。然我决定往彼法师说法之所接足顶戴。亦与法师乐说辩才。又令法师及听法众一切病苦。恶见恶作邪疑之心悉令断灭。世尊。随所方面说此法门。有能受持温诵之者。我及眷属当往彼所。若有一切斗诤饥馑病患忧恼内外怨敌。亢旱水涝寒热失序风雨不时。恶见恶作者当令消灭。人及非人畜生等畏。及彼一切不吉祥梦。恶相恶人无有润泽。苦涩恶味辛臭恶触。如是诸患悉当断除。乃至师子恶兽毒龙野牛豺狼。盗贼奸诈人非人等。无量诸畏悉皆断灭。为使众生得乐具故。而令种种谷药华果上味饮食。衣服舍宅毡褥卧具。果报成就悉皆充满。随有流通此法门处。不利益事我当遮之。利益之事当令成就。若彼众生信乐正法行善行者。我当诲示令福增长。我今于此一切佛前立大誓愿。唯愿诸佛同怜愍我。令我所作佛事大愿成就。愿成就故意所依处皆令满足。愿满足故即我丈夫所作成就

尔时释迦如来为首。与一切诸佛。同共怜愍摄受妙音大梵故。作如是言。善男子。我等当以陀罗尼咒与汝受持。所以者何。若一切释梵护世四天王。及诸余天龙夜叉阿修罗等于佛圣教起不净心者。以咒力故皆当摄伏。妙音大梵作如是建立大丈夫所作事时。十方诸佛同唱是言。当愿妙音大梵愿力成就。即说咒曰

多地他者问池(一)问茶跛履侈提(二)呵茂摩(三)呵茂摩(四)娑啰叉(五)婆罗九娑弭佉(六)跛履婆呵(七)遮啰么(八)也他者锼比佉阿茂罗跛履侈提(九)萨婆部驮地史耻坻(十)娑婆呵(十一)

尔时释迦牟尼世尊。说是咒已作如是言。善男子。此陀罗尼。能令一切魔及释梵护世。诸余天龙夜叉阿修罗有大光泽。摄受一切人非人等。皆令回向诸佛功德。汝今若能受持如是陀罗尼者。即是能作大丈夫所作事也。妙音大梵言。婆伽婆。我今以是女人形相。当善护持一切女人。当善成熟一切女人。婆伽婆。若有女人厌恶女身求丈夫相。应当受持读诵书写供养此经。我当往彼女人之所满其所愿。若有女人厌患男女。亦当受持读诵书写供养此咒。如是女人持咒力故。虽未离欲更不受胎。复有女人为他轻贱被人欺凌失诸乐受。亦应读诵此陀罗尼。以陀罗尼威神力故。一切愿满诸乐成就。尔时大梵为供养故。为护持此陀罗尼神力法门故。为满一切众生愿故。即以两手捧摩尼宝珠。奉施十方一切诸佛。尔时诸佛同发声言。如是如是。善男子。愿汝常能护持佛教。满众生愿

    宝星陀罗尼经摄受妙法品第七

尔时会中。有菩萨摩诃萨。名妙慧通达。在胜珠炎如来前坐。去释迦如来不远。于牟忽多顷现作梵形。于刹那顷现作魔形。乃至现释天形。他化自在天形。又复现作诸天主形。化乐兜率夜摩天形。四天王天大自在形。或现夜叉阿修罗迦楼罗紧那罗摩睺罗伽。罗刹饿鬼毗舍遮鸠槃茶。刹利婆罗门毗舍首陀等形。或现师子象马水牛等形。乃至示现种种畜生之形。于刹那顷或现鸟树山果。衣服卧具种种医药。宝庄严器。牟忽多顷示现比丘比丘尼像。一刹那顷示现佛像。或现八万四千种种色相。乃至方圆处色净妙形貌。尔时长老富楼那弥多罗尼子。即起合掌问释迦牟尼如来言。世尊。何因何缘。而此菩萨有如是八万四千净妙之相。方圆处色种种类身。佛告富楼那。此菩萨有大功德摄受力境界。一切声闻辟支佛所不能及。妙慧通达菩萨摩诃萨。随彼住受力境界成熟众生。一切声闻辟支佛非其地。随是众生遍满十方无量无数。若净不净。诸佛刹土。常以无障碍慧眼。如所愿如所意。如是衰恼所缠。如所归依。此菩萨入如是三昧。以是色貌威仪。随处方圆。种种色相具足。乃至佛形。如所化度众生。皆安置三乘住不退地。若众生为贪不自在种种爱求。为断彼贪故与其所须。然后置于不退之地。若病患须医药者即与其药。然后立于不退地也。富楼那。此妙慧通达菩萨。于一日中能度如恒河沙数众生。解脱诸苦置于三乘不退之地。富楼那白佛言。世尊。此善男子。成就众生故为丈夫事其来久如。佛言。阿僧祇佛刹微尘数劫。此善男子。发阿耨多罗三藐三菩提心。经尔所时得三昧力加护。建丈夫事已来。复更经六十四阿僧祇劫。富楼那言。妙慧菩萨。从此久如于何佛刹。当得阿耨多罗三藐三菩提。佛言。更经二十六百千大劫。过彼已后有大劫名能度。世界名摩尼华须。其国众生皆寿四十千岁。妙慧菩萨于五逆不善法恶众生中。当成阿耨多罗三藐三菩提。其佛号曰开敷无边光如来阿罗呵三藐三佛陀。佛于四十千年中恒作佛事。以三乘法成熟众生。乃至令其得般涅槃。于是已后无边光佛。以无余涅槃而般涅槃。富楼那言。世尊。此菩萨先所成熟彼诸众生当生何处。佛言。此菩萨先作如是不自摄受愿。十方世界于一一方微尘数等无间佛刹。彼刹土中所有诸佛令我得见。我若不见彼等诸佛。不取阿耨多罗三藐三菩提。我先所行菩萨道时劝发众生。最初发阿耨多罗三藐三菩提心。示教建立于六波罗蜜。已成熟者遍于十方诸佛刹土。已得阿耨多罗三藐三菩提者亦令我见。以如是三摩提庄严力加护故。于十方无间一一佛刹微尘等诸刹土中。能为如是大丈夫事。及彼诸佛刹中作五逆罪不可治众生。乃至具足不善法众生。于彼命终。乘我愿力皆生我国。我为菩萨。令是众生种诸善根置不退地。然后我身当取正觉。妙慧菩萨有是大愿。尔时十方诸佛刹土俱来菩萨同作是言。我等今者普来云集至此佛刹。今得见于大师所得有如是相。及见如是大集会大悲具足诸菩萨等。及以昔所未闻。过去未来现在诸佛金刚法等因缘法心能建立摧碎陀罗尼印句差别门记法式拥护。令我得闻

    宝星陀罗尼经授记品第八

尔时阿閦如来。普告一切大众。作如是言。我等劝汝诸善男子。梵释四王天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽人非人等。诸有于佛教得清净信来此集会者。得见一切诸佛世尊。及诸菩萨摩诃萨。释梵天王人非人等普来云集。如是大相甚为难得。汝等今见此处集会。皆应于如来前各各自愿。汝今于此佛刹。若现在世及未来世。必能护持如是妙法。令三宝种常得炽然。尔时有魔名曰息华。以七宝器盛种种华果及诸谷萌芽。自变其形为女人像。具足微妙第一端正。色相圆满无与等者。第一衣服严饰其身。持宝器华以供养佛。作如是言。一切诸佛世尊一心念我。若此世界及余世界。所有诸佛已集会者。如是一切诸佛世尊。我今以一切华果诸谷萌芽。满于宝器奉献诸佛。唯愿慈悲普皆摄受。与我成就满菩提愿。若我尽此贤劫。于一切佛刹。以女人形惠施众生饮食华果。乃至成熟众生。以是福报令我六波罗蜜具足圆满。得成阿耨多罗三藐三菩提。及我所化众生。皆悉供给无所乏少。是时一切诸佛同作是言。善哉善哉。善男子。汝能以清净心建立大施。及供养一切诸佛世尊。我已受汝所施。令汝如所求如所为求。乃至尔所时求满汝意愿。功德成就神通成就。时息华魔复作是言。所有城邑村落。有能受持开示此经典者。书写经卷及供养者。我当于彼国邑聚落乃至边疆有人住处。丛林华果五谷秀实皆令成就。彼一切处所有众生乃至禽兽食华果者皆令充足。世尊。若有一人于其方所应食果实。竟不得食而命终者。我今即为欺诳一切三世诸佛及此大会诸圣众等。亦莫令我得阿耨多罗三藐三菩提。唯除业尽及命尽者。所有华果美味之属。皆令众生普得受用。以此因故。令我具足檀波罗蜜。若诸众生食果实者。是等众生当起悲心互相利益。以此因故。令我具足尸波罗蜜。若诸众生受用华果。是等众生起柔软心。以此因故。令我具足羼提波罗蜜。若诸众生受用华果。当令坚固精进之心。以此因故。令我具足毗梨耶波罗蜜。若诸众生受我华果。心心数法起无常想。以此因故。令我具足禅波罗蜜。若诸众生乃至禽兽食华果者。皆令乐法得住性空。以此因故。令我具足般若波罗蜜。复次随所有处行此法门。彼诸众生所有种种。稻禾麦豆杂类果实。我以是故心甚勤劳。为彼众生多获种子。亦令一切仓窖盈满。若彼众生乃至禽兽食华果者。以此因故。令我具足般若波罗蜜。若一一方流通开示此法门处。随彼所有甘蔗蒱桃石榴等果。一切汁味无不香美倍胜于常。众生所有瓶[(工*几)/瓦]瓮器皆令盈满。若诸众生受用食时。悉得增长智慧色力。以此因故。令我具足般若波罗蜜。世尊。我得如是六波罗蜜净因满足。令我得阿耨多罗三藐三菩提。一切诸佛及一切菩萨摩诃萨众。当随喜我能作如是菩萨行相。时大众中。一切诸佛默然许可。尔时有佛名曰智星。作如是言。善男子。汝当普请一切众生为大施主。以如是相如是力如是精进勇猛。如是劬劳不息。汝善男子。能作如是相力精进者。即是菩萨丈夫所作。时息华魔。于智星佛前。闻如是安慰已。即白佛言。唯愿世尊一心护念。与我善业成就满足。在在处处。若此法门不流行处。我与眷属不入其境。若是法门流行之处。我与眷属恒住于彼。令其土地谷药华果倍复滋茂。色香美味悉皆具足。众生受用随时饱满。仓廪地窖悉皆盈积。乃至畜生所食之物亦令丰穰。以此善根令我具足般若波罗蜜。世尊。我尽千劫于此佛刹。令诸众生如是相如是力如是受用饮食。当令充足。世尊。如是无量无数恒河沙等。五浊世界一一刹土。誓于千劫大作佛事。然后我身当得阿耨多罗三藐三菩提。世尊。我今以此神咒章句愿自呼摄。即说咒曰

多地也他遮弥佉(一)遮弥佉遮弥佉(二)毗毗履多呵沙帝(三)婆呵婆呵婆呵(四)娑么啰阿娑磨剑(五)娑啰知(六)毗婆婆娑脾(七)娑啰娑练陀离(八)娑啰摩显陀离(九)娑啰婆阇练陀离(十)珊怛跛夜娑摩剑(十一)杇杇杇杇杇杇(十二)阿僧伽社脾(十三)哆佉哆佉哆佉(十四)婆由婆义(十五)优波娜也(十六)珊怛跛夜(十七)鼻阇颇罗补所报所提(十八)陀那驮泥移娜(十九)毡陀啰差移(二十)社闻婆呵泥(二十一)娑么啰(引)娑磨剑(二十二)三藐波啰底钵那婆炎(二十三)娑哆迦里野么弥(二十四)么弭么弭么泯阇婆啰(二十五)娑婆呵(二十六)

时息华魔说是咒已。白佛言。世尊。所在之处。有能开示此经法门及陀罗尼章句。我往彼处。为欲自成熟故。为菩提行满足故。尔时一切诸佛同共赞言。善哉善哉。在会大众菩萨摩诃萨。及一切梵释天王护世四王。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽鸠槃茶毗舍遮人非人等。从一切佛刹中来者。皆共同声唱如是言。善哉善哉。善男子。汝能以此女形修行六波罗蜜成熟众生。以我等福德精进劬劳力故。唯愿令汝所作佛事当得成就。释迦如来作如是言。谁有怜愍此善男子能佐助者

宝星陀罗尼经卷第七宝星陀罗尼经卷第八

        唐天竺三藏波罗颇蜜多罗译

    授记品之余

尔时息华魔眷属同声唱言。世尊。我等眷属随顺佐助。若汝善男子。得阿耨多罗三藐三菩提时。当与我等授菩提记。息华魔言。如是善男子。魔眷属言。所有众生下种于地收诸果实而受食者。以此善根当令我等得大安乐得大利益。息华魔复白释迦如来言。我是护持世尊教法者。我是炽然世尊正法者。我于此中初作灭饥馑者。唯愿世尊。与我受阿耨多罗三藐三菩提记。时息华魔。五轮着地头面礼拜释迦如来足已却坐一面

尔时世尊。即为息华。而说偈言

  汝起勇猛善逝子　　无垢清净莲华面
  今日能发坚牢愿　　当得第一大菩提
  此诸众生饥火逼　　我为至亲能救护
  解脱一切众生者　　起大悲心当作佛
  以空无相无愿力　　解脱六趣苦众生
  恒以虚空清净法　　令诸众生得无垢
  不久于此佛刹土　　当证觉法名胜慧
  于未来世得作佛　　勇猛善智降胜怨

时息华魔闻是偈已。便生清净第一欢喜。即以天华散于佛上。尔时复有菩萨摩诃萨名成就智。即起于坐向彼十方诸来世尊。先以声觉作如是言。唯愿世尊一心念我。所以者何。忆我往昔初入贤劫。当于拘留孙佛所发大誓愿。普欲成就一切众生示受女形。为令众生四百四病得消灭故。复取大地精味。散布种种诸草木根。和合四百四味。随药功能众生受用病皆消灭。示以根药四百四种。示以果药四百四种。示苏煎药四百四种。示油煎药四百四种。示以写药四百四种。示以诸治阿伽陀药。乃至汤散丸等。总治身分内外众药。凡有一千四百种类。我为成熟诸众生故。为欲消灭诸病苦故。亦为利益诸众生故。如是众药并皆示之。世尊。我为拘留孙佛及彼众会。常作种种驱　　使给侍。本心希望得授记莂。是时拘留孙佛便告我言。善男子。未来之世人寿百岁。尔时有佛出现于世。名释迦牟尼如来阿罗诃三藐三佛陀。释迦如来以大愿故。大集诸佛及菩萨众。汝当于彼得授阿耨多罗三藐三菩提记。从是已来。拘那含如来亦如是说。迦叶如来亦如是说。我自昔来久发此愿。乃至恒河沙等大劫。于此佛刹作大药天。为除众生一切病故。我于彼时久以大地淳浓精味。布散种种诸药根枝华叶果实。令诸众生普得受用。及灭内外诸病苦故。所有众生若正和合受用之时。令起无常苦空无我。分别心及心数法转。以此善根令我具足般若波罗蜜。如是我于此佛刹作大丈夫事。如是如是。十方恒河沙等诸世界中以女人形。于一一世界如恒河沙劫。以如是相如是力。如是勇猛精进。如是劬劳乃至给侍。如是如是。病苦众生令成熟故。然后我身当得阿耨多罗三藐三菩提。及我今日复于佛前增进本愿。与此息华作大功德其心坚固。常为佐助无有劬劳。我等二人共为女形同一色貌。为欲成熟诸众生故。乃至倍加成熟诸女人故。今我二人取地精气和合饮食。令诸香味悉皆具足。老病众生食此味者。一切病患皆得消灭。以此胜因令我具足般若波罗蜜。若我得阿耨多罗三藐三菩提者。愿佛世尊摄受我等为称善哉。若佛世尊同与我等菩提记者。愿为我等称赞善哉。尔时世尊。称赞成就智菩萨言。善哉善哉。善男子。汝能如是作大利益丈夫。即为成就智菩萨。而说偈言

  汝为世间病者医　　能持诸根得安乐
  莲华清净最上刹　　得佛号毗卢遮那

持地菩萨摩诃萨。亦作是愿。以女人形化度众生。如地持物悕念授记。释迦如来。为说偈言

  汝如大地持一切　　今当速得所希念
  刹名胜摄功德满　　作佛名曰智自在

智上菩萨。愿受女形化度一切。作如是念悕得授记。释迦如来。为说偈言

  汝智充足诸众生　　及以华果方便摄
  未曾闻刹上清净　　得佛名为上胜因

示现灰菩萨。作女人形。受用火事成熟众生。愿得授记。释迦如来。为说偈言

  示诸世间无常想　　成熟众生于菩提
  刹名生尘最吉祥　　于彼作佛名灯火

动众生离尘菩萨。愿作女形。为成熟众生故受用风事。悕念授记。释迦如来。为说偈言

  摇动众生令欢喜　　能令烦恼究竟灭
  刹名清净现平等　　当得作佛号月光

无障碍灯菩萨。愿作女形。为成熟众生故受用虚空事。亦悕授记。释迦如来。为说偈言

  得无依智清净者　　能说无上正觉道
  刹名调障无染着　　当得作佛号智上

妙香说菩萨。愿作女形。为成熟故受用华事。为菩提故悕望授记。释迦如来。为说偈言

  现作香华普供养　　开示诸佛无上道
  莲华藏刹清净土　　得佛号普香如来

袈裟色菩萨。愿作女形。为成熟众生故。受用种种染色愿得授记。释迦如来。为说偈言

  以袈裟衣利众生　　相应供养三宝种
  青光刹中最无上　　当得作佛号宝光

尔时无量诸种子天林天果天。乃至六十七俱胝那由他百千菩萨摩诃萨。为欲成熟诸众生故。倍为度脱诸女人故作女人形。发愿同得阿耨多罗三藐三菩提记。释迦如来。各说一偈各得记莂。何以故。转男为女其事则易。转女作男其事则难。是时百俱胝诸大龙王及诸小龙。同作是愿悕望授记。释迦如来。各说一偈授菩提记。复有六万四千频婆。及八十俱胝阿修罗。七十阿閦毗俱胝那由他百千诸天及诸天女。九十九频婆俱胝百千诸魔及其眷属。乃至恒河沙等人非人众。及刹利婆罗门毗舍首陀。男子女人童男童女。亦皆同心悕望阿耨多罗三藐三菩提记。如是等类。一一各得一偈授记。过于数量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。薜荔多毗舍遮人非人等未发心者。今于佛前同发阿耨多罗三藐三菩提心。过于数量众生住阿毗跋致地。过于数量众生得菩萨种种三昧忍陀罗尼。过于数量众生漏尽离欲得阿罗汉果。亦过数量众生回声闻辟支佛心。住佛阿毗跋致地。如是等一切同声而作是言。我等依一切诸佛教故受此法门。若有受持读诵书写此法门者。我及眷属。当共如法供给供养

    宝星陀罗尼经慈愍品第九

尔时释迦牟尼如来。复作是言。一切诸佛。若怜愍此佛刹众生来相问讯者。当一心念。此息华善男子等。欲令众生得衣服饮食及诸药物。随心受用令充足者。又以女人形相。于阿耨多罗三藐三菩提成熟众生者。一切诸佛应当加护。是息华等令愿满足。如彼善男子所愿。如其所欲如其所为。随彼种种所须衣服饮食并诸药物。若化施设皆令满足。使诸众生所须供侍随意受用。即发心时如是等事悉得成就。彼善男子能作如是建立丈夫所作之事。诸佛世尊。依大悲功德定慧庄严。忆念众生作如是言。以此神咒章句施与汝等。随意所愿皆令具足。一切善根所依。一切三世诸佛世尊所共受持。即说咒曰

哆地也他树柢婆婆(一)地履底婆婆(二)牟尼婆婆(三)娑底也婆婆(四)否若楞迦啰婆婆地也娜(五)啰娑摩呵迦喽拏婆婆(六)摩呵婆啰哆婆婆(七)阿慕呵婆婆(八)楼底婆婆(九)差底婆婆(十)娑履闻婆婆(十一)佉伽婆婆(十二)婆诱婆婆(十三)伐哆婆婆(十四)阿地所吒娜婆婆(十五)阿摩婆婆(十六)阿呵娜婆婆(十七)哆他多婆婆(十八)部哆句致婆婆(十九)涅鼻履底婆婆(二十)底履鸠舍閜婆婆(二十一)底履夜娜婆婆(二十二)哆疑驮计迦婆婆婆(二十三)底履毗慕去所婆婆(二十四)底履首迦罗婆婆(二十五)啰所吒啰地所吒娜婆婆(二十六)婆婆婆婆婆婆(二十七)娑摩多(二十八)阿娜若婆摩哆(二十九)吒吒吒吒吒吒吒所咤死地(三十)萨婆鸠舍逻地(三十一)所咤那也(三十二)娑婆呵(三十三)

善男子。此一切法平等神咒。能令一切悕望者悉皆满足。汝等眷属应当受持。令一切众生随所受用皆得成熟。能令汝等菩提行满足故

尔时息华胜天成智天地持天等。而为上首。与十千菩萨俱。为令众生随所受用得成熟故。以女人形勤劳化度。一时同声作如是言。由此咒力。诸佛世尊。令我所愿皆得满足。如是神咒能与我等作大加护。能令我等得无上智。是故我等当共受持此陀罗尼。欲令一切众生悉成熟故。以大勤劳供给所须。今于一切如来前。愿一切众生普得成熟住于自解。若有天乃至人。于如来所说妙法。欲破坏散灭者。我若不勤方便遮障令妙法久住者。我等则为欺诳一切三世诸佛世尊。亦莫令我得阿耨多罗三藐三菩提。若有善男子若天乃至若人。欲恼乱比丘比丘尼优婆塞优婆夷。我等若不勤作方便遮障。令彼忧恼不消灭者。我等则为欺诳一切三世诸佛世尊。亦令我等莫得菩提。若有求无上菩提善男子善女人。有遭水火毒害厌蛊热病温疟等病。或一日二日三日四日数发动者。如是等畏。乃至天龙夜叉迦吒富单那。刹利婆罗门毗舍首陀。师子犬等疾疫饥渴种种厄难诸余灾恼。有是等畏者。以此一切诸佛所持一切悕求满足陀罗尼神咒章句。令诵念者悉得解脱。唯除先世决定业障。若我等不除彼障则为欺诳一切三世诸佛世尊。亦莫令我得阿耨多罗三藐三菩提。时彼一切诸佛世尊。同来此佛刹集会者皆称是言。善哉善哉。善男子。汝等所愿甚为胜妙。能作如是大丈夫所作事

尔时释迦如来。即为魔王。而说偈言

  于诸来佛当起信　　应生最上欢喜心
  为菩提故生庆幸　　应当速发利他意
  汝魔境界无亲友　　亦无所欲如意者
  汝以无力失魔业　　何能等类我牟尼

于是恶魔。复说偈言

  我无一念信菩提　　心亦不作欢喜想
  语汝牟尼且默然　　我亦自有亲友者
  由彼亲友我有力　　我今住于自境界
  我有最上威德力　　尽汝寿命我不从

    宝星陀罗尼经拥护品第十之一

尔时会中。有佛世尊名曼陀罗香。白释迦如来言。彼过去诸佛。从种种刹土中来于五浊佛刹大集时。并共拥护此法门也。亦令无量俱胝魔众自然退散。以慈悲眼视诸众生。有恶见者皆令解脱。炽然智炬安置众生于吉祥道。说此金刚法等缘法心建立摧碎陀罗尼印章句差别门记法门之时。为令恶党悉皆退散建立法幢。如是如是。我等十方诸佛今日住世。亦为将养怜愍诸众生故。亦于秽恶五浊佛刹同作大集。拥护如此微妙法门。乃至建立无上法幢。释迦佛日灭度之后。谁能于此刹土。当作第一护持妙法。当令正法炽然流布。当使众生普皆成熟。入此大集数者。我等以此法门付嘱谁手。释迦如来。白曼陀罗香如来言。所有旧住此佛刹者。得忍菩萨及释梵护世。天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽等王。勤加拥护此妙法门。及此世界四天下中旧住众生。于此法门生净信者。释梵护世乃至摩睺罗伽王等。以此陀罗尼印清净法门付其手中。是时曼陀罗香如来。以无障碍圆满之声遍此佛刹。作如是言。诸善男子。谛听谛听。所有来此佛刹者。诸如来阿罗诃三藐三佛陀难得兴世。及一切诸佛世尊。于一刹那顷集一佛刹亦甚为难。如此一切诸佛世尊。怜愍汝等故来此集。摄受一切诸众生故。护持诸佛大法门故。置立无上道故。一切诸佛入三世数者。今日护持一切地界一切水界一切火界一切风界一切空界。令此妙法久住世故。令三宝种不断绝故。成熟一切诸众生故。乃至度彼生死岸故

尔时一切诸佛世尊。及诸佛刹旧住菩萨摩诃萨。释梵护世天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等王。及诸余精气中有大精气众生。乃至所有四天下世界居住者彼一切众作如是言。善男子。我等以此诸佛所护正法重付嘱汝。为令众生普成熟故。汝等常应炽然如是不灭坏法不坠没法。若有信心善男子善女人。当共受持书写大集法门。乃至比丘比丘尼优婆塞优婆夷。彼等一切诸善男子。受持诵念此法门者。汝等常当拥护供给。以此法门如法付嘱。若法师乐求法乐禅定乐听法乐持法者。汝等宜应拥护乃至供给。何以故。所有过去如来阿罗呵三藐三佛陀。彼一切如来。亦于秽恶五浊佛刹集者。共以妙法付嘱释梵护世故令此妙法不隐没故护持未来传法人故。乃至成熟一切众生故。如是如是。所有当来十方诸佛。于五浊世一刹那顷普皆云集利益众生故。当说陀罗尼。当拥护妙法。当付嘱释梵护世等。当供给所须。我等今者亦复如是

汝此佛刹诸旧住者。及四天下释梵护世。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等王倍加付嘱。未来之世倍加拥护。倍加供给故。汝亦如是应当忆念。如金刚不可坏法广令炽然。若有信心护持此法善男子善女人。及受持此法比丘比丘尼优婆塞优婆夷。乃至但书持经卷安置家中者。有能说法及乐听者。有勤修禅定受持法者。汝等皆当护彼善心供养供给。何以故。一切诸佛普皆受持此法门故。随所有处。若村若城若国中若边地。若王宫内若阿练若处。若流通此法门。若开示宣说。若授与人。若能温诵。乃至但书写经卷安置家中者。是等众生以此法力故。能令地味及众生精气悉皆增长。汝等以彼精气光泽。精进勇健皆得增长。亦令眷属及其田宅增长丰饶。当令人王常得拥护势力自在。亦当拥护王之化内以彼法味常令充足。阎浮提内诸人王等。当生和合相利益心。恒信业报。种善根心无悭吝心。常于一切众生作利益心。常于一切众生起慈愍心。乃至令王能生正见。各各于己国土自生喜乐。能令具足行善之人充满其国。丰乐倍常地土精味自然倍胜。花果药物无不甘美。谷米财宝亦倍增多。触处可乐。一切人民无病苦者。一切斗诤他方怨敌。蚊虻毒蛇恶鬼罗刹。恶禽恶兽豺狼师子。非时风雨。如是恶事悉当消灭。昼夜常宿一月半月。时节年岁悉皆正行。是诸众生多行十善。于彼命终皆生天上。还与汝等而作眷属。如是无量功德甚多。皆由称扬一切诸佛大法陀罗尼法门故。是诸众生皆度生死此岸得入无余。名闻增长果报满足。所种女身现生后受。以法力故。如是等身一切皆尽

宝星陀罗尼经卷第八宝星陀罗尼经卷第九

        唐天竺三藏波罗颇蜜多罗译

    拥护品之余

唯置作五逆者诽谤正法者谤无贤圣者。身口意业所作之恶业及果报一切皆灭。若此法门乃至经卷。若但书持置于宅中。彼等所有诸业烦恼能为障碍量等须弥皆悉消灭。一切善根悉得增长。一切善分皆悉满足。意所悕望皆悉成就。身口意善悉当增长。一切恶见断灭无余。一切怨敌以法调伏。一切微细寂灭之道悉当得入。以此一切诸佛世尊所共护持大集陀罗尼法门加护力故

随所有国此陀罗尼法门当流行地。能令彼地肥腻精味倍上成就美果妙味当得增长。苦辛恶味当得远离。华果财谷色类成就。仓库贮器悉皆增满。衣服饮食汤药所用倍胜增多。由法力故

若有众生受彼饮食者。当得无病颜色成就。气力强健忆念坚固。乐求善法远离诸恶。彼诸众生若命终已。当生汝等种类之中。眷属增长势力具足怨不能坏。以法力故。当得四姓之所拥护。当以法义共相示诲。汝等若能如是作者。即为供养一切三世诸佛世尊已

尔时曼陀香如来。即依诸佛清净境界智慧音声随类句义。以一切诸佛世尊语悉满此刹。遍告此佛刹中一切诸菩萨摩诃萨及释主梵主摩呼罗伽主所有居此佛刹者。倍复加劝此四天下中所居住者。汝等应当住持开示此诸佛语大集法门。拥护此经微妙正法

尔时众中九万七千俱胝得忍诸菩萨摩诃萨。弥勒为首。居此佛刹者。一切同声作如是言。我等今者奉诸佛教。为欲供养一切三世诸如来故。于此一切诸佛世尊微妙法门。恭敬顶戴尊重如佛。悲愍成熟诸众生故。乃至安置无上道故

我等于诸聚落城邑州县国土王宫诸寂静处。以此法门广布显示。为欲成熟诸众生故。令此妙法得久住故

尔时一切诸佛世尊来此刹者咸作是言。善哉善哉。汝等如是作所应作。是时一切释梵摩呼罗伽主等居此士者。并余来众六十四俱胝那由他等。大精味中有大威德众生。一切同声作如是言。我等于此微妙大集法门悉当受持。乃至广为开示显说。成熟众生故。妙法久住故。乐法听法者悉当拥护

我等今者奉诸佛教。随此法门流行之处。令使一切斗诤违背。谋计诤论。饥俭荒乱。他方怨敌。非时风雨。非时寒热。苦辛涩味。恶人恶物悉当消灭。安隐快乐丰饶和合。悉当成就此妙正法当令久住。倍加勤勇拥护供给正法国王。及以勤修禅定众生悉当拥护

时彼一切诸佛世尊同声赞言。善哉善哉。善男子。汝等今者应如是作。勤作自他利益之事。即于一切三世诸佛为供养已。如汝等勤劳成熟诸众生故。令此妙法得久住故。汝等皆当速得阿耨多罗三藐三菩提

尔时中四天下释梵天主。乃至摩呼罗伽主。及大威德中最上首者。一切悉皆从坐而起。恭敬合掌作如是言。我等亦奉一切诸佛世尊教故。悉共光显此妙正法拥护住持。及此大集一切诸佛所护陀罗尼印法门。当如法受

乃至于诸聚落城邑州县国土王宫诸寂静处。当广开示。持妙法人拥护供给。所有住信正法法师及听法者。比丘比丘尼优婆塞优婆夷。善男子善女人信受此法。乃至若但书写经卷置之家中。勤修禅定。我等于彼拥护供给种种供养衣服饮食。华盖幢幡涂香末香。乃至一切医药资具。诸有所须善作供给。若人能于此妙法门。诵时读时开示说时。我等自往彼法座所。为听法故如大师想。于此法门恭敬尊重一心赞叹。诸盖幢幡持以供养。何以故。我等于此一切诸佛之所拥护陀罗尼法门广开示时。以法味故当得精气。具足力。具足精进。具足志。具足念。具足智。具足善友。具足眷属。具足所有军众。怨不能坏。是故我等令一切国界所有斗诤谋计言讼。饥俭疾病他方怨贼。非时风雨极寒极热灾旱愆时。恶梦恶相粗涩无腻苦辛恶味。恶人恶物诸不善分悉当消灭。倍复安隐丰熟喜乐。无病和合悉当成就。时风时雨寒热以时。昼夜位分半月一月。时节年岁悉令正行。诸宿星曜日月之次不令失度。泉池陂河皆令满足。随有众生所依住处。瀑水漂溺我皆遮断不令覆没。我等于彼国邑聚落利众生故。所有枝叶华果根茎诸谷药味。悉当肥腻色相鲜泽美味滋多。财谷药味衣服庄严诸资具等。令诸众生悉当具足无所减少

彼诸众生求善根心离诸恶业。胜福德聚。及彼寿命悉令成就。所有聚落国土。以此一切诸佛之所拥护陀罗尼法门开示。乃至书写经卷安置家中。若读若诵恭敬供养。于置经处。若有刹利灌顶之王。我当拥护供给所须令无所乏。所无利益当为彼等而除断之。所有利益当为彼等随而与之。一切灾怪惊动不吉。恶见恶作为恶所持。恶愿恶归奸诈赞撽。幻谄妄语嫉妒嗔忿。诸悭吝等悉当消灭。正见正道直信调伏一心惭愧。如是等法悉当示诲

妃后内宫宰相辅臣。主藏亲族刑罚官将。一切人民四姓男女童男童女等。亦当拥护供给乃至惭愧示诲。所在诸方乃至四足亦当拥护。随有国土以此法门宣布开示。乃至书写经卷及经卷住处。以大勤勇彼诸众生悉当拥护。此妙正法随处光显不令隐没。我等当起精进力故。作如是事。是时一切诸佛世尊。悉共称赞诸善丈夫。善哉善哉。诸善男子。汝等如是作所应作。以此正法及三宝种。不令隐没故作勤劳。汝等如是如汝所作。即于一切三世诸佛为供养已

    宝星陀罗尼经护正法品第十一

尔时世尊释迦如来告诸大众。释梵天王。毗楼勒叉。毗楼博叉。提头赖吒。毗沙门等。诸善男子。我以大悲愍众生故。于此五浊秽恶佛刹难得法时。愿得阿耨多罗三藐三菩提。是中众生堕无明闇。烦恼怨贼奸狡恼害。我为众生灭烦恼故。退诸魔党建立法幢。无量众生诸苦解脱。雨大法雨退俱胝魔。诸善男子。是故我今以此妙法。殷勤付嘱汝等手中。如此十方无量世界。过数过量诸佛世尊。及诸菩萨摩诃萨等普来集者。以此金刚法等因缘法心建立一切法摧碎陀罗尼印句门记法门。拥护佛土并诸地味众生所居者。诸过恶消灭故。成熟众生故。一切不善业尽无余故。三宝种久住故。乃至一切佛事成就故。是故汝等受持拥护我妙正法。能令善根福行增长。若温诵教示为他说。授趣三归依优婆塞护住净梵行。诸善根等福行增长。若修初禅福行增长。乃至修灭受想定。若须陀洹果。乃至佛菩提果福行善根。如是等相皆得增长。现在所作乃至未来当作然妙法灯。能令一切福行增长。是故付嘱汝等手中。如来所觉妙法令炽然故。劝发汝等福德增长。是故付嘱汝等手中。若未来世于此法门。乃至书写经卷安置家中。以法力故。一切恶业悉当灭尽。随所有处若在村城。若欲受持当净洗身着新净衣。以华布散烧种种香。敷种种毡褥。严师子座。开示此法说此法门。乃至书写经卷受持读诵。若汝等于彼不来听法。拥护法师及听法者。自他恶业尽故。汝等则为欺诳诸佛愚失正道

尔时娑婆世界主梵天王白佛言。世尊。若于今时若未来世。随所有处。乃至此妙正法未灭已来。若聚落城邑州县国土。边疆远处王城宫内。若僧伽蓝若寂静处。若婆罗门家。若长者大家。若庶民家。若说法师。比丘比丘尼优婆塞优婆夷。及余清信善男子善女人等。好洗浴好涂身着新净衣。散华布饰庄严道场。烧种种香敷种种缯彩设种种味。升师子座。广为他人开示演说此陀罗尼印。若书若读时。我共无量百千徒众。当往彼处围绕听法。拥护彼法师故。及诸听法者自他恶业尽故。一切善法成熟故。大妙正法炽然故。入大智明第一道故。彼诸城邑乃至庶民家。我当拥护彼诸众生。令彼众生财谷丰饶仓库盈满故。若我不来闻所未闻。即于一切佛世尊前违昔誓愿。时梵天王即于佛前而说咒曰

多地也他鸯咎呵澄(去音)伽否啰茶(去)拏(一)耶弭吐(二)佉佉(三)佉婆(四)佉婆(五)吉利那佉婆(六)娑婆呵(七)

时梵天王说此咒已。重白佛言世尊。若我于彼说法师处。不来听者不拥护者。乃至财谷丰饶仓库增长故。众生充足故。即违本誓愿

尔时一切诸佛世尊。及大菩萨摩诃萨。一切天人人非人等。同声赞彼大梵天王。善哉善哉

尔时释天主憍尸迦白佛言。世尊。随所在处。若今现在若未来世。乃至村城。若我不往闻所未闻。即于一切佛世尊前。违昔誓愿为有过者。即于佛前而说咒曰

多地也他佉婆弭履佉(一)佉婆弭履佉(二)那閜伽(三)阿母若(四)阿母婆呵(五)阿呿吒(六)阿吐(七)婆舍吐(八)嗜那婆啰揭(九墟偈反)娑婆呵(十)

时释天主说此咒已。重白佛言世尊。若我不作如昔所愿者。此即是我自违誓愿为有过者。是时大众乃至人非人等咸称叹言。善哉善哉释迦天主。尔时毗楼勒叉天王白佛言。世尊。随所在处。若今现在若未来世。乃至城邑有此法门。我若不往不作拥护。世尊。此即是我自违誓愿为有过者。即于佛前而说咒曰

多地也他欧佉(一)那婆娑荼(二)娑母陀啰赐儿(三)哆他负多(四)婆楼(上音)拏婆婆啰阇(五)娑婆呵(六)

是时大众乃至人非人等。咸共称叹毗楼勒叉大护世言。善哉善哉

尔时毗楼博叉天王白佛言。世尊。若今现在若未来世。随所在处乃至城邑有此法门。我若不往为作拥护闻所未闻。即于佛前违昔誓愿为有过者。即于佛前而说咒曰

多地也他阇老伽(一)阿到伽(二)阿历耄伽(三)阿历么(四)娑连社婆(五)脾(毗也反)耶母阇(六)娑婆呵(七)

是时大众乃至人非人等。咸共称叹毗楼博叉天王言。善哉善哉

尔时提头赖吒天王白佛言世尊。若今现在若未来世。随所有处乃至城邑有此法门。我若不往为作拥护闻所未闻。即于佛前违昔誓愿为有过者。即于佛前而说咒曰

多地也他频头社婆(一)佉婆社婆(二)啰母佉(三)叉娑啰(四)否迦婆呵(五)阿(上声)末伽婆吒(六)娑婆呵(七)

是时大众乃至人非人等。咸共称叹提头赖吒天王言。善哉善哉

尔时毗沙门天王白佛言。世尊。若今现在若未来世。随所有处乃至城邑有此法门。我若不往为作拥护闻所未闻。即于佛前违昔誓愿为有过者。便于佛前而说咒曰

多地也他簉(初后反)陀利(一)簉簉簉陀利(二)佉陀利(三)阿儞簉陀利(四)那也那簉陀利(五)醯履哆簉陀利(六)娑伽啰醯履哆簉陀利(七)僧九娑簉陀利(八)达摩叉耶簉陀利(九)娑婆呵(十)

是时大众乃至人非人等。咸共称叹毗沙门天王言。善哉善哉

尔时于此世界。此四天下所有一百一十二夜叉大将主将军众。于四天下守卫拥护者。复有四万夜叉。于此四天下居住者。复有大神通中最胜诸天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩呼罗伽等。咸共同声白佛言。世尊。若今现在或未来世。随所在处有此法门。乃至此妙法灯不灭已来。若在聚落城邑州县国土。王城王宫阿兰若处。若婆罗门家长者家。居士家庶民家。若法师。若比丘比丘尼优婆塞优婆夷。复有诸信心善男子善女人。应好洗浴以香涂身着新净衣。散华布饰庄严道场。敷置种种毡褥衣服。烧种种香。种种美味盛满净器。施设妙好师子法座。升此坐已。广为他人分别开示此经。及读诵时。我等一一与无量百千眷属围绕往彼听法。为拥护法师。为拥护己众及余众生。为拥护故。成熟众生故。我等若不往彼城邑乃至庶民家。及以眷属不受教敕不成熟众生。不令众生丰饶财谷仓库盈满。又复一切斗诤。饥馑疾病。他方怨敌。非时风雨。极寒极热。诸灾难等若不遮断。我等则为欺诳过去未来现在诸佛世尊。违本誓愿空无所得。得白癞病退失神通身体烂坏

世尊。虽复如此。我等今者并诸眷属。若今现在若未来世。于此世界四天下处。决定光显释迦如来微妙正法。及信此法人当为拥护供给所须。所作成熟恶业灭尽。我等于此法门教示开显彼说法人。又令说法人及听法者财谷丰饶。诸所受用悉当增长。于佛所说不坏不灭法。悉当受持。时彼一切诸佛世尊。一切大众人非人等。咸共同声。赞彼天龙护法神等。善哉善哉。汝等如是善所应作

尔时怀乐菩萨于大众中即白释迦如来言。世尊。云何此百俱胝所有诸魔并诸眷属。一切尽皆来到此耶。佛言善男子。此一切魔并诸眷属悉来此会。怀乐菩萨复白佛言。云何世尊。此一切魔并诸眷属。于三宝中得清净信不。佛言不也。复次善男子。此诸恶魔一千眷属。于三宝中而不得意。不清净信返生嗔恨。若今现在若未来世。乃至此妙正法炽然已来。当勤方便伺求其短。令正法灭坏故。隐没故。如是复有十八诸魔。并其眷属一万三千。如是复有二百诸魔。并其眷属二千一百。彼诸魔等。于三宝中悉不得意。不清净信返生嗔恨。若今现在及未来世。乃至此妙正法广流行时。常勤方便伺求其短。令我教法及妙正法灭坏故。隐没故。何以故。往昔已来憎嫉力持故。不种善根故。为恶知识所摄故。于善离欲无受乐中。永无悕望无欲愿故

彼诸魔心。于如来心及菩萨心未曾和顺。住不净信不解脱故。是诸魔等今虽不信。以见如来大集妙色。及得闻此甚深陀罗尼。以是因缘故于后时得清净信得阿耨多罗三藐三菩提。怀乐菩萨作如是言。希有世尊。希有善逝。彼等众生乃至不种善根。若但耳闻触此法门。如是因缘故当得阿耨多罗三貌三菩提

尔时有魔名曰不去。曾于佛所极多供养。于三宝中净信不动。得阿耨多罗三藐三菩提记。作大仙人形从坐而起。于释迦如来前合掌遍观如来。世尊威力加故。于一切佛刹大声遍满。作如是言。诸佛世尊一心念我。一切菩萨摩诃萨。及天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩呼罗伽人非人等。魔及眷属听我所说。今此世尊释迦牟尼大悲导师。往昔之时誓愿如是。于极秽恶五浊佛刹。得阿耨多罗三藐三菩提。作逆众生诽谤妙法谤无圣人。具不善根恶行相应。心相续成就者。普令出过三恶道故。成熟三乘故。修忍三昧陀罗尼故。引向清净诸佛刹土。令三宝种久住不断。成就大愿。断除一切秽浊佛刹。成满一切功德庄严

是故我等当如是作。为令如来正教久住。及妙正法得不灭坏。若今现在若未来世。无有若魔若魔眷属。于如来所受正法。欲灭坏阴没。乃至不能恼一众生。唯除少随顺不具信者。若持此妙法者。随顺此法者。说此法者。听此法者。比丘比丘尼优婆塞优婆夷。及余信心善男子善女人。勤修三业能自策勤。坐禅诵经营理塔寺。恒勤作福。勤事供养佛法僧宝。勤断三界烦恼系缚。勤断一切众生诸苦。悉令解脱者。彼等行人若为魔使。若魔女魔男。若魔眷属欲恼乱彼。伺求其短障难善业。作乱心因者。为彼等故。我今现前请诸世尊。当与我力善业成就。怜愍我故。一切菩萨摩诃萨等。并一切魔及魔眷属。一切天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩呼罗伽人非人等。所有一切来此佛刹者。及大地众。为欲利益诸众生故。佛教正法得久住故。当怜愍我。今欲说咒与我成就。若魔若魔眷属。欲恼彼等人及法者。我当降伏令其心乱令其身苦令身恼缩退失神通。故说此咒句。若诸恶魔并魔眷属。魔男魔女。若魔使等。若于佛教起一念恶不清净心。恼乱诸比丘比丘尼优婆塞优婆夷。乃至但起一刹那心。欲作恼乱退失善分。若于村城国邑。乃至王城宫内。边疆静处。随所在处。有此法门开示分别。若于此等起破坏心。乃至一刹那。于彼诸方斗诤疫死。饥俭诸病。他方怨敌。非时风雨。极寒极热。瀑水卒起。地动地吼。火星流堕。有如是等诸恶相起。或于华叶果实诸谷药味。欲于彼等起破坏心时。即令彼魔乃至魔使。郁热所烧熏污烂臭。无所能作不能起举。五系缚之令其自见乃至一切支节。卷缩不能舒展。令得黑闇不睹光色。退失神通心意错乱。令彼六根不能缘境。即说咒曰

多地也他阿摩离(一)阿[馬*甘](呼甘反)么离(二)阿[馬*甘]么离(三)阿阇婆婆(四)阿阇婆婆(五)茂啰沙离(六)鞞夜佉娑离(七)社么娑离(八)呵呵呵呵呵呵(九)瞿啰娑吒(十)社那呿伽(十一)尔也呿伽(十二)泌(毗蜜反)尔也婆娑呿伽(十三)阿茂叉啰(十四)叉叉叉叉叉叉(十五)茂啰婆呵(十六)呿伽娑婆呿若(十七)娑婆跛履跛哆茂啰(十八)阿(上音)若若婆由若(十九)毡陀啰嗽履也若若(二十)那婆(上音)若若(二十一)丘啰叉若若(二十二)婆婆若若(二十三)倍哆句胝哆他(上音)多若若(二十四)萨婆尔脾啰地(上音)史耻多若若(二十五)婆迦啰么(二十六)底履健哆叉婆(二十七)叉么摩叉摩若(二十八)差(初几反)上哆摩啰毗所也(二十九)娑婆呵(三十)

尔时不去魔说是咒时于刹那顷。由得一切智拥护故。诸魔境界悉皆灭坏无所成就。如是如是所有欲作不利益者。皆不成果。是时一切诸佛世尊。咸共称赞善哉善哉。及一切菩萨摩诃萨。天龙夜叉人非人等。亦共称赞善哉善哉。是时大地皆大震动。四海涌沸。诸须弥山王。魔及眷属悉大惊动。是时恶鬼神等亦复如是。唯除于佛教法清净信者。及得忍菩萨不生惊怖

尔时魔王问坚固慧菩萨言。善男子。何等因缘。此不去魔有是胜力。是谁加彼。此无慈悲。令我部党及我境界力之所作。一切散灭悉皆退坏。乃更建立沙门瞿昙。黑党亲眷说断恶见。我即闻此陀罗尼时。令我身体臭恶烂坏无所能为。一切诸方为我黑闇。不见诸光大热所烧耶

尔时坚固菩萨答魔王言。此是一切诸佛世尊神力加护。亦是一切人非人等。与此不去魔力故。令汝等一切诸魔境界之力。如所欲作悉皆摧碎。今说此不退陀罗尼句时。汝今应生清净信心。于如来所。发阿耨多罗三藐三菩提心。汝今若能如是作者。此身口意诸苦恼触悉当解脱。是时魔王答坚固菩萨言。我今宁当忍耐此苦。令身口意。受于无量无数大苦恼事。至于最后边际劫。我终不发阿耨多罗三藐三菩提心

宝星陀罗尼经卷第九宝星陀罗尼经卷第十

        唐天竺三藏波罗颇蜜多罗译

    阿吒薄俱品第十二

尔时夜叉众中。大将军主名阿吒薄俱。而作可畏夜叉之形。复有夜叉名曰为想。而作鹿形。复有夜叉名曰智炬。作猕猴形。复有夜叉名舍渴爱。作羖羊形。复有夜叉名曰断流。而作象形。此五夜叉是善丈夫。去释迦如来不远。于憍陈炎如来前坐。此等五人一切身分。皆出清净微妙香光。各以两手捧光明大宝。为供养世尊故尔时怀乐菩萨摩诃萨。以清净心观彼五人清净所依。乃是菩萨摩诃萨。即告阿吒薄俱大夜叉军将言。善丈夫。汝等今者见何等义。现如是相威仪所作供养世尊。时阿吒薄俱答怀乐菩萨言。善男子。于过去世九十一劫。于此佛刹有佛出世。号毗婆尸如来应供正遍知。彼佛世时。我等兄弟同一母生。于彼佛所。俱发阿耨多罗三藐三菩提心。为成熟众生勤作方便。从彼已来于尸弃如来所如是毗叶婆如来所。乃至于此大贤劫中。最初如来名拘留孙。彼佛出世。从尔已来我等大愿常作同母兄弟。于彼如来。我等兄弟以种种供养供给所须。彼佛世时想善丈夫为优婆塞。乐修禅定作如是愿。愿我常于大贤劫中作夜叉大将。若有夜叉居住空野之处。于诸众生常怀恶心无有悲愍。种种杂类夜叉之形。乃至迦吒富单那等。我以方便现同彼类。为说正法令生净信。得净信已为受戒法。置之吉祥安隐善道。乃至随所有处。诸畜生趣亦复如是。獐鹿虎狼猪羊犬等为其说法。乃至恒河沙数恶夜叉等。诸畜生趣尽同所作。为其说法令种善根。彼成熟已安置于彼三乘正道。然后我得阿耨多罗三藐三菩提记。智炬夜叉愿作猕猴形者。为成熟猕猴故。舍渴爱夜叉愿作羖羊形者。为成熟住八难众生故。断流夜叉愿作象形者。为成熟象等故。如是万二千诸大神通夜叉。居四天下者。往昔已来作种种愿。为成熟众生故。为求阿耨多罗三藐三菩提故。于彼拘留孙如来前。求阿耨多罗三藐三菩提时。为成熟恶夜叉故

愿尽大贤劫彼恶夜叉无悲愍心。乐作恶法无恩慈心。乃至迦吒富单那夺精气者。狂乱他心者。作不善心者。杀害众生者。乃至邪见者。刹利婆罗门毗舍首陀等心狂乱者。道路城邑州县国土等中作狂乱者。作诸灾怪星宿日月。昼夜度数。半月一月时节年岁皆令失度。斗诤谋计。饥馑疾病。他方怨敌。非时风雨。极寒极热。和合集起如是恶事。种子药草花果汁味悉欲破坏。众生喜乐无病和合。于善法。欲地味精气财谷宝物。食味法味解脱味皆令灭没者。有如是等诸恶夜叉。教令受戒置不退地。然后我乃取阿耨多罗三藐三菩提记。我从彼已来。常生诸恶大夜叉中为大军将。乃至极恶迦吒富单那等。以三乘法成熟安立。置于不退之地。从是已来。见下中上鬼不曾轻欺。如所见形我同彼形。随类与语筹量渐进令其欢喜。断除诸恶立慈悲心。满悕望已。教令供养佛法僧宝。令不退转。随有夜叉眷属之处。我当往彼以法教示。彼诸夜叉随其住处。若见我来咸共白言。善来阿吒薄俱。由彼称我名阿吒薄俱故。我名阿吒薄俱。若今时人无先圣法。住于恶戒常行黑业。彼命终已生三恶道。少分众生生于人中。若行杂业者。于三宝中时有净信。彼命终已由杂业故。杂生诸恶夜叉迦吒富单那中。于世间中倍复增长。彼等一切白法之分方便灭坏。由彼恶故。今时斗诤倍复增长。我又不能于一切时。于恶夜叉乃至恶富单那。以柔软语置于白法

我又不能于一切时。于沙门婆罗门刹利毗舍首陀罗等。男女长幼小男小女除其扰乱。我又不能于一切时。城邑州县国土道路除其扰乱。我又不能于一切时。令诸鬼神等心心数法置解脱味。善男子。我今蒙一切诸佛威德力故。已得善入一切夜叉迦吒富单那等方便谄心智。善男子。有陀罗尼。名金刚佉婆娑履诸鬼心大暴恶明咒。若有行此咒者。诸夜叉女。夜叉父母。夜叉男女。夜叉夫妇并其眷属。若罗叉罗叉女。乃至龙龙女。鸠槃茶鸠槃茶女。颠病鬼。疟病鬼。若日日发。乃至四日发鬼。若迦吒富单那迦吒富单那女。迦吒富单那父母。迦吒富单那男女。迦吒富单那夫妇并其眷属。不复更能恼乱。刹利婆罗门毗舍首陀。乃至国土。复次善男子。随所有处。若城邑州县。若王宫内。乃至庶民家。此金刚佉婆娑履诸鬼心大暴恶明咒。随处开示。时彼处所有恶夜叉迦吒富单那等。往昔已来憎嫉随逐。不善业者愿令悉舍。生于慈悲柔软之心。于一切众生起利益心。若一切聚落家宅。为天龙夜叉迦吒富单那等之所扰乱。一切日月星宿灾怪。毒气等之所加害。厌蛊扰乱。及身中风病黄病阴病疟病。若日日发。或二日三日四日发。癞病癣疥。欬嗽丁疮。腹痛支节等病之所扰乱。皆得除灭。愿令人非人等及至禽兽。勤修白业断诸怖畏。具足喜乐昼夜受乐。布施调伏摄护身口而无懈怠。勤修乐求助菩提道。又作如是言。善男子。诸佛世尊随喜加护。与我此咒成就业句。能除一切扰乱恶法。遮断一切不善之分。增长一切善法之分。我今欲说此一切诸恶金刚佉婆娑履大明咒句。释迦如来当加护我圆音演说。若我圆音演说此文字。声满一切佛刹者。如是诸来大众。闻此圆音演说句义文字皆令欢喜

尔时世尊释迦如来。告阿吒薄俱大夜叉军将言。善男子。我等诸佛已加护汝此圆音演说金刚佉婆娑履诸鬼心大暴恶陀罗尼咒。破坏黑党炽然白法。善男子。汝当勇猛。说此能除一切扰乱金刚佉婆娑履诸鬼心大暴恶明咒。遮断一切诸恶咒句。是时阿吒薄俱大夜叉军将。即从坐起曲躬合掌。向释迦如来以大音声。尽此佛刹普皆告知。即于佛前说此咒句

多地也他豆(上音)摩豆摩(一)驮摩驮摩(二)豆摩豆摩(三)儞履娜(四)娜罗努罗儞罗(五)鸠吒儞鸠吒儞(六)摩诃鸠吒泥(七)吒吒吒株(八)摩诃吒吒(九)阿婆娑(十)阿毗阿毗(十一)履尼履尼(十二)摩诃履尼履尼(十三)履弭履弭履弭(十四)陀履弥(十五)履簁(平音)摩诃履簁(十六)首楼首楼(十七)摩诃首楼首楼(十八)首楼首楼陀(十九)摩诃首楼首楼(二十)呕舅摩舅摩(二十一)舅摩那(二十二)履弭履弭(二十三)醯履醯履(二十四)醯履醯履(二十五)醯履醯履(二十六)醯履醯履(二十七)醯履(二十八)儞弭儞弭(二十九)醯儞醯儞(三十)母儞母儞(三十一)部地(上音三十二)履跛啰婆啰(三十三)所吒(上音)所吒路迦(三十四)柘履耶视泥视泥(三十五)视娜履所婆(三十六)视娜视娜履所婆(三十七)娑婆呵(三十八)

是时阿吒薄俱大夜叉军将说此咒已。即白佛言。世尊。随所有处若城邑乃至庶民家。说此金刚佉婆娑履耶大明咒句时。若有夜叉乃至迦吒富单那。心不净信。及身口意不受教戒。不于众生起慈悲心。以是故。我今更说倍复严迅大明咒句。即于佛前而说咒曰

多地也他阿(上音)眵(一)阿眵(二)母泥母泥(三)阿(上)耆(上)泥朽朽(四)母泥母泥(五)历娜履所婆(上音)朽朽(六)阿迦啰檀池(七)阿哆檀池(八)阿哆阿哆(九)阿底(十)呕吒(十一)醯(上音)儞(十二)醯儞(十三)醯履醯履醯履醯履醯履醯履醯履(十四)哆哆啰舅历(十五)舅历舅历舅历(十六)醯履醯履(十七)儞里儞里(十八)摩呵儞里(十九)三母陀罗儞(去音)佉(二十)呵吒呵吒呵吒(二十一)阿啰拏弥(去音)佉(二十二)叉婆佉(二十三)比履地毗(二十四)阿(去音)跛(二十五)帝(多易反)殊(二十六)婆由(二十七)阿迦舍(二十八)[口*陀][口*陀]陀穷脾(二十九)朋穷脾(三十)恶差(初饥反)穷脾(三十一)视许婆穷脾萨傍(去音)伽穷脾(三十二)啰袪穷脾(三十三)娑陀娑斗穷脾(三十四)娑婆呵(三十五)

尔时阿吒薄俱夜叉大将说此咒时。应时无间。一切天龙夜叉。迦吒富单那皆大惊怖。此佛刹土地及虚空住者悉皆战怖。一刹那顷如是一切诸鬼。即于佛前合掌敬仰作如是言。南无一切诸佛。南无南无一切诸佛。最胜大悲愿悲愍我。阿吒薄俱夜叉大将。说入一切鬼心咒句

    宝星陀罗尼经诸佛还国品第十三

尔时一切诸佛世尊。从十方来者。各从坐起现还国相。是时大众地及虚空住者悉皆战怖。一切大地悉皆震动。从空雨华。于虚空中作百亿乐。烧香末香从空而下。光明遍照此佛刹内。一切大众皆悉合掌。尔时娑婆世界主梵天王问大栴檀香佛言。世尊。是诸众生。以何善根当得具足。诸佛世尊。以几种法加护众生。于未来世得此法门。当受当持当读当温诵。及为余人。当广开示。书写此经。书写已安置家中

尔时世尊大栴檀香如来告梵天王言。如是梵王。一切诸佛。加护众生六界之身。调伏魔党故。息灭斗乱故。成熟众生故。妙法久住故。净无上道故。如是一切诸佛世尊诸大菩萨。有十种法加护众生。于未来世得此法门。当受持读诵。书写经已安置家中。何等为十。一者一切诸佛诸大菩萨。殷勤付嘱一切天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩呼罗伽等。常令拥护受持法人。不起非法。身口意业。示诲善法。随所受用衣服饮食。常令丰足无病安隐乃至舍己身命。护持法人令无过失。二者彼人所得念慧乐说。趣巧方便得无过失。及彼欲乐相应意觉深忍具足。随所住心如空如地。三者以四摄法劝诸四众及余众生。得住善法取坚固身。三事清净行菩提道。四者得宝幢三昧。得是三昧巧能观察诸三昧门。五者彼持法人随处命终。无量无数诸佛世尊。诸比丘众诸菩萨众。常现在前将养说法。六者诸佛世尊所说成就句义文字法。时悉皆得闻。即得一切最胜圣法无受喜乐。彼一切业障。随彼命终最后刹那。舍寿死识。得如法灭。犹如死法阿罗汉灭。七者如所悕望清净佛刹随意化生。彼诸世尊住世将养。常说清净大乘教法。彼持法人。于此大乘无障碍智。具足如虚空心而住。八者不久于此功德悉得具足。九者彼持法人。秽浊佛土不复受生。除自本愿。十者速疾当得阿耨多罗三藐三菩提。是为十法。诸佛世尊。以此十法加持法人。若于今时若未来世。此妙正法当得炽然。若有受持此陀罗尼法门。乃至但书写此经安置家中。一切诸佛诸大菩萨当拥护彼持法之人。一切烦恼悉得解脱。即是菩萨摩诃萨也

尔时世尊释迦如来告释梵护世。诸善男子。此诸世尊。皆从十方普来会者。怜愍汝等诸众生故。令此世界外物清净故。成熟一切众生故。显示菩提行故。退魔党故建立法幢故。显示一切佛事故。三宝种不断故。灭一切病故。遮一切恶故。拥护一切怖畏故。断一切恶见故。入菩提道故。满足如来十力故。尽一切烦恼业故。说此希有大希有相。昔未曾有昔所未闻。甚深句义陀罗尼。拥护家宅城邑国土。乃至拥护此四天下。天龙人非人等。谷药花果。护说法师及听法者。为得无著陀罗尼故。入如虚空智故。以一法式得一切智智故

复次善男子。以此法门故。一切诸佛依入大悲智。以十种法护此佛刹中一一诸物增长不坏。善男子。一切诸佛菩萨。于此佛刹遍皆受用无空缺处。护持一切善法故。一切佛土所受生者。于此佛刹当起尊重礼拜。如塔庙想如大师想。由此佛刹所受生者。善能建立一切法故。灭除业障五逆罪故。具不善法得不爱果。尽无余故。住诸善法。善男子。此是诸佛于此佛刹大丈夫业。善男子。汝等应当恭敬受持此法。若有在家及出家人。受持此法者。及信此法者。汝等应当守护此人。汝等当得利益安乐故

尔时俱苏摩幢如来。于此法门称扬功德。说如是偈

  净金满诸刹　　舍供诸如来
  不如持此经　　福德无边量

尔时胜宝盖如来。亦复如是。称叹此经无量功德。说如是偈

  若持金宝聚　　施与恒沙佛
  不得如此福　　如彼持经者

尔时须弥峰如来。亦复如是。称叹此经无量功德。说如是偈

  最上华聚盖　　连布覆虚空
  普施于诸佛　　净喜心供养
  末法欲尽时　　多诸怖畏事
  持此经福量　　诸佛不能说

尔时释迦如来亦复如是。称扬此经无量功德。说如是偈

  若起净心牟尼前　　炷如须弥香油灯
  无量俱胝大劫中　　熙怡持此以供养
  复有余人乐福德　　悕求无障解脱身
  法欲尽时以此经　　为信者说福胜彼

尔时阿閦如来。亦复如是。称赞此经无量功德。说如是偈

  若修持忍慧　　常起精进行
  禅定摄身仪　　及以广大智
  末世斗诤时　　持此妙法印
  修忍进无等　　智慧亦无比

尔时净三昧勇力如来。亦复如是。称赞此经无量功德。说如是偈

  开示此经法　　受持及书写
  授与他相应　　复能常读诵
  烧香以供养　　华鬘及上服
  所得诸功德　　无能度量者

尔时无量无数诸佛世尊。称扬此经功德利益无量无边。既称赞已即告释梵护世。诸善男子。汝等一切受此法门。尽烦恼障一切业障。于后末世。若有众生但闻此经。尽烦恼障一切业障。佛说此经已。一切世间得信善男子。天人阿修罗乾闼婆等。闻佛所说欢喜奉行

宝星陀罗尼经卷第十


大哀经

    No. 398 [No. 397(1-2)]

大哀经卷第一

        西晋月氏三藏竺法护译

    诸菩萨所生庄严大会法典品第一

闻如是。一时佛在王舍城灵鹫山。古昔诸佛之所游居。如来威神之所建立。其地道场。诸菩萨众所共咨嗟。无极法座。天龙鬼神揵沓和等。咸俱归命稽首为礼。而于佛土宣畅德本。如来威光。慕乐法门菩萨神明等。入无量无限功德如来所行。成等正觉转妙法轮。为极元首善宣开化。于一切法而得自在。所度无极。明晓众生志性所趣。睹其诸根。便度彼岸晓了一切。蠲除挂碍。诸所止处为作佛事而无俗业。坚住于行莫能当者。大比丘众六百万人。一切人民。灭除尘欲无众蔽碍。则为如来法王之子。行深妙法。其所由生不从颠倒。柔软和雅威仪礼节而皆备悉。为大众祐如来之道。而得亲近。诸菩萨众不可称计。行无挂碍。决了普智诸通敏慧。又诸大菩萨大慈大哀。兴布法云而演电明。为雨甘露满饱众生诸久饥渴。等心一切执志如地。诸所妄想倚着结缚皆已除弃。熙降弘恩。道品之法三十有七。犹如日殿圣慧之宫。明智光曜靡所不照。灭大幽冥显示世间。指其道路宣其德本。若如莲华开[門@為]之时。枯竭恩爱。志深渊池。兴立正业具大神通。游于虚空。譬如月宫照乎夜闇。所可游行等心众生。得其志性靡不忻悦。善权方便有益无损。至于道谊亦无增减。普现所行。志若须弥坚住不动。常修梵行供养三宝。于诸境界无能移转。过诸世间之所有法毁呰诽谤。现于一切诸佛国土。而现亲厚。神曜远照志如大海。其器广大盛满法水。修菩萨行。一切众生之所宗戴。犹如师子君主最尊。奉四圣谛怀于大悲心慕慈愍。寂然观察。所察普显。于深妙法而无所畏。坏诸外道。于无央数百千诸劫。究竟无抵。其若菩萨行不以懈惓。一切诸德悉已具足

其名曰普观见无尽菩萨。皆睹诸国庄严遍现菩萨。如来种性成就无退菩萨。威仪化众示无嗔恚菩萨。无量辩才幢英变音菩萨。积累清净金光威神王菩萨。分别光明辩解散句菩萨。生无量福积累亲业菩萨。如是等类无数菩萨

于是世尊班宣法门。名曰生诸菩萨。佛成正觉时十六年。见诸梵行普皆兴盛。睹诸菩萨咸来集会。欲演如来诸持法藏。而众开士皆悉云至。佛自念言。吾宁重增诸菩萨行。使得将护兴立道行。曾有经典讲无盖门。如来所为无极变化。为诸菩萨大士之众。当令进入如来境界。于时世尊以佛境界。变现如来三昧正受。佛适以此佛境。变现定意正受众祐圣旨。上虚空中自然高座。如三千大千佛土。广大高远。上至欲界及无色界。悉佛正行如来功德之所兴化。诸菩萨众性行清净。照于十方诸佛世界。悦可无量众生意行。一切诸天龙神宫殿靡不蒙曜。请召十方诸菩萨等。咨嗟无量名德之称。悉坐无数重阁交露。或有紫金以为墙壁。吉祥藏宝以为轩窗。以玛瑙宝而作户牖。明月藏宝以为栏楯。离垢光宝以为户扇。以普明宝而为重阁。一切众宝而为垣障。垂诸贯珠竖众幢幡。而然锭镣。悬诸缯盖。上好栴檀而用垩涂。异妙栴檀可意众香。怀来越度。海中名香而用然之。龙所出宝若干种华。而散其上。众宝之树罗列而行。诸宝香炉巍巍微妙。其所光饰。普周十方诸佛世界。清净奇妙欢悦人心。普悉现于高座之中。其师子座不可称数。亿百千垓而自然现。高座粲丽广长而峻。众所钦乐莫不忻庆。此四大域所有部界。则自然生四万宫殿而甚高大。又其栏楯高四丈九广二十里。以夜光珠离秽宝珠梵英宝珠。悬在幡盖。而以紫金庄饰交露。出自然音。从地以上乃至高座。又既崇妙自然化成无有作者。如是此四域所兴变化。三千大千世界亦复如是。诸有四域悉等无异。皆自然生无极宫殿。于时世尊安隐寂然从三昧起。应时三千大千世界六反震动。其大光明靡所不照。佛与菩萨诸弟子众眷属围绕。诸天在上歌咏功德。而雨众华散诸天衣覆盖虚空。烧众名香。空集乐器而自然鸣。十方佛国皆自然动。光照无量诸佛国已。佛大神足无极变化。境界无限威神无际。圣光无边感动无底。于灵鹫山忽然不现。与大众俱。诸天龙神揵沓和阿须伦迦留罗真陀罗摩睺勒。侍从世尊欲听经法。又四天王与诸天俱。见佛世尊欲诣讲经。于上叉手雨诸天华。供养大圣以偈赞曰

  日月之威曜　　明珠天然晖
  佛光悉蔽之　　消灭三恶趣
  其明遍佛土　　越须弥铁围
  悉归命最胜　　咸各怀踊跃

时四天王从诸天人。各以此偈赞世尊已。忻戴无量。时天帝释与忉利天。见于大圣欲诣大殿。至高座所则施供养。雨诸天香散于佛上。叉手以偈而叹颂曰

  神足度无极　　显变化无等
  现乎亿佛土　　最胜日以出
  降伏诸魔界　　普德净庄严
  其神足自在　　稽首无等伦

忉利诸天偈赞佛已。侍从世尊

时须深天王。见佛欲诣宫殿高座。雨于天衣叉手赞佛

  安住慧无量　　普知众生性
  无著如虚空　　皆远三世事
  一心入诸行　　悉晓群生性
  是故可奉敬　　三世悉戴仰

时炎天王偈赞佛已。侍从世尊

兜率天王与诸天俱。见于世尊欲诣宫殿大高座所。雨天珍宝而供养佛。叉手赞曰

  宜畅于经谊　　观如幻野马
  彼则无文字　　何有意心像
  兴愍哀众生　　故佛赞尊法
  归知法自然　　胜晓无吾我

时兜率天王偈赞佛已。侍从世尊

无憍乐天王与诸天俱。见于世尊欲诣宫殿大高座所。雨宝璎珞供养佛上。叉手赞曰

  显示乎法身　　十方如虚空
  最胜现色像　　愍哀而开化
  宣法无有色　　最胜行普平
  礼法自然慧　　明识一切谊

无憍乐天以偈叹佛。侍从世尊

化自在天与诸天人。见于世尊欲诣宫殿讲堂高座。雨天宝珠而供养佛。叉手赞曰

  禁戒离诸垢　　则立于清净
  劝化其高尊　　定意不可动
  智慧无等伦　　如海无嗔恨
  已度于终始　　稽首得自在
  神圣之足底　　自然立相轮
  显修乎慈哀　　从本此为先
  解脱三迳迹　　稽首佛德行
  则以悲哀故　　增加以平等
  以寂然为华　　解脱成其实
  犹如蜂之王　　劝化诸眷属
  安住如莲华　　以头脑稽首
  善建立禁戒　　住于安谛地
  精进之势力　　超殊无能逮
  稽首正品类　　甚尊不可动
  愍哀为清净　　道场成光曜
  智慧离垢秽　　威明消闇冥
  无数百众生　　咸共归稽首
  则为无极觉　　头面礼大圣
  其脱门之迹　　音畅于虚空
  智慧驰悬远　　光明照十方
  众生华百千　　令得解开彼
  觉了离垢秽　　稽首无所著
  察之无等伦　　何能有踰者
  求之于十方　　导师不可逮
  功勋甚众多　　一切德备悉
  吾今而咨嗟　　其志无饱满
  阿须伦诸龙　　帝主所归礼
  无数诸天人　　佥共叹其德
  其所赞名称　　众多难思议
  举誉礼世尊　　功勋皆流布

化自在天偈赞佛已。侍从世尊

于时世尊则以无量佛之境界。感动变化。为百千天人所共咨嗟。诣宝高座。时佛世尊适升高座。四域宫殿悉知见之。一切三千大千世界。诸在四域皆复如是。悉知见之。于时大圣坐于三千宝护高座师子之床。诸菩萨众及大弟子亦复次坐。于是大圣有三昧名无盖法门娱乐。以此定意正受。佛适三昧。圣体诸毛一一毛孔。各出江河沙等光明。威曜尽照东方诸佛世界。靡不周至。南西北方四隅上下。亦复如是。尽照诸界遍无遗漏。所照十方诸佛国土。应时诸土一切地狱。勤苦拷掠悉为休息。畜生解脱。饿鬼得安。时诸众生诸患消除。不为淫怒愚痴所惑。而无瑕秽苦劳之难。慈心相向共相瞻视。如父如母。如兄如弟。如子如身无异。如来光明照诸菩萨诸菩萨众承佛威神。光曜之中说此颂曰

  精进力无量　　广普无所住
  又以精勤力　　越度亿载劫
  十力功流布　　普达于十方
  释迦文威光　　广照于一切
  其欲求法谊　　故往百千土
  礼佛听尊法　　而至忍世界
  其在兜率天　　十方诸菩萨
  斯等察此光　　佛演安众生
  魔尘异学众　　降以精进力
  如莲华出日　　须弥照十方
  其身曜无底　　晖普于一切
  诣彼听尊法　　最胜转法轮
  今日无等伦　　班宣无比经
  十力愍众生　　故转尊法轮
  今日众集会　　广普难可遇
  笃信欲见佛　　今当诣忍土

尔时光明普告十方诸佛国土。说斯颂已。动诸佛国安于众生。耀诸法界净除一切尘劳之境。灭众幽冥蔽魔宫殿。与诸菩萨无数眷属。还回忍土。在佛头上忽然不现

于时东方无量功德宝福普辞世界。其佛号离垢净光海华无断光言王如来。佛土有菩萨。名首藏华诸法自在。彼光所请。与十江河沙等诸菩萨众会眷属围绕。忽没彼土。须臾之顷至此忍界。诣宝高座住世尊前。稽首足下绕佛万匝。雨夜光珠众宝璎珞供养散佛。以颂赞曰

  十力功勋发　　皆达于十方
  嗟叹无等伦　　德祚度彼岸
  我等所诣土　　欲听经法故
  一切闻名称　　释师子之号
  世尊为平等　　离垢光普曜
  如诸法无本　　亦无有嗔恨
  见危惧众生　　辄令得解脱
  为诸法之王　　如幻师善学

时诸菩萨无央数众。嗟叹佛已。各神足力悉化作座而坐其上

南方佛辩世界。无量德宝辩如来佛土。有菩萨名宝柱。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不见。须臾之顷至此忍界。诣宝高座住于佛前。以白珠交露覆盖佛上。稽首足下绕佛万匝。以颂赞曰

  世尊悉周匝　　愍雨于众生
  开[門@為]光明焰　　以空无吾我
  以八平正路　　消竭尘欲渊
  寂秘诸树王　　长育清白林
  则以智慧光　　化灭阴冥母
  悟久梦众生　　溺没终始流
  为显示正路　　消竭恩爱池
  令逮清净眼　　使度如前胜

时无数菩萨颂赞佛已。各神足化变作其座皆自处上。于时西方照耀世界。普明如来至真佛土。彼有菩萨名显音契王。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。雨瑛真珠供养世尊。稽首足下绕佛万匝。以赞颂曰

  其圣体之行　　犹如虚空界
  所愿悉清净　　劫数无有量
  其身净无垢　　永无有众漏
  能周于十方　　无思议佛土
  所讲如时雨　　雷震梵妙音
  悦可群萌类　　应如志所慕
  其心无所行　　亦无有不行
  所演畅诸音　　出应众生心

时无数菩萨颂赞佛已。各神足化变作其座皆自处上

于时北方众宝锦界。无量德宝光如来佛土。彼有菩萨号曰海觉。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。稽首足下绕佛万匝。以颂赞曰

  体色紫磨金　　觉施以寂然
  善照于十方　　快普现其身
  其体无俦匹　　众人若观察
  则灭诸欲尘　　忻豫长安隐
  最胜诸学子　　瞻戴世光明
  其志咸忻仰　　如须弥顶王
  皆诸神足力　　若干种变化
  不能见最胜　　顶上之威相

时无数菩萨颂赞佛已。各各神足变作其座皆自处其上

于时东南方无忧世界。除众戚冥如来佛土。有菩萨名普曜。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。稽首足下绕佛万匝。以宝交露供养上佛。以颂赞曰

  于一毛孔里　　怀无限佛土
  众生不以患　　国土不迫迮
  最胜救济行　　为诸无眼目
  诸佛为最妙　　识胜之光明
  以一之刹土　　畅无数佛国
  其诸所显现　　刹土不增减
  随如应方便　　大称随时入
  普入一切变　　神足所感动

时无数菩萨颂赞佛已。各神足变化作其座皆自处上

于时西南方善观世界。大哀观众生如来佛土。有菩萨名思于大哀。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。雨妙衣服供养覆佛。稽首足下绕百千匝。以颂赞曰

  禁戒甚清净　　人尊如宝珠
  长夜自将护　　如牦牛爱尾
  见于毁禁者　　加之以愍哀
  不自叹己身　　不呰毁他人
  住如须弥山　　意定不可动
  智慧如江海　　尊超于神灵
  已度一切有　　有为缚刑狱
  化亿载众生　　疗其尘劳病

时无数菩萨颂赞佛已。各神足化变作其座皆自处上

于时西北方离暗冥世界。光净王如来佛土。有菩萨名光曜网。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。以宝璎珞之具用覆佛上。稽首足下绕百千匝。以颂赞曰

  身觉了生死　　犹如幻师化
  示现所感动　　如幻无所有
  假如师幻化　　众生皆如兹
  其界不可动　　众生无自然
  如人卧寐梦　　睹见若干形
  寤则无所见　　诸色想无为
  圣说法如梦　　有为从念生
  见有所退转　　不退不回还

时无数菩萨颂赞佛已。各神足化变作其座皆自处上

于时东北方住净离垢世界。空城离垢心如来佛土。有菩萨名觉无底离垢。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。以常鼓音交露覆盖佛上。稽首足下绕百千匝。以颂赞曰。

  明识深妙法　　等解指自然
  省察诸空相　　一切诸所法
  普知一切世　　众生心所趣
  其心如虚空　　清净慧无底
  群黎之所行　　三世诸驰逸
  一心一时行　　悉知诸所有
  无有众生想　　其心谛离念
  已除众妄想　　善权普平等

时无数菩萨颂赞佛已。各神足化变作其座皆自处上

于时下方照明世界。深青莲首如来佛土。有菩萨名曰辩严。与十江河沙等诸菩萨俱眷属围绕。在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。以明珠交露共覆佛上。稽首足下绕百千匝。以颂赞曰

  如亿载佛土　　其中所有尘
  安住诸子孙　　来诣于最胜
  各欲自启问　　无数亿千劫
  则以一文字　　意化于一切
  圣慧不可喻　　权智无等伦
  总持定无量　　功德无崖底
  洪勋无能限　　斑宣无数劫
  毛孔所咨嗟　　不可尽究竟

时无数菩萨颂赞佛已。各神足化变作其座皆自处上

于时上方庄严世界。名称如来佛土。有菩萨名诸法变王。与十江河沙等诸菩萨俱。眷属围绕在于彼土忽然不现。须臾之顷至此忍界。诣宝高座住于佛前。一切庄严众宝紫金交露之帐覆盖佛上。稽首足下绕百千匝。以颂赞曰

  一切安住业　　今显无崖底
  于心得自在　　导师行亦然
  独诸佛所知　　非众生所行
  如空无边际　　群庶本如此
  其行无俦匹　　今日显无底
  成佛转法轮　　导师灭度如
  犹若有所种　　法不失果实
  十方诸最胜　　不可称限量

时无数菩萨颂赞佛已。于佛空中。各神足化变作其座皆自处上

    大哀经叹会品第二

彼时须臾之间。十方菩萨悉会面现。其菩萨众不可称限无能计会。亿百千数莫能称载。光明所劝集于忍界。诣宝高座住世尊前。时佛[宴-女+安]然从定意兴。其明晃照自然音出。其自然音。普告于三千大千世界。令闻其教。于时佛土信不信者。已为应器比丘比丘尼。童男童女人与非人。天龙鬼神揵沓和阿须伦迦留罗真陀罗摩睺勒。闻佛音诏身心坦然。加敬悚息。承佛威神。自然而有妙宝宫殿。悉共趣之。须臾之间至宝高座。稽首佛足绕圣三匝。各就床榻。又此光音告敕梵天。梵忍天王。梵身天王。梵满天王。梵度着天王。大梵天王。光曜天。少光天。无量光天。光音天。净严天。少净天。无量净天。难还天。净身天。用果天。无揵天。于是天善施天。善所施天。一善天如眴之顷集宝高座。稽首足下绕佛七匝。不处地上自处其座。于时世尊睹见大众佥然来会。有神光曜名曰显现。诸菩萨力眉间演出于此光明。绕诸菩萨七匝竟已。于诸菩萨顶上而没。时有菩萨名首藏华诸法自在。遇此光曜。应时逮得一切庄严定意适三昧已。其宝高座自然为佛。有师子座。高八十亿垓百千之寻。妙宝为足众珍栏楯。妙衣敷上。一切诸华以散其上。悦意诸宝以为严饰。一切菩萨睹此缘变断绝所慕。皆令众会自睹其明。可悦一切众生。现其心意所欲求愿。寻时皆了无可犹豫。时首藏华诸法自在菩萨。复以劫叹施诸恶趣三昧正受。别化如来大师子座。庠序安隐。从三昧起恭恪钦敬。叉其十指以颂赞佛

  其日光明者　　但照世俗耳
  天帝威神德　　营从乐忉利
  其梵天尊王　　慕恋梵天上
  佛之圣威化　　变动界若此
  观察法自由　　自然如虚空
  若幻野马比　　亦如水中月
  诸所作所造　　悉为无有主
  晓了如诳诈　　见众生清净
  其心慕于色　　斯色何所在
  其心为自然　　所由皆不实
  一切虽清净　　此亦如幻化
  其于自然者　　虚伪何有处
  能分别本净　　执御心鲜洁
  其境从容来　　彼无有尘欲
  思想念诸念　　其心已脱此
  则见若干种　　幻化之所为
  虚空无所有　　从地而出生
  显示国土地　　若干明珠宝
  向者为法王　　建立师子座
  当处于此座　　开化亿众生
  跱立缯幡盖　　大幢诸严饰
  此无所从来　　亦无所越至
  若能晓诸法　　无所从来者
  便能为众生　　现诸胜变化
  大圣梵音声　　所演善哉快
  为世巨锭燎　　威神德无极
  愍伤吾之故　　当升处高座
  讲说于经典　　断生老病死
  其清净众生　　十方来会此
  各各次第坐　　欲听愍法谊
  本所因发举　　愿解于此慧
  圣在师子座　　安详颁宣法

于是世尊见首藏华诸法自在菩萨志性清净。即便处于大清净法师子之座。寻时讲说诸菩萨行。当所立趣。又有经典名无盖门。净菩萨道诸佛法力。成就宝身圣明屋宅。于一切法而得自在。入总持中分别解说。剖判入门大神通慧。入于微妙不退转轮。无能回还。导御一切诸定意乘。入于一乘无毁法界。说众生性根原所趣。为之唱导解发诸法。毁坏诸魔入应顺法。去诸尘劳六十二见。开化当入柔顺之法。令诸爱欲邪见乱律入无碍慧。劝众德本普无不接。颁宣权慧。皆入一切佛平等圣。悉无阴蔽无处所门。所宣诸法分别如谊。入于诸法。无念不念无应不应觉了深妙十二缘起。圣慧功德乃达魔天。佛身口意皆令庄严。所念志趣智慧明达而不可盖。入乎圣谛开化声闻。晓心所归缘觉之律。普得一切诸慧境界诸菩萨律。一切所入于法自在。颁宣如来功勋名称

时佛讲说如是比像无极法典。说是语时。教化告敕诸菩萨德。所愿至诚悉已具足。示现如来变化感动。解诸众会狐疑结网。降摄一切诸魔之场。光显如来训诲之谊。备佛本业欲使具足。是故世尊。处师子座宣无盖门。于时宝幢菩萨承佛圣旨用佛庄严三昧正受。令普众会致佛庄严。建立威神

时名闻力菩萨承佛圣旨用红莲华三昧正受建立众会。一切诸华令成法华。以此众华散于世尊一切菩萨。三昧时海觉菩萨承佛圣旨以众香定三昧正受。使诸毛孔建立演出妙味栴檀。四明网菩萨承佛圣旨以光明定三昧正受。令一切光建立众会。靡不蒙安。五大哀念菩萨承佛圣旨以无眴定三昧正受建立众会。瞻戴如来目不敢眴。六离垢察无底菩萨承佛圣旨以法悦定三昧正受建立众会。慕乐正法好法志法乐以法乐。七辩严菩萨承佛圣旨以愿迹定三昧正受建立众会。皆令蠲除五盖之患。八变诸法王菩萨承佛圣旨以无忽忘三昧正受建立众会。志在佛道慕如来行。九心勇菩萨承佛圣旨建立众会。使伏诸魔及外怨害。靡不从化。十降诸魔菩萨承佛圣旨以毁魔场三昧正受。适三昧已。应时三千大千世界所有众魔其数百亿及诸魔兵。速疾速疾。各从宫殿忽然不现。诣宝高座住于佛前。稽首足下绕于世尊。无央数匝不可称计。奇异妙物供养大圣。恭敬悚息一心叉手。劝助天师颁宣经典。唯愿以时开化说教。吾身今日降魔菩萨威神所建。故来劝助。唯天中天。吾当放舍所作魔事不乱众生。今以法故来至于斯。由是大圣当察吾身志操所趣。于时世尊察魔心念赞曰。善哉善哉。诸仁者等。汝党乃能放舍魔事。劝助如来令说经法。缘是之故。汝等之身因此获报皆当越度一切魔业。所以者何。犹百千岁屋室闇冥一灯入中寻即消昧。如是诸人于百千劫兴发尘劳闇冥之欲。一善本心力之所变。消灭众患令无有余。譬如诸人一日之宫一月之殿。一大宝珠。一一各出光明之曜消除众冥。如是诸人一心善本观其修行。而念应顺。皆除一切无明众冥六十二见九十六迳众患之难。以是之故。今日诸仁来觐如来加复劝助。因此德本。稍渐蠲除一切无慧愚痴之冥。当获无极导法之门

大哀经卷第一大哀经卷第二

        西晋月氏三藏竺法护译

    无盖法门品第三

于是法[敖/力]王菩萨在于彼会。而白佛言。唯然世尊。如来境界不可思议。示现建立大圣威光。令诸菩萨永无狐疑。各各修行。唯当宣说无盖之门大会法品。所以者何。其大会者今悉集此。皆为菩萨。一被大德铠不可思议。二以大神通圣慧娱乐。三皆有功勋通于十方。四所修清白心离垢秽。五以明解脱多所照耀。六皆为诸佛所见咨嗟宣扬功勋。七于一切法得尊自在。八诸度无极越终始岸。九一切皆从权方便生。十而悉消化魔业欲尘。十一降伏一切诸外邪道。十二皆能分别方便讲说章句谊理。十三慧无挂碍智度无极超于彼岸。十四其意自由勇步无难逮圣总持。十五建立无盖辩才无断。十六晓了众生根原所趣。具足缺漏备不备者。十七察诸众生从应所解而为说法。十八所宣经道除众罪殃而无遗漏。十九其音随时柔软和雅。如哀鸾鸣。犹龙海吼。亦如梵声。二十慈愍众生而示灭度。亦以慈愍令众得济。二十一心常怀执无极之慈。二十二志性抱念无盖之哀。二十三所住坚固而不可动。言行相应。二十四修立法幢显示十方。二十五其志坚强犹如金刚。不可破坏如铁围山。二十六尽建所愿不失本誓。二十七畅入深妙分别玄奥十二缘起。二十八蠲除两际断灭常见一切诸见六十二疑所习连着。二十九亦如大乘群庶法王。诱进牵致使入于道。三十众庶大导将致无难。三十一从无央数劫好乐法宝合集智慧。三十二为大医王疗众人病。灭除众生无色尘劳蓄滞之病(第三十三法经本阙)。三十四此诸菩萨大师子王所抚育子。三十五一切诸行若听异音。闻说如来秘密之谊。亦不恐惧。三十六而以相好庄严其身。三十七皆以大哀具足祠祀。三十八其心勇猛不怀怯弱。三十九降伏四魔爱欲境界。四十善施桥梁开寤眠寐。四十一如是根力觉意禅思解脱定意正受。以善修成所当为业。四十二常以殷勤欲度众生。四十三逮得总持揽制一切。四十四若利无利。叹誉诽谤。有誉失名。若苦若乐。于世八事而无所著。四十五其心得入欢喜悦豫乐爱经典。四十六颁宣流布道法之宝。四十七充满智慧备悉道空。四十八其行鲜明犹如莲华。四十九蠲除一切诸有为法。五十其光清净覆蔽日月释梵晖曜。五十一悉已逮得海中三昧。五十二道御一切诸法之宝。五十三而于三宝由得自在无能断截。五十四明识解说一切诸界。五十五执持诸佛经典之要五十六积累合集无量功德咨嗟之称。五十七造立无限功祚智业。五十八而得亲近具足佛慧。五十九达了当来无央数劫本末之际。六十(第六十法本内少)。法[敖/力]王菩萨白佛言。如是世尊。此诸菩萨大士之会功勋若兹。我意大圣。心自念言。当令世尊为诸菩萨宣无盖门大会法品。诸菩萨众所可由生。至未曾有天中之天。诸佛兴出多所饶益。则能悦可菩萨大士。使得成具。当来菩萨德本明哲。其初发意菩萨清净行欲成者令入一乘使不退转。诸菩萨众具足佛法。至阿惟颜一生补处。令其果报无所遗失。若有众生所识分明志存决定。怀来因缘化使入道。其不决定当令仰入于无极哀其有众生永在邪见。为说处所使决其网。乐三乘者因故佛兴而自严饰。诸天龙神犍沓和人与非人世人阿须轮。皆得蒙济。所以者何。佛兴出世实为善哉。如是比像。至未曾有难及希有。经典之要。现出于世得共睹知。唯愿大圣。斯等正士发意之顷。建立化变此法高座。一切声闻及诸缘觉。于百千劫所不能逮。吾以是故心自念言。难及难及至未曾有。此人之等。乃能施设如是色像神足变化。谁以见此。当复兴发声闻之行缘觉之心。所以者何。其有初发菩萨心者。过诸声闻缘觉之众。今欲引喻。譬如世尊。愚痴之子从生騃冥。舍夜光大宝珠。取水精珠。所见颠倒自以为是。众人所行亦复如是。舍乎大乘。转求声闻缘觉之乘。若复有人至性真实。发无上正真道意。若已发意甫发意者。亦当不久具足成就如是法要。法[敖/力]王菩萨说是语时。彼众会中三亿百千垓天人。皆发无上正真道意

    大哀经庄严法本品第四

尔时世尊睹诸菩萨皆来大会。此诸菩萨皆以法故。而来集此。悉以执持如来妙藏。宣畅菩萨诸所行住无盖法门所由品奥。修御法典。复有光明名无畏辩。应时眉间大人之相放斯光曜。绕诸菩萨七匝已竟。因复绕于总[敖/力]王菩萨身百千匝。寻入总[敖/力]王菩萨之顶。适蒙此光承佛威神。绕诸菩萨百千匝。其光悉照师子之座。其身威仪转复光曜光明巍巍。益甚加倍踰诸菩萨。总[敖/力]王菩萨。时见如来无极威变。即从座起。偏出右肩右膝着地叉手。于世尊上虚空之中。化成如来庄严宝盖。佛所建立。琉璃为幢上至炎天。瑰异琦珍帝青琉璃宝藏殊妙而以严饰。垂贯真珠缯彩旗幡而为庄校。紫金交露周匝缭绕。覆诸菩萨大会之众。其盖广长大如三千大千世界。如是比像建立宝盖奉献如来。雨于天华。威变伎乐而自然鸣。寻时以颂而赞世尊

  光明普遍靡不见　　目所周悉为显谊
  诸法自在权自由　　不可思议趣诸德
  大圣正士演光明　　其口清净宣辩才
  道光绕我百千匝　　在吾顶上没不现
  如本意志所怀念　　辩才照明持亦然
  所知百千胜于前　　用蒙人雄道师恩
  其身巍巍心清净　　踊跃以时获如愿
  乃知正觉慧无量　　其大辩才入我身
  佛实难及威无极　　其羸劣者不所乐
  承佛圣旨今悉见　　当复启问愍众生
  诸菩萨众行所入　　等趣世间而御众
  所生光明所变处　　当复咨启阿惟颜
  魔众无量悉来会　　而独游步上道乘
  及余志求微妙法　　为是等故问最胜
  当善执持此魔场　　而常谛受斯佛慧
  今适是时世尊说　　为众生故开法藏
  鄙身明智无不及　　人中之尊慧无量
  能了最胜无限智　　今当启问无极权
  世尊圣慧由自在　　本于长夜所修学
  善遵[敖/力]尊为法王　　惟为颁宣道师行

总[敖/力]王菩萨以颂赞佛已。白世尊曰。如来境界不可思议。诸菩萨行莫能称限。吾及众会听察如来至真等正觉所说经法。未曾厌倦睹于众生。最胜世尊行乎大哀。故问此谊何谓世尊。菩萨庄严而自校饰。以菩萨行而为应谊。何谓菩萨不可思议逮法光明离于闇冥蔽碍之患。以大法门而为清净。何谓菩萨在众生尊。第一大哀修行慈愍。成就所行不舍众生。何谓菩萨逮佛菩萨所行诸业。所尊正法不怀恼法善哉世尊。愿分别说诸佛菩萨之所行住等趣法门。犹如菩萨降伏魔众。蠲除疑网入如来界游菩萨境。晓了一切众生志操。心行清净摄取佛土执持魔场。从如来教而于诸法速得自在无所蔽碍

佛告总[敖/力]王菩萨。善哉善哉。正士。乃能问于如来。欲善决了诸佛菩萨。仁能逮得无量如来所行了了。族姓子。谛听善思念之。当为汝说。如诸菩萨行及余菩萨功勋具足。疾逮一切诸法自在。总[敖/力]王菩萨及诸大众受教而听。佛言。菩萨有四事庄严。何谓四。一曰戒庄严未曾毁禁。二曰定意庄严至未曾乱。三曰智慧庄严心无蔽碍。四曰总持庄严所闻不忘。是为菩萨四事庄严。于彼何谓以戒庄严。族姓子。知则用一事以戒庄严。何谓一。常愍众生心不怀害。矜哀群黎一切有命。亦敬爱之莫不悦可。复有二事以戒庄严。何谓为二。一曰杜塞恶趣。二曰开善趣门。复有三事以戒庄严。何谓为三。一曰身行清净而无沾污。二曰口言清净辞不粗犷。三曰其心清净未尝坏乱。复有四事以戒庄严。何谓为四。一曰如所志愿必果无异。二曰如所约誓则得成就。三曰如所慕乐必成无违。四曰如所图画则得超至。是为四。复有五事以戒庄严。何谓为五。一曰与禁戒士俱共精修。二曰习学智慧未曾懈废。三曰勤志解脱不怀慢恣。四曰修度见品未尝休懈。五曰益加精进尊于无上无极灭度。是为五。复有六事以戒庄严。何谓为六。一曰无所毁犯亦不怀恨。二曰无所缺漏亦不捐弃。三曰不有沾污无所损落。四曰不为瑕疵修一清净行。五曰而博听受不从欲秽。六曰若有所听不载仰人。是为六。复有七事以戒庄严。何谓七。一曰戒品清净。二曰布施清净。三曰忍辱清净。四曰精进清净。五曰禅思清净。六曰智慧清净。七曰善权清净而无放逸。是为七。复有八事以戒庄严。何谓八。一曰所处具足。二曰其地究竟。三曰所御备悉。四曰性戒周密。五曰不被烧害得至成就。六曰佛兴出世得无所著。七曰无盖普达。八曰得从善师所问具足。是为八。复有九事以戒庄严。何谓九。一曰而于圣慧无所恐惧。二曰有所睹见而不怯弱。三曰晓了空慧。四曰分别善权。五曰习于清凉而无恼热。六曰将护禁戒如蜂采华。七曰修治其心令无情欲。八曰其心调和不怀粗犷。九曰逮得调定中和之地。是为九。复有十事以戒庄严。何谓十。一曰庄严其身具足诸相。二曰其口庄严言行相副。三曰其心庄严而无瑕疵。四曰国土庄严具足所愿。五曰开化众生庄严志性清净。六曰所生庄严一切众恶而无所犯。七曰菩萨行庄严学如来行。八曰圣慧庄严不怀自大。九曰道场庄严劝助众德。十曰力无所畏不共法庄严。立戒为本未曾舍禁。是为总[敖/力]王菩萨十事庄严

佛告族姓子。何谓菩萨定意庄严。定有一事。何谓一。常怀慈心愍哀众生。复有二事定意庄严。何谓二。一曰修行威仪礼节。二曰性行质直而无谄饰。复有三事定意庄严。何谓三。一曰无有谀谄。二曰志性清和。三曰无有虚伪。复有四事定意庄严。何谓四。一曰为人仁调而不佷戾。二曰不怀毒害见他瑕疵。三曰不犯禁忌致诸患难。四曰不从愚戆以趣闇蔽。是为四。复有五事定意庄严。谓去五盖。何谓五。一曰贪欲。二曰嗔恚。三曰睡眠。四曰调戏。五曰狐疑。复有六事定意庄严。谓六思念。何谓六。一曰常念于佛。二曰常念经法。三曰常念圣众。四曰常念禁戒。五曰常念布施。六曰常念诸天。复有七事定意庄严。谓不舍道心修七觉意。何谓七。一曰意念觉意。二曰法觉意。三曰欢悦觉意。四曰精进觉意。五曰信觉意。六曰定觉意。七曰护觉意。复有八事定意庄严。谓八正由路。何谓八。一曰正见。二曰正命。三曰正语。四曰正业。五曰正念。六曰正便。七曰正意。八曰正定。复有九事定意庄严。谓菩萨不舍道心常立大哀亦无所住。其心不舍一切众生。何谓九一曰蠲除爱欲寂灭众恶不善之业。憺怕悦安。此念俱行修第一禅。二曰其人寂除思念所行。其内庠序而为专一。无思无行憺怕悦安修第二禅。三曰永观欢悦离欲之行而常安详。其身适安犹如圣贤所说所观。其意行安修第三禅。四曰断除苦乐究尽往古忧戚欢悦。观察于斯无苦无乐修第四禅。五曰皆度一切诸色之想。究畅尽竟性之如地。不复思念若干诸想。游于无量虚空之慧而为修行。六曰过于一切虚空诸想。游无量识诸识之慧而为修行。七曰皆越一切诸识智慧。不计有身不用识慧而为修行。八曰皆超一切不用识慧。于有想无想之处而为修行。九曰皆出一切有想无想之处。悉入一切思想所愚。定意思惟以为正受。以权方便不于本际而取证也。住于本愿开化众生。复有十事定意庄严。何谓十。一曰心无所生不怀嗔恚。二曰具足寂然之行。三曰不舍所愿。四曰寂在闲居。五曰不失德本。六曰其心憺怕。七曰身心休息图度计校。八曰度安诸法。九曰心得自在。十曰得贤圣性。是为十事定意庄严

佛告族姓子。何谓菩萨智慧庄严。计有一事智慧庄严。何谓一。于一切法而不卒暴。复有二事智慧庄严。一曰舍于狐疑。二曰离诸爱处。复有三事智慧庄严。一曰断除愚戆。二曰烧尽无明坏诸阴界。三曰永灭闇冥幽昧之事。复有四事智慧庄严。一曰晓断诸苦。二曰了绝诸习。三曰明于造证。四曰不住由路。复有五事智慧庄严。一曰戒禁清净而无所获。二曰定意清净精度智慧。三曰解品清净游于众生。四曰度知见品而为清净。皆于三世无所挂碍。五曰法品清净以用成行。复有六事智慧庄严。谓净三场施度无极。净于己场身如野马。人场清净犹等如梦。道场清净无望报故。戒度无极净乎三场。身场清净等如影故。言场清净如浮响故。心场清净等如幻故。忍度无极亦净三场。弃捐粗辞所言清净。除去冤结常喜咨嗟。若有段段支解其身。观察法身清净无秽。进度无极亦净三场。清净无厌好游生死睹之如梦。坚强清净志如金刚故。无应不应。清净行者度想着故。寂度无极清乎三场。愚冥清净退入慧故。弃捐清净入于诸法。无所著故。勤心清净发神通故。智度无极亦净三场。四思清净化众生故。总持清净摄正法故。所愿清净严佛土故。复有七事智慧庄严将护其意。一曰于四意止不起不灭。二曰于四意断身意憺怕。三曰其神足者晓了诸根。四曰其五根者。降弃一切诸魔尘劳。五曰其五力者明晓诸法自然之故。六曰其觉意者无所不达致未曾有。七曰其由路者无往无来无往来故。复有八事智慧庄严。谓不失圣慧行权方便。一曰寂然观慧而为憺怕。二曰观察见于诸法为憺然故。三曰慧品晓法品故。四曰界品其性本行等境之故。五曰晓于诸入本无欲故。六曰明十二缘晓无我故。七曰达于诚信永无嗔故。八曰一切诸法无所破坏如实观故。复有九事智慧庄严。一曰知过去事。本清净故。二曰知于当来未然清净故。三曰知于现在究竟净故。四曰知定了了。报应之谊无所失故。五曰知于未定。导因缘故。六曰晓处于邪为开化故。七曰知佛平等达法身故。八曰等于诸法法无欲故。九曰诸圣平等修无为故。复有十事智慧庄严。一曰所有如梦为惑相故。二曰了如所梦思想相故。三曰了如野马分别相故。四曰了如实见因缘相故。五曰了如影见形用事合故。六曰了如呼响用杂会故。七曰了于法界无坏相故。八曰了于无本不住相故。九曰了于本际无动相故。十曰晓于无为。其无为者自然相故。是族姓子。菩萨所行十事智慧庄严。佛告族姓子。何谓菩萨总持庄严。以有一事而为庄严。其意常达未曾忽忘。复有二事总持庄严。一曰怀来道谊。二曰总摄无违。复有三事总持庄严。一曰晓了诸谊二曰分别严饰美辞。三曰明诫所归随其方便。复有四事总持庄严。一曰言无所著。二曰无刚[革*卯]辞。三曰所言柔和。四曰无刺讥辞。复有五事总持庄严。一曰诸所闻声唯归于谊。二曰晓诸身识唯归于慧。三曰一切经典唯归经理。四曰了诸人响唯归于法。五曰在于方俗归度世行。复有六事总持庄严。一曰言行相应。二曰顺从至诚所言清净。三曰不怀自大行无所著。四曰无有谀谄言无所失。五曰修于大哀如应说法。六曰方便随品而为宣说等讲俗智。复有七事。一曰其辩才智适发寻对。二曰辩才应机。三曰小辩才捷疾。四曰辩才无碍。五曰辩才无滞。六曰辩才无缺。七曰辩才应谊。复有八事总持庄严。一曰晓了诸天所言。二曰解识诸龙音声。三曰明察鬼神言响。四曰分别揵沓和语。五曰解阿须伦所咏。六曰达加留罗辞。七曰畅真陀罗所言。八曰识摩睺勒及诸众生口之所宣。复有九事总持庄严。一曰不猗无为。二曰诸所修行而不怯弱。三曰勇猛说法。四曰其智慧圣不为虚伪。五曰晓了所说广普具足。六曰其贡高者顺为说法。七曰得平正者为说质直而开化之。八曰见有处者为现劫烧。九曰得境界者随其学乘而为斑宣。复有十事总持庄严。一曰从其志操不为众生宣粗犷辞。二曰闻佛说法修习慧明。不复志慕世俗之智。三曰言不可尽假一文辞耳。四曰其无所住为说无处。五曰说于诸佛咨嗟无量。六曰弃除恶趣尘劳粗辞。七曰说于灭度不可称限。八曰忍于众生无碍根本。九曰从佛之教。十曰忍于分别超异辩才。是族姓子。菩萨十事总持庄严。于是世尊欲重宣此谊令人重解。即说颂曰

  诸大圣人　　有四庄严　　以此应谊
  尊之上乘　　戒禁定意　　及最智慧
  总持如是　　明解分别　　为诸众生
  所见钦敬　　其身口意　　常以清净
  悉断狐疑　　诸所句迹　　其奉戒者
  以此庄严　　生天世间　　功勋流布
  其所志愿　　辄得成就　　常修正行
  以行为上　　其奉净戒　　以此庄严
  其人得近　　速逮定意　　智慧解脱
  圣慧若兹　　亲近无为　　归此行者
  戒禁清净　　斯为庄严　　戒无所犯
  禁不缺漏　　不弄戒法　　性无卒暴
  名响畅溢　　靡不宣持　　戒清净者
  斯为庄严　　其戒清净　　布施鲜洁
  忍辱清净　　精进亦然　　一心清净
  智慧无异　　善权清净　　亦无放逸
  所住坚固　　强不可动　　逮明谛地
  行不怀恨　　性不舒缓　　志常谨敕
  戒清净者　　斯为庄严　　其戒茂盛
  未常退转　　其心不生　　众恼烦热
  秉意兴行　　未曾悔变　　戒清净者
  斯为庄严　　不恐不懅　　未曾慷慨
  其意寂静　　无能毁称　　其犯禁者
  常被系闭　　戒清净者　　斯为庄严
  其心修禁　　功勋无极　　志性仁和
  斯意安调　　则为己身　　庄严相好
  戒清净者　　斯为庄严　　如口所言
  身行若兹　　庄严其口　　所护庄严
  不以欲尘　　严饰其心　　戒清净者
  斯为庄严　　斯人则为　　庄严佛土
  开化众生　　使入大道　　此明哲者
  庄挍生处　　以是之故　　不犯众恶
  所谓庄严　　常奉佛道　　修治最胜
  于佛道场　　庄严诸力　　四无所畏
  以为庄严　　圣慧无慢　　普加慈愍
  一切众生　　其明智者　　所见正真
  无有谀谄　　不怀细碎　　不随贪欲
  嗔恚愚痴　　志性猛毅　　无有五盖
  修六思念　　而无放逸　　为七觉意
  奉道若兹　　稍渐皆惟　　一切定意
  亲近所行　　修乎寂然　　善顺随时
  不失众德　　住乐静思　　所察入乱
  于道自在　　为贤圣种　　未曾犹豫
  不达经典　　无有狐疑　　亦无沉吟
  除去无明　　无有愚冥　　常处至诚
  明识圣慧　　戒清净者　　无所逮得
  智慧最上　　定意清净　　顺从二事
  解脱清净　　不怀慢者　　圣慧清净
  睹见三世　　度众为惠　　晓了离欲
  则法清净　　斯清净者　　不怀自大
  其智慧者　　此为庄严　　智慧行施
  以为庄严　　若能清净　　于三品场
  己身众生　　及修道教　　如梦幻化
  而无所著　　以戒智慧　　而为庄严
  又复净治　　于三品行　　身行口言
  心念亦然　　影像幻化　　亦如浮响
  是为智慧　　而成庄严　　则能清净
  于三品事　　无能屈者　　亦不动摇
  普观一切　　常察法身　　智慧精进
  而自庄严　　亦复清净　　于三品事
  未曾懈惓　　志性坚强　　未常怀应
  亦无不应　　所以智慧　　一心庄严
  亦以三事　　修行清净　　其所观察
  无有闇昧　　斯明哲者　　兴立五通
  善权智慧　　以庄严者　　亦复清净
  于三品事　　善受总持　　了平等谊
  示众生法　　亦净佛土　　于四意止
  志不退转　　于四意断　　不行二事
  身心憺怕　　斯为神足　　晓了一切
  众生根原　　于魔尘欲　　永无所有
  诸法自在　　随顺决了　　无所从来
  及致来道　　是为威仪　　智慧庄严
  永致湛然　　为寂禅定　　所观察者
  行无崖底　　晓诸阴衰　　修乎法品
  明识诸界　　犹如虚空　　分别情入
  空无所有　　法无吾我　　从缘而起
  晓了真谛　　慧无怀恨　　无恐惧慧
  因缘随念　　于三世慧　　无所挂碍
  明了三聚　　之所归趣　　晓识三宝
  则为一相　　其智慧者　　以此庄严
  明晓幻化　　为悉惑相　　恨从惑相
  譬如若梦　　等如芭蕉　　为悉惑相
  诸法无会　　犹如影相　　从缘合生
  如水中月　　亦如呼响　　因对而出
  其法界者　　慧常无坏　　明了无本
  智无所住　　法动无动　　本际常然
  有为无为　　此无有二　　深要智慧
  清净为道　　是为庄严　　诸佛之法
  其人未常　　意怀惑乱　　怀来遭遇
  总持经典　　而常解说　　谊理微妙
  而恒游步　　灭度之惠　　言不卒暴
  亦无粗犷　　口所宣传　　无有不可
  诸所说音　　众当察谊　　所仰圣慧
  常以了了　　识经谊理　　靡不闻达
  以归于法　　不计有人　　一切诸法
  度世为要　　以此总持　　而自庄严
  口所颁宣　　常说至诚　　口之所言
  恒趣平等　　有所为者　　常讲经典
  随时不虚　　无有为事　　欺人兴此
  说其辩才　　速及正慧　　常无挂碍
  而无所住　　随顺无失　　善自庄严
  如好华鬘　　闻知天龙　　所说言辞
  鬼神揵沓　　及阿修伦　　迦留真陀
  及摩睺勒　　亦复晓了　　众生所说
  此等不来　　在于众会　　亦复不住
  而就见之　　此勇猛者　　为颁宣法
  则以智慧　　而达知之　　其自大者
  见怀乱意　　睹斯所说　　顺从应时
  自大贡高　　睹其所说　　其怀慢者
  无有嗔恚　　为分别说　　三乘之教
  断诸狐疑　　令无结网　　则得亲见
  佛法正真　　不依仰人　　智慧如是
  于一切字　　常晓灭尽　　所分别晓
  谊无质碍　　咨嗟诸佛　　无量功德
  其逮总持　　以此庄严　　毁咨尘欲
  所知无限　　善权方便　　随时开化
  晓了一切　　众生根本　　诸佛所知
  逮分别辩　　其以总持　　而庄严者
  斯人用此　　称名普闻　　吾住一劫
  歌叹其行　　不能究竟　　斯功德勋

    大哀经八光品第五

世尊复告总[敖/力]王菩萨。菩萨有八光明。以此光明。离不可思议诸闇昧。修清净行。何谓为八。一曰念光明。二曰志光明。三曰游光明。四曰法光明。五曰慧光明。六曰至诚光明。七曰神通光明。八曰奉行光明。是为菩萨八大光明。于彼何谓念光明。有八事为念光明。何谓八。往古所造众德之本未曾忘失。所未立德日日积功。如所闻法未曾忘失。逮知谊理分别所趣。不从六界成就念门。断诸非法具足善德睹有强心。诸佛世尊所为建立。护持法城志怀于源。逮一切法德诸光明。是故菩萨八事光明。曰所志光明复有八事。何谓八。志解谊理不怀严饰。志在圣慧不怀识着。志在于法不怀尘欲。志在精进不怀诤讼。志在佛道不怀声闻缘觉。志在微妙不怀小乘。志在于佛不怀魔事。志在大慈大哀。未曾怀害加于众生。是为八事所志光明。游光明复有八事。何谓为八。所可游行常颁宣法。游知众生志操所念。所游之处分别辩慧。所游之处常解深妙十二缘起。所游之处有所宣畅亘无不通。所游之处晓了清净前后增损。所游之处普备一切诸佛之法。是为八。法光明复有八事。何谓八。其明照世而为解说。入于善本。又为众生演度世法。为畅圣慧。诏使令除诸罪之法。无漏法光善宣道教。不住无明及于众漏。见于生死罪福所趣。睹已尘欲光明。不堕灭尽而取证也。其光明法善察所趣客尘之源。无为法光心本清净。自然鲜洁诸法永寂。是为八事。慧光明复有八事。何谓为八。一曰八等光诸道。二曰诸道迹光慧。三曰往来光照。四曰放不还明。五曰演无著曜。六曰缘觉威曜。七曰菩萨慧明。八曰如来至真正觉光明。是为八。至诚光明复有八事。何谓为八。其堕灭尽以至诚行照曜于彼。其行诚谛第一道迹慧光照彼。其行诚谛致第二果则以照彼。其行诚谛得第三果亦复照彼。其行诚谛得第四果亦复照彼。其行诚谛得缘觉果亦复照彼。其行诚谛得菩萨忍亦复照彼。其行诚谛成佛正觉亦复照彼。是为八。神通光明复有八事。何谓为八。所谓光明靡所不曜。其天眼者睹诸色像。永寂诸响则以天耳普闻诸音。所念光明识念无央数劫往古行事。本净光明察睹一切众生心行如虚空。无碍光明又其神足游步无限诸佛国土。慧光明者成无漏圣。积德光明开化众生使修善业。慧业光明决断一切众生疑结。是为八事。奉行光明复有八事。所谓奉行。一曰遵修圣慧。二曰志智慧明。三曰行正见明。四曰奉观察光。五曰照众生性曜。六曰修其脱心。七曰无嗔恚心。八曰遵修其明令永究竟。是为八。佛时颂曰

  以往古净业　　心初不忽忘
  意习无所习　　善劝无懈废
  所闻未曾忘　　速得解法谊
  寂然界憺怕　　志强弃非法
  晓了于念门　　选择所造业
  怀勇者睹之　　建立胜自在
  守护于法城　　等一众生法
  智者离诸冥　　利益于群萌
  逮得光明曜　　无疑决犹豫
  志强慧自在　　速成至佛道
  志在于谊理　　不逸存严饰
  慧士不着想　　不猗于文字
  其志于法者　　善调欲离痴
  有志净善权　　不诤安住道
  意常存于道　　不念声缘觉
  常怀微妙业　　不念于小乘
  思惟于佛道　　不从诸魔教
  常怀于大哀　　不娆于众生
  假使所颁宣　　所游无狐疑
  随时化众生　　所在群萌行
  所游分别辩　　彼慧无挂碍
  明于因缘法　　无有缘起事
  晓了方便慧　　安住所步顶
  一切能普入　　诸佛所兴法
  世间法光明　　悉知人民业
  及度世圣慧　　雄为智慧光
  所生无罪舋　　大慧修本净
  善遵于道路　　常宣无罪业
  于漏无有漏　　法光明照曜
  断一切诸漏　　利润于众生
  于有数无数　　法常游于慧
  是无垢离冥　　游入灭尽行
  尘劳诸诤讼　　其慧无蔽碍
  明识众尘欲　　其心本清净
  其智得灭度　　晓不起寂然
  如是类无限　　大乘光明业
  彼于八等慧　　游达于道迹
  亦晓了往来　　分别于不逮
  无著及缘觉　　菩萨世吼护
  慧皆能达此　　所游解圣贤
  至诚明无量　　勇猛善修行
  其逮得果证　　无恚议第一
  其行至诚者　　入寂第一果
  第二三第四　　逮缘觉之果
  设有能加精　　逮法忍平等
  如最胜得道　　至诚皆照彼
  又其天眼者　　普见十方佛
  成就于天耳　　闻十方音声
  识念那术劫　　前世慧光明
  随顺知他心　　清净慧悉照
  游亿垓佛土　　神足照十方
  轻举如虚空　　逮无为之慧
  功德光无底　　神通益众生
  慧界无挂碍　　决群黎狐疑
  奉行所应谊　　志强法慧光
  至成明无限　　则为神通光
  修行圣智慧　　意广辩无底
  等观于正见　　究竟无结恨
  其净于此八　　斯光威无极
  虽未成佛道　　常行作佛事

大哀经卷第二大哀经卷第三

        西晋月氏三藏竺法护译

    大哀品第六

佛复告总[敖/力]王菩萨。菩萨有十六事。常以大哀加于众生。何谓十六。于是菩萨除见贪身。众生处在若干邪见。则为断去迷惑疑业。为说经法。是为菩萨兴发大哀愍于众生。众生处在虚伪颠倒。非常想常。苦想为乐。无身想身。空有净想。当为蠲除此颠倒行。菩萨于彼兴发大哀为说经典。众生处在计有吾我。一切无形而想有形。当为除去吾我之事。菩萨于彼兴发大哀颁宣经道。于此众生处在五盖而自覆蔽。堕在欲疮多所危害。睡寐无明虚伪狐疑。因缘所覆不了深法。吾当为彼除诸阴盖。菩萨于彼兴发大哀为说经法。众生处在六情挂碍。眼见色而想着为文饰。耳声鼻香舌味身触意法。而怀想着猗受文饰。当为此等灭除六情。菩萨于彼兴发大哀为说经道。众生处在贡高自大。憍慢求敬。是我自由咄吾志邪。怀害虚伪。余人卑贱我为尊贵。自说我所行正于尊复尊经道。又胜加复[敖/力]。乃强绮于容色。自计有识而自放恣。永无所获自谓成就。不贤嫉贤不圣嫉圣。处于邪见想住正道。吾当为此说除憍慢贡高自大。菩萨于彼兴发大哀为说经道。众生处在迷惑邪迳离于圣路。当为除邪显示圣道。菩萨于彼兴发大哀为说经道。众生处在虚伪恩爱之着。贪于妻息男女家居产业。夙夜汲汲无有懈废。当为除此令脱恩爱。菩萨于彼兴发大哀为说经道。众生处在各共诤讼恚恨不和。怀结嗔怒多所讼理。当为除此斗诤嗔恚。菩萨于彼兴发大哀为说经道。众生处在恶友所摄。离于善友兴造恶业。当为除此诸恶知识使从善友。菩萨于彼兴发大哀为说经道。诸天处于悭惜贪餮。不知懈倦离于圣慧。当为除此悭惜贪餮兴隆圣慧。菩萨于彼兴发大哀为说经道。众生处在非谊之业。存有常计断灭之见。当令入于深奥缘起之业。菩萨于彼兴发大哀为说经道。众生处在无明愚冥。猗着我人寿命。当为除去一切邪见。令逮贤圣清净之眼。菩萨于彼兴发大哀为说经道。众生处在娱乐生死。设受五阴五体之贼。当为除去一切三界之所猗着。菩萨于彼兴发大哀为说经道。众生处于魔见系缚。处于思想计是我所应与不应。当令解脱魔网系缚依猗所著。菩萨于彼兴发大哀为说经道。众生处在塞无为门开恶趣户故。当为阐泥洹之门。菩萨于彼兴发大哀为说经道。佛言总[敖/力]王菩萨。是为十六事菩萨大士兴发大哀愍加众生也

    大哀经开化品第七

尔时佛告总[敖/力]王菩萨。复有三十二事所修善业。除不顺教罪恶之业。何谓三十二。众生在于自大睡寐立见己身。则以智慧而化导之使入道义。是为菩萨第一之业。志乐于小卑劣之乘。计吾我人。则开化之入于微妙无极大乘。众生若处非法邪见计有身者。则开化之以己所乐正法之义劝助诱之。睹于众生戒不清净。身业鲜洁本性和调。则以此业开化众生。见诸众生堕于邪见六十二疑。则以正见贤圣之业。化导群黎而建立之。见于众生存在无明所念颠倒。则开化之显示道明。思惟柔顺亦复自立于清和义。见于众生远离法行身自修法。亦开化人住于正法。而复随时为演经义。见于众生悭吝所盖。身心不贪一切所有皆能惠施。亦能化人惠诸所有。见诸众生犯于诸恶住不谨慎。身奉净戒亦化于人立于净业。见于众生多所诤讼嗔恚茂盛。身修忍辱行慈心力。亦复化人奉于慈愍。见于众生处在懈怠多所废落。身不厌倦勤行精进。亦复化人夙夜勤力。见于众生其心愦乱而志放逸。身自摄意一心禅思。令不驰逸其意安详。亦开化人立于庠序。见于众生处于邪点憍慢自大。身修智慧离于愚冥。则以大智而开化之令除闇昧。众生处于非时之行身则自坏。善权方便修平等行。亦化于人权谋随时奉平等业。众生处于尘欲所危思想。多不净行应在不应。身已永除恩爱之源。亦以化人除诸瑕秽。见于众生而处贪身来致刑狱系缚之患。身除贪己众结之难。亦化众人舍于贪身一切颠倒。见于众生不调无寂不顺律教亦未得解。身寂调定解随律教。亦化众人调定顺律。见于众生不奉孝顺而无反复坏诸德本。身承孝道亦修恩义将护善原。劝立众人使修孝事。常念反复不失德本。众生处于挂碍。诸蔽顺从恶教。身度蔽碍。亦化众人使离挂碍。众生处于非恶之教。不归先圣不顺众祐。身奉善命从明智教。亦化众人顺从旧德咨受先达。众生处于多为无义虚伪之行汲汲匆匆。身顺义理务众德本。亦复化人令勤修行立诸善源。众人处于贫匮之行离贤圣财。身修无穷遵于七财。信戒惭愧闻施智慧。亦劝立人圣贤七业。众生处于常遭疹疾。摄载四蚖身修无患安隐无欲。亦化众人使除诸病永令无难。众生处于若干闇冥离慧光明。身修明曜。化立众人无极大光众生处于三界挂碍生死五趣轮转无际。身自断除三界之着。而化众人随时拔去三界之结。众人处于左道之业。离于右路。身修正道。亦立众人住于右路。众生处于贪身寿命不睹患难。身不惜命见患所由。亦化众人不猗身命察知众难。众生处于离佛法众。身自修德不断三宝。化立众人随三宝教。见于众生舍于正法。身护经典。亦化众人将护大典。宣传佛教立乎正法。见于众生住远世尊。六思念教身随六念。亦化众人奉六思念。见于众生从于尘劳罪福之业。身离罪尘。亦化众人使舍殃秽。见于众生而从一切不善之法普离众善。身修善法舍于非法。亦化众人住于正真柔顺之法。是族姓子。菩萨所行平等之业。当可所立能顺如此。则奉正真无上大业

    大哀经道慧品第八

佛告总[敖/力]王菩萨言。又族姓子。菩萨之业不可称载。所以者何。计如众生贪欲诤门。菩萨修业积功累德。合集众行至初法门。正使族姓子。江河沙等诸佛世界满中众生。皆令成立声闻缘觉。悉令此等一切众生所立善业。不如发意菩萨功勋。百倍千倍万倍亿倍巨亿万倍。不任为喻。所以者何。自断本性所习尘欲。声闻缘觉住于缘合。菩萨大士蠲除一切众生尘劳所住缘合故。族姓子。一切众生所可造业。声闻缘觉所立德本。比菩萨业为尊为最。无有俦匹。所以者何。凡夫愚人习从颠倒不顺之业。声闻缘觉亦随缘习。菩萨业者。有颠倒功勋无量。以是之故。菩萨大士过于众生。越于声闻缘觉之上。于时总[敖/力]王菩萨闻佛所说。欢喜踊跃善心生焉。劝助赞善世尊所演。至未曾有难及难及。如来乃宣菩萨庄严菩萨光明菩萨大哀菩萨化业。唯愿世尊如来至真。垂恩广覆重复解说。何因诸佛而于众生兴立大哀。大哀何所比像。其事云何以比之瑞应。云何住在何所。诸佛世尊造业云何。善哉世尊。如来皆知亦能普见。于诸所造业而睹悉达。惟为我等而分别说

佛告总[敖/力]王菩萨。谛听善思。如来当说。如来大哀。如来造业。所可斑宣。族姓子知。诸佛世尊不兴大哀亦不奉行也。所以者何。诸佛世尊常加大哀不舍众生。从无数功积累已成。犹是之故。不行退转不舍众生。是则名曰如来大哀。其哀无量不可称计。难不可当。无可容处。从始至终无能称载。所以者何。如来得道常怀大哀愍于众生。如其佛道大哀亦如是。何谓如来得至佛道。无本无住乃致大道。于彼何谓而住于本。已计身本。立在不诚思想之源。以是之故。如来随时合成于道。名曰无本。亦无所住。以是如来成最正觉。因此达知一切众生无住无本。解其所处。当为宣传如此之谊令其晓了。以故如来于诸众生常怀大哀。又族姓子。道者寂然亦复澹泊。何谓寂然。云何澹泊。于内寂然于外澹泊。所以者何。其眼者空。察无吾我。亦无所受。眼耳鼻口身心亦复空耳。亦无吾我亦无所受。是为眼空。识别除此不为色逸。是谓寂然。耳鼻口身意亦复空耳。识别除此。不为诸法所见驱使。是谓憺怕。众生之类不能晓了。此寂憺怕使明识斯。以故如来于诸众生而怀大哀

又族姓子。道者本净亦复显曜。所谓净者。心本清净。何谓言曰其本清净亦复显曜。所谓净者。无所著故亦无所犯。等如虚空。空本净故与空合同。等如虚空故曰空等聚。究竟本净又极显曜。以故名曰本净显曜。愚痴凡夫不觉其实。反为客尘而见染污。吾当解彼本净显曜。是故如来于诸众生而怀大哀

又族姓子。道无精进亦无不精进。何谓无精进亦无不精进。摄一切法是则名曰为无精进。已能受习一切法者。如来于彼亦无精进。亦无不进。则度诸渎。又如来者。于流诸彼不见此迹彼岸。以故名曰离此彼中。如来至真皆解诸法故成正觉。由是名曰为如来也。是无精进亦无不精进。愚戆凡夫亦不晓了。吾当斑宣令解其意。是故如来于诸众生而怀大哀。又族姓子。道者无想亦无因缘。何谓无想亦无因缘。其眼于识而无所得。其无想者。不见诸色则无因缘。耳鼻口身意亦复如是。亦无所得亦无思想。不见诸法则无因缘。是无想无缘为贤圣行。何谓圣行。其于三界而无所行是贤圣行。其此无行为贤圣行。愚戆凡夫不能晓了此贤圣行。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者无往无来现在。等于三世断于三场。何谓三场。其心不退游于过去亦不驰骋。于当来慧亦不退念。于现在事于心意识而无所住。不想过去不念当来不戏现在。等于此三则净三场。愚痴凡夫不能晓了此贤圣行。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者无身亦复无数。亦无明识。亦无耳鼻口身意识。所识者。无为无数。所谓无为不起不坏亦无处所。是则名曰离于三相。是以无为。如其无为解了有为亦复俱然。所以者何。一切所有皆为自然。悉无所有。其无所有彼则无二。以故无身亦复无为。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀。又族姓子。道者无所坏迹。何谓为迹。何谓无坏。无本为迹。其无所住曰无所坏。界则为迹无我无坏。本际为迹无动无坏。空则为迹无获无坏。无想为迹无念无坏。无愿为迹无处无坏。泥洹为迹无毁无坏。是无坏迹。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道不从身而成正觉。亦不从心。所以者何。身者愚騃。如草木墙壁瓦石影譬。心者如幻。其以身心觉了如此。是名曰道。假有言辞而言兴盛。又其道者无有言辞。亦无身心法与非法。无道不道。无诚无欺。所以者何。道者无言。于一切法而无有道。何所是处。其于言辞而无所说。犹如虚空无有处所。亦无所住无有言辞。道亦如兹则无所住亦无文辞。如是其于诸法审实求道。则无文辞法亦无言。若能晓了诸法无言。是为诸法之所生也。愚戆凡夫未能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者无取亦无所依。何谓无取而无所依。断于眼识而不受色。亦无所得。不依耳鼻身口意。断无识者亦无所受亦无所得。诸法无获是谓无依。如来以此无受无依。怀来于道致最正觉。眼于受色不以为依。识不退从。耳声鼻香口味身。更意法亦无所依。识不退从。已不住识。则能分别此一切众生心之所处。何谓众生心之所处。众生心处则有四事。何谓为四。一曰色心之处。二曰痛痒。三曰思想。四曰生死之处所。彼于处所而无所住如来明此于无住际。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者则空。谓空者。道则为空。所以空者诸法皆空。如来于彼达无本空。解一切法而致正觉。空亦复空故成正觉。以此一慧则别空事。彼则无二。其无二者。空与道慧则无有二。已无有二法则无二。已无有二。则无有名无想无底无行。无所流布所可谓言。所依受者是为归趣。非真谛谊。何所有法而逮色者。空者曰空犹如虚空。所言虚空。虚空无言故曰空。空无言亦空。诸法处所为若此也。至于无名不言有名。如是无慢无言。处所亦无处所。已无慢说无处所。已名亦若兹。所说法者。又计彼法无有言教。亦无不教。一切诸法亦复如斯。生亦复然无正无邪。如来无生晓了无本。如来所知所解脱者。不解不缚是谓平等。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而起大哀

又族姓子。道等如空。其虚空者无等无邪。道亦如兹无等无邪。计于诸等无成道者。彼无有等亦无有邪。如来以此无等无邪。解一切法而悉无本成最正觉。又于诸法。而不受正亦不受邪。如其法数慧数亦如。承佛圣旨。何谓佛圣法有所受者故曰为有。是则归趣无所受者。斯无所有则无有主。以是自然而得逮成。离于自然后无游行。亦无有进亦复无退。是谓进行。有所除断。如来说法断如是行。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道如真迹。何谓真迹。计如道者色复亦如。无本不退。又如道者。痛想行识亦复无本而不退转。又如道者。地水火风其种亦如而不退转。又如道者。眼种色种及眼识种。耳鼻身口意法杂种。亦复无本而不退转。诸法所绝。使了三际种诸入。如来于彼觉了真谛而成正觉。所晓了者不从颠倒。又如去本中后亦如。其无本者而不退转。其本种者则无所生。其他种者亦复无为。中种澹泊。是则名曰如真谛迹。又如一事一切亦如。如一切事一事亦如。如一事者众多亦然而不可得。是为真谛。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者入室则入无室。何谓为室何谓无室。修行一切诸德善法。是曰为室。于一切法而无所获。是曰无室。所以无室。心无所住无有处所。故曰无室。无想三昧至解脱门。故曰无室。观察想念称量计校越度称量。故曰有室。其无识业是曰无室。观察有为故曰有室。观察无为此则无室。察于无为是则无室。得入无室则为道矣。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道无穿漏亦无所受。何谓无漏。何谓无受。离于四漏名曰无漏。一曰欲漏。二曰有漏。三曰痴漏。四曰见漏。离此四漏。所谓无受。离四事受。一曰受欲。二曰受有。三曰受见。四曰猗戒离此四受。彼此四受。悉归无明恩爱所缠。依猗于内从内发起。如来至真除于内受。所生根本于内清净。归趣一切众生清净。其内净者彼无想念已。无想念除于颠倒。唯念柔顺不住无明。已不住无明。则不复住十二有数。已能不住十二有数。则无所生。其无所生彼则寂然。其寂然者彼则无谊。其无谊者乃第一谊。其第一谊乃为究尽其究尽者彼无人谊。其无人谊无所获谊。其无获谊则如来道。是十二缘。已了十二则曰法谊。其法谊者是则名曰睹见缘起。其睹缘起则见于法其见法者则见如来。如是观者则无有本。性极本末有见想乎。何曰所有。于诸所想不兴因缘。此谓于想而无因缘。如是察者。乃为正觉如来所解。如是像法普行平等。其所等者亦无偏邪。如是平等无有诸漏。亦无所受。愚戆凡夫不能晓了。吾当开悟使分别此。是故如来于诸众生而怀大哀

又族姓子。道者清净无垢无染。何谓清净无垢无染。空则清净。无想离垢。无愿无染。无生清净。无污离垢。无起无染。本性清净。解脱无染。无游逸则清净。亦无轻戏为离垢。寂调则无染。无本为净法界显曜。本际无染虚空清净。虚无无垢慌惚不染。除内为净于外无逸。则曰无垢。无内外行则曰无垢。不习诸入则曰无染。慧尽过净了。净于当来不起无垢。分别现在住于法界。则无所染是谓清净无垢无染。而平等御于一法矣。至寂然迹。其寂然者则为憺怕。寂然憺怕是谓仁和。是族姓子。犹如虚空道亦如之。如其道者法亦如之。如一切法众生亦如。又如众生国土亦如。如其国土泥洹亦如。如泥洹等见于诸法。究尽寂然此已辩矣。于诸部党而无部党。是为清净无垢无染。如来于彼于诸色像。了一切法而无色像。遂成正觉。观于一切众生之界。无净无垢。于此诸数。是则名曰悟寐众生而怀大哀。如来则以善权方便。感致梵天。不以无请而转法轮。于彼应时六万八千梵天之众。自于天宫忽然不现。在波罗奈鹿苑之中。住世尊前稽首足下。劝请世尊令转法轮。唯愿大圣。班宣经道。若说法者多所救济。梵天。尔时叹此颂曰

  正使诸法　　寂然憺怕　　清净鲜洁
  无垢无染　　既不可获　　无音无作
  则以道慧　　最胜悉了　　于无数劫
  造立愍哀　　勤行难量　　精修长久
  欲得开化　　众生迷惑　　睡眠来久
  大愚所蔽　　众生多有　　晓了积德
  本以曾修　　故诣最胜　　必当识别
  殊异尊法　　唯愿如来　　时转法轮
  已得摄伏　　魔所处场　　寻时开阐
  于甘露门　　为众广演　　贤圣句迹
  唯愿导师　　显示道迳　　假使正觉
  矜哀无尽　　垂愍众人　　转无思议
  我身今日　　劝请至尊　　唯闻最上
  道法之轮　　设使大圣　　怀乎恩慈
  犹拘那鋡　　佛讲说教　　亦如迦叶
  转其法轮　　唯愿世尊　　颁宣经道
  譬如天雨　　多所润泽　　生于药草
  及茂五谷　　以大哀云　　普周世间
  如来为雨　　正法之水　　从始生时
  口宣妙言　　圣自发生　　当度众生
  群庶悉集　　渴仰饥虚　　唯以法味
  除其痟渴

佛言。如是族姓子。其梵天王劝请如来殷勤若兹。又佛正觉不舍大哀。在波罗奈仙人所止苑园之中。寻时即转无上法轮。沙门梵志诸大魔神梵天王世人。所不能制。所讲经道出非常音。告于三千大千世界。比丘拘轮(晋言本际)第一解法。于时世尊宣乎赞颂

  深妙不可获　　第一无所作
  拘轮解本际　　不怀于结恨

如来说此法轮之经。不可称计无央数人众生之类。受教随律见于如来。兴阐大哀。无量无限难不可计会群黎之党。皆发无上正真道意。是族姓子。诸佛世尊以十六事。愍念众生而怀大哀。常以慈愍未曾忽忘。彼亦无业不怀恐怖。如来所修无极之哀。不可称载。为一一人而造立行。江河沙劫忍在地狱。初不退还。以是方便。使诸众生随律受教贤圣之法。以此比像如来至真。为诸众生。各各一一受形命者。为一一人各各恒河沙劫。忍于地狱勤苦之患。欲使众人随律受教入贤圣法。如来不以懈倦而厌。不违大哀。族姓子知。诸佛世尊愍哀众生。巍巍如是常怀大哀。又族姓子。诸弟子众声闻种类志怀恐惧。其所愍哀。畏怖如鱼慈犹肌肤。菩萨之慈犹如骨髓。诸佛世尊怀无极哀。常当劝助求于佛慧。化声闻哀。令入道心奉菩萨哀。诸佛世尊。决于道慧故怀大哀。声闻哀者察于慈心。瞻察开化为菩萨哀。究尽启导为佛大哀。厌造立行为声闻哀。精勤转上为菩萨哀。超越诸行为佛大哀。是族姓子。诸佛世尊。而于众生常怀大哀。一劫百劫千亿万劫。为一人故住在世间。劫数难计不可称载。而于泥洹不永灭度也。必当济之故。族姓子。当解知此其佛大圣如来至真在于众生而怀大哀

    大哀经宣劫世品第九

佛言。族姓子。乃往过去久远之世。不可计会无能称载。长远悬旷不可议劫。尔乃有佛名栴檀香如来至真等正觉。而出乎世。世界曰香土。劫号上香。其佛寿命千二百六十八万六千岁。其声闻众亦八百六十八万六千人。诸菩萨众不可称限。其如来至真。有一毛孔所演妙香。熏周三千大千世界。其熏巍巍资美难量。彼佛世界曾无秽气。其土所有墙壁树木。山陵溪谷所有形色。以如来香皆被蒙熏。香气芬馥不可为喻。以故世界名曰香土。其有人众生。彼佛土皆悉被荷如来圣香使身口意不被殃舋。若有出家在其佛所作沙门者。闻此妙香皆得四禅。其土已更曾与千佛悉同一字。号曰栴檀香。以故其劫名曰上香。栴檀香作佛事竟。然后乃当取般涅槃。临灭度时察众生界。何许是人。吾应当化。令随律教。则道眼见有想无想天。而有所化异人。宿世曾以殖众德本。志在微妙佛应所化。在彼天上八万四千劫。在于彼境乃生人间无有欲尘闻大乘德。当发无上正真道意志不退转。时栴檀香如来至真。以权方便。怀抱大哀故示因缘。告诸比丘。今是吾时当般泥洹欲取灭度。于时其佛兴隆大哀。有三昧名曰无厌定意正受。现大灭度。然后广布舍利靡不周接。其正法住千八百四十八万四千岁。斯法开化多所救济。当尔之世无有像法。彼佛世尊以三昧力。等以神足建立神圣。八万四千劫。在彼没形而不自现。如是族姓子。于八万四千劫多所开化。其彼天人在有想无想天。竟八万四千劫寿已。还生人间生尊者家。年适八岁。是栴檀香如来至真乃从三昧起。在尊者家。显佛身形住诸子前。又其家中余人不睹。八岁童子独见之耳。其童子者曾志大乘。如应说法演家患难。咨嗟大道不可称载。于时童子至心淳和。发于无上正真道意。寻时得成不退转法。佛见彼心则授其决。过七万二千阿僧祇劫。当成无上正真之道为最正觉名曰宝上如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。其余人者不闻授决。独此童子一身知耳。本应器故。时万二千天子闻所授决。淑淳一心发无上正真道意。各自兴愿。宝上如来成正觉时。吾等当生于彼佛土。其佛所说必当如愿。生乎彼土宝上佛所。时栴檀香佛。授诸菩萨莂已。乃就泥洹而取灭度。诸天人民供养舍利。故族姓子。诸佛世尊。大哀具足巍巍若斯。非声闻缘觉地所能及。又族姓子。诸佛圣教若断绝时。故寻复续立。诸天中天所发众祐。其等功德益加炽盛。所化转茂。至不灭度思报功祚。终不相违而亡失也。如来讲此大哀谊时。于大会中三分江河沙等众生之类。皆发无上正真道意。减半江河沙等诸菩萨众。逮柔顺法忍。江河沙等诸菩萨众。成立大哀逮得总持。如佛世尊。又其法忍名阿惟颜。逮成此忍。于时众会闻说此言。欢喜踊跃善心生焉。俱共咨嗟世尊之德。便雨天华供养世尊。乐器自鸣。当是之时莫不亘然

    大哀经处处品第十

佛告族姓子。何谓如来所作事业。如来事业有三十二。何谓三十二。则以佛无上之慧。处处如有知。非处如有知。有限无限有为无为靡不通达。彼何谓处。何谓无处。所言非处。无家救济。身行恶。口言恶。心念恶。欲得可意所欲必获。欢悦之报生于善处未之有也。所谓处处如有。所望得护。身行善。口言善。心念善。欲得可意欢悦安隐。恩德之报归于善处。此事必果。其悭贪者。欲得财富。犯于禁戒而作众恶望生天人。怀毒嗔恚欲求端正。懈怠得道。其志迷乱眩惑放逸欲入寂灭。其怀邪智驰骋不正。欲得坏除挂碍正处。怀来真正。此不可果。施望大富。持戒生人。忍辱端正。精进得度。禅定入寂。正慧圣达。蠲除挂碍。所止之处此事必果。又复豫知其犯逆者。心不存定。禁戒清净心常寂然。如行颠倒。不能逮得柔顺法忍。如笃信空逮得法忍。如狐疑者心不休息。如除结网心得止息。知于女人不以此身成转轮王天帝梵天魔王之主在世尊前。佛知于女人转女形已成转轮王释梵魔天在世为佛。如转轮王以正治国慈愍万民不行邪恶民知转轮王不行抂横以邪治邦侵怨万民。知郁单越人终不犯恶堕苦地狱。知其域人必生天上快乐之处。知杀生者欲得长寿。盗窃不失。淫劮化生。妄言求辩。醉酒不乱两舌求和。恶口咨嗟。绮语求名。嗔求好颜。诤颂求安。邪见望度。此事未果。慈人不杀欲圣长寿。清廉不盗欲望。不失贞洁不淫。忠信不欺。圣慧不醉。不斗彼此。言和不粗。辞质不饰。忍辱不嗔。放舍不贪。正见不邪。必得长寿。财安不失。妻息贞良。口气香好。黠慧讲谊。眷属和穆。众人赞扬。听采其言。财宝丰饶。莫不瞻颜。世世识道。此事悉果。豫知八等不得不至于果证也。知得果证得入于时。知于道迹不复往来八反生死。又知往还不复三反而周旋。知于往来二反周旋。弃于五阴而取灭度。知于不还不复还反归于此世。知所在处而取灭度。知无所著不复牵连而有处所。知无所著无余终始。知贤圣士不舍佛道归于异学。知贤圣士当归命佛不信外道。又豫睹知菩萨逮得不起法忍终不退转。还就小乘无所从生。法忍菩萨必成其道不复回还。豫知菩萨坐佛树下不成正觉终不起也。坐于树下成于无上正真之道。必果不疑。豫知如来道慧广远而无挂碍。欲求如来慧不通达而有蔽碍未之有也。欲令如来圣慧损耗。而不周普未之有也。世尊道慧悬旷周接靡不通达。豫知假使有人欲见佛心未曾有也。如来心者。天上天下无能见者。知天上天下欲见佛顶无能堪任睹佛顶者。豫知如来常定心未曾忘普见一切众生所念。豫知佛心未曾挂碍心常一定见于本际。豫知世尊从本已来而无有失。所说至诚言满十方常无口过。豫知欲求世尊使有阙漏。诸佛大圣身行清净。超明月珠日月释梵。虚空清净无能及者。佛天中之天。道慧超殊巍巍无侣不可为喻。是族姓子。如来处处力无限量。所说无际。所畅文字真谛无欺。佛于是颂曰

  地尚可擘裂　　空无动使动
  欲使佛所说　　无能令有处
  丈夫尚能化　　令空为五色
  世尊所说处　　无能令有处
  佛之所宣畅　　上下并中间
  一切悉至诚　　莫能令不及
  若说非处处　　上下及中间
  此事悉真正　　终无有变异
  晓了其处处　　而为讲经法
  是故实无虚　　悉见心志性
  异学外道士　　所在皆驰逸
  用不达处处　　佛正觉无此
  其知处非处　　随时度众生
  诸佛名称广　　寻为说其处
  众生无应器　　佛亦观于彼
  随时而观察　　以何能将养
  是为第一业　　诸佛殊胜道
  所作无殃舋　　则以度众生
  无量不可计　　说处及非处
  是为大仙力　　外道无能逮

大哀经卷第三大哀经卷第四

        西晋月氏三藏竺法护译

    了三世品第十一

佛复告族姓子。如来别知当来过去今现在诸所行业所在因缘处所报应。云何别知。于是如来悉解过去所可作者。诸善报应若不善事。当来所作善不善事。报应之方。现在所作亦复如是。当来之世。两当所作殃舋功德。当悉分野如来悉知。当来所作与众殊特。当来所作方损耗者。当来所作有增益者。如来悉知。假使现在所立造业而有增益。于当来世而复损耗。如来悉知。设于现业如有损耗。复于当来亦复折减。如来悉知。若于现在有所增益。于当来事亦复增益。如来悉知。若于过去修习瑕疵卑贱之业。于当来世又习微妙正士之业。如来悉知。其所行者。因薄少功报以大德。或行大业殊异之德。致超异功不可称载。或以声闻之故而有施与。或缘觉故。或佛道故。因其施与。如来悉知。若于现在所遭苦痛若过安隐。若现作安或现得苦。或现在作恶。寻遭恼患。或现作恶未来致乐。或现作善辄获安报。如来悉知。一切众生过去当来今现在。罪福因缘所致报应。此皆如审而无有异。罪福之应亦无殊别。如来悉知。以知之故。则为如本而为说法。是为如来第二之业。佛于是颂曰

  如来晓因缘　　明眼别报应
  三世无挂碍　　知众生所行
  因当报安乐　　福趣天世人
  缘其致苦患　　安住悉知之
  善恶所造业　　因获其果实
  安住亦了此　　如明珠在掌
  或为少事业　　所获无限量
  是广若薄浅　　佛悉知本末
  或为声闻施　　若住缘觉乘
  立于最胜业　　安住悉知之
  所因造苦行　　或复成安乐
  从乐而获苦　　因复住于业
  或复苦恶行　　反成住于乐
  或有行善恶　　报以苦胜患
  或从苦致苦　　从乐而作乐
  罪福为自然　　佛悉知报应
  三世所展转　　众生因缘报
  佛了以圣慧　　不虚无有异

    大哀经了众生所品第十二

佛告族姓子。如来晓于众生他人异种所好不同志学各异。于脱未了悉知如审。云何知之。或时有人住于贪欲志好恚脱。或复有人住于嗔恚因贪欲脱。或复有人住于愚戆信欲恚脱。如来悉知。或复有人住于善德好不善脱。或复有人住于不善志信善道。如来悉知。或复有人。专精下劣信微妙脱。如来悉知或复有人。专精微妙志好解脱。或复志好专精下劣。住于殊特超异之谊。或复住在殊特专精。堕在下劣所可好信。永在邪业不决了界。或复信乐在不决定成于正业。或有好乐向正定门而得解脱。如来悉知。或有信乐当度欲界。或因信乐得度色界。或有好信超于三界。或从信喜耗减缘致殊特。或好殊特致于损耗。如来悉知。所可生处其色若干。财业各异所受不同。所信乐致顶相。或得住限。如来悉知。如其心所知辄为说法令斯得解。是为如来第三之业。佛于是颂曰

  世间志不同　　意所好各异
  志操不可限　　佛悉知无际
  佛知志所趣　　或之于信乐
  住欲嗔恚贪　　或住怒愚戆
  或住痴而欲　　住于善不善
  所行特不特　　安住悉知之
  因下劣微妙　　志性好幽玄
  或从殊异业　　专精信解脱
  或从信下劣　　因致上微妙
  或从超殊行　　便获下胜智
  犹邪不决了　　从不了正受
  好信度三界　　佛知志所乐
  所生色若干　　其在中各异
  从顶异发相　　因信得解脱
  三界诸众生　　佛悉知说法
  随其应得受　　是为十力业

    大哀经号众种类品第十三

佛告族姓子。如来悉知世间众类若干种形不可计身。云何知之。其身所为积于罪舋。如来悉知。若以其身积累功德。如来悉知。若以其身种于秽恶。致无拥护不获济界。如来悉知。又如来者悉知境界眼界色界眼色识界。了其本末根源所起。云何知之。其内则空于外亦空。内外亦空。耳鼻口身意亦复如是。意法识一切诸界。了其本末所从出也。云何知之。内空外空内外皆空。地种水种火种风种亦复悉空。云何知之。了如虚空是故知之。亦知欲界色界及无色界。云何知之。知从想念而致注此有为界无为界。知有为界无行为想。知无为界不以非行而造想矣。知尘劳界因从客尘致欲之相。知嗔恨界其本清净鲜洁为相。知于行界从不顺念无明为相。知泥洹界因从顺念显明为相。世间众人身所猗界。为如是也。所可住界所催迫。因界现仪。专精其界。从志性界。因界而住。由界而生。如来悉知。随其所知而应说法。是为第四之业。佛于是颂曰

  其人中师子　　皆晓了诸界
  于斯世间人　　从身之所行
  其界所兴起　　广普不可限
  安住一切智　　根源所从出
  罪福所从生　　诸身所因出
  由缘所可归　　及身之所生
  由是界所立　　因得脱诸种
  咸知如是身　　最胜为大圣
  眼种亦如是　　色种并意种
  最胜悉知空　　本净无忧戚
  耳鼻亦如斯　　舌种及身界
  其意法诸种　　当知悉为空
  地水火风种　　此诸界适等
  其人中师子　　等解如虚空
  欲界亦如此　　色无色界然
  别知是诸界　　因思想成立
  佛知因客相　　起欲为自然
  安住解嗔恚　　亦复为本净
  分别觉于此　　诸行及无行
  又复计泥洹　　则无有三想
  所因界出相　　犹从不解明
  一切所因出　　如巧师合散
  是世身无数　　其形为若干
  佛佥晓了知　　不自念我知
  犹如于虚空　　十方无边际
  其人中师子　　普知诸境界
  彼最胜圣慧　　极上无崖底
  众人所不及　　不能知涯际
  是为第四谊　　圣人离垢秽
  善明识诸界　　因开化众生
  以律启悟意　　所作罪福业
  不复起嗔恚　　其志悉有别

    大哀经晓众生根本品第十四

佛告族姓子。如来悉能晓了他人众生诸根精进。云何晓了。知于众生软劣根者若中间。亦复有人诸根通利。若殊特根若下劣根。所因其根缘猗思想。其根本际而兴情故。从嗔恚际起愚痴原。如来皆知诸根想念为何等类。杂碎之秽起淫怒痴。如来至真。亦悉知此诸根想念为何等类。其淫怒痴因缘诸根。而有所为。从不善缘而有此根。或从无智而有此根。或从诸念而有此根。如来悉知。又复如来知眼诸根。耳鼻身口意亦复如是。男根女根。命根乐根。苦根欢根。恐根观根。信根进根。意根定根。慧根无异根。所当知根悉知此根。其根所由眼根因缘。耳根所住。鼻口身诸所根本。有所立处如来悉知。因耳之缘而有鼻根之所立处。从鼻因缘有立舌根。从舌因缘而立身根。从身因缘立于眼根。如来悉知。何所众生因从施根而致应戒。如来悉知。此等诸根增减进退。各为分别演布施事。或有众生因从戒根而行布施应戒。如来则为演戒本末。或有众生从忍辱根而应精进。如来即为演忍本末。或有众生从精进根而应忍辱。如来则为演其精进之本末也。或有众生因一心根而应智慧。如来则为分别禅思。或有众生从智慧根而应一心。如来则为分别解说诸根增减进退之原。宣畅智慧根力觉意。八由正路三十七品。亦复如是。具足周审演其本末靡不究畅。各为一切而令判了。或有众生从声闻根学缘觉乘。如来知根演声闻乘。或复有人从缘觉根学声闻乘。佛知此等诸根所趣。则为解说缘觉之乘。或有众生从大乘根学于声闻缘觉之乘。如来悉知此等诸根之所归趣。而为斑宣大乘之业。或有众生各缘异根而学大乘。如来悉知此等诸根各各别异。则为解说。无修行根众生之徒。不能修根不应法器。如来见此不应器者。因令学观。或人修学根顺应器。如来睹之怀来应器。则以殷勤为说经道。如是族姓子。如来悉知。一切众生他人身根及其异身。诸根所趣所念不同识其本末。若不念者。晓知诸根从其比类。知诸人根志操所应因缘所为而可化者。方便从谊坐起经行进退之谊。咸达其根。如来悉畅靡所不通而为宣经。是为如来第五之业。佛于是颂曰

  知根广无极　　了众生志性
  其根为何类　　最胜悉知行
  下劣中上妙　　诸根佛所知
  无等伦如是　　从所应解意
  其际欲恶尘　　其根若薄鲜
  若复性卒暴　　假使怀粗犷
  胜知之何因　　晓了其本末
  其不善无别　　所依当解脱
  从眼意男女　　亦复晓眼根
  苦乐及欢悦　　何从致忧恼
  所因观义道　　精进意慧定
  及知他余事　　意勇复如是
  眼因缘耳处　　成致鼻耳舌
  因身至因缘　　得兴立眼耳
  施根志戒禁　　为说布施事
  戒根学布施　　为说戒法谊
  忍根现精进　　为演忍辱事
  精进现忍辱　　为宣精进事
  从智根致禅　　为人说智慧
  从精进致忍　　为人说勤力
  从禅根致慧　　为人说禅思
  从慧根致禅　　为人说圣智
  其声闻乘根　　而至于缘觉
  最胜演声闻　　为舍缘觉义
  若志缘觉行　　学习声闻行
  佛便舍声闻　　为讲缘觉事
  其根在尊业　　斯人学下劣
  佛说度无极　　分别舍缘觉
  见处处有行　　胜观为分别
  降以纯熟根　　十力为解说
  众人以何缘　　诸根所应行
  知其志性趣　　报应之所为
  从其尽诸根　　如坐成实本
  自以智慧明　　是世尊分别

    大哀经普游品第十五

佛复告族姓子。如来皆知。普由一切靡所不达。密如有知。云何知之。众生必救于真谛界。知众生界或在邪业矣。悉复分别此群生界。必定不定处于邪事报应之力。彼亦如是。其众生界必在决定。前世宿命报应之果致此功勋。明识精勤诸根通利应当被训。如来则为广说经典。此等之类。于贤圣说当为应器。如来则观宿本缘迹。寻为如应为演经道。众生之界在不决定。存因缘力为教授相。宜以戒度寻为训诲。如应禁戒不得解脱。不致济度。如来则为诱入无本。因缘报应病与药。若从如来听闻经典。奉顺道教便致德果。诸佛世尊由此等故兴出世间。众生没溺永在邪业未立德本。意劣弱颜不为应器。如来至真为讲经道。其不应器令得解脱如来睹此不应器者观察护之。以是之故菩萨大士被弘誓铠而救济之。又复如来则以三事了贪欲者。世尊。或以贪欲人故而兴出矣。又以贪欲而见系缚。欲令出家故兴出矣。或以宿命贪吝缘故。而为兴出。又知嗔恚复有三事。或以嗔恚而见系缚。思想之故。故兴出世。或有所愿不具足故。故兴出世。或有宿世阴盖所缠故。故兴出世知其愚戆当有三事。或有愚戆行无明事。或有贪见身故。或有沉吟之故。如来悉知。又如来知则以苦行了本神通。诸根明者因从苦行加痛致神通。懦劣根者。以安隐行速成神通。根通利者。以勤苦行成神通定。懦劣根者。亦因加痛而致神通。以舍因缘行于调和。了别神通。不信于道而不休息。当本加杖令成神通。佛悉知之。心性不和其行促暴。知疾可化令致神通。使无暗冥而欢喜悦。或有行者。因集道力使具足成。如来所知不复勤学。或有所行从修道力而具足成。不因集力。或有所行。不因集力不行道力。而具足成。或有所行从合集力。亦行道力而具足成。如来悉知。或有所行志性和雅其行不应。如来悉知。或有所行应机成就性不和雅。或有所行性不和雅所行不成。或有所行志性和雅所应成就。如来悉知。或有所行其身清净心口不净。或有所行口言清净身心不净。或有所行身口心净。或有所行其身口心俱不清净。如来悉知。如是之类所可行者。因缘报应所可依倚所从出生一切众生之所行者。如来悉知。慧无损耗普达悉见是为如来第六之业。佛于是颂曰

  其有因行者　　如往悉知之
  决定之种类　　识别众生界
  其不决定者　　所行动虚伪
  不应器如是　　随邪见之业
  其贪欲行者　　则有三因缘
  嗔恚行复三　　愚戆亦如是
  斯尘欲之界　　无量杂种类
  世尊悉知之　　所行因缘应
  所行勤苦事　　谓意聪达者
  其懦劣之根　　亦复当如是
  诸根通利者　　因行安隐来
  世吼悉护知　　如是等无异
  而行调和者　　而住寂清净
  则以因此故　　速得致清净
  亦疾成其行　　究竟道调和
  亦复加疾使　　寂然寻欢悦
  合集诸所行　　积累其功德
  或不以行道　　而达于道慧
  或有从行道　　而获于成就
  俱知其二事　　从殊特行成
  或有修行者　　志性而和调
  或有应所行　　而不顺应行
  有大人之行　　两事俱清净
  佛普见一切　　无所不晓了
  或有人作行　　其身修清净
  其所言心念　　而不能清净
  或复有修己　　身口行清净
  其心之所为　　未曾行清净
  或有在世间　　身口心清净
  众生之所行　　佛皆见普达
  或有能成就　　或不能究竟
  是为安住佛　　第六所了业

    大哀经一心定意品第十六

佛复告族姓子。如来至真。知其一心脱门定意正受之业。尘劳嗔恚之所从发。审如有知。云何知之。众生尘欲之所系缚。所因报应而致此缘。当复何缘而致清净。如来悉知。何谓缘报。何谓事业。从不慎念而致缘报。从无明事众生之类而致欲尘。从无明事而致行矣。从行致识。从识致名色。从名色致六入。从六入致所更。从更致痛。从痛致爱。从爱致受。从受致有。从有致生。从生致老。从老致尘欲。为报应因致事业。因见致爱。从结爱处。是为缘报。是为事业。缘致爱欲尘劳之缚。彼复何谓缘报。云何事业令其众生致于清净。有二报应及十二事。众生因此而致清净。何谓为二。一曰因从他人闻柔顺谊。二曰内自己身如应念法。复有二事而致清净。一曰而一其心专志学问心不愦乱。二曰晓了方便寂然之谊观察其源。复有二事而致清净。一曰知无所来发动所起。二曰知无有来亦无所至。复有二事而致清净。一曰观无所生本无处所。二曰致于灭度亘然寂静。复有二事而致清净。一曰其行成就无有不办。二曰明慧之事造其正证。复有二事而致清净。一曰志修道法顺入脱门。二曰其本清净至度知见。复有二事而致清净。一曰至灭尽慧而无所著。二曰无所生慧常无所猗。复有二事而致清净。一曰则以至诚而致道德。二曰常以审实获于成就。是二报应及二业清净众生。如来悉知。又尘劳结方便无量。清净方便亦复无限。又其尘劳而致清净。便近成就因审观故。又净方便。随尘劳行而渐近法。摄其慢者。如来圣慧悉达知此拔其因缘。此族姓子。如来之慧寂然于欲澹泊。诸恶不善之法。兴行俱念忽静安隐。行第一禅以能一心。住寂灭界静然正受。从第一禅起修八解门反覆逆顺而修正受。所见皆知三昧正受。显示平等又现定意。如来三昧无所畏难无能坏者。如来三昧无有因缘不从方便。如来常定一心不忘。于诸三昧最为上尊。常住一定普见一切三昧正受。其心不退未尝增减。其所显现无有不定。如来三昧初无所生。无能观察。声闻缘觉所不能及。过诸菩萨及正真觉。如来三昧无能越者。卓然殊绝巍巍无量。一切众生所不能知。如来之慧亘然无际。无穷无极无可为喻。以权方便开化声闻令得定意。如来悉知。了诸缘觉菩萨行事。随其应时而教诲之。是为如来第七之业。佛于是颂曰

  众生因缘事　　其尘劳爱欲
  自在悉知之　　其慧无崖底
  如其行清净　　及复不清净
  佛大慧自在　　悉能晓了此
  不慎念报应　　因缘生明慧
  事业无明行　　及其所造作
  识名色如是　　其本情六根
  世尊悉达之　　因缘所事业
  其缘劳尘欲　　所贪诸所作
  睹见其因缘　　事业于欲行
  思想所缚结　　因是为缘起
  众人所住处　　从是致因缘
  众人所誓愿　　则有二因缘
  因从人听者　　慎省受其言
  内已如应念　　观诸法悉空
  彼人致解脱　　生死之江海
  寂然而观察　　精勤蠲除二
  思惟而睹之　　无来无有去
  称量省其源　　无生亦无终
  彼寂灭入道　　尔乃为清净
  常住于正行　　慧者修行三
  其无放逸者　　遵崇三脱门
  成于灭尽慧　　至诚逮无生
  是缘报事业　　清净兴上愿
  最胜一心知　　常三昧正受
  逮成于寂灭　　意勇复起立
  观察而思惟　　一切诸逆顺
  其佛大法王　　八解门正受
  则以一定意　　致无量亿定
  无等伦悉见　　其行而普平
  其心定所行　　道法无穷极
  由是之行故　　胜心无所定
  若声闻缘觉　　定意亦如是
  诸菩萨若兹　　若干种定意
  安住之意定　　皆超越其上
  如来所修业　　随时慧教化

大哀经卷第四大哀经卷第五

        西晋月氏三藏竺法护译

    知众生本行品第十七

佛告族姓子。如来见已及他众生。知于往古不可称计本所行业。一世十世百世千世百千世无数世不可计载。百千亿世天地成败劫立劫尽。亦不可计无能限量天地及劫之反数也。而悉知之靡不彻了。本于某处名字种姓。居止饮食颜色形容寿命长短。所更苦乐善恶之事。于某处没生于某处。于某处没复生彼处。言语学问音辞章句。而悉说之。己身本末一切众生。皆以了了为众生讲。如来咸知。众生因所从来本末根源。所更苦乐随其应时。察其本末而为说法。识其过去心所执怀心所抱缘使其挂碍。或无朽废所因兴缘。本为何从而有是心。如来皆知。其一人心所行如是。因其行而起阴蔽。如来能悉颁宣无数恒河沙劫所行本末。亦复观察一切十方众生心之本末等无差特。说其本际当来亦然。心之所缘如来所睹。而演本无有过于此而无穷极。是为如来知其往古过去众生之心不可思议不可称量。佛之圣智不可称计。如来察于众生之行。心怀恐惧扰扰不安。周旋生死。某在某处。某从某来。本殖德本志在佛道。或为声闻缘觉之乘。缘其种德承佛圣慧。悉识念之。是为如来而知众人所殖德本因缘之报。应其根源而为说法。而令听者立不退转。各从本行心所信乐。使得其所。是为如来第八之业。佛于是颂曰

  其劫之数　　无底亿垓　　世之锭燎
  悉识往古　　又察己身　　及知众生
  所观了了　　如掌中珠　　名字种姓
  颜像亦然　　住此终没　　所周旋处
  因何所缘　　而受其身　　其平等乘
  演说彼法　　其有过去　　无量无底
  众人之心　　所想念法　　所可由从
  而其发心　　最胜大慧　　而皆知之
  其中间心　　从古过去　　因人所行
  安住悉知　　恒河沙劫　　称量本末
  咨嗟讲说　　不得涯底　　当来无底
  本际之源　　而为颁宣　　往古所行
  其无俦疋　　慧不可尽　　世尊如是
  圣慧如海　　若有众生　　立德求佛
  设于过去　　奉敬最胜　　住佛神足
  力无所畏　　悉念于此　　前世所作
  世尊皆知　　众生所念　　如其往本
  所种众德　　悉识于此　　住三乘者
  成不退转　　解脱净道　　安住别识
  过世善行　　一切众生　　无能思议
  是为大圣　　第八之业　　以化众生
  所度无底

    彻视品第十八

佛告族姓子。如来至真。以净天眼过于凡俗。皆见众生生者死者微妙瑕秽善恶祸福好颜丑姿趣安趣苦。如其众生所兴祸福报应之果。如其本末悉知斯实。其人如是。身行恶口言恶心念毒害。谤毁贤圣坠于邪见。以此邪见所行事业。寿尽身坏堕于恶趣危害地狱苦恼之中。于是民人其身行善。发口言善。心所念善。不谤贤圣随其正见。则因正见所行快事。寿尽身散。便趣安处快乐世生。如来于彼则以天眼。如其方面观诸佛土。等如空界无边无际。思其法界而不可得。亦无所著。超过一切诸所句迹。其有众生受形类者。敢有现世皆见终没而复生者。其诸佛土今现在者。皆见有外散坏合成。又复所现诸菩萨众。悉复睹此尽终没。来就其生而复出家。或复所现坐于树下。成最正觉转于法轮。舍其寿命而取灭度。声闻解脱灭度。皆复见此缘觉之法。显示神足而为众生作祐。或有众生形不现者。外道异学五通仙人明所不睹。声闻缘觉及诸菩萨所不能逮。如来至真。则以天眼悉睹此类。如来见于众生所有微神。根如车轮多于三千大千世界。其不现者不可称载。众生之界如是无量。浩浩昊昊无有崖底。如来天眼巍巍如兹。悉睹一切诸佛国土众生种类本末源界。何许众生。佛所应化而随律者。从其人本修行佛戒。寻立其前便化其人。余人在边犹不见知。是为如来第九之业。佛于是颂曰

  如来之天眼　　清净无垢秽
  严治无量劫　　功德威神圣
  睹见于十方　　诸佛土众相
  所有及与无　　诸所可兴衰
  彼所有众生　　有色并无色
  归于善恶趣　　生上下中间
  退没来受胎　　行恶堕苦恼
  积德则安乐　　最胜悉知此
  其诸菩萨众　　一切诸佛土
  游步所作行　　出生弃家去
  若在佛树下　　降伏魔官属
  诸佛皆知此　　天眼悉睹之
  若佛为法王　　逮上最正觉
  所可转法轮　　度脱诸天人
  为作尊佛事　　或复放寿命
  若复现灭度　　佛亦悉睹彼
  其听导师法　　思惟而修行
  致尊清净业　　兴立无恼热
  自闻于经道　　毁呰于生死
  已度至彼岸　　最胜悉见之
  其外道声闻　　缘觉及菩萨
  天眼之所睹　　不究见生界
  如来之天眼　　清净无垢秽
  普见于众生　　微妙身神处
  所现如车轮　　众生细妙身
  多于三千界　　诸天人民形
  生死若干种　　众生界如此
  悉知天人想　　普为现佛道
  如来所开化　　众生根通利
  世雄在前住　　为说尊上法
  余人在其边　　不见如来化
  是为导师业　　天眼之势力

    大哀经诸漏尽品第十九

佛复告族姓子。如来至真。皆尽诸漏以无漏心而修解脱。以智慧度已证神通而尊其行。生死已断建立梵行。所作已办知名色源。如来于彼以无漏慧。清净无垢鲜洁显曜。蠲除一切诸所止处挂碍之蔽。诸声闻众诸漏所尽。而有限碍未至止处。其缘觉者所尽诸漏。若有限碍于大哀行而无辩才。如来至真。所尽诸漏众行普会而悉备足。皆除一切诸所止处执怀大哀辩才勇猛而无所畏。威神巍巍无能谛察。一切世人所不能逮。一心一时而佥平等。如来至真。亦无罪业挂碍止处。威仪礼节亦无缺漏。犹如虚空而本清净。一切诸魔及诸外道所不能当。功德名称。是为如来诸漏尽慧。不与一切尘欲挂碍而俱合同。是无漏慧住于坚固。为诸尘漏众生之类。讲无漏法。除诸所著而说经典。从不诚思而出生矣。众生由此而成众漏则受阴入。以故汝等观察而审。如来则为兴喻示本。而现其前如应说法。令知尘欲虚伪无实。使知如审以了真谛无受法者。是族姓子。如来至真第十之业。佛于是颂曰

  其导师者　　为无漏慧　　明阐广普
  清净无量　　所以十方　　以势超殊
  堪任于此　　笃信遵道　　诸漏尽慧
  谓声闻众　　不除止处　　缚在挂碍
  人中之上　　为众导师　　已除止处
  独无限碍　　其得缘觉　　亦复如是
  无有大哀　　及与辩才　　有佛世尊
  诸漏已尽　　以无尽慈　　辩才无量
  清净尊人　　住无尽慧　　知其众人
  诸漏所因　　缘其好此　　而与众生
  不能晓了　　其应真迹　　最胜则为
  愍哀此三　　讲无常法　　苦空非身
  今此诸法　　本从无出　　了是若干
  致尊佛道　　亦无有人　　及与寿命
  号名为人　　所作亦然　　一切众生
  猗此若干　　世尊兴愍　　故说解脱
  又其安住　　不以懈惓　　亦复未曾
  减损佛智　　以故最胜　　常怀殷勤
  心恒怜伤　　颁宣经道　　佛业如是
  伦匹若兹　　是为十方　　降伏外道
  十力所住　　建立势强　　转无称量
  殊胜法轮

    大哀经四无畏品第二十

佛告族姓子。如来至真。有四无畏谛住勇猛所作业者。吾为至真平等之觉。自了如此。诸天世人沙门梵志魔王释梵。不能障塞如来之法。言不晓了。成最正觉未之有也。何故如来名等正觉。了一切法悉为平等无有偏党。其凡夫法及与佛法。则悉平等故成正觉。其所学法及不学法缘觉之法。与菩萨法。至诸佛法悉亦等之。故曰正觉。其计世俗及于度世。有罪无罪有漏无漏。有为无为。有数无数。此二诸法亦悉等之。故成正觉。彼何故等以空故等。故曰为等。诸见自然以无想等。想自然故。以无愿等。三界自然故。以无想等。所想自然故。以无行等。行自然故。以无起等。所起自然故。以无依等。所依自然故。能如审等。三世自然故。以慧等。无明恩爱自然之故。以泥洹等。生死自然故。又族姓子。如来至真。于一切法如是平等。故成正觉。是故名曰平等正觉。如其如来晓了诸法成最正觉。如是建立住于大哀。便为众生。若干方便种种因缘。各为如应而分别说。则归命法因法而生。寻时灭尽苦恼之源。其此非师自称为师。不尊称尊。未成正觉自谓正觉。是故如来于此俦类独无所畏。超绝无侣而无伦匹。是为如来十一之业。佛于是颂曰

  于诸法平等　　由已成正觉
  是故平等觉　　如来而普现
  其凡夫之法　　佛法则亦等
  所学不学法　　及诸缘觉乘
  诸有世俗法　　及与度世法
  诸善不善行　　泥洹一等类
  解空及无相　　弃捐于诸愿
  无生无所行　　等见于此事
  等明如是业　　所说亦如兹
  因此度众生　　是为大仙法

佛复告族姓子。如来自知诸漏已尽。彼诸天人天上世间。无能讥谤如来至真敢言诸漏不尽者。所谓如来诸漏尽者。如来已脱爱欲之源。心解诸欲无所挂碍。又佛心者已度诸漏。蠲除一切尘劳之行无所挂碍。是故名曰如来至真。诸漏已尽故显现世。以贤圣慧第一真谛。无敢当前能遮蔽法雨。当令除灭秽修之行使其造证。以故曰尽。无有不尽。未曾生尽。以此名为尽。如来所尽。谓真谛者无所复尽。已无所尽此则无为。其已无为彼则无受。无在不在。此无处所。是谓兴立。成诸如来住无所生。是诸法住如法界住。此为应慧。如是应者。则无所应亦不灭度亦无所成。如是像法则不可得。诸漏形色亦不除漏。如来大哀住权方便。皆为众生而演经典使除诸漏。是为如来十二之业。佛于是颂曰

  最胜已尽诸漏欲　　未曾复有贪挂碍
  人尊皆脱诸生死　　已断瑕秽无有余
  安住皆弃诸无明　　未曾可得愚痴冥
  人中师子诸余见　　是故无碍无欲尘
  安住所说随其时　　皆尽诸漏无死生
  究察诸法无所有　　岂能使尽复令长
  其所尽者无伴党　　若已尽者假名尽
  其有尽者二有为　　计彼又无于三相
  住于此界无取作　　佛以圣慧度彼岸
  晓了是以应说法　　是为安住十二法

佛复告族姓子。如来悉了蔽碍尘欲诸挂惑法而无挂碍。天上世间诸天人民。无能堪任毁于如来言不应法。于彼何谓废退于法。又有一事令法废退。何言毁于如来为不为一。谓心愦乱不能专精。复有二法。一曰不惭。二曰无愧。复有三法。一曰身行恶行。二曰口出粗辞。三曰意念毒害。复有四法。二行于四至不可至。一曰[怡-台+龍]悷。二曰嗔恚。三曰触忌。四曰愚痴。复有五法。一曰杀生。二曰盗窃。三曰贪淫。四曰妄言。五曰醉酒。复有六法。一曰无恭恪心。二曰秘惜经典。三曰轻毁禁戒。四曰不随定意。五曰不怀法念。六曰憍慢法师。复有七法。一曰自大。二曰甚慢。三曰重慢。四曰是我。五曰邪慢。六曰过诸贡高。七曰无能及我。复有八法。一曰邪见。二曰邪念。三曰邪言。四曰邪业。五曰邪活。六曰邪便。七曰邪意。八曰邪定。复有九法。谓九害恼。一曰我所敬者而轻蔑之。二曰今现轻蔑。三曰将来党侵。四曰我所憎者而敬爱之。五曰今现钦敬。六曰将来钦敬。七曰曾侵毁我。八曰今现侵我。九曰将来侵我。缘是之故起恼害心。复有十法。谓十恶业。一曰杀生。二曰盗窃。三曰淫劮。四曰妄言。五曰两舌。六曰恶口。七曰绮语。八曰无明。九曰斗诤。十曰邪见。是为所行从不顺念。见应顺法而不爱乐。堕于颠倒立在阴盖。依倚邪见恩爱之弊。则失正法违远妨废。身口心行如来悉知。如其所知知诸蔽碍。所说如审。如是法者致于蔽碍。当除此法。已能除去故为说法。令诸众生去诸阴盖超然则出。是为如来十三之业。佛于是颂曰

  诸最胜晓了法　　其习此不得脱
  着心怀不能舍　　谓不知羞惭者
  身口意亦如是　　初未能将护斯
  贪嗔恚痴恐惧　　犯杀生偷窃人
  犯人妻妄语醉　　六失行七憍慢
  说于八邪脱门　　皆妨废解脱迹
  若不能制其意　　乃及十不善句
  由不舍不顺念　　是等类未解脱
  见随逐颠倒着　　而依猗放逸谊
  不当习如是法　　可成兹人中尊

佛复告族姓子。如来晓了贤圣所行。寻造平等尽苦恼。众生习善因是得生。若造平等便灭患害。假使诸天世间人民。不能障蔽如来正法。谓于至尊。不应众圣之所宗奉不任大道。佛永无畏。何谓所宗。谓一乘道净众生。有二法。一曰寂然。二曰所愿。复有三法。一曰空。二曰无想。三曰无愿。复有四法。谓四意止。一曰身意。二曰痛痒意。三曰思想意。四曰法意。复有五法。一曰信根。二曰精进根。三曰意根。四曰定根。五曰智根。复有六法。一曰念佛。二曰念法。三曰念众。四曰念施。五曰念戒。六曰念天。复有七应法。一曰意觉意。二曰法觉意。三曰精进觉意。四曰欢悦觉意。五曰信觉意。六曰定觉意。七曰护觉意。复有八应法。一曰正见。二曰正念。三曰正言。四曰正业。五曰正活。六曰正便。七曰正意。八曰正定。复有九应法。一曰第一禅。二曰第二禅。三曰第三禅。四曰第四禅。五曰虚空慧正受。六曰以慧正受。七曰不用慧正受。八曰有想无想而为正受。九曰灭于一切诸痛思想正受。复有十应法。一曰离杀生。二曰离盗窃。三曰离贪淫。四曰离妄言。五曰离两舌。六曰离恶口。七曰离詈骂。八曰离绮语。九曰离嗔恚。十曰无邪见住于正业。是谓应行。离于所生。是为诸善三十七品。合集戒品成于定品合于慧品究竟解品。通达度知见品成贤圣谛离于所生。复次所谓离于所生。谓修行平等贤圣之事。所谓应贤圣者。彼无法品若二不二有权无权。有进或退若生不生无受无舍。道所越度诸不平等二事之行。诸法无二。则如审慧修所依生。如来以此无所生行。为众生说。若能行此众生归斯寻尽苦恼。是为如来第十四业。佛于是颂曰

  近斯清净　　至不可量　　人所依猗
  逮到清净　　最胜普闻　　而悉知之
  已知经典　　乐说甘露　　至乎众善
  无数诸法　　道品清净　　为佛世尊
  勇猛习此　　而得解脱　　十力所演
  无有所处　　如应顺念　　灭尽尘劳
  方便等法　　无忧丰茂　　不依于法
  不猗非法　　逮平等脱　　精进平均
  其缘善德　　不依道法　　慌惚虚无
  如空无念　　犹如幻化　　如梦所见
  彼则得度　　生死所趣　　是为十力
  所行之业　　人所获致　　于所周旋
  是以大哀　　而度脱之　　兴隆慈愍
  故无等伦

    大哀经十八不共法品第二十一之一

佛复告族姓子。如来至真。而无缺漏。智者愚者。得未误失所行正法。所以者何。如来至真身行无阙。则为至真平等之觉。威神巍巍端正殊绝。威仪礼节视瞻举动。顺于等行。被服法衣手执应器。行步进止往来周旋。经行坐立猗卧出入。郡国州城大邦县邑聚落。足不蹈地。千辐相文自然轮现。柔软殊妙香洁莲华而现乎地。如来之足践于其上。其有虫蚁含血之类。遇如来足昼夜七日而得安隐。寿终之后复生天上。其法衣被自然四寸不[打-丁+親]其体。随蓝之风不能动衣。其傍众生皆得获安。是故言曰如来之身无有缺漏。又族姓子。如来至真。有所演辞未曾有短。智者愚者。不能得便求瑕阙者。所以者何。如来至真所言以时。演辞至诚如实无虚。应谊合法顺如律教。所言平等言行相应。语无违失应不应时口所说者。皆悦一切众生之心。无有复重。谊理美要成就庄严。口演一音。悉应众生志性所念。各得闻知忻然解达。是故名曰如来至真言辞无短

又族姓子。如来至真心之所念亦无误失。而令智者及与愚者求得便者。心念法失。所以者何。如来常定无有不寂。怀众生类得其心本。除诸误失而为说法。是为如来十五诸业。佛于是颂曰

  其尊大人　　无有阙漏　　身行口言
  胜心所念　　其世吼护　　无短无罪
  愍哀入中　　怜伤等现　　欲求佛失
  一切悉无　　以此经法　　示人令寂
  使皆弃此　　诸瑕阙行　　是为最胜
  十五之业

佛复告族姓子。如来至真。无有粗教。所宣音响而令诸魔及与官属。并外异学裸形露精殊别异术而得便者。如来无言亦无有声。离诸猗着。如来难说一切众生。咸皆启受不以有为。亦复不处在于无为。如来身行靡不究畅。口言无短而今所行。人得其便不与世诤。是故如来无有音响。常顺空行。如来无我亦无所受。复无贪业离一切趣。是故如来无有诤讼。设无音响。因此蠲除众生音响。而为说法。是为如来十六之业。佛于是颂曰

  若闻咨嗟　　不以动悦　　若闻毁呰
  亦不愁戚　　除诸所著　　亦无猗望
  本修善行　　行无所著　　最胜谛修
  常顺空行　　无我无受　　彼无憎爱
  如其所住　　讲说经法　　是为至诚
  所说尊业

佛复告族姓子。如来常念未曾忽忘亦无愦乱。意不迷慌而违远法也。如来常定为一切智诸通之慧。则以脱门定意正受以无能忘。普见一切众生心行之所住处。观察其本。便以应谊而为说法。不违法谊辩才开明。随顺无逆。其不忘者。去来今慧无所挂碍。咸见三世因其己身。自以其心未曾忽忘。慈愍十方一切众生。亦复如是。殷勤念济而为说法。是为如来第十七业。佛于是颂曰

  导师所念　　未曾忽忘　　顺从法禅
  脱门为行　　一切众生　　志性所行
  应其所之　　而为说法　　所分别了
  未曾忘失　　达于三世　　应无所犯
  设无所忘　　应其说法　　是诸大圣
  所行之业

佛复告族姓子。如来至真。心常静然无有不定。坐起行步卧寐饮食言辞寂然常以一心。如来至真三昧微妙所度无极。越乎彼岸。禅思一心初无阴蔽。普察众生诸有形类。行定者不定者。永无敢睹察如来思惟念所见心也。除其如来神圣所建。作其威灵乃能见耳。设如大圣常定一心三昧亦然。不可上下为人说法不复观察。所以者何。常见一切众生心故。佛之圣慧巍巍如是。不可攀逮。玄如虚空无有表里靡不通达。是为如来第十八业。佛于是颂曰

  佛无进退　　心常永定　　行步住止
  坐卧寝食　　言辞寂然　　无能乱者
  最胜常定　　莫敢迷惑　　八方上下
  终无得便　　亦无敢知　　其心所定
  因其所定　　为人说法　　常演道谊
  是最胜业

大哀经卷第五大哀经卷第六

        西晋月氏三藏竺法护译

    十八不共法品第二十一之余

佛复告族姓子。如来至真。无若干想亦无众念而令其心迷惑忘也。所以如来无若干想。如虚空土不可穷尽。不察众生而各各异。用其本净无若干故。察于诸佛无若干种。用其法界不可破坏。慧平等故。亦于诸法无差别想。用无欲故。如来不坏奉禁戒者。偏爱顺念。亦不毁呰于犯戒者。睹修道者不往肃敬。不尊道者不以弃忽。不计律教是我所也。永处邪见不轻忽之。如来至真所行平等于一切法。是故名曰如来至真无若干想。设无若干。则便宣此无若干想。开化众生令不各异。众想消除而为说法。是为如来十九之业。佛于是颂曰

  诸安住道　　无若干想　　一切最后
  见诸佛土　　计于经典　　无各各异
  诸大名称　　所行普等　　设奉禁戒
  若毁失者　　众生易化　　若不可化
  诸两足尊　　彼心平等　　开度众生
  各怀贪相

佛复告族姓子。如来至真。无有犹豫。所观察者悉见根源不复思惟。所以者何。如来大圣道德已成莫观不成。身行谨敕心怀柔软。戒禁鲜明智慧殊绝不当瞻觐。如来圣明不有超异也。佛以智虑常察普护。不从愚冥则由度世。不堕方俗迷惑之行。如来所护因从贤圣。不从不圣贤。如来所护。转于清净无上梵轮。愍哀众生而得自在。独步十方不从他人。而有所誉无有偏党。又其如来所观护者。无卒不暴常顺庠序而无错谬。若有所往得无受舍。已离于二诸所氾流。已度四渎称量一劫。思惟本末不能究尽。各各异所不念所。不知过去念无所娆触。不自现功。如是审实而无有异。佛悉究畅靡所不达。是为如来观察大哀巍巍若此。护诸众生具足说法。是为如来二十之业。佛于是颂曰

  如来所观护　　未曾有懈惓
  善修其道谊　　卓然殊特行
  其心身如是　　禁戒及智慧
  尊上为大人　　所行常至诚
  如来未曾怀　　猗着诸危害
  亦无想诸念　　不为虚伪事
  其所观护者　　真谛无华饰
  便则以此谊　　为众生说法

佛复告族姓子。如来至真。无有贪损。何谓为贪。唯乐善法。其善法者为何谓乎。如来大哀未曾损秏。亦不猗贪。咸于大哀所说经典亦无误失。不令众生从律贪欲而致迷秏。开化众生初不谬惑。不舍闲静。亦无所启而有违废。劝诸菩萨未曾喜忘。而于三宝恒不断绝。如来至真无所贪着。圣明至真道德为乐。是故名曰如来正真。无有贪欲而致损秏。为诸众生颁宣经典。令其慕乐无上正真具诸通慧。是为如来二十一业。佛于是颂曰

  最胜常不贪　　慕乐善德业
  慈哀施以法　　度脱于众生
  喜乐济群萌　　随时而开导
  最胜不损道　　劝不断三宝
  无贪嫉嗔恚　　不从愚禁忌
  由因诸通慧　　善慕经典教
  见众生懈怠　　最胜化勤修
  积无量慧业　　以此度群黎

佛复告族姓子。如来至真。于精进事而不损秏。所谓如来精进。云何谓开化众生。观察殷勤求之所在。因而度脱不遗一人。于听经典常令清彻。是为精进。如来至真。如是比像得诸听经。为诸应器一劫不倦。因而听采甚深法者。大圣宣之一劫不废。为说经典离于食馔将护众生。如来至真以一人故。于恒河沙诸佛国土而独游步。从如开化令发道意。如来身心及口所言不以懈倦。身心静然无有闲据。如来方便精进勤修靡不咨嗟。因随平等则以精进。化乎众生至圣解脱。其致道真。乃至申畅如来功勋。是为如来二十二业。佛于是颂曰

  其人中师子　　因精进之力
  以此精进力　　常而咨嗟之
  其精勤势力　　未曾有损秏
  所演说经法　　用应法器故
  安住所精进　　无能究畅者
  其身口及心　　初未尝劳倦
  已精进平等　　一切无罪亹
  其意怀愍哀　　常为众生说

佛复告族姓子。如来至真。意之所念一切未曾而中忘也亦不损秏。如来所念竟无中废。所以者何。族姓子。从初得成至最正觉道。以普见一切众生过去当来今现在心之所怀念。悉忆识之不中忽忘。永存普达众生之行。如来未尝复重惟极遣慧往察。如来所念实无损秏。入于众生三处诸性。入诸人根观众生行。如来所兴不有观察亦不思惟。而为众生讲说经典。豫知时节进退迟疾。而为分别授其决矣。所以者何。其意永存不中忘故。如其心定因无所忘。识念众生寻为说法。是为如来二十三业。佛于是颂曰

  世雄所念　　心未曾忘　　又最胜尊
  不忆重思　　其所游步　　如成正觉
  知众生心　　无有遗漏　　亦复未尝
  猗于识知　　见于众生　　久长性行
  令其建立　　无有事业　　人中之尊
  为众法王

佛复告族姓子。如来至真。无失定意三昧正受。一切诸法无有偏党。诸法如审。何故如来不失定意。用修平等无卒之故。三昧亦等故。如来等于欲际。无欲之际亦复等矣。如生死际等。泥洹际亦复如是。以平等故。故能正受此之谓也。赞于如来三昧不忘。所以者何。则于平等无忽无忘亦不退转。如来定者不合于眼。亦复不合耳鼻身口意而同尘也。诸根不定。其三昧定不依地种。亦复不依水火风空。亦复不怙欲界色界无色界。不慕今世不恃后世。无所著故。故不损耗。是故名曰如来至真定意不忘。亦为众生讲说经典。令应法器致乎定意。是为如来二十四业。佛于是颂曰

  最胜为常定　　定意不损耗
  等顺一切法　　正从佛定意
  不猗地水火　　风欲色无色
  大圣不着此　　故不损三昧

佛复告族姓子。如来智慧未曾损耗。何谓为知。敬达诸法无所不通。慧不仰人。为他众生班宣圣智。方便随时所决无尽。明了一切章句显迹。令入一品住所说经亿百千劫。假使来问去来进退。为决疑网靡不坦然。其慧遍入宣畅三乘。剖判归趣。以诸众生八万四千行。则为讲说八万四千诸经法藏。是为如来智慧无极无量无尽。所说无限慧不损耗。亦为众生显示如是无尽智慧而为说法。是为如来二十五业。佛于是颂曰

  佛正觉智慧　　现在志慕乘
  善宣分别解　　自在度无极
  为众生说法　　从本性所乐
  则以一文字　　入无底章句
  知于众生行　　所察无边际
  则为此等班　　八万四千藏
  安住之所宣　　智慧无损耗
  是为十力业　　故号人中尊

佛复告族姓子。如来解脱无有损耗。何谓如来说。诸声闻因声而脱。其缘觉者由了因缘而得解脱。诸佛世尊。皆离一切挂碍诸二而得解脱。所以名曰解脱者何。无过去界不与当来。诸界合同不住现界。其眼于色离于二受。名曰解脱。耳声鼻香舌味身更心法。离于二受而得解脱。心所依倚心本清净而悉了之。故曰发心之顷成无上正真道。如来随时为诸众生讲说经典使离猗受令无所著。是为如来二十六业。佛于是颂曰

  诸声闻众　　依音解脱　　诸缘觉学
  因缘为慧　　过诸挂碍　　无垢如空
  是为诸佛　　无依所猗　　其心系在
  于过去事　　清净解脱　　是为执心
  如应解脱　　察众生根　　开度众生
  不令损耗

佛复告族姓子。如来至真。知于过去一切身行所可造业。其本明识而不废退。如来所睹诸胜所行。因其随时而化众生。有所讲说而度群黎。默然亦度。饮食亦济。威仪礼节显示众生令随律教。或复现于三十二相。因而得救。或以自示八十种好。因而得度。或复欲观如来顶相。威神巍巍不得谛视。光踰日月超绝无侣。因益喜悦而从得度。或有众生趣来见佛辄随律教。或演光明睹其曜晖而得济度。或见经行举足下足悦而得济。或入城郭从其还出令受开化。诸佛世尊。举动进止威仪礼节。皆以此事益于众生。靡不受化未曾唐举。是故名曰如来至真。一切身业本慧[番*去]党。靡不有益而不损耗。是为如来第二十七业。佛于是颂曰

  其目睹见　　威仪礼节　　行步所入
  若复还出　　诸相种好　　及顶威曜
  以此开化　　而度众生　　导师假使
  演其光明　　无数群萌　　亿载安隐
  见其威曜　　则随往教　　诸两足尊
  常修此业

佛复告族姓子。如来至真口所演业。皆为慧党晓了自在。所以者何。诸佛世尊所说经道。悉为应时所说无虚。善哉随宜。所可宣言至诚无欺。无有罪舋。举动安详而不卒暴。离于粗疏未曾荒迷。常怀质直无有谀谄。初不恶口不演粗辞。无所猗着口言柔软。进止应法不为羸弱。性不飘飖亦不狭劣。不为杂碎行步安谛。发言和雅其声柔软。音响香美。择言徐语舒缓时出。辞章粲丽滋味具足。无有犷[革*卬]言无疾病思而后语。自护己身。所为应节。心念随时。灭其贪欲而除嗔恚。烧其愚痴降伏诸魔。危害众恶疗治诸疾。别其义理悦智者意。音如哀鸾声如天帝。其响哀和亦如江海。声靖如地。如雕鹫王命诸眷属。其意安隐如须弥山。所发言辞殊赤觜鸟。其声慈愍犹如鸳鸯相呼和时。亦如雁王将导营从。亦如鹿王鸣呼官属。又如箜篌琴筝箫瑟鼓吹。应节吹呗吹笙发音。斯音相和各各悲快。佛之音响柔软清和。过于彼节百千亿倍。深奥微妙声无秽浊。闻者入耳心中欢然。积累德本。所宣章句不可穷尽。随时应宜前后相副。不失句义合于法句。各从方便不违时节。见一切人诸根增减。而为说法。布施庄严将养戒禁。常令严净。合集忍辱。精进超殊究畅圣业。观察智慧云集慈心。不厌愍哀其喜显曜。不释所护建立三乘。不断三宝别三峻聚。净三脱门。所修至诚斑宣智慧。为诸明者不见诽谤。诸贤圣所咨嗟。志玄旷如虚空。一切功勋悉为备足。告族姓子。如来言辞发教应节。巍巍如是。复过于此无可为喻。是故言曰一切所说。如来言辞慧响超殊。越诸言声。三界无逮最为慧上。靡不应命而顺从者。是为如来二十八业。佛于是颂曰

  无等伦言辞和　　以无垢超诸德
  发一响入诸声　　响周遍诸三千
  令声闻听其教　　缘觉乘亦如是
  或有闻广其志　　发其心求佛道
  其闻慈如次第　　各畅辞不错乱
  若讲说殊胜法　　又其心无退念
  犹如山之呼响　　应其音而来报
  人中上言如是　　所演说悦众心

佛复告族姓子。如来至真。皆如一切众意所念。取为慧党靡所不达。所以者何。察于如来无心意识。初无想念而有进退。以慧照曜消化众冥。其如来慧。普至一切众生心念。亦复遍入存一切意。超诸群生其识所念。诸消化法。其三昧定无所依仰。越于阴盖。离十二缘起之行。永舍三念。去于臭秽。降伏魔事。去虚伪列谀谄之秽。舍乎吾我。除去无明愚冥根株。净修道业心如虚空。而无想念不坏法界。告族姓子。如来至真。其心意业慧党若兹。是为如来二十九业。佛于是颂曰

  不当称最胜　　两足尊圣心
  积累众圣明　　导师业清净
  此安住之慧　　处在众生性
  普入靡不周　　在自然法界
  禅定意如是　　一切善备悉
  其察心意识　　一切无想念
  已过诸魔界　　超于危害业
  自然如虚空　　离垢无所在

佛复告族姓子。如来至真。知于过去慧无挂碍。其所睹见智无损秏。所及云何。其诸过去诸佛国土。合者成者。皆知其数多少进退。其土所有草木山谷诸药丛林。悉分别之。其佛国土所有众生。蚑行喘息身形种类。悉识知之。人民言语音声种类。蜎飞蠕动悉晓了之。彼土前后诸佛兴出多少之数。悉亦演之。诸佛之所斑宣经典卷数多少。有所显照亦悉畅之。化诸声闻其限若干。开诸缘觉入其律乘。悉亦识之敢可劝导。为菩萨学。使发大乘无上正真。亦悉具足。其佛国土所有好丑言教行迹。转相瞻侍亦悉恤之。其比丘众言行举动。上下相顺进退之宜。亦悉别之。有睹寿命长短久存中夭。亦复晓之。复知随法建立年岁。亦识喘息长短好丑。饮食衣服所止居业。如来悉知。过去众生。终始周旋所当往生。诸根若干其行不同志性各异。所怀心意境界殊特。其心悉畅而不中忽。心念多少好丑善恶。如来悉知。其数之限则见目睹。不以二慧而复再思。如来至真亦不遣心。追推过事而推知之。以慧心悉睹豫见。不复重念。其慧如是巍巍无量。见众生性。不中有废而为说法。是为如来三十之业。佛于是颂曰

  佛之圣明慧　　无限无挂碍
  在诸佛之土　　而斑宣经典
  劝诸众生界　　令笃信佛道
  诸佛国土中　　其所行进退
  诸人民根原　　志性所归趣
  所有药草木　　音响之好丑
  过去心名何　　诸所可造行
  平等觉悉达　　睹见如所有

佛复告族姓子。如来至真。知于当来而无损秏。慧无挂碍皆睹悉达。云何知之。于当来世所当兴成若复毁坏其合若散。如来悉知。劫起所烧。其水色何等像类。其佛国土当还复者。其地广长阔狭远近。尘埃之数。一一佛土。诸佛所兴教化群黎。诸声闻数缘觉之众诸菩萨等。饮食衣服所止居泽。出入喘息行步举动。所可游居威仪礼节。一一如来所化众生。立于声闻缘觉之乘。若学大乘。如来悉知。一一佛土诸众生类。当往生者。其心生念若干之数。诸念所灭。如来悉知。皆达此已。如来不复而重思念。心察怀抱观于当来。常睹悉见。而为众生广说经道。是为如来三十一业。佛于是颂曰

  于当来世　　世之所有　　当所合成
  若复毁散　　刹土众生　　诸佛之数
  其佛正觉　　皆成此数　　其心未曾
  而有忽忘　　其意观察　　普达当来
  而为众生　　应时说法　　是两足尊
  之所行业

佛复告族姓子。如来至真。或见现在而不损耗。其慧所睹无所挂碍。所见云何。知于现在十方世界一切国土所有多少之数。诸现在诸佛所现在一切菩萨。声闻缘觉之数多少。星宿形像进行运转。为有几所。现在一切树木药草山林溪谷。十方土地境界远近。国中尘数。悉明其限。十方诸水以执一毛。揾取水知有几渧。十方诸火境界兴焰。若复衰灭存亡所在。亦悉达之。十方诸风所由形色。所从因出往来周旋成败增益。亦悉知之。十方虚空迥远悠邈。其里亿数无边无际。佛悉知之。无有不及如毛尘者知于现在三品之行。众生之界。进退难易。根本深浅。受教迟疾。佛知现在地狱众生所犯殃舋。罪适归此其所因由。从其中出。当所生处。复知方便所用除殃。又知现在众生之种蚑行喘息蠕动之类。所因行业而堕此难。了其所便可除殃罪。当所生处。复知现在饿鬼之界。所因悭贪而堕此患。所当因由方便除罪。决所当生。知于一切现在众生心所怀念所为尘劳爱欲之病。复知离欲无尘秽者。又知现在一切众生当以何律而受开化。或复有人不从往教。缘知诸天生天上意退没所归。佛悉知之。如是本末初未曾念。二慧重思入于无二。而为众生广说经法。是为如来三十二业。佛于是颂曰

  诸最胜慧　　普靡不周　　无限无量
  不可思议　　等如虚空　　虚无无喻
  一切世间　　所不能逮　　其于十方
  一切众生　　诸所现在　　当所造行
  如来悉知　　睹其根原　　是诸佛业
  见悉究畅

    如来道品第二十二

佛复告族姓子。是为如来所行道业。如来以此所行道业。开化众生。以无言辞而演文字。难当难成。又族姓子。如来至诚。无有羁学能禁制者。其业无量不可思议。诸天龙神及世间人。无能计会称载所知。初无所言而文字现。难是难及无能抑制。遍诸佛土定意周普。现诸正觉皆已超越。无诸邪业无所想念。犹如虚空三昧平等。察诸法界而无差异。所以者何。诸佛世尊所可宣说无有若干。所因兴出无有偏党。等诸众生国土亦然。所说悉同道神不别。解脱无异。所至灭度亦无若干。又族姓子。如来至真有诸法界为一种味成最正觉。于众生界无所蔽碍。善权方便以无碍法而悉明了。则为众生转其法轮令不退转阿惟越致。譬如族姓子。上工珠师修于清净无垢宝珠。重治令曜。手执此珠宝。举着浊水令水凝然。去浊就清。不复勤而劳其功。然后则出着于食味。上于瓶瓮。若于钵器。令其中水皆使清澄。所劳功夫不足言耳。然后服着大药味中。以微细重而重洗之。所洗已净去诸刺蕀。是则名曰夜光宝珠。如来至真亦复如是。察诸众生瑕秽境界。为演无常苦。空非身悲哀辛酸苦毒之灾。众生迷惑爱乐生死。苦恼患厌尔乃令入贤圣法律。如来精进于彼无难。然后乃达空无相愿。如来以慈而开导之。所勤精进而无所著。便次得成于不退转。斑宜经道三场清净。何谓佛界。而令众生来入其境。已得越度入如来法。故曰无上众祐之要。是族姓子。以此因缘。当作此观。如来至真所入三昧不可思议。修乎平等达于三世。不断三宝。如来于彼不可思议。住于道业犹如是空。其身自然无能逮者。现形一切诸佛国土。而于诸法永无所获。不择自在随其音响而教化之。若为众生宣经典时。皆离一切心诸所缘。而悉知见众生心行志性所趣。诸菩萨众志操清净。诸佛世尊。以此等故兴出世间。是族姓子。是为如来至成之谊。由无本业。谓无所住而不违远。亦无懈息。授菩萨决不断言教。是利名曰如来道业。佛讲说此如来业时。十方无量不可计会无数佛土六反震动。其大光明。普照诸界。雨天华香。其宝清净佛师子座。诸来集会大声闻众。天龙鬼神犍沓和等。阿须伦迦留罗真陀罗摩睺勒。比丘比丘尼童士童女。咸共听闻如来宣此道业法典。欢喜踊跃不能自胜。善心生焉。各各赍持若干种华名香杂香华鬘涂香衣服幡盖及大幢幡。鼓诸伎乐琴瑟箜篌。供养如来。取头上宝而以散之。或赍麻油。或执雷音。或取其发。或脱宝璎以珠挍饰。或明月珠。或怀月珠及解脱华。或持无瑕精洁之供。或获印绶原赦之养或有宝果或以鹰鸟。或以綖缕。或寂然物不猗空物。或头宝璎。或颈着珠。或手或脚所有庄严。而供养佛悉遍散之。或复又取夜光宝珠。或复又取紫磨宝饰。以散其上。或马藏宝天帝殊绀大青宝珠火色宝珠。月光宝珠若干种色。瑰异奇宝以供养散。紫磨粟金杂碎白银。本榓杂香。儋堂杂香。栴檀杂香。黑妙杂香。丹赤真珠。似人杂香。而自退漏雨散。及诸天华。加雨意华。无极意华。月度月华。柔软音大软响华。其华曜目。大地陆地诸华。其轮离垢而有百叶。或有千叶。或百千叶。其光远照香悉周遍。其香美妙洋溢所观靡不欣乐。其光照曜执持其焰。其色无量文饰交露。青莲芙蓉诸所杂华。而自然堕。又复雨地须蔓那华。思怡无忧华瓶。梧桐舍着。徐详平顺而雨此华。箜篌乐器箫成鼓吹。鼓舞诸伎自然而鸣。又复加雨诸天华香杂香众宝璎珞宝珠衣服卧具。其诸十方来会菩萨。踊住空中。自投其身用供养佛。适各投身不惜躯命。应时空中。周遍自然覆宝高座。有宝交露。垂无央数诸珠璎珞。周遍挍饰。紫金杂厕其饰殊特。诚非世有。出若干种诸宝莲华。一切所有珍宝璎珞。一一枚珠各有无数不可称载化菩萨现咸悉共见。诸菩萨出适来出已。绕佛七匝。则复还坐于宝莲华。十方无量诸异国土。不可称计诸佛世尊。一一诸佛各各一切共嗟叹之。其供养以经典之要。以供养故致于清净。各共叹德穷劫不竟。供养法故。佛以威神遣诸弟子。诣此忍土所赍供养。入此忍界。其宝庄严超踰于此。严饰宝座殊绝难及。彼时大会无数众生见是变化。皆发无上正真道意。不可称载诸菩萨众逮得无所从生法忍。于时世尊。周匝遍察诸菩萨众。汝等正士。谁能堪任。如是比像清净庄严。菩萨所住所当建立。如来至真。意所遣使在遍止宿。将护视之无有思想。亦无音响。所敷氍[叟*毛]毾[登*毛]之具。弥勒如来成佛已后。十六年中当坐于此净宝高座。是为菩萨行愿归趣。名无盖门大会法品经典之要。亦当广布分别其谊。彼时所会一切菩萨。亦当兴发供养此法。弥勒如来及于贤劫诸菩萨众。于时会中有一菩萨。名变动诸法王。即从座起。于莲华上右膝长跪。叉手白佛。唯然世尊。我能堪任。将护于此清净挍饰。止息其边无有思想。精勤一心而不懈废。侍于弥勒至成如来。常供养之。及于贤劫诸如来众至真等正觉等。时有魔天。名曰所作所立坚强处。将四域来在彼会。谓变动诸法王菩萨。族姓子。其器云何。为何等类而用其器。受此严净令不毁散。变动诸法王菩萨。答所作魔。族姓子知。一切诸器皆归坏败。无常存者无所堪受。唯有空虚而可不毁。无所妨废。于诸器中最为高尊。仁行当宜谛察我身。目无得眴。必能睹见于无极器。时所作魔。观察变动诸法王菩萨。谛视其身而目不眴。即见变动诸法王菩萨脐中有水王光明世界。何故名曰水王光明。其佛世界悉满众水。周遍国土。若有遥视如一大海。彼有如来。名曰乐莲华首至真等正觉。于今现在。淳诸菩萨为说大乘。其水界中又有莲华。名宝庄严。其彼如来及诸菩萨而坐于上。时所作魔叉手而立。稽首归命变动诸法王菩萨。变动诸法王菩萨。谓所作魔。仁君。岂见诸菩萨器。答曰已见。其器无极。报曰是水君能任受。如是像无极天器。亿百千劫那术诸劫数之报坏。于此庄严挍饰。终不枯竭。无能消化。时所作魔。稽首礼佛。唯愿世尊。我本亿念志在杂碎。未见于此诸正士等。未得闻是经典要时。欲得成声闻缘觉而取灭度。今日又见变动诸法王菩萨威神巍巍。闻此经典感动变化。诸建立至意。当发无上正真道心。如今所作不敢违废。于最正觉愍伤众生。多所安隐多所将护。假使吾身于江河沙劫地狱见煮。然后乃成无上正真。虽遭此厄不以为患。不舍佛道。时佛咨嗟所作魔曰。善哉善哉。汝身乃为大道之故。一心被服弘誓大铠。今仁如此建立志愿。所誓必果

大哀经卷第六大哀经卷第七

        西晋月氏三藏竺法护译

    八总持品二十三

时有菩萨名师子英。在会中坐。问总[敖/力]王菩萨。唯族姓子。菩萨所立。于何总持而皆受持。诸佛所说所演经典不可穷尽。则以善教悦可众生。靡不忽然如冥睹明。总[敖/力]王菩萨。报师子英。菩萨所住此八总持。悦可众生使得开达。其慧无穷。何谓为八有总持。一名净光音。二名无尽法藏。三名无量退进。四名海印意。五名莲华严。六名入。无碍印。七名入分别辩。八名建立佛庄严。是为八。菩萨住此有所畅说。悦可众生。时师子英。复问总[敖/力]王菩萨。仁族姓子。宁可屈意垂哀一切。复重解此八总持谊广演其旨。设诸菩萨闻此总持。所得辩才必当勤学。总[敖/力]王曰。族姓子听。今为仁说八总持谊广散所归。何谓净光音。假使菩萨住此总持。其所入门无所挂碍。甚为鲜洁归乎坚要。其意正立而说经典。其音通彻闻一佛国。或二或三或四或五。或十二十三十四十五十诸佛国土。或百或千。其音教告诸佛国土。或十二十三十四十五十百千亿诸佛国土。闻其音教。或复通彻无量无际诸佛国土。从意所乐。欲令音教通乎几何诸佛国土。多少无极悉能堪任。恣意所欲一师子坐。而为十方一切众生。讲说经法。欲令二十里众人得闻。或三十里。或一须弥。或至梵天。从其众生本意应说。处师子床建立其志。为诸众生讲说经法。悦可其心靡不开解。身适处于师子座已。十方诸佛皆现其身。诸佛说法皆得闻之。适闻已后得总持力。悉识念之未曾复忘。以斯法典解达其谊。其所说法诸可听受。无能遏断。入于一文音响之事。皆能演说一切文字。普入诸响诸因缘句。入文字故入无量门。说于诸法无有来相。诸法无处无所住故。诸法自然无反覆故。诸法怀来无所到故。用清净故。诸法无根。用无有处所生无生故。诸法无边无所成故。诸法无尽无所住故。诸法无生无所行故。诸法不起无所作故。诸法不有无因缘故。诸法不乱无等御故。诸法不灭无有生故。诸法无行无所愿故。诸法无戏。无有想念应不应故。诸法无言永入无行故。诸法无教。用有所说而有失故。诸法无嗔无有恨故。诸法无想无所著故。诸法无念无有虚故。诸法无猗无所望故。诸法无诲于空等故。诸法无辞用无思故。诸法无究无师主故。诸法无生无有教故。诸法悉净无有来故。诸法无我我自然故。诸法无人甚清净故。诸法无寿无长存故。诸法无命入于谊故。诸法实空于内寂故。诸法无想。其本际者无有际故。诸法无愿无所受故。诸法无行用无为故。诸法无为。以越所起章句行故。诸法不坚无所依故。诸法无著无所习故。诸法自然用无身故。诸法无作所作净故。诸法无业无所入故。诸法无报无所合故。诸法无合无所坏故。诸法无舍无所取故。诸法无眴不可捉故。诸法无获无所指故。诸法无触无所造故。诸法无漏无流处故。诸法无有志无成故。诸法清净无[番*去]党故。诸法无属无若干故。诸法无色四大无常故。诸法无痛无所遭故。诸法无想越众念故。诸法无行离诸欲故。诸法无识无所慕故。诸法无界如空等故。诸法无舍越诸界故。诸法无境无所由故。诸法无贪无所想故。诸法无像无处所故。诸法无形无所降故。诸法无浊除诸愦故。诸法无忆无所执故。诸法无想无有二故。诸法无岸度界迹故。诸法无怙离所在故。诸法无常缘不诤故。诸法无名无所怪故。诸法无杂各随行故。诸法无住无所存故。诸法无烂无所烧故。诸法无恶离诸恶故。诸法如水洗诸垢故。诸法无灾甚清净故。诸法甚清净不可数故。诸法无计无所著故。诸法无求无有动故。诸法无摇不可震故。诸法无为与空等故。诸法虚无无所为故。诸法无根无所行故。诸法无现无所曜故。诸法无照舍诸明故。诸法无比无有邪故。诸法无偏等慌惚故。诸法无冥无所视故。诸法无晃无部党故。诸法无罪离于舋故。诸法歌颂作善业故。诸法入虚用侵欺故。诸法无进无所立故。诸法无见无有类故。诸法无有尝无有味故。诸法无柔无细滑故。诸法无识无诸法故。诸法无缘离心意识故。诸法无惟道平等故。诸法本净。以灭诸入不复生故

如是族姓子。菩萨已逮净光音。于诸因缘文字章句。咨嗟其谊。若于一劫复过一劫。颁宣经典。不舍诸缘文字章句。随时所应不以为难。取要言之。一切诸文各各诸字。以一一文为众说法。于彼文字而无穷尽。善住法眼谛演辞谊。其言粲丽。于是菩萨住于总持。究畅清净威仪随时。辩才鲜明其心显曜。遵修慈心。其所布施亦复清净。法施衣食俱无所吝。其戒清净行无缺漏。忍辱清净心不怀害。精进清净造安隐业。一心清净寂然无冥。智慧清净舍于闇昧。广有所照其业清净。无所违失。其目清净三眼无垢。其耳清净得天耳听。闻诸如来所讲说业。其鼻清净。闻于如来戒法之香。其舌清净。无可意味志道法味。其身清净。所生一切不为胎垢之所沾污。其心清净。善权随时普入诸法。其色清净相好庄严。所闻清净。悦耳之音而无乱响。其香清净。戒闻施香所见被熏。其味清净。味味复味成大人相。细滑清净。手脚柔软犹如幼童。其法清净逮法光明。其意清净。所闻经法怀忆不忘。其志清净越魔径路。行步清净。普入深妙无极经典。菩萨已住于此总持。自恣从志告诲教授。几何佛土光明所照。其数亦然。又其光明。演出一切十方诸佛所演法教。以用逮致于此总持。因得殊特无言辞故。是族姓子。净光音总持也。所可演出。若有所入所可称说。不可限量。此净音总持。分别所趣不可思议。言辞无极所决无限。所摇方面旷而无际。入无挂碍

佛言族姓子何谓无尽法藏总持。谓色无尽。以色无常故。曰无尽说色无常。以色苦故亦说苦恼。色无我故亦说无我。色寂然故亦说寂然。色恍惚故亦说恍惚。色如沫故亦说聚沫。色如幻故亦复说幻。色如野马故亦说野马。色如水月故亦说水月。色如梦故亦说梦。色如呼响故亦说呼响。色如形影故亦说形影。色如照面像故亦说面像。色无有故亦说无有。色无学故亦说无学。色无究竟故亦说无究竟。其色空故亦说于空。色无想故亦说无想。色无愿故亦说无愿。色无行故亦说无行。色无生故亦说无生。色无起故亦说无起。色本自然故亦说本自然。色用本无故亦说本无。色过去自然故。亦说过去自然。色当来自然故亦说当来自然。色中自然故亦说中自然。色憺怕故亦说澹泊。色静嘿故亦说静嘿。色无游故亦说无游。色无戏故亦说无戏。色不可思议故亦说不可思议。色无貌故亦说无貌。色无体故亦说无体。色无人故亦说无人。色无寿故亦说无寿。色无命故亦说无命。色无养故亦说无养。色愚騃故亦说愚騃。色不仁故亦说不仁。色无神故亦说无神。色如束薪故亦说束薪。色如草木墙壁瓦石之类。故亦说草木墙壁瓦石之类。色如诳相故亦说诳相。色为四大故亦说四大。色无声故亦说无声。色无教故亦说无教。色不可得故亦说不可得。色念净故亦说念净。色缘起故亦说缘起。色无断故亦说无断。色非常故亦说非常。色如屋故亦说如屋。色无痛故亦说无痛。色从罪福生故亦说罪福。色法界苦故亦说法界。色住法界故亦说住法界。色于本际法界而无动故。亦说本际。色无我故亦说无我。色无受故亦说无受。色无载故亦说无载。色无念故亦说无念。色无怯故亦说无怯。色无量故亦说无量。色无边故亦说无边。其色于道本清净故。亦说道净。色空等故亦说空等。色于泥洹本清净故。亦说泥洹清净。举要言之。五阴六衰诸法诸名身形句迹。径路偏章及诸识身。悉入一音之所显曜。说无尽慧。计是四大宝藏之箧。所咨启慧亦不可尽。其宝藏箧圣法经典。亦复游入于无尽慧。所颁宣智。是为无尽法藏之总持也。一切诸所讲说宣传。若于一劫复过一劫。咨嗟此德无尽法藏犹不可尽

佛告族姓子。何谓无量退进总持。于彼回旋断绝计常。而反其流。十二缘起从无明缘而自致行。从行致识。从识致名色。从名色致六入。从六入致更。从更致爱。从爱致痛。从痛致受。从受致有。从有致生。从生致老病死。从死致于哀泣忧戚所不可意。从致五阴大恼之患已除无明。行识名色六入更爱痛受有生老病死啼哭愁戚。不可阴意大患永除。彼从无量宣无限门入于无底。是故名曰无量退进之总持也。亦受亦舍故曰回旋。无受无舍此之谓也。亦起亦灭所以回旋。不起不灭此之谓也。与尘劳合而致诤讼。所以回旋。反本清净无著放逸。此之谓也。于一切法而有所行。受应不应念与不念。所以回反。无想无念无应不应。此之谓也。因缘诸见所以回反。断因缘见此之谓也。名之与色所以回反。无名无色此之谓也。有为无为所以回反。净于三场此之谓也。有内有外所以回反。不住于识此之谓也。罪福报应所以回反。无罪福报此之谓也。善与不善所以回反。永无所行不处善恶。此之谓也。有漏无漏所以回反。无有二事此之谓也。殃舋所蔽尘劳之冥所以回反。本净自然此之谓也。计我不我所以回反。其际清净此之谓也。生死泥洹所以回反。诸法泥洹其源静然此之谓也。是族姓子。说无量总持进退无底。若有菩萨。住是无量进退总持。志无所生达法无起。于无央数百千劫中。讲说经典不能究尽。总持之慧其谊微妙。此无量退进总持。若入中慧有所宣畅。则能觉了清净道门。照曜幽冥靡不亘然

佛告族姓子。何谓海印意总持。犹族姓子。诸四方域世界之中。诸有形色。又其像貌山谷树木。诸所生草众药之类所有形貌日月光明明珠水曜焰电。诸有像貌。州城大邦郡国县邑居舍屋宅。所有像貌。园观浴池川流泉源。入流行色生活之业。自睹形像好丑善恶。中上下貌一切诸色。及与归之。皆依大海而不别异。是谓大海。菩萨若住此海印意总持。等印一切众生之身。亦复等演文字之教。以等心印而印众生。十力诸佛。口演所宣无极大法。此典皆从菩萨口出。佛印见印。所说法者忻而无限。讲诸法印。慧无所印。所可讲说。悉如来印分别众谛。其无印者。永无所行心。自然寂。其离印者。得离欲法清净之行。其度印者。所演究竟靡所不通。其号印者。皆宣名物各各畅了。其乐印者。除去欲贪放逸恩爱。其十印者。具足十力。其被恐印者净除诸意。其烧咤印者舍于烧热。其六印者成六神通。其左披印者弃捐左道。其审印者说于真谛。其如印者所行如实。其哆印者蠲除一切诸所根本。其迦印者离所作业。其娑印者宣畅至诚。其现势力故。其生印者度生老死故。其志印者谓意清净故。其界印者不坏法界故。其寂印者具足憺怕故。其虚印者。虚静空无无不可尽故。其尽印者。消化尽想慧无起故。其立印者觉意谛住故。其知印者。别知一切众生类故。其普印者。而悉颁宣诸所兴衰。其有印者。觉了分别所有无有。其贪印者。消除贪淫嗔恚愚痴之忌难也。其己印者。己身已通而成正觉。其自印者身自解故。其旦印者。旦自释舍诸所猗相。其数印者灭遣根源。其处印者。则于处处如有悉知。其无印者无有若干。其果印者逮得果证。其阴印者除诸阴盖。其疾印者离邪疾故。其施印者。得成施戒香熏故。其坚印者。已逮断坚刚强性故。其究印者。究畅文字摅其根源。如是族姓子。菩萨说法演若干文。悉知一切文字印说。是为海印入总持门

佛告族姓子。何谓莲华严总持。菩萨大士若入众会。在所住处辄为说经。设有所宣。于时于彼即生莲华。其色殊妙。菩萨适坐于莲华。逮虚空中则雨莲华。又诸莲华各各演出若干种音。讲说经法唯说深谊。无有杂句严饰之教。攀引典喻正典上要。分别谊归。十二部经。一曰闻经。二曰得经。三曰听经。四曰分别经。五曰现经。六曰应时经。七曰生经。八曰方等经。九曰未曾有经。十曰譬喻经。十一曰住解经。十二曰行经。其所演法。若有听者辄尽众苦。菩萨如是自然精进。不释常定。于时莲华所演经典。适断众苦便行佛事。又其菩萨一切毛孔。悉出光明化为莲华。诸莲华上各化菩萨。诣于十方不可涯底无数佛土。奉现诸佛。是族姓子。名曰莲华严入总持门。佛复告族姓子。何谓入无碍总持门。假使不舍一言辞已。至二三四乃至乎千。所生之处常不忘之。或亿百千种种之说悉能识念。为众宣畅世世不忽。诸根和悦颜色殊绝。与众超异悦可众人。无有恨乱或能所说闻于。无量江河沙等诸佛刹土。或能通畅如佛国尘诸佛国土。于是所演诸法门者。随时方便。又彼法门。一时悉遍诸佛国土满中尘数诸世界也。或二三四。或五至十百千无量。所说应声亦无所著。则无所住。其音柔和合众人心。辞美随时其谊雅妙不失其节。莫不忻豫入无碍门

佛复告族姓子。何谓入分别总持。晓了其谊。所宣旨慧而不可尽。分别法者。所宣正慧亦不可想。随时分别。所说明慧亦不可穷。分别辩者。所宣正智亦无涯底。菩萨已获如此慧者。其于东方所有众生。悉能合会集在一处。各各随意言语各异音声若干。从其宜便所知多少。来难菩萨悉能发遣申畅其谊。南方西方北方。四隅上下亦复如是。来难菩萨各各问谊。一时各各尽为发遣。随音清浊若干种言。悉得开解。各随本心而得入道。各闻其言音不错乱。则以一音入无数音。以无数音则入一音。是为名曰分别庄严总持

佛告族姓子。何谓建立佛想总持。若有菩萨得此总持。处大法座在于众中。常于虚空。值其顶上变交露帐化佛处上。紫磨金色三十二相众好严身。自承其德顶近如来右手所在。化佛举手适着头上。应时菩萨。其身即变成为佛形庄严相好。建立其口言辞如佛。被蒙其意亦如佛意。适能成就建如是法。则入一切众会心念。从其本行而为宣法。一日二日至乎五日。半月一月半岁一岁五百千岁。从意自恣至乎无穷不可计岁。离于饮食。为诸众生而讲说经。所宣经典而无有穷尽。其身不懈心亦不怠。悉是如来之所建立。圣感所接。彼则成致于四大慧。何谓四。一曰慧解一切众生志操。二曰分别章句靡不通畅。三曰则以圣智所宣无穷。四曰则从其人本。而所学乘。了其意归而解说法。是族姓子。如来相建立总持。所入门者。有所宣说。又此总持可演谊。不可称载。无有边际。通佛境界。尔时总[敖/力]王菩萨。睹于如来说如斯谊。以赞颂曰

  安住已宣说　　于八总持行
  此乘所宣获　　分别得解畅
  说亿载经典　　辞不得边际
  其谊所分别　　说者无所损
  佛音甚柔和　　其声微妙快
  宣告江河沙　　无量千佛土
  众生得听闻　　逮成得灭度
  此总持清净　　所畅音无际
  讲说无数劫　　其法无穷尽
  一句之言辞　　宣布不可说
  一切诸文藻　　智者得随时
  是为法箧藏　　觉意无涯底
  皆弃诸非受　　其行甚清净
  亦不着中间　　不随退转界
  斯勇普惟法　　专精而奉行
  其逮得总持　　蠲除众根源
  其于四域界　　诸所有形类
  一切悉等印　　江海无思惟
  其有逮得此　　海印之总持
  彼行者印门　　所说无思议
  若在中众会　　大人讲说法
  逮于虚空中　　广雨诸莲华
  又诸莲华者　　演亿千法教
  莲华严总持　　清净德若兹
  一音所演句　　二三及五六
  诸音各各闻　　声而不错乱
  千亿百那术　　言辞不可尽
  有逮得总持　　所觉无挂碍
  其所宣辩才　　法谊说应时
  十方众生来　　各各共难问
  悉为发遣之　　决了所疑律
  其逮得总持　　意所觉如此
  其大人正士　　若坐于高床
  诸佛以右手　　而摩着顶上
  其人得辩才　　如佛无有异
  用逮此佛化　　妙上总持故
  假使此菩萨　　逮成总持者
  彼意所怀德　　无际不可念
  讲说亿千劫　　犹如江河沙
  咨嗟其功德　　境界不可尽
  如莲华自然　　踊处于三世
  坚住如须弥　　所部无能动
  假使有逮得　　无上之总持
  其慧则普流　　周遍于三世
  若在众会中　　勇猛如师子
  调御诸外学　　降伏令成就
  假使有逮得　　此上之总持
  在所游行处　　悉弃诸恐惧
  其光踰大明　　所照而随时
  其行若如水　　洗除众垢秽
  其行亦如火　　无相无有念
  其行亦如风　　不着诸境界
  其行亦如医　　疗治诸疾厄
  随时给法药　　汤火而救济
  其有逮得者　　极上妙总持
  彼慧无嗔恨　　随根而解说
  其行如月明　　能除夜众冥
  心等光明正　　而演大晖曜
  其有逮得此　　总持最无觉
  众生来观瞻　　视之无厌极
  其行喻日光　　照曜于闇冥
  开三界众生　　使得其悟解
  若逮得于此　　最上之总持
  枯竭于众庶　　爱欲尘劳源
  其行亦如王　　典领其国土
  如息意王教　　以法施所闻
  其有逮得此　　最上之总持
  一切无所受　　不着于诸有
  其行犹如龙　　意强有神变
  兴云雨众生　　亦复出电焰
  其有逮得此　　最上之总持
  此放诸法雨　　消灭众恼热
  其行如天帝　　不为诸容色
  而见所迷惑　　心广而思法
  其有逮得此　　最上之总持
  诸来众会者　　悉瞻戴其颜
  其慈之所行　　等游如梵天
  一切无等伦　　来生于此世
  其有逮得此　　最上之总持
  彼生于梵天　　所在常清净
  则成大五通　　常与众超异
  游百千佛土　　难计无思议
  其有逮得此　　最上之总持
  彼供养十方　　无央数诸佛
  诸佛所咨嗟　　随所止方面
  悉共愍哀之　　念之如一子
  其有逮得此　　最上之总持
  计如是不久　　当逮佛功勋
  其辩甚广远　　所演无穷尽
  说种种微妙　　无数诸经典
  其有逮得此　　最上之总持
  严行如华鬘　　辩才如流泉
  在众意坚强　　所觉而通畅
  其慧无涯底　　所行如虚空
  其有逮得此　　最上之总持
  彼则无憍慢　　离谀谄自大
  其智慧善权　　所游而自恣
  能精进奉行　　当修慈愍哀
  其有逮得此　　最上之总持
  一切皆蠲除　　有为之瑕秽
  知众生言辞　　所说之善恶
  了众人所好　　一切诸根行
  其有逮得此　　最上之总持
  本所可宣畅　　其谊不可尽
  精勤神定意　　诸根及五力
  觉意路如是　　其寂然最上
  其有逮得此　　最上之总持
  彼则观诸法　　所获甚清净
  于诸度无极　　已逮至彼岸
  意强而明达　　慧了诸四思
  其逮得于此　　最上之总持
  其人自然解　　安住诸所行
  寂然成澹泊　　仁和无放逸
  威仪礼节行　　分别住安谛
  其有逮得此　　最上之总持
  其人未曾有　　不与诸尘劳
  以成如法幻　　志性离瑕秽
  所在胎生处　　不能垢所染
  其有逮得此　　最上之总持
  则住于莲华　　立在诸佛前
  其人身口意　　威神无缺漏
  普兴一切慧　　周流归众生
  其有逮得此　　最上之总持
  诸佛所建化　　说法而自立
  已成大智慧　　为众生行道
  于无数劫中　　叹德不可穷
  其有逮得此　　最上之总持
  若有欲叹誉　　无能得源际

于是世尊。赞总[敖/力]王菩萨。善哉善哉。仁快说此咨嗟总持之所入行。所以然者。此法自然无所依怙。不仰他人。入已曾往过去诸佛。更问深妙总持门故。以是之故。汝族姓子。当作斯观。等无有异

大哀经卷第七大哀经卷第八

        西晋月氏三藏竺法护译

    往古品第二十四

佛告族姓子。乃往过去久远世时。劫数无量不可计会。悬旷极远不可思议。尔时有佛。号离垢光如来至真等正觉明行成为善逝世间解无上士道法御天人师。号佛世尊。世界曰善离垢。劫名照明。其界清净。地绀琉璃净如明镜。地平如掌。其界之土琉璃之土。生七宝树。枝叶华实皆亦宝成。又自然生众宝莲华。大如车轮其色若干。见者心欢。其形微妙香洁甚美。宝为交露屋宅精舍。诸天人民被服饮食。犹如第六自在天上。人民鲜洁行步安详。其淫怒痴鲜而薄少。举动言教。其佛世界无有日月。其佛离垢光明。身出大晖遍诸佛土。晨夜常明昧爽不别。莲华合者则知为冥。莲华开者则知为明。其离垢光如来至真。诸菩萨众有八百亿。出家菩萨居士菩萨。无能限量不可称载。建立无上正真之道。其佛土地不闻异学无有异乘。唯修大乘。行悉淳淑立不退转。世尊云何。为彼说法。唯演空慧空无相教。佛寿半劫。众人居宅若干种宝。佛即行步皆随时节。诸天亦然。其于地上立交露帐舍宅居中。名之为人。其处虚空而立屋宅栅阁。名之为天。起止饮食等无差别。又其佛界无复国君。唯离垢光世尊。则为无上大法之王。诸天人民无各各异。皆来事师无各异名。所作不别无有异念。唯奉如来咨受经典。思惟其谊。彼无女人。无罪处名。无犯尘欲。其土众生唯学三度。一曰禁戒。二曰守心。三曰学智。何谓为戒。习诸通慧心念不舍。弃捐诸行。何谓守心。住于定意逮得神通。何谓为智。住智度无极得分别辩。如是族姓子。有学如此。名曰学度。是诸菩萨不受禁戒。其土清净巍巍如是。世尊说法严妙殊绝。卓然无喻。时彼佛土诸菩萨中。有一菩萨名曰光首。即从坐起。偏出右肩右膝着地。叉手白佛。唯然世尊。所言总持为何谓也。菩萨何住。诸佛所说皆能执持。为众生演令心欢悦。佛告光首。又族姓子。有总持名为宝曜菩萨住此。悉受诸佛之所讲说。悦众生心。光首又问。唯愿如来。宣宝曜总持。其中谊理我等闻之。奉之如教逮此总持。离垢光佛。寻为光首菩萨。叹此颂曰

  欲逮得宝曜　　永除诸尘秽
  于垢而无垢　　舍诸一切染
  心常净离着　　是宝曜总持
  逮得此持者　　其明无不照
  其身口清净　　光明性离垢
  等意行慈心　　是宝曜总持
  已脱三十二　　解诸一切想
  则离众悕望　　是宝曜总持
  所游入怀勇　　大德如虚空
  解明如虚静　　是宝曜总持
  不断乎三宝　　绝三垢三世
  穷尽众苦源　　是宝曜总持
  害贪淫恚痴　　除尘诸秽浊
  宝树受欲意　　宝曜总持尊
  诸所有音响　　世间上中下
  入于一切声　　宝曜持离垢
  精勤深奥法　　无数妙句谊
  不着吾我人　　总持离此二
  逮得分别辩　　坚住于四道
  四禅震于梵　　是宝曜总持
  第一法藏义　　启受四等行
  尊修五神通　　宝曜总持尊
  谛住四意止　　常顺四意断
  奉于四神足　　是宝曜总持
  已受持五根　　而立于五力
  无能七觉意　　是宝曜总持
  奉于八由路　　化寂然所观
  至于明解脱　　是宝曜总持
  游戏所住地　　近顺解脱道
  断除一切恼　　是宝曜总持
  照明一切世　　寂光之道场
  眼清净广照　　是宝曜总持
  天眼净如此　　智慧眼曜冥
  眼净为法目　　是佛眼清净
  是尘净于魔　　此五阴消害
  亦净于死魔　　归命力降魔
  住于此总持　　至亿那术土
  见垓数诸佛　　得闻上经典
  以听广妙法　　意力怀总持
  分别其义趣　　为天世人宣
  心明发意知　　解了所报应
  其法入于慧　　住总持逮此
  辩才无挂碍　　三达三眼净
  逮得三脱諠　　精进逮总持
  无数诸总持　　无限说无量
  逮此总持胜　　便获一切所
  其禅及脱门　　正受极三昧
  神通自娱乐　　当入此总持
  若海诸水王　　万川流河归
  是胜总持然　　诸法门无量
  入于无尽意　　悉解无穷慧
  其福无涯底　　行总持逮此
  色像众相好　　种姓慧清净
  珠宝离垢掌　　逮总持如此
  入乎深要藏　　怀无从生忍
  在不退转地　　说是总持者
  无数诸菩萨　　求于无上道
  已逮此总持　　成佛不为难
  十方诸最胜　　说法愍众生
  逮此总持者　　辩才无断绝
  悦亿垓众生　　知根意所信
  口未有所说　　逮此总持者
  则转于法轮　　度百千众生
  立之于尊乘　　勇住此总持
  无数那术劫　　嗟叹其功勋
  逮此总持者　　不能尽究畅

如是族姓子。离垢光如来至真。说此总持竟。诸大众中三万二千菩萨逮此总持。光首菩萨亦复逮得此宝曜持。于族姓子所忆云何。尔时光首菩萨。岂异人乎。勿作斯观。所以者何。则尔身是。以是之故。总[敖/力]王。于今堪任度诸秽恶。亦复于此咨问如来。章句通利。无犹豫心决其疑网。由是之故。今世勇猛具启前问。不难如来是决总持。宣照世间令意亘然。仁者修法目观达故。会此复重获此总持。意怀勇猛。心自颁宣

    大哀经智本慧业品第二十五

于是智积菩萨。时在彼会。前白佛言。菩萨云何逮宝曜时。已能获致不复忽忘益于众生。以总持力而自立业。佛告智积。族姓子。其有菩萨。住于智本而为智慧业。尔乃逮得宝曜总持。不复忽忘益于众生。智积菩萨复白佛言。善哉世尊唯为解说。何谓智本。何谓慧业。佛言且听。善思念之。当为汝说。智积菩萨受教而听。佛告族姓子。谛听义旨思存心怀。是为智本。如所闻法则以具足为他人说。是为慧业。观察分别是为智本。启发众会令得开解。是为慧业。随顺观察知其根源。是为智本。随时开化建立众生。是为慧业。修平等行而无偏党。是为智本。奉平正行不为邪疑。是为慧业。心无所生都无所著。是为智本。虽心不生能宣经典。是为慧业。闲处静思其心寂寞。是为智本。身心宴然而无愦乱。是为慧业。心常乐一万事不起。是为智本。识一乘道而不违舍。是为慧业。专修憺怕而普观察。是为智本。得明解脱蠲除众冥。是为慧业。遵乎专一三脱之门。是为智本。证明三达去来今事。是为慧业。笃信道议而无疑惑。是为智本。度于一切诸所挂碍。是为慧业。其心不怯志怀勇慧。是为智本。身心休息离于汲汲。是为慧业。其意安详而不卒暴。是为智本。思惟悬旷而悉识念。是为慧业。如有所毁寻即觉制。是为智本。心常正定而得其所。是为慧业。遵修意止申畅意法。是为智本。意无所存亦无所念。是为慧业。奉四意断令舍根源。是为智本。则已净本蠲除众瑕晓了诸法。是为慧业。修学神足忽然轻举。是为智本。已无所行而远神足。是为慧业。习化五根根源常寂。是为智本。分别诸根之所归趣。是为慧业。住于五力势不可动。是为智本。降魔尘劳令欲不起。是为慧业。晓了七觉逮柔顺忍。是为智本。分别诸业一切自然。是为慧业。合集由路勇畅无滞。是为智本。若以识别浮筏譬喻。其非法者立之于法。是为慧业。明识苦习而修道业。是为智本。明证尽谛智本无尽。是为慧业。讽诵经典识其句谊。是为智本。已通经典而能奉行。是为慧业。一切所闻皆能执持。是为智本。道御众义不违其理。是为慧业。于受音响而无所著。是为智本。顺其经典而识正旨。是为慧业。观诸万物一切无常。是为智本。而悉晓了于无所行一切诸法。是为慧业。观诸万物一切皆苦。是为智本。一切诸法计本空无。是为慧业。察一切法而无吾我。是为智本。观诸众生本悉清净。是为慧业。闻真谛法不怀恐怖。是为智本。分别诸法之所归趣。是为慧业。观察寂然泥洹憺怕。是为智本。一切诸法本净寂灭。是为慧业。闻于经谊不怀犹豫畏惧之难。是为智本。晓了义理知其正归。是为慧业。听如审法不疑深洽。是为智本。分法辩才剖判其本。是为慧业。于一切音听不恐惧。是为智本。随时宣畅各令得所。是为慧业。闻佛辩才不怀弱怯。是为智本。识其辩才而遍颁宣。是为慧业。为众生故慈奉法行。是为智本。不舍慈愍以慈加众。是为慧业。自为己身亦为他人而兴愍哀。是为智本。俱于二事而无所著发无盖哀。是为慧业。爱喜道法而怀悦豫。是为智本。不举不下无所违失。是为慧业。离于结缚危害之事而以观察。是为智本。晓了己身举动进止。是为慧业。常念于佛心无他思。是为智本。明识法身而无所猗。是为慧业。常念经典识其义理。是为智本。而能分别离于欲法。是为慧业。常念圣众供养诸道。是为智本。逮于无为观察无尘。是为慧业。常念惠施济诸穷厄。是为智本。舍一切尘而顺道意。是为慧业。常念戒禁而自谨慎。是为智本。而已习行于无所识行别禁戒。是为慧业。常念于天使意开解。是为智本。其法清净离于秽尘。是为慧业。若有所闻覆疏其议。是为智本。与诸世俗无所覆挍。是为慧业。所作事业安谛无失。是为智本。而悉晓了无作无报。是为慧业。不怀贡高而不自大。是为智本。得无极慧而成大智。是为慧业。所行为已自省其身。是为智本。为已亦及二事俱兴。是为慧业。若能执持八万四千诸法经藏。是为智本。分别八万四千诸行。是为慧业。晓了随时而宣经典。是为智本。如应讲经无所违失。是为慧业。开化众生建立于道。是为智本。智度无极善权方便。教诲众生立不退转。是为慧业。未曾畏惧五趣所生。是为智本。所生之处多所将护。是为慧业。精勤自修逮音响忍。是为智本。常以修行无所怀生。是为慧业。自将其节得柔顺忍。是为智本。若以逮得不起法忍。是为慧业。发意勤修不退转地。是为智本。超然进前阿惟颜地是为慧业。其已行成坐佛树下。是为智本。所当晓了断除疑碍解是平等。皆以一时发心之顷。随时顺谊。成于无上正真之道。为最正觉。是为慧业。佛欲重解宣畅此谊。尔时颂曰

  若听受其法　　启问无放逸
  斯清净众人　　咨奉于智本
  闻之则能演　　慈心布诸民
  其菩萨殊胜　　为造慧之业
  善意而思惟　　是为明智本
  分别说所行　　是为慧之业
  行如所顺念　　是则为智本
  此行为人说　　是为慧之业
  逮心无所生　　此则智之本
  心行无所趣　　是为慧之业
  净修正真行　　是则为智本
  宣转造所行　　是为慧之业
  专一寂道行　　是则为智本
  身心不计我　　是为慧之业
  畏难生死习　　是则为智本
  爱乐一乘道　　是为慧之业
  好乐寂然观　　是则为智本
  思惟明脱事　　是为慧之业
  精勤三脱门　　是则为智本
  明证三达智　　是为慧之业
  精修四意止　　是则为智本
  念无意无我　　是为慧之业
  弃恶修善行　　是则为智本
  本净除此法　　是为慧之业
  勤致四神足　　是则为智本
  不贪习神足　　是为慧之业
  笃信净解脱　　是则为智本
  度一切挂碍　　是为慧之业
  精进不猗息　　是则为智本
  身意已休息　　是为慧之业
  其志了安详　　是则为智本
  不住一切处　　是为慧之业
  自觉识定意　　是则为智本
  行本净正受　　是为慧之业
  善建立五根　　是则为智本
  知众生诸根　　是为慧之业
  奉行于五力　　是则为智本
  殷勤得圣慧　　是为慧之业
  觉意柔顺忍　　是则为智本
  解了一切法　　是为慧之业
  勤修道精进　　是则为智本
  弃捐法非法　　是为慧之业
  方便苦自然　　是则为智本
  于证不灭尽　　是为慧之业
  修持随谊典　　是则为智本
  导御从谊理　　是为慧之业
  不厌惓诸闻　　是则为智本
  履顺其要行　　是为慧之业
  如应求其议　　是则为智本
  奉行于圣达　　是为慧之业
  不猗于寿命　　是则为智本
  所念如法教　　是为慧之业
  求观物无常　　是则为智本
  于是知无生　　是为慧之业
  信脱万物苦　　是则为智本
  诸法悉无为　　是为慧之业
  解诸法无我　　是则为智本
  其性以清净　　是为慧之业
  信脱泥洹寂　　是则为智本
  众生永灭度　　是为慧之业
  观察其谊理　　是则为智本
  觉谊而分别　　是为慧之业
  若笃信经典　　是则为智本
  畅达于经法　　是为慧之业
  不畏一切音　　是则为智本
  晓了诸归趣　　是为慧之业
  不离佛辩才　　是则为智本
  晓了自恣说　　是为慧之业
  建立众生慈　　是则为智本
  得无缘之愍　　是为慧之业
  哀己及他人　　是则为智本
  不想着我人　　是为慧之业
  常得欢喜悦　　是则为智本
  不悦无所起　　是为慧之业
  不造为恩爱　　是则为智本
  心不得二脱　　是为慧之业
  其意常念佛　　是则为智本
  若随法身教　　是为慧之业
  常思惟经典　　是则为智本
  明识法报应　　是为慧之业
  念圣众功勋　　是则为智本
  若觉了无为　　是为慧之业
  若心好布施　　是则为智本
  设舍一切尘　　是为慧之业
  思戒具清净　　是则为智本
  住无漏之禁　　是为慧之业
  念于大神天　　是则为智本
  若念净复净　　是为慧之业
  所闻而覆疏　　是则为智本
  不与世同尘　　是为慧之业
  善修谨敕业　　是则为智本
  于作无所作　　是为慧之业
  谦逊不自大　　是则为智本
  不计吾有慧　　是为慧之业
  己身常精勤　　是则为智本
  为众生造行　　是为慧之业
  若持诸法藏　　是则为智本
  晓了众生行　　是为慧之业
  度一切诸恶　　是则为智本
  归三处众生　　是为慧之业
  惠施为仁爱　　等立益众生
  开化使离秽　　是为慧之业
  皆以等利之　　视如佛功德
  正士则如是　　是为慧之业
  畏所有然炽　　是则为智本
  思惟生于彼　　是为慧之业
  不嗔得尽慧　　是则为智本
  兴无所生慧　　是为慧之业
  若得音响忍　　是则为智本
  其行如所念　　是为慧之业
  致柔顺法忍　　是则为智本
  无所从生忍　　是为慧之业
  住不退转地　　是则为智本
  得阿惟颜地　　是为慧之业
  坐于佛树下　　是则为智本
  已逮诸通慧　　是为慧之业
  计其智之本　　是曰为道心
  依怙于此心　　所作为慧业
  常谛住道心　　则能不动转
  是业为慧事　　所行常随时
  若修行佛道　　是心道之本
  佛神力如此　　亦分别辩才
  若于无数劫　　咨嗟此功勋
  佛德及光明　　不可得边际
  其过去诸佛　　现在亦如是
  若当来安住　　十方不可计
  其有欲供养　　此无量最胜
  当顺随道心　　则成无放逸

佛说于此智本慧业时。十方无量诸佛国土六反震动。宝严高座亦复如是。于是智积菩萨前白佛言。唯然世尊今者何故十方世界不可计会无数佛土六反震动。其虚空中所立高座亦复如是。佛言。族姓子。是智本慧业经典要品。过去如来之所叹说。往古世时。智积菩萨在于虚空。多所持护。启问如来。佛为解答。是故地大震动光明普照

    大哀经智积菩萨品第二十六

尔时有菩萨。名逮分别辩。前白佛言。智积菩萨何故号曰为智积耶。佛告族姓子。乃往过去久远世时。有佛号名首寂如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。世界曰精勤。劫名阿摩勒。其佛世界安隐快乐众生无患。首寂如来诸菩萨众四万二千。诸声闻众八万四千。皆悉恭恪谦卑顺教。其佛辩才以方等经。为诸菩萨兴百亿难。歌颂悉周告诸菩萨。汝等正士。谁能堪任受百亿难。一一解说而发遣之。彼诸菩萨又报佛言。过今夜已当发遣之。或言七夜。或言半月。或言一月。思惟然后乃能发遣。各各自思。白世尊义。时彼众会有一菩萨。名曰觉意。前白佛言。唯愿大圣。我不起坐不整威仪。无所思察。于如来前令尊证明。悉当发遣所可难谊。时此正士适师子吼。三千大千世界六反震动。其大光明普照世间。以此威光。告地上神四天王天。忉利天。炎天兜率天。无憍乐天。化自在天。上至魔界天。梵天梵身天。梵满天。梵度着天。大梵天。光曜天。鲜光天。无量光天。光音天。严净天。鲜净天。无量净天。难及天。善见天。善胜天。离果天。一善天。空慧天。识慧天。不用空慧天。有想无想天。悉来集会。诸比丘比丘尼童士童女不可称计。亦皆来会。及诸十方诸所千界。悉来住立于高座前。时觉意菩萨见诸大众悉来集会。承己福力意强霸力及总持力分别辩力无所畏力。奉佛威力在于佛前诸众会中取百亿难。一一诸难兴百亿义。而发遣之。不转其时。不移其坐。亦不起立。不动膝脚。所说流滑义不差错。闻者亘然若冥睹明。因时会中六万人众。皆发无上正真道意。八万四千菩萨。逮得无所从生法忍。首寂如来则赞之曰。善哉善哉。其音应时遍告三千大千世界。其地上神上至净身诸天之众。皆闻其声悉共咨嗟。今此菩萨乃能发遣百亿众难。当号名之为智积也。族姓子。智以是之故。故曰智积欲。知尔时觉意菩萨。岂异人乎。莫作斯观。所以者何。则是智积菩萨也

    大哀经叹品第二十七

于是总[敖/力]王菩萨前白佛言。未曾有也。世尊。诸佛世雄。乃能善决于是淳淑无上正真之道。畅其文字不可限量。入无限谊难受难持。解了深妙十二缘起。不能勤学。亦为甚难。其二行者无能及者。是六情难灭。坐有所著权不能解。非是下度声闻缘觉地所能逮者。是菩萨行印一切法。覆挍法界则以平等。犹如虚空。无有作想悉无所著。越所悕望别众生行。晓了一切报应之缘。而复颁宣智度无极。广修善权奉静寂句。逮得神通。以等行故。入佛一门无有差特。不为若干。等定如空。党无等伦。等无所等。诸佛平等离于二事。修行灭寂去诸文字。导御于义令分别解。畅其音响于义无获。所得等习奉行三宝。讲三脱门度于三界。晓了三达兴发自在。譬喻定意。则能建立诸佛之法。怀来佛慧饶益一切。诸佛所叹。唯然世尊。若族姓子及族姓女。有能信此去来今佛。如是比像所讲道谊无量之慧。以信乐至发无上正真道意。将护正法。闻如此比经典之要。持讽诵读具为人说。得福无底。则于如来为有反复孝顺报恩。佛言。如是如是。族姓子。如尔所云若族姓子族姓女。佛目睹见十方诸佛所现国土满中七宝。持用奉施如来至真等正觉。若复有人持是经典。勤讽诵读具足讲说。为众宣传。殷勤精进启受正典。怀之而行。而不违断三宝之教。如是行者。德超乎彼不可称限。于时世尊说此谊已。叹此颂曰

  吾以佛眼　　睹诸国土　　诸如来等
  如积紫金　　供养如来　　福尚鲜少
  若闻此典　　功德乃广　　其有应器
  得听斯经　　深奥玄妙　　第一至真
  已具即受　　持讽诵读　　计此功祚
  为最上尊　　最胜若此　　常住于法
  从法养生　　不从衣食　　是故当奉
  安住之法　　则为孝顺　　报诸佛恩

尔时世尊告众一切诸会菩萨。谁能堪任受是过去当来现在诸佛世尊无上正真道法之护。吾灭度后于五浊世时俗愦扰能传此经使广流布。令其正法住在久存。应时彼会六万亿垓诸菩萨众。同时举声而叹颂曰

  吾等世尊　　佥共堪任　　将护如来
  无数亿劫　　百千那术　　所集无上
  正真道教　　于后来世　　当广宣布
  又复大圣　　唯加威恩　　建立神德
  令此经典　　于后末世　　使广流布
  令众生类　　咸共奉命　　宣令人民
  得殖德本　　已积德者　　耳得逮闻

于时世尊即叹颂曰

  正觉言至诚　　住于真谛法
  以此建诚言　　顺立于斯经
  彼于无尽哀　　而住无极慈
  演愍伤众生　　故建立斯经
  成就功德品　　越诸圣慧党
  普入诸所行　　故建立斯经
  降伏一切魔　　消化诸异学
  坏一切邪见　　故建立斯经
  四王天帝释　　梵王演布施
  天龙犍沓和　　故建立斯经
  地神虚空天　　杂碎诸小天
  见佛名所建　　当奉持此诏
  修于四梵行　　四谛自庄严
  将护于所部　　故建立斯经
  虚空无色像　　令无色有色
  佛之所建立　　无能动移者

于时四天王异口同音。则于佛前以颂赞曰

  吾等顺此典　　佛威所将护
  子孙及眷属　　还逮而侍卫
  若有受持者　　精勤于道教
  我等当奉事　　四面营翼之

于时天帝释。则于佛前叹此颂曰

  吾等报佛恩　　当护导师法
  是神妙经者　　行者得成佛
  我等为诸佛　　孝顺报护经
  将养如是典　　以此奉持法

于时梵三钵天王。则于佛前叹此颂曰

  其不习放逸　　越度一切乘
  悉从是经生　　深奥谊殊绝
  当舍梵天安　　设此经所在
  故当往听受　　亦当随营护

于时兜率天王。则于佛前叹此颂曰

  其一生补处　　从兜率天下
  便当奉持此　　佛所说经典
  世尊我堪任　　弃捐天安乐
  游住阎浮提　　听说此经典

于时魔子导师。则于佛前叹此颂曰

  以毕魔罪业　　不复从害教
  其受持此经　　识谊而奉行
  我当拥护此　　如来之经典
  令兴其精进　　普使具足获

于时魔波旬。于世尊前叹此颂曰

  吾于众生类　　不复为败乱
  其有受持此　　摄坏众欲尘
  诸魔不得便　　说此经典者
  诸佛所建立　　吾当将护之

于是须深天子。于世尊前叹此颂曰

  诸佛之正道　　此经悉演说
  若有持斯经　　则奉一切佛
  我当执此典　　为亿数天赞
  劝助发道意　　闻者则遵行

于是弥勒菩萨。于世尊前叹此颂曰

  若有志有道　　其慈不须属
  拥护一切法　　自出意布施
  吾诣兜率天　　佛之所建立
  如是正像经　　当令普流布

于是耆年大迦叶。于世尊前叹此颂曰

  吾等慧薄少　　声闻之所说
  当任其势力　　执持世尊法
  若有受持此　　当往侍卫之
  堪以宣辩才　　赞之为善哉

于时舍利弗。于世尊前叹此颂曰

  法犹如虚空　　世护之所说
  吾当将养之　　奉敬斯正典
  若所在方面　　奉持如是经
  住在于后世　　将念一切族

于时耆年大目犍连。于世尊前叹此颂曰

  世尊今现在　　清净诸众生
  以持此经典　　察谊观奉行
  于百千劫中　　终不归恶趣
  已授于佛决　　得为法王子

于是贤者阿难。于世尊前叹此颂曰

  我面于佛前　　闻无数千经
  从本未曾更　　闻如是比经
  今已遇此典　　亲从圣咨受
  当令普流布　　为求佛道者

尔时世尊咨嗟释梵护世四天及诸天子菩萨声闻。善哉善哉。仁等正士。汝等乃能拥护正法。又如是比演师子吼。今我重嘱于正士等。殷勤委累。其有众人。志于大乘未得法忍。若遇如此建立经典。受讽诵读。常与如来而面相见。如是不久当得其决成于无上正真之道。若声闻学受佛此经。当于弥勒如来至真第一会数。若缘觉乘以此经典持讽诵读。吾灭度后虽无所闻成缘觉道。佛说于此总[敖/力]王菩萨所问经典义时。无央数人皆发无上正真道意。不可计会诸菩萨众立不退转地。不可称载诸菩萨等。逮得无所从生法忍。无限世界六反震动。其大光明普遍十方。天雨众华其于十方来会菩萨。启供养佛奉敬正典。普及一切宝严高座。化作宝华。而俱举声宣畅功德。吾等善利获无极庆。身自亲近得至于此。逮闻如是决疑经典。当令世尊释迦文尼延命久寿长存于世。使此经典在阎浮提永普流布。其比丘比丘尼童士童女。受持如此比像经者。是等亦令当蒙拥护。亦使长寿。常以弘恩加益众生悉缘得度

    大哀经嘱累品第二十八

于是总[敖/力]王菩萨前白佛言。至未曾有。世尊。善分别说此经典义。所演微妙其辞粲丽。菩萨元首所当行者。降制一切诸魔异学。方便随时导御诸典。而复悦可得众生心。出生一切诸乘之行。悉入如来无极功勋。亲具诸愿显现大道。是经典者。所名为何。云何奉行。佛告总[敖/力]王菩萨。是经号如来大哀。佛所宣教当奉持之。闻如来善莂未曾虚妄。当奉持之。佛说如是。总[敖/力]王菩萨十方世界来会开士。诸大弟子释梵四王。天龙鬼神犍沓和阿须伦迦留罗真陀罗摩睺勒比丘比丘尼童士童女。一切众会诸天世人。闻佛所说莫不欢喜

大哀经卷第八


大乘大集地藏十轮经

    No. 411 [No. 410]

大乘大集地藏十轮经

    大乘大集地藏十轮经序品第一

        三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。在佉罗帝耶山诸牟尼仙所依住处。与大苾刍众俱。谓过数量大声闻僧。复有菩萨摩诃萨众。谓过数量大菩萨僧。说月藏已。尔时南方大香云来雨大香雨。大花云来雨大花雨。大妙殊丽宝饰云来。雨大殊丽妙宝饰雨。大妙鲜洁衣服云来。雨大鲜洁妙衣服雨。是诸云雨充遍其山诸牟尼仙所依住处。从诸香花宝饰衣服。演出种种百千微妙大法音声。谓归敬三宝声。受持学处声。忍辱柔和声。精进勇猛声。降伏四魔声。趣入智慧声。广大名称遍满三界声。劝修殊胜念定总持声。空无相无愿声。厌离贪欲声。色如聚沫声。受如浮泡声。想如阳焰声。行如芭蕉声。识如幻事声。无常声苦声无我声空声。惭愧声。远离声。护念声。慈悲喜舍声。证得诸法声。生天涅槃声。趣向三乘声。转大法轮声。雨大法雨声。成熟有情声。度三恶趣声。修治圆满六到彼岸声。善巧方便声。趣入十地声。游戏神通声。游戏清净无上大乘声。不退转地声。无生法忍声。灌顶受位声。趣入一切诸佛大海声

尔时一切诸来大众咸见如是种种云雨。亦闻如是诸法音声。随意所乐各见其身种种香花宝饰衣服之所庄严。又各自见两手掌中持如意珠。从是一一如意珠中雨种种宝。复从一一如意珠中放诸光明。因光明故。一一有情皆见十方殑伽沙等诸佛世界。又因光明见诸佛土。一一世尊无量众会恭敬围绕。复因光明见诸佛土一切有情若有病者。因此光明之所照触众病除愈。诸应被杀及囚系者。光明照故皆得解脱。诸身语意粗重秽浊。因光皆得轻软清净。诸饥渴者亦皆饱满。诸被种种刑罚逼切。光明照故皆离忧苦。诸少衣服宝饰珍财。光明照故随念皆足。若诸有情乐欲杀生。乃至或有乐欲邪见。由此光明之所照触。皆悉乐欲远离杀生。乃至乐欲远离邪见。若诸有情为于种种求不得苦之所逼切。光明照故随愿皆得。又因光明见诸佛土一切有情所受众苦无不休息。皆悉欢娱受诸妙乐。又见如是诸佛土中。由此光明之所照触。远离一切昏云尘雾。烈风暴雨不善音声。及诸臭秽苦辛恶味恶触恐怖远离一切邪业邪语邪意邪归。不寒不热安静坦然地平如掌。诸妙乐具充满其中

尔时众会其身欻然。地界增强坚重难举。既睹斯瑞咸悉惊疑。何因何缘而现此相。于众会中有天帝释名无垢生。去薄伽梵不远而坐。即从座起顶礼世尊。合掌向佛以颂问曰

  具谛语谛见　　谛善住牟尼
  普为众弘宣　　谛究竟坚法
  令诸有情类　　灭苦及苦因
  何缘于此中　　现诸云雨等
  令举众欢悦　　咸生净信心
  皆发趣大乘　　度疑生实见
  天人大众身　　地界增坚重
  不能自胜举　　此相有何缘
  两手皆珠现　　雨众宝放光
  照十方除罪　　息苦获安乐
  导师复何因　　令举众皆见
  种种香鬘等　　各各自严身
  天人普犹豫　　不测何因缘
  有谁将欲来　　现此神通力
  为是佛菩萨　　为梵魔释天
  唯愿大导师　　速为众宣说

尔时世尊。告无垢生天帝释曰。汝等当知。有菩萨摩诃萨名曰地藏。已于无量无数大劫。五浊恶时无佛世界成熟有情。今与八十百千那庾多频跋罗菩萨俱为欲来此礼敬亲近供养我故。观大集会生随喜故。并诸眷属作声闻像将来至此。以神通力现是变化。是地藏菩萨摩诃萨。有无量无数不可思议殊胜功德之所庄严。一切世间声闻独觉所不能测。此大菩萨。是诸微妙功德伏藏。是诸解脱珍宝出处。是诸菩萨明净眼目。是趣涅槃商人导首。如如意珠雨众财宝。随所希求皆令满足。譬诸商人所采宝渚。是能生长善根良田。是能盛贮解脱乐器。是出妙宝功德贤瓶。照行善者犹如朗日。照失道者犹如明炬。除烦恼热如月清凉。如无足者所得车乘。如远涉者所备资粮。如迷方者所逢示导。如狂乱者所服妙药。如疾病者所遇良医。如羸老者所凭几杖。如疲倦者所止床座。度四流者为作桥梁。趣彼岸者为作船筏。是三善根殊胜果报。是三善本所引等流。常行惠施如轮恒转。持戒坚固如妙高山。精进难坏如金刚宝。安忍不动犹如大地。静虑深密犹如秘藏。等至严丽如妙花鬘。智慧深广犹如大海。无所染著譬太虚空。妙果近因如众花叶。伏诸外道如师子王。降诸天魔如大龙象。斩烦恼贼犹如神剑。厌诸諠杂如独觉乘。洗烦恼垢如清净水。能除臭秽如疾飘风。断众结缚如利刀剑。护诸怖畏如亲如友。防诸怨敌如堑如城。救诸危难犹如父母。藏诸怯劣犹若丛林。如夏远行所投大树。与热渴者作清冷水。与饥乏者作诸甘果。为露形者作诸衣服。为热乏者作大密云。为贫匮者作如意宝。为恐惧者作所归依。为诸稼穑作甘泽雨。为诸浊水作月爱珠。令诸有情善根不坏。现妙境界令众欣悦。劝发有情增上惭愧。求福慧者令具庄严。能除烦恼如吐下药。能摄乱心如等持境。辩才无滞如水激轮。摄事系心如观妙色。安忍坚住如妙高山。总持深广犹如大海。神足无碍譬若虚空。灭除一切惑障习气。犹如烈日销释轻冰。常游静虑无色正道一切智智妙宝洲渚。能无功用转大法轮。善男子。是地藏菩萨摩诃萨。具如是等无量无数不可思议殊胜功德。与诸眷属欲来至此。先现如是神通之相。世尊说是地藏菩萨诸功德已。尔时地藏菩萨摩诃萨。与八十百千那庾多频跋罗菩萨。以神通力现声闻像。从南方来至佛前住。与诸眷属恭敬顶礼世尊双足。右绕三匝在如来前。合掌而立以颂赞曰

  两足尊导师　　慈心常普覆
  安忍如大地　　遍除嗔忿心
  具殊胜相好　　庄严诸佛国
  能以谛慈悲　　充满一切土
  永绝诸爱网　　如实善安住
  舍诸清净国　　度染浊众生
  本愿摄秽土　　成熟恶众生
  起坚固正勤　　久修诸苦行
  久修诸苦行　　闻生悚惧心
  修诸施戒忍　　及精进定慧
  曾供事无量　　佛菩萨声闻
  及济诸有情　　饥渴病死者
  本为他有情　　自舍多身命
  本为正法故　　舍多骨血皮
  弃舍自安乐　　悲愍诸有情
  专为诸有情　　勤修断惑网
  善护于六根　　恒远离诸欲
  观有为无常　　苦空无我性
  诸苦业增长　　皆贪爱为因
  故先于六根　　永断诸贪欲
  普于有情界　　常安住大悲
  虽得胜菩提　　而不舍本愿
  随见诸有情　　逼切在众苦
  随起勤精进　　勇猛而济拔
  令勤修施戒　　忍进定般若
  如母于一子　　慈心而养育
  本于有情类　　常住普慈心
  故速证菩提　　度脱无量众
  本修菩提行　　无不为众生
  故今于有情　　不舍于六度
  昔常于末世　　求无上菩提
  今还末世中　　速成无上觉
  调伏诸恶见　　天龙人药叉
  安住能断惑　　如金刚圣道
  授无量有情　　得胜菩提记
  成应供导首　　最上良福田
  世尊无等侣　　普覆诸群生
  无量大名闻　　充满十方界
  是故诸菩萨　　为成就己事
  咸共来归依　　大牟尼足下
  闻所说妙法　　皆生欢喜心
  起增上正勤　　修习菩提行
  由导师法力　　皆速证菩提
  故今者导师　　大集未曾有
  十三兆药叉　　恒啖诸血肉
  皆舍诸恶业　　速趣大菩提
  有得胜总持　　安忍及静虑
  有永尽诸漏　　应供世间尊
  有修四无量　　有住四摄法
  有得四辩才　　有安住顺忍
  有得健行定　　有得妙慧眼
  有住无生忍　　皆由导师力
  世尊大威德　　摧灭众魔怨
  降伏诸外道　　九十五异类
  尽地狱傍生　　饿鬼非天趣
  故贞实有情　　咸归尊足下
  今者息刀兵　　疫病饥馑劫
  度迷失正道　　盲冥诸有情
  诸烦恼狂乱　　皆安寂灭道
  故我舍诸缘　　来礼敬尊足
  无边诸佛土　　现在诸导师
  咸广赞世尊　　闻者皆来此
  我闻遍知海　　真实德无边
  度脱诸有情　　心欢喜敬礼
  曾修无量福　　今得礼尊足
  愿无量劫中　　常修多供养
  我今学世尊　　发如是誓愿
  当于此秽土　　得无上菩提

尔时地藏菩萨摩诃萨。以妙伽他礼赞佛已。与诸眷属复持无量天妙香花种种宝饰而散佛上。变成宝盖住虚空中。为听法故即于佛前俨然而坐。尔时一切诸来大众。既见地藏菩萨摩诃萨已。皆获希奇得未曾有。各持种种上妙香花宝饰衣服幢幡盖等。奉散地藏菩萨摩诃萨而为供养。皆作是言。我等今者快得善利。因佛神力亲得瞻仰礼敬供养如是大士。尔时众中。有菩萨摩诃萨名好疑问。从座而起整理衣服。偏袒一肩礼佛双足。右膝著地合掌向佛。而白佛言。世尊。此善男子从何而来。所居佛国去此远近。成就何等功德善根。而蒙世尊种种称叹。复能赞佛不可思议功德法海。我等昔来未曾闻见。唯愿为说。世尊告曰。止善男子。如是大士功德善根。一切世间天人大众皆不能测其量浅深。若闻如来为汝广说如是大士功德善根。一切世间天人大众。皆生迷闷或不信受。时好疑问复重请言。唯愿如来哀愍为说。佛言。谛听善思念之。吾当为汝略说少分。如是大士。成就无量不可思议殊胜功德。已能安住首楞伽摩胜三摩地。善能悟入如来境界。已得最胜无生法忍。于诸佛法已得自在。已能堪忍一切智位。已能超度一切智海。已能安住师子奋迅幢三摩地。善能登上一切智山。已能摧伏外道邪论。为欲成熟一切有情所在佛国悉皆止住。如是大士。随所止住诸佛国土随所安住诸三摩地。发起无量殊胜功德。成就无量所化有情。如是大士。随住如是诸佛国土。若入能发智定。由此定力令彼佛土一切有情皆悉同见诸三摩地所行境界。随住如是诸佛国土。若入具足无边智定。由此定力令彼佛土一切有情随其所应能以无量上妙供具。恭敬供养诸佛世尊。随住如是诸佛国土。若入具足清净智定。由此定力令彼佛土一切有情。皆悉同见诸欲境界无量过患心得清净。随住如是诸佛国土若入具足惭愧智定。由此定力令彼佛土一切有情皆得具足增上惭愧。离诸恶法心无忘失。随住如是诸佛国土。若入具足诸乘明定。由此定力令彼佛土一切有情皆得善巧天眼智通宿住智通死生智通了达此世他世因果。随住如是诸佛国土。若入无忧神通明定。由此定力令彼佛土一切有情皆离一切愁忧昏昧。随住如是诸佛国土。若入具足胜通明定。由此定力令彼佛土一切有情皆得具足神通善巧。随住如是诸佛国土。若入普照诸世间定。由此定力令十方界离诸昏暗。令彼佛土一切有情普见十方诸佛国土。随住如是诸佛国土。若入诸佛灯炬明定。由此定力令彼佛土一切有情舍邪归依归正三宝。随住如是诸佛国土。若入金刚光定。由此定力令彼佛土所有一切小轮围山大轮围山苏迷卢山及诸余山溪涧壑瓦砾毒刺诸秽草木皆悉不现。令彼佛土所有一切众邪蛊毒诸恶虫兽灾横疫疠昏暗尘垢不净臭秽悉皆销灭。令彼佛土地平如掌。种种嘉祥自然踊现。清净殊胜众相庄严。随住如是诸佛国土。若入智力难摧伏定。由此定力令彼佛土一切魔王及诸眷属。皆悉惊怖归依三宝。随住如是诸佛国土。若入电光明定。由此定力令彼佛土一切有情皆悉远离后世恐怖得法安慰。随住如是诸佛国土。若入具足上妙味定。由此定力令彼佛土一切有情随念皆得饮食充足。随住如是诸佛国土。若入具足胜精气定。由此定力令彼佛土一切有情无不皆得增上力势离诸病苦。随住如是诸佛国土。若入上妙诸资具定。由此定力令彼佛土一切有情随乐皆得床座敷具衣服宝饰诸资身具无所乏少殊妙端严甚可爱乐。随住如是诸佛国土。若入无诤智定。由此定力令彼佛土一切有情身心勇健远离一切怨憎系缚和顺欢娱爱乐具足施戒安忍勇猛精进心无散乱成就智慧。随住如是诸佛国土。若入能引胜踊跃定。由此定力令彼佛土一切有情皆受无量胜妙欢喜。随住如是诸佛国土。若入具足世路光定。由此定力令彼佛土一切有情得无碍智能修种种清净事业。随住如是诸佛国土。若入善住胜金刚定。由此定力令彼佛土一切有情皆得诸根具足无缺常乐远离其心寂静。随住如是诸佛国土。若入增上观胜幢定。由此定力令彼佛土一切有情皆深呵厌自恶业过咸善护持十善业道生天要路。随住如是诸佛国土。若入具足慈悲声定。由此定力令彼佛土一切有情皆悉发起慈心悲心无怨害心普平等心更相利益安乐之心。随住如是诸佛国土。若入引集诸福德定。由此定力令彼佛土一切有情离诸斗诤疾疫饥馑非时风雨苦涩辛酸诸恶色触悉皆销灭。如是大士。随住如是诸佛国土。若入海电光定。由此定力令彼佛土一切大地众宝合成。一切过患皆悉远离种种宝树衣树器树诸璎珞树花树果树诸音乐树。无量乐具周遍庄严。以要言之。此善男子。于一一日每晨朝时。为欲成熟诸有情故。入殑伽河沙等诸定。从定起已遍于十方诸佛国土。成熟一切所化有情。随其所应利益安乐。此善男子。已于无量无数大劫。五浊恶时无佛世界成熟有情。复于当来过于是数。或有世界刀兵劫起害诸有情。此善男子见是事已。于晨朝时以诸定力除刀兵劫。令诸有情互相慈愍。或有世界疫病劫起害诸有情。此善男子见是事已。于晨朝时以诸定力除疫病劫。令诸有情皆得安乐。或有世界饥馑劫起害诸有情。此善男子见是事已。于晨朝时以诸定力除饥馑劫。令诸有情皆得饱满。此善男子。以诸定力作如是等无量无边不可思议利益安乐诸有情事。此善男子。具足成就无量无数不可思议殊胜功德。常勤精进利益安乐一切有情。曾于过去无量无数殑伽沙等佛世尊所。为欲成熟利益安乐诸有情故。发起大悲坚固难坏勇猛精进无尽誓愿。由此大悲坚固难坏勇猛精进无尽誓愿增上势力。于一日夜或一食顷。能度无量百千俱胝那庾多数诸有情类。皆令解脱种种忧苦。及令一切如法所求意愿满足。随所在处若诸有情种种希求忧苦逼切。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得如法所求离诸忧苦。随其所应安置生天涅槃之道。随所在处若诸有情饥渴所逼。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得如法所求饮食充足。随其所应安置生天涅槃之道。随所在处若诸有情乏少种种衣服宝饰医药床敷及诸资具。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得如法所求衣服宝饰医药床敷及诸资具无不备足。随其所应安置生天涅槃之道。随所在处若诸有情爱乐别离怨憎合会。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得爱乐合会怨憎别离。随其所应安置生天涅槃之道。随所在处若诸有情身心忧苦众病所恼。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得身心安乐众病除愈。随其所应安置生天涅槃之道。随所在处若诸有情互相乖违兴诸斗诤。有能至心称名念诵归敬供养地藏菩萨摩诃萨者一切皆得舍毒害心。共相和穆欢喜忍受展转悔愧慈心相向。随其所应安置生天涅槃之道。随所在处若诸有情闭在牢狱杻械枷锁检系其身具受众苦。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得解脱牢狱杻械枷锁自在欢喜。随其所应安置生天涅槃之道。随所在处若诸有情应被囚执鞭挞拷楚临当被害。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得免离囚执鞭挞加害。随其所应安置生天涅槃之道。随所在处若诸有情身心疲倦气力羸惙。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得身心畅适气力强盛。随其所应安置生天涅槃之道。随所在处若诸有情诸根不具随有损坏。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得诸根具足无有损坏。随其所应安置生天涅槃之道。随所在处若诸有情颠狂心乱鬼魅所著。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得心无狂乱离诸扰恼。随其所应安置生天涅槃之道。随所在处若诸有情贪欲嗔恚愚痴忿恨悭嫉憍慢恶见睡眠放逸疑等皆悉炽盛恼乱身心常不安乐。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得离贪欲等身心安乐。随其所应安置生天涅槃之道。随所在处若诸有情为火所焚为水所溺为风所飘。或于山岩崖岸树舍颠坠堕落。其心。慞惶。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得离诸危难安隐无损。随其所应安置生天涅槃之道。随所在处若诸有情为诸毒蛇毒虫所螫。或被种种毒药所中。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得离诸恼害。随其所应安置生天涅槃之道。随所在处若诸有情恶鬼所持成诸疟病。或日日发或隔日发。或三四日而一发者。或令狂乱身心战掉。迷闷失念无所了知。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得解脱无畏身心安适。随其所应安置生天涅槃之道。随所在处若诸有情为诸药叉罗刹饿鬼毕舍遮鬼布怛那鬼鸠畔荼鬼羯吒布怛那鬼吸精气鬼及诸虎狼师子恶兽蛊毒厌祷诸恶咒术怨贼军阵及余种种诸怖畏事之所缠绕。身心慞惶惧失身命恶死贪生厌苦求乐。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切皆得离诸怖畏保全身命。随其所应安置生天涅槃之道。随所在处若诸有情或为多闻或为净信或为净戒或为静虑或为神通或为般若或为解脱或为妙色或为妙声或为妙香或为妙味或为妙触或为利养或为名闻或为功德或为工巧或为花果或为树林或为床座或为敷具或为道路或为财谷或为医药或为舍宅或为仆使或为彩色或为甘雨或为求水或为稼穑或为扇拂或为凉风或为求火或为车乘或为男女或为方便或为修福或为温暖或为清凉或为忆念或为种种世出世间诸利乐事。于追求时为诸忧苦之所逼切。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。此善男子。功德妙定威神力故。令彼一切皆离忧苦意愿满足。随其所应安置生天涅槃之道。随所在处若诸有情以诸种子殖于荒田或熟田中。若勤营务或不营务。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。此善男子。功德妙定威神力故。令彼一切果实丰稔。所以者何。此善男子。曾过无量无数大劫。于过数量佛世尊所。发大精进坚固誓愿。由此愿力为欲成熟诸有情故。常普任持一切大地常普任持一切种子。常普令彼一切有情随意受用。此善男子威神力故。能令大地一切草木根须芽茎枝叶花果皆悉生长药谷苗稼花果茂实成熟润泽香洁软美。随所在处若诸有情贪嗔痴等皆猛利故造作杀生或不与取或欲邪行或虚诳语或粗恶语或离间语或杂秽语或贪或嗔或复邪见十恶业道。有能至心称名念诵归敬供养地藏菩萨摩诃萨者。一切烦恼悉皆销灭远离十恶成就十善于诸众生起慈悲心及利益心。此善男子。成就如是功德妙定威神之力勇猛精进。于一食顷能于无量无数佛土一一土中以一食顷皆能度脱无量无数殑伽沙等所化有情。令离众苦皆得安乐。随其所应安置生天涅槃之道。此善男子。成就如是如我所说不可思议诸功德法。坚固誓愿勇猛精进。为欲成熟诸有情故。于十方界。或时现作大梵王身。为诸有情如应说法。或复现作大自在天身。或作欲界他化自在天身。或作乐变化天身。或作睹史多天身。或作夜摩天身。或作帝释天身。或作四大王天身。或作佛身。或作菩萨身。或作独觉身。或作声闻身。或作转轮王身。或作刹帝利身。或作婆罗门身。或作茷舍身。或作戌达罗身。或作丈夫身。或作妇女身。或作童男身。或作童女身。或作健达缚身。或作阿素洛身。或作紧捺洛身。或作莫呼洛伽身。或作龙身。或作药叉身。或作罗刹身。或作鸠畔荼身。或作毕舍遮身。或作饿鬼身。或作布怛那身。或作羯吒布怛那身。或作粤阇诃洛鬼身。或作师子身。或作香象身。或作马身。或作牛身。或作种种禽兽之身。或作剡魔王身。或作地狱卒身。或作地狱诸有情身。现作如是等无量无数异类之身。为诸有情如应说法。随其所应安置三乘不退转位。善男子。如是大士。成就如是不可思议诸功德法。是诸殊胜功德伏藏。是诸解脱珍宝出处。是诸菩萨明净眼目。是趣涅槃商人导首。如是乃至能无功用转大法轮。如前广说。善男子。假使有人于其弥勒及妙吉祥并观自在普贤之类而为上首殑伽沙等诸大菩萨摩诃萨所。于百劫中至心归依称名念诵礼拜供养求诸所愿。不如有人于一食顷至心归依称名念诵礼拜供养地藏菩萨求诸所愿速得满足。所以者何。地藏菩萨利益安乐一切有情。令诸有情所愿满足。如如意宝亦如伏藏。如是大士。为欲成熟诸有情故。久修坚固大愿大悲勇猛精进过诸菩萨。是故汝等应当供养。尔时十方诸来大众。一切菩萨摩诃萨及诸声闻天人药叉健达缚等皆从座起。随力所作各持种种金银等屑众宝花香。奉散地藏菩萨摩诃萨。复持种种上妙衣服末尼宝珠真珠花鬘真珠璎珞金银宝缕幢幡盖等。奉上地藏菩萨摩诃萨。复以无量上妙音乐种种赞颂恭敬供养地藏菩萨。尔时地藏菩萨摩诃萨。持此种种上妙供具回奉世尊而说颂曰

  天人龙神所供养　　十方菩萨皆来奉
  闻救世有大功德　　唯愿受我最胜供

尔时地藏菩萨摩诃萨。说是颂已顶礼佛足。于是世尊复说颂曰

  起坚固慧清净心　　灭诸有情无量苦
  施众妙乐如宝手　　能断惑网如金刚
  起大悲慧具精进　　善持妙供奉世尊
  以海智救苦众生　　登诸趣有无畏岸

尔时地藏菩萨摩诃萨。即从座起而白佛言。大德世尊。我当济度此四洲渚。世尊弟子一切苾刍及苾刍尼邬波索迦邬波斯迦。令其皆得增长忆念。增长守护忆念。增长寿命。增长身体。增长无病。增长色力。增长名闻。增长资具。增长亲友。增长弟子。增长净戒。增长多闻。增长慧舍。增长妙定。增长安忍。增长方便。增长觉分圣谛光明。增长趣入大乘正道。增长法明。增长成熟有情。增长大慈大悲。增长一切白法。增长妙称遍满三界。增长法雨普润三界。增长一切大地精气滋味。增长一切众生精气善作事业。增长正法精气善行。增长智慧光明。增长六到彼岸妙行。增长五眼。增长灌顶。增长生天涅槃。所谓有名具足水火吉祥光明大记明咒总持章句。我于过去殑伽沙等佛世尊所。亲承受持此陀罗尼。能令增长一切白法。增长一切种子根须芽茎枝叶花果药谷精气滋味。增长雨泽。增长有益地水火风。增长喜乐。增长财宝。增长胜力。增长一切受用资具。此陀罗尼能令一切智慧猛利破烦恼贼。即说咒曰

谶蒱(一)谶蒱(二)谶谶蒱(三)阿迦舍谶蒱(四)缚羯洛谶蒱(五)庵跋洛谶蒱(六)筏罗谶蒱(七)伐折洛谶蒱(八)阿路迦谶蒱(九)萏摩谶蒱(十)萨帝(丁[其*皮]反)摩谶蒱(十一)萨帝(丁[其*皮]反)昵(泥吉反)诃罗谶蒱(十二)毗婆(缚迦反)路迦插婆谶蒱(十三)邬波睒摩谶蒱(十四)奈野娜谶蒱(十五)钵刺惹三牟底(都异反)刺拏谶蒱(十六)刹拏谶蒱(十七)毗湿婆(缚迦反)梨夜谶蒱(十八)舍萨多腊婆(缚迦反)谶蒱(十九)毗阿(去声)荼素(上声)吒(二十知戒反)莫醯隶(二十一)萏谜(二十二)睒谜(二十三)斫羯洛细(二十四)斫羯洛沫呬隶(二十五)厕(初凡反)隶(二十六)諀(匹里反)隶(二十七)揭刺婆跋罗伐刺帝(二十八)[尸*欠](上声醯以反)[口*(隸-木+士)](二十九)钵腊薛(三十)钵刺遮啰饭怛泥(三十一去声)曷刺怛泥(三十二去声)播啰(三十三)遮遮遮遮(三十四)[尸*欠](上声)隶(三十五)弭隶(三十六)黳羯他(三十七)托契(三十八)托龋卢(三十九)闼[口*(隸-木+士)](四十)闼[口*(隸-木+士)](四十一)弭隶(四十二)磨绽(四十三徒界反)瘅绽(四十四徒界反)矩隶(四十五)弭隶隶(四十六)盎矩之多毗(四十七)遏[口*梨](四十八)祁(上声)[口*梨](四十九)波啰祁(上声)[口*梨](五十)矩吒苫沫隶(五十一)敦只(五十二葵计反)敦只(五十三葵计反)敦具隶(五十四)浒卢(五十五)浒卢(五十六)浒卢(五十七)矩卢窣都弭隶(五十八)弭[口*李]第(五十九)弥[口*李]绽(六十徒界反)叛荼陀(六十一)喝(诃葛反)罗(六十二)[尸*欠](上声)梨(六十三)浒卢(六十四)浒鲁卢(六十五)

  善说能净诸有尘　　善说能净斗诤劫
  善说能净浊恶意　　善说能净浊大种
  善说能净浊恶味　　善说能净浊恶气
  善说能满诸希望　　善说能成诸稼穑
  善说能令一切佛　　如来世尊所加护
  善说又能令一切　　菩萨加护而随喜

世尊如是。具足水火吉祥光明大记明咒总持章句。我于过去殑伽沙等佛世尊所。亲承受持此陀罗尼。能令增长一切白法广说乃至增长一切受用资具。大德世尊。此陀罗尼。普能济度此四洲渚世尊弟子一切苾刍及苾刍尼邬波索迦邬波斯迦。令其皆得增长忆念广说乃至增长一切受用资具。此陀罗尼能令世尊甘露圣教炽然久住。利益安乐三界众生。尔时地藏菩萨摩诃萨。演说如是大记明咒总持章句。时佉罗帝耶山普皆震动。俱胝天乐不鼓自鸣。雨无量种天妙香花及珍宝等。一切众会咸悉惊跃。皆获希奇得未曾有。时众会中有大吉祥天女具大吉祥天女大池妙音天女大坚固天女具大水天女放大光天女而为上首。总有一万八千天女。于四大种皆得自在。从座而起稽首佛足。合掌恭敬而白佛言。希有大德。甚奇世尊。我等虽于诸四大种得自在转。而不能知是四大种初中后相生灭违顺。如此大士。已得微细甚深般若波罗蜜多。能善了知是四大种初中后相生灭违顺。佛言。如是如是。天女。此善男子。已得微细甚深般若波罗蜜多。能善了知是四大种初中后相生灭违顺。天女当知。如如意珠具足众德。能雨种种上妙珍宝施诸众生。此善男子亦复如是。能雨种种觉支珍宝施诸众生。如宝洲渚种种珍宝充满其中。此善男子亦复如是。成就种种觉支珍宝。如天波利质多罗树众妙香花之所严饰。此善男子亦复如是种种微妙佛法珍宝而自庄严。如师子王一切畜兽无能惊伏。此善男子亦复如是。一切众生无能惊伏。譬如朗日能灭世间一切昏暗。此善男子亦复如是。能灭一切众生恶见无明昏暗。譬如明月于夜分中能示一切失道众生平坦正路。随其欲往皆令得至。此善男子亦复如是。于无明夜能示一切迷三乘道驰骋生死旷野众生三乘正路随其所应方便安立令得出离。譬如大地一切种子树山稼穑地身众生之所依止。此善男子亦复如是。一切殊妙菩提分法之所依止。譬如大宝妙高山王善住坚固无缺无隙此善男子亦复如是。善住一切不共佛法。由不弃舍诸众生故。名为无缺。一切善根皆善施与诸众生故。名为无隙。譬如虚空一切众生皆所受用。此善男子亦复如是。一切众生皆所受用。此善男子。成如是等无量无边诸功德法。时诸大众闻说地藏菩萨摩诃萨成就无量称赞功德。皆获希奇得未曾有。尊重恭敬皆大欢喜。至心谛观地藏菩萨目不暂舍。尔时世尊重显此义。而说颂曰

  地藏真大士　　具杜多功德
  现声闻色相　　来稽首大师
  施诸众生乐　　救脱三有苦
  雨无量种雨　　为供养大师
  天帝无垢生　　观察四方已
  合掌恭敬住　　赞请于大师
  我见世尊众　　末尼宝光明
  遍照诸佛国　　无不皆明了
  六通照世间　　今当来至此
  勇猛名地藏　　现出家威仪
  七圣财伏藏　　无畏佛音声
  诸菩萨胜幢　　众生之导首
  解脱宝所依　　福海具精进
  悲意乐聪敏　　救苦诸有情
  与怖者为城　　如明月示道
  生善根如地　　破惑如金刚
  能施解脱宝　　如水漂众惑
  烦恼热为盖　　愈疾如良医
  一日称地藏　　功德大名闻
  胜俱胝劫中　　称余智者德
  能解诸众生　　一切烦恼缚
  至健行定等　　诸定之彼岸
  十二缘清净　　诸智如虚空
  破无边佛土　　诸有情暗聚
  随诸土入定　　四静虑等流
  普令诸有情　　入定除惑热
  众生宿恶业　　刀兵病饥馑
  随所在恼害　　皆能令解脱
  众生五趣身　　诸苦所逼切
  归敬地藏者　　有苦悉皆除
  众生乘苦轮　　展转相违害
  归敬地藏者　　皆住忍慈心
  十二缘所怖　　追求苦所依
  归敬地藏者　　皆安住无畏
  若乐修诸福　　正念戒闻慧
  归敬地藏者　　所求皆满足
  乐一一功德　　工巧药种子
  归敬地藏者　　所求皆满足
  求诸谷药田　　男女衣仆使
  归敬地藏者　　所求皆满足
  众德具相应　　能任持大地
  因兹诸谷药　　润泽而细软
  诸烦恼所覆　　乐行十恶业
  归敬地藏者　　烦恼恶皆除
  现作种种身　　为众生说法
  具足施功德　　悲愍诸众生
  假使百劫中　　赞说其功德
  犹尚不能尽　　故皆当供养

大乘大集地藏十轮经卷第一

(永徽二年正月廿三日于长安大慈恩寺翻经院法师玄奘奉　诏译)

(大慈恩寺沙门大乘光笔受　法海寺沙门神昉笔受)

(大总持寺沙门道观笔受　蒲洲普救寺沙门行友证文)

(普光寺沙门道智证文　汴洲真谛寺沙门玄忠证文)

(弘福寺沙门明浚正字　大总持寺沙门玄应正字)

(弘福寺沙门文备证义　蒲洲栖岩寺沙门神泰证义)

(廓洲法讲寺沙门道深证义　宝昌寺沙门法祥证义)

(罗汉寺沙门慧贵证义　实际寺沙门道明证义)

(大总持寺沙门道洪证义　大慈恩寺沙门玄奘奉诏译)
大乘大集地藏十轮经卷第二

        三藏法师玄奘奉　诏译

    十轮品第二

尔时地藏菩萨摩诃萨。从座而起整理衣服。顶礼佛足偏袒一肩。右膝著地合掌恭敬。而白佛言

  我今问世尊　　无量功德海
  唯愿赐开许　　为解释除疑

世尊告曰。汝真善士。于一切法智见无碍。为欲饶益他有情故请问如来。随汝意问。吾当为汝分别解说令汝心喜。于是地藏菩萨摩诃萨。以颂问曰

  我曾十三劫　　已勤修苦行
  为一切有情　　除三灾五浊
  多俱胝佛所　　已设无边供
  曾见大集会　　清信众和合
  聪哲勤精进　　皆来同会集
  未曾见如是　　无诸杂秽众
  云何此佛国　　秽恶损净善
  智者皆远离　　恶行者同居
  多造无间罪　　诽谤于正法
  毁圣起恶见　　妄说断常论
  具造十恶业　　不畏后世苦
  多远离三乘　　臭秽向恶趣
  无明蔽其目　　贪嫉多奸矫
  云何转佛轮　　度此众生类
  云何破相续　　如金刚烦恼
  云何得总持　　果能如是忍
  今我见导师　　大集甚希有
  未曾见余处　　具如是众德
  具杜多功德　　勤修菩提道
  云何处愚众　　能开示佛轮

世尊告曰。善哉善哉善男子。汝于过去殑伽沙等诸佛世界五浊恶时。已曾请问殑伽沙等诸佛世尊如是法义。汝于如是所问法义已作劬劳已善通达已到圆满众行彼岸。已得善巧方便妙智。今为成熟一切有情令得利益安乐事故。为令一切菩萨摩诃萨善巧方便圣行伏藏施等六种波罗蜜多成熟一切有情胜行一切智智功德大海速圆满故。为转一切刹帝利王诸暴恶行使不堕落三恶趣故。为令此土三宝种姓威德炽盛久住世故。复问如来如是法义。谛听谛听善思念之。吾当为汝分别解说。唯然世尊愿乐欲闻。尔时佛告地藏菩萨摩诃萨言。善男子。如来由本愿力成就十种佛轮。居此佛土五浊恶世。一切有情退没一切白净善法。匮乏所有七圣财宝。远离一切聪敏智者。断常罗网之所覆蔽。常好乘驭诸恶趣车。于后世苦不见怖畏。常处遍重无明黑闇。具足十种不善业道。造五无间。诽谤正法。毁呰贤圣。离诸善法具诸恶法。我住如是杂恶土中得安隐住。得无惊恐得无所畏。自称我处大仙尊位转于佛轮。降诸天魔外道邪论。摧灭一切诸众生类犹如金刚坚固烦恼。随其所乐安置一切有力众生令住三乘不退转位

善男子。譬如有国时虚君位。其中所有一切人民。自军他军更相侵害。忧愁扰乱人众不安。有无量种斗讼违诤互相欺凌。谄言妄语粗恶乖离诬誷矫乱。种种疾病盲翳昏闇寒热疟疾温气疫疠癫痫干枯饮食不消。其心狂乱诸根不具支体缺减。乏少种种衣食资具。一切所有皆不可乐。诸有情类归依种种外道邪神。恶见恶心及恶意乐皆悉炽盛。迷失正道临堕恶趣。时彼国中有诸耆旧聪明多智博学平恕威严整肃。相与谋议运诸筹策。即便召集国邑人民。共所荐推取一王子。先具多种布施调伏寂静尸罗精进勇猛。难行苦行一切备满。具诸殊胜福德之相。诸根圆满支体无缺。身形长大相好端严。成就最胜美妙容色。常为一切尊重恭敬。率土人民无不亲爱。禀性淳质常怀慈悲。博学多才备诸伎艺。柔和忍辱庄严其心。是大后妃所生嫡子。以诸妙香熏清净水调和冷暖沐浴其身。著于种种上妙香熏众宝庄严鲜净衣服。末尼珠宝置在髻中。金宝华鬘冠饰其首。素练轻缯束于发际。又以种种末尼真珠金银等宝共所合成珥珰璎珞环玔印等众妙宝饰庄严其身。织成宝履下承其足众宝伞盖上覆其顶。安置古昔一切天仙所护持座。趣入一切天帝同许共所护持善巧营构殊妙大殿。登自先王所升尊座。绍王位已。扣击一切天帝龙帝药叉神帝阿素洛帝鸠畔荼帝各所护持广大钟鼓。其声振响周遍国界。刹帝利等四大种姓无量人众。沐浴其身著净衣服。执持种种妙宝缯彩伞盖幢幡末尼真珠金银螺贝璧玉珊瑚茷琉璃等生色可染无量珍奇。奉献新王以呈嘉瑞。贵族净行博学多才诸婆罗门。以无量种微妙赞颂歌咏帝德。种种善事咒愿于王。以诸吉祥散洒王顶。先王所重宿望贵族。博学多艺性直贤明。随其所应授以种种职位官僚理诸王事。先于国境自军他军更相侵害。今皆令息。亦令一切怨敌恶友能为害者皆悉殄灭。损除自国一切黑品增益自国一切白品。善男子。刹帝利种灌顶大王。成就如是第一王轮。由此轮故于自国土得安乐住。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是杂染五浊恶世索诃佛土空无佛时。其中所有一切众生。为自心中随眠缠垢。自军他军恼害侵逼。愁忧扰乱愚冥不安。起无量种执著断常。斗讼违诤互相轻蔑。起贪嗔痴谄诳言等。具足十种不善业道。执著有情纷扰世界。成就种种烦恼疾病。阙正法眼忿恨烧恼。常不思惟真实正法。弃正法味讥毁善行。乏少所受喜乐滋味。常为种种烦恼罗网之所覆蔽。归依六种外道邪师。迷失圣道向三恶趣。于此土中有诸菩萨摩诃萨。已于过去亲近供养无量诸佛。已入诸佛功德大海。已住诸佛本所行道。皆共集会来至我所。同谓我言。汝于过去已修无量布施调伏寂静尸罗精进勇猛。难行苦行一切备满。是诸微妙福慧方便大慈悲等共所庄严大功德藏。是一切定总持安忍诸地功德圆满大海。无谄无诳。身形长大相好圆满。忍辱柔和端正殊妙。不复依他修菩提道。一切智海已得圆满。成就最胜美妙容色。能为一切声闻独觉作大导师。亦能安慰一切生死怖畏众生与作亲友。大慈悲等无量功德共所庄严。是羯洛迦孙驮．羯诺迦牟尼．迦叶波如来等父之真子。于此贤劫当得作佛。一切菩萨摩诃萨中最为上首。以诸功德种种妙香熏奢摩他．毗钵舍那清净之水而自沐浴。著惭愧衣。清净法界为髻中珠。冠饰诸佛所行境界广大华鬘。束以解脱殊妙素练。又以种种一切智智无生忍等功德珍宝而自庄严。慈悲喜舍以为宝履能覆三界。三种妙行圆满圣因以为伞盖。安置古昔诸佛天仙共所护持金刚定座。趣入一切声闻独觉恭敬护持四种念住。坐先诸佛所敷之座。证得无上正等菩提一切智位。为令一切三宝种姓不断绝故。转于法轮击法钟鼓。妙法音声遍满三界。令诸天．龙．药叉．罗刹．阿素洛．揭路荼．紧捺洛．莫呼洛伽．鸠畔荼．弥荔多．毕舍遮．布怛那．羯吒布怛那．人．非人等于四圣谛皆得明解。三转十二行相法轮。一切世间所有沙门若婆罗门诸天魔梵人非人等所不能转为欲利益安乐世间无量天人令得殊胜广大义利。昔所未转而今转之。善男子。我成如是第一佛轮。由此轮故如实了知此世他世是处非处。得安隐住得无惊恐得无所畏。降诸天魔外道邪论。转大梵轮成大梵行。我应住此杂染世界五浊恶时。处大众中正师子吼。灭诸有情五无间业广说乃至诸不善根。摧灭一切诸众生类坚如金刚相续烦恼。建立一切永尽诸漏解脱妙果。随其所乐安置一切有力众生令住三乘不退转位

善男子。如刹帝利灌顶大王。初登王位受帝职已。观察过去未来现在诸王法道。于其种种王业轮中。以善观察因果报智。随其所应建立一切辅臣僚佐普及国邑愚智人民三种业轮。由此业轮率土众生长夜受用。所有种种适意资具喜乐增长。能灭一切怨敌恶友。何等名为三种业轮。一者建立帝王业轮。谓善教习军阵斗战。降他兵众抚育人民。二者建立田宅业轮。谓善教习造舍营农。令得安隐饮食充足。三者建立财宝业轮。谓善教习工商杂艺。令得种种珍玩资财随意受用增诸快乐。善男子。刹帝利种灌顶大王。成就如是第二王轮。由此轮故。于自国土得安乐住。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来。初成佛果得无上智。观察过去未来现在诸佛法眼。以善观察诸业法受因果报智。建立一切所化有情三种业轮。由此业轮能令三宝种姓法眼长夜不灭无上正法炽盛流通。令诸有情长受种种生天涅槃安隐快乐。及令一切外道邪论不能降伏我正法眼。而能如法摧彼邪论善男子。何等名为三种业轮。一者建立修定业轮。二者建立习诵业轮。三者建立营福业轮。善男子。云何如来修定业轮。定有十种何等为十。谓正观察诸有识身六种境界。我我所执以为其因。业为良田。无明覆盖。爱为滋润。无有自在依他而立系属众缘。为欲断灭业烦恼苦三种流故。如是观察。云何业流。谓诸有情所行诸行。若此诸行所由无明及爱为因能生诸有。名烦恼流。若由烦恼识为其因众缘和合名色生起。名色为因众缘和合六处生起。六处为因众缘和合触受。后有生老死等次第生起。是名苦流。如是三流。业为良田。无明为因。爱为滋润而得生长。为欲枯涸业为良田无明为因爱为滋润三种流故。于五取蕴观为无常及苦无我。愚钝无动如幻如焰如水中月如梦所见。空无所有无相无愿。无所造作无生无起无出无像寂静远离无所出生。于五取蕴如是观察。能顺空忍顺无相忍顺无愿忍。为欲随顺观五取蕴。复方便修入出息观。即是修习持来去念。云何由念如实观察入息出息。谓正观察。数故。随故。止故。观故。转故。净故。应知此中数能造作二种事业。一能为依伏诸寻伺。二能取于入出息相。随能造作二种事业。一依出离舍诸寻伺。二能善取入出息相。止能造作二种事业。一能示现入出息灭。二能安住胜三摩地。观能造作二种事业。一能示现入出息尽。二能安住心及心法。别异观察。转能造作二种事业。一能方便舍诸取蕴。二能方便趣入圣地。净能造作二种事业。一能舍结。二能净见。如是六种方便。修习入出息观。便能随顺观五取蕴。所以者何。如是入息出息自性。名色取蕴。如是入息出息领纳。名受取蕴。如是入息出息取相。名想取蕴。如是入息出息造作。名行取蕴。如是入息出息了别。名识取蕴。如是所说五种取蕴。各各别异互不相似。新新非故无住无积不可言说。如是观察五种取蕴能除三行。若能如是究竟随观三种行尽。便能于此诸有识身六种境界究竟随观。我我所执业于无明爱因田覆润一切皆尽。如是修习四种念住皆得圆满。乃至修习八支圣道皆得圆满。如是乃至修习十八不共佛法皆得圆满。如是乃至修一切种无生法忍首楞伽摩三摩地等皆得圆满。如是修习持来去念入诸静虑。名住正法胜义有情。名为真实修习静虑。名为真实供养三世诸佛世尊。名一切佛心中之子从佛口生。是法所成是法所化。或有菩萨如是修习渐渐退转。乃至漏尽成阿罗汉具六神通。或有菩萨如是修习渐渐增长功德圆满成大菩萨。乃至十八不共佛法。一切种智修习圆满。此人不久当得无上正等菩提。善男子。我以如是诸业法受因果报智。观察三世诸佛法眼安立有情。于此十种修定业轮令其修习。善男子。是名如来修定业轮。善男子。云何如来习诵业轮。谓诸苾刍或苾刍尼邬波索迦邬波斯迦。或复净信诸善男子或善女人。善根微薄依世俗谛根机未熟。我当安置如是有情令其习诵初夜后夜精勤无怠。若诸有情求无上智。我当安置纯净大乘令其自读或教他读令其自诵或教他诵令其自说或教他说于大乘中令其自习或教他习。为令自身及他身中大烦恼众皆除灭故。为令证得无上智故。为除一切有情苦故。为令趣入无畏城故。若诸有情求缘觉乘。我当安置诸缘起法令其习诵。若诸有情求声闻乘。我当安置百千文颂四阿笈摩。百千文颂毗奈耶藏百千文颂阿毗达磨及毗婆沙令其习诵。善男子。是名如来习诵业轮。善男子。云何如来营福业轮。谓诸有情根机愚钝未种善根智慧微劣懈怠失念染著种种受用资具远离善友。我当安置如是有情使营福业。谓令修作佛法僧事及亲教师轨范师事。善男子。是名如来营福业轮。善男子。我成如是第二佛轮。由此轮故。以其无上三世业智。如实了知一切有情诸业法受因及果报。随其所应立三业轮。成熟一切所化有情得安隐住。得无惊恐。得无所畏。摧诸天魔外道邪论。转大梵轮成大梵行。如实了知众生因报

善男子。如刹帝利灌顶大王。成善巧智。观察一切沙门婆罗门。刹帝利茷舍戍达罗等种种功德多闻勇健工巧伎艺。若诸众生富有功德成巧便智。精进勇猛坚固不退。种种福德而自庄严。此刹帝利灌顶大王。随彼所应给施珍宝财谷田宅奴婢仆使。于自国土若诸众生德艺轻微功业鲜薄。此刹帝利灌顶大王。随彼所应微加赈恤。于自国土若诸众生。功德薄劣少于精进。懈怠懒惰忘失正念。无慈悲心不知恩报。于后世苦不见怖畏。没居家泥积诸恶行。此刹帝利灌顶大王。随彼所应种种谪罚。或以言教苦切呵责或夺种种珍宝资财或夺受用如意产业或罚鞭杖或禁牢狱或断支节或斩身首。如是无量随应谪罚。善男子。刹帝利种灌顶大王。成就如是第三王轮。由此轮故。令自国土增长安乐能伏一切怨敌恶友善守护身令增寿命。善男子。如是如来成就善巧知根机智。若诸弟子。远离福慧巧方便智及以布施调伏寂静。失念心乱。来至我所归依于我。而我善知彼根意乐随眠胜解。随其所应为说治罚毗奈耶法。若诸众生其性佷戾于诸学处不能奉持。为令久住我之圣教多有所作。或为制立忆念治罚。或以言教恐怖呵责或暂驱摈。或令折伏归诚礼拜。或不与语不共同利。或如草布或复灭摈。我以妙智知诸有情补特伽罗根机意乐随眠胜解。如应谪罚。为令皆破广大积聚无义黑闇枯竭烦恼诸瀑流故。令得生天涅槃乐故。为行恶道补特伽罗得调伏故。随其所应说治罚法。观察黑说大说差别。随其所应授与治罚行恶道法。我以妙智知诸有情具足成就增上信敬纯净意乐。随其所应为说种种善品差别令其修学。乃至令彼一切善根皆得圆满入无畏城。善男子。我成如是第三佛轮。由此轮故。知诸有情补特伽罗种种根机意乐随眠。及与胜解诸业法受。随其所应利益安乐。得安隐住得无惊恐得无所畏。自称我处大仙尊位转于佛轮摧诸天魔外道邪论处大众中正师子吼

善男子。如刹帝利灌顶大王。知自国土有无量有情补特伽罗归依种种邪神外道起于邪信及起邪见学邪禁戒执著修治邪吉凶相具受种种无利益苦。大王知已数数召集。以其先王治国正法开悟示现教习诫敕。令其舍除倒信倒见。修学先王正直旧法。令自国土一切有情一趣一归一意一欲一切和合同依先王正法而转听受诏命随顺奉行率土和同作所应作。时刹帝利灌顶大王。常与群臣数数集会。共味嘉肴受诸快乐嬉戏游行不相猜贰。咸共畴咨理诸王务。善男子。刹帝利种灌顶大王。成就如是第四王轮。由此轮故。令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来成就善巧知胜解智。见诸世间种种邪归邪见邪意乐著邪法行邪业行由是因缘受无量苦。如来见已。数数召集于大众前。以其过去诸佛世尊三宝种姓因果六种波罗蜜多瑜伽依因三律仪等诸因果法。开悟示现庆慰诫敕一切众会。令其解脱诸颠倒见建立正见。安置十善正直旧道。共诸有情数数同修法随法行。方便引摄因果等流。为诸有情四众和合同修一切殊胜善行。便共游戏四种念住。于三摩地解脱智见诸道品中欢娱受乐。为令圣教久住世故。绍三宝种不断绝故。便共游戏四正勤四神足五根五力七等觉支八圣道支。于其种种胜三摩地解脱智见诸道品中欢娱受乐。善男子。我成如是第四佛轮。由此轮故。知诸有情补特伽罗种种胜解归趣意乐诸业法受。随其所应利益安乐。得安隐住。得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。知自国土或他国土有无量有情补特伽罗于自财色耽染无厌于他财色贪求追爱。即便安置坚固城郭村坊戍逻国邑王宫广说乃至舍罗鹦鹉防守众具令无损失。善男子。刹帝利种灌顶大王。成就如是第五王轮。由此轮故令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来成就善巧知诸性智。知诸恶魔及九十五众邪外道并余无量众魔外道所惑有情。于自财色耽染无厌于他财色贪求追爱。于我自身及我徒众。深生憎嫉。为害我故假设珍馔杂以毒药。闇置火坑伪敷床座或推山石或放狂象拔剑追逐散坌尘秽谤行淫欲毁是不男或谓非人或言幻化。以是诸恶而相诽毁。于佛法僧亦起无量种种诽谤骂詈毁辱。于我近住声闻弟子。嫉妒因缘起诸毁谤。如来知已善守六根。依四梵住具四辩才。为诸声闻宣说法要。安立清净三解脱门。我以如是世出世间知诸性智。如实了知一切众生种种无量诸性差别。随其所应为作饶益。善男子。我成如是第五佛轮。由此轮故。以世出世知诸性智知诸有情补特伽罗种种无量诸性差别。随其所应利益安乐。得安隐住得无惊恐得无所畏。自称我处大仙尊位转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。安置一切坚固城郭村坊戍逻国邑王宫广说乃至舍罗鹦鹉防守具已。处自宫中与诸眷属后妃婇女而自围绕。游戏五欲种种乐具放恣六根受诸喜乐。善男子。刹帝利种灌顶大王。成就如是第六王轮。由此轮故令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来与诸菩萨摩诃萨众及大声闻安置一切坚固圣教防守之事。即便现入最初静虑乃至现入第四静虑现入无边虚空处定广说乃至现入非想非非想定。如是乃至现入一切佛所行定。入此定已。无量百千俱胝那庾多天龙药叉罗刹健达缚阿素洛揭路荼紧捺洛莫呼洛伽弥荔多毕舍遮布怛那羯吒布怛那等于诸众生常怀毒恶损害之心无慈无悲于后世苦不见怖畏。而彼见我入于一切佛所行定皆于我所生大欢喜起净信心于三宝中皆生最胜欢喜净信。尊重恭敬得未曾有。于一切恶惭愧发露深心悔过誓愿永断。由是因缘一刹那顷无量无数诸烦恼障业障法障皆得销灭。无量无数福慧资粮皆得成满。背离生死趣向涅槃。护持如来无上正法。善男子。我成如是第六佛轮。由此轮故如来游戏静虑解脱等持等至无量百千微妙深定。以净智随转灭诸有情无量烦恼。随其所应利益安乐得安隐住。得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。与诸群臣领四兵众。周巡观察一切自国城邑聚落山川溪涧园苑田泽陂河池沼旷野丛林镇逻等处。随彼所在国界诸方险阻多难不任营理有疑有怖堪容外境怨敌恶友投窜藏伏。此刹帝利灌顶大王。随其力能方便安置种种修理坚固防守。令彼诸方平坦无难堪任营理无疑无怖遮其外境怨敌恶友投窜藏伏。安抚自国一切人民皆离众苦受诸快乐。善男子。刹帝利种灌顶大王。成就如是第七王轮。由此轮故令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来以其佛眼。如实了知一切有情补特伽罗有贪有嗔有痴心等。如实了知是诸有情种种烦恼病行差别。如来知已便起无量精进勇猛方便势力。随其所宜授以种种修定妙药。令诸有情精勤修学除烦恼病。若诸有情宜修不净除烦恼病。即便授以修不净药。若诸有情宜修梵住除烦恼病即便授以修梵住药。若诸有情宜修缘起除烦恼病即便授以修缘起药。若诸有情宜修息念除烦恼病即便授以修息念药。若诸有情宜可修于三解脱门除烦恼病即便授以修于三种解脱门药。若诸有情宜修静虑除烦恼病即便授以修静虑药。若诸有情宜修无色除烦恼病即便授以修无色药。若诸有情乃至宜修首楞伽摩诸三摩地除烦恼病即便授以首楞伽摩三摩地药所以如来授诸有情如是法药。不令一切所化有情为四魔怨之所系摄。不令一切所化有情背人天乘向诸恶趣。不令如来无上法眼三宝称姓速疾坏灭。由是如来授诸有情如是法药。善男子。我成如是第七佛轮。由此轮故以其无上遍行行智授诸众生种种法药。令勤修学除烦恼病。得安隐住。得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。忆念自他本昔种姓初生童子嬉戏等事。谓忆自他于如是处。初生沐浴怀抱乳哺按摩支节乃至戏笑或弄灰土或与侍从种种遨游或习伎艺或复修营种种事业或游他国夙夜栖泊或奉事王或理王务或为太子或登王位得大自在受诸快乐广大名称遍诸方维。念是事已安立先王所遵正法。抚育一切国土人民。守护自国不侵他境。善男子。刹帝利种灌顶大王。成就如是第八王轮。由此轮故令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来处大众会忆念自他宿世所经无量种事。谓忆一生或二或三乃至无量百千生事。或忆成劫或忆坏劫或忆无量成劫坏劫。曾于过去住如是处如是名字如是种姓如是种类如是饮食如是领纳苦受乐受如是寿量如是久住如是极于寿量边际从彼处没来生此间复从此没往生彼处。忆念宿世如是等事无量无边。随诸众生根性差别建立正法为作饶益。善男子。我成如是第八佛轮。由此轮故利益安乐无量有情得安隐住得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。随念观察自国有情种姓伎艺及诸事业死此生彼因果胜劣差别不同。知彼有情生如是家。其身勇健或复怯弱。于诸伎艺已学未学。所有事业善作恶作。富贵贫贱端正丑陋。如是等类乃至命终。或有自业未尽而死。或有自业已尽而死。或犯王法刑戮而死。或有递相残害而死。或因鞭杖捶楚而死。或因囹圄幽絷而死。或因习学伎艺而死。或因战阵伤杀而死。或因斗诤欧击而死。或因财宝贪吝而死。或因色欲耽湎而死。或因忿恨结愤而死。或因劳倦顿弊而死。或因饥渴乏绝而死。或有过死或无过死。或耆年死或壮年死或幼年死。或作种种善业而死。或作种种恶业而死。知诸有情行善行者身坏命终当往善趣。知诸有情行恶行者身坏命终当往恶趣。知是事已复自思惟。我当正勤修身善行修语善行修意善行。我当施设种种方便修行布施调伏寂静。身坏命终当往善趣勿堕恶趣。此刹帝利灌顶大王。思惟是已勇猛精进。修身语意三种善行。常行布施。一切所有饮食衣服象马骑乘卧具医药房舍灯明及余资具奴婢僮仆种种珍财头目手足乃至身命无所吝惜。及离杀生离不与取离欲邪行离虚诳语离粗恶语离离间语离杂秽语离诸贪欲离诸嗔恚离诸邪见。由是因缘此刹帝利灌顶大王。当获十种功德胜利。何等为十。一者具大名称。二者具大财宝。三者具妙色相。四者具多眷属。五者少病少恼。六者朋友眷属聪慧多闻。七者正至正行亲近供养。八者广美声誉流振十方。九者大威德天神常随卫护。十者身坏命终当生天上常居善趣安乐国土。善男子。刹帝利种灌顶大王。成就如是第九王轮。由此轮故令自国土增长安乐。能伏一切怨敌恶友。善守护身令增寿命。善男子。如是如来如实了知一切有情死生等事。谓如实知若诸有情成身恶行成语恶行成意恶行诽谤贤圣具足邪见邪见业因身坏命终堕诸恶趣或生地狱或生傍生或生饿鬼。若诸有情成身善行成语善行成意善行不谤贤圣具足正见正见业因身坏命终升诸善趣或生天上或生人中或尽诸漏。如来如是如实知已。于彼众生起大慈悲。勇猛精进现三神变。令彼众生归趣佛法教诫安置成立世间出世间信。何等为三。一者神通变现。二者记说变现。三者教诫变现。由是三种变现威力。劝发有情教诫安置成立世间出世间信。令于一切有趣死生皆得解脱。善男子。我成如是第九佛轮。由此轮故利益安乐无量有情。得安隐住得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。如刹帝利灌顶大王。为除四洲无量有情种种身病弃舍王位。以诸香汤沐浴身首著鲜净衣端坐思惟。于诸众生其心平等慈悲护念。为令解脱一切病故以其种种香花伎乐及余供具供养一切大威德天神。尔时一切天帝龙帝乃至莫呼洛伽神帝。知是事已各相谓言。此刹帝利灌顶大王。具诸功德有大威神应作轮王统四洲渚。我等宜应共往建立令复王位统四洲渚令诸众生无病安乐。时诸天帝乃至莫呼洛伽神帝。即便共往立刹帝利灌顶大王转轮王位。令具七宝统四大洲皆得自在。千子具足勇健端正能摧怨敌跨王大地亘穷海际谪罚皆停刀杖不举。咸修正法普受安乐。善男子。刹帝利种灌顶大王。成就如是第十王轮。由此轮故于四大洲爰及八万四千小渚。安立其中诸有情类十善业道。善守护身令增寿命身坏命终当生天中受诸妙乐。善男子。如是如来昔菩萨位。知自他身有无量种诸烦恼病。以定香水洗浴其身及以谛法大慈大悲灌沐其首著惭愧衣。十方一切诸佛世尊。以诸静虑等持精进方便智意慈悲护念。咸作是言。如是大士。是大福慧庄严宝器。堪容一切三种不护四无所畏如来十力及与十八不共佛法。堪得无上一切智智。大慈大悲无不具足。常欣利乐一切众生。是求佛宝商人导首。能救有情生死众苦。能施有情涅槃大乐。我等一切诸佛世尊。应以诚言与其所愿。令成如来应正等觉得无上法为大法王。我于尔时依福慧力勇猛精进。于四圣谛如实知已证得无上正等菩提。善男子。如转轮王统四大洲皆得自在。如是如来于四静虑四无色定四种梵住四无碍解四圣谛观四无所畏如来十力及与十八不共佛法一切种智皆得自在。如转轮王具足七宝。如是如来成就七种菩提分宝。如转轮王千子具足勇健端正能伏怨敌。如是如来有阿若多憍陈那为最初苏跋陀罗苏剌多为最后诸大声闻从佛心生从佛口生从法化生得佛法分诸漏永尽名为勇健。具四梵住名为端正能伏一切天魔外道异论怨敌。如转轮王化及八万四千小渚。如是如来于百俱胝南赡部洲于百俱胝西瞿陀尼洲于百俱胝东毗提诃洲于百俱胝北俱卢洲于百俱胝诸大溟海于百俱胝诸妙高山于百俱胝四大王天于百俱胝乃至非想非非想天于百俱胝大轮围山于此高广一佛土中。言音施化皆得自在。善男子。我成如是第十佛轮。由此轮故如实了知自身他身诸漏永尽。利益安乐无量有情。得安隐住得无惊恐得无所畏。自称我处大仙尊位。转于佛轮摧诸天魔外道邪论。处大众中正师子吼

善男子。我成如是十种佛轮。本愿力故居此佛土五浊恶世。一切有情。损减一切白净善法。匮乏所有七圣财宝。远离一切聪愍智者。断常罗网之所覆蔽。常好乘驭诸恶趣车。于后世苦不见怖畏。常处遍重无明黑闇。具十恶业。造五无间。诽谤正法。毁呰贤圣。离诸善法。具诸恶法。我于其中成就如是佛十轮故。得安隐住得无惊恐得无所畏。自称我处大仙尊位。转于佛轮降诸天魔外道邪论。摧灭一切诸有情类犹如金刚坚固烦恼。随其所乐安立一切有力众生令住三乘不退转位。尔时会中一切菩萨摩诃萨众一切声闻一切天龙广说乃至一切羯吒布怛那众人非人等。皆大欢喜同唱善哉。雨大香雨雨大花雨雨众宝雨雨大衣雨。一切大地皆悉震动。闻说如是十种佛轮。于众会中有八十四百千那庾多菩萨摩诃萨得无生法忍。复有无量菩萨摩诃萨获得种种诸陀罗尼三摩地忍。复有无量无数有情初发无上正等觉心得不退转。复有无量无数有情逮得果证

大乘大集地藏十轮经卷第二
大乘大集地藏十轮经卷第三

        三藏法师玄奘奉　诏译

    无依行品第三之一

尔时会中有大梵天名曰天藏。久殖善根住第十地具诸菩萨摩诃萨德。即从座起合掌礼佛。而说颂言

  功德藏慧海　　我今问所疑
  愿慧海垂听　　为我除疑滞
  我等今渴仰　　德藏胜法味
  及最上义味　　举众咸欲闻

佛告天藏大梵天言。如来今者恣汝意问。当随问答令汝心喜。大梵天言。唯然世尊以颂问曰

  利慧修定者　　安住不放逸
  为住胜义谛　　为依止生死
  昼夜于法义　　精勤而诵习
  为渡烦恼海　　为退堕恶趣
  勇猛勤营福　　为定趣涅槃
  为处生死中　　退堕于恶趣
  聪慧刹帝利　　成就十种轮
  为沉生死中　　为当升佛果
  杂染心难伏　　诸烦恼所乱
  以何净其心　　修定福诵业

尔时世尊告彼天藏大梵天曰。善哉善哉。汝善辩才能问斯义。汝于此法已作劬劳。汝于诸行已得圆满。汝于过去殑伽沙等佛世尊所已勤三业兴隆正法绍三宝种。今为饶益无量众生复问如来如是深义。善男子。有大记别法名无依行。过去一切诸佛世尊。为欲成熟诸有情故。为令厌离生死法故。为令除断业烦恼故。为令三乘速圆满故。宣说住持此无依行大记别法。现在十方诸佛世尊。亦为成熟诸有情故。为令厌离生死法故。为令除断业烦恼故。为令三乘速圆满故。宣说住持此无依行大记别法。未来一切诸佛世尊。亦为成熟诸有情故。为令厌离生死法故。为令除断业烦恼故。为令三乘速圆满故。宣说住持此无依行大记别法。汝于过去诸如来所已具得闻此无依行大记别法。我于今者亦为成熟诸有情故。为令厌离生死法故。为令除断业烦恼故。为令三乘速圆满故。宣说住持此无依行大记别法。汝应谛听善思念之。吾当为汝分别解说。尔时天藏大梵天言。唯然世尊愿乐欲闻

佛言。大梵。有十种无依行法。若修定者随有一行。尚不能成欲界善根。设使先成寻还退失。况当能成色无色定乃至三乘随成一乘。何等为十。一者世有一类。虽欲修定而乏资缘经求扰乱。二者复有一类。虽欲修定而犯尸罗行诸恶行。三者复有一类。虽欲修定而颠倒见妄执吉凶身心刚强。四者复有一类。虽欲修定而心掉动不顺贤圣诸根轻躁。五者复有一类。虽欲修定而离间语破乱彼此。六者复有一类。虽欲修定而粗恶语毁骂贤圣。七者复有一类。虽欲修定而杂秽语及虚诳语。八者复有一类。虽欲修定。而怀贪嫉于他所得利养恭敬心不欢悦。九者复有一类。虽欲修定而怀嗔忿于诸有情心常愤恚。十者复有一类。虽欲修定。而怀邪见拨无因果。大梵当知。是名十种无依行法。若修定者随有一行。尚不能成欲界善根。设使先成寻还退失。况当能成色无色定乃至三乘随成一乘。

复次大梵。又有十种无依行法。若修定者随有一行。终不能成诸三摩地。设使先成寻还退失。何等为十。一者乐著事业。二者乐著谈论。三者乐著睡眠。四者乐著营求。五者乐著艳色。六者乐著妙声。七者乐著芬香。八者乐著美味。九者乐著细触。十者乐著寻伺。大梵当知。是名十种无依行法。若修定者随有一行。终不能成诸三摩地。设使先成寻还退失。若不能成诸三摩地。虽集所余诸善法聚而有是事。追求受用信施因缘。发起恶心心所有法。于诸国王大臣等所犯诸过罪。或被呵骂或被捶打或被断截肢节手足。由是因缘或成重病长时受苦。或疾命终于三恶趣。随生一所乃至或生无间地狱。如嗢达洛迦．阿逻荼底沙．瞿波理迦．提婆达多。如是等类退失静虑。乃至堕于无间地狱受无量种难忍大苦。尔时世尊告阿若多憍陈那言。吾听汝等给阿练若修定苾刍。最上房舍最上卧具最上饮食。一切僧事皆应放免。所以者何。诸修定者若乏资缘。即便发起一切恶心心所有法。不能成就诸三摩地。乃至堕于无间地狱受无量种难忍大苦。修定行者若具资缘。诸三摩地未成能成若先已成终不退失。由此不起一切恶法广说乃至不善寻伺。往生天上证得涅槃。修定行者。若未成就诸三摩地。初夜后夜当舍睡眠精进修学。远离愦闹。少欲知足无所顾恋。一切贪嗔忿覆恼害憍慢贡高悭吝嫉妒离间粗恶虚诳杂秽一切人间嬉戏放逸皆悉远离。如是行者。应受释梵护世四王转轮王等赞叹礼拜恭敬承事奉施百千那庾多供。况刹帝利．婆罗门．茷舍．戍达罗等。未得定者。尚应受此赞叹礼拜恭敬承事奉施供养。何况已得三摩地者。尔时世尊而说颂曰

  修定能断惑　　余业所不能
  故修定为尊　　智者应供养

尔时天藏大梵天言。大德世尊。于佛法中而出家者。若刹帝利大臣宰相以鞭杖等捶拷其身或闭牢狱或复呵骂或解肢节或断其命。为当合尔为不合耶

佛告天藏大梵天言。善男子。若诸有情于我法中出家乃至剃除须发被片袈裟。若持戒若破戒下至无戒。一切天人阿素洛等。依俗正法。犹尚不合以鞭杖等捶拷其身或闭牢狱或复呵骂或解肢节或断其命。况依非法。何以故。除其一切持戒多闻。于我法中而出家者。若有破戒行诸恶法内怀腐败如秽蜗螺实非沙门自称沙门实非梵行自称梵行恒为种种烦恼所胜败坏倾覆。如是破戒诸恶苾刍。犹能示导一切天．龙．药叉．健达缚．阿素洛．揭路荼．紧捺洛．莫呼洛伽．人．非人等无量功德珍宝伏藏。又善男子。于我法中而出家者。虽破戒行而诸有情睹其形相应生十种殊胜思惟。当获无量功德宝聚。何等为十。谓我法中而出家者。虽破戒行。而诸有情或有见已生于念佛殷重信敬殊胜思惟。由是因缘终不归信诸外道师书论徒众。乃至能入离诸怖畏大涅槃城。或有见已生念圣戒殊胜思惟。由是因缘能离杀生离不与取离欲邪行离虚诳语离饮诸酒生放逸处。乃至能入离诸怖畏大涅槃城。或有见已生念布施殊胜思惟。由是因缘得大财位。亲近供养正至正行。乃至能入离诸怖畏大涅槃城。或有见已生念忍辱。柔和质直殊胜思惟。由是因缘。便能远离离间粗恶杂秽嗔忿。乃至能入离诸怖畏大涅槃城。或有见已生念出家精勤修行殊胜思惟。由是因缘。能舍家法趣于非家勇猛精进修诸胜行。乃至能入离诸怖畏大涅槃城。或有见已生念远离诸散乱心静虑等至殊胜思惟。由是因缘。心乐山林阿练若处昼夜精勤修诸定行。乃至能入离诸怖畏大涅槃城。或有见已生念智慧殊胜思惟。由是因缘。欣乐听闻读诵正法。乃至能入离诸怖畏大涅槃城。或有见已生念宿殖出离善根殊胜思惟。软语慰问乃至礼足。由是因缘。当生尊贵大势力家。无量有情咸共赡仰。乃至能入离诸怖畏大涅槃城。善男子。于我法中而出家者。虽破戒行。而诸有情睹其形相生此十种殊胜思惟当获无量功德宝聚。是故一切刹帝利王大臣宰相。决定不合以鞭杖等捶拷其身或闭牢狱或复呵骂或解支节或断其命

复次大梵。若有依我而出家者。犯戒恶行内怀腐败如秽蜗螺。实非沙门自称沙门。实非梵行自称梵行。恒为种种烦恼所胜败坏倾覆。如是苾刍虽破禁戒行诸恶行。而为一切天．龙药叉．健达缚．阿素洛揭路荼紧捺洛莫呼洛伽人非人等作善知识。示导无量功德伏藏。如是苾刍虽非法器。而剃须发被服袈裟进止威仪同诸贤圣。因见彼故无量有情种种善根皆得生长。又能开示无量有情善趣生天涅槃正路。是故依我而出家者。若持戒若破戒下至无戒。我尚不许转轮圣王及余国王诸大臣等依俗正法以鞭杖等捶拷其身或闭牢狱或复呵骂或解支节或断其命。况依非法。大梵。如是破戒恶行苾刍。虽于我法毗奈耶中名为死尸。而有出家戒德余势。譬如牛麝身命终后虽是无识傍生死尸而牛有黄而麝有香能为无量无边有情作大饶益。破戒苾刍亦复如是。虽于我法毗奈耶中名为死尸。而有出家戒德余势。能为无量无边有情作大饶益。大梵。譬如贾客入于大海杀彼一类无量众生挑取其目。与末达那果和合捣簁成眼宝药。若诸有情盲冥无目乃至胞胎而生盲者。持此宝药涂彼眼中。所患皆除得明净目。破戒苾刍亦复如是。虽于我法毗奈耶中名为死尸。而有出家威仪形相。能令无量无边有情暂得见者尚获清净智慧法眼。况能为他宣说正法。大梵。譬如烧香其质虽坏而气芬馥熏他令香。破戒苾刍亦复如是。由破戒故非良福田。虽恒昼夜信施所烧身坏命终堕三恶趣。而为无量无边有情作大饶益。谓皆令得闻于生天涅槃香气。是故大梵。如是破戒恶行苾刍。一切白衣皆应守护恭敬供养。我终不许诸在家者。以鞭杖等捶拷其身或闭牢狱或复呵骂。或解支节或断其命。我唯许彼清净僧众。于布萨时或自恣时驱摈令出。一切给施四方僧物。饮食资具不听受用。一切沙门毗奈耶事。皆令驱出不得在众。而我不许加其鞭杖系缚断命。尔时世尊而说颂曰

  瞻博迦华虽萎悴　　而尚胜彼诸余华
  破戒恶行诸苾刍　　犹胜一切外道众

复次大梵。有五无间大罪恶业。何等为五。一者故思杀父。二者故思杀母。三者故思杀阿罗汉。四者倒见破声闻僧。五者恶心出佛身血。如是五种。名为无间大罪恶业。若人于此五无间中。随造一种不合出家及受具戒。若令出家或受具戒。师便犯罪。彼应驱摈令出我法。如是之人。以有出家威仪形相。我亦不许加其鞭杖。或闭牢狱或复呵骂。或解支节或断其命。复有四种近五无间大罪恶业根本之罪。何等为四。一者起不善心杀害独觉。是杀生命大罪恶业根本之罪。二者淫阿罗汉苾刍尼僧。是欲邪行大罪恶业根本之罪。三者侵损所施三宝财物。是不与取大罪恶业根本之罪。四者倒见破坏和合僧众。是虚诳语大罪恶业根本之罪。若人于此四近无间大罪恶业根本罪中随犯一种。不合出家及受具戒。若令出家或受具戒。师便得罪。彼应驱摈令出我法。如是之人。以有出家及受具戒威仪形相。我亦不许加其鞭杖或闭牢狱或复呵骂或解支节或断其命。如是或有是根本罪非无间罪。有无间罪非根本罪。有根本罪亦无间罪。有非根本罪亦非无间罪。何等名为是根本罪亦无间罪。谓我法中先已出家受具戒者。故思杀他已到究竟见谛人等。如是名为是根本罪亦无间罪。此于我法毗奈耶中应速驱摈。何等名为是根本罪非无间罪。谓我法中先已出家受具戒者。故思杀害他异生人。下至方便与人毒药堕其胎藏。如是名为是根本罪非无间罪。此人不应与僧共住。诸有给施四方僧物。亦不应令于中受用。何等名为是无间罪非根本罪。谓若有人或受三归。或受五戒或受十戒。于五无间随造一种。如是名为是无间罪非根本罪。如是之人。不合出家及受具戒。若令出家或受具戒。师便得罪。彼应驱摈令出我法。何等名为非根本罪亦非无间罪。谓若有人或受三归或受五戒。于佛法僧而生疑心。或归外道以为师导。或执种种若少若多吉凶之相祠祭鬼神。若复有人于诸如来所说正法或声闻乘相应正法或独觉乘相应正法或是大乘相应正法。诽谤遮止自不信受。令他厌背障碍他人读诵书写下至留难一颂正法。如是名为非根本罪亦非无间。而生极重大罪恶业近无间罪。如是之人。若未忏悔除灭如是大罪恶业。不合出家及受具戒。若令出家或受具戒。师便得罪。彼应驱摈令出我法。若已出家或受具戒。犯如是罪若不忏悔。此于我法毗奈耶中。应速驱摈。所以者何。此二种人习行破毁正法眼行。习行隐灭正法灯行。习行断绝三宝种行。令诸天人习行无义无利苦行堕诸恶趣。此二种人自谤正法毁呰贤圣。亦令他人诽谤正法毁呰贤圣。命终当堕无间地狱经劫受苦不可疗治

复次大梵。或有遮罪无依行法。或有性罪无依行法。于性罪中。或有根本无依行法。云何根本无依行法。谓若苾刍行非梵行犯根本罪。或以故思杀异生人犯根本罪。或复偷盗非三宝物犯根本罪。或大妄语犯根本罪。若有苾刍于此四种根本罪中随犯一种。于诸苾刍所作事业令受折伏。一切给施四方僧物。皆悉不听于中受用。而亦不合加其鞭杖或闭牢狱或复呵骂。或解支节或断其命。如是名为于性罪中根本重罪无依行法。何故说名为根本罪。谓若有人犯此四法。身坏命终堕诸恶趣。是诸恶趣根本罪故。是故说名为根本罪。何故无间及近无间根本罪等。说名极重大罪恶业无依行法。善男子。譬如铁抟铅锡抟等掷置空中终无暂住必速堕地。造五无间及近无间四根本罪。并谤正法疑三宝等。二种罪人亦复如是。若人于此十一罪中随造一种。身坏命终无余间隔。定生无间大地狱中受诸剧苦。故名极重大罪恶业无依行法。犯此极重大罪恶业无依行法补特伽罗。于现身中决定不能尽诸烦恼。尚不能成诸三摩地。况能趣入正性离生。彼人命终定生地狱受诸重苦

复次大梵。若善男子若善女人。以净信心归依我法。或趣声闻乘。或趣独觉乘或趣大乘。于我法中净信出家受具足戒。于诸学处深心敬重。于四根本性罪戒中坚固勇猛精勤守护。如是之人。常为一切人非人等随逐拥卫。名不虚受人天供养。于三乘中随所欣乐速能趣入成办究竟。是故真实求涅槃者。宁舍身命终不毁犯如是四法。所以者何。诸有情类要由三因得涅槃乐。一者依止如来为因。二者依我圣教为因。三者依我弟子为因。诸有情类依此三因。精勤修行得涅槃乐。若人毁犯如是四法。我非彼师彼非弟子。若人毁犯如是四法。则为违越我所宣说甚深广大无常苦空无我相应利益安乐一切有情别解脱教。若越如是别解脱教。则于一切静虑等持皆成盲冥不能趣入。为诸烦恼恶业缠缚。于三乘法亦为非器。当堕恶趣受诸重苦。若善男子若善女人。于我所说别解脱教。所制四种根本重罪清净无犯。我是彼师彼是弟子。随顺我语善住我法。一切所作皆当成满。此人善住尸罗蕴故。名为善住一切善法。或名具足住声闻乘。或名具足住独觉乘。或名具足住于大乘。所以者何。若能护持如是性罪四根本法。当知。则为建立一切有漏无漏善法胜因。是故护持如是四法。名为一切善法根本。如依大地一切药谷卉木丛林皆得生长。如是依止极善护持四根本戒。一切善法皆得生长。如依大地一切诸山小轮围山大轮围山妙高山王皆得安住。如是依止极善护持四根本戒。诸声闻乘及独觉乘无上大乘皆得安住。如依大地求得一切世间美味。如是依止极善护持四根本戒。求得一切念定总持安忍圣道乃至无上正等菩提。又如大地于净不净皆等任持。极善护持四根本戒诸善男子及善女人亦复如是。于其法器及非法器其心平等不讥不弄不自贡高不卒呵举能为一切善法生处。又如大地一切有情皆共受用而得存活。极善护持四根本戒诸善男子及善女人亦复如是。于诸如来所说正法生长第一欢喜净信。于诸有情无差别想以四摄法平等摄受。一切有情皆共依止。受用法乐而自存活

尔时尊者优波离。闻佛所说从座而起。整理衣服顶礼佛足偏袒一肩右膝著地。合掌恭敬白佛言。世尊。如佛所说。极善护持四根本戒。诸善男子及善女人。于其法器及非法器。其心平等不讥不弄不自贡高不卒呵举。若如是者。于未来世有诸苾刍破戒恶行。实非沙门自称沙门实非梵行自称梵行。诸苾刍僧于是人等云何方便呵举驱摈

佛告尊者优波离言。我终不许外道俗人举苾刍罪。我尚不许诸苾刍僧不依于法率尔呵举破戒苾刍。何况驱摈。若不依法率尔呵举破戒苾刍或复驱摈。便获大罪。优波离。汝今当知有十非法。率尔呵举破戒苾刍便获大罪。诸有智者皆不应受。何等为十。一者不和僧众。于国王前率尔呵举破戒苾刍。二者不和僧众。梵志众前率尔呵举破戒苾刍。三者不和僧众宰官众前率尔呵举破戒苾刍。四者不和僧众。于诸长者居士众前率尔呵举破戒苾刍。五者女人众前率尔呵举破戒苾刍。六者男子众前率尔呵举破戒苾刍。七者净人众前率尔呵举破戒苾刍。八者众多苾刍苾刍尼前率尔呵举破戒苾刍。九者宿怨嫌前率尔呵举破戒苾刍。十者内怀忿恨率尔呵举破戒苾刍。如是十种名为非法。率尔呵举破戒苾刍便获大罪。设依实事而呵举者尚不应受。况于非实。诸有受者亦得大罪。复有十种非法。呵举破戒苾刍便获大罪。诸有智者亦不应受。何等为十。一者诸余外道呵举苾刍。二者不持禁戒在家白衣呵举苾刍。三者造无间罪呵举苾刍。四者诽谤正法呵举苾刍。五者毁呰贤圣呵举苾刍。六者痴狂心乱呵举苾刍。七者痛恼所缠呵举苾刍。八者四方僧净人呵举苾刍。九者守园林人呵举苾刍。十者被罚苾刍呵举苾刍。如是十种非法。呵举破戒苾刍便获大罪。设依实事而呵举者亦不应受。况于非实。诸有受者亦得大罪

复次优波离。若有苾刍。毁犯禁戒与僧共住。于僧众中有余苾刍。轨则所行皆悉具足。一切五德无不圆满。应从坐起整理衣服恭敬顶礼苾刍僧足便至破戒恶苾刍前求听举罪作如是言。长老忆念。我今欲举长老所犯。以实非虚妄。应时不非时。软语非粗犷。慈心不嗔恚。利益非损减。为令如来法眼法灯久炽盛故。长老听者。我当如法举长老罪。彼若听者。便应如法如实举之。彼若不听。复应顶礼上座僧足恭敬白言。如是苾刍犯如是事。我依五法如实举之。时僧众中上坐苾刍。应审观察能举所举及所犯事虚实轻重。依毗奈耶及素怛缆方便捡问慰喻呵责以七种法如应灭除。若犯重罪应重治罚。若犯中罪应中治罚。若犯轻罪应轻治罚。令其惭愧忏悔所犯

时优波离复白佛言。世尊。若实有过恶行苾刍恃白衣力或财宝力或多闻力或词辩力或弟子力以如是等诸势力故。凌拒僧众。上坐苾刍持素怛缆及毗奈耶．摩怛理迦者如法教诲皆不承顺。如是苾刍云何治罚。佛言。优波离。上座苾刍持三藏者。应和僧众遣使告白国王大臣令助威力然后如实依法治罚。时优波离复白佛言。世尊。若彼有过恶行苾刍。以财宝力或多闻力或词辩力。或以种种巧方便力。令彼国王大臣欢喜皆住破戒非法朋中。容纵如是恶苾刍罪。不听如实依法治罚。尔时僧众应当云何。佛言。优波离。若彼苾刍行无依行。于僧众中粗重罪相未彰露者。是时僧众应权舍置。若彼苾刍行无依行。于僧众中粗重罪相已彰露者。是时僧众应共和合依法驱摈令出佛法。优波离。譬如燕麦在麦田中。牙茎枝叶与麦相似秽杂净麦。乃至彼草其穗未出。是时农夫应权舍置。穗既出已是时农夫恐秽净麦并根剪拔弃于田外。行无依行破戒苾刍亦复如是。恃白衣等种种势力。住于僧中威仪形相与僧相似秽杂清众。乃至善神未相觉发于僧众中粗重罪相未彰露者。是时僧众应权舍置。若诸善神已相觉发于僧众中粗重罪相已彰露者。是时僧众应共和合。依法驱摈令出佛法。优波离。譬如大海不宿死尸。我声闻僧诸弟子众亦复如是。不与破戒恶行苾刍死尸共住。时优波离复白佛言。世尊。若彼破戒恶行苾刍。僧众和合共驱摈已。彼恶苾刍。以财宝力或多闻力或词辩力或以种种巧方便力。令彼国王大臣欢喜。皆住破戒非法朋中。以威势力凌逼僧众还令如是破戒苾刍与僧共住。尔时僧众当复云何。佛言。优波离。尔时僧中有能悔愧持戒苾刍。为护戒故不应嗔骂破戒苾刍。但应告白国王大臣。或恐凌逼而不告白。应舍本居别往余处

大乘大集地藏十轮经卷第三
大乘大集地藏十轮经卷第四

        三藏法师玄奘奉　诏译

    无依行品第三之二

尔时地藏菩萨摩诃萨复白佛言。大德世尊。颇有佛土。五浊恶世空无佛时。其中众生烦恼炽盛习诸恶行。愚痴佷戾难可化不。谓刹帝利旃荼罗。宰官旃荼罗。居士旃荼罗。长者旃荼罗。沙门旃荼罗。婆罗门旃荼罗。如是等人善根微少无有信心。谄曲愚痴怀聪明慢。不见不畏后世苦果。离善知识乃至趣向无间地狱。如是等人为财利故。与诸破戒恶行苾刍相助共为非法朋党。皆定趣向无间地狱。若有是处我当住彼以佛世尊如来法王利益安乐一切有情无上微妙甘露法味方便化导令得受行。拔济如是刹帝利旃荼罗乃至婆罗门旃荼罗令不趣向无间地狱

尔时佛告地藏菩萨摩诃萨言。善男子。于未来世此佛土中有诸众生。烦恼炽盛习诸恶行。愚痴佷戾难可化导。谓刹帝利旃荼罗。宰官旃荼罗。居士旃荼罗。长者旃荼罗。沙门旃荼罗。婆罗门旃荼罗。如是等人善根微少无有信心。谄曲愚痴怀聪明慢。离善知识言无真实。不能随顺善知识语。常行诽谤毁呰骂詈于诸正法。犹豫倒见不见不畏后世苦果。常乐习近诸恶律仪。好行杀生乃至邪见。欺诳世间自他俱损。是刹帝利旃荼罗。乃至婆罗门旃荼罗坏乱我法。于我法中而得出家。毁破禁戒乐营俗业。彼刹帝利乃至婆罗门等。恭敬供养贪利求财有言无行。传书送印通信往来商贾贩易。好习外典种殖营农藏贮宝物。守护园宅妻妾男女。习行符印咒术使鬼。占相吉凶合和汤药疗病求财以自活命。贪著饮食衣服宝饰。勤营俗务毁犯尸罗。行诸恶法贝音狗行。实非沙门自称沙门实非梵行自称梵行。彼刹帝利旃荼罗乃至婆罗门旃荼罗。爱乐亲近恭敬供养听受言教。此破戒者。于刹帝利旃荼罗乃至婆罗门旃荼罗。亦乐亲近恭敬供养听受言教。若见有人于我法中得出家已具戒富德精进修行学无学行乃至证得最后极果。彼刹帝利旃荼罗。乃至婆罗门旃荼罗反生憎嫉。不乐亲近恭敬供养听受言教。善男子。譬如有人入宝洲渚。弃舍种种帝青大青金银真珠红莲华色茷琉璃等大价真宝取迦遮珠。于未来世此佛土中。有刹帝利旃荼罗。乃至婆罗门旃荼罗。亦复如是。入我正法宝洲渚中。弃舍种种具戒富德乐胜义谛。具足惭愧学无学人及善异生精勤修学六到彼岸具诸功德真圣弟子。取诸破戒好行众恶无惭无愧言辞粗犷身心憍骜离诸白法无慈无悲恶行苾刍。以为福田恭敬供养听受言教。如是恶人师及弟子。俱定趣向无间地狱

善男子。有十恶轮。于未来世此佛土中。有刹帝利旃荼罗。宰官旃荼罗。居士旃荼罗。长者旃荼罗。沙门旃荼罗。婆罗门旃荼罗。如是等人。于十恶轮或随成一或具成就。先所修集一切善根。摧坏烧灭皆为灰烬。不久便当肢体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱。何等为十。如是破戒恶行苾刍。有刹帝利及宰官等。忍受恶见谤阿练若清净苾刍言。诸仁者。如是苾刍愚痴凡猥。诈现异相诳惑世间。为求饮食衣服利养恭敬名誉自赞毁他。嫉妒斗乱贪著名利无有厌足。应当摈黜勿受其言。如是苾刍专行妄语离谛实法。于此皆无得道果者。亦无离欲永尽诸漏。但为利养恭敬名誉住阿练若自现有德。慎莫供养恭敬承事。如是谄曲非真福田。非行道者。时刹帝利旃荼罗乃至婆罗门旃荼罗。于阿练若清净苾刍。不能生实信心希有之想。心无恭敬意怀凌蔑。不乐亲近承事供养。所有言说皆不听受。轻毁如是住阿练若清净苾刍。即是轻毁一切法眼三宝种姓。时彼国中有诸天龙药叉神等信敬三宝无动坏者。于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿互相谓言。仁等当观此刹帝利宰官居士长者沙门婆罗门等旃荼罗人。皆悉轻毁一切法眼三宝种姓。损减善根。由恶友力摄诸罪业当堕恶趣。我等从今勿复拥护此刹帝利旃荼罗等并其所居国土城邑。作是语已。一切天龙药叉神等皆悉弃舍。不复拥护彼刹帝利旃荼罗等并彼所居国土城邑。于彼国土一切法器真实福田皆出其国。设有住者亦生舍心不复护念。由诸天龙药叉神等及诸法器真实福田于刹帝利旃荼罗等并彼所居国土城邑。皆舍守护不护念已。时彼国土自军他军竞起侵凌更相残害。疾疫饥馑因此复兴。彼刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。一切国民皆无欢乐。先所爱乐今悉别离。朋友眷属更相嗔恨。潜谋猜贰无慈无悲。嫉妒悭贪众恶皆起。所谓杀生乃至邪见无惭无愧。食用一切窣堵波物及僧祇物。曾无悔心。彼刹帝利旃荼罗王。憎嫉忠贤爱乐谄佞。令己官庶互相侵凌。愤恚结怨兴诸斗诤。共余邻国交阵战时。军士离心无不退败。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱

复次善男子。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。随恶友行善根微少。谄曲愚痴怀聪明慢。于三宝所无淳净心。不见不畏后世苦果。此有一类。于声闻乘得微少信。实是愚痴自谓聪敏。于我所说缘觉乘法及大乘法毁呰诽谤。不听众生受持读诵下至一颂。复有一类。于缘觉乘得微少信。实是愚痴自谓聪敏。于我所说声闻乘法及大乘法毁呰诽谤。不听众生受持读诵下至一颂。复有一类。于大乘法得微少信。实是愚痴自谓聪敏。于我所说声闻乘法缘觉乘法毁呰诽谤。不听众生受持读诵下至一颂。如是等人名为毁谤佛正法者亦为违逆三世诸佛。破三世佛一切法藏焚烧断灭皆为灰烬。断坏一切八支圣道挑坏无量众生法眼。若刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。于佛所说声闻乘法缘觉乘法及大乘法障碍覆藏令其隐没乃至一颂。当知是人名不恭敬一切法眼三宝种姓。由是因缘。令护国土一切天龙药叉神等信敬三宝无动坏者于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间大狱

复次善男子。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。随逐破戒恶苾刍行。广说乃至。于彼国中有诸法器真实福田于刹帝利旃荼罗等皆住舍心而不护念。虽居其国而依法住常不喜乐俗间居止。亦不数数往施主家。设令暂往而护语言。纵有语言曾无虚诳。终不对彼在家人前讥毁轻弄诸破戒者。于诸破戒恶行苾刍终不轻然辄相检问亦不现相故显其非。常近福田远诸破戒。而彼破戒恶行苾刍。于此持戒真善行者反生嗔恨轻毁侵凌。于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人在家男女大小等前种种谄曲虚妄谈论毁呰诽谤此持戒者。令刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人于我弟子少欲知足持戒多闻具妙辩才诸苾刍所心生嗔恨种种粗言呵骂逼切令心忧恼身不安泰或夺衣钵诸资身具。令其匮乏或夺所施四方僧物不听受用或闭牢狱枷锁拷楚或解支节或斩身首。善男子。当观如是诸刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。亲近破戒恶行苾刍造作如是种种大罪乃至当堕无间地狱。若诸众生作五无间或犯重戒或近无间性罪遮罪犹轻。如是诸刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。亲近破戒越法重罪。善男子。如是破戒恶行苾刍。虽作如是越法重罪。而依我法剃除须发被服袈裟。进止威仪同诸贤圣。我尚不许国王大臣诸在家者依俗正法以鞭杖等捶拷其身或闭牢狱或复呵骂或解支节或断其命。况依非法。国王大臣诸在家者。若作此事便获大罪决定当生无间地狱。于诸破戒恶行苾刍。犹尚不应如是谪罚。何况持戒真善行者。善男子。若有苾刍于诸根本性重罪中随犯一罪虽名破戒恶行苾刍。而于亲教和合僧中所得律仪犹不断绝。乃至弃舍所学尸罗犹有白法香气随逐。国王大臣诸在家者无有律仪。不应轻慢及加谪罚。如是苾刍虽非法器退失圣法秽杂清众。破坏一切沙门法事。不得受用四方僧物。而于亲教和合僧中所得律仪不弃舍故。犹胜一切在家白衣。犯性罪者尚应如是。况犯其余诸小遮罪。是故不许国王大臣诸在家者轻慢谪罚。所以者何。善男子。乃往过去有迦奢国王名梵授。敕旃荼罗。有大象王名青莲目。六牙具足住雪山边。汝可往彼拔取牙来。若不得者。汝等五人定无活义。时旃荼罗为护身命。执持弓箭被赤袈裟。诈现沙门威仪形相。往雪山边至象王所。时彼母象遥见人来执持弓箭惊怖驰走诣象王所。白言大天。今见有人张弓捻箭徐行视觇来趣我等。将非我等命欲尽耶。象王闻已举目便见剃除须发著袈裟人。即为母象而说颂曰

  被殑伽沙等　　诸佛法幢相
  观此离诸恶　　必不害众生

时彼母象以颂答曰

  虽知被法服　　而执持弓箭
  是恶旃荼罗　　乐恶无悲愍

时大象王复说颂曰

  见袈裟一相　　知是慈悲本
  此必归佛者　　愍念诸众生
  汝勿怀疑虑　　宜应速摄心
  被此法衣人　　欲渡生死海

时旃荼罗即以毒箭弯弓审射中象王心。母象见之举声号呴悲哀哽噎。以颂白言

  被此法衣人　　宜应定归佛
  威仪虽寂静　　而怀毒恶心
  应速踏彼身　　令其命根断
  灭此怨令尽　　以射天身故

时大象王以颂答曰

  宁速舍身命　　不应生恶心
  彼虽怀诈心　　犹似佛弟子
  智者非为命　　而坏清净心
  为度诸有情　　常习菩提行

时大象王心生悲愍。徐问人曰。汝何所须。彼人答曰。欲须汝牙。象王欢喜。即自拔牙施旃荼罗。而说颂曰

  我以白牙今施汝　　无忿无恨无贪惜
  愿此施福当成佛　　灭诸众生烦恼病

善男子当观。如是过去象王。虽受无睱傍生趣身为求阿耨多罗三藐三菩提故而能弃舍身命无吝。恭敬尊重著袈裟人。虽彼为怨而不加报。然未来世有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。实是愚痴怀聪明慢。谄曲虚诈欺诳世间。不见不畏后世苦果。于归我法而出家者若是法器若非法器诸弟子所恼乱呵骂或以鞭杖楚挞其身或闭牢狱乃至断命。此于一切过去未来现在诸佛。犯诸大罪。决定当趣无间地狱。断灭善根焚烧相续。一切智者之所远离。彼既造作如是重罪复怀傲慢诳惑世间。自称我等亦求无上正等菩提。我是大乘当得作佛。譬如有人自挑其目盲无所见。而欲导他登上大山。终无是处。于未来世有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。亦复如是。于归我法而出家者若是法器若非法器诸弟子所恼乱呵骂或以鞭杖楚挞其身或闭牢狱乃至断命。此于一切过去未来现在诸佛犯诸大罪。断灭善根焚烧相续。一切智者之所远离。决定当趣无间地狱。彼既造作如是重罪。复怀傲慢诳惑世间。自称我等亦求无上正等菩提。我是大乘当得作佛。彼由恼乱出家人故。下贱人身尚难可得。况当能证二乘菩提。无上大乘于其绝分。又善男子。过去有国名般遮罗。王号胜军。统领彼国。时彼有一大丘圹所名朅蓝婆。甚可怖畏药叉罗刹多住其中。若有入者心惊毛竖。时国有人罪应合死。王敕典狱缚其五处。送朅蓝婆大丘圹所。令诸恶鬼食啖其身。罪人闻已为护命故。即剃须发求觅袈裟。遇得一片自系其颈。时典狱者如王所敕。缚其五处送丘圹中。诸人还已至于夜分。有大罗刹母名刀剑眼。与五千眷属来入冢间。罪人遥见身心惊悚。时罗刹母见有此人被缚五处剃除须发片赤袈裟系其颈下。即便右绕尊重顶礼合掌恭敬。而说颂言

  人可自安慰　　我终不害汝
  见剃发染衣　　令我忆念佛

时罗刹子白其母曰

  母我为饥渴　　甚逼切身心
  愿听食此人　　息苦身心乐

时罗刹母便告子言

  被殑伽沙佛　　解脱幢相衣
  于此起恶心　　定堕无间狱

时罗刹子与诸眷属右绕此人尊重顶礼合掌恭敬。而说颂曰

  忏悔染衣人　　我宁于父母
  造身语意恶　　于汝终无害

尔时复有大罗刹母名驴骡齿。亦有五千眷属围绕来入冢间。时罗刹母亦见此人被缚五处剃除须发片赤袈裟系其颈下。即便右绕尊重顶礼合掌恭敬。而说颂言

  人于我勿怖　　汝颈所系服
  是仙幢相衣　　我顶礼供养

时罗刹子白其母曰

  人血肉甘美　　愿母听我食
  增长身心力　　勇猛无所畏

时罗刹母便告子言

  人天等妙乐　　由恭敬出家
  故供养染衣　　当获无量乐

时罗刹子与诸眷属。右绕此人尊重顶礼合掌恭敬。而说颂曰

  我今恭敬礼　　剃发染衣人
  愿常于未来　　见佛深生信

尔时复有大罗刹母名鬇鬤发。亦有五千眷属围绕来入冢间。时罗刹母亦见此人被缚五处剃除须发片赤袈裟系其颈下。即便右绕尊重顶礼合掌恭敬。而说颂言

  大仙幢相衣　　智者应赞奉
  若能修供养　　必断诸有缚

时罗刹子白其母曰

  此人身血肉　　国王之所赖
  愿听我饮啖　　得力承事母

时罗刹母便告子言

  如是染衣人　　非汝所应食
  于此起恶者　　当成大苦器

时罗刹子与诸眷属右绕此人尊重顶礼合掌恭敬。而说颂曰

  汝是大仙种　　堪为良福田
  故我修供养　　愿绝诸有缚

尔时复有大罗刹母名刀剑口。亦有五千眷属围绕来入冢间。时罗刹母亦见此人被缚五处剃除须发片赤袈裟系其颈下。即便右绕尊重顶礼合掌恭敬。而说颂言

  汝今被法衣　　必趣涅槃乐
  故我不害汝　　恐诸佛所呵

时罗刹子白其母曰

  我常吸精气　　饮啖人血肉
  愿听食此人　　令色力充盛

时罗刹母便告子言

  若害著袈裟　　剃除须发者
  必堕无间狱　　久受大苦器

时罗刹子与诸眷属右绕此人尊重顶礼合掌恭敬。而说颂曰

  我等怖地狱　　故不害汝命
  当解放汝身　　愿脱地狱苦

时诸罗刹母子眷属同起慈心解此人缚。忏谢慰喻欢喜放还。此人清旦疾至王所。以如上事具白于王。时胜军王及诸眷属。闻之惊跃叹未曾有。即立条制颁告国人。自今已后于我国中。有佛弟子若持戒若破戒下至无戒但剃须发被服袈裟。诸有侵凌或加害者。当以死罪而刑罚之。由此因缘众人慕德渐渐归化王赡部洲。皆共诚心归敬三宝。善男子。当观如是过去罗刹。虽受无暇饿鬼趣身。吸人精气饮啖血肉。恶心炽盛无有慈悲。而见无戒剃除须发。以片袈裟挂其颈者。即便右绕尊重顶礼恭敬赞颂无损害心。然未来世。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。心怀毒恶无有慈愍。造罪过于药叉罗刹。愚痴傲慢断灭善根。于归我法而出家者若是法器若非法器剃除须发被服袈裟诸弟子所。不生恭敬。恼乱呵骂或以鞭杖楚橽其身或闭牢狱乃至断命。此于一切过去未来现在诸佛。犯诸大罪。断灭善根焚烧相续。一切智者之所远离。决定当生无间地狱。又善男子。昔有国王名超福德。有人犯过罪应合死。王性仁慈不欲断命。有一大臣多诸智策前白王曰。愿勿为忧。终不令王得杀生罪。不付魁脍令杀此人。时彼大臣以己智力将犯罪人付恶醉象。时恶醉象以鼻卷取罪人两胫举上空中尽其势力欲扑于地。忽见此人裳有赤色。谓是袈裟心生净信。便徐置地忏谢悲号。跪伏于前以鼻抆足。深心敬重瞻仰彼人。大臣见已驰还白王。王闻喜愕叹未曾有。便敕国人加敬三宝。因斯断杀王赡部洲。善男子。当观如是过去醉象。虽受无睱傍生趣身。而敬袈裟不造恶业。然未来世有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。心怀毒恶无有慈愍。造诸罪业过恶醉象。愚痴傲慢断灭善根。于归我法而出家者若是法器若非法器剃除须发被服袈裟诸弟子所。不生恭敬。恼乱呵骂或以鞭杖楚挞其身或闭牢狱乃至断命。此于一切过去未来现在诸佛犯诸大罪。断灭善根焚烧相续。一切智者之所远离。决定当生无间地狱。若刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。成就如是第三恶轮。由此因缘令护国土一切天龙药叉神等信敬三宝无动坏者于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿。广说乃至彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言。受诸苦毒痛切难忍命终定生无间地狱

复次善男子。于未来世此佛土中。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。随恶友行善根微少。广说乃至。不见不畏后世苦果。见有所施四方僧物。谓诸寺舍或寺舍物。或诸园林或园林物。或诸庄田或庄田物。或所摄受净人男女。或所摄受畜生种类。或所摄受衣服饮食。或所摄受床座敷具。或所摄受病缘医药。或所摄受种种资身应受用物。如是所施四方僧物。具戒富德精进修行学无学行乃至证得最后极果。清净苾刍所应受用。彼刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。以强势力侵夺。具戒清净苾刍不听受用。回与破戒恶行苾刍经营在家诸俗业者。令共受用或独受用。破戒苾刍既受得已。或共受用或独受用。或与俗人同共受用。由是因缘。令护国土一切天龙药叉神等信敬三宝无动坏者。于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱

复次善男子。于未来世此佛土中。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。随恶友行善根微少。广说乃至。不见不畏后世苦果。见依我法而出家者聪睿多闻语甚圆满或能传通声闻乘法或能传通独觉乘法或能传通无上乘法令广流布利乐有情。彼于如是说法师所。呵骂毁辱诽谤轻弄欺诳逼迫恼乱法师障碍正法。由是因缘。令护国土一切天龙药叉神等信敬三宝无动坏者于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱

复次善男子。于未来世此佛土中。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。随恶友行善根微少。广说乃至。不见不畏后世苦果。见有所施四方僧物。寺舍庄田人畜财宝花树果树染树荫树香药树等及余资身种种杂物。我诸弟子具戒富德精进修行学无学行乃至证得最后极果清净苾刍所应受用。彼刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。以强势力或自逼夺或教人夺。或为自用或为他用。由是因缘。令护国土一切天龙药叉神等信敬三宝无动坏者于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱

复次善男子。于未来世此佛土中。有刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。善根微少无有信心。谄曲愚痴怀聪明慢。言无真实远离善友随恶友行。于诸圣法心怀犹豫。不见不畏后世苦果。常乐习近诸恶律仪。好行杀生乃至邪见。而怀傲慢诳惑世间。自称我是住律仪者。彼刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人。种种方便毁灭我法。于归我法而出家者数数嗔忿呵骂毁辱拷楚禁闭割截支节乃至断命。我所说法不肯信受。坏窣堵波及诸寺舍。驱逼苾刍退令还俗。障碍剃发被服袈裟。种种驱使同诸仆庶。由是因缘。令护国土一切天龙药叉神等信敬三宝无动坏者于刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人心生嗔忿。广说乃至。彼刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱

善男子。若刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。于上所说十种恶轮或随成一或具成就。先所修集一切善根摧坏烧灭皆为灰烬。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱。此刹帝利旃荼罗王宰官居士长者沙门婆罗门等旃荼罗人。于当来世下贱人身尚难可得。况当能证二乘菩提。无上大乘于其绝分。如是恶人大乘名字尚难得闻。况当能证无上佛果。是人究竟自损损他。一切诸佛所不能救

善男子。譬如有人压油为业。一一麻粒皆有虫生。以轮压之油便流出。汝当观此压麻油人于日夜中杀几生命。假使如是压麻油人以十具轮相续恒压于一日夜一一轮中所压麻油数满千斛。如是相续至满千年。汝观此人杀几生命。所获罪业宁为多不。地藏菩萨摩诃萨言。甚多世尊。甚多大德。此人所杀无量无边。所获罪业不可称计。算数譬喻所不能及。唯佛能知余无知者。佛言善男子。假使有人为财利故置十淫坊。一一坊中置千淫女。一一淫女种种庄严。诳惑多人恒为欲事。如是相续至满千年。此人获罪不可称计。算数譬喻所不能及。如前十轮压油人罪等一淫坊所获罪业。又善男子。假使有人为财利故置十酒坊。一一坊中种种严饰。方便招诱千耽酒人饮兴欢娱昼夜无废。如是相续至满千年。此人获罪不可称计。算数譬喻所不能及。如前所说十淫坊罪等一酒坊所获罪业。又善男子。假使有人为财利故置十屠坊。一一坊中于一日夜杀害千生。牛羊驼鹿鸡猪等命。如是相续至满千年。此人获罪不可称计。算数譬喻所不能及。如前所说十酒坊罪等一屠坊所获罪业。如前所说十屠坊罪等刹帝利旃荼罗王乃至沙门婆罗门等旃荼罗人于前十恶随成一轮一日一夜所获罪业。尔时世尊。而说颂曰

  十压油轮罪　　等彼一淫坊
  置彼十淫坊　　等一酒坊罪
  置十酒坊罪　　等彼一屠坊
  置彼十屠坊　　罪等王等一

大乘大集地藏十轮经卷第四
大乘大集地藏十轮经卷第五

        三藏法师玄奘奉　诏译

    无依行品第三之三

尔时地藏菩萨摩诃萨。复白佛言。大德世尊。若有真善刹帝利真善宰官真善居士真善长者真善沙门真善婆罗门。如是等人能自善护亦善护他善护后世善护佛法。出家之人若是法器若非法器下至无戒剃除须发被袈裟者普善守护恭敬供养。又能善护声闻乘法缘觉乘法及大乘法。恭敬听闻信受供养。于住大乘具戒富德精勤修行乃至住果补特伽罗。能善守护助其势力。咨问听受欢喜谈论。远离破戒恶行苾刍。于诸所施四方僧物。终不令人非法费用勤加守护供四方僧。于窣堵波及僧祇物。终不自夺不教他夺亦不自用不教他用。于能辩说三乘法人恭敬供养加护与力。不令他人诽谤毁辱。尊重安慰诸出家人。信受护持佛所说法。终不破坏诸窣堵波。亦常护持僧伽蓝舍。于剃须发被服袈裟出家人所。终不毁废。于十恶轮自不染习。亦常劝他离十恶轮。具学先王治国正法。绍三宝种常令炽盛。恒乐亲近诸善知识。慈心抚育一切国人。随其所宜方便化导。令舍邪法。修行正法。如是真善刹帝利王乃至真善婆罗门等。得几所福灭几所罪

佛言。善男子。假使有人出现世间具大威力。于日初分积集七宝满赡部洲奉施诸佛及弟子众。于日中分亦集七宝满赡部洲。奉施诸佛及弟子众。于日后分亦集七宝满赡部洲。奉施诸佛及弟子众。如是日日相续布施满百千年。此人福聚宁为多不。地藏菩萨摩诃萨言。甚多世尊甚多大德。此人福聚无量无边不可称计算数譬喻所不能及。惟佛能知余无知者。佛言。善男子。如是如是。如汝所说。若有真善刹帝利王乃至真善婆罗门等。于十恶轮自不染习。亦常劝他离十恶轮。所获福聚过前福聚无量无边不可称计。又善男子。假使有人出现世间具大威力。为四方僧营建寺宇。其量宽广等四大洲。上妙房舍床敷衣服饮食医药资缘充备。令诸如来声闻菩萨大弟子众止住其中。精进修行种种善品。若昼若夜无有懈息。经百千俱胝那庾多岁。供给供养相续不绝。此人福聚宁为多不。地藏菩萨摩诃萨言。甚多世尊甚多大德。此人福聚无量无边不可称计。算数譬喻所不能及。惟佛能知余无知者。佛言。善男子。如是如是。如汝所说。又善男子。假使有人出现世间具大威力。为四方僧营建寺宇。宽广量等十四大洲。上妙房舍床敷衣服饮食医药资缘充备。令诸如来声闻菩萨大弟子众止住其中。精进修行种种善品。若昼若夜无有懈息。经百千俱胝那庾多岁供给供养相续不绝。此人福聚宁为多不。地藏菩萨摩诃萨言。甚多世尊甚多大德。此人福聚无量无边不可称计。算数譬喻所不能及。唯佛能知余无知者。佛言。善男子。如是如是。如汝所说。又善男子。假使有人出现世间具大威力。为佛舍利起窣堵波。严丽高广量等三千大千世界如前所说。为四方僧造寺福聚类此所说为佛舍利起窣堵波所获福聚。于百分中不及其一于千分中亦不及一于百千分亦不及一于俱胝分亦不及一那庾多分数分算分计分喻分乃至邬波尼杀昙分亦不及一。又善男子。假使有得波罗蜜多具八解脱静虑等至大阿罗汉。遍满三千大千世界。如稻麻竹苇甘蔗丛林。一切皆被坚缚五处经百千年。时有一人出现于世。具大威力乐福德故。悉解被缚诸阿罗汉。香汤澡浴奉施衣钵。经百千年给上房舍床敷衣服饮食医药种种所须如法资具。诸阿罗汉般涅槃已。供养焚烧收取舍利。以妙七宝起窣堵波安置其中。复以种种宝幢幡盖香花伎乐而供养之。如前所说为佛舍利起窣堵波所获福聚。类此所说解阿罗汉供养福聚。于百分中不及其一于千分中亦不及一于百千分亦不及一于俱胝分亦不及一那庾多分数分算分计分喻分乃至邬波尼杀昙分亦不及一。善男子。若有真善刹帝利王乃至真善婆罗门等。于十恶轮自不染习。亦常劝他离十恶轮。所获福德过前福聚。无量无边不可称计。如生福数灭罪亦尔

善男子。若有真善刹帝利王及诸真善宰官居士长者沙门婆罗门等。于未来世后五百岁法欲灭时。能善护持我之法眼。能自善护亦善护他善护后世善护我法。出家弟子若是法器若非法器下至无戒剃除须发被袈裟者。普善守护恭敬供养令无损恼。又能善护三乘正法。听受供养声闻法时。于独觉乘及大乘法不生诽谤于独觉乘及大乘人亦不憎嫉。听受供养独觉法时。于声闻乘及大乘法不生诽谤。于声闻乘及大乘人亦不憎嫉。听受供养大乘法时。于声闻乘独觉乘法不生诽谤。于声闻乘独觉乘人亦不憎嫉。于声闻乘独觉乘法不求趣证。唯求趣证大乘正法。于住大乘具戒富德精勤修行乃至住果补特伽罗。多数亲近承事供养深心敬重请问听受。远离破戒恶行苾刍。于诸所施四方僧物。终不令人非法费用。勤加守护供四方僧。于窣堵波及僧祇物。终不自夺不教他夺。亦不自用不教他用。于能辩说三乘法人。恭敬供养加护与力。不令他人诽谤毁辱。尊重安慰诸出家人。信受护持如来圣教。终不破坏诸窣堵波。亦常护持四方僧寺。于我出家诸弟子所终不毁废还俗策使。于十恶轮自不染习。亦常劝他离十恶轮。具学先王治国正法十善业道摄化世间。常当亲近诸善知识。绍三宝种常令炽盛善护法眼令不灭没。如是真善刹帝利王乃至真善婆罗门等。由具如是诸功德故。名不虚受国人俸禄。一切天龙药叉鬼神乃至羯吒布怛那等。皆生欢喜。慈悲拥护。一切法器真实福田。亦生欢喜慈悲护念。由是因缘。所居国土及诸有情。展转炽盛安隐丰乐。邻国兵戈不能侵害。皆敬慕德自来归附。由此展转劝修善业枯竭恶趣增长天人。守护身命令得长远。自灭烦恼亦令他灭。住持菩提道六波罗蜜多。破坏一切众邪恶道。于生死海不久沉沦。常离恶友常近善友。生生常遇诸佛菩萨。恭敬承事曾无暂废。不久皆当随心所乐各各安住于佛国土。证得无上正等菩提

尔时众中一切天帝及诸眷属乃至一切毕舍遮帝及诸眷属。从座而起顶礼佛足合掌恭敬而白佛言。大德世尊。于未来世后五百岁。于此佛土法欲灭时。若有真善刹帝利王乃至真善婆罗门等。于十恶轮自能远离亦能劝他令其远离。善护自他善护后世护持正法绍三宝种皆令炽盛无有断绝。以要言之如佛所说。如是等人于三乘法恭敬听受终不隐藏于三乘人护持供养不令扰恼。于三宝物勤加守护不令侵损。我等眷属于此真善刹帝利王乃至真善婆罗门等。勤加拥护令其十法皆得增长。何等为十。一者增长寿命。二者增长无难。三者增长无病。四者增长眷属。五者增长财宝。六者增长资具。七者增长自在。八者增长名称。九者增长善友。十者增长智慧。大德世尊。若彼真善刹帝利王乃至真善婆罗门等。于十恶轮自能远离亦能劝他令其远离。具前所说诸功德者。我等拥护定当得此十法增长。复次世尊。若有真善刹帝利王乃至真善婆罗门等。成就如前所说功德。我等眷属勤加拥护。令于十法皆得远离。何等为十。一者远离一切怨家寇敌。二者远离一切非爱色声香味触境。三者远离一切障疠疾病。四者远离一切邪执恶见五者远离一切邪妄归依。六者远离一切邪恶灾怪。七者远离一切邪恶事业。八者远离一切邪恶知识。九者远离一切居家淤泥。十者远离一切非时夭丧。大德世尊。若彼真善刹帝利王乃至真善婆罗门等。成前所说诸功德者。我等拥护。定当得此十法远离。复次世尊。若有真善刹帝利王。具修如前所说功德令圆满者。我等眷属勤加拥护。令此帝王并诸眷属及其国土一切人民。令于十法皆得远离。何等为十。一者远离一切他国怨敌。二者远离一切自国怨敌。三者远离一切凶恶鬼神。四者远离一切愆阳亢旱。五者远离一切伏阴滞雨。六者远离一切非时寒热烈风暴雨霜雹灾害。七者远离一切恶星变怪。八者远离一切饥馑荒俭。九者远离一切非时病死。十者远离一切邪执恶见。大德世尊。若彼真善刹帝利王。具修如前所说功德令圆满者。我等眷属勤加拥护。令此帝王并诸眷属及其国土一切人民定当得此十法远离

尔时世尊赞诸天帝及其眷属乃至一切毕舍遮帝及眷属言。善哉善哉。汝等乃能发此誓愿。此事皆是汝等应作。由是因缘当令汝等长夜安乐。

尔时天藏大梵复白佛言。世尊。唯愿听我为未来世此佛土中一切真善刹帝利王说能护国不退轮心大陀罗尼明咒章句。由此护国不退轮心大陀罗尼明咒章句威神力故。令未来世此佛土中一切真善刹帝利王不为一切怨敌恶友之所摧伏。能令一切怨敌恶友自然退散。能善护持身语意业。为诸智者常所称赞。离诸恶法常行善法。常离一切邪见邪归。常于大乘精进修行勇猛坚固。常能成就无量无数所化有情。智不依他自然善巧。具能修行六到彼岸珍宝伏藏。远离一切忿悭嫉等烦恼缠垢。常为一切人非人等恭敬护念。诸有所为心无忘失。不舍有情乐四摄事。常不远离法器福田。佛言天藏。吾今恣汝为未来世此佛土中一切真善刹帝利王。说能护国不退轮心大陀罗尼明咒章句。由此护国不退轮心大陀罗尼明咒章句威神力故。令未来世此佛土中一切真善刹帝利王。不为一切怨敌恶友之所摧伏。广说乃至。常不远离一切诸佛及佛弟子。尔时天藏大梵即说护国不退轮心大陀罗尼明咒章句

怛绖他(唐言谓)牟尼冒[口*(隸-木+士)](一)牟那揭腊茷(二)牟尼纥梨达曳(三)牟尼嚧诃毗折(常列反)隶(四)牟那曷栗制(五)牟尼笈谜(六)束讫罗博差(七初戒反)钵逻奢博差(八初戒反)蜜罗博差(九初戒反)骚剌婆纥栗帝(十)妒剌拏纥栗折(章列反)隶(十一)钵怛逻叉纥栗帝(十二)具具拏蜜隶(十三)唈(乌合反)茷叉萨隶(十四)遏怒诃只[口*履]茷(十五)牟尼钵塔茷(十六)莎诃(唐言善说)

天藏大梵。说是咒已复白佛言。唯愿世尊及诸大众。于我所说大陀罗尼皆生随喜。世尊告曰。善哉善哉。一切大众亦作是言。善哉善哉

尔时世尊复告尊者大目乾连。及告弥勒菩萨摩诃萨曰。善男子。汝等皆应受持如是天藏大梵所说护国不退轮心大陀罗尼明咒章句。传授未来此佛土中一切真善刹帝利王。令自受持及令流布。由是因缘彼诸真善刹帝利王并诸眷属及国人民。一切皆得利益安乐常转法轮。名称高远威德炽盛。摧灭邪见建立正见守护法眼绍三宝种皆令炽盛无有断绝。成熟无量无边有情。于大乘中坚固净信。久住圆满能具修六波罗蜜多。断一切障速到究竟。尔时世尊重显此义。而说颂曰

  时天藏大梵　　请问两足尊
  利根等有情　　乐修定诵福
  聪慧王成法　　为升进沉沦
  所修三事中　　唯除惑不退
  世尊告彼言　　若犯无依行
  虽觉慧猛利　　而趣无间狱
  非真聪慧故　　乐行十恶轮
  断灭诸善根　　速趣于地狱
  定能断烦恼　　非听诵福业
  故欲求涅槃　　常当修静虑
  有慧勤精进　　护持我正法
  由敬信袈裟　　能渡烦恼海
  乐处空闲林　　远造无同类
  敬持戒修定　　能渡诸有海
  普信敬三乘　　兴隆我正法
  供养染衣者　　当成功德海
  能伏难调心　　不举苾刍罪
  修知足圣种　　当成两足尊
  远离恶苾刍　　亲近圣行处
  不食用僧物　　速证大菩提
  三界中安乐　　皆由三宝生
  故求安乐人　　常供养三宝
  旃荼罗王等　　朋党恶苾刍
  于三宝起过　　速堕无间狱
  十压油轮罪　　等彼一淫坊
  置彼十淫坊　　等一酒坊罪
  置十酒坊罪　　等彼一屠坊
  置彼十屠坊　　罪等王等一
  真善国王等　　兴隆我正法
  普供养三乘　　当成功德海
  七宝满赡部　　奉施佛及僧
  彼所获福聚　　不如护佛法
  为佛僧造寺　　量等十四洲
  彼所获福聚　　不如护佛法
  造佛窣堵波　　量等三千界
  彼所获福聚　　不如护佛法
  解阿罗汉缚　　种种修供养
  不障我正法　　其福胜于彼
  千俱胝劫中　　智者勤修定
  所生胜觉慧　　不如护我法
  真善国王等　　远离十恶轮
  护持我正法　　及著袈裟者
  不毁谤我说　　三乘法及人
  普听闻供养　　护持说法者
  不损三宝物　　不障著袈裟
  当敬器非器　　福胜无伦匹
  如五日并现　　大海皆枯竭
  如是护我法　　能枯竭烦恼
  如风灾起时　　诸山皆散灭
  如是护我法　　能除灭烦恼
  如水灾起时　　大地皆漂坏
  如是护我法　　能坏非爱果
  如如意宝珠　　随所愿皆满
  如是三乘法　　能满众生愿
  如遇得贤瓶　　除贫获富乐
  如是遇佛法　　灭惑证菩提
  如十五夜月　　明照满虚空
  如是护法人　　智慧周法界
  如虚空平等　　无物亦无相
  如是护法人　　知诸法一味
  如日放光明　　恒除世间闇
  如是护法者　　常普照世间

    大乘大集地藏十轮经有依行品第四之一

尔时金刚藏菩萨摩诃萨。于大众中从座而起。顶礼佛足偏袒一肩右膝著地合掌恭敬。以颂问曰

  昔言破戒失净德　　非贤圣器非我子
  诸沙门法弃如烬　　不应居我清众中
  三垢所污失灭道　　彼不堪消胜供养
  于施四方僧众物　　少分我亦不听受
  四根本罪随犯一　　清众所弃如海尸
  云何今说恶苾刍　　应忍应悲遮谪罚
  复劝应勤供养彼　　悲愍勿生微恶心
  恭敬听受所说法　　当获福慧大悲者
  六通救世余经说　　汝等皆当信大乘
  正直微妙菩提道　　应舍二乘解脱路
  云何今复说三乘　　普劝听持修供养
  根力觉道沙门果　　此经中有余处无
  八支圣道无等伦　　三乘皆同行此道
  欲求解脱勤精进　　各随所愿证菩提
  有情中尊当照察　　会今昔教使无违
  令诸天人菩萨众　　解悟心欢证真实
  闻说大乘谁有益　　闻说大乘谁有损
  十种解脱声闻乘　　闻说谁损谁有益
  何人闻法转升进　　何人闻法翻退没
  云何厌患诸有为　　能速枯竭于老死
  昼夜勤修诸善者　　依何妙理御何乘
  能渡深广四瀑流　　救世皆当为宣说

尔时佛告金刚藏菩萨摩诃萨言。善哉善哉善男子。汝今为欲利益安乐无量有情为诸天人阿素洛等作大义利。请问如来如是深义。汝应谛听善思念之。吾当为汝分别解说。金刚藏菩萨言。唯然世尊。愿乐欲闻

佛言善男子。有十种补特伽罗。轮回生死难得人身。何等为十补特伽罗。一者不种善根。二者未修福业。三者杂染相续。四者随恶友行。五者不见不畏后世苦果。六者猛利贪欲。七者猛利嗔恚。八者猛利愚痴。九者其心迷乱。十者守恶邪见。如是十种无依行因。令诸众生犯根本罪毁犯尸罗堕诸恶趣。何等名为十无依行。谓我法中而出家者。有加行坏意乐不坏有意乐坏加行不坏有加行意乐俱坏。有戒坏见不坏有见坏戒不坏有戒见俱坏。有于加行意乐戒见虽皆不坏而但依止恶友力行作无依行。有虽依止善友力行而复愚钝犹如哑羊于诸事业都不分别闻善友说善不善法不能领受不能记持不能解了善不善义由是因缘作无依行。有于种种财宝众具常无厌足追求因缘其心迷乱作无依行。有为众病之所逼恼便求种种祠祀咒术由是因缘作无依行。如是十种无依行因。令诸众生犯根本罪于现法中非贤圣器。毁犯尸罗堕诸恶趣。善男子。若有补特伽罗加行坏意乐不坏。随遇一种无依行因犯根本罪。便深怖惧惭愧弃舍。而不数数作诸恶行。如来为益彼故。说有污道沙门。所以者何。彼作如是重恶业已。即便发露不敢覆藏惭愧忏悔。彼由如是惭愧忏悔罪得除灭。永断相续不复更作。虽于一切沙门法事皆应摈出一切沙门所有资具不听受用。而由彼人于三乘中成法器故。如来慈悲或为彼说声闻乘法。或为彼说缘觉乘法或为彼说无上乘法。彼有是处转于第二第三生中发正愿力遇善友力。一切所作诸恶业障皆悉消灭。或有证得声闻乘果。或有证得缘觉乘果而般涅槃。或有悟入广大甚深无上乘理。如是戒坏见不坏者。应知亦尔。若有补特伽罗意乐坏加行不坏。如来为益彼故。说求四梵住法。彼是声闻乘器或是缘觉乘器。若有补特伽罗加行意乐俱坏。彼于诸乘皆非法器。如来为益彼故。赞说布施。若有补特伽罗见坏戒不坏。如来为益彼故。说缘起法令舍恶见于现身中入声闻法或缘觉法或于余身方能悟入。若有补特伽罗戒见俱坏。彼于圣法亦不成器。如来为益彼故。赞说布施。若有补特伽罗加行意乐戒见不坏而但依止恶友力行。如来为益彼故。赞说十善业道。若有补特伽罗虽复依止善友力行而复愚钝犹如哑羊不能领受善不善法。如来为益彼故。赞说习诵。若为种种贪病所逼。有为种种见趣迷惑。如来为益如是等故。求解脱者为其开示能出生死趣声闻乘四圣谛法。断见论者为其赞说诸缘起法。常见论者为说三界诸有诸趣死此生彼如陶家轮往来无绝无常等法。善男子。如来无有所说名字言说音声空无果者。无不皆为成熟有情。是故一切毁谤如来所说正法。坏诸有情正法眼罪。过诸无间似无间等无量重罪。若有于我为欲利乐一切有情所说正法。谓依声闻乘所说正法或依缘觉乘所说正法或依大乘所说正法诽谤遮止障蔽隐没下至一颂。当知是名谤正法者。亦名毁灭八圣道者。亦名破坏一切有情正法眼者。如是之人既自习行大无利行。亦令一切有情习行大无利行。此人依止无惭愧僧。如是毁谤如来正法

复次善男子。有四种僧。何等为四。一者胜义僧。二者世俗僧。三者哑羊僧。四者无惭愧僧。云何名胜义僧。谓佛世尊。若诸菩萨摩诃萨众。其德尊高于一切法得自在者。若独胜觉。若阿罗汉。若不还。若一来。若预流。如是七种补特伽罗。胜义僧摄。若诸有情带在家相。不剃须发不服袈裟。虽不得受一切出家别解脱戒一切羯磨布萨。自恣悉皆遮遣。而有圣法得圣果故胜义僧摄。是名胜义僧。云何名世俗僧。谓剃须发被服袈裟。成就出家别解脱戒。是名世俗僧。云何名哑羊僧。谓不了知根本等罪犯与不犯。不知轻重毁犯种种小随小罪不知发露忏悔所犯。憃愚鲁钝于微小罪不见不畏不依聪明善士而住。不时时间往诣多闻聪明者所亲近承事。亦不数数恭敬请问云何为善云何不善云何有罪云何无罪修何为妙作何为恶。如是一切补特伽罗哑羊僧摄。是名哑羊僧。云何名无惭愧僧。谓若有情为活命故。归依我法而求出家。得出家已于所受持别解脱戒一切毁犯无惭无愧。不见不畏后世苦果。内怀腐败如秽蜗螺贝音狗行常好虚言曾无一实。悭贪嫉妒愚痴憍慢离三胜业。贪著利养恭敬名誉。耽湎六尘好乐淫泆爱欲色声香味触境。如是一切补特伽罗无惭僧摄。毁谤正法是名无惭愧僧

善男子。胜义僧者。于中或有亦是胜道沙门所摄。言胜道者。谓若能依八支圣道。自度一切烦恼驶流亦令他度。此复云何。谓佛世尊及独胜觉诸阿罗汉。如是三种补特伽罗。已离一切有支眷属。故名胜道。复有菩萨摩诃萨众。不假他缘于一切法智见无障。摄受利乐一切有情。亦名胜道沙门所摄。其胜义僧及世俗僧于中或有亦是示道沙门所摄。若有成就别解脱戒真善异生。乃至具足世间正见。彼由记说变现力故。能广为他宣说开示诸圣道法。当知如是补特伽罗。名最下劣示道沙门。证预流果补特伽罗是名第二。证一来果补特伽罗是名第三。证不还果补特伽罗是名第四。复有菩萨摩诃萨众。是名第五。谓住初地至第十地。乃至安住最后有身。此皆示道沙门所摄。若有成就别解脱戒轨则所行清净具足。此皆命道沙门所摄。以道活命故名命道。复有菩萨摩诃萨众。为欲摄受利益安乐一切有情。具足修行六到彼岸亦名命道。如是胜道示道命道三种沙门。名为世间真实福田。所余沙门名为污道。虽非真实。亦得堕在福田数中

若有依止无惭愧僧补特伽罗。于我正法毗奈耶中名为死尸。于清众海应当摈弃非法器故。我于彼人不称大师。彼人于我亦非弟子。有无惭僧不成法器称我为师。于我舍利及我形像深生敬信。于我法僧圣所爱戒亦深敬信。既不自执诸恶邪见。亦不令他执恶邪见。能广为他宣说我法。称扬赞叹不生毁谤。常发正愿随所犯罪数数厌舍。发露忏悔众多业障皆能除灭。当知如是补特伽罗。信敬三宝圣戒力故。胜九十五诸外道众多百千倍。非速能入般涅槃城。转轮圣王尚不能及。况余杂类一切有情。以是义故如来观察一切有情诸业法受差别相已作如是说。于我法中。剃除须发被袈裟者。我终不听刹帝利等毁辱谪罚。若有毁辱谪罚一切出家之人。所获罪报如前广说。又依我法舍俗出家。剃除须发被赤袈裟。即为一切过去未来现在诸佛慈悲护念。威仪形相所服袈裟。亦为过去未来现在诸佛世尊慈悲守护。是故轻毁剃除须发被赤袈裟出家人者即是轻毁一切过去未来现在诸佛世尊。由是因缘诸有智慧厌怖众苦欣求人天涅槃乐者。不应轻毁舍俗出家剃除须发被袈裟者。有无惭僧毁破禁戒。不成三乘贤圣法器。既自坚执诸恶邪见亦能令他执恶邪见。谓为真善刹帝利真善婆罗门真善宰官真善居士真善沙门真善长者真善茷舍真善戌达罗若男若女说诸世间无父无母乃至无有善业恶业所得果报。无有能得圣道果者。一切诸法不从因生。或有执言色界是常非变坏法。或有执言无色界常非变坏法。或有执言外道所计诸苦行法得究竟净。或有执言唯声闻乘得究竟净非独觉乘亦非大乘。于声闻乘信敬称赞宣说开示。于独觉乘及于大乘。诽谤轻毁障蔽隐没不令流布。或有执言唯独觉乘得究竟净非声闻乘亦非大乘。于独觉乘信敬称赞宣说开示。于声闻乘及于大乘。诽谤轻毁障蔽隐没不令流布。或有执言唯有大乘得究竟净非声闻乘非独觉乘。于大乘法既自生信教他生信。既自恭敬教他恭敬。既自称赞教他称赞。既自书写教他书写。既自读诵教他读诵。既自听受教他听受。既自思惟教他思惟。于他有情若是法器若非法器。皆为广说开示解释微细甚深大乘法义。于声闻乘及独觉乘。诽谤轻毁障蔽隐没不令流布。自不生信障他生信。自不恭敬障他恭敬。自不称赞障他称赞。自不书写障他书写。自不读诵听受思惟。障他读诵听受思惟。不乐广说开示解释三乘法义。或有执言唯修布施得究竟净非戒非忍乃至非慧。或有执言唯修禁戒得究竟净非施非忍乃至非慧。或有执言唯修安忍得究竟净非施非戒乃至非慧。或有执言唯修精进得究竟净非施非戒乃至非慧。或有执言唯修静虑得究竟净非施非戒乃至非慧。或有执言唯修般若得究竟净非施非戒乃至非定。或有执言唯修种种世间所习诸伎艺智得究竟净。或有执言唯修种种投岩赴火自饿等行得究竟净

善男子。如是破戒恶行苾刍非法器者。种种诳惑真善法器诸有情等。令执恶见。彼由颠倒诸恶见故。破坏真善刹帝利王乃至真善戌达罗等若男若女所有净信戒闻舍慧。转刹帝利成旃荼罗。乃至茷舍戌达罗等成旃荼罗。此非法器破戒苾刍并刹帝利旃荼罗等。师及弟子俱断善根。乃至当堕无间地狱。善男子。如人死尸膀胀烂臭。诸来见者皆为臭熏。随所触近烂臭死尸。或与交玩随被臭秽之所熏染。如是真善刹帝利王乃至真善戍达罗等若男若女。随所亲近破戒恶行非法器僧。或与交游或共住止或同事业。随被恶见臭秽熏染。如是如是。令彼真善刹帝利王乃至真善戍达罗等若男若女退失净信戒闻舍慧成旃荼罗师及弟子俱断善根。乃至当堕无间地狱

大乘大集地藏十轮经卷第五
大乘大集地藏十轮经卷第六

        三藏法师玄奘奉　诏译

    有依行品第四之二

善男子。汝观如是刹帝利等无量有情。亲近如是破戒恶行非法器僧。退失一切所有善法。乃至当堕无间地狱。是故欲得上妙生天涅槃乐者。皆应亲近承事供养胜道沙门咨禀听闻三乘要法或求示道命道沙门。若无如是三道沙门。当于污道沙门中求。虽复戒坏而有正见具足意乐及加行者。应往亲近承事供养咨禀听闻三乘要法。不应亲近承事供养加行意乐及见坏者。彼虽戒坏而无邪见。意乐加行见具足故。应诣其所咨禀听闻声闻乘法独觉乘法及大乘法不应轻毁。于三乘中随意所乐发愿精进随学一乘。于所余乘不应轻毁。若于三乘随轻毁一下至一颂。不应亲近或与交游或共住止或同事业。若有亲近或与交游或共住止或同事业。俱定当堕无间地狱。善男子。是故若欲于三乘中随依一乘求出生死欣乐安乐厌危苦者。应于如来所说正法或依声闻乘所说正法或依独觉乘所说正法或依大乘所说正法普深信敬勿生谤毁障蔽隐没下至一颂。常应恭敬读诵听闻。应发坚牢正愿求证。谤毁三乘随一法者不应共住下至一宿。不应亲近咨禀听法。若诸有情随于三乘毁谤一乘。或复亲近谤三乘人咨禀听受。由此因缘皆定当堕无间地狱受大苦恼难有出期。何以故善男子。我于过去修菩萨行精勤求证无上智时。或为求请依声闻乘所说正法下至一颂乃至弃舍自身手足血肉皮骨头目髓脑。或为求请依独觉乘所说正法下至一颂。乃至弃舍自身手足血肉皮骨头目髓脑。或为求请依于大乘所说正法下至一颂。乃至弃舍自身手足血肉皮骨头目髓脑。如是勤苦。于三乘中下至求得一颂法已。深生欢喜恭敬受持。如说修行时无暂废。经无量劫修行一切难行苦行。乃证究竟无上智果。复为利益安乐有情。宣说开示三乘正法。以是义故。不应谤毁障蔽隐没下至一颂。常应恭敬读诵听闻。应发坚牢正愿求证善男子。如是三乘出要正法。一切过去未来现在。过殑伽沙诸佛同说。大威神力共所护持。为欲拔济一切有情生死大苦。为欲绍隆三宝种姓令不断绝。是故于此三乘正法。应普信敬勿生谤毁障蔽隐没若有谤毁障蔽隐没三乘正法下至一颂。决定当堕无间地狱

复次善男子。于未来世此佛土中。有刹帝利旃荼罗婆罗门旃荼罗。宰官旃荼罗。居士旃荼罗。沙门旃荼罗。长者旃荼罗。茷舍旃荼罗。戌达罗旃荼罗。若男若女。谄曲愚痴怀聪明慢。其性凶悖懆厉粗犷。不见不畏后世苦果。好行杀生乃至邪见嫉妒悭贪。憎背善友亲近恶友。非是三乘贤圣法器。或少听习声闻乘法便于诸佛共所护持独觉乘法无上乘法。诽谤毁呰障蔽隐没不令流布。或少听习独觉乘法。便于诸佛共所护持声闻乘法无上乘法。诽谤毁呰障蔽隐没不令流布。或少听习无上乘法。便于诸佛共所护持声闻乘法独觉乘法。诽谤毁呰障蔽隐没不令流布。为求名利唱如是言。我是大乘是大乘党。唯乐听习受持大乘不乐声闻独觉乘法。不乐亲近学二乘人。如是诈称大乘人等。由自愚痴憍慢势力。如是谤毁障蔽隐没三乘正法不令流布。憎嫉修学三乘法人。诽谤毁辱令无威势。善男子。一切过去未来现在诸佛世尊及诸菩萨摩诃萨。为欲利乐一切有情。以大悲力护持二事。一者为欲绍隆三宝种姓常令不绝。舍俗出家剃除须发被服袈裟。二者三乘出要四圣谛等相应正法。如是二事。唯佛世尊及大菩萨能善护持。非诸声闻独胜觉等。亦非百千那庾多数大梵天王及天帝释王四大洲转轮王等所能护持。于未来世此佛土中。有刹帝利旃荼罗王。见依我法而得出家剃除须发被袈裟者。方便伺求所犯过失。以种种缘呵骂毁辱或加鞭杖或闭牢狱或夺资具或脱袈裟废令还俗使作种种居家事业。或横驱役或滥摈遣或断饮食或害身命。彼刹帝利旃荼罗王。以己愚痴憍慢势力。毁辱谪罚诸佛菩萨以大悲力共所护持我诸弟子。诽谤毁灭诸佛菩萨以大悲力共所护持我甚深法。于其三世诸佛菩萨共所护持三乘正法。障蔽隐没不令流布。有刹帝利旃荼罗王乃至茷舍戌达罗等旃荼罗人若男若女。愚痴憍慢自号大乘。彼人尚非声闻独觉二乘法器。况是无上大乘法器。为求利养恭敬名誉。诳惑世间愚痴杂类。自言我等是大乘人。谤毁如来二乘正法。如是人等愚痴谄曲憍慢嫉妒悭贪因缘。毁我法眼令速隐灭。彼于三世一切诸佛犯大过罪。亦于三世一切菩萨犯大过罪又于三世一切声闻犯大过罪。不久便当支体废缺遭遇种种重恶疾病

彼刹帝利旃荼罗王。乃至茷舍戌达罗等旃荼罗人若男若女。由造恶业起倒见故损断一切所有善根。虽复有时多修施福于未来世当生鬼趣傍生趣中受富乐果而彼身中尚不能起色无色界下劣善根。况当能种声闻独觉及无上乘无功用起一切智智善根种子。又令其舌为病所害于多日夜结舌不言。受诸苦毒痛切难忍。命终定当生于无间大地狱中。是故如来慈悲怜愍一切真善刹帝利王乃至真善戌达罗等若男若女。令得长夜利益安乐。殷勤恳切作如是言。汝等应当于归我法剃除须发被片袈裟出家人所慎勿恼乱讥呵谪罚。于我所说三乘正教慎勿谤毁障蔽隐没。若违我言而故作者。所获罪报如前广说。所以者何。此归我法剃除须发被赤袈裟出家形相。乃是过去未来现在诸佛菩萨大悲神力之所护持。此剃须发被赤袈裟出家威仪。是诸贤圣解脱幢相。亦是一切声闻乘人受用解脱法味幢相。亦是一切独觉乘人受用解脱法味幢相。亦是一切大乘之人受用解脱法味幢相。如来所说三乘正法。亦是三世诸佛菩萨大悲神力之所护持。是诸贤圣解脱依止。亦是一切声闻乘人受用解脱法味依止。亦是一切独觉乘人受用解脱法味依止。亦是一切大乘之人受用解脱法味依止

善男子。以是义故求解脱者。应当亲近恭敬供养诸归我法剃除须发被赤袈裟出家之人应先信敬声闻乘法。若自听受教他听受。若自读诵教他读诵。若自书写教他书写。若自施与教他施与。若自宣说教他宣说。思惟修行广令流布。如是信敬独觉乘法。若自听受教他听受。若自读诵教他读诵。若自书写教他书写。若自施与教他施与。若自宣说教他宣说。思惟修行广令流布。如是信敬于大乘法。若自听受教他听受。若自读诵教他读诵。若自书写教他书写。若自施与教他施与。若自宣说教他宣说。思惟修行广令流布。若非器者。不应自听勿教他听。乃至广说又应远离一切恶法。应舍恶友应亲善友。应勤修习六到彼岸。应数忏悔一切恶业。应随所宜勤发正愿。若能如是斯有是处。现身得成声闻乘器。或独觉乘种子不退。或复大乘种子不退。是故三乘皆应修学。不应憍傲妄号大乘谤毁声闻独觉乘法。我先唯为大乘法器坚修行者。说如是言唯修大乘能得究竟。是故今昔说不相违。尔时世尊重显此义而说颂曰

  对诸大众前　　金刚藏问我
  云何劝供养　　破戒恶苾刍
  失杜多功德　　痴恶见所持
  非法器污道　　而不听谪罚
  复说从彼闻　　三乘微妙法
  真解脱良药　　趣寂静涅槃
  何故余经言　　一大乘解脱
  遮学二乘法　　今复说三乘
  哀愍诸有情　　令舍邪恶业
  得利益安乐　　愿为说除疑
  为益刹帝利　　乃至戌达罗
  不听恼苾刍　　恐彼染大罪
  剃发被袈裟　　诸佛法幢相
  诸佛等护持　　解脱道之眼
  虽破诸律仪　　非永遮解脱
  能舍诸恶见　　当速趣涅槃
  如腐败良药　　犹能疗众病
  如是破律仪　　亦能灭他苦
  不听彼苾刍　　在布萨羯磨
  许为他说法　　俱获福无疑
  若归敬三宝　　称我为大师
  能弃舍众恶　　胜诸外道众
  如堕罗刹渚　　商众悉惊惶
  各执兽一毛　　渡海得免难
  如是破戒者　　离诸恶邪见
  由一信为因　　脱烦恼罗刹
  由护解脱相　　诸佛等护持
  不恼破戒僧　　能离诸重恶
  诸乐多福人　　欣求真解脱
  等护器非器　　证解脱无难
  痴慢号大乘　　彼无有智力
  尚迷二乘法　　况能解大乘
  譬如阙坏眼　　不能见众色
  如是阙坏信　　不能解大乘
  无力饮池河　　讵能吞大海
  不习二乘法　　何能学大乘
  先信二乘法　　方能信大乘
  无信诵大乘　　空言无所益
  内真怀断见　　妄自号大乘
  不护三业罪　　坏乱我正法
  彼人命终后　　定堕无间狱
  故应观机说　　勿为非器者
  憍傲无慈悲　　暴恶志下劣
  智者应当知　　是坏断见者
  非声闻缘觉　　亦非大乘器
  谄毁谤诸佛　　必堕无间狱
  持戒乐喧闹　　悭法畏苦恶
  智者应当了　　是名声闻乘
  乐施观生灭　　常欣独静处
  智者应当了　　是名独觉乘
  具足诸善根　　守护慈悲本
  常乐摄利物　　是名为大乘
  舍身命护戒　　不恼害众生
  精进求空法　　应知是大乘
  心堪忍诸法　　善言无秘吝
  于法常欣乐　　应知是大乘
  法器非法器　　利乐心平等
  不染诸世法　　应知是大乘
  是故有智者　　普敬说三乘
  不恼我僧徒　　速成无上觉

复次善男子。若有真善刹帝利。真善婆罗门。真善宰官。真善居士。真善长者。真善沙门。真善茷舍。真善戌达罗。若男若女。成就十种有依行轮。于现身中速能种殖声闻乘种令不退失。或于现身成声闻乘诸圣法器。非独觉乘大乘圣器。何等为十。一者具足净信。信有一切善恶业果。二者具足惭愧。远离一切恶友恶见。三者安住律仪。远离杀生乃至饮酒。四者安住慈心。远离一切嗔恚忿恼。五者安住悲心。救拔一切羸弱有情。六者安住喜心。远离一切语四恶业。七者安住舍心。远离一切悭贪嫉妒。八者具正归依。远离一切妄执吉凶。终不归依邪神外道。九者具足精进。坚固勇猛修诸善法。十者常乐寂静。思求法义欢悦无倦。善男子。若有真善刹帝利王乃至真善戌达罗等若男若女。成此十种有依行轮。于现身中速能种殖声闻乘种令不退失。或于现身证声闻乘所有圣法。成声闻乘诸圣法器。非证独觉大乘圣法。非成独觉大乘圣器应知此中独觉大乘皆如是说。善男子。如是十种有依行轮。一切声闻独觉菩萨诸佛如来皆同共有

善男子。复有十种有依行轮不共声闻。唯与独觉菩萨如来皆同共有。若有真善刹帝利王乃至真善戌达罗等若男若女。成此十种有依行轮。于现身中速能种殖独觉乘种令不退失。或于现身证独觉乘所有圣法。成独觉乘诸圣法器。何等为十。一者修行清净身语意业。二者具足惭愧厌患自身。三者于五取蕴深生怖畏。四者见生死河极为难渡。五者常乐寂静离诸愦闹。六者乐阿练若不讥他失。七者守护诸根心常寂定。八者善观缘起审察因果。九者常乐勤修等持静虑。十者于集起法能善除灭。善男子。若有真善刹帝利王乃至真善戌达罗等若男若女。成此十种有依行轮。于现身中速能种殖独觉乘种令不退失。或于现身证独觉乘所有圣法。成独觉乘诸圣法器。善男子。是名一切声闻独觉有依行轮。一切声闻及诸独觉依止此轮。速能超渡三有大海。速能趣入般涅槃城

善男子。有依行轮。是何句义。言有依者。名有执取有我所依有所摄受有所系属。行谓蕴行界行处行。有系属行。轮谓教授教诫之轮。如转轮王所乘车轮或首行轮。如是一切声闻独觉。依止此轮求涅槃道。故此二种非大乘器。所以者何。由彼依止下劣行故非大乘器。由彼执取自诸蕴行惊怖厌患自求解脱一切忧苦。不求解脱一切有情而修行故非大乘器。由彼依止自诸界行。惊怖厌患自求解脱一切忧苦。不求解脱一切有情。而修行故非大乘器。由彼摄受自诸处行惊怖厌患自求解脱一切忧苦不求解脱一切有情。而修行故非大乘器。由彼系属有系属行于诸有情不乐摄受无有慈悲有系属故非大乘器。由彼观他具受众苦舍而不救但为自身求解脱故非大乘器。由彼自断诸烦恼首不乐断除一切有情诸烦恼首非大乘器。由彼不能驭大乘轮趣菩提故非大乘器。由彼不能随大光轮趣菩提故非大乘器。由彼喜乐独一无侣入涅槃城。而修行故非大乘器

善男子。有诸众生于声闻乘独觉乘法未作劬劳正勤修学。如是众生根机未熟。根机下劣精进微少。若有为说微妙甚深大乘正法。说听二人俱获大罪。亦为违逆一切诸佛。所以者何。若诸众生于声闻乘独觉乘法。未作劬劳正勤修学。根机未熟根机下劣。精进微少而便听受微妙甚深大乘正法如是众生实是愚痴自谓聪睿。陷断灭边坠颠狂想执无因论。于诸业果生断灭想。拨无一切善作恶作。妄说大乘坏乱我法。非法说法法说非法。实非沙门说是沙门。实是沙门说非沙门。实非毗奈耶说是毗奈耶实是毗奈耶说非毗奈耶。愚痴颠倒憍慢嫉妒朋党之心。于大乘法称赞拥卫令广流布。于声闻乘独觉乘法。谤毁障蔽不令流布。不能如实依声闻乘或独觉乘或无上乘。舍俗出家受具足戒成苾刍性。亦不如实修集一切善法因缘。于我弟子或是法器或非法器。谓勤修行学无学行乃至证得最后极果真善异生。持戒破戒无戒者所。种种毁骂呵啧恼乱。夺其衣钵不听受用诸资生具。系缚禁闭如是拨无一切因果断灭论者。虽在人中实是罗刹。于当来世无数大劫难得人身。宁在地狱受无量苦。不处人中起断灭见。如是痴人。不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱。于诸恶趣轮转往来受诸苦恼难可救济多百千劫难复人身。虽过无量无数劫已还得人身。而生五浊无佛世界。生盲生聋喑哑无舌。种种重病常所婴缠。或身矬丑人不喜见。言词拙讷耳所恶闻。心常迷乱无所解了。生贫穷家众事阙乏。不逢善友随恶友行乐作恶业。好执恶见造无间罪。复还重堕无间地狱。轮转恶趣难有出期。如是愚痴断灭论者坏乱毁灭我之正法。逼恼谪罚我诸弟子持戒破戒及无戒者。皆令不安修诸善品。由是因缘多百千劫没众恶趣。从闇入闇难有出期。如是众生所有罪报。皆为未求听习声闻独觉乘法先求听习微妙甚深大乘正法。如是愚痴断灭论者。下劣人身尚难可得。况当能成贤圣法器。尚不能得声闻独觉所证涅槃。况得广大甚深无上正等菩提。如是众生所有过失。皆由未学声闻乘法独觉乘法先入大乘。善男子。譬如坯瓶多诸瑕隙盛油乳等尽皆渗漏能盛所盛二俱坏失。所以者何。器有失故。如是众生于声闻乘独觉乘法。未作劬劳正勤修学。根机未熟根机下劣精进微少。若有为说微妙甚深大乘正法。说听二人俱获大罪。亦为违逆一切诸佛。所有过失广说如前。譬如世间库藏颓穴。置诸宝货多有散失。如是众生于二乘法谤毁不信不肯修学。为说大乘不如实解。因此造罪轮转无穷。譬如舟船多诸泄漏。不任乘载泛于大海。如是众生多怀悭嫉。于二乘法未曾修学。妄号大乘实怀断见。憍慢谄曲成泄漏身。不堪凭入一切智海。譬如有人其目盲瞽不堪呈示种种珍宝。如是众生憍慢放逸。执著空见不学二乘盲无慧目不任显示无上大乘功德珍宝。譬如有人其身臭秽。虽以种种上妙香涂而竟不能令身香洁。如是众生愚痴憍慢。于二乘法不乐勤修。不断杀生乃至邪见虽勤听受无上大乘。而竟不能解甚深法。譬如石田虽殖好种勤加营耨终无果实。如是众生于二乘法。憍慢懈怠不乐勤修。贪求五欲曾无厌倦。虽于彼身殖大乘种精进勤苦终无所成。譬如瓮器先贮毒药投少石蜜不任食用。如是众生于二乘法。不肯修学执无因论。为说大乘终不能成自他利益。譬如瓮器先贮石蜜投少毒药不任食用。如是众生精勤修学二乘正法犹未成就。为说大乘二俱坏失。譬如有人痴狂心乱为作音乐不能了知。如是众生于二乘法未曾修学。贪嗔痴等猛利烦恼扰乱其心。执著无因及断灭论。根机未熟。为说大乘。虽经多时而不能解。譬如有人不著甲胄不持刀仗辄入阵中必遭伤害受诸苦恼。如是众生于二乘法未曾修学。智慧狭劣根器未成。为说大乘。必生妄执。由此展转造恶无穷。如是痴人不久便当支体废缺于多日夜结舌不言受诸苦毒痛切难忍命终定生无间地狱。于诸恶趣轮转往来。应知如前次第广说

善男子。是故智者先应观察一切众心然后说法。先当发起慈心悲心喜心益心不懈怠心能忍受心不憍慢心不嫉妒心不悭吝心等引定心然后为他宣说正法。终不令他诸众生类闻所说法轮转生死堕大险难。是故如来善达一切众生心相。以无尘垢无取行轮为说正法。具大甲胄一切菩萨摩诃萨众。为他说法亦复如是。由悲愍故。为令断灭诸烦恼故。为令超渡三有海故。为诸众生于三乘中随心所乐随趣一乘速圆满故为说正法。终不令其轮转生死堕大险难。云何名无尘垢行轮。无尘垢者。谓说法时。不为有蕴。不为有处。不为有界。不为有欲界。不为有色界。不为有无色界。不为有此世。不为有他世。不为有诸行。不为有受。不为有想。不为有思。不为有触。不为有作意。不为有无明。乃至不为有老死。不为有行及不行故。为诸众生宣说正法。唯为一切诸蕴处界广说乃至行与不行皆寂灭故。为诸众生宣说正法。以是义故名无尘垢。行者。所谓为能永断死此生彼。为诸众生宣说正法。为能永断诸蕴处界广说乃至为能永断行与不行。为诸众生宣说正法。是名为行。轮者。所谓如满月光清凉无碍遍满虚空照触一切无障境界。如是如来及诸菩萨所有神通记说教诫三种胜轮。作用无碍遍诸世界利乐一切所化众生。令诸众生不异归趣。不共一切世间众生。不共一切声闻独觉。能令众生断灭生死诸苦恼法证得安乐菩提涅槃。是名为轮。如是名为诸佛菩萨无尘垢行轮。云何名为无取行轮。谓于诸法无所挂碍。犹如日光普照一切。三乘根器随其所宜宣说正法无所执著。谓诸如来为诸众生说如是法。犹如虚空无差别相。以无量定游戏自在庄严住持为诸众生说微妙法无所执著。具大甲胄一切菩萨摩诃萨众。为他说法亦复如是。谓说诸法非有非空。非即色空。非离色空。乃至非即识空。非离识空。非即眼空。非离眼空。乃至非即意空。非离意空。非即色空。非离色空。乃至非即法空。非离法空。非即眼识空。非离眼识空。乃至非即意识空。非离意识空。非即欲界空。非离欲界空。乃至非即虚空无边处空。非离虚空无边处空。非即识无边处空。非离识无边处空。非即无所有处空。非离无所有处空非即非想非非想处空。非离非想非非想处空。非即四念住空。非离四念住空。乃至非即八支圣道空。非离八支圣道空。非即缘起法空。非离缘起法空。非即三不护空。非离三不护空。非即四无所畏空。非离四无所畏空。非即十力空。非离十力空。非即十八不共法空。非离十八不共法空。非即大慈大悲大喜大舍空。非离大慈大悲大喜大舍空。非即涅槃空。非离涅槃空。是名如来及诸菩萨为诸众生宣说处中微妙正法。善男子。如是如来为诸众生。以无尘垢行轮说法。如满月光清凉无碍遍满虚空照触一切无障境界。乃至广说。又以无取行轮说微妙法。于一切法无所挂碍。犹如日光普照一切。三乘根器随其所宜。宣说正法无所执著。谓诸如来为诸众生说如是法。犹如虚空无差别相。以无量定游戏自在庄严住持。为诸众生说微妙法无所执著。令于三乘随宜趣入。具大甲胄一切菩萨摩诃萨众。为他说法亦复如是。令诸众生闻此最胜甚深法已于三乘中随其所乐随趣一乘种种善根皆得成熟。随于一乘极善安住。终不令其于生死中增长种种恶不善法。令于涅槃坚固不退

善男子。菩萨摩诃萨为断无量无数众生生死流转。为他说法。声闻独觉但为自断生死流转。为他说法。菩萨摩诃萨为令无量无数众生渡四瀑流。为他说法。声闻独觉但为令己渡四瀑流。为他说法。菩萨摩诃萨为除无量无数众生诸烦恼病。为他说法。声闻独觉但为自除诸烦恼病。为他说法。菩萨摩诃萨为断众生诸蕴烦恼习气相续令尽无余。为他说法。声闻独觉但为自断诸蕴烦恼习气相续有余不尽。为他说法。菩萨摩诃萨为成大悲等流果故。大悲为因为他说法。声闻独觉不为大悲等流果故。无大悲因为他说法。菩萨摩诃萨于诸众生有所顾念而为说法。声闻独觉于诸众生无所顾念而为说法。菩萨摩诃萨为息一切他众生苦。为他说法。声闻独觉但为自息己所有苦。为他说法。菩萨摩诃萨为满一切众生法味。为他说法。声闻独觉但为自满己身法味。为他说法。菩萨摩诃萨为诸众生得胜法明。为他说法。声闻独觉但为自己得胜法明。为他说法。善男子。以要言之。菩萨摩诃萨无量律仪。普为除灭一切众生大无明闇大怖畏事一切衰损得大光明及大名称。如实觉悟一切智智。为他说法。声闻独觉少分律仪。但为灭除自无明闇得小光明及小名称如实觉悟少分法智。为他说法。善男子。声闻独觉无有于他实怀顾念。无有于他实怀悲恻。无有于他实不轻弄。无有于他实为利益。无有于他实为拔济。无有于他实行荐举。无有于他实欲称叹。无有于他实无谄曲而行赞美。无有于他不顾己身令彼安乐。无有于他不起误失身语意业。善男子住大乘者。无有于己实怀顾念。广说乃至无有于他发起误失身语意业

大乘大集地藏十轮经卷第六
大乘大集地藏十轮经卷第七

        三藏法师玄奘奉　诏译

    有依行品第四之三

复次善男子。有诸众生禀性暴恶言辞粗犷。实是愚痴怀聪明慢。不断杀生乃至邪见。于他所得利养恭敬世所称誉深生嫉妒。常自追求利养恭敬世所称誉。曾无厌倦。恒自赞誉轻毁于他。不自防护身语意业常乐习行一切恶行。内行碜毒无有悲愍。无惭无愧喜触恼他于诸福田好简胜劣。于归我法诸出家人。常乐伺求所有瑕隙。才得少相未审真虚即便轻毁呵骂谪罚。其心刚强佷戾迷乱。常喜触恼诸出家人。不省己过念讥他阙。虽闻赞叹大乘功德发意趣求。而心好为诸重恶事。曾未寂静。诳惑他故。于大乘法现自听闻教他听闻。现自读诵教他读诵。为自荐举陵伏他故。于大乘法恭敬赞美。自于大乘诸行境界。不曾修学未能悟解。而自称号我是大乘。诱劝他人附己修学。规求名利以自活命。譬如破戒恶持律师。自犯尸罗乐行恶行。为名利故诱劝他人。令勤修学毗奈耶藏。如是谄曲虚诈众生。下贱人身尚当难得。退失善趣二乘涅槃。况得大乘终无是处。当堕恶趣难有出期。诸有智人不应亲近。而无惭愧于大众中自号大乘如师子吼。为名利故诱诳愚痴。令亲附己共为朋党。譬如有驴披师子皮而便自谓以为师子有人遥见谓真师子及至鸣已皆识是驴咸共唾言此非师子是食不净真弊恶驴种种呵叱皆共舍去。我说如是补特伽罗。常乐习行十恶业道。烧灭一切人天种子。尚退声闻独觉乘法。况于大乘能成法器。愚痴憍慢自号大乘。诳惑他人招集利养。譬如痴慢无手足人欲兴战伐入于大阵徒设功效终无克成。诈号大乘亦复如是。信手戒足无有一全。不自崖揆所堪行业。欲兴战伐烦恼大阵。徒设功效终无克成。我说。是人不护三业专行恶行妄号大乘。实于三乘皆非法器。而欲破坏一切众生勇健坚牢烦恼大阵欲皆显示一切众生八支圣道。令入无畏涅槃之城。终无是处。所以者何。善男子。夫大乘者。受持第一清净律仪。修行第一微妙善行。具足第一坚固惭愧。深见深畏后世苦果。远离所有一切恶法。常乐修行一切善法。慈悲常遍一切有情。恒普为作利益安乐。救济度脱一切有情所有厄难生死众苦。不顾自身所有安乐。唯求安乐一切有情。如是名为住大乘者。善男子。有何等相名声闻乘。谓诸众生常勤精进安住正念乐等引定离诸谄诳。信知业果不著五欲。世间八法所不能染。修善勇猛如救头然。常审谛观诸蕴界处。恒乐安住所有圣种。具此相者名声闻乘。如是众生尚未能成独觉乘器。况复能成大乘法器。善男子。有何等相名独觉乘。谓诸众生具上声闻一切功德。复能于彼五取蕴中。数数安住随无常观。数数安住随生灭观。普于一切缘生法中。能审谛观皆是灭法。具此相者名独觉乘。如是众生非大乘器。尔时世尊重显此义而说颂曰

  若真善人刹帝利　　乃至真善戌达罗
  修信等十有依轮　　于声闻乘速成器
  求独觉乘三业净　　具足惭愧怖诸蕴
  知过乐静住空闲　　念守诸根心寂定
  善观缘起修静虑　　诸蕴界处巧能观
  具此十行有依轮　　成胜乘器度有海
  修共三乘二乘轮　　自求解脱烦恼苦
  不度有情不舍习　　此人俱非大乘器
  愚痴懈怠根下劣　　于二乘法不勤修
  定不能具大乘轮　　故非大乘广大器
  愚痴独一求解脱　　劣意下行无慈悲
  乐著断见向恶趣　　弃舍正法说非法
  毁谤二乘舍律行　　受具足戒号大乘
  破乱我法惑众生　　由此人身难复得
  恼乱我法诸贤圣　　谪罚被赤袈裟人
  呵骂遮夺衣钵等　　长时退失人天趣
  是故若欲复人身　　不患舌庈而舍命
  常乐值遇诸佛者　　普应弘护三乘法
  欲得三乘最上乘　　应善观察三乘法
  欢喜为他普开示　　当得成佛定无疑
  破戒悭嫉怀憍慢　　自赞毁他号大乘
  舍离此人依智者　　定当成佛度三界
  于三乘器随所宜　　慈悲为说三乘法
  随愿令满无悭嫉　　当得成佛定无疑
  知蕴界处皆空寂　　无所依住譬虚空
  说法等摄诸有情　　当获妙觉无边智
  破戒意乐怀恶心　　闻说大乘胜功德
  诈号大乘为名利　　如弊驴披师子皮
  我今普告一切众　　若欲疾得胜菩提
  当善修持十善业　　护持我法勿毁坏
  我昔诸余契经说　　应求大觉行大乘
  舍离声闻独觉乘　　为清净者说斯法
  曾供无量俱胝佛　　断恶勤劳修净心
  我为劝进彼众生　　故说一乘无第二
  今此众具三乘器　　有但堪住声闻乘
  心极忧怖多事业　　彼非上妙菩提器
  有痴乐静住独觉　　彼非上妙菩提器
  有堪安住上妙智　　故随所乐说三乘
  具净功德乐解脱　　闻说大乘堕恶趣
  如病痰癊教服乳　　此增毒害非除疾
  如是非器声闻乘　　闻说大乘心迷乱
  便起断见坠恶趣　　故应说法审观机

    大乘大集地藏十轮经忏悔品第五

尔时世尊说是颂已。于众会中有无量百千众生。曾误闻法谬生空解。拨无因果断灭善根往诸恶趣。闻说此经还得正见。即从座起顶礼佛足。于世尊前深生惭愧至诚忏悔。合掌恭敬而白佛言。大德世尊。我等本在声闻乘中曾种善根。未能成熟声闻乘器。后复遇闻独觉乘法迷惑不了。便生空见拨无因果。由是因缘。造身语意无量罪业往诸恶趣。我等今者于世尊前。闻说此经还得正见。深心惭愧发露忏悔。不敢覆藏。愿悉除灭从今已往永不复作。防护当来所有罪障。唯愿世尊。哀愍摄受令我等罪皆悉销灭。于当来世永不更造。唯愿世尊。哀愍济拔我等当来恶趣苦报。我等今者还愿受行先所修集声闻乘行。唯愿世尊。哀愍教授。世尊告曰。善哉善哉。汝等乃能如是惭愧发露忏悔。于我法中。有二种人名无所犯。一者禀性专精本来不犯。二者犯已惭愧发露忏悔。此二种人于我法中。名为勇健得清净者。于是世尊随其所乐。方便为说四圣谛法。于彼众中。有得下品忍者。有得中品忍者。有得上品忍者。有得世间第一法者。有得预流果者。有得一来果者。有得不还果者。于中复有八万四千苾刍诸漏永尽心得解脱。意善清净成阿罗汉。欢喜礼佛还复本座

时众会中复有五十七百千那庾多众生。曾误闻法谬生空解。拨无因果断灭善根往诸恶趣。闻说此经还得正见。即从座起顶礼佛足。于世尊前。深生惭愧至诚忏悔。合掌恭敬而白佛言。大德世尊。我等本在独觉乘中曾种善根。未能成熟独觉乘器。后复遇闻说大乘法。虽生爱乐而不能解。愚冥疑惑便生空见拨无因果。由是因缘。造身语意无量罪业。乘此业缘。于无量劫堕诸恶趣。受种种苦楚毒难忍。我等今者于世尊前。闻说此经还得正见。深心惭愧发露忏悔不敢覆藏。愿悉除灭。从今已往永不复作。防护当来所有罪障。唯愿世尊。哀愍摄受令我等罪皆悉销灭。于当来世永不更造。唯愿世尊。哀愍济拔我等当来恶趣苦报。我等今者还愿受行先所修集独觉乘行。惟愿世尊。哀愍教授。世尊告曰。善哉善哉。汝等乃能如是惭愧发露忏悔。于我法中有二种人名无所犯。一者禀性专精本来不犯二者犯已惭愧发露忏悔。此二种人于我法中。名为勇健得清净者。于是世尊随其所乐。方便为说诸缘起法。令彼一切修缘觉乘。渐次圆满皆悉证得幢相缘定。于独觉乘得不退转。欢喜礼佛还复本座

时众会中复有八十百千那庾多众生。曾于过去诸佛法中。毁谤佛教下至一颂。由是因缘堕诸恶趣受众苦报。初复人身生便喑哑。常患舌[病-丙+今]口不能言。闻说此经还得正见。即从座起顶礼佛足。于世尊前深生惭愧。至诚忏悔宿世恶业。合掌恭敬瞻仰世尊。佛神力故皆悉能语。尔时世尊知而故问。汝等宿世作何恶业。今处众中口不能语。彼诸人众俱时白佛。于中一类作如是言。大德世尊。我等往昔于毗钵尸如来法中。或言毁谤大乘正法。或言毁谤独觉乘法或言毁谤声闻乘法下至一颂。我等由是恶业障故。九十一劫流转生死。常处地狱傍生饿鬼。喑哑无舌都不能言。受诸苦毒痛切难忍。始于今世得复人身。而犹喑哑常患舌[病-丙+今]。蒙佛神力方始能言。复能忆念自过去世所有因缘诸恶业障。复有一类作如是言。大德世尊。我等往昔于尸弃如来法中。或言毁谤大乘正法。各随本缘如前广说。复有一类作如是言。大德世尊。我等往昔于毗摄浮如来法中。或言毁谤大乘正法。各随本缘如前广说。复有一类作如是言。大德世尊。我等往昔于羯洛迦孙驮如来法中。或言毁谤大乘正法。各随本缘如前广说。复有一类作如是言。大德世尊。我等往昔于羯诺迦牟尼如来法中。或言毁谤大乘正法。各随本缘如前广说。复有一类作如是言。大德世尊。我等往昔于迦叶波如来法中。或言毁谤大乘正法。或言毁谤独觉乘法。或言毁谤声闻乘法下至一颂。我等由是恶业障故。从尔以来流转生死。常处地狱傍生饿鬼。喑哑无舌都不能言。受诸苦毒痛切难忍。始于今世得复人身。而犹喑哑常患舌庈。蒙佛神力方始能言。复能忆念自过去世所有因缘诸恶业障。我等今者于世尊前。闻说此经获得正见。深心惭愧发露忏悔不敢覆藏。愿悉除灭。从今以往永不复作。防护当来所有罪障。唯愿世尊。哀愍摄受令我等罪皆悉销灭。于当来世永不更造。唯愿世尊。哀愍济拔我等当来恶趣苦报。唯愿世尊。哀愍我等为说正法。世尊告曰。善哉善哉。汝等乃能如是惭愧发露忏悔。于我法中有二种人名无所犯。一者禀性专精本来不犯。二者犯已惭愧发露忏悔。此二种人于我法中。名为勇健得清净者。于是世尊随其所乐。方便为说种种正法。各随所宜皆得利益。欢喜礼佛还复本座

时众会中复有无量百千声闻及无量百千那庾多菩萨。闻说此经忆昔所造诸恶业障。即从座起顶礼佛足。于世尊前深生惭愧至诚忏悔。合掌恭敬皆白佛言。大德世尊。我等忆昔曾于无量诸佛法中或有说言我等于彼诸佛弟子或是法器或非法器多行忿恨呵骂毁辱讥刺轻诮种种诽谤隐善扬恶。我等由此恶业障故。经无量劫堕诸恶趣。受诸重苦楚毒难忍。后得值遇无量诸佛。皆曾亲近承事供养。又得值遇无量菩萨摩诃萨众。亦皆亲近承事供养。于一一佛一一菩萨摩诃萨前。皆深惭愧发露忏悔诸恶业障。于一一佛一一菩萨摩诃萨所。皆得听受无量法门精勤护持。修学无量难行苦行。由彼业障有余未尽。令我等辈未能证得安乐涅槃未能证得三摩地门殊胜功德。我等今者于世尊前闻说此经。复深惭愧发露忏悔不敢覆藏。愿悉除灭。从今以往永不复作。防护当来所有罪障。唯愿世尊。哀愍摄受令我等罪皆悉除灭。于当来世永不更造。唯愿世尊。哀愍济拔我等当来恶趣苦报。我等今者承佛威力。愿随所乐速能证得安乐涅槃。或能证得三摩地门殊胜功德。复有说言。我等于彼诸佛弟子或是法器或非法器。以粗恶言期克迫胁。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼诸佛弟子或是法器或非法器。打棒伤害。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼诸佛弟子。或是法器或非法器。侵夺衣钵。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼诸佛弟子或是法器或非法器。侵夺种种资生众具绝其饮食。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼无量诸佛出家弟子或是法器或非法器。退令还俗脱其袈裟课税役使。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼无量诸佛出家弟子或是法器或非法器。或有罪犯或无罪犯。枷锁系缚。禁闭牢狱。我等由此恶业障故。经无量劫堕诸恶趣。应知如前次第广说。复有说言。我等于彼无量诸佛出家弟子或是法器或非法器。起轻慢心种种触恼令不安乐。我等由此恶业障故经无量劫受诸重苦楚毒难忍。后得值遇无量诸佛。皆曾亲近承事供养。又得值遇无量菩萨摩诃萨众。亦皆亲近承事供养。于一一佛一一菩萨摩诃萨前。皆深惭愧发露忏悔诸恶业障。于一一佛一一菩萨摩诃萨所。皆得听受无量法门精勤护持。修学无量难行苦行。由彼业障有余未尽。令我等辈未能证得安乐涅槃未能证得三摩地门殊胜功德。我等今者于世尊前闻说此经。复深惭愧发露忏悔不敢覆藏。愿悉除灭。从今以往永不复作。防护当来所有罪障。唯愿世尊。哀愍摄受令我等罪皆悉消灭。于当来世永不更造。唯愿世尊。哀愍济拔我等当来恶趣苦报。我等今者承佛神力。愿随所乐速能证得安乐涅槃。或能证得三摩地门殊胜功德。于是世尊普告声闻菩萨众曰。善哉善哉。汝等乃能如是惭愧发露忏悔。有二种人名无所犯。一者禀性专精本来不犯。二者犯已惭愧发露忏悔。此二种人于我法中。名为勇健得清净者。又善男子。如是恼乱佛弟子罪。比前所说近无间罪。彼但有名未足称罪。然此恼乱佛弟子罪。亦过前说五无间罪无量倍数。所以者何。若诸苾刍毁破禁戒作诸恶法。犹能示导无量百千俱胝那庾多众生善趣涅槃无颠倒路。与诸众生作大功德珍宝伏藏如前广说。况持禁戒修善法者。以是义故若有恼乱佛弟子众诸出家人。当知则为断三宝种。亦则名为挑坏一切众生法眼。亦为毁灭我久勤苦所得正法。与诸众生作大衰损。是故恼乱佛弟子罪。过前所说五无间罪无量倍数。是故汝等今于我前。起至诚心增上惭愧殷勤恳切发露忏悔往昔所造诸恶业障。我今慈悲摄受汝等。令恶业障渐得消灭。于此佛土大贤劫中有千如来出现于世。汝等于彼诸如来前。亦当至诚发露忏悔诸恶业障。防护当来所有罪咎。于此贤劫千如来中。最后如来名曰卢至如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。十号具足。汝等于彼卢至佛前。亦当至诚发露忏悔诸恶业障乃得灭尽无有遗余。时诸声闻及菩萨众俱时白佛。唯然世尊。我等审当于彼最后卢至佛所获得正见离诸邪见诸恶业障尽灭无余解脱一切众苦恼者。若令我等于大贤劫常处无间大地狱中恒受种种极重苦恼亦能堪忍。世尊告曰。善哉善哉。汝等乃能如是勇猛。汝等由此坚固精进自誓愿力。定能于彼卢至佛前。宿世所集诸恶业障皆悉消灭。定能发起增上信敬亲近供养卢至如来。定能永断一切烦恼成阿罗汉。或定能证三摩地门殊胜功德。时诸声闻及菩萨众。欢喜礼佛还复本座

尔时世尊告金刚藏菩萨摩诃萨言。善男子。我以佛眼观诸世间。见未来世此佛土中。有无量无数百千俱胝那庾多刹帝利旃荼罗．婆罗门旃荼罗．宰官旃荼罗．居士旃荼罗．长者旃荼罗．沙门旃荼罗茷舍旃荼罗．戌达罗旃荼罗．若男若女。少种善根虽得人身而随恶友起诸邪见造诸恶行。坏我甚深无上正法。于我所说无有炽然。灭炽然法不生信乐。或于我说与声闻乘相应正法。诽谤轻毁障蔽隐没不令流布。或于我说与独觉乘相应正法。诽谤轻毁障蔽隐没不令流布。或于我说与无上乘相应正法。诽谤轻毁障蔽隐没不令流布。或于归我诸出家人若是法器若非法器。多行忿恨呵骂毁辱讥刺轻诮种种诽谤隐善扬恶。广说乃至起轻慢心种种触恼。如是诸人非圣法器。自实愚痴怀聪明慢。从此命终堕三恶趣。受无量种增上猛利难忍苦毒。经于无量百千俱胝那庾多劫难复人身。如前广说。善男子。如是众生宁处无间大地狱中受诸重苦。不受如是鄙恶人身憍慢贡高随顺恶友造作如是恶不善业流转生死难可济度常处生死受诸苦恼。

尔时会中有无量无数大慧有情。从座而起顶礼佛足。合掌向佛悲泣堕泪而白佛言。大德世尊。谛观如是世间众生虽皆获得难得人身。而远离正信远离正愿远离正意乐远离正见远离善知识远离好时远离好处远离净戒远离正定远离正慧如是众生虽皆获得难得人身。而由愚痴憍慢力故。造作如前所说重罪。毁谤世尊所说正法。触恼世尊出家弟子。我等今者对世尊前。以至诚心发真誓愿。我等从今流转生死乃至未得解脱已来。常愿不遇如是恶缘。决定不造如是重罪。终不毁谤诸佛正法。亦不触恼诸出家人。必不挑坏众生法眼。亦不断灭三宝种性。惟愿世尊。哀愍摄受我等所发如是誓愿。时众会中复有无量百千俱胝那庾多聪慧有情。从座而起顶礼佛足。合掌恭敬而白佛言。大德世尊。我等今者对世尊前。以至诚心发真誓愿。我等从今流转生死乃至未得法忍已来。于其中间常愿不处诸帝王位。常愿不处诸宰官位。常愿不处诸国师位。常愿不处城邑聚落镇逻长位。常愿不处诸军将位。常愿不处诸商主位。常愿不处一切祠祀寺观主位。常愿不处长者居士沙门主位。常愿不处诸师长位。常愿不处诸家长位。常愿不处断事者位。常愿不处乃至一切富贵尊位。乃至未得法忍已来。我等若处如是诸位。则于佛法名恶因缘。造诸重罪。毁谤诸佛所说正法。触恼诸佛出家弟子。必当挑坏众生法眼。亦为断灭三宝种性。亦为损恼无量有情。由是定当堕无间狱。轮转恶趣难有出期。唯愿世尊。哀愍摄受我等所发如是誓愿。尔时一切诸来大众。天龙药叉健达缚人非人等。皆从座起顶礼佛足。悲号感切涕泪交流。合掌恭敬而白佛言。大德世尊。我等无始生死已来。愚痴憍慢起诸恶业或身恶业或语恶业或意恶业。自作教他见闻随喜。如是诸罪今对佛前皆深惭愧发露忏悔不敢覆藏。愿悉除灭。从今以往永不复作。防护当来所有罪咎。第二第三亦如是说。我等至诚发真誓愿。从今乃至生死后际。于其中间常愿不逢诸恶知识。亦愿不遇诸恶因缘。设当逢遇愿不随顺。决定不造如前所说诸恶罪业。勿令我等长夜受苦。唯愿世尊。哀愍摄受我等所发如是誓愿

尔时世尊普告一切诸来大众。善哉善哉。汝等乃能于后世苦深见怖畏发露忏悔。汝等今者欲度生死深广瀑流欲入无畏涅槃之城。发如是愿。诸善男子。有十种法。能令菩萨摩诃萨等获得无罪正路法忍。何等为十。诸善男子。若诸菩萨摩诃萨等。不著内身不著外身不著内外身不著过去身不著未来身不著现在身。名第一法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著内受不著外受不著内外受不著过去受不著未来受不著现在受。名第二法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著内想不著外想不著内外想不著过去想不著未来想不著现在想。名第三法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著内行不著外行不著内外行不著过去行不著未来行不著现在行。名第四法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著内识不著外识不著内外识不著过去识不著未来识不著现在识。名第五法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著此世名第六法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著他世。名第七法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著欲界。名第八法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著色界。名第九法。能令菩萨摩诃萨等获得无罪正路法忍。又善男子。若诸菩萨摩诃萨等。不著无色界名第十法。能令菩萨摩诃萨等获得无罪正路法忍。诸善男子。是名十法。能令菩萨摩诃萨等获得无罪正路法忍。世尊为众说此法时。于众会中有七十二百千俱胝菩萨摩诃萨。同时证得无生法忍。复有八十四百千那庾多菩萨。证得随顺法忍。复有无量百千声闻。乃至永断一切烦恼成阿罗汉。复有百千那庾多众生。先未发心今发无上正等觉心于如来智住不退地。复有无量无数众生。先未发心于今乃发独觉乘心。复有无量无数众生。先未发心于今乃发声闻乘心

尔时世尊复告大众。若诸有情已得法忍处刹帝利灌顶王位受用种种胜大财业。及处种种富贵尊位。是我所许。非余有情。金刚藏菩萨白佛言。世尊。若诸有情未得法忍于刹帝利灌顶王位受用种种胜大财业。及余种种富贵尊位。定不许处为亦许耶。世尊告曰。若诸有情未得法忍。有能受行十善业道。亦劝众生令受学者。我亦听许处刹帝利灌顶王位受用种种胜大财业。及余种种富贵尊位。若诸有情未得法忍。亦不受行十善业道及劝众生令勤受学。以强势力处刹帝利灌顶王位受用种种胜大财业。及处种种富贵尊位。名刹帝利旃荼罗王及余种种富贵尊位旃荼罗王。愚痴憍慢毁坏扰乱我甚深法。灭正法灯断三宝种。于我出家诸弟子众。种种恼乱捶拷刑罚。夺其衣钵基业财产。退令还俗课税役使。系闭牢狱乃至断命。于我所说微妙法义。诽谤轻毁障蔽隐没不令流布。夺窣堵波及僧祇物。如是诸人皆当坠堕无间地狱受诸剧苦轮转恶趣难有出期。时金刚藏菩萨复白佛言。世尊。若诸有情未得法忍。亦不受行十善业道及劝众生令勤受学。以强势力处刹帝利灌顶王位受用种种胜大财业。及余种种富贵尊位。颇有别缘得方便救。令其免堕无间地狱及余恶趣受诸苦不。世尊告曰。亦有别缘得方便救。谓有众生处刹帝利灌顶王位及余种种富贵尊位。虽复未得成就法忍十善业道。而有信力尊敬三宝。于佛所说三乘相应诸出要法下至一颂。终不谤毁障蔽隐没不令流布。于佛出家诸弟子众持戒破戒下至无戒剃除须发被袈裟者。皆不恼乱捶拷谪罚侵夺衣钵基业财产退令还俗课税役使系闭牢狱乃至断命。亦不侵夺窣堵波物及僧祇物。遮制摧伏诸暴恶人。不令恼乱诸出家众。不令侵夺三宝财物。于佛所说三乘相应诸出要法恭敬听受。既听受已精进修行法随法行。于我三乘贤圣弟子恭敬供养亲近承事。于大乘中誓愿坚固终无疑难退屈之心。亦常劝导安置众生令于大乘信受修学。此刹帝利旃荼罗王及余种种富贵尊位旃荼罗王。过去诸佛皆共听许处帝王位及余种种富贵尊位。虽复受用种种国土城邑聚落胜大财业。而得免堕无间地狱及余恶趣。我亦听许处帝王位及余种种富贵尊位。虽复受用种种国土执邑聚落。而得免堕无间地狱及诸恶趣。若诸有情欲得忏悔除灭一切诸恶业障令无余者。于我所说如是法门。当勤修学勿令废忘。有能如此现前大众惭愧忏悔诸恶业者。先世所造一切恶业。皆得销灭无有遗余

大乘大集地藏十轮经卷第七
大乘大集地藏十轮经卷第八

        三藏法师玄奘奉　诏译

    善业道品第六

尔时金刚藏菩萨摩诃萨复白佛言。大德世尊。菩萨摩诃萨云何于声闻乘得无误失。云何于声闻乘补特伽罗得无误失。云何于独觉乘得无误失。云何于独觉乘补特伽罗得无误失。云何于大乘得无误失。云何于大乘补特伽罗得无误失。云何常能炽然三宝种姓云何于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。云何于大乘法常得升进无有退转。云何利慧胜福常得增长。云何于一切定诸陀罗尼诸忍诸地速得自在无有退转。云何常得值遇诸善知识随顺而行。云何常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。云何于诸善根常精进求心无厌足。云何常于菩提种种行愿心无厌足

尔时世尊告金刚藏菩萨摩诃萨言。善男子。有菩萨摩诃萨十轮。若菩萨摩诃萨成此十轮。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地。速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。常于一切先所造作恶不善业以圣金刚坚利法智摧坏散灭令无遗余不受果报。更不造新恶不善业心无厌倦速能证得无上法轮。常勤修习七觉分宝心无厌倦。常能除灭一切众生诸烦恼病心无厌倦。一切众生依止存活

善男子。如转轮王具足七宝凡所行动轮宝导前余宝随后巡四大洲普能除灭一切众生身心浊秽普能生长一切众生身心安乐。菩萨摩诃萨亦复如是。成就十轮。于声闻乘得无误失。广说乃至一切众生依止存活。善男子。如大车辂具足四轮多人乘之游行大路于其路上土块瓦砾草木根茎枝叶华果为轮所辗皆悉摧坏不任受用。菩萨摩诃萨亦复如是。成就十轮。悉能摧坏诸烦恼障诸有情障一切法障令不受报。善男子。如利剑轮才一投掣能斩怨敌首及支节令无势用。菩萨摩诃萨亦复如是。成就十轮。能破一切五趣牢狱生死大苦。永断一切烦恼恶业令不受报。善男子。如火灾起五日出时遍四大洲一切河海水界津润无不枯竭。菩萨摩诃萨亦复如是。成就十轮。一切四因诸烦恼障诸有情障一切法障苦报根本悉皆枯竭。善男子。如风灾起四方猛风俱时顿发一切世界大小诸山及诸大地悉皆散灭。菩萨摩诃萨亦复如是。成就十轮。世间四倒憍慢诸山无不崩坏。一切众生诸烦恼障诸有情障一切法障苦报根本悉皆散灭。善男子。如师子王吼声一发一切禽兽悉皆惊怖飞落走伏无敢辄动。菩萨摩诃萨亦复如是。成就十轮。法音一震。乃至一切外道异学恶知识等悉皆惊怖。忘失言辩无敢酬抗。善男子。如天帝释与阿素洛将欲战时天军围绕手执金刚奔趣阵敌诸阿素洛惊怖退散。菩萨摩诃萨亦复如是。成就十轮。一切倒见外道异学恶知识等惊怖退散。善男子。如如意珠置高幢上。能雨种种上妙珍宝。给施一切贫乏众生。菩萨摩诃萨亦复如是。成就十轮。处净戒幢雨大法雨。给施一切无量众生。善男子。如闇夜分世间幽冥都无所见迷失正道满月出已诸闇皆除。诸失道者皆见正路。菩萨摩诃萨亦复如是。成就十轮。若诸众生无明昏闇。由此迷失八支圣道。菩萨为其宣说正法。除无明闇生法光明。开示显现八支圣道。令断诸漏尽诸苦际。善男子。如大日殿出现世间一切苗稼悉皆增长。一切花叶悉皆敷荣一切臭秽悉皆除歇诸谷果药悉皆成熟雪山销流诸河充溢渐次转注满于大海。菩萨摩诃萨亦复如是。成就十轮。依止增上布施调伏寂静尸罗安忍正勤静虑般若方便慈悲辩才功德皆悉炽盛。为诸众生宣说正法。由法威光令诸众生种种增上善根苗稼悉皆增长。种种增上妙行华叶悉皆敷荣。种种烦恼恶业恶行悉皆除歇。善趣涅槃诸谷果药悉皆成熟。邪见慢山悉皆销流。种种正信戒闻舍慧及诸定河无不充溢渐次盈满大涅槃海。令诸有情随意所乐趣入无畏涅槃之城。善男子。云何名菩萨摩诃萨十轮。善男子。此十轮者非余法也。当知即是十善业道。成就如是十种轮故。得名菩萨摩诃萨也。于一切恶皆能解脱。一切善法随意成就。速能盈满大涅槃海。以大善巧方便智光成熟一切众生之类。皆令获得利益安乐。所以者何。善男子。过去一切诸佛世尊。皆悉远离十恶业道。皆悉称扬赞叹如是十善业道所得果报。是故若能于此所说十善业道随守护一乃至命终究竟无犯。必获一切殊胜果报如前后说。善男子。若菩萨摩诃萨。能尽形寿远离杀生。即是施与一切众生无惊无怖。令诸众生不生忧苦离毛竖畏。由此善根速得成熟。所有前际轮转五趣没生死河。因杀生故。造身语意诸恶业障诸烦恼障诸有情障一切法障诸寿命障。自作教他见闻随喜。由此远离杀生轮故。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无有猜虑。身心安乐寿命长远。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处无病长寿。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离杀生法。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土离诸兵器。无有怨害斗战之名。绝诸怖畏安隐快乐。一切无病长寿有情来生其国。如来自寿无量无边。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第一远离杀生轮也。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种性。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广如前说

复次善男子。若菩萨摩诃萨能尽形寿离不与取。即是施与一切众生无惊无怖无有热恼亦无扰动于自所得如法财利喜足而住。终不希求非法财利。由此善根速得成熟。所有前际轮转五趣没生死河。因不与取。造身语意诸恶业障诸烦恼障诸有情障一切法障诸财宝障自作教他见闻随喜。由此远离不与取轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐财宝具足。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处具大财宝。端正聪明安隐快乐。不与五家共诸财宝。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离不与取。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土众宝庄严。宝树宝池宝台殿等无不充备。离我我所无所摄受一切具足严饰有情来生其国。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第二远离不与取轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿离欲邪行。即是施与欲流所漂一切众生无惊无怖无嫉无害。无有热恼亦无扰动。于己妻室喜足而住。终不希求非法色欲。由此善根速得成熟。所有前际轮转五趣没生死河。因欲邪行。造身语意诸恶业障诸烦恼障诸有情障一切法障诸室家障。自作教他见闻随喜。由此远离欲邪行轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐妻室贞良。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处具诸眷属。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离欲邪行。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土无诸女人。离诸淫欲具足第一梵行有情来生其国。一切有情皆受化生。不处胞胎臭秽不净。如来自身寿命无量。为诸有情。如应说法。般涅槃后正法久住利益安乐无量有情。善男子。是名菩萨摩诃萨第三远离欲邪行轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿离虚诳语。一切众生常共爱敬。所出言词皆诚谛量。闻悉敬奉无所猜疑。由此善根速得成熟。所有前际轮转五趣没生死河。因虚诳语。造身语意诸恶业障诸烦恼障诸有情障一切法障诸信言障。自作教他见闻随喜。由此远离虚诳语轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。所出言词他皆信奉。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处所言诚谛。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离虚诳语。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土一切真实离诸虚伪。妙香洁物之所庄严。无谄无诳心行正真希求纯净善法有情来生其国。香洁妙服宝饰庄严。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第四远离虚诳语轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿离离间语。一切众生常共爱敬。所发言词皆令和顺。闻悉敬奉无所猜疑。由此善根速得成熟。所有前际轮转五趣没生死河。因离间语。造身语意诸恶业障诸烦恼障诸有情障一切法障诸和敬障。自作教他见闻随喜。由此远离离间语轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。所发言词皆令和顺。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处所言和顺。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离离间语。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提所居佛土一切坚密难可破坏。诸美妙物之所庄严。无违无竞善和诤讼希求淳质善法有情来生其国。常修和敬听闻正法。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第五远离离间语轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿离粗恶语。一切众生常共爱敬。所发语言皆令欢悦。闻悉敬奉无所猜疑。由此善根速得成熟。所有前际轮转五趣没生死河。因粗恶语。造身语意诸恶业障诸烦恼障诸有情障一切法障诸调善障。自作教他见闻随喜。由此远离粗恶语轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。所出言词皆令欢悦。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处所言柔软。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离粗恶语。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土远离一切不可意声。种种上妙如意和雅诸意乐声结集法声充满其土。具足念慧梵音清彻调善有情来生其国。常以软语更相劝进。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第六远离粗恶语轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地。速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿离杂秽语。一切众生常共爱敬。所发言词皆有义利。闻悉敬奉无所猜疑。由此善根速得成熟。所有前际轮转五趣没生死河。因杂秽语。造身语意诸恶业障诸烦恼障诸有情障一切法障诸义利障。自作教他见闻随喜。由此远离杂秽语轮。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。所发言词皆成义利。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处言必饶益。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离杂秽语。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土远离一切无义利声。种种上妙菩萨藏摄大法音声周遍国土。成就无边大愿妙智能善辩说种种法义如是有情来生其国。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第七远离杂秽语轮。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿远离贪欲。一切众生常所爱重。其心清净离诸染浊。由此善根速得成熟。所有前际轮转五趣没生死河。因贪欲故。造身语意诸恶业障诸烦恼障诸有情障一切法障诸无贪障。自作教他见闻随喜。由此远离贪欲轮故。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。其心清净离诸染浊。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处其心清净离诸染浊。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离贪欲法。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土地平如掌众宝充满。种种宝树行列庄严。种种宝衣宝庄严具宝幢幡盖金银真珠罗网等树处处皆有。甚可爱乐远离憍慢颜貌端严诸根无缺其心平等如是有情来生其国。无贪功德圆满庄严。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第八远离贪欲轮也。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地。速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

大乘大集地藏十轮经卷第八
大乘大集地藏十轮经卷第九

        三藏法师玄奘奉　诏译

    善业道品第六之二

复次善男子。若菩萨摩诃萨能尽形寿远离嗔恚。一切众生常所爱重。其心清净离诸垢秽。由此善根速得成熟。所有前际轮转五趣没生死河。因嗔恚故。造身语意诸恶业障诸烦恼障诸有情障一切法障诸无明障。自作教他见闻随喜。由此远离嗔恚轮故。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。其心清净离诸垢秽。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处其心清净离诸垢秽。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离嗔恚法。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入深广智海。乃至证得无上菩提。所居佛土远离一切浊秽风云郁烝尘垢诸粗弊物。众宝庄严甚可爱乐。远离憍慢颜貌端严诸根无缺心常寂定如是有情来生其国。慈悲功德圆满庄严。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。善男子。是名菩萨摩诃萨第九远离嗔恚轮也。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃鬘发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿心无厌足。所得果报广说如前

复次善男子。若菩萨摩诃萨能尽形寿远离邪见。一切众生常所爱重。其心清净离邪分别。由此善根速得成熟。所有前际轮转五趣没生死河。因邪见故。造身语意诸恶业障诸烦恼障诸有情障一切法障诸正见障。自作教他见闻随喜。由此远离邪见轮故。皆悉辗坏摧灭无余不受果报。于现身中诸人天等皆共亲爱无所猜虑。身心安乐。其心清净离邪分别。将命终时身心不为忧苦逼切。所爱妻子眷属围绕。临命终时不见可怖剡魔王使。唯见可意成调善法具戒富德真实福田为善知识。身心欢悦深生敬信。既命终已还生人中。诸根圆满支体具足。随所生处其心清净离邪分别。端正聪明安隐快乐。复遇可意成调善法具戒富德真实福田为善知识。依彼修学离邪见法。能断一切恶不善法。能成一切殊胜善法。能求一切大乘法义。能修一切菩萨愿行。渐次趣入大乘大海。乃至证得无上菩提。所居佛土远离一切声闻独觉二乘人法。远离一切天魔徒众。远离一切外道朋党。众宝庄严甚可爱乐。远离一切妄执吉凶常见断见我我所见如是有情来生其国。寿命长远受用一味。谓大乘味。如来自身寿命无量。为诸有情如应说法。般涅槃后正法久住。利益安乐无量有情。圣教一味无有乖诤。炽盛流通离诸障难。善男子。是名菩萨摩诃萨第十远离邪见轮也。菩萨摩诃萨成就此轮故。于声闻乘得无误失。于声闻乘补特伽罗得无误失。于独觉乘得无误失。于独觉乘补特伽罗得无误失。于其大乘得无误失。于其大乘补特伽罗得无误失。常能炽然三宝种姓。于诸如来出家弟子若是法器若非法器下至一切被片袈裟剃须发者得无误失。于大乘法常得升进无有退转。利慧胜福常得增长。于一切定诸陀罗尼诸忍诸地速得自在无有退转。常得值遇诸善知识随顺而行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸善根常精进求心无厌足。常于菩提种种行愿六波罗蜜多心无厌足。所得果报广说如前

善男子。若菩萨摩诃萨成就如是十轮。能速证得阿耨多罗三藐三菩提。所以者何。于过去世。一切如来应正等觉。皆悉远离十恶业道。皆悉称扬赞叹如是十善业道所得果报。为欲长养一切众生。利益安乐菩提道故。为欲除灭一切众生业烦恼苦令无余故。为欲枯竭三恶趣故。为欲绍隆三宝种故。为欲断除三界有故。为欲永断蕴界处故。为令一切速入无畏涅槃城故。广说如前远离十种不善业道所得果报。是故善男子。若不真实希求如是十善业道所证佛果。及不真实下至守护一善业道。乃至命终而自称言。我是真实行大乘者。我求无上正等菩提。当知如是补特伽罗。是极虚诈是大妄语。对十方界佛世尊前。诳惑世间无惭无愧。说空断见诱诳愚痴。身坏命终堕诸恶趣。善男子。若但言说及但听闻。不由修行十善业道能得菩提般涅槃者。于一劫中或一念顷。可令十方一切佛土地界微尘算数众生皆登正觉入般涅槃。然无是事。所以者何。十善业道。是大乘本是菩提因。是证涅槃坚固梯蹬。善男子。若但发心发誓愿力。不由修行十善业道能得菩提般涅槃者。于一劫中或一念顷。可令十方一切佛土地界微尘算数众生皆登正觉入般涅槃。然无是事。所以者何。十善业道。是世出世殊胜果报功德根本。善男子。若不修行十善业道。设经十方一切佛土微尘数劫。自号大乘或说或听。或但发心或发誓愿。终不能证菩提涅槃。亦不令他脱生死苦。善男子。要由修行十善业道。世间方有诸刹帝利婆罗门等大富贵族四大王天乃至非想非非想处或声闻乘或独觉乘乃至无上正等菩提。皆由修行十善业道品类差别。是故善男子。若欲速满无上正等菩提愿者。当修如是十善业道以自庄严非住十恶不律仪者能满如是无上正等菩提大愿。若求速悟大乘境界速证无上正等菩提速满一切善法愿者。先应护持十善业道。所以者何。十善业道。是能安立一切善法功德根本。是世出世胜果报因。是故应修十善业道。尔时世尊重显此义。而说颂曰

  欲除诸有苦　　证得大菩提
  应修十善轮　　精勤勿放逸
  便于三乘法　　及补特伽罗
  一切出家人　　皆得无误失
  信受行大乘　　利乐一切众
  觉胜法净土　　速证大菩提
  若离于杀生　　一切皆爱敬
  恒无病长寿　　常乐不害法
  一切所生处　　恒乐佛所行
  常遇佛法僧　　速成无上觉
  若离不与取　　智者皆爱敬
  灭贪所生业　　获无贪所生
  生生常巨富　　能为大施主
  得众宝庄严　　可爱净佛国
  若离欲邪行　　灭臭秽烦恼
  枯竭贪爱河　　速得净佛国
  拔诸众生类　　令出欲淤泥
  安置于大乘　　使勤修梵行
  若离虚诳语　　得圣自在智
  常乐谛实言　　灭虚妄众苦
  一言为证量　　常遇佛法僧
  速得大菩提　　劝修不妄语
  若离离间语　　成众善法器
  常遇佛法僧　　不归于断灭
  得圣无染著　　陀罗尼宝藏
  达深法海源　　速成无上觉
  若离粗恶语　　常说柔软言
  众生皆爱敬　　灭先世罪业
  令众常欢悦　　成菩萨导师
  知诸佛所行　　超过第十地
  若离杂秽语　　智者皆爱敬
  为他所发言　　具获五功德
  常听受圣言　　恒欣求圣道
  圆满诸佛海　　速得一切智
  若离于贪欲　　不诽谤圣教
  供养服袈裟　　弘三乘圣道
  当生净佛国　　导师之所居
  乘于无上乘　　速得最胜智
  若离于嗔恚　　一向修慈心
  速疾证等持　　乐众圣行处
  当生净佛土　　远离诸过恶
  住彼证菩提　　令离诸嗔忿
  若离于邪见　　纯修净信心
  乐开示三乘　　亦供养诸佛
  永脱诸恶趣　　遇众贤圣者
  具诸菩萨德　　逮得最上智
  我说十善业　　能趣胜菩提
  生长诸等持　　陀罗尼忍地
  此轮大威德　　能摧诸恶趣
  破坏诸恶障　　速证大菩提

    大乘大集地藏十轮经福田相品第七之一

复次善男子。菩萨摩诃萨有十财施大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。何等为十。所谓布施种种饮食衣服宝饰象马车乘及以自身手足耳鼻头目髓脑皮骨血肉国城妻子奴婢田宅。如是一一行布施时不顾身命。不专为己求于世间出世间乐发心布施。但欲普为一切有情生长大慈大悲芽故发心布施。为欲引发善巧方便殊胜智故发心布施。为欲引发一切有情安乐事故发心布施。为欲除灭一切有情苦恼事故发心布施。无胜他心无粗犷心无嫉妒心无悭吝心而行布施。于所施物若多若少下至一食终不希求自受果报发心布施。终不希求声闻乘果发心布施。终不希求独觉乘果发心布施。于所施物若多若少下至一食但为希求一切种智发心布施。善男子。菩萨摩诃萨成就如是十种财施大甲胄轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。所以者何。声闻独觉发心布施无大慈悲。但为己身舍贫穷故。但为己身脱众苦故。但为己身得安乐故。但为己身证涅槃故。不能普为一切有情而行布施。菩萨摩诃萨发心布施有大慈悲。普为有情舍贫穷故。普为有情脱众苦故。普为有情得安乐故。普为有情证涅槃故。不为自身而行布施。以是义故。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。菩萨摩诃萨修行财施波罗蜜多时。于妙五欲心无染著。自所摄受一切乐具。普能施与一切有情。依普摄受诸有情心依自忍受一切苦心依灭一切有情苦心依与一切有情乐心依与有情大涅槃心而行布施。以是义故。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。善男子。若于五欲心无染著具大慈悲而行布施。是名菩萨摩诃萨也。亦名一切声闻独觉真实福田。若不除断世间五欲。无大慈悲而行布施。虽舍无量无边施物。而犹不得名为菩萨摩诃萨也。亦非一切声闻独觉真实福田。此施不蒙圣印所印。是故应断世间五欲具大慈悲而行布施。若不断于世间五欲无大慈悲而行布施。不名菩萨非真福田。善男子。染著五欲行布施轮。尚不能灭自身所有少分苦恼。况能除灭一切有情无量苦恼。尔时世尊重显此义。而说颂曰

  成就财施轮　　智者净意乐
  尽离于五欲　　安乐诸有情
  为乐诸有情　　不求自果报
  虽行少分施　　而名真福田
  虽复施众多　　而依止五欲
  非圣印所印　　住不定聚中
  虽行少分施　　而不依五欲
  名声闻独觉　　真实良福田
  故应舍五欲　　常行清净施
  安乐有情众　　成真实福田

复次善男子。菩萨摩诃萨有十法施大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。速能获得日灯光定。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。何等为十。谓诸如来所说正法。或声闻乘相应正法。或独觉乘相应正法。或与大乘相应正法。或世间法。或出世间法。或有漏法。或无漏法。或有为法。或无为法。或不二法。菩萨摩诃萨于此十法深信敬重一切听闻。随力所能审谛领受。思惟观察究竟通利随其所宜为他演说。于说法时无嫉妒心无悭吝心无憍慢心无求利心无轻他心无自举心。有恭敬心有饶益心有大慈心有大悲心。为声闻乘补特伽罗说声闻法。不为彼说独觉乘法及大乘法。为独觉乘补特伽罗说独觉法。不为彼说声闻乘法及大乘法。为于大乘补特伽罗说大乘法。不为彼说声闻乘法独觉乘法。随诸有情根器所能为说正法。非根器者终不为说。于其大乘诸有情所。终不劝修独觉乘行声闻乘行。于独觉乘诸有情所。或时劝彼修大乘行。于声闻乘诸有情所。或时劝修独觉乘行及大乘行。于诸如来所说正法下至一颂乃至半句深信敬重。终不毁谤障蔽隐没。于说法师起世尊想。于听法众起病者想。于所说法起良药想。断除五欲无所希求。宣说正法。善男子。是名菩萨摩诃萨十种法施大甲胄轮。若菩萨摩诃萨成就此轮能断五欲。速能获得日灯光定。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  智者修法施　　随器说三乘
  不为说余乘　　恐闻而谤法
  称根器说法　　不为非根器
  各随其所乐　　劝进令欢喜
  终不劝大乘　　令修二乘行
  或时劝彼二　　进修中上乘
  常恭敬听法　　深信不毁谤
  供养说法师　　如佛世尊想
  劝闻妙法药　　令除烦恼病
  舍利养名誉　　而宣说正法

复次善男子。菩萨摩诃萨复有净戒大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何净戒大甲胄轮。善男子。菩萨净戒有二种相。一者共。二者不共。云何菩萨共净戒轮。谓诸在家近事近住所受律仪。或复出家及受具足别解脱戒。如是律仪别解脱戒。是名菩萨共净戒轮。共诸声闻独觉乘等。菩萨不由此净戒轮。能除一切有情烦恼诸恶见趣及能解脱业障生死。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何菩萨不共净戒大甲胄轮。谓诸菩萨普于十方一切有情起平等心无扰动心无怨恨心护持净戒。普于一切持戒犯戒布施悭贪慈悲忿恚精进懈怠下中上品诸有情所无差别心无差别想护持净戒。普于三界一切有情。无恚无忿及诸恶行护持净戒。普于三有蕴界处中无所分别护持净戒。不依欲界。护持净戒。不依色界护持净戒。不依无色界护持净戒。不观诸有一切果报护持净戒。不依一切得与不得护持净戒。不依诸行护持净戒。是名菩萨不共净戒大甲胄轮。善男子。若菩萨摩诃萨成此净戒大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  住在家律义　　出家解脱戒
  与二乘等共　　不名摩诃萨
  智者修空法　　不依诸世间
  亦不依诸有　　护持清净戒
  离取相尸罗　　无染无诸漏
  护持如是戒　　名真实福田

复次善男子。菩萨摩诃萨复有安忍大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何安忍大甲胄轮。善男子。菩萨安忍有二种相。一者世间。二者出世间。云何菩萨世间安忍。谓有漏忍。缘诸有情有取有相依诸果报依诸福业所发起忍。依自诸色声香味触所发起忍。有发趣忍。无堪能忍。力羸劣忍。弃众生忍。有诳诈忍。矫悦他忍。不为利乐诸有情忍。是名菩萨世间安忍。如是安忍共诸声闻独觉乘等。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何菩萨出世安忍大甲胄轮。谓无漏忍。一切贤圣大法光明。普为利乐一切有情。无染著忍。永断一切所作事业。语言因相文字音声行依处安忍。修此忍故。能断一切三结三受三相三世三有三行三不善根四种瀑流四扼四取四种身系。修此忍时心意寂静。是名菩萨出世安忍大甲胄轮。善男子。若菩萨摩诃萨成此安忍大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  安忍说二种　　谓有相无相
  有相忍有著　　智者不称誉
  修忍依三行　　依蕴界处等
  是名有漏忍　　非摩诃萨相
  为灭四颠倒　　修无染著忍
  寂静三行等　　此忍可称誉
  能寂静诸行　　离一切分别
  心平等如空　　此忍可称誉
  诸法同一趣　　空无相寂灭
  心无所住著　　此忍成大利

复次善男子。菩萨摩诃萨复有精进大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何精进大甲胄轮。善男子。菩萨精进有二种相。一者世间。二者出世间。云何菩萨世间精进。谓诸菩萨精进勇猛。勤修三种世福业事。何等为三。一者施福业事。二者戒福业事。三者修福业事。修此即名三种精进。如是精进缘诸众生有漏有取依诸果报依诸福业。是名菩萨世间精进。如是精进共诸声闻独觉乘等。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何菩萨出世精进大甲胄轮。谓诸菩萨勇猛精进。于诸众生其心平等。除灭一切烦恼业苦。如是精进一切贤圣共所称誉。无漏无取无所依止。普于一切精进懈怠布施悭贪持戒破戒慈悲忿恚下中上品诸众生所无差别心无差别想勇猛精进。普于三界一切众生平等无二为作事业语言思惟诸行依处无所住著勇猛精进。普于三有蕴界处中。无所分别勇猛精进。不依欲界勇猛精进。不依色界勇猛精进。不依无色界勇猛精进。不观诸有一切果报勇猛精进。不依一切得与不得勇猛精进。不依诸行勇猛精进。不依三种世福业事勇猛精进。具足出世三福业事勇猛精进。是名菩萨出世精进大甲胄轮。善男子。若菩萨摩诃萨成此精进大甲胄轮。从初发心一切五欲皆能除断得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  于六根染著　　漂愚五瀑流
  虽勇猛精进　　智者皆厌毁
  缘众生精进　　有漏及有取
  非真实福田　　不名摩诃萨
  智者勤精进　　远离一切著
  心无所依止　　名真实福田
  不染著名色　　离蕴界处等
  为众作归依　　是名摩诃萨
  行世如水月　　修精进究竟
  此轮能永断　　众生烦恼缚

复次善男子。菩萨摩诃萨复有静虑大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何静虑大甲胄轮。善男子。菩萨静虑有二种相。一者世间。二者出世间。云何菩萨世间静虑。谓诸菩萨依著诸蕴修习静虑。依著诸界修习静虑。依著诸处修习静虑。依著欲界修习静虑。依著色界修习静虑。依著无色界修习静虑。依著三律仪修习静虑。依著三解脱修习静虑。依著四念住修习静虑。依著四正断修习静虑。依著四神足修习静虑。依著五根修习静虑。依著五力修习静虑。依著七等觉支修习静虑。依著八圣道支修习静虑。依著地界修习静虑。依著水界修习静虑。依著火界修习静虑。依著风界修习静虑。依著空界修习静虑。依著识界修习静虑。依著乐受修习静虑。依著苦受修习静虑。依著不苦不乐受修习静虑。依著虚空无边处修习静虑。依著识无边处修习静虑。依著无所有处修习静虑。依著非想非非想处修习静虑。依著此世修习静虑。依著他世修习静虑。依著小想修习静虑。依著大想修习静虑。依著无量想修习静虑。如是静虑。有漏有取有所依著。是名菩萨世间静虑。如是静虑共诸声闻独觉乘等。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何菩萨出世静虑。谓诸菩萨远离诸蕴修习静虑。远离诸界修习静虑。远离诸处修习静虑。远离欲界修习静虑。远离色界修习静虑。远离无色界修习静虑。远离三律仪修习静虑。远离三解脱修习静虑。远离四念住修习静虑。远离四正断修习静虑。远离四神足修习静虑。远离五根修习静虑。远离五力修习静虑。远离七等觉支修习静虑。远离八圣道支修习静虑。远离地界修习静虑。远离水界修习静虑。远离火界修习静虑。远离风界修习静虑。远离空界修习静虑。远离识界修习静虑。远离乐受修习静虑。远离苦受修习静虑。远离不苦不乐受修习静虑。远离虚空无边处修习静虑。远离识无边处修习静虑。远离无所有处修习静虑。远离非想非非想处修习静虑。远离此世修习静虑。远离他世修习静虑。远离小想修习静虑。远离大想修习静虑。远离无量想修习静虑。如是静虑能发贤圣广大光明。无漏无取无所依著。是名菩萨出世静虑大甲胄轮。善男子。若菩萨摩诃萨成此静虑大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  为舍己重担　　修有所得定
  求断自烦恼　　非真智者相
  依器有所观　　求解脱修定
  取著此彼岸　　非利乐有情
  为利乐有情　　修定舍重担
  灭一切烦恼　　是真智者相
  为润诸有情　　修无依著定
  永断诸有爱　　是名大慧者
  为解诸有缚　　令住无畏城
  修行寂止定　　是名摩诃萨

大乘大集地藏十轮经卷第九
大乘大集地藏十轮经卷第十

        三藏法师玄奘奉　诏译

    福田相品第七之二

复次善男子。菩萨摩诃萨复有般若大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何般若大甲胄轮。善男子。菩萨般若有二种相。一者世间。二者出世间。云何菩萨世间般若。谓诸菩萨唯依读诵书写听闻。为他演说三乘正法。欲求除灭一切众生无明黑暗。欲求发起一切众生大慧光明。谓于如来所说种种与声闻乘相应正法精勤读诵听闻书写为他演说劝正修行。或于如来所说种种与独觉乘相应正法精勤读诵听闻书写为他演说劝正修行。或于如来所说种种与无上乘相应正法精勤读诵听闻书写为他演说劝正修行。不求贤圣无漏道支不求圣道不求圣道所摄解脱不行寂静真实般若。常行有见有相般若。如是般若有取有著。是名菩萨世间般若。如是般若共诸声闻独觉乘等。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何菩萨出世般若。谓诸菩萨精勤修习菩提道时。随力读诵听闻书写。为他演说三乘正法。而于其中依无所得方便而住。无所行动无所思惟无有根本。以如虚空心普寂灭心无增减慧无取著心无生灭心无退转心法平等心真如心实际心法界心无我心无分别心寂灭安忍离分别心。善巧安住无成坏地。善巧安住无住无著胜妙慧地。如是般若无取无著。是名菩萨出世般若大甲胄轮。善男子。若菩萨摩诃萨成此般若大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护

复次善男子。菩萨摩诃萨复有善巧方便大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉。作大福田。一切声闻独觉乘等。皆应供养承事守护。云何名为善巧方便大甲胄轮。善男子。菩萨善巧方便有二种相。一者世间。二者出世间。云何名为菩萨世间善巧方便。谓诸菩萨或为自利或为他利或为俱利。常怀彼此示现种种工巧伎术。为自及他得成熟故。承事供养诸佛世尊。或诸菩萨或诸独觉或诸声闻或母或父或诸病者或诸羸劣无依怙者。若见厄难临被害者。种种勤苦方便救济。以四摄事成熟有情。是诸菩萨自住大乘。于诸声闻及独觉乘非大乘器若诸声闻及独觉乘根未熟者。为说微妙甚深法教令其修学。或劝勤修诸圣静虑。或为开示最胜义谛劝令修行超四颠倒。觉悟四种无堕法性。或令趣入四无碍解。或复乃至劝令安住四念住四正断四神足五根五力七等觉支八圣道支有余无余道及道果。趣入巧智令其成熟。若诸有情贪求名称利养富贵。诸根躁扰善根未熟。劝令读诵诸阿笈摩及毗奈耶阿毗达磨。或劝读诵除佛所说顺解脱论令其成熟。若诸有情不乐布施。劝令惠舍种种珍财令其成熟。若诸有情暴恶不仁劝令修学四种梵住。若诸有情心多忿恚劝令修忍。若诸有情心多懈怠劝修精进。若诸有情心多散乱劝修静虑。若诸有情具足恶慧为说正法谓以记说教诫方便令其成熟。若诸有情不敬三宝具无依行劝受三归令敬三宝或劝受学近事律义。或劝受学近住律仪令其成熟。或劝修习种种工巧伎术业处令其成熟。如是等菩萨摩诃萨种种世间巧方便智过殑伽沙菩萨摩诃萨以是一切书论工巧伎术业处加行精进巧方便智。摧伏一切外道异学。如是名为菩萨世间善巧方便。此巧方便共诸声闻独觉乘等。亦作一切佛法依因。亦是善巧诸行依处。亦是善巧任运无思灭退堕法。又善男子。若诸菩萨不依明师不依善友。修行世间善巧方便。是诸菩萨愚于世间善巧方便向诸恶趣。不能随顺安住出世巧方便智。亦非一切真实福田。不能善巧知诸有情根行差别。以于善巧方便愚故。为诸声闻及独觉乘非大乘器及于大乘根未熟者。宣说大乘令其修学。又为大乘法器有情。宣说声闻独觉乘法。令修声闻独觉乘行。为独觉乘法器有情说声闻乘。令其修习声闻乘行。为声闻乘法器有情说生死法令其爱著。不为宣说厌生死法。又于善巧方便愚故。若诸有情乐行杀生。广说乃至执著邪见。为彼宣说甚深大乘。不为宣说生死流转死此生彼众苦果报。令其厌怖离诸恶法。又于善巧方便愚故。乃至若诸有情乐修净戒令修布施。若诸有情乐修安忍。劝舍安忍令修净戒。若诸有情乐修精进劝舍精进令修安忍。若诸有情乐修静虑劝舍静虑令修精进。若诸有情乐修般若劝舍般若令修静虑。如是菩萨愚于世间善巧方便。不能真实利乐有情。与诸有情为恶知识。此巧方便依有所得。有所执著。如是名为菩萨世间善巧方便。如是世间善巧方便。共诸声闻独觉乘等。此不名为大甲胄轮。亦不由此名为菩萨摩诃萨也及名一切声闻独觉真实福田。云何名为菩萨出世善巧方便。谓诸菩萨但为利他不为自利。示现种种工巧伎术。为成熟他承事供养诸佛世尊或诸菩萨或诸独觉或诸声闻或母或父或诸病者或诸羸劣无依怙者。若见厄难临被害者。种种勤苦方便救济。以四摄事成熟有情。随其意乐随其根器为诸有情宣说正法。又能渐次劝诸声闻修独觉乘。劝诸独觉修习大乘。若于声闻及独觉乘根未熟者。为说厌离生死苦法。令其修学厌离生死欣求涅槃。若诸有情乐行杀生广说乃至乐著邪见。随其根性。或为宣说生死流转死此生彼众苦果报。令其厌怖离诸恶法。或为宣说与声闻乘相应正法。或为宣说与独觉乘相应正法。或为宣说无上乘中浅近之法令渐修学。若诸有情已乐布施。为说胜上受持净戒令其修学。广说乃至若诸有情已乐静虑。为说胜上无漏圣道所摄般若令其修学。此巧方便依无所得无所执著。如是名为菩萨出世善巧方便大甲胄轮。善男子。若菩萨摩诃萨成就如是善巧方便大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等皆应供养承事守护。尔时世尊欲重显此义。而说颂曰

  所修慧有二　　世间出世间
  取著名世间　　无取著出世
  修善巧方便　　依二种差别
  有所得世间　　无所得出世
  若唯说一乘　　是名恶说法
  不能自成熟　　亦不能度他
  一向恶众生　　为说三乘教
  是则为愚痴　　不名摩诃萨
  有堪趣三乘　　欣求闻正法
  为说乐生死　　非为智者相
  专意谛思惟　　随根欲教化
  此善巧方便　　智者所称誉
  众生虽有恶　　而堪入三乘
  随根器教导　　令解脱众恶

复次善男子。菩萨摩诃萨复有大慈大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。云何大慈大甲胄轮。善男子。慈有二种。谓法缘慈。有情缘慈。法缘慈者。名为大慈。名大甲胄。有情缘慈。不名大慈。非大甲胄。所以者何。有情缘慈。共诸声闻独觉乘等。声闻独觉为自利乐。不为有情精勤修习有情缘慈。声闻独觉为自寂静为自涅槃为灭自惑为灭自结。不为有情精勤修习有情缘慈。是故此慈不名大慈。非大甲胄。其法缘慈。不共声闻独觉乘等。唯诸菩萨摩诃萨众所能修行。菩萨摩诃萨普为利乐一切有情。精勤修习此法缘慈。菩萨摩诃萨普为一切有情寂静及得涅槃灭烦恼结。精勤修习此法缘慈。是故此慈名为大慈。是大甲胄。又诸菩萨修法缘慈。不依诸蕴不依诸处不依诸界不依念住乃至不依道支不依欲界不依色界不依无色界不依此世不依他世不依此岸不依彼岸不依得不依不得。如是菩萨修法缘慈。超诸声闻独觉乘地。是名菩萨法缘大慈大甲胄轮。善男子。若菩萨摩诃萨成此大慈大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  声闻及独觉　　修有情缘慈
  心带十三过　　唯求自利乐
  菩萨大名称　　普为诸有情
  修不共大慈　　心离十三过
  心除十三垢　　为趣大菩提
  修法缘大慈　　成福田非远
  安住十三力　　出过诸有情
  犹如师子王　　超胜诸禽兽
  降伏十三怨　　离断常边执
  心无有染浊　　速证大菩提

复次善男子。菩萨摩诃萨复有大悲大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。所以者何。一切声闻独觉乘等。但为己身得利乐故而修行悲。不欲普为一切有情得利乐故修行大悲。菩萨摩诃萨不为己身得利乐故而修行悲。但欲普为一切有情得利乐故修行大悲。是故菩萨成就大悲大甲胄轮。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。是菩萨摩诃萨普为饶益诸有情故行四摄事而成熟之。谓由大悲普为利乐诸有情故行布施摄能舍一切珍宝财物禽兽仆使国城妻子乃至身命无所吝惜。行无所得为方便故。不见一切所化有情不见施者不见受者不见施物不见施行不见施行所得果报。乃至不见无所得行。如是大悲普为利乐诸有情故。行爱语摄。行利行摄。行同事摄。随其所应如上广说。乃至不见无所得行。是菩萨摩诃萨常以最胜能调伏心能寂静心无数量心不行一切蕴处界心所生无动无住大悲大甲胄轮。成熟一切所化有情心无厌倦。如是名为菩萨大悲大甲胄轮。不共一切声闻独觉。善男子。若菩萨摩诃萨成此大悲大甲胄轮。从初发心一切五欲皆能除断。得名菩萨摩诃萨也。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。尔时世尊重显此义。而说颂曰

  甚深微妙法　　所成之大悲
  难测类虚空　　无色无安住
  菩萨大精进　　具杜多功德
  胜智成大悲　　勇健超诸世
  无依怙有情　　生死苦秽缚
  大悲水沐浴　　令解脱众苦
  菩萨行大悲　　能竭生死海
  非诸声闻众　　及独觉所行
  众生贪恚痴　　迷谬堕恶趣
  濯以大悲水　　脱苦得萧然

复次善男子。菩萨摩诃萨复有能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉。作大福田。一切声闻独觉乘等。皆应供养承事守护。云何菩萨摩诃萨能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。谓诸菩萨于一切法审谛照察。如明月光遍满虚空。其心平等无依无相无住无染。普于一切三摩地门陀罗尼门。心无行动。于诸眼色眼识眼触离意染著心无行动。于眼触缘生内三受或乐或苦或非苦乐。心常寂定无所取著。于诸耳声耳识耳触。于诸鼻香鼻识鼻触。于诸舌味舌识舌触。于诸身触身识身触。于诸意法意识意触。广说亦尔。普于一切心意识中。心常寂定无所取著。于心意识所生三受或乐或苦或非苦乐。心常寂定无所取著。普于三世诸蕴界处一切品类。皆无取著心无行动。普于一切三界三行三触三受三根三乘三律仪三解脱一切品类。其心寂静无住无相无所取著平等而住。普于一切布施净戒安忍精进静虑般若波罗蜜多。心无行动寂静而住。如是普于四念住四正断四神足五根五力七等觉支八圣道支。心无行动寂静而住。普于一切九次第定。心无行动寂静而住。又于三行无障法智道支道体所引作用。皆无取著心无行动。于阿赖耶非阿赖耶有取无取有漏无漏此岸彼岸小大无量作与不作善恶无记诸品类中。心无行动寂静而住。普于一切大慈大悲善巧方便成熟有情乃至十地三不护四无所畏乃至十八不共佛法一切品类皆无取著。心无所动寂静而住。菩萨摩诃萨由此轮故能永息除三受过失。能永寂灭一切分别。能永远离一切法相。复能安住能引一切虚空眼顶诸三摩地诸陀罗尼善巧方便大甲胄轮。菩萨安住如是轮故。一切过去所引未尽恶不善业。无暇恶趣诸有诸趣。死生诸业皆能除灭。令尽无余不受果报。又善男子。譬如世界火灾将起五日出时一切世间小池大池小河大河小海大海水皆枯竭灭尽无余。如是菩萨成就能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。复能安住能引一切虚空眼顶诸三摩地诸陀罗尼善巧方便大甲胄轮。一切过去所引未尽恶不善业无暇恶趣诸有诸趣死生诸业皆能除灭。令尽无余不受果报。又善男子。譬如世界水灾起时于此三千大千世界诸小世界各四大洲八万小渚妙高山王及诸山等皆为灰水浸烂销尽令无有余。如是菩萨成就能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。复能安住能引一切虚空眼顶诸三摩地诸陀罗尼善巧方便大甲胄轮。一切过去所引未尽恶不善业无暇恶趣诸有诸趣死生诸业皆能除灭。令尽无余不受果报。又善男子。譬如黑暗遍满虚空朗日出时皆能除灭。如是菩萨成就能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。复能安住能引一切虚空眼顶诸三摩地诸陀罗尼善巧方便大甲胄轮。发起无边虚空智日。能永除灭自身四倒无明黑暗。一切过去所引未尽恶不善业无暇恶趣诸有诸趣死生诸业皆能除灭。令尽无余不受果报。又由此故于诸佛法增进自在常无退转。不复随顺恶友力行。常得不离见一切佛及诸菩萨声闻弟子不离闻法不离亲近供养众僧。于诸功德心常无厌。乃至菩提恒无间断。又常不离念佛思惟乃至梦中亦无暂废。又善男子。云何菩萨摩诃萨能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。谓诸菩萨入初静虑乃至第四静虑。入无边虚空处乃至非想非非想处。入灭受想定。住此定中一切三受三行断灭。心无行动。诸受想思触作意等悉皆断灭。安住此定或一日夜。或复乃至七七日夜受定味食。从此定起其心寂静。无所取著宴然而住。复入胜义究竟空定。住此定中其心平等。无所取著犹若虚空。身诸毛孔皆出霜液状如昴星。灭除一切郁烝结缚。从此定起得正忆念。最胜喜乐充遍其身。如大自在天子入现一切乐定身诸毛孔皆遍受乐。如是菩萨乐触其身便思念佛思念佛故则唯见佛不见余相。菩萨尔时若念一佛则见一佛。若念多佛。则见多佛。若念小身佛则见小身佛。若念大身佛则见大身佛。若念无量身佛则见无量身佛。若念自身为佛身相。则见自身同于佛身众相圆满。若念他身为佛身相。则见他身同于佛身众相圆满。若念一切情非情数所有色像为佛身相。则见一切情非情数所有色像皆同佛身众相圆满。不见其余一切色像。菩萨尔时便作是念。一切诸法一切色像皆如幻等。谛实不虚。我今复应皆悉断灭一切三受三行等法令无有余。作是念已入灭尽定。住此定中如心所期皆尽断灭。受定味食或一七日夜。或二七日夜。或三四五六七八九十七日夜。或经无量百千俱胝那庾多劫。随力所能安住此定受定味食。从此定起其心寂静。无所取著宴然而住。复入胜义究竟空定广说如前。乃至思念佛身相已。知一切法一切色像皆如幻等谛实不虚。善男子。是名菩萨摩诃萨能引遍满虚空无量无边广大众具辞无碍解一切佛法诸三摩地诸陀罗尼坚固大忍大甲胄轮。菩萨摩诃萨成就此轮。则能安住能引一切虚空眼顶诸三摩地诸陀罗尼善巧方便大甲胄轮。住此轮故。发起无边虚空智日。能永除灭自身四倒无明黑暗。一切过去所引未尽恶不善业无暇恶趣诸有诸趣死生诸业皆能除灭。令尽无余不受果报。善男子。若菩萨摩诃萨成就此轮。从初发心一切五欲皆能除断。超胜一切声闻独觉。普为一切声闻独觉作大福田。一切声闻独觉乘等。皆应供养承事守护。由此轮故于诸佛法增进自在常无退转。不复随顺恶友力行。常得不离见一切佛及诸菩萨声闻弟子。不离闻法不离亲近供养众僧。于诸功德心常无厌。乃至菩提恒无间断。又常不离念佛思惟乃至梦中亦无暂废。如是菩萨福德智慧速疾圆满。不久安住清净佛国。证得无上正等菩提。于彼佛国一切有情皆受化生色相如佛。烦恼微薄皆住大乘。尔时世尊重显此义。而说颂曰

  欲成诸法器　　断一切烦恼
  常趣入真空　　众事无难作
  为断诸有缚　　当勤修等持
  功德定相应　　必获难思慧
  修静虑无色　　灭定真空观
  起念佛胜智　　能尽一切恶
  有无一切法　　破以真空观
  永离诸恶趣　　常得见诸佛
  善修真空观　　勤学诸善法
  供养一切佛　　速当成佛果
  为有情亲友　　灭除烦恼病
  速住净佛国　　证得大菩提
  众生如佛相　　遍满于佛土
  皆趣求佛乘　　离声闻独觉

    大乘大集地藏十轮经获益嘱累品第八

佛说如是大法门时。于众会中有殑伽沙等菩萨摩诃萨。过去久习念佛思惟。今闻世尊所说念佛修观方便皆得念佛三摩地门。复有无量无边众生。闻是法已皆得一切定命华鬘陀罗尼门。复有无量无边众生。闻佛所说皆得一切首楞伽摩电光依止陀罗尼门。复有无量无边众生。闻佛所说皆得一切法自在转光明依止顺忍。复有无量无边众生。闻佛所说远尘离垢于诸法中生净法眼得预流果。复有无量无边众生。闻佛所说得一来果。复有无量无边众生。闻佛所说得不还果。复有无量无边众生。闻佛所说皆得最上阿罗汉果。复有无量无边众生。闻佛所说心求出离三界牢狱依佛出家趣入正法。复有无量无边众生。闻佛所说尽寿安住十善业道依声闻乘发心不退。复有无量无边众生。闻佛所说尽寿安住十善业道依独觉乘发心不退。复有无量无边众生。闻佛所说尽寿安住十善业道依大乘中发阿耨多罗三藐三菩提心不复退转。复有无量无边众生。闻佛所说得世正见由此正见除灭一切往恶趣因烦恼恶业增长一切向善趣因正愿善业。复有无量无边众生。闻佛所说皆受三归安住近事近住净戒乐供养佛乐听闻法乐奉事僧昼夜精勤曾无懈废。复有无量无边众生闻佛所说远离一切邪趣邪归恶意恶业于佛法中得决定信弃舍家法清净出家

尔时世尊告虚空藏菩萨摩诃萨言。善男子。吾今持此地藏十轮大记法门。付嘱汝手。汝当受持广令流布。若诸众生于此法门。有能读诵思惟其义为他解说住正行者。汝当为彼守护十法。令于长夜利益安乐。何等为十。一者为彼守护一切财位令无损乏。二者为彼守护一切怨敌令不侵害。三者为彼守护令舍一切邪见邪归十恶业道。四者为彼守护令免一切身语谪罚。五者为彼守护遮断一切谤毁轻弄。六若为彼守护令于一切轨范尸罗皆得无犯。七者为彼守护令悉除灭一切非人四大乖反非时老病。八者为彼守护不遭一切非时非理灾横夭殁。九者为彼守护命欲终时得见一切诸佛色像。十者为彼守护令其终后往生善趣利益安乐。善男子。若诸有情于此法门。有能读诵思惟其义。为他解说住正行者。汝当为彼勤加守护如是十法令于长夜利益安乐。时虚空藏菩萨摩诃萨白佛言。唯然世尊。我当受持如是法门广令流布。若诸有情于此法门。有能读诵思惟其义为他解说住正行者。我当为彼守护十法。令于长夜利益安乐

时薄伽梵说是经已。于众会中虚空藏菩萨摩诃萨．地藏菩萨摩诃萨．金刚藏菩萨摩诃萨．好疑问菩萨摩诃萨．天藏大梵等及诸天．龙．药叉．健达缚．阿素洛．揭路荼．紧捺洛．莫呼洛伽．人．非人等一切大众闻佛所说。皆大欢喜信受奉行

大乘大集地藏十轮经卷第十

    大乘大集地藏十轮经序

昔者旭照高山。天宫御一乘之驾。流晖原隰。鹿苑转四谛之轮。虽复发轸分逵。而涂无乱辙。一云普洽。而卉木各茂。自鹄林变色慧日寝光。达学电谢以息肩。真人长往而寂虑。且前贤述圣。难令各解。后进孤陋。更异亲承。况乎正法既往。久当像末。定慧与福德异时。醇化与浇风殊运。然则一乘三乘之驾。安可以同其辙哉。若识时来在数药性勿违。然后可以清沉痼之宿疾。体权实之同归矣。十轮经者。则此土末法之教也。何以明之。佛以末法恶时去圣浸远败根比之坏器。空见借喻生盲。沉醉五欲。类石田之不苗。放肆十恶。似臭身之垢秽。故此经能濯臭身开盲目陶坏器沃石田。是以菩萨示声闻之形。象王敬出家之服。以此幢相化彼无惭。显二事之护持成三乘之道果。故经曰。为令此土三宝种姓威德炽盛久住世故。又曰。摧灭一切诸众生类犹如金刚坚固烦恼。然则三宝久住。显教传于末法。金刚烦恼验障异乎一乘。寻旧经之来。年代盖久。但谱第遗目。传人失记。翻译之主既往。来兹之日罕闻。同我者失魄于真彩。异我者大笑于淡味。谬以千里。能勿悲乎。夫极曜文天。或蔽亏于薄雾。至言轨物。时沦滞于广辩。针石一违。有死生之巨痛。纤毫错学。有升坠之异涂。其可易乎。属有三藏玄奘法师者。始则学架东朝。末乃访道西域。轻一生之性命。涉数万之艰难。果能竭溟渤。以索亡珠。蹈龙宫而穷秘藏。吞法流于智海。瓶写无遗。受道气于檀林。香风更馥。至于因明三量声论八音。莫不究立破之源。穷字转之本。如来所说菩萨所传。已来未来一朝备集。昉以薄业不偶真应。幸达圣制乱于未肇。后贤传灯于既夕。遂使定死余命。冀反魂于法药。昏野迷方。期还辕于觉道。于是染翰操纸杜绝外虑务详至教释彼纷执。畴咨法主重启梵文。粤以永徽二年岁次辛亥正月乙未。尽其年十二月甲寅翻译始毕。凡八品十卷。以今所翻比诸旧本。旧本已有今更详明。旧本所无斯文具载。于是处座伉谈者。响法雷而吐辩。静虑通微者。镜玄波而照心顶火暴腹之徒。戢萤晖于慧日。喜足谦怀之侣。腾高节于清风矣前佛既往。后佛未兴。庶此教长悬。永济来者。弘道之士。如何勿思

大乘大集地藏十轮经卷十


大方等大集经

    No. 397

大方等大集经卷第一

        北凉天竺三藏昙无谶于姑臧译

    璎珞品第一

如是我闻。一时佛在王舍城耆阇崛山中往古诸佛本所住处大塔之中。诸大菩萨之所赞叹。其地洁净微妙最胜诸佛法座。诸天龙鬼乾闼婆等常行称咏。又能增长无量善根。常有诸佛微妙光明。成就无量无边功德。具足诸佛所行之处。如来得成菩提道已。转妙法轮。调伏无量无边众生。于一切法而得自在。世尊逮得一切法中无碍智慧。能善分别一切众生诸根利钝。永断一切烦恼习气。不待庄严了知诸法。与大比丘僧六万八千。一切调伏断烦恼习气。皆是佛子善解深义。悉是福田能断诸有。得净戒果不生不灭。复有无量诸菩萨僧。具无碍智甚深智无知智。大慈大悲降注法雨。能施一切甘露法味。于诸众生等心如地。增长成就助菩提法。智慧光明能破黑闇。悉能照明善恶之道。能开众生善心莲华。能令众生善根成熟。增长善芽干烦恼海。具智慧翼游空无碍。喻之如日。善能增损众生善恶。喻之如月。为诸善本如须弥山。至心寂静修行梵行。不为世论之所动转。安住无上出家之法。能见诸佛一切世界。积善法藏犹如大海。具足成就诸陀罗尼。寂静圣行及大慈悲。清净庄严定慧二目。久已远离深法怖畏。无量劫中所修菩提。未毕竟者终不休息。成就菩萨所有功德。其名曰慧光无碍眼菩萨摩诃萨。见一切田庄严璎珞菩萨摩诃萨。不断如来性出世意菩萨摩诃萨。为诸众生示现细行神足菩萨摩诃萨。无量乐说无碍神足幢名称菩萨摩诃萨。净众光(丹云生)自在王菩萨摩诃萨。善能论解字义广说论义神足菩萨摩诃萨。无量功德智慧庄严住菩萨摩诃萨。如是等菩萨摩诃萨。常与如来同止共住。如来常为分别宣说菩萨所行法门之法。尔时如来成得佛道。始十六年广知众中多修梵行悉来大集。堪任受持菩萨法藏。尔时如来即作是念。我今当于如是无量象王众中宣说菩萨所行之法。先当示现诸佛如来大神通力。为诸菩萨令知诸佛深境界故。尔时世尊即入三昧。其三昧名佛境神通实见众生。以佛功德威神力故。于欲色天二界中间出大坊庭。犹如三千大千世界。定慧二力之所成就。其处堪任佛所游居。复出大光其明清净。遍照十方诸佛世界。能令众生得知足心。于诸天宫最为殊胜。能劝十方放逸菩萨。其坊四匝白琉璃树真金为墙。功德宝室马瑙垂檐。杂宝栏楯。白真珠网以覆其上。种种幡盖以为庄严。众香涂地烧散杂香。十方世界众生所有上妙庄严悉于中现。安置无量百千万亿师子法座。其座各有无量杂色柔软敷具。能令众生欢喜爱乐。诸四天下各以七宝作四梯梐。金刚阶蹬广十由旬。如其行时出微妙音。如四天下三千大千世界亦复如是。尔时世尊从三昧起。大千世界六种振动。亦放无胜最大光明。即与声闻菩萨大众。前后围绕欲往彼坊。一切诸天尊重赞叹。香花伎乐涂末烧香曼陀罗花摩诃曼陀罗花曼殊沙花摩诃曼殊沙花等以为供养。能动无量无边世界。光明遍照无不大明。示现诸佛神通福德。当尔之时耆阇崛山一切大众忽然不现。蹬中阶节上升虚空。时无量亿诸天龙等及不护神。伎乐神。非天神。金翅鸟舞神。腹行神。嗜肉神。善饿鬼神。瓮耳鬼神。住厕罗刹。厌人鬼。能狂鬼。影鬼。产乳罗刹。持发鬼。常醉鬼。如是等众悉侍从佛。以天香花微妙天乐而供养之。尔时四天王合掌长跪以偈赞佛

  如来光明胜一切　　能坏三恶道黑闇
  今我归依乐依止　　萨婆悉达无上尊

时四天王与诸天人。偈赞佛已寻侍佛后。尔时帝释与忉利天人。于其界次阶上见佛。以天香华微妙伎乐而供养之。以偈赞佛

  如来具足六神通　　所得大悲无能胜
  以佛功德严十方　　我今敬礼无与等

时帝释与忉利天。偈赞佛已寻侍佛后。尔时夜摩天王与夜摩天子。于其界次阶上见佛。以天香花微妙伎乐而供养之。以偈赞佛

  无碍智慧无有边　　善解众生三世事
  一心能知无量心　　是故稽首礼无上

时夜摩天王与夜摩天子。偈赞佛已寻侍佛后。尔时兜率天王与兜率天子。于其界次阶上见佛。以天花香微妙伎乐而供养之。以偈赞佛

  佛知诸法如幻炎　　无受无作无字说
  愍众故说不可说　　记说无我知法性

时兜率陀天王与兜率天子。偈赞佛已寻侍佛后。尔时化乐天王与善化乐天子。于其界次阶上见佛。以天花香微妙伎乐而供养之。以偈赞佛

  如来具足得十力　　知诸法界如虚空
  无色哀愍示形色　　其心平等视众生
  如来常行世尊行　　为众生故行世行
  开无分别诸法界　　我今敬礼非天人

时化乐天王与诸天子。偈赞佛已寻侍佛后。尔时他化自在天王与他化自在天子。于其界次阶上见佛。以天香花微妙伎乐而供养之。以偈赞佛

  如戒而住寂静地　　修集无上三昧定
  其智无碍无有边　　我礼毕竟解脱者
  大慈大悲微妙语　　真实能知道非道
  勇健精进力无胜　　我今敬礼无能动
  常能修集三解脱　　无能称赞尽其德
  乌虽不同金鸟飞　　亦能任力而游翔
  我今如乌任力赞　　唯愿哀愍受微叹
  不种不收其果实　　不赞如来无解脱
  怜愍为叶智慧花　　三昧为须解脱敷
  菩萨蜂王食甘露　　我今礼佛法莲花
  大悲智慧光圆满　　能破众生无明闇
  其戒清净众乐见　　我今敬礼佛法月
  其心平等如虚空　　香涂割刺心无二
  能净无量众生垢　　我今敬礼佛法河

时他化自在天王与诸天子。偈赞佛已即寻佛后。诸天各各赞叹佛已。尔时如来示现无量神通道力。渐渐至彼七宝坊中。如四天下见佛上升。三千大千世界所见亦复如是。尔时世尊。至宝坊中升师子座。声闻菩萨各各次第坐于宝座。尔时世尊入佛三昧。其三昧名无碍解脱。一一毛孔放大光明。其数无量如恒沙等。照于东方无量世界。南西北方四维上下亦复如是。地狱蒙光众苦得息。其余众生除贪恚痴。慈心相向如父如子。尔时以佛功德力故其光明中说如是偈。为劝放逸诸菩萨故

  如来精进无量边　　精进力过无量劫
  谁能赞佛光明德　　唯有十方诸世尊
  为劝十方诸菩萨　　乐于放逸不修禅
  释迦如来放是光　　召诸菩萨集此界
  成就具足佛十力　　能破世界诸魔王
  世法不污如莲花　　是其光明无有量
  如来转此无上轮　　诸天世人所不能
  为诸众生转法轮　　如本十方佛所转
  如来今者集大会　　难见犹如优昙花
  若有信心成就者　　悉为听法至佛所

是光明中所说偈颂遍告十方。劝喻一切诸菩萨等。振动一切世界大地。普施一切众生安乐。能净一切众生烦恼。破坏众生无明痴闇。能蔽一切天魔宫殿。光遍十方还从顶入。尔时东方有佛世界。名无量功德宝聚神通。有佛世尊号净大净光七菩提分宝花无断光王。彼有菩萨名诸法自在功德花子。遇斯光已。与十恒河沙等诸大菩萨俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花而供养佛。即于佛前以偈赞曰

  一切功德到彼岸　　常为十方佛所称
  无碍名号遍十方　　大慈大悲释师子
  如来法界无差别　　为钝根者说差别
  宣说一法为无量　　如大幻师示众事

时诸菩萨偈赞叹佛头面礼已。以己神力于佛东边化作床座次第而坐。尔时南方有佛世界名曰佛光。有佛世尊号无量功德宝。彼有菩萨名曰宝杖。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花而供养佛。即于佛前以偈赞曰

  大慈法云降法雨　　常说无常空无义
  以八正水灭结火　　能长众生诸善根
  佛光能破无明闇　　能诲放逸诸菩萨
  能焦三有诸爱种　　能示真实道非道

时诸菩萨偈赞叹佛头面礼已。以己神力。于佛南边化作床座次第而坐。尔时西方有佛世界名曰光明。佛号普光。彼有菩萨名称力王。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花供养于佛。复于佛前以偈赞曰

  于无量劫发善愿　　是故得身净无漏
  如来行业如虚空　　无碍音声遍十方
  如来梵声如雷音　　此声无业非因出
  无听无受无众生　　大悲何故音声说

时诸菩萨偈赞叹佛头面礼已。以己神力。于佛西边化作床座次第而坐。尔时北方有佛世界名宝庄严。佛号无量功德庄严。彼有菩萨名大海智。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花供养于佛。复于佛前以偈叹曰

  如来无上金光明　　能坏一切世间闇
  若有众生遇斯光　　遇者悉能坏烦恼
  设身高出大千界　　神通道力无边际
  是人不能见顶相　　大悲旷世造何业

时诸菩萨偈赞叹佛头面礼已。以己神力。于佛北边化作床座次第而坐。尔时东南方有佛世界名曰无忧。佛号能坏一切闇。彼有菩萨名无胜光。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花供养于佛。复于佛前以偈赞曰

  无量界入一毛孔　　亦不娆害诸众生
  如来境界无知者　　是故神通难思议
  能令一身作无量　　而其真身无增减
  虽为众生现神变　　然其内心无憍慢

时诸菩萨偈赞叹佛头面礼已。以己神力。于佛东南化作床座次第而坐。尔时西南方有佛世界名曰善见。佛号心平等。彼有菩萨名大悲心。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花供养于佛。复于佛前以偈赞曰

  无量世中护禁戒　　犹如牦牛爱其尾
  见有毁戒生悲心　　亦不憍慢赞己身
  如来之心如须弥　　十方邪见不能动
  智慧甚深无得底　　犹如大海难思议
  佛自解脱一切有　　亦令苦缚得解脱
  所得解脱实无差　　随道行时有别异

时诸菩萨偈赞叹佛头面礼已。以己神力于佛西南化作床座次第而坐。尔时西北方有佛世界名曰坏闇。佛号大神通王。彼有菩萨名曰宝网。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界大宝坊中。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花供养于佛。复于佛前以偈赞曰

  如来世尊犹如幻　　而为众生说幻事
  宝无真物故名幻　　无有众生说众生
  如人梦中见诸色　　寤已真实无色相
  为度众生示世行　　如来真实无世行

时诸菩萨偈赞叹佛头面礼已。以己神力于佛西北化作床座次第而坐。尔时东北方有佛世界名曰净住。佛号心同虚空。彼有菩萨名无边净意。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界。见释迦牟尼佛。头面作礼右绕万匝。以妙香花供养于佛。复于佛前以偈赞曰

  佛知甚深诸法界　　常乐寂静修无想
  及知众生诸心想　　亦说诸法如虚空
  住一心中知三世　　亦复能知种种业
  不生心想众生想　　无量世修无相想

时诸菩萨偈赞叹佛头面礼已。以己神力于佛东北化作床座次第而坐。尔时下方有佛世界名曰乐光。佛号宝优钵花。彼有菩萨名庄严乐说。遇斯光已。即与十恒河沙等诸大菩萨俱共发来至娑婆世界。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花而供养佛。复于佛前以偈赞曰

  无量智者佛真子　　数如十方微尘等
  于无量劫咨问佛　　不尽如来一字义
  是故如来智无边　　功德总持亦如是
  名称力势无边际　　犹如大海十方界

时诸菩萨偈赞叹佛头面作礼。以己神力于如来下方化作床座次第而坐。尔时上方有佛世界名璎珞庄严。佛号大名称。彼有菩萨名一切法神通王。遇斯光已。即与十恒河沙等诸菩萨众俱共发来至娑婆世界。见释迦牟尼佛。头面礼敬右绕万匝。以妙香花而供养佛。即于佛前以偈赞曰

  佛身身业无边际　　心口及业亦如是
  唯佛能知佛三业　　余不知如虚空边
  如来无师无教者　　是故众生称大师
  诸佛法界叵思议　　菩提法轮入涅槃

时诸菩萨偈赞叹佛头面礼已。以己神力于佛上方化作床座次第而坐。尔时一念中间十方无量诸大菩萨。一时云集大宝坊中。尔时世尊即从三昧安详而起。謦欬之声彻于十方。一切众生悉得闻之。闻已即于佛法僧宝生信敬心。十方世界所有比丘比丘尼优婆塞优婆夷。若人非人闻佛声已身心寂静。以佛功德威神力故。悉得睹见宝阶梯蹬。于一念顷悉蹬宝阶至宝坊中。各随其位次第而坐。诸梵天人亦闻其音。梵天。大梵天。梵师天。梵众天。光天。少光天。无量光天。净天。少净天。无量净天。无云天。福德天。广果天。无诳天。无热天。善见天。乐见天。阿迦尼吒天。亦一念顷俱至宝坊。见佛世尊头面礼已。次第而坐化作床座。尔时世尊。见诸大众皆已集会。放眉间光。其光名曰示菩萨力。绕诸菩萨七匝已。于诸菩萨顶髻而入。尔时会中有一菩萨。名诸法自在功德花子。即入三昧。其三昧名璎珞庄严。以三昧力故。于宝坊中出师子座。座高八万亿多罗树。七宝庄严散种种花。为诸众生之所乐见。能净一切众生之心。尔时诸法自在功德花子菩萨摩诃萨。化作如是师子座已。从其三昧安详而起。合掌恭敬头面作礼。即于佛前以偈赞曰

  日月光明坏现冥　　佛光能坏三世闇
  如来具足神通力　　胜于一切诸天光
  佛了法界无觉知　　如幻水月无去来
  无生无受无作者　　真实知已为众说
  知色心中无色心　　方便为众说色心
  如来神通犹如幻　　知诸法界亦复然
  一切众生心常净　　或时为客烦恼污
  诸佛如来得解脱　　示现神通等如幻
  虚空无地无住处　　如来之心亦如是
  为众故升师子座　　如先诸佛说甘露
  一切大众无去来　　亦无听说无受者
  诸法悉皆如虚空　　唯愿开阐真实界
  世尊受我师子座　　愿为众生师子吼
  愍众故演梵音声　　炽然智灯破痴闇
  十方诸来听法众　　悉来集会此宝坊
  愿佛当施大法施　　破无量世贫穷际

尔时世尊。以大慈悲怜愍诸法自在功德花子菩萨摩诃萨。升其所奉师子宝座。欲说一切诸菩萨行无碍法门。具足一切佛法。十力四无所畏。入一切法自在陀罗尼法门。入四无碍智法门。入大神通法门。不退转法轮。不退住处。摄一切乘具一切法界无分别法界。善知一切众生心根。法界真实坚固难沮。能坏一切四魔怨仇。调伏一切恶见烦恼。获得不共善权方便。得大平等心无二故。一切诸佛等入之处无挂碍处。说一切法悉真实故。演说诸法非觉非非觉故。十二因缘平等相观故。具足智慧大庄严故。庄严佛身佛音声故。无尽念意行智慧故。演说真实四圣谛故。能令声闻身心净故。令辟支佛坐绍位床故。大乘菩萨得法自在故。广宣诸佛所有功德故。解说宣示一佛法故。说诸菩萨大功德故。裂诸众生疑网心故。摧灭一切恶邪论故。增长如来佛正法故。显示众生佛神力故。以如是等诸因缘故。如来升于师子宝座。尔时宝杖菩萨。承佛神力入佛璎珞庄严三昧。以三昧力故。能令大众悉得种种璎珞庄严。时称力王菩萨。复承佛神力入莲花三昧。以三昧力故悉令大众皆得妙花。供养于佛及诸菩萨。时大海慧智菩萨亦承佛神力入妙香三昧。以三昧力故能令大众皆得妙香。供养于佛及诸菩萨。时宝网菩萨亦承佛力入光明三昧。以三昧力故悉令大众身得光明。时悲心菩萨亦承佛神力入无瞬三昧。以三昧力故。悉令大众仰瞻如来目未曾瞬。时无边净意菩萨亦承佛神力入喜三昧。以三昧力悉令大众喜乐听法。时庄严乐说菩萨亦承佛神力。入寂静意三昧。以三昧力悉令大众远离五盖。时一切法神足王菩萨亦承佛神力入不忘三昧。以三昧力悉令大众专念菩提心不忘失。时勇健菩萨亦承佛神力入无胜三昧。以三昧力悉令大众摧伏诸魔。时破魔菩萨亦承佛神力入坏魔三昧。以三昧力召此三千大千世界一亿魔王。来集宝坊至于佛所。头面作礼合掌恭敬。咸作是言。唯愿如来。广为众生开甘露门。我等皆因破魔菩萨威神力故。当得远离一切魔业。于诸大众心无妨碍。佛言善哉善哉。善男子。汝等今已得离魔业。以是因缘于未来世复当得离一切魔业。善男子。譬如一处百年闇室一灯能破。汝等亦尔。无量世中无明黑闇。今日能破如日月宝光。住信戒施慧禅定亦尔。善男子。汝等今者请佛说法。以是因缘。汝等当得破无明闇。为诸众生作智慧明。尔时众中有一菩萨名法自在王。白佛言。世尊。如来境界不可思议。何以故。如来发心将欲说法。能令一切大众云集。为菩提故作大庄严大法神通。无量世间得大名称。身心寂静获得解脱。及得不可思议法界十方诸佛之所赞叹。具足一切十波罗蜜。成就通达善权方便。能裂一切诸魔疑网。能灭众生恶邪诸论。能善分别一切法界。逮得具足无碍智慧。具念意行智慧勇健。具足获得四无碍智。善知众生诸根利钝。知众生界随意说法。常能宣说清净法界。善解一切方俗之言。能得一切清净梵音。具足成就慈悲之心。诸邪异见不能令动。不可破坏如金刚山。具修三相建立法幢。已渡甚深十二因缘河。断断常见能调大众。无量劫中得不可思议法聚。能疗众病如大医王。闻深法已不生怖畏。三十二相八十种好庄严其身。具足成就三十七品及八解脱。身口意业纯善无杂。能令众生悉来听法。世间之法所不能污。常受安乐常修法界。惠施法宝于法无厌。于诸有法心不染着。犹如莲花尘水不染。明胜诸光智深如海。绍三宝性调众生界。能开佛藏护持佛法。具足无量功德智慧。无量劫中修集庄严无量功德。常欲获得一行之心一色一处。具如是等功德菩萨悉来集会。唯愿如来。说菩萨行无碍法门。利益过去未来现在诸菩萨等。令初发心得不退故。久发心者得增长故。行菩提道得净意故。不退菩萨学佛法故。一生菩萨璎珞庄严故。后身菩萨得阿耨多罗三藐三菩提故。定性众生增长因缘故。未定性者作因缘故。未入佛法者令得入故。已入佛法者敬佛法故。乐三乘者说一乘故。施于世间人天乐故。世尊。如来出世。有如是等不可思议事。世尊。今此大众一一菩萨。悉能示现诸大神通。是故诸佛及诸菩萨不可思议。世尊。云何众生无明爱重。虽见菩萨如是神通。而故生于声闻缘觉卑下之心世尊。菩萨初发菩提心时。已胜一切声闻缘觉。世尊。譬如有人舍诸琉璃取于水精。一切众生亦复如是。舍于大乘喜乐声闻辟支佛乘。若有众生已发欲发阿耨多罗三藐三菩提心者。如是之人悉当获得如是功德。尔时会中有三十亿那由他百千万亿众生天与人。发阿耨多罗三藐三菩提心

    大方等大集经陀罗尼自在王菩萨品第二之一

尔时世尊。知诸菩萨悉已大集。作是思惟。今日如是善丈夫等。咸欲得知诸法实义。能持如来甚深法藏。欲得闻受诸菩萨行无碍法门。寻放眉间白毫光明。名无所畏。绕诸大众满七匝已。于陀罗尼自在王菩萨顶上而入。尔时陀罗尼自在王菩萨。承佛神力。化作宝盖。犹如三千大千世界。七宝庄严。以覆如来宝座之上。头面作礼合掌长跪。说偈赞佛

  如来于法得自在　　其光能破世间闇
  世尊佛眼无挂碍　　能见诸法真实义
  具足无量诸功德　　无师独悟诸法界
  如来放光为众生　　今入我身何因缘
  我本所知念不明　　陀罗尼根亦如是
  此光今来入我身　　了了得知诸法界
  身心获得大清净　　受乐无上无有边
  我今已知佛境界　　亦得乐说无碍辩
  十方诸佛亲近难　　愚者不能师事之
  我今承佛神力故　　欲少发问利众生
  何因缘发菩提心　　复以何义佛出世
  何缘放光遍十方　　复以何因示神通
  何缘佛为众授记　　愿为大众分别说
  今此大众胜无上　　悉能受持佛法界
  此众无魔及魔业　　唯有开示佛法藏
  我智浅近有边崖　　何能咨请无上尊
  今问如来无边智　　云何得知诸方便
  愿今教诲诸弟子　　我学已得法自在
  得已能施大法雨　　当报十方诸佛恩

世尊。诸佛如来不可思议。菩萨所行无有边际。是故我今欲问如来无上法王大慈悲聚。为利众生问甚深义。云何名为菩萨之行。以何璎珞庄严菩萨。能令菩萨所行清净。云何能坏愚痴诸闇。云何能断疑网之心。云何菩萨为诸众生修慈悲心。云何菩萨拥护众生。云何菩萨真实能修菩萨之业善业不诲业。唯愿如来哀愍宣说。又此大众利根智慧。能解佛语能知法界。能达菩萨所行无碍法门。能坏一切魔及魔业。破大疑心能解诸佛甚深境界。知众生界众生心性。能见无量诸佛世界。能护如来无上正法。能于诸法得大自在。尔时佛赞陀罗尼自在王菩萨言。善哉善哉善男子。能问如来甚深之义。能善行佛无量行者。乃能如汝发斯深问。汝今至心。当为汝说。菩萨若能成就具足如是功德。当于诸法得大自在。世尊。今正是时唯垂宣说。佛言善男子。菩萨有四璎珞庄严。一者戒璎珞庄严。二者三昧璎珞庄严。三者智慧璎珞庄严。四者陀罗尼璎珞庄严。戒璎珞庄严有一种。谓于众生无有害心。菩萨若无恶害之心。一切众生常所乐见。复有二种。一者闭塞恶道。二者能开善门。复有三种。一者身净。二者口净。三者意净。复有四种。一者所求悉得。二者所愿具足。三者所愿成就。四者所欲能作。复有五种。一者信。二者戒。三者定。四者念。五者慧。复有六种。一不破戒。二不漏戒。三不杂戒。四不悔戒。五自在戒。六无属戒。复有七种。所谓七净。一者施净。二者忍净。三者精进净。四者禅定净。五者智慧净。六者方便净。七者善方便净。复有八种。谓八具足。一者无作具足。二者地具足。三者不忘心具足。四者不缓具足。五者诸根具足。六者佛世具足。七者离难具足。八者善友具足。复有九种。一者不动。二者不畏。三者定智。四者寂静。五者至心。六者清净。七者结缓。八者调心。九者住调伏地。复有十种。一者净身。为三十二相故。二者净口。为言无二故。三者净意。为解脱故。四者净田。为令众生福德增故。五者净心。为调众生故。六者净有。为行化众生故。七者菩萨名净。为得如来诸功德故。八者净慧。大神通故。九者净方便。破诸魔众故。十者净戒。为不共法故。善男子。如是等事。名戒璎珞庄严。三昧璎珞庄严有一种。所谓为诸众生修集慈心。复有二种。一者质直。二者柔软。复有三种。一不虚诳。二不粗犷。三不邪谄。复有四种。一者不爱行。二者不嗔行。三不畏行。四不痴行。复有五种。所谓远离五盖三昧。复有六种。所谓修集六念三昧。复有七种。所谓修集七觉三昧。复有八种。所谓修集八正三昧。复有九种。一者菩萨修集菩提心及大慈悲心。于一切无量众生修集念心。远离恶欲不善之法。有觉有观寂静喜乐得初禅。二者远离觉观内得喜心。至心思惟无觉无观。定生喜乐得第二禅。三者离喜修舍具足念心。无有放逸身受安乐得第三禅。四者远离苦乐灭忧喜心。非苦非乐修集舍念寂静念得第四禅。五者远离色相修无量空相。六者远离空相修无量识相。七者远离识相修无所有相。八者远离无所有相修非想非非想相。九者虽未成就善方便智。以三昧力教化众生。复有十种。一者观法无有错谬。二者具足成就舍摩他。三者精进无有休息。四者善能了知时节。五者至心受持善法。六者寂静其心。七者观身。八者常观法界。九者心得自在。十者获得圣性。是名三昧璎珞庄严。善男子。智慧璎珞庄严有一种。所谓心无疑网。复有二种。一者远离疑心。二者远离嗔心。复有三种。一者远离无明。二者破无明[穀-禾+卵]。三者作大光明。复有四种。一者知苦。二者断集。三者证灭。四者修道。复有五种。一者戒众清净。二者定众清净。三者慧众清净。四者解脱众清净。五者解脱知见众清净。复有六种。一者净檀波罗蜜有三种。一者内净观法如幻。二者众生净观之如梦。三者菩提净不求果报。二者净尸波罗蜜有三种。一者观身如影。二者观口如响。三者观心如幻。三者净羼提波罗蜜有三种。一者闻毁不嗔。二者闻赞不喜。三者若被割截及夺命时能观法界。四者净毗梨耶波罗蜜复有三种。一者不想。二者坚固。三者不见法相。五者净禅波罗蜜有三种。一者不着诸法。二者心不退转。三者所缘清净。六者净方便波罗蜜有三种。一者摄取众生。为解脱故。二者净陀罗尼。为持法故。三者所愿清净。为净佛土故。复有七种。一者修四念处不取不着。二者修四正勤不出不灭。三者修四神足身心清净。四者修于五根知根无根。五者修于五力能破烦恼。六者修菩提分知法界真实。七者修集圣道无有去来。复有八种。一者修定。为毕竟净故。二者修智。为坏闇故。三者修知阴智。为知法众故。四者修知界智。为解法界等虚空故。五者修知入智。为知法性平等故。六者修知十二因缘智。观无我无我所故。七者修观谛智。坏四倒故。八者修集分别知法界智。为知真实故。复有九种。一者观无常想。二者观无常苦想。三者观苦无我想。四者观食不净想。五者观于世间不可乐想。六者观诸生死多过患想。七者观解脱想。八者观离贪想。九者观于尽想。复有十种。一者观于诸法犹如幻想。二如梦想。三如炎想。四如响想。五如芭蕉树想。六如水中月想。七如影想。八者观于法界无增减想。九者观诸法界无有去住。十者观于无为无有生灭。是名为慧璎珞庄严。善男子。陀罗尼璎珞庄严有一种。所谓念心。复有二种。一者先受。二者毕竟能持。复有三种。一者知义。二者知字。三者知说。复有四种。一者正语。二者了语。三者无碍语。四者不谬语。复有五种。所谓五依。一者依义不依于字。二者依智不依于识。三者依了义经不依不了义经。四者依法不依于人。五者依出世不依于世。复有六种。一者如说而持。二者所言诚实。三者发言人所乐闻。四者怜愍语。五者生善芽语。六者时语。复有七种。一者利语。二者庄严语。三者无碍语。四者无滞语。五者无二语。六者先知而语。七者了语。复有八种。一者知方俗语。二者知鬼神语。三者知诸天语。四者知诸龙语。五者知乾闼婆语。六者知阿修罗语。七者知金翅鸟语。八者知畜生语。复有九种。一者无畏语。二者无缩语。三者无难语。四者知解说语。五者知如法答语。六者知广说语。七者知次第语。八者说无常语。九者无尽语。复有十语。一者坏疑网语。二者开示界语。三者开法门语。四者开智慧语。五者破闇冥语。六者解一一字语。七者赞叹佛语。八者呵烦恼语。九者分别根利钝语。十者开佛功德妙语。善男子。是名陀罗尼璎珞庄严。尔时世尊欲重宣此义以偈颂曰

  四庄严璎珞　　能端严大乘
  所谓戒定慧　　无上陀罗尼
  能令三业净　　一切人所爱
  永断三恶道　　是名戒璎珞
  如愿得具足　　获得人天身
  能修勤精进　　是名戒璎珞
  能修无上定　　得二种解脱
  见无上涅槃　　是名戒璎珞
  其戒不破漏　　无上戒不杂
  能得大自在　　名璎珞庄严
  戒净能净施　　戒净能净忍
  戒净净五度　　名戒璎珞严
  戒净能净有　　净大不放逸
  无畏心不悔　　是名戒璎珞
  戒净得圣性　　亦能净身心
  获得无边定　　是名戒璎珞
  不怖畏不动　　定得清净有
  能断烦恼缚　　是名戒璎珞
  能调难调根　　能得大名称
  庄严自在心　　是名戒璎珞
  能如说而作　　能净口四种
  远离诸烦恼　　名璎珞庄严
  能净自佛土　　能调诸众生
  能修大慈悲　　名璎珞庄严
  不作诸恶业　　修于菩萨行
  能大力无畏　　名璎珞庄严
  能严大涅槃　　能得大因果
  慈心满众生　　名璎珞庄严
  能离悭诳心　　修柔软四摄
  断爱嗔怖痴　　名璎珞庄严
  能破五恶盖　　修集十念心
  助道不放逸　　名璎珞庄严
  具足于二翼　　如法思惟义
  乐素住寂静　　名璎珞庄严
  于法无所疑　　亦无痴乱心
  真实解四谛　　名璎珞庄严
  持戒心无著　　亦复不生慢
  不取戒戒者　　名璎珞庄严
  无上慧净定　　亦知二净慧
  能了知三界　　名璎珞庄严
  意净不生慢　　见不净不轻
  知法不可说　　名璎珞庄严
  慧能庄严智　　智亦庄严慧
  自他菩提净　　名璎珞庄严
  知法如梦幻　　不说诸法无
  能随世间说　　名璎珞庄严
  慧能庄严戒　　戒能璎珞慧
  身口菩提净　　名璎珞庄严
  见法如水月　　亦如热时炎
  说法如响相　　如乾闼婆城
  非法不作法　　名慧璎珞严
  慧能庄严忍　　忍能庄严慧
  身口菩提净　　名璎珞庄严
  随法不增减　　解已调众生
  至心观法身　　名璎珞庄严
  慧能庄严进　　进能庄严慧
  不悔动心净　　名璎珞庄严
  慧能庄严定　　定能庄严慧
  能说深法界　　得无胜神通
  能知诸方便　　得无上总持
  法土众生净　　名璎珞庄严
  知众根利钝　　坏烦恼诸魔
  身心得自在　　名璎珞庄严
  道无有去来　　亦无去来者
  非过非未来　　非现非修者
  不分别法界　　能净毕竟定
  知诸阴入界　　名慧炬庄严
  阴入界如空　　无我无我所
  生灭因十二　　是名智慧净
  谛知第一义　　亦知阴入界
  于法不生诤　　知三世无碍
  分别三聚众　　能为说三乘
  能以三宝教　　修三无相定
  无相知一相　　非幻知如幻
  无说能为说　　空说于不空
  诸法非常变　　不毁坏法界
  和合因缘故　　流布于法界
  是名为真智　　不分别法界
  知二动不动　　知于二浅深
  知二常无常　　是名大净智
  常不失念心　　了知于法界
  知字及知义　　于世谛无闇
  一闻能持法　　解了众生语
  能坏诸邪道　　修于无上智
  依无上四依　　璎珞大总持
  我说功德鬘　　为严菩提心
  于众说无畏　　善解天神语
  能坏众疑网　　能开诸法界
  能赞于三宝　　劝人令供养
  亲近佛与众　　修集无上智
  我说四璎珞　　能严佛菩萨
  若有至心信　　即得是庄严

大方等大集经卷第一

    大集经第一卷校正后序

按此经国本宋本。皆六十卷。凡十七品。丹藏中。三十卷十一品。又经初首。国宋两本则有璎珞品名。丹藏所无。其虚空藏品。两本在不可说后。丹藏在无言品前。又于宝髻品后。两本有无尽意品四卷。丹藏即无。而有日密分三卷。如是不同者何耶。今以开元录前后文。括而统之。此经凡有六本。录云。按梁沙门僧祐大集记云。有十二段说。共成一经。第一璎珞品。二陀罗尼自在王品。三宝女品。四不眴品。五海慧品。六无言品。七不可说品。八虚空藏品。九宝幢品。十虚空目品。十一宝髻品。十二无尽意品。按云。此则第一本也。今以品次验之。是两本六十卷中。前分三十卷矣。又云。今捡经本。与祐记不同。第一陀罗尼自在王菩萨品。二宝女品。三不眴品。四海慧品。五虚空藏品。六无言品。七不可说品。八宝幢分。九虚空目分。十宝髻品。十一日密分。按云。此则第二本也。今以品次验之。则今丹藏经三十卷者是矣。又云。隋朝僧就合大集经。乃以明度五十校计经。题为十方菩萨品。编月藏后。及无尽意成五十八卷者。按云。此则第四本也。又云。其合大集经。亦有六十卷成者。三十一二两卷。重有宝髻品。足成六十卷。其宝髻品在日密前。二十六七卷是。此复重编。未详何意。又日密日藏梵本不殊。重重编载误之甚矣。按云。此则第五本也。今以品次验之。则今两藏本经六十卷者是矣。但不重载宝髻品。斯为小异耳。即于前第四本五十八卷经中。分彼日藏分十卷。为十二卷。足成六十耳。其第三第六两本。今以诸藏所无。故不烦叙。经本如是不同。藏中致斯有异耳。谨按开元录前后文相。今此两藏本经六十卷者。有六失故不可依行。录云。亦有经本。分为璎珞品者不然。此是一段不合分二。按云。此经分之一失也。又云。僧祐记中无日密分。有无尽意品者不然。今以无尽意经。虽大集别分。非无谶译。又非次第不合入中。按云。此经入中。又为无谶译。二失也。又云。其虚空藏品。祐在不可说后。未详所以。按云。此经在彼。三失也。又云。日密日藏梵本不殊。重重编载。误之甚矣。按云。此经重载。四失也。又云。明度五十校计经。题为十方菩萨品。编月藏后者非也。既无凭准故不依彼。按云。此经依之。五失也。又明度经安世高译。而云那连提耶舍译。按云。此亦误人。六失也。不独如是。其十方菩萨品。即下难函中。明度五十校计经二卷耳。无尽意品。即下最函中。无尽意经六卷耳。而于此中并重编之。是亦杂沓难依者也。是则理须正之。正之如何。略则如开元录及丹藏经。为三十卷乃正矣。合则如开元录中第六本。为八十卷方备矣。然今不能即正者。以此六十卷本是本朝芬皇宗选行经。行来已久久。则难变耳大方等大集经卷第二

        北凉天竺三藏昙无谶于姑臧译

    陀罗尼自在王菩萨品第二之二

佛复告陀罗尼自在王菩萨。善男子。菩萨摩诃萨有八光明。以是八明能坏诸闇净菩萨行。何等为八。一者念光。二者意光。三者行光。四者法光。五者智光。六者实光。七者神通光。八者无碍智光。念光有八种。一者不失过去善法。二者作未来善。三者。闻法不忘。四者思惟实义。五者不为六尘所坏。六者忆持如守门人遮止恶法。为真善法守善法城门。七者不为邪法之所诳惑。八者能大增长纯善之法。是名念光八种。意光亦有八种。一者义意非字意。二者智慧意非识意。三者法意非人意。四者实意非虚意。五者菩萨意非声闻意。六者上意非下意。七者佛意非退意。八者怜愍意非害意。是名意光八种。行光亦有八种。一者法行。二者一切行。三者众生行。四者众生心行。五者十二因缘行。六者广说行。七者行行。八者一切佛法行。是名行光八种。法光亦有八种。一者世法光。二者出世法光。三者无漏法光。四者无为法光。五者解脱法光。六者心解脱法光。七者毕竟解脱法光。八者破无明慧法光。是名法光八种。智光亦有八种。一者八正智光。二者须陀洹智光。三者斯陀含智光。四者阿那含智光。五者阿罗汉智光。六者辟支佛智光。七者菩萨智光。八者正觉智光。是名智光八种。实光亦有八种。一者正定行。二者得须陀洹果。三者斯陀含果。四者阿那含果。五者阿罗汉果。六者辟支佛果。七者菩萨。八者佛菩提。是名实光八种。神通光亦有八种。一者眼光。能见正色。二者耳光。能闻正声。三者念光。能念过去阿僧祇劫所有众生。四者性光。为观性净众生之心。五者虚空光。以大神通光。遍到十方无量世界。六者方便光。具无漏智故。七者功德庄严光。为利益一切众生故。八者智慧庄严光。为坏一切众生疑心故。是名神通光八种。无碍智光亦有八种。一者智光。二者意光。三者慧光。四者佛光。五者正见光。六者净众生心光。七者解脱光。八者毕竟光。是名八无碍智光。尔时世尊欲重宣此义而说偈言

  修集于念心　　不忘善恶业
  乐闻赞诵经　　修集不放逸
  能调伏诸根　　安住于寂静
  增长于善法　　修集于念光
  能遮止恶法　　犹善守门者
  能守护法城　　不令四魔入
  不随逐音声　　思惟真实义
  亲近善知识　　喜乐如法住
  其意无边上　　永断诸烦恼
  邪法不能动　　恶世不生谤
  诚心念菩提　　不说小乘心
  常乐念上意　　为众破下意
  不畏魔烦恼　　修集大慈悲
  不念害众生　　其得大智光
  能坏诸疑心　　解了甚深义
  知真实方便　　修四无碍智
  乐观十二缘　　众生之所因
  知无作受者　　能修大光法
  能知诸佛法　　行世出世行
  能到十方土　　了知人天业
  修集无上智　　说三归一乘
  修集八正道　　为坏三世法
  于有漏无漏　　如实而知之
  能利益人天　　令断有漏法
  不谬为无为　　真实而知之
  寂静光无暗　　不著有为相
  知结入出缘　　知众心性净
  若有大乘定　　即知如是法
  乐住无漏流　　了四沙门果
  知菩提道行　　故修无碍智
  破邪修实光　　入众无所畏
  乐说真实义　　为破生死法
  眼耳净无障　　能见闻色声
  过去念不谬　　亦了知他心
  到十方无碍　　知法如虚空
  得无漏智慧　　为调诸众生
  具功德智慧　　为利诸众生
  于无量世中　　求是二庄严
  乐受持净戒　　乐护于佛法
  修集真实光　　为于如法住
  我说无量光　　为令众生得
  有信此经者　　即得此诸光

尔时世尊复告陀罗尼自在王菩萨。善男子。菩萨摩诃萨修集大悲有十六事。何等十六。一者菩萨摩诃萨见诸众生贪着我见。以我见故增长诸见。常为生死之所系缚。是故菩萨为此众生修大悲心。悲因缘故宣说法化。为坏众生如是妄见。二者见诸众生心怀颠倒。常见无常无常见常。苦见于乐乐见于苦。净见不净不净见净。我见无我无我见我。是故菩萨为此众生修集悲心悲因缘故宣说法要。为坏众生如是四倒。三者见诸众生心怀憍慢。实无有物而生物想。实无有事而生事想。以是因缘起七种慢。以是慢故增长恶法。是故菩萨于此众生修集悲心。悲因缘故宣说法要。破坏众生如是憍慢。四者见诸众生五盖所覆。以覆盖故。心多生疑不解深义。是故菩萨于此众生修集悲心。悲因缘故宣说法要。为坏众生如是五盖。五者见诸众生沈六入海。眼取色相。耳取声相。鼻取香相。舌取味相。身取触相。意取法相。是名为沈。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为拔众生如是沉没。六者见诸众生有七种慢。一者慢。二者大慢。三者慢慢。四者我慢。五者增上慢。六者下慢。七者邪慢。菩萨摩诃萨。于下慢者。自言胜汝。于慢慢者。自言最胜我色胜乃至识胜。于增上慢者。菩萨语言。汝实非圣。不应便起圣人之想。为邪慢者。宣说正见。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生如是憍慢。七者见诸众生离于圣道。乐行世道恶道。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生世道恶道。八者见诸众生造恶道行。属无明爱妻息所系不得自在。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生如是系缚。出离恶道。九者见诸众生亲近恶友远离善友。其心甘乐造作恶业。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生如是恶业。远离恶友亲近善友。十者见诸众生造作悭贪。于无明爱心无厌足为施智慧。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生如是悭贪无明及爱。施与智慧。十一者见诸众生我见断见。为施众生十二因缘真智慧故。菩萨于此而生悲心。悲因缘故宣说正法。为断众生我见断见。施与十二因缘智故。十二者见诸众生行无明闇。我见众生见命见士夫见。别异见邪见着见。菩萨为施智光明故。于此众生而生悲心。悲因缘故宣说正法。为断众生如是所见。十三者见诸众生乐于生死。于五聚阴而生亲想。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为断众生如是三有。十四者见诸众生为魔所缚。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为坏众生如是魔网。十五者见诸众生甘乐快乐。而不能知真实乐因。是故菩萨于此众生修集悲心。悲因缘故宣说正法。示诸众生真实乐因。十六者见诸众生求涅槃门不能知处。是故菩萨于此众生修集悲心。悲因缘故宣说正法。为此众生开涅槃门。善男子。菩萨修悲。悉因如是十六因缘

善男子。一切众生有三十二不善之业。菩萨见已修集善业。为坏众生如是恶业。何等三十二。一者有诸众生无明睡眠。菩萨见已修集智慧。为悟众生如是睡眠。二者见诸众生下解下欲。菩萨见已修集上解上欲。为以大乘而教化之。三者有诸众生乐为非法。菩萨见已修集正法。为令众生于诸法中得大自在。四者有诸众生修集邪命。菩萨见已修于正命。为坏众生如是邪命。五者有诸众生入于邪林。菩萨见已修集正见。为令众生出邪林故。六者有诸众生乐为放逸。菩萨见已修不放逸。为令众生离放逸故。七者有诸众生乐为粗穬。菩萨见已修如法住。为坏众生如是粗穬。八者有诸众生悭贪吝惜。菩萨见已修一切施。为坏众生悭贪心故。九者有诸众生毁犯禁戒。菩萨见已修持净戒。为破众生毁禁心故。十者有诸众生心常嗔恨。菩萨见已修慈悲忍。为坏众生如是嗔恨。十一者有诸众生懒惰懈怠。菩萨见已修勤精进。为坏众生如是懈怠。十二者有诸众生其心狂乱。菩萨见已修集定心。为坏众生如是狂乱。十三者有诸众生邪智覆心。菩萨见已修集正智。为坏众生如是邪智。十四者有诸众生说义颠倒。菩萨见已思惟正义。为坏众生如是颠倒。十五者有诸众生乐造世行。菩萨见已修善方便。为坏众生乐世行故。十六者有诸众生系属烦恼。菩萨见已先自除断。为坏众生烦恼系缚。十七者有诸众生我见所缚。菩萨见已自除我见。为断众生如是我见。十八者有诸众生诸根不调。菩萨见已自调诸根。为调众生如是不调。十九者有诸众生。说言无作无有受者。菩萨见已宣说有作及有受者。为坏众生如是邪说。二十者有诸众生不知恩义。菩萨见已说知恩法。为坏众生如是不知恩义。二十一者有诸众生未得谓得。菩萨见已修集正法。为坏如是增上慢故。二十二者有诸众生恶口粗穬。菩萨见已修善。口语。为坏众生如是恶口。二十三者有诸众生贪无厌足。菩萨见已修集知足。为坏众生不知足故。二十四者有诸众生。不能恭敬父母师长。菩萨见已修不放逸。为令众生供养恭敬父母师长。二十五者有诸众生贫穷困苦。菩萨见已修集七财。为坏众生如是贫穷。二十六者有诸众生。常为四大毒蛇所病。菩萨见已修身念处。为令众生远离如是四大毒病。二十七者有诸众生行无明闇。菩萨见已修集智慧。为令众生然慧灯故。二十八者有诸众生乐三有狱。菩萨见已修出离道。为示众生知出离故。二十九者有诸众生常行左道。菩萨见已修集右道。为令众生舍左道故。三十者有诸众生贪着身命。菩萨见已于自身命修不贪着。为令众生舍贪着故。三十一者有诸众生。不能恭敬供养三宝。菩萨见已修集信心。为令众生信三宝故。三十二者有诸众生。实非世尊自谓世尊。菩萨见已修集六念。为令彼等知真实法故。善男子。是名众生三十二业。菩萨见已修治自业。成就具足一切善法坏诸恶业。劝诸众生令行善业。善男子。菩萨摩诃萨有无量业。何以故。众生烦恼有无量门。为闭众生烦恼门故。菩萨修集无量善业。善男子。如恒河沙等世界众生。悉住声闻辟支佛乘。欲比菩萨初发心业。百分千分不可为喻。何以故。二乘之人自为解脱观于烦恼。菩萨不尔。常为众生得解脱故观诸烦恼。善男子。菩萨摩诃萨所作诸业。于诸凡夫二乘业中最为殊胜。何以故。众生之业性是颠倒。二乘之业有边际故。菩萨之业无边无量。是故菩萨胜于一切声闻缘觉

尔时陀罗尼自在王菩萨闻是法已。心生欢喜踊跃无量。白佛言。世尊。甚奇甚特。快说如是不可思议。如来于此已说菩萨璎珞庄严。菩萨光明。菩萨大悲。菩萨善业。唯愿宣说。云何如来观诸众生起于大悲。云何名悲。悲有何行。有何相貌。何因缘起。云何名佛业。佛业有何行。有何相貌。有何因缘起。善哉世尊。一切知见。唯愿广说如来之业。佛言。善哉善哉。善男子。汝今谛听善思念之。吾当为汝分别解说。善男子。一切如来所有大悲不出不行。何以故。常不变故。无量劫中修集得故。是故大悲不行不转。不修不舍亦能为于一切众生。善男子。一切诸佛所有大悲。无量无边其心平等。从久远来。无量舌力不能宣说。善男子。如来世尊。未尝远离如是大悲。无上菩提及与大悲。如是二法等无差别。如来所得无上菩提无根无住。根名我见。住名四颠倒。如来世尊知根知住。是故菩提无根无住。一切众生皆悉无有无根无住。欲施众生无根无住起大悲心。如来于此欲令知故演说正法。善男子。夫菩提者清净寂静。云行为净。云何寂静。净名为内。寂静名外。内名眼空。空名无我。无有我所。何以故。性是一故。乃至意亦如是。何以故。性是一故知眼空已。不着于色不着色心。是名寂静。乃至意法亦复如是。一切众生不知菩提清净寂静。如来于此而起大悲。演说正法为令知故。善男子。一切众生心性本净。性本净者。烦恼诸结不能染着。犹若虚空不可沾污。心性空性等无有二。众生不知心性净故。为欲烦恼之所系缚。如来于此而起大悲。演说正法欲令知故。善男子。夫菩提者不取不舍。云何不取。如来不见一切诸法此岸彼岸。何以故。一切诸法离此彼故。如来世尊如实知之。是名不取。云何不舍。一切众生不知法界。如来教令了了知故。是名不舍。如来于此而起大悲。演说正法为令众生知是二法。善男子。夫菩提者无想无缘。云何无想。不见眼识乃至意识。不见色相乃至法相。于是法中不知不见故无取着。是名无缘。无想无缘是名圣行。云何圣行。所谓不行三界之行。善男子。如是不行名为圣行。一切圣人不行于行。众生不行如是圣行。如来于此而起大悲。演说正法欲令知故。善男子。夫菩提者非是三世。非三世者名为三等。过去意未来识现在贪。是名三分。以能了了知三分故。意识及贪无有住处。以是义故。不念过去不求未来不爱现在。若见三世悉平等者。是名正见。如来为令一切众生得如是等平等正见。而起大悲演说正法。善男子。夫菩提者。无身无为非眼识界。乃至非意识界。是名无身。不生不灭不尽不住无有三相。是为无为。善男子。一切法性是名无性。若无性者则无有二。是故菩提无身无为。一切众生不知菩提无身无为。如来为令了了知故。而起大悲演说正法

善男子。夫菩提者。无有分别无有句义。云何分别。云何句义。无所住者名无分别。字不摄故名无句义。非有二故名无分别。不入法界名无句义。无动摇故名无分别。不变易故名无句义。不可说故名无句义。空故名无分别。无觉观故名无分别。无相故名无句义。不发故名无分别。无愿故名无句义。知众生界同于虚空。名无分别。无众生界名无句义。不生故名无分别。无宅故名无句义。不灭故名无分别。无为故名无句义。不行故名无分别。平等故名无句义。知平等故名无分别。寂静故名无句义。众生不知如是等义。如来为令了了知故。而起大悲演说正法。善男子。夫菩提者。不可以身得。不可以心得。何以故。身心如幻故。若能了知身心真实。是名菩提。为流布故名为菩提。而其性相实不可说。善男子。夫菩提者。不可说身不可说心。不可说法不可说非法。不可说有不可说无。不可说实不可说空。何以故。性不可说故。菩提者无有住处。不可宣说。犹如虚空。为真实知一切诸法。不可宣说。字中无法法中无字。为流布故。故可宣说。一切凡夫不知真实。是故如来于此众生而起大悲。演说正法为令知故。善男子。夫菩提者无取无缘。云何无取。云何无缘。知眼真实名为无取。知眼无境名为无缘。乃至知意真实名为无取。知意无境名为无缘。如来世尊以如是义。知于菩提无取着故名为无取。无屋宅故名为无缘。眼识不住于彼色中名无屋宅。乃至意识亦复如是。一切众生心无住处。如来世尊。如实而知心无住处。无住处者有四种。色受想行。于是四法心无所住。是名心无住处。是故名为一切诸法悉无住处。如来世尊如实知之。一切凡夫不能知故。如来于此而起大悲演说正法。善男子。夫菩提者名之为空。而菩提中无有空相。是故名空。一切法空菩提亦尔。如来世尊。真实能知如是之空。是故如来名为知空。诸佛名觉。一切诸法而不觉知。空中之空亦能了知。无上菩提空及菩提即是一如。空与菩提是一非二。离空菩提别有法者可得说二。以无二故名之为空。无名字故名之为空。无相貌故名之为空无威仪故名之为空。无修行故名之为空。无言说故名之为空。善男子。第一义者谓无诸法。云何说空。善男子。譬如虚空无言无说。无言无说故。故名虚空。无言说中无有言说是名为空。一切诸法亦复如是。无名字法说为名字。如是名字亦无住处。若名无住处。名下之法亦复如是。如来真实知如是法不生不灭。以真知故名得解脱本无系缚。云何说言名得解脱。是故如来无缚无解。如是等法一切凡夫不能知见。如来于此而起大悲。演说正法为令知故。善男子。夫菩提者同于虚空。虚空之性不平不下菩提亦尔。若法无性不可说言有平有下。如来世尊。知一切法无平无下。乃至微尘不作平下。若法有性即如实智。如实智者。知一切法本无今有已有还无。出时灭时无所系属。从缘而出从缘而灭。以是义故名之为道。断是道故名为菩提。凡夫众生不知如是真实道故。如来于此而起大悲。宣说正法为令知故。善男子。夫菩提者名真实句。真实句者即是菩提色亦如是如是二句等无差别。受想行识地水火风。眼界色界眼识界。乃至意界法界意识界。亦复如是。名法流布。真实觉知如是阴入界法无有颠倒。不颠倒者。知过去法不生不灭。未来之法不生不灭。现在之法亦不生不灭。如是知已。名不颠倒名真实句。真实句者。如一法一切法亦如是如一切法一法亦如是。是真实句凡夫不知如来于此而起大悲。演说正法为令知故

善男子。夫菩提者非内非外。云何为内。云何为外。非内者无所造作。非外者无所觉知。内者谓作外者谓相。菩提之体非作非相。是故名为非内非外。又非内者非身口意业。非外者非三业缘非内者无相解脱门。非外者空解脱门。如是等义凡夫不知。如来于此而起大悲。演说正法为令知故。善男子。夫菩提者无漏无取。云何无漏。云何无取。无漏者远离四流。四流者欲流有流无明流见流。无取者远离四取。四取者欲取有取见取戒取。而诸众生无明所覆行于四取。以渴爱故作我我所。如来了知我取根本。是故我净。我净故能净众生。我净者。则不觉知一切诸法。亦不思惟一切非法。不起无明。不起无明因缘故。不起十二因缘有。十二因缘有不起故则不生。不生故入决定聚。入决定聚者名为了义。了义者名第一义。第一义者名无众生。无众生义者名不可说。不可说义者即十二因缘义。十二因缘义者即是法义。法义者即是如来。以是义故我经中说。若有得见十二因缘则为见法。见法者为见如来。见如来者即无所见所见是邪。夫邪见者谓想数法。如来无想亦无想数。以是义故见如来者为无所见。若见如来无想无作无知无觉。是名真实见于如来。如来亦尔。觉知一切诸法平等。如法界无取。一切凡夫不能觉知。如来于此而起大悲。演说正法为令知故。善男子。夫菩提者。清净寂静先明无诤。云何为净。云何寂静。云何光明。云何无诤。不杂烦恼名之为净。空解脱门名之寂静。无相无愿名为光明。无生无灭名为无诤。又无生者名之为净。无灭者名为寂静。无取者名光明。不出者名无诤。性名为净。无诸烦恼名为寂静光明无诤。法界名净。真实之性名曰寂静光明无诤。虚空之性名之曰净。无分别法界。名曰寂静光明无诤。内外清净名之为净。于内外法不取不着。名为寂静光明无诤。真知五阴名之为净。真实知界名为寂静光明。远离诸入名为无诤。见过去尽名之为净。见未来不生名为寂静。见现在法住于法界无有动转。名光明无诤。清净寂静光明无诤。如是四法等入一界一法一句。如是三法即是涅槃。远烦恼故名之为净。毕竟净故名曰寂静。无闇冥故名曰光明。不可说故名为无诤。以是故言释迦如来默无所说。善男子。夫菩提者即是虚空。虚空者名之为法。如法众生亦尔。如众生福田亦尔。如福田涅槃亦尔。以是义故。一切诸法同于涅槃。如来能觉如是法界。是故名佛。修集具足清净寂静光明无诤。如是四句名之为佛。如来能知善方便故。初得菩提默然而住。无所宣说待梵王请。尔时尸弃梵王与六万八千诸梵天人来至我所。头面作礼合掌而言。唯愿如来。为诸众生转正法轮。而说偈曰

  如来法离净寂静　　大光无碍无有诤
  无字无声亦无说　　真实觉知如法界
  佛为众生无量劫　　苦行受持世间戒
  为悟无明睡众生　　久行放逸迷实义
  又此会中无量众　　于无量佛积善根
  能解甚深真实义　　唯愿转于无上轮
  此众已调一切魔　　欲令开阐甘露门
  如来号为真导师　　示闇众生无上道
  如来虽有大慈悲　　怜愍众生如一子
  我今劝请法应尔　　愿转无上正法轮
  如往三佛转法轮　　唯愿如来亦复尔
  毕竟导师无退转　　示暗众生一真道
  如雨润长诸草木　　令诸众生除热渴
  佛施法雨于众生　　为得无上无异果
  如来初生发誓言　　我当救彼苦众生
  众生渴仰甘露味　　愿大施主施法雨

尔时世尊既受请已。往波罗奈鹿野林中仙人住处。转正法轮。如是法轮。诸天魔梵及余沙门。婆罗门等所不能转。尔时世尊说四谛时。憍陈如比丘得法眼净。其声遍闻三千大千世界。尔时世尊说优陀那

  甚深之义不可说　　第一实义无声字
  憍陈比丘于诸法　　获得真实之知见
  即是我往无量世　　所得菩提今已得

如来转是正法轮时。无量众生悉得调伏。示现如是大悲神通。众生见已。阿僧祇人发阿耨多罗三藐三菩提心。善男子。如来如是十六大悲。悉为众生而修起之。如来以是悲因缘故。为一一众生。于恒河沙劫大地狱中。受诸苦恼心不悔退。而其悲心亦无损减。以是义故如来大悲不可思议。善男子。声闻人悲犹如画皮。菩萨大悲犹如破肉。如来大悲破骨彻髓。声闻之悲赞佛所知。菩萨大悲劝他令行。如来大悲授人阿耨多罗三藐三菩提记。声闻悲心为慈因缘。菩萨大悲为调众生。如来大悲为毕竟度。声闻悲心因粗苦生。菩萨大悲因离苦生。如来大悲因断一切因缘而生。善男子。如来修集如是大悲。若为一人住经一劫百劫千劫万劫。至无量劫终不毕竟入于涅槃。善男子。如来大悲成就如是无量功德。善男子。乃往过去无量无边阿僧祇劫。时世有佛号栴檀窟。界名大香劫名上香。尔时世尊于三百三十二万劫中。常以正法教诸声闻。时佛身上一一毛孔所出香气。遍满三千大千世界。尔时此界无有臭秽名。所有草木山河之属悉栴檀香。众生身香亦复如是。一切无有身口意恶。诸佛弟子闻此香已即得四禅。尔时乃有一万诸佛。次第兴世皆同一号。号栴檀窟。是故彼劫名曰上香。尔时如来作佛事已欲入涅槃。观诸众生谁未调者我当调之。尔时如来以净天眼。见有一人在非有想非无想处。已于先佛种下上善根。定当因佛而得度脱。非因声闻得解脱也。寿过八万四千劫已。乃当下生来受五欲。当得闻于大乘经典。发阿耨多罗三藐三菩提心安住不退。尔时世尊以大悲故起大方便。告诸比丘。我涅槃时到。作是言已即便入于不悔三昧。示诸众生令知涅槃。既知如来入涅槃已。令诸大众广设供养。正法住世满足六十八万四千岁。当尔之时佛诸弟子。乃至无有一人于正法所作邪法想。尔时世尊以定力故。八万四千劫隐密此身不令众见。过是劫已。彼人即下生于人中大长者家。经八十年彼佛即从三昧而起诣长者家。其家大小悉无见者。唯是童子独得见之。尔时世尊为令彼人于五欲中心生厌离。而为说法。彼人闻已。即得不退阿耨多罗三藐三菩提心。如来知已即为授记。善男子。汝于来世过七万二千阿僧祇百千劫。当得成于阿耨多罗三藐三菩提。号曰宝上。如是音声余无闻者。唯有一万二千诸天同得闻之。闻已悉发阿耨多罗三藐三菩提心。俱作是言。愿彼宝上成佛之时。我等当于是佛法中。咨受正法而为弟子。尔时如来知是事已复与授记。宝上如来成作佛时。汝等当作受法弟子。彼佛亦当授汝阿耨多罗三藐三菩提记。时栴檀窟佛授彼记已。尔乃毕竟入于涅槃。一切诸天大设供养。善男子。如来具足如是大悲。非诸声闻缘觉所知。善男子。尔时彼佛不断佛种。若有众生供养三宝亦复如是。佛说如是大悲功德时。此会众中有三恒沙等众生发阿耨多罗三藐三菩提心。半会大众得成于忍。半中之半得具如是十六大悲。其余半半得佛法忍。尔时一切诸天世人闻法欢喜。同声赞叹。善哉善哉。甚奇甚特。快说如是大悲法门

大方等大集经卷第二大方等大集经卷第三

        北凉天竺三藏昙无谶于姑臧译

    陀罗尼自在王菩萨品第二之三

善男子。如来复有三十二业。何等三十二。善男子。如来能知是处非处。云何是处。云何非处。善男子。若有造作身口意恶。得受安乐无有是处。是名非处。若有造作身口意善。受乐果者斯有是处。是名是处。若习悭贪得大富者无有是处。修行惠施得大富者斯有是处。毁破禁戒得受天身无有是处。护持净戒得受天身斯有是处。嗔恨之人得身端正无有是处。修集忍辱得身端正斯有是处。懈怠之人得大神通无有是处。勤修精进得大神通斯有是处。放心散乱得定地者无有是处。摄心不乱得定地者斯有是处。愚痴之人断烦恼气无有是处。修智之人断烦恼气斯有是处。若作五逆得无漏者无有是处。若无五逆得无漏者斯有是处。以女人身作转轮王无有是处。以男子身得转轮王斯有是处。帝释梵王佛亦如是。若转轮王非法治国无有是处。转轮圣王正法治化斯有是处。郁单曰人堕三恶道无有是处。郁单曰人寿终生天斯有是处。杀生因缘得长寿者无有是处。以是因缘寿命促短斯有是处。若有邪见得圣道者无有是处。若有正见得圣道者斯有是处。须陀洹人得第八有无有是处。须陀洹人即涅槃者亦无是处。阿那含人受欲有身亦无是处。阿罗汉人受后有者无有是处。贤圣之人咨承异师无有是处。得不退忍退菩提者无有是处。菩萨坐于菩提树下。不得菩提而起去者无有是处。如来若有烦恼习者亦无是处。诸佛世尊。知有障碍无有是处。若有能见如来顶者亦无是处。若有众生能知如来心境界者无有是处。如来之心不常定者亦无是处。如来世尊有二语者无有是处。如来世尊有过失者亦无是处。善男子。是名如来第一之业。尔时世尊即说颂曰

  大地可说动转相　　猛风可说停住相
  虚空可说有色相　　佛不说处为非处
  虚空可说作界像　　佛不说处为非处
  如来演说处非处　　下中上分悉真实
  不说是处非处一　　如是二处各无二
  如来亦说下中上　　各各无有三种相
  佛知是处非处已　　故能宣说无上法
  如来了知众生心　　善能分别细微相
  沙门梵志闇处行　　不知是处非处因
  众生不知处非处　　是故不能得解脱
  如来悉知处非处　　是故称为无上尊
  若诸众生无法器　　如来于是修舍心
  设大方便待时节　　为令彼得真解脱
  如来世尊智无上　　是则名为第一法
  如是清净第一业　　为令众生得调伏
  如来说是第一力　　甚深难测无能知
  如是妙法难可宣　　为破邪见怜愍说

复次善男子。如来世尊。善知去来现在众生所有诸业。知业知报。知恩知处。若过去业是不善因。如来知是未来之世得不善果。若未来业有退因缘。如来了知实是退因。若未来业能增长法。如来悉知以是因缘能增长法。若现在业若进若退。如来悉知以是因缘有进有退。若有作业是声闻因。是缘觉因。是菩萨因。是如来因。如来悉知以是因缘。是声闻因是缘觉因。是菩萨因是如来因。是名如来第二之业。尔时世尊复说颂曰

  如来获得无上智　　是故能知业因果
  智知三世非三摄　　能知众生三世业
  善解众生安乐因　　亦能了知苦恼因
  如来坏邪无因果　　是故修集第二业
  通达进退二法因　　善恶业果亦复然
  如来知见无障碍　　如观掌中庵罗果
  知下中上真实相　　三乘所因亦复然
  如来善知众生业　　亦知善恶诸业果
  众生业果三世摄　　知见不谬名正觉

复次善男子。如来世尊。知诸众生种种欲解。若贪欲若嗔恚若愚痴。现在世贪起未来世贪恚愚痴。现在世嗔起未来世贪嗔恚痴。现在世痴起未来世贪嗔恚痴。如来悉知。现在住善欲未来恶欲。现在住恶欲未来善欲。如来悉知。现在住下欲。未来世下中上分。现在住中欲。未来世下中上分。现在住上欲。未来世下中上分。如来悉知。邪聚众生能作正聚。不定众生住于正定。如来悉知。欲界众生有色无色界欲解。知声闻人。有缘觉欲解。有佛欲解。如来真实通达知故而为说法。是名如来第三之业。尔时世尊。即说颂曰

  众生欲解有种种　　其意若干非一徒
  如来真实知诸欲　　故能随意演说法
  贪欲嗔恚愚痴性　　随相而知无颠倒
  下中上品亦如是　　善恶业因果真实
  通达三聚无有定　　一切三乘亦复然
  智知三世非三摄　　为诸众生说三力

复次善男子。如来悉知无量世界。若修善行。若行恶法。若无碍行。云何名知。内空外空内外空故。复次如来知眼知色及知眼识。云何而知如虚空故。复次如来知欲色界及无色界。云何而知如觉观故。复次如来知于行界。云何而知如行性故。复次如来知烦恼界。云何而知客尘性故。复次如来知不污界。云何而知。一切诸法性本净故。复次如来知生死界。云何而知无明缘故。复次如来知涅槃界。云何而知实思惟故。复次如来知世住界。知世爱界。知世嗔界。知世痴界。知世净界。知世净心界。以知界故能实说法。是名如来第四之业。尔时世尊。即说颂曰

  如来人中师子王　　能真实知众生界
  如来智慧无有边　　是故能知世无边
  知善恶行解脱行　　亦知眼色眼识行
  通达一切无量法　　其性本来常清净
  内外真实无所有　　五阴诸入十八界
  身口意业及四大　　如是诸法悉无实
  知如是等众生界　　皆悉同于虚空境
  三界性相无真实　　诸烦恼界亦如是
  烦恼性相无坚牢　　无漏解脱亦复然
  如来虽知真实界　　终不言知而生慢
  虚空无量无边际　　一切众生界亦然
  如来智慧无边际　　远离三种有为相
  佛智无上甚深奥　　一切众生不能知
  如来怜愍众生故　　宣说如是第四力

复次善男子。如来善知一切众生诸根利钝。云何而知。知上中下知增知减。亦知贪欲有一亿种。嗔恚愚痴各一亿种。知贪欲重知贪欲轻。知嗔恚重知嗔恚轻。知愚痴重知愚痴轻。知一种根能增生死。知一种根能灭生死。了知善根知不善根。知非善非不善根。知解脱根。知六情根。男根女根命根。苦根乐根。忧根喜根。舍根信根。进根念根。定根慧根。未知欲知根。知根知已根。知眼根因乃至意根因。知耳根因作眼根缘。知鼻根因作舌根缘。知舌根因作身根缘。知戒庄严能修于施。知施庄严能修于戒。如来悉知谁可说施。谁可说戒。乃至智慧亦复如是。知谁可为说四念处。乃至八圣道分。谁可为说声闻之乘。辟支佛乘。无上佛乘。知缘觉根学声闻乘。知正觉根学声闻乘辟支佛乘。知下根人能修上根。上根之人修于下根。知众生根未可调者。则生舍心。可调伏者为说正法。如来悉知熟不熟相。不熟熟相。不熟不熟相。熟有熟相。知生死根。知解脱根。知庄严根。知具足根。一切根性因缘果报。悉知悉见。是名如来第五之业。尔时世尊。即说颂曰

  如来知根到彼岸　　故知众生种种解
  亦了知根下中上　　并及诸业亦如是
  亦知烦恼轻重相　　及知诸根难易调
  知乐生死及解脱　　了知眼根至意根
  知根行处及灭处　　了知一切三乘根
  有可转者不可转　　知众生根熟不熟
  随其意种为说法　　善知呵责软语调
  知有不受教诲者　　则于其人修舍心
  如来善知诸方便　　为破烦恼庄严智
  为破众生烦恼故　　演说如来第五业

复次善男子。如来真实知至处道。云何而知。知正定聚。知邪定聚及不定聚。知于因力及果报力。知过去世福德因缘。知现在世庄严因缘难调易调。略说广解广说略解。知是众生能得解脱不得解脱。知不定者遇善知识住正定聚。不得善友则无解脱。如来知已。随其意趣而为说法。彼闻法已。系念思惟获得善果。如来出世惟为不定。终不为彼邪定说法。何以故。非是器故。不能获得真解脱故。是名如来于是人所修集舍心。菩萨摩诃萨真实知已勤修庄严。为破如是邪定众生。是故菩萨发阿耨多罗三藐三菩提心。如来善知贪有三种。一者因见净故。二者受因缘故。三者本因缘故。嗔有三种。一者嗔因缘故。二者受因缘故。三者本因缘故。痴亦三种。一者无明因缘。二者我见因缘。三者疑网因缘。复次如来。知诸众生苦迟得通。苦速得通。知苦迟者能得乐速。知乐速者能得苦迟。知乐迟者能得乐速。知有修力知有智力。又知有道具足修力不具智力。有具智力不具修力。有具修力及以智力。不具修力不具智力。又知有道能作净心不能庄严。有能庄严不能净心。有作净心能具庄严。有不具净心不具庄严。又知有道能净其身不净口意。有净口意不净其身。有身口意净。有身口意不净。是名如来第六之业。尔时世尊。即说颂曰

  如来善知所至处　　亦知众生诸因缘
  亦能了知定不定　　通达明晓调不调
  不为邪定演说法　　亦不调伏下根者
  知贪嗔痴三种说　　亦知诸结轻重相
  知于四道转不转　　是故佛知道毕竟
  修力智力真实知　　下中上力亦如是
  知身口意净不净　　心及庄严亦复然
  众生诸根烦恼界　　如来知已为破坏
  为彼无明闇众生　　宣说如来第六业

复次善男子。如来知禅解脱三昧烦恼解脱。云何而知。知诸众生以因缘故贪乐生死。以因缘故贪乐涅槃。云何名因。云何名缘。若诸众生思惟不善。是名生死因缘。因不善思惟故生长无明。是故不善为因无明为缘。因无明故则生于行。是故无明为因诸行为缘。因诸行故则生于识。是故行则为因识则为缘。因识故则生名色。是故识则为因名色为缘。因名色故则生六入。是故名色为因六入为缘。因六入故则生于触。是故六入为因触则为缘。因触生受。是故触则为因受则为缘。因受生爱。是故受则为因爱则为缘。因爱生取。是故爱则为因取则为缘。因取生有。是故取则为因有则为缘。因有生生。是故有则为因生则为缘。因生则有老死等苦。是故生则为因老死为缘。烦恼为因诸业为缘。诸见为因爱结为缘。烦恼为因五盖为缘。是名为因是名为缘。而诸众生以是因缘贪乐生死。何因缘故贪乐涅槃。有二因二缘。令诸众生乐于涅槃。一者乐喜听法。二者乐正思惟。复有二种。一者舍摩他。二者毗婆舍那。复有二种。一者不去智。二者不来智。复有二种。一者观生死。二者观涅槃。复有二种。一者如法持。二者得证。复有二种。一者修解脱门。二者得解脱果。复有二种。一者尽智。二者无生智。复有二种。一者谛智。二者观十二因缘。是名为因是名为缘。而诸众生。以是因缘乐于涅槃。如来悉知如是等禅三昧解脱。既了知已。舍离欲恶不善之法。有观有觉离生喜乐入于初禅。入初禅出灭定。入灭定出初禅。乃至八解脱亦复如是。一切众生悉不能知如来世尊出入之处。如来悉知住定平等。及以上下众生。谓佛入一三昧。而佛实入一切三昧。众生见佛起一切定。而佛实入一定三昧。如来三昧无有次第然非不定。一切声闻缘觉菩萨悉不能知。如来又知说法因缘。得声闻三昧说法因缘。得缘觉三昧说法因缘。得菩萨三昧。知已随意而为演说。是名如来第七之业。尔时世尊。即说颂曰

  如来了知生死因　　亦复通达解脱因
  既了知已为说法　　破坏生死不善因
  不善思惟无明因　　无明因缘长生死
  烦恼因缘受业果　　诸见因缘增爱结
  若得亲近善知识　　至心听受无上法
  观察内外空三昧　　即能越度生死海
  修集无上定智慧　　观法平等无去来
  若能观见无出灭　　即得了了寂静眼
  修集无上三脱门　　具足尽智无生智
  既自获得无碍智　　复能为诸众生说
  入于初禅出灭定　　入于灭定随意出
  如来三昧无次第　　是故名为常在定
  如来所入种种定　　与诸法界无差别
  二乘不知佛住处　　菩萨不知甚深定
  众生常行无明闇　　不知如来入出处
  无上世尊怜众生　　是故宣说第七业

复次善男子。如来善知自身所有过去世业。若一生二生至无量生。一灾二灾至无量灾。一劫二劫至无量劫。忆念生名种姓饮食。色貌形质苦乐寿命。是诸众生造是业因得此有身。念他有灭生于他有。如自身他亦如是。亦知众生所有业因。是诸众生造是业因得他有身。知众生心及因缘。是心灭已次第生心。如是等事恒沙众生所不能知。佛宿命智悉知三世无有始终。如是智慧不可称量。劝诸众生汝今当念。过去世中所更善恶。以佛力故悉得忆念。往昔所种无量善根。若佛边种若于声闻缘觉边种。既忆念已。如来即为随意说法令不退转。是名如来第八之业。尔时世尊。即说颂曰

  如来忆念无量世　　若自若他善恶业
  明见无量劫中事　　犹观掌中庵罗果
  种姓生名悉能知　　色劫生灭亦如是
  亦知寿命及住处　　善恶业因亦复然
  知众无量次第心　　及知心因生灭处
  遍知无量劫中生　　亦不尽于无碍智
  佛智无量不可称　　二乘不知其境界
  为令众生念过去　　随意宣说第八业

复次善男子。如来天眼清净微妙。见诸众生生灭堕落。若受善色若受恶色。若生善有若生恶有。亦能明了知诸业因。知是众生身口意恶。诽谤圣人增长邪见。以恶业故舍此身已即堕地狱。知是众生身口意善。不谤圣人增长正见。以是业缘舍此身已即生善有。如来天眼能见十方诸佛世界。无有边际犹如虚空。无有限量犹如法界。悉见众生生时灭时。见诸世界成时坏时。亦知众生发菩提心生时灭时。见一切佛始成正觉。转正法轮入涅槃时。见诸声闻证得解脱。得解脱已取涅槃时。见诸缘觉以神通力。报诸众生信施恩时。如是等事。一切五通声闻缘觉及诸菩萨所不能见。如来天眼成就如是无量功德。以天眼故观诸众生。谁应为佛之所化度。谁复应为声闻缘觉之所化度。若应从佛而得度者。如来即为示现其身。其余众生悉无见者。是名如来第九之业。尔时世尊。即说颂曰

  无量劫中修善业　　获得如是净天眼
  能见十方诸众生　　具足成就善恶色
  见上中下诸众生　　亦见受于善恶有
  能知身口意善业　　业因所得诸果报
  亦知声闻辟支佛　　菩萨之人善法境
  见十方佛破魔兵　　转正法轮入涅槃
  见诸声闻得解脱　　教化众生取灭度
  见辟支佛示神通　　以报施主之恩德
  如来所说真实法　　闻已能度生死海
  声闻缘觉及菩萨　　不能知佛所见处
  如来睹见细微尘　　亦见无量无边界
  如来教化佛所度　　是故宣说第九业

复次善男子。如来世尊知诸漏尽毕竟解脱。我生已尽梵行已立。所作已办更无后有。佛漏尽智清净微妙。言清净者无诸习气。声闻之智有边有量。何以故。有习气故。辟支佛智亦有边量。何以故。无大悲故。佛漏尽智无量无边。何以故。知一切行故。具足成就一切智故。永断一切诸习气故。摄取大慈大悲。庄严四无所畏。于一切法无取相习。一切世间所不能胜。行住坐卧无诸过失。犹如虚空清净明了不杂烟云。佛漏尽智亦复如是。不杂一切诸烦恼习。如来成就清净具足是漏尽智。能为众生敷扬宣说。令彼闻者断诸烦恼。菩萨闻已发大庄严为断烦恼。是名如来第十之业。尔时世尊。即说颂曰

  佛漏尽智无有边　　清净不杂烦恼习
  声闻缘觉习结气　　是故漏尽智不净
  如来具足大慈悲　　是故其智无边际
  具足成就一切行　　故知众生漏行处
  所可演说无常我　　令众生知空无乐
  修善思惟得净眼　　知无众生无士夫
  大悲怜愍诸众生　　具足十力四无畏
  为断烦恼智无碍　　是故宣说第十业

复次善男子。如来具足四无所畏。成如来业。如来业者。悉已觉知一切诸法。若天若人若魔若梵若沙门若婆罗门。如实而言如来不觉不知法者。无有是处。何以故。如来世尊名为正觉觉平等法。若凡夫法若圣人法。若声闻法若缘觉法。若菩萨法若佛法。若学法若无学法。若世法若出世法。若善法若不善法。若有漏法若无漏法。若有为法若无为法。如是等法平等觉知。故名正觉。言平等者。见空平等法真实故。无相平等坏诸相故。无愿平等不着三界故。不生平等无生性故。无行平等无行性故。无出平等无出性故。无至处平等无至处性故。真实平等无三世性故。智解脱平等无无明性故。涅槃平等无生死性故。见如是法皆悉平等。是故如来名为正觉。如是观已以大慈悲。为诸众生称扬宣说。若非世尊作世尊想。若非正觉作正觉想。若非漏尽作漏尽想。如来具足四无所畏。能坏如是诸恶想等。是名如来第十一业。尔时世尊。即说颂曰

  佛知一切法平等　　是故得名一切智
  凡圣菩萨及佛业　　世与出世善恶业
  空无相愿无生灭　　一切悉见其真实
  如来悉见平等故　　为众演说十一业

复次善男子。如来真实永尽诸漏。是故唱言我尽诸漏。我都不见人天魔梵沙门婆罗门。真实而言佛漏未尽。云何名为如来漏尽。佛于欲漏心得解脱。有漏无明漏。一切习气一切见漏。心得解脱。是故如来名为漏尽。第一义中圣人真知。无觉无断无证无修。为流布故说言尽漏。何以故。尽者即是无生无灭。无尽者不可宣说。不可说故名之无为。夫无为者无出灭住。佛若出世不出于世法性常住。如来不觉我及我断。如来住于大慈大悲。为众生故宣说我断。是名如来第十二业。尔时世尊。即说颂曰

  如来永断诸漏结　　及以无边诸习气
  是故世法不能污　　如花处水泥不着
  大悲人中师子王　　为众生故说流布
  真实而知无出灭　　无我我所亦复然
  一切诸法无增减　　随其性相真实说
  如来得大自在力　　为众故说十二业

复次善男子。如来真实说遮道法。我都不见人天魔梵沙门婆罗门。说言是法不能遮。云何名遮。云何不遮。有一法能遮道。所谓放逸。复有二法。所谓无惭无愧。复有三法。谓身口意恶。复有四法。所谓欲嗔怖痴。复有五法。所谓杀生偷盗淫泆妄语饮酒。复有六法。所谓不敬佛法僧戒三昧不放逸。复有七法。一者慢。二者大慢。三者慢慢。四者邪慢。五者邪语。六者邪命。七者邪念。复有八法。一者邪见。二者邪思惟。三者邪语。四者邪业。五者邪命。六者邪方便。七者邪念。八者邪定。复有九法。所谓有人欲作诸恶。现作作已加于己亲。有人以善加于己怨。有人以恶加于己身。亦复如是。是名为九。复有十法。所谓十恶。一者杀生。二者偷盗。三者淫泆。四者妄语。五者两舌。六者恶口。七者无义语。八者贪嫉。九者嗔害。十者邪见。若有比丘起恶思惟。以是因缘。不知有为多诸过咎。以不知故生颠倒心。颠倒因缘增长五盖。五盖增故令诸烦恼遮障善法。烦恼因缘身口意业造作诸恶。如来如实知如是法能遮于道。既自知已为众演说。为坏如是遮障道法。是名如来第十三业。尔时世尊。即说颂曰

  若有修集于放逸　　真实不能得解脱
  身口意等诸恶业　　无惭无愧诸烦恼
  亲近恶法能遮道　　善觉对治不对治
  为坏烦恼故演说　　大慈大悲十三业

复次善男子。如来实说圣道毕竟。若有众生亲近正念必得解脱。我都不见人天魔梵沙门婆罗门。真实记言修道者不得毕竟无上解脱。云何名为真实圣道。有一种。所谓一乘。复有二种。谓舍摩他毗婆舍那。复有三种。谓空三昧无相无愿。复有四种。谓四念处。复有五种。谓信等五根。复有六种。谓六念处。复有七种。谓七觉分。复有八种。谓八正道。复有九种。所谓初禅乃至灭定。复有十种。所谓十善。是名毕竟真实圣道。又毕竟道者。无有能作增减取舍无执无放。非正非邪非一非二。是名真实毕竟之道。如来世尊怜愍一切。为诸众生说如是道。是名如来第十四业。尔时世尊。即说颂曰

  如来了知寂静法　　有亲近者得解脱
  如来无师无教者　　自然而得甘露味
  有修三十七助法　　烦恼结灭得解脱
  思惟善知真实法　　不着法性真解脱
  如来见法如虚空　　犹如幻化热时焰
  具足十力无边身　　为众故说十四业

复次善男子。如来身业无有过失。若愚若智。无能宣说佛有过失。何以故。如来若行若坐若住。着衣持钵若受饮食。若见若闻若有所说。入出城邑村落舍宅。足不蹈地常行千叶莲花之上。若有众生遇触佛影。七日安乐无饮食想。舍是身已生于善有。如来衣服离身四寸。暴猛风力所不能动。如来虽有如是等事。而其内心未尝不定。是故如来身无过失。善男子。如来口业亦无过失。何以故。时语真语。实语。正语。期语。义语。不多语。如持而语净语。解一切语。微妙语。无异语。一音语。是故如来无口过失。如来意业亦无过失。何以故。如来常作一切佛事。而其内心初无憍慢。不役智虑而知法尽。是名如来无挂碍智。是故如来意无过失。为坏众生如是过失故宣说法。是名如来第十五业。尔时世尊。即说颂曰

  如来身口意寂静　　是故无能说有过
  实不可说为流布　　是业非业说为业

复次善男子。如来不与天人魔梵沙门婆罗门而生诤讼。何以故离爱恚故。一切世间供养恭敬。心不生高亦不欢喜。一切世间毁呰轻慢不生愁恼。凡所造善事无不成。终不造作不善之业。如来实无世间诤事。亦常修集无诤三昧。如来无我无有我所。为坏众生是非诤讼。说如是业。是名如来第十六业。尔时世尊。即说颂曰

  如来修集无诤定　　是故其心无嗔喜
  如来为断众烦恼　　是故宣说十六业

复次善男子。如来之心无有忘误。于八解脱不失念心。常观一切众生意行。观已复能随宜说法。于四无碍亦无念失。于三世中忆念不忘。既自不失忆念之心。复为众生说是念法。是名如来第十七业。尔时世尊。即说颂曰

  如来修集八解脱　　故于诸法不失念
  知众生心随意说　　为令得念说是业

复次善男子。如来真实无不定心。若行若住若坐若卧若语若默常知诸法深妙之义。一切世间若有入定若不入定。悉无能知如来心也。唯除诸佛借其道力。欲令一切无量众生常在定故。说如是业。是名如来第十八业。尔时世尊即说颂曰

  如来正觉常在定　　所作诸事无散乱
  常入三昧无知者　　是故宣说十八业

复次善男子。如来真实无种种想。所谓无分别福田非福田想。亦无分别诸众生想及以法想正觉之想及法界想。分别持戒及毁戒想。亦无分别怨想亲想受不受想。分别正见邪见之想。是故如来无种种想。为坏众生如是诸想宣说是业。是名如来第十九业。尔时世尊。即说颂曰

  如来永断一切想　　是故了知诸法界
  为破众生若干想　　宣说如来十九业

复次善男子。如来从智舍心无不知舍。何以故。修身故。修戒故。修心故。修慧故。断痴故。如来舍心出于世间。即是圣舍。是毕竟舍。转梵轮舍。共大悲舍。为利众生舍。知对治舍。如是等舍。无增无减不高不下。不杂烦恼不一不二。不观时节无碍无对。不住不动不隐不显。真实不虚。如来成就如是大舍。而能为诸众生说法。是名如来第二十业。尔时世尊即说颂曰

  如来修身戒心慧　　从于智慧修舍心
  于诸众生无爱恚　　不动不住真实舍
  大慈大悲无上尊　　具足如是之大舍
  无碍智慧调众生　　演说清净二十业

复次善男子。如来欲业无增无减。何等名欲。欲于善法。所谓大慈大悲说法度人安住寂静。劝诸菩萨学菩提道。令三乘种相继不绝。如是诸欲。不随欲出随智而生。欲令一切众生具足阿耨多罗三藐三菩提故演说正法。是名如来二十一业。尔时世尊。即说颂曰

  如来欲者无增减　　大慈大悲故说法
  不断三乘无边身　　为众演说如是业

复次善男子。如来精进无有休息。云何不息。所谓调伏众生说法化度。假使有一人能无量劫佛边听法。如来当为说不休息。若有一佛于无量劫演说法者。如来亦听心无懈废。若过无量恒沙世界。有一众生应受化者。如来要当随逐。不舍。不食不息。不生疲倦悔退之心。常劝众生令勤精进。是名如来二十二业。尔时世尊。即说颂曰

  具精进人师子王　　于大众中赞精进
  精进说法无休息　　是故进业二十二

复次善男子。如来念心无有增减。何以故。如来初得阿耨多罗三藐三菩提时。遍观一切去来现在众生之心。后说法时不失先念。念本三聚及三种根。凡所演说无不作念。是名如来二十三业。尔时世尊。即说颂曰

  如来初得菩提时　　遍观众生如实心
  凡所说法不失念　　二十三业佛所说

复次善男子。如来三昧于一切法平等无减是故诸佛一切平等。于一亿种贪欲恚痴。及一亿种无贪恚痴。其心平等无有差别。有为无为生死涅槃亦复如是。具如是等平等三昧。不杂眼耳鼻舌身意。四大三界非此非彼。亦非一切非增非减。为令众生得是三昧。宣说正法。是名如来二十四业。尔时世尊。即说颂曰

  如来等观一切法　　是故常定心无乱
  不为三界之所摄　　诸根四大亦如是
  一切诸法无差别　　平等观察善不善
  如来所说如是业　　为诸众生得是定

复次善男子。如来智慧常无减少。以是智力知一切法。能随众生意趣说法得无碍智。知一切义。知一切字。知一切句。于无量劫演一句法。出无量义断一切疑。说三乘法并及八万四千法门。亦说八万四千法聚。是名无量无边智慧。为令众生得是智故宣说正法。是名如来二十五业。尔时世尊。即说颂曰

  佛智无碍无有边　　能说无碍无边法
  演一字作无量句　　演一句作无量义
  说八万四千法门　　亦及尔所诸法聚
  为令众得无碍智　　是故宣说如是业

复次善男子。如来解脱无有减少。声闻之人从他闻故而得解脱。缘觉之人从因缘故而得解脱。如来无师自然觉悟。永断烦恼及以习气。过去不断。未来不着。现在不住。亦不贪着眼色二法。乃至意法亦复如是。知心性净。是故唱言如来一念得阿耨多罗三藐三菩提。为令众生一念得成阿耨多罗三藐三菩提故演说正法。是名如来二十六业。尔时世尊。即说颂曰

  为诸声闻闻解脱　　亦为缘觉因缘悟
  如来解脱不著有　　不着三世心性净
  凡所演说为解脱　　劝诸众生无上道
  二十六业非业故　　大慈大悲处众说

复次善男子。如来身业随智慧行。智所围绕以是业故。众生闻见说法默然。行住坐卧饮食出入城邑聚落。三十二相八十种好悉得调伏。是故如来一切身业随智慧行。是名如来二十七业。尔时世尊。即说颂曰

  如来身业为众生　　故示种种妙相好
  凡所举动调众生　　大悲为众说是业

复次善男子。如来口业随智慧行。何以故。说法净故。无脱失故。真正语。易解语易知语。非高语非下语。非曲语非粗语。非恶语非闇语。柔软语非轻语。非疾语非畏语。非不解义语。非恶声语。非缓语。甘露语可爱语。次第语庄严语。恭敬语乐闻语。不贪语不垢语。清净语毕竟语。不诳语不痴语。无碍语广语。真实语不作语。不尽语安乐语。身寂静语心寂静语。贪寂静语嗔寂静语。痴寂静语坏魔语。破邪论语。梵声迦陵频伽声。释声大海潮声。拘仑阇声。秋月孔雀声。拘枳罗声。命命鸟声。鹅王声鹿王声琴声鼓声。贝声。伎乐声人乐闻声耳根乐声。增善法语。句义无尽语。合字句义语。时语略语。知足语。调诸根语。施庄严语。清净戒语。共忍行语。精进神通语。远离欲界语。具足智慧语。慈语悲语。喜语舍语。说三乘语。不断三宝语。解三聚语。解三世语。解三解脱语。分别四谛语。修集语赞叹语。佛语圣语。无边语无行语。善男子。如来成就如是等语。是故如来所有口业随智慧行。是名如来二十八业。尔时世尊。即说颂曰

  如来所说如净珠　　成就无量诸功德
  其声遍满十方界　　一音能令种种解
  凡所演说不作念　　更不观众心境界
  如来音声如响相　　无说无闻亦如是
  大慈大悲清净语　　为众生解种种法
  是故宣说如来业　　二十八业如先佛

复次善男子。如来意业随智慧行。何以故。如来了知一切众生心意识等。亦不随意随缘随贪随恚随痴。远离诳惑及我我所无明闇翳。平等清净无有边际犹如虚空。是故如来所修意业随智慧行。是名如来二十九业。尔时世尊。即说颂曰

  如来之心不可量　　如以毫毛举须弥
  常观众生心所缘　　远离说魔烦恼界
  人中象王说善业　　为坏众生种种恶
  为净众生身口意　　二十九业今已说

复次善男子。如来智慧知过去世。其智无碍亦无障者。云何为智。知过去佛无量无数。及其世界所有草木众生之数。其心所缘种种音声。亦知其佛说几所法。有几众生得声闻乘辟支佛乘及菩萨乘。亦知彼佛所有世界寿命修短。众数多少名字种种喘息饮食。众生根界意界法界心界行界。其心次第生灭出没。如实了知知其数量非比智知。是名如来第三十业。尔时世尊。即说颂曰

  佛智无碍无障者　　故能悉知无量土
  了知一切诸佛事　　众生诸根及法界
  人师子王知过去　　如观掌中阿摩勒
  无边身说三十业　　为令众生知过世

复次善男子。如来智慧知未来世。其智无碍亦无障者。云何为智。知未来世若出若灭。一切世界几劫水灾。几劫火灾几劫风灾。成坏之数。几佛世界几佛出世。世界之中有几微尘。有几声闻缘觉菩萨。亦知彼佛几食几息。几行几住几坐几卧。几人获得声闻解脱。几人获得缘觉解脱。几人获得正觉解脱。几人修集慈悲喜舍。亦复了知几所众生次第心生次第心灭。了了能知如是等事。亦非比智。是名如来三十一业。尔时世尊。即说颂曰

  如来了知未来世　　一切诸法之出没
  知佛世界及以佛　　众心次第生灭等
  既得知已无憍慢　　名三十一如来业

复次善男子。如来智慧知现在世。其智无碍亦无障者。云何为智。如来悉知十方现在世界。诸佛声闻缘觉菩萨众数日月星宿草木微尘。地水火风四大海渧。众生毛发种种形色。心意次第生灭出没。亦知地狱畜生饿鬼现业果报。几时住世几时解脱。亦知人天业果因缘。几时住世几时解脱。知烦恼界及诸根界意界法界。如来虽复种种知已。不生高心口亦不出二种之言。是名如来三十二业。尔时世尊。即说颂曰

  无上如来叵思议　　无有知佛所缘境
  如来所知如虚空　　无量无称无边界
  所说微妙第一义　　为令众生得是业
  总持自在能问佛　　无上世尊随意答

善男子。如来世尊具足如是三十二业。则能调伏无量众生。善男子。如来世尊虽为众生说是诸业。而如来业真实无量不可称计。善男子。如来业者。一切世间所有众生。不能思惟不能了知不能宣说。如是业者。悉能等知一切国土犹如虚空。何以故。十方诸佛悉平等故。善男子。诸佛所说。观察众生及佛世界。解脱涅槃等无差别。佛观法界皆一味已。转不可转正法之轮。善男子。譬如善识真宝之匠。于宝山中获得一珠。得以水渍从渍出已。置酢浆中从酢浆出已。置之豆汁意犹不已复置苦酒。苦酒出已置众药中。从药出已以[王*婁]褐磨。是名真正青琉璃珠。善男子。如来亦尔。知众生界不明净故。说无常苦及以不净。为坏贪乐生死之心。如来精进无有休息。复为演说空无相愿。为令了知佛之正法。如来精进犹不休息。复为说法令其不退菩提之心。知三世法成菩提道。名大珍宝良祐福田。是故当知。如来诸业不可思惟。不可称量不可宣说。如来具足三十二业。虽知己身犹如虚空。而于世界示现其身。亦复宣说不可说法。永断一切心之因缘。悉知一切众生心界。亦知一切菩萨境界。善男子。如来世尊真实业者。终不断绝菩萨授记。是名如来真实之业。尔时世尊说是业时。十方世界六种震动。大光普照雨于无量无边香花。诸在此坊天人大众。阿修罗迦楼罗紧那罗摩睺罗伽人及非人。闻如来业心大欢喜。复以种种香花伎乐宝幢幡盖供养之具而供养佛。其中或以周罗宝顶宝发手玔杂宝璎珞。日珠月珠指环珠带宝佩发饰。或以耳环以奉如来。谓青琉璃。及莲花珠金翅鸟珠。阎浮宝珠帝释宝珠。火珠光珠无量光珠。无量色珠柔软净珠。金刚宝珠及白真珠。复以杂香。所谓末香。金沙和杂栴檀之香。多伽罗香沉水。弥佉多摩罗跋香。复散诸花。所谓曼陀罗花摩诃曼陀罗花曼殊沙花摩诃曼殊沙花。拘毗陀罗花波利质多罗花。乐花。娑罗花大娑罗花。百叶花千叶花。饶叶花大光花。香叶花乐香花乐见花。无量色花无定色花。水生花。优波罗花波头摩花。拘物头花分陀利花。陆生花。婆利师花摩梨花。须曼那花育坻花。檀内伽梨花。阿提目多伽花。瞻婆花阿叔迦花。种种伎乐种种幢幡盖。十方界诸来菩萨。各升虚空宝坊之上。放身投下供养于佛。投身散已其身不现。化七宝网遍覆其上。复现其身在珠网中。尔时十方一切诸佛。各各遣一波利之树。以用供养释迦如来。以佛力故一一诸树各至宝坊庄严其处。尔时会中无量众生。发阿耨多罗三藐三菩提心。无量众生。得无生法忍

大方等大集经卷第三大方等大集经卷第四

        北凉天竺三藏昙无谶于姑臧译

    陀罗尼自在王菩萨品第二之四

尔时世尊。举身顾眄观诸大众。如象王回而作是言。诸善男子。谁能守护如是供具及此宝坊。令不毁坏灭没损减。以待弥勒成正觉已。十六年后供养彼佛及贤劫中五百如来。是时会中有一菩萨名诸法神通自在王即从坐起。胡跪合掌而作是言。世尊。我能守护如是供具及此宝坊。令不毁坏灭没损减。以待弥勒成正觉已。十六年后供养彼佛及贤劫中五百如来。尔时众中有一魔王名曰神通。其所住国名四天下。语诸法神通自在王菩萨言。善男子。汝今安置如是供具并及宝坊。置何器中而守护之令不毁坏。善男子。凡言器者性是无常。而我此身常住无变。善男子。汝今应当谛观我身。尔时魔王闻是语已。如教谛观见其脐中。有一世界名水王光。有佛世尊号宝优钵罗。其世界中有大宝山。如来处中结加趺坐。与诸菩萨宣说正法。尔时魔王见是事已。心甚奇讶。即礼诸法神通自在王菩萨。赞言善哉善哉。大士。我今始知汝有妙器堪任护持如是供具及此宝坊令不毁灭。尔时魔王即白佛言。世尊。我往未见如是菩萨。未闻如是微妙法时。欲学声闻入于涅槃。我今既见诸法神通自在王菩萨威神之力。即发阿耨多罗三藐三菩提心。世尊。假使我身恒沙劫中受地狱苦。然后乃成无上道者。亦终不舍菩提之心。佛言善哉善哉。善男子。汝能善发阿耨多罗三藐三菩提心。汝亦当得如是无量神通之力。是时会中复有菩萨名师子幢。语陀罗尼自在王菩萨言。善男子。菩萨摩诃萨获得何等陀罗尼门。而能受持一切佛语。凡所演说字句及义无有穷尽。陀罗尼自在王菩萨言。善男子。有八陀罗尼。菩萨摩诃萨若有得者。则能受持一切佛语。凡所演说字句及义而无穷尽。何等为八。一者净声光明陀罗尼。二者无尽器陀罗尼。三者无量际陀罗尼。四者大海陀罗尼。五者莲华陀罗尼。六者入无碍门陀罗尼。七者四无碍智陀罗尼。八者佛庄严璎珞陀罗尼。是名为八。若有菩萨安住如是八陀罗尼。则能受持一切佛语。凡所演说字句及义而无穷尽。师子幢菩萨言。善哉大士。唯愿广说。菩萨闻已当得受持一切佛法。陀罗尼自在王菩萨言。善男子。谛听谛听当为汝说。净声光明陀罗尼者。菩萨摩诃萨若得住者。能于无量无边佛所。具足成就无量功德得净四大。以是因缘其声微妙宣说法时。其音遍满一佛世界二佛世界。五佛世界十佛世界。二十佛世界三十佛世界。四十佛世界五十佛世界。百佛世界千佛世界。万佛世界乃至百千万佛世界。不可称不可数。随所说法即得遍闻。其说法时所坐法座师子之床。或一由旬或如须弥。或如梵处坐如是处。设有十方无量诸佛讲宣道化。普得闻之受持不忘。善解字句及其义味。自说法时及听佛说。于是二事各无妨碍。于一字中说一切法。一字者所谓为阿。阿者诸字之初。菩萨摩诃萨说阿字时。即能演说一切诸法。阿之言无。无者。诸法无根诸法无生。诸法无初诸法无边。诸法无尽诸法无作。诸法无来诸法无去。诸法无住诸法无性。诸法无出诸法无行。诸法无增诸法无高。诸法无减诸法无主。诸法无用诸法无愿。诸法无戏论亦无觉观。无说无听无处无入。诸法无我及无众生。无净无命无名无主。无有士夫无内无外无常无相无亿无量。无为无迹无句无字。无碍无共无随他无随己。无执无放无取无舍。无数无身无净无秽。无转无变无受无声。无相无结无污无狂。无漏无有无覆无浊。无对无色无受无想无行无识。无因无果无阴入界。无因缘无境界。无受无欲无色无无色。无诱导无黑无白。无滓无思惟。无时无归无净无杂。无烧无习无屋无支。无动无住无坚无脆。无可见无可触。无光无闇无曲无罪。无实无虚无痴无观。无见无修无见无闻。无觉无智无触无识。善男子。菩萨摩诃萨。获得如是净声光明陀罗尼时。于此一字说一切法。菩萨于此一字之中说无量义。无有错谬。不坏法界不失字义。菩萨得是陀罗尼已身口意净。举动进止众生乐见。是名身净。凡所演说众生乐闻。是名口净。修集慈悲喜舍之心。是名意净。菩萨得是陀罗尼已。能净二施财施法施。能净于戒见毁戒者不生恶心。能净于忍见害众生不生嗔恼。能净精进修行善法无有休息。能净禅定坏憍慢故。能净智慧除无明故。能净于业坏恶因故。能净于眼得三眼故。能净于耳获得天耳闻佛声故。能净于鼻悉嗅诸佛净戒香故。能净于口于甘露味不贪着故。能净于身得化身故。能净于意善思惟故。能净于色三十二相故。能净于声说妙法故。能净于香戒闻施等得清净故。能净于味得无上味故。能净于触修集无上诸三昧故。能净于法观诸法界无分别故。能净于念如所闻法不忘失故。能净于意永不系属诸魔党故。能净于行观察甚深诸法界故。善男子。菩萨住是陀罗尼已。随说音声所至之处。身之光明亦如是照。善男子。是陀罗尼成就如是无量功德。无尽器陀罗尼者。菩萨住是陀罗尼已。说色无常不可穷尽。说色是苦亦不可尽。说色无我说色如沫。如幻水月梦响影焰。亦不可尽。说色无性亦不可尽。说色无相空不可说。不可愿求不可造作。不生不灭非是过去未来现在非内非外非净非秽。非我我所非去非来。非对非碍非一非二。非是众生亦非寿命。亦非丈夫非贪嗔痴。非有非无非漏非无漏。非有为非无为。非盲非聋非跛非躄。非狂非乱非草木石。非树非地。非水火风。非舍非宅非城非郭。非大村落非山。非圆非方非四大造。非作非受非声非闻。非是可说。十二因缘不可穷尽。非常非断。无业无果非阴入界。非住欲界色无色界。非同非异亦非烦恼。非净非污非平非曲。菩萨摩诃萨说色如是不可穷尽。善男子。是无尽器陀罗尼者。有无量无边不可说分。分此一分以为千分。我于如是千分之中。唯说一分犹不能尽。无量际陀罗尼者。际者所谓常见断见。无量者谓十二因缘。际者所谓无明行识。乃至老死众苦聚集。又无量者所谓生死。又复际者谓无始终。又复际者谓无取舍。又复际者无出无灭。又复际者无污无净其性净故。又复际者所谓可见。又复际者所谓名色。又复际者有为无为。又复际者。所谓三世内外业果。无业无果善及不善。有漏无漏业及烦恼。我以无我生死涅槃。善男子。夫无量者所谓微尘。际者所谓地水火风。是名无量际陀罗尼。菩萨住是陀罗尼已。无量劫中为众说法。而其所说字句义味不可穷尽。是陀罗尼成就如是无量功德。大海陀罗尼者。善男子。犹如大海。四天下中所有诸色。众生卉木药树谷子。日月星宿云气雷电。国邑聚落城郭殿堂园池山河。如是一切诸种种色悉于中现。菩萨住是陀罗尼已亦复如是。一切众生身口意业。各各于是菩萨身中一一印现。十方世界所有众生所有口业。悉于菩萨口中印现。是故菩萨有所言说皆悉真实。印者名无所有。谓诸法无有觉观。无说无边无作无贪。是名第一真实之义。复有遮印遮之言眼。眼即无常可净可见。复有那印那之言名。一切诸法流布故名真实无名。复有逻印逻之言世。一切世间属爱无明。复有陀印陀之言十。佛具十力能化众生。复有波印波之言五。如来远离除灭五欲。得阿耨多罗三藐三菩提。复有杀印杀之言六。如来真实了知六入故。能调伏一切众生。复有杀印杀之言六。如来具足六念处故。得大自在。复有杀印杀之言六。如来具足六神通故。能以神通教化众生。复有婆印婆之言左。如来世尊离左道故。得阿耨多罗三藐三菩提。复有多印多之言实。如来善觉真实之性故名正觉。复有耶印耶之言彼。如来等知此彼平等。复有婆印婆之言结。如来远离诸烦恼故名阿梨呵。复有阇印阇言生老。如来已过生老之分故名世尊。复有昙印昙之言法。如来说法清净无垢。复有奢印奢之言奢摩他。如来成就修奢摩他。复有佉印佉之言虚空。如来知见一切诸法同于虚空。复有迦印迦言苦行。如来远离一切苦行。复有婆印婆之言实。如来所说四真谛者即是真实。复有摩印摩之言道。如来能说八正之道。复有伽印伽之言深。如来所说其义甚深。复有羼印羼之言忍。如来具足忍波罗蜜。复有呼印呼之言赞。如来常赞十方诸佛。复有若印若之言遍知。是故如来名一切智。复有婆印婆之言有。如来已解一切诸有。复有车印车之言欲。如来欲于一切善法。复有波印波之言前。如来常为一切众生现前说法。复有颇印颇之言果。如来常说四沙门果。善男子。因如是字演说诸法。所有诸字悉于菩萨口业印现。是名大海陀罗尼也。莲花陀罗尼者。菩萨住是陀罗尼已。所说法处常出七宝净妙莲花以为法座。菩萨坐上宣说法化。又复多雨无量莲花。是诸莲花亦出种种清净法音。其音深广多诸方喻。十二部音。清净之音。断烦恼音。尔时菩萨默然而住。是诸莲花皆能演法。亦出种种无量光明。一切众生皆见菩萨坐诸花台施作佛事。是名莲花陀罗尼也。入无碍门陀罗尼者。菩萨摩诃萨说一法时无有挂碍。若说二法三法四法。乃至百千无量无边恒沙等法。如四天下微尘等法。乃至三千大千世界微尘等法。乃至恒河沙等诸佛世界微尘等法。于字句义亦无挂碍。是名入无碍门陀罗尼也。四无碍智陀罗尼者。所谓法无碍智。义无碍智。辞无碍智。乐说无碍智。东方无量世界众生有问法者。菩萨随以法无碍答。南方无量世界众生有问义者。菩萨随以义无碍答。西法无量世界众生有问辞者。菩萨随以辞无碍答。北方无量世界众生问乐说者。菩萨随以乐说智答。是名四无碍智陀罗尼也。佛璎珞庄严陀罗尼者若有菩萨获得如是七陀罗尼。其顶髻上有佛像现。其色真金有大光明。三十二相八十种好。尔时菩萨身口意等悉作佛业。其所思念如佛所念。菩萨具足如是佛业。能知大众种种之心。知已随意而为说法。若一日若二日。乃至无量百千万岁。不能尽其所知法门文字句义。又复具足四种智慧。何等为四。一者知众生心。二者知诸字句。三者知所说无尽。四者知于真实。菩萨具足如是四智。能调众生为阿耨多罗三藐三菩提。善男子。是名佛璎珞庄严陀罗尼也。善男子。是八陀罗尼其分无量。于是分中分其一分以为千分。于是分中唯说一分犹不能尽。是陀罗尼成就如是无量功德。尔时陀罗尼自在王菩萨即说颂曰

  如来说八陀罗尼　　若有菩萨具得者
  能解诸经种种义　　其辞句义不可尽
  具足善业得妙声　　能令无量世间闻
  众生闻已修善法　　修已获得于解脱
  无量劫中说无法　　因一法根说无尽
  亦因一字解多义　　是名如来说际持
  人中牛王断二际　　说中道义无有边
  具足智慧平等观　　虽成是持无得者
  四方色等现大海　　一切字印印菩萨
  说法之时无障碍　　成就大海陀罗尼
  坐宝莲花演说法　　亦雨莲花散大众
  莲花亦说无量法　　是名寂静莲花持
  说于一字无障碍　　无量字中亦如是
  说无量义无有滞　　具足如是无碍持
  说法深义无有尽　　辞及乐说无有边
  能破众生疑网心　　获得无上智总持
  顶髻常出如来像　　身口意业佛无异
  若具如是八持者　　穷劫赞叹不可尽
  具足是八陀罗尼　　处世不污如莲花
  在世最高如须弥　　不可称计亦如是
  世邪不动亦复然　　是人具足如是持
  能坏世道诸邪见　　犹如师子兽中吼
  若得无上陀罗尼　　能达世间清净行
  能增无量诸善法　　亦能教化多众生
  具足如是陀罗尼　　能坏众生无明闇
  作大光明如朝日　　亦能除破诸黑闇
  说法无碍如虚空　　为众生行如猛风
  施于法药坏烦恼　　如世良医救病者
  若得具足无上持　　有赞功德不能尽
  能作清凉如秋月　　增长善法亦如是
  菩萨成就如是持　　能化无量诸众生
  若具如是陀罗尼　　获得自在如大王
  能化众生于大乘　　能施法财破贫穷
  能降法雨如龙王　　摧灭烦恼如恶雹
  若得如是陀罗尼　　能化众生于菩提
  不能说过如帝释　　字义不尽如虚空
  若得成就陀罗尼　　一切大众乐见闻
  其意不散常在定　　修集无量慈悲心
  清净梵行游神通　　是四皆如大梵天
  若得成就陀罗尼　　即能供养十方佛
  了了观见十方界　　于其世界化众生
  若具如是陀罗尼　　即得具足佛功德
  常为十方佛所念　　亦如父母念一子
  若有菩萨得是持　　能赞功德无量鬘
  具足成就戒念慧　　能解众生心所行
  若得成就陀罗尼　　无有憍慢及悭贪
  善知方便调众生　　修集慈悲坏烦恼
  若得成就陀罗尼　　烦恼不污如虚空
  善解众生随意语　　亦能随意演说法
  若具如是陀罗尼　　悉能了知众生根
  能解众生种种解　　随其所解而说法
  随对治门为说法　　三十七品调众生
  若得如是陀罗尼　　修奢摩他无有边
  若得如是陀罗尼　　具足六度如诸佛
  了知一切烦恼界　　通达寂静而坏之
  身口意业悉寂静　　行住坐卧亦如是
  若得成就如是持　　无复烦恼诸习气
  得净法身无有边　　非生所生常化生
  身口意业随智行　　所有定念亦如是
  若得成就如是持　　有赞叹者不能尽

尔时世尊赞陀罗尼自在王菩萨。善哉善哉善男子。汝已久得是陀罗尼。是故能善分别解说所有无量功德之义。不但今日。已于过去无量佛所亦作如是分别解说。善男子。过去无量阿僧祇劫。尔时有佛号净光明。世界名净劫。亦名净纯。净琉璃以为世界犹如明镜。地平如掌。所有林树七宝所成。妙宝莲花大如车轮。清净鲜洁人所乐见。其土人民悉处七宝楼殿堂阁如天无异。贪欲恚痴渐已经微。土无日月唯有佛光。青莲花开则知是夜。赤莲花敷则知是昼。时彼佛有六万百亿大菩萨僧。出家之人不可称计。皆悉志乐无上大乘。世界乃至无二乘名。一切皆是不退菩萨。其佛寿命具足半劫。人之与天无有差别。在地为人处空为天。无有王者除佛法王。其土人民无有宗事。诸天邪神及归依者。亦无女身毁戒之名。具足三戒。何等为三。一从戒戒。二从心戒。三从慧戒。发菩提心厌悔生死名从戒戒。修三昧慧名从心戒。修集智慧得大智慧名从慧戒。尔时众中有一菩萨。名曰光顶。从坐而起头面礼足。右绕恭敬长跪合掌。而白佛言。世尊。所言陀罗尼者。云何名为陀罗尼也。菩萨住何陀罗尼中。能持一切诸佛名号。为诸众生分别解说。佛言。善男子。有陀罗尼名曰宝炬。菩萨住是陀罗尼中。能持一切诸佛名号。为诸众生分别解说。随诸众生种种语言。光顶菩萨复白佛言。唯愿世尊分别广说。我等闻已当得修持。佛言。善哉善哉善男子。至心谛听吾当为汝分别解说。尔时世尊即说偈言

  远离一切诸烦恼　　清净无垢犹真实
  其心能作大光明　　是名宝炬陀罗尼
  身口意业悉寂静　　犹如秋月之明净
  修集大慈心平等　　是名宝炬陀罗尼
  其心无有诸觉观　　悉得远离于二见
  亦非有想非无想　　是名宝炬陀罗尼
  具足成就念意慧　　能入无上大法门
  清净无垢如虚空　　是名宝炬陀罗尼
  远离三种尘劳垢　　成就三种清净慧
  已于三有得解脱　　是名宝炬陀罗尼
  能悉破坏贪恚痴　　亦得远离烦恼浊
  除灭无明诸邪闇　　是名宝炬陀罗尼
  众生音声上中下　　一切悉能了了知
  能随众生意说法　　是名宝炬陀罗尼
  具足甚深无量义　　亦复具足诸字句
  远离于我及我所　　是名宝炬陀罗尼
  具足成就四依法　　亦复具四无碍智
  其心常在于四禅　　是名宝炬陀罗尼
  能广分别第一义　　具足而得四梵行
  修集具足五神通　　是名宝炬陀罗尼
  受持专忆四念处　　精进获得四正勤
  庄严成就四如意　　是名宝炬陀罗尼
  成就五根及五力　　一切邪风不能动
  修集无上七觉分　　是名宝炬陀罗尼
  成就定慧二翅翼　　游翔平坦八正路
  趣向无上智解脱　　是名宝炬陀罗尼
  能践菩萨之道地　　及住无上真解脱
  永断一切烦恼习　　是名宝炬陀罗尼
  能作无量大光明　　犹如世间之日月
  能净三种清净眼　　是名宝炬陀罗尼
  能净一切诸烦恼　　亦得远离诸魔业
  观察五阴味过咎　　是名宝炬陀罗尼
  善知调伏诸众生　　永离六根之因缘
  为众说法令得念　　是名宝炬陀罗尼
  住于如是陀罗尼　　能到十方佛世界
  见佛至心听受法　　亦能广说如是法
  既闻法已至心持　　能为众生说字义
  以大念力因缘故　　能解诸佛微妙语
  能说无常苦无我　　诸法悉从缘得果
  了了观察诸法界　　是名宝炬陀罗尼
  成就乐说无碍智　　三明三慧亦如是
  若有住是总持者　　乃能得八解脱义
  佛说无量陀罗尼　　悉来摄在此持中
  若得如是陀罗尼　　是名成就无量持
  若入无量诸禅定　　及得无量诸神通
  皆由如是总持力　　是故名为持中王
  如四大海无障碍　　一切河泉皆投之
  诸法众流亦如是　　皆悉归趣是持海
  得身无边意无尽　　能广分别说法界
  成就无量功德者　　乃能获是陀罗尼
  若得如是微妙持　　即得三十二相好
  其色殊胜上种性　　多饶财宝得自在
  于诸有中得无生　　能广分别诸法义
  安住不动不退地　　皆由得是陀罗尼
  菩萨若欲修菩提　　当修如是陀罗尼
  得是持已修道易　　能演说法调众生
  于无量劫说法时　　字义二法不可尽
  能净众生诸烦恼　　以得如是陀罗尼
  能转无上正法轮　　能令众生脱众苦
  能进众生无上道　　以得如是陀罗尼
  若有众生千万口　　一口而有千万舌
  不能宣说成持者　　所得无量之功德

善男子。尔时净光明佛说是法时。光顶菩萨及与三万二千菩萨悉皆获得是陀罗尼。善男子汝知。尔时光顶菩萨。岂异人乎即汝身是。是故汝今能广分别是陀罗尼。是大众中得是持者汝最第一。尔时会中有一菩萨名曰慧聚。白佛言。世尊。云何菩萨得宝炬陀罗尼。得已不失。能以此法调伏众生。善男子。若有菩萨安住慧根造作慧业。如是菩萨能得是持。得已不失。能以此法调伏众生。慧聚菩萨复作是言。善哉世尊。唯愿演说。云何慧根。云何慧业。佛言。善哉善哉善男子。至心谛听吾当为汝分别解说。善男子。若有善男子善女人。未闻智慧而得闻之是名为根。闻已广说名之为业。始观诸法名之为根。观已广说名之为业。初观善根名之为根。转以化人名之为业。观不放逸名之为根。转以化人名之为业。调伏自心名之为根。调伏他心名之为业。住于寂静名之为根。净身口意名之为业。知于一乘名之为根。为众生说名之为业。修奢摩他名之为根。具三种慧名之为业。修三解脱名之为根。证得三慧名之为业。修四念处名之为根。不念于念名之为业。修四正勤名之为根。离烦恼性名之为业。修四如意名之为根。知无如意名之为业。修集信心名之为根。放舍一切名之为业。修无所畏名之为根。能广说之名之为业。修集三昧名之为根。知定次第名之为业。修集智慧名之为根。知一切法名之为业。庄严菩提名之为根。得菩提时名之为业。证苦习道名之为根。证尽灭时名之为业。不依不了义名之为根。依了义经名之为业。初听受法名之为根。依止其义名之为业。不依于人名之为根。依止于法名之为业。见法无常名之为根。法无生灭名之为业。知诸法苦名之为根。知法无作名之为业。知法无我名之为根。知法性净名之为业。知涅槃净名之为根。知法本净名之为业。闻义不畏名之为根。依止于义名之为业。闻真不怖名之为根。依止真法是名为业。知字不畏名之为根。知已乐说名之为业。闻说如来无碍智力。不生怖畏名之为根。依止如来无碍智力名之为业。生法二缘名之为根。无缘之慈名之为业。怜愍众生名之为根。能为坏苦名之为业。思善得喜名之为根。心不着法名之为业。无爱恚舍名之为根。无一无二名之为业。念佛名根。念于法身名之为业。念法名根。知法性净名之为业。念僧名根。知僧无为名之为业。念戒名根。知无持者名之为业。念施名根。能舍烦恼名之为业。念天名根。获得净天名之为业。闻已思惟名之为根。不着世间名之为业。知本无今作名之为根。无作无受名之为业知。于涅槃名之为根。得大解脱名之为业。自利名根。自利利他名之为业。受持八万四千法聚名之为根。通达其义名之为业。能演说法名之为根。解无明等名之为业。劝诸众生于菩提道名之为根。劝修智慧方便不退名之为业。不畏诸有名之为根。愿生诸有名之为业。从闻得忍名之为根。思惟得者名之为业。随意得忍名之为根。因不生得名之为业。余一生在名之为根。最后边身名之为业。坐菩提树名之为根。了知诸法名之为业。说是慧根慧业之时。一切十方诸佛世界。及此宝坊六种震动。尔时慧聚菩萨摩诃萨白佛言。世尊。何因缘故十方世界及此虚空七宝坊庭如是震动。善男子。是慧根慧业。亦是过去诸佛所说。是故此地为大震动。尔时具足四无碍智菩萨白佛言。世尊。何四缘故慧聚菩萨名之为聚。佛言。善男子。过去无量阿僧祇劫有佛出世。号功德藏如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。土名善生劫名无垢。其土众生一切纯善。尔时佛有三万二千大菩萨众。八万四千声闻大众。尔时世尊欲试菩萨。以百亿事问诸菩萨。诸善男子于是众中谁能解说如是等义。其中有言我当思惟。经一月日乃能解之。或复有言我过半月。复有言曰我过七日。或言我过一日一夜乃能解之。尔时众中有一菩萨名曰念意。白佛言。世尊。我今不起此坐能解是义。尔时菩萨于大众中师子吼已。其地即时六种震动放大光明。劝诸地神乃至阿迦尼吒诸天。一切悉来诣如来所。尔时大众所坐之处。纵广满足百万由旬。念意菩萨。见诸大众悉以集会。以神通力智慧念力。陀罗尼力四无碍力。无所畏力佛神力故。于是百亿一一事中解百亿义。不豫思惟无有停滞。说是义已。是大众中六万众生发阿耨多罗三藐三菩提心。四万众生得无生忍。从地神诸天乃至阿迦尼吒天。一切悉闻说法之声。善男子汝知。尔时念意菩萨岂异人乎即慧聚是。以是因缘名为慧聚。尔时世尊即说颂曰

  闻说法故名为根　　演说法故名为业
  思惟诸善名为根　　解说深义名为业
  如法而住名为根　　随意说法名为业
  修奢摩他名为根　　具三种慧名为业
  四种念处名为根　　四正勤法名为业
  信等五根名为根　　信等五力名为业
  七菩提分名为根　　八正道分名为业
  不依止字名为根　　依止于义名为业
  不依于人名为根　　依止于法名为业
  不依不了名为根　　依止了义名为业
  不依于识名为根　　依于智慧名为业
  了知无作名为根　　通达无生名为业
  生法二慈名为根　　无缘之慈名为业
  无所畏惧名为根　　能宣正法名为业
  六思念处名为根　　六念之义名为业
  能自利益名为根　　自利利他名为业
  受持正法名为根　　能为人说名为业
  余一生在名为根　　最后边身名为业
  若菩萨心得不退　　即解了知慧根业
  能得无生之上忍　　能开无上菩提门

尔时陀罗尼自在王菩萨白佛言。世尊。佛所说法不可思议。无上菩提亦不可思议。何以故。非字说故非字摄故。如来所说无量无边故。入无量无边法门故。十二因缘深难解故。着二法者不能知故。利智之人渐渐知故。非是六情所知见故。亦非二乘智境界故。世尊。如是菩提悉是一切诸法之印。不可造作犹如虚空。非是屋宅离屋宅故。知一切行一切众生所有因果。一切智慧广大无边。庄严一切无量善法。能为善法而作应器。能以神通显示于人。住二道者示以无二。示一切佛平等无差无字无义。不可宣说不可听闻。能示众生三宝正聚。及三脱门解脱三界。示三种慧金刚定因。住于一切诸佛正法。悉闻一切诸佛智慧。利一切众亦能宣说一切诸佛。世尊。若有善男子善女人。能作如是赞叹菩提所有功德。得闻如是方等经典。受持读诵书写演说。是名能报诸佛之恩。佛言。如是如是善男子。如汝所说得无量功德。善男子。一切十方诸佛世界满中七宝以献如来。若有人能受持是经。书写读诵解说其义。所得福德无有差别。尔时世尊告诸菩萨。善男子。于此众中谁能于我灭度之后。护持如是无上菩提。广说是义令法久住。尔时众中有诸菩萨及诸天人各六万亿同声而言。我等能于如来灭后。护持如是无上菩提。广说是经令法久住。唯愿如来加之愿力。尔时世尊即说偈言

  若我实同十方佛　　永渡生死大苦海
  如是功德无上法　　应当久住无毁灭
  若我无量世修慈　　真实为于诸众生
  观众平等无有二　　是故正法得久住
  若我具足二庄严　　无量世中利众生
  以是二法化众生　　是故正法得久住
  若能破坏烦恼结　　并及除灭诸邪见
  具足一切诸善法　　故能善发是愿力

善男子。不独汝等一切人天一切魔梵。于我灭后悉能护持如是正法。善男子。虚空可作色。色可同虚空。我愿神通力不可得令异。尔时四天王作如是言。若有人能于佛灭后。受持是经读诵书写解说其义。我等常当随逐守护。诸梵天言。我等当舍禅定妙乐守护是人。兜率天言。我等亦当守护如是持经弟子。时魔波旬复作是言。世尊。若有人能受持是经。我于其人终不造作魔业魔事。功德藏天子言。世尊。一切诸佛所得菩提悉在是经。若有人能受持读诵书写解说。当知是人即得菩提。弥勒菩萨言。世尊。我当于彼兜术天上。广宣如是无上经典。大德迦叶复作是言。世尊。我声闻人智慧虽微。应当任力受持读诵宣说其义。阿难复言。世尊。我于此经真实受持。乃至不失一字一句。如佛口出无有异也。若有众生发菩提心。我亦能为是人广说。佛言。善哉善哉善男子。汝等悉能于我灭后。护持正法不令毁灭。善男子。若有众生求于大乘。未得法忍受持是经。当知是人不过七佛便得授记。若声闻人有受持者。弥勒成佛在初会中。若缘觉人有受持者。于我灭后得成道证。说是法时。无量众生发阿耨多罗三藐三菩提心。无量众生成就忍辱。无量众生得不退心。无量世界六种震动。十方世界诸来菩萨。以好香花伎乐幡盖供养于佛。咸作是言。我等来此七宝坊中得大善利。若我脱有少福德力。愿以此力令释迦如来久住于世。如是正典流布遍满十方世界无有毁灭。若有优婆塞优婆夷等持是经者。令离一切忧愁怖畏无诸病苦。尔时陀罗尼自在王菩萨言。世尊。今所说法无量无边不可思议。一切邪法不能倾动。乃是一切善法之本三乘根栽。复是一切诸法初门。若有众生来问我言。是法何名云何受持。当云何答唯愿说之。佛言。善男子。是名大悲说大悲法。名如来业受菩萨记。当如是持。说是经已。人天大众欢喜顶戴信受奉行

大方等大集经卷第四大方等大集经卷第五

        北凉天竺三藏昙无谶于姑藏译

    宝女品第三之一

尔时世尊。故在欲色二界中间大宝坊中师子座上。与诸大众围绕说法。尔时会中有一童女名曰宝女。即从坐起。右手执持白真珠贯。而作是言。若我真实能于十方无量世界。受持如是大集正典。读诵书写演说其义广流布者。愿此珠贯着佛顶髻及诸菩萨。说是语已即掷珠贯。以佛神力及以诚言。珠贯即在如来顶上。亦遍一切诸菩萨首。而诸菩萨各各自于首贯珠中。见其来世成佛之时所有世界菩提之树。众生调伏及往愿力了了见知。见已各各生奇特想白佛言。世尊。是宝女者。云何乃有如是无量大功德也。我于无量阿僧祇劫所有誓愿。今于一念悉见了了。佛言。善哉善哉善男子。实如所言。是宝女者已于过去九万六亿那由他佛。种诸善根发大善愿。所生之处常得真实。是故是女凡所思念言无虚发。若欲令此大千世界满中宝花即言而有。若言欲令满此三千大千世界。种种妙香言已即有。若欲示现种种形色。转轮王色。四天王色天帝释色梵天王色。或沙门色婆罗门色。或比丘色比丘尼色。优婆塞色优婆夷色。如言即得。若风灾起时转为火灾。火灾起时转为水灾。水灾起时转为风灾。如言即转。若有魔王将诸兵众。执持刀杖弓弩箭矢鉾槊戈楯。欲令转变成宝花者。如言即成。若于空旷无水多乏。为诸众生发大誓愿。其中即有城邑聚落。人民大小浆水无乏。若愿三千大千世界所有诸色如如来色。即如其言成佛妙色。若言一切所有大众悉住虚空。言已即住。善男子。若是宝女。欲于此处虚空之中。遍闻十方诸佛所说。如言即闻。善男子。宝女童女成就如是无量无边诸大功德。尔时宝女即于佛前说偈叹曰

  我今成就大宝聚　　故能赞叹无上尊
  远离一切诸烦恼　　是足大宝助菩提
  如来具足无上宝　　大光能照无边世
  无上宝幢佛世尊　　我今献宝以供养
  车磲马瑙青琉璃　　金刚真珠日月宝
  以如是宝供养佛　　为令众生成菩提
  世尊身光胜诸宝　　众生乐见无疲厌
  处在一方见十方　　令众各见前有佛
  有见如来身行住　　或见坐卧及说法
  或见默然无所宣　　或见入定修智慧
  如来一一毛孔光　　能照十方诸世界
  光明清净最无上　　犹如秋月净莲花

尔时宝女偈赞佛已复作是言。世尊。我今于此大集经中欲少问义。如来若许乃敢咨启。佛言。善哉善哉宝女。随意发问。若有疑网我当为汝而除灭之。尔时宝女即白佛言。世尊。云何实语云何为实。云何法语云何为法。佛言。善哉善哉至心谛听。吾当为汝分别解说。宝女。菩萨摩诃萨有三种实。何等为三。一者不诳诸佛。二者不诳己身。三者不诳众生。云何名为不诳诸佛己身众生。宝女。若有菩萨发阿耨多罗三藐三菩提心已。贪着声闻辟支佛乘。是则名为欺诳诸佛己身众生。云何不诳。宝女。若有菩萨发阿耨多罗三藐三菩提心已。若在地狱受大苦恼。若遇魔业邪见同止。若生恶国起恶烦恼。身遇刀槊斫刺烧炙。于如是时终不舍离菩提之心。不休不息不畏不悔。令菩提心遂更增广。为诸众生受大苦恼。见受苦者心更增广。勤修精进欲得菩提。不为邪语之所诳惑。一切邪风不能倾动。是名菩萨不诳诸佛己身众生。宝女。若有菩萨不诳诸佛己身众生。是名菩萨真实之实。宝女。不诳诸佛复有四事。一者其心坚固。二者住于至处。三者具足势力。四者勤修精进。不诳己身亦有四事。一者净心。二者至心。三者不诳。四者不曲。不诳众生亦有四事。一者庄严。二者修慈。三者修悲。四者摄取。宝女。是名菩萨第一之实。菩萨实者。初发愿时不舍众生。复次宝女。菩萨实者。不多语守护语。不粗语真实语。若在独处大众王边发言诚实。非为财物而故妄语。非为自在而故妄语。若有三千大千世界满中七宝。尚不为之而生妄语。况复小事而妄语也。宝女。如是实者。有三十二净。何等三十二。一者惭语。二者功德语。三者愧语。四者柔软语。五者不虚语。六者无讥呵语。七者不贪着语。八者不畏语。九者闭诸恶道语。十者开诸善道语。十一者圣行语。十二者慧行语。十三者内净语。十四者外净语。十五者乐受语。十六者乐听语。十七者不涩语。十八者微妙语。十九者分别语。二十者妙音语。二十一者纯善语。二十二者不诳语。二十三者不热语。二十四者欢喜语。二十五者自劝喻语。二十六者劝喻他语。二十七者不失语。二十八者安隐语。二十九者福田语。三十者如佛语。三十一者实围绕语。三十二者净口语。复次宝女。菩萨实者。凡所言说口意相称。云何名为口意相称。修集施故获得菩提。非因悭贪而能得之。是名意口相称而语。能施一切名之为实。修集净戒获得菩提。非因毁戒而能得之。是名意口相称而语。如戒而住名之为实。修集忍辱获得菩提。非因嗔恚而能得之。是名意口相称而语。具足修忍是名为实。勤行精进获得菩提。非因懈怠而能得之。是名意口相称而语。修精进故名之为实。修集禅定获得菩提。非因乱心而能得之。是名意口相称而语。修集定心名之为实。修于智慧获得菩提。非因愚痴而能得之。是名意口相称而语。修智慧故名之为实。三十七助菩提之法。四无量心亦复如是。复次宝女。夫真实者所谓圣行。圣行者苦无常行。又复圣行。所谓知苦远集证灭修道。知于五阴无出生相。是名知苦。五阴因者。所谓爱结毕竟远离。不贪不着。不赞不求。不去不来。是名离集灭一切相。然其灭时无一法灭。不平等法作平等法。是名证灭观。奢摩他。毗婆舍那。其相平等。无觉无观无有平等。无系无取无作无变。是名修道真实了知。如是等谛又能分别广说其义。是名菩萨摩诃萨实说是真实法。时十千菩萨得真实忍。宝女。法语者。凡所演说依法而语。观法念法奉行于法。行至处法求法欲法乐法修法。法幢法杖庄严法器。法灯法明。法念法意。法有法疑。庄严璎珞法床法仪。法护法财法无穷尽。广大无边。法事法身法口法意。菩萨摩诃萨具足成就如是等法。是名法语。法者真实之语守护法语。教人供养父母和上耆旧有德。赞叹菩提及菩提道。令人不舍菩提之心。至心系念不忘菩提。不离庄严修菩提法。亲近贤圣善知识等。修集信心专念听法。慕求正法勤于精进。不贪着法知恩报恩。乐于寂静不断圣种。教化头陀勤行十善。赞叹惠施一切善法愿向菩提。至心受持清净戒律。修集忍辱。除去懈怠。修净禅定。智慧方便。慈悲喜舍。修四真谛趣向于谛。四无碍智得大神通。随顺法施修四念处。乃至修集八圣道分定慧二法得智解脱。如法解脱声闻缘觉菩萨诸乘。赞说一切所有福德。当观十二甚深因缘。分别空门无相无愿无所畏惧。说五阴如幻如化。说十八界如虚空相。说诸入性同于空性。常说七财六念六敬。解说具足六波罗蜜。说六常行修六神通。具足五眼说第一义。流布世间成就业语。一切众生其心平等赞叹佛语。宝女。若有菩萨具足如是法语。口终不说我语。不说众生语。不说寿命语。不说士夫语。不说断语不说常语。不说有见语不说无见语。不说两断语。不着中语不说聚语。不说灭语不说诤语。不说偏语不觉知语。不颠倒语。不增疑心语。不逆法语。观法界语破憍慢语。说法菩萨如法而住。如法而说实语法语不断语不折语。说法菩萨一切世间不能共论见者怖畏。法语菩萨能演说空无相无愿。不着三界及以诸有。不从他乞。无心意识。无有尘垢无明无闇。不系属他不系属自。无有高下。不杂一切境界因缘。清净寂静无有导首。难知难觉不可思惟不思惟行。清净智者。乃能知之。无受受者永断诸受。过于三世不灭无灭相。不生无生相。无有丰俭。无生无断。无增无减。无当有无已有。非修非见。非魔见非真实见。非相非非相。非一相而亦一相。非有屋宅远离屋宅。非近非远非离非别非缚非解。非有漏非无漏亦非相似。非苦非乐非具足非不具足。非名非色非着非脱非破非完。虽非金刚不可坏相真实如尔。非近非远无色无因。亦非顽嚚非此非彼。非内非外非自非他。非见非闻非忆非忘。非识非知非识境界非知境界。宝女。是名为法。若能广说如是等法。是名说法。复次宝女。法语菩萨不与一切世间诤竞。不轻不慢于他未学。心不轻笑不生高心。不自赞叹不谤他说。不以饮食为他说法。不遮他善令生疑惑。见他犯罪终不说之于他法中不生轻贱。不遮止他所修行法。凡所说法。不离于空无相无愿。终不分别一切法界。不动法界不动实性。不依字识人不了义。虽不依止亦不诽谤。于自他众不生分别。亦不诽谤十二因缘。非在世间净于世间。非法净法无贪无悭。无有毁戒不舍破戒。无嗔无妒无有懈怠。不失道心不忘菩提。为欲庄严无上智慧。不休不息心不生悔。于他法中心无妒嫉。不以着于非修多罗谤修多罗。毗尼摩耶亦复如是。于正法所终不见非。不因于慢而增长慢。不谤因果及业果报。于正法中心无退转。知恩念恩报之不忘。终不怀抱嗔恨之心。不着我见不嫉他利。于怨亲中无有二想。得他讥刺终不报之。不作两舌斗乱彼此。不怀谄曲显异惑众。不为他喜受菩萨戒。比丘戒比丘尼戒。式叉摩那戒。沙弥戒沙弥尼戒。优婆塞戒优婆夷戒。住空闲处思惟寂默。勤心受读十二部经。不为胜他故受持守护如是等戒。不为供养现作知足。不为显他不知足故自修知足。不信诸佛无上菩提。他之所作。不造恶业邪恶活命。不舍七财不贪于食。不断圣种。不诽谤他不自赞叹。于佛法中不作数量。赞叹大乘心无厌足。是名法语。尔时世尊复告宝女。菩萨义者云何名义。所谓信心修庄严时无有虚诳。为欲庄严一切善根。至心专念修行善法。破众生疑不求果报。施诸众生安隐快乐。护持禁戒不失忍心。勤修精进增长善法。修寂静定摄诸散乱。具无上智破无明闇。修集慈心等诸众生。修集悲心随众所作亲往营理。修集喜心施众法喜。修集舍心不观苦乐。舍财法已心无悔吝。所言柔软坏众恶心。利益于他具足甚深。修行同事劝发大乘。以是四摄调伏众生。见一切行皆是无常苦空无我。净诸烦恼。依止于义不依于字。依止于智不依于识。依了义经舍不了义。依止于法不依于人。说义无碍无有穷尽。而于法界无所分别。说辞无碍获得解脱。说乐说无碍如法而说。庄严惠施不知厌足。庄严于戒善愿成就。庄严多闻如法而作。庄严功德具足相好。庄严智慧知诸众生上中下根差别之相。庄严于定为心清净。庄严于智得三种慧。修四念处为心不散乱。修四正勤为得善根。修四如意往来诸方。修集五根辩分别句。修集五力为坏烦恼。修七觉分为知诸法。修八正道不为恶动。修集神通为不退失。菩萨摩诃萨解如是义。是名为义。若有菩萨能说是义。是名说义。复次宝女。又复义者。修集空定坏诸有法。修集无相坏诸法相。修集无愿不求三界。若能演说如是三空。是名说义。一切诸行不可修行。是名为义。菩萨说是不可修行。是名说义。断一切生是名为义。菩萨若说诸法无生。是名说义。诸有无出是名为义。如是说者是名说义。四真谛者名之为义。如是说者是名说义。无我我所名之为义。如是说者是名说义。字不可说名之为义。如是说者是名说义。真实之义名之为义。如是说者是名说义。一切菩提之法。不可称计。是名为义。菩萨摩诃萨。如是说者是名说义。多闻之人如法而作。是名为义。如是说者是名说义。一切诸乘大乘为最。是名为义。能如是说是名说义。复次宝女。无所分别名之为义。无有众生。亦无受命。一味不动不尽。一事不生不出。不来不去不灭不二。不可观见。无有造作。无为无作。心不谄曲。三世平等。三分无差。不失不得。不热不冷。不净不秽。不行如尔。不取不舍。非道示道。非常非断。亦非中道。不嗔不浊。不观于法及以非法。非一切字音声辞语。无心意识。于贪嗔痴不生分别。一切诸法作相有相。空无相愿是三即空。真实入法等与不等皆悉平等。因于智慧获得解脱。宝女。菩萨若能如是具义。是名为义。说如是义是名说义。宝女。云何菩萨说于毗尼。佛说毗尼凡有二种。何等为二。一者犯毗尼。二者烦恼毗尼。云何为犯。云何毗尼。犯已寻觉不善思惟。因于无明颠倒虚妄欺诳烦恼。着我众生疑心。不得解脱。掉悔憍慢放逸寡闻。因如是等是名为犯。若破疑心获得解脱。得解脱故见有犯处。即是非处亦非非处。非身口意。不取不舍不可睹见。非是身作及心口作。若是三作即是灭法。若是灭法。谁作谁犯如犯。一切诸法亦复如是。诸法无根无作无处。若能破坏如是等疑。是名为净。是名不热。随师教作。是名有信。是名有定。是名毗尼。云何烦恼。云何毗尼。十二有支。所谓无明乃至老死。是名烦恼性。能调伏一切烦恼。是名毗尼。何以故。空无相愿能调诸法。若法是空无有性相不可愿者。云何而有贪恚痴等。无作能调一切诸法。若一切法不可作者。云何而有烦恼诸结。一切诸法从因缘生。若从缘生云何可见。见如是等十二有支。亦知烦恼及烦恼相。若是空智能观菩提。即以此空空于烦恼。若能观察如是平等。是名毗尼。若能如是演说义者。是名菩萨能说毗尼。若是毗尼能知我者。即是了知烦恼毗尼。云何名为知我毗尼。谓观无我观于我性。知我净我实。知我分别我空我修。知我不动不说不着不生不灭。若能如是知于我者。即是了知烦恼毗尼。若实无我而作我想。于无烦恼作烦恼想。亦复如是若我本无烦恼亦尔。若有具足毗婆舍那。则能如是观察了知。是名知我烦恼毗尼。烦恼者非过去未来现在。若能不作不念不求。是名知于烦恼毗尼。毗尼亦非去来现在。如心非色。非内非外。亦非中间。烦恼亦尔。非色非内外及以中间。何以故。无觉知故。无诤竞故。无清净故。无造作故。若能如是知诸烦恼。不出不灭是名了知烦恼毗尼。宝女。菩萨若得如是等知烦恼毗尼。亦为众生说如是法。是名菩萨演说毗尼。说是法时。十千菩萨得无生忍。尔时宝女心大欢喜。前白佛言。世尊。如来所说真实法义。及以毗尼不可思议。若有菩萨能如是说。是人则能实知实见。尔时舍利弗语宝女言。汝今已具如是等法。能演说不。宝女答言。大德舍利弗。实名无贪无贪即义。如是义者即不可说。不可说者即是毗尼。大德。若如是者云何可说。复次舍利弗。实者即灭灭者即法。法者即净净者即义。义者即毗尼。如是等法无有文字。若无文字云何可说。大德。实者即如如者即法。法即无二无二即义。夫无二者亦不可调。若不可调云何名调。如是等法悉无所有。若无所有云何可说。舍利弗言。汝今成就何等宝故。立如是名名宝女耶。答言。大德。有三十二菩萨宝心。如是心中悉无声闻辟支佛心。何等三十二。一者发心为度一切诸众生故。二者发心为令佛种不断绝故。三者发心为持佛法不灭尽故。四者发心守护僧故。五者发心为施众生圣法之乐。六者发心为诸众生修集大慈。令众远离烦恼诸苦。七者发心修集大悲舍内外物。八者发心护持禁戒调毁戒故。九者发心修忍破坏不忍。憍慢恶心颠心醉心狂心放逸自在心故。十者发心精进为破懈怠畏退悔心调伏懈怠诸众生故。十一者发心修定为破乱心狂心妄念。为令众生获得四禅及八解脱。调伏欲界诸众生故。十二者发心修智破一切闇。真实知见入于法界。十三者发心为知众生平等无二皆一味故。十四者发心为得无贪无嗔利衰毁誉。其心无二安住善法苦乐不动。为如是等护众生故。十五者发心为得无怖无畏。欲解甚深十二因缘离一切见。十六者发心为欲庄严智慧。及以功德无有厌足。十七者发心为欲不离见佛常闻法故。十八者发心为欲如闻而说。十九者发心为得广大法聚心无食吝。二十者发心为欲赞叹净戒。如闻而住教化慰喻毁禁人故。二十一者发心为破一切众生七种慢故。二十二者发心为知一切众生上中下根。二十三者发心为破诸魔恶业。二十四者发心为施众生安乐。二十五者发心为欲坏破众生。所有众苦心不生悔。二十六者发心为欲具足成就得佛法故。二十七者发心为知有为之法。一切无常苦无我故。如已不离心无厌悔。二十八者发心为乐修集一切助菩提法。二十九者发心为见空无相愿。以众生故而不取证。三十者发心为于虽畏诸有亦护诸有。三十一者发心为于见生死过而不厌悔。三十二者发心为于若近菩提受无上乐舍。是妙乐为众生故受贫穷苦。舍利弗。是三十二发心之宝。悉无声闻辟支佛心。是故菩萨名为宝聚。尔时世尊赞宝女言。善哉善哉。汝真实说菩萨摩诃萨发菩提心。而菩提心成就无量无边功德。不可齐说三十二事何以故。非声闻宝能得佛宝。非缘觉宝能得佛宝。以菩萨宝能得佛宝。得佛宝已。则得声闻辟支佛宝。菩萨佛宝。是故菩萨名为宝聚。尔时舍利弗白佛言。世尊。宝女所说不可思议。我观其说。是女似得四无碍智。佛告舍利弗。汝今方谓。是女未得四无碍耶。是女久已成就具足。宝女说法字不可尽。文句义味亦不可尽。时舍利弗语宝女言。仁者今当广分别说四无碍智。于一切法悉成其事。大德。菩提心者名无碍句。何以故。菩提心中摄诸义故。是名义无碍智。一切法界入菩提心。是名法无碍智。实无文字而说文字。是名辞无碍智。不可说法说不断绝。是名乐说无碍智。义不可说名义无碍。一切诸法皆如幻相名法无碍。无言说业名辞无碍。于六入界无有障碍名乐说无碍。了达于义名义无碍。乐于寂静名法无碍。字不合法法不合义名辞无碍。说即是声名乐说无碍。如来正觉即菩提义名义无碍。菩提义者能生于法名法无碍。法可作句名辞无碍。说已得义名乐说无碍。法义者名义无碍。解脱者名法无碍。演说法相非有法性名辞无碍。分别法界及非法界名乐说无碍。僧即无为名义无碍。诸僧一味名法无碍。和合僧故名辞无碍。说僧功德名乐说无碍。大德。是四无碍遍一切法。时舍利弗言。世尊。是女人者发心已来为久近耶。在何佛边种诸善根。佛言舍利弗。过去无量阿僧祇劫。尔时有佛。号分别见如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。土名大净。如兜率天。与菩萨僧七万六千。一切皆是清净梵行。得不退转陀罗尼门。尔时有转轮圣王。名净德报王。千世界而得自在。后宫婇女八万四千。千子具足。其力皆等莲花力士。尔时圣王。于三万六千亿岁。种种供养佛及菩萨。所谓房舍卧具衣服饮食病瘦医药。舍利弗言。世尊不审。彼佛寿命几时。舍利弗。其佛寿命满十中劫。时转轮王。与其后宫眷属婇女及外人民九万二千亿那由他。赍持种种无量无边供养之具。往至佛所。以八千亿上妙珍宝而散佛上。头面作礼长跪合掌。口宣是言。世尊。我今所设供养之具。颇复更有殊胜供养胜我者不。时佛答言。大王。有异供养胜诸供养。如是供养于此供养。百分千分万分百千万分。不及其一。王言。世尊是何供养。愿乐欲闻唯愿说之。尔时世尊即说偈曰

  如恒河沙等世界　　满中妙宝持用施
  虽有如是无量福　　不如怜愍发菩提
  无量亿等恒沙佛　　净妙花香以供养
  如是福德犹不如　　发菩提心七步退
  如是发心即为施　　戒忍精进禅智慧
  若为怜愍发大心　　其福无量不可尽
  上色力财上族姓　　是人乃能发菩提
  主千世界至梵天　　得大自在乃能发
  若乐喜发菩提心　　如是乃能断恶有
  能为人天开正路　　能开八正邪崄径
  诸根具足不盲聋　　皆由至心发菩提
  能见十方诸世尊　　能闻天上甘露味
  若能至心发菩提　　是人能破疑憍慢
  无量智慧得自在　　能为众生说法界
  众生见之如父母　　亦如良医师友想
  能疗众生烦恼病　　教诲令趣菩提道

尔时圣王闻佛说是发菩提心所得功德。其心欢喜踊跃无量。与其眷属内外人民。悉发阿耨多罗三藐三菩提心。即于佛前而说偈言

  我今怜愍于众生　　是故发此菩提心
  若欲获得大自在　　不应于此生退转
  生死无量受苦恼　　而于自他无利益
  宁发于此受大苦　　非以不发受安乐
  若有众生发菩提　　即得人天圣王乐
  亦得寂静无漏乐　　及得无上菩提乐
  最上慧忍三昧定　　具四无量及六度
  三种净慧六神通　　四无碍智大自在
  无上十力四无畏　　及三念处及大悲
  成就具足十八法　　如是皆由发菩提
  能动十方诸世界　　亦知十方众生心
  能度无量诸众生　　皆由发于菩提心

舍利弗。说是偈时。四万夫人无量众生。皆发阿耨多罗三藐三菩提心。尔时圣王。复于万亿年中。供养彼佛。供养佛已厌世出家。既出家已思惟四句。一者实句。二者法句。三者义句。四者调句。于一亿年常思如是四句之义。舍利弗汝知。尔时转轮圣王。岂异人乎。即宝女是也。舍利弗言。世尊。何业缘故受是女身。佛言。舍利弗。一切菩萨不以女业而受身也。乃以神通智慧之力示女身耳。为欲调伏诸众生故。舍利弗。汝今实谓宝女菩萨是女身耶。莫造斯观。何以故。受女身者即是慧力神通之力。舍利弗。是女久已于无量劫中离男女身。如是身者非是过去。亦非未来现在。此身即方便身。是方便身化此世界。九万二千诸女人等。发阿耨多罗三藐三菩提心。是故示现是方便身。尔时宝女语舍利弗。大德。汝今能以女人之身说正法耶。舍利弗言。我于男身尚生厌悔。况女身乎。舍利弗。汝于男身生厌悔耶。舍利弗言。如是如是。大德。是故菩萨胜诸声闻辟支佛等。何以故。汝诸声闻所厌悔处。菩萨于中受乐不悔。声闻之人不求诸有。菩萨于中甘乐受之。声闻之人于诸功德生知足想。菩萨之人无有厌足。声闻之人厌离烦恼。菩萨之人处而不惧。舍利弗言。宝女。菩萨之人有何等力。以是力故心无厌离。宝女答言。大德。菩萨摩诃萨有八种力处之无厌。何等为八。一者慈力。心无碍故。二者悲力。为调伏故。三者实力。不诳诸佛以众生故。四者慧力。离烦恼故。五者方便力。心不悔故。六者功德力。无所畏故。七者智力。坏无明故。八者精进力。破放逸故。是名八力菩萨具足如是八力其心不悔。舍利弗言。宝女。汝今已具足八力耶。答言大德。言具足者即是颠倒。颠倒者即是二相。二相者即是有为。有为者即无所有。无所有者即是平等。大德。若平等者云何有力。云何无力。云何可说一二之数。大德。一切诸法皆如虚空。而是虚空。不可说内不可说外。不可说明不可说闇。一切诸法亦复如是。若一切法同虚空者。云何可说有力无力一二之数。大德。菩萨摩诃萨。亦有力亦无力。云何有力。云何无力。无烦恼力有智慧力。无悭吝力有惠施力。无破戒力有持戒力。无嗔恚力有忍辱力。无懈怠力有精进力。无乱意力有禅定力。无无明力有智慧力。是故菩萨远离恶法修集善法。是故菩萨无恶法力有善法力。尔时世尊赞宝女言。善哉善哉。若有善男子善女人。能如是说即是实说。宝女菩萨说是法时。五百菩萨成就忍心

大方等大集经卷第五大方等大集经卷第六

        北凉天竺三藏昙无谶于姑臧译

    宝女品第三之二

尔时宝女复白佛言。世尊。如经中说。如来具足十神力者。为即十力是世尊耶。为离十力有世尊乎。若即十力是世尊者。是名二法若是二者即是无常。若离十力有世尊者。云何如来说诸法等。世尊。若一力中具十力者。何故如来不说百力。若不说百。当知一力非十非百。尔时世尊赞宝女言。善哉善哉。如来世尊。非一非二。若非一二。云何言十。云何言百。菩萨摩诃萨远离一二。得阿耨多罗三藐三菩提。如来世尊非即十力。非离十力。能说十事。故名如来具足十力。如来虽说如是十力。而一力中具无量力。为流布故说言十力。宝女复言。善哉世尊。唯愿广说如是十力。佛言宝女。至心谛听。吾当为汝分别解说。宝女。菩萨修行菩提道时。求声闻乘及造恶业。无有是处。以是坚心。得菩提时成就初力。如来成就如是力故。于大众中作师子吼能转法轮。如是法轮。天人魔梵沙门婆罗门。所不能转。复次宝女。菩萨修行菩提道时。了知诸业悉是一业。以是力故。了知过去未来现在一切诸业业因缘处及以非处。得菩提时成第二力。复次宝女。菩萨修行菩提道时。了众生根知已说法。以是力故。得菩提时成第三力。复次宝女。菩萨修行菩提道时。观众生界。观已随界而为说法。以观界故。得菩提时成第四力。复次宝女。菩萨修行菩提道时。观诸众生上中下根。观已随解而为说法。以知解故。得菩提时成第五力。复次宝女。菩萨修行菩提道时。观至处道。若有为道。若无为道。若声闻道。若缘觉道。若菩萨道。以观道故。得菩提时成第六力。复次宝女。菩萨修行菩提道时。恭敬尊重修诸禅定。为调众生而说法要。以修集故。得菩提时成第七力。复次宝女。菩萨修行菩提道时。于过去善根不生诽谤。成就念心不作放逸。不放逸故。得菩提时成第八力。复次宝女。菩萨修行菩提道时。见未学者不生轻心。自既学已不生憍慢。能施众生智慧光明。以施明故。得菩提时成第九力。复次宝女。菩萨修行菩提道时。教诸众生远离漏法不令增长。赞叹解脱修无漏道。亦为众生说无漏道。以修无漏故。得菩提时成第十力。宝女。菩萨修集如是十力。能具如来十种之力。宝女复言。世尊。菩萨摩诃萨修行何法。得四无畏及十八法。佛告宝女。菩萨修行菩提道时。所得妙法不生贪吝。不作是念。若我教彼彼则胜我。于诸众生其心平等。能舍内外施于一切。观察法界无种种相。以是因缘。得菩提时成初无畏。复次宝女。菩萨修行菩提道时。诸遮道法了了而知。以了知故不行不随如是遮法。亦不称赞不以教人。知遮道已而远离之。以是因缘。得菩提时成二无畏。复次宝女。菩萨修行菩提道时。常修净道常说净法。修治庄严得净法故。如是庄严亦自修治亦教众生。以是因缘。得菩提时成三无畏。复次宝女。菩萨修行菩提道时。终不起于憍慢之心。终不自说我知我见。覆藏功德显露罪过。以是因缘。得菩提时成四无畏。复次宝女。菩萨修行菩提道时。失道众生示以正道。除去道路瓦石恶刺。津途崄绝施作桥梁。闇冥之处为设灯明。见犯罪者能令调伏。能除众生所有疑悔。于非犯者不强言犯。除坏众生疑法之心。施法光明劝请说法。见说法者称赞善哉。恭敬尊重不生轻心。欲解一切众生言音。不正语者心不轻之。以是因缘。得菩提时成初无失。复次宝女。菩萨修行菩提道时。实语法语。义语时语。调伏语。不错语。离诸恶语。圣人之语。若闻法已转为他说。为于自利及利他故。说时不轻。不生诤讼。信佛法僧。亦令众生信佛法僧。观诸法界不可宣说。以是因缘。得菩提时知一切语。得无量门总持方便。是故其身一切相好一一毛孔。悉出如来微妙音声。复次宝女。菩萨修行菩提道时。常修六念。亦化众生令修六念。以是因缘。得菩提时不失念心。亦得法证总持方便。无量众生于无量劫。思惟深义一时来问。如来不假思惟之力。而能一时各随问答。复次宝女。菩萨修行菩提道时。常护一切众生之心。不与众生作乱心因诸苦恼因。见诸众生行善法时。不遮不乱。善知诸法悉如幻相。于诸众生其心平等。知诸法界同于一味。以是因缘。得菩提时其心常定。得无边闻总持方便。得是持已。心常在定而作佛事。复次宝女。菩萨修行菩提道时。想不颠倒心不颠倒。以不倒故。于无我中不作我想。众生命人士夫男女。憍慢烦恼。常断有无。善恶垢净。有漏无漏。世间出世间。生死涅槃等想。一切众生有颠倒故。有如是想。若无颠倒则无是想。行于中道。以是因缘。得菩提时成就一想无有二想。修是定故。得无尽器总持方便。以是持力。心常修集无想三昧。怜愍众生修集大悲。说法不息。复次宝女。菩萨修行菩提道时。修集舍心舍于苦乐。不苦不乐。不喜不愁。不爱不嗔。以是因缘。利衰毁誉心无有二。常观无常苦无我等。亦化众生修如是舍。以是因缘。得菩提时名为大舍。得是舍已。得大海印总持方便。以是持力。虽得人天阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽释天梵天恭敬供养。不以为欣。邪见恶人轻慢骂辱。不以为戚。其心平等。如地水火风。不上不下不动不浊。修大慈悲。复次宝女。菩萨修行菩提道时。至心求菩提甚深之法种种善根。不求声闻乘。修集大悲。如是等心无有退转。以是因缘。得菩提时成如来欲。无增无减。得金刚幢总持方便。得大自在。知云何说。知说何事。知何时说。知何处说。知为何众生。复次宝女。菩萨修行菩提道时。常勤精进。于诸善法不知厌足。恭敬供养和上善友。亦常亲近乐听正法。随闻而持。如是精进为调众生。为欲供养无量诸佛。为令无量无边众生得无上道。亦令获得如是精进入于法门。以是因缘。得闻佛法总持方便。是故菩萨得菩提时。成就如是精进无减。以精进故具足神通。复次宝女。菩萨修行菩提道时。具足念心修四念处。观内外身无常苦无我。受心法念亦复如是。修空无相无愿三昧。为如来身。观身念处不证解脱。以是因缘。得菩提时成就如来念心无减。得知心通知诸众生根界。解业烦恼行习心处。善根恶根果报生灭。诸有次第。诸佛世界诸乘大众。菩萨诸行得授记莂。父母亲族师长和上。知如是等心不失念。复次宝女。菩萨修行菩提道时。常修智慧。利慧。疾慧。无边慧。甚深慧。解慧。净慧。不动慧。无碍慧。无胜慧。了知声闻缘觉乘慧。无上慧。不知足慧。具足如是等慧。求慧求法持法说法。甘乐于法。以乐法故。于内外物不生贪着。于师和上能忍众苦。以所须物奉献贡上。为于一字一句之义。能以十方世界珍宝奉施法主。一偈因缘舍于身命。虽于无量恒河沙等劫修行布施。不如一闻菩提之事心生欢喜。于正法所乐闻乐说。常为诸佛诸天所念。以念力故。世间所有经典书论悉能通达。以是因缘。得菩提时成佛智慧无增无减。如是等智名为无碍。知众生心。善不善无记。有漏无漏。世间出世间。垢法净法。生死涅槃。一切法门。一切菩提事。一切菩提道。一切世界。一切劫一切微尘去来现在。于如是事通达无碍说时无尽。以是因缘。如来能于一法之中说无量法。复次宝女。菩萨修行菩提道时。不乐在家求受五欲。乐处空闲修出家法。乐修深义及三脱门。以是修力得无碍法门无挂碍智。过魔境界庄严具足。远离烦恼及诸恶见说甚深义破众疑心。除去一切诸恶觉观。破于欲界色无色界。为贪众生演说正法令离贪心。为喜嗔者演说慈心令离嗔恚。为愚痴者说十二因缘令离无明。为悭贪者说檀波罗蜜。为破戒者说尸波罗蜜。为嗔恚者说羼提波罗蜜。为懈怠者说毗梨耶波罗蜜。为乱心者说禅波罗蜜。为无智者说般若波罗蜜。为凡夫人说四真谛。为颠倒者说无常无净无乐无我。为结缚者说三十七助菩提法。菩萨具足如是等法。以是因缘。得菩提时成就解脱无增无减。如是解脱无能动者。毕竟清净毕竟解脱。能知能见一切声闻辟支佛乘。亦得清净总持方便。以持力故能说解脱。于一切法得大自在。复次宝女。菩萨修行菩提道时。恭敬智慧得智势力。得智光明。知眷属智。知无贪心。知无嗔心。知无痴心知无爱心。知无垢心。知无诤心。知无食心。知无贪心。知无上心。知无碍心。知无记心。知善心。知不善心。知恶心。知净心。知不净心。大心小心。狭心广心。遍知心不遍知心。贪心舍心。持戒心破戒心。忍心不忍心。懈怠心精进心。定心乱心。痴心慧心。凡心圣心。正定聚心。邪定聚心。不定聚心。声闻心。缘觉心。菩萨心。苦谛心。集谛心。灭谛心。道谛心。虽知如是而不取证。为调众生常说正法。谓四真谛十二因缘。远离断见及以我见。说因缘果从缘而生。非因于我众生命等。了知无明因缘于行。行因缘识。识因缘名色。名色因缘六处。六处因缘触。触因缘受。受因缘取。取因缘爱。爱因缘有。有因缘生。生因缘老死忧悲苦聚。无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六处灭。六处灭故触灭。触灭故受灭。受灭故取灭。取灭故爱灭。爱灭故有灭。有灭故生老死忧悲苦恼灭。大苦聚灭。作是观已复作是念。如是等法。实非我作众生寿命士夫等作。非常非断。若非众生士夫等作。是名为空。如其空者即是无我众生寿命及以士夫。无常无断。若无常断无生无灭。无生灭者三世不摄。三世不摄即名为无。如其无者不可算数。无算数故即第一义。第一义者即是如来语。如来语者即无斗诤。无斗诤者名沙门法。沙门法者即是虚空。若能了知如是等法名真实知。若观思惟诸恶因缘。则生无明至大苦聚。恶思惟灭则无明灭。乃至大苦聚灭。作是观已。不着常见不着断见。知一切法从缘而生从缘而灭。知一切法无我众生寿命士夫。不见此彼及以中间。何以故。若无彼此云何有中。是故菩萨如是说法。以是因缘。得菩提时成解脱智无增无减。亦得无边总持方便。以得持故。依于法界观虚空界。说是处非处。至漏尽力四无所畏大慈大悲。宣说甚深秘密之藏。兼以是法化于众生。是名不与二乘共之。身口意等具足神通。复次宝女。菩萨修行菩提道时。一切身业随智慧行。不欺众生而作妨碍。不贪不悭无有害心。梵行清净勤修精进。集助道法不惜身命。为诸众生起大慈悲。以是因缘。得菩提时名为如来。一切身业随智慧行。得一切光总持方便。以是持力。能作种种方便之身。所谓天身。龙身。阿修罗身。迦楼罗身。乾闼婆身。紧那罗身。摩睺罗伽身。梵身。释身。四天王身。刹利身。婆罗门身。毗舍身。首陀身。比丘比丘尼。优婆塞优婆夷身。示现如是种种身已。为诸大众随意说法。说法既竟即灭不现。令一切众不知所在。或身灭已而故说法。一切众生六情瞻对而无厌足。若不见时心常缘念。复次宝女。菩萨修行菩提道时。一切口业随智慧行。不欺众生。妄语两舌。恶口无义语。常安隐语。法语毗尼语。不热语。佛语义语。喜闻语。乐见语。以是因缘。得菩提时名为如来一切口业随智慧行。获得三分总持方便。以是持力。善解一切众生语言。说诸众生所有之业。佛所出言是真实语。十二因缘语。随解脱语。不贪语。寂静语。因缘语。复次宝女。菩萨修行菩提道时。一切意业随智慧行。不欺众生。不妒不害。不作邪见修于正见。起大慈悲于诸众生其心平等。终不忘失菩提之心。具足智慧捐除憍慢。以是因缘。得菩提时。名为如来一切意业随智慧行。获得无垢总持方便。以是持力。住一心中能知一切众生诸心。观众生心悉皆平等。如幻化相本性清净。观诸众生身业平等。皆如水月。见诸众生悉在己身。己身亦在众生身中。犹如影现。能令众生悉作佛身。亦令己身作众生身。一切无有能动转者。复次宝女。菩萨修行菩提道时。信过去世诸佛智慧。善身口意业无有疑网。若闻佛事不可思议。不惊不怖。信过去佛世界众生。已得调伏。信如来身游十方界往返无碍。能解一切众生言语。随其种种而为说法。一切三世智慧无碍。了知过去一切法界一切诸乘知诸众生业果神通。知他心智于如是等心信无疑。亦化众生令同已信。以是因缘。得菩提时名为如来知过去世智慧无碍。因往修集勇健三昧。获得健行总持方便。以是持力。能知过去诸佛世尊寿命种姓。亦知过去菩萨声闻辟支佛等。一切众生业果神通。亦知过去所有诸劫。有佛出者无佛出者及其名字净以不净。若广若狭若粗若细。若微尘等若倒若顺。于如是等悉得了知。如观掌中庵摩罗果。复次宝女。菩萨修行菩提道时。信未来世诸佛智慧。善身口意业无有疑网。若闻佛事不可思议不生惊怖。信未来世界众生悉当调伏。信于如来游十方世界往返无碍。能解一切众生语言。随其种种而为说法。一切三世智慧无碍。了知未来一切法界一切诸乘。知诸众生业果神通。知他心智于如是等心信无疑。亦化众生令同已信。以是因缘。得菩提时名为如来知未来世智慧无碍。因修悲定得师子吼总持方便。以是持力。能知未来诸佛世尊寿命种姓。亦知未来菩萨声闻辟支佛等。一切众生业果神通。亦知未来所有诸劫有佛出者无佛出者。及其名字净以不净。若广若狭若粗若细。若微尘等若倒若顺。于如是等悉得了知。如观掌中庵摩罗果。复次宝女。菩萨修行菩提道时。信现在世诸佛智慧。善身口意业无有疑网。若闻佛事不可思议不惊不怖。信现在佛世界众生悉得调伏。信如来身游十方界往返无碍能解一切众生言语。随其种种而为说法。一切三世智慧无碍。了知现在一切法界一切诸乘。知诸众生业果神通。知他心智于如是事心信无疑。亦化众生令同己信。以是因缘得菩提时名为如来知现在世智慧无碍。因修净定获得金刚总持方便。以是持力能知现在诸佛世尊寿命种姓。亦知现在菩萨声闻辟支佛等。一切众生业果神通。亦知现在所有诸劫。有佛出者无佛出者。及其名字净以不净。若广若狭若粗若细。若微尘等若倒若顺。于如是等悉能了知。如观掌中庵摩罗果。宝女。是名十八不共之法。如来。复有不共之法。谓无见顶。何以故。无边身故。无能胜者。名不共法。何以故。一切事具故。见者除恼名不共法。何以故。身如药树故处众无畏。名不共法。何以故。一切清净故处众无怯。名不共法。何以故。四无畏故知众生心。名不共法。何以故。随意说法故徒众寂静。名不共法。何以故。随师教故出言清净。名不共法。何以故。不说无义语故。凡所宣说闻者欢喜。名不共法。何以故。离怨亲想故。说法之声齐众而闻。名不共法。何以故。余无利益故。各各见佛正在已前。瞻对之时目未曾眴。名不共法。何以故。身不可思议故。闻佛所说要生善芽。名不共法。何以故。成就无量诸功德故见者无厌。名不共法。何以故。觉一切法故。举身回顾如象王视。名不共法。何以故。威仪清净故大师子吼。名不共法。何以故。具足大力故威仪纯善。名不共法。何以故。所有身业随智行故口业纯善。名不共法。何以故。所有口业随智行故一切眼目。名不共法。何以故。所有意业随智行故众生乐闻。名不共法。何以故。语微妙故受上供养。名不共法。何以故。无上福田故无尽功德。名不共法。何以故。不求果报故无能坏者。名不共法。何以故。一一节中有那罗延力故记事不虚。名不共法。何以故。知诸根故为一切师。名不共法。何以故。通达一切故寿命无尽。名不共法。何以故。得法身故有亲近者得大利益。名不共法。何以故成就一切诸善法故。所得智慧无能浊者。名不共法。何以故。知三世智性清净故。出身血者得五逆罪。名不共法。何以故。成就一切诸善根故烦恼习尽。名不共法。何以故。了知一切烦恼因故知一切行。名不共法。何以故。觉一切法故。宝女。是名如来不共之法。尔时宝女复白佛言。世尊。如来所得三十二相。是何业因之所成就。佛告宝女。如来成就无量功德。是故得成三十二相。我今于是无量事中。当略说之。如来至心护持净戒。得足下平相。修行种种惠施业故。得千辐轮相。不欺一切诸众生故。得足跟佣相。护正法故。得指纤长相。不坏他众故。得网缦相。妙服奉施故。得手足软相。净饮食施故。得七处满相。喜闻佛法故。得鹿王[跳-兆+尃]相覆藏他过故。得阴藏相。修善法故。得上身如师子相。常以善法化众生故。得缺骨平满相。救护怖畏故。得臂肘佣相。见他事业乐佐助故。得手摩膝相。常修十善故。得清净身相。常施病药故。得所食之物至喉悉现相。常发庄严修善法故。得师子颊相。于诸众生其心平等故。得四十齿相。和合诤讼故。得齿密相。珍宝施故。得齿齐相。身口意净故。得二牙白相。护口四过故。得广长舌相。成就无量功德故。得味中上味相。于众生中常柔软语故。得梵音相。修集慈心故。得绀色目相。至心求于无上菩提故。得牛王睫相。赞叹他人所有功德故。得白毫相。恭敬父母师长和上故。得肉髻相。乐说深法故。得身柔软相。施敷具故得金光相。远离聚说世间事故。得一一孔一毛生相。乐受善友师长教敕故。得身毛上靡相。不以恶事加众生故。得发色金精相。常劝众生修三昧故。得身圆满如尼拘陀相。生生之处作佛像故。得那罗延力相。宝女。菩萨摩诃萨成就如是无量功德。获得如是三十二相。宝女复言。世尊。菩萨摩诃萨不可思议。快哉如来。善说佛法。尔时世尊赞宝女言。善哉善哉。如汝所说。一切众生闻是义者。即得具足无量功德。闻已信者。亦得成就无量功德。说是法时。十方无量无边世界六种震动。无量众生发菩提心。五千菩萨得无生忍。虚空诸天雨种种花。鼓众伎乐以供养佛。若有众生已于无量无边佛所殖众德本。乃得闻是如来十力四无所畏不共之法三十二相。是人闻已能生深信。信已能于大众之中作师子吼说如是法。何以故。下劣之人不能得闻如是正法。假使得闻未必得信。上人持戒智慧具足乃能得闻。闻已敬信。信已不久当得阿耨多罗三藐三菩提。宝女复言。世尊。佛不可思议。法僧亦尔不可思议。闻信是经亦不可思议。若有信者是人定得阿耨多罗三藐三菩提。世尊。云何菩萨修行法行。宝女。菩萨摩诃萨不舍亲旧。知恩报恩怜愍一切。有归依者终不舍弃。至心念于菩提之道。修于忍辱。难施能施摄取众生慈心护戒。思惟善义护持正法。乐法念法持法乐静。独处空闲心无悔退。善护众生净身口意。为四无量发大庄严。常劝众生于菩提道。凡所讲论先赞大乘。不先许人后生悔心。清净其行知足少欲。不悭不妒不断圣种。心无诤讼了知因果。信闻戒施惭愧智慧。亲近善友随师长教。心无憍慢。恭敬礼拜长老有德。离贪恚痴我及我所。常念佛法僧施戒天。得供养时其心不高。常勤修行六波罗蜜空无相愿诸善方便。不见我常众生寿命士夫之相。修四念处乃至八正道分。是名菩萨修行法行。又法行者无眼无色无色想行。无耳无声无声想行。无鼻无香无香想行。无舌无味无味想行。无身无触无触想行。无意无法无法想行。非色行。非色非非色行。非色苦行。非色非非色苦行。非色我行。非色非非色我行。非色空行。非色非非色空行。非色无相行。非色无愿行。非色无行行。非色性行。非色实行。非色寂行。非色生行。非色出行。非色因缘行。非色聚行。是名法行。受想行识亦复如是。宝女。若无如是阴入界行。是名法行。无欲界行色界行无色界行。无住无脱。是名法行。无去无来无有住处。无心意识无见无闻无知无识。无有身业口业意业。非法非非法。非一非二。非去来现在。非垢非净非聚非散。非我众生寿命士夫。非常非断。非我非我所。非始非终。是名法行。是名我法。是名住处。是名法性。是名法处。是名空处非处。名毕竟处。不动不住无有相貌。无出无灭无所修行。无取无舍无受无施。若能知见如是等法。是名真知。是名实知。是名法知。若有菩萨能作是学。为诸众生行于生死。而于涅槃无所动转。是名菩萨真实法行。说是法时八千菩萨成就忍辱。尔时宝女复以种种珍宝杂物。供养于佛而作是言。世尊。若有菩萨行是法行。即是修行一切佛行。即得授记坐菩提树。成就阿耨多罗三藐三菩提。尔时舍利弗语宝女言。汝知菩萨不退印耶。尔时宝女即说偈言

  诸众生界及法界　　若能平等观无异
  不生分别一一数　　是名菩萨不退印
  过去未来及现在　　十方世界诸世尊
  皆悉平等观法界　　是名菩萨不退印
  观有为界皆无常　　有漏无漏亦如是
  知一切法本性净　　是名菩萨不退印
  观于生死无有量　　不可称计知其数
  若能一念通达知　　是名菩萨不退印
  一切世间诸法界　　及以出世诸圣法
  若知平等悉真实　　是名菩萨不退印
  若能了知诸佛界　　及以诸魔波旬界
  通达是二无差别　　是名菩萨不退印
  贪欲嗔恚愚痴等　　一切众生诸烦恼
  知从颠倒因缘生　　是名菩萨不退印
  生死之法及涅槃　　无上正道及菩提
  观察是法无差别　　是名菩萨不退印
  知是五阴如菩提　　如菩提性入界然
  观是诸法无有二　　是名菩萨不退印
  地水火风及造色　　观之犹如虚空等
  如是即得真实印　　亦如十方诸佛印
  如眼界等菩提然　　是二平等无差别
  自能受持为他说　　是名菩萨不退印
  知诸众生所有心　　能为一切心因缘
  如是因缘无障碍　　是名菩萨不退印
  能遍观察诸众生　　所有诸根上中下
  能观生死尽彼岸　　是名菩萨不退印
  所有字义句无尽　　于无量劫而演说
  无能破坏作障碍　　是名菩萨不退印
  虚空边际尚可尽　　世间猛风可系缚
  菩萨所有不退心　　一切世间不能转
  成就无量陀罗尼　　于诸法中不失念
  次第演说诸法义　　如佛口出无有异
  十方世界佛世尊　　为度众生说无量
  悉能受持解深义　　是名菩萨不退印
  无量劫中所闻法　　犹如现闻而演说
  无量世学陀罗尼　　获得如是无尽印
  成就具足如是持　　及以无上真知慧
  若得菩萨不退印　　则能宣说如是法
  若观一切诸法空　　亦不亲近不远离
  若有成就不退心　　当知是人有空印
  一切诸法虚空印　　其性本来无生灭
  若能了知是法界　　是名菩萨不退印
  诸法皆从因缘有　　离于众缘无法界
  若能了知如是者　　当知是有不退印
  所有威仪诸色声　　能空一念悉示现
  为欲教化诸众生　　即是菩萨不退印
  惠施之心如虚空　　无量劫中不可尽
  成就无量诸功德　　即是菩萨不退印
  修集净戒为佛戒　　获得佛戒如虚空
  成就如是无上戒　　即是菩萨不退印
  一切众生所有戒　　及以学戒无学戒
  虽有如是无量戒　　不及不退十六一
  若得最上无生忍　　成就无量无有边
  若得如是无生忍　　如过去佛之所得
  为众生故善庄严　　无量世中不休息
  常勤修集精进行　　即是菩萨不退印
  常乐修集诸禅定　　亦为众生宣说法
  虽复示现诸威仪　　而其内心不离定
  具足无上正知见　　远离一切烦恼习
  若有成就不退心　　则能近于佛境界
  具足三种之神通　　及其如来善方便
  若有成就不退心　　是人欲得正觉印
  一切众生不能知　　是人心行及境界
  为诸众生无量行　　即是菩萨不退印
  其实未得无上道　　而能示现如来身
  生及成道转法轮　　处众示现大涅槃
  未舍菩萨不退印　　亦能获得如来印
  犹如虚空无有边　　所得佛印亦如是

说是偈时。三千大千佛之世界六种震动。五千菩萨得不退印。尔时世尊赞宝女言。善哉善哉。快说菩萨不退转印

尔时须菩提白佛言。世尊。宝女定得不退转印。是故能作如是宣说。若不证者何能如是。佛告须菩提。如是如是如汝所说。宝女久已得不退印。忍辱成就已尽大乘甚深边底。尔时宝女白佛言。世尊。何故名大乘。佛言。其乘广大故名大乘。于诸众生无挂碍故故名大乘。是一切智善根根本故名大乘。无有烦恼诸结黑闇故名大乘。所有光明无处不遍故名大乘。周遍其边有眼目故故名大乘。本性常净初无沾污故名大乘。断诸烦恼一切习气故名大乘。护持禁戒故名清净。修集定故名为安住。修智慧故名为无漏。修解脱故名无系缚。示一切法等无二故名解脱智。摄十力故名无能动。具四无畏故名无怖惧。摄取十八不共法故名为无碍。修集大慈故名平等。破坏一切诸魔众故名为最胜。摧烦恼魔故名寂静。坏阴魔故名不可数。破死魔故名为常住。具足檀那波罗蜜故名为富足。具足尸罗波罗蜜故名为无热。具足羼提波罗蜜故名为无怨。具足精进波罗蜜故名为无动。具足禅那波罗蜜故名无漏无转。具足般若波罗蜜故名胜一切世间出世间。具足方便波罗蜜故名为摄取。一切诸乘断诸有故名无有。有因八道得故名为安。具定慧翼所往无碍调诸根故名大神通。修正勤故能见一切诸佛世界修念处故远离恶法。亲近善法。修七觉分远离一切诸烦恼结。无为无漏无胜无上。无能见顶无能知者无有遮障。无有听闻无入出处。大众大堂一味不作。不作数量平等无二。得大名称十方无碍。一切人天之所恭敬。成就无量无边功德。永断一切悭吝破戒害心懈怠乱心无明。能令众生获得多闻。为作安乐断一切苦。能令作善业。佛智无碍智。无上智平等智。一切智。是名大乘。说是法时。万二千众生发阿耨多罗三藐三菩提心。既发心已复作是言。若有众生能发如是大乘心者。即得无量善法利益。尔时宝女白佛言。世尊。何障碍故。不令众生疾得大乘。佛告宝女。有三十二事。以是因缘为作障碍。何等三十二。一者乐声闻乘。二者乐缘觉乘。三者乐释身故。四者乐梵身故。五者乐为世乐受持禁戒。六者乐修一善。七者常怀嫉妒。八者多财贪着悭吝。九者不乐劝化众生令修善法。十者心憍慢故。十一者不求菩提心故。十二者畏菩提心故。十三者于一法中生着心故。十四者不善思惟故。十五者不能亲近师长和上善知识故。十六者诽谤余部故。十七者不能净于身口意业故。十八者不能护持无上法故。十九者得少法味吝不说故。二十者少解法义生大慢故。二十一者远离四摄故。二十二者不能恭敬同师同学故。二十三者不乐念于六波罗蜜故。二十四者远离三聚故。二十五者不发愿故。二十六者少善根故。二十七者倒解义故。二十八者不叹三宝故。二十九者诽谤大乘菩提事故。三十者自不解义诽他说故。三十一者不觉了知诸魔事故。三十二者乐生死故。是名三十二事障碍大乘不令众生疾得大乘。宝女。如是障碍其事无量。我于今者但略说耳。大乘所有功德无量。障碍之事亦复如是。亦如涅槃功德无量。障碍之事亦复无量。如生死过无量无边。即是大乘之障碍也。宝女。若有人能远离如是无量恶法。当知是人即得大乘。宝女。若有菩萨能得净心。是人即能获得大乘。世尊。众生云何速得成就无上大乘。宝女。有三十二事。众生修集能速得之。何等三十二。一者众生不请而往亲附。二者见他福德不生妒心。三者至心修集无量善根。四者营他事业不生愁恼。五者至心不浊身口业净。六者不为利养改四威仪。七者如说而住。八者于诸众生其心清净。九者终不放舍菩提之心。十者清净庄严檀波罗蜜。十一者清净尸波罗蜜。怜愍毁禁故。十二者净忍波罗蜜。不惜身命故。十三者净精进波罗蜜。得十力无畏故。十四者净禅波罗蜜。远离烦恼故。十五者净般若波罗蜜。除烦恼习故。十六者修勇健定。坏诸魔业故。十七者至心度脱诸众生故。十八者修四摄故。十九者心平等故。二十者不舍一切诸众生故。二十一者知恩报故。二十二者护持正法故。二十三者修助道法不休息故。二十四者于诸善法无厌足故。二十五者破憍慢故。二十六者供养三宝故。二十七者于一切法不生诤故。二十八者善解十二深因缘故。二十九者具七财故。三十者于一切法得自在故。三十一者修六神通故。三十二者修集定慧故。是名三十二众生修集疾得菩提。说是法时。七万二千众生发阿耨多罗三藐三菩提心。万二千菩萨得无生法忍。一切诸天以诸花香种种伎乐。供养于佛尊重赞叹。作如是言。若有得闻如是等经。当知是人定得阿耨多罗三藐三菩提。尔时梵天释天四天王天白佛言。世尊。如来今者演说如是无限量义了了之义。坏烦恼义。摧诸魔业。破诸邪见。能持一切无上正法。我等亦能受持读诵书写解说。若佛弟子有能受持读诵书写广说之者。我等亦当为作卫护。若有恶鬼欲为是人作娆害事。我当遮止不令成就。佛言。善哉善哉。善男子。汝于尔时。若能护我诸弟子者。即是护持我之正法。如是护者法则久住。尔时世尊告阿难言。阿难。汝当受持拥护演说如是经典。若有菩萨于无量劫乐修惠施。复有菩萨受持是经。读诵书写为人广说。修大慈悲兼以此义劝人令学。其人所得福多于彼。亦能速疾获得大乘。阿难白佛言。世尊。是经何名。云何奉持。佛言阿难。是经名为真实法义毗尼方便。成就发心无量宝聚。无量陀罗尼十力四无畏不共法聚。菩萨摩诃萨不退转印广说大乘宝女所问。如是等名汝当奉持。尔时阿难及诸人天闻经欢喜。信受奉行

大方等大集经卷第六大方等大集经卷第七

        北凉天竺三藏昙无谶于姑藏译

    不眴菩萨品第四

尔时世尊。故存欲色二界中间大宝坊中。与诸大众围绕说法。尔时众中有金色光。其光明净遍照三千大千世界。悉蔽一切日月四天释梵光明。照已即灭。一切大众瞻睹如来目未曾眴。当尔之时寂然无声亦无声欬。出入气息。尔时大德须菩提白佛言。世尊。今何因缘有是光明。一切大众瞻睹如来目未曾眴。尔时佛告须菩提言。东方过于无量世界。彼有菩萨名曰不眴。与万菩萨俱共发来。欲听如来微妙方等大集经典。是其光明所言未讫。不眴菩萨已至佛所。大宝坊中赍持种种香花伎乐供养于佛。头面礼足恭敬右绕。却坐一面宝莲华上。尔时须菩提。复白佛言。世尊。不眴菩萨。所来世界去此远近。国土何名佛号何等。佛言。须菩提。东方去此七万二千恒河沙等诸佛世界。土名不眴。佛号普贤如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。不眴菩萨从彼而来。尔时不眴菩萨摩诃萨长跪合掌。说偈赞佛

  如来世尊众宝聚　　具足一切波罗蜜
  无上法师天中天　　为众生故我敬礼
  寂静戒定不可动　　无上智慧调诸根
  为诸众生说大集　　故我归依师子王
  乐施天人诸安乐　　众生喜见如满月
  具足力势破魔众　　我今归依大药树
  成就善根施甘露　　能度众生生死海
  我今归依无上尊　　具足妙相三十二
  世尊庄严此大众　　犹如须弥显四域
  名称无碍遍十方　　人中象王我敬礼
  如来智慧如虚空　　通达三世无障碍
  随众生根而说法　　我今敬礼自在王
  过无量劫勤精进　　超胜同业诸菩萨
  所得佛法如先佛　　我今敬礼一切觉
  十方诸佛悉赞叹　　精进殊胜无边量
  无量众生得闻已　　悉皆同发菩提心
  于正法中无厌足　　兼以劝化诸众生
  能说清净法之性　　我今稽首大法王

尔时不眴菩萨偈赞佛已白佛言。世尊。我等于此大集经中欲少发问。唯愿如来垂哀听许。佛言。善哉善哉。善男子。随意发问。吾当为汝分别宣说。除却汝等疑网之心。不眴菩萨既蒙听许。心大欢喜白佛言。世尊。菩萨摩诃萨修何三昧速得成就阿耨多罗三藐三菩提。得大念心大智大意。惭愧勇健修施教戒。被忍辱铠建精进幢。游戏神通庄严慈悲。深乐法喜登陟舍山。能说能答摧伏魔怨。坏诸邪见不离诸佛。菩萨善友常得化身。不失念心深信大乘。乐施众生无上智光。不为世法之所染污同于四大。如地利益一切众生。如水能洗一切垢秽。如火能熟众生善根。如风能于戒闻慧等无所障碍。修集慈悲犹如虚空。慧眼无量犹如帝释。心得自在如自在天。正法化世如转轮王。聚大福德如须弥山。于善无厌聚众珍宝犹如大海。思惟十二因缘深义亦复如是。无所畏惧如师子王。具善法财犹如商主。一切依止如大医王。能作光明犹如庭燎。破闇如日清凉如月。烦恼不污犹如莲华。具足一切诸佛妙法犹如满月。佛言。善哉善哉。善男子。能以此义咨启如来。至心谛听。吾当为汝分别解说。善男子。有三昧名一切法自在。菩萨修集是三昧者。则能获得如是等事。亦得无量无边福德。疾成阿耨多罗三藐三菩提。成佛之时世界所有一切具足。善男子。一切法自在三昧者。所谓信佛法僧。苦集灭道。阴入界等空无相愿。出生灭没十二因缘。内外因果业及果报信于开塞观一切法如幻如化如焰如响。如水中月龟毛兔角。空中之花石女之子。如着影衣梦乘白象。若有若无及以有无。非有非无非常非断。非生非灭非内非外。非见非断信如是等。则能信佛菩萨大事而不自轻。菩萨事业虽复广大。我亦能知心得自在。能大惠施护持禁戒。不妨外事怜愍众生常修忍辱。为不退故勤行精进。为令众生离烦恼故修集智慧。为坏一切分别想故修集三昧。得妙音声一切乐闻。修于念佛观诸如来平等无二。修于念法观一切法同一性相。修于念僧观一切僧无有退转。修于念舍舍诸烦恼。修于念戒常念佛戒。修于念天念后边身。净身口意不随他人。戒定智慧清净施已。能得具足三十二相。施种种物具足成就八十种好。为欲庄严出世智慧具四念处。为欲远离一切烦恼故具四正勤。为令其心得自在故具四如意。为欲坏破诸魔怨故修集信根。为不颠倒一切法故修精进根。劝令忆念诸罪过故修集念根。为诸众生心清净故修集定根。为于一切诸法顶故修集慧根。为无坏故修集五力。为真实知一切法故修七觉分。为真实知道非道故修八正道。乐于寂静少欲知足远离恶友。虽复通达一切事业。终不于中生独师想。于诸烦恼心不贪着。不嗔众生不疑诸见。于我我所心不生着。常修欲度众生之心。于师和上父母善友生念恩心。常思报答往昔之恩。见毁禁者不生讥刺。舍弃重担真观阴故。不竞不诤护法持戒。摄取持戒及护法者。听法念法供养于法。于正法中心无疑网。凡所演说不为饮食。至心演说说时不轻。亦不自高。为出善芽所闻不失。瞻病所须供给走使。供养法师不说其短。不观种姓戒与非戒。常乐闻法至心不忘。不失时节常请法师。敷扬道化。有所讲说不生憍慢。闻已解义亦不自大。不观他人所有过失。所可听法为知足故。为不断绝三宝种故。为得无碍宿命智故。为得真实见法性故。为发无上菩提心故。为护如来真实法故。为得上族好种姓故。为见佛法比丘僧故。为得坚固不退心故。为行圣行入圣数故。为得无尽大财宝故。为得无边大功德故。为得清净梵音声故。为得具足佛功德故。为得具足菩萨法故。为欲受持读诵书写菩萨法藏及摩夷故。为欲受持如是等法广宣说故。善男子。菩萨摩诃萨获得一切法自在三昧者。于一切事无能教者。尔时世尊即说颂曰

  其心敬信佛法僧　　亦复明信四真谛
  若得智慧无挂碍　　是名诸法自在定
  能知于苦第一谛　　亦能远离于集因
  证获第三真灭谛　　修集无上圣道谛
  具足成就大念心　　真实观阴如虚空
  其身威仪大寂静　　是名诸法自在定
  能观六入性相空　　亦能调柔于诸根
  能坏众生疑网心　　是名诸法自在定
  能修集空无相愿　　破坏一切诸憍慢
  所行诸行无黑闇　　是名诸法自在定
  远离断见及我见　　令身口意业寂静
  其心不著有无法　　是名诸法自在定
  所说正义无颠倒　　调伏一切众生心
  既说法已无憍慢　　是名诸法自在定
  修集一切诸善根　　不为烦恼之所污
  其心无热亦无浊　　是名诸法自在定
  不为他喜求菩提　　亦不虚诳修善法
  十方诸佛观其心　　是名诸法自在定
  常乐惠施护持戒　　怜愍心故忍诸恶
  精进修定及智慧　　是名诸法自在定
  为诸众生修慈心　　亦无分别怨亲想
  乐施众生无上乐　　是名诸法自在定
  调伏众生于菩提　　修舍离欲得安乐
  常乐修集五神通　　是名诸法自在定
  所说正法众乐闻　　其义难尽如大海
  真实了知于法性　　是名诸法自在定
  观察佛身如诸法　　佛性法性无差别
  护法之心无退转　　是名诸法自在定
  身口意业得寂静　　具足戒定心无为
  远离一切烦恼习　　是名诸法自在定
  能证无上真解脱　　亦能获得实知见
  修集定慧无有边　　是名诸法自在定
  不净之物不以施　　不受一切不净戒
  三十二相具足成　　是名诸法自在定
  修行种种诸惠施　　是故获得八十好
  于佛法中得自在　　是名诸法自在定
  修集具足四念处　　正勤能坏诸烦恼
  为调众生修如意　　是名诸法自在定
  为入佛法修信根　　为坏魔众修五力
  为知诸法修七觉　　是名诸法自在定
  修八正道破邪径　　施于众生无上乐
  心无憍慢一师想　　是名诸法自在定
  若得修集自在定　　是人则能离烦恼
  亲近诸佛菩萨等　　乐修少欲知足行
  为在无上圣人数　　以众生故修大悲
  不为饮食演说法　　是名诸法自在定
  为法不惜于身命　　护持正法不吝财
  常乐修行二种施　　是名诸法自在定
  常劝众生令听法　　如其未解心不轻
  不为胜他护持戒　　是名诸法自在定
  无量世中所闻法　　至心受持为他说
  无上法师大名称　　不观时节戒非戒
  演说不休亦不息　　不失时节随意说
  所说诸法如幻相　　是名诸法自在定
  所言真实甘乐闻　　闻已如说而安住
  其心无贪无嫉妒　　是名诸法自在定
  有问无嗔无轻慢　　常修怜愍无二相
  能自净除诸过失　　是名诸法自在定
  具足七种无上财　　成就寿命无上命
  具足十力四无畏　　是名诸法自在定
  常乐闻法善思惟　　善思惟已如法住
  如法住已为众说　　是名诸法自在定
  不忘菩提上种性　　供养三宝得化身
  劝化大众具菩提　　是名诸法自在定
  其目清净见诸佛　　得梵音声无上边
  其音遍满十方界　　是名诸法自在定
  财宝惠施无有尽　　智慧演说无穷竭
  供养父母师和上　　是名诸法自在定
  成就具足宿命智　　不失无上菩提心
  六波罗蜜无厌足　　是名诸法自在定
  为欲利益众生故　　受菩萨藏及摩夷
  乐为众生广分别　　是名诸法自在定
  远离一切恶思惟　　了了睹见十方界
  一心能知无量心　　是名诸法自在定
  一心了知三世事　　修集无量诸神通
  得后边身智无碍　　是名诸法自在定
  怜愍众生修大悲　　观察诸根随意说
  一切佛法得自在　　是名诸法自在定
  若有得闻如是事　　至心受持生信顺
  即能获得无上道　　亦如往世诸世尊

尔时不眴菩萨白佛言。世尊。菩萨摩诃萨成就何法获得如是一切诸法自在三昧。佛言。善男子。菩萨摩诃萨具足一法则能获得如是三昧。所谓不着一切诸法。复有一法不着于戒。何以故。若不着戒则能不着一切善法。具足戒故则能成就一切佛法。得大利益无上大道。是故我言。戒是一切善法根本。戒名大灯。若着戒者是人则于菩提障碍非菩提道。若于诸法生贪著者。去菩提道则为大远。若不贪着则为邻近。复有二法。菩萨具足则能获得如是三昧。一者为于菩提方便。修集舍摩他。二者为于善法方便。修集毗婆舍那。复有三法。菩萨具足得是三昧。何等为三。一者不舍众生修空三昧。二者不舍于法修无相三昧。三者求于诸有修无愿三昧。尔时世尊即说颂曰

  调伏众生修集空　　护持法故修无相
  不舍诸有修无愿　　是人则得是三昧

复次善男子。复有四法。菩萨具足则能获得如是三昧。何等为四。一者具足四谛方便。二者具足四无量心。三者具足四无碍智。四者具足四摄之法。复有五法。菩萨具足得是三昧。何等为五。一者具足五神通。二者具足五根。三者具足五力。四者具足真智观于五阴。五者具足五眼。复有六法。菩萨具足得是三昧。何等为六。一者具足六波罗蜜。二者具足六念。三者具足智慧观于六入。四者具足远离六道。五者具足六通。六者具足六和敬法。复有七法。菩萨具足得是三昧。何等为七。一者无贪远离烦恼。二者于众生所无有嗔恚。三者于诸法中无有疑心。四者具无碍智无有五盖。五者观十二因缘无有疑网。六者成就无上智慧。七者成就无上三昧。复有八法。菩萨具足得是三昧。何等为八。一者修集八正道分。二者离八邪道。三者远离八难。四者具足八大人觉。五者具八解脱。六者具八胜处。七者专念菩提。八者断烦恼习。复有九法。菩萨具足得是三昧。何等为九。一者不失念心。二者解甚深义。三者破坏魔业。四者具佛三昧。五者净身口意。六者具足方便。七者威仪纯善。八者勤行精进具六波罗蜜。九者远离声闻辟支佛道。复有十法。菩萨具足得是三昧。何等为十。一者具足佛智。二者具足法界无分别智。三者于真实性无有动转。四者具足三世平等智慧。五者具足众生心平等智。六者具知诸根上中下智。七者具足四无碍智。八者具足三解脱门。九者具足诸法同一味智。十者具足诸法无生灭智。说是法时。三万二千菩萨摩诃萨得是三昧。尔时须菩提语不眴菩萨言。是大众中三万二千诸菩萨等。皆悉获得如是三昧。善男子。汝今得耶。不眴菩萨言。大德。乃至无有一法可得名为三昧。我云何得。凡言得者即是颠倒。夫颠倒者即我我所。菩萨若着我我所者。则不能得如是三昧。须菩提言。菩萨摩诃萨住于何处得是三昧。不眴菩萨言。如须菩提所住之法得解脱者。我如是住得是三昧。须菩提言。我实不住一切法中而得解脱。大德。菩萨摩诃萨亦复如是。不住诸法得是三昧。须菩提言。善男子。菩萨摩诃萨将不住于空无相愿得三昧耶。不眴菩萨言。空无相愿可得住耶。不也善男子。大德。是故空无相愿所住之处。得是三昧。善男子。如是三昧住在何处。不眴菩萨言。如一切法真实性住。住是三昧者亦如是。住一切诸法真实性者名圣解脱。圣解脱者名无所住。无住之住住一切法。一切诸法不住烦恼不住解脱。大德。得解脱者。为具烦恼不具烦恼。善男子。我亦不具非不具也。大德。若仁不具非不具者为何所得言解脱也。须菩提言。善男子。若使法界有缚系者。我则解脱。而法界性无缚解相。非相非非相。非种种相。非一相非多相。如法界相解脱亦尔。时须菩提说是法时。八千比丘得阿罗汉果。须菩提语不眴菩萨言。善男子。如佛所说。若能具足如是等法得是三昧。汝今具足是三昧不。不眴菩萨言。大德。一切诸法无有根住。若法无根即是无住。夫无住者名为无作。若无作者云何可住。须菩提言。若无住者何故如来常作是言。住如是法得无生忍。不眴菩萨言。大德。无所住者亦名为住。是故如来亦说住贪而得解脱。而智慧性不能坏贪住于解脱。若有菩萨能知如是不住之住。是名无生智慧。住是无生智慧中已。则能获得无生法忍。复次大德。若有菩萨不离凡夫能知圣法。以凡夫心观察圣法。以圣法性观察于忍。忍性观忍。复以是忍观一切法。知如是等名无生忍

复次大德。若有菩萨观二种界。一众生界。二者法界。以法界性观众生性。以众生性观法界性。若离法界无众生界。法界众生界无生无灭。若能如是通达知者名无生智。无生智者即无生忍。复次大德。菩萨摩诃萨知从十二因缘生法。从六境界作六因缘。若善不善。是善不善即无生灭。何以故。境界之性不能生法。六入亦尔不能生法。何以故。无生性故。如其六入能生法者。则应常生不须外缘。若外境界性能生者。亦应常生不假于内。若俱生者则有二相。二相之法性无真实。通达了知如是等者名无生忍。若得如是真智慧者。是名菩萨得无生忍。复次大德。若有菩萨具足成就二种庄严功德智慧。观是二事平等无二。虽如是知不言我知。亦于此知不生贪着。是名无生忍。复次大德。菩萨摩诃萨身意寂静观法寂静。法寂静已观菩提静。菩提静已观忍寂静。亦不随他不着内外。是名菩萨无生法忍。说是法时不眴菩萨等五百菩萨得无生法忍。尔时世尊赞不眴菩萨言。善哉善哉。善男子。汝所演说无生法忍。即是真实如先佛说。复次善男子。菩萨若得心自在者。即得诸法自在三昧。云何名为心自在耶。善男子。若有菩萨远离贪爱。得帝释身或转轮王身。虽为无量诸众生等说五欲乐。而其内心实不贪着。是名菩萨心得自在。复次善男子。若有菩萨修集三昧。四无量心求诸有时。不以有心以智慧心。虽生欲界不因欲心。其心常不远离三宝。修集庄严诸波罗蜜。以四摄法摄取众生调伏众生。修三十七助道之法。是名菩萨心得自在。复次善男子。若有菩萨修空无相愿。自不证于空无相愿。亦为众生说如是法。为调声闻辟支佛等。入于无生正定之聚而为说法。彼既闻已即得解脱自不证之。亦令众生不舍菩提。是名菩萨心得自在。复次善男子。若有菩萨。为调声闻辟支佛故。入无生灭正定之聚。亦得灭定。又能通达一切三昧出入相行。虽得如是通达自在。亦不证于灭尽三昧。何以故。未具佛法故。是名菩萨心得自在。复次善男子。若有菩萨以平等智观于法界。种种世间种种众生种种说法种种方便。是名菩萨心得自在。复次善男子。若有菩萨生长寿天未尽天寿。其身亦生短命之中。为欲调伏诸众生故。是名菩萨心得自在。复次善男子。若有菩萨具足快乐。舍是乐已为诸众生受大苦恼。护众生故护菩提故。是名菩萨心得自在。复次善男子。若有菩萨同于声闻辟支佛行。而心护念菩提之道。亦修菩提微妙之行。为诸声闻缘觉之人。随意说法而亦不证。是名菩萨心得自在。复次善男子。若有菩萨解八万四千法门。亦复通达烦恼行处。为断众生诸烦恼故。处中说法。亦不为诸烦恼所污。是名菩萨心得自在。复次善男子。若有菩萨具足神通。若有众生盲聋跛躄。菩萨摩诃萨自变其身。亦同其像而为说法。是名菩萨心得自在复次善男子。若有菩萨具足智慧。通达外典善解邪论。而其内心不为邪见。为欲调伏诸众生故修集其道。是名菩萨心得自在。善男子。菩萨具足如是等事。名心自在。亦名得一切法自在三昧。须菩提言。世尊。不眴菩萨得是三昧。为久近耶。佛言。过去无量阿僧祇劫。尔时有佛号自在王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名净劫亦名净。其佛国土地平如掌。金银琉璃颇梨庄严。常有幡盖。如兜率天多饶饮食。尔时众生所有贪欲嗔恚愚痴无有势力。多有利智能解佛语。一切悉乐无上大乘。尔时世尊与八万四千大菩萨众。三万二千声闻大众。尔时世有转轮圣王。名曰广持号曰法士。成就七宝轮宝象宝马宝女宝珠宝兵宝主藏之臣。千子具足王四天下。治以正法不加刀杖。怜愍众生教以十善。一切众生亦乐受之。尔时千子悉发阿耨多罗三藐三菩提心。尔时圣王供养如来菩萨声闻一切大众。衣服饮食卧具汤药房舍资生。经万岁已发阿耨多罗三藐三菩提心。为无上道修三十七助道之法。尔时彼佛寿命满足八万四千岁。王有一子名曰法语。于彼佛法信心出家。勤行精进清净持戒。为得无上菩提道故。尔时法语比丘。二万年中无有睡眠。如弹指顷不生贪心嗔心痴心不善觉观。不念父母宗亲眷属饮食衣服房舍卧具资生之物。亦不觉知昼夜之相。二万年中常修念佛。须菩提。法语比丘勤精进故。获得四禅四无量心四无色定。过二万年已往诣佛所。头面礼敬右绕三匝。却住一面白佛言。世尊。我发阿耨多罗三藐三菩提心。为施一切众生安乐。为欲调伏一切众生。唯愿世尊哀愍示导。云何令我化诸众生宣说正法。佛言比丘。有八陀罗尼门。若成就者得无碍语。则能为诸众生说法。何等为八。一者念佛知法身故。二者念法知净法故。三者念僧知无碍故。四者真实思惟破恶觉观故。五者知字不可说故。六者修舍摩他。为知诸法同一昧故。七者修毗婆舍那。为知诸法本性净故。八者修方便智。为得忍故。比丘。具如是八陀罗尼门。则能堪任宣说正法化诸众生。比丘。复有八精进。菩萨具者能宣说法化诸众生。一者求法勤行精进。二者持法勤行精进。三者观法勤行精进。四者说法勤行精进。五者护法勤行精进。六者供养法师勤行精进。七者护受法者勤行精进。八者如法而住勤行精进。是名为八。复有八法。菩萨具足能化众生。何等为八。一者修慈等观众生故。二者修悲调伏众生故。三者观法得无上法故。四者观智破憍慢故。五者护诸众生施安乐故。六者善思惟坏诸烦恼故。七者修助道法庄严菩提故。八者护法具足六度故。须菩提。菩萨摩诃萨若能具足如是等法。则能教化一切众生。尔时比丘闻是法已。于十千年系心思惟。勤行精进为得是法。以精进故即得无尽器陀罗尼。善解一切众生语言随语为说。得是持已复有无尽辩才。成就如是陀罗尼已。周遍城国村邑聚落。化无量众于三乘道。为其父母兄弟眷属宗族说法。悉令获得随顺法忍。须菩提。尔时比丘复往佛所。头面敬礼右绕三匝。却住一面白佛言。世尊。如佛先说我已证得。佛神力故得圣智慧。世尊。颇有三昧菩萨修已心不退转增长善法。佛言比丘。有三昧名一切法自在。菩萨修已其心不退。亦得增长无量善法。尔时比丘闻三昧名。即白佛言。世尊。菩萨云何行。云何修。云何学。而能获得如是三昧。比丘。有八法八庄严八发心。菩萨具已得是三昧。何等为八。一者净心。二者至心。三者施心。四者离烦恼心。五者观六界。六者修忍。七者勤精进。八者修定身心寂静。是名八法。八庄严者。一者舍。二者戒。三者功德。四者智。五者舍摩他。六者毗婆舍那。七者发菩提心。八者庄严一切佛法。是名八庄严。八发心者。一者发心无有众生寿命士夫。一切诸法亦复如是。二者发心一切诸法无常苦无我。三者发心一切诸法空无相愿。四者发心未来之法无有住处。五者发心现在之法无有住处。六者发心一切诸法无业果报。七者发心一切诸法无有作者。无有受者。八者发心一切诸法无有系属。菩萨具足如是等法得是三昧。比丘闻已进修不久。即得如是一切法自在三昧得三昧已即放光明。遍照三千大千世界。尔时比丘即往佛所。头面作礼右绕三匝。上升虚空一多罗树。结加趺坐满一千年。不动不摇法喜为食。获得比智乐说无碍。令三万六千亿众生得不退心。无量众生安住三乘。尔时法语比丘。过千年已从座而起作如是言。如来世尊。勤精进故得阿耨多罗三藐三菩提。非懈怠也。善男子。汝于无量无边世中。成就无量无边功德。故能速得如是神通。善男子。汝已于往七万六千亿佛所。种诸善根净修梵行。是故因此过去善根。获得如是现在善果。佛告须菩提。汝知尔时法语比丘得三昧者。岂异人乎。即是今之不眴菩萨。成就如是无量功德。尔时世尊为须菩提。说是菩萨往因缘时。三万二千众生发阿耨多罗三藐三菩提心。虚空之中诸天龙神乾闼婆等。雨诸华香以用供养不眴菩萨。而作是言。我等今日见此菩萨得大利益。尔时须菩提语不眴菩萨言。善男子。汝已久修清净梵行。不眴菩萨言。大德。夫梵行者。非是过去未来现在。若非过去未来现在即是无作。若无作者即名为行。如是行者名为无生名为无诤。无有言说及以威仪。大德。非眼行故名为梵行。非耳鼻舌身意行故。名为梵行。非色声香味触法行故。名为梵行。亦非色受想行识行故。名为梵行。非相非缘。非见非闻非知非觉。大德。如是等法无去来住。无牵无挽无有数量。无上无下是名梵行。须菩提言。善男子。夫梵行者名八正道。不眴菩萨言。大德。云何八正道名为梵行。若以正见为梵行者。不见诸法名为正见。等见诸法名为正见。不见之见乃名正见。若不见者。云何得名为正见耶。若无正见。云何得名为梵行乎。无有思惟名正思惟。夫思惟者名为颠倒。若颠倒者。云何得言正思惟耶。一切音声皆悉平等。若善若恶若一若二。若过去若未来若现在。若一切字若一切声。是名为响。若是响者。云何得言为正语耶。声平等者。一切行法皆悉无常。是苦无我涅槃寂静。若能等观一切诸法。如涅槃相及演说者是名正语。无身无身业。无口无口业。无意无意业。何以故。无业处故。若有业处则有我我所。若无我我所则无业果。若如是观名为正业。若为寿命行于邪命。远离邪命故名正命。若观是等无我我所。无有众生寿命士夫。如其无者。何故得名为正命耶。于眼识色不生染着。眼识性空。以识性空故眼色亦空。若眼色识空至意识法亦复如是。若如是观是名正命。无有颠倒。断诸精进名正精进无精进法。无精进者。无有具足成就精进。无有精进为利益者。若能观察如是等法是名正精进。若能等念一切诸法平等如空。一切诸法亦复如是。如一切法阴入界等亦复如是。若能观于如是等法是名正念。观一切法皆悉平等无我我所。若能如是平等观者是名正定。大德。若能如是观一切法性平等者名八正道。是名梵行。非以数故名八正道。非八正道名为梵行。非世道故名为梵行。非着心故名为梵行。非二相故名为梵行。无作相故名为梵行。若见诸法无有住处乃名梵行。尔时不眴菩萨。为诸大众说如是等梵行法时。五百比丘离诸烦恼。得阿罗汉果。须菩提言。善哉善哉善男子。快说是法。如离烦恼阿罗汉人。其所宣说等无有异。大德。我今亦是远离烦恼。亦是阿罗汉。我亦远离声闻缘觉烦恼诸法。我如法住故名阿罗汉。尔时须菩提白佛言。世尊。是不眴菩萨。乐说无碍不可思议辩才利智。随问而答。佛言须菩提。不眴菩萨得一切法自在三昧。以是故能随问而答。若有菩萨得是三昧。一切世间人天魔梵。不能障其乐说无碍。尔时帝释白佛言。世尊。若有人于无量世中。具足功德乃能得见。不眴菩萨闻其所说。世尊。若有比丘比丘尼优婆塞优婆夷。受持是经读诵书写为人解说及闻法者。悉发阿耨多罗三藐三菩提心。当知是辈一切皆当如不眴菩萨作师子吼。世尊。我当拥护如是等人。佛言善哉善哉。憍尸迦。汝今至心护持正法。尔时梵王复白佛言。世尊。我当乐修舍定三昧。舍禅定乐来护佛法及说法者令离病苦。随何国土有说法处。我当往彼至心听受。若有国土信受此经供养三宝。我亦当为除灭恶相。令其土境清净安怗正法治化。佛言善哉善哉。梵王。汝真护法。若有人能如是护法。当知是人终不远离三宝之宝。尔时四天王。复白佛言。世尊。我亦能护受持读诵书写解说如是法者。佛言善哉善哉。善男子。若知法者是人乃能拥护是法。汝于我所得闻法已。即获法眼断诸恶道。若复至心护持正法。不久当断一切诸有。尔时世尊告阿难言。汝当受持如是经典。为四部众广说其义。阿难白佛言。世尊。我能受持如是经典。如佛所说等无有异。广为四众宣释分别。尔时人天阿修罗乾闼婆一切大众。闻经欢喜赞叹善哉

大方等大集经卷第七大方等大集经卷第八

        北凉天竺三藏昙无谶于姑臧译

    海慧菩萨品第五之一

尔时世尊。故在欲色二界中间大宝坊中。与诸大众围绕说法。是时三千大千世界。大水盈满犹如大海。又如劫尽水灾起时。然诸世界国邑村落。城郭舍宅山林树木。上至色界无所娆害悉皆如故。而诸大众皆见是水。尔时水中出生无量分陀利花。青琉璃茎真金为叶。功德宝台帝释宝须。周匝多有无量之花。纵广十里在宝坊中。高一多罗树。尔时大众。各各自见在此花上。其花尔时出大光明。遍照十方无量世界。尔时大众心生欢喜。我等今者必当得闻殊胜妙法。尔时弥勒菩萨即从坐起。前礼佛足右绕三匝。于莲华上长跪合掌。白佛言世尊。何因缘故。如是三千大千世界满中大水犹如大海。又如劫尽水灾起时。复出无量分陀利花。大光如是遍照十方无量世界。佛言弥勒。下方过于三千大千世界微尘等国。有一世界名宝庄严。其土有佛号海智神通如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼有菩萨名曰海慧。欲来至此大宝坊中。与无数菩萨俱共已断一切数想。欲来听是大集经典。时舍利弗白佛言。世尊。彼佛世界去此甚远。海慧在彼。颇得闻此佛所说不。佛言舍利弗。如汝今于我前所闻。彼亦如是。如汝今日及诸大众睹见于我。海慧菩萨见我亦尔。世尊。菩萨摩诃萨所有神通不可思议。住于极远无量世界。而有如是无碍天眼无障耳通。世尊。谁有闻是不思议事。而当不发阿耨多罗三藐三菩提心。唯除下劣不肖人耳

尔时海慧菩萨。具足无量神通之力。于一念中在彼国灭。忽然现此大宝坊中即入三昧。令此大众悉得遥见。彼佛世界所有人民。城邑聚落屋舍殿堂。山林树木飞鸟走兽。及见彼佛与诸大众围绕说法。现是事已。即从三昧安详而起。前礼佛足右绕三匝。以其世界所有香花种种伎乐。供养于佛作如是言。下方世界海慧神通如来。致问无量如来身命及以大众悉安隐不。却坐一面宝莲花上。时有梵王名曰修悲。作是思惟何因缘故有是大水。满此三千大千世界而非水灾。我今当往问于世尊。即与六万八千梵俱诣如来所。头面敬礼右绕三匝。长跪合掌白佛言。世尊。何因缘故。此中三千大千世界。七宝莲花庄严遍满。无量菩萨各各次第坐宝花上。三千世界大水盈满。佛言梵天。善男子。此是海慧菩萨摩诃萨神通之力。梵天言世尊。如来所说大集妙典犹未讫耶。佛言梵天。如来所有乐说无碍不可穷尽。梵天。佛与无量菩萨大众。观察法界讲论法界。法乐微妙亦不可尽。梵天言世尊。如来所言海慧菩萨其谁是耶。佛言梵天。汝今不见坐宝莲花。其花纵广满十由旬。为诸菩萨之所恭敬赞叹者乎。其身色像光明炜烨。唯除如来余无及者。尔时梵天。见已即生恭敬之心。头面礼拜作如是言。若有得见如是正士得大利益。我今遇之亦复如是。世尊如是正法当久近住。佛言善男子。如是正法如如来寿。我涅槃后是诸菩萨亦护是法。何以故。此经即是过去未来现在佛印。尔时海慧菩萨踊在空中高七多罗树。示现己身智慧之力。为令大众生信心故。庄严此经故。而说偈言

  下方有土过尘数　　有佛海智神通尊
  常为众生演说法　　我闻能受为人说
  我今来此大众中　　供养恭敬十力尊
  所来眷属诸菩萨　　为破法中细疑心
  我今敬礼最无胜　　如法而作上供养
  为欲庄严上菩提　　教化众生无上道
  若观诸色无有相　　亦能断离三种受
  若无相貌及种性　　是人能礼无上尊
  若不贪着我我所　　亦复修集于中道
  观一切法如虚空　　是人能礼无上尊
  若不贪着诸境界　　亦能寂静于内入
  于诸法界不生着　　是人能礼无上尊
  若见如来真法身　　能竖无上大法幢
  见一切法如幻相　　是人能礼无上尊
  若见无施无受者　　无作无受亦如是
  若无正见及邪见　　是人能礼无上尊
  亦不定在菩提中　　又不决定在生死
  远离一切诸烦恼　　是人能礼于如来
  若有至心修善法　　净身口意三业等
  亦能调伏于诸根　　是人能礼无上尊
  若忍诸法无有我　　不成菩提舍众生
  为菩提故持净戒　　是人能礼无上尊
  若观诸法犹如焰　　众生平等如虚空
  净心不作诸心想　　是人能礼无上尊
  为诸众生受大苦　　为菩提故修忍辱
  观一切法如水月　　是人能礼于正觉
  观无众生命士夫　　亦为众生修菩提
  观法念念灭尽相　　是人能礼无上尊
  受地狱苦心不退　　勤加精进修集道
  闻诸法空心不怖　　是人能礼无上尊
  一切境界无挂碍　　犹如空中动手者
  亦观三世相平等　　是人能礼无上尊
  若魔不能知其心　　是人能得大神通
  若说法字义无尽　　是人能礼无上尊
  若能遍闻诸佛音　　闻已受持广宣说
  不见三宝差别相　　是人能礼无上尊
  如来具六波罗蜜　　无有去来如虚空
  了了知诸众生界　　是故我礼无上尊
  如来成就大功德　　终不生于似我慢
  我今敬礼佛色像　　是身世间不能作
  佛光胜于一切光　　其意殊妙亦最上
  一切众生不见顶　　是故我礼一切胜
  如来知诸众生解　　随解而为演说法
  能知烦恼之对治　　是故我礼于世尊

尔时海慧菩萨。偈赞佛已从空而下。白佛言世尊。我今于此欲少咨问。唯愿如来哀愍听许。佛言善哉善哉。善男子。随意致问。吾当为汝分别解说。海慧菩萨言世尊。我先闻有净印三昧。若有菩萨住是三昧。即得阿耨多罗三藐三菩提。唯愿如来说是三昧。令诸菩萨普皆得闻。闻已皆当庄严修行为阿耨多罗三藐三菩提故。佛言善男子。至心谛听吾今当说。善男子。如净宝珠。匠者琢磨价直无量人所珍重。善男子。菩萨初发菩提心已。修集善法多闻思惟。观察法界净于初心。初心既净咸为诸佛菩萨敬念。即便获得净印三昧。善男子。净宝珠者离九种宝。何等为九。一者金性。二者银性。三者琉璃性。四者颇梨性。五者马瑙性。六者莲花性。七者车磲性。八者功德宝性。九者珊瑚性。是名为九离。是九性名净宝珠。其价无量。转轮圣王之所受用。是珠光明余光不及。善男子。菩萨摩诃萨发菩提心亦复如是。离九种性得净印三昧。何等为九。一者凡夫性。二者信行性。三者法行性。四者八忍性。五者须陀洹性。六者斯陀含性。七者阿那含性。八者阿罗汉性。九者辟支佛性。离是九性入佛种性得净印三昧。以其净故胜于一切声闻缘觉。施于一切众生光明。善男子。净宝珠者耐磨穿押。是故此珠名无瑕玼。善男子。净印三昧亦复如是。善男子。云何净印三昧。修集三戒具十善法。修行慈悲怜愍众生。见他事业亲往营理。爱念一切修舍意净。常念众生以四摄法。摄取一切专念六念。调伏诸根少欲知足。不断圣种息诸斗讼坏于憍慢。恭敬供养诸师和上耆旧长宿。不轻于他求法护法。远离恶法。于佛法僧信心无坏。心常缘念一切善法。不赞己身常称他德。知恩报恩净诸威仪。具于忍辱求舍摩他修陀罗尼。心等如风地水火空。常乐出家修集寂静持戒精进。亲近善友净于诸根。眼耳鼻舌身心无碍。观于不净为坏贪结。修集慈心为破怨亲。观十二缘为坏无明。远离一切障碍之法。施法无吝具足成就六波罗蜜。不求余乘。内外清净观生死过。于菩提道心不悔退。教化众生于大乘中。善男子。菩萨具足如是等法。净不净意。发阿耨多罗三藐三菩提心。是名宝珠。尔时世尊即说颂曰

  若有修集大慈心　　具足成满十善法
  是人定见弥勒佛　　故菩提心难思议
  修集大悲为众生　　亦常教化于大乘
  为除烦恼修舍心　　故菩提心难思议
  具足修集念智慧　　及能调伏于自心
  能修知足及少欲　　是故菩提心最胜
  远离一切诸恶法　　其心柔软于众生
  增长一切诸善法　　是故菩提心最胜
  恭敬供养师和上　　绍继增长圣种性
  远离一切诸憍慢　　是故菩提心最胜
  其心质直不欺诳　　常乐寂静化众生
  除去憍慢不轻他　　是故菩提心最胜
  护持正法能听说　　化诸众生离烦恼
  至心专念无上乘　　是故菩提心最胜
  供养三宝信四谛　　远离诸恶修善法
  不嗔不恚于众生　　是故菩提心最胜
  客烦恼起生惭愧　　即向十方佛忏悔
  修集善法调诸根　　是故菩提心最胜
  净身口意知业果　　知恩念恩知酬报
  信十二缘净威仪　　是故菩提心最胜
  具舍摩陀修智慧　　具足持戒乐菩提
  受大苦恼心不动　　是故菩提心最胜
  其心平等如四大　　视诸众生如虚空
  常乐出家修菩提　　是故菩提心最胜
  贪乐寂静净身心　　修行法行观四谛
  实语法语真义语　　是故菩提心最胜
  有所说法而安住　　勤修精进坏魔业
  于所修法无懈怠　　是故菩提心最胜
  亲近善友佛菩提　　能度众生生死海
  能净一切六境界　　是故菩提心最胜
  远离障碍除五盖　　诸根清净无憍慢
  贪欲嗔恚痴对治　　是故菩提心最胜
  观善思惟具念心　　修助菩提得神通
  不畏生死乐涅槃　　是故菩提心最胜
  凡所说法不为食　　于诸法中心无吝
  修行善法不求报　　是故菩提心最胜
  不以余乘摄众生　　所说众乐而受持
  其心无量无有边　　是故菩提心最胜
  内外清净无过咎　　不畏生死修菩提
  修菩提时心不悔　　是故菩提心最胜
  知众生界净国土　　庄严菩提不自为
  迷惑众生示正道　　是故菩提心最胜
  善知法界真实性　　无分别智不可说
  能破众生怖畏想　　是故菩提心最胜
  若能具足如是法　　是能净发菩提心
  不为世法之所污　　烦恼魔业亦复然
  若有能发菩提心　　是则能胜一切乘
  能净一切众生心　　亦能演说无上道

善男子。云何名为菩提之心押而不坏。押者名为大悲。缘于一切众生。绍三宝种不令断绝。为佛法故庄严善根。三十二相八十种好严净世界。为护正法不惜身命。善男子。若为诸恶众生打触恼乱娆害。悉当忍之。亦应不舍一切众生。心不生悔不愁不恼。为调众生勤加精进。若遇骂辱嗔恚打掷。默然受之终不加报。应作是念。夫大乘者与世共诤。何以故。一切众生顺生死流。大乘之法逆生死流。一切众生各各诤讼。大乘之法破坏斗诤。一切众生嗔恚炽盛。大乘之法除灭嗔心。一切众生各各虚诳。大乘之法质直无虚。十方世界若有众生。以诸刀杖随逐菩萨。而作是言。谁有发此菩提心者。我当叚叚支解其身如胡麻许。菩萨闻此终不退转菩提之心。亦不放舍慈悲喜舍惠施持戒忍辱精进禅定智慧。何以故。菩萨思惟。我于无量无边世中。受大地狱畜生饿鬼人天等身。受行恶法不能自利及利他人。若我或于无量世中。为彼恶人刀杖随逐节节支解。我终不舍于菩提心及诸众生。何以故。若我不能忍受如是世中苦者。何能堪忍地狱诸苦。行善法时。多有恶法来作障碍。我若不忍。云何能作种种善法。一切众生施我恶事。我要当以善法施之。众生施我刀杖骂辱。我以无上大忍施之。菩萨摩诃萨若能如是思惟观者。当知不久得阿耨多罗三藐三菩提。如是观已能忍三押。谓身口意。云何押身。若菩萨身被支解时。尔时依法将顺恶人。具足六波罗蜜。云何菩萨身被支解。而得具足六波罗蜜。菩萨若被支解身体不惜身命。尔时具足檀波罗蜜。于彼恶人修集慈心。尔时具足尸波罗蜜。不嗔不骂不以恶事还往加之。尔时具足忍波罗蜜。为诸众生勤行精进。终不舍离菩提之心。尔时具足精进波罗蜜。若他嗔打其心不动。不失正念其意清净。尔时具足禅波罗蜜。观身无常苦空无我。犹如草木瓦石等类。尔时具足般若波罗蜜。具足如是六波罗蜜已。押而不坏。是名押身。云何押口。忍于一切恶言骂辱。若实不实但责己身烦恼诸结。终不怨他为诸众生修集慈悲。菩萨摩诃萨修集如是。忍恶骂时。即得具足忍波罗蜜。菩萨摩诃萨遇骂辱时即作是念。是人往世悭贪因缘。亲近恶友得是恶心。我破悭贪修集惠施亲近善友。是故我能舍是嗔恚。尔时具足檀波罗蜜。菩萨摩诃萨遇骂辱时作是念言。是人破戒不信业果。是故骂我。我受持戒信于业报。是故修忍念于菩提。护持正法将顺众生。尔时具足尸波罗蜜。菩萨摩诃萨遇骂辱时作是思惟。是人懈怠不修善法。是故骂我。我勤精进修集善法舍离嗔心。于善法所心无厌足。我今要当设大方便。先令是人坐菩提树。然后我当取菩提果。尔时具足精进波罗蜜。菩萨摩诃萨遇骂辱时复作是念。是人失念狂乱放逸烦恼所污。我今破坏一切烦恼。为如是等诸恶众生发菩提心。若诸众生悉清净者。我复何缘发菩提心。是故专心缘念菩提心不匆务。尔时具足禅波罗蜜。菩萨摩诃萨遇骂辱时复作是念。是人着我我所众生寿命士夫。我依法界。法界之中唯骂谁受。我亦不见一法是骂及以骂者。尔时具足般若波罗蜜。若能至心受持修行五波罗蜜。尔时具足忍波罗蜜。是名押口。云何押心。不畏魔众退菩提心。不畏一切众邪异见退菩提心。不畏地狱饿鬼畜生种种诸苦退菩提心。若见佛像来作是言。汝亦不能发菩提心。菩提之道甚为难得。不如早修声闻乘法。速证涅槃受大安乐。菩萨尔时闻是语已即自思惟菩提之道难之与易。我终不退。定当得到菩提树下坐金刚床。我昔己请一切众生。许当以法而惠施之。我今未与云何欺诳。我当随顺一切佛心。堪忍如是押心之事。不诳诸佛人天大众及以已身。是名押心。尔时世尊即说颂曰

  向菩提道心不坏　　大慈大悲亦复然
  又不断绝三宝种　　无量庄严为菩提
  为佛十力四无畏　　三十二相八十好
  无量世中舍财施　　亦受种种大苦恼
  为得三宝诸功德　　受持正法而广说
  为度众生生死海　　是故堪受种种苦
  十方世界恶众生　　执持刀杖逼我身
  心终不动失菩提　　怜愍一切众生故
  无量劫中受苦恼　　不能自利及利他
  今我此忍大利益　　亦能得佛无量德
  为佛功德碎其身　　犹如胡麻心不悔
  心亦不退无上道　　多受诸苦为菩提
  行住坐卧念菩提　　其心寂静离烦恼
  若欲起嗔于众生　　先当怨己及烦恼
  三恶道中受诸苦　　为诸众生得佛道
  不求人天上快乐　　甘乐为众受诸苦
  若于人中所受苦　　不及地狱百千一
  虽受三恶无量苦　　亦不退失菩提心
  观身无常及无我　　四大之性如四蛇
  至心放舍如是身　　能得智慧无上道
  流转诸有受诸苦　　以不能观身真实
  菩萨能观身真实　　是故永离诸苦恼
  行恶之时无妨碍　　修行善法多留难
  诸佛世尊为证知　　是故我受种种苦
  我今能忍如是等　　身口意业无量苦
  以是因缘菩提心　　坚牢毕竟不可动
  舍身具六波罗蜜　　于身无贪具足檀
  于彼恶人生慈心　　是故具足于尸罗
  割身能忍不生嗔　　以是因缘具羼提
  受苦时心不动转　　是故具足毗黎耶
  不失念心乐寂静　　是故具足于禅那
  观身无我无我所　　尔时具足于般若
  若我能作是庄严　　不久定得无上道
  若我不忍恶口业　　云何能坏众烦恼
  若我调伏身口意　　则能忍受众苦逼
  能坏一切诸魔众　　虽有众邪我不动
  若欲具足波罗蜜　　如来十力四无畏
  获得无上无价宝　　当学调伏身口意

善男子。云何名为穿菩提心。菩萨既发菩提心已。终不生于相似我慢。不着菩提心。不贪菩提心。不爱菩提心。不观菩提心。如是则能令心寂静。观深法界观诸佛法。深法界者。谓十二因缘远离二边。一切诸法性自无我。观于我性一切法性空无有主。住空三昧无相无愿。知诸行法无所造作。观色如沫受如水泡。想如热焰行如芭蕉识则如幻。观界无作无有动摇。入如聋盲。心无暂住。憍慢之结都无生处。诸法无二无有分别。一味一乘一道一源。观一切声无有声相。一切音声次第不合。一切诸法不可宣说。了知苦相。集无我所。于灭无增。知道毕竟。无障碍故观身念处。知去来受念心出灭。知于法界观界非界。故修正勤欲得自在。故修如意离诸烦恼。名为信根。乐于寂静名精进根。非有念故名为念根。非思惟故名为定根。远离一切名为慧根。不随他故名为信力。无障碍故名精进力。不退转故名为念力。心得自在名为定力。不观善恶名为慧力。不放逸故名念觉分。入诸法故名择法觉分。如法行故名进觉分。远离恶故名喜觉分。身心寂静名除觉分。知实三昧名定觉分。不观于二名舍觉分。远离诸见名为正见。离诸觉观名正思惟。知诸声性名为正语。于身口意不生贪着。名为正业。离嫉妒心名为正命。不增不减名正精进。于善不善不生贪着。是名正念。观诸心界是名正定。实相之性其性寂静。毕竟义者。名无常苦无我。假名清净大净。能调心者名之为施。身心清净名之为戒。诸法无常名之为忍。勤修是智名为精进。内外清净名为三昧。观真实故名为智慧。知诸众生心性本净是名为慈。观于一切等如虚空是名为悲。断一切喜名为喜心。远一切行名为舍心。一切诸法未来世净。过去种种现在无我。善男子。若能真实观察了知如是等法。是名为穿菩提心宝。菩萨观察如是法已。次第得一切法自在陀罗尼。善男子。譬如日月不作往来照明之心。以诸众生福德力故。自行往返坏诸闇冥。善男子。菩萨摩诃萨若能观了如是等法。亦复如是不作是念。我当利益无量众生。而令众生大得利益。善男子。若菩萨摩诃萨。能作是观是名禅波罗蜜般若波罗蜜。何以故。入定乃能作如是观。乱心不能定者。即是禅波罗蜜。观者即是般若波罗蜜。如是乃能观于真实。了了见于一切法相。云何名见一切法相。一切法相名无相相。言无相者即是无作。即此无作名之为相。若能永断如是无相即无相相。又无相者名无生相。无相相者名无灭相。无生无灭名无相无相相。若见无生无灭无作无一无二无嗔无诤无有。如尔不动不转知于法性。是名真性。是名法性。是名实性。善男子。菩萨摩诃萨若真实知如是等法。名非住住。说是法时。十二那由他众生发阿耨多罗三藐三菩提心。万六千天得无生忍。尔时世尊即说颂曰

  能破一切诸法相　　清净无上菩提心
  若能如是观察者　　即得不着一切法
  明见甚深诸法界　　亦不怖畏于涅槃
  以是不怖因缘故　　则能增长于佛法
  明信于因及果报　　十二因缘亦如是
  远离二边常断见　　随意种种说正法
  于常无常心不着　　又能演说于中道
  知一切法是空性　　无有众生无寿命
  一切诸法空无相　　亦复无有次第生
  其性本来常寂静　　无有能作如虚空
  不观一切诸法相　　了了觉知无有生
  观色如沫受如泡　　想如热焰行芭蕉
  观心如幻四大空　　观入犹如聋盲者
  又观心意无内外　　心无住处界无二
  不着诸法色色相　　虽有是知无憍慢
  观一切法皆平等　　一味一乘一道源
  能知如是真实义　　了了能观于法界
  无有音声能观声　　无有心意能观心
  无有文字观文字　　是能真实知法界
  一切法义不可说　　声及文字亦复然
  真实知苦集灭道　　具足系心四念处
  于诸法界无分别　　其心能得大自在
  远离一切诸烦恼　　修四正勤行精进
  为得无碍大自在　　勤心修集四如意
  于一切法不贪着　　为于如是修信根
  常乐住于大寂静　　是故修集精进根
  心无念虑知真实　　是故修集于念根
  悉能调伏诸心想　　是故修集于定根
  为能观察于法界　　是故修集于慧根
  为欲了知诸法界　　是故修集七觉分
  不观诸法一二数　　是故修集八正道
  如意能以财物施　　亦能如意受持戒
  又能清净于内外　　是则名为大神通
  一切诸法本性净　　是故修集于慈悲
  断一切喜诸烦恼　　是故修集于喜心
  一切诸法本性净　　去来现在亦复然
  若观诸法无生灭　　是人即得真实知

尔时世尊。复告海慧菩萨言。菩萨得是净大净已。其心真实无有欺诳于诸众生平等无二。得真实智毕竟大智净印三昧。安住净印三昧根本。云何名为三昧根本。为诸众生修大慈悲。虽得供养其心不高。嗔恚毁辱心亦不下。心不高故。则能生于不憍法性不憍名字。亦不生于相似我慢。身口意业从智慧生。是故一切所作诸业非不随智。云何菩萨身业随智。所得身形殊胜微妙。众生见者即得调伏。身四威仪亦能调伏。离诸身过身曲身滓。其身清净相好庄严。诸根具足无有缺减。不恃此身而生憍慢。见下色者心亦不轻。自于其身不生贪着。观身法界及以身业。知是色已。念于法身不求食身以定为食。为调众生现受其施常修圣行。所谓非为贪欲嗔恚愚痴受持清净戒拥护正法。菩萨摩诃萨具足如是随智身业。得大神力无所畏力。以是力故。于诸佛土普示其身。如此世界所示色身。余诸世界亦复如是。放大光明遍照十方无量世界。其光柔软众生遇者离烦恼热。离烦恼已受大快乐。是名菩萨身业随智。云何菩萨口业随智。所谓远离六十四种恶口之业。粗语浊语非时语妄语。漏语大语高语轻语破语不了语。散语低语仰语错语。恶语畏语吃语诤语讇语调语诳语恼语。怯语邪语罪语哑语。入语烧语地狱语虚语慢语轻语。不爱语说罪咎语。失语别离语。利恶语两舌语。无义语无护语。喜语狂语杀语害语。系语闭语缚语打语。歌语非法语。自赞叹语。说他过语。谤三宝语。是名六十四(丹本云少十一种无处访本)。善男子。菩萨摩诃萨远离如是恶口等事。凡有所说。说实说真。说解脱说如实。说随谛。说利众生。说随众生心实不实。说众乐闻。说一切声。说一切语。说净众生根。说令众生离于烦恼。说于佛语。说于甘露其声遍闻十方世界。说令众生永离苦恼。说于深义。说调众生。说不造作恶。是名菩萨口业随知。云何菩萨意业随智。住一心中能知一切众生之心。常在禅定现诸威仪。一切众魔声闻缘觉。悉不能知心所缘处。终不生心欲自毁害方便害他。了一切法通达无碍。得如是心不受能受亦不证灭。是名菩萨意业随智。是名净印三昧根本。如是根本复有十种。一者净初发心。二者净菩提道。三者净六波罗蜜。四者净干慧故修于三昧。五者净相。六者净好。七者净陀罗尼。八者净如法住。九者净于无失。十者净三十七助道之法。是名为十。善男子。净印三昧具三十法。一者内净。二者外净。三者心净。四者憍慢净。五者身净。六者眼净。七者一切众生无众生净。八者一切法本性净。九者一切法同一味净。十者空无相愿净。十一者解脱法门净。十二者一切诸法入法界净。十三者一切诸法入一性净。十四者信心无坏净。十五者无障碍净。十六者一切解脱净。十七者无为净。十八者观十二因缘净。十九者十力四无所畏净。二十者无胜净。二十一者一切法智净。二十二者过去业净。二十三者慈悲净。二十四者不舍众生净。二十五者破诸魔业净。二十六者离内贪净。二十七者离诸习气净。二十八者一念知一切法净。二十九者不失念心净。三十者具足庄严净。菩萨具足如是等法。名净印三昧。得是三昧已。得八不共法。何等为八。所得世界金刚为地。一树之上种种枝叶。种种华果。一切众生不起烦恼。地狱饿鬼畜生之类。悉见菩萨坐菩提树。见已即得微妙快乐。金光遍照无量世界。一切大地六种振动。无一众生有娆害者。一念之智知一切法。是名为八。尔时世尊即说颂曰

  若知诸法如虚空　　净于本性不生灭
  即能净于如来印　　亦得住于定根本
  虽得供养心不喜　　呵责骂辱心不嗔
  修集慈悲心平等　　是则名为净印定
  远离一切诸憍慢　　离已其心不自高
  能呵烦恼诸结缚　　是则名为净印定
  其身永离诸恶业　　庄严妙相三十二
  具足清净于诸根　　亦复不生憍慢结
  见有下色丑陋者　　贫穷斯下心不轻
  为菩提故净说法　　是则名为净印定
  观察于身真实性　　坏于众生贪身想
  是故获得上法身　　远离一切杂食身
  常在禅定法喜食　　为众生故受揣食
  甘露上味增法命　　是则名为净印定
  爱乐圣行持佛戒　　远离贪欲恚痴等
  菩萨先自调其身　　然后复为众生说
  神通遍游诸十方　　为调众生演说法
  如彼色像示其身　　随其意趣为说法
  身出无量金色光　　遍照十方诸世界
  能坏众生烦恼热　　增长菩提心功德
  若有三恶苦众生　　遇已悉得无上乐
  皆得远离恶道苦　　信心成就修善业
  如来所说身净业　　为令众生净佛身
  若有能修如是业　　获得净身如先佛
  若有远离恶口业　　即得从智微妙声
  凡所演说众乐闻　　闻者皆得生善芽
  远离六十四恶口　　是人则能说甘露
  能说无为之大乘　　亦得善解众生语
  能离贪欲恚痴语　　演说甚深真实义
  其声遍闻十方界　　为众宣说实解说
  呵毁打害不嗔诤　　心常怜愍柔软语
  为众演说不可说　　说已其心不生慢
  若能清净如是业　　是人远离口诸恶
  如来所说口净业　　为令众生广长舌
  若有修集善意业　　是人一念知诸心
  常在禅定示威仪　　坏诸魔业心不高
  不受能受为众生　　了知真实不证灭
  一切众魔不知心　　声闻缘觉亦复然
  不生害心于自他　　能观甚深诸法界
  若欲得是净印定　　常当修集于十法
  清净庄严佛境界　　净于善法及六度
  具足功德及身相　　得无碍说陀罗尼
  如法而住净其心　　不失念心说无我
  离一切障慧无碍　　其意无失具功德
  修助菩提无放逸　　为诸众生说菩提
  无量世界身无碍　　演说正法化众生
  具足八种不共法　　获得无上大利益
  金刚为地树种种　　悉见菩萨坐菩提
  若欲具足如是德　　当修净印三昧定
  如来修集是定故　　获得功德不可议

大方等大集经卷第八大方等大集经卷第九

        北凉天竺三藏昙无谶于姑臧译

    海慧菩萨品第五之二

善男子。菩萨摩诃萨若欲获得净印三昧。应当修集净于菩提。远离一切滓浊之心。善男子。若不能见诸法性净。则为渴爱烦恼所污。一切诸法不可思惟。不作不行清净寂静。无有尘垢亦无过失。毕竟清净如解脱性。法界不坏无有分别。实性法性无有差别。一切诸法空无相愿。如解脱性无碍平等。一切诸法亦复如是。若能如是正观察者。是名无浊。善男子。菩萨若能为诸众生。说如是法是名无滓。善男子。若有菩萨心无滓浊。是人则得净印三昧。海慧菩萨言。世尊。如是三昧其义甚深不可说故。不可睹见断数法故。难可解了不可见故。是大智慧摄诸法故。一切菩萨皆悉平等。无垢无滓无诸障碍。无有住处微妙难明不可喻说。其性坚固犹如金刚。不生不灭不破不坏不系不缚。是大光明远离闇故。不可思议无垢清净远离贪故。无有诤讼修集慈故。不觉不观离去来故。一切平等如虚空故。世尊。观何因缘得是三昧。佛言。善男子。譬如有人欲游虚空。大自庄严菩萨亦尔。欲得是定当大庄严。平等庄严一切诸法。何以故。世间之法从子得果。善男子。一切有为识为种子。此三昧者无有种子。何以故。而此三昧非眼识识。乃至非意识识。非作非色。非受非想非行非识。观一切法普皆平等。是名三藐三佛陀。善男子。非异相故名为生死。非异相故名为涅槃。善男子。随生死相即涅槃相。何以故。一切诸法本性净故。本性性者名为无性。夫无性者名无性相。若无相性即是无作。如是无作即是法性无有文字。若无文字即名为如。如前中后亦尔是名三世。夫三世者即名为空。空即无作。如是无作何有作者。是故无作名之为空。若无作作者。当知无法。若无法者无求无愿。若无愿求则无身口意业。无身口意业即名无碍。无碍者名为不出。不出不灭不住。不灭不住即无为相。无为相者是名不住。不住者谓无一切所作之业。意不住色乃至意不住行。若是四处意无住者是名无住。若无住者则不生于相似我慢。若无如是相似我慢则无增长。若无增长则无有因。若无有因则无觉观。若无觉观是名默然。善男子。如是等法其义甚深。若能信者即得解脱。永离颠倒烦恼障碍。即能受持过去未来现在诸佛所有法藏。是大船师导师商主咒师医师。则能供养三世诸佛。是名佛子。过于魔业破诸魔众。不久当得净印三昧。能大庄严坚牢船舫。济渡众生于生死海。世尊。云何菩萨能坏一切诸魔伴党。佛言。菩萨若能不求诸法。尔时则能坏破魔众不求一切境界因缘。善男子。有四种魔。一者阴魔。二者烦恼魔。三者死魔。四者天魔。善男子。若能观法如幻相者。是人则能破坏阴魔。若见诸法悉是空相。是人则能坏烦恼魔。若见诸法不生不灭。是人则能破坏死魔。若除憍慢则坏天魔。复次善男子。若知苦者能坏阴魔。若远离集破烦恼魔。若证灭者则坏死魔。若修道者则坏天魔。复次善男子。若见一切有为法苦则坏阴魔。若见诸法真实无常坏烦恼魔。若见诸法真实无我能坏死魔。若见诸法寂静涅槃能坏天魔。复次善男子。菩萨若能于身无贪。舍身施时回向菩提能坏阴魔。施时远离悭贪之心坏烦恼魔。若观财物一切无常能坏死魔。为众生故修悲布施能坏天魔。复次善男子。若有菩萨不为我见受持净戒能坏阴魔。不为有贪受持净戒坏烦恼魔。若为远离生死过失受持净戒能坏死魔。若能生心令毁禁者悉持净戒。受持净戒则坏天魔。复次善男子。若有菩萨不见我忍我修于忍则坏阴魔。不见众生有修忍者坏烦恼魔。不见生死则坏死魔。不见菩提则坏天魔。复次善男子。若有菩萨勤修精进。其身寂静则坏阴魔。勤行精进其心寂静坏烦恼魔。勤行精进观法无生能坏死魔。勤行精进为调众生令转生死则坏天魔。复次善男子。若有菩萨不为五阴修集禅定能坏阴魔。不着界处修集禅定坏烦恼魔。不着入处修集禅定能坏死魔。所有诸善回向菩提能坏天魔。复次善男子。若有菩萨知阴方便能坏阴魔。知界方便坏烦恼魔。知入方便能坏死魔。以如是等种种方便回向菩提能坏天魔。复次善男子。若有菩萨观一切法皆是空相能坏阴魔。观一切法悉是无相坏烦恼魔。观一切法悉是无愿能坏死魔。具是三法回向菩提能坏天魔。复次善男子。若有菩萨观身身处不觉不着能坏阴魔。观受受处不觉不着坏烦恼魔。观心心处不觉不着能坏死魔。观法法处不觉不着能坏天魔。作如是观终不失于菩提之心。是人则能坏破四魔。善男子。若着我者则增魔事。菩萨摩诃萨亦知有我亦知无我。若有法非有我非无我。如是则无一法增减。一切众生无明所覆。是故菩萨为欲庄严无上大乘。非为我故而发庄严。发庄严已作是思惟。谁庄严法坚固不坏。我当庄严我亦不为坏我众生寿命士夫而行庄严。为破众生着我邪惑众生寿命士夫等见。而行庄严。众生颠倒见是五阴常乐我净。我当为说如是无常苦空无我。为令众生得真实智。若有众生心有愿求。当知是人即名为着。若不愿求则无有着。若不著者是人不诳。若不诳者得真实智。知于过去未来现在。不着过去未来现在。何以故。过去已尽未来未至现在不住。若于三世不作着想名不颠倒名菩萨行。了知一切众生诸行。知已了了说业及果。亦知贪行嗔行痴行。知有众生行于贪欲庄严于嗔。行于嗔恚庄严于贪。行于愚痴庄严于贪。行于贪欲庄严于痴。行于嗔恚庄严于痴。行于愚痴庄严于嗔。善男子。有诸众生于色生贪于声生嗔。复有众生于声生贪于色生恚。复有众生于香生贪于味生恚。复有众生于味生贪于香生恚。复有众生于触生贪于法生恚。复有众生于法生贪于触生恚。复有众生贪欲羸劣嗔恚猛健。复有众生贪欲猛健嗔恚羸劣。复有贪羸痴健痴羸贪健。嗔羸痴健痴羸嗔健。或有众生为色调伏。非为声香味触法等。有为声调伏。非为色香味触法等。有为香调伏。非为色声味触法等。有为味调伏。非为色声香触法等。有为触调伏。非为色声香味法等。有为法调伏。非为色声香味触故。复有众生心寂静故而得调伏。非身寂静而得调伏。或有众生身寂静故而得调伏。非心寂静而得调伏。或有众生闻说无常而得调伏。非因于苦不净无我而得调伏。或有众生闻说苦故而得调伏。非因无常不净无我而得调伏。或有众生闻说不净而得调伏。非因无常苦无我等而得调伏。或有众生闻说无我而得调伏。非因无常苦不净等而得调伏。复有众生见身神通而得调伏。非他心智而得调伏。或有众生因他心智而得调伏。非因神通而得调伏。善男子。有诸众生勤修精进迟得解脱。有少精进速得解脱。有勤精进速得解脱。有少精进迟得解脱。有因解脱非缘解脱。有缘解脱非因解脱。有因缘解脱非因缘解脱。有诸众生观于内法而得解脱。非观于外有观于外而得解脱。非观于内有观内外而得解脱。有不观内外而得解脱。有诸众生因乐行故而得解脱。非因苦行有因苦行而得解脱。非因乐行或因苦乐而得解脱。或有不因苦行乐行而得解脱。有诸众生因赞美故而得调伏。非因呵责或因呵责而得调伏。非因赞美或因赞毁而得调伏。或有不因而得调伏。有诸众生因逆说法而得调伏。不因顺说或有因顺而得调伏。不因于逆或因逆顺而得调伏。或有非因逆顺说法而得调伏。有诸众生因闻略说而得调伏。非因于广或有因广而得调伏。非因于略有因广略而得调伏。或有不因广略说法而得调伏。有诸众生因四真谛而得调伏。有因念处而得调伏。有因正勤而得调伏。或因如意而得调伏。或因五根而得调伏。或因五力而得调伏。或因七觉而得调伏。或因八道而得调伏。善男子。众生之行不可思议。众生之心亦不可思议。众生调伏不可思议。所入法门不可思议。众生境界不可思议。菩萨摩诃萨获得如是不可思议智。然后乃知一切众生。所行之行不可思议。善男子。譬如罗网多有诸结。有人在中以咒术力。破网得出随意而去。菩萨摩诃萨亦复如是。入众生中以智咒力。坏烦恼网随意自在。虽未证得阿耨多罗三藐三菩提。而能通达众生所行

尔时舍利弗白佛言。世尊。菩萨摩诃萨初发无上菩提心时。闻诸众生有如是行。不惊不怖是事实难不可思议。佛言。舍利弗于意云何。如师子子。虽复初产闻师子吼。有怖畏不。不也世尊。菩萨摩诃萨初发无上菩提心时。闻众生行亦复如是。舍利弗于意云何。火势虽小畏干薪不。不也世尊。菩萨摩诃萨初发无上菩提心已。得智慧火亦复如是。舍利弗。如来今以非喻为喻。舍利弗譬如猛火与诸干薪。结期七日当大战斗。尔时一切干树草木种种枝叶悉共聚合如须弥山。尔时猛火有一亲友而语之言。汝今何故。不自庄严多求援助。彼薪众多汝唯一己何能当之。时火答言。彼怨虽多我力能敌不须伴党。舍利弗。菩萨摩诃萨亦复如是。虽诸烦恼悉共和合其势炽盛。菩萨智慧力能消伏。舍利弗。菩萨摩诃萨有二种力。一烦恼力。二智慧力。菩萨若无烦恼力者。则不能共诸众生行。亦不能知众生行处。亦当证于声闻缘觉。是故菩萨以烦恼力遍游诸有不生怖畏。是名菩萨行于方便。舍利弗。如小毒蛇不须伴侣。初发心者亦复如是。舍利弗。譬如萤火虽有无量千万亿数。不能障蔽日之光明。菩萨摩诃萨亦复如是。虽有烦恼无量无数。不能障蔽菩萨智光。舍利弗。如阿伽陀一丸之药能破大毒。菩萨智慧亦复如是。小智慧药能坏无量大烦恼毒。舍利弗。譬如天降一味之水。随地差别得种种味。菩萨摩诃萨一解脱智亦复如是。随众生根说种种异。舍利弗。如阎浮树下有金泥。是金泥中有种种宝。菩萨摩诃萨初发菩提金泥心中。亦复有声闻辟支佛宝。舍利弗。如余小王一切悉属转轮圣王。一切人天亦复如是。悉来归属初心菩萨。舍利弗。如薄福人不遇宝雨。若不能于无量佛所种诸善根。则不能发菩提之心。舍利弗。无甘蔗子则无种种石蜜诸味。若无菩提心者。亦无种种三宝诸味。舍利弗。如耆婆医王常作是言。天下所有无非是药。菩萨亦尔说一切法无非菩提。舍利弗。如阿修罗王尽其势力。不能遮障日月之道。一切魔众亦复如是。尽其势力不能遮障。勤行菩萨修菩提道。舍利弗。如色界天宫殿屋宅依空而住。勤行菩萨所得菩提。亦复如是依空而住。舍利弗。譬如虚空悉能容受一切万物。而是虚空初无增减。无量佛法亦复如是。虽有菩萨发心推求。而是佛法亦无增减。舍利弗。譬如有人任力游空。而虚空性无增无减。菩萨亦尔。住其信力行于佛智。而是佛智亦无增减。舍利弗。譬如陶师未成器时不得器名。菩萨善法亦复如是未发心时亦不得名。舍利弗。如人已见转轮圣王。则不求见诸余小王。菩萨亦尔。若已发起菩提之心。则不更发声闻缘觉心。舍利弗。如余处中不出众宝。众宝要出于大海中。舍利弗。声闻宝中不出三宝。三宝要从菩萨宝出。舍利弗。譬如太子不名为王。非不名王。菩萨摩诃萨亦复如是。非名为佛非不名佛。舍利弗。譬如小宝亦不可轻。何以故。如是小宝能作大事多所利益。菩萨亦尔。初发心时亦不可轻。舍利弗。我今为诸菩萨摩诃萨说如是喻。若有菩萨闻是诸喻即得安乐。尔时世尊即说颂曰

  若欲证得于佛道　　应当除灭疑网心
  勤修无上信心者　　即能获得于菩提
  若修净印三昧者　　宣说诸法皆如梦
  无量世中净其心　　即能得证正觉道
  佛所得道非身业　　亦非口意二业等
  无为真实性亦尔　　是故不可以喻说
  佛道无对不可见　　非眼识界如虚空
  非是一切诸情根　　又非诸根之境界
  非相非阴非入界　　非是心意受想识
  非知非知之境界　　是故佛境不可知
  诸佛大悲难思议　　无量无边无障碍
  无字无声不可说　　是故无能知佛界
  若有众生无量世　　亲近善友听正法
  闻已即得大福德　　常受妙乐如先佛
  一切诸魔不得短　　诸根调伏行乐处
  能以方便坏四魔　　如法而住行佛界
  若行如是菩提道　　即得菩提为人说
  能渡众生生死海　　能破一切大邪见
  即得无上相好等　　成就十力四无畏
  能知众生烦恼行　　能坏一切诸有道
  若有菩萨勤精进　　即能破坏诸烦恼
  如火能焚干草木　　菩提心能烧烦恼

尔时世尊复告海慧菩萨言。善男子。菩萨摩诃萨勤行精进。易得阿耨多罗三藐三菩提。谁有修行勤精进者。当知是人即有菩提。谁有精进是人即具檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。能自利益亦利于他。善男子。过去无量劫有佛世尊。号勤精进如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名善见劫名华聚。尔时世界大水弥满。其水出生八万四千上妙莲华。一一纵广满十由旬。有无量亿金色光明。其香微妙。阿迦腻吒诸天。见已多受安乐。作如是言。是世间中多有莲华。当知亦当多有佛出。是故此劫名曰华聚。是时彼国寂静无声。以寂静故。无量世界诸菩萨等常乐观察。以观察故各各皆得喜行三昧。是故彼世名曰善见。其国多有七宝林树楼阁殿舍。众生安乐如兜率天。多饶饮食易获神通。无有女身一切化生。亦无二道皆修大乘。尔时彼佛有三万六千出家菩萨皆悉获得不退转心。无量人天初发菩提坚固不退。彼佛世尊常乐宣说勤精进行。时大众中有一菩萨。名坚固庄严。从座而起前礼佛足。长跪合掌作如是言。世尊。云何菩萨勤行精进。佛言。善男子。勤行精进凡有四法。何等为四。一者发心。二者作心。三者观心。四者如法住。如是四法即是具足佛法因缘。何以故。善男子。发者即是生善法因。作者名为增善法因。观者名为利众生因。如法住者名入一切佛法因缘。又复发者求闻正法。作者闻已能说。观者善思惟义。如法住者如说而住。又复发者调伏悭心。作者能一切施。观者为众生施回向菩提。如法住者不求施果。又复发者求觅受人。作者见来求者生慈愍心。观者观财无常。如法住者不求果报。又复发者如法求财。作者求于净命。观者于不坚物修于坚法。如法住者一切舍时不生憍慢。又复发者离诸恶戒。作者至心受持诸净禁戒。观者至心调伏毁禁之人。如法住者净持禁戒不生憍慢。又复发者净于口业。作者净于身业。观者净于意业。如法住者修集善法。又复发者远离嗔心。作者修集忍辱。观者将护自他。如法住者修忍辱已不生憍慢。又复发者常乐教化邪见众生。作者能坏众生嗔恚之心。观者不见内外。如法住者远离一切烦恼诸结。又复发者远离懈怠。作者勤修精进。观者调伏一切懈怠众生。如法住者劝诸众生令修精进。又复发者名为善慈。作者所作已竟。观者不求余乘。如法住者不失无上菩提之心。又复发者庄严禅支。作者庄严三昧。观者终不生于相似我慢。如法住者破坏众生行恶之心。又复发者庄严念心。作者庄严诸有。观者其意坚固。如法住者勇健无怯。又复发者名如法因。作者名如方便。观者名为门户。如法住者名为解脱。又复发者谓求名字。作者持于文字。观者字不可说。如法住者远离文字。又复发者离恶知识。作者亲近善友。观者于善友所至心听法。如法住者不谬解义。又复发者乐于舍家。作者远离怨亲。观者求于善法。如法住者不随他意。又复发者所谓少欲。作者所谓知足。观者易养易满。如法住者善知时宜。又复发者如戒而学。作者于戒不漏。观者如意学戒。如法住者如慧学戒。又复发者檀波罗蜜尸波罗蜜。作者羼提波罗蜜。毗梨耶波罗蜜。观者禅波罗蜜。般若波罗蜜。如法住者智波罗蜜。方便波罗蜜。又复发者行施摄取。作者软语摄取。观者利他摄取。如法住者同利摄取。又复发者所谓大慈。作者所谓大悲。观者所谓大喜。如法住者所谓大舍。又复发者护持正法。作者净于福田。观者庄严相好。如法住者调伏众生。又复发者实知阴魔。作者离烦恼魔。观者坏于死魔。如法住者摧伏天魔。又复发者谓身念处。作者谓受念处。观者谓心念处。如法住者谓法念处。又复发者了了知苦。作者远离于集。观者证真实灭。如法住者谓修于道。又复发者所谓信根。作者谓精进根。观者所谓念根。如法住者所谓慧根。又复发者谓七觉分。作者谓八正道。观者谓舍摩他。如法住者毗婆舍那。善男子。如一切行皆名为发。修一切善悉名为作。一切净心名之为观。知一切业名如法住。善男子。彼佛复告坚固庄严。善男子。勤精进者寂静其心。心若寂静即是精进。若坏贪身即是精进。若知身意即是精进。断我我所即是精进。断诸系缚即是精进。障烦恼尽即是精进。若能远离一切障碍即是精进。若能除却十种憍慢即是精进。能坏贪恚即是精进。若能远离无明有爱即是精进。若不放逸者修于善法即是精进。若能真实观内外入即是精进。若真实知阴界诸入即是精进。心寂静者即是精进。破坏疑心即是精进。若于三世不分别者即是精进。若观法界不动转者即是精进。若不漏者即是精进。若不害者即是精进。若不生悔即是精进。若不求者即是精进。若不灭者即是精进。若不作者即是精进。若无增减即是精进。无上无下即是精进。不舍不着即是精进。不缚不解即是精进。不去不来即是精进。不生不灭即是精进。非有放逸非不放逸即是精进。无作作者即是精进。无闇无明即是精进。非见非不见即是精进。善男子。彼佛说是精进法时。无量菩萨得无生忍。善男子。今此会中五千菩萨亦得如是无生忍法。七千天人发阿耨多罗三藐三菩提心。善男子。尔时坚固庄严菩萨闻是法已。为得如是无量法故。勤修精进获得下忍。为求法故不坐不卧乃至命终。既舍身已得生梵世。受梵天身于无量世。供养于佛听受正法。于彼劫中。周遍供养八万四千诸佛如来。听受正法勤行精进。善男子汝知。尔时坚固庄严岂异人乎。即我身是。善男子。我久具足是精进故。超弥勒等诸大菩萨先成正觉。是故我言谁有精进。当知是人即有菩提。善男子。我勤精进犹尚难得阿耨多罗三藐三菩提。况懈怠耶。若有菩萨能精进者。是人则能自利利他。尔时世尊即说颂曰

  我念过去无量世　　花聚劫中精进佛
  善见世界水弥满　　出生八万四千花
  其国犹如兜率天　　丰饶饮食无女身
  不由父母悉化生　　亦无二道纯一乘
  十方世界诸菩萨　　观善见国受安乐
  三万二千出家众　　无量人天发菩提
  尔时彼佛赞精进　　唯为坚固菩萨说
  若能发心勤修善　　系心思惟如法住
  尔时世尊为我故　　分别广说是四句
  发菩提心如法行　　思惟得忍如法住
  若求正法名初发　　如法而说名为作
  受义不谬善思惟　　修集于忍如法住
  若勤行施是初发　　求觅受者名为作
  明见无常善思惟　　不观二相如法住
  如法求财是初发　　清净活命是名作
  破坏悭心善思惟　　不求憍慢如法住
  远离恶戒是初发　　不漏护戒是名作
  调伏毁戒善思惟　　戒净无慢如法住
  远离恶口是初发　　其心寂静是名作
  其心寂静善思惟　　诸法寂静如法住
  远离害心是初发　　修集忍辱是名作
  将护自他善思惟　　忍不生慢如法住
  诱喻嗔者是初发　　远离恶人是名作
  内外寂静善思惟　　不着我心如法住
  远离懈怠是初发　　勤修精进是名作
  知于真实善思惟　　修集于道如法住
  始求善法是初发　　求已毕竟是名作
  念心受持善思惟　　不失于法如法住
  求于禅支是初发　　修集三昧是名作
  无相似慢善思惟　　无有过失如法住
  念慧之心是初发　　获得法门是名作
  拥护正法善思惟　　勇健精进如法住
  正念因缘是初发　　修善方便是名作
  观于内法善思惟　　得解脱已如法住
  始求文字是初发　　通达解了是名作
  知不可说善思惟　　了无文字如法住
  远离恶友是初发　　亲善知识是名作
  闻已如闻善思惟　　不远离法如法住
  佛法出家是初发　　除舍怨亲是名作
  修集善法善思惟　　不随他意如法住
  少欲知足名发作　　乐于寂静善思惟
  住寂静已说无诤　　亦自修集如法住
  从戒而学是初发　　不行漏戒是名作
  无戒之戒善思惟　　从智慧戒如法住
  不说世事是初发　　常乐寂静是名作
  易养易满善思惟　　观察无常如法住
  乐修施戒是初发　　忍辱精进是名作
  修禅智慧善思惟　　修智方便如法住
  行施摄取是初发　　软语摄取是名作
  利益众生善思惟　　自利利他如法住
  修集慈悲名发作　　不别三世善思惟
  为诸众生净身心　　修集喜舍如法住
  获得正法是初发　　清净福田是名作
  庄严自身善思惟　　调伏众生如法住
  破坏阴魔是初发　　离烦恼魔是名作
  能坏死魔善思惟　　摧魔怨敌如法住
  修集身念是初发　　修集受念是名作
  修集念心善思惟　　修集法念如法住
  了了知苦是初发　　远离于集是名作
  证灭真实善思惟　　修于正道如法住
  修于信根是初发　　修集诸力是名作
  修念三昧善思惟　　修于智慧如法住
  身心寂静是初发　　远离邪见是名作
  观于名色善思惟　　精进不悔如法住
  无我我所是名发　　无缚无解是名作
  无去无来善思惟　　法性不动如法住
  远离憍慢是初发　　除去贪恚是名作
  观十二缘善思惟　　离痴有爱如法住
  若能远离一切相　　破坏所有诸障碍
  具足十力四无畏　　能说功德勤精进
  如来说是精进法　　十千众生悟无生
  五千菩萨得法忍　　无量人天发菩提
  坚固庄严我身是　　精进超过诸菩萨
  若欲获得上真道　　当修精进如先佛

尔时修悲梵天。语海慧菩萨言。所言佛法。佛法者云何名佛法。海慧菩萨言。梵天。佛法者名一切法。一切法者名为佛法。如佛法性即一切法性。如一切法性即佛法性。佛法性一切法性无有差别。一切法寂静佛法亦寂静。一切法空佛法亦空。梵天。一切法即十二因缘。菩提者亦十二因缘。梵天言。善男子。夫佛法者将不过于三界法耶。梵天。三界佛法性无差别。三界平等佛法平等无有二相。善男子。譬如虚空无有增减。佛法亦尔。无增无减性是空故无上无下。梵天若善男子。欲见佛法当作是观。复次梵天。夫佛法者非处非非处。非生非灭。非青黄赤白班驳琉璃虚空界色。杂色无色。非有形质方圆修短。无相无相相。无缚无解。无如是相名为佛法。无相无句无有文字。清净寂静。空义。无相义。无聚义。毕竟无出义。觉知义。不可宣说不可睹。不可见者名寂静义。寂静义者即是空义。空义者即无聚义。无聚义者即真实义。真实义者即是毕竟不出之义。毕竟不出义者即不灭义。不灭义者即无处义。无处义者即是法性。法性者即是佛法。是名学法名阿罗汉法名缘觉法。名为佛法。如是佛法及余诸法。亦无住处不出不灭。无色形质方圆修短。无智相貌无明无闇。一切诸法等无差别。求佛法者。谓佛佛法及一切法。菩萨摩诃萨坐于道场菩提树下。乃能了了真实知见。何以故。诸佛正法无住处故。一切诸法亦无住处。佛法不可得。一切诸法亦不可得。佛法平等。一切诸法亦复平等。若无因缘即无种性。若无种性即无出灭。若无出灭即名真实。真实知者即是实性。过去未来现在诸法即是佛法。何以故。通达三世无障碍故。无障碍者即是佛智佛智者即是十八不共之法。不共之法者摄一切法。是故诸法即是佛法。诸法佛法无二无别。梵天言。善男子。汝今了了见佛法不。梵天。佛法非色不可睹见。汝云何言了了见耶。一切诸法悉不可见。夫了了者即是佛法。无有二相。梵天言。善男子。如来何故。说佛知见一切诸法。梵天。如来佛法若有定相。可得说言了了知见。善男子。佛法无耶。梵天。法若无定不可说有。不可说无。若不可说有无相者。云何得言了了知见。善男子。如来云何说于佛法。梵天。如说虚空。虚空之性实无定相。佛法亦尔。善男子。佛法如是不可思议。菩萨初发菩提心时。闻如是法不惊不怖不可思议。正觉之性亦不可思议。梵天。佛所说者。乃能发是菩提之心。是故闻之不生怖畏。梵天。若有著者则生怖畏。若不著者不生怖畏。惜身命者则生怖畏。不惜身命无所怖畏。有障碍者则生怖畏。无障碍者无所怖畏。着我我所则生怖畏。断我我所无所怖畏。善男子。菩萨摩诃萨有何力故闻深佛法不生怖畏。梵天。有八种力。闻深佛法不生怖畏。何等为八。一者信力。二者善友力。三者多闻力。四者善根力。五者善思惟力。六者破憍慢力。七者大慈悲力。八者如法住力。梵天。菩萨具足如是八力。闻说深法不生怖畏。尔时世尊赞海慧菩萨言。善哉善哉。善男子。善能宣说菩萨诸力。实如汝言。菩萨具足如是诸力。闻深佛法不生怖畏。善男子。一切言说名之为声。菩提之性亦不可说亦不可见。不可说见名第一义。如来了了知见如是不可宣说。愍众生故而为宣说菩提。非心亦非心数。何况声字。善男子。如来怜愍诸众生故觉甚深法。觉甚深法已。无知无觉无心心数。无声无字不可宣说。为众生故说有文字音声次第。善男子。譬如虚空非是色法。不可睹见非对非作。善男子有人善画画空作像。若男若女若象若马。如是之人可思议不。不也世尊。善男子。是犹可信。如来世尊知不可说。而能演说是事甚难。虽复说此不可说法。然真实知性不可说。善男子。若闻是法不惊不怖。当知是人久于无量诸如来所种诸善根。善男子。如是经典不可思议。若有人能受持读诵书写解说。是人则能受持一切诸佛。法藏。摄取一切众生解脱。善男子。若有菩萨了了得见无量世界所有诸佛。见已即以上妙七宝满是世界。持用奉献诸佛世尊。是人福德宁为多不。甚多世尊。如是功德难以喻说。善男子。不如有人拥护正法为怜愍故。受持读诵解说是经。何以故。法施之施胜于食施。夫食施者即是世施。法施之施是出世施。善男子。若人能护佛正法者。即为四摄。何等为四。一为佛摄。二为天摄。三为福摄。四为智摄。佛摄众生。复有四事。一者常得亲近诸佛。二者诸魔不得其便。三者获得无尽陀罗尼。四者得住不退转地。天摄众生。亦有四事。一者说法之处诸天清净。二者说法之时众乐受听。三者终不为他因缘所害。四者不信者信。福摄众生亦有四事。一者庄严于身。三十二相八十种好。二者庄严于口。凡所演说众生乐闻。三者庄严佛土。四者庄严种姓。所谓释梵转轮圣王。智摄众生亦有四事。一者知众生根如意说法。二者知众生病苦随病施药。三者得大神通游诸佛土。四者了了通达法界。善男子。若欲获得如是功德。应当勤心护持正法。尔时世尊即说颂曰

  若能护法生怜愍　　受持是经及广说
  我说千分中一分　　犹如大海取一渧
  知恩念恩念如来　　是人可信付法藏
  供养无量十方佛　　如是则能护佛法
  虽施无量国珍宝　　不如至心诵一偈
  法施最妙胜食施　　是故智者应护法
  十方诸佛天龙神　　功德智慧所摄取
  庄严修行诸相好　　是人皆由护正法
  常遇诸佛善知识　　常闻无上真实道
  速得无量陀罗尼　　是人皆由护正法
  身口意戒得清净　　具大神通游诸国
  不退菩提具六度　　是人皆由护正法
  世界微尘可说尽　　护法功德不可量
  欲得不可宣说知　　应当坚心护正法

尔时众中有一菩萨。名功德宝光。即从坐起头面敬礼长跪合掌前白佛言。世尊。如来于是大经典中。说言佛法不可宣说。若不可说云何可护。佛言。善哉善哉。善男子。如是如是。如来正法实不可说。如来觉知不可说法。如是正法虽不可说而有字句。以字句故可得宣示。如是字句受持读诵书写解说。是名护法。善男子。复有护法。见有受持读诵书写解说之者。恭敬供养亲近礼拜尊重赞叹。生于师想拥护供给衣服饮食卧具汤药房舍灯烛。闻其所说称赞善哉。护其种姓所住宅舍。亦复护其侍使之等。闻恶隐蔽闻善称扬。善男子。若能拥护是持法者。是人即能护佛法僧。复次善男子。若有能修空无相愿。是人即是护持正法。复次善男子。见有诽谤方等经者不与同止。言语谈论调伏其罪。是人即是护持正法。复次善男子。若有人能修集悲心。无饮食想怜愍众生。宣说正法是名护法。复次善男子。不惜身命受持读诵书写解说如是等经。是名护法。复次善男子。若有听法一字一句。往一由旬乃至七步入出息顷。是名护法。善男子。过去无量阿僧祇劫有佛号曰大知声力如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。国名净光。劫名高显。其土纯是青琉璃宝。诸菩萨众一切成就无量势力。具足神通智慧无碍。一切菩萨悉受天身至心听法。无有出家在家差别。尔时世尊为护法故。与诸大众颁宣正法。彼时会中有一菩萨名曰法慧。白佛言。世尊。何等是法而言拥护。佛言。善男子。夫六入者乐求境界。若能遮止是名护法。善男子。眼识于色是名非法。若能远离是名护法。乃至意识于法亦复如是。善男子。若见眼空见已不观于色不着于识。是名为法。若能真实知如是法。是名护法。乃至若见意空。见已不观于法。不着于识是名为法。若能真实知如是法。是名护法。善男子。若法能生法。于是法中不求不取。心不贪着。是名护法。若有见法能生邪见。于是见中不求不取心不贪着。是名护法。若有无明不能净心。于是垢中不求不取心不贪着。是名护法。善男子。若有一法求取之后不能施人。此法非法亦非比尼。若能施者即是正法即是比尼。若有无取无求无施。即是正法即是比尼。夫取求者即是非道。若不施即是非法即非比尼。若能施者即是正法即是比尼。不取不求不施。即是不出不生不灭。若非出生灭云何可施。不可施者乃名为法。乃名比尼。何以故。未生烦恼作障因缘故。是故无尽。无尽者无出。无出者名为法。名为比尼。于如是法不求不取。是名护法。善男子。尔时彼佛说是法时。三万二千菩萨。得无生法忍。海慧菩萨言。世尊。如我解佛所说义者。法及非法是名为法。何以故。若有分别法非法者。是人不名护持正法。若作法相是名非法。世尊。若能了达见一切法是无法者是名第一真实之义。世尊。若无法无非法即是无数。若无数者即是实性。实性者名为虚空。虚空之性无边无节。法性亦尔。法性实性无有差别。何以故。无边无节故。若有菩萨。见如是等即真实见。世尊。我不见一法。以不见故不见有增不见有减。世尊。我如是见。将不诽谤如来说耶。是实见不。善男子。如是见者不谤如来。是真实见。说是法时。海慧菩萨及万天人得无生忍。善男子汝知。尔时海慧菩萨岂异人乎。即我身是。是故我于无量世中。所求正法今以付汝。尔时众中有六万亿诸菩萨等。同共发声白佛言。世尊。我等当共拥护正法受持广说。佛言。善男子。汝今云何如法而住护持正法。山王菩萨即作是言。世尊。惜身命者不能护法。我不惜命如法而住。故能护法。功德山王菩萨言。世尊。有贪利者不能护法。我无贪利故能护法。宝幢菩萨言。世尊。若见有法非法二相不能护法。我无二相故能护法。福德藏菩萨言。世尊。具烦恼者不能护法。我有智力已远离之故能护法。持炬菩萨言。世尊。不破闇者不能护法。我今破闇故能护法。电光菩萨言。世尊。若随他心不能护法。我随自意故能护法。遍藏菩萨言。世尊。不调诸根不能护法。我今调伏故能护法。净光菩萨言。世尊。若作种种诸法相者不能护法。我今于法无种种相故能护法。增行菩萨言。世尊。心狂乱者不能护法。我修三昧故能护法。商主菩萨言。世尊。不知道者不能护法。我今了知故能护法。善念菩萨言。世尊。有疑心者不能护法。我已断疑故能护法。善见菩萨言。世尊。不如法住不能护法。我如法住故能护法。慧光菩萨言。世尊。愚痴之人不能护法。我今修智故能护法。平等菩萨言。世尊。取怨亲相不能护法。我今平等故能护法。法行菩萨言。世尊。不知众生诸根境界不能护法。我今知之故能护法。神通王菩萨言。世尊。见我我所不能护法。我今不见故能护法。师子吼菩萨言。世尊。不知佛性不能护法。我今知之故能护法。弥勒菩萨言。世尊。若远菩提不能护法。我今已近故能护法。功德聚菩萨言。世尊。若无无量功德聚者不能护法。我今已有故能护法。文殊师利言。世尊。如是等语悉是谬语。何以故。如来世尊。坐于道场菩提树下不得一法。汝云何言我当护法。世尊。我于诸法不取不舍。为众生故修集悲心不护不舍

尔时佛赞文殊师利言。善哉善哉。善男子。如来昔坐菩提树下实无所得。无所得故便从中起。文殊师利言。如来真实坐于道场菩提树耶。何故而言从坐而起。世尊。如来若坐菩提树下。如来世尊则有二相。一者如来。二者菩提。如来世尊已离二相。佛言。善男子。菩提众生一切法性等无差别一味一性。如来坐于菩提树下见如是法。是故名为逮得菩提。我都不见离菩提外别有一法。见一切法皆悉平等。而是平等不入于数。是故平等名为无碍。以是因缘如来名为一切无碍。善男子。若能如是见如来者。是人即得如来解脱。得解脱已则能如是真实知见。说是法时。海慧菩萨所将眷属诸菩萨等。欢喜踊跃各作是言。我等今者得大利益。现见释迦牟尼如来。及见文殊师利菩萨。世尊。随是经典所住世界。当知其土得大利益。若有供养是经典者。及有受持读诵书写广说其义。亦得利益。尔时世尊。告诸菩萨言。汝今知得何等利益。诸菩萨言。世尊。我等当以如是之义咨问文殊。诸菩萨言。文殊师利。云何名为得大利益。文殊师利言。有十利益。何等为十。佛出于世见已生信。既生信已听受正法。闻正法已永坏疑心。坏疑心已得清净命。得清净命已不为利说法。彼闻法已发菩提心。既发心已坚固不退。心不退已如法而住。如法住已得无生忍。诸善男子。是名十利不可思议。说是法时。三万六千众生。发阿耨多罗三藐三菩提心。三千大千世界大地。六种震动。出金色光

大方等大集经卷第九大方等大集经卷第十

        北凉天竺三藏昙无谶于姑臧译

    海慧菩萨品第五之三

尔时海慧菩萨白佛言。世尊。是大乘经能多利益无量众生。何以故。一切众生因大乘故。得人天乐及涅槃乐。世尊。夫大乘者。何法摄取。何法利益。何法难得。何法障碍。何因缘故名为大乘。佛言。善男子。有一法摄取大乘。所谓初发菩提之心。既发心已修不放逸。复有一法明信业果。复有一法观十二缘。复有一法于诸众生其心平等乐修大慈。复有一法谓不退失菩提之心。复有一法所谓念佛。复有一法如法住已念于正法。复有一法以不退心念于众僧。复有一法不失道心念于净戒。复有一法远离烦恼心念于舍。复有一法欲得无量寂静之身专念于天。复有一法念欲安隐一切众生。复有一法勤行精进。复有一法欲令众生悉得解脱。得解脱已受于喜乐。复有一法乐求正法。复有一法远离退心为众说法。复有一法于听法者生爱念心。复有一法于说法者乐为供养。复有一法于正法中生药树想。复有一法于自己身生大医想。复有一法至心专念护持正法。复有一法绍隆三宝不令断绝。复有一法远离懈怠。复有一法所谓知足。复有一法于一切财无贪悭想。复有一法自持戒已能化毁禁。复有一法自修忍已。能化众生令离嗔心。复有一法得少利益生大恩想。复有一法少得恩分生大报想。复有一法自持净戒不轻毁禁。复有一法破于憍慢。复有一法至心求觅听法之人。复有一法离恶知识。复有一法至心修善。复有一法不随他意。复有一法调伏诸根。复有一法于法师心如如来想。复有一法不惜身命护持正法。复有一法行于世法不为沾污。复有一法不惜身命求于正法。复有一法调伏众生受苦不恨。复有一法如来现在若涅槃后。供养塔像等无有二。复有一法众生不请乐为善友。复有一法于好物中心无贪着。复有一法乐念出家。复有一法乐称人善。复有一法乐求庄严菩提之法。复有一法于同师同学心无嫉妒。复有一法教化众生发菩提心心无悔退。复有一法覆藏他过。复有一法求一切语。复有一法求一切作。复有一法所谓实语。复有一法发言之后要终其事。复有一法于善法所心无厌足。复有一法随所得物悉与人共。复有一法善知魔界。复有一法破坏憍慢修真实知。复有一法心乐寂静。复有一法离我我所。复有一法不自赞叹。复有一法随俗而行。复有一法修正命已乐于寂静。复有一法持净戒已思惟善法。复有一法修多闻已不生憍慢。复有一法修善行已即住初地。复有一法修空三昧观于法性。复有一法得供养已其心不高。复有一法乐说世者不与同止。复有一法得如法物与同学共。复有一法真实方便。复有一法一切知已不生贪想。复有一法未学学已心不生悔。复有一法既学知已心不轻慢。复有一法遇骂辱已心不生嗔。复有一法供养骂辱其心无二。复有一法闻说正法称赞善哉。复有一法为欲具足六波罗蜜常求庄严。复有一法信心不退。复有一法为菩提道求于庄严。复有一法受供养已常净己心。为令施主得大利益。复有一法具足七财。复有一法能破众生贫穷困苦。复有一法以善方便调伏众生。复有一法以四摄法摄取众生。复有一法不与众生而共诤讼。复有一法闻法之时于法师所不求其短。复有一法未得无上沙门果证心不生悔。复有一法常行世间。不为八法之所染污。复有一法常观己过。复有一法于举罪者不生嗔恚。复有一法见世间法其心生舍。复有一法不诳善友。复有一法先净其心教他令净。复有一法不为利养受持净戒。复有一法为增善法修集寂静。复有一法为于善法修净庄严。复有一法为净功德而修庄严。复有一法为净智慧而修庄严。复有一法修集无想三昧方便。复有一法如法而忍。复有一法修三解脱。复有一法知处非处。复有一法修舍摩他。为欲庄严毗婆舍那。复有一法知于解脱。复有一法观于三世等。复有一法谓不分别一切法界。复有一法一切法性不生不灭。菩萨摩诃萨观是百法。如是名为摄取大乘尔时世尊。复告海慧菩萨言。善男子。有二法利益大乘。一者乐念佛法。二者乐离声闻。复有二法。一者拥护解脱。二者能演说法。复有二法。一者求菩提心。二者调伏众生。复有二法。一者观菩提心犹如幻相。二者观诸众生悉无有我。复有二法。一者不舍菩提之心。二者观法平等。复有二法。一者净于善根。二者无作无净。复有二法。一者为善法故而修庄严。二者毕竟。复有二法。一者自身毕竟。二者众生毕竟。复有二法。一者内净。二者外净。复有二法。一不作罪。二作已悔。复有二法。一能布施。二不求报。复有二法。一平等施。二能回向。复有二法。一者持戒。二者不求善果。复有二法。一不自誉。二不毁他。复有二法。一者忍辱。二者软语。复有二法。一者于贪不贪。二者于嗔不嗔。复有二法。一者为于善法勤修精进。二者不轻懈怠。复有二法。一身寂静。二心寂静。复有二法。一求禅支。二调伏心。复有二法。一乐在禅定。二不厌欲界。复有二法。一者求法。二者乐法。复有二法。一者乐观法。二者欲法。复有二法。一者乐求善友。二者恭敬供养。复有二法。一至心听。二至心受。复有二法。一数咨问。二如法住。复有二法。一者知法。二者知义。复有二法。一者闻已无厌。二者知已无厌。复有二法。一者修善。二者离恶。复有二法。一者乐说正法。二者于受法者生怜愍心。复有二法。一者于法无悭吝心。二者说时无有食想。复有二法一者至心听。二至心受。复有二法。一离五盖。二修七觉。复有二法。一者喜。二者乐。复有二法。一者知已。二者知时。复有二法。一信果报。二作善业。复有二法。一者不断圣性。二者实语。复有二法。一者如说而住。二者不藏如来功德。复有二法。一者净身。二者远离三不善根。复有二法。一者观身犹如草木。二者为净心故修行善法。复有二法。一者净口。二者远离四过。复有二法。一者观一切法悉不可说。二者观声如响。复有二法。一者净心。二者远离无明嫉妒邪见。复有二法。一者内净。二者外无行处。复有二法。一者修慈。二者远离亲怨之想。复有二法。一观众生犹如虚空。二者修慈。复有二法。一者不舍悲心。二者求善不悔。复有二法。一者能调不调。二者调时不悔。复有二法。一者持法。二者护持法者。复有二法。一者乐法。二者护法。复有二法。一者称扬人善。二者乐藏他过。复有二法。一者离贪。二者离嗔。复有二法。一者不舍众生。二者修舍。复有二法。一者念佛。二者知无念处。复有二法。一者观身。二者求三十二相。复有二法。一者念法二者化诸众生令住法中。复有二法。一者观无贪处。二者于贪者所生于悲心。复有二法。一者念菩萨僧。二者依无退僧。复有二法。一者观于无僧。二者拥护四沙门果。复有二法。一者念戒。二者知菩提心不可宣说。复有二法。一者观戒无住。二者护毁禁者。复有二法。一者念施。二者施已无悔。复有二法。一者远离烦恼。二者离烦恼故演说正法。复有二法。一者念天。二者乐寂静。复有二法。一者具足念心。二者拥护乱心。复有二法。一者功德庄严。二者智慧庄严。复有二法。一者观无造作。二者乐修善法。复有二法。一者无缚。二者缚者解脱。复有二法。一者远离诳心。二者至心清净。复有二法。一者知恩。二者念恩。复有二法。一者说一切过。二者而远离之。复有二法。一者自修圣行。二者化他令行。复有二法。一者愿求善法。二者心无厌足。复有二法。一者远离恶法。二者亲近善法。复有二法。一者请佛说法。二者至心听受。复有二法。一者知一切法不生不灭。二者说字句义。复有二法。一者知无众生。二者以己善根与众生共。复有二法。一者远离诸相。二者深求三十二相。复有二法。一者观空。二者将护众生。复有二法。一者修集无愿。二者及愿众生。复有二法。一者修一切善。二者愿诸众生同修善根。复有二法。一者智慧无碍。二者受诸有身。复有二法。一者不动。二者不悔。复有二法。一者惭。二者愧。复有二法。一乐寂静。二求静法。复有二法。一者修集无诤三昧。二者观无众生。复有二法。一者少欲。二者知足。复有二法。一者覆藏他罪。二者显露己过。复有二法。一者观十二因缘。二者深信。复有二法。一者无我。二者无众生。复有二法。一者防自烦恼。二者坏他烦恼。复有二法。一者观无作无受。二者乐修善法。复有二法。一者观生死过。二者不断生死。复有二法。一者自乐生死。二者化诸众生令度生死。复有二法。一者求波罗蜜。二者求已无处。复有二法。一者求智。二者化他令同己智。复有二法。一者不求供养。二者为供养故造作诸业。复有二法。一者于有恩处常欲报之。二者于恩无恩等而报之。复有二法。一者修不放逸。二者修无缘慈。复有二法。一者入于出家。二者既出家已心生爱乐。复有二法。一者自成功德。二者于无德者生怜愍心。复有二法。一者修于身念。二者无有念处。复有二法。一者念于受处。二者无有念处。复有二法。一者念于心处。二者无有念处。复有二法。一者念于法处。二者无有念处。复有二法。一者远离不善之法。二者亲近能生善法。复有二法。一者远离已生恶法。二者护持已生善法。复有二法。一者为令未生善法得生。二者为令增广而拥护之。复有二法。一者获大神通。二者得已教化众生。复有二法。一者安住法界。二者遍见诸佛世界。复有二法。一者信心不动。二者化不信者令同己信。复有二法。一者净心。二者教化狂乱之人。复有二法。一勤精进。二化懈怠。复有二法。一者具足无碍智慧。二者化彼无明众生。复有二法。一者观界。二者观缘。复有二法。一者求智庄严。二者其心不悔。复有二法。一者观诸烦恼。二者出烦恼已了知解脱。复有二法。一者一切法解脱。二者烦恼不合三界。复有二法。一者庄严菩提。二者修学菩提。复有二法。一者尽智。二无生智。复有二法。一者观圣道方便。二者观生死方便。复有二法。一者毕竟道。二者知退转道。复有二法。一者如法而住。二者于诸法中不生着见。复有二法。一者从缘生灭。二者从缘解脱。复有二法。一知魔业。二知已离。复有二法。一者于恚生忍。二者于忍生爱。复有二法。一者为菩提故而修庄严。二者虽修庄严心无贪着。复有二法。一者不舍烦恼。二者不舍修善庄严。复有二法。一者知处非处。二者以诸善根回向菩提。复有二法。一者观菩提心犹如幻相。二者修向无上菩提庄严。复有二法。一者观诸众生及以菩提等无差别。二者知诸众生因缘菩提而得解脱。复有二法。一者知法无生。二者为善法故而修庄严。复有二法。一者不可说法而能宣说。二者一切众生悉同一乘。复有三法。一者初发菩提之心。二者亲近善友心不生悔。三者修集大悲心不退转。复有三法。一者破坏悭吝。二者惠施一切。三者摄取菩提。复有三法。一者具足净戒。二者调伏毁禁。三者回向菩提。复有三法。一者心不嗔恨。二者调嗔恚者。三者回向菩提。复有三法。一者于生死中心无悔退。二者甘乐营他所作事业。三者回向菩提。复有三法。一者得三昧定。二者不生憍慢。三者回向菩提。复有三法。一者求于多闻。二者得已不生憍慢。三者回向菩提。复有三法。一者生缘。二者法缘。三者无缘。复有三法。一者自悲。二者悲他。三者离自他悲。复有三法。一者为于自利修集智慧。二者以是智慧转化众生。三者自利利他。复有三法。一者知过去已尽。二者知未来无生。三者知现在无住。复有三法。一者为正定者修集慈心。二者为邪定者修集悲心。三者为不定者修集解脱。复有三法。一者净身。二者净口。三者净意。复有三法。一者修不净观为坏贪欲。二者修慈为坏嗔恚。三者观十二因缘为坏无明。复有三法。一者安。二者乐。三者知足。复有三法。一者闻已能持。二者能广分别文字句义。三者观察罪过。复有三法。一者具足七财。二者能大法施。三者能施众生。复有三法。一者实义。二者真义。三者不诳义。复有三法。一者自知。二者知他三者知时。复有三法。一者五阴法阴平等。二者诸界法界平等。三者诸入法入平等。复有三法。一者修空。二者无相。三者无愿。复有三法。一者不谤因果。二者方便生法皆从因缘。三者和合因缘而得名字。复有三法。一者信佛不可思议。二者信法不生诽谤。三者信僧良祐福田。复有三法。一者远离贪欲。二者远离嗔恚。三者远离愚痴。复有三法。一者世谛。二者第一义谛。三者不着二谛。复有三法。一者远离烦恼。二者远离憍慢。三者于福田所礼拜供养。复有三法。一者不染欲界。二者不着色界。三者于无色界不生憍慢。复有三法。一者供养不喜。二者毁辱不恚。三者离世八法。复有三法。一者藏覆诸根。二者解了诸根。三者寂静诸根。复有三法。一者趣向善地。二者离善地障。三者观善地德。复有三法。一者至心。二者净心。三者净庄严。复有三法。一者学戒戒。二者学心戒。三者学慧戒。复有三法。一者受乐不生贪逸。二者受苦不生恼恚。三者不苦不乐修集于舍。复有三法。一者转因不造作故。二者转于烦恼不观相故。三者转于三世无愿求故。复有三法。一者眼空。二者色寂静。三者受无住处。复有三法。一者藏戒。二者护定。三者观慧。复有三法。一者忆持念法。二者思惟观法。三者如法而住。复有三法。一者音声因缘声闻解脱。二者十二因缘缘觉解脱。三者六度因缘菩萨解脱。复有三法。一者施。二者大施。三者毕竟施。复有三法。一者护法。二者护持正法。三者护持大乘。复有三法。一者行于生死。二者观其罪过。三者知已远离。复有三法。一者至心听法破除五盖。二者常乐寂静。三者如法而住。复有三法。一者依义。二者依法。三者依智。复有三法。一者求多闻已乐于寂静。二者乐寂静已思惟善法。三者善思惟已知法平等。复有三法。一者亲近智者。二者咨问多闻。三者护于善人。复有三法。一无贪心为人说法。二见听法者慈心视之。三者一心观于菩提。复有三法。一者视诸众生其心平等。二者观心平等。三者观佛平等。复有三法。一者过去已尽。二者未来不合。三者现在不住。复有三法。一者观苦无常。二者诸法无我。三者涅槃寂静。复有三法。一者闻已坚持。二者三昧坚持。三者智慧坚持。复有三法。一者犯已不覆。二者悔先所犯。三者至心护戒。复有三法。一者破坏疑心。二者破坏悔心。三者破障碍心。复有三法。一者善欲。二者离谈世事。三者乐于寂静。复有三法。一者忍甚深法。二者说甚深义。三者解种种义。复有三法。一者具足声忍。二者具思惟忍。三者具于顺忍。复有三法。一者智慧方便。二者大慈。三者精进坚牢。善男子。菩萨具足如是等法。能利益大乘。善男子。复有四法障碍大乘。何等为四。一者听不应听。二者不欲听受菩萨法藏。三者行诸魔业。四者诽谤正法。复有四法。一者贪欲。二者嗔恚。三者愚痴。四者不乐求法。复有四法。一者嫉他得利。二者于财悭贪。三者乐诳法师。四者不乐亲近见善知识。复有四法。一者于善知识生恶友想。二者于恶知识生善友想。三者非法法想。四者法非法想。复有四法。一者不乐惠施。二者施已生悔。三者施已观过。四者不念菩提心。复有四法。一者为欲而施。二者为嗔而施。三者为痴而施。四者为怖畏而施。复有四法。一者为名字施。二者为本而施。三者为善友施。四者为胜故施。复有四法。一者不至心施。二者不自手施。三者不现见施。四者轻慢施。复有四法。一者下物施。二少物施。三者不至心施。四者轻慢施。复有四法。一者毒施。二者刀施。三者不净施。四者无利益施。复有四法。一者见持戒者生嗔恚心。二者见毁禁者生爱念心。三者随恶友语。四者不念施戒。复有四法。一者非法求利。二者如法得财不与人共。三者断他供养。四者心不知足。复有四法。一者为贪利养故摄持威仪。二者为利养故下声而语。三者其心谄曲。四者邪命自活。复有四法。一者于同学所生嗔恚心。二者于同乘者生嗔恚心。三者不知魔业。四者乐说他过。复有四法。一者憍慢不听正法。二者不能恭敬法师。三者不能礼拜父母师长善友四者意随恶业。复有四法。一者覆他功德。二者广说他过。三者增长憍慢。四者嗔恚坚固。复有四法。一者懈怠。二者不乐听闻善语。三者不随顺语。四者住于非法。复有四法。一者不调。二者不净。三者不藏。四者不忍。复有四法。一者不喜闻受无上善法。二者乐在城邑聚落村屯。三者毁破禁戒乐受供养。四者不能调伏根门。复有四法。一者不能摄取众生。二者不能调伏众生。三者不能护持正法。四者乐说法师过罪。复有四法。一者不修信心。二者不能观察众生罪过。三者不观恶知识过。四者不观疑心罪过。复有四法。一者不观内。二者不观外。三者无惭。四者无愧。复有四法。一不知恩。二不报恩。三者背恩四者乐邪见。复有四法。一者诽谤圣人。二者将护世人。三者不信福田。四者呵毁法施。复有四法。一者不净身业。二者不护口业。三者不舍意业。四者厌悔大乘。复有四法。一者为破和合而作两舌。二者于师和上出嗔恚语。三者为坏利益作无义语。四者欺诳人天而生妄语。复有四法。一者不护戒因。二者乱禅定因。三者不信后世。四者乐着世事。复有四法。一者粗穬。二者憍慢。三者乐说世间。四者常乐睡眠。复有四法。一者假菩萨名而受供养。二者不能瞻视病苦之人。三者不种善子。四者不向菩提。复有四法。一者自轻。二者轻法。三者轻福。四者数念声闻辟支佛乘。复有四法。一者贪身。二者贪心。三者贪命。四者贪戒。复有四法。一者贪房舍。二者贪檀越。三者贪邪见。四者贪破戒。复有四法。一者多作。二者多语。三者多受。四者多视。复有四法。一者我见。二者邪见。三者断见。四者常见。复有四法。一者不作。二者作已转。三者心悔。四者不乐。复有四法。一者不向道地。二者不修禅定。三者退失智慧。四者不乐方便。复有四法。一者障碍于法。二者障碍善业。三者烦恼隐碍。四者魔业障碍。善男子。如是等法名障大乘。说是法时。四万四千人天。发阿耨多罗三藐三菩提心。二万八千菩萨。得无生法忍。三千大千世界大地六种震动。虚空之中无量天人。异口同音作如是言。善哉善哉。世尊。今日如来大师子吼。怜愍众生开大乘门。世尊。若有众生于是法中得少分者。即得断除三恶道苦。渐渐当得无量法宝。譬如有人于村邑外见大宝聚。见已怜愍即还入村告语众人。谁欲断贫当与我俱。是人说时。或有信者或不信者。其中信者即与相随俱至宝所。随意采取即破贫苦。而是宝聚亦无增减。亦不念言听是人取不听彼人。破是人贫不破彼人。听是持去不听彼持。如来世尊亦复如是。于无量世勤求如是无上法宝。求已得见生大怜愍。以大梵音语诸众生。若有欲坏生死贫穷。当至心听。有诸众生薄福不信。则不能坏生死贫穷。其中信者随任智力。取声闻乘辟支佛乘菩萨大乘。是大宝聚亦无增减。若有至此宝聚之中。乃至不能取一宝者。是人常住三恶道中。若有能取一字一句。乃至一念受持之者。是人能坏生死贫穷。何况取是大乘经典一品二品。及其具足听受读诵为人解说。尔时世尊赞诸天人。善哉善哉。诸天子。若有受持如是经典。是人则具一切善法。顶戴如来无上佛智。是大智聚。能大利益无量众生。尔时世尊。以偈颂曰

  诸乘之中大乘最　　犹如虚空无边际
  远离一切生死有　　趣菩提树无障碍
  若能清净其心意　　所有惠施于一切
  至心受持清净戒　　趣菩提树无障碍
  于诸众生心平等　　常观烦恼诸罪过
  能胜一切下劣乘　　调伏众生于大乘
  若有至心受读经　　具足寂静戒忍辱
  具足智慧坏魔众　　怜愍众生趣道树
  庄严慈悲乘四禅　　智慧利刀摧魔众
  道树下观十二缘　　起已愍众说大乘
  十方众生乘大乘　　乘无增减如虚空
  大乘神通叵思议　　是故如来修集之
  安住念处严正勤　　如意为足根势力
  游八正路采觉宝　　是故如来趣道树
  其心寂静离烦恼　　坏破诸闇获智光
  是故梵天及帝释　　敬礼如来乘大乘
  具足六度六神通　　具善方便修三脱
  能坏诸魔及邪见　　是故如来乘大乘
  若有具足诸善根　　及以成就不善根
  有信则得破烦恼　　是故大乘难思议
  所有一切世间法　　及以无上出世法
  若有学法无学法　　一切摄在大乘中
  若有众生行恶道　　亲近邪见恶知识
  怜愍是辈修方便　　为调伏故说大乘
  下劣不乐于大乘　　心迮不能坏人结
  常求自乐舍余人　　闻说大乘生恐怖
  若有智者具力势　　怜愍众生作利益
  闻说大乘心欢喜　　坏众苦恼心不悔
  若欲了知众生行　　一切众生诸界根
  菩萨一念能通达　　是故大乘难思议
  得身寂静相庄严　　得口寂静众乐闻
  得心寂静具神通　　如是皆因趣大乘
  若有人能行大乘　　是则不断三宝种
  能为众生作利益　　破坏贫穷诸苦恼
  能到十方诸世界　　现见无量佛世尊
  如是趣向大乘者　　是人即得无量福
  一切世间无能胜　　趣向无上大乘者
  具足大力坏魔众　　是故大乘难思议
  得色得力大自在　　梵释转轮圣王身
  若有乘此大乘者　　是人受于三界乐
  施已终不生悔心　　所重之物不吝着
  舍身自施修慈悲　　是故大乘难思议
  持戒精进乐梵行　　能以神力障日月
  不贪着身善果报　　修如是乘调众生
  说法有受不受者　　于是不生嗔爱心
  身心勤修大精进　　为得难得之大乘
  能得无上大法王　　亦得难忍之忍辱
  无量劫中受苦恼　　为得大乘胜一切
  勤作利益多众生　　身口意业悉柔软
  修集慈悲及神通　　为住大乘大利益
  了知法界生住灭　　无我无诤调诸根
  若能安住于大乘　　即受安乐如先佛
  具足念心及精进　　四如意足大神力
  依止正法及真义　　皆由乐住于大乘
  具足无上无所畏　　能师子吼无上尊
  微妙相好自庄严　　皆由乐住于大乘
  具足三种之神通　　调伏教化于众生
  其心寂静无憍慢　　若行大乘具忍辱
  具足梵音声微妙　　一切众生甚乐闻
  若乐修集大乘者　　是人善解众生语
  所作诸业为净土　　不久当得无边身
  若有至心听是法　　当受无边无上乐
  能游虚空达边际　　能知大海水几渧
  不能演说大乘德　　是故是乘难思议

尔时世尊。复告海慧菩萨。善男子。若欲受持如是等经。欲自寂静其深心者。应当受持门句法句金刚句。至心观察门句者。一切法中而作门户。所谓阿字一切法门。阿者言无。一切诸法皆悉无常。波亦一切法门。波者即第一义。那亦一切法门。那者诸法无碍。陀亦一切法门。陀者性能调伏一切法性。沙亦一切法门。沙者远离一切诸法。多亦一切法门。多者一切法如。迦亦一切法门。迦者一切诸法无作无受。娑亦一切法门。娑者一切诸法无有分别。伽亦一切法门。伽者如来正法甚深无底。阇亦一切法门。阇者远离生相。昙亦一切法门。昙者于法界中不生分别。奢亦一切法门。奢者具奢摩他得八正道。佉亦一切法门。佉者一切诸法犹如虚空。叉亦一切法门。叉者一切法尽。若亦一切法门。若者诸法无碍。咃亦一切法门。咃者一切法是处非处。蛊亦一切法门。蛊者观五阴已得大利益荼亦一切法门。荼者一切诸法无有毕竟。迦亦一切法门。迦者身寂静故得大利益。至亦一切法门。至者心寂静故离一切恶。优亦一切法门。优者受持拥护清净禁戒。蛇亦一切法门。蛇者善思惟。替亦一切法门。替者住一切法。修亦一切法门。修者一切诸法性是解脱。毗亦一切法门。毗者一切诸法悉是毗尼。毗尼者调伏己身。时亦一切法门。时者一切诸法性者不染污。阿亦一切法门。阿者一切诸法性是光明。娑亦一切法门。娑者修八正道。婆亦一切法门。婆者一切诸法非内非外。善男子。是名门句。能净念心。能净其心。知众生根。法句者一切诸法解脱印。一切诸法无二印。一切诸法无常断印。一切诸法无增减印。一切法等如虚空印。一切诸法五眼道印。一切法如虚空印。一切诸法无有分别如虚空印。一切诸法入法界印。一切法如印。一切诸法无去来现在如印。一切诸法本性净印。一切法空印。一切法无相印。一切法无愿印。一切法无处无非处印。一切法苦印。一切法无我印。一切法寂静印。一切法性无过咎印。一切诸法第一义摄取印。一切诸法如法性住印。一切诸法毕竟解脱印。一切诸法无时印。一切诸法过三世印。一切诸法味同一印。一切诸法性无碍印。一切诸法性无生印。一切诸法性无诤印。一切诸法性无觉观印。一切诸法非色不可见印。一切诸法无屋宅印。一切诸法无对治印。一切诸法无业果印。一切诸法无作无受印。一切诸法无出灭印。善男子。是名法句。如是法句。即是过去未来现在诸佛菩提。如是法印句。摄取八万四千法聚。善男子。若能如是观法聚者。即能获得无生法忍。善男子。若有未种善根之人。闻是法已。即得种之坏于魔业。善男子。若如是观即能获得无尽器陀罗尼。如是等法悉能摄取八万四千三昧八万四千众生行性。是名法句。金刚句者。其身不坏犹如金刚。何以故。法性不坏故。智慧之性能破无明。是故智慧名金刚句。五逆之罪坏一切善。是故五逆名金刚句。不净之观能坏贪欲。是故不净名金刚句。慈心之观能坏嗔恚。是故慈心名金刚句。观十二缘能坏愚痴。是故观缘名金刚句。一众生心摄取一切众生之心。名金刚句。一众生心一切众生心悉皆平等。名金刚句。一切佛一佛皆悉平等。名金刚句。一福田一切福田无尽平等。名金刚句。一切诸法如虚空等。名金刚句。一切诸法等同一味。名金刚句。一切诸法及以佛法平等无二。名金刚句。金刚三昧能坏一切诸魔恶业。名金刚句。如来妙音坏诸恶声。名金刚句。观无生灭过生老死。名金刚句。善男子。如是等法名金刚句。名坚牢句。名不坏句。名不破句。名平等句。名为实句。名无二句。不退转句大寂静句。无能作过句。不增不减句。无有有句无有法句。真句有句。不谤佛句依法句共僧句如尔句。分别三世句。勇健句梵句。慈句心句虚空句。菩提句不低句。法相句无相句。心意识无住句。波旬句破魔句。无上句无胜句。广句行己境界句。入佛境界句。无觉观句。于法界所不分别句。无句句。善男子。若有菩萨。能解如是等句义者。必当坐于菩提树下。金刚师子法座之上。说是法时。八千菩萨得入法门陀罗尼。亦获一切众生平等三昧。尔时十方诸来菩萨。以妙香华种种伎乐。供养于佛。说偈赞曰

  我今敬礼无上尊　　能知一切众生声
  说相无相实一相　　而得妙相三十二
  若有众生一一心　　平等摄诸众生心
  说行无行实一行　　是故我礼无上尊
  如来真实知因果　　故为众生说业报
  真如法界非有无　　是故我赞无上尊
  一切众生无觉观　　其心本净无有贪
  从因缘故生贪欲　　是故我礼真智因
  我见佛身种种色　　而如来身实无色
  愍众故示无色色　　我礼人中师子王
  一切福田入一田　　而是一田无增减
  不动法界不转移　　是故我礼人象王
  观诸众生心如幻　　诸法菩提亦复然
  知一切法皆平等　　是故我礼无平等
  观诸法界悉平等　　故说诸法无一二
  非有非无是解脱　　是故我礼断二见
  日月可说坠落地　　猛风可说索系缚
  须弥可说口吹动　　不可说佛有二语
  实语真语及净语　　身心清净如虚空
  世法不染如莲花　　是故我礼无上尊
  若有能赞如是德　　即获如是之功德
  我为如是诸功德　　敬礼如是功德聚

时诸菩萨既赞叹已。白佛言世尊。夫大宝者所谓佛也。佛出世者即是乐出。佛出世者即是信出。佛出世者即是念出。佛出世者即是智出。佛出世者即是施戒忍精进禅定慧出。佛出世者即是慈出悲喜舍出。佛出世者。即是十二因缘法义智出。佛出世者即是念处正勤如意根力觉道一切善法出。尔时众中有一菩萨名曰慧聚。白佛言世尊。生老病死出于世者即是佛出。无明爱出即是佛出。贪恚痴出即是佛出。一切疑网烦恼出者即是佛出。何以故。若如是等法不出世者。佛以何缘出现于世。佛言善哉善哉。善男子。实如所言。尔时海慧菩萨言。世尊。若有不见如是等法。时如来为出于世不出于世。善男子。菩萨初发菩提心时。真实不知如是等法。是故我为而宣说之。善男子。菩萨有四种。一者初发菩提之心。二者修行菩提之道。三者坚固不退菩提。四者一生当补佛处。发心菩萨见佛色相。见已即发菩提之心。修行菩萨见佛具足一切善法。见已即发菩提之心。不退菩萨见如来身及一切法皆悉平等一生菩萨不见如来所有功德及一切法。何以故。所得慧眼了了净故。断二见故。净智慧故。若不见净不净。不见非净非不净。是人即能明见如来。善男子。我昔如是见然灯佛。见已即得无生法忍。亦能了了知得无得。得已即时上升虚空。高七多罗树。处空住已。了了得知一切法界。了了知已心无所住。无所住已。得六万三昧门。时然灯佛即授我记。摩纳。汝于来世当得作佛。号释迦如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。我于尔时都不闻是授记音声。亦无佛想及授记想。我于尔时三种净慧。不见我想不见佛想及授记想。复有三净。不见于我不见众生及以正法。复有三净。不见名不见色。不见因。复有三净。见一切阴悉入法阴。见一切界悉入法界。见一切入悉入法入。复有三净。过去已尽。未来不生。现在不住。复有三净。观身如水月。观声不可说。观心不可见。复有三净。空无相愿。若如是见即是真实见于授记。善男子。若有菩萨作如是见。是名实见

大方等大集经卷第十大方等大集经卷第十一

        北凉天竺三藏昙无谶译

    海慧菩萨品第五之四

尔时海慧菩萨白佛言。世尊。菩萨摩诃萨若有具足如是等见发何等愿。佛言。善男子。如是之人如本发愿。菩萨摩诃萨若心在定若不在定。为众生故如本发愿。善男子。譬如人有甘蔗稻田。具满一顷其地平正。欲溉灌时开其水口纵之令去。更不施功自然周遍。善男子。菩萨摩诃萨亦复如是。若在定中系心思惟。若不在定不思惟时。为众生故如本发愿。所作善根。悉皆愿与众生共之。共已回向无上佛法。菩萨心净戒忍定慧亦复清净。观于佛法及诸众生平等无二。虽有是愿初无有心。是故菩萨虽复无心。于诸众生而誓愿力未常不及。所有善根悉与共之。共已回向无上菩提。善男子。如娑罗树有人斫伐根。既断已随斫而倒。善男子。菩萨摩诃萨亦复如是。修集三昧常向菩提。假使有人唱言是树莫斫处堕。是树犹故随斫处倒。菩萨摩诃萨亦复如是。所修善法。欲令不向无上菩提则无是处。何以故。法性尔故。菩萨摩诃萨所修善法。唯为不断三宝种性。为净佛土。为庄严身三十二相八十种好。为庄严口说法之时众生乐闻。为庄严心观诸众生平等无二。为得佛法诸佛三昧。菩萨虽不贪如是法。而能自在得如是法。何以故。誓愿力故。善男子。譬如陶师泥在轮时不得物名。既成器已名随物立。菩萨善法亦复如是。未发愿时。则不能得波罗蜜名。是故菩萨一切善法要当发愿。善男子。譬如金师金未成器。亦不得名。及其成已得璎珞名。菩萨善法亦复如是。未发愿时则不能得波罗蜜名。善男子。譬如比丘欲入灭定先立誓愿。我今入定。若揵椎鸣乃当起出。而是定中无揵椎音。以愿力故鸣揵椎时则便出定。善男子。菩萨摩诃萨亦复如是怜愍众生作如是愿。诸未度者我当度之。诸未脱者我当脱之。修菩提时入深三昧。以悲力故念诸众生。不证声闻辟支佛乘。是故菩萨虽复修集三十七品而不得果。善男子菩萨所行不可思议。虽入深定亦不证得沙门道果。善男子。譬如二人欲过猛火。其一人者着金刚铠即能过之。其一人者身被干草为火所焚。何以故。草则易烧金则坚故。菩萨摩诃萨亦复如是。怜愍众生专念菩提。庄严甚深无量三昧。以三昧力能过声闻缘觉正位不取果证。从定起已得正觉道如来三昧。被干草者喻于声闻。声闻之人厌悔生死。于诸众生无慈悲心。是故不能过于声闻缘觉正位。何以故。二乘之人于福德中生知足想。菩萨之人于福德中心无厌足。金刚铠喻空无相愿。大猛火者喻诸行法。菩萨摩诃萨观一切法空无相愿。而能不证沙门道果。世尊。菩萨摩诃萨具足是事不可思议。修是三昧而不取证。行生死火不为所烧。菩萨摩诃萨成就方便入一切定。亦不为定之所诳惑。具方便故。虽行诸行心无染着。虽为邪见说沙门果。亦自不证沙门道果。佛言。善哉善哉。实如汝说。善男子。如三染汁盛以一器。所谓罗差郁金青黛。染三种物。所谓毳[疊*毛]及憍奢耶衣。毳以浆浸则成青色。叠净浣故成于黄色。憍奢耶衣先以灰浸则成赤色。如是三物。虽同一器受色各异。善男子。三乘之人亦复如是。器者喻于空无相愿。三种色者。喻于声闻缘觉菩萨。随衣受色喻三种菩提。空无相愿亦不生念。与如是果不与是果。善男子。毳喻声闻。叠喻缘觉。憍奢耶衣喻菩萨乘。菩萨摩诃萨见一切法。如聋如盲无有众生。如是见时心无染着无有悔退。是时心中真实了知。我于众生非有利益非无利益。亦为众生修集大悲。善男子。譬如微妙净琉璃宝。虽复在泥经历百年。其性常净出已如本。菩萨摩诃萨亦复如是。了知心相本性清净。客尘烦恼之所障污。而客烦恼实不能污清净之心。犹珠在泥不为泥污。菩萨摩诃萨作如是念。若我心性烦恼污者。我当云何能化众生。是故菩萨常乐修集福德庄严。乐在诸有供养三宝。乐为众生趋走供使。于生贪处不起贪心。护持正法。乐行惠施。具足净戒。庄严忍辱。勤行精进。庄严禅支。修集智慧。多闻无厌清净梵行。修大神通三十七品。善男子。菩萨摩诃萨行如是法。不为烦恼之所染污。不着三界。菩萨摩诃萨行善方便功德力故。虽行三界身心不污。善男子。譬如长者唯有一子心甚爱念。其于游戏误坠圊厕。时母见已恶秽不净。父后见之呵责其母。即便入厕牵之令出出已净洗。爱因缘故忘其臭秽。善男子。长者父母喻于声闻缘觉菩萨。厕喻三界。子喻众生。母不能拔喻声闻缘觉。父能拔济喻诸菩萨。爱因缘者喻于大悲。菩萨摩诃萨具善方便入于三界。不为三界之所染污。是故道有二种。一者声闻。二者菩萨。声闻道者厌于三界。菩萨道者不厌三界。善男子。菩萨修集空无相愿。虽行诸有不堕于有。既不堕有复不取证。行三界者是名方便。不取证者是名智慧。善男子。菩萨摩诃萨观一切法无有二相。若观法等众生亦等。如是等者涅槃亦等。是名智慧。若能如是等观众生不证涅槃。是名方便。清净惠施是名为慧发愿回向是名方便。世尊。云何名为清净智慧清净方便。善男子。菩萨若见无我众生寿命士夫是名为慧。若修集空无相无愿。以诸善根愿及众生回向菩提。是名方便。复次善男子。知诸众生下中上根。是名为悲。知已随意而为说法。是名方便。净智慧故虽行诸有心无染着。净方便故虽修二乘不证其果。善男子。若能不为一切烦恼之所污染。是名为慧。能调众生悉令趣向阿耨多罗三藐三菩提。是名方便。菩萨发愿悉令众生得无尽财无尽福德增长善根。诸学无学声闻缘觉。一切菩萨随意得法名净方便。若能受持一切佛法。广分别说。无穷尽说。无障碍说。不空而说。随乐而说。是名净慧。菩萨摩诃萨生生之处不失无上菩提之心。是名净慧。生生之处所作善法愿及众生。名净方便。净慧因缘知菩提心无住无根。净方便故化诸众生趣于菩提。世尊。菩萨摩诃萨若具如是二净。所作诸业无非菩提。何以故。一切法中悉有闇障。坏闇障故即是菩提。是故菩萨常不远离于菩提也。菩萨若作如是念言我离菩提。当知是人不得菩提。若念我今有菩提者。是人菩提有净不净。若能如是观诸法者即得菩提。即是净智方便也。善男子。过去无量阿僧祇劫。有佛出世。号无边光如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。土名不眴劫名光味。尔时世尊初坐道场菩提树下。未成佛时。十方世界一生补处。不退菩萨悉来睹见。至其所已以种种华而供养之。华处空中高七多罗树。成佛道已放大光明遍照十方。十方世界多有诸天。见佛光已各作是言。无边光佛真实出世。彼佛世界庄严丽饰。如彼他化自在天宫。彼劫初时过十千年。有佛出世号曰光味。是故此劫名曰光味。善男子。光味劫中有十四亿诸佛如来出现于世。其佛世界有九万六千小国。一一国土纵广八万四千由旬。一一国有八万四千城。其城纵广满一由旬。一一城中居止人民八万四千。彼土具足如是等事。其土纯以四宝挍饰。所谓金银琉璃颇梨。多饶饮食无所乏少。其土人民无我我所。犹如北方郁单越土。其佛寿命满十中劫。声闻大众九万六千亿。菩萨大众万二千亿。土有二城。一名乐。二名净。其佛世尊生于净城住于乐城。其土有王名曰净声。七宝具足统领三千大千世界。后宫婇女三万六千。姿颜端严如天无别。有十万子雄猛勇健。悉皆具半那罗延力。各各成就二十八相。一切皆发阿耨多罗三藐三菩提心。有八万女清净无秽。形容瑰异如天无差。一切亦发阿耨多罗三藐三菩提心。其王尔时经二劫中。供养如来及声闻菩萨大众。为如来故造作宝坊满五由旬。是宝坊中复有宝楼其数十万。为供养僧。尔时圣王与其眷属。一切皆修清净梵行。时佛教化无量众生于大乘法。复化无数于声闻乘。尔时其王供养佛已。与诸眷属俱至佛所。头面礼足右绕恭敬。长跪合掌白佛言。世尊。云何菩萨修行大乘不随他语。云何菩萨生得毕竟。云何菩萨得无所住。云何菩萨得无动慧。云何菩萨得清净慧。云何菩萨力能远见。云何菩萨诸根猛利。云何菩萨具足佛土。云何菩萨行不放逸。云何菩萨闻甚深法心不怖畏。云何菩萨得名菩萨。佛言。大王有四事法。修行大乘不随他语。何等为四。一者具足圣信出于世界。二者具足智慧观诸法性。三者具诸神通。四者修净精进为化众生。大王。菩萨具足如是四法。修行大乘不随他语。复有四法生得毕竟。何等为四。一者知于善法为调伏心。二者不贪己乐。三者为诸众生修集慈悲。四者常乐大乘。是名为四。大王。复有四法得无所住。何等为四。一净于心。二净庄严。三离虚诳。四修坚慧为具福德。是名四法。大王。复有四法得净智慧。何等为四。一者净眼。二者以四摄法摄取众生。三者净身三十二相八十种好。四净佛土观净法界。是名为四。大王。复有四法。能得远见诸根猛利。何等为四。一者念菩提树不舍菩提心。二者念佛智慧亦不着智。三者念法身。修集于空无相无愿。四者念佛涅槃。于生死中心无厌悔。是名为四。大王。复有四法具足佛土行不放逸。何等为四。一者受帝释身。为化诸天令不放逸。二者受梵天身。为化诸天令不放逸。三者受转轮王身。为化众生令不放逸。四者受于大臣长者之身具足珍宝。为化众生令不放逸。是名为四。大王。复有四法闻甚深法心不怖畏。何等为四。一者亲近善友。二者善友为说甚深佛法。三者善能思惟。四者如法而住。是名为四。大王。复有四法得菩萨名。何等为四。一者求波罗蜜。二者为诸众生修集悲心。三者乐求佛法。四者化众生时心不厌悔。是名为四。善男子。时净声王从彼如来闻是法已。及诸眷属一切皆得无生法忍。舍其国土于佛法中出家修道。尔时世尊告彼王言。大王。汝今出家即是报佛。若能如是生信舍离。是名大报。是名功德。多所利益。大王。菩萨出家有二十四利益之事。何等为二十四。一者舍于世事得大自在。二者舍于烦恼获得解脱。三者身服染衣得无染道。四者具足四事得四性种。五者乐于头陀。远离一切大欲恶欲。六者不舍戒聚受人天乐。七者不舍菩提获得佛法。八者常乐寂静离世谈语。九者不着法故得大净心。十者具足禅支。得禅定故。十一者求于多闻。得智慧故。十二者破坏憍慢。得智慧故。十三者破除邪见。得正见故。十四者不生觉观。为真实知诸法界故。十五者等观众生。得大慈故。十六者化诸众生心无疲惓。得大悲故。十七者不惜身命。为护法故。十八者寂静其心。为得神通故。十九者念于如来。为见佛故。二十者修善思惟。为得十二缘深智慧故。二十一者得于顺忍。二十二者得无生忍。二十三者信一切功德。二十四者得佛智慧。是名二十四。善男子。尔时圣王闻是法已。转以教化一切男女眷属臣民。时彼国中有九万九千亿众生悉共出家。善男子。净声比丘既出家已复白佛言。世尊。我今云何得名出家。佛言。比丘汝名净声当净自界。自界既净则名比丘则名出家。尔时比丘闻佛说已。心乐寂静作是思惟。界者即眼观。眼空者即是净界。夫净界者即是佛土。耳鼻舌身亦复如是。意者即界。若观意空即是净界。夫净界者即是佛土。即是一界。即是空界。即众生界。即无相界。即无愿界。即无作界。即无为界。善男子。净声比丘如是观已。即时获得身轻心轻。身心轻已得无量神通。得神通已得乐说无碍陀罗尼门。善男子汝知。尔时净声比丘岂异人乎。即汝身是。男女眷属即汝所将来菩萨听法众是。说是伊帝曰多伽时。万八千人发阿耨多罗三藐三菩提心。八千众生得无生忍。善男子。若有欲得阿耨多罗三藐三菩提者。当如法说如说而住。云何名为如法而说如说而住。善男子。若有人言。我当作佛请诸众生许以法味。请已不能受持读诵分别解说微妙经典。不能护持清净禁戒。勤修精进不修知足。于善法中少得知足。是名欺诳不如法说不如说住。若有人言。我当作佛请诸众生许以法味。请已受持读诵演说。护持禁戒勤修精进。少欲知足多得善法不生足想。是名不诳如法而说如说而住。善男子。譬如国王多请宾客。请已不设供宾之具。宾客既至方云未办。于是宾客各作是言。昨受王请家不设食。今赴王信复无所得。呵责愁恚怨叹啼泣。善男子。菩萨摩诃萨请诸众生许以法食。不求多闻持戒精进。不修三十七助道法。众生呵责人天涕泣。善男子。菩萨摩诃萨若能如作应如作说。不应欺诳一切众生。复次善男子。复有众生请求菩萨为我说法。菩萨许言。当为汝说许已放逸。众生既见菩萨放逸。即便劝喻。既劝喻已方为说法。说时或问甚深之义。以放逸故而不能答。不能答故心生惭愧。护于身心诳于众生而便舍离。善男子。菩萨若欲如说而住。无惜身心以护众生。善男子。过去世有一师子王住深山窟常作是念。我是一切兽中之王。力能视护一切诸兽。时彼山中有二猕猴共生二子。时猕猴向师子王作如是言。王若能护一切兽者。我今二子以相委付。我欲余行求觅饮食。时师子王即便许可。时彼猕猴留其二子。付彼兽王即舍而行。是时山中有一鹫王名利见。师子王眠。即便搏取猕猴二子处崄而住。时王寤已即向鹫王而说偈言

  我今启请大鹫王　　唯愿至心受我语
  幸见为故放舍之　　莫令失信生惭耻

鹫王说偈报师子王

  我能飞行游虚空　　已过汝界心无畏
  若必护是二子者　　为我故应舍是身

师子王言

  我今为护是二子　　舍身不惜如枯草
  若我护身而妄语　　云何得称如说行

说是偈已即至高处欲舍其身

尔时鹫王复说偈言

  若为他故舍身命　　是人即受无上乐
  我今施汝猕猴子　　愿大法王莫自害

善男子。时师子王即我身是。雄猕猴者即迦叶是。雌猕猴者善护比丘尼是。二猕猴子即今阿难罗睺罗是。时鹫王者即舍利弗是。善男子。菩萨为护是依止者不惜身命。善男子。云何名为如说而作。菩萨若言我当惠施即便大施。是名菩萨如说而作。菩萨若言我能持戒。即化一切同己护戒。是名菩萨如说而作。菩萨若言我修忍辱。即化众生同修忍辱。是名菩萨如说而作。菩萨若言我勤精进为于佛法。即化众生同修精进为于佛法。是名菩萨如说而作。菩萨若言我修禅定即化众生。除去乱心修集禅定。是名菩萨如说而作。菩萨若言我修智慧如法分别。是名菩萨如说而作。善男子。菩萨若言我当坏破一切恶法。即便修集一切善法。是名菩萨如说而作。善男子。能庄严者名为如说。能毕竟者名为如作。能发心者名为如说。得果证者名为如作。能净心者名为如说。能至心者名为如作能发心者名为如说。不退心者名为如作。至心听法名为如说。闻已如住名为如作。能净口者名为如说。能净身者名为如作。初受戒者名为如说。至心护持名为如作。发菩提心名为如说。行菩萨道是名如作。得住忍地名为如说。住不退地名为如作。得一生身名为如说。得后边身名为如作。趣菩提树名为如说。得菩提果名为如作。善男子。是名菩萨如法而说如说而作。说是法时。五百菩萨住无生忍地

尔时会中有一菩萨。名曰莲华。白佛言。世尊。如佛所说。如说如作不可思议。如佛所住即是如说即是如作。善男子。汝于是事能了知不。已知世尊。若知正法是真实者名如法住。山王菩萨言。世尊。无所住法名如法住。何以故。见一切法无有觉故。以无觉故不见一法名之为觉。若无一法云何有住。若如是见名如法住。福德王菩萨言。世尊。若随心者非如法住。若有菩萨观意如幻名为无住。若无住者名如法住。然灯菩萨言。世尊。无有贪心名如法住。云何贪心。谓于法中有损有益。若无贪心名如法住。日子菩萨言。世尊。若有菩萨有所著者是名为动。若于法中心无所著。是名无动。若无有动名如法住。勇健菩萨言。世尊。一切世间皆随心行。若知心行名如法住。乐见菩萨言。世尊。如佛所说因受受苦。若能不受诸受则断。若能不取诸取则断。虽不受取不舍众生名如法住。香像王菩萨言。世尊。一切众生悉有重担。所谓五阴。若有能知五阴真实。为坏阴见弃捐重担。而于诸法亦无担想名如法住。持世菩萨言。世尊。若行世间非如法住。若正庄严名如法住。正庄严者见一切法等如虚空。坚意菩萨言。世尊。若有菩萨。不生于生不灭于灭。亦复不见生灭之性名如法住。光明遍照高贵德王菩萨言。若能知见真实涅槃。见法是灭及无生灭。一切众生悉有佛性。为趣菩提而修庄严名如法住。光无碍菩萨言。世尊。若有行处即是魔业。非如法住。若无行处则坏魔业。若坏魔业名如法住。净进菩萨言。世尊。若作念言我当得法。为是得法勤行精进。如是精进是空精进。若能观察诸法不定。以是不定勤修精进名如法住。过三恶道菩萨言。世尊。一切诸法无作无变无觉无观。无觉观者名为心性。若见众生心性本净名如法住。不可思惟思惟菩萨言。世尊。知诸众生一切心性不作心想。名不可思惟而思惟也。若能于是不思惟中而思惟者名如法住。乐寂静菩萨言。世尊。若有菩萨净诸心界。是则能离一切诸漏。若能远离一切漏者是名正行。若正行者名如法住。商主菩萨言。世尊。菩萨若有清净善法。福德庄严智惠庄严。观二庄严平等无二。以功德等观智慧等。以智慧等观功德等。无差别者名如法住。维摩诘菩萨言。世尊。不观于二名如法住。若于法界不坏不别名如法住。依义菩萨言。世尊。若有菩萨依于正义不依于字。为正义故受持读诵。广说八万四千法聚。无失无动名如法住。净意菩萨言。世尊。若有菩萨发菩提心。至心拥护是菩提心。修菩提时知诸法性。夫法性者非处非非处名如法住。毕竟净意菩萨言。世尊。若有菩萨远离垢秽如浣去垢。能令烦恼不污其心名毕竟净。其心净已随菩提行名如法住。海慧菩萨言。世尊。若有亲近恶知识者非如法住。不修圣法非如法住。若近恶友则行魔业堕于魔处。世尊。若有欲离一切魔业诸魔行处诸恶法者。当近善友。佛言。善男子。汝今真知魔业行不。已知世尊。善男子。汝今当为无量菩萨大众而说。世尊。夫魔业者即是眼色。若人见色生贪着心即是魔业。乃至意法亦复如是。复次世尊。菩萨修行檀波罗蜜时。不爱之物持用惠施。所爱财货贪吝不舍。爱者则施恚者不与。分别受者及以财物。若有分别如是二者是名魔业。复次世尊。菩萨修行尸波罗蜜时。护持禁戒近持戒者。赞叹己身毁呰破戒是名魔业。复次世尊。菩萨修行忍波罗蜜时。于大力者能生忍辱。于少力者不能生忍。见大力者软语谦下。见小力者粗语轻蔑是名魔业

复次世尊。菩萨修行进波罗蜜时。说声闻乘说缘觉乘说菩萨乘。修菩提时。轻慢声闻辟支佛乘。口不宣说。乐于世行不乐供养恭敬三宝。所谓华香幡盖伎乐。尊重赞叹不求多闻。见多闻者不能亲近是名魔业。复次世尊。菩萨修行禅波罗蜜时。获得禅定不能调伏一切众生。心生悔厌贪着禅乐。呵说法者不乐讲论。赞叹寂静贪着禅味。呵毁二界爱无色身。寿命极长不见诸佛。不闻正法远离善友。不知方便受舍修舍是名魔业。复次世尊。菩萨修行般若波罗蜜时。知于因果。不以四摄摄取众生而调伏之。不知众生上中下根是名魔业。复次世尊。菩萨若乐空闲寂静。乐寂静已受寂静乐。不乐听法说法问疑。以寂静故烦恼不起。以不起故不知知想。不离离想不证证想。不修修想不得实义是名魔业。复次世尊。菩萨若有修集多闻。好语乐语。微妙之语。软语喜语。若为衣食卧具利养而演说法。若有信解能至心听而不为说。若有放逸致供养者便为说之。可为说者而不为说。不可说者反为说之是名魔业。复次世尊。若有菩萨说法之时秘藏深义。有诸天人得他心智。知已不悦即作是念。我为如来真正法来。不为世间浅近语来。是人欲毁如来正法不能增长。若人有毁佛正法者。我不乐见闻。其所说即便舍去是名魔业。复次世尊。若有菩萨于恶知识作善友想。恶知识者不以四摄摄取众生。不修多闻不化众生。不说出法乐说世语。不知法不知时不知义是名魔业。复次世尊。恶知识者。不能开示分别解说声闻缘觉菩萨佛法。不化众生令修慈悲远离八难修行施戒。柔软语言亲近平等教忍无力。说言佛道甚为难得。无量世中勤苦乃获。是名恶友名为魔业。复次世尊。菩萨若有憍慢之心。以憍慢故不能供养佛法众僧师长和上父母长宿同学同师。若见胜己不能亲近听法问疑。是故虽闻闻已便失。见下己者亲近爱念。是故恶法渐渐增长。恶法增故远离善法。世尊。譬如大海渐渐深故一切诸流悉共归之。菩萨坏慢亦复如是。渐渐增长一切善法。菩萨若不坏憍慢者是名魔业。世尊。譬如有人高原陆地种瞻波树。水常行处复作坻塘。地既高燥又不得水。渐渐枯黄不能增长。世尊。菩萨摩诃萨亦复如是。憍慢增故不亲善友。不闻正法虽闻复失。复次世尊。菩萨摩诃萨身色具足端正自在。多有眷属福德庄严。未能具足智慧庄严。以是因缘生于憍慢。以憍慢故。若有菩萨具智庄严。思惟正法身体羸瘠。见已轻慢不能供养。以是因缘复增憍慢。无明放逸不调魔业。如是菩萨为色生慢是名魔业。尔时世尊告海慧菩萨言。善哉善哉。善男子。善能分别宣说魔业。善男子。至心谛听。吾今当说坏魔业道。善男子。一切诸法其性空寂。若知诸法其性空已。亦知一切众生皆空。既知空已而修慈心调伏自身。是名菩萨破坏魔业。若观诸法性是无相。而为众生修集慈心。是名菩萨破坏魔业。若观诸法性是无愿。为诸众生至心求有。既求有已随而调伏。是名菩萨能坏魔业。观一切法性是无贪。众生之性亦复无贪。为调伏贪而摄取之。是名菩萨能坏魔业。若观诸法性是无恚。众生之性亦复无恚。为调伏恚而摄取之。是名菩萨能坏魔业。若观诸法性是无痴。众生之性亦复无痴。为调伏痴而摄取之。是名菩萨能坏魔业。观诸法性无生无灭。坏生灭故宣说正法。是名菩萨能坏魔业。观一切法性是平等。虽说三乘不舍大乘。是名菩萨能坏魔业。若不贪着心意识等。亦能远离一切因缘。为诸众生得解脱故修法庄严。虽过诸行终不舍离菩萨所行。是名菩萨能坏魔业。说是法时。天魔波旬庄严四兵来趣宝坊。如先趣向菩提树时。如来见已告海慧言。汝说魔业我说坏魔。以是因缘魔王波旬。庄严四兵而来至此。欲设何计以当御之。海慧菩萨言。世尊。我今欲持魔王波旬及其眷属置庄严国。我身当住魔所住处。尔时舍利弗言。善男子。庄严世界去此远近佛号何等。舍利弗。在此东方过于十二恒河沙等世界。其土有佛号破疑净光。今现在世为诸菩萨说净菩萨行。彼国三千大千世界有一亿魔。一一魔王有十千亿人兵眷属。其佛初坐菩提树时。如是诸魔悉共庄严至菩萨所。尔时菩萨先为诸魔讲宣正典。令其得住不退转地。然后乃成阿耨多罗三藐三菩提转正法轮。彼佛世尊。其大弟子及侍使者亦悉是魔。如是等魔悉能教化调伏众生。是故我今取魔波旬安置彼土。为欲坏其所行魔业。庄严如来无上正法。时魔波旬闻是语已心生恐怖。四望顾视欲求退处。四方障碍不得从意。复欲灭身亦不能得。方计不立倍复生懅。白佛言。世尊。唯愿大慈少见救护。佛言。波旬我于此事不得自在。汝当归向海慧菩萨求哀忏悔。时魔波旬即向海慧合掌而言。善男子。我从今日不敢复作如是魔业。唯愿仁者听我忏悔。海慧菩萨言。我于汝所都无嗔心。菩萨之法常应忍辱一切众生。波旬。汝可往彼礼觐彼佛。汝身当得无量利益。尔时菩萨即以右手摩其顶上作如是言。若诸菩萨于诸法中无贪吝者。以我神通令汝必至彼佛世界。言已波旬即至彼土。既至彼土见佛敬礼却住一面。彼诸菩萨白佛言。世尊。何等国土有如是等不净之人而来至此。佛言。善男子。西方过十二恒河沙等诸佛世界。彼有世界名曰娑婆。佛号释迦牟尼。为过数量诸菩萨等说大集经。彼有菩萨名曰海慧。说魔业时。是魔庄严四种兵众来至会所。海慧菩萨以神通力移来至此。彼世界中诸菩萨等语波旬言。善男子。汝今宜发阿耨多罗三藐三菩提心远离魔业。我当与汝共为同学。时魔波旬闻是语已。即发阿耨多罗三藐三菩提心。时诸菩萨即请波旬升师子座。问波旬言。承彼如来为诸大众说大集经。斯有何事惟仁说之时魔波旬。以海慧菩萨神通力故宣说所闻。乃至不失一句一字。彼诸菩萨即白佛言。我等愿乐欲见彼佛释迦牟尼及众菩萨。彼佛即告诸菩萨言。且待须臾。自当得见此宝坊中。诸菩萨等复白佛言。世尊。我等欲见魔王波旬。于彼世界为何所作。尔时世尊观此彼界众生心已。告海慧菩萨言。善男子。汝今当以此佛世界示彼菩萨。尔时海慧菩萨即于十指放大光明。其光即过十二恒河沙等诸佛世界遍照彼土。此间大众悉见彼土佛及菩萨魔王波旬处师子座说大集经。时诸菩萨即从座起。向彼如来头面敬礼。散种种华而以供养。所散诸华当彼佛上变成华台。彼诸菩萨见是华台即白佛言。世尊。如是华台从何处来。佛言。善男子。娑婆世界诸菩萨众所散供养。诸菩萨言。世尊。云何令我得见彼土娑婆世界。佛言。善男子。汝等今当敬礼是光至心念持。自当得见彼佛世界。时彼菩萨如佛所言。敬礼光明至心念持。即得见此娑婆世界。见已即起礼释迦牟尼佛。以诸香华遥供养之。又见三千大千世界。净水澄满犹如大海。彼所散华至此世界大宝坊中。当如来上变成宝盖。时魔波旬白彼佛言。世尊。我当云何还彼世界。佛言。善男子。若欲还者应当至心念于海慧。时魔波旬至心念于海慧菩萨。念已即得还此世界。时舍利弗见魔波旬即作是言。波旬汝得见彼佛世界不。波旬言。舍利弗。我已见之。及见彼土清净菩萨所住之处。舍利弗言。汝于彼土作魔业不。大德。我至彼土至心勤求无上菩提。何缘复得造作魔业。若有至心求菩提时见魔业者。是人则得勤修精进。此界大众见魔波旬还来至此。六万众生十千魔众。同共发阿耨多罗三藐三菩提心作是言。愿我等辈所受身形。如彼菩萨身形无异。海慧菩萨言。世尊。为阿耨多罗三藐三菩提。多有怨敌。善哉世尊。为护法故建立神通。以通力故是经当得久住于世。佛言。善男子。我今所立善愿神通。为诸众生种于善根。尔时世尊告四天王。汝等当知。若我弟子比丘比丘尼优婆塞优婆夷。受持读诵书写广说如是等经。汝等四王当深护助。无为欲乐而作放逸。吾今出世为坏放逸护正法故。而说咒曰。所谓

三咩(羊鸣音)三摩三咩沫顿祢　婆罗跋坻陀祢　陀那跋坻　投弥陀那跋坻阿婆散提　阿摩隶　毗摩隶　阇毗罗提　迦罗提　迦罗那　阿梨　阿罗跋坻阿隶婆散提　涅伽旦尼　阿跋坻沫提　摩呼沫提　摩罗夷提　毗首提　毗首提跋坻　尼萨隶莫罕泥

善男子。是名四天王咒。若有法师受持是经当诵是咒。诵已修慈缘念十方。至心念于四天王等。尔时四王当示其梦或自往护。时四天王白佛言。世尊。我等四王闻是咒已。即与眷属至法师所拥护侍卫。若是法师所须资生。我当方便令其得之。远离病苦身受安乐。尔时世尊告海慧菩萨。善男子。汝今至心听帝释咒。所谓

阇耶阇耶末坻阿跋坻跋坻　摩拘隶斯陀跋坻　输泥膻帝羯隶檀提昙摩尼　多迦隶　叉耶叉耶目佉　阿跋蔕那　涅伽蔕那　莎坻　莎坻散提

来憍尸迦。阿修罗坏诸天则胜。诸天胜故佛法增长。憍尸迦。欲受安乐当护正法。善男子。是名释咒。善男子。若有法师欲说法时。当先洗浴令身净洁。持妙香华正东而礼。一心忆念十方诸佛。慈心普及一切众生。然后乃升师子法座。诵如是咒而作是言。憍尸迦来。四天王来。为诸大众除却障碍消灭烦恼。尔时帝释及四天王。念法师故即便共来。是故大众乐闻说法。善男子。汝今复听十方诸魔及眷属咒。所谓

奢咩　奢摩跋坻　奢摩密幉　阿浮隶摩罗欻坻　瞢崛隶　婆罗绨　迦由犁　坁祁跋坻　阿虑迦尼　比舍荼尼　尼末坻　阿跋持　区区隶　伽罗萨尼　忧目企　奢蜜坻　波罗目企　槃檀那涅伽熙坻　奢摩[糸*施]

如是咒者。力能系缚一切论师一切魔众。是名佛印。不可破坏魔眷属怨。善男子。若有法师受持读诵如是等咒升师子座。专念诸佛慈及众生。自于己身生医师想。于所说法生良药想。于听法者生疾苦想。于如来所生善友想。于正法中生常恒想。若能如是说正法时。其处四边各一由旬魔不能到。时魔波旬白佛言。世尊。若佛弟子有能读诵如是神咒。其身清净我当拥护不作魔业。我以海慧神通力故舍于魔业。随有国土城邑村落说是法处。我当化身亲往听受。佛言。善哉善哉。波旬。汝若能得如是心者则坏魔业。亦当获得如是等法。善男子。复当至心听梵天咒。所谓

迷多伽隶　迦楼那伽隶　无经多伽隶　忧比叉伽隶　佛陀伽隶　昙摩伽隶　僧伽伽隶　苏羯多毗阇耶　摩诃毗檀尼　毗兽提目尔　尼波隶陀耶　乌阇跋坻　乌阇严弥　捺檀尼　昙摩波坻吒跋尼　萨遮坻优波跋坻毗兽坻　莎折多优波舍弥　乌卢迦耶梵摩　毗卢迦耶梵摩

若欲具足受持如是梵天咒者。当行梵行清净持戒。读诵是咒请召梵天。梵天汝来拥护如是大众。令其至心乐听正法。念于三宝转正法轮护持法城。若有法师能调诸根。至心净护身口意等。勤修戒忍精进多闻。发菩提心修四无量。升于法座诵如是咒。诵是咒已。梵天王等与诸眷属悉来集会是讲法所。尔时梵王白佛言。世尊。若有法师读诵是咒。我在初禅闻是咒已。当舍定乐而往其所。当施八法。何等为八。一者施念。持所闻故。二者施慧。思惟深法故。三者施解。分别深义故。四者施乐说无碍。为坏疑心故。五者施辞无碍。为解一切众生语故。六者施无所畏。为众无胜故。七者施法光明。为不谬说故。八者施其不谬授记。世尊。我等亦能广宣是法。善男子。我涅槃后如是等天当护正法。海慧菩萨言。世尊。如来正觉涅槃之后。若有信者应以此法付嘱其人令得久住。尔时世尊眉间白毫放大光明。遍照三千大千世界。如来化身充满其中。三十二相八十种好具足庄严。数如三千大千世界。一切卉木茎节枝叶。是诸化佛同作是言。十方诸佛释迦如来。同愿正法久住于世。何以故。虽有一切恶魔眷属。不能破坏如是等法。大地可坏。大海可焦。须弥山王可碎如尘众生诸心可合。是一虚空可画。四大可转。诸佛誓愿不可变易。尔时世尊即告阿难。汝当受持如是等经读诵广说。海慧菩萨言。世尊。今此会中多有无量诸大菩萨。如来何缘顾命阿难令受持之。时诸大众咸有疑心。海慧阿难谁念心多。尔时世尊知众会疑。告大迦叶。三千大千世界众生数为多不。甚多世尊。迦叶。假使如是无量众生。悉得人身常问如来。如来所说不可穷尽无有障碍。善男子。如天降雨无有障碍。一切众流归集大海。而是大海无增无减。海慧菩萨所可受持。十方佛法亦复如是。迦叶。假使三千大千世界。所有众生具足总持。如阿难等。欲比海慧所受持法。百分千分百千万分不及其一。说是语时百千众生发阿耨多罗三藐三菩提心。以妙华香贡上供养海慧菩萨。尔时莲华菩萨白佛言。世尊。若有人能信顺受持。读诵书写解说其义。供养恭敬如是经者得几所福。尔时世尊即说偈言

  若满三千大千界　　七宝奉施十方佛
  不如信顺是经典　　受持读诵福多彼
  四法所成诸功德　　佛说无量无边数
  发菩提心常法施　　如法而住修集悲
  佛说四法无边量　　智者闻已不怖畏

虚空之性众生界如来正智菩提心

说如是等法宝聚时。十方所来诸菩萨等。以妙香花种种伎乐。供养于佛尊重赞叹作如是言。世尊。若有人能受持读诵书写解说如是等经。所得功德不可称量。十方诸佛说不能尽。何以故。世尊。众生若闻如是等经。无有不发阿耨多罗三藐三菩提心者。是故此经名大宝聚。尔时一切大众人天。一切声闻及阿难等。诸迦楼罗乾闼婆等及世间人。闻经欢喜。信受奉行

大方等大集经卷第十一大方等大集经卷第十二

        北凉天竺三藏昙无谶译

    无言菩萨品第六

尔时世尊。故在欲色二界中间大宝坊中。与诸大众围绕说法。时王舍城师子将军家产一子。当其生时。虚空之中多有诸天作如是言。童子。当应念法思惟于法。凡所发言莫说世事。常当颁宣出世之法。常当守口慎言少语。莫于世事起诸觉观。当依于义莫依文字。尔时童子闻是语已。不复涕泣无婴儿相。乃至七日色貌和悦。见人欢喜目未曾眴。是时有人语其父母。是儿不祥不应畜养。何以故。喑无声故。父母答言。是儿虽复喑不出声。然其身根具足无缺。当知是儿必有福德。非是不祥薄福之人。因为立字字曰无言。时无言童子渐渐长大如八岁儿。所游方面人所乐见。随有说法转法轮处。乐往听受口无所宣。尔时无言童子。以佛神力与其父母眷属宗亲往宝坊所。到已见佛心生欢喜。礼敬供养右绕三匝。合掌而立。并见十方诸来菩萨生大喜心。尔时舍利弗白佛言。世尊。师子将军所生之子。身根具足而不能语。是何恶业因缘所致。佛告舍利弗。汝今不应作如是语轻是童子。何以故。是人即是大菩萨也。已于无量无边佛所种诸善根。不退转于菩提之道。是儿生时。多有诸天来诫敕之。善哉童子。当念正法思惟正法。无得宣说世间之事。常当颁宣出世之义。常当守口慎言少语。莫于世事起诸觉观。当依于义莫依文字。舍利弗。如是童子从天教诲。是故无语默然思惟获得四禅。舍利弗。无言菩萨示如是身。则能调伏无量众生。是故默然无所宣说。舍利弗。我今说是大集经典。无言菩萨。当于此中能大利益无量众生。时无言菩萨。以己愿力神通道力。令诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。比丘比丘尼优婆塞优婆夷。各自见其右手之中有大莲华犹如车轮。色香具足微妙第一人所乐见。一一华台有一菩萨结加趺坐。三十二相八十种好庄严其身。尔时无言菩萨现如是等大神通已。低头合掌作如是言。南无佛陀。南无佛陀。诸莲花台中一切菩萨。亦复如是同作是言。南无佛陀。南无佛陀。发是言已。十恒河沙等世界大地六种震动。虚空诸天以妙香华种种伎乐供养于佛。尔时无言以佛神力及己愿力。与诸菩萨踊在虚空高七多罗树。正向于佛而说偈言

  如来无色示现色　　亦复于色无染着
  若有众生入佛法　　云何当知真实色
  非色聚中有如来　　亦不离色有如来
  如来已离诸色聚　　哀愍众生故示色
  如来哀愍众生故　　以诸相好庄严色
  实无色相为众说　　是故如来难思议
  如来正法无文字　　离文字已无有声
  无有文字无可说　　甚深寂静无有觉
  如佛先在菩提树　　所觉诸法亦如是
  此法无字无音声　　亦无造作无可说
  如是诸法无相貌　　亦以远离一切相
  一切诸法若无相　　如来云何而演说
  如来具足大慈悲　　是故怜愍为利益
  不可说法而演说　　亦知真实不可说
  如来了知不可说　　亦知音声性空寂
  真实了知一切义　　是故名佛真实觉
  所说之法名世谛　　如来真实觉知之
  世谛不出无有性　　不可造作无有期
  真实无有色相貌　　为众故示种种色
  知法无法无上尊　　为众生故而演说
  我初生时受天语　　是故默然无所说
  至心念法思惟法　　是故不见色与声
  若得入于深法界　　尔时则无色声等
  若能远离于心业　　即得远离于口业
  无有言说即是语　　虽复言说亦无语
  语亦非作亦非说　　言语本性寂静故
  我今至心念菩提　　亦复至心修其道
  我今说是无上语　　亦当定得真实道
  我心不得菩提道　　口及口行亦不得
  无上菩提即是空　　其性本来常寂静
  如菩提性声亦尔　　不见不取法性故
  我声如是不可见　　所求菩提亦如是
  为菩提故有修行　　是行亦无所至处
  是行如是无至处　　是故菩提处非处
  六波罗蜜如菩提　　一切善法亦如是
  一切语言无语言　　于无语中能说语
  若有惠施妙音声　　惠施之主及财物
  如是等施即菩提　　一切皆悉不可说
  若是布施可口说　　菩提体亦应可说
  菩提之性如虚空　　一切音声亦如是
  若有心能真实知　　知已亦能宣说声
  随知是声而处灭　　即是菩提真实相
  若能远身口意业　　一切烦恼亦复然
  即是一切波罗蜜　　如来所说实法性
  惠施不在菩提中　　菩提不在惠施中
  如是二法即音声　　亦无所住无至处
  若有能知如是等　　即是真实大菩萨
  若于施时不生慢　　即是无上大施主
  护持禁戒即是声　　无有形色无至处
  诸法不生及不灭　　即是无上持戒相
  如是禁戒无能作　　亦复无身口意业
  若不出灭不造作　　云何可说是禁戒
  为流布故出音声　　众生立名名禁戒
  如诸禁戒声亦尔　　如是二法俱无漏
  口之所说为戒故　　而说种种诸庄严
  音声实无诸庄严　　真实知之无所有
  身业口业及心业　　能回此戒向菩提
  禁戒音声及菩提　　如是二法如虚空
  若有能作如是知　　是人即行戒行处
  即能得到戒彼岸　　彼处甚深难得见
  说忍音声即是空　　空性无处无造作
  忍辱与空是二法　　无有差别如虚空
  忍辱之声非色作　　不可睹见无处所
  若有修集平等心　　即是忍之真实相
  忍辱虽复念念灭　　而与色身常共行
  一切文字皆无漏　　众生立名名忍辱
  若有能调身口意　　即是无上之忍辱
  若有能忍忍辱者　　是亦即是无上忍
  若有众生碎其身　　节节坏末如胡麻
  观身犹如干草木　　是则名之为身忍
  若闻恶口骂詈时　　其心不动如法住
  观察音声如虚空　　即是无上之口忍
  若能通达烦恼因　　远离一切诸烦恼
  是则名之为心忍　　不为一切烦恼污
  如忍即是菩提性　　身口意业亦如是
  若能回是向菩提　　是则名为得菩提
  若有众生勤精进　　上中下等及粗细
  于无量劫修集之　　无所获得无毕竟
  若不获得精进者　　是故菩提名无得
  若能不得一切法　　即是无上勤精进
  若有如是精进者　　不增不减如虚空
  如是即是大菩萨　　勤行精进无所畏
  一切诸禅无有聚　　无有造作无至处
  若有思惟一切法　　即是真禅波罗蜜
  远离一切诸恶色　　恶身恶口亦复然
  能焦一切诸烦恼　　即是真禅波罗蜜
  若能观心真实性　　一切法中亦不见
  若能无心远离心　　即是真禅波罗蜜
  若能观心及菩提　　即是无上真实见
  若有如是真实见　　获得菩提不为难
  若能知见无文字　　一切诸法无生灭
  若作如是观见者　　是即名为大智慧
  虽复口说于智慧　　智慧亦不住口声
  若知口声实无声　　即是智慧之真性
  若法无有此彼住　　中间亦复无住处
  一切法性无住处　　即是无上大智慧
  无有文字无有行　　无有相貌无有性
  无有取舍等二相　　是名无上大智者
  若观一切波罗蜜　　其性平等如虚空
  是即名为无平等　　能观一切法平等
  若能平等一切法　　亦能观于众生等
  悉能等观一切佛　　所得智慧无平等
  若诸菩萨有智者　　能观如是无等法
  即得无上菩提果　　犹如先佛之所得

无言菩萨说是偈时。万二千那由他众生发阿耨多罗三藐三菩提心。六万菩萨得无生忍。时华台中诸菩萨等。悉从座起头面礼佛。以妙莲华恭敬供养无言菩萨。口宣是言。我是知恩我今报恩。时舍利弗言。世尊。如是菩萨何因缘故发如是言。我是知恩我今报恩。佛言。舍利弗。如是菩萨皆悉因于无言菩萨发菩提心。是故说言我是知恩我今报恩。今复因于无言菩萨听受如是大集经典。并来睹见供养于我。尔时无言菩萨白佛言。世尊。我有所疑今欲启请。唯愿如来哀愍听许。佛言。善男子。随意致问当为汝说。时舍利弗语无言菩萨。仁者。若无言语云何得问。大德。一切诸法皆悉无言无字无说。何以故。一切众生性无言故。以觉观故而有声出。若无觉观云何有声。云何可说。云何有字。大德。夫觉观中无字无声。离于觉观亦无声字。觉观之体即非觉观。我作文字亦不觉观。我因觉观有大功德。若能观于如是深法。是则名为十二因缘。若从缘生即是空寂则无定相。若有如是真实知者。即是真实知于法性。大德。诸法悉从因缘和合。而和合中实无作者生者出者。是故诸法无主无音无声无心。无有觉观非无觉观。何以故。颠倒因缘而有出灭。是故若有问者听者及解说者。不合不散一相无相。大德。夫问难者即是大悲。我有大悲是故问佛。如是问者即是悲问非口问也。夫口问者是声闻问。声闻着声故名声闻。菩萨普悲故无口问。舍利弗言。善男子。若一切法性无定者。一切众生性亦无定。若无定者菩萨为谁而修悲心。大德。若诸众生有定性者。一切菩萨终不修悲。一切众生实非众生。以颠倒故作众生想。是故菩萨修集悲心。为坏颠倒宣说无我。大德。菩萨摩诃萨不为坏有而说正法。不为坏我寿命士夫而修慈悲宣说正法。为知真实深法界故而宣说法。真法界者即空三昧无相无愿。舍利弗言。善哉善哉。善男子。我亦如是真实了知。所以相问试汝智耳。为令佛法增长故问。为欲利益众生故问。尔时无言菩萨白佛言。世尊。如经中说有二因缘能生正见。所谓闻声及善思惟。唯愿哀愍为诸菩萨广宣说之。云何闻声及善思惟生于正见。佛言。善男子。至心谛听。吾当为汝分别解说。善男子。为菩提心而听法者即是闻声。至心忆念菩提之心。是善思惟。观菩提心是名正见。复次善男子。为菩提道而听法者。是名闻声。不远离道是善思惟。如法而住是名正见。为调伏心而听法者。是名闻声。远离恶心是善思惟。获得善心是名正见。为严善法而听法者。是名闻声。修集庄严是善思惟。愿向菩提是名正见。为听善法是名闻声。增长善法名善思惟。愿向菩提是名正见。为听惠施是名闻声。能舍一切是善思惟。不求果报是名正见。为听戒聚是名闻声。至心护戒名善思惟。愿向菩提是名正见。为听法忍是名闻声。打骂不报是善思惟。愿向菩提是名正见。为听精进是名闻声。破坏懈怠是善思惟。愿向菩提是名正见。为听三昧是名闻声。能净身心是善思惟。愿向菩提是名正见。为听智聚是名闻声。闻已正观是善思惟。愿向菩提是名正见。听四摄法是名闻声。摄取众生是善思惟。知是摄法无取无作空无所有是名正见。听五通法是名闻声。得身心轻名善思惟。愿向菩提是名正见。听四无碍是名闻声。修集无碍是善思惟。愿向菩提是名正见。听四依法是名闻声。勤修四依名善思惟。愿向菩提是名正见。听三十七品是名闻声。若闻演说四念则是念处。说于舍离谓四正勤处。说于定聚谓四如意。说无所畏谓诸根处。说无能坏谓诸力处。说离烦恼谓七觉分。说真知法谓八正道。是善思惟不着断常。以如是道愿向菩提是名正见。听四谛法是名闻声。知苦离集证灭修道。是善思惟。见如是法不生不灭是名正见。听三解脱是名闻声。信空三昧。不畏无相。不疑无愿。是善思惟。以如是法愿向菩提名为正见。修空三昧调心明见。修集无相为除觉观。修集无愿为求诸有。是名正见。听发心法是名闻声。修菩提道是善思惟。其心不退是名正见。得善知识是名闻声。供养亲近名善思惟。受其教诲是名正见。听于法界是名闻声。观于法界是善思惟。如法而住是名正见。见佛世尊名为闻声。念诸菩萨名善思惟。得毕竟道是名正见。初听八万四千法聚是名闻声。观诸众生如是行处是名思惟。调伏八万四千诸根是名正见。善男子。随何因缘能生善法是名闻声。闻已不离诸善因缘名善思惟。以如是法愿向菩提是名正见。善男子。如是二法无有差别。谓善思惟及以正见。何以故。一切诸法平等无二。是善思惟能观平等。是正见故。无增减者即是正见。无取舍者即是正见。无作作者即是正见。无觉观者即是正见。无念念处即是正见。无作无思即是正见。无一无二即是正见。一门一味一乘一行其性是一。无诸烦恼憍慢等结。无闻无说无垢无净。法界之性不可分别。如如不动三世平等。无我我所。无有众生寿命士夫。无字无声。不可宣说。不知不见。一切法中得知足心。远离诸相。断一切喜觉观屋宅。乃至赞佛不生佛相。若入定时。观如是等甚深法界。名善思惟。从定起已为诸众生。宣说如是甚深法界。是名正见。说是法时十千菩萨得是正见

尔时舍利弗语无言菩萨言。善男子。从谁闻法而得正见。无言菩萨言。大德。若有不得去来现在菩提心者。我从彼闻而得正见。观三世等一切法等。于一切法不生觉观。其心不住有为无为。远离一切众生之相。而为众生修诸苦行。亦复远离二种之相。一众生相。二者心相。远离二节知实法性。实法性者无有有有。通达一切诸佛深法。不生憍慢自言我知。大德。我从是人听受正法。是人亦不宣说一字。亦令一切而乐闻之。知法真实不可宣说。为众生故而宣说之。出于世间不为世污。毕竟修集无有能知修与不修。我从是人闻受正法。住于法性于众生性不生分别。观众生性法性空性皆悉平等。我于如是人边闻法。是人不坐菩提树下。不起不行不眠不卧。不睡不寤而得菩提。得菩提已终不作相言得菩提。一切众生亦不知彼获得菩提。无得乃得故无得相。大德。夫正法者无有光明。无光明者即无处所。无处所者即是无身。无身者即是无畏。无畏者即是不出。不出者即是不生。不生者即是不灭。不灭者即是不着。不著者即是不动。不动者即是不变。不变者即无駃无闇。无駃无闇即无觉观。无觉观者即是无世。无世者即是无器。无器者即是无贪。无贪者即是性净。性净者不合烦恼。不合烦恼者即不颠倒。不颠倒者即是平等。平等者即是真实。真实者不生不灭。不生不灭者名从因缘。从因缘者即不去来。不去来者即无境界。无境界者即是无句。无句者即是不狂。不狂者即是无闻。无闻者即是无作。无作者即是无住。无住者即是无字。无字者即是无相。无相者即是过于心意识句。过心意识即是寂静。寂静者即是无热。无热者即是无嗔。无嗔者即毕竟。毕竟者即是无有。无有者即是涅槃。是名为法。大德。即是正法。即是说法。即是闻法。即是正见。大德。夫正见者不见于身。身行病行。不见于见。不生贪着。不觉不观。是名佛法圣见正见。复次大德。观无明爱与解脱等无有差别。是名正见。如是见已不着不取。是名圣见。复次大德。观贪恚痴空无相愿平等无二。不见于相见无相相。是名圣见。不观一二等一切法。名圣正见。复次大德。若能观我及众生等。众生等故如来平等。如来等故佛法平等。佛法等故圣众平等。圣众等故大慈平等。慈平等故虚空平等以不住住。如是平等名圣正见。大德。如一切法声亦如是。如声即是圣见即是正见。大德。圣正见者亦无生出。若无生出从谁听法。舍利弗言。如我解仁所说义者。一切诸法无所语言。大德。如是如是。一切诸法实无言语。善男子。若言如来成就功德。如是言中得何等罪。大德。若如是说。当知是人有大过咎。何以故。如来功德不决定故。所以者何。无福无罪故名如来。若观如来有功德者。是名为欲。夫有欲者即是大欲。有欲大欲即是过咎。善男子。云何得名无过咎耶。大德。如第五大。如第七情。如十九界。无出无入无生无灭。无有造作无心意识。乃名无过。若有知见远离证修。是名罪过。若有诸界是名罪过。若无诸界是名无过

尔时佛赞无言菩萨言。善哉善哉。善男子。如汝所说即是善说。说是法时万二千菩萨得无生法忍。无言菩萨复白佛言。世尊。如佛所说。菩萨摩诃萨有四种力。所谓信力进力念力慧力。唯愿如来广分别说。云何名为菩萨四力。佛言。善男子。至心谛听吾亦当说。若有菩萨于佛正法深信顺解不作疑心是名信力。若勤精进求于佛法。不休不息不生疑悔是名进力。若有菩萨求于善法。得已不失念菩提心。所作善根。愿向菩提是名念力。若有菩萨内自思惟不随他语了知法性是名慧力。复次善男子。若有信心亲近圣人是名信力。若能供养如是圣人是名进力。至心听受圣人之言是名念力。闻圣法已如法而住是名慧力。复次善男子。信业果者是名信力。既生信已不作诸恶是名进力。过去善业现世犹增是名念力。若知诸法有因有果是名慧力。复次善男子。若信心法不可说者有名信力。若因此信能调伏心是名进力。若能至心是名念力。观法如幻是名慧力。复次善男子。若见法空是名信力。若断邪见是名进力。若见内外悉皆空寂不生怖畏是名念力。若能观见第一义空是名慧力。复次善男子。若能观见无相无愿是名信力。为他演说无相无愿是名进力。至心观察无相无愿是名念力。了知是法不可宣说是名慧力。复次善男子。能一切施不求果报是名信力。施已不悔亦不休息常行不绝是名进力。施时至心念于菩提发愿回向是名念力。不观财物受者施者及以果报是名慧力。复次善男子。若有受持清净禁戒不求果报是名信力。不生烦恼毁坏禁戒是名进力。如是净戒至心护持愿向菩提是名念力。观身口意如水中月响幻炎等是名慧力。复次善男子。若有修行忍辱之法不求其果是名信力。若有打骂能忍受之是名进力。为忍辱故修集慈悲及不放逸愿向菩提是名念力。观身口意都无所忍是名慧力。复次善男子。若有了知勤精进故。得阿耨多罗三藐三菩提。非懈怠得是名信力。若能调伏一切众生。护持听受供养正法。能为众生趋走给使能净佛土是名进力。能令众生远离懈怠。勤修精进愿向菩提是名念力。若修精进不增不减是名慧力。复次善男子。若乐寂静离说世事是名信力。若住空寂获得四禅及八解脱是名进力。若于诸禅无有退失是名念力。若观诸禅无常苦无我是名慧力。复次善男子。若闻一切诸波罗蜜三十七助菩提之法信不生疑是名信力。闻已转为众生演说是名进力。心善思惟是名念力。如法而住是名慧力。复次善男子。为诸众生修集慈心是名信力。怜愍众生令其离苦是名进力。观察法已心得大喜是名念力。于怨亲中其心平等修集大舍是名慧力。复次善男子。观察是身无量众恶之所成就诳惑凡夫犹如幻相是名信力。受死苦时专心系念佛法僧宝不惜身命是名进力。亦不生于诸恶之心。声闻心辟支佛心。贪心嗔心痴心。妒心悭心毁戒心是名念力。若观法界分别法界观无碍智。亦知过去未来现在是名慧力。复次善男子。喜者名信。不退转者名为精进。不狂乱者名为念力。了了知者名为慧力。复次善男子。以信力故能有所作。以进力故事得毕竟。以念力故无所漏失。以慧力故能如法说。复次善男子。观疑网故名为信力。远离疑故是名进力。更不生疑是名念力。说能坏疑是名慧力。复次善男子。信佛法者是名信力。为菩提故而修行之是名进力。得顺忍故是名念力。得无生忍是名慧力。善男子。信根信力无有差别。进根进力。念根念力。慧根慧力。亦复如是。说是法时。百千菩萨得无生忍地。四万二千众生发阿耨多罗三藐三菩提心

是时会中有一菩萨名曰莲华。语无言菩萨言。善男子。汝向问佛。佛即为汝分别解说。汝心喜耶。无言菩萨言。善男子。我亦不问不听一法。云何生喜。莲华菩萨言。善男子。汝于佛所不听法耶。无言菩萨言。诸佛如来都无所说。我云何听。何以故。我非法器故。莲华菩萨言。汝今若非是法器者。是何等器。无言菩萨言。善男子。我身今者尚非法器。况复余器。莲华菩萨言。汝若非是真法器者。云何当得阿耨多罗三藐三菩提。无言菩萨言。善男子。阿耨多罗三藐三菩提亦非是器。善男子。若离佛法有菩提者。当知有器。一切佛法即是菩提。菩提即是佛法。善男子。是故我若远离烦恼。不见佛法不见菩提。烦恼菩提及以佛法无有差别。若烦恼中见菩提者即是如见。若离烦恼见菩提者是名倒见。莲华菩萨言。善男子。云何名倒见。见我寿命士夫摩纳。离是之外别有贪欲嗔恚愚痴。是名倒见。一切法性及菩提性无有差别。无作无受我性众生寿命士夫摩纳。即是贪欲嗔恚愚痴。如是等法即是菩提。是名如见。即四大中及四大造求于菩提不余处求。云何名求。求时不见一切诸物。不见者即是无处。无处者即是无住。无住者即是一切诸法之性。一切诸法若无性者即是实相。实相者非常非断名毕竟节。若有能见如是等节。当知是人不流不散。不流不散即无生灭即是涅槃。即是实知一切诸法。若如是等得涅槃者。即是圣句入于涅槃。是故如来于经中说。自不调伏能调伏他。自不解脱能解脱他。自不寂静能寂静他。自不涅槃令他涅槃。无有是处。若自调伏令他调伏。若自解脱令他解脱。若自寂静令他寂静。若自涅槃令他涅槃。斯有是处。善男子。菩萨摩诃萨修菩提道。解了一切众生所行。于诸法相及以法界不生分别修行一切善法之时。亦不见有诸魔徒众。虽求佛法不见求者。虽调众生不见我人。虽行诸法烦恼不污。虽顺世法世法不染。负五阴担亦无住处。远离诸界不动法界。修解脱法门不退善法。明见三界不杂烦恼。行檀波罗蜜不生憍慢。乃至般若波罗蜜亦复如是。随一切行实不行于一切诸行。若能修行如是等行。当知即是行菩提道。于菩提道及菩提行不生分别。若行如是菩提道行。于诸法中不见有我。无贪无嗔无亲无怨无有障碍。若无障碍即无为行。若无为行即是真实大菩萨也。莲华菩萨言。善男子。何因缘故名为菩萨。善男子。能觉众生所不觉者故名菩萨。能寤无明睡眠众生故名菩萨。演说随顺菩提之法故名菩萨。能令众生深乐寂静是名菩萨。增长佛语竖正法幢护念圣众。于菩提心无有动转。不住声闻辟支佛心。终不舍离至诚之心。发愿毕竟能度未度能解未解。为无依者而作归依。能灭未灭能调烦恼。不脱烦恼观生死过亦求诸有。修空三昧不舍众生。修集无想不舍菩提想。修集无愿深乐诸有。虽乐佛法于贪无贪。知有为法多诸罪咎。而其内心不舍有为。虽离诸闇不得大明。得大智慧以为器钾。深乐惠施严施璎珞。净佛世界具足净戒。具足誓愿具足忍辱。能调一切不忍众生。勤修精进求无坏身。能坏欲界乐受下身。虽受诸有其心不悔。善知方便常自调伏求于菩提。为诸众生修习慈心。为坏众苦修集悲心。为调不调修习喜心。非毕竟舍修集舍心。通达了了解甚深义。非诸声闻缘觉境界。依于义法了义经智不依世法。亦为众生而作依止。为诸众生庄严身口。如说而作庄严于心。为诸众生庄严神通。利益众生犹如大地。能净一切犹如大水。烧诸烦恼犹如炽火。于法无碍犹如猛风。于法平等犹如虚空。得陀罗尼持一切门。乐说无碍令众喜闻。至心念佛为净心故。能大法施叚食施故。正命自活威仪清净。修无诤三昧深乐寂静。乐调众生离说世语。见乐世者呵啧教诲。具七种财其心柔软。乐行惠施坚固不退。眷属不坏亲近善友。知恩报恩观过去业。随众生意能坏疑心。观察生死多诸过咎。所作至心解一切语。修集大乘不疑三乘。众生乐见随问而答。得无碍智诸佛所念。时节语不多语。光明清凉犹如秋月。善法具足犹如满月。众生乐见犹如明月。增长善法犹如初月。一味甘甜如月一味。观一切法如水中月。清净无垢如月无翳。易共语言诸根具足。于一切法犹如桥梁。能度众生于四駃水。为诸众生营作佛事。其心初不动菩萨界。以如是义故名菩萨。尔时莲华菩萨白佛言。世尊。无言菩萨作如是说。当知不久得阿耨多罗三藐三菩提。转于无上法宝之轮。若有能信受持如是无言菩萨所说法者。亦复当得如是功德。佛言。善哉善哉。善男子。如汝所说。无言菩萨得慧灯三昧。是故若欲于无量劫说一句义不可穷尽。莲华菩萨言。世尊。唯愿如来垂矜哀愍。增长众生诸善法故。庄严无上大集经故。少为大众开示如是慧灯三昧。若有智慧菩萨。闻已亦当获得如是三昧。得已亦当疾得阿耨多罗三藐三菩提。佛言。善男子。至心谛听。吾当为汝少分别说。言慧灯者即是智灯。智灯者即是破闇。无闇者即是破疑。破疑者即是慧灯。慧灯者即是诸法无二相也。善男子。了了智。不疑智。不失智。不挽智。不随智。无闇智。圣智。猛利智。捷疾智。分别智。广大智。纯一智。种种智。过去智。未来智。现在智。三世平等智。三界智。三解脱门智。三慧智。三宝智。三乘智。三眼智。三垢智。三滓智。三聚智。心意识智。阴入界智。因缘和合智。见毕竟智。如法界智。自相智。第一义智。方便智。一切声语智。一切字智。无碍智。不坏智。能说法智。知下中上根智。无作无受智。一切咒智。一切医智。一切世事智。庄严陀罗尼智。日月三昧智。入三昧智。圣智。圣三昧智。金刚三昧智。无诤三昧智。心等三昧智。坏魔三昧智。日光三昧智。无想三昧智。宝幢三昧智。一切法门三昧智。一切法器三昧智。无边光三昧智。福德三昧智。无住三昧智。乐见三昧智。善见三昧智。无尽器三昧智。毕竟尽智。一切智。无动智。那罗延三昧智。一切见智。如是等六万三昧门智。我于往昔见燃灯佛。即得如是诸三昧门。如是诸三昧门。一切悉是慧灯三昧之所摄持。善男子。譬如日出能为四事。一者有大光明。二者除灭闇冥。三者示种种色。四者令诸众生得造事业。菩萨摩诃萨住是三昧亦复如是能为四事。一者破坏一切烦恼闇冥。二者出大慧光。三者示诸众生种种诸行。四者开示众生道非道等。善男子。譬如净宝之珠置之高幢。其明遍照四由延所。施诸众生所须之物。而珠体相无有增减。慧灯三昧亦复如是。住是三昧菩萨摩诃萨。永断一切烦恼习气。净戒净定净慧净身心净于方便净陀罗尼。修集大悲放大光明。遍照无量诸佛世界。随众生意而作事业。菩萨虽作如是诸事。而其相性无有增减。善男子。譬如虚空容受佛土无有障碍。亦不障碍一切雨渧风火水灾。一切众生无量无边。善男子。慧灯三昧亦复如是。住是三昧诸菩萨等。为诸众生说一切法无有障碍。方便教化一切众生。为因力者演说方便。令其解脱调伏成熟。为邪定者方便演说令坏邪定。无善子者令种善子。无法器者令作法器。为法器者分别演说阿耨多罗三藐三菩提。求声闻人方便说法。令其获得四沙门果。求缘觉人方便教诲。令其获得辟支佛道。复为方便说法渐进。令其悉发阿耨多罗三藐三菩提心住不退地。通达八万四千法聚。为坏众生疑网心故。种种开示分别解说。解说一事于无量劫不可穷尽。虽作如是无量之事。而是三昧亦无增减。善男子。譬如一灯力能显示种种诸色。慧灯三昧亦复如是。于一心中能于无量诸佛世界示种种色。而是三昧无有倾动。是故四念处中法念为顶。四正勤中未生善法能生善法名之为顶。四如意中身心寂静名之为顶。五根五力中慧根慧力名之为顶。七觉分中择法为顶。八正道中正见为顶。一切外道所有舍摩他毗婆舍那名之为顶。四真谛中灭谛为顶。四依之中依义为顶。四无碍智义无碍智名之为顶。六神通中漏尽为顶。四无量心悲心为顶。修梵行中智慧为顶。诸波罗蜜中般若为顶。一切方便知众生心名之为顶。一切诸力处非处力名之为顶。诸无畏中初名为顶。不共法中无碍为顶。三十二相无见顶相名之为顶。八十种好不空说法名之为顶。庄严口中解一切语名之为顶。庄严心中破慢为顶。一切法中智慧为顶。是名慧灯三昧。说是经时。莲华菩萨及万菩萨得是三昧。三千大千世界大地六种震动。一切大众以妙华香种种伎乐供养于佛尊重赞叹。时会菩萨各作是言。世尊。我等昔来未曾闻是三昧名字。况得闻其广说分别。我今皆得如是三昧。是故报恩设此供养。若有闻是三昧名字。即能获得大利益事。不失无上菩提之心。佛言。善哉善哉。善男子。如汝所说。若有众生。已于无量无边佛所。殖诸善本亲近善友。然后乃得闻是三昧。尔时世尊说是法时。于其脐中出一菩萨身真金色。三十二相八十种好放大光明。除佛光明余无及者。是时菩萨敬礼佛足右绕七匝。长跪合掌而白佛言。世尊。慧憍如来致意无量。问讯世尊起居轻利身无病患大众安不。我今此界有六万亿诸菩萨等。欲往听受大集妙典。并欲觐见无言菩萨。及以十方诸来菩萨。并复欲闻慧灯三昧。善哉善哉释迦牟尼。幸为开示。令诸往者悉得慧灯三昧还来此土时舍利弗言。世尊。慧憍如来住何方面去此远近世界何名。而是菩萨复名何等。是六万亿诸菩萨等住在何处。舍利弗。其佛世界去此东方过一恒河沙等恒河沙世界。世界名曰金刚坚根。佛号慧憍。舍利弗。何因缘故。世界名曰为金刚坚根。舍利弗。彼佛世界地悉金刚。其佛愿力故致如是。其佛身体众生菩萨身悉金刚。是故世界得如是名。此菩萨者名金刚脐是人能于一念之顷。破坏一切金刚诸山。直至无量诸佛世界。示现诸佛脐中而出。以佛神力及已愿力。是故名为金刚脐也。舍利弗。汝向所问如是菩萨住何处者。汝今当问彼金刚脐。自当答汝。尔时舍利弗。即问金刚脐言。善男子。汝言六万亿菩萨者住在何处。金刚脐言。如来说汝智慧第一。当以圣智观是菩萨所住之处。时舍利弗。即以圣智观之不见。语金刚脐。善男子。我尽圣智不见。大德。汝之同学阿尼楼陀。天眼第一。当令观之住在何处。尔时阿尼楼陀。以天眼观三千大千世界亦不能见。语舍利弗。我以天眼都不能见。金刚脐菩萨言。大德。汝之同学若不能见。不名天眼应名肉眼。舍利弗言。善男子。汝之天眼其义云何。大德。我之天眼。汝诸声闻所不见色我能见之。舍利弗言。善男子。何等色法我不能见而汝得见。大德。汝今得见金刚坚根世界。慧憍如来及菩萨不。不也善男子。我唯闻名不能得见。大德。如是佛土如来菩萨及诸众生。我之天眼悉能得见。是名菩萨清净天眼。如是天眼。一切声闻辟支佛等之所无有。说是法时。求声闻者六万众生舍离本志。发阿耨多罗三藐三菩提心。各作是言。愿我获得无碍佛眼不用声闻辟支佛等障碍之眼。尔时金刚脐菩萨即入三昧。以佛神通及己力故。令一切众悉见六万亿诸菩萨等。在佛身内坐莲华台。至心专念听佛所说。然不逼触如来之身而如来身无增无减无有障碍。时诸大众见。是事已。供养礼敬欢喜赞叹如来之事不可思议。复作是言。如来之身智慧三昧。一切悉皆不可思议。何以故。是六万亿诸菩萨等。悉住身内无障碍故。金刚脐菩萨观诸大众作如是言。诸大众汝等不知如来之身如虚空也。是无边身。无障碍身。广身法身。无相貌身。无量身耶。诸善男子。如来若欲内一切物所谓国土城邑村屯聚落山河树木置身中者亦无障碍。是故如来不可思议。善男子。十方世界无量净土无量菩萨来诣如来。听大集经成就妙色。具二十八大人之相。如来亦内置其身内。何以故。此土众生梵释诸王。若其见者生愧耻故。是故不令得见一人。尔时世尊功德力故。及金刚脐菩萨力故。悉令大众见如是等六万亿菩萨。悉从如来一毛孔出。出已礼佛右绕七匝却坐一面。尔时金刚脐菩萨白佛言。世尊。何因缘故无言菩萨名无言也。佛言。善男子。汝自咨问无言菩萨。自当答之。金刚脐菩萨。即问无言菩萨善男子。何因缘故字无言耶。无言菩萨默然而住。二问三问亦复如是。金刚脐言。善男子。何故不答。无言菩萨言。我求言辞都不可得。是故默然无所宣说。善男子。若求言辞不可得者。云何有是不得之言。善男子。我答一切佛语世语。云何名为答佛语耶。善男子。我以念力受持一切诸佛所说。不忘不失。然都不见音声字句。为流布故而宣说之。亦为众生坏是声字及以文句而宣说法。云何名为答世语耶。解诸众生种种言音。随其所言而为说法。善男子。汝能如是随顺说法为久近耶。善男子。我从除灭觉观已来能作是说。善男子。何因缘故作如是说。善男子。若无觉观声云何出。以是因缘作如是说。善男子。夫声出者。为从身出从心出耶。善男子。夫音声者不在身心。何以故。身如草木心如幻化。众因缘故有声而出。若从缘出即是无常。若无常者即是无定。无常无定即是空无。夫音声者犹如虚空。不可睹见不可宣说如虚空。一切诸法亦复如是。若声无者。声所了法亦复是无。是声空故一切法空。声寂静故诸法寂静。声不可见一切诸法亦不可见。声不出生一切诸法亦不出生。若不出生即无去来。若无去来即是甚深十二因缘。甚深因缘无作无属。若无作属即无生出。无生无出即是无句。若无句者即是不生。眼色及识乃至法识。无有生老病死等苦。日月光明亲怨之想。断一切行难可睹见不近不远。金刚脐言。善男子。如是等说是何等说。善男子。如是即是毕竟不出。善男子。何等名为毕竟不出。善男子。不近不远是毕竟不出。善男子。何等名为不近不远。善男子。即是虚空。若见诸法如虚空者是名平等。善男子。以何义故。名一切法如虚空耶。善男子。过去之法无有终竟。未来现在亦无终竟。三世无终即是实相即是无二。二者所谓。眼色耳声鼻香舌味身触心法是名为二。若有二者即是可说。若无二者即不可说。不可说者即是无识无心无意。以是义故不可宣说。夫可说者即是二法。不可说者即是无二。善男子。谁作是二。善男子。夫无二者不可作二。二亦不可作于无二。若坚牢者不可作脆。脆亦不可作于坚固。生死之法不作无二。涅槃之法不得作二。正见之性不作邪见。邪见之性不作正见。金刚脐菩萨白佛言。世尊。无言菩萨凡所解脱。似得如是慧灯三昧。佛言。善哉善哉善男子。汝谓无言不得慧灯三昧耶。尔时金刚坚根世界。慧憍如来诸菩萨等。语无言菩萨言。善男子。汝住何地能作是答。无言菩萨言。善男子。如佛所说。菩萨摩诃萨。若住戒地能如是答。善男子。善哉善哉。唯愿解说如是戒地。善男子。若无身住心住意住内住外住及内外住即是住戒。善男子。若无相无命无作无行即是住戒。若有菩萨住如是戒即是无住。若无住者终不生念。我能出声有所演说。善男子。如汝所问住在何地。能如是答者。我住法性实相法界能如是答。若如是知法真实者则无觉观。若无觉观云何有说。诸菩萨言。善男子。如是说时为何所说。善男子。如是说时即说二法。一者灭尽。二者不出。一者过去。二者未来。现在不住故不可说。善男子。过去之法不可作相。未来现在亦复如是。若使有人于三世法而作相者即是颠倒。是故一切诸法之义不可宣说。一切法义身口意等所不能说。何以故。无业无作。无有色貌。无有口业。无有觉观。犹如响相。如佛化故。善男子。诸佛菩萨凡所言说皆逆世语。是故一切诸佛菩萨不可思议。诸佛菩萨所有智慧。不可思议不可穷尽不动法界。尔时一切菩萨摩诃萨。同声赞叹无言菩萨。善哉善哉。善能分别如是法门。令我等辈得大利益。并得觐见如是无量诸大菩萨。金刚脐语无言菩萨言。善男子。我欲与汝俱还金刚坚根世界觐见供养慧憍如来。无言菩萨言善男子。金刚坚根世界。即是此间娑婆世界。慧憍佛者。即是释迦牟尼如来。我何用往彼佛世界。金刚脐言。善男子。此佛世界地非金刚。云何而言即彼世界。无言菩萨言。善男子。汝之神通能坏无量。金刚之山直过无碍。汝今试坏此土微尘。如其坏者然后乃知汝名金刚。尔时无言。即便入于金刚三昧。悉变此土一切山林草木微尘皆为金刚。时金刚脐尽其神通。乃至不能破一微尘。时金刚脐白佛言。世尊。我之神力能坏一切世界金刚及诸山壁。以何因缘今于此土。乃至不能坏是一微尘。为是如来神通之力。为是无言道德力耶。佛言。善男子。是无言菩萨入金刚三昧。三昧力故令此三千大千世界一切所有悉为金刚。若欲复使无量世界为金刚者其力亦能。金刚脐菩萨言。世尊。菩萨摩诃萨具足几法。能得如是金刚三昧。佛言善男子。菩萨摩诃萨具足四法。则能获得如是三昧。何等为四。一者至心念于菩提。二者所作善法毕竟。三者至心庄严善法愿向菩提。四者能观十二因缘。是名为四。复有四法。一者成就神通。二者修三脱门。三者持戒精进。常观法界知一切法无有根本。无有觉观不可宣说。四者知义知时。知实知一切法皆悉平等。是名为四。复有四法。一者从大悲心求大智慧。二者从善方便求三十七助菩提法。三者从大慈心观诸众生一切平等。四者从于舍心观四真谛。复有四法。所谓身口意业。及菩提心不可沮坏悉如金刚。善男子。菩萨摩诃萨。具足成就如是等法。则能获得金刚三昧。说是法时。六万亿菩萨一切悉得金刚三昧。尔时无言。启白其父师子将军。尊者。佛出世间即是具足无量功德。大功德聚即是如来。佛出世时无量众生得大利益。大利益者即是涅槃。夫涅槃者常不变易。尊者何故不发阿耨多罗三藐三菩提心。其父答言。吾初生时。已发阿耨多罗三藐三菩提心。尔时亦有无量诸天。来劝如汝无异。如是事者唯佛证知。师子将军所将眷属满五百人。悉发阿耨多罗三藐三菩提心。尔时无言菩萨。赞其眷属。善哉善哉。善能庄严菩提之心。诸眷属言。云何名为庄严菩提心。无言菩萨言。有四十事庄严菩提心。何等四十。所谓信佛不疑。不动法界。供养圣众。亲近善友。于诸菩萨作医王想。于诸众生其心平等。供养恭敬诸师和上。父母有德顺受其语。护法求法。至心听法。既受持已为人广说。供养恭敬护法之人。为他说法。不生食想。破坏憍慢。知恩报恩。常善思惟。如法而住。能施难施。至心护戒。精进勤修一切善法。具足成就功德庄严。心无嫉妒护诸众生。防制烦恼。调伏其心及以施心。调诸众生能断烦恼。知足寂静。修净梵行。不断圣种。世法不污。供养恭敬说法之人。随顺世间。远离懈怠。无有放逸。不求下乘菩提之心初不动转。处在生死心不厌悔。远离一切不善之法。具足一切纯善妙法庄严梵行。是名四十。尔时师子将军言。汝当时时示现其身。为令我等不退无上菩提之心。无言菩萨言。尊者。具足十法常得亲近诸佛菩萨。何等为十。所谓自舍己乐以施众生。修集忍辱护无力者。常劝众生修集善法。化导一切趣向菩提。愿诸众生先得阿耨多罗三藐三菩提。我当供养听其所说受持拥护然后我当成无上道。知实法性不惜身命。为护法故闻深法界不生恐怖。观无菩提无有得者。观己平等一切众生亦复平等。以众生等观法亦等。以法平等观虚空等。观生死苦亦不舍离。见生死过心无悔恨。具足如是诸善法者。常得亲近诸佛菩萨。说是法时。师子将军及诸眷属得柔顺忍。尔时世尊告阿难言。阿难。汝当受持读诵书写如是经典。何以故。是经典中分别演说一切法相。亦令无量无边众生。发阿耨多罗三藐三菩提心。阿难。若有能于无量佛所植诸善本。是人乃能信受是经。持读诵写广分别义。受是经者有三事。一者定发阿耨多罗三藐三菩提心。二者得不退心。三者能护正法。尔时大众闻是语已。有七那由他菩萨。即从座起白佛言。世尊。我等能于如来灭后。受持是经读诵书写。无言菩萨言。世尊。如来世尊得何等法。而令是等受持守护。善男子。若能护是持法之人。即是护法。所谓书写读诵解说文字。文字可说法不可说。善男子。有二种人能守护法。一者如法而住。二者诵是文字。若无文字法不可说。尔时一切大众。及师子将军所将眷属诸天世人。闻是法已心大欢喜信受奉行

大方等大集经卷第十二大方等大集经卷第十三

        北凉天竺三藏昙无谶译

    不可说菩萨品第七

尔时世尊。故在欲色二界中间大宝坊中。与诸大众围绕说法。是时会中有一菩萨名不可说。从座而起更整衣服。偏袒右肩前礼佛足。长跪合掌而说偈言

  无碍智慧无碍行　　如虚空性不可说
  三世平等无觉观　　我今敬礼无上尊
  观于无相乐寂静　　调伏诸根远离相
  了诸法性无有二　　我礼人中师子王
  观众生性及法性　　如是二性无差别
  等心观于诸众生　　今我永断一切性
  所得菩提无所得　　如菩提性色亦尔
  无相庄严庄严相　　我今敬礼无上尊
  一切法界无觉观　　凡夫观之有相行
  法界之性不破坏　　佛真实智故我礼
  如来身业不可说　　口意等业亦如是
  一切法性及众生　　无上胜尊了了知
  如来住于真实地　　所可演说无声字
  众生乐闻得大利　　是故如来难思议
  所说诸法无相貌　　调伏众生断诸有
  善说众生法性空　　是故我礼大丈夫

尔时不可说菩萨。偈赞佛已。白佛言。世尊。此会菩萨。各各当已已咨请竟。我今于是大集经中复欲少问。唯愿如来垂哀听许。佛言。善哉善哉。善男子。随疑致问。吾当为汝分别解说。尔时不可说菩萨。既蒙许可即入定意。入定意已悉令大众处大宝台。上虚空中雨散华香种种伎乐。而以供养复出是声。是不可说菩萨摩诃萨。今于是中欲问大事。尔时不可说菩萨摩诃萨白佛言。世尊。诸佛菩提清净寂静。大静无垢无闇大光。真实如尔其性平等。微妙甚深无有觉观。远离诸垢不可宣说。无字无句无有音声。广大无量无有边际。离一切边不增不减。不前不却无有住止。无峻无平无有无无。坚固无坏无我我所。无取无舍无广无狭。无法无众生。无尽毕竟尽。不空空性。非处非非处。非心非作非生非灭。如地水火风。无有边际不可度量。平等遍有无有障碍犹如虚空。非眼识界乃至非意识界。断一切有不可譬喻离一切喻。如一切佛真实知故非不是如。何以故。一切众生皆悉得故非异于如。何以故一切众生悉平等故其性是有。何以故。是实性故其性是实。何以故。无有去来现在节故。无作无受无色无心。无想无受断一切受。无想断想。无行断行。无识断识。无阴入界断阴入界。无初中后离诸魔业。无有流布无漏非摄。非行非讼无诤无罪。常住自性无有分别。无生无能生。无灭无能灭。无有根本无上无下。无有屋宅无方无间。非智非慧亦非慧行。非谛所摄非生死摄。无有对治无具功德远离诸相。世尊。若如是义名菩提者。即无变句。即无觉句。即无贪句。即无诤句。即坚固句。即不坏句。即不动句。即不作句。即无身句。即无生句。即无智句。即平等句。即无二句。即是实句。有句。真句。第一义句。无分别句。一味句。一事句。一乘句。无尽句。三世平等句。分别三世句。空句。无相句。无愿句。无行句。寂静句。性句。如句。无生句。无出句。尽句。无屋宅句。法句。实性句。自身性句。无身句。无作句。无想句。无诤句。无断句。无常句。十二因缘句。可观句。定句。上句。胜句。无罪咎句。无上句。毕竟句。净句。无顶句。无胜句。无等句。无依句。念句。无相似句。胜一切世间句。无句句。一切句之所依句。如是菩提。非青非黄非赤非白非色非非色。非长非短非圆非方无有规矩。非三界摄。非道非毕竟非行非到。非有处所非取非舍。离诸烦恼无有愁畏。断一切喜无真无化。离一切入无我我所。无有众生寿命士夫。无量无边不可思议。无有分界犹如虚空。其性毕竟不可宣说。成就如是无量之法乃名菩提。说是法时。三千大千世界大地六种震动。一切诸天大设供养香华伎乐。各作是言。善哉善哉。善男子。快作是说。尔时会中有八万四千菩萨。得无尽器陀罗尼一切法自在三昧无碍解脱法门。若有人能如是信者。是人亦当得是法利

尔时不可说菩萨复白佛言。世尊。菩萨之戒不可宣说。何以故。身之本性不可说故。是故身戒不可宣说。口之本性亦不可说。是故口戒不可宣说。意之本性亦不可说。是故意戒不可宣说。世尊。若有菩萨修行无上菩提道时。护十善法亦不可说。若以十善劝诸众生。所劝众生亦不可说。修集慈悲喜舍之心亦不可说。何以故。修集慈心观无众生。修集悲心无作无受。修集喜心离憍慢醉。修集舍心远离二相。世尊。若有菩萨如是修集四无量心。即是修于清净梵行。住于梵道。是梵方便胜一切梵。常为诸梵之所供养。何以故。胜出一切诸梵行故。不修众生因缘慈故。不修诸法因缘悲故。不修二相因缘喜故。不修内外因缘舍故。远离一切世间行故。舍弃世间诸梵行故。是故常为一切诸梵之所供养。世尊。以是因缘。菩萨之戒不可宣说。菩萨戒者终不自诳亦不诳佛。何以故。自即无性无性即无无即无出无出即是无有因缘。无因缘者即是无字。无字者即是不可言说。若有菩萨能如是学即不自诳。云何名为不诳。诸佛如来觉了一切诸法非法非非法。若非法非非法者即是平等。如是平等不可宣说。若有菩萨作如是学。是名不诳诸佛如来。复次自者即是无我无有我所。知亦无我无有我所。若能如是修集学者。亦是无我无有我所。若能如是思惟观者即不自诳。又如来者能随于如。随于如者即随众生。随众生者即是随顺一切诸法。随一切法即是不出不灭不住。若法不出不灭不住即是无为。是故说言无为之法有三种相。所谓无出无灭无住。以是义故名为无为。无为即圣圣名无怨。如来远离一切怨故故名为圣。怨者所谓无明。如来永离一切无明。是故不为一切怨仇之所侵害。凡夫之人具无明故。是故常为怨仇所害。如来世尊能观怨界及智慧界。知烦恼界及寂静界。知生死界及涅槃界。知众生界及法界。了知魔界及以佛界。观于色界及以眼界。耳界声界鼻界香界舌界味界身界触界意界法界。知无明界及智慧界。皆悉平等即是平等。佛界不可说界。生死涅槃二界平等。即是佛界不可说界。名色界知名色界皆悉平等。即是佛界不可说界。知六入界六神通界皆悉平等。即是佛界不可说界。触界灭界皆悉平等。即是佛界不可说界。受界灭界皆悉平等。即是佛界不可说界。爱界灭界皆悉平等。即是佛界不可说界。取界灭界皆悉平等。即是佛界不可说界。有界灭界皆悉平等。即是佛界不可说界。生界灭界皆悉平等。即是佛界不可说界。老病死界及以灭界皆悉平等。即是平等佛界不可说界。世尊。菩萨若能作如是等观即得入于一切诸界。菩萨若入如是等界。见有贪者不生嗔恚。见断贪者亦不生爱。见有嗔者不生嗔心。见断嗔者不生爱心。见有痴者不生恚心。见断痴者不生爱心。何以故。菩萨摩诃萨。于如是等三种界中了了知故。如是菩萨了知三聚。世尊。菩萨若欲作是学者不诳如来。何以故。知诸如来所觉诸法。而是菩萨随顺学故。是故菩萨不诳如来

尔时众中有一菩萨名无所畏。问不可说菩萨言。善男子。菩萨摩诃萨。云何而学名诳如来。不可说菩萨言。善男子。若有菩萨自作是言。我是持戒彼是破戒。如是菩萨名诳如来。我是施者彼是悭贪。我是修忍彼是嗔恚。我是精进彼是懈怠。我是定者彼是乱者。我是智慧彼是愚痴。我是知足少欲之人。乐于寂静易养易满。乞食粪衣唯畜三衣不处众中。多闻诤语所言柔软。众生乐受具念智慧。净诸威仪及以口业。具四摄法慈悲喜舍。真语实语如说而作。知魔境界知已远离。常能修学六波罗蜜。能善说法为诸众生发大誓愿。能化众生不令放逸。若作如是自赞己身毁呰他者。是名菩萨诳于如来。复次善男子。菩萨若言我能观察。如是等法远离修灭。是亦名为诳于如来。何以故。诸佛出世及不出世法性常住。以常住故一切法界不可知见。不可远离不可修灭。菩萨若说我及我所。是亦名为诳于如来。何以故无二相故。若有说言我已得证我能远离。是亦名为诳于如来。何以故性清净故。若言我有四念处者。是亦名为诳于如来。何以故。如来觉了一切诸法无有念故。若言我有四正勤者。是亦名为诳于如来。何以故。如来觉了一切诸法本性离故。若言我有四如意分。是亦名为诳于如来。何以故。如来觉了一切诸法无分别故。若言我具根力觉道。是亦名为诳于如来。何以故。如来世尊性无为故。若有说言我异道异。是亦名为诳于如来。何以故。身即是道故。若言无明异于有爱。是亦名为诳于如来。何以故。无明与爱即是智慧即解脱故。若言三毒异三解脱门。是亦名为诳于如来。何以故。空无相愿即是贪欲嗔恚痴故。若言四倒异四果者。是亦名为诳于如来。何以故。四倒即是四道果故。若言八邪异于八正。是亦名为诳于如来。何以故。为坏八邪修八正故。若言众生九居止处异九次第。是亦名为诳于如来何以故。无二性故。若有说言十善异于无学。十善。是亦名为诳于如来。何以故。一切诸法无修学故。善男子。菩萨若学如是等法。是名为诳诸佛如来。善男子。一切众生及一众生无二无别。何以故性无我故。言一众生一切诸法无二无别。若言一法一切法界无二无别。一佛世尊一切法界无二无别。言一佛界一切佛界无二无别。言一福田一切福田无二无别。一切福田及以虚空无二无别。一切圣人远离烦恼。一切凡夫无二无别本性清净。一众生心一切众生心。无二无别本性清净。一界一切界。一入一切入。一众生行一切众生行无二无别。若言诸法乃至无有一念暂住。不造众恶不着善法不生憍慢。于不得中不作得想。于不证中不作证想。知于生死及以涅槃无作无受。知诸烦恼无有根本无生无长。随于戒戒心戒慧戒。远离烦恼不舍众生。净檀波罗蜜。无戒于戒。净尸波罗蜜。无人于人及无有我。净羼提波罗蜜。无作于作。净毗梨耶波罗蜜。无净于净。净禅波罗蜜。无行于行。净般若波罗蜜。无尽无生获得忍辱。得无记心而受记莂。不入正位亦不退转。一生不生兜率陀天。不从天下而处母胎。于一切法心无所住。亦不自说我已过于生老病死。不行七步。亦不自言我是世间无上之尊。不处中宫婇女娱乐。不习世间技艺之事。示现老人为坏贪身。示现病苦为坏贪寿。示现死相为坏贪欲及我我所。示现沙门为令众生不求释梵人天之身。勤求出世无上之法。踰出宫城。示现出离三界系缚及示悲果。前后顾视示无嗔爱。三十二相庄严其身。为示众生良祐福田。剃除周罗弃舍璎珞。遣马揵陟放阐陀还。示现远离一切烦恼。现剃髭发示不贪着于一切法。受着袈裟示调众生。从郁陀伽阿罗逻边咨问受法。示现破坏自高之心。六年苦行为坏外道。现受饮食示随世法。现受槀草示于知足。坐草蓐上示坏憍慢。诸天龙神赞叹戴仰。示现功德庄严果报。降伏魔怨示勇猛力。右手指地示往福力。大地震动示报恩故。获得无上菩提之道。示现了知一切法相。观诸法等名之为佛。佛之智慧无能胜者。以是义故名为如来。了了知见善不善法名萨婆若。真实语故名天人师。不出诸法名转法轮。无转无说故名转说。无入之入名为法入。无门之门名为法门。无作之作名为法作。无禅之禅名为正禅。无脱之脱名正解脱。一切法性无系无缚。若是灭法即是过去。即是不生。是名佛出。无出之出即名佛出。若有菩萨能作是学。是名不诳诸佛如来。尔时世尊。赞不可说菩萨摩诃萨言。善哉善哉。善男子。善能分别如来出世。若有能信如是佛出。是人不觉一法微相。若不觉者乃能了知如来出世。何以故。无出之出即是佛出无作。无作者无受。无受者无漏。无漏者无诤无见。无入无转。无生无灭。无有菩提。无谄无诳。无心意识。无眼无二。无有眼行乃至意行。无说无教。是名佛出。尔时无畏菩萨白佛言。世尊。如佛所说。如来出世及不可说。所说佛出谁当信之。尔时宝女语无畏言。法兄。如来出世不可思议。难可庄严难可证得。若人懈怠心不真正虚伪谄曲憍慢喜嗔嫉妒悭贪。不知恩义受恩不报。三戒不净贪着三界。三垢所污不敬三宝不修三脱。粗犷恶口乐说无义不知惭愧。为利养故外现细行。自诳诳他贪于供养诸根不调。乐求声闻辟支佛乘。心不真实寡闻愚痴。无念喜忘不知方便。不修慈悲喜舍之心常行魔界。贪着于人众生寿命。说无因果无业行缘。其心放逸乐为恶行。舍离头陀乐行世法自赞己身毁呰他身。贪于身命色等五法。乐于睡眠。喜闻世法不知时节。亲近恶友不能修行四摄之法。法兄。如是等人不知佛出不信佛出。无畏菩萨言。宝女。汝今已得远离如是恶法不耶。宝女言。法兄。我已远离如是恶法。云何远离如不贪节。云何不贪犹如贪节。云何贪节如真实节。云何实节如我见节。云何我见如过去节。云何过去如无明节。云何无明如贪爱节。云何无明贪爱等节。犹如智慧解脱等节。云何智慧解脱等节。犹如幻节。无畏菩萨言。宝女。幻者非心非意。智慧解脱即是心意。法兄。一切众生心意智慧。及以解脱悉皆如幻。无畏菩萨言。宝女。如不可说菩萨所说。汝能信不。宝女言。法兄。不可说者终无所说。如其说者非不可说。若不可说有所说者。云何得名不可说耶。即应是说。以不可说实无所说。是故名为不可说也。若不可说实无所说。我于今者为何所闻。若无所闻何所信耶。无畏菩萨言。宝女。是不可说实有所说。今有证知所谓大众一切大众皆悉得闻。是不可说之所宣说。宝女言。法兄。此大众中若有言我闻不可说之所说者。即是虚妄。何以故。是不可说实无所说。云何大众而言闻耶。无畏菩萨言。宝女。汝于今者信佛语不。法兄。若有世间无信之人。即是佛也。何以故。信者即是贪欲嗔恚。如来无有贪欲嗔恚。是故无信。若无信者即是无证。法兄。空无相愿真实无证。是故如来亦无有证。法兄。法界实性无作无为。虚空等法真实无证。是故如来亦无有证。无畏菩萨言。宝女。以何为证。宝女言。法兄。若有不见无量佛法。如是之人可以为证。无畏菩萨言。宝女。此舍利弗。目揵连等是证信不。宝女言。法兄。如是如是是证是信。何以故。声闻人戒则有边际。如来之戒无有边际。定慧解脱解脱知见亦复如是。尔时舍利弗语宝女言。宝女。声闻亦有三解脱门。如来亦有三解脱门。汝今何故以声闻人而为证信不以如来。宝女言。大德。如阿耨达池。有八味水雨阎浮提。而已一切草木丛林。悉得增长。如是雨水有差别不。舍利弗言。不也宝女。大德。如阿耨达池水本一味。德人用之则有种种微妙甘味。薄德之人用其味则一粗恶不美。大德。如来声闻三解脱亦复如是。是故如来声闻之人。则有差别。而法界性实无差别。尔时世尊赞宝女言。善哉善哉。宝女。善能分别宣说是义。宝女。说是法时。天与人三万二千发阿耨多罗三藐三菩提心。宝女复语舍利弗言。大德。譬如大海其水一味。多有诸宝。亦有水精下价之珠。法界亦尔。虽复平等诸佛学之得无价宝。声闻学之得下价宝。大德。如须弥山上有诸天人多受快乐。或复有天少受快乐。而须弥山实无差别。法界亦尔。虽复无差如来处之受无量乐。声闻处之受有量乐。大德。如转轮王。虽有千子皆亦不得称绍尊位。声闻之人亦复如是。虽有智慧不名为佛。大德。如然灯器。金则黄光铜则赤光。其色虽异灯无差别。法界亦尔。诸佛然之智光无边。声闻然之智光有边。而法界性实无差别。大德。如转轮王入城邑时一切悉知。薄福之人入城邑时。乃至亲厚犹不觉知。如来世尊入法界时亦复如是。一切天人皆悉觉知。障覆一切外道异学。胜诸声闻辟支佛等。声闻之人入法界时。声闻犹尚不觉不知。况复余人。大德。譬如山间有师子吼。瞿枳罗鸟。迦陵频伽。孔雀等声。人声牛声。驴声马声。响随声发。而是响者实无差别。随声发故响则不同。如来声闻三解脱门亦复如是。如来能坏一切魔众。能胜一切外道邪见。能知一切众生心念。能知众生种种所行。能调声闻辟支佛等。能出诸佛如来音声。声闻之人虽同法界。则不能同作如是等事。大德。譬如甘蔗其味虽一。与白石蜜为福德人。出黑石蜜为薄福德人。法界亦尔。菩萨摩诃萨则得大智甘露之味。不杂声闻辟支佛味。声闻唯得有边智味。大德。譬如三千大千世界多有大海。为利无量无边众生。亦有小河利少众生。法界亦尔。大德。如日月星宿俱游虚空而星宿明不及日月。是虚空性实无差别。法界亦尔。如来声闻虽俱游止。智慧光明实不同等。而法界性亦无差别。大德。譬如二人同学一业。一则工巧多得利益。一则疏拙获利无几。如来声闻法界亦尔。大德。如一叠华无有差别。巧方便故得上价衣。拙方便故得下价衣。法界一性亦复如是。如来乃以智慧方便大慈大悲业因缘故。得大寂静无价智慧。声闻之人得下智慧而不清净。大德。如大海中有罗睺罗阿修罗王。亦有其余众生之类。唯阿修罗王能得其底余则不得。法界亦尔。如来则得毕竟智慧。声闻不得。大德。譬如大地生千叶华及七叶华。诸天世人见千叶华悉生欢喜。如来声闻法界亦尔。诸天世人见佛欢喜心生爱乐。非声闻也。大德。以是义故。如来智慧无量无边。声闻智慧有量有边。而法界性实无差别。无畏菩萨语宝女言。是不可说菩萨摩诃萨定是汝师。能以妙法调伏于汝。宝女答言。善男子。不可说菩萨无所调伏。何以故。如是菩萨。不见自他及以此彼。如其尔者何所调伏。善男子。若有不觉一切魔界及自境界。如是之人则能调伏。复次善男子。若能知见一切诸法。不见有我及以我所。如是之人则能调伏。复次善男子。若有能自勤修苦行。不劝他修。修苦行已心不生高。如是之人则能调伏。复次善男子。如诸菩萨为众生故。在大生死即得解脱不行涅槃。如是之人则能调伏。是名第一实义调伏。尔时世尊告无畏菩萨言。善男子。是宝女者。真实从彼不可说菩萨而得调伏。以调伏故未来当得阿耨多罗三藐三菩提。是时宝女复白佛言。世尊。菩萨摩诃萨实无调伏。若调伏者即是大悲。悲能调伏非是人也。声闻之人则须调伏。何以故。无大悲故。世尊。如庵罗果树上熟者。其味甘美人所贪嗜。若生郁者其味则苦人所薄贱。如来智慧亦复如是。从大悲生。是故自调不由于他。无畏菩萨语宝女言。汝亦能报是不可说菩萨恩不。宝女言。善男子。我若知恩何得不报。若有众生不能修行菩提道者。如是之人则不能报。宝女。云何名为修菩提道。宝女言。善男子。三十二业名菩提行。何等三十二。终不退失菩提之心。不贪声闻辟支佛心。至心修行无有谄曲。凡所修行无有障碍。为众生行心无厌悔。虽行生死离贪恚心。于诸众生其心平等。悉能教化而调伏之。以四摄法而摄取之。为众得乐修大慈心。为苦众生修行大悲。如说而行精进坚固。终不欺诳一切众生。所修庄严为助菩提。不求一切世间之乐。心不贪着世间利养。不为身故造作众恶。不贪寿命不见他过。其心调伏净三种戒。庄严修集相好之业。常念出家报往善业。常乐寂静多闻无厌。智慧能利自身他身。凡所说法无有食想。能舍一切不求果报。净于戒聚不生憍慢。终不自赞所有功德。为他人故勤修忍辱。为净土故勤行精进。为知方便求一切智。永断一切烦恼习气。为得神通护持正法。亲近善友善心思惟。远离魔业如法而住。得无生灭微妙智慧。善男子。若有不能行如是法。当知是人不能报恩。亦复不能知如来恩。善男子。有二种人必死不治。毕竟不能知恩报恩。一者声闻。二者缘觉。善男子。譬如有人坠堕深坑。是人不能自利利他。声闻缘觉亦复如是。堕解脱坑不能自利及以利他。尔时无畏菩萨。即脱己身所著上衣。以报宝女说法之恩。尔时宝女不肯受之。无畏菩萨言。我为法故唯愿受之。善男子。法离于贪。是故不应说法。而受法者无取。是故不应取供养物。法者无贪。是故不应贪供养物。法者无我及以我所。是故不应以我所物而为供养。法者清净。是故不应以不净物而为供养。法无身心。身心行者非供养也。法非心意识。心意识者非供养也。法无牵挽。有牵挽者非供养也。法非有无。是故有法非供养也。法非诸有。是故有想非供养也。法非觉观。有觉观者非供养也。法无增减。有增减者非供养也。法无高下。有高下者非供养也。法不可说不可听闻无有名字。舍一切声远离圣道。是故不可以衣供养。法无境界。非眼境界。至意境界。无有屋宅。是故不应以衣供养。法者即是十二因缘。非常非断。是故不应以衣供养。法无障碍不颠不倒。不可量度。无我众生士夫寿命。不生不灭不出无为。是故不应以衣供养。无畏菩萨言。宝女。如来世尊亦受如是法之供养。善男子。如来虽受法之供养。如法界性而不分别。宝女。云何名为分别法界。善男子。若言法异法供养异。受施者异施者亦异。是则名为分别法界。若不分别法及供养受者施者。是则不名分别法界。无畏菩萨言。宝女。如其法界无分别者。云何说言分别法界不分别耶。宝女言。善男子。法界之性虽无分别。而诸众生心颠倒故生于分别。善男子。如有器故名为完破。若有作业有所取者。则名为破名为分别。善男子。如器虽坏器中虚空终不可坏。法界之性亦复如是。尔时世尊赞宝女言。善哉善哉。若有人能成就是法。如是之人堪受三千大千世界人天供养。佛说是已。大众诸人各各脱身乌多罗僧奉上宝女。尔时不可说菩萨摩诃萨白佛言。世尊。凡可说者即是世间。不可说者即是出世。可宣说者即是爱心。不可说者即是离爱。可宣说者是世间行。不可说者是出世行。世尊。出世之义无所造作。无所作者即无诤讼。无诤讼者即沙门法。沙门法者即出世法。出世法者即无罪过。无罪过者即是不取不生不灭。不生不灭即是出世。出世之法不可宣说不可显示。以是义故。一切诸法不可宣说。尔时众中有一天子。名曰胜意。语不可说菩萨言。善男子若一切法不可说者。众生云何而得言说。不可说言。善男子。汝宁知响有言说不。胜意言。善男子。响者皆从因缘而有。善男子。是响之因为定在内为定在外。天子言。善男子。如是因者不定在内不定在外。天子。一切众生强作二想而有所说。诸法之性实不可说。天子言。善男子。若不可说云何如来宣说八万四千法聚。令诸声闻受持读诵。天子。如来世尊实无所说。无所说者即是如来。天子。汝知何等为如来也。将不谓色受想行识是如来乎。将不说佛是去来现在。有为无为阴界诸入三界所摄。是因是果是和合耶。或想非想亦想非想非想非非想耶。不也善男子。天子。若如是等非如来者。云何可说。若不可说云何而言如来。世尊演说八万四千法聚。是故八万四千法聚实不可说。声闻受者亦不可说。不可说者即是正义。义若无说即是真实。若可说者则为不定。若不可说则为可证。若可说者不可为证。何以故。以颠倒故。尔时胜意天子白佛言。世尊。是不可说菩萨所说谁当信之。尔时不可说菩萨。以神通力化作比丘作如是言。我今深信是不可说菩萨所说。何以故。我如如来亦如法界。如来诸阴不可宣说。我阴亦尔不可宣说。如来界入不可宣说。我之界入亦不可说。如来菩提我之菩提。亦尔等无差别。如来了知诸众生界。我亦了知诸众生界。如来转于无上法轮。我亦如是转于法轮。如来入于无上涅槃。我亦如是入于涅槃。天子言。比丘汝今将非魔所造耶。而说是言等于如来。比丘言。天子。若有人言我异佛异。当知是人即魔弟子。若有说言以我平等观法平等。法平等故众生平等。众生平等如来平等。如是之人即真实知能过魔界。时化比丘说是语时。五百比丘漏尽解脱。八千菩萨成就忍辱。即以香华供养比丘。舍利弗言。诸善男子。何故供养是化比丘。诸菩萨言。大德。谁作是化。诸善男子。汝今不知是不可说之所化乎。诸菩萨言。大德。譬如如来复化如来。有人供养为供养谁。诸善男子。是人即是供养如来。大德。若有供养是化比丘。即是供养不可说菩萨。舍利弗言。善男子。是不可说菩萨摩诃萨。设何供养任供养之。大德。若有智人无有声行。无字无色无名无作。无所宣说无自无他。无法非法无净无秽。如是供养乃任供养。时化比丘语舍利弗言。大德。汝意将无谓我今者异于汝耶。舍利弗言。不也比丘。何以故。如来常说一切诸法皆悉如幻。如来如说我亦如信。大德。若有人能供养如来。即是供养化无异也。时舍利弗。语不可说菩萨言。善男子。谁入是化今作是说。大德如镜中像。其谁在中而有像现。善男子。无在中者直以清净四大因缘故有像现。大德。化亦如是法性净故能作此说。善男子。若尔者一切众生何故不能如是宣说。大德。镜之背后俱不离镜像何不现。善男子。镜背四大不清净故。大德。众生亦尔。不能清净法界性故不能宣说。善男子。汝先后语义不相应。何以故。汝常说言。一切法界性自清净。今云何说法界不净。大德。若不尔者。汝云何因阿湿比丘得法眼净。善男子。我但因其开导除灭客烦恼故名法眼净。实无所得。善男子。若有人言我得虚空。是义不然。何以故。虚空之性常自清净。若常清净。云何可得。客云覆故众生不见。除客云故名之为见。法界之性亦复如是。是故我实不得法眼。善男子。汝今云何作如是等不相应说。言法界性或净不净。不可说菩萨言。大德。汝之所说及我所说者。皆是诸佛如来境界。非是我等之所知见。舍利弗言。善男子。若言是说是佛境界非我所知。云何复言法界之性无有分别。若有分别当知法界则有无量。不可说言。大德。法界性一实非无量。舍利弗言。善男子。如其法界性是一者。云何说言是佛境界非我所知。若法界一以何因缘一切众生不名如来。大德。汝欲分别众生如来有异相也。善男子。如汝先说。我不欲令众生如来有别异想。大德。汝意定谓有无生耶。善男子。有所谓法界。大德。汝意复谓有邪正耶。不也善男子。邪正聚者即是颠倒。大德。汝谓有法不生生耶。不也善男子。若是不生毕竟不生。大德。汝意谓是不生之法有分别耶。不也善男子。大德。如其不者。何故说言一切众生非如来耶。若如是者谁是众生。谁是如来。善男子我以先解如是之义。为显智慧故作此问。善男子。若有不解汝意所说。是诸众生当堕地狱。何以故。以生诽谤故。不可说菩萨言。大德。如是法者无人能诽无人能受。何以故。若有诽受当知是人亦当获得如是等法。大德。如大力士。弱劣之人不能生疑。我法亦尔。若有不于无量佛边种善根者。终不能疑不能受持。善男子。如我解汝所说义者。有人信顺如是法语。胜无量劫行檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。世间般若波罗蜜。尔时世尊赞舍利弗言。善哉善哉。如汝所说。若有信解如是语者。当知是人已于无量阿僧祇劫。修行如是六波罗蜜。若有不能信是语者。则不能得受佛记莂。成阿耨多罗三藐三菩提。若能信者则得受记。成阿耨多罗三藐三菩提。舍利弗。我念往昔无量劫中。修六波罗蜜。以不能信如是语故不得受记。不成阿耨多罗三藐三菩提。其后信已即得受记。成阿耨多罗三藐三菩提。是故当知。若有人能信解是语即得受记。成阿耨多罗三藐三菩提。不可说菩萨白佛言。世尊。以何等分而得受记。若过去分得受记者是义不然。何以故是灭法故。若未来分得受记者是亦不然。何以故以未生故。若现在分得受记者是亦不然。何以故不可说故。若是三分无受记者。云何说言菩萨受记。佛言。善男子。若有菩萨摩诃萨。信不可说知不可说说不可说。于不可说不生怖畏。知不可说及色二法无有差别。受想行识眼乃至意。佛法僧宝生死解脱。法界不可说亦复如是。是名菩萨得忍辱分。得无生分。得无出分。得无取分。得无污分。得无有分。得无作分。具足成就如是等分。于一切法不生二相。二心二意二分二缘。若有菩萨能如是观。是名不去不来不住。以不住故故无所作。无所作故无所愿求。无愿求故不断不常。若无断常即是中道。中道即是十二因缘。十二因缘无作无求。以是义故。名为甚深。无有作者无有受者。以是义故复名甚深。不生而生不出而出。以是义故复名甚深。譬如炽火从因缘生。无有作者无有受者。是火灭已无有去处。无有来处。一切诸法亦复如是。无有作者无有受者。善男子。若有菩萨能如是知。当知是人则得受记

尔时世尊说是法时。八千菩萨得无生法忍。得是忍已。上升虚空七多罗树。合掌恭敬而说偈言

  若能观是色阴分　　及不可说无二相
  是人即获平等智　　犹如先佛之所得
  若观受想行识阴　　亦复如是无有二
  能谛了知不可说　　即得受记如先佛
  若欲观察入界等　　及一切法无二相
  无声无字无有节　　是故诸法不可说
  不可说分三世分　　即是一分无差别
  实性真相悉平等　　如是观名义菩萨
  贪欲嗔恚及愚痴　　空无相愿悉平等
  生死涅槃无差别　　佛法僧宝亦无二
  一切法义不可说　　无有生灭如虚空
  无作无受如火性　　从缘而生非缘灭
  灭已不知去来处　　一切诸法亦如是
  诸法皆从因缘生　　因缘断故名为灭
  若法不生而不灭　　亦复不常而不断
  即是甚深十二缘　　更不从缘而出生
  本无有生而今生　　本无有出而今出
  无有造作无受者　　无有诸因及果报
  亦复非有而非无　　非有彼此二种相
  亦不在内非在外　　即是甚深十二缘
  是法本无而今有　　已有之法后还无
  若是有法三世摄　　当知性相如前说
  若是内法外中无　　外法之性内中无
  一切诸法亦如是　　是名第一真空义
  一切众生心本性　　清净无秽如虚空
  凡夫不知心性故　　说客烦恼之所染
  若诸烦恼能污心　　终不可净如垢秽
  诸客烦恼障覆故　　说言凡夫心不净
  如其心性本净者　　一切众生应解脱
  以客烦恼障覆故　　是故不得于解脱
  心不能生次第心　　心不能见次第心
  一切诸心从缘生　　是故次第心不断
  若能知见如是心　　犹如虚空及幻相
  是人即得心自在　　亦能了知次第心
  犹如幻师所作幻　　无量世业师亦尔
  如心众生亦复然　　若知即得心自在
  若有能得如是忍　　犹如幻法无因缘
  若知如是不生贪　　不由因缘得解脱
  一切众生诸心性　　如来摄为三世摄
  犹如幻物无真性　　众生之心亦复然
  心能了知诸众生　　众生亦能了于心
  心者非色不可见　　如心众生亦复然
  如众生性一切法　　无为之性不可说
  如来学得真法性　　是故名为无碍智
  一切凡夫不知见　　流转无量生死中
  无明所覆迷于实　　不知如尔及法界
  法界之性如虚空　　一切世间不能说
  如来修集大慈悲　　无字法中而演说
  犹如世间六种味　　各各不能自觉知
  众生虽说阴入界　　而不能了其性相
  众生智慧不生灭　　犹如虚空及以幻
  远离一切颠倒故　　是则名为净智慧
  如来觉了一切法　　无受无作如草木
  若能观察如是法　　是人即得无生忍
  若有无量诸菩萨　　获得如是忍辱者
  是人即为无量佛　　授其无上菩提记
  若能放舍内外物　　乃至不惜于身命
  能调一切诸众生　　是人即为佛授记
  若能清净诸众生　　既清净已不生慢
  说诸众生悉清净　　以是因缘得受记
  若知诸法念念灭　　为众生故修忍辱
  复能演说众生忍　　因是忍故得受记
  远离恶法勤精进　　为修善法不休息
  若能演说勤精进　　因精进故得受记
  一切诸法本性净　　平等无差如虚空
  若能演说是平等　　因三昧故得受记
  若能知法不可说　　说时不生于怖畏
  能以方便化众生　　因是智故得受记

尔时魔王将四种兵车兵马兵象兵步兵来至佛所。魔自化身作比丘像。语不可说菩萨言。善男子。魔王波旬。今将四兵来至佛所。汝今欲设何等方便。不可说言。彼若来者我当令其发阿耨多罗三藐三菩提心。比丘言。善男子。彼魔波旬都无善心。云何能令发菩提心。不可说言。我当调伏令得善心。得善心已以是因缘。发阿耨多罗三藐三菩提心。云何调伏。我当往彼他化自在王。其境界彼当属我。既属我已我当随意而调伏之。尔时波旬闻是语已心生忧怖。即欲退还而不能得复作是念。我于今者既不被缚又不得解。亦复不能作神通力。时魔即闻空中声曰。是不可说神通之力。魔王波旬。即时便前向不可说。礼拜忏悔而作是言。我今舍离一切魔业。不可说言。波旬。谁系缚汝。波旬答言。善男子。我无系放而不能行。不可说言。善男子。如汝今者。不系不放而不能行。一切众生亦复如是。无系无放而不能行。何以故。无明爱等颠倒系缚不得解脱。波旬。汝今若欲坏系缚者。应当速发阿耨多罗三藐三菩提心。波旬答言。善男子。一切众生成就几法。能发无上菩提心耶。波旬。众生成就十六种法。能发阿耨多罗三藐三菩提心。何等十六。所谓常修上心莹磨诸根。勤修诸善庄严功德。至心持戒不生悔厌。修集大悲怜愍众生。信佛世尊有大慈悲。为诸众生受行诸苦。能坏众生所有苦恼。调伏诸根具足正念。心无所畏不求诸有。乐求佛智不乐二乘。受乐无慢受苦无悔。恭敬智慧破坏憍慢。知恩报恩具足身力。护持正法不断三宝。是名十六。善男子。若有众生具如是法。当知是人能发阿耨多罗三藐三菩提心。波旬言。善男子。众生若具如是等法。能发阿耨多罗三藐三菩提心者。我今实无如是等法。云何能发无上道心。不可说言。波旬。譬如种树为华果实。初虽未有当知其后必得不疑。众生若为向菩提心行。亦复如是。虽未现有。渐渐当得是十六法。波旬言。善哉善哉。善男子。如汝所说。说是法时天与人众。三万二千。发阿耨多罗三藐三菩提心。波旬言。善男子。云何名为向菩提心行。善男子。有三十二法。向菩提心而得增长。何等三十二。一者至心。二者定心。三者净心。四者欲心。五者不放逸心。六者修集善法。七者庄严趣向无上菩提。八者能以四摄摄取众生。九者乐行方便。十者调伏众生。十一者能熟众生。十二者能知因缘。十三者勤行精进。十四者亲近善友。十五者具足信心。十六者具足信心故便生欢喜。十七者。供养恭敬师长和上有德之人。十八者能瞻病苦。十九者能善思惟。二十者如法而住。二十一者为护法故不惜身命。二十二者成就总持。二十三者具足念心。二十四者能说深法。二十五者具足智慧。二十六者具足诸力。二十七者愿于菩提。二十八者不舍众生。二十九者修集慈悲喜舍之心。三十者。游于生死心不生悔。三十一者为受身故庄严福德。为发净愿庄严智慧。三十二者知一切法不可宣说。是名三十二。菩萨若能增长是法。必得阿耨多罗三藐三菩提。善男子。譬如秋夜初月增长亦明亦净。众生未发菩提之心。具足如是三十二法。亦复如是。善男子。菩萨若能具足如是三十二法得妙色相。常为天人之所供养。能舍一切不求果报。发大誓愿净于三世。持戒完净不漏不破。修于忍辱得从闻善。无生法忍庄严善法。身心寂静不贪善根。终不修集爱味诸禅。亦不修习缘众生慈。唯修法缘无缘之慈。修集大悲作他所作。知恩报恩不舍众生。乐听正法如闻而说。演说法时无有食想。能调自他离贪恚心。以四摄法摄取众生。修行福智二种庄严。毗婆舍那及舍摩他。具足念心净诸威仪。成就获得四无碍智。身口意业从于智慧。其心坚固无有退转。常能利益一切众生。波旬。为诸众生入佛法故。示有文字音声演说。第一义中都无如是文字声说。是则名为一切法性。一切法性性不可说。波旬言。善男子。若一切法不可说者。菩萨云何发大誓愿向于菩提。不可说言。波旬。譬如虚空其性无边。是中宁可作井池不。不也善男子。波旬。若一切法性无不可说者。终不可证不可宣说。波旬言。云何名为发菩提心。不可说言。了知贪性则名发心。若复了知嗔痴悭妒阴入诸界。无明行识名色六入。乃至生老病死大苦是名发心。波旬言。一切诸法有何等性。波旬。一切诸法无出是性。波旬言。云何无出。夫无出者即无魔迹。魔迹即是我及我所。离我我所是名无出。觉观因缘行想聚取。说想非想生灭善恶。有漏无漏有为无为。世及出世即是魔迹。若无如是即是无出。说是法时八千菩萨得无生忍。虚空之中出如是声。善哉善哉。波旬。说是法时八千菩萨得无生忍。波旬言。善男子。菩萨具足何等法故得无生忍。空中声曰。修集具足六波罗蜜得无生忍。尔时不可说菩萨白佛言。世尊唯愿如来。为诸菩萨说不可说。佛言。善男子。若有菩萨。行檀波罗蜜时。观身如幻。观受如梦。观于菩提犹如虚空。行施之时不见一法。是名檀波罗蜜不可宣说。若有菩萨观戒戒地毁戒及地。观诸众生无有我性。观于法性。是名持戒不毁破戒。具足戒已不发三眼。一持戒眼。二破戒眼三菩萨眼。虽复持戒不求一法。不见菩提去来现在。是名尸波罗蜜不可宣说。善男子。若有菩萨观诸众生。不生不出而修于忍。观于菩提众生诸法皆悉空寂。众生空中无嗔喜心。亦复不觉一法怨相而修于忍。亦复不觉远离一法而修于忍。是名羼提波罗蜜不可宣说。善男子。若有菩萨勤行精进。都不见有身口意等一法是生一法是灭。而修精进不坏法界。为度众生而修庄严。于空无我不生错乱。为欲具足一切佛法而行庄严。闻说佛法即是无法。于是事中不生恐怖。清净庄严如来世界。虽复庄严观之如空。亦不庄严转于法轮。何以故。一切法性不可说故。是名毗梨耶波罗蜜不可宣说。善男子。若有菩萨修禅波罗蜜。修已不见过去心性。净本性已不见住处。亦复不见贪恚痴心上中下心及无贪恚。愚痴慧心亦不分别。何以故。如贪恚痴性。无贪恚痴亦复如是。如是观已亦入禅定。亦不能作平等平等。亦不能以不平等法而作平等。亦能了知阴界诸入。善恶净秽。有漏无漏。世间出世间。生死涅槃对治等法。是名禅波罗蜜不可宣说。善男子。云何名为不可宣说般若波罗蜜。若无慧行。无我我所众生寿命士夫。常断有无等见。欲界色界及无色界是名无行。无有诤讼无去无来。是则名为随于慧行。离无明闇及恶邪见。观如是法即真实观。善男子。火灾起时一切烧尽。无有因缘唯除虚空。菩萨行是不可宣说般若波罗蜜时。亦复如是无有因缘。见一切法本性尽灭。以方便故为诸众生宣说涅槃。亦知众生无有名字。以方便故宣说名字。以慧力故知过去未来说于出灭。虽复了知无有身心。以方便故说于身心。虽知诸法不可宣说。为众生故方便而说。虽知无施及以受者。以方便故说施说受。虽知诸法本性清净。以方便故说有禁戒。虽知诸法本无嗔性。以方便故修集忍辱虽知无修无有远离。以方便故勤修精进。虽知诸法本性寂静。以方便故修行禅定。虽知无有生死涅槃。以方便故修集智慧。虽知诸法本性自灭。以方便故说于涅槃即是般若。夫般若者无声名字不可宣说。不可见闻无心无识。不取不舍非我我所。非有处所形质规矩。不高不下非色非见。非对非作非觉非想。无有住处非去来现在。非色声香味触法意。非明非闇非是虚空。非内非外非作非有。非肥非瘦非增非减。本性清净非贪恚痴。亦非狂乱无有边际不可称量。是名般若波罗蜜不可宣说。说是法时。魔王波旬。于系得脱心生欢喜即作是言。如我今闻不可说法而得解脱。若有善男子善女人闻是法者。亦当如我于颠倒中而得解脱。一切众魔不得其便。尔时会中万二千众生。发阿耨多罗三藐三菩提心。是时阿难白佛言。世尊。如是正法名字何等云何奉持。佛告阿难。是经名为方等大集。亦复名为不可说法。亦复名入一切佛法。断一切佛所有名字。若有人能顶戴受持如是等法。即能获得阿耨多罗三藐三菩提。尔时空中多设伎乐香华。供养不可说菩萨。是时三千大千世界六种震动

大方等大集经卷第十三大方等大集经卷第十四

        北凉天竺三藏昙无谶译

    虚空藏品第八之一所问品第一

尔时婆伽婆。游如来行处妙宝庄严堂上。如来威神大功德庄严众相具足。因于本行佛地得报。菩萨宫宅称无量赞。如来神力之所建立。入无碍智行处生胜喜悦。思念进智分别巧说。众德具足来世所叹。世尊正觉善转法轮。善能调顺无量众生。于诸法中皆得自在。知诸众生心所趣向。善能分别一切诸根。彼岸善断结习永尽无余。所施佛事自然成办。与大比丘众六百万人俱。其心调柔结习已断。皆是如来法王之子。行甚深法善能解了无所有法。殊妙端正威仪具足。是大福田。正住如来所教法中。复与大菩萨僧俱。度一切诸行。不舍菩萨所行。得无我忍。于诸众生不舍大悲。过诸世间而顺世法勤化众生。亦能善入如来行地。又复不离菩萨行地。其名曰普明菩萨摩诃萨。无碍明菩萨。于一切法自在王菩萨。无碍行处菩萨。分别辩觉菩萨。净无量网明灯王菩萨。不染行处菩萨。坏魔界放光明菩萨。如是等不可计阿僧祇。不可思不可称不可量。无齐限不可说菩萨摩诃萨俱

尔时世尊。说诸菩萨出要之行。名无碍法门庄严菩萨道。成就佛法诸力无畏。得知诸法自在。入陀罗尼印门。入分别诸辨门。入大神通门。入说不退转轮诸乘平等门。入一相法界无分别门。入说随众生根所解差别门。入坚法分别坏诸魔界善顺思惟门。入断诸结及见无碍智慧门。入无等愿方便智门。入诸佛等智门。入诸法无滞碍如实分别门。入无变异平等法门。入甚深十二因缘门。入功德智慧庄严佛身口意坚固思进念专无尽门。入四圣谛门。为调伏声闻故。入远离身心行门。为调伏辟支佛故。入授一切智记门。为调伏菩萨故。入诸法自在门。为显佛功德故。所谓开示解说显现令解。教读施设次序开张。分别令易随顺正说。尔时世尊如是善分别大法方便时。于此三千大千世界一切诸色像。若铁围山大铁围山。须弥山王。及诸黑山。四天下及阎浮提。聚落城邑舍宅。大海江河泉源陂池。药草树木及诸丛林。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等宫殿。地神宫殿。虚空中诸神宫殿。四天王天三十三天。夜摩天。兜率陀天。化乐天。他化自在天。及梵天宫殿。上至阿迦腻吒天宫殿。一切大地及欲界色身众生。悉皆隐蔽眼所不见。喻如劫尽火灾起后。大地焦尽大水未出。当尔之时乃无一色与眼作对。尔时三千大千世界。亦复如是亦无少色。是欲色界所摄。唯除妙宝庄严堂中所见色像。尔时于妙宝庄严堂中虚空中。无所依着。自然成无量百千那由他宝台。微妙庄严世所乐见。喻如大妙庄严世界。一宝庄严佛土菩萨所住宝台此诸宝台亦复如是。见诸大众坐宝台中。于妙宝庄严堂内。自然踊出净妙真金师子之座。高十千由旬。此师子座出妙净光明。普照此三千大千世界。映诸菩萨光明令不明显。尔时大众欢喜踊跃。心情悦豫叹未曾有。合掌向佛作如是言。今者如来必说大法现此瑞应。尔时舍利弗承佛威神从宝台起更整衣服。偏袒右肩右膝着地。合掌向佛而白佛言。世尊。是何瑞相有如是等生胜喜悦现大神变。世尊。此诸大众皆生疑惑。愿如来说何因何缘。现此未曾有事。尔时佛告舍利弗。东方去此过八佛世界微尘数等佛土。有世界名大庄严。彼国有佛号一宝庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。以何因缘世界名大庄严。若广说彼世界庄严事者一劫不尽。是故彼土名大庄严。何因缘故。彼佛名为一宝庄严。舍利弗。彼如来因一宝说法。所谓无上大乘之宝。是故彼佛名一宝庄严。彼佛与诸菩萨众各升师子座。踊在空中高八十亿多摩树。为诸菩萨说虚空印法门。何谓虚空印法门。如一切法以虚空为门无住处故。一切法无住处门无形相故。一切法无形相门过诸行处故。一切法无行处门内外净故。一切法净门性无染故。一切法无染门自性寂静故。一切法寂静门。心意识本无故。一切法本无门离物非物故。一切法无物门无教相故。一切法无教门无形段故。一切法无形段门。离因缘境界故。一切法无因缘境界门寂灭相故。一切法寂灭门离二相故。一切法无二门舍别异故。一切法无别异门入一相故。一切法一相门自相净故。一切法自相净门过三世故。一切法过三世门不离平等故。一切法不离平等门。幻化相非相故。一切法幻化相门体不实故。一切法无体门无作相故。一切法无作门身心远离故。一切法远离门离相无相故。一切法无相门相不动故。一切法不动相门无依处故。一切法无依处门住无际故。一切法无际门无樔窟故。一切法无樔窟门。无我无我所故。一切法无我无我所门无主故。一切法无主门性无我故。一切法无我门。内清净故。舍利弗。彼一宝庄严如来。为诸菩萨广说如是虚空印法门。彼如来说是法时。无量阿僧祇诸菩萨。解知诸法性与虚空等于诸法中得无生忍。舍利弗。彼大庄严刹土一宝庄严佛所。有一菩萨摩诃萨名虚空藏。以大庄严而自庄严。于诸不思议愿最为殊胜。得一切功德中之威德无碍知见。不可思议菩萨功德以自庄严。以诸相好庄严其身。以善说法随所应度庄严其口。不退于定庄严其心。以诸总持庄严其念。入诸微细法庄严其意。顺观法性庄严于进。以坚固誓庄严淳至。以必成办庄严所作。以从一地至一地庄严毕竟。舍诸所有庄严于施。以净心善语庄严于戒于诸众生心无有碍庄严忍辱。众事备足庄严精进。入定游戏神通庄严于禅。善知烦恼习庄严般若。为救护众生庄严于慈。住不舍众生庄严于悲。心无犹豫庄严于喜。离于憎爱庄严于舍。游戏诸定庄严神通。得无尽宝手庄严功德。分别诸众生心行庄严于智。教众生善法庄严于觉。得慧明净庄严慧明。得义法辞应庄严诸辩。坏魔外道庄严诸无畏。得佛无量功德而自庄严。常以诸毛孔说法庄严于法。见诸佛法明庄严自明。能照诸佛国庄严光明。说不错谬庄严所记。神通随所乐说庄严教授。神通到四神足彼岸庄严变化。神通入佛密处庄严诸如来护持。自悟正智庄严法自在。如说而行无能坏者。庄严一切善法坚固。彼虚空藏菩萨。成就如是等无量功德。与十二亿菩萨摩诃萨俱。发意欲来诣此娑婆世界见我。礼拜供养恭敬围绕。亦为此大普集经。分别少法门分故。又为此十方诸来会菩萨生大法明故。又为增益开大乘法故。又为受持如来法故。又为无量众生善根出生故。又为以善法调伏诸魔外道故。又为示现菩萨师子游戏神通故。彼虚空藏菩萨。欲来至此是其瑞应

尔时世尊说此事已。即时虚空藏菩萨。与十二亿菩萨摩诃萨恭敬围绕。诣一宝庄严佛所。白佛言。世尊。我欲诣娑婆世界。见释迦牟尼佛。礼拜供养。彼佛报言。欲往随意宜知是时。即顶礼一宝庄严如来足下已右绕七匝。承佛游戏无作神足。于彼大庄严国土忽然不现。以一念顷与诸菩萨众俱。来至此娑婆世界。宝庄严堂妙宝台上。尔时虚空藏菩萨。雨妙华香供养世尊。及此大宝集经。所谓曼陀罗华。摩诃曼陀罗华。波利质多罗华。摩诃波利质多罗华。曼殊沙华。摩诃曼殊沙华。卢遮那华。摩诃卢遮那华。水陆诸华大如车轮。百叶千叶百千叶。皆出光明香气普薰妙香。适意开敷鲜净。杂色光耀眼所乐见。雨如是等种种无量妙华满妙宝堂中。高一多罗树。作诸天乐其音皆出无量百千法门之声。与檀波罗蜜相应声。尸罗羼提毗梨耶禅那般若波罗蜜相应声。与四无量相应声。与四摄法相应声。与助道法相应声。与三脱门相应声。与四圣谛相应声。与十二因缘相应声

尔时虚空藏菩萨供养世尊顶礼佛足。绕七匝已在一面立。白佛言。世尊。彼一宝庄严如来应正遍知致问无量。少病少恼起居轻利安乐行不。彼一宝庄严如来又言。有十二亿菩萨。与虚空藏菩萨俱往。至彼娑婆世界。愿世尊说如是如是法。使诸菩萨得自然智。亦使成就大法光明已还来至此。所以者何。以世尊昔来已曾化此。善男子等发菩提心。尔时虚空藏菩萨当世尊顶上。化作大宝盖。广十千由旬。以青琉璃为轩。真珊瑚宝为子。以琉璃及阎浮檀金为升垂。杂妙真珠缦网璎珞宝铃和鸣。其盖光明普照十方。与诸妙华互相绮错。尔时虚空藏菩萨于如来不思议功德深生敬重合掌向佛以偈赞言

  法义智慧最胜尊　　本净无垢无所著
  喻如虚空无染污　　我礼不动圣足下
  行无与等无涯底　　现法严身最殊胜
  佛真法身如虚空　　普生大悲而济度
  人中师子能示现　　百福庄严世尊身
  断诸言语无音响　　离诸言说无戏论
  虽知如是而现说　　无性众生令悦豫
  众心非心得此心　　能知非心幻化心
  善知众生心行性　　而能不住彼我心
  示现威仪济众生　　善逝身无作不作
  佛知众生随所乐　　即能示现如是形
  世尊于法不计我　　不生忆想着于法
  能知以何法受教　　而随所悟应时说
  大众渴仰瞻世尊　　世所希有最无比
  世尊无心于示现　　无能令诸大众悦
  此等诸法从缘生　　虚无寂寞非真实
  世尊善知如是法　　得至清凉泥洹道
  去离二边不着中　　知虚非真无自性
  此等诸法无作者　　善说业报非断常
  法无众生命及人　　寂静不名如虚空
  如实分别无众生　　而安多众至甘露
  昔行多劫不思议　　求进势力胜菩提
  所为妙行今已成　　至无至义觉无余
  一切诸法上中下　　悉知平等常无异
  智者所知知不着　　是故世尊定不乱
  阴入诸界如幻化　　三界皆如水中月
  众生虚伪性如梦　　以智分别说是法
  世人假称名得道　　实无有得无得相
  如道无得轮无转　　如轮无转无度者
  故能度众于四流　　自度度彼系颠倒
  善能安慰苦恼者　　自灭灭彼至无为
  众生无生无涅槃　　众生本净不可得
  道及众生犹如幻　　自觉此际觉多众
  如虚空中不见色　　一切群生色亦尔
  诸法离色及色相　　能知此色则得离
  作诸妙喻以赞佛　　执见而赞是其毁
  佛德如空无差别　　无所限量是赞佛
  故礼净尊净他者　　无缘无心入微心
  如佛功德世尊知　　如如功德我今礼
  能知众生无我者　　知诸法际离欲者
  见法身者则见佛　　即为供养十方佛

虚空藏菩萨说此偈已。即时妙宝庄严堂及虚空中诸宝台六变振动。一切大众心净悦豫。踊跃欢喜叹未曾有。皆言虚空藏菩萨。善能说此妙偈。若有善男子善女人能行此法者。乃至梦中不见有法。以渐皆当得师子吼。如虚空藏菩萨。尔时虚空藏菩萨。以如斯妙偈赞如来已。白佛言。世尊。欲少所问。唯愿听许。若听问者。尔乃敢问。所以者何。世尊。有无量知见能知众生诸根。有淳熟未淳熟者。世尊明达去诸闇冥故。世尊了义善说分别诸句义故。世尊知时不过限故。世尊所记不谬如说不错故。世尊知时随诸众生行说法故。世尊善游戏通达诸神足故。世尊善观。体众生心行故。世尊最无染于诸法中得自在故。世尊自悟觉了诸法故。世尊正御邪趣众生。教令入正故。世尊是大医王。能令无始世界众病永断故。世尊大力成就佛十力故。世尊无畏成就四无畏故。世尊无胜成就十八不共法故。世尊大慈行救一切众生心无碍故。世尊大悲行知见无我。拔一切众生苦故。世尊大喜行于禅解脱定入定到彼岸故。世尊大舍行断一切憎爱。心如虚空故。世尊得平等觉了诸佛法无碍故。世尊无憎爱心毕竟清净毁誉不动故。世尊无悕望智慧满足于利养赞叹无欲求故。世尊一切知见一切佛行处到彼岸故。我知见世尊有如是等无量无边功德成就。是故我欲于法门中少有所问。虚空藏菩萨作是语已。尔时世尊告虚空藏菩萨言。善男子。我当听汝问随汝欲问恣汝所问。吾当随汝所问悦可尔心。尔时功德光明王菩萨问虚空藏菩萨言。善男子。汝为谁故欲问如来。即时虚空藏菩萨。以偈报功德光明王菩萨言

  一切等心诸众生　　平等能至彼岸者
  游戏无垢悲心中　　我为是等问世尊
  能到正见无垢秽　　已无犹豫断彼疑
  自得了达利众生　　我为是等问世尊
  知我无我无与等　　为众发心不着众
  能脱众生计我见　　我为是等问世尊
  能护威仪慎所行　　其心清净如虚空
  坚固不动如须弥　　我为是等问世尊
  进心无涯慧无等　　勇健能害烦恼怨
  已结已断断彼结　　我为是等问世尊
  乐施威仪调伏心　　常住闻进戒忍力
  禅定诸通胜慧明　　我为是等问世尊
  乐空无相无愿法　　而现受形处生死
  无生无终达甘露　　我为是等问世尊
  知见甚深无崖际　　声闻缘觉所不及
  而知一切众生行　　我为是等问世尊
  善能了达乐正行　　于法非法系已断
  常处正定心不乱　　我为是等问世尊
  不断佛种诸贤士　　能护正法及与僧
  多闻三世诸佛赞　　我为是等问世尊

尔时虚空藏菩萨。以此妙偈答功德光明王菩萨已。白佛言。世尊。云何菩萨行檀波罗蜜与虚空等。云何行尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜与虚空等。云何行功德与虚空等。云何行智与虚空等。云何菩萨不离如如。如来所许。念佛念法念僧。念施念戒念天。云何菩萨修行诸法平等如泥洹。云何菩萨善分别行相。云何菩萨持诸佛法宝藏。随如来所觉法相性。如实知诸法相性已不取不舍。云何菩萨分别众生。从始已来清净而教化众生云何菩萨善顺发行成就佛法。云何菩萨不退诸通。于诸佛法悉得自在。云何菩萨入甚深法门。诸声闻辟支佛所不能入。云何菩萨于十二因缘。因善得胜智方便。离二边诸见。云何菩萨为如来印所印。如如不分别智方便。云何菩萨入法界性门。见一切法平等性。云何菩萨淳至坚固犹如金刚。于此大乘心住不动。云何菩萨自净其界如诸佛界。云何菩萨得陀罗尼终不失念。云何菩萨得无障碍如来加持辩。云何菩萨得自在示现受生死。云何菩萨破诸怨敌去离四魔。云何菩萨利益众生庄严功德。云何菩萨世无佛时能作佛事。云何菩萨得海印三昧。善能得知众生心行。云何菩萨能得知诸尘界无碍。云何菩萨威仪行成就。离诸闇冥得胜光明。于诸法中得自然智。速得成就一切智行

尔时世尊告虚空藏菩萨言善哉善哉。善男子。汝善能分别问于如来如斯妙义。如汝已曾供养过去无量诸佛。种诸善根心行平等喻如虚空。礼敬诸佛至慧明处。发勤精进欲度一切。诸佛如法不舍一切众生。度大慈悲彼岸。及过诸魔行不离世法。以虚空同量之心。成就此无上大乘妙法虚空藏。汝之功德无有边际难可校量。汝已曾于过去恒河沙等。诸佛世尊所问如此事自亦能说。是故虚空藏。汝今谛听谛听。善思念之。吾当为汝分别解说。所问诸菩萨事复过于此。能得无上大乘。如来自然智。一切种智。虚空藏菩萨言。唯然快哉愿乐欲闻。佛告虚空藏。善男子。菩萨成就四法。行檀波罗蜜与虚空等。何谓为四。善男子。若菩萨于一切处。无障碍不分别。行檀波罗蜜。以我净故于施亦净。以施净故于愿亦净。以愿净故于菩提亦净。以菩提净故于一切法亦净。善男子。是为菩萨成就四法。行檀波罗蜜与虚空等。善男子。若菩萨成就八法能净檀波罗蜜。何等为八。离我能施。离为我施。离爱结施。离无明见施。离彼我菩提相施。离种种想施。离悕望报施离悭嫉施。其心平等如虚空。是为菩萨成就八法能净檀波罗蜜。离此八法是谓净施。喻如虚空无所不至。菩萨慈心行施。亦复如是。喻如虚空非色叵见。菩萨所行诸施不依于色。亦复如是。喻如虚空不受苦乐。菩萨所行诸施离一切受。亦复如是。喻如虚空无有相智。菩萨所行诸施离诸想结。亦复如是。喻如虚空是无为相。菩萨所行诸施无为无作。亦复如是。喻如虚空虚假无相。菩萨所行诸施不依识想。亦复如是。喻如虚空增益一切众生。菩萨所行诸施利益众生。亦复如是。喻如虚空不可穷尽。菩萨所行诸施。于生死中无有穷尽。亦复如是。善男子。喻如化人给施化人。无有分别无所戏论不求果报。菩萨亦复如是。如化人相去。离二边而行诸施。不分别戏论悕望果报。善男子。菩萨以智慧舍一切结使。以方便智不舍一切众生。是为菩萨行檀波罗蜜与虚空等

尔时会中有一菩萨名曰灯手。从座而起偏袒右肩右膝着地。合掌白佛言。世尊。何等菩萨能行如是檀波罗蜜。佛言善男子。菩萨若过诸世间。得出世间法。非色无体无行知见清净。非闇非明离一切诸相。至无相智际成就无尽忍。近如来知见已。绍菩萨决定界分。已得受记为不退转印所印。已得灌顶正位。已得善行知众生行相。至一切处亦无所至。如是菩萨能行是檀波罗蜜。说此法时。万六千菩萨。见诸法性犹如虚空得无生法忍。佛告虚空藏菩萨言。善男子。菩萨成就四法。行尸罗波罗蜜与虚空等。何谓为四。善男子。菩萨知身如镜中像。知声如响。知心如幻。知诸法性犹如虚空。是为菩萨成就四法。行尸罗波罗蜜与虚空等。善男子。菩萨成就八法能护净戒。何等为八。善男子。诸菩萨不忘菩提心能护于戒。不求声闻辟支佛地能护于戒。持戒不限于戒能护于戒。不恃诸戒能护于戒。不舍本愿能护于戒。不依一切生处能护于戒。成就大愿能护于戒。善摄诸根为灭烦恼能护于戒。是为菩萨成就八法能护净戒。善男子。喻如虚空离诸悕望。菩萨以无求心能护于戒亦复如是。喻如虚空清净。菩萨持戒清净亦复如是。喻如虚空无有垢污。菩萨持戒无垢亦复如是。喻如虚空无有热恼。菩萨持戒无恼亦复如是。喻如虚空无有高下。菩萨持戒无高无下亦复如是。喻如虚空无有樔窟。菩萨持戒而无所依亦复如是。喻如虚空无生无灭毕竟无变。菩萨持戒无生无灭毕竟无变亦复如是。喻如虚空悉能容受一切众生。菩萨持戒普能运载亦复如是。为利益众生能护正戒。善男子。如水中月无持戒破戒。菩萨亦复如是。了知一切诸法犹如月影无持戒破戒。是为菩萨行尸波罗蜜与虚空等。善男子。菩萨成就四法。行羼提波罗蜜与虚空等。何等为四。善男子。若菩萨他骂不报。以分别无我想故。他打不报以无彼想故。他嗔不报以离有想故。他怨不报以去离二见故。是谓菩萨成就四法。行羼提波罗蜜与虚空等。善男子。菩萨成就八法。能净羼提波罗蜜。何等为八。善男子。菩萨善净内纯至。修羼提波罗蜜。善净外不悕望。修羼提波罗蜜。于上中下毕竟无障碍。修羼提波罗蜜。随顺法性无所染着。修羼提波罗蜜。离一切诸见应空。修羼提波罗蜜。断一切诸觉应无相。修羼提波罗蜜。舍一切诸愿应无愿。修羼提波罗蜜。除一切诸行应无行。修羼提波罗蜜。是谓菩萨摩诃萨成就八法。能净羼提波罗蜜。善男子。喻如虚空无憎无爱。菩萨修羼提波罗蜜。无憎无爱亦复如是。喻如虚空无有变易。菩萨毕竟心无变易。修羼提波罗蜜。亦复如是。善男子。喻如虚空无有亏损。菩萨毕竟修羼提波罗蜜。心无亏损亦复如是。喻如虚空无生无起。菩萨修羼提波罗蜜。心无生起亦复如是。喻如虚空无有戏论。菩萨修羼提波罗蜜。心无戏论亦复如是。喻知虚空不望恩报。菩萨修羼提波罗蜜。于一切众生不望果报亦复如是。喻如虚空无漏无系。菩萨修羼提波罗蜜。离一切漏不系三界亦复如是。善男子。菩萨行羼提波罗蜜时不作是念。彼来骂我我能忍受。亦不见骂者受骂者及所骂法。不作是观。不作是戏论言。彼空我亦空。亦不作是思惟。音声如响何由而出。亦复不作是观我是彼非。又复不作是见。彼无常我亦无常。亦复不作是念。彼愚我智。亦不作是想。我等应行忍辱。善男子。譬如有人求娑罗枝。为娑罗枝故。赍持利斧入娑罗林中。至一大树下斫其一枝。余枝不作是念。彼已被斫不斫我等。其被斫者亦不作是念。我已被斫余者不斫。二俱无想不生憎爱。善男子。菩萨摩诃萨行羼提波罗蜜时观知一切法性。如草木墙壁瓦石等。而示现割截身体。为教化众生故。无憎无爱无忆想分别。善男子。是为菩萨行羼提波罗蜜与虚空等

善男子。云何菩萨摩诃萨行毗梨耶波罗蜜与虚空等。善男子。菩萨成就四法行毗梨耶波罗蜜与虚空等。何谓为四。善男子。若菩萨勤求一切善法。而知一切法自性不成就。以一切最胜供具。给侍供养诸佛世尊。然不见如来及所供侍之法。善能受持一切诸佛所说妙法。亦不见文字而可受持。亦能成就无量众生。见众生性即是泥洹。毕竟无生无起。善男子。是为菩萨成就四法。行毗梨耶波罗蜜与虚空等。善男子。若菩萨成就八法。能净毗梨耶波罗蜜。何等为八。善男子。菩萨为净身故。发勤精进。知身如影。不着于身。为净口故。发勤精进。知口语如响。不着于口。为净意故。发勤精进。知意如幻无所分别。不着于意。为具足诸波罗蜜故发勤精进。知诸法无自性。因缘所摄不可戏论。为得助菩提分法故发勤精进。觉了一切法真实性故无所碍着。为净一切佛土故发勤精进。知诸国土如虚空故不恃所净。为得一切陀罗尼故发勤精进。知一切法无念无非念故不作二相。为成就一切佛法故发勤精进。知诸法入一相平等故而不坏法性。善男子。是为菩萨成就八法。能净毗梨耶波罗蜜。善男子。喻如虚空无有疲惓。菩萨于无量劫。发勤精进无有疲厌。亦复如是。喻如虚空悉能容受一切诸色。然此虚空无有覆障。菩萨为容受一切众生。发勤精进平等无碍亦得如是。喻如虚空能生一切药草丛林。然此虚空无有住处。菩萨为增益一切众生诸善根故发勤精进。无所依着无有住处亦复如是。喻如虚空至一切处然无有去。菩萨发勤精进为至一切法故。而无至无不至亦复如是。喻如虚空非色。而于中见种种色。菩萨为一乘故发勤精进。而为成就纯至故。示诸乘差别亦复如是。喻如虚空本性清净。不为客尘所污。菩萨发勤精进本性清净。为众生故现受生死。不为尘累所染亦复如是。喻如虚空性是常法。无有无常。菩萨究竟为不断三宝故。发勤精进亦复如是。喻如虚空。无始无终不取不舍。菩萨发勤精进。无始无终不取不舍亦复如是。善男子。精进有二种。始发精进。终成精进。菩萨以始发精进习成一切善法。以终成精进分别一切法不得自性。唯所集善根见是平等。所见平等亦非平等。善男子。喻如工匠刻作木人身相备具。所作事业皆能成办。于作不作不生二想。菩萨为成就庄严本愿故。发勤精进修一切业。于作不作不生二想。去离二边亦复如是。善男子。是为菩萨行毗梨耶波罗蜜与虚空等。善男子。云何菩萨摩诃萨行禅波罗蜜与虚空等。善男子。若菩萨成就四法。行禅波罗蜜与虚空等。何等为四。善男子。若菩萨专其内心。亦不见内心遮缘外界诸心。亦不见外心行处。以己心平等故。知一切众生心平等。亦不依二法心及平等思惟。法界定性无摄无乱。知一切法性无有戏论。是为菩萨成就四法。行禅波罗蜜与虚空等。善男子。若菩萨成就八法。能净禅波罗蜜。何等为八。善男子。若菩萨不依诸阴修禅。不依诸界修禅。不依诸入修禅。不依三界修禅。不依现世修禅。不依后世修禅。不依道修禅。不依果修禅。是为菩萨成就八法。能净禅波罗蜜。喻如虚空无所依着。菩萨修禅无所依止亦复如是。喻如虚空无所爱恋。菩萨修禅离诸染着亦复如是。喻如虚空不着诸见。菩萨修禅舍离诸见亦复如是。喻如虚空无有诸慢。菩萨修禅离诸憍慢亦复如是。喻如虚空究竟无灭。菩萨修禅善入法性究竟不退亦复如是。喻如虚空不可破坏。菩萨修禅不坏本际亦复如是。喻如虚空无有变易。菩萨修禅不变如如亦复如是。喻如虚空非心离心。菩萨修禅离心意识亦复如是。善男子。菩萨以平等心修禅。非不平等心。云何心平等。若心不高不下。无求无非求。无作无非作。无分别无非分别。无行无非行。无取无舍。无闇无明。无知无念。无非知无非念。不一不异。非二非不二。无动无不动。无去无不去。无修无非修。心不缘于一切境界。是谓平等心。以菩萨心平等故。不取于色。去离眼色二法。而修于禅。以心平故。不取声香味触法。去离意法二法。而修于禅。善男子。喻如虚空火灾起时不能焚烧。水灾起时不为所漂。菩萨不为诸烦恼火之所焚烧。不为诸禅解脱三昧所漂。受生自无定乱。乱心众生能令得定。自行已净不舍精进。与平等等示现差别。而不见平等及不平等二相。善能遍观智慧真性。其心不为爱见所覆。于诸行中行无所著与虚空等。善男子。是为菩萨行禅波罗蜜与虚空等

善男子。云何菩萨行般若波罗蜜与虚空等。善男子。若菩萨成就四法。行般若波罗蜜与虚空等。何等为四。善男子。若菩萨以我净故。知众生亦净。以知净故知识亦净。以义净故知文字亦净。以法界净故知一切法亦净。是为菩萨成就四法行般若波罗蜜与虚空等。善男子。若菩萨摩诃萨成就八法。能净般若波罗蜜。何等为八。善男子。若菩萨精勤欲断一切不善法而不着断见。精勤欲生一切善法而不着常见。知一切有为法皆从缘生。而不动于无生忍法。善分别说一切字句。而常平等无有言说。善能辨宣一切有为无常苦法。于无我法界寂静不动。能善分别诸所作业。而知一切法无业无报。善能分别垢法净法。而知一切法性常净。善能筹量三世诸法。而知诸法无去来今。是为菩萨成就八法能净般若波罗蜜。善男子。喻如虚空非行无行。菩萨行般若离一切行亦复如是。喻如虚空无能破坏。菩萨行般若一切诸魔无能坏者亦复如是。喻如虚空性常寂静。菩萨行般若觉见寂静亦复如是。喻如虚空性常无我。菩萨行般若了知无我亦复如是。喻如虚空性非众生。菩萨行般若。离一切众生见亦复如是。喻如虚空性无有命。菩萨行般若。离一切命见亦复如是。喻如虚空性无有人。菩萨行般若。离一切人见亦复如是。喻如虚空非物非非物。不可名字。菩萨行般若。离物非物见亦复如是。善男子。般若是寂静句义无微觉故。是不作句义自相净故。是无变句义无行相故。是真实句义不发动故。是不诳句义无有异故。是了达句义入一相故。是通明句义断习气故。是满足句义无欲求故。是通达句义能正见故。是第一句义无所得故。是平等句义无高无下故。是牢固句义不可坏故。是不动句义无所依故。是金刚句义不可摧故。是已度句义所作办故。是真净句义本性净故。是无闇句义不恃明故。是无二句义不积聚故。是尽句义究竟尽相故。是无尽句义无为相故。是无为句义离生灭故。是虚空句义无障碍故。是无所有句义真清净故。是无处句义无行迹故。是无樔窟句义无所猗故。是智句义无识别故。是无降伏句义无群匹故。是无体句义不受形故。是知见句义知苦不生故。是断句义知集无和合故。是灭句义究竟无生故。是道句义无二觉故。是觉句义觉平等故。是法句义究竟不变故。善男子。此般若不从他得。自证知见如性行故。知一切文字句义其犹如响。于诸言音随应而报。其辩不断。亦不执著文字言语。菩萨摩诃萨。如是能于一切言说中善能报答。知诸音声言说如响。解不可得故。不生执着亦不戏论。善男子。是为菩萨行般若波罗蜜与虚空等。尔时世尊。欲重明此义。而说偈言

  离着而行施　　普及适众性
  终已无碍心　　亦不生分别
  我净故施净　　施净故愿净
  愿净菩提净　　道净一切净
  无我我所想　　离爱及诸见
  舍除彼我相　　施心如虚空
  去离诸想施　　无有望报心
  舍嫉妒心结　　施心如虚空
  空非色无猗　　无受想分别
  亦无行及识　　施时心亦然
  如空益一切　　始终无穷尽
  解法施无尽　　利益一切众
  如化人相施　　不望所施报
  慧者施亦尔　　终不望其报
  以慧断结习　　方便不舍众
  不见结及众　　如是施如空
  知身如镜像　　知声犹如响
  知心如幻化　　法性如虚空
  不舍胜菩提　　不求于二乘
  于过去诸佛　　常敬慎护戒
  不舍本愿故　　能于诸趣中
  善成就本愿　　摄意护净戒
  如空无悕望　　无热恼高下
  无浊无变易　　净戒者亦尔
  如空受一切　　水月不持戒
  护戒者如是　　净戒如虚空
  骂打嗔怒等　　忍力故不嗔
  无我及彼见　　以去离二想
  内纯至善净　　外行亦清净
  纯至故无嗔　　顺如法能忍
  离诸见忍空　　舍觉而离想
  无愿无悕望　　舍诸行所取
  无爱如虚空　　不戏不怀恨
  无戏不求报　　无漏忍者尔
  无忍无骂者　　彼人声如响
  非是及无常　　无如是戏论
  彼愚及我智　　无生而示生
  虽如是分别　　犹修无生忍
  如斫娑罗枝　　余枝不分别
  断身无分别　　此忍净如空
  勤修无所依　　供佛无佛想
  持法不著文　　度众无众想
  净身净法身　　净口无言说
  净心无意行　　具诸波罗蜜
  具助菩提法　　净土如虚空
  成就辩总持　　求如是佛法
  如空受无惓　　故能生丛林
  遍至无形色　　精进亦如空
  常净如虚空　　无始亦无终
  人精进亦尔　　无始无终成
  如机关木人　　所作无分别
  行者无二想　　其进如虚空
  知止住内心　　摄外境界心
  自心彼心等　　依止无心禅
  诸法性常空　　以无漏智知
  不依阴界入　　亦不依三界
  不依于三界　　不依界道果
  如空常无依　　修禅者亦尔
  空无爱见慢　　修禅者亦尔
  空无退坏变　　修禅者亦尔
  平等寂解脱　　智者不缘界
  无结无禅等　　是故禅如空
  我净众生净　　智净识亦净
  义净文字净　　法净界亦净
  断不善及习　　大士集诸善
  知有无缘生　　无生不着灭
  善分别文字　　说无常苦法
  示现受业报　　言有垢及净
  知法性常净　　而筹量三世
  空无行非行　　慧无行亦尔
  如空无能坏　　无我人寿者
  非物非无物　　拔断二边见
  知句假不染　　不变真实句
  满足通达句　　达义慧等句
  等不动牢句　　金刚度净句
  明尽无尽句　　无为虚空句
  处樔识别句　　降伏体智句
  断集灭道句　　法觉智慧句
  如响随声应　　无尽辩亦尔
  说法无所依　　此慧净如空

大方等大集经卷第十四大方等大集经卷第十五

        北凉天竺三藏昙无谶译

    虚空藏菩萨品第八之二

佛复告虚空藏言。善男子。何谓菩萨行功德与虚空等者。若菩萨闻佛无量法广大如虚空故。发萨婆若心彼作是念。如萨婆若无量。佛无量。自在觉无量。于如是无量中。生无量欲精进不放逸行。为佛道故当行无量菩萨所行之法。所以者何。如诸佛无量功德庄严身故。我亦为庄严其身。应成就无量善根。如诸佛无量功德。庄严口庄严意。庄严道场庄严佛土故。我亦当庄严口意道场佛土。应成就无量善根。我当教化无量众生。为成就善根。我于无量生死中。为成就善根故不生厌惓。诸佛世尊。有无量国土。无量智慧。无量神通。彼诸众生。无量行。无量心。无量诸根差别。于生死中受无量苦恼聚。起诸烦恼。我为入无量诸佛法。为舍无量众生所行诸根生死苦恼聚故。成就无量善根。菩萨以如是正观之心。所作功德与诸波罗蜜相应。与四摄法相应。与四无量心相应。与助菩提法相应。成就众生受持正法。恭敬供养诸佛世尊。及净菩萨所行相应法。如是等所作无量功德与虚空等。以众生性无量故。佛智慧无量故。法界无量故。所修亦无量。如虚空众生性。佛智慧法界无处不至。一切众生皆得蒙益。菩萨所作功德亦复如是。至一切处利益众生。以无依着故。以愿方便力故。善男子。菩萨能如是行功德与虚空等

善男子。云何菩萨行智与虚空等者。若菩萨从善知识得闻法已。善顺思惟所作诸行终不放逸。修少境界想已受无量想。受无量想已得如是智明。得是智明已得阴方便智。得界方便智。得入方便智。得谛方便智。得十二因缘方便智。知众生垢亦知垢性。知众生净亦知净性。所谓众生有染心。如实知有染心无染心。如实知无染心有恚心。如实知有恚心无恚心。如实知无恚心有痴心。如实知有痴心无痴心。如实知无痴心有诸烦恼心。如实知有诸烦恼心无诸烦恼心。如实知无诸烦恼心。彼菩萨不见有垢心为卑无垢心为胜。所以者何。以菩萨入不二性清净法门智故。如法性我性亦尔。如我性无我性亦尔。如无我性诸法亦尔。性清净故。若入一切诸法性清净者。则不求诸法有垢有净。亦不见诸法文字相貌。不受不着故。亦不见诸法障碍盖缠及不障碍盖缠。菩萨思惟无量境界。离心识二法。名之为智不名为识。喻如虚空无心意识。菩萨亦复如是。离心意识。知诸法性与虚空等。智行无碍过诸碍故。善男子。是为菩萨行智与虚空等

善男子。云何菩萨成就不离如如来所许念佛者。菩萨若在阿练若处。或在树下。或在旷野。或在露处。以得定力故能摄心不着诸缘。以不散乱心善摄所念。以行相观如来。成就三十二相八十随形好。庄严其身取一一相貌。为成就己身故。心向一切智地于如来身。忆念放鬘网光明。菩萨以得解悕望观如来身。满一由旬二由旬。三四五十由旬。乃至百由旬。若过百由旬。以得解悕望。观坐道场。或见转法轮。或见现种种威仪说法调伏众生。或见于一佛世界施作佛事。或五佛世界。或十二十三十四十五十。或百佛世界施作佛事。乃至百千无量世界施作佛事。得解悕望观自见随意。若听法若供养给侍诸佛世尊。于余威仪随意自在。菩萨如是观如来色身已忆念佛功德。或观戒。或观定。或观慧。或观解脱。或观解脱知见。或观力无所畏。或观佛不共法。或观菩萨本行。或观成就佛地。普忆念如来成就功德已。忆念如来业。何等相貌云何造业。身造耶。口造耶。意造耶。威仪造耶。可见耶。不可见耶。可说耶。不可说耶。何国造耶。几种身造耶。如是种种忆念胜业。成就不可思议诸善根已。观如来法。诸佛世尊以法身故名为如来。不以色身。彼菩萨不见色是如来。不见相是如来。不见种性是如来。不见阴界诸入是如来。不见威仪是如来。不见过去未来现在世是如来。不见因是如来。不见缘是如来。不见所以是如来。不见和合是如来。不见有是如来。不见无是如来。不见成就是如来。不见败坏是如来。不见彼有如来。不见此有如来。不见如来在何所。不见如来。不恃如来。不分别如来。不得如来。喻如虚空无有阴界入名。非不利益众生。诸佛世尊。无有阴界入名。亦非不利益众生。善男子。是为菩萨不离如如来所许念佛。善男子。云何菩萨不离如如来所许念法者。若菩萨念法。所谓四念处。四正勤。四如意足。五根。五力。七觉分。八圣道分。三脱门。四圣谛。甚深十二因缘。六波罗蜜。菩萨所应学藏。不退转轮净三境。是为菩萨所应念法。云何应念。念舍念欲。离念灭念。无来无去念。无樔窟念。无自性念。出世间念。解达念。尽念无生念。无取念。无漏念。无为念。涅槃无自性。作如是念。于诸法中犹有法想。所以者何。以有想故则有动念。有动念故则住颠倒。住颠倒者无有念法。若离念法非法二想。知一切法是无生已。断法想故得无生忍。得无所得无所有故。善男子。是为不离如如来所许念法

善男子。云何菩萨不离如如来所许念僧者。僧谓四双八辈。僧中或是阿罗汉向。阿罗汉果。或是阿那含向。阿那含果。或是斯陀含向。斯陀含果。或是须陀洹向。须陀洹果。是为声闻僧。复次有僧。所谓不退转菩萨得决定忍。上圣正位已离诸相恃着戏论。次得如来功德无间。彼菩萨念如是等大菩萨众。应供养赞叹。合掌给侍右绕礼敬。是良祐福田。是第一僧入圣众数。是僧所应作事皆已成办。是菩萨念僧。亲近菩萨僧。不亲近声闻僧。彼菩萨虽忆念僧。不取僧数不取有数。知僧是无为。忆念无行无变异无生无灭。作如是忆念。不生心行境界。善男子。是为菩萨不离如如来所许念僧

善男子。云何菩萨不离如如来所许念舍者。所谓舍财舍法。复次有舍身及命。舍一切邪道。复次有舍不取一切法。所以者何。有取者则无舍。若不取者。名为究竟舍。究竟舍中则无有求。无求者则不望报。不望报故谓为真实舍者。若菩萨行如是坚固舍。随舍发愿。若舍时及发愿时。不见菩提及佛法而专念舍。念过去诸菩萨行道时。云何行舍。我今云何行舍。将无不及为智者所讥耶。即能一切舍。舍已分别所舍。谁是舍者舍何等物谁作忆念。如是分别已都无所得。不见舍者所施物及所忆念。是为菩萨不离如如来所许念舍。善男子。云何菩萨。不离如如来所许念戒者。若菩萨持戒至解脱处威仪行成就。乃至微戒畏如金刚。恒修净命善护持戒。菩萨自念戒摄身口。是无作相而谨慎奉行。修胜正命于萨婆若心终不废舍。纯至不动亦终不舍大慈大悲。摄取教诲破戒众生。宁舍身命不求余乘。是名为戒。菩萨念胜戒。不瑕缺戒。不荒秽戒。不求戒。不染戒。无浊戒。智者所叹戒。菩萨念如是等戒。不恃持戒。不毁破戒。不称己德不讥彼过。终不舍戒亦不依戒亦不住戒。虽舍一切诸所恃着而行色行。是为菩萨不离如如来所许念戒

善男子。云何菩萨不离如如来所许念天者。若菩萨念天。所谓念欲界天。或色界。或无色界天。念欲界天持戒果报故。受适意色声香味触。以天五欲游戏娱乐。天衣饮食自恣满足。一向受爱喜适意乐。菩萨作是念。此一切兴盛皆当衰灭。是诸天等亦当无常变异。由放逸故不造善根。先有善业今悉当尽。此诸天等虽生天上。犹未脱地狱畜生饿鬼之分。菩萨作是念已。不悕望生欲界天处。唯除兜率天宫。兜率宫中有一生补处菩萨。于一切菩萨行以到彼岸。一切诸地。一切神通。一切诸定。一切陀罗尼。一切辩才。一切菩萨事。于一切方便等以度彼岸。但忆念如是功德。于此天中心生欣仰。若欲生天者当愿生如是天中。菩萨发心言。我何时当得如是天身。菩萨复念色界诸天。此诸天等。由诸禅四无量心果报故生彼天处。已过欲界欲患一心处定。以喜为食一向知受第一乐报。菩萨作如是念。彼色界诸天。受少味故用为欢喜。无常有常想。苦有乐想。无我有我想。无涅槃有涅槃想。此色界诸天。亦有无常变。异未脱地狱饿鬼畜生之分。是菩萨不愿生色界诸天处。唯除净居天即彼入涅槃不还此间者。菩萨作是念。此是清净诸天。已脱五道流转生死。是菩萨以如是故。生敬重之心。亦不愿乐求生彼处。菩萨复念无色界诸天。受无色定果报。已过欲界色界心处定寂静。菩萨作是念。此无色界诸天。离见佛闻法及供养僧此诸天等。不知求出无色界法。假令久住会当变灭。未脱地狱饿鬼畜生之分。是故于彼天处亦不愿生。但作是念。我当作天中天如来应供正遍知。是菩萨虽念诸天。不依欲界色界无色界天处。而于三界众生起大悲心。是为菩萨不离如如来所许念天

善男子。云何菩萨。行诸法平等如涅槃者。若菩萨知入诸法平等如涅槃。见一切众生性同涅槃。知已入涅槃者。无阴界诸入。如是菩萨见众生性同涅槃。过诸阴界入见如影如梦。无有生死而现生死。凡夫众生所因结使造烦恼业。造烦恼业已受无量苦报。菩萨以般若波罗蜜力故。善观结使断令不生。亦不因彼作业而受苦报。得至涅槃平等之处。名之无为。过一切算数智道。不舍本愿故。游戏大慈。已到慧方便彼岸。已入佛神通力。已能善知分别诸想。自已得度度未度者。自已得解解未解者。自已得安安未安者。自已得涅槃使未得者得。于涅槃生死无有二想。是为菩萨行诸法平等如涅槃

善男子。云何菩萨善分别行相者。若菩萨翘勤精进求胜善法。于甚深法门心入筹量。清净通利分布慧明。得大智明门。以此大智明门力故。知一切众生心行所趣。总说一一众生。有八万四千诸行皆能了知。所谓贪欲行二万一千。嗔恚行二万一千。愚痴行二万一千。等分行二万一千。是为八万四千诸行。一一众生皆有是行。若广说者则有无量行。一一行相门中。知有八万四千诸根。一一根门中。知有八万四千种差别解。尽知诸行诸根诸解差别相。知所应修习相。云何知差别相。知此诸行诸根诸解。是贪欲相。是嗔恚相。是愚痴相。是等分相。是减相。是增相。是住相。是达相。是名知差别相。云何知所应修习相。知诸行诸根诸解无常相。苦相。无我相。空相。寂灭相。离相。如实相。涅槃相。相自空相。相自离相。若能知如是等诸行诸根诸解。如如来成就诸行无障碍智。知一切众生诸行诸根诸解差别相。菩萨亦次如来智知。而不舍菩萨所行。教化众生无有疲惓。是名善分别行相

善男子。云何菩萨持诸佛法宝藏者。善男子。如来藏无尽亦无量。至一切处。悦可一切众生。如众生诸行诸根诸解。无量阿僧祇。不可思议。不可称不可量。诸佛法宝藏。无量阿僧祇。不可思议。不可称不可量。亦复如是。佛法宝藏文字。假令一切众生如阿难等。一劫乃至百劫。不能受持读诵。能令通利除义。所以者何。如来一切法宝藏唯有一义。所谓离欲义。寂灭义。涅槃义。若菩萨闻如来法宝藏已。随力所受。受持读诵通利。善顺正观如所受行。菩萨入法藏门。坚持思惟。不依一切相行。则得陀罗尼门三昧门。得陀罗尼门三昧门已。能持一如来法宝藏文字及义。若二若三若四若五。若十二十三十四十五十。若百若千若百千。乃至无量无边阿僧祇。不可思议不可称不可量。无有量过诸量。于一切诸佛法宝藏心不散乱。受持读诵通利文字及义。广为人说。依义不依文。净意成就所闻说法。乃至一句文义不失。能净辩门。善能巧说悦可众心。为诸佛所叹。亦能降伏诸魔外道。及供养三宝。乃至不见一法异于法性。不坏本际。不动于如。如来所觉了性法。以知一切法性如如来所觉故。乃至不见一法不入佛法者。所以者何。如来知一切法性如幻无成就故。知一切法性如野马无所取故。知一切法性如镜中像不彼此故。知一切法性如梦不真实故。知一切法性如响从缘起故。知一切法性空虚无实故。知一切法性无相无分别故。知一切法性无愿无发动故。如来如实知一切法性如是相。菩萨如是知一切法性无生。能持诸佛法宝藏。乃至一切非念非不念。是为菩萨持诸佛法宝藏

善男子。云何菩萨分别众生从始以来清净而教化众生者。若菩萨为教化一切众生故。修于大慈大悲时。作如是思惟。何等是众生。作是念言。此诸众生但假名字。颠倒虚假谓为众生。一切众生本际清净。毕竟无生无起。但因虚妄愚痴故造种种业。造种种业已受无量忧悲苦恼。喻如有人梦中劫盗他物。为王者所捉种种苦治。梦作贼人虚妄忆想受诸苦恼。作是念言。我何时当得脱此苦恼。是人梦中实无成就无所觉知。一切凡夫及一切诸法。皆亦如梦无有觉知。为颠倒所覆。受无量妄想忧悲苦恼。亦复如是。菩萨作是念言。是诸众生我应令如实觉知诸法。使脱妄想苦恼。于诸众生中。亦不见众生性。而不舍大悲教化众生。是为菩萨分别众生从始以来清净而教化众生。善男子。云何菩萨善顺发行成就佛法者。若菩萨闻甚深微妙。于诸世间最胜佛法。发大欲精进。我应成就此甚深微妙。于诸世间最胜佛法。如是善思惟分别。是何等法与何法相应。是何等法知何法。菩萨作是念言。无有法与法相应者。无有法与法不相应者。无有法知法者。无有法不知法者。此诸法性钝性无性故。是一切法从因缘生。无有定主。而能随意庄严。有种种果报相诸法无性故。布施是庄严宝藏大富相。布施得大富不离因故。布施不知大富。大富不能知施。持戒是庄严生天相。持戒得生天不离因故。多闻是庄严智慧相。多闻得智慧不离因故。思惟是庄严断结相。思惟得断结不离因故。思惟不能知断结。断结不能知思惟。菩萨如是忆念诸法无生能庄严相。是故布施已回向萨婆若。成就檀波罗蜜。行是菩萨檀波罗蜜。则能具足佛法。持戒回向萨婆若。成就尸波罗蜜。行是菩萨尸波罗蜜。则能具足佛法。修羼提波罗蜜回向萨婆若。成就羼提波罗蜜。行是菩萨羼提波罗蜜。则能具足佛法。发毗梨耶回向萨婆若。成就毗梨耶波罗蜜。行是菩萨毗梨耶波罗蜜。则能具足佛法。入禅定回向萨婆若。成就禅波罗蜜。行是菩萨禅波罗蜜。则能具足佛法。净般若回向萨婆若。成就般若波罗蜜。行是菩萨般若波罗蜜。则能具足佛法。菩萨如是善顺行时。不见一法无因无缘而生者。亦不着因缘。自善顺入一切法。如我无生无起。一切法无生无起。亦复如是。如我空一切法空。亦复如是。如我离一切法离亦复如是。知一切法入平等如性非作非不作。是为菩萨善顺发行成就佛法

善男子。云何菩萨不退诸通。于诸佛法悉得自在者。若菩萨戒身真净。心定不动。得大智光明。已成就福德智慧资粮。已到诸波罗蜜彼岸。已成就四摄。已修四梵行。已修欲进念慧定。以善修四神足故得五神通。诸菩萨本业净故。勤进不废舍故。常不散乱行故。善伏结使故。离念声闻辟支佛心故。受持方便故。攀缘上地诸法故。无我无依行故。是以菩萨不退诸通。是故诸菩萨。究竟知诸法无退。知诸法与法性等无有变异如虚空无变。是为菩萨不退诸通。于诸佛法悉得自在

善男子。云何菩萨入甚深法门。诸声闻辟支佛所不能入者。若菩萨入甚深因缘法。知逆顺因缘法。善知出知离。知生知灭。知集知尽。善知众生。以何因缘故。受垢离垢。舍净得净。乃至不见一法有垢有净。知一切法性相清净。亦不得清净法相。以我甚深故知一切法甚深。以我离故知一切法离。以我无二故知一切法无二。以眼色二俱离故乃至意法亦离。则入第一义。以世谛故假名诸法。亦不执着真谛世谛。是为菩萨入甚深法门。诸声闻辟支佛所不能入。善男子。云何菩萨于十二因缘善得胜智方便。离二边诸见者。若菩萨知一切缘生法。属他所摄。属因属缘。属和合。属所由。所谓诸法皆从境界缘生。各有所因各有所依。诸法各各九相分别。譬如外诸药草丛林及诸树木等。皆无诸根。无记无知。依诸大故便得增长。各各无相分别。内有诸法亦复如是。依造业增长一切诸法。无我人众生寿命。亦无作者受者。诸法生时无能生者。灭时无能灭者。菩萨作是念言。是诸缘生法各无自性。无自性者他不能生。所因亦无性。所缘亦无性。无自性者则无他性。若法无自性他性者则无生。无能生未生。不可生已。生亦不生。若未生非未生。不生者则究竟无生无能生。是故一切诸法皆无生无起。但以名字故。假名从因缘生。而实无生。亦无断无常。所以者何。若法有生性者。则当有灭则是断见。若无灭者即有常见。离断常见故。当知一切诸法皆无有生。是为菩萨于十二因缘。善得胜智方便。离二边诸见。善男子。云何菩萨为如来印所印。如如不分别智方便者。若菩萨于甚深法。得现前知见力。离一切倚着。过诸戏论。得无终无始无生法忍。如来尽知诸菩萨所成就根已。以如来印印之。所谓受决定三菩提记。是如来印无错无谬。无诸障碍无诤竞不可沮坏。无能非者无能发印者得。如来印愿行成就。智水所灌菩萨为如是印所印。所谓究竟无生无起印。空印。无相印。无愿印。离染印。寂灭印。涅槃印。菩萨智行成就。不坏如性。不变法界。不离本际。于诸法中。不见上中下黑白等差别。菩萨亦见一切众生。为此印之所印。无忆想分别。不舍本大誓愿。是为菩萨为如来印所印。如如不分别智方便

善男子。云何菩萨入法界性门。见一切法平等性。若菩萨见诸法界。无处不至。无来无去。无生无灭。无相无起。无戏无行。菩萨作如是思惟。此诸法等皆同法界。如法界是离欲界。离尘垢界故。是无生界不可作故。是无灭界无灭尽故。是无来界不入根门故。是无去界无所至故。是不可安界无形质故。是无樔窟界无依止故。是真实界三境分断故。此法界中无眼界。无色界。无眼识界。如法界。一切法界亦如是。是故名一切法入于法界。乃至无意界法界意识界。如法界。一切法亦如是。是故名一切法入于法界。是菩萨知一切法入于法界。知地界法界无二无别。水界火界风界法界亦无二无别。欲界法界亦平等无二无别。色界无色界有为界无为界法界。亦平等无二无别。如是知无心境界及觉。是为菩萨入法界性门。见一切法平等性

善男子。云何菩萨淳至坚固。喻如金刚心住不动于此大乘者。若菩萨以直心行。成就净淳至以不退。毕竟不减。勤进以无碍。大慈以无惓。大悲以普至。方便得成就真实观慧。无碍等法皆悉成就。菩萨见一切众生有垢有浊。凡愚粗犷拒逆不顺。是故菩萨为教化一切群生故不废精进。见此生死有无量过患忧悲苦恼等。不退于来际庄严。亦解无量无边阿僧祇诸佛法。为成就难集难持难满诸佛法故。种诸善根而能入如来无量法宝藏。众生性无量故。法性无量故。虚空性无量故。为受持一切如来法宝藏故。不舍精进。闻一切法空无相无愿。无作无生无起。解了分别观行身证。成就未具足佛法。终不中道证于实际。善入诸禅解脱三昧。亦不厌离欲界而现受生。已离阴界诸入。无形无色无行。而随众生性。随意示现种种形色而为说法。转菩萨轮示大涅槃。亦不舍菩萨行。入如是不思议法门。知一切法无性相。不动不坏不散。于此大乘不退转。如金刚宝珠能鉴余宝。余宝无能鉴此珠者。诸菩萨亦复如是。能以声闻辟支佛乘。度无量无边众生。令入涅槃。而自不灭度。亦不退究竟大乘。是为菩萨淳至坚固。犹如金刚心住不动于此大乘。善男子。云何菩萨自净其界。如诸佛界者。若菩萨知一切法无界无非界。至一切处无至无不至。若菩萨见法发六情皆知是佛法。亦不见凡夫法佛法有异。作是念此一切法皆是佛法。佛法至一切处故。一切诸法及佛法但假名字。亦非是法亦非非法。是故我等不应取着。以自界净故知诸佛界净。此法与平等等。眼界是佛界。耳鼻舌身意法界是佛界。我不应分别有尊有卑。菩萨如是至一切法平等界。是为菩萨自净其界如诸佛界

善男子。云何菩萨得陀罗尼终不失念者。若菩萨已得成就陀罗尼行。云何陀罗尼行。善男子。陀罗尼行有三十二。何等三十二。修于得法为陀罗尼故。修于欲法。修于尊法。修于向法。修敬仰法。修于乐法。修求法无厌。修亲近供养多闻智慧者。修于和上阿阇梨所。无憍慢心尊重给侍。修如来教诲无所拒逆。修于说法人所生世尊想不求其短。修于受持正法开示解说。修所得法无所吝惜。修无悕望而行法施。修求智慧根栽。修如所闻法善顺思惟。修于诸法坚固受持。修于梵行无有休息。修乐远离行阿练若行。修心常寂静。修勤行诸念。修顺行六和敬。修于诸长宿无调慢行。修于一切众生中生无碍心。修缘生法得。修顺忍。修三脱门正观心无惊怖。修四圣种顺行不惊疑。修勤受持诸佛正法。修为众生行于大慈。修受持正法不惜身命。修大智行不生憍慢。修常教化众生而无厌惓。善男子。是为三十二种修陀罗尼行。菩萨修已得如是陀罗尼门。以得是陀罗尼门故。能总持一切诸佛所说。不忘不失陀罗尼者。所谓于如所闻法不忘不失。以念而念。以意分别。以进能觉。于诸文字入无边崖。于诸言音随类善解。言辞辩说无有滞碍。于不了义经善能进入。于了义经进入微觉。于世谛有分别智。于第一义谛知无言说。于诸谛有分别智。于四念处有不忘智。于四正勤等无坏智。于四神足有游戏智。于诸根门有差别智。于诸力中得无胜智。于七觉分觉一切法如性智。于八圣道无退没智。于定法中得善住心。于慧法中得遍至智。于明解脱得随顺智。于诸辩中得深入智。于诸神通得生起智。于诸波罗蜜得分别智。于四摄法得方便智。于讲法处授不及智。于诸经义得无分别智。于诸文字得无尽智。于一切众生得称足智。随所受解得说法智。于一切文字得所因辩智。于一切垢净得如实觉智。于一切法得无障翳明智。是为陀罗尼。得陀罗尼平等心者去离憎爱能堪受法雨。断一切结使热恼。顺诸助道法。是为陀罗尼菩萨。住此陀罗尼故常行无失。是为菩萨得陀罗尼终不失念。善男子。云何菩萨得无障碍。如来加持辩者。若菩萨善净淳至。善护戒众。拔诸慢根。离彼我想诸佛世尊知如是菩萨是大法器令持正法。以佛神力及自善根力故。得捷辩。得疾辩。得无碍辩。得无滞辩。得巧说辩。得甚深辩。得众音具足辩。得善庄严辩。得无减辩。得无畏辩。得妙偈赞辩。得快说修多罗辩。得善说譬喻本缘辩。得无坏胜辩。得分别句无尽辩。得圆足辩。得威德无违辩。得说法不唐捐辩。得断众疑辩。得利应辩。得分别文字不错谬辩。得悦可众辩。得问答方便辩。得以法降伏一切外道辩。已成就如是等二十四辩。此诸辩修行二十四种因故。能得成就。何等二十四。善男子。若菩萨不违逆师长教故。能得捷辩。不谄曲故能得疾辩。舍离烦恼故得无碍辩。无我行故得无滞辩。离两舌故得巧说辩。入因缘法无际故得甚深辩。行种种施故得众音具足辩。严饰如来塔庙故得善庄严辩。不舍菩提心故得无减辩。善护诫众故得无畏辩。施种种幢幡华盖宝铃故。得妙偈赞辩。恭敬供养给侍诸尊及师长故。得快说修多罗辩。昔殖修习无量善根故。得善说譬喻本缘辩。不轻贱恶趣众生故。得无坏胜辩。施无量宝藏故。得分别句无尽辩。真实言说无粗犷故。得圆足辩。讲说法时无诤竞故。得威仪无违辩。以德淳净顺法律行故。得说法不唐捐辩。不吝于法不恃己德故。得断众疑辩。求法之时不威逼他生恭敬心故。得利应辩。常省己过不讥彼缺故。得分别文字不错谬辩。等润众生不望报故。得悦可众辩。受持大乘不求小乘故。得问答方便辩。不着我见入平等性故。得以法降伏一切外道辩。是名二十四种成就诸辩因。善能随彼众生所应受解说法无有错谬。所受法者亦不退失。是为菩萨得无障碍如来加持辩

善男子。云何菩萨得自在示现受生死者。若菩萨成就十二法。得自在示现受生死。何等十二。亲近真善知识故。消除我见故。成就戒身故。善知入出定故。并修智慧方便故。善知深入诸通游戏故。如实亲知诸法无生无起故。净本愿种故。常不舍大慈大悲故。知一切法如幻化故。知一切法如梦想故。一切诸佛加威神故。是为菩萨成就十二法。无生现生无起现起。而现一切生死。于一切诸佛大会示现其身。在在佛国皆现受生。而常不动于真法身。是为菩萨得自在示现受生死也。善男子。云何菩萨破诸怨敌去离四魔者。若菩萨翘勤修习。观五阴如幻。得离阴魔。观诸法性净故。得离烦恼魔。观一切法从缘生性不成就故。得离死魔。观一切法缘所庄严是无常败坏相故。得离天魔。菩萨如是观故得离四魔。发趣菩提终不懈息。所有障菩提魔业。菩萨皆能远离。何谓魔业。所谓心向小乘是为魔业。不护菩提心是为魔业。于众生生异想是为魔业。行施望报是为魔业。为受生故持戒是为魔业。有色想行忍是为魔业。为世事精进是为魔业。于禅生着味想是为魔业。于慧生戏论是为魔业。厌惓生死是为魔业。作诸善根而不回向是为魔业。厌恶烦恼是为魔业。犯罪覆藏是为魔业。憎嫉菩萨是为魔业。诽谤正法是为魔业。不受正法是为魔业。不知报恩是为魔业。不进求诸波罗蜜是为魔业。不敬顺法是为魔业。吝惜于法是为魔业。为利养说法是为魔业。不知方便而化众生是为魔业。舍四摄法是为魔业。轻毁禁者是为魔业。嫉持戒者是为魔业。学二乘行是为魔业。悕望正位是为魔业。舍离大慈而观无生是为魔业。欲证无为法是为魔业。厌离有为功德是为魔业。不愍众生是为魔业。不谦下尊长是为魔业。习行两舌是为魔业。谀谄多奸是为魔业。显己净行是为魔业。作恶不耻是为魔业。不流布法是为魔业。以少德为足是为魔业。不遮结使是为魔业。不舍心垢是为魔业。忍沙门垢是为魔业。善男子。若亲近行一切不善法。远离一切善法尽是魔业。善男子。是谓诸魔业。行是业者障菩提道。彼诸菩萨已过舍离能正受行故。云何为正受行。若菩萨成就四法能正受行。何等为四。一者于诸波罗蜜法无懈退行。二者不舍欲进及不放逸。三者正住方便大慈法中。四者入甚深无爱无樔窟法门。善男子。菩萨成就此四法。正受行故能破诸怨敌。是为菩萨能破诸怨去离四敌

善男子。云何菩萨庄严功德资粮利益众生者。若菩萨善根回向向无等等。若有所种善根。若布施。若爱语。若利益若同事。尽以施与一切众生。以净戒众故得自在力。用此自在力故。随诸众生所应受乐而度化之。以种功德无厌故得无尽宝手。用此无尽宝手能施众生无量富乐。以求无边智慧资粮故。得无碍陀罗尼辩。用此无碍陀罗尼辩能总持一切诸佛所说。能说妙法悦可众心。以善调身心故。不退于诸通。用此不退诸通力故。能过无量佛刹。以无数方便度多众生。以常勤求法无疲惓故。得一一毛孔出无量法门。用出无量法门力故。能常以法施利益众生。以并修慧方便波罗蜜故得分身智。用此分身智力故。能于诸趣中在在现身。度化群生。常以无相敬侍诸佛故。得无厌见闻。以此无厌见闻力故。其有众生得见闻者。彼诸众生乃至为作大涅槃因。是为菩萨庄严功德资粮利益众生。善男子。云何菩萨世无佛时能作佛事化度众生者。若菩萨已成就菩萨十力。已于菩萨四无畏中而得自在。已于菩萨十八不共法中不从他受。已修如来力无所畏不共法等。已得游戏首楞严三昧。已于四辩。得智力自在。已于诸佛法得灌顶正位。于一切诸菩萨行得次佛神力。若有菩萨成就如是等法者。若诸佛土众生应见佛身而受化者。然彼土世无佛时即于彼国而现入胎。现初生时。现出家时。现坐道场转法轮时。现舍寿命未入涅槃时。亦能示现大涅槃。亦现法住时节久近。亦复不舍菩萨行法。亦不用所化以为满足。是为菩萨世无佛时能作佛事化度群生。善男子。云何菩萨得海印三昧能知一切众生心行者。若菩萨多闻如海。成就慧众常勤求法。菩萨为闻法故。尽能施与珍宝库藏。为闻法故尽能施与仆从给使妻子眷属。为闻法故舍家饰好严身之具。为闻法故谦下给事。为闻法故舍国土荣位及己身命。菩萨以如是等无数方便。勤求法门而不恃所行。菩萨为闻法故。去至一由旬乃至百由旬。为闻一四句偈受持读诵广为人说。不舍是精进。是菩萨自成就多闻。于一切众生生大悲心。无忧心。不望报心。乃至一众生不生轻贱而为说法。从一日乃至七日而无食想。乃至命终不舍说法。以说法善根回向海印三昧。随所闻法受持读诵通利。善知义趣不依文字。真实坚持终身不舍。菩萨发大欲精进。以此大欲精进力故。不久便得海印三昧。得此三昧已。即得自然无量阿僧祇百千万法门。得无量阿僧祇百千万亿修多罗。不从他闻自然能说一切诸佛所说悉能受持。能了一切众生心行。善男子。喻如阎浮提一切众生身及余外色。如是等色海中皆有印像。以是故名大海印。菩萨亦复如是。得大海印三昧已。能分别见一切众生心行。于一切法门皆得慧明。是为菩萨得海印三昧。见一切众生心行所趣

善男子。云何菩萨得知诸尘界无碍者。若菩萨以眼空故知色亦空。以色离故知眼亦离。耳鼻舌身亦如是。意空故知法亦空。以法离故知意亦离。菩萨如实知空性离性。于内外法无有障碍。知诸结本性净故则不起使。于一切法无所有着。以不见诸法着处着法著者。是为菩萨能得知诸尘界无碍

善男子。云何菩萨威仪行成就。离诸闇冥得胜光明。于诸法中得自然智。速得成就一切智行者。若菩萨发起所作修习正行。诸业尽是如来所许智者所赞。所谓身口意业。以行此业故。悦可诸佛及余贤圣善知识等。所造诸业无能讥嫌。最胜无上无与等者无能毁损。所作诸业终不悔退。所作诸业不离愚痴。所作诸业皆能观知。所作诸业终不动转。所作诸业究竟吉祥。是菩萨知所作业非憍慢。所造慧所作业非愚痴所造。如是所作善业已。一切三昧诸陀罗尼门。悉现在前不从他闻。菩萨若见诸佛。若不见诸佛。终不退转助菩提道诸善根。若遇适意善知识不适意善知识。不退菩提法。是菩萨过一切障碍地。离一切诸魔结使修三解脱。般若波罗蜜力故。疾得佛道自然道一切智道如来道。是为菩萨威仪行成就。离诸闇冥得胜光明。于诸法中得自然智。速得成就一切智行。尔时世尊欲重宣此义而说偈言

  已离边无碍　　慧功德庄严
  彼离诸着相　　回向无上道
  舍我慢憍慢　　慧者庄严智
  无障碍解脱　　具足一切智
  非色非种性　　念佛非功德
  不忆念法身　　是念佛所许
  离欲性寂静　　非相非明闇
  无心无意行　　如是名念法
  圣无为无爱　　无诸烦恼染
  以解脱得称　　名念僧无碍
  已舍一切受　　无阴界入行
  解脱诸动念　　名究竟念舍
  不依无漏戒　　不行身口意
  不生过三有　　名念无漏戒
  如天净无垢　　兜率灌顶天
  忆念自业报　　当作天中天
  持世尊正法　　舍离诸烦恼
  解脱法非法　　是持世尊法
  如佛得道相　　受持法亦然
  善思惟真际　　无法可摄持
  如我性净故　　诸法性亦净
  知众生如相　　而教化众生
  不见众生增　　亦复不见减
  说断颠倒想　　教化无量众
  说诸阴界入　　不异于佛界
  知如虚空性　　则入于佛界
  言语诸文字　　犹如呼声响
  知非内非外　　即得陀罗尼
  受持读诵利　　进求说诸法
  无我无法想　　安住陀罗尼
  持诸佛所说　　善说悦众心
  不失诸禅定　　是陀罗尼力
  不持不诵文　　不积集诸法
  常说法无碍　　如龙降大雨
  无住无障碍　　说无量契经
  不生众生想　　慧者得是辩
  以佛力说法　　庄严自威仪
  悦众随所乐　　是辩佛所许
  知法实性者　　知与虚空等
  无我人寿命　　如是持佛法
  众生同涅槃　　究竟不生灭
  得是不动忍　　是为不放逸
  见诸阴如幻　　诸界如法性
  六入如空聚　　得离于阴魔
  知使如浮云　　究竟无和合
  于法无妄想　　则离烦恼魔
  知众生不生　　无生则无死
  诸法无去来　　如是过死魔
  无爱无动者　　行道无道想
  无我人行悲　　则能降众魔
  知智识平等　　不住为无为
  知众心如幻　　心健无能坏
  此彼无障碍　　成就胜法船
  渡众无众想　　是谓大船师
  知空无有我　　净生死渴爱
  将导渡众生　　是谓大导师
  善知进退相　　随法而依止
  方便示涅槃　　佛说善导师
  知心心相续　　二心不共俱
  是名知心性　　佛赞能护众
  知诸法性净　　如空水中月
  知者离烦恼　　是谓净众生
  知一余亦然　　入诸法如梦
  虚空不可取　　得道无染污

说此分别诸法门时。七十二那由他众生。发阿耨多罗三藐三菩提心。三万二千菩萨得无生法忍。时大宝庄严堂。六种震动大光普照。诸天于虚空中作百千种伎乐。雨种种天华。说如是言。此诸众生为如来印所印已入如来法中。闻此法门心得信解。受持通利能为他说如法修行。白佛言。世尊。我等一切向此佛土。深心供养恭敬礼拜。以如来应供正遍知出世故。闻说此方便法门。及见此土菩萨。尔时虚空藏菩萨闻佛解说已。心净欢喜。心净欢喜已。以无价宝网供养于佛。宝网中放大光明。照十方诸佛国土。供养已白佛言。世尊。未曾有也。如来无碍智如是甚深难解。如来应供正遍知。如所闻法门。佛以无碍智如实解说。一切大众皆得欢喜

大方等大集经卷第十五大方等大集经卷第十六

        北凉天竺三藏昙无谶译

    虚空藏菩萨品第八之三

尔时众中有一菩萨。名曰速辩。即从座起偏袒右肩。右膝着地合掌向佛白佛言。世尊。此虚空藏菩萨。何因缘故名虚空藏。佛告速辩菩萨。善男子。譬如大富长者多诸民众。无量库藏财宝充满。能行布施心无悭吝。若行施时。贫穷往者随意所须。开大宝藏悉能给与。彼诸众生皆得适意。长者施已心喜无悔。善男子。虚空藏菩萨亦复如是。常行功德成就方便力回向故。戒身善清净故。得成就神足力故。纯至究竟善清净故。所愿增益成就故。知一切法如幻化故。得如来神足力故。于虚空中随众生所须。若法施若财施。尽能施与皆令欢喜。以是故善男子。是贤士以此方便智故名虚空藏。复次善男子。过去无量阿僧祇劫。复过无量阿僧祇劫。不可思议不可称不可量不可算数。尔时有佛出世。号普光明王如来．应供．正遍知．明行足．善逝．世间解．无上士．调御丈夫．天人师．佛．世尊。世界名曰大云清净。劫名虚空净。是大云清净世界。丰足炽盛安隐快乐多诸天人。地平如掌无诸沙砾荆棘。宝绳界道。杂宝庄严软如天衣。阎浮檀金华遍布其地。众宝间错。世界众生无上中下。人天同等如兜率天。彼世界无有村营城邑聚落。是诸天人各有宝楼台观。人宫在地天处虚空。以此为异。是普光明王如来寿命十六中劫。纯以菩萨为僧有六十那由他。皆得神通游戏。于菩萨行悉得自在。尔时于三千大千世界处中有一四天下。名曰日明。如来于中成阿耨多罗三藐三菩提。于三千大千世界而作佛事。彼日明四天下中。有转轮圣王名功德庄严。于四天下而得自在七宝成就。是大圣王。于四天下中起七宝台。东西八由旬南北四由旬。周匝有五百园观。是功德庄严圣王。有三十三万六千宫人婇女。端正殊妙如天玉女。有四万童子端正勇健。各与半那罗延力等。尔时功德庄严王与童子婇女及诸眷属俱。出诣大乐庄严园游观。作乐歌舞以自娱乐。尔时众中有二大夫人。一名德威。二名德光。离本坐处诣一树下。思惟诸行无常。当作是思惟时。各有一子化生抱上。端正殊妙成就第一微妙之色。相好严身观者无厌。身放大光普照园观。于上空中诸天唱言。此二童子。一名师子。二名师子进。从是以来常名师子师子进。尔时二子适生不久说诸妙偈。赞功德庄严王言

  昔造善恶不败忘　　供养诸佛亦不失
  纯至不舍菩提心　　坚持所闻不忘智
  调伏自守不失戒　　忍辱软和善防护
  能报恩者造善业　　能勤精进不失道
  善能专心定诸根　　心能分别思惟慧
  以智能造不浊业　　以此净法证菩提
  不为烦恼所染着　　善能分别诸义趣
  是故能舍受胎形　　化生清净莲华中
  我等从上医王佛　　闻此普光明如来
  智慧无等叵思议　　故来至此为法故
  愿共父王到佛所　　礼拜供养大法王
  诸佛世尊甚难值　　亦如优昙波罗华
  王闻是语甚适意　　时会大众皆欢喜
  百千万种导从王　　俱共发进向佛所
  到已璎珞及杂华　　涂香伎乐诸供具
  供养围绕七匝已　　合掌敬礼在前立
  尔时师子师子进　　顶礼两足天人尊
  以口呜足而赞叹　　言辞妙巧顺法义
  世尊是舍依止护　　为世盲冥开大明
  体众心行到彼岸　　随所信乐能悦可
  今此大王恃王位　　贪着色声香味法
  是故不来至佛所　　失供养佛不闻法
  快哉世尊生大悲　　愿说无上菩提法
  令此大王发道心　　坚固不退于佛智
  佛踊八十多罗树　　处在虚空告王言
  人王汝今至心听　　闻已如法而奉行
  五欲无常喻如梦　　命喻草木如霜露
  王及国邑如幻化　　是故智者不足贪
  习行欲者无厌足　　习欲渴爱更增心
  习犹未足而命终　　唯得圣智者乃足
  汝当善顺观己身　　诸阴如幻不坚固
  四大其犹如毒蛇　　六情无实如空聚
  妻子珍宝及王位　　临命终时无随者
  唯戒及施不放逸　　今世后世为伴侣
  观我神足力无畏　　以诸相好庄严身
  辞应弟子徒众等　　是故王宜发道心
  大王即时闻法已　　妻子眷属皆欢喜
  七十六千亿众俱　　皆发无上菩提心
  皆言我已发道心　　誓度一切诸众生
  我等涉行为众生　　成正觉已度脱之

尔时功德庄严王从佛闻说如斯等偈。及见神变已。复增益坚固菩提之心。顶礼佛足而白佛言。唯愿世尊。及菩萨弟子大众。受我八万四千岁请愿。以衣服饮食卧具医药。给侍所须

尔时世尊及诸大众。为怜愍王故即便受请。于是功德庄严王。知佛受其请已。欢喜踊跃顶礼佛足。绕已便去。时王子师子师子进。及二万王子舍世王位。于佛法中剃除须发出家修道。勤行精进乐求善法。师子及师子进出家未久。得五神通坚固不退。彼佛知此二人得神通已。加其威神。常为众生演说妙法。彼二比丘。即于彼三千大千世界。从国至国。从四天下至四天下。施作佛事而为说法。彼二比丘。以如是因缘。化度无量阿僧祇众生。令坚固不退于无上大乘。尔时功德庄严王于八万四千岁中。以诸乐具供养世尊及大众已。与一切群臣前后侍从。为听法故往至佛所。而作是念。我诸子等剃除须发出家修道。常受供养自不行施。亦未见得过人之法。宁可还家舍财布施修诸功德。如我所种善根耶。尔时普光明王如来即知功德庄严王心。告师子进菩萨言。善男子。现汝自在功德神力。大菩萨变现使此大众普得见闻。回彼邪心使得正见。为降伏诸魔外道故。尔时师子进菩萨即时入定已。现如是等相。使三千大千世界六变振动。于上虚空中雨种种妙物。所谓诸华香。末香涂香。缯盖幢幡。作种种天乐。美膳饮食。璎珞衣服。种种珍宝。皆从空中缤纷而下。雨如此宝。满足三千大千世界。众生得未曾有皆大喜悦。尔时从地神诸天上至阿迦腻吒天皆欢喜踊跃。唱如是言。此大菩萨。可名虚空藏。所以然者。以从虚空中能雨无量珍宝充足一切。尔时世尊即印可其言名虚空藏。于是功德庄严王见师子进。作如是无量神变。心净踊悦得未曾有。舍憍慢心合掌向佛作如是言。希有世尊。菩萨功德智慧乃能如是。自然而雨无量珍宝。充足一切终无穷尽。世尊。在家者施所益无几。夫出家者。以神通力施无崖际。在家者施不称彼意。虽施犹吝以为苦恼。出家者施能适彼意。亦不吝惜不生苦恼。尔时功德庄严王即舍王位与子吉意。以真信心剃除须发。于佛法中出家修道。出家已。为增长善法故常勤精进。出家未久修得四禅四无量心及五神通。时吉意王以法治化国无怨者。精进不废供养世尊。佛复告速辩菩萨。善男子。尔时功德庄严王者岂异人乎。莫造斯观。即拘留孙如来是。尔时师子菩萨者则我身是。尔时师子进菩萨者。即虚空藏菩萨是。善男子。虚空藏菩萨当乎尔时。初于空中雨无量珍宝。以是因缘常名虚空藏。善男子。尔时王子吉意者。今弥勒菩萨是。尔时二万王子于彼佛法中出家者。今与虚空藏菩萨来此众中听法者是。于彼佛法中先出家者。彼王内外眷属及王子所化众生。今现在十方行菩萨道。是故速辩菩萨。应常净戒众增长本愿。以净戒众增长本愿故。随欲所作皆能成办。尔时众中有诸菩萨。渴仰欲见虚空藏神变之力。虚空藏相貌云何

尔时世尊知众心所念。即告虚空藏菩萨言。善男子。现汝神变虚空藏相。尔时虚空藏菩萨即入称一切众生意三昧。入已以此三昧力故。于此三千大千世界。妙宝庄严堂上虚空中。雨种种妙物。随众生所欲尽给足之。所谓须华雨华。须鬘须香。须末香须涂香。须缯盖幢幡。须种种音乐。须严身之具璎珞衣服。须肴膳饮食。须车乘翼从。须金银琉璃颇梨车渠马瑙真珠珊瑚。雨如是等种种珍宝随意与之。有须法欲法乐法之者。于虚空中随所乐闻。出众法音悦可耳根。所谓契经。音合偈经。受记经。偈经。结可经。因缘经。双句经。本生经。胜处经。方等经。未曾有经。大教敕法。须如是等经者。尽出应之。须譬喻者。须那罗等变音者。须巧言语音者。须种种杂音者。须甚深音者。须方便浅音者。须如是等音者。尽出应之。须声闻乘度者。出四谛法音应之。须缘觉乘度者。出甚深十二因缘法音应之。须大乘度者。出六波罗蜜不退转法音应之。又于空中出诸妙偈曰

  说诸法性　　如虚空等　　今说其门
  众咸谛听　　如空无高　　亦无有下
  以无高下　　亦无体性　　如空无生
  亦无有灭　　以无生灭　　性不败坏
  如空无增　　亦无有减　　以无增减
  同诸法相　　如空无明　　亦无有闇
  以无明闇　　心性亦尔　　如日照空
  亦无有喜　　不照不忧　　智者学尔
  如雨鉾箭　　不伤于空　　行者修空
  亦不可伤　　如空水润　　无有喜悦
  智者称利　　亦无喜悦　　如空毁誉
  无有分别　　智者毁誉　　亦复如是
  如动大地　　空终不动　　智者无依
  不动法性　　如干大炭　　不烧虚空
  知烦恼者　　不为所烧　　如空常住
  无有败坏　　诸法亦尔　　常住法界
  喻如虚空　　受一切色　　法界亦尔
  受一切法　　如空非色　　相不可见
  心性如是　　同空无相　　虚空假名
  无有形貌　　心意识然　　亦假名说
  如空无边　　终不可取　　大人智然
  与虚空等　　如鸟行空　　无有足迹
  行菩提然　　行不可见　　身灭过去
  如虚空等　　现在诸阴　　同虚空相
  四大亦然　　同如虚空　　如三灾后
  无诸异相　　一切众生　　不能满空
  凡夫如是　　五欲无满　　若有圣智
  知一切法　　彼足无求　　离淫贪着
  如空广大　　无有边崖　　佛法亦尔
  无有边际　　知诸法性　　是佛法者
  彼不依物　　亦不舍物　　知物非物
  住于实际　　于物非物　　无有二相
  以声明空　　空性非声　　无有音声
  是名为空　　佛虽说空　　终已无说
  空性叵说　　是故名空　　如幻化梦
  野马影响　　诸佛说法　　皆悉如是
  为导众生　　说如是喻　　真净之义
  更无譬喻　　诸法无相　　以相如说
  相及无相　　法性俱无　　空相为相
  空亦无相　　体此相者　　是为菩萨
  无滞无碍　　无戏无动　　无始无终
  是为菩萨　　不离众生　　非众生数
  如众生性　　是为菩萨　　喻如幻师
  杀众幻人　　实无死者　　所度亦尔
  幻与众生　　泥洹佛法　　知同一性
  无性无相　　此大士得　　无漏空藏
  充足一切　　不可穷尽　　昔殖众德
  故获斯藏　　不有贮聚　　乃能如是
  能知诸法　　因缘生者　　其藏无尽
  不可思议　　救世大仙　　说四无尽
  空及道心　　众生佛行　　若财是宝
  则可贮聚　　非宝无宝　　是以无尽
  究竟空法　　已尽无尽　　无尽不尽
  是谓无尽　　知此门者　　近于菩提
  住此门故　　速成菩提

以虚空藏菩萨神力故。于上空中雨如是等妙法及财。令三千大千世界一切众生。得无量不可思议快乐所愿具足。有患苦众生蒙药除愈。孤穷众生得无量珍宝。系闭众生得开悟解脱。诸根不具者悉得具足。应被刑戮者。空中雨诸化人而代受之。亲爱久别悉得欢会。被忧煎众生悉得无忧。堕三涂众生。蒙光触身除一切苦身心快乐。尔时此三千大千世界中众生各各饮食游戏。五欲具足共相娱乐。或有行施作诸功德。一切众生成就如是等乐。各作是言。乃有此大士能施世乐。此虚空藏菩萨出世故。能施世间甘露。乃能常勤为与一切众生乐无疲惓也。虚空藏菩萨现如是等神变。悦可一切众生性。示现菩萨神力。以财施法施摄众生故。令无量阿僧祇众生发阿耨多罗三藐三菩提心。令无量菩萨得无生法忍。复令无量阿僧祇不可说不可说诸菩萨发勤精进故。得成就诸三昧门陀罗尼门。得游戏神通门。尔时生疑菩萨作是念。此不可思议未曾有也。虚空藏菩萨但于娑婆世界。示现种种神足也。亦于他方世界现种种神足也。尔时虚空藏菩萨知生疑菩萨心所念。即放身光。以此光明力故普照十方无量无边诸佛世界。尔时生疑菩萨及余菩萨。皆见虚空藏以神变力。于十方无量无边不可思议诸佛世界。应化众生亦如此娑婆世界等无有异。一切声闻辟支佛所不能为。生疑菩萨见如是神变已。疑网即除。合掌礼虚空藏菩萨而作是言。希有大士。乃能安此无尽之藏在虚空中。普雨充足无量世界而犹不尽。大士有安此藏在于空中其已久如。虚空藏言。善男子。自我发阿耨多罗三藐三菩提心已来。常有此藏在于空中。生疑菩萨又问。大士。发阿耨多罗三藐三菩提心已来几时。虚空藏答言。世尊当知。汝可问之。生疑菩萨即白佛言。世尊。虚空藏菩萨发阿耨多罗三藐三菩提心已来为经几时。唯愿说之除我等疑。佛告生疑菩萨言。善男子。此事久远甚深难知。若当说之令诸天人皆生疑惑不信佛语。以不信故得无量罪。生疑菩萨复白佛言。世尊。唯愿说之。若有久殖善根者必当信受。佛告生疑菩萨。善男子。汝已殷勤欲闻。岂得不说。谛听谛听善思念之。吾当为汝分别解说。为坚固善根久殖德本者生喜悦故。善男子。喻如一恒河沙数等诸恒河沙。以此诸恒河沙一沙为一佛土。末尔所佛土尽为微尘聚着一处。有一长寿之人于此尘聚中。百劫乃取一尘尽此尘数。欲知虚空藏菩萨发心已来劫数。复过于此。非算数所知。善男子。当以此比知虚空藏发心久近。善男子。乃往过去过恒河沙数等诸恒河沙。以此诸恒河沙一沙为一佛土。末尔所佛土尽为微尘。复过是数百千万劫。尔时有佛。号曰净一切愿威德胜王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼世界名曰现无量诸佛刹土。劫名众宝庄严。彼世界。何故名曰现无量诸佛刹土。善男子。以彼刹土真净故。能现十方诸佛刹土。喻如无翳净月现于清水。善男子。以是因缘故。十方无量阿僧祇诸佛刹土。及彼诸佛并师子座。众生所作皆现彼国。是故彼世界名为现无量刹土。彼世界与百亿三千大千世界等。广博严净丰乐安隐天人炽盛。地平如掌无有丘陵堆阜秽恶不净。多诸珍宝。间错而成端严可乐。悬诸缯彩幢幡华盖庄严。烧栴檀沉水众妙杂香。以杂色劫波育张施其上众宝妙华以布其地。在在处处。生宝华树果树衣树璎珞树伎乐树宝器树香树灯树药树等。普以庄严。以界八道平正分明。真珠璎珞宝网庄严。观者无厌彼世界中不假日月光明。以诸灯树及摩尼树。而以照明无有昼夜。唯以宝华开合知有时节。彼世中众生。无盲瞎偻躄痤短跛蹇形体。不具颜貌丑恶污面睐眼。无有如是等丑恶众生。一切众生皆成就三十二相。庄严其身。彼世界中乃无三涂八难诸恶名字。亦不闻外道异学音声。彼世界众生皆必定于阿耨多罗三藐三菩提。亦无声闻辟支佛名。彼佛纯说诸菩萨乘。彼世界中无女人及胎产者。一切众生结加趺坐自然化生。无老病名尽彼寿命。命终之后。生余清净佛土。或还生本土。善男子。彼土成就如是无量无边不可思议功德。我若一劫若减一劫。说彼功德终不能尽。善男子。尔时现无量诸佛刹土中有一转轮圣王。名曰众天灌顶。典领三千大千世界。于诸佛所久殖德本。利根慧猛威德成就。灌顶圣王有三万六千子。皆于莲华中化生。皆于过去诸佛所久殖善根尔时净一切愿威德胜王如来。与诸天世人大众恭敬围绕。游于众天灌顶圣王住处。诸菩萨众无量无数。非算师及算师弟子所能算知。彼佛寿命百千劫。劫数长短如此贤劫。彼世界众生。经尔所劫谓如一劫。尔时众天灌顶圣王请净一切愿威德胜王如来及菩萨僧。四十中劫劫数长短。如此中劫供养适意。肴膳饮食。衣服卧具。房舍台观。园林浴池。如是等种种所须之物。而以供养。尔时众天灌顶圣王为供养佛故。庄严一小千世界以为妙堂。纯以琉璃宝庄严其地。周匝垣墙众宝合成。以赤栴檀及忧陀罗婆罗栴檀为柱。以车磲宝为栌欂。间错此堂。以如是等庄严合成甚可爱乐。世尊中食后从三昧起。在此堂中为诸大众讲说妙法。复庄严一堂与一四天下等。欲令如来及菩萨僧于其中食。日日所用食直珍宝如大山[卄/積]。善男子。尔时众天灌顶转轮圣王于四十中劫常专一念。未曾放逸不作余事。常以一切乐具。供养如来及菩萨僧。于尔所时所作功德。亦不发愿有所志求。过四十中劫。于最后日。以无价三衣供奉如来诸菩萨僧。各施一衣。当乎尔日世尊。中后为诸大众广说妙法。于时众天灌顶圣王侍从围绕。为听法故往诣佛所

尔时世尊知彼圣王功德淳淑堪任有用。于时世尊及众天灌顶转轮圣王等。七日七夜都无食想。处师子座身不倾动说大乘经。名摄菩萨净行不退转轮方便。世尊说如是法。为欲令尽受持不忘失故。灌顶圣王于七日七夜心不分散。从佛闻法欢喜踊跃。其心悦豫从座而起。顶礼佛足右绕七匝。绕七匝已右膝着地。合掌向佛深心淳至。发阿耨多罗三藐三菩提心已。即说偈言

  我发无上心　　请召诸群生
  无救者作救　　冥世开大明
  非为一法行　　非为供一佛
  非为一众生　　愿度无余故
  生老病死苦　　众恼所逼者
  一切莫忧惧　　我誓要当度
  欲嗔痴慢覆　　失道造诸恶
  正断邪恶业　　导至无畏城
  堕三涂众生　　难处受众苦
  强志莫忧惧　　我生施无畏
  无明痴所翳　　不识解脱门
  我为然法炬　　得明至涅槃
  为四流所漂　　沉溺不得边
  为造胜法船　　令度诸有流
  处生死饥馑　　食先甘业尽
  我为作导师　　当令至安乐

佛告生疑菩萨言。善男子。尔时灌顶圣王说此偈已。彼佛世界即六变振动光明遍照。于时圣王发道心已。即得菩萨三昧名曰不退菩提心。以得此三昧力故。常得见诸佛无碍。乃至梦中一切烦恼不为作患。自是已后其心不与嫉妒共俱。不与破戒俱。不与嗔恚俱。不与懈怠俱。不与散乱俱。其心不与愚痴等俱。彼灌顶圣王。尽其形寿常给侍世尊左右。为闻法故。又常教化三万六千子令发阿耨多罗三藐三菩提心。亦复教化余无量无边众生令发阿耨多罗三藐三菩提心。善男子。尔时众天灌顶转轮圣王者。岂异人乎。莫造斯观。即今虚空藏菩萨是也。尔时彼诸王子及诸大众。教令发阿耨多罗三藐三菩提心者。我今即见在此会中大力精进大智慧诸菩萨摩诃萨听法者是也善男子。虚空藏菩萨发心已来。经如是无量阿僧祇劫行菩萨道。此虚空藏菩萨从发心已来。未曾失菩提心未曾胎产。常值诸佛听法供养众僧。于诸佛所受持正法。摄法为首未曾失念。能善分别成就遍行。初发心已得甚深难解菩萨初地能行诸施。成就大悲得无戏论。无有厌惓发勤精进。学一切诸论知一切世法。成就惭愧得坚固念力。此菩萨住于初地。于无量阿僧祇不可称不可量不可思议不可说不可说诸劫。能净淳至具足行檀波罗蜜。于诸众生常行大慈。勤修摄法一切波罗蜜及诸助道法。成就欲进不放逸等。皆随顺檀波罗蜜。是菩萨住于初地。常勤给侍供养诸佛。勤求方便教化众生。净佛国土住于初地。得入一切地智慧光明而不过初地。然后乃成就无量功德智慧资粮。得如来力持不退神通已。离诸地障碍。而从初地入菩萨第二地。住无量阿僧祇劫净于二地。修尸罗波罗蜜乃至十地。为一一众生所经劫数亦复如是。于一一地中过无量阿僧祇劫成就菩萨行。为诸众生现作佛事。而不舍菩萨所行。善男子。少有菩萨能行如是甚深不思议殊胜不散乱淳至勤修进行。如此虚空藏菩萨所行成就者。尔时生疑菩萨问虚空藏菩萨言。希有善男子。乃能如是发弘誓愿。于此大乘久住生死无疲惓耶。虚空藏答言。善男子。此大地运载诸山河石壁树木丛林一切药草百谷苗稼及诸众生有疲惓不。答言。不也大士。虚空藏言。善男子。诸菩萨心亦如大地。淳至成就故行菩萨行无有疲惓亦复如是。虚空藏复言。善男子。如此大地住于水上。此水持地无有疲惓。诸菩萨心亦如大水。以大悲力故教化众生无有疲惓亦复如是。虚空藏复言。善男子。如此大水住于风上。此风持水无有疲惓。诸菩萨心亦如大风。以大方便力故净佛世界无有疲惓亦复如是。虚空藏复言。善男子。喻如大风住于空上无所依止。此空持风无所障碍无有疲惓。诸菩萨心亦如风空。以般若波罗蜜力故集一切佛法无有懈废疲惓亦复如是。所以者何。菩萨知一切法相。所以成就无生质。无作者无受者。因缘合成故而有所作。所作诸法亦无有实。本际空故本际离故实无成就。自性空故无生无灭。知一切诸法性相如。是故不见有法可生疲厌及疲厌者。所以者何。菩萨知一切法无二故。知生死性与涅槃性等。知涅槃性与一切法性等。知一切法性与无性等故。亦不恃不着。知一切诸法过去际未来际无自性。以定力故。誓愿力故。不起于定而能现一切所作

尔时生疑菩萨问虚空藏菩萨言。唯愿大士说诸菩萨三昧行业。何谓三昧。何谓行三昧业者。虚空藏菩萨答生疑菩萨言。善男子。有八万四千种诸三昧门。此诸三昧门能总摄一切诸余三昧。何等是八万四千三昧门。善男子。菩萨有三昧名曰不忘菩提心。能成就不散乱行。有三昧名曰降伏。能净淳至。有三昧名曰不显行。能究竟成就不退所作。有三昧名曰不依。能增进成就毕竟。有三昧名曰无垢。能成就白心。有三昧名曰照耀。能开示善法。有三昧名曰真净。能回一切魔行。有三昧名曰踊出。终不为外道诸论之所降伏。有三昧名曰舍离。能调伏一切诸烦恼结。有三昧名回伏。能令一切入真实道。有三昧名曰转进。能离声闻辟支佛地。有三昧名曰乐游。能不厌生死。有三昧名曰趣向。能从一地至一地故。有三昧名曰怡怿。能成就悦可大众故。有三昧名无碍光。能于一切众生成就等心。有三昧名曰知所作。能顺一切所作不逆故。有三昧名曰师子相。能成就大众无所畏。有三昧名曰心勇。能降伏四魔。有三昧名曰莲华庄严。能成就不染世法。有三昧名曰光庄严。能普照诸佛世界。有三昧名曰清凉。能断离憎爱故。有三昧名曰幢相。能成就一切佛法光明故。有三昧名曰炬王。能成就大智慧光明。有三昧名曰日光。能成就断除无明闇冥。有三昧名曰集德。能成就辞辩无尽。有三昧名曰那罗延。能成就金刚身。有三昧名曰坚固。能成就不掉动心。有三昧名曰弥楼幢。能成就不见顶相。有三昧名曰坚自在。能成就度本愿。有三昧名曰金刚士。能成就不退诸通。有三昧名曰金刚场。能成就升于道场。有三昧名曰喻如金刚。善能鉴彻一切诸法。有三昧名曰行王。能观一切众生心行。有三昧名曰慧王。能成就胜智。知诸根满足未满足者。有三昧名曰随类。能成就随众生性而为说法。有三昧名曰修一切诸身。能成就法身。有三昧名曰不眴。能得成就无碍见见诸如来。有三昧名曰无诤。能得分别一切因缘。有三昧名曰无垢轮。能得成就转妙法轮。有三昧名曰电光。能得觉诸法因缘。有三昧名曰善分别。能知诸界尽同一界。有三昧名曰庄严王。能得成就相好。有三昧名曰随解王。能以一音报于一切。有三昧名曰不分别法界。能知一切三昧同一三昧。有三昧名曰坚固。能得不退于诸法性。有三昧名曰不可坏。能知诸法同于法性。有三昧名曰无终。能知本际非际。有三昧名曰无作。能成就如如无有变易有三昧名曰无动。能知诸法平等如虚空。有三昧名曰净住。能得成就诸波罗蜜。有三昧名曰善摄。能成就四摄法。有三昧名曰等行。能得成就四梵行。有三昧名曰无碍观。能得成就诸助道法。有三昧名曰海印。能得总持诸佛所说。有三昧名曰空。能断一切诸见。有三昧名曰无相。能断一切诸觉。有三昧名曰无愿。能得净成就一切诸愿。有三昧名曰决了。能得成就无生法忍。有三昧名曰不脱。能得成就不失所闻法。有三昧名曰无翳。能以善说悦可众生。有三昧名曰得丰。能得成就宝手。有三昧名曰法云。能雨一切法门。有三昧名曰宝庄严。能得成就不断三宝胜种。有三昧名曰无比。能成就智所作业。有三昧名曰虚空门。能得离一切障碍。有三昧名曰智印。能得遍知一切诸法。有三昧名曰见现在诸佛。能得成就诸如来功德。有三昧名曰选择寂静如意。能得成就离于本际。有三昧名曰分别一相法门。能得成就于未来世说一相法门。有三昧名曰了知一切法平等性。能得成就解了一切经书。有三昧名曰集诸功德。能得润益一切众生。有三昧名曰游戏神通。能得成就不思议解脱。有三昧名曰自觉。能入如来秘密之藏。有三昧名曰首楞严。能于菩萨地中乃至示大涅槃。有三昧名曰遍至。能得成就在在现生。有三昧名曰灌顶王。能得成就菩萨所行无余。有三昧名曰无胜。能得成就如来十力。有三昧名曰无尽。能得成就四无所畏。有三昧名曰无等。能得成就佛不共法。有三昧名曰愿王。能得成就诸所闻法。自利利彼功不唐捐。有三昧名曰善入无垢印。能现前觉了一切佛法。有三昧名曰善知觉。能得成就萨婆若智无有遗余。有三昧名曰尽无边。能得成就一切佛事受行无余。善男子。此谓八万四千三昧门。以此等为首。菩萨坐道场时。便得八万四千诸三昧门。一一三昧。以无量阿僧祇百千万亿三昧以为眷属。善男子。是诸三昧能知八万四千种众生诸所行法。以能显现八万四千法聚。善男子。是为略说诸菩萨行。及诸佛法藏少分。而诸菩萨行无量无边。诸佛法藏不可思议

尔时虚空藏菩萨说是法时。有万六千菩萨得柔顺忍无量三昧而现在前。复有八万四千众生发阿耨多罗三藐三菩提心。尔时世尊赞虚空藏菩萨言。善哉善哉。善男子。快说是诸三昧法门。善说如来胜智。如汝自身证行此法不从他得。尔时生疑菩萨合掌白虚空藏言。希有大士。乃能成就如是不可思议功德。不从他闻。而能入于如来胜智行处。我亦愿乐欲令一切众生得此不可思议法如来行处。尔时大德舍利弗问生疑菩萨言。善男子。谁为汝作此生疑名也。生疑菩萨答舍利弗言。菩提心为我作此生疑名。所以然者。若不发菩提心。于佛法中终不生疑。其有发阿耨多罗三藐三菩提心者。其人于一切佛法则生疑惑。为欲现知明了一切佛法故。譬如灌顶刹利王最大太子成就王相。应作国主次父之后应绍王位。是故其子每常咨问治国之法。我当云何监领国事。大德舍利弗。菩萨摩诃萨亦复如是。毕竟发阿耨多罗三藐三菩提心者。次如来后亦应绍继无上法王尊位。亦常思惟咨问一切智相应之法。我等应当云何持无上法王法也。是故亦于一切佛法每常生疑。大德舍利弗。当知以此因缘由菩提心故立此生疑名也。生疑菩萨复语舍利弗言。大德。我从昔来不忆值诸佛菩萨及善知识。未曾不问诸佛妙法。是故我真名生疑也

大方等大集经卷第十六大方等大集经卷第十七

        北凉天竺三藏昙无谶译

    虚空藏菩萨品第八之四

尔时虚空藏菩萨白佛言。世尊。诸佛行处不可思议。菩萨所应行法亦复无量。是故此行不可以少誓庄严。不可以少言说。不可以小乘道而得成就。快哉世尊。唯愿说诸菩萨大誓庄严及道庄严。菩萨以大誓庄严及道庄严故。能乘大乘行真实最上出世间道。为当得出世无上大乘。成就一切自然大智。虽未成一切智。能作佛事利益一切。佛告虚空藏菩萨言。善男子。谛听谛听善思念之。吾当为汝分别解说诸菩萨大誓庄严乘庄严道庄严。唯然世尊。愿乐欲闻。佛言。善男子。菩萨有二十庄严法以自庄严。自庄严已能乘大乘。何等为二十。善男子。若有菩萨毕竟发阿耨多罗三藐三菩提心。于一切众生生最胜大悲。生利益众生心。利益众生心已。便能庄严无上大誓。何谓大誓庄严。为度未度者大誓庄严。乘大船舫故。为解未解者大誓庄严。脱虚妄颠倒故。为安未安者大誓庄严。安止无畏道故。为未得涅槃者令得涅槃大誓庄严。舍五阴重担故。为常勤给足众生大誓庄严。精进不懈怠故。为不舍无量生死大誓庄严。不疲厌故。为悦可一切诸佛大誓庄严。现前供养恭敬故。为受持一切佛法大誓庄严。不断三宝种故。为受持一切所闻不忘大誓庄严。得陀罗尼故。为善说法悦可一切众生大誓庄严。得辩才故为集无量。功德资粮大誓庄严。成就相好故。为悦可一切善知识大誓庄严。坚固所行故。为遮驰散心大誓庄严。生诸禅解脱三昧故。为在阿练若处舍离身命大誓庄严。得六通故。为欲大师子吼无所畏惧大誓庄严。现前得无我法故。为欲至一切世界大誓庄严。欲知一切诸法如幻如梦如影故。为普照严饰一切世界大誓庄严。净戒众受持成就力故。为成就如来十力大誓庄严。满足诸波罗蜜故。为得四无所畏大誓庄严。如所说行故。为尽得十八不共法大誓庄严。如所闻菩萨地法不戏论故。善男子。是为诸菩萨二十大誓庄严。以此庄严力故能乘于大乘。菩萨以此自庄严力故。断三恶趣因缘。是名庄严。具足善为诸佛所护持。是名庄严。随所欲至便得往生。是名庄严。舍一切胞胎能化生诸佛前。是名庄严。能行无诤身口意业。是名庄严。住不放逸行为诸天世人之所恭敬。是名庄严。善通达三脱门而不证实际。是名庄严。一切无我法皆现在前而犹不舍大誓庄严。是名庄严。是为菩萨具足大誓庄严。云何云为庄严菩萨乘。善男子。乘者谓无量也。无边崖故。普遍一切喻如虚空。广大容受一切众生故。不与声闻辟支佛共。是故名大乘。复次乘者。以正住四摄法为轮。以真净十善业为辐。以净功德资粮为毂。以坚固淳至毕竟为輨辖钉镊。以善成就诸禅解脱三昧为辕。以四无量心为善调。以善知识为御。以知时非时为发动。以无常苦空无我之音为驱策。以七觉宝绳为鞦纼。以净五根为索带。以弘普端直大悲为旒幢。以四正勤为网。以四念处为安详。以四神足为速进。以胜五力为鉴阵。以八圣道为直进。于一切众生无障碍慧明以为轩。以无住六波罗蜜回向萨婆若。以无等四谛度到彼岸。是为大乘。此乘诸佛所受。声闻辟支佛所观。一切菩萨所乘。释梵护世所应敬礼。一切众生所应供养。一切智者所应赞叹。一切世间所应归趣。一切怨憎不能轻毁。一切诸魔不能破坏。一切外道不能测量。一切世智不能与竞。此乘殊胜无能遏者。一切贤圣之所守护。此乘随愿能至一切佛界故。此乘普照能放缦网光明故。此乘有大名称能出法门故。此乘强志不退还故。此乘坚牢不懈缓故。此乘正住不倾动故。此乘众事备具。能满一切所愿故。善男子。是名大乘诸大誓庄严。菩萨乘此乘。乘此乘已能从一地至于一地。是其庄严。能舍诸地过患是其庄严。能舍诸魔业是其庄严。能化度众生是其庄严。能净佛世界是其庄严。能现菩萨神变是其庄严。能度生死大饥馑是其庄严。能入如来行处是其庄严。善男子。云何菩萨庄严道。善男子。菩萨大誓庄严及乘大乘。已舍一切邪道。舍一切邪道已趣于真实正道到萨婆若。何谓正道耶。所谓不舍善法故行于大欲。不退菩提道故勤修精进。善根不失故行不放逸。不动淳至不没于所作。必能究竟仰攀上法。求功德资粮无有满足。求智慧资粮终不废舍。是为菩萨正道。复次善男子。菩萨道者。所谓四禅。四无量心。四空定。五神通。三福业。三学。六应敬。六念。四摄法。四念处。四正勤。四神足。五根。五力。七觉分。八圣道分。三解脱门。知阴方便。知界方便。知入方便。知谛方便。知因缘方便。是名为道。菩萨得成就此道方便。皆能随顺入六波罗蜜道。所以然者。以菩萨六波罗蜜道不与一切声闻辟支佛共故。此道一切诸佛皆所称叹。从诸如来口出成就方便。菩萨能知一切法实性者。能住出世间六波罗蜜圣道。云何为住。善男子。若有菩萨。成就自然慧方便而求菩提。于此五受阴中为如实觉故求于菩提。是菩萨知色无常而行布施。知色苦知色无我。知色钝知色无智。知色如幻。知色如水中月。知色如梦知色如影。知色如响。知色如旋火轮。知色无我知色无众生。知色无命知色无人。知色无主知色无养。知色空知色无相知色无愿。知色无作。知色无生知色无起。知色无出知色无形。知色寂静知色离。知色无终知色无成。知色与虚空等。知色如涅槃性而行布施。菩萨如是行施时。以施离故知色亦离。以色离故知施亦离。以色施离故知愿亦离。以愿离故知色施亦离。以色施愿离故知菩提亦离。以菩提离故知色施愿离。而知一切法同菩提性。善男子。是为菩萨出世间檀波罗蜜。受想行亦如是。知识无常应行布施。知识苦知识无我。知识钝知识无智。知识如幻知识如野马。知识如水中月。知识如梦知识如影。知识如响知识如旋火轮。知识无我知识无众生。知识无命知识无人。知识无主知识无养。知识如空知识无相知识无愿。知识无作。知识无生知识无起。知识无出知识无形。知识寂静知识离。知识无终知识无成就。知识与虚空等。知识如涅槃性而行布施。菩萨如是行布施时。以施离故知识亦离。以识离故知施亦离。以识施离故知愿亦离。以愿离故知识施亦离。以识施愿离故知菩提亦离。以菩提离故知识施愿离。而知一切法同菩提性。善男子。是为菩萨出世间檀波罗蜜。复次善男子。菩萨知色无常而护于戒。乃至知色如涅槃性而护于戒。知受想行亦如是。知识无常而护于戒。乃至知识如涅槃性而护于戒。以戒离故知识亦离。知戒离故乃至于识亦离。乃至知一切法同菩提性。善男子。是为菩萨出世间尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜亦如是。知色无常而行于慧。乃至知色如涅槃性而行于慧。知受想行无常而行于慧。乃至知识如涅槃性而行于慧。以慧平等故知识平等。以识平等故知慧平等。以慧识平等故知愿平等。以愿平等故知慧识平等。知慧识愿平等故知菩提平等。以菩提平等故知慧识愿平等。即知一切法同菩提性。善男子。是为出世间般若波罗蜜。是为菩萨出世间波罗蜜道。悉能摄取一切诸道。当知一切诸道皆入在中。何故名之为出世间耶。善男子。五受阴名为世间。菩萨善分别五阴。观是无常乃至如涅槃性。已知此道中无有世间及世间法。知此道是无漏是出世间无所系着。是名出世间。善男子。是名菩萨道。复次道者。所谓如实求一切诸法。分别选择不见一切诸法。相续积聚无二无别。是故名道。而此道者无有憎爱。无憎爱故名为平等。离思惟观察余乘故名为广大。去离谄故名为端直。去离曲心故名为无奸。断除诸盖故名无系滞。去离欲嗔恚害觉故名无尘垢。不爱色声香味触故名为安乐。去离诸魔事故名为清凉。去离烦恼众贼故名为无畏。能到涅槃故名为出要。成就静定故名清凉水。慧善解故名为常明。善修慈故名为凉乐。不舍大悲故名进无厌。常行喜故名为悦豫。成就舍故名无过失。顺摄法故名为大富。成就施食波罗蜜力故。得萨婆若智辩。诸佛善护持故名过四魔行法。不舍本愿故名进无滞碍。渡一切烦恼流故名无有上。一切世间无能降伏故名无詶对。善男子。此道成就如是等及诸余无量功德。一切大士乘此道故能往来教化无量众生。是为庄严。无诸烦恼现入烦恼。是其庄严。观于生死而不证实际。到空无相无作门。而能教化行诸见诸相诸愿众生。是其庄严。现入声闻辟支佛涅槃而不舍生死。是其庄严。现诸趣受生而不动于法性。现说一切言教而不动于无言。是其庄严。能现一切佛事而不舍菩萨行。是其庄严。善男子。是为菩萨大誓庄严大乘庄严道庄严。菩萨以大誓庄严自庄严故。能乘大乘顺出世间圣道。未得萨婆若为众生故能作佛事

尔时众中有菩萨名曰宝德。问虚空藏菩萨言。善男子。汝已修此出世间圣道耶。虚空藏答言已修。宝德言。云何修。虚空藏答言。如得清净道如是修。宝德问言。云何为清净道。虚空藏答言。善男子。我净故道净。宝德问言。云何为我净。虚空藏答言。如世净。宝德问言。云何世净。虚空藏答言。善男子。色过去际净。所以然者。以色本际无来故。色未来际亦净。所以然者。以色未来际无去故。色现在际亦净。所以然者。以现在色无住故。善男子。是为世净。受想行识过去际净。所以然者。以识本际无来故。识未来际亦净。所以然者。以识未来际无去故。识现在际亦净。所以然者。以识现在际无住故。善男子。是为世净。善男子。以世中世净故则我净。以我净故是名道净。宝德言。善男子。如是净道能何所为。虚空藏答言。能作大智慧光明。以此慧明力故。能知一切法过去未来际。宝德复问言。何谓过去未来法际。虚空藏答言。一切法于过去际无生。于未来际无灭。是名知过去未来际。宝德复问。若见过去未来际者。为何所见。虚空藏答言。见二俱离。宝德复问。何谓二俱离。虚空藏答言。离断常者。善男子。若有见法生及着法者。则是断常见。所以然者。由有生故则有灭。有生灭故则有断常之见。若不见有法从自性他性生者则见因缘。若见因缘则见法。若见法者则见如来。若见如来者则见如。若见如者则不滞于断亦不执于常。若不常不断者即无生无灭。宝德复问。善男子。若无生无灭。云何有名数。虚空藏答言。假言说故名之法耳。善男子。犹如有空故。有色差别名。所谓青黄赤白色。紫色颇梨色。琉璃色。粗色细色。长色短色。方色圆色。虚空不为如是等法所染。然一切色自性亦空。一切诸法亦复如是。同虚空性。但假言说有名数耳。所谓善法不善法。世间法出世间法。应作法不应作法。有漏法无漏法。有为法无为法。而菩萨亦不作一切非福行。所作福行皆是虚诳。非真不坚固。是菩萨知一切行非行。平等舍离一切相。成就般若波罗蜜力故。回向菩提而亦不见菩提有增有减。不于色中求菩提。亦不于受想行识中求菩提。菩萨以无求故。住于清净戒众。修无愿解脱门。满足一切诸愿。知生死性同涅槃性。虽入究竟涅槃为断除众生虚妄颠倒故行菩萨行。亦无行法可行。善男子。如是菩萨入于涅槃行菩萨行。善男子。凡有所作皆是生死。无有所作是名涅槃。菩萨所行是无所作。是故菩萨名入涅槃行菩萨行。善男子。凡有染着樔窟妄想戏论取相。是名生死。涅槃者无染着樔窟妄想戏论取相。是名涅槃。菩萨以修无乐着樔窟妄想戏论取相。行菩萨行。是名菩萨入于涅槃行菩萨行。当说此法时有五百菩萨得无生法忍

尔时世尊赞虚空藏菩萨言。善哉善哉贤士。快说法性称菩萨行真实不异。虚空藏白佛言。世尊。此是如来快也。所以者何。由世尊慧明故。我等得斯辩分。世尊。喻如日光照阎浮提。由日威德力故。有眼之者得见色像作诸事业。由于如来大智力故。照一切众生及诸世界亦复如是。诸法实性不可言说。诸言说性与虚空等。是故诸法不可得数。凡有数法则有限量。凡有限量则是有为。凡有有为则可知可断可修。凡是可知可断可修则有得有证有名数法。思惟筹量分别。不见有法可知可断可修可证可得故。即无有得。所以然者。以一切法无生故。能如是正见诸法。于诸法中不生爱染。以无爱染故则无有着。以无著故则无近。以无近故则无受无取。何谓无受无取。谓色若常若无常无受无取。受想行识。若常若无常无受无取。色若苦若乐。若有我若无我。若净若不净无受无取。受想行识若苦若乐若有我若无我无受无取。色若空若非空。无受无取。受想行识若空若非空。无受无取。色若离若非离。无受无取。受想行识若离若非离。无受无取。菩萨以无受无取故。得诸法无受三昧。住是三昧已。诸佛世尊以无上心通授是菩萨记。是菩萨虽入涅槃见一切众生究竟同涅槃性。为教化众生故。不舍大誓庄严及菩萨大悲。云何菩萨入于涅槃行菩萨行。善男子。凡有所作名为生死。凡无所作名为涅槃。菩萨以正智慧。见一切诸行离相。菩萨以法明眼明了见故。能说如来智明

尔时宝德菩萨问虚空藏菩萨言。善男子。汝何为自隐己智言尽是如来力耶。虚空藏答宝德言。善男子。如来岂不说隐善显恶也。善男子。我还问汝随意答我。善男子。于汝意云何。若无阿那婆达多龙王时。阿耨大池能出四河。使诸众生得受用不。宝德答言。不也。虚空藏言。善男子。若无如来则无法律。菩萨无由得成大智之海。亦不能利益一切众生。以如来出世故则有法律。诸菩萨得成大智之海。亦能度化一切众生。善男子。是故当知一切菩萨所得辩说。能以利益众生。皆是如来神力。宝德复问。善男子。诸如来辩。可得转至菩萨心不。虚空藏答言。不也。宝德言。云何由如来力故得辩说也。虚空藏答言。善男子。喻如巧种果树。因缘和合便得果实。然树非即果。果不离树。善男子。如来所说法。菩萨于此法中善顺行故。便生大智明辩。因佛说得亦无有转。宝德言。希有善男子。因缘生法如是甚深难测。虚空藏言。善男子。一切诸法究竟无生。宝德言。善男子。诸法谓从缘生。虚空藏言。善男子。生已生也。未生生也。宝德言。善男子。生已不生。未生亦不生。虚空藏言。善男子。是故无生。宝德言。善男子。缘中有因耶。虚空藏答言。无也。宝德言。因中有缘耶。虚空藏答言。无也。宝德言。于汝意云何。若因若缘自实有性耶。虚空藏言。无也。宝德言。善男子。于汝意云何。诸法无因缘生耶。虚空藏答言。不也。善男子。是故一切法无自性无生无起无出。是以缘不生因。因不生缘。自性不生自性。他性亦不生他性。自性不生他性。他性不生自性。是故说一切法自性无生。所以者何。以如无生无灭。法性实际亦无生无灭。如如法性实际。如来所觉一切诸法亦复如是无生无灭。宝德言。善男子。如来亦不出世也。虚空藏答言。此不应说也。所以者何。如来于一切法。尽不可说不可言出。不得言不出。若有人问言。如来出世耶。不出世耶。智者为不谤如来故应置不答。宝德问言。云何应置。虚空藏言。如法性住。应如是置。宝德言。云何法性住。虚空藏答言。如虚空性住。住无所住。法性亦如是住。如法性众生性亦尔如众生性一切法亦尔。如一切法如来亦如是住。住无所住。无住处故无住无不住。是故不得言生。不得言灭。宝德言。善男子。如来出世事。甚深甚深。虚空藏答言。善男子。若能如实解了缘生法者。名为佛出世。宝德言。善男子。谁当解此说也。虚空藏答言。若于一切法中不得增减者。宝德问言。何谓为增。虚空藏答言。增者所谓增上句。谓于无中妄生增上。无增上句者是平等句。无等句无文字句。无句无教句。无教之中。无句无增上。亦无心意识。以是故非句。喻如空中鸟迹究竟已无。当无而言鸟迹。于一切法中无有字句亦复如是。无句而假名为句。如无迹假名为迹。如来出世亦无有出。假名为出亦复如是。是故智者不应取着。以无取着故假名为出。而常依无出。所以者何。以无生是一切诸法实性故。无生者则无所有。是故名一切法无所有性。无所有性无有住处。无住处故是无住际。一切诸法及无住际。即是实际实际即是一切法际。是故言一切法与实际等。言实际者是三场分断际。不可坏际。不断不常际如实际。三世等际。以如是等际等一切法际。所以者何。实际及我际无二无别。实际及众生寿命养育人际。无二无别。实际及我见际无二无别。于我见中无有实际。能如是如实知者则无有二十种我见。所以者何。以实际中无一无多故。实际与平等等。无来无去无尽无减。实际究竟空故。是故言一切法是无尽门无尽际。涅槃者无尽。所谓空故无性故。如涅槃无尽无不尽。一切法亦复如是。以是故言一切法与涅槃等。诸法无等无不等无俦匹故。喻如虚空无有俦匹。一切诸法亦复如是。若见有詶匹。言有涅槃者。已言有涅槃。便求涅槃则与贤圣相违。已言有涅槃故。便言此应知此应断此应证此应修此应生此应灭。如是行不具者。不能如实知。不能如实见。则不识不解。不知不见。不识不解一切法故。则着于文字。于诸法中妄生诤竞。生诤竞者于佛法中则为可愍。所以然者。如来说言。沙门之法不应诤竞

尔时大德阿难白佛言。希有世尊。此贤士才辩乃能如是甚深明了难解难测也。于一切法不从他受。如身自证能如是说。虚空藏菩萨即谓阿难言。大德。我已自身证知。是故如所证知能如是说。何以故。我身即是虚空。以虚空证知一切法。为虚空印所印。大德阿难。凡诸菩萨修身善解身相者。能以此身作诸佛事。现种种色像。而亦不退于真法身。亦复不离结业生身。又复不过于平等性。现变化身悉得自在。于一切佛国普能示现。终已不隐应化之身。如是行者皆可名之为身证行。阿难问言。善男子。汝于法颇有证耶。虚空藏答言。大德阿难。我不见法离于身身离于法。阿难言。善男子。汝若身证者汝得阿罗汉果耶。虚空藏言。大德。无得不得无所得故。于一切法无恼行故。离贪欲嗔恚愚痴故。是谓阿罗汉。阿难言。善男子。汝何时当般涅槃耶。虚空藏言。大德。阿罗汉者无般涅槃。知一切法究竟是涅槃亦无涅槃相。凡愚之人有如是分别戏论行。言此是生死此是涅槃。阿罗汉者无是戏论也。大德阿难言。善男子。如我解汝所说义。夫菩萨者。不应言是凡夫。亦不应言是学。不应言是无学。去离二相故。虚空藏言。大德阿难。善哉善哉。以非凡夫非学非无学故。在在处处皆能示现。于一切处亦不取着

尔时五百大声闻。各以己身所著忧多罗缯奉上虚空藏。奉上衣已。一时同声说如是言。其有众生深心发阿耨多罗三藐三菩提者快得善利。于如是大智法藏中不堕其外。所上之衣即便不现。彼诸声闻问虚空藏言。衣何所至也。虚空藏答言。入我藏中。又言。如来知之汝等可问。尔时诸声闻即白佛言。世尊。衣何所至也。佛告诸比丘。东方去此过无量阿僧祇诸佛刹土。有世界名曰袈裟幢。其界有佛号曰山王如来。虚空藏已遣此衣至彼世界。诸声闻即白佛言。世尊。以何因缘遣衣至彼耶。佛言。欲以此衣于彼世界施作佛事。虚空藏菩萨于此所说。如虚空藏等三昧印法门。此三昧于彼衣中当演其义音。彼世界无量阿僧祇诸菩萨。闻此法故当得无生法忍。诸比丘当知。菩萨作如是种种方便利益众生。说此法时于上虚空中雨无量金色华。以此诸花遍覆妙宝庄严堂。于诸花中出如是法音。其有众生信此虚空藏所说法。善顺思惟分别其义者。皆当为不退转印所印。毕定得至无上道场。尔时阿难白佛言。世尊。是何瑞应乃雨此花。出如是妙音安慰众生。佛告阿难。有梵天名曰光明庄严。从梵天上与六十八百千梵众俱欲来诣此。如来说此语已。时诸梵众忽然来至妙宝庄严堂上。顶礼佛足右绕七匝。绕七匝已在一面立。合掌向佛而白佛言。希有世尊。虚空藏菩萨不可思议。戒众。清净善修诸定。善分别大智慧。善能游戏诸大神通。善能满足大弘誓愿。善能成就大权方便善能庄严身口及意。善能于诸法中成就大自在力。是虚空藏菩萨。身口及意都无所作。无有分别忆想。而能现此不可思议庄严神变。又能显现无量百千法门。亦能出入百千诸三昧门。从昔以来常乐修习成就诸善法故。世尊。诸菩萨不应于往昔所修善根不知其因。集诸善根亦应无厌。所以者何。是因往昔所种善根果报故。能现如是不可思议神变。佛告梵天。如是如是。如汝所言。诸菩萨已成就善根资粮及出要智方便故。能现如是不可思议功德庄严之事。无忆想分别。亦无不分别。梵天白佛言。世尊。云何菩萨集善根资粮及出要智方便。佛告光明庄严梵天言。善根有三种。何等为三。所谓无贪善根。无恚善根。无痴善根。是名善根。资粮者。所谓舍一切所有修慈观诸法。是名资粮。方便者。所谓去离凡夫地。不愿乐声闻辟支佛地。进入诸菩萨地是名方便。智者。所谓知舍不善法智。知集善法智。知回向菩提智。是名智。菩萨能住如是等正行者。是名出要。复次善根者。能发阿耨多罗三藐三菩提心。资粮者。所谓求一切善法。方便者。所谓已作未作善根终不废忘。智者。所谓知心如幻化。如是等法现前了知。是名出要。复次善根者。所谓淳至。资粮者。所谓发动。方便者。所谓深心。智者。所谓无持无动。能行如是等法者。是名出要。复次善根者。所谓欲善法。资粮者。所谓胜进。方便者。所谓安住不放逸。智者。所谓舍一切依着。能行如是等行者。是名出要

复次善根者。所谓正信。资粮者。所谓不舍本愿。方便者。所谓不舍念定。智者所谓慧。能正住如是等行者。是名成就善根资粮智方便出要。复次善根者。所谓悦可诸善知识。资粮者。所谓给侍所须。恭敬供养尊重利益。方便者。所谓于善知识生世尊想。智者。所谓知时非时而问法。能正住如是等行者。是名出要。复次善根者。所谓善顺听法。资粮者。所谓受持不废忘。方便者。所谓随闻能观。智者。所谓随所闻而行。能正住如是等行者。是名出要。复次善根者。所谓值佛悦可。资粮者。所谓护一切诸波罗蜜诸摄法及助道法。方便者。所谓能从一地至于一地。智者。所谓得无生法忍。菩萨能正住如是等行者。是名成就善根资粮方便智出要。尔时光明庄严梵天白佛言。希有世尊。如来能以四句义。总说一切菩萨行。世尊。一切佛法应于中求。尔时虚空藏菩萨语梵天言。一句亦能总摄一切佛法。何谓为一。所谓离欲句所以然者。以一切佛法同于离欲。如佛法一切法亦然。梵天。是为一句总摄一切佛法。复次梵天。一空句总摄一切佛法。一切佛法同于空故。如佛法一切法亦然。梵天。是为一句总摄一切佛法。所谓无相句。无愿句。无作句。无生句。无起句。如句。法性句。真际句。离句。灭句。尽句。涅槃句。总摄一切佛法。以一切佛法同于涅槃故。如佛法一切法亦然。梵天。是为一句总摄一切佛法。所以者何。以如是等句皆非句故。一切佛法非句。假名为句。复次梵天。欲是离欲句。所以者何。离欲性即是欲故。一切佛法亦同是性。嗔恚是离嗔句。所以者何。离嗔恚性即是嗔恚故。愚痴是离愚痴句。所以者何。离愚痴性即是愚痴故。一切佛法亦同是性。身见是实际句。所以者何。实际性即是身见。一切佛法亦同是性。无明是明句。所以者何。明性即是无明故。一切佛法亦同是性。乃至苦恼是离苦恼句。所以者何。离苦恼性即是苦恼故。一切佛法亦同是性。色是虚空句。所以者何。虚空性即是色故。一切佛法亦同是性。受想行识是无作句。所以者何。无作性即是识故。一切佛法亦同是性。地大是虚空句。所以者何。虚空即是地大故。一切佛法亦同是性。水大火大风大是法界句。所以者何。法界性即是风故。一切佛法亦同是性。眼是涅槃句。所以者何。涅槃性即是眼故。一切佛法亦同是性。耳鼻舌身意是涅槃句。所以者何。涅槃性即是意故。一切佛法亦同是性。梵天。是为一句总摄一切佛法。菩萨入如是等一一智门。皆见一切佛法入于一句。梵天。喻如大海能吞众流。一一句中摄一切佛法亦复如是。喻如虚空悉能苞容一切色像。一一句中摄一切佛法亦复如是。如是等一切佛法。若摄若不摄。若说若不说。不增不减。究竟离相故。梵天。喻如算师数数以算筹。布在算局上。然局中无筹。筹中无局。所以者何。究竟不相应故。究竟离故。如是于上一一句中假名数故。言一切佛法皆入一句。而诸佛法不可名数算计。究竟不相应故。究竟离故。梵天。如佛法名数。即是一切法名数。何以故。一切法即是佛法。此法非法非非法。自性空故。自性离故。自性究竟无性故。无性即是虚空。虚空性同一切法性。此法性非生相非灭相。非有处相非无处相。是故一切法名无相无非相。说如是一法门时于彼梵众中有万二千梵天。皆发阿耨多罗三藐三菩提心。复有昔殖德本五千梵天得无生法忍

尔时众中有一菩萨名曰宝手。问虚空藏菩萨言。希有善男子。一切诸法及如来法。甚深难测不可思议。又善男子。何谓安一切佛法根本耶。虚空藏菩萨答宝手言。善男子。菩提心是安一切佛法根本。一切法住菩提心故。便得增长。宝手菩萨言。善男子。菩提心者。何法所摄得不忘失能速至不退转地。虚空藏言。善男子。菩提心为二法所摄得不忘失速至不退转地。何等为二。所谓淳至毕竟。是名为二法所摄得不忘失能速至不退转地。宝手言。善男子。此二者为几法所摄。虚空藏言。此二法为四法所摄。何等为四。所谓淳至者。为不虚诈不谄曲所摄。毕竟者。为无我及上进所摄。是为二法为四法所摄。宝手言善男子。此四法为几法所。摄虚空藏。言善男子。此四法为八法所摄。何等为八。所谓不虚诈者。为不犹豫及体真净所摄。不谄曲者。为正直及正住所摄。无我者。为不退没及进所摄。上进者。为功德资粮及智资粮所摄。是为四法为八法所摄。宝手言。善男子。此八法复为几法所摄。虚空藏言。善男子。此八法复为十六法所摄。何等十六。所谓不犹豫者。为大慈及大悲所摄。体真净者。为身调及心调所摄。正直者。为忍辱及柔和所摄。正住者。为无憍慢及无滞碍所摄。不退没者。为坚固及力所摄。上进者。为如所作及正行所摄。功德资粮者。为始发及究竟不舍所摄。智资粮者。为求多闻及思惟所闻所摄。是为八法为十六法所摄。宝手言。善男子。此十六法复为几法所摄。虚空藏言。善男子。是十六法。为三十二法所摄。何等三十二。所谓大慈者。为无碍心及于一切众生等心所摄。大悲者。为无厌惓及勤给足一切众生所摄。身调者。为不触挠及不加害所摄。心调者。为定及寂静所摄。忍辱者。为受正教及顺行所摄。柔和者。为惭及愧所摄。无憍慢者。为谦卑及礼敬所摄。无滞碍者。为无垢秽及不强梁所摄。坚固者。为不犯所行及成就本愿所摄。力者。为住正意及不掉动所摄。如所作者。为如说及能行所摄。正行者。为正发及正进所摄。始发者。为必胜及不退所摄。不舍者。为乐胜及上求所摄。求多闻者。为亲近善知识及悦可善知识所摄。思惟所闻者。为智慧及善观所摄。善男子。是为十六法为三十二法所摄。宝手言。善男子。此三十二法。复为几法所摄。虚空藏答言。善男子。是三十二法。为六十四法所摄。何等六十四法。所谓无碍心者。为护我及护彼所摄。于一切众生等心者。为无别异及一味所摄。无厌惓者。为如梦观及知。生死如幻所摄。勤给足一切众生者。为诸神通及方便所摄。不触娆者。为羞耻及信有业报所摄。不加害者。为少欲及知足所摄。定者。为无发恼及无散失所摄。寂静者。为舍吾我及离我所所摄。受正教者。为求法及欲法所摄。顺行者。为敬重及平等无疲惓所摄。惭者。为内心断除及外不行所摄。愧者。为信乐佛智及在屏处不行恶所摄。谦卑者。为不骜慢及知自下所摄。礼敬者。为身端心直所摄。无垢秽者。为具静定及修智慧所摄。不强梁者。为不粗犷及不两舌所摄。不犯所行者。为不舍菩提心及念道场所摄。成就本愿者。为舍魔事及佛神力持所摄。正住意者。为不轻躁及不掉乱所摄。不掉动者。为如石山及不可移转所摄。如说者。为所作善业及无热恼所摄。能行者。为无虚诳及不舍归趣所摄。正发者。为离边见及顺观甚深因缘所摄。正进者。为善巧及方便所摄。必胜者。为不懈慢及勇猛所摄。不退者。为大欲及增进所摄。乐胜者。为见如来及闻法所摄。上求者。为舍诸地过患及得诸地功德所摄。亲近善知识者。为无憎嫉及信乐所摄。悦可善知识者。为敬顺及不逆教敕所摄。智慧者。为无常观及无我观所摄。善观者。为修无相及不怙涅槃所摄。善男子。是三十二法。为六十四法所摄。宝手复问。此六十四法。复为几法所摄。虚空藏答言。善男子。此六十四法。为百二十八法所摄。何等为百二十八法。所谓护我者。为断一切恶及成就一切善根所摄。护彼者。为忍辱及柔和所摄。无别异者。为犹如水心及如风心所摄。一味者。为法界观及如如观所摄。如梦观者。为无移转观及无真实观所摄。如幻者。为适性示现及无自性观所摄。诸神通者。为了义及了智所摄。方便者。为大悲及般若波罗蜜所摄。羞耻者。为不覆藏所犯及悔过所摄。信有业报者。为不放逸及畏恶趣所摄。少欲者。为净处有齐限及离宿秽所摄。知足者。为易称及易养所摄。无发恼者。为究竟及究竟边际所摄。无散失者。为得忍及不退转地所摄。舍吾我者。为不计我身及与寿命所摄。离我所者。为无贪及无愚痴所摄。求法者。为智及断所摄。欲法者。为不着五欲及离烦恼所摄。敬重者。为起世尊想及疗救想所摄。无疲惓者。为身轻及翘勤省眠所摄。内心断除者。为身念处及受念处所摄。外不行者。为心念处及法念处所摄。信乐佛智者。为深敬重及净信所摄。在屏处不行恶者。为自证知及诸神天证知所摄。不骜慢者。为不自叹誉不讥彼人所摄。知自下者。为不虚称及不显己德所摄。身端者。为不行三不善业及不犯禁戒所摄。心直者。为常省己过及不说彼短所摄。具静定者。为寂静心及灭烦恼所摄。修智慧者。为选择诸法及知无我所摄。不粗犷者。为常行益事及顺忍所摄。不两舌者。为自足眷属及和合别离者所摄。不舍菩提心者。为众生及为佛智所摄。念道场者。为欲坏于魔众及成正觉所摄。舍魔事者。为正观及不舍菩提志所摄。佛神力持者。为坚固行及善淳至所摄。不轻躁者。为坚护诸根及不舍境界所摄。不掉乱者。为观苦及观空所摄。如石山者。为不高及不下所摄。不可移转者。为断爱及除恚所摄。所作善业者。为智所作业及舍魔事所摄。无热恼者。为净戒及净定所摄。无虚诳者。为诚实语及不望果报所摄。不舍归趣者。为成就贤士业及不行怯弱所摄。离边见者。为观无生及不败坏观所摄。顺观甚深因缘者。为观因及观缘所摄。善巧者。为第一无诤竞及不骜慢所摄。方便者。为离方便及无生方便所摄。不懈慢者。为身力及心力所摄。勇猛者。为胜进心及害怨敌所摄。大欲者。为不求利养及不爱身命所摄。增进者。为无愚冥及不退还所摄。见如来者。为修念佛及清净信所摄。闻法者为乐至讲所及乐请问所摄。舍诸地过患者。为不散乱行及舍离恶知识所摄。得诸地功德者。为方便回向及不舍本行所摄。无憎嫉者。为能施一切及称意而舍所摄。信乐者。为无垢行及不浊心所摄。敬顺者。为知世宜及随顺行所摄。不逆教敕者。为舍除不净及净正行所摄。无常观者。为动转观及败坏观所摄。无我观者。为不得作者及不得受者所摄。修无相者。为不缘境界及除觉所说所摄。不怙涅槃者。为除去无明及断爱着所摄。善男子。是为六十四法。为百二十八法所摄。尔时宝手菩萨。从虚空藏菩萨闻分别如是等法门已。欢喜踊跃得未曾有。即白虚空藏菩萨言。希有大士。汝乃能成就如斯捷疾辩才及巧分别辩。事事所问尽能开解。如我今者。解汝所说义趣及与文字。以如是方便。若一劫若减一劫。说不可尽辩亦无断。尔时佛告宝手菩萨言。善男子。如是如是如汝所言。此虚空藏菩萨若演一句之义。若一劫若减一劫。说不可尽辩亦无断。虚空藏菩萨有如是无量无边不可思议无尽辩才。尔时宝手菩萨。以手遍覆妙宝庄严堂。于其手中出无量花香璎珞末香涂香衣服严身之具及诸幢幡妙盖。雨如是等上妙供具。供养如来及虚空藏。于上空中。百千音乐不鼓自鸣。于诸音中出诸妙偈。以赞如来

  持德开德具百福　　上意调伏念不动
  沙门贤士降天人　　十力佛子十方吼
  大称威德自在尊　　降伏有畏除痴闇
  能度漂流诸天人　　闭恶趣门使清凉
  圣尊巧说音微妙　　无错无谬音恬静
  三界无等无三垢　　十方所说施众乐
  意念坚固乐寂静　　最胜十方降彼力
  已舍谄曲得甘露　　无有尘累众归仰
  世尊处众不动转　　而化十方无量众
  随众生行能随顺　　佛子亦乐修此行
  如日无翳能普照　　能令众华得开敷
  佛智慧光照长流　　诸子得悟亦如是
  如风无碍山不动　　净如虚空照如日
  佛子放光雨甘露　　是故我礼佛及子
  大千海水尚可量　　十方虚空犹可涉
  诸众生心尚可同　　世尊功德不可尽

大方等大集经卷第十七大方等大集经卷第十八

        北凉天竺三藏昙无谶译

    虚空藏菩萨品第八之五

说此偈已。时魔波旬严四种兵来诣佛所。到已化作长者形。前礼佛足。在一面立而白佛言。希有世尊。此诸大士。乃能成就如是不可思议种种神变。又能示现不可思议庄严之事。世尊。于未来世有几所众生。闻此不可思议神变而得开悟。决定不疑者也。佛告魔波旬言。于未来世中。少有众生若一若二。闻此不可思议神变经典。得信解者少耳。波旬。喻如一毛析为百分以一分毛于大海中取一渧水。于汝意云何。取者多耶。在者多耶。波旬言。世尊。取者甚少。在者甚多。佛复告波旬言。如海中所取水甚少。众生闻是不可思议神变经典。能信解者少亦如是。如大海中水在者甚多。不信解不可思议神变经典者。多亦如是。佛复告波旬。若有一人于恒河沙等劫。日日以满三千大千世界。满中珍宝持用布施。不如善男子善女人闻是不可思议神变经典能信解者其福甚多。所以者何。波旬若有信解是经典者。则知其人亲从释迦牟尼如来。闻是经典信解无疑。何以故。波旬。若未种善根众生。闻此世所难信经典。能信解者无有是处。波旬。我般涅槃后法欲灭时。多有憍慢众生。彼诸众生着我所说文字。不知方便故。各各生于诤竞。舍思惟法舍已正行为利养名誉衣服饮食。自缠缚故。乐论世俗种种诸事及世典文辞。而不论第一实义不乐玩习佛无上道反向他人讥论如是等真实深妙经典。则为诽谤诸佛。积集无量大苦恼聚。魔神诸天佐助彼人。为利养恭敬及名闻故。重增放逸骜慢。彼诸人等以骜慢故。若见有持戒贤行比丘受持读诵此经典者。而轻慢憎嫉横生谤毁。彼诸愚人则为现世破犯禁戒。其中或有畏不活者。或惭耻于人者。假被袈裟。或有舍戒还附俗者。如是等人身坏命终。堕阿鼻地狱受诸苦报。佛复告波旬。于未来世中若有求菩萨乘众生。着诸因缘善根微浅。新发道意但著文字不能了义。于如是等甚深经典。受持读诵为人说时。则为他人所见轻贱陵蔑。以为他人所轻贱陵蔑故。便舍如是等甚深经典。读诵声闻辟支佛相应经典。为利养名誉种种所须之所缠缚故。反诽谤毁呰如是真实甚深经典。又复轻贱受持读诵此经典者。乃至不欲以眼观之。常乐卑行退失菩萨大乘之法。所谓退失淳至心及深心。魔神诸天得如是等人便故。勤作方便坏乱其心。乃至使令不闻如是等经。设当闻者。生大诽谤无有信心。此人亦复积集无量罪聚。成就破法重业。永离三宝不得见佛闻法及供养僧。所以者何。波旬。以于如来所说法律中生疑犹豫故

尔时魔波旬。自见有过忧愁惶恐。前礼佛足在一面立。时虚空藏菩萨问魔波旬言。汝何以忧愁憔悸战栗悚息。状如失志人。在一面立耶。魔波旬答言。善男子。我从如来闻说如是等可畏之事。是故以为忧愁恐怖。当堕何趣谁当救我。我于如来所说法律之中。数作无量诸留难事。是故忧耳。虚空藏言。波旬。佛法之中有出罪法。汝可来至世尊所。可诚心忏悔所作诸恶。更莫复作。若能如是可获善利。为不空过。尔时天魔波旬。即前五体投地。礼世尊足下。仰视如来流泪涕泣而白佛言。世尊。我今诚心忏悔。从昔以来于如来所说法律之中。数作无量诸留难事。唯愿世尊起大悲心。以慈愍故愿受忏悔。佛言善哉善哉。波旬。汝乃能自见所作诸恶。为上善哉。能如是悔过罪者。于佛法中则为弘广如来法藏。诸佛亦受其人悔过。是故汝今勿更复作。尔时世尊告众菩萨言。诸贤士。汝等各说过魔界行法。为生怜愍魔波旬故

尔时众中有一菩萨名金山王。在众中坐即白佛言。世尊。若有防护内界者。则为未过魔界。若复有菩萨见一切诸界同佛界者。知此佛界即是非界。是为菩萨能过魔界

尔时宝德菩萨白佛言。世尊。有依倚樔窟者。是为魔界。若有菩萨不倚樔窟。知一切法无得相者。则能为诸众生。说断倚樔窟法。是为菩萨能过魔界

尔时宝手菩萨白佛言。世尊。若有取我我所者。是为魔界。若有菩萨不取我我所者则无诤竞。以无诤竞故则无心行。况当有魔界耶。是为菩萨能过诸魔界

尔时无诤勇菩萨白佛言。世尊。若有触有离则有诤讼。有诤讼者魔得其便。若无触无离自不诤讼。亦不令他诤讼。以得无我故。无恼行者能过魔界

尔时宝思菩萨白佛言。世尊。若有妄想分别则是烦恼。及有烦恼处则是魔界。若有菩萨知一切诸法无相貌者。于诸烦恼则无妄想。若内若外亦不别知。去离一切妄想分别故。是为菩萨能过魔界

尔时乐作菩萨白佛言。世尊。若有乐不乐处。则有憎有爱。若有憎有爱则是魔界。若有菩萨去离憎爱平等行者。于诸法中则无二想。得入不可思议界。是为菩萨能过魔界

尔时离诤菩萨白佛言。世尊。魔界由我而起。若菩萨能知我者。得无我忍即知我净。知我净故知一切法净。知一切法净故。知诸法性净如虚空。是为菩萨能过魔界

尔时。法自在菩萨白佛言。世尊。若顺烦恼法为爱所使者。魔则得其便。世尊。若有菩萨于诸法中最得自在自然开悟。以为诸佛之所授记。于菩提法终不退转。是为菩萨能过魔界

尔时山相击音菩萨白佛言。世尊。若心有缺漏则是魔界。若菩萨戒无缺漏心无缺漏。成就一切诸空法行者。是为菩萨能过魔界

尔时喜见菩萨白佛言。世尊。若有不见佛不闻法者。魔得其便。若有菩萨常见诸佛而不着色像。常听诸法而不著文字。以见法故则为见佛。以无言说故能听诸法。是为菩萨能过魔界

尔时帝网菩萨白佛言。世尊。若有恃有动则是魔界。若菩萨善相顺精进。知一切法究竟。无成就相故不恃不动。是为菩萨能过魔界

尔时德明王菩萨白佛言。世尊。若有行二法者。则魔得其便。若有菩萨知一切法同于法性。则不见魔界与法性有异解。知法性与魔界等。以不二相故。是为菩萨能过魔界

尔时香象菩萨白佛言。世尊。若有菩萨性弱畏甚深法者。则魔得其便。若勇健菩萨善能通达三解脱门。于甚深法不惊不畏。以能现前证知诸法实性故。是为菩萨能过魔界

尔时弥勒菩萨白佛言。世尊。喻如大海中水同一碱味。佛法海中亦复如是。同一法味。所谓解脱味离欲味。若菩萨善解一味法者。是为菩萨能过魔界

尔时虚空藏菩萨白佛言。世尊。喻如虚空究竟无垢究竟明净究竟不为一切烟尘云雾之所干绕。菩萨亦复如是。心如虚空。知一切法性常清净。亦复不为客尘烦恼之所干绕。得度般若波罗蜜彼岸离诸闇冥。于诸法得慧光明者。是为菩萨能过魔界

尔时文殊师利法王子菩萨白佛言。世尊。若有言语则有滞碍。若有滞碍则是魔界。若法不为一切言说所表者。乃无滞碍。何谓法不可言说。所谓第一义。其第一义中亦无文字及义。若菩萨能行第一义谛。于一切法尽无所行。是为菩萨能过魔界。无所过故

尔时世尊告波旬言。汝闻说过魔界法不也。波旬白佛言。世尊。唯然已闻。佛言波旬。若有行如是等法者。一切诸魔无如之何。若有诸魔。欲于行人起魔事者。终不能办。而更成就无量罪聚。是故波旬。汝可发阿耨多罗三藐三菩提心。于如是过魔界法。应坚持奉行。汝若能如是行者。则能过一切诸魔国界。波旬。喻如百千年垢腻可于一日浣令鲜净。如是于百千劫中所集诸不善业。以佛法力故善顺思惟。于一日一时尽能消灭。波旬。如有干草[卄/積]大如须弥。以少火投中速能烧尽。如是以少慧力故。能除灭无量诸闇冥聚。何以故。波旬慧明勇猛故。无明劣弱故。时魔波旬即作是念。大慈世尊今怜愍我。而能为我说菩提心法。我今宜应于如来所种少善根。于是波旬即化作八万四千殊妙宝盖及无量华鬘璎珞末香涂香而告己眷属言。诸佛世尊出世甚难。卿等诸人咸应共来至世尊所为供养故。尔时魔天眷属中。有八万四千众及魔波旬。各共持殊妙宝盖及无量华香璎珞末香涂香。至世尊所设供养已。皆发阿耨多罗三藐三菩提心。诸余魔眷属诸天不发菩提心者。形相嗤笑讥论。波旬复言。希有波旬。乃能于沙门瞿昙前。诈现如是笃信之相。状如至亲。所以然者。波旬或欲于沙门瞿昙所学咒幻方术。是故今于面前。现善赞誉耳。尔时魔子丑面及余魔子等。悉无信心各说是言。假使沙门瞿昙。以诸方术回转魔王者。我等共当设诸方便令如是等经不得流布。设使流布者。亦当令少有护助。信受行者亦令甚少。当为多人之所薄贱轻弄。常堕边方不令中国之所宣传。唯使诸无威德贫穷众生当得闻之。常为诸大威德豪富之人不信诽谤也

尔时世尊。告虚空藏菩萨言。贤士汝闻此诸魔子出是恶言不耶。虚空藏白佛言。唯然已闻。佛言。善男子。是故汝当安慰护助此妙经典。为降伏诸魔神故。于是虚空藏菩萨。即白佛言。诸佛世尊。皆已护持如是等经。我等亦当安慰受持。尔时虚空藏菩萨。即说咒曰。所谓

阿跋低(一)跋低(二)毗跋低(三)婆醯多[少/兔]散提(四)头楼陀罗尼(五)涅伽多涅伽多尼(六)钵伽多尼(七)迷罗育低(八)伽楼那涅耐提(九)萨遮跋低(十)浮多勒差(十一)达摩涅折低(十二)达摩勒差(十三)郁鸠离(十四)尸鸠离(十五)咻楼咻楼咻楼德迦攡(十六)多婆婆帝低(十七)尸罗[少/兔]婆帝低(十八)阿叉夜涅涕池(十九)枳奢婆迦利拖(二十)佛驮遏提魅低(二十一)达摩蔚耆罗泥(二十二)僧伽[少/兔]铜咩(二十三)阿[少/兔]头隶(二十四)不可济度(二十五)坏魔眷属(二十六)若犯此者(二十七)无诸刀杖(二十八)顺已处行(二十九)圣众所住(三十)吉吉等句(三十一)顺流解脱(三十二)破诸外论(三十三)降伏魔众(三十四)

  四王常护　　及天帝释　　梵王世主
  奉佛诸天　　护菩提者　　如是等神
  常当拥护　　降伏诸魔　　利众生故
  受持正法　　护说法师　　尽当拥护

虚空藏菩萨说此咒已。即时此妙宝庄严堂及三千大千世界六变振动。时诸魔子见上虚空中。有五百蜜迹执金刚杵。炽然如火甚可怖畏。时诸蜜迹。唱如是言。若有魔子及诸魔神。若闻此咒。其有不发阿耨多罗三藐三菩提心者。吾等当击破其头令作七分。尔时魔子及诸眷属。惊怖战悚身毛皆竖。即合掌礼佛而白佛言。我等今发阿耨多罗三藐三菩提心。善哉世尊。愿救我等离此恐怖得无畏乐。尔时世尊。告侍者阿难言。如向此诸魔子所说言。我等当于来世于此经典作留难者。必当称其本誓而作留难如斯经典。唯当以佛神力及诸菩萨受持故。当得流布于世。而无有多人受持读诵分别解说。佛复告阿难。汝见此诸魔子为脱恐怖故发阿耨多罗三藐三菩提心不。阿难白佛言。世尊。唯然已见。佛复告阿难言。此语即为诸魔子。当作离魔事因。以不深心发菩提故。佛复告阿难。于未来世。当有佛出现于世。名无垢相如来应正遍知。此魔波旬。于彼佛所乃当不退转发阿耨多罗三藐三菩提心。阿难。彼无垢相如来。知其深心成就故。当授阿耨多罗三藐三菩提记。当于尔时。亦当作魔王。深心敬信于如来正法。如弥勒出时。有魔王名曰导师。深心敬信佛法圣众。此诸五百魔子。亦当于彼生于魔中。当于彼佛所为菩提故种诸善根。乃至波旬成佛之时。当与授阿耨多罗三藐三菩提记。佛告阿难言。此魔波旬。今虽发菩提心。犹豫不定。如少叠毳。虽尔当渐渐成就无量功德。为世之尊如今我身

尔时众中有无量无边诸天世人释梵护世。闻授魔波旬记当得成佛。欢喜踊跃怪未曾有。合掌向佛而作是言。甚奇希有。其见佛者必得成就无量功德法宝之聚。所以然者。或有不信众生。为欲挠乱如来故。而得见佛。或有遇会得见佛者。即为彼众生作因。乃至令得涅槃。又白佛言。世尊。自除如来应正遍知。谁能如是分别。知众生根。佛告诸天人言。如汝等所言。其有得见如来者。无不蒙益。汝等当知。或有众生善根都尽。于无量阿僧祇那由他劫。无人身分者。如是众生见如来故。即便得作善因乃至涅槃。如来乃能如是。作无量不可思议无上福田。佛复告诸天人言。心性常净。而凡愚众生不能如实知见。以不能如实知见故。言是垢。能正知见故。便言是净。而第一实义中。无有一法可净可污。汝等当知。诸烦恼者。无方无处非内非外。以不善顺思惟故便生烦恼。善顺思惟故则无烦恼。增减不等则生烦恼。无增减者则无烦恼。虚伪妄想便是烦恼。无有妄想则无烦恼。是故我言。如实知邪见则是正见。而邪见亦不即是正见。能如实知者。则无虚妄增减取着。是故名为正见。佛复告诸天人言。喻如大地依水界住。大水依风界住。大风依虚空住。虚空无所依住。如是大地无所依住。而假有依住之名。是故汝等当如是知之。苦依于业业依于结。而苦业结都无所依。以心性常净故。如是当知。一切诸法无有根本。都无所住。以假言说故。言有而实无也。是故说一切法本性常净。究竟无生无起。佛复告诸天人言。是故汝等当知。此法门名为性常净法门。菩萨通达此门者。不为一切烦恼之所染污。而亦不恃此清净门。以舍一切诸恃动故。便得平等道。能过魔界入于佛界。亦能得入诸众生界。而不动法界知一切法无界无非界。而能速生一切智界。当说此法时。有五百菩萨得无生法忍。尔时申越长者在于众中。从座而起顶礼佛足。白佛言世尊。为我故说如是等甚深经典。我先为触恼世尊故。作大火坑及设毒饭。而大圣如来是不可害者。故我于佛生信敬心。自尔以来。疑悔心结常未能除灭。今者从佛闻此甚深微妙经典。疑悔即除心无障碍得安乐行。世尊。是故我信敬心转复增长。今我家中多诸财宝。当以供佛法僧及诸沙门婆罗门贫穷孤独下贱乞儿。世尊。谁当闻是断一切缚甚深经典。而于一切诸物生贪著者乎

尔时虚空藏菩萨白佛言。世尊。诸佛如来无上菩提。甚为甚深难可测知。若有菩萨于未来世。舍己身命及利养名誉。而能侍佛菩提者。甚为难有。尔时众中有六十八亿菩萨。从座而起合掌向佛。一时同声而说偈言

  世尊灭后　　我等能忍　　舍身寿命
  为护正法　　舍利名誉　　离诸贪着
  愿护正法　　为佛智故　　骂詈呵责
  及讥刺语　　护正法故　　当忍受之
  轻贱毁弄　　唱说恶名　　当以慈忍
  为护此经　　来世比丘　　计着诸有
  与魔为党　　诽谤正法　　毁禁行恶
  乐着俗累　　为利所覆　　不乐正法
  恃玩俗典　　憍慢放逸　　高叹己利
  蔑正行者　　常舍闲静　　乐处愦闹
  习世文辞　　计着吾我　　不营教化
  不业智慧　　舍离坐禅　　不亲三宝
  无有智慧　　群党求利　　动与结俱
  乐受他供　　他慈心施　　惜犹己有
  数往到彼　　说诸世事　　田宅居业
  及贩卖事　　勤求息利　　犹言沙门
  骜慢著有　　依邪崄见　　闻性空法
  当大惊怖　　言后长远　　但求现报
  当虚妄说　　非法言法　　如是大灾
  弊恶比丘　　魔及魔子　　复当佐助
  经文是一　　说义各异　　各是己论
  愚者当尔　　诸深妙经　　能与解脱
  当拥遏之　　及说浅事　　我胜汝劣
  由胜得果　　于佛法中　　当如是竞
  如是竞时　　众生数坏　　为非法王
  之所恼逼　　于是末世　　坏甚可畏
  我持正法　　救世所说　　我常慈心
  不舍法律　　生正大悲　　为世作护
  毁禁作恶　　不住正法　　坠堕何道
  我常忧愍　　见故作恶　　谤毁正者
  我终不共　　与为亲党　　常任我力
  善护口过　　见无用人　　不说其短
  我住圣种　　头陀护戒　　处定习慧
  常勤修行　　离世愦闹　　乐处闲静
  无著如鹿　　善调知足　　若至聚落
  摄根少语　　见说法者　　共论正法
  爱语利益　　以化众生　　又与说法
  令断恶行　　我为正法　　极远当往
  为彼说法　　利益众故　　若见凡愚
  有缺失者　　但当自护　　住法行忍
  毁辱恭敬　　当如须弥　　不染世法
  为世导师　　毁禁比丘　　若来呵责
  自省己行　　将是业报　　当为是等
  嫉恶众生　　先意善言　　现为恭敬
  彼即生念　　我亦沙门　　成就是德
  无若干恶　　诸毁禁等　　如失志人
  闻是经忧　　如劓照镜　　其作方便
  不欲闻之　　复教余人　　言非正法
  又教国王　　坏臣民心　　诽谤正法
  言非佛说　　我等于时　　以佛力故
  为持正法　　不惜身命　　世尊知我
  言无有二　　当坚护持　　住是正法
  作诚实语　　如说而行　　悦可诸佛
  乃成菩提

尔时虚空藏菩萨赞诸菩萨言。善哉善哉诸大士。汝等乃能发诚实愿。受持如来甚深微妙无上大法。甚为快也。虚空藏菩萨白佛言。世尊。其有善男子善女人。受持读诵此经典者。得几所福。佛告虚空藏言。贤士。譬如东方十三千大千世界。南西北方四维上下。各十三千大千世界。尽末为微尘。以尔所尘集为一聚。设有一人成就神足无量威德。寿命长远。此人持诸微尘。过东方尔所尘数世界。乃下一尘。如是展转东行。尽此尘聚。而诸世界犹不可尽。如东方世界。南西北方四维上下。亦过尔所佛土乃下一尘。如是展转诸方世界。尽此尘聚而诸世界犹不可尽。虚空藏。于汝意云何。是诸世界宁为多不。虚空藏白佛言。甚多甚多。世尊。无量无边不可计知。佛言贤士。是诸世界微尘所著处及不着处尽此微尘所及世界已。还为一大城。纵广高下悉皆同等。于其城中满葶苈子。贤士。是诸葶苈子。可数知不。虚空藏白佛言。世尊。假设譬喻犹不能了况可数知。唯除如来无能数者。佛告虚空藏言。如是如是。如汝所言。唯如来能知是诸葶苈子。若百数千数百千万数。佛言贤士。设有一人成就神足无量威德。能以口吹是诸葶苈布散十方。一葶苈子堕一佛世界。终不过一。贤士。于汝意云何。是诸葶苈所及世界。宁为多不。虚空藏白佛言。世尊。是诸世界。乃非心力所能分别。说分别者。令人心迷错乱。贤士。我今告汝。若有行菩萨道善男子善女人。日日以满尔所等世界。无量珍宝持用布施。无有休废不营余事。若复有善男子善女人。受持读诵书写此甚深经典。不求利养为菩提故。乃至为一人说。使其人闻已。劝令于阿耨多罗三藐三菩提。乃至发一善念。欲令正法久住世故。此人功德复过于彼布施者上。百倍千倍百千万倍。乃至非算数譬喻所及。何况能令住阿耨多罗三藐三菩提者。何以故。贤士。以能说如是无量善根。成就诸菩萨。为护持正法故。贤士。我不见菩萨更有余法能过于是。坚固正行摄诸善法。教化众生者也。尔时虚空藏菩萨白佛言。世尊。希有如来不可思议。如来大法亦不可思议。如如来大法不可思议。其受持此经典者。所得功德亦不可思议。唯愿世尊。护持此经为当来世。令受持此正法。诸善男子善女人手得是经。执在胸怀不离是经。若应离生死者。不从他闻。自然得悟菩提。悟菩提已。广为他说。佛言贤士。谛听谛听善思念之。吾当为护此经故。当说章句召护世四天王天。帝释梵天王等诸神。以此章句召故。护世四天王天。帝释梵天王。皆当拥护诸说法师持此经者。说此世所难信甚深经典时。使无能作留难。所谓若王大臣驱遣出国。若得重病。若斗诤时起。若国土疾疫。如是等事起时。以咒术力故。即令消灭不得成就。何等为咒术章句。所谓

头头丽(一)提提丽(二)陀夜簸帝(三)陀夜罗伽罗(四)泥帝提(五)毗婆知(六)赊咩(七)赊弥多毗(八)目仚(九)膻帝低(十)尼[山*耆]弩祢(十一)阿[少/兔]多丽(十二)鸣多罗尼(十三)婆簸斯(十四)钵他输陀尼(十五)钵陀[少/兔]枳(十六)钵陀散提(十七)般若牟丽(十八)阿娑究丽(十九)浮陀勒差(二十)伊那萨枝(二十一)多婆萨枝(二十二)多婆钵低(二十三)

随佛意　顺法性　恭敬僧　世主信　护世四王　为诸佛子　受持此咒　护说法者

尔时四天王即从座起。合掌向佛而白佛言。世尊。我等当护此诸佛子受持经者。即说咒曰

首鞞(一)首婆钵低(二)首提帝(三)因哆拥(四)陀梨拥(五)陀罗尼(六)颇耽麋(七)阿丘拥怯卑(八)阿目仚(九)阿罗尼陀拥(十)薮首晒婆醯那(十一)脾提脾陀赖散提(十二)三咩(十三)婆夜咩(十四)三摩赖弥(十五)波扇多[口*第](十六)休休(十七)醯醯(十八)丘楼丘丽(十九)

于时四大天王自在者。说此不可犯咒已

尔时天帝释即从座起心净悦豫。合掌向佛而说偈言

  末世饥馑时　　大称诸贤士
  受持说此经　　我当为给侍

于是帝释说此偈已。即说咒曰

弥低(一)首脾(二)摩诃弥低(三)达摩弥低(四)天多加丽(五)三摩弥低(六)萨遮弥低(七)那提咩(八)阿[少/兔]多丽(九)阿[少/兔]头离(十)阿[少/兔]勒差(十一)萨婆萨埵阿[少/兔]伽醯(十二)阿那[少/兔]多卑(十三)修冀低(十四)阿毗卢提(十五)阿毗伽醯(十六)浮提菩舍咩(十七)腻魑(十八)遏他尼低(十九)泥提罗尼(二十)阿那他婆差帝(二十一)咩低(二十二)咩低阇耶私(二十三)修莎罗(二十四)

  汝等起禅乐　　来护持法者
  诸世界世尊　　皆悉共受持

尔时梵自在天王即从座起。赞彼释梵护世诸天言。善哉善哉。汝等乃能为护正法持法说法者故。发大庄严。汝等正应如是。甚得其宜随如来法律。住世久近。于尔所时中。当有识别正行法行。于尔所时中诸天世人。甚当炽盛充满宫宅。此法灭后。诸天世人转当减少宫宅空荒

尔时世尊告弥勒菩萨言。弥勒。汝受持此甚深经典。读诵书写广为人说。弥勒。我今以如斯等甚深经典嘱累于汝。令此大法久住世故。降伏诸魔故。为利益一切众生故。令一切外道不得便故。教敕一切菩萨。使亲近此经不远离故。欲令佛法大明久住于世不衰灭故。使佛法僧种不断绝故。尔时弥勒菩萨即白佛言。世尊。我于如来在世及灭度后。常当受持此甚深经典广宣流布。所以者何。受持此法者。则为受持过去未来现在诸佛正法。非但受一如来法也。世尊。我亦为自护己法故。世尊。我常与诸天人众。普会处兜率天宫。每为广说如是等甚深经典。我复当令人中。受持读诵此经典者。使手得是经执在胸怀不离经卷。世尊。若复末世法欲灭时。其有受持此经转为人说者。当知皆是弥勒威神之所建立。世尊。当于尔时虽多诸魔事娆乱行人。诸说法者。依烦恼魔为魔所持故。不乐此经不勤修习。互相是非。我等俱当勤作方便。令说法者爱乐是经。常勤修习读诵通利。广为人说。尔时世尊赞弥勒菩萨言。善哉善哉。弥勒。汝乃能为护持正法故作师子吼。汝不但今于我前作师子吼。亦于过去无量阿僧祇诸佛前作师子吼护持正法。尔时世尊告大德阿难言。阿难。汝受持此经耶。阿难白佛言。唯然世尊。以佛神力故我已受持。佛言阿难。汝常当广为四众分别解说。若有先种善根乐胜法者。如是等人闻已。则能信解受持读诵广为人说。其人则得无量无边不可思议大功德聚。阿难即白佛言。世尊。当何名斯经。云何奉持。佛言阿难。此经名劝发菩萨庄严菩提。当如是奉持之。尔时功德庄严菩萨。在于众中即从座起。右膝着地合掌向佛。白佛言。希有世尊。如来为拥护正法及说法者故。善能如是快赞此经。世尊。诸新学菩萨为菩提故种诸善根。以种种华香璎珞末香涂香。勤供养如来。而不受持此经。是人颇成以第一供养供如来不。佛言。善男子。不成第一供养如来。亦不能以此因缘得无量功德。不如善男子善女人。受持此经者功德甚多。尔时世尊即说偈言

  我以佛眼　　所见佛刹　　周遍十方
  广大无边　　尔所诸界　　盛满珍宝
  菩萨以此　　恒用布施　　若有于此
  甚深妙经　　无所得法　　诸佛所说
  而能受持　　为人演说　　此人功德
  复多于彼　　华香璎珞　　涂香末香
  宝盖幢幡　　上妙衣服　　以是供具
  普满诸界　　供养如来　　回向佛道
  若后末世　　法欲灭时　　于救世法
  勤修护助　　受持正法　　不放逸行
  此功德聚　　复多于彼　　十方世界
  一切巨海　　尽盛满中　　上妙香油
  作大灯炷　　犹如须弥　　然以供养
  一切诸佛　　法炬若欲　　断灭之时
  知世众生　　无明所覆　　若能然此
  大法炬者　　此人功德　　复胜于彼
  我之所见　　无量诸佛　　虽亿千劫
  种种供养　　诸天上妙　　适意供养
  不能受持　　此妙经典　　若于诸佛
  知有重恩　　拥护三宝　　为报恩故
  为欲饶益　　一切众生　　受持此经
  福胜于彼　　我以佛眼　　所见众生
  若有能教　　尽成释梵　　所得功德
  不如书写　　持此经者　　功德甚多
  大千世界　　所有众生　　若有能教
  尽成二乘　　若有能发　　菩提心者
  护持此经　　功德复胜　　持经功德
  假令是色　　悉当充满　　十方世界
  唯除如来　　无上大智　　更无能知
  此功德者　　如如来智　　无有边际
  虚空法界　　亦无边际　　能持如来
  此经法者　　功德无边　　亦复如是

尔时功德庄严菩萨白佛言。世尊。如我今者。信解如来所说义趣。后五百岁。法欲灭时。诸发大乘众生。其不受此经法者。将知是等为魔所持堕佛法外。世尊。我今堪任如来灭后受持此经。欲令佛法久住世故。尔时世尊为嘱累此经法故。放大光明。普照十方无量阿僧祇诸佛世界。彼诸如来。亦为嘱累此经法故。皆放眉间白毫相光。普照十方一切世界。无不周遍说此经已。如来以大神力放光明。时无量阿僧祇诸佛世界。六变振动。有无量阿僧祇众生发无上道心。无量阿僧祇菩萨得无生法忍。复有无量阿僧祇菩萨。得一生补处善根。又复过是无量阿僧祇众生得声闻乘住学无学地。佛说经已。虚空藏菩萨大德阿难诸菩萨大众。及诸声闻诸天世人。闻佛所说皆大欢喜

大方等大集经卷第十八大方等大集经卷第十九

        北凉天竺三藏昙无谶译

    宝幢分第九魔苦品第一

尔时世尊故在欲色二界中间大宝坊中。与诸眷属围绕说法。告大众言。我昔初得阿耨多罗三藐三菩提时。住王舍城迦兰陀长者竹林。尔时城中有二智人。一名优波提舍。二名拘律陀。具足成就十八种术。五百弟子常相随逐。是时二人各相谓言。若有先得甘露味者要当相惠。时有比丘名曰马星。于其晨朝从禅定起。入王舍城次第乞食。忧波提舍。中路遥见马星比丘。即作是念。我久住是王舍城中。初未曾见若人沙门婆罗门等威仪庠序。如此人者。我当往问所事何师从谁受法。时忧波提舍。即往趣彼马星比丘。作如是言。比丘。汝师是谁从谁受法。马星答言。善男子。有释迦牟尼如来大士。胜诸出家无上之尊。已度生死获得解脱。能度一切无量众生。名之为佛。能悟众生。善作诸行能干苦河。具足成就如是等法。即是我师我从受法。忧波提舍言。汝师常说何等法义。善男子。汝今谛听。我当为汝分别解说。法从缘生。通达是因。因缘灭故。即是寂静。世间即苦。苦因名集。若修八正。世间集灭。若无苦集。我师说言。名为涅槃。善男子。我师唯说如是等法。忧波提舍闻是语已。得法眼净名须陀洹。即说偈言

  我闻比丘说四谛　　即得过于三恶道
  昔来未闻今得闻　　昔所未得今已得
  我今已过三恶趣　　真实了知道非道
  我今诚心归依佛　　以能宣说是法故

说是偈已复语比丘。如是世尊今住何处。马星答言。世尊。今在王舍大城迦兰陀长者竹林之中。与迦叶等千比丘俱。菩萨十千汝可往彼。忧波提舍言。比丘。我今先当还问同学及我徒众。时忧波提舍。敬意礼拜马星比丘。右绕三匝还所住处。拘律陀梵志。遥见忧波提舍。即便问言。忧波提舍。汝今诸根清净悦豫颜色光泽。将非获得甘露味耶。善男子。我已得矣。谛听谛听当为汝说。法从缘生。通达是因。因缘灭故。即是寂静。世间即苦。苦因名集。若修八正。世间集灭。若无苦集。我师说言。名为涅槃。拘律陀言。善男子。如是之言能尽诸苦。即是梵行。能断邪见一切因缘。亦说一切有为皆空。善男子。唯愿更说。忧波提舍复如本说。说已即得须陀洹果。拘律陀言。如是之言。能过四流度于生死。通达五阴永灭烦恼。是甘露味我今已得。不宜住此。善男子。如是师者住在何处。忧波提舍言。我闻住在王舍大城迦兰陀竹林。尔时忧波提舍及拘律陀。告诸弟子。此间今有释迦如来。我已咨受其所说法。汝等今者欲何所趣。尔时魔王告诸天众。鸯伽摩伽陀国有二大人智慧最胜。一名忧波提舍。二名拘律陀。今欲为彼瞿昙弟子。若此二人从彼瞿昙沙门受法。我境则空。我今欲往转彼二人出家之心。尔时魔王即化其身作马星像。至忧波提舍拘律陀所。而作是言。善男子。我先所说试汝智耳。汝既无答。释迦如来。真实不作如是之言。如来常说。无善业果无恶业果。若能亲近五欲乐者。是人即得甘露法味。又言无有今世后世。是故无业。若无业者谁作谁受。既无种子云何得果。释迦如来唯作是说。尔时忧波提舍与拘律陀。各相谓言。如是语者即是魔说。非如来语。又非马星比丘所说。魔知是已即便灭去。尔时二人复告弟子摩纳。汝常谛观生老病死世无免者。我今已能永灭诸苦。汝等今日欲何志求。尔时魔王复更化作马星形像。而作是言。谁能破坏生老病死。譬如有人说言。我能坏彼虚空。无有是处。若言能坏生老病死。亦复如是。时拘律陀语魔王言。我欲通达清净之法远离诸苦。一切出家皆悉无有解脱如是烦恼苦者。是故我今欲诣如来。魔王如野狐鸣。而云师子吼。色虽相似实非师子。魔王汝今虽作比丘形像。汝之所说非比丘说。夫比丘者破诸烦恼。破烦恼语即是清净。言无善恶非比丘语。时虚空中一切诸天。各各赞言。善哉善哉。善男子。一切出家佛道最胜。夫佛道者即是涅槃。汝今不受魔之所说。善哉善哉。尔时魔王受大苦恼即便隐灭。时诸弟子白二师言。如师今受瞿昙沙门无上正法。我等亦尔。当往启受。时二大师与五百弟子前后围绕。往迦兰陀长者竹林。尔时魔王复于其路化作大坑深百由旬。欲令诸人不得诣佛。如来知已即以神通。令彼二人所见平坦无有坑崄。魔复于前化作大山高广千里。如来神力令其不见。时魔复遣百千师子遮其道路。时诸师子见忧波提舍及拘律陀五百弟子。善心即生默然潜伏。诸人即得前至佛所。到已头面礼敬佛足。却住一面而白佛言。世尊。唯愿如来听我出家。我欲修佛清净梵行。佛言。善来诸善男子。恣意修集清净梵行。作是言已具比丘戒。尔时魔王见是二人得出家已。即便化作自在天像。向于佛所而说偈言

  世间若有智慧人　　具足成就世方术
  悉来礼敬供养我　　我亦为彼说净道
  瞿昙若欲度生死　　今当诚心见归依
  我今所说清净道　　如先佛说无有异

我时以偈答魔王言

  我真实知八正道　　能永远离破诸苦
  汝等真实不能知　　无以狐身师子吼

尔时魔王隐自在天像。复现梵像而说偈言

  真实远离诸烦恼　　能过三千大千界
  莫为众生受诸苦　　应当默然受禅乐
  世间乃至无一人　　堪任盛受甘露味
  我今怜愍故告汝　　应当速入于涅槃

我时以偈复答魔言

  我见世间多众生　　能度生死大崄河
  如是上中下品类　　先得度已我乃灭

尔时魔王受大忧恼。入于苦宅还其所止。其诸眷属各作是言。我王何故受是大苦。虽作是语无能知者。时魔婇女其数五百。身佩璎珞庄严饰好。为魔波旬作诸伎乐。歌舞嬉戏以相娱乐。波旬以手而遮止之。婇女于是默然而住。从二至七。魔亦如是遮止至七。时有一女名曰电光。语波旬言。大王何故如是愁恼。如失天位火灾起耶。将无有怨不能坏乎。波旬答言。我有大怨谓释种子。是大恶人成就幻术。若不治者我界则空。诸婇女言。彼释种子。以何庄严。有何道力。谁为伴党。能空王界。魔王答言。彼人以戒施忍庄严。无常苦空以为器甲。若坏众生诸有受生。我莫能知其所住处。具足无上大神通力。大慈大悲而为伴党。能度一切三有众生。是故能令我界空虚。时诸婇女闻佛功德。赍持香华及诸伎乐。来至佛所尽心供养。是大众中唯佛见之。其余众生悉无睹者。尔时大众咸有疑心。即白佛言。世尊。如是香华伎乐供养。将非舍利弗目揵连等力所作耶。佛言不也。此是波旬五百闻女供养之具。魔王不久当来至此。时诸婇女闻佛语已。心生欢喜即得不失菩提心定尔时婇女长跪合掌。而说偈言

  如来永断诸烦恼　　能施众生净法眼
  令众生度生死河　　是故至心赞叹礼
  一切人天赞供养　　具足无量无边智
  愿佛为我开方便　　令我得解于女身
  世尊修大空三昧　　了了通达第一谛
  具足法宝大商主　　愿坏魔力调我等

尔时婇女说偈赞已。即还魔所而说偈言

  王之自在非常我　　亦未离生老病死
  众苦烦恼绕王身　　常行痴闇处恶道
  若欲度生老死河　　当生信心诣如来
  我今欲还至佛所　　咨受甘露断诸味

尔时波旬生大恶心。欲以五系系诸婇女。佛神力故而不能系。时诸婇女即还佛所。波旬眼见不能遮止。复于空中作毗岚风。欲令诸女处处散灭不见于佛。以佛力故不能令坏。尔时魔王啼哭懊恼。以大音声告其妻子。我今丧失大神通力。有一毒树今出于世。为诸众生说于断灭。成就大幻有巧方便。魔诸眷属闻是语已。悉来聚集至魔王所。大王何故生大愁苦。既无退相又无火灾。欲界之中亦无怨敌。魔王言子。汝今不见。世有一人坐菩提树。坏四兵聚犹如猛火焚烧干草。世间所有一切智人。今已归属如此。即是我之怨敌。汝今不见五百婇女。舍我而去归依彼耶。汝等若不治彼释子。如此三千大千世界。不久当空。汝等各当牢自庄严。咸共尽力除彼释子。魔子言曰。善哉大王。我当庄严尽其神力。若我能除善哉快矣。如其不能复当归依。魔王复曰。恶人汝今云何发如是言。大王。瞿昙沙门往独一己坐菩提树犹难沮坏。况今眷属无量殷多而可除灭。魔王言。爱子若能杀彼瞿昙沙门。甚善甚善。如其不能自守土境。尔时四兵其数无量。满阎浮提高八十由延。放大恶风降注大雨。手拍须弥动四天下。出大恶声如大龙王夜叉诸鬼。振动一切河池泉源。一切龙鬼人天之等。咸皆怖畏心惊毛竖。时彼魔众于须弥山取一大石。欲令覆盖王舍大城迦兰陀林诸善男子。我于尔时即入破魔力势三昧。魔子尔时所雨刀槊箭石火毒。以我力故。皆悉变为忧钵罗华。钵头摩华。拘勿头华。分陀利华。堕王舍城。复雨种种微妙好香。变是恶声作如来声。法声僧声神通之声。波罗蜜声不退转声。菩萨之声破四魔声。涅槃音声。坏其恶风令无遗余。其土所有一切草木。悉皆变为微妙七宝。我身尔时高至初禅。三十二相八十种好。放大光明悉照三千大千世界。其中所有一切天人。诸龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽人非人等。地狱畜生饿鬼等类。皆见我身。无量诸天大设供养。华香幡盖伎乐之属。三恶众生称南无佛。即得解脱受人天身。尔时魔众见佛示现如是神力皆生信心。生信心已即说偈言

  我今归依于如来　　净身口意无上智
  能示魔界八正道　　施闇众生大光明
  具足大力无能胜　　等视一切如子想
  其心平等如虚空　　故我稽首大商主
  烦恼不污修慈悲　　获得吉祥示因果
  能施众生真解脱　　是故我今稽首礼
  大慈大悲天中天　　最胜无上之世尊
  说一切法如水月　　我今敬礼大幻师
  众生遇重烦恼病　　是故归依大医王
  三恶众生贫七财　　今当归依离诸漏
  唯愿哀愍听我忏　　于佛所生诸恶心
  佛是众生慈父母　　我今弃舍诸魔业
  我能请召诸众生　　为其发起菩提心
  愿为我说无上道　　具足何等得菩提
  我今献奉妙香华　　为众生故供养佛
  亲近善友善思惟　　至心听受如法住

尔时五百婇女及魔眷属。以妙香华幡盖伎乐。供养于我。此供养具。遍至无量恒河沙等诸佛世界。一时供养无量诸佛。一切魔众悉皆睹见一切诸佛形色修短方圆之相。等无有异。唯师子座世界树林。所居舍宅差别不同。魔众见已各心欢喜。坐于佛边至心听法。听受法己还波旬所。启白魔言。我等往至彼瞿昙所。尽其神力乃至不能令一毛动。大王当知。我今已属瞿昙沙门。尔时波旬心恶生嗔。即作是念。我当云何杀彼释子除灭此怨。尔时波旬及其眷属。心生忧恼。入于苦宅

    大方等大集经宝幢分中往古品第二

尔时魔众。复还我所而白我言。世尊。我欲大乘念于大乘。欲具神通大慈大悲。世尊。菩萨摩诃萨具足几法不近恶友。速得成就阿耨多罗三藐三菩提。善男子。菩萨摩诃萨具足四法不近恶友。速得成就阿耨多罗三藐三菩提。何等为四。一者若有菩萨不贪诸法不舍诸法。不受诸法不觉诸法。亦无有我及以我所想。行于布施不求果报。不生贪着不舍不取。亦无觉知我我所想。乃至般若亦复如是。二者若有菩萨不见众生寿命士夫。亦复不舍于众生界。不贪不取。亦无觉知我我所想。三者若有菩萨不见色声香味触法。不舍色声香味触法。不舍不取。亦无觉知我我所想。四者若有菩萨能深观察如是等法。于佛正智不生觉观。何以故。断一切行断一切智。名为佛智。无有无乘。无声无想无字。无有无量。无生无出无灭。无想无碍无障。无见寂静。无我无命无名。无明无闇无处无界。无根无翅无有思惟。无食无贪无净无垢。无尘无节无边无数。无行无受无业无宅。无取无作无可显示。无念念灭即是佛智。犹如虚空如空无觉不可宣说。无有染着无有觉知。善男子。菩萨具足如是等法。不亲恶友。速得成就阿耨多罗三藐三菩提。善男子。若有能求如是智慧。当知是人能观二法。所谓眼色乃至意法。复有二法生死涅槃。复有二法一生二有。复有二法一常二断。复有二法众生寿命。复有二法一此二彼。复有二法一内二外。诸善男子。若有欲求如是佛智。离是二法。观异法者。当知是人则不能得。善男子。譬如有人求火取水。求水取火。求食取石。求华取铁。求香取尸。求衣取木。求于涂香而取虚空。求佛智者。若离是二更观异法。亦复如是。是时宝坊大会之中。有一菩萨名曰地意。闻是语已白佛言。世尊。不可说义可觉知不。若不可觉。云何得名一切智耶。善男子。不可说智即一切智。善男子。我今问汝随汝意答。于意云何。我得如来一切智时。有所得不。地意菩萨即便思惟。我若说有即是常见如其说无即是断见。我等当远离如是二边说于中道。思惟是已。白佛言。世尊。如是义者亦有亦无。世尊。若不出灭无数无量。非明非闇即是佛智。电意菩萨言。世尊。若无去来即是佛智。善见菩萨言。世尊。无得无离无证无修。即是佛智。无尽意菩萨言。世尊。若法不为三世所摄。不堕三界。非是三结。三智三乘阴入界等。无有增减即是佛智。金刚意菩萨言。世尊。若不分别凡法圣法学无学法。声闻缘觉及以佛法。即是佛智。坚意菩萨言。世尊。如法无转即是佛智。宝手菩萨言。世尊。若观诸法生坏之相。观已通达知无得失。即是佛智。善觉意菩萨言。世尊。三界众生。从意观意亦不觉意。即是佛智。分别怨亲菩萨言。世尊。若有人能不乐烦恼。不厌烦恼。不爱不嗔。不舍不求。不施不念。即是佛智。莲华子菩萨言。世尊。不乐罪福得深法忍。不觉不知我及我所。若不觉知我我所者。即是佛智。月光童子菩萨言。世尊。若能观察一切诸法。犹如水月。亦不见法有增有减。即是佛智。无边意童子菩萨言。世尊。若于诸法不见明闇。于一切心不见生灭。即是佛智。弥勒菩萨言。世尊。若能观察四种梵行及不善行平等无二。即是佛智。无尽意菩萨言。世尊。若观三世六波罗蜜二相无差。即是佛智。文殊师利童子菩萨言。世尊。若于诸法心无贪嗔。亦观诸法甚深境界。亦不了知非不了知。亦不观法有增有减。不观智慧及以无明。即是佛智。尔时众中有一菩萨。名曰乐欲。语文殊师利言。善男子。如来世尊以何因缘。说如是等甚深之义。文殊师利言。善男子。为令众生远离邪见得正见故。得正见已不生染着无有悭吝。不近恶友正命自活。不着三结怜愍众生。不着三宝不诳一切。于诸众生不舍不着。不着财物不着三界。众生怖畏能为救护。能坏恶道开示正路。不着忍辱离一切想。灭一切垢除一切闇。不求果报。善男子。以是因缘求一切智。得是智已。于声字句不生觉观。佛语邪语佛行余行。佛法余法阴界诸入。功德庄严智慧庄严。十波罗蜜三解脱门。业之与果世智佛智。于如是法不生分别。是故如来说如是等甚深之义。乐欲菩萨言。善哉善哉。文殊师利。实如所言。甚深义者即是佛智。何以故。无所觉故。若无所觉故不可说。不可说者即是佛智。若有能知是不可说。当知是人即得佛智。佛言。善哉善哉。善男子。善能分别宣说佛智。何以故。不着诸法不生不灭。即是佛智。善男子。不着诸法。即不出边不破坏边。无明涅槃真无出边虚空涅槃。一切诸法一切众生不可说边。是虚空边无挂碍边。无有物边无有阴边。三行空边法阴业阴。果非果阴。聚阴无物。无物边虚空边。一切诸法不可说边。菩萨摩诃萨若能具足如是等边。即得佛智。说是佛智不可说时。一切魔众得无生法忍。舍于粗身获得细身。随心意身法化之身。复有二万八千众生。于诸法中得无生忍。九万二千菩萨得无量陀罗尼。一切众魔以妙香华伎乐供养。赞诵如来。作如是言。世尊。善知识者。即是一切善法根本。我今遇佛善知识故。得大利益。佛告善男子。汝当至心观于诸业。尔时世尊。即为众会说过去业。善男子。过去无量阿僧祇劫。劫名电持。时世众生寿命满足六万八千。世界名曰妙香光明。是中有佛。号香功德如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时彼世具足五滓。有转轮王名曰华目。王四天下。与诸眷属大臣人民至于佛所。以妙香华幡盖伎乐。供养于佛及比丘僧。敬意礼拜右绕三匝。以偈赞佛

  佛为人天所赞叹　　远离诸恶乐寂静
  具足七财破贫穷　　云何令众得深智
  修集三种解脱门　　已得离生老病死
  能度三恶道诸生　　云何令众过魔业

佛言大王。具足三法得甚深智。何等为三。一者至心缘念一切众生。二者修集大悲破众生苦。三者见一切法无有众生寿命士夫。不生分别。又有三法能过魔业。一者于诸众生不生恶心。二者修行施时不观福田及非福田。三者观一切法平等无二犹如虚空。不生不灭无行无物。无有相貌不可宣说。菩萨具足如是等法。得甚深智能过魔业。尔时圣王有一夫人。名曰善见。与八万四千诸婇女俱共供养佛。既供养已。即说偈言

  大千世界无胜者　　常乐寂静修子想
  善行远离诸尘垢　　云何令我离女身
  已得远离一切怨　　真实见生老病死
  唯愿为我演说道　　令我具足男子身
  离诸有得无上有　　能施欢喜增善法
  具足十力四无畏　　云何令我离女身
  摧灭四魔修四梵　　实语具足巧方便
  三十二相八十好　　云何令我离女身

佛言。善女人。有巧方便。得离女身能坏女业。乃至得阿耨多罗三藐三菩提。终不复受女人之身。除其誓愿巧方便者。所谓宝幢陀罗尼门。若有能修是陀罗尼。得离女身。净身口意。远离三障。若有闻是陀罗尼名。即离女身受男子身。得具足身微妙智慧。净身口意。乐于善行。具足多闻。远离恶业及受苦报。能灭五逆无间重罪。何以故。如是宝幢陀罗尼者。即是过去无量诸佛之所演说。为破恶业增长善法故。十方现在无量诸佛亦共说之。为破恶业增善法故。未来之世十方诸佛亦共说之。为破恶业增善法故。我今现在亦复宣说如是宝幢陀罗尼门。十方现在无量诸佛。悉共赞叹是陀罗尼。善女人。若刹利王所领国土。若有如是陀罗尼名。赞叹受持读诵书写。其王则为十方现在诸佛世尊护念赞叹。乃至阿迦尼吒诸天。亦复护念而赞叹之。是王行住坐卧之处。亦有无量天龙夜叉悉共护念。令其国土和安无诤。无有疫病。兵革不起。无恶风雨。不寒不热。谷米丰熟。诸恶鬼神及恶禽兽。悉怀喜心不生恶想。随是经典所住国土。其土若有恶星不祥恶想恶病。皆悉除灭。若刹利王兴兵攻伐。专念是经能伏强敌。令已得胜二王俱念。则二兵和同不相侵害。若有国土城邑村落人。若畜生有疫病者。当写是持安着幢头。其土不祥疾疫悉皆除灭。若有法师持戒精进。月十五日净自洗浴。以妙香华供养三宝。升师子座赞陀罗尼。是人能护所住国土。所有恶相寻即消灭。亦能调伏教化众生。得阿耨多罗三藐三菩提。善女人。若有人能读诵此经乃至一偈。如是之人终不复更受女人身。亦得不退菩提之心

尔时香功德佛。说是陀罗尼已。足指按地。即时大地六种震动。乃至十方亦复如是。其中所有天龙夜叉。以佛如来功德力故心生欢喜。亦见亦闻说陀罗尼。尔时如来。说宝幢陀罗尼曰

阇落翅　阇落翅目翅阇隶　阇罗阇怜泥阇罗跋赖帝　阇醯隶波罗　富娄沙　三摩奢阿摩弥沈　摩弥摩诃弥阇摩弥　婆罗弥婆婆毗　婆婆毗　婆婆毗　婆阇毗　婆罗诃　婆隶蓰　阇诃弥　婆罗诃　婆隶蓰　阿罗阇醯　阇斗目呿　婆沛罗　婆沛罗　私陀　跋赖坻　檀帝隶　檀帝罗　檀帝隶　修隶毗诃伽　旃陀毗　诃伽旃陀毗诃伽斫啾　树提沙毗呵伽　萨婆叉裔帝多凡　修罗毗诃迦　阇罗阇罗迦奢弥隶呵　奢弥隶呵　奢弥隶呵　奢弥隶呵　奢弥隶呵　奢弥隶呵　毗婆车陀羯摩　豆宁　豆宁　豆宁　温摩　渥毗婆车提　阇那吃栗多　阿讷婆陀隶　奴鸯崛隶　多崛隶　毗婆崛隶　究罗呵　因陀婆隶　婆诃那毗婆车陀羯婆　遮婆坻　遮婆坻　遮婆坻　呵暮阿陀舍尼　婆隶跋坻　婆师久摩羯　摩树坻　羯阇醯阇醯树坻腻迦毗罗娑毗罗娑毗罗娑毗罗娑　毗赖阇　毗赖阇　劫婆摩诃劫婆醯　利嘻隶嘻隶阿　那婆坻那婆坻昙摩檀那阇那阿婆罗弥隶絁阿罗军陀罗　波食毗婆坻那　帝隶婆凡羯摩叉裔婆罗咄颇婆　富娄沙多凡阿三摩　三摩三摩　毗坻　若多陀　阿竭陀莎诃

尔时世尊。即为大众说陀罗尼。五百婇女闻已即得男子之身。复有无量人天诸女。亦受男子身。及得不退菩提之心。永断一切决定女业。善男子。尔时夫人闻是持已。所将八万四千女人亦转女身得男子身。复有无量人天妇女。亦转女身得男子身。尔时圣王。以四天下委付千子。与无量人出家修道。尔时复有无量诸天。各作是念。转轮圣王以何因缘舍国出家。复相谓言。此界如来演说妙法。以法力故女转为男。有人出家能施袈裟。为诸白衣说人天乐。坏三恶苦灭一切有。摧诸魔业令魔受苦。魔既受苦不乐听法。大幻师者。谓香功德沙门是也。复有说言。当知沙门即是魔也。何以故。能转女身得男子身。时有大臣名曰善行。作如是言。我诸妇女悉为男子。汝等无量妻妾诸女。亦舍本形受男子身。剃除须发被着袈裟。咸皆归向属彼沙门。唯我一己独住不往。我等当舍是国土去。永不见闻是大恶人。尔时诸人闻是语已。唱言善哉。我今若欲不见不闻。远离恶沙门者。当入深山。尔时诸人既入山已。舍家修集婆罗门法。作如是言。无有解脱无善恶果。此世今有一沙门出。宣说断见。说于魔业欺诳众生。是大幻师。若人往见听其所说。亲近礼拜供养恭敬。心即狂乱无所晓知。剔除须发被着袈裟。舍家所有受乞食制。住于冢间受一食法。于生死中生厌离想。不乐受于五欲之乐。及诸香华璎珞伎乐。不乐宣说世间之事。具足如是诸不善法。说斯断见行于魔业。是诸众生之大怨仇。教化无量无边众生。令生断见。若不见闻得大利益。时华目比丘。闻无量人生大邪见。即作是念。我若不能调伏如是邪见众生。云何当得阿耨多罗三藐三菩提。时华目比丘。即便往请香功德佛。与无量比丘僧。周遍国土城邑聚落处处说法。所谓远离恶法修进善法。或说大乘。或缘觉乘及声闻乘。或沙门果。或比丘戒或优婆塞戒。或说三归。或复演说转女身法。或说宝幢陀罗尼门。或说十善。说是法时破除无量众生疑网生于善心。发于阿耨多罗三藐三菩提心。令无量众生来至佛所。唯除一人。善行大臣向彼华目。发恶誓愿。汝若未来成无上道。我当于汝成佛国土。而作恶魔。诣菩提树作大恐怖。若成佛已当坏汝法。若我于汝生信心者。汝便当与我受记莂。诸善男子。尔时比丘即我身是。夫人善见即弥勒是。善行大臣魔波旬是。波旬。汝于尔时发是誓愿。若于我所生信心者。当与受记。是故我今称汝本愿。与受阿耨多罗三藐三菩提记。波旬。汝于往昔香功德所。礼拜供养以是善根。我今与汝授菩提记。说是法时。五百婇女得男子身。无量众生。以三乘法。而得调伏

    大方等大集经宝幢分中魔调伏品第三

尔时世界百亿魔王。悉来集聚。至波旬所。波旬语诸魔王言。诸善男子。汝等知不。有释种子出现于世作大幻术。六年苦行趣菩提树。我于尔时。将领三万六千亿众。至于彼所然我尽力。乃至不能动金刚座。尔时瞿昙。于菩提树成就幻术。以幻力故。令此三千大千世界六种震动。使我眷属颠倒堕落如树拔根。当尔之时。释子成就无相幻术。以幻力故。十方智人悉皆归属。推求瞿昙所度众生。心相所在莫知其处。若有人能至心归依。尽力不能动其一毛。不可诳惑不可怖畏。我今婇女五百之众。及诸眷属悉复归向。而我不能遮止动转。汝等今者福德弘大多有幻力。若能有心见助佐者。然后我能坏彼释子断绝其命。亦能摧破诸归依者。灭沙门法增长魔业。尔时我当受无上乐。尔时有魔名曰亲近。即作是言。彼释子者。悉已成就无量功德。功德庄严智慧庄严。不住诸有悉能调伏一切众生。能坏种种众苦烦恼身净心净。汝等不能起恶加害。波旬言。我诸眷属为彼释子之所诳惑。汝等若不作方便者。如是世界不久当空。复有魔言。如来不住一切诸有心净身净。远离一切诸恶烦恼。于三界中而得解脱。一切有为不能系缚。是故名为无上寂静。如是寂静谁能毁害。波旬言。若欲界中所有众生。贪着五欲归释子者。是人则能破坏四魔。是等恶人若不治者。汝等云何能治欲界。复有魔言。彼释子者如幻如炎。不可宣说无有处所。无诸障碍。如是之人云何可害。波旬言。释子于此欲界之中。受食供养诳惑众生。我当云何而不治耶。复有魔言。我今所有神通之力。及我眷属神通之力。不及释子神通之力十六分中一。我当云何而能加害。波旬言。若彼瞿昙入城乞食。我当方便令其终日不得一粒。当放大石骂辱使嗔。我唯一己犹望能办。况于汝等多诸眷属。复有魔言。设使造作如是等事加彼释子。不能令彼生嗔喜心。若不嗔喜云何可害。波旬言。彼释子者有大智慧。以智力故嗔处不嗔喜处不喜。修集大慈大悲之心。于诸众生平等无二。是故于我不生嗔喜。复有魔言。若为三界所系缚者。我则能害。彼释子者。不为三界之所系缚。我何能害。波旬复言。汝等若能随我计者害彼不难。汝等悉作比丘比丘尼优婆塞优婆夷像。至诸国土城邑聚落。向诸国王大臣长者。作如是言。我等已属沙门瞿昙。沙门瞿昙实非沙门空言沙门。非婆罗门虚自称言是婆罗门。实非持戒现持戒相。真实破戒不异凡夫。汝等若信。善哉善哉。如其不信七日之后。当雨大石猛火利刀。作是言已。便当于空而降雨之。若作如是种种方便。瞿昙眷属将坏不久。时诸魔王咸言善哉。尔时诸魔各自庄严。庄严毕已。趣向鸯伽摩伽陀国。尔时波旬所有一切弊恶眷属。悉庄严已趣向雪山。时雪山中有一仙人。名曰光味。眷属五百悉具五通。波旬到已头面礼敬。作如是言。沙门瞿昙悉坏一切异见外道。处在大众宣说是言。一切众生中实无沙门及婆罗门。大德。若能与我俱至摩伽陀国。我则能坏沙门瞿昙。沙门瞿昙殊不能与大德论议捔试神力。沙门瞿昙若摧灭已。一切众生悉当恭敬供养于汝。尔时波旬作是语已。还来向于无量魔众广说上事。时有一魔复作是言。瞿昙沙门入王舍城。乞食之时我当于其中路。而作师子虎狼罗刹恶鬼等像。令彼见已生怖畏心。既生怖畏不能论议现神通力。复有魔言。我当于彼虚空之中。降雨大石坏破瞿昙。复有魔言。我当诈作瞿昙弟子。既为弟子当得亲近。得亲近已当断其命。复有魔言。我当现作长者之像设食请之。彼若受请我当害之。复有魔言。我当现作淫女之像。至诸王所云彼瞿昙与我交通。复有魔言。我当至彼瞿昙沙门。现坏其身而为七分。汝等当言。如此尸者瞿昙所杀。复有魔言。我当于彼虚空之中。大声唱言沙门瞿昙是大恶人。若有男女供养之者。命终当生阿鼻地狱。尔时世尊知魔心已。变此三千大千世界悉为金刚。以遮石雨火雨刀雨。悉令众生眼不睹见如是魔业。尔时世尊四大弟子。入王舍城次第乞食。时舍利弗从东门入。中路值遇五百魔子执持刀杖。语舍利弗。汝若歌舞善哉善哉。如其不者当断汝命。舍利弗言。善哉童子。我今当歌汝等当舞。诸魔子言。善哉大德。时舍利弗。即说偈言

  我今不求阴界入　　无量世中诳惑故
  若有求于如是法　　是人终不得解脱

时舍利弗说是偈已。复说陀罗尼句

婆呵罗(一)婆呵罗(二)婆罗婆呵啰(三)摩利至嘙罗呵(四)萨陀婆啰呵(五)阿摩[(口*皮)/女]呵啰(六)莎呵(七)

时舍利弗。说是陀罗尼已。五百魔子心得调伏。得调伏已礼拜忏悔。即作是言。大德我今当发阿耨多罗三藐三菩提心归依三宝。舍离一切魔之恶业。尔时大德大目犍连从南门入。中路亦值五百魔子手执刀杖。语目连言。汝若歌舞善哉善哉。如其不者当断汝命。目连答言。善哉童子。我今当歌汝等当舞。诸魔子言。善哉大德。尔时目连。即说偈言

  我今不求阴界入　　无量世中诳惑故
  若有求于如是法　　是人终不得解脱

时目犍连说是偈已。复说此陀罗尼句

阿[(口*皮)/女]摩(一)阿[(口*皮)/女]摩(二)摩啰拏(三)啰阇(四)阇呵奢(五)摩咃(六)奢摩咃(七)奢摩咃(八)伽伽那[(口*皮)/女]摩(九)莎呵(十)

时目犍连。说是陀罗尼已。五百魔子心得调伏。得调伏已礼拜忏悔。即作是言。大德。我今当发阿耨多罗三藐三菩提心归依三宝。舍离一切恶魔事业。尔时弥多罗尼子从西门入。中路亦值五百魔子执持刀杖。语富楼那。汝若歌舞善哉善哉。如其不者当断如命。富楼那言。善哉童子。我今当歌汝等当舞。诸魔子言。善哉大德。时富楼那。即说偈言

  我今不求阴入界　　无量世中诳惑故
  若有求于如是法　　是人终不得解脱

时富楼那说是偈已。复说此陀罗尼句

呿竭[(口*皮)/女](一)呿竭[(口*皮)/女](二)呿竭[(口*皮)/女](三)茂遮泞(四)茂遮泞(五)阿跋多尼(六)比跋多尼(七)莎呵(八)

时富楼那。说是陀罗尼已。五百魔子心得调伏。得调伏已礼拜忏悔。即作是言。大德。我今当发阿耨多罗三藐三菩提心归依三宝。舍离一切恶魔事业。时须菩提从北门入。中路亦值五百魔子执持刀杖。语须菩提。大德。汝若歌舞善哉善哉。如其不者当断汝命。须菩提言。善哉童子。我今当歌汝等当舞。诸魔子言。善哉大德。时须菩提。即说偈言

  我今不求阴入界　　无量世中诳惑故
  若有求于如是法　　是人终不得解脱

时须菩提说是偈已。复说此陀罗尼句

娑茂提(一)比茂睼(二)茂利蛇阇醯(三)思隶(四)思隶(五)思隶(六)婆思隶(七)婆思隶(八)啊[(口*皮)/女]思隶(九)复多拘置思隶(十)莎呵(十一)

时须菩提说是陀罗尼已。五百魔子心得调伏。得调伏已礼拜忏悔。即作是言。大德。我今当发阿耨多罗三藐三菩提心归依三宝。舍离一切恶魔事业。尔时世尊神通力故。令王舍城所有众生一切皆见百由旬地。城四门中各各皆有一大弟子。其城中出一大莲花。纵广满足二十五丈。琉璃为茎黄金为叶。金刚为须有无量叶。光明远照。众生皆见高出三丈。四天王处乃至阿迦腻吒天处。亦如是见高出三丈。时莲华中说如是偈。诸天世人随处皆闻

  此世界中一佛出　　悉能摧伏一切魔
  能转无上妙法轮　　调伏此间诸众生
  二足中尊能成就　　忧婆提舍拘律陀
  能破二种烦恼根　　佛欲来此调众生
  了知三世如掌果　　具足三戒所说净
  远离三垢愍一切　　佛欲来此调众生
  具足如意无所畏　　调伏四众说四果
  常乐说法真实义　　圣师子王为我来
  具足五力及五根　　成就功德无碍智
  无上世尊为众生　　修悲拔出三恶众
  调伏六根得上信　　远离六入修六念
  具足六通真实语　　世尊欲来调众生
  一切众生烦恼缚　　处闇不知解脱道
  常行魔路不知实　　贪着颠倒失智慧
  不知此彼及生死　　贪五欲故远离禅
  是故不能得解脱　　不能修道报昔善
  众生不知生老死　　是故不修三解脱
  远离一切施戒慧　　是故不出三恶道
  众生若离五欲乐　　亲近如来听正法
  至心受持一偈义　　是人解脱如先佛

又复偈音闻于色界十六住处

  若有修集清净法　　远离诤讼修禅定
  至心专念诸解脱　　无有散乱坏烦恼
  获得十三忍辱法　　远离恶触及乱心
  出过一切生老死　　修四无量诸禅定
  永断常见及断见　　过三恶道得正定
  深观无常无我乐　　获随法忍如先佛
  若欲舍乐如涕唾　　观一切空行无异
  净于法界及菩提　　于法无碍如虚空
  能坏四魔灭烦恼　　修集正道诸方便
  不畏邪见如师子　　当亲如来则获之

出如是等偈音声时。无量众生趣莲华所。尔时波旬耳闻是偈。又见王舍城中莲华。无量众生悉坐其下。次第乃至阿迦腻吒。亦复如是受大苦恼。告诸魔言。谛听谛听。瞿昙沙门作大幻术。汝等不能造作魔业。不久当失所居之处。汝等当雨刀石猛火。时有一魔语波旬言。瞿昙沙门。悉已成就无量功德具二庄严。所谓功德智慧。彼神力故。令我狂乱不能造作魔之事业。我今于彼实怀恐惧。复有一魔语波旬言。汝今愚痴行于邪道。无心之人若见瞿昙尚生信敬。况有心者。汝今若欲得大利益。应当至心归依宗敬。复有一魔语波旬言。波旬。汝今云何常乐恶行造作恶业。汝当远离恶魔之业。汝今不见如来世尊。趣王舍城欲施众生甘露味耶。汝来当共归依瞿昙。尔时无量魔众乘空而下至王舍城。或作王像或转轮王像成就七宝。或复示作自在天像。或作沙门梵志尼干。或作四天王像日月等像帝释梵像。或有坐立及以礼拜而赞叹者。或有周遍绕王舍城。或有示现上其城上。或有青色白衣白璎珞白幡白盖。或有黄色赤衣赤璎赤幡赤盖。或有白色种种色衣种种璎珞黄幡黄盖。或有赤色青衣青璎青幡青盖。或七宝色七宝衣服七宝璎珞七宝幡盖。或琉璃色或颇梨色。种种色衣种种璎珞。种种幡盖。或有向佛散种种华烧香礼拜。或有歌颂赞叹起舞。波旬见已举声啼哭。即作是念。我今丧失所有福报。一切魔众悉皆归属瞿昙沙门。尔时波旬语梵天言。我虽失福无有伴党。犹故能坏瞿昙沙门。我今当示最后势力。我今能拔如是莲华。尔时波旬则趣莲华。虽复目睹捉不能得。如世人言我能捉电。电虽可见而不能捉。莲华亦尔。魔虽得见而不能捉。是时波旬心生懊恼。如是莲华捉之尚难云何可拔。复作是念。我今当出无量恶声令诸四众闻已怖畏。当舍瞿昙迸散而去。波旬尔时即出大声。一切四众都无闻者。唯魔自闻。闻已复生大怖畏心。尔时波旬怖畏战栗。两手拍地而不能着。犹如拍空。复欲取杖以打四众。亦不能见。倍生怖畏举身战栗。犹如猛风吹动树叶。复作是念。我今永失一切功德一切神力。不如速还本所住处。若不还者必死不疑。于是欲去莫知道径。复作是念。我今住此瞿昙沙门多将眷属今至不久。如其到者必见屠戮。我今正欲沉身此地。复恐此界众生见之。是时波旬不能上下四方遁走。即见己身被五系缚。见已涕泣愁忧苦恼。时有一魔名曰圣道。作转轮王像。向彼波旬而说偈言

  汝以何缘出恶声　　啼哭愁忧受苦恼
  如来今将趣莲华　　能坏众生种种苦
  汝等若欲受安乐　　当至心依无上尊
  汝若不乐五系缚　　应受我语归世尊

尔时波旬闻是偈已。即作是念为我得脱当诈归依非实心也。即向如来所住方面。合掌说偈

  我今归依世中尊　　能坏众生诸苦恼
  亦复忏悔一切恶　　于佛眷属更不造

时魔波旬说是偈时。于五系缚寻时解脱。得解脱已欲趣己界。复还被缚第二第三乃至第七。尔时波旬既不得去。至心听法

大方等大集经卷第十九

阇路翅(一)阇路迦慕翅(二)阇梨(三)阇罗阇梨尼(四)阇罗[(口*皮)/女]赖坻(五)阇唏隶(六)[(口*皮)/女]啰富楼沙勒叉拏(七)娑摩留呵蛇(八)阿摩咩(九)[(口*皮)/女]摩咩(十)[(口*皮)/女][(口*皮)/女]咩(十一)摩呵咩(十二)阇摩屣(十三)阇呵咩(十四)呿[(口*皮)/女]啰咩(十五)[(口*皮)/女]啰鞞(十六)[(口*皮)/女][(口*皮)/女]鞞(十七)[(口*皮)/女]呵脾(十八)登伽脾(十九)[(口*皮)/女]阇脾(廿)[(口*皮)/女]呵啰[(口*皮)/女]离屣(廿一)阇呵咩(廿二)呿[(口*皮)/女]啰脾(廿三)阿罗阇唏梨(廿四)禅[豆*婁]梨(廿五)禅[豆*婁]罗茂[口*仚](廿六)[(口*皮)/女]呵啰(廿七)[(口*皮)/女]呵啰(廿八)[(口*皮)/女]呵啰(廿九)婆呵啰思陀婆啰极(卅)弹帝罗(卅一)弹帝罗(卅二)修利蛇比呵呿(卅三)旃陀罗比呵呿(卅四)斫啾树帝沙比呵呿(卅五)萨[(口*皮)/女]叉蛇唎埵(卅六)修啰比呵呿(卅七)阇呿伽(卅八)阇呿伽(卅九)阇呿伽(四十)修呿伽(四十一)比呵摩(四十二)阿勿呵(四十三)阿勿呵(四十四)阿勿呵呵(四十五)阿勿呵(四十六)阿勿呿(四十七)阿勿呿(四十八)阿勿呿(四十九)阿勿呿(五十)阿勿呿(五十一)勿呿(五十二)勿呿勿呿(五十三)鞞[(口*皮)/女]车陀羯摩(五十四)[豆*婁]泞(五十五)[豆*婁]泞(五十六)[豆*婁]泞(五十七)[豆*婁]泞(五十八)郁[?*皮]陀鞞[(口*皮)/女]车陀(五十九)蘘那吃多(六十)阿[少/(兔-、)][?*皮]陀(六十一)鸯究隶(六十二)朋究隶(六十三)比遮究隶(六十四)究罗呵(六十五)因陀罗波利[(口*皮)/女]呵[(口*皮)/女](六十六)鞞[(口*皮)/女]车陀竭婆(六十七)遮[(口*皮)/女]赖坻(六十八)遮婆赖坻(六十九)遮[(口*皮)/女]赖坻(七十)遮婆赖坻(七十一)阿暮呵陀舍奴波利[跳-兆+犬]多(七十二)[(口*皮)/女]沙呿摩(七十三)羯摩树喻极(七十四)呿伽阇唏(七十五)阇呵树极(七十六)腻呿(七十七)毗啰娑(七十八)毗啰娑(七十九)毗啰娑(八十)毗啰娑(八十一)毗啰娑(八十二)毗啰娑(八十三)[(口*皮)/女]阇摩[?*皮]伽啰摩吃波(八十四)摩诃吃波(八十五)唏隶(八十六)唏利隶(八十七)阿拏[(口*皮)/女]赖坻(八十八)娑摩蛇腻[口*仚](八十九)陀摩(九十)陀那(九十一)阿波啰勿[糸*他](九十二)呵罗军荼罗婆呿(九十三)比[跳-兆+犬]多蛇(九十四)唎婆畔羯摩叉蛇(九十五)波啰[豆*婁]婆[(口*皮)/女]富留沙埵(九十六)阿娑摩娑摩蛇(九十七)比提蘘(九十八)多咃伽多(九十九)莎呵(百)大方等大集经卷第二十

        北凉天竺三藏昙无谶译

    宝幢分第九三昧神足品第四

是时如来四大弟子与诸魔子。游王舍城歌舞颂偈。尔时大地六返震动。无量天人悲感啼泣。苦哉苦哉。今者如来犹在于世。而四弟子为诸魔众之所戏弄。即共和集往至佛所而作是言。世尊。唯愿如来放舍舍心。何以故。一切诸魔欲坏佛法。佛言。我今当入王舍大城。教化众生欲破坏魔业。示大神通施作佛事。尔时佛欲入王舍城。时诸天众悲[口*睪]。向佛而作是言。今佛入城实非时也。何以故。无量恶鬼弥满虚空。无量魔众持刀大石。若佛入城如来法灯将灭不久。尔时如来默然不许。复有天言。世尊。王舍城中。五百魔子执持刀戟欲害如来。复有一天啼泣而言。今者释种不久当坏。复有天言。无上法船今当散灭。三界众生谁当济渡令至彼岸。复有天言。一切众生常为烦恼之所缠绕。无上大师如其灭者。谁当令彼得解脱耶。复有天言。世尊。不见空中无量魔众。欲雨刀剑大石猛火。唯愿如来。愍众生故且莫入城。复有天言。世尊。王舍城中有二万魔。各各示作婆罗门像。执持刀剑欲害如来。复有二万持槊待佛。复有二万执持弓箭。复有二万持大炬火。唯愿如来。受我等语勿复入城。如来尔时默然不许。尔时世尊入王舍城门。其守城天啼泣向佛作如是言。唯愿如来勿复入城。何以故。今此城中恶众弥满。若使如来于此灭者。我当云何见诸天众。魔众今者欲雨刀剑猛火大石。如来若灭众生闇行灭大法炬坏大法山。生老病死欢喜受乐。佛于尔时。虽闻是语亦不许可。时天复言。世尊。若不惜身命必欲放舍有六大城何必于此。如来若于此间灭者。则令我于无量世中得大恶名。尔时复有无量诸天俱至佛所。作如是言。世尊。我已曾见无量诸佛说法教化无量众生。实未曾见如是魔众。世间众生常为无量诸恶烦恼之所围绕。值遇良医通达无量医方方便。如来何故。放舍大慈大悲之心。复有天言。如来往昔无量劫中为诸众生修集苦行。今者云何欲舍众生放弃身命。唯愿怜愍演说正法。调伏一切闇昧众生。愿施众生光明。迷行之人示以正路。永断一切三恶道苦。唯愿久住莫舍身命。尔时复有净居诸天。告诸天言。且勿[口*睪]哭放舍愁恼。如来具足十力无畏。今欲摧灭一切魔众。假使无量无边魔众。乃至不能动佛一毛。尔时梵王释提桓因。往至佛所白佛言。世尊。一切魔众今者定欲毁害如来。唯愿勿往。如来当灭一切众生无明闇行。世尊往昔请诸众生。许以甘露斯事未果。云何便欲放舍身命。莫猗往昔菩提树下坏一魔已轻蔑余者。如来若入王舍城中。即便灭没无复疑也

尔时世尊出大梵音声。遍三千大千世界已。而作是言。谛听谛听。假使诸魔悉皆遍满十方世界。尽其力势乃至不能动我一毛。我昔已请无量众生许以甘露。今当演说第一义谛。增长善法说于正道以称我愿。我于往昔无量世中。为诸众生多受苦恼。放舍一切金银琉璃颇梨宝货国城妻子衣服饮食及以身命。以妙香华幡盖灯明供养诸佛。受持净戒修行忍辱。谁能以恶加于我身。我于众生常修慈悲。谁能令我而灭没耶。如我先已摧魔眷属。当知今者亦能破坏。汝等于此勿怀怖畏。时无量天闻是语已。心生喜乐各各而言。南无大士如来世尊。坏大魔众破诸烦恼。永断习气摧憍慢山。拔生死树。灭死日月除无明闇。劝化一切邪见众生。焦涸四流然大法炬。示菩提道击大法鼓。施诸众生善法之乐。复令觉悟四真谛相。度生死海入无畏处。说是语已。以妙香华幡盖伎乐供养于佛。复以种种微妙好华散王舍城。所谓曼陀罗华摩诃曼陀罗华。波楼沙华摩诃波楼沙华。迦迦罗华摩诃迦迦罗华。曼殊沙华摩诃曼殊沙华。瞻婆罗华摩诃瞻婆罗华。欢喜华大欢喜华。爱乐华大爱乐华。波利质多华。俱毗遮罗华。忧婆钵罗华。俱物头华。波头摩华。分陀利华。如是等华。庄严遍覆如来行处。于路二边七宝行树高一多罗树。间有八味清泉。上虚空中多有诸天。手持上妙七宝幡盖。雨诸杂华金银颇梨琉璃等宝。牛头栴檀及白栴檀。坚[革*卬]沉水种种华香。遍雨如来所行之处。复有种种微妙伎乐。一切人民悉共严治王舍城外如来行处。诸魔眷属庄严城内。时佛世尊入王舍城。尔时心游首楞严定。示现微妙八十种好。若事象者即现象像。事师子者现师子像。有事牛者即现牛像。事命命鸟现命命像。有事兔者即现兔像。有事鱼龙龟鳖。梵天自在建陀八臂。帝释阿修罗迦楼罗虎狼猪鹿。水火风神。日月星宿。国王大臣。男女大小。沙门婆罗门。四王夜叉。菩萨如来。各随所事而得见之见已皆称南无南无无上世尊。合掌恭敬礼拜供养。尔时雪山光味仙人。与其弟子在西门下。侧立待佛。光味仙人睹见佛身。是仙人像。为无量众生之所供养。即作是言。如是人者真是大仙。堪受世间人天供养。何以故。福德相故。我云何知彼大我大。我今当问生姓经书出家久近。光味仙人即趣佛所。告其弟子摩纳。彼仙人者德相成就。了了可知聪明睿哲能解深义汝等应当至心生信。如我所见相书所载。是人必能说无上道。彼定能令我度生死。五百弟子同声叹言。善哉善哉如和上言。尔时光味与五百弟子。前后围绕即至佛所。作如是言。汝是谁耶。佛言。是婆罗门。光味复言。姓何等耶。答言。我姓瞿昙。又问。受何戒耶。答言。吾受三戒。又问。修集何行。答言。吾修三空行。又问。出家已来为久近乎。答言。具大智时。又问。汝颇读诵星宿书不。答言。汝今读诵得何利益。光味复言。我以此法教诸众生。受我语者多献供养。佛言。汝知此书。颇能得过生老死不。光味复问。瞿昙。生老病死云何可断。佛言。汝若不能断生老死何用读诵如是星书。光味复言。瞿昙。汝若不知星宿书者。身上何故有星行处。如我知者。定谓瞿昙通达如是星宿彼岸。佛言。云何名星宿道。光味答言。谓二十八宿日月随行。一切众生日月年岁皆悉系属。瞿昙。一切星宿迹有四分

瞿昙。东方七宿。谓角亢氐房心尾箕。若人生日。属角星者。口阔四指额广亦尔。其身右边多生黑子。上皆有毛。当知是人多财富贵。广额似像。聪明多智眷属炽盛。其项短促。脚两指长。左有刀创。多有妻子。恶性轻躁。寻命八十。四十年时一受衰苦。长子不寿。心乐法事。衰患在火。瞿昙。属角星者有如是相

属亢星者。心乐法事。受性多巧。聪明富贵。多怀惭愧。怨不能害。乐欲出家。受性柔软。轻躁确尽无所隐藏。寿六十年。三十五时身遇笃病。绕颈四指。当有疮[病-丙+槃]。不宜子息。瞿昙。属亢星者有如是相

属氐星者。生人受身勇健。臣富豪贵。寿二十五。左有黑子。于父母所悔(丹本云恒)生恶心。敬出家人。于己眷属不能增长。瞿昙。属氐星者有如是相

属房星人受性弊恶。愚騃无智巨富豪贵。右有黑子。寿三十五当被兵死。宜于兄弟。瞿昙。属房星人有如是相。属心星人富贵多财。愚痴风病。寿三十五头有疮[病-丙+槃]。有大名声。毒不能中。妻子不乐。瞿昙。属心星人有如是相。属尾星人具诸相好。雄壮富贵得大自在。两乳轮相。有大名声。身诸光明胜于日月。聪明大智无能胜者。贪乐出家能调烦恼。增长眷属多有惭愧。寿命百年。四十五时。暂一受苦。胸有德相众生乐见。不宜父母。瞿昙。属尾星人有如是相

属箕星人乐喜诤讼。多犯禁戒。受性弊恶人不喜见。贪欲炽盛。寿六十年。贫穷困苦。常乐游行。牙齿疏小。胸臆确瘦。瞿昙。属东方宿有如是相

属井星人多饶财宝人所恭敬。心乐于法。脐有疮[病-丙+槃]。寿八十年。慈孝供养父母师长。先父母丧。心无悭吝多有惭愧。衰祸在水。瞿昙。属井星者有如是相

属鬼星人悭吝短寿。脐下四指当有黑子。不宜父母。喜乐诤讼。瞿昙。属鬼星者有如是相。属柳星者富贵持戒。慕乐法事。寿七十五。增长眷属。死已生天。腰有赤子。敬受法者人所信伏。瞿昙。属柳星者有如是相

属七星者乐为劫贼。盗物为业。奸伪谄曲。薄福短寿。举动粗犷。愚痴狂骇必被兵死。瞿昙。七星生者有如是相。属张星者。寿命八十。善于音乐。首发稀少。衰二十七及三十三。富贵勇健有大名称。聪明无吝。乐法惭愧。不宜父母及以兄弟。顶(丹本云项)有疮[病-丙+槃]。过三十五乃有子息。阴有黑子。髀有黄子。瞿昙。属张星者有如是相

属翼星人善知算数。悭吝恶性钝根邪见。右有黑子。寿命三十三。绝无子息。瞿昙。属翼星者有如是相

属轸星人巨富豪贵。多饶眷属奴婢仆使。聪明勇健。乐法爱法。敬受法者。寿命百年。死已生天。瞿昙。属南方星者有如是相

属奎星者。其人两颊当有黑子。持戒乐法。敬受法者。富贵乐施。身有火疮。寿五十年。瞿昙。属奎星者有如是相。属娄星者寿命短促。贫穷困苦。乐见毁戒。其心悭吝。膝下疮[病-丙+槃]。寿三十年不宜于兄。瞿昙。属娄星者有如是相。属胃星者不宜父母。多失财宝。田业舍宅。膝有黑子。过二十二得大富贵。不悭乐施。瞿昙。属胃星者有如是相。属昴星者乐于正法。辩口利辞。聪明富贵。多有名称。护持禁戒。人所敬信。死已生天。膝有青子。寿五十年。瞿昙。属昴星者有如是相。属毕星者人所信伏。恶性喜斗。于己姊妹生于贪心。富贵多怨。常患胸痛。不宜钱财。左有黑子。寿七十年。瞿昙。属毕星者有如是相

属觜星者富贵乐施。惭愧无贪。无有病苦。众生乐见。死已生天。衰在七十。寿满八十。瞿昙。属觜星者有如是相。属参星者受性弊恶。多造恶业。作守狱卒。贪欲偏多。聪明贫苦。寿六十五。多有黑子。瞿昙。属西方星有如是相。属斗星者受性愚痴。贪不知。贫穷恶性。寿命短促。当病食死。黑色羸瘦。瞿昙。属斗星者有如是相

属牛星者性痴贫穷。乐为偷窃。心多嫉妒。寿七十年。无有妻子。瞿昙。属牛星者有如是相。属女星者持戒乐施。其人足下多有黑子。增长眷属。寿八十年。有大名声。无有病痛。宜于父母及以兄弟。瞿昙。属女星者有如是相。属虚星者福德富贵。眷属爱乐。悭吝不施。寿六十五。其人足下当有黑子。瞿昙。属虚星者有如是相

属危星者身无病苦。聪明持戒。通达世事。富贵多财。寿八十年。宜诸眷属。瞿昙。属危星者有如是相

属室星者受性弊恶。多犯禁戒。为人富贵。寿命百年。死堕恶道。不宜父母及以兄弟。瞿昙。属室生者有如是相。属壁星者雄猛多力。尊荣富贵。有大名称。眷属增长。不宜父母。寿命千年。名闻无量。乐法出家。敬受法者。聪明多智。善解世事。瞿昙。属北方星有如是相。若有通达如是相者。到于彼岸得大智慧

佛言。众生闇行。着于颠倒烦恼系缚。随逐如是星宿书籍。仙人星宿虽好。亦复生于牛马狗猪。亦有同属一星生者。而有贫贱富贵参差。是故我知是不定法。仙人汝虽得禅。我是一切大智之人。何故不问解脱因缘乃问是事。光味又言。汝今现身如世无异。而尊其事与仙无别。我今真实不知汝是天耶仙耶。龙耶鬼耶。声如梵音色如古仙。我从昔来未曾见闻如是色相如是事业。是故今问。汝为是谁系属于谁。姓氏何等。宣说何事。唯愿广说我当听受。尔时世尊即说偈言

  若有学习着相书　　是人不能知此彼
  若有烦恼所缚者　　不得解脱常受苦
  我今具足六神通　　是故名大婆罗门
  六波罗蜜是我性　　以六和敬调诸根
  我以受持三种戒　　行空无相三脱门
  我往初发菩提心　　尔时得名大出家
  我都不觉一法相　　是故不说星宿书
  法无众生无寿命　　是故演说无我净
  已度三受三行岸　　断诸根故无有相
  我已真实知诸法　　是故获得大寂静
  若无挂碍如虚空　　虽行菩提不学法
  修集禁戒大忍辱　　即得无想大智慧
  若不觉业求果报　　如法不转得菩提
  心不贪着一切阴　　亦复不观于此彼
  又不觉知菩提道　　是能速得菩提道
  无有相貌无想念　　于一切法无觉观
  亦不贪着于诸法　　即能获得一切觉
  若有修集净梵行　　是人得名婆罗门
  观察诸法如虚空　　是人即得名大觉

于是世尊说是偈已。光味仙人及诸眷属。一切皆见如来本身。见本身已。往善所追。即各获得宝幢三昧。得是三昧。能遍观察一切三昧。故名为幢。于诸三昧而得自在。游入一切三昧境界。是故名为宝幢三昧。尔时光味合掌恭敬。持微妙华满其手掬。说偈赞佛

  如来成就无量德　　犹如大海水弥满
  功德光明甚微妙　　悉照三千大千界
  勇猛精进大智慧　　出胜一切诸众生
  具足大慈大悲心　　是故我礼无上尊
  如来永断诸烦恼　　故我稽首大仙师
  清净金色戒光明　　我今礼敬于佛日
  能干众生诸烦恼　　能说真实菩提行
  能坏一切烦恼山　　转于无上正法轮
  今我修于菩提道　　为得无量大智慧
  如来具足一切相　　愿记我等菩提时
  我当云何断烦恼　　度脱一切苦众生
  演于真实正真道　　平等犹如十方佛
  众生三世造恶业　　我当云何令其断
  若我身口意善业　　愿此因缘断彼结
  永断一切烦恼病　　身受妙乐如先佛
  令众妙色诸根具　　远离诸恶修善法
  断除众生诸邪见　　修习具足于正见
  得识宿命乐善行　　度生死河至彼岸
  六波罗蜜得具足　　知佛深法常住世
  乐降无上大法雨　　令诸众生离贫渴
  若我身口意恶业　　今于佛前悉忏悔
  我今所有福德力　　施与众生早成佛
  我请一切诸众生　　劝之令种菩提子
  我为众生受苦时　　愿不生悔及退转
  净于世界及众生　　得无碍智净法界
  若我真实得佛道　　愿此所散成华盖

尔时光味即以华散。是时三千大千世界六种震动。无量众生生敬喜心。有诸众生奉事象者。见佛是象作如是言。云何此象有大福德。令是仙人敬意供养。乃至若有敬事佛者。见彼仙人敬心供养。见已生信礼拜赞叹。尔时世尊出首楞严定。从定起已一切众生悉见佛身。见已心生供养欢喜。各任己力而作供养。尔时世尊告光味言。善男子。一切诸天见汝决定发阿耨多罗三藐三菩提心欢喜踊跃故。令是地六种震动。善男子。汝当成就无量智慧。然后获得无上佛道。乃当复于无量世界然大法炬。善男子。汝于来世过三阿僧祇劫。当于此土北方世界名曰香华。其界庄严如阿弥陀。当于彼中得成为佛名光功德如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。于无量世宣说大乘。终不说于声闻缘觉。尔时大众耳闻目见光味仙人得受记莂。悉共欢喜供养恭敬。五百弟子。无量众生。发阿耨多罗三藐三菩提心。其意坚固无有退转

    大方等大集经宝幢分中相品第五

尔时佛知诸魔心已即入三昧。三昧力故令王舍城有十二门。一一门中有一如来。尔时诸魔见十二佛。自现其身为五通像。乃至示现梵天王像。以妙香华幡盖伎乐供养于佛。佛入城时足指案地。令此三千大千世界六种震动。其中天人阿修罗等。帝释梵天及四天王一切众生。悉皆得见十方世界十方众生。皆悉来集王舍大城。赍持香华供养于佛。佛神力故。令香华中说如是偈

  若欲永断三恶道　　应当发起菩提心
  若于生死独觉者　　是能度脱诸众生
  若欲离于恶匆务　　应当修集于正道
  若有值遇诸如来　　是人即得受道记
  如来大士利众生　　今来入此王舍城
  欲摧一切诸魔众　　欲转无上正法轮
  佛为五滓诸众生　　宣说三乘首楞严
  如来今欲大授记　　欲听实义应往彼

是偈音声周遍而闻。迦兰陀竹林精舍有诸菩萨阿罗汉等。悉往集会王舍大城中。乃至十方无量世界净土秽土有佛之处及无佛处。一切众生悉来聚集。尔时世尊入佛庄严璎珞三昧。入三昧已。令此娑婆世界清净庄严。犹如未来遍见如来所有国土。尔时世尊光明净妙。众生乐见。十方无量微尘世界净秽等土有无佛处一切众生亦复如是。乐见如来净妙光明。亦复乐闻如来音声。尔时十方一一方面。无量佛土无量菩萨。悉来至此娑婆世界王舍大城。尔时此界具足多有无量菩萨。如是菩萨悉共供养如来世尊。或有菩萨于娑婆世界雨诸杂香以供佛养。或有菩萨于此世界雨真珠宝以供养佛。或有菩萨于此世界雨妙璎珞。或雨金银琉琉颇梨车磲马瑙。或雨栴檀沉水诸香。或复有雨牛头栴檀。或雨诸华须曼那华以供养佛。或有菩萨以真实法赞叹于佛。或有现作天帝释像。梵天王像。四天王像。魔王形像。自在天像。违陀天像。八臂天像。转轮王像。宝像山像。树林等像。大臣长者男女师宗牛羊象马水牛等像。作如是像。趣王舍城大莲华所。以手触华华即为动。是时一切魔众男女大小及诸眷属。皆悉动摇生大恐怖即作是言。何因缘故我之宫殿如是倾动。我等所尊将不退没。失我天耶。我等复不欲灭堕乎。我往常见如是世界有五滓浊。今者何缘寂然清净。尔时诸魔悉见十方清净菩萨皆来集会娑婆世界。见是事已复作是言。以佛世尊光明严丽众生乐见之因缘故。乃至不见己之眷属有一人在。复作是念。我今何故不往佛所亲近供养。时魔波旬即至佛所。合掌恭敬而说偈言

  我今归依于如来　　已得欢喜至心乐
  愿见放舍还本处　　还已乃当听正法

尔时世尊说偈答言

  我不劝汝以去来　　诸法性相亦如是
  汝今若有大神通　　随意自在无遮者

是时波旬复说偈言

  如佛世尊真实语　　今者实无遮我者
  我适欲还本处时　　寻即见身被五缚

佛言。我已永断一切系缚。欲解一切众生系缚。我亦不念众生诸恶。是故得名解脱系缚。尔时世尊见十方众生悉来集会即说偈言

  一切大众至心听　　远离一切疑网心
  我今所说不思议　　应当谛观业因缘
  无上世尊甚难有　　法僧二宝亦复然
  人身难得信亦尔　　施心福田亦复难
  无上世尊难得见　　见已闻法亦复难
  难得远离于八难　　得如法忍亦复难
  其心难得而调伏　　修空三昧亦复难
  修善思惟如法住　　如是二事亦复难
  一切烦恼难远离　　获得菩提亦复难
  我今说趣菩提事　　犹如世人说变化
  我之所说远离爱　　能坏闇冥修善法
  所示无上正真道　　应当至心勤修行
  若欲远离三恶垢　　及余一切诸魔业
  不为烦恼之所害　　应当从佛听正法
  若欲具足三种戒　　应学具足三脱门
  即能破坏三界结　　亦能过于三恶道
  若不断绝三宝性　　为于正法丧身命
  即能具足无量通　　是人名为如法住
  若欲三世无觉观　　亦复不着三世法
  是人能过于三界　　亦复获得如法忍
  一切凡夫无明覆　　常为四倒所围绕
  于无法中作法想　　于无物中作物想
  以是因缘名颠倒　　如是之人行邪道
  若有说言眼见色　　乃至意能知诸法
  如是之人行颠倒　　流转生死无量劫
  若有修集四禅定　　是则名为世间慧
  能度一切诸颠倒　　亦于生死得解脱
  若能调伏诸众生　　亦复远离于四流
  如是之人干生死　　亦复能到于彼岸
  若能具足四如意　　是名菩萨无所畏
  亦能永断于生死　　令诸众生脱恐怖
  若能了了知五阴　　是人能到无漏边
  了知不生亦不灭　　能令众生到彼岸
  若能于佛世尊前　　忏悔发露一切罪
  是人远离于邪见　　能到生死之彼岸
  若观生死多受苦　　行业因缘迳三恶
  以近恶友因缘故　　造作无量之恶业
  若能远离恶知识　　亦能远离诸邪见
  是人能观生死过　　亦能咨问第一义
  若有能观第一空　　是人能服甘露味
  我常说于第一义　　至心听者无有相
  我说六入真实空　　无有造作无受者
  众生颠倒谓有相　　法性真实无所有
  若有众生六受爱　　是能生于六触因
  如是六触真实空　　一切诸法亦复然
  如一法性诸法尔　　如一切法一法然
  一切诸法无生灭　　亦无相貌无有物
  我所宣说无胜道　　一切诸法如一法
  若见诸法无性相　　是人获得真实义
  若有修行十三忍　　即能度于生死岸
  真知法性众生性　　得无上道如先佛

于是世尊说是偈时。十方如恒河沙等五滓世界一切众生悉得闻之。一一世界无量众生。闻已即得不退转心。或有获得陀罗尼者。或复有得三昧定者。或有成就得诸忍者。此佛世界无量众生闻已亦得不退转心。教化众生于三乘中。尔时光味菩萨于莲华边造七宝梯具种种华。合掌恭敬而白佛言。如来佛日大慈悲光。无量众生多受苦恼。唯愿降注无上法雨。除灭众生烦恼疾病。有诸众生任为法器。堪受如来无上法味。愿说八道净于法眼。上升莲华摧伏众魔。十方世界无量菩萨悉为证人。了了能见诸法空寂。无有相貌犹如虚空。知法无我。唯愿如来忆念往昔初发菩提心时所立誓愿。如来尔时自言。我若具足十力四无所畏。当施众生甘露法味。悉令得度生死大海。今已果之。唯愿演说清净之法。度诸众生于生死海。化无量人于菩提道。尔时世尊即蹬宝梯坐莲华上。遍观十方告波旬言。波旬。汝亦当生欢乐之心。何以故。以汝因缘有是大集。亦因于汝令我说法。说法因缘断诸生死度于四流。令诸众生获得正道得虚空相。如是等事皆因于汝。汝当请我。我当说法。魔波旬言。瞿昙。若无嗔心憍慢嫉妒。何故恼我而宣说法。若有嗔恚憍慢嫉妒。云何自言我得解脱。佛言波旬。我住母胎经历十月。汝于尔时欲来杀我。我心于汝亦无嗔恚。我初生时地六种动。汝于尔时复降石雨。我饮乳时汝持毒药置之乳中。我昔初乘香象之时。汝动此地令六种震欲令我堕。我在林野修世禅时。汝将婇女欲来乱我。我乞食时汝以臭豆持来施我。我时虽受竟不食之。我初出城汝自变身为黑毒蛇。又作恶贼围城四边。我行虚空复放风雨。我下马时雨大猛火。我苦行时复作恶声故令五人恐怖舍我。我身羸瘦复放冷风。及其洗浴放大暴水。我度河已复欲危害。化作无量师子恶兽。受牧牛女所奉乳糜。汝复持毒置之而去。我趣菩提道树之时。复于中路降金刚雨。我坐树下金刚座上。复遣四女来娆乱我。汝虽如是欲来害我。然我于汝都无恶心。如是等事终不能令我心扰乱。复将无量百千万众。造作种种无量恶事。欲令我身不得菩提。我既获得阿耨多罗三藐三菩提已。复来请我令舍寿命。因于汝欲令我于彼娑罗大村乞食不得。又因汝故令阿阇世放大醉象欲令害我。又因汝故提婆达多放下大石。又因汝故令我受彼婆罗门请。三月之中食瞰马麦。又因汝故令我为彼孙陀利女之所诈谤。又因汝故尸利鞠多火坑毒食以请于我。汝于尔时作如是等无量恶事不能害我。今复聚合如是魔众欲来害我。然我于汝都无嗔心。我今当度无量亿魔。我为众生常勤修集慈悲喜舍。汝若不信十方诸佛诸大菩萨可为明证。唯为汝故使我于此恶世之中施作佛事。汝虽于我作无量恶。然我犹故随逐于汝。我今实无嗔妒憍慢。我于汝所修集慈心。汝于我所生大恶心。善哉波旬。应离恶心启请于我说无上法。我欲与汝受菩提记。既受记已当广为汝宣说法要。汝闻法已。当得远离一切恶业。我常思念种种方便令汝解脱。而汝于我常生恶心。我常于汝生怜愍想。汝今当舍恶见恶意。我当授汝阿耨多罗三藐三菩提记。尔时波旬闻是语已。生嗔恶心欲还所止。复还见身被五系缚。欲出大声而不能出。即吐恶气欲歔杀佛。尔时如来变其恶气成须曼华。佛神力故令是化华遍至十方恒河沙等诸如来所而以供养。于诸佛上一一化作须曼华盖。尔时无量诸佛世尊无量菩萨。各各自问其土如来。如是变化谁之神力。无量诸佛各各说言。娑婆世界释迦如来。欲为具足五滓众生演说法要。所谓法印句门入陀罗尼能坏一切魔境界力。开显一切佛功德力。竖大法幢不断佛种。能令一切善法增长。能坏一切邪见众生。能坏一切恶梦不祥。能断疾病刀兵饥馑斗讼等事。复能调伏一切天龙乾闼婆人。炽然慧炬示导一切平等之道。能令一切远离恶见。能断一切诸恶种性。能令一切同于一性。能护一切城邑聚落沙门婆罗门。能知一切星宿运度。能学一切世间诸事。能令一切远离恶口获无碍辩。观一切法通达其性如法而住。能说大乘安慰菩萨。悉令能得不退转心。能施无上甘露法味。能令获得无生法忍。转正法轮利益调伏无量众生。悉令得住六波罗蜜。能令众生见无上道。能降法雨示诸佛事过四魔界。入大涅槃金刚法心因缘自在陀罗尼。持欲演说如是等法。如过去佛未来诸佛之所宣说。现在十方诸佛世尊。住世说法教化众生。皆是金刚法心因缘自在陀罗尼也。过去未来诸佛世尊亦复如是。尔时诸方无量菩萨各白佛言。世尊。我初未曾闻金刚法心因缘自在陀罗尼。云何名为金刚法心因缘自在陀罗尼。唯愿如来分别解说。乃至为令入大涅槃。利益无量人天杂类。尔时十方诸佛世尊。各各告其诸菩萨言。善男子。我亦欲见释迦如来听受是法。为欲利益一切众生。为坏一切众生恶业。乃至为欲入大涅槃。尔时十方诸佛世尊告诸菩萨言。善男子。若欲供养一佛世界无量诸佛。各欲听受无上正法所未闻法。见大集会。宜当往诣娑婆世界释迦如来所住之处。尔时无量诸菩萨等。默然而受佛之教敕。各作是言。我欲于彼一佛世界供养恭敬无量诸佛。亦欲于彼无量佛所听受种种无量法义。亦欲睹见无量神通及以无量不思议事。不知彼土有座处不。若有座处则得供养听受正法。尔时诸佛告诸菩萨言。善男子。汝等不应于如来所生疑虑心。何以故。诸佛境界不可思议。智慧方便不可思议。为欲调伏一切众生。善男子。娑婆世界释迦如来。智慧方便不可限量。善男子。释迦如来一切众生阴所摄身。一一皆如须弥山王。能令耆苈容其座处。是名如来智慧方便。亦令众见葶苈不宽所座不迮。而葶苈子其质如本无增减相。复次善男子。一切世界所有大地。悉令入于一微尘中。亦令微尘无增减相。是名如来智慧方便。复次善男子。一切世界所有诸水。悉能令入一微尘中。亦令微尘无增减相。是名如来智慧方便。复次善男子。一切世界所有诸风。悉能令入一毛孔中。亦令毛孔无增减相。是名如来智慧方便。复次善男子。一切世界所有诸火。悉令入于一毛孔中。亦令毛孔无增减相。是名如来智慧方便。复次善男子。十方所有一切众生。悉能令入一微尘中。亦令微尘无增减相。是名如来智慧方便。复次善男子。一切众生三世所有身口意业三世所受苦受乐受无苦乐受。三世众生身口意业所受果报。三世所有地水火风。至一切法界。释迦如来于一念中了了通达。亦不称言我知我觉。又不役虑然后而知。善男子。释迦如来具足如是智慧方便住娑婆世界。尔时十方无量佛土无量菩萨。既得闻佛无量功德。即各具足无量神通

大方等大集经卷第二十大方等大集经卷第二十一

        北凉天竺三藏昙无谶译

    宝幢分第九中陀罗尼品第六

尔时东方有乐世界。佛名阿閦。与诸无量神通菩萨发彼世界。一念来至娑婆世界释迦如来大集之处。到已坐于化莲华上。无量菩萨亦复如是。各各皆坐化莲华上。如是东方无量诸佛无量菩萨各各来诣娑婆世界。到已皆坐化莲华座。南北二方亦复如是。尔时西方安乐世界无量寿佛。亦与无量神通菩萨发彼世界。一念来至娑婆世界释迦如来大集之处。到已坐于化莲华上。无量菩萨亦复如是。各各皆坐化莲华上。各各以己神通福力作供养具。或作金沙和微妙香以散佛上。或作种种微妙香华。或起右绕娑婆世界。或有长跪说偈赞叹。或有系心善思惟者。或雨金华乃至优钵罗华。或以妙眼瞻睹佛身。时有童子名须菩提。以己神力及佛神力。出大音声而说偈言

  诸佛无量大宝幢　　能坏一切疑网心
  我初未曾得见闻　　如是无量大会众
  满此世界无量佛　　具足福德诸菩萨
  此地即是大宝塔　　皆得供养十方佛
  无量诸佛何因缘　　悉来集是恶世界
  今此国土恶众生　　亦复不能信佛事
  为坏一切大魔业　　为欲具足大功德
  为欲示现大神通　　是故诸佛集会此
  此会若有诸众生　　至心生于信喜心
  若以此心听受法　　是人即能破魔业
  若欲通达无上乘　　及欲修行八正道
  若欲永断诸烦恼　　应当至心听正法
  诸十方佛及菩萨　　皆来至此坐化华
  释迦如来欲说法　　为护正法住无量

如是音声充遍大会。无量菩萨得无量忍。异口同声作如是言。我今坐已。唯愿如来宣说正法。摄一切法无畏微妙。能坏魔业过于魔道。摧伏魔幢建立胜幡。坏诸烦恼调伏怨敌。裂诸疑网入种智门。过诸怖畏护众菩萨。亦令菩萨一切受乐。得诸菩萨慧方便门。及以一切安乐之处。一切三昧忍辱光明慧方便门。三十七品心陀罗尼。唯愿如来广分别说。为令众生受诸安乐。获得上色上力上乐上触上辩上念上意。为闻法已不忘失故。为坏国土恶瑞应故。受持戒故。修集道故。不失无上菩提心故。唯愿如来为如是事。颁宣广说是陀罗尼。为护法故。不断一切三宝种故。示诸菩萨菩提道故。为不分别虚空法性空相等故。显示明闇有相无相。观平等相此彼法故。为不分别众生寿命士夫等法。不生不灭断一切相。一切变易等相无物。虚空实性故。唯愿释迦牟尼如来及与诸佛广宣分别大陀罗尼。为令无量无边众生真实睹见三宝性故。为令无量无边众生发阿耨多罗三藐三菩提心故。尔时一切无量诸佛默然许之。许已即入诸佛上妙境界誓愿功德三昧。尔时此间娑婆世界。所有地狱畜生饿鬼诸苦即灭得见诸佛。有诸众生疑网无信即得净信。一切众生。悉见无有贪欲嗔恚愚痴憍慢恶见疑网狂乱等病。身心寂静。各各皆作如是念言。唯我一人独坐佛前听受正法。如来世尊唯为我说。独调伏我断诸烦恼。如我所请而为我说。尔时世界一切众生。异口同音作如是言。愿佛说法我当顶受。尔时释迦如来。劝此世界所有众生。令供养佛。尔时众生既闻劝已。即各供养一切诸佛香华幡盖伎乐赞叹。尔时世尊即作是言。十方诸佛谛听谛听。我以往昔本愿力故。在此世界具足五滓恶众生中。成阿耨多罗三藐三菩提。是诸众生迷失正道无明所覆。失于正念增长烦恼。安处三趣乐作十恶。远离善根舍功德业。喜造五逆耽着非法。诽谤正典毁呰圣人。嗔恚炽盛不乐修慈。招提僧物随意而用。于业果报不能深信。不乐供养师长和上有德之人。为如是等弊恶人故。修集如是大慈悲心。以是因缘。于是世界而得成道。既成道已。常乐修集勤精进法。忍于饥渴寒热等苦。游诸国土城邑聚落。为诸众生宣说正法。或有众生贫穷病苦受身丑陋。为怜愍故。受其所施臭秽之食。为欲增长施主福德。皆悉食之。亦受众生粗涩臭秽弊坏衣服。山间河涧空旷林野所有住处悉亦受之。若草若叶。若石若塼。为众生故随施受之而卧其上。以勤精进修善方便。为刹利故演说王事。为婆罗门说四毗陀星宿祀天。为诸大臣说治化事。为诸医师演说四大增减等病。为诸农夫商贾之人。说护财谷。为诸女人说护璎珞。勤修诸善得不共夫。为出家者说于忍辱。为调伏故说如是法。未得善利劝之令得。未得证者劝令得证。未解脱者劝令解脱。为调众生受诸苦恼。我为众生修集慈悲。然诸众生犹于我所生不善心。或打或骂。或生嫉妒。或有说言。沙门瞿昙即是幻士。虽赞持戒自畜妻妇。虽赞慈心而害众生。赞舍富贵自往王家。瞿昙沙门善知方术。虽畜妻妇不生子息。瞿昙沙门能治女身故。令末利生爱重心。瞿昙沙门善知咒术故。令须达生宗敬想。瞿昙沙门善知药法。是故其身常有光明。得如是等无量恶名。或有以石土木刀毒遥见打掷为欲杀我。为杀我故。故放恶象毒蛇。于我住处放大猛火粪秽不净。造作种种诸恶方便。欲坏我法。为灭我法。为摧法幢。为破法船。为坏法性。为破法藏。十方诸佛。唯愿观察。过去诸佛。有于如是五滓世界成得佛道。无有不说如是大集金刚法心因缘自在陀罗尼者。为坏一切诸魔力故。为三宝种不断绝故。为诸众生增善法故。为坏一切佛法怨故。为令众生远离苦故。灭身口意诸恶业故。为令人天性调柔故。为诸国土受安乐故。为破世间诸恶相故。为令众生悉得具足六波罗蜜故。为发无上菩提心故。为教菩萨善方便故。为令菩萨次第住故。以如是等诸因缘故。过去诸佛为如是等五滓众生。说是大集金刚法心因缘自在陀罗尼也。今此世界十方诸佛悉来集会。唯愿诸佛。各说如是陀罗尼咒。为怜愍故。为当流布大乘经故。为此世界法久住故。令诸恶魔不得便故。尔时诸佛即皆同声。说此陀罗尼句

安伽逻(一)安伽逻(二)半伽逻(三)婆[(口*皮)/女]伽逻(四)婆逻[(口*皮)/女]伽逻(五)婆蛇比呵(六)曼啰婆毗(七)阿[口*仚](八)阿佉婆呤(九)题咩(十)度慕汦(十一)翘婆知(十二)翘由离(十三)三摩婆阿尼(十四)三摩多婆提呤(十五)陀弥(十六)陀移(十七)陀摩翘阇(十八)弥啰[少/(兔-、)]破犁(十九)破罗婆汦(二十)伽泞(二十一)伽那婆逻汦(二十二)希利(二十三)希提(二十四)希逻(二十五)希逻翘(二十六)谵婆提(二十七)婆迦斯(二十八)咤迦汦(二十九)咤迦婆逻汦(三十)伽那[(口*皮)/女]呵汦(三十一)希利汦(三十二)尸利汦(三十三)频地利[(口*皮)/女]汦(三十四)具婆希(三十五)酬呤(三十六)弥啰酬呤(三十七)酬蓰(三十八)阿其离(三十九)阿婆弥(四十)娑利也(四十一)多哆旦(四十二)富流(四十三)希利(四十四)战地离(四十五)摩陀弥(四十六)陀弥(四十七)究周流(四十八)牟周流(四十九)阿遮吒(五十)至利(五十一)至弥利(五十二)遮婆呵(五十三)周婆(五十四)周娄(五十五)悉啰[(口*皮)/女]呵(五十六)究娄(五十七)娑罗究侜(五十八)究侜(五十九)摩诃娑逻娑(六十)[豆*斤]侜(六十一)[豆*斤]侜(六十二)摩诃萨哆希力陀蛇(六十三)富罴(六十四)修富罴(六十五)度摩波利呵利(六十六)阿婆移(六十七)流之泞(六十八)迦逻叉(六十九)阿陀摩兜(七十)比婆呵(七十一)提提利(七十二)摩摩利(七十三)波舍佉(七十四)或或逻(七十五)路迦比那蛇迦(七十六)[(口*皮)/女]时离(七十七)[(口*皮)/女]时罗陀呤(七十八)[(口*皮)/女]时离陀提(七十九)斫迦逻婆时离(八十)遮尼离(八十一)遮迦逻婆提(八十二)陀呤(八十三)陀呤(八十四)牟离咤呤(八十五)休休呤(八十六)朋伽频婆呤(八十七)舍利奢(八十八)流流周(八十九)之利周利(九十)牟呤慕陀呤(九十一)慕荼泞(九十二)慕荼泞(九十三)伽伽逻尼(九十四)牟荼泞(九十五)散婆逻牟荼泞(九十六)提提罗蛇尼(九十七)摩醯首逻罗蛇尼(九十八)律师婆尼(九十九)陀逻[(口*皮)/女]至(一百)战荼罗素咩(百一)萨婆萨写阿提[口*悉]多(百二)车陀兜[(口*皮)/女]阿那(百三)摩弥尼(百四)[(口*皮)/女]罗逻提(百五)乌阇其离(百六)比比那(百七)[(口*皮)/女]那逻诃(百八)复佛呤(百九)仇留(百十)仇留(百十一)牟留(百十二)牟留(百十三)希希(百十四)希希(百十五)阿逻(百十六)阿逻(百十七)迦迦荼婆呵(百十八)希希多(百十九)阿由那(百二十)鞬荼谵婆斯(百二十一)竭陀尼(百二十二)阿婆陀呵泞(百二十三)末力伽比流比流(百二十四)破罗萨哆(百二十五)阿路沙[(口*皮)/女]提(百二十六)希利希利(百二十七)夜哆婆阇蛇(百二十八)莎其罗(百二十九)夜多波兰遮(百三十)希力陀蛇婆呵(百三十一)萨多波利[(口*皮)/女][(口*皮)/女](百三十二)末力伽毗卢呵尼(百三十三)阿遮罗佛提(百三十四)陀陀波罗遮罗波遮蛇(百三十五)宾荼希力陀蛇(百三十六)战陀逻[(口*皮)/女]逻泞(百三十七)阿遮呤输陀泞(百三十八)波逻冀逻摩力伽(百三十九)伊罗(百四十)伊利呤(百四十一)波腊脾(百四十二)波逻[(口*皮)/女]逻汦(百四十三)萨婆啰多哆多(百四十四)萨多[少/兔]竭脾(百四十五)阿那[(口*皮)/女]罗那伏律汦(百四十六)阿罗茶(百四十七)安伽呤(百四十八)舍弥尼(百四十九)比婆罗[(口*皮)/女]俞希(百五十)阿希多(百五十一)阿婆希(百五十二)尼逻[(口*皮)/女]蛇[(口*皮)/女](百五十三)阿之逻末力伽(百五十四)罗[(口*皮)/女]那(百五十五)逻仇婆呤(百五十六)犁勒那朋舍(百五十七)陀摩伽蛇(百五十八)阇罗战陀(百五十九)三牟陀罗[(口*皮)/女]提(百六十)摩诃复多脾蛇(百六十一)三牟陀比伽婆(百六十二)陀罗尼牟陀离那(百六十三)摩呿牟陀逻(百六十四)波逻波罗提(百六十五)思比陀牟陀(百六十六)阿婆多尼(百六十七)娑波多尼(百六十八)三慕迦逻(百六十九)比豆多逻斯那(百七十)厕提牟地离都思(百七十一)移迦之(百七十二)卑利痴比迦蛇(百七十三)[(口*皮)/女]呵婆冀荼(百七十四)迦[(口*皮)/女]吒(百七十五)尸逻波逻提多希力陀蛇(百七十六)三牟陀多陀罗尼(百七十七)陀逻(百七十八)陀逻(百七十九)陀逻(百八十)弹提罗(百八十一)弹堤罗休尼罗萨婆希力陀蛇勿陀离都思阇吒(百八十二)阇婆咤(百八十三)阇呿[(口*皮)/女]咤(百八十四)修摩堤(百八十五)摩提(百八十六)摩诃复多勿陀离多(百八十七)易翅之散迦罗(百八十八)婆荼蛇多那尼(百八十九)首力多复多(百九十)伊尼弥尼(百九十一)裟遮尼(百九十二)输沙萨遮尼(百九十三)牟地离多遮利也阿堤咩那(百九十四)婆比哆(百九十五)阿那若哆(百九十六)摩呵富若三牟遮蛇[(口*皮)/女]多逻(百九十七)摩诃迦留尼迦牟地离多(百九十八)萨婆三藐波罗提般(百九十九)至逻逻逻罗阇罗兜(二百)萨婆尼犁(二百一)萨婆牟尼婆罗沙婆摩诃迦留那三摩堤若那婆离难(二百二)咩啰多竭毗(二百三)比利也比利也(二百四)婆犁那提[口*悉]多(二百五)萨婆复都波蛇(二百六)莎呵

尔时娑婆世界一切众生。闻是咒已。各各称言南无一切十方诸佛。第二第三亦复如是。甚奇甚特。诸佛大会不可思议。诸菩萨事亦不可思议。我等昔来未曾得闻如是持名今得闻之。能坏一切魔境界力。绍三宝性断魔罗网。得诸善法具足佛事。为如是等说是大持。为诸众生着心封印。印诸众生阴入界法。乃至获得大般涅槃。尔时会中有一童子菩萨。名曰月光。从莲华起。一心合掌观察十方。以佛力故出大音声。其音遍闻娑婆世界。而说偈言

  如是大集甚难得　　具足智慧亦复难
  难得亲近善知识　　如是法印亦难闻
  如来怜愍诸众生　　为众生故护正法
  说是无上陀罗尼　　为坏种种诸魔力
  十方诸佛说是持　　为不断绝三宝性
  能和一切诸忿诤　　亦能增长无上忍
  增益众生诸善根　　消灭国土诸恶相
  能破众生三恶业　　亦令远离诸恶见
  如来说是无上持　　为欲显示无上道
  亦为具六波罗蜜　　真实修于菩提道
  是持即是善方便　　亦能增长无阂智
  摄取一切诸善法　　是故名为无上持
  具修三十七道品　　是名无垢菩提道
  能断一切疑网心　　及断众生诸烦恼
  是持即是真实语　　了了睹见菩提道
  我今欲说陀罗尼　　是则名为无上胜
  为欲拥护说法师　　及以听受是持者
  其谁欲受欲听者　　我今当说勿生疑
  无上无胜陀罗尼　　即是最上之智慧

尔时有恒河沙等菩萨童子。异口同音作如是言。我等亦欲说陀罗尼。若比丘比丘尼优婆塞优婆夷。先当澡浴净于身心着新衣服。以妙香华供养三宝。升于法座说陀罗尼。如是四众无有众生能起恶事以加之者。身心不浊四大清净。身诸病苦皆得远离。如是法师。若有过去业因缘病。悉皆消灭。听此法者亦复如是。灭过去业因缘病苦。尔时月光童子菩萨。向十方佛。长跪合掌而说咒曰

那提阿三摩路卑(一)咩罗素摩[(口*皮)/女]泯(二)伊希那遮久遮尼(三)那婆久遮尼(四)那遮久遮尼(五)牟罗输陀尼(六)[(口*皮)/女]荼呿(七)[(口*皮)/女]荼呿(八)修罗啰尼(九)那[(口*皮)/女]修罗啰尼(十)复多拘知(十一)波利车陀(十二)阇罗呿(十三)阇罗呿婆移(十四)阇罗呿那(十五)摩叉呿(十六)迦迦呿(十七)呵呵(十八)呵呵(十九)休休休(二十)拨施脾陀那婆利车陀(二十一)阿摩摩(二十二)若摩摩(二十三)呿摩摩(二十四)三牟陀陀罗(二十五)阿陀罗呿婆(二十六)散迦罗尼(二十七)波利车陀菩提娑厕提比摩(二十八)比比摩摩诃比比摩(二十九)复多拘知(三十)阿迦奢或婆娑波利车陀莎呵

尔时娑婆世界。十方诸佛菩萨声闻。释梵龙王。阿修罗王。乾闼婆王。迦楼罗王。紧那罗王。摩睺罗伽王等。同声唱言。善哉善哉。菩萨童子。善能说是大陀罗尼。为坏魔业及恶知识身心诸病。是上慧印。尔时会中有一梵王。名菩提自在。自变其身而为女像。端严殊特踰于人天。以妙璎珞而自庄饰。在西方佛阿弥陀前。作如是言。唯愿世尊。加我神力。令我一音遍满此间娑婆世界。我今欲说陀罗尼咒护说法者及听法者。亦令释迦如来灭后无有能于是说法者生起恶事。若魔若魔父母子息眷属亲友仆使。若天若龙。若阿修罗若乾闼婆。若伽楼罗。若紧那罗。若摩睺罗伽。若鸠槃茶。若富单那。迦多富单那。荔[卄/梨]多。毗舍遮。夜叉罗刹等。父母子息眷属仆使。亦复如是。于是法师不能为恶。乃至不能动其一毛之分为其身心而作恶事。唯愿世尊。加我神力。令我音声遍此世界。尔时会中有一帝释。名曰高持。语菩提自在梵言。姊。莫于如来生戏弄心。何以故。夫戏弄者即凡夫法。如来已过凡夫事业。一切有为悉是无常。如来不增有为之法。唯增于空断声字句。姊。如来于汝不生诤讼。但观平等一相无相。犹如虚空。夫虚空者无三有为。无有觉观。不离有为。无有障碍。如来世尊亦复如是。于一切法无有障碍。如来于欲亦复如是。一切觉观寿命士夫。阴界诸入音声字句。悉皆无碍。姊今云何。于如来所而生戏弄。无量寿佛告帝释言。善男子。当先思惟然后发言。无得于后而生悔恨。何以故。是女人者即大丈夫。已于无量诸如来所。久修善本。为欲庄严此大众故。现为女身实非女也。即是菩萨摩诃萨身。汝云何言称之为姊。尔时帝释闻佛语已。即前忏悔。自在梵言。我受汝忏。令汝不得恶口等果。尔时梵天。白无量寿佛。世尊。若彼高持不忏悔者。当得何等恶口果报。佛言。善男子。彼若不忏。当于八万四千世中常受女身。其形丑陋臭秽不净。是故众生应当护口。尔时无量寿佛。告菩萨言。我今施汝威神道力。便可说之。尔时梵天。敬白十方无量诸佛及诸菩萨一切人天。唯愿善听。若有欲令如来正法久住于世。拥护说法及听法者。唯愿诸佛悉施我欲。说是语时。其音遍满娑婆世界。尔时一切梵王释王。各作是言。我施仁欲并欲受持。尔时梵天即说咒曰

阿摩犁(一)比摩犁(二)伽那沙踟(三)波利战踟(四)摩诃战踟(五)遮弥(六)摩诃遮弥(七)素咩(八)哆弥(九)阿[(口*皮)/女]呵(十)比[(口*皮)/女]呵(十一)修伽阇尼啰呿婆(十二)牟罗波利车陀(十三)夜叉战踟(十四)比舍遮战荼(十五)阿婆阿多尼(十六)三婆逻哆尼(十七)娑伽罗尼(十八)谵婆尼(十九)慕呵尼(二十)郁遮吒尼(二十一)阿摩呵(二十二)阿多遮尼(二十三)呿伽舍婆(二十四)阿摩罗(二十五)阿牟罗(二十六)牟罗波利跋汦(二十七)阿娑罗呿婆(二十八)莎呵

阿遮遮(一)阿[(口*皮)/女]呵遮遮(二)周尼罗叉(三)遮遮咤(四)呿遮遮(五)那呿伽遮遮(六)遮遮(七)遮遮遮遮(八)阿牟罗遮遮(九)呵摩摩牟罗遮遮(十)阿牟罗呵牟婆茶婆呵(十一)莎呵

尔时一切诸天世人。咸皆赞言善哉善哉。是陀罗尼不可思议无能胜者。尔时梵王复作是言。若有不能调伏恶鬼。闻是持已即便能调。若有受持如是咒者。随所住国。信心诸王一切男子女人。若大若小。若天若人。皆于是王不能起恶。若有起恶首为七分。其心干焦身被癞病。有神通者即便还失。暴风所吹身陷入地。随是持咒流布之处。我亦当护令得远离一切诸恶。受者听者不乏衣食卧具医药资生所须。尔时会中有一梵天。名曰正语。亦现女像。复作誓言。我今于此娑婆世界。现在佛前至心护法。乃至释迦如来灭后亦当护之。随是持咒流布之处。护其国土。说者听者令离魔业一切恶事。若有法师欲说法者。为调众生。先当读诵是陀罗尼。即说咒曰

阿婆咩(一)比摩咩(二)庵婆罗(三)庵婆呤(四)波利军阇那荼(五)富沙波逻婆呵(六)阇留迦(七)摩呿罗蛇(八)伊利弥利(九)冀利弥利(十)冀提遮罗牟蛇离(十一)牟陀罗目[口*仚](十二)莎呵

若有法师。先读诵说如是持者。我以天耳当往听之。闻已身往在其会中。令诸会者远离诸恶。至心听受如是持咒。若我闻已而不往者。则为欺诳过去未来十方现在无量诸佛。亦于未来。不得成就阿耨多罗三藐三菩提。若我往者。即令法师逮无碍辩得无所畏。听法之人。远离病苦及疑网心。饥渴寒热。兵革怨敌。虎狼毒兽。一切诸恶。唯愿十方一切诸佛加我神力。尔时释迦如来。白诸佛言。今我当与此梵天咒。为护法故。即便说咒

遮慕踟(一)慕茶波利车陀(二)阿牟摩(三)阿牟摩(四)呵牟摩(五)娑罗叉(六)[(口*皮)/女]罗究思(七)弥呿波利[(口*皮)/女]呵(八)遮罗摩(九)蛇哆[(口*皮)/女](十)修比呿(十一)阿牟罗波利车题(十二)萨婆佛陀阿提[口*悉]汦(十三)莎呵

于是如来说是咒已。即告梵天。善男子。如是持咒力。能调伏一切众生。尔时梵天白佛言世尊。我今所以现此女身。为欲调伏一切女人。若有女人欲生男者。当读是持。读是持已即得生男。厌儿息者便不复生。若有受持读诵之者。我当至心营卫拥护

    大方等大集经宝幢分中护品第七

尔时会中有一菩萨。名善系意。立于宝光功德佛前。现身如梵。或如帝释。或自在天。或他化自在天像。或兜率天。或夜摩天。或提头赖吒天。或毗楼勒迦。或毗楼博叉。或毗沙门。或作龙王。或阿修罗王。或紧那罗王。或伽楼罗王。或夜叉王。或罗刹王。或毕力迦王。或毗舍阇王。或拘办荼王。或作刹利婆罗门毗舍首陀比丘比丘尼优婆塞优婆夷。或作师子象虎毒蛇牛马之形。复作种种飞鸟之身。一时之中能示八万四千种色。尔时富楼那弥多罗尼子。白释迦如来言。世尊。何因缘故。是善男子变现如是八万四千种种诸色佛言富楼那。是善系意菩萨摩诃萨。所入三昧不可思议非是声闻缘觉境界。是善男子以如是等诸善方便调伏众生。随众生身意色三昧。悉能住之。若有众生宗事梵天敬念梵天。即现梵像为说三乘法。乃至或有奉事佛者。即现佛身为说三乘。若有众生宗事畜兽。即现兽像为说三乘。若有奉事山谷河涧树林百卉。即现其像而调伏之。若有众生贪于财利。先以财施后为演说三乘之法为坏贪故。若有病者随其所须给施医药。若悟时与。若梦中与。令其病者众苦除愈。为调伏故而为说法。富楼那。是善男子于一日夜。能以三乘调伏恒河沙等众生。富楼那言。是善男子。发阿耨多罗三藐三菩提心已来。为久近耶。富楼那。是善男子已于无量恒河沙等劫中发心。是人得是三昧已来。调伏众生。已经六万四千亿阿僧祇劫。富楼那言。世尊。是善男子久近当得成无上道。成道之时在何国土。富楼那。此世界中过六大劫。劫名星宿。于是劫中当成正觉。号曰宝髻。是时众生寿四万岁。多造恶逆具足五滓。成正觉已四十年中。宣说三乘便入涅槃。富楼那言。世尊。彼时众生未调伏者。复当云何。富楼那。彼时众生无有一人不调伏者。富楼那。如是菩萨常立誓愿。十方各各千佛世界所有众生。乃至一人不调伏者。我终不成阿耨多罗三藐三菩提。若我不能了了知见如是世界所有诸佛。亦复不成阿耨多罗三藐三菩提。如是十方千佛世界所有众生。若有一人非我调者。我亦不成阿耨多罗三藐三菩提。若他世界所有恶人愿生我国。生我国已。我当以三乘之法而调伏之。富楼那。如是菩萨具足如是不思议事。富楼那言。世尊。我于今者得大利益。而得见闻如是正士。若有人能至心听受是大集经。是人亦得如是利益

    大方等大集经宝幢分中授记品第八

尔时阿閦佛。告大众言。今是众中梵释四王。阿修罗王。人王非人王。如是等众集会甚难。汝等今日而得值遇。应当至心于诸佛前随其至乐发深重愿。时有魔王名庄严华。现七宝首而为女像。身佩种种微妙璎珞。作如是言。今我至心于诸佛前立大誓愿。愿于贤劫娑婆世界。以此女身常施众生香华甘果而调伏之。以是因缘。令其成就阿耨多罗三藐三菩提。尔时一切十方诸佛。同时赞言。善哉善哉。善男子。汝有信喜。而于今日大作佛事。当随汝愿悉得成就。魔王复言。世尊。随何国土有人受持读诵书写思惟分别是陀罗尼处。我当住中为作种种华果树林泉源浴池谷米所须令无所乏。若有众生于是经中。义说非义。非义说义。我当治之。或令病苦狂乱错谬。国主摈之生嗔害心。此言若虚则为欺诳十方大众。亦莫令我于未来世得阿耨多罗三藐三菩提。若此世界及他世界佛诸弟子。不得供养利安之者。无有是处。除过去业必应受者。如我所施华果浴池泉源谷米。即是我之檀波罗蜜。受我施已。获得无上慈善之心。即是我之尸波罗蜜。受我施已。勤修精进集诸善法。即是我之进波罗蜜。受我施已。深观诸法无常之相。即是我之禅波罗蜜。受我施已。能忍一切身口意恶。即是我之忍波罗蜜。受我施已。能观诸法空无相愿。即是我之般若波罗蜜。如是我则具足成就六波罗蜜。唯愿十方无量诸佛令我得之。尔时十方无量诸佛。默然许可。尔时慧幢如来。赞庄严华。善哉善哉。善男子。如汝所愿当令汝果。汝既果已当得利益无量众生。尔时魔王即以女身说此陀罗尼

遮弥呿(一)遮咩呿(二)遮咩呿(三)涅伏多阿提(四)[(口*皮)/女]呵(五)[(口*皮)/女]呵(六)[(口*皮)/女]呵(七)沫罗(八)沫迦(九)娑罗知(十)比婆婆比(十一)娑罗娑利地离(十二)娑罗摩希地离(十三)娑罗[(口*皮)/女]时离地离(十四)多波蛇沬迦(十五)休休休休(十六)阿沙伽阇脾(十七)多呿(十八)多呿(十九)多呿(二十)婆油婆醯(二十一)乌波那蛇(二十二)萨多波蛇(二十三)频阇破罗(二十四)富逋沙陀(二十五)陀那陀泞那(二十六)遮居离厕移(二十七)阇罗[(口*皮)/女]呵尼(二十八)沫罗沫迦(二十九)三藐波罗提波那婆延(三十)萨多迦利(三十一)蛇摩咩(三十二)摩咩(三十三)摩咩(三十四)阇婆罗(三十五)莎呵

世尊是陀罗尼流布之处。若国土城邑聚落村屯。我当住中调伏众生。悉令具足无上佛道。尔时一切十方诸佛无量菩萨。梵释四王。阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽人非人等。同声赞言。善哉善哉。善男子。汝能以是女人之身。护持如来无上正法调伏众生。修行具足六波罗蜜。演说无量诸佛功德。尔时释迦如来。告诸大众。谁能与此同心护法。尔时会中无量众生。咸作是言。我等能与是善男子。同共护法不相舍离如影随形。愿是菩萨成无上道。当复与我授佛道记。时庄严华白释迦如来言。世尊。如来灭后。我当于此护持如来无上正法及受法者。唯愿如来怜愍我故。授我阿耨多罗三藐三菩提记。佛言。善男子。汝得阿耨多罗三藐三菩提时。世界名法行。佛名功德意。时庄严华。既闻记已。即以香华供养如来。尔时会中有一菩萨。名曰吉意。白娑婆世界十方诸佛言。世尊。是人已于贤劫之初迦罗鸠孙陀佛所。发大誓愿。愿以女身教化成就无量众生。亦令远离四百四病故。说四百四善方便。根药果药散药丸药。下药吐药。阿伽陀药。油苏汤药。各四百四。以如是等调伏众生。复于四万四千岁中。供养恭敬迦罗鸠孙陀佛及以众僧。供养佛已即得受记。彼佛告言。善男子。未来众生寿命百三十年当有如来号释迦牟尼。以大愿力。娑婆世界当有十方无量诸佛菩萨集会。是大集时。汝于彼中当得受阿耨多罗三藐三菩提记。迦那牟尼迦叶等佛。亦复如是。是人尔时白彼佛言。世尊。我以本愿力故。常以女身持种种药。给施一切病苦众生。以我是愿福德力故。一切树木华果悉出甘露之味。若有食者。即是我之檀波罗蜜因。若有食我如是所施华果谷米甘露味者。舍除毁禁受持净戒。即是我之尸波罗蜜因。受我食已勤行精进修集善法。即是我之进波罗蜜因。堪忍持戒思惟修善即是我之羼提波罗蜜因。深观诸法无常之相。即是我之禅波罗蜜因。观法苦空无常无我。即是我之般若波罗蜜因。如此世界女身教化。调伏众生令离病苦。十方世界亦复如是。世尊。我说是事。令庄严华增长成就精进力势。如来灭后。我当与彼共护佛法。唯愿世尊。于此大众与我授记。尔时一切十方诸佛赞言。善哉善哉。释迦如来当授汝记。尔时世尊告吉意言。善男子。汝于当来莲华世界。得成为佛。号曰善见。如吉意女。地天水天。火天风天。虚空天。种子天。华天果天。山天树天草天。抵天涧天。宝天四天下天。乃至六万七千神天。亦复如是。皆是菩萨现受女像为调伏众生。是等女天悉得授记。当成阿耨多罗三藐三菩提。所以现为女像教化。为令众生转女身故。若转男身得女身易。若转女身为男则难。是故以此女身教化是等六万七千诸女得授记已。百亿龙王。百千亿夜叉。百万亿阿修罗。七万亿天。九万九千亿魔王。恒河沙等人。所谓刹利婆罗门毗舍首陀。不可数拘办茶等。发阿耨多罗三藐三菩提心。无数众生得不退转菩提之心。不可数众生得菩萨三昧。不可数众生得无生忍。不可数众生得陀罗尼。不可数众生得菩萨地。不可计众生成就忍辱。不可计众生得沙门果。不可计众生得尽诸漏。不可计众生于声闻心无有退转。不可计众生于缘觉心无有退转。不可计众生得不退心

    大方等大集经宝幢分中悲品第九

尔时释迦如来。白诸佛言世尊。怜愍我故悉来集此娑婆世界。时庄严华吉意菩萨。为护法故发深重愿。如愿即得。时十方佛。为二正士大誓愿故。即说咒曰

树提婆婆(一)持律提婆婆(二)牟尼婆婆(三)萨多婆婆(四)富若棱伽婆婆(五)[口*長]那婆婆(六)摩诃迦留那婆婆(七)摩诃伏律多婆婆(八)阿慕呵婆婆(九)流提婆婆(十)厕提婆婆(十一)娑利罗婆婆(十二)却伽婆婆(十三)婆由婆婆(十四)跋多婆婆(十五)阿提单那婆(十六)阿摩婆婆(十七)阿颇那婆婆(十八)多咃多婆婆(十九)复多拘置婆婆(二十)尼提提婆婆(二十一)梨究舍罗婆婆(二十二)梨养那婆婆(二十三)梨陀兜婆婆(二十四)梨比目叉婆婆(二十五)梨道居罗婆婆(二十六)赖吒提那婆婆(二十七)婆婆(二十八)婆婆(二十九)婆婆(三十)三摩多(三十一)阿那若三摩多(三十二)咤咤咤咤咤咤咤咤咤(三十三)娑咤思提(三十四)萨婆佛陀究舍罗牟罗阿提啅那(三十五)莎呵

说是咒已。复告二人。善男子。汝等若欲教化众生。应当受持如是等咒。时庄严华菩萨。与诸菩萨其数十万。作如是言。十方诸佛为众生故。所说神咒。我等要当受持在心。若我今于十方佛前。立大愿已。听是神咒不能受持。则为欺诳诸佛世尊。亦莫令我得阿耨多罗三藐三菩提。若有人天持是咒者。设有于其起恶心者。我若不护令我不得成无上道。若比丘比丘尼。优婆塞优婆夷。受持是咒。亦无有能于是四众起恶心者。时十方佛。同声赞言。善哉善哉。善男子。汝能受持无上法雨。尔时释迦如来。告魔波旬。汝于佛法当生信心。以汝因缘。当令无量无数众生得解脱果。汝今失离一切伴侣。谁当与汝复共为恶。我怜愍故。殷勤告教。汝可速发阿耨多罗三藐三菩提心。魔波旬言。世尊。我今乃至无一念心发阿耨多罗三藐三菩提心。瞿昙今者。未能永断欲界众生。云何令我失离伴侣。我终不能归依三宝

    大方等大集经宝幢分中护法品第十

是时会中有佛。名曰曼陀罗华微妙香。语释迦牟尼佛。如过去世十方诸佛。以怜愍故。亦悉集会五滓世界。为护法故。坏魔怨故。怜愍众生故。施大智炬故。为说正道故。十方现在无量诸佛。亦复如是。今日十方无量诸佛。悉来集会娑婆世界。谁可付嘱释迦佛法。释迦如来言。我之正法可以付嘱频婆娑罗等诸大国王四王帝释梵天王等。如是等众能护我法。若有能发菩提心者。当知是人则能护法。尔时一切大众所有天王梵王龙王。异口同声作如是言。世尊。我等要当至心护法。何以故。如来正法难得难值。一佛界中无量佛会。亦复难遇。十方诸佛尚为众生而来集会。我等云何不护正法尔时十方诸佛。同声赞言。善哉善哉。善男子。若有刹利能护法者。所有国土衰恶之事。四百四病皆令除灭。及其国土所有树木华果谷米滋茂丰登。护其人民亲戚眷属令离诸恶。若有比丘比丘尼优婆塞优婆夷。亦当护之。何以故。过去菩萨。得成阿耨多罗三藐三菩提者。皆由拥护正法因缘。未来现在亦复如是。若能护是受者听者。当知佛法久住不灭。是故娑婆世界。天王人王当守护法。为久住世不断绝故。善男子。若有善男子善女人。欲令佛法久住于世不灭尽者。应当供养是大集经受者说者何以故。是大集经即是十方诸佛印封。若能供养如是大集。即是供养十方诸佛。释迦如来灭度之后。随有是经流布之处。若有听受持读诵说书写经卷乃至一偈一句一字。而其国主一切恶事即得消灭。所有树木谷米药草。四大天王降施甘露。而以益之。国土王法悉得增长。邻国恶王勤求和同。各各自生喜心慈心。一切诸天佛弟子者悉来拥护。如是国土王子夫人及诸大臣。各各生于慈愍之心。谷米丰熟食之无病。亦无斗讼兵革不起。无诸恶兽及恶风雨。远离一切过去恶业。若诸众生有女业者。现受生受及以后受。即能令灭除五逆罪。谤方等经及以圣人。犯四重禁一阐提辈。其余恶业如须弥山。悉能远离增长善法。具足诸根身口意善。远离恶见破坏烦恼。修集正道供养诸佛。具足善法及内外事。令诸众生寿命增长念慧成就。尔时弥勒菩萨等九万七千亿菩萨得无生忍者。作如是言。我等亦能佛灭度后护持正法。为怜愍故。当于都邑城村聚落广说是经。尔时娑婆世界无量诸佛。同声赞言。善哉善哉。善男子。娑婆世界一切人天。复作是言。我等亦能于佛灭度后。护持正法及四部众中受持说者。时十方佛。复赞叹言。善哉善哉。汝等真能护持正法。善男子。汝等若能护持正法。应当供养如是诸佛世尊。我等要当拥护是经流布之处都邑聚落人民眷属及受持者。并令土地谷米丰熟药木滋茂。何以故。随有是经流布之处。我于是中有大力势。以力势故我能护之。令离一切衰祸之事。亦令是国所有众生远离恶业生于惭愧。是时十方诸佛赞言。善哉善哉。汝今真能护持正法。亦能供养十方诸佛护持法者听受法者

    大方等大集经宝幢分中四天王护法品第十一

尔时释迦牟尼佛。告诸梵天帝释四王。善男子。我为如是恶众生故。本愿力故。大怜愍故。于此恶处成就阿耨多罗三藐三菩提。为欲利益无明闇冥渴法众生。常乐增长烦恼众生破坏魔众建立法幢。施其法雨。令诸众生离烦恼苦。令不可计无量众生发阿耨多罗三藐三菩提心。无量诸佛及诸菩萨。悉来在此世界集会。为坏众生无量恶业绍三宝种。我涅槃后所有正法当付汝等。汝等便当深心守护。若有菩萨福德成就。如是等辈。亦能拥护我之正法。若有众生。已于诸佛种诸善根者。是人于后法欲灭时余五十年。守护正法信敬受持读诵书写解说其义。如是法师。若于都邑城村聚落。欲多饶益无量众生。当净澡浴着新好衣庄严香华。于一案上安置种种诸甘味浆。置高座前。汝等尔时若不来集为护法师遮诸恶事听受正法自利利他。汝则欺诳十方诸佛。尔时梵天白佛言。世尊。随是经典流布之处都邑聚落。我当至心而拥护之。若比丘比丘尼。优婆塞优婆夷欲说是经。当净洗浴着新净衣。聚集香华乃至甘浆。置高座前。我与眷属定往其所。若我不往。则为欺诳十方诸佛世尊。此世界中。随有是经流布之处。当令其地无诸兵革及诸恶事。我今至诚十方佛前立深重誓。即说咒曰

安仇呵(一)登伽(二)富罗那呵(三)　蛇咩呿(四)呿呿(五)婆呿(六)[(口*皮)/女]呿[(口*皮)/女](七)居离那呿[(口*皮)/女](八)莎呵

尔时释提桓因。即说咒曰

呿[(口*皮)/女]密(一)摩奢密奢(二)那罗呿(三)阿牟若(四)阿牟[(口*皮)/女]呵(五)阿呿吒(六)阿呿(七)阿伽呿时那休律[口*仚](八)莎呵

尔时东方天王提头赖吒。即说咒曰

频头阇那(一)呿婆阇那(二)罗牟呿(三)叉娑罗(四)富那呵(五)阿末伽婆咤(六)莎呵

尔时南方天王毗留勒叉。即说咒曰

郁呿那婆阇荼(一)三牟陀斯若(二)多哆周多(三)婆逻那[(口*皮)/女](四)婆逻阇(五)莎呵

尔时西方天王毗留博叉。即说咒曰

阇路伽(一)阿郁伽(二)阿摩慕伽(三)阿摩摩娑逻阇(四)婆脾也牟阇(五)莎呵

尔时北方天王毗沙门。即说咒曰

[颱-台+秋]地离(一)[颱-台+秋][颱-台+秋][颱-台+秋]地离(二)呿[颱-台+秋]地离(三)阿尼[颱-台+秋]地离(四)希力多[颱-台+秋]地离(五)娑竭逻希力多(六)[颱-台+秋]地离散究娑[颱-台+秋]地离(七)陀摩叉地[颱-台+秋]地离(八)莎呵

尔时十方诸佛。赞梵释四王等言。善哉善哉。汝等今真能护持正法。时梵释四天王等白佛言。世尊。我等随是经典流布之处。要当至心护持。十方诸佛及诸菩萨。同共赞言。善哉善哉。毗沙门等。汝能真实护持正法。尔时娑婆世界。有万二千大鬼将军。护此世界。复有四万四千小将。成就大力及大功德。同音而言。世尊。我等亦当于未来世。随有是经流布之处。我则随护。若说法时我亦当往。有听法者。当为坏其种种魔业护说法者。令得增长一切善法。当劝诸王大臣长者。施其衣食种种资生所须之物。亦令其土无有兵革寇难之事及恶风雨。若我虚妄则诳十方无量诸佛。尔时娑婆世界。有一菩萨。名曰疑心。白释迦牟尼佛言。世尊。此娑婆世界。有百亿魔不。如其有者悉来集不。佛言。一切都集。世尊。若都集者。有信心不。佛言。善男子。皆有信心。唯除波旬眷属千人。当于未来破坏我法常求过罪。是魔波旬及其眷属破坏三宝。何以故。皆是过去恶因缘故。过去不种善根因缘。善男子。我法灭时是魔波旬及与眷属。于如是法乃得信心。种菩提子修菩萨道。乃至得阿耨多罗三藐三菩提

尔时会中有一魔天。名曰太白。已于无量诸如来所。成就功德。所有信根无能倾动。奉敬三宝。已于诸佛得受阿耨多罗三藐三菩提记。现仙人像。从坐而起长跪合掌。以大音声遍诸佛土。而白佛言。世尊。释迦如来本愿因缘。生怜愍故。于此具足五滓世界谤法众中。得成阿耨多罗三藐三菩提。以怜愍故。说三乘法脱三恶道。复为无量无边菩萨。说无生忍。不断十方诸佛种性。是故我当于未来世至心拥护。令释迦法久住不灭。令诸魔众不得其便。我终不坏如来正法。若无持者佛法则灭。若诸四众无说听者法则衰灭。若未来世。善男子善女人。修立三业绍三宝性。为坏三界诸恶烦恼。修行正道。能坏众生三恶道苦。一切魔众无能为也。唯愿十方无量诸佛。施我功德智慧二力。我欲诵咒。为坏一切恶魔眷属。时十方佛同共赞言。善哉善哉。时太白魔即说咒曰

阿摩犁(一)阿汉呿咩(二)阿阇婆[(口*皮)/女](三)阿阇婆婆(四)阿阇婆婆(五)牟罗娑犁(六)脾也呿娑[口*仚](七)阇摩娑犁(八)呵呵(九)呵呵(十)呵呵(十一)伽罗娑吒(十二)阇囊却伽(十三)若蛇却伽(十四)比若蛇娑呿伽(十五)阿牟叉逻(十六)叉叉(十七)叉叉(十八)叉叉(十九)牟逻婆呵呿迦(二十)莎呿若(二十一)莎波利婆多(二十二)牟逻(二十三)阿若若(二十四)战陀修利蛇若若(二十五)婆提若若(二十六)那婆呵若若(二十七)呿逻叉若若(二十八)那波逻若若(二十九)复多拘知若若(三十)多哆多若若(三十一)萨菩婆比若若(三十二)逻提悉多若若(三十三)遮居逻摩频婆多叉婆(三十四)叉摩摩(三十五)叉波若(三十六)差比多(三十七)摩罗比沙蛇(三十八)莎呵

说是咒时地六种动。一切魔众心生怖畏。一切天人。乃至迦罗富单那皆离怖畏。得不退转菩提之心。尔时魔王问坚意言。善男子。是太白魔王从何处来。有何等力。而能破坏一切魔众及诸黑业。增长瞿昙断灭之法。我今睹见心欲变吐。四方皆闇身心苦痛。而彼见之甘乐爱着。唯愿怜愍为我说之。坚意菩萨言。波旬皆是一切诸佛威神。令是太白有如是力。以是力故坏诸魔众。增长如来无上正法。是太白菩萨所有德力。乃至人天无能坏者。波旬。汝于三宝宜应生信发菩提心远离一切身口意恶。波旬言。大士。我今方欲造成种种身口意恶。实不能发菩提之心

    大方等大集经宝幢分中旷野鬼品第十二

尔时旷野菩萨即现鬼身。散脂菩萨即现鹿身。慧炬菩萨现猕猴身。离爱菩萨现羖羊身。尽漏菩萨现鹅王身。如是五百诸菩萨等各各现受种种诸身。其身悉出大香光明。一一菩萨手执灯明。为欲供养十方诸佛。尔时疑心菩萨。至心观察是五百人。即知悉是菩萨大士。语旷野鬼言。善男子。汝等何故现如是身供养诸佛。旷野鬼言。善男子。往古过去九十一劫。有佛世尊。号毗婆尸如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。我于尔时。与如是等同一父母共为兄弟。受持五戒勤修精进。聪明智慧心乐善法。种种供具供养彼佛。既供养已。皆发阿耨多罗三藐三菩提心。为欲调伏一切众生。尸弃。毗舍浮。鸠留孙佛。亦复如是。皆供养已。散脂大士于彼佛前立大誓愿。愿我来世以鬼神身教化众生。若有弊恶恶鬼众生。我当演说三乘之法而调伏之。乃至无量恒河沙等恶鬼恶兽悉令调伏。然后乃当成就阿耨多罗三藐三菩提。亦有一万二千大鬼。于此世界发大誓愿调伏众生。尔时我复发大誓愿。若有恶鬼。欲坏如来如是正法。我当治之。是故我受如是鬼身。若有恶鬼。能杀众生。令其心乱。恶心杀害。深着邪见。能令刹利婆罗门毗舍首陀乱心作恶。于国土中移转日月。错易年岁使国荒乱。寒暑失所变改时节。降恶风雨谷米不登。及坏一切树木果子。愿我悉能调伏教化令住三乘。我亦不害夺其命根。同其受身。与共软语言谈戏笑。以三乘法而教化之令离恶道。若有众生远离善法。行身口意不善之业。舍是身已生三恶道。或有杂作善恶诸业。是人舍命则受鬼身。是故尔时。恶鬼滋多善鬼鲜少。是故我欲调伏恶鬼现受是身。亦令刹利婆罗门毗舍首陀远离恶心。善男子。有金刚槌咒。以是咒力。一切恶鬼于彼四姓不能为恶。善男子。若有都邑城村聚落有是咒处。一切恶鬼无能为也。是处众生皆修慈心。远离一切不善之事恶病恶雨亢旱斗诤。乃至鸟兽皆生善心。远离一切诸恶怖畏。我今于此十方佛前发大誓愿欲说是咒。尔时释迦如来告旷野鬼善男子。十方诸佛。今已施汝神通之力。便可说之。时旷鬼即起合掌而说咒曰

豆摩(一)豆摩(二)陀摩(三)陀摩(四)豆摩(五)豆摩(六)那那罗(七)尼罗(八)尼罗(九)究吒尼(十)究吒尼(十一)摩诃究吒尼(十二)吒吒吒株(十三)摩诃吒吒吒(十四)阿娑婆(十五)阿比(十六)利尼(十七)利尼(十八)摩诃利尼利尼(十九)利弥(二十)利弥(二十一)利弥(二十二)陀利蓰(二十三)摩诃利蓰(二十四)首流首流(二十五)摩诃首流首流(二十六)首流多(二十七)摩诃首流首流(二十八)郁究摩(二十九)仇摩(三十)仇摩(三十一)仇摩那(三十二)利弥(三十三)利弥(三十四)希利(三十五)希利(三十六)希利(三十七)希利(三十八)希利(三十九)希利(四十)希利(四十一)希利(四十二)希利(四十三)希利(四十四)希利(四十五)希利(四十六)尼弥(四十七)尼弥(四十八)希尼(四十九)希尼(五十)牟尼(五十一)牟尼(五十二)牟提尼(五十三)娑逻娑逻娑逻吒(五十四)路迦那利也(五十五)只儜(五十六)只儜(五十七)时儜力沙婆(五十八)时那(五十九)时那(六十)时那逻沙婆(六十一)莎呵

世尊。随有国土诵此咒处。彼诸恶鬼虽闻是咒。于诸众生。犹怀恶心凶暴难伏。不受法教不起慈心者。我为是等诸恶鬼故。更说此咒以调伏之

阿车(一)阿车(二)牟尼(三)牟尼(四)尼休休(五)牟尼(六)牟尼(七)摩那逻沙婆(八)休休(九)阿尼罗那荼(十)阿多但荼(十一)阿多阿提(十二)流咤(十三)希尼(十四)希尼(十五)希利(十六)希利(十七)希利(十八)希利(十九)希利(二十)希利(二十一)希利(二十二)希利(二十三)郁仇摩(二十四)仇摩(二十五)仇摩(二十六)仇摩(二十七)希梨(二十八)希梨(二十九)希梨(三十)尼利(三十一)尼利(三十二)摩诃尼梨(三十三)三牟陀呼呿(三十四)阿吒(三十五)阿吒(三十六)阿吒(三十七)陀罗咩呿(三十八)叉[(口*皮)/女]呿(三十九)叉[(口*皮)/女]呿(四十)卑利痴比(四十一)阿波(四十二)泯阇(四十三)婆由(四十四)阿迦奢(四十五)啅啅啅(四十六)究脾(四十七)婆穷脾(四十八)阿叉穷脾(四十九)视靴穷脾(五十)萨多伽穷脾(五十一)逻阇穷脾(五十二)萨多兜穷脾(五十三)莎呵

    大方等大集经宝幢分中还本品第十三

于是十方无量诸佛。各各欲还本佛世界。其地即时六种震动。上虚空中雨种种华。微妙伎乐不鼓自鸣。种种诸香而以供养一切大众。悉共合掌礼敬诸佛。尔时梵天白月香佛言。世尊。是谁神力成几福德。于未来世能信受持读诵书写如是经典。梵天。皆是十方现在诸佛。本愿力故破坏魔众。除国霜雹暴风恶雨。护持正法。为调众生宣示正道。亦是诸佛本愿力故。来世众生成就十法。能于未来护持正法。是人亦为诸大所护梵天。若有人能具足念心善意方便。是人则能拥护正法。不贪五欲常修习空。忍辱如地得深大忍。以四摄法摄取众生。此彼无碍。修行清净菩提道行宝幢三昧。如是之人。于未来世能护正法。书写受持读诵解说。是人舍身得见十方现在诸佛及比丘僧诸菩萨等。亦闻诸佛所说妙法。闻已即得圣人喜乐。灭除一切不善之法。得生清净诸佛国土。常闻演说大乘经典。终不生于五滓世界。常得亲近娑婆世界如是诸佛。是人于后余五十年。以佛力故。则能护持如来正法。尔时释迦牟尼佛告梵天言。随是经典流布之处。其土则无一切恶事恶雨疾病。受者听者身无患苦。衣食无乏。尔时华幢佛告诸大众。若以满此娑婆世界微妙七宝施十方佛。不如有人于佛灭后余五十年受持读诵书写是经。所得福多先福德。佛复告大众。假使有人。以恒河沙等上妙七宝施十方佛。不如有人于佛灭后余五十年受持读诵书写是经所得福多。佛说是已。诸天世人闻已欢喜信受奉行

大方等大集经卷第二十一

安伽逻(一)安伽逻(二)半伽逻(三)婆婆伽逻(四)婆逻[(口*皮)/女]伽逻(五)婆蛇比呵(六)曼啰婆毗(七)阿[口*企](八)阿呿婆泠(九)题咩(十)度慕泯(十一)翘婆知(十二)翘由离(十三)三摩婆阿尼(十四)三摩多婆提泠(十五)阿弥(十六)阿移(十七)陀摩翘阇(十八)弥啰[少/兔]破梨(十九)破罗波泯(二十)伽泞(二十一)伽耶婆[這-言+羼]泯(二十二)希利(二十三)希提(二十四)希罗(二十五)翘希罗(二十六)谵婆提(二十七)婆迦斯(二十八)咤迦泯(二十九)咤伽嘙罗泯(三十)伽那嘙呵泯(三十一)希利泯(三十二)尸利泯(三十三)频地利嘙泯(三十四)具婆希(三十五)酬泠(三十六)弥啰酬泠(三十七)酬蓰(三十八)阿其离(三十九)阿婆弥(四十)婆利也(四十一)多哆且(四十二)富流(四十三)希利(四十四)战地离(四十五)摩陀弥(四十六)陀弥(四十七)究周流(四十八)牟周流(四十九)阿遮吒(五十)至利(五十一)至弥利(五十二)遮婆呵(五十三)周婆(五十四)周娄(五十五)迷啰嘙呵(五十六)究娄(五十七)婆罗究洞(五十八他公切)究侗(五十九)摩诃婆逻娑(六十)[豆*斤]侗(六十一)[豆*斤]侗(六十二)摩诃萨哆希力陀蛇(六十三)富罢(六十四)修富罢(六十五)度摩波利呵利(六十六)呵婆移(六十七)流之泞(六十八)迦逻叉(六十九)阿陀摩兜(七十)比婆呵(七十一)提提利(七十二)摩摩利(七十三)波舍呿(七十四)或或逻(七十五)路迦比那蛇迦(七十六)婆时利(七十七)嘙时罗陀吟(七十八)婆时离陀提(七十九)斫迦罗婆时离(八十)遮居离(八十一)遮迦罗嘙提(八十二)陀吟(八十三)陀吟(八十四)婆泠(八十五)牟离咤吟(八十六)休休吟(八十七)多伽频婆吟(八十八)舍利奢(八十九)流流周(九十)之利周利(九十一)牟吟慕陀吟(九十二)慕荼泞(九十三)慕荼泞(九十四)伽伽罗尼(九十五)牟荼泞(九十六)散婆逻牟荼泞(九十七)提提罗蛇尼(九十八)摩醯首罗逻蛇尼(九十九)律师婆尼(一百)陀逻嘙至(百一)战荼逻素咩(百二)萨婆萨写阿提[口*悉]多(百三)车陀兜嘙阿那(百四)摩弥尼(百五)嘙逻逻提(百六)乌阇其离(百七)比比那(百八)嘙那诃逻(百九)复佛吟(百一十)仇留(百一十一)仇留(百一十二)牟留(百一十三)牟留(百一十四)希希(百一十五)希希(百一十六)阿逻(百一十七)阿逻(百一十八)迦迦荼嘙呵(百一十九)希希多(百二十)阿由那(百二十一)鞬荼谵婆斯(百二十二)竭陀尼(百二十三)阿嘙阿呵泞(百二十四)末力伽比流(百二十五)破罗萨哆(百二十六)阿路沙嘙提(百二十七)希利希利(百二十八)夜哆婆阇蛇(百二十九)莎其罗(百三十)夜哆波兰遮(百三十一)希力陀婆呵(百三十二)萨多波利嘙嘙(百三十三)末力伽毗卢呵尼(百三十四)阿遮逻佛提(百三十五)陀蛇波罗逻遮波遮蛇(百三十六)宾荼希力陀蛇(百三十七)战陀逻嘙逻泞(百三十八)阿遮吟输陀泞(百三十九)波逻冀逻摩力伽(百四十)伊逻(百四十一)婆逻冀逻摩力伽(百四十二)伊逻(百四十三)伊利吟(百四十四)波腊脾(百四十五)婆罗嘙逻泯(百四十六)萨婆逻多哆(百四十七)萨多[少/兔]竭脾(百四十八)阿那嘙逻那伏律泯(百四十九)阿罗荼(百五十)安伽吟(百五十一)舍弥尼(百五十二)比婆罗婆俞希(百五十三)阿希多(百五十四)阿婆希(百五十五)尼逻嘙蛇嘙(百五十六)阿之罗末力伽(百五十七)逻嘙那(百五十八)罗仇婆吟(百五十九)犁勒那朋舍(百六十)陀摩伽蛇(百六十一)阇罗战陀(百六十二)三牟陀罗嘙提(百六十三)摩诃复多脾比伽嘙三牟陀(百六十四)陀罗尼牟陀离那(百六十五)摩呿牟陀逻(百六十六)娑逻婆提(百六十七)思比陀牟陀(百六十八)阿嘙多尼(百六十九)婆婆多尼(百七十)慕迦逻(百七十一)比豆多逻斯那(百七十二)厕提牟地离都思(百七十三)移迦之(百七十四)卑利痴比迦蛇(百七十五)嘙呵嘙呵冀荼(百七十六)迦嘙咤(百七十七)尼罗波罗提多希力陀陀蛇(百七十八)三牟陀多陀罗尼(百七十九)陀罗(百八十)陀罗(百八十一)陀罗(百八十二)弹提罗(百八十三)弹提罗休尼罗萨婆希力陀蛇勿陀离都思阇咤(百八十四)阇婆咜(百八十五)阇呿[(口*皮)/女]咤(百八十六)修摩提(百八十七)摩提(百八十八)摩诃复多勿陀离多(百八十九)易翘之散迦罗(百九十)婆荼蛇多那尼(百九十一)首力多复多(百九十二)伊弥尼弥尼(百九十三)婆遮尼(百九十四)输沙萨遮尼(百九十五)牟地离多遮利也何提咩那(百九十六)婆比哆(百九十七)阿那若哆(百九十八)摩诃富若三牟遮蛇[(口*皮)/女]多罗摩呵加留尼迦牟地离多(百九十九)萨婆三藐波罗提般(二百)至逻阇罗兜(二百一)萨[(口*皮)/女]尼梨(二百二)萨婆牟尼婆罗沙娑摩诃迦留那三摩提若那若那婆离难(二百三)咩啰多竭毗(二百四)比利也比利也(二百五)婆梨那提[口*悉]多(二百六)萨婆复都波蛇(二百七)娑呵(二百八)大方等大集经卷第二十二

        北凉天竺三藏昙无谶译

    虚空目分第十之一初声闻品第一

尔时世尊故在欲色二界中间大宝坊中。与无量比丘僧诸大菩萨。围绕说法。时舍利弗目揵连等。出家未久。以舍利弗目连因缘。说声闻法杂四真谛。尔时众中有诸人辈。本是外道。诸根闇钝自谓有智。起大憍慢。增长色慢欲慢无明慢胜慢非法慢。未得第二第三第四沙门果证。是故如来为如是等。宣说中道。为离如是恶烦恼故。如来说是中道义时。如是诸人各各论说断见我见。尔时世尊即作是念。哀哉诸人本外道故。虽入佛法犹生大慢。于未得中而生得想。于未知中而生知想。于如来法中而不修行。虽顺四谛而不能得四无碍智。乃至不得第四果证。尔时世尊二手举捉瞻婆华鬘。发大誓愿。以愿力故。于华鬘中出生四宝。一帝释宝。二天光宝。三金刚光宝。四胜诸光宝。一一宝中出大光明。遍照此间娑婆世界。光明出已掷之虚空。时华鬘中说是偈言

  虽除须发不去结　　被服染衣不离染
  示佛为师不随教　　如是之人污大众
  如来宣说正法时　　而复不能至心听
  是人不得真实义　　亦不能离诸烦恼
  若能睹见实法性　　是能破坏无明慢
  若有亲近善知识　　是人速得甘露味
  若能呵责于生死　　是则能得到彼岸
  是人具足戒多闻　　亦具禅定智慧聚
  若人欲坏烦恼魔　　远离阴魔及死魔
  摧伏天魔诸眷属　　常当亲近无上尊

说是偈已。声闻弟子有憍慢者。咸作是念。如来知我并有污心。是故为我说如是偈。即时心中生大惭愧。及四天下佛诸弟子。亦复如是生惭愧心。于一念顷悉来集会。尔时无量百千万亿声闻大众悉来聚集。于是佛知众会已定。即为宣说杂四真谛。时此宝鬘直往南方。过九万二千恒河沙等诸佛世界。彼有世界名金刚光藏。其土众生具足五滓。有佛世尊。号金刚光明功德如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。亦为四众宣说如是杂四真谛法。而彼会中有诸菩萨声闻四众比丘比丘尼优婆塞优婆夷。见是宝鬘大光明已。观察四方。仰见宝鬘在佛顶上虚空中住。即白佛言。世尊。如是宝鬘从何处来。谁之所遣。彼佛答曰。善男子。北方去此。九万二千恒河沙等诸佛世界。彼有世界名曰娑婆。有佛世尊号释迦牟尼如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。亦为具足五滓众生。宣说开示杂四谛法。如我今于此土无异。善男子。彼佛世界所有众生甚大痴闇粗犷轻躁。生大憍慢多作恶业难调难解。是故释迦牟尼如来。为此大集于大集中演说正法。为坏如是诸大恶事。彼世界中所有众生。于未得中而作得想。于未证中而作证想。于未修中而作修想。是故彼佛为大众说法。如法修行。为坏如是大憍慢故。为得尽智及无生智。将欲宣说虚空目法行。为得声闻缘觉佛果。欲开如来无上法藏。是故彼佛遣此宝鬘。从我索欲我今与之。并欲以是法目陀罗尼赠彼为信。能作无量微妙大明能干一切诸恶烦恼。能持一切所闻不忘能净一切心之垢污。能护一切诸善禁戒。能入一切大智慧中。能护一切无上三昧。能护己心生他喜心。受持圣法远离诸病。所求之法如愿即得。增长一切资生所须。亦能长养一切善根。能调恶王及以四姓。诸恶鬼神鸟兽水虫。护持一切诸善根本。能得如来一切诸法。乃至能得十八不共。是故我今。欲遣如是法目陀罗尼至彼世界与释迦如来。即告金刚山童子言。善男子。汝可往彼娑婆世界称我名字问讯彼佛。金刚光明功德如来。以此法目陀罗尼门远赠世尊。金刚山童子言。世尊。善哉善哉。我亦欲往礼觐彼佛。并欲启受所未曾闻虚空目法门。尔时复有六万亿菩萨摩诃萨八十千亿声闻大众。同声而言。世尊。我等亦欲诣彼世界礼觐彼佛。并欲启受所未曾闻虚空目法门。唯愿如来加我神力令得往返。彼佛答言。善哉善哉。诸善男子。宜知是时。是金刚山童子者。能调伏汝。即是汝等善知识也。尔时彼佛。即告金刚山童子言。善男子。谛听谛听。我当为汝宣说如是法目陀罗尼。即说咒曰

阿[(口*皮)/女](一)阿[(口*皮)/女](二)阿[(口*皮)/女](三)若那蛇咤(四)摩诃摩呿(五)三摩呿呿[(口*皮)/女][(口*皮)/女](六)树提(七)阿咃(八)那[(口*皮)/女]那蛇泞(九)佛阇罗哆(十)安豆赖哆(十一)阇逻迦哆(十二)阿那耨德叉(十三)凡浮婆(十四)那婆荼婆(十五)勒叉卢战那(十六)莎致呿婆(十七)陀逻尼叉阇(十八)波逻迦啅婆(十九)鞞那叉(二十)婆那鞞吼(二十一)阿那迦呿(二十二)战荼咩修(二十三)波陀呿多(二十四)修卢遮那(二十五)卢战那婆(二十六)卢遮蛇若婆婆斯(二十七)莎呵(二十八)

善男子。汝当受持读诵书写是陀罗尼。往彼世界问讯释迦牟尼如来。如我辞曰。四部弟子乐受法不。四姓之人能供养不。众生之心不浊乱不。常能亲近于如来不。复能尊重赞叹佛不。增广流布佛正法不。金刚光明功德如来。以此法目陀罗尼门远赠世尊。能作大明。干焦一切诸恶烦恼。乃至获得如来十八不共之法。时金刚山童子。受持读诵书写如是陀罗尼已。告诸大众。若欲往彼娑婆世界觐见释迦牟尼如来。并欲启受所未曾闻虚空目法门者。应当远离一切色想。亦莫念于分别之相。常当修集虚空之相。远离一切取舍等相。放舍一切尘劳等相。解诸结缚专念虚空。尔时大众咸作是言。善哉善哉。善男子。即前礼佛礼已。系念观虚空相。于一念顷即来至此娑婆世界。觐见释迦牟尼如来。头面礼足供养恭敬。尊重赞叹右绕三匝。却在一面合掌而立。是时宝鬘复往西方。过八万亿诸佛世界。彼有世界。名曰慧闇。具足五滓。有佛世尊。号曰智幢如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。亦为四众宣说如是杂四谛法。彼时会中有诸菩萨声闻四众比丘比丘尼优婆塞优婆夷。见是宝鬘大光明已。观察四方。仰见宝鬘在佛顶上虚空中住。即白佛言。世尊。如是宝鬘从何处来。谁之所遣。彼佛答言。善男子。东方去此。八万亿诸佛世界。彼有世界名曰娑婆。具足五滓。有佛世尊。号释迦牟尼十号具足。亦为四众宣说开示杂四谛法。如我今于此土无异。乃至欲开如来法藏。是故彼佛遣此宝鬘。从我索欲我今与之。并欲赠彼净目陀罗尼。能作大明干焦烦恼。乃至能得如来十八不共之法。是故我今。欲遣如是净目陀罗尼至彼世界赠彼如来。彼佛即告胜幢童子。汝可往彼娑婆世界称我名字问讯彼佛。并以如是净目陀罗尼门。远相赠遗。时彼众中复有无量菩萨声闻。同声而言。善哉世尊。我等亦欲诣彼世界礼觐彼佛。并欲听受所未曾闻虚空目法门。乃至彼佛即说咒曰

蜜呵(一)蜜呵(二)蜜呵(三)蜜呵(四)阿婆蜜呵(五)萨多蜜呵(六)修婆舍蜜呵(七)那婆蜜呵(八)修破婆(九)阿能伽提比叉(十)阇蛇私罗(十一)那罗乌难(十二)呿婆波啰(十三)那逻逻禅(十四)修叉(十五)翅奢私罗(十六)阿婆罗私摩(十七)摩诃厕提阇那(十八)阿那叉陀(十九)阿婆呿伽(二十)那由多文陀(二十一)娑婆逻(二十二)阿若伽伽(二十三)萨遮首留婆竭婆车那(二十四)莎呵(二十五)

善男子。汝当受持读诵书写是陀罗尼。往彼世界。乃至一面合掌而立。是时宝鬘复至北方。过九万九亿诸佛世界。彼有世界名曰为常具足五滓。有佛世尊。号发光功德。十号具足。亦为四众宣说开示杂四谛法。而彼会中有诸菩萨声闻四众比丘比丘尼优婆塞优婆夷。见是宝鬘大光明已。观察四方。仰见宝鬘在佛顶上虚空中住。即白佛言。世尊。如是宝鬘。从何处来。谁之所遣。彼佛答言。善男子。南方去此。九万九亿诸佛世界。彼有世界名曰娑婆。具足五滓。有佛世尊。号释迦牟尼十号具足。亦为四众宣说开示杂四谛法。如我今于此土无异。乃至欲开如来法藏。是故遣此四宝华鬘。从我索欲我今与之。并欲赠彼光目陀罗尼。能作大明干焦烦恼。乃至能得如来十八不共之法。是故我今。欲遣如是光目陀罗尼。至彼世界赠彼如来。彼佛即告胜意童子。善男子。汝可往彼娑婆世界称我名字问讯彼佛。以是光目陀罗尼远相赠遗。时彼众中。复有无量菩萨声闻。同声而言。善哉世尊。我等亦欲诣彼世界礼觐彼佛。并欲启受所未曾闻虚空目法门。乃至彼佛即说此陀罗尼

阇婆摩(一)阇婆摩(二)阇婆摩(三)阿拘卢吒(四)比婆阇婆(五)摩诃陀摩(六)呿婆(七)阿逻阇(八)散菩陀若呿婆(九)阿逻阇[(口*皮)/女]婆(十)三牟婆逻[(口*皮)/女]婆(十一)三摩逻[(口*皮)/女][(口*皮)/女](十二)阇[(口*皮)/女][(口*皮)/女][(口*皮)/女][(口*皮)/女](十三)阇提叉蛇婆婆(十四)摩希阇婆涅畔陀(十五)比牟遮婆婆(十六)那蛇那婆婆(十七)遮颰婆婆(十八)输卢多婆婆(十九)其浪那婆婆(二十)靴婆婆(二十一)迦蛇婆婆(二十二)质多婆婆(二十三)三牟陀婆婆(二十四)提逻那婆婆(二十五)嗔那修留提婆婆(二十六)莎呵

善男子。汝当受持读诵书写是陀罗尼往彼世界。乃至一面合掌而立。是时宝鬘复至东方。去此六万千亿佛土。彼有世界名曰宝顶。具足五滓。有佛号曰宝盖光明功德。十号具足。亦为四众宣说开示杂四谛法。而彼会中有诸菩萨声闻四众比丘比丘尼优婆塞优婆夷。见是宝鬘大光明已。观察四方。仰见宝鬘在佛顶上虚空中住。即白佛言。如是宝鬘从何处来。谁之所遣。彼佛答言。西方去此。六万千亿诸佛世界彼有世界。名曰娑婆。具足五滓。有佛世尊。号释迦牟尼十号具足。亦为四众宣说开示杂四谛法。如我今于此土无异。乃至欲开如来法藏。是故遣此四宝华鬘。从我索欲我今与之。并欲赠彼圣目陀罗尼。能作大明干燋烦恼。乃至能得如来十八不共之法。是故我今欲遣如是圣目陀罗尼至彼世界赠彼如来。即告虚空声童子。善男子。汝可往彼娑婆世界称我名字问讯彼佛。并以如是圣目陀罗尼远相赠遗。乃至复有无量菩萨声闻大众。同音而言。善哉世尊。我等亦欲诣彼世界礼觐彼佛。并欲启受所未曾闻虚空目法门。乃至彼佛即说此陀罗尼

阿罗摩(一)阿罗摩(二)阿罗摩(三)阇蛇逻阇(四)首路罗阇(五)伽阇手(六)[(口*皮)/女]逻遮罗(七)阿尼遮(八)阿呿莎逻(九)呿伽莎阇那(十)那乌诃(十一)那逻咃(十二)那乌诃(十三)摩醯首逻遮摩(十四)阿摩昵(十五)阿蛇莎利逻(十六)遮[颱-台+秋]遮摩(十七)遮[颱-台+秋]散遮[颱-台+秋]那(十八)那[(口*皮)/女](十九)那婆摩阇(二十)阿[(口*皮)/女]呿[(口*皮)/女](二十一)车婆那婆呿伽禅头(二十二)娑罗战陀罗(二十三)摩醯首逻尼罗那[(口*皮)/女](二十四)萨陀摩叉蛇(二十五)莎呵

善男子。汝当受持读诵书写是陀罗尼往彼世界。乃至一面合掌而立。时四童子变此世界。地平如掌。香华幡盖七宝具足为供养佛。一切天宫阿修罗宫悉为震动。诸天悦豫多受喜乐。咸以香华七宝幡盖种种伎乐供养于佛。时四童子作如是等。供养佛已。上升虚空高七多罗树。各执四宝说偈赞叹

  佛是清净大法王　　为诸众生说甘露
  于诸众生心如地　　大宝商主愍一切
  为众生说清净法　　令离诸苦及烦恼
  如来心等如虚空　　其语微妙知真道
  具足戒禁及智慧　　永灭烦恼降甘露
  为渴法者出恶世　　智炬大明能坏闇
  虽无修集八圣道　　及以证得解脱者
  如来犹故生怜愍　　施诸人天净法眼
  能度众生生死岸　　能施无上七财宝
  能令众生悔生死　　具修三十七助道
  法宝久失佛今示　　是故得名无上尊
  四方众生已大集　　唯愿怜愍转法轮

尔时一切无量大众心生欢喜。各作是言。如是无量无边众生从何处来。威仪清净具无量德。惭愧智慧皆悉成就。我从昔来未曾睹见如是妙色五通大仙。尔时世尊告憍陈如比丘。憍陈如。四方多有无量菩萨。悉来集会。为听法故。今当至心清净其意。尔时世尊以微妙音告四童子。诸善男子。善来甚快。从何方面何处而来。时四童子敬礼佛足周匝围绕。尔时金刚山童子言。世尊。南方去此。九万二千亿恒河沙等诸佛世界。彼有世界。名金刚光藏。具足五滓。有佛世尊。号金刚光明功德如来。十号具足。今现在为诸众生。宣说开示杂四谛法。彼佛劝我至此世界。问讯世尊。并欲听受虚空目法门。世尊。彼金刚光明功德如来。致敬殷勤。问讯世尊。并遗如是陀罗尼。能作大光明干焦烦恼。乃至能得如来十八不共之法。即于佛前说如是咒。乃至四童子亦复如是。说是咒已。其地即时六种震动。一切龙王各作是言。我等亦当共至佛所。尔时东方有二龙王。一名牛护。二名宝护。是二龙王与六万龙王。南方亦二。一名为月。二名婆修。与七万龙王来至佛所。头面敬礼。前白佛言。世尊。我等皆能受持读诵书写如是法目陀罗尼。若有比丘比丘尼优婆塞优婆夷。受持读诵书写如是法目陀罗尼者。我等皆当诚心守护。西方北方亦复如是。尔时世界一一各有十万龙王。来至佛所头面礼敬。尔时龟兹国土有一龙王。名曰海德。是阿那婆达多龙王弟。与九万龙王。于阗国土有一龙王。名乐藏宝。亦是阿那婆达多龙王弟。与万八千龙王。波罗越国有一龙王。名曰山德。亦是阿那婆达多龙王弟。与二万龙王。师子国土有一龙王。名曰宝藏。与四万八千龙王。毗茶国土有一龙王。名曰长发。与四万二千龙王。念蜜奢山有一龙王。名曰婆修吉。与八千龙王。乌苌国土有一龙王。名阿钵罗罗。与二万五千龙王。乾陀罗国有一龙王。名伊罗钵多。与三万龙王。真丹国土有一龙王。名曰三角。与万八千龙王。难陀龙王。优波难陀龙王。亦与无量龙王。共至佛所头面礼敬。白佛言。世尊我等皆能受持读诵书写如是陀罗尼门。乃至不忘不失一字。佛言。善哉善哉。善男子。汝等真实能护正法。尔时世尊。告正语天女。天女。汝能守护我正法不。世尊。如来在世及灭度后。是陀罗尼流布之处我当守护。有受持者随其所求我当与之。若复有欲见我身者。我当现之。世尊。若有比丘比丘尼优婆塞优婆夷欲见我者。当净其身持戒精进。于一日中三时洗浴。断食三日独在静处若佛像边。若在塔中。若处静室。以妙香华种种幡盖及诸味浆供养于佛。面正东向读诵如是陀罗尼句

[(口*皮)/女]吒置(一)[(口*皮)/女]吒置(二)休娄(三)休娄(四)屯豆娄(五)屯豆娄(六)呿吒(七)呿吒(八)比莎诃

是时四众。诵是陀罗尼已我当随诸四众之所愿。求我悉当令一切成就。若我不来。即为欺诳十方诸佛。亦莫令我成阿耨多罗三藐三菩提。尔时佛告罗睺阿修罗王。毗摩质多阿修罗王。毗娄遮那阿修罗王。我今以此净目陀罗尼。付嘱汝等。何以故。汝有大力。若有众生不信三宝。能令信故。诸阿修罗言。善哉世尊。我等护持。若有四众比丘比丘尼优婆塞优婆夷。若佛在世。若灭度后。受持读诵书写广说是陀罗尼。我于是等能施八事。何等为八。一者健行。二者乐听受法。三者心无怖畏。四者常明无闇。五者善愿具足。六者解脱。七者具足辩才。八者善法增长。世尊。若阿修罗父母兄弟妻子眷属。恼是人者我等当治。若我不于此世界中护佛法者。则为欺诳十方诸佛。尔时世尊观四众已。告憍陈如比丘。憍陈如。一切大众甚乐闻法。无量世界无量众生。悉为法故来集于此。咸皆欲知法行方便。成大智慧。远离贪欲一切烦恼。真实了知法行方便。时憍陈如白佛言。善哉世尊。诚如圣教。世尊。四方世界。无量菩萨。悉持四佛所与欲来并欲启受虚空目法行。今正是时唯垂怜愍。为众生故而宣说之。世尊。所言法行。法行比丘。云何名为法行比丘。唯愿世尊。分别演说法行比丘。佛言憍陈如。至心谛听当为汝说。若有比丘。读诵如来十二部经。谓修多罗。乃至优婆提舍。是名乐读。不名法行。复有比丘。读诵如来十二部经。乐为四众敷扬广说。是名乐说。不名法行。复有比丘。读诵如来十二部经。能广演说思惟其义。是名思惟。不名法行。复有比丘。受持读诵十二部经。演说思惟观其义理。是名乐观。不名法行。憍陈如。若有比丘能观身心。心不贪着外一切相。谦虚下意不生憍慢。不以爱水溉灌业田。亦不于中种识种子。灭觉观心境界都息。永离烦恼其心寂静。如是比丘。我则说之名为法行。如是比丘。若欲获得声闻菩提缘觉菩提如来菩提。即能得之。憍陈如。如工陶师埏埴调泥。置之轮上随意成器。法行比丘亦复如是。憍陈如。若有比丘修法行者。当观三事。一者身。二者受。三者心。观三事已得二种智。一者尽智。二者无生智。憍陈如。云何尽智。云何无生智。知尽烦恼名为尽智。知尽有支名无生智。复次无行行智名曰尽智。无行果智名无生智。尽诸使智名曰尽智。尽烦恼智名无生智。复次知尽诸行名曰尽智。尽一切有名无生智。分别尽物是名尽智。知诸缚解名无生智。知尽根界名曰尽智。知尽缘界名无生智。不觉观烦恼名曰尽智。不觉观果报名无生智。复次尽三地智名曰尽智。尽一切漏名无生智。复次我生已尽梵行清净。名曰尽智。更无余有名无生智。如是二智即名一智。亦名一行知于三道。若有比丘能断三道。是名法行。能作是观。是观心受。云何比丘能观察身。若有比丘观息出入。是名观身观受观心。云何名为观息出入。息入出者。名阿那波那。入名阿那。出名波那。观于出入如门如向。若有比丘能如是观。是名法行。若有比丘能观能数。随息入出冷暖长短。若遍满身。系心鼻端。能观新故。分别诸相能观生坏。求舍摩他善入于定。亦能观察息之粗细。乃至观于内身。身作身想。是名比丘修于法行。憍陈如。修数息时获得二事。一者离恶觉观。二者观息相貌。修集随时亦得二事。一者专念念心。二者离善觉观。观于冷暖亦得二事。一者分别出入。二者观心数相。修观身时亦得二事。一者身轻。二者心轻。转观生灭亦得二事。一者知一切法是无常相。二者知一切法是无乐相。善男子。法行比丘念入出息系心一处。云何数减。二数为一。三数为二。乃至十数为九是名数减。云何数增。一数为二。乃至九数为十。是名数增。何故修增。坏一切觉观故。得初禅时观息入出。及以心相。初禅五支。一觉。二观。三离生喜。四者受乐。五者定。具五支时离贪恚痴。若有比丘具是五支。是名法行。远离五事成就五事。修集梵行成大功德。憍陈如。若有比丘能得二禅。名为法行。若有比丘观息出入。系心一处远离喜乐。得第三禅不喜不乐。何以故。一心系念息入出已。远离喜乐得第四禅。若有比丘观息入出则观五阴。若观五阴是名法行。若比丘见一切法行生灭。乃至见一切烦恼生灭。是名法忍。若比丘见眼空。乃至见意识空。是名空忍。若比丘见眼无相。乃至见意识无相。是名无相忍。若比丘不愿于眼乃至意识。是名无愿忍。若比丘观苦异乐异不苦不乐异。是名中谛忍。若为众生行于生死。如是名为随上谛忍。云何随忍随根随力随于觉观乃至随涅槃。于如是法心不著者。是名信忍。是名为信。不名信根。若摄身心不令造恶。是为精进。不名进根。若能专念如是等法。是名为念。不名念根。心心数法能系一缘。是名为定。不名定根。若能不观如是等相。是名为慧。不名慧根。若观如是无根。是名法行

憍陈如。若有比丘观于顶法世第一法。观三解脱空无相愿无常苦空。是名法行。是名空三昧。如是三昧。缘无受命。缘无自在。无相三昧。缘尽缘坏。缘灭缘厌。无愿三昧缘于甘露。非甘露行。有甘露行非缘甘露。有空三昧缘于甘露。非甘露行。有甘露行非缘甘露。无相三昧缘于甘露。非甘露行。有甘露行非缘甘露。憍陈如。若有比丘缘慧灭庄严入无愿三昧。是名缘于甘露非甘露行。若有比丘缘慧灭而得解脱。名甘露行非缘甘露。空与无相亦复如是。憍陈如。若有比丘能如是观。是名法行。憍陈如。若有比丘观受观心。是名法行。何以故。能坏我见二十种故。憍陈如。断见我见各有五种。色断乃至识断。是名五断见。色我乃至识我。是名五我见。憍陈如。五种断见分别则有四十四种。十六种说想。八说无想。八说非想非非想。六说种种想。六种说断。是名四十四种。我见分别十八。四定说我。四种说边。四说异事。六说无求三昧。是名六十二见。二十我见因缘。能生四百四种烦恼为离如是诸烦恼故。观于身心是名法行。如是比丘能观身心。憍陈如。云何八人。云何决定。憍陈如。断见之人言一念断。常见之人言八忍断。是二种人俱得决定后离烦恼俱亦无妨。憍陈如。能得八忍是名八人。得十六心是名决定。是名如法。憍陈如。若有比丘成出入息。即得八人名。亦名决定。憍陈如。若有比丘成就数息。即得信根乃至慧根。若得五根。即得世间第一法。如是比丘。能破一切疑网之心。是名真实修集圣行。若有比丘成就苦智。则断十种烦恼。是名修初无漏心观。尔时次第观无愿三昧。观无愿时修三十七助道之法。是名无漏定智。得苦法忍苦法智集法忍集法智。尔时观于色界五阴无色界四阴。如欲界苦。色无色界亦复如是。如是观已。断色无色十八种烦恼。十八种断已。作是思惟。如是诸苦从何业来。谁之所造作。是观已。了知是苦从爱因缘。我若不拔如是爱根必当生苦。是故观集。作是观已断七烦恼。观欲界集已。色无色界亦复如是。如是观已。得比忍比智。作是观时断十二烦恼。憍陈如。具八忍者是名见法。断三界集已。复作是观。何因缘故断于苦集。为安乐故。夫安乐者即是灭谛。尔时初观欲界灭谛。得灭法忍断七烦恼。色无色界亦复如是。作是观已得灭比忍灭十二烦恼。复作是观。何因缘故得是比忍。因修八道。以八正道力故。知欲界苦集灭谛色无色界苦集灭谛。尔时次生道法忍。得已能断八种烦恼。尔时复观色无色界。得道比忍。断十四烦恼。以修集故。远离八十八种烦恼。是名决定得须陀洹果。是名十六心。是名必得菩提。是七往来断一切苦。憍陈如。有人从信决定。有人从法决定。有人从一生得须陀洹果。乃至得阿罗汉。有人入信根乃至慧根。有人修定。有人修慧。有人得初禅乃至四禅。入决定观。观一切行无常次第生灭。远离一切凡夫之法。有人观一切行无常苦空不净。不得自在无有寂静。从缘而生从缘而灭。作是观已。得寂静灭谛。是名比丘如法而行。憍陈如。如来了知一切众生诸根利钝。亦知一切众生心性诸烦恼性。是名如来随应众生而为说法。随诸烦恼宣说对治。是故得名萨婆若智

憍陈如。我涅槃后有诸弟子。受持如来十二部经。书写读诵颠倒解义。颠倒宣说。以倒解说。覆隐法藏。以覆法故名昙摩鞠多憍陈如。我涅槃后我诸弟子。受持如来十二部经读诵书写。而复读诵书说外典。受有三世及以内外。破坏外道善解论义。说一切性悉得受戒。凡所问难悉能答对。是故名为萨婆帝婆。憍陈如。我涅槃后我诸弟子。受持如来十二部经书写读诵。说无有我及以受者。转诸烦恼犹如死尸。是故名为迦叶毗部。憍陈如。我涅槃后我诸弟子。受持如来十二部经。读诵书写。不作地相水火风相虚空识相。是故名为弥沙塞部。憍陈如。我涅槃后我诸弟子。受持如来十二部经。读诵书写。皆说有我不说空相。犹如小儿。是故名为婆嗟富罗。憍陈如。我涅槃后我诸弟子。受持如来十二部经。读诵书写。广博遍览五部经书。是故名为摩诃僧祇。善男子。如是五部虽各别异。而皆不妨诸佛法界及大涅槃。云何名为随于信行。若信三宝具足信根。从信根因缘入于决定。得须陀洹果斯陀含果阿那含果。过色无色界。得阿罗汉果。从信得解名信解脱。亦名一分。亦名身证。名慧解脱。是名随信行。憍陈如。云何名为随于法行。若有从法入于决定。具足慧根。得须陀洹果斯陀含果阿那含果。过色无色界。得阿罗汉果。是名见到二分解脱。亦名身证慧得解脱。心得解脱得灭尽定。是故名为二分解脱。是名无学解脱。是名法行。是名成就观身乃至成就法法观。是名成就毗婆舍那及奢摩他云何名为奢摩他。奢摩他者。名之为灭。能灭贪心嗔心乱心。名奢摩他。云何名为奢摩他相。能灭贪相及嗔痴相。名奢摩他相。云何名为随奢摩他入于决定。若能随修舍摩他行。尊重赞叹。向奢摩他方便庄严。是则名为奢摩他相。若有比丘。深自思惟。我之贪心唯观不净乃能坏之。嗔恚之心慈能坏之。十二因缘能坏愚痴。是名奢摩他相。云何名为毗婆舍那。若修圣慧。能观五阴次第生灭。是名毗婆舍那。复次若观诸法皆如法性。实性实相真实了知。是名毗婆舍那。云何名为毗婆舍那相。若能成就具足念心。观一切行从缘而生从缘而灭。一切行无自在无作无受。是名毗婆舍那相。云何名为从毗婆舍那入于决定。至心念于毗婆舍那。恭敬尊重向庄严道。是名从毗婆舍那入于决定。云何名为出法摄心非灭法摄心。若比丘能观心出因缘乃至一切行出因缘。是名出法摄心非灭法摄心。云何名为灭法摄心非出法摄心。若比丘能深观察灭心因缘乃至一切行灭因缘。是名灭法摄心非出法摄心。云何名为非出法摄心非灭法摄心。若比丘能观心性眼性乃至识性。是名非出法摄心非灭法摄心。云何缘摄心非思惟摄心。若比丘能观出息不观入息。是名缘摄心非思惟摄心。云何名为思惟摄心非缘摄心。若比丘观于入息。是名思惟摄心非缘摄心。云何名为非缘摄心非思惟摄心。若比丘观于心性眼性乃至意性。是名非缘摄非思惟摄。憍陈如。若比丘能摄心者。则得八十诸三昧门。及修三解脱门。若比丘观过去身。及修庄严。观身见身。是名修无愿解脱门。若比丘观过去身已。唯见于心而不见身。及修庄严观身见身。是名修无相解脱门。若比丘观过去身已。亦不见作及以作者。作者无身身无作者。修庄严道观身见身。是名修空解脱门。观受心法亦如是。复次憍陈如。三解脱门修庄严观。观一切行不出不灭。出已则灭灭无所至。不至去来。是名庄严无愿解脱门。复次观未来世诸行未出。若行未出。则无有灭。是名庄严无愿解脱门。不毕竟尽。毕竟尽者。则无生灭。若无生灭即毕竟尽。若毕竟尽即空因缘。若如是观毕竟尽者。是名庄严空解脱门。若观诸行是毕竟尽。即无生灭。若无生灭即无有空。何以故。先有后无名之为空。若本无者则无后无。若无后无云何名空。若无行者即是无为。毕竟尽者。非是有为亦非无为。空亦非行亦非无行。是故毕竟尽者。非有为摄非无为摄。是名庄严无相解脱门。若一切行毕竟尽者。即是涅槃。非过去未来现在。是故非过去行灭名为涅槃。非未来现在行灭名为涅槃。须陀洹人见是涅槃。乃至阿罗汉人见是涅槃。云何名苦谛。观一切行不见第一谛。观一切因不见第二谛。观一切灭不见第三谛。观一切道不见第四谛。云何名生。本无后有是名为生。云何名灭。有已还无是名为灭。无有出灭是名为尽。何因缘故。无有出灭名之为道。道有六行。修非修。行非行。知非知。若有比丘。能见如是生灭法者。是人能厌一切诸行。能见一切行无常相。云何无常相非无常法。若有相杂初无漏根行。若有相杂无愿解脱门行。若有空相苦相不净相无我相。是名无常相非无常法。云何无常法非无常相。所谓三界色相乃至法相。是名倒相。是名舍相。非无常相。是名无常法非无常相。云何无常相亦无常法。所谓一切众生未得决定。以世俗道入诸三昧。随法相忍。是名无常相亦无常法。云何非无常相非无常法。所谓寂静常相解脱净相。是名非无常相非无常法。云何名为得第一谛。所谓观于六根五阴犹如镜像。名得第一谛。云何一心观于四谛。若观诸行悉是苦因。以苦因故可见可灭可得远离。如是名为心缘无漏。是故一心获得四谛。名离有漏心得解脱。若有比丘观于心心。是名无愿解脱门观心心已观十二事。一者业。二者行。三者苦。四者空。五者坏。六者不自在。七者过去。八者现在。九者未来。十者因缘。十一者无作。十二者无受。是名见于心心。名无愿解脱门。若有比丘观察是心。无有心主无出入者。无能远离无可远离。是名见于心心得空解脱门。若观无有入定之心。而得远离一切烦恼。无因缘故烦恼不生。是名远离见于心心得无相解脱门。若如是观。即得远离有漏之心。得无漏解脱。憍陈如。一切有为诸行无有决定。若不定者。云何而得入于定聚。若言观察于三世已得入定聚者。是义不然。何以故。过去已尽。未来未出。现在无常。三世观异。云何得入正聚聚耶。是故一切异观性不决定。憍陈如。譬如殿堂有四梯橙。若言不由初第一橙至四橙者。无有是处。登初橙时亦不得名登第四已。如是四橙亦不名一。憍陈如。若是四谛即一谛者。可一心得。憍陈如。观时亦异得时亦异。观时异者。因果尽坏。得时异者。苦智集智灭智道智。若有比丘观行无常。是苦无我不净无住。是漏结缘是一切有。是名系缚。是故不求诸阴诸行。厌一切行乐求涅槃。至心思惟涅槃功德。深乐寂静不惜身命。修奢摩他毗婆舍那。是名比丘修集法行。憍陈如。云何比丘心能见心。若有比丘能观察心。心是无常是生灭法。是名比丘心能见心。如是比丘修空三昧。云何名空。阴入界空。谛空实空。十二因缘空。性空。云何阴空。所谓色空无我我所。乃至识空无我我所。是名阴空。入界二空亦复如是。云何谛空。所谓苦谛无得无舍。乃至道谛亦复如是。云何实空。一切法中无有觉观我及我所。是名实空。云何十二因缘空。十二因缘即是十二有支。观十二支无我我所。是名十二因缘空。云何性空。若有比丘。观于眼空无我我所。乃至意空亦复如是。是名法行能观心心。如是比丘不见众生寿命士夫某甲。知诸法性真解世谛。为流布故说阴入界。知一切法性无出灭。如是比丘能度生死。能知一切苦集灭道能断烦恼。憍陈如。若有比丘修集法行。知一切法从因缘生从因缘灭。如是比丘得三解脱知色真相。色真相者。所谓碍相。受受相。想觉相。行行相。识知相。是名真知一切法相。如是观已得空解脱门。见一切法无作受者寿命自在。唯见无常苦无我等。是名得无愿解脱门。观一切法无生无灭。是名得无相解脱门。憍陈如。法行比丘能得神通。无恶觉观。口终不说四种恶过。无有斗诤不听恶言。尔时即得远离五盖增五善根。是法行比丘获得初禅。入初禅已欲得身通。系心鼻端观息入出。深见九万九千毛孔息之出入。见身悉空。乃至四大亦复如是。如是观已。远离色相获得神通。乃至四禅亦复如是。云何法行比丘获得眼通。憍陈如。若有比丘观息出入真实见色。既见色已作是思惟。如我所见三世诸色。意欲得见随意即见。乃至四禅亦复如是。云何法行比丘得天耳通。憍陈如。若有比丘得初禅时。观息出入已次第观声。乃至四禅亦复如是。云何法行比丘得他心智。若有比丘观息出入得初禅时。修奢摩他毗婆舍那。是名他心智。乃至四禅亦复如是。云何法行比丘得宿命智。憍陈如。若有比丘观息出入。得初禅时获得眼通。得眼通已。观于初有迦罗罗时乃至五阴生灭无量劫中五阴生灭。乃至四禅亦复如是。所言禅者何故名禅。疾故名禅。疾大疾。住大住。静寂静。观灭远离是名为禅。初禅者亦名具足。亦名远离。云何具足。云何远离。言远离者远离五盖。言具足者具足五支。所谓觉观喜安定。云何名觉。如心觉大觉思惟大思惟。观于心性是名为觉。云何名观。若观心行大行遍行随意。是名为观。云何为喜。如真实知大知心动至心。是名为喜。云何为安。所谓身安心安受安。受于乐触。是名为安。云何为定。若心住大住不乱。于缘不谬无有颠倒。是名为定。第二禅者。同离五事所谓五盖。具足三支。一喜二安三定。入第三禅。亦离五事具足五支。一者念。二者舍。三者慧。四者安。五者定。入第四禅。亦离五事具足四支。一者念。二者舍。三者不苦不乐。四者定。憍陈如。若有比丘具足四禅是名法行。憍陈如。若有比丘观身厌患。远离身相一切身触喜触乐触。分别色阴远离色阴。观无量空处。是名法行比丘入空处定。是名比丘修集法行。憍陈如。云何比丘得识处定。若有比丘修舍摩他毗婆舍那。观心意识。自知此身不受。知三受已。得远离是三种受。是故名为得识处定。是名法行。憍陈如。云何比丘得少识处定。若有比丘观三世空。知一切法行亦生亦灭空处识处亦生亦灭。作是观已次第观识。我今观识亦非识非非识。若非识者是名寂静。我今云何永断此识。作是观已得少识处。是名比丘得少识处定。憍陈如。云何比丘获得非想非非想定。憍陈如。若有比丘有非心想。作是顺忍。我今此想是苦是漏。是疮是痈。是不寂静。若我能断如是非想及非非想。是名寂静。若有比丘。能断如是非想非非想。是名获得无想解脱门。何以故。法行比丘作是思惟。若有受想。若有识想。若有触想。若有空。若有识。若有非想非非想。如是等想名为粗想。我今若修无想三昧。则能永断如是等想。是故见于非想非非想。为寂静处。如是见已。入非想非非想定。若得非想非非想定已。不爱不贪能破无明。破无明已。名为获得阿罗汉果。前三种定二道所断。后第四定终不可以世俗道断。凡夫离于非想非非想处无粗烦恼。亦有十法。所谓一受二想三行四触五思惟六欲七解八念九定十慧。云何为受。所谓识受。云何为想。所谓识想。云何为行。所谓法行。云何为触。所谓意触。云何为思。所谓法思。云何为欲。所谓欲入出定。云何为解。所谓法解。云何为念。所谓念三昧。云何为定。所谓心如法住。云何为慧。所谓慧根慧力。观向四果行。乃至得阿罗汉果。观于生灭及空三昧。观于四大如四毒蛇。如是十法。第四空处具足而有。以其无有粗烦恼故。一切凡夫谓是涅槃。憍陈如。若有比丘修集圣道。厌离四禅及四空处。观于灭定庄严之道。作是思惟。诸出入息悉是无常。我若能断出入息者。即是安乐。是故一切诸行因缘悉灭受灭乃至慧灭。觉观灭故。阴入界灭。贪恚痴灭。一切心数法灭。一切非心数法亦灭。是名不与凡夫共法。非是世法是无学法。憍陈如。若须陀洹斯陀含。终不能得如是灭定。若次第得须陀洹果。亦不能得。若须陀洹舍是身已。得阿罗汉果。亦不能得。若有具足八解脱者。是人能得。憍陈如。若使如来穷劫尽劫说是法目陀罗尼法乃能穷尽。是名法无碍智。憍陈如。如是法目陀罗尼者不可思议。憍陈如。假使有人。能以兔毛渧数知海水渧。不能数知法目陀罗尼所有功德。若除如来欲说尽者无有是处。乃至一切娑婆世界微尘亦尔。尔时世尊。告金刚山童子言。善男子。汝所持来法目陀罗尼。吾今所说颇有异不。不也世尊。善男子。如是说不。世尊。实如是说。善男子。若有人能受持如是法。读诵书写广为人说。当知是人。常为一切人天龙神阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽等之所守护。一切四魔不能得其便。度烦恼河入八正道。金刚山童子言。善哉善哉世尊。实如圣教。尔时世尊。告憍陈如。若比丘比丘尼优婆塞优婆夷。修行是法无能坏者。是名施光能净寂静。无有行处无浊无动。无有舍宅无少无多。名至处行细行坚行。能坏四魔及四魔众一切邪见。度生死河入智慧海。常为诸圣之所赞叹。得近如来所入之处。虽复未断一切烦恼。亦得上身无上菩提上色上力上辩上念上慧上处。或得典领作四域王。若三二一。若作帝释。乃至得作他化自在王。若作梵王。若复获得菩提树下金刚之床。梵音深远其心平等。得大悲心得舍摩他。坏诸烦恼名无上尊。说是法时。舍利弗目揵连等。于一坐处得阿罗汉果。尔时一切世人诸天而赞叹言。如来功德不可思议。无量众生得须陀洹果斯陀含果阿那含果阿罗汉果。发阿耨多罗三藐三菩提心。尔时四天王及功德天白佛言。世尊。随是经典所流布处。我当护其四部弟子。及其国土城邑村落。诸王人民

大方等大集经卷第二十二

阿[(口*皮)/女](一)阿[(口*皮)/女]阿[(口*皮)/女](二)蘘那蛇沙吒(三)摩诃摩呿(四)摩诃咃娑婆娑(五)树喻低(六)阿咃(七)那[(口*皮)/女]那咃祢(八)佛阇啰[糸*多](九)安缕濑[糸*多](十)阇罗迦咃(十一)阿那耨得叉(十二)滼复婆(十三)那[(口*皮)/女][口*荼][(口*皮)/女](十四)勒叉鲁遮那(十五)莎吒呿[(口*皮)/女](十六)陀罗尼茂阇(十七)波啰伽啅[(口*皮)/女](十八)鞞那厕(十九)婆那鞞哹(二十)阿那迦咃(二十一)栴茶咩修(二十二)婆罗呿多(二十三)修鲁遮那(二十四)鲁遮那[(口*皮)/女](二十五)鲁遮蛇蘘[(口*皮)/女][(口*皮)/女]斯(二十六)莎诃(二十七)

勿力呵(一)勿力呵(二)勿力呵(三)勿力呵(四)阿[(口*皮)/女]勿力呵(五)萨[多*也]勿力呵(六)修[(口*皮)/女]奢勿力呵(七)那婆勿力呵(八)修颇[(口*皮)/女](九)阿能伽(十)柢比叉(十一)阇蛇私罗(十二)那[(口*皮)/女]噢[日*男](十三)呿伽钵罗(十四)那啰那讇(十五)宿沙(十六)翅奢私罗(十七)阿[(口*皮)/女]罗思罗(十八)摩诃迫坻阇那(十九)阿那闪陀罗(二十)阿婆呿伽(二十一)那犹多闪陀罗(二十二)娑颇啰(二十三)阿蘘伽伽(二十四)那啰拏(二十五)娑遮(二十六)守留多竭婆侈那(二十七)莎呵(二十八)

阇[(口*皮)/女]摩(一)阇[(口*皮)/女]摩(二)阇婆摩(三)阿驹卢吒(四)比[(口*皮)/女]阇婆(五)摩诃陀摩[(口*皮)/女]呿(六)阿啰阇(七)珊菩陀(八)蘘呿[(口*皮)/女](九)阿啰阇[(口*皮)/女][(口*皮)/女](十)啰阇[(口*皮)/女][(口*皮)/女](十一)阇坻叉蛇[(口*皮)/女][(口*皮)/女](十二)摩醯阇[(口*皮)/女]尼畔陀(十三)比牟遮[(口*皮)/女][(口*皮)/女](十四)那啰蛇拏[(口*皮)/女][(口*皮)/女](十五)斫啾[(口*皮)/女][(口*皮)/女](十六)输卢多[(口*皮)/女][(口*皮)/女](十七)输卢多[(口*皮)/女][(口*皮)/女](十八)伽恨拏[(口*皮)/女][(口*皮)/女](十九)嗜贶[(口*皮)/女][(口*皮)/女](二十)迦蛇[(口*皮)/女][(口*皮)/女](二十一)质多[(口*皮)/女][(口*皮)/女](二十二)娑茂陀啰[(口*皮)/女][(口*皮)/女](二十三)[革*亟]啰拏[(口*皮)/女][(口*皮)/女](二十四)叱那修留坻[(口*皮)/女][(口*皮)/女](二十五)莎呵(二十六)

阿罗摩(一)阿罗摩(二)阿罗摩(三)阇蛇啰阇(四)字犁蛇啰阇(五)伽阇哹(六)[(口*皮)/女]啰阇罗(七)阿那遮(八)阿呿莎啰(九)呿伽莎阇那(十)那乌呵(十一)那啰蛇那乌呵(十二)摩醯湿波罗遮摩(十三)阿摩昵呵(十四)阿蛇[(口*皮)/女]利罗(十五)斫啾遮摩(十六)斫啾娑斫啾那(十七)那[(口*皮)/女]那[(口*皮)/女]摩阇(十八)阿[(口*皮)/女]呿[(口*皮)/女](十九)车[(口*皮)/女]那[(口*皮)/女](二十)呿伽禅缕(二十一)娑啰旃陀啰(二十二)摩醯湿波罗昵罗那[(口*皮)/女](二十三)娑檀摩叉蛇(二十四)莎呵(二十五)大方等大集经卷第二十三

        北凉天竺三藏昙无谶译

    虚空目分第十之二中世间目品第二

尔时世尊。即放眉间白毫相光。悉蔽十方诸佛世界。日月星宿珠火灯明所照之处。一切石山诸恶刺棘为不复现。十方无量恒河沙等世界众生。见是光已。各各系念思惟善事。其中诸佛见是光已。各告己众而作是言。善男子。过于无量恒河沙世界。彼有世界名曰娑婆。具足五滓。有佛出世。号释迦牟尼如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。无量世界无量菩萨无量声闻。悉集彼土坐彼佛前。彼佛即为宣说法行法目陀罗尼门。为诸声闻。说法行已放大光明。将欲演说净目法门陀罗尼法。为中乘者得缘觉果。为诸菩萨。庄严成就阿耨多罗三藐三菩提。具足十地如来十八不共之法。转不退轮坏三恶趣。令修八圣得无上果。尔时十方恒河沙等世界诸众。闻是语已。各各白佛言。世尊。我欲往彼娑婆世界至说法处。听受如是净目法门。尔时无量诸菩萨众。悉共来诣娑婆世界。到于佛所头面礼拜却坐一面。时此世界无量梵天。往至佛所供养恭敬却坐一面。百亿魔天。百亿化自在天。百亿兜率天。百亿夜摩天。百亿帝释天。百亿四天王天。百亿日月天。百亿自在天。百亿阎罗王。百亿地鬼。四百亿阿修罗。四百亿龙王。如是等众悉向佛所。恭敬供养却坐一面。无量沙门及婆罗门悉得神通。来向佛所恭敬供养却坐一面。诸世界中外道相师。见光明时作是思惟。如是光者。非是日月星宿之明。必是异光。如是不久七日并出。当焦四海须弥山王一切草木。其后欲界火灾当出。或复有言。却后不久必当雨毒害于一切。或复有言。却后不久必当雨刀害诸人物。恶时将至谁能救之。或复有言。瞿昙沙门怜愍一切。唯是能救施其寿命。尔时一切无量众生至心念佛。念已即见是大宝坊。以佛力故即至坊中。尔时波斯匿王。以佛神力故亦见宝坊。以佛力故得到坊中。忧填耶那王。恶性王。输头檀王。摩醯陀王。修陀奢那王。频婆娑罗王。如是等王亦因佛力得见宝坊。悉至坊中供养礼拜次第而坐。各作是念。今此众中有大仙人。有佛世尊。此光因缘今当问谁。当问仙人。问佛可耶。尔时须陀舍那王言。我今有大婆罗门师。名曰电发。善知相法能解能说。是最可问。电发闻已即作是言。我所博览一切相书都无此事。我实不能解此光瑞。阎浮提中一切相师其数五百悉不能解。尔时频婆娑罗王。语诸王言。汝何故狂。此大众中有佛世尊。号释迦牟尼。具一切智。善知世间出世间相。了十二月善相之书。大悲怜愍一切众生。实语正语。唯佛能说是光报应。尔时诸王及诸大众一切宗仰。共白佛言。世尊。唯愿如来为我等说十二月相书。佛言大王。今此大会不应宣说世间相书。频婆娑罗王白佛言。世尊。今此会中有诸众生。不信如来所有功德。又不信是一切智人。唯愿破坏如是疑心。而宣说之。是诸众生若得闻已心生喜信。生信心已。乃可为说出世之道。如是众生。亦当乐受易可调伏。佛言大王。至心谛听。我当说之。大王。往昔雪山有一仙人。名婆伽婆。食果草根修集慈心。而不能除诸烦恼结。不能调伏贪欲之心。时彼住处有一雌虎。即共行欲。虎便怀妊日月已满。至此人所产十二子。是时仙人心怜愍故。即取洗浴而哺养之。虎母心爱随时乳养。尔时仙人各为立名。一名竭伽。二名跋伽婆。三名为虎。四名师子。五名担重。六名婆罗堕阇。七名步行。八名婆罗奴。九名健食。十名恶性。十一名师子担。十二名健行。是十二子年始七岁。食草根华果。是时父母俱时命终。时十二子心怀愁恼。仰天号哭。如何一旦无所归依。时有树神闻是声已。作如是言。诸童子且莫啼哭。有归依处。所谓梵天怜愍众生。汝等应当昼夜六时净自洗浴。向于虚空至心礼拜求哀梵天。梵天当以无碍天耳闻汝等声。闻已当来至汝住处。以怜愍故。来已当坏汝等痴闇施慧光明得智慧已。一切诸天当供养汝。况世间人。时十二子闻是语已。如教而行经十二年。然后梵天乃闻其声。即来下至三十三天。尔时帝释见梵天来即前供养。既供养已。即复白言。大士。欲何所至。憍尸迦。汝不见彼雪山之中十二仙耶。憍尸迦可共往彼。时释提桓因与无量天。相随俱下至雪山中。时十二仙见梵天来。欢喜踊跃礼拜供养。时梵天王。告十二童子。汝等何故。十二年中精勤苦行供养于我。欲何所求。为求名声色力财宝圣道智慧诸天身耶。时竭伽仙白梵天言。大士。我今不求如是等事。我欲求智慧。为众生故。我等孤稚少失覆荫自随其心。无教告者。唯愿大士施我智慧。令我识知善恶等业。及了众生善恶等业。亦知众生国土城邑刹利婆罗门毗舍首陀男女大小善恶等相受苦乐事。诸王贪国无厌足者。兴兵相伐衰盛等相。若我知已。当以方便教灭恶相。令得受乐

    大方等大集经虚空目分中弥勒品第三

尔时弥勒菩萨即于佛前。心念说偈。问于如来

  非有途路　　而有轮转　　如来亦不
  住一切道　　非道见道　　道见非道

佛言。善男子。非道者即是不出不灭。不住非智。非智境界。非明非闇。非常非断。非善非恶。非是色阴乃至识阴。是名实性。是名法性。名一切行。名真实际。是名非道。如是中道。诸佛如来转于法轮。而不贪着如是诸道。若有众生。道见非道非道见道。如是众生不能达于道与非道及知三道。如来悉能分别解说。及以断道。善男子。如来世尊于无道中而转法轮。为坏众生三种道故。何等三道一烦恼道。二者苦道。三者业道。业道者。所谓行有。烦恼道者。所谓无明爱取。苦道者。所谓识名色六入触受生老死等。如是三道。何因缘有。触缘故有。善男子。因眼见色而生爱心。爱心者即是无明。为爱造业即名为行。至心专念名之为识。识共色行是名名色。六处生贪是名六入。因入求受名之为触。贪着心者即名为爱。求是等法名之为取。如是法生是名为有。次第不断名之为生。次第断故名之为死。生死因缘众苦所逼名之为恼。乃至识法因缘生贪。亦复如是。如是十二因缘。一人一念皆悉具足。出有三种。一者因出。二者初出。三者道出。若有比丘修行法行。观察所有爱心相貌。比丘当观。若有爱心即是无明。无明之体能出二过。一者出行。二者出识。识亦有二。一者出名。二者出色。名色亦二。一者无住。二住六入。六入亦二。一不厌欲。二能生触。触亦有二。一生受心。二者求受。受亦有二。一受苦乐。二生贪爱。爱亦有二。一者系缚坚固。二者求取。取亦有二。一者贪心。二者求有。有亦有二。者乐住。二生因缘。生亦有二。一者生老。二者苦缘。老亦有二。一坏壮色。二作死因。死亦有二。一坏寿命。二爱别离。是名出因。云何初出。若有比丘修集法行。观如是法。亦出亦灭是名初出。尔时世尊。告憍陈如。云何道出。若比丘见道有二种。一者行行。二者慧行。憍陈如。汝颇知是行行慧行耶。憍陈如言。未知世尊。唯愿如来为观十二因缘比丘得大智慧坏诸烦恼。分别解说。比丘闻已当具受持。尔时世尊。告宝幢童子。善男子。汝颇能知息出入不。不也世尊。善男子。法行比丘。先观无明乃至老死。云何名为观于无明。先观中阴。于父母所生贪爱心。爱因缘故四大和合。精血二渧合成一渧。大如豆子名歌罗罗。是歌罗罗有三事。一命二识三暖。过去世中业缘果报。无有作者及以受者。初息出入是名无明。歌罗罗时气息入出。有二种道。所谓随母气息上下。七日一变。息入出者名为寿命。是名风道。不臭不烂。是名为暖。是中心意名之为识。善男子。若有欲得辟支佛果。当观如是十二因缘。后观三受因缘。五阴十二入十八界。云何为观。随于念心观息出息入。观于内身皮肤肌肉筋骨髓脑如空中云。是身中风亦复如是。有风能上。有风能下。有风能满。有风能焦。有能增长。是故息之出入名为身行。以出入息从觉观生。故名意行。和合出声名为口行。以如是等三行因缘。故有识生。识因缘故则有四阴及以色阴。故名名色。五阴因缘行六处。故名六入。情尘相对故名为触。触因缘故念色至念法。是名为受。贪着于色乃至于法。是名为爱。爱因缘故四方求觅。故名为取。取因缘故受于后身。故名为有。有因缘故有生老死种种诸苦。是名五阴十二入十八界十二因缘之大树也。是故缘出入息。能生一切诸苦烦恼。是故凡夫生时。亦为烦恼系缚。死时亦尔。终不能得身心自在。不得三昧。不尽诸漏。若有比丘观入出息。如空中风无我我所。无有作者及以受者。从缘而生从缘而灭。无相无物无有觉观。众生风者亦复如是。共四大行。生歌罗罗九孔乃至九万九千诸孔出入无作无受。是风出入如是肉段。以是因缘故。有无明乃至老死众苦聚集。善男子。譬如虚空无物无我。出入诸息地水火风。寿命暖识。无明乃至生老病死。亦复如是。众生颠倒于非我中而横见我。于如是等同虚空法。作阴界入想。一切凡夫因是颠倒。轮转生死无有穷已。若法行比丘。观是息冷则举身冷。观是息暖则举身暖。是身尔时随意随风。若观冷时不得禅定不入定聚。是人则堕冷地狱中。若观暖时不得禅定不入定聚。是人则堕热地狱中。若佛弟子修集法行。观察出入息冷暖等时则得正道。法行比丘如实观察无明乃至生老病死。心不颠倒。是名净目陀罗尼也。善男子。汝若能受是陀罗尼。即是真实观入出息。宝幢菩萨白佛言。世尊。诸佛境界不可思议。非是声闻缘觉所及。尔时四天王白佛言。世尊。随是经典所流布处。我等要当随侍守护。所有恶事悉令消灭

    大方等大集经虚空目分中四无量心品第四

尔时频婆娑罗王白佛言。世尊。因诸声闻辟支佛等修行法行。令阎浮提无有疾疫饥馑恶事。世尊。菩萨摩诃萨修四无量心。若有四姓供养恭敬。得几所福。佛告大王。若有菩萨修四无量。随所住国具八上事。一者其土人民供养父母增长惭愧。恭敬沙门诸婆罗门耆旧有德。受持禁戒。大王。若诸国土有诸菩萨修四无量。其土人民。则能成就如是初事。复次大王。若有菩萨修四无量。随所住国其土人民。修集慈心远离杀害。其心调柔无有浊心嗔恚之心。平等无二。是名为二。复次大王。若有菩萨修四无量。随所住国其土人民。不贪财宝。乐为惠施。呵责盗窃。是名为三。复次大王。若有菩萨修四无量。随所住国。其土人民。自足妻色。远离非法。呵责欲心。是名为四。复次大王。若有菩萨修四无量。随所住国其土人民。真语实语无破坏语。常修善语。是名为五。复次大王若有菩萨修四无量。随所住国。其土人民。无有嫉妒浊恶之心。是名为六。复次大王。若有菩萨修四无量。随所住国其土人民。正见不谬无有邪见。是名为七。复次大王。若有菩萨修四无量。随所住国其土人民。一切供养恭敬三宝。远离恶见。是名为八。大王若有菩萨修四无量。随所住国其土人民。具足如是八种功德。大王。若有菩萨修四无量。随所住国。其土无有八怖畏事。何等为八。一者无内外军畏。二者无诸恶鬼畏。三者无恶星宿畏。四者无诸恶病畏。五者无诸恶兽畏。六者无诸恶贼畏。七者无诸旱涝畏。八者无诸谷难畏。大王。若有菩萨修四无量。随所住国。其土无有如是八畏。大王。若有菩萨修四无量。随所住国。其土具足八大丈夫。何等为八。一者有诸众生。已于过去无量佛所。深种善根。如是之人乐生其土。二者复有众生。已于过去无量世中。修戒多闻。如是之人乐生其土。三者复有众生。已于过去无量世中。供养父母师长和上耆旧有德。如是之人乐生其土。四者复有众生。已于过去无量世中。成就天业。当受天身。故转天身来生其土。五者复有众生能坏一切三恶道业。如是之人乐生其土。六者复有众生具声闻乘。如是之人乐生其土。七者复有众生乐缘觉乘。如是之人来生其土。八者复有众生。已于过去无量世中。修六波罗蜜。如是之人乐生其土。大王。若有菩萨修四无量。随所住国。其土具足如是八人。大王。若有菩萨修四无量。随所住国。其地具足上地水味无上法味众生之味。一切众生心相亲爱。如是众生舍是身已。复生天上。乃至鸟兽亦复如是。大王。譬如一筐盛四种香。一者沉水。二者多伽罗。三者牛头栴檀。四者多摩罗叶。如是四香合有四两。有四姓人。以四种衣置之筐中。经数日已各自赍去。而是四香铢两不折。然是衣中各各有香。大王。若有菩萨修四无量。随所住国其土人民。各各成就种种功德。而于菩萨无所损减。尔时频婆娑罗王白佛言。世尊。菩萨摩诃萨修四无量心不可思议。何以故。菩萨摩诃萨自身修集。能令无量无边众生得大利益

尔时会中有一菩萨。名曰净光。告无胜菩萨言。善男子。汝今已得无上利益。何以故。汝常修集四无量心。无胜菩萨言。善男子。我今云何得大利益。如是法中无作无受。无觉无见无知。无此无彼。善男子。如人自言。能画虚空璎珞庄严。虽有是言。真实不能。一切诸法亦复如是。无出无坏。无生无灭。无有处所。无有觉观。净三解脱。无相无作无愿。如尔法界。无转无散。无合无碍。无浊无边。犹如虚空无有和合。无欲无性。无见无说。法性无数。无少无多。无有境界。无二无著。无量无色。无声寂静。无变无量。犹如虚空。无比无胜。无常无断。难见难知。难可思惟。坚固无行。无有嗔恚。摄诸佛界。是名梵行。名四无量。如来修集。心无厌足。勤行精进。是名佛法。大信大念。大不放逸。至心不忘。若菩萨摩诃萨修集如是四无量心。即是菩萨修行菩萨甚深法界。如是菩萨将欲近入无生法忍。行六波罗蜜护诸佛法。已近第三如法顺忍。真见佛身。能摧魔众及坏邪道。度生死河入大智海。通达一切诸佛境界。具足庄严诸佛功德。诸所有色种姓财物。胜诸众生。次第当坐如来法座。具足一切三昧总持。不为一切圣人所轻。为诸缘觉之所赞叹。常为诸佛之所护念。能解一切国土众生种种语言。于诸法中。不见受者及以施者。亦无说者及听法者。无有作者及以受者。犹如虚空。净光言。善男子。是故我言。汝今成就无量功德。何以故。已于无量无边世中勤修集故。善男子。若佛获得十力无畏一切佛法。出家苦行逮成正觉。转妙法轮示大神通入大涅槃。如是等事悉皆因修四无量心。如是即是四无量果。以是义故。诸善男子及善女人。应当修集四无量心。说是法时二万众生得随慈忍。无量众生具四无量心。一切大众咸供养佛

    大方等大集经虚空目分中净目品第五

尔时有一菩萨童子。名无胜意。长跪合掌白佛言。世尊。慈无量心。有何等相。有何等体。何等因缘。何等果报。云何具足。佛言。善哉善哉。善男子。能问如是甚深之义。尔时如来即入三昧。其三昧名调伏众生无所畏惧。入三昧已。从其肉髻放大光明。其光猛盛有种种色。遍照无量无边世界。复出妙音。而说偈言

  淤泥之中生芙蓉　　亦复生于种种华
  众生以之供养佛　　并及一切诸天神
  一切恶国亦如是　　生诸圣人大菩萨
  能调难调不调众　　犹如众生华供养
  娑婆世界恶土地　　释迦住中宣说法
  若欲获得无量利　　应当往彼娑婆界

无量世界所有众生。闻是偈已。各各供养其土世尊。既供养已。乘佛神力。悉来集会娑婆世界。至于佛所头面礼拜却坐一面。尔时此界大宝坊中。无量众生具足弥满。是诸众生各作是念。独我至此供养如来。独在佛前咨问正法。如来独为我一人说。尔时世尊。告无胜意童子。善男子。慈有三种。一众生缘。二者法缘。三者无缘。善男子。众生缘者缘于五有。若有法行菩萨。欲得具足六波罗蜜大慈大悲菩萨十地。速得成就阿耨多罗三藐三菩提。转正法轮。调伏无量无边众生。令度无边生死大河。欲坏无量恶魔伴党入大涅槃。如是菩萨。应当修集四无量心。应云何修。若菩萨摩诃萨。为下方众生乃至上方一切众生。修集是慈。视诸众生如父如母。如师和上。如佛世尊声闻缘觉。尔时应作如是思惟。若有众生。横于我所起诸恶事。菩萨尔时应作是念。若我嗔是恶众生者。则为十方诸佛所见。是大可耻。当见呵责。云何是人为阿耨多罗三藐三菩提。而自不能调伏其心。譬如有人无有脚足而欲趣彼郁单曰土。如无目者而欲读书。如无手者而欲执作。远离慈心。而欲获得阿耨多罗三藐三菩提者。亦复如是。若不能断如是嗔心。尚不能得声闻菩提。何况阿耨多罗三藐三菩提。若我不能调伏自心。当为诸佛声闻缘觉天龙八部之所呵责。若我不能调伏自心。当得大罪受地狱苦。不得现在未来利益。是故应当修集慈心。复作是念。若有于我已作诸恶。始作欲作。或以恶事加于我亲。以利养事益于我怨。亦复如是。如是观已。菩萨先于一方众生。修集慈心。二三四方四维上下。亦复如是。善男子。是名菩萨慈缘众生。尔时会中有一天子。名曰明星。白佛言世尊。若菩萨摩诃萨。初修慈心。如是慈心有何等果。为是现在。为在未来。具足成就几所福德。世尊。如是菩萨修集慈心。颇复当堕三恶道不。佛言。善哉善哉。善男子。汝已于昔供养恭敬无量诸佛。是故今能发如是问。已种善子善根坚固。无量世中修集慈心。不与声闻辟支佛共。为欲利益无量众生。是故今者能作是问。善男子。谛听谛听。今当为汝分别解说。若有菩萨。能如我先所说修慈。是人则得卧安寤安不见恶梦。资生所须无所乏少。诸天守护人天乐见。不闻恶声身不恶病。常乐寂静勤行精进乐受正法知见无我。常为国主沙门梵志男女大小乃至鸟兽之所供养。亲近善友。所谓声闻缘觉诸佛菩萨。乐行惠施能度众生。所有善心。不为三毒之所破坏。善名好誉流布四方。能疗众生所有恶病。能令众生远离众苦。能解众生一切系缚。能调众生诸恶烦恼。能坏一切恶邪异见。能与众生信心念心。大智慧心。心住大乘无能倾动。不随他语。能坏众生身口意恶。能灭众生三种障业。唯除五逆诽谤正法贤圣之人。劫招提僧物。善男子。菩萨若能如是修慈。当舍命时。面见十方诸佛世尊手摩其头。佛手触故心则欢喜。心欢喜故。寻得往生其佛国土。亦闻如是善妙之言。所谓莫生怖畏。莫生怖畏。汝是修慈纯善之人。定当得生净佛世界。觐见无量诸佛世尊。离三恶道必入涅槃。亦闻法缘无缘之慈。亦得具足四无量心。乃至获得阿耨多罗三藐三菩提。尔时明星天子。闻是法时。于诸禅定出入自在。无胜意童子白佛言。世尊。如是天子。以何力故。于禅定中速入速出。佛言。善男子。是天子者。已于无量诸如来所。殖诸善根。无量世中修法缘慈。本愿力故生四天处。在日天前十千由旬。所住宫殿纵广三万二千由旬琉璃所成。前后左右满十由旬。诸天男女而共围绕。是人在中离其眷属。三由旬所独坐宝床。出入禅定一日一夜。此四天下有八十天处。六十龙处。四阿修罗处。四迦楼罗处。五十二紧那罗处。四十六摩睺罗伽处。八拘办荼处。三十富饿鬼处。三十毗舍遮处。于如是处。悉能调伏如是众生。以本愿力故。往昔发愿。此阎浮提夜五分过。余一分在。当在日前十千由旬。先当破坏阎浮提闇而作明相。若阎浮提诸善众生。欲度生死修禅定者。当为是人除去睡眠施其念力。若欲见我。我当于梦现作和上师长父母。若有凡夫修集外道。我当破坏其人邪心示以正道。若有众生于世间事及出世事。生懈怠者。睹见我已除去懈怠勤修事业。若有众生迷失正路。得见我时则还见道。若有众生身遇重病。得见我者苦痛休息。身得安眠受大快乐。若有老人身受众苦心多忘误。得见我者还得念心。然我出时能令众生系心念善。若有众生命将欲尽。最后一念。我当为说大乘经典。彼既闻已面见佛像。舍身得生净佛世界。若有欲求辟支佛者。我当为说辟支佛乘。若有欲求声闻乘者。我亦当为说声闻乘。若有众生。有三恶业。闻我说法恶业即灭。世尊。我先行于阎浮提国。然后次行于瞿陀尼。瞿陀尼后次郁单曰郁单曰后。次弗婆提。以如是等本愿力故。常得修行六波罗蜜。乃至得成阿耨多罗三藐三菩提。尔时明星天子白佛言。世尊。我今为欲利益一切众生故。说此陀罗尼

庐遮罗(一)卢遮罗(二)卢遮那(三)娑罗叉婆(四)娑罗叉婆(五)娑罗叉[(口*皮)/女](六)阿[(口*皮)/女]呵呵(七)阿[(口*皮)/女]特荼(八)阿婆阇婆(九)阿婆叉那(十)阿叉叉叉(十一)富罗婆逻(十二)阿婆叉叉(十三)阇婆阇婆(十四)摩呵迦波(十五)阿婆阿婆(十六)摩呵娑摩(十七)频豆(十八)莎阇羯波(十九)阿靴(二十)阿靴(二十一)呵呵尼摩(二十二)沫逻莎律阇(二十三)迦留那阇逻(二十四)莎呵

世尊。若有比丘比丘尼优婆塞优婆夷。若男若女若大若小。若有至心念我事者是人则得净于诸业。神通施戒忍辱精进禅定智慧。解脱佛土四无碍智。如是诸人不得成就如是事者。我则欺诳十方诸佛。于未来世。亦莫令我得阿耨多罗三藐三菩提。尔时无胜意童子白佛言。世尊。他方佛土所有人民。常作是言。娑婆世界杂秽不净。然我今者常见清净。佛言。如是如是。善男子。如汝所说。又此世界诸菩萨等。或作天像调伏众生。或作龙像。或作鬼像。或阿修罗像。或迦楼罗像。或紧那罗像。或摩睺罗像。或夜叉像。或拘办荼像。毗舍阇像。薜荔陀像。人像畜生像鸟兽之像。游阎浮提。教化如是种类众生。善男子。若为人天调伏众生。是不为难。若为畜生调伏众生。是乃为难。善男子。阎浮提外。南方海中有琉璃山。名之为潮。高二十由旬。具种种宝。其山有窟名种种色。是昔菩萨所住之处。纵广一由旬高六由旬。有一毒蛇在中而住。修声闻慈。复有一窟名曰无死。纵广高下亦复如是。亦是菩萨昔所住处。中有一马修声闻慈。复有一窟名曰善住。纵广高下亦复如是。亦是菩萨昔所住处。中有一羊修声闻慈。其山树神名曰无胜。有罗刹女名曰善行。各有五百眷属围绕。是二女人常共供养如是三兽。善男子。阎浮提外西方海中有颇梨山。高二十由旬。其山有窟。名曰上色。纵广高下亦复如是。亦是菩萨昔所住处。有一猕猴修声闻慈。复有一窟名曰誓愿。纵广高下亦复如是。亦是菩萨昔所住处。中有一鸡修声闻慈。复有一窟名曰法床。纵广高下亦复如是。亦是菩萨昔所住处。中有一犬修声闻慈。中有火神。有罗刹女。名曰眼见。各有五百眷属围绕。是二女人常共供养是三鸟兽。善男子。阎浮提外北方海中有一银山。名菩提月。高二十由旬。中有一窟名曰金刚。纵广高下亦复如是。亦是菩萨昔所住处。中有一猪修声闻慈。复有一窟名香功德纵广高下亦复如是。亦是菩萨昔所住处。中有一鼠修声闻慈。复有一窟名高功德纵广高下亦复如是。亦是菩萨本所住处。中有一牛。修声闻慈。山有风神名曰动风。有罗刹女名曰天护。各有五百眷属围绕。是二女人常共供养如是三兽。善男子。阎浮提外东方海中有一金山。名功德相。高二十由旬。中有一窟名曰明星。纵广高下亦复如是。亦是菩萨昔所住处。有一师子修声闻慈。复有一窟名曰净道。纵广高下亦复如是。亦是菩萨昔所住处。中有一兔修声闻慈。复有一窟名曰喜乐。纵广高下亦复如是。亦是菩萨昔所住处。中有一龙修声闻慈。山有水神名曰水天。有罗刹女名修惭愧。各有五百眷属围绕。是二女人常共供养如是三兽。是十二兽。昼夜常行阎浮提内。天人恭敬。功德成就已。于诸佛所发深重愿一日一夜。常令一兽游行教化余十一兽安住修慈。周而复始。七月一日鼠初游行。以声闻乘教化一切鼠身众生。令离恶业劝修善事。如是次第至十三日。鼠复还行。如是乃至尽十二月。至十二岁。亦复如是。常为调伏诸众生故。善男子。是故此土多有功德。乃至畜生亦能教化。演说无上菩提之道。是故他方诸菩萨等。常应恭敬此佛世界

尔时会中有一优婆塞。名曰净德。白佛言。世尊。我今可得睹见如是十二兽不。善男子。若有比丘比丘尼优婆塞优婆夷。欲得睹见是十二兽。欲得大智大念大定大神通力。欲受一切所有典籍四无量心。欲行正道得奢摩他。欲得寂静。欲增善法。是人当以白土作山。纵广七尺高十二尺。种种香涂金薄薄之。四边周匝二十尺。所散瞻婆华当以铜器盛。诸种种非时之浆置之四面。清净持戒日三洗浴敬信三宝。离山三丈正东向立。诵如是咒

战陀罗呵(一)修利蛇比摩(二)其罗[月*兄](三)沸己牟逻(四)若蛇牟逻(五)阿呵希(六)娑呵啰希(七)若蛇[日*可]希(八)萨婆复多呵(九)梨蛇婆呵休(十)摩莎车婆牟梨(十一)迦[(口*皮)/女]浮(十二)逻奢浮(十三)修逻蛇牟(十四)呿迦那(十五)摩希叉婆(十六)迦婆摩诃(十七)阿叉比婆逻(十八)多波比莎(十九)沙持因持利蛇鞞莎(二十)阿阇牟他婆(二十一)婆卢婆叉(二十二)槃陀哆(二十三)遮罗叉婆希(二十四)呵迦比牟(二十五)哆比勒搜(二十六)散遮勒搜(二十七)[(口*皮)/女]婆浮(二十八)娑逻[(口*皮)/女]叉搜(二十九)沸己遮(三十)哆莎赖莎(三十一)陀叉逻莎(三十二)波利波遮(三十三)修罗修(三十四)搜婆莎弥(三十五)希逻莎(三十六)[(口*皮)/女]逻牟莎逻莎(三十七)牟莎逻私(三十八)逻婆逻娑(三十九)频婆思逻莎(四十)[(口*皮)/女][(口*皮)/女]逻娑(四十一)陀摩卢遮那逻娑(四十二)富囊挫兰呵逻娑(四十三)首陀卢遮那逻娑(四十四)[(口*皮)/女]摩摩逻娑(四十五)比摩卢遮那呿伽(四十六)萨颠摩逻娑(四十七)阿利耶卢遮那耨耨(四十八)比摩牟(四十九)婆罗呵芒[(口*皮)/女]呵逻私[少/(兔-、)][少/(兔-、)](五十)阿由比目猛(五十一)牟尼逻提致汦(五十二)莎呵

住十五日。当于山上见初月像。尔时则知见十二兽。见已所愿随意即得。善男子。若能如是修行苦行。即得眼见是十二兽。尔时净德优婆塞语明星菩萨言。善男子。汝能教化调伏众生。云何调伏。为以身耶。口耶意耶。善男子。我非身口。唯以心业。善男子。若是心业。为过去耶未来耶现在乎。善男子。亦非去来。唯是现在。制限在心不令作恶。善男子汝犹不能令现在心获得解脱云何而能调伏众生。明星答言。我今受持四无碍智净目持力故。能调伏一切众生净德言。四无碍智净目持者。亦复不能调伏众生。何以故。无觉观故。云何而言。能调众生。善男子。我今问汝随意见答。善男子。摄入系缚解脱清净道及寂静。虽复平等亦不平等。如是平等及不平等。何因缘生。何因缘出。何因缘增长。汝宁不知乎。净德答言。善男子。如是等事。因我我所生出增长。明星菩萨言。善男子是我我所何因缘生。善男子。是我我所风因缘生。明星菩萨言。风住何处。善男子。风住虚空。又问虚空为何所住。答言。虚空住于至处。又问。至处复何所住。答言。至处何处住者不可宣说。何以故。远离一切诸处所故。一切处所所不摄故。非数非称不可量故。非觉非观。非有非无。非行非生。非出非灭。非有增长。非字非念。非作非受。非闇非明。非增非减。非壮非老。真实之性是一切法无挂碍门。是故至处无有住处。明星菩萨言。善男子。如是即是四无碍智净目陀罗尼。若有菩萨修集如是陀罗尼者。一切烦恼则为烂败入法缘慈。一切法中无有疑心。说是法时十方世界无量众生得法缘慈。无量众生得近四无碍智净目陀罗尼。尔时世尊赞是二人。善哉善哉。善男子。能如法问。能如法答。是陀罗尼因缘力故。四天王等。于我灭后能守护法

大方等大集经卷第二十三

战阿罗呵(一)修利蛇比摩(二)其罗贬(三)佛已牟逻(四)若蛇牟逻(五)阿呵希(六)婆呵啰希(七)若蛇呵希(八)萨婆复多呵希(九)梨咃婆呵休(十)摩沙车婆牟梨(十一)迦[(口*皮)/女]浮(十二)逻奢浮(十三)修逻蛇牟(十四)呿迦那(十五)摩希叉婆(十六)迦婆摩呵(十七)阿叉比婆逻(十八)多波比婆(十九)沙持因持利蛇鞞婆(二十)阿阇牟他婆(二十一)婆卢婆叉(二十二)槃陀哆(二十三)遮罗叉婆希(二十四)呵迦比牟(二十五)哆比勒搜(二十六)散遮勒搜(二十七)嘙嘙浮(二十八)婆罗婆叉搜(二十九)佛已遮(三十)哆纱赖沙(三十一)陀叉逻娑(三十二)波利波遮(三十三)修逻修(三十四)搜婆娑弥(三十五)希逻(三十六)嘙罗牟娑罗娑(三十七)牟娑逻私(三十八)罗婆逻婆(三十九)频婆思逻娑(四十)嘙嘙逻娑(四十一)陀摩卢遮那逻娑(四十二)富囊挫兰呵逻婆(四十三)首陀卢遮那逻娑(四十四)嘙摩摩逻娑(四十五)比摩卢遮那呿伽(四十六)萨颠摩逻娑(四十七)阿利那遮那褥褥(四十八)比摩牟(四十九)婆遮呵芒嘙呵逻私葂葂(五十)阿由比目醯(五十一)牟尼逻提致沙(五十二)娑呵(五十三)大方等大集经卷第二十四

        北凉天竺三藏昙无谶译

    虚空目分第十之三中圣目品第六

尔时明星菩萨白佛言。世尊。声闻之人行声闻乘。辟支佛人行辟支佛乘。如是二人云何修悲。思作何法离何烦恼。佛言。善男子。若有善男子善女人。行声闻乘辟支佛乘。不观众生所有乐相。不作怨亲父母等相。怜愍众生修起悲心。乃至十方亦复如是。若我不能于恶众生修集悲者。当观是人八种苦相。生苦乃至死苦。是人具足如是八苦。我当云何于是人所不生悲心。是人复有三种大苦。亦复未得脱三恶道。我当云何不生怜愍。云何名为观于生苦。从业因缘父母和合。初受意识。歌罗罗时。其身犹如葶历子许。是时未有入出气息。亦不觉知苦之与乐不苦不乐。离先色相。未具后色。无力无欲。无有精进。无有憍慢上色上性上自在相。无五欲相。诸根不具。如是众生我当云何不生怜愍。如是众生过去爱取名为无明。过去业有名之为行。初入胎心名之为识。歌罗罗中。初色四阴名为名色。是时未具十二有支。以生因缘故。可说有十二因缘。众生如是何有智者不生怜愍。歌罗罗时住六七日。六七日转名頞浮陀。是时形色犹如小枣。住七七日转名伽那。是时形色如胡桃壳。住八七日转名闭尸。形色犹如频婆罗果。是时身边有五胞出谓头手脚。十二七日始有肠相。二十七日男女根别。二十一七日始生骨节。乃至三十六七日中。其身具足血肉毛根。三十八七日具足身肢。四日四夜住在腹中臭秽之处。是人如是我当云何不怜愍耶。尔时还忆本生之事。忆已愁苦。作是念言。若我出胎当修善法。愿后更莫生如是处。修不放逸远离受生。初出母胎。尔时举身受迫迮苦。入风触身亦复受苦。身初至地。以水摩洗复受大苦犹如地狱。尔时还失忆宿命事。生已复有老病死苦随逐不舍。复有风病白水黄水和合等病。如是四病数各百一常随逐之。是故名为生。是大苦既受生已老复随逐。发白面皱。失智惭愧。发毛稀疏。诸行陈故诸根衰熟。易破易坏。烂朽危脆。唯贪二味。所谓碱酢。能坏安乐身根遍恼。是大苦河。能破众生三世壮色。妄如婴儿。狂如鬼着。众生具足如是恶事。我当云何不生怜愍。尔时复为死所侵逼。失于智慧寿命诸有。舍弃诸阴。身坏命坏四大离散。三世众生寿命之怨。一切众生成就死法。我当云何不生怜愍。尔时复有所不爱物。而来亲近。所谓寒热饥渴恶人恶兽。众生如是我当云何不生怜愍。复有所爱别离。所谓盛年财宝。康强寿命。父母妻子亲戚眷属上妙六尘。众生既受如是等苦。我当云何不生怜愍。或有众生于三世中。求上六尘而不能得。以是因缘具受众苦。若我于此恶类众生不生怜愍。我当云何得阿耨多罗三藐三菩提。一切众生受五阴担。我亦如是。若我不修大悲之心。云何得舍如是重担。一切圣人已得远离五阴重担。若不修行三种净戒。不善思惟。其心放逸不行正道。不得解脱如是之人受百种苦。众生既受如是百苦。我当云何不修悲心。若有众生于一日夜。能如是观。是人得心犹如虚空。是人能于一切众生修集大悲。是人能得身心寂静。是人不远正真法界及以法性。如是方便。能得声闻缘觉众生缘悲。若有菩萨初修道时。作是思惟。设令我有恒河沙等如须弥身。当以是身为于一人。于无量世受大剧苦。令彼一人得受乐者。我终不悔。亦不退转于菩提心。复作是念。假令一切所有众生。各各执椎如须弥山。来打我身经无量岁。我当忍受不生恶心乃至一念。复作是念。是人所受百种之苦。一切众生亦受是苦。而不知念阿耨多罗三藐三菩提。我今是学阿耨多罗三藐三菩提。云何不受刀剑火石。亦复如是。若我当于一切众生生恶心者。诸佛贤圣当见呵责而作是语。是人欲得阿耨多罗三藐三菩提。云何如是而不忍辱。菩萨摩诃萨修净意者。即是忍辱。忍辱者即是璎珞精进道性器四财宝。菩萨修集如是忍辱。能净身心。能净庄严坚固庄严。得大智慧。不与声闻辟支佛共。于诸众生最为殊胜。一切四魔不得其便。邪不能动。烦恼折减一切怨仇不能为恶。言辞所说不可穷尽。其智甚深犹如大海。精进坚牢如须弥山。等诸众生如海一味。能大利益犹如大地。净众垢污犹如清水。能作光明犹如朗日。于众无碍犹如猛风。世法不污犹如莲华。下视众生如金翅鸟。众生乐见如夏日云。众生乐受如夏时雨。见无余求犹病遇医。坏诸贫穷如如意珠。施众禅定犹如梵天。生死无碍犹如虚空。示平不平犹如明灯。人天恭敬犹如帝释。若有菩萨起嗔恚心。一切怨贼悉得其便。丧失一切善根财宝。一切众魔获得其过。为诸烦恼之所污染。入大闇处失一切善根。为诸圣人之所呵责。若有菩萨起嗔恚心乃至一念。则为丧失一切善法。设我悉受一切众生无量亿数打骂毁辱。乃至不应起一念嗔。何以故。如是众生不学慈悲。若彼众生心无嗔打。我当云何修集慈悲。以是义故。众生嗔时我应生喜。何以故。即是我之悲因缘故。若有善男子善女人。能作是观。即得不共声闻缘觉众生缘悲。亦能疾得阿耨多罗三藐三菩提。善男子。复有众生观三恶道苦众生已。修集悲心。复有观察三界所有诸苦众生。而修悲心。复有观察五阴众生。而修悲心。入界亦尔。善男子。以是义故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。当修慈悲。何以故。夫慈悲者。即是一切善法种子。若有众生得色界身。亦是修集慈悲因缘。若无色身。若声闻道若缘觉道。若诸菩萨庄严坚固行六波罗蜜。调伏众生得无生忍。成阿耨多罗三藐三菩提。皆因慈悲种子因缘。说是慈悲因缘法时。明星菩萨得无生法忍。是忍不与缘觉声闻共之。八万四千众生得如法忍。五万五千那由他众生发阿耨多罗三藐三菩提心。十万八千众生得不退心。二万众生成就慈悲。五千比丘得阿罗汉果。五百比丘尼尽一切漏。十万亿众生破大邪见得正见心。尔时世尊告无胜意童子。善男子。过去有佛名发功德意。亦说如是大慈大悲。无胜意童子言。世尊。所言如者云何名如。佛言。善男子。远离身相名之为如。无胜意童子言。所言身者即是实性。即是寂静。即是法界。即是无漏。即是无尽佛言。善男子。如身者即是一切众生之身。即是过去未来边际。即是寂静。无胜意童子言。世尊。若一切佛如即是身。佛言。善哉善哉。善男子。如是法界无有增减。三世平等不生不出不灭。犹如虚空。如身亦如是。说是法时。三万众生得如法忍。尔时世尊告明星菩萨言。善男子。云何修集缘众生喜。善男子。若有菩萨不修慈悲。不念众生所有乐相。乃至不观三趣三界所有诸苦。而亦观于五阴出灭。如是观已生于喜心。但乐观法。观已生喜。如是喜心愿及众生。是名为喜。世尊。云何修舍。善男子。若有菩萨不修慈悲及以喜心。修舍念舍父母乃至声闻缘觉菩萨诸佛。修是舍时。远离一切爱嗔法心。是人修集空无相愿。既修集已。不久定当得入涅槃。若人修集如是等四无量心。是人则为十方诸佛菩萨天龙夜叉刹利婆罗门毗舍首陀比丘比丘尼优婆塞优婆夷之所供养。随有国土若四部众修集如是四无量心。其土则已远离一切衰祸之相。其中众生乐离恶法受持善法。善男子。四无量心。具足如是无量福德

    大方等大集经虚空目分中辟支佛乘品第七

无胜意童子复白佛言。世尊。修缘觉乘。比丘比丘尼优婆塞优婆夷善男子善女人。云何修集慈悲喜舍。佛言。善男子。若有修集辟支佛乘。比丘比丘尼优婆塞优婆夷善男子善女人。观众生乐。解众生乐。念法缘慈。终不忆念缘众生慈。如自心中所受乐事。亦愿众生同共得之。观法平等。观乐平等。观心平等。观如平等。如是观已。乃至不于一人生恶。设有因缘生恶心者。应作是念。若我于彼生恶心者。云何当得阿耨多罗三藐三菩提。菩萨摩诃萨。成就无量纯善功德。若于一人生嗔恶心。尚不能得阿耨多罗三藐三菩提。况我未成诸善功德。以是因缘。修众生慈及法缘慈。悲喜舍心亦复如是。善男子。若有欲学缘觉乘者。应如是修慈悲喜舍。说是法时。六万亿众生得住初地。或得二地三地四地五地。或有众生得无生忍。或有获得辟支佛道及声闻道。无量众生发阿耨多罗三藐三菩提心

    大方等大集经虚空目分中圣无碍智品第八

尔时众中有一童子名虚空声。白佛言。世尊。云何菩萨庄严无上菩提之道。修一切智目方便。无缘梵行一切法目方便。无缘梵行一切阴入界方便。解脱方便。三昧方便。陀罗尼方便。得忍方便。诸地方便。世尊。云何菩萨摩诃萨。修一切智目门。同虚空慧度于彼岸。无缘梵行。越度四流断四魔系。佛言。善哉善哉。善男子。汝今能入四无量海。欲度众生于生死河。是故今者发如是问。复欲不断佛大智海。善男子。十方佛土若有菩萨。同共汝行三昧智慧。我说法时。如是等辈悉为明证。若无如是菩萨证者。我则不说无缘梵行。何以故。我若说者。多于是中而生疑心。若有未得无缘梵行亦复生疑。以是义故。不应宣说。尔时世尊。即入三昧。其三昧名虚空幢。入已面门出大光明。其明种种遍照十方诸佛世界。蔽于日月令不复现。其光明中出大声言。娑婆世界释迦牟尼。为诸众生宣说梵行坏诸烦恼。说声闻乘辟支佛乘无缘梵行。无量众生及诸菩萨。次第而坐听受正法。亦说清净菩提之行。为欲利益无量众生故。作大集说种种行。无量众生获得一生及以后生。十方众生闻是语已。一切悉集娑婆世界。或有菩萨现真金身雨于金沙或现银身雨于银沙。或琉璃身雨琉璃沙。或颇梨身雨颇梨沙。或沉水身雨沉水沙。或栴檀身雨栴檀沙。或多摩罗跋身。雨多摩罗跋沙。供养于佛。供养已毕头面敬礼却坐一面

尔时世尊告虚空声童子。善男子。今日十方诸大菩萨。其中或有得法忍者得无生忍一生后生。悉为我证如是菩萨修集慈悲喜舍之心。了了通达诸法之性。亦能远离身相业相。其心不著有为无为。亦不贪着眼乃至意色乃至法。至心修集无缘梵行。无诸觉观不生憍慢。无所贪着知真实性。观一切法皆悉平等。所谓三世三界三戒。亦得增长大慈大悲大喜大舍。一切众生。远离三界阴入界等。离一切字聚名聚句聚有为之法。作是观时。即得具足大慈大悲大喜大舍。修集同空三昧梵行六波罗蜜。诸佛护念。具善方便住第三忍。过于声闻辟支佛道。远离一切眼色因缘乃至一切意法因缘。观法界如随顺不倒。获得大慈大悲等力。于诸法中得大自在。而于生死不生厌悔。有大力势调伏众生。于三乘中得智方便。能雨法雨得无碍智。解诸众生异语方便。善男子。是名圣目陀罗尼。具无碍智修集梵行。善男子。若有菩萨修是梵行。如是菩萨常得见佛。能具佛法净佛世界。性净众净。行净智净。意净供养亦净。能具十地。次第当坐如来法座。如是名为清净法行。是名如来。是名世尊。名过四潮。名菩提道。能得菩提转大法轮。云何名为一切智耶。若智能观一切平等。众生平等三世平等不倒平等。如是等一切法见虚空目。见法虚空目。见无行虚空目。见性虚空目。见如空虚空目。见如内空虚空目。见如外空虚空目。见如内外空虚空目。见如大空虚空目。见如第一义空虚空目。见如有为空虚空目。见如无为空虚空目。见如毕竟空虚空目。见如无始空虚空目。见如性空虚空目。见如散空虚空目。见如自性空虚空目。见如一切法空虚空目。见如无所觉空虚空目。见如无法空虚空目。见如无性空虚空目。见如无法有法空虚空目。见如实性空虚空目。见如无相无愿虚空目。见如一切法无边无处虚空目。见如大慈大悲虚空目。见一切知见虚空目。见一切智。如是见已转正法轮。是名不共众生法界。是名一切智。名佛境界。说是无缘梵行时九万二千众生成就是法。恒河沙等众生得如法忍。恒沙众生远离垢秽得法眼净。一千比丘得阿罗汉果。无量人天发阿耨多罗三藐三菩提心

    大方等大集经虚空目分中护法品第九

尔时一切欲色界天。以妙香华幢盖伎乐供养于佛。白佛言。世尊。如来先已于阎浮提。转正法轮。今复于此大宝坊中。转大法轮。为菩提行故。一切大众复作是言。如来境界不可思议。何以故。如来在此大宝坊中。转法轮时。十方无量佛世界中。所有菩萨悉来集此。为听如是虚空目法行。尔时文殊师利童子。金刚山童子。无胜幢童子。无胜意童子。虚空声童子。如是等童子。其数九万二千亿。白佛言。世尊。唯愿如来以愿力故。令是虚空目法行久住于此娑婆世界及十方土无有灭没。何以故。如是法中说三梵行。菩萨若行如是三行。即得阿耨多罗三藐三菩提。佛言。善男子。南方世界金刚光明功德如来。西方世界智幢如来。北方世界发光功德如来。东方世界宝盖光明功德如来。是四如来以先有愿。以是愿故。是经后当流布十方令诸菩萨悉得修行如是三行。我今以此正法。付嘱四大天王。功德天女。四大龙王。诚实语天。四阿须罗王。具天。大自在天。八臂天地神女等。何以故。善男子。或有众生。其性弊恶。有大势力。多造重业不受是经。是人死已受恶鬼身恶龙之身。是恶鬼龙欲坏佛法。降注恶雨恶风尘坌。为诸修行三业比丘。而作重病。以手探腹取其心肝。吹吐恶气置饮食中故。令食者得大重病。良医拱手不能疗治。如是修行三业比丘。尽舍命已。是名法灭。如是恶鬼。复令如来所有弟子。刹利婆罗门。毗舍首陀。大臣长者悉生恶心。恶心既生互相残贼。当尔之时。阎浮提内国土城邑。空荒无人。人民既无。谁当流布如是经典。是故我今不以是经。付嘱菩萨。比丘比丘尼。优婆塞优婆夷。及诸国主。以付四王乃至地神。如是天神至心护持。若有国土。刹利婆罗门。毗舍首陀。比丘比丘尼优婆塞优婆夷。受持读诵如是经者。是诸天神。当至心护。劝诸檀越令致供养。所谓衣服饮食。卧具病药房舍灯烛。是诸檀越若有恶相诸恶病瘦。诸天力故悉令消灭。以是因缘法得增长无有灭没。尔时一切诸天神等。白佛言世尊。若今现在若佛灭后。我等要当舍离自事守护是法。若佛弟子比丘比丘尼优婆塞优婆夷。有能受持如是等经勤行精进。虽复受畜八不净物。畜养妻息金银琉璃颇梨。田宅奴婢仆使。我为法故。亦当守护遮诸恶鬼不令娆近。随是经典所在之处。令其土地日月五星不越常度。怨仇兵革皆悉消伏。所有众生若男若女。若大若小。悉乐受诵如是经典。持戒清净勤行精进。世尊。以是因缘。一切诸天乐处人间。是人舍身即得生天。诸天增长色力寿命。所有恶相灭无遗余。其无信者我能令信。若佛弟子。比丘比丘尼。优婆塞优婆夷。不能受持如是经典。读诵书写。不乐寂静。不善思惟。乐求供养不持净戒。懒惰懈慢。心无惭愧。亲近白衣。如是比丘。以财俗力毁佛弟子。若打若杀若缚若骂。向王大臣说其过恶。佛诸弟子。闻是事已生大恶心。生恶心已。诸善鬼神舍至他土。是故恶鬼即得其便。既得便已。诸国兴兵互相讨伐。降恶风雨令谷不登。人民饥馑共相茹食。尔时十方世界菩萨白佛言。世尊。诸佛如来。为如是等五滓众生。制于禁戒。唯愿如来为法久住复制禁戒。所谓身戒口戒意戒。不得受畜一切恶物。恶心斗诤。亲近国王大臣长者。受畜一切俗人之物。如余佛土所制净戒。佛言。善男子。止止。佛自知时。善男子。因缘未出。如来则不豫制禁戒。尔时世尊告频婆娑罗王。大王。汝之国法何名大罪。何名小罪。频婆娑罗言。世尊。我之国法。有四重罪。一者断他命根。二者偷至五钱。三者淫他妇女。四者为五钱故大众王边故作妄语。如是四罪犯者不活。佛言。我今亦为未来弟子制是四重。复次大王。王子几岁不听入宫。世尊。过二十年则不听入。佛言。我亦如是。沙弥二十乃至得道不听入众。王言世尊。如我国法。有作罪者必死不疑。或打或骂闭系输物。摈出界外。如来法中其义云何。大王。我之法中亦复如是。有犯罪者或令苦作一月二月。或不与语共坐共食。或不共住。或摈令出。或出一国。或出四国。有佛法处。治如是等恶比丘已。诸善比丘安乐受法。故使佛法久住不灭。大王。若未来世有我弟子。饶财多宝有大力势。王所亲爱。一切大众不能摈治。如是等人汝等当治。刹利婆罗门毗舍首陀。不能治者。如是四姓。则为断我三宝种性。能灭法炬。破坏法船。燋涸法味。夺众生眼。我法坏时。心则放舍。大王。譬如一人夺一切眼。于意云何。是罪多不甚多。世尊。不可称量。不可计数。大王。若有刹利婆罗门毗舍首陀。有大力势。见我法灭舍不守护。其所得罪亦复如是。大王。若有国主。于无量世修施戒慧。见我法灭舍不拥护。如是所种无量善根悉皆灭失。其国当有三不祥事。一者谷贵。二者兵革。三者疫病。一切善神悉舍离之。其王教令人不随从。常为邻国之所侵娆。暴火横起多恶风雨。暴水增长吹漂人民。内外亲信咸共谋叛。其王不久当遇重病。寿终之后生地狱中。若宿善追及。还得人身。无量世中常盲无目。贫穷跉跰行乞自活。常生恶心。因是恶心。复当还堕于地狱中。如王夫人。太子大臣城主村主。将帅郡守宰臣。亦复如是。频婆娑罗耳闻是语。悲泣哽咽收泪而言。世尊。我值如来犹故不能如法治国。况未来世放逸诸王。不能持戒修行精进。治恶比丘护持佛法。不能绍继三宝种性。如是诸王。长夜常行于三恶道。尔时诸王夫人。太子大臣。城主村主将帅郡守宰官。皆白佛言。我等于今现在之世。要当勤心守护佛法。亦当供养受持法者。衣服饮食卧具医药。治恶比丘绍三宝性。佛言。善男子。汝等若能建立此事。则为供养三世诸佛。亦得无量不可思议诸善功德

    大方等大集经虚空目分中大众还品第十

尔时世尊复告诸天。善男子。汝等今者勿怀忧虑。我今当与未来弟子。为护法故。立严峻制。为不断绝三宝性故。为欲增长诸善法故。为增长多闻满宝藏故。为离一切苦烦恼故。为成无上菩提道故。善男子。我今所说。一切声闻。具足成就得声闻乘。一切缘觉具足获得辟支佛乘。一切菩萨。具足成满三种梵行。得无上智。善男子。是经能离诸恶众生。能坏众生恶不善法。能灭身口意不善业。能破一切诸恶果报。若有善男子善女人。供养是经。则为供养十方诸佛。尔时娑婆世界一切众生。异口同音而作是言。善哉善哉。世尊我初未闻是大法聚。今得闻之。世尊。我能受持守护是法。为护法故不惜身命。若有比丘比丘尼优婆塞优婆夷。受是经者我当供养。随其所须一切给与。若复有能供养如是受持经者。我等亦当勤守护之。内外财宝令无损秏。随是经法所流布处。亦护其土令无诸恶。佛言。善哉善哉。善男子。汝能如是守护法者。则为供养三世诸佛。善男子若诸众生有护法心。若生人天得大自在。乃至畜生亦有大力。为人所重不经寒苦。善男子。是护法者恶不能加。心无所畏无能破坏。诸魔烦恼不得其便。多饶眷属智慧具足。凡有所说无所挂碍。乐行十善修集正定。父母诸王见则恭敬。能升法座转正法轮。凡有所闻终不忘失

大方等大集经卷第二十四大方等大集经卷第二十五

        北凉天竺三藏昙无谶译

    宝髻菩萨品第十一之一

尔时世尊故在欲色二界中间大宝坊中。坐师子座。放大光明犹如日月。得大自在犹如梵释。功德高显独如须弥山。法界甚深犹如大海。于大众中演说正法。初中后善字义真正。具足清净班宣梵行。为诸菩萨净于法印。令诸菩萨闻已修集。尔时东方过九万二千诸佛世界。彼有世界名曰善华。其土有佛。号曰净住如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为化众生宣说正法。有一菩萨名曰宝髻。与诸菩萨其数八千。没彼世界欲来此土。赍妙宝盖欲奉如来。其盖周覆一千世界。及诸香华欲供养佛。妙音说偈赞叹如来

  若诸人天得睹佛　　则为获得大利益
  如来所受苦无量　　勤精进故得菩提
  往昔精进修菩提　　超过一切诸菩萨
  为令众生得利益　　故转无上正法轮
  如来如是难得见　　所说正法亦难闻
  获得人身亦复难　　诸根具足亦如是
  若诸众生行不善　　亦不能作三善业
  若人欲得大利益　　应当觐见释中尊
  若欲听受无上法　　并见十方诸菩萨
  具足三十二妙相　　应当速诣大宝坊
  今若不种诸善根　　后必不得大涅槃
  若欲具足人身者　　应当速诣娑婆界
  若欲破坏三恶道　　欲受人天微妙乐
  获得无上无比乐　　应当诣于娑婆界
  大医今施甘露味　　除灭众生诸烦恼
  如来商主大法王　　今日演说无上界

宝髻菩萨说是偈时。其声遍满大千世界。时舍利弗闻是偈已即白佛言。世尊。如是偈音何处演说。佛言。舍利弗。东方过于九万二千诸佛世界。彼有世界名曰善华。其土有佛号曰净住。彼有菩萨名曰宝髻。与八千菩萨俱来至此。是其所说。其声闻乎大千世界。劝诸众生令修善法。尔时宝髻菩萨。与八千菩萨。及无量人天。来至佛所。头面礼拜。白佛言。世尊。善华世界净住如来。致敬问讯。起居轻利气力安不。眷属大众乐受法不。世尊。我从彼来至此世界。为听菩萨净行法印。唯愿如来。普为一切。大慈怜愍分别解说。令诸菩萨闻已修集。破坏一切烦恼习气修菩萨行。了知一切众生之心。能修菩萨所有行相。能得解了智慧之行。能知一切烦恼等行。能修菩萨所修法行。能深观察一切罪过。身得无碍见一切佛。佛言。善哉善哉。善男子。谛听谛听。我今当说如是净行十分之一。善男子。菩萨摩诃萨有四行。何等为四。一者波罗蜜行。二者助菩提行。三者神通行。四者调众生行。波罗蜜行者。是愿方便。助菩提行者。是修道方便。神通行者。是调心方便。调心方便者。是菩提心坚固方便。善男子。云何名檀波罗蜜。檀波罗蜜即是净行。能坏痴心能修舍心。修舍心已能一切施。若有菩萨能一切施。即得四种无分别心。何等为四。一者不分别众生。二者不分别法。三者不分别心。四者不分别愿。是名为四。不分别众生。是可与是不可与。此多与此少与。此上与此下与。此恭敬与此轻慢与。此全与此半与。此持戒此破戒。此福田此非福田。此得大报此不得大报。此是正见此是邪见。此行正聚此行邪聚。善男子。若菩萨摩诃萨。得如是心。名不分别心。无憍慢心。无上下心。无挂碍心。是平等心。真正之心。平等施戒。平等慈悲。无有分别犹如虚空。是名不分别众生。不分别法者。菩萨终不作是分别受者为说不受不说。受法者施其所须。不受法者则不供给。终不观察凡夫之人不可惠施。贤圣之人则应布施。是名不分别法。不分别心者。观诸众生心皆平等。不为报施。无内外贪。非为名施。不求果施。所爱之物施已不悔。为摄众生故行惠施。是名不分别心。不分别愿者。施时不为得帝释身梵王之身转轮王身魔身长者大臣之身。亦复不为大自在故。大眷属故。不为上有。不为声闻辟支佛乘。乃至不为阿耨多罗三藐三菩提故。而行布施。是名不分别愿。善男子。菩萨摩诃萨修惠施时。具足成就如是四事。则得远离八不正见。一者我见。二者众生见。三者寿命见。四者士夫见。五者常见。六者断见。七者有见。八者无见。是名为八。复得远离四种功德。一者凡夫功德。二者声闻功德。三者缘觉功德。四者余习功德。如是施已。不观四相。一者常相。二者乐相。三者我相。四者净相。能净四法。一者净身。二者净口。三者净心。四者净愿。远离三碍。一果报碍。二声闻碍。三悔心碍。善男子。菩萨修行如是施时。远离三畏。一者憍慢畏。二者上慢畏。三者魔业畏。菩萨修行如是施时。具四种印。一者内空印。二者外空印。三者众生空印。四者菩提空印。如是施时具四精进。一者满众生故具足精进。二者护佛法故具足精进。三者为具三十二相八十种好故具足精进。四者净佛土故具足精进。是时复得具足四念。一者念菩提心。二者念欲见佛。三者心常念慈。四者念离烦恼。如是施时净于三事。一者自身。二者他身。三者菩提。如是施时净于四智。一者界智。二者众生满足智。三者愿智。四者助菩提智。善男子。菩萨若能行如是法。则能净于檀波罗蜜。善男子。云何菩萨净于尸波罗蜜行。善男子。有一种净。所谓菩萨怜愍一切世间众生。胜于声闻辟支佛慈。能坏魔业调诸众生。具足无量功德宝聚。无有放逸。复有二种。一者于诸众生。不生恶心。二者调诸众生令向菩提。复有三种。一者净身。远离一切身恶业故。二者净口。远离一切口恶业故。三者净意。远离一切贪恚邪见故。复有四种。一者劝诸众生令持禁戒。二者劝诸众生具足净戒。三者能调诸毁戒者。四者见持戒者。供养恭敬尊重赞叹。复有五种。一持戒已不生憍慢。二见毁戒不生轻慢。三见持戒心无嫉妒。四终不求声闻之乘。五者不念辟支佛乘。复有六种。一者念佛。为过戒故。二者念法。为过戒已心不生悔。三者念僧。为能具足如来戒故。四者念戒。为不求诸有果报故。五者念施。为能一切悉施与故。六者念天。为欲具足诸善法故。复有七种。一者深信一切佛法。二者勤行精进。为得佛法故。三者具智。为知一切诸佛法故。四者闻已能说一切佛法故。五者供养父母师长和上。六者畏于现在未来恶业。七者有惭愧心。复有八种。一者不为利养显异惑众。二者不说自事。离一切故。三者不赞供养。心知足故。四者行圣种性。乐善法故。五者随头陀法。不惜身命故。六者乐于寂静。离说世事故。七者深心乐法。厌三界故。八者至心护法。不惜身命故。复有九种。一者离九恶心。过九众生所居处故。二者念净。三者念修。四者增长善法。五者心乐寂静。六者离烦恼热。七者庄严舍摩他。八者勤行精进。九者不欺众生。复有十种。一者净身三业。二者净口四业。三者净意三业。四者远离嫉妒。五者离谄曲心。六者至心念戒。七者为持戒故。勤行精进。八者软语。为调众生。九者受身为众生使。十者于诸福田不生轻慢。善男子。菩萨修行尸波罗蜜。有二种净行。一者有心有相及以庄严。宁舍寿命终不毁戒。二者无心无相及无庄严。于一切法心无所著。复有二种。一者净于内入。二者不求一切外入。复有二种。一者常愿菩提之心。二者不观本向菩提戒相。善男子。云何菩萨净羼提波罗蜜行。善男子。菩萨摩诃萨受骂不报口业净故。受打不报身业净故。受嗔不报意业净故。善男子。菩萨摩诃萨虽受骂辱所以不酬。护众生故。受诸楚毒所以不报。护后世故。被截手足慈心不嗔。护菩提故。见有求者。心不生嗔。为四摄故生慈心故。增菩提道故。坏悭贪心破魔业故。善男子。菩萨摩诃萨修念佛已。行于忍辱。受一切苦。为得佛身故。善男子。复有菩萨修于忍辱。为欲具足得十力故。复有菩萨修于忍辱。为欲成大师子吼故。复有修忍。为知三世无挂碍故。复有修忍。为得大慈大悲力故。复有修忍。为得具足一切智故

善男子。菩萨摩诃萨具足二力。能成就忍。一者智力。二者修力。以智力故观于身心。是故为忍。以修力故不着诸法。是故为忍。复次善男子。净忍菩萨则能观察一切法中无有众生。是故修忍。一切诸法其性解脱。是故菩萨观一切法。无忍无嗔。若于诸法心无所著。是名为忍。善男子。菩萨有二忍。一者观如法身。二者观如法界。菩萨摩诃萨若能如是观二法者。是名菩萨净羼提波罗蜜行。善男子。云何菩萨。净毗梨耶波罗蜜行。若菩萨摩诃萨于诸修行不息不悔。于诸善法心无厌足。亦乐修行五波罗蜜。常求庄严一切善法。拥护正法乐宣说之。调伏众生心无休息。过于声闻辟支佛乘。拥护一切诸佛正法。修诸苦行其心不悔。终不丧失本昔善根。广修多闻心无厌惓。为众走使不生愁悔。是名精进。如是精进云何名净。若能观身犹如影像。口无言说心毕竟净。以尽智观诸灭法。以无生智知诸有尽。如是观时则能庄严三种精进。一者体庄严。二者觉庄严。三者分别庄严。复有三种不着精进。一不着眼。二不着色。三不着识。乃至法亦复如是。是名不取不舍精进。具足如是勤精进已。不取惠施不舍悭贪。不取持戒不舍毁戒。不取忍辱不舍嗔恚。不取精进不舍懈怠。不取禅定不舍乱心。不取智慧不舍愚痴。不取善法不舍恶法。不取佛道不舍二乘。是名二种勤精进也。是二精进能具佛法。复有二种。所谓内外。若菩萨能修如是勤精进者。是名毗梨耶波罗蜜行净。善男子。云何菩萨净禅波罗蜜行。若菩萨摩诃萨。取诸禅支观诸禅支。观已入定。既入定已。不贪着色受想行识。是名为禅。非着眼禅乃至意禅。是名为禅。非着色禅乃者法禅。是名为禅。非着地水火风空禅。是名为禅。非着日月释梵自在天禅。是名为禅。非着欲界色无色禅。是名为禅。非着此彼禅。是名为禅。非观身心禅。是名为禅。非着上下禅。是名为禅。非着四取禅。是名为禅。非着众生寿命士夫我人相禅。是名为禅。非着常见断见有无见禅。是名为禅。非毕竟尽漏禅。是名为禅。非入定聚禅。是名为禅。非得沙门果禅。如是禅者。非毕竟行禅。名空调伏禅。非真空禅。名无相调伏禅。非真无相禅。名无愿调伏禅。非真无愿禅。是菩萨具足成就大慈大悲一切空行禅。云何名为具一切空。若能不观布施持戒忍辱精进禅定智慧方便。慈悲喜舍。四谛菩提。智慧誓愿庄严。舍摩他毗婆舍那。解脱惭愧。是名诸佛方便三昧神通无碍智。摄取十力四无所畏十八不共法。不为二乘之所染污。断诸习气。具足无量大神通智。为诸众生之所归依。庄严世法及出世法。能善调伏一切众生。渡于四流生死大海。能断一切所有系缚。净诸法性。是名性寂静。非向法寂静。亦取向法舍性。了了向法盲性。有闻向法聋性。勤调伏向法停住。凉灭寂静。调伏炽然。是名一切行空。善男子。譬如三千大千世界。所有众生悉善知画。其中或有善能泥涂。或能磨彩。或晓画身不晓手足。或晓手足不晓面目。时有国王。以一张[疊*毛]与是诸人。而告之言。凡能画者。悉来聚集于此[疊*毛]上。画吾身像。尔时诸人悉来聚集。随其所能而共作之。有一画师。以缘事故竟不得来。诸人画已持共上王。善男子。可言诸人悉集作不。不也。世尊。善男子。我说此喻。其义未显。善男子。一人不来故。不得言一切集作。亦不得言像已成就。佛法行者亦复如是。若有一行不成就者。不名具足如来正法。是故要当具足诸行。名为成就无上菩提。说是法时。六万菩萨于一切行。得具足空。善男子。云何菩萨摩诃萨净般若波罗蜜。善男子。菩萨摩诃萨具十二慧。一者知过去无碍。二者知未来无碍。三者知现在无碍。四者知有为无碍。五者知无为无碍。六者知一切世作无碍。七者知出世无碍。八者知辩才无碍。九者知实无碍。十者知世谛无碍。十一者知第一义谛无碍。十二者知诸众生利钝无碍。是名为慧。难破能破。难观能观。难解能解。譬如金刚不可沮坏。是名出世之慧。毕竟慧。一切众生真解心慧。难行难入难见。甚深难可习学。正见正聚。远离诸见及以习气。自知了了知见一切众生之心。法智义智无所贪着。旷大光明无诤无迮。善知时节过于时节。护正法聚。毕竟觉正觉实觉。远诸垢秽不为一切之所呵责。一行无行。一切众生行。无足迹行。虽离一切世间之行。亦不远离一切世行。虽离世界不离佛土。虽离一切诸行庄严。亦不远离调伏众生。虽离诸行不离善行。虽离众生心行因缘。不离知于众生心行。虽离世行不离世法。虽离诸身亦入众生心。是名为慧。如是智慧甚为难得。非善根纯熟终不能获。不能常修行善法者。亦不能得如是智慧。菩提树下乃能得之。真知法性诸佛所护。度至彼岸。知一切法施甘露味。是故名为般若波罗蜜。善男子。如是智慧。毕竟了知一切缘一切相。一切众生心之所行。以是义故名为智慧。如是智慧有二寂静。一者知碍相寂静。二者知无碍相寂静。复有二种。一者无觉净。二者离诸见净。如是智慧菩萨摩诃萨常游众生利钝根中。众生心中。一切法中。观诸烦恼即是智慧。菩萨虽住诸界。多住佛界。能善观见十方世界。离一切盖。悉是一切佛法根本。具足一切无上佛法。不学诸法不离诸法。不坏一法不成一法。菩萨成就如是智慧。能作功德能读诵说一切佛法。一切福德悉能得之。皆能修成一切善法。是名菩萨净般若波罗蜜行。说是法时。二万二千众生发阿耨多罗三藐三菩提心。八千菩萨得无生忍。五百比丘漏尽意解。十千天人得须陀洹果。尔时一切天与人同声而言。世尊。若有人能信是经者。当知是人诸佛所护。何况有能受持读诵书写供养。善男子。云何菩萨摩诃萨净菩提行。善男子。菩萨摩诃萨观身念处。有二种行。一者不净行。二者净行。不净行者。观身不净臭秽充满。无常无住诳诸凡夫。净行者。菩萨摩诃萨作是思惟。我今因是不净之身。得净佛身。得净法身。净功德身。一切众生所乐见身。复次善男子。菩萨摩诃萨观身身已。能净二行。一者无常。二者常。菩萨摩诃萨观身无常毕定当死。如是观已。不为身故造诸恶业邪命自活。修三坚法。一者身坚。二者命坚。三者财坚。如是观已。能为众生而作给使。即得远离身口意曲。菩萨如是观身无常。得如是等无量功德。云何为常。菩萨摩诃萨观无常已则得常身。因无常故得功德身。因无常故。不断佛种法种僧种。善男子。又复常者即是无尽。无尽者即是无为。无为者即是一切智所行处。一切智所行处者。是空无相愿。又复常者即是虚空。菩萨摩诃萨观一切法犹如虚空。是名菩萨摩诃萨常行。善男子。复有菩萨修身念处。观察一切众生之身。毕竟当是如来佛身。如如来身法身亦尔。如是二身我身亦尔。是名菩萨观无漏身。菩萨尔时所得善法。随其多少悉是无漏。以如是法。发愿回向一切种智。得无漏已终不起漏。所言漏者即是三漏。所谓欲漏有漏无明漏。菩萨了了知三漏已。为众生故生于欲界。亦复不为欲漏所污。色无色界亦复如是。无明漏者已拔其根。何以故。拔无明故则无见漏。菩萨摩诃萨修身念已。于是身中。不见我及我所不生憍慢。离我我所故。不求不取一切财物。不求取故于物无诤。以无诤故即是寂静。夫寂静者即是忍辱。住于忍辱不上不下。不上不下者即如法住。如法住者。不行善法不行恶法。不上下已即得善友。得善友已遇善知识。遇善知识故得闻正法。闻正法故不以漏心向有漏法。是名过于诸漏境界。过漏境已常入禅定。既入定已。乃至一法不生觉观。无觉观故。不作一法不变一法。是名如法。是名一切法平等。若得如是诸法平等。是名一切智。善男子。菩萨摩诃萨若能如是观身念处。是名观身身念。善男子。菩萨尔时次观受念处。于有受者生慈悲心。向诸众生作如是言。毕竟乐者断一切受。若人能断一切受者。即是常乐。菩萨尔时随所受者生慈悲心。若自若他受乐受时。远离爱心生于慈心。若受苦时。远离嗔心生于悲心。若受不苦不乐。离无明心生于舍心。是故菩萨受乐受时不生贪着。受苦受时不生嗔恚。受不苦不乐不生无明。菩萨尔时观一切受无常苦无我。见受乐者即知是苦。见受苦者如痈如疮。见不苦不乐受是不寂静。观于乐受即是无常。观于苦受即是空无。不苦不乐即是无我。菩萨尔时作是观已。见是诸受即是无受。见一切受即是有为。若是有为即是生灭散漏无住。如是观已。不见于我不见受者。是名菩萨大智方便。因是方便。见一切受无常生灭。观一切法悉是空无。无受无受者无作无作者。从缘而生从缘而灭。无属无取于诸因缘不生觉观。因无觉观。作如是言。诸因缘法皆悉是空。菩萨摩诃萨如是观时成受念处。能令身心皆悉寂静。知一切行。是名一切智。是名受受念处。云何菩萨修心念处。菩萨摩诃萨住菩提心。观是心性。不见内入心。不见外入心。不见内外入心。不见阴中心。不见界中心。既不见已作是思惟。如是心缘为异不异。若心异缘。则一时中应有二心。若心即缘。不应复能观于自心。犹如指端不能自触。心亦如是。作是观已。见心无住无常变异。所缘处灭。即知是心非从缘生非不缘生。非常非断非内非外非有非无。观心如是。不妨如法知心寂静。是名菩萨修心心念。复次善男子。菩萨摩诃萨观心非色不可睹见。非是觉观。是名菩萨修心念处。如心心数亦如是。如心数心行亦如是。如心行心所求法亦如是。如所求法。菩提亦如是。如菩提一切善法亦如是。菩萨若观心。如猕猴画水朝露蜂王鱼母。如河如焰。如想远事独行无身。常转无停。贪着诸界次第生灭。能摄如是无量之心。令住一处不动不转。不漏不错不乱不散。是名舍摩他。菩萨若能作如是观。是名成就观心心念处。是名知心境界。是名知心法界。是名知心真实之相。是名知心真实之性。即是广知即真净知。了知真知实知如幻。是名知法。名知心性。名知心尽。名无取知无挂碍知。菩萨摩诃萨如是观已。善知一切众生心性。知已如应而为说法。如知自心性。知一切众生心性。亦复如是。如自知心相。知一切众生心相亦复如是。如知自心空。知一切众生心空亦复如是。如观自心平等。观一切众生心平等。亦复如是。作是观已不动法界。是名菩萨修心心念处。善男子。云何菩萨修法念处。菩萨摩诃萨作如是观。法出法灭。无我众生寿命士夫。无生无灭无没无出。是名法性。若能求法是名出法。若不求法是名灭法。若善不善。出者从缘灭者从缘。如是观时观于三行。所谓恶行善行不动行。是三行中。我当常行福善之行。为十善法。十善法者。为净身业。欲求如来三十二相八十种好他不能害。净口业者。凡有所说众乐听受。净心业者。于诸众生其心平等。常入禅定。净四无碍智。净慈心故施众生常乐。净悲心故。无量世中为众生受苦其心不悔。净于十力。为知众生诸根利钝。净四无畏。为知众生障无障故。净十八法。为知三世无障碍故。净一切佛法。为一切众生无能胜故。菩萨摩诃萨能如是观。于诸善法及诸功德。不生厌足亲近善行。远离恶行及烦恼习。真实了知于不动行。虽知不贪心得自在。随愿往生非结业生。生于欲界为众生故。善男子。菩萨摩诃萨得善方便。观法念处。修集庄严助菩提法。远离一切障菩提垢。得是功德。不着常见不着断见。离是二见行于中道。夫中道者有二种法。一者不善念。二者无明。是二法中心不放逸。是名中道。复有二法。一行二识。复有二法。一者名色二者六入。复有二法。一触二受。复有二法。一爱二取。复有二法。一有二生。复有二法。一老二死。是二法中不放逸者。是名中道。如是中道。世间智慧所不能见。不可宣说不可显示。无有相貌无色无处无取无舍。清净寂静。善男子。夫中道者。不可眼见。乃至不可触触。亦无至处亦世出世。不可宣说非多非少。故名中道。善男子。我与无我名为二边。若有说言非常非断。非命非士。非想非非想。非觉非非觉。非实非虚。非此非彼。非有非无。非有为非无为。非行非非行。非生死非涅槃。不作如是。是名中道。复次善男子。菩萨摩诃萨观法法念。不分别法界。如法界众生界亦如是。如是二界名虚空界。一切诸法悉入法界。夫法界者即众生界。众生界者即无分别。是名观察一切法。等见一切界即是法界。虽明了见而心不着。以不着故则无分别。菩萨摩诃萨不以肉眼天眼慧眼观法念处。何以故。如是三眼无相貌故。是故观法则以法眼。虽了了知而心不着。虽复不着不失法界。是名佛智。能知如是甚深法界。亦不失于一切智念。是名菩萨修法法念处。善男子。菩萨摩诃萨何故修集是四念处。为欲远离四颠倒故。修身念处为离净倒。修受念处为离乐倒。修心念处为离常倒。修法念处为离我倒。又离四食。修身念处离于抟食。修受念处离于触食。修心念处离于识食。修法念处离于思食。又复远离识四住处。修身念处离住色处。修受念处离住受处。修心念处离住想处。修法念处离住行处。复离五阴。修身念处远离色阴。修受念处远离受阴。修心念处远离识阴。修法念处离想行阴。是名菩萨净四念行。善男子。云何菩萨修四正勤行。菩萨摩诃萨常乐修集一切善法。未生恶法为不生故勤行精进。已生恶法为远离故勤行精进。未生善法为令生故勤行精进。已生善法为住不失故勤行精进。善男子。菩萨摩诃萨于无量世修集善行。是故性善。不以方便令恶不生。若有菩萨修四正勤心得自在。四正勤者。菩萨尔时心及心数与大慈悲和合共行。故名正勤。菩萨尔时次第修集四如意足。一者欲。二者心。三者进。四者慧。专念至心念于菩提。是名为欲。修大悲故觉心轻便。是名为心。远离恶法是名精进。得方便故名之为慧。菩萨修四如意足已。得四自在。一者寿命自在。以自在故。虽生短命自得长寿。为调众生。与长寿者演说正法。于长寿中能现短寿。随是菩萨所生之处。若天若人得命自在。二者身得自在。以自在故。随心作身随心作色。示现威仪为众生故。菩萨若欲于诸众生其身同等。高大微小悉皆能作。三者得法自在。以自在故。能知一切世出世法。示诸众生一切世事。于出世行心亦不退。明知甚深十二因缘。得无碍智。能为众生说种种法。无量众生闻是法已。发阿耨多罗三藐三菩提心。四者愿得自在。以自在故。令四大海合作一海。不来不去无有动转如本不异。亦令三千大千世界诸须弥山合为一山。不来不去无有动转如本不异。于四天王三十三天无所妨碍。欲令三千大千世界。悉作金宝七宝栴檀华香璎珞。虚空水火皆随意成。是名菩萨得四自在。善男子。菩萨若得四如意足。则得面见十方诸佛。与共语言进止一处。一切梵天帝释四王。阿修罗乾闼婆迦楼罗紧那罗摩睺罗伽。亦复如是。云何净严四如意足。善男子。若能供养父母和上师长有德。见诸众生先意问讯。柔软与语如语而作。视诸众生其心平等。善心正心恭敬心惭愧心。远离贪欲嗔恚愚痴。无欺无贪无姤无悭。营他事业如己所作。无势力者助其力势。泥涂之处发治土石。河涧沟渠造作桥梁。或以身负或施船济。常施众生所须之物。口不说他衰恼之事。亦不讥刺他所犯罪。有犯罪者能如法除。遮诸烦恼令不生起。所重之物能以施人。既施之后心不生悔。为诸众生发愿回向。信心以善劝诸众生。不惜身命少欲知足。于他利养心无悕望。常念出家亦劝众生。念善知识无心舍离。于怨亲中平等无二。以种种乘施行路者。羸乏之人施床卧具。有恐怖者能为救护。视诸众生如父母想。不轻毁戒施贫财物。有病瘦者给其医药。施恩于他不自称说。终不断绝三宝种性。常念无为。远离世事一切诸恶不善之法。不为世法之所污染。不失菩提至心之念。是名庄严净四如意足行

大方等大集经卷第二十五大方等大集经卷第二十六

        北凉天竺三藏昙无谶译

    宝髻菩萨品第十一之二

云何菩萨净五根行。菩萨信心不可动转。名为信根。不由他教而行精进。名精进根。常念菩提名为念根。常修大悲名为定根。摄取善法名为慧根。复次信诸佛法名为信根。求诸佛法名精进根。念诸佛法名为念根。得佛三昧名为定根。断诸疑网名为慧根。复次心向菩提无有疑网。名为信根。增长善法名精进根。求善方便名为念根。视诸众生其心平等。名为定根。观诸众生上中下根。名为慧根。复次心净无浊名为信根。坏众浊心名精进根。念清净法名为念根。观心性净名为定根。能令众生住清净法。名为慧根。复次远离一切弊恶之法。名为信根。求诸善法名精进根。得已不失名为念根。既得善法如法而住。名为定根。思惟善法不善无记。名为慧根。复次信根者即是施心。精进根者即是乐施无有休息。念根者既施之后不求果报。定根者即平等施心无分别。慧根者不观福田及非福田。复有信根。即是初入善法之心。精进根者能坏憍慢。念根者离我我所。定根者远离一切六十二见。慧根者远离一切诸恶烦恼。是名菩萨净五根行

云何菩萨净五力行。善男子。菩萨摩诃萨具足五根。不为诸魔之所破坏。故名为力。一切声闻辟支佛乘所不能及。一切众生不能令其退大乘心。一切烦恼不能破坏。能令其心知足少欲。身得大力善覆诸根得金刚身。是名为力。善男子。菩萨摩诃萨住信力时。终不造作一切诸恶。住进力时造一切善。住念力时不失善法。住定力时不为五欲乐之所坏。住慧力时远离一切诸结烦恼。复次住信力时不随他语。住进力时求善不息。住念力时得陀罗尼。住定力时说法平等。住慧力时能坏一切众生疑心。复次住信力时具得解力。住进力时具精进力。住念力时具解脱力。住定力时具足愿力。住慧力时具诸行力。复次住信力时见悭罪过。住进力时远离悭贪。住念力时以所修善愿向菩提。住定力时其心平等。住慧力时心终不求施戒定报。复次住信力时能离一切破戒之垢。住进力时至心具戒。住念力时以所持戒愿向菩提。住定力时具清净地。住慧力时远离作戒。复次住信力时远离嗔心。住精进力修习忍辱。住念力时以所修忍愿向菩提。住定力时护诸众生。住慧力时不观众生士夫寿命。复次住信力时远离懈怠。住进力时所修诸行到毕竟岸。住念力时所修精进愿向菩提。住定力时身心寂静。住慧力时不住善恶。复次住信力时远离一切匆务之事。住进力时勤求禅支。住念力时以所修定愿向菩提。住定力时其心常定。住慧力时不着诸定。复次住信力时远离无明。住进力时勤求诸善。住念力时以所修智愿向菩提。住定力时修善思惟。住慧力时如法而住。复次住信力时具足七力。住进力时得住七觉。住念力时得八念处。住定力时离七识处。住慧力时离八邪支。复次心于菩提无有退转。是名信力净信力行。不取不舍是名进力净进力行。修四念处是名念力净念力行。调伏于心是名定力净定力行。远离诸见知善方便。是名慧力净慧力行。善男子。云何菩萨净七觉行。终不失于助菩提法。名念觉分。不取不舍奢摩他。名择觉分。离一切恶名进觉分。离诸愁恼名喜觉分。身心寂静名除觉分。得解脱味名定觉分。所作已办名舍觉分。复次不舍菩提心名念觉分。至心护法名择觉分。调诸众生无有休息名进觉分。具足善法名喜觉分。离诸烦恼名除觉分。能令众生住三昧中名定觉分。令诸众生悉知法界名舍觉分。复次不念声闻辟支佛乘。名念觉分。分别一切法字句义。名择觉分。求善法时三业不息。名精进觉分。离怨亲心名喜觉分。如法而住名除觉分。随诸世间而能调伏。名定觉分。不观二法名舍觉分。善男子。助菩提者。觉一切法知一切法。分别诸法筹量诸法。知诸众生心性心行。是名菩提分。亦名圣行。如是圣行。非是一切凡夫魔众邪见所行。非是色声香味触行。非一切相一切受。诸心意识见闻觉知。有想无想一切法行。故名圣行。夫圣行者。非觉非非觉亦非大觉。而能对治一切诸法。然复不与诸法诤讼。是名圣行。圣行者即是佐助菩提之法

善男子。云何菩萨净八道行。八道者。所谓正见。云何正见。正见者。见一切法皆悉平等。如是正见不名空见。何以故。自有正见非是空见。如是二见亦名同见。复有我见众生见空见。不名正见。如是三见亦复同见。又众生见命见空见。不名正见。如是三见亦复同见。又有我见断见空见。不名正见。如是三见亦复同见。又有有见无见空见。不名正见。如是三见亦复同见。复有四见。佛见法见僧见空见。是名正见。如是四见不名空见。善男子。若有人着如是见者。不名正见。若不著者乃名正见。何以故。夫正见者。见无分别平等无二。云何名为平等见耶。若作是念。凡夫法下学法为上。如是名为非平等见。凡夫法漏学法无漏。凡夫法食缘觉无食。凡夫法垢菩萨法净。凡夫有为佛是无为。如是见者非平等见。若能观察凡夫之法乃至佛法无有差别。乃名平等。若能观见凡夫法空至佛法空。是名正见。观凡夫法从因缘生辟支佛法亦从缘生。乃名正见。若观凡夫法寂静菩萨法寂静。是名正见。若观凡夫法不具足。乃至佛法亦不具足。是名正见。若观我与无我无有差别无差别见。乃名正见。若如是见则不见于上中下法。于一切法亦无觉观。是名正见。正见者名无所见。无所见者即是正见。若如是见。是人乃至不见一法一法相貌一法光明。善男子。若如是见。是名佛法之正见也。说是法时。五百比丘得阿罗汉果。善男子。云何正觉。正觉者离一切觉。觉者名为智慧方便。观法知法是名正觉。观察诸法何者是垢何者是净。如是观已。都不觉知等与不等。离一切觉是名正觉。云何正语。口所出言不自焦恼亦不焦他。不自污辱亦不污他。不自生慢不生他慢。不自诳惑不诳惑他。是名正语。复次正语凡有所说。说一切法皆悉平等。善能分别有为之相。是名正语。复次正语说一切法空无相愿。无生无灭无出无没。是名正语。复次正语说有为苦无常无我涅槃寂静。是名正语。若有众生说言众生。一切无有寿命士夫。一切诸法从因缘生从因缘灭犹如子果。是名正语。净正语者即是佛语。是名净正语行。云何正业。正业者。若业虽能坏一切业。亦不名业。若业能作寂静之因。不垢不净能坏烦恼不令增长。是名正业。知业如是犹作善业。亦观诸业皆悉空寂。无有坚实是苦无乐。是名正业。云何正命。正命者。若命不妨自身他身。不增一切诸恶烦恼非恶业活。是名正命。菩萨摩诃萨于诸众生净于正命。以是正命愿向菩提。是名正命。如是正命能利自他。正精进者。勤作方便求诸善法。欲心不息无有厌悔。是名精进。推求诸法平等之性。亦不观法等与不等。不作非不作。了知于如法性实性。名正精进。宣说正法令诸众生离邪精进。亦知众生所修行行。是名正精进。云何正念。若念施戒忍辱精进禅定智慧四无量心。是名正念。复有正念。摄诸烦恼不令妄起。不近一切恶魔诸业。不堕恶道不起恶心。常修一切正善之法。远离一切邪恶之法。是名正念。菩萨住是正念之中。获得正聚沙门正果。是名正念。云何正定。修行圣行知苦离集证灭修道。是名正定。复有正定。观一切法皆悉平等。若观我净一切亦净。若观我空一切亦空。虽作是观不入正位。是名菩萨之正定也。菩萨摩诃萨住是定中。于一念顷得一切智。是名正定。说是法时。万六千天与人发阿耨多罗三藐三菩提心

善男子。云何菩萨净神通行。善男子。天眼五种。悉能睹见十方世界。及见十方世界诸佛。亦见众生出生退没。所见十方无有挂碍。胜于一切声闻缘觉及诸天人。菩萨具足如是五事。则能了了见一切法。是名菩萨净天眼行。菩萨摩诃萨得天耳通。闻五种声。人声。非人声。地狱声。十方诸佛说法之声。一切众生语言音声。是名菩萨净天耳行。云何菩萨净他心智行。知他心智亦有五种。悉知一切人天之心。地狱饿鬼畜生等心。知过去心。知未来心。知现在心。是名菩萨净他心智行。复有他心智。知是众生是正定聚。是邪定聚。是不定聚。知是众生有贪嗔痴。既了知已随应说法。众生闻已得坏烦恼。是名菩萨净他心智行。云何菩萨净宿命智行。了知是身从贪恚痴因缘而生。了知是身从施戒忍精进定慧慈悲喜舍因缘而生。了知是身具足不具足。了知是身因无明爱及四倒生。了知是身施因缘故具足财物及以眷属。如是等智。是名菩萨净宿命智行。云何菩萨净神通行。神通行者亦有五种。一者示色。二者解种种语而为说法。三者善能了知心意识等。四者能觉诸法说一切法。是名菩萨净神通行

善男子。如是五通为漏尽故。菩萨修习而不尽漏。为欲了知一切诸漏。何以故调众生故。善男子。譬如一城纵广一由旬多有诸门。路崄黑闇甚可怖畏。有入城者多受安乐。复有一人唯有一子爱念甚重。遥闻彼城如是快乐。即便舍子欲往入城。是人方便得过崄道。到彼城门一足已入未举一足。即念其子。寻作是念我唯一子。来时云何竟不与俱。谁能养护令离众苦。即舍乐城还向子所。善男子。菩萨摩诃萨亦复如是。为怜愍故修习五通。既修习已。垂得尽漏而不取证。何以故。愍众生故舍漏尽通。乃至行于凡夫地中。善男子。城者喻于大般涅槃。多诸门者喻于八万诸三昧门。路崄难者喻诸魔业。到城门者喻于五通。一足入者喻于智慧。一足未入者喻于菩萨未证解脱。言一子者喻于五道一切众生。顾念子者喻大悲心。还子所者喻调众生。能得解脱而不证者。即是方便。善男子。菩萨摩诃萨大慈大悲不可思议。宝髻菩萨白佛言。世尊。如佛所说大慈大悲不可思议。实如圣教。不但慈悲不可思议。善方便力亦不可思议。菩萨了了自知当得阿耨多罗三藐三菩提而不证之。为众生故行于生死。不为生死之所污染。世尊。菩萨摩诃萨具何等法。在生死中心不厌悔。善男子。菩萨摩诃萨具二十一法。在生死中而不生悔。一者所修善法共大慈行。二者所修慈心共大悲行。三者所修大悲共调众生行。四者调伏众生共精进行。五者所修精进共善心行。六者所修善心共方便行。七者所修方便与慧共行。八者所修习慧共禅定行。九者所修四禅共神通行。十者所修神通与智共行。十一者所修习智与欲共行。十二者所修习欲与念共行。十三者所修习念共菩提心行。十四者所修菩提共四摄行。十五者所修四摄与戒共行。十六者所修戒禁共多闻行。十七者所修多闻共如法住行。十八者如法共住陀罗尼行。十九者陀罗尼共无碍智行。二十者无碍智共功德庄严行。二十一者功德庄严共智慧庄严行。是名菩萨二十一法在生死中不生厌悔

宝髻菩萨白佛言。世尊。云何菩萨庄严自身。亦令众生得大利益。佛言。善男子。菩萨摩诃萨若具多闻则名庄严。为他演说名大利益。复次得大总持名为庄严。为他演说名大利益。复次无有放逸名为庄严。调伏众生名大利益。复次三十二相名为庄严。具大智慧名大利益。复次口言柔软名为庄严。说如说行名大利益。复次能一切施名为庄严。不求果报名大利益。善男子。是名菩萨庄严自身。亦令众生得大利益。善男子。过去无量阿僧祇劫。劫名乐喜。彼中有佛号一切众生乐念如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛世界名曰天观。善男子。何故彼劫名曰乐喜。彼大劫中具有六万诸佛出世。彼劫之初首陀婆天。唱如是言。是劫当有六万佛出。众生闻已心皆乐喜。是故彼劫名曰乐喜。善男子。其佛世界庄严微妙无有限量。快乐好妙如天无别。是故世界名曰天观。其土皆悉栴檀为地。一切无有土沙尘雾。其香遍薰无量佛土。其地周遍出诸莲华。一一诸华有大光明遍照其土。其土众生悉得神通足不蹈地。乃至无有一人处胎皆悉化生。一切不闻女人之名。亦无受苦三恶道名。一切众生禅喜为食其土无有三乘之名。一切皆以真金璎珞天冠宝饰而自庄严。虽无剃发染衣袈裟。而亦得名出家之人。何以故。于一切物舍无贪故。彼土如来色如梵天。现梵天身。为诸菩萨演说法要。若他世界有诸菩萨。见彼佛已受大欢喜。善男子。彼佛若欲宣说法化。升大法座在大众上七多罗树。常略说法。何以故。一切众生根猛利故。如来所说唯是一句。而诸众生解百千句。如来常说四净之法。何等为四。一者波罗蜜净。二者助菩提净。三者神通净。四者调众生净。时有菩萨。名曰宝聚。白佛言。世尊。云何菩萨庄严自身。亦令众生得大利益。彼佛答言。善男子。菩萨若具无碍智者名为庄严。能作智明名大利益。尔时彼佛说是法时。六千菩萨得无生忍。时彼菩萨复白佛言。世尊。云何菩萨庄严菩提树。佛言。善男子。菩萨若能修不放逸。是名庄严菩提之树。云何名为不放逸。不放逸者名如法住。如法住者如说而住。复次不放逸者。名无量庄严。无量布施。无量持戒。无量忍辱。无量精进。无量禅定。无量智慧。无量佛法。无量调伏。无量功德智慧庄严。供养无量诸佛世尊。具智慧故无量多闻。为增智慧故无量修奢摩他毗婆舍那。成就如是无量等法。名为庄严菩提之树。亦能疾得阿耨多罗三藐三菩提。善男子。一切佐助菩提之法。以不放逸而为根本。具大庄严一切智慧。不失一切善法。远离一切烦恼。摄取一切诸法。于一切法无有挂碍。调伏诸根护诸善法不令退失。知时非时。具足十力四无所畏。佛法顶法名不放逸。善男子。说是法时。万二千菩萨得无生忍。尔时宝聚菩萨。即汝身是。善男子。汝今当知具不放逸菩萨摩诃萨。则能庄严菩提之树

善男子。云何菩萨净于调伏。善男子。众生之行。无量无边不可思议。调伏亦尔。无量无边不可思议。菩萨行亦无量无边不可思议。菩萨摩诃萨一心至心调伏众生。善男子。有诸众生闻说惠施则得调伏。或有众生闻说持戒而得调伏。复有众生闻说施戒而得调伏。复有众生软语调伏。复有众生嗔语调伏。复有众生具二种语而得调伏。复有众生闻说身业而得调伏。复有众生闻说舍身而得调伏。复有众生胜能调伏。复有众生强可调伏。复有众生闻说呵责而得调伏。复有众生施时调伏。复有众生初时调伏。复有众生见妙色已而得调伏。声香味触亦复如是。复有众生常亲近故而得调伏。复有众生。常远住故而得调伏。复有众生见佛调伏。或有众生闻法调伏。或有众生闻无常法而得调伏。苦空无我亦复如是。或有众生闻说施声而得调伏。戒忍精进禅定智声。亦复如是。或有众生闻说一切有为无常而得调伏。或有众生闻赞人天而得调伏。或有众生闻声闻乘而得调伏。辟支佛乘佛乘亦复如是。或以四摄而得调伏。或以三摄二摄一摄而得调伏。或复不以四摄之法而得调伏。或因内施而得调伏。外施内外施亦复如是。或闻宣说地狱中苦而得调伏饿鬼畜生人天亦尔。或说纯乐而得调伏。或闻纯苦而得调伏。或闻苦乐而得调伏。或有睹见比丘形像而得调伏。比丘尼优婆塞优婆夷像而得调伏。或因种种作倡伎乐而得调伏。善男子。菩萨如是能知种种调伏众生行。是名菩萨能行六波罗蜜。具足佐助菩提之法。具足神通调伏众生。善男子。若有菩萨具足四法。则能调伏一切众生。一者心不悔厌。二者不贪诸乐三者知时非时。四者了知诸心。复有四法。何等为四。一者正语。二者爱语。三者净语。四者如法语。复有四法。一者于诸众生心无挂碍。二者悲心。三者利益心。四者自调诸根。复有四法。一者净于自心。二者怜愍他心。三者勤行精进。四者远离受乐。善男子。是故菩萨摩诃萨调伏之行。无量无边不可思议。善男子。过去无量阿僧祇劫。有劫名爱。是中有佛号广光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名寂静。彼佛具有九万六千亿声闻众。八万四千诸菩萨众。其土人民寿命十七万二千岁。尔时有一大王之子。名财功德。婆罗门种。颜貌端正众生乐见。年十六时自恃端正而生憍慢。初不向佛恭敬礼拜。尔时如来即作是念。如是王子今将退失阿耨多罗三藐三菩提善根不熟。若得善友则得诣佛闻法受持。尔时如来即于八万四千菩萨大众之中。行筹而言。谁能调伏是婆罗门子。谁能于是八万四千年中。经常往返是王子家若受众苦。所谓骂打心不生悔。八万四千诸菩萨等乃至无有一人取筹。第二第三亦复如是。第三唱已。有一菩萨名净精进。即从座起偏袒右肩。右膝着地合掌而言。世尊。我今能诣彼王子家甘心受苦。说是语时三千大千世界为大震动。一切人天咸共同声唱言。善哉善哉大士。时净精进菩萨。即便往彼王子门立。王子见之恶言呰毁以土坌面。刀杖瓦石而加其身。菩萨尔时不嗔不去心不疲厌。经一千年受如是苦。过二万岁乃得至彼第二门下。八万四千年七日未满。方得至其第七门下。尔时王子见是菩萨。便作是言。道士今来何所求索。即于菩萨生不思议心。云何是人经尔所时。多受众苦而心不厌。第二第三亦如是言。道士今来欲何所求。尔时菩萨知彼王子心已调伏。即说偈言。

  世间所有一切财　　金银琉璃及颇梨
  及四供养我不须　　唯为法故来至此
  此世有佛名广光　　为众生说无上法
  众生闻已离烦恼　　亦受无量甘露味
  诸佛世尊出于世　　甚难于彼灵瑞华
  今此世出无上尊　　汝乃放逸沈欲海
  一切众生常闇行　　无上如来施慧炬
  自恃财色生憍慢　　而不往诣如来尊
  一切财宝众生命　　佛说是二悉无常
  众生若闻是甘露　　不诣佛者名放逸
  汝本往昔行菩提　　请诸众生许法味
  汝今犹属诸烦恼　　云何能调诸放逸
  我今求汝共诣佛　　破坏憍慢离烦恼
  勤修精进舍国事　　令汝终时心不悔
  是时王子闻是已　　远离憍慢即生信
  赞叹恭敬净精进　　忏悔先来所加苦
  我今舍离国土事　　及以上妙五欲乐
  坏破憍慢至佛所　　听甘露法调众生
  八万四千众围绕　　持妙香华往供养
  到已即便奉献佛　　破慢至心而听法
  礼拜合掌心欢喜　　向佛世尊发是言
  我今归依净精进　　受苦不悔调伏我
  虽设多供不能报　　今于佛前至心悔
  我所修行菩提道　　以慈悲心调众生
  我更不造放逸心　　乃至获得菩提道

善男子。尔时王子即舍王位。在佛法中出家听法。如法而住得无生忍。善男子汝知。尔时净精进者岂异人乎。莫作斯观即我身是。财功德者即弥勒是。善男子。是故菩萨调众生行。无量无边不可思议。若有菩萨能调众生。是真菩萨所修之业。善男子。菩萨摩诃萨有四种业。一者净佛国土菩萨业。二者净身菩萨业。三者净口菩萨业。四者求一切佛法菩萨业。复有四业。一者知心。二者知根三者知病四者能治

尔时宝髻菩萨闻是法已。即以髻上真宝之珠价直无量。从无量业之所出生。奉献如来。作是誓愿。我今以是顶宝施佛。愿此功德为众生首。因是因缘得无上智。尔时世尊即便微笑。是时口中出大光明。种种杂色。悉能隐蔽一切光明。尔时疾辩菩萨即起合掌白佛言。世尊。何因缘故如来微笑。佛言。善男子。汝见宝髻施我顶宝不。已见世尊。善男子。如是菩萨已于无量无边佛所。发阿耨多罗三藐三菩提心。持戒精进求于菩提。供养无量恒河沙等诸佛世尊。亦已调伏恒河沙等无量众生。善男子。如是菩萨于未来世。过十阿僧祇劫。当得阿耨多罗三藐三菩提号曰宝出。世界名净光。劫名无垢。其佛世界七宝所成。光明遍照十方世界。一切人民无有饥渴。一切皆是清净菩萨。耳初不闻二乘之名。常闻纯一大乘之法。是故如来名曰宝出。一切菩萨具足神通。其土无主唯除法王。一切众生悉得化生。亦复无有三恶之名。及男女根爱欲之名。无有众生不具诸根。亦无边地。众生寿命四万中劫。是佛世尊不说余事。唯除六度菩萨慈悲一切利根。闻说一句悟解千句。是佛常为一切菩萨说陀罗尼金刚句。云何名为陀罗尼金刚句。陀罗尼金刚句者即是一句。如是一句即摄一切法句无尽法句。无尽法句一切诸佛所不能尽。是故名为无尽法句行。无尽法句摄一切字。一切宇者摄一切法句。一时不得说于二字。一字亦复不合二字。是故名一句。名为作句名为字句。若不分别字句法句作句。是名陀罗尼金刚句。善男子。如是陀罗尼金刚句。彼佛常为诸菩萨说。善男子。若我一劫若减一劫。说彼如来所有功德不能具尽。尔时宝髻闻授记已心大欢喜。说偈赞叹

  一切知见一切事　　得到一切法彼岸
  远离一切诸烦恼　　是故名佛无上尊
  我所供养无量佛　　如来善了如一佛
  如来获得无碍智　　故知三世无障碍
  如来今为我授记　　令我远离疑网心
  我亦当得真实道　　如今释迦牟尼尊
  一切大地能令散　　虚空日月可令落
  如来之言无有二　　是故我定得菩提
  正语实语微妙语　　授我无上菩提记
  若我真实得菩提　　当善调伏无量众
  我之所得净妙国　　及其大众佛已说
  我今闻此无上法　　坏疑趣向于菩提
  我今精进修菩提　　调伏众生心不悔
  今佛口施我信力　　无上智慧及佛力

说是偈时。万二千众生发阿耨多罗三藐三菩提心。各作是言。愿我皆得生彼世界。尔时世尊告阿难言。汝当受持如是正法。读诵广说为大利益诸天世人。阿难。若有众生信受是经。定当为我之所授记。善男子。若以三千大千世界满中七宝给施众生。满一千年。不如有人受持读写如是经典。阿难白佛言。世尊。是经何名。云何奉持。阿难。是经名曰方等大集大陀罗尼大行菩萨入处。尔时阿难闻佛说已。诸天世人皆大欢喜。信受奉行

大方等大集经卷第二十六大方等大集经卷第二十七

        宋凉州沙门智严共宝云译

    无尽意菩萨品第十二之一

如是我闻。一时佛游王舍城如来行处宝庄严堂。是大功德之所修成。佛一切法本行果报。苞容无量诸菩萨众。其所讲宣悉是无量甚深之义。皆是如来神力护持。入无碍行微妙智门。其心欢喜得念进意。分别智慧无轻毁者。若有称赞叹其功德。尽未来世不可穷尽。如来正觉觉平等法。善转法轮度无量众。于一切法而得自在。知众生意尽其根源。善为众生断诸习气。虽为佛事心无所作。与大比丘六百万人。悉是如来法王之子。善得解脱断烦恼习。晓了甚深无生法忍。成就威仪其行端严。堪受供养为众福田。善持诸佛所说教戒。复有菩萨摩诃萨众。其数无量不可称计不可思议不可宣说。是诸菩萨于一念顷。能过无量无边佛刹。已曾供养过去诸佛。咨受妙法无有厌足。常勤教化无量众生。善解方便智慧具足。其心安住无碍解脱。善除忆想取相戏论。近一切智悉是补处。其名曰电天菩萨。胜诤菩萨。日藏菩萨。勇健菩萨。离恶意菩萨。游行菩萨。观眼菩萨。离闇菩萨。如是无量菩萨大士。德皆如是

尔时世尊入诸菩萨所行无碍诸法门经。所谓庄严诸菩萨道甚深佛法。十力无畏智慧成就。获得自在总持印门。分别诸辩大神通门。转不退转无生法轮。通达诸法同于一相。于一相法不生分别。知诸众生根性无碍。善能观察诸法实相。破坏一切诸魔境界。入于通达善思惟门。能除一切烦恼诸见。无碍智慧善权方便。一切佛法平等无二。受持诸佛智慧之门。演说诸法如真实相。忆想取相入平等门。成就功德入深因缘。庄严佛身身口意业。念意进持显示四谛。分别妙慧化声闻故。身心寂静化缘觉故。得一切智化大乘故。入一切法得自在智。赞叹如来诸功德故。如是等门宣说开示教导分别

时佛说是大集经时。于此东方自然出现大金色光。照此三千大千世界靡不周遍。除佛光明其中所有日月释梵护世天王。诸龙鬼神乾闼婆。阿修罗．迦楼罗．紧那罗．摩睺罗伽。所有光明悉不复现。诸墙壁等树木丛林。小山大山。目真邻陀山。铁围山。大铁围山。及国土中间其光彻照。若此世界所有地狱皆蒙其光。其中众生光触身时。除一切苦受微妙乐。尔时佛前大众之中。其地自然出六十亿净妙莲华。好香流布种种庄严。诸华杂色悦可众心。其华各有亿百千叶。以宝罗网弥覆其上。华质柔软犹如天衣。其有触者受妙快乐。是一一华所出诸香。遍满三千大千世界。是世界中若天若人。所有诸香悉灭不熏。诸龙八部闻其香者。皆得妙喜渐离烦恼。尔时尊者阿难见是金色光明及诸莲华白佛言。世尊。今此瑞应谁之所为。有是光明及诸莲华。佛告阿难。有菩萨摩诃萨名无尽意。在此东方。与六十亿诸菩萨俱。眷属围绕欲来至此故先现瑞。未久之间。时无尽意即以神力。感动此地令大震动。放无量光雨种种华。亿那由他诸天人等。作百千伎乐。与六十亿诸菩萨众周匝围绕来至佛所。至佛所已寻于佛前住虚空中高七多罗树。合掌向佛出微妙音。其声遍闻大千世界。即以偈颂而赞叹佛

  清净永离垢　　勇健除诸欲
  能灭众尘劳　　而得净妙眼
  三垢荒秽等　　善断吐洗灭
  一切皆无余　　稽首大慈觉
  除去诸怖畏　　善灭无明网
  十力圣主王　　邪论不能伏
  外道异见人　　皆悉怀怖畏
  犹如师子王　　独步无所惧
  正觉净光明　　无垢普照曜
  天人世间中　　能离一切闇
  除尽众闇冥　　无有无明网
  其光常明净　　如日出云雾
  众生老死苦　　无有救护者
  为调是等故　　而受无量苦
  能生坚慈悲　　唯有等正觉
  犹如大医王　　勤行疗众疾
  一切诸法本　　其性无有我
  譬如山谷响　　皆从众缘生
  众生本无性　　无作无受者
  而能为此故　　生于大慈悲
  诸有之渊海　　无明闇甚深
  其中多觉观　　勇溢而波浪
  不从他闻法　　自然到彼岸
  如莲华在水　　行世不染污
  秋月草木零　　盛热河池竭
  比智知世法　　迁动不常住
  愚人所亲近　　圣智所呵弃
  解法不牢固　　独拔渡有流
  其面目开明　　譬如优钵罗
  微妙甚清净　　过百千日月
  所有过去世　　及现在众生
  一切所赞叹　　如来悉堪受
  调不调伏故　　除热得清凉
  是故我今日　　稽首无上尊
  度世增上福　　功德无有极
  如人中牛王　　顶礼佛福田

尔时无尽意菩萨以如实赞赞叹佛已从空中下。及六十亿诸菩萨众顶礼佛足。礼佛足已右绕三匝。于华台上结加趺坐

尔时舍利弗白佛言。世尊。是无尽意菩萨摩诃萨。从何处来。佛号何等。世界何名。去此远近。佛告舍利弗。汝可自问。无尽意当为汝说。时舍利弗。敬顺佛教问无尽意。唯善男子从何处来。佛号何等。世界何名。去此远近。无尽意言。唯舍利弗。有来想耶。舍利弗言。唯善男子我知想已。无尽意言。若知想者应无二相。何缘问言从何处来。唯舍利弗。有来去者为和合义。如和合想。是无合无不合。无合无不合即不去不来。不去不来者是圣行处。唯舍利弗。有来去者即是业相。如业相无作无非作。无作无非作即不去不来。不去不来者是圣行处。唯舍利弗。有来去者是国土相。如国土相。无国土无非国土。无国土无非国土即不去不来。不去不来者是圣行处。唯舍利弗。有来去者即是缘想。如缘想无缘无非缘。无缘无非缘即不去不来。不去不来者是圣行处。唯舍利弗。有去来者即因等生相。如因相。无因无非因。无因无非因即不去不来。不去不来者是圣行处。唯舍利弗。有去来者即是文字语言。如文字相。无文字无非文字。无文字无非文字即不去不来。不去不来者是圣行处。舍利弗言。唯善男子。汝今所说微妙事相。吾从昔来所未曾闻。向之所疑当还启请。如主关人。若见空行若见担者。即应诘问。汝所赍持悉是何物。若知种稷应收其税。唯善男子。我等如是。从他闻法随音声解以自照心。是故我今应当咨禀。汝等大士。为护大乘出生无量声闻缘觉。唯善男子。愿为分别说其来处。无尽意言。唯舍利弗。汝今自可咨请如来。如来当说断汝疑网

时舍利弗。即白佛言。唯愿世尊。说是菩萨从何处来佛号何等世界何名去是远近。若闻彼佛及世界名。则令无量无边菩萨庄严菩提。佛告舍利弗。谛听谛听善思念之。吾今当说彼土功德及佛名号。汝闻是时勿怀疑惧。应当一心信受奉持。时舍利弗。闻是语已。赞言善哉善哉。世尊。愿时宣说。我当一心顶戴受持。佛告舍利弗。东方去此度十恒河沙国土微尘等世界。彼有世界名曰不眴。是中有佛号曰普贤如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊今现在。舍利弗。其土无有声闻缘觉。乃至不闻二乘之声。一切圣众纯是菩萨。已于过去久修德本。善业成备布施调伏。自守防护戒忍多闻。心不放逸安住功德。威仪成就忍力无碍。于无上道坚固精进。所修善根一切成就。诸禅解脱三摩婆提。游戏神通大智照明。善分别知一切诸法。所怀慈心等如虚空。大悲坚固拯济众生。常行喜心令彼同欢。所有舍心善灭憎爱。魔网诤讼悉使无余。善解众生诸根所趣。随其根量授与法财。其心平等如地水火风。能坏一切外道异论。摧伏敌阵建立胜幡。入深佛法十力无畏。于诸大众心无所惧。常观甚深十二因缘。离有无见行于中道。我及我所众生寿命。养育士夫作者受者。断常有无一切诸见。结缚因缘皆灭不起。总持王印而以印之。所有辞辩分别敷演。那由他劫说不可尽。得大神力感动无量无边佛土。于诸佛土善能往来。断除嗔怖憍慢放逸。其所演说如师子吼。一切众生怨亲中人。悉皆安止究竟涅槃。法云垂布以兴雷震。三明解脱以为电光。无上法雨以为甘露。能惠法财三宝不断。内外清净譬如宝珠。相好殊胜最上无比。以诸善根璎珞其身。佛法灌顶得补处位。善能分别诸众生行。随而调伏令得解脱。能净道场坐师子座。于诸法中得无所畏。能自变形犹如佛身。一切佛事悉能示现。心得自在转于法轮。舍利弗。彼土纯有如是菩萨摩诃萨等以为眷属。尔时大会闻佛称赞彼菩萨众功德智慧踊跃欢喜。以天优钵罗华。拘物头华。波头摩华。分陀利华。曼陀罗华。散无尽意及诸菩萨。异口同音作如是言。我等今日快得善利。得见如是诸正士等。礼拜供养恭敬围绕。若有众生闻其名者。亦得如是无量善利。若闻赞叹称其功德。悉皆当发无上道心。说是语时大会中有三百六十万众生发阿耨多罗三藐三菩提心

佛告舍利弗。彼佛世界无三恶道及其名字。亦无邪行越戒之名。又无女人悭贪嫉妒破戒嗔恚懈怠乱心愚痴之名。及以障碍荫盖集名。众生根等无上中下。纯是一乘无大小名。佛土无有净秽之名。亦无三宝差别之称。不闻饥渴饮食之声。及我我所遮护之名。无诸魔网妄见集名。彼佛世界平坦广大。一日月照周匝六十亿百千那由他由延。是希有事是彼菩萨本愿所致。其土平正犹如手掌。琉璃众宝杂厕共成。其地柔软犹如天衣。若有触者受微妙乐。宝树庄严行伍相当。宝绳连绵以界八道。所有诸华常自开敷。亦无石沙荆棘秽恶。所有诸山纯以众宝而挍饰之。人天无别法喜禅味以为饮食。其土无有王者之名。唯除普贤如来法王。彼佛世尊及诸菩萨。不以文字而有所说。彼诸菩萨唯修观佛。谛视无厌。目不曾眴。即便能得念佛三昧悟无生忍。是故彼土名曰不眴。云何念佛。谓不观色相。出生种性过去净业。是时心中不生自高。不观现在阴界诸入。见闻觉知心意识等。无有戏论生住灭相。不取不舍不念不思。不观思想及非思想。不分别想法想己想无一异想。境界功德内外中间。不起觉观始终之念。不观形貌威仪法式。不观戒定智慧解脱解脱知见。十力无畏不共之法。正念佛者。不可思议。不造行不作想。无等等离思惟。无所念无思处。无阴入界生住灭想。无有处所非无处所。非动非住。非色非识非想非受非行。于识不生识知。于地水火风不生识知。眼色耳声鼻香舌味身触心法亦复如是。如是不缘一切境界。不生诸相我及我所。不起见闻觉知之想。究竟能到一切解脱。心心数法灭不相续。净诸忆想非忆想等。善除爱恚灭因缘相。此彼中间悉断无余。是法清净无文字故。法无欢喜不动转故。法无有苦不味着故。法无燋热本寂灭故。法无解脱性舍离故。法无有身离色相故。法无受相无有我故。法无结缚寂无相故。法相无为无所作故。法无言教无识知故。法无始终无取舍故。法无安止无处所故。法无有作离受者故。法无有灭本无生故。心数思惟所缘住法。不取其相不生分别。不受不着不然不灭不生不出。法性平等犹如虚空。过于眼色耳声鼻香舌味身触心法。是名菩萨念佛三昧。菩萨得是念佛三昧。一切法中得自在智陀罗尼门。闻佛所说悉能受持终不忘失。亦得晓了一切众生言辞音声无碍辩才。舍利弗。彼普贤如来。不如此土以二因缘演说正见。所谓从他闻声内正忆念。彼诸菩萨当见佛时。寻能分别诸深妙义。具足成就六波罗蜜。何以故。若不取色相即是具足檀波罗蜜。若除色相即是具足尸波罗蜜。若观色尽即是具足羼提波罗蜜。若见色寂灭即是具足毗梨耶波罗蜜。若不行色相即是具足禅波罗蜜。若不戏论色相即是具足般若波罗蜜。是诸菩萨即观佛时。寻具如是六波罗蜜得无生忍。舍利弗。诸佛世界严净微妙。少有如彼普贤如来不眴世界

时舍利弗语无尽意。唯善男子。快哉仁者。汝等大士。得在彼土见普贤佛获无量利。时无尽意语舍利弗。大德今者。颇欲得见不眴世界普贤世尊及大众不。舍利弗言。唯然欲见。令此大众增长善根。时无尽意。即入菩萨示现一切佛土三昧。入三昧已令此大众及舍利弗。寻见彼土普贤如来及其大会。见是事已即从座起。合掌遥礼彼佛大众。此会大众以佛世尊及无尽意神通道力。得微妙华世所希有。其华色香未曾见闻。自然满掬遥散东方。以用供养普贤如来。华寻遍至彼佛世界普贤如来及其大众。彼诸菩萨见是华已白佛言。世尊。是华严丽世所希有。为从何处而来至此。彼佛答言。是无尽意在娑婆世界。是中亦有十方世界诸来菩萨。而共聚集能仁佛所。供养恭敬尊重赞叹。听佛世尊说大集经。是其大众所散之华。彼诸菩萨复白佛言。其佛世界在何方面去是远近。彼佛答言。诸善男子。在此西方去是佛土十恒河沙世界微尘等国。彼有世界名曰娑婆。诸菩萨言。愿乐欲见释迦文佛及其大众。尔时普贤如来寻放大光。其明彻照此佛世界。彼诸大众因佛光明。悉得遥见娑婆世界释迦文佛及诸大众。见已欢喜合掌恭敬作如是言。希有世尊。其土菩萨一切大众。从何所来而作此集。遍满其界间无空处。彼佛答言。诸善男子。其诸大众悉从十方无量世界而来集会。咨启听受甚深妙法

时舍利弗问无尽意。谁字仁者为无尽意。无尽意言。唯舍利弗。一切诸法因缘果报名无尽意。所以者何。一切诸法不可尽故。舍利弗言。唯善男子。愿仁当说无尽法门。无尽意言。唯舍利弗。初发无上菩提心时已不可尽。所以者何。发菩提心不离烦恼故。发心相续不悕余乘故。发心坚固不参外论故。发心不坏魔不沮故。发心恒顺善根增长故。发心至常有为法无常故。发心不动一切诸佛安慰护助故。发心胜妙离衰损故。发心安止不戏论故。发心无喻无相似故。发心金刚坏诸法故。发心无尽无量功德悉成就故。发心平等利众生故。发心普覆无别异故。发心鲜明性常净故。发心无垢智慧明了故。发心善解不离毕竟故。发心广快慈如虚空故。发心旷大悉能容受诸众生故。发心无碍智慧通达故。发心遍至大悲不断故。发心不断善解立愿故。发心为归诸佛所赞故。发心殊胜二乘宗仰故。发心深远一切众生所不知故。发心不败不破佛法故。发心安隐善与众生诸快乐故。发心庄严一切功德悉成就故。发心善察智慧成就故。发心增长随意施与故。发心如愿戒清净故。发菩提心普及怨亲具忍辱故。发心难坏具精进故。发心寂灭具禅定故。发心无毁具智慧故。发心无愿增长大慈故。发菩提心住根坚牢增长大悲故。发心和悦增长大喜故。发心不动增长大舍故。发心任重诸佛所受故。发心不绝三宝不断故。唯舍利弗。菩萨如是为一切智发菩提心。岂可尽耶。舍利弗言。唯善男子。譬如虚空不可穷尽。为一切智发菩提心。不可得尽亦复如是。无尽意言。唯舍利弗。佛戒无尽。因戒发心故不可尽。佛定无尽。因定发心故不可尽。佛慧无尽。因慧发心故不可尽。佛解脱无尽。因解脱发心故不可尽。佛解脱知见无尽。因解脱知见发心故不可尽。唯舍利弗。如来戒定智慧解脱解脱知见其性无尽。因是五众发菩提心。岂可尽耶。如来十力四无所畏十八不共法无尽。因如是等故发菩提心是故无尽。唯舍利弗。举要言之。一切如来悉皆无尽。因是发心故不可尽。三宝不断故无有尽。众生性无尽故无尽。如实智无尽故无尽。随诸众生无量心行智无尽故无尽。回向无上无尽故无尽。教化众生无尽故无尽。无尽智无生故无尽。离性无生故无尽。知一切法本性无尽故无尽。唯舍利弗。是名菩萨发菩提心不可尽也

复次舍利弗。是菩萨心清净无尽。心清净者不作谄故。不作谄者无奸诈故。无奸诈者善分别故。善分别者无邪命故。无邪命者心清白故。心清白者常正一故。常正一者性殊胜故。性殊胜者无轻毁故。无轻毁者灭诸曲故。灭诸曲者心质直故。心质直者入平正故。入平正者心坚实故。心坚实者不可坏故。不可坏者性牢固故。性牢固者不可动故。不可动者无所依故。无所依者除我心故。除我心者无伴等故。无伴等者息呰蔑故。息呰蔑者作善业故。作善业者无呵责故。无呵责者消过失故。消过失者不热恼故。不热恼者性真实故。性真实者无虚诳故。无虚诳者如说行故。如说行者能善作故。能善作者无瑕疵故。无瑕疵者不错谬故。不错谬者无所滞故。无所滞者不退转故。不退转者观众生故。观众生者大悲根深故。大悲根深者善化众生不疲惓故。善化众生不疲惓者不求己乐故。不求己乐者不贪利养故。不贪利养者不染爱故。不染爱者缘诸法故。缘诸法者观羸劣故。观羸劣者见众生故。见众生者常拥护故。常拥护者为归依故。为归依者无垢累故。无垢累者善观察故。善观察者无讥论故。无讥论者心纯善故。心纯善者。不动摇故。不动摇者善清净故。善清净者常精进故。常精进者内清净故。内清净者常鲜明故。常鲜明者无垢染故。唯舍利弗。其净心者能断悭惜。亦化他人令断悭惜。其净心者能断破戒。亦化他人令断破戒。其净心者能断嗔恚。亦化他人令断嗔恚。其净心者能断懈怠。亦化他人令断懈怠。其净心者能断乱心。亦化他人令断乱心。其净心者能断愚痴。亦化他人令断愚痴。舍利弗。净心如是能断一切诸不善法。安诸众生于善法中。是故名曰菩萨净心不可得尽

复次舍利弗。菩萨摩诃萨心行清净亦不可尽。何以故。菩萨行施时。一切皆见舍诸所有。菩萨行戒亦不可尽。一切皆见持诸禁戒头陀正行威仪无犯。菩萨行忍亦不可尽。一切皆见于诸众生心无恚碍。菩萨行进亦不可尽。一切皆见于诸善法精勤修集。菩萨行禅亦不可尽。一切皆见于诸禅定无有错乱。菩萨行慧亦不可尽。一切皆见修习多闻。是名菩萨行施行戒行忍行进行禅行慧。菩萨修行慈悲喜舍亦不可尽。一切皆见利益拔苦欢喜踊跃善断爱恚。是名菩萨慈悲喜舍。菩萨所行三业清净。离身三恶及口四过。心离三恶。所谓贪欲嗔恚邪见。菩萨修学多闻无尽不吝惜故。菩萨修行无吝惜者集一切智故。菩萨修集一切智者劝余菩萨发道心故。劝余菩萨发道心者修行安止于善根故。修行安止于善根者愿向无上菩提道故。愿于无上菩提道者摄取一切诸佛法故。摄取一切诸佛法者四事摄取故。菩萨修行四事摄者忏悔诸罪故。菩萨修行悔过法者发露诸恶故。菩萨修行发露诸恶者回向一切诸功德故。菩萨回向诸功德者积聚无量诸珍宝故。积聚无量诸珍宝者劝请诸佛故。劝请诸佛者摄取诸法故。摄取诸法者行大士法故。行大士法者能为众生作重任故。为诸众生作重任者不舍坚牢诸庄严故。不舍坚牢诸庄严者成就众生一切善事故

复次舍利弗。菩萨摩诃萨有四行无尽。何等为四。菩萨心行无尽。法施无尽。教化无尽。善根无尽。是为菩萨四行无尽。菩萨复有四行无尽。何等为四。乐在空闲摄持威仪无有厌足。常乐聚集无量功德而无厌足。多求学问广知诸义而无厌足。常愿无上菩提智慧而无厌足。是名菩萨四行无尽。菩萨复有四行无尽。何等为四。觉校计无尽。觉称量无尽。觉思惟无尽。觉观法无尽。是为菩萨四行无尽。菩萨复有四行无尽。何等为四。觉垢因无尽。觉白法无尽。呵诸烦恼无尽。赞叹白法无尽。是名菩萨四行无尽。菩萨复有四行无尽何等为四。观诸阴尽无尽。观诸界尽无尽。观诸入尽无尽。观因缘尽无尽。是名菩萨四行无尽。菩萨复有四行无尽。何等为四。说无常行无尽。说苦行无尽。说无我行无尽。说寂灭涅槃无尽。是名菩萨四行无尽。举要言之。菩萨所行一切无尽。向一切智。尊一切智。仰一切智。一切智无尽。以是因缘菩萨所行悉皆无尽。是名菩萨心行无尽

复次舍利弗。是菩萨心毕竟无尽。何以故。其所思惟乃至一念常缘菩提心不疲惓。专趣诸地过生死故。毕竟增长到彼岸故。毕竟本行转胜增上故。毕竟离负摄胜法故。毕竟无等具足一切诸佛法故。毕竟所缘增长善法故。毕竟能到过心行处故。毕竟庄严无疲厌故。毕竟修行吉祥菩提种种苦行悉成就故。毕竟不望不求己乐故。毕竟随顺无诸恶故。毕竟调伏住圣法故。毕竟不杂离烦恼故。毕竟难施不吝头目故。毕竟难戒拥护犯禁故。毕竟难忍忍无力势诸过恶故。毕竟难进专修苦行舍二乘故。毕竟难定心不味着诸禅定故。毕竟难慧不着一切诸善根故。发行能到一切善事悉成就故。毕竟远离憍慢增上慢胜慢我慢下慢憍慢邪慢善分别故。毕竟能舍施诸众生不求报故。毕竟不惊观深佛法故。毕竟增进不停滞故。毕竟无尽常精进故。毕竟不诳必为众生作重担故。又毕竟者。调柔众生。慈覆利益诸贤善人。悲心救拔诸行恶者。恭敬尊长。护无护者。归无归者。照无照者。依无依者。伴无伴者。直诸曲者。善不善者。无奸奸者。净邪命者。恩于恩者及无恩者不知恩者。利不利者。实虚谤者。不憍憍者。不毁作者。软语教呵。诸作恶者。护邪行者。见行方便不以为过。于诸受者等心恭敬。于余菩萨常行诱导。以柔软语而演教诲。乐在空处修行善法。离诸利养不惜身命。无有邪念心寂灭故。言无邪谄摄口过故。不以邪业而求利益。其心少欲常知足故。心调柔和无垢秽故。回在生死具善根故。能忍诸苦为众生故。是为大士一切毕竟而不可尽。是菩萨心。生死烦恼永不能坏。何以故。是心增长诸功德故。含受一切诸众生故。成就无尽妙智慧故。大德。是名菩萨摩诃萨毕竟无尽

尔时舍利弗。语无尽意菩萨摩诃萨言。唯善男子。颇复更有无尽法不。无尽意言有。菩萨修行檀波罗蜜不可穷尽。何以故。菩萨摩诃萨行施无量。所谓须食与食具足命辩色力乐故。须饮与饮离渴爱故。须衣与衣具清净色除无惭愧故。须乘与乘得一切乐具神通故。须灯与灯具足佛眼清净故。须音乐者施与音乐具足天耳清彻故。须香与香身出具足微妙香故。须鬘与鬘具陀罗尼七觉华故。须涂香末香悉施与之。具戒定慧熏涂身故。须种种味随意与之。味相成就故。无依止者施与依止。能为众生具足救护为归依故。须敷具者悉施与之。具足究竟断除阴盖。成就梵天贤圣诸佛妙床座故。须座与座具足三千大千世界以为道场。金刚座处悉成就故。随其所须悉能与之。成就菩提诸所须故。随病施药得无老死。甘露法药悉成就故。须仆使者皆给与之。自在智慧得具足故。若以金银琉璃颇梨真珠珂贝璧玉珊瑚种种诸珍用惠施者。具足大人三十二相故。能以种种璎珞施者。具足八十随形好故。若以象马车乘施者。具足大乘故。若持园林以布施者。具诸禅支故。若持妻子以布施者。具足无上道法爱故。若以仓库谷财施者。具足诸善法宝藏故。以阎浮提若四天下随意施者。具足法王得自在故。以诸乐具持用施者。具足无量法乐乐故。若持脚足以布施者。法足具成进至道场故。若以手施。具足法手安抚众生令得乐故。若以耳鼻用施与者。具足诸根悉通利故。若以眼目持用施者。为欲具足无碍法眼故。若以头施。于三界中具足殊胜一切智慧故。若以血肉持用施者。诸不坚牢具坚牢故。若以髓脑持用施者。具金刚身得不坏故。菩萨不以邪命求财而行布施。不逼众生强求他物转以施人。无恐怖施。无羞耻施。无悭惜施。如其所许无损减施。无不爱施。毕竟常施。无不毕竟施。无谀谄施。无奸诈施。不疑业报施。无邪命施。无愚痴施。无不信施。无不解施。无疲难施。无依着施。无选择施。无异相施。不求受者施。无有众生不堪受者持戒犯戒无增减施。于受者所不望报施。不求名施。不毁誉施。无慢非慢施。无热恼施。不悔心施。不自赞施。无杂秽施。不望业报施。无定处施。无有嗔怒垢爱等施。有来乞者不恼害施。无轻易施。不[卑*頁]面施。不撩掷施。无不故施。无手不与施。无不常施。无断绝施。无嫉慢施。无齐限施。如其所许不贸易施。无有堪任不堪任施。无非福田施。不轻小施。不赞多施。无衰耗施。不求后生施。不求自在得财宝施。不求释梵护世天王转轮圣王诸果报施。不愿声闻缘觉乘施。不求王子得自在施。不为一世故施。无厌足施。无不回向一切智施。无不净施。无不时施。无刀毒施。无恼众生施。菩萨行施。不为智者之所轻笑。何以故。观空寂行施。是故无尽。无作所熏施。是故无尽。出三有相施。是故无尽。不取处施。是故无尽。为解脱果是施无尽。为伏众魔是施无尽。为断结爱是施无尽。为增上施是故无尽。善分别施是故无尽。助菩提施是故无尽。正回向施是故无尽。庄严道场解脱果施是故无尽。是施无边是故无尽。是施无坏是故无尽。是施不断是故无尽。是施广大是故无尽。是施无住是故无尽。是施无伏是故无尽。无等等施是故无尽。是施进趣一切种智是故无尽。唯舍利弗。是名菩萨修行布施而不可尽

尔时舍利弗语无尽意言。善哉善哉。唯善男子。仁已快说菩萨摩诃萨修行檀波罗蜜而不可尽。唯愿仁者当说菩萨尸波罗蜜如诸菩萨所得无尽尸波罗蜜。无尽意言。唯舍利弗。菩萨戒众六十七事清净修治亦不可尽。何等六十七。于诸众生不起恼害。于他财物不生窃盗。于他妇女中不生邪视。于诸众生无有欺诳。初不两舌于自眷属知止足故。无有恶口忍粗穬故。无有绮语常善说故。于他乐事不贪嫉故。初无嗔恚忍恶言故。正见不邪贱余道故。深信于佛心不浊故。信顺于法善观法故。信敬于僧尊重圣众故。五体投地志念佛故。五体投地思惟法故。五体投地宗敬僧故。坚持禁戒。一切无犯。乃至小禁不放舍故。持不缺戒不依余乘故。持不穿戒离恶处生故。持不荒戒不杂诸结故。持不污戒专长白法故。持甚深戒随意回向得自在故。持赞叹戒智者不呵故。持纯善戒正念知故。持不呵戒一切戒不散故。持善坚戒防护诸根故。持名闻戒诸佛所念故。持知足戒无不厌故。受少欲戒。断贪惜故。持性净戒身心寂灭故。持阿兰若戒。离愦闹故。持圣种戒不求他意故。持威仪戒一切善根得自在故。持如说戒人天欢喜故。持慈心戒护众生故。持悲心戒能忍诸苦故。持喜心戒心不懈怠故。持舍心戒离爱恚故。持自省戒心善分别故。持不求短缺戒护他心故。持善摄戒善守护故。持惠施戒教化众生故。持忍辱戒心无恚碍故。持精进戒不退还故。持禅定戒长诸禅支故。持智慧戒多闻善根无厌足故。持多闻戒博学坚牢故。持亲近善知识戒助成菩提故。持远离恶知识戒远离恶道故。持不惜身戒观无常想故。持不惜命戒勤行善根故。持不悔戒心清净故。持不邪命戒心行清净故。持不焦戒毕竟清净故。持不烧戒修善行业故。持无慢戒心下不憍故。持不掉戒远离诸欲故。持不高戒心平直故。持柔和戒心无抵突故。持调伏戒无恼害故。持寂灭戒心无垢秽故。持顺语戒如说行故。持化众生戒不离摄法故。持护正法戒不违如实故。持如愿成就戒于诸众生心平等故。持亲近佛戒愿求如来无上戒故。持入佛三昧戒具足一切诸佛法故。舍利弗。是名菩萨六十七事净治戒众而不可尽

又舍利弗。菩萨无尽清净戒中无有倚着。所谓破我人众生寿命养育士夫色受想行识地水火风。是净戒中无眼色相。耳声鼻香舌味身触意法等相。亦无身心。是戒定相一向不共故。是戒分别相方便缘一切法故。是戒空相得无相际不杂三界故。是戒不作无生忍故。是净戒中无有已作今作当作。是清净戒过去不灭未来不来现在不住。又舍利弗。是净戒中心净无垢识不止住思不亲近。是清净戒不依欲界不近色界不住无色界。是清净戒舍离欲尘除嗔恚碍灭无明障。是清净戒不断不常不逆因缘。是清净戒无有我相舍我所相不住身见。是清净戒不取假名不住色相不杂名色。是清净戒不系于因不起诸见不住疑悔。是清净戒不住贪嗔痴不着善根。是清净戒不恼不热寂灭离相。是清净戒不断佛种求正法故。不断法种不分别法性故。不断僧种修无为故

舍利弗。持净戒者相续不断故不尽。所以者何。凡夫戒者在所受生是故有尽。人中十善尽故有尽。欲界诸天福报功德尽故有尽。色界诸天禅无量心尽故有尽。无色界天所入诸定尽故有尽。外道仙人所有诸戒退失神通尽故有尽。一切声闻学无学戒入涅槃际尽故有尽。辟支佛戒无大悲心尽故有尽。舍利弗。菩萨净戒皆无有尽。何以故。于是戒中出一切戒。如种无尽果亦无尽。是菩提种不可尽故。如来戒禁亦无有尽。以是故诸大士等所持诸戒皆不可尽。舍利弗。是名菩萨修持净戒而不可尽

尔时舍利弗语无尽意言。善哉善哉。善男子。仁已快说菩萨尸波罗蜜而不可尽。唯愿仁者。当说菩萨羼提波罗蜜。如诸菩萨所得无尽羼提波罗蜜。无尽意言。唯舍利弗。菩萨具三十二事。修行忍辱亦不可尽。何等三十二。断诸结故当知是忍。不生害故当知是忍。无有缠故当知是忍。无有恼故当知是忍。无覆蔽故当知是忍。无有嗔故当知是忍。无忿诤故当知是忍。无斗讼故当知是忍。于诸尘界心不异故当知是忍。护自他故当知是忍。顺菩提心故当知是忍。善思惟故当知是忍。无二想故当知是忍。识业报故当知是忍。庄严身故当知是忍。口演净言故当知是忍。心清净故当知是忍。心坚牢故当知是忍。言语自在故当知是忍。不忆想故当知是忍。善分别心故当知是忍。护他心故当知是忍。修梵世行故当知是忍。受人天报故当知是忍。身相胜故当知是忍。具妙梵音故当知是忍。除诸过患故当知是忍。断诸荒秽故当知是忍。断一切不善根故当知是忍。杀诸结贼故当知是忍。于恼害众生得超越故当知是忍。具足一切佛法故当知是忍。舍利弗。是名菩萨三十二事修行忍辱而不可尽

舍利弗。云何为忍。若见骂者默受不报。善知音声如响相故。见有呵责默而受之。善知身相如影像相故。见有嗔者心不怀恨。善知心法如幻相故。忿不报忿心清净故。闻有称名心不生爱不自高故。闻不称名心不生碍功德具足故。若遇荣利不生喜悦善自调故。若遇衰耗不生挂碍心寂灭故。见有称者心不惊动善知分别故。见有毁者心不缩没其心广大故。见有讥者其心不下善安住故。见有誉者其心不高不倾动故。若遇乐事心不欢逸观有为法无常相故。若遇苦事心不疲恼为众生故。世法不染不依止故。忍受诸苦见危逼者以身伐故。忍节节支解具足觉支故。众苦加身悉能堪受具佛身相故。忍他过患善作业力故。示现烧热修诸苦行伏外道故。现入诸道出过释梵护世诸天故。是名菩萨之忍辱也

又毕竟忍者无有诤讼。何以故。若见他骂我能忍者。如是忍者是观二相非毕竟忍。若言谁骂我者。如是忍辱是法功德非毕竟忍。若骂眼耶。如是忍者是观入相非毕竟忍。耳鼻舌身若骂意耶。如是忍者是观诸入非毕竟忍。若无骂者。如是忍辱是观无我非毕竟忍。若知假名。如是忍者是观响相非毕竟忍。彼之与我二俱无常。如是忍者是观无常非毕竟忍。彼是颠倒我无颠倒。如是忍者是观高下非毕竟忍。彼不勤行我是勤行。如是忍者是观勤懈非毕竟忍。彼住恶道我住善道。如是忍者是观善恶非毕竟忍。我忍无常不忍有常。我能忍苦不受诸乐。我忍无我不忍有我。我忍不净不忍于净。如是忍者。是观有对非毕竟忍。我忍于空不忍诸见。我忍无相不忍诸觉。我忍无愿不忍于愿。我忍无作。不忍于作。我忍结尽不忍结在。我忍于善不忍不善。我忍出世不忍在世。我忍无诤不忍于诤。我忍无漏不忍于漏。我忍白法不忍黑法。我忍寂灭不忍生死。如是忍者是观相对非毕竟忍

云何名为毕竟忍耶。若入空寂。不与诸见和合不倚着空。是诸见等亦复皆空。如是忍者是无二相是毕竟忍。若入无相不与诸觉和合。不倚无相是觉皆空。如是忍者。是无二相是毕竟忍。若入无愿不与愿合。不倚无愿是愿皆空。如是忍者是无二相是毕竟忍。若入无作不与作合。不倚无作是作皆空。如是忍者是无二相是毕竟忍。若入尽结不与结合。不倚尽结诸结皆空。如是忍者是无二相是毕竟忍。若入于善不与不善和合。不倚于善不善皆空。如是忍者。是无二相是毕竟忍。若入出世不与世合。不倚出世在世皆空。如是忍者是无二相是毕竟忍。若入无诤不与诤合。不倚无诤是诤皆空。如是忍者是无二相是毕竟忍。若入无漏不与漏合。不倚无漏诸漏皆空。如是忍者是无二相是毕竟忍。若入白法不与黑合。不倚白法黑法皆空。如是忍者是无二相是毕竟忍。若入寂灭不与生死和合。不倚寂灭生死皆空。如是忍者是无二相是毕竟忍。若性不自生不从他生不和合生。亦无有出不可破坏。不可坏者是不可尽。如是忍者是毕竟忍。无作非作。无所倚着。无分别。无庄严。无修治。无发进。终不造生。若无生者是不可尽。如是忍者是无生忍。无生忍者是不出忍。不出忍者是毕竟忍。如是菩萨修行是忍得受记忍。舍利弗。是名菩萨行忍无尽。说是忍时。一切大众赞无尽意言。善男子。善哉善哉。快说此忍。言已即雨种种希有诸华末香涂香无数杂衣幢幡宝盖。以用供养于无尽意。百千伎乐于上空中自然出声作如是言。若有众生欲得如来甚深忍者。闻作是说不应惊怖。时诸华香杂衣幡盖普遍充溢。满此三千大千世界

尔时佛告无尽意言。善男子。汝所供养华香等物。可自求器除去摒挡。无尽意言。唯然世尊。我今当以神通之力即身为器。时无尽意。即入菩萨色身三昧。入三昧已一切所有供养之具悉入脐中。身界如故不增不减。尔时众中有一菩萨名大庄严。问无尽意。善男子。所入三昧名为何等。而仁入已诸供养具悉入身中。身界如故而不增减。无尽意言。善男子。其三昧者名为一切色身三昧。大庄严言。是三昧定。颇复更有余力势不。无尽意言。是三昧力。能令身界悉受三千大千世界所有色相。身界如故亦无增减。尔时众中或有人天作是思惟。宁可得见是定力不。尔时佛知一切大众人天所念。告无尽意。善男子。汝可示现是定神力。时无尽意菩萨摩诃萨。于是三昧久已通达。是故能以一切大众十方诸来大菩萨等佛及圣僧悉内身中。尔时其身犹如大宝庄严世界。受诸菩萨摩诃萨等所有种种庄严之事。是时大众悉自见形在无尽意菩萨身内。时无尽意示现如是大神通已。是时大众各还如本。时大庄严菩萨摩诃萨问无尽意。善男子。我从昔来未曾见闻如是三昧神通变化。无尽意言。善男子。假使三千大千世界一切所有悉入我身犹无增减况于此耶。说是无尽忍辱现大神变时。七十六那由他天及人发阿耨多罗三藐三菩提心。万二千菩萨摩诃萨得无生法忍。舍利弗。是名菩萨修行忍辱而不可尽

大方等大集经卷第二十七大方等大集经卷第二十八

        宋凉洲沙门智严共宝云译

    无尽意菩萨品第十二之二

尔时舍利弗。语无尽意言。善哉善哉。唯善男子。汝已快说菩萨羼提波罗蜜而不可尽。唯愿仁者。当说菩萨毗梨耶波罗蜜。如诸菩萨所得无尽毗梨耶波罗蜜。无尽意言。唯舍利弗。菩萨具足八事。修行精进而不可尽。何等为八。发大庄严而无有尽。积集勇进而不可尽。修行诸善而不可尽。教化众生而不可尽。助道功德而不可尽。助无上智而不可尽。助无上慧而不可尽。集助佛法而不可尽。云何菩萨庄严无尽。于诸生死心不疲倦。不计劫数当成佛道。若干劫在而作庄严。若干劫在不作庄严。菩萨庄严所经劫数不可称计。如从今日至生死。本为一日一夜。如是三十日为一月。十二月为一岁。于是百千万岁。一发道心一见如来。如是发心。所见诸佛。如恒沙数。于尔所佛边。方得知一众生心行。如是遍知一切众生心之所行犹不退没。是则名曰不懈庄严无尽庄严。经于如是见佛发心。知他众生心所行时。常修具足檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。修集一切助菩提法。具修相好十力无畏不共之法。具修一切诸佛法故。是名不懈庄严无尽庄严。若有菩萨闻作是说。不惊不怖不畏。当知是菩萨不懈精进。是名菩萨庄严无尽。云何菩萨勇进无尽。若三千大千世界满中盛火。为见佛故。要当从是火中而过。若为闻法教化众生安止众生于善法故。亦应如是从火中过。是名菩萨勇进无尽。何因缘故。名曰勇进。常为他故。为静他故。为调伏他故。为灭尽他故。常不懈慢坚牢不退。心善安止于大悲中常勤精进。而为众生故名勇进。菩萨行时步步御心。悉向菩提常观众生为化度故。虽作是观不起烦恼。是名菩萨勇进无尽

云何菩萨修习无尽。如所发起一切善心常愿菩提。是名菩萨修集无尽。何以故。以诸善根回向阿耨多罗三藐三菩提。初无尽故。舍利弗。譬如天雨一渧之水堕大海中。其渧虽微终无灭尽。菩萨善根愿向菩提。亦复如是无有灭尽。修集善根者。所谓正回向修集善根。为护众生修集善根。为随众生诸所须故修集善根。为欲成就一切智故修集善根。是名菩萨修集无尽

云何菩萨教化无尽。众生之性不可称计。菩萨于中不应称计。若言一日教化三千大千世界满中众生。如是计数乃至无量不可思议不可称劫教化众生者。虽作如是教化众生。不可称计不可思议。于众生分犹未是教化百分千分百千分百千万分。乃至算数譬喻所知众生。何以故。是众生性无量无边不可称计不可思议。若菩萨闻作是说。不惊不怖不畏。当知是菩萨勤修精进。是名菩萨教化无尽。云何菩萨助道无尽。菩萨所修助道功德无量无边。菩萨于中不应限量。何以故。一切众生所有功德。若去来现在。及声闻缘觉所有功德。于佛世尊始是成就一毛孔功德。如是一一毛孔所有功德。乃至一切毛孔功德。聚集成就始成如来一随形好。如是一一随形好等。乃至一切随形好功德。聚集成就如是成就如来一相。如是一一相至三十相。聚集如是三十相百倍功德。始成如来眉间毫相。乃至修集倍是毫相百千功德。始成如来无见顶相。是名菩萨助道功德无尽。云何菩萨助智无尽。菩萨所修助智无量无边。菩萨于中不应限数。若三千大千世界所有众生。如一信行所成就智。如是信行。比一法行所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界众生悉为法行。比一八人所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生悉为八人智。比一须陀洹所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为须陀洹智。比一斯陀含所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为斯陀含智。比一阿那含所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为阿那含智。比一阿罗汉所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为阿罗汉智。比一缘觉所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉成缘觉智。比一百劫菩萨所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为百劫菩萨所成就智。比一得忍菩萨所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界所有众生。悉为得忍菩萨所成就智。比一不退菩萨所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若三千大千世界。所有众生悉得不退菩萨智。比一补处菩萨所成就智。百分千分百千分百千万分。乃至算数譬喻所不能及。若无量无边世界众生。悉如补处所成就智。比一如来是处非处智。百分千分百千分百千万分。乃至算数譬喻所不能及。总说如来诸力无畏不共之法亦复如是。若菩萨闻作是说。不惊不怖不畏。当知是菩萨勤行精进。是名菩萨助智无尽。云何菩萨助慧无尽。一切众生所有心行不可穷尽。菩萨于中不应计数。若过去未来现在众生所有心行。若有人于一念中。具如是等三世众生所有心行。如是念念皆亦如是具诸心行。如一人心中所具心行。一切无量无边众生皆亦如是。若过去未来现在众生。所有贪淫嗔恚愚痴及诸烦恼。若有一人于一念中。具如是等三世众生所有烦恼。如是念念当亦如是。具诸烦恼无量无边。如一人心中所具诸结。一切无量无边众生皆亦如是。菩萨于中生慧光明。一念慧光无诸尘翳。悉照过去未来现在众生烦恼诸心所缘境界生住灭相无有遗余。是菩萨于诸众生三世相应诸烦恼等无不尽知。舍利弗。譬如虚空无所不覆。菩萨慧光亦复如是无所不照。若菩萨闻作是说。不惊不怖不畏。当知是菩萨勤行精进。是名菩萨助慧无尽

云何菩萨修集助佛法无尽。菩萨所行修助佛法无量无边。若菩萨于中不应限量。从初发心至坐道场。于其中间。修行具足六波罗蜜。修行具足诸助道法。如是一切发心修行一切善根不可称计悉助佛法。是名菩萨修助佛法而无有尽。是名菩萨八事修行精进无尽

复次舍利弗。菩萨精进亦不可尽。若身善业若口善业若意善业常勤不住。何以故。菩萨所作精进。常与身口意相应。虽身口精进皆由于心。心为增上。云何菩萨心精进耶。所谓心始心终。云何心始。初发心故。云何心终。菩提心寂灭故。云何心始。于诸众生起大悲故。云何心终。无我人故。云何心始。摄众生故。云何心终。不取诸法故。云何心始。不厌生死故。云何心终。无三界故。云何心始。舍所有故。云何心终。无所轻故。云何心始。受持戒故。云何心终。不持戒故。云何心始。修行忍故。云何心终。无忿诤故。云何心始。发行诸善故。云何心终。独不杂故。云何心始。修集定故。云何心终。心清净故。云何心始。多闻无厌故。云何心终。善思惟故。云何心始。习问义故。云何心终。法无言说故。云何心始。求智慧故。云何心终。断戏论故。云何心始。修四梵行故。云何心终。舍真智故。云何心始。具五通故。云何心终。具漏尽故。云何心始。发念处故。云何心终。念无思惟故。云何心始。发正勤故。云何心终。脱善不善故。云何心始。发如意分故。云何心终。具报得故。云何心始。发诸根方便故。云何心终。观诸根法故。云何心始。集诸力故。云何心终。智不坏故。云何心始。发助菩提分故。云何心终。善知分别诸学方便故。云何心始。求助道法故。云何心终。无进趣故。云何心始。求寂灭故。云何心终。心永寂灭故。云何心始。发起慧故。云何心终。善知法故。云何心始。觉知因故。云何心终。善知因故。云何心始。从他闻故。云何心终。于诸法中无放逸故。云何心始。发严饰故。云何心终。知身性故。云何心始。庄严口故。云何心终。圣默然故。云何心始。行三脱故。云何心终。无所作故。云何心始。降四魔故。云何心终。舍结习故。云何心始。知方便故。云何心终。了于慧故。云何心始。善知发故。云何心终。善知度故。云何心始。知世俗故。云何心终。善知真谛故。是名菩萨心精进也。是心具足精进无尽故说始终。菩萨具足如是作相。而心未常住于作业。是菩萨于诸业相知而故作。云何菩萨知而故作。为诸善根故。为诸众生修大悲故不离有为。为一切佛真妙智故不随生死。是名菩萨摩诃萨毗梨耶波罗蜜而不可尽。说是法时。七十那由他诸天及人发阿耨多罗三藐三菩提心。三万二千菩萨摩诃萨得无生法忍

尔时舍利弗。语无尽意言。善哉善哉唯善男子。仁已快说菩萨毗梨耶波罗蜜而不可尽。唯愿仁者。当说菩萨禅波罗蜜。如诸菩萨所得无尽禅波罗蜜。无尽意言。若菩萨摩诃萨以十六事修行禅定而无有尽。不与声闻辟支佛共。何等十六。菩萨修定无有吾我。具足如来诸禅定故。菩萨修定不味不着。不求己乐故。菩萨修定行于大悲。断诸众生烦恼结故。菩萨修定增益诸禅观。见欲界诸过患故。菩萨修定具诸通业。为知众生诸心行故。菩萨修定其心柔软。于众生中得自在故。菩萨修定诸禅三昧善知入出。过于色界无色界故。菩萨修定其心寂灭。胜于二乘诸禅三昧故。菩萨修定更无有发。毕竟已作故。菩萨修定无诸衰耗。善断除灭诸习气故。菩萨修定常入智慧。过诸世间到彼岸故。菩萨修定为知众生心。度脱一切诸众生故。菩萨修定不断三宝种。具足无尽诸禅定故。菩萨修定无有退失。其心常定无诸错谬故。菩萨修定而得自在。具足一切诸善法故。菩萨修定内善思惟。断入出息得胜智故。舍利弗。是名菩萨以十六事修行禅定而无有尽。不与声闻辟支佛共。云何名为菩萨修定。具诸通智故。云何为通。云何为智。若见诸色相是名为通。若知一切色尽法性而不证尽是名为智。若闻音声是名为通解了三世一切音声无言辞相是名为智。若知一切众生心行是名为通。若知心行悉皆灭尽不证于灭是名为智。若念过去是名为通。若知三世无有挂碍是名为智。若能遍至诸佛世界是名为通。若知佛界同虚空相是名为智。若求诸法无破坏相是名为通。若不见法是名为智。若不坏世间是名为通。若不杂行是名为智。若过梵释护世天王是名为通。过于二乘学无学智。是名为智。是名菩萨修行禅定通智差别

唯舍利弗。菩萨若知一切众生烦恼乱心。是故修集诸禅定法。助成住心。舍利弗。如是众生烦恼心乱。菩萨于中。善修聚集助成禅定。令此禅定住平等心。是名菩萨修行禅定。若住众生平等智中。是名为定。心行平等性相平等毕竟平等发行平等。是名为定。住于施戒忍辱精进禅定智慧及诸法等。是名为定。如定等者则众生等。众生等者则诸法等。入如是等是名为定。如是等定则等于空。等于空者则众生等。众生等者则诸法等。入如是等是名为定。如空等者则无相等。无相等者则无愿等。无愿等者则无作等。无作等者则众生等。众生等者则诸法等。入如是等是名为定。自心等故他心亦等。是名为定。一切等者。所谓利衰如地水火风。得是等心心如虚空。无有高下常住不动。所行威仪常定不转。本性自尔不恌不高。自在无畏寂默无言。知义知法知时非时。随世所行不杂于世。舍世八法灭一切结。远离愦闹乐于独处。菩萨如是修行诸法。于诸禅定心安止住离世所作。是菩萨以方便慧入禅波罗蜜。入禅定时生大悲心为诸众生是名方便。其心永寂是名为慧。入时念佛是名方便。不依止禅是名为慧。入时摄取一切善法。是名方便。不分别法性。是名为慧。入时趣向庄严佛身。是名方便。于佛法身不生分别。是名为慧。入时念佛声如梵音。是名方便。于法性中无言说相。是名为慧。入时受持心如金刚。是名方便。思惟诸法本性不乱。是名为慧。入时不舍本所誓愿教化众生。是名方便。于一切法思惟无我。是名为慧。入时思惟一切善根。是名方便。思惟善根性无所住。是名为慧。入时遍观诸佛世界。是名方便。见诸佛界同于虚空。是名为慧。入时庄严菩提道场。是名方便。观所庄严同于寂灭。是名为慧。入时欲转无上法轮。是名方便。思惟法轮无转不转。是名为慧。入时一向修助觉分。是名方便。为知众生诸热恼心。是故修集如来禅定。知一切法相应不相应有相无相一切相续。随顺菩萨决定思惟。是名为慧。是名菩萨入于禅定方便慧也。如是菩萨。禅波罗蜜方便智慧。二事俱行得佛法器。一切诸魔不能破坏。说是法时。三万二千菩萨得日灯三昧。何因缘故名日灯三昧。譬如日出。灯火月光星宿诸明悉不复现。菩萨大士得是定已。先所修智一切二乘学与无学。及余众生所得诸智。皆亦如是悉不复现。是名日灯三昧。菩萨住于禅波罗蜜。即于无量百千种种诸禅三昧而得自在。今于此中当说少分。其名曰电灯三昧。净三昧。月光三昧。净庄严三昧。日光三昧。不可思议三昧。勇出三昧。照明三昧。无垢光明三昧。功德光明三昧。一切法中得自在三昧。吉道三昧。无忧三昧。坚称三昧。勇出如须弥山等三昧。法炬三昧。法健三昧。法尊三昧。自在知一切法三昧。住法聚三昧。总持法净三昧。随知他心行三昧。法幢璎珞三昧。烧一切烦恼三昧。破四魔力三昧。十力声勇健三昧。无碍断碍三昧。手灯三昧。施得名闻三昧。持地三昧。住无我如须弥山三昧。胜诸明智三昧。智焰三昧。生慧三昧。修禅三昧。无量自在三昧。心调伏无我无我所成就三昧。水月三昧。日声三昧。无有高下如佛三昧。离相三昧。如善调象师子游戏三昧。念佛三昧。念法得智自在无碍三昧。无退不退三昧。不眴三昧。胜净光无我三昧。空三昧。无相三昧。无愿三昧。住心平等三昧。金刚三昧。增上三昧。无能胜三昧。旋三昧。净声三昧。善分别三昧。离烦恼三昧。广大如空三昧。入诸功德三昧。念意进觉三昧。勇慧三昧。辩无尽三昧。语无尽三昧。总持三昧。不忘三昧。善作三昧。观一切世三昧。善知所乐三昧。生踊跃三昧。勇慈心净三昧。大悲根本三昧。入喜三昧。舍离三缠三昧。法义三昧。法作三昧。智炬三昧。智海三昧。不波荡三昧。一切心喜三昧。调伏三昧。解脱智三昧。已自在三昧。法场金刚幢三昧。莲华三昧。莲华增上三昧。离世法三昧。不动三昧。慧增上三昧。诸佛所念首楞严三昧。无诤三昧。火三昧。火明三昧。解脱胜智三昧。庄严佛身三昧。遍照三昧。入众生心欢喜三昧。顺助道三昧。庄严诸波罗蜜三昧。宝鬘三昧。与诸觉华三昧。与解脱果三昧。甘露三昧。速疾如风三昧。实际三昧。遮海涛三昧。山相搏三昧。广大神足三昧。见无量诸佛三昧。闻持三昧。不乱三昧。一念智无量功德海净三昧。如是等不可计那由他诸三昧。入禅波罗蜜时悉得清净。舍利弗。是名菩萨修行禅定而不可尽

尔时舍利弗。语无尽意言。善哉善哉。善男子。仁已快说菩萨禅波罗蜜。唯愿仁者。当说菩萨般若波罗蜜。如诸菩萨所得无尽般若波罗蜜。善男子。般若波罗蜜。云何行云何入。无尽意言。唯舍利弗。般若波罗蜜。如闻修行善入思惟。舍利弗言。唯善男子。云何如闻修行。无尽意言。闻者具八十行。何等八十。欲修行顺心行。毕竟心行。常发起行。亲近善友行。无憍慢行。不放逸行。恭敬行。随顺教行。从善语行。数往法师所行。至心听法行。善思惟行。不乱心行。勤进心行。生宝想行。起药想行。除诸病行。念器行。进觉行。意喜行。入觉行。闻无厌行。增长舍行。调智行。亲近多闻行。发欢喜行。身轻悦行。心柔和行。闻无疲倦行。闻义行。闻法行。闻威仪行。闻他说行。闻所未闻行。闻诸通行。不求余乘行。闻诸波罗蜜行。闻菩萨藏行。闻诸摄法行。闻方便行。闻四梵行。闻念正智行。闻生方便行。闻无生方便行。观不净行。思惟慈行。观因缘行。观无常行。观苦行。观无我行。观寂灭行。观空行。观无相行。观无愿行。观无作行。作善行。持真实行。不失行。好恶住处防护心行。勤进无懈行。善分别诸法行。知诸烦恼非伴侣行。护诸善法自伴侣行。降伏烦恼非伴侣行。亲近正法财行。断诸贫穷行。智者所赞行。欣乐利根行。众圣所劝行。令非圣者生欢喜行。观诸谛行。观阴过患行。思量有为多过患行。思义行。不作一切恶行。自利利他行。随顺增进诸善业行。进增上行。得一切佛法行。舍利弗。是名菩萨如其所闻具八十行

舍利弗。菩萨摩诃萨。行般若波罗蜜。具三十二事善入思惟。何等三十二。善入受持定。善入分别慧。善入心柔和。善入身独行。善入十二缘。善入不断。善入不常。善入因缘生法。善入无众生无命无人。善入无来去住处。善入无进不断因果。善入空不懈。善入无相不废。善入无愿不舍。善入不证空无相无愿。善入生诸禅三昧。善入不随禅定生。善入生诸通智。善入不证无漏法。善入内观法。善入不证决定。善入思量有为法过患。善入不著有为法。善入观一切众生无我而不舍大悲。善入一切趣诸怖畏处。善入虽生诸趣非业故生。善入离欲。善入不证离欲法。善入舍所乐欲。善入不舍法乐。善入舍一切戏论诸觉。善入不舍方便诸观。舍利弗。是名菩萨行般若波罗蜜三十二事善入思惟

又复善思惟者所谓善顺句。善顺句者是不始句。是不终句。是不住句。是无依句。是不动句。是不猗句。是平等句。是非等句。是真实句。是正真句。是不变句。是清净句。是永寂句。是不然句。是不举句。是不下句。是不灭句。是不增句。是不共句。是不戏论句。是如句。是不如句。是如非如句。是非如非不如句。是如实句。是三世平等句。是三际句。是不住色句。是不住受想行识句。是不住地大句。是不住水火风句。是不住眼界色界眼识界句。是不住耳界声界耳识界句。是不住鼻界香界鼻识界句。是不住舌界味界舌识界句。是不住身界触界身识界句。是不住意界法界意识界句。是念义句。是念智句。是了义经句。是念法句。是名菩萨善入思惟

又复善思惟者。所谓一切诸法。若我无我如是诸法随顺观察。若知众生无有我者。即是随顺观察诸法。如是观察即是善入思惟。如善思惟即是思惟生死涅槃同一法界。观是二句无有差别。如是见者是名勤进善入思惟。若观黑法及以白法二性平等无有差别。是名勤进善入思惟。若观诸枙及以无枙不动不恃。是名勤进善入思惟。若菩萨起善思惟。为诸众生而不舍离。于诸法相亦不分别。是名菩萨发善思惟。舍利弗。如闻行者。如是得入报善思惟是名为慧

舍利弗。菩萨慧者。有十六法不于中住。云何十六。不住无明行识名色六入触受爱取有生老死乃至不住无明灭至生死灭。不住根本身见乃至不住六十二见。不住高下乃至不住世法利衰毁誉称讥苦乐。不住慢慢增上慢胜慢我慢下慢憍慢邪慢乃至不住二十烦恼。不住因贪所起诸结。若粗若细若上中下。乃至不住贪欲所起一切诸结。不住痴闇覆盖诸碍。乃至不住因痴所起一切诸结。不住淫欲爱浊。不住阴死烦恼天魔乃至不住因魔所起诸魔事等。不住我人众生寿命养育士夫。乃至不住取众生相。不住业障报障法障烦恼障诸见障乃至不住一切习气。不住思想忆想分别想缘相想境界见闻觉知乃至不住一切诸结。不住随众生心行智乃至不住八万四千法聚。不住悭贪布施破戒持戒嗔恚忍辱懈怠精进乱意禅定愚痴智慧乃至不住诸波罗蜜伴非伴等。不住定乱邪正善不善世间出世间可作不可作有漏无漏有为无为黑法白法生死涅槃乃至不住一切诸法伴非伴等。不住众生异相诸乘异相佛界异相诸佛异相诸法异相圣众异相乃至不住一切异相。不住知不知识不识世谛真谛乃至不住一切诸相。所谓菩萨思惟慧者。无闻无行无身无相无形无为。如是真慧。不住一切忆想思惟心作止住名字异相。舍利弗。是名菩萨真智慧者不住如是十六法中

舍利弗。云何菩萨慧者。处所具八方便。何等八。诸阴方便。诸界方便。诸入方便。诸谛方便。诸缘方便。三世方便。诸乘方便。诸法方便。云何诸阴方便。若说诸阴如沫如泡。如热时焰。如芭蕉树。如幻如梦。如呼声响。如镜中像。如影如化色。如水沫如水沫性。非我非众生。非命非人。色亦如是。能如是知是名菩萨观色方便。受喻如泡。想喻如焰。行如芭蕉。识喻如幻。如泡如焰如芭蕉幻性。无我无众生。无命无人。受想行识亦复如是。能如是知。是名菩萨观受想行识方便。诸阴如梦如响。如像如影。如化如化等性。无我无众生无命无人。是诸阴等亦复如是。能如是知是名菩萨观阴方便。所谓阴者即世间相。世间相者是可坏相。如可坏相即无常性。苦性。无我性。寂灭性。能如是知是名菩萨观阴方便。云何菩萨知界方便。法界地界。水火风界。是法界中。无有坚相湿相热相动相。法界眼界耳界鼻舌身意界。是法界中。无有见相闻相嗅相别相觉相知相。法界色界声香味触法。是法界中。无眼可见相。耳可闻相。鼻可嗅相。舌可别相。身可觉相。意可知相。法界眼识界。耳鼻舌身意识界。是法界中。无眼识知色。乃至无意识知法。法界色界法界非色作相。乃至法界亦复如是。法界我界无二无别。法界欲界色界无色界我界生死界涅槃界无二无别。法界虚空界。一切法界我界空界。无相无愿无作不出不生无所有等如涅槃。虚空涅槃。及一切法等。无有二。如是无量有为法界入无为界。能如是知如是说者。是名菩萨知界方便

云何菩萨观入方便。如佛所说。眼空我空我所空。何以故。是眼性中。无我无我所。耳鼻舌身意空亦复如是。观是入者见一切法。若善不善。无有二相。是名菩萨观入方便。若眼入色。入若见眼色离欲。不证离欲法。是名菩萨观入方便。耳入声入鼻入香入舌入味入身入触入意入法入。若见离欲不证离欲法。是名菩萨观入方便。所谓入者。若圣入非圣入。云何圣入。若修集道。云何非圣入。不修集道。若菩萨住道。于不修道者生大悲心不舍入道。是名菩萨观入方便

云何菩萨。观谛方便。所谓甚深难入。云何难入。若苦智集智灭智道智。苦智者观阴无生。集智者观断爱因。灭智者观无明等诸烦恼无有和合。道智者得平等观。于一切法无所倚着。菩萨若于四圣谛中作如是观。而不取证为化众生。是名菩萨观谛方便。复有三谛。何等三。俗谛。第一义谛。相谛。云何俗谛。若世间所用语言文字假名法等。云何第一义谛。乃至无有心行。何况当有言语文字。云何相谛。观一切相同于一相。一相者即是无相。菩萨随顺俗谛而不厌倦。观第一义谛而不取证。观诸相谛一相无相。是名菩萨观谛方便。复有二谛。何等二。俗谛。第一义谛。何等俗谛。若说苦集道谛。若世间语言文字假名法等。云何第一义谛。若于涅槃法终不忘失。何以故。如与法界其性常故。菩萨随俗不生厌倦。观第一义而不取证。复有一谛。何等为一。于一切法无所倚着。为化众生现有所著。是名菩萨观谛方便。复次五阴苦。若见五阴苦相。是名为苦观。苦即空是名苦智观苦圣谛。若观五阴诸烦恼爱因见因是名为集。若观爱因见因。不取不着不希不求。是名集智观集圣谛。若五阴毕竟尽相。过去已灭。未来未生。现在不住。是名为灭。能如是知。是名灭智观灭圣谛。若得道者证集灭智比智知已是名为道。若于是中悉见空性。是名道智观道圣谛。若能如是观四圣谛。是名菩萨观谛方便。若一切受是名为苦。若于诸受思惟分别。是名苦智观苦圣谛。受因和合是名为集。若于受因知如真实。是名集智观集圣谛。若除诸受无受者受。观受灭尽不证于灭。为化众生。是名灭智观灭圣谛。若有所受是名为道。虽有和合犹如筏喻。不为所受不求于道。是名道智观道圣谛。作如是知。见四圣谛清净平等。是名菩萨观谛方便。复次略说生苦是名为苦。若观于生。是名苦智观苦圣谛。生从因缘是名为集。若观有非有。是名集智观集圣谛。一切生非生是即非灭。若法不生即无有灭。是名为灭。若观此灭即是灭智观灭圣谛。若如是等。推求称量思惟分别是名为道。若灭如是求称量等。入法门者是名道智。观道圣谛。若住于智不证圣谛。是名菩萨观谛方便。云何菩萨观缘方便。集不善思惟故无明集。无明集故行集。行集故识集。识集故名色集。名色集故六入集。六入集故触集。触集故受集。受集故爱集。爱集故取集。取集故有集。有集故生集。生集故老死集。老死集故忧悲苦恼集。若知如是诸苦聚集。是名菩萨观缘方便。若住如是诸法聚集。则不长养。无所作。无诤讼。无有主。无所属。无系缚。所谓若因善法。因不善法。因不动法。若因向涅槃法。如是等法如实分别。若诸众生根量齐限。因是诸根所作诸业。若有受报及非受报。善知其因聚集方便。是名菩萨观缘方便。不善思惟灭则无明灭。无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死灭。老死灭故忧悲苦恼诸苦聚灭。若知如是诸苦聚灭。是名菩萨观缘方便。一切诸法属因属缘属和合。若法属因缘和合。是法则不属我人众生寿命。若法不属我人众生寿命则不入法数。能如是知是名菩萨观缘方便。若菩萨所修诸法。为助菩提安止菩提。如是诸缘悉见灭尽。而不取证为化众生。是名菩萨观缘方便。云何观三世方便。若念过去己身他身。善不善心心数法。不善心法。呵责毁呰善心数法。悉以回向无上菩提。是名菩萨观过去方便。若未来世心心数法。一向专念菩提之道。若起善心愿悉回向无上菩提。所有不善心心数法不令入心。发如是愿是名菩萨未来方便。若现在世心心数法。善思惟等所作诸业。悉以回向无上菩提。是名菩萨观现在方便。作如是方便。是名菩萨观三世方便。复次善解三世空无所有。若作是观观三世空智慧力故。若于三世诸佛所种无量功德。悉以回向无上菩提方便力故。如是方便。是名菩萨观三世方便。复次虽见过去尽法不至未来。而常修善精勤不懈。观未来法。虽无生出不舍精进愿向菩提。观现在法。虽念念灭。其心不忘发趣菩提。如是方便。是名菩萨观三世方便。过去已灭未来未至现在不住。虽如是观心心数法生灭散坏。而常不舍聚集善根助菩提法。如是方便。是名菩萨观三世方便

复次若诸神通。念过去世所作善根。念已回向无上菩提。念未来世未生善根。愿心所图如意成就。现在世中常生善根。专念不懈回向无上菩提之道。如是方便。是名菩萨观三世方便。复次若化众生。念过去世所作善根助道功德。所谓随众生心应可化者。如其所乐悉已化讫。若未来世所有众生。或须见佛及诸圣人而得度者。随形应适悉令得度。若现在世所有众生。若应闻法应见神力。亦随所应皆悉化之。随所教化诸众生已。即于三世成自他利。如是之利悉为菩提具无碍智。如是方便。是名菩萨观三世方便

舍利弗。云何菩萨观诸乘方便。世有三乘。何等三。声闻乘。缘觉乘。大乘。复有二乘。何等二。天乘人乘。云何菩萨观声闻乘。佛未出世无声闻乘。何以故。从他闻法生于正见。所谓闻者持戒威仪。威仪具故戒聚具足。戒聚具足已定聚具足。定聚具足已慧聚具足。慧聚具足已解脱聚具足。解脱聚具足已解脱知见聚具足。如是方便。是名菩萨观声闻乘方便。复次观声闻乘。若善不善及不动行。心常毁呰厌离三界。观一切行无常苦无我寂灭涅槃。乃至一念不悕受生。常怀怖惧心不甘乐。观阴如怨界如毒蛇。入如空聚。于一切趣不愿受生。若能如是开示分别。是名菩萨观声闻乘方便。云何菩萨观缘觉乘方便。若缘觉出世。观其所行如实知之。缘觉所行出过声闻所有功德。欲精进不放逸。持戒少闻不多供养诸佛世尊给侍使令。以中根故常有厌心。所作众事皆悉鲜少。厌患愦闹常乐远离。独住空闲威仪庠序。出入凝重安心静默简于人事。能为众生现世福田。其心玩乐观十二缘。常念一法出世涅槃。数游禅定不从他闻自然觉了少分境界。因缘悟道故名缘觉。若能如是开示分别。是名菩萨观缘觉乘方便。云何菩萨观大乘方便。其乘无量。今于此中当说少分。是乘无量悉能容受。一切众生。无挂碍故。是乘增长一切善根。令无量众生得受用故。是乘具足诸波罗蜜。能随众生心行化故。是乘能过助道之法。进趣无碍至道场故。是乘平等无碍光明照于一切无量众生悉堪受故。是乘无畏过怯弱道。悉能示现诸佛法故。是乘能坏一切诸魔外道邪众。了十二缘。建立佐助菩提幢故。是乘能除一切诸边有无断常因缘。诸见所起烦恼障碍。覆盖疑网调戏。得佛无碍真智慧故。是乘富足具诸珍宝。真实不虚能益众生。大悲勇猛本愿成就故。是乘具足十力无畏不共之法。相好严身身口意故。如是方便。是名菩萨观大乘方便。云何菩萨观一切法方便。所谓若有为。若无为。菩萨于中善知方便。云何善观有为方便。所有身善业。口善业意善业。愿以回向无上菩提。是名有为方便。若观身口意业同菩提相。回向菩提。是名菩萨观无为方便。复次有为方便。若能聚集五波罗蜜。是名有为方便。虽知般若波罗蜜其性无为。于所聚集终无厌贱。要欲具足诸波罗蜜。深解善根同无漏菩提。而犹愿成一切种智。是名菩萨无为方便。复次有为方便。住于无碍平等心中。以四摄法摄取众生。是名有为方便。云何无为方便。善解众生无我无人无所悕求。知四摄法同无为解脱。而能回向一切种智。是名无为方便。复次有为方便。若诸烦恼生死相续断令不起。所有善根助菩提者令不断绝。乃至不行少烦恼分。是名有为方便。云何无为方便。虽观空无相无愿。知此三空即助道方便故能不证。是名无为方便。复次有为方便。虽在三界不为三界烦恼所污。是名有为方便。云何无为方便。虽出三界不证于出。是名无为方便。如佛所说知诸法方便则能具足一切种智。何以故。一切种智无量无边。具足正念慧方便故。是故名为一切法方便。舍利弗。是名菩萨智慧所缘八方便也。舍利弗。是八方便能摄菩萨无尽智慧。舍利弗。是慧能解。观了善法不善法故。是慧如箭。善射法故。是慧财行。圣法现在故。是慧真解。断除诸见烦恼障碍诸覆盖故。是慧定愿。悉能满足本所求故。是慧消融。能除烦恼诸焦热故。是慧悦豫。不断法乐故。是慧正念。了所缘义故。是慧安住。具三十七助道法故。是慧得相。如所行乘能具足故。是慧解相。性智照故。是慧能度。过诸流故。是慧能进。成正定决定故。是慧正见。具足一切诸善法故。是慧欢喜。堕烦恼者能拔济故。是慧殊胜。得顶法故。是慧微妙。自然觉故。是慧不行。不近三世故。是慧摄取。具一切方便故。是慧能断。过诸思想故。是慧不放逸。舍离闇曚故。是慧初始。发行一切诸善法故。是慧能发。具诸乘故。是慧照明。除无明网故。是慧与眼。一切众生如其所解得明了故。是慧无依。过眼色故。是慧第一义。出真实故。是慧无诤。善分别故。是慧明了。向智门故。是慧无尽。能遍行故。是慧不逆。见十二缘故。是慧解脱。诸缠系缚悉善断故。是慧不杂。离于一切障碍法故。舍利弗。一切众生所有心行。如是智慧悉能照达。如众生心行慧思智诸烦恼门。如是智慧皆悉观了。若声闻缘觉菩萨如来所有智慧。是菩萨悉能遍学。舍利弗。是名菩萨无尽之慧。以是无尽慧具无尽智。说是法时。三万二千菩萨善根熟者。得无生法忍

大方等大集经卷第二十八大方等大集经卷第二十九

        宋凉州沙门智严共宝云译

    无尽意菩萨品第十二之三

尔时无尽意菩萨复语舍利弗。菩萨修慈亦不可尽。何以故。菩萨之慈无量无边。是修慈者无有齐限等众生界。菩萨修慈发心普覆。舍利弗。譬如虚空无不普覆。是菩萨慈亦复如是。一切众生无不覆者。舍利弗。如众生界无量无边不可穷尽。菩萨修慈亦复如是。无量无边无有穷尽虚空无尽故众生无尽。众生无尽故菩萨修慈亦不可尽。是谓大士所修慈心不可得尽。舍利弗言。善男子。齐几名众生界。无尽意言。所有地界水火风界其量无边。而犹不多于众生界。舍利弗言。唯善男子。颇可得说譬喻比不。无尽意言可说。但不得以小事为喻。舍利弗。东方去此尽一恒沙佛之世界。南西北方四维上下。皆一恒沙佛世界。作一大海其水满溢。使一恒河沙等诸众生聚集。共以一毛破为百分以一分毛渧取一渧。如是一恒河沙共取一渧。二恒河沙共取二渧。如是展转乃至尽此满大海水尽。是众生界犹不可尽。菩萨慈心悉能遍覆如是众生。舍利弗。于意云何。是修慈善根岂可尽耶。舍利弗言。实不可尽。唯善男子。是虚空性尚可得尽。菩萨慈心不可尽也。若有菩萨闻作是说不生惊怖。当知是人得无尽慈。舍利弗。是慈能自拥护己身。是慈亦能利益他人。是慈无诤。是慈能断一切嗔恚荒秽系缚。是慈能离诸结及使。是慈欢喜。是慈不见一切众生破戒之过。是慈无热身心受乐。是慈远离一切恼害。是慈能离一切怖畏。是慈能顺众圣人道。是慈能令嗔者欢喜。是慈能胜一切斗诤。是慈能生利养称叹。是慈庄严释梵威德。是慈常为智人所赞。是慈常护凡夫愚人。是慈常能随顺梵道。是慈不杂远离欲界。是慈能向解脱法门。是慈能摄一切诸乘。是慈能摄非财功德。是慈长养一切功德。是慈过诸无作功德。是慈悉能庄严相好。是慈能离下劣钝根。是慈能开天人涅槃诸善正道。是慈能离三恶八难。是慈爱乐诸善法等。是慈如愿一切所欲成就自在。是慈平等于诸众生。是慈发行离诸异相。是慈正向持戒之门。是慈能护诸犯禁者。是慈能成无上忍力。是慈能离诸慢放逸。是慈发起无诤精进入于正道。是慈根本入圣禅定。是慈善能分别于心离诸烦恼。是慈因慧而生总持语言文字。是慈定伴离魔结伴。是慈常与欢喜同止。是慈善为心之所使。是慈坚持威仪戒法。是慈能离诸掉动等。是慈能灭种种诸相。是慈善香惭愧涂身。是慈能除烦恼臭气。舍利弗。夫修慈者。悉能拥护一切众生。能舍己乐与他众生。声闻修慈齐为己身。菩萨之慈悉为一切无量众生。舍利弗。夫修慈者能度诸流。慈所及处有缘众生。又缘于法又无所缘。缘众生者初发心也。缘法缘者已习行也。缘无缘者得深法忍也。舍利弗。是名菩萨修行大慈而不可尽

复次舍利弗。菩萨摩诃萨修行大悲亦不可尽。何以故。舍利弗。如人命根即以出息入息为本。菩萨如是修学大乘。以大悲为本。如转轮圣王。以轮宝为本。菩萨如是修一切智以大悲为本。如大长者唯有一子愍爱情重。菩萨大悲亦复如是。于诸众生爱之若子。如是大悲我已行已。如是大悲作己利已。如是大悲不假他事。如是大悲己心所作出不谄曲。如是大悲所作毕竟出正决定。如是大悲种性所作出于直道。如是大悲心无邪曲出生正直。如是大悲无有憍慢出众生境。如是大悲捐舍己身出如来身。如是大悲不贪寿命出不作恶。如是大悲拥护众生出于菩提。如是大悲护真实法出心清净。如是大悲见诸穷厄出拔济事。如是大悲本誓坚固出不动心。如是大悲不欺己身人天贤圣出不虚诳。如是大悲其行清净出于善业。如是大悲自舍己乐出与他乐。如是大悲不与他苦出不焦热。如是大悲能令众生舍于重担出坚精进。如是大悲有忍势力出护无力。如是大悲不厌可污出瞻病者。如是大悲得法自在出教化钝根。如是大悲覆自功德出显他功业。如是大悲出离诸苦。如是大悲出求无漏乐。如是大悲出舍所爱物。如是大悲出作众善业无所娆恼。如是大悲出善持禁不舍毁戒。如是大悲出教化众生。如是大悲出不惜身命。如是大悲出舍自支节。如是大悲出生他善根。如是大悲出自利益善根。如是大悲出无味诸禅。如是大悲出不厌欲界。如是大慈出于观慧。如是大悲出不污善根。如是大悲出诸众生如所愿成。如是大悲出有为无为。如是大悲出不证无为。如是大悲出知众生性同无为而能教化。如是大悲出护毁戒者。如是大悲出赞叹佛戒。如是大乘诸悲出于大悲。以是因缘故名大悲。谓大悲者。必定善行布施持戒忍辱精进禅定智慧诸助道法。为得自然无师智慧。营他众生所作事业。精勤专著如修己务。以是因缘故名大悲。舍利弗。是名菩萨修行大悲而不可尽

复次舍利弗。菩萨摩诃萨。修行于喜亦不可尽。云何为喜。常念于法欢喜踊跃。不生懈怠无诸恼热。离五欲乐住于法乐。心和悦豫身轻柔软。意勤劝督心常生悲。乐求如来无上法身。乐修相好以自庄严。听法无厌念行正法。行正法已心生欢喜。生欢喜已具得法悲。常于众生不生碍心。以增上欲勤求于法。勤欲法已深心得解甚深佛法。远离二乘发无上心。除诸悭惜发于舍心。见来乞者心生欢喜。舍时欢喜施已无悔。如是布施三时清净。得清净已心则悦豫。于持戒者常行布施。于毁禁者喜心摄取。自持禁戒心则清净。能令恶道怖惧众生得无所畏远离恶处。一心回向如来禁戒。坚持牢固不可亏坏。恶骂加己堪忍不报。于诸众生心无憍慢。于诸尊长谦下恭敬。言常和悦离于嚬蹙。先以爱语终无谄曲。不以邪心诱诳于人。不以利养为他执役。其心清净无有粗过。于诸不可不见其过。不求他短不举人罪。专心正念诸和敬法。于诸菩萨生如来想。爱说法者重于己身。爱重如来如惜己命。于诸师长生父母想。于诸众生生儿息想。于诸威仪如护头首。于诸波罗蜜如爱手足。于诸善法生珍宝想。于教诲者生五欲想。于知足行生无病想。爱乐求法生妙药想。于举罪者生良医想。摄御诸根无有懈怠。是故名喜。是喜寂静觉知微妙故。是喜寂灭无恌戏故。是喜行倚不戏论故。是喜根本心不乱故。是喜多闻取善语故。是喜平等心柔软故。是喜勇猛善作业故。是喜不悔专行善故。是喜正住不懈怠故。是喜不动无所依故。是喜不共难摧伏故。是喜实义不忘失故。是喜真实无变异故。是喜诚谛如所作故。是喜能舍力坚牢故。是喜大力无能胜故。是喜能作诸佛神力求诸佛法故。舍利弗。是名菩萨修行于喜而不可尽

复次舍利弗。菩萨摩诃萨。修行于舍亦不可尽。云何菩萨修舍无尽。菩萨行舍。舍有三种。云何为三。舍诸烦恼。舍护己他。舍时非时。云何舍诸烦恼。恭敬供养其心不高。轻蔑毁呰心亦不下。若得利养心不贪恃。若遭衰恼心亦不愁。若遇誉赞心无喜庆。若遭毁者心不退缩。若遇讥者心无亏赧。若有称者善住法界。若遭苦事心力忍受。若遇乐事明见无常。放舍所爱断于嗔恚。于亲非亲得平等心。持戒毁戒意无增减。作善作恶无有二相。于爱非爱心无所著。闻善不善心能堪忍。于善恶语心不系着。于昧过患其量无二。于诸众生得平等心。于上中下得等光明。不惜身命好恶名闻同于法界。于实不实法心得清净。于世法等得菩萨舍。是名菩萨舍于烦恼。云何菩萨舍护己他。若被割截身体支节。心无嗔恨不求仇报。以得舍心故能舍二。内外身口于此二中不生诤讼。于眼与色无有欲污。耳声鼻香舌味身触意法亦复如是。故于二中不生诤讼是故名舍。不伤不害是故名舍。舍护己他是故名舍。于利非利心行平等是故名舍。于第一义不生诤论是故名舍。于己心中善能分别是故名舍。观舍己身是故名舍。不害他身是故名舍。菩萨修舍于诸禅定常行舍心。诸佛世尊不听菩萨于诸众生而行舍心。何以故。菩萨常修精进为利自他勤求善根。是名菩萨舍护己他。云何舍时非时。非器众生舍不引接。衰毁讥苦舍而不受舍求声闻成决定者。行布施时舍修持戒。修持戒时舍于布施。修忍辱时舍施戒进。修精进时舍施戒忍。行禅定时舍于布施。修智慧时舍五波罗蜜所不应作终不复作。如是诸法安住戒行。精勤勇猛具足修行。是名菩萨修无尽舍

复次舍利弗。菩萨诸通亦不可尽。云何诸通。天眼通。天耳通。他心通。宿名通。如意通。云何天眼通菩萨天眼于诸天龙鬼神诸乾闼婆学无学人声闻缘觉所有天眼为最第一。微妙殊胜开达明了。向一切智功德所成。不与天龙二乘共之。若有十方无量无边诸佛世界。所有形貌色像光明。若粗若细若近若远。菩萨天眼一切悉见。照了分别善解善见。亦见其中所有众生生诸趣者。除无色天其余业行生死相续。若业业果分别诸根悉知无遗。若于十方无量无边诸佛世尊。所有庄严净妙国土悉见无余。如是见已清净持戒。愿以回向庄严己土。住是持戒如其所愿。悉得成就无量大利。菩萨天眼亦见其中。菩萨大众修行于道。身四威仪及正忆念。得解脱法安住总持。辩才方便入慧方便。见已自修如是诸行悉令备足。是菩萨眼清净无碍得见色故。是眼不污不着色故。是眼解脱远离诸见烦恼故。是眼清净性明了故。是眼不依离所缘故。是眼不发断烦恼故。是眼无医断疑网故。是眼不起断障碍故。是眼得明照了法故。是眼念知不行识故。是眼无贪嗔恚愚痴能断一切诸结使故。是眼无上趣圣本故。是眼无碍平等光明照众生故。是眼无垢断恶法故。是眼不染性清净故。是眼入佛眼毕竟不舍故。是眼不缚断爱恚故。是眼行义出于真实修行念知净道法故。何以故。是大士安住大悲深解法相。善分别义无有诤讼。随见闻说背不善法。趣向道场心无障碍。见悭惜人能舍财施。见毁禁者修持净戒。见嗔恚者修忍不诤。见懈怠者摄取劝励。见散心者示诸禅支。无智慧者施与慧眼。行邪道者示以正道。修下行者为说甚深微妙佛法令入一切智。不退诸通具足菩提。舍利弗。是名菩萨天眼神通而不可尽

复次舍利弗。菩萨摩诃萨天耳神通亦不可尽。云何菩萨天耳神通。若十方无量无边诸佛世界所有诸声。所谓天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人声。及以圣声。所谓声闻缘觉菩萨正遍知声。一切凡是耳根所对。乃至地狱饿鬼畜生。蝇蚁蚊虻所有诸声一切悉闻。若诸众生心所缘处。若善不善无记所作事业。出诸音声。一切悉解。若口善业口不善业口无记业。如是诸业悉如实知。若有口业因于爱欲说嗔说痴。若有口业因于嗔恚说欲说痴。若有口业因于愚痴说欲说嗔。若因欲说欲因嗔说嗔因痴说痴。如是诸声亦皆能知。或有口业心净口粗。或有口业口净心粗。或有口业口净心净。或有口业口粗心粗。如是一切无碍耳通能如实知。是菩萨天耳。亦知圣声及非圣声。若闻圣声不生爱着。闻非圣声心不生碍。于圣人声得具大慈。非圣人声得具大悲。若闻过去未来诸声。得尽本际如实正智。是菩萨天耳。得闻一切诸佛世尊所说妙法。闻已忆念正智总持不忘不失。随众生器而为说法。善知诸法坚不坚相。是菩萨若听一佛说法。不闻余佛所说法者无有是处。一切诸佛所可演说悉能听受。菩萨若闻善不善无记法声。皆悉善知时与非时。所谓若有众时非说法时。闻已默然而无所说。若有说时非有众时。所谓正为一人能堪受者。是故虽说不为一切。事若真实或畏伤他故不为说。事若不实为利益他。以清净心方便得说。若所喜声即能得闻。所不喜者便不复闻。若于大众为诸众生演说法时。随其耳识所解所受。是菩萨天耳悉得闻知。若说法时或有众生。应解悟者便得闻法。不解悟者则便不闻。是菩萨耳界法界其性清净。知见我人众生悉清净故。是菩萨正分别耳界。如言语文字所说之相。若有五趣杂类众生。随其所解言语音声而为说法。持是天耳回向如来所得耳界。不求余乘故。舍利弗。是名菩萨天耳神通而不可尽

复次舍利弗。菩萨知他心通亦不可尽。云何菩萨知他心通。若诸众生上中下心菩萨悉知。知是众生因施根心相。知是众生因戒根心相。知是众生因忍根心相。知是众生因进根心相。知是众生因定根心相。知是众生因智根心相。知是众生因慈悲喜舍根心相。知是众生因声闻缘觉大乘根心相。知是众生因力增上善根具足。知是众生因行增上善根故得生此。知是众生其行清净心不清净。知是众生其行不净而心清净。知是众生心行俱净。知是众生行之与心二俱不净。知是众生过去世心诸根行因。知是众生随缘悟法。是名菩萨知他心智。又复知他未来世心。知是众生未来世中有持戒因。现在世中有布施因。知是众生未来世中有忍辱因。现在世中有持戒因。知是众生未来世中有精进因。现在世中有忍辱因。知是众生未来世中有禅定因。现在世中有精进因。知是众生未来世中有智慧因。现在世中行俗心因。知是众生未来世中发大乘因。现在世中有下根因。未来众生有如是等诸因诸缘。是诸因缘能如实知。是菩萨于未受化众生终不疲厌。如其心根如实能知。随其器量而为说法。若乐少闻则不多说。说必有益功不唐捐。是名菩萨知他心智。若现在世众生所行。心心数法悉如实知。所谓欲心如实知。欲心离欲心如实知。离欲心恚心如实知。恚心离恚心如实知。离恚心痴心如实知。痴心离痴心如实知。离痴心散心如实知。散心摄心如实知。摄心懈怠心如实知。懈怠心精进心如实知。精进心下心如实知。下心上心如实知。上心乱心如实知。乱心定心如实知。定心无解脱心如实知。无解脱心有解脱心如实知。有解脱心无寂静心如实知。无寂静心有寂静心如实知。有寂静心有量心如实知。有量心无量心如实知。无量心一一众生一一烦恼缠覆心者一切皆知。如是知已。如其出道而为说法。又是菩萨所住之处。先观众生知其根量。随而为说出要之法。是诸众生上中下根悉如实知。是菩萨心知他心时无有障碍。何以故。是菩萨心智猛利善分别故。念意进慧之所知故。善能解了菩提相故。断诸习气故。清净无垢故。明了无诤故。无诸烦恼故。无有渊流故。照一切法故。善入一切众生心故。能如是解。是菩萨心智猛利。于如是法正入知者。是名菩萨他心智通而不可尽

复次舍利弗。菩萨宿命智通亦不可尽。云何菩萨宿命智通。是菩萨念宿命事。若自若他善受忆持。安住法界无有倾动。无倾动者能善解了善作业故。是念无恼安住禅定故。是念无畏善摄智慧故。是念不从他求现得善知故。是念正忆毕竟不失故。是念助功德善解大乘故。是念助智不从他具足故。是念善根诸波罗蜜具足能到一切佛法故。是宿命智。若念一生二生三生四生五生十生二十生三十生四十生五十生。乃至百生千生百千生无量百生无量千生无量百千生。及天地成坏无量成世无量坏世无量成坏世无量成坏劫。知诸众生于是中生如是种姓如是名字如是色像如是饮食如是寿命受苦乐等。于是中死还是中生。于彼中死还彼中生。是菩萨念如是等无量生死。自念宿世及他众生尽过去际。是菩萨念自善根回向阿耨多罗三藐三菩提。念他善根愿令发阿耨多罗三藐三菩提心。是菩萨以正念心。于本生死行苦。善观无常苦无我。若观无常苦无我者。于诸色欲封禄寿命眷属自在悉无贪着。亦复不贪释梵护世转轮圣王及受生处五欲欢乐。为化众生故现受生。是菩萨念于无常苦无我已。过去秽行发露忏悔。现世诸恶乃至失命终不为之。过去善根欲令增广。回向阿耨多罗三藐三菩提。现在善根与众生共。回向阿耨多罗三藐三菩提。是菩萨离诸恶愿不断三宝种故。所有善根悉以回向阿耨多罗三藐三菩提。舍利弗。是名菩萨念宿命智而不可尽

复次舍利弗。菩萨摩诃萨如意神通亦不可尽。云何菩萨如意神通。若欲进心慧所摄诸法。调伏柔和心得自在。善修集故。现在能得是如意通。是菩萨作种种神通变化。以是神通为化众生。是菩萨一一示现种种神通教化众生。所谓若色相若力势若变化。是菩萨示种种色相。令众生见见已心伏。所谓若佛色像若缘觉色像若声闻色像若释梵护世转轮圣王色像。及余种种无量色像。乃至示现畜生色像。化众生故作是示现。示现是已随其所应而为说法。若有众生自谓己身有大势力。而起憍慢嗔恚贡高。菩萨欲为调伏如是诸众生故示现大力。所谓示现那罗延力四分之一或四分之二或四分之三。或全示现须弥山王高十六万八千由旬纵广八万四千由延。以三指举掷置他方无量世界。譬如掷一阿摩勒果。于菩萨力而无损减。断取三千大千世界。下尽水际以手举之。高至有顶住经一劫。菩萨成就示现如是大势力时。能令如是嗔恚憍慢贡高众生内善调伏。知调伏已然后随应而为说法。是菩萨修如意通。能得智慧变化势力。以变化力诸所欲作悉得成就。能变大海以为牛迹大海不小。又变牛迹以为大海牛迹不大。若劫欲尽火灾起时。欲变为水能如意变。水灾起时能变为火。风灾起时能变为火。火灾起时能变为风。风灾起时能变为水。水灾起时能变为风。如是变化皆悉成就。若上中下法随意变化。唯除诸佛。更无有人能移动留碍破坏。菩萨如意神通。所谓释梵天王魔王波旬及其眷属。是菩萨作种种变化。示诸众生令欢喜已。然后随意而为说法。是菩萨神通勇健自在。能过诸魔烦恼境界。入于佛界不恼众生。所有善根皆悉成就。一切魔众无能断者。舍利弗。是名菩萨如意神通而不可尽

复次舍利弗。菩萨四摄亦不可尽。云何为四。一者布施二者爱语三者利行四者同利。云何布施。施有二种。财施法施。云何爱语。于求财人及听法者柔和与语。云何利行。于求财人及听法者。随其所求悉令满足。云何同利。求财法者以大乘己利令彼安止。又复施者。见诸乞求心生清净。爱语者。于诸乞士心生欢喜。利行者。于诸乞士随其所利而令具足。同利者。常以大乘劝诲众生。复次施者。所谓舍心。爱语者。行无限齐。利行者。毕竟不悔。同利者。回向大乘。复次施者。起慈行舍。爱语者。不舍喜心。利行者。大悲庄严利于众生。同利者。舍于高下。发心回向一切种智。复次施者。如法求财清净行施。爱语者。将导爱者安止善法。利行者。说于己利以利益他。同利者。令诸众生发一切智心。复次施者。舍于内外。爱语者。功德智慧心无吝惜。利行者。舍自利行而行利他。同利者。弃舍重位心初无悔。复次法施者。如所闻法悉能演说。爱语者。不为利养而演说法。利行者。诲他讽诵心无疲厌。同利者。一切智心所得妙法。即以此法劝励众生。复次法施者。若有众生一一听法次第为说而无错谬。恶语者。为人说法不辞远近。利行者。有求法人供给衣服饮食卧具病瘦医药令无所乏。既施所安然后随应而为演说。同利者。凡所讲说常劝众生。回向阿耨多罗三藐三菩提。复次法施者。于诸施中知其最胜。以此胜法为人演说。爱语者。常为利益众生故说。利行者随义而说不随文字。同利者。常为具足佛法故说。复次施者。具足檀波罗蜜。爱语者。具足尸罗羼提波罗蜜。利行者。具足毗梨耶波罗蜜。同利者。具足禅那般若波罗蜜。复次施者。初发菩提。爱语者。修行菩提。利行者。不退菩提。同利者。一生补处。复次施者。安住菩提种子根本。爱语者。滋长菩提芽茎枝叶。利行者。渐以开敷生菩提华。同利者。已能成就菩提果实。舍利弗。是名菩萨以四摄法摄取众生而不可尽

复次舍利弗。菩萨摩诃萨四无碍智。亦不可尽。云何为四。一者义无碍。二者法无碍。三者辞无碍。四者乐说无碍。云何义无碍。于诸法中知第一义。是比智。是因智。是缘智。是和合智。是不堕边智。是不住中智。是十二因缘智。是不异法性智。是如实智。是真际智。是觉空空智。是无相相智。是无愿愿智。是无为为智。是观一相智。是观无我智。是观无众生智。是观无命智。是观无我第一义智。是观过去无挂碍智。是观未来无有边智。是观现在一切种智。是观诸阴如怨贼智。是观诸界如毒蛇智。是观诸入如空聚智。是观内法永寂灭智。是观外法无行处智。是观所缘如幻化智。是观念正住智。是观忍正法智。是观自身智。是观了诸谛智。是苦不和合智。是集不作智。是灭自性智。是道能到智。是分别诸法智。是观众生诸根心行随所入智。是诸力无能伏智。是诸觉如实解智。是禅定受持智。是慧光明智。是幻化庄严智。是热时焰迷惑智。是梦中所欲智。是响所缘智。是镜中像无去来智。是种种相无相智。是扼离扼智。是取生离生智。是声闻乘从他闻智。是缘觉乘观十二缘智。是大乘具足一切善根智。舍利弗。是名菩萨义无碍智。又复义无碍者。思一切法义。何以故。是一切法无我众生无命无人。如无我众生无命无人即名为义。如命义者色等诸法亦复如是是名义无碍。又复义无碍者。是无住说。是无尽说。是得一切法说。如是义无碍者。诸佛所许。是真实义无别无异。智慧分别无有障碍。是名菩萨义无碍智而不可尽。舍利弗。云何菩萨法无碍智。若观诸法。所谓善法不善法。世法出世法。可作法不可作法。有漏法无漏法。有为法无为法。黑法白法。生死法涅槃法。是智法性平等。是智菩提平等。是智性平等。是名法无碍智。又复法无碍者。观于众生。多欲心行。少欲心行。初发欲心行。欲相心行。现在所缘欲心行。现在因缘欲心行。有众生内有欲行外无欲行。外有欲行内无欲行。有内外欲行。有内外无欲行。有色欲行非声香味触。有声欲行非色香味触。有香欲行非色声味触。有味欲行非色声香触。有触欲行非色声香味。入如是观众生诸欲行门行。欲行者二万一千行。恚行者二万一千行。痴行者二万一千行。等分行者二万一千行。观如是众生八万四千心之所行如实而知。随其所应而为说法。舍利弗。是名菩萨法无碍智。而不可尽

舍利弗。云何菩萨辞无碍智。于诸音声悉观了知。所谓天龙鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人如是言语文字音声皆悉能知。如是五道杂类众生。随其种类一一音声语言文字而为说法。是名辞无碍智。如是语法文字思惟觉了无碍。是菩萨知一语二语三语乃至多语男语女语非男女语过去语未来语现在语。知积一字至多字语。是名辞无碍智。是辞无碍智。说时无谬无有滞碍。妙语通畅所言审谛正直无粗。所有文辞具足庄严。大众闻者无不欢喜。如是种种微妙音声。深远广普庄严俗谛第一义谛。以智慧箭善射邪见。是辞无碍诸佛所许。能令众生皆得欢喜。舍利弗。是名菩萨辞无碍智而不可尽

舍利弗。云何菩萨乐说无碍智不可窟尽。所说无碍所说不住。所说速疾所说捷利。如所问答无挂碍答。无违逆答。是相应答。住忍力答。依二谛答。依施戒忍进定慧答。依一切法章句而答。依于念处正勤如意根力觉道甚深义答。依寂灭思惟答。所谓乐说无碍智者。若一切言语文字。口所分别正直而答。所谓一切禅定三摩跋提真谛智答。辩畅三乘随诸众生一切心行如应而答。所言巧妙非如哑羊。强梁粗恶卒暴恌戏。如是之语悉无复有。所宣寂灭人所受用。威德之言无诸缠缚。相应无违微妙柔软。无可讥诃圣人所赞。如佛世尊所教诲语。梵音清彻一切悉闻。是乐说无碍智诸佛所许。为他众生说微妙法。闻是法者得出世乐灭尽诸苦。是名乐说无碍智也。舍利弗。是名菩萨摩诃萨四无碍智而不可尽

复次舍利弗。菩萨摩诃萨有四依法亦不可尽。何等为四。依义不依语。依智不依识。依了义经不依不了义经。依法不依人。云何依义不依语。语者若入世法中而有所说。义者解出世法无文字相。语者若说布施调伏拥护。义者知施戒忍入于平等。语者称说生死。义者知生死无性。语者说涅槃味。义者知涅槃无性。语者若说诸乘随所安止。义者善知诸乘入一相智门。语者若说诸舍。义者三种清净。语者说身口意受持净戒功德威仪。义者了身口意皆无所作。而能护持一切净戒。语者若说忍辱断除恚怒贡高憍慢。义者了达诸法得无生忍。语者若说勤行一切善根。义者安住精进无有终始。语者若说诸禅解脱三昧三摩跋提。义者知灭尽定。语者悉能闻持一切文字智慧根本。义者知是慧义不可宣说。语者说三十七助道之法。义者正知修行诸助道法能证于果。语者说苦集道谛。义者证于灭谛。语者说无明根本乃至生缘老死。义者知无明灭乃至老死灭。语者说助定慧法。义者明解脱智。语者说贪恚痴。义者解不善根即是解脱。语者脱障碍法。义者得无碍解脱。语者称说三宝无量功德。义者三宝功德离欲法性同无为相。语者说从发心至坐道场。修集庄严菩提功德。义者以一念慧觉一切法。舍利弗。举要言之。能说八万四千法聚是名为语。知诸文字不可宣说是名为义。云何依智不依于识。识者四识住处。何等四。色识住处。受想行识住处。智者解了四识性无所住。识者若识地大水火风大。智者识住四大法性无别。识者眼识色住。耳鼻舌身意识法住。智者内性寂灭外无所行。了知诸法无有忆想。识者专取所缘思惟分别。智者心无所缘不取相貌。于诸法中无所悕求。识者行有为法。智者知无为法识无所行。无为法性无有识知。识者生住灭相。智者无生住灭相。舍利弗。是名依智不依于识

云何依了义经不依不了义经。不了义经者分别修道。了义经者不分别果。不了义经者所作行业信有果报。了义经者尽诸烦恼。不了义经者诃诸烦恼。了义经者赞白净法。不了义经者说生死苦恼。了义经者生死涅槃一相无二。不了义经者赞说种种庄严文字。了义经者说甚深经难持难了。不了义经者多为众生说罪福相。令闻法者心生欣戚。了义经者凡所演说必令听者心得调伏。不了义经者若说我人众生寿命养育士夫作者受者。种种文辞。诸法无有施者受者。而为他说有施有受。了义经者说空无相无愿无作无生。无有我人众生寿命养育士夫作者受者。常说无量诸解脱门。是名依了义经不依不了义经

云何依法不依于人。人者摄取人见作者受者。法者解无人见作者受者。人者凡夫善人信行人法行人八人须陀洹人斯陀含人阿那含人阿罗汉人辟支佛人菩萨人。一人出世多所利益多人受乐。怜愍世间生大悲心。于人天中多所余润。所谓佛世尊。如是等名佛依世谛为化众生故作是说。若有摄取如是见者。是谓依人。如来为化摄人见者故。说依法不依于人。是法性者。不变不易无作非作无住不住一切平等。等亦平等。不平等者亦复平等。无思无缘得正决定。于一切法无别无异。性相无碍犹如虚空。是名法性。若有依止是法性者。终不复离一相之法。入是门者观一切法同一法性。是故说言依一切法不依于人。舍利弗。是名菩萨摩诃萨四依无尽

大方等大集经卷第二十九大方等大集经卷第三十

        宋凉州沙门智严共宝云译

    无尽意菩萨品第十二之四

复次舍利弗。菩萨摩诃萨修集助道功德智慧亦不可尽。云何修集功德无尽。若布施持戒心所修集。发行慈悲自所有罪发露忏悔。亦代众生发露忏悔。已行忏悔次当随喜。一切众生学无学人及辟支佛发心菩萨已习行者。坚住不退一生补处。如是诸人于三世中所集功德。当以一心随其欢喜。复于过去未来现在诸佛世尊所有善根生随喜心。是随喜菩萨悉当成就如是功德。随喜已讫。次当劝请十方世界一切诸佛。始成道者请转法轮。示涅槃者常住于世。及请一切菩萨圣人。常为众生住世说法。如是善根如菩提想。悉以回向无上菩提。是菩萨未发心者劝令发心。已发心者为说诸度。有贫穷者救摄以财。病施医药随时瞻疗。无势力者劝行忍辱。有犯禁者令不覆藏。已覆藏者劝令发露。现在诸佛及涅槃者。悉皆发心供养恭敬。敬重师长如佛世尊。若求法时没命不懈。于此法宝生无价想。于说法者生诸佛想。为听法故。过百由旬心力勇锐无疲劳想。凡所讲说不为利养。于父母所知恩报恩。供养给事心初无悔。所作功德常无厌足。护身口意令无谄曲。建立佛塔所得功德。等于梵天劝请之福。具足诸相开门大施故。得随形好修诸善根故。庄严身者无憍慢故。庄严口者离口过故。庄严意者不住法故。庄严佛土者神通教化故。庄严法者离诸欲故。庄严大众者不两舌恶口破坏他故。于受法者如实说故。说法欢喜称赞善哉。所作功业不唐捐故。离覆盖者故往听法故。庄严菩提树者以妙园林奉施佛故。庄严道场者成就一切诸善根故。出生清净者不为烦恼所染污故。得宝手者能舍一切所重物故。得无尽者无量宝藏以布施故。见者欢喜常和悦故。体得法性者心慧光明等照众生故。庄严光明者不轻未学善诱导故。生生清净者持戒功德悉成就故。处胎清净者不见他罪故。生人天者净行十善故。慧明独步者所可教化不生分别故。于法自在者所爱重法无吝惜故。世中独胜者毕竟清净故。微妙解脱者不求少分行故。行一切功德者不舍一切智心故。七财满具者信为根本故。摄取正法者不惜身命故。不诳世间者具本誓愿故。具足一切佛法者诸善根本本已行故。舍利弗。是名略说菩萨功德。若广说者。若经一劫若过一劫不可得尽

云何菩萨智慧无尽。若一一因闻说智慧。若一一缘得于智慧。云何为因。内增上欲。云何为缘。外勤求法。如是因缘依佛智慧。非依声闻缘觉智慧。亲近智者心无憍慢。常于其人起世尊想。是诸智者知受法人。心已柔和。为说智慧教令依止。随其正器说无染法。听法之人于是法中。勤修聚集。助法精进是为智慧。云何菩萨助法精进。若无悕求简绝事务省少语言。于诸所欲心常知足。初夜后夜减损睡眠。凡所闻义能善思惟筹量分别。数求善法心无爱浊。除诸阴盖无有障蔽。所犯过失寻能除灭。正行坚固趣向倾仰。尊敬法行具精进行。求法不懈如救头然。无有我行不迟缓行。不舍本行心增上行。呵众闹行爱乐独行。向阿兰若处思惟行。圣种知足行。不动头陀行。欣乐法行。不思惟世间言语行。求出世间法行。不失正念行。发诸法义行。真正道行。知缘总持行。惭愧庄严行。智慧坚牢行。除无明网缠结系缚净慧眼行。善觉了行。广觉了行。不灭觉行。分析觉行。现在知行。不从他功德行。不自恃功德行。赞叹他人诸功德行。善修作业行。因果不动行。知清净业行。舍利弗。是名助法精进

复次舍利弗。菩萨摩诃萨有四种施。具足智慧。何等为四。一者以纸笔墨施与法师令书写经。二者种种校饰庄严妙座以施法师。三者以诸所须供养之具奉上法师。四者无谄曲心赞叹法师。舍利弗。是名菩萨四种布施具足智慧。菩萨复有四持禁戒具足智慧。何等为四。一者持戒常演说法。二者持戒常勤求法。三者持戒正分别法。四者持戒回向菩提。是名菩萨四种持戒具足智慧。菩萨复有四种忍辱具足智慧。何等为四。一者于求法时忍他恶骂。二者于求法时不避饥渴寒热风雨。三者于求法时随顺和上阿阇梨行。四者于求法时能忍空无相无愿。舍利弗。是名菩萨四种忍辱具足智慧。菩萨复有四种精进具足智慧。何等为四。一者勤于多闻。二者勤于总持。三者勤于乐说。四者勤于正行。舍利弗。是名菩萨四种精进具足智慧。菩萨复有四种禅定具足智慧。何等为四。一者常乐独处。二者常乐一心。三者求禅及通。四者求无碍解智。舍利弗。是名菩萨四种禅定具足智慧。菩萨复有四种智慧具足智慧。何等为四。一者不住断见。二者不入常见。三者了十二缘。四者忍无我行。舍利弗。是名菩萨修行四慧具足智慧。菩萨复有四拥护法具足智慧。何等为四。一者拥护法师如己君主。二者护诸善根。三者将护世间。四者护利益他

舍利弗。是名菩萨四拥护法具足智慧。菩萨复有四满足法具足智慧。何等为四。一者说法满足。二者智慧满足。三者利益满足。四者诸法满足。舍利弗。是名菩萨四满足法具足智慧。菩萨复有四力具足智慧。何等为四。一者精进力求于多闻得解脱故。二者念力菩提之心不忘失故。三者定力等无分别故。四者慧力修多闻故。是名四力具足智慧。复有四方便具足智慧。何等为四。一者随世所行。二者随众生行。三者随诸法行。四者随智慧行。是名四方便具足智慧。菩萨复有四道具足智慧。何等为四。一者诸波罗蜜道。二者助菩提道。三者行八圣道。四者求一切智慧道。是名四道具足智慧。菩萨复有四无厌足行具足智慧。何等为四。一者乐于多闻无有厌足。二者乐于说法无有厌足。三者行慧无厌。四者行智无厌。是名菩萨四无厌足具足智慧。复次助智慧者。随一切众生心行。随一切法行。随布施行。随持戒忍辱精进禅定智慧行。随慈悲喜舍行。得具足智慧。何以故如诸菩萨所发起行。皆以智慧而为根本。智慧成已还依止智。是菩萨安住于智依一切智。诸魔眷属不能留难。是故能得具一切智。舍利弗。是名菩萨助智无尽

复次舍利弗。菩萨摩诃萨四念处亦不可尽。是菩萨观身修身行。见过去未来现在诸身颠倒和合。如外草木墙壁瓦石。从因缘有不可长养无所系属。此身如是从因缘生不可长养无所系属。是阴界入中我我所空常无常空。是身无我无有我所。是身不坚不可依怙。当求菩提正觉之身。云何菩提正觉之身。所谓法身。金刚之身不可坏身。坚牢身出三界身。我身虽有无量过患。愿当除灭成如来身。是菩萨所以堪忍久处四大诸结焦然。皆为利益诸众生故。如外四大地水火风。种种门。种种所作。种种形貌。种种器物。种种所用。皆为利益一切众生。我今此身为利众生亦复如是。菩萨摩诃萨见如是利益已。观身众苦不生厌离。观身无常不厌生死。观身无我不舍教化。观身寂灭不随于舍。是菩萨观内身时不生烦恼。观于外身亦复如是。是菩萨离黑污身成白净身业。具足妙相以自庄严。于天人中多所利益。是名菩萨观身修身行。云何菩萨观受修受行。菩萨如是思惟。诸受一切皆苦善分别受。智慧筹量知受寂灭。若受乐时不贪所欲。若受苦时观三恶道。起大悲心不生嗔恚。若受不苦不乐时不起愚痴。是菩萨正念受处。如其所受。若苦若乐不苦不乐。于是诸受知出知修。观诸众生受寂灭庄严。是诸众生于诸受中不知出修。若受乐时生于贪着。若受苦时便生嗔恚。若受不苦不乐时便生愚痴。我今要当进修智慧。除一切受发诸善根。起大悲心摄取智慧。亦为众生除断诸受而为说法。未解受者受苦。解受者受乐。云何解受者。所谓无受者无我人众生寿命养育士夫。除摄取受者。摄者。受取者。受受者。受有者。受颠倒者。受分别者。受诸见者。受眼相者。受耳鼻舌身意相者。受色相者。受声香味触法相者。受眼缘色生触。受苦受乐受不苦不乐。受耳声鼻香舌味身触心缘法生触。受苦受乐受不苦不乐。是名为受。复有一受心意觉了。复有二受内受外受。复有三受过去未来现在受。复有四受觉了四大。复有五受思惟五阴。复有六受分别六入。复有七受七识住处。复有八受八邪法也。复有九受九众生居处。复有十受十不善法。舍利弗。举要言之。无量众生诸受思惟所缘境界一切名受。菩萨于中修受观行起大智慧。知诸众生善不善受生住灭相。舍利弗。是名菩萨正受念处而不可尽

云何菩萨观心念处。菩提之心不忘不失。正念不乱如是观心。心生已灭无有住相。不于内住不从外来。我初所发菩提心者。是心已尽过去变异。不至方所不可宣说无有住处。若心所集诸善根等亦是过去尽灭变异。不至方所不可宣说无有住处。若心善根回向阿耨多罗三藐三菩提。是亦灭尽变异之法。不至方所不可宣说无有住处。心不知心。心不见心。心不生心。我以何心。成阿耨多罗三藐三菩提。是菩提心不与善根心合。善根心不与回向心合。回向心不与菩提心合。若菩萨作是观时不惊不怖。是名菩萨勤精进也。又复思惟观察甚深十二因缘不失因果。知是心性属众因缘。不可长养无作无系。一切诸法亦复如是。如法修行如所庄严。我今当勤修集庄严不离心性。云何心性。云何庄严。心性者。犹如幻化无主无作无有施设。庄严者。所作布施悉以回向严净佛土。心性者。如梦所见心相寂灭。庄严者。具足持戒修集诸通。心性者。如镜中像其相清净。庄严者。所修诸忍悉以回向无生法忍。心性者。如热时焰究竟寂灭。庄严者。于一切善深发精进回向具足无上佛法。心性者。无色无对无所为作。庄严者。一切所修禅定解脱三摩跋提回向具足佛之禅定。心性者。不可得见亦不可取。庄严者。于一切问难善能分别回向具足佛之智慧。心性者。无缘不生。庄严者。常观善根。心性者。无因不生。庄严者。因助菩提而发起心。心性者。舍离六尘心则无起。庄严者。入佛境界。如是菩萨观是心行系念神通。得神通已能知一切众生诸心。既知心已如其心量而为说法。又观心行系念大悲。教化众生无有厌倦。又观心行不起尽灭变异之相。不舍生死相续烦恼。正念是心知无生起成正决定。如是行者不堕声闻辟支佛地。极是心势以一念智。成阿耨多罗三藐三菩提。舍利弗。是名菩萨正心念处而不可尽

舍利弗。云何菩萨观法念处。常以慧眼见一切法。至坐道场未曾中失。是菩萨当观法时。不见一法乃至微相。离空无相无愿无作无生无灭无物。亦不见一法乃至微相不入十二缘者。菩萨观法。见诸非法无不是法。云何为法。谓无我义。无众生义。无寿命义。无人义。是名为法。云何非法。谓我见众生见。寿命见人见。断见常见。有见无见。是名非法。复次一切法是法。一切法是非法。何以故。观空无相无愿。是名一切法是法。我慢憍慢我及我所摄取诸见。是名一切法非法。是菩萨观法时不见有法。非菩提因出世道因。是菩萨知一切法悉是出世。得无碍大悲。观一切法烦恼结缚如幻化相。知是诸法非有烦恼非无烦恼。何以故。了诸法义无有二性。是诸烦恼无隐藏处无有聚集。若解烦恼即解菩提。如烦恼性即菩提性。是菩萨安住正念。无有一法可作分别。无诸障碍善能解了正住法性。如住法性即住众生性。如住众生性即住虚空性。如住虚空性即住一切法性。菩萨观法时。依于佛法解一切法即是佛法。其心尔时不生尽智无为。虽尽而亦不尽入无生智。亦观众生不舍假名。法念处者。安住正念一切诸法。所谓声闻缘觉菩萨正觉所知一切假名诸法。尽未来际终不忘失。又法念处者。说无量行亲近佛法。坏诸魔众得自然智。舍利弗。是名菩萨正法念处而不可尽

复次舍利弗。菩萨摩诃萨四正勤亦不可尽。何等为四。若未生恶不善法为不生故。生欲勤进摄心正除。已生恶不善法为断故。生欲勤进摄心正除。未生善法为生故。生欲勤进摄心正除。已生善法安住修集为增广不失故。生欲勤进摄心正除。未生恶不善法为不生故。生欲勤进。所谓欲者。善思惟也。勤精进者。不舍善思惟也。摄心正除者。观善思惟也。何以故。善思惟时。恶不善法不令入心。云何恶不善法。恶不善法。非戒聚伴。非禅定伴。非智慧伴。云何非戒聚伴。若破重戒及毁余戒。是名非戒聚伴。云何非定聚伴。若毁威仪及余乱心法。是非定聚伴。云何非智慧伴。若摄取诸见及余见障碍。是非智慧伴。是名恶不善法。善思惟时如是等恶法不令入心。是名初正勤已生恶不善法为断故生欲勤进摄心正除。如上所说。恶不善法心不聚集。无有方所无有住处。是不善法心行断故。已觉了故。从缘生故。净故生欲碍故生恚。无明缘故生于愚痴。是善思惟观不净时灭于欲心。修集慈心灭于嗔恚。观十二因缘灭于愚痴。如是烦恼永寂灭者。即是除断一切假名。亦复不见有可断者。是名第二正勤未生善法为生故生欲勤进摄心正除。是诸善法说有无量。何以故。无量善法菩萨修集。于是法中欲为根本。勤进修集摄心者出过善法。正除者在在处处常在善法。是名第三正勤已生善法安住修集为增广不失故摄心正住。是诸善根悉已回向阿耨多罗三藐三菩提。何以故。善根回向无上菩提者则不可尽。所以者何。如是善根不依三界。若依三界是则损耗。是故回向一切种智诸善根等不可得尽。是名第四正勤。舍利弗。是名菩萨修四正勤不可穷尽

复次舍利弗。菩萨摩诃萨四如意分亦不可尽。何等为四。欲进心思惟。如是四法。以慈悲喜舍而为根本。是四无量心常亲近。常亲近故心得调柔。心调柔故得入初禅第二禅第三禅第四禅。入诸禅故身得轻软。成就如是身轻心柔。入如意分。善入如意分已即生神通。若欲若进若心若思惟。欲者专向彼法。精进者成就彼法。心者观察彼法。思惟者彼法方便。是如意分已具足故能得神通。欲者庄严。进者成就。心者正住。思惟者能善分别。是菩萨得如意分随其所解。如其所作心得自在。随意所往善作诸业。毕竟成就一切本行。如风行空无所挂碍。舍利弗。是名菩萨四如意分不可穷尽

复次舍利弗。菩萨摩诃萨五根亦不可尽。何等为五。信根进根念根定根慧根。云何信根。信于四法。何等四。于生死中行世正见信于业报。乃至失命终不作恶。信菩萨行不随诸见。专求菩提不求余乘。信解诸法同空无相无愿之法。同第一义同于了义。甚深因缘无我众生无有分别。信一切佛十力四无所畏十八不共法。如是信已消除疑网修集佛法。是名信根。何等进根。若法信根所摄。是法即为进根所修。是名进根。云何念根。若法进根所修。是法终不忘失。是名念根。云何定根。若法念根所摄。是法不忘不失一心不乱。是名定根。云何慧根。若法定根所摄。是慧所观是慧体性。内自照了不从他知自住正行。是名慧根。是五根者。共相续生具一切法得授记别。譬如外道五通神仙不能定知胎中差别。男女相现然后乃知。多有菩萨无信等根。诸佛世尊不为授记。若成就者便与授记。舍利弗。是名菩萨五根无尽

复次舍利弗。菩萨五力亦不可尽。何等为五。信力进力念力定力慧力。云何信力。是信一向不可沮坏。乃至天魔变为佛身。示现出入禅定解脱。不能倾动菩萨信力。是名信力。云何进力。菩萨精进于诸善法得坚固力。如所得力。修诸禅定诸天及人所不能坏。如本所愿皆悉成就。是名进力。云何念力。菩萨住诸善法不为烦恼之所破坏。何以故。是菩萨正念之力能摧伏故。如是念力无能坏者。是名念力。云何定力。远离愦闹常乐独行。是菩萨虽有所说。言语音声不碍初禅。善住觉观不碍二禅。心生欢喜不碍三禅。是菩萨虽乐化众生。不舍佛法而亦不碍于第四禅。是菩萨行四禅时。诸妨定法无能为也。菩萨尔时不舍于定亦不随定。而能自在处处往生。是名定力。云何慧力。是菩萨知世间法出世间法。无有一法能坏是智。菩萨在在所生之处。一切伎艺不从师受悉自然知。世间外道苦行难行。是菩萨为教化故。亦悉现受同其所行。是出世法能过世者。慧力成就故。诸天及人所不能伏。是名慧力。舍利弗。是名菩萨五力无尽

复次舍利弗。菩萨摩诃萨七觉分亦不可尽。何等为七。念觉分择法觉分进觉分喜觉分除觉分定觉分舍觉分。云何念觉分。若念觉分能观于法。能分别法撰集思智。亦能观察诸法自相。何等为自相。观一切法自性皆空。念如是等令其觉了。是名念觉分。云何择法觉分。若能分别晓了八万四千法聚。如所了法。了义是了义。不了义是不了义。世谛是世谛。第一义谛是第一义谛。假名是假名。正了无疑是正了无疑。如是等法分别选择。是名择法觉分。云何进觉分。若念法择法喜法除法定法舍法。以智摄取精进勇猛。欲不退转勤修力励。不舍本意行于正道。是名进觉分。云何喜觉分。所修法喜。于无量法心生悦豫无有懈怠。清净乐法是喜踊跃。能除身心舍诸烦恼。是名喜觉分。云何除觉分。若除身心及诸烦恼。离于覆盖入定境界令心正住。是名除觉分。云何定觉分。如所入定悉能觉了。非不入定是觉了法。又了诸见烦恼结缚。无始无终其心平等。一切诸法无别异相。能觉如是诸法等者。是名定觉分。云何舍觉分。若法忧喜其心不没。亦复不为世法所牵。无高无下正住不动。无有诸漏无喜无著。无诸障碍正直随顺真谛正道。是名舍觉分。舍利弗。是名菩萨七觉分亦不可尽

复次舍利弗。菩萨摩诃萨八圣道分亦不可尽。何等为八。正见正思惟正语正业正命正精进正念正定。云何正见。若见出世不起我见众生寿命养育士夫断见常见有见无见。亦复不起善与不善无记等见。乃至不起生死涅槃二相之见。是名正见。云何正思惟。若思能起贪欲嗔痴诸烦恼等。是不名正。是正思惟不思不起如是等事。唯思戒定智慧解脱解脱知见。是正思惟能思如是住戒等聚。如是思惟名正思惟。云何正语。凡所演说不令其身而有燋恼。亦不损他。成就如是善妙好语趣于正道。是名正语。云何正业。若业黑有黑报。白有白报。黑白有黑白报。终不敢作。若业非黑非白有非黑非白报。若业能尽业是业必作。是菩萨所依止业。勤修如是诸正业等。是名正业。云何正命。若不舍圣。种头陀威仪。不动不转无诸奸谄。不为世间利养所牵。易养易满常自坚持威仪礼节。见他得利心不生热。于己利养常知止足。如是正行圣人所赞。是名正命。云何正进。若进向邪非圣所赞。所谓贪淫嗔恚愚痴烦恼。是不正精进终不为之。若法能入正谛圣道寂灭涅槃攀缘正路。是正精进修集勤行。是名正进。云何正念。若念不失不动于法。正直不曲。见生死过进向涅槃。系心不忘不失正道。是名正念。云何正定。若定不乱于一切法。是菩萨如是住时成正决定。是名正定。菩萨住是三昧为一切众生得解脱故。成正决定。是名正定。是八圣道悉是过去未来现在诸佛之道。是菩萨觉了已演说开示。分别显现成就佛道。舍利弗。是名菩萨八圣道分亦不可尽

复次舍利弗。菩萨摩诃萨修行定慧亦不可尽。云何为定。若心寂静正寂静寂灭不然。心常不乱守护诸根。不动不转无有卒暴。安详静默坚持不失。善调柔软独处闲静。其身远离心不回转。思乐空寂阿练若处。无有恶求亦无所求非有多求。正命正行威仪坚固。知时随时常知止足。易养易满堪忍力故。心无高下能忍恶骂。发心专向善法思惟。乐思惟处及诸禅支。发起慈心入于悲心。安住喜心善修舍心。正入初禅二禅三禅四禅。空处识处无所有处非有想非无想处。善能思惟九次第定。是名为定。举要言之。菩萨助定无量无边勤行修集。是名菩萨定不可尽。云何为慧。是慧修道入于诸法无我无人众生寿命。如是智慧分别诸阴如幻如化。诸界平等入如空聚。分别诸谛皆悉明了。随顺观知十二因缘。分别诸见因果果证。所谓分别者。于一切法能得正见。如实而见真见空见无相愿见。又分别者无分别故分别。所谓见者。亦无所见无所别知。如是见者为真实见。见真实者即得方便。是菩萨如是慧见不随无为。修行诸善心无所住。是名为慧。舍利弗。是名菩萨修行定慧而不可尽

复次舍利弗。菩萨摩诃萨总持辩才亦不可尽。云何总持。所修善根正念积集。所有八万四千法聚。能正受持不忘不失。是名总持。又复总持。若一切佛所说妙法。一切菩萨缘觉声闻凡夫众生音声善语。悉能受持是名总持。设劫灾起舍命余生。菩萨尔时正念总持不忘不失。如观掌中阿摩勒果。菩萨观见一切诸法亦复如是。是名总持。云何辩才。菩萨所说无有滞碍。所说无住所说无断所说通利所说喜豫所说捷疾。如是所说皆是先业清净果报。诸佛护念诸天摄受。说无错谬功不唐捐进向涅槃。菩萨成就如是辩才。所有色像及众生类。辩才应机不豫思惟不豫分别。善能赞说契经偈颂。若至大众刹利众婆罗门众长者众沙门众四天王众三十三天众魔众梵众。在在处处自然能知众生根量。以无碍辩而为说法。是菩萨如本喜乐讲宣法要终身不断。是名辩才。舍利弗。是名菩萨总持辩才亦不可尽

复次舍利弗。菩萨摩诃萨撰集四法亦不可尽。何等四。是菩萨知一切行无常一切行苦一切法无我一切法寂灭涅槃。云何无常。义无所有是无常义。无所破坏是无常义。是无常义者即无我义。若法无我无能坏者。性寂灭故。是名无常义。云何苦义。无所求故是苦义。爱染尽故是苦义。无所愿故是苦义。空无有故是苦义。是名苦义。云何无我义。毕竟无我是无我义。如无我义即是空义。无所有义。虚诳不实义。是名无我义。云何寂灭涅槃义。是寂灭义非念念灭。如非念念灭即是寂灭。菩萨得是无尽智慧。知一切法相同于寂灭。寂灭者即是涅槃。是名寂灭涅槃义。舍利弗。是名菩萨撰集四法而不可尽

复次舍利弗。菩萨摩诃萨一道亦不可尽。云何一道。菩萨所得真实智慧不从他闻。又一道者菩萨独一无有伴侣。已于阿耨多罗三藐三菩提能大庄严。以自力势精进摄取。毕竟自修不假他作。自以因缘勇猛之力。建立如是坚固庄严。如诸众生所作善业。我亦如是悉当作之。及诸圣人从初发心所作诸行我亦当作。施非我伴我是施伴。戒忍精进禅定智慧非是我伴我是彼伴。诸波罗蜜不能使我。而我能使诸波罗蜜。一切善根皆亦如是。如是等法虽非我伴我要当行。不恃于他勇猛自力独行无伴。坐于道场金刚座处坏诸魔众。以一念慧成阿耨多罗三藐三菩提。我当如是觉了分别。舍利弗。是名菩萨一道无尽

复次舍利弗。菩萨摩诃萨所修方便亦不可尽。云何方便。见一切法是方便。发起诸法是方便。为菩萨使是方便。毕竟分别是方便。无有齐限是方便。志意常求出世之法是方便。于布施时即能具足诸波罗蜜是方便。持禁戒时在在处处自在往生是方便。行忍辱时庄严自身及菩提道是方便。行精进时心无所住是方便。修禅定时无有退失是方便。修行慧时不证无为是方便。修慈心时愍无力势是方便。修悲心时不厌生死是方便。修喜心时无乐处乐是方便。修舍心时发心修集一切善根是方便。能修天眼为欲成就诸佛眼故是方便。修集天耳为欲成就诸佛耳故是方便。修他心智为得佛智知诸众生根量深浅故是方便。修宿命智为得佛智。知于三世无挂碍故是方便。修集神通为得诸佛神通力故是方便。随众生心是方便。既自晓了复了众生是方便。能自度已示现未度。而方勤修求于度世是方便。已离烦恼示有烦恼是方便。已舍重担示有重担是方便。能知根量随量说法是方便。善能诱进钝根众生是方便。知时非时是方便。知可行道堕邪众生安置正道是方便。能令量作无量无量作量是方便。令损坏者还复如本是方便。示现胜地是方便。示说涅槃有五欲乐是方便。已得解脱示有系缚是方便。处在生死不堕生死是方便。于诸威仪无所专当亦不退失是方便。唯观众生不观持戒及以毁戒是方便。摄诸见缘不生诤竞是方便。悉是音声假名无实是方便。常行三界是方便。得解脱相行是方便。亲近凡夫如亲近圣人是方便。不证涅槃常处生死是方便。于魔行处显大光明无有烦恼是方便。一切是一切非是方便。舍利弗。是名菩萨修行方便亦不可尽。舍利弗。是名菩萨摩诃萨八十无尽。是八十无尽悉能含受一切佛法。无尽意菩萨摩诃萨说是法门品时。六十七百千众生未发心者即发阿耨多罗三藐三菩提心。五百二千菩萨摩诃萨得无生法忍

尔时大众以种种华香种种华鬘种种华盖。供养如来及无尽意并是经典。于上空中有无量天乐。自然出声作如是言。诸佛世尊于无量劫所集阿耨多罗三藐三菩提。无尽意菩萨今于是大集经中已说其义。若有闻是无尽法门。信解受持读诵解说。当知是人则为具足是无尽法

尔时世尊以覆肩衣与无尽意赞言。善哉善哉。大士快说是义。非但我许。十方诸佛亦复如是。尔时无尽意菩萨摩诃萨两手捧衣置自顶上。而白佛言。世尊。诸天世人当视是衣过于塔想。以是如来所受用故。尔时多有种种宝衣。种种宝盖。种种宝幡。种种宝树。种种宝鬘。从十方世界自然而来。覆无尽意而为供养。是时宝衣幡盖树鬘自然演出如是之言。善哉善哉善男子。善能说是无尽法门。如汝所说我等所许。尔时舍利弗白佛言。世尊。如是宝衣供养之具。从何处来乃出是言。佛告舍利弗。是无尽意菩萨初发阿耨多罗三藐三菩提心时。所化众生皆于十方已成阿耨多罗三藐三菩提。是彼诸佛正遍知等。知恩报恩故。遣是来称扬赞叹。是无尽意真实功德。并复供养所说经典。尔时大众于无尽意菩萨摩诃萨。倍生恭敬尊重赞叹。作如是言。我等今者快得大利。得见无尽意菩萨。恭敬供养尊重赞叹。并得闻是无尽法门。若有直得闻无尽意菩萨名字亦得善利。何况眼见兼闻是典

尔时世尊于大众中闻是语已。告舍利弗。若有善男子善女人学菩萨道。于一劫中供养诸佛。学戒威仪。以堪忍力尽诸众生生死苦际。精勤修集如救头然。于诸禅定一心成就智慧方便。若离此经。我说是人未能具足六波罗蜜。舍利弗。若有善男子善女人。闻是经典信解受持读诵解义如说修行。我说是人已为具足诸波罗蜜。速得成就阿耨多罗三藐三菩提。何以故。舍利弗。若有菩萨受持此经为他演说。即为具足檀那波罗蜜。何以故。于诸施中法施为胜。初不忘失菩萨之心。若持此经即是持戒。故能具足尸罗波罗蜜。何以故。一切菩萨所学禁戒是经所摄。若于此经能堪忍乐。一切众生所不能坏。能于是中进修忍辱。即为具足羼提波罗蜜。若是经典勤行转说。身口意业精勤修集。即为具足毗梨耶波罗蜜。若于是经其心寂灭无有散乱。一心定意分别法相。即为具足禅那波罗蜜。若于是经自得现智。不从他闻得正行智。即为具足般若波罗蜜。舍利弗。若有菩萨勤学是经。若欲具足诸波罗蜜则为不难。舍利弗。若有菩萨学习此经。受持读诵如说修行书写经卷。当知是人一切佛法已为在手。四大之性可变令异。是菩萨心于阿耨多罗三藐三菩提不可复转。舍利弗。此经典者即是菩萨不退转印。是故菩萨当求是印。若有善男子善女人。亲近是印者则为亲近一切佛法

尔时四天王及其眷属即从座起。合掌向佛白佛言。世尊。我等四王是佛弟子已得道迹。若有善男子善女人受持是经。我等堪任为作卫护供给侍使。当于是人起如来想。何以故。是经典中出诸乘故

尔时释提桓因即从座起。合掌向佛白佛言。世尊。我数从佛闻无量无边百千经典。未曾得闻如是经典分别深义。世尊。在在处处国土郡县城邑村落有说此经者。我躬当与三十三天故往听受。并护法师益其气力。勇猛精进正念辩才。令是法师于诸大众得无所畏广能宣说如是经典。佛言。善哉善哉。憍尸迦。汝欲拥护是说法者。令得勇进正念辩才。憍尸迦。若欲拥护是说法人。即为拥护诸佛正法。护正法者则为拥护一切众生

尔时梵自在天王。合掌长跪前白佛言。世尊。若是经典流布之处。我躬当与其余梵众并诸眷属。舍禅喜乐往诣彼所听受咨请。我往彼时当现四瑞令其觉知。云何为四。一者令见微妙光明。二者得闻殊异之香。三者令说法者得无碍辩及正忆念。所说吉祥不失章句。四者令其大众发善欲心。喜乐听法无有厌足。以是四瑞。应知梵天王与其眷属躬来听法

尔时第六魔王波旬。合掌白佛言。世尊。如是经典。令我势力一切羸劣。何以故。若有菩萨闻是经典受持读诵为他广说。当知其人即为受记。世尊。如是菩萨所往之处至诸佛界。当知如佛世尊。我今所有憍慢嫉妒贡高之心。以无尽意威德力故皆已摧伏。我今当护如是经典及说法者。是经所在流布之处。乃至不起一念之心而作留难。何况身往故作因缘

尔时佛告尊者阿难。汝从今日当为正法久住世故。受是经典持读诵说。尔时阿难正服而起。偏露右肩右膝着地。前白佛言。世尊。我今敬奉佛教受持是经。但恨不能广宣流布如诸菩萨。佛告阿难。汝且自安。今此会中有诸菩萨摩诃萨等。自能护持令此经典广宣流布。尔时会中有六十亿诸菩萨摩诃萨应护法者。即从座起合掌白佛言。世尊。我等要当宣传此经。令至十方。娑婆世界弥勒大士。自当于中护持是典及说法者。世尊。若佛灭后后五百岁。若有菩萨闻是经典受持读诵。当知皆是弥勒神力之所建立。尔时佛赞护法菩萨摩诃萨众。善哉善哉。诸善男子。汝等不但今于我前护持正法。亦曾护持过去恒沙诸佛正法

尔时无尽意菩萨摩诃萨白佛言。世尊。我今自以少智慧分说是经典。文字句义必不具足。今于佛前及无尽法所可成就诸菩萨等忏悔过失。佛告无尽意菩萨。善男子。若有菩萨得四无碍智。凡所讲说无有错谬。如是菩萨得真空义分别法门。乃能宣说如是经典。善男子。汝今已到第一之处。成就四辩自在无碍。是大乘经不从他闻而能分别。善男子。汝今成就如是住位。身口意业无有错谬。何以故。菩萨所修三业成就。常以智慧为根本故。善男子。已有无量百千万亿诸佛世尊。皆共称扬听汝所说。无尽意。汝本已于我所及诸佛所。毕竟忏悔无有漏失。尔时尊者阿难白佛言。世尊。此经何名。云何奉持。佛告阿难。此经名无尽意所说不可尽义章句之门。又名大集。当如是奉持。阿难。汝应信受如是经典。何以故。汝受是已所得持念倍前千数。若为他说则立佛事。佛说是已无尽意菩萨摩诃萨。尊者阿难舍利弗。诸天龙神乾闼婆阿修罗等。一切大众莫不欢喜。作礼而去

大方等大集经卷第三十

按此经。宋乡藏中皆六十卷凡十七品。丹藏中三十卷十一品。又经初首宋乡则有璎珞品名。丹藏所无。其虚空藏品宋乡在不可说后。丹藏在无言品前。又于宝髻品后。宋乡有无尽意品四卷。丹藏即无。而有日密分三卷。如是不同者何耶。今捡开元录。此经凡有六本。录云。按梁沙门僧祐大集记云。有十二段说共成一经。第一璎珞品。二陀罗尼自在王品。三宝女品。四不眴品。五海慧品。六无言品。七不可说品。八虚空藏品。九宝幢品。十虚空目品。十一宝髻品。十二无尽意品。按云。此则第一本也。今捡品次。是宋乡本六十卷中前分三十卷矣。又云。今捡经本与祐记不同。第一陀罗尼自在王菩萨品。二宝女品。三不眴品。四海慧品。五虚空藏品。六无言品。七不可说品。八宝幢分。九虚空目分。十宝髻品。十一日密分。按云。此则第二本也。今捡品次。则今丹藏后三十卷者是矣。编又云。隋朝僧就合大集经。乃以明度五十校计经。题为十方菩萨品编月藏后。及无意尽成五十八卷者非也。既无凭准故不依彼。按云。此则第四本也。又云。其合大集经亦有六十卷成者。三十一二两卷重有宝髻品。足成六十卷。其宝髻品在日密前二十六七卷是。此复重编未详何意。又日密日藏梵本不殊。重重编载误之甚矣。按云。此则第五本也。今捡品次。则今宋乡藏经六十卷者是矣。但不重载宝髻品。斯为小异耳。则似于前第四本五十八卷经。中分彼日藏分中卷为十二卷。足成六十耳。其第三第六两本。今以诸藏所无故不烦叙。经本如是不同。藏中致斯有异耳。谨按开元录前后文相。令此合经六十卷者。有六失故不可依行。录云。亦有经本分为璎珞品者不然。此是一段不合分二。按云。此经分之一失也。又云。僧祐记中无日密分。有无尽意品者不然。今以无尽意经。虽大集别分。非无谶译。又非次第不合入中。按云。此经入中又为无谶译二失也。又云。其虚空藏品。祐在不可说后。未详所以。按云。此经在彼三失也。又云。日密日藏梵本不殊。重重编载误之甚矣。按云。此经重载四失也。又云。明度五十校计经。题为十方菩萨品。编月藏后者非也。既无凭准故不依彼。按云。此经依之五失也。又明度经安世高译。而云那连提耶舍译。按云。此亦误人六失也。既有六失。理须正之。正之如何。略则如开元录及丹藏经为三十卷乃正矣。合则如开元录中第六本为八十卷方备矣。今宋乡二藏于目录则取开元录。而经本则仍僧就本者。直以无心于相校耳大方等大集经卷第三十一

        北凉天竺三藏昙无谶译

    日密分中护法品第一

尔时世尊故在欲色二界中间大宝坊中。与大菩萨其数无量。为诸大众说虚空目出息入息甘露门已默然而住。一切大众亦复如是。各作是念。如来今日深知我心欲法无厌。必当降注甘露法雨。作是念已。合掌恭敬乐瞻如来。犹如笃病乐见良医。处闇之者乐睹光明。如没水者乐至彼岸。如受苦者乐得归依。一切大众亦复如是。是时众中有一菩萨。名莲华光功德大梵。已于无量无边佛所。种诸功德善根增长。于阿耨多罗三藐三菩提心不退转。成就具足法缘之慈。从坐而起合掌恭敬。长跪白佛言。世尊。一切众生心所缘处。无有边际。骏速无形其性本净。于诸有中无能障碍。欲得通达知真实故。精勤修集四无量心。因修集故获得尽智。世尊。若使三界性本净者。何故修集如是尽智。惟愿如来为诸菩萨敷扬散说。令退转者得不退故。摧灭无量烦恼界故。断破无边诸苦聚故。惟愿如来。垂心怜愍说未曾闻。众生闻是未曾闻已。度生死海摧折爱树。何以故。一切烦恼爱为根本。惟愿垂哀分别演说爱之过咎。如来能净众生六根。重愿演说清净法聚。佛言。善哉善哉。善男子。若有能行六波罗蜜。即能自知心所行处。是人终不念声闻乘。虽复修行无量诸行未得其边。亦不怖畏退堕声闻辟支佛地。若诸菩萨不能修集四无量者。如是菩萨于菩提道则为有退。是名不得清净六根。是名于法有贪有悭。如是名为行于他行不行自行。是名不能成就七财不能度脱一切众生于生死海。是故我说如是行者。即是声闻辟支佛行。我初演说四圣谛行。后复续说诸菩萨行。尔时一切大众咸作是念。如来将欲说声闻乘。不说大乘耶。将非如来不乐如是菩萨众耶。如来不欲断三宝种性耶。何故不说大乘妙法。为诸天人得信心故。未发菩提心者为发心故。已发心者得增长故。为诸众生得信心故。如来若说大乘法者。无量众生当得发起菩提之心。因得修行不共之法。成就具足法陀罗尼。善男子。声闻乘者即是大乘。大乘者即声闻乘。如是二乘无有差别。尔时众中诸住十住诸菩萨等作如是言。世尊。我等已得无生法忍。我已能行如来十八不共法行。我已解了诸声闻乘及以大乘。如是众中无量众生。不能得解小乘大乘。诸善男子。汝等当修不退禅定。时诸菩萨即便修入。入已或有身放光明犹一灯炬。如释梵身光。如日月光。如三日光。如四日光。如八日光。如十日光。如亿日光。如是遍照娑婆世界。是光能令无量众生身心寂静。在三恶者离诸苦恼。邪见之人远离恶见。永离贪欲嗔恚痴怖饥渴等患。尔时此佛世界众生。皆共供养佛法僧宝增长善法。尔时此佛世界。并及十方恒河沙等无量世界。若空不空及净不净光。悉遍照十方佛界。所有菩萨能行圣行菩提道者。于一念顷悉来聚集大宝坊中。头面礼佛却坐一面。尔时世尊告声闻众。汝等比丘颇见如是善神足不。如是神足能坏一切恶魔境界及诸有处。能护法界。能行一切诸佛境界。分别声闻辟支佛界。出胜一切所有神通。善男子。一切菩萨所以示现大神通者。为增众生诸善根故。为不断绝三宝性故。为未信者得信心故。为已信者得增长故。为令众生受五乐故。为欲长养大乘法故。为令身得常乐我净故。以如是等诸因缘故。示诸众生如是神通。善男子。随如是等菩萨行处。是中佛法即得增长。若现在未来久住不灭。所有众生修立塔庙供养众僧。求无尽身无苦恼身。所作供养。皆作生身法身。生身供养者即是塔像。法身供养者书写读诵十二部经。如是胜以七宝香华伎乐幡盖璎珞供养。善男子。我于尔时心亦受之。由如是施如是众生具足当得三乘果报心不退转。若诸众生具造屋室及经行处。我即受用。若树林华园讲堂精舍。及供养我所有弟子。饮食卧具病药房舍。我亦受用。若诸法师高座说法。我于是时亦至心听。若施法师衣食卧具病药房舍园林服乘田宅奴婢。我亦受之。是名法供养。如是之人能净身心庄严身心。亦能庄严阿耨多罗三藐三菩提。能得无上微妙快乐。能一切物施一切人施一切时施。能一切果受一切人受一切时受。是名成就惠施之福。是人终不到三恶道得不堕法。如意所求不转三乘。是人常得具足二种。所谓财法。所求之物随意即得。常为十方诸佛所念。能坏一切魔之境界。若有信者以其所有奉施法师。若有破戒受如是物。乃至一叶一华一果。如是痴人。以是因缘得大不善报。现在即得四大恶果。一者恶名远闻。二者所亲师友悉皆远离。三者得大重病苦恶而死。所谓死时不下饮食睹见恶色。以是因缘口不能语卧失粪秽。四者所有六物及余财货不至僧中。或为火烧恶贼所劫。后世复受四种恶报。所谓地狱饿鬼畜生。若得人身身无手足。若受饿鬼。无量岁中不见水浆不闻其名。受畜生身常食泥土。若得为人处在空土无三宝处五滓之世。盲无眼目常遇重病食诸粪秽。舍是身已还堕地狱。何以故。以受法师所得物故。是恶比丘能坏能灭能断三宝。是故获得如是恶果。尔时众中有一大德比丘名伽耶迦叶。白佛言。世尊。如是人者可名人不。我今思惟非是人也。何以故。是人深为利养心故受持禁戒。故名非人。佛言。善哉善哉。迦叶。宁受地狱等身。终不受取如是等物。善男子。人身难得已得。佛法难遇已遇。禁戒难受已受。而不趣向圣行梵行。是名丧失大利益事。如是恶人。贪食心故受持禁戒非为法心。如是痴人以多闻力。及以国王大臣力故。受如是物。即便当得大恶业果。尔时频婆娑罗王白佛言。世尊。出家之人受如是物得如是果。在家人受其罪云何。佛言大王。汝今不应问如是事。王言世尊。我修圣行终不受取如是等物。为未来世诸恶王等问如是事耳。佛言大王。我若宣说未来恶王所得果业。有不信者得大罪报。是故我今置之不说。王言世尊。惟愿如来为未来世刹利婆罗门毗舍首陀有信敬者。奉持佛法守护法师及财物者。具分别说。佛言。善哉善哉。大王。若未来世诸恶王等。侵夺法师如是等物。当知是王现世获得二十种恶。一者天不卫护。二者恶名远闻。三者亲友远离。四者怨敌增长。五者财物损耗。六者心多散乱。七者身不具足。八者不得睡眠。九者常患饥馑。十者所服饮食变成恶毒。十一者民不爱敬。十二者邻国数侵。十三者所有眷属不受其教。十四者秘密之事谋臣显露。十五者所有财物水火侵夺。十六者常有重病。十七者汤药不行。十八者医药不疗。十九者浆水不下。二十者常念不净。是名二十。舍是身已寻复当生阿鼻地狱一劫受苦。过是劫已得饿鬼身处大空野。不闻浆水饮食之名。诸根残缺身不具足。无量岁中受大苦恼。受是果已生大海中受大兽身。无量由旬如大肉团。常为众生之所唼食受大苦恼。若得人身生无佛处五滓之世。耳目不具。大王。未来恶王得如是等诸大恶报。王言世尊。我今宁受地狱之身。终不受是恶王身也。佛言大王。今以是法法师财物付嘱汝等有信诸王。何以故。夫法师者。即是如来法身之藏。王言世尊。若诸刹利婆罗门毗舍首陀有能护持如是法财。其人当得何等功德。佛言大王。如是人者胜于一切声闻缘觉。大王。譬如有人能断一切十方众生所有寿命夺其眼目截其手足。大王。如是人者所得罪报为多少耶。频婆娑罗王默然不答。佛言大王。何故默然。王言世尊。是人所得恶业果报。不可称量不可计数。世尊。若于一人造此恶业罪尚难计。况一切人。大王。若佛在世及灭度后。若有恶王刹利婆罗门毗舍首陀。侵夺法师如是等物。所得罪报分为百分。上所得罪不及其一。频婆娑罗王言。世尊。如法治国是王难得。若不放逸则能护法。若放逸者则不能护。世尊。能护法者得何功德。大王。譬如有人能与如上众生寿命眼目手足。是人得福宁为多不。世尊。能与一人命目手足。其福尚多。况尔所人。大王。若有护法所得功德分为百分。先所得福不及其一。王言世尊。若有受取一法师物。是得罪不。若有拥护一法师者。复得福不。大王。若有受取一法师物至五法师。护一法师及五法师。所得罪福正等无别。大王。若一庙寺若一村落。若一树林住五法师。若鸣揵捶集四方僧。客僧集已次第赋给房舍饮食卧具医药。无吝惜心。初夜后夜读诵讲论。厌患生死专乐涅槃。不自赞身不讼彼短。少欲知足常乐赞叹。少欲知足勤心精进。志乐寂静修于念定。怜愍众生。大王。是名众僧如法而住。护戒精进持佛密藏。读诵书写分别教诏。是名众僧怜愍众生利益众生。能持如来十二部经。亦能奉持寂静禁戒。具足惭愧贤圣功德。大王。是名众僧大功德海。为天人师能大利益无量众生。能断一切众生苦恼。能施一切众生解脱。是五比丘犹名众僧。何况无量。大王。若无量僧悉破禁戒。但令五人清净如法。若有施者得福无量。不可称量不可计数。何以故。以有护持佛法者故。愍愍一切诸众生故。其心平等无二相故。王言世尊。破戒比丘可得处众受信施不。大王。如王国内有一罪人未及摈驱。王若给施刹利婆罗门毗舍首陀。是人颇得受乐不耶。不也世尊。大王。破戒比丘亦复如是。虽在众中受取信施不得安乐。何以故。破禁戒故。不如法故。大王。如是人者一切十方无量诸佛所不护念。虽名比丘不在僧数。何以故。入魔界故。持禁戒者即佛弟子。毁禁戒者即魔弟子。又持戒者即出世道。破禁戒者即入世道。我都不听毁戒之人受人信施如葶苈子。何以故。是人远离如来法故。王言世尊。言破戒者有何等相。可得知不。大王。有智能知。大王。若有不能恭敬三宝。不生信心无有惭愧。于师和尚耆老长宿同师同学不生恭敬。摧灭圣幢不修梵行。增长悭贪乐在居家。不能清净口四种业。常修食心远离法心。乐说世间无益之事。是名比丘初破戒相。未名具足毁禁戒也。若如是等受畜奴婢象马牛羊驼驴鸡猪乃至八种不净之物。是名具足毁禁戒也。如是名为沙门中滓。沙门中曲。沙门中幻。沙门中贼。沙门中醉。沙门中旃陀罗也。如是比丘不应共住不共和合。不应共作九十九羯磨。是名丧失比丘事业堕在贪处。大王。宁与旃陀罗人而共同止。不与如是恶比丘住。何以故。如是比丘烧灭善根。断三世善慈愍之心。是恶比丘。即是圊厕增生死法。即是人天诸恶种子。何以故。是人欺诳自他人天。如是比丘灭解脱灯能摧法幢。能涸法海破说法者。能诳施主破和合僧。若有恶王若刹利婆罗门毗舍首陀。拥护如是诸恶比丘。是王便当增三恶道。种殖天人诸恶种子。大王。若恶比丘呵骂责数如法住者。敬信诸王应当摈驱。若驱摈者王多得福。若王无信如法比丘不应与彼恶比丘住。如法比丘有智慧者。应先往王所作如是言。大王。今者能持法不。王若答言。大德。我能如法护持佛法。智者尔时便应默然。若彼大王有贪心者语比丘言。大德。是寺庙中多有大众。我当云何为五比丘驱遣多人。智者闻已不应复往。便当舍去至寂静处。王言世尊。若有恶王随顺如是恶比丘语。而是大地云何能载是王。从此过于无量恒河沙劫。终不能得复受人身。无量众生得解脱已。是生犹故。未能得断三恶道业。大王。若未来世有信诸王。若刹利婆罗门毗舍首陀。能护法师造立塔像。供养众僧种种所须。治恶比丘为护法故能舍身命。宁护如法比丘一人。不护无量诸恶比丘。是王舍身生净佛土常值三宝。不久当得阿耨多罗三藐三菩提。大王。我今不听一人受畜八不净物。惟听大众得受畜用。大王。若有人能护持法者。当知是人乃是十方诸佛世尊大檀越也。护持大法。大王。僧物难掌。我今惟听二人掌护。一者罗汉比丘具八解脱。二者须陀洹人。大王。除是二人更无有人掌护僧物

    大方等大集经日密分中四方菩萨集品第二之一

尔时世尊为频婆娑罗王说是法已。东方有国名曰无量。彼中有佛名五功德。常说妙法教化众生。有一菩萨名曰日密。至心听法仰瞻虚空。见有无量无边菩萨从东方来趣向西方即白佛言。世尊。我见东方无量菩萨趣向西方。以何因缘。舍净妙国趣向秽土。善男子。西方过此无量无边恒河沙等诸佛世界。彼有世界名曰娑婆。五滓具足弊恶众生充满其土。释迦如来于中宣说三乘之法。为欲增长佛正法故。为不断绝三宝种故。为破魔界竖法幢故。为法久住不灭尽故。彼佛世界有无量佛无量菩萨。宣说宝髻陀罗尼法。既说法已。释迦如来复说三乘四无碍智四种梵行及四摄法。无量众生闻是法时心无疲厌。乐甘露故。以彼如来本愿力故。四方无量诸佛菩萨悉集其土。佛说法时诸菩萨众悉入禅定。既入定已身放光明。如一灯炬至亿日光。善男子。若欲护法可从定起诣娑婆世界。善男子。彼佛世界所有众生。烦恼坚牢系缚深重。其形丑秽多起憍慢。恶口两舌远离实语。其实愚痴现智慧相。多起悭贪现舍离相。多有谄曲现质直相。心多浊乱现清净相。多有嫉妒现柔软相。乐离别人现和合相。多起邪见现正见相。彼国众人随女人语。以随语故断绝善根增三恶道。善男子。汝今颇能为我作使至彼国不。我欲与欲。令彼如来善说法要。所言欲者。谓真陀罗尼。是陀罗尼成就具足无量功德。能断欲贪。色无色贪憍慢我慢一切取贪。一切五盖。一切我见断见。戒取见取见常见。众生见。士夫见。作者见。受者见。人见天见。色见声见香见味见触见。四大见。出见生见。灭见住见。是名随如真忍。是陀罗尼能真实知色乃至识眼乃至意阴入界诸入。解脱法界无上妙乐。善男子。彼界众生如生聋生盲生哑贪欲狂醉。是故与欲。随如真实陀罗尼法一切法藏不可思议诸法之门。能坏一切诸魔伴党及魔境界。善男子。是陀罗尼亦能调伏一切魔众。能怖一切诸恶毒龙。能使恶鬼生知足想。能化一切阿修罗众。能调一切大金翅鸟怖紧那罗。令诸罗刹刹利婆罗门毗舍首陀生于敬信。能坏一切贪女身者。令多闻者生爱乐心。习禅之人心得寂静。善疗一切诸恶重病。能除一切国土恶相。所谓恶贼恶鸟恶兽恶风恶雨恶寒恶热。善男子。若有人能诵如是陀罗尼者。则能得见无量诸佛。善男子。汝持是咒至彼国土。向彼四众具足宣说。尔时世尊即说是陀罗尼

婆移婆蛇波利婆呤(一)婆醯婆诃波利婆呤(二)卑利痴比卑利痴波利婆呤(三)阿脾阿婆波利婆呤(四)汦只汦阇波利婆呤(五)摩呤摩罗波利婆呤(六)呿岐却伽波利婆呤(七)阿路翅阿路迦波利婆呤(八)哆咩哆(九)摩波利婆呤(十)思呤思罗波利婆呤(十一)伽咩伽摩波利婆呤(十二)阿步[(口*皮)/女]阿步婆波利婆呤(十三)罗摩(十四)罗摩(十五)罗摩(十六)罗咩(十七)罗摩(十八)逻罗(十九)逻罗(二十)逻罗(二十一)摩比挫若那(二十二)复多其醯复多其力摩波利婆呤(二十三)遮[颱-台+利]其力醯遮[颱-台+利]其力摩波利婆呤(二十四)输路多其力醯输路多其力摩波利婆呤(二十五)其浪那其力醯其浪那其力摩波利婆呤(二十六)时贶其力醯时贶其浪摩波利婆呤(二十七)迦蛇其力醯迦蛇其力摩波利婆呤(二十八)摩那其力醯摩那其力摩波利婆呤(二十九)拨陀其力醯拨陀其力摩波利婆呤(三十)脾陀那其力醯脾陀那其力摩波利婆呤(三十一)窒囊其力醯窒囊其力摩波利婆呤(三十二)优波陀其力醯优波陀其力摩波利婆呤(三十三)婆婆其力醯婆婆其力摩波利婆呤(三十四)阇提其力醯阇提其力摩波利婆呤(三十五)阇逻摩那罗其力醯阇逻摩那罗其力摩波利婆呤(三十六)[口*(或-口+(一/口))]呿萨多波其力醯[口*(或-口+(一/口))]呿萨多波其力摩波利婆呤(三十七)阿逻波逻膇阇其力醯阿逻波逻膇阇其力摩波利婆呤(三十八)阿拔多(三十九)比跋多写(四十)阿婆逻牟波摩萨写比伽(四十一)比尼跋多(四十二)阿陀利也赖咩(四十三)散比伽扇提(四十四)莎呵(四十五)

尔时日密菩萨摩诃萨白佛言。世尊。我能向彼宣说是咒。但于彼土生怖畏想。何以故。如来向者为我宣说。彼土众生多诸弊恶。犹如生聋生盲生哑随女人意。世尊。若有随顺女人意者。当知是人永断善根。佛言。善男子。汝今不为现利后利。当为饶益一切众生。但往宣说勿生疑虑。善男子。汝非彼土维摩诘耶。何故生怖。日密菩萨默然不对。善男子。何故默然。日密言。世尊。彼维摩诘即我身也。世尊。我于彼土现白衣像。为诸众生宣说法要。或时示现婆罗门像。或刹利像。或毗舍像。或首陀像。自在天像。或帝释像。或梵天像。或龙王像。阿修罗王像。迦楼罗王像。紧那罗王像。辟支佛像。声闻像。长者像。女人像。童男像。童女像。畜生像。饿鬼像。地狱像。为调众生故。是时众中有诸菩萨其数八万。同一三昧出入共俱。复有无量无边菩萨。其心掉动至心系念。欲得亲近亲见礼拜释迦如来及诸大众。并欲听受微妙大典。如是大众皆共同心欲往彼界。我为是辈欲说大事。何以故。是等大众其心未定。若往彼界或生颠倒近恶知识。尔时彼佛告日密言。善男子。汝今不应生怖畏想。何以故。我今当施汝等菩萨。不共法行。无想行。调伏行。解脱行。分别生死行。不断三宝行。大慈大悲行。一切智解脱行。破坏四魔恶邪论行。尽智无生智行。毕竟入涅槃行。是名莲华陀罗尼。令诸菩萨不乐三界。证无相解脱门。入无行解脱门。善男子。若有信者能至心听是莲华持。是人能薄一切贪欲一切烦恼。舍身七世常得生天识知宿命。虽处欲界不为欲污常乐出家。一切人天乐与供养。善男子。若有人能至心七日及听是持者。终不堕坠三恶道中。善男子。若有人天听是持者。远离欲法修集禅定。若有人能于王刹利婆罗门毗舍首陀耳中。宣说是陀罗尼。闻者寻发出家之心。若有女人能至心听是陀罗尼受持读诵。即转女身得男子身。于阿耨多罗三藐三菩提无有退转。乃至证得大般涅槃。终不更受女人之身。除自发愿。善男子。若有人以是总持咒余药草。持涂鼓贝若打若吹。若有闻者邪见蛊道诸弊恶病无能加之。善男子。是陀罗尼成就如是无量福德。尔时世尊即说是陀罗尼句

思陀摩提(一)比路迦摩提(二)伊梨翅汦利蓰(三)流遮修流遮(四)佛提比佛提(五)摩诃佛提(六)温摩提温摩多波罗提蓰陀泞(七)罗伽婆罗迦陀罗波利提蓰陀泞(八)频豆频豆摩提(九)至吒至吒波罗提蓰陀泞(十)遏翅战陀豆(十一)呵呵至置(十二)呵多尼咩(十三)呵多迦摩比岐(十四)比摩多佛题(十五)呵多蛇其攡(十六)呵多比三摩其攡(十七)呵多三牟陀阇脾(十八)呵多比摩多逻只(十九)呵多希醯(二十)呵多遮知(二十一)呵多达波罗阇(二十二)呵多婆休罗阇(二十三)呵多婆阇摩提(二十四)呵多留伽摩提(二十五)呵多乌伽赖咩(二十六)呵多陀摩密提(二十七)呵多萨婆优波陀那(二十八)若若若(二十九)比阇若若(三十)比婆阇若若(三十一)婆逻末力伽若若(三十二)伊沙安兜逻伽豆[口*企](三十三)莎呵(三十四)

尔时世尊告日密菩萨言。善男子。是莲华持能断四流。汝当至心受持是持向彼世界。何以故。彼佛世界有百亿魔众。能坏众生所有善法。善男子。汝等若诵是陀罗尼。则不为彼恶魔所侵。尔时日密。与无量亿诸菩萨俱。无数人天白佛言。世尊。如来智慧不可思议。我等昔来初未曾闻是陀罗尼。尔时彼佛世界女人八万四千。闻是持已。寻转女身得男子形。时彼佛以瞻婆华鬘。告日密言。善男子。汝持此鬘并陀罗尼。往娑婆世界。供养彼佛释迦牟尼。尔时日密从彼如来默然而受。是时会中八万菩萨俱白佛言。世尊。我等亦欲往彼世界。佛言。善男子。善哉善哉。汝等若往一切当现梵天之像。尔时大众即便化为梵天之身。往娑婆界释迦如来所。到已即于此娑婆界雨瞻婆华。头面礼敬释迦如来。右绕三匝即坐一面。时佛故为频婆娑罗王。宣说法行

尔时南方过一由旬满城沙数诸佛世界。有一世界名袈裟幢。其中众生具足五滓。其土有佛名山王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在为诸众生宣说法要。彼佛世界有一菩萨名香象王。仰瞻虚空。见无量菩萨从南方来趣向北方。见已白佛言。世尊。如是菩萨摩诃萨等何因缘故。从南方来趣于北方。佛言。善男子。北方过一由旬城沙世界。有国名娑婆。释迦如来在中宣说大集妙典分别三乘。为不断绝三宝种故不断法行。破魔界故竖法幢。故一切十方诸佛世尊。悉于彼土宣说敷演宝幢陀罗尼。说已各各还本住处。释迦牟尼。为诸菩萨及声闻众宣说法要。善男子。汝等颇欲诣彼世界听受法不。我今亦欲与彼佛。欲所谓断业陀罗尼随顺空门。断于色贪憍慢慢慢我慢。乃至为得尽智无生智故。尔时世尊即说此陀罗尼句

豆幕提(一)豆幕提(二)奥叉豆幕提(三)波罗婆裟豆幕提(四)萨婆阿迦舍豆摩(五)阿鞞呿伽(六)鞞咩多呿伽(七)阿鞞叉呿伽(八)阿婆慕阿却伽(九)阿那若却伽(十)脾也佛提却伽(十一)婆路遮却伽(十二)式[口*仚]却伽(十三)比堤弥逻却伽(十四)乌数摩却伽(十五)乌罗却伽(十六)阿叉却伽(十七)蛇婆摩那却伽(十八)湿波却伽蛇婆比若那却伽(十九)遮[颱-台+秋]陀兜却伽(二十)蛇婆摩那比若那陀兜却伽(二十一)卑利痴比陀兜却伽(二十二)蛇婆比若那陀兜却伽(二十三)折挫利蜜兜波那却伽(二十四)蛇婆阿脾陀尼迦却伽(二十五)豆呿却伽(二十六)蛇婆末力却伽(二十七)比婆娑那(二十八)阿比叉婆(二十九)阿婆那那(三十)比那那(三十一)婆牟陀那那(三十二)萨婆迦逻那那(三十三)萨婆散哆那比具波那那(三十四)阿冀之那那(三十五)叉婆(三十六)叉婆(三十七)伊利(三十八)蜜利(三十九)伊伊利(四十)伊伊兰弥利(四十一)莎呵(四十二)

尔时世尊。告香象王菩萨言。善男子。是名随空三昧陀罗尼也。永断一切欲贪色贪及无色贪。乃至断除一切烦恼。善男子。汝当一心受持读诵是陀罗尼。往彼世界教化众生。香象王菩萨言。世尊。我已至心受诵是持。今欲往彼然生畏想。何以故。我曾从佛闻彼世界众生弊恶多贪嗔痴。时山王佛。告香象王言。善男子。汝常化作婆罗门像教化众生。或摩醯首罗像或帝释像。或那罗延像或鬼像。天像龙像阿修罗像。转轮王像。婆罗门刹利毗舍首陀像。大臣长者像。声闻像男女等像。教化众生。云何方言于彼世界生怖畏耶。善男子。我当施汝大法行法一切智慧。能知诸行破四魔行。能调一切众生行。能喜一切众生行。不断三宝行。能调一切恶龙行。能坏一切众生恶业行。大慈大悲行。破三恶道行。救众生行。破恶见行。能坏女业行。一切法无尽行。能破一切悭贪行。能得一切三昧神通行。能令众生欢喜行。乃至能得菩提道行。善男子。若有众生闻是等行。当知是人能得破坏恒河沙等恶业因缘。断绝三障。惟除五逆谤方等经毁呰圣人。善男子。若有人能信心听受如是等行。是人随意获得三乘。不离十方诸佛菩萨阿罗汉等。常净三业随众生意。当知是人能一切舍乃至头目。一切诸恶不能加害。是人若行尸波罗蜜。得具忍戒圣所乐戒。圣所念戒。大寂静戒。调伏梵释四天王戒。调伏婆罗门刹利毗舍首陀戒。是人终不自赞己身毁呰他身。心常呵责世中利养。卧安悟安身无病苦。易得饮食。一切众生之所乐见。是人临死则得睹见诸佛菩萨。诸佛赞言。善哉善哉。善男子。善持禁戒精进无懈。当生我国。我能令汝住十住位。既见佛已心生欢喜。以是因缘。舍身则得往生净国。位阶十住乃至得阿耨多罗三藐三菩提。是人若行毗梨耶波罗蜜。成就大力身心无病。健行布施戒波罗蜜。人天龙鬼阿修罗等悉来供养礼拜是人。乃至得阿耨多罗三藐三菩提。是人若行羼提波罗蜜时得法缘忍。不觉不见一切众生。是人若为一切众生之所割剥。终不生于一念恶心。乃至得阿耨多罗三藐三菩提。常为人天之所供养。是人若行禅波罗蜜。获得法缘禅定解脱。十方诸佛无时不念。乃至得阿耨多罗三藐三菩提。常为人天之所供养。是人若行般若波罗蜜时。常为诸佛菩萨所护。乐于寂静调伏心界。了了通达一切法界。心无疑阂。人天不能沮坏其心。乃至得阿耨多罗三藐三菩提。常为人天之所供养。善男子。受是行已。往娑婆世界不应生怖。善男子。若净世界所摈之人悉在彼土。所谓五逆谤方等经毁呰圣人犯四重禁。如是人等多共污辱。娑婆世界释迦如来。本愿因缘于彼现身。善男子。若彼世界所有恶人闻是行已。七年之中修慈悲心。离口四过修集六念善男子。是人复当净自洗浴着鲜洁衣。向于东方至心作礼。诵如是等行陀罗尼。乃至七年所有诸恶皆悉除灭。若有女人能如是行。即转女身得男子身。乃至得阿耨多罗三藐三菩提。尔时世尊即说此陀罗尼

舍罗那脾蛇(一)式叉脾蛇(二)蜜提脾蛇(三)波罗呵那脾蛇(四)律提脾蛇(五)因提利蛇脾蛇(六)婆罗脾蛇(七)蒲澄伽脾蛇(八)三摩提脾蛇(九)陀罗尼脾蛇(十)叉提脾蛇(十一)长那脾蛇(十二)阿留波脾蛇(十三)阿尼阇脾蛇(十四)末力伽脾蛇(十五)阿邲若脾蛇(十六)波罗提散比陀脾蛇(十七)复弥脾蛇(十八)邲陀脾蛇(十九)摩诃咩罗脾蛇(二十)摩诃伽留那脾蛇(二十一)卑利痴比脾蛇(二十二)萨埵脾蛇(二十三)陀摩脾蛇(二十四)多摩脾蛇(二十五)阿路迦脾蛇(二十六)波罗提婆娑脾蛇(二十七)波罗提首六迦脾蛇(二十八)伽伽那脾蛇(二十九)摩留多脾蛇(三十)首若咃脾蛇(三十一)波罗提多脾蛇(三十二)阿尼蜜多脾蛇(三十三)具沙脾蛇(三十四)靳遮那蛇(三十五)阿比婆娑(三十六)阿[少/兔]那(三十七)阿[少/兔]那(三十八)阿婆诃遮遮(三十九)遮遮罗比牟(四十)叉蛇比牟(四十一)阿摩脾蛇比牟(四十二)阿三牟陀遮罗比牟(四十三)车陀比比牟(四十四)阿迦舍比牟(四十五)蒲波舍摩比牟(四十六)阿那婆娑比牟(四十七)阿诃诃比牟(四十八)阿罗波逻比牟(四十九)郁波舍摩娑利罗比牟(五十)莎呵(五十一)

尔时。香象王菩萨白佛言。世尊。我当受持读写大行陀罗尼已往娑婆世界。是时彼土多有无量菩萨摩诃萨。俱从定起共白佛言。世尊。我亦欲往娑婆世界觐见礼拜释迦如来。听受咨启大集经典。佛言。善哉善哉。善男子。欲往随意今正是时。善男子。汝等可化作帝释像。时香象王菩萨摩诃萨及其大众悉皆变身为帝释像。俱共发来诣娑婆界到已即于娑婆世界雨散诸香。所谓牛头栴檀匈坚鞭香。多摩罗拔沉水诸香多伽罗香。以用供养释迦如来。尔时香象王菩萨。与其大众从空而下。头面礼佛右绕三匝。却坐一面

大方等大集经卷第三十一大方等大集经卷第三十二

        北凉天竺三藏昙无谶译

    日密分中四方菩萨集品第二之二

尔时西方过四十恒河沙等诸佛世界。有佛世界名曰坚幢。具足五滓。其土有佛名高贵德王。如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在宣说法要教化众生。彼大众中有一菩萨。名光密功德。仰瞻虚空见诸菩萨从西方来趣于东方。见已白佛言。世尊。何因缘故无量菩萨。从西方来趣于东方。佛言。善男子。东方去此四十恒河沙等世界。彼有世界名曰娑婆。具足五滓。释迦如来以是因缘。为诸众生宣说妙法名曰大集。分别三乘为不断绝三宝性故。破魔界故竖法幢故。一切十方无量诸佛悉集彼国。咸共宣说宝幢陀罗尼。说已各各还本住处。释迦如来为诸菩萨及声闻众。敷扬宣说四无碍智清净梵行。善男子。汝今颇欲诣彼世界见彼佛不。我今亦欲与彼佛欲。所谓断业陀罗尼。随无愿定。成就具足无量功德。能断欲贪色无色贪。憍慢慢慢我慢。乃至尽智无生智。得阿耨多罗三藐三菩提。尔时世尊。即说陀罗尼句

舍那舍[(口*皮)/女](一)摩舍那舍[(口*皮)/女](二)阿[(口*皮)/女]叉舍(三)叉[颱-台+秋]舍[(口*皮)/女](四)遮[颱-台+秋]舍[(口*皮)/女](五)输卢多舍[(口*皮)/女](六)其浪那舍[(口*皮)/女](七)视贶[(口*皮)/女](八)迦蛇舍[(口*皮)/女](九)摩那舍[(口*皮)/女](十)叉[(口*皮)/女]邲陀(十一)遮[颱-台+秋]卑利痴比叉[(口*皮)/女](十二)输卢多阿[(口*皮)/女]叉[(口*皮)/女](十三)其浪那汦只叉[(口*皮)/女](十四)视贶[(口*皮)/女]由叉[(口*皮)/女](十五)迦蛇迦逻摩叉[(口*皮)/女](十六)摩那乌阇叉婆(十七)阿路迦若蛇叉婆(十八)频阇散迦罗摩叉婆(十九)安仇逻却伽叉婆(二十)三摩流波脾蛇叉婆(二十一)舍摩迦阇叉婆(二十二)叉蛇逻婆叉婆(二十三)扇多脾娑逻叉婆(二十四)那奴那(二十五)泥那奴那(二十六)阿婆泥那奴那(二十七)那蛇波那移那奴那(二十八)伊槃都头呿写莎呵(二十九)

尔时佛告光密功德言。善男子。汝持是持至彼世界。先问起居然后说之。时诸菩萨白佛言。世尊。我已受持是陀罗尼。我虽欲往然生畏想。何以故。曾从佛闻。彼土众生恶见成就。多贪恚痴随女人语。能速造作阿鼻狱业。佛言。善男子。汝非彼土诸四天下。二界中间二十一日大金翅鸟。恐怖大海六万四千亿诸大龙王。令得归依佛法僧宝发菩提心耶。世尊。实如圣教。善男子。国土亢旱。汝非象龙马龙金翅鸟龙。于七日中降注大雨。令诸恶龙生恐怖耶。世尊。实如所言。善男子。汝于如是诸恶龙中犹不生畏。何缘而今生怖畏耶。世尊。譬如智人闻于他处多有宝藏。是人即往以抓把之。把已渐见心生欢喜。竟无疲厌。我亦如是。因问如来。得闻如是实语。因闻是语得大势力。能执佛印调伏彼土。佛言。善哉善哉。善男子。我当施汝大神良咒。能净诸业。净于因缘。净于调伏。净于欲。净增长。净平等。净恶风。净行。净无明。净生死。净一切烦恼。净一切三界有为之法。净于彼此。是名曰咒。善男子。如是神咒彼国闻已。上中下结皆悉微薄。色无色有亦复如是。皆得超越恒河沙等劫中诸业。一切五有身口意恶。皆能令净。善男子。若有人能听受是咒。持讽诵读乃至七日至心不忘。当知是人一切恶罪皆悉消灭。除五逆罪谤方等经毁呰圣人犯四重禁。是人所求乃至菩提随意即得。若欲修行檀波罗蜜亦得成就。乃至般若波罗蜜亦复如是。善男子。娑婆世界所有众生。无有因缘得呵责法。何以故。十方世界所可摈遣诸恶众生。皆往生彼娑婆世界。是故能作五逆恶罪。谤方等经毁呰圣人犯四重禁。是人以是业因缘故。多生恶道受无量苦。既受苦已。又不能得十善之法。以是因缘复还生于娑婆世界。是人若本修集信根乃至慧根。终不生于弊恶国土。以修如是恶法因缘故。生于恶国诸根残缺不具人身无有念心。饮食衣被卧具医药。严身资生所须难得。寿命促短不得安眠。智慧善根福德不具。吉事鲜少无有慈心。乐行恶业乐修恶见。乐读邪书乐信恶友乐发恶愿。多诸病苦多恶遽务。常喜增长三恶道法。敬事邪神受性弊恶。调戏嫉妒。具足成就诸不善业。乐谤三宝乐行三恶道。善男子。是恶众生闻是咒已。于生死法而生悔心。离三恶道。修集信根乃至慧根。亦乐修行六波罗蜜清净梵行。增寿益算除恶病苦。智慧炽盛亲厚无损。一切善法无有耗减。具足成就十善之法。长益三宝乐修法行。令诸众生具足如是无量善法。善男子。释迦如来娑婆世界。若有众生受持禁戒。敬信三宝咨启妙法读诵书写得欢喜心。以是因缘。即得过于三恶道业。若有未来重恶之罪。即现在受苦。小遇头痛。若失财物眷属离坏恶名远闻。若被打骂则得除灭。善男子。如是神咒成就具足无量功德。能坏一切所有恶业。能为众生作大利益。能浣众生无量恶心。作大光明。得大念心作大寂静。是人常为十方诸佛菩萨声闻缘觉诸天龙鬼人王之所拥护。是人临死得见十方无量诸佛。闻佛所说诸佛赞言。善哉善哉。善男子。汝来生我净妙国土。我能令汝速住十地。是人寻时生欢喜心。欢喜心故则得深信。以是因缘则得生于净妙国土。生已即阶十住正位。得阿耨多罗三藐三菩提。善男子。汝可受持如是神咒读诵通利。向娑婆世界先往问讯释迦如来。然后宣说。尔时世尊即说此陀罗尼

却伽波利车陀(一)竭婆叉斯(二)竭婆呤(三)邲陀波逻婆伽差(四)叉婆俞岐(五)波逻提呵呤(六)舍摩那思迦提(七)三摩咩伽受蓰(八)阿叉蛇那汦(九)叉婆[(口*皮)/女]只(十)尼陀那阇蓰(十一)三摩那阇蓰(十二)阿陀舍蛇阇蓰(十三)比波逻[(口*皮)/女]阇蓰(十四)斯叉阇蓰(十五)斯若阇婆阇蓰(十六)娑利罗仇呵阇蓰(十七)沙罗仇呵阇蓰(十八)厕婆那拘施(十九)婆陀那拘薄(二十)思婆陀那缇(二十一)比婆波逻罗汦(二十二)优波迦罗摩那缇(二十三)阿那婆哆罗[口*企](二十四)波罗提迦逻咩那(二十五)婆迦咃施(二十六)婆卢遮那[(口*皮)/女]咩迦罗咃陀呤(二十七)迦摩娑施(二十八)阿舍却岐(二十九)那蛇军只(三十)邲陀[(口*皮)/女]泞(三十一)基离那婆泞(三十二)留遮婆泞(三十三)婆咩摩迦呤(三十四)舍利蛇[(口*皮)/女]泞(三十五)摩伽阇蓰(三十六)诃利拘那婆(三十七)那蛇那目[口*企](三十八)婆罗叉拘罗(三十九)那蛇那受呤(四十)因陀罗[(口*皮)/女]娑泞(四十一)乌阿(四十二)阿婆阿(四十三)阿逻[(口*皮)/女]阿(四十四)[(口*皮)/女]逻阿[(口*皮)/女]逻(四十五)婆咩伽豆佉尼提罗涅槃希(四十六)莎呵(四十七)

尔时彼佛说此陀罗尼已。时彼会中复有无量菩萨大众。同声赞言。善哉善哉。我等今日亦欲往彼。彼佛告言。宜知是时。汝若往者。一切变身为那罗延像。皆言。如是世尊。尔时光密菩萨与诸大众。一切化为那罗延像。俱共发来至娑婆界。既至此已。于虚空中雨细金沙。持以供养释迦如来。既供养已。从空而下头面敬礼。右绕三匝却住一面

尔时北方过于八万恒河沙等诸佛世界。彼有世界名普香身。具足五滓。是中有佛号德华密如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在为诸众生宣说法化。彼大众中有一菩萨名虚空密。在会听法。仰瞻虚空见诸菩萨其数无量。从北方来趣于南方。即白佛言。世尊。何因缘故。无量菩萨从北方来趣于南方。佛言善男子。南方过于八万恒河沙等诸佛世界。彼有世界名曰娑婆。具足五滓。有佛世尊名释迦牟尼。今现在世为诸众生宣说妙法。分别三乘竖大法幢广说法聚。十方诸佛悉集彼国。为诸菩萨解说宝幢陀罗尼已。各各还归本所住处。释迦如来故为大众菩萨声闻宣说法要。多有秘密甘露之语。若欲听者可往彼国。释迦如来常发大愿。若有十方诸菩萨等来听我语。即得十八不共之法。又复愿言。我成佛已愿我土地具足上味。彼佛世界所有菩萨有大念心。精进持戒智慧具足。犹如诸佛清净世界。修集禅定成就具足。若入禅定其身放光。或如一灯或如百千无量日月。悉共集会听佛说法。若有十方诸菩萨等来至彼者。皆从定起往至彼国。觐见释迦牟尼如来及其大会。听陀罗尼游戏神通。善男子。汝若欲往娑婆世界。彼土众生寿命短促多诸恶病。智慧善根福德善行。皆悉薄少。于三恶道不生怖畏。贪着财物心不清净。多怀嫉妒无有惭愧乐行十恶。是诸众生或有杂行。舍是身已。即于其国作大恶鬼。乃至作恶迦那富单那。作恶鬼已收取地味。乃至一切果蓏谷米草木等味。若有食者身得恶病无有势力。是诸恶鬼常伺众生初生长大能断其命。是故其土众生短寿。善男子。我本修集菩提道时。亦常发愿。愿我来世常勤精进不休不息。恭敬供养无量诸佛。听受正法问难深义。我当云何护处胎者。令其母子产生安隐。若天龙鬼若罗刹鬼若阿修罗。若迦楼罗若紧那罗。若摩睺罗伽。若拘辩荼。若荔[卄/梨]多。若毗舍遮。若富单那。若迦多富单那。若受多罗。若阿卫末罗。若一行乃至四行。若起死尸鬼。若毒蛊道。若恶药。若触身心。如是等事。不能为是母子作恶。乃至生已。乳哺饮食长养大时。不能作恶令其心浊。乃至梦中亦复如是。常行十善乐施乐戒。于三恶道心生怖畏。世尊。有何咒药能办是事。时无量佛即时施我净陀罗尼。以是持力令我于往无量世中。调伏无量无数众生。劝之令行六波罗蜜。我于无量无数世中。常念何处有是妊身。诸女人等防遮恶鬼乃至恶药。是故我往先教三归。教三归已。一切恶众及诸毒药。无能加害。是儿生已常得善心。智慧具足身体无缺。若游行时。常为无量善神拥护。面貌端正众生乐见。乐修慈悲。布施持戒忍辱精进。处在寂静乐修禅定。近善知识具足智慧坏诸苦恼。一切天鬼乐为供养。厌离生死甘乐涅槃。若发无上菩提之心即得阿耨多罗三藐三菩提。若发辟支佛心即得辟支佛道。若发声闻心即得如实忍。是诸众生永离恶趣常行善道。善男子。我以如是无量方便调伏众生。为阿耨多罗三藐三菩提。善男子。若有众生遇大重病。取师子皮以咒咒之持与病者。如其无皮若肉若骨。若无肉骨若取粪涂及屎处土。若无粪土以咒结索。或作符书以与病者病即除愈。若树无华果。以咒雨水持以溉灌便得华果。若亢旱时求觅龟心。五返咒之置龙泉中。则降大雨。若多雨时。坏败谷麦城邑聚落。求蟒蛇皮七返咒之。置龙泉中霖雨即止。若其国土多有怪异。恶风恶雨恶星日月。应于七日中净自洗浴。服食乳糜。七日之中读诵是咒。诸恶异怪寻即消灭。善男子。若有人闻是陀罗尼。所有烦恼寻即薄少入正定聚。善男子。我以如是无量方便调伏众生。令得修集六波罗蜜。乃至得阿耨多罗三藐三菩提。善男子。是陀罗尼。能为众生作大利益。能断一切诸恶重病。能护一切妊身女人。及处胎者灭一切结知阴入界。摧伏四魔所有境界。能令一切诸天欢喜。令诸恶鬼生知足想。能令恶龙心大怖畏。能坏一切恶邪诸论。令诸四姓心生欢喜。能令女人贪心自除。令多闻者念心坚牢。坐禅之人心得善寂。能坏一切国土恶相。令三宝种无有断绝。能令法果增长无减。能令佛法广普流布。能坏一切无明痴聚。能得尽智及无生智。尔时世尊即说此陀罗尼句

摩那叉(一)阿[(口*皮)/女]叉(二)伽罗婆叉(三)阇罗叉(四)摩摩那叉(五)叉婆叉(六)摩陀叉(七)那茶叉(八)那茶罗休(九)比婆那吒(十)却伽那吒(十一)阿吒那吒(十二)究那吒(十三)波利究婆那吒(十四)那茶那吒(十五)富利迦那吒(十六)遮凡婆罗那吒(十七)却钳[(口*皮)/女]罗那吒(十八)佛迦罗那吒(十九)帝婆留陀逻那吒(二十)三摩罗蛇那吒(二十一)尸利拘婆那吒(二十二)憍多吒(二十三)多茶罗婆(二十四)摩留多却婆(二十五)提休叉(二十六)婆提逻酬(二十七)挫摩那酬(二十八)婆呵那富置(二十九)散提逻阇婆(三十)阿摩摩阇婆(三十一)摩休罗伽阇罗(三十二)阿涅那(三十三)阿涅那逻婆(三十四)阿涅那叉(三十五)阿[(口*皮)/女]呵末力伽涅那叉(三十六)伊槃都豆呿写(三十七)莎呵(三十八)

毕竟尽苦是名为咒。说是咒时彼大众中六万亿人得如法忍。复有六万人入正定聚。善男子。我今以是净陀罗尼与彼佛欲。汝当受持讽读诵写。时虚空密菩萨摩诃萨敬承佛教。受持读写是陀罗尼。与无量菩萨俱共发来至娑婆界。悉自变其身为转轮王。以种种宝供养如来头面敬礼。右绕三匝却坐一面

    大方等大集经日密分中分别说欲品第三

尔时频婆娑罗王见无量菩萨。或作梵像及帝释像。那罗延像转轮王像。从座而起敬意合掌在一面立。尔时日密菩萨摩诃萨即于佛前以偈赞叹

  于诸足中最殊胜　　施诸恶见大光明
  行正道者施法印　　摧灭恶龙及四魔
  坚竖法幢施解脱　　以大法炬坏众闇
  亲近善友修集定　　愍众生故说福田
  佛法僧宝甚难得　　人身信心亦复难
  虽得人身善友难　　得善友者坏烦恼
  众生闇行没结河　　如来船师能拔济
  四方诸佛遣我来　　今于大会说与欲

日密菩萨说是偈已。如其本土所教诫事悉皆说之。尔时世尊告舍利弗。是陀罗尼四方诸佛所与欲也。为欲利益此土众生。舍利弗。汝当受持读诵书写是陀罗尼。于四众中广分别说。时虚空密菩萨摩诃萨复以偈赞于佛

  如来真实知法界　　示魔众生正直道
  若有真实生信心　　是则能破三恶道
  供养如来一香华　　无量世受无上乐
  无量世中身具足　　亦得无上真智慧
  若能一闻是总持　　即得摧灭诸烦恼
  一切人天所供养　　获得无生及尽智

    大方等大集经日密分中分别品第四

尔时世尊告四大菩萨。善男子。汝若住此世界者。随意修集所有善法。时四菩萨及其大众。即便各各随意入定。既入定已。身出光明犹如一灯。乃至犹如无量日月。尔时大德阿若憍陈如。承佛神力即作是念。我今若问如来一义。如来因是或当分别广说如是四陀罗尼。如来说时其声必闻娑婆世界。众生闻已疑网心坏。于向法中得大光明。度于彼岸到正定聚不堕恶道。一切悉行纯善之法。作是念已即从座起。敬意默然合掌而立。尔时佛告阿若憍陈如。汝将不欲问大义耶。如是世尊。实欲咨启惟愿听许。佛言。憍陈如。汝今知时。我当破坏一切疑网。憍陈如言。如佛经中说有二种。所谓爱与士夫行于生死。云何名爱。云何士夫。何故如来说是二种行于生死。佛言。善哉善哉憍陈如。快发斯问。能大利益无量众生。是知时问是如法问。谛听谛听。吾当为汝分别解说。憍陈如。爱有三种。所谓欲爱。色无色爱。复有三种。所谓有爱。断爱。法爱。憍陈如。云何欲爱。所言欲者名为放逸。放逸因缘则为贪触。以触因缘则生乐想。乐想因缘则焦身心。焦身心故乐行十恶。十恶因缘则能增长三恶道苦。若受人身贫穷困苦。贪因缘故五道受生。生在羊中多受苦恼。虽受是苦心无惭愧不生悔恨。若因少善还得人身爱心增长。爱增长故身口不净。造作无量诸重恶业乃至五逆。以是因缘复于地狱受大苦恼。一切受苦皆因爱心。是故如来为爱解脱。宣说正法呵责欲法。若有众生得闻如是呵责欲已。观欲如果如大毒树。毒盆行厕如刀如贼。如旃陀罗如热铁丸。如恶雹雨如恶暴风。毒蛇怨家空野罗刹如杀害人。如粪如冢。若有人能作如是观。是人所有爱之与贪。爱腻爱着爱宅爱热。爱憎等法寻即除灭。灭已念法乐法。学法受法取法。勤求于法财法藏法净法行法。归依于法。是人临死获得法念。因法念故。寻得闻于十方诸佛宣说法要教化众生。既闻法已心生欢喜。生欢喜故即得睹见诸佛色身。是人舍身生净国土无三恶道。常与善人游止共俱具足智慧。舍施精进修集慈悲。调伏众生断烦恼习。具足无量庄严功德。譬如香箧以盛衣服。夜服皆香箧香不减。憍陈如。若诸众生善愿力故生净国土。共善众生同共事业。亦复如是。自增诸善彼善无减。憍陈如。是故善男子善女人。若欲自利利他共利。常当勤求依于善友。憍陈如。若人能作如是观察欲性之相。当知是人不久当得阿耨多罗三藐三菩提。世尊。云何善友。憍陈如。夫善友者。所谓诸佛菩萨诸阿罗汉。又善友者即我身是。何以故。我常怜愍一切众生。能说诸欲所有过患。是故大众应受我语。我所出语终无有二。言不虚妄不两舌语。非无义语非粗恶语。所言诚实慈语悲语安众生语。我今当说诸欲罪过。汝等应当一心受持。既受持已。脱三恶道疾得阿耨多罗三藐三菩提。尔时娑婆世界一切众生同发声言。世尊。唯愿宣说欲之罪过。我等今当至心受持。佛言。诸善男子。有四种欲。一者色欲。二者形欲。三者天欲。四者欲欲。是名为四。云何色欲。四大造色。凡夫不见无我众生。生颠倒想见男女想。上下色想是色可爱是色可恶。因是颠倒见男女相故。令贪欲未生便生。生已增长。是人因是远离善根及善知识。不能善护身口意业。是故名为恶法之聚。何以故。不能观察欲解脱故。以是义故增三恶道。受于地狱饿鬼畜生无量世中受大苦恼皆由贪欲。贪欲因缘令欲增长。若有智者观察女色。见不净相皮肤肌肉筋骨血脉。见已心乐修集是想。如女身男身亦尔。如近远亦如是。如此彼亦如是。如他自亦如是。是人若能修集是心。即于贪爱疾得解脱。观是身骨筋节相连。心随身行。尔时系心在于额上。如枣许处。心乐修集如是相已。身得寂静不见恶相。不见恶事不见恶缘。是则名为奢摩他。名心寂静。云何复名身寂静耶。是人入定灭于入息。既无入息何有出息。是则名为身心寂静。身心寂静即舍摩他之因缘也。是人观身所有骨节离散如沙为风所吹。见已即生空无物想。观于虚空。是则名为身心寂静。是名因于舍摩他定而得解脱。世尊。虚空相者。是有为相不。憍陈如。是有为相。世尊。虚空若是有为相者。为是自相是他相耶。憍陈如。若能观察一切法界。及有为界。是名为自相。何以故。若能观察色寂静者即见佛身。所以者何。若人观骨能令如沙为风所吹。是人能破色贪色欲。能深观察色之实性。是人所见皆如虚空。十方诸色空如琉璃。于中复见无量诸佛。乃至十方亦复如是。复见如来三十二相八十种好。十方世界亦复如是。是人若得悔生死法。即自思惟我当问佛。如是虚空谁之所作。当云何灭。作是念已。我已问已我已知已。虚空之性无有作者。当云何灭。言虚空者。无有觉观无物无数。无有相貌无出无灭。一切诸法亦复如是。作是观时得阿那含果。是阿那含悉断一切贪欲之心。唯有五事未能除断。一者色爱。二者无色爱。三恌。四慢。五者无明。是人若得见如来身。便作是念我当知数。是人尔时观少见少观多见多。复作是念。如是诸佛从何处来。复作是念如是诸佛。无所从来去无所至。我三界心是心因身。我随觉观欲多见多欲少见少。诸佛如来即是我心。何以故。随心见故心即我身我即虚空。我因觉观见无量佛。我以觉心见佛知佛。心不见心心不知心。我观法界性无坚牢。一切诸法皆从觉观因缘而生。是故一切所有性相即是虚空。虚空之性亦复是空。若有初发菩提心者。当观无量诸法因缘。是人若发求声闻心。尔时即得无相三昧。令彼无明永灭寂静。亦复获得随顺空忍。是人若见虚空是空。尔时即得身心寂静。是则名为空解脱门。取阿罗汉则为不难。若复修行灭定解脱。为灭无量诸法因缘。说是法时。九万九千亿众生得修定忍。八万四千众生得修空忍。六万众生得空三昧解脱门。二万众生悉得现见诸佛三昧。八万四千众生得阿罗汉果。无量众生得须陀洹果。复次憍陈如。若有比丘自观己身作不净想。不能调伏自己心者。是人次应谛观死尸。若青色若烂坏。若赤色若膖胀。若离散若骨白如贝。当深观心乐住何处。知已即取如观外色自身亦尔。若青色乃至如贝。如昼夜亦如是。如夜昼亦如是。如去来亦如是。如来去亦如是。尔时若见外物树木人畜杂物皆作骨想。作是观已乃至命终不生贪心。是人现在能离于欲。他世未能。是人若能获得修空陀罗尼者。即能观骨作离散相如沙微尘。若自若他不见色相如一微尘。即时获得虚空之相。见一切色如青琉璃。见已复观虚空黄色。能观黄色赤色白色杂色琉璃色。若见地水亦如琉璃。是人能观一切大地如四指许。若欲动者。即以足指蹑之令动随意久近。乃至大地树木山河悉为之动。若观诸水作种种色。或分陀利华优钵罗华。拘物头华波头摩华。于一切水行住坐卧。观一切山作种种色。其形细软如兜罗绵。而于其中行住坐卧。又自观身轻漂如风。作是观已能游虚空行住坐卧。是人复入火光三昧。身放种种妙色光明。又复游入焰摩迦定。身上出水身下出火。作如是等大神变已。复作是念。我当云何得见诸佛。尔时随其所观方面悉得见佛。多观多见少观少见。见已复念。诸佛世尊无所从来去无所至。我三界心是心因身。我随觉观欲多见多欲少见少。诸佛如来即是我心。何以故。随心见故。心即我身我即虚空。我因觉观见无量佛。我以觉心见佛知佛。心不见心心不知心。我观法界性无坚牢。一切诸法皆从觉观因缘而生。是故法性即是虚空。虚空之性亦复是空。我因是心见青黄赤白杂色虚空。作神变已。所见如风无有真实。是则名为共凡夫人如实陀罗尼。是人复作是念。若有虚空即是无取。无有觉观不可宣说。如我心离观虚空相。亦观心相不作远离。离一切作不作发心。设发寻灭以心缘灭故。是心便灭。净身口意修集灭定。是人长夜系心在定。从灭定起舍其寿命入于涅槃。是名不共凡夫如实陀罗尼。云何名为共凡夫人如实陀罗尼。若有能作如是思惟我随意观。色即是见。色即是我心。我心即色。如我远离一切色相。观虚空相是人尔时修虚空相。是则名为共凡夫人如实陀罗尼。若有能作如是观。色即是虚空。我以如是色因缘故得观虚空。虚空之性名无障碍。是风住处。如是风者因四大生。我是色相亦复如是因四大起。虚空风色等无差别。一切法性性自空寂。观自他性亦复如是。虚空者即是无生无灭。作是观时系念如来。作是念已见虚空中有无量佛。即时获得阿那含果。是名不共凡夫如实陀罗尼也。复作是念。言虚空者即是我也。即是净我即是我心。我者无色如空无边。我亦如是。是名共凡夫如实陀罗尼。若有能观一切法中无我无我所。言空处者即是无我色无有我。若念如来若观如来即是我也。我见佛已。得沙门果乃至阿罗汉果。是名不共凡夫如实陀罗尼也。若观净我者即是空处空即我心。若能永断一切烦恼即是净心。若能修集八直正道是名净心。能如是修。即能获得须陀洹果乃至阿罗汉果。是名不共凡夫如实陀罗尼。复有观色。观色相者即分别相。分别相者即是嗔相。嗔恚相者即生死相。我今为断生死相故。观心相空。是名共凡夫如实陀罗尼。又复观我即是寂静。我今亦未断于觉观。若我观我我如虚空。我我者即是苦。苦所从生即名为集。如是苦集是可断法是名为灭。观苦集灭是名为道。得须陀洹果乃至阿罗汉。是名不共凡夫如实陀罗尼。又复念言。我何以故观于虚空。空者即我我若远离虚空观者。次观识处如虚空观。识观亦尔。如空无边心亦如是。是名共凡夫如实陀罗尼。若能观识即是苦者。知苦所从名之为集。若集可断是名为灭。观苦集灭是名为道。得须陀洹果乃至阿罗汉果。是名不共凡夫如实陀罗尼。若观识处即是觉观疮疣烦恼。如我远离空处识处修无想处。是人修无想已得无想定。是名共凡夫人如实陀罗尼。若观识处。即是疮疣苦恼之法。如我远离观于识相。次观无想相。言无想者即是无我无我所相。作是观已。即得须陀洹果乃至阿罗汉果。是名不共凡夫如实陀罗尼。若有能观无想处者即是细想。如我远离是无想处。观非有想非无想处。是名共凡夫人如实陀罗尼。若观非想非非想处即是大苦。是处可断可得解脱。作是观时得须陀洹果乃至阿罗汉果。永断一切欲贪色贪。离凡夫名得圣人号。永断一切三恶道因。是名如实陀罗尼也。是彼诸佛之所遣来。日密菩萨所赍持。欲能断一切诸结烦恼。一切恶见我见取见戒见常见断见命见作见士夫见受见色见触见出见四大见。能断如是等见。是陀罗尼善能了达阴入界等。能净诸见能令受者永受安乐。沮坏众魔调伏恶龙令诸天喜。坏阿修罗调迦楼罗。能喜刹利婆罗门毗舍首陀。能断恶欲。令坐禅者贪乐寂静。能疗一切诸恶重病。能防一切诸恶斗讼。能增法界能护三宝。能得尽智及无生智坏无明聚。如来说是陀罗尼时。无量众生得须陀洹果。无量众生得阿罗汉果。无量众生获得是持。无量众生发阿耨多罗三藐三菩提心。无量众生得无生忍

大方等大集经卷第三十二大方等大集经卷第三十三

        隋天竺三藏那连提耶舍译

    日密分中分别品第四之二

尔时阿若憍陈如白佛言。世尊。云何名为莲华陀罗尼。如日密菩萨之所宣说。智者受持读诵书写得大利益。不乐三界得无相解脱门者。皆能断诸烦恼。七返常受人天之身。虽在欲界不为欲污。诸天世人常所恭敬。佛言。憍陈如。所问莲华陀罗尼者。非诸声闻缘觉所知。是陀罗尼乃是十八不共法行。憍陈如。假使我于无量劫中。宣说是持终不可尽。亦令闻者生迷闷心。是陀罗尼唯佛能说唯佛能听。何以故。是陀罗尼难知难解余三亦尔。世尊。唯愿如来当说如空空行陀罗尼。憍陈如。至心谛听当为汝说。憍陈如。若有众生放逸因缘生触欲心。是人不知解脱之处。流转生死无量世中。在三恶道受大苦恼。菩萨摩诃萨见诸众生受如是等无量苦恼。生怜愍心勤行不息遍修诸道。作是行已得阿耨多罗三藐三菩提。得菩提已说苦解脱。众生闻已即得脱苦。苦解脱者。即是初果乃至阿罗汉果。憍陈如。云何触欲。言触欲者二身共合。因身合故则生于触。因触生乐因乐生苦。苦因缘故。生死苦恼从是而生。憍陈如。如四毒蛇以四因缘能害众生。见嘘啮触。欲亦如是。有见因缘。有闻因缘。有念因缘。有触因缘。因是四缘令诸众生远离一切诸善根本。于生死中受大苦恼。憍陈如。云何名为触欲解脱。若有比丘能观白骨作是思惟。色者即是四大所造。四大所造即是无常性无坚牢。离散之法皮毛肉血。智者云何。于是身中生净好相。作是观已。悉于一切十方净色。即时获得不可乐相。是比丘复作是念。我于是相乐修集者。则得断除一切烦恼生老病死。是名舍摩他。若观足骨乃至头骨。是名毗婆舍那。既得如是毗婆舍那舍摩他已。观息出入。见息出时即作是念。如是风者从何处来去至何处。如是观时远离身相。生于空相不见内法。是名内空。不见我所及外色相。是名外空。观内外色空。复作是念。我今修集入息相已作大利益。能坏一切内外诸色。我坏如是内外色相。皆是入息观因缘也。以是因缘令我不见内外诸色。我无色相即是空力。我今定知一切诸法。无有去处无有来处。作是观已。所有觉观一切永断。复观是识。知是一切觉观因缘。我当远离心意识行。何以故。若有生者当知定灭。作是观时得须陀洹果乃至阿罗汉果。或有获得如法忍者或得菩提。若观觉观是灭相者即得灭定。是名不共凡夫如空陀罗尼。是持成就无量功德。永断无量诸大苦恼。说是法时。九万二千众生得须陀洹果。六万众生得阿罗汉果。九万九千众生得如空陀罗尼。八万众生得辟支佛果。八千亿众生发阿耨多罗三藐三菩提心。无量众生得不退心。尔时阿若憍陈如白佛言。世尊。高贵德王佛。所持来欲随无愿陀罗尼。唯愿如来分别解说。憍陈如。我今当说至心谛听。憍陈如。有诸众生触欲系缚不知解脱。是人应观无愿解脱。作如是念。欲欲色欲及无色欲。触欲解欲。知是诸欲因觉观生诸行因缘。如是诸行无有作者无有受者因风而生。我身口行亦复如是因风而生。因是风故身得增长。因是风故口得增长。如我观风即入出息。谛观一切身诸毛孔从风因缘。复观一切不净之物。复观是身命终之时。是尸更无风息入出。复作是念我身口行因缘于风。若无风者无身口行因缘。是故尔时得空三昧修集增长。因修集故能断欲贪乃至触欲。作是观已。得须陀洹果乃至阿罗汉果。或有发阿耨多罗三藐三菩提心。尔时善意觉观菩萨摩诃萨白佛言。世尊。若声闻人修不净相。得成相已有何等相。善男子。若为破坏欲贪之结。修不净相。系心眉间自观身骨。是名一相。若观自身及以他身。是名二相。又观一切悉是不净。是名三相。是人能观苦集尽净。名舍摩他得暖法相。是人如是观白骨时见智如灯。观身四行乃至微尘。是名顶法。观四真谛。是名声闻不净观。成就获得舍摩他定。是名白骨观相。观是相时得八正道。因八正道。得须陀洹果乃至阿罗汉果。善男子。光明佛土声闻之人。观如是法即得道果。说是法时。无量众生得如法忍。无量众生得如实忍。尔时世尊复告憍陈如。若四真谛可一念证者。如来应为一切众生。演说一行一法一事。若一人证时。一切众生亦应同证。何以故。烦恼同故亦不应有八万法聚差别之异。憍陈如。是故众生。应以种种因缘调伏。不以一缘。憍陈如。一切众生非实一乘一行一贪一念一欲一解一信。是故如来宣说种种句偈名字种种法门。以是义故。如来具足十种神力。憍陈如。一切众生具有种种颠倒之相。是故如来为净颠倒。说无常相苦相无我相。胀相烂相青相坏相离散等相。世尊。云何名为一切世间不可乐想。云何复名食不净想。佛言。憍陈如。汝今不应问如是事。何以故。彼界得道此界得道。其相各异。憍陈如。我若具说众生闻者或生迷闷。世尊。唯愿怜愍为诸菩萨能信解者。分别宣说。世尊。是诸众生若闻宣说如是二相。能种善子增长善根能破无明。世尊。一切众生痴爱因缘乐于生死。是故生死无始无终。世尊。一切众生以食因缘增长贪欲。世尊。一切众生初未得闻如是二相。是故流转生死五道受大苦恼。如来世尊大慈大悲无量世中常念众生。唯愿如来怜愍故说。不可乐想食不净想。若佛宣说不可乐想食不净想。众生闻者不生欲贪不生食贪。世尊。若有众生能苦呵责欲心食心。当知是人速到彼岸。佛言憍陈如。至心谛听。我今当说一切世间不可乐想食不净想。憍陈如。世有二种。一众生世。二者器世。众生世者。所谓五道众生。器世者。欲界之中有二十处。色界十六。无色四处。云何欲界有二十处。八大地狱。一一地狱有十六围绕。一者等活。二者黑绳。三者众合。四者叫唤。五者大唤。六者热。七者大热。八者阿鼻地狱。若有众生身口意恶。悉生如是大地狱中受大苦恼。是诸众生虽见妙色。不生乐想。以是因缘复生大苦。声香味触亦复如是。有智之人观是事已。生不乐想。憍陈如。若观畜生其身细小。犹如微尘十分之一。有如微尘乃至如枣。有一由旬乃至百千万由旬等。是诸众生或有寿命。如一念顷至七念顷。或有一劫至千万劫顷。是诸众生无有法行。智慧惭愧怜愍之心。当受苦恼生大怖畏。各各常生相害之心。远离一切诸善之法。常行黑闇常行邪道。是故智者修不可乐想。憍陈如。智者复观饿鬼之身。或长一尺或如人等。或百由旬或如雪山。当患饥渴裸形无衣。被发缠身无有惭愧。羸瘦骨立身无血肉。各生恶心心无怜愍。湿冷诸气永无复有。或食铁浆铁糗铁丸。热粪热脓。热血热风。热草热果。然不能得恒不供足。寿千万劫常受苦恼行于黑闇。智者观已。修集世间不可乐想。憍陈如。有智之人。次观人身一切皆有。生苦老苦病苦死苦。爱别离苦。怨憎会苦。求不得苦。饥渴困苦。欲苦嗔苦嫉妒等苦。两舌恶口寒热等苦。诸恶兽苦。恶王等苦。是人身中受如是苦。智者云何而不修集不可乐想。憍陈如。智者云何。观于欲天不可乐想。智者观初欲界六处。是中众生欲爱所焦。所受果报不等故苦。无常故苦。取苦尽苦。爱别离苦。智者云何于中不修不可乐想。次观色界十六住处。是中诸天修世禅定。有漏故苦。无寂静苦。所欲故苦。有胜定苦。善法藏苦。未解脱苦。不知彼岸不尽地狱饿鬼畜生人因缘苦。观是苦已。智者即修不可乐想。复次色界众生。或有修集无漏禅定。是等不能具足八正道苦。欲具八正道方便时苦。得无学地不自在苦。不得缘觉三昧故苦。不得如来三昧故苦

不能观察一切众生境界故苦。如是众生于色界中。若入涅槃受如是苦。智者云何于色界中不修世间不可乐想。次复观察于无色界不可乐想。彼中众生修有漏三昧苦。学地不得自在苦。又不得听闻正法故苦。不能毕竟断受故苦。舍命退时生邪见苦。不能永断三恶道苦。舍命堕苦。知如是时修集世间不可乐想。复次憍陈如。世间者即是行。行有三种。身行口行意行。身行者谓入出息。口行者所谓觉观。意行者所谓想受。是三种行。其相是一。智者云何能分别知。智者观息出入数时。深观息之冷暖乃至一切毛孔入出。是人观息。谛知是息本无今有。若本无今有是无常相。无决定相如电画水。如是观时得身行相。观如是相从何因缘。即知是相因于觉观。觉观之性本无今有。是故无常是可断法是可解脱。是觉观相因心而生。心亦本无今有。本无今有是无常相。可破坏相无归依相。无有物相无有我相。作是观时。于诸行中心则生悔。能修世间不可乐想。汝等比丘。若能深观如是三行。则能永断一切烦恼。能净正见断生死法。成平直道正聚所摄。得须陀洹果乃至阿罗汉果。憍陈如。智者于诸行中修不可乐想。憍陈如。云何比丘观所著衣作不乐想。若有比丘裁衣缝衣。见衣触衣。着衣脱衣。观如是时。如血涂皮烂臭可恶。虫所住处无可乐处。如是观时。于衣贪心即时除灭。憍陈如。云何修集食不乐想。若有比丘执持钵时。如血涂髑髅。烂臭可恶虫所住处。若得食时。应观是食如死尸虫。若见糗时如末骨想。得饭浆时作粪汁想。得诸饼时作人皮想。所执锡杖作人骨想。得乳酪时作脓血污想。若得菜茹作发毛想。得种种浆作生血想。憍陈如。若有比丘作如是观。是名于食不可乐想。憍陈如。云何于房舍生不可乐想。比丘若入房舍之时。应生是念如入地狱受诸苦恼。如是房舍即是和合。所有材木即是人骨。土是人肉。乃至一切床榻被褥。亦复如是。作是观时。是名世间不可乐想。若能观察如是想者。是人即得如实法忍。随空无相无愿等忍。是人乐修空相。因修空相见一切法悉是生灭苦空无我。观阴入界十二因缘。一切法性苦空无我。如是见已。即得须陀洹果乃至阿罗汉果。憍陈如修集世间不可乐想。能断欲贪色无色贪。一切憍慢疑恌无明。乃至得无学地。是名具足随无愿陀罗尼。憍陈如。是陀罗尼能破一切恶魔。乃至能令三宝增长。说是法时。无量众生得法眼净。无量亿众诸漏永尽。八那由他众随无愿陀罗尼。无量众生发阿耨多罗三藐三菩提心。五万八千众生得不退菩提心。无量众生得如法忍。尔时无量众生白佛言。世尊。一切众生若闻是法。云何不发阿耨多罗三藐三菩提心。我今护持听受是法。佛言。善哉善哉。诸大檀越。汝等今者欲护大法。因护法故未来之世。当得无量福德果报。尔时舍利弗白佛言。世尊。德华密佛遣虚空密菩萨摩诃萨。所持来欲净陀罗尼。唯愿说之。佛告舍利弗。谛听谛听善思念之。当为汝说德华密佛所遣来欲净陀罗尼。为坏此土众生四倒。舍利弗。此土众生实无有我。颠倒心故。横生我想。智者深观知无有我。作是观已则破颠倒。舍利弗。云何智者观于无我。所谓观身谛知无我。何以故。以和合故。复次观眼亦无有我。何以故。四大合故。若眼转瞬即是风力。如是风者。因于虚空去来回转。而虚空性性无所有亦不可说。若无所有不可说者即是无我。是故虚空实无有我。是空中风亦复无物。不可宣说是故无我。如观风地亦如是。地亦无物不可宣说是故无我。水火亦尔。是故当知眼之四大亦复无物。不可宣说是故无我。若复有言眼色因缘故有我相者。是义不然。何以故。眼中无我色亦如是。而和合中亦复无我。和合因缘生于眼识。而是识中亦复无我。因识生色名为名色。名色因缘生于六入。六入因缘触。触因缘受。受因缘爱。爱因缘取。取因缘有。有因缘生老病死等。如是等法因眼识生。而是眼识亦复不从十方而来。所因之念生眼识者。是念亦灭。眼识不住于二念中。亦不语念汝住我灭。而是灭法亦无处所。是故诸法缘合故生缘离故灭。若因缘故生无缘则灭。是故当知实无有我。而是因缘亦无作受无有作者。是故无我。若无我者我所亦无。是故眼性无我我所。无合无散即是生灭。一切诸法亦复如是。一切法性无取无舍。非诸声闻缘觉诸佛之所造作。如眼识空一切法空亦复如是。作是观时得空三昧门。或得须陀洹果乃至阿罗汉果。观眼既然耳鼻舌身亦复如是。观身无我发亦无我。皮毛血肉筋骨脓髓。肠唾暖气上下诸风。寿命名字皆无有我。直以众缘和合故名为身。身触因缘故生身识。识因缘名色。名色因缘六入。六入因缘触。触因缘受。受因缘爱。爱因缘取。取因缘有。有因缘生老病死等。如是等法因生身识。而是身识亦复不从十方而来。所因之念生身识者。是念亦灭。身识不住于二念中。亦不语念汝住我灭。而是灭法亦无处所。是故诸法缘合故生缘散故灭。有缘故生无缘故灭。是故当知实无有我。而是因缘亦无作受无有作者。是故无我。若无我者我所亦无。是故身性无我我所。无合无散即是生灭。一切诸法亦复如是。一切法性无取无舍。非诸声闻缘觉诸佛之所造作。如身识空。一切法空亦复如是。作是观时得空三昧门。或得须陀洹果乃至阿罗汉果。舍利弗。若有比丘能如是观眼身无我。当知是人得三昧门。为诸天世人之所供养。说是法时。无量众生过去恶业悉得除灭。无量众生得法眼净。无量众生得须陀洹果乃至阿罗汉果。九万四千众生获得如是净陀罗尼。无量众生发阿耨多罗三藐三菩提心。无量众生于菩提中心不退转。无量众生得如法忍。无量众生得破欲贪色无色贪。无量众生得随空无相愿陀罗尼。无量众生成就不净观。无量众生成阿那波那。或得舍摩他。或得毗婆舍那。或得性地。或得声闻辟支佛法。或得菩萨法。一切女人闻已悉得转于女身。欲界众生悉受快乐如三禅地。尔时一切天人八部。供养于佛欢喜而住。尔时频婆娑罗王白佛言。世尊。此世界中无量菩萨。所可成就光明妙色。我从本来初未曾见初未曾闻。世尊。是菩萨光能照一切娑婆世界。若是菩萨近于阿耨多罗三藐三菩提者。其光云何。大王。若有菩萨成就无上菩提道者。其光能照十方世界。何以故。善法庄严诸功德故。成就具足庄严法故。一切善根多增长故。以近无上菩提道故。毕竟无上菩提道故。受于如来正法果故。分别演说无边法故。所可得身无挂碍故。获得清净真实法故。所可修集到彼岸故。未来世业已得尽故。成就无量佛正法故。能转无上妙法轮故。于一切法得自在故。通达一切众生根故。永断一切烦恼习故。是故光明悉能遍照十方世界。大王。随佛功德大势力故。亦能睹见十方诸佛。王言世尊。我今欲见十方诸佛菩萨声闻。尔时世尊告阿若憍陈如。若我弟子声闻之人在家出家。是人各各深自思惟所有善法。我亦欲入如来三昧。若有人天得如实忍。若有不退于三乘者。如是众生亦入于定。复有众生于三宝所得信敬心。亦复如是入于禅定。尔时世尊即入三昧。其三昧名一切佛境界。行智广如虚空一切智者喜日月光明。如是三昧。声闻缘觉及诸菩萨。所不能知不能计量。是名佛境界三昧。如来入是三昧已。娑婆世界百亿四天下百亿须弥山。百亿日月乃至百亿有顶。如是等土悉入佛身。娑婆世界地狱饿鬼畜生天人。有受苦者皆得除灭一切欢喜。譬如比丘入第三禅。所有一切菩萨摩诃萨悉从定起见佛光明。见光明已。自所有光寻灭不现。一切声闻所受快乐。譬如比丘入第三禅。尔时一切无量众生悉皆自睹如来毛孔一一毛孔出无量光。如恒河沙等日月光明。亦如恒河沙十住菩萨所有光明。如是光明悉能遍照十方佛土。尔时十方诸佛世尊。各告大众。诸善男子。汝等颇见释迦如来大光明不。如是光明成就无量无边功德。是光因于大慈大悲。为于怜愍诸众生故。是故今者示诸众生大神变相。一切众生见是光已。皆发阿耨多罗三藐三菩提心。他方世界有诸众生得神通者。皆集至此娑婆世界。其不得者遥礼供养。尔时一切诸佛菩萨及声闻众。皆悉来诣娑婆世界。一切菩萨悉以七珍种种华香伎乐幢盖。供养恭敬尊重赞叹。有诸众生处佛身者。皆悉见之。见已复受无量快乐。尔时娑婆世界一切众生。同共发声作如是言。我等以是善因缘故。愿后共生一国土中。令得睹见十方诸佛。三恶业道已得消灭。若有众生见佛神变。不发阿耨多罗三藐三菩提心者。当知是人常行黑闇。诸菩萨等。为众生故受种种苦。或化作佛或作辟支佛。或作声闻梵天帝释。四大天王那罗延像。自在天像龙像鬼像。阿修罗像转轮王像。若有佛界应以声闻得调伏者现声闻像。如是等化自非十住不能为也。是故无上菩提之心。成就无量无边功德。尔时一切诸佛身内所有众生。以偈颂曰

  以诸恶心因缘故　　流转生老病死者
  以不亲近善知识　　是故不能到彼岸
  若能远离诸恶心　　诸恶邪见恶因缘
  能断三有生死者　　是则能到于彼岸
  众生难得于人身　　得已值遇善友难
  笃信之心复难得　　得已难得听正法
  若有能发菩提心　　是人能断诸烦恼
  亦能教化无量众　　现大神变如今佛
  若能永断二法者　　所谓常断二见等
  若见一切行无我　　是人名为善思惟
  若能修集苦集谛　　是人能断诸烦恼
  若能发起菩提心　　是人则胜诸世间

说是偈已。无量众生发阿耨多罗三藐三菩提心。复有众生发缘觉心。复有众生发声闻心。或有众生得无量陀罗尼。复有众生得如法忍不退忍如实忍。或有获得须陀洹果乃至阿罗汉果

尔时波旬。悉见娑婆世界在佛身内。见已悲泣涕泪横流心生愁恼。若坐若起若行若立进止出入以手拍头亦受苦恼。乃至一切魔之眷属亦复如是。时魔波旬有一大臣。名曰空树。见魔愁恼。而说偈言

  何故愁恼而独行　　其心迷乱如狂人
  所至之处心不乐　　唯愿天王说因缘

时魔波旬。复以偈答

  我见瞿昙大神力　　是故生恼而狂行
  内心躁动无安所　　愁热逼切及眷属
  睹见如来无边身　　悉受一切娑婆界
  令我境界悉空虚　　是故我今生愁恼
  十方所有诸圣人　　悉来集会此世界
  大设供养供养佛　　是故令我生愁恼
  瞻睹如来大神力　　及见眷属归依佛
  我今独行无伴侣　　是故令我生愁恼

尔时大臣。复说偈言

  我今多有诸眷属　　其心弊恶具器甲
  力能破坏如来身　　及能毁坏大神力

时魔波旬。复说偈言

  我今眷属深畏佛　　云何能坏神通力
  若欲生心毁坏时　　则自见身被五缚

是时大臣。复说偈言

  如其怨敌势力大　　当诈现亲则可坏
  若知瞿昙有大力　　先当现诈亲厚心

时魔波旬。复说偈言

  我若诈现亲厚心　　为欲毁坏瞿昙身
  即现颈下系死尸　　为一切人所呵责

是时大臣。复说偈言

  一切欲有是魔界　　所有人天属如来
  愿王切敕恶龙王　　是能破坏瞿昙身

时魔波旬。复说偈言

  若汝审知龙有力　　我已失心汝自约
  若实能坏瞿昙者　　我还得土及本心

尔时大臣即便宣告诸恶龙王。汝当为我坏瞿昙身。时诸恶龙将欲飞空而不能动。即语大臣。敬奉来命欲往毁坏。适生此心便不得去。尔时大臣即生怖畏。作如是念。我若今者现魔大力。令诸恶龙心生嗔恚。以嗔恚故则能毁坏瞿昙之身。尔时龙宫有化死尸充满侧塞。诸龙见已。自于宫室心不甘乐。作是念言。是谁化作此死尸耶。虽复思惟莫知谁为。尔时一切四天下中诸大龙王。及其男女大小眷属。即出宫室至佉罗坻山。其山平坦广纵正等四万由旬。皆是先圣所游居处七宝具成。乃至难陀婆难陀王。亦舍住处至此山中。四大海中。所有龙王。及其眷属无量无边。伊罗跋龙王。善住龙王。龟龙王。阿那婆达多龙王。目真邻陀龙王。德海龙王。水德龙王。舍德龙王。乐德龙王。阿波那罗龙王。山德龙王。牛德龙王。伊罗跋多龙王。长臂龙王。长发龙王。净龙王。迦羯罗龙王。水[漂*寸]龙王。黑发龙王。金色龙王。舍拘龙王。念弥龙王。象龙王。利牙龙王。有行龙王。疑网龙王。长面龙王。赤眼龙王。乐见龙王。如是等阎浮提土所有龙王。其数八万并其眷属。乃至四万四千国土所有龙王。皆至佉罗坻山。北郁单越有二龙王一名无遍二名金身。是二龙王。与无量众及四万四千国土龙王。亦至此山。东弗婆提有二龙王。一名为月。二名婆私吒。是二龙王。与无量众生及四万四千国土龙王。至此山中。西瞿耶尼有二龙王。一名宝发。二名光发。及四万四千国土龙王至此山中。及四天下四生龙王。并其眷属亦至此山。是诸龙王其身皆如四寸药根。以嗔恚故身如须弥。时魔波旬。见如是等诸龙王已。告其眷属。谛听谛听。以我力故令如是龙从宫室出。至彼大山悉失势力。不能毁坏瞿昙沙门

大方等大集经卷第三十三

尔时复有大臣名曰戒梯。即白魔言。大王。如是龙王为欲破坏释迦身故。集会一处各作是念。我今当以何等方便。坏瞿昙身。波旬答言。我有是事若审汝当往看。尔时大臣与百千万众生。欲往彼山。尔时如来从禅定起。坐于一面示现常身。大臣既见如来常身在摩伽陀国。见已即作是念。瞿昙沙门退失神通。将不于我生怖畏耶。欲于我所生大恶乎。我应先至彼瞿昙所。与共谈论。尔时大臣即与大众往至佛所。而说偈言

  汝身未度生死海　　云何当能度众生
  瞿昙勿诳诸众生　　说言当得大涅槃

尔时如来。复以偈答

  我已得度生死海　　亦得永脱一切有
  我以慈悲因缘故　　说言众生当涅槃
  汝已于昔无量世　　发起无上菩提心
  已曾供养无量数　　百千巨亿诸世尊
  汝今定当得佛道　　云何言我诳众生
  我今施汝大念力　　便可至心观本身

尔时大臣闻是偈已。即自观察过去本身。了了明见发菩提心。供养无量无边诸佛。见已即时心大惭愧。于如来前头面着地。忏悔作礼白佛言。世尊。我今已忆无量世中发菩提心。已曾供养无量亿佛。于诸佛所听受妙法。已得修行六波罗蜜。世尊。迦叶佛时有一比丘。说声闻乘我不思惟。便言是语非是佛语魔之所说。是人已发菩提之心行菩萨道。以是因缘。迦叶如来不授我记。我因是事生于魔界。受是身来。已经五万七千亿岁。世尊。我宁以是过去等身受地狱苦。终不退于菩提之心。佛言大臣。善哉善哉。若人以金如须弥山并七宝物。于无量世供养于佛。其福不如发菩提心。何以故。发是心者。乃是供养十方诸佛。尔时戒梯菩萨即于座上得如法忍。从坐而起头面作礼。绕佛三匝。以身上衣供养于佛。乃至四万四千大众亦复如是。时魔波旬。见其大臣及其眷属。已归依佛心生苦恼。牢闭门户却坐一面。尔时世尊。即为大众说三种慈。所谓生缘法缘无缘。如虚空目中之所宣说。尔时一切诸天龙王。悉皆集会佉罗坻山先圣住处。欲动不能欲行亦然。欲现大身而复不能。寻向难陀婆难陀王而作是言。大王。先者所作臭秽死尸。皆是波旬之所为也。是故令我悉来至此受是小身。若能归依魔波旬者。可得解脱。尔时伊罗跋罗龙王言。魔王今者丧失本心及其神足。云何当能救济汝等。尔时龙王或有归依四天王者。或有归依忉利天或焰摩天或兜术天或化乐天或他化自在天或梵天等。尔时海龙王即作是言。汝等不见释迦如来。一切贤圣人天杂类。大设供养而归依耶。尔时或有龙王。归依那茶仙人或马藏仙人。或归广仙人或光味仙人或跋伽婆仙人。归依如是等五种仙人。是五仙人悉得五通住于雪山。悉在光味大仙人所听受正法。光味菩萨。亦以种种无量赞叹。赞叹如来。尔时仙人悉闻一切龙王音声。闻已即白光味仙人。颇闻诸龙哭声不耶。答言已闻。大士。唯愿往彼救济其苦。光味答言。汝等可往我不得去。所以者何。今有大天。欲得闻受无缘慈故。时四仙人礼拜光味。往佉罗坻山而救济之。诸龙见已。即各举声求哀求救。仙人答言。我不能救。彼雪山中有一菩萨名曰光味。彼能救拔吾等不能。汝当一心求哀作礼。时诸龙王各自同声向彼作礼。尔时光味闻是声已。与无量诸天大众至佉罗坻山。龙王见已头面作礼。唯愿大士救我等苦。尔时光味菩萨知时已到欲说星宿。尔时大海龙王。白光味菩萨言。大士。是星宿者。谁之所说。谁作大星。谁作小星。谁作日月。何日之中。何星在先。云何满月。云何为时。如是星宿系属何天。性是何等。何轻何重。何善何恶。何食何施。谁造此昼。谁作此夜。影有几步。名曰为转。云何南转。云何北转。大士。汝于诸仙最为第一。唯愿具足分别解说。尔时光味菩萨。告诸龙王。大王。先过去世贤劫之初。旃陀延城。其城有王名无量净。正法治国。不贪欲乐常乐寂静才智聪达。王有夫人。欲心发动与王游行。在一林中贪心视王。即便妊身。是时夫人时满即生其儿。头耳项眼唇口悉皆似驴。余分似人。其母见已即生怖畏。掷之厕中身未至地。是时驴鬼于空接取。往雪山之中。瞻看哺养犹如生子。时雪山之中有甘美药。驴鬼采取以食是儿。是儿食已身则转异。有大光明福相具足智慧慈悲。以是因缘。诸天礼拜供养赞叹。为是儿故。于雪山中有诸种种药草果蓏。余相悉转唯唇似驴。是故名为驴唇仙人。于六万年受持禁戒常翘一足。一切梵天魔天帝释。大设供养而供养之。皆悉合掌。白驴唇仙人。欲求何愿唯愿语之。若我力能我当施汝。仙人答言。我今欲得了知星宿。为众人故心生怜愍。一切天言。若为怜愍一切众生。欲得知者愿当说之。仙人言。梵天。我实不解最初宿。说是星时。诸大龙王。于光味菩萨心生欢喜。尔时光味菩萨为诸龙王出微妙音赞叹三宝。又作是言。我今真实不能救拔汝等苦恼。唯有如来释迦之尊乃能救之。释迦如来为欲调伏诸众生故。于无量世能舍所珍。修习慈悲为救苦恼。尔时一切龙王男女大小至心念佛赞叹归依。南无世尊于众生中最为殊胜。一切法中心得自在。于诸法海已到彼岸。能救一切众生苦恼。施其安乐平等无二。怜愍一切能示正道惠施正眼。一切天龙之所供养。能受一切十方世界所有人天微妙供具。世尊。我今多受无量苦恼。唯愿慈悲少垂救拔。是诸龙王心念佛已。寻自见身如先无异。时光味菩萨语诸龙王。如来功德不可思议。为众生故于无量世修行具足六波罗蜜。说三慈悲调伏众生。说一切法无我无作。说阴入界四大烦恼。说烦恼性及众生性。说一切法无性无相。无碍无作无垢无净。无明无暗无取无舍。无行无住无一无二。阴入界等及以四大亦复如是。名第一义空。是故如来能调众生为无上尊。是故如来能拔汝等无量苦恼

    日密分中救龙品第六

尔时世尊告光味菩萨。善男子。汝今欲闻诸龙业不。光味菩萨白佛言。世尊。今正是时。唯愿演说。佛言。善哉善哉善男子。至心谛听当为汝说。尔时一切天人。以好香华妓乐旛盖供养于佛。尔时世尊与欲色界一切诸天无量声闻及菩萨众。从摩伽陀国趣须弥山。尔时梵天设七宝座以待如来。复有造作七宝街道。是时梵王作如是言。唯愿如来经涉此路坐我座上。尔时他化自在天。复以阎浮檀那宝造床及道。亦言。如来愿行此路坐我座上。尔时化乐诸天。复以天金造床及道。亦言。如来愿行此道坐我金床。尔时删兜术陀天。复以天银造床及道。亦言。如来愿行此道坐我银床。时夜摩天。复以琉璃造床及道。亦言。如来愿行此道坐琉璃床。时忉利天。复以真珠造床及道。亦言。如来愿行此道坐真珠座。时四天王。复以玛瑙造床及道。亦言。如来愿行此道坐玛瑙床。时四阿修罗。复以栴檀造床及道。亦言。如来愿行此道坐栴檀座。尔时世尊心怜愍故。化作佛像遍行六道。遍坐六座。以如来真身。处在梵王所设道座。一一化像皆有无量声闻菩萨。以为眷属。一一化像所有光明。犹如无量日月光明。是诸龙王见化像已。心生恭敬各作是言。今须弥山乃至如是千日月耶。难陀婆难陀言。如来世尊。与无量梵天趣须弥山。是其光明非日月也。汝等若欲得解脱者。应当至心专念如来。如来世尊已坏无明。是故今有如是光明。阿那婆达多龙王言。是光明者。是魔所有非佛光也。何以故。一切欲界属魔波旬故。是魔波旬能作是恶。波旬今者怜愍故能救如是诸龙王苦。或有说言。如此乃是化自在天。化乐天。兜率陀天。夜摩天。忉利天。四天王等。以怜愍故能救如是诸龙王苦。善住龙王言。是光明者。即是光味菩萨光明。以怜愍故救诸龙王苦。宝髻龙王言。是光明者。乃是出家剃除须发大德人光。以怜愍故救诸龙王苦。海龙王言。是光明者是如来光。何以故以怜愍故。如来世尊。于诸众生修一子想。能救众生一切苦恼。于无量世修行具足六波罗蜜。唯为救济一切众生无量苦恼。是故一切欲色界天。设大供具而供养之。尔时世尊告帝释言。憍尸迦。如我游此娑婆世界为化众生。如汝在于三十三天为度诸天。憍尸迦言。世尊。我今未有无边之智。云何说我能化诸天。世尊。是须弥山有无量天。无量梵天。无量鬼神。无量乾闼婆。无量紧那罗。无量迦楼罗。无量阿修罗。无量摩睺罗伽。无量诸龙。无量大仙。无量圣人。唯愿如来。以怜愍心化度如是无量众生。尔时世尊熙怡微笑。无量色光从其口出。青黄赤白玻璃杂色。遍照十方幽冥之处。胜无量亿梵天光明。无量亿数释天日月。能坏一切诸恶魔业。尔时世尊告帝释言。憍尸迦。娑婆世界所有诸山须弥为最。我亦如是。于诸众生最为第一。尔时一切龙王闻是语已各白佛言。世尊。唯愿怜愍救我等苦。佛言。诸善男子。汝等先当至心念佛。我当救之。尔时世尊告憍陈如。其音遍闻十方世界。憍陈如。一切诸法悉皆无常。一切诸法生住无常。何以故。生因缘故。一切因缘生法。即是苦也。若法生时即是苦。即是痈疮。即是有支。即是生老。即是生灭。憍陈如。眼即无常。若眼生者即是苦。即是痈疮。即是有支。即是生老。即是生灭。乃至意亦如是。憍陈如。若眼灭者。即是生老病死等灭。即是一切有支灭。乃至意亦如是。众生不知眼之生灭。是故流转在五道中。如来为断眼生灭故而演说法。亦为说苦断苦行法。是故如来是梵中大梵。天中大天。象中大象。是沙门中大沙门。婆罗门中大婆罗门。慈中大慈。悲中大悲。无上之尊为大丈夫。已到生死大海彼岸。最大福田无胜施主。其心平等为大法王。持大禁戒无上精进。善修梵行了知正道。为大导师通达余业。憍陈如。善知眼之生灭因缘故名如来。不了知故名为凡夫。云何不知名为凡夫。憍陈如。一切众生皆说有我。是故不见眼生灭相。轮转五道。憍陈如。有诸外道。说言见者名之为我。乃至知者是我。眼者即是我之因缘。乃至意者亦复如是。憍陈如。诸外道说眼喻于向。我者喻见。若如是者是名颠倒。何以故。所言见者即是和合。于和合中而生我想。是故颠倒。若言向喻于眼见喻我者。是义不然。何以故。向中见者。亦见亦闻。亦识亦触。眼不如是。是故见者不得名我。向虽久故见犹明了。眼若久故不得如是。我者名常。若我见闻我则无常。若无常者云何说我。憍陈如。众生以是颠倒因缘不见四谛。如来了是颠倒相故。名为正智。我者即是如来。若有能知如来我者。是人则能坏颠倒相。若坏颠倒则破魔业。若破魔业。是人则能救拔诸龙。憍陈如。是故我今能救诸龙大方等大集经卷第三十四

        随天竺三藏那连提耶舍译

    日藏分护持正法品第一

如是我闻。一时婆伽婆。在王舍城迦兰陀竹园。与大菩萨其数无量不可称计前后围绕。及余十方诸佛世界。无量无数不可思议阿僧祇。诸大菩萨声闻之众。地及虚空皆悉遍满。俱来集会前后围绕。复有十方无量世界帝释天王．梵天王．四天大王．诸大龙王．夜叉王．乾闼婆王．阿修罗王．迦楼罗王．紧那罗王．摩睺罗伽王。如是等无量无数不可称计俱来集会。复有欲界色界天龙．夜叉．罗刹．乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽等。皆悉一心瞻仰如来。尔时世尊为诸大众说虚空目安那波那甘露法门四无量已。默然而坐。娑婆世界地及虚空。一切大众亦皆默然合掌向佛。唯悕如来甘露法雨而无厌足。犹如重病思遇良医。如在大闇思见光明。如溺大河思登彼岸。如遭急难思求依护。如是遍满娑婆佛刹地及虚空诸大菩萨及诸声闻。释梵天王摩睺罗伽王。乃至人非人等合掌默然。瞻仰法王亦复如是。尔时众中有一大梵天王。名曰功德莲华光。已于昔日供养无量无边诸佛。于诸佛所殖诸善根。于阿耨多罗三藐三菩提得不退转。系心缘法善修慈愍。即从坐起合掌向佛而说偈言

  大圣神通力　　能速遍诸刹
  如心无所障　　光照十方国
  巧说奢摩他　　尽智及方便
  阿那波那念　　及四无量等
  佛于三界中　　生死际已舍
  净慧悉满足　　胜人天修罗
  已离于爱缚　　度疑到彼岸
  了知诸菩萨　　现证于佛法
  众生心乱故　　堕在生死河
  如盲无所见　　常为苦所没
  远离善知识　　不闻清净法
  轮回生死中　　为诸结所缚
  佛度生死海　　慈悲故说法
  为烦恼众生　　断生死罗网
  爱为烦恼本　　诸众生染着
  能仁巧分别　　令尽生死际
  以痴爱因缘　　不修诸功德
  若能断之者　　六根皆寂灭
  大慈牟尼王　　悲心为说法
  闻已除痴爱　　获甘露涅槃

尔时佛告功德莲华光大梵天王。而说偈言

  过去修诸度　　今亦如是行
  不乐声闻乘　　及辟支佛地
  复有诸众生　　数起嗔恚心
  及念二乘等　　是则为障碍
  以是诸障故　　退失于佛法
  不起是障者　　得佛法满足
  有四生众生　　俱来至此刹
  非唯爱欲身　　非尽念不净
  是中大智人　　能行菩提道
  已曾久修习　　定忍总持等
  能守护诸根　　正念加趺坐
  安住自境界　　佛当为汝说
  乐五众众生　　为说不净法
  令断于系缚　　七菩提分满
  我无嫉妒心　　怜愍故为说
  菩萨闻此法　　不舍菩提心
  十方一切佛　　已曾住此刹
  昼夜常加护　　令佛法久住
  汝等诸菩萨　　愍此刹众生
  常生欢喜忍　　令我法久住
  我说声闻法　　为断贪欲心
  示五阴诸入　　及十八界空
  十三奢摩他　　及毗婆舍那
  能断难断爱　　是人得清净
  显说无漏行　　声闻四真谛
  怜愍众生故　　为令法久住
  说此四谛法　　令度生死海
  复告诸菩萨　　汝等莫生疑
  佛当为汝等　　广说菩萨行

尔时此娑婆世界中。所有众生在佛会者作如是念。如来今者。欲说声闻法。不说菩萨道。十方世界诸来菩萨复作是念。如来慈愍欲令我等于此世界修诸禅行。使三宝种不断绝故。于此刹中所有天龙夜叉罗刹乾闼婆阿修罗乃至人非人等。未信者令信。已信者令增进故。欲令一切众生悉受安乐舍诸疑悔。满足涅槃八正道故。令此佛刹有大福德。具足熏修众善法故。十方世界所有众生作如是念。娑婆佛刹福德吉处。我今恭敬尊重供养礼拜彼佛刹中诸菩萨等。各作是念。我今应当于此世界结加趺坐。各各入于种种胜忍陀罗尼门及诸三昧。放大光明利益安乐诸众生故。作是念已。即于此刹加趺而坐。入于胜忍陀罗尼诸深三昧。是诸菩萨或有经于百大劫中修菩萨行。有得无生法忍乃至十地。具足修习十八不共四无所畏等诸功德法。各以胜忍陀罗尼诸深三昧因缘力故。放大光明。其中或有光。如灯炬野火之明。有如释梵诸天大梵王光。又如一日之光。二三四五如是转倍。乃至百千万亿日光。此诸光明遍照三千大千世界。其中众生遇斯光者。身心安乐皆大欢喜。如人热闷入清凉池。是光能除众生三恶道苦。饥渴寒热种种诸病。及贪嗔痴邪见等患。乃至能令三界狱中所有恐怖厄难众生。令尽苦际。是时此刹诸众生等蒙光力故。咸共深心恭敬供养。尊重赞叹佛法僧宝。厌舍诸恶勤修善法。从是诸光乃至遍照十方。如恒河沙等诸佛世界净秽等刹。有佛无佛皆悉普照。犹如重夜幽闇之中忽有百千万亿日光俱时普照。此及他方恒河沙刹土。光明遍照亦复如是。尔时十方恒河沙等诸佛世界。有诸菩萨摩诃萨等。承佛神力于一念顷来至此刹。各在一面结加趺坐。是诸菩萨或有已经百千大劫修菩萨行。或有乃至具足十地。皆悉修习十八不共四无畏等诸功德法。各以善根福德力故。入深三昧放大光明。遍照三千大千世界。其中所有魔王龙王乃至人天。诸光明等皆悉不现。尔时世尊告诸声闻四辈等众。汝今应知。此诸菩萨摩诃萨等。大善根力入于三昧放此光明。遍照三千大千世界。又彼十方诸佛如来。曾于此刹作佛事已。而还本国今共加护。此诸菩萨摩诃萨等。令入禅定现神通力。为令现在及未来世三宝久住不断绝故。以是菩萨神通光明因缘力故。令诸天龙．夜叉．罗刹．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人．非人等。未信者令信。已信者令增长。于正法中发大精进。如法修行自在无碍得不退转。乃至修学涅槃正道具足满故。是诸菩萨随所住处。于当来世是中皆应起立塔寺造作法堂。安置舍利经法形像。以种种七宝而修供养。所谓金银琉璃车磲马瑙颇梨真珠珂贝璧玉及上缯彩。种种衣服床榻卧具。种种幡盖袈裟法服。种种璎珞华香末香涂香烧香。作诸音乐礼拜供养。为令恐怖生死众生求涅槃道修功德故。尔时世尊作如是言。于未来世若有善男子善女人。于三宝所如是布施我悉受之。令彼众生于三乘中随其所乐得不退转。若复有人为供养故。或造一舍一僧伽蓝。经行之处布施园林。衣服饮食卧具床褥。种种汤药而供养之。或有建立讲读论堂经行禅室。于中布施奴婢田宅。象马车乘驼驴牛羊。种种诸物衣服卧具。及诸汤药资生所须。令持法比丘身心安隐。坐禅修道讲读论义。如法修行具足庄严。得胜自在涅槃道故。欲令佛法久住于世故。舍如是等种种诸物。我于尔时与诸菩萨及声闻众皆悉受之。若未来世有善男子善女人。为供养三宝故。能舍如是种种诸物。建立讲读论堂经行禅室。给其所须。我悉知见而生随喜。与诸菩萨及声闻众同共受用。何以故。为令是等得大果报。于三恶道得远离故。随其所欲于三乘中得不退转。乃至各于三乘而般涅槃故。又善男子善女人。以如是等种种诸物供养因缘故。于未来世当获二利。何等为二。一者法利。二者财利。随所生处资财具足宿习因缘故。是诸物不生悭吝悉能舍施。为欲供养比丘比丘尼优婆塞优婆夷故。随其住处。或在山林树下阿兰若处无愦闹声。堪可坐禅系念之处。建立塔寺房堂静室。随彼所须皆能给施。是比丘等受彼施已如法行故。天龙夜叉随其所在皆悉拥护

尔时佛告诸比丘言。汝等当知。十方诸佛已曾于此娑婆世界。入深禅定现大神通。破坏魔王及诸龙等。慈愍众生故演说妙法。为令三宝久住世间。各于此土作佛事已归还本国。尔时如恒河沙等诸佛世界。有无量无边阿僧祇菩萨摩诃萨。欲见于我礼拜供养。听闻正法及受持故。复为闻说虚空目修多罗四无碍法。各于他方来集此刹。慈悲怜愍诸众生故。入于禅定现大威力。破坏魔王及诸龙等。欲令此土诸众生辈供给供养施其所须修诸功德。于三乘中得解脱故。是未来世有善男子善女人。信心清净为欲供养如法修行诸比丘故。或舍家宅园林田地奴婢乃至资生种种所须

尔时若有破戒比丘。受他所舍乃至一华一果。是恶比丘以愚痴故。受他净心所施诸物获大恶报。于现在世得四恶报。何等为四。一者恶名远闻流布十方。二者父母师长兄弟眷属。奴婢亲戚皆悉离散。三者获大重病卧粪秽中。恶报。相现痛苦而死。四者衣钵坐具所有资财。悉为五家之所分散。是名四种恶报。于未来世复获四种大恶果报。何等为四。一者身坏命终堕大地狱。二者于地狱中久受勤苦。地狱终已复生畜生饿鬼道中。得无手足报。居在旷野无水之处。经百千万岁具受辛苦。三者从彼命终生毒蛇中。得无眼报经无量岁唯食于土。四者于彼命终得生人中。堕五浊世不值诸佛。于彼世中虽得人身。常无眼目亦无手足。住在旷野唯食世间所弃秽食恒不充足。不得与人同共住止。从彼命终复堕地狱。于三恶道难得免出。何以故。彼善男子善女人。净心舍施田舍园林衣服汤药种种诸物。唯欲供养如法比丘。然破戒者受他所施唯欲供身。不与如法持戒比丘。以是因缘获如是罪。又破戒者久处生死具受诸苦。虽得人身不值佛世。所以者何。诸佛如来不可思议难可值遇。彼破戒者。断灭法母不求精进。不用见闻佛法僧故。以是因缘不值佛世。彼恶比丘于当来世得如是等大恶果报

尔时大德伽耶迦叶。闻此语已悲泣雨泪而白佛言。世尊。如我解佛所说义者。宁处地狱具受众苦。终不受此破戒身也。所以者何。虽得此身而复出家。为衣食故具犯禁戒受他净施。获如是等种种苦恼。佛言迦叶。如是如是如汝所说。宁处地狱受种种苦。不受人身起如是等破戒罪业。何以故。地狱罪毕更不造新故。业尽已便于苦报而得解脱。迦叶。诸身之中人身难得。得人身已值佛出世复难于是。虽值佛世出家受戒是最为难。所以者何。得受戒已如法修行能尽苦际。断诸漏结而得解脱。是净信心善男子善女人。若刹利婆罗门毗舍首陀。欲供养净行持戒比丘。以其具足福德善根故。或舍家宅园林静室奴婢象马牛羊等物种种资生。以为常住僧业。令彼比丘身心安隐集善根故。是愚痴比丘毁犯净戒舍诸善根。远离静念专为非法。彼善男子等而不供养。以是因缘衣服卧具资生所须皆不充足。便作是言。我大智人堪可受彼所施诸物。或假檀越豪强势力。夺他如法比丘所受诸物。唯自供身以为私用。言是己有此非僧物。彼愚痴人造是罪故。于当来世受如是等诸恶果报

尔时频婆娑罗王白佛言。世尊。若善男子善女人。若刹利婆罗门等。欲供养如法比丘故。舍彼田宅园林种种诸物资生所须。是破戒者夺他所受唯自供己。以是因缘获如是等大恶果报。若在家人夺彼持戒行法比丘如是布施种种资生。而自用者。是诸人等得几许罪。佛言大王。不须问此得几罪报。王复白佛。若未来世有刹利等。以种种诸物施与持法比丘。以是因缘诸比丘等多有资生。是刹利婆罗门毗舍首陀。不信佛法及因果故又不畏罪。如是人辈夺而用者得几许罪。佛言大王。是诸人等夺他施故。当得无量大恶果报。若我具说重增彼罪。所以者何。是刹利婆罗门毗舍首陀。净心施彼行法比丘种种诸物。是比丘等多有资生。如是愚人犹彼痴驴。以不信故夺他所受种种施物而自供己。以是因缘故当得大罪。彼人若闻我说恶业差别种种果报。诽谤不信。如是愚人得二种罪。一者夺他所施。二者于我所说诽谤不信。时频婆娑罗王复白佛言。世尊。唯愿说之。唯愿说之。于当来世若刹利婆罗门毗舍首陀四种姓中。有信佛法深识因果怖畏罪者。闻佛所说初中后善义味甚深。纯备具足清净梵行。如是之人闻已能信。如法修行作诸功德。复为供养行法比丘故。舍种种诸物给其所须。若有破戒比丘及愚痴人。夺彼持法比丘如是种种所受诸物。彼信心人方便拥护持戒比丘。终不令彼侵夺欺陵。频婆娑罗王说是语已。佛言大王。善哉善哉。快说是语。大王。于当来世若有刹利婆罗门毗舍首陀。为欲供养行法比丘故。或舍田宅园林奴婢象马衣服卧具饮食汤药资生所须。若有刹利婆罗门毗舍首陀。以不信故夺他所施。而彼愚人于现身中得二十种大恶果报。何者二十。一者诸天善神皆悉远离。二者有大恶名流布十方。三者眷属知识违背乖离。四者怨憎恶人同共聚会。五者所有资财悉皆散失。六者心狂痴乱恒多躁扰。七者诸根不具。八者睡卧不安。九者恒常饥渴。十者所食之物犹如毒药。十一者所爱之人悉皆离别。十二者共事之人常多斗诤。十三者父母兄弟妻子奴婢不信其言。十四者所有隐密覆匿之事。知识亲友共相显露。十五者所有财物五家分散。十六者常遇重病无人瞻视。十七者资生所须常不称意。十八者形体枯悴。十九者久受勤苦难得免离。二十者常处粪秽乃至命终。大王。是愚痴人于现身中得如是等二十种诸恶果报。命终之后堕阿鼻地狱一劫受苦。饥食铁丸渴饮融铜。用热铁鍱以为衣服。行住坐卧所受之物皆是火聚。六方炽焰更相通彻。彼诸罪人于阿鼻地狱具受如是种种等苦。从彼命终生末伽车[馬*犬]饿鬼中。居在旷野无水之处。生便无眼。又无手足。四方热风来触其身。形体楚毒犹如剑切。宛转在地受大苦恼。脂髓膏流犹居热熬。魂神迷乱出大恶声。具受如是百千种苦经无量岁。然后命终生大海中受肉团身。其形长大满百由旬。然彼罪人所居之处。于其身外面一由旬。满中热水状若融铜。经无量百千岁受如是等种种苦恼。如地狱中等无差别。从彼命终于阎浮提旷野泽中忽然化生。形如肉团犹若大山。四方热风来烧其身。飞禽走兽竞来食之。经无量岁。尔乃命终还堕地狱。复经无量百千万岁备受众苦。然后命终生饿鬼中。乃至肉团之身。经无量百千岁。往反轮回具受众苦。其罪渐薄得出为人。生无佛国五浊刹中。从生而盲诸根不具。身形丑恶人不喜见。佛告频婆娑罗王言。大王。如是罪人于当来世。获如是等大恶果报。所以者何。是持法比丘如法行故。有信心者种种资财具足施与。彼恶比丘愚痴人等。夺而自用故获如是诸恶果报

尔时频婆娑罗王。闻此语已悲泣雨泪而白佛言。世尊。我今宁受地狱等身。终不欲受是人身也。何以故。以此人等造是罪故。获如是种种大苦果报。尔时佛告频婆娑罗王言。大王。汝等诸王及刹利婆罗门毗舍首陀聚落主等。如今现在及未来世乃至法住。于是时中所有持法比丘。付嘱汝等应好拥护。若有信心善男子善女人。为供养行法比丘故。或舍种种资生杂物。汝好拥护。勿令非法比丘及诸恶人欺夺侵陵。若有恶人欺夺如法比丘所受信施。汝等应当如法治之。王白佛言。世尊。若有国王见彼非法比丘及诸愚人夺彼行法比丘所受信施。不如法治者当得几许罪报。乃至刹利婆罗门毗舍首陀聚落主等。见此非法比丘及诸愚人侵夺行法比丘所受信施。当得几许罪报。佛告大王。我今问汝。随汝意答。除诸佛如来所有功德。一切声闻及辟支佛所有福德。若有一人具足成就如是等大福德聚。是人福德是为多不。王言世尊。如是如是。是人福德甚多甚多。佛言大王。如彼一人所得福德。如是一切众生各皆备足是等功德。若有恶人于彼一切有福人所。割其手足耳鼻生挑其眼。如是恶人得几许罪。王闻此语悲泣哽咽不能自胜。佛言大王。何以不答。时王闻已犹复悲泣。而白佛言。世尊。如是愚人所获罪报。无量无边阿僧祇不可称计。乃至算数譬喻所不能及。世尊。若毁坏一人具上福者。手足耳鼻生挑其眼。其罪大多不可思议。何况毁坏一切具是福者。佛言大王。如我现在及未来世乃至法尽。于其中间若有信心善男子善女人。俱舍如是资生所须田宅园林象马奴婢衣服卧具汤药等物。施与行法比丘。若非法比丘及诸愚人夺彼所施。是刹利婆罗门毗舍首陀聚落主等。见此非法恶人不如法治者。获大重罪复过于彼

尔时频婆娑罗王白佛言。世尊。如是国王治国之事。甚难甚难。何以故。彼放逸王等不如法治。是非法恶人获如是罪。若有国王及刹利等不放逸故。拥护是等持法比丘。若有信心檀越施彼所须。若有非法恶人侵夺欺陵。当如法治者得几许福。佛言大王。如上所说具福诸人。若复有人有大势力。禁闭狱中具受饥渴无量苦恼。若有一人具足大力。胜于前者出彼狱中。尔许诸人悉令解脱。经于百年四事供养。衣食汤药种种所须无不备足。佛言大王。彼有力人得几所福。王白佛言。世尊。彼有力人所得福德。不可思议不可称计。乃至算数譬喻所不能及。佛言大王。彼刹利婆罗门毗舍首陀及聚落主等。如今现在及未来世乃至法住。是诸人等如法治彼非法比丘及愚痴人故。所得福德复过于彼。若复有人于今现在及未来世乃至法欲灭时。若有信心善男子善女人。具舍种种所须施彼行法比丘。若有非法恶人侵夺欺陵。若复有人方便教化不令侵夺。语言。汝等今者。若不随教当治汝罪。如彼恶人随其教诲止彼欺心。不复侵夺持法比丘所受信施。是刹利乃至聚落主等。所得福德甚多甚多。王复白佛言。世尊。若有乃至一比丘能如法住所有诸物。若有恶人欺陵侵夺者。我等刹利及婆罗门乃至聚落主等。不如法治当获大罪。是一比丘所有资生。彼非法恶人有侵夺者。我等刹利乃至聚落主等。如法拥护不令彼人侵夺欺陵。乃至如法治之获大功德。佛言大王。不如汝所说。所以者何。于我法中有诸比丘。假令如法始从一人乃至四人。我不听受彼田宅园林象马车乘奴婢等常住僧物。若满五人乃可得受。若在僧伽蓝中或阿兰若处。持法比丘在中止住。鸣钟集僧和合布萨羯磨等事。房舍床榻卧具汤药同共受用。乃至百千众僧在一伽蓝若阿兰若处。鸣钟集僧和合布萨。房舍卧具衣服汤药同心受用。而不贪着亦不系念。不如其驎陀鸟贪着诸肉。食尽乃止终不中舍。持法比丘则不如是。初中后夜减省睡眠。精进诵经坐禅修道。背舍生死向涅槃路。如是比丘不称他短不说己长。谦下卑逊不自憍高。衣食知足头陀精进不放逸行。系念思惟心不驰散。于一切众生起慈悲心怜愍覆护。大王。如是僧中有劫夺者获大罪报。守护饶益得大功德。复次大王。随其所在若僧伽蓝或阿兰若处。有五比丘止住其中。持戒不破清净具足。乃至于小罪中生大怖畏。如佛修多罗中所说空行。若自读诵。教他读诵。不诽谤他不说他过。不称己长谦下自卑。不生憍慢嫉妒之心。慈悲怜愍一切众生。求解脱道出生死海。如是众僧。若在伽蓝或阿兰若处。鸣钟集僧和合受用。常住僧物乃至汤药。若复有人如法供养获大功德。劫夺侵陵得大罪报。大王。是五比丘。精进持戒惭愧具足。于小罪中生大怖畏。行头陀法住四圣种。如是众僧所有福德犹若大海。即是世间天人阿修罗中最上福田。能令一切众生离诸苦恼而得涅槃。何况十人二十三十乃至百千。若有信心刹利婆罗门毗舍首陀。为供养故鸣钟集僧。是僧集时其中或有非法比丘若多若少。共如法比丘同处集者于是众中乃至有五比丘。持戒清净具足惭愧。于小罪中恒生怖畏终不毁犯。如是众僧大修精进。弃舍世间所有诸事。惟希出世涅槃之道。所有功德无量无边。是大福田。应受世间天人供养。是故大王。汝等应好拥护如法安置。供给所须勿令乏少。若有非法之人欲相欺陵轻心毁辱者。汝好护持勿令是等侵扰之也。频婆娑罗王白佛言。世尊。我于今者欲有所问惟愿听许。佛言大王。随汝意问。王白佛言。世尊。若有破戒比丘。得与如法众僧和合共住。受彼上妙衣食卧具资生所须乃至汤药不。佛言大王。我今问汝。随汝意答。如王国中群臣百官乃至亲属。如是之人若一若二乃至众多。犯王国法合其重罪。王时嗔怒方欲刑戮。王于尔时设于大会。歌舞作乐欢乐集时。是犯罪人得在会次同食歌舞欢娱作乐不。王白佛言。如是之人不得在会。乃至不令与我相见。何况共受集会欢乐。佛言大王。如是如是。若有比丘破戒犯罪。实非沙门自言是沙门。实非梵行言我梵行。如是之人犹如盲人。于生死中流转退没。大王。如是之人于三世诸佛法中具犯禁戒。以是因缘诸佛如来之所弃舍。非佛弟子是魔眷属。常趣恶道不堕僧数。不得在如法僧中行住坐卧同受房舍卧具资生诸物。乃至糠[麩-夫+孚]亦不得受。何况得受众僧上妙供具资生所须。如是之人佛法之外众所弃舍。频婆娑罗王白佛言。世尊。是破戒比丘不得与如法众僧和合共住同受种种衣食卧具汤药等物。世尊。是破戒人有何等行类相貌而可得知。佛言大王。是破戒相初未现时难可了知。何者是破戒初相。所谓不乐供养三宝和尚阿阇梨。亦不信重四圣种法而不修习。又不修行三十七助道法。是名破戒初相。心贪利养无有惭愧。与诸俗人以为亲友。称赞己德以自贡高。轻蔑诽谤毁呰他人。心不乐说正法之言。唯喜好谈无益之语。专行魔业恼乱众僧。他说一言十语加报。纵心荡逸终不相下。犹如恶狗。复似飞乌众声乱鸣唯欲求胜。虽复出家处在众中。谄曲虚伪专行刺毒。又如商人持种种物在道而行逢彼恶贼。是破戒人为沙门中贼。又似猕猴粪涂身已搪突于人。在于众中犹如俱兰吒华无色无香。心不和合恒出诤讼之言。常贪利养名闻等事。乐恶比丘及诸俗人以为伴侣而共谈语。是诸比丘乃至未盗众僧田宅园林奴婢象马驼骡牛驴。如是等物难可了知。是名破戒初相。若盗如是等物是名破戒等相。是相出已失比丘法。是波罗夷非沙门。不得与如法众僧同共止住。应当摈出。众告大王。是持戒比丘。宁与旃陀罗同共止住。不与破戒之人同住居止。如树枯朽火从内起。根本既烧枝叶亦尽。破戒比丘亦复如是。以破戒火烧诸功德。善根果报悉尽无余。于未来世堕三恶道。远舍慈悲而行魔业。譬如厕溷不可为净。谤诸贤圣断三宝种。法海干竭坏正法城。诳惑施主恼乱清众。如法比丘僧和合时违诤不随。彼破戒比丘盗僧物因缘故。国主刹利婆罗门毗舍首陀乃至若男若女一切施主等。虽舍所须空无所得。失人天路堕恶道中。是故大王。汝等当知。彼破戒人无有惭愧。以劫盗心取彼僧物以为己有。是如法比丘随其住处。若在林中或在伽蓝。不应共住应生慈愍。方便示教遣令出众。语言。长老汝等不应住此。如是三谏。是破戒人若去者善。若不出众如法比丘不得嗔骂。应告国王刹利婆罗门毗舍首陀及有势力者言。此有比丘不如法行恒相扰乱。不令我等安心行道。惟愿捡挍勿令侵恼。而彼国王刹利乃至聚落主等。应当治之驱逐令出。若彼刹利王等取彼破戒比丘饮食财物而不驱遣者。如法比丘亦不应嗔。莫贪住处及资生等。默然舍去更求余处无难之所。若在山林窟中。或阿兰若地。随其静处就彼而住。频婆娑罗王闻此语已。悲啼号泣而白佛言。世尊。刹利婆罗门毗舍首陀乃至聚落主。为衣食资财故护彼破戒比丘与其势力。令此如法比丘舍其住处。以是因缘于当来世堕大地狱受无量苦。于三恶道轮回往反难得免出。于未来世有无量无边恒河沙等诸佛出现于世。具大慈悲入生死中度苦众生。而不能令彼等国王刹利婆罗门及聚落主舍恶趣报得人天身。何以故。不受如法比丘语故。又不供给供养故。受如是等大罪果报。佛言大王。于当来世诸国土中有信心刹利婆罗门毗舍首陀。为供给供养如法比丘因缘故。若造伽蓝静处。或阿兰若处起立房堂。施与如法比丘。或舍田宅园林奴婢种种所须资生杂物乃至汤药。以如是供养因缘故。彼诸施主于当来世。或生刹利婆罗门大姓等家。六欲诸天乃至有顶。或生他方净佛世界值佛闻法。不久当得阿耨多罗三藐三菩提。若复有人于我法中。为求福德涅槃道故。应当供养供给如法比丘。尔时频婆娑罗王白佛言。世尊。是诸比丘虽犯破戒初相。然未盗僧物。如是之人。云何不得与如法比丘同共住止同饮食衣服等和合受用。佛言大王。我今问汝。随汝意答。若王眷属大臣宰相。犯王国法造种种罪。唯不合死有刑流者。如是之人。王若设会歌舞作乐大集之时。得在会次同受饮食共欢乐不。王白佛言。世尊。如是之人尚不欲见。何况得在会所同受欢乐。尔时佛告王言大王。若有富伽罗具造诸恶。于三恶趣不能勉离。如是之人受他田宅园林象马车牛资生之具。如此之人非佛弟子。非沙门非释子。于三世佛法中是大罪人。不得与行法比丘乃至和合少时共住同受衣服卧具饮食汤药。若有刹利婆罗门毗舍首陀及聚落主等。见破戒人与持法比丘同住共受衣服等物而不驱遣。彼刹利等。是三世诸佛正法之中为大罪人。如是刹利婆罗门等。若不驱摈彼恶比丘。虽复更修功德种种布施。欲免此罪终不能灭。要必当堕阿鼻地狱。是故大王。若有欲得自利利他者。于彼破戒人所不应拥护。何以故。若有供养彼恶比丘。失人天善根断三宝种堕诸恶趣。若刹利婆罗门等。拥护行法比丘。不令彼恶比丘与共同住和合受用衣服饮食。是刹利等虽不布施修余功德。即是三世诸佛之大檀越。能持三世诸佛正法。是人命终生于他方净佛国土。不久当得阿耨多罗三藐三菩提。是故大王。汝等刹利婆罗门等。应当拥护供养供给行法比丘。乃至法欲灭时所有如法比丘。应当拥护供养供给。以是因缘能令三宝久住不灭。若不拥护如法比丘我法即灭。若法在世能令人天充满恶道减少。王言世尊。有何等人堪为知事守护僧物。供养供给如法比丘。佛言大王。有二种人堪持僧事守护僧物。何者为二。一者具八解脱阿罗汉人。二者须陀洹等三果学人。此二种人堪知僧事供养众僧。诸余比丘。或戒不具足。心不平等。不令是人为知僧事

大方等大集经卷第三十四大方等大集经卷第三十五

        隋天竺三藏那连提耶舍译

    日藏分陀罗尼品第二之一

尔时世尊共频婆娑罗王说是法时。东方过无量无边恒河沙等诸佛国土。有佛世界名无尽德。佛号瞻波迦华色如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。于今现在常说妙法教化众生。彼有菩萨名日行藏。仰观虚空见有无量无边阿僧祇菩萨摩诃萨众从东方来往趣西方。复见西方有大光明。是等菩萨寻光而去。尔时日行藏菩萨见此事已。即从坐起顶礼佛足。恭敬合掌白佛言。世尊。我见空中无量无边恒河沙等诸菩萨众。从东方来往向西方。复见西方有大光明。以何因缘有此大光。诸菩萨等寻光而去。尔时瞻波迦花色佛告日行藏菩萨言。善男子。西方过无量无边恒河沙等诸佛世界。彼有世界名娑婆具足五浊。其国有佛名释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。于彼世界召集大众。以方便力广说三乘。论议法门教化众生。为令法母久住故。为令三宝不断绝故。为令法行常住故。为令魔王失势力故。为建立法幢故。为令正法久住故。以是因缘诸菩萨等集彼世界。十方诸佛已于彼处说宝幢陀罗尼竟各还本土。今释迦牟尼佛。复于彼界为诸菩萨摩诃萨大阿罗汉一切大众。演说三乘四无碍智四梵天行及四摄法。娑婆世界地及虚空大众充满。咸皆渴仰乐闻佛说。何以故。彼佛如来所说妙法犹如甘露。一切听者心无厌足。又以彼佛本愿因缘。十方佛刹诸菩萨众皆集其土。彼诸菩萨或有百劫修行者。乃至一生补处者。有于十八不共法中自能修习不由他悟者。有得自在无碍智慧方便具足者。是诸菩萨既集彼已一切皆坐。以自善根方便力故入于三昧。入三昧已身放光明。有菩萨光如一灯者。有如山上烽火者。有如一日十日百日千日光者。有如无量千万日光明者。以彼菩萨力故。于大集所遍覆三千大千世界。为欲令彼娑婆世界福德庄严。四大滋味地转增胜。众生受用增益身力。得四念处得大精进。远离悭贪能行布施。如净佛刹诸众生等以是因缘诸菩萨众各各端坐。以自善根力入诸三昧放大光明。复有十方诸佛刹中菩萨摩诃萨未来集者。从禅定起见大光明。亦欲往诣娑婆世界。见释迦牟尼佛及大集众。恭敬礼拜听受妙法。欲闻日藏法行坏龙境界焰品一切众生恶业尽陀罗尼故。诸菩萨等欲集彼处。以自善根力入种种三昧。汝今亦可从禅定起诣彼世界。善男子。彼佛世界诸众生等。有种种恶多诸渴爱。为诸烦恼之所系缚。犹如厕猪乐处不净。诸女人等身体丑陋自谓端正。犹如醉人不自觉知。种种臭秽自言清净。两舌恶口远离实语。常乐淫欲行非梵行。实大愚痴现智慧相。心大悭贪现能施相。心怀谄曲虚幻不实现质直相。于他善事心生妒忌。口言赞美心怀嗔嫉现慈忍相。常乐破坏现和合相。邪见偏多现正见相。彼土众生有得禅定获身通者。或有具足得五通者。或有久修四禅定者。如是智慧丈夫为诸女人之所惑乱。心随染着为欲所使犹如僮仆。于一念顷退失是等诸妙功德当堕恶道。以诸女人恶因缘故得如是罪。善男子。彼佛世界有如是等种种诸恶。汝今颇能往彼国不。我欲与欲。善男子。彼释迦牟尼佛。说日藏法行坏龙境界焰品尽一切众生恶业陀罗尼。我今说欲。所谓四谛顺忍陀罗尼汝可持去。此陀罗尼有大势力有大利益。能除一切欲贪色无色贪。能除我慢大慢增上慢。能除一切不净资生。能除一切恶贪种种戏笑及诸歌舞无利益事。能尽一切我见。一切边见一切疑。一切戒取。一切常见。一切断见。一切众生见。一切障碍见。一切逋沙见。一切富伽罗见。一切作者见。一切受者见。一切色见。一切声见。一切香味触见。一切四大见。一切生见。一切灭见。一切法见。此四谛顺忍。能如实知色阴乃至识阴。能知十二入十八界。知已能舍。此陀罗尼能照诸法。悉能现见诸涅槃道。何以故。彼界众生甚大愚痴如生盲人。此四谛顺忍一切法常住藏不可思议法门。能断一切恶见。能得一切自在。能破魔王境界及魔伴党。能破魔事及他境界。悉能降伏一切外道。能怖一切诸恶毒龙。能令一切诸天欢喜。能令善夜叉皆得安隐。能怖诸恶阿修罗迦楼罗。能令紧那罗心生欢喜。能令摩睺罗伽生大怖畏。能令刹利生大信心。能摄婆罗门令住佛法。能令毗舍生大信心。能令首陀罗生欢喜心。能断一切妇人贪欲。令多闻人生大欢喜。令坐禅人心得安隐。能却一切种种恶事及诸斗诤。能除饥馑及夭横死。能除外贼恶风恶雨恶兽瀑水非时寒热枯涩苦辛恶草等物。能令法母常住不断。能建三宝。佛法欲灭生大怖畏能令不灭。怖畏众生能施无畏。能生尽智觉无生智。能破一切无明闇障。能除一切生死苦担。尔时世尊即说咒曰

[口*寫]绖咃(一)婆裔婆野波履婆隶(二)婆醯婆诃波履婆隶(三)必利洟(他地反)仳必利洟(他地反)鼻波履婆隶(四)阿捭阿跛波履婆隶(五)低誓低[禾*土]波履波隶(六)末隶末逻波履婆隶(七)却偈(其隶反)却伽(其个反)波履婆隶(八)阿卢翅阿卢迦(其可反)波履波隶(九)萨他迷(芒闭反)萨他么波履婆隶(十)曷罗誓曷罗(厘可反)[禾*土]波履婆隶(十一)徙隶徙逻波履婆隶(十二)伽迷伽么波履婆隶(十三)阿蒱婆阿蒱婆波履波隶(十四)罗么罗罗么(十五)罗谜(芒闭反)罗么(十六)曷罗剆(勒可反)曷罗逻(十七)何啰罗何啰罗么(十八)[月*坒]踏[(口*皮)/女](蒱么反)攘娜复[多*頁](登我反十九)伽逻弥复[多*頁](登我反二十)揭逻磨波履婆隶(二十一)斫刍揭逻醯斫刍揭逻诃波履婆隶(二十二)输嚧呾啰揭逻醯输嚧呾啰揭逻诃波履婆隶(二十三)伽罗娜揭逻醯伽罗娜揭逻诃波履婆隶(二十四)什婆揭逻醯什婆揭逻诃波履婆隶(二十五)迦(居佉反)耶揭逻醯迦耶揭逻诃波履婆隶(二十六)么娜揭罗么那揭逻诃波履婆隶(二十七)馺跛曷利舍揭逻醯馺跛曷利舍揭逻诃波履婆隶(二十八)鞞[多*頁]娜揭逻醯鞞[多*頁]娜揭逻诃波履婆隶(二十九)怛履瑟那揭逻醯怛履瑟那揭逻诃波履婆隶(三十)忧波陀那揭逻醯忧波陀那揭逻诃波履婆隶(三十一)婆[(口*皮)/女]揭逻醯婆[(口*皮)/女]揭逻诃波履婆隶(三十二)阇帝揭逻醯阇帝揭逻诃波履婆隶(三十三)[禾*土]啰摩啰娜揭逻醯[禾*土]啰摩啰娜揭逻诃波履婆隶(三十四)独佉珊多跛揭逻醯独佉珊多跛揭逻诃波履婆隶(三十五)阿啰波逻蹋陛[禾*土]揭逻醯阿啰波啰蹋陛[禾*土]揭逻诃波履婆隶(三十六)阿跋[多*頁]鞞婆[多*頁]写(三十七)阿跋啰摸跛么娑卸(思夜反)鞞也(三十八)毗尼跋阿利(三十九)弥也曷啰舍(四十)萨鞞伽羯帝莎波诃(四十一)

善男子。此日藏法行坏龙境界焰品尽一切众生恶业陀罗尼欲四谛顺忍。汝可持往娑婆世界。问讯释迦牟尼佛作如是言。东方过无量恒河沙佛刹。彼有世界名无尽德。佛号瞻波迦华色多陀阿伽度阿罗诃三藐三佛陀。今现在说法。彼佛如来令我送欲并问讯释迦牟尼佛。少病少恼气力安乐。及诸弟子悉安隐不。闻佛说法如教行不。彼释迦牟尼佛已能破坏一切魔王境界一切龙王境界。独超众圣转妙法轮。但彼五浊诸恶众生障碍未尽为是等故我今说此日藏法行坏龙境界焰品一切众生恶业尽陀罗尼欲。此四谛顺忍陀罗尼有大威德。若有人能受持读诵得大势力。尔时日行藏菩萨摩诃萨作如是言。我已受持此陀罗尼得大势力。能向彼国具足宜说。但彼世界有诸恶事我甚怖畏。何以故。我向亲闻佛口所说。彼土众生多诸贪欲如生盲人。诸女人等多诸奸谄诳惑于人。实不端正自言端正。实大愚痴现智慧相。能令众生迷没贪着。乃至久修禅定得五神通。诸智慧人于一念顷。为诸女人之所惑乱。退失是等神通智慧一切善根。堕大地狱。彼诸众生有如是事故我怖畏。时瞻波迦花色佛闻此语已。告日行藏菩萨言。善男子。汝今不为自身得力自身安乐。当为利益一切众生故往彼宣说

尔时瞻波迦花色佛。告日行藏菩萨言。善男子。彼娑婆世界释迦牟尼佛大集众中。有一优婆塞名毗摩罗诘。是汝身不。时日行藏菩萨默然不答。尔时世尊复更问言。善男子。何故默然。如是三问然后乃答。作如是言如是如是。我于彼刹为欲教化诸众生。故名毗摩罗诘。彼诸众生皆谓。我是优婆塞毗摩罗诘世尊。我于无量阿僧祇诸佛刹中。为化众生作种种身。或于余刹作梵王身。或作帝释。或作炎摩．兜率．化乐．他化自在天王等身。复于余刹。或作龙王．阿修罗王．迦楼罗王．紧那罗王．摩睺罗王如是等身复于余刹或作声闻辟支佛身。或作人王．刹利等身．婆罗门身．长者身．女人身．童男身童女身。复于余刹或作畜生身．饿鬼身．地狱身。世尊。于此刹中有八十百千诸菩萨等。同众禅定行住坐卧未曾舍离。是等菩萨见我欲往娑婆世界皆乐随从。欲见释迦牟尼佛及大集众。礼拜供养并欲听法。而诸菩萨有初行者其心未定。而彼世界多诸恶事。是等菩萨或生贪染。恐于彼处近恶知识心生颠倒。我甚怖畏。尔时瞻波迦华色佛。告日行藏菩萨言。善男子。勿怖勿畏。今为汝等一切菩萨说离受不共行。法无相处行。调伏地行。解脱之行。到有海岸行。三宝性久住不尽行。大慈大悲行。一切智解脱行。坏四种魔降外道行。尽智无生智行。尽一切作业一切寿命阴行。善男子。今为汝说日眼莲华陀罗尼。此陀罗尼能令众生厌离生死三有牢狱。得无相三昧解脱门苏息处。得无相三摩跋提。舍最后一念身智而入涅槃。善男子。若有人能一心听受此日眼莲华陀罗尼。是人所有一切贪欲及诸烦恼皆悉微薄。舍身之后七返生天得宿命智。不为欲染而得圣道。一切诸天皆乐供养。天上寿尽复得七返生于人中。虽处欲界不为欲染。即于人中得成圣果。常为一切礼拜供养。善男子。若有得闻此陀罗尼。乃至七遍一心善听者。此人命终七返生天。获得五通为诸天师。一切诸天皆悉礼拜恭敬供养。天上寿尽七返生人。得五神通为人中圣师。一切天龙夜叉乾闼婆阿修罗等皆悉供养。善男子。若有人能于天众中。七遍宣说此莲华陀罗尼。一切诸天及天女等能一心听。皆离五欲乐修禅定。若有人能于国王所或刹利婆罗门毗舍首陀等众中。七遍宣说此陀罗尼。如是等众能善听者即得出家。若有女人得闻此咒一心善听。七日七夜不念余事专心诵持。舍此身已得转女身。随所生处能薄贪等一切烦恼。于阿耨多罗三藐三菩提无有退转。乃至得证大般涅槃。终不更受女人之身。除化众生自愿受身。善男子。若有诵此莲华陀罗尼七遍。咒诸药草用涂鼓贝。若打若吹随其音声所至之处。一切咒咀一切厌蛊。一切毒药一切符书。一切谄缚淫欲烦恼不能为害。善男子。我今说此大力日眼莲华陀罗尼。即说咒曰

多绖他(一)徙陀么帝(二)毗卢迦(基我反)么帝(三)咽隶(四)羁(居离反)[多*頁](丁可反)矣利师(五)沤制(六)苏楼沤制(七)佛地(徒纸反)毗佛地(徒纸反八)摩诃佛地(九)郁奴摩提(十)郁奴摩爹(徒娜反十一)钵剆底筛(疏皆反)达腻(十二)阿罗伽摩芦婆(十三)阿啰伽度芦婆(十四)钵剆底筛达腻(十五)频豆频豆么底(十六)质吒质吒钵剆底筛达腻(十七)頞勒羁(居离反十八)旃陀罗提(十九)呵呵(虎我反)质[木*郅](竹几反二十)诃[多*頁]腻弭(二十一)诃[多*頁]迦(基我反)么鞞只(基犁反二十二)诃[多*頁]富娜曷啰婆[(口*皮)/女](二十三)曷啰栘(社奚反二十四)诃[多*頁]斫三刍(二十五)摩帝(二十六)诃[多*頁]毗么[多*頁]佛地(徒纸反二十七)诃[多*頁]夜奇离(二十八)诃[多*頁]毗三么揭离(二十九)诃[多*頁]三姥爹啰社裨(三十)诃[多*頁]鞞么[多*頁]曷啰誓(三十一)诃[多*頁]咥(呼旨反)[口*戒](呼计反三十二)诃[多*頁]者者帝(嘲隶反三十三)诃[多*頁]达么曷啰誓(三十四)诃[多*頁]蒱呼曷啰誓(三十五)诃[多*頁]跛社么帝(三十六)诃[多*頁]嚧伽曷啰舍弥(三十七)诃[多*頁]达么徒蜜帝(三十八)诃[多*頁]萨婆优波陀娜(三十九)若(如者反)茹若(如者反四十)毗社树竖(四十一)毗者社若若(如者反四十二)娑罗末伽(其我反)若若(如者反四十三)咽沙案[多*頁](四十四)娑啰伽(其我反四十五)独[敲-高+(立/(可-一))]莎波诃(四十六)

善男子。此日眼莲华陀罗尼能干一切欲河能出一切苦海到于彼岸。汝当至心持此陀罗尼往彼世界。如从我闻至彼说之。何以故。彼佛世界有百千万种种魔事咒药蛊道。能怀众生所有善法。汝等若诵此陀罗尼。一切魔王内外眷属所作种种无量恶事。及上妙五欲不能侵恼。何况余人鄙陋秽欲而能为害

尔时日行藏菩萨。与无量千万亿那由他诸菩萨等及无量百千那由他诸天及人白佛言。世尊。如来功德智慧辩才不可思议。大不可思议。最大不可思议。我等昔来未曾得闻如是坏欲大陀罗尼。说此语时众中八万四千天女。至心听受生大信心恭敬供养。即转女身得男子身。于阿耨多罗三藐三菩提得不退转。尔时瞻波迦华色佛。捉瞻波迦花鬘。告日行藏菩萨摩诃萨言。善男子。持此华鬘并日眼陀罗尼四谛顺忍陀罗尼。往彼世界供养释迦牟尼佛。此陀罗尼有大势力犹如电光。速能破坏一切欲事。能大利益能尽一切欲贪。乃至能除一切苦担。汝可持去问讯释迦牟尼佛。时日行藏菩萨于彼佛所默然受之。尔时众中八万菩萨。俱白佛言世尊。我等皆往彼娑婆世界。见释迦牟尼佛及大集众。礼拜供养听受妙法。佛言善男子。随汝意去。咸可一心作梵天像。形色长短威仪服饰往彼世界。尔时日行藏菩萨及无量百千那由他诸菩萨等。皆作大梵天像。形色长短威仪服饰等无有异。作此化已顶礼佛足。右绕三匝绕已复礼。礼已于彼界没。如一念顷即至娑婆世界。初入娑婆世界即以瞻波迦华。散释迦牟尼佛积至于膝。如是渐行往诣佛所。到佛所已顶礼佛足却一面立。当尔之时释迦如来。犹为频婆娑罗王宣说法行

尔时南方去此娑婆世界。譬如有城方一由旬沙满其中。复有一人具大神力。担负而行尽一世界乃下一沙。过是数已有佛世界名袈裟幢具足五浊。佛号山帝释王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。于彼众中有菩萨摩诃萨名曰香象。仰观虚空见无量无边阿僧祇菩萨摩诃萨众从南方来往诣北方。又见北方有大光明。见此事已。问山帝释王佛言。以何因缘诸菩萨等从南方来往诣北方。尔时山帝释王佛告香象菩萨言。善男子。北方过一由旬城沙满其中。从是北行。一沙为一世界。过是数已有佛刹土名曰娑婆。具足五浊有佛号释迦牟尼。于今现在为无量大众。以方便力广说三乘论议法门。为教化众生故。为令法母常住故。三宝性不断绝故。增长法行故。坏魔境界故。建立法幢故。十方诸佛已于彼刹说宝幢陀罗尼竟各还本土。今释迦牟尼佛复为诸菩萨摩诃萨大声闻众。宣说妙法。娑婆世界地及虚空。大众充满间无空处乐闻佛说。何以故。彼佛如来所说法要。言辞美妙犹如甘露。一切听者心无疲厌。善男子。汝能往彼娑婆世界听受法不。我今亦欲与彼佛欲。并说随顺空忍陀罗尼。此陀罗尼有大势力能大利益。能尽一切欲贪一切色贪一切无色贪。能尽一切我慢大慢增上慢。能生尽智能觉无生智。能裂一切无明闇障。能舍一切苦担。尔时世尊而说咒曰

哆绖他(一)头摩帝头摩帝(二)恶踦(躯宜反)头摩帝(三)钵啰娑婆头摩帝(四)萨婆迦头摩帝(五)阿鞞却伽(其我反六)培鞞娜却伽(七)碎(苏骨反)朱却伽(八)阿[(口*皮)/女]摸诃却伽(九)阿娜涅也却伽(十)毗耶佛履帝却伽(十一)僧迂喽者却伽(十二)阿泥么却佉(十三)卢者那却伽(十四)尸弃却伽(十五)毗底(都履反)寐啰却伽(十六)郁刍么却伽(十七)坞啰却伽(十八)恶攲却伽(十九)耶婆么那却伽(二十)尤喽跛却伽(二十一)耶婆毗娘那却伽(二十二)斫刍陀妒却伽(二十三)耶婆么娜毗娘那陀妒却伽(二十四)必利洟陛(蒱比反)陀妒却伽(二十五)耶婆毗娘娜陀妒却伽(二十六)靼埵(都和反)履悉蜜驻跛萨他娜却伽(二十七)耶婆阿虱吒达奢阿鞞尼迦佛陀达摩却伽(二十八)独佉却伽(二十九)耶婆磨勒伽却伽(三十)毗婆哪毗[踣-口+(可-一)][(口*皮)/女](三十一)阿那娜娜(三十二)阿陛(蒱比反)娜娜(三十三)三姥陀剆娜娜(三十四)萨婆迦啰娜娜啰(三十五)萨婆僧萨他娜毗瞿跛娜娜(三十六)阿紧(吉因反)若(女我反)柘娜娜(三十七)叉(初诈反)婆叉(初诈反)[(口*皮)/女](三十八)伊犁伊儸(三十九)伊犁伊罗(四十)寐利莎波诃(四十一)

善男子。是名顺空陀罗尼。汝可持往娑婆世界教化众生。问讯释迦牟尼佛。尔时香象菩萨作如是言。我已受持此陀罗尼。得大势力得大利益。今欲往彼唯有一事心生怖畏。何以故。我亲从佛闻彼土众生多诸恶贪。乃至女人谄诈弊恶。令久修禅得五神通智慧之人于一念顷退失神通及诸功德。堕大地狱。故我今生怖。尔时山帝释王佛告香象菩萨言。善男子。譬如雪山以十三因缘。令虚空中有清凉风。以冷风故热恼皆除。一切河水悉皆清凉。善男子。如是久学无生忍智慧菩萨。以十三因缘防护身心。不生烦恼六根无热。不为无明河之所漂流。智慧之人能为愚人说无众生等法。令离痴缚除五阴重担。善男子。汝以十三种因缘。久学无生忍。何故而言我今怖畏。汝于余界或作梵天身教化众生。复于余刹或作摩醯首罗身教化众生。复于余刹或作帝释身教化众生。复于余刹或作那罗延身教化众生。复于余刹或作天身教化众生。复于余刹作夜叉身教化众生。复于余刹或作龙王身教化众生。复于余刹或作阿修罗王身教化众生。复于余刹或作转轮圣王身教化众生。复于余刹或作大医王身教化众生。复于余刹或作刹利身教化众生。复于余刹或作婆罗门身教化众生。复于余刹或现声闻身教化众生。复于余刹作大臣身教化众生。复于余刹作辟支佛身教化众生。如是无量刹中以种种色身。现化众生而作佛事。云何方言。我今怖畏。善男子。勿生怖畏。今为汝说无尽根大受记持心法行。一切智智坏四魔行。三宝久住行。坏一切毒龙境界行。尽一切众生恶业行。大慈教化众生行。大悲淳至入三恶道救拔众生行。于一切众生作欢喜心行。断一切众生恶见恶爱恶愿恶乘行。解脱一切众生地狱行。断一切女身得丈夫身行。说一切法阴无有尽行。断一切众生悭嫉行。得一切三昧神通无尽行。摄一切众生安置菩提道行。舍声闻辟支佛乘行。乃至说得无上最胜涅槃行。善男子。若有众生闻此无尽根授记法行生信乐者。彼人所有无量生死。恒沙业障众生障法障烦恼障。能障一切善根。未受未尽未吐者。如是等业皆悉灭尽。不受罪报不生恶处。唯除三事。何者为三。一五无间。二谤正法。三谤圣人。此三种罪必定受报。善男子。若有众生乃至一念。闻此无尽根受记陀罗尼。能至心听信受忆念生尊重者。彼人所有恒沙罪业不受果报。常乐修行一切善根。若行檀波罗蜜时。十方诸佛一切菩萨辟支佛大阿罗汉。皆以神力加护。是人得圣加故多饶财宝。以用布施不可穷尽。乃至能舍头目髓脑。远离嫉妒得平等心。于一切田心无优劣。亦复不见我能行施彼为受者。作是施时一切天龙鬼神阿修罗夜叉乾闼婆等不能为障。唯除三种。所谓五逆。诽谤正法。毁呰圣人。此三种罪。一切圣人神力不加故有障碍。若行尸波罗蜜时。常勤精进住忍辱中。得欢喜心得随顺心。怜愍众生犹如一子亦如己身。常为一切圣人之所赞叹。常为诸天释梵四王龙神夜叉人非人等。刹利婆罗门毗舍首陀。礼拜供养得圣力加。心不自高亦不毁他。亦复不乐多积衣食。趣得支身心无忧恼。于一日夜六时自省。卧觉安隐无多恼患衣食丰饶。于一切众生慈悲不舍。随心所念皆悉不空。临命终时得见诸佛。一切诸佛皆赞叹言。善哉善哉大丈夫。善能持戒清净不破。善来将汝往诣清净佛刹。令汝得住十地位中。彼人见佛得清净心得欢喜心。心欢喜故。舍身则得往生净国速得十地。不久即得阿耨多罗三藐三菩提。乃至一念闻此无尽根受记陀罗尼得如是利。是菩萨若学行羼提波罗蜜时。一切圣人神通力加令得法忍。不见众生不见彼不见此。若有人来截其手足割其耳鼻。乃至不起一念嗔心。离嗔心已。一切天王一切人王。礼拜供养。乃至速得阿耨多罗三藐三菩提。是菩萨若学行毗梨耶波罗蜜时。得无患身成就大力。壮健智慧精进勇猛。能行四摄布施爱语利益同事教化众生。具四摄已。一切天王龙王夜叉王阿修罗王迦楼罗王紧那罗王摩睺罗伽王人王。合掌烧香恭敬礼拜。是人名闻流布。常为一切人天之所爱念。乐欲见之常欲拥护。乃至速得阿耨多罗三藐三菩提。是菩萨若学禅波罗蜜时圣人加故。得四禅四空三摩跋提。乃至千万三摩提门。陀罗尼门忍门。常为一切诸佛所念。常为一切天王人王。拥护爱念恭敬拜礼。乃至速得阿耨多罗三藐三菩提。彼菩萨若学般若波罗蜜时。常为诸佛菩萨阿罗汉辟支佛之所拥护。心得安隐远离愦闹得胜法念心心数。成就得圣人智慧根。具足入一切法中。所作已办度疑网河。于一切法不生疑碍。一切天人阿修罗所不能坏。常为天人八部。供养恭敬爱念守护。闻名见形皆生欢喜乐欲亲近。若自供养若教人供养。此人临终见十方佛。一切诸佛皆悉授手。赞言。善哉善哉大丈夫。善来将汝往向我清净佛刹。令汝得住十地位中。是人闻已得欢喜心。心欢喜故命终即得生佛净土。生已速得住于十地。不久即证阿耨多罗三藐三菩提。善男子。此无尽根大授记陀罗尼。有如是大力如是大利益。汝当受行。往彼世界不应怖畏。善男子。释迦牟尼佛本所誓愿。若有众生造作五逆谤方等经毁呰圣人犯波罗夷。如是之人清净佛刹所不容者。皆生我国我当教化。以是因缘诸恶众生悉集其国。善男子。若彼世界诸恶众生。闻此无尽根大授记陀罗尼。能于七年常行慈心不动心怜愍心平等心。远离两舌不恶口不妄语不绮语。如是昼夜常念诸佛。当净洗浴昼三夜三。整衣服右膝着地。合十指掌对十方佛前。念无尽根大授记陀罗尼。一心诵者彼人经七年已。所有诸难极重罪业皆灭无余。若有女人欲求自在。能于七月昼三夜三。如前念此无尽根大受记陀罗尼。一心诵者如是女人随所生处得大自在。于流转中更不复受女人之身。乃至得阿耨多罗三藐三菩提唯除自愿。若有女人求好夫主。求好种姓。求大自在求不用男女。或愿多有男女者。应当澡浴清净着净洁衣。独处闲静昼三夜三。右膝着地合掌向佛。一心诵念此无尽根大授记陀罗尼者。随心愿乐皆得称意。所求男女多少皆得。端正聪明无有疑难。善男子。此无尽根大授记陀罗尼。如是大力如是大利益。汝从生死已来未曾得闻。尔时世尊即说咒曰

哆侄他(一)舍啰娜毗夜也(二)式叉毗夜也(三)徙寐履帝毗夜也(四)钵啰河娜(奴可反)毗夜也(五)矣履地毗夜也(六)因地利夜毗夜也(七)[(口*皮)/女]剆毗夜也(八)蒱滕伽毗夜也(九)三摩地毗夜也(十)陀罗尼毗夜也(十一)羼帝(都利反)毗夜也(十二)毗梨耶毗夜也(十三)阇娜毗夜也(十四)钵逻若(女我反)阿霤(驴诟反)必也毗夜也(十五)阿纫(奴邻反)社毗夜也(十六)摩伽毗摩也(十七)遏鼻娘毗夜也(十八)钵啰帝(都利反)三陛(蒲履反)爹毗夜也(十九)步寐(莫履反)毗夜也(二十)坒(父一反)绖[口*耶](余歌反)毗夜也(二十一)摩诃梅怛利毗夜也(二十二)摩诃迦霤(驴诟反)那毗夜也(二十三)摩诃牟帝多毗夜也(二十四)摩呼卑叉毗夜也(二十五)必利洟鼻毗夜也(二十六)萨埵毗夜也(二十七)达摩毗夜也(二十八)答摸毗夜也(二十九)阿卢迦毗夜也(三十)钵啰帝(都利反)婆娜毗夜也(三十一)钵啰帝(都利反)输卢得迦毗夜也(三十二)伽伽那毗夜也(三十三)摩霤[多*頁]毗夜也(三十四)钵啰帝(都利反)多三姥波爹毗夜也(三十五)输娜(奴下反)多毗夜也(三十六)阿尼蜜多毗夜也(三十七)揜(乌合反)钵啰尼系毗夜也(三十八)侯喽[多*頁]毗夜也(三十九)瞿沙毗夜也(四十)紧(吉因反)柘那毗夜也(四十一)阿鼻三摩夜毗夜也(四十二)阿怒娜(四十三)阿怒娜(四十四)揜[(口*皮)/女]呵者者(四十五)者遮啰(四十六)者遮啰毗姥(四十七)柘陛(蒱履反)斫刍者遮啰毗姥(四十八)毗夜也毗姥(四十九)察夜毗姥(五十)阿么毗夜也毗姥(五十一)阿三姥陀遮啰毗姥(五十二)捂眵陀毗姥(五十三)阿迦舍毗姥(五十四)骠钵舍么毗姥(五十五)阿那婆娑毗姥(五十六)呵呵呵毗姥(五十七)阿啰波啰毗姥(五十八)优波舍么毗姥(五十九)萨利罗毗姥(六十)莎波呵(六十一)

善男子。此无尽根大授记陀罗尼。有大威德有大势力。能大利益一切众生。摄护众生怜愍众生。洗除众生令得寂灭。善男子。持此陀罗尼往诣娑婆世界。如我所言问讯释迦牟尼佛。尔时山帝释王佛说此陀罗尼已。一切大众皆大欢喜。赞言。不可思议大不可思议。得见离障第一智慧。说此大授记陀罗尼。一切众生所有小罪中罪大罪最大罪轻重业障牢固难舍。能与善根作障碍者。此陀罗尼速能除尽得无漏道。尔时香象菩萨生大欢喜。而说偈言

  此无尽根陀罗尼　　最胜第一无过者
  能尽众生诸恶业　　亦断一切罪駃河
  生死流转自所作　　悉能远离无有余
  以福德力因缘故　　于一切苦得解脱
  能竭生死三有海　　速生清净有佛国
  于流转中大怖畏　　现见无量大障碍
  悉能倾动诸烦恼　　疾证无上胜菩提
  一切众生不能坏　　若有闻此陀罗尼
  速能受持常忆念　　具足如是诸功德

尔时香象菩萨白山帝释王佛言。我已持此无尽根授记陀罗尼竟。今欲往彼娑婆世界。是时众中有无量阿僧祇菩萨摩诃萨。从无垢三昧起。异口同音白佛言。世尊。我等今者渴仰欲见释迦牟尼佛及大集众礼拜供养。我从昔来未曾得闻日藏法门。惟愿听我往彼世界。尔时世尊告诸菩萨言。善男子。随汝意去。咸可一心作帝释像。身色形貌长短威仪势力自在往彼世界。尔时香象菩萨及无量阿僧祇菩萨。咸共一心悉皆化作帝释王身。形貌色像长短威仪势力自在皆无有异。作此化已。三礼山帝释王佛。右绕三匝绕已从彼界没。如一念顷即到娑婆世界。入此刹已。放诸香云雨种种末香。所谓牛头栴檀香。龙身牢固香。多摩罗叶香。沉水香。多伽罗香。随六时变异香。为供养释迦牟尼佛故放香云已。次第渐向释迦牟尼佛所。到佛所已。以帝释身顶礼佛足。右绕三匝却一面立。当尔之时释迦如来犹共频婆娑罗王。宣说法行

大方等大集经卷第三十五大方等大集经卷第三十六

        隋天竺三藏那连提耶舍译

    日藏分陀罗尼品第二之二

尔时西方去此佛刹。四十二恒河沙等诸佛国土。过是数已。有佛世界名坚固幢。其国有佛号智德峰王如来应供正遍知。于五浊世与诸四众眷属围绕而为说法。时彼众中有菩萨摩诃萨名炎德藏。在大众中听佛说法。仰观虚空见无量无数阿僧祇菩萨摩诃萨众从西方来而往东方。复见东方有大光明。睹是事已。即白智德峰王佛言。世尊。以何因缘有如是事。尔时智德峰王佛告炎德藏菩萨摩诃萨言。善男子。东方去此四十二恒河沙等诸佛世界。有世界名曰娑婆。佛号释迦牟尼如来应供正遍知。现处五浊为无量无边众生说三乘法。欲令法母三宝种久住故。法行不断故。破魔界故。为欲建立佛法幢故。十方一切诸如来等。皆悉至彼娑婆世界。共说宝幢陀罗尼。说已各还本刹。今释迦牟尼佛复为菩萨摩诃萨及声闻众。更大集会。以四无碍智说三解脱门清净梵行。娑婆世界地及虚空皆悉充满。是诸大众皆悉乐闻释迦如来所说法门。心无厌足。尔时智德峰王佛告炎德藏菩萨摩诃萨言。善男子。汝可持我语往娑婆世界问讯释迦牟尼佛。彼佛今说日藏法行坏龙境界名曰炎品。能尽一切众生恶业。善男子。我有陀罗尼欲名无愿顺。汝可送往。此陀罗尼有大势力有大利益。能尽一切欲贪色贪无色贪。能尽一切我慢慢慢增上慢。能破一切无明闇聚。能舍一切诸苦重担。乃至能得尽智无生智。得阿耨多罗三藐三菩提。时彼世尊而说咒曰

怛绖他(一)舍那舍婆(二)奢摩那舍婆(三)阿婆叉舍婆(四)斫刍舍婆(五)输嚧哆罗舍婆(六)伽拏舍婆(七)什婆舍婆(八)迦耶舍婆(九)摩那舍婆(十)叉婆毗陀(十一)斫刍毕利洟鼻叉婆(十二)输嚧哆啰阿婆叉婆(十三)伽啰拏帝阇叉婆(十四)视婆婆喻叉婆(十五)迦耶膻啰摩叉婆(十六)摩那乌阇叉婆(十七)阿卢迦若那叉婆(十八)毗阇僧羯摩叉婆(十九)唵句啰呿伽叉婆(二十)婆摩喽毕也鼻耶叉婆(二十一)舍摩迦阇叉婆(二十二)叉耶啰娑叉婆(二十三)膻哆鼻耶婆叉婆(二十四)那都那(二十五)泥那都那(二十六)阿婆泥那都那(二十七)那耶波那夷那都那(二十八)伊沙伊婆都度呿[口*寫](二十九)莎呵(三十)

善男子。汝可持此无愿顺陀罗尼。往彼娑婆世界如我辞曰。智德峰王如来问讯释迦牟尼佛。起居轻利气力安乐不。转正法轮无障碍不。彼恶众生乐听所说日藏法行坏龙境界炎品不。尔时炎德藏菩萨白智德峰王佛言。世尊。我今已受持此陀罗尼。今虽欲往娑婆世界。而怀怖畏。何以故。我亲从佛闻彼佛世界五浊炽盛。彼诸众生众苦逼迫。贪欲嗔恚愚痴邪见贪着女色。于须臾间能成阿鼻地狱恶业。以是义故我甚怖畏。尔时智德峰王佛告炎德藏菩萨言。善男子。汝飞于彼娑婆世界四天下中。二十一日化作金翅鸟王。令彼大海六十四万亿诸龙见汝形故皆生怖畏以是因缘受三归依。乃至发阿耨多罗三藐三菩提心不。炎德藏菩萨言。如是世尊。实如圣说。尔时智德峰王佛复告炎德藏菩萨言。善男子。汝往于彼娑婆世界四天下中亢旱之处。于七日中化作象头马头大龙王身。令旧住龙心生怖畏。不安本处悉腾虚空。七日之中澍大甘雨耶。炎德藏菩萨言。世尊。实如圣说。佛言。善男子。汝于如是诸恶龙中尚不怖畏。又汝过去发弘誓愿。在在处处利益众生。何故今者忽生恐畏。汝受我使莫生惊怖。尔时智德峰王佛告炎德藏菩萨言。善男子。我复教汝智慧依止大授记陀罗尼。汝持往彼得无怖畏。尔时炎德藏菩萨白佛言。世尊。譬如智人坐伏藏上。以手把土忽得一宝。得已欢喜复更重把。如是渐渐得宝转多。我亦如是重问如来望得如来无价法宝。得是宝已。为欲教化诸众生故。若蒙如来开大法印。以法印力如来力故。则能教化一切众生。尔时智德峰王佛即说咒曰

怛绖他(一)珊提(多夷反)啰那奢摩(二)三摸他那奢摩(三)阿跋阇那奢摩(四)莎凌楞伽奢摩(五)僧逾伽奢摩(六)拔[馬*犬]那奢摩(七)三摩毗沙摩奢摩(八)婆多那奢摩(九)三摩羯岚摩奢摩(十)遏毗驮奢摩(十一)耶婆阇罗摩罗拏奢摩(十二)耶婆萨婆摩奴阇奢摩(十三)耶婆萨婆怛利陀都(十四)三斯羯利哆奢摩(十五)阿逻波罗奢摩(十六)

佛言。善男子此智慧依止授记陀罗尼。彼土众生若有闻者。皆能轻薄下中上结。色无色有亦复如是。恒河沙等劫生死过恶皆悉散灭。过去五有身口意业。生于有中受不爱果。所在生处障修善根四大衰恶。所爱之财求不能得。旧所亲爱悉皆离散。所不乐事而悉和合。身受诸苦心多浊乱。不乐修习一切善根。乐着一切诸不善法。如是等业悉灭无余。善男子。若有一闻此陀罗尼。一心听受七日七夜专精修习。如上所说诸恶罪业皆得消灭。除五无间诽谤正法毁呰圣人犯四重禁。此四种人失陀罗尼力毕定受罪。若复有人无是四罪乐修善根。修行檀波罗蜜种种布施。是人则为一切诸佛诸菩萨众声闻缘觉之所加护。以圣加故得无尽物。亦乐持戒忍辱精进禅定智慧。一切天人阿修罗等不能沮坏。常为一切天王人王。见者恭敬供养礼拜。闻者欢喜心常忆念赞叹守护。临命终时得见十方曾所念佛。皆来授手作如是言。善男子来。我今将汝向我世界。令汝安住十地位中。彼人见佛心大欢喜。以欢喜故得生清净有佛。国中速住十地。是人不久当得阿耨多罗三藐三菩提。善男子。此智慧依止大授记陀罗尼。有如是大力有大利益。善男子。彼娑婆世界有诸众生。不到涅槃道。何以故。造五无间诽谤正法毁呰圣人犯四重禁如是众生十方净土所不容者皆生彼国。是诸众生于三恶道长夜受于种种诸苦。彼众生等虽出三涂。已无清净业因缘故。释迦如来本愿力故。还复生于彼娑婆界。若诸众生过去所有信根乃至慧根。曾修布施乃至智慧。曾修愿行不乐流转。学涅槃道净修梵行。如是人等生彼世界。恶业众生得丑陋身。诸根缺减其心暗钝。衣服饮食卧具汤药。资生乏少寿命短促。痴无智慧睡眠不安。薄善根少福德。诸适意事而不从心复无悲心。乐行恶行乐着恶见。乐习恶论乐起恶愿。乐受恶法不信正法。多诸病苦多散乱心。多乐恶事造三恶业。虚妄忆想非吉为吉。心不乐忍其心粗犷。常乐修习十不善业。诽谤三宝趣三恶道。善男子。彼佛刹中如是众生。闻此智慧依止授记陀罗尼。至心一听者。彼诸众生生厌离心度三恶道。复有众生曾修信根乃至慧根。亦曾修习六波罗蜜。不乐流转净修梵行。若得闻此陀罗尼已。增益寿命身少病苦。智慧增益资财无损。长善根海增善知识。乃至增益一切善业皆悉成就。成就正见具足十善种三善根。乐三自归乐起诸愿。乐阿兰若光显三宝。复能于此智慧依止大授记陀罗尼。至心听受专精修习。读诵受持乃至七日七夜忆念不舍。成就如是无量功德。除五无间诽谤正法毁呰贤圣犯四重禁。如是众生堕于恶趣。于彼命终而来生此娑婆世界。以彼业气习未尽故。于未来世应受恶报。由得闻此智慧依止大授记陀罗尼。于现在身虽不能得胜妙果报。以陀罗尼力故。于当来世无量恶报悉灭无余。彼诸众生为灭如是诸恶业故。应当书写此陀罗尼门。复应造作七佛形像。于释迦牟尼佛法之中。建立寺舍供养供给法行比丘。亦当数数受八戒斋。勤行精进乐听正法如说修行。此诸众生于三宝中得决定信生欢喜心因缘故。能灭无量百千万亿那由他劫在在处处应受恶道种种诸苦。于现在世多诸病苦。受身形残资生减失。眷属离散为人奴仆。受诸挝打恶口粗犷。不得自在为人诽谤。已受如是种种苦故。过去恶业皆悉灭无。如是善男子。此智慧依止授记大陀罗尼。于诸众生有大势力我今更说。尔时世尊即说咒曰

怛绖他(一)佉伽波利眵(尺之反)提(二)伽唎婆叉(侧檀反)西(三)伽跛利(四)鼻陀钵啰婆伽叉(恻檀反五)叉婆踰岐(强予反六)钵底呵黎(七)奢摩那四迦涕(八)三摩迷伽阇师(疏斋反九)阿叉夜那低(十)叉婆跋栘(常兮反十一)祢[馬*犬]那阇师(十二)娑摩娜阇师(十三)娑摩伽逻阇师(十四)阿地呵奢夜阇师(十五)鼻钵啰婆阇师(十六)西叉阇师(十七)西祢夜阇婆阇师(十八)娑利罗瞿咥(声指反)夜阇师(十九)娑利罗瞿咥夜阿阿鞞绮婆那鸠世(二十)萨檀拘帝(二十一)私婆檀那梯(二十二)毗哆钵啰鼻利低(二十三)呕波膻啰磨娜梯(二十四)阿那叱地夜跋罗企(羌予反二十五)钵罗帝羯迷那(二十六)三迦太夜世(二十七)萨卢遮那婆迷(二十八)拘嚧太黎(二十九)迦摩萨世(三十)阿世奢佉岐(躯予反三十一)那夜军阇(三十二)鼻地夜跋泥(三十三)羯罗那跋泥(三十四)郁遮跋泥(三十五)三迷摩迦黎(三十六)奢利夜跋泥(三十七)摸伽阇师(三十八)呵利拘那婆(三十九)那夜那目企(四十)娑啰叉拘黎(四十一)那逻延拏树黎(四十二)因陀罗婆萨泥(四十三)乌阿(四十四)阿婆阿(四十五)阿阿(四十六)何罗婆阿(四十七)婆啰(四十八)阿婆啰(四十九)何罗萨弥伽(其我反五十)豆佉祢提(都夷反)罗(五十一)涅槃醯莎和呵(五十二)

善男子。此大授记陀罗尼有大功德有大势力有大利益。能尽一切恶业。怜愍救护一切众生。悉能洗除诸罪垢秽。身心光洁能与念力与寂灭力。若有众生一心听受如说修行。一切如来一切菩萨一切辟支佛一切阿罗汉悉皆加护。乃至天王人王亦常护念。敬爱礼拜供养供给。彼人临终。得见过去曾所诵念十方诸佛。皆悉授手作如是言。善男子来。我今将汝生净佛土。汝生我国速住十地。彼人见佛得大欢喜。大欢喜故命终得生净佛国土。既生彼已得住十地。不久得成阿耨多罗三藐三菩提。善男子。此智慧依止大陀罗尼。有如是力能净恶业成就净心证涅槃道。尔时智德峰王佛告炎藏菩萨言善男子持此陀罗尼。往诣娑婆世界至释迦牟尼佛所。如我辞曰。智德峰王佛问讯世尊。炎藏菩萨摩诃萨言唯然受教。时彼众中无量无边阿僧祇菩萨摩诃萨。异口同声作如是言。我等今者乐欲见彼娑婆世界释迦牟尼佛。礼拜供养及见大众。听受日藏坏龙境界能尽诸恶业陀罗尼门。我等昔来初未曾往彼娑婆界。今从定起欲往彼土。惟愿世尊听我等往。尔时智德峰王如来告众菩萨摩诃萨言。善男子。欲往随意。应当摄心以游彼国。汝等各自变身如那罗延具足庄严。时炎藏菩萨与诸菩萨摩诃萨众。一切皆作那罗延身庄严示现。顶礼佛足右绕三匝。即从彼发如一念顷至娑婆界四天下中摩伽陀国释迦牟尼佛所。到已以阎浮金末而散佛上。既供养已顶礼白佛言。世尊。智德峰王如来问讯。世尊。少病少恼起居轻利气力安不。转正法轮无障碍不。作是语已却住一面。尔时北方去此娑婆世界。八十恒河沙佛刹。过是数已有佛世界名普上香五浊充满。彼国有佛号德华藏如来应供正遍知。现在说法。彼佛众中有菩萨摩诃萨名虚空藏在会听法。尔时虚空藏菩萨摩诃萨仰观虚空。见虚空中无量无边阿僧祇菩萨摩诃萨。从北方来往诣南方。复见南方有大光明。见是事已即白佛言。世尊。我始从定起在会听法。见虚空中无量无边阿僧祇菩萨摩诃萨。从北方来往诣南方。复见南方有大光明。以何因缘有如是事

尔时德华藏佛告虚空藏菩萨言。善男子。于此南方过八十恒河沙佛刹。有佛世界名曰娑婆。亦如我刹五浊充满。彼中有佛号释迦牟尼如来应供正遍知。今现在世。为诸众生说三乘法。欲令法母久住世故。令三宝种不断绝故。建大法幢坏魔网故。十方诸佛皆集彼国说宝幢陀罗尼。说已各还本土。释迦牟尼佛为诸菩萨摩诃萨大声闻众作大集会。以四无碍智说三解脱门。彼佛土中地及虚空大众充满。如来处于师子之座。放大光明说深妙法。清净梵行及以四摄。日藏法门坏龙境界炎品。除诸众生不善恶业陀罗尼门。一切乐闻无有厌足常作是念。若有十方一切刹中菩萨摩诃萨。亿百千劫行菩萨行。欲得逮于一生补处。乃至十八不共之法。自具足得无障碍智不随他教者。彼诸菩萨悉应来集娑婆世界。以自善根入种种三昧。令此世界大地得大利益。令诸众生不失念力。布施持戒忍辱精进得大智慧。亦如他方清净佛土具诸功德。今此娑婆世界亦有十方诸大菩萨摩诃萨众悉来集会。彼菩萨众于娑婆世界。随自分力各入三昧。从于身边而放光明。或如大灯。或如百千万亿无量无边日月光明。彼诸菩萨摩诃萨皆大集会彼娑婆界。以是因缘有大光明。彼十方佛刹诸菩萨众未至彼者。从三昧起趣于南方。往娑婆世界欲见释迦牟尼佛及诸大众。欲闻破坏一切恶业陀罗尼门。结加趺坐。各各入于奋迅游戏诸深禅定。善男子。汝今可往彼娑婆世界。善男子。彼中众生短命多病少智慧少善根少福德。于三恶道心无怖畏。乏少资生多贪爱欲。行不净行无惭无愧乐行十恶。如是众生舍此身已堕于恶道。复有生于恶夜叉中。迦吒富单那中。乃至阿迦富单那中。既生彼已收地精气及种种谷华果草木一切等味。其有食者身力减损。彼诸恶鬼增益势力。常伺人便住胎出胎。随其成长乃至夺命。是故彼诸众生多病短命无念慧力。不畏未来三恶道苦。乃至乐行十不善业堕于恶道。善男子。我于过去行菩萨时作如是愿。牢固勇猛勤无休息。供养诸佛如说修行。咨问彼佛何等陀罗尼咒。能护胎藏及以母身令得安隐。令诸恶龙夜叉罗刹阿修罗迦楼罗紧陀罗摩睺罗伽。鸠槃茶裨黎多。毗舍阇。富单那。迦吒富单那。乌摩罗。阿跋思摩罗。或一日疟乃至四日。或毒药恶咒。或行恶药。能令身心逼迫苦者。令是诸恶悉不得便。或在母胎乃至出胎乳哺长养种种饮食及其精气。身心浊乱悉不得便。令彼众生安隐住胎。乃至乳哺长养身心不浊。无病长命增益智慧。乃至能行十善业道。乐行布施乐持禁戒。怖畏未来三恶道苦。何等陀罗尼能得如是。唯愿大慈为我宣说。我得闻已于当来世教化众生。尔时彼佛即为我说奢摩裴多悉致蔓多罗。大授记陀罗尼。我闻此咒受持流布无量亿劫。常以此咒化导众生。令得修行六波罗蜜牢固精进。复以此咒护诸母人及护胎藏。若天若乌摩罗。阿跋娑摩啰人非人等。于彼妇人及以胎藏。不能令彼四大不调身心浊乱。夺人精气恶咒恶药乃至阿修罗。及余世间坏胎藏者亦不得便。胎藏安隐产生无难。诸根满足身体清净颜貌端正。具足智慧不失念力。大力诸天百千万亿。及诸眷属无量众数常随卫护。能令彼得宿命智慧。怖畏恶道生慈悲心。乐行布施持戒忍辱精进禅定。乐善知识易得圣智。能得尽苦具足智慧。乐空寂处灭诸烦恼。天龙夜叉诸鬼神等供养供给。厌恶生死志求涅槃。乃至能发阿耨多罗三藐三菩提心。在在生处终不忘失菩提之心。速得成就菩萨三昧。若生辟支佛心现得顺忍。于未来世成辟支佛。若发声闻心得四谛顺忍。不堕三恶生天人中。善男子。我于过去行菩萨行时。以无量方便教化众生。令住阿耨多罗三藐三菩提。善男子。此陀罗尼如是大力有大利益。善男子。若诸众生遇重癞病。应以此陀罗尼咒师子乳与病者服。一切诸病悉皆除愈。若不能得师子乳者。取祭死尸边食。以此陀罗尼咒之与病者服。一切诸病亦悉除愈。若无此食应取尘弃药。持此陀罗尼咒之与病者服。一切诸病亦得除愈。善男子。我于过去行菩萨行时。如是勤求方便教化众生。乃至令住阿耨多罗三藐三菩提。若见诸树无华果者。我时即以此咒用咒雨水浇灌树根。彼树华果即得滋茂。乃至蒱桃种种谷草皆令茂盛。若天无雨取沟渎中诸不净汁。安龟甲中以咒咒之。以瞻波迦树叶裹此龟甲。置龙池中即时大雨。若天多雨损败苗实。当取阿阇迦罗蛇头中珠以咒咒之。置龙泉中雨即便止。若非时黑风大寒大热。日月星宿失其常度。年节四时变异灾怪。应愍众生七日七夜净修梵行澡浴身体。服食乳糜若但食菜。一心专念更无异想。七日七夜讽诵受持此陀罗尼。复以此陀罗尼咒。咒净葵菜。裹摩陀那果安天庙中。即除非时风雨寒热种种灾恶。日月星宿还依常度。善男子。我于过去修菩提时。欲令众生所在安隐。若见虚妄忆想倒见众生。我于尔时为彼说此陀罗尼咒。彼诸众生闻此咒已。虚妄颠倒皆悉舍离。修十善业起于善愿淫欲薄少。善男子。我于过去以方便力教化众生令住六波罗蜜。亦自具行六波罗蜜。乃至得阿耨多罗三藐三菩提。善男子。此陀罗尼能与众生如是大力。与大利益。能除一切诸病苦恼。能护怀妊妇人及以胎藏。能坏一切烦恼诸结。能知四大五阴十二入十八界示方便道。能觉安隐快乐涅槃。能令众生信心清净。能入诸法差别法门。摄诸外道坏魔境界。善男子。此陀罗尼力能令一切诸天欢喜。夜叉恶鬼心生知足。诸阿修罗极大怖畏。迦楼罗紧陀罗等亦皆欢喜。摩睺罗伽不能反顾。摧伏邪论。能令刹利婆罗门毗舍首陀信心欢喜。能令女人薄少淫欲。于多闻者益其念力。修禅定者乐阿兰若。能却一切盗贼斗诤饥馑疫病旱涝寒热粗涩恶触。如是等事皆悉除灭。法母增长佛法流布。三宝不断除生死畏。破无明聚弃舍苦檐。能得尽智及无生智尔时世尊即说咒曰

怛绖他(一)摩那叉(恻我反二)阿婆叉(三)罗伽娑叉(四)阇罗叉(五)末磨那叉(六)阿婆叉(七)曼陀叉(八)那茶叉(九)那茶罗休(十)鼻萨那吒(十一)佉伽那吒(十二)阿吒那吒(十三)拘那吒(十四)钵利鸠萨那吒(十五)那茶那吒(十六)富利迦那吒(十七)郁怛罗那吒(十八)迦毗那吒(十九)军阇那吒(二十)苏目伽那吒(二十一)遮婆茂婆罗那吒(二十二)佉伽凡钳婆啰那吒(二十三)富沙迦啰那吒(二十四)系娑(苏我反)郁卢达啰那吒(二十五)三摩罗耶那吒(二十六)失啰鸠三(二十七)憍怛吒(二十八)怛罗(二十九)摩妒佉啰婆(三十)提畜叉(三十一)婆帝啰竖(三十二)豆婆那摩啰竖(三十三)婆呵那否智(三十四)僧低啰阇婆(三十五)阿摩啰阇婆(三十六)摩呼啰伽阇罗(三十七)阿祢拏婆啰(三十八)阿祢拏叉(三十九)阿婆呵摩唎伽祢拏叉(四十)咽沙咽婆都豆佉写(四十一)娑和呵(四十二)

尔时世尊说此陀罗尼时。彼大众中六万亿人得柔顺忍复有六十频婆罗人得须陀洹果斯陀含果阿那含果阿罗汉果善男子。汝可持我此陀罗尼往娑婆界如我辞曰。北方去此八十恒河沙佛刹。过是数已有佛世界名普上香。亦具五浊。彼中有佛号德花藏如来应供正遍知。现在说法。问讯释迦牟尼佛。少病少恼气力安不。诸弟子众乐听法如说行不能摧四魔诸恶龙不。佛转法轮无障碍不。善男子。于彼释迦牟尼佛所。说日藏法门。能坏魔王龙王境界。灭除恶业。说此奢摩裴多悉致大授记陀罗尼。欲令此陀罗尼有大势力大利益。能令众生安隐快乐灭诸烦恼。乃至弃舍苦担。尔时德华藏佛诸弟子众咸共赞言。善哉善哉。希有世尊。希有世尊。如来智慧一切法中无障无碍。我等从昔已来初未得闻如是甚深大陀罗尼。能与众生安隐快乐。听此陀罗尼已悉发勇猛读诵受持。何以故。此陀罗尼有如是无量无边大功德故。尔时虚空藏菩萨摩诃萨白佛言。世尊。若有众生怖畏生死欣乐涅槃。一心称名礼拜供养德华藏佛。并诵此陀罗尼生希有心。彼诸众生增长善根获大利益。尔时德华藏佛告虚空藏菩萨摩诃萨言。善男子。如是如是如汝所说。善男子。我于往昔修菩提时。勤求方便作如是愿。我得阿耨多罗三藐三菩提时。若有十方诸佛国土。其中众生乐行布施乃至智慧。若能至心称我名号礼拜供养。令彼众生无有天人阿修罗等能加恶者。亦无有能障碍修行六波罗蜜者。又能增益无量善根。唯除过去造极恶业者。若此愿不成我誓不取成等正觉。善男子。若有妇人欲求子者。若复不愿有多子者。若有怀妊怖畏产难。彼诸人等应当至心称我名号礼拜供养。若人非人无能得便。亦无恶咒毒药能令身心受逼迫苦。乃至一念能加恶者。我誓不取阿耨多罗三藐三菩提。善男子。我于往昔求菩提时作如是愿。覆护利益一切众生。是故众生应当至心称我名号礼拜供养。一切诸恶皆悉除灭决定无疑。唯除过去极重恶业现受报者。尔时虚空藏菩萨白佛言。希有世尊。不可思议。我今欲往娑婆世界见释迦牟尼佛。但彼众生弊恶嫉妒。无慈悲心不知报恩。言常粗犷多行邪见无恼我耶。我今往彼或无利益。佛言。善男子。无如是事。谁是成就四无量心而能加恶。假使百千诸魔眷属亦无障碍者。善男子。汝于往昔无量劫来。而常修行四无量心。汝莫怖畏。善男子。我有陀罗尼从四无量梵行中生。能灭诸恶乃至恶梦。汝可受持此陀罗尼。若有多嗔众生闻此咒者皆生慈心。若不生者或便惛睡。尔时世尊即说咒曰

怛绖他(一)呼呼鼻利呵(二)浮浮啰(三)咽罗啰婆(四)一逻(五)娑呵(六)呵筹(七)伽筹(八)伽伽那叉(九)奢摩奢摩(十)蜜多啰蜜多啰(十一)斫迦啰(十二)跋帝帝隶(十三)娑伽啰帝隶(十四)豆利哆哂(香指反)[穴/(怡-台+未)](十五)哂黎呵跋醯(十六)那逻阇哜(十七)夜婆那蜜低黎(十八)绮底蜜低黎(十九)婆利蜜低黎(二十)始佉蜜低黎(二十一)摩都啰蜜低黎(二十二)佉伽蜜低黎(二十三)萨都阇蜜低黎(二十四)萨婆羯摩蜜低黎(二十五)摩那跋利哆蜜低黎(二十六)陀胝(张夷反)湿婆啰蜜低黎(二十七)莎和呵(二十八)

善男子。此陀罗尼名灭一切恶及诸恶梦。其有诵持者。应以瞻卜油咒之七遍。用涂两手及用涂面。诸恶心人睹见之者皆生欢喜。乃至恶龙夜叉迦吒富单那等。乃至千万诸魔眷属不起恶心。况加恶事。假使满四天下诸恶众生。咒一合水而以散之。令彼众生皆生信心。乃至不起一念之恶。若有浊水满四大海。取一合水以此咒咒之投彼大海。能令浊水悉变澄清。善男子。汝可持此陀罗尼往娑婆界。尔时无量阿僧祇菩萨摩诃萨。异口同声作如是言。我等今者渴仰欲见大德世尊释迦牟尼佛。礼拜供养尊重赞叹。亦欲观彼大众集会。听日藏法门坏龙境界炎品。为除一切众生诸恶业故。惟愿世尊听我往彼。佛言。善男子。欲往随意。应当一心以游彼国。汝等皆可变作转轮圣王。七宝成就千子具足。庄严其身如转轮王法。即时八十千万菩萨摩诃萨与虚空藏菩萨。恭敬围绕德华藏佛。绕三匝已上升虚空。是诸菩萨摩诃萨众。各自化作转轮王身。七宝成就千子具足。象兵马兵车兵步兵。如是种种庄严如轮王法。即从彼发一念之顷至娑婆世界。以阎浮提金末散娑婆世界佛及菩萨声闻大众。如是金末皆悉遍满娑婆世界。复以龙栴檀香末而以散之。复以真珠亦以散之。复以真珠金璎珞具亦以散之。复以颈珠而用散之。复以种种璎珞种种衣服而以散之。复以种种幢幡宝盖亦以散之。其诸菩萨摩诃萨众。皆为供养释迦牟尼多陀阿伽度阿罗呵三藐三佛陀。彼诸菩萨摩诃萨众。作是供养已恭敬围绕右绕娑婆世界。绕三匝已而来至此四天下中摩伽陀国释迦牟尼佛所。到已恭敬礼拜绕佛三匝却住一面

大方等大集经卷第三十六大方等大集经卷第三十七

        隋天竺三藏那连提耶舍译

    日藏分菩萨使品第三

尔时频婆娑罗王。见未曾见无量阿僧祇梵天。帝释天。那罗延天。四天下转轮圣王。见已心大欢喜。从坐而起在一面立。尔时四使菩萨摩诃萨及其眷属。合掌向释迦牟尼佛。时日行藏菩萨以瞻波迦华鬘散释迦牟尼佛上。而赞叹曰

  于诸足中最殊胜　　施诸恶见大光明
  能说出世平等行　　行正道者施法印
  摧灭毒龙及四魔　　解世烦恼佛为胜
  竖坚法幢施解脱　　以大法炬灭众闇
  亲近善友修集定　　愍众生故说福田
  佛法僧宝甚难得　　人身信心亦复难
  虽得人身善友难　　得善友者坏烦恼
  众生恶智烦恼覆　　速能为灭烦恼网
  众生没于烦恼河　　佛如大船能拔济
  我等诸佛使说欲　　随喜如来佛法藏

尔时日行藏菩萨白释迦牟尼佛言。世尊。东方过无量恒河沙佛刹。彼有世界名无尽德。佛号瞻波迦华色如来应供正遍知。现在说法。彼佛如来使我送欲。并问讯释迦牟尼佛。少病少恼无多患不。弟子眷属身力乐不。常安隐不。乐听法不。闻佛所说如教行不。乐阿兰若不。世尊于此破坏众魔。独超众圣转于无碍微妙法轮。但此五浊诸恶众生障碍未尽。于佛法轮不信受者。为是等故彼瞻波迦华色佛说此日藏法行坏龙境界炎品一切众生恶业尽陀罗尼欲。名四谛顺忍陀罗尼。此陀罗尼有大势力有大利益。能尽一切欲贪色无色贪一切慢增上慢我慢等。如上所说。此四谛顺忍陀罗尼。能坏一切魔王势力。能令诸天心生欢喜。能令阿修罗迦楼罗生大怖畏。能令紧陀罗心生欢喜。能令摩睺罗伽生怖畏心。能坏外道。于刹利所能与知足。能摄婆罗门令入佛法。能令毗舍生大信心。能令首陀罗生欢喜心。能令女人离诸贪欲。能令智人生欢喜心。令坐禅人乐阿兰若。能却一切种种恶事及诸斗诤饥馑疫病夭横死者。能除外贼非时寒热恶风雨恶兽瀑水苦辛枯涩诸恶触等。能建立法幢光显佛法。令法母久住佛种不灭。能安慰生死流转众生。能生尽智。能觉无生智。能裂一切无明暗聚。能舍一切苦担能干一切苦海。尔时日行藏菩萨。即说如上四谛顺忍陀罗尼

[口*寫]绖咃(一)婆裔婆野波履婆隶(二)婆醯婆诃波履婆隶(三)必利洟(他地反)仳必利洟(他地反)鼻波履婆隶(四)阿捭阿跛波履婆隶(五)低誓低社波履波隶(六)末隶末逻波履波隶(七)却偈(其隶反)却伽(其个反)波履婆隶(八)阿卢翅阿卢迦(其可反)波履婆隶(九)萨他迷(芒闭反)萨他么波履波隶(十)曷罗(厘可反)誓曷罗(厘可反)社波履婆隶(十一)徙隶徙逻波履婆隶(十二)伽迷伽么波履婆隶(十三)阿蒱婆波履婆隶(十四)罗么罗么(十五)罗谜(芒闭反)罗么(十六)曷啰剆(勒可反)曷罗逻(十七)阿啰罗阿啰罗么(十八)[月*坒]蹋婆(蒱么反)攘娜复[多*頁](登我反十九)伽逻弥复[多*頁](登我反二十)揭逻磨波履婆隶(二十一)斫刍揭逻醯斫刍揭逻诃波履婆隶(二十二)输嚧怛啰揭逻醯输嚧怛啰揭逻诃波履婆隶(二十三)伽罗娜揭逻醯伽罗娜揭逻诃波履婆隶(二十四)什婆揭逻醯什婆揭逻诃波履婆隶(二十五)迦耶揭逻醯迦耶揭逻诃波履婆隶(二十六)么那揭逻醯么娜揭逻诃波履婆隶(二十七)馺跛曷利舍揭逻醯馺跛曷利舍揭逻诃波履婆隶(二十八)鞞[多*頁]娜揭逻醯鞞[多*頁]娜揭逻诃波履婆隶(二十九)怛履瑟那揭罗醯怛履瑟那揭罗诃波履婆隶(三十)忧波陀那揭逻醯忧波陀那揭逻诃波履婆隶(三十一)婆[(口*皮)/女]揭逻醯婆[(口*皮)/女]揭逻诃波履婆隶(三十二)阇帝揭逻醯阇帝揭逻诃波履婆隶(三十三)社啰摩啰娜揭逻醯社啰摩啰娜揭逻诃波履婆隶(三十四)独佉珊多跛揭逻醯独佉珊多跛揭逻诃波履婆隶(三十五)阿啰波啰蹋陛社揭逻醯阿啰波啰蹋陛社揭逻诃波履婆隶(三十六)阿跋[多*頁]鞞婆[多*頁]写(三十七)阿跋啰摸跛么婆卸(思夜反)鞞也(三十八)毗尼跋[多*頁](三十九)阿利耶曷啰舍弥(四十)萨鞞伽膻帝莎波诃(四十一)

说此咒已白佛言。世尊。此四谛顺忍陀罗尼。是彼瞻波迦华色佛所送。尔时释迦牟尼佛闻此咒已赞言。善哉善哉。乃至一切娑婆世界诸佛刹中十方来众及此刹众。亦称善哉。除入定者。尔时释迦牟尼佛告日行藏菩萨言。善男子。我今不起此座。于大众中广为众生说此四谛顺忍陀罗尼。文字及义不增不减。善男子。汝欲来此彼瞻波迦华色佛。为护汝身不怖畏故。说身受行陀罗尼。乃至说涅槃道日眼莲华陀罗尼。汝今当为一切众生于此宣说。尔时日行藏菩萨即于佛前。说所持来日眼莲华陀罗尼

怛绖他(一)徙阿摩帝(二)毗卢迦(基我反)么帝(三)咽隶(四)羁(基离反)[多*頁]矣利师(五)沤制(六)苏楼沤制(七)佛地(徒纸反)毗佛地(徒纸反八)摩诃佛地(九)郁奴摩提(十)郁奴摩爹(十一)钵剆底筛(疏皆反)达腻(十二)阿罗伽度芦婆(十三)阿啰伽度芦婆(十四)钵剆底筛达腻(十五)频豆频豆么底(十六)质吒质吒钵剆底蒒达腻(十七)頞勒羁(居离反十八)栴陀罗提(十九)呵呵(虎我反)质挃(竹杌反二十)诃[多*頁]腻弭(二十一)诃[多*頁]迦(基我反)么鞞只(其利反二十二)诃[多*頁]富娜曷啰婆(二十三)曷啰栘(二十四)诃[多*頁]斫刍(二十五)三摩帝(二十六)诃[多*頁]毗么地(徒只反二十七)诃[多*頁]夜奇离(二十八)诃[多*頁]毗三么揭离(二十九)诃[多*頁]三姥爹啰社裨(三十)诃[多*頁]鞞么[多*頁]曷啰誓(三十一)诃[多*頁]咥(呼旨反)[口*戒](呼戒反三十二)诃[多*頁]者帝(嘲隶反三十三)诃[多*頁]达么曷啰誓(三十四)诃[多*頁]蒱呼曷啰誓(三十五)诃[多*頁]跋社么帝(三十六)诃[多*頁]嘘伽曷啰舍弥(三十七)诃[多*頁]达么徙蜜帝(三十八)诃[多*頁]婆忧波陀娜(三十九)若(如者反)茹若(如者反四十)毗社树坚(四十一)毗者社若若(四十二)娑罗末伽(其我反)若若(四十三)咽娑案[多*頁](四十四)婆啰伽(其我反四十五)独敧莎呵(四十六)

说此咒已白佛言。世尊。彼瞻波迦花华佛。为护我故说此陀罗尼。尔时释迦牟尼佛告长老耶舍。汝可持此日眼莲华陀罗尼。何以故。佛出世难。闻此陀罗尼亦复甚难。若佛如来及弟子众。或阿罗汉须弥山王。及于大海其德可说此日眼莲华陀罗尼。非于一劫若百千劫可说其德。此陀罗尼如是甚深。汝当一心受持读诵。于四众中广宣说之。彼娑婆界一切众生闻此咒已。一切欲贪色无色贪悉皆除灭。乃至能得漏尽智证得涅槃乐。尔时香象菩萨复以偈赞

  唯佛坐于菩提树　　能坏众魔及眷属
  独得无上胜菩提　　证知一切众生类
  佛放胜光蔽外道　　如日能映诸荧火
  法母三宝种常住　　圣集为度诸众生
  为求善法及菩提　　供养佛故同集此
  唯佛甘露洗众生　　演说菩提胜行故
  能度众生更不生　　尽漏尽思尽烦恼
  安置众生寂灭城　　唯佛于世如妙药
  能除众生诸忧愁　　彼佛使送陀罗尼
  并复问讯牟尼月　　多闻智海慈悲行

说此偈已白佛言。世尊。譬如有城方一由旬沙满其中。如是一沙为一佛刹。过是数已。南方有佛世界名袈裟幢。具足五浊。佛号山帝释王如来十号具足。今现在说法。彼佛如来使我送欲。并问讯释迦牟尼佛。少病少恼常安乐不。弟子众等无多患不。乐听法不。既闻法已如说行不。乐阿兰若不。乐坐禅不。佛于此刹破坏魔王及诸恶龙。光显正法转无障碍清净法轮。但此佛刹诸恶众生障碍未尽。不受法轮者。为是等故。彼山王如来。令我送此日藏法行坏龙境界炎品一切众生恶业尽陀罗尼欲。名空顺忍陀罗尼。此陀罗尼有大势力有大利益。能却一切欲贪。能尽一切色非色贪。能尽一切慢增上慢。如上所说乃至能舍苦担。尔时香象菩萨即说所送空顺忍陀罗尼

怛绖他(一)头摩帝头摩帝(二)恶踦(驱置反)头摩帝(三)钵啰娑婆头摩帝(四)萨婆迦舍头摩帝(五)阿鞞却伽(其我反六)培鞞娜却伽(七)碎(苏骨反)朱叉却伽(八)阿[(口*皮)/女]摸诃却伽(九)阿那涅也却伽(十)毗耶佛履帝却伽(十一)僧迂喽者却伽(十二)阿泥么却伽(十三)卢者那却伽(十四)尸弃却伽(十五)毗底寐却伽(十六)郁刍么却伽(十七)呜啰却伽(十八)恶敧却伽(十九)耶婆么娜却伽(二十)尤喽跛却伽(二十一)耶婆毗娘那却伽(二十二)斫刍陀妒却伽(二十三)耶婆么娜毗娘那陀妒却伽(二十四)必利洟陛陀妒却伽(二十五)耶婆毗娘娜陀妒却伽(二十六)靼(之结反)埵(都和反)履悉蜜驻跛萨他娜却伽(二十七)耶婆阿瑟吒达奢阿鞞尼迦佛陀达摩却伽(二十八)独佉却伽(二十九)耶婆磨勒却伽(三十)毗婆[(口*皮)/女]娜毗敧[(口*皮)/女](三十一)阿那娜娜(三十二)阿陛娜娜(三十三)三姥陀剆娜娜(三十四)萨婆迦啰啰娜娜(三十五)萨婆僧萨他娜毗瞿跛娜娜(三十六)阿紧(吉因反)柘若(女我反)娜娜(三十七)叉(初诈反)婆叉婆(三十八)伊犁伊儸(三十九)伊犁伊罗(四十)寐利苏波呵(四十一)

说此咒已白佛言。世尊。此陀罗尼是彼山王如来所送。尔时释迦牟尼佛心大欢喜赞言。善哉善哉。并及一切娑婆世界诸大集众。皆大欢喜同赞善哉。除空静处入禅定者。尔时释迦牟尼佛语香象菩萨言。善男子。我今不起此座。于大众中广为众生说此空顺忍陀罗尼。文字及义不增不减。善男子。汝欲来此彼山王佛为护汝故。说无量根陀罗尼汝可说之。何以故。能却一切心受行故。得平等一切智智故。四魔境界坏故。法母三宝性不断故。尔时香象菩萨白佛言世尊。我今当说。即于佛前说所持来无尽根大授记陀罗尼

怛绖他(一)舍啰娜毗夜也(二)式叉毗夜也(三)徙寐履帝毗夜也(四)钵啰河拏(奴下反)毗夜也(五)矣履地毗夜也(六)因地利毗夜也(七)啰剆毗夜也(八)蒲腾伽毗夜也(九)三摩地毗夜也(十)陀罗尼毗夜也(十一)羼帝(都利反)毗夜也(十二)毗梨耶毗夜也(十三)阇娜毗夜也(十四)钵逻若(女我反)阿霤(驴诟反)必也毗夜也(十五)阿纫(奴邻反)社毗夜也(十六)摩伽毗夜也(十七)遏鼻娘毗夜也(十八)钵啰帝(都履反)三陛(蒲履反)爹毗夜也(十九)步寐(莫履反)毗夜也(二十)坒(父一反)绖耶(余歌反)毗夜也(二十一)摩诃梅怛梨毗夜也(二十二)摩诃迦霤(驴诟反)那毗夜也(二十三)摩诃牟帝多毗夜也(二十四)摩呼卑叉毗夜也(二十五)必利洟鼻毗夜也(二十六)萨埵毗夜也(二十七)达摩毗夜也(二十八)答摸毗夜也(二十九)阿卢迦毗夜也(三十)钵啰帝婆娜毗夜也(三十一)钵啰帝输卢得迦毗夜也(三十二)伽伽那毗夜也(三十三)摩霤[多*頁]毗夜也(三十四)钵啰帝多三姥波爹毗夜也(三十五)输娜(奴下反)多毗夜也(三十六)阿尼蜜多毗夜也(三十七)揜钵啰尼系多毗夜也(三十八)侯喽[多*頁]毗夜也(三十九)瞿沙毗夜也(四十)紧(吉因反)柘那毗夜也(四十一)阿鼻三么夜毗夜也(四十二)阿怒娜(四十三)阿奴娜(四十四)阿[(口*皮)/女]呵者者(四十五)者遮啰(四十六)者遮啰毗姥(四十七)柘陛(蒱履反)斫刍者遮啰毗姥(四十八)毗夜也毗姥(四十九)察夜毗姥(五十)阿磨毗夜也毗姥(五十一)阿三姥阿遮啰毗姥(五十二)坞眵陀毗姥(五十三)阿迦舍毗姥(五十四)骠钵舍么毗姥(五十五)阿那婆婆毗姥(五十六)阿呵呵毗姥(五十七)阿啰婆啰毗姥(五十八)优波舍么毗姥(五十九)萨利罗毗姥(六十)娑波呵(六十一)

说此咒已白佛言。世尊。此是山王如来所说无尽根授记陀罗尼。护我身故。尔时释迦牟尼佛告长老憍陈如。汝可受持读诵此无尽根陀罗尼。憍陈如。佛出世难。闻此陀罗尼者亦复倍难。善男子。若佛如来或佛弟子大阿罗汉等。于百千劫可得数知一切众生三世心心数法。此陀罗尼德非百千劫说能尽其边。以是故。憍陈如。当受持此无尽根陀罗尼。于四众中如闻广说。若有众生得闻此法。能尽恶业乃至得四无碍不坏辩才。能常乐说于三界中得最胜身。尔时炎德藏菩萨摩诃萨合掌向释迦牟尼佛。以偈赞曰

  六道烦恼苦所[漂*寸]　　佛智如船自他度
  六根所迷魔罥缚　　佛出世难说实道
  智人能舍六种家　　佛为世亲除俭法
  得六神通诸三昧　　诸佛大圣实语者
  能解众生流转缚　　我等信心闻佛赞
  世亲使我来此刹　　唯愿世尊听我说

尔时炎德藏菩萨摩诃萨白佛言世尊。西方过四十二恒河沙等佛刹。有佛世界名坚固幢。佛号智德峰王如来十号具足。今现在说法。彼佛如来使我说欲并问讯释迦牟尼佛。安隐住不。起居轻利不。弟子众等无多患不。乐听法不。若听法已能如说行坚固住不。乐阿兰若行不。如来于此破坏众魔及龙眷属。光显正法最胜无碍转妙法轮。但此世界诸恶众生障碍未尽。于佛法轮不顺行者。是故彼佛说此日藏法行坏龙境界炎品一切众生恶业尽陀罗尼欲。所谓无愿顺陀罗尼。此陀罗尼有大势力有大利益。能尽一切欲贪色无色贪。一切慢增上慢我慢等。如前所说能裂一切无明暗聚。能舍一切苦担尔时炎德藏菩萨。即说所送无愿顺陀罗尼

怛绖他(一)舍摩那舍婆(二)阿婆叉舍婆(三)斫刍舍婆(四)输嚧哆啰舍婆(五)伽拏舍婆(六)视婆舍婆(七)迦耶舍婆(八)摩那舍婆(九)叉婆毗陀(十)斫刍毕利洟鼻叉婆(十一)输卢哆啰阿婆叉婆(十二)伽罗拏帝阇叉婆(十三)什婆婆喻叉婆(十四)迦耶　羯罗摩叉婆(十五)摩那乌阇叉婆(十六)阿卢迦若那叉婆(十七)毗阇僧羯摩叉婆(十八)唵句啰呿伽叉婆(十九)婆摩喽毕也鼻耶叉婆(二十)舍摩迦阇叉婆(二十一)叉耶啰娑叉婆(二十二)羯哆鼻耶婆叉婆(二十三)耶耶耶(二十四)泥那都那(二十五)阿婆泥那都那(二十六)那耶波那夷那都那(二十七)伊沙伊婆都度呿[口*寫]莎呵(二十八)

说此咒已白佛言。世尊。此无愿顺陀罗尼。是彼智德峰王如来所送。尔时释迦牟尼佛及一切娑婆世界诸大集众。皆赞善哉善哉。唯除在定。尔时释迦牟尼佛告炎德藏菩萨摩诃萨言。善男子。我今不起此座。于大众中广为一切众生说此无愿顺陀罗尼。文字句义不增不减。善男子。汝从彼来。智德峰王佛为护汝故。说智慧依止陀罗尼。汝今当为一切众生于此宣说。若有众生闻此法已。所有上中下结。欲有因缘所生烦恼悉皆微薄。复能除却恒河沙劫生死之苦。一切恶业亦皆除灭。一切善根具足圆满。尔时炎德藏菩萨白佛言。世尊。如是如是。我今当说。即于佛前说智慧依止陀罗尼

怛绖他(一)佉伽波利眵(尺之反)提(二)伽唎婆叉(恻檀反三)西伽跋梨(四)鼻也钵啰婆伽叉(恻檀反五)叉婆踰岐(强子反)钵底呵梨(六)奢　磨那四迦涕(七)三摩迷伽阇师(疏齐反八)阿叉夜那低(九)叉婆跋栘(常兮反十)祢[馬*犬]那阇师(十一)婆摩娜阇师(十二)娑摩伽逻阇师(十三)阿地呵奢夜阇师(十四)鼻钵啰婆阇师(十五)西叉阇师(十六)西祢夜阇婆阇师娑利啰瞿咥(馨之反)夜阇师(十七)娑利罗瞿咥夜阿鞞绮婆那鸠世(十八)萨檀拘帝(十九)私婆檀那梯(二十)毗哆钵啰鼻利低(二十一)呕波羯啰磨那梯(二十二)阿那比地夜跋罗仚(羌兮反二十三)钵罗帝羯迷那(二十四)三迦太夜世(二十五)萨卢遮那婆迷拘嚧太梨(二十六)迦摩萨世(二十七)阿世奢佉岐(躯予反二十八)那夜军阇(二十九)鼻地夜跋泥(三十)羯罗那跋泥(三十一)郁遮跋泥(三十二)三迷摩迦梨(三十三)奢利夜跋泥(三十四)摸伽阇师(三十五)呵利拘那婆(三十六)那夜那目仚(三十七)娑啰叉拘梨(三十八)那罗延拏树梨(三十九)因陀罗婆萨泥(四十)乌阿(四十一)阿婆阿(四十二)阿阿(乌可反)何罗婆阿婆啰(四十三)阿婆啰(四十四)阿罗萨弥伽(其我反四十五)豆佉祢提(都夷反)啰(四十六)涅槃醯(四十七)莎和呵(四十八)

说此咒已作如是言。此是智德峰王佛所说陀罗尼。尔时释迦牟尼佛告长老舍利弗言。汝可受持此智慧依止陀罗尼。所以者何。佛出世难。闻此陀罗尼亦复倍难。舍利弗。若佛如来及佛弟子大阿罗汉。于百劫中可得知此四天下微尘等数。此智依止陀罗尼德于百千劫说不能尽。此陀罗尼如是甚深。是故应受持读诵。于此众中广为人说。若有众生能听受者。彼人所有下中上欲有因缘所生烦恼及色无色有因缘所生烦恼皆悉微薄。复能除却恒河沙劫生死之苦五无间业。及于女人旧所造业皆悉除灭。乃至漏尽得涅槃道。尔时虚空藏菩萨摩诃萨合掌向佛而说偈言

  如来真实知法界　　示魔众生正真道
  若有真实生信心　　是则能破三恶道
  供养如来一香华　　无量世受无上乐
  无量世中身具足　　亦得无上真智慧
  若能一闻是总持　　即能摧灭诸烦恼
  一切人天所供养　　获得无生及尽智
  华德藏佛功德具　　彼佛使我来问讯

尔时虚空藏菩萨白释迦牟尼佛言。北方去此八十恒河沙世界。彼有佛刹名一切香上。具足五浊。佛号德华藏如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。彼佛使我送欲。并问讯释迦牟尼佛。如来于此降伏众魔及龙眷属。最胜无碍转妙法轮。但此刹中诸恶众生。于佛法轮不顺行者。是故彼德华藏佛。说此日藏法行坏龙境界炎品一切众生恶业尽陀罗尼欲。所谓奢摩裴多悉致那利陀罗尼。此陀罗尼能令众生得大势力得大利益得大安隐。能除一切病苦。能坏一切烦恼一切阴入界。能差别知一切法。能示一切方便。能清净涅槃道。能令一切众生心生欢喜。能入一切法门无有障碍。能以正法降伏外道令住佛法。能坏一切魔王境界。此陀罗尼有大力用。善摄一切诸魔外道令失势力。能令诸天生大欢喜。能令夜叉心生知足。能怖阿修罗。能坏金翅鸟。能令紧陀罗生大欢喜。能令摩睺罗伽不敢回顾。能令外道默然无对。能令刹利心生欢喜。能令婆罗门信入佛法。能令毗舍首陀罗等皆大欢喜。能令女人不乐多欲。能令怀孕女人产生安隐。能令多闻人心不失念。能令坐禅人乐阿兰若。能除一切患难一切斗诤饥馑疾疫。能除内外奸宄。能除非时寒热风雨暴水。苦辛枯涩恶触等事。能光显法母建立佛法。绍三宝种令不断绝。于生死中作大安慰。能生尽智。能证无生智。能坏无明暗聚一切苦担此名奢摩裴鞞多悉致陀罗尼。尔时虚空藏菩萨即于佛前。说奢摩裴多悉致那利大授记陀罗尼

怛绖他(一)摩那叉(恻我反二)阿婆叉(三)罗伽婆叉(四)阎罗叉(五)末摩那叉(六)阿婆叉(七)曼陀叉(八)那荼叉(九)那荼啰休(十)鼻萨那吒(十一)佉伽那吒(十二)阿吒那吒(十三)拘那吒(十四)钵利鸠萨那吒(十五)那荼那吒(十六)富利迦那吒(十七)郁怛罗那吒(十八)迦毗那吒(十九)军阇那吒(二十)苏目伽那吒(二十一)遮婆茂啰那吒(二十二)佉伽凡钳婆啰那吒(二十三)富沙迦啰那吒(二十四)系娑(苏我反)郁卢达啰那吒(二十五)三摩罗耶那吒(二十六)失啰鸠三(二十七)憍怛吒(二十八)怛罗(二十九)摩妒佉啰婆(三十)提畜叉(三十一)婆帝啰竖(三十二)豆婆那摩罗竖(三十三)婆呵呵那否智(三十四)僧低(当梨反)啰阇婆(三十五)阿摩啰阇竖(三十六)摩呼啰伽阇罗(三十七)阿祢拏婆啰(三十八)阿祢拏叉(三十九)阿婆阿唎伽祢拏叉(四十)咽沙咽婆都豆佉写(四十一)莎波呵(四十二)

说此咒已白佛言。世尊。此陀罗尼有大势力。有大利益。彼德华藏佛令我送来。尔时释迦牟尼佛。赞言善哉。及一切大众皆赞善哉。除坐禅者。尔时佛告虚空藏菩萨摩诃萨言。善男子。我今不起此坐。广为大众说此陀罗尼。文句及义不增不减。善男子。汝从彼来。德华藏佛为护汝故说陀罗尼。令恶心者生欢喜心。诸不信者悉皆惛睡。此陀罗尼从德华藏佛所久修四无量行生。汝今当为一切众生于此宣说。若有闻此陀罗尼。一切恶人皆生欢喜

尔时虚空藏菩萨。即说一切恶心众生生欢喜心不信众生悉皆惛睡陀罗尼

怛绖他(一)浮呼鼻利呵(二)浮浮罗(三)咽逻啰浮(四)一逻(五)娑呵(六)呵筹(七)伽筹(八)伽伽那叉(九)奢摩奢摩(十)蜜多啰蜜多罗(十一)斫迦罗(十二)跋帝帝隶(十三)娑伽啰帝隶(十四)豆利哆哂(香指反)寐(十五)哂利呼跋醯(十六)那罗阇斋(吒戒反十七)夜婆那蜜低黎(十八)绮底蜜低梨(十九)婆利蜜低梨(二十)始佉蜜低黎(二十一)摩都啰蜜低黎(二十二)佉伽蜜低黎(二十三)萨都阇蜜低黎(二十四)萨婆羯摩蜜低黎(二十五)摩那跋利哆蜜低黎(二十六)陀胝(张夷反)漯婆啰蜜低黎(二十七)莎和呵(二十八)

说此持已。一切恶龙各还所住悉皆睡眠。唯除得忍不退转者。乃至恶夜叉。恶阿修罗。恶迦楼罗。恶紧那罗。恶卑离多。恶毗舍阇。恶富单那。恶迦吒富单那。彼一切众各还所住皆悉睡眠。唯除得忍不退转者。若复有人恶心粗犷无有慈悲。彼此怀恨常不舍离。不畏当来堕于恶道。造五无间诽谤正法。毁呰圣人乐行不善。彼恶众生闻此咒已悉皆惛睡。有信心者得慈悲心。不斗诤心得不浊心。得念法缘心。畏当来世堕三恶道。得恭敬三宝心。得念法心念寂灭心。一切众生闻此陀罗尼已。即得住于如是等心。尔时虚空藏菩萨白佛言。世尊。我欲来此。彼德华藏佛。为护我故。说此陀罗尼。尔时释迦牟尼佛告长老目干连言。汝可受持此陀罗尼。目连。如来多陀阿伽度阿罗诃三藐三佛陀出世甚难。闻此陀罗尼亦复倍难。所以者何。此陀罗尼从无限齐四梵行生。目干连。如来百千劫不行余业。说此陀罗尼义。一切天人无有能知者。乃至十地菩萨亦不能知。唯除诸佛。此陀罗尼如是甚深如是大力。能与大利益。能速满足阿耨多罗三藐三菩提。又能满足大慈大悲教化众生。是故目连。汝当受持读诵此陀罗尼。于大众中广为人说。若有闻此陀罗尼者得大利益。多嗔众生于未来世应受恶者。皆悉尽灭不受果报。能知生死多诸过恶。修大善根取大福德。亲近大善知识供给供养。是故速得不退阿耨多罗三藐三菩提。目连。此陀罗尼能然法灯。绍三宝种

大方等大集经卷第三十七大方等大集经卷第三十八

        隋天竺三藏那连提耶舍译

    日藏分定品第四

尔时世尊。告四使菩萨及其眷属诸菩萨等。善男子。汝若乐住此娑婆界者。各各随意入所修学。自福德善根。三昧陀罗尼。三摩提。三摩跋提。时四菩萨及其眷属。即便各各随意入定。入禅定已身出光明。有菩萨光如大炬火。有菩萨光乃至如百千万日月光者。尔时大德憍陈如。承佛神力作如是念。我今欲问如来一义。如来因是。或当分别广说如来四陀罗尼文字及义。如来若说。此娑婆界十方之众。若得闻者坏疑网心。于一切法得大光明速得四果。未得须陀洹速得须陀洹。未得斯陀含得斯陀含。未得阿那含得阿那含。未得阿罗汉得阿罗汉。过三恶道得人天身。一切悉得纯善之法。作是念已即从座起。合掌向佛默然而住。尔时佛告阿若憍陈如。汝将不欲问我义耶。憍陈如白佛言。如是世尊。我实欲问。愿佛听许如我意说。佛告憍陈如。随汝意问。我当广说令汝心喜。一切天人闻此语已皆生欢喜。尔时憍陈如白佛言。世尊。如佛经中说有二种。所谓爱及富伽罗。行于生死。云何名爱。云何名富伽罗。何故如来说此二种行于生死。佛告憍陈如。善哉善哉快发斯问。憍陈如。汝为怜愍一切众生故作是问。欲与一切众生乐故作如是问。如是问者是知时问。憍陈如。至心谛听我今当说。憍陈如言。如是如是。如佛所说我当受持。尔时世尊告憍陈如。爱有三种。所谓欲爱。色爱。无色爱。复有三种。所谓有爱。离有爱。法爱。憍陈如。何者欲爱。欲名放逸。放逸因缘则生贪触。以触因缘。则生乐想。如是等法众生乐着。欲心发动如火所烧。欲因缘故。乐造十恶舍离十善。以是因缘。堕于地狱畜生饿鬼。生贫穷夜叉中。欲因缘故于生死中。受五阴身具种种苦。虽受是苦不生怖畏。心无惭愧不乐修善。于流转中难得人身。设得人身以欲因缘身口不净。造作无量诸重恶业乃至五无间业。以是因缘。复于生死三恶道中受大重苦。一切受苦皆因欲心。欲集因缘犹如粪猪被于系缚。趣三恶道受诸苦恼。是故如来为断贪欲。宣说正法呵责欲法。若有众生得闻如是呵责欲已。能如实观诸欲不净。如毒生果。如大火聚。如满[土*瓦]毒药。如满瓶粪。如利刀如贼。如旃陀罗加絺那。如热铁丸。如大雹雨。如恶毗岚婆风。如恶毒蛇。如恶野泽。如罗刹洲。如跋陀伽都。如种种粪扫聚。如尸陀林。是人如是知欲过患。于欲事中生大怖畏身大战动。爱法乐法学法欲。剃除须发身被法服。求于正法求法自在。于正法中生清净心。于法道中行法救济。如是乐者。彼人临终获得正念。以念法故。乐法气味故。念法果报故。见十方佛在大众中宣说法要教化众生。既闻法已得欢喜心。心欢喜故数数得见诸佛色身。是人死已离三恶道生有佛刹。常与善人游止。共俱能行布施忍辱精进乐于禅定。修习五通乐涅槃道。大慈悲心教化众生。能得诸佛璎珞庄严功德之身。过去所有烦恼及习悉皆尽灭。彼诸众生得如是庄严身心。譬如香箧盛种种衣衣服皆香。而彼香华不失称两。不损其色。如是憍陈如。若有众生乐法因缘。临命终时得见诸佛。因见佛缘得欢喜心。心欢喜故生有佛刹。共善众生同其事业。亦复如是自增善根。得种种璎珞庄严身心。不久得阿耨多罗三藐三菩提觉。而彼善不减。是故憍陈如。若有善男子善女人。见自利益见他利益。见彼此利益。常应亲近善友学善友法。常闻善友呵责欲法种种过患。如是闻已。乃至得阿耨多罗三藐三菩提道。憍陈如。所言善友者。谓诸佛菩萨辟支佛阿罗汉。又善友者即我身是。何以故。我今出世怜愍众生。欲为断除一切苦恼。能说诸欲一切过患。是故大众应受我语我不妄语。常真实语非无义语。非粗恶语慈悲心语。我今当说诸欲罪过。汝等应当一心受持。既受持已。于三恶道速得解脱。乃至得阿耨多罗三藐三菩提

尔时一切娑婆世界三千大千一切大集。诸来众等同发声言。唯愿如来宣说欲过。我等闻已。如佛所说至心受持。佛言憍陈如。谛听谛听。四种因缘众生生欲。何者为四。色贪。长短赤白等贪。触贪。乐贪。乐歌舞种种庄严璎珞服饰等贪。何者色贪。色名四大和合。生灭不住。无我无众生。如是四大。无我无众生。一切凡夫无明颠倒。横于色中而生觉观。此是男此是女。此好此恶。此可乐此不可乐。欲火入心犹如鬼着。男见女身执相。取着长短黑白。以是因缘。未生欲能令生。已生欲能令增长。是人如是念欲转多常不舍离。一切善根悉皆减少。不复爱乐诸善知识。不能善护身口意业。与一切罪而共和合。不见一切诸欲过患。以不见故。命终即入三恶道中。或在地狱。或在畜生。或在饿鬼。于彼恶道。无量世中受诸大苦。皆由贪欲。贪欲因缘令欲增长。诸有智者观察女色念不净想。不念女身所有发毛皮肉筋血。但念白骨专心不舍。如女人身男子身亦如是。如见近身远身亦如是。如他身自身亦如是。但念白骨不念发毛皮肉筋血。如是念已数数思惟。心常信念不忘失者。此名心顺行道初断欲法门。是人复念彼骨中心三摩跋帝。住于眉间如枣许处。如是念已数数思惟心住不失。彼人尔时心得寂静。气息不出不入。不见恶相不见恶事。不乐不念乃至不缘一法。是则名为奢摩他名心寂静。此名烦恼顺行道第二断欲法门。云何身寂静。是人如是念故。能令身中出入息定。不入不出。彼智慧人波啰娑佛陀。身心乐寂灭。如是念故心速顺奢摩他。此名第三寂灭攀缘断烦恼道法门。是人复念头骨顶中如一小枣处。如是数数念已见彼中空。如是数数念空。见彼顶骨如一沙尘。如是第二第三见骨末。依此法用一切头骨皆如尘末。见彼骨末为风所吹。如是见一切身骨。皆悉如末为风所吹。如是不见身骨乃至见虚空。彼中身心波啰娑三跋帝。此名第四顺奢摩他寂灭攀缘断烦恼道法门

尔时长老阿若憍陈如白佛言。世尊。虚空相者。是有为相不。佛言如是。善男子。虚空之相是有为相。时憍陈如复白佛言。世尊。若虚空相是有为者。为是自相为他相耶。佛言憍陈如。若能观察一切法界及有为界。是名自相。何以故。若能观察色寂静者。当知彼人能见如来。所以者何。若人观骨。见骨如末为风所吹。见是事已。能深观察色之实性。是人尔时见一切色悉皆空寂。乃至不见一切诸相。唯见虚空但念虚空。于彼虚空数数修习。见十方色一切皆空如净琉璃。于中复见无量诸佛。乃至十方亦复如是。见佛身已。又见如来三十二相八十种好。乃至十方悉见诸佛色身具足。光照团圆如尼俱陀树。彼人过去若曾习学涅槃之道。有善根者。即作是念我当问佛。如是虚空谁之所造。久近当灭。作是念已即便问佛。尔时如来即为宣说。夫虚空者。但有名字无有作者当何所灭。言虚空者。无有觉观无物无数。无有相貌无出无灭。一切法相亦不可得。能想所想亦皆是无。了知是已。于诸想缚悉皆解脱。即便获得阿那含果。能断一切贪欲之心。唯有色爱无色爱结。及于掉慢诸无明在。彼人尔时见佛身已。作如是念。我今当知如来身相长短广狭。作是念已。见所在处十方空中悉有如来。彼人尔时欲得观少即便见少。欲得观多随意见多。无量无边亦复如是。复次彼人更作是念。如是诸佛从何而来。复作是念。如是如来无所从来去无所至。彼人尔时不见诸佛有去来已。又作是念。三界受身心但虚假。以是因缘我随觉观。欲多见多欲少见少。诸佛如来即是我心。何以故。自心作佛自心见故。心即我身身即虚空。我因觉观故见无量无边诸佛。我以觉心见佛知佛。非心心知非心心见。见心相者则不可断。我观法界性无牢实。随念生故。是故一切所有性相。及心觉观即是虚空。虚空之性亦复非有。若能如是见彼空者。已于过去发菩提心。彼人修习三昧因缘。即得诸佛现其前住。是人若发求声闻心。即得一切无相三昧。既修习已。复得无著清净智心远离无明。亦复获得随顺空忍。不久得于四果真证。彼人若见空即是空。尔时即得身心寂静。得寂静已。是则名为空解脱门。入是门已。欲得取于阿罗汉果则为不难。是名第五修习空寂灭诸攀缘断烦恼道真实法门。尔时世尊说此法已。彼大众中有九十九百千万亿诸天及人。得奢摩他顺忍。八万四千人得空顺忍。如是六万天人得空三摩提解脱法门。二万众生皆得诸佛现在三昧。无量众生得须陀洹果。八十四百千比丘得无漏道

尔时佛告憍陈如言。若复有人自观头骨心若不停及不乐者。是未调伏。既未调伏亦复不能得于解脱。彼人尔时应当更诣尸陀林所观察死人。或见青瘀膖胀血涂。或见脓流处处淹渍。皮肉烂溃筋脉相交。禽兽往来争共唼食。或见白骨其色如珂。髅颔差移手足分散。见是相已。当熟察心乐住何处。知已即观常念不舍。一切外色败坏若斯。自揆我身亦应如是。始从青瘀臭处腥臊。终至白骨支离消散。心常专念勿使他缘。若住若行若坐若卧。勤修观行滑利流通。昼夜相续不令驰散。闭目开目恒使分明。从少至多内外洞彻。如是展转乃至山河草木丛林人畜等物。皆作骨相亦复如是。于四威仪常见自身骨具等事。未曾舍离。如是心住不动如山。于一缘中常定无乱。不净念等悉具足满。彼人尔时于此身中作是观已。乃至命终不起染心。于现在时能离贪欲。他世未能。此人若得顺虚空陀罗尼。即能观骨作离散相。如是念已。四方俱时皆令风起吹此骨身。皆悉磨散使如微尘。如是自身风因缘故。皆作尘已一切诸色一切大地。亦各以风因缘力故散如微尘。如是作已。身及万物悉皆随风。尘飞消散都无所见。犹如虚空离诸言说。如是观已得虚空相。见一切物如青琉璃。数数修习。如是等念令不驰散。如是观已。复观虚空作于黄色系心忆想。亦令成就无分散意。如是观已。复观赤色想念赤色。观赤色已。复作白色想念白色。观白色已。复观紫色紫色成已。观颇梨色。于虚空中作如是念。如是万法色及地等一切诸物。皆见青色及颇梨色令不驰散。作是观已次作水想。亦见青色及颇梨等一切诸色。皆见于水更无余想。唯见大地如四指许。余皆为水。彼人见是四指地已便无增减。复作是念。我于今者当以足指动此大地。使令动转随意久近。若欲令于少分动者即随所念。如是动已。乃至能令诸山大地大海江河。一切随动出大音声。其声远彻闻于余方。复观诸水有种种色。或优钵罗华。拘物头华。钵头摩华。分陀利华。如是种种一切诸华皆随念见。复观虚空皆作地想。于其地上行住坐卧俯仰屈伸。复观一切土石诸山作种种色。事形细软如兜罗绵。于其山上回转去来经行宴坐。彼人尔时作如是等诸外观已。悉皆放舍还更摄念。复自观身作轻微想。更增修习令其成就。如兜罗绵随风飘散。作是观已于虚空中行住坐卧。是人复入火光三昧。身现种种妙色光明。青黄赤白及颇梨色。又复游入炎摩迦定。于身上下互出水火。乃至地中现于出没。如鸟处空无诸障碍。日月威力有大光明。能以手摩不生惊畏。又复身上到于梵天。作如是等现神变已。复随所乐作如是念。于其身内或青或黄或赤或白。或复见紫及以颇梨。复作是念。我当云何得见诸佛。随其方所皆悉睹见。彼人尔时若欲见小随念即见。若欲见大亦随念见。乃至充塞遍满虚空。复作是念。是等诸佛。无所从来去无所至。唯我心作。于三界中。是身因缘唯是心作。我随觉观。欲多见多欲少见少。诸佛如来即是我心。何以故。随心见故心即我身。即是虚空。我因觉观见无量佛。我以觉心见佛知佛。心不见心心不知心。我观法界性无牢固。一切诸法皆从觉观因缘而生。是故法性即是虚空。虚空之性亦复是空。我因是心见种种色青黄赤白。一切杂色及以虚空。种种示现作神变已。所见如风无有真实。但妄想心依止于色。是则名为共凡夫人顺四谛陀罗尼。佛言憍陈如。何者名为不共凡夫四谛顺陀罗尼。若有人能作如是念。此虚空者不可捉持。无有觉观不可宣说。心亦如是犹如虚空。不可捉持不可宣说。如是二种。皆悉虚妄忧愁恼乱。犹如火烧虚诳斗诤。我今舍离是空色等。一切诸念乱想觉观。如是舍诸虚空色等虚妄觉观一切心已。心不复生。离诸念故心得寂灭。得寂灭已更不复生。何以故。心缘灭故是心便灭。身心释悦悉皆舍离。以舍离故身得安隐。舍觉观故口离语言。心安一缘修习灭定。是人尔时一日一夜。入于如是寂灭三昧。如意自在经无量亿百千万岁。于是三昧堪忍不散。从灭定起舍有漏法及其寿命。入于涅槃。此名无漏不共凡夫四谛顺陀罗尼第一解脱门。佛复告憍陈如。云何名为共凡夫人四谛顺陀罗尼。若有人能作如是念。我随觉观观如是色观如是我。我心即色色即我心。若我远离一切色相观虚空相。是人尔时修虚空相。即入无量空处三昧。此则名为共凡夫人顺四谛陀罗尼义。若有人能作如是念。色即是空我以此色因缘空故。得见虚空。何者境界是虚空相。虚空之性名无障碍。是风住处。如是风者是四大相我色亦尔是四大摄。此二法者无有差别。心亦如是犹如虚空。复作是念。此四大者以何为体。一切诸法性自空寂。自他等性亦皆空寂。夫虚空者即无所有。不生不灭无处无家。作是观时系念诸佛。既系念已。见虚空中有无量佛。一心念已得阿那含果。此则名为不共凡夫四谛顺陀罗尼第二解脱门

复次行者作如是念。何者境界是虚空相。复何因缘名为我相。行者自念。言虚空者即是我也。即是净我即是我心。我者无色如虚空无边。我亦如是此则名为共凡夫人如实陀罗尼。若有能观一切法空无我我所。言空处者即是无我色亦无我。若观如来即是我也。我见佛已。得须陀洹果斯陀含果阿那含果。乃至一切有漏法尽得阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第三解脱门

复次行者。若观于我清净不浊。即是空处空即我心。若能永断一切烦恼即是净心。若能修习八直正道是名净心。作如是学。即能获得须陀洹果乃至证得阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第四解脱门

复次行者。若有欲观于色相者即分别相。分别相者即是嗔相。嗔恚相者即生死相。我今为断生死相故观心相空。此则名为共凡夫人四谛顺陀罗尼。行者若观于我即是寂静。我今亦未断于觉观。若观于我及我我所如观虚空。我我所者即是苦也。苦所从生即名为集。如是苦集是可断法是名为灭。观苦集灭是名为道。得须陀洹果斯陀含果阿那含果。乃至获得阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第五解脱门

复次行者作如是念。何以故。我今已观此虚空相。夫虚空者即是于我。我若远离虚空观者。次观识处。如虚空观识观亦尔。如虚空处无量无边。识亦如是无量无边。此则名为共凡夫人四谛顺陀罗尼。行者若念识名为想。亦名觉观。识即是苦。知苦所从名之为集。苦集可断是名为灭。观苦集灭是名为道。得须陀洹果斯陀含阿那含阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第六解脱门

复次行者若观识处即是觉观。如刺入身如疮如病。如我前时远离空处。离空处已亦离识处。离识处已修无想处。是人尔时得无想已不缘一法。即得住于无想三摩跋提。此则名为共凡夫人三摩跋提。若观识处即是疮痍苦恼之法。如病如痈。如我远离观于识相。次观无想。言无想者即是无我。无我我所想。观念清净大般涅槃。作是观时。即得须陀洹果斯陀含果阿那含果。乃至得于阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第七解脱门

复次行者若有能观无想处者。即是细想。如我远离是无想处观。非有想非无想处亦复如是。此则名为共凡夫人如实陀罗尼。若观非想非非想处即是大苦。是处可断可得解脱。作是观时。彼人即得须陀洹果斯陀含果阿那含果。乃至得于阿罗汉果。此则名为不共凡夫四谛顺陀罗尼第八解脱门

憍陈如。此陀罗尼有如是等不可思议种种利益。又能除断一切欲贪一切色贪一切非色贪。离凡夫位得圣人法。永断一切三恶道因。于当来世不更受于地狱畜生及以饿鬼。是名四谛顺陀罗尼。汝今当知。此即是彼瞻波迦华色如来所遣。日行藏菩萨所赍持欲。我今在此说大集经。是故彼佛送此欲来。此陀罗尼能断一切诸结烦恼。又能永尽一切结恨诸增上慢及我慢等一切嫉妒。能却世间一切家业一切戏笑。能断一切我见一切疑见及婆罗多触。能断一切常见断见寿命见逋沙见富伽罗见作见知见一切色见乃至触见一切生见一切四大见。能断如是一切诸见。能知一切五阴十二入十八界等。能令受者得涅槃乐。能坏众魔调伏恶龙。能令一切诸天及诸夜叉皆生欢喜。能怖阿修罗及迦楼罗紧那罗摩睺罗伽。能坏一切恶邪外道。能悦一切刹利婆罗门毗舍首陀罗。能令一切多贪妇女念于少欲。能令多闻人心生欢喜。能令坐禅人乐阿兰若。能疗一切诸恶重病能却一切斗诤饥馑疾疫凶衰及诸横死。能除外贼恶风恶雨恶水瀑河非时寒热。种种苦辛粗涩恶味。能光法母建立法幢。绍三宝种使不断绝。又能安慰生死流转恐怖众生。令其快乐。能生尽智证无生智。能裂无明破诸闇聚。能舍苦担入于涅槃。佛说此四谛顺陀罗尼忍时。无量无边阿僧祇众诸天及人。远尘离垢于诸法中得法眼净。九十六亿那由他众生。舍诸烦恼心得解脱。八十亿百千那由他众生。得此四谛顺陀罗尼。无量无数阿僧祇众生。发阿耨多罗三藐三菩提心。亦复得于不退转道。四万二千众生得无生法忍。一切天龙夜叉罗刹阿修罗迦楼罗乾闼婆紧陀罗摩睺罗伽。薜荔多鸠槃茶。毗舍遮人非人等皆悉赞言。善哉善哉无上世尊。言音微妙不可思议。最胜难量不可称说。无慧眼者为出智光。苦担众生能为除却。于流转海作大船筏。如是善巧无碍智说。谁有闻者不乐发于阿耨多罗三藐三菩提心。尔时长老阿若憍陈如白佛言。世尊云何名为日眼莲华陀罗尼。如日行藏菩萨摩诃萨之所宣说。智者受持读诵书写得大利益。于三界狱不生乐想。得无相三摩提解脱门。得无所有处三昧。得双头灭结。若有闻者能薄烦恼。七返常受人天之身。于人天中能得圣道。不为贪欲之所染污。诸天世人常所恭敬。佛告憍陈如。谛听谛受。精勤用心莫生疲懈。汝所问此日眼莲华陀罗尼者。非是一切声闻辟支佛心行境界。何以故。此陀罗尼乃至清净十八不共佛法力生。憍陈如。若我今于百千万劫。说此日眼莲华陀罗尼终不可尽。亦令闻者一切天人心生迷闷。此陀罗尼唯佛能说唯佛能听。何以故。此陀罗尼有无量义难知难觉。如日眼莲华陀罗尼。自余三方无尽根陀罗尼。智依止陀罗尼。恶睡眠众生陀罗尼。亦复如是。憍陈如白佛言世尊。唯愿说彼南方山王如来香象菩萨所送空顺陀罗尼。佛言。如是如是。至心谛听当为汝说。憍陈如。若有众生触欲因缘惛醉迷乱。不知解脱醒觉之处。流转生死于无量劫在三恶道。受诸苦恼不可堪忍。菩萨摩诃萨大慈悲心。见诸众生受如是等无量苦恼。起大精进修行诸道。修行道已得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。说出苦道。若有众生能至心听如说顺行即得脱苦。得须陀洹果乃至阿罗汉果。佛告阿若憍陈如。云何触欲。若有众生和合欲事。因和合故则生于触。因触生乐。因乐生苦。苦因缘故。生死苦恼从是而生憍陈如。如四毒蛇。以四因缘能害众生。所谓见毒嘘毒啮毒触毒。如是一切念欲众生亦复如是。有见因缘有闻因缘。有念因缘有触因缘。以是四缘。令诸众生远离一切诸善根本。于生死中受大苦恼。佛告憍陈如。云何名为触欲解脱。若彼行者作如是念。以何方便得离触欲。复作是念。若我能观骨琐远离贪欲。是则名为最胜方便。作是思惟。色者即是四大所造。四大所造即是无常。性无牢固破坏离散。皮肉发抓脓血筋骨。智者终不于是身中生净好相。作是观已。若昼若夜悉见一切十方清净犹如珂贝。见是事已。即时获得一切世间不可乐想。如是行者复作是念。我此生死烦恼鼓作。我于此想若乐修者。则能断除一切烦恼生老病死。如是行者于一切骨正觉观已。一心正念不失不动。此名奢摩他。如是次第正观头骨乃至足骨。一心正念不失不动。此名毗婆舍那。复作是念。以何方便得破生死。作是思惟。观于口鼻和合入出风方便故。破生死鼓。如是行者自观身骨。犹如碎末为风所吹。于自身中骨想皆尽不见身相。如是观时远离身相。生于空相不见内法。此则名为第一空门。复次行者。于自身中复更思惟。一切外色风力所坏。作是观已。于此内外一切诸色不念不见。此则名为第二空门。复次行者作如是念。我今不见一切内外诸色相貌。皆是空力。我今定知一切诸法无有去相无有来相。作是观时。一切觉观悉皆永断。此则名为第三空门

复次行者作如是念。识为大罪。复观是识知是一切觉观因缘。我当速离心意识行。何以故。若有集法当知定灭。一切有法体非真实。一切有法性是寂灭。此则名为第四空门。作是观时。得须陀洹果乃至阿罗汉果。或有获得法顺忍者。或有获得菩提证者。复次行者。若观觉观是灭相者。即得灭定。此则名为不共凡夫空顺陀罗尼。是陀罗尼成就无量一切功德。有大力势能大利益。永断无量诸大苦恼。善能除断一切欲贪一切色贪乃至一切想非想贪。能舍一切烦恼苦担。此即是彼山王如来香象菩萨摩诃萨所送。以我说此大集经故。彼佛送此陀罗尼欲。说此法时九十二万百千众生得须陀洹果。六百万诸众生等不生烦恼。得无漏道慧心解脱。九十那由他百千众生。于初学中得此空顺陀罗尼。八百万诸众生等。得辟支佛证智定心。六十六频婆罗众生发阿耨多罗三藐三菩提心。无量众生亦得住于不退转道。一切大众皆赞善哉。天雨杂华并散香末。尔时憍陈如复白佛言。世尊。唯愿如来。为我说彼智德峰王佛。遣炎德藏菩萨摩诃萨所送无愿顺陀罗尼。佛言。如是如是憍陈如。至心谛听当为汝说。有诸众生处在世间。爱乐于欲昼夜贪味不知出道。不知出故。于流转身受大苦恼。是人应当观于无愿解脱法门。作如是念。欲欲。色欲。及无色欲。触欲。解欲。如是等欲因觉观生。诸行因缘和合故有。复次行者更如是念。如是诸行无有作者无有受者。因风造作故有。于我身口意行亦复如是。因风而生。因是风故身得增长。因是风故口得增长。复作是念若身口意因风造者。我当碎身令如微尘。如是念已谛自观察。我此身中入出气息即同彼风。谛观一切身诸毛孔。从风因缘故有生死。复观一切不净之物。肉血发抓因风故成。复观是身命终之时。是尸更无风息入出。复作是念。我身口行因缘于风。若无风者无身口行。是故尔时得空三昧修集增长。因修集故一切有本叶薄华萎。乃至渐渐能断欲贪及以解欲。作是观已得须陀洹果乃至阿罗汉果。或有发阿耨多罗三藐三菩提心。复次行者若心乱时。应如是观彼欲因缘。念种种色乃至念天。以是心散。时彼行者更如是念。若我一切诸生处中。欲未断故此心更生。譬如伐树不去于根唯却枝檊。不除根故其树更生。爱亦如是。爱入未断能生诸苦。复次行者不念于取一心专修。乃至我身。骨琐雪白色如珂贝悉皆筋连。见骨琐已。是时若眼中见内外色。或复见彼一切皆空。但骨琐连色白如贝不增不减。时彼行者如是念已不失于心。此名奢摩他。复次行者若如是学。此我头骨齿骨项骨。乃至此是我脚指骨。如是念者坐不得禅。何以故。以有奢摩他毗婆舍那两种念故。心不得禅。时彼行者。摄念缘中心住不动。欢喜快乐速疾得修。若独念一毗婆舍那。心正住者。应当速疾念彼骨琐专系思惟。此行若明。更好观察骨相成尘。磨灭分散随逐因缘。作是观者。此名毗婆舍那顺忍觉。若一切骨离垢色白。碎末为尘与心和合。如是思惟。此名生顺忍觉。若彼行者观一切色。离垢洁白及骨成尘。离我和合心识去来。如是观者。此名无我尽顺忍觉。若一切色为识境界。眼中来者。离垢净白及以骨尘。作如是念。彼不可说。不可捉持。亦不停住。如是念者。此名奢摩他顺忍觉。如是行人。得此顺忍觉因缘故。于三世中现在未来。一切贪欲悉皆除灭及尽三有。于三界中脱三垢缚。即得入于三解脱门。如是念已。得须陀洹果。乃至如是一相念者。得阿罗汉果。复次行者。观一切色。及以骨琐犹如珂贝。离垢筋连见骨琐已。时彼行人心定不动。若心不动。行住坐卧常系一缘。如是念者。名奢摩他调柔修习。时彼行人。复更内外观察于空。念内外空得入三昧。观一切色悉皆青相。念此骨琐亦作青色。见诸骨琐作青色已。时彼行人复作是念。谁作此色及骨琐青。谁造谁安。乃至琉璃及颇梨色。作此思惟分别想已更如是念。此青色者心因缘见。是虚妄见非是实见。如是念已。知法从缘精勤修习。于诸世间常为众生礼拜供养。佛告憍陈如。此无愿顺陀罗尼义。除不乐想。及除食中诸颠倒想。是彼智德峰王如来遣炎德藏菩萨摩诃萨所送来欲。尔时座中有菩萨摩诃萨。名正念智白佛言。世尊。若诸声闻修不净相及奢摩他。得成相已有何等相。佛言。善男子。若为破坏贪欲之结。修不净念系心眉间。自观己身三百碎骨。如是相出及不净念。于是时中彼行人身亦热亦动。此名初相。得是相已。乃至常观彼如是相。见自己身涩触等相及以他身亦复如是。名第二相。又彼行者修不乱心。一切悉观亦皆不净。名第三相。是人能观苦集尽净。名奢摩他。行者身中如是相出得于暖法。如温乳汁灌澍身心。此则名为不动心相。时彼行者若有心中乐如是相。当舍念心。此相清净贪染。自除无明污心。智慧断故。行者如是观白骨时。念此骨相乃至寂灭因缘故。有如是观察。即见一切身中暖出。此如是相若奢摩他。得具足满。此则名为暖相善根。行者尔时缘于过去福德善根。今作此修心行清净。见智如灯内心自知。复次行者观身四行。从于琐骨乃至微尘洞彻明了。如自额中睹于灯炎。见一切色及以自心并心数法。尽分别知。譬如窗中日光明照。微尘回转无暂时停。一切有为譬如尘性。作如是念。乃至世间一切有法见无我见寂灭实智。行者尔时得顶善根。是名顶法。复次行者得顶法已。更自观身。或见火出或见火然。或见大光满十方面。从初禅地乃至四禅善根所生。如是色阴微妙四大。彼行者身亦如是得所见身色。满足禅乐不异于天。时彼行人更从心里复出日光。见于十方处处日轮皆悉遍满。见是相已不生心念。是时得入空三昧中。复见顶上种种色出犹如伞盖。此名顶相功德善根。复次行者不取缘相四谛顺忍。尔时彼中得四谛证。善男子。此名声闻修习不净正念因缘不净正念。因缘成已得奢摩他。是名白骨灯光观相。复于彼中如是相生。亦见是相。见是相已得欢喜心。欢喜因缘得八正道。因八正道能断一切烦恼爱结。得须陀洹乃至阿罗汉果。善男子。汝自刹中胜炎佛土。声闻之人若富伽罗乐阿罗汉。观如是法不净因缘即得道果。说此不净解脱法时。无量无数无边众生证得四谛如法顺忍。乃至无量无边众生得如实果。尔时世尊复告阿若憍陈如言。善男子。若一切众生共同一心。其四真谛可以一念而证得者。如来应为一切众生演说一行一法一事。亦不应有八万法聚。随逐因缘差别之异。若一人证时。一切众生亦应同证。若一人断时。一切众生亦应同断。不应别有声闻三乘。不应别有菩萨十地。何以故。烦恼同故。断时证处处所是同。憍陈如。是故众生应以种种因缘调伏。不以一缘及以一事。憍陈如。若一切众生觉观未尽。如是时中一切有法大疮大莿种种有生。种种生中有法。增长种种相种种色种种心。时彼行者如是思念。若欲自心乐心取相。观此骨琐心和合生。彼念因缘。作此初心次第思惟。如是必定得涅槃道果证不难。又见此身得乐因缘不退转故。复次行者作如是念。何因缘故心和合生。彼因缘故乐说方便。能知是者。此则名为第二胜心。现见法乐。住必定心得不退转。复次行者如是思念。我今此心几许因缘和合共生。处处觉观攀缘取舍。如是身心有乐受故。或妄想住。我于彼身心乐寂灭。又如是念。若我因缘和合故生。缘骨琐故。身心安乐乐已还灭。若彼行人生于眼识乃至意识。生及住灭方便因缘亦皆寂灭。作如是念。此则名为第三胜心现见法乐。必定不退得涅槃道。以是因缘及得四果不久不难。复次行者作如是念。若我此身一切法界。通达方便清净体性。亦非体性寂灭方便住。复如是念。我一切心相寂灭方便住。又一切心相觉观想灭寂静心住。此则名为第四胜心。现见法乐。如是必定得涅槃道。身虽未证欲证不难。憍陈如。如是四种最胜尚心和合现时。即得明见八十四百千三摩提行门。见是行己得阿那含果。乃至得阿罗汉果。尔时又得二种解脱。有大势力具大神通。为诸天人礼拜供养。憍陈如。一切众生非实一乘一行一贪一念一欲一解一信。是故如来宣说种种句偈名字种种法门。以是义故。如来具足十种神力。憍陈如。一切众生具有种种颠倒之想。是故如来为净众生颠倒想故。说无常想或乐苦想。或无我想或乐死想。或膖胀想或乐烂想。或乐脓想或青瘀想。或乐种种虫啖食想。或乐臭想或乐骸骨离散等想。尔时阿若憍陈如重白佛言。世尊。云何名为一切世间不可乐想。云何复名一切世间食不净想。憍陈如。汝今不应问如是事。何以故。我此刹中别有方便。得涅槃道及四果法。彼刹众生根性不同。信心行别。方便力别得涅槃道。国界既殊其相各异。憍陈如。若我具说如是之法。唯除得无生忍菩萨摩诃萨能信受此。其余众生闻即迷没。时憍陈如复白佛言。世尊。唯愿怜愍为诸菩萨能信解者分别宣说。世尊。是诸众生。若闻宣说一切世间不可乐想及以食中不净想等。听闻如是二种相已。能生种种上妙善根。能破无明种种障碍。一切众生爱入和合。痴见缠缚如揭头罗。于流转中处处受生。于流转中处处造行。又过去际诸流转中不可见知。以是因缘乐于生死。是故生死无有始终。何以故。一切众生在流转中。不闻如是食不乐想。以食因缘增长贪欲。又不闻于此法门故。是故五处流转受生困苦疲极。如来世尊大慈大悲。无量世中常念众生。唯愿如来怜愍故。说此具足满无愿顺陀罗尼

大方等大集经卷第三十八大方等大集经卷第三十九

        隋天竺三藏那连提耶舍译

    日藏分恶业集品第五

尔时世尊告憍陈如言。善男子。彼智德峰王如来。愍此世界五浊众生及天人故。命彼焰德藏菩萨摩诃萨送此欲来。为欲安乐诸众生故。时憍陈如重白佛言。世尊如是如是。惟愿如来广演分别一切世间不可乐想食不净想。若佛宣说不可乐想食不净想。众生闻者能舍欲贪不着诸味。世尊。若有众生能于诸欲及饮食中皆生怖畏。于此二事生厌离心。苦切呵责应修清净。当知是人越流转河速到彼岸。能得解脱诸有系缚。佛言。憍陈如。如汝所说一切世间不可乐想食不净等。对诸天人及余大众。如智德峰王如来无愿顺陀罗尼焰德藏菩萨摩诃萨所送。汝至心受。憍陈如言。唯然世尊。我今谛听。佛语憍陈如。云何名为一切世间不可乐想。憍陈如言。世间者凡有二种。一者众生世间。二者器世间。云何名为众生世间。所谓五趣众生。天人饿鬼畜生地狱。此名五趣众生世间。器世间者。欲界之中有二十处色界十六无色有四。此四十种。名器世间众生住处。欲界之中有二十处者。第一谓于八大地狱一一地狱四面各有十六隔子。以为眷属周匝围绕。彼中观察生不乐想。云何名为八大地狱。一名一死一活地狱。二名黑绳地狱。三名众合地狱。四名叫唤地狱。五名大叫唤地狱六名热地狱。七名大热地狱。八名阿鼻地狱。若过去未来及现在世有诸众生。自身口意造诸恶业故。生于彼大地狱中。经无量劫备受种种百千苦恼。彼地狱中设睹妙色。以心逼切不生乐想。以见因缘无乐想故复生大苦。如是转转从一地狱至一地狱。苦中极苦不可堪忍不可言说。若耳闻声及鼻嗅香。舌尝其味身中觉触。心缘诸法亦复如是。彼一切心不爱不乐不曾欢喜。一切不好无一可意。身常火然食热铁丸饮融铜汁。所有触处悉皆是火。不可忍耐极大苦受。彼诸众生以其恶业未毕尽故如是不死。乃至一切未受果报。亦彼中生。次复人中。身口意行造恶业故亦彼中受。憍陈如。世间众生多乐于乐不乐辛苦。彼地狱中谁欲乐入。此名最初恶业地狱众生所住之处。智慧之人观是事已生不乐想。憍陈如。何者名为第二所居畜生生处。观察彼已生不乐想。憍陈如。畜生之中身有差别。或有众生。其身大者。如析一毛以为百分如一分许。有于如是不可思议微细之身。复有众生身如窗中游尘。复有众生身如十千由旬。复有众生寿命如一时顷。复有众生寿命如七时顷。复有众生寿命一劫。乃至百劫千万亿劫。以恶业故在彼中生。不乐善法不种善根。无有法行亦无智慧。无惭无愧无慈悲心。常受苦恼生大怖畏。各各互生相害之心。远离一切诸善之法。常行不善无明黑暗。崄恶道中造地狱业。起嗔忿心不乐福德。是报熟时恶道中受。下身下心生如是处。常受种种饥渴寒热捶打乘骑。负重困乏领穿背破。蚊虻毒虫竞相唼食。如是苦恼无量无边。何有智人乐于彼处。智慧之人观是事已。于畜生中不生乐想。是名第二恶业众生畜生住处。憍陈如。云何名为第三所居饿鬼生处。观察彼处生不乐想。憍陈如。饿鬼之中身有差别。或有饿鬼身长一尺。或有饿鬼身量如人。或有身如千踰阇那。或复有鬼身如雪山。彼诸饿鬼裸形无衣。被发自缠黑瘦羸瘠。唯皮裹骨肉血都无。身体粗涩犹如枯树。恒苦饥渴思念食饮常不能得。口内火然焰出于外。心常嗔忿无有慈悲。热闷慞惶求凉不得。又为饥渴之所逼切。饮销铜汁食烧铁丸。及诸热恶臭烂脓血。热屎热尿热糗热浆。及诸热风或复热雨。一切草木江海河池。树叶华果所食之物。求觅甚难恒不能得。设复得之或经千年或百千年。如是寿命常受苦恼。行住坐卧黑闇无明。何有智人乐于彼者。智慧之人观是事已。于饿鬼中不生乐想。是名第三恶业众生饿鬼居处。憍陈如。云何名为第四人间所居之处。观察彼处不生乐想。憍陈如。有智之人次观人中。一切皆有种种诸苦。所谓生苦老苦病苦死苦。爱别离苦怨憎会苦。求不得苦五盛阴苦。饥苦渴苦贪苦嗔苦妒嫉等苦。妄言绮语两舌等苦。恶口骂詈诽谤等苦。寒苦热苦恶风恶雨疫蝗等苦。毒恶禽兽伤害等苦。恶世恶王牢狱等苦。贫穷下贱短命等苦。既念此苦更生重苦。缘苦生苦还造苦因。于未来身复受苦报。如是转转无量无边。受诸辛苦无有穷尽。何有智者乐于彼中。是名第四众生人中居处。智慧之人观是事已。于人道中不生乐想。憍陈如。云何名为第五所居欲天生处。观察彼处生不乐想。憍陈如。有智之人观初欲界有于六天。是中众生常乐欲事欲爱所缠。所受果报差别不等生于苦受。或复果报胜劣不同。或上或下。其下果报见上果报。耻愧羞惭常生苦受。或于过去修福来者今得生此。果报将终福德欲尽。如是念时则生苦受。或复种种有所为作。勤劳辛苦故生苦受。或所爱人玩弄之物。分张离散故生苦受。一切福德果报毕尽。见好处所心生爱乐。既不得往生大苦受。又知业行速堕恶道畜生饿鬼及地狱中。以如是故倍大苦受。如是种种无量诸苦。何有智者乐于彼处。此名第五欲界六天受报处所。智慧之人观是事已。于彼欲天不生乐想。复次憍陈如。云何名为色天中不生乐想。智慧之人观彼色界十六住处一切诸天。修于世禅得生于彼。因既有为是有漏法。苦未尽故。不得寂灭心意快乐。及于种种其余胜乐。是故苦受。又未到于乐彼岸故。是故在此苦流转中不知出道。以是义故三恶趣中未得解脱。是故苦受。何有智者乐于彼处。此名第六有漏色天。智慧之人观是事已。于彼色天不生乐想。复次憍陈如。智者观彼色界众生。如是修习无漏禅故得住彼天。以未具足满八正道。是故苦受。为八正道欲满足故精勤方便。是故苦受。一切无学三摩提地。心未得故生于苦受。彼辟支佛诸陀罗尼。未自在得故生苦受。于诸如来三昧境界。未自在得故生苦受。一切众生境界皆苦。如是众生于色界中。若欲双头入般涅槃。如上所说种种诸苦具足受之。何有智者乐于彼处。是名第七无漏色天。智慧之人观是事已。于色天中不生乐想。复次憍陈如。云何名为观无色天不生乐想。智慧之人观无色界四种天处。以能修习有漏三昧。故得生彼一切漏中。未得解脱。是故生苦。一切学地及无学地未得自在。是故生苦。不得听闻诸佛正法。是故生苦。一切爱欲未毕竟断。于流转中不得自在。是故生苦。彼处寿终不得胜趣生于邪见。如是大苦一切三恶。烦恼业道未能永断。如是生苦。一切三恶道中未得度脱。如是生苦。何有智者乐于彼中。是名第八无色四天。智慧之人观是事已。于无色天不生乐想。故得出于一切有狱。及离一切诸有中生。如是八种和合观时。智慧之人乃能获得。虽不生心而常至心修八正道。憍陈如。此则名为一切世间不可乐想。复次憍陈如。言世间者即名为行。云何智者于行世中。不生乐想。行有三种。何者是三。一者身行。二者口行。三者意行。云何身行。身行者谓气息入出。是名身行。云何口行。口行者所谓觉观言说。是名口行。云何意行。意行者名为想受。是名意行。是名三行。此三种行其相如是。一切众生一种心想。智者云何能分别知。于身口意生不乐想。智者观身出入气息取九十九数时。深观息之凉暖和合方便。一切身分出入气息。彼一切身出入气息从口鼻中。乃至一切毛孔道中气息出入。是人观息谛知是息。本无有生亦无有灭。若本来无今始有者。是无常想无决定相。如水上泡如空中霆。如是观时一切行中得身行相。观如是相从何因缘。即知是相因于觉观。觉观之性本无今有。是故无常。是可断法。是解脱法而是觉观因妄心生。而此心性本无今有。本无今有是无常相。可破坏相。无归依相。无有物相。无有我相。无有实相。作是观时于诸行中心则生悔。能修世间不可乐想。复次智者若能深观如是三世。则能永断一切烦恼十二入等。能净正见断除流转相续之法。成平直道正聚所摄。作如是等方便修时。决定能得须陀洹果乃至阿罗汉果。憍陈如是名智者于诸行中得不乐想。以是义故名不乐想方便攀缘。复次憍陈如。云何智者观所著衣作不乐想。憍陈如。若智慧人观于衣裳。或造或缝或割或染。及成就已在其身边。或见或摩或着或脱。如是想念此如人皮。见新色衣作血涂想。诸恶臭虫之所居停。蚊虻虮虱不净充满。智者见已不生乐心。如是憍陈如。此名智人于衣服中得不乐想。憍陈如。云何名为智慧之人观于食中得不乐想。憍陈如。若有行者执持钵时作如是想。此之皿器如剥发皮脓血所污。不净髑髅烂臭可恶。诸蝇蛆薮遍满其中无可贪者。若见食时应观是食。如死尸虫秽恶充遍。若得糗者作如是观。此糗糏尘犹如骨末。若得于[麩-夫+并]。应观是[麩-夫+并]作人皮想。如是得臛或复得浆。得粥得羹如是想念。此如脓血或大小便。或如人脂或如人脑。若得种种众杂菜茹。复作是观此如马髦或如人发。若得萝卜虀者。复作是念此如人齿。若得肉者作如是念此如人肉。得白石蜜或黄石蜜。或蒱桃饮或石榴浆。乳酪醍醐生熟苏等。作如是念此如人血。或如人脓或涕或涎脑髓唾等。如是恶露臭处难看。智慧之人于是食中不生乐想。复次憍陈如。云何智人于房舍中生不乐想。智者如是入诸堂宇房廊屋室。或楼阁中。入已思惟应生怖畏。我今入此外有四门。如大地狱焚烧我身。若见屋梁椽柱脊檩。如是观察此之材木共相牚柱。犹如人身一切碎骨。见泥泥壁如肉覆骸。见画庄严如血涂漫。又观种种床蓐铺席犹如人皮。又观坐卧眠止处所。或如骨锁或如死人。如是种种饮服汤药丸散煎膏。皆作是想起诸厌离。憍陈如。是名智人一切食中得不乐想。如是念已得何利益。即能获得三种顺忍。何者三忍。谓空顺忍。无相顺忍。无愿顺忍。是人如是得三忍已乐修空想。因修空想住是空中。见一切法悉皆是空。入是空已复得利益。能知生灭方便利行。如是阴界无常苦空无我不净。见十八界及十二入。乃至四谛十二因缘。一切法性苦空无常及以无我。如是念已得须陀洹果乃至阿罗汉果。得解脱相。复次憍陈如。此三摩提无学解脱。如是利益一切世间不生乐想。善能除断一切欲贪一切色贪及非色贪。一切疑慢。一切调戏。一切无明。又能安置于无学地。憍陈如。此名二种一切世间不可乐想。如是种种名具足满无愿顺陀罗尼微妙之义。此陀罗尼有大势力。能除欲色非色调慢。能证尽智及无生智。能裂一切黑暗罗网。能舍一切苦恼重摧。以我说此大集经故。彼智德峰王如来。命焰德藏菩萨摩诃萨。手中送此无愿顺陀罗尼欲来。憍陈如。是陀罗尼能摧一切诸恶魔等。能胜一切毒害龙众。诸天敬信倍更欢喜。夜叉顺奉生大踊悦。诸阿修罗内心怖畏。又能恐惧迦楼罗王。令紧那罗生于爱乐。摩睺罗伽自然摄伏。能破一切邪见外道。令刹利王生欢喜心。诸婆罗门信心增长。又令毗舍及首陀罗悉生欢喜。能令多欲女人贪心止息。令多闻者进益受持。坐禅行人乐阿兰若。能除一切种种诸患。能却一切斗诤怨家。饥馑非时外贼横死。恶风雹雨暴水灾霜。寒热苦辛粗涩味触。如是变怪悉能消除。光赞大乘绍三宝种。照曜佛母竖立法幢。安慰流转怖畏众生。此名微妙无愿顺陀罗尼。说是法时无量无数阿僧祇众生远尘离垢得法眼净。九十八频婆罗人得阿罗汉果。八那由他众生得彼无愿顺陀罗尼。无量无数阿僧祇众生发阿耨多罗三藐三菩提心得不退转。五百八十万众生得无生法忍。尔时一切无量大众。天龙夜叉罗刹阿修罗迦楼罗紧那罗摩睺罗伽。饿鬼毗舍遮鸠槃茶。富单那迦吒富单那人非人等。异口同音俱称赞言。善哉善哉大圣世尊不可思议。最大最妙不可思议。如来世尊得无碍智。明见我等于此阿耨多罗三藐三菩提中敢有不发欢喜心者。世尊如来。知诸众生。善知诸根知诸烦恼。知诸方便知到彼岸。能令众生充足法味。能令众生见八圣道。能除众生担苦之担。能与众生乐担令担。我今一切天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽等一切合掌。各各如是齐心唱言。在在处处有佛世尊。说此四种无愿顺忍陀罗尼处。乃至国王大臣长者。沙门婆罗门毗舍等众。有能书写置此经处。或复有人能读能诵讲说之者。如是等处我等卫护加助威神。有所求须一切供养。礼拜供给彼说法人。不令乏少无有衰秏。不如意事一切怨家不能得便。一切资生常使具足。身无病恼得欢喜心。乐于法者我如是护。彼人终不更生恶道。以是因缘成于法器。一切供养得具足满。佛言。善哉善哉。诸大檀越。汝等今者。欲护大法。因护法故三宝不断。未来之世当得无量福德果报。尔时长老舍利弗。于大众中即从座起。一心合掌前白佛言。世尊。德华藏佛遣虚空藏菩萨摩诃萨所送奢摩裴多悉帝那恶业众生不信心者令彼睡眠陀罗尼欲。我及一切世间天人欲得闻知。唯愿如来广为宣说。佛告舍利弗。谛听谛听善思念之。我当为汝广分别说德华藏佛所送净陀罗尼欲。彼佛如来为于此土诸众生等薄少善根多诸烦恼。以烦恼故起四倒心乐着我想。着我想故颠倒迷惑。流转生死失八正道。是故彼佛送此欲来。舍利弗。一切众生实无有我此土众生颠倒心故横生我想。舍利弗智慧之人深自观察知无有我。作是观时则破四倒。舍利弗。云何智者观于无我。所谓观身谛知无我。何以故。以和合故。复次观眼亦无有我。何以故。眼识初生。如是观察至心思惟。或见种种服饰衣裳铺卧床蓐结加趺坐。坐已摄念一切六根不相舍行。心不舍故如是可见。而此眼根四大合生。筋连水满余不能动。若眼转时但是风力。风故能转。而彼风性因于虚空。出入根中左右回转。根清净故则能明见。而彼虚空性无所有无有依止。不可捉持亦不可说。若无所有不可说者即是无我。是故虚空实无有我。是空中风亦复无物。以无物故不可宣说。是故无我。是风因缘亦入根中。左旋右转清净照了。彼风吹幻亦不可捉亦不可说。离于我所觅不可得。如是眼中地界牢固。如尼拘陀子。至心谛观观已拔出。碎末为尘吹令飞散。如是推求永不见我。如是决定知无有我。此地界中分析无我。彼地地相但有名字。不可捉持无我无主。如是次第观察水界及以火界犹如风界。如是思惟。既思惟已定知无我。故不复疑眼大中我。是故当知。眼之四大一切无物不可宣说。是故无我。若复有言眼识因缘故有我者是义不然。何以故。眼中无我色亦如是。而和合中亦复无我。和合因缘生于眼识。如是识中亦复无我。风中空中悉亦无我。如是推觅竟不可得。此识但是十二因缘循环流转。离十二因缘识不可见。但因识生名色名为名色。名色因缘故六入生。六入因缘故触生。触因缘故受生。受因缘故爱生。爱因缘故取生。取因缘故有生。有因缘故生生。生因缘故则有衰老及以病死。如是等法因眼识生。而是眼识非东方来。南西北方四维上下亦复如是。所因之念生眼识者。是念亦灭眼识不住。第二念中亦不语念。汝住我灭而是灭法。亦复非去至十方面。亦复不专一处住止。是故诸法因缘故生。若离因缘则不得生。因因缘生。因因缘灭。如是因缘名相续法。是故当知。实无有我而是因缘。亦无作者无有受者。无有起者。无他起者是故无我。若无我者我既是空我所亦空。何以故。然体性尔故。是故眼性无我我所。无有积聚非合非散。即生灭故。一切诸法亦复如是。一切法性无取无舍。非罗汉作。亦复非是辟支佛作。非菩萨作非如来作。如眼识空一切法空亦复如是。离我无我空故不见。作是观察无相无愿三种解脱空门之时。悉能除断一切悭贪及诸烦恼。如是念已或有得于须陀洹果阿罗汉果。观眼既然。耳鼻舌中亦复如是。复次行者知身无我。次观于发析一一毛以为百分。烧使成灰风吹散灭。如是一发体性既空。行人心疑自然明了。何以故。一发之中不见有我。如是皮中肉中血中唾中涕中肠中脑中骨中髓中。筋脉甲爪喘息冷暖。上下诸风寿命名字皆无有我。直以因缘共相和合。故名为身。如是思惟至心观已。知身触因故生身识。识因缘名色。名色因缘六入。六入因缘触触因缘受。受因缘爱。爱因缘取。取因缘有。有因缘生。生因缘老死。彼一切法心识依止。故生身识。而是身识非东方来。南西北方四维上下亦复如是。所因之念生身识者。彼念灭时身识不住。第二念中亦不语念。汝住我灭而是灭法。亦无处所不见聚处不见散处。是故诸法缘合故生缘离故灭。有缘故生无缘故灭。一切因缘相续故见。若离相续则不可见。是故当知实无有我。而是因缘亦无作者。无有住者无有起者无使起者。如是因缘不可得故。是故无我。若无我者我所亦无。是故身性无我我所无聚无散。生灭法故。一切诸法亦复如是。彼法性中亦不可得无取无舍。非声闻作。亦复非是辟支佛作。非菩萨作。非如来作。如身识空一切法空亦复如是。体性无我亦无我所。彼空故我不可见。一切诸法悉皆离我亦离我所。以离故空。作是观时即能获得无相无愿三种解脱空行法门。证空因缘能断一切悭贪烦恼。或有得于须陀洹果。乃至第四阿罗汉果。智者如是一一推寻我不可得。不可得故自知无我。谛观无我离疑网心。尔时知身了了无我。舍利弗。若有行者能如是观。当知是人得此无相无愿解脱三种空门。为诸天主释提桓因之所供养并护其身。令常受乐犹如帝释。如是梵天乃至一切诸天余王。一切龙王一切夜叉王。一切迦楼罗王。一切紧那罗王。一切摩睺罗伽王。彼诸王等如是礼拜。供养供给无令乏少。常加卫护亲奉所须。恶心众生不得其便。若在一切诸人王中。所得礼拜供养护身亦复如是。舍利弗。此名奢摩裴多悉帝(都地反)那持陀罗尼。是德华藏如来命虚空藏菩萨摩诃萨送来至此。以我此刹说于日藏大集经故彼持欲来。此陀罗尼有大势力能大利益。慈悲怜愍一切众生。能救一切危厄患苦。能舍一切烦恼诸结。能知一切阴入界等。能辨一切法之差别。能示一切善巧方便。能与一切涅槃道乐。能入一切诸法之门。能摧一切难降伏魔。能破一切邪论外道。能与一切诸天欢喜。能令一切夜叉知足。能怖一切诸阿修罗。能令一切诸迦楼罗心生喜悦。能令一切诸紧陀罗欢乐无厌。能令一切摩睺罗伽不得回顾。能令一切刹利喜欢。诸婆罗门信心增广。毗舍眷属及首陀罗皆大欢喜踊跃。无量多欲妇女能令少贪。妊娠女人使得安隐。令念持者乐于多闻。修习定人乐阿兰若。能却斗诤国土饥荒。能除死殃及诸盗贼。非时风雨冻暍苦辛粗涩肥膻如是恶触。照曜法母竖立法幢。于流转中绍三宝种。解诸系缚怖畏众生。能生尽智证无生智。能破黑暗与大光明。能舍众生苦恼重担。如此奢摩裴多悉帝(都地反)那持大授记陀罗尼。能令一切三有众生恶业道中截流而过入佛界中。于一切法自在无碍。乃至十八不共佛法无为彼岸。能转法轮雨诸法雨。善能教化一切众生。悉令得住于涅槃道。说此恶业尽陀罗尼法时。无量众生过去恶业悉得除灭。无量阿僧祇诸天及人。远尘离垢得法眼净。无量众生得须陀洹果。百千频婆罗众生。得于无漏阿罗汉果。七十那由他众生。获得如是奢摩裴多悉帝(都地反)那持陀罗尼。得此陀罗尼已于三乘中更不退转。无量无数阿僧祇诸天及人。发阿耨多罗三藐三菩提心。无量众生于菩提中亦得住心不退转道。八万四千诸众生等得无生忍。一切现在娑婆世界刹中众生。闻此四种四谛顺空顺无愿顺奢摩裴多悉帝(都地反)那持等陀罗尼义已。悉得破坏一切欲贪长短色贪触贪乐贪色非色贪。又诸众生得如实见知贪障碍。听闻法已其中有得不净观善根者。有得六入念者。或有得于普不散心善根者。或有得于遍善根者。或有得于阿那波那善根者。或有得于奢摩他者。或有得于毗婆舍那者。或有得于初禅定者。或有得于中间禅者。或有乃至得四禅者。或有得于四空定者。或有得于四谛顺忍者。或有得于性人地者。或有得于八法地者。或得和合小乘善根者。或得小乘非和合者。或复有得一切智知善根者。或复有得三摩提忍陀罗尼善根者。又彼众中有诸女人厌离心生。观察女身有种种过穷极鄙恶。我以何故受于此身贪着色欲。作是呵责。以闻法故。一切妇人悉各修念不乐自身。其中九十一频婆罗人中女人。转女人相得男子身。九十九百亿天中女人。八万四千龙中女人。八百六十万夜叉中女人。八十四万阿修罗中女人。七万迦楼罗中女人。十二频婆罗紧陀罗中女人。一千摩睺罗伽中女人。九十频婆罗饿鬼中女人。四十二频婆罗毗舍阇中女人。如是一切诸女人等。悉失本根得成男子。其中若有妊娠妇人。胎藏安隐无诸伤损。乃至畜生亦复如是。其产生者具足五根。男女聪明智慧端正。或有藏内未时即生。或有他患皆能除却。悉令安隐如第三禅。修习行人得于定乐。身心悦豫亦复如是。尔时一切天龙夜叉阿修罗迦楼罗紧陀罗摩睺罗迦。薜荔多。毗舍遮。鸠槃茶。富单那。迦吒富单那。人及非人。一切大众同作是唱。善哉善哉。佛婆伽婆。如是妙法不可思议。我等昔来未曾听受。如今如来所转法轮。能令我等一切恶业障碍尽除。于流转中度一切有。饮甘露浆得寂灭乐。教化拥护一切众生。舍于五浊得胜智慧入佛境界。照曜三宝不令断绝。如来今者降诸法雨。称我等力一心供养。如是乃至迦吒富单那等种种诸天。作于诸天种种音乐。复雨天上细末金银犹如雨下。乃至华香衣服缯彩种种璎珞种种天鬘。以散如来。为供养故一切天人悉皆云集。唯除坐禅入三昧者。如是众生各于生处。所有华香衣服璎珞金银宝鬘。供养佛已欢喜而住

大方等大集经卷第三十九大方等大集经卷第四十

        隋天竺三藏那连提耶舍译

    日藏分护持品第六

尔时一切诸天大王并其眷属。一切龙王。一切夜叉王。阿修罗王。迦楼罗王。紧陀罗王。摩睺罗伽王。薜荔多王。毗舍遮王。富单那王。乃至迦吒富单那等一切诸王。各并眷属礼拜于佛。同心合掌作如是言。世尊。我等从今在在处处。若有比丘或比丘尼。诸优婆塞及优婆夷。但有信心若男若女。能作如是念不净观寂灭三昧如前佛说善根因缘得摄心住者。我等一切天诸眷属。乃至清净信心之人。或男或女。常当救济犹如导师。令彼身心及其眷属为作供养。衣食床铺卧具汤药种种资生所须皆与。如是具足令其安隐更不愁于一十五种浊恶之事。设复有者我等于中常共加护。何者名为十五浊心。所谓或以石撩。或以杖打。或以刀斫。或以槊贯。或毒药中。或崖上掷。或复恶人或复不信或四大动。我为作护。或以恶心送彼人所好饮食汤药者我为作护。贪嗔妒嫉两舌恶口。如是恶事欲相加者我为作护。或有恶人用浊恶心。以诸衣钵床卧铺具病患汤药常作檀越。或劝化他。或自亲旧为供养者。彼诸恶事我为作护。或复怨家。或复恶鬼。如是等恶我为作护。或毒中护。或恶天子。或内国土。或外国土。如是贼起我为作护。此十五种浊恶之事。或比丘或比丘尼。或优婆塞或优婆夷。或余信心男子女人。或今现在或复当来。乃至劫尽末法世时。何者名为末法世时。谓读诵人无不依于波罗提木叉道中行。若不坐禅则不能得于三摩提。乃至不得第四之果。乃至不得寂灭三昧。是则名为末法世时若如上说。初夜后夜不曾睡眠读诵是经或坐禅定。如是住者。彼诸眷属比丘比丘尼优婆塞优婆夷。乃至信心或男或女一切眷属乃至住处。或复聚落都邑国城。或阿兰若处或聚落主家。随所在处有此十五浊者。我尽救济为作拥护。令是诸恶一切悉除。于何聚落有福德人常住之处。或多人住或一人住。乃至复有一日一夜修福德者。乃至一日一夜所住处者。或复城邑或聚落家。我皆救济为作护助。不令其人经于恶事。无问一切诸檀越家。或复刹利或婆罗门毗舍首陀。或男或女小男小女。一切救济常为守护不令入恶。若有如是修福德者身心精进。若有人供养礼拜恭敬种种供给。或为造房或大寺舍。或林或苑或作衣裳。食饮所须坐卧处所。或复病患汤药针灸种种医疗。如是檀越。我等如是十五浊中一切悉护。若有胎藏妊娠女人。供养如是福德人时。我等护持无时暂舍。设诸恶人及以恶鬼欲加恶者。回彼恶心悉令欢喜。如是儿女在在处处修福德者。念善根者为他爱敬。或余众生劝助赞美。或复家人称说其名。或咒结索拥护众生。或教福德或教舍恶。我等于彼如是众生。十五浊中常亲护持。诸恶鬼神不得其便。若有如是修福德者或人非人。能信其语如教而行。如是一切我等亦护。若有恶人。于彼行者修福人中。或嗔或骂或欲加恶或生障碍者。如是等辈诸恶众生。我等不护是恶众生。十五浊事不得护者名字云何。十五浊者。第一恶患。第二失于自在。第三散失种种资生。第四身中四肢种种割截。或眼或耳口鼻手足。或复斫头。第五失于所爱妻子及诸眷属。第六失于官位。第七失居家。第八为诸怨家所侵。第九心常忧愁。第十嗔于刹利心常行恶。第十一邦邑国城众生浊恶。第十二诸偷盗来失种种物。第十三自家妇女恒相斗诤。第十四国土贼盗他国贼来。第十五短命速死。若恶众生有如是十五种事。我等不护富伽罗等言。若复有人虽修福业不受善语恒起恶嗔。欲为造福德者作诸恶事。种种福中为作障碍。若有如是诸恶众生来归于我。望咒术中得种种力。如是咒中种种法用虽具足有。我等于彼如是众生。不加不护不与其力亦不救济。若彼众生意欲规求望得如是如是之物我亦不与。若有众生于常修常命福德之人。生嗔作恶种种障碍者。如是我等亦如上说。或复今世及未来中。能依此法忆念修行及法欲尽。常有诸天龙神乃至迦吒富单那等。恶心嗔忿无有慈悲。不乐当来妙好之身。不畏三涂恶道果报。若有如是造福德人。乐阿兰若种诸善根。或住塳间或复树下或在寺舍。或尸陀林行住处所。福德之人悉如上说。天龙乃至迦吒富单那恶见恶心。此福德之人。是处住止。或身心浊或夺精气。或被行人供养檀越。我诸天龙乃至迦吒富单那等。离慈悲心不知恩报。于当来生不怖恶道。垢浊身心夺其精气。唯除过去极重恶业。此恶业中非可得护。若我天龙乃至迦吒富单那等应可得护。而不护者现世则为欺诳一切三世诸佛。于流转中不见罗汉及辟支佛。常令我身不成福器不得涅槃。佛言。善哉善哉。善男子。汝能如是发于此心。亦如一切三世诸佛。过去世时修行无异绍三宝种竖立法幢光照法母。汝等如是则为供养一切三世十方诸佛。汝善男子。或男或女能作如是勤精进心。于正法中好守护者。如是法行富伽罗故。常护常念常供给足。如是众生于流转中。常得尊贵和合眷属。常受安乐不经辛苦。乃至速成阿耨多罗三藐三菩提道。善男子。汝等求乐不求于苦。是故应当常勤精进作诸善根。诸天等言。善哉善哉。我从今日如是修习如是发心。尔时此娑婆界。有于恶心诸饿鬼等。常仰食啖一切众生精气血肉以为生活。如是鬼等无量阿僧祇。同白佛言。世尊。我等恶业罪报所招。常啖于人肉血精气以活性命。今日发心入佛法住。为佛弟子。更不造恶不生恶念。若佛弟子如佛今说不净观法。常如是修如是习行一种无异。若我不如富伽罗心所在念者。令于我眼黑暗常盲。一切四肢不能动转。又不具足身中五根。我等亦如富伽罗。护此福德人并其施主。造立寺舍房室树林园菀。浴池衣钵饮食卧具。倚床汤药一切所须。如是檀越我等亦护。佛言。善哉善哉。善男子。汝好发心。常当如是莫令放逸

尔时牢固地天。从座而起作如是言。世尊。若佛弟子常摄五根。如佛今说不净观法。如是系念至心行时。我等地天为此行者。常出地味滋润。彼人令其身中增益寿命。是地精气充溢因缘。行者身中得色得力得念得喜得精进得大智慧。佛言。善哉善哉。汝大檀越能发是心真是佛子。从佛口生从法化生。与如是食益于彼身。此福因缘速于大乘成就满足

尔时众中有大德天。复从座起前白佛言。世尊。若有如是法行比丘佛弟子等。彼诸檀越。或以种种金银宝珠种种资生种种谷米具足供给。若诸弟子如佛所说不净观法。乃至寂灭三昧空门如是系念。从于初夜至中后夜坐卧行立。如是念法心无外缘。彼诸檀越为营寺舍。或造一屋或一树林。或复衣食坐卧床铺。病患汤药种种资生常供给之。彼得如是无乏少。己身得安隐无有忧愁。心常欢喜得好福田成就法器。如是施已当来之世得大果报。深心乐法不生恶道不造恶法。我如是护彼人。即得修慈悲心。如是种种胜妙善根增长不减。佛言。善哉善哉。大檀越。此是汝等精进之心。于大乘中速能增长福德之力。尔时众中金刚力士。复白佛言。世尊如来。说此大集经已。诸大檀越并眷属众。各各发心护持佛法利益众生。彼因缘故此娑婆界佛刹之中。法母照曜增进光明。尔时弥勒菩萨摩诃萨。为欲利益于未来故。即于众中问金刚力士言。善男子。何者为虚空之法此可见不。若不可见此事云何。又复问言。何者名为诸法和合。金刚力士报弥勒言。实际之岸不可见故此和合法亦不可见。弥勒又问。善男子。何者名为真实虚空不和合法。金刚力士报弥勒言。彼中无异。弥勒又问。善男子。何者名为虚空之法。何者名为不和合法。金刚力士报弥勒言。不动不生法界入事是故不异。弥勒又问。善男子。云何名为有为无为漏无漏法。金刚力士报弥勒言。如本真实如是如如性无有异。漏无漏法虚空和合是故不异。弥勒又问。善男子。何者名为真实如如漏无漏法。金刚力士报弥勒言。虚空合故真实如如。非是漏法非无漏法。弥勒又问。善男子。何者名为虚空和合法。金刚力士报弥勒言。一切诸法离于障碍。和合故空非集非散。何以故体性不失故。而彼空中亦不可得物及空故。故名空法。善男子。一切法中此方便故。当知一切如如体性。体性本来是空故空。如是万法和合故空。想离想故此空非想非想亦空。何以故。如是一切和合法空不可说故。一切诸法体性尔故。此如是法非沙门造。非罗汉造。非辟支佛造。非菩萨造。非如来造。如是如是真实如如。漏无漏法一切皆空。和合法故。非相离故。非异法故。弥勒菩萨如是当知。尔时金刚力士说是法已。无量众生。曾于过去学空来者。一切恶业悉皆除尽远尘离垢。于诸法中得法眼净。九十二那由他众生。于此法中发阿耨多罗三藐三菩提心。无量众生亦得住于不退转道。究竟阿耨多罗三藐三菩提

    大方等大集经日藏分佛现神通品第七

尔时频婆娑罗王。闻佛说此不净观法。一切大众各欲护持。踊跃欢喜即从座起前白佛言。世尊。如是法门福德最胜不可思议。今此国土娑婆世界佛刹之中。无量诸大菩萨摩诃萨。所可成就光明妙色。我从本来初未曾见初未曾闻。世尊。是菩萨光悉能遍照大千世界乃至有顶亦皆充满。我今眼中不睹余色。但见于此娑婆世界佛刹之中乃至大小诸铁围山悉满光明。世尊。如是菩萨摩诃萨等。若得近于阿耨多罗三藐三菩提者其光云何。如来入于三昧所。放光明相复云何。如来光明我得见不。缘彼光明复得见于其余佛刹种种妙好奇特事不。佛言。如是如是。大王。若有菩萨成就无上菩提道者。其光能照十方世界。何以故。能于如来境界之中。行大福德庄严力故。于过去世菩萨行中。成就具足大福德力庄严法故。一切菩萨修行善根多增长故。具无量福生于佛家。亲近无上菩提道故。毕竟无上菩提妙道。于不可宣说如来智力奋迅。远离一切障碍。佛境界中胜疾智故。入佛智慧正法果故。分别过去无量劫来。无边佛法境界依故。此地最胜转妙法轮。一切自在所可得身。如是福德无挂碍故。获得清净真实法故。所可修习到彼岸故。未来世业已得尽故。通达一切众生善根。永断一切烦恼习故。离于障碍住佛界中。是故光明悉能遍照十方世界。大王如是随佛功德光明力故。亦能睹见一切十方无量无数阿僧祇佛。王言世尊。我今欲见如是十方无量无数阿僧祇佛并诸菩萨摩诃萨及声闻众。时频婆娑罗王随从眷属有无量亿诸众生等。异口同音复白佛言。如是世尊。亦愿如来示现我等诸佛境界过去所行福德庄严离障碍事。我等见已发欢喜心

尔时世尊。告阿若憍陈如。汝等大众在家出家声闻弟子。皆各系念深心思惟。以自善根力入于禅定。我于今者亦欲入于如来三昧。当于尔时此佛刹中天龙夜叉乃至一切人及非人。或有见四谛者。或有得顺忍者。或于三乘得不退者。如是众生皆结加坐亦入禅定。复有众生于三宝中得信敬心。亦复如是入于禅定。尔时世尊。即入一切如来境界日月三昧。行智广大悉能遍覆一切虚空。能令一切智慧众生皆生欢喜。如是三昧不可计量不可睹见。非诸声闻及辟支佛乃至十方恒河沙等补处菩萨之所能知。唯佛如来乃能得之。是名如来境界三昧。如来如是入三昧已。此娑婆世界三千大千百亿四天下。百亿须弥山。百亿日月乃至百亿诸有顶天。皆悉影现入佛身中。如是娑婆世界一切佛刹入佛身已。其中所有一切众生地狱饿鬼及以畜生或天或人。彼诸众生或身或心。有苦受者皆得除灭。一切自在悉生欢喜。譬如比丘入第三禅得具足乐。尔时一切诸大菩萨摩诃萨众。先在座中入三昧者皆从定起。从定起已见佛光明。见光明已自所有光寻灭不现。如是声闻及佛弟子。乃至一切诸天人众入禅定者各各皆起。彼诸大众身心得乐。譬如比丘入第三禅。尔时一切无量众生生大欢喜。踊跃无量不可思议未曾闻见。又其六根一切清净现佛身中。或坐或行或住或卧。复见如来一一毛孔出无量光。譬如十方恒河沙等日月光明。亦如一切恒河沙等大摩尼珠。亦如恒河沙等十地菩萨摩诃萨众。一时普放大焰光明。如是光明悉能遍照十方佛土。如是如来一一毛孔所出光明。处处皆满于十方刹最为殊胜。尔时十方一切诸佛。于其刹中自在而住。各为大众异口同音。称赞我名说于此偈

  汝观具足功德满　　怜彼一切诸众生
  智慧大力能拔除　　释迦如来胜中最
  慈悲心故放此光　　一切佛刹皆充满
  又愍是诸众生故　　令其悉现于身中
  一一佛刹满光明　　众生见者皆欢喜
  发心清净悉牢固　　得胜无上实菩提
  汝等若有得神通　　一切宜应急疾往
  恭敬接足稽首礼　　释迦师子最胜尊
  若有未得神通者　　向彼低头遥礼拜
  速起菩提真智念　　得见牟尼正觉身

尔时十方一切诸佛。各于其国说如是偈。慈悲教化诸众生故。又以如来过去修行。愿力庄严具足满故。彼诸佛刹一一如来。亦有无量恒河沙等诸大菩萨摩诃萨众并大弟子声闻比丘。复有无量亿恒河沙诸天及龙夜叉乾闼婆阿修罗迦楼罗紧陀罗摩睺罗伽等。无量大众围绕彼佛。各乘神通俱来诣此娑婆世界。到此刹已向于如来。头面接足右绕三匝。右绕毕已各赍持来一切所有种种宝物种种宝衣种种袈裟种种璎珞种种幡盖种种杂华种种熏香种种涂香种种音乐种种赞叹种种歌舞供养如来。设供养已与其眷属各还所住。时诸众生在娑婆界佛身中者。皆悉见之。见已欢喜。复受无量无边快乐。又诸众生得见十方一切诸佛。于其刹土坐金刚座而演说法。又见诸佛各各刹中于自坐处。为诸众生说此世界释迦如来一切功德。有大名称大智慧力。福德庄严具大精进大慈悲力教化众生。彼诸刹中无量阿僧祇恒河沙等众生。发阿耨多罗三藐三菩提心。于自刹中得受记别。无量众生于缘觉乘得受记别。彼诸大众亦见此土一切众生入于佛身。亦得如是受于记别。其中众生或有受乐或有受苦。一切皆现释迦如来身内住止。若空五浊佛刹众生得见如来。及见十方无量无数说法诸佛。一一如来各有无量无数众生恭敬围绕。见已起大爱敬生欢喜心。彼诸众生一切身中。所有恶受悉得除舍安隐快乐。若不空五浊刹者。十地菩萨摩诃萨等。教化众生故。随何刹中得见于佛。见已生信。得信心已听受妙法。彼诸菩萨各于彼处化作佛身。以一音声满一切刹。各各异口同说偈言

  十方诸佛同一乘　　成就善根故来此
  离佛及余菩萨众　　更无如是大德人
  汝等一一诸众生　　速发菩提无上道
  若不勇猛勤精进　　流转苦海无出期
  汝等宜应一切来　　速随于我相逐往
  供养人中释师子　　顶礼右绕彼世尊

时诸菩萨摩诃萨等。化作佛身说此偈已。各与无量无边恒河沙数得神通力。一切众生俱来诣此。见释迦牟尼佛。见已右绕三匝。绕已各持赍来种种宝物种种宝衣种种音声种种歌舞。以用供养释迦如来。供养毕已悉发阿耨多罗三藐三菩提心。或有众生于辟支佛乘而发愿者。如是悉得不退转道。彼诸众生又皆各各得种种忍种种陀罗尼种种善根。得已各还本刹。或有菩萨化作辟支佛身。或复化作阿罗汉身。或复化作梵天王身。或复化作帝释天身。或复化作四天王身。或复化作那罗延身。或复化作摩醯首罗。或复化作自在天身。或复化作星宿天身。或复化作阿修罗身。或复化作转轮圣王。如是种种龙身鬼身。随所在处佛刹之中。若有众生乐见阿罗汉身。见罗汉已欢喜受法。彼诸菩萨摩诃萨等。为欲教化诸众生故。即于彼中作罗汉身。为彼众生说种种法。彼诸众生见大光明及释迦佛。得见佛已心中爱敬生大欢喜。具足六根满一切愿。恶业皆尽悉乐受生。又彼菩萨摩诃萨等。于佛刹中化作如是阿罗汉身。说法教化大福德聚。具足成就善根力故。能以一音遍一切刹。作诸言辞说如是偈

  众生久处流转中　　愚痴不知出要道
  以诸种种罪业故　　得此生死苦恼身
  是故应速舍恶心　　邪见颠倒诸烦恼
  早度有流到彼岸　　云何汝等不觉知
  难见导师今已见　　难得人身今已得
  难遇善友今逢值　　难闻正法今得闻
  是故汝等应至心　　速发无上菩提道
  出离一切生死狱　　证佛微妙功德身
  若能永离两种邪　　所谓断常等二见
  知于一切行无我　　如是名入正观门
  爱行取入有于生　　智水洗除悉令净
  同共往诣娑婆国　　恭敬供养释师子

时诸菩萨摩诃萨等。如是化作阿罗汉身。说此偈已与于无量恒河沙等得神通力一切众生。俱共发引来到此刹。到已头面顶礼释迦牟尼如来并其眷属。恭敬围绕三匝佛已。出所赍来种种宝物种种宝衣种种袈裟种种璎珞种种伞盖种种幢幡种种宝华种种宝香种种音乐偈赞歌舞。以用供养释迦如来。供养毕已各还自刹。到自刹已坐于自座。各为于己众称杨赞说释迦如来作如是言。释迦如来。怜愍教化一切众生。能与众生一切利益。是诸菩萨各自众中如是称说。彼众闻已悉皆赞叹释迦如来。既赞叹已无量无数阿僧祇众生。发阿耨多罗三藐三菩提心。或复有于辟支佛乘而发心者。或复有于声闻乘中而发心者。各各乘中得不退道。有得种种陀罗尼忍种种善根。亦见此土娑婆佛刹诸众生等入释迦如来身中。是诸众生见此不可思议神德变已。无量阿僧祗恒河沙等众生。皆发阿耨多罗三藐三菩提心。其中或有发声闻辟支佛心者。各于自乘得不退转。或有作于转轮圣王微妙之身得受记别

大方等大集经卷第四十大方等大集经卷第四十一

        随天竺三藏那连提耶舍译

    日藏分中星宿品第八之一

尔时欲界魔王波旬。悉见一切娑婆国土所有众生及诸天宫合家眷属在佛身中。时魔波旬见已悲泣涕泪横流。心大懊恼遍身汗出。啼哭失声称怨大唤或起或立或坐或行。入出家居东西狂走。频申欠呿怖惧慞惶。愤叹长歔喘息粗短。合眼张口吐舌舐身。露背现胸申臂缩脚。摇动头项索手揩摩。种种施为受大苦恼。乃至一切魔之眷属。心内愁忧亦复如是。时魔波旬有一军主。名戒依止。见王身心如是煎迫。说偈问言

  何故愁恼独行住　　唱唤驰走似颠狂
  出入家居心不安　　如是因缘愿王说

时魔波旬闻是语已。倍更懊恼啼哭雨泪。说偈答言。

  我今身体汗遍流　　心中分裂如刀割
  啼哭眼中泪如血　　为睹瞿昙现变通
  其形广大无有边　　刹土悉皆居腹内
  我失臣民及眷属　　境界宫殿悉空虚
  复有十方大众来　　充满于此娑婆界
  各设无边大供养　　礼拜围绕或往还
  令我自在无威力　　伴侣眷属归于彼
  如来有是大神力　　云何令我心不愁

时戒依止大魔军主。为于波旬复说偈言

  我所统领诸军众　　强壮勇健实难当
  刀轮奋击拟如来　　须臾破身令粉碎

时魔波旬说偈答言

  我等诸军及眷属　　久已归依佛世尊
  设欲自往生恶心　　即见项边带枷锁

时戒依止大魔军主。复说偈言

  我今多设诸方便　　诱诳于彼恶怨家
  诈现亲善作知识　　得便然后当摧灭

时魔波旬说偈答言

  若我发起毒恶心　　如是方便欲毁佛
  即见死尸系颈下　　如是臭恶难可看

时戒依止大魔军主。复说偈言

  一切欲界属于魔　　唯有天人信归佛
  诸恶毒龙亦王领　　愿敕速害瞿昙身

时魔波旬复说偈答

  若审知龙有力能　　我已荒迷汝自敕
  若实能坏瞿昙者　　我还得土复本心

尔时戒依止大魔军主即自念言。世间难摧谓三种毒。一者天魔。二者恶龙。三者得定五通仙人。我今魔宫已被破坏。唯龙境界牢固。光明照耀海中。威力自在眷属围绕不可思议。龙既属魔其余兵众悉皆统领。今当为王约敕速往坏彼瞿昙魔波旬言。善哉善哉。智慧军主汝可疾去。到彼龙宫如是切敕。早与瞿昙共相斗战。时戒依止大魔军主。辞王毕已即自举手。普告无量百千军众唱如是言。汝等宜应速整衣钾。我今欲往彼龙王宫。令诸恶龙兴发毒风。害瞿昙命使令破碎。如是说已一切军众悉不能动。其戒依止军众及身既不得前。眼中泪出身毛皆竖。合掌向魔波旬说言。我等今者不能得去。沙门瞿昙奸伪多幻。知我等家系缚于我。令我身内一切火燃焦沸热恼犹如汤煮。我今如是力不自在。云何复欲假力于他。时魔波旬倍更懊恼忧愁不乐。令戒依止具以上事宣告诸龙。汝当为我坏瞿昙身。时诸恶龙将欲飞空而不能去。语戒依止敬奉来命欲往毁坏适生此心便不得往。时戒依止即生恐怖作如是念。若我今者现魔大力。令诸恶龙心生嗔忿。以嗔忿故则能破坏瞿昙之身。时魔波旬及戒依止。化龙宫内作诸蚊虻蝇疽毒虫死尸人粪。臭处狼藉充满其中。诸龙见已于自宫室心不甘乐。作是念言是谁化作此恶物也。虽复思念莫知谁为。尔时一切四天下中。诸大龙王及其男女大小眷属悉生嗔忿。即出宫殿至须弥下佉罗坻山。其山平坦于山顶头有大圣人先所居住。彼山周匝纵广正等四万由旬。一切庄严纯是七宝。乃至难陀优婆难陀龙王。亦与无量百千眷属。舍自住宫往佉罗坻大圣人处请求救济。彼龙奋身如须弥山。即到彼已其身皆小犹如铜[槎-工+目]。虽如是知不能得语。各各自说我等欲往而不能动。即大忧愁嗔忿停坐。尔时复有娑伽罗龙王。亦与无量亿那由他百千眷属。如是伊罗钵龙王。如是善住龙王。如是德叉迦龙王。如是阿那婆达多龙王。如是目真邻陀龙王。如是海德龙王。如是婆娄那龙王。如是大德龙王。如是那吒达都龙王。如是阿钵罗逻龙王。如是山德龙王。如是牛头龙王。如是阿蓝浮龙王。如是伊罗钵多龙王。如是郁车伽臂龙王。如是婆罗[邱-丘+冊]那龙王。如是斯罗摩罗龙王。如是迦迦吒行龙王。如是稽罗绮龙王。如是水行龙王。如是安阇那殊致龙王。如是迦那迦宾阇那龙王。如是奢俱奢伏绮龙王。乃至闭眼龙王。乃至白象腋龙王。乃至天利龙王。乃至天婆婆遮罗龙王。乃至天迦龙王。乃至伊罗口龙王。乃至天眼赤龙王。乃至端正龙王。乃至光行龙王。乃至此间阎浮提地八十六千诸大龙王。时彼一切一一龙王。各有无量百千眷属悉皆来诣此圣人处请求救济。如是乃至八十四万诸海洲中。一一海洲则有无量亿那由他百千诸龙。各舍宫宅为救济故来佉罗坻大圣处。如是郁单罗拘卢洲中。鼻担比龙王大遍龙王。彼二龙王各与无量亿那由他百千诸龙眷属围绕。请求救济故来到此圣人住处。如是弗婆毗提洲中。苏摩娄叉龙王婆斯目叉龙王。彼二龙王亦与无量亿那由他百千诸眷属围绕。悉来到此求于救济。如是瞿耶尼洲中。曷赖多那龙王瞿波罗婆龙王。彼二龙王亦与无量亿那由他百千诸龙眷属围绕前后随从。为求救济故来到此大圣人处。尔时复有此四天下八万四千一切洲中。所有诸龙卵生胎生湿生化生。如是诸龙如在生处。龙妇龙男龙女龙子。为救济故一切悉来此大圣人牟尼处所。到已一切皆得小身譬如铜[槎-工+目]。彼龙嗔忿各作是念。我等本身如须弥山。今者云何如是细小。时魔波旬见于诸龙。皆来入此牟尼处所悉受小身。见已波旬心中懊恼。亦生嗔忿怖畏不安。语其众军及眷属言。汝等看此一切诸龙。以我力故变其宫殿。化作一切蚊虻毒蝇及余臭恶种种粪秽。皆舍自家来诣大山圣人处所。悉失势力无复自在。不能毁坏沙门瞿昙。时戒依止大魔军主白波旬言。大王莫愁愿听我语。如是诸龙受此身者。非是沙门瞿昙所化。龙自集会一处戏笑作于是身。望得方便害彼释子。魔波旬言。如是者善汝可速去听问彼龙。说何语言作何方便。可得令彼沙门瞿昙破坏离散。若得碎者我境界胜龙宫亦全。时戒依止大魔军主。前后导从百千万众欲往彼山。发于自家乘空而进。尔时世尊宣扬过去一切诸愿。通达显示究竟无余。一切圣人现在世者。一切牟尼处所作证。一切众生教化毕了。一切诸佛眷属家生。奋迅境界皆已示现。一切菩萨摩诃萨众。所得寿命一种无差。一切天龙夜叉罗刹人及非人。得见一切诸佛刹土。光明遍照种种庄严心皆欢喜。十方一切余佛刹中。此刹光明最胜巍巍。福德因缘得此殊胜。余佛刹中一切五道皆来此刹。供养礼拜释迦如来。是时佛神力故。此娑婆界及十方佛土一切众生入佛身内。如是神通诸佛境界三摩提力。彼诸众生见佛身光。出过十方一切诸佛世界。普皆充满照曜殊特能蔽余光。于自坐处作如是说。释迦如来不可思议未曾闻见。彼诸菩萨如是说已。各以种种华香宝衣袈裟缨络种种音乐供养如来。供养毕已无量百千右绕礼拜悉皆退坐。时此大众一切天龙夜叉罗刹阿修罗迦娄罗紧陀罗摩睺罗伽鸠槃荼薜荔多毗舍遮富单那迦吒富单那。乃至一切人及非人。亦设种种供养。如前作礼右绕毕皆退坐如是听法。时戒依止大魔军主。将领眷属在于阎浮地上游行。尔时如来在众中坐。示现常身安然不动。大魔军主见已念言。沙门瞿昙示现大身。今复本形在摩伽陀国端坐不异。或能见我大魔军众。怖畏失力无复神通。彼戒依止大魔军主复作是念。沙门瞿昙多诸巧慧。或能于我欲生恶心。我今先当到瞿昙所。看彼道术方便因缘。试共谈论观其诈伪。时戒依止大魔军主。眷属围绕前至佛所。对如来立而说偈言

  未能度脱于自身　　生死海中得出离
  何以诳他众生类　　云我安汝置涅槃

尔时如来。答戒依止大魔军主。而说偈言

  我久超度流转海　　更不生于诸有中
  慈悲愍念诸群生　　是故说于出要道
  汝于往昔无数劫　　已发最胜菩提心
  值遇然灯佛世尊　　修行布施及持戒
  如是过去亿千佛　　悉已恭敬曾供养
  当得于此清净乘　　我今决定授汝记
  未来成佛还如我　　云何乃说诳众生
  我今施汝智慧眼　　可念前生行本末
  时戒依止魔军主　　即得宿命识往身
  头陀苦节习于禅　　业果福德皆明了

时戒依止大魔军主闻此偈已。念彼过去福德因缘。对于如来五体布地眼中泪出。长跪合掌作如是言。如来世尊。我大懊悔我大惭愧。如大痴人如迷如醉如着鬼癫。我念过去经一阿僧祇劫。大精进力发阿耨多罗三藐三菩提心。行六波罗蜜。修习圣道作诸福德。值佛现在种种供养。听受妙法发弘誓愿。乃至迦叶如来法中。有一比丘说声闻法。有大乘人说菩萨法。我于尔时心错口恶谤此说人。言是魔语或魔眷属。大乘人边说小乘过。如是恶口说因缘故。我于彼中。迦叶如来不授我记。得阿耨多罗三藐三菩提。以彼恶口罪业因缘。我于彼死魔界中生。受是身来已经五十七亿千岁。世尊。我宁更历六百千年受地狱苦。终不一念失阿耨多罗三藐三菩提心。何况退于四梵行念。第一第二如是忏悔。乃至第三如是忏悔。并余眷属亦复如是。又过去世流转际中。如是当来于生死海及在地狱。终不暂退阿耨多罗三藐三菩提心。佛言军主。善哉善哉善男子。若复有人。燃于大灯如须弥山。并七宝物于无量世供养诸佛。是福德聚不如有人至心慈悲发菩提心。何以故。发是心者乃是供养十方诸佛。彼过去福此最为胜。汝善男子。今尽此罪更莫余念。生死五阴一切有中得导师身。尔时戒依止菩萨摩诃萨。即于坐处得法顺忍。从坐而起头面作礼绕佛三匝。即脱身上无价宝衣真珠璎珞供养如来。脱布施已说偈问言

  菩萨云何修诸法　　达了一切悉皆空
  观察世间如水泡　　能尽诸有无明缚
  一切恶见性非实　　得胜无生顺忍心
  常于菩提道中行　　能令众生得解脱

尔时世尊。答戒依止而说偈言

  不动如山四种心　　智慧之人乃能有
  无量亿劫受诸苦　　为愍一切诸众生
  佛说禁戒坚固持　　乃至不破如一点
  一切三世佛正法　　具足圆满悉能行

尔时八万四千魔军及戒依止菩萨眷属。闻戒依止得授记已心大欢喜。即于佛前至心悔过。一切皆发阿耨多罗三藐三菩提心。此菩提心名为三昧顺菩提心。得此心已欢喜踊跃。各各脱衣以用布施布施已坐。尔时波旬见其军主并及眷属已归依佛。心生嗔忿苦恼不安。更大怖畏作如是言。我今得出沙门腹中。复失眷属未知几人。于此得出作佛弟子有几人在。速闭城门莫放一人令其出外。自魔境界安隐住止。尔时世尊。更为彼魔大众眷属说三种梵行。所谓众生攀缘。法攀缘。离攀缘。如虚空眼品中说。尔时一切诸天龙王。悉皆集会佉罗坻山牟尼圣人处所中住。彼一切龙各见自形。小如铜[槎-工+目]欲动不能。游行绝望思念旧体。懊恼细身宛转彼中。不得自在怖畏毛竖。一切相与向难陀跋难陀王边。礼拜作如是言。大王我龙国土。今者所有蚊虻苍蝇毒虫粪秽种种不净。皆是瞿昙之所为也。是故我等皆舍宫宅。来到此间求觅救济。又不能得离于小身及以怖畏。若能归依佛世尊者可得免脱是时难陀跋难陀龙王。作如是言。沙门瞿昙多诸方便种种幻术。能内一切娑婆佛刹安置身中。于我龙家亦复化作一切诸恶。令我怖畏来此求救。今者沙门自失势力。无复方便神通道术。身今如本坐旧座中岂能救我。如是小身既造此狱。安置于我皆不得去。何能救济令无怖畏。一切诸龙系属波旬。欲界自在唯有魔力。今可礼拜求出此难。各各还家安隐而住。尔时伊罗婆龙王。复作是言。汝等诸龙莫生懊恼。何以故。沙门瞿昙已能降伏魔之眷属。群臣人民作于弟子。唯魔王在丧失本心及其神力。云何当能救济汝等。时诸龙王。闻伊罗婆如是说已。或有礼拜四天王者。或有礼拜帝释天者。或有礼拜须夜摩天。或有礼拜删兜率陀。或有礼拜化乐天者。或有礼拜他化自在。或有礼拜大梵天者。尔时娑伽罗龙王。复语一切诸龙王言。汝等不见彼诸天王人及非人圣贤杂类。礼拜供养沙门瞿昙而归依耶。尔时诸龙即复归依其余仙圣。时彼山顶有六圣人。第一名苏尸摩。第二名那筹。第三名阿收求多。第四名毗梨呵。第五名婆揭蒱。第六名殊致阿罗娑(隋言光味)。彼一切龙。或有归于苏尸摩边作礼拜者。或有归依于那筹者。或有礼拜阿收求多。或有礼拜毗梨呵者。或有归依婆揭蒱者。或有归依殊致罗娑。彼一切龙。皆悉归命此六圣人请求救济。是六圣人得五神通。悉各在于雪山边住。彼五圣人皆在殊致罗娑菩萨摩诃萨大圣人所听于正法。时殊致罗娑菩萨。亦以种种无量言辞。赞叹释迦如来神德。时五圣人悉闻一切龙王哭声。求乞救济闻已即起。白殊致罗娑菩萨摩诃萨言。大德颇闻彼龙啼哭[口*睪]啕求救声不。答言已闻。大士今圣人处。一切诸龙大懊恼心。我等闻知尚欲往救况大德乎。唯愿慈悲往至彼所。救一切龙与其解脱。时殊致罗娑大圣人言。汝等可往我未及去。所以者何。此中大天龙王夜叉。百千万众今对我坐。问离障碍四梵行法。彼心欢喜听我所说。时五圣人礼彼殊致罗娑大士三匝绕已。以神通力飞腾虚空。到佉罗坁大山顶头牟尼圣人处所。尔时彼处一切龙王。见五圣人心生欢喜。恭敬礼拜作如是言。汝等大仙福德之人。智慧方便一切庄严。于苦恼中已到彼岸。愿救济我出恶狱中令得解脱。彼五圣人如是答言。我等不能救济汝等。所以者何。现今雪山有大菩萨名殊致罗娑。诸圣人中最大智慧大解方便。彼菩萨能与汝解脱。汝可一心求哀劝请。诸龙闻已。如是异身同共合掌。遥向殊致罗娑圣人。恭敬礼拜皆唱是言。大德圣人。愿救济我愿怜愍我。尔时殊致罗娑菩萨摩诃萨。闻彼龙王唱救济声。即与大天紧那罗等。夜叉罗刹百千万人前后围绕。以神通力发于雪山乘空而往。到佉罗坻山顶。时诸龙王见彼圣人。各各恭敬合掌礼拜。一心同声作如是言。大仙圣人愿救济我。于此狱中与我解脱。令我自身及以眷属。安隐还家离诸苦恼。尔时殊致罗娑菩萨。善解方便知世因缘。欲为诸龙说星宿法。星宿法者。各有度数和合时节。合时则易不合则难。时节未合不得解脱。谛听次第我当为汝分别解说。今此月者名奢婆拏。星宿名为富那婆薮。富那婆薮属此五月。此月复系属于日天。汝诸龙王。与此星辰时未和合。尔时娑伽罗龙王白殊致罗娑菩萨言。大士。是星宿者本谁所说。谁作大星谁作小星谁作日月。何日之中何星在先。于虚空中复谁安置三十日月十二月年。云何为时。系属何处姓何字谁。何善何恶何食何施。若为是昼若为是夜。日月星宿复若为行。何者名为月初一日何者满月。若为时节若为行度。一一各几复若为停几许时行。何者是轻何者是重。何者是合何者非合。云何力多云何力少。云何名为日前后行。上行几影下行几影。影有几步名曰为转初转。云何月北月南。云何次第。大士。汝于诸圣第一最尊。愿愍我龙具足解说。我等闻已脱苦奉行。尔时殊致罗娑菩萨告诸龙言。大王。过去世时。此贤劫初有一大城名曰瞻波。彼中人民和合炽盛。有一天子名大三摩多。端正少双才智聪明正法行化。常乐寂静不着世荣。为诸人民之所宗仰。恭敬礼拜而侍卫之。彼三摩多。清净慈悲愍念众生犹如赤子。不乐爱染常自洁身。王有夫人多贪色欲。王既不幸无处遂心。曾于一时游戏园苑。独在林下止息自娱。见驴命群根相出现。欲心发动脱衣就之。驴见即交遂成胎藏。月满生子头耳口眼悉皆似驴。唯身类人而复粗涩。[髟/公/心]毛被体与畜无殊。夫人见之心惊怖畏。即便委弃投于屏中。以福力故处空不坠。时有罗刹妇名曰驴神。见儿不污念言福子。遂于空中接取洗持。将往雪山乳哺畜养。犹如己子等无有异。及至长成教服仙药。与天童子日夜共游。复有大天亦来爱护此儿。饮食甘果药草身体转异。福德庄严大光照耀。如是天众同共称美。号为佉卢虱吒(隋言骏唇)大仙圣人。以是因缘彼雪山中并及余处。悉皆化生种种好华。种种好果。种种好药。种种好香。种种清流。种种和鸟。在所行住并皆丰盈。以此药果资益因缘。其余形容粗相悉转身体端正。唯唇似驴。是故名为驴唇仙人。是驴仙人学于圣法。经六万年翘于一脚。日夜不下无有倦心。天见大仙如是苦行。时诸梵众及帝释天。并余上方欲色界等。和合悉来礼拜供养。乃至龙众修罗夜叉一切云集。所有仙圣修梵行人。皆来到此驴圣人边。种种供奉赞叹称扬。如是苦行生来未睹。设供养已合掌问言。大仙圣人欲求何等。唯愿为我诸天说之。若我力能即当相与终不吝惜。尔时驴唇闻是语已。内心庆幸答诸天言。必能称我情所求者今当略说。我念宿命。过去劫时见虚空中有诸列宿日月五星。昼夜运行各守常度。为于天下而作照明。我欲了知分别识解。愍暗瞑故不惮劬劳。此贤劫初无如是事。汝等一切诸天龙神怜我故来。愿说星辰日月法用。犹如过去置立安施。造作便宜善恶好丑。如我所愿具足说之。一切天言。大德仙人。此事甚深非我境界。若为怜愍一切众生。如过去时愿速自说。尔时佉卢虱吒仙人告一切天言。初置星宿昴为先首。众星轮转运行虚空。告诸天众。说昴为先其事是不。尔时日天而作是言。此昴宿者常行虚空历四天下。恒作善事饶益我等。我知彼宿属于火天。是时众中有一圣人名大威德。复作是言。彼昴宿者我妹之子。其星有六形如剃刀。一日一夜历四天下行三十时。属于火天姓鞞耶尼。属彼宿者祭之用酪。佉卢虱吒仙人语诸天曰。如是如是如汝等言。我今以昴为初宿也

复次置毕为第二宿。属于水天。姓颇罗堕。毕有五星形如立叉。一日一夜行四十五时。属毕宿者祭用鹿肉

复次置嘴为第三宿。属于月天。即是月子。姓毗梨伽耶尼。星数有三形如鹿头。一日一夜行十五时。属嘴宿者祭根及果

次复置参为第四宿。属于日天。姓婆私失絺。其性大恶多于嗔忿。止有一星如妇人黡。一日一夜行四十五时。属参宿者祭用醍醐

次复置井为第五宿属于日天。姓婆私失絺。其有两星形如脚迹。一日一夜行十五时。属井宿者以粳米华和蜜祭之

次复置鬼为第六宿属岁星天。岁星之子。姓炮波那毗。其性温和乐修善法。其有三星犹如诸佛胸前满相。一日一夜行三十时。属鬼星者亦以粳米华和蜜祭之

次复置柳为第七宿。属于蛇天。即姓蛇氏。止有一星如妇女黡。一日一夜行十五时。属柳星者祭用乳糜。右此七宿当于东门

次置南方第一之宿名曰七星。属于火天。姓宾伽耶尼。其有五星。形如河岸。一日一夜行三十时。属七星者宜用粳米乌麻作粥祭之

次复置张为第二宿。属福德天。姓瞿昙弥。其星有二形如脚迹。一日一夜行三十时。属张宿者毗罗婆果以用祭之

次复置翼为第三宿。属于林天。姓憍陈如。其有二星形如脚迹。一日一夜行十五时。属翼星者用青黑豆煮熟祭之

次复置轸为第四宿。属沙毗梨帝天。姓迦遮延。蝎仙之子。其星有五形如人手。一日一夜行三十时。属轸星者作莠稗饭而以祭之

次复置角为第五宿。属喜乐天。姓质多罗延尼。乾闼婆子。止有一星如妇人黡。一日一夜行十五时。属于角者以诸华饭而用祭之

次复置亢为第六宿。属摩姤罗天。姓迦栴延尼。其有一星如妇人黡。一日一夜行十五时。属亢星者当取菉豆和苏蜜煮以用祭之

次复置氐为第七宿。属于火天。姓些吉利多耶尼。氐有二星形如脚迹。一日一夜行四十五时。属氐宿者取种种华作食祭之。右此七宿当于南门

次置西方第一之宿其名曰房。属于慈天。姓阿蓝婆耶尼。房有四星形如缨络。一日一夜行三十时。属房宿者酒肉祭之

次复置心为第二宿。属帝释天。姓迦罗延那。心有三星形如大麦。一日一夜行十五时。属心星者以粳米粥而用祭之

次复置尾为第三宿。属猎师天。姓迦遮耶尼。尾有七星形如蝎尾。一日一夜行三十时。属尾星者以诸果根作食祭之

次复置箕为第四宿。属于水天。姓特叉迦旃延尼。箕有四星形如牛角。一日一夜行三十时。属箕宿者取尼拘陀皮汁祭之

次复置斗为第五宿。属于火天。姓摸伽逻尼。斗有四星如人拓地。一日一夜行四十五时。属斗宿者末粳米华和蜜祭之

次复置牛为第六宿。属于梵天。姓梵岚摩。其有三星形如牛头。一日一夜行于六时。属牛宿者以醍醐饭而用祭之

次复置女为第七宿。属毗纽天。姓帝利迦遮耶尼。女有四星如大麦粒。一日一夜行三十时。属女宿者以鸟肉祭之。右此七宿当于西门

次置北方第一之宿名为虚星。属帝释天。娑婆天子。姓憍陈如。虚有四星其形如乌。一日一夜行三十时。属虚宿者煮乌豆汁而用祭之

次复置危为第二宿。属多罗拏天。姓单那尼。危有一星如妇人黡。一日一夜行十五时。属危宿者以粳米粥而用祭之

次复置室为第三宿。属蛇头天。蝎天之子。姓阇都迦尼拘。室有二星形如脚迹。一日一夜行三十时。属室星者肉血祭之

次复置辟为第四宿。辟属林天。婆娄那子。姓陀难阇。辟有二星形如脚迹行一日一夜四十五时。属辟星者以肉祭之

次复置奎为第五宿。属富沙天。姓阿风吒排尼。奎有一星如妇女黡。一日一夜行三十时。属奎宿者以酪祭之

次复置娄为第六宿。属乾闼婆天。姓阿舍婆。娄有三星形如马头。一日一夜行三十时。属娄星者以大麦饭并肉祭之

次复置胃为第七宿。属阎摩罗天。姓跋伽毗。胃有三星形如鼎足。一日一夜行三十时。属胃宿者粳米乌麻及以野枣而用祭之。右此七宿当于北门。二十八宿有五宿。行四十五时。所谓毕参氐斗辟等。二十八宿言义广多。难晓深趣不可具宣。我今略说。说是宿时同闻诸天。皆悉欢喜

大集经卷第四十一大方等大集经卷第四十二

        隋天竺三藏那连提耶舍译

    日藏分中星宿品第八之二

尔时殊致阿罗娑仙人。告诸天曰。是佉卢虱吒仙人。于过去世亦造恶业。罪因缘故。虽得人身半为驴状。以有慈力其罪除灭。更得最好端正之身犹如帝释。告诸龙等。我以福德诸因缘故如彼仙人。为一切天而作导师今亦如是。能教汝等深实语言。诸龙当知。佉卢虱吒似释身已。是天人众皆悉欢悦。一心合掌作如是言。今大圣人为我等说往昔之事。何者星宿行最在前。食何等食作何事业。行于虚空复几许时。如是问已仙人答言。汝等一切至心听受。我以慈力还得端正。今复怜愍安隐众生。说一年内事之终始。令于汝曹如盲得目。初日星宿乃至月满。诸星所在皆悉具说。为欲利益诸众生故。安置昴星在众星前。汝等诸天以为是不。一切天言。善哉善哉。我等经历星宿。知昴最尊大威德天之外甥也。其有六子运行虚空。是故昴星可为先首。佉卢虱吒仙人言。月合诸星起昴终胃。月行宿讫一月将满。八月黑初月合在胃。如是次第轮转不息。我今复说刹那之数。一千六百刹那名一迦罗。六十迦罗名摸呼律多。三十摸呼律多为一日夜

胃宿纵恶自在如首罗天。能护四方皆得安隐。汝等天人见彼为恶勿生嫌怪。严治刑法乃护众生。一切天言。如是如是如圣人教。严于法令乃济众生。月与胃合。其日病者或轻或重难可疗治。其日生者性多嗔愤。犷恶刚毅难可亲昵。有大官位能胜众生。亢虚参胃。此四宿日不得入阵斗战。不可远行。不得剃头及以治鬓。毕牛轸星。此三宿日。乃宜斗战及以远行剃头洗头。柳张宿日。可得造作一切诸事。昴宿翼宿斗宿。此三宿日求财可得。宜服医药持戒布施。宜作新衣及造璎珞。嘴宿角宿女宿七星之宿。此四宿日宜于行来道路安隐。氐宿井宿危宿。此三宿日作恶得成。房宿柳宿心宿娄宿七星之宿张宿。此六宿日得造舆车床及绳床并诸衣服。要结知识

昴宿速疾作种种业。其速如火。其日得病酪饭祭之四日除愈。其日生者常得大富。其日入胎。斗宿房宿虚宿柳宿室宿。此五宿日不宜造作一切诸事。唯得共于大敌斗战。井氐翼宿。此三宿日善恶之事皆悉得作。毕宿之日亦得自在。井氐危宿。此三宿日。昴宿生者于此日内。不得作事远行斗击。假令急事亦不得作。女角嘴宿此三宿日亦为最恶。翼宿之日与怨家斗获得其胜。或刚或柔还致和合。轸宿牛宿。此二宿日求伴不得。服药合药出家布施。造新衣服璎珞床铺。卧具等物皆得成就。参宿虚宿亢宿。此三宿日行来安隐。鬼尾室宿此三宿日。共他造恶离于慈心种种得作。七星宿日心宿房宿柳宿辟宿。此五宿日宜结婚姻。宜造舆车及以床缛。参宿之日作事亦吉。然于一切须生怜愍

毕星水性。汝等于此第二宿日。造柔软事悉得和合。其日病者以香祭火五日后愈。其日生者其人大富福德乐法。牛宿奎宿七星宿日。及心宿日而受胎者。其人薄德常作下事。鬼尾室宿。此三宿日。一切事业皆不得作。不得斗战不得远行不得诣官。卖买交易工巧作务皆不得作。亢宿虚宿此二宿日。若作好事不得和合。唯宜斗战克获胜捷。轸宿之日为事有利。利作柔软无有障碍。嘴宿角宿女宿等日众事和合。所作成办服药得力。若欲舍施。若造衣服及以璎珞皆悉得作。井宿氐宿危宿等日远行安隐。房宿柳宿辟宿等日。欲离慈心造恶得成。斗宿箕宿娄宿胃宿室宿翼宿此六宿日。宜结亲友婚聚知识。床铺辇舆皆悉得造

嘴宿四日用事。于此世间作诸事业疾速自成。其日病者豆糜祭月八日除愈。其日生者为人猛健大富饶财。当为妇女见诸恶事宜自防护。我说不虚。嘴宿生人。若以女宿娄宿斗宿张宿等日而入胎者为恶不善。昴宿房宿柳宿此三宿日。不得斗战不得远行及向官府。有须行者应止勿去。井宿氐宿危宿等日。造作众恶不相和顺。妄言谄曲欲杀怨家皆得成就。角宿之日欲作事者刚柔并得。参宿之日作事利益能致自在。亢虚二宿不相和合。参星之日乃得利益。其日服药出家布施。璎珞衣服并皆得作。鬼宿尾宿室宿等日远行安隐。心宿奎宿七星宿日。此三宿日欲作恶者恶事得成。轸宿胃宿毕宿牛宿箕宿等日。宜结亲友得好知识婚嫁吉事。舆车床缛皆悉得造

参宿五日用事能成诸恶。欲为业者少于利益。其日病者以生苏糜祭于四道十日得愈。其日生人性虽聪明而心怀恶。求于钱财遂至于死。亦主作贼致失身命。其日生人及入胎者。虚宿心宿奎宿翼宿斗宿胃宿。此六宿日多为障碍。乃至鬼尾室宿等日。亦不和合。一切诸事皆不得作。亢宿之日欲造作者。宜为轻事。氐宿危宿井宿奎宿。此四宿日乃得自在

井宿六日用事。其为恶业分判果决。其日得病炒粳谷华祭于日天。八日得愈。其日生人及受胎者。宜为田作当得大富。又饶畜生象马羊等。于辟宿日百事不宜。柳宿房宿。此二宿日造作百事多有耗散。氐宿之日宜作众事。如意自在。鬼宿参宿尾宿等日。宜造百事所求称意。心宿星宿奎宿等日。宜出远行。道路安隐所向和合。斗宿翼宿奎宿等日。宜结朋友求善知识。亢宿毕宿觜宿虚宿。此四宿日为井生人作诸障碍

鬼宿七日用事。能为柔软不破善法。其日得病以黄石蜜祭于岁星五日除愈。其日生者此人持戒好乐善事。得大官位国师宰辅。常教国王善法治世。至于娶妻特难和合。殷勤因人然后成就。其日生人。欲在室宿鬼宿翼宿娄宿斗宿等日受胎者吉。毕角女宿。此三宿日为其障碍。七星心宿奎宿之日。作事不成当失财物。尾宿之日作事得成。房宿之日亦多利益。辟宿柳宿。此二宿日为事不称。张宿之日远行安隐。娄宿箕宿为其障碍。轸牛昴宿。此三宿日作事和合必得良伴。亢宿觜宿参宿虚宿。宜结朋友及善知识亢宿危宿。此二宿日所求者得多有利益

柳宿八日用事。一切恶业皆悉能作。于世间中如阎罗王。其日病者不可疗治。其日生者性多嗔怒无有慈悲。多造[億-音+(夫*夫)]过人所憎嫉。能破善法常好猎射。辟宿牛宿。此二宿日入胎者吉。轸宿昴宿入胎者凶。觜宿虚宿亢宿张宿。此四宿日不宜作事多有耗散。箕宿娄宿房宿等日。宜作众事得好成就。心宿之日。七星宿日。胃宿之日远行安隐。翼宿斗宿女宿等日。宜修读学伎艺成就。角宿斗宿危宿尾宿毕宿。此五宿日宜结知识。氐宿参宿井宿室宿。此四日。亦复宜结诸知识。七星九日用事。于诸众生温和柔软。其日病者以胡麻油和粳米饭祭其先人。八日除愈。其日生者聪明福德常为善事。然彼人性微好妄言。若护其身宜慎妄语。其人作事利。心宿日奎宿氐宿。此三宿日受胎者贫乏少财物。参宿危宿毕宿等日受胎者凶常作恶事。角宿女宿。此二宿日受胎亦贫。好为恶事。翼胃斗宿。此三宿日而受胎者。作事自在得他人物。娄宿张宿箕宿等日。欲作事者多饶障碍。轸宿牛宿昴宿氐宿。此四宿日行来安隐作事和合。虚宿觜宿。此二宿日为其障碍。张宿十日用事。作柔软事安隐世间。其日病者以频婆果生苏祭神。七日得差。其日生者性乐芳香衣裳璎珞。贪于欲事而复嗜酒。若在众中须自慎儆。娄宿井宿。此二宿日受胎最恶。虚亢觜宿。是三宿日受胎亦恶不宜作事。昴轸牛宿。此三宿日亦多障碍。张宿之日乃得自在

胃宿斗宿。此二宿日有所求者不得如意。氐宿之日其受胎者能除障碍。亢宿参宿毕宿女宿。此四宿日远行安隐。柳宿奎宿鬼宿心宿房宿辟宿。此六宿日欲结知识障碍不成。翼宿十一日用事。行四天下作两种业。所谓谄曲及柔软事。其日得病煮黑青豆以用祭神十日除愈。其日生者宜于种种。然性愚痴。悭贪鄙吝不能喜舍。亦能不食。五日六日乃至七日。不为世人之所爱乐。善须谨慎防护怨家不宜斗诤。胃宿之日而入胎者多造诸恶。危宿参宿氐宿房宿。此四宿日善恶二事并皆得作。房宿之日无有善恶。辟宿鬼宿。此二宿日有受胎者好失财物。胃宿娄宿斗宿。此三宿日受胎之者。轸牛昴宿。此三宿日作事和合。若于虚宿觜宿亢宿。此三宿日作事者成。得三宿力远行安隐。井室尾宿。此三宿日无善无恶。娄宿七星奎宿柳宿心宿等日。结善知识嫁娶之事皆得和合

轸宿十二日用事。为恶自在速疾如风。其日得病以酪祭神五日除愈。其日生者大富饶财。能用五兵刀槊弓箭斗轮鞙索。能作大贼杀害众生。若修善者亦能持戒喜舍布施。种种功德皆悉能作。其人行处。七步之内蛇不敢前。其日入胎于诸贼众而得为主。又能持戒喜舍布施。尾宿之日其受胎者所在之处无有障碍。入阵斗战能胜怨敌。井宿室宿二宿之日。其受胎者从生至死常宜作事。牛亢虚宿。此三宿日其受胎者。唯除牛宿不宜作事。其余亢虚及女觜宿。此四宿日作事利益得于自在。亢毕危等。此三宿日远行安隐。氐宿参宿房宿辟宿。此四宿日作种种事得人气力。又宜娶妇要结亲友及善知识。箕宿七星娄宿斗宿张宿胃宿。此六宿日有造作者如上利益。角宿十三日用事。为恶速疾。其日病者去菉豆皮生捣祭神六日除愈。其日生人嘲戏音乐歌舞作倡。皆悉能解。复能舍施。又多色欲。亦复爱乐有知之人。其人入胎宜毕宿日。娄宿七星箕宿等日。其人入胎多造作恶事。辟宿房宿鬼宿等日。其人作事种种皆吉无有障碍。危宿氐宿参宿等日。若作事业亦得自在。觜宿亢宿虚宿尾宿。此四宿日远行安隐。觜宿柳宿。营事业者得知识力。心宿奎宿斗宿昴宿翼宿牛宿张宿。此七宿日宜结亲友婚姻等事

亢宿十四日用事。能于世间作诸恶业。其性疾速为业快利。其日得病极恶难治。华蜜祭神。二十五日乃可得愈。其日生者善能算计大富饶财。其性悭贪不能喜舍。又多嗔恚心意难得。若见特牛及黄腰者须自防护。其人若在觜宿箕宿。此二宿日而入胎者为恶不善。张宿胃宿柳宿心宿。此四宿日欲作事者无有善恶。室宿尾宿井宿等日。欲为事者多有障碍。参氐危宿。此三宿日有所营者得他人力。娄宿箕宿七星之宿。此三宿日远行安隐。房鬼辟宿。此三宿日宜结亲友娶妇之事。轸宿女宿毕宿昴宿牛宿翼宿亢宿此七宿日。但宜行来余不可作

氐宿十五日用事。能作诸恶人所畏敬。其日得病以华祭神。满十五日乃得除愈。其日生者威德肃然大富饶财。其性悭贪淫他妇女。须自治身勿行此事。其人入胎宜在参宿。欲作诸事宜在危宿。若七星宿娄宿箕宿日。作事者成无有善恶。若昴宿日牛宿翼宿。营事则恶多有障碍。辟宿房宿尾宿。此三日则有利益。室宿之日远行安隐。心奎柳宿。此三宿日欲为事者得他人力。张宿斗宿胃宿。此三宿日宜结亲友娶妇之事

房宿白月一日用事。能于世间作速疾事。其日病者作青豆饭以用祭神十日除愈。其日生者有堕崖岸刀兵之厄。于此二事须自护身。宜于治生贩卖之业。软弱儒雅乐法信福。其人入胎宜井宿日张宿斗宿胃宿等日。欲作诸事无有善恶。轸毕女宿。此三宿日作事者凶。心宿柳宿奎宿。此三宿日作事者吉。室宿房宿鬼宿辟宿。此四日作事安隐而得自在。箕宿娄宿。此二日远行安隐得知识力。虚宿昴宿张宿翼宿。作事有利得他人物。箕宿觜宿角宿虚宿亢宿参宿。此六宿日要结亲友大小知识娶妇皆吉。心宿二日用事好作恶事。其日得病以粳米饭并大麦饭黄石蜜等祭帝释天。经十三日然后除愈。其日生者性多嗔恚无有慈心。纵持戒者亦复破戒。若见于他行净行法。宜于此处须自慎儆。生产之所亦须护身。此心宿日入胎者吉。角虚觜宿。此三宿日入胎不吉。昴牛翼宿。此三宿日宜作诸事。辟宿之日若作事者多有障碍。七星箕娄。此三宿日乃得自在多有利益。尾宿柳宿奎宿危宿轸宿毕宿。此六星宿得他人力。胃张斗宿。此三宿日宜远行来道路安隐。室宿亢宿危宿井宿氐宿参宿。此六宿日宜结亲友及以娶妇

尾宿三日用事刚柔二事皆悉能作。其日得病取诸果根及果华气。以用祭神三十日愈。其日生者大富饶财多有谷麦。其人有相神德之人。唯生产处须自防慎。亦复好为草马所蹋。至草马所又须自备。尾宿之日而入胎者。柳宿角宿危宿参宿。此四宿日宜作恶事。轸宿房宿毕宿奎宿。此四宿日不可造作诸种事业。危宿之日恶事得作。斗宿翼宿胃宿。此三宿日欲作恶事。无有利益多诸烦恼。箕宿七宿娄宿。此三宿日乃得自在为有利益。角宿虚宿觜宿。此三宿日得他人力而获自在。昴宿牛宿张宿。此三宿日行来安隐。室宿辟宿井宿鬼宿房宿氐宿。此六宿日宜结知识大小亲友婚姻嫁娶其事皆吉

箕宿四日用事。其日得病应以麻糜尼俱陀子。祭于水神八月(丹本云日)乃愈。其日生人善能耕田行船之业。其性精进行十善业。多闻智慧有大名誉大富饶财。常与智人共相随逐。七星宿日及娄宿日宜作诸业角觜虚宿。此三宿日。造作诸事无善无恶。氐宿室宿。此二宿日为事不吉。井宿之日经营事者失于旧业。翼宿昴宿牛宿等日欲为事者。自在如意能有利益。张宿胃宿斗宿等日造作事者。得他人力亦为有利。参宿亢宿危宿等日。欲作事者亦得他力。轸宿毕宿女宿等日。若欲远行道路安隐。奎宿鬼宿柳宿房宿辟宿。此五宿日宜结亲友娶妇之事

斗宿五日用事作柔软业。其日得病炒粳谷华以蜜和之。用祭诸神七日除愈。其日生者是智慧人。少病大富多有知识。其人入胎宜在张宿。若在危参亢宿等日平无善恶。欲营众事皆悉成就。辟宿房宿鬼宿胃宿。此四宿日作事不吉。毕女轸宿。此三宿日欲求自在多有障碍。昴宿牛宿翼宿等日。欲营事者自在如意。氐宿井宿室宿等日。亦宜作事有其福力。角宿觜宿虚宿等日。若远行者道路安隐。奎宿柳宿房宿娄宿七星心宿。此六宿日宜结亲友嫁聚之事

牛宿六日用事。其日生者为性刚毅心无怖畏。猛健胜人能破国土。前无强敌大富饶财。若入胎者宜在翼宿。一切众星不为障碍皆作善友

女宿七日用事。其日得病经十二月。石蜜及华祭于山神乃得除愈。其日生者远行遇伴。宜以治生作柔软事。其人有智少于病疾。常得世间国王供养。轸宿之日入胎者平无有善恶。鬼宿房宿。此二宿日为作障碍。七星宿心宿女宿毕宿。此四宿日宜造众事。亢宿危宿参宿等日作事不合。虚宿觜宿。乃得和合如意自在。室宿井宿氐宿等日。远行安隐亦得自在。奎宿房宿柳宿等日欲营事者。得他人力亦遇良友。昴宿张宿翼宿等日宜结亲友

虚宿八日用事。其日得病一年乃愈。应以菉豆乌豆小豆江豆作四种臛。香华祭神。其日生者性多嗔贪贫无衣食。于色欲间亦复乏少。依约亲属常多怖畏。若角宿日受胎者吉。张宿胃宿箕宿之日。受胎者恶多有障碍。房宿柳宿奎宿等日。入胎者平无有善恶。氐宿井宿室宿等日。受胎亦恶离散不合。亢危参宿。此三宿日作事利益得有和合。觜宿之日。欲作事者一切得作。鬼宿尾宿辟宿。此三日宜以远行道路安隐。娄宿七星心宿等日。若为事者得善知识及于良伴。翼宿箕宿昴宿等日。亦宜要结诸亲友等。毕宿牛宿。此二宿日亦复宜于结大善友

危宿九日用事其性柔软。其日得病苏乳酪糜以祭水神七日除愈。其日生者性多嗔忿。猛健勇锐而有水厄。若至水所须自防慎。亢宿之日入胎者吉。娄宿七星心宿等日。若作事者平无善恶。斗宿昴宿翼宿。此三宿日作事者恶。辟宿鬼宿尾宿参宿。此四宿日作事亦恶不得如意。室宿井宿氐宿之日。作事和合而得安隐。七星之宿。房宿柳宿奎宿等日。远行安吉。张宿箕宿胃宿等日。欲作事者得良伴力。角宿女宿觜宿轸宿毕宿牛宿。此六宿日宜结善友及以纳妻

室宿十日用事其性速疾。其日得病以种种华用祭于神三十日愈。其日生者奸伪作贼。愚痴妄语杀害众生。心常作恶不畏父母。若斗诤盗贼如是等处横罗其殃。其人入胎必在氐宿。若作事者箕宿胃宿张宿之日。无有障碍处处可为。毕宿轸宿牛宿。此三宿日若作事业一切皆恶。井宿之日作事乃吉。房宿柳宿奎宿之日造作事者。多有障碍不得利益。鬼宿尾宿辟宿之日。宜作事业为得利益。娄宿七星心宿等日远行安隐。昴宿斗宿箕宿等日。若作事者得良伴力。虚宿觜宿角宿等日。宜以要结小知识者。虚宿参亢宿等日。宜以要结大知识者

辟宿十一日用事。其日得病华及鹿脯以祭火神满七日愈。其日生者其人智慧乐圣人法。学于众艺种种皆能。歌舞伎倡亦复悉解。又主大富多有金银及饶谷帛。若入胎者宜尾宿日。昴宿斗宿。此三宿日造作众事平无善恶。觜女鬼宿。此三宿日为事成就。心娄七星。此三宿日为事多障。柳宿房宿。此二宿日欲作事者和合如意。轸宿牛宿毕宿之日。作事自如逢遇良伴。张宿胃宿箕宿之日行来安隐。亢宿虚宿参宿。宜可要结小知识者。井宿氐宿危宿等日。宜可要结亲友大吉

奎宿十二日用事。其日得病宜以香华祭于神祇。经二十日乃得除愈。其日生者作柔软事有大势力。人所尊重。唯于闇里须自护身。大富饶财金银谷帛无有限量。治生有利得他人物。彼人入胎宜在心宿轸宿毕宿牛宿等日。亦多蓄积。亢宿虚宿。此二宿日。作事者平无有善恶。参宿之日不可作事。柳宿翼宿斗宿昴宿。此四宿日行来安隐。女宿毕宿角宿之日。若作事者为得良伴。箕宿张宿胃宿等日欲作事者。无有障碍为得人力。娄宿心宿尾宿。此三宿日欲结知识为有利益。井宿氐宿危宿。此三宿日宜可要结知识小者。鬼宿尾宿室宿。此三宿日宜可要结知识大者

娄宿十三日用事。其日得病麦粥祭神二十五日然后除愈。其日生者为性躁疾。常护众生不害物命。若至关津须自防慎。当作医师善解方药能疗众病。亦复善能歌舞之事。心宿之日有入胎者。无有障碍。角宿觜宿女宿虚宿井宿亢宿危宿。此七宿日若作事者平无善恶。此星宿日。唯莫卖买。不宜行来及以剃头。亦不得至相斗处所。昴宿斗宿张宿。此三宿日宜报怨仇斗诤得胜。宜作轻利濡事得成。七星宿日作事牢固亦有利益。张宿箕宿胃宿。此三宿日欲远行安隐。辟轸毕宿。此三宿日作事利益亦宜密语。参宿虚宿亢宿之日宜作恶事。鬼宿尾宿室宿等日。宜可要结诸小知识。柳宿房宿辟宿等日。宜可要结诸大知识。为得众人爱护于己。宜造床舆及买牛马

胃宿十四日用事。人生吉凶造作善恶疾病等事如上说了。月行虚空周匝宿讫还更起昴。是故言日虚空月满。三十昼夜亦名月满。八月满者起胃终昴其月如是。夜十五时昼十五时。日午之影长六脚迹。娄宿夜行房在日前。荧惑日子是时随日。是八月时蝎神主当昴宿为业前已说竟。是白月内。次十五日昴又用事。月合昴星是八月满。昴与月合一日夜讫。其次复转合于毕宿。九月初日毕用事也

九月黑月。一日合毕二日合觜。三日合参四日合井。五日合鬼六日合柳。七日合星八日合张。九日合翼十日合轸。十一日合角十二日合亢。十三日合氐十四日合房。十五日合心。是黑月满

白月一日合尾二日合箕。三日合斗四日合牛五日合女六日合虚。七日合危八日合室。九日合辟十日合奎。十一日合娄十二日合胃。十三日合昴十四日合毕。十五日合觜是白月满。九月合觜宿满。昼十四时夜十六时。日午之影长八脚迹。日行南陆。昴宿夜行尾在日前。其九月时岁星用事。为一切天之所尊敬。得失诸事皆悉由之。是九月时。射神主当

十月黑月一日合参。二日合井三日合鬼。四日合柳五日合星。六日合张七日合翼。八日合轸九日合角。十日合亢十一日合氐。十二日合房十三日合心。十四日合尾十五日合箕。是黑月满

白月一日合斗二日合牛三日合女虚。四日合危五日合室。六日合辟七日合奎。八日合娄九日合胃。十日合昴十一日合毕。十二日合觜十三日合参。十四日合井十五日合鬼。是白月满

十月合鬼宿满。昼十三时夜十七时。日午之影长十脚迹。觜宿夜行女在日前。当此之时辰星用事。是十月时。磨竭之神主当其月。十一月。黑月之内一日合柳。二日合七星三日合张。四日合翼五日合轸。六日合角七日合亢。八日合氐九日合房。十日合心十一日合尾。十二日合箕十三日合斗。十四日合牛十五日合女。是为黑月满。白月一日合虚。二日合危三日合室。四日合辟五日合奎。六日合娄七日合胃。八日合昴九日合毕。十日合觜十一日合参。十二日合井十三日合鬼。十四日合柳十五日合七星。是白月满

十一月合七星满。昼十二时夜十八时。日午之影十二脚迹。鬼宿夜行危在日前。近南转辰星用事。是十一月。水器之神主当其月。十二月。黑月一日合张。二日合翼三日合轸。四日合角五日合亢。六日合氐七日合房。八日合心九日合尾。十日合箕十一日合斗。十二日合牛十三日合女。十四日合虚十五日合危。是黑月满

白月一日合室。二日合辟三日合奎。四日合娄五日合胃。六日合昴七日合毕。八日合觜九日合参。十日合井十一日合鬼。十二日合柳十三日合七星。十四日合张十五日合翼。是白月满

十二月合翼宿满。昼行十三时夜行十七时日转近北。日午之影十二脚迹。七星夜行天师岁星用事之时。是十二月。天鱼之神主当其月

正月黑月一日合轸。二日合角三日合亢。四日合氐五日合房。六日合心七日合尾。八日合箕九日合斗。十日合牛十一日合女。十二日合虚十三日合危。十四日合室十五日合辟。是黑月满

白月一日合奎。二日合娄三日合胃。四日合昴五日合毕。六日合觜七日合参。八日合井九日合鬼。十日合柳十一日合七星。十二日合张十三日合翼。十四日合轸十五日合角。是白月满

正月合角宿满。昼行十四时夜行十六时。日转近北。日午之影长八脚迹。张宿夜行娄在日前。日子荧惑严恶速疾此时用事。是正月时。持羊之神主当其月

二月黑月一日合亢。二日合氐三日合房。四日合心五日合尾。六日合箕七日合斗。八日合牛九日合女。十日合虚十一日合危。十二日合室十三日合辟。十四日合奎十五日合娄是黑月满

白月一日合胃。二日合昴三日合毕。四日合觜五日合参。六日合井七日合鬼。八日合柳九日合星。十日合张十一日合翼。十二日合轸十三日合角。十四日合亢十五日合氐是白月满

二月合氐宿满。昼行十五时夜行十五时日近北行。日午之影长六脚迹。角宿夜行昴在日前。阿修罗师名曰太白此时用事。是二月时。持牛之神主当其月

三月黑月一日合房。二日合心三日合尾。四日合箕五日合斗。六日合牛七日合女。八日合虚九日合危。十日合室十一日合辟。十二日合奎十三日合娄。十四日合胃十五日合昴是黑月满

白月一日合毕。二日合觜三日合参。四日合井五日合鬼。六日合柳七日合星。八日合张九日合翼。十日合轸十一日合角。十二日合亢十三日合氐。十四日合房十五日合心是白月满

三月合心宿满。昼行十六时夜行十四时日行近北。日午之影长四脚迹。氐宿夜行觜在日前。日子名曰佛陀悬多此时用事作柔软业。是三月时。双鸟之神主当其月

四月黑月一日合尾。二日合箕三日合斗。四日合牛五日合女。六日合虚七日合危。八日合室九日合辟。十日合奎十一日合娄。十二日合胃十三日合昴。十四日合毕十五日合觜是黑月满

白月一日合参。二日合井三日合鬼。四日合柳五日合七星。六日合张七日合翼。八日合轸九日合角。十日合亢十一日合氐。十二日合房十三日合心。十四日合尾十五日合箕。是白月满

四月合箕宿满。昼行十七时夜行十三时日近北行。日午之影长两脚迹。房宿夜行日随井星。是四月时。蟹神主当其月

五月黑月。一日合斗。二日合牛女三日合虚。四日合危五日合室。六日合辟七日合奎。八日合娄九日合胃。十日合昴十一日合毕。十二日合觜十三日合参。十四日合井十五日合鬼是黑月满

白月一日合柳。二日合七星三日合张。四日合翼五日合轸。六日合角七日合亢。八日合氐九日合房。十日合心十一日合尾。十二日合箕十三日合斗。十四日合牛十五日合女。是白月满

五月合女宿满。昼行十八时夜行十二时。日极行北。日午之影长半脚迹箕。宿夜行心在日前。是时日光。焰炽大盛。此五月时。师子之神主当其月

六月黑月一日合虚。二日合危三日合室。四日合辟五日合奎。六日合娄七日合胃。八日合昴九日合毕。十日合觜十一日合参。十二日合井十三日合鬼。十四日合柳十五日合七星。是黑月满

白月一日合张。二日合翼三日合轸。四日合角五日合亢。六日合氐七日合房。八日合心九日合尾。十日合箕十一日合斗。十二日合牛女十三日合虚。十四日合危十五日合室。是白月满

六月合室宿满。昼行十七时夜行十三时强。日近南行。日午之影长二脚迹。女宿夜行张在日前。月子名觉此时用事。此六月时。天女之神主当其月

七月黑月一日合辟。二日合奎三日合娄。四日合胃五日合昴。六日合毕七日合觜。八日合参九日合井。十日合鬼十一日合柳。十二日合七星十三日合张。十四日合翼十五日合轸。是黑月满

白月一日合角。二日合亢三日合氐。四日合房五日合心。六日合尾七日合箕。八日合斗九日合牛女。十日合虚十一日合危。十二日合室十三日合辟。十四日合奎十五日合娄。是白月满

七月合娄宿满。昼行十六时夜行十四时。日转近南。日午之影长四脚迹。室宿夜行角在日前。阿修罗师名曰太白此时用事。是七月时。秤量之神主当其月

尔时佉卢虱吒告天众言。是诸月等各有主当。汝可救济四种众生。何者为四。救地上人诸龙夜叉乃至蝎等。如斯之类皆悉救之。我以安乐诸众生故。布置星宿各有分部。乃至摸呼罗时等亦皆具说。随其国土方面之处。所作事业随顺增长

佉卢虱吒于大众前合掌说言。如是安置日月年时大小星宿。何者名为有六时也。正月二月名暄暖时。三月四月名种作时。五月六月求降雨时。七月八月物欲熟时。九月十月寒冻之时。十有一月合十二月大雪之时。是十二月分为六时。又大星宿其数有八。所谓岁星荧惑镇星太白辰是日月荷罗睺星。又小星宿有二十八。所谓从昴至胃诸宿是也。我作如是次第安置说其法已。汝等皆须亦见亦闻。一切大众于意云何。我所置法其事是不。二十八宿及八大星。所行诸业汝喜乐不。为是为非宜各宣说。尔时一切天人仙人阿修罗龙及紧那罗等。皆悉合掌咸作是言。如今大仙。于天人间最为尊重。乃至诸龙及阿修罗无能胜者。智慧慈悲最为第一。于无量劫不忘。怜愍一切众生故获福报。誓愿满已功德如海。能知过去现在当来一切诸事。天人之间无有如是智慧之者。如是法用。日夜刹那及迦罗时。大小星宿。月半月满年满。法用更无众生能作是法。皆悉随喜安乐我等。善哉大德。安隐众生。是时佉卢虱吒仙人复作是言。此十二月一年始终。如此方便大小星等刹那时法皆已说竟

又复安置四天大王。于须弥山四方面所各置一王。是诸方所各领众生。北方天王名毗沙门。是其界内多有夜叉。南方天王名毗留茶俱。是其界内多鸠槃茶。西方天王名毗留博叉。是其界内多有诸龙。东方天王名题头隶吒。是其界内多乾闼婆。于四方维皆悉拥护。一切洲渚及诸城邑。亦置鬼神而守护之

尔时佉卢虱吒仙人。说法已。诸天龙夜叉阿修罗紧那罗摩睺罗伽人非人等。一切大众皆称善哉欢喜无量。是时天龙夜叉阿修罗等。日夜供养佉卢虱吒。次复于后过无量世。更有仙人名伽力伽出现于世。复更别说置诸星宿。小大月法时节要略。尔时诸龙在佉卢氐山圣人住处。尊重恭敬光味仙人。尽其龙力而供养之

大集经卷第四十二大方等大集经卷第四十三

        隋天竺三藏那连提耶舍译

    日藏分送使品第九

尔时娑伽罗龙王白光味菩萨言。大德。乃能忆念如是过去宿命劫中种种善业无量往事而不忘失。及说虚空星宿照明安施法用。悉皆了达一一无遗。于三界中最尊最胜。智慧第一更无能过。是故彼龙并及我等。如是方便得脱此狱离于苦恼。怜愍众生慈悲一切。功德戒行及婆罗多。庄严于心一切满足。是时光味语诸龙言。我今非是佉罗虱吒苦行仙人。亦复不能于虚空中置于星宿。今我说者神通力知。汝娑伽罗诸龙王等莫作是说。我实不能然。此佉罗虱吒仙人。宿往因缘说犹未尽。尔时帝释及诸梵天各向佉罗虱吒仙人。齐共合掌作如是言。我等乐闻唯愿更说。我等梵天诸天中尊。犹如大仙圣人中尊。我诸天中有梵行者。若放种种神祇咒术我皆了知。亦能为他分别广说。时虱吒仙言。若能如是。亦可教化一切众生悉令知之。是时青眼帝释天主在于众中。虱吒仙人语帝释言。天主。一切善法必令具足。住持于世常使照明。修善法人拥护勿舍。若有精进乐善众生。持戒多闻修禅学慧。如是等众。天主应当供给所须衣服饮食卧具汤药。种种施与令无有穷。我说虚空星宿法已。今此世界诸地分中。各有龙王停止守卫。如娑伽罗龙婆娄那德叉迦宝护大行瞿娑罗婆苏婆呼嚧俱叉婆私无俱叉等。此八龙王护于海中。能令大海无有增减。阿奴驮致毗昌伽苏致婆娄那得于问娄叉婆。此四龙王守护池中出一切河。是故诸河流注无竭。难陀优波难陀。此二龙王守护山中。是故诸山丛林郁茂。婆须吉娑罗啰盖输卢瞿摩只利。亦为守护。毗梨沙阎浮伽赤眼娑罗婆帝。于小河水而为守护。悉陀摩奴阿罗苏摩贺卢唱利。于圣人所及诸药草而为作护。坚固紧输迦欢喜。此于地中而为守护。最胜光毗喻婆三婆毗离耶尸弃。此于火中作护。动摩都劣三摸地羁兰耶羁赖车。此于风中作护。优罗婆罗阿阇耶帝罗娑罗。此于树中作护。吁嚧呵张火薄脚罗沙斯。此于花中作护。香常跋陀耶逻婆遮富娄那迦罗。此于果中作护。阿匙林婆毗遮婆多吁嚧脂多末罗伽。彼中毗首羯磨苏摩[敲-高+(立/(可-一))]师奇和沙月眼。此四种一切工巧为最守护。羁罗睺陀罗僧伽那斯阿兰那惧无迦。如此四种夜叉。于一切福德布施等中能为作护。金刚眼师子眼善见眼三槊。如此四种一切龙护。如是等各各为护。尔时光味菩萨。于诸仙圣天人龙中最上最胜。怜愍一切苦恼众生。是故于此救诸龙厄令得解脱。时光味菩萨作是思惟。云何当令彼诸龙等。于三宝中回心归向。即以方便善巧音辞。次第教言一切龙王。信于我者。我实不能拔济于汝。今有大圣一切智人。乃能施汝安隐无畏。我所赞叹。佉罗虱吒仙人功德如是。说法非我小德办于斯事。彼圣人者。过去无量阿僧祇劫。已曾修习种种福德。一切难事皆悉能舍。所谓象马种种宝车。妻子国城金银辇舆。奴婢衣裳床榻敷具。众生须者称意与之。或复手足耳鼻舌身。头目筋骨皮肉肌肤求无吝惜。速能满足六波罗蜜。具大慈悲于苦恼众生能令解脱。为诸众生得安隐故。乃至处于地狱之中。救济众生心无暂舍。亦不自为得成佛道。欲令一切恶趣众生得脱种种老病死苦。是大仙人。乃往过去无边劫中。经历是等种种愿行。而是仙人。生生世世坚固精进勇猛慈悲。引接众生安涅槃道。又彼佉罗虱吒仙人。无量劫来种种福德具足圆满

乃至生于净饭王家。托在摩耶夫人腹内。既出生已举手唱言。我三界中最尊最胜。放种种光能与一切众生安乐。光因缘故感动无量天龙夜叉及阿修罗人非人等。一切悉来而共供养。又于生时一一方面各行七步。脚所蹈处皆有莲华承捧其足。以此脚踏行步因缘。一切山河地及大海悉皆涛动。如是变现出生功德。又释迦子。能令我等一切众生解脱生老病死。寂灭安隐。离诸怖畏到涅槃城。说是语时。一切诸天阿修罗众。龙及夜叉乾闼婆紧陀罗摩睺罗伽人非人等。各散种种众宝杂华涂香末香。于虚空中犹如雨下。以用供养。种种赞叹。尔时光味菩萨为诸大众而说偈言

  过去无量僧祇劫　　种种布施习檀那
  清净尸罗及羼提　　精进坐禅学般若
  安乐一切众生故　　备忍种种诸苦辛
  宫中六万后妃嫔　　弃舍出家如脱屣
  独处六年修苦行　　日食一麻一米麦
  精进昼夜不睡眠　　身形唯有皮骨在
  菩提树下思惟坐　　八十万众天魔来
  四方上下地及空　　八十由旬悉充满
  如是魔军及眷属　　皆能破坏使归降
  成就无上胜菩提　　得证第一义谛果
  见闻种种无怖畏　　其心寂静如涅槃
  常于一切众生中　　等心愍念无偏党
  真实智慧具足满　　教导一切诸天人
  无一众生起邪恶　　如是慈悲彻骨髓
  又于一切众生类　　乃至蚁子及蜎飞
  不生恼乱毒害心　　一切众生流转中
  悉能令其得解脱　　又于系缚诸有狱
  拔出众生使获安　　絓是小小如[槎-工+目]身
  大圣悉皆往救济　　彼诸龙等一切众
  能却其恶及忧愁　　是故大圣哀愍来
  慈心出汝此狱中　　广说无边深秘要
  不自在者悉称心　　一切归寂安隐住
  得彼圣人救济者　　不畏金翅诸鸟王
  各还所止恣意游　　如本受乐心无异
  大圣过去修万行　　不许恼乱一众生
  汝等所有诸灾恶　　魔王所为非佛作
  莫起余心谤毁佛　　受我教诲发菩提
  勿生疑恶自迷没　　一一皆如我前说

尔时一切诸大龙王所有眷属男女大小。在于牟尼圣人处者。闻此说已各各一心齐共合掌。作如是言。南无南无大圣。一切世间众生中胜。具一切法到自在岸。能与一切众生解脱。能与一切众生安乐。能与一切众生欢喜。能令一切到智慧彼岸。于诸众生慈悲平等。令修善法悉具足满。成就一切善业众生。安立善道与实法眼。于天龙中作上福田。于三界中最胜最尊。能受世间一切供养。我等诸龙同共辛苦。满此狱中未能得出。如是至心礼拜归命。说此语已。一切龙等悉得本形。虽复旧身而犹不能。于彼山中免离得出。尔时一切诸龙王等复白光味菩萨言。惟愿救济。如大德说。彼圣人者。于诸众生不起恼乱常施安乐。此言诚实我今信受无有疑心。若愍众生慈悲救济。惟愿速来令我等辈出彼魔狱。是时光味告诸龙言。彼大圣人具足智慧。牟尼如来心常怜愍一切众生。修习诸善舍于诸恶大悲普覆。于流转中精勤勇猛接引众生。于菩提道令得安隐。现见因果成就佛眼。一切菩萨摩诃萨过去久远不嗔因缘。悉皆具足慈悲喜舍四梵行法。复次菩萨摩诃萨道行因缘中生。因缘生已。种种恶趣及慈等行皆已说竟。复次彼佛如来世尊住无量阿僧祇恒河沙等诸佛刹微尘等无量无边。清净阿耨多罗三藐三菩提行故。六波罗蜜悉具足满。菩萨摩诃萨出于流转生死海故。到大涅槃智慧彼岸。坏四魔故。绍三宝种不断绝故。能以法水洗诸众生。一切烦恼垢令清净故。如来如是永离攀缘说四梵行。复说如性出相离相。及离我见。一切法等无尽方便。谓于五阴十八界十二入实谛观故。四大差别生死等法皆得灭尽。方便离于贪嗔痴等。一切烦恼体性悉空。无众生界离诸攀缘。无喜离喜无行离行。无物离物无想离想。无诸障碍无有处所。无尘无染无暗无明。不可捉持。无自无他不来不去。无异离行。乃至一切阴入界等。智眼体性非暗非明。不行不生。法界真实。不灭不坏。如如不生。法界真实皆空。过去一切诸法等中悉皆了达。是真攀缘如来从生。若有菩萨于是法中达到彼岸。具足充满六波罗蜜。犹如虚空离色离触。如是心得无障碍智。普断一切诸见及习悉皆除尽。如是得离一切烦恼。是名菩萨摩诃萨离观四种梵行之法。是时光味说此法已。时彼众中娑伽罗龙王。毗昌伽苏脂龙王。须摩呼嚧迦沙护宝龙王。如是等龙王。已于过去菩萨行中修习福德发弘誓愿。念宿命已即得光明照耀陀罗尼。余诸龙众八十那由他。亦曾过去种种愿行悉修习来。一切皆发三菩提心得于三昧。尔时光味即自化作圣人之身如菩萨形。与诸仙等乘神通力。从虚空中往如来所

    大方等大集经日藏分念佛三昧品第十

尔时一切诸龙众等。信受光味菩萨之言。皆悉至心归依于佛。归依于法。归依于僧。作是归时。魔王波旬亲见亲闻。既见闻已大生惊怪怖畏不安。嗔恚忧愁遍身流汗。举手摸头而说偈言

  呵呵看彼甚大笑　　奸伪幻惑释沙门
  诱诳诸龙皆归已　　迷忤一切诸众生
  惑乱道中妄安立　　实非言是我法真
  如是实法若得时　　彼中始终应不失

尔时波旬说是偈已。彼众之中有一魔女名为离暗。此魔女者曾于过去殖众德本。作是说言。沙门瞿昙名称福德。若有众生得闻佛名一心归依。一切诸魔于彼众生不能加恶。何况见佛亲闻法人。种种方便慧解深广。父王今者欲于如来及学佛道者边兴造恶心终不能成。时魔王言。沙门瞿昙解达真如智慧广大。于空法中深入坚固。自既度脱生死大海。又教众生亦皆出离。魔女答言。如王所说。若于空法觉实际者。设千万亿一切魔军。终不能得须臾为害。如来今者开涅槃道。女欲往彼归依于佛。即为其父而说偈言

  离相不着人中胜　　如如常住天中尊
  到于彼岸智慧城　　我今欲往归依彼
  修学三世诸佛法　　度脱一切苦众生
  善于诸法得自在　　当来愿我还如佛

尔时离暗说是偈已。父王宫中五百魔女姊妹眷属。一切皆发菩提之心。是时魔王见其宫中五百诸女。皆归于佛发菩提心。益大嗔忿怖畏忧愁即作是念。我今当行大魔王力大魔王威。于自宫中魔王坐处极尽神化。当彼圣人牟尼住所。一切诸龙和合集处。作大火石从虚空中一时雹下。碎彼诸龙及光味仙人使其远散。若彼去者我魔王宫乃可安乐。作是念已。即于空中放大火雹如雨而下。是时如来以神通力变彼火石悉为天华。缤纷乱坠堕佉罗坻。满山顶上圣人住处悉皆充遍。一切龙王莫不欢喜。是时魔王见雹下于圣人住所。即自指示五百女言。诸女好看。今彼处所一切诸龙眷属大众。归依沙门瞿昙边者。我已破碎一切如尘。何况我宫而不能坏。若我宫中有欲归向于瞿昙者。要当使其如彼不异。是时五百诸魔女等。更为波旬而说偈言

  若有众生归佛者　　彼人不畏千亿魔
  何况欲度生死流　　到于无为涅槃岸
  若有能以一香华　　持散三宝佛法僧
  发于坚固勇猛心　　一切众魔不能坏
  何况毕定求作佛　　若有精诚持一戒
  或复至心来佛边　　听受一句微妙法
  即发不退菩提道　　决定一切众中尊
  得佛金刚不坏身　　能摧一切四魔众
  父王但看诸龙等　　各散种种香华云
  惟佛世尊能了知　　非是魔王之境界
  独一导师处于世　　说于殊胜难思议
  所作一切皆吉祥　　能令众生罪业除
  我等过去无量恶　　一切亦灭无有余
  至诚专心归佛已　　决得阿耨菩提果

尔时魔王闻是偈已。倍大嗔恚怖畏煎心。憔悴忧愁独坐宫内。是时光味菩萨摩诃萨闻佛说法。一切众生尽离攀缘得四梵行。当于佛前从空而下到佛所已。光味菩萨与其大众。为佛作礼右绕三匝。却住合掌而白佛言。世尊如来。说彼四禅地依止心念陀罗尼。以是陀罗尼咒术力故。我忆过去。有二婆罗门子。以欲事故罪应合死。为官所收杀时未到。王敕有司付于牢狱。半月半月时给一餐。五缚系身。两手两足悉皆桁械。咽喉被锁饥渴难堪。兼复畏于死时将逼。狱中一心归依于佛。彼时有佛名曼陀罗华香。专意佛边遥求救济。是时彼佛怜愍众生及我等故。于自座中现佛境界大神通力。说四禅地依止心念陀罗尼作如是言。我以佛力令彼狱中二婆罗门闻此四禅地依止心念陀罗尼。闻已欢喜至心忆念。以是因缘令其所有一切恶业一切障碍。若今生中恶业障碍。若多生中诸恶业障。若烦恼障。法障。众生障。舍施障。智慧障。生活障。寿命未尽横死障。意欲不生系地所牵业力障碍。若有清净佛刹之中。情愿欲生而不得往违心障碍。如此一切恶业障碍。闻此四禅地依止心念陀罗尼因缘故。喉及手足五种枷锁。自然一时脱落在地。即于狱中得陀罗尼力。以神力故得出于狱。从虚空中到曼陀罗华香佛所。礼拜供养尽其寿命。即得往生山光佛刹。彼佛世尊名曰云色。从云色佛求请出家。既出家已。生生世世无量劫中。常得不生于空佛刹。恒值佛世如今此刹。娑婆世界三千大千佛土。地及虚空乃至阿迦腻吒天。人非人等皆悉充满。时彼佛刹一切众生。地及空中乃至阿迦腻吒天。亦复如是。一切众生具足恶业及诸障碍。以彼如来为众生故。说此四禅地依止心念陀罗尼。身口意恶悉皆消除。若听闻此陀罗尼力。一切三世诸罪恶业悉灭无余。又彼众生种种更得人忍三昧陀罗尼。乃至寿命欲尽之时。此间死已如愿欲生他方清净佛刹。应念即生得于宿命。常勤精进行十善法。常不复堕三恶道中。常能修行六波罗蜜。常行四摄。常得见佛。常闻于法。常供养僧。常得四禅及五神通。常具足得四梵行。念生生世世。常与彼法和合共生。乃至涅槃未曾舍离。佛言。善哉善哉。善男子。汝为大利益众生故。作如是说。过去宿命发心因缘

尔时世尊复告光味菩萨言。善男子。谛听谛听。若有比丘比丘尼优婆塞优婆夷。或男或女有信心者。欲于三乘及余道中。愿得速证涅槃道尽一切苦者。欲得一切闻持在心。一切身口意业清净。欲护佛法。欲求种种利益。种种衣食一切丰饶。自在殊胜端正大力。眷属强盛国土富安。职位高迁多人敬奉。聪明智慧最尊最胜。行住四仪常无所乏。及乐种种施戒坐禅。得诸三昧乃至无色。一切有顶所有三昧。亦复乐于四梵天行。若有乐于陀罗尼人。望得如是种种众事。而彼恶业坚固厚重。诸业障碍。烦恼障碍。乃至欲生清净佛刹。不生障碍。以如是故。种种善愿不得称心。欲令如是种种恶业速灭尽者。而此众生应净洗浴着鲜洁衣。菜食长斋勿啖辛臭。于寂静处庄严道场。正念结加或行或坐。念佛身相无使乱心。更莫他缘念其余事。或一日夜或七日夜。不作余业至心念佛。乃至见佛小念见小大念见大。乃至无量念者见佛色身无量无边。彼佛身形三十二相。于一一相亦念亦观皆令明了。随所见相见青光明。于彼光相专精系意无令心乱。作是念时而诵是咒

哆绖咃　毗视林婆　毗视林婆　郁头波驮避耶毗视林婆　斯那婆颇　罗斯那婆头　罗阿[少/兔]那多他恀阿[少/兔]那多他恀复嘘多俱致毗视林婆毗视林婆　莎呵

如是一相在于前心。[骨*力][骨*力]专念不起乱想。然后诵此陀罗尼咒。乃至念于佛身相中青色出光。彼光出已从行者顶入。尔时安心慎莫惊怖。于自身中见于此光。如彼青色念此青光。于自身中各各肢体处处遍行。乃至一切身中火然。见火然已乃至成灰。及四方风来吹散灭。如是念时。见于自身无有一相惟有空在。乃至十方皆悉是空不见一色。如是念佛青色力缘。诵持于咒成就此行。善男子。若复有人如是系念不散乱心。学四禅地依止心念陀罗尼。而彼众生一切业障。烦恼障。法障。罪业皆尽。惟除五逆破毁正法诽谤圣人。若复有人。如是乐者。能如上习念佛三昧。一日一夜口能诵持一切佛法。一切外道十八种论智慧胜处。如是种种句义文章悉皆忆持无有遗忘。又一日夜得于四禅。四种神通四无量行。四种辩才。及四无色三摩跋提。如是等法一切成就具足得之。如是修者乃至能于一弹指顷。到一佛刹及无量刹。又以一足能动如是无量刹土。过是等刹亦能动摇。能以一身结加趺坐遍满诸刹。如是世界能令水满。十方尘数皆能数知。能以七宝满诸国界。又复彼人于一念顷。悉能得知生死业报。过去现在及以当来。一切众生所有心数。又彼行人能以一身。种种化作一切佛身。帝释天身。梵天王身。那罗延身。摩醯首罗身。四天王身。转轮圣王身。乃至水火遍虚空。又复彼人如是念者。能一念中一切十方地及虚空种种华满七宝充遍。一切众香伞盖幢幡。种种衣裳种种缨络。一切虚空皆悉能满。若复有人至心修习此四禅地依止念佛三昧。一一差别谛识了达。时彼众生如是无量恶业悉尽。如是无量福德精进种种三昧。种种陀罗尼种种忍及五神通。于余乘中速得满足。流转海中毕定疾出。除五无间谤法诽圣不得是法。彼人应须经七七日。此四禅地依止念佛三昧心内熏修。于此法中常说修习不舍离者一切罪尽。若不专心罪两分尽。平常用心罪一分尽。如是修习须精进心纯信敬心。能如是者彼恶乃尽。若复有人此四禅地依止念佛三昧。或天中说。或人中说。若彼天人信心听受如此三昧。内自思惟生于欢喜。如是之人若在牢狱五锁系身。或复余处受辛苦者悉得免脱。若失生活或复求财。或打或烧或临河水。或被毒药或为种种怨家来侵。或一切鬼或一切幻。或复国王种种怖畏。或自家中斗诤口舌。或复他人横来嗔怒。或死怖畏或恶道中欲堕怖畏。如是怖畏此业皆尽生人天中。若复有人一闻如是四禅地依止念佛三昧。至心信受如是念佛三昧。有大势力。有大利益。小小用心尚得如是。何况至心无有疑惑。说此三昧法时众中八十六频婆罗那由他百千从十方来诸天人等。过去已曾为此三昧所熏修者。皆悉获得如上所说。复有八十四那由他众生得苦智忍。无量众生得此三昧。或须陀洹至罗汉果。无量众生发菩提心时。彼离暗五百魔女。承佛神力在魔王宫。悉皆得此念佛三昧。悉舍本形得男子身。曾于过去修学如是念佛三昧故。时此五百诸魔王女得三昧已及男子身。心生欢喜欲往佛所。一切化作大梵天身。一一梵王无量千亿眷属围绕。或作无量帝释天身。亦有千亿眷属围绕。各以无量种种音乐种种庄严。如是化已从魔宫下。向如来所设于供养。种种华鬘末香涂香散于佛上。顶礼佛足右绕三匝。却住一面

    大方等大集经日藏分升须弥山顶品第十一

尔时佛告光味菩萨摩诃萨言。善男子。汝今当知。彼一切龙恶道中生罪业悉尽。复告光味。空观心念故。时光味言。如是世尊。如来清净戒行具足。如来当为一切诸龙作庄严故。复次光味。我于是时实为诸龙。不可思议业报差别欲广说故。尔时一切诸色欲天。乃至夜叉鸠槃茶等。从虚空中雨种种华散种种香。衣服幢幡七宝璎珞。种种伎乐无量百千亿那由他。一时俱作歌咏赞叹出妙音声。人与非人佥然恭敬。尔时世尊从座而起。四面顾视向北方看。此何处山与须弥接近。彼欲界及于色天。尔时如来与诸大众菩萨声闻天人龙神一切八部四面围绕。前后导从趣须弥山。是时如来欲以足步蹑于山根。次第登上大梵天等。知佛欲升须弥山顶。即为如来化作七宝阶桥。持诸天衣及华香末种种校饰。如是作已前白佛言。惟愿如来行我桥上。他化乐天亦为佛故。用阎浮金化作宝桥。以龙栴檀末而散桥上。作如是言。惟愿如来行我桥上。化自乐天亦为佛故用诸天金化作宝桥。种种牛头细栴檀末散于桥上。作如是言。惟愿如来行我桥上。兜率陀天亦为佛故以诸天银化作宝桥。以诸种种应时所出微妙之香名黑栴檀。末而散桥上。作如是言。惟愿如来行我桥上。须夜摩天亦为如来。以天琉璃化作宝桥。散诸种种多摩罗叶细末香。作如是言。惟愿如来行我桥上。天帝释亦为佛故以赤真珠化作宝桥。以天种种栴檀一切宝末用散桥上。又以天缯七宝妙网而罗覆之。覆已作如是言。惟愿如来行我桥上。如是四镇四大天王。亦以珍琦天石藏宝。为如来故化作宝桥。亦持细妙种种天衣覆于桥上。覆已作如是言。惟愿如来。从我桥上上须弥山。是时四大阿修罗王并其眷属。为如来故以其所出摩娑罗宝化作宝桥。持天金银细末之屑散于桥上。散已作如是言。惟愿如来行我桥上。尔时世尊为彼一切梵释四镇及阿修罗诸天王等。以怜愍故一时化作八佛如来。三十二相八十种好无有殊异。八部四众菩萨声闻围绕导从。彼一切天阿修罗等。如是大设诸庄严已。时佛世尊即上宝桥升须弥顶。或余处起或余处去。彼八如来身大明耀。一一佛身皆放光明。如百千亿日月之光一时照明。如是八佛放身光已。时诸龙众一切皆在此佉罗山圣人处所集聚而住。诸龙见已一切怪言。此是何处八大护世。今来依止于须弥山。尔时难陀优波难陀龙王作如是言。此是梵天一切欲色围绕而住。一切天中最为殊胜到智慧岸。怜愍我等故来至此。今一切龙若欲得出此苦狱者皆可礼敬。是时阿那婆蹋多龙王作如是言。此非梵天乃是魔王。于欲界中威力自在。愍我等故。妻子眷属皆悉围绕。为欲界中一切众生脱于怖畏。故来是中救我龙厄。时地利致色龙王作如是言。此非魔王乃是欲界他化等天故来此中。欲令一切诸龙解脱。尔时众中一切龙王。皆发大声作如是言。愿诸天等。与我解脱。与我解脱。施我安乐。令我早得出于地狱。时娑伽罗龙王复作是言。彼非兜率化自乐等。此是天主释提桓因所放光明。照于欲界及四天下。观彼一切四域众生乐于善法。汝等一切起慈悲心。更勿生嗔。于彼天所求乞解脱速离此苦。时善住龙王作如是言。此非帝释。乃是一切诸色界天。舍于禅乐从彼下来。欲雨法雨与众生乐。汝诸龙等一切至心礼拜乞救。时毗昌伽苏脂龙王复作是言。此非色天神通力来。是四天王毗沙门等。为护四方各各自将眷属而来。欲除罪恶诸众生故。尔时宝护龙王复作是言。此非四天王。我见染衣剃除须发身服袈裟。相好端然盛德自在。为诸天人之所瞻仰。恭敬供养合掌围绕。如日月天星宿遍绕。此八大圣皆悉显赫。坚固照明身紫金光。三十二相慈悲一切。于三界中得受供养。尔时毗昌伽苏脂龙王更如是言。真实导师我亲见来。能救能护一切众生能竭苦海。能于此狱与解脱乐。今近住此须弥山顶。如是世尊神通力故。此须弥顶忽更广阔。八十四百千踰阇那。尔时欲色一切诸天。各欲供养于如来故。为佛造作七宝阶桥。楼阁梯橙次第节级。乃至上到阿迦腻吒天。各以种种不可思议天杂琉璃罗网校饰。犹如宝盖巧妙少双。一切众生见无厌足。无量百千种种珍宝以用庄严。种种天衣种种璎珞。种种伞盖缯彩幢幡。蠡鼓钟铃花香伎乐。如是供养遍满虚空。尔时世尊告帝释言。天主。如是三千大千世界娑婆刹土。一切诸佛。并大菩萨摩诃萨。大阿罗汉。大仙圣人。及乐福德大力魔王。种种色欲天龙夜叉人非人等。于此三千大千刹住受用皆讫。如是帝释。此须弥山。如来世尊十方佛刹。诸来菩萨大阿罗汉一切圣人。乐福魔王大德诸天。乃至于龙夜叉罗刹人及非人。此须弥山皆悉停住。汝诸天等当来世中多得势力。时天帝释白佛言。若佛如来怜愍我者。如是受用神通力作。及此三千大千世界娑婆刹中所有菩萨大阿罗汉。大梵魔王。他化乐天。诸帝释天。乃至于此娑婆世界所有天王。龙王。夜叉王。乾闼婆王。阿修罗王。迦娄罗王。紧那罗王。摩睺罗伽王。复有大力福德众生。天中圣人。人中圣人。一切皆来供养佛故。见于佛故。礼拜佛故。听于法故。如是等众。此须弥山若受用者。我于当来增大胜乐得大安隐。尔时世尊受帝释天于彼中住。端坐正念熙怡微笑。笑已口中出种种光。青色黄色赤色白色紫颇梨色。照此三千大千佛刹之中。百亿魔王宫。百亿帝释宫。百亿梵天宫。百亿一切诸天王宫。百亿阿修罗王宫。百亿圣人牟尼住处。是一切光如是照已。如上所说一切福德大力魔王。乃至圣人一切惊觉。各各寻光乘神通力。如一念顷来到于此须弥山顶。尔时世尊现神光已告帝释言。天主。如是三千大千世界一佛刹中。则有百亿须弥山王。是时一切诸须弥中。此须弥山最尊最胜。何以故。我及天人一切大集在此受用度诸龙故。说此语时无量百亿帝释天等。一切梵王皆大欢喜。如是如来神通力故。时四龙王皆得从彼圣人住处而出。既得出已各还自方。如是娑伽罗龙王。还于南方大海岸中。复其本身大如须弥。乃至举头到帝释宫自见于佛。如是西方护宝龙王。北方毗昌伽苏脂龙王。东方苏摩呼嚧叉龙王。各还大海于旧宫中悉复本形。乃至如前须弥山头自来见佛所。余无量那由他百千万亿。犹在彼处不能得出。时一切龙向大圣人如是称说。愿救济我。愿救济我。于此狱中令速解脱。尔时难陀优波难陀二龙王等。从佉罗山圣人住处。各以自身依须弥山。化作大桥拄帝释宫。作如是言。惟愿如来踏此桥上。从须弥顶下佉罗坻圣人处坐。为一切龙归依说法。时帝释天如是念言。此龙身涩毒气皮粗。或伤如来足不安隐。作是念已即以天服覆于龙身。又持天中牛头栴檀。优罗伽娑罗栴檀。多摩跋香。此三种香及以天华种种屑末。散于桥上并蔽龙身。时佉罗坻牟尼住处。以佛力故更增广博。八十四亿那由他百千踰阇。彼处广已大梵天王以天金银化作师子须弥宝座。种种庄严幡华帐盖而安置之。尔时一切诸龙王等闻是语已各白佛言。世尊。惟愿怜愍救我等苦。佛言龙王。汝等先应至心念佛。我当救之。尔时世尊在须弥顶。告于长老憍陈如言。憍陈如。诸佛境界奋迅神通加被之力如是说法。及此一切三千大千。娑婆世界佛刹之中。所有一切无量众生。彼诸众生。闻我说法能听受者。憍陈如。一切诸法悉皆无常。一切诸法生住无常。何以故。生因缘故。如眼识生。生已住。住已念。念更生。此即是苦。是生因缘。即是苦生。即是痈疮。即是一切十二有支。即是生老病死因缘。如是念念生灭。如眼因缘。耳鼻舌身亦复如是。憍陈如。住虽暂有灭更渐生。此譬如窗。此生住缘。此苦因缘。有此百种老病及死。如是展转渐生因缘。眼见造业。随见随念随念随造。所造生死因缘无穷。憍陈如。如眼寂灭。光灭没故不见众色。如彼日没窗中不见。若因缘灭一切患灭。十二有支一切寂灭。生死寂灭如日没缘。耳鼻舌身亦复如是。憍陈如。如心寂灭所缘亦灭。此窗因缘如本不生。一切万法亦复如是。此名苦灭一切患灭。十二有支一切寂灭。究竟生死尽诸有边亦复如是。憍陈如。众生不知眼之生灭。随逐耳鼻舌身所染。是故流转于五道中。我之圣法能离生死过于彼岸。是故如来为断一切眼生灭故而演说法。亦为说苦断苦行法。一切苦中得尽其底。是故如来得此法已。是一切天梵中大梵。天中大天。人中大人。沙门中大沙门。婆罗门中大婆罗门。大慈悲中大悲最胜。无上之尊为大丈夫。已度生死流转彼岸。一切世中最胜檀那。昙摩。僧琰摩。何者檀那。所谓舍施。乃至头目手足所须肢节皆悉能舍。况复余物。此名檀那。何者昙摩。清净持戒。乃至人来索头与头。心不嗔忿慈悲不失。是名昙摩。何者僧琰摩。不舍六根一心禅定。一切福德言语诵持忆念不忘。此二思量思念已修。此二种名僧琰摩一切众生平等心法。若我舍法昙摩檀那。及僧琰摩。四梵行法圣八正道。如是之法慈心熏故。此一切法于无量劫慈心修故。如我所得一切诸法。于众生中广演宣说。亦作导师悲怜众生开解其意。演说此事无所缺减。汝等今者应当一心信受奉持学习诸禅。种种兰若。或林树下。或复冢间。种种山岩崖岸中住。于彼坐禅。为尽生死故。勤大精进身心不倦。莫作下心。无所成故死时悔恼。此我一切所教之法。如是说已此娑婆界三千大千佛刹之中百亿四天下。一四天下。则有无量亿那由他百千众生。彼诸众生种种善根福德具足。或得陀罗尼。或得于忍。或得法眼。或得须陀洹。乃至阿罗汉。或有众生。地狱畜生饿鬼等中。余报恶业悉得尽灭。如是夜叉贫穷因缘一切皆尽而得大富。或有众生人中贫穷恶业报尽。及诸恶病皆得除愈。狱禁众生皆蒙解脱尔时娑伽罗龙王即于佛前说偈赞叹

  真金离垢满月面　　清净行具最胜田
  三界天人龙中尊　　能去众生浊垢恼
  施戒忍辱及精进　　成就真实平等心
  解脱诸龙施安乐　　忆念往昔誓愿力
  慈悲久修众业行　　坚固胜彼诸众生
  如是备受众苦辛　　不忘彼龙诸所恼
  种种流转得越度　　出过生死海彼岸
  自身解脱济群生　　智水洗龙使清净

大集经卷第四十三大方等大集经卷第四十四

        隋天竺三藏那连提耶舍译

    日藏分中三归济龙品第十二

尔时空中自然而雨种种香华种种宝衣种种音乐种种歌舞充满虚空。一切天龙夜叉罗刹及阿修罗悉皆恭敬。尔时世尊与诸大众菩萨声闻。左右围绕前后随从。从须弥顶蹈龙身桥。下佉罗坻圣人住处。梵天所敷宝师子座。坐于彼座。时虚空中一切天龙夜叉罗刹。并阿修罗。紧那罗等各设供养。种种香末种种华香种种宝衣以散佛上。右绕三匝礼已而坐。尔时娑伽罗龙王白佛言。世尊。何因缘故。我等一切在龙中生。佛言龙王。谛听谛听。我今为王分别广说。有十种业来生龙中。何者为十。有诸众生行六波罗蜜。欲得阿耨多罗三藐三菩提觉。亦愿欲得无恶障碍。或复欲得多修布施以时舍施。愿因缘故来生龙中。复次龙王。或有众生于大乘中修行舍施。福德果报因缘故愿生龙中。复次龙王。或有众生为阿耨多罗三藐三菩提故行于布施。福报虽多不能清净。怖畏地狱饿鬼畜生中因缘故愿生龙中。复次龙王。有诸众生欲行阿耨多罗三藐三菩提时。生高心大慢力因缘故愿生龙中。复次龙王。有诸众生发菩提愿行阿耨多罗三藐三菩提时。多生嗔恚恨他众生。以嗔忿向彼地狱饿鬼畜生因缘故长起嗔忿。如是死已愿生龙中。复次龙王。有诸众生求于小乘。欲得福田觅圣人中。舍布施报福德供养。如是因缘自愿力故来生龙中。复次龙王。有诸众生嫉妒慢故。彼业因缘来生龙中。复次龙王。有诸众生多起憍慢饶于语言。以彼自业来生龙中。复次龙王。有诸众生不信佛法僧宝。又不供给和上阿阇梨及余大德。又不供养父母二亲。于中种种嗔忿毒心爱憎憍慢痴因缘故。于福田中邪错行故。以是业缘来生龙中。复次龙王。有诸众生种种痴慢恶业力多福德力少。心怖畏故愿生龙中。复次龙王。有诸众生妄语两舌恶口无慈。此三业缘故而生龙中。佛言龙王。以此十种业因缘故来龙中生。复次龙王。复有三业因缘而生龙中。何等为三。有诸众生。坚固恶业造身口意。彼业熟故生地狱中经无量劫。受大极苦难得解脱。虽免大业小业未尽生于龙中。或畜生中。或饿鬼中。以此三恶业因缘故来生龙中。时娑伽罗龙复白佛言。如是世尊。而此龙中或有诸龙所受乐报犹如诸天。或有余龙受乐如人。有如饿鬼。如畜生者。或有余龙如地狱中受大辛苦。说是事已时娑伽罗大龙王子名青莲华面前白佛言。世尊。我何恶业罪因缘故来生龙中。身大端正。所有色触或复衣裳及坐卧处。于一切时我身受用犹如火烧。常无衣服赤体而行。如我父王乐受最胜。如转轮王果报不异。佛言华面。谛听谛听。善思念之。今当为汝说于本事。乃往过去三十一劫。有佛世尊名曰尸弃多陀阿伽度阿罗诃三藐三佛陀。时彼世中有王名曰裴多富沙。彼富沙王。于三月中供养彼佛并及无量百千须陀洹斯陀含阿那含阿罗汉并大菩萨摩诃萨众。以种种衣服饮食汤药而供给之至心听法。既闻法已即发阿耨多罗三藐三菩提心。如是三月设供养已。彼富沙王。为尸弃佛及余众僧造立寺舍。施种种衣饮食汤药床卧被褥具足丰饶。彼富沙王第一太子名裴多娑树帝。彼娑树帝见佛闻法。于流转中生大怖畏。从父王边礼拜咨启。请欲就佛愿求出家。王报子言。欲往随意。任汝出家。既出家已又白父言。我欲父王寺上停止。富沙王言。亦随汝意。住彼寺中。时尸弃佛众僧弟子。在彼寺中坐卧受用敷啖饮食。彼富沙子裴多树帝妒嫉心生。忿彼旧住佛弟子众恒嗔骂之。时彼众僧被嗔骂已悉皆离寺。彼娑树帝见僧去已生欢喜心即自念言。彼去者好我大安隐。众僧去已。时娑树帝。恣用寺内衣服饮食。有余人来即不听住。彼娑树帝具造如是诸恶业已。命终之后生大地狱中。经无量千万那由他岁受诸火烧。地狱得脱生饿鬼中。复经无量百千万岁而受辛苦。饿鬼中死还堕地狱。脱地狱已生饿鬼中。如是经由三十一劫。汝等诸龙谛听谛受。其娑树帝于流转中。具足如是受诸辛苦。佛言华面。彼娑树帝者岂异人乎。即汝身是也。乃往过去恶业因缘故生大地狱饿鬼畜生轮转受苦。经是三十一大劫中备受众苦未曾暂舍。余残业故来生龙中受是恶报。时华面龙。闻是语已大声啼哭。举身自投四支布地。礼拜白佛作如是言。我今至心从佛忏悔。我大痴惑大慢愚曚。不解方便差别好恶造是罪业。低头合掌至心发露不敢覆藏。如来世尊。我今至诚入于骨髓。归佛归法归比丘僧。从今发意乃至寿尽。于是时中作优婆塞。佛言。善哉善哉。善男子。汝今有于地狱饿鬼恶道业报。如是至心归依我者得尽彼业。此中死已值弥勒佛得于人身。于弥勒佛法中出家证罗汉果。佛言华面。莫更狐疑。时彼裴多富沙人王。于三月中以种种资生供养尸弃如来。及诸菩萨声闻众故今得此报。受娑伽罗大龙王身犹如天乐。三十一劫不生三恶。常生天人受如是报。彼亦为于阿耨多罗三藐三菩提行因缘故。来此龙中愿欲得生。说是语时一切诸龙皆大懊恼悔往先咎。悉于佛前至心供养

尔时众中有一盲龙名曰颇罗机梨奢。举声大哭作如是言。大圣世尊。愿救济我。愿救济我。诸佛慈悲怜愍一切。我今身中受大苦恼。日夜常为种种诸虫小蛇虾蟆之所唼食。居热水中无暂时乐。佛言梨奢。汝过去世于佛法中曾为比丘。毁破禁戒内怀欺诈。外现种种善相威仪。广贪眷属弟子众多。名声四远莫不闻知。彼诸弟子如是说言。我和上得阿罗汉果。以是因缘多得供养。得供养已独受用之。见持戒人反恶加说。彼人懊恼如是念言。世世生中愿我所在食汝身肉。如是恶业死生龙中。是汝前身。众生愿故食啖汝身。恶业因缘得此盲报住热水中。又于过去无量劫中。在融赤铜地狱之中。常为诸虫之所食啖。尔时龙众闻此语已。忧愁啼哭作如是言。我等今者。皆悉至心咸共忏悔。愿令此苦速得解脱。尔时如来出金色手摩彼龙面作如是言。汝等谛听。我于过去曾作国王名曰善眼。是时有一盲婆罗门。来从我乞求索一眼。我时欢喜两眼皆与。若我此言诚不虚者。令汝梨奢清净眼生。一切诸罪悉皆除尽。即说咒曰

多绖咃　斫刍佉婆　娑兰那佉婆　羯磨佉婆　阿难阇那　毗啰阇佉破　兰多若摩　尼婆罗那都夜　阿鞞栴陀罗　树低　频头输第　吃利波输第颇罗输第　阿誓　多誓　多隶　多隶　婆细陀索继陀索继鸣卢罗避　摩诃鸣卢罗避　帝腹阿逻多那婆罗帝莎呵

尔时世尊说此实净眼陀罗尼已。彼梨奢龙得清净眼。余五万三千龙亦得净眼。及余八十四那由他夜叉鸠槃荼饿鬼薜荔多毗舍遮人非人等。罪垢消灭皆得净眼。尔时善德天子向佛合掌。而说偈言

  看彼十力世导师　　能使诸龙眼清净
  今生若不得值佛　　诸失眼者常盲冥

尔时世尊告长老憍陈如。汝可持此净眼陀罗尼咒。若有众生过去恶业。于今现在或当来世。或四大病。或恶人咒。或因毒药。以此缘故即便失目。如是众生。应当诵此净眼陀罗尼。自悔过去所造恶业。于诸众生起大慈悲。至心念佛舍于余事。七七日中昼夜六时以手拭眼。以是因缘得清净眼。若有众生于过去世作诸恶业。或毁于法或谤圣人。于说法者为作障碍。或抄写经洗脱文字。或损坏他眼或暗蔽他。此业缘故今得盲报。如是重恶业因缘故。七七日中不得差者。应当抄写此陀罗尼至心诵持悔过彼业。复以海沫。甘草。呵梨勒。阿摩罗。毗醯罗。此五种药捣末蜜和。盛着旧龟甲中以久年苏火上煎已。诵此陀罗尼一千八遍。以咒此药用涂眼上。舍诸缘事七七日中念佛造像至心发愿。时彼众生恶业消尽得清净眼。若有财者并营寺舍。随力所办布施资生。如是一切恶业皆尽。于当来世无量生中常不失眼。尔时一切诸龙众等作如是言。南无南无大悲世尊。能施三世众生利益。失眼得明。一切恶业清净无垢。尔时有龙名曰青色。大声唱唤而说偈言

  世尊能除诸罪垢　　犹如大河洗一切
  悉知众生种种行　　是故称佛众中尊
  我所居停住泽中　　大野枯泉无有水
  热风吹身剧于火　　形体屋舍臭难堪
  八千亿年住于彼　　曾无一日受欢乐
  常为众生所食啖　　眷属大小悉皆然

尔时世尊说偈答言

  若有众生造诸罪　　而复修营于福德
  建立寺舍施钟铃　　种种饮食供养僧
  以此杂福因缘故　　在所生中随业受
  造恶苦辛如地狱　　施食快乐似天堂
  或复来生于龙中　　缘彼善业因缘故
  于龙头中自然出　　希有如意妙宝王
  所欲念者皆随意　　种种果报皆悉具
  虽处枯泉及旱泽　　能出上妙清流水
  清净虚空布密云　　地平如掌泉池涌
  行住坐卧所在处　　皆能应念生诸水
  若有一切诸众生　　虽复能得于人身
  备造种种罪恶业　　不能供养于三宝
  死后众苦皆聚集　　地狱饿鬼具受之
  设复得为龙王身　　所有眷属并妻子
  贫穷饥饿诸热恼　　顶上无有如意宝
  居住空泽多毒虫　　枯涸常干无有水
  如是皆由过去世　　曾于佛法作比丘
  或见兰若苦行人　　嫉妒悭心惜饮食
  远客比丘来寄止　　嗔忿怀怒心不喜
  檀越平等施饮食　　于中遮止便骂詈
  设有清净好流水　　屎尿粪秽满其中
  所有居住行坐处　　一切臭秽皆不净
  或有清净持戒者　　如是见已皆远离
  若有余处好人闻　　无心欲来于此者
  彼人恶业因缘故　　死堕地狱无量世
  灰河沸屎烧赤铜　　无量亿年受楚毒
  如是饿鬼中饥渴　　生曾不闻浆水名
  余报复生龙道中　　具足多年受辛苦
  虽得龙身常饥饿　　在所生处空无水
  或在枯泽恶焦山　　绝水常干无饮食
  死已数入地狱中　　大火热恼充遍身
  在彼经于无量岁　　如是循还饿鬼中
  自非修禅能救济　　礼拜供养佛如来
  持戒智慧学多闻　　精进舍于悭慢想
  妒嫉毒心最为恶　　此业因缘须断除
  忆念死时受是殃　　决定无疑早忏悔

尔时如来说是偈已。彼龙众中二十六亿诸饿龙等。念过去身皆悉雨泪。作如是言。唯愿哀愍救济于我。大悲世尊。我等忆念过去世时。于佛法中虽得出家。备造如是种种恶业。以恶业故经无量身在三恶道。亦以余报故生在龙中受极大苦。如青色龙我亦如是。尔时世尊语诸龙言。汝可持水洗如来足。令汝殃罪渐得除灭。时一切龙以手掬水水皆成火变作大石。满于手中生大猛炎。弃已复生如是至七。一切龙众见如是已惊怖懊恼啼泣雨泪。佛告诸龙。汝造罪业得是恶报。修善业人受于好果。我今教汝说真实誓。若佛导师怜愍一切。于诸众生平等无二。此言不虚。愿我诸龙火炎时灭。作是誓已火炎皆灭。时饿龙等乃至八过。以手捧水洗如来足。至心忏悔。我从今日更不造恶。如是忏已各白佛言。如来大慈愿救济我。佛言诸龙。汝此恶业有余未尽。弥勒佛世当得人身。值佛出家精进持戒得罗汉果。时诸龙等得宿命心。自念过业啼泣雨面。各如是言。我忆往昔于佛法中。或为俗人亲属因缘。或复听法来去因缘。所有信心。舍施种种华果饮食。共诸比丘依次而食。或有说云。我曾吃啖四方众僧华果饮食。或有说言。我往寺舍布施众僧。或复礼拜如是吃啖。或复说言。我毗婆尸如来法中曾作俗人。或复有说。我尸弃佛如来法中曾作俗人。或复有说。我毗叶婆如来法中曾作俗人。或复有说。我迦罗拘村驮佛法之中曾作俗人。或复有说。我迦那迦牟尼佛法之中曾作俗人。或复有说。我迦叶佛如来法中曾作俗人。或复有说。我释迦牟尼佛法之中曾作俗人。或以亲旧问讯因缘。或复来去听法因缘往还寺舍。有信心人供养僧故。舍施华果种种饮食。比丘得已回施于我我得便食。彼业因缘。于地狱中经无量劫。大猛火中或烧或煮。或饮洋铜。或吞铁丸。从地狱出堕畜生中。舍畜生身生饿鬼中。如是种种备受辛苦。恶业未尽生。此龙中常受苦恼。热水烂身热风吹体。热沙热土热粪热灰。食入口中变成铜汁或作铁丸。于一切时。所食之物。入口口焦。入咽咽烂。入腹腹然。直过堕地遍体穿穴。受如是苦不可堪忍。惟愿如来慈哀救济。佛告诸龙。此之恶业与盗佛物等无差别。比丘逆业其罪如半。然此罪报受未尽故难可得脱。汝等今当尽受三归一心修善。以此缘故于贤劫中值最后佛名曰楼至。于彼佛世罪得除灭。时诸龙等闻是语已。皆悉至心尽其形寿各受三归。时彼众中有盲龙女。口中膖烂满诸杂虫状如屎尿。乃至秽恶犹若妇人。根中不净臊臭难看。种种噬食脓血流出。一切身分常为蚊虻诸恶毒蝇之所唼食。身体臭处难可见闻。尔时世尊以大悲心见彼龙妇眼盲困苦。如是问言。妹何缘故得此恶身。于过去世曾为何业。龙妇答言。世尊。我今此身众苦逼迫无暂时停。设复欲言而不能说。我念过去三十六亿于百千年生恶龙中受如是苦。乃至日夜刹那不停。为我往昔九十一劫于毗婆尸佛法之中作比丘尼。思念欲事过于醉人。虽复出家不能如法。于伽蓝内敷施床褥。数数犯于非梵行事。以快欲心生大乐受。或贪求他物多受信施。以如是故于九十一劫。常不得受天人之身。恒三恶道受诸烧煮。佛又问言。若如是者。此中劫尽妹何处生。龙妇答言。我以过去业力因缘生余世界。彼处劫尽。恶业风吹还来生。此时彼龙妇说此语已。作如是言。大悲世尊愿救济我愿救济我。尔时世尊以手掬水。告龙女言。此水名为嗔陀留脂药和。我今诚实发言语汝。我于往昔为救鸽故弃舍身命。终不疑念起悭惜心。此言若实令汝恶患悉皆除差。时佛世尊。以口含水。洒彼盲龙妇女之身。一切恶患臭处皆差。既得差已作是说言。我今于佛乞受三归。是时世尊。即为龙女授三归衣。时彼众中复有一龙。种种臭恶一切诸虫。满其口中及咽喉内脓血流出。有见闻者皆悉舍去。时佛见已即便问言。善男子。汝于过去作何恶业受如是报。彼龙张口。于其口内出种种虫。脓血流溢犹如热火。虽复张口竟不能言即还闭口。尔时世尊即为彼龙而说偈言

  汝以过去盗因缘　　轻戏圣人受是报
  至诚听我此实言　　即得清凉灭诸苦

尔时世尊说实语已。即以少水泻龙口中。火及虫脓悉皆灭尽。龙口清凉作如是言。大圣如来。我忆过去迦叶佛时。曾作俗人在田犁地。有一比丘。来从我乞求五十钱。我时报言。听待谷熟当与汝食。比丘复言。若当五十不可得者愿乞十文。我于尔时嗔彼比丘而语之言。乃至十钱亦不相与。时彼比丘心生懊恼。又于余时往寺舍中入树林下。辄便盗取现在僧物十庵罗果而私食之。彼业因缘地狱受苦。恶业未尽生野泽中作饿龙身。常为种种诸虫食啖。脓血流溢饥渴苦恼。又彼比丘以嗔忿心恶业缘故。死便即作小毒龙身。生我腋下[口*束]于我血。热气触身不可堪忍。是故我身热脓血满。龙白佛言。大悲世尊。唯愿慈哀救济于我。令我脱彼怨家毒龙。尔时世尊。以手抄水。发诚实语作如是言。我曾往昔于饥馑世。尔时愿作大身众生长广无量。以神通力于虚空中唱如是言。彼野泽中有大身虫名曰不嗔。汝等可往取其身肉。以为饮食可得不饥。时彼世中人非人等。闻此声已一切悉往竞取食之。说是真实谛信语时。彼龙腋下小龙即出。时此二龙俱白佛言。世尊。我等久近。离此龙身解脱殃罪。佛告龙言。此业大重次五无间。何以故。若有四方常住僧物。或现前僧物。笃信檀越重心施物。或华或果或树或园。饮食资生床褥敷具疾病汤药一切所须。私自费用或持出外。乞与知识亲里白衣。此罪重于阿鼻地狱所受果报。是故汝等可受三归。归三宝已乃可得住于冷水中。如是三称三受。身即安隐得入水中。尔时世尊。即为诸龙而说偈言

  宁以利刀自割身　　支节身分肌肤肉
  所有信心舍施物　　俗人食者实为难
  宁吞大赤热铁丸　　而使口中光焰出
  所有众僧饮食具　　不应于外私自用
  宁以大火若须弥　　以手捉持而自食
  其有在家诸俗人　　不应辄食施僧食
  宁以利刀自屠脍　　身体皮膜而自啖
  其有在家诸俗人　　不应受取僧杂食
  宁以自身投于彼　　满室大火猛焰中
  其有在家俗人辈　　不应坐卧僧床席
  宁以火热炎铁锥　　拳手握持便焦烂
  其有在家俗人等　　不应私用于僧物
  宁以胜利好刀枯　　而自脔切其身肉
  勿于出家清净人　　发起一念嗔恚心
  宁以自手挑两眼　　捐弃投之掷于地
  其有习行善法者　　不应怀忿嗔心视
  宁以热铁鍱其身　　东西起动行坐卧
  不应嗔忿心妒嫉　　而着众僧净施衣
  宁饮灰汁碱卤水　　热沸烁口犹如火
  不应怀贪毒恶心　　服食众僧净施药

尔时世尊说此偈已。一万四千诸龙众等悉受三归。所有过去现在业报。诸苦恼中而得解脱。深信三宝其心不退。复有八十亿诸龙众等。亦于三宝起归敬心。尔时世尊告憍陈如。汝观此等诸恶众生自诳其心。或以怖畏贫穷因缘。或于恶道生于恐畏修行善法。或作比丘所得种种资生之具。皆是信心檀越所施。而是众生或自食啖。或与他人或共众人。盗窃隐藏私处自用。如是业故堕三恶道久受勤苦。复有众生。贫穷下贱不得自在。是故出家望得富饶解脱安乐。既出家已。懈怠懒堕不读诵经。禅慧精勤舍而不习。乐知僧事。复有比丘昼夜精勤乐修善法。读诵经典坐禅习慧不舍须臾。以是因缘感诸四辈种种供养。时知事人得利养已。或自私食或复盗与亲旧俗人。以是等缘久处恶道出已还入。如是愚瞑不见当来果报轻重。我今戒敕沙门弟子。念法住持不得自称。我是沙门真法行人。猗众僧故。他信施物。或饼或果或菜或华。但是众僧所食之物。不得辄与一切俗人。亦不得云此是我物别众而食。又亦不得以众僧物贮积兴生种种贩卖云有利益招世讥嫌。又亦不得出贵收贱与世争利。又亦不得为于饮食及僧因缘。使诸众生堕三恶道。应须劝引安善法中。令比丘众真信三宝。摄诸众生乃至父母。令得安隐置三解脱

大集经卷第四十四大方等大集经卷第四十五

        隋天竺三藏那连提耶舍译

    日藏分护塔品第十三

尔时长老阿若憍陈如白佛言。世尊。此日藏修多罗长夜照明。说一切龙恶业果报不可思议。复说菩萨真实行法。佛言。如是如是。憍陈如。此四天下有大支提圣人住处。若有众生精勤方便坐禅正慧。当知此处则为不空。如是福地则为流布日藏法宝。何者名为大支提处。此阎浮提内王舍城中。圣人处所大支提者。乃是过去无量如来。无量菩萨。无量缘觉。无量声闻。曾于其中修道灭度。今悉现有当来亦然。过去诸佛菩萨圣人。皆以付授婆娄那龙。令使拥护住持安立。我今亦欲令此处所光明久住。还以付嘱婆娄那龙。若有众生能护我法。精勤方便坐禅正慧。诸富伽罗。应常守护供给供养。尔时婆娄那龙王作如是言。如是如是。如世尊教。往昔过去迦罗鸠村驮应正遍知。亦以此处令我守护供给供养。精勤方便坐禅正慧。修善法者为作檀越。我于尔时供给守护乃至法灭。次复有佛。名拘那迦牟尼乃至迦叶。亦以此处付嘱于我守护供养。我于尔时供给守护。乃至法尽亦复如是。彼佛法中或有弟子。不受奴婢僮仆田地。以清净心精勤苦行。如是一切我皆守护。今日如来。复以此处付嘱于我住持守护。尔时世尊。复以西瞿耶尼须弥山下何罗阇低罗山中圣人处所名曰云尽。付宝护龙王。时宝护龙白佛言。世尊。如是如是。如世尊教。过去迦罗鸠村驮如来。亦以此云尽圣人住处付嘱于我。我于尔时守护此处。及佛弟子如法行者乃至法灭

尔时世尊。复以东弗婆提须弥山下青鸯伽那山中支提圣人住处名圣人生。付苏摩呼嚧叉龙王。时彼龙王白佛言。世尊。如是如是。如世尊教。尔时世尊复以须弥山下北胁之间华齿山中支提圣人住处名香峰牟尼。付毗昌伽苏脂龙王。乃至清净法行比丘亦皆付嘱。时彼龙王作如是言如是如是如世尊教。过去迦罗鸠村驮如来。亦以此香峰圣人住处付嘱于我。及法行比丘守护供养。乃至迦叶如来。亦复如是。今日如来。又以香峰支提处所付嘱于我。我当守护。佛言。善哉善哉。汝大龙王。如是能护我法住持法母。汝是我伴大善知识如法檀越一切众生依于我法。国土久住利益照明。尔时世尊复以西瞿耶尼洲中那焰牟尼圣人处所。付嘱瞿娑岚婆龙王。乃至法行弟子。守护供养亦复如是。复以东弗婆提洲中昵迦罗陀莲华牟尼圣人住处。付嘱婆私摸极叉龙王。乃至法行弟子。守护供养亦复如是。复以北郁多罗越洲中香峰炎圣人住处。付嘱地行龙王。乃至法行弟子。守护供养亦复如是。复以大海之中娑伽罗龙王宫摩尼藏炎牟尼圣人住处。付嘱娑伽罗龙王。乃至供养亦复如是复以须弥山顶帝释住处开华藏殿牟尼圣人住处。付嘱伊罗跋罗龙王。守护供养亦复如是。复以此阎浮中难陀婆陀那大德圣人牟尼住处。付嘱阎浮迦龙王守护供养亦复如是。复以此阎浮中鞞奢利善住牟尼圣人住处。付嘱婆须吉龙王。守护供养亦复如是。复以此阎浮中迦毗罗婆须都善香迦那迦灯牟尼圣人住处。付嘱阿那婆达多龙王。守护供养亦复如是。复以阎浮提中摩伽陀国毗富罗朋迦牟尼圣人住处。付嘱山德龙王。守护供养亦复如是。复以阎浮提中摩偷罗国名爱云炎牟尼圣人住处。付嘱阎婆迦质多罗龙王。复以阎浮提中憍萨罗国名阇耶首驮牟尼圣人住处。付嘱吃利弥迦龙王。复以阎浮提中苏波洛罽萨遮牟脂邻陀罗名香牟尼圣人住处。付嘱牟脂邻陀罗龙王。复以阎浮地中乾陀罗国名大利舍那若摩罗牟尼圣人住处。付嘱伊罗跋多罗龙王。复以阎浮提内罽宾国中名宫宫摩尼佉牟尼圣人住处。付嘱吁留逻龙王。复以阎浮提中庵浮利摩国名亿藏炎牟尼圣人住处。付嘱逻浮逻龙王。复以阎浮提中震旦汉国名那罗耶那弗罗婆娑牟尼圣人住处。付嘱海德龙王。复以阎浮提内于阗国中水河岸上牛头山边近河岸侧。瞿摩婆罗香大圣人支提住处。付嘱吃利呵婆达多龙王。守护供养。此大支提皆是过去大圣菩萨。大辟支佛。大阿罗汉。得果沙门。五通神仙诸圣住处。是故过去一切诸佛次第付嘱。欲令流转怖畏众生增长善根得菩提故。如是十方无量无数阿僧祇刹过去诸佛及诸菩萨。皆住于彼大支提处常加守护。令诸众生恶业尽故。于未来世无量无边阿僧祇刹。诸佛菩萨摩诃萨声闻缘觉。亦复住此二十大支提常加守护。令诸世间增福德故。一切众生恶业尽故。复次一切菩萨摩诃萨。一切辟支佛。一切阿罗汉。得果沙门。一切五通神仙圣人。于此二十圣人住处大支提中常加护持。一切众生福德增故。一切众生恶业尽故。如是过去一切圣人。付嘱如是二十支提。我今付嘱亦如前佛。欲令一切流转海中怖畏众生得安乐故。坚固护持不散坏故。时一切龙受佛付嘱二十支提圣人处已。作如是言。大圣世尊。我等诸龙多于障碍。贪嗜睡眠如痴无异。一夜睡眠当于人中二十一年。如是我等睡犹不觉。或有恶人及非人等。或水或火毁坏支提。我等或睡或食饮时。或复喜欢为世欲事。如此因缘。此之恶事则不能却。是故我于一切过去现在当来佛法之中成诸不善。尔时世尊告二十八夜叉将言。我今持此圣人住处付嘱于汝。此二十支提福德住处。好加爱敬精心护持。时二十八夜叉将言。敬顺佛教。二十支提如来付嘱岂敢不持。但瞿摩娑罗香山一处我难受取。时只利呵婆达多龙王。即白佛言。世尊。如来今者。以于阗国牛角峰山瞿摩娑罗乾陀牟尼大支提处付嘱于我。然彼国土城邑村落悉皆空旷。所有人民悉从他方余国土来。或余天下或余刹中。菩萨摩诃萨。大辟支佛。大阿罗汉。得果沙门。五神通人坐禅力故。向彼供养瞿摩娑罗旧无众生。一切来者皆是他国。世尊。此二十八诸夜叉将。不肯护持我今怪此。所以者何。以彼不护我等诸龙得于恶名。佛言。龙王莫如是说。何以故。今有二万大福德人见于四谛。从沙勒国而往彼住。以彼二万福德众生有大力故。于此瞿摩娑罗香山大支提处。日夜常来一切供养。龙王当知。如是之时恒不饥乏。又迦叶佛时。彼于阗国名迦逻沙摩。国土广大安隐丰乐。种种华果众生受用。彼国多有百千五通圣人世间福田。依止其中系念坐禅。乐阿耨多罗三藐三菩提。以其国土安隐丰乐。彼土众生多行放逸贪着五欲。谤毁圣人为作恶名。以灰尘土坌彼圣人。时诸行者受斯辱已。各离彼国散向余方。时彼众生见圣人去心大欢喜。是因缘故。彼国土中水天火天皆生嗔忿。所有诸水河池泉井一切枯竭。时彼众生无水火故饥渴皆死。是时国土自然丘荒。佛告龙王。我今不久往瞿摩娑罗牟尼住处。结加七日受解脱乐。令于阗国。于我灭度后一百年。是时彼国还复兴立。多饶城邑郡县村落。人民炽盛皆乐大乘安隐快乐。种种饮食及诸果华无所乏少。时僧儿耶大夜叉将白佛言。世尊。如是如是。佛言。大夜叉将。汝忆过去久远事不。僧儿耶言。我念往昔迦叶佛时。此牛角山圣人住处。迦叶如来。亦于彼处七日结加受解脱乐。过七日已从禅定起。我时到彼瞿摩娑罗香牢尼住处礼拜供养。彼迦叶佛。亦以平等法行比丘。精勤方便坐禅正慧。修善法者付嘱于我。时只利呵婆达多龙王白佛言。世尊。我誓于此瞿摩娑罗香大支提所常护不舍。乃至佛诸弟子法行比丘。精勤修善不受畜者我等守护。乃至法尽。或水或火。或龙夜叉。或鸠槃茶。弥勒佛时嗔忿作恶。如是时中非我所护。佛言。善哉善哉。龙王。若能如是发至诚心。加护我法住持法母令法久住。是我真伴是好檀越。是时座中有六十亿菩萨摩诃萨并及十方余佛刹中一切菩萨。皆悉来集娑婆世界。听于日藏大授记经。闻已一切同白佛言。如是世尊。我等从今常来于此四天下中牟尼住处礼拜供养。持种种华种种幡盖种种金银而以奉散。亦复持此日藏授记恶业尽陀罗尼。如佛所说广为一切众生而宣说之。我今为利自身他身恶业尽故。行菩提道满足六度。今此众中有多亿魔。及于无量阿僧祇天龙夜叉阿修罗迦楼罗紧陀罗摩睺罗伽。悉在此会围绕世尊。惟愿如来。以此二十牟尼圣人住处普皆付嘱。莫遣当来魔天龙王夜叉罗刹。及紧陀罗阿修罗等生于异心。于此二十大支提处空无守护。令彼恶人及非人等欲兴破毁。佛言。善哉善哉。善男子。汝莫怖畏。何以故。过去诸佛亦以此处。付嘱一切龙王夜叉。我亦如是。以此二十大支提处。付嘱诸龙及夜叉众。所以者何。未来众生多在八难。欲令彼等恶业尽故。薄慢心故。乐涅槃故。乃至资生所须。饮食汤药无所乏故。风雨顺时华果茂盛五谷熟成常安乐故。以是因缘。付嘱诸龙及夜叉等。于未来世一切诸佛。亦于二十大支提处林树经行坐禅苦行。得阿耨多罗三藐三菩提转于法轮。乃至涅槃安置塔庙。及佛弟子法行比丘。四果圣人亦于彼住。一切天人皆于彼处礼拜供养。多生功德起涅槃道。彼佛世尊。亦以二十大支提处及诸弟子。付嘱龙王及夜叉等令加守护。善男子。我今为汝说。一切恶心众生悉得欢喜。亦得生于诸三昧力。亦除一切恶邪烦恼。大授记陀罗尼咒。此陀罗尼。过去未来一切诸佛加助随喜。此咒能令恶心众生得柔软故。教修一切诸福德故。令习恶人心欢喜故。一切福德皆成就故。种种大愿达彼岸故。大智慧中安隐住故。得大闻持陀罗尼故。大方便智得究竟故。一切怨家生欢喜故。能除一切诸灾患故。出大难故。离怖畏故。办大事故。大谛见故。得大忍故。大智海中深远入故。得四神足三摩跋提。能除一切诸恶见故。乃至能了阿耨多罗三藐三菩提故。而说神咒

多绖咃阿摩　阿摩婆婆　阿摩波利婆婆　三舍耶揭婆　波利婆婆　蜜多罗蜜多罗舍罗耶　蜜多罗波利婆婆　蜜多罗三[穴/(怡-台+未)]若耶尼瞿卢陀三[穴/(怡-台+未)]若耶　摸极叉三[穴/(怡-台+未)]若耶　示利苦伽婆优婆矣罗阇　毗那舍耶　三摩舍罗耶帝罗阿那　薄迦岚摩　婆婆迦岚摩示利地毗迦罗婆那三摩若那阿波婆伽　那罗夜那跋伽摩　萨婆多　他阿伽多地悉他那跋伽　莎呵

尔时世尊。说是咒已告大众言。此陀罗尼亦名贤面。一切诸佛之所加护。能生禅定三摩提。能尽一切诸恶。乃至能了阿耨多罗三藐三菩提。若今现在及未来世。大支提处。若有余众。或魔或天。或龙夜叉。或复罗刹。或阿修罗。或迦楼罗。或紧陀罗。或鸠槃茶。人及非人。或以水火种种恶事欲坏支提。汝等应念三世诸佛。念诸佛已于彼众生起慈悲心。诵持如是大陀罗尼。令诸一切恶心众生悉皆除灭。若诸魔王及人非人。于如来所心不乐者。悉生欢喜恭敬供养。时佛神力令魔波旬于自宫内即得安住。自然得闻此陀罗尼。闻此咒已即于佛所生欢喜心得大信心。得信心已啼泣雨泪。集诸眷属作如是言。汝等一切谛听谛听。我今于此大牟尼处。得大忍心不动如山。彼牟尼尊慈悲满足。放大光明照一切龙一切天人一切修罗。我亦在彼于牟尼所兴造诸恶。今欲忏悔受三归依。汝若曾于佛边作恶。今可忏悔受三归依。我今共汝俱往见佛。礼拜供养至心听法。断烦恼魔入清净道。离于怖畏到涅槃城。时魔波旬。与其眷属八十亿众。前后围绕往至佛所。到已接足顶礼世尊。说如是偈

  佛两足尊世中胜　　自得寂灭亦教他
  忍辱精进愍众生　　我等愚痴兴恶意
  不知过去诸业行　　惟佛世尊能了知
  苞藏国土内身中　　令我心远种种惑
  三世诸佛大慈悲　　受我礼忏一切殃
  法僧二宝亦复然　　至心归依无有异
  愿我今日所供养　　恭敬尊重世导师
  诸恶永尽不复生　　尽寿归依如来法

时魔波旬说是偈已白佛言。世尊。如来于我及诸众生平等无二。心常欢喜慈悲含忍。佛言如是。时魔波旬生大欢喜发清净心。重于佛前接足顶礼右绕三匝。恭敬合掌却住一面。瞻仰世尊心无厌足。时彼众中有一魔子名加罗支。与其眷属从座而起。到于佛前接足顶礼。长跪白佛作如是言。世尊。云何名眼。为眼是色因缘。为色是眼因缘。乃至意法因缘亦复如是。佛言。善男子。非眼是色因缘。非色是眼因缘。乃至非意是法因缘。非法是意因缘。善男子。眼眼性空。眼识识性空。善男子。眼因缘眼识生。彼因缘故色可见。乃至意因缘意识生。彼因缘故法可知。非眼识可得。何以故。非余处来非余处去眼非常住。于三世中一切皆空。如是眼者亦非满见。亦非减见。非和合见。非相离见。亦非相触。亦不依止。譬如日出光照一切。其有窗处明焰皆入照于壁上。而是壁光不作是念我暗我明。此光非但独在一壁及众多壁。以因缘故有是光生。此壁及光。非合非离因壁见光。而此壁光不作是念日能生我。日亦不念我生此光。何以故。日灭没已光亦随灭。去处来处一切皆空无一可见。以日因缘故能照耀见此光色。以光显赫照耀因缘故得可见。于彼生识亦复如是。是内六入生外六入。亦外六入生内六入。外六入亦非因缘。内六入亦非因缘。何以故。彼此性离亦非聚集。亦非和合亦非依止。乃至内入外入。彼和合识亦非聚集。亦非和合亦非依止。何以故。各不相持境界离故。此法及识智慧知见诸行因缘。行因缘故有识。而此识生则三种行。云何三行。身行口行及以意行。云何身行。身行名为气息入出。此名身行。彼息出入去来动作。彼此出入各不相识。新识若生旧识不住。体性尔故。非聚集故。亦非异故。于如如中各不相依。虚空平等风行空中。风亦非空空亦非风。何以故。彼此不触各非境界。彼二皆空亦不可说。何以故。相离相故。无增减故。不依此岸及彼岸故。第一义谛如如住故。此名身行。是故身行非识依止。亦非伴侣。非是和合。非是聚集。常不依止。相离相故。是识亦复非依止身离和合故。此名身行。云何口行。口行二种名为觉观。云何是觉何者是观。于出入息生二种心。思惟忆念是名为觉。乃至细心次生。如是渐除得清净心亦名为觉。是觉依止出入故生生已即灭。根尘亦复不觉。此彼境界相相离故。性相无故。乃至不可说其长短此名为觉。何者是观。若有人观冷相触身于是中行。或复热相一切气息皆犹于风。彼风因缘观触知者此名为观。各离境界彼此离相。乃至不可说其长短是名觉观。云何意行。意行名思。云何名思。知一切法。乃至能知时出入气息。非时出入气息。知此出息非彼入息。知彼入息非彼出息。差别悉知。如是思量。知行顺相非行顺相。此则名为彼风依止。如是二种不可得说。云何是思云何心相。乃至知行差别作已。入涅槃道过凡夫地名出生死。于禅定中心能除却此则名思。如是风者不去不来。彼思识中如是依止。眼如眼乃至意如意各不相触。三受尽已名为圣人。如是善男子。非眼是色因缘。非色是眼因缘。乃至非意是法因缘。非法是意因缘。何以故。此二境界非远非近。亦非聚集。亦非思量。亦非和合。何以故。不可说故。此岸彼岸中不依止故。依实际故。佛说此已。是时魔子伽罗支二万眷属。曾于过去佛法之中。修行福德皆得顺忍。复有无量无边众生。亦于过去殖众德本。或得初禅乃至四禅。或有得于须陀洹果斯陀含果阿那含果。或有当来于小乘中为福种子。乃至当来辟支佛中得为种子。或复有发阿耨多罗三藐三菩提心。时彼众中有六十频婆罗龙。过去已来未曾值佛。今闻此法皆发阿耨多罗三藐三菩提心。时此一切三千大千佛刹大地。六种震动大动遍动。一切十方诸来菩萨摩诃萨。各得种种菩萨三昧。得三昧已各以种种宝种种衣种种香种种花。散于佛上供养如来。作如是言。如是世尊不可思议。我从昔来未曾见闻如是大集说此三昧力陀罗尼。此即释迦牟尼如来第二利益转妙法轮。我等今者于此日藏大授记鞞富略修多罗一心奉持。为诸众生广分别说是时众会魔天龙王夜叉罗刹阿修罗迦楼罗紧陀罗摩睺罗伽鸠槃茶薜荔多毗舍遮。现在集者悉如是说。不可思议释迦如来。能作如是利益众生。各大欢喜。以种种音乐种种宝种种衣种种璎珞花鬘烧香涂香。从空而散供养如来。是时娑伽罗龙王白佛言。世尊。惟愿如来暂入海中。往我家内受我微供怜愍我故。若佛如来至我宫者。我之眷属一切皆得闻此日藏授记大陀罗尼。时娑伽罗龙王复白佛言。世尊。彼大海中一切男女。若得闻此大乘日藏大授记经。专心听者得几许福。佛言龙王。若善男子。以四天下满中七宝布施如来。复有众生。具足闻此大乘日藏大授记经一心听者。于前福德百倍不及。百千亿倍不及。乃至算数所不能及。大王。若有听是甚深经典其福难量

尔时娑伽罗龙王。复作是言。若佛世尊不入大海。我当抄此日藏授记大集经典置我宫中。以是因缘。于彼海中几许诸龙福德增长。佛言龙王。随所有处抄此日藏大授记经。如法安置恭敬供养。则能获得十种利益。何等为十。若有人能如法抄写此经一心供养。令其家内一切吉祥。若在众中得大自在。五谷丰饶种种资生钱财宝物悉皆具足。复次龙王。若有宅内。或复众中抄此日藏大授记经抄已供养。于其处所。则有六十亿菩萨摩诃萨。数来礼拜供养此经。以是因缘。种种恶事斗诤疾疫种种恶病。谷米贵俭国土饥荒。他方贼盗非时风雨一切皆灭。彼六十亿菩萨摩诃萨白佛言。世尊。我当种种拥护供给令得称心。复次龙王。若有家内或大众中。抄此日藏大授记经如法安置。彼帝释天及诸梵天四天王天。二十八大夜叉将并其眷属。乃至大德天并其男女。娑罗娑陀天。牢固地天。善住乐天等。一切眷属皆至其国。日夜至心常加守护与其安乐。时帝释天乃至善住乐天等。闻是语已作如是言。如是如来。我及眷属常当至心往护彼国。复次龙王。若有居家乃至国土抄写此经。福德天下于过去世供养多佛布施持戒。如是之人往彼受生。复次龙王。若有居家乃至国土抄写此经。其中众生精进勇猛。不乐五欲常行檀那波罗蜜乃至般若波罗蜜。复次龙王。若有居家乃至国土抄写此经。福田众生常乐安住。复次龙王。若有国土抄写此经。其国常有种种善法如雨而下。复次龙王。若有国土抄写此经。其中众生于十善业常行不舍。复次龙王。若有国土抄写此经。其中众生常生慈心。复次龙王。若有居家乃至国土抄写此经。其中众生常人天生不入恶道。大王如是日藏大授记经。随何国土如法抄写。安置供养数数读诵。具足得此十种利益。何以故。若有读诵此日藏经如说行者。彼福德聚于百劫中说不可尽。龙王。此日藏大集大授记经。如是甚深能满大愿能大利益。说是经已。十方佛刹诸来菩萨。到此三千大千世界娑婆国土。大集聚会并此菩萨摩诃萨众。乃至魔王天龙夜叉罗刹阿修罗迦楼罗紧那罗摩睺罗伽鸠槃茶饿鬼毗舍遮富单那人非人等。随分悟解满足于心。皆大欢喜各设供养。佥然而住

大集经卷第四十五大方等大集经卷第四十六

        高齐天竺三藏那连提耶舍译

    月藏分第十四月幢神咒品第一

如是我闻。一时佛在佉罗帝山牟尼诸仙所依住处。与大比丘众有学无学六百万人。于诸烦恼坚牢缠缚悉得解脱。唯勤方便求断习气。及诸菩萨摩诃萨众。无量无边不可算数不可称计。悉得忍力化诸龙众。说日藏经已。即时西方现大华云。所谓优波罗华。波头摩华。拘牟陀华。芬陀利华。阿提目多华。瞻波迦华。婆利师迦华。如是华云悉皆来现。其华云中现一半月。广十由旬。于半月中复现真金重阁讲堂。庄严微妙。其堂光明过百千万亿日月光明。其光悉照佉罗帝山。复现种种奇异华云。所谓优波罗华。乃至婆利师迦华。其华光艳。照牟尼仙所依住处。七宝五柱重阁讲堂。甚奇微妙。隐蔽日月光不能现。于其堂中复现半月。于半月中有于千叶青色莲华。其华台上复有世尊端坐说法。其光普照一切大众。一一头上皆现半月微妙天鬘。复雨种种宝种种华种种香

尔时慧命大目揵连。见如是等神通变化生希有心。又知大众心有所疑。从坐而起偏袒右肩右膝着地。合掌向佛。而说偈言

  惟佛悉除诸烦恼　　于盲冥中能觉悟
  为群生故闭恶趣　　令诸众生住善道
  惟佛降伏诸亿魔　　令诸外道失光显
  调伏众生住檀尸　　枯涸众生烦恼海
  八功德水令洗浴　　以觉分宝济众生
  无量亿众入涅槃　　能转无上法轮宝
  一切所有诸龙众　　为嗔所使行诸恶
  渴爱所逼无有慈　　惟佛能益令归信
  四天下龙皆来集　　一心归于佛法僧
  尽诸业障及烦恼　　皆护正法而安住
  于此复现妙华云　　中有半月光照曜
  一切现此半月鬘　　今当欲有何佛事
  积此诸华如大山　　雨诸香华及众宝
  大众睹瑞心有疑　　当欲雨于何法雨
  此处微妙最第一　　如此大众皆依住
  于诸过佛修供养　　是人师子如是来

尔时佛告大目揵连。西方有世界名月胜。佛号日月光。有月藏童真菩萨摩诃萨。将诸眷属八十亿那由他。百千菩萨摩诃萨。欲来向此。为欲见我礼拜供养。与大众集说欲随喜。又欲付嘱诸天龙夜叉乾闼婆等。正法眼故。应时月藏菩萨摩诃萨。与其眷属八十亿那由他百千菩萨摩诃萨。从彼世界来至佛所。头面礼足右绕三匝住立佛前。皆悉合掌一音说偈

  吉祥无数劫　　所修为众生
  吉祥见众生　　生死苦所逼
  吉祥以檀施　　大仙作饶益
  吉祥能行施　　超越于人天
  吉祥护净戒　　众生不能动
  吉祥令怒者　　住于慈善心
  吉祥发勇进　　度脱懈怠者
  吉祥离恶道　　安置于善趣
  吉祥善修忍　　容恕怒恶心
  吉祥希有事　　是故悉归依
  吉祥修诸禅　　诸天生希有
  吉祥悉枯竭　　众生诸苦海
  吉祥熏修智　　追回恶道轮
  吉祥上菩提　　到最难到处
  吉祥降魔众　　建立正法幢
  吉祥所转者　　最是正法轮
  吉祥愍异空　　降伏诸外道
  吉祥降法雨　　充足渴世间
  吉祥作明证　　天人乾闼婆
  吉祥满世界　　我为最上师
  吉祥安四果　　应受世供养
  吉祥令亿众　　安住于涅槃
  吉祥久住时　　法眼所建立
  吉祥久住世　　世间无与等
  吉祥菩提果　　众所获大利
  吉祥为众生　　宣说无上法
  吉祥以法水　　洗浴诸众生
  吉祥善能度　　是诸天人等
  吉祥能显现　　无垢真妙法
  吉祥除众生　　所有诸烦恼
  吉祥诸僧众　　世间最第一
  吉祥善生世　　能益于人天
  吉祥令四众　　明净善光显
  吉祥令四众　　全护戒律仪
  吉祥行檀舍　　持戒及精进
  吉祥修忍禅　　及以妙般若
  吉祥大梵王　　娑婆世界主
  吉祥大魔王　　诸欲自在王
  吉祥憍尸迦　　辅佐诸眷属
  吉祥诸天众　　及诸宫殿等
  吉祥毗沙门　　及诸夜叉众
  吉祥提头赖　　眷属乾闼婆
  吉祥毗楼勒　　并与鸠槃茶
  吉祥毗楼博　　及诸龙军众
  吉祥日月天　　星辰及诸宿
  吉祥大自在　　儿及造界主
  吉祥风火神　　及以地神等
  吉祥诸龙众　　及以阿修罗
  吉祥诸罗刹　　及与紧那罗
  吉祥迦楼罗　　摩睺罗伽等
  吉祥雨甘雨　　行雨大神王
  吉祥护持国　　一切人中王
  吉祥婆罗门　　刹利毗舍陀
  吉祥所供养　　最胜尊导师
  吉祥愿闻者　　真正无过法
  吉祥诸现未　　供养三宝者
  吉祥一切众　　灭除诸烦恼
  吉祥诸众生　　同住于正法
  吉祥檀尸罗　　精进之彼岸
  吉祥禅那度　　忍辱波罗蜜
  吉祥诸一切　　到彼智岸者
  吉祥令诸病　　一切皆除愈
  吉祥皆休息　　一切浊恶世
  吉祥诸众生　　愿令悉解脱
  吉祥令一切　　悉得诸无漏
  吉祥于大地　　种子所生者
  吉祥诸禾稼　　药草树林果
  吉祥彼一切　　依时悉成熟
  吉祥胜地精　　一切处充满
  吉祥人精气　　一切皆安住
  吉祥法精气　　充满一切众
  吉祥皆休息　　一切诸罪恶
  吉祥令众生　　而得胜菩提
  吉祥于诸法　　自在到彼岸
  吉祥正法雨　　普润诸众生
  吉祥诸众生　　悉度于三有
  吉祥令一切　　悉证大涅槃

大德婆伽婆。我今欲说吉祥章句大力神咒。如是神咒过去诸仙之所宣说。建立守护善能增长吉祥之事。能除一切罪垢恶见。入诸善根增长大悲。以此咒句。悉能资益一切众生。乃至一切獐鹿鸟兽所得闻者。令如是等心得安隐。离浊恶世一切诸障。众生障法障如是等障皆悉休息。一切善根随所触法令得入心。念慧坚固名称形色人所喜乐勇健无畏。于十善业道坚固安住。檀波罗蜜乃至般若波罗蜜。四念处乃至十八不共法坚固安住。大慈大悲大方便力一切种智乃至究竟无上涅槃坚固安住。除其造作五无间业诽谤正法毁呰贤圣断常二见。唯除如是诸罪人等。是吉祥句。常为先圣建立加护。如此咒句。亦复能令诸天信受得入十善业道。亦令得入檀波罗蜜乃至般若波罗蜜。四念处乃至十八不共法。大慈大悲。大方便力。乃至一切种智无上涅槃。复能令彼诸魔眷属悉得归信。诸神龙王夜叉罗刹阿修罗乾闼婆紧那罗伽楼罗摩睺罗伽饿鬼毗舍阇。刹利婆罗门毗舍首陀。令入十善业道。檀波罗蜜乃至般若波罗蜜。大慈大悲大方便力。四念处乃至十八不共法。一切智一切种智无上涅槃惟除五逆诽谤正法毁呰贤圣。作是语已。而说咒曰

多地夜他　栴达梨　栴达啰毗提　栴达啰磨咩　栴达啰婆婆犀　栴达啰跋帝　栴达啰不[口*梨]　栴达啰婆[口*兮]　栴达啰差帝[口*梨]　栴达啰阇移　栴达啰頞寄　栴达啰底[口*梨]　栴达啰瞂咩　栴突喽　栴达啰婆啰[口*兮]　栴达啰勿达[口*梨]　栴达啰婆地移　栴达啰婆咩　栴达啰佉只　栴达啰因达[口*梨]　栴达啰恶差　栴达啰梨鞞　栴达啰簸利鞞　栴达啰跋簁　栴达啰悉帝　栴达啰簸剃　栴达啰頞泥　栴达啰只[口*梨]　栴达啰博差　栴达啰悉泥[口*兮]　栴达啰卢咩　栴达啰鸠闭　栴达啰娑闭　栴达啰受婆隶　栴达啰宾滞　栴达啰恶差　栴达啰薮帝　栴达啰伽泥　栴达啰什鞞　栴达啰悉钵尸　栴达啰磨泥　栴达啰跋帝　迷底唎耶跋帝　迦喽拏跋帝　萨底耶跋帝多剃耶跋帝　差耶跋帝　扇多跋帝　底啰跋帝　栴达啰卢寄　薮婆呵

世尊。如此神咒。过去诸佛牟尼仙圣建立守护。如此神咒名月幢月。能令众生悉得吉祥归信三宝。灭除一切诸恶重罪。乃至逮得无上涅槃。月藏菩萨说是咒时。三千大千世界六种震动。依欲界色界一切众生。皆大战悚惊怖不安。于时诸天雨种种宝种种花种种香种种末香种种衣服种种卧具种种璎珞。雨如是等种种物时。如是诸物互相振触。出于种种妙法音声。谓三宝声三律仪声三解脱声三明声三学声。离三界欲声三种菩提声。无常声苦声无我声空声。不悕望声离喜声无生声。如体性声实际声。法界声如如声不去不来声。无处不建立不退转不行无窟宅无所依发精进声。檀波罗蜜声乃至般若波罗蜜声。慈悲喜舍四念处乃至八圣道分声。奢摩他毗婆舍那声。四摄声四无碍声摄受正法声因缘法声护正法声。如幻如梦如影如响如水中月。随诸众生应得度者而摄受之。厌离流转出向空闲阿兰若处。为他说者已自行之不相违背。悉皆如法坚固安住而求一切善根声。十地声无生忍声。十八不共法声一切种智声。转法轮声。生死流转令住八圣道不随流转声。降伏四魔令入无余涅槃声。闻是声已。此三千大千世界众生及地狱众生等。于彼一切诸众生类。一一众生皆以前身亲善知识因缘力故。随其差别所种善根。若檀若尸若修禅定。若于声闻及缘觉乘发心起愿。若于无上大菩提果发弘誓愿。于彼众生随本所习。如前诸声悉入其耳。随其善根曾所修行造作业缘。皆能忆念此宿命事。爱重敬信佛法僧宝。速来归依。彼众生中自有业障悉得除尽。于彼命终。一时生天。及生人间。俱至佛所而坐听法。如是畜生饿鬼亦悉来集。皆是先业。亲善知识因缘力故。种善根故若檀若尸。乃至业障而得尽灭。其中亦有即身来至佛所听法。亦有于彼命终生于天人来诣佛所听受正法。如是人天悉来佛所。惟除魔王及诸眷属。四阿修罗王并其眷属。于时三千大千世界地平如掌。当于尔时。须弥山铁围山大铁围山黑山。是等诸山。大海树林皆悉不现。惟除佉罗帝山。其山广博如十四天下。于中人与非人间无空处。上方亦如十四天下。无量不可计无有边际。于虚空中大众充满。为见佛故。礼拜供养故。成熟众生。见大众集为听法故。而来集会。此三千大千世界。随其所有宫殿舍宅林树药草。茎叶华果众杂宝物。如是一切。皆悉变成半月而现于彼。一一半月之中。出是色光如千日月和合光明遍照三千大千佛土。如是色相广大庄严。是时十方无边佛土。一切皆现。于彼佛土。菩萨摩诃萨。释天王。梵天王。及余天王。龙王。夜叉王。紧那罗王。一切神王。承佛威神。得见此佛及大众集。复见如是妙色光明。见已皆悉发意欲来。承佛神力。于一念顷即至佛所。礼拜供养至心听法

尔时月藏菩萨摩诃萨。以天宝末天花天香天鬘天衣。散于佛上。三遍散已右绕三匝。住立佛前合掌白言。大德婆伽婆。我有罪过。不及于此大众集会。十方所有菩萨摩诃萨。于此悉集。我有因缘后来至此。大德婆伽婆。我在本国月胜世界。与诸眷属七日之中入阿颇那迦定。从定起已。即问日月光如来。大德婆伽婆。徒众眷属今何所去。日月光佛。即答我言。善男子。东方去此过百千亿佛世界已。次有世界。名曰娑婆。彼土有佛。号释迦牟尼如来应供正遍知。住世说法未入涅槃。今于彼处大众集会。十方诸佛国土所有菩萨摩诃萨。一切皆集于彼世界。为见释迦牟尼佛礼拜供养听大集经故。我眷属亦复往彼。汝今亦可诣彼佛所礼拜供养说月幢月咒。以是因缘我来在后。是时月藏菩萨。而说偈言

  惟佛独是众生父　　于烦恼火而救拔
  我今谢过最胜佛　　以我因缘后来故
  惟佛人天作大明　　普照十方诸国土
  我今谢过佛法王　　以我因缘后来故
  惟佛能示涅槃道　　趣恶道者追令回
  谢过牟尼大商主　　以我因缘后来故
  惟佛世间大医师　　于失目者与法眼
  谢过最胜大医王　　以我因缘后来故
  惟佛能示诸船筏　　令众生度四疾河
  谢过人中最胜者　　以我因缘后来故
  惟佛慈云降法雨　　洗众生意烦恼垢
  谢过大圣胜法尊　　以我因缘后来故
  唯佛一人于四流　　能度众生三有海
  谢过世尊实语者　　以我因缘后来故
  惟佛开诸正法藏　　以七圣财济众生
  谢过大胜法施主　　以我因缘后来故
  惟佛能与众生眼　　于无明闇拔盲瞽
  我本端坐一三昧　　阿颇那禅心安住
  我不见佛现神变　　以我因缘后来故

佛言。善哉善哉。善男子。汝大精进能于七日入深禅定。如是妙定。是丈夫住处。是如来住处无上住处。善男子。汝及眷属七日安住阿颇那迦禅。以是义故今悉成就。无量亿那由他百千诸天龙王。夜叉阿修罗紧那罗人非人等。于阿耨多罗三藐三菩提。除其业障。众生障。法障禅障。烦恼障。觉分障。悉灭无余。彼诸众生。有得不忘菩提心三昧者。于无上道不退转者。复有众生。于一切佛法得大明忍。彼等众生以此善根。不久于阿耨多罗三藐三菩提而成正觉。如是善男子。汝以七日入禅定故。一时能灭众生大苦。令得成就大福德聚。善男子。若有众生。惟依读诵欲求阿耨多罗三藐三菩提者。是人多喜着于世俗。以世俗故尚不得调己心烦恼。何能调伏他人烦恼。善男子善女人。乐着读诵求菩提者。便有嫉妒求名利。富贵高心自是轻慢毁他。以自高故。尚不能得欲界善根。何况能得色无色界一切善根。又不能得声闻菩提。何况能得辟支佛道及无上菩提。何以故。第一义谛阿耨多罗三藐三菩提。不与声闻辟支佛共。是故非以世俗能得阿耨多罗三藐三菩提最胜善根大福德聚。善男子。譬如星火不能枯竭甚深大海。如是如是。善男子。不以世俗能竭自身烦恼大海。何能竭他众生烦恼。善男子。譬如一人口所吹风。不能损坏世界大地。如是善男子。不以世俗能得成就大慈大悲。善男子。譬如藕丝不能秤动须弥山王。如是善男子。不以世俗能自满于阿耨多罗三藐三菩提智。何能令他得第一义。如是善男子。能成就阿耨多罗三藐三菩提智者。非世俗也。何者是第一义。所谓修造一切福事。若修福者。亦当数数熏修身心。若修身者。则能修心。能修心者。则能修慧。若能修身心修慧。如是之人则能速满六波罗蜜。能以四事摄诸众生。成熟于阿耨多罗三藐三菩提。成等正觉。不以世俗也。于世俗中。复有众生计断常二见者非第一义。复有众生。于世俗中。我见边见亦非第一义。复有众生。于其世俗。求现世乐及后世乐。亦非第一义。而我不见更有一法。能尽业障乃至烦恼障。一日一夜令无量亿那由他百千众生。悉得敬信佛法僧宝。成熟安住无上大乘。若有禅士。虽复持戒。不能具足。禅法不周。未得三昧。是人于禅。若坐若行。初夜后夜。得与禅定相应而住。则能除断无量业障。能令多亿那由他百千众生。悉得归信。成熟菩提种种善根福德之聚。况具持戒。得真法三昧诸陀罗尼忍。得四梵住宴坐寂定。于七日中。所得福德。不可思议不可为喻。何况能除众生障烦恼障等。尽灭无余。乃至成熟无量众生。向阿耨多罗三藐三菩提。亦能积集无量福聚。又能满足六波罗蜜。何以故。是修禅者。若行若坐除诸障法令心清净。于一切行。舍攀缘想。是檀波罗蜜。于舍攀缘想。常不休息。是尸波罗蜜。于诸境界不生疮疣。是羼提波罗蜜。不舍于离。是毗梨耶波罗蜜。于诸事中心不放纵。是禅波罗蜜。诸法体性无生乐忍。是般若波罗蜜。复次若于境界不起扰浊。是檀波罗蜜。若于境界无有疮疣。是尸波罗蜜。若于境界不能染污。是羼提波罗蜜。若于境界无有动转。是毗梨耶波罗蜜。若于境界无有计念。是禅波罗蜜若于境界一向清净行。是般若波罗蜜。复次于诸阴舍。是檀波罗蜜。于诸阴不计念。是尸波罗蜜。于诸阴求无我想。是羼提波罗蜜。于诸阴起怨家想。是毗梨耶波罗蜜。于诸阴不令炽然。是禅波罗蜜。于诸阴毕竟弃舍。是般若波罗蜜。复次于诸界舍。是檀波罗蜜。于诸界不扰浊。是尸波罗蜜。于诸界舍因缘。是羼提波罗蜜。于诸界数数弃舍。是毗梨耶波罗蜜。于诸界不起发。是禅波罗蜜。于诸界如幻想。是般若波罗蜜。复次菩萨于诸众生。起于慈心。是檀波罗蜜。于诸众生心无憎爱。是尸波罗蜜。于诸众生。起于悲想。是羼提波罗蜜。于诸众生起救济想。是毗梨耶波罗蜜。于诸众生。以喜摄想。是禅波罗蜜。于诸众生。不作彼此吾我等想。是般若波罗蜜。复次菩萨。于诸众生。以法施之。不生二想。是檀波罗蜜。于诸众生柔和爱语。是尸波罗蜜。于诸众生。不起诸恶。是羼提波罗蜜。于诸众生爱语不退。是毗梨耶波罗蜜。于诸众生。利益怜愍。是禅波罗蜜。于诸众生。同行其法。是般若波罗蜜。复次菩萨。安置众生于诸善处。是檀波罗蜜。于一切法。而不依倚。是尸波罗蜜。于一切法。以一道入。是羼提波罗蜜。于一切法及一切难。无扰浊想。是毗梨耶波罗蜜。于一切法。而不分别。是禅波罗蜜。能以一字。入一切法。为众生说。是般若波罗蜜

善男子。如是菩萨摩诃萨。以此第一义甚深法要。能满六波罗蜜。非世俗也。如是如是。善男子。诸菩萨摩诃萨等。第一义谛善巧方便。皆以此法自为为他。勤修令满六波罗蜜。速于阿耨多罗三藐三菩提而成正觉。如是十方现在诸余世界。所有菩萨摩诃萨等。第一义谛善巧方便。一切皆悉以此道法。速于阿耨多罗三藐三菩提。而成正觉。当来十方无量阿僧祇诸佛世界。诸菩萨摩诃萨等。皆悉勤修如是甚深第一义谛善巧方便。修六波罗蜜。能于阿耨多罗三藐三菩提而成正觉。非世俗也。彼诸菩萨摩诃萨。为法眼久住绍三宝种使不断绝。勤求修学。为一切众生。执大明炬而作照明。令其止息烦恼道苦道。与其慧眼。令度一切三有流转。安置无上菩提之道。彼等于圣法默然。初夜后夜舍得相应。善能出生三昧正受。与三解脱门相应而住。善男子。汝今七日于阿颇那迦禅而入定故。成熟无量诸众生故。是故劝汝及诸善男女等。若现在世未来世末世。于我法中初夜后夜常与于舍相应而住。以正法眼而作照明。绍隆三宝使不断故。为成熟众生故。勤修如是第一义谛。为满六波罗蜜勤修而住。佛告一切诸天人众龙神夜叉。应当养育供给是人。衣服饮食卧具汤药随其所须尽给与之。亦当守护除其灾横。离诸凶衰殃恶疾病悉令除灭。何以故。与禅相应者是我真子。从佛口生从法化生。若有施主天龙夜叉。能于现世及未来世与舍相应。以第一义谛为满六波罗蜜故。为除众生诸烦恼道及苦道故。法眼久住绍三宝种使不断故。汝等施主天龙夜叉皆应护养。并与衣服饮食卧具病瘦汤药。随其所须尽给与之。亦应劝请及以赞叹。以彼施主天龙夜叉持我正法。为欲令我法眼久住。绍三宝种使不断故。如是等辈是我真子。从佛口生从法化生故。比丘比丘尼。优婆塞优婆夷。及余清信士。若善男子善女人。以第一义乃至求于阿耨多罗三藐三菩提者。及养护者。我以彼等寄付于汝。弥勒为首及以贤劫诸菩萨等。当以四事摄受劝化。授其禁戒。复令住于四无量心。四禅四无色定。大方便力。大慈大悲。乃至十八不共法。当复授与无上道记

尔时。弥勒菩萨摩诃萨以为上首。及与贤劫诸菩萨等白佛言。世尊。如是如是。大德婆伽婆。我当护念彼诸众生。乃至与其授于阿耨多罗三藐三菩提记。若现在世。及未来世。乃至法住。是诸施主。作大明者。亦当与授无上道记。天龙夜叉揵闼婆等。于阿兰若处静默修行。求第一义者。信乐受持供养供给。衣服卧具乃至汤药。随所须者。尔时世尊欲重明此义。而说偈言

  于此世间一日出　　无量亿华悉开敷
  如佛一人出世间　　众生所怖福华现
  若欲速得十胜力　　及度坚固诳烦恼
  复欲速得最胜定　　静默独住阿兰若
  欲得人天信敬受　　及除心之烦恼渴
  欲断于心苦重担　　安心圣道奢摩他
  若欲排却诸恶难　　及诸功德自庄严
  于诸苦海欲自度　　应当安心妙菩提
  若欲得彼七法财　　及欲得于方便忍
  欲为众生说妙法　　常当乐住阿兰若
  六根常与三昧合　　应当寂住阿兰若
  少欲头陀善知足　　此人能人贤圣道
  若能速舍五欲乐　　得五力故灭烦恼
  若于五道度众生　　自舍过恶住三昧
  若欲得于四无量　　及得无碍四辩才
  欲得四禅彼岸处　　是人应修第一义
  若欲速知于三有　　欲知诸法苦无常
  及知诸行性相空　　应当乐住阿兰若
  若欲速知二种法　　毗婆舍那奢摩他
  及欲速知有为过　　要当住于菩提心
  独住闲静不放逸　　便能疾舍于世谛
  以精进求第一义　　能速舍离诸恶道
  若欲枯竭脓血海　　及欲枯竭烦恼海
  若欲速竭三有海　　常与圣种心相应
  若欲成熟众生海　　若欲满诸大愿海
  若欲得知生死际　　如救头燃处闲静
  欲知本生及居处　　久远微细所从来
  以诸方便乐闲静　　摄心于彼得三昧
  若欲游戏禅定海　　若欲觉悟神通海
  若欲度于渴爱海　　若欲得于天中最
  若欲得饮正法海　　若欲见于庄严土
  若欲见于诸佛海　　欲问甚深诸义海
  欲得如是胜功德　　及欲速得胜菩提
  当离众恼住兰若　　以此得道亦不难
  若人百亿诸佛所　　于多岁数常供养
  若能七日在兰若　　摄根得定福多彼
  若人读诵千亿法　　及解妙义如佛说
  若于七日住兰若　　三昧福聚转多彼
  若人多岁营僧事　　更不造作余种业
  若人七日住兰若　　其人福聚多于彼
  为众说法解深义　　于多年岁无余业
  若能七日心住寂　　其福德聚不可数
  若人营造多佛塔　　伽蓝田业给施僧
  若能七日在兰若　　其福转多胜于彼
  闲静无为佛境界　　于彼能得净菩提
  若人谤彼住禅者　　是名毁谤诸如来
  若人破塔多百千　　及以焚烧百千寺
  若有毁谤住禅者　　其罪甚多过于彼
  若有供养住禅者　　饮食衣服及汤药
  是人消灭无量罪　　亦不堕于三恶道
  是故我今普告汝　　欲成佛道常在禅
  若不能住阿兰若　　应当供养于彼人
  若能住禅不放逸　　则能速满于六度
  欲求大明菩提道　　以此方便疾能到
  欲求菩提住寂静　　当舍一切诸缘业
  及离烦恼舍诸乐　　则能速到檀彼岸
  若舍境界阴界入　　及舍贪嗔愚痴过
  弃诸烦恼修善业　　以此能到檀彼岸
  当以慈悲念众生　　息诸分别不自是
  常能怜愍诸众生　　即满尸罗波罗蜜
  勤舍罪业修诸禅　　亦当舍诸阴界入
  爱诸方便常求禅　　除障到于精进岸
  境界不动不味着　　为舍因缘修悲喜
  一道清净不移动　　以此得满忍辱度
  于境界中不念虑　　离疾不乐得于喜
  诸法离掉无分别　　不染不愁是为舍
  阴界如幻无起作　　相续修行不断绝
  善修了知如是法　　以此得满般若度
  故我今告一切众　　若有欲除诸罪业
  求忍三昧陀罗尼　　当知如是住寂静
  若欲超越声闻乘　　及欲超越缘觉乘
  又欲疾得胜佛地　　应当速住阿兰若
  若心摄住阿兰若　　以此即是供诸佛
  于是能舍一切罪　　是则能满于六度
  当得作佛三有最　　能转清净正法轮
  枯竭众生诸恶趣　　度脱众生三有海
  当舍恶见诸缘事　　常发最胜菩提心
  应当速向兰若处　　于彼当成如是德

尔时世尊。说此经时。诸会大众闻是甚深第一义禅。有于过去善修集者九万二千人。得无生法忍。七十亿那由他百千众生。得种种三昧诸陀罗尼及无生忍。八万一千人得授阿耨多罗三藐三菩提记。如恒河沙等众生未发无上菩提心者。悉皆发心。于阿耨多罗三藐三菩提。得不退转

大集经卷第四十六大方等大集经卷第四十七

        高齐天竺三藏那连提耶舍译

    月藏分第十四魔王波旬诣佛所品第二

尔时复于魔王宫中。所有一切诸杂林树果实华叶。衣冠璎珞庄严之物。皆悉变成半月而现。放大光明照魔王宫。内外明彻。琴瑟箜篌一切乐器。及非乐器宝庄严具。及余诸物。自然演出如是偈句

  世间无等大导师　　于诸法中最自在
  今住佉罗帝迦山　　为众显示佛法海
  开说一道清净法　　闻者必得胜菩提
  波旬犷戾儞不如　　令汝魔界悉空无
  汝本曾作一邪善　　今得如是自在报
  汝今法应当退落　　何不速去见导师
  一切所来诸众生　　曾作邪善千亿数
  福藏大众皆来集　　听受最上无病法
  各各向佛心敬仰　　见尊导师修供养
  以其净信灭烦恼　　更不重生于欲界
  专信礼拜尊导师　　灭三界苦烦恼缚
  亿世受于胜妙报　　速与三界为亲友
  又于三界作法王　　说真实法度众生
  一切诸法如水泡　　有为相现犹如幻
  福报无常悉空无　　当疾舍离我见过
  速发无上菩提心　　以此定受胜妙福

尔时魔王波旬。及诸官属。见闻是已。惊怖战悚从床而堕。两手掩耳而作是言。当观沙门作此幻惑。必夺我等诸魔势力。令诸色像悉成半月。复出如是种种音声。沙门瞿昙现大神力。尽摄欲界以为己有。可速击鼓集诸大众皆到此处。作是语已。于其宫中即便击鼓。击彼鼓时。于其鼓中。即出如是音声偈句

  诸法空寂风和合　　远离所依众色像
  于作无用诳众生　　事相诈现犹如幻
  和合因缘故成字　　如书虚空字不住
  阴界空寂离众色　　无常义现不自实
  声尘入于耳根门　　无常义现不暂停
  其识如幻若分别　　显现无我不自在
  眼根迅速故空寂　　是苦自性义相应
  鼻根香尘与舌味　　身根及与一切触
  心法并与无常俱　　迷惑众生无所觉
  如是六境生诸苦　　能令失坏涅槃道
  以是凡夫转五趣　　不能离缚得解脱
  于诸境界除渴爱　　则能速到胜妙处
  此心自性清净相　　观是了知菩提道
  若己境界得自在　　则能悲愍一切众
  于彼当得檀戒忍　　智慧功德自庄严
  得最无上菩提智　　能度无量诸众生

说此偈时。魔之宫殿。一切众生惊怖不安。男夫妇女。童男童女。迭共相唤。诣魔王所。住立其前。魔王以偈告彼众言

  汝等悉见此魔宫　　如是无量极丑恶
  诸声不息生大苦　　定夺我等魔势力
  沙门瞿昙作是声　　欲灭魔力境界事
  可速往诣瞿昙所　　咸共赞叹而归依

尔时魔子名鸯瞿罗歇。即以偈颂。而白父言

  我今严驾着铠甲　　将诸勇健斗战士
  弓刀鉾槊及刀轮　　刀面鼓面诸兽面
  魔军夜叉龙修罗　　及诸眷属满虚空
  速诣恶心瞿昙所　　碎灭令彼如灰尘

尔时魔王。说偈答言

  我从昔来于彼人　　曾作无量恶留难
  汝亦应见菩提树　　瞿昙胜我及军众
  如是我等数恼乱　　瞿昙常胜于我等
  不见天龙阿修罗　　能动彼人一毛端

尔时复有魔之大臣。名珊卢遮那。而说偈言

  我等可速舍欲界　　但当自护己宫殿
  瞿昙昔来未至此　　今来拒之莫听前

尔时魔王。甚大忧愁默然不答

复有大臣名起怖畏。而说偈言

  惟有巧力可伏怨　　当以谄伪诈为亲
  我等将众往诣彼　　诡诈而叹彼沙门

复有大臣。名毗阐陀行。而说偈言

  昔此宫殿众盈满　　沙门侵夺今减少
  已归彼者众甚多　　我等亦可往归依

尔时魔王。闻其所说即嗔彼臣。嗔已默然

复有大臣名曰老智。而说偈言

  瞿昙力加诸宫殿　　出此种种异音声
  我等若不疾诣彼　　沙门必速来到此
  此处无人能遮护　　以力止彼瞿昙仙
  我等宁可共一切　　速诣归彼大沙门

尔时于彼诸宫殿中。所居大众男夫妇女眷属大小。悉作一朋复作是言。大王。今可将诸眷属速诣彼所。我等今当守护此诸城邑宫殿。尔时魔王。即作是言。如是如是。我与他化自在天王及诸军众眷属大小往诣彼所。并与化天兜率陀天须夜摩天释提桓因及其军众共诣彼所。复与毗沙门天王并诸军众。毗楼勒叉天王并鸠槃茶军众。提头赖吒天王并乾闼婆紧那罗军众。毗楼博叉天王及诸龙众。往诣彼所。作是语时。复有魔王辅佐大臣。名珊遮罗拏。白言大王。今者所有诸天宫殿皆悉空寂欲界诸天及诸天女一切眷属。悉在瞿昙大沙门所听法而住。如是紧那罗龙鬼夜叉伽楼罗鸠槃茶。悉在彼处种种供养沙门瞿昙听受其法

尔时魔王自观察已。见诸欲界一切宫殿皆悉空寂。欲界之中所有诸天人非人等。皆悉集在于瞿昙所而坐听法。惟有阿修罗未到于彼。而作是言。我今当与诸阿修罗俱诣彼所。令其会众皆悉惑乱不得正信。勿使瞿昙教彼大众诸法如幻。不去不来不合不散不生不灭。令我欲界皆悉空寂。复作是言。我今当共诸阿修罗并及军众疾诣彼所。遮诸众生不令速得越度苦海到于彼岸。以沙门力速背死法。令我境界势力减少。我今速往遮护彼诸人非人等。时魔波旬。即以魔之神通境界。念四阿修罗王及其军众一切眷属。速来集在须弥山顶。然后相将共下诣彼瞿昙沙门所。诈设美言谦下赞叹。示作归依求见因缘。当以方便令诸大众悉生怖畏断其正信。又不令彼于瞿昙所生其尊敬。以是令彼沙门瞿昙厌患于世速入涅槃。如是魔王。数数悕望阿修罗众。然诸阿修罗。为佛神力之所加故。茫然不知魔之悕望。其魔即时恶意于佛及一切阿修罗。便作是言。观瞿昙一人于我境界。已得解脱不可追回。我于欲界悉得自在。此凡贱畜生阿修罗不受我教。我当为其作大衰恼。令彼速舍所治宫殿。然后我当以神通力。将诸眷属往见瞿昙。又复与诸大臣勇将左右诸军男夫妇女营从围绕。以第一最胜五音作乐调戏歌舞。一切衣服庄严之具。众宝香华幢幡宝盖音声和合令速严办。往见瞿昙。我今亦将夫人婇女及以男女大众围绕。以第一最胜魔之境界神通游戏五音和合。往见瞿昙。何以故。唯除瞿昙。诸余大众天龙乾闼婆人及阿修罗等。世间大众悉令迷惑。当以坚牢欲网而罗网之。于生死大海不令速度。是故诣彼。余者留住守此宫殿。时魔波旬。即将九百六十万频婆罗眷属男夫妇女童男童女大臣左右。以魔境界神通加持。作第一最胜五音伎乐歌舞调戏。一切所有令人多喜生染著者悉具备之。时魔波旬。住彼诸宫告言。悉出往诣彼所。而复合掌。说偈颂曰

  唯佛尽除诸烦恼　　唯佛能化诸世间
  唯佛能然正法灯　　三界中最我归依

尔时魔王。既作如是魔之神通境界力已。从彼宫出以手散华。所散之华于四天下悉作华盖在空而住。于一切处悉雨种种宝种种华如云而下。当于尔时。世尊。仍说住阿兰若第一义谛。佛告大众。汝等一切守摄诸根击心专念莫令驰散。此魔波旬。多将诸众歌舞调戏。五音作乐众伎和合。又与妇女眷属大小围绕而来

尔时魔王与诸眷属。寻即来到佉罗帝山牟尼诸仙所依住处。到佛所已。即于佛上虚空之中化七宝盖。纵广七由旬而覆佛顶。复以无价真珠璎珞严置佛上。复以种种众宝华香涂香末香天鬘幢幡宝盖金缕真珠璎珞及五音伎乐。供养世尊。右绕三匝。而说偈言

  我今归命佛世尊　　从是终不起恶心
  瞿昙心定容恕我　　我当守护佛正法
  于世更无如世尊　　怜愍利益众生者
  自得解脱令他得　　是故我归最胜尊
  唯佛慈愍一切众　　已越生死烦恼山
  常慈乐度诸众生　　今速归依汝世尊
  能了有为及无为　　离二如莲不着水
  积德梵行所依身　　是故我今归依佛
  世无寂定无病法　　清净常胜伏烦恼
  唯有正法及涅槃　　是故归依无等法
  于世更无如僧众　　和合解脱八丈夫
  能离一切烦恼缚　　是故归依大德僧
  闲居静默常一食　　第一义心恒相应
  慈悲愍念诸众生　　我亦归依于彼等
  于三宝种作炽然　　护养所有佛声闻
  我劝一切诸众生　　名衣上馔而供养

尔时会中诸来大众。若天若人乾闼婆等同声赞言。善哉善哉。尔时世尊。告慧命憍陈如。而说偈言

  我已告汝声闻众　　所有相应求解脱
  常乐所依四圣种　　以彼得满菩提道
  如树果繁速自害　　竹芦结实亦如是
  如骡怀妊自丧身　　无智求利亦复然
  亦如盛夏恶雹雨　　伤害一切诸苗稼
  如是贪求利养者　　必当速失胜菩提
  又如诸树华开敷　　而复为火所焚烧
  如是贪求利养者　　亦当退失菩提道
  若有比丘得供养　　乐求利养坚著者
  于世更无如此恶　　故令不得解脱道
  如是贪求利养者　　既得道已还复失

尔时魔王。闻说偈已。即自念言。沙门瞿昙。知我虚伪诈现归依。羞愧默然。退坐一面听法而住。魔诸妇女。诸根形貌容状光色。皆悉枯悴变成恶色。背偻跛躄丑陋弊恶。所有男夫都不复能歌舞调戏。五音作乐皆悉闭塞不能出声。却坐一面。听法而住

    大方等大集经月藏分诸阿修罗诣佛所品第三

尔时月藏菩萨摩诃萨。为欲摄化诸众生故。说月幢月咒句之时。于彼四大阿修罗王所治之处。一切所有草木华果众宝璎珞庄严之事衣服卧具皆悉变成半月而现。彼等诸事迭相掁触出五音声。所有鼓贝箜篌筝笛具足作乐。彼等音中。亦复演出如是偈句

  唯佛化导以安隐　　并众住在佉罗山
  于臭烦恼拔众生　　为其说法永断除
  凡夫悉堕生死海　　烦恼驶河起波浪
  三有更无哀愍者　　如牟尼尊慈善心
  多众聚集一方所　　天人鸠槃龙夜叉
  悉依佉罗帝山所　　于诸苦畏求解脱
  我等俱时速诣彼　　为欲听闻正法故
  魔王不久或来此　　而为我等作留难
  一心听受胜妙法　　于彼净心得大福
  以福长寿除诸怨　　于世常受威德乐
  若以此福求解脱　　断诸烦恼得罗汉
  及断诸缘作辟支　　亦能成佛具诸乐
  如是当得无有疑　　是故速舍诸缘缚
  一切当起清净心　　速到佛所修供养
  从此贤劫初以来　　未有如是大众集
  于后久远弥勒兴　　我等不得许时寿

尔时于彼四阿修罗城邑宫殿。有如是事。以菩萨力庄严加持故。闻是句义皆生信心。各各于其城邑宫殿云集一处。共相谓言。今当于此欲有何事。所以者何。我等昔来未曾见者今得见之。昔未闻者今得闻之。无人知者。时魔波旬。从己宫下欲礼佛故而往散华。所散之华于四天下皆作华雨。当雨之时。于四阿修罗城邑宫殿。遍一切处皆悉变作最极臭秽。及恶烟尘灰土[土*蓬][土*孛]处处盈满。蚊虻蛇蝎诸恶毒蝇亦复悉满。忧愁恼乱不可爱乐。当于尔时。诸阿修罗城邑宫殿皆悉黑闇。一切阿修罗男夫妇女童男童女。悉怀最极忧愁恼乱不乐住彼。各于巷陌迭相云集。至己王所在前住立。阿修罗王。见诸衰害极增忧恼。毗摩质多罗阿修罗王。与诸眷属及所治处一切阿修罗男夫妇女童男童女。波罗陀阿修罗王。跋持毗卢遮那阿修罗王。与诸眷属及所治处男夫妇女童男童女。向罗睺罗阿修罗王所治城邑聚落宫殿。见彼如是诸恶恼乱蚊虻蛇蝎毒蝇等已。三阿修罗王俱至罗睺罗阿修罗王所。于前住立。毗摩质多阿修罗王。请问罗睺罗阿修罗王。而说偈言

  一切修罗诸宫殿　　犹如地狱等无异
  热风暴起来至此　　一切状似火烧焚
  所有树林诸果实　　悉皆堕落在于地
  诸有莲华及浴池　　草苗众华悉枯竭
  烟尘[土*蓬][土*孛]于我等　　阿修罗城诸宫殿
  及有蚊虻蚤恶蝇　　无量诸恶毒虫等
  今闻如是众恶声　　众生多恼不喜乐
  诸阿修罗受此苦　　悉为饥渴所逼恼
  苦逼无所可归依　　一切惊怖心焦枯
  生死畏等谁威力　　而不利益我天龙
  以何方便令休息　　如是种种怖畏事
  非是恶龙来至此　　降伏我等阿修罗

尔时罗睺罗阿修罗王。说偈答言

  阿修罗辈汝谛听　　我等昔日具安乐
  五欲所须皆称意　　神通勇健有大力
  所持弓刀及箭槊　　罥索矛[矛*贊]剑轮等
  一切今当悉退落　　城邑巷陌尽茫然
  男夫妇女先凶健　　颜色端正有势力
  悉与诸天共齐等　　于今时中定当尽
  命尽众生白法尽　　羞耻惭愧解心尽
  及聪明人所知尽　　巧行与善圣智尽
  苗稼及诸华药尽　　果味等尽诸戒尽
  所欲称意音乐尽　　众宝衣服饮食尽
  喜乐事尽人天尽　　夜叉乾闼修罗尽
  婆罗门种刹利尽　　并诸毗舍首陀尽
  惟共诸恶众生等　　非圣谄曲杀盗淫
  妄语两舌绮恶口　　贪恚胆佞痴邪见
  俭短增长及饥渴　　爱离怨会与捕猎
  见他得利生嫉忌　　割截斩斫诸破坏
  毒害刀槊剑轮增　　面目流泪忧悲苦
  蚊虻恶风及烟尘　　斯等并来为触恼
  地狱畜生与饿鬼　　是等境界大苦海
  此非善行相应时　　念念退失于正见
  白业之人恶事增　　如是众恶皆兴盛
  是阿修罗尽时至　　唯无等乘能遮止

尔时波罗陀阿修罗王。白罗睺罗阿修罗王说偈问言

  唯王为诸众生故　　常勤精进修诸法
  具大福德神通力　　及以智慧庄严身
  此是何力谁所作　　欲灭我等阿修罗
  谁能救护于我等　　当礼敬彼而归依

尔时罗睺罗阿修罗王。说偈答言

  此非释梵天王力　　亦非自在那罗延
  又非夜叉及龙神　　惟除魔王欲自在
  昔恼诸龙亦如是　　大仙瞿昙为断除
  我等礼彼瞿昙仙　　能施我等安乐故

尔时跋持毗卢遮那阿修罗王。以偈问言

  为是天人龙夜叉　　能施一切安乐者
  彼何神通精进力　　为当方便造幻惑
  于何法中得自在　　何谁能受彼教敕
  为于魔力得解脱　　而得何力使其然

尔时罗睺罗阿修罗王。以偈答言

  昔见端正大沙门　　端坐菩提树阴影
  魔将军众而诣彼　　以慈悲力速降伏
  于彼得成胜菩提　　超过一切诸天众
  具大慈悲入涅槃　　故能枯竭众苦海
  此诸仙中最胜幢　　具足十力众生药
  释梵自在修罗仙　　欲自在魔那罗延
  悉礼于彼作归处　　是人能示众解脱
  于诸一切三界中　　超胜所有诸天众
  调伏寂静降诸根　　乐寂七圣财庄严
  安住涅槃到彼岸　　悉能枯竭烦恼海
  是故我等一切众　　悉归能灭诸苦者
  皆持种种妙香花　　各各合掌而求请

尔时罗睺罗。毗摩质多罗。波罗陀。跋持毗卢遮那。四阿修罗王。及男夫妇女童男童女。所有一切阿修罗众皆悉云集。有以烧香供养礼佛而求请者。有持种种杂色妙华。有持种种摩尼宝珠。有持种种幢幡宝盖金缕真珠璎珞衣服。以用奉佛而求请者。有持种种筝瑟箜篌箫笛鼓吹五音作乐。供养礼拜求请佛者。罗睺罗阿修罗王。以己神通境界之力。大身游戏两手执持帝释毗楞伽摩尼宝鬘。头面礼拜遥奉世尊。说偈赞曰

  佛为众生乐　　久修诸苦行
  怜愍一切众　　愿亦愍我等
  忍辱如大地　　悲愍诸众生
  休息诸浊恶　　愍覆于我等
  佛度诸畏讫　　得于无上智
  等心于众生　　愿愍阿修罗
  佛以八圣船　　度脱苦众生
  涅槃味充饱　　慈念阿修罗
  佛于诸众生　　不耻恶种姓
  一切如赤子　　是故归依佛

尔时毗摩质多罗阿修罗王。以两手捧持一切诸天登祚所著摩尼宝鬘。头面作礼以偈赞曰

  胜过天龙众　　修罗鸠槃茶
  尽除诸烦恼　　心意所作恶
  降伏业苦道　　而到于彼岸
  远离于有想　　及无想众生
  悲念众生故　　不入于涅槃
  为诸众生故　　能忍一切苦
  视于诸众生　　如母念一子
  愿愍于此等　　苦处洒悲水
  休息苦恼触　　烦恼水所溺
  起发坚勇者　　愿救众生苦
  念今苦苦至　　为魔力所坏
  苦触阿修罗　　愿洒大悲水
  众生若于佛　　起于嗔恶心
  而不能动佛　　身心少分者
  若彼所有乐　　境界身心事
  佛常等慈悲　　于此更无异
  惟佛于天人　　能施一切乐
  我等为魔恼　　心孤无所依
  无有余众生　　能灭于魔业
  惟佛速除遣　　尽坏无有余
  诸天龙证知　　夜叉阿修罗
  如佛众生最　　能救一切苦
  魔欲速灭我　　修罗诸宫殿
  愿速放戒光　　施我满足乐

尔时波罗陀阿修罗王。两手捧持梵天光幢摩尼宝珠和合天鬘。头面作礼说偈赞曰

  流转狱所缚　　离诸一切乐
  极恶大巨海　　没溺无所依
  唯佛精勤行　　于三阿僧祇
  自度到彼岸　　悉竭烦恼海
  为诸众生故　　六年行苦行
  而得无上智　　灭除彼烦恼
  我等为魔娆　　无力受诸苦
  愿除魔所加　　洗浴我等宫
  此等僧祇众　　为诸苦所恼
  愿救此诸苦　　当往见世尊

尔时跋持毗卢遮那阿修罗王。两手捧持梵天艳光摩尼宝鬘。头面作礼以偈赞曰

  今礼牟尼尊　　于法自在者
  超过释梵王　　降魔及军众
  超过日月光　　及与四天王
  慈悲明日月　　普照诸众生
  五日并出时　　海水悉枯竭
  若供佛功德　　无能枯竭者
  超度于三界　　而入无畏城
  大悲覆众生　　诸苦悉除灭
  等心诸众生　　如母视一子
  我等忧翳障　　慈风愿吹散
  更无余归依　　可救我等苦
  如佛功德满　　莫舍修罗宫

尔时世尊以佛耳闻。以佛眼见诸阿修罗城邑宫殿。魔力所加。一切诸难皆悉周遍无有遗余俱受热恼。愿乐求我荫覆救护。为归为趣。我当救护诸阿修罗。今正是时。于时世尊以大悲威势现一切乐。即入悲风光明三昧。三昧力故。令四阿修罗宫殿所有魔之神力所加苦事。一念之顷皆悉休息还复如故。亦如三十三天宫殿。于中即现第一妙乐可乐之事。彼诸阿修罗见已。踊跃心生欢喜。口眼皆悦熙怡微笑皆作是言。南无佛陀南无佛陀。作是语已即以诸天胜妙宝鬘。向佛方所遥掷奉献。其罗睺罗阿修罗王所掷宝鬘即到佛所。于佛顶上空中而住。毗摩质多罗阿修罗王所掷宝鬘。亦到佛所于虚空中住右肩上。波罗陀阿修罗王所掷宝鬘。亦到佛所于虚空中住左肩上。跋持毗卢遮那阿修罗王所掷宝宝。亦到佛所住于佛前放光而照。其余所有诸阿修罗。复持种种众宝香华幢幡宝盖。及以金缕宝珠天鬘真珠璎珞种种衣服涂香末香。彼等一切悉向世尊遥掷奉献。而以供养。是时于此佉罗帝山牟尼诸仙所依住处。雨种种华乃至末香如降暴雨

尔时会中有菩萨摩诃萨。名求断疑。从座而起偏袒右肩。合掌礼佛以偈问曰

  大仙世尊无量智　　于先已雨如是雨
  现诸神通变化瑞　　月藏菩萨来到此
  今复雨于种种宝　　谁当复来到于此
  为是大德诸菩萨　　为是他方诸佛使

尔时佛告求断疑菩萨摩诃萨言。善男子。此是魔王波旬。于四阿修罗城邑宫殿。化作阴闇灰尘烟雾蚊虻毒蝇及以种种毒蛇蜂蝎。于彼一切树林草木华果泉池皆悉枯涸。一切阿修罗苦困欲死。彼等向我一心归依合掌作礼。以种种华乃至末香。于彼阿修罗所住城邑。向我遥掷而作供养。罗睺罗阿修罗王所掷宝鬘。今我顶上者是也。毗摩质多罗阿修罗王所掷宝鬘。今我右肩者是也。波罗陀阿修罗王所掷宝鬘。在我左肩者是也。跋持毗卢遮那阿修罗王所掷宝鬘。今在我前者是也。尔时魔王波旬从坐而起。向佛合掌恭敬礼拜而作是言。此诸阿修罗蒙佛恩福。我今亦令诸阿修罗还得具足饶益安乐佛告波旬。汝今不须作如是言。我已令其充足安乐。我诸阿修罗城邑宫殿。转胜微妙乐具悉有还复如故。何以故。彼等四大阿修罗王是我亲旧。如是其余所有一切阿修罗等。于我得信敬仰尊重心生希有。今当不久来至于此为听法故。魔王波旬复生恶心而作是念。我是一切欲界之中最胜自在。于诸众生能作苦乐。沙门是人。何能狡猾幻惑异端妖邪多语。敢共我竞而欲与我挍量比并。释梵四王摩醯首罗那罗延天。转轮圣王。一切众生。无能与我挍量比并作相违者。今此瞿昙。作幻诳惑一切众生。遍四天下地及虚空一切盈满。皆悉欲见瞿昙故来。今此下贱畜生之类诸阿修罗亦复蒙摄。我今当作魔之境界神通势力游戏所加。更作幻惑恼乱于彼沙门瞿昙。及以降伏诸来会众。时魔波旬观其眷属而说偈言

  诸魔各作念　　我常降伏怨
  及恼此会众　　并禁阿修罗

尔时世尊而说偈言

  汝等见我力　　昔于菩提树
  天神为证明　　我修真正法
  随汝所有力　　恣汝当现之
  若能恼我者　　我当作归依

尔时魔王波旬复增第一极重嗔恨。以一切魔力境界神通游戏所加。念于四方最热之风。令其一切诸来大众热风触恼而作降伏。于时世尊即入摧伏魔力三昧。其三昧力。即于四方复起第一妙香凉风。触其身分皆受快乐。魔王波旬知是事已。复于佛前化大火聚。世尊即于彼处化作清凉大池。水涌上出。魔王见已。复于空中降雨大石。佛即变其所雨之石。悉令化作种种天华而雨其处。魔王波旬及与眷属。复以两手捉佉罗帝山。而欲速疾震动三千大千世界。佛复以此三千地界加作金刚。尚不能动乃至一尘。况能多也。魔王复以嗔怒之力。向阿修罗所住之方。放口嘘气成黑气云。令其城邑宫殿阴闇。使诸阿修罗重复迷惑不能去来。尔时世尊即复变其所吹气云。令作种种天妙华云。尔时于彼四阿修罗城邑宫殿。复雨种种天华之雨。其华雨中演出百千微妙法门。所谓佛声法声僧声。檀那波罗蜜声乃至般若波罗蜜声。三善行声。三归依声。三律仪声。三不护声。三依止声。三种菩提声。三乘声。三修声。三种善根声。越度三界声。三受声。三解脱声。三示现声。四念处声。四正勤声。四如意足声。四不坏信声。四禅声。四梵住声。四摄声。四无碍智声。四无色定三摩跋提声。四圣谛声。五根声。五力声。五支三昧声。五解脱入声。显示六根声。六和敬声。六念声。六通声。七圣财声。七识住声。七觉分声。八圣道声。九次第定声。十圣处声。佛十力声。大慈声大悲声。因缘生起声。心不可坏声。舍一切恶见声。不忘菩提心声。不退转声。忍声。三昧声。陀罗尼声。授记登祚声。无生忍声。苦行声。十地声。十八不共佛法声。到菩提声。转法轮声。不可坏佛声。舍声。厌声。解脱定声。灭声。成就众生声。摄受正法声。辩才声。无常声。苦声。无我声。空声。无所作声。寂静声。无生声。如声。实际声。入法界声。无众生无命无养育无受者如如。不生不灭不常不断不去不来不住不行声。大神通变化声。加护三宝种声。乃至大般涅槃声。地狱畜生饿鬼人天苦五阴重担声。数数流转生死与爱别离声。一切有为流转之狱如幻芭蕉水月响声。信念精进忍及智慧十善业道护持声。出彼流转狱声。于彼华雨出是无量百千种声。彼诸音声。能令无量阿僧祇等阿修罗。于三宝中深得敬信。尊重归依生希有心。渴仰欲见释迦牟尼。及欲听法供奉众僧。极甚惊怖。流转生死与爱别离。悕望涅槃。彼诸一切阿修罗等俱发声言。南无释迦牟尼如来。南无释迦牟尼如来我等今往见于释迦牟尼如来。礼拜供养故。听法故。及供奉众僧故。为看大集故。为求无上菩提乘故。为退落魔幢故。为建立法幢故。为三宝种不断绝故。为听第一义圣谛法门故。为休息烦恼道苦道故。为断截魔缚故。为枯竭爱河故。为满法海故。为入智海故。为成熟众生海故。为供养诸佛海故。是故我等及诸眷属往诣佛所。不为恶魔于我等中更得自在。我等从今不复重遭如是之苦

尔时牟真邻陀阿修罗王。复作是言。我今亦与妇妾宫人男女大小。诸阿修罗妇女眷属八万四千。一切皆悉着青衣服青色庄严。青伞青盖青幢青幡青车青华。青色摩尼琴瑟箜篌。青宝青鼓。我今将诸五音作乐歌舞调戏第一庄严。及将眷属而往见佛。恭敬礼拜听受妙法。供奉众僧故往诣佛所

尔时须质多罗阿修罗王复作是言。我今亦与妇妾宫人男女眷属九十九百千阿修罗妇女。一切皆着黄衣庄严。乃至供奉众僧故往诣佛所

尔时睒婆罗阿修罗王复作是言。我今亦与妇妾宫人男女眷属百千亿阿修罗妇女。一切皆悉着绀色衣璎珞庄严。乃至供奉众僧往诣佛所

尔时跋持毗卢遮那阿修罗王复作是言。我今亦与妇妾宫人男女眷属九十九频婆罗阿修罗妇女。一切悉着朱色衣服璎珞庄严。乃至往诣佛所

尔时毗摩质多罗阿修罗王复作是言。我今亦与妇妾宫人男女眷属九十九恶初矣尼百千阿修罗妇女。一切悉着颇梨色衣璎珞庄严。乃至往诣佛所

尔时罗睺罗阿修罗王复作是言。我今亦与夫人婇女男女眷属及土田主附庸王并及长者臣将左右城邑聚落所有人众。如恒河沙等阿修罗妇女。一切悉着马瑙色衣璎珞庄严。复持马瑙色衣。及与幢幡宝盖金缕真珠璎珞摩尼宝珠香华涂香及所乘车。皆悉同是马瑙之色。并以鼓角琴瑟箜篌箫笛伎乐。如是等事皆马瑙色。相与作乐歌舞戏笑。最胜庄严在于虚空。为欲见佛礼拜供养。及为听法供奉众僧故。往诣佛所如前所说。皆悉严备彼诸色相。第一微妙希有未有。昔来未闻如是等大庄严事。从彼阿修罗所居处出住在空中

尔时毗摩质多罗阿修罗王。及与眷属五音作乐歌舞戏笑。诣罗睺罗阿修罗王于前而引

尔时波罗陀阿修罗王。及与眷属皆大严持。到罗睺罗阿修罗王右厢而引

尔时跋持毗卢遮那阿修罗王。并与眷属亦复如是具大庄严。到罗睺罗阿修罗王左厢而引

尔时睒婆罗阿修罗王。及与眷属亦悉严持。诣罗睺罗阿修罗王于后而引

尔时牟真邻陀阿修罗王。及与眷属亦大严驾。到罗睺罗阿修罗王在上而引

尔时须质多罗阿修罗王。及与眷属如是庄严。亦到罗睺罗阿修罗王在下而引

尔时于中罗睺罗阿修罗王及与眷属。如是色相以大庄严。五音伎乐一时俱作。歌舞戏笑音声和合而诣佛所。复以两手持种种宝华天鬘涂香。向佛方所遥散奉献。到佉罗帝山上变作大云空中而住。其佉罗帝山牟尼诸仙所依住处。雨种种宝种种华种种天鬘种种涂香

尔时会中有诸众生作如是念。欲有何事。是何等力先作此瑞

尔时世尊告慧命耶舍言。汝等比丘当自正念系心而住勿得散乱。世尊复告慧命耶舍。汝等比丘当以精勤系念而住勿得散乱。若能精勤系念不散。则能休息烦恼之道及除苦道。能住第一义谛。能满六波罗蜜。不久得成阿耨多罗三藐三菩提。此是诸阿修罗及与一切眷属妓女而今欲来。并作五音妓乐和合而作庄严。为礼拜我供养听法。是故汝等。勿得散乱系念而住。尔时一切阿修罗及与眷属。寻即来到佉罗帝山。到已即时右绕其山。三匝讫已。将诸眷属诣世尊所

尔时罗睺罗阿修罗王向世尊头面作礼右绕三匝于前住立。持梵天髻上光明艳色摩尼宝珠置于佛前。复用种种宝华末香幢幡宝盖。及以金缕真珠璎珞。复以种种歌舞作乐而用供养。合掌向佛说偈赞曰

  心调士中最　　能施一切乐
  法灯常法施　　增长法智慧
  世尊然法炬　　天人皆悉知
  了达悕望法　　安住涅槃道
  唯佛荫诸众　　如盖覆一切
  摧伏诸阴魔　　死魔烦恼魔
  降魔及军众　　并及恶心意
  稽首于世尊　　勇健愍诸有
  是魔极恶心　　常行诸恶事
  此是彼戏笑　　欲得众生苦
  此诸修罗宫　　苦云悉弥覆
  佛即起悲心　　触我诸修罗
  佛为众生故　　修诸苦行讫
  多劫修檀戒　　行忍及智慧
  世尊更不作　　诸余恶行事
  佛以如是事　　足令我得乐
  惟佛精进士　　三界无等双
  离诸烦恼缚　　解脱于三有
  佛仍于众生　　慈悲而常转
  礼佛不动山　　慈心正安住

尔时毗摩质多阿修罗王及与眷属。头面接足礼拜世尊。右绕三匝佛前住立。即以千斤阎浮檀金置于佛前。复以日爱宝摩尼珠置在佛上。如是种种宝种种香华。乃至种种歌舞伎乐而作供养。合掌恭敬说偈赞曰

  释梵大自在　　轮王那罗延
  护世及波旬　　悉无如是力
  天龙夜叉等　　人及阿修罗
  亦无如世尊　　慈悲大势力
  惟佛众生最　　如地不嗔喜
  能忍一切恶　　并作恶业者
  等视诸众生　　如母爱其子
  心平于一切　　是故礼佛足
  愿护此一法　　勿使魔更来
  不令彼得胜　　作此恶恼害
  一切恶嗔怒　　及以最极恶
  实语愿说咒　　降伏诸魔军
  如人身无病　　不求诸医师
  如是阿修罗　　无事不想佛
  我今甚欢喜　　来诣于佛所
  愿说清净法　　令到菩提道
  显示诸贤圣　　寂定如虚空
  远离于诸恶　　及离我我所
  速知于实际　　能除诸烦恼
  速断一切缚　　得知最上道

尔时波罗陀阿修罗王及与眷属。顶礼佛足右绕三匝。持众杂色种种宝树。状如波吒罗七宝之树置于佛后。种种宝叶华果。金缕真珠璎珞。天生宝鬘。天璎衣服。指印环玔。宝盖幢幡。手璎珞脚璎珞臂璎珞。宝庄严具于佛头上空中垂下。乃至种种歌舞作乐而供养佛。一心合掌说偈赞曰

  众生常为彼　　烦恼火所烧
  求乐恒不得　　不遇施乐者
  一切住恶道　　惟佛众生药
  安住解脱道　　能救一切苦
  惟佛赏人主　　三有中更无
  愍进智慧水　　众德满如海
  为盲失道者　　安住于正路
  导引诸众生　　住胜涅槃道
  凡夫饥无厌　　唯佛能充饱
  常为烦恼溺　　唯佛能救拔
  遭溺之病苦　　苦逼失其念
  如此苦苦者　　导师为亲救
  恶心众生等　　龙鬼诸罗刹
  见佛得正念　　安住大悲心
  唯佛于三界　　能作救护者
  我等已孤独　　悉为众苦溺
  我等皆一心　　一切乐法住
  愿说最上义　　令我得菩提
  以得于佛眼　　最上诸佛智
  速伏诸魔怨　　愿降正法雨

尔时跋持毗卢遮那阿修罗王将诸眷属。顶礼佛足右绕三匝。于佛右左积阎浮檀金。复以种种宝种种华种种末香宝盖幢幡。及以金缕真珠璎珞歌舞作乐。合掌供养说偈赞曰

  福田福德水　　福种福德牙
  福树福德枝　　福条福德叶
  福华福味果　　最上福味浆
  福色福阴影　　福德子成就
  佛福善坚固　　福勇能伏他
  福色勇健士　　福德不动山
  福华覆盖土　　福药所依身
  福山最上顶　　放福智慧水
  福德海甚深　　福德众生依
  妙福众宝磺　　福味如巨海
  福器盛甘露　　福愿皆盛满
  福商恒将向　　无漏宝国土
  我等众福尽　　是故归依佛
  福德贤宝瓶　　愿愍施我等

尔时复有阿修罗仙。名一切菩提鬘。具有大福大威德大智慧大苦行。以菩提心而作庄严。得五神通离诸尘垢。安住成就一切众生。常化一切阿修罗等堪受彼供。是诸阿修罗无上导师。与九万五千具足五通阿修罗仙。前后围绕来诣佛所顶礼佛足。以真金瓶盛八功德水。置于佛前并献宝杖。复与九万五千眷属各各执持异种宝盖。以奉世尊右绕三匝。合掌向佛说偈赞曰

  忍辱如大地　　忍水常盈满
  安住于净忍　　宁心无所失
  烦恼渴爱尽　　安处于信财
  佛住慈悲心　　置众菩提道
  说法犹如水　　若闻如是法
  爱乐菩提心　　能成第一义
  大悲愿调伏　　此诸下劣行
  愿受我修罗　　所献众宝物
  三界所有供　　弃舍不求染
  唯佛无烦恼　　堪受世供养
  佛以大菩提　　严三有众生
  愿说第一义　　为得菩提故
  我于拘留孙　　曾闻第一义
  拘那含牟尼　　迦叶佛亦然
  我以自愿力　　应现阿修罗
  为化修罗故　　修行菩提道
  闻法获德藏　　复能转示他
  降魔恶徒党　　炽然正法朋
  于此浊恶世　　难有功德人
  现佛境界事　　是佛妙神力

大集经卷第四十七大方等大集经卷第四十八

        高齐天竺三藏那连提耶舍译

    月藏分第十四本事品第四

尔时弥勒菩萨摩诃萨。即从坐起。偏袒右肩整理衣服。合掌向佛而作是言。世尊。既是释迦贵种刹利大姓。迦毗罗城净饭王子。此四阿修罗畜生种类极成卑下。世尊。何故言与我亲。尔时佛告弥勒菩萨摩诃萨言。于过去世第三十一劫有佛出兴。号毗舍浮如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛常为四众说法。尔时有一大婆罗门。名弗沙耶若。已于过去无量佛所种诸善根。于阿耨多罗三藐三菩提而不退转。深信具足归依三宝。受持五戒离诸放逸。时弗沙耶若有弟八人。一名弗沙金刚。二名弗沙那毗。三名弗沙阇利。四名弗沙跋摩。五名弗沙车帝。六名弗沙树。七名弗沙毗离。八名弗沙那提。时弗沙耶若婆罗门劝诸弟言。汝等贤首。今可归依佛法僧宝。受持五戒离诸放逸。发阿耨多罗三藐三菩提心。时彼诸弟皆悉不肯归依三宝。乃至不肯发菩提心。时弗沙耶若数劝诸弟经于多年。复问诸弟。汝等。何故皆悉不肯归依三宝。乃至不肯发菩提心。竟有何意何所愿求。时彼八弟即作是言。兄能千年修二威仪。惟行惟住不坐不卧。经七日夜限食一揣。修此难行足满千年。然后我当归依三宝受持五戒离诸放逸发于无上菩提之心。弥勒。时弗沙耶若闻是语已。一心喜悦。即为八弟而立誓言。汝等。若能归依三宝。乃至能发阿耨多罗三藐三菩提心不退转者。我今必当千年之中不坐不卧七日七夜限食一揣。我立誓已。于千年中若昼若夜。乃至一刹那顷念于坐卧。乃至于七日夜过食一揣。永当使我违三世佛。违六波罗蜜。违十善业道。不成阿耨多罗三藐三菩提

尔时空中。有百千亿那由他无量诸天赞言。大士善哉善哉。坚固勇猛大力决定。汝于来世盲冥众中当得成佛。多陀阿伽度阿罗诃三藐三佛陀声震于世。时毗舍浮佛。以弗沙耶若头陀功德故赞言。善哉善哉大婆罗门。汝今以此苦行威仪。行檀波罗蜜乃至般若波罗蜜故。于未来世第三十一大贤劫中人寿百岁于彼成佛。号释迦牟尼如来应正遍知。声震于世。汝当尔时。与此八弟授阿耨多罗三藐三菩提记。弥勒。彼弗沙耶若婆罗门。足满千年不坐不卧。经七日夜限食一揣。满千年已。令彼八弟安住三归受持五戒。及发无上菩提之心。善男子。是弗沙耶若化其八弟及余无量百千万亿那由他等。诸婆罗门长者居士男子女人童男童女。皆成熟已。即于毗舍浮如来法中出家学道。尔时所有解说经论及诸外典。诵持不忘为人解说。然后至闲林中。与第一义谛禅波罗蜜相应而住经五万年。于彼时中。成熟无量百千万亿那由他阿僧祇天龙夜叉阿修罗伽楼罗紧那罗摩睺罗伽畜生饿鬼毗舍遮人非人等。向于阿耨多罗三藐三菩提令不退转。弥勒。彼弗沙耶若婆罗门者岂异人乎。莫作异观我身是也。我于尔时为欲成熟彼八弟故。于千年中不坐不卧。但行但立经七日夜限食一揣。我为成熟彼诸弟故。乃至于闲林中住第一义谛经五万年。成熟无量百千万亿那由他阿僧祇天龙夜叉阿修罗伽楼罗紧那罗摩睺罗伽畜生饿鬼毗舍遮人非人等。向阿耨多罗三藐三菩提令不退转。尔时弗沙金刚者今罗睺罗阿修罗王是。弗沙那毗者今毗摩质多罗阿修罗王是。弗沙阇利者今波罗陀阿修罗王是。弗沙跋摩者今婆稚毗卢遮那阿修罗王是。弗沙车帝者今魔王波旬是。弗沙树者今汝弥勒是。以是因缘得无碍智。一生补处安住大乘。弗沙毗离者今毗摩罗诘是也。弗沙难提者今提婆达多是也。当如是观。我昔为求阿耨多罗三藐三菩提故。为欲成就魔波旬故。作如是等无量苦恼毛竖惊怖难行之事。是故今此魔王波旬。以福德智慧二种庄严故。有如是等神通威力。有大功能。于欲界中最胜自在。此魔波旬及余眷属。今于我所起勤害心。于正法幢起推折心。于僧宝所起破坏心。于八圣道起断除心。于正法灯起毁灭心。于诸众生一切善法起隐没心。致留难心。作恐怖心。不怜愍心。违反之心。令诸众生退舍善道堕恶趣心。于诸龙众起惊怖心。于阿修罗宫起破坏心。于此说法大众会所。欲障碍故而来至此。复起欲坏大众集心。兴此恶意顾视而坐。若有众生为障碍他故。娆乱他故。降伏他故。欺陵他故。求称誉故。求名闻故。依于五欲戏笑乐故。求富贵故。修行施戒忍辱精进禅定智慧。不为解脱。不为信敬。不为离欲寂静。唯为自身五欲乐故。修行施戒忍辱精进禅定智慧。为如是等诸结所缚杂于愚痴。于欲界中果报成熟。为魔波旬如是苦恼。此魔波旬以本障碍他故。娆乱他故。降伏他故。欺陵他故。求称誉故。求名闻故。依于五欲戏笑乐故。求富贵故。于毗舍浮如来法中。修行施戒忍辱精进禅定智慧。以是因缘。今于现在白法尽灭。五浊恶世得作魔王。于三宝所不生信敬无尊仰心。如是波旬常于众生而作诸恶。不利益故。令苦恼故。令堕落故。提婆达多亦复如是。此罗睺罗阿修罗王。毗摩质多罗阿修罗王。波罗陀阿修罗王。婆稚毗卢遮那阿修罗王。牟真邻陀阿修罗王。及余阿修罗等。亦于毗舍浮如来法中。憍逸自举不勤修习。复怀疑惑杂诸烦恼。贪欲嗔恚愚痴邪见。无明胆佞断常之心。修行施戒忍辱精进禅定智慧。以是因缘。今生下类苦恼畜生阿修罗道。为诸结所缚疑惑愚痴。是故彼等尚不能发世俗正见。何况能发无上善根。唯有弥勒菩萨摩诃萨毗摩罗诘及菩提鬘阿修罗仙等。于毗舍浮如来法中。不为障碍他故。乃至不求富贵故。但乐离欲化众生故。修六波罗蜜。以是因缘。此大丈夫弥勒菩萨毗摩罗诘及菩提鬘阿修罗仙等。得无碍智。以诸菩萨功德庄严。巧成一切众生智药。是故我今告于汝等。若有欲求无上智者。是人应当深信清净。以第一义谛而求菩提。莫以世谛。譬如五大河水能满大海。不以小河。如是以依第一义故。速能充满一切智海。不以世谛。又如须弥山王依于大地久住不动。不以依水。如是以依第一义谛。一切善根而得坚固。不以世谛。又如一切草木依于大地而得生长。不以草叶。如是四念处乃至十八不共法大慈大悲等。依第一义谛而得生长。不以世谛。又如猛风依于虚空而能吹荡烟云尘雾。不依于地。如是为求菩提诸善男子善女人等。依第一义谛。能吹诸恶见云烦恼烟雾十恶道尘。不以世谛。又如依日大光明故。得见高下及诸色像种种作业。不以依彼油灯小光。如是以依第一义谛菩提之心。无有迷惑作诸善业。不以世谛。是故应舍一切爱取摄受之事。住闲林中。不作放逸修第一义。不以世谛。汝等如是便能速满六波罗蜜。于阿耨多罗三藐三菩提而成正觉。尔时世尊欲重明此义而说偈言

  一生处弥勒　　问于尊导师
  云何畜生类　　言与人为亲
  世尊见久远　　告于弥勒言
  修罗等往昔　　皆是我兄弟
  第三十一劫　　毗舍浮佛时
  我作婆罗门　　聪慧字耶若
  六度常相应　　菩提不退转
  时我有八弟　　邪见婆罗门
  劝令信三宝　　及发菩提心
  彼皆不肯行　　愚痴邪见故
  既历多年已　　钝根作是言
  兄能千年中　　常离于坐卧
  复经七日夜　　限食饭一揣
  如是千年满　　我当住菩提
  我时一心喜　　誓住二威仪
  既满千年已　　方得成熟彼
  又化多众生　　出家离俗已
  复与第一义　　相应五万年
  如是第一义　　我时本安住
  转化无量众　　坚住无上道
  罗睺毗摩质　　婆稚波罗陀
  波旬毗摩诘　　弥勒及提婆
  如是八人等　　先是我兄弟
  为彼修苦行　　成熟于菩提
  我为无上道　　行诸苦难事
  波旬提婆达　　常欲危害我
  魔于过去时　　所作诸善业
  初无有信敬　　恒欲恼众生
  但为富贵欲　　求名不尊重
  毗舍浮法中　　而行于六度
  白法尽灭已　　恶法增长时
  得为魔波旬　　欲界中自在
  又于三宝所　　不肯生信敬
  波旬提婆达　　常欲恼众生
  如是修罗王　　增上憍逸士
  疑惑有欲垢　　及诸嫉妒行
  今在畜生类　　而作修罗王
  于诸最胜法　　无智不能了
  弥勒毗摩诘　　道鬘修罗仙
  于毗舍得信　　修行无上道
  彼与六度合　　常化诸众生
  是故今殊胜　　成熟无碍智
  故我今示汝　　宜舍诸疑惑
  勤修第一义　　证菩提不难
  如海常充满　　种种众宝物
  如是修真谛　　能令智满足
  又如依大地　　生长诸苗稼
  如是真谛合　　能生胜菩提
  又如风依空　　吹荡诸尘曀
  如是修真谛　　能灭诸烦恼
  又如依日光　　明见诸色像
  若住第一义　　能睹诸佛法
  是故若欲求　　于世速成佛
  宜舍诸见着　　安住第一义
  往诣闲林中　　端坐修禅定
  勇决独无侣　　求无上菩提
  精勤自调伏　　防护于己心
  弃舍诸邪见　　远离于断常
  怒心龙夜叉　　并及诸鬼神
  无量百千亿　　化之以真谛

    大方等大集经月藏分第十四第一义谛品第五

尔时月藏菩萨摩诃萨即从坐起偏袒右肩右膝着地。合掌向佛而作是言。世尊。我今欲有所问。惟愿如来。随时听许为我解释。尔时佛告月藏菩萨摩诃萨言。善男子。如来应正遍知。恣汝所问。当随意答令汝心喜。尔时月藏菩萨摩诃萨闻佛语已即白佛言。唯然受教。大德婆伽婆云何菩萨摩诃萨住阿兰若修第一义谛得如月。以四无碍成熟众生能满六波罗蜜。佛言。善哉善哉善男子。快问是义。汝于过去无量佛所殖诸善根。修诸功德圆满之行。已曾问此甚深之义。汝今直欲为彼未曾修习求阿耨多罗三藐三菩提。诸善男子善女人故问如是义。善男子。谛听谛听善思念之。吾当为汝分别解说。善男子。若有清信善男子善女人。求阿耨多罗三藐三菩提者当作是观。三界所有一切众生。皆为贪欲嗔恚愚痴三毒猛火焚烧炽然。生老病死忧悲苦恼皆亦炽然不得解脱。作是观时。菩萨于彼诸众生所起大悲心。复作是念。一切众生莫不厌苦求乐。彼等如是为苦所转如五节轮。复作是念。何因缘故此诸众生众苦增长无有休息。作是念时。知诸众生皆为爱取因缘所摄故。受是苦增长不息。是故我当弃舍爱取所摄因缘。出向闲林独而无侣。于第一义谛思惟而住。如是先自除苦。然后乃能除众生苦。如是菩萨以真实心欲令众生离苦得乐。当知此心从大悲起。菩萨摩诃萨弃舍一切爱取因缘。出向闲林独而无侣如犀牛角。于四圣种喜悦而住。不念地不念我地不念地我。水火风大亦如是。不念色不念我色不念色我。受想行识亦如是。不念眼不念我眼不念眼我。如是不念眼识不念我眼识不念眼识我。如是不念眼触不念我眼触不念眼触我。如是眼触因缘生受。若苦若乐不苦不乐。不念乐不念我乐不念乐我。乃至不苦不乐亦如是。耳鼻舌身亦如是。不念意不念我意不念意我。乃至意触因缘生受。若苦若乐不苦不乐。不念乐不念我乐不念乐我。乃至不念不苦不乐亦如是。不念四大不念我四大不念四大我。乃至不念三受。不念六想。不念三行。不念六识。不念色声香味触亦如是。不念虚空处。不念识处。不念无所有处。不念非想非非想处。不念见不念闻不念觉不念知。不念代谢。不念觉观。不念心。不念此世间不念彼世间。不念过去不念未来不念现在。不念断不念常。不念三昧不念禅。不念舍不念尽不念用。不念生不念灭。不念我不念数。不念黑不念白。不念胜不念劣。不念行不念住不念坐不念卧。不念闇不念明。不念作不念三界。不念刹那亦如是

呵呵呵呵呵呵　哒啰咩　达啰腻移　沓婆差　沓婆揭勒叉移　陀婆木叉移　苏婆贺善男子。是名菩萨摩诃萨住于闲林修第一义谛。佛说如是阿兰若第一义谛时。有八十亿百千频婆罗诸天及人。于第一义谛曾修习者皆得无生法忍。复有恒河沙等天人。得柔顺忍。复有过虚空量诸众生等。得不忘菩提心三昧。复有八万四千比丘。得无漏心解脱

尔时世尊复作是言。善男子。若有菩萨摩诃萨。如上所说弃诸爱取所摄因缘。乃至如我所说修第一义谛时。云何菩萨摩诃萨得如月。以四无碍成熟众生。能满六波罗蜜。善男子。如菩萨摩诃萨观诸众生。皆为三毒猛火炽然。生老病死忧悲苦恼皆亦炽然不得解脱。作是观时。菩萨于彼诸众生所起大悲心。此是菩萨摩诃萨得如月。照除众生无明黑闇如初日月。如菩萨摩诃萨为除众生诸苦恼故。舍诸爱取所摄因缘。此是菩萨摩诃萨得如月。照除众生无明黑闇。与义无碍相应成熟众生。为满六波罗蜜故如二日月

如菩萨摩诃萨出向闲林独而无侣如犀牛角。于四圣种喜悦而住。此是菩萨摩诃萨得如月。照除众生无明黑闇。与法无碍相应成熟众生。为满六波罗蜜故如三日月

如菩萨摩诃萨修第一义谛。此是菩萨摩诃萨得如月。照除众生无明黑闇。与词无碍相应成熟众生。为满六波罗蜜故如四日月

如菩萨摩诃萨于三界境界及一切乐。皆悉弃舍修第一义谛。此是菩萨摩诃萨得如月。照除众生一切渴爱。与乐说无碍相应成熟众生。为满六波罗蜜故如五日月

如菩萨摩诃萨弃舍现在人中乐。亦不悕望于五欲乐而修第一义。此是菩萨摩诃萨得如月。照除众生一切嗔闇。成熟众生能满檀波罗蜜。是故菩萨摩诃萨于诸众生如六日月

如菩萨摩诃萨于诸境界得奢摩他定。此是菩萨摩诃萨得如月。成熟众生能满尸罗波罗蜜。是故菩萨摩诃萨于诸众生如七日月

如菩萨摩诃萨三界境界休息相应。不分别嗔不分别慈。此是菩萨摩诃萨成熟众生能满羼提波罗蜜。是故菩萨摩诃萨于诸众生如八日月

如菩萨摩诃萨一切三界休息相应。不分别极不分别。此是菩萨摩诃萨成熟众生能满毗梨耶波罗蜜。是故菩萨摩诃萨于诸众生如九日月

如菩萨摩诃萨为悲愍众生故而修第一义。此是菩萨摩诃萨成熟众生能满禅波罗蜜。是故菩萨摩诃萨于诸众生如十日月

如菩萨摩诃萨为众生故。于诸三界阴界诸入三受等事。不分别极不分别。住如实际而修第一义。此是菩萨摩诃萨成熟众生能满般若波罗蜜。是故菩萨摩诃萨于诸众生如十一日月。如是善男子。此是菩萨摩诃萨住于闲林修第一义时得如月。以四无碍成熟众生能满六波罗蜜

复次善男子。云何菩萨摩诃萨修第一义时成熟众生复得如月。善男子。如菩萨摩诃萨住于闲林若行若住若坐若卧。舍离分别一切三界阴界入等。住不分别修第一义。时诸地行天龙夜叉罗刹阿修罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那。饥渴寒热更相怖畏。逼迫身心常怀嗔恶。于诸众生而无慈愍。不观后世畏。彼诸天龙乃至迦吒富单那。往菩萨所见已大笑。而欲夺于菩萨精气。又以恶气而欲嘘之。及欲打害散乱其心。彼诸鬼神虽起此恶。去一由旬不能往到彼菩萨所。何能以气嘘之夺其精气。及以打害散乱其心。彼诸鬼神心极生怪。复示第一最恶形色。欲令菩萨畏之心裂。然此菩萨若行若住乃至不能动其一毛。何况能作诸余恼乱。彼诸天龙乃至迦吒富单那。以一切方便不能少分恼乱。于彼修第一义谛菩萨摩诃萨。彼等便于修第一义谛菩萨摩诃萨所。心得敬信尊重敬仰心生希有。以于菩萨生敬信故。身心苦尽得乐充满。彼等复数诣菩萨所接足礼敬。还其本处游行止住。复于众生更相敬重。常生慈心不怖畏心不胆佞心不恼害心无怨仇心不斗诤心作平等心休息杀生心。乃至休息诸邪见心。彼等数数向于菩萨极作敬重。头面礼足发愿忏悔一切罪业。而作是言。我等从今乃至久远。生死流转随几时中。亦常恭敬供养仁者。以为左右亲友知识兄弟眷属及作檀越。乃至菩萨于阿耨多罗三藐三菩提得成正觉。是时仁者。于三乘中与我授记。以仁者力故。我等当于生死流转而得解脱入无畏城。此是菩萨摩诃萨修第一义时。成熟众生能满六波罗蜜。是故菩萨摩诃萨。于诸众生如十二日月

如菩萨摩诃萨住于闲林修第一义时。所有空行天龙夜叉罗刹阿修罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那。于诸众生犷恶嗔恚无有慈愍不观后世畏。作如是等诸恶形色非威仪事。乃至不能恼彼住于闲林修第一义谛菩萨摩诃萨一毛。何况能作诸余恼乱。彼等天龙便于菩萨摩诃萨所心得敬信。乃至休息十不善道。彼等数数向菩萨所发愿忏悔一切罪业。乃至仁者于三乘中与我授记。我等当于生死流转而得解脱入无畏城。此是菩萨摩诃萨修第一义时。成熟众生能满六波罗蜜。是故菩萨摩诃萨于诸众生如十三日月

如菩萨摩诃萨住于闲林修第一义时。彼诸天龙乃至迦吒富单那。向彼菩萨摩诃萨边。忏悔业障众生障法障烦恼障。乃至是诸众生得成熟故能满六波罗蜜。是故菩萨摩诃萨于诸众生如十四日月

如菩萨摩诃萨住于闲林修第一义时。彼诸天龙夜叉罗刹鸠槃茶饿鬼毗舍遮富单那迦吒富单那。犷恶嗔恚。于诸众生无有慈愍。不深敬信不观后世畏。乃至于彼修第一义谛菩萨摩诃萨所。深得敬信尊重敬仰生希有心。一切皆悉弃舍恶业及舍舍宅。昼夜诣彼修第一义谛菩萨摩诃萨所。修行如上休息杀生。于诸众生生悲心利益心怜愍心而住。休息偷盗邪淫妄语。此是修第一义菩萨摩诃萨能满檀那波罗蜜。如彼休息两舌。此是菩萨摩诃萨能满尸罗波罗蜜。如彼休息恶口。此是菩萨摩诃萨能满羼提波罗蜜。如彼休息绮语。此是菩萨摩诃萨能满毗梨耶波罗蜜。如彼休息贪嗔。此是菩萨摩诃萨。能满禅波罗蜜。如彼休息邪见得正见数数作如是愿。当令我等得无上智。此是菩萨摩诃萨能满般若波罗蜜。如彼天龙乃至迦吒富单那。于彼修第一义菩萨摩诃萨所深得敬信。亦复不勤怖畏刹利沙门婆罗门毗舍首陀。亦不怖畏男夫妇女童男童女。亦不怖畏象马师子虎豹豺狼獐鹿鸟兽。亦不怖畏国土城邑聚落舍宅。亦不怖畏地水火风。亦不怖畏药草林树花果等物。此是菩萨摩诃萨修第一义时。成熟众生乃至能满六波罗蜜。是故菩萨摩诃萨于诸众生如十五日月一切圆满。如是菩萨摩诃萨住于闲林修第一义谛。速能满足六波罗蜜。譬如十五日月众星围绕微妙可爱。如是修第一义谛菩萨摩诃萨。为彼信心诸天龙等乃至迦吒富单那。善行围绕微妙可爱。譬如十五日月照除一切无明黑闇。如是修第一义谛菩萨摩诃萨。照除天龙乃至迦吒富单那等十不善曀。譬如月体性凉冷。能令热恼诸众生等身心得乐。如是修第一义菩萨摩诃萨。令彼天龙乃至迦吒富单那等嗔怒所恼者。令住慈心身得安乐。譬如月令失道者见道。如是修第一义谛菩萨摩诃萨。令诸失道天龙夜叉乃至迦吒富单那等。于天人所皆生慈愍。乃至能见于三乘道。譬如十五日月一切圆满照于月爱摩尼宝珠。如是宝珠以月光照故。能出多水满于小河及诸大河又满大海。如是修第一义谛菩萨摩诃萨。以如是等威仪力故。乃至迦吒富单那得深敬信。不怖刹利乃至不怖童男童女。不怖城邑乃至不怖树林花果。以此因缘人非人等乃至迦吒富单那獐鹿鸟兽。各于所须具足充满。以彼所须得充满故。不相恼害身心安乐。于十善业道堪能修行。乃至于天人中得受果报具足快乐。以是因缘于三乘中得不退转。如是诸天人等多得饶益。如菩萨摩诃萨住于闲林修第一义。能令诸天人等得安隐乐。以是等故速能满足六波罗蜜。是故菩萨摩诃萨当住闲林修第一义。于一切善根三昧陀罗尼。忍辱坚固得住成熟

如须弥山王善得安住。如是修第一义谛菩萨摩诃萨。于一切善根檀波罗蜜善得安住。如师子兽王。以尸罗波罗蜜降诸烦恼。如那罗延。以羼提波罗蜜伏诸三界一切恶见。如波利质多罗树花始开敷。以毗梨耶波罗蜜种种善根花得开敷。如日轮焰光。以禅波罗蜜能除一切无明黑闇。如十五日月一切圆满。以般若波罗蜜功德庄严所愿圆满。如如意宝能除贫穷。以方便力种种善根不可穷尽。智财无减法愿充满。犹如大云能降大雨。如是菩萨摩诃萨住于闲林修第一义。乃能降注诸法宝雨。如菩萨摩诃萨修第一义。善能安住于菩萨行。一切魔事终不能动得不退转。于阿耨多罗三藐三菩提亦得圆满。种种功德宝花庄严。得到一切诸法智明。如幢上摩尼宝能成一切义。如毗沙门王贤瓶能到一切智炬。如得月爱摩尼宝珠在于手中。一切所知皆得圆满。犹如大海。亦如冬时着惭愧衣。如勇健人巧用种种坚牢器杖。如善化伏藏养育一切众生。如阿那婆达多池紧那罗等均平受报。犹如莲花诸烦恼泥不能染污。如宝花聚。百千法门种种围绕。犹如宝鬘。一切声闻辟支佛等之所瞻仰。犹如泉池净水盈满。洗除众生诸烦恼垢。如斯陀大河。荡除众生一切烦恼诸恶见垢。如大河中船。能度众生诸烦恼河。如枳萨利师子。降伏一切众邪异道。如帝释金刚杵。降伏一切烦恼阿修罗。犹如伞盖。遮障众生诸烦恼雨。如大梵王。令诸众生度于流转。生死旷野示涅槃道。是名菩萨摩诃萨住于闲林修第一义时成熟如是无量功德。如是善男子。第一义谛是何句义。第一义谛是五根句义。第一义谛是三昧根义。大慈大悲义。深信一切智义。以四摄法摄受一切众生义。护持正法义。勤求一切佛法义。远离诸难义。住佛功德义。超过声闻辟支佛地义。能净三业义。以诸三昧庄严心义。净三恶趣令诸众生舍邪道义。信解忍义。成熟众生无生忍义。舍离憎爱义。于诸法决断义。分别一切法义。勤求一切智义。得一切助菩提义。觉了十二因缘义。分别上首义。三不护义。四无畏义。十力义。大慈大悲成熟众生义。方便勤求如来十力第一义谛义。十地义。登祚地义。降魔义。得一切种智义。转法轮义。降法雨义。度一切众生义。建立八圣道义。第一义谛有如是等无量大义。善男子。第一义谛荡诸结垢灭一切恶。能度众生烦恼淤泥。枯竭爱河超过一切流转旷野。破诸见网照除无明。降伏诸怨断除忧戚。诸根适悦令入正道。觉悟诸法增长善根。舍诸凡愚入贤圣位到菩提道。善男子。如是第一义谛一切功德皆悉圆满。成熟无上最胜智慧。能令众生到于一切生死彼岸

尔时月藏菩萨摩诃萨白佛言。世尊。所谓三昧。三昧者是何身。是何攀缘。是何想。是何相。是何性。第一义谛是何身是何攀缘是何想是何相是何性。佛言。善哉善哉。善男子。汝于三昧久已修习善根圆满。汝今为于诸众生故问于如来如是等义。善男子。汝今谛听。善思念之。吾当为汝分别解说。月藏菩萨摩诃萨白佛言。世尊。唯然受教。佛言。善男子。诸声闻乘三昧者。名不善三昧。三界身。颠倒攀缘。不净想。厌离相。不喜乐性

地界三昧者。不分离身。取攀缘。重想。坚相。碎坏性

水界三昧者。不分离身。满攀缘。润想。稀软相。枯竭性

火界三昧者。不分离身。成熟攀缘。热想。烧相。尽灭性

风界三昧者。不分离身。吹举攀缘。无碍想。急疾相。轻举性

分别阴三昧者。渴爱身。缘起攀缘。弃舍想。苦相。无我性

空三昧者。通利法身。诸法攀缘。无物想。开视相。毕竟空性

无相三昧者。舍三结身。涅槃攀缘。空想。休息相。究尽作性

如是无愿心心法三昧者。五识身。因缘攀缘。常修行想。速疾相。无所依性。此等是声闻乘三昧

修是缘起三昧。名缘觉乘三昧

安住大乘。善男子。慈三昧者。忆念身。众生攀缘。无碍想。无嗔相。不浊性

悲三昧者。忆念身。众生攀缘。不害想。救拔相。愍恻性

喜三昧者。忆念身。众生攀缘。乐着想。爱乐相。常庆喜性

舍三昧者。忆念身。众生攀缘。无嗔喜想。常舍相。无功用性

念佛三昧者。法性身。形像攀缘。色处想。爱敬相。欢喜性

念阿那波那三昧者。以身为身。念为攀缘。不住想。冷热相。生灭性

善男子。如是第一义谛四禅灭空三昧三摩跋提。依阿那波那念。何谓阿那波那念。阿那言入息。波那言出息。念谓心法

善男子。彼入息出息当修。修已身猗心亦得猗。当云何修。一者数。二者随顺。三者止住。四者观相。五者转还。六者快净。数有二种作。一者依彼除觉观。二者取出入息相。随顺亦二种作。一者依出除觉观。二者取入息相。止住亦二种作。一者示现出入息渐渐减尽。二者安住三昧。观相亦二种作。一者示现出入息渐渐减尽。二者观察心心诸法。种种别异处处止住。转还亦二种作。一者息三种受。二者止三种行。以此得净空三昧。何者为空三昧。见诸法无命。观诸法无主。于彼得住七种空。何者为七。所谓阴空界空入空谛空因缘空法空性空。是名空三昧。住是空三昧则增长因缘息。增长因缘息则事休息。事休息故则道休息。善男子。此是菩萨摩诃萨第四禅不可得无言说得第一义谛三昧。非声闻辟支佛境界。菩萨摩诃萨得禅定处。毕竟不堕声闻辟支佛地。能满六波罗蜜。于七日夜成熟无量亿那由他百千众生。天龙夜叉乃至迦吒富单那等。何况能多日夜。随其所有国土城邑。有如是等住第一义禅。菩萨摩诃萨于彼国土有十二种功德利益。何等十二。一者于彼世界国王不嗔恼。婆罗门不嗔恼。沙门不嗔恼。毗舍不嗔恼。首陀不嗔恼。男夫妇女童男童女及畜生类禽兽等不嗔恼。二者于彼国土他方怨敌不来侵国兵杖不起。三者于彼国土无贼寇无欺诈无矫诳。四者于彼国土恶人不入无诸疫病。唯除四大相违病者。终不横死除自报尽。五者于彼国土亦无非时风雨寒热。六者于彼国土一切众生无有嗔恶急躁粗犷。颠倒见取为痴所覆。天龙夜叉罗刹阿修罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那。师子白象虎豹豺狼毒蛇蝮蝎。七者于彼国土亦无蚊虻恶蝇虱蚤鼨鼠野狐训狐兔枭及以鹰鹞并余伤害食苗稼虫。八者于彼国土花果美味皆悉甘脆。无苦辛涩无味等物。亦无饥馑。果药丰饶。九者于彼国土大地平正无有旷野高下崄难。地无盐卤亦无坑涧。花果树林常得青翠扶疏蔚茂。是故众生不乏衣食。所须常得饶益安乐。十者于彼国土人无怨仇斗诤毁訾亦无言讼。皆生慈心利益心同心喜心。施心戒心忍心精进心禅定心智慧心。求法心不违反心。勤求三乘心求解脱心知足心。唯除过去诸不善业怨仇心等。十一者于彼国土当得诸佛住世。若无诸佛有缘觉住。若无缘觉有声闻住。若无声闻有五通仙住。于彼国土常有如是应受供人。十二者于彼国土无恶名称不可乐声。所谓谪罚声斗讼声狱系缚声。杀害声着铠甲声。捕猎声偷盗声。骂詈声期克声。俭声饥馑声少衣服声。欺陵声病声邪淫声。妄语声两舌声。粗犷语声绮语声。贪声嗔声归依恶天神声。于彼国土常无如是诸恶邪声。常有如是好声满足。所谓三宝声三律仪声。四梵住声四摄声。六波罗蜜声。无生法忍声。登祚声不受后有声降魔声。转法轮声降法雨声。于彼国土以此诸声常得充满。修第一义禅菩萨摩诃萨。随所住处于彼国土诸众生等。皆得趣向无上菩提。于三界中声震于世。若有菩萨摩诃萨欲得速满六波罗蜜。及欲成熟无量无数万亿众生速成阿耨多罗三藐三菩提。当诣闲林于四圣种相应而住。如是菩萨摩诃萨以第一义谛得八地智。尔时世尊欲重明此义。而说偈言

  月藏问尊天人师　　愿为我说上月语
  云何菩萨住兰若　　云何修习第一义
  云何于彼得如月　　与义相应无碍智
  能成无数亿众生　　亦能速满于六度
  断除烦恼及诸行　　佛说修习第一义
  见三界苦烦恼火　　老病忧悲死炽然
  于诸众生生怜愍　　速舍爱取摄因缘
  喜乐圣种住兰若　　于第一义常相应
  修诸禅者舍六根　　亦舍爱取阴界入
  三界境界爱尽除　　远离三世及断常
  于禅损减尽不念　　是人得离黑白尘
  亦离明闇诸分别　　亦常修习第一义
  舍离阴界住菩提　　于诸世间得如月
  国土众生息惊怖　　犹如满月照世间
  如是众生得安乐　　如月性冷焱光明
  于诸国土恶声息　　如是功德亦如月
  若人修习第一义　　微妙音声满世间
  俭病斗诤悉休息　　令诸众生向菩提
  信顺忍成第一义　　悟无生忍亦复然
  亦以此成无碍智　　亦能速满于六度
  亦以此法成众生　　亦以此法速成佛
  声闻不善处　　颠到亦应离
  地界不分离　　坚重碎坏性
  水界不分离　　希润枯竭体
  火界烧煮熟　　热想尽灭性
  诸阴是爱性　　因缘得休息
  空有于七种　　法物令开现
  无相除渴爱　　休息于诸结
  舍诸集因缘　　皆以无愿力
  修习因缘起　　唯是缘觉乘
  大乘诸众生　　修行诸梵住
  安般念三昧　　开示于身心
  心能住无事　　休息三种取
  不可得言说　　是名第一义
  非彼二乘地　　安住此实际
  若以此三昧　　成熟无数众
  名称满于中　　是人速成佛
  是故若欲满　　檀等波罗蜜
  及欲成佛道　　常乐阿兰若
  若常乐兰若　　修诸圣德行
  速舍诸缘碍　　得成佛菩提

尔时世尊说是第一义时。于彼众中五百七十菩萨摩诃萨。曾于过去修此法者。一切皆得无生法忍。复有六十百千频婆罗菩萨摩诃萨。曾修此法。彼等皆悉于十地行得自然智。复有六十百千那由他频婆罗众生。曾于过去修四梵住及四无碍。彼等皆得月藏三昧自然成熟得八地智。复有八万四千比丘。得尽诸漏心得解脱。如恒河沙数诸众生等未发无上菩提心者。皆于阿耨多罗三藐三菩提得不退转

大集经卷第四十八大方等大集经卷第四十九

        高齐天竺三藏那连提耶舍译

    月藏分第十四令魔得信乐品第六

尔时有一帝释天王。名曰火光。与大众集在于会坐。白憍尸迦帝释言。憍尸迦。此魔波旬。为当欲令住于闲林与第一义相应菩萨摩诃萨等得三昧故。勤作恼乱为欲退彼三昧故也。时憍尸迦。答彼火光天帝释言。是魔波旬。于四天下一切处中。令诸众生退失留难善朋党故。勤作恼乱。又令退失留难檀波罗蜜乃至般若波罗蜜故。勤作恼乱。复令退失天人种故。三种菩提故。增长三恶道故。勤作恼乱。魔诸眷属亦复如是。为欲增长一切众生大苦海故。勤作恼乱。憍尸迦说是语已。于时一切诸来大众。皆以慈心瞻视魔王。有诸菩萨摩诃萨等。慈愍劝谏魔王波旬。是时火光帝释复与一万帝释天众。悉共合掌向魔波旬作如是言。大王庆喜庆喜。于三宝中应生信敬。是时娑婆世界主大梵天王与六十亿百千梵众及四天王。慈心眼视魔王波旬亦作是言。庆喜庆喜。汝魔波旬。若于三宝不得信敬。未来长夜有大损失。无所利益堕诸恶道。是魔波旬。为彼一切诸来大众。各各皆以慈心眼视。及诸菩萨摩诃萨等释天梵天护世四王劝谏之时。从座而起合掌向佛头面礼足。而说偈言

  智者一向弃王位　　以有烦恼嫉妒慢
  故令失坏胜善道　　坠堕诸恶不善趣
  我以富贵狂因缘　　于善导师多留难
  遮障众生诸善业　　初不见佛起嗔心
  世尊一向常忍辱　　慈悲怜愍诸众生
  等心一切已慢除　　枯竭众生烦恼海
  惟佛烧尽烦恼薪　　能示人天解脱道
  令亿众生度有海　　我盲无智入闇冥
  我今启请诸大众　　愿以慈愍助我等
  谢过如来住坚信　　更不重起恼乱心
  我今一向护佛法　　炽然光显正法眼
  自舍所有贪妒慢　　忏悔无余诸罪业
  我今发大菩提心　　及劝一切众生等
  自修精进满六度　　置彼众生于八道
  我为一一众生故　　显说无量诸法门
  随所能令入法城　　如是勤劝一切众
  未曾见有如此会　　悉能净信于三宝
  由我恶心被厌贱　　故今舍之及众过
  从今永住净信心　　愿后更不被厌贱
  心与圣德常相应　　不复造作众恶业

尔时魔王说此偈已。即向佛所到已礼拜。而说偈言

  我于世尊作留难　　愿以上忍见容恕
  救孤独者受我忏　　大智慈仁不怀嗔

尔时一切诸来大众咸同一音而白佛言。婆伽婆。唯愿容恕魔王波旬。魔今深信诚心忏悔。当持佛法炽然法眼。令世尊法久住于世。复使人天长夜当得利益安乐。尔时世尊以偈答曰

  忍为世间最　　忍是安乐道
  忍为离孤独　　贤圣所欣乐
  忍能显众生　　忍能作亲友
  忍增美名誉　　忍为世所爱
  忍得富自在　　忍能具端正
  忍能得威力　　忍照于世间
  忍得诸欲乐　　忍能成工巧
  忍力降伏怨　　及以除忧恼
  忍得好容色　　忍能具眷属
  忍招诸胜报　　忍能超善道
  忍得人乐观　　忍能得妙好
  忍能息诸苦　　忍得寿命长
  忍得大梵王　　忍得欲自在
  忍得天帝释　　轮王具神通
  忍得人中主　　忍力难降伏
  忍得龙夜叉　　修罗中自在
  忍能息诸怨　　不害于众生
  忍能离偷盗　　忍能舍淫欲
  忍能止妄语　　两舌绮恶言
  忍能除贪嗔　　及离邪见意
  忍力成施戒　　精进及禅那
  般若波罗蜜　　能满此六度
  忍能除诸惑　　忍得罗汉乐
  亦得辟支佛　　及住无生忍
  忍能具十地　　速得菩提道
  忍于诸众生　　得为无上胜
  忍能降众魔　　及伏诸外道
  忍能于世间　　转最无上轮
  忍令多众生　　枯竭三恶道
  忍断烦恼障　　及能净法眼
  忍授众生记　　三乘随所求
  忍能伏刚恶　　夜叉罗刹等
  忍与种种人　　授记最胜道
  忍已降诸怨　　亦能灭众恶
  忍能息一切　　非时暴风雨
  忍能作大集　　此诸所来众
  我恕汝波旬　　于我诸犷戾
  但自谢己心　　是我第一恕
  今于大众前　　证知劝诫汝
  莫坏我所习　　一切佛正法

尔时一切诸来大众。天人阿修罗乾闼婆等同声叹言。善哉善哉。婆伽婆。如来常于一切众生慈悲怜愍。以诸善法饶益安乐。魔王波旬。常于世尊起憎恶心怨心害心。与诸众生为恶知识。于诸善法常作留难令住不善。时有梵天名曰威德。白不动大梵天王。而说偈曰

  如空无边亦无等　　一切众生所依住
  佛智如是不思议　　于一切法到彼岸
  世尊有叹檀行处　　怜愍一切众生故
  以檀得为功德士　　速能满诸波罗蜜
  或有广说戒忍进　　及以禅那般若等
  世尊于此一一中　　具足能显于六度
  如来唯以禅定法　　说能趣向菩提道
  是故常应乐住禅　　速能证于大菩提

尔时复有一切梵王。诸帝释王诸余天王。诸龙王诸夜叉王诸阿修罗王诸伽楼罗王诸紧那罗王诸乾闼婆王诸摩睺罗伽王诸罗刹王诸鸠槃茶王诸饿鬼王诸毗舍遮王等。从座而起向魔波旬。合掌而礼作如是言。大王敬信敬信牟尼世尊。以此世尊解脱诸过。到于一切功德彼岸。慈悲怜愍诸众生等。施一切乐觉了诸法。舍诸流转住于彼岸。又言大王。若有众生。乃至一念深信如来敬仰尊重叹未曾有。以敬信故得作轮王。统四天下七宝具足。乃至得作帝释天王。欲自在主魔王波旬。娑婆界主大梵天王。何况常能具信三宝。是故大王。应舍魔见诸恶浊心具足净信。于生死流转富贵自在受诸果报。后成正觉能施众生一切安乐。得为世间无上福田。尔时魔王复与诸臣顶礼佛足。专心敬信牟尼世尊殷勤忏谢

尔时世尊以偈告曰

  恶心奸慧汝当起　　我常容忍天人证
  至心修行菩提道　　汝当作佛无边慧

尔时魔王极生净信。即持无价摩尼宝鬘。无价咽璎珞臂璎珞脚璎珞及以指印。奉献世尊合掌而礼作如是言。我昔于佛多作留难。为欲破坏正法眼目断三宝种坏灭法炬。何以故。远离善法迷惑心故。今于三宝深得敬信。本昔所作一切业障今已忏悔。已发阿耨多罗三藐三菩提心蒙得授记。唯愿世尊。哀受我等摩尼宝鬘璎珞指印。尔时世尊。慈悲怜愍魔波旬故。即便受之。尔时魔王。心生大喜作如是言。若佛所有声闻弟子。比丘比丘尼优婆塞优婆夷。若复余人。宴坐闲林与第一义相应住者。现在未来若魔魔子魔妇魔女。魔诸左右男夫妇女。及依魔住所有众生。若天天子天妇天女。天诸左右男夫妇女。若龙龙子龙妇龙女。龙诸左右。男夫妇女。乃至迦吒富单那若子若妇若女。若诸左右男夫妇女。娆乱衰害取其精气。气嘘其身散乱其心。若夺衣服饮食汤药。若教他夺若夺其味。若以鼻嗅若放臭气满其住处。若复见彼住于闲林比丘比丘尼优婆塞优婆夷及余众生修第一义者。若不勤作供给供养衣服饮食及以汤药。我当令彼若魔魔子乃至迦吒富单那左右男女。得头病眼病耳病腹病如是等病之所逼恼。退失神通不复能得飞空远逝一切方所皆迷闇冥。魔王波旬作是语已。即说咒曰

庵摩差(叉戒反)喝啰摩差　庵摩摩啰差　莫叉鞞阇婆帝　莫叉苏兜帝　阿婆羯簁　阿婆坻[口*梨]　时那匙(上支反)那摩伽娑婆犀　頞啰弃摩那底[口*梨]　浮阇跋啰　坻泥阿佉[口*樓]差摩佉跛弥　陀罗阿鞞斯啰佉鞞娑　牟达罗佉鞞　毕[口*梨]剃毗涅寐帝郁特迦　涅寐帝　坻阇涅寐帝婆耶婆涅寐帝　阿迦奢妹罗　涅寐帝分示那啰夜拏　佉婆涅文支　摩醯首婆啰涅文支　阿娑遮婆　涅文支　萨兜婆僧弃耶跋柘　涅文支　钵啰摩頞他　涅文支　钵啰伽拏　钵啰頞他　涅文支　多婆跋啰多　涅目多　钵啰摩頞他　涅文支逻　苏婆呵

尔时一切诸来大众。于中所有恶行恶心。于诸众生无慈悲者皆悉惊怖。魔王波旬复作是言。若有违我此教令者。当得如上众病等恼。复次世尊。我今摄护佛子声闻伏诸恶行。不令现在及未来世作诸衰恼。能使世尊法眼久住。令三宝种不断于世。尔时世尊复赞魔言。善哉善哉。如是波旬。汝于长夜具大功德。无复诸恶一切衰恼

尔时一切诸来大众。诸天及人乾闼婆等皆悉赞言。善哉善哉。魔王波旬。能于三宝深得净信。如是佛法长夜炽然。天人当得入无畏城。闭塞恶道常开善趣解脱之门。于四天下所有斗诤疫病饥馑非时风雨皆得休息。又令四天下常得安隐丰乐可乐多众盈满。尔时魔王礼世尊足。右绕三匝退坐一面。尔时大众欲重明此义。以偈颂曰

  魔心决定得欢喜　　忏谢如来及眷属
  真心踊悦作是语　　慈悲人前舍诸恶
  犹如虚空无边际　　佛智境界亦如是
  觉了无边诸法已　　于世说法最第一
  或有说檀胜无等　　以檀能得妙菩提
  或复有说尸罗忍　　精进禅定及智慧
  如是种种方便说　　示现无等大菩提
  天人修罗应当知　　世尊降伏自在魔
  此经佛说忍为最　　能得一切安隐乐
  忍能休息诸烦恼　　能示胜妙解脱城
  卑心合掌咸向佛　　忏悔已作诸恶业
  当发最胜菩提愿　　我等必当作导师
  自然如来授记已　　魔王速成等正觉
  及余百千众生等　　亦与无上菩提记
  已满忍辱波罗蜜　　速为无等大导师
  与诸善法作依止　　护诸声闻故说咒
  若魔依魔诸神鬼　　夜叉修罗富单那
  如有恼害佛子者　　当以恶病着其身
  一切大众皆踊悦　　欢喜咸作如是言
  以此业故法炽盛　　则得久住于世间
  魔王安住净忍心　　三宝水泉难枯竭
  当息世间一切浊　　饥馑暴风及亢旱
  是故人天得诸乐　　本所修习忍辱行
  乐檀尸罗忍方便　　到进禅智大彼岸

尔时世尊显说如是忍功德时。九百八十万诸天人等曾修忍者。一切悉得无生法忍。十频婆罗百千人得柔顺忍。亿那由他百千天人得须陀洹果。过于数量诸众生等得世正见。十频婆罗百千天人阿修罗夜叉罗刹。昔未曾发阿耨多罗三藐三菩提心者。悉得发心及不退转。百万众生得授阿耨多罗三藐三菩提记

    大方等大集经月藏分第十四一切鬼神集会品第七

尔时护世四大天王。从座而起合掌向佛。头面礼拜作如是言。婆伽婆。此阎浮提种种国土。城邑村落园林寺舍山泽等处。所有诸恶天龙夜叉罗刹阿修罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那依彼住者。嗔恶穬戾无惭无愧。于诸众生无有慈愍。常害他命及作恼乱。彼诸天龙乃至迦吒富单那等。于阎浮提非时数数起于亢旱恶风雹雨闇[目*壹]灰尘严寒毒热。以是灾害坏诸苗稼五谷花果蒱萄甘蔗劫贝等物。故令众生多有种种饥馑疫病爱别离苦众恼逼切。各各迭相怖惧斗战心常恐畏。诸王刹利于己眷属五欲众具不生喜乐。于己国土触恼一切沙门婆罗门毗舍首陀。男夫妇女童男童女。亦复触恼象马牛羊师子虎豹豺狼狗犬。一切禽兽皆令触恼。于诸众生种种因缘而逼恼之。昼夜杀害烧煮割截。五谷财帛所欲供具身心乐事及诸善行皆悉损减。以是因缘令人天等善趣减少。又令阎浮提善事灭故不可爱乐。我等一切不能遮护。今此世尊大集之处。一切大士菩萨摩诃萨诸声闻众皆悉集云。一切天王及与眷属。一切龙王阿修罗王。乃至一切毗舍遮王。悉与眷属皆来集会。世尊。彼等于此阎浮提一切国土城邑村落山谷寺舍园林之处。惟愿世尊。分张付嘱。天龙夜叉罗刹阿修罗鸠槃茶饿鬼毗舍遮等。各令护持。若彼天龙乃至毗舍遮。于阎浮提作于一切斗诤触恼。非时风雨疫病饥馑寒热等事。各各随分而遮护之。若于阎浮提所有斗诤触恼疫病饥馑非时风雨寒热等事皆悉休息。令阎浮提所有华果药草劫贝财帛五谷甘蔗蒱萄及酪蜜等皆得成熟。所有苗稼不令衰坏。于阎浮提诸处人中及獐鹿鸟兽。随其所欲皆无乏少。以无乏故。令彼众生修诸善行。修正法行修真实行勤修而住。令彼诸善增长不退。以是因缘。此阎浮提安隐丰盛人多盈满甚可爱乐。世尊正法则得久住。一切人天所愿满足。众生悉得趣向善道及涅槃道离三恶趣。令三宝种得不断绝。尔时四天王欲重明此义。以偈颂曰

  于此阎浮提　　所有诸国土
  恶天龙夜叉　　罗刹鸠槃茶
  饿鬼毗舍遮　　迦吒富单那
  嗔恶无恩养　　无慈于众生
  彼等无惭愧　　触恼诸刹利
  沙门婆罗门　　毗舍及首陀
  师子象虎豹　　非时恶风雨
  疫病及饥馑　　能令众生苦
  彼等害众生　　毁坏于世间
  残害诸苗稼　　及灭正法灯
  我等四天王　　不能遮此恶
  愿佛当分布　　国土城邑等
  付嘱龙夜叉　　罗刹鸠槃茶
  令彼各遮护　　非时恶风雨
  息诸怖畏恼　　令无病饥馑
  华果药苗稼　　充足众美味
  众生不乏少　　所用诸供具
  一切善法增　　令得可乐事
  佛法得久住　　众生趣善道
  三宝种不绝　　愿佛常哀愍
  大地具众美　　离诸苦辛味
  华果皆具足　　种种味充满
  泉池陂河等　　净水常充满
  于诸苗稼等　　不能夺精气
  彼所进饮食　　心软无粗穬
  慈念常相向　　流转净无垢
  舍家众事业　　住于阿兰若
  勤修菩提行　　令多众生信
  法朋得增益　　令魔众损减
  四天下丰乐　　诸处人充满

尔时世尊问四天王释提桓因娑婆世界主大梵等言。诸天王辈。若见若闻此贤劫初拘留孙佛及拘那含牟尼佛迦叶佛等出现世时。云何以此阎浮提中所有天龙夜叉鸠槃茶等分张付嘱。为如我今菩提树下初成正觉。以此一切阎浮提中天龙夜叉鸠槃茶等分张付嘱安置不也。如是问已。四大天王释提桓因娑婆世界主大梵王等白佛言。大德婆伽婆。我等见闻此贤劫初拘留孙佛菩提树下初成正觉。以此阎浮提天龙夜叉鸠槃茶等分张付嘱。如今世尊菩提树下初成正觉。以此阎浮提天龙夜叉鸠槃茶等分张付嘱等无有异。彼拘留孙佛出现世时。众生寿命四万岁。彼时大地精气众生精气法精气等力得增上。味增上威增上德增上慈增上胜增上智增上。如是等事皆得增上。尔时依地果味众华药等众生食者皆得软心。慈心悲心喜心舍心。施心戒心忍心精进心禅定心智慧心。离杀生心乃至离邪见心。少欲知足少烦恼垢。多福长寿离欲闲居。爱乐正法厌患流转炽三宝种。以是因缘得离恶道趣向善道。尔时诸天乃至迦吒富单那。一切禽兽悉得具足如是等事。次后众生名寿损减。名寿损减故福德损减福德损减故地味精气损减。地味精气损减故众生精气损减。众生精气损减故众生心法作善惭愧损减众生心法作善惭愧损减故正法甘露精气损减。彼诸众生名寿损减。乃至正法甘露精气损减故。广作杀生乃至邪见。乃至禽兽亦复如是。如是众生远离善道及涅槃道趣向恶道。彼命终已生恶道中。若彼众生生于夜叉乃至迦吒富单那中者。嗔恶无慈不视后世可怖畏事。广作杀生乃至邪见彼等众生于阎浮提。未得入于付嘱护持分中。如是拘那含牟尼佛。迦叶佛。于菩提树下初成正觉。以此阎浮提天龙夜叉鸠槃茶等分张付嘱。如今世尊于道树下初成正觉。以此阎浮提天龙夜叉鸠槃茶等分张付嘱等无有异。如是白法渐减黑法增长。从是已来无量那由他百千恶龙夜叉乃至迦吒富单那生长番息。常嗔穬恶不怀惭愧。于诸众生无有慈心。不观后世可怖畏事。残害他命食其血肉。彼等不入分布分中无定住处。此恶龙等不守护人乃至畜生。常欲夺人精气断他命根。灭坏国土城邑村落寺舍等处。能令诸王嗔恼。乃至能令畜生等恼。又复能令非时风雨严寒毒热。坏灭一切华实苗稼。如是恶龙乃至迦吒富单那等不受我教。我于彼等不得自在。是故于今五浊极恶白法损减。如来出世。一切众生于慈导师得生敬信尊重爱乐。佛所发言称机利益。具足功德智慧之聚得成大悲。六波罗蜜相应究竟所愿得满。获六神通于法自在。覆护摄受一切众生。能与众生一切善道及涅槃乐。今者于此本未曾有。昔来未闻如是大集。一切天王及与眷属皆来集会。一切龙王乃至日王夜叉王罗刹王阿修罗王乾闼婆王紧那罗王伽楼罗王摩睺罗伽王鸠槃茶王饿鬼王毗舍遮王。悉与眷属皆来集此。所未来者今愿世尊。以神通力尽皆摄之。若有诸恶鬼神无所系属。不受他教嗔恶粗犷无有慈愍。不观后世可怖畏事。残害他命饮血食肉。所不来者。惟愿世尊当复慈愍以神通力命彼鬼神及其眷属皆来至此。使得分布入他分中。不令数数恼乱众生。以此方便令四天下大地余味而不速灭。精气安住不复损减。以地精气不损减故。众生精气不损减。众生精气不损减故。正法甘露精气住不损减正法甘露精气不损减故。众生心法作善平等增长。以是因缘令三宝种得不断绝。如是如是。法眼久住。闭三恶道开于善趣及涅槃门。如是如是白法增长黑法损减。如是如是天人增长。无量天人悉得充足涅槃快乐。四天王等说是语时。世尊观察默然不言。尔时娑婆世界主大梵天王。憍尸迦及诸释天四大天王。皆共合掌告诸大众。我等咸白一切菩萨摩诃萨一切声闻。一切天龙夜叉罗刹乾闼婆阿修罗紧那罗伽楼罗摩睺罗伽饿鬼毗舍遮富单那等一切大众。愿悉劝请如来法尊。当使世尊令诸天众悉集于此。一切龙众乃至一切迦吒富单那等亦悉来集。彼等于阎浮提所有国土城邑村落寺舍园林山谷旷野河井泉池。如是等处游止住者分张付嘱。令彼一切诸善天龙乃至一切迦吒富单那分取安置。各自当分平等守护。不令纵舍不令生恼。各各教彼同行其法。常作善念折伏恶心。复令各各护持自分。而不纵舍不恼于他。彼若各各当分平等作护持者。名称流布得大勇猛获大福报。尔时一切菩萨摩诃萨一切声闻一切天龙夜叉罗刹阿修罗伽楼罗紧那罗乾闼婆摩睺罗伽鸠槃茶饿鬼毗舍遮富单那迦吒富单那。乃至一切诸来大众。欢喜踊跃从座而起。合掌向佛一时同声作如是言。我等劝请如来应供正遍知。愍我等故。利众生故。得大悲心。一切诸天乃至迦吒富单那悉令集此。彼等于此阎浮提中城邑村落乃至依止泉池住者。分张付嘱。令彼天龙乃至迦吒富单那分取安置。若彼诸天乃至迦吒富单那等。各舍己分犹作恼害。不遮恼他应当治罚而折伏之。愿佛发勇作大佛事。一切尽皆分张安置。尔时世尊说偈答曰

  于此佛法中　　无有恼他义
  度于苦彼岸　　诸处心平等
  诸法无有二　　导师舍憎爱
  一道如虚空　　此是佛境界
  若有有为心　　思惟去来事
  彼以法非法　　能摄鬼神来

尔时复有一大梵天名曰正辩。住第十地圣无上圣。以诸菩萨功德庄严在会而坐。此正辩天白诸天王一切龙王一切阿修罗王乃至一切迦吒富单那王作如是言汝等如是。今从如来得闻是义。如佛世尊。若行若住若坐若卧不恼众生。汝等今悉一时同声发愿悕求应当说言。所有非人一切天龙鬼神所摄。常食精气。恼害于他食肉饮血者。彼等一切愿护世四王力势折伏。所有化生湿生胎生卵生。如是随其所有诸龙夜叉罗刹阿修罗伽楼罗乾闼婆紧那罗摩睺罗伽鸠槃茶饿鬼毗舍遮富单那迦吒富单那一切等类四生所依。彼等悉为四大天王力所摄伏。愿四大王摄彼一切所不来者悉至于此

尔时一切天王乃至迦吒富单那王作是愿言。除三十三天已下所有四天王天及诸龙众。乃至迦吒富单那四生所依一切无余。悉愿依于四大天王。彼等四王力所摄伏。若有诸天乃至迦吒富单那等。于四天王如有违反一一王力不受教敕。即当为彼炽然铁轮截其耳鼻。若截耳鼻犹故违者。复令铁轮截彼手足。若截手足犹故违者。复斩其首。若有乃至违四天王教敕之者必令如是

尔时毗沙门天王。即以炽然焰赫铁轮向于北方而遥掷之。即说咒曰

多地夜他　穷穷尼逻穷(其凤反)　叉婆穷　伽佉伽伽　尼迦佉阇罗厕　苏婆呵

尔时毗楼博叉天王。亦以炽然焰赫铁轮。向于西方而遥掷之。复说咒曰

多地夜他　尸梨器　尸罗器　伽伽那　尸梨器　叉尸罗器底　阇梨　苏婆呵

尔时毗楼勒叉天王。亦以炽然焰赫铁轮。向于南方而遥掷之。即说咒曰

多地夜他　阇逻鼻唎师　阇啰鼻唎师　悉多婆　阇啰鼻唎师　达罗尸　阇逻阇啰　鼻唎师　苏婆呵

尔时提头赖吒天王。亦以炽然焰赫铁轮。向于东方而遥掷之。即说咒曰

多地夜他　阿那易(戈利反)阿那阿那耶　阿那浮毗　阿迦奢浮毗摩系(下帝反)都易　苏婆呵

尔时四方诸天。乃至迦吒富单那。及诸大小树林药草神等。遥见铁轮炽然焰赫。悉大惊惧愁忧不乐恐命不存。观十方已各作念言。谁当有能救于我等。为归为趣施我等命。即便观见大悲世尊。如实利益诸众生者。佉罗帝山牟尼诸仙所依住处。大众悉集围绕而坐。唯彼当能救我等命。即往佛所疾如电光。到佛前住。如是十方所有诸天乃至迦吒富单那等皆往佛所到已而住

尔时世尊欲重明此义。而说偈言

  时我两足尊　　问释梵四王
  为见为闻彼　　过去诸导师
  分布四天下　　为令天等护
  可不如我今　　道树下分布
  天王答我言　　如是昔诸佛
  坐于道树下　　分与夜叉等
  后因过及时　　转生诸杂恶
  鸠槃龙夜叉　　罗刹鬼单那
  穬恶无慈愍　　常食他肉血
  彼恼于诸国　　及恼四姓人
  非时作风雨　　及以寒热等
  饥馑病斗诤　　灭坏大地味
  无慈于一切　　恼害多众生
  莫能遮护者　　不伏于我等
  是以地精气　　众生精气没
  正法妙精气　　难得者日损
  时过因缘故　　天人等损减
  增长诸恶世　　法朋难可得
  法不久住世　　灭坏正法灯
  断绝三宝种　　世间当盲冥
  今佛大勇猛　　于白法尽时
  出现阎浮提　　大悲众生药
  中言具六通　　究了诸法岸
  利益众生故　　作此大集会
  一切天龙王　　护世等来集
  诸鬼恶无慈　　恒食他肉血
  龙鬼富单那　　彼等不来此
  无所受教令　　不依属他分
  一切受佛语　　令彼皆来集
  愿分于彼等　　各令有所嘱
  不令更恼害　　夺他精气等
  三种精气住　　令人修法行
  白法得增长　　黑法得消灭
  以是恶道息　　天人得增益
  解脱门得开　　三宝种炽然
  福流诸众生　　速能得解脱
  于时我嘿然　　不随于彼等
  梵王诸帝释　　四大护世王
  俱白一切众　　所来在会者
  劝请天人师　　摄诸鬼来此
  分张付嘱彼　　城邑诸村落
  昼夜常护持　　各令住自分
  菩萨等大众　　从座起合掌
  劝请大导师　　摄诸鬼来此
  一切分作分　　护持阎浮提
  勿恼于众生　　发勇人中上
  我不恼乱他　　远离去来事
  了知法无二　　离诸众生想
  正辩大梵王　　告诸天王言
  导师不恼他　　佛法无此事
  悉共发愿言　　令鬼不为害
  分布各依止　　彼四天王等
  诸王作是言　　我今依汝语
  誓敕于彼等　　悉令得作分
  若彼不依教　　速为轮所烧
  于时四天王　　使轮向四方
  乃至一时顷　　尽皆到佛所
  顶礼世尊足　　合掌于彼住

大集经卷第四十九大方等大集经卷第五十

        高齐天竺三藏那连提耶舍译

    月藏分第十四诸恶鬼神得敬信品第八之一

尔时护世四大天王。见无量阿僧祇天龙夜叉。乃至迦吒富单那等。种种色。种种形。种种欲。种种行。种种性。彼等于诸众生性无慈愍。嗔恶粗穬。不观后世畏。不入他分无所护持。数恼刹利乃至畜生。夺其精气。食其血肉。是诸鬼神俱来集已。时四天王欢喜踊跃。各自问其所领大将

毗沙门天王问散脂夜叉大将言。此四天下所有夜叉。若卵生胎生湿生化生。或依城邑聚落舍宅塔寺。园林山谷河井泉池。塳间树下旷野田中。闲林空舍大海宝洲。若地行水行空行一切无余。今悉来集世尊所不。散脂大将言。大王。此四天下所有夜叉。乃至大海宝洲。若地行水行空行一切无余。今悉来集在世尊所

提头赖吒天王问乐欲乾闼婆大将言。此四天下所有乾闼婆余如上说。毗楼勒叉天王问檀帝鸠槃荼大将言。此四天下所有鸠槃茶余如上说

毗楼博叉天王问善现龙王言。此四天下所有诸龙摩睺罗伽伽楼罗诸饿鬼等。若卵生胎生湿生化生。若依城邑聚落舍宅。乃至大海宝洲。若地行水行空行一切无余。今悉来集世尊所不。善现龙王言。大王。此四天下所有诸龙乃至饿鬼一切无余。今悉来集在世尊前

尔时四大天王。释提桓因。娑婆世界主大梵天王。正辩梵天。合掌向佛一心敬礼而作是言。大德婆伽婆。此四天下所有天龙乾闼婆紧那罗夜叉罗刹鸠槃茶毗舍遮摩睺罗伽伽楼罗诸饿鬼等。若卵生胎生湿生化生。若地行水行空行一切无余。今悉来集在世尊所。我等受诸大智人语劝请如来。惟愿世尊。哀愍我等诸众生故。令恶众生得敬信故。为正法眼得久住故。绍三宝种不断绝故。令地精气众生精气正法精气久住增长故。又令善道及涅槃道八真圣道常不灭坏及增长故。世尊。此阎浮提所有城邑聚落舍宅乃至宝洲一切无余。天龙夜叉乃至迦吒富单那等。随其所宜分布付嘱。令护持故。今此大集一切天王。一切龙王乃至毗舍遮王。各将眷属皆悉来集。以彼一切付嘱是等。令其教授忆念摄受同行其法。令彼诸天乃至迦吒富单那等。各于己分护持养育。勿自纵舍亦莫恼他。见恼他者令其遮护不得纵舍。令彼各于己分发大勇力正护养育。若彼发大勇力应生欢喜。彼则喜乐。名称流布获大福报。尔时世尊受其劝请。慈悲怜愍彼等众故。遍观一切诸来大众。即举右臂而作是言。汝等贤首一切大众。各各谛听。我当解说。佛出世难如优昙花。离八难难如顺时香树。闻正法难如雨阎浮檀金。遇戒定僧为供养难如诣大海宝洲。于三宝所得净信难如求如意珠。值遇三宝为布施难如求功德天贤瓶。受持戒难如牛头栴檀洲难可得到。于众生所起悲愍难。如值勇健怨贼执金刚杵难可得度护身命。知足难如善作阿湿婆迷陀耶若(阿湿婆者齐云马也迷陀者宝柱也耶若者祀也为此祀者唯阎浮提王之所能也)

诸贤首。有十种平等。若有众生具此平等。于流转时恒受胜报。速能得入无畏大城。何等为十。一者众生平等。二者法平等。三者清净平等。四者布施平等。五者戒平等。六者忍平等。七者精进平等。八者禅平等。九者智平等。十者一切法清净平等

诸仁者。于彼何者众生平等。众生者。谓三界所有一切众生。若有众生自爱己身。欲得活命求乐离苦。应如是学。若有丈夫寿者作业。若善不善自作教他现见受报。是故诸仁者。若求乐离苦。彼应如是。若身口意作诸善业不作恶业。若此身若后身自益益他。自善善他不作恶业。诸仁者。是名众生平等

诸仁者。于彼何者法平等。法者若有众生。求乐离苦欣生畏死。恩爱不离怨憎不会。如此之人心海所溺。何以故。若有众生。计着我者生死流转。不见清净解脱道故。是故于法平等思惟观察。不离众生有法。不离法有众生。如众生体性即是我体性。如我体性即是一切法体性。如一切法体性即是佛法体性。如是观诸法平等时。众生即阴不可得。离阴不可得。和合不可得。离和合亦不可得。非法非非法。是人如是得住无相。是名法平等。诸仁者。于彼何者清净平等。谓得人身具满十德。何等为十。一者离下贱家。二者不钝。三者不哑。四者诸根不缺。五者得男子身。六者颜容端正。七者得好眷属。八者不贫。九者不为他欺发言有中。十者多人瞻仰。何以故。言得人身名清净平等。如得人身故得三律仪离三恶道。能求三乘三种菩提随所而得。云何清净平等。若人能得菩提于一切法心无所依。于一切内外境界心无所依。是人不依一切法。于如如无所取。见一切法不取内心不取外心。于二境界极得寂定。是人如是正见清净法时。不见内外有众生。命者。寿者。生者。人者。众数。养育。作者。使作者。起者。使起者。受者。使受者。知者。见者。是人如是于诸众生得见无我清净平等。无众生无命无我。离欲清净不起边见。如是得入众生清净平等。如是得入一切法空。无行智印无相无愿。如是得入众生清净平等。是人以彼法成熟众生。而不坏我。亦不坏事及不坏财。若知一切众生体性平等。则知一切法体性。若一切法体性。即是佛法体性。是名一切法平等佛法。是名清净平等

诸仁者。于彼何者布施清净平等。诸仁者。以四种布施清净平等。以布施故。众生于流转时恒受胜报。速能得入无畏大城。何等为四。一者于一切众生起怜愍心。二者平等心。三者大慈心。四者大悲心。此为四种布施清净平等。众生于流转时恒受胜报。速能得入无畏大城

诸仁者。于彼何者于一切众生起怜愍心清净平等。若有众生。求乐离苦。恩爱不离。怨憎不会。欲得长寿利养名称富贵五欲。应如是学。如我爱欲喜重自己身命无有厌足。以一切方便无上护持无有价量。如是于一切众生。一一众生乃至虫蚁。爱欲喜重自己身命无有厌足。以一切方便无上护持无有价量。我何故于他众生于他寿者。作恼作害。夺活命具。离其命根。坏其命根。若我于他众生于他寿者生恼离命。以离一一命故。我当亿百千世于世世中还彼离命受诸苦恼。我从今日于诸众生。起父母想及男女。想乃至虫蚁亦作父母及男女想。更不恼害他命。亦不夺他活命之具。不离坏命。亦不教他夺其精气及断命根。如是我当亿那由他千百劫流转生死于世世中受身命时。无能恼害夺活命具及离坏命者。何以故。一切众生。无有非我父母兄弟男女等者。如是我于一切众生无有非其父母兄弟男女等者。以是因缘我曾与一切众生亲。一切众生曾与我亲我若于亲而生恼者。是所不应。所谓恼者。我若触恼刹利。令彼刹利于己境界国土人民。于诸所欲不生知足。及婆罗门乃至畜生。触恼其心令不知足。以是因缘共相战斗诤论讥毁诉讼谄诳妄语。互相支解及断命根。是故我今于诸众生休息触恼及断命根。我以此布施清净平等因缘故。于流转时无能触恼。共我斗战诤论讥毁诉讼谄诳妄语支解断命。是名触恼

于彼何者害命。彼应如是学。一切众生与我亲。我与一切众生亲。我若害众生命是所不应。我若作非时风雨亢旱灾雹雨尘闇曀枯涸诸水损减花果药草众味。以是因缘众生饥渴。四大增动生种种病。因其病故而取命终。是故我于一切众生休息害命。以休息故。地味精气不复隐没。以是因缘令诸众生离于饥渴。四大不动诸病不生。不因于彼而取命终。我以此布施清净平等。乃至于流转时。我更不受饥渴病苦。是名害命

于彼何者活命之具。彼所资身命者。应如是学。一切众生与我亲。我与一切众生亲。我若于彼夺活命具。是所不应。若夺众生花果药草五谷精气活命具者。令彼众生食恶花果药草五谷众味精气。令其身心损瘦无力失念嗔恶轻躁粗横恶色多病。是故我当随顺过去诸天仙教。于一一花果众味精气六十四分中。取一分精气以活身命。余六十三分留活众生令受安乐。我今以是知足因缘。乃至于流转时。我更不食无味精气残害之食。具大威力强记软心好色无病。是名活命之具。于彼何者离别命。若以恶心视诸众生。气嘘其身散乱其心。于彼节节夺其精气。夺精气故令其身心为苦所恼。应如是学。我与一切众生亲。乃至是所不应。我若于亲恶心视之。气嘘其身散乱其心。于身支节夺其精气。故令我亲身心得苦。以是因缘乃至于流转时。无有非人恶心视我。亦不气嘘我身散乱我心。不夺精气是名离别命

于彼何者坏命。若诸众生为自食故。割截支节尽夺精气。山木高处深水大河推令堕落。若与毒药使起尸鬼。若作厌蛊及余物害。若断饮食。或斩其首以断命根。以是因缘汝等若自爱己欲得长寿求乐离苦。名称富贵及求解脱。应如是学。我与一切众生亲。一切众生与我亲。若我为自食故。夺其精气割截支节乃至斩首。是所不应。以此因缘乃至于流转时。无能斩首坏我命者。是名坏命。此是清净平等。诸仁者。若复怜愍一切诸众生故。为之积集功德智慧。断除一切虚诳幻见。得坚固勇猛求一切善如说修行。为命因缘于他众生不起恶念。于诸众生不起害心。所持禁戒与众生共。见众生乐深生欢喜。于己乐缘自能知足。一切爱事无不能舍。于一切法无吝惜心。常怖三界于诸忍事力能堪受。信无常相能如说行。于己有失能自观察。见他有失则生悲愍。于诸善法无有厌足。常发露忏悔得无边回向能求深法。于诸众生作福田心。求厌离智。于三界狱流转烦恼能得怖畏。勤息众生一切苦恼。能求一切佛法。能发休息诸恶道心。于一切法善得安住。诸仁者。是名世间清净平等

诸仁者。我今当说第一义清净平等。作是说已。即说咒曰

多地夜他　夜咩夜咩　钵罗佉夜咩　优钵啰佉夜咩　耶夜咩佉夜夜咩　苏婆呵

说此法门时。八百六十万紧那罗乾闼婆等。远尘离垢得法眼净

尔时世尊。复说咒曰

多地夜他　瞿竭[口*梨]　夜婆瞿竭[口*梨]　忧婆夜婆　瞿竭[口*梨]　苏婆呵

尔时世尊。复说咒曰

多地夜他　陀罗婫陀罗陀婫　忧跛陀罗　陀罗陀婫　苏婆呵

说此法门时。九百四十万夜叉。远离尘垢得法眼净

尔时世尊。复说咒曰

多地夜他　阿阇泥　叉叉阇泥　伽叉叉阿阇泥　毛啰阿阇泥　叉差苏婆呵

说此法门时。七千万龙。于远尘离垢法而得三昧

尔时世尊。复说咒曰

多地夜他　呵呵呵呵呵呵　系杅婆　呵呵呵　视若视若视若　呵呵呵　苏婆呵

说此法门时。三百万那由他阿修罗得不忘菩提心三昧

尔时世尊。复说咒曰

多地夜他　阿奴那　阿那蒱那　阿婆那奴那　阿婆矣[口*梨]夜　阿婆那奴那　苏婆呵

说此法门时。八万四千频婆罗鸠槃茶得喜乐三昧

尔时世尊。复说咒曰

多地夜他　陀伽陀阇　阿婆陀伽陀阇　阿婆伽陀阇阇　揵陀揵陀阇　苏婆呵

说此法门时。七十万那由他饿鬼毗舍遮富单那迦吒富单那。得电王三昧。过诸数量天龙夜叉乃至迦吒富单那等昔未曾发无上菩提心者。皆悉发心诸仁者是名第一义布施清净平等

诸仁者。于彼何者戒清净平等。若一切世间若出世间。善道及涅槃乐。戒为根本能安住声闻辟支佛地。能安住阿耨多罗三藐三菩提智。此戒清净平等。所谓十善业道。休息杀生偷盗邪淫妄语两舌恶口绮语贪嗔邪见。诸仁者。休息杀生获十种功德。何等为十。一者于诸众生得无所畏。二者于诸众生得大慈心。三者断恶习气。四者少诸病恼为事决断。五者得寿命长。六者为非人护持。七者寤寐安隐无诸恶梦。八者无诸怨仇。九者不畏恶道。十者身坏命终得生善道。诸仁者。是名休息杀生得十种功德。若能以此休息杀生善根回向阿耨多罗三藐三菩提。是人不久证无上智。彼人到菩提时。于彼国土离诸害仗长寿众生来生其国

休息偷盗获十种功德。何等为十。一者具大果报为事决断。二者所有财物不共他有。三者不共五家。四者众人爱敬无有厌足。五者游行诸方无有留难。六者行来无畏。七者以乐布施。八者不求财宝自然速得。九者得财不散。十者身坏命终得生善道。诸仁者。是名休息偷盗得十种功德。若能以此休息偷盗善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人到菩提时。于彼国土具足种种花果树林衣服璎珞庄严之具。珍奇宝物无不充满

休息邪淫获十种功德。何等为十。一者得诸根律仪为事决断。二者得住离欲清净。三者不恼于他。四者众人喜乐。五者众人乐观六者能发精进。七者见生死过。八者常乐布施。九者常乐求法。十者身坏命终得生善道。诸仁者。是名休息邪淫得十种功德。若能以是休息邪淫善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人到菩提时。于彼国土无有生臭。亦无女根。不行淫欲皆悉化生。休息妄语获十种功德。何等为十。一者众人保任所言皆信。二者于一切处乃至诸天发言得中。三者口出香气如优钵罗花。四者于人天中独作证明。五者众人爱敬离诸疑惑。六者常出实语。七者心意清净。八者常无谄语言必应机。九者常多欢喜。十者身坏命终得生善道。诸仁者。是名休息妄语得十种功德。若能以此休息妄语善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人到菩提时。于彼国土无有生臭。众妙宝香常满其国

休息两舌获十种功德。何等为十。一者身不可坏平等。二者眷属不可坏平等。三者善友不坏平等。四者信不坏平等。五者法不坏平等。六者威仪不坏平等。七者奢摩他不坏平等。八者三昧不坏平等。九者忍不坏平等。十者身坏命终得生善道。诸仁者。是名休息两舌得十种功德。若能以此休息两舌善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人到菩提时。于彼国土所有眷属一切魔怨及他朋党。所不能坏

休息恶口获十种功德。何等为十。一者得柔软语。二者捷利语。三者合理语。四者美润语。五者言必得中。六者直语。七者无畏语。八者不敢轻陵语。九者法语清辩。十者身坏命终得生善道。诸仁者。是名休息恶口得十种功德。若能以此休息恶口善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人到菩提时于彼国土法声充遍离诸恶语

休息绮语获十种功德。何等为十。一者天人爱敬。二者明人随喜。三者常乐实事。四者不为明人所嫌共住不离。五者闻言能领。六者常得尊重爱敬。七者常得爱乐阿兰若处。八者爱乐贤圣默然。九者远离恶人亲近贤圣。十者身坏命终得生善道。诸仁者。是名休息绮语得十种功德。若能以此休息绮语善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人得菩提时。于彼国土端正众生来生其国。强记不忘乐住离欲

休息贪欲获十种功德。何等为十。一者身根不缺。二者口业清净。三者意不散乱。四者得胜果报。五者得大富贵。六者众人乐观。七者所得果报眷属不可破坏。八者常与明人相会。九者不离法声。十者身坏命终得生善道。诸仁者。是名休息贪欲得十种功德。若能以此休息贪欲善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人得菩提时。于彼国土离于魔怨及诸外道

休息嗔恚获十种功德。何等为十。一者离一切嗔。二者乐不积财。三者众圣喜乐。四者常与贤圣相会。五者得利益事。六者颜容端正。七者见众生乐则生欢喜。八者得于三昧。九者得身口意光泽调柔。十者身坏命终得生善道。诸仁者。是名休息嗔恚得十种功德若能以此休息嗔恚善根回向阿耨多罗三藐三菩提。是人不久得无上智。彼人得菩提时。于彼国土所有众生悉得三昧。来生其国心极清净

休息邪见获十种功德。何等为十。一者心性柔善朋侣贤良。二者信有业报乃至夺命不起诸恶。三者敬信三宝设为活命不信天神。四者得于正见不怪异事。亦不简择良日吉时。五者常生人天离诸恶道。六者常乐福德明人赞誉。七者弃俗礼仪常求圣道。八者离断常见入因缘法。九者常与正趣正发心人共相会遇。十者身坏命终得生善道。诸仁者。是名休息邪见得十种功德。若能以此休息邪见善根回向阿耨多罗三藐三菩提。是人速满六波罗蜜。于善净佛土而成正觉。得菩提已于彼佛土。功德智慧一切善根庄严众生来生其国。不信天神离恶道畏。于彼命终还生善道。诸仁者。于彼行布施清净平等时。于戒休息杀生。修平等行。具大清净平等果报。得于长寿离诸怖畏

彼行布施清净平等时。于戒休息偷盗修平等行。具大清净平等果报。不共他有。修一切善无有留难

彼行布施清净平等时。于戒休息邪淫修平等行。具大清净平等果报。修习善根无有留难。无邪淫念观自他妇。彼行布施清净平等时。于戒休息妄语修平等行。具大清净平等果报。不被毁谤。发心坚固如说修行。于天人中独作证明。口出香气如优钵罗花。彼行布施清净平等时。于戒休息两舌修平等行。具大清净平等果报。得不坏眷属丈夫眷属敬信眷属

彼行布施清净平等时。于戒休息恶口修平等行。得微妙音不闻恶声

彼行布施清净平等时。于戒休息绮语修平等行。具大清净平等果报。发言得中断一切疑。众生乐见

彼行布施清净平等时。于戒休息贪欲修平等行。具大清净平等果报。受果报已还复能舍。受解脱果具大势力

彼行布施清净平等时。于戒休息嗔恚修平等行。具大清净平等果报。颜容端正众人爱敬。为事无碍诸根不缺

彼行布施清净平等时。于戒休息邪见修平等行。具大清净平等果报。正见国土正见家生。常值诸佛菩萨声闻。见佛闻法供养众僧。修菩提行。常不舍离清净平等

诸仁者。此是戒清净平等。以是戒清净平等自庄严者是人不久成佛功德。具足相好音声清净。降诸魔怨得清净平等。是人不久得一切佛法禅念慧行清净大智大慈大悲。乃至能满一切佛法清净平等。是名世间戒行清净平等处

诸仁者。于彼何者出世间戒行清净平等处。若于戒三摩跋提信解行者。不依色阴持戒。不依受想行识阴持戒。不依眼不依色。不依眼识不依眼触不依眼触因缘生。受爱取有生持戒。乃至不依意不依法不依意识。不依意触不依意触因缘生。受爱取有生持戒。不依地界持戒。不依水火风界持戒。不依无边虚空入持戒。乃至不依非想非非想入持戒。不依欲界色界持戒。不依现世后世持戒。不依声闻乘辟支佛乘一切种智持戒。不依闻不依禅不依智持戒。不依听力不依三昧力。不依陀罗尼力不依忍力。不依有漏力不依无漏力。不依有为界力。不依无为界力。不依善不善力。不依明闇力持戒。诸仁者。是名出世间戒清净平等处。是名修戒梵路圣道。能入无上无畏大城。众圣所依戒清净平等。以护第一义清净戒故。能入净智。戒者是何义。譬如大铁围金刚山间热恼之风。以山障故不令得至四天下。如是学圣清净平等戒。爱热之风。修四念处故不令得起。以是义故名之为戒。譬如大铁围山间臭秽之风。以山障故不令得至四天下。如是护圣清净平等戒。以四无所畏故爱取臭秽不令得起。以是义故名之为戒。譬如大铁围山间黑闇。以山障故不得至四天下。如是护圣清净平等戒。无明有为有漏相。修七觉分故不令得起。以是义故名之为戒。离欲义是戒义。解脱义是戒义。休息义是戒义。无尽义是戒义。灭义是戒义。此诸句义名为戒义。诸仁者。是名有为无为戒清净平等。若有世间沙门婆罗门。住此有为无为清净平等戒者。彼人名为世间福田。若有于彼敬信尊重护持养育。给施衣服床褥卧具饮食汤药一切所须。是人以此善根乃至于流转时恒受胜报。速能得入无畏大城。诸仁者。于彼何者忍清净平等。忍有二种。一者舍忍。二者息怒忍。诸仁者。于彼何者舍忍。若有众生。求一切乐息一切苦。是名舍忍清净平等。若复有人求乐离苦。彼人观于三界一切苦道烦恼毒热。唯除圣人。是人为己利故生大怖畏。如是怖畏。观于三界一切炽然。为诸烦恼大火所烧。一一众生为诸苦害。驱驰流转不能自脱。如彼为苦所逼未得解脱。我亦如是为苦所逼。以何方便能自脱苦。即作是念。不以余事我以舍忍解脱诸苦令具诸乐。作是念已。即便起发。以忍知足。能舍种种资身之具。所谓饮食衣服卧具屋宅象车马乘。随其所须皆悉给与。是人以忍布施欲灭诸苦。是人数数修忍知足。住时能行舍施于正。趣正行人应往其所。亲近供养随顺其教。以供养故如是如是闻于种种生死过患涅槃利益。是人或于声闻乘发心。或于缘觉乘发心。或于大乘发心。为己乐故。复增忍知足护养众生。是名舍忍清净平等。乃至舍外资财及自己乐。忍受诸苦令他得乐。是名舍忍清净平等。若见乞人种种形色。种种威仪。种种音声。种种嗔怒。种种骂辱。种种欺陵。种种粗穬不喜之言。来从求索。是人如是如是。心未调柔。嗔恚未净。未住净忍。彼作是念。谁能胜我。何以故。彼食血肉。诸恶夜叉罗刹鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。未闻生死苦恼涅槃功德。不观后世畏众苦所恼。未得解脱一切诸苦。何以故。彼等离善知识不闻正法。故在生死为苦所溺。我已数数得闻生死苦恼涅槃功德。观后世畏勤息诸苦。近善知识得闻正法。我今欲度生死沉溺。何故起嗔。是故我应作是思惟。骂辱音声及诸违事皆悉如风。我当弃舍不应起嗔。如是于诸众生。欲舍种种想。一切文字语言分别皆悉如风。于诸众生离种种想。修忍清净平等。是人数数于诸众生。舍种种想一切文字分别想。修忍清净平等。如是如是。是人心则住忍清净平等得喜得净。如是如是。是人修四无碍法无碍义无碍辞无碍乐说无碍。是人数数修法无碍乃至乐说无碍。是人则能舍身皮肉筋骨眼耳鼻舌手足头等所爱之命。是菩萨摩诃萨。修分别无分别忍清净平等。是名菩萨舍忍清净平等

诸仁者。于彼何者息怒忍清净平等

诸仁者。若菩萨摩诃萨。能于一切言语音声文字。舍分别想。及一切色身形相。举动威仪。去来意业戏笑。舍分别想。亦舍一切爱取所摄。不求果报离于苦乐。无分别想乃至于己身命分别无分别想。得住第一义忍清净平等。譬如虚空。于明于闇不嗔不喜不分别。如是菩萨摩诃萨。住第一义忍清净平等。一切有为行戏笑。言语文字形色苦受乐受。离分别。分别不嗔不喜。菩萨于彼众生。离分别想。得住第一义忍清净平等。譬如虚空不动不正遍动不震不正遍震。如是菩萨摩诃萨。于一切业有为诸行。身心不动不正遍动。亦复不震不正遍震。譬如虚空清净离垢。如是菩萨摩诃萨。住第一义忍清净平等。于彼一切有为身心。善得清净。譬如虚空长养一切众生。如是菩萨摩诃萨。住第一义忍清净平等。养育一切众生。譬如虚空不为劫火所能烧坏不为劫水劫风所坏。如是菩萨摩诃萨。若住第一义忍清净平等。乃至未到无上菩提。不为贪嗔痴等毁坏其心。譬如清净虚空十五日夜极圆满月普放冷光。令热恼众生身心凉乐。如是菩萨摩诃萨。住第一义忍清净平等以身口威仪。休息众生诸烦恼热。譬如清净虚空十五日夜极圆满月众星围绕临四天下光明照耀。如是菩萨摩诃萨。住第一义忍清净平等。随所住处。常为天龙乃至迦吒富单那等之所围绕。晖显照曜。譬如清净虚空十五日夜极圆满月照海岛上。月爱摩尼从彼珠中。流出大水能满大海。如是菩萨摩诃萨。住第一义忍清净平等。所有天龙夜叉罗刹鸠槃茶饿鬼毗舍遮富单那迦吒富单那。粗穬嗔恶无有慈愍。于诸众生不观后世畏。是菩萨。以第一义忍清净平等。放胜光明。照耀一切天龙夜叉罗刹乃至迦吒富单那等。以是令彼天龙夜叉乃至迦吒富单那等。悉得清净善心。于诸众生起慈悲心。利益心。休息众生苦恼心。令住一切乐心。观后世畏心。离一切恶心。于一切善法起大精勤心。以是彼等极得清净心。乃至于一切善法。发大勇猛心。彼等次第渐离一切不善。悉得充足一切善根。能满大涅槃海。诸仁者汝等应当观此菩萨。虽未至究竟。以住第一义忍清净平等故。已得超过声闻缘觉。以第一义忍成熟众生。如我昔作忍辱仙人。常在林中食诸甘果。时有国王名曰迦利。支解我身而为八段。我于彼时。以能善修第一义忍故。从所割处流出白乳。以是忍辱苦行因缘。成熟无量亿那由他百千天龙夜叉罗刹乾闼婆阿修罗紧那罗摩睺罗伽伽楼罗饿鬼毗舍遮富单那迦吒富单那等。彼时无量亿那由他百千人非人等。悉发阿耨多罗三藐三菩提心。我昔为人生非难处。作此苦行不足为难。诸仁者。汝等谛听。如我往昔生在难处。受于兔身止住林中。为令仙人得于食故。即自踊身投大火聚。以能善修第一义忍清净平等故。令彼火聚变成莲池。净水盈满。我于尔时卧花台上。以是苦行因缘。令此三千大千世界六种震动。尔时无量释梵四王。天龙夜叉乃至迦吒富单那等。及诸仙人人非人等。以种种供具供养于我。作是愿言。汝得阿耨多罗三藐三菩提时。当与我等授阿耨多罗三藐三菩提记。我昔兔身。以能善修第一义忍清净平等。是忍不共声闻缘觉。我于往昔作兔身时。梵释天王护世四王天龙夜叉乃至人非人等。悉以种种香花涂香末香种种宝珠宝幢幡盖众妙音乐。尊重赞叹。生未曾有。而作供养。今阿罗汉之所无也。诸仁者。如是菩萨。善修第一义忍清净平等。诸仁者。是第一义忍清净平等。是何句义。第一义者。谓到生死彼岸故名第一义。忍者见三界阴究竟空。及见一切界入究竟空。故名为忍。清净者。谓以圣慧。除净三界诸烦恼道业道苦道。故名清净。平等者。谓以圣慧。如实知一切三界行一切法性如如实际。如实知非如实际非非如实际。断一切烦恼道。故名平等。诸仁者。是名菩萨第一义忍清净平等

诸仁者。于彼何者精进清净平等。以精进能与布施清净平等作因。是名精进清净平等。乃至以精进能与般若清净平等作因。是名精进清净平等。以精进能舍一切见。以精进能与四念处清净平等作因。以精进能超过一切声闻缘觉。以精进能与四正勤四如意足作因。以精进能舍一切烦恼。以精进能与四摄事。四无碍辩。四梵住。四无色定。五根五力。七觉分八圣道分。九次第定。如来十力。十二善有支。十八不共法作因。以精进能与大慈大悲般若清净平等作因是名精进清净平等。以精进能与成熟众生清净平等作因。是名精进清净平等。以精进为集无量佛法种种善根。乃至能集无量方便智无量胜愿。习无量功德智慧。与无量种种众生有生取作因。是名精进清净平等。以精进居兜率天宫。观其时节一生补处。乃至以精进舍彼宫殿。了了知入母胎。乃至以精进于蓝毗尼林。从母右胁安隐而出。乃至以精进行于七步。震动大地诸山大海。乃至以精进受难陀忧波难陀龙王灌水洗浴。乃至以精进童子游戏示现一切工巧。乃至以精进处在宫中五欲不染。乃至以精进夜半踰城往诣闲林。乃至以精进诣忧陀罗迦罗茶迦罗摩仙人所而修供养。乃至以精进六年苦行。乃至以精进于阿耨多罗三藐三菩提而成正觉乃至以精进转于法轮。无量人天为证。是名精进清净平等。我以精进今于佉罗帝山牟尼诸仙所依住处。作此大集。十方所有菩萨摩诃萨有如佛土微尘数众。悉令集此。有如佛土微尘等数。诸天龙夜叉罗刹乾闼婆阿修罗摩睺罗伽伽楼罗紧那罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。悉来大集为闻法故。是名精进清净平等。诸仁者以四大海水分为渧数。如彼渧数。具修精进清净平等。能令菩萨摩诃萨等满足毗梨耶波罗蜜。是名精进清净平等

大集经卷第五十

大方等大集月藏经卷第五

        高齐天竺三藏那连提耶舍译

    诸恶鬼神得敬信品第八上

尔时护世四大天王。见于无量阿僧祇众。天龙夜叉乃至迦吒富单那等。种种色种种形种种欲种种行种种性。彼等众生性无慈愍。于诸众生常起嗔恚恼害之心。不观后世可怖畏事。无所系属无所护持。是等恒常触恼刹利乃至畜生。夺其精气食其血肉。是四天王见诸鬼神俱来集已。欢喜踊跃各自问其所领大将。毗沙门天王问于散脂夜叉大将言。此四天下。一切所有夜叉罗刹。若卵生胎生湿生化生。或依城邑聚落舍宅塔寺园林山谷河井泉池陂泺冢间树下旷野田中闲林空舍。及大海内众妙宝洲。彼诸鬼神。若在地行水行空行一切无余。今悉来集世尊所不。散脂大将言。大王。如王所言。此四天下。所有夜叉。乃至大海宝洲。若地行水行空行。一切无余今悉来集在世尊所。提头赖吒天王问于乐欲乾闼婆大将言。此四天下一切所有乾闼婆众余如上说。毗楼勒叉天王问于檀帝鸠槃茶大将言。此四天下一切所有鸠槃茶众余如上说。毗楼博叉天王问于善现龙王言。此四天下所有龙众摩睺罗伽迦楼罗诸饿鬼等。若卵生胎生湿生化生。或依城邑聚落舍宅。乃至海内众妙宝洲。若在地上水中空中。所游行者。一切无余今悉来集世尊所不。善现龙王言。大王。如王所言。此四天下所有诸龙乃至饿鬼。一切无余今悉来集在世尊所。尔时四大天王。释提桓因。大梵天王。正辩梵天。合掌向佛而作是言。大德世尊。此四天下所有天龙乾闼婆紧那罗夜叉罗刹鸠槃荼毗舍遮摩睺罗伽迦楼罗诸饿鬼等。若卵生胎生湿生化生所有地行水行空行。一切无余今悉来集在世尊所。我等大众皆同劝请。唯愿如来。哀愍我等。慈悲一切诸众生故。令恶众生得敬信故。令正法眼得久住故。绍三宝种不断绝故。彼地精气众生精气正法胜味甘露精气令得久住利益增长故。又令善道及涅槃道常不灭坏利益增长故。大德世尊。此阎浮提一切城邑聚落舍宅。乃至宝洲一切无余。天龙夜叉乃至迦吒富单那等。今悉来集。天王龙王乃至毗舍遮王。悉将眷属亦皆来集。唯愿世尊付嘱此王。同行其法忆念摄受。令彼天龙夜叉罗刹。乃至迦吒富单那等。各有所属随于己分养育护持。恒常不舍莫令恼他。见恼他者令其遮护常不舍离使得安隐。若彼各各于其己分劝发勇力平等护持。彼等则得喜乐名闻多受福报。尔时世尊受其劝请。慈悲怜愍彼一切故。遍观大众观大众已。举其右臂而作是言。汝等贤首。一切大众各各谛听。我当解说。佛出世难如优昙华。离八难难如顺时香树。闻正法难如雨阎浮檀金。遇戒定僧得供养难。如入大海诣妙宝洲。信敬三宝难如求如意珠。布施三宝难。如求功德天贤瓶受持戒难如牛头栴檀国难可得到。于众生所起慈悲难如值勇健怨贼执金刚杵难得脱免。谨慎知足难。如善作马祀(梵语阿湿婆迷陀耶若此云马宝柱祀为此祀者唯阎浮王之所能也)。诸仁者。有十种平等。若诸众生具十平等。于生死中恒受胜报。速能得入无畏大城。何等为十。一者众生平等。二者法平等。三者清净平等。四者布施平等。五者戒平等。六者忍平等。七者精进平等。八者禅平等。九者智平等。十者一切法清净平等。诸仁者于彼何者是众生平等。若有众生。为求身命受乐离苦应作是见。若受者作业。若身口意。若善不善。自作教他。彼受现报及后世报。是故汝等。若欲离苦求二世乐。应当造作身口意善。莫起诸恶。若求二世自益益他自乐乐他自好好他勿作诸恶。此是众生平等。诸仁者。于彼何者是法平等。若有众生。求乐离苦欣生畏死。恩爱不离怨憎不会。如此之人心海所溺。何以故。若有众生。计着我者生死流转。不见清净解脱道故。是故于法平等思惟观察。众生不离法。法不离众生。若众生体性即是我体性。若我体性即是一切法体性。若一切法体性。即是佛法体性。若如是观诸法平等。是人得无所有不见众生。亦无众生去来合散。亦不见有众生可得非法非非法。是人如是得住无相。此是法平等。诸仁者。于彼何者是清净平等。谓得人身具满十德。何等为十。一者离下贱家。二者不钝。三者不哑。四者诸根不缺。五者得男子身。六者颜容端正。得好眷属。七者不贫。八者不为他欺。九者发言有中。十者多人乐见。何以故。言得于人身清净平等。如得人身得三律仪离三恶道能求三乘。以此则得三种菩提。不以余法。云何清净平等能到菩提。是人令心不依诸法。令心不依内外境界。不依如如见。一切法无和合相。不取内心不取外心。于二境界极得寂定。如是清净正见理时。不见有我内有众生。外有命者寿者。生者人者。众数养育。作者使作者。起者使起者。受者使受者。知者见者。此十六名皆出妄想。是人如是于诸众生。得见无我清净平等。以是义故离欲清净不起边见。如是得入众生清净平等。及诸法空无行智印无相无愿。如是得入众生清净平等。复以彼法成熟众生。而不自坏亦不坏财。若知众生体性平等。则知一切法体性平等。若一切法体性平等。即是佛法体性平等。是故一切诸法名为佛法。此是清净平等。诸仁者。于彼何者是布施清净平等。谓四种心清净布施。以布施故。众生于流转时恒受胜报。速能得入无畏大城。何等为四。一者于一切众生起怜愍心。二者平等心。三者大慈心。四者大悲心。怜愍心清净平等者。若有众生。求乐离苦恩爱不离怨憎不会。长寿利益名誉流转富贵五欲悉称心者。应如是学。如我喜乐爱欲自己身命。以一切方便无上护持。无有价量。如是于一切众生。一一众生乃至虫蚁。亦皆喜乐爱欲自己身命。一切方便无上护持。无有价量。我若恼害众生。若复夺他活命之具及断命根。我于亿百千世生死流转。还被恼害失活命具。及断命根受无量苦。我从今日于诸众生。起父母想及男女想。乃至虫蚁亦作父母及男女想。是故更不恼害众生。亦不夺彼活命之具及断命根。亦不教他夺人精气及断命根。如是我当亿那由他百千万劫。生死流转无能恼害。亦不被夺活命之具。及断命根。何以故。一切众生。无一众生非我父母兄弟男女如是我于一切众生。无一众生非是父母兄弟男女。以是义故。我曾与彼一切众生无非是亲。一切众生亦曾与我无非是亲。若于父母乃至男女作恼害者。是义不然。诸仁者。于彼何者是不触恼。若诸众生。求乐离苦应如是学。我若于刹利触恼其心。令彼刹利于己境界国土人民。本所欲者不生喜乐。及婆罗门乃至畜生。触恼其心。本所欲者不生喜乐。以是因缘递相征伐。斗乱诤讼。胆佞妄语。互相支解及断命根。以是因缘我从今日于诸众生休息恼害及断命根。以此清净平等布施业因缘故。我当久远生死流转。无能触恼共我斗乱诤讼及断命根。以是义故。名不触恼。诸仁者。于彼何者是不害命。若诸众生。求命不害应如是学。一切众生无非我亲。我若暴雨或非时雨。若雨灰尘令多闇[目*壹]。或久亢旱枯涸流泉。令诸华果药草五谷众味损减。以是因缘。令我亲知饥馑困苦。动其四大发种种病。乃至命终。若加此害是义不然。以是义故。我于众生远离害命。以不令彼地味精气有损减故。使我亲知无饥馑苦。不动四大种种病生及不横死。以是清净平等布施。乃至久远生死流转。不受饥馑病死等苦。以是义故名不害命。诸仁者。于彼何者非是夺他活命之具。若诸众生。求身命者应如是学。一切众生无非我亲。我若夺其花果药草五谷精气活命之具。彼诸众生。若以食彼无好精气。花果药草五谷味故。其身损瘦无有势力。失念恶性轻躁粗犷。萎黄少色生种种病。若加此苦是义不然。是故我应受彼先圣诸天教敕。于彼众味唯应得取第六十四一分精气。以活身命。六十三分地味精气。留活众生令受安乐。我以知足业因缘故。乃至久远生死流转。不复更啖无好滋味无精气食。以其食故。具威德力能强记念。心性柔软颜容端正无诸病苦。是名不夺活命之具。诸仁者。于彼何者是命不别离。若求命者应如是学。一切众生无非我亲。若恶心眼视及以气嘘令其失心。于身支节夺其精气。使我亲知身心受苦。是义不然。以是因缘。我当久远生死流转。无有非人气嘘眼视散乱其心夺其精气。以是故名命不别离。诸仁者。于彼何者是不坏命。若诸众生。爱己身命求乐离苦。名闻富贵乃至解脱。应如是学。一切众生无非我亲。我若为饮食故。夺亲精气若节节支解。若山顶树上高阁深河推令堕落。及与毒药。若遣起尸恶鬼相害。若作厌蛊若断饮食。若以刀剑斩其身首。随其方便断彼命根。若加此苦是义不然。以是因缘。我于久远。生死流转。不被众生夺其精气。无能支解及断命根。以是义故名不坏命。此是布施清净平等。复次布施清净平等者。怜愍一切诸众生故。为之积集功德智慧。除诸幻见精进坚固。求一切善如说能行。不为活命而起恶心。于诸众生不起害意。所持禁戒与众生同。见众生乐深生欢喜。于己乐缘自能知足。所爱之事皆悉能舍。于诸胜法无吝惜心。常怖三界忍力自在。信无常相如说修行。于己失机能自观察。见他失机则生悲愍。修善无厌有罪勤忏。无边回向乐求正理。常于众生作福田想。勤为众生令息恶道。于一切法心无所住。此是世谛布施清净平等。我今当说第一义谛布施清净平等。尔时世尊。而说咒曰

多地也他　夜咩夜咩　钵啰佉夜咩　忧钵啰佉夜咩　夜寐　耶夜咩　佉夜夜咩　苏婆诃

说此法门时。八百六十万。紧那罗乾闼婆等。远尘离垢。得法眼净

尔时世尊。复说咒曰

多地也他　瞿竭[口*梨]　瞿竭[口*梨]　夜婆瞿竭[口*梨]　忧婆夜婆　瞿竭[口*梨]　苏婆诃

尔时世尊。复说咒曰

多地也他　陀媲　陀罗媲　陀罗陀媲　忧跛陀罗　陀罗媲　苏婆诃

说此法门时。九百四十万夜叉。远尘离垢得法眼净。尔时世尊。复说咒曰

多地也他　阿阇泥　叉叉阿阇泥　伽叉叉　阿阇泥　毛罗阿阇泥　叉差　苏婆诃

说此法门时。七千万龙。于远尘离垢法。得胜三昧

尔时世尊。复说咒曰

多地也他　诃诃诃诃诃诃　系打婆　诃诃诃　若若若　诃诃诃　苏婆诃

说此法门时。三十那由他百千阿修罗。得不忘菩提心三昧

尔时世尊。复说咒曰

多地也他　阿奴那　阿奴那　阿婆那奴那　阿婆夜[口*梨]　阿婆那奴那　苏婆诃

说此法门时。八万四千频婆罗鸠槃荼。得喜乐三昧。尔时世尊。复说咒曰

多地也他　陀伽陀阇　阿婆陀伽陀阇　阿婆陀　伽陀阇阇　犍陀犍陀阇　苏婆诃

说此法门时。七那由他百千饿鬼。毗舍遮富单那。迦吒富单那。得电王三昧。过诸数量天龙夜叉。乃至迦吒富单那等。昔未曾发无上真实菩提心者皆悉发心。此是第一义谛布施清净平等。诸仁者。于彼何者是戒清净平等。若一切世间及出世间。所有善道及涅槃乐。戒为根本。以是因缘。得住声闻辟支佛地。及阿耨多罗三藐三菩提果。所谓十善业道。远离杀生偷盗邪淫妄语两舌恶口绮语。贪嗔邪见。诸仁者。于彼远离杀生因缘获十种功德。何等为十。一者于一切众生得大无畏。二者于诸众生得大慈心。三者得断习气。四者无诸病恼。五者得寿命长。六者非人护持。七者寤寐安隐无诸恶梦。八者无有怨家。九者不畏恶道。十者得生善道。以是远离杀生善根。回向阿耨多罗三藐三菩提。是人不久证无上智。得菩提已。于彼佛土离诸害杀。长寿众生来生其国。诸仁者。于彼远离偷盗因缘。获十种功德。何等为十。一者具大财报。二者不共他有。三者不共五家。四者众人爱敬常不厌舍。五者远游十方无有疑虑。六者行处无畏。七者常乐布施。八者不求财宝自然速得。九者得财即施。十者得生善道。以是远离偷盗善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土具足种种花果树林。衣服璎珞庄严之具。珍奇宝物无不充满。诸仁者。于彼远离邪淫因缘。获十种功德。何等为十。一者得摄诸根律仪。二者得住离欲清净。三者不恼于他。四者众人称誉。五者众人乐观。六者能发精进。七者见生死过。八者常乐舍施。九者常乐求法。十者得生善道。以是远离邪淫善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土无有腥臭亦无女人。不行淫欲皆悉化生。诸仁者。于彼远离妄语因缘。获十种功德。何等为十。一者众人信语。二者于一切处乃至诸天发言得中。三者口出香气如优钵罗花。四者于人天众独作证明。五者众人爱敬离诸疑惑。六者常出实语。七者心意清净。八者常无谄语言不失机。九者常多欢喜。十者得生善道。以是远离妄语善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土。无有腥臭。种种妙香芬馨遍满。诸仁者。于彼远离两舌因缘。获十种功德。何等为十。一者得身不坏。二者得眷属不坏。三者得交友不坏。四者得信不坏。五者得法不坏。六者得律仪不坏。七者得奢摩他不坏。八者得三昧不坏。九者得忍不坏。十者得生善道。以是远离两舌善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土众生眷属不为诸魔他人所坏。诸仁者。于彼远离恶口因缘。获十种功德。何等为十。一者言音柔软。二者语辞流利。三者言音润泽。四者得和合语。五者言必得中。六者得质直语。七者得无畏语。八者得不谄语。九者得如法语。十者得生善道。以是远离恶口善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土法音充满。远离一切鄙恶言辞。诸仁者。于彼远离绮语因缘。获十种功德。何等为十。一者天人爱敬。二者天人随喜赞叹。三者常乐实语。四者常与明人共住不离。五者闻言悉领。六者得智慧人爱敬尊重。七者常得爱乐阿兰若处。八者爱乐贤圣默然。九者远离恶人亲近贤圣。十者得生善道。以是远离绮语善根。回向阿耨多罗三藐三菩提。得菩提已。于彼佛土颜容端正强记不忘。乐远离者来生其国。诸仁者。于彼远离贪欲因缘。获十种功德。何等为十。一者身根不缺。二者口业清净。三者心不散乱。四者得胜果报。五者得大富贵。六者众人乐观。七者得不坏眷属及不坏财。八者常与明人相会。九者不离法声。十者得生善道。以是远离贪欲善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土离彼魔怨及诸外道。诸仁者。于彼远离嗔恚因缘。获十种功德。何等为十。一者得离嗔恚。二者不乐积财。三者随顺贤圣。四者常与贤圣相会。五者得利益事。六者面部端严。七者见众生乐则生欢喜。八者常得三昧。九者三业调柔。十者得生善道。以是远离嗔恚善根。回向阿耨多罗三藐三菩提。得菩提已。彼佛国土所有众生。悉得三昧心极清净。诸仁者。于彼远离邪见因缘。获十种功德。何等为十。一者心性柔善伴侣贤良。二者信有业报乃至夺命不起诸恶。三者归敬三宝不信天神。四者得于正见不择岁次日月吉凶。五者常生人天离诸恶道。六者得贤善心明人赞誉。七者弃于世俗常求圣道。八者离断常见信因缘法。九者常与正信正行正发心人共相会遇。十者得生善道。以是远离邪见善根。回向阿耨多罗三藐三菩提。是人速满六波罗蜜。于善净佛土而成正觉。得菩提已于彼佛土。功德智慧一切善根庄严众生来生其国。不信天神离恶道畏。于彼命终还生善道。诸仁者。于彼布施清净平等行时。于戒远离杀生平等行。以是因缘。具大果报离诸怖畏。诸仁者。于彼布施清净平等行时。于戒远离偷盗平等行。以是因缘。具大果报不共他有。修一切善无有留难。诸仁者。于彼布施清净平等行时。于戒远离邪淫平等行。以是因缘。具大果报修习善根。无有留难。无邪淫念观自他妇。诸仁者。于彼布施清净平等行时。于戒远离妄语平等行。以是因缘。具大果报。若被毁谤人不信受。如说修行发意所为莫不坚固。于天人众独作证明。口出香气如优钵罗花。诸仁者。于彼布施清净平等行时。于戒远离两舌平等行。以是因缘具大果报。得不坏眷属丈夫眷属敬信眷属。诸仁者。于彼布施清净平等行时。于戒远离恶口平等行。以是因缘具大果报。离粗犷语得微妙音。具足清净离弊恶声。诸仁者。于彼布施清净平等行时。于戒远离绮语平等行。以是因缘具大果报。发言得中断大众疑。众人乐见。诸仁者。于彼布施清净平等行时。于戒远离贪欲平等行。以是因缘具大果报。正受其报还能舍施。具受胜报备大威力。诸仁者。于彼布施清净平等行时。于戒远离嗔恚平等行。以是因缘具大果报。端正丰美众人爱敬。一切无碍诸根不缺。诸仁者。于彼布施清净平等行时。于戒远离邪见平等行。以是因缘具大果报。正见国土正见家生。常值诸佛及诸菩萨声闻缘觉。见佛闻法供养众僧。修菩萨行常不舍离清净平等。诸仁者。此是戒行清净平等。以是戒行自庄严者。是人不久具足相好。成佛功德音声清净。降伏魔怨禅念慧行。清净大智大慈大悲。乃至能成一切佛法清净平等。此是世间起发戒行清净平等。诸仁者。于彼何者是出世间起发戒行清净平等。若戒清净及三摩提起信解行者。不依色事而持禁戒。不依受想行识事而持禁戒。不依眼事而持禁戒。不依色眼识眼触眼触因缘生受爱取有生事而持禁戒。乃至不依意事而持禁戒。不依法意识意触意触因缘生受爱取有生事而持禁戒。不依地界水火风界事而持禁戒。不依无边虚空处。无边识处。无所有处。非想非非想处事而持禁戒。不依欲界色无色界事而持禁戒。不依现在及未来事而持禁戒。不依声闻及辟支佛无上大乘一切智事而持禁戒。不依闻事禅事智事而持禁戒。不依闻力三昧力陀罗尼力忍辱力事而持禁戒。不依有漏无漏力有为无为事善不善力明闇力事而持禁戒。此是出世间起发戒行清净平等。梵路圣道入无畏城。彼诸贤圣所依戒行清净平等。第一义谛入清净智。诸仁者。所言戒者。是何句义。譬如金刚铁围山间热恼之风。以山障故不令得去至四天下。如是圣戒清净平等。修四念处力能障彼爱热之风不令得起。以是义故名之为戒。譬如铁围山间臭秽之风。以山障故不令得去至四天下。如是圣戒清净平等。修四无畏力能障彼邪臭之气不令得起。以是义故名之为戒。譬如铁围山间甚大黑闇。以山障故不令得曀此四天下。如是圣戒清净平等。修七觉分力能障彼无明有为有漏之相不令得起。以是义故名之为戒。诸仁者。离欲义是戒义。解脱义是戒义。休息义是戒义。尽义是戒义。灭义是戒义。此诸句义名为戒义。诸仁者。此是有为无为戒行清净平等。若有沙门及婆罗门。修此有为及无为戒平等住者。彼人应受世间供养。若世间人于彼沙门及婆罗门。敬信尊重护持养育。衣服饮食床褥卧具。病患因缘施其汤药活命之具。彼人流转于生死中。恒受胜报速能得入无畏大城。诸仁者。于彼何者是忍清净平等。忍有二种。一者舍忍。二者息怒忍。舍忍清净平等者。若欲得一切乐舍一切苦。是名舍忍清净平等。若有众生。求乐离苦观彼三界一切苦道及烦恼火之所逼热。唯除圣人。是人为已生大怖畏。作是见时。三界众生皆为烦恼炽然逼热。一一众生种种苦害。驱驰流转不能自救。如是我共一切众生为苦所恼以何方便而能自救。即作是念。不以余事。唯应修忍脱一切苦具一切乐。便能喜乐修平等忍。能舍种种资身之具。所谓饮食骑乘衣服卧具屋宅床榻。随其所须皆悉给与。以忍布施为灭诸苦。是人数数修忍住时。能行舍施。于正发心人正修行人。应到其所而修供养。数供养故。从彼人闻生死过患涅槃功德。是人如是。若声闻乘及缘觉乘无上大乘发心求证。为彼乐故。重复乐忍养育众生。此是舍忍清净平等乃至若舍身外资财。能自忍苦令他得乐。亦名舍忍清净平等。若彼种种形色种种威仪。种种音声种种嗔怒骂辱欺凌粗犷非实不喜之言。乞士来求诸如是等。是人心未柔软嗔恚未净不得住忍。是人生念。谁能胜我。是故被辱未能行忍。复作是念。彼食血肉夜叉罗刹鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。何故未闻生死大苦涅槃至乐。不观后世可怖畏事。众苦所恼未能解脱。应知彼等离善知识及不闻法。是故生死为苦所溺。我已近善知识。数数得闻生死苦恼涅槃安乐。观后世畏常勤修习断一切苦。当得度彼生死沉沦。何故起嗔而不行忍。是故我应作是分别。骂辱音声及诸违事皆悉如风。我当弃舍不应起嗔。如是应舍诸众生想。作是念时。骂辱音声及诸违事悉如风过。离众生想修行忍辱清净平等。是人若数于彼众生。舍种种想。骂辱声音及诸违事离分别想。修行忍辱清净平等。是人住忍心喜得净。如是则能修无碍智。谓法无碍及义无碍。如是则能悉舍内财。所谓皮肉筋骨眼耳鼻舌手足及头所爱之命。如是菩萨摩诃萨修无分别非无分别忍清净平等。是名舍忍清净平等。诸仁者。于彼何者是息怒忍清净平等。若菩萨摩诃萨能于一切言语音声文字。舍分别想及于一切色身形想。举动威仪去来戏笑舍分别想。亦舍爱取不求果报。离于苦乐无分别想。乃至于己身命无分别想。得住第一义忍清净平等。譬如虚空遇闇不嗔得明不喜。不作如是分别之心。如是菩萨摩诃萨住第一义忍清净平等。于彼一切有为诸法语言形色及苦乐受。离于分别不作分别。不嗔不喜。于诸众生离分别想。得住第一义忍清净平等。譬如虚空不动不止。遍动不震不止遍震。如是菩萨摩诃萨于一切业有为诸行。身心不动不止遍动。亦复不震不止遍震。譬如虚空清净离垢。如是菩萨摩诃萨住第一义忍清净平等。于彼一切有为身心善得清净。譬如虚空长养众生。如是菩萨摩诃萨住第一义忍清净平等养育众生。譬如虚空非劫尽火所能烧坏。非劫尽水及劫尽风所能毁坏。如是菩萨摩诃萨住第一义忍清净平等。乃至未到无上菩提。不为贪欲嗔恚愚痴三毒炽火烧坏其心。譬如清净虚空十五日夜极圆满月。普放冷光热恼众生身心凉乐。如是菩萨摩诃萨住第一义忍清净平等。皆息己身威仪忧恼。亦息众生诸烦恼热。譬如清净虚空十五日夜极圆满月。众星围绕照四天下。如是菩萨摩诃萨住第一义忍清净平等。随所住处为诸天龙乃至迦吒富单那等之所围绕晖显照曜。譬如清净虚空十五日夜极圆满月。照海岛上月爱摩尼。从彼珠中流出大水能满大海。如是菩萨摩诃萨住第一义忍清净平等。以第一义忍清净平等。放胜光明照曜一切。诸天及龙夜叉罗刹。乃至迦吒富单那等。令彼悉得善心清净。于诸众生起大慈悲心。深利益心。休息苦恼心。令住一切乐心。观后世畏心。离一切恶心。于一切善起勤进心。彼诸鬼神以得如是诸胜善心。次第渐离一切不善。一切善水悉皆充足。故能流满涅槃大海。诸仁者。应当观此菩萨善根。虽未能至究竟处所。以住第一义忍清净平等故。已得超过一切声闻及辟支佛。能以善法成熟众生。如我昔作忍辱仙人。常在林中食诸甘果。时有国王名曰迦利。支解我身而为八段。我于彼时以能善修第一义忍故。从所割处流出白乳。以是忍辱苦行因缘。成熟无量亿那由他百千天龙夜叉罗刹乾闼婆阿修罗紧那罗摩睺罗伽迦楼罗饿鬼毗舍遮富单那迦吒富单那等。彼时无量亿那由他百千天龙乃至人非人等。悉发阿耨多罗三藐三菩提心。诸仁者。我昔人身生非难处。作此苦行不足为难。如我往昔生于难处受彼兔身。为使仙人得肉食故。即自踊身投大火聚。以能善修第一义忍清净平等。令大火聚变作莲池。时彼兔身卧花台上。以苦行因缘。令此三千大千世界六种震动。彼时帝释护世四王天龙夜叉。乃至迦吒富单那等。及诸仙人人非人等种种供养。而语我言。汝若得成阿耨多罗三藐三菩提。当于彼时我等必于阿耨多罗三藐三菩提而得授记。诸仁者。我昔兔身以能善修第一义忍清净平等故。已得不共声闻缘觉所有供养。是故彼时梵释天王护世四王天龙夜叉。乃至人非人等。悉以种种胜上香花涂香末香音乐众宝幢旛等事。赞叹尊重希有供养。今阿罗汉之所无也。诸仁者。菩萨如是善能修住第一义忍清净平等。此四句义今当解释。第一义者。能到彼岸。以是义故名第一义。忍者。见三界阴为究竟空。及见界入为究竟空。以是义故名之为忍。清净者。谓以圣慧除净三界诸烦恼道业道苦道。以是义故名为清净。平等者。谓以圣慧于三界行一切法理真如实际得如实知。无烦恼道业道苦道。以是义故名为平等。此是菩萨摩诃萨第一义忍清净平等。诸仁者。于彼何者是精进清净平等。以此精进。能与布施清净平等作因。乃至能与般若波罗蜜清净平等作因。以是则能舍一切见。以此精进能与四念处清净平等作因。超过一切声闻缘觉。以此精进能与四正勤四如意足作因。以是则能舍诸烦恼。以此精进。能与四摄事四无碍辩四梵住四无色定。五根五力七觉支。八圣道分九次第定。断十二有支得如来十力十八不共法大慈大悲般若波罗蜜清净平等而作因缘以此精进能与成熟众生清净平等作因。以此精进。为得无量佛胜法故集诸善根。以此精进。能习无量巧方便智。无量愿智转转殊胜。修习无量大功德聚。以此精进。随愿受生教化利益。以精进故。居兜率天宫观其时节舍彼宫殿正知了了而入母胎。以精进故。于蓝毗尼林从母右胁安隐而出。以精进故。行七步已震动大地及诸山海。以精进故。受彼难陀及婆难陀龙王兄弟淋水洗浴。以精进故。童子游戏示现一切工巧奇能。以精进故。处在宫中五欲不染。以精进故。夜半踰城向闲林下。以精进故。诣优陀迦迦罗荼迦罗摩诸仙人所而修供养。以精进故。六年修彼难行苦行。以精进故。得阿耨多罗三藐三菩提。以精进故。转大法轮无量人天得证圣道。是名精进清净平等。诸仁者。我以是精进。今于佉罗帝山牟尼诸仙所依住处。作此大集。十方所有菩萨摩诃萨。有如佛土微尘数众悉令集此。有如佛土微尘等数诸天及龙夜叉罗刹乾闼婆阿修罗摩睺罗伽迦楼罗紧那罗鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。悉来大集。为闻法故。是名精进清净平等。诸仁者。以四大海水分为滴数。如彼滴数。具修精进清净平等。能令菩萨摩诃萨等。满足毗离耶波罗蜜。是名精进清净平等

大方等大集月藏经卷第五大方等大集经卷第五十一

        高齐天竺三藏那连提耶舍译

    月藏分第十四诸恶鬼神得敬信品第八之二

诸仁者。于彼何者是禅清净平等。有禅声闻缘觉如来共。有禅缘觉如来共不共声闻。有如来禅不共声闻缘觉。有如来禅共声闻缘觉一切众生

诸仁者。于彼何禅声闻缘觉如来共。若有众生。求乐离苦观后世畏。是人修行布施清净平等时。若有正趣正发心者。应到其所起卑下心随顺供养。从彼人边得闻正法。闻已知义如法修行。心乐离欲流注相续。是人得离诸欲恶不善法。有觉有观离生喜乐入初禅。无觉无观定生喜乐入第二禅。离喜行舍念增上正知入第三禅。舍苦舍乐先灭忧喜不苦不乐舍念清净入第四禅。度一切想灭有对想不念别异想入无边虚空处。度无边虚空处入无边识处。度无边识处入无所有处。度无所有处入非想非非想处。度非想非非想处入灭受想定

诸仁者。住初禅者灭音声刺。住第二禅者灭觉观刺。住第三禅者灭喜刺。住第四禅者灭出入息刺。住无边虚空处者灭色刺。住无边识处者灭虚空刺。住无所有处者灭识刺。住非想非非想处者灭无所有刺。住灭受想者灭受想刺。是名身行得倚口行得倚意行得倚。八解脱禅士。得灭尽定到彼岸。阿罗汉依此处得四念处四正勤四如意足五根五力七觉分八圣道分三解脱门四无碍辩。依此处得奢摩他毗婆舍那。此非菩萨行清净平等。不得四摄事四梵住三不护四无所畏十力十八不共法一切智智。是名禅波罗蜜平等声闻缘觉如来共

诸仁者。若复有人。先修缘觉乘退入声闻乘行声闻行。是人入初禅乃至入灭尽定。依此定得三解脱门四无碍辩。不得四摄事四梵住三不护。乃至不得一切智智。是名禅平等声闻缘觉如来共

诸仁者。若复有人。先修大乘退入声闻乘。是人入初禅乃至入灭尽定。得三解脱门四摄事四梵住。不得三不护。乃至不得一切智智。是名禅平等声闻缘觉如来共

诸仁者。于彼何禅缘觉如来共不共声闻。若有众生。久修声闻乘后入缘觉乘。是人昔来未得初禅。得已思惟求因缘法。乃至得第四禅已思惟求因缘法。入空无愿无相三昧。以彼三昧思惟舍离证无色定。以彼三解脱门入灭尽定。于一切处思惟求缘觉法。是人求于因缘第一义三行灭无余非想受灭。是名禅平等缘觉如来共不共声闻。若复有人。未学声闻乘善学缘觉乘。是人入初禅思惟求因缘法。是人依初禅超彼余禅及无色定。入三行灭无余第一义灭定。是名禅平等缘觉如来共不共声闻

诸仁者。若复有人。未学声闻缘觉乘。先学大乘退入缘觉乘。是人入初禅。于彼禅中思惟求因缘法。如是乃至第四禅中思惟求因缘法。如是四无色定一切处思惟求因缘法。如是三行灭无余第一义灭定。以三解脱门得不可说三昧。其处无生无灭。非证非修非有非无。非此岸非彼岸。非闇非明。非可测非分别非不分别。是名佉伽毗沙拏劫(佉伽齐云犀牛毗沙拏云角)辟支佛世间独福田。是名禅清净平等第一义缘觉如来共不共声闻。其处一切生死有海断。行苦苦苦坏苦断。于不可说义能自觉知。是名第一义禅清净平等

诸仁者。于彼何者如来第一义禅清净平等不共声闻缘觉。若如来入初禅。不依阴入定。不依界入定。不依入入定。不依地界水火风界入定。不依虚空处界识处界无所有处界非想非非想处界入定。不依灭界入定。不依现在及未来世入定。不依生不依灭入定。不依有不依无入定。无所依不依所依。如如来入初禅如是。第二第三第四禅虚空处界识处界无所有处界非想非非想处界如是。如来入灭界定不依阴入定。乃至不依所依。如来入灭界定。是名如来第一义禅清净平等不共声闻缘觉

诸仁者。于彼何者是如来禅清净平等共声闻缘觉一切众生。如来入世间初禅。乃至入世间第四禅。缘觉声闻亦能入世间初禅乃至第四禅。一切众生劫欲尽时。亦曾能入世间初禅乃至第四禅。于后恶心因缘退失修禅。嗔恶粗穬不观后世畏。于诸众生无有慈愍。食其血肉趣三恶道

复次如如来入世间初禅。乃至入世间第四禅。彼一切众生。若天若人畜生饿鬼地狱众生作是念。如来心心数法行在何处住在何住。彼一切众生乃至虫蚁。佛力加故。亦如实知佛心心数法住于初禅。乃至知住第四禅。此亦是如来禅平等共一切众生。此禅平等。非一切声闻辟支佛地。是名禅清净平等。诸仁者。于彼何者智器清净平等。智有二种。一者世间智。二者出世间智。诸仁者。何者世间智。其世俗书典。口所言说结集解释。言语之道音声演说。文字显示闻诸论说。若书字句义。若算若数若印。若种种苦行法。若学工巧事。如是所说种种作业。随其所求皆得成就。诸余三世俗念作事。若触若受若想若思若念。如是一切非涅槃器。是名世间智器平等。诸仁者。于彼何者世间智器平等。诸仁者。世间智器平等者。布施持戒忍辱精进禅定闻慧智器平等何者世间布施智器平等。诸仁者。若有人乃至尽形休息杀生偷盗邪淫妄语饮酒诸放逸处。于一切众生安住慈心怜愍心救济心是涅槃器。诸仁者。是名世间布施智器平等

诸仁者。于彼何者世间戒智器平等。诸仁者。若于一切众生具哀愍心观后世畏。常住慈心柔软心利益心无怨仇心无嫉妒心无粗穬心无两舌心无憍逸心安住慈心。诸仁者。是名世间戒智器平等

诸仁者。于彼何者世间忍智器平等。诸仁者。若闻众生种种恶口纯粗穬言。闻已不取不起卒暴不生变浊不现嗔相。于诸众生亦复能忍。不顺言辞音声所出。诸仁者。是名世间忍智器平等

诸仁者。若见众生于其我所作恶作过作罪作无利益。若坏色若坏声香味触若坏身若坏命。于此众生常能修忍应如是学。是诸众生。从无始流转习贪恚痴离善知识未曾修学。我近善知识我能修学我求一切乐。若于一切众生不起嗔嫌。是人得一切乐。是故于彼一切众生见已不取不起卒暴不生变浊不现嗔相。是名世间忍智器平等

诸仁者。于彼何者世间精进智器平等。诸仁者。若于众生勤施不断。及修戒忍精进禅智不断。诸仁者。是名世间精进智器平等

诸仁者。于彼何者世间禅智器平等。诸仁者若入世间初禅乃至第四禅。入无边虚空处乃至非想非非想处。诸仁者。是名世间禅智器平等

诸仁者。于彼何者世间闻慧智器平等。诸仁者。若与如是空法相应。大乘言教有所堪能。读诵受持言辞清净。为人演说不谄不幻。一切烦恼恶业障尽。知法知义。是人于彼言教知法知义。昼夜精勤求无上智。诸仁者。是名世间闻慧智器平等

诸仁者。于彼何者出世间智器平等。诸仁者若善男子。不取色受想行识。不取眼色不取眼识不取眼触。不取眼触因缘生若苦若乐不苦不乐。如是乃至不取意法不取意识不取意触。不取意触因缘生若苦若乐不苦不乐。如是不取地界水火风界。不取虚空界。乃至不取非想非非想界。不取现在及未来世。不取善不善。不取有漏无漏。不取声闻乘。不取缘觉乘。不取无上大乘。不取三界不取三乘。不取有不取无。不取无所有无有言说。得无缘慈三昧。非诸声闻辟支佛地是人以此三昧故。能见入首楞严三昧门。次第当得首楞严三昧。诸仁者。是名出世间智器清净平等。非决定清净平等。是方便力求智平等

诸仁者。于彼何者安住出世间一切法器般若一切法界清净平等。诸仁者。一切法界。非肉眼见非天眼见。是圣法慧眼相应。以圣慧眼观诸法界不增不减。不见诸法有盛有衰。不见近远方所无所至去。不见有生有灭。是人如是见诸法清净平等时。更不见众生有实可得。若入众生不可得。是人则得入一切法不可得。何以故。不离众生有一切法。不离一切法有众生。其众生体性是一切法体性。其一切法体性是众生体性。其一切法体性是我体性。其我体性是一切法体性。其一切法体性是佛法体性。其佛法体性是无我界体性。其无我界体性是实际体性。其实际体性是如如体性。如是知一切法。诸仁者。是名安住出世间一切法器般若一切法界出世间智器清净平等

诸仁者。于彼何者出世间一切法器清净平等。若菩萨摩诃萨如是安住般若入禅定时。不见有法可得。住于禅定而不舍离于一切法境界。无住无灭无所觉知住于禅定。是人不以身禅住于禅定。不以心禅住于禅定。是人住如是禅时。入于如如实际法界。能入诸法无所取着。超过一切声闻辟支佛上。是人于如是禅住于禅定。是未决定菩萨。能断一切诸烦恼见及上烦恼缠。若复菩萨能住如是禅者。则能入于一切诸法。入此法时能知众生善恶诸欲而成熟之。是人不见众生。不见我人寿命众数生者养育作者使作者起者使起者受者使受者。是人若复入于如如法界时。见诸众生颠倒烦恼。以颠倒故受种种苦。是人如是入于微细如如实际法界。是菩萨于众生不见众生而成熟之。众生非实故。众生无众生故。众生无我故。众生离故。众生无自性故。众生不可说故。众生空故。众生无相故。众生无愿故。众生无作故。众生如性故。众生无生故。众生不灭故。众生清净故。而成熟众生如是亦不见我。乃至不见受者。亦不坏事。是诸法自性相。不可说不可说法界。一切语言文字不能说不可显示无所有。是菩萨以大悲故。于不可说法而说诸法。此有漏此无漏。此世间此出世间。此有罪此无罪。此有为此无为。此有烦恼此无烦恼。此应修行此应舍离。此凡夫法此学法。此无学法。此缘觉法。此菩萨法。此佛法。诸仁者。是未决定菩萨。如是安住出世间一切法器般若入一切法界。清净平等分别说法。菩萨于所说法不见其相。诸仁者。譬如幻者。遍虚空界化作种种色种种花。未曾作事而能现作。佛不出世。于彼花中。能出如是妙义句味。入于法门演法音声。作如是事。是为难不。时一切天人及鬼神众作如是言。大德婆伽婆。此事为难。大德修伽陀。此第一难。佛言。诸仁者。此转难此第一转难。其未决定菩萨。于无所属法如是法。无色不可见非文字非言说。自未知未证未善修未自在未到彼岸。而能于他众生除诸烦恼而成熟之。此为转难。彼诸众生。于如是甚深无言说法未作证。闻已不谤。此为第一转难。彼诸众生。能碎一切诸烦恼树。住柔软心作业心。于一切众生慈心愍心不害心悲心共心同心。彼诸众生。以柔软心故。枯竭有海渡烦恼海速入无畏城。于如是无言说未作证。闻已不谤。彼亦转难第一转难。何故汝等恶心鬼神不自制心。于诸众生不作柔软心。不观后世畏。诸仁者。若有住出世间一切法器清净平等三昧菩萨摩诃萨。能使一切众生守护六根各住自境。岂况不能遮障汝等恶心鬼神。是善丈夫皆得是法住大慈大悲心不恼于他。何以故。以修大慈大悲方便力故不恼于他。是诸菩萨入如是甚深法已。能掷众生虚空界中。多亿那由他劫各不相见。岂况不能制于汝等诸恶鬼神。亦复能掷一切众生世界中间大黑闇处。乃至能令一切众生唯食风食水食土食石。是诸菩萨以住如是甚深出世间法器清净平等三昧故。能令一切众生于多亿劫不食。岂况不能制于汝等食他众生精气血肉诸恶鬼神。何故纵舍汝等。是诸菩萨以大慈大悲方便力故纵舍汝等。于此四天下所有菩萨摩诃萨。安住如是甚深出世间法器清净平等三昧。其名曰众自在菩萨。慈自在菩萨。文殊音菩萨。电自在菩萨。日自在菩萨。月自在菩萨。地自在菩萨。想自在菩萨。观世自在菩萨。水自在菩萨。如是等万八千菩萨摩诃萨居此四天下。彼诸菩萨摩诃萨住此十种第一甚深出世间一切法器清净平等。何等为十。所谓众生平等。法平等。清净平等。布施平等。戒平等。忍平等。精进平等。禅平等。般若平等。一切法清净平等。住此十种第一甚深出世间一切法器清净平等三昧菩萨摩诃萨。一一皆能制于汝等诸恶鬼神。如上所说。何故纵舍汝等。是诸菩萨以修大慈大悲方便力故纵舍汝等。何况如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。诸仁者。假使一切众生。住如是十种出世间甚深一切法器清净平等。如前所说菩萨摩诃萨。以一如来一念之智胜于彼等。何况如来于一切时。以大悲心覆护汝等。不生嗔恚亦不弃舍。如来于一切时怜愍汝等。欲令得于利益安乐。汝等如是无有惭愧。不观后世畏。于一切众生作不愍心不柔软心恶心怨心不慈心不悲心。汝等不应作是非法。欲重明此义。而说偈言

  大雄见如是　　无余鬼神集
  即时举右臂　　宣说如是言
  佛出世甚难　　法僧亦复难
  众生净信难　　离诸难亦难
  哀愍众生难　　知足第一难
  得闻正法难　　能修第一难
  得知难平等　　于世常受乐
  此十平等处　　智者当速知
  初众生平等　　舍离诸恶业
  造作诸善业　　久受于胜乐
  修行法平等　　一切法等等
  佛声闻缘觉　　凡夫等如如
  此清净平等　　于彼人中得
  远离取境界　　亦复不坏我
  布施平等喜　　不害他众生
  不夺活命具　　不坏诸花果
  无有一众生　　非我父母者
  一切诸众生　　曾与我亲知
  我更不触恼　　乃至一众生
  休息于非时　　一切恶风雨
  丰盛可乐事　　养育诸亲知
  众生精气增　　常得不损减
  不气嘘他身　　不嗔恶眼视
  不夺他精气　　充满一切乐
  我心利一切　　不嗔有失者
  为断诸烦恼　　求于诸佛法
  十种善业道　　智者常守护
  于世常欢喜　　后得见涅槃
  不依阴持戒　　亦不依界入
  灭诸有支戒　　灭诸有渴爱
  舍离种种想　　能息于嗔怒
  如是字言合　　智者离分别
  如虚空空故　　离一切分别
  如是修忍者　　智者离分别
  譬如空中月　　众星共围绕
  如是修忍者　　安隐众中显
  月光照摩尼　　海水得盈满
  忍照恶心鬼　　令得清净信
  一切离诸恶　　修于菩提行
  彼众生次第　　能满诸佛海
  我昔作仙人　　林中修忍辱
  节节支解身　　不起嗔怒心
  作兔为仙人　　自投身入火
  我以修忍故　　火变为莲池
  我以彼忍力　　成熟多众生
  今诸阿罗汉　　无有如是忍
  智者常精进　　修行为福慧
  智海得增满　　得成诸佛海
  修禅及般若　　得离诸烦恼
  不分别三界　　得住于如如
  智者修禅智　　出世住实际
  不染于诸法　　离一切分别
  不分别诸法　　不见有众生
  诸法唯一相　　得见佛境界
  无量菩萨众　　安住此法性
  不恼于汝等　　以住圣般若
  如来于汝等　　容恕不为恼
  汝等无羞耻　　远离于惭愧
  作恶诸众生　　弊性多刚强
  见佛大勇猛　　皆得柔软心
  汝等各应当　　自遮己恶心
  汝等当次第　　速证大涅槃
  汝等若柔软　　得离诸恶业
  为护此法故　　付嘱于汝等
  我所说声闻　　具智大名称
  彼怜愍汝等　　令得福智慧
  当得饮食利　　诸天所供养
  得于胜住处　　及得增寿命
  若闻导师语　　如说能修行
  人天世间中　　常受胜乐报

尔时世尊于彼诸恶鬼神众中说法讫时。于彼诸恶鬼神众中。彼恶鬼神昔于佛法作决定信。彼于后时近恶知识心见他过。以是因缘生恶鬼神。彼九十二那由他百千诸恶鬼神得住须陀洹果。亿那由他频婆罗百千诸恶鬼神昔行大乘者得随顺忍。无量阿僧祇诸恶鬼神得柔软心。得已复发阿耨多罗三藐三菩提心

尔时于彼鬼神众中。有罗刹王名牛王目。与万罗刹王合掌向佛。一心敬礼而作是言。大德婆伽婆。我等为嗔使故久于世间受不爱果。我等今者承佛神力得自忆念此贤劫中宿命之事。我等于鸠留孙如来法中曾得出家。诵持八万大乘法聚。复诵八万声闻法聚。发阿耨多罗三藐三菩提愿。我等彼时于阿兰若住法比丘所起嗔怒心。以是业障于彼命终生于地狱。久被烧煮失念无余。于彼命终生此食他血肉恶罗刹中。正由我等昔出家时共作恶业。今受于此恶罗刹身。为饮食故断无量亿那由他百千众生命。以是我等今于佛所悔诸恶业更不复作。如是至三。至到坚固修行律仪。惟愿世尊。授于我等阿耨多罗三藐三菩提记

佛言。诸仁者。我不见更有一法远离菩提心如于阿兰若比丘所而起恶心者。诸仁者。于未来世。此贤劫最后如来名曰卢遮。彼佛当授汝等胜菩提记。彼万罗刹王垂泪而言。宁处地狱不作人身于阿兰若比丘所一念之顷。而起恶心。以彼能断一切善故。何况数数而起恶心

尔时复有诸恶鬼神敬信三宝。住柔软心观后世畏。一切同音而作是言。大德婆伽婆。我等从今休息诸恶。忏悔过去一切恶业。我等今当食花食香食果食水食风食法食喜。更不恼他。护持佛法受佛付嘱为久住故。及受世尊声闻弟子住阿兰若者增上护持。佛言。善哉善哉。善丈夫。汝等应当如是善受我之付嘱。我今复以汝等付嘱。贤劫一切菩萨一切声闻。彼怜愍汝等。于其昼夜作善助道。与汝善分称名劝请。以是汝等增长精气大力威德及大功能亲知眷属。彼彼如是护持我法故。亦复善护阿兰若住法比丘若大乘小乘。如是如是精气增长乃至眷属。如是如是汝等作胜供养三世诸佛。以此善根能舍恶趣得世间乐及涅槃乐

    大集经月藏分第十二诸天王护持品第九

尔时世尊。示世间故。问娑婆世界主大梵天王言。此四天下是谁能作护持养育。时娑婆世界主大梵天王作如是言。大德婆伽婆。兜率陀天王。共无量百千兜率陀天子。护持养育北郁单越。他化自在天王。共无量百千他化自在天子。护持养育东弗婆提。化乐天王。共无量百千化乐天子。护持养育南阎浮提。须夜摩天王。共无量百千须夜摩天子。护持养育西瞿陀尼

大德婆伽婆。毗沙门天王。共无量百千诸夜叉众。护持养育北郁单越。提头赖吒天王。共无量百千乾闼婆众护持养育东弗婆提。毗楼勒叉天王。共无量百千鸠槃茶众护持养育南阎浮提。毗楼博叉天王。共无量百千龙众护持养育西瞿陀尼

大德婆伽婆。天仙七宿三曜三天童女护持养育北郁单越。彼天仙七宿者。虚危室辟奎娄胃。三曜者。镇星岁星荧惑星。三天童女者。鸠槃弥那迷沙。大德婆伽婆。彼天仙七宿中。虚危室三宿是镇星土境。鸠槃是辰。辟奎二宿是岁星土境。弥那是辰。娄胃二宿是荧惑土境。迷沙是辰。大德婆伽婆。如是天仙七宿三曜三天童女护持养育北郁单越

大德婆伽婆。天仙七宿三曜三天童女护持养育东弗婆提。彼天仙七宿者。昴毕觜参井鬼柳。三曜者太白星岁星月。三天童女者。毗利沙弥偷那羯迦吒迦。大德婆伽婆。彼天仙七宿中。昴毕二宿是太白土境。毗利沙是辰。觜参井三宿是岁星土境。弥偷那是辰鬼柳二宿是月土境。羯迦吒迦是辰。大德婆伽婆。如是天仙七宿三曜三天童女护持养育东弗婆提

大德婆伽婆。天仙七宿三曜三天童女护持养育南阎浮提。彼天仙七宿者。星张翼轸角亢氐。三曜者。日辰星太白星。三天童女者[糸*枲]呵迦若兜罗。大德婆伽婆。彼天仙七宿中星张翼是日土境。[糸*枲]呵是辰。轸角二宿是辰星土境。迦若是辰。亢氐二宿是太白土境。兜罗是辰。大德婆伽婆。如是天仙七宿三曜三天童女护持养育南阎浮提

大德婆伽婆。彼天仙七宿三曜三天童女护持养育西瞿陀尼。彼天仙七宿者。房心尾箕斗牛女。三曜者。荧惑星岁星镇星。三天童女者。毗离支迦檀[少/兔]婆摩伽罗。大德婆伽婆。彼天仙七宿中。房心二宿是荧惑土境。毗利支迦是辰。尾箕斗三宿是岁星土境。檀[少/兔]婆是辰。牛女二宿是镇星土境。摩伽罗是辰。大德婆伽婆。如是天仙七宿三曜三天童女护持养育西瞿陀尼

大德婆伽婆。此四天下南阎浮提最为殊胜。何以故。阎浮提人勇健聪慧梵行相应。佛婆伽婆于中出世。是故四大天王。于此倍增护持养育。此阎浮提有十六大国。谓鸯伽摩伽陀国。傍伽摩伽陀国。阿槃多国。支提国。此四大国。毗沙门天王与夜叉众围绕护持养育。迦尸国。都萨罗国。婆蹉国。摩罗国。此四大国。提头赖吒天王与乾闼婆众围绕护持养育。鸠罗婆国。毗时国。般遮罗国。疏那国。此四大国。毗楼勒叉天王与鸠槃茶众围绕护持养育。阿湿婆国。苏摩国。罗苏吒国。甘满阇国。此四大国。毗楼博叉天王与诸龙众围绕护持养育

大德婆伽婆。过去天仙。护持养育此四天下故。皆亦如是分布安置。于后随其国土城邑村落塔寺园林树下冢间山谷旷野河泉陂泺乃至海中宝洲天祠。于彼卵生胎生湿生化生诸龙夜叉罗刹饿鬼毗舍遮富单那迦吒富单那等。生于彼中还住彼处无所系属不受他教是故愿佛于此阎浮提一切国土。彼诸鬼神分布安置为护持故。为护一切诸众生故。我等于此说欲随喜。佛言。如是大梵。如汝所说。尔时世尊欲重明此义。而说偈言

  示现世间故　　导师问梵王
  于此四天下　　谁护持养育
  如是天师梵　　诸天王为首
  兜率他化天　　化乐须夜摩
  能护持养育　　如此四天下
  四王及眷属　　亦复能护持
  二十八宿等　　及以十二辰
  十二天童女　　护持四天下
  随其所生处　　龙鬼罗刹等
  不受他教者　　还于彼作护
  天神等差别　　愿佛令分布
  怜愍众生故　　炽然正法灯

尔时佛告月藏菩萨摩诃萨言。了知清净士。此贤劫初。人寿四万岁时鸠留孙佛出兴于世。彼佛为无量阿僧祇亿那由他百千众生。回生死轮转正法轮。追回恶道安置善道及解脱果。彼佛以此四大天下。付嘱娑婆世界主大梵天王他化自在天王化乐天王兜率陀天王须夜摩天王等。护持故。养育故。怜愍众生故。令三宝种不断绝故。炽然故。地精气众生精气正法精气久住增长故。令诸众生休息三恶道故。趣向三善道故。以四天下付嘱大梵及诸天王。如是渐次劫尽诸天人尽。一切善业白法尽灭。增长大恶诸烦恼溺。人寿三万岁时。拘那含牟尼佛出兴于世。彼佛以此四大天下。付嘱娑婆世界主大梵天王他化自在天王乃至四大天王及诸眷属。护持养育故乃至令一切众生休息三恶道趣向三善道故。以此四天下付嘱大梵及诸天王。如是次第劫尽诸天人尽。白法亦尽。增长大恶诸烦恼溺。人寿二万岁时。迦叶如来出兴于世。彼佛以此四大天下。付嘱娑婆世界主大梵天王他化自在天王化乐天王兜率陀天王须夜摩天王憍尸迦帝释四天王等及诸眷属。护持养育故。乃至令一切众生休息三恶道趣向三善道故。彼迦叶佛以此四天下。付嘱大梵四天王等。及付诸天仙众七曜十二天童女二十八宿等。护持故。养育故。了知清净士。如是次第至今劫浊烦恼浊众生浊大恶烦恼浊斗诤恶世。时人寿百岁一切白法尽。一切诸恶闇翳世间。譬如海水一味大碱。大烦恼味遍满于世集会恶党。手执髑髅血涂其掌共相杀害。如是恶众生中。我今出世菩提树下初成正觉。受提胃波利诸商人食。为彼等故。以此阎浮提分布天龙乾闼婆鸠槃茶夜叉等。护持养育故。以是大集十方所有佛土一切无余菩萨摩诃萨等。悉来集此。乃至于此娑婆佛土。其处百亿日月。百亿四天下。百亿四大海。百亿铁围山大铁围山。百亿须弥山。百亿四阿修罗城。百亿四大天王。百亿三十三天。乃至百亿非想非非想处。如是略数娑婆佛土。我于是处而作佛事。乃至于娑婆佛土所有诸梵天王及诸眷属。魔天王。他化自在天王。化乐天王。兜率陀天王。须夜摩天王。帝释天王。四大天王。阿修罗王。龙王。夜叉王。罗刹王。乾闼婆王。紧那罗王。迦楼罗王。摩睺罗伽王。鸠槃茶王。饿鬼王。毗舍遮王。富单那王。迦吒富单那王等。悉将眷属于此大集。为闻法故。乃至于此娑婆佛土所有诸菩萨摩诃萨等及诸声闻一切无余悉来集此。为闻法故。我今为此所集大众。显示甚深佛法。复为护世间故。以此阎浮提所集鬼神。分布安置护持养育

尔时世尊。复问娑婆世界主大梵天王言。过去诸佛。以此四大天下曾付嘱谁令作护持养育。时娑婆世界主大梵天王言。过去诸佛。以此四天曾付嘱我及憍尸迦令作护持。而我有失不彰己名及帝释名。但称诸余天王及宿曜辰护持养育

尔时娑婆世界主大梵天王及憍尸迦帝释。顶礼佛足而作是言。大德婆伽婆。大德修伽陀。我今谢过。我如小儿愚痴无智。于如来前不自称名。大德婆伽婆。唯愿容恕。大德修伽陀。唯愿容恕。诸来大众亦愿容恕。我于境界言说教令得自在处护持养育。乃至令诸众生趣善道故。我等曾于鸠留孙佛已受教敕。乃至令三宝种已作炽然。拘那含牟尼佛迦叶佛所。我受教敕亦如是。于三宝种已勤炽然地精气众生精气正法味醍醐精气久住增长故。亦如我今于世尊所顶受教敕。于己境界言说教令得自在处。休息一切斗诤饥馑。乃至令三宝种不断绝故。三种精气久住增长故。遮障恶行众生。护养行法众生故。休息众生三恶道趣向三善道故。为令佛法得久住故。勤作护持。佛言。善哉善哉。妙丈夫。汝应如是

尔时佛告百亿大梵天王言。所有行法住法顺法厌舍恶者。今悉付嘱汝等手中。汝等贤首。于百亿四天下。各各境界言说教令得自在处。所有众生。弊恶粗犷恼害于他无有慈愍不观后世畏。触恼刹利心及婆罗门毗舍首陀心。乃至触恼畜生心。如是作杀生因缘。乃至作邪见因缘。随其所作非时风雨乃至令地精气众生精气正法精气作损减因缘者。汝应遮止令住善法。若有众生。欲得善者。欲得法者。欲度生死彼岸者。所有修行檀波罗蜜者。乃至修行般若波罗蜜者。所有行法住法众生。及为行法营事者。彼诸众生。汝等应当护持养育。若有众生。受持读诵为他演说种种解脱经论。汝等当与彼诸众生念持方便得坚固力。入所闻不忘智信诸法相。令离生死修八圣道三昧根相应。若有众生。于汝境界住法。奢摩他毗婆舍那次第方便与诸三昧相应。勤求修习三种菩提者。汝等应当遮护摄受勤作舍施勿令乏少。若有众生。施其饮食衣服卧具病患因缘施汤药者。汝等应当令彼施主五利增长。何等为五。一者寿增长。二者才增长。三者乐增长。四者善行增长。五者慧增长。汝等长夜得利益安乐。以是因缘汝等能满六波罗蜜。不久得成一切种智。时娑婆世界主大梵天王为首。共百亿诸梵天王咸作是言。如是如是。大德婆伽婆。我等各各。于己境界弊恶粗犷恼害于他无慈愍心不观后世畏。乃至我当遮障与彼施主增长五事。佛言。善哉善哉。汝应如是。尔时复有一切菩萨摩诃萨一切诸大声闻一切天龙乃至一切人非人等赞言。善哉善哉。大雄猛士。汝等如是。法得久住。令诸众生得离恶道速趣善道。尔时世尊欲重明此义。而说偈言

  我告月藏言　　入此贤劫初
  鸠留佛付嘱　　梵等四天下
  遮障诸恶故　　炽然正法眼
  舍离诸恶事　　护持行法者
  不断三宝种　　增长三精气
  休息诸恶趣　　令向诸善道
  拘那含牟尼　　复嘱大梵王
  他化化乐天　　乃至四天王
  次后迦叶佛　　复嘱梵天王
  化乐等四天　　帝释护世王
  过去诸天仙　　为诸世间故
  安置诸宿曜　　令护持养育
  至于浊恶世　　白法尽灭时
  我独觉无上　　安置护人民
  今于大众前　　数数恼乱我
  应当舍说法　　置我令护持
  十方诸菩萨　　一切悉来集
  天王亦来此　　娑婆佛国土
  我问大梵王　　谁昔护持者
  帝释大梵天　　指示余天王
  于时释梵王　　谢过导师言
  我等所王处　　遮障一切恶
  炽然三宝种　　增长三精气
  遮障诸恶朋　　护持善朋党

大集经卷第五十一大方等大集经卷第五十二

        高齐天竺三藏那连提耶舍译

    月藏分第十二诸魔得敬信品第十

尔时会中。有一魔王名曰岁星。即起合掌。向诸魔众。而说偈言

  今此瞿昙仙　　大欲欺陵我
  分布四天下　　一切诸鬼神
  与诸四天王　　皆悉令护持
  唯除于我等　　而不见与分

尔时会中。复有魔王名那罗延月。举手指示魔王波旬。而说偈言

  由此波旬故　　而不分与我
  如是一恶人　　毁灭我等众

尔时会中。复有魔王名卢陀弗师吒。而说偈言

  我等今当共　　远弃魔波旬
  如是弊波旬　　鄙践极恶法
  我等从昔来　　未曾见闻此
  我今咸劝请　　大师瞿昙仙
  真正法宝聚　　炽然令久住
  我等当护持　　养育令增长

尔时魔王波旬。见闻诸魔作一朋党共平论已羞惭耻愧。从座而起合掌向佛。而说偈言

  一切佛世尊　　于诸世间中
  永离于妄语　　最尊独第一
  我今已忏谢　　一切尊导师
  深得生敬信　　一向定归依
  世尊今何故　　犹见生厌贱

尔时世尊。告彼月藏菩萨摩诃萨。而说偈言

  了知清净士　　如是魔波旬
  今实于我所　　种种作留难
  无能尽说过　　今于大众中
  诚心忏谢我　　非是谄曲意
  深敬信三宝　　尊重未曾有
  是故我今与　　如是魔波旬
  当授于无上　　正智菩提记

尔时月藏菩萨摩诃萨白佛言。世尊。凡夫心轻犹豫不定。于三乘中未住究竟。于善于恶不能决定。愿亦不定。以不定故遇善知识得生净信。以信因缘。身口意业所作诸善能发胜愿。以彼善心胜愿因缘。随所悕求得彼最胜妙善报果。大德婆伽婆。譬如群牛食种种草若生若枯亦饮种种清浊等水。及构捋时出纯净乳。从彼净乳出香味酪。从香味酪出生熟酥。从生熟酥出上醍醐胜果成熟。大德婆伽婆。如是凡夫。善心相续能生净信。以信因缘次发胜愿。如是次第得大妙果。如是世尊。发大乘者亦复如是。乃至未得柔顺忍来。心常犹豫动转不定。得顺忍已。于大乘中修六波罗蜜。心不疲惓次第增进。乃至得作自然法王。大德婆伽婆。譬如粪秽散置野田下诸种子以水溉灌。人功助成因缘具足。于诸种子花叶果实具足成熟。大德婆伽婆。如是凡夫以犹豫心于大乘中行六波罗蜜。次第修学得柔顺忍。不久能满六波罗蜜。于阿耨多罗三藐三菩提而成正觉。如是波旬。虽复昔有种种诸恶烦恼炽然种种心行身口意业作诸不善应受苦报。今于佛所深得敬信至诚忏悔发于无上菩提之心。既发心已。即得受于阿耨多罗三藐三菩提记。次第得成无上法王。大德婆伽婆。譬如商主昔虽未见大海宝洲。办具资粮道路不错。共诸商人勤用功力。次第得度大海彼岸到彼种种摩尼宝洲。大德婆伽婆。如是波旬。若能诚心发露忏悔一切恶业。以诸善根至诚回向无上菩提。发大勇猛则能速满六波罗蜜。能度三有生死大海。无边功德皆悉圆满。得到一切智慧宝洲。非是二乘之所能到

尔时佛告月藏菩萨摩诃萨言。了知清净士。如是如是。如汝所说。此魔波旬。今于我前发露忏悔昔所造作一切恶业。已得清净发于无上菩提之心。是故我今与是波旬授于阿耨多罗三藐三菩提记。于未来世当得成于无上法王

尔时复有百亿诸魔。俱共同时从座而起。合掌向佛顶礼佛足而白佛言。世尊。我等亦当发大勇猛护持养育佛之正法炽然三宝种久住于世间。令地精气众生精气法精气皆悉增长。若有世尊声闻弟子住法顺法三业相应而修行者。我等皆悉护持养育一切所须令无所乏。复有世尊声闻弟子。无所积聚。离诸烦恼浊乱斗诤。不相言讼。不求名利。于诸恶法羞惭耻愧。不与四众亲友交通。弃舍聚落独住闲林。坚固勇猛如救头然。于诸善法相应住者。我等当共护持养育一切所须令无所乏。所有一切诸恶众生我悉遮障。于一切处所有斗诤饥馑疾疫他方怨敌非时风雨冰寒毒热蚊虻蛇蝎诸杂虫兽我皆遮护令得敬信。刹利婆罗门毗舍首陀乃至畜生。亦令敬信于佛正法。一切天．龙．夜叉．罗刹．阿修罗．乾闼婆．紧那罗．摩睺罗迦．迦楼罗．鸠槃荼．饿鬼．毗舍遮．富单那．迦吒富单那等。亦令敬信佛之正法。复令一切天龙夜叉罗刹阿修罗乾闼婆紧那罗摩睺罗伽迦楼罗鸠槃荼饿鬼毗舍遮富单那迦吒富单那等。精气具足色力丰盛好香美味充足无乏。所有依地一切草木。根茎枝叶华果繁茂。五谷苗稼增长光泽。及诸衣服亦悉丰饶。土地肥良皆悉可乐。寺舍园林河泉池井宫殿屋宅山薮林野悉令具足。令诸众生于彼住处心得悦乐身不疲惓。若复世尊声闻弟子。有所积聚烦恼散乱懈怠懒惰不应法者。我当弃舍不复护持安置养育自修而住。我今终不于三世佛所而故妄语犯染污罪。佛言。善哉善哉。诸欲自在士。汝应如是炽然我法。乃至能与一切众生安隐快乐。诸仁者。我以法眼复寄阎浮提一切人王。若我弟子于我法中。贪爱积聚烦恼斗诤。与俗相染亲友交通贪求名利。于身口意不应正法。令诸天人不得敬信。乐作诸恶住不善道。令阎浮提诸国王等当如法治。为令佛法得久住故。诸天人等得敬信故

尔时世尊。复告百亿他化自在天。百亿化乐天。百亿兜率陀天。百亿须夜摩天。百亿释提桓因言。诸仁者。如我所说法律毗尼。付嘱汝等。汝当护持如上所说安置养育。作是语已。彼五天王即白佛言。世尊。若有世尊声闻弟子住法顺法三业相应而修行者。我等皆共护持养育供给所须令无所乏。若复世尊声闻弟子无所积聚护持养育亦如上说。若复世尊声闻弟子住于积聚乃至三业与法不相应者。亦当弃舍不复养育自修而住。我今终不于三世佛所而故妄语犯染污罪。佛言。善哉善哉。妙丈夫。汝应如是令我佛法炽然久住。与诸众生安隐快乐。尔时一切诸来大众。天人乾闼婆等。亦复赞彼五天王言。善哉善哉。妙丈夫。我等昔来未闻如是护持养育。诸佛正法久住世间。天人炽盛恶道减少

尔时世尊欲重明此义。而说偈言

  于此娑婆界　　初入贤劫时
  拘楼孙如来　　已嘱于四天
  帝释梵天王　　护持令养育
  炽然三宝种　　增长三精气
  拘那含牟尼　　亦嘱四天下
  梵释诸天王　　护持令养育
  迦叶亦如是　　已嘱四天下
  梵释护世王　　护持行法者
  过去诸仙众　　及以诸天仙
  星辰诸宿曜　　亦嘱令分布
  我出五浊世　　降伏诸魔怨
  而作大集会　　显现佛正法
  诸天咸劝请　　分布四天下
  我时问梵天　　谁昔受付嘱
  梵天不自称　　及以天帝释
  遍观诸天已　　然后忏谢佛
  一切诸天众　　咸共白佛言
  我等所王处　　皆护持正法
  炽然三宝种　　增长三精气
  令息诸病疫　　饥馑及斗诤
  过去诸如来　　教我令安置
  如今尊导师　　亦敕令护持
  世尊复告语　　百亿诸梵天
  百亿天帝释　　百亿四天王
  汝等各皆悉　　于己四天下
  随其所王处　　遮障恶众生
  不令心扰浊　　安住于善处
  修行正法者　　当与不妄念
  若有诸声闻　　勤求涅槃者
  一切有所须　　悉皆供给之
  亦与彼施主　　增益五功德
  寿命报安乐　　精进及智慧
  能速满六度　　证于大菩提
  如是百千亿　　诸天大梵王
  咸共白佛言　　我各于己土
  护持诸声闻　　遮障恶众生
  安住佛正法　　炽然三宝种
  三种味精气　　皆悉令增长
  百亿诸魔众　　皆共生惭愧
  亦悉从座起　　合掌白佛言
  我等皆发心　　护持佛正法
  炽然三宝种　　增长三精气
  安置诸众生　　令住于善道
  为诸众生故　　休息一切恶
  护持于世尊　　行法诸声闻
  持佛真妙法　　三业常相应
  以诸所须物　　养育令无乏
  若有诸声闻　　无所积聚者
  远离斗诤讼　　羞惭于名利
  坚固勤精进　　犹如救头然
  能令无量众　　安住于正法
  一切诸恶处　　皆令可爱乐
  依地所生种　　果药诸苗稼
  悉皆令滋茂　　膏泽香味具
  若有诸声闻　　贪求积聚者
  嗔妒多诤讼　　求利无羞耻
  若有如是辈　　我等当舍离
  我于三世佛　　终不犯妄语
  导师复告语　　汝等诸魔众
  护国诸人王　　遮障恶众生

    大集经月藏分第十二提头赖吒天王护持品第十一

尔时于此世界四天下中。有日天子月天子。告彼疾行坚固天子言。世尊今在佉罗帝山牟尼诸仙所依住处作大集会。佛及弟子为令佛法得久住故。绍三宝种不断绝故。三种精气不损减故。令恶众生得敬信故。使三恶道得休息故。令三善道得增长故。汝等速往彼大集所说欲随喜。我及眷属。于佛正法护持养育。时彼疾行坚固天子往诣佛所。到已头面礼足而白佛言。世尊。彼日天子月天子。遥礼佛足作如是言。我等既是乘车疾行。不得往诣彼大集所。我及眷属说欲随喜。于佛正法我当护持。安置养育令三宝种而得炽然。亦令五星二十八宿皆得正行。三种精气悉令增长。遮障一切不善众生。令善法朋皆得充盛。人天善道具足盈满。佛言。日天子月天子。汝于我法护持养育。令汝长寿无诸衰患。尔时复有百亿提头赖吒天王百亿毗楼勒叉天王百亿毗楼博叉天王百亿毗沙门天王。彼等同时及与眷属从座而起。整理衣服合掌敬礼作如是言。大德婆伽婆。我等各各于己天下。勤作护持养育佛法。令三宝种炽然久住。三种精气皆悉增长。乃至世尊声闻弟子三种善业相应住者。我等于彼勤加护持摄受养育。令心不浊离诸散乱趣涅槃门。随几时中我等常当遮障一切恶心众生令善法朋久住增长。一切斗诤疫病饥馑非时风雨冰寒毒热苦辛涩触无味枯燥臭秽众恶不可乐事悉令休息。何以故。世尊弟子。不作积聚常修慈心与善相应离诸散乱而安住故。佛言。善哉善哉。善男子。汝当如是勤加护持摄受养育我所修习诸佛法眼。诸来大众亦皆赞言。善哉善哉

尔时佛告乐胜提头赖吒天王言。妙丈夫。此四天下阎浮提中东方第四分汝应护持。何以故。此阎浮提诸佛兴处。是故汝应最上护持。过去诸佛已曾教汝护持养育。未来诸佛亦复如是。并及汝子乾闼婆众诸夜叉等一切眷属。应令敬信护持养育。汝有九十一子乐种种行。彼或乘象游行十方。或复乘马。或复乘驼或乘特牛。或乘羖羊。或乘白羊。或复乘龙。或复乘鸟。或乘男夫。或乘妇女。或乘童男。或乘童女游行十方。汝亦应令得生敬信。当共彼等护持阎浮提东方第四分

复有乾闼婆大臣大力军将。初名般支迦。次名般遮罗。次名郎伽罗。次名扇陀。次名奚摩跋多。次名质多斯那。次名那荼王。次名禅那离沙婆。次名尸婆迦。次名牟真邻陀。次名毗湿婆蜜多罗。次名除珍达罗斯等。皆是汝之大臣大力军将。汝亦应令得生敬信。当共彼等护持阎浮提东方第四分

复有四大刹多罗大力军将。有多兵众。一名好长耳。二名好长鼻。三名善充满。四名佉陀梨钵帝。斯等刹多罗皆是汝之大力军将。汝亦应令得生敬信。当共彼等护阎浮提东方第四分

复有乾闼婆大力军将兄弟三人。常将兵众有大势力。彼等皆悉受汝教令。一名乐欲。二名著欲。三名喜歌。复有乾闼婆兄弟十一人初名鞞利迦。次名槃梯。次名蓝菩尸仛。次名迦罗荼。次名拘抧罗声。次名耶舍失利。次名耶舍槃多。次名耶输达罗。次名摩罗槃妒。次名摩罗缦都。次名摩头曼多。复有乾闼婆兄弟三人。一名尸利曼都。二名头坻曼多。三名富师波曼多。复有乾闼婆三十三人初名萨陀曼都。次名耶阇曼多。次名檀那曼多。次名难提迦。次名忧波罗。次名波头摩。次名栴檀。次名栴檀那。次名度卢摩罗娑。次名般遮罗。次名拘抧罗苏婆罗。次名沾浮罗。次名般遮尸佉。次名搔跋尼。次名苏罗斯。次名摩罗毗。次名跋达那。次名迦摩尸利吒。次名尼干吒。次名尼干吒迦。次名婆提浮罗。次名耶输陀罗。次名毗首婆蜜多罗。次名尸骞陀。次名天鼓。次名摩兜罗。次名质多罗斯那。次名那荼王。次名禅那梨沙婆。次名尸婆迦。次名牟真邻陀。次名毗首婆蜜哆庐。次名除珍达罗。如是乾闼婆有多军众大有势力。汝亦应令得生敬信。当共彼等护持阎浮提东方第四分

复有十六天神有大势力具足神通。初名最胜。次名上胜。次名成就义。次名他不胜。次名上喜。次名喜军。次名乐喜。次名增长喜。次名饶财。次名多饶财。次名具毛。次名十毛。次名饶毛。次名忧波罗。次名钵摩迦。次名赊摩。如是十六诸天神王大有威力。汝亦应令得生敬信。当共彼等护持阎浮提东方第四分

东方有处名遮波罗。过去诸佛曾依彼住。亦是罗汉诸贤圣众得证果处。诸天人等发心修行所依住处。汝等应以大精进力护持阎浮提东方第四分

东方有山名阿跋多。次名梨师三婆婆。亦是过去诸佛贤圣本修行处。诸天人等依于此处得见圣谛。是故汝等当以大精进力护持阎浮提东方第四分

东方复有三曜七宿三天童女。应令彼等于其昼夜正行世间。汝共彼等护持阎浮提东方第四分

东方复有天龙夜叉罗刹鸠槃荼饿鬼毗舍遮富单那迦吒富单那等住汝东方无所属者。我当于后分布彼等安置诸国令汝护持。尔时乐胜提头赖吒天王白佛言。世尊。如是如是。大德婆伽婆。过去诸佛付嘱安置护持养育。亦教我等护持东方弗婆提界。如今世尊教我安置一等无异。我当深心顶戴敬受于佛正法。护持阎浮提东方第四分。并我诸宫眷属大小亦令护持。于三恶趣皆令休息。于三善道皆悉炽然

尔时乐胜提头赖吒天王。复有刹多罗辅佐大臣男夫妇女童男童女。一切皆共从座而起。合掌向佛头面礼足而白佛言。世尊。我等今于导师世尊得生深信。尊重敬仰得未曾有。法宝僧宝亦生深信。尊重敬仰得未曾有。大德婆伽婆。我等从今精勤护持阎浮提界东方第四分。世尊所有声闻弟子。若比丘比丘尼优婆塞优婆夷。若余众生于三善业相应住者。敬信三宝供养奉施听受法者。于佛正法发心修行受持禁戒相应住者。并勤供养诸众僧者。我等常当护持养育。若复有余诸众生等住阿兰若。及佛弟子住法顺法。发心坚固如犀牛角。独而无侣住于闲林。我等当以一切所须供养奉施护持养育。若复有余一切众生见彼闲林相应住者能以所须勤供养者。我等亦当护持养育令其所须悉得称意。亦令长寿无诸衰病财富自在安隐快乐善名流布。大德婆伽婆。我等当作如是等事护持养育。于佛正法亦令一切斗诤疫病饥馑俭短非时风雨悉令休息。复令一切花果药草五谷等物滋茂成熟肥腻软泽善香美味妙色增盛。又令地味众生味法醍醐味滋茂增长。如是精味得增长故。息三恶道善道盈满。佛法久住炽然世间。佛言。善哉善哉。妙丈夫。汝等精勤作如是事护持养育。令我法眼久住炽然。善说法律能生信解。则为具足供养三世一切诸佛。汝等便得寿命增长法增长眷属增长名称增长色力增长善朋增长舍宅增长信增长戒增长闻增长精进增长念增长慧增长。如是等事得增长故。便能速满六波罗蜜。得成无上自然法王如我今也。尔时一切诸来大众。天人乾闼婆等咸皆赞言。善哉善哉妙丈夫。汝应如是精勤护持诸佛正法令得久住炽然在世使不断绝

尔时世尊。欲重明此义。而说偈言

  世间二神通　　日月遣使来
  疾行坚天子　　今与大众欲
  如是佛正法　　我等当守护
  炽然三宝种　　星辰得正行
  增长三精气　　遮障恶众生
  法朋得增长　　善道皆盈满
  百亿提头赖　　勒叉毗楼博
  百亿毗沙门　　咸共白佛言
  我于己天下　　各皆勤护持
  乃至诸比丘　　少欲离积聚
  我等遮诸恶　　法朋得增长
  斗诤病饥馑　　诸恶令休息
  导师佛告言　　乐胜提头赖
  过去诸如来　　已教汝安置
  护持阎浮提　　东方第四分
  汝军及眷属　　亦令法眼增
  提头白佛言　　唯然大雄猛
  我军大力众　　法眼令炽然
  除诸不善法　　遮障恶众生
  常护诸声闻　　无所积聚者
  乾闼婆悉起　　亦复白佛言
  声闻无积聚　　饮食令无乏
  我等护持法　　住法境界者
  养育彼施主　　我等亦护持
  遮障恶众生　　法朋令炽然
  三种精气增　　善道皆充满

    大集经月藏分第十二毗楼勒叉天王品第十二

尔时佛告火花毗楼勒叉天王言。妙丈夫。此四天下阎浮提界南方第四分。汝应护持。何以故。此阎浮提诸佛兴处。是故汝应最上护持。过去诸佛已曾教汝护持养育。未来诸佛亦复如是。并及汝子一切眷属大臣军将夜叉罗刹。皆令护持。汝有九十一子。乐种种行。或复乘象游行十方。乃至或乘童男童女游行十方。汝亦应令得生敬信。共护阎浮提南方第四分

复有鸠槃茶大臣有多兵众大有势力。初名跋那拘。次名阿吒薄拘。次名婆吒迦。次名薮支卢摩。次名阿斯目佉。次名跌荼尸帝。次名摩兜罗。次名跌荼泥弥。次名帝利揵吒迦。次名栴檀那。次名伽罗竭陀。次名薮目佉。次名陀提目佉。乃至复有四刹多罗。一名金刚轮。二名金刚焰。三名箭毛。四名风王。彼等皆有大力兵众。乃至复有鸠槃荼大力军将兄弟九人。一名檀提。二名忧波檀提。三名葛迦赊。四名钵湿。五名摩诃钵湿婆。六名大肚。七名象手。八名十手。九名火手。复有鸠槃茶兄弟三人。一名地行。二名山行。三名左行。复有鸠槃茶兄弟三人。一名黑色。二名朱目。三名云色。复有鸠槃茶兄弟四人。一名无垢。二名无疮疣。三名云天。四名大力。复有鸠槃茶二十六人。初名长耳。次名长乳。次名独象。次名编发。次名十杵。次名十目。次名孤树。次名乐欲。次名大欲。次名木师。次名爱子。次名三鸠槃荼子。次名一切巷。次名杂色。次名彩眼。次名满瓶。次名瓶眼。次名无病。次名刍叉。次名黄发。次名多茶叉。次名叉叉。次名缕綖。次名啖蝇。次名马水。次名啖髓。斯等鸠槃茶大力军将。有大势力多有兵众。汝亦应令得生敬信。共护阎浮提南方第四分

复有十六诸天神王。初名杂止。次名杂发。次名芬陀利。次名妙光。次名火光。次名独闇。次名多闇次名斑驳。次名月尊。次名众杂。次名夜暮。次名欺陵。次名不欺陵。次名恶抧。次名婆苏抧。次名他不胜。斯等十六诸天神王。有多兵众大有势力。汝亦应令得生敬信。共护阎浮提南方第四分

南方有塔名善安住。过去诸佛诸仙贤圣曾于彼住见四圣谛。南方有山名曰善现。过去诸佛诸贤圣众亦于彼住见四圣谛。南方复有三曜七宿三天童女。汝亦应令正行于世。共护阎浮提南方第四分

南方复有天龙夜叉罗刹乾闼婆鸠槃茶阿修罗迦楼罗紧那罗摩睺罗伽饿鬼毗舍遮富单那迦吒富单那住汝南方无所属者。我当于后分布安置随其国土。亦令汝等护持养育。尔时火华毗楼勒叉天王白佛言。世尊。如是如是。大德婆伽婆。去诸过佛已曾嘱我教令安置。亦为过去诸天神仙教我安置护持阎浮提南方第四分。如今世尊亦教安置。我当顶受护持养育。我及眷属大臣军将亦复护持养育佛法。乃至于三恶趣皆悉休息。于三善道增长盈满

尔时火花毗楼勒叉天王眷属。刹多罗等大臣辅佐鸠槃大将男夫妇女童男童女。彼等皆悉从坐而起。向佛合掌顶礼佛足。而白佛言世尊。我等今于导师世尊得生深信尊重敬仰得未曾有。法宝僧宝亦生深信尊重敬仰得未曾有。大德婆伽婆。我等从今精勤养育护持阎浮提南方第四分。乃至令佛正法久住炽然。恶道休息善道盈满。佛言。善哉善哉妙丈夫。乃至一切诸来大众。天人乾闼婆咸共赞言。善哉善哉

尔时世尊。欲重明此义。而说偈言

  佛告毗楼勒　　大臣鸠槃茶
  过去佛教汝　　护持于南方
  古昔诸天仙　　亦教汝安置
  炽然正法朋　　遮障恶众生
  导师今告汝　　令我法炽然
  当受我寄付　　如来正法眼
  炽然三宝种　　三种精气增
  饮食众味药　　膏泽丰可乐
  住法诸比丘　　乃至无积聚
  应当护养育　　令无所乏少
  亦护彼施主　　财命乐富慧
  五事常饶益　　悉令得增长
  正行诸宿曜　　星辰岁四时
  令竭三恶趣　　善道皆盈满

    大集经月藏分第十二毗楼博叉天王品第十三

尔时佛告栴檀华毗楼博叉天王言。妙丈夫。此四天下阎浮提界西方第四分。汝应护持。何以故。此阎浮提诸佛兴处。是故汝应最上护持。过去诸佛已曾教汝护持养育。未来诸佛亦复如是。并及汝子大臣眷属亦令护持。汝有九十一子。乐种种行如上所说。复有诸龙大臣兵众有大势力。一名师子。二名师子发。三名自在。四名黄头。五名黄鼬。六名赤目。七名瞿耽摩。八名山水。乃至复有四刹多罗。一名鸯瞿。二名朚瞿。三名儚(亡曾反)伽叉。四名阇叉附。乃至复有诸龙军将。有大势力常将兵众。初名难陀。次名忧波难陀。次名善现。次名阿那婆达多。次名和修吉。次名善建立。次名天齿。次名得叉迦。次名婆楼那。次名婆娑婆。次名阿楼那。次名侯楼荼。次名冰伽罗。次名生伽罗。次名功德。次名妙德。次名功德满。次名虚妄行。次名波赊。次名摩诃波赊。次名禅那。次名宅施。次名海施。次名阎浮施。次名睒婆罗。次名善臂。次名苏摩那。次名日光。次名月光。次名月眼。次名栴檀。次名妙贤。次名妙耳。次名质多罗。次名施色。次名頞支。次名牟真邻陀。次名蓝净罗。次名迦那迦。次名象耳。次名般筹迦。次名声佉。次名伊罗钵。次名阿波罗逻。次名那罗达。次名忧波那罗。次名尸利迦。次名庵罗提他。次名婆稚子。次名提到罗吒。次名瞻波。次名瞿昙摩。次名般遮梨。次名项力。次名黚(九严反)婆利。次名毗摩。次名山臂。次名恒伽。次名辛头。次名博叉。次名私陀斯。如是等六十一龙。皆是汝之大力军将。乃至西方十六天神。亦有兵众有大势力。初名萨沙婆帝。次名西赊婆帝。次名耶输陀罗。次名耶赊跋帝。次名郁伽摩。次名第一善。次名善觉。次名善起。次名阐陀。次名毗阐陀。次名离垢。次名毗楼茶。次名牛仙。次名瞻婆迦。次名优楼阇。次名迦迦吒誓。乃至西方有塔名曰极雨。乃至有山名曰香风。乃至有山名众色重阁。乃至西方复有三曜七宿三天童女。皆令正行共护阎浮提西方第四分。西方所有诸天龙鬼乃至迦吒富单那等住汝西方无所属者。我当于后分布安置随其国土亦令汝等护持养育

尔时栴檀华毗楼博叉天王。作如是言。大德婆伽婆。过去诸佛已曾如是教我安置护持养育此阎浮提西方第四分。如今世尊教我安置等无有异。我今佛前深受教敕护持西方诸佛正法。乃至善道皆令盈满。尔时毗楼博叉复于佛前。而说偈言

  毗楼博叉王　　共诸龙臣言
  过去佛天仙　　敕我护西方
  并诸龙军众　　遮障恶众生
  斗乱诸病疫　　汝应令休息
  增长三精气　　及护我法眼
  住法诸比丘　　少欲无积聚
  护持增寿命　　及色力乐瞻
  如是天人师　　今悉向我说
  深信佛所敕　　我今顶戴受
  护持三宝种　　炽然正法眼
  住法诸声闻　　我等当护持
  共诸龙军众　　除诸不善法
  遮障恶众生　　令彼悉休息
  华果药丰饶　　膏泽众味具
  令诸刹利王　　敬信佛正法
  毗舍及首陀　　龙神夜叉众
  我令彼得信　　深敬佛所说
  护持在闲林　　少欲无积聚
  正行诸宿曜　　星辰岁四时
  令竭三恶趣　　善道皆盈满

    大集经月藏分第十二毗沙门天王品第十四

尔时佛告拘鞞罗毗沙门天王言。妙丈夫。此四天下阎浮提界北方第四分。汝应护持。何以故。此阎浮提诸佛兴处。是故汝应最上护持。过去诸佛已曾教汝护持养育。未来诸佛亦复如是。并及汝子大臣眷属夜叉毗舍遮皆令护持。汝有九十一子。乐种种行。彼或乘象游行十方。或复乘马。或复乘驼。或乘特牛。或乘羖羊。或乘白羊。或复乘龙。或复乘鸟。或乘男夫。或乘妇女。或乘童男。或乘童女。游行十方。汝亦应令得生敬信。共护阎浮提北方第四分

复有夜叉大臣大力军将。初名无病。次名吉祥。次名安隐。次名成利。次名他不胜。次名满愿。次名丰饶。次名欢喜。次名水尽(丹盖)次名南浮沙度。次名电光。次名火光。次名水眼。次名郁伽。次名好耳。次名摄受。斯等夜叉是汝大臣大力军将。应令彼等得生敬信。共护阎浮提北方第四分

复有四大刹多罗。一名长目。二名长面。三名坐瓮。四名花杖。斯等刹多罗皆是汝之大力军将。汝亦应令得生敬信。共护阎浮提北方第四分

复有夜叉大力军将。常将兵众。初名因陀罗。次名苏摩。次名婆楼那。次名婆阇波帝。次名婆罗波阇。次名伊奢那。次名胜欲。次名栴檀。次名尼干吒。次名尼干吒迦。次名婆稚。次名摩尼遮罗。次名波尼逻。次名忧般遮迦。次名娑陀只利。次名奚摩跋多。次名萨他。次名波罗末檀那。次名干竹迦。次名迦摩多卑。次名富楼那。次名佉陀利。次名瞿波利。次名只呵知。次名阿吒迦。次名阿吒薄拘。次名那罗提。次名那罗逻担。次名禅那梨沙婆。次名质多罗迦。次名质多斯那。次名施婆利。次名涅伽多。次名长牟。次名摩那吒。次名摩那婆。次名枲何度。次名毗卢遮那。次名伏龙。次名毗摩。次名护门。次名多摩那。次名能迷惑。次名取意。次名子男婆。次名伽吒僧叉。次名钵干沓婆。次名明月。次名阿婆娑婆。次名三牟达罗。次名牛仙。斯等五十夜叉军将。皆是汝之大力军众受汝教敕。汝亦应令得生敬信。共护阎浮提北方第四分

复有十六诸天神王。初名伊荼。次名鞞荼。次名那荼。次名天莲花。次名钵陀摩跋帝。次名黟(一兮反)干絺多。次名摩诃军阇。次名阿奚多。次名奚多奢耶。次名毗楼稚。次名忧波罗。次名月。次名如月。次名婆楼那。次名三波帝。斯等十六诸天神王亦有大力有多军众。汝亦应令得生敬信。共护阎浮提北方第四分。北方有塔名尸佉利。过去诸佛诸仙贤圣依彼住处见四圣谛。北方有山名曰申渠。日月天子所居住处。及大神力名称鬼神所依住处。汝以彼等大精进力。共护阎浮提北方第四分

北方复有三曜七宿三天童女。汝亦应令正行于世。共护阎浮提北方第四分。北方所有天龙夜叉罗刹鸠槃茶饿鬼毗舍遮富单那迦吒富单那。住汝北方无所属者。我当于后分布安置随其国土亦令汝等护持养育

尔时拘毗罗毗沙门天王白佛言。世尊。如是如是。大德婆伽婆。过去诸佛已曾教我令作护持安置养育此阎浮提北方第四分。我今如是深受佛教护持阎浮提北方诸佛法

尔时拘毗罗毗沙门王儿及大臣刹多罗等诸夜叉将十六天神一切眷属男夫妇女童男童女皆从座起。合掌向佛顶礼佛足。而白佛言。大德婆伽婆。我及眷属。今于佛所得生深信尊重敬仰得未曾有。法宝僧宝亦生深信尊重敬仰得未曾有。大德婆伽婆。我等从今诚心殷勤摄伏恶心诸众生故。勤加护持此阎浮提北方第四分。我今亦与上首毗沙门王。同心护持此阎浮提北方诸佛法

尔时拘毗罗毗沙门王复白佛言。世尊。若佛弟子比丘比丘尼优婆塞优婆夷。于佛正法三业相应者。专心听法如说修行学持戒者。若余众生于三宝所得敬信者。供佛施僧勤修福业者。我与眷属皆共同心受佛寄付为作安置护持养育。若佛弟子依阿兰若住法顺法勤加修行。如犀牛角独而无侣住于闲林。我当倍复护持养育。若有众生。于彼闲林世尊所有修行声闻勤修供养无所乏者。我当方便护持养育五事饶益。何谓为五。一者寿命增长。二者财增长。三者无病增长。四者乐增长。五者称誉增长。我以如是护持养育令具足故。三宝炽然佛种久住。若有众生。于己境界贪求聚积无有厌足。不观后世可怖畏事。嗔恶躁急无有慈愍。触恼刹利种种兵仗共相战斗。屠割斫刺捕猎杀害。牢狱系闭讁罚摈黜。杀生偷盗乃至邪见。而与刹利作恶因缘。及婆罗门毗舍首陀男夫妇女童男童女乃至畜生共相触恼作恶因缘。令彼众生迭相杀害种种劫夺。无量恶行因缘集会。我当遮障诸恶众生。令住慈心悲心信心戒心舍心闻心慧心。令离不善安置善处。遮诸斗诤疫病饥馑非时风雨及恶霜雹。亦复遮障一切恶象师子虎狼恶牛恶马熊罴鹰鹞蚊虻蝇蚤。亦令一切花叶果药五谷滋茂众香美味好色腻泽。皆悉可乐常令丰足。地味精气众生味精气法醍醐味精气。如是精气增长。世间所有枯燥粗涩恶色无味臭秽花叶果药不可爱乐不中用物。我令彼等皆悉隐没。如是地味精气众生味精气法醍醐味精气增长久住。以地味精气众生味精气法醍醐味精气增长久住故。如是佛法增长久住。以是佛法增长久住故。一切众生生死烦恼长夜休息。得入无畏大涅槃城。以是因缘。我共军将大臣眷属。护持阎浮提北方第四分。令佛法眼久住炽然。乃至亦令世尊弟子无所积聚住于闲林。如犀牛角独而无侣。三业相应如救头然。不相调弄欺陵斗诤。于诸众生生慈心悲心愍心信心戒心舍心精进心念心定心慧心。大德婆伽婆。我等如是令佛法眼久住世间。于三宝种炽然久住。亦令世间一切众生不可乐事苦触等物悉令休息。遮恶众生建立善法。息三恶趣增三善道。若复世尊声闻弟子。弃舍正念弃舍思惟弃舍正观弃舍读诵及为他说。弃舍正法所修行事。营综家业种种生具商贾。种植园林果树。畜养奴婢象马驼驴牛羊鸡犬猪豚獐鹿鹰鹞孔雀。勤修王家所有事业。城邑事聚落事家业事。与俗交通驱使走役通致信命。贮积钱财饮食衣服稻粟缯帛。于他财物亦复守护藏惜积聚。或复咒术或以书画教他自活。若如是者我等不能护持养育。我今终不于三世佛所而故妄语犯染污罪。佛言。善哉善哉妙丈夫。我于无量阿僧祇劫所修法眼善说正法毗尼正戒。如是勤加护持养育令久住者。则为供养三世诸佛。汝等如是则得寿命增长财增长力增长乐增长朋党增长眷属增长宫殿增长信增长戒增长闻增长精进增长舍增长念增长慧增长。以是增长因缘力故。便能速满六波罗蜜成等正觉。犹如我今得成无上自然法王。我今复以佛之正法。付嘱阎浮提诸大国王。于我灭后护持养育。若有比丘离诸惭愧污染我法。私立田业畜养奴婢乃至畜生而作种种家业生活。如是比丘。阎浮提界诸大国王。应当遮障呵责摈黜令离诸过。护持养育令行正法

尔时一切诸来大众。天人乾闼婆阿修罗人非人等。咸皆赞言。善哉善哉妙丈夫。汝为佛法得久住故勤加护持

尔时世尊。欲重明此义。而说偈言

  佛告毗沙门　　及千夜叉众
  汝等皆应共　　护持于北方
  住法诸比丘　　惭愧声闻等
  汝受我寄付　　勤加护养育
  过去尊导师　　敕汝令安置
  护持佛正法　　遮障恶众生
  增长三精气　　息诸斗诤讼
  相应诸声闻　　亦当勤护之
  毗沙门王言　　如是佛正法
  寄付我顶受　　勤加护养育
  炽然正法眼　　增长三精气
  遮障恶众生　　勤断诸斗讼
  无积聚声闻　　少欲知足者
  能离诸恶业　　我亦勤护持
  若有能供养　　修行诸声闻
  当以五事增　　饶益于彼等
  腻泽香美味　　华果众药草
  为令彼受用　　我悉令丰饶
  三种味精气　　彼得增长故
  我等勤护持　　佛法久炽然
  我复令国王　　剃发无惭者
  彼等王应遮　　大众咸皆赞

大集经卷第五十二大方等大集经卷第五十三

        高齐天竺三藏那连提耶舍译

    月藏分第十二咒轮护持品第十五

尔时世尊。复告四天王言。我今与汝大力雄猛不可害轮大明咒句。如是咒句。过去亿百千万诸佛之所演说。汝若持此大力雄猛不可害轮大明咒句。一切诸魔及魔眷属尚不敢近何能触娆

尔时世尊。作是语已。即说咒曰

哆绖夜他(一)阿婆夜陀提(二)毗喽陀毗羯啰咩(三)阿那毗[口*梨](四)阿那罗移(五)阿毗勤泥(六)阿拘毗移(七)阿咒帝(八)输婆提市(九)提阇婆底(十)摩诃提帝(十一)忧簸舍咩(十二)迷哆啰伽帝(十三)阿婆喽[口*兮](十四)迷达涕(十五)頞他悉地(十六)舒婆谟遮(十七)婆蒱娑婆帝(十八)娑摩竭啰舒只(十九)阿[少/兔]哆[口*梨](二十)达摩毗诃[口*梨](二十一)哆他多娑摩底(二十二)佛陀地虱他泥(二十三)尸啰毗首地(二十四)阿[少/(兔-、)]竭啰咩(二十五)阿僧诃唎移(二十六)复多具致(二十七)阿毗市聂帝(二十八)苏婆呵(二十九)

诸仁者。此是汝等四大天王。大力雄猛不可害轮大明咒句。如是咒句。过去亿百千万诸佛之所演说。汝若持此大力雄猛不可害轮大明咒句。一切诸魔及魔眷属尚不敢近何能触娆。尔时所有一切诸魔及魔眷属皆悉惊怖无有势力。各各羞惭向佛合掌

尔时世尊。复告毗沙门天王言。我今与汝北方大力雄猛不可害轮大明咒句。汝以持此大力雄猛不可害轮大明咒故。于己眷属及他眷属．天．龙．夜叉．罗刹．阿修罗．乾闼婆．鸠槃茶．饿鬼．毗舍遮．富单那．迦吒富单那．尚不敢近何能触娆。汝于一切恶鬼神所。当得大力雄猛不可害轮

尔时世尊。作是语已。即说咒曰

哆绖夜他(一)勿檀泥(二)钵罗勿檀泥(三)勿达那跋帝(四)渠唎乾陀利(五)朱唎(六)旃茶唎(七)頞唎毗阇耶末提(八)驱驱勿檀泥(九)跋罗(十)吠罗(十一)勿檀泥(十二)苏婆呵(十三)

汝以此咒北方当得大力雄猛不可害轮于己眷属及他眷属尚不敢近何能触娆

尔时世尊。复告提头赖吒天王言。我今与汝东方大力雄猛大明咒句乃至当得不可害轮

尔时世尊。作是语已。即说咒曰

哆绖夜他(一)丘喽阇帝(二)勿喽阇帝(三)钵罗帝虱虿(四)摩诃萨[口*(黍-禾+利)](五)崎啰跋帝(六)郁那婆帝(七)伽楼婆帝(八)求喽鞞(九)勿喽鞞(十)求喽勿喽鞞(十一)求喽求喽(十二)勿喽干提(十三)勿喽阇帝(十四)阿罗娑婆帝(十五)摩罗娑婆帝(十六)黟泥迷泥(十七)多豆婆南(十八)多豆婆南(十九)苏婆呵(二十)

汝以此咒。东方当得大力雄猛不可害轮。于己眷属及他眷属尚不敢近何能触娆

尔时世尊。复告毗楼勒叉天王言。我今与汝南方大力雄猛大明咒句。乃至当得不可害轮

尔时世尊。作是语已。即说咒曰

哆绖夜他(一)耆唎耆唎(二)耆卢那跋帝(三)[口*兮]泥(四)呵腻泥(五)阿泥那跋帝(六)群筹群筹(七)苏婆呵(八)

汝以此咒。南方当得大力雄猛不可害轮于己眷属及他眷属尚不敢近何能触娆

尔时世尊。复告毗楼博叉天王言。我当与汝西方大力雄猛不可害轮大明咒句。汝以持此大力雄猛不可害轮大明咒故。于己眷属及他眷属诸龙夜叉罗刹阿修罗乾闼婆鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。尚不敢近何能触娆

尔时世尊。作是语已。即说咒曰

哆绖夜他(一)阿毗婆喽泥(二)婆喽拏跋帝(三)勿啰竭啰跋帝(四)婆喽泥(五)婆喽拏耶世(六)忧受婆罗(七)钵啰受娑[口*(黍-禾+利)](八)腻受婆隶(九)摩呵受婆隶(十)受婆逻(十一)摩身达啰舍(十二)娑阇鞞(十三)萨婆哆啰毗唎帝(十四)讫利多耶世失虿(丑芥反十五)苏婆呵(十六)

汝以此咒。西方当得大力雄猛不可害轮。于己眷属及他眷属尚不敢近何能触娆

尔时世尊。复告四大天王。而说偈言

  诸山有称誉　　自在者化作
  极两鸡罗娑　　香仙佉罗担
  风火及雪山　　日月所居处
  北方常护持　　世尊真妙法
  般支般遮罗　　讫尼伽罗度
  彼等常护持　　四维佛正法
  地神大地神　　黑色大黑色
  罗睺毗摩质　　须质波罗陀
  婆稚睒婆利　　及牟真邻陀
  共护于下方　　世尊真妙法

    大集经月藏分第十二忍辱品第十六之一

尔时有一阿修罗王。名曰火味。在彼会中。从座而起。举手而指罗睺罗阿修罗王。向四百亿阿修罗王。作如是言。此罗睺罗阿修罗王。是我等辈尊重师长。能以福慧益诸众生自在勇猛。诸阿修罗中最胜第一。罗睺罗王及与我等。皆为瞿昙之所欺陵。为令佛法得炽然故。付嘱余众而不见与故。令我等受大耻辱。次复有一阿修罗王。名镇星毗摩。作如是言。我等昔来。各各于己四天下中。与释提桓因共相齐等。今如野干逐师子后。我等宁可舍此凡下还于本国城邑宫殿。又我宁死何能忍受如是陵辱。此是大怨。令我等辈生大忧苦。时罗睺罗阿修罗王。作如是言。众生宁可最胜人边受其骂辱。不于凡下而得赞叹。何以故。令多好人所轻贱故。此天人师。于三界中最胜自在。住于彼岸善知时宜随其所应故如是也

尔时月藏菩萨摩诃萨。合掌向佛一心敬礼。而作是言。导师当观此罗睺罗阿修罗王。具有如是坚慧胜慧。安住坚信乐善乐忍。持戒清净深信三宝。不久速成无上导师。唯愿世尊。炽然法故应当与此罗睺罗分

尔时世尊。告四百亿阿修罗王。而说偈言

  汝先具诸德　　各已住净信
  如是昔诸佛　　嘱法与汝等
  我今以此法　　悉亦付嘱汝
  当以诸方便　　护持我法眼
  汝等作是福　　增满大智海
  各于自境界　　守护我正法
  住法常乐忍　　护持定根者
  汝等若如是　　咸供三世佛
  常诣于善趣　　命智果具足
  于世流转时　　得离诸恶道
  诸求胜报者　　当炽我法眼
  各于己国土　　遮障恶众生

尔时诸阿修罗悉起合掌。咸作是言

  我等阿修罗　　各各于己国
  休息一切恶　　炽然世尊法
  习行法施者　　于恶作护持
  增长三精气　　离恶住善道

尔时诸来一切大众。诸天及人乾闼婆等。咸皆叹诸阿修罗言。善哉善哉

尔时世尊。亦复叹彼四百亿阿修罗王及诸眷属。作如是言。善哉善哉妙丈夫辈。汝能如是。是名供养三世诸佛。当勤护持养育我法。佛之法眼而得炽然。令三宝种久不断绝。是故我今将于汝等及诸眷属。付嘱十方一切诸佛现在住世未涅槃者。及付贤劫一切菩萨摩诃萨。汝等常与彼诸阿修罗生生相值。汝当于此贤劫之中得成正觉出于世时。当与汝等作上施主。护持正法持戒第一得禅三昧具足忍力。如此贤劫最后如来。名曰卢遮应正遍知。出现于世。尔时卢遮当授彼等阿耨多罗三藐三菩提记。便得速满六波罗蜜。不久当为无上法王。得入无畏涅槃大城。如是若复有诸众生。若现在世及未来世。于我法中出家修道三业相应。若复放人出家修道。若复有能勤加护持养育供给。我诸声闻比丘比丘尼优婆塞优婆夷。令三宝种得不断绝。若有能修檀波罗蜜乃至般若波罗蜜。若有营造塔庙形像及以修故。种种舍施供养供给四方众僧。置立寺舍及以修故。又复于彼四方僧寺。舍施种种衣服卧具器物所须。及施田宅财宝园林僮仆给使乃至畜生。若复见他舍施诸物还追夺者以力遮护。若复施我声闻弟子衣服饮食卧具汤药一切所须。我之所有声闻弟子。或有因缘遭遇苦恼。若以自力若假他力方便令脱。我以如是诸众生等。悉皆付嘱十方现在一切诸佛。及付贤劫所有菩萨摩诃萨等。令其摄受生得相值。若彼贤劫诸佛出世。是诸众生。于彼佛所作大施主。守护正法持戒第一得禅三昧具足忍力。如此贤劫最后如来出现于世。于时彼佛当授彼等阿耨多罗三藐三菩提记。便得速满六波罗蜜。不久当为无上法王得入无畏涅槃大城

尔时复有无量亿百千众生。悲泪满目瞻仰如来作如是言。我今观诸大悲世尊所有解脱。出于三界一切诸道生死牢狱。舍于渴爱离世八法及我我所憍慢烦恼。离于一切十二有支。知一切法犹如虚空住不颠倒。常于众生起大悲心。然诸如来。为众生故令此法眼及三宝种于此娑婆久住不灭故加护持。如来今复以诸天．龙．夜叉．罗刹．乾闼婆．紧那罗．迦楼罗．摩睺罗伽．鸠槃茶．饿鬼．毗舍遮．富单那．迦吒富单那．人．非人等。寄付诸佛及诸菩萨。彼诸众生。现在未来若布施若持戒若修定慧。于此佛法精勤相应。寄付诸佛及诸菩萨摩诃萨等。为满六波罗蜜令得阿耨多罗三藐三菩提故。若有众生厌苦求乐。无不于现在世及未来世方便精勤护持养育炽然法眼绍三宝种而能得之。佛言。如是如是。如汝所言。若有爱已厌苦求乐。应当护持诸佛正法。从此当得无量福报。若有众生。为我出家剃除须发被服袈裟。设不持戒彼等悉已为涅槃印之所印也。若复出家不持戒者。有以非法而作恼乱骂辱毁呰。以手刀杖打缚斫截。若夺衣钵及夺种种资生具者。是人则坏三世诸佛真实报身。则挑一切天人眼目。是人为欲隐没诸佛所有正法三宝种故。令诸天人不得利益堕地狱故。为三恶道增长盈满故。何以故。我昔为于一切众生修菩萨行。为此法眼于诸众生起大悲心。舍己身血犹如大海。与诸乞者舍头犹如毗福罗山。眼耳亦尔。舍鼻犹如。百千突卢那。舍舌犹如一突卢那。舍手舍脚各皆亦如毗福罗山。舍皮可覆一阎浮提。亦舍无量象马车牛奴婢妻子及以王位与诸乞者。亦复舍于无量国土城邑宫殿村落舍宅寺庙园林衣服卧具山泽林薮与诸乞者。于诸佛所受持禁戒而无缺犯。一一佛所无量供养。一一佛所禀受无量那由他百千法门。受持读诵护持戒行善修三昧陀罗尼忍。又我亦曾供养恭敬无量无边菩萨摩诃萨。供养恭敬无量缘觉。供养无量佛声闻众。供养无量到果声闻。供养无量外道仙人。供养无量父母师长。供养无量病苦之者。亦于无量苦逼众生无救护者为作救护。无归依者为作归依。无趣向者为作趣向。令其安住及以供养。我已无量长远劫数修诸苦行持戒威仪梵行具足。诸仁者。我已如是于彼三大阿僧祇劫悲愍一切苦众生故。发大坚固勇猛之心。久修无上菩提之行。我今于此盲冥世间无大导师俭法之时。极恶增长白法尽时。五无间业诽谤正法毁呰贤圣与不善根相应众生。嗔恶穬涩离诸羞耻无有慈愍。不观后世可怖畏事。于如是等诸众生中。发心愿成阿耨多罗三藐三菩提。复于一切净佛国土所弃众生中降大法雨。复愿与彼诸众生等除如金刚坚固烦恼。彼等众生随其所欲于三乘菩提令不退转。复愿救度三恶众生安置善道及涅槃乐。与彼众生作正法眼加护令得久住于世长夜炽然。彼诸众生于我法中出家剃发被服袈裟不持禁戒。若有供养彼等人者。如是众生亦得大果。何况为我出家持戒住法相应。供养侍者即得无量阿僧祇大福德聚。何况复能种种供养我诸声闻圣弟子众。而当不得无量不可说阿僧祇大福德聚。是故我今于如是等诸众生中。于阿耨多罗三藐三菩提而成正觉。一切世间天人中最以大悲故。建立一切诸声闻众为上福田。所谓得向八大丈夫。以是缘故。所有众生于现在世及未来世应当深信佛法众僧。彼诸众生于人天中当得受于胜妙果报。不久当得入无畏城。如是乃至供养一人为我出家及有依我剃除须发着袈裟片不受戒者。供养是人亦得乃至入无畏城。以是缘故我如是说。若复有人为我出家不持禁戒剃除须发着袈裟片。有以非法恼害此者。乃至破坏三世诸佛法身报身。乃至盈满三恶道故。是故我上如是告汝。若有爱己求乐离苦。应当精勤护持养育炽然法眼绍隆三宝令不断绝。以是因缘。从此当得无量福报

尔时月藏菩萨摩诃萨复与八千亿那由他百千菩萨摩诃萨。俱从座起合掌向佛。一心敬礼作如是言。如是如是。大德婆伽婆。于我住处月胜世界大师如来日月光。时时称扬娑婆世界释迦牟尼佛。昔菩萨时大勇猛力极苦精勤而修诸行。如是菩萨以大慈悲大愿力故。今者于彼五浊恶世无间罪业诽谤正法毁呰贤圣不善相应诸众生中。于阿耨多罗三藐三菩提而成正觉。是佛于彼计断计常嗔恶粗[怤-寸+喿]无有慈愍归依邪道求种种师不观后世可怖畏事诸众生中。为之说法。然诸众生勤作方便欲害释迦牟尼如来。或以毒药和食而奉。或以刀杖恶象师子恶牛恶狗方便欲害。或有谤言而无梵行。或言非男或言是贼。或言杀生。作如是等种种诽谤。或复有以尘土污坌。或有于大众中粗穬骂詈种种毁呰。或有于佛住处以诸臭秽不净之物污令盈满。或有见者啼泣不喜。或有见者合眼掩面。或有见者背走远逝。有不欲见闭户塞窗。而彼释迦牟尼如来于此一切恶众生中。而能忍受如是无量众恶苦事。亦复于彼诸恶众生不嗔不恼。然复不舍昼夜。常于彼诸众生起大悲心。一切时处随逐化之。如少牸牛初生犊子而未长大忽然失之其母尔时求觅而走如是释迦牟尼如来亦复如是。于诸众生其心平等。以大悲故随逐而走。于三恶道而拔济之。置于善道及涅槃乐。如是大悲相应具足。今此释迦牟尼如来娑婆世界而作佛事。尔时于彼一切大众闻此事已。皆生希奇未曾有心欢喜踊跃。于彼佛前作如是言。大德婆伽婆。我等亦尔。当以精勤大勇猛力经于无量阿僧祇劫修菩提行。行檀波罗蜜乃至行般若波罗蜜。如是善巧方便成熟诸众生故。而修诸行犹如释迦牟尼如来作菩萨时久修菩提行。愿于五浊不净世界恶众生中。于阿耨多罗三藐三菩提而成正觉。乃至安置一切众生于诸善道及涅槃乐。我亦如是。愿于五浊不净佛土。于阿耨多罗三藐三菩提而成正觉。如是成熟五无间业。乃至与彼诸不善根相应众生。安置善道及涅槃乐。彼诸众生即时于日月光佛所如上所愿得授记者

尔时会中复有无量恒河沙等菩萨摩诃萨。是于十方为见释迦牟尼佛故。为供养故见大集故而来此者。彼诸菩萨咸同一音作如是言。大德婆伽婆。我等亦各于己佛土从彼如来各闻如是称扬世尊。如月藏菩萨之所说也。于彼各有那由他诸菩萨等。悉皆如是发大誓愿。为欲成熟诸众生故而作佛事。亦如月藏菩萨摩诃萨之所说也

尔时复有于彼诸来一切天龙乃至一切迦吒富单那人非人等。皆悉合掌作如是言。我等谢过大悲释迦牟尼如来应正遍知我等于佛若身口意所作罪过。若于法僧及于世尊一声闻弟子所作罪过。今于佛前诚心忏悔。愿更莫造坚持禁戒。我等无知犹如小儿不善所行。唯愿世尊。大悲深愍受我忏悔。我等受寄护持养育世尊法眼。以诸方便令得炽然。护持三宝久住不灭。亦能增长三种精气遮障诸恶。于佛一切声闻弟子。乃至若复不持禁戒剃除须发着袈裟片者。作师长想护持养育与诸所须令无乏少。若复有诸刹利国王。作诸非法恼乱世尊声闻弟子。若以毁骂刀杖打斫。及夺衣钵种种资具。若他给施作留难者。我等令彼自然卒起他方怨敌。及自国土亦令兵起。病疫饥馑非时风雨斗诤言讼诽谤讥调。又令其王不久复当亡失己国。如是若复诸婆罗门毗舍首陀男夫妇女童男童女。若余天龙乃至迦吒富单那等。于佛所有声闻弟子作其恼乱。若夺精气气嘘其身。乃至恶心以眼视之。我等悉共令彼天龙乃至迦吒富单那等。所有诸根缺减丑陋不依处所。我以誓力悉令如是。我等游止及常居处。令彼不复得与我等共住共食。亦复不得同处戏笑。如是摈罚。若有恼乱乃至剃发被服袈裟不持戒者亦复如是。若复世尊声闻弟子。乃至无所积聚有慈愍心三业相应。如是时来我等能护令世尊法眼炽然不灭

尔时世尊而赞叹言。善哉善哉。诸妙丈夫。汝若如是则于一切所作事中无诸过失。汝等以是受我付嘱护持养育炽然法故。便为供养三世诸佛。若汝勤加护持养育炽然我法绍三宝种令不断绝。若有为我已出家者。及与未来诸出家者。汝等亦应护持养育。此是汝等阿耨多罗三藐三菩提因

尔时罗睺罗阿修罗王。与无量百千阿修罗等。俱从座起合掌向佛。一心敬礼作如是言。大德婆伽婆。我等亦为勤护养育炽然佛法。令三宝种不断绝故。为降伏他故。休息遮障一切诸恶故。令三精气得增长故。复为护持摄受养育世尊所有声闻弟子及正法故。复为利益诸众生故。遮诸罪过摧诸恶人降伏诸怨。并除一切邪鬼魍魉息诸斗诤。成就一切诸禾苗稼。令诸恶人得作善友。悉摄一切散乱者故。又令所欲皆得称意故。说大陀罗尼。名曰电光噤缩。作是语已即说咒曰

多地夜他　啰婆系　啰婆系　啰婆系　曼仇啰系　阿婆仇啰系　跋啰摩啰系　珊都啰系　阇婆勒那啰系　阿婆蜜唎也啰系伽那底啰啰系　伽婆叉收达啰啰系首收达啰　首收达啰　首收达啰啰系　牟尼婆遮那啰系　底唎啰且那羽舍罗系　失勤那　底唎鸣阇牟尼啰系　质啰迦罗　底唎牟尼啰系　旃达啰　[少/(兔-、)]那头婆啰系逻　苏婆呵

大德婆伽婆。此电光噤缩大陀罗尼。悉能饶益一切众生。乃至令诸所欲称意。若有比丘比丘尼优婆塞优婆夷。若余清信善男子善女人等。能与禅法相应而住。若复营事。若行兰若。若在树下。若在露地。如是人等若能受持读诵念此电光噤缩大陀罗尼。若有阿修罗阿修罗妇阿修罗父阿修罗母及与儿女若阿修罗左右眷属男夫妇女及阿修罗给使之人。欲来恼害伺其便者。皆悉不能得彼少分。是阿修罗不复还能入己城邑。令其头破以为七分。如阿梨树枝。尔时诸来一切大众咸皆叹言。善哉善哉。尔时毗摩质多罗阿修罗王复与百千阿修罗等俱从座起。合掌向佛一心敬礼作如是言。大德婆伽婆。我等亦为护持养育世尊所说正法眼故。乃至增长三种精气故。复为护持摄受养育世尊所有声闻弟子故。又为降伏一切怨家令诸恶人皆生归仰。休息一切所有疾病。伏诸刚强摄诸恶人令作善友具好眷属。令诸种子得生不坏。成熟一切果实苗稼故。说大陀罗尼名师子游步。作是语已即说咒曰

多地夜他湅(娑楼反)唎夜　跋啰企(佉帝反)跋啰企跋啰企　阿牟尼　阿牟佉牟尼阇耶毗阇易　阿婆啰题　耶阇夷泥　婆呵萨啰叉　佉[口*梨]阿那佉[口*梨]　毗耶寐失啰佉唎牟那迦啰娑佉[口*(黍-禾+利)]　阿蜜多　受沙佉[口*(黍-禾+利)]　何婆咩娑斯那嘙系　常伽啰奢咩　颇逻啰娑勿达[口*(黍-禾+利)]设阇喽　奢摩那　仚博憩僧　伽奢咩忧波扇多呵唎　苏婆呵

大德婆伽婆。此师子游步大陀罗尼。能伏诸怨。乃至成熟一切苗稼。若有比丘乃至清信善女人等与禅相应。乃至露地受持读诵流布如是师子游步大陀罗尼。若有阿修罗乃至给使。欲来恼害伺其便者。终不能得彼之少分。是等亦复不能还入阿修罗城。令其头破而作七分如阿梨树枝。尔时诸来一切大众亦皆叹言。善哉善哉

尔时牟真邻陀阿修罗王。与无量百千阿修罗等俱从座起。合掌向佛一心敬礼作如是言。大德婆伽婆。我等亦为护持养育世尊所说正法眼故。乃至增长三种精气故。复为护持摄受养育世尊所有声闻弟子故。说大陀罗尼名伏诸龙。作是语已即说咒曰

多地夜他　毗[口*梨]沙叉　毗唎沙叉　毗唎沙叉　[糸*枲](须凌反)　呵毗唎矢至迦毗唎沙佉那　摸啰曷多　呵呵纣呵纣呵纣伽伽纣渠竭[口*(黍-禾+利)]　渠竭[口*(黍-禾+利)]　三牟达啰渠竭[口*(黍-禾+利)]　萨婆　闼逻　渠竭[口*(黍-禾+利)]　悉那婆渠竭[口*(黍-禾+利)]　萨婆浮阇伽　渠竭[口*梨]　呵呵渠竭[口*梨]　悉多婆閦多　渠竭[口*梨]　娑紧柘那　渠竭[口*梨]　阿婆多阿腻夜　婆斫閦毗夜　阿腻夜　军他閦婆　遮罗斗牟逻　阿佉阇　呵腻夜斗　婆罗斗　毗弥奢　阿腻夜斗　阿衫浮　呵腻夜　苏婆呵

大德婆伽婆。此伏诸龙大陀罗尼。悉能休息一切疾病。亦能卷缩打缚一切恶鬼不令为害。能止非时恶风暴雨诸恶毒气。亦能降伏。眼视杀人众恶龙等断诸欲着。于诸龙身能作热恼及能热恼。其所住处热恼其心热恼其业热恼所有资生之具。大德婆伽婆。若有比丘乃至清信善女人等与禅相应。乃至露地受持读诵流布如是降伏诸龙大陀罗尼。若有龙若龙妇若龙父若龙母若龙儿女若龙左右男夫妇女若龙给使。欲来恼害伺其便者。乃至不能得彼少分。令其反得热恼之病。头破七分如阿梨树枝。尔时四天下所有诸龙来在会者皆悉嗔怒。怖彼所来阿修罗城。诸阿修罗令使惊怖不能自安

尔时复有娑伽罗龙王。从座而起向诸大龙。合掌作礼而说偈言

  若有见大圣　　是人则除嗔
  离嗔即为圣　　应当止恚恼
  忍辱世第一　　忍得世间乐
  忍辱离诸怨　　忍趣安隐城
  无量阿修罗　　恒与我等怨
  但当自容忍　　佛常如是说
  由嗔趣恶道　　嗔还增长嗔
  以嗔舍朋友　　嗔不得解脱
  我等畜生道　　恶戒嗔恚故
  若能除嗔慢　　得生于人中
  既得人身已　　归佛而出家
  修习解脱行　　当为大导师

尔时娑伽罗龙王如是说已。一切诸龙皆得忍辱。面色熙怡各坐本处

尔时跋持毗卢遮那阿修罗王。复与无量百千阿修罗等俱从座起。合掌向佛一心敬礼作如是言。大德婆伽婆。我等亦为护持养育世尊正法令三宝种不断绝故。勤降伏他一切恶事。及诸恶人皆悉休息。令三精气而得增长故。复为救护摄受养育世尊一切声闻弟子故。说大陀罗尼名休息众病。作是语已即说咒曰

多地夜他　摸楞伽摩　摩朋伽摩　阿毗朋伽摩　阇逻朋伽摩　悉多婆毗[口*興](呵朋反)伽摩　跋尸夜毗[口*興]伽摩　除尼毗[口*興]伽摩　阿舍尼毗[口*興]伽摩　婆呵毗[口*興]伽摩　差(叉梨反)啰毗啰婆梨珊底啰毗恒伽摩　娑伽啰阇逻丘肘阇逻丘肘毗鞞舍丘肘萨婆卢伽　因地利耶丘肘　悉蜜唎底　毗朋楞舍丘肘　苏婆呵

大德婆伽婆。此休息众病大陀罗尼。能除所有一切病苦。息诸毒害一切恶雹。亦能降伏一切恶龙。令与世尊声闻弟子奉给所须犹如奴仆

尔时诸来一切龙众诸大龙王皆悉嗔忿。于虚空中即起大云在阿修罗上。欲声大鼓欲降大石。雨铁罥索[矛*(替-曰+貝)]鉾刀杖刀面铁口利齿口竹口瓶口如是等形。为欲害诸阿修罗而不能得

大集经卷第五十三大方等大集经卷第五十四

        高齐天竺三藏那连提耶舍译

    月藏分第十二忍辱品第十六之二

尔时世尊告诸龙众阿修罗言。汝等莫斗应修忍辱。仁者。若能离于嗔怒成就忍辱。速得十处。何等为十。一者得作王王四天下自在轮王。二者毗楼博叉天王。三者毗楼勒叉天王。四者提头赖吒天王。五者毗沙门天王。六者释天王。七者须夜摩天王。八者兜率陀天王。九者化乐天王。十者他化自在天王。诸仁者。若具足忍。是人速得如是十处忍辱近果。复次诸仁者。若能深忍转增具足。当知是人复得五处。何等为五。一者梵众。二者大梵天王。三者声闻道果。四者缘觉。五者如来应正遍知。诸仁者。若能深忍转增具足。是人速得如是五处。又若具足修行忍者。自然近得一切世间胜妙五欲。资生所须皆悉具足。是人若复至到修行忍功德者得圣安乐。若有非圣凡下之人。犷戾自高性常嗔怒。于多人所现大嗔恚。当知是人身坏命终堕于地狱。若复傥得出彼地狱。生于下劣畜生道中。作下劣龙身阿修罗身。若得生人极下卑贱诸根残缺。或长诸根或复无根或复二根或复大根。形容丑陋跛躃背偻身体臭秽。生旃陀罗妓作邪媚。如是等余下贱之家。若生边地少衣乏食下贱家。生及无福田喜作种种不善之处。以是因缘。是人展转复趣地狱畜生饿鬼。诸仁者。我今略说如是不忍嗔怒果报。诸仁者。以嗔恚故于生死中增长无量恶不善法。以是因缘。是人转复堕于地狱畜生饿鬼。诸仁者。是故我今如是告汝一切诸龙阿修罗等。汝已长夜各各迭相违反而住。汝等一切今悉于我及与诸来大众之前。各各迭相应生至到忍辱之心。当息久积心心嗔怒。若不能忍。必令汝得所不喜果。是故汝等各相容忍。若能不嗔。斗诤讥调言讼嫉妒自守而住。汝等如是必定当得胜妙之事无诸过恶

尔时诸来一切大众咸皆叹言。善哉善哉。汝能如是受佛教诫。各各如是迭相忍辱。便得于此四天下中常得胜报无诸恶事

尔时月藏菩萨摩诃萨复告娑伽罗龙王。罗睺罗阿修罗王。阿那婆沓多龙王。毗摩质多罗阿修罗王。婆楼那龙王。牟真邻陀阿修罗王。善住龙王。跋持毗卢遮那阿修罗王。以偈教言

  汝等得授记　　最胜非余乘
  何故于导师　　而无羞惭耻
  执持筏而溺　　多众随驶流
  如是弃最胜　　一切所厌贱
  凡龙阿修罗　　嗔故被厌贱
  汝等妙丈夫　　悉应舍恚怒
  慈能趣善道　　具受诸欲乐
  慈能离诸难　　及作善知友
  慈能得大智　　及依大明师
  慈能离诸恶　　亦令人乐观
  慈得具大富　　常能施一切
  慈能乐戒定　　复得最胜慧
  慈能得工巧　　善学一切事
  慈于最胜处　　端坐化众生
  慈得胜妙身　　备相端正容
  慈能具妙音　　众人悉乐闻
  慈得善眷属　　梵行无嫉妒
  乐法具惭愧　　明人常随喜
  慈能得官位　　坐于胜座处
  能息众生恶　　安置菩提道
  慈能得十地　　及忍陀罗尼
  慈能成就悲　　舍离于诸着
  慈能得神足　　值遇明导师
  慈能得净土　　清净离烦恼
  慈能降众魔　　到大菩提岸
  慈于天人中　　能转正法轮
  慈能化众生　　置于三乘处
  慈能善说法　　降伏诸外道
  慈以八圣道　　度脱天人等
  安置不死处　　汝等皆能入
  我今与汝等　　慈心陀罗尼
  我于亿佛所　　专心得听闻
  汝以己眷属　　安置慈忍处
  相于起慈心　　长夜得安乐

尔时月藏菩萨摩诃萨说此偈已。即说咒曰

多地夜他　迷帝[口*梨]　摩诃迷帝　[口*梨]迷哆啰[少/兔]跋帝　迷哆啰啰匙　迷哆啰憩　迷哆罗侯系　迷哆啰隶　迷帝[口*梨]　迷帝[口*梨]　迷喽娑鞞讫唎帝　娑呵啰匙　闭逻风伽蓰　薮啰耶呵泥　婆逻浮常耆　初罗叉鞞　那耶那喽系　俱嚧他车掣　阿摸伽啰泥　啰阇頞寄　吉隶奢薮啰　三摩啰泥　浮阇伽　鞞[口*梨]系　奴腻多鞞[口*梨]系　阿啰尼企　刹哆啰豆喽咩　阿求隶耆　唎哆啰匙阿啰悉那鞞　阿俱卑易鸯鸠匙摸叉毗钵啰易　俱嚧他叉易(以世反)苏婆呵

诸仁者。此大慈心陀罗尼。我曾往昔于亿佛所从彼得闻。汝等应当于己眷属及他眷属息怒恶心而教授之。月藏菩萨摩诃萨说是慈心陀罗尼时如来叹言。善哉善哉。一切所有诸来大众。诸天乾闼婆阿修罗人非人等。亦皆叹言。善哉善哉

尔时诸天各得住于慈心忍心无怨心无言讼心。迭相谢过。天向诸龙龙向诸天。慈心忍心无怨心无斗诤心无言讼心迭相谢过。诸天向阿修罗阿修罗向诸天。乃至谢过。诸龙向阿修罗阿修罗向诸龙。乃至谢过。诸天向夜叉夜叉向诸天。乃至谢过悉如上说。如是如是。天向．罗刹．乾闼婆．紧那罗．伽楼罗．摩睺罗伽．鸠槃茶．饿鬼．毗舍遮富单那．迦吒富单那。住于慈心忍心无怨心无斗诤心无言讼心。乃至迦吒富单那向彼诸天。住于慈心乃至谢过亦如上说。龙向夜叉乃至迦吒富单那住于慈心。乃至谢过。夜叉乃至迦吒富单那向于诸龙。乃至谢过亦皆如是。乃至迦吒富单那向迦吒富单那。住于慈心。乃至谢过亦复如是。彼等皆以大慈心陀罗尼力因缘故。一切天龙阿修罗夜叉罗刹乾闼婆紧那罗伽楼罗摩睺罗伽鸠槃茶饿鬼毗舍遮富单那迦吒富单那等。迭相住于慈心忍心无怨心无言讼心无斗诤心离嗔怒心离嫉妒心。是大慈心陀罗尼力因缘故。一切人类迭相住于慈心忍心怜愍心无怨心无言讼心无斗诤心。一切畜生若禽若兽乃至极下微小诸虫迭相住于慈心忍心怜愍心无怨心无斗诤心无违反心

尔时诸天乃至一切迦吒富单那人非人等所来大众。合掌向佛恭敬礼拜。同时一音作如是言。我等皆已承佛威神。迭相谢过。迭相住于慈心忍心怜愍心无怨心无诤讼心。我等一切今当亦复谢过。如来应正遍知。我等昔来于世尊所。若身口意所作罪过。及于法僧若身口意所作罪过。乃至世尊一声闻弟子所。若身口意所作罪过。乃至若有为佛剃发着袈裟片作违反行非法器者。若身口意所作罪过。是等诸罪悉于佛前诚心忏悔。修戒威仪。愿佛容恕受我等忏。当令我得住戒威仪。又复我等从今以往。乃至剃发着袈裟片作违反行者。及佛声闻弟子所。悉当发心作导师想。护持养育具足供给一切所须不令乏少。佛言。善哉善哉。诸妙丈夫成就忍辱。乃至汝等于我佛所。若身口意所作罪过。若于法僧所作罪过。乃至于我一声闻弟子。若身口意所作罪过。乃至为我剃除须发着袈裟片者。若身口意所作罪过。各自深观如是罪业诚心忏悔。皆得除灭不受恶报。如是汝等皆当护持养育我法。乃至为我出家剃发不持禁戒着袈裟片者。汝等皆应护持养育。若能护持养育此者深可赞叹。若我所有声闻弟子持戒具足多闻舍慧解脱知见悉具足者。汝等皆应护持养育。彼等自以过去善根福德因缘善得供养。若有众生于未来世无智慧福德。为我剃发着袈裟片。不受禁戒或受毁犯。于诸善法不得相应。若复护持养育此者得无量福。我与彼等作善导师怜愍利益。何以故。当来之世有恶众生。于三宝中少作善业。若行布施若复持戒修诸禅定。以其如是少许善根作诸国王。愚痴无智无羞惭愧憍慢炽盛。无有慈愍不观后世可怖畏事。彼等恼乱我诸所有声闻弟子。打缚骂辱。或复驱使令其供给。夺其饮食衣钵汤药所须之物寺舍园田。系闭牢狱摈徙讁罚。乃至剃发着袈裟片者亦复如是。及以群臣诸断事者。愚痴无智离诸羞惭。无有慈愍不观后世可怖畏事。彼等恼乱我诸声闻。乃至系狱摈徙讁罚。乃至为我剃除须发着袈裟片者亦复如是。我今以此诸出家者悉付于汝。勿令彼等饥渴孤独致于命终

尔时上座阿若憍陈如。从座而起作如是言。大德婆伽婆。彼等刹利若婆罗门毗舍首陀。如是等人恼乱世尊声闻弟子得几许罪。且置持戒。若复为佛剃除须发着袈裟片。不受禁戒受而毁犯。恼乱此者得几许罪。佛言。止止。憍陈如。莫问此事

尔时娑婆世界主大梵天王。即从座起而白佛言。大德婆伽婆。唯愿说之。大德修伽陀。唯愿说之。若有为佛剃除须发被服袈裟不受禁戒受已毁犯。其刹利王与作恼乱骂辱打缚者得几许罪。佛言。大梵。我今为汝且略说之。若有人于万亿佛所出其身血。于意云何。是人得罪宁为多不。大梵王言。若人但出一佛身血得无间罪。尚多无量不可算数。堕于阿鼻大地狱中。何况具出万亿诸佛身血者也。终无有能广说彼人罪业果报。唯除如来。佛言。大梵若有恼乱骂辱打缚为我剃发着袈裟片不受禁戒受而犯者。得罪多彼。何以故。如是为我出家剃发着袈裟片离不受戒或受毁犯。是人犹能为诸天人示涅槃道。是人便已于三宝中心得敬信。胜于一切九十五道。其人必速能入涅槃。胜于一切在家俗人。唯除在家得忍辱者。是故天人应当供养。何况具能受持禁戒三业相应。诸仁者。其有一切刹利国王及以群臣诸断事者。如其见有于我法中而出家者作大罪业大杀生大偷盗大非梵行大妄语及余不善。如是等类但当如法摈出国土城邑村落不听在寺。亦复不得同僧事业。利养之物悉不共同。不得鞭打。若鞭打者理所不应。又亦不应口业骂辱。一切不应加其身罪。若故违法而讁罚者。是人便于解脱退落受于下类。远离一切人天善道。必定归趣阿鼻地狱。何况鞭打为佛出家具持戒者

尔时复有一切诸天一切诸龙。乃至一切迦吒富单那诸来大众。于三宝中得增上信尊重敬仰及希有心。复作是言。我等一切从今以往。护持养育世尊正法。及与比丘比丘尼。优婆塞优婆夷。乃至毁犯佛禁戒者。我等亦当摄受护持乃至为佛剃除须发着袈裟片不受禁戒无所积聚。我亦于彼作导师想。护持养育供给所须。皆令具足。若诸国王见有如是为佛出家受持禁戒。乃至为佛剃除须发着袈裟片不受禁戒受而毁犯无所积聚。如其事缘治其身罪鞭打之者。我等不复护持养育。如是国王舍离彼国。以舍离故令其国土而有种种谄诈斗诤疫病饥馑刀兵俱起。非时风雨亢旱毒热伤害苗稼。又若我等舍离彼国。当勤方便令其国土所有世尊声闻弟子悉向他国。使其国土空无福田。若有世尊声闻弟子。乃至但着袈裟片者。若有宰官鞭打彼等。其刹利王不遮护者。我等亦当出其国土。复作是言。我等今者一切相与随所堪能。勤作种种供养世尊。尔时诸天及与诸龙。乃至一切迦吒富单那等。俱时发心因缘力故。即时于此四天下中。所有诸山皆悉变成七宝之山。为欲供养世尊故耳。所有树林枝叶花果。一切亦皆变成七宝。于其花果复出种种胜妙供具。及五音作乐而为供养。四天下中所有依地众药草苗。一切亦皆变成七宝而为供养。此四天下所有地界一切变成青琉璃地而为供养。彼诸天龙乃至迦吒富单那。四天下中上尽欲界一切所有各随力能而作供养。有雨种种宝种种花种种衣服种种璎珞种种天妙花盖幢幡而为供养。有持种种天妙幢幡宝盖金缕真珠璎珞摩尼宝器而为供养。有以种种琴瑟箜篌箫笛齐鼓奁鼓雷鼓以为音乐供养世尊。有以种种歌乐音声而为供养。有雨种种音乐之器而为供养。复以种种庄严国土而为供养。诸四天下所依住者。人非人等。乃至一切大小诸虫皆悉见闻。彼等一切苦受休息皆生乐受。随有种种身触觉知得乐充足。及得希奇未曾有心。于三宝中深得敬信

尔时世尊大悲怜愍。一切众生为成熟故。彼等一切音声语言。皆是贤圣之所加被。如是一切人非人等所有语言。及从宝中所出音声。枝叶花果琴瑟箜篌箫笛齐鼓奁鼓雷鼓所出音声。一切皆是圣力所加。彼等一切皆得希奇未曾有声建立所加。所谓色色空受受空想想空行行空识识空。如是眼入眼入空耳鼻舌身入耳鼻舌身入空意入意入空。如是色入色入空声香味触入声香味触入空法入法入空。如是眼界眼界空乃至意识界意识界空。如是知身离欲净。知一切法离欲净。知一切法界离欲相。知一切法如如。如是知者。是人则为于空不动。是人堪能拔济一切众生想。于一切行令得解脱。于众生想色想受想行识想。眼入想乃至意识界想。是人如是堪能安置一切众生于三乘无为界。行者云何能开示简择彼等诸法。所谓修内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空一切法空不可得空无法空有法空无法有法空。复有法法相空。无法无法相空。自法自法相空。他法他法相空。若能如是修习简择此诸法空彼人堪能乃至安置一切众生于三乘无为界。彼等行者以何法门得知内空乃至无法有法空。所谓还以空解脱门。能修简择内外等法。何者名为内外法。内法者。所谓眼耳鼻舌身意。行者如实知眼眼空非积聚不可坏不可取。何以故此诸法性尔。乃至知意意空非积聚不可坏不可取。何以故诸法性尔。是名内空。如是行者应如实知。外法者。所谓色声香味触法。行者如实知色色空乃至法法空非积聚不可坏不可取。何以故诸法性尔。是名外空。如是行者应如实知。何者名为内外空。内外法者。谓内六入外六入。行者如实知内外入空非积聚不可坏不可取。何以故诸法性尔是名内外空。如是行者应如实知。何者名为空空。空者。一切诸法空。以彼空故空非积聚不可坏不可取。何以故诸法性尔。是名空空。如是行者应如实知。何者名为大空。东方东方空乃至四维空非积聚不可坏不可取。何以故诸法性尔。是名大空。如是行者应如实知。何者名为第一义空。第一义者所谓涅槃。如是涅槃以涅槃故空。非积聚不可坏不可取。何以故诸法性尔。是名第一义空。如是行者应如实知。何者名为有为空。有为法名欲界色界无色界。欲界色界无色界空。非积聚不可坏不可取。何以故诸法性尔。是名有为空。如是行者应如实知。何者名为无为空。无生无灭不住不异。是名无为。无为以无为故空。非积聚不可坏不可取。何以故诸法性尔。是名无为空。如是行者应如实知。何者名为毕竟空。毕竟名诸法至竟不可得。非积聚不可坏不可取。何以故诸法性尔。是名毕竟空。如是行者应如实知。何者名为无始空。来去不可得。非积聚不可坏不可取。何以故诸法性尔。是名无始空。如是行者应如实知。何者名为散空。无所取舍。非积聚不可坏不可取。何以故诸法性尔。是名散空。如是行者应如实知。何者名为性空。一切有为无为法性。非声闻作非缘觉作非如来作此法性空。非积聚不可坏不可取。何以故诸法性尔。是名性空。如是行者应如实知。何者名为自相空。恼坏是色相。能受是受相。取相是想相。造作是行相。了知是识相。如是等有为无为一切法自相自相空。非积聚不可坏不可取。何以故诸法性尔。是名自相空。如是行者应如实知。何者名为一切法空。一切法者。所谓色受想行识。眼乃至意。色乃至法。眼色因缘生识乃至意法因缘生识。此有为无为诸法。是名一切法。彼诸法空。非积聚不可坏不可取。何以故诸法性尔。是名一切法空。如是行者应如实知。何者名为不可得空。一切法不可得。非积聚不可坏不可取。何以故诸法性尔。是名不可得空。如是行者应如实知。何者名为无法空。一切无物不可得。非积聚不可坏不可取。何以故诸法性尔。是名无法空。如是行者应如实知。何者名为有法空。于和合中无物。非积聚不可坏不可取。何以故诸法性尔。是名有法空。如是行者应如实知。何者名为无法有法空。无物无物空有物有来空。非积聚不可坏不可取。何以故诸法性尔。是名无法有法空。如是行者应如实知。何者名为法法相空。法名五阴。五阴空。非积聚不可坏不可取。何以故诸法性尔。是名法法相空。如是行者应如实知。何者名为无法无法相空。无法名无为法。是无为法空。非积聚不可坏不可取。何以故诸法性尔。是名无法无法相空。如是行者应如实知。何者名为自法自法相空。诸法自法空。是空非智作非见作。非积聚不可坏不可取。何以故诸法性尔。是名自法自法相空。如是行者应如实知。何者名为他法他法相空。若佛出世若不出世。法住法相法位法界如实际。性相常住无有变异过。此诸法空。非积聚不可坏不可取。何以故诸法性尔。是名他法他法相空。如是行者应如实知。知已能令众生离众生想。离一切行想受想色想识想。离眼想乃至意想。离色想乃至法想。然后安置一切众生于三乘无为界。若有行者。于此诸法如实现前知。得名善修。彼诸众生昔于此法已修习者。如是第一甚深法声入于耳根。或有众生不种善根。如是法声亦入于耳。或有见佛专心瞻仰。彼人一切无尽善根皆来现前。乃至逮得不退转地。十力无畏成大法器。或有众生有无常声入于耳根。或有苦声。空声。无我声。三律仪声。四念处声。四正勤声。四如意足声。五根声。五力声。七觉分声。八道分声。实论声。因缘法声。梵住声。四摄声。无碍辩声。禅声。解脱声。无色定声。六波罗蜜声。巧方便声。三昧陀罗尼忍声。声闻乘声。缘觉乘声。大乘声。不退转地声。业障尽声。烦恼障尽声。众生障尽声。法声尽声。有为国土功德庄严声。无为心清净声。大慈声。大悲声。三不护声。四无畏声。十力声。十八不共法声。一生补处声。十地声。最后身声。降魔声。无上智声。转法轮声。随应度者现神变声。弃诸命行声。于诸众生示现无上大涅槃声。如是诸声各各差别入于耳根。是诸众生乃至畜生饿鬼趣等。如是无量百千法门入于耳根。彼诸众生得第一希有欢喜踊跃。于三宝中极得信敬。彼诸众生烦恼障业障众生障法障。于三分中二分已尽。彼诸众生闻是声已。无量阿僧祇众生昔有恶心者。彼等悉得柔软之心怜愍心善业心。得观后世可怖畏事。得种具足天人善根。以彼诸声令于无量阿僧祇众生归依三宝。所有受持禁戒净者。彼等有得须陀洹果。乃至有得阿罗汉果。复有无量阿僧祇众生。于缘觉乘种诸善根。复有无量阿僧祇众生。发阿耨多罗三藐三菩提心。即得住于不退转地。复有无量阿僧祇众生。得无生法忍。尔时世尊。欲重明此义。而说偈言

  火味阿修罗　　指示罗睺罗
  是我最胜师　　福慧庄严具
  佛告于彼等　　当息妒嗔怒
  付嘱是法眼　　护持故当受
  彼诸修罗喜　　敬答尊导师
  我当护法眼　　乃至法久住
  我等说最胜　　不隐法神咒
  令彼一切龙　　皆失憍慢力
  尔时诸龙辈　　各各皆嗔怒
  欲以憍慢力　　共诸修罗斗
  佛告诸龙王　　及以修罗主
  汝等于长夜　　各各常犷戾
  若不除嗔怒　　于诸乐非器
  常为苦所触　　下劣臭秽身
  身分支不具　　恒乏于资生
  闻说此诸苦　　皆以嗔为本
  恶罚诸枷锁　　牢狱饥渴等
  地狱鬼畜生　　由嗔受此苦
  一切应忍辱　　能忍者则无
  丈夫得最胜　　富贵具诸欲
  汝等二朋众　　诸龙阿修罗
  各自修忍辱　　忍故无诸恶
  大众皆喜悦　　一切咸赞叹
  汝今闻是语　　皆悉得于忍
  天龙阿修罗　　夜叉及诸鬼
  一切皆得忍　　慈心共相视
  人与畜生等　　得忍皆和顺
  禽兽及小虫　　慈悲相怜愍
  大众皆合掌　　瞻仰导师言
  我等迭相荫　　皆得慈心住
  又我诸大众　　于佛尊导师
  所作诸罪业　　若身口意犯
  于法众僧所　　一人边有过
  人中坚固士　　唯愿见容恕
  我于世尊法　　一切所作恶
  今悉至到忏　　愿佛慈纳受
  于时两足尊　　告彼大众言
  汝忏恶业尽　　终无有苦报
  剃发不受戒　　被服袈裟片
  而作导师想　　于彼人中上
  恶王障法眼　　贪痴打比丘
  如出导师血　　当堕阿鼻狱
  大众作是言　　我等护比丘
  若有诸恶王　　恼诸声闻众
  我等于诸事　　皆舍于彼国
  其土有沙门　　令向于余处
  毁坏彼诸国　　饥馑兵疫起
  沙门所诣国　　我等亦诣彼
  悉令得胜乐　　具足衣饮食
  于彼炽法眼　　供养人中上
  无余四天下　　悉变成七宝
  复雨诸香华　　珍宝及衣服
  歌舞妓乐等　　供养于导师
  众生所见闻　　皆得充足乐
  圣加令诸音　　尽变作佛声
  说诸有为苦　　无常空无我
  三世一切法　　悉空无所有
  集散二俱空　　眼识二亦然
  乃至心法界　　阴身等法空
  如是知诸法　　则能救众生
  若知三界空　　能解众生缚
  诸有十二支　　一切皆性空
  若昔于此法　　如是修习者
  彼等闻诸声　　悉皆得于忍
  智力无所畏　　得住菩提道
  薄福诸众生　　得闻有为声
  无量众精勤　　得入菩提行
  檀戒忍精进　　禅定及智慧
  佛土福庄严　　精进故令净
  汝等当作佛　　到彼诸法岸
  降魔及军众　　而降正法雨
  无量众生界　　能与正法眼
  汝等一切众　　速入安隐城
  无量众闻声　　得趣大菩提
  及得二乘道　　有得人天乐
  有得至于果　　罗汉三摩提
  如是恶众生　　得于柔软意
  怖畏诸恶业　　安住慈善心

大集经卷第五十四大方等大集经卷第五十五

        高齐天竺三藏那连提耶舍译

    月藏分第十二分布阎浮提品第十七

尔时世尊。既知一切诸来大众于三宝所皆生深信尊重敬仰得未曾有更不信事诸余天已。告他化自在天王。化乐天王。兜率陀天王。须夜摩天王。帝释天王。四大天王及诸眷属。娑伽罗龙王。阿那婆达多龙王。罗睺罗阿修罗王。毗摩质多罗阿修罗王。睒婆利阿修罗王跋持毗卢遮那阿修罗王。大树紧那罗王。乐欲乾闼婆军将。檀提鸠槃茶军将。因陀罗夜叉军将。寒叶饿鬼王。垂唇毗舍遮王。阿那竭啰富单那王。巷路唤声迦吒富单那王等作如是言。诸仁者。汝等一切如是劝我。分布安置此阎浮提。一切国土城邑宫殿王都聚落山岩寺舍。园池旷野诸树林间。付嘱护持勿令有恶。又令大地精气众生精气正法精气增长炽然。佛正法眼久住于世。绍三宝种使不断绝。损减恶趣增益善道。令此阎浮提一切安隐丰乐可乐以是因缘。我今分布此四天下嘱汝一切诸大天王一切龙王。乃至一切迦吒富单那王。汝等各应发心舍离眷属。分布安置护持养育并汝诸天一切眷属乃至。迦吒富单那王一切眷属。亦令于此阎浮提中一切国土乃至树林。分布安置护持养育。是故汝等诸大天王及诸眷属。乃至迦吒富单那王及诸眷属。于阎浮提皆应诚心随喜赞叹。莫嗔莫恨亦莫生怒

尔时所有一切菩萨摩诃萨。色界诸天。欲界天人一切龙众一切乾闼婆。乃至一切迦吒富单那等诸来大众。皆悉合掌各作是言我等一切诚心随喜敬受佛教。如佛世尊分布安置此阎浮提。我等发心受佛教敕。护持养育佛正法眼令得炽然。佛言。善哉善哉。妙丈夫。汝等应当如是诚心说欲随喜

尔时世尊告彼法食喜食禅食诸天言。此四天下大海水中八万洲渚一切国土。汝等法食喜食禅食诸天。应等护持养育我法。住法比丘如法顺法。发心修行三业相应。剃除须发身着袈裟。汝等应当护持养育。时彼法食喜食禅食诸天各作是言。我当护持大海水中八万洲渚一切国土诸佛正法。若佛弟子乃至不畜妇女畜生田宅资产。我等皆当护持养育

尔时世尊赞彼天言。善哉善哉。一切大众亦复赞言。善哉善哉

尔时世尊告月藏菩萨摩诃萨言。了知清净士。若我住世诸声闻众。戒具足。舍具足。闻具足。定具足。慧具足。解脱具足。解脱知见具足。我之正法炽然在世。乃至一切诸天人等。亦能显现平等正法。于我灭后五百年中。诸比丘等。犹于我法解脱坚固。次五百年我之正法禅定三昧得住坚固。次五百年读诵多闻得住坚固。次五百年于我法中多造塔寺得住坚固。次五百年于我法中斗诤言颂白法隐没损减坚固。了知清净士。从是以后于我法中。虽复剃除须发身着袈裟。毁破禁戒行不如法假名比丘。如是破戒名字比丘。若有檀越舍施供养护持养育。我说是人犹得无量阿僧祇大福德聚。何以故。犹能饶益多众生故。何况我今现在于世。譬如真金为无价宝。若无真金银为无价。若无银者鋀石无价。若无鋀石伪宝无价。若无伪宝赤白铜铁白镴铅锡为无价宝。如是一切诸世间中佛宝无上。若无佛宝缘觉无上。若无缘觉罗汉无上。若无罗汉诸余圣众以为无上。若无圣众得定凡夫以为无上。若无得定净持戒者以为无上。若无净戒污戒比丘以为无上。若无污戒剃除须发身着袈裟名字比丘为无上宝。比余九十五种异道最尊第一。应受世供为物福田。何以故。能示众生可怖畏故。若有护持养育安置是人。不久得住忍地

尔时世尊告六欲诸天言。汝等应如过去佛时所分得分当勤护持。复于此四天下。时时之中勤加思惟佛正法义。为令我法得久住故。绍三宝种不断绝故。时彼诸天各作是言。唯然受教。尔时世尊赞言。善哉善哉。一切大众亦复赞言。善哉善哉

尔时世尊告四天王言。汝等及诸眷属。应如过去佛时所分得分。还作护持安置养育我之正法。时四天王各作是言。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊告乾闼婆等言。诸仁者。汝等及诸天仙。于优昙林庵罗林阎浮林呵[黍-禾+利]勒林阿摩罗林蒱萄林。如是等林于中而住。复共四天王宫诸天子等。为我佛法得久住故。应当思惟佛正法义。时乾闼婆等咸言。如是。大德婆伽婆。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊告娑伽罗龙王难陀龙王婆难陀龙王善现龙王婆楼那龙王婆修吉龙王得叉迦龙王阿难陀龙王阿楼那龙王岁星龙王言。汝等各在大海之中住本宫殿。护持养育我之正法。时龙王等各作是言。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊告阿那婆达多龙王善住龙王清胁龙王摩利尼龙王优婆罗龙王乾闼婆龙王云池龙王主雹龙王摩奚曼多龙王美音龙王言。汝等各住本宫护持养育我之正法。时龙王等各作是言。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊告鸠槃茶檀提大将优婆檀提大将迦罗迦大将摩诃钵赊大将摩呼陀遮利大将堀求尼大将婆朱赊尼大将鸯堀卢大将鞞罗差大将一眉大将言。汝等各住本宫护持养育我之正法。时鸠槃茶大将等各作是言。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊告因陀夜叉大将苏摩大将婆楼那大将波阇钵帝大将跋罗头婆阇大将伊奢那大将旃檀那大将月眼大将婆多竭梨大将奚摩跋多大将言。汝等各住本宫护持养育我之正法。时夜叉大将等各作是言。唯然受教。大德婆伽婆。我等护持养育安置世尊正法。及住法比丘供给所须。乃至剃发不持戒者。亦复供给一切所须。为令佛法得久住故。绍三宝种不断绝故。三种精气得增长故。休息一切斗诤言讼怨仇疫病饥馑短乏非时亢旱曜宿失度为断除故。乃至世尊声闻弟子三业相应不积聚者当勤养育

尔时世尊赞言。善哉善哉。善男子。汝等如是为利益安乐一切三界众生故。及一切大众。亦复赞言。善哉善哉

尔时世尊告一切毕利多依旷野住者。一切毗舍遮依空舍住者。一切富单那依野田住者。一切迦吒富单那依于塳间及厕边住者言。汝等各于住处护持养育我之正法。时毕利多等各作是言。唯然受教。佛及大众咸皆赞言。善哉善哉

尔时世尊复作是言。诸仁者。所有诸天乾闼婆．紧那罗．夜叉．罗刹．龙王．阿修罗．鸠槃茶。如昔世尊所分得分国土城邑聚落舍宅。随所得处为作护持安置养育我当随喜。一切大众亦复随喜。若复有诸天龙夜叉乃至迦吒富单那等。如昔世尊所分得分国土城邑。不正护持安置养育者。我当转付诸余天龙。令其安置护持养育。各随国土善作护持。我今以波罗奈国付嘱善发乾闼婆千眷属。阿尼罗夜叉仙五百眷属。须质多罗阿修罗无量眷属。德叉迦龙王百眷属。大黑天女五百眷属。汝等护持养育波罗奈国。为令我法得久住故。绍三宝种不断绝故。遮障一切恶众生故。时善发乾闼婆．阿尼罗夜叉仙．须质多罗阿修罗．德叉迦龙王．大黑天女等。各与眷属咸作是言。大德婆伽婆。我等护持养育安置波罗奈国周遍土境。遮障不饶益养育饶益者。乃至遮障一切不善诸恶众生

尔时世尊。赞言。善哉善哉。诸来大众亦复赞言。善哉善哉

尔时世尊。以迦毗罗婆国。付嘱火护紧那罗仙千眷属。拘翅罗声乾闼婆万眷属。婆闼跋帝夜叉大将千眷属。奢摩那迟阿修罗二万眷属。跋那牟支龙王一万眷属。摩诃钵奢鸠槃茶大将五百眷属。栴迟栴茶梨二大天女各一万眷属。汝等共护迦毗罗婆国。乃至遮障诸恶众生。彼等一切皆作是言。我等及诸眷属。护持养育迦毗罗婆国周遍土境。乃至遮障诸恶众生。佛及大众咸皆赞言。善哉善哉

尔时世尊以摩伽陀国。付嘱善住炎光天子千眷属。优波罗乾闼婆千眷属。乐声阿修罗千眷属。善臂龙王善意龙王各万眷属。孔雀味阿修罗五百眷属。拘那罗大夜叉三千眷属。军毗罗夜叉百千眷属。十象鸠槃茶大将百千眷属。懆恶天女夺意天女各十千眷属。汝等共护摩伽陀国。乃至遮障诸恶众生。佛及大众咸皆赞言。善哉善哉

尔时世尊以拘萨罗国。付嘱迷提羯那天子千眷属。乐胜乾闼婆大将十千眷属。乌麻紧那罗千眷属。具德龙王千眷属。弗沙钵帝阿修罗五百眷属。婆楼那夜叉大将婆楼那王夜叉大将各五万眷属。那荼迦鸠槃荼五百眷属。摩尼毗梨天女千眷属。汝等共护拘萨罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以鸯伽国。付嘱月音天子万眷属。乐欲乾闼婆大将沾浮楼乾闼婆大将各十千眷属。阿摩罗军紧那罗五百眷属。师子藏阿修罗五百眷属。旃檀大夜叉力幢大夜叉各五千眷属。奴罗车鸠槃荼二千五百眷属。摩诃迦梨天女二千五百眷属。汝等共护鸯伽国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以般遮罗国。付嘱罗拏时天子五百眷属。乐歌乾闼婆七百眷属。摩叶紧那罗千眷属。般支迦夜叉将五千眷属。安阇瞿波阿修罗千眷属。乐法鸠槃茶五百眷属。左黑天女王鬘天女各二千五百眷属。汝等共护般遮罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以苏摩国。付嘱宝髻天子五千眷属摩头曼多乾闼婆千眷属。胜缕紧那罗千眷属。优波般遮迦夜叉将二千眷属。黑龙王千眷属。知欲阿修罗千眷属。鸠罗婆鸠槃茶六百眷属。斯多天女博叉天女各五百眷属。汝等共护苏摩国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以阿湿婆国。付嘱卢醯奴天子千二百眷属。流水乾闼婆千眷属。摩尼拓罗夜叉军将五千眷属。阿周罗阿修罗六百眷属。日光龙王无量眷属。摩尼拓利鸠槃茶五百眷属。不可取天女马胜天女各二千五百眷属。汝等共护阿湿婆国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以摩偷罗国。付嘱善择天子十千眷属。静明乾闼婆千眷属。游梯迦紧那罗二百眷属。胜欲夜叉乘人大夜叉各千五百眷属。无垢龙王千眷属。伽楞拓利阿修罗千眷属。墨色鸠槃茶千眷属。夺意天女二千眷属。汝等共护摩偷罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以支提耶国。付嘱善贤天子五百眷属。阿吒迦乾闼婆五百眷属。无垢紧那罗千眷属。除结夜叉无结夜叉各五百眷属。妙贤龙千眷属。普竹阿修罗五百眷属。牛王鸠槃茶三百眷属。胜优波罗天女子眷属。汝等共护支提耶国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以婆蹉国。付嘱月光天子十千眷属。莲华香乾闼婆千眷属。摩陀那果紧那罗五千眷属。大果夜叉五千眷属。阿楼那龙千眷属。恶树阿修罗百眷属。叶眼鸠槃茶五百眷属。阿那迦华天女千眷属。汝等共护婆蹉国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以赊耶国。付嘱摩醯首罗天仙五千眷属。不酒乾闼婆千眷属。离垢紧那罗千眷属。因陀罗夜叉苏摩夜叉各二千五百眷属。善现龙千眷属。牟真邻陀阿修罗王五百眷属。优波檀提鸠槃茶讫利迦赊鸠槃茶各二千五百眷属。鬼子母天女善护天女各万眷属。汝等共护赊耶国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以优禅尼国。付嘱月云天子五百眷属。门牟乾闼婆千眷属。摩尼耳乾闼婆五百眷属。五恶夜叉千眷属。山臂龙王五百眷属。木手阿修罗三百眷属。善现鸠槃茶五百眷属。毛齿天女千眷属。汝等共护优禅尼国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以修罗吒国。付嘱法华天子百千眷属。具欲乾闼婆将万眷属。山怖紧那罗仙一百眷属。难陀龙王十千眷属。驴眼阿修罗五百眷属。善灯大夜叉千眷属。大肚鸠槃茶将千眷属。安隐天女千眷属。汝等共护修罗吒国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以摩诃罗仛(丑加反)国。付嘱孔雀发天子五百眷属。乐欲乾闼婆虎就乾闼婆各五百眷属。乳味紧那罗百眷属。主水龙王千眷属。乐宝阿修罗五百眷属。羖羝脚大夜叉军那罗大夜叉各千眷属。钵头摩迦鸠槃茶大将五百眷属。婆楼尼大天女五千眷属。汝等共护摩诃罗仛国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以输卢那国。付嘱千金天子千眷属。善胁乾闼婆千眷属。白色紧那罗五百眷属。世辩夜叉千眷属。大富鸠槃茶五百眷属。极恶天女摩尼果天女各五百眷属。汝等共护输卢那国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以摩尼讇鞞国。付嘱华音天子五百眷属。那罗延乾闼婆二百眷属。摩醯首罗华紧那罗三百眷属。团眼夜叉五百眷属。波罗奈子阿修罗百眷属。赤目鸠槃茶百眷属。雪王天女百眷属。汝等共护摩尼讇(市瞻反)鞞国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以波吒罗弗国。付嘱娑罗流支天子千眷属。人华乾闼婆五百眷属。摩尼瞿沙紧那罗三百眷属。声佉流支夜叉五百眷属。娑罗地阿修罗五百眷属。尸利瞿沙龙八百眷属。浮流尼鸠槃茶百眷属。毗楼池天女五百眷属。汝等共护波吒罗弗国。乃至佛及大众咸皆赞言。善哉善哉(次鸯伽国下)

尔时世尊以乾陀罗国。付嘱火布天子三千眷属。喜歌乾闼婆千眷属。大胜紧那罗五百眷属。师子发夜叉五百眷属。伊罗钵龙王千眷属。贤力龙王千眷属。精气主阿修罗五百眷属。猿猴声鸠槃茶百眷属。摩尼天汝频头天女各千眷属。汝等共护乾陀罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以阿槃提国。付嘱师子爱天子五千眷属。摩罗曼多乾闼婆二千眷属。胜目紧那罗百眷属。苏摩夜叉地行夜叉各千眷属。冰加罗阿修罗三千眷属。婆私陀荼龙千眷属。军那罗叉鸠槃茶百眷属。忧波罗天女流泉天女各二千眷属。汝等共护阿槃提国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以婆楼挐跋帝国。付嘱鸡娑利天子千眷属。众彩乾闼婆五百眷属。博叉流支紧那罗二百眷属。迦茶龙王忧波迦荼龙王各二千眷属。毗摩阿修罗百眷属。月焱鸠槃茶三百眷属。自护天女摩尼频头天女各千眷属。汝等共护婆楼挐跋帝国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以帝跋尼国。付嘱师子齿天子五千眷属。萨陀曼多乾闼婆五百眷属。牟尼萨罗紧那罗百眷属。摩尼贤夜叉满贤夜叉各二千五百眷属。铁耳阿修罗五百眷属。阿槃多鸠槃茶百眷属。萨市尼天女般支天女各千眷属。汝等共护帝跋尼国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以瞻波国。付嘱香云天子并诸天仙一千眷属。德鬘乾闼婆二百眷属。求筹遮紧那罗百眷属。坚毛夜叉五千眷属。迦那迦阿修罗百眷属。善现鸠槃茶近现鸠槃茶各五万眷属。什目天女五百眷属。汝等共护瞻波国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以悉都那国。付嘱赤云天子千眷属。沾浮楼乾闼婆五百眷属。摩尼遮婆紧那罗百眷属。难胜夜叉千眷属。泥荼鸠支阿修罗五百眷属。鞞[少/兔]迦鸠槃茶百眷属。静默天女善目天女各一千五百眷属。汝等共护悉都那国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以西地国。付嘱山眼天子二百眷属。法喜乾闼婆百眷属。薮支罗婆紧那罗百眷属。大身夜叉千眷属。执刀阿修罗百眷属。止流鸠槃茶三百眷属。金光天女黑光天女各二千五百眷属。汝等共护西地国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以富楼沙富罗国。付嘱阿罗脯斯天子千眷属。难提乾闼婆百眷属。净众紧那罗百眷属。摩尼华夜叉千眷属。迦荼龙王阿婆罗罗龙王各二千五百眷属。大怖伽楼罗百眷属。讫多孙地阿修罗五百眷属。烧竹鸠槃茶五百眷属。多卢斯天女三目天女各五百眷属。汝等共护富楼沙富罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以乌场国土。付嘱习音天子五百眷属。华光乾闼婆三百眷属。善怖紧那罗百眷属。迦罗婆提夜叉五百眷属。郎浮罗龙三百眷属。遮曼池阿修罗百眷属。曼陀果鸠槃荼百眷属。呵梨帝天女染贤天女各五百眷属。汝等共护乌场国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以寄萨离国。付嘱黑色天子千眷属。金色乾闼婆百眷属。跋那牟至紧那罗八十眷属。散发夜叉五百眷属。力天龙王百眷属。那佉遮利阿修罗百眷属。无垢声鸠槃茶八十眷属。胜针天女蝎天女各五百眷属。汝等共护寄萨离国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以金性国。付嘱禅那离沙婆天子五百眷属。摩那婆乾闼婆百眷属。善称紧那罗百眷属。禅那离沙婆夜叉五百眷属。宝冠阿修罗百眷属。香意鸠槃茶八十眷属。汝等共护金性国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以摩都罗国。付嘱歌赞天子百眷属。五髻乾闼婆五百眷属。威德紧那罗八十眷属。坚鉾夜叉五百眷属。冰伽罗阿修罗五百眷属。贤目鸠槃茶百眷属。沾浮楼天女五百眷属。汝等共护摩都罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以薮离迦国。付嘱财目天子千眷属。善顶乾闼婆百眷属。赊摩鸠斯紧那罗五百眷属。坚固夜叉五百眷属。耶婆那夜叉千眷属。无畏紧那罗百眷属。跋罗头婆阇夜叉五百眷属。啖婆何利阿修罗八百眷属。瞿伽叉鸠槃茶三百眷属。啖婆何利罗刹五百眷属。释迦罗刹五百眷属。汝等共护薮离迦国。乃至佛及大众。咸皆赞言。善哉善哉

尔时世尊以般遮囊伽罗国。付嘱婆婆叉天子千眷属。月光乾闼婆百眷属。围目夜叉千眷属。大云阿修罗五百眷属。诃奴阇鸠槃茶百眷属。摩尼枳萨梨天女五百眷属。多摩罗婆利天女千眷属。汝等共护般遮囊伽罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以波斯国。付嘱檀[少/兔]师天子五千眷属。拘毗罗乾闼婆三千眷属。梨鞞摩师紧那罗千眷属。住勇夜叉五百眷属。那摩罗王夜叉五百眷属。庵罗提他乾闼婆千眷属。伊沙那时紧那罗千眷属。竭娑拘支鸠槃茶四千眷属。那罗斯罗刹五千眷属。呵梨达罗刹二千眷属。汝等共护波斯国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以敕勤国土。付嘱佉楼那天子千眷属。妙好乾闼婆五百眷属。帝利迦紧那罗五百眷属。三钵夜叉二万眷属怖畏夜叉十千眷属。休流歇龙千眷属。金耳阿修罗千眷属。善林树鸠槃茶千眷属。金枳(金支反)萨罗罗刹五千眷属。汝等共护敕勤国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以叵耶那国。付嘱海怖天子千眷属。那茶浮乾闼婆百眷属。马目紧那罗百眷属。华齿夜叉二千眷属。大齿夜叉千眷属。忧波罗耳龙五百眷属。动手阿修罗百眷属。解脱鸠槃茶百眷属。质摩只萨梨罗刹女五百眷属。黑闇罗刹护门罗刹各二千五百眷属。月光罗刹千眷属。汝等共护叵耶那国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以尸利耶摩国。付嘱黑发天子百眷属。金臂乾闼婆八十眷属。风响紧那罗百眷属。阿楼那夜叉千眷属。八发夜叉千眷属。上踊龙王百眷属。快作阿修罗百眷属。香筒鸠槃荼五百眷属。黑泽天女五百眷属。汝等共护尸利耶摩国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以跋离迦国。付嘱赤铜色天子八百眷属。媚眼乾闼婆百眷属。针黑紧那罗百眷属。牟耳夜叉五千眷属。黟罗羯那龙百眷属。息牛阿修罗百眷属。阿毗拏萨利鸠槃茶五百眷属。长苗天女妙胜天女各五百眷属。汝等共护跋离迦国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以罽宾那国。付嘱怖黑天子五十眷属。五音乾闼婆千眷属。水性紧那罗五百眷属。广执夜叉三万眷属。长生夜叉流云解脱夜叉各二千五百眷属。睺罗荼龙十千眷属。郁金阿修罗千眷属。陀楼跋尼鸠槃茶五百眷属。正辩天女千眷属。园林罗刹女十千眷属。汝等共护罽宾那国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以忧罗赊国。付嘱那罗摩乾闼婆百眷属。五怖夜叉二千眷属。尸利沙夜叉千眷属。汝等共护忧罗赊国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以佉罗婆罗国。付嘱时兰那乾闼婆百眷属。华宝夜叉千眷属。善乐目龙千眷属。怖人鸠槃茶五百眷属。顺欲天女百眷属。汝等共护佉罗婆罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以阿疏居迦国。付嘱牟尼佉利夜叉二千眷属。好施罗刹千眷属。婆稚龙五百眷属。止云鸠槃荼百眷属。呵梨帝罗刹女千眷属。汝等共护阿疏居迦国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以达罗陀国。付嘱鞞婆达利乾闼婆百眷属。道路夜叉黄头夜叉勇健夜叉各千眷属。跋陀龙王二千眷属。孔雀毛龙王百眷属。生解天女毛罗阇利天女各二百五十眷属。汝等共护达罗陀国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以弗梨沙国。付嘱夺意夜叉戒贤夜叉各五百眷属。云腹龙王三百眷属。离恶鸠槃茶八十眷属。搔跋质罗天女百眷属。汝等共护弗梨沙国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以伽赊国。付嘱持华乾闼婆摩睺罗伽乾闼婆各千眷属。金枳(金支反)持夜叉毗持夜叉各二百五十眷属。光掌龙王胜夺龙王各五百眷属。阿楼尼天女华目天女各二百五十眷属。汝等共护伽赊国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以遮居迦国。付嘱剑婆罗龙王五百眷属。极恶鸠槃茶百眷属。那朱波毗舍遮百眷属。星目罗刹女五百眷属。天铠饿鬼将二百眷属。歇恶夜叉三百眷属。汝等共护遮居迦国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以簁堤国。付嘱具足龙王善道龙王各百眷属。坚目鸠槃茶百眷属。八毗那耶迦天女一百眷属。道神天女尸利天女各二百五十眷属。珂贝天女安住天女各五十眷属。汝等共护簁堤国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以沙勒国。付嘱发色天子百眷属。护国乾闼婆百眷属。佛护夜叉助雹夜叉各五百眷属。孔雀项龙王百眷属。山目龙女五百眷属。讫利波赊鸠槃茶五百眷属。持德天女龙护天女各二百五十眷属。汝等共护沙勒国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以于填国土。付嘱难胜天子千眷属。散脂夜叉大将十千眷属。羖羊脚大夜叉八千眷属。金华鬘夜叉五百眷属。热舍龙王千眷属。阿那紧首天女十千眷属。他难阇梨天女五千眷属。毗沙门王神力所加共汝护持于填国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以龟兹国土。付嘱牟铠天子千眷属。黄头大夜叉千眷属。厌财罗刹女千眷属。睺护大夜叉千眷属。疏齿鸠槃茶千眷属。尸利遮吒罗刹鹿齿罗刹各五百眷属。汝等共护龟兹国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以婆楼迦国。付嘱骞茶夜叉千眷属。阿婆迦利鸠槃茶百眷属。垂乳罗刹千眷属。汝等共护婆楼迦国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以奚周迦国。付嘱王活乾闼婆五百眷属。奚卑罗龙百眷属。汝等共护奚周迦国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以亿尼国。付嘱勇健执蠡大夜叉将千眷属。象耳龙王三千眷属。吉迦知罗刹女雪池罗刹女各二千五百眷属。汝等共护亿尼国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以鄯善国。付嘱阿罗知天子百眷属。阿沙迦夜叉五千眷属。无著罗刹女十千眷属。汝等共护鄯善国土。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊以紧那罗国。付嘱赤目大夜叉十千眷属。不动鸠槃茶千眷属。汝等共护紧那罗国。乃至佛及大众咸皆赞言。善哉善哉

尔时世尊。以震旦国。付嘱毗首羯磨天子五千眷属。迦毗罗夜叉大将五千眷属。法护夜叉大将五千眷属。坚目夜叉大将五千眷属。大目夜叉大将五千眷属。勇健军夜叉大将五千眷属。摩尼跋陀夜叉大将五千眷属。贤满夜叉大将五千眷属。持威德夜叉大将五千眷属。阿荼薄拘夜叉大将五千眷属。般支迦夜叉大将五千眷属。婆修吉龙王五千眷属。须摩那果龙王五千眷属。弗沙毗摩龙王五千眷属。呵梨帝鬼子母天五千眷属。伊罗婆雌大天女五千眷属。双瞳目大天女五千眷属。汝等贤首。皆共护持震旦国土。于彼所有一切触恼斗诤怨仇忿竞言讼两阵交战饥馑疫病非时风雨冰寒毒热悉令休息。遮障不善诸恶众生嗔恚粗犷苦辛涩触无味等物悉令休息。令我法眼得久住故。绍三宝种不断绝故。三种精气得增长故。利益安乐诸天人故。勤加护持。以是因缘汝等今世及以后世常得安乐。毗首羯磨天子及与眷属。迦毗罗大夜叉法护夜叉坚目夜叉大目夜叉勇健夜叉摩尼跋陀夜叉贤满夜叉持威德夜叉阿荼薄拘夜叉般支迦夜叉及与眷属。婆修吉龙王须摩那果龙王。弗沙毗摩龙王及与眷属。呵梨帝鬼子母天。伊罗婆雌天女双瞳目天女及与眷属。各作是言。大德婆伽婆。我等共护震旦国土。休息一切斗诤乃至增长三种精气。我等勤加护持养育。乃至世尊声闻弟子三业相应不积聚者。倍复安置护持养育

尔时世尊赞言。善哉善哉。善男子。汝应如是护持我法。诸来大众亦复随喜赞言。善哉善哉

诸仁者。我以阎浮提一切国土。付嘱诸天乾闼婆紧那罗夜叉龙王阿修罗鸠槃茶诸天女等。各令安置护持养育一切众生。是故汝等诸大龙王不得分者。应当容忍莫恨。所谓娑伽罗龙王阿那婆沓多龙王。伊罗跋龙王。婆楼那龙王。善住龙王。德叉迦龙王。恒河龙王。辛头龙王。博叉龙王。私陀龙王。堤首尼龙王。摩醯谟遮利龙王。金胁龙王。跋致苏多龙王弗婆钵赊龙王。众色云龙王。拘那跋帝龙王。阿斯多龙王。遮弥罗龙王。香山龙王。那罗延面龙王。婆婆牟支龙王。那陀叉龙王。如是等一百八十万诸大龙王。住阎浮提不得分者。应当容忍莫恨。汝等各住本宫护持养育我之正法。当作利益一切众生行。以是因缘汝等今世及以后世自利利他何以故。彼诸天龙乾闼婆紧那罗夜叉阿修罗鸠槃茶天女罗刹女等。随其国土昔所住处。彼诸天龙乃至天女。为护彼彼诸国土故。安置养育一切众生。是故汝等大夜叉王不得分者。应当容忍莫恨。所谓箭毛夜叉。赊罗毗夜叉。迦吒首利夜叉。婆罗目企夜叉。婆罗稚夜叉。婆摩罗夜叉。其梨迦吒夜叉。由梯迦夜叉。其梨呵夜叉。满面夜叉。迦赊毗提夜叉。护国夜叉。楼迦夜叉。箭爪夜叉。波那流支夜叉。狼爪夜叉。师子怖夜叉。阿楼尼夜叉。修罗阇毗夜叉。阿茶阇梨夜叉。得叉梨师夜叉。灰手夜叉。苏摩那虎夜叉。罗摩那时夜叉。恶叉尼弃罗夜叉。质多罗夜叉。佛护夜叉。如是等八频婆罗诸夜叉大将。依阎浮提种种寺舍园林泉池山岩林薮树下安住不得分者。应当容忍莫恨。随所住处乃至山林树下各住本处。护持养育我之正法。利益安乐一切众生行。以是因缘汝等今世及以后世自利利他。何以故。彼诸天龙乾闼婆紧那罗夜叉阿修罗鸠槃茶天女罗刹女等。随其国土昔所住处。彼诸天龙乃至天女。为护彼彼诸国土故。安置养育一切众生。是故汝等诸阿修罗王不得分者。应当容忍莫恨。所谓罗睺罗阿修罗王。毗摩质多罗阿修罗王。波罗陀阿修罗王。睒婆利阿修罗王。牟真邻陀阿修罗王。须质多罗阿修罗王。跋稚毗卢遮那阿修罗王。悉利罗耆阿修罗王。黟罗跋支阿修罗王。瞿摩阇毗阿修罗王。毗茶叉阿修罗王。那耶遮利阿修罗王。伽阇弥罗阿修罗王。初罗檀茶阿修罗王。阿斯末罗阿修罗王。迦摩跌知阿修罗王。婆罗干荼阿修罗王。毕他摩尼阿修罗王。波罗那佉阿修罗王。萨婆鸯伽叉阿修罗王。讫赊婆睺阿修罗王。如是等六万那由他阿修罗王住阎浮提不得分者。应当容忍莫恨。各住本宫护持养育我之正法。当作利益一切众生行。以是因缘汝等今世及以后世自利利他。何以故。彼诸天龙乾闼婆紧那罗夜叉阿修罗鸠槃茶天女罗刹女等。随其国土昔所住处。彼诸天龙乃至天女为护彼彼诸国土故。安置养育一切众生。是故汝等诸大天女应当容忍莫恨。所谓歇大天女。造光天女。地解天女。增护天女。解脱天女。增水天女。少热天女。净目天女。饶财天女。宝藏天女。摩尼爪天女。黑绳天女。随时天女。王顶天女。天水天女。眼目天女。莲华天女。忧昙婆罗天女。赊尸天女。明炬目天女。善意天女。难胜天女。胜目天女如是等六十二百千诸大天女。依阎浮提种种塔寺城邑聚落园林泉池河边山谷大海边住不得分者。汝等随所住处各各于彼护持养育我之正法。汝等于彼所有怖畏斗诤怨仇饥馑疫病他方怨敌非时风雨冰寒毒热悉令休息。遮障不善诸恶众生嗔恚粗犷苦辛涩触无味等物悉令休息。令我法眼久住世间。绍三宝种不令断绝。三种精气增长炽然。利益安乐诸天人故勤加护持。以是因缘汝等今世及以后世常得利益安乐众生。时彼六十二百千天女白佛言。大德婆伽婆。我等护持养育佛法。休息斗诤增长一切三种精气。乃至世尊声闻弟子三业相应无所积聚者。我等勤加护持养育。佛言。善哉善哉。善女人辈。汝等应当如是护持。诸来大众皆亦随喜赞言。善哉善哉

尔时世尊。复告一切诸天乾闼婆乃至诸大天女言。我今与汝息诸诤讼大陀罗尼心。汝等以此陀罗尼心故。各于己国若曜宿失度。摄诸众生令得敬信。一切斗诤悉得休息。作是语已。即说咒曰

哆地夜他　摩陀那　摩陀那　瞿摩陀那阿婆摩多　阿兮摩多　摩陀那佉　阿差摩坻波罗　赊摩帝　阿唎婆三摩摩帝尼佉摩帝　波赊摩帝　苏遮啰拏摩帝阿毗婆摩帝　阿啰毗婆摩帝　悉陀頞他摩帝　叉婆摩帝　苏婆呵

尔时娑婆世界主大梵天王。从坐而起向佛合掌头面作礼而作是言。大德婆伽婆。我今复以大陀罗尼。降诸恶龙及恶鬼神。护持国土。遮障一切诸恶众生。作是语已。即说咒曰

哆地夜他　昙无啰牟喽啰牟喽　那伽牟喽　那伽牟喽　阿薮啰牟喽　药叉牟喽鸠槃茶牟喽　浮单那牟喽　迦吒富单那牟喽　阿耶婆牟喽侯呵侯呵牟喽　呵呵呵呵　牟厨帝药叉牟喽啰婆呵啰婆呵　啰婆呵　萨婆乌阇啰婆呵　苏婆呵

尔时所有诸天龙王鸠槃茶饿鬼毗舍遮富单那迦吒富单那饮血食肉者。皆悉惊怖忧愁恐惧。向佛合掌头面礼足而作是言。唯愿世尊。大悲覆护。我等云何复得存活。佛言。汝等且莫忧愁。大地所有华果五谷药草众味清净未食堕落地者。如是华果众味精气汝等食之足得活命。若复有人作食清净遗落在地。汝等亦当食其精气而自充济。复有我诸声闻弟子修禅定者。以己善根咒愿。汝等亦得色力精气丰盛眷属朋党具足势力。若有施主施我弟子寺舍园林田地舍宅称名咒愿。汝当于彼与欲随喜护持养育。以是事故汝等宫殿当得增长。若有施主施我弟子饮食衣服卧具汤药受取之时称名咒愿。汝亦随喜。以彼咒愿汝随喜故。汝等便得寿命增长愿容增长安乐增长朋党增长势力增长。汝等昼夜应当精勤护持养育如是施主及以受者

尔时世尊。欲重明此义。而说偈言

  两足大法王　　观众作是言
  帝释汝问我　　各随与其分
  天龙鸠槃茶　　夜叉修罗刹
  阎浮诸国土　　城邑众聚落
  旷野诸树林　　山岩井泉池
  法眼得久住　　诸恶令休息
  丰饶悉可乐　　为于阎浮提
  四天中鬼神　　付嘱勤护持
  汝等舍眷属　　我复更分布
  莫嗔怒嫉妒　　与欲当随喜
  法喜禅味食　　如是诸天众
  一切皆悉起　　咸作如是言
  我等为正法　　护持阎浮提
  声闻具持戒　　不为积聚者
  剃头不持戒　　欲令法眼增
  我等皆至心　　勤加护养育
  导师告彼言　　正法我灭后
  具满五百年　　坚固住解脱
  五百年禅诵　　五百造塔寺
  至后五百年　　坚住于斗诤
  后时有剃头　　破戒无羞耻
  供养如是辈　　亦得无量福
  譬如金无价　　除金至银宝
  鋀石伪铜铁　　白镴及铅锡
  世间若无宝　　锡镴为最上
  佛宝亦如是　　最尊独第一
  次宝辟支佛　　罗汉余证果
  得定净持戒　　破戒名字僧
  深信求解脱　　若能供养彼
  不久住忍地　　必速证菩提
  六欲诸天子　　宝国诸鬼神
  住林乾闼婆　　海中十大龙
  十大鸠槃茶　　夜叉十神通
  各住本宫殿　　护持我正法
  饿鬼住旷野　　毗舍遮空室
  富单依野田　　迦吒冢间住
  如是各随喜　　依分皆护持
  依分不正护　　复勤恼于他
  我以如是等　　更转付余天
  诸龙夜叉众　　乾闼紧那罗
  天女修罗等　　罗刹鸠槃荼
  普遍诸国土　　安置护养育
  迦毗波罗奈　　摩伽拘萨罗
  般遮鸯伽国　　苏摩阿湿婆
  摩偷支提国　　婆蹉及赊耶
  罗吒忧禅尼　　罗仛输卢那
  摩尼讇鞞国　　乾陀波吒罗
  般提婆楼帝　　跋尼悉都那
  瞻波钵浮尼　　富楼沙富罗
  乌场寄萨梨　　金性摩都罗
  波斯敕勤土　　般遮囊伽罗
  尸利耶摩国　　叵耶薮利迦
  罽宾跋利国　　佉罗忧罗赊
  伽赊遮居国　　达罗弗离沙
  簁提沙勒国　　婆楼兮周迦
  于填及鄯善　　龟兹紧那罗
  震旦等国土　　护持令安置
  于此一切国　　诸龙无分者
  一百八十万　　夜叉等无分
  及八频婆罗　　修罗不得分
  六万那由他　　天女等无分
  六十二百千　　我今悉谢汝
  各住本宫殿　　护持我正法
  当与汝神咒　　遮障恶众生
  休息诸恼害　　一切斗诤讼
  亢旱及水潦　　病俭诸贼寇
  增长三精气　　诸恶令休息
  护持我正法　　炽然三宝种
  声闻诸比丘　　三业常相应
  剃头不持戒　　一切皆护持
  为诸声闻故　　具舍诸田宅
  饮食及汤药　　一切有所须
  如是诸施主　　汝等护养育

大方等大集经卷第五十五大方等大集经卷第五十六

        高齐天竺三藏那连提耶舍译

    月藏分第十二星宿摄受品第十八

尔时佛告娑婆世界主大梵天王释提桓因四天王言。过去天仙云何布置诸宿曜辰。摄护国土养育众生。娑婆世界主大梵天王释提桓因四天王等。而白佛言。过去天仙分布安置诸宿曜辰。摄护国土养育众生。于四方中各有所主

东方七宿。一者角宿主于众鸟。二者亢宿主于出家求圣道者。三者氏宿主水生众生。四者房宿主行车求利。五者心宿主于女人。六者尾宿主洲渚众生。七者箕宿主于陶师

南方七宿。一者井宿主于金师。二者鬼宿主于一切国王大臣。三者柳宿。主雪山龙。四者星宿主巨富者。五者张宿主于盗贼。六者翼宿主于商人。七者轸宿主须罗吒国

西方七宿。一者奎宿主行船人。二者娄宿主于商人。三者胃宿主婆楼迦国。四者昴宿主于水牛。五者毕宿主一切众生。六者嘴宿主鞞提诃国。七者参宿主于刹利

北方七宿。一者斗宿主浇部沙国。二者牛宿主于刹利及安多钵竭那国。三者女宿主鸯伽摩伽陀国。四者虚宿主般遮罗国。五者危宿主着花冠者。六者室宿主乾陀罗国输卢那国及诸龙蛇腹行之类。七者壁宿主乾闼婆善音乐者。大德婆伽婆。过去天仙如是布置四方诸宿。摄护国土养育众生

尔时佛告梵王等言。汝等谛听。我于世间天人仙中一切知见最为殊胜。亦使诸宿曜辰摄护国土养育众生。汝等宣告令彼得知。如我所分国土众生各各随分摄护养育。大梵王等而白佛言。如是大德婆伽婆。唯然受教

尔时佛告梵王等言。我今以彼于摩国。陀楼国。悉支那国。奈摩陀国。陀罗陀国。佉沙国。罗佉国。赊摩国。侯罗婆国。舍头迦国。頞阇婆国。没遮波国。此十二国。付嘱角宿摄护养育。亦护角宿日建立国土城邑聚落及角宿日所生众生汝等宣告令彼得知。梵王等言。如是大德婆伽婆。唯然受教

尔时佛告梵王等言。我今以彼阿罗荼国。诃利那国。叔迦罗国。波卢罗国。弗利赊国。那摩帝国。俱致娑国。苏那婆国。赊摩国。跛陀婆国如是十国。付嘱亢宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼佉搜迦国。信头婆迟国。阿摩利国。余尼目佉国。难陀婆国。伽沙国。跋使俱阇国。由婆迦国。婆佉罗国。沙婆罗国。伽楼荼国。鸠筹迦国。婆遮利婆国此十三国。付嘱氐宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼波头摩国弗色迦罗国。目帝国。嵩伽摩国。耆利国。不摩婆国。南耆利国。遮波罗国。修帝达赊国。提婆那国。奚周迦国。此十一国。付嘱房宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼睺罗婆国。鸠罗婆国。牟罗婆国。能伽婆国。苏提闼国。鸠知迦国。天王国。毗那婆国。波搜多国。奚迦国如是十国。付嘱心宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼伽阇弗国。迦罗婆国。迦迦波他国。悉陀叉国。郁瑟吒罗婆国。帝罗南国。阿罗毗国。那婆国。弗色迦罗婆国。摩兜利国。迦邻伽跋帝国。摩于达利国。毕姜阇国。钵利犀罗婆国此十四国。付嘱尾箕二宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼婆蹉国。忧禅尼国。忧楼频螺国。输尼般多国。摩荼婆国。毗使拏提波国。遮罗羯波国。婆罗斫迦罗国。罗摩伽摩国。迦尸弗国。鸠楼沙国。陀修国。卢醯多国。阿婆陀荼国。帝拏槃那国。遮达那国。毗伽阇国此十七国。付嘱井宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼波吒利弗国。摩尼蓝婆国。婆楼那国。那遮罗国。羯那国。北般遮罗国。帝跋拏国。娑罗蹉国。瞻波国。苏都那国。鸠楼差多国。西地国。富楼沙富罗国。侯弥单国。蓝摩婆国。瞿罗国。奚摩国。阇耶波梯国。婆求弥国。恒河门国。头婆罗婆帝国。旃达罗跋帝国。婆楼迦车国。苏尼弃国。瞿沙跋帝国。此二十五国。付嘱鬼宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼寄萨梨国。摩诃尼梯国。乌场国。须尼弃国。波罗婆国。忧罗婆国。区荼国。尼佉国。干荼波罗婆国。婆寄多国。如是十国。付嘱柳宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼阿鞞遮国。苏跋拏国阇吒国。金性国。摩兜罗国。毗摩尸利国。检婆楼遮国。苏梨国。婆求遮国。频头罗婆国。婆罗那国。般遮囊伽罗国。此十二国。付嘱星宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼波斯国。诃利陀国。敕勤国。阿摩罗国。婆罗婆国。苏摩尼弃国。叵耶那国。三牟遮国。尸梨沙国。婆利国。伽菟娑国。摩遮国。兜佉罗国。摩头师利国。此十四国。付嘱张翼二宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼伽罗婆罗国。忧罗赊国。罽使拏国。婆耆国。檀多摩利国。婆楼遮国。陀荼国。达拏国。薮牟寄赊国。鸠论遮差国。呿罗婆罗国。阿疏俱迦国。此十二国。付嘱轸宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼鸠赊弗利国。紧那罗国。迦卑罗摩利国。三谟师国。咽罗尼国。时婆利国。奚阇尼国。摩兜褰迟国。般荼梨国。蜜拏梨国。修罗毗国。侯摩多尼国。此十二国。付嘱奎宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼提帝赊婆国。苏摩跋罗国。多罗比尼国。阿赊若国。俱萨罗斯国。悉都那国。娑罗瞬迟国。紧拏多利国。湿婆尼利国。罗婆师饥国。佉吒梨毗国。佉娑利国。白马国。此十三国。付嘱娄宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼阿斯那弃国。军陀罗毗国。安尼师国。遮俱波国。兜伽帝国。逋支国。支多毗悉帝国。忧簁帝国。槃头波罗国。毗罗梨迦国。摩陀罗毗国。迦拏波帝国。达婆娑梨国。此十三国。付嘱胃宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼波罗耽罗国。只叔迦国。婆楼遮国。输卢那国。迦毗罗婆国。奢耶国。马面国。伽楼荼国。憍罗跋陀国。吴地国。阇婆跋帝国。鞞楼国。伽楼诃国。于填国。伽颇罗国。狗面国。尼婆罗国。俱那娑国。此十八国。付嘱昴宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼摩伽陀国。鞞提诃国。萨罗国。奚浮迦国。牟尼奢耶国。罗罗国。余尼迦国。拘萨罗国。跋沙伽国。阿荼国。鞞诃迦国。頞那婆国。伽耶国。尼婆国。槃罗婆国。跋知尼国。陀楼国。尸利曼多国。弥伽颇罗国。摩醯首罗腻罗耶国。罽宾国。婆卢师多国。沙勒国。忆尼国。簁堤国。此二十五国。付嘱毕宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼尼娑国。迦尸国。奢鸠尼国。阿吒摩阇国。紧陀国。摩婆摩国。达毗迦国。八城国。殊提沙国。婆毗迦国。婆求荼国。摩诃罗吒国。乾陀罗国。迦婆摩国。般遮罗国。多荼沙国。首婆迦国。摩师跋那国。兜罗婆国。苏摩国。婆求国。摩多摩利国。摩罗婆国。鸠留国。瞿沙国。此二十五国。付嘱嘴宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼阿湿婆国。奢跋那国。摩偷罗国。鸯伽吒婆国。摩头曼多国。俱周罗国。曼遮国。婆求摩国。俱阇婆国。震旦国。首罗犀那国。阿那牟佉国。佉罗婆罗国。犀摩娑国。那[少/兔]逻婆跋陀国。曼迟罗婆国。奚周迦国。此十七国。付嘱参宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼辛头鸠罗国。瞿那悉须国。迦罗差国。娑罗差国。达罗腻钵帝国。海果国。阿楼瑟拏罗婆国。那婆弗使波罗婆国。摩那兜利国。民陀罗跋帝国。如是十国。付嘱斗宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼刹利天祠如是二处。付嘱牛宿摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼阿楼那国。鸠私娑罗阇利国。瞻波兜簁国。龟慈国。摩蓝浮沙国。舍迦国。物陀罗多国簁提国。瞿师国婆罗弥国。如是十国付嘱女宿。摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼难提跋弥国。波罗尸国。满福国。忧罗奢国。蓝浮沙国。娑婆国。摩陀罗婆国。簁提国。佉沙国。娑罗斯国。师子国。诃波他国。诃利鸠时国忧婆毗罗国。多罗尼国。毗舍离国。忧迦利国。此十七国。付嘱虚宿。摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼迦车鞞帝国。波利支国。龙花国。鸠荼婆国。难提跋檀那国。婆楼迦国。乾陀俱致国娑弥利国。夜瑟吒俱利国。如是九国。付嘱危宿。摄护养育。乃至唯然受教

尔时佛告梵王等言。我今以彼侯曼陀国。奢曼陀国。头摩迦国。酬摩迦国。犍沙婆国。鸠支国。博叉利国。德叉尸罗国。婆弥婆利国。跋陀跋帝国。忧摩差国。跋娑多牟利摩国。婆楼迦车国。婆罗跋帝国。此十四国。付嘱室壁二宿。摄护养育。亦护二宿日建立国土城邑聚落。及二宿日所生众生。汝等宣告令彼得知。梵王等言。如是。大德婆伽婆。唯然受教

尔时佛告梵王等言。所言曜者。有于七种。一者日二者月三者荧惑星四者岁星五者镇星六者辰星七者太白星。所言辰者。有十二种。一名弥沙二名毗利沙三名弥偷那四名羯迦吒迦五名[糸*枲]呵六名迦若七名兜逻八名毗梨支迦九名檀尼毗十名摩伽罗十一名鸠槃十二名弥那。我今令此诸曜辰等摄护国土城邑聚落养育众生。汝等宣告令彼得知。梵王等言。如是大德婆伽婆。唯然受教

尔时娑婆世界主大梵天王释提桓因护世四王及诸眷属而白佛言。大德婆伽婆。若有世尊声闻弟子不得畜养奴婢畜生园林田宅俗人资具及不交往。除四方僧物。起发精进三业相应常怀惭愧。独住闲林集诸善法。我于彼时令宿曜辰正行于世遮恶众生触恼斗诤。两国兵仗疾病饥馑非节风雨失时寒热悉令休息。护佛正法久住炽然。绍三宝种使不断绝。三种精气增长安住。亦使世尊声闻弟子身口意业清净相应发大勇猛循法而住

尔时佛告阿若憍陈如言。为令我法得久住故。成熟众生故。阎浮提中一切诸国。一名诸国。多名诸国。同名诸国。及不列名国。分布与彼天龙夜叉乃至迦吒富单那等令作护持及宿曜辰亦付诸国令作护持。乃至令三宝种不断绝故。所有诸国多名同名。于彼诸国同名夜叉同名罗刹。有国无鬼神名有鬼神住。还付彼等令作护持。于阎浮提有余鬼神不列名者亦使护持。憍陈如。一切鬼神皆悉发心护持养育。乃至随我声闻弟子三业相应常无聚积循法而住。于一切时护持养育。憍陈如。汝等应当常不聚积住阿兰若。三业相应背舍生死趣向涅槃成熟众生。应如是学

尔时世尊。欲重明此义。而说偈言

  或熟众生故　　我问诸天王
  云何昔天仙　　配宿摄诸国
  梵天答我言　　过去天仙等
  安置诸宿曜　　护如法众生
  今付汝国土　　应当加养育
  亦付鬼神等　　而令作护持
  及彼宿曜辰　　各令摄国土
  护持养育故　　炽然正法眼
  护不畜田宅　　清净声闻众
  遮诸恶众生　　及息诸浊恶
  不绝三宝种　　增长三精气
  汝告宿曜等　　令彼作护持
  我告诸声闻　　令住正法眼
  应当舍憍慢　　精勤住兰若
  背舍于生死　　趣向于涅槃
  乐住禅境界　　成熟亿众生

    大集经月藏分第十二建立塔寺品第十九

尔时娑婆世界主大梵天王释提桓因四天王等及诸眷属。从座而起合掌向佛一心敬礼而作是言。佛说于此四天下中所有过去诸佛如来之所建立住持大塔牟尼诸仙所依住处。于现在世及未来世而常不空。佛为菩萨摩诃萨等降大法雨皆悉充满。初名众仙所兴。次名德积。次名金刚焰。次名香室。次名睒婆梨。次名贤城。次名须质多罗。次名水光。次名香薰。次名善建立。次名遮波罗。次名金灯。次名乐依。次名牟真邻陀。次名金刚地。次名慈窟。次名那罗延窟。次名渠摩娑罗香。次名慧顶。次名大德窟。次名善现。次名青郁茂窟。次名虚空子。次名牛头栴檀室。次名难胜。此是过去诸佛建立住持大塔。常为菩萨摩诃萨等之所加护。是于我等常所供养。世尊所有声闻弟子。于现在世及未来世。复有几所塔寺住处。令我等辈护持养育

尔时世尊熙怡微笑。从其面门放种种光照曜诸方。即时于此四天下中。而有无量百千诸佛处处而现。东弗婆提八万佛现。北郁单越百千佛现。西瞿陀尼五万佛现诸海岛国百千佛现。此阎浮提二百五十千佛处处而现。波罗奈国六十佛现。迦毗罗婆国二十佛现。摩伽陀国三十佛现。鸯伽摩伽陀国二十佛现。拘萨罗国五十佛现。须罗吒国二十佛现。摩诃罗吒国三十佛现。乾陀罗国十佛而现。阿槃提国二十六佛现。般遮罗国二十五佛现。苏摩国十二佛现。阿叶婆国十佛而现。摩偷罗国十佛而现。毗罗国十八佛现。婆蹉国五十六佛现。奢耶国四十二佛现。优禅尼国二十三佛现。舒卢那槃多国二十五佛现。舒卢那国三十八佛现。摩尼蓝婆国二十五佛现。波梨弗国五十五佛现。婆楼那跋提国四十八佛现。提跋那国二十九佛现。瞻波国二十五佛现。悉都那国三十六佛现。西地国七十佛现。富楼沙富罗国五十佛现。乌长国二十六佛现。抧萨罗国二十二佛现。金性国二十九佛现。摩兜罗国四十佛现。涑利迦国二十八佛现。般遮囊伽国五十八佛现。波斯国二十佛现。敕勤国四十佛现。尸利沙国三十二佛现。婆佉罗国五十八佛现。罽宾国五十五佛现。忧罗奢国二十五佛现。佉罗婆罗国十二佛现。阿疏拘迦国二十二佛现。陀罗陀国十五佛现。波卢那国二十佛现。弗离沙国十五佛现。迦沙国二十八佛现。遮拘迦国二十佛现。簁提国四十五佛现。沙勒国九十八佛现。于填国百八十佛现。龟兹国九十九佛现。婆楼迦国二十四佛现。奚周迦国十八佛现。亿尼国八十佛现。鄯善国二十九佛现。紧那罗国八十佛现。震旦国二百五十五佛现。罗罗国二十四佛现。吴地国五十佛现。新陀跋持国二十五佛现

佛言。诸仁者。如是等佛。于此四天下国土城邑村落山林处处而现我今神力之所加故。还有如是等数塔寺。于彼彼处。我诸声闻现在未来三业相应。及与三种菩提相应有学无学具足持戒多闻善行。度诸众生于三有海。及诸施主为我声闻而造塔寺。亦复供给一切所须。及彼眷属付嘱汝等。勿令恶王非法恼乱。又复勿令他方冤敌盗贼水火人非人等之所恐怖。亦勿令彼饥渴乏少。以乏少故于三善业不得相应。退舍禁戒善朋损减

尔时复有诸梵天王诸释天王诸龙王诸夜叉王诸阿修罗王诸鸠槃荼王。皆与眷属合掌向佛而作是言。大德婆伽婆。已有一切如来塔寺及阿兰若处。现在世尊声闻弟子所有住处。及未来世刹利．婆罗门．毗舍．首陀。若在家人若出家人。为于世尊声闻弟子造塔寺处。随有世尊声闻弟子三业相应。及与三种菩提相应。有学无学住于持戒多闻善行。我等悉共守护于彼。令离一切诸难怖畏。诸有世尊声闻弟子所立塔寺及阿兰若处。如有给施饮食衣服卧具汤药一切所须。如是施主我等亦当护持养育。若复世尊声闻弟子。乏少昼夜所须众具贫苦之者。我为彼等作大施主。受其寄付护持养育除诸怖畏。佛时赞言善哉善哉。诸贤首。汝等一切于四天下应当如是。如今汝等受我教敕如说修行。我以汝等及诸眷属付嘱弥勒

尔时世尊。欲重明此义。而说偈言

  天王皆悉起　　敬礼瞿昙仙
  问诸塔寺数　　说佛所依处
  于此四天下　　复有几塔寺
  声闻所依者　　我等共护持
  两足尊微笑　　于此四天下
  化作诸佛现　　无量百千数
  四方神力加　　故现诸化佛
  示佛诸声闻　　所立诸塔寺
  为住三乘道　　是故而建立
  乐三业相应　　如是声闻住
  以诸声闻寺　　付嘱于汝等
  供养彼施主　　亦当护养育
  不令相违恼　　勿使他得便
  莫令有乏少　　退舍于禁戒
  天王及眷属　　禀受佛教敕
  我等悉护彼　　导师所建立
  我等及眷属　　勤护诸塔寺
  已作当作者　　一切勤护持
  知足诸比丘　　住于无积聚
  离欲慈悲心　　我等当守护

    大集经月藏分第十二法灭尽品第二十

尔时月藏菩萨摩诃萨复从座起。整理衣服偏袒右肩。合掌向于十方一切诸来菩萨摩诃萨众。口眼微笑顾视月灯菩萨摩诃萨。而说偈言

  观此希有慈悲士　　释迦大仙尊导师
  今以此法甘露味　　付嘱夜叉令护持
  普告一切作是言　　我之正法汝当护
  一切声闻器非器　　当视如子护养育
  为我剃头着袈裟　　勿令于后有恼害
  休息诸恶俭病疫　　亦息非时风热雨
  如是三种精气增　　正法久住于世间
  众生不堕诸恶道　　速能趣向大涅槃
  我从昔来未见闻　　慈悲希有余土无
  除佛更无余众生　　能令正法久炽然
  诸佛慈悲慧无量　　广持正法令久住
  导师灭后佛正法　　炽然久住事希有
  此土不善烦恼山　　坚固希有最难坏
  转正梵轮法眼住　　悉令住善到涅槃
  此土极恶人与魔　　夜叉修罗鸠槃荼
  彼等究竟灭烦恼　　护持世尊真妙法
  以是因缘得最胜　　能尽所作诸恶业
  彼勤供养于三宝　　是故速能趣涅槃
  断除烦恼牟尼尊　　世间自在大导师
  怜愍一切众生故　　告令护持佛正法

尔时月灯菩萨摩诃萨。闻月藏菩萨说是偈已。复说偈言

  我欲问佛无边慧　　法眼几时住于世
  如此佛月灭度后　　烦恼痴诤闇世间
  云何贤圣复得集　　当作何人方便护
  云何示世安隐道　　能度三趣亿众生

尔时一切诸来大众。向诸菩萨摩诃萨。赞言善哉善哉

尔时月灯菩萨摩诃萨从座而起。偏袒右肩整理衣服。右膝着地合掌向佛头面作礼。以偈问曰

  我今问佛无边慧　　以我今有诸疑网
  以何因缘法眼灭　　云何法灯久炽然
  谁能破坏此法鼓　　谁能枯涸正法河
  云何法眼得久住　　我当于彼助护持
  为以尸罗精进力　　为以羼提禅般若
  为以何力法久住　　唯愿速说何方便
  云何法水得久流　　有多亿数助佛者
  我等精勤坚固行　　为令法海不速竭
  大地精味常增长　　及以众生法精味
  枯涸众生烦恼海　　众生更不趣恶道

尔时佛申金色右臂。而说偈言

  汝等共谛听　　一切有为法
  无常火所烧　　无有少常者
  譬如诸戏人　　作于种种戏
  如是等众生　　皆为烦恼转
  犹如幻芭蕉　　亦如水中月
  三界有为法　　一切皆如是
  诸法我自觉　　道成如先佛
  我今大众会　　天人作证明
  正法付天神　　护持众苦尽
  成于三界尊　　能令法炽盛
  显现八正路　　邪意恶觉灭
  沙门刹利王　　激动相嗔恼
  我今当不久　　涅槃灭无余
  大智诸声闻　　亦随我涅槃
  余方诸佛国　　一切诸菩萨
  具大神通者　　复还向他方
  福德诸国王　　大臣长者灭
  限满百年后　　佛法渐隐没
  薄福众生等　　于我法出家
  不乐于三乘　　亦不畏后世
  活命故出家　　多诈无羞耻
  贪求诸名利　　处处谄嫉妒
  远离于禅诵　　善舍诸善法
  昼则乐言讼　　夜则多睡眠
  乐读外杂典　　舍离佛所说
  复与女人通　　严饰身衣服
  为求名利故　　但营世俗业
  常为他作使　　通致诸信命
  往返俗人家　　贩卖以自活
  乐作诸田业　　又复喜斗诤
  见诸善比丘　　梵行多闻者
  嫉妒复嗔骂　　不容彼坐卧
  而作粗穬语　　诽谤及毁呰
  于诸俗人边　　称扬不善业
  言此诈比丘　　是贼最恶人
  若有供养者　　多得恶名闻
  于彼不获福　　亦莫信彼说
  诸寺恶比丘　　盗说梵行者
  种种不善事　　是以刹利嗔
  彼诸恶比丘　　杂以外文颂
  称赞彼刹利　　能令刹利喜
  毗舍婆罗门　　利喜亦如是
  以是得供养　　持戒被欺陵
  刹利婆罗门　　嫌恨持戒者
  嫌恨持戒故　　致使诸天嗔
  弃舍彼国土　　刹利辅相臣
  向于宝国土　　在彼而安住
  轻贱持戒故　　菩萨亦舍离
  诸天舍离后　　其国大可畏
  恶龙恶夜叉　　罗刹鸠槃荼
  入国夺精气　　及食其肉血
  恶王婆罗门　　毗舍首陀等
  共护国城邑　　及以诸村落
  宫舍国园林　　恶鬼遍充满
  常夺彼精气　　触恼诸刹利
  婆罗毗舍陀　　男女等皆嗔
  复令心变恶　　互共相斗诤
  彼等斗诤故　　布萨行檀绝
  其国水枯涸　　非时风雨起
  饥馑极俭短　　乏少资生具
  果苗不成熟　　地味众生味
  法味及精气　　一切皆损减
  兴动诸兵仗　　互共相劫夺
  如是悭贪国　　恶比丘往返
  复以佛僧物　　饮食诸果药
  持用与俗人　　因此得供养
  奴婢及田宅　　与彼令摄受
  不善比丘等　　以之为尊长
  少智诈多闻　　不喜禅戒者
  禅戒者去后　　为财共斗诤
  刹利闻生嗔　　打害恶比丘
  还俗舍法服　　系闭于牢狱
  以是诸天嗔　　迭共相告语
  如是国土中　　旃陀罗王治
  朋党恶比丘　　毁破袈裟服
  自坏己国土　　不久当败亡
  堕在阿鼻狱　　受苦极长远
  于是贤劫中　　无脱地狱时
  是旃陀罗王　　众圣所厌贱
  听读檀尸法　　谄曲虚诈现
  是王多诈伪　　速灭己国土
  苗稼不成熟　　亢旱及水潦
  鼨鼠恶象暴　　自他国兵起
  曜入非常宿　　大地普震动
  白虹妖星堕　　时气多疫病
  焚烧诸聚落　　速坏国城邑
  剃头着袈裟　　诸佛所加护
  一人出家者　　天人所供养
  唯除诸如来　　无有自在者
  彼旃陀罗王　　讁罚恶比丘
  毁坏三世佛　　二种净法身
  烦恼疮深重　　难得值诸佛
  诸天皆舍离　　彼旃陀罗王
  如是国土坏　　法眼当散灭
  诸天舍离故　　如是国土坏
  三种精气减　　毁灭天宫殿
  白法善朋少　　黑法恶党增
  于彼浊恶世　　无有明智人
  所住阿兰若　　乐法安隐住
  彼持我正法　　能令多众信
  鬼神敬信故　　遮障诸怖畏
  增长三精气　　炽然我正法
  彼以禅定乐　　充满天宫殿
  是故以我法　　付诸鬼神王
  遮障恶刹利　　莫恼我声闻
  国王于持戒　　亲近常供养
  破戒不亲供　　舍离各随住
  国王不恼彼　　持戒及毁禁
  刹利净持戒　　彼此皆信敬
  毗舍婆罗门　　不恼诸天神
  正法得久住　　白法常增长
  汝等于此土　　随意而安住
  汝等若发心　　此土常安住
  乃至我法尽　　莫向诸余国
  以檀尸罗法　　令多众归信
  智者能成熟　　彼非是希有
  于彼恶世时　　炽然我正法
  遮障恶刹利　　此事为希有
  慈心常相应　　莫打我声闻
  彼二说正法　　能救地狱苦
  比丘不护戒　　国王莫讁罚
  汝诸刹利王　　莫共沙门斗
  俗人作诸恶　　速趣于地狱
  软语向彼二　　遮除诸恶业
  莫以粗穬语　　亦莫打治罚
  以是国不坏　　增长三精气
  正法得久住　　佛法久炽然
  多有说法者　　能闭三恶趣
  休息世间恶　　增益诸天众
  涅槃门得开　　无漏者则入
  菩萨得增长　　犹如明分月
  能以于六度　　充满诸佛法
  是故诸智者　　所来诸菩萨
  当住于此土　　炽然我正法
  盲冥失道者　　当与正法眼
  众生以六度　　成熟于菩提
  汝等则成供　　三世诸如来
  速证菩提果　　净国作导师
  大众皆默然　　唯有贤劫众
  弥勒为上首　　一切皆悉起
  合掌而白佛　　咸作如是言
  我不诣余方　　护持佛正法
  尽我精进力　　成熟大菩提
  随于彼时中　　应机而说法
  欲有留难时　　我等不能遮
  法欲灭尽时　　我亦不能遮

尔时世尊。告彼白智童真菩萨摩诃萨。而说偈言

  观此诸菩萨　　勇猛执智炬
  无量阿僧祇　　他方佛土来
  种种善根宝　　归依诸佛海
  慈悲方便力　　于佛法不动
  于此无有一　　能持我法者
  贤劫诸菩萨　　堪能持我法
  于我灭度后　　佛法欲灭时
  所有出家者　　而无有惭耻
  远离功德智　　懈怠不精进
  舍道学世业　　不乐持禁戒
  愚痴与俗交　　多言复无羞
  贪取佛僧物　　染着五欲乐
  如是比丘等　　资生与俗同
  疑惑多贪财　　邪淫怒嫉妒
  见住兰若者　　说其诸过恶
  不乐读诵经　　嗜睡多喜斗
  如是等沙门　　厌贱禅兰若
  坚着于恶事　　自高轻蔑他
  沙门及俗人　　悭贪不舍施
  啖食佛僧物　　多遭种种病
  无有慈愍心　　少力恶喜斗
  以是天不雨　　润泽悉枯涸
  饥馑遍世间　　果实无滋味
  乏少于饮食　　嗔诤相侵夺
  造十不善业　　少福无供养
  法味不纯厚　　行法心亦薄
  迭共作粗想　　杀害无慈愍
  不孝于父母　　亦不供尊长
  多修世俗行　　疑惑复嫉妒
  贪染于邪法　　非法无厌足
  贪求无厌故　　是以久流转
  如是诸国王　　及以辅相臣
  沙门婆罗门　　毗舍首陀罗
  乐斗憎持戒　　互共相谤毁
  南方边夷国　　王名波罗帝
  百千诸军众　　士将共围绕
  西方边夷国　　有王名百祀
  亦将百千军　　前后共围绕
  北方边夷王　　名善意释迦
  士将诸营从　　围绕亦百千
  东方睒弥国　　王名为大军
  眷属百千众　　围绕而侍卫
  大军王有子　　名之为难看
  生时身着铠　　把刀血涂身
  大力身坚固　　而从母胎生
  是时长者等　　大臣五百人
  同时俱生子　　身亦着铠甲
  执刀血涂身　　皆从母胎生
  是日于其国　　天龙降血雨
  五百长者子　　难看同处养
  难看年七岁　　父王授其位
  边夷三恶王　　又至北天竺
  破国杀害人　　怨仇妒女色
  积财以火烧　　嗔怒向中国
  边夷王等来　　毁破佛塔寺
  杀害诸众僧　　劫夺佛僧物
  病瘦诸比丘　　不能走逃避
  少壮强力者　　散走于诸方
  诸余比丘等　　少年初出家
  未善学戒者　　威仪法不具
  处处走逃避　　随至被欺陵
  毁辱而打骂　　恒受诸苦恼
  彼三边夷王　　及与诸军众
  渐诣拘睒弥　　十二年中斗
  三王及眷属　　难看王杀尽
  统领阎浮提　　而作一盖王
  于后大悔恨　　我获无量罪
  颇有明比丘　　当于我忏悔
  说言有三藏　　父名为火施
  种姓常清净　　是大婆罗门
  子名失师迦　　高才智勇博
  释子中大名　　今住波梨国
  时王即遣使　　请彼三藏来
  为王演正法　　令王生敬信
  我于十二年　　战斗大作罪
  三王及眷属　　军众我杀尽
  我亦十二年　　具设般遮会
  普告阎浮提　　释子皆来集
  所有诸比丘　　住在阎浮提
  愿各悉来此　　受我等供养
  比丘等悉集　　睒弥般遮会
  在路有饿死　　或病在道傍
  中有遭水毒　　或值贼虎伤
  或复坠山涧　　比丘死无数
  余残到睒弥　　威仪法则坏
  百千皆来集　　设大般遮会
  初起般遮日　　大云皆悉起
  普遍阎浮提　　降澍于大雨
  时王甚欢喜　　此是众僧力
  比丘既集已　　互共相借问
  颇见我和上　　及问阿阇梨
  知识诸等侣　　同学何处去
  我今得来此　　彼或道路亡
  高声大悲哭　　相恋而嗥啼
  失师三藏起　　少时静默住
  比丘大嗥哭　　惆怅不自抑
  王见彼嗥哭　　晓谕亦不止
  时王自思惟　　此有罗汉不
  天神夜告王　　还于波梨弗
  善财长者子　　名曰涷罗多
  是大阿罗汉　　恒在香山中
  三明解脱具　　而来安住此
  今于此大月　　十五日布萨
  由此布萨故　　百千众集会
  中有一三藏　　复有阿罗汉
  于时诸天众　　皆来听布萨
  今是最后集　　当作无上护
  法幢当摧折　　法炬当散灭
  法山欲崩颓　　法海当枯涸
  八种功德水　　最后当亦竭
  比丘众声乱　　三藏于时起
  高声言寂静　　谛听戒律仪
  所有诸释子　　一切皆来集
  我于此众中　　多闻到彼岸
  学戒犹不净　　何况于余人
  若有一比丘　　能持此禁戒
  威仪无缺者　　今当为布萨
  若于毗尼戒　　威仪无缺犯
  于此大众前　　有者今当现
  为学戒律者　　今当作布萨
  罗汉涷罗多　　即起师子吼
  依如经中说　　我学戒清净
  决定无有疑　　布萨我当听
  如佛之所说　　禁戒我善学
  三藏有弟子　　名曰鸯伽多
  懆恶即嗔骂　　咄彼涷罗多
  经中未见汝　　是学戒律者
  大德如是说　　云何故违反
  鸯伽嗔极盛　　两手执大棒
  打杀阿罗汉　　净戒可敬者
  诸善比丘等　　大哭而嗥啼
  各各相嗔怒　　毁破身衣服
  时有大夜叉　　名目佉檀提
  于佛深生信　　敬重佛正法
  即以金刚杵　　杀害彼鸯伽
  由杀阿罗汉　　无著涷罗多
  复有恶比丘　　名曰鸡多罗
  两手亦执棒　　复杀彼三藏
  比丘皆悉起　　各各共相杀
  百千诸比丘　　存活者无几
  是时须臾顷　　大地普震动
  于其虚空中　　出大恶音声
  四方起大恶　　火爨数百千
  火幢大可畏　　现住在空中
  彗星及妖星　　四方而流堕
  千亿诸天神　　皆作如是言
  释迦所集法　　今日当隐没
  色界诸天子　　一切欲界天
  正法隐没已　　大声悲嗥哭
  见佛诸夜叉　　堕地而宛转
  从今于世间　　更无有佛法
  律仪木叉戒　　一切悉空无
  闇冥遍世间　　无救无归趣
  诸人等不久　　无异于獐鹿
  法幢当摧折　　法鼓声亦绝
  甘露门闭塞　　法师亦丧亡
  法炬当散灭　　法轮更不转
  正法桥破坏　　法足不复行
  法水止不流　　法河永枯涸
  法山欲崩颓　　法海当复竭
  住林阿兰若　　所有诸天子
  于时大怖畏　　悲嗥而自扑
  有诸魔眷属　　邪见诸恶党
  歌舞皆欢喜　　踊跃弄衣服
  释迦所说法　　趣彼甘露者
  隐没是其宜　　我法得炽盛
  难看王既知　　正法隐没已
  从初至后夜　　出城往诣彼
  见诸比丘尸　　堕地即闷绝
  良久乃得稣　　而复更悲啼
  见杀阿罗汉　　三藏失师迦
  无量比丘死　　我亦不久活
  收拾阿罗汉　　别取三藏尸
  及诸比丘丧　　种种而阇维
  余残在比丘　　召唤集一处
  肴馔众美味　　种种而供养
  复舍千万宝　　一宝直百千
  以此众宝物　　拟造五百寺
  一一诸比丘　　各施百千物
  师等在此住　　我等当养育
  为我说正法　　我当至心听
  一切皆默然　　无有说法者
  其王三劝请　　白诸比丘已
  亦皆默然住　　一切无说者
  王白诸比丘　　可不知法耶
  语已袈裟白　　染色不复现
  从床皆堕落　　宛转在于地
  咸皆称佛言　　佛法宝隐没
  须发爪皆长　　诸法亦忘失
  当时虚空中　　大声震于地
  一切皆遍动　　犹如水上轮
  城壁碎落下　　屋宇悉圯坼
  树林根枝叶　　花叶果药尽
  唯除净居天　　欲界一切处
  七味三精气　　损减无有余
  解脱诸善论　　当时一切尽
  所生花果味　　希少亦不美
  诸有井泉池　　一切尽枯涸
  土地悉碱卤　　剖裂成丘涧
  诸山皆焦然　　天龙不降雨
  苗稼皆枯死　　甘蔗劫贝药
  生者皆死尽　　余草更不生
  雨土皆昏闇　　日月不现明
  四方皆亢旱　　数现诸恶瑞
  十不善业道　　贪嗔痴倍增
  众生于父母　　视之如獐鹿
  众生及寿命　　色力威乐减
  远离人天乐　　皆悉堕恶道
  如是不善业　　恶王恶比丘
  毁坏我正法　　损减天人道
  诸天善神王　　悲愍众生者
  弃此浊恶国　　皆悉向余方
  先佛不作者　　我今为众生
  弃舍身寿命　　为增三精气
  悲愍众生故　　舍寿第三分
  令我法海满　　洗浴诸天人
  过去诸如来　　依寿而灭度
  彼于七日后　　正法皆隐没
  今我涅槃后　　正法五百年
  住在于世间　　众生烦恼尽
  精进诸菩萨　　得满于六度
  行者速能入　　无漏安隐城
  像法住于世　　限满一千年
  剃头着袈裟　　持戒及毁禁
  天人所供养　　常令无所乏
  如是供养彼　　则为供养我
  若有为我法　　归依而剃头
  身着袈裟衣　　说彼是我子
  假使破禁戒　　悉住不退地
  若有挝打彼　　则为打我身
  若有骂辱彼　　则为毁辱我
  是人心欲灭　　正法大明灯
  故为器非器　　舍寿第三分
  为众得安乐　　饶益诸天人
  我昔行苦行　　为诸众生故
  舍已自身乐　　令法久炽然
  我昔舍身命　　为诸病人故
  亦为贫众生　　令法久炽然
  我昔为菩提　　舍财及妻子
  宝象马车乘　　令法久炽然
  我昔供诸佛　　缘觉及声闻
  父母诸师长　　令法久炽然
  为闻菩提故　　无量阿僧祇
  备受种种苦　　令法久炽然
  我修戒律仪　　长夜常勤行
  十方佛为证　　令法久炽然
  我昔常忍辱　　忍诸恶众生
  为众除烦恼　　令法久炽然
  我昔勤精进　　坚固常伏他
  度脱诸众生　　令法久炽然
  我修禅解脱　　无色三摩提
  恒沙不可数　　令法久炽然
  我昔为般若　　住在于闲林
  演说无量论　　令法久炽然
  我昔常怜愍　　舍已身血肉
  及舍身支节　　为增长法眼
  我愍恶众生　　以慈而成熟
  安置于三乘　　增长正法施
  我昔智方便　　度脱诸恶见
  安置于正慧　　法雨令不绝
  我昔以四摄　　救度诸众生
  灭恶烦恼火　　令四众久住
  我昔除外道　　诸恶邪见网
  安置于正路　　四众得供养
  我为彼舍命　　慈愍度众生
  不令世间闇　　而有所归趣
  如是于后时　　欲令法不坏
  是故嘱法眼　　饶益诸众生
  于我灭度后　　菩萨向余方
  为欲不灭坏　　一切贤圣法
  故我今说咒　　令法久炽然
  金刚密无缺　　解脱味所依
  所有十方佛　　当与我说欲
  在此所来者　　大众亦与欲

尔时世尊。为令正法得久住故。说大陀罗尼咒

哆地夜他　阿婆牟寄　婆牟寄　质阇牟寄　佉罗牟寄　遮罗摩兮　阿兮　阿兮　达啰婆帝　摩呵地唎滞　悉耽婆罗兮　阇迦利　磨什婆隶　达啰牟驶　能伽咩什婆隶　什婆啰摩涅婆波　苏婆呵

尔时世尊。说此金刚坚固深密解脱味体陀罗尼句时。遍此三千大千世界六种震动。天降花雨。一切乐器不鼓自鸣。诸来大众遍满大地。皆悉悲泣流泪赞叹。而作是言。释迦牟尼如来应正遍知甚为奇特。未曾有法大悲具足。随彼众生为成熟故。安置显现未来法故舍第三分寿。说是语时。在会众生依烦恼身者心得敬信。尽虚空量诸众生等未发无上菩提心者皆悉发心。九十二那由他众生得柔顺忍。八那由他众生得首楞严三昧圣灯三昧。十万诸夜叉见四真谛。二千菩萨得共行测量毗尼三昧。六十四百千阿修罗得殊胜行那罗延三昧。八那由他百千诸天得清净行三昧。三十那由他百千鸠槃茶得胜幢上灯三昧。二十那由他百千诸龙得不欺陵力行三昧。二万比丘尽诸有漏心得解脱

尔时智炬童真菩萨摩诃萨。白文殊师利菩萨摩诃萨言。了知清净士。观此释迦牟尼如来。以大名称充满十方诸佛国土。云何充满。谓释迦牟尼佛从初发心求阿耨多罗三藐三菩提已来。于一切众生平等安置。以福田心种种勤修而行布施。于一切菩萨道修最胜行。成熟一切诸众生故发最胜愿。舍清净国至此五浊众苦世界。于阿耨多罗三藐三菩提而成正觉。以大慈悲因缘力故。为无间业诽谤正法毁呰贤圣一切不善恶业缠缚。十方一切清净佛土所弃众生为诸烦恼之所缚者。成熟如是诸众生故。于此娑婆世界求阿耨多罗三藐三菩提。于一切菩萨道修最胜行。是人今于五浊世界。于阿耨多罗三藐三菩提而成正觉。此无间业诸众生等。种种骂辱诽谤如来。轻贱毁呰勤加逼恼。彼等以嫉妒因缘故。种种方便心欲杀害。复以种种兵仗刀箭[矛*(替-曰+貝)]鉾钺爷崩大石山毒药水火。复放狂象师子虎豹恶牛恶狗勤加害佛。尔时如来犹于彼等诸众生所。以大慈悲哀怜覆护。踰于父母视其一子。于诸苦海方便拔济。是以今佛释迦如来。于十方佛土名称普闻。今复为此诸众生故。以一切法付嘱天龙诸鬼神等。为令法眼久住炽然。复为众生舍第三分寿。亦为法眼久住炽然。一切声闻器以非器。及诸剃头着袈裟者。为护持故。不恼害故。增长三精气故。以是释迦如来于此十方一切佛土一切如来一切菩萨摩诃萨一切大智诸天人所。极得名称充满十方。是故一切诸来菩萨摩诃萨等。各各相与随力所堪。皆设第一最上供具。供养如来尊重恭敬

尔时一切诸来大众菩萨摩诃萨等。从座而起口眼微笑。彼诸菩萨于此娑婆世界。遍雨种种宝供养具供养世尊。有雨碎金。有雨碎银。有雨碎毗琉璃。有雨碎颇梨。有雨赤真珠。有雨碎马瑙。有雨碎车磲。有雨龙蛇。所爱重者碎栴檀香。有雨牛头栴檀香。有雨多摩罗跋香。有雨黑坚沉水香。有雨种种众妙宝花。有雨七宝盖七宝幢七宝幡金缕真珠璎珞环钏。有持劫波如意宝树。有持宝衣树。有持宝花树。有持宝器树。有持宝香树。供养世尊。复有菩萨于娑婆土所有树林花叶果实一切草木。变成七宝而供养佛。复有菩萨。于娑婆土一切所有山石塼瓦。变成七宝而供养佛。复有菩萨。于娑婆土一切所有大地界分。变为微妙诸天宝香而供养佛。一切众生依地住者。彼等七日七夜身心快乐犹若诸天。复有菩萨于娑婆土一切所有大水界分。变为诸天第一微妙甘露美味香洁醇具水界。众生七日七夜身心快乐犹若诸天。复有菩萨以一切风变为微妙清净香风而供养佛。于三恶道所有众生。一切无余香风触故。七日七夜身心快乐犹若诸天。尔时上至阿迦腻吒天。下至四天王身天及诸天女一切无余。而以种种微妙音声赞叹世尊。复以种种歌舞音乐而供养佛。一切夜叉。一切罗刹。一切鸠槃茶。一切乾闼婆。一切阿修罗。一切紧那罗饿鬼毗舍遮富单那迦吒富单那人非人等。彼等一切随力所堪作种种赞叹。乃至种种供养世尊

尔时世尊告上首弥勒及贤劫中一切菩萨摩诃萨言。诸善男子。我昔行菩萨道时。曾于过去诸佛如来作是供养。以此善根与我作于三菩提因。我今怜愍诸众生故。以此报果分作三分。留一分自受。第二分者。于我灭后与禅解脱三昧坚固相应声闻令无所乏。第三分者。与彼破戒读诵经典相应声闻正法像法剃头着袈裟者令无所乏。弥勒。我今复以三业相应诸声闻众比丘比丘尼优婆塞优婆夷。寄付汝手勿令乏少孤独而终。及以正法像法毁破禁戒着袈裟者。寄付汝手勿令彼等于诸资具乏少而终。亦勿令有旃陀罗王共相恼害身心受苦。我今复以彼诸施主寄付汝手。我今所有器以非器为我出家而供养者。汝等亦当护持养育。弥勒。若于现在及未来世。读诵受持此法门者彼等当得十种清净功德。何等为十。身清净故离杀生离偷盗离邪行。口清净故不妄语不恶口不两舌不绮语。心清净故离贪欲离嗔恚离邪见。是为十。从是已后百千万生常得如是十种精净功德。若有至心听此法门者。是人住如实际得于八种清净功德。何等为八。一者长寿。二者端正。三者富贵。四者名称。五者常为诸天守护。六者所须常无所乏。七者尽诸业障。八者命欲终时有十方佛及诸大众。放大光明照其眼目。令其人见得生善处。于百千万生。常得如是八种功德。我今更复略说。是人当得十三种清净功德。何谓十三。一者生死流转。终不更起颠倒恶见。二者不生五浊无佛国土。三者常得见佛。四者常闻正法。五者常得供养众僧。六者值善知识。七者常与六波罗蜜相应。八者不堕小乘。九者常以大慈大悲大方便力成熟众生。十者常发胜愿。十一者乃至菩提而常不离如上等法。十二者速能满足六波罗蜜。十三者于阿耨多罗三藐三菩提而成正觉。若有受持书写读诵为他解说如说修行此月藏法门者。所得功德如前所说。作是语时。月藏菩萨摩诃萨。尊者阿若憍陈如。及于一切诸来大众。天人阿修罗乾闼婆等。一切众生闻佛所说。皆悉欢喜顶戴奉行

大集经卷第五十六大方等大集经卷第五十七

        高齐天竺三藏那连提耶舍译

    须弥藏分第十五声闻品第一

南无十方一切诸佛

如是我闻。一时婆伽婆。在佉罗帝山。依牟尼仙住处。与大声闻众过出众数。一切皆是佛大弟子。与大菩萨众无量无边。悉从十方诸佛世界而来集会。次第究竟梵翼记分

尔时众中去佛不远有功德天住于佛前。为听法故即从座起。合掌向佛而白佛言。大德婆伽婆。有诸菩萨以施福船[舟*發]渡生死海。何以故。此佛世界五浊极秽。多有众生功德智慧悉皆减少。以是因缘故。菩萨摩诃萨于此众生起大悲心。又此众生说无因论。资财乏短。勤苦追求而不能得。此诸菩萨若不行施。不能化彼罪恶众生。是故诸菩萨作如是念。我今被檀度铠起大精进。泛施船[舟*發]越生死海。是诸菩萨摩诃萨。修行布施福德之事。令入诸佛无上大海。乃至获得最上灌顶法王之位。世尊。复有众生计存常见广乏资财。苦身求索亦不能得。菩萨若不修行戒施。则不成熟彼诸众生。是故菩萨摩诃萨于计常众生起大悲心。复作是念。我当化彼计常众生。我以如是持戒铠[舟*發]。欲度生死大海。乃至得受灌顶法王之位。是诸菩萨以持戒福事行及十善道。成熟众生令入无上诸佛大海。乃至安置灌顶法王之位。世尊。此复有众生行十善道而不清净。于杀盗淫乃至贪嗔等。身见众生福德智慧减少故赀财乏短。勤苦追求亦不能得。彼诸众生若不以出家清净戒。无以成熟。是故菩萨摩诃萨。于彼杀盗淫妄语两舌恶口绮语贪嗔等身见恶行众生所。起大悲心。以无常方便。令诸众生入佛法中。以出家戒成熟众生。此即是我忍进钾胄。是出家戒。即为船[舟*發]渡生死海。以是缘故。菩萨摩诃萨以持戒福德及无常方便。教化成熟出家律仪戒众生。彼菩萨以是业故。乃至令入无上诸佛大海。乃至安置灌顶法王之位。菩萨摩诃萨便自能入无上诸佛大海。尔时功德天白佛言。大德婆伽婆。云何菩萨摩诃萨。最初修学禅波罗蜜本业。学已知诸禅分。能出欲界断除五支成就五支。于四神足游戏神通。善能往诣一切佛刹迅疾如电。于一切佛所供养听法。为竭众生三种道故。何等为三。谓业道烦恼道苦道。满足禅波罗蜜。云何满足禅波罗蜜。具足六波罗蜜。满足六波罗蜜已。速得阿耨多罗三藐三菩提。佛言善哉善哉。清净智。汝清净智。于此法中以为疲劳满此法行。为众生故。能于如来应正遍知所。问于此义。汝清净智。当至心听善思念之。我今为汝分别演说。功德天言。如是世尊。我当听受唯愿说之。于是世尊。告功德天言。清净智。如汝所问。云何菩萨摩诃萨最初修学禅波罗蜜本业。学已智于禅分。能过欲界除断五支成就五支。于四神足游戏神通。善能往诣一切佛刹迅疾如电。于一切佛所供养听法。为竭众生三种道故。何等为三。谓业道烦恼道苦道。能生修道所作福事。满足禅波罗蜜。禅波罗蜜满足故。具足六波罗蜜。满足六波罗蜜已。速得阿耨多罗三藐三菩提。清净智。此菩萨摩诃萨初修禅定。于一切出入息相系心缘念。彼菩萨摩诃萨以不乱心出息入息。随入息触心。彼入息触心者名为觉。随出息触心。随出息触心者名为观。乃至喜乐一心不乱心。将出欲界离于觉观。断除贪欲及嗔恚盖。伏一切恶法。得于初禅有觉有观。彼时即有如是相起。一切身分悉皆震动充遍于身。若菩萨增上勇猛。系念专住彼时。便能灭于觉观。喜乐一心得第二禅。为除喜过精勤不止。既灭喜已得第三禅乐。菩萨尔时其身适乐。犹如暖乳以灌身体。得希有乐如天身想。彼得成就如是胜乐。于三宝中得增上信心。复作是念。我为利益一切众生。被服大铠勤修禅定。我今应舍身乐。彼菩萨摩诃萨止出入息。舍相续攀缘心。系意鼻端。于出入息住心观察。又观彼心刹那散坏。知生知灭。又知彼心刹那相应散坏无生。如水中月如光影如阳焰如电。心意识一切阴界入如泡。是故弃舍身乐。思念彼法生灭。入第四禅。尔时即有如是相起。菩萨虽复闭目如大日光照见明了。彼菩萨作是念。以此攀缘光明相故。一切众生阴界入不断增长炽然。我今应当心念止于攀缘光明。彼复于此以灭方便舍受想思触忆集生灭。入胜清净善寂灭城。住止身口意业。彼菩萨还从定起。取出入息相。观触念相还入空定。从空定起。复观出入息生灭攀缘相。便入无愿三昧。从无愿三昧起。见出入息寂灭。住无相定。如是则能修满四念处及三解脱门。彼菩萨以观出入息生灭。观于生灭故修四正勤满足。彼菩萨以观出入息出没相。便能具修满四神足。彼观出入息故。即能散坏其身犹如窗尘。尔时即得修满五根。以出入息出没方便。观察三行。如是便能修满五力。彼以除出入息受想方便。观察除寂灭。如是修七菩提分满足。彼以出入息风方便念散坏。一切大地界。及一切色悉皆无余。彼无有相无有语言。无有状貌无有假名。三行寂静极寂静寂灭。得无缘三昧。此如是名游戏禅定禅波罗蜜本业。诸菩萨摩诃萨。共一切声闻辟支佛禅本业。若住于此以下精进。或证须陀洹果或斯陀含果阿那含果。或乃至住阿罗汉果。若菩萨坚固精进大悲心。顾念一切众生。无量福德智慧聚为之疲劳。彼菩萨摩诃萨于如是禅本业。游戏三昧方便安住。不退阿耨多罗三藐三菩提。不堕声闻决定聚中。不舍禅定本业大铠。彼菩萨摩诃萨满足禅波罗蜜。满足禅波罗蜜已。便能满足六波罗蜜。清净智。乃至若国土中或比丘比丘尼优婆塞优婆夷。欲趣声闻乘。欲趣缘觉乘。或趣大乘。或善男子善女人。于如是禅本业游戏三昧系念思惟者。随所住处。彼国土一切天王常善守护。一切龙王。一切夜叉王。一切阿修罗王。一切紧那罗王。一切摩睺罗伽王。一切饿鬼王。一切毗舍阇王。一切罗刹王等。当善护彼国。若国土中有如是禅相应福田住者。彼国土彼刹利王。得十种可爱乐法。何等为十。一者安隐灭一切患。二者长命。三者得上妙色。四者皮肤鲜软。五者支节可爱。六者得善眷属。七者能修善业。八者系念慈悲方便。九者恒与名称福器相应。十者命终生于天上。是为十。又彼国土复得成就十种殊胜利益。何等为十。一者不为自贼他贼之所劫害。二者亦无恶贼毒兽蚊虻蝗虫等。三者无有旱潦及非时风雨寒热等触。四者土地平正无诸丘墟溪涧崄圹。五者彼国一切种子五谷诸药草木林树蓊蔚茂盛。无诸辛苦涩恶等味华果。六者无诸恶声斗诤反逆饥俭病患及非时死。七者彼国众生长命端正。适乐丰盈无秽浊心。游戏快乐如法修行生于天上。八者其国土中诸福田器之所依住。爱乐随顺禅定三昧。九者彼国众生饮食所须悉皆无乏。上妙可爱资成四大。称顺根性增长无违。十者其土人民勇健强记有慈悲心命终生天。清净智。此十种法善能庄严于彼国土。清净智。此菩萨摩诃萨以业障碍舍离大乘。住声闻地违化众生。此是声闻禅波罗蜜游戏三昧。声闻以此了知满足禅分。出三界窟宅及诸有缚。断除五支成就五支。越过三界住无学地游戏神通到八解脱。禅定彼岸一劫修行。得为一切诸佛之子。从佛口生从法化生。彼虽如是。犹故不能往诸佛土供养诸佛从佛听法。亦复不能干竭众生三种道。若能如是游戏三昧者。随其所住国土。获得如上大功德利

    大集经须弥藏分第十五菩萨禅本业品第二

尔时佛告功德天言清净智。云何菩萨摩诃萨不共一切声闻辟支佛禅波罗蜜本业差别满足。若菩萨摩诃萨满足禅波罗蜜已。便能满足余五波罗蜜。清净智。此菩萨摩诃萨于一切出入息中及五受阴。观其生灭。既观察已消竭渴爱。不堕声闻决定聚中。于四神足游戏神通。善能往诣一切佛刹迅疾如电。于诸佛所供养听法。干竭一切众生三道。谓烦恼道业道苦道。虽出欲界而不舍欲界。为化众生故现生诸趣。不为胎染。断除众生烦恼罗网。然于众生而无所得。清净智。此菩萨摩诃萨随出入息各各别观。但新非故如实了知。如是出入息中色受阴如实了知。受想行阴亦如实了知。如是出入息中识受阴如实了知。于出息异入息异。知出息异知入息异。知入息异中受想思触念。知出息异中受想思触念亦如是。入息受时非出息受。出息受时非入息受。如是三有轮转受想思触念因缘故相续不断。漂生死海而不能渡。数数生老死已还生。不能如实觉知此法。不能如实出彼生死。于出入息不能如实觉察。复次如是出入息。于九疮门出入往来。如是九十九那由他百千毛孔门。一切皆悉息出息入。而于九十九那由他百千毛孔不增不减。不能觉知非过去非未来非初非中非后。不知住不知出。复作是念。我今一切毛孔出息入息生灭方便。应与生灭相相应住。是菩萨摩诃萨随九疮门出息入息生灭。观察如是。九十九那由他百千毛孔门。一一毛孔中观察出入息生灭。观察出入息生灭相应住。若菩萨欲观毛孔小相但见毛端息从往来。即能见小。若欲见大。便能得见如芥子许。若欲得见如庵摩勒果许。即能得见。若欲得见频螺果许。亦即能见。若欲得见一由旬千由旬乃至一四天下。一一毛孔而观察之。随欲见广即能见广。彼时菩萨作如是念。众生以眼迷惑。系缚生死相续不断。漂生死流受种种苦。彼菩萨复作是念。我今弃舍一切色想。已得无言三昧。非诸声闻辟支佛地。于彼地界亦无所得。水界火界风界虚空界识界亦无所得。不行阴界入。非前际非后际。非此世非他世。非善业报非恶业报。非生非灭。非有烦恼非离烦恼。无有所得。菩萨如是住寂灭住。彼若欲得于无量劫于此一切法无语言空三昧。若住若加。菩萨如是自智加持三昧力故。便能于此一切法无语言空三昧。无量劫住。亦能满足六波罗蜜。为成就众生因缘故。清净智。如是地藏菩萨摩诃萨于此一切法无语言空三昧。到自在彼岸。是菩萨若欲入此三昧时。以福德智慧力。为成熟众生故。先作是愿。乃至我未出三昧已来。于此时中欲令此国土境界及四天下。此佛世界一切众生诸有所须资生之具。随其相貌随其多少随其所乐。所谓饮食衣服卧具璎珞庄严之具。园林屋宅形色状貌胑节身分。可爱色声香味触等。欲见如是等事。是时菩萨便入此三昧。菩萨入此三昧已。随其时节。于此佛世界四天下一切众生。如上所说所须之具便得充足。或复作是念。随我住定时节远近。随诸众生多少分齐。欲除众生身心之病。谓风黄癊等分之病。或人非人所作。如是欲灭贪嗔痴等烦恼诸病。及灭十不善业。令住十善业道中。便即入此三昧。彼菩萨摩诃萨随其住定时节久近。随其所为多少众生。如上所说身心病苦悉皆除灭。又菩萨复作是愿。随我住定时节已来。欲灭地狱种种诸苦。畜生之中互相残食等苦。阎魔罗界饥渴等苦。及寒热苦。怨憎会苦。爱别离苦。求不得苦。随愿分齐。令诸众生离一切苦恼及不善法。成就一切善法。令诸众生慈心相向。生利益心。不动心。无怨心。无诤心。无斗讼心。哀愍心。乃至禅正受善住心。不迷惑心。及灭众生愚惑之心。又灭众生常见断见及诸见聚。于三宝所恭敬供养生希有心。令诸众生离四颠倒住四不颠倒。于四圣谛及第一义谛。心善安住。如是菩萨福德智慧善巧方便力之所加持。菩萨尔时为化众生因缘故欲入三昧。乃至未出三昧已来。令此国土及阎浮提四天下。乃至此一佛刹所有众生。随其分齐安乐之事。如上所说欲令获得。然后入于无语言一切法空三昧。彼菩萨摩诃萨入此三昧时间乃至佛刹。随所要期众生分齐。彼菩萨以福德智慧三昧力故。随住定时。如上所说种种资生及诸乐具。乃至未出定来。令诸众生悉皆获得。彼菩萨入此定时。无有身苦心苦亦无饥渴。火不能烧水不能漂。乃至劫火所不能害。及以劫水亦不能烂。不为风灾之所散坏。又复不为疫病饥馑刀兵等劫尽其命根。欲取灭度随意自在。又人非人毒风暴热不能侵恼。又彼菩萨在定未起随其所念。欲令无量佛刹入一微尘。又复十方国土一切诸佛及大菩萨声闻眷属。于一爪甲悉能得见令无遗余。又令一切众生入一毛孔。而彼众生于自境界悉见如故。又十方世界无量佛刹所有诸风。菩萨悉令入一毛端。随风境界游行虚空。广狭去来无诸障碍。于彼毛端亦无增减如本不异。又十方一切诸佛世界所有水界。菩萨能令入一豆[禾*會]。随水广狭流注往来亦无障碍。于彼豆[禾*會]而无增减。又彼菩萨不复处胎。除自愿力。不生恶趣。不受女形。不生下劣。诸根具足终不缺减。身口意行无有过失。亦不生于无佛世界。除自愿力为化众生。是菩萨常不远离见佛闻法供侍众僧。亦不远离福德智慧无畏方便教化众生。乃至入于无上涅槃。如是清净智。彼菩萨摩诃萨被于如是大坚固铠。最初修习禅波罗蜜本业。能过欲界了知禅分。断除五支成就五支。乃至游戏于四神足。善能往诣一切佛刹迅疾如电。供养一切诸佛听闻正法。干竭众生所有三道。所谓烦恼道业道苦道。如是清净智。菩萨摩诃萨满足禅波罗蜜已。便能满足六波罗蜜。满足六波罗蜜已。速得阿耨多罗三藐三菩提。尔时世尊说是禅波罗蜜本业时。于彼众中。五万众生曾于过去修行此法。是故今得无生法忍。八万四千菩萨得首楞严三昧。九万九千菩萨得满足禅波罗蜜。无量无边众生发未曾发无上菩提心。发是心已住不退转地

    大集经须弥藏分第十五灭非时风雨品第三

于时地藏菩萨摩诃萨告功德天言。清净智。汝今当观此四天下端严殊妙。一切菩萨所应供养忆念守护。于其长夜应当恭敬。今释迦牟尼佛集一切菩萨摩诃萨故。显示一切菩提道行不退转轮。究竟善巧方便佛灌顶地。乃至汝行檀波罗蜜。满足最上不退转行。若汝于如是最上福田。以诸饮食而修供养。以此精勤速能满足六波罗蜜。满足六波罗蜜已。则能究竟安住一切种智。时功德天作如是言。如是如是。如仁者所说。唯愿听我说本因缘。我念往昔过无量劫。我共释迦牟尼佛修菩萨行同发誓愿。汝若能得成无上道时。愿我于彼四天下中到功德处。得功德处已。于一切众生中。随其所须衣食之具悉皆给与。仁者善听。于过去世过无量劫。彼时有佛。号因陀罗幢相王如来．应供．正遍知．明行足．善逝．世间解．无上士．调御丈夫．天人师．佛．世尊。出现于世。人寿千岁。彼时有优婆塞名光无垢德。聪慧调柔多闻无畏。为四众说法。众所归伏多有眷属。彼有长子名无垢德。即以偈颂问其父曰

  父今何故　　勤心不下　　舍其事业
  及自身命　　为护众生　　勇猛增勤
  何故此身　　不取灭度

尔时光无垢德。复以偈颂而报子言

  吾见世苦　　极迷众生　　生老病死
  之所逼迫　　烦恼火炽　　沈流恶道
  故我勇猛　　欲灭彼火　　又智减少
  不见未来　　堕生死河　　极重恶处
  对于恶道　　迷失正路　　为救度彼
  故我修行　　又不能成　　布施调摄
  而常远离　　人天安乐　　于善知识
  常相乖背　　愿示众生　　出世要路
  烦恼狱中　　常系众生　　无有眼目
  复无救者　　执着恶见　　啖食血肉
  为除彼故　　故我修行　　我于众生
  如是悲念　　为一一人　　住阿鼻狱
  具受种种　　尤剧苦恼　　如为一人
  众多亦然　　我不乐求　　声闻智慧
  及缘觉智　　亦不愿求　　唯求无上
  最胜智慧　　子今当知　　我行胜道
  乃至无量　　恒河沙数　　苦恼众生
  未脱苦来　　为欲度彼　　诸众生故
  我终不取　　菩提正觉　　汝今当知
  亦应如是　　于诸众生　　常应起悲
  应常勇猛　　修行善法　　以此回向
  无上圣道　　烦恼火中　　救脱众生
  汝应勇猛　　何极苦恼　　应当修行
  布施调柔　　得成佛道　　无有疑也
  若我得成　　无上菩提　　汝于众生
  给施饮食　　我时授汝　　胜菩提记
  汝当安住　　坚固誓愿

尔时功德天语地藏菩萨摩诃萨言。善男子。我于尔时于因陀罗幢相王佛所。作如是愿。乃至我住世间随其久近。种种精勤难行苦行。布施调伏。禁摄放逸。及诸禅定。营助众事多闻舍行。皆悉修习。所有种种难舍能舍。如是我父。于当来世人寿百岁烦恼怨诤秽浊迷惑恶世界中。成阿耨多罗三藐三菩提。我于彼国中现为功德主。于释迦牟尼佛境界众生及其眷属。得施无上衣服饮食资身之具。即于释迦牟尼佛前。得受阿耨多罗三藐三菩提记。若彼土众生暴恶粗犷无慈愍心。亦无反复恶行恶心。成就如是种种诸恶。风雨不时或复旱潦。寒热不调作诸灾变。众生所有诸华果实。五谷药草及诸美味。悉皆殄灭夺其精气。众生资产皆悉衰耗而作闇冥。愿我尔时于彼众生福德加被。智慧威力。悉令遮止生其信心。又令众生资生不乏。不令行恶。增长善法。佛所应度受化众生。绍三宝性使不断绝。势力增盛又令我得依报自在。教化众生令得阿耨多罗三藐三菩提。于今佛前所发誓愿。于未来世得满足者。唯愿印可赐言善哉。尔时因陀罗幢相王佛即便印可赞言。善哉善哉。善男子。如汝所愿必得满足。又善男子。我当施汝作世水宅心陀罗尼。汝以此陀罗尼心能成就众多众生。又令无量众生丰足资生果报无乏。又能度于烦恼暴流。即说咒曰

多地耶他　阇蓝婆　摩诃阇蓝婆　阿奴呵阇蓝婆娑啰阇蓝婆　郁伽阇蓝婆　夜叉毗梨阇蓝婆　那伽毗梨阇蓝婆优罗伽毗梨阇蓝婆　阿萨帝鼻梨阇蓝婆　阿输婆比梨阇蓝婆　摩嗟比　梨阇蓝婆　曼厨迦比梨阇蓝婆　佉目罗比梨阇蓝婆　崩起比梨阇蓝婆　阿摩比梨阇蓝婆苏脂目佉阇蓝婆婆摩啰婆摩啰阇蓝婆摩啰比阇迦茶钵多罗布疏波颇蓝婆素叉犁牛婆索　达摩耶若(如耶反)比利使致搔醯蓝婆　伽苫步(上)　罗婆穷(去)　穷(去)　婆罗穷频头穷　婆罗阇比　娑婆呵

是陀罗尼句。若为他人及自己身。称其名号为诵此陀罗尼。一切怖畏一切殃祸悉皆消灭。善男子。此作世水宅心陀罗尼。汝若以此心陀罗尼。便能成就众多众生。汝善男子。我昔于彼因陀罗幢相王佛所。受持此作世水宅心陀罗尼。于彼佛所种种供养。持戒多闻布施精勤。从是以来。复于十千佛所。增进如是愿行。以此善根。今于贤劫中得大功德处。今犹不堪成此大业。何以故。从昔以来无量恶龙及夜叉罗刹。阿修罗鸠槃茶饿鬼毗舍遮等出生世间。于诸众生毒恶凶暴无信无悲。无慈愍心行于恶法。非时风雨旱潦灾雹。寒热不调种种返逆。自军他军怨憎斗诤。热风暴起不顾来世。是诸众生于彼过去诸佛之所加持作世水宅心陀罗尼。不生信乐。彼恶众生不信乐故。于诸种子芽茎枝叶花果美味五谷药草及诸资生。破灭毁坏夺其精气。于诸地味放毒气吹。以是毒气令其地味杂毒涩恶。杂病无腻臭秽无味。令此大地作如是等。由是因缘众生不乐。若依地味众生食此种子芽茎枝叶华果诸味五谷药草资身之具者。便生恶心刚犷毒恶。于诸众生无悲愍心不顾后世。为诸病所逼身色粗恶。种种烦恼诸苦所害。具足恶见住邪归依。于三宝所不生信乐尊重恭敬希有之心。乃至禽兽亦复执于种种恶见。迷失本道。谄曲无实但有口言。彼诸众生于三宝中身口心意违失善法。破戒比丘不能禁摄。于彼持戒任放相应。辩才大德诸比丘所常生远离不能亲近。骂詈毁谤轻弄恼乱称扬其过。远离惭愧离十善道。心不爱乐一切善行。起远离心。尔时众生远离福智。寿命短促趣向恶道。是故我今于彼众生。不能令其丰足所须。亦复不能成熟众生。汝于今者是大丈夫。于正法中而得自在智慧善巧。又汝已度一切三昧陀罗尼忍。善能观察智慧彼岸。慈悲庄严通智彼岸汝悉已度。又汝于彼诸菩萨中为最胜幢。已能成就一切众生。汝今为我应当于此四天下中起悲愍心自智观察。云何能令此四天下诸恶毒龙。夜叉．罗刹．阿修罗．鸠槃茶．饿鬼．毗舍遮．迦吒富单那等。一切恶鬼皆悉降伏。风雨顺时水旱调适。秋实丰茂寒温和平。以是因缘令诸地味增长势力气味香美。食用无患增益念力。色貌充润甚可爱乐。称意之事皆出于世。依此大地诸众生等。食用无过增长念力如上所说

尔时地藏菩萨告功德天言。清净智。我今能令此佛刹土所有四大普遍无余。悉能令变为天饮食。使诸众生于百千劫食不能尽。何以故。但此众生薄福德故所不能食。于此胜报非其应器。清净智。我又能令此娑婆佛刹变为天宫及天卧具。庄严衣服香华果树。种种音声众妙伎乐。众宝庄严悉能为作。此诸众生远离福德。又非其器不堪受用。唯除如来应正遍知。十住菩萨及住首楞严三昧得自在者乃能受用。清净智。又我能令一切众生置第四禅。令无有余。岂可不能降伏龙富单那等。又我不应佛未听许而现神变。譬如转轮圣王主兵藏臣。不奉王教而发四兵无有是处。如是菩萨悉是佛子。从佛心生。从佛口生。从法化生。是故一切诸菩萨等。无有不请如来而现神变。清净智。复有陀罗尼轮。名水风摩尼宫集一切咒术章句。建立一切三世诸佛三宝之性。清净智。汝今可问如来水风摩尼宫大陀罗尼轮集一切咒术章句。若佛说者我亦随喜。汝等若能受持此陀罗尼者。一切所愿皆悉满足。尔时大功德天女与大辩天女。大坚固天女。作光大天女。可喜天女。安隐天女。多摩罗坚固天女。明星主天女。奢摩天女。颇梨天女。如是等上首天女。八万四千那由他天。百千众前后围绕。从座而起合掌向佛。时功德天女即于佛前而说偈言

  能灭极恶浊烦恼　　离垢无垢清净行
  我等渴仰陀罗尼　　唯愿演说总持轮
  牟尼说寂无秽浊　　三宝炽然最胜句
  令修罗等得净心　　增长地味无毒恶
  能除寒热暴风雨　　愿说守护夺精气
  令食谷药果味等　　强记除患修善行
  灭除毒害诸恶见　　归信最胜无上法
  或夺精气多烦恼　　云何教化此众生
  此诸天等于牟尼　　希求最上甚深妙
  显示趣向菩提道　　令诸众生入大乘
  大众云集果愿满　　十方菩萨赞佛德
  云何降伏诸恶龙　　雨泽调适苗稼茂

尔时佛告功德天言。清净智。此大陀罗尼诸佛如来时乃说之。如来今于大众会前而自要誓。此水风摩尼宫陀罗尼轮。一切十方三世诸佛之所加持。今当显示。一切十方诸来菩萨得闻此者。彼诸菩萨能住十方无佛国土五浊世中。能显示此水风摩尼宫陀罗尼轮。以此陀罗尼力故。其国所有非时风热寒温旱潦悉皆除灭。由此陀罗尼故。令彼毒恶无慈愍众生不顾来世。谓天龙夜叉罗刹阿修罗迦楼罗。紧那罗摩睺罗伽鸠槃茶饿鬼毗舍遮富单那迦吒富单那人非人等乃至禽兽得信乐心柔和软善。念力善巧乐求正法。护持正法绍三宝种。以此陀罗尼力故。彼佛刹土所有众生。增长寿命。增长身色。增长五谷。增长资生。增长安乐。增长无患。增长名誉。增长持戒。增长多闻。增长布施。增长慈悲。增长智慧。增长方便。增长三昧。增长陀罗尼。增长地观。增长乐出世。增长化众生。增长入大乘。增长胜愿。增长地地转入。增长观察阴界入。增长惭愧。增长摄功德庄严佛土。增长六波罗蜜行。增长一切十方诸佛常所护念。增长值遇佛一切菩萨善友。增长游戏神足。增长坏一切烦恼不令增长。增长神通度于彼岸。不令退减一切善法乃至无上涅槃。即说咒曰

多地他　苏婆罗　婆罗底　那耶婆罗底　掣(平声)沙吒婆罗底　阿那婆罗底　奢婆多喝啰婆罗底　奢啰拏婆罗底　鸠牟尼婆罗底　珊支啰婆罗　底掣(平声)陀娑罗婆罗底　娑罗婆罗底　娑罗钵利诃利　娑罗婆罗多(上声)钵利诃利　那耶钵利诃利　婢毗迦钵利诃利耶若钵利诃利苏婆罗钵利诃利　频头钵利诃利　阇罗钵利诃利　憩多罗钵利诃利　特叉钵利诃利　珊尼摩钵利诃利　苏婆婆钵提犁　劬摩耶婆　末陀索溪　阿那耶波卢誓　迷罗跋迷　阿罗那求师佉罗　毗阇鞞　那罗延拏婢谌林鞞　忧罗伽阿尼弥簁　宫阇啰婆胡迷　诃阇赁鞞羯摩毗罗犁舍罗摩拏婆离犁　佉曷罗伽奢迷阿斯那迷　阿耆尼钵底利　能求耽鼻犁　婆耶遮婆留尼揵咃赁鞞犁　释迦啰是若移阿那鸱提帝利那耶娜尼利　帝利耶头婆佛阿诃地子瑟痴帝　莎婆诃

使此国天子及其眷属悉皆吉祥莎婆呵

那罗延拏　尼罗移莎婆呵　斫迦啰跋多迦罗迷　莎婆呵

说此水风摩尼宫陀罗尼轮一切咒术章句时。一切佛刹所有大地六种震动。诸来大众战栗不安。心惊恐怖同声唱言。南无南无佛陀耶

尔时佛告功德天言。清净智。汝以此水风摩尼宫陀罗尼轮力。能除一切斗诤。一切毒害夜叉罗刹修罗恶龙。乃至人非人等及诸禽兽。一切非时风热寒冷灾雹旱潦等过。悉皆消灭。清净智。此陀罗尼能令五谷悉皆成好。令诸众生增益寿命。增长果报。乃至增长一切善法。未入无上涅槃已来不令失坏。若闻此陀罗尼。受持读诵如说行者。彼人必定趣于涅槃安住三界。尔时地藏菩萨白佛言。世尊。我亦欲说磨刀大陀罗尼。以此陀罗尼力。令一切众果报所须及以地味悉无减损无能毁夺地之精气。又亦无能放毒气者。亦复无能坏其美味。不能令其变为涩恶。亦复不能令其隐没。亦复不能令此大地不生五谷芽茎枝叶华果药草。亦复不能夺其精气。又复不令有其毒气。亦不干枯。又不涩恶。不令不熟寒热不伤。食用无障食已无毒。若食有毒能令食者腹痛吐下。身心逼恼支体挛缩。热病颠狂心乱失念。迭相劫夺斗诤。杀生偷盗乃至邪见。是诸众生常与如上恶法相应。所谓若天或龙。或夜叉罗刹。阿修罗迦楼罗紧那罗鸠槃茶乾闼婆饿鬼毗舍遮。或富单那或迦吒富单那或人或非人。于诸众生不能恼害

多地他　那鼻　摩诃那鼻　初何啰那鞞　阿鼻具那鞞(去声)僧输沙拏那鞞　鼻何啰闇佉鞞阿婆啰牟尼　多嚧那胡嚧醯(呼计反)那他(上声)钵帝　利阇婆徒迷　摩啰婆帝　帝弭罗钵帝　利蹇荼　涅利何隶　斫初婆嘶　佉拏(上声)　毗迷踦(上声)帝都裔　莎波呵　鸯求啰踦　莎波呵　布疏簸耶迷　莎波呵　颇罗赁鞞　莎波呵　萨智耶都裔　莎波呵　赊梨啰　那婆迦罗摩毗沙　莎波呵

此陀罗尼句拥护此国主　莎波呵

汝清净智。此是磨刀大陀罗尼。汝以此磨刀大陀罗尼力。于诸众生。能作如上诸大业事。能为大药。以是因缘故。汝今则能令诸众生禀受汝化。于是一切诸来大众。赞地藏菩萨言。善哉善哉

尔时世尊亦赞地藏菩萨言。善哉善哉。善男子。汝今能为一切众生如大妙药。何以故。汝身即是微妙大药。汝于此四天下一切众生中众生之药。能灭一切众生苦恼。能施一切众生乐具。成就大悲。汝能显示。如是甚深磨刀大陀罗尼力故。令此众生地味精气种子芽茎枝叶华果诸味五谷药草而不衰损。无毒增长。具足成就众生食者。令彼众生秽浊斗诤悉皆消灭堪修善行。此四天下非时风热寒温旱潦皆悉消除。日月星宿昼夜月半月尽时节年岁变怪。为灭此故说此磨刀大陀罗尼。以此陀罗尼力故。令我三宝种及以法眼得久住世。使此愚闇薄福我慢所坏者不修善根。恶刹利及诸宰相。于我如是百千万亿阿僧祇劫精勤苦行所集之法。不灭不坏。比丘比丘尼优婆塞优婆夷无有恼乱。以无恼故诸天不忿。天不忿故。一切众生悉皆获得如上乐具

大集经卷第五十七大方等大集经卷第五十八

        高齐天竺三藏那连提耶舍译

    须弥藏分第十五陀罗尼品第四

尔时世尊告功德天言。清净智。我于往昔与汝二人。于因陀罗幢相王佛所同发誓愿。我今与汝得愿满足。我今已得阿耨多罗三藐三菩提。汝亦住于功德之处。功德天言如是如是。大德婆伽婆。如是如是大德修伽陀。我与世尊所愿已满。我与世尊善欲已满。我共世尊昔于因陀罗幢相王佛所同发誓愿。今愿悉满心意满足。是故如来出现于世。我今得住功德之处。我今虽复得功德处。犹故未能满昔本愿成熟众生。何以故。此处多有象龙马龙蛇龙鱼龙虾蟆龙。彼于此界诸众生中起于恶行。虽说甚深作光陀罗尼。犹故未制此诸恶龙。彼龙常起非时寒热恶云暴雨旱潦不调伤害众生及以五谷芽茎枝叶华果药草。大德世尊。今此世界四天下中。诸龙大龙及龙眷属男龙女龙龙男龙女。所有龙趣生者。彼一切皆已来集。又十方世界一切佛刹。诸大菩萨摩诃萨皆来集会。及一切天．夜叉．罗刹．乾闼婆．紧那罗．鸠槃荼．饿鬼．毗舍遮．富单那．迦吒富单那．等一切来集。又复世尊。声闻弟子人非人等。亦悉来集在大集会。为听法故住于佛前。一切众生依四食活。大德婆伽婆。今正是时。唯愿除此诸恶毒龙灾害方便。于如来所无有信心。其心常与恶法相应。恼乱众生损坏众生。资生之具毒恶粗犷。于诸众生无悲愍心不见后世。莫令于我所化众生为作障难。是故世尊。于彼众生应起大悲灭彼诸恶

尔时世尊告须弥藏龙仙菩萨摩诃萨言。善男子。汝于往昔然灯佛所。为化诸龙发大勇猛弘誓大愿。汝须弥藏。有四生龙大龙毒恶。过去未来现在所有气毒龙见毒龙。触毒啮毒贪毒嗔毒痴毒龙等。此诸恶龙。今当云何如法除彼所有恶业。令诸众生所有种种资生之具无所损减。于三宝中信乐爱敬。深信后世离于恶业。尔时须弥藏龙仙菩萨摩诃萨白佛言。世尊。我当入彼毒龙宫中结加趺坐入龙频申三昧。以此三昧力故。令彼恶龙贪嗔傲慢皆悉消灭。柔和调伏其心寂静深信后世。于一切众生所。慈悲怜愍起救济心。令彼毒龙心生敬信。亦不恼乱一切众生。安置救济众生心地。又世间所有风雨旱潦。有云大云寒热所害。彼诸众生当称我名合十指掌作如是言。大慈悲者。念我念我能化伏龙。须弥藏菩萨种种方便智慧勇猛修行无上菩提道者。唯愿救我除灭我苦。作是言已即说咒曰

多地耶他　萨耽婆步阇　毗梨荼步阇　输拒卢梨荼步阇　迷卢阇婆　伽除婆步阇炎(于剑反)炎阿泥婆步阇　苏摩罗阿跋多步阇债菩步阇　莎波呵

此陀罗尼咒句拥护某甲　莎波呵

大德婆伽婆。若有众生为诸毒龙之所恼乱。当称我名并诵此陀罗尼。能灭此龙贪嗔慢妒毒恶之心。我以清净天耳过于人耳而得闻之。我得闻已。若四生龙大龙龙父龙母龙男龙女及龙眷属。不能令彼生敬信心。犹作如是非时风雨寒热旱潦灾云恶等。若不灭者。又我不与一切众生安乐因缘满其愿者。我便欺诳一切十方三世诸佛。亦莫令我得成阿耨多罗三藐三菩提。如是大德婆伽婆。我于过去然灯佛所。于佛眷属大众之前。发于如是坚固大愿。从是以来常善安住教化众生。又从是来。复于亿那由他百千佛所诸佛现在眷属前。亦作如是坚固大愿。我常安住大精进力。教化众生策勤不惓。如我今者于世尊前坚固精进等无有异。为欲降化诸恶龙故。世尊。我念过去阿僧祇劫已来。未曾忆念于一念顷舍于坚固勇猛精进心。常安住坚固精进教化众生。乃至今日亦复教化一切众生。此诸龙王。于大乘法精进修行。谓此善住龙王为一切象龙王。此难陀龙王婆难陀龙王为一切蛇龙主。此阿耨达龙王为一切马龙主。此婆楼那王为一切鱼龙主。此摩那苏婆帝龙王为一切虾蟆龙主。如是等诸大龙王。能与众生作诸衰恼。自余诸龙自力不堪作上衰患。此五大龙王安住大乘有大威德。是大龙王各各佛前约率眷属。不令起作如上灾祸。于佛法灯三宝种姓。久住于世不令速灭。尔时一切诸来大众。同声赞须弥藏龙仙菩萨摩诃萨言。善哉善哉

尔时善住龙王。从座而起偏袒右肩。合掌向佛而作是言。大德婆伽婆。依属于我诸龙大龙。所谓胎生卵生湿生化生。随佛弟子声闻菩萨徒众眷属。所住国土慈心相向。无怨害心住安等心。又彼国土得为王者。于佛法中得净信心拥护佛法。不恃傲贵自在而生憍慢毁坏佛法。亦不恼乱比丘比丘尼优婆塞优婆夷所有依佛出家若器非器。剃除须发服持袈裟至于彼人信心护持。其国土中或余众生于佛法中起怨刺者。国王应当如法遮约。又其国中先王敬信。曾施沙门及婆罗门田宅封邑。令其受用更不追夺。若有辅相明智大臣。和合一心共治国事。得财坚固尝舒施手。是刹利王善护国土。一切国中所有斗诤秽浊。如前所说。我等诸王。各各自敕己之眷属不起灾变。何故我今作如是敕。此袈裟染衣一切过去诸佛常所加持。又此袈裟则为一切诸菩萨种。则是趣向涅槃正路。即是刚刀能断烦恼。则是涅槃种子。则是失道者灯明。亦是除病者药。如大猛风吹无明云。则是欲行恶道者杖。则是吐药能吐烦恼毒。则是金刚坏修罗冤。则是一切善法宝藏。如清净水能洗罪染。观诸法犹如明镜。能摄乱心犹如罗网。能容禅定犹如宝箧。犹如大地能生诸波罗蜜。应当顶戴如髻明珠。能容忍辱犹如屋宅。则是净器容十地行。障诸外道犹如城郭。则是良医治烦恼病。于诸学者如须弥山。除烦恼蒸犹如明月。除邪见闇犹如净日。为智慧藏犹如大海。于菩提分法犹如华鬘。于一切智智犹如贤瓶。一切佛护犹如意珠。又此袈裟一切诸佛之所加护。于诸众生雨法雨故。是故婆伽婆。若恶刹利王破坏佛法。恼乱比丘比丘尼乃至器非器依佛出家者。若治罚其身。或税其物乃至断命。是故其国中。有敬信佛天夜叉罗刹阿修罗鸠槃荼饿鬼等有大威德。于彼一切刹利王所起嗔恚心。令彼国土斗诤饥俭疫病刀兵竞起。非时风雨旱潦寒热。损伤五谷种子芽茎枝叶华果药味。此非龙过。是诸龙等实自无辜横得恶名。大德婆伽婆。譬如婆罗门自食蒜已与宝女通。不言己臭妄怨宝女言汝臭秽。世尊。是刹利恶王亦复如是。舍刹利法行首陀行。以是因缘。彼护国土威德诸天乃至薜荔等。心生嗔忿破坏国土。国王臣民不审已过。妄与诸龙大龙而作恶名。佛言龙王。已曾教敕一切诸王。若顺教行者得人天乐。乃至获得涅槃之乐。若恶刹利王不顺教行者。乃至堕于阿鼻地狱。复告龙王。各各自诫己之眷属。当设严教勿令违犯。令彼现在及未来世莫坏我法及三宝种。尔时龙王白佛言。如是如是婆伽婆。如是如是修伽陀。世尊。随彼彼土若有持戒多闻所居之处。于彼国中随其所有我之眷属。若男龙女龙龙父龙母龙男龙女及龙眷属。于彼国土若城邑聚落一切诸处。作非时风雨霜雹寒热。伤坏五谷华果药味资生之具。世尊。若彼福田所居之处。若有诸龙违背我教。我与立誓令彼恶龙其身焦瘦退失神通。焦热触身依报灭坏。无复辞辩不堪为作。即说咒曰

多地耶他　那伽啖步蓰　那伽泥迷　那伽陀啰　输伽啰　输伽啰　阇逻输伽啰　阿鼻摩只娑　波呵　娑啰目仚　迦罗帝步簁　那婆萨耽鞞　帝阇耶婆颇隶　毗目赊羯隶　莎波呵

如是陀罗尼句拥护某甲令一切怖畏一切灾害悉令消灭　莎波呵

尔时一切大众赞善住龙王言。善哉善哉。大龙王。能护一切众生。尔时会中一切龙众惊怖恐惧。时难陀龙王。婆难陀龙王。从座而起偏袒右肩。合掌向佛而作是言。大德婆伽婆。若现在世未来世。若恶刹利王。悭惜资财自不受用。亦不施他。于己资财悭惜耽着不舒施手。于沙门婆罗门不信。不施贫穷行路乞丐之者。皆不给济于己宫内及其眷属。亦复不与如法乐事。彼彼守护国土。诸天夜叉罗刹阿修罗鸠槃茶饿鬼等有大威德。彼等一切于恶刹利王起嗔怒心。令彼国土斗诤饥馑疫病刀兵竞起。乃至五谷药味悉皆损坏。非彼诸龙及大龙过。彼龙王等实无过失横得恶名。譬如有风吹彼臭尸。世间之人便言臭风然彼风性实非臭也。如是世尊。恶刹利王亦复如是以悭贪故。一切护国土者起嗔恚心。以嗔恚故破乱其国。横为诸龙而作恶名。虽然我为彼龙而作教令。若彼诸龙。若过去若未来违我教者。若于如是诸佛所有声闻弟子持戒多闻所居国土。若我眷属胎生卵生湿生化生。若男龙女龙龙父龙母龙男龙女及龙眷属。于彼城邑聚落山川溪谷。作非时风雨旱潦灾雹大寒大热。伤害众生五谷华果及诸药味资生之具。于佛声闻弟子福德人所。作损害者。彼诸龙等违我命者当为立誓。令彼诸龙身体挛缩不能游行。退失神通焦热触身。一切依报悉皆损坏。无复辞辩无所能作。即说咒曰

多地他　婆啰拏输迷　鸠牛婆头啰踦婆嚧拏惧鞞　阿迦罗踦　翅赊泥毗摩何啰伽踦　鸠拏鼻　阿罗耆　阿多沙隶　那耶那耽鞞　迦罗鸠世　衰鸯惧波罗制干　陀何罗婆斯　莎婆呵

此陀罗尼句拥护某甲　莎波呵

尔时一切大众。赞难陀跋难陀言。善哉善哉。尔时阿那婆达多龙王。亦于佛前自誓拥护。敕诸眷属亦如上说。即说咒曰

多地他　那摩比梨世　那婆那摩比梨世阿奴差那婆躬　阇鼻踦　佉伽裴佉钵啰都嚧安　廌(徒卖反)贺耶斯隶那啰耶拏瞿迷比　那悉须隶　阿赊迦啰迷　阿初是泥　移簁牟尼萨鞞　莎波呵

此陀罗尼拥护某甲令无怖畏殃祸　莎波呵

尔时婆楼那龙王。亦于佛前教令眷属。及自要誓亦如上说。即说咒曰

多地他　兮摩鞞迷　簸罗绮拏瞿泥　多摩频　度帝利泥　婆罗叉达利迷伽僧俱迷　比耶牟芩　翅世　徒嚧谟提摩移(上)多那锯斯　折摩奚鸡　遮罗何啰鸯耆　那荼达坻犍荼加都隶　莎波呵

此陀罗尼句拥护某甲　莎波呵

尔时摩那苏婆帝龙王。即从座起。偏袒右肩右膝着地。合掌向佛而作是言。大德婆伽婆。若有依我诸龙大龙。胎生卵生湿生化生。婆伽婆。若现在未来有恶刹利王等。舍刹利王法行于恶行。是王当趣阿鼻地狱先道。当知皆是恶刹利王过。龙王无辜横加恶名。以此因缘龙王嗔忿作诸恶业。虽然我等敬受如来之教。世尊。譬如人众之中有妙宝女。澡浴清净以香涂身。着转轮圣王上妙衣服。于其头首着胜七宝鬘。以真金绳臂印环钏以自庄严乘大象乘。眷属围绕送诣刹利王所。如是世尊。我等诸龙畜生所摄损坏之身。为贪嗔慢之所染污。如来今者是法轮王。以第一调伏水。洗浴我等服惭愧衣。以三十七助菩提分鬘。庄严头首。以种种三昧陀罗尼忍地。庄严我等心意识。升大乘车。我今欲往离于五浊清净佛土随佛世尊为诸清净大菩萨众之所围绕说大乘法处。是故我等敬受佛教。我于今者及自眷属。安住坚固弘誓大愿。在在处处城邑聚落山川边城。若声闻乘人。若辟支佛乘人。若菩萨乘人。若出家若在家。若持戒若破戒。若多闻若少闻。若精进若懈怠。若定若乱。若念若失念。但于如来所爱信恭敬心生希有。于法僧所及圣爱戒亦复如是。于三菩提随意趣向。爱信恭敬生希有心。坚固安住随所住处。若我眷属若龙父龙母若男龙女龙若龙男若龙女及龙眷属。随在在处处城邑聚落山川边崄。非时风雨旱潦灾雹寒热暴起。伤害五谷种子芽茎枝叶及诸药味资生之具。在在处处随有佛诸声闻弟子福田住处。若有诸龙违我命教。我今立誓令其身体一切挛缩。退失神通不能游行。焦热触身诸根闭塞。依报失坏不能为作。即说咒曰

多地耶他　佛陀阇耶　婆罗差　阿摩尼迷菩哆娑离梨　阿婆末提　钵啰帝耶尼梨阿婆尼逻迷　仚罢输簁那苏都卑钵梨卑　娑什鞞娑揵陀婆梨　婆啰諵讫利移　莎波呵

此陀罗尼拥护某甲　莎波呵

尔时一切诸来大众欢喜踊跃。合掌赞叹摩那苏帝龙王言。善哉善哉。大丈夫。汝所应作为欲利益一切众生。是时一切龙众。惊怖战栗闷乱失性。尔时有乾闼婆仙名曰药生。即从座起偏袒右肩。合掌向佛而作是言。诸佛大众当一心念。若现在若未来。恶刹利王愚痴无智憍慢所害。不顾后世欺诳无悲。恼乱比丘比丘尼。乃至归依如来剃须着袈裟衣者。而作恼乱。我当于彼恶刹利王所。以三昧力故而作是誓。令彼恶王现得果报。当令王身及其眷属资生乐具为诸敌国之所侵夺。及为内贼反逆扰乱。河池枯竭或复潦溢。疫病所恼恶星变现。寇贼竞起耽荒着乐。家亲眷属乖散不安。四大变异鬼神娆乱。天及诸龙乃至饿鬼有威德者悉皆不安。有刹利婆罗门毗舍首陀。若男若女亦悉不安。师子虎狼恶兽毒虫亦皆不安。我今为欲破坏彼恶王国故作此誓。何以故。是诸恶王于如来所出家剔发一切诸佛之所住持兴三宝种者。而作恼乱。即说咒曰

多地他　跋泥　耶婆那钵隶　摩诃跋那泥　度嚧　摩遮哜　鸠苏摩婆罗帝　育多衫婆差　鞞摩地利多差婆(上)嚧钵那耶　钵利婆利菩摩　度嚧迦啰　迷泥何镰阇斯　逻迷帝利　裴摩跋多　磨输嚧佉誓　那耶那嫌居隶　卑婆车鞞梨迻　陀那谟制僧伽毗舍差　波罗刹帝　波罗民　陀达隶　浮弥颇师哜于嚧摩陀隶　婆那伽逝浮摩哜　阿婆哜　颇那耶比梨使　什婆迦罗迷修多罗差　乾闼婆斯迷　莎波呵

此陀罗尼句拥护某甲令无怖畏灾祸　莎波呵

令恶刹利王及不见后世恼乱比丘者得如是恶

尔时一切诸来龙众及乾闼婆众。各作是言。愿放舍我。若刹利王违法行恶恼乱法僧。我当顺誓还。令我等于自宫内游戏歌舞自在受乐。尔时一切诸来大众同声赞言。善哉善哉。尔时地藏菩萨摩诃萨。合掌礼佛而作是言。世尊我有一切三昧游戏神通。今亦欲说幢杖大陀罗尼门。若于此幢杖大陀罗尼门一经耳者。所有耳病悉得除愈。亦除一切贪嗔痴等烦恼诸病。设不全灭能令轻薄。以此咒咒于海皮。安禅百千遍用涂王鼓。有闻声者。所有贪嗔痴等一切烦恼悉皆微薄于佛法中得清净信恭敬爱乐希有之心。亦得勇猛随顺法行。深信后世资生丰足。众人爱乐莫不喜见。即说咒曰

多地他　崩伽婆　末帝阿卢波　摩帝器多罗浮　革波那蹇地　句那摩仚隶磨蹉奴隶　桥何啰那地那叉跋迷　槃陀何啰输迷　捭伽罗耆梨迷卢醯多何罗鞞儜伽罗苏　婆伽那子梨泥安陀柘逝梨迦啰浮逝　鸡舍卢醯　三摩提头婆利　莎波呵

此陀罗尼句拥护某甲令离怖畏　莎波呵

尔时如来赞地藏菩萨摩诃萨言。善哉善哉。善丈夫。及一切大众亦共赞言。善哉善哉。尔时无尽意菩萨。即从座起偏袒右肩。合掌向佛而作是言。佛及大众唯愿随喜。我今亦欲说大陀罗尼。名一切如来语言音声发幢盖摩尼愿眼。有大威德。有大威势。有大威力。满多闻藏满智慧藏。诸佛声闻之所成就。若有于如来所。尽形寿安住净戒。安住优婆塞戒。若住沙弥戒。若住具足戒。若器非器。若于此幢盖摩尼愿眼大陀罗尼。能受持读诵七日七夜。慧观方便恒常观察于五受阴。数数诵此幢盖愿眼大陀罗尼。于七日七夜能诵满百千遍。便得闻持随闻能受。得无量辩才。能令刹利婆罗门毗舍首陀及一切众生生敬信心。又复能令丰足资财趣向天道。常得亲近生诸佛前。即于佛前而说咒曰

多地他　帝利拏　僧是若翅　鼻帝利拏频鞞迦嚂陀差　蒱婆苏闭　遮摩罗谌鞞　阿婆罗差　阿差耶卢　臂阿迟耶兜摩帝弥利尸利婆毗莎婆利鸯磲阇陀是祢　阇阇啰奴迷　阿那摩输地弥梨佉其梨差居罗婆哜末伽婆差袍　婆莎婆利　阿佛梨帝苏步　莎婆啰佉逝　苏谟帝谟泥　莎波呵

此陀罗尼拥护某甲　莎波呵

尔时世尊赞无尽意菩萨言。善哉善哉。善丈夫。于我法中善作住持。汝能显现此幢盖愿眼大陀罗尼。能示一切众生多闻眼。尔时一切菩萨大众赞无尽意菩萨言。善哉善哉。善丈夫。汝于现在及未来世若有趣向一切大乘众生。则能增长住持多闻之聚。汝今于此幢盖愿眼满足多闻大陀罗尼。能显示故

尔时文殊师利童子菩萨摩诃萨。即从座起偏袒右肩。合掌向佛而作是言。世尊。我今亦欲令此四天下所有树木华果五谷药味芽茎枝叶。及依地众生资须之具令其丰足。为拥护故说大陀罗尼。名能惧尸利子利奴。此四天下中希有未有未见未闻。如来所作如是大集我今说此能惧尸利子利奴大陀罗尼。有大威力。增长一切种子芽茎枝叶华果药味。润泽甘美悉皆丰饶。令一切众生能作信戒多闻布施智慧慈悲方便。长养一切助菩提分法。即于佛前而说咒曰

多地他　阿曼祢耶居闭　伽婆叉毗誓渠　卢遮卢迷　钵吒叉卢迷尸利耶叉居苏迷那　婆锯闻　地(徒买反)何啰阇跋迷车吒婆波摩哜　毕素狼只阿佛啰素隶　何娑伽阇差　卢摩浮阇差　钳毗啰婆素迷　阿奴摩耶萨利钵罗赊都裔　莎波呵

此陀罗尼句拥护某甲　莎波呵

尔时文殊师利白佛言。世尊。以此陀罗尼书高幢上。以大音声而读诵之。复以此陀罗尼咒磨陀那果汁一千遍。用散树木田苗五谷。若以此咒咒诸蠡鼓而吹击之。随其音声所到之处。所有华果五谷药味依地生者。一切灾害无能毁坏。无能干枯。不能烧灭。亦复不能夺其精气。又亦不能损其势力。无能劫夺。若天若龙乃至大威德薜荔鬼。若魔若魔子若魔眷属不能为害。况余众生及众生数。惟除宿业定障。尔时世尊赞言。善哉善哉。善男子。汝今善能于四天下中升施德乘。善男子。汝复又能助成无量众生无上菩提之道。尔时一切诸菩萨众赞文殊师利菩萨言。善哉善哉。如汝所作常应如是。尔时观世音菩萨语弥勒菩萨摩诃萨言。我今与汝大陀罗尼。名船华功德。以此陀罗尼句。于诸众生被以大慈铠音而为说法。是等众生以汝三昧神通力故得闻正法。除诸恶心及诸邪见诸恶知识及诸恶伴。恒常忆念慈悲善根。于一切众生所起怜愍心。深见后世心。远离十不善心。住十善道心。悉能清净一切众生心。降注法雨称众生欲。一切冤家令其欣喜生信乐心。即说咒曰

多地耶他　蓝步莎婆利　迦莎耶跋迷　三称移婆竭隶　陀婆何楞伽阇隶　暮力差素何　叉莎婆梨苏呵　风只　阿婆路迦隶　悉陀阿毗婆差驰呵　那频婆子梨　阿毗扇陀遏鞞　搔婆遮罗　阿婆啰何罗斯　婆罗呵初地利　[王*垔]迦何啰都裔　三摩提羯泥　婆罗阇尼帝利　摩诃浮多多究细　阿啰拏尼隶　婆罗呵赊迷尼罗居苏迷　莎波呵

此陀罗尼句拥护国主　莎波呵

如是弥勒。此船华功德大陀罗尼。以此陀罗尼铠。菩萨摩诃萨为众生说法。若诸众生闻此陀罗尼音一经耳者。乃至微细蚊蚋虫等。浊恶之心皆悉消灭。于善法中得安住心。况复人等得闻此陀罗尼。若有人欲求雨者。当至泉源龙居之处。诵此陀罗尼一日诵一千八遍。日日如是乃至七日。复以种种好华名香百味饮食散龙池中。唯除酒肉五辛不净之食。从月七日至十四日。于十五日旦当以胡椒末和篦麻油咒一千八遍。涂白[疊*毛]上弃龙泉中。能令此龙于彼人所生大欣喜便澍大雨

尔时会中诸大龙及诸龙仙诸来集者。得闻船华功德大陀罗尼。欣喜踊跃不能自胜。深自庆幸起于慈心信后世心。于三宝中净信尊重。生恭敬心希有之心。忏悔自己生畜生趣恶业之心。入无上大乘心。彼诸龙等各随力能欲供养佛。诸龙大龙或有雨于金末银末牛头栴檀坚黑沉水龙坚栴檀多摩罗叶香又雨优钵罗华波头摩种种诸华种种衣种种盖种种幢幡金绳珠璎。一切诸龙大龙向佛合掌。一时同声而作是言。大德婆伽婆。我等一切于三宝所。住增上信乐心。我等今者于世尊前说诚实誓。在在处处城邑聚落人民之中。显示如是船华功德陀罗尼。如是一切诸余陀罗尼。谓水宅心陀罗尼。磨刀陀罗尼。幢盖愿陀罗尼。能求尸利子利奴陀罗尼。船华功德陀罗尼。及四天王所说陀罗尼。并四龙心陀罗尼。如是等大陀罗尼。在在处处一一显示演说受持读诵。我等诸龙随彼彼处城邑聚落边地山川。随其时节起云降雨。寒温调适。我等于彼彼处。灭除自军他军斗乱诤讼疫病饥馑死亡等。令其处处安隐丰熟。人民安乐甚可爱乐。我又令彼种子芽茎枝叶华果树木五谷药草。增长其味不令损减。众生依报丰饶。肥腻甘甜胜味妙香能令出生。我等亦能令阎浮提一切诸王悉生慈心利益心无怨心无违诤心。如是婆罗门刹利毗舍首陀。乃至夜叉令生慈心。乃至优婆塞优婆夷。令生和合心。随此陀罗尼所至到处。我等能为如上所说之事

尔时世尊赞诸龙言。善哉善哉。尔时一切诸来大众亦赞诸龙。善哉善哉。尔时须弥藏菩萨亦赞善哉。赞善哉已。告功德天言。清净智。汝今乃有如是无量诸大菩萨以为善友。犹故不能转调伏轮成熟众生。时功德天语须弥藏菩萨言。若菩萨摩诃萨以愿力自在因缘故。于此秽恶五浊佛刹受生。得值如是善知识伴。如我今日得遇如是相应善友者。彼人阿耨多罗三藐三菩提便在掌中。则为满足六波罗蜜。若有勇猛精进菩萨为善友所摄者。一切种智便在掌中。佛言。如是如是。清净智。如汝所说。若有菩萨摩诃萨愿力自在。为成熟众生因缘故生五浊世。勇猛精进坚固不退。以四摄法相应。为如是大善知识伴所摄。一切智智已在掌中。当知彼人便为满足六波罗蜜离三恶道。当知是人远离胞胎。当知是人住无学地尽诸有漏。当知彼人为一切诸佛忆念护持。当知是人住离欲地

尔时会中有天帝释。名无垢威德。合掌向佛而作是言。世尊。何因何缘。是诸龙大龙损坏世间众生资财。佛言。有二因缘。是诸龙等能坏世间众生资财。何等为二。一者贪力因缘。二者嗔力因缘。以是因缘故。起非时云雨霜雹寒热。损坏众生所有种子芽茎枝叶华果五谷药味。悉令烧然干枯堕落。损减众生资生之具。令身口意造作种种诸重恶业。众生以此重业障故。烧灭过去一切善根无有遗余。远离善知识常在三恶道。或有众生。于现在世为衣食故。乃至造作五逆重业。以恶业故于无量劫不得人身。设使久后得人身者。或诸根残缺或失正念。生真陀罗家下劣种姓工巧之家。贫穷下贱衣食不充资生乏短。又复以恶业故离善知识。以身口意恶业障行。复堕三恶道中乃至阿鼻地狱。是其胜路。如是善男子饮食乏短故。是诸众生久处生死沉流不绝。具受三涂种种极苦

尔时世尊即说偈言

  所有诸苦生　　皆由于饮食
  若离于饮食　　诸苦则不生

尔时无垢威德帝释。即说偈言

  奇哉恩爱罥　　乃至于有顶
  如是广大罥　　皆因饮食生
  凡夫二种因　　爱绳系缚身
  不能得逃避　　犹如鹿着罥
  或走或徐行　　起已还复堕
  爱毒药过故　　或啼或喜笑
  机关苦轮逼　　犹如压油麻
  一切诸人天　　爱逼迫亦然
  百千众伎术　　虽见种种巧
  爱戏弄人天　　巧妙过于彼
  贪爱毒之过　　能害一切人
  设学武勇怨　　犹尚不能及
  如夜叉所执　　狂乱种种语
  爱夜叉所执　　狂乱过于是
  世有吉祥人　　能离恩爱怖
  若能干竭爱　　则度世彼岸

尔时观世音菩萨。亦说偈言

  贪嗔痴惑人　　狂乱无正念
  远离一切善　　造作重恶业
  不敬尊父母　　散灭于善道
  不敬信三宝　　又造诸逆业
  无有悲愍心　　暴恶甚可怖
  彼嗔心力故　　入阿鼻地狱
  众生嗔恚故　　迭互相食啖
  数数恶道中　　众苦所逼迫
  远离善知识　　恶心所踬顿
  常处诸有海　　游行黑闇路
  菩萨大悲身　　为如是众生
  自舍于己乐　　令彼得解脱
  修习菩提行　　造作三种事
  建立胜法幢　　除灭众生恶
  为一众生故　　广集诸苦行
  精勤修道法　　舍财及身命
  为一一众生　　无量劫受苦
  救拔众生故　　堪忍世苦恼
  功德天勇猛　　住教化众生
  为贪欲众生　　发起菩提心

尔时功德天以一斛器盛诸种子。奉上观世音菩萨摩诃萨。而作是言。我今以此一切种子施善丈夫。为欲增益一切种子。愿令我意所欲成满。又令我能于四天下充足众生资生之具。于恶暴虐断善众生拔其苦恼。令得安住菩提之种

尔时观世音菩萨摩诃萨即以手执彼种子器。遍示十方作如是言。一切十方诸佛菩萨及以诸龙今现在者。愿悉念我。令使一切诸四天下所有种子芽茎枝叶华果五谷及诸药味。地味精气众生精气善法精气增长无损。又复令此四天下中三宝种性相续不断。使功德天一切所愿皆悉满足。常使功德天能令一切众生资财丰足。亦能教化一切众生。远离一切恶令发菩提心。又令诸众生得离三恶道生于天中。即说咒曰

多地他　牟尼尸婆　牟尼那佉　牟尼波罗　牟尼婆利　萨[豆*斤]婆于娑差帝刹多啰波罗那　腻罗婆耶婆萨婆毗阇　耶婆悉利梨　莎波呵

此陀罗尼句拥护某甲　莎波呵

尔时世尊赞观世音菩萨功德天言。善哉善哉。告功德天言。清净智。一切诸佛及诸大众已作加护。于此四天下中五谷种子芽茎枝叶悉令成熟。又亦令汝能化众生。汝今应当教化众生

尔时帝释憍尸迦白佛言。世尊。当何名此法门。云何受持。佛告憍尸迦。此经名曰如来共功德天本愿要誓经。亦名须弥藏菩萨所愿。亦名陀罗尼箧。亦名增长地味。亦名三昧方便教化众生。说此法时功德大天。须弥藏菩萨摩诃萨。及一切诸来龙大龙并其眷属。一切神仙天人阿修罗乾闼婆众。闻佛所说皆大欢喜

大方等大集经卷第五十八大方等大集经卷第五十九

        高齐天竺三藏那连提耶舍译

    十方菩萨品第十三

佛在王舍国法清净处时。自然师子座交络帐。佛时坐现三十二相。光影表现十方。诸菩萨皆来谒问佛。菩萨何因缘。有痴者。有黠者。有慧者。有能飞者。有能坐行三昧禅者。有能彻视者。有不能飞者。有不能坐行禅行三昧得定意不能久者。智慧有厚薄者。同菩萨行。何因缘有薄厚。同有心意识。同眼耳鼻口身。何因缘得行异。佛言。善哉善哉。十方过去佛现在佛诸当来佛。皆说人能计心意识眼耳鼻口身。皆说为同法。佛言。人能校计六情为一切。得十方佛智慧。佛告诸菩萨言。诸菩萨有薄厚。诸菩萨问佛。何等为薄厚。佛言。菩萨。厚者谓菩萨行道随道行深。菩萨薄者。行道不能悉随行。谓行有多少随道少。是为菩萨薄。诸菩萨问佛。何等为菩萨常随道不失行。佛言。谓菩萨常守心意识令不动。归灭尽种道栽。谓菩萨能守眼令色不着。归灭尽种道栽。谓菩萨能守耳令声不着。归灭尽种道栽。谓菩萨能守鼻令香不着。归灭尽种道栽。谓菩萨能守口令味不着。归灭尽种道栽。谓菩萨守身令细滑不着。归灭尽种道栽。菩萨如是能守六情得好恶不动常守灭尽。是为厚随道深。菩萨复问佛。何等为菩萨行薄。佛言。谓菩萨失行。有时得行有时不得行。有时菩萨能守心意识随道。有时眼不能守。便失行不随道。有时守眼不能守耳。有时能守耳不能守鼻。有时守鼻不能守口。有时能守口不能守身。有时能守身不能坐禅。有时能坐禅不能校计。有时能校计不能行。有时能行不能分别。有时能分别不能知细软微意。用是故。菩萨随道有失行有得行。用是故。菩萨行道有薄厚不等。菩萨问佛。如是当作何等行。佛言。要菩萨当自行校计。当自知堕校计。不堕校计堕校计者。菩萨为黠不知校计为痴。问曰。当校计黠。当校计痴者云何。佛言。已校计痴。便能校计黠。佛言。人有百八爱令痴。欲校计得黠者。有五十校计。知五十校计中细微罪便得黠。诸菩萨问佛。何等为五十校计。佛言。五十校计者谓从心本起。欲知者。第一当校计百八痴。第二当校计百八疑。第三当校计百八颠倒。第四当校计百八欲。第五当校计百八堕。第六当校计百八爱。第七当校计百八栽。第八当校计百八识。第九当校计百八因缘着。第十当校计百八种。是为十校计

佛言。菩萨复有十校计。第一当校计百八关生。第二当校计百八止行。第三当校计百八断生死。第四当校计百八灭不灭。第五当校计百八罪入空不见。第六当校计百八不舍尽。第七当校计百八不舍净入净。第八当校计百八精还戒。第九当校计百八进入道。第十当校计百八忍戒。是为菩萨十校计

菩萨复有十校计。第一当校计百八辱道。第二当校计百八合道愿。第三当校计百八本信入道。第四当校计百八出痴入慧。第五当校计百八欢喜灭。第六当校计百八未得佛悲。第七当校计百八未得佛愁第八当校计百八未得佛恼。第九当校计百八未得佛经黠未得佛泥洹要。第十当校计百八出罪要未得入泥洹要。是为菩萨十校计

佛言。菩萨复有十校计。第一当校计百八求入慧出罪法。第二当校计百八求入空法度出空。第三当校计百八罪法起空时当知灭时归空。第四当校计百八持空法解尽法。第五当校计百八尽法不复生。第六当校计百八泥洹长生不灭。第七当校计百八应相念。第八当校计百八舍相念。第九当校计百八杂相念当知杂相。第十当校计百八受相长生不灭。是为菩萨十校计

佛言。菩萨复有十校计。第一当校计百八十方生死万物本末成败。第二当校计百八十方成败作证。第三当校计百八十方人所有皆痴。第四当校计百八牵十方痴作证。第五当校计百八十方阿罗汉泥洹去无所有作证。第六当校计百八牵十方辟支佛泥洹去作证。第七当校计百八牵十方过去若师泥洹去当牵作证。第八当校计百八十方今现在佛亦当泥洹去今我作释迦文佛所主天地自在变化要当复泥洹去若当牵我用作证。第九当校计百八十方当来佛亦当泥洹去当牵作证。第十当校计百八尽力却贪求佛如我亦当般泥洹去。是为合菩萨五十校计。诸菩萨皆稽首受教

诸菩萨问佛言。当校计百八痴从心本起者云何。佛告诸菩萨言。若有菩萨心有所念。不自知心生心灭中有五阴中有习。不知为痴转入意。意有所念。不自知意生意灭。中有五阴中有习。不自知为痴。转入识。识有所识。不自知识生识灭。中有五阴中有习。不知为痴。转入眼。眼见好色不自知着不自知灭。中有五阴中有习。不知为痴。眼所见中色。不自知着不自知灭。中有五阴中有习。不知为痴眼所见恶色。不自知着不自知灭。中有五阴中有习。不知为痴。转入耳。耳闻好声不自知着不自知灭。中有五阴中有习。不知为痴。耳所闻中声。不自知着不自知灭。中有五阴中有习。不知为痴。耳所闻恶声。不自知着不自知灭。中有五阴中有习。不知为痴。转入鼻。鼻所闻好香。不自知着不自知灭。中有五阴中有习。不知为痴。鼻所闻中香。不自知着不自知灭。中有五阴中有习。不知为痴。鼻所闻恶臭。不自知着不自知灭。中有五阴中有习。不知为痴。转入口。口所得美味好语言。不自知着不自知灭。中有五阴中有习。不知为痴。口所得中味中语言。不自知着不自知灭。中有五阴中有习。不知为痴。口所得恶味恶语言。不自知着不自知灭。中有五阴中有习。不知为痴。转入身。身所得好细软可身。不自知着不自知灭。中有五阴中有习。不知为痴。身所得中细软。不自知着不自知灭。中有五阴中有习。不知为痴。身所得恶坚苦痛不可身。不自知着不自知灭。中有五阴中有习。不知为痴。菩萨行道要当数息校计如是。菩萨即稽首受行

诸菩萨言。佛虽为我说痴我未解。诸菩萨问佛言。设我知百八痴着知灭灭。当为痴为黠。佛报诸菩萨言。虽知着知灭。续尚痴未解。诸菩萨复问佛。我未闻佛说数息时痴。我闻佛说已知。何以故为痴。佛告诸菩萨。譬喻如新学菩萨未能飞。但耳闻十方佛欲愿往。要未能飞。如是为见十方佛未。诸菩萨报言。如是为但有愿。要为不见十方佛。佛告诸菩萨言。若曹今虽闻我说百八痴着灭。譬如新学菩萨但愿欲到十方佛国不能飞往。佛复问诸菩萨言。新学菩萨。何以故愿到十方佛国不能飞往。诸菩萨报佛言。用不能坏痴未灭罪故。未能飞行至十方佛国。佛言。譬喻诸菩萨但能说着说灭。但说不行名为痴。诸菩萨问佛。何从当得黠。佛告诸菩萨言。所著为痴要当灭。不着乃为不痴要未为黠。诸菩萨问佛言。何以故复未为黠。佛告诸菩萨言。复有百八疑不解故。诸菩萨问佛言。何等为百八疑。佛言。菩萨不自知心生心灭。中有五阴中有习。不知为疑。不自知意生意灭。中有五阴中有习。不知为疑。不自知识生识灭。中有五阴中有习。不知为疑。转入眼眼所见好色不自知生灭。中有五阴中有习。不知为疑。眼所见中色不自知生灭。中有五阴中有习。不知为疑。眼所见恶色不自知生灭。中有五阴中有习。不知为疑。转入耳。耳所闻好声不自知生灭。中有五阴中有习。不知为疑。耳所闻中声不自知生灭。中有五阴中有习。不知为疑。耳所闻恶声不自知生灭。中有五阴中有习。不知为疑。转入鼻。鼻所闻好香不自知生灭。中有五阴中有习。不知为疑。鼻所闻中香不自知生灭。中有五阴中有习。不知为疑。鼻所闻恶臭不自知生灭。中有五阴中有习。不自知为疑。转入口。口所得美味好语言不自知生灭。中有五阴中有习。不知为疑。口所得中味中语言不自知生灭。中有五阴中有习。不知为疑。口所得恶味恶语言不自知生灭。中有五阴中有习。不知为疑。转入身。身所得好细软可身不自知生灭。中有五阴中有习。不知为疑。身所得中细软不自知生灭。中有五阴中有习。不知为疑。身所得恶粗坚苦痛不可身不自知生灭。中有五阴中有习。不知为疑。佛言。菩萨不去是未应为菩萨。诸菩萨问佛。何以故。不应为菩萨。佛言。用不行安般守意不校计百八颠倒故。诸菩萨问佛。何等为百八颠倒。佛言。谓菩萨心所多念为生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。转作意。意所多念生死罪。中有五阴中有习。自言我无罪。如是生死无数劫颠倒。意转作识。所多识生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒转入眼。眼所多视好色生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。眼所多视中色生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。眼所多视恶色生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。转入耳。耳所多闻好声生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。耳所多闻中声生死罪。中有五阴中有习。自言我无罪。如是生死无数劫为颠倒。耳所多闻恶声生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。转入鼻。鼻所多闻好香生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。鼻所多闻中香生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。鼻所多闻恶臭生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。转入口。口所多得美味好语言生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。口．所多得中味中语言生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。口所多得恶味恶语言生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。转入身。身所多得好细软可身生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。身所多得中细软生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。身所多得恶粗坚苦痛不可身生死罪。中有五阴中有习。自言我无罪。如是生死无数劫是为颠倒。佛言。是为百八颠倒。如是菩萨为不解。诸菩萨报佛言。我虽生死颠倒。我欲依经法度人。佛问诸菩萨言。汝度人欲求使人作何等道。诸菩萨报佛言。我欲使人悉得佛道。佛言。若曹辈众多。何以故。不自取佛但群辈相随。诸菩萨言。我虽相随不离经行。佛问诸菩萨言。若曹辈宁能一日俱得佛不。诸菩萨报佛言。我不能俱得佛。佛问诸菩萨。何以故。诸菩萨报佛言。我辈中有相未具者。我曹辈中有功德未满者。我曹辈有生死罪未尽者。佛告诸菩萨。若曹辈有相未具者。有功德未满者。有罪未尽者。如若曹言。相未具者自不能得佛。何能使他人得佛。若曹功德未满不能自得佛。何能使他人得佛。佛言。若曹生死罪意未尽不能自得佛。何能使他人得佛。诸菩萨皆稽首惭

诸菩萨复问佛言。如是我何因缘不得佛。佛报诸菩萨言。若曹坐不行安般若守意校计百八欲欲不舍故。诸菩萨言。行安般守意校计舍百八欲欲者云何。佛报诸菩萨言。若曹心所念念复念为欲。欲中有五阴中有习。是为欲欲。转入意。意复念为欲。欲中有五阴中有习为欲欲。转入识。识为欲。欲中有五阴中有习为欲欲。转入眼。眼所见好色为欲。欲中有五阴中有习为欲欲。眼所见中色为欲欲。中有五阴中有习为欲欲。眼所见恶色为欲。欲中有五阴中有习为欲欲。转入耳。耳所闻好声为欲。欲中有五阴中有习为欲欲耳所闻中声为欲。欲中有五阴中有习为欲欲。耳所闻恶声为欲。欲中有五阴中有习为欲欲。转入鼻。鼻所闻好香为欲。欲中有五阴中有习为欲欲。鼻所闻中香为欲。欲中有五阴中有习为欲欲。鼻所闻恶臭为欲。欲中有五阴中有习为欲欲。转入口。口所得美味语言为欲。欲中有五阴中有习为欲欲。口所得中味语言为欲。欲中有五阴中有习为欲欲。口所得恶味恶语言为欲。欲中有五阴中有习为欲欲。转入身。身所得好细软可身为欲。欲中有五阴中有习为欲欲。身所得中细软可身为欲。欲中有五阴中有习为欲欲。身所得恶粗坚痛不可身为欲。欲中有五阴中有习为欲欲。佛言。诸菩萨。若曹但坐不解欲欲。诸菩萨报佛言。我曹无有欲欲。佛问诸菩萨若曹欲求佛度十方人不。诸菩萨言然。我曹欲求佛度十方人。佛报诸菩萨言。如是为欲欲。何以故言无欲。佛问诸菩萨。若意宁念十方勤苦人不。诸菩萨言然。我曹念勤苦人。佛言。若念诸勤苦人为欲。何以故言无欲。佛问诸菩萨言。若曹至十方佛所问经。若今为忘不。诸菩萨报言。我所问经我皆识不忘。佛问诸菩萨。汝识十方佛说经。宁传为人说经不。诸菩萨言然。我日行为人说经。佛言。若为人说经。宁欲使人解不。诸菩萨言然。欲使人解。佛言。如若为人说经。为欲使人解如是为欲欲。何以故言无欲。佛复问菩萨。若为人说经。宁教人布施不。诸菩萨言然。我曹教人布施。佛问诸菩萨。若教人布施。持何等与佛。诸菩萨报言。我第一欲使人持好色华。佛言。汝曹不欲色。何以故使人持五色好华可眼与佛。如是汝为欲色。何以故言我曹不欲色。佛复问诸菩萨。若宁闻十方佛说经为可耳不。诸菩萨报言。十方佛为我说经可耳。我曹皆欢喜。佛言。如汝闻经欢喜为欲。何以故言无欲。佛复问诸菩萨言。若欲教人为佛烧香不。诸菩萨报佛。我日自行采众华名香持用上佛。佛言。如汝行采众华香。欲得可鼻持行上佛。佛言。如若欲得香华可鼻如是为欲。何以故言无欲。佛复问诸菩萨言。若曹为人说经宁欲可口不。诸菩萨言。我曹为人说经。欲分别可口。欲使人意解。佛言。如若可口为欲。何以故言不欲。佛复问诸菩萨言。汝宁欲具三十二相可身不。诸菩萨言。我勤苦具相但欲可身耳。佛言。如若可身为欲。何以故言不欲。诸菩萨稽首各自惭

佛言。如是菩萨尚未有所怙。诸菩萨稽首言。愿佛哀我当为说。佛因为说。行菩萨道若数息行禅。若自怙定意。当校计百八堕。灭者应禅不灭者不应禅。诸菩萨问佛言。禅为弃恶。百八堕灭者为弃恶。不灭者不为弃恶。若从禅觉起。若行步坐起。得因缘为人说经。所见万物能自校计百八堕能使不着。能使不堕罪。是为菩萨校计行。诸菩萨问佛言。校计百八堕。当从何所起。佛告诸菩萨。校计百八堕者。菩萨心所念中有五阴中有习。是为堕。心转作意中有五阴中有习。是为堕。意转作识中有五阴中有习。是为堕。转入眼。眼所见好色中有五阴中有习。是为堕。眼所见中色中有五阴中有习。是为堕。眼所见恶色中有五阴中有习。是为堕。转入耳。耳所闻好声中有五阴中有习。是为堕。耳所闻中声中有五阴中有习。是为堕。耳所闻恶声中有五阴中有习。是为堕。转入鼻。鼻所闻好香中有五阴中有习。是为堕。鼻所闻中香中有五阴中有习。是为堕。鼻所闻恶臭中有五阴中有习。是为堕。转入口。口所得美味好语言中有五阴中有习。是为堕。口所得中味中语言中有五阴中有习。是为堕。口所得恶味恶语言中有五阴中有习。是为堕。转入身。身所得好细软可身中有五阴中有习。是为堕。身所得中细软可身中有五阴中有习。是为堕。身所得恶粗坚苦痛不可身中有五阴中有习。是为堕。是为百八堕行。佛告诸菩萨言。校计百八堕。不自知堕罪。苦痛当在后。亦不知羞惭。自说言能断百八堕道行。佛言。是人譬如淫泆妒女上头淫泆自可己妊身。不知胞胎儿在腹中日大几所。淫泆妒女为复淫泆自可。至儿成就十月当生。儿当转未转。当生未生。其母腹痛自惭自悔。当堕痛时妒女啼声闻第七天。儿生已后其母痛愈。便复念淫泆。便不念惭不念痛。便复淫泆如故。如是苦不可言。妒女亦不能自觉苦痛。佛言。菩萨行道不校计百八堕。譬如淫泆妒女不自知罪多少。亦不厌苦痛。亦不自校计还惭罪。不知生死五道苦痛。不自知堕三恶道。不自惭行言我堕道。如是世世自受殃。还自惭斯无有利。学道弟子谛学。是诸菩萨皆欢喜稽首受行

佛言。菩萨如是尚未应为解。诸菩萨问佛言。何以故为未解。佛言。谓菩萨不能校计百八爱故。诸菩萨问佛。校计百八爱者云何。佛言。菩萨行禅不能一意一心令灭。但坐着百八故。一者菩萨心有所念不能灭为爱。中有五阴中有习。是为爱。心转作意不能灭为爱。中有五阴中有习。是为爱。五意转作识不能灭为爱。中有五阴中有习。是为爱。转入眼。眼所见好色不能灭为爱。中有五阴中有习。是为爱。眼所见中色不能灭为爱。中有五阴中有习。是为爱。眼所见恶色不能灭为爱。中有五阴中有习。是为爱。转入耳。耳所闻好声不能灭为爱。中有五阴中有习。是为爱。耳所闻中声不能灭。是为爱。中有五阴中有习。是为爱。耳所闻恶声不能灭为爱。中有五阴中有习。是为爱。转入鼻。鼻所闻好香不能灭为爱。中有五阴中有习。是为爱。鼻所闻中香不能灭为爱。中有五阴中有习。是为爱。鼻所闻恶臭不能灭为爱。中有五阴中有习。是为爱。转入口。口所得美味好语言不能灭为爱。中有五阴中有习。是为爱。口所得中味中语言不能灭为爱。中有五阴中有习。是为爱。口所得恶味恶语言不能灭为爱。中有五阴中有习。是为爱。转入身。身所得好细软可身不能灭为爱。中有五阴中有习。是为爱。身所得中细软不能灭为爱。中有五阴中有习。是为爱。身所得恶粗坚苦痛痒不可身不能灭为爱。中有五阴中有习。是为爱。佛言。菩萨行道不校计却百八爱。不自知百八爱堕罪。譬如新生小儿从小至大不能自知日增几所大。菩萨行道不能觉罪多少。譬如是。若菩萨行道觉百八爱堕罪。便当自惭。便当自断。便当自离。便当自灭。如是爱断为应菩萨。佛说如是。诸菩萨皆稽首受行

佛言。菩萨行道当校计百八栽。行道不校计百八栽。不应为菩萨行。去栽者乃应菩萨行。诸菩萨问佛言。当去栽者云何。佛告诸菩萨言。菩萨独处一处当坐行禅。数息相随止观还净。得净为除栽。不净者为不除栽。如是从禅起若在人中。当行校计当断去栽。诸菩萨问佛言。当校计去栽者云何。佛言。行道不得一心定意。为不灭栽。佛言。不得一心定意者。心有所念中有五阴中有习。便生栽。转入意。意中有五阴中有习。便生栽。转入识。识中有五阴中有习。便生栽。转入眼。眼见好色中有五阴中有习。便生栽。眼所见中色中有五阴中有习。便生栽。眼所见恶色中有五阴中有习。便生栽。转入耳。耳所闻好声中有五阴中有习。便生栽。耳所闻中声中有五阴中有习。便生栽。耳所闻恶声中有五阴中有习。便生栽。转入鼻。鼻所闻好香中有五阴中有习。便生栽。鼻所闻中香中有五阴中有习。便生栽。鼻所闻恶臭中有五阴中有习。便生栽。转入口。口所得美味好语言中有五阴中有习。便生栽。口所得中味中语言中有五阴中有习。便生栽。口所得恶味恶语言中有五阴中有习。便生栽。转入身。身所得好细软可身中有五阴中有习。便生栽。身所得中细软中有五阴中有习。便生栽。身所得恶粗坚苦痛不可身中有五阴中有习。便生栽。如是为栽不断。佛言。若有菩萨行道言我无是栽。如是为贡高。为自种栽。便不能自度脱。便无有黠意。不能知栽罪多少。譬如身生毛。其人亦不能自校计一一数。不能自知毛多少。诸菩萨行道不能自除罪。反言我求佛道欲度十方。如是尚不能自度。何能度十方。菩萨行道能去栽者。便能度十方。不去栽便不能度十方。佛说如是。诸菩萨皆欢喜受行

佛言。如是菩萨尚未应解。诸菩萨复稽首言。如是未解。愿佛为我解。佛言。菩萨有百八罪识。不灭者不应为菩萨。诸菩萨问佛言。何等为百八罪识。佛言。谓菩萨心所念为罪。中有五阴中有习为识。是为罪识。转入意。意所念复念为罪。中有五阴中有习为识。是为罪识。转入识。识所念不忘为罪。中有五阴中有习为识。是为罪识。转入眼。眼所见好色为罪。中有五阴中有习为识。是为罪识。眼所见中色为罪。中有五阴中有习为识。是为罪识。眼所见恶色为罪。中有五阴中有习为识。是为罪识。转入耳。耳所闻好声为罪。中有五阴中有习为识。是为罪识。耳所闻中声为罪。中有五阴中有习为识。是为罪识。耳所闻恶声为罪。中有五阴中有习为识。是为罪识。转入鼻。鼻所闻好香为罪。中有五阴中有习为识。是为罪识。鼻所闻中香为罪。中有五阴中有习为识。是为罪识。鼻所闻恶臭为罪。中有五阴中有习为识。是为罪识。转入口。口所得美味好语言为罪。中有五阴中有习为识。是为罪识。口所得中味中语言为罪。中有五阴中有习为识。是为罪识。口所得恶味恶语言为罪。中有五阴中有习为识。是为罪识。转入身。身所得好细软可身为罪。中有五阴中有习为识。是为罪识。身所得中细软为罪。中有五阴中有习为识。是为罪识。身所得恶粗坚苦痛不可身为罪。中有五阴中有习为识。是为罪识。佛问诸菩萨。若曹有是罪不。诸菩萨言。我但有五阴无有罪。佛复问诸菩萨言。天下何等为使人有罪不得道者。诸菩萨报佛言。天下人皆坐贪不得道。佛言。天下人贪生死。为有五阴习不。诸菩萨言有罪。佛问诸菩萨言。若曹持见身取佛当复生死。诸菩萨报佛言。我曹当复生死。不从是现在身得佛。佛问诸菩萨。若曹要当更几生死当得佛。诸菩萨报佛言。我曹生死尚未有要。佛复问诸菩萨。何以故无有要。诸菩萨言。我不自知罪福多少。用是故我不知要。佛告诸菩萨。如是若曹与天下人有何等异。诸菩萨报佛言。我能飞到十方佛国。我能晓佛所语。佛言。若曹能飞到十方佛国。能晓十方佛所语。若曹何以不应时取佛。何以故复生死要。诸菩萨报佛言。我曹尚有本罪未尽故。用本愿功德福未满故。用是故我曹不应时得佛。佛言。若曹言天下人但坐五阴生死习故有罪。今若曹亦当复生死习有罪。若曹何以故语我言无罪。诸菩萨皆惭稽首受行

佛言。我虽说是菩萨尚未解。诸菩萨稽首言。愿佛当复为我解。佛言。菩萨有百八因缘着痛。诸菩萨问佛。何等为百八因缘着痛。佛言。菩萨心有所念为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入意。意有所念为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入识。识有所识为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入眼。眼所见好色为因缘着痛。中有五阴中有习。当坐因缘生死痛。眼所见中色为因缘着痛。中有五阴中有习。当坐因缘生死痛。眼所见恶色为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入耳。耳闻好声为因缘着痛。中有五阴中有习。当坐因缘生死痛。耳所闻中声为因缘着痛。中有五阴中有习。当坐因缘生死痛。耳所闻恶声为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入鼻。鼻所闻好香为因缘着痛。中有五阴中有习。当坐因缘生死痛。鼻所闻中香为因缘着痛。中有五阴中有习。当坐因缘生死痛。鼻所闻恶臭为因缘着痛。中有五阴中有习。当坐因缘生死痛。转入口。口所得美味好语言为因缘着痛。中有五阴中有习。当坐因缘生死痛。口所得中味中语言为因缘着痛。中有五阴中有习。当坐因缘生死痛。口所得恶味恶语言为因缘痛。中有五阴中有习。当坐因缘生死痛。转入身。身所得好细软可身为因缘着痛。中有五阴中有习。当坐因缘生死痛。身所得中细软为因缘着痛。中有五阴中有习。当坐因缘生死痛。身所得恶粗坚苦痛不可身为因缘着痛。中有五阴中有习。当坐因缘生死痛。佛言。诸菩萨尚未厌因缘生死痛。诸菩萨言。我用厌因缘生死痛故作菩萨耳。佛言。汝曹厌生死痛。何以故不种道栽。何以故种因缘生死痛罪罪栽。诸菩萨报佛言。我日种道栽。佛言。如若种道栽。何以故有因缘生死百八痛。诸菩萨即惭稽首受行

诸菩萨皆稽首问佛言。佛虽为我说经我不解是。佛言。我见若曹种百八痛。我知汝曹不解。诸菩萨复稽首言。愿佛解我。佛言。菩萨心有所念。欲得心不能。以时得坐痛。中有五阴中有习。是为种痛。转入意。意有所念复念可意不可意为种痛。中有五阴中有习。是为种痛。转入识。识有所识不可我为痛。中有五阴中有习。是为种痛。转入眼。眼所见好色为痛。中有五阴中有习。是为种痛眼所见中色为痛。中有五阴中有习。是为种痛。眼所见恶色为痛。中有五阴中有习。是为种痛。转入耳。耳所闻好声为痛。中有五阴中有习。是为种痛。耳所闻中声为痛。中有五阴中有习。是为种痛。耳所闻恶声为痛。中有五阴中有习。是为种痛。转入鼻。鼻所闻好香为痛。中有五阴中有习。是为种痛。鼻所闻中香为痛。中有五阴中有习。是为种痛。鼻所闻恶臭为痛。中有五阴中有习。是为种痛。转入口。口所得美味好语言为痛。中有五阴中有习。是为种痛。口所得中味中语言为痛。中有五阴中有习。是为种痛。口所得恶味恶语言为痛。中有五阴中有习。是为种痛。转入身。身所得细软可身为痛。中有五阴中有习。是为种痛身所得中细软为痛。中有五阴中有习。是为种痛。身所得恶粗坚苦痛不可身为痛。中有五阴中有习。是为种痛。佛言。菩萨断是百八痛。乃应为菩萨行。不断痛者不应为菩萨行。是为菩萨十校计。佛言。诸菩萨如是尚未解。当复校计。诸菩萨问佛。当复校计何等。佛言。菩萨当校计百八关生。诸菩萨问佛。何等为百八关生。佛言。菩萨心所贯痛痒思想生死识。中有五阴中有习。是为贯生。佛言。关心不使入痛痒思想生死识。便无五阴无有习。佛言。关五阴习令心不动。为断生死痛关者。为贯地水火风空痛痒思想生死识。中有五阴中有习。是为贯生。关意便不动。不受地水火风空痛痒思想生死识。中有五阴中有习。是为贯生。关意便不动。不受地水火风空痛痒思想生死识。不受五阴习。不关者堕罪。关意不动者堕道。是为关生。转入识。识亦贯地水火风空色痛痒思想生死识。便有五阴习便贯生死。不关者堕生死痛。关者为堕道不为生死。转入眼。眼所贯好色中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。眼所贯中色中有五阴中有习。是为贯生死。关令不动者堕道。不关堕罪。眼所贯恶色中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。转入耳。耳所贯好声中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。耳所贯中声中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。耳所贯恶声中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。转入鼻。鼻所贯好香中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。鼻所贯中香中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。鼻所贯恶臭中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。转入口。口所贯美味好语言中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。口所贯中味中语言中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。口所贯恶味恶语言中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。转入身。身所贯好细软可身中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。身所贯中细软中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。身所贯恶粗坚苦痛不可身中有五阴中有习。是为贯生死。关令不动者堕道。不关者堕罪。佛言。菩萨行要当关令不动。动者为未解。诸菩萨报佛言。我曹当坐禅令不动。佛问诸菩萨言。禅已复动不。诸菩萨报佛言。禅觉复动。佛问诸菩萨。何以故复动。诸菩萨言。自然动。佛问诸菩萨。何以故自然动。诸菩萨言。我不解不知从何因缘动。佛言。如是诸菩萨尚未解。诸菩萨言。愿佛当复为我解。佛言。菩萨所以禅自然动觉者。菩萨有百八关生。动不动不止故。佛说如是。诸菩萨皆稽首受行

佛言。菩萨如是尚未应解。诸菩萨言。何以故复未解。佛言。但坐菩萨有本不止守百八行故。诸菩萨皆稽首言。愿佛当复为我解。佛言。菩萨心本多所念不止守故。心本罪百八行。转入意。意本多所念。不止守故意本罪百八行。转入识。识本多所念。不止守故识本罪百八行。转入眼。眼本多所见好色。不止守故眼本罪百八行。眼本多所见中色。不止守故眼本罪百八行。眼本多所见恶色。不止守故眼本罪百八行。转入耳。耳本多所闻好声。不止守故耳本罪百八行。耳本多所闻中声。不止守故耳本罪百八行。耳本多所闻恶声。不止守故耳本罪百八行。转入鼻。鼻本多所闻好香不止守故鼻本罪百八行。鼻本多所闻中香。不止守故鼻本罪百八行。鼻本多所闻恶臭。不止守故鼻本罪百八行。转入口。口本多所得美味好语言。不止守故口本罪百八行。口本多所得中味中语言。不止守故口本罪百八行。口本多所得恶味恶语言。不止守故口本罪百八行。转入身。身本多所得好细软可身。不止守故身本罪百八行。身本多所得中细软。不止守故身本罪百八行。身本多所得恶粗坚苦痛不可身。不止守故身本罪百八行。佛说如是。诸菩萨皆欢喜受行

大方等大集经卷第五十九此经自下二卷。则丹藏所无。故今无可相校。而宋乡二本。此卷之中皆有三节之文。文断义绝。难取解处。第一第九幅十七行云。有五阴中有之下(更云)所多得中味中语言等。第二第十幅二十一行云。言相未具者自不之下(更云)习自言我无罪等。第三第十二幅二行云。是为颠倒口之下(更云)能得佛何能使人得佛。是为三节文断处也。今准明度经此中二本。皆错将是为颠倒口之下。所多得中味中语言乃至相未具者自不等。凡二十七行。总三百七十九字。进而写之于五阴中有之下。却将五阴中有之下。习自言我无罪乃至是为颠倒口等。凡二十七行。总三百七十六字。退而写之于相未具者自不之下。致令三节之文文断义绝。今依明度经。进退而正之。又为看旧乡宋藏者。略录正文于左中有五阴中有(便云)习自言我无罪乃至是为颠倒口(便云)所多得中味中语言乃至相未具者自不(便云)能得佛何能使人得佛(云云)大方等大集经卷第六十

        高齐天竺三藏那连提耶舍译

    十方菩萨品之二

佛言。菩萨坐禅数息不得定意。得定意不久。但坐不断本罪故使禅不安。菩萨自言。我何因缘本罪不断。佛言。用菩萨坐不校计断生死故。令本罪不断。佛言。欲断本罪者。当断当来生死意。当灭本罪生死意。诸菩萨问佛言。何等当断当来生死意。当灭本罪生死意。佛言。心所动为本罪转得因缘。为当来生死罪。要当断当来生死乃应菩萨。诸菩萨皆稽首言。愿佛当复为我解当来生死罪。佛告诸菩萨。心所动得因缘合。中有盛百八生死。菩萨要当断是盛百八生死。菩萨意所动得因缘。不能远意。中有盛百八生死。菩萨要当断是盛百八生死。菩萨为本识动。复欲识中有盛百八生死。菩萨要当断是盛百八生死。转入眼。菩萨眼所见好色为本。好色动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。眼所见中色为本。中色动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。眼所见恶色为本。恶色动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。转入耳。菩萨耳所闻好声为本。好声动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。耳所闻中声为本。中声动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。耳所闻恶声为本。恶声动欲分别。中有盛百八生死。菩萨要当断是盛百八生死转入鼻。菩萨鼻所闻好香为本。好香动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。鼻所闻中香为本。中香动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。鼻所闻恶臭为本恶臭动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。转入口。菩萨口所得美味好语言为本。美味好语言动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。口所得中味中语言为本。中味中语言动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。口所得恶味恶语言为本。恶味恶语言动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。转入身。身所得好细软可身为本。细软动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。身所得中细软为本中细软动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。身所得恶粗坚苦痛不可身为本。恶粗坚苦痛不可身动欲分别。中有盛百八生死。菩萨要当断是盛百八生死。佛言。菩萨要当断是乃应菩萨。不断者不应为菩萨。如是尚未解。诸菩萨报佛言。我已解因缘。诸菩萨言。我闻佛所说。我一切不堕罪中。佛问诸菩萨。汝宁见菩萨髡头剔须作沙门者不。诸菩萨言然。见作沙门。佛问诸菩萨。沙门当髡头剔须时。沙门头须了尽[歹*斯]不。诸菩萨言尽[歹*斯]。佛言。当尽[歹*斯]时。沙门宁愿复欲使头须生不。诸菩萨言。沙门不愿使生。佛问诸菩萨。头须发何以故复生。诸菩萨言。自然生。沙门亦不使生。佛言。沙门头须发生。宁能自知日长几分。诸菩萨报佛言。沙门头须发生不能自知日长几分。佛言。菩萨不能自觉微微盛百八罪行。譬如沙门自有头发生不知日长几分。如是菩萨罪坐不能自知。言我无罪者云何。佛问诸菩萨。宁有是不。诸菩萨即稽首惭受行

诸菩萨报佛言。愿佛当复为我解。佛言。菩萨不可自怙言我无罪罪灭。佛言。要校计百八本罪灭不灭。菩萨问佛。何等为百八本罪灭不灭。佛言。菩萨心生转便灭。灭中有百八后世当复生受不灭。转入意。意生转复灭。灭中有百八后世当复生受不灭。转入识。识生转复灭。灭中有百八后世当复生受不灭。转入眼。眼所见好色生转便灭。灭中有百八后世当复生受不灭。眼所见中色生转便灭。灭中有百八后世当复生受不灭。眼所见恶色生转便灭。灭中有百八后世当复生受不灭。转入耳。耳所闻好声生转便灭。灭中有百八后世当复生受不灭。耳所闻中声生转便灭。灭中有百八后世当复生受不灭。耳所闻恶声生转便灭。灭中有百八后世当复生受不灭。转入鼻。鼻所闻好香生转便灭。灭中有百八后世当复生受不灭。鼻所闻中香生转便灭。灭中有百八后世当复生受不灭。鼻所闻恶臭生转便灭。灭中有百八后世当复生受不灭。转入口。口所得美味好语言生转便灭。灭中有百八后世当复生受不灭。口所得中味中语言生转便灭。灭中有百八后世当复生受不灭。口所得恶味恶语言生转便灭。灭中有百八后世当复生受不灭。转入身。身所得好细软可身生转便灭。灭中有百八后世当复生受不灭。身所得中细软生转便灭。灭中有百八后世当复生受不灭。身所得恶粗坚苦痛不可身生转便灭。灭中有百八后世当复生受不灭。菩萨言。我何以故罪生复灭。何以故我了不见。佛问诸菩萨。汝曹心宁转不。诸菩萨报佛言。我心转生。设我心不转生。亦不能与佛共语。佛问诸菩萨言。若心生时宁还自觉心生不。诸菩萨言。我但识见因缘时。不觉初起生时。佛言。如汝所说尚不能知心初生时。何能无罪。佛说如是。诸菩萨皆惭稽首受行

诸菩萨报佛言。为我解微太促。愿佛更复为我解。佛问诸菩萨言。汝曹生以来。宁能觉身中温热有几所火。觉身中寒有几所风。合身中有几所水。诸菩萨言。我不能还自具分别知多少。佛言。若不知多少。宁知寒热为水火不。诸菩萨报佛言。我知寒热有水火。佛言。汝尚知寒热水火。何以故不知多少。诸菩萨言。我但能觉寒热。不能知多少。佛言。菩萨不自觉心生正受罪百八罪多少。譬如不觉寒热水火不知火生以来多少。菩萨不自知心转生以来多少。如是菩萨但能觉枝不能觉根。如是菩萨罪入空中尚未解。诸菩萨皆稽首问佛。愿更为我解罪入空中。佛言。菩萨有百八罪入空中不可见。何等为百八罪。若菩萨心有所念。生空中复灭空中。中有百八罪不可见心生灭。譬如人语有声不可见。要为有声在空中但不可见。转入意。意生空中复灭空中。中有百八罪不可见。转入识。识生空中复灭空中。中有百八罪不可见。转入眼。眼所见好色生空中复灭空中。中有百八罪不可见。眼所见中色生空中复灭空中。中有百八罪不可见。眼所见恶色生空中复灭空中。中有百八罪不可见。转入耳。耳所闻好声生空中复灭空中。中有百八罪不可见。耳所闻中声生空中复灭空中。中有百八罪不可见。耳所闻恶声生空中复灭空中。中有百八罪不可见。转入鼻。鼻所闻好香生空中复灭空中。中有百八罪不可见。鼻所闻中香生空中复灭空中。中有百八罪不可见。鼻所闻恶臭生空中复灭空中。中有百八罪不可见。转入口。口所得美味好语言生空中复灭空中。中有百八罪不可见。口所得中味中语言生空中复灭空中。中有百八罪不可见。口所得恶味恶语言生空中复灭空中。中有百八罪不可见。转入身。身所得好细软可身生空中复灭空中。中有百八罪不可见。身所得中细软生空中复灭空中。中有百八罪不可见。身所得恶粗坚苦痛不可身生空中复灭空中。中有百八罪不可见。佛告诸菩萨。若不见罪生空中。亦不见灭空中。如是诸菩萨尚未应解。诸菩萨言。如是我为觉知解。佛问诸菩萨。若何因缘觉。诸菩萨何以故。不常坐禅。何以故。复飞行到十方佛所。菩萨言。用我有本愿故。不得不行耳。佛言。如若有本愿到十方佛所。何因缘坐禅弃罪。设令汝坐禅弃罪本愿当灭。诸菩萨言。我坐禅但灭当来罪耳。我未灭本愿罪。佛问诸菩萨。若曹从无数劫以来所作。过去生死罪当灭不。诸菩萨言。我当灭过去无数劫本罪。佛言。若尚能灭无数劫本罪。何以故。独不灭本愿罪。诸菩萨言。佛问我是我不能卒解。佛言。如是若曹为未解。何以故言我解。诸菩萨皆稽首惭受行

诸菩萨报佛言。佛虽为我解我尚未解。愿佛当复为我解。当复何等行。佛言。诸菩萨行道无数劫以来意生死本意。譬如果实种着土中生大树。已成大树。树上生百种亿亿枝枝。生亿亿万叶枝。枝生亿亿万实。一实者当复转生一树。菩萨坐禅弃我本罪。譬如取树叶一一灭之。取实一一灭之。便不复种生。取枝一一灭之。如是叶实枝灭尽了[歹*斯]但有根。根者为譬如本愿一意所起本罪意。譬如树根枝叶生当复灭之。不灭者当长养实复生。灭者不复生。菩萨守意。譬如守树根不得使树枝叶实生。生为增当来罪。灭者为不增当来罪。为灭本罪。如是菩萨本罪未尽者。常当念百八不舍尽。诸菩萨稽首言。愿佛为我解我不解。佛言。不舍尽心有所念。生念还尽百八便尽。是为不舍尽。转入意。意生念还尽百八便尽。是为不舍尽。转入识。识生念还尽百八便尽。是为不舍尽。转入眼。眼所见好色念还尽百八便尽。是为不舍尽。眼所见中色念还尽百八便尽。是为不舍尽。眼所见恶色念还尽百八便尽。是为不舍尽。转入耳。耳所闻好声念还尽百八便尽。是为不舍尽。耳所闻中声念还尽百八便尽。是为不舍尽。耳所闻恶声念还尽百八便尽。是为不舍尽。转入鼻。鼻所闻好香念还尽百八便尽。是为不舍尽。鼻所闻中香念还尽百八便尽。是为不舍尽。鼻所闻恶臭念还尽百八便尽。是为不舍尽。转入口。口所得美味好语言念还尽百八便尽。是为不舍尽。口所得中味中语言念还尽百八便尽。是为不舍尽。口所得恶味恶语言念还尽百八便尽。是为不舍尽。转入身。身所得好细软可身念还尽百八便尽。是为不舍尽。身所得中细软念还尽百八便尽。是为不舍尽。身所得恶粗坚苦痛不可身念还尽百八便尽。是为不舍尽。如是菩萨不舍尽。便入百八净。佛说如是。诸菩萨皆欢喜稽首受行

诸菩萨复稽首问佛言。为何等为百八净。佛言。若有菩萨心起生出念。即还入灭为入净。为灭百八不舍净。转入意。意生出即还入灭为入净。为灭百八不舍净。转入识识生出即还入灭为入净。为灭百八不舍净。转入眼。眼所见好色生出即还入灭为入净。为灭百八不舍净。眼所见中色生出。即还入灭为入净。为灭百八不舍净。眼所见恶色生出。即还入灭为入净。为灭百八不舍净。转入耳。耳所闻好声生出。即还入灭为入净。为灭百八不舍净。耳所闻中声生出。即还入灭为入净。为灭百八不舍净。耳所闻恶声生出。即还入灭为入净。为灭百八不舍净。转入鼻。鼻所闻好香生出。即还入灭为入净。为灭百八不舍净。鼻所得中香生出。即还入灭为入净。为灭百八不舍净。鼻所闻。恶臭生出即还入灭为入净。为灭百八不舍净。转入口。口所得美味好语言生出。即还入灭为入净。为灭百八不舍净。口所得中味中语言生出。即还入灭为入净。为灭百八不舍净。口所得恶味恶语言生出。即还入灭为入净。为灭百八不舍净。转入身。身所得好细软可身生出。即还入灭为入净。为灭百八不舍净。身所得中细软生出。即还入灭为入净。为灭百八不舍净。身所得恶粗坚苦痛不可身生出。即还入灭为入净。为灭百八不舍净。菩萨行如是不舍净。便能精还百八应戒。佛说如是。诸菩萨皆欢喜受行

诸菩萨复稽首问佛言。何等精还百八应戒。佛言。诸菩萨行道心起。即精还灭百八。为还应戒。转入意。意生即精还灭百八。为还应戒。转入识。识生即精还灭百八。为还应戒。转入眼。眼所见好色生即精还灭百八。为还应戒。眼所见中色生即精还灭百八。为还应戒。眼所见恶色生即精还灭百八。为还应戒。转入耳。耳所闻好声生即精还灭百八。为还应戒。耳所闻中声生即精还灭百八。为还应戒。耳所闻恶声生即精还灭百八。为还应戒。转鼻。鼻所闻好香生即精还灭百八。为还应戒。鼻所闻中香生即精还灭百八。为还应戒。鼻所闻恶臭生即精还灭百八。为还应戒。转入口。口所得美味好语言生即精还灭百八。为还应戒。口所得中味中语言生即精还灭百八。为还应戒。口所得恶味恶语言生即精还灭百八。为还应戒。转入身。身所得好细软可身生即精还灭百八。为还应戒。身所得中细软生即精还灭百八。为还应戒。身所得恶粗坚苦痛不可身生即精还灭百八。为还应戒。佛说如是。诸菩萨皆欢喜受行

佛言。诸菩萨以精还应戒便进行入道。诸菩萨问佛言。何等为精还戒便进行入道。佛言。菩萨心有所念从心尽力。尽所念灭百八。是为进行入道。转入意。意有所念从意尽力。尽所念灭百八。是为进行入道。转入识。识有所识从识尽力。尽所识灭百八。是为进行入道。转入眼。眼所见好色从好色尽力。尽好色灭百八。是为进行入道。眼所见中色从中色尽力。尽中色灭百八。是为进行入道。眼所见恶色从恶色尽力。尽恶色灭百八。是为进行入道。转入耳。耳所闻好声从好声尽力。尽好声灭百八。是为进行入道。耳所闻中声从中声尽力。尽中声灭百八。是为进行入道。耳所闻恶声从恶声尽力。尽恶声灭百八。是为进行入道。转入鼻。鼻所闻好香从好香尽力。尽好香灭百八。是为进行入道。鼻所闻中香从中香尽力。尽中香灭百八。是为进行入道。鼻所闻恶臭从恶臭尽力。尽恶臭灭百八。是为进行入道。转入口。口所得美味好语言。从美味好语言尽力。尽美味好语言灭百八。是为进行入道。口所得中味中语言。从中味中语言尽力。尽中味中语言灭百八。是为进行入道。口所得恶味恶语言。从恶味恶语言尽力。尽恶味恶语言灭百八。是为进行入道。转入身。身所得好细软可身。从好细濡可身尽力。尽好细软可身灭百八。是为进行入道。身所得中细软。从中细软尽力。尽中细软灭百八。是为进行入道。身所得恶粗坚苦痛不可身。从恶粗坚苦痛不可身尽力。尽恶粗坚苦痛不可身灭百八。是为进行入道。佛言。进行入道便能忍持行戒

诸菩萨问佛言。何等为忍持行戒。佛言。菩萨已能当能忍持戒不离戒。如是乃应菩萨行。菩萨心动当忍百八不得令转。是为忍心忍行戒。转入意。意有所念。当从意忍不得令转。百八便不得行。是为忍行戒。转入识。识有所识。当从识忍不得令转。百八便不得行。是为忍识忍行戒。转入眼。眼所见好色。从好色当忍不得令转。百八便不得行。是为忍好色忍行戒。眼所见中色。从中色当忍不得令转。百八便不得行。是为忍中色忍行戒。眼所见恶色。从恶色当忍不得令转。百八便不得行。是为忍恶色忍行戒。转入耳。耳所闻好声。从好声当忍不得令转。百八便不得行。是为忍好声忍行戒。耳所闻中声。从中声当忍不得令转。百八便不得行。是为忍中声忍行戒。耳所闻恶声。从恶声当忍不得令转。百八便不得行。是为忍恶声忍行戒。转入鼻。鼻所闻好香。从好香当忍不得令转。百八便不得行。是为忍好香忍行戒。鼻所闻中香。从中香当忍不得令转。百八便不得行。是为忍中香忍行戒。鼻所闻恶臭。从恶臭当忍不得令转。百八便不得行。是为忍恶臭忍行戒。转入口。口所得美味好语言当忍不得令转。百八便不得行。是为美味好语言忍行戒。口所得中味中语言。从中味中语言当忍不得令转。百八便不得行。是为忍中味中语言忍行戒。口所得恶味恶语言当忍不得令转。百八便不得行。是为忍恶味恶语言忍行戒。转入身。身所得好细软可身。从好细软可身当忍不得令转。百八便不得行。是为忍好细软可身忍行戒。身所得中细软。从中细软当忍不得令转。百八便不得行是为忍中细软忍行戒。身所得恶粗坚苦痛不可身。从恶粗坚苦痛不可身当忍不得令转。百八便不得行。是为恶粗坚苦痛不可身忍行戒。佛言。是为菩萨十校计

佛言。菩萨复有十校计。诸菩萨稽首问佛。何等为十校计。佛言。菩萨当能耐辱。能耐辱便入道。诸菩萨问佛。何等为耐辱入道。佛言。菩萨心有所念。当辱心不得令念。便辱百八罪不得胜。是为辱心入道。转入意。意有所念当辱意不得令念。便辱百八罪不得胜。是为辱意入道。转入识。识有所念当辱识不得令念。便辱百八罪不得胜。是为辱识入道。转入眼。眼所见好色。当辱好色不得令念。便辱百八不得胜。是为辱好色入道。眼所见中色。当辱中色不得令念。便辱百八不得胜。是为辱中色入道。眼所见恶色。当辱恶色不得令念。便辱百八不得胜。是为辱恶色入道。转入耳。耳所闻好声。当辱好声不得令念。便辱百八不得胜。是为辱好声入道。耳所闻中声。当辱中声不得令念。便辱百八不得胜。是为辱中声入道。耳所闻恶声。当辱恶声不得令念。便辱百八不得胜。是为辱恶声入道。转入鼻。鼻所闻好香。当辱好香不得令念。便辱百八不得胜。是为辱好香入道。鼻所闻中香。当辱中香不得令念。便辱百八不得胜。是为辱中香入道。鼻所闻恶臭。当辱恶臭不得令念。便辱百八不得胜。是为辱恶臭入道。转入口。口所得美味好语言。当辱美味好语言不得令念。便辱百八不得胜。是为辱美味好语言入道。口所得中味中语言。当辱中味中语言不得令念。便辱百八不得胜。是为辱中味中语言入道。口所得恶味恶语言不得令念。便辱百八不得胜。是为辱恶味恶语言入道。转入身。身所得好细软可身。当辱好细软可身不得令念。便辱百八不得胜。是为辱细软可身入道。身所得中细软。当辱中细软不得令念。便辱百八不得胜。是为辱中细软入道。身所得恶粗坚苦痛不可身。当辱恶粗坚苦痛不可身不得令念。便辱百八不得胜。是为辱恶粗坚苦痛不可身入道。佛言。菩萨行如是。为应菩萨忍戒行。菩萨以忍辱便得百八合道愿。便得百八本信入道。便得百八出痴入慧。便得百八欢喜还灭。便得百八佛悲心。便得百八未得佛道愁。何等为佛百八悲心。何等为百八未得佛道愁。谓菩萨得佛悲心。念十方泥犁中人难得度脱。谓菩萨得佛悲心。念禽兽蜎飞蠕动难得度脱。谓菩萨得佛悲心。念薜荔中饿鬼难得度脱。谓菩萨得佛悲心。念二十八天及诸天长寿憍乐不知苦习难得度脱。谓菩萨得佛悲心。念世间帝王豪贵难得度脱。谓菩萨得佛悲心。念世间痴人不解难得度脱。谓菩萨得佛悲心。念世间人多痴难得度脱。谓菩萨得佛悲心。念十方五道一切五道一切同法难得度脱。如是菩萨为得佛悲心。便得佛愁。谓菩萨念十方五道勤苦难得度脱愁。菩萨已悲已愁百八爱复增多。如是菩萨不可用百八爱增多故不悲愁。佛言。我但用十方五道勤苦悲愁故得佛。是为菩萨未得佛百八悲。是为菩萨未得佛百八愁。佛言。复有菩萨未得佛百八恼。诸菩萨问佛言。何等为菩萨百八恼。佛言。谓菩萨未得佛。见十方泥犁中人拷掠毒痛。欲往度脱不能度脱便生恼。谓菩萨未得佛。见禽兽蜎飞蠕动及人民转相拷掠毒痛相杀。菩萨欲度不能度便生恼。谓菩萨未得佛。见薜荔饿鬼无所食。欲度脱不能度便生恼。谓菩萨未得作佛。见世间人所作恶贪淫嗔恚烹杀祠祀贪利强盗快心恣意。见是曹人死生五道苦痛无有断绝。虽上为诸天无有别异。要五道死生苦痛。便不时得佛便生恼。便增盛百八爱行。是为菩萨未得佛百八恼。谓菩萨未得佛经要百八黠。未得佛泥洹要。诸菩萨复问佛。何等为百八得佛经黠。佛言。谓菩萨能自护六情百八不行。为得佛经黠。何等为未得佛泥洹要。佛言。谓菩萨未得佛。未得泥洹要。佛言。诸菩萨当校计百八出罪要。便得入泥洹要。菩萨复问。佛言。何等为出罪要便得入泥洹要。佛言。谓菩萨所念为罪出要当灭。灭者为得入泥洹要。一切六情百八灭。亦为入泥洹要。是为菩萨出百八罪入泥洹要。是为菩萨十校计

佛言。菩萨复有十校计。第一菩萨相聚会。但当校计百八当令尽。当求入慧出罪。便应菩萨法。二者当校计菩萨百八求入空法。便出罪空法。是为菩萨百八校计出罪入道空。三者菩萨当校计百八罪法初起空生时。当知校计灭归空时。是为菩萨校计百八生灭。为合空以知生灭是为菩萨谛校计。四者菩萨当校计百八持空法解尽法。诸菩萨复问佛。何等为持空法解尽法。佛言。菩萨一切知十方所有本末皆空已。知空知所有当复灭尽。菩萨知尽以为谛。即不复贪百八。不复行着欲。菩萨能自解当知尽。是为菩萨校计持空法解尽法。是为菩萨校计百八解尽应法。五者菩萨当校计百八尽法不复生。已知不复生。是为菩萨校计尽法不复生已知不复生法。六者菩萨当校计百八尽。当得泥洹长生不复灭不死。菩萨得是校计自知苦。是为菩萨法知泥洹乐校计法。七者菩萨当校计知百八尽泥洹念。是为菩萨知泥洹校计相念。八者菩萨当校计百八灭尽舍相念不复念。是为菩萨百八舍相念不复念校计。九者菩萨当校计所念不尽便生杂相念。以知杂相念。当校计泥洹无所有何以故复有杂相念当复灭。是为菩萨知杂相念校计。十者菩萨当校计自知灭无所有。长受泥洹相。泥洹长生不复灭。是为菩萨校计受泥洹相。是为菩萨十校计

佛言。菩萨复有十校计。诸菩萨问佛。何等为菩萨十校计佛言。一者菩萨自知百八罪。亦当为十方人说百八罪亦当为人说十方生死五道苦痛。常当为十方人说万物成败本末生死无所有。是为菩萨一校计。二者菩萨当校计十方成败牵证用示人。是为菩萨牵证校计解人法。三者菩萨当校计十方人所有皆坐贪故着以贪着皆为痴。菩萨常当为人解贪着解人痴。菩萨亦当持贪痴还自况。我未知菩萨道时贪痴亦剧。是菩萨得是校计。常当慈心解人贪痴。是为菩萨校计。四者菩萨常当校计百八牵十方痴人作证。诸菩萨复问佛。何等为牵十方痴人作证。佛言。十方人所念皆坐百八痴故。菩萨去百八乃为不痴。菩萨失行百八行便为痴。常当牵十方痴人作证不得失。是为菩萨校计法。五者菩萨当复校计百八牵十方阿罗汉作证者。诸菩萨言。复校计百八牵阿罗汉作证云何。佛言。菩萨失行但坐贪着故。当牵阿罗汉泥洹去无所有。我何为所念失行。何为当坐是苦所念。牵阿罗汉泥洹常作证。是为菩萨校计法。六者若复失行。当校计百八牵辟支佛泥洹无所有作证。是为菩萨校计法。七者菩萨若失行。当复校计百八无所有。当牵十方过去佛泥洹无所有。十方过去佛皆我师。皆取泥洹去。我何为失行行在世间。菩萨已牵证便还摄行。是为菩萨牵证校计法。八者菩萨复失行。当复牵现在十方佛亦当泥洹去。常当牵自证已自证当即还行。是为菩萨百八牵证还行校计法。九者菩萨当校计百八复失行。佛言。我今作释迦文佛。我所主天地帝王人民皆属我。自在飞行大威神。我要般泥洹去归无所有。常当牵我作证。常当坚意求佛。持我作证意不转。转者为失行。便堕盛百八爱行中。是为菩萨校计。十者菩萨常当尽力却贪令不得受求。受求者为不应菩萨。菩萨谛求分别思惟我所校计。是为菩萨五十校计。佛言。诸菩萨行安般守意常苦失行。无有不失行。时诸菩萨问佛。何以故。我曹作菩萨常苦失行。佛言。菩萨不厌生死苦习故。不自觉生死习故。不谛知生死尽无所有。不谛知有佛泥洹道故。佛言。诸菩萨不可自用作菩萨道故。贡高胜十方人。佛言。未得佛生死苦习未与尽合未与道合。常有身体苦痛。亦有寒热苦。亦有饥渴苦恼不能断。如是菩萨未可自怙其善。佛言。我未得佛时。自谓智慧无能及者。自谓知禅无能及者。自谓知细微灭心无有及者。佛言。我已立身作释迦文佛。还自校计作菩萨时所知譬如一菩萨智。今已作佛有所知譬如十方佛国中所有万物菩萨。佛言。十方佛所有菩萨智慧。未能得一方佛一小尘智。菩萨即稽首问佛言。我曹痴何以多不能及佛一尘智佛言。用汝不厌生死苦习故。不早取佛故。不知细微意故。不知灭本断根故。汝曹尽力精进行。亦当知十方佛智慧。诸菩萨问佛。我何因缘生死多如是。佛言。汝曹不谛行安般守意三十七品经十二问三向中微意。不知分别校计生死百八中细微意故。使生死多难得佛。佛言。汝心未起时。中有五百四十百八爱行心转作意。中有五百四十百八爱行意转作识。中有五百四十百八爱行。转入眼。眼所见好色。中有五百四十百八爱行。眼所见中色。中有五百四十百八爱行。眼所见恶色。中有五百四十百八爱行。转入耳。耳所闻好声。中有五百四十百八爱行。耳所闻中声。中有五百四十百八爱行。耳所闻恶声。中有五百四十百八爱行。转入鼻。鼻所闻好香。中有五百四十百八爱行。鼻所闻中香。中有五百四十百八爱行。鼻所闻恶臭。中有五百四十百八爱行。转入口。口所得好味美好语言。中有五百四十百八爱行。口所得中味中语言。中有五百四十百八爱行。口所得恶味恶语言。中有五百四十百八爱行。转入身。身所得好细软可身。中有五百四十百八爱行。身所得中细软。中有五百四十百八爱行。身所得恶粗坚苦痛不可身。中有五百四十百八爱行。佛言。一心中有五百四十百八爱行。五百四十百八爱行中。一爱者当受一生死。一爱者当受一身。如是不尽五百四十为受。五百四十生死身。意亦尔识亦尔。好色亦尔中色亦尔恶色亦尔。好声亦尔中声亦尔恶声亦尔。好香亦尔中香亦尔恶臭亦尔。美味好语言亦尔。中味中语言亦尔。恶味恶语言亦尔。好细软可身亦尔。中细软亦尔。恶粗坚苦痛不可身亦尔。佛问诸菩萨。宁知是不。诸菩萨言。闻佛说皆知。佛言诸菩萨。汝曹宁信有是无。诸菩萨言。信有是众不疑但不解。佛问诸菩萨汝曹发起来至我所。宁知汝意中几转。汝闻我造说经以来。知汝意几转。诸菩萨报佛言。不知几转。佛问诸菩萨。何以故不知几转。诸菩萨言。我闻佛说经。欢喜不知觉几转。佛言。汝曹来至今不觉意转堕生死。譬如是摩竭国中尘不知多少。菩萨但坐失行。不自知觉生死多少。是故不即时得佛。诸菩萨各各稽首欢喜受行

诸菩萨各各稽首言。未闻佛五十校计时。自用不失行。闻佛解五十校计。自知失行。佛言。汝亦失行亦不失行。菩萨复问。何以失行亦不失行。佛言。汝至十方佛前自贡高自誉言。我解无有是五十校计罪。便堕罪失行。是为亦失行。佛言。不失行者。菩萨至十方佛前。常当自惭身体自惭生死自惭。生堕罪不能校计知。常持五十校计还自惭是为菩萨不失行。不自惭者常失行。佛说如是。诸菩萨各各自惭。各各自悔。各各自念灭尽非常苦空非身。诸菩萨闻经皆大欢喜。前为佛作礼头面着佛足。受行而去

大集经卷第六十


大方等大集经菩萨念佛三昧分卷第一

    No. 415 [No. 414]

大方等大集经菩萨念佛三昧分卷第一

        隋天竺三藏达磨笈多译

    序品第一

尔时婆伽婆。在王舍城耆阇崛山中。与大比丘众千二百五十人俱。一切皆是大阿罗汉。诸漏已尽无复烦恼。心善解脱慧善解脱。调伏一切犹如大龙。舍离重担不受后有。所作已办获真己利。住平等智入解脱门。自在得度众苦彼岸。惟除尊者阿难一人

复有无量诸菩萨摩诃萨众。皆从十方世界来者。各与一切菩萨。摩诃萨众俱

复有无量净居诸天子。其名曰难陀天子。须难陀天子。栴檀那天子。须摩那天子。自在天子。大自在天子。难胜天子。善威光天子。如是等诸天子众。过夜半已放大光明。直照于此耆阇崛山已。咸诣佛所顶礼尊足。即以天多摩罗跋香。天沉水香。天多伽罗香。天末栴檀香。及牛头栴檀香。如是等种种诸香。殷勤再三散于佛上已。复以天散华及天鸡婆罗华。摩诃鸡婆罗华。曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。阿地目多华。以如是等种种众华。亦殷勤再三散于佛上已。而复渐进。前诣佛所右绕三匝。一心恭敬合十指掌。稽首礼佛退住一面

尔时诸天子众各如是念。今此菩萨念一切佛三昧法门。过去诸如来应供等正觉。已曾于彼天人大众中。宣扬分别利益一切诸众生故。今我世尊。岂不为斯天人．大众．梵．魔．沙门．婆罗门．诸龙．夜叉．乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人非人等．敷演宣说如是妙典。为欲利益一切世间天人大众故。亦令未来世一切众生咸蒙利益故

尔时难陀天子。须难陀天子。栴檀那天子。须摩那天子。自在天子。大自在天子。难胜天子。善威光天子。如是一切诸天子众。作是思惟已。即白佛言。世尊婆伽婆。今此菩萨念一切佛三昧法门过去诸如来应供等正觉。已曾为诸天人．大众．梵．魔．沙门．婆罗门．诸龙．夜叉．乾闼婆乃至一切人非人等。敷扬演说如是经典。利益世间诸众生故。惟愿世尊大慈哀愍。今亦为此天人．大众．梵．魔．沙门．婆罗门及彼一切人非人等。演说如是方等法门。令诸世间多获利益安隐快乐故

尔时世尊大悲熏心。为欲利益一切世间诸众生故。默然受是诸天子请。时诸天子见佛默然。知圣哀许。顶礼佛足围绕三匝。即于耆阇崛山忽然不见还于天宫

尔时世尊。过夜后分将明旦时。便作大师子王警欬之声而复微笑。时佛如来应供等正觉。忍发如是殊异声已。须臾之间是耆阇崛山。精舍所有诸比丘众。承佛威神一切皆悉集于如来应供等正觉所

尔时复有众多异阿兰若处诸比丘等。具大神通有大威德。亦皆承佛威神俱从阿兰若处来。入耆阇崛山集如来所

尔时王舍大城。一切诸比丘尼亦皆承佛威神。入耆阇崛山集如来所

尔时摩伽陀国主。韦提希子阿阇世王。与无量百千眷属前后围绕。入耆阇崛山集如来所

尔时复有诸夜叉大将。其名曰阿吒婆迦旷野居夜叉大将。伽陀婆迦驴形夜叉大将。金毗罗摩竭鱼夜叉大将。须脂路摩针毛夜叉大将。摩罗陀梨持华鬘夜叉大将。如是等诸夜叉为首。并余诸夜叉辈。有大威神具大势力。各与无量百千眷属前后围绕。入耆阇崛山集于佛所

尔时复有诸阿修罗王。其名曰大叫罗睺阿修罗王。种种可畏毗摩质多阿修罗王。须婆睺善臂阿修罗王。波诃罗舒展陀阿修罗王。有大威神具大势力。闻佛警声。心生惊悚身毛皆竖。各与无量百千眷属前后围绕。来入耆阇崛山集于佛所

尔时复有此三千大千世界所有诸大龙王。及其眷属彼各闻佛警欬声时。心生惊悚身毛皆竖。承佛威神来入耆阇崛山集于佛所

尔时舍婆提大城给孤独长者。亦与无量百千眷属前后围绕。自舍婆提诣王舍城。入耆阇崛山集于佛所。为欲恭敬供养如来听闻正法故

尔时毗舍离大城。亦有无量诸梨车子。皆生大净婆罗门家。其名曰善思梨车子。伏怨少壮梨车子。功德生梨车子。无边手梨车子。举手梨车子。然手长者子。如是等而为上首。皆已久住无上大乘。各与无量百千眷属前后围绕。自毗舍离诣王舍城。入耆阇崛山集于佛所

尔时瞻波大城。复有无量诸长者子。已于过去供养无量无边诸佛。种诸善根具大威德有大势力。其名曰善住长者子。利益长者子。无边精进婆罗门子。如是等而为上首。及余无量长者居士。各与无量百千眷属前后围绕自瞻波城诣王舍城。入耆阇崛山集于佛所。为欲恭敬供养如来听闻正法故

尔时波罗奈城。有无量种异类人众。已于过去供养无量百千诸佛。植诸善根皆已纯熟。自波罗奈诣王舍城。入耆阇崛山集于佛所。为欲恭敬供养如来听闻正法故

尔时拘尸那城。复有无量诸力士末罗子。亦曾供养无量百千诸佛世尊。以久熏修诸善根故。有大威德具足势力。亦与无量眷属围绕。自拘尸那诣王舍城。入耆阇崛山集于佛所。亦为恭敬供养如来听闻正法故

尔时东方过无量恒河沙诸世界中。一切大梵天王并余天众。有大威德具大神通。闻佛世尊大师子王謦欬声时。咸大惊愕举身毛竖。承佛威神各与无量千万天众眷属围绕。皆自本处发来诣此娑婆世界王舍大城。入耆阇崛山集于佛所。如是南西北方四维上下。皆有如是无量恒河沙世界。所有一切大梵天王及余天众。有大威德及大神通。闻佛世尊大师子王謦欬声时。亦咸惊悚举身毛竖。承佛威神各与无量千万天众眷属围绕。皆自本处发来诣此娑婆世界王舍大城耆阇崛山集于佛所

尔时耆阇崛山。其地弘博纵广正等。如此三千大千世界。大众充满无有空处如杖头许。然彼大众皆有无量大威德力及大神通。一切天人诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人辈皆悉充满

尔时世尊知诸世间天人大众一切集已。复发如是大师子王謦欬之声。发大声已自精舍出。至一方所而复微笑。时诸世间天人大众睹是事已。各舍己服及诸华鬘。以种种香而散佛上。供养恭敬至心瞻仰

尔时大众中有尊者舍利弗。尊者目犍连。尊者大迦叶。尊者须菩提。尊者富楼那弥多罗尼子。尊者罗睺罗。尊者大劫宾那。尊者大迦旃延。尊者阿泥楼陀。尊者护世。尊者守笼那。尊者难陀。尊者阿难等。而为上首。及余一切诸大声闻。皆是大德具大神通。一切皆来集斯会坐

尔时大众中复有尊者。弥勒菩萨摩诃萨。越三界菩萨摩诃萨。踊大步菩萨摩诃萨。初发心即转法轮菩萨摩诃萨。善思菩萨摩诃萨。大音声菩萨摩诃萨。善行步菩萨摩诃萨。超三世菩萨摩诃萨。持世菩萨摩诃萨。文殊师利菩萨摩诃萨。不空见菩萨摩诃萨等而为上首。及余无量无数菩萨摩诃萨皆于过去无量诸如来所。种诸善根众行熏修功德成满。久已得住阿耨多罗三藐三菩提

尔时尊者不空见菩萨摩诃萨见佛世尊复微笑已从座而起整容理服。偏袒右肩右膝着地。合掌向佛。而说偈曰

  最胜无上两足尊　　无缘不应现微笑
  一切世间无等侣　　惟愿为我演笑因
  常施贫穷诸所须　　亦说大乘最妙宝
  能与生盲决胎膜　　今事微笑何因缘
  世尊三界尚无比　　何况世间得论胜
  能作世间大导师　　今应显笑有何缘

尔时世尊。即告不空见菩萨摩诃萨言。不空见。汝今见斯胜地方所左右边动众相庄严可爱乐不。不空见言。如是世尊。如是婆伽婆。佛复告言。不空见。汝应当知此地方所。往古诸如来应供等正觉。已曾受用教化游居。尔时不空见菩萨闻佛教已。速疾而行趣彼方处。至彼方已。便入三昧。住三昧时。自然成就上妙宝座。种种庄严皆悉具足。严饰座已。还诣佛所。头面礼足而白佛言。世尊。今此方处庄严若是。惟愿世尊。亦当及时处斯胜地。尔时世尊便往方所。至方所已如法升座。于是如来应供等正觉升此座时。如此三千大千世界一切大地六种震动。所谓。动遍动等遍动。震遍震等遍震。涌遍涌等遍涌。吼遍吼等遍吼。起遍起等遍起。觉遍觉等遍觉。东涌西没。西涌东没。南涌北没。北涌南没。中涌边没。边涌中没。时此大地如是动已。佛神力故遍此世界有大光明。令诸众生等受快乐。下至阿鼻大地狱中。所有众生蒙光触身。诸苦消灭等受快乐。如是一切诸地狱中受苦众生。及以诸畜生辈更相残害。阎罗王界诸饿鬼等。遇斯光已所有苦具皆悉消除。饥渴充满无有众生不受乐者。当尔之时一切众生。悉舍恶念皆起慈心。递相爱乐各怀悲愍。犹如亲属相视欢欣和合同座。于是赞曰

  世尊处斯座　　能放大光明
  大地六反动　　令众生欢喜
  如来处斯座　　法王放光明
  当知如是时　　众生等受乐
  正觉处斯座　　大智归依处
  放光利世间　　遍照此佛刹
  奇哉是大乘　　最胜乘无上
  如来处斯座　　利益难思议
  奇哉是大乘　　最胜乘无上
  沙门婆罗门　　于此莫能测

尔时世尊出广长舌。遍覆于此三千大千世界已。告诸菩萨摩诃萨及诸大声闻众言。诸善男子。汝等当知昨中夜后。欻有净居诸天。难陀天子。须难陀天子。栴檀天子。须摩那天子。难胜天子。乃至须多波天子等。与无量诸天子。有大威德具大神通。放盛光明直照耆阇崛山。来至我所。即以种种天上妙香。所谓天末栴檀。乃至天多摩罗跋香等散于我上。复以种种天华。所谓优钵罗华。乃至大曼殊沙华等。供养于我右绕三周。顶礼我足退住一面。彼退住已。更于我所增敬上心。合十指掌默然而住。住已即作如是思惟。今此一切菩萨念佛法门。过去诸如来应供等正觉。已曾为彼天人大众宣扬解释。惟欲安乐彼诸众生。今我世尊亦当为此天人大众。如是演说念佛法门。安乐利益诸众生故。彼诸天子如是念已。即便请我说此法门。时我默然许为其说。诸天知已于是不现。尔时世尊。即说颂曰

  比丘知昨中夜后　　净居天王摩醯罗
  将诸天众及眷属　　难陀及以须难陀
  须摩那天栴檀等　　乃至难胜须多波
  普放世间胜光明　　直照此土耆阇崛
  彼天既来至我所　　以天华香而供养
  然始右绕我三周　　顶礼恭敬一面住
  彼诸天子默生念　　今此念佛修多罗
  过去最胜曾广宣　　怜愍世间众生故
  今我释尊十力具　　宁不演说斯法门
  利益世间诸群生　　安隐一切天人故
  诸天念已便发请　　时我默然遂许之
  我故欲于耆阇山　　如先诸佛所演说
  天知我已许之故　　生大欢乐尊敬心
  一切咸复恭敬礼　　右绕三周然后去
  比丘汝辈当善听　　我闻过去诸佛说
  莫于是处生惊疑　　诸如来智难可测
  往昔诸佛所行道　　我先知尽无复疑
  现在一切人中尊　　所得菩提我已证
  当来大悲愍世者　　自然法身我觉知
  我今具足无碍智　　如是大智难称量
  超出世间无与等　　一切众生莫能测

    菩萨念佛三昧分不空见本事品第二之一

尔时世尊告尊者舍利弗。尊者大目揵连。尊者大迦叶。尊者须菩提。尊者富楼那弥多罗尼子。如是等具足神通有大威德诸大弟子言。汝诸比丘。如汝所知依汝境界。当于我前各师子吼。何以故。若汝说者令此一切天人大众诸声闻人咸得信解故

尔时世尊。复告弥勒菩萨摩诃萨。文殊师利菩萨摩诃萨。越三界菩萨摩诃萨。超不思议菩萨摩诃萨。善行步菩萨摩诃萨。初发心即转法轮菩萨摩诃萨。善思惟菩萨摩诃萨。大音声菩萨摩诃萨。持世菩萨摩诃萨。不空见菩萨摩诃萨等言。不空见。汝今应当大师子吼。决定请说诸佛世尊所得功德真实相貌。汝若请者则能利益一切世间诸众生辈。是故我今躬自劝汝。时彼不空见菩萨闻圣教已。即于佛前。以偈赞曰

  世尊百福金色身　　慈悲妙觉第一义
  功德智慧斯无减　　忽令我请何因缘
  无有等类人中尊　　世间胜智靡超者
  法王功德已究竟　　何缘今日劝我请
  佛灭清净禅第一　　智慧深妙解脱真
  解脱知见先圆满　　何故今日劝咨问
  法王威仪咸具足　　一切世间最尊雄
  既能自利亦利他　　大师何因劝我请
  世尊慈悲久淳至　　旷劫常行无怨亲
  无障碍辩难称量　　何因世尊令我请
  能施一切贫乏财　　亦开世间生盲眼
  胜尊能令怖者安　　何缘世尊劝我请
  佛身滓秽不能污　　衣服本来离尘垢
  生处王中圣王家　　何因今者方劝请
  圣衣离身四指间　　终无近体而能住
  旋岚巨风吹不动　　圣尊何事而劝请
  世尊寻常行路时　　所至窊凸自平满
  或经高阜即坦然　　何因今日令我请
  世尊身相悉圆满　　行步支节无动摇
  由得不坏难思议　　不应今日令我请
  我观世尊回顾时　　大地便随六反动
  无有神足若如来　　如是自在人中最
  世尊光明所照触　　能令狂者不失心
  但能暂睹如来光　　或时失念旋即复
  世尊行时足动尘　　众生遇者七日乐
  乃至寿终随意生　　故我归命与乐者
  若人遭病受大苦　　众痛酸迫不能堪
  暂蒙世尊以手摩　　即得安隐不可说
  世尊法身具斯力　　皆因旷劫长时修
  是处终无有疑惑　　导师不应劝我请
  人中独尊种种能　　调伏大仙度一切
  我今还白天人师　　是故不应劝我请

尔时世尊。复告不空见菩萨言。善哉善哉汝不空见。快说是事善思念之吾当解说。不空见言。如是世尊。惟愿广释我今谛受。佛告不空见。我念过去无量无边阿僧祇劫。时彼有王名无边精进。有大神通具足威德正法治化。所居大城名曰善住。其城宽旷东西具满十二由旬。南北惟有七由旬半。城有七重。其城重别皆以七宝。所谓金银琉璃颇梨马瑙车磲真珠珊瑚。尽用如是众宝间错。复次不空见。当知彼城。城有四面面别三门。门各皆有二阙相对。楼阁高广庄严殊丽。具足咸以妙宝合成。当其门中竖帝释胜幢以为门限。乃至所有楣枨枢阖。一切皆是众宝厕窴。复次不空见。彼城诸门。咸有金银二种络网。罗覆其上。复于网上种种严饰。金网银铃银网金铃。清风吹动出微妙音。具足和雅犹如天乐。复次不空见。彼城七重。于七重内具足宝阶。斯有栏槛镂绮分明。七宝所成杂色可爱。于金栏处垂白银茸。于银栏所悬真珠茸。于珠栏处悬琉璃茸。乃至种种诸彩交错。众宝间悬互相映发。复次不空见。彼城七重周匝皆有宝堑围绕。所谓金银琉璃颇梨马瑙。诸种庄严皆用宝成其堑。各有七宝阶陛杂色分炳微妙可观。复次不空见。彼精进王。诸堑水中妙华盈满。所谓优昙钵花。钵头摩花。拘物头花。分陀利花。如是众花。光明可爱。鲜洁柔软芳烈远闻。众生受用无遮护者。复次不空见。彼精进王。其堑岸上植种种华。所谓尼文迦多华。钵帝剑华。阿地目多迦华。瞻波迦华。婆梨师迦华。拘毗罗陀华。达奴迦利迦华。如是诸华香鲜可爱。犹如天华。民人取用亦无遮护。复次不空见。彼城各有七重行列。多罗宝树周匝围绕。鲜明可爱七宝合成。其黄金树白银为叶及以华果。白银树者真珠为叶及以华果。真珠树者琉璃为叶及以华果。琉璃树者颇梨为叶及以华果。颇梨树者马瑙为叶及以华果。马瑙树者车磲为叶及以华果。车磲树者赤真珠为叶及以华果。赤真珠树者珊瑚为叶及以华果。珊瑚树者真金为叶及以华果。复次不空见。诸多罗树光茂可观。微风触动出妙音声。若得闻者欢喜受乐。如人作乐能生种种微妙音声。若有得闻无不受乐。彼多罗树风来触时出微妙音。令人乐闻亦复如是。复次不空见。彼王城中常有如是种种诸声未曾断绝。所谓象声。马声车声。步声鼓声。贝声箜篌声。琴瑟琵琶筝笛笳箫。如是一切种种音声未曾暂息。王恒宣令国内民人。谁有所须饮食衣服象马车乘。随意所须皆悉给与。复次不空见。彼王城外多罗树林。行人游处在下休息。若饮若食或卧或坐。闻此宝树诸微妙音莫不皆受五欲妙乐。复次不空见。彼精进王。于大城内近远皆如一射箭所。置一华池四岸及底皆四宝成。四面阶道七宝庄饰。所谓黄金阶道白银庄饰。白银阶道琉璃庄饰。琉璃阶道颇梨庄饰。颇梨阶道马瑙庄饰。马瑙阶道珊瑚庄饰。珊瑚阶道虎珀庄饰。众宝杂厕见者欢喜。复次不空见。彼池复有诸种妙华。所谓优钵罗华。钵头摩华。拘物头华。分陀利华。如是众华香气芬馥。众生闻者无不爱乐。于池岸上复植诸华。所谓伊尼摩迦乃至达[少/兔]迦利华。众华可爱犹如天华。彼华池门常开不闭。人民往来无遮禁者。复次不空见。彼精进王。于大城内置游观园。于诸园中复有种种七宝树林常有华果。王与夫人后宫侍御。同共游处欢欣取乐。门亦不限任彼人民游观嬉戏等受快乐。复次不空见。又于彼园内面各一箭所别置花池。亦以金等四宝所成。复用七宝严饰阶陛。众色光丽见者乐观。彼池水内种种诸华。所谓优钵罗华。乃至分陀利。是等众华芳鲜可爱。池岸复有多种林树及诸华果。所谓婆尼斫迦华。陀摩那伽。乃至达[少/兔]迦利华。是等华果香鲜可爱。人民取用无遮禁者。复次不空见。彼精进王。禀性仁爱慈念众生如母爱子。亦常深心敬事沙门婆罗门刹利长者。如子事父。复次不空见。彼王形量魁伟挺异常人。身体圆满众相具足。面目端正颜色光荣。威德弘普天人爱敬。复次不空见。彼王宿植德本生刹利家。种姓尊高世无胜者。所生父母七世清净。妻子眷属福庆会同。无有一人行过非者。复次不空见。彼王以福业故。天下丰饶凡是百味恒满仓厨。缯锦诸珍盈溢府库

大方等大集经菩萨念佛三昧分卷第一大方等大集经菩萨念佛三昧分卷第二

        隋天竺三藏达磨笈多译

    不空见本事品之余

复次不空见。彼精进王。以慈爱怜愍多好行檀。常为大会无碍施主。天下所有沙门婆罗门贫穷疾病。诸乞求者随须给与无有休厌

复次不空见。彼精进王。凡所统领八万四千城邑聚落。皆是净业胜因所感七宝合成。于诸城上一一复造八万四千栴檀楼观。诸门左右亭传路次。悉有堂舍众宝庄严。门无昼夜常开不闭。以拟一切等获大安。又诸城内衢巷街陌。恒然灯烛有大光明。令彼人民各力为作。同共受斯安隐快乐

复次不空见。彼精进王。时有二子。一名师子二名师子意。诸根明利身相圆满。有大威德具足神通。皆已先发阿耨多罗三藐三菩提心。复次不空见。当尔之时有佛世尊。号曰宝聚如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。常为天人梵魔沙门婆罗门诸龙夜叉乾闼婆阿修罗乃至一切人非人等。宣明正法初中后善。义味深奥其文亦善。纯备无杂清白梵行。复次不空见。时彼宝聚如来应供等正觉。常与七十二亿百千诸大声闻皆阿罗汉。具足神通有大威德。近善住城说法教化。复次不空见。尔时宝聚如来应供等正觉。即于食时着衣持钵。与彼七十二亿百千大声闻众前后围绕。威容详雅入善住城次第乞食。彼精进王。适与二子在高楼上。遥望见彼宝聚如来。大众围绕端严殊特威德巍巍。行人观睹莫不乐见。诸根清净心虑澹然。上下调伏胜奢摩陀。到于第一功德彼岸。具足圆满一切种地。王既见已生奇特心喜勇无量。即与二子取诸华鬘涂香末香及余名香。俱出宫门。速疾持诣宝聚如来应供等正觉所。奉献供养佛及大众。顶礼佛足却住一面。复次不空见。彼精进王及其二子。即便要请宝聚如来。与诸大众尽形供养。所谓衣服器具饮食医药。凡是所须悉皆奉给。庶事隆厚圣众获安。是精进王与其二子。宿植德本常求佛法。今既遭逢又蒙受请。心生欢喜庆幸特深。复次不空见。时彼宝聚如来应供等正觉。于天人中说法教化所应作已。便于中夜入无余涅槃。不空见。时精进王。闻彼世尊般涅槃已。即与夫人及其二子。躬率群臣及诸民众。诣彼世尊般涅槃处。至已敬礼世尊足下。悲号啼哭椎胸大叫。举身投地如树中摧。躄地宛转而伤叹曰。世尊灭度一何驶哉。大圣涅槃遗弃我等。世间方盲导师长逝。众生贫困商主告终。世界将昏慧灯忽灭。不空见。彼精进王。如是追慕极悲叹已。方与二儿诣世尊所。以诸香水沐浴圣身。复用众香遍涂尊体。更以种种殊异华鬘微妙乐音。尽虔供养然后方用迦尸迦衣。妙叠缠裹安处金棺及以铁椁。其棺又以七宝杂厕。如是盛置彼佛身已。方聚清净赤妙栴檀。高一由旬纵广正方一拘卢舍。散诸种华及以华鬘。烧然殊胜涂末香等。灌以苏油然后起火阇维宝聚如来色身

复次不空见。时彼王子师子既见如来般涅槃已。如是思惟。天人大师舍我灭度。我于今日何义苟存。今我若获随从如来应供等正觉。而取灭度岂不乐哉不空见。时彼王子如是念已。用诸名香自涂其身。复以诸香熏其衣服。以[疊*毛]缠裹。然后周围放大猛火梵烧其身。火炽盛已师子方于猛焰之中。发大弘誓救诸众生。歌赞归依如来功德。以偈颂曰

  世间宝中最尊上　　今日放舍入无余
  天人大师转法轮　　我等从此不复睹
  法王利益无量众　　今已弃置入涅槃
  吼宣如是大菩提　　长不复见众围绕
  不可思议大导师　　说法能令闻者喜
  一切天人诸魔梵　　从今永绝不闻声
  能施贫穷法财宝　　为众演说皆乐闻
  诸天龙鬼人非人　　自此长往无归趣
  世间从今无所依　　偏悼我王何恃怙
  并师子意失覆护　　永不闻佛说法音
  我宁捐躯及寿命　　无用独住于世间
  以是今灭所爱身　　因兹更广弘誓愿
  我于佛所种善根　　父王亦常尊三宝
  先愿以此诸功德　　令王及我证法身
  于不思议诸佛所　　供养修行众善业
  普愿群生同斯福　　亦令我誓无虚言
  世尊灭度我焚身　　其有得闻或亲见
  一切皆同等正觉　　非彼现在身证者
  若人觉悟及梦中　　但令见我今所作
  彼必成佛无有疑　　非彼现在身证者
  我此爱身终败坏　　事同水沫无坚牢
  愿彼食我诸虫兽　　皆得速成菩提道
  今我誓行精进事　　或有毁骂或轻诃
  令我速得调御师　　非彼现在身证者
  我求无上正觉时　　其或慈心相观视
  即于世间疾成佛　　非彼现在身证人
  我今所愿及未发　　为是焚烧所爱身
  若此诚誓必不虚　　令我还见灭度佛
  如我暂得睹世尊　　何异天师重出世
  今我虽复盛焦然　　犹冀身存得观佛
  世尊智慧无障碍　　常转三世清净轮
  如昔广利诸众生　　令我见佛从火起
  济世大师若暂起　　如先威力普眼尊
  佛知师子心精诚　　为之暂起视神力
  广与世间兴变事　　令无量众厌患身
  毕竟利益诸众生　　还复焚身入寂处
  大众睹佛巨神变　　以清净意赞妙音
  诸佛妙法难思议　　戒及禅定亦复然
  智慧解脱不可量　　神通变化亦难测
  虽已灭度能净我　　今故归命焰炽身
  世尊威德无有比　　神通已达彼岸边
  灭度能令生厌离　　今我归依普眼观
  慈悲一切最尊胜　　能以自心知他心
  悉治无边界众生　　归命无等善逝者
  于诸医中第一尊　　常以妙药施众生
  能除无量众病苦　　归命怜愍救护人
  以我称赞诸善根　　恭敬供养诸功德
  放舍爱身所获福　　先愿利益诸众生

不空见。时彼王子师子。发斯大愿以自庄严。然后增火卒舍身命。时诸世间天人梵魔沙门婆罗门乃至一切人非人等。见斯事已。咸于世间生重厌离

复次不空见。时彼王子舍身命已。即生梵天作大梵王。于诸梵中最尊最胜。有大威德具大神通。不空见。时彼王子生梵宫已。即自思惟。我从何处作何善根而来生此。得有如是功德果报大神通力。作是念已。便自了了分明见知。我于人间为精进王子。我与父王众具供养恭敬歌赞宝聚世尊。世尊灭度。我即焚身于彼炽然猛火之中。发大誓愿叹佛功德。以此善根今生梵宫。然我今应还下人间。开慰我父答所生恩。复当供养宝聚如来入于涅槃烧身处也。复次不空见。时大梵王如是念已。与眷属天于彼宫没。犹如壮士屈伸臂顷。即至人间往诣宝聚如来应供等正觉阇毗身处。以天众香所谓天末旃檀。及天牛头沉水。多摩罗跋香等而为供养。复散种种天上妙华。华若车轮犹云遍满而为供养。师子梵天供养佛已。方慰其父精进王言。大王当知。王子师子烧身丧命。今我是也。我时即生大梵天中。愿王勿复忧悲痛恼。惟应欢喜深自庆快。何以故。王今已获第一大利。所以者何。诸佛世尊难遭难遇。而王已得值遇世尊宝聚如来应供等正觉。尊重恭敬具足供养。是为希有第一大利。是故大王从今已后。惟当一心受持是法。弟师子意亦应如是。受持此法复应供养世尊舍利。处处流布广兴塔庙。我于梵宫亦常如是。持斯妙法尊奉舍利。如是言已忽然不现

复次不空见。时彼精进王闻梵语故。即与其子师子意者。往诣宝聚如来应等正觉舍利之所。恭敬礼拜歌诵赞叹。持一切香一切华鬘并诸音乐。复持诸种幢幡宝盖。奉献供养。又少时间于彼八万四千诸城。纯以七宝兴起八万四千塔。高一由旬面各广长一拘卢舍。殊特端严光耀可爱。安止舍利咸令供奉。又于一一宝塔之所。常然八万四千灯明。各各复以一切名香一切妙华。及以华鬘一切幢幡。一切宝盖一切乐音。鼓蠃角贝钟铃磬铎。凡是众具莫不毕备。如是供养受持是法。彼精进王以斯善根。于八万四千劫不生恶道。及师子意亦同果报。王大夫人名曰善意。其最大臣多曰无嗔。亦于八万四千劫中受胜果报。彼王如是于诸劫中。次第供养六万诸佛。所生常受转轮王身。正法治化利益众生

复次不空见。彼宝聚佛灭度之后。时节未几有一菩萨摩诃萨。名普密王现生世间。为世间故舍家出家示修苦行。诣菩提树坐于道场。以一念慧断除无明烦恼习气。即证阿耨多罗三藐三菩提。不空见。时彼师子大梵天王。以天眼观见普密王如来应供等正觉出兴于世。即复还下住虚空中。持天众香及以妙华散于佛上。然后至地右绕三周。恭敬合掌头面礼拜。劝请世尊转大法轮。时彼师子梵王住于佛前。以偈请曰

  世尊今应阐妙法　　我等众生堪听闻
  智慧摧敌今适兴　　一切世间莫能毁
  如来无上调御者　　具足至真十种号
  利世大师今已起　　自然正觉妙菩提
  功德圆满人中上　　圣智久修非始然
  世尊但为演妙音　　今此大众乐闻受
  弘誓本为度世间　　无归依者作覆护
  如昔所愿今既满　　已到寂静无为处
  今当速开甘露门　　能坏三缚出众恼
  梵王陈请义已周　　如来于是默然许
  于须臾顷普密佛　　遂令彼梵极欢喜
  及无量亿天人众　　以闻善逝转法轮
  时彼梵天蒙说已　　广持众具奉报恩
  于是复发弘誓愿　　为求无上菩提处
  今于普密世尊前　　陈我所作诸功德
  以此善根所生处　　常奉十方诸世尊
  我昔道场供养佛　　请听慈说利众生
  因是微善凡所居　　愿于佛前常歌赞

尔时世尊复告不空见菩萨摩诃萨言。不空见。时彼精进王子师子梵天。以烧身善根得生梵宫。次第供养五千诸佛。听闻正法增长善根。常发广大不思议愿。不空见。汝今当知。尔时无边精进王者岂异人乎。即我身是。时彼不空见菩萨复白佛言。世尊。彼王二子师子及师子意者。今何所在。为于现世供养诸佛。为已灭度在他世耶。佛言不空见。汝知。尔时王子师子意者。今此弥勒菩萨摩诃萨是。尔时王子师子者。即汝不空见菩萨是也。以汝于彼宝聚如来佛法之中。发大誓愿一舍身故。能令三万天人大众。发阿耨多罗三藐三菩提心。彼辈终必证大菩提无有疑也。尔时世尊为重宣此义。以偈颂曰

  我观过去久远劫　　佛号宝聚无上尊
  无师自觉现世间　　能益天人群生类
  具足百福金色相　　慈心显发实义门
  开示众生菩提路　　吼唱能尽众苦源
  宝聚挺特人中胜　　七十二亿众圣贤
  三明六通具八解　　随佛入城而分卫
  我于今日为胜王　　无边精进大威力
  恒将二子从左右　　因巡游观处高楼
  遥见调伏大仙神　　比丘僧众悉围绕
  我时及子趋疾下　　驰诣无等尊胜前
  既至大师善逝所　　施设诸种妙供具
  顶礼尊足口发言　　启请如来及僧众
  衣食众具尽形奉　　满足八万四千年
  并是二子净信心　　为求无上菩提故
  人中极尊既涅槃　　兴起八万四千塔
  众宝间厕奇光耀　　但为人宝遗余身
  一一城中宝塔所　　各然无量百千灯
  香华音乐鼓钟铃　　彼王为佛兴斯供
  因种如是胜善根　　次第遭遇六万佛
  悉皆供养亲承事　　为求无上大菩提
  汝不空见勿复疑　　曩时统领大地主
  彼深智王我身是　　其号无边精进力
  常以华香修供养　　教化一切诸众生
  具然无量百千灯　　为世除闇作光明
  施与财宝未曾休　　听闻正法亦无厌
  精进苦行不暂舍　　为证无上大涅槃
  汝于宝聚如来所　　以衣缠身火洞然
  犹如灯炷涂膏油　　须臾火至即[火*韱]烬
  汝时身火炽焰盛　　毛色无动神不惊
  于彼人宝灭度日　　尔躬如是为世间
  猛火如斯煎迫时　　汝犹方便而劝请
  愿见世尊从火起　　大悲护世现本形
  我今所愿成就者　　方得如意舍身命
  但能暂见如往昔　　所获功德不思议
  我凡所有诸誓言　　冀其一切皆和会
  若我当来必成佛　　愿于猛焰见世尊
  佛智清净无障碍　　于彼三世坦然平
  照明师子淳净心　　佛以精诚从火现
  不空见此愿力持　　护世须臾应念起
  因兹更发庄严誓　　不思议愿实难量
  世尊从彼火起时　　一切皆得厌离心
  又以净意发赞音　　佛威希有难可测
  无边相好火盛然　　法王应念忽便起
  以佛世尊现神变　　千数众得解脱心
  汝不空见知师子　　大慈应感忽还坐
  由见世尊此神变　　千数众发菩提心
  大悲为世利益已　　还复偃卧猛火中
  师子于是放舍身　　一念往生大梵处
  即从梵宫还佛所　　具足供养人中尊
  奉持微妙天华香　　投散彼佛碎身地
  彼宝聚尊涅槃后　　其间时节无几何
  复有普密天人师　　为利世间故兴世
  坐于道树等至真　　是天中天号大觉
  大梵天王设供养　　恭敬顶礼两足尊
  请转法轮利世间　　佛知心净默然许
  梵王闻法大欢庆　　身得安乐心怡然
  更发殊常大誓愿　　植不思议众善根
  一劫值遇五千佛　　皆得亲承兴供养
  智者不应更他疑　　彼时师子汝即是
  不空见时为吾息　　汝后事佛经五千
  我皆明见汝烧身　　求斯无上菩提道
  汝复无量千佛所　　于彼灭度舍利时
  亦烧无量所爱躯　　皆为他乐自受苦
  我知汝今及异世　　无量千生长时修
  或佛现在或涅槃　　汝常建斯诚实语
  经昔无量百千生　　惟我神力能知汝
  不空汝久发斯愿　　果报今者皆明现
  汝于诸佛大师前　　不思议行悉圆满
  常业歌赞两足尊　　苦行熏修诸大誓
  今获偈叹大法王　　斯由往积胜因缘
  又于普密王佛前　　摄取最上无边愿
  汝今果获如斯报　　蒙佛如来现威神
  时不空见于众所　　恭敬合掌顶礼佛
  请问天尊调御师　　慈悲利益众生事
  大仙我曾何誓愿　　而能舍弃无量生
  惟愿世尊开少分　　我蒙圣说乃能了
  不空汝于往昔事　　吾今为汝粗说之
  汝于云音如来所　　已发如是广大愿
  诸佛若证菩提时　　当今我身常奉觐
  又于帝幢普眼佛　　彼时亦发大誓愿
  世间若有最导师　　当令我即同斯道
  汝于日灯如来所　　亦发胜妙诸行愿
  汝不空见惟我知　　造作众宝经行处
  或营壮丽佛精舍　　若构殊异僧伽蓝
  彼皆微妙七宝成　　一切资具奉诸佛
  于不思议众所尊　　人中师子善生佛
  持七宝盖及众具　　供奉超世天中天
  于彼普眼如来所　　尔时又起妙愿行
  广施灯明众供调　　奉献世间天人师
  汝于如是无量佛　　过千万亿那由他
  自受勤苦安众生　　发彼庄严弘广誓
  汝于普密王佛前　　所发诚愿我今说
  如其修行成佛者　　我所散华遍大地
  汝于云雷音佛所　　为世间故发斯愿
  若有众生闻我名　　愿彼咸即成佛道
  复于帝释幢佛前　　广兴供养因誓愿
  凡我所处若见闻　　彼彼皆得成佛道
  汝于日灯如来所　　奉施七宝经行处
  无边威所大明佛　　汝当尔时发愿言
  常施胜处妙庄严　　愿我佛刹亦如是
  汝于月上如来所　　愿得第一最天宫
  佛尊处中而游化　　众生游者悉成佛
  汝于澡浴善逝前　　实作如是至诚愿
  若于夏日盛暑时　　众生身心离热恼
  汝于鸯只罗佛所　　亦发如是增上愿
  恒于长夜黑闇时　　愿施灯明除迷惑
  若我舍施身命处　　其有食肉诸众生
  必皆成佛无有疑　　非彼现在身证者
  或于觉悟及梦里　　若有众生闻我名
  一切成佛无有疑　　非彼现在身证者
  汝于勇猛精进时　　其有爱憎尔所作
  斯等皆当成法王　　非彼现在得证者
  汝先无量世生处　　于彼恒愿求菩提
  我今说汝实功德　　当来必获无上尊
  若有禽兽及余众　　彼必成佛无复疑
  诸是食汝身肉等　　一切自然证法身
  我知汝有千数行　　皆为利益诸众生
  若有闻者或生疑　　以时未至我不说
  凡我所说汝诸事　　其或众生愿乐闻
  彼彼得佛必无疑　　非余现在身证者
  若人欲见救世尊　　转此清净胜法轮
  闻已能破诸苦恼　　为证菩提故乐闻
  若人欲见三世佛　　恭敬供养上福田
  具足积聚诸功德　　必先受持此三昧
  为利世间天人故　　世尊宣说是事已
  遂下法座而徐行　　即还归寂于本室

大方等大集经菩萨念佛三昧分卷第二大方等大集经菩萨念佛三昧分卷第三

        隋天竺三藏达磨笈多译

    神变品第三

尔时尊者舍利弗。尊者大目干连。尊者大迦叶。尊者阿难。及诸天人梵魔沙门婆罗门等。咸作是念。何因何缘。今我世尊如来应供等正觉。在于天人大众中。为诸梵魔沙门婆罗门诸龙夜叉乾闼婆阿修罗。及以人非人等。宣说如斯念佛三昧法门名已。而未解释。即从坐起还本住处默然寂坐耶。尔时不空见菩萨摩诃萨如是思惟。今此天人梵魔沙门婆罗门。及彼一切诸龙夜叉乾闼婆等。大众咸集而我世尊本处入定。我今亦应少现神通。现神通已。为令种种称叹世尊大慈功行。尔时不空见菩萨摩诃萨。如是思惟已即入三昧。三昧力故令此三千大千世界庄严微妙。凡诸所有皆七宝成。所谓金银琉璃颇梨马瑙车磲珊瑚真珠。如是众宝之所严饰。其地平正犹如手掌。一切大地咸有如是宝。诸多罗树八道间错罗布其中。彼等诸树端严可爱。金多罗树白银叶华。银多罗树琉璃叶华。琉璃树者颇梨叶华。颇梨树者马瑙叶华。马瑙树者车磲叶华。车磲树者真珠叶华。赤真珠树黄金叶花。如是处处悬缯彩盖。垂诸金铃宝网罗覆建布幢幡皆用杂宝。复以种种微妙庄严周匝围绕世尊住处。一切多是可爱众花。所谓优钵罗花。波头摩花。拘物头花。分陀利花。如是等花。皆悉充满于此世界。具足庄严清净微妙其事亦尔。尔时不空见菩萨摩诃萨。三昧力故复现如是庄严之事。令此三千大千世界所有大众。乃至天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切众。故化作众宝大莲花座。其花具有无量千叶清净柔软。譬若迦耶邻尼天衣。令诸众生各相见知彼此。咸得坐于花座。尔时不空见菩萨摩诃萨。复于定中更现如是大神通事。令此三千大千世界一切大地六种震动。所谓动遍动等遍动。涌遍涌等遍涌。起遍起等遍起。震遍震等遍震。吼遍吼等遍吼。觉遍觉等遍觉。是六各三合十八相。如是乃至中涌边没边涌中没。犹如摩伽陀国赤圆铜钵。置于石上倾转不定自然出声。如此三千大千世界。不扣不击自然出声。其事若此当震吼时。彼诸众生闻声觉悟者。一切皆受上妙触乐。犹如东方不动世界。亦如西方安乐国土。其中众生等受快乐。闻声获安亦复如是。尔时不空见菩萨摩诃萨。住三昧故。心转清净无有垢浊。随顺调柔远离粗犷寂无变动。心深润泽普令安乐。然后复作如是神通。令此三千大千世界。遍虚空中雨炽然火。不令灭坏众生身心而彼众生蒙火触身。皆得受斯微妙胜乐。犹如比丘入火三昧恬然安乐。触火众生怡悦亦尔尔时不空见菩萨摩诃萨。以三昧力复作如是大神通事。令此三千大千世界。雨天栴檀细末之香。其香微妙遍满三千大千世界。若彼众生闻此香者。皆得如是第一胜乐。犹如释迦如来应供等正觉。其于往昔行菩萨时。在彼然灯佛世尊前。受菩提记已。得不思议希有妙乐。时诸众生闻天妙香。不思议乐遍满身心亦复若此

尔时众中尊者阿难作如是念。今何因缘忽见如是不可思议希有庄严。此大神变谁所致乎。然我世尊还房宴寂。不当若是斯大神通。岂我诸大声闻众中所能作耶。为此会众多诸大人犹如龙象。或其所作得非弥勒菩萨。文殊师利菩萨。越三界菩萨。乃至不空见等。亦或是余诸大菩萨摩诃萨辈。具足威光现斯事耳。尔时尊者阿难如是念已。即白尊者大目连言。大德。我闻世尊常如是说。我弟子中神通第一则目连其人也。今现是瑞将无大德之所为乎。时大目连答阿难言。仁者此瑞殊常非我能作。所以者何。忆念我昔于一时间。取此三千大千世界悉内口中。其时众生乃至无有一念惊惧觉往来想。阿难。又念我昔住梵天宫发一大声。遍此三千大千世界。阿难。复念我昔在世尊前作师子吼。能以须弥内于口中。能过一劫若减一劫如是为常。阿难。又念我昔至阳炎世界。于彼发声遍此世界咸得闻知。阿难。又念我昔身住于此阎浮提界而能遥动忉利天宫难胜大殿。阿难。又念我昔至彼难陀优波难陀诸龙王所。彼龙如是炎炽巨毒我时降伏令住戒善。又亦曾辱恶魔波旬。阿难。我念往昔至于东方。住彼第三千世界。有一大城名曰宝门。于彼凡有六万亿千家人。我即于彼六万亿千家中。一一皆现我目连身。为彼众生演说诸法无常苦空无我。皆令安住如是正法。阿难我虽能为曩之变化。初未曾见如是神变。云何作耶。阿难。今我处此大莲华座。观见十方一一佛土无量无边。同我世尊释迦号者。皆还本室默然寂坐。而我见彼诸佛国土。亦如观此娑婆世界。阿难。我于向时亦以天眼。周遍观察是变因缘。而终弗知所从来处。尔时大目连为重明此义。以偈颂曰

  我所成就四神足　　同类孰能相挍比
  唯独世尊天人师　　余人神通宁我及
  我曾吞合此佛刹　　大地众生弗觉知
  我又曾至梵天宫　　一音充满此世界
  我又曾于世尊前　　吞啖须弥若经劫
  我又炎界发大声　　令此佛刹遍闻听
  我又震动天帝宫　　彼于天女众中坐
  我又往诣难陀所　　降伏如斯大毒龙
  我又念昔作神变　　身住于此现东方
  我令六万亿千家　　彼彼各谓见我身
  阿难我今所观变　　初未睹是大神通
  我唯生大希有心　　然是神通非我作
  我今处大莲花座　　亦见众生坐花中
  复见诸佛大威王　　观察尽于十方界
  决定自在天尊作　　或能大士之所为
  如是非常大神变　　昔来未见今方睹

尔时尊者大目干连。作如是等师子吼。时彼大众中十千天人。于诸法中得清净眼

尔时阿难白尊者舍利弗言。大德。我亲从佛闻如是言。我诸声闻大弟子中智慧第一。则舍利弗其人也。今此神变将非大德之所作乎。时舍利弗语阿难言。阿难。此瑞殊常非我所及。所以者何。我念自从二十年来。精勤修习毗婆舍那。一心观察求法实相。终不能知诸法边际。阿难。又念我昔取一袈裟投置地上。时大目连第一上座。威神若是既不能取。乃至不能举令离地。何云手擎。阿难。又念我昔居世尊前作师子吼。亦于一切具足神通诸大声闻及学无学。天人梵魔沙门婆罗门。乃至一切诸龙夜叉乾闼婆阿修罗等诸大众前。时彼外道波梨波阇来至我所。与我诤入诸禅定已。复欲共我较隐其身竞师子吼。我于彼时。建丈夫志行丈夫事。遂作如此诸不思议。唯除世尊一切知见。及以弥勒菩萨摩诃萨。诸是一生补处者。又除彼成就甚深法忍诸菩萨摩诃萨。又除得海德三昧诸菩萨摩诃萨。又除得善住三昧诸菩萨摩诃萨。又除得诸佛现前三昧菩萨摩诃萨。除如是等诸大菩萨摩诃萨已。自外所有如来世尊声闻大弟子。若来问我隐身时事。乃至外道波梨波阇等。而更问我隐没身时为住何处者。阿难。我作如是大神变时。一切声闻设辟支佛。皆不能知我身所在。及其说时空闻我声。终不能知我身所在。阿难。我常精勤大丈夫行。亦复成就大智人事也。阿难。我心随我行非我随心行。阿难。我今自知身处大莲花座。亦见一切天人大众皆悉坐彼大莲花座。阿难。我复见彼一切十方无量无边不可思议诸世界中。皆有诸佛世尊。悉在菩提树下坐于道场成等正觉。具足成就无量无边大威德力。诸天大众恭敬围绕。大梵天王请转法轮曰。世尊。若当转法轮者我等随顺。阿难。我闻是声我见是事。今者如是无量无边诸佛国土。皆是七宝杂色缯彩悬诸金铃。罗网覆上种种宫殿微妙庄严。如此娑婆世界。阿难。我于向时亦作是念。今此不思议大庄严事。将非世尊大神通作乎。或是诸大菩萨摩诃萨辈。厚集善根具足福智。能现若斯大神变耳。亦或世尊声闻众中诸大弟子。久种善根具大威德之所为也。尔时尊者舍利弗为重明此义。以偈颂曰

  世尊神力难思议　　及求如来功德者
  所有声闻大弟子　　满此佛刹学无学
  于彼智中我第一　　何云更有胜我者
  唯除诸佛如来辈　　及诸菩萨行菩提
  自我观察诸法相　　具足满于二十年
  求诸法底不得边　　我之智慧过于彼
  今者在佛世尊前　　欲以此智师子吼
  且置一切诸外道　　唯大声闻求我身
  终无有能见我身　　及以所作诸神变
  唯除如来等正觉　　并诸佛子大菩萨
  是乃知我身所在　　非彼外道及声闻
  禅定解脱不思议　　是心任我而回转
  我修丈夫真空行　　仁者我业常如是
  我有如是胜神通　　一切声闻不能入
  然我今所见十方　　若斯神力我贪羡
  我今处大莲华座　　遍见诸方无量土
  无量刹中咸有佛　　各诣佛树坐道场
  彼刹众宝异庄严　　端正微妙甚可爱
  我时亦作如是念　　决定如来现神通
  或大弟子之所为　　或诸菩萨不空见

尔时尊者舍利弗。作如是师子吼。时众中有一万三千人。远尘离垢得法眼净

尔时阿难如是思惟。此大迦叶。有大威德具足神通。今是变化或其所作。我今亦当问其作不。于是阿难即白尊者摩诃迦叶言。大德。我亲从佛闻如是说。我弟子中头陀第一。则大迦叶其人也。是不思议大神变事。将非大德之所为乎。时大迦叶答阿难言。仁者。此变殊常非我能作。所以者何。我念一时辄不自量。在世尊前作师子吼。阿难。我时于此三千大千世界。须弥山王及大铁围。乃至诸余黑山之属。一以口吹能令破散。乃使无有如微尘许。其有众生住彼山者。不令损害亦无觉知。如是诸山皆悉灭也。阿难。我又一时于此三千大千世界。一切大海大河小河陂池诸水。乃至无量亿那由他百千水聚。以口一吹皆令干竭。而彼众生不知不觉亦无苦恼。阿难。我又一时在如来所。及诸天人梵魔沙门婆罗门。一切世间诸大众前。作师子吼广现神通。阿难。我今唯有如斯威力。能作如是自在神通。阿难。我念一时在于如来应供等正觉前。为诸世间天人梵魔沙门婆罗门一切大众。作师子吼。世尊。我能于此三千大千世界之内。以口一吹即令大火炽然遍满犹如劫烧终亦不使损一众生。亦令众生竟不觉知。阿难。我真具足如是神通。阿难。我念一时于此世界。以天眼观见彼东方过亿百千世界。有一佛刹猛火洞然。我既见已如是思惟。而我今应示现神通。既思惟已即入三昧。于三昧中以口一吹过于东方千亿世界。炽然猛火即令熸灭。彼火灭已我便出定。即见彼界还复如本。阿难。我今但有如是神力。阿难。今此众中有诸众生。若天若人若梵若魔若沙门婆罗门多有疑心。谓我妄言彼若不信。世尊后时从三昧起。任自咨问。而今世尊。虽入三昧足知是事亦闻我声。尔时世尊。尚坐本处住三昧中。遥命阿难曰。如是如是。如大迦叶师子吼说。真实非虚汝当忆持。时诸天人一切大众闻佛教已。方于迦叶生希有心起难遭想。时彼尊者摩诃迦叶。作如是等师子吼时。有三亿人于诸法中远尘离垢。复有八十五那由他百千诸天。远尘离垢得法眼净

尔时不空见菩萨。弥勒菩萨。文殊师利菩萨。越三界菩萨。如是及余无量无边诸大菩萨摩诃萨等。皆自久来被服如是大弘誓铠。闻大迦叶作师子吼。便化华聚若须弥山。乃至再三散迦叶上。复多化作大七宝盖。住虚空中覆大迦叶顶。并覆一切声闻大众。尔时大迦叶见如是等诸七宝盖。遂告阿难曰。阿难。今此众中决定知有大乘高行菩萨摩诃萨。能作如是大神通事。而今复现斯大神变也。阿难。我今坐此大莲华座。所见诸方无量无边不可称数诸佛世尊。又见彼刹皆七宝成。殊丽庄严真可瞻睹。彼诸众生复有如是胜上果报。我今悉见犹如忉利。一切诸天耽醉花冠常带璎珞。诸天身色如月光明。于虚空中有化宝盖。彼诸众生一一顶上悉有宝盖。如我顶上覆七宝盖无别异也阿难。我又见彼诸佛刹土。有诸菩萨自兜率天降入母胎。阿难。我见如是神通事时。深生欢喜踊跃无量。阿难。我复思念如是奇异如是希有。岂彼随宜凡劣众生能作如是大师子吼。能现如是大神通事。尔时尊者大迦叶为重明此义。以偈颂曰

  阿难十方大水聚　　大海巨河诸流等
  我以口风一往吹　　令彼枯竭无遗渧
  曾住正觉世尊所　　于此刹中作神变
  我能干涸水聚时　　众生无损亦不觉
  此界所有一切山　　须弥铁围黑山等
  能以口风吹令散　　仁者我住如是通
  众生所有住须弥　　及余诸山不动处
  尔时令彼无损觉　　智者我有如是通
  我以神通烧此刹　　口风一吹皆炽然
  彼等众生不觉知　　当尔之时无毁坏
  我昔于此佛刹中　　遥见东方满刹火
  用口气吹能灭彼　　我通如是难思议
  我今见此大神通　　心生殊特大希有
  诸佛弟子不思议　　一切诸行亦如是
  我今处此莲华上　　观彼众刹妙庄严
  菩萨降自兜率天　　入于母胎尽生际
  为当定此声闻辈　　心得自在神通人
  为是菩萨不空见　　复彼弥勒文殊等

尔时阿难复作是念。此富楼那弥多罗尼子。于一切法已到彼岸。有大威德具足神通。或时能作如是大事。我今亦应问其作不。尊者阿难如是念已。即便白彼富楼那言。大德。我亲从佛闻如是语。我大声闻诸弟子中说法第一。则富楼那弥多罗尼子其人也。是不思议庄严神瑞。将非大德之所为乎。时富楼那答阿难曰。此瑞异常非我能及。所以者何。我念昔时有诸众生。应以神通得教化者。我便为彼取此三千大千世界。以手摩之开示彼等。当尔之时无一众生有惊怕想亦不觉知。唯彼众生应在此化与神通者。乃能见我手摩世界。阿难譬如壮士以右手。取一迦梨沙般那。左手回转不以为难。如是阿难。我取于此三千世界。以手回转不以为难。亦复若此。阿难。我念一时于世尊前。以一指节取此三千大千世界一切水聚。皆令入我手指节间。无一众生有损减想。阿难。我往一时于初夜中。以净天眼过于人眼。观此三千大千世界。作如是念。是中复有何等众生。于诸法中心生疑惑。我当解释令得除断。我即观此三千大千世界。所有一切诸四天下无量众生疑惑诸法。我复生念我今应当不离是坐不出是定。为诸众生断除疑网。阿难。我时念已。便入定心清净明了。光泽成就寂然不动。为彼众生宣说诸法。决断疑网无有滞碍。令彼众生各作斯念。我等今者皆各蒙此尊者富楼那弥多罗尼子。独住我前为我宣说。阿难。我当初夜说法之时。即有一万四千众生。皆得安住佛正法中。复有三万众生护持禁戒。复令六万众生信佛法僧归依三宝。然始安详自三昧起。阿难。我唯有是说法余功决疑事也。阿难。我又复念于此世界。以天眼观见彼北方。过三万佛刹有一世界。其号伏怨。彼世界中有一众生。于诸法中多起疑网。时彼众生有声闻根易可受化。然彼世尊般涅槃已。我即生念我今亦应不起此坐不往彼刹。而为众生解释疑网。如是念已即入三昧。于三昧中为彼世界无量无边不可称数。阿僧祇诸众生辈。演说正法。令彼皆得诸法光明。阿难。我但具是声闻神通。今此众中若有疑者。须世尊出请问自知。如是语时。佛神力故虚空出声。告阿难曰。阿难。如是如是。如富楼那大师子吼。汝当忆持。尔时诸天世人阿修罗等。一切大众闻是事已。发希有心生奇特想。作如是言。希有希有。声闻尚能建斯大事。况彼菩萨诸佛世尊。尔时尊者富楼那弥多罗尼子。为重明此义。以偈颂曰

  我于说事悉通达　　诸漏有生皆灭除
  望佛如来无分毫　　大尊神变独超世
  我取此界及诸山　　以手回转亦摩抹
  彼时不动一众生　　我但有斯神通力
  三千世界诸水聚　　此刹若见若不闻
  我内彼水一指间　　于诸众生无损减
  我于初夜天眼观　　何等众生心疑惑
  求其善根及诸法　　欲以神力为决除
  我于如是生念时　　不离本坐亦无往
  已为宣说正道法　　令彼得闻破心疑
  我于如是说法时　　令万四千住圣法
  三万诸人护禁戒　　六万正信受三归
  我复念彼初夜时　　所出神通甚微妙
  观过北方三万界　　见一佛刹名伏怨
  彼佛界中诸众生　　独有一人深疑惑
  我时不起现彼说　　令彼各谓己独闻
  阿难我智正若此　　如是神通佛自知
  众生若有疑惑者　　但当决定请世尊
  我今坐斯莲华上　　见一世尊般涅槃
  彼佛处火就阇维　　自外诸方亦皆尔
  我心观佛生希有　　是不可测谁所为
  为是世尊为声闻　　而我见佛斯灭度

尔时阿难复如是念。彼尊者罗睺罗。世尊之子。于一切法已度彼岸。有大威德具大神通。或时能作如斯大事。我今亦当问其作不。尊者阿难作是念已。即便白彼罗睺罗。大德。我亲从佛闻如是言。我诸声闻大弟子中持戒第一。则罗云其人也。是不思议庄严神变。将非大德之所为乎。时罗睺罗答阿难曰。阿难。世尊大悲普覆一切。虽称赞我持戒精进具足神通。然而今者所现神变事。特非常不可测度。我从生来未尝见睹。亦未思惟又无分别。况复能为如斯神变。阿难。是大庄严实非我作。所以者何。我念往昔唯此三千大千世界广大若是。所谓百亿四天下。百亿日月。百亿大海。百亿须弥山。百亿大铁围山。如是及余黑山之类。一切皆纳一毛孔中。当尔之时我身如本。众生不异。诸四天下所有大地。须弥诸山乃至大海及以众流。咸皆安隐无相枨触。一切无有逼迫损伤。阿难。我但有是自在神力。阿难。我昔一时取此三千大千世界所有大海。及余小海大河小河。乃至陂池微细水聚。如是一切悉入毛孔。当尔之时我身无损众生无害。诸大海水及与河流。乃至陂池细微水聚。各皆如本无相漂迫。所居皆知身在水中阿难。我昔一时此处入禅既入定已。即于东北至一世界。彼佛世尊号难胜威。如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊所。现身礼敬。敬已即复还此世界迦维罗城净饭王前。求索一掬栴檀末香。得已还持。于彼佛刹供养世尊。香气遍满。时即为彼难胜威佛。化作楼观像辇。分明高万由旬。一切妙宝庄严间错。复以天香为七宝盖覆佛顶上。高一万亿八千由旬广八千由旬。又于彼界为一切众生。各各化作栴檀楼观像辇。高百由旬广五十由旬。四柱方整随意所乐。令彼众生备具庄严。各皆自有无相障碍。阿难。我但如是究竟声闻神通彼岸。今此众中若有于我生疑惑者任咨世尊。世尊虽处寂定尚当证知。尔时罗睺罗欲重宣此义。而说偈曰

  我曾取此三千界　　百亿四天与铁围
  一切悉入毛孔中　　阿难我有如斯力
  此阎浮提如是大　　彼彼各住不相知
  一切皆入毛孔中　　阿难是我神通力
  此须弥山甚高广　　铁围众山不随宜
  皆悉置一毛孔中　　阿难知我神通力
  彼等皆各无迫触　　而见入我一毛中
  时我身体不觉疲　　彼亦不知处毛道
  三千大千诸水聚　　众流陂河及大海
  一时吸之置毛孔　　我但有是大神通
  此界如是众水聚　　大海诸河及细流
  彼等皆各不相知　　而我能令入毛孔
  阿难我此神通事　　昔曾数现世尊前
  此众如有疑惑人　　当问如来无碍眼
  阿难我处大莲花　　见彼十方诸菩萨
  舍施头目及妻子　　悉祈无上菩提尊
  我见神变生希有　　决为世尊之所为
  或不空见弥勒辈　　亦或声闻大弟子

尔时尊者罗睺罗。作如是等师子吼。时彼大众中有八十七亿百千那由他诸天人等。远尘离垢得法眼净。是诸天人得法证已。以天栴檀末香。殷勤再三散于尊者罗睺罗上。如是供养已复发是言。希有希有。清净佛子真行大乘已。于诸法种众善根。今能如是大师子孔

大方等大集经菩萨念佛三昧分卷第三大方等大集经菩萨念佛三昧分卷第四

        隋天竺三藏达磨笈多译

    神变品之余

尔时阿难复作是念。彼尊者须菩提。善修无诤行。于一切法已到彼岸。有大威德具足神通。或能为是不思议变。我今应当问其作不。时彼阿难如是念已。而复白彼须菩提言。大德。我亲从佛闻如是说。我诸声闻大弟子中解空第一。则须菩提其人也。是不思议大庄严事。将非大德之所作乎。时须菩提答阿难曰。阿难。世尊虽说我修无诤空行第一。然是神通非我能作。所以者何。我念一时入于三昧。如此三千大千世界弘广若斯。置一毛端往来旋转如陶家轮。当尔之时无一众生有惊惧心。亦不觉知己之所处。阿难。我念往昔于如来前。欲作如是大师子吼白言。世尊。如此三千大千世界宽广如是。我能以口微气一吹皆令散灭。复令其中所有众生不惊不迫无往来想。阿难。我于尔时在世尊前。已曾示现如是神通。阿难。我念一时复于佛前作师子吼白言。世尊。我今能以如此三千大千世界。其间所有一切众生。皆悉安置一指节端上至有顶。然后还来住于本处。令彼众生寂然无声。不相逼迫无往返想。阿难。我念一时宴坐三昧。见彼东方现前则有六万诸佛。如是南西北方四维上下无量无边百千世界。各有六万诸佛世尊。昔所未见今皆见知。阿难。我于彼时住阎浮提。以是定心复发神力。至须弥顶天帝释边。撮取一掬栴檀末香。往彼无量诸世界中。供养向时尔许如来应供等正觉。彼彼世界诸众生等。皆悉明了见我住是阎浮提界。供养承事彼诸世尊。知我是此娑婆世界释迦牟尼如来应供等正觉。声闻大弟子上座须菩提。于空无诤三昧门中最第一者。阿难。我到如是神通彼岸。具足成就神通波罗蜜。阿难。今此众中若天若人若梵若魔若沙门婆罗门等。于我所说尚有疑心。彼若能问我师世尊。今在寂定自当证知。尔时佛神力故。于虚空中出大音声。命阿难曰。阿难。如是如是。如上座须菩提向师子吼。汝如是持。时彼天人梵魔沙门婆罗门阿修罗等。见闻是已身毛皆竖。发希有心得未曾有。作如是言。甚为希有。实未曾睹如是大事。乃至世尊诸弟子等。尚有如是胜妙神通大威德力。何况诸佛所有三昧神通境界。而可思量而可宣说。尔时尊者须菩提。见诸世间天人梵魔沙门婆罗门生希有已。为重明此义以偈颂曰

  我住禅定解脱门　　无诤三昧最第一
  我昔曾于世尊所　　现神通力无有边
  我转三千世界地　　一切令入毛道中
  如彼陶轮无穷已　　众生安然不觉往
  我昔住于如来前　　分散诸山及大地
  时彼众生无损减　　以住如是神通门
  我以此界及众生　　皆置掌中入后顶
  乃至还下彼不觉　　一切咸是斯神通
  我曾入定观东方　　见彼六万诸世尊
  南西北方亦如是　　六万如来无有阙
  又彼四维及上下　　诸佛亦足六十千
  平等具相金色身　　我以天香而遍散
  令彼众生悉知见　　各言我有须菩提
  亦领此界牟尼尊　　声闻禅中最第一
  我今作此师子吼　　时众若疑当问佛
  佛放大声诫告曰　　如是阿难汝受持
  我灭众生及我心　　乃至佛想无遗行
  无诤空行无伦比　　我实住此三摩提

    菩萨念佛三昧分弥勒神通品第四

尔时弥勒菩萨作如是念。今者世尊诸大声闻弟子众辈。有大威德具足神通。各皆自陈师子吼事。如我今者亦应于此一切世间天人梵魔沙门婆罗门诸大众前。少现菩萨神通事耳。时彼弥勒菩萨如是念已即告尊者阿难曰。我念昔曾于晨朝时。着衣持钵诣世尊所。顶礼佛足白言。世尊。我今欲入此王舍城如法求食。言已即行。阿难。我于尔日复如斯念。今于谁家初施食者。我要当令是人先住阿耨多罗三藐三菩提。然后方受斯人食也。阿难。我时念已即入大城次第乞食。至一大姓婆罗门家。于彼门下默然立住。阿难。时彼大姓施婆罗门。知我乞食见我默住。即告我言。善来阿逸多。圣者阿逸多。今日何故自屈临此。其有所须愿取我食。阿难。我即告彼婆罗门言。大婆罗门。汝今若能于阿耨多罗三藐三菩提种善根者。然后乃当受汝施食。阿难。时婆罗门即答我言。仁今若能持此食分遍奉十方恒河沙等一切诸如来应供等正觉者。然后我当发阿耨多罗三藐三菩提心。尽力勤修诸菩萨行。所以者何。我亦先于诸如来所。种彼一切诸善根故阿难。我时复语婆罗门言。大婆罗门。汝今必能建立斯志。我当受食分布供养恒沙如来阿罗诃三藐三佛陀。无有疑也。时婆罗门复语我言。圣者阿逸多。但受我食分张奉献恒沙如来。我便发誓亦如誓行。阿难。我复语彼婆罗门言。大婆罗门。汝今审能发如斯誓。如誓行者。我取汝食分散供养恒沙如来。阿难。彼婆罗门。乃至三反要我供养。我亦殷勤令其发心也。阿难。我时如是与婆罗门。反覆周旋相约束已。然后告彼婆罗门言大婆罗门。如汝言者。速将食来吾当为汝分布供养恒沙世尊。阿难。时婆罗门闻我言已。便授我食。我既受已。则于其前如弹指顷。分布供养恒沙如来。阿难。我于尔时分布彼食。供养恒沙诸世尊已。然后还彼婆罗门家。阿难。时婆罗门见我如是无碍神通。心生惊怪身毛皆竖。然后欢喜踊跃无量。即持种种上妙饮食。奉施于我劝我饱食。我时受已自恣食之。彼婆罗门然后方持一切珍宝。一切诸香一切众华。一切华鬘一切上妙诸璎珞具。与我相随诣世尊所。恭敬合掌顶礼佛足。即于佛前发阿耨多罗三藐三菩提心。复作是愿其有众生闻我施此抟食善根。皆即住于不退转地。世尊。若我此愿必得成就阿耨多罗三藐三菩提者。以此善根令我未来成菩提时。亦有如是无量无边诸声闻众。皆是清净大阿罗汉如今无异。若我此誓真实不虚者。以是因缘令此三千大千世界一切大地六种震动。而彼大婆罗门发是愿时。佛神力故。应时此间三千大千世界所有一切大地六种震动。阿难。今此众中若天若人于我此事生疑心者。世尊出时应当咨问。阿难。我今未成阿耨多罗三藐三菩提。已具如是大威德力。到于一切神通彼岸。阿难。我念往昔无量无边阿僧祇劫。有佛世尊号曰然灯如来应供等正觉。出现世间。我时于彼然灯佛前。获得如是一切菩萨念佛三昧。得三昧已。诸方所有一切诸佛现说法者。彼诸世尊常现在前。又我得此三昧门已。即于无量无边劫中。以此神通教化无量无边众生。悉令住于阿耨多罗三藐三菩提中。犹如今者王舍城中大婆罗门。阿难。复念往昔于彼莲华上如来应供等正觉所。以一神通教化成熟彼三万亿百千众生。皆令住于阿耨多罗三藐三菩提中。阿难。我又曾于最上不退转行佛世尊所。得一三昧名曰普明。得三昧已。教化成熟六万八千欲界诸天。皆令发于阿耨多罗三藐三菩提心。阿难。当如是知菩萨摩诃萨一切皆有不可思议大神通力第一彼岸。尔时弥勒菩萨摩诃萨。为重明此义。而说颂曰

  我曾晨朝整衣钵　　请问释师教明行
  于是顶礼辞如来　　世尊我今将求食
  大师如是诫我曰　　汝去当念利众生
  我涅槃后汝成佛　　诸种功德皆圆满
  阿难我时如是念　　未知今往前食所
  当于谁家初受食　　我应教令住菩提
  我行乞食有所遇　　遂逢大姓婆罗门
  以恭敬心称善来　　希有远至阿逸多
  我今自悔仁来晚　　唯愿时坐受我食
  大士妙法难思议　　我当奉上精美膳
  我时语彼婆罗门　　汝能先发菩提意
  利益天人大众等　　然后我方受汝食
  彼婆罗门复要我　　汝阿逸多今若能
  以我此供恒沙尊　　如是我发菩提志
  我便许彼婆罗门　　汝于菩提慎莫退
  吾以汝供奉诸佛　　终令汝身获大果
  时婆罗门更诚誓　　愿为我奉诸如来
  诸佛胜尊若受者　　我行菩提无疑惑
  彼婆罗门信我言　　发诚至心受我食
  我持彼供恒沙尊　　令婆罗门须臾见
  彼既睹我大神通　　或惊或喜增珍膳
  供养我毕至佛所　　便发无上菩提心
  时婆罗门发心已　　复广弘誓不思议
  若有菩萨得闻者　　彼于世界速成佛
  我昔在佛然灯前　　得此微妙胜三昧
  彼名菩萨念诸佛　　能与妙乐难称量
  昔于然灯世尊所　　受此胜念三昧时
  我登得见十方佛　　以彼威德故能睹
  若人住此三昧中　　能现无边诸神变
  百僧祇劫诸所作　　皆为利益诸众生
  我于莲华上佛所　　得三昧故现神通
  满足七万诸众生　　皆因我住菩提道
  我又最上如来前　　于彼精勤修梵行
  所得三昧实端生　　能施深乐难称量
  我于最上行佛所　　受一三昧名普明
  月上佛时住胜禅　　迦叶佛前获深定
  阿难如是大神通　　皆于往昔得成就
  以此神通自在力　　我所修见诸如来
  若人欲见诸世尊　　欲转无上妙法轮
  欲拔众生出苦海　　是人应学斯妙定

尔时众中梵魔沙门婆罗门天人阿修罗一切世间。得闻弥勒菩萨摩诃萨师子吼时。皆大欢喜生奇特心叹未曾有

    菩萨念佛三昧分叹佛妙音胜辩品第五之一

尔时不空见菩萨摩诃萨。睹诸大众天人梵魔沙门婆罗门。诸龙夜叉乾闼婆阿修罗等。得未曾有生奇特心。或时惊怖身毛皆竖。见是事故。一心安详从三昧起已。即告尊者阿难言。大德。善哉妙哉。诸佛世尊甚为希有甚为希有。所以者何。诸如来应供等正觉乃至能有大慈大悲。具足无量诸功德等。阿难。诸如来应供等正觉能证。如是阿耨多罗三藐三菩提时。觉一切法无有生故。见一切法无有作故。知一切法不可得故。然后于彼波罗奈城。古仙住处鹿苑林中。三转十二行无上妙法轮。而是法轮初未曾见。一切世间若梵若魔若天若人若沙门婆罗门。有能如法为斯转者。何等名为三转法轮。云何复称十二行也。所谓此是苦。此是集。此苦灭。此苦灭道。乃至此苦已知。此集已断。此灭已证。此道已修是为三转。如是三转得名为十二行也。又此为八圣道分是中有无量文字。无量名句无量言音。无量义趣无量解释。然说斯义为开示故。为论义故为分别故。为显示深义故。为易知故为具足故。时彼不空见菩萨摩诃萨。复告尊者阿难言。阿难。是故我言诸佛世尊甚为希有。诸如来应供等正觉。有大慈悲具足功德。诸佛世尊既证得阿耨多罗三藐三菩提已。然后为诸声闻众等。于彼无教法中以教说故。无言法中以言说故。无相法中以相说故。无证得中教令证得彼法。虽无语言可说相貌可得。而诸智者皆已觉悟。诸贤善人亦得证知。诸阿罗汉咸得解脱于彼无始生死中也

复次阿难。譬如有人持一束草。言欲堰塞恒河大流。于意云何。彼人如是其事可乎。阿难答曰不也大士。何以故。彼人所作世间本无。何论可不。不空见言。如是阿难。如来应供等正觉。为诸声闻于无言法更以言宣。无名相中以名相说。其事若此。复次阿难。譬如有人本无口舌。欲以一音遍诸世界咸得闻知。于意云何。彼人所作其事可乎。阿难答曰。不也大士。何以故。彼人所作世间本无。何论可不。不空见言。如是阿难。如来应供等正觉。为诸声闻无言说中更以言宣。无名相法以名相说。其事亦尔。复次阿难。譬如有人手持彩笔书画虚空。望成文字。于意云何。彼人所作可成就乎。阿难答曰。不也大士。彼人所作世间亦无。何问成不。不空见言。如是阿难。如来应供等正觉。为诸声闻无言法中更以言宣。无名相法以名相说。其事若此。复次阿难。譬如有人先无手足。咒术伎能而大唱言。我能担负须弥山王。于意云何。彼人所作其可遂乎。阿难答曰。不也大士。是人所作世间既无。何问可不。不空见言。如是阿难。如来应供等正觉。为诸声闻无言法中更以言宣。无名相法以名相说。共义亦尔。复次阿难。亦如有人至大海际。或取一板或持小筏。或欲身涉或欲身浮。广施方便发如是言。我度大海登陟彼岸。于意云何。彼人所作为可尔乎。阿难答言。不也大士。一切世间本无斯事。何云可不。不空见言。如是阿难。如来应供等正觉。为诸声闻无言说中更以言宣。无名相法以名相说。其义若此。尔时不空见菩萨摩诃萨。为重明此义。以偈颂曰

  诸佛大慈难思议　　常以悲光照一切
  于无量亿那由劫　　正觉如是深法门
  诸法本性无生处　　因缘集会往来空
  无上天师虽善宣　　然彼自性常寂灭
  诸佛正法难称量　　世尊慈爱故宣演
  能开如是难见法　　利益世间诸天人
  不可说法难值闻　　十力雄猛能广说
  显示最上清凉道　　安隐世间天人众
  世尊巧说无相法　　无师自然能觉知
  破坏一切诸外道　　凡愚莫知此实际
  诸佛智海难测量　　宣说法界亦无尽
  一切声闻同已证　　开示转变不思议
  如人把草塞恒河　　尊者我谓不为难
  正觉转彼无生轮　　我持此事难于彼
  若人手执五色笔　　种种众彩画虚空
  无语言中置语言　　我持此事难于彼
  若人无手亦无足　　求负须弥度大海
  无相法中转相轮　　我谓此事难于彼
  若人无舌复无口　　一言遍满恒沙界
  无证法中能令证　　我谓斯事难于彼

尔时尊者不空见菩萨摩诃萨告阿难言。尊者。诸佛如来应供等正觉。甚为希有。能于无量阿僧祇劫。觉了通达一切诸法究竟彼岸号佛世尊。然诸如来应供等正觉。随顺众生诸根差别乐欲所应。微妙圆音自然而出。普为宣说种种句门。所谓若诸众生乐行布施。如来则为赞说檀波罗蜜。彼亦随念世尊为我宣说施法。有诸众生乐修禁戒。如来则为赞说尸波罗蜜。彼复生念世尊为我宣说戒法。有时众生乐行忍辱。如来则为赞说羼提波罗蜜。彼亦生念世尊为我宣说忍法。有时众生乐行精进。如来则为赞说毗梨耶波罗蜜。彼亦生念世尊宣说精进。或时众生乐习禅定。如来则为赞说禅波罗蜜。彼亦生念世尊为我宣说禅法。或时众生乐求智慧。如来则为赞说般若波罗蜜。彼亦生念世尊为我宣说智慧。或时众生乐求解脱。如来则为赞说解脱。彼亦生念世尊为我宣说解脱。或时众生乐修解脱知见。如来则为赞说解脱知见。彼亦生念世尊为我宣说解脱知见。或时众生乐生天者。如来则为赞说生天。彼亦生念世尊为我宣说生天。有诸众生乐修无常。如来则为赞说无常。彼亦生念世尊为我宣说无常。有诸众生乐修苦者。如来则为赞说众苦。彼亦生念世尊为我宣说苦法。有诸众生乐修无我。如来则为赞说无我。彼亦生念世尊为我宣无我法。有诸众生乐修空寂。如来则为赞说空法。彼亦生念世尊为我宣说空法。有诸众生乐修不净。如来则为赞说不净。彼亦生念世尊为我宣说不净。有诸众生乐欲生天。如来则为说生天法。彼亦生念世尊为我说生天法。尊者。乃至有诸众生乐种种法。如来则为说种种法。彼亦生念世尊为我说种种法。尔时不空见菩萨。欲重明此义。而说偈言

  诸佛世尊具圆音　　随众生类自然出
  彼之意乐所欲闻　　如来随顺说发起
  或有众生乐布施　　如来则为赞檀度
  或有众生乐持戒　　如来复为赞尸罗
  或有众生乐忍辱　　如来则为赞羼提
  若有众生乐精进　　如来为赞毗梨耶
  或有众生乐三昧　　如来则为赞禅定
  若彼众生乐智慧　　如来则为赞般若
  若彼众生乐解脱　　如来亦为赞解脱
  若彼众生修无常　　即令闻彼无常法
  彼若乐闻苦不净　　亦令闻苦不净音
  彼若乐闻空无我　　不思议音赞空寂
  彼若乐闻缘觉乘　　世师妙音说缘觉
  彼或乐闻诸佛乘　　两足尊赞菩提道
  乃至彼乐生天宫　　音中亦显生天事
  如是妙音难思议　　随诸类感便应现
  彼等既闻清净音　　其谁不趣菩提道

尔时不空见菩萨摩诃萨复告尊者阿难言。阿难。诸佛世尊殊特希有。如来应供等正觉。能有如是炽然善根。所以者何。诸佛世尊从久远来。乃能供养无量无边过恒沙数诸如来等。又复常行施忍精进诸事。所谓捐舍身命头目髓脑。难作能作种种苦行。调伏身心。然后方证阿耨多罗三藐三菩提。证菩提已。则能具足无量辩才为他说法云何辩才。谓不思议辩才。无上辩才。无胜辩才。无取着辩才。妙解脱辩才。无障碍辩才。善和合辩才。相应辩才。炽盛辩才。无有问辩才。豫知辩才。作相辩才。无作相辩才。静默然辩才。不怯弱辩才。除恚辩才。种种文字庄严辩才。种种词句庄严辩才。义句庄严辩才。甚深句庄严辩才。显现深义辩才。于深示浅易知辩才。无边譬喻辩才。捷疾辩才。善决疑辩才。成就无际辩才。能问辩才。略问广答辩才。利益辩才。无毁辩才。善思量辩才。无謇塞辩才。无耻辱辩才。具足成就离谤辩才。具足成就智人所赞辩才。具足无畏心辩才。具足不狭劣辩才。具足不错文句辩才。具足不忘辩才。具足无失辩才。具足随心说法辩才。具足知他至心为说辩才。具足开发无秽浊辩才。具足庄严音句能说辩才。具足能说过去辩才。具足能说未来辩才。具足能说现在辩才。具足圣者辩才。具足知无生妙知辩才。具足能令一切众生欢喜辩才。尔时不空见菩萨摩诃萨。重宣此义。而说偈曰

  供养最胜尊　　无数无边量
  能证无上道　　世间大导师
  广集诸善根　　得彼难思辩
  无謇复无碍　　无量亦无边
  和合解脱义　　尊胜无上人
  善说断疑网　　随问皆能释
  种种深密教　　及以诸譬喻
  具足庄严辩　　妙音难可量
  清净咸相应　　决了法安住
  不思无能坏　　亦无惧畏心
  妙音与智俱　　不惊不毁损
  无错庄严句　　安乐无忘失
  不惑于诸方　　无滓致心净
  过去与当来　　现在无挂碍
  凡圣平等转　　辩才非他生
  近远同时闻　　佛音说时出
  海水可知量　　毛滴可知数
  诸佛大名称　　辩才难得边
  虚空可尽边　　须弥易称量
  无上天人师　　辩才深难测

大方等大集经菩萨念佛三昧分卷第四大方等大集经菩萨念佛三昧分卷第五

        隋天竺三藏达磨笈多译

    叹佛妙音胜辩品之余

尔时不空见菩萨摩诃萨复告尊者阿难言。阿难。诸佛世尊是大梵声。是大师子声。是大雄朗声。是大龙王声。是大妙鼓声。是大妙歌声。是妙好声。是大风声。是大云声。是大雷声等。阿难。诸佛世尊是大善声。不思议声。是无量声。是无边声。是不可称声。是满足声。是无碍声。是迦陵频伽声。阿难。诸佛如来是圆满声。诸如来是可证声。诸如来是可知声。诸如来是深远智声。诸如来是不可坏清声。诸如来是无垢声。诸如来是无讥诃声。诸如来是无嘶破声。诸如来是妙好声。诸如来是最上妙好声。诸如来是无缺声。诸如来是不怯弱声。诸如来是具足一切功德声。阿难。诸佛如来应供等正觉出音声时。若欲一音遍满一佛世界即能遍满。若欲遍满二佛世界。若三若四若五若十乃至百千世界乃至亿那由他。乃至无量无边阿僧祇不可数知世界。如来世尊。还出如是无量无边阿僧祇不可数不可知殊异声音。皆悉充满彼诸世界。令彼众生诸有得闻如来声者。咸作是念。今者世尊独为我转如斯法轮。阿难。诸佛世尊有如是等不思议声。阿难。诸佛世尊有如是声如是利益

尊者阿难。譬如日轮为阎浮提诸众生辈。有眼目者作大利益。云何利益。所谓光明照了一切。如是阿难。诸如来应供等正觉。清净声轮凡所至处。能为一切信根众生。随宜宣说作大利益。其义亦尔。复次阿难。譬如秋月十五日夜。彼月光轮清净圆满。阎浮提人见者欢喜。如是阿难。诸如来应供等正觉圆满声轮。能为一切法音光明。闻者欢喜得大利益。其义亦尔。复次阿难。譬如大海水平等一味常住澹然难入难度。其间多有诸异珍宝。而能为彼一切众生若人非人作大饶益。如是阿难。诸如来应供等正觉。圆音平等一味湛然难入难测。微妙而能安乐一切众生。其义亦尔。复次阿难。譬如大地任持一切山林河海王都大城民人聚落。复能生长诸种苗稼根茎华果。饶益安乐一切众生。如是阿难。诸如来应供等正觉。普载声轮任持一切令无坏损。复能生长众生善根功德华果。饶益世间。其义亦尔。复次阿难。譬如虚空容受一切。能令众生种种兴作。往来游处为大利益。如是阿难。诸如来应供等正觉。广大声轮遍满一切。能令众生多有所作。受用去来无不利益。其义亦尔。复次阿难。譬如三十三天波利质多罗树。其华敷时能令三十三天皆生欢喜多受适乐。如是阿难。诸如来应供等正觉。开发声轮。能为一切启甘露门。令诸众生等证常乐。其义亦尔。尔时不空见菩萨摩诃萨。为重明此义。以偈颂曰

  世尊真善大梵音　　师子妙音牛王吼
  最上龙吼满世界　　器度雄朗丈夫声
  云雷风等弘壮声　　彼不思议悉无量
  转行十方无边界　　所至无碍皆悉闻
  如来出声甚圆备　　世间未能障其声
  亦如迦陵频伽音　　所闻清婉甚微妙
  圣不望报生物喜　　教令证此最胜声
  解脱深句无有比　　世间无有能毁坏
  不破不缺微妙声　　相续不断和合出
  救护世间无穷已　　具足一切功德音
  调伏丈夫如意声　　其声遍闻于三界
  彼诸众生斯念喜　　各言为我宣妙声
  若欲声满一世界　　若二三四及与五
  若十二十至五十　　百千亿数复过前
  若复过彼恒沙土　　皆能充满一切刹
  令彼众生无异心　　咸作是念但为我
  譬如日轮出现时　　能为阎浮作明导
  如是世尊天人师　　法声光明照世间
  犹如秋月处众星　　其轮圆满异明净
  彼为阎浮兴大利　　众生睹见皆欢喜
  世尊如是满月声　　不思议净胜世间
  其有闻者心无厌　　为诸众生作饶益
  犹如大海水湛然　　深广无边难得底
  其间常出众异宝　　为诸世间作利益
  如是诸佛大名称　　其声深远亦难穷
  恒教证彼清净音　　与不可坏一切乐
  若此三千诸大地　　能持异类诸众生
  如是诸佛普载声　　生成一切众饶益
  譬如虚空能容受　　飞鸟群生皆获益
  如是足尊广纳音　　恒以胜善利众生
  犹如忉利质多罗　　华时已乐彼诸天
  如是诸佛甘露音　　能为众生毕竟利
  尊者设我满一劫　　或复百劫赞其声
  生生弗能得其边　　佛不思议声若是
  假使十方诸众生　　各各恣口长歌叹
  终亦莫能致少分　　佛音如是难思议
  假彼行住诸众生　　或于一时皆成佛
  彼诸佛说亦无尽　　佛声如是难思议
  世尊如是众妙音　　庄严具足无伦匹
  若人但能生喜心　　彼等终无恶道畏
  佛音如是难思议　　第一微妙无可比
  若有菩萨得斯喜　　不久则成佛法王

尔时四天王天主帝释。须夜摩天王。兜率陀天王。化乐天王。他化自在天王。魔王之息导师太子。娑婆世界主大梵天王。乃至净居天王。及余一切大威德诸天。与欲色界中复有无量诸天子等。闻不空见菩萨摩诃萨称赞世尊音声功德已。一切皆于不空见所起尊重心。欢喜踊跃不能自持。咸以天妙栴檀末香。天华及鬘天妙衣服。宝盖幡幢杂色雕彩。施散悬置于不空见菩萨摩诃萨上。时会众中有六万亿那由他百千欲色界天。闻说如来音声功德。为当得故发阿耨多罗三藐三菩提心种诸善根。复有五千比丘。被精进铠于阿耨多罗三藐三菩提种诸善根。复有七百千万诸比丘尼。发阿耨多罗三藐三菩提心及弘誓愿。复有百千优婆塞。皆各从彼宝莲华座起。直诣不空见菩萨摩诃萨所。复有二亿那由他百千女人。各解自身众宝璎珞散掷虚空。住于不空见菩萨摩诃萨上。皆于阿耨多罗三藐三菩提种诸善根

    菩萨念佛三昧分赞如来功德品第六

尔时不空见菩萨摩诃萨复告尊者阿难言。阿难诸佛世尊甚为希有。诸如来功德具足故。自天降下具足故。入胎具足故。住胎具足故。出胎具足故。母生具足故善根具足故。众相具足故。众好具足故。庄严具足故。出家具足故。入定具足故。大入定具足故。深心具足故。至心具足故。真信具足故。无畏具足故。戒身具足故。定身具足故。慧身具足故。解脱身具足故。解脱知见身具足故。诸通具足故。证智具足故。至一切证知第一彼岸故。至慈大慈第一彼岸故。至悲大悲第一彼岸故。至喜大喜第一彼岸故。至舍大舍第一彼岸故。至最胜无等第一彼岸故。至诸威仪第一彼岸故。至诸神通第一彼岸故。至一切诸法无碍第一彼岸故。至是处非处力第一彼岸故。至诸开道利益第一彼岸故。至奢摩他毗婆舍那第一彼岸故。至一切禅定解脱三摩跋提第一彼岸故。至无贪无嗔无痴无慢无放逸无嫉妒无恚。舍离诸过解脱五道。至四无畏第一彼岸故。令一切众生种诸善根受业果报。教论发起第一彼岸故。令一切众生诸戒行聚。不破不缺不浊不杂。成丈夫志无所触犯。智者所赞无有过愆。一切世间若天若人若梵若魔沙门婆罗门。乃至无能如法诃责非理毁者。阿难。诸佛世尊功德殊胜。一切世间众生类中。乃至无有能得测量宣说如来戒等功德知其少分。何处有人复能过者。阿难。汝等从今当如斯观此虚空界如是广大。此四方界如是弘宽。我皆了知限量边际。诸佛功德不可测量。如是阿难。诸佛世尊所有戒聚。所有定聚。所有慧聚。及解脱聚。解脱知见聚。乃至一切威仪神通利益无碍。不可宣说不可显示。不可得知不可得入。所以者何。阿难。诸佛世尊所有功德皆无有边。何以故。诸佛世尊有无量戒行。有无量定行有无量慧行。有无量解脱行。有无量解脱知见。乃至有无量诸功德悉等。是故阿难。当知诸佛世尊具足若此。尔时不空见菩萨摩诃萨。为重明此义。以偈颂曰

  世尊天降入胎时　　住不思议出亦尔
  生家最胜母无比　　最上第一诸功德
  体备众相三十二　　诸好具足庄严身
  诸佛所作不思议　　皆缘旷劫久修集
  人中胜上求出家　　成就禅定大三昧
  正心淳信斯坚固　　一切方便无不知
  戒行三昧皆具足　　智慧成满无伦比
  解脱知见亦已获　　神通威德彼岸边
  能灭炽苦救众生　　慈悲要行最为首
  喜舍亦妙行平等　　诸佛世尊自证知
  身口常与意行合　　所行随智难思量
  威仪无比超世间　　法王神力到彼岸
  无诤三昧见法如　　是处非处皆明了
  禅定解脱难测度　　普能饶益诸众生
  定慧止观斯成就　　光明遍觉灭垢心
  无有贪恚众过愆　　解脱无畏皆善学
  戒行无破亦无羸　　无浊无杂尽清净
  多众生触不嗔恼　　不求果报智所称
  内无过失外无毁　　假彼天人及梵魔
  或复沙门婆罗门　　莫能讥诃常清净
  虚空犹可尽其界　　诸方亦可极其边
  无上调御天人师　　清净戒行孰能测
  大海可以口饮干　　无边水聚亦复尔
  诸佛光明不可识　　清净戒行谁得边
  须弥可以口吹散　　大小铁围亦复然
  诸佛妙行不可知　　清净戒行难得底

尔时不空见菩萨摩诃萨作是思惟。今者如来应供等正觉。若降威神俯临斯会可谓善哉。今我亦当为诸菩萨摩诃萨故。请问世尊一切菩萨念佛三昧微妙法门。如来先已显示其名。今者当应为诸弟子。演说斯法宣明义理。世尊。宁当过安禅寂乎。尔时世尊。知彼不空见菩萨摩诃萨如是念已。佛神力故应时此会三千大千世界。大地六种震动。所谓动涌起震吼觉等。如是具足十八相动乃至涌没。如是动已。时佛世尊。复以神力放大光明。照此三千大千世界。彼光出时能令一切星宿天宫。月天子宫日天子宫。乃至欲界诸天宫殿。所有光明丧灭不现。复有如是无量无边不可思议阿僧祇恒河沙数。诸梵天宫所有威光。悉皆暗晦。乃至色界一切天宫。蒙佛光故亦皆不现。诸光没已。唯佛世尊神光独盛。尔时世尊大慈熏心。为欲饶益诸众生故。从禅定起安详徐步。诣彼大众周旋观察是不空见菩萨摩诃萨等已。于是一切世间诸天。及人若梵若魔沙门婆罗门。诸龙夜叉阿修罗辈遇佛光明。咸各自彼莲华座起。前诣佛所曲躬合掌。礼敬世尊各还退坐

尔时不空见菩萨摩诃萨遥见世尊。身相分明端严殊特。诸根寂静如调象王。心意朗然若澄净水。一切种具足一切智圆满。自彼而来深生喜已。于是不空见菩萨即告尊者阿难言。阿难。汝观世尊从禅定起。如来世尊从静室来。必当开演第一诚谛终无虚妄。如来世尊。是妙语者是真语者。是实语者是如语者。是不异语者是善语者。心善思惟常行善事。身业无失。口业无失。意业无失。一切功德斯皆具足。所谓具足最上第一戒聚故。具足最上第一定聚故。具足最上第一实慧聚故。具足最上第一解脱聚故。具足最上第一解脱知见聚故。具足最上第一威仪故。具足最上第一神通故。具足最上第一利益故。具足最上第一不思议辩才故。具足最上第一成就故。具足最上第一微妙故。具足最上第一天退故。具足最上第一入胎故。具足最上第一住胎故。具足最上第一生家故。具足最上第一圆满功德故。具足最上第一不思议诸相故。具足最上第一不思议诸好故。具足最上第一过去业故。具足最上第一善根故。具足最上第一具足发心故。具足信心故。具足破烦恼故。具足大破烦恼故。具足舍家故。具足知五种故。所谓具足第一戒身故。具足第一定身故。具足第一慧身故。具足第一解脱身故。具足第一解脱知见身故。已到第一神通彼岸故。已到第一无余智证彼岸故。已到第一分别法彼岸故。已到第一分别义彼岸故。已到第一分别办才彼岸故。已到第一寂静定彼岸故。已到第一明达彼岸故。已到第一根力觉道彼岸故。已到第一慈及大慈彼岸故。已到第一悲及大悲彼岸故。已到第一喜及大喜彼岸故。已到第一舍及大舍彼岸故。已到第一不思议威仪彼岸故。已到第一惭愧彼岸故。已到第一于一切法自在彼岸故。已到第一过去智知见无碍彼岸故。已到第一未来智知见无碍彼岸故。已到第一现在智知见无碍彼岸故。已到第一身业随智慧行彼岸故。已到第一口业随智慧行彼岸故。已到第一意业随智慧行彼岸故。阿难。如来应等正觉。于一念中能具足知一切众生心心所行。若善若恶若净若垢等

尔时不空见菩萨摩诃萨复告尊者阿难言。尊者阿难。诸佛世尊如大海。净戒聚不可得底故。尊者阿难。诸佛世尊如须弥山。三昧聚不可动摇故。尊者阿难。诸佛世尊如虚空。智慧聚无有边故。尊者阿难。诸佛世尊如虚空。摄一切众生无障碍故。尊者阿难。诸佛世尊如日轮。为诸世间作法光明故。尊者阿难。诸佛世尊如大火聚。焚烧一切众生诸烦恼薪故。尊者阿难。诸佛世尊如河如陂如池如泉。洗荡众生生老病死垢故。尊者阿难。诸佛世尊如良医。能愈一切众生诸疫病苦故。尊者阿难。诸佛世尊如大云雨。能以法水润泽众生枯槁故。尊者阿难。诸佛世尊如师子王。能破一切众生大我慢故。尊者阿难。诸佛世尊如大船。能度众生生死河故。尊者阿难。诸佛世尊如那罗延。能伏一切世间大力故。尊者阿难。诸佛世尊如优昙华。一切世间难得见故。尊者阿难。诸佛世尊如波利质多树华。三十二大人相可爱乐故。尊者阿难。诸佛世尊如父母。能与一切众生安乐利益故。尊者阿难诸佛世尊作利益作安乐。能今一切众生得住故。尊者阿难。若人说言如来出世有无量辩才。如是说者。是则名为善说如来。如来出世有不思议辩才。是名善说。尊者阿难乃至如是略说。如来出世有无边辩才。如来出世有无碍辩才。如来出世有无取着辩才。如来出世有胜解脱辩才。如来出世有随顺义辩才。相应义辩才。微妙净辩才。巧问辩才。不问辩才。上辩才。无上辩才。慈辩才。大慈辩才。悲辩才。大悲辩才。喜辩才。大喜辩才。舍辩才。大舍辩才。佛出世利益辩才。尊者阿难。若人说言如来出世具足利益一切众生。是则名为善说如来。尊者阿难。若人正言同义辩才利益众生。是则如来出于世间。又说若言彼利益辩才。为一切众生得利益故。当正言音悉令具足。是则如来出于世间。斯人亦名善说如来。尊者阿难。若人说言彼无归众生。无依众生。无救众生。无护众生无怜愍众生。如来出世。为归为依为救为护为怜愍者。是则名为善说如来。尊者阿难。假使我今若经一劫若减一劫。长时歌赞诸佛世尊辩才功德终不得一。又复经于无量劫数。具足演说如来应供等正觉辩才功德。终亦不得其少分边尊者阿难。譬如有人老病羸瘠。至大众中发如是言。诸人当知。我虽年迈为病所摧。而犹能以一毛端勺渧取大海。令即干枯。是人素无神通咒术。而能如是果决壮言。尊者于意云何。彼人言义可取信不。阿难答曰。不也大士。不空见复言。尊者。彼人之言一切世间诸天及人。颇曾惊叹此事希有如是困人。能以毛端尽大海水如斯念不。阿难答曰。不也大士。如是尊者。此事本无依何取信。我今赞说诸佛世尊辩才功德不得少边。其事若此。尊者阿难。且置斯事。假使佛今还自赞说毛分功德。过亿百千那由他劫亦不能尽。而况余人。尊者阿难。且置斯事。我今更说假使大地所有一切众生。若干种类有足无足二足四足乃至多足。有色无色有想无想非有想非无想。如此世界及以十方无量无边诸世界中所有众生。设使尽皆一时成佛。彼诸世尊。经无量劫。皆还叹佛一毛功德终亦不尽。尊者阿难。当知一切诸佛世尊。乃有如是不可思议具足功德。尔时不空见菩萨摩诃萨。为重明此义。以偈颂曰

  尊者当观法王来　　一切世间应供养
  功德威光殊显赫　　一切智满难可倾
  最上妙言佛真说　　实语及如无异言
  善说圣法真实知　　身口离过意亦尔
  心无异念绝分别　　戒行最胜三昧深
  智慧解脱悉超伦　　解脱知见无可比
  威仪具足不思议　　无上神通如实智
  利益世间无有量　　辩才妙行亦无类
  降天下生象牛王　　入胎成就世中胜
  住胎殊异无有等　　家生具足母尊高
  成就众根最第一　　胜相圆满不思议
  妙好咸备极庄严　　一切分明世瞻仰
  具足真心信清净　　禅定除垢有大威
  放舍世欲乐出家　　菩提成就得五种
  已度神通第一岸　　智慧无碍亦无边
  及奢摩他毗舍那　　法王通达斯自在
  大海之水广且深　　其或可以毛端测
  调御丈夫清净戒　　虽经旷劫不能知
  须弥虽固犹可动　　以手投掷至梵宫
  诸佛初住定禅时　　已自无能动乱者
  虚空容有得其边　　四方亦可知其限
  终无能见正觉境　　思惟分别此彼处
  尊者大地实弘广　　然可以指遍度量
  舍离烦恼人中尊　　彼心意识不可尽
  如日轮光破众闇　　观诸善恶若见色
  如是自在世间师　　能破巨黑无明云
  犹如秋月出重云　　众生见者皆欢喜
  法王智光如满月　　如睹妙色无不乐
  冥寂长夜如明灯　　为诸眼目作先导
  世间智者能除暗　　恒以法光照众生
  能设法炬自在尊　　天人大师为他作
  一切诸有皆灭尽　　是故称佛光明王
  圣智如河及泉水　　能荡生老病死尘
  如大医王施良药　　调御能除众疾苦
  犹如龙王降大雨　　能满一切诸大地
  诸佛如是行慈悲　　充足一切乐法者
  大师子王震吼时　　降伏世间诸恶兽
  世尊如斯决定说　　破除外道我慢心
  如大舟船常往返　　济度一切诸去来
  诸佛如是遍周旋　　拔彼常没四流者
  优昙钵华世希有　　此阎浮提最难见
  天人世尊难中难　　一切世间归依处
  如波利树华现时　　三十三天甚爱乐
  大人相好出兴世　　众生睹见悉欢喜
  世尊神变难穷尽　　如我今者谓宣说
  我以叹佛诸功德　　毕竟利益诸群生

大方等大集经菩萨念佛三昧分卷第五大方等大集经菩萨念佛三昧分卷第六

        隋天竺三藏达磨笈多译

    佛作神通品第七

尔时世尊。自袈裟内出金色手。摩彼不空见菩萨摩诃萨顶复出广长舌相。即告不空见菩萨言。善哉善哉。汝不空见。汝今乃能为诸众生。如是叹说如来应供等正觉真实功德也。不空见。若有说言世间众生无救护时。是中必有能救护者。出现世间为作救护。不空见。当知即是善说如来也。复次不空见。若复说言世间众生无归趣时。是时必有不思议辩才无量辩才。出现于世。能与众生作大归依不空见。当知即是善说如来也。复次不空见。若复说言世间众生。多贪欲行。多嗔恚行。多愚痴行。是时必有无欲恚痴大师出世为除三毒。不空见。当知即是善说如来也。复次不空见若复说言世间众生。多悭吝时多嫉妒时。是时必有远离悭嫉好行布施大师出兴为破悭嫉。不空见。当知即是善说如来也。复次不空见。若复说言世间众生。无有惭愧羞耻之行。是时必有惭愧羞耻大师出世除无惭耻。不空见。当知即是善说如来也。复次不空见。若复说言世间众生。多行憍慢贡高之事。是时必有和敬调柔大师出世为除憍慢。不空见。当知即是善说如来也。复次不空见。若复说言世间众生。无有慈悲不能喜舍。多行嗔恚秽浊毒心。是时必有断除嗔毒具足四等导师出世教修慈悲大利益事。不空见。当知即是善说如来也。复次不空见。若复说言。世若多恶无善众生。其有能教令生善根。先有善根令其增广。如是利益大师出兴。不空见当知则是善说如来也。复次不空见。若复说言五浊恶世众生病增。世有大人能行利益。导以出法安乐众生。不空见。当知是言则谓我也。所以者何。吾今出于五浊恶世。宣扬妙法断除邪垢。能多利益诸众生故。尔时世尊。手摩不空见菩萨顶时。即以神力于一念间。令此大众咸见东方无量无边不可说阿僧祇现在一切诸佛国土。彼国土中诸佛世尊未灭度者。及彼众生一切境界皆悉现前。亦闻彼佛说法音声。亦见彼刹清净庄严种种具足。如是乃至南西北方四维上下十方所有诸佛净土。一切境界明了现前。若观掌中庵摩勒果

又复世尊。以手摩彼不空见菩萨摩诃萨顶时。以佛神力及不空见本愿因缘。于一念间。即见十方无量无边阿僧祇不可数过去诸佛入涅槃者。乃至彼刹清净庄严了了分明若观手掌。又蒙佛力亦见当来诸佛世尊。清净刹土庄严具足

尔时不空见菩萨摩诃萨。以本愿力承佛威神。尽见十方三世诸佛及彼佛刹清净庄严已。为重宣此义即从坐起。正持威仪偏袒右肩右膝着地。合掌向佛。以偈颂曰

  三千世界所有水　　若人欲量皆可知
  调御丈夫天人师　　戒行深远孰能测
  须弥高广最巍巍　　羸老病人口吹散
  世尊初入于禅定　　亿百千劫难可了
  虚空足量能尽边　　四方亦可步其际
  世尊大师等正觉　　智慧甚深无源底
  虚空平等无挂碍　　可为暴风所飘动
  如来本性无烦恼　　贪恚痴毒何所居
  日轮圆满处空中　　清净光明遍世界
  如是阿罗仙种姓　　于此天众而曜晖
  又如秋月合昴宿　　威光超世挺众星
  如是满月大法王　　炎赫独出天人上
  若优昙华甚希有　　时乃一遇不世出
  诸天中天调御师　　有时而现随意感
  世尊妙手摩我顶　　金色百福相庄严
  不可毁坏悉具足　　其为利益斯若是
  世尊真言及实语　　人中法王转正轮
  普遍十方世界中　　甚为利益悉自在
  蒙世尊手摩顶时　　我见十方最上人
  如恒河中说沙数　　大威德仙众多彼
  大牟尼尊手加我　　即见诸佛如弥陀
  犹恒河中算沙数　　人中最胜众多彼
  如来慈手亲摩觉　　安乐世界我见知
  阿閦应供两足尊　　大悲光明作饶益
  我蒙世尊神手触　　尽见世间灭度尊
  于一念顷如恒沙　　大慈降伏诸根者
  世尊以手摩我时　　亦睹弥勒昔诸愿
  如彼当来一切事　　了了明白无复疑
  过去诸佛我已见　　未来现在亦复然
  十方三世诸如来　　神通德力难称说
  世尊以手摩我时　　普见十方救世者
  并睹诸佛清净刹　　我因更发最上愿
  诸佛神通难思议　　戒定智慧亦如是
  诸余功德不可说　　唯愿如今常教示
  如来下手摩我时　　即见十方诸塔庙
  众宝金色如恒沙　　具足种种微妙供
  诸佛皆具大名称　　彼彼相好充十方
  百千乐音以供养　　我见彼刹悉如是
  彼刹复有诸佛塔　　金缕间错宝颇梨
  高大过于一由旬　　端正庄严皆若此
  复见大尊诸塔庙　　众宝杂厕甚精华
  亦有住于虚空中　　常以天华散其上
  我复见彼诸胜塔　　涌出高满十二旬
  彼诸佛所名灯然　　光明遍照十方刹
  世尊以手摩顶时　　我见妙塔不可说
  彼佛各有大名称　　其间皆悉如来力
  世尊手摩我顶时　　于是得见诸佛刹
  彼或烧身或受辱　　种种行类不可宣
  各于自刹修苦行　　无有昼夜如救然
  勇猛弘誓度众生　　皆为无上菩提故
  我又睹见十方刹　　有诸菩萨常辛勤
  自剜身肉然多灯　　彼为菩提光明故
  我又复见清净身　　于诸佛前常立住
  至彼世尊涅槃已　　为求菩提大德故
  我又复见为法人　　香油灌身然灯炬
  苦身精意遍十方　　终不系心财食类
  我又更见诸丈夫　　恒舍头目及身手
  妻子王位与国城　　志令群生获安乐
  如我所见无遗余　　不可口言而宣说
  我所知见最胜等　　蒙佛威灵故遍观
  世尊威神加持故　　令我见斯希有事
  吉祥第一天中天　　我今归依最无上

    菩萨念佛三昧分见无边佛广请问品第八

尔时不空见菩萨摩诃萨白佛言。世尊。今此一切天人大众。既见世尊久处禅定。默无言说咸生渴仰。唯愿世尊俯就斯座。尔时世尊。闻不空见菩萨摩诃萨。为彼天人大众请已。端身正念默然许之

尔时不空见菩萨既蒙默许。偏袒右臂右膝着地。合掌向佛复白佛言。世尊。我今欲问。若圣听者乃敢发言。佛告不空见。如来应供等正觉。随汝所问当为汝说。断汝所疑令尔心喜。然是天人梵魔沙门婆罗门等皆当证知。时不空见菩萨摩诃萨承佛教已。即便白言。世尊。菩萨摩诃萨应当思惟何等三昧。应当亲近何等三昧。应当修行何等三昧。如是菩萨思惟亲近。及以修行此三昧已。现见何法而得安乐。云何当得如大海多闻受故云何当得如须弥山。菩提心安住不倾故。云何当得如大铁围山。一切外道邪论不能动故。云何当得如虚空一切法无碍故。云何当得如虚空。心无染着故。云何当得如日轮破除一切无明闇故。云何当得如月轮。白净法圆满故。云何当得如灯轮。作法光明故。云何当得如大炬。一切受阴灭故。云何当得如火聚。焚烧一切诸烦恼故。云何当得如河池泉源。一切众生随意受用故。云何当得如大船。一切众生度彼岸故。云何当得如桥梁。不没生死烦恼中故。云何当得降伏众敌。破坏魔军诸憍慢故。云何当得如波利质多罗树。为一切诸方所有众生。开七菩提华香风普熏故。云何当得如优昙钵华。希有难得故。云何当得如药王。等疗一切众生病苦故。云何当得如大医王。起大悲心愍痛众生故。云何当得如栴檀树。除众热恼作清凉故。云何当得如大云雨。等注法雨令满足故。云何当得如蜜器。能具足说一味法故。云何当得如师子吼。能与一切众生无怖畏故。云何当得如父母。等与一切众生安乐利益故。云何当得见真法。至如法性实际彼岸故。云何当得解释深趣。至实义彼岸故。云何当得巧说法辩。至能分别彼岸故。云何当得善巧说法。至具足方便彼岸故。云何当得分别了义。善知字句法故。云何当得正意正行。具知足故。云何当得统御大众。无所畏故。云何当得说如实义。入实际故。云何当得如大海。一切法同一味故。云何当得如大山。三昧安静无能动摇故。云何当得如门闑(亦云帝释幢也)。菩提心不可动转故。云何当得坚固力心志具故。云何当得具足威仪。不作虚谄故。云何当得端正身。为他欢喜说法故。云何当得最妙。最上色相故。云何当得尊贵。大姓家生故。云何当得大法王。福报功德故。云何当得具足。无量辩才故。云何当得不取着辩才故。云何当得不错辩才故。云何当得分别种种名字句辩才故。云何当得不思议辩才故。云何当得无边辩才故。云何当得解脱辩才故。云何当得同义(亦云成就也)辩才故。云何当得随他意义辩才故。云何当得渐亲近辩才故。云何当得所问能答辩才故。云何当得无问自说辩才故。云何当得不毁坏辩才故。云何当得无退转辩才故。云何当得甚深句字种种说辩才故。云何当得无量无边譬况辩才故。云何当得未证大菩提。已能具足梵音声故。云何当得第一微妙音声故。云何当得迦陵频伽音声故。云何当得师子王音声故。云何当得大龙王音声故。云何当得大牛王音声故。云何当得大钟鼓音声故。云何当得胜妙歌赞音声故。云何当得乐弦音声故。云何当得哀婉清美音声故。云何当得风云雷震音声故。云何当得甚深庄严辩才音声故。云何当得诸妙语言文字章句。真正庄严辩才音声故。云何当得甚深能大巧说音声故。云何当得种种譬喻辩才音声故。云何当得一切世间最胜供养音声故。云何当得共他论义辩才音声故。云何当得神通彼岸音声故云何当得不忘失法音声故。云何当得不缺少善法音声故。云何当得诸善根行具足他赞音声故。如是一切悉皆具足。尔时不空见菩萨摩诃萨。发如是等诸疑问已。为重宣此义。以偈问曰

  具足金色百福相　　能觉一法利无边
  最胜功德我今问　　何等三昧先应思
  如来妙智无等伦　　世间宁有加上者
  我今请尊修何定　　所获功德不思议
  天人大师上调御　　思惟是定何功德
  菩萨于此云何修　　而能安乐于一切
  云何自然多闻海　　云何守护决定心
  得住诸佛功德处　　云何如大铁围山
  是中都无恚恨心　　而能降伏诸外道
  云何无碍如虚空　　云何复得心自在
  云何如日复如月　　云何同炬亦如灯
  云何为众作光明　　云何复须观三昧
  云何解脱诸烦恼　　云何能度生死岸
  云何发心苦轮中　　独超三界无与等
  云何波利质多树　　大人相好妙庄严
  云何如彼优昙华　　勇健雄猛不出世
  云何施药不望报　　良医救苦调御师
  能除众生诸热病　　安住净戒得清凉
  云何当得如法宝　　无量功德度彼岸
  云何甚深微妙法　　犹蜜甜味妙无加
  云何得此师子音　　能令众生无怖畏
  云何等益如父母　　得彼深乐不思议
  云何能得妙辩才　　行于菩提大名称
  云何说彼最胜道　　云何而得无碍智
  云何于义能巧便　　云何妙知诸法相
  云何分别名句身　　云何世法及出世
  云何正念与正行　　云何知足具思惟
  云何多闻如大海　　云何叹佛真实德
  云何说彼诸众生　　生死根本如实际
  云何诸法无差别　　犹如大海同一碱
  云何如山定无动　　不退转心如门闑
  云何一心无余业　　但求无上大菩提
  云何具足诸威仪　　身相端严见者喜
  云何常生大姓家　　亦受法王大福聚
  云何得彼无量辩　　所有言论世莫思
  云何字句义深微　　我今请问护世者
  云何无上难得胜　　亲近真辩无遗忘
  云何同义称根性　　若问不问斯相应
  云何未证具梵音　　其声清婉甚微妙
  迦陵频伽声可爱　　大智雄猛声远闻
  云何师子大龙音　　更得深重牛王吼
  云何世尊得弦乐　　具足种种诸器声
  云何获彼甜味音　　而常演说众欣乐
  云何功德音无毁　　其出如风若震雷
  云何多种譬喻音　　能宣甚深诸言说
  云何所出善语言　　云何诸法不忘失
  云何有中获宿命　　彼诸神通云何修
  云何修行无疲倦　　遍知一切诸善法
  如是诸法不思议　　自然轮转遍十方
  世尊我皆无复疑　　是故今问归依处

尔时不空见菩萨摩诃萨。殷勤郑重如是问已。即以神力身升虚空。于虚空中自然化作天宝华盖。庄严微妙七宝所成。谓金银琉璃颇梨马瑙车磲真珠具如是等种种宝饰。彼宝盖中雨种种华而彼众华右绕三匝住佛顶上。即彼华中以偈叹曰

  归命丈夫大调御　　无上正觉两足尊
  一切世间天人辈　　宁有可以比类者
  长夜黑暗诸众生　　愚痴颠倒堕邪道
  极尊明智世间限　　能令还复平正路
  失于清白法种子　　众生烦恼内烧心
  胜尊犹如世父母　　能令安止白法处
  遗丧善法深利人　　后世方将可怖畏
  最尊成就大慈行　　为诸众生真导师
  一切众生无善利　　无有覆护无救者
  希有大悲教世师　　世尊真为作救护

尔时华中说是偈已。彼华方至如来足上。须臾即飞遍往三千大千世界。遍诸佛前施散供养。彼宝盖中复出栴檀末团大如车轮至如来身忽然不现。而彼栴檀香气微妙。充满三千大千世界。所有众生得闻此香。皆悉受于上妙快乐。犹如菩萨入第四禅。尔时不空见菩萨摩诃萨。示现如是神通事已即白佛言。世尊。是诸菩萨摩诃萨等。云何当得如斯智慧。所谓大智慧。速疾智慧。机捷智慧。猛利智慧。无相智慧。巧入智慧。甚深智慧。广普智慧。无畏智慧。圆满智慧。云何复得不可算数不可称量诸妙善根。所谓心如金刚。善根穿彻一切法故。心如迦邻提衣。柔软善根能作业故。心如大海。善根摄诸戒聚故。心如平石。善根住持一切事业故。心如山王。善根发生一切善法故。心如大地。善根负持众生事业故。得心不随他行。善根远离非法教诲故。得心善修行。善根一切法安住故。得不坏信善根。于诸如来所行之处不疑惑故。住一世界自然遍见十方诸佛。亦闻彼佛宣说妙法。复见菩萨声闻大众。又睹佛刹清净庄严受用等事悉无疑故。乃至摄受决定善根。于一切时自利利他故。世尊。如我今者实为自利。复欲利益诸众生故。请问如来也。世尊。我今复为弘广众生净信心故。请问如来也。世尊。我今复为彼诸菩萨摩诃萨辈。具足圆满不思议善根故。请问如来也。世尊。我复为斯被大精进弘誓铠甲诸大菩萨摩诃萨故请问如来也。世尊。有诸菩萨摩诃萨辈。于生死中发大精进。为一切众生而亦不取众生之相。然是菩萨摩诃萨虽于生死烦恼中。长夜度脱一切众生。而实不住生死烦恼想。世尊。我为如是诸众生故。请问如来也。世尊。有诸菩萨摩诃萨等。行慈悲时于诸众生都无嗔恨。设诸众生诃责骂辱楚挞挝打种种苦迫。如是菩萨于众生所终无报答。乃至不起嫌心不失本愿。无异分别及余思惟一心修行大慈大悲。世尊。我为如是住于大乘诸菩萨故。请问如来也。世尊。有诸菩萨摩诃萨辈。为众生故欲舍己乐及诸乐具。欲受一切炽然大苦。发如斯念。我当云何令一切众生得最胜乐。令一切众生得大法明。世尊。彼诸菩萨如是念时凡所有物。若内若外。无不施者。无不益者。无不饶者。世尊。我为如斯诸菩萨故。请问如来也。世尊有诸菩萨摩诃萨辈。被着如是精进铠时。发如斯念。我今当应为一一众生。于恒河沙劫住大地狱受诸苦恼。犹入出息不以为苦。亦不退没菩提之心。世尊。我复为是诸菩萨故。请问如来也。世尊。有诸菩萨摩诃萨辈。被着如是精进铠已。发如斯念。我今当为一切众生。执诸事业厮役服勤。种种承事不以为苦。于是或为奴婢。或为仆隶。或为傧从。或为弟子。我应如是乃至为作种种眷属成熟众生。世尊。我复为是诸菩萨故请问如来也。世尊有诸菩萨摩诃萨辈。为一切众生故。发大勇猛修诸苦行。舍身手足头目髓脑。或时节节支解其形。析骨消髓不以为苦。无有休懈。方更炽然于阿耨多罗三藐三菩提事。世尊。我为如斯诸菩萨故。请世尊耳。尔时不空见菩萨摩诃萨。如是问已。为重宣此义。以偈颂曰

  我问天师诸胜智　　大智彼等云何成
  云何速智及捷疾　　利智聪明能通达
  何因得彼甚深智　　尽无边智为我宣
  弘广普遍一切智　　是为最胜求菩提
  云何当得无怖畏　　具足善巧为我说
  云何而得金刚心　　一切法中无疑惑
  云何得是柔软心　　戒行清明净如海
  云何如山不动转　　菩提决定愿庄严
  云何行行不随他　　于义明了得安住
  云何而得不坏信　　诸佛所作无复疑
  云何得彼生念智　　住于一界现十方
  遍睹诸佛及闻法　　并大集众亦明了
  其身不离于一刹　　而能供养十方尊
  妙华众香及涂香　　诸余众具难可说
  心住此刹无他缘　　身现十方无量土
  亲承奉事彼诸佛　　悉由神通力无边
  无请我今为行慈　　住于惭愧修行者
  不自利己常益他　　为斯我请大名称
  诸有发心求佛智　　善根成熟不思议
  如是三昧云何修　　我故为彼问无著
  被此忍铠为众生　　我要当拔诸重苦
  彼等已离众生想　　为斯故问正觉真
  彼辈常住平等心　　观察众生无异想
  常能成就慈悲者　　我为彼故问如来
  是中应行何等法　　速得如是不思议
  所得功德无有边　　我为彼故请调御
  被弘誓铠勇猛人　　为一众生恒沙劫
  大地狱中受焰苦　　善哉安乐诸众生
  彼等无睡亦无疲　　内外诸物无不施
  如是摄受众生者　　我今为彼同普观
  呵责毁辱及捶骂　　身受煎迫众事苦
  为他奴婢及仆隶　　皆由斯辈请世尊
  无量百千数亿头　　有来求索皆能舍
  当舍头时极欢喜　　为求无上妙菩提
  为诸众生而更舍　　手足及以身余肢
  救解失道众生类　　除拨生死还正路
  又施妻妾及男女　　七宝珠玉及金银
  亦舍上妙众器具　　我为彼故问如来
  舍身命财无厌倦　　长夜听说不疲劳
  心常寂灭行头陀　　我以彼故问正觉
  真实妙语恒系心　　粗鄙恶言闻即离
  而于他所无嫌恨　　我缘彼故咨自在
  常以慈心观众生　　其犹父母爱一子
  而于怨亲行平等　　故我为彼请人王
  现有如斯诸功德　　然我今日以宣陈
  其或未具诸众等　　我亦为是咨问佛
  世尊我今有善根　　初发问时便克获
  藉此菩萨诸功德　　速证寂静三昧王

大方等大集经菩萨念佛三昧分卷第六大方等大集经菩萨念佛三昧分卷第七

        隋天竺三藏达磨笈多译

    赞三昧相品第九

尔时世尊。赞不空见菩萨摩诃萨言。善哉善哉。不空见。汝于往昔乃能供养无量无数诸佛世尊。于诸佛所种诸善根。具足修行诸波罗蜜。一切法中所作已办。而常为彼诸众生辈。作不请友为行大慈。成就正信诸众生故。请问世尊如斯大义。为被大铠诸众生故。请问世尊如是大义。为不动不退大菩提心诸众生故。请问世尊如斯大义。为不坏信意诸众生故。请问世尊如斯大义。为发弘广大愿庄严诸众生故。请问世尊如斯大义。为不思议善根诸众生故。请问世尊如斯大义。为着不思议铠甲诸众生故。请问世尊如斯大义。为超越三界诸众生故。请问世尊如斯大义。为专精实义诸众生故。请问世尊如斯大义。为随顺大智诸众生故。请问世尊如斯大义。为乐甚深法行诸众生故。请问世尊如斯大义。为重布施诸众生故。请问世尊如斯大义。为重开示诸众生故。请问世尊如斯大义。为一切能舍内外身财诸众生故。请问世尊如斯大义。为成就最上无上戒聚诸众生故。请问世尊如斯大义。为深忍相应诸众生故。请问世尊如斯大义。为勇猛精进诸众生故。请问世尊如斯大义。为得深禅定诸众生故。请问世尊如斯大义。为深重智慧诸众生故。请问世尊如斯大义。为以资财方便巧摄一切诸众生故。请问世尊如斯大义。又为心若金刚诸众生故。为心如门闑不动不转诸众生故。为心如净水无有尘垢诸众生故。为心如迦耶邻提衣诸众生故。为乐入深义诸众生故。为尊重正法诸众生故。为舍担能担诸众生故。为不惜身命诸众生故。为不乐一切世间有为诸众生故。请问如来如是大义。不空见。汝于今者能为如斯诸大菩萨摩诃萨辈。请问如来如是义耳。尔时世尊。复告不空见菩萨摩诃萨言。不空见。汝应谛听善思念之。吾当为汝广分别解说。时彼不空见菩萨摩诃萨即白佛言。善哉世尊如蒙圣说一心谛受。佛言不空见。有菩萨三昧。名念一切佛菩萨。当应亲近修习观察思惟。如是三昧既能修习。观察思惟此三昧已。则得增广成就现前安乐法行故。则得增广无贪善根故。则得增广无嗔善根故。则得增广无痴善根故。则得具足惭愧故。则得成就神通故。则得圆满一切佛法故。则得清净一切佛土故。则得天降下生具足故。则得入胎具足故。则得住胎清净具足故。则得母生微妙清净具足故。则得家生清净具足故。则得诸根微妙清净具足故。则得大人相清净具足故。则得诸妙好清净具足故。则得出家具足故。则得最上寂静具足故。则得大寂静具足故。则得诸通具足故。则得为一切众生作归依具足故。则得多闻具足故。则得世间出世间法具足故。则得一切诸法住处具足故。则得巧妙方便知出世法具足故。则得善通达一切诸法具足故。则得巧知前际后际法相具足故。则得善巧庄严文字句义具足故。则得智慧具足故。则得微妙神通具足故。则得巧转变心具足故。则得善教示他具足故。则得为他众生及富伽罗。胜负白黑上下满缺增损胜力具足故。则得是处非处具足故。则得未成阿耨多罗三藐三菩提趣向具足故。则得正行具足故。则得意具足故。则得自在具足故。则得神通具足故。则得尊胜大家具足故。则得大姓具足故。则得端正具足故。则得大威具足故。则得大光明具足故。则得作诸功德具足故。则得大功德具足故。则得大人牛王具足故。则得令他欢喜音具足故。则得令他深欢喜音具足故。则得微妙音具足故。则得梵音具足故。则得相应辩才具足故。则得无诤辩才具足故。则得无著辩才具足故。则得称实辩才具足故。则得种种辩才具足故。则得一切言音辩才具足故。则得所生不离诸佛世尊而常恭敬供养具足故。则得离边地生具足故。则得常生中国具足故。则得遍游诸世界礼拜承事诸佛世尊咨请论义具足故。则得成就无量无边功德具足故。则得一切菩萨功德庄严具足故。乃至则得菩提树下道场庄严具足故。尔时世尊。为重宣此义。以偈颂曰

  不空见斯胜三昧　　如我今住智德中
  其有菩萨能修行　　彼见十方一切佛
  当即速获诸神通　　因是复睹清净刹
  遂能下生妙具足　　入胎具足亦复然
  住胎之时无有比　　母最清净胜家生
  一切相好咸具足　　亦当修彼诸行法
  舍家出家离众欲　　捐弃人欲及与天
  彼为世间求菩提　　所生常有诸甘露
  亦得诸通及神足　　转智圆满彼世间
  多闻总持大德人　　行行斯由多闻海
  统诸大众义明了　　巧知众生方便学
  诸法行处皆悉知　　世间之法及出世
  智人所知智具足　　远离诸业及痴恼
  有为之法尽皆舍　　而常亲近于无为
  常以天眼观众生　　复用天耳听闻法
  宿命明白知过往　　他心善达前人意
  神通变化自在游　　心能巧转随所因
  得大名闻行佛国　　能广利益诸世间
  明达是处及非处　　一切诸法靡不知
  深照净法及垢染　　以常修习胜三昧
  能得正行具足人　　彼之智慧实无比
  具正思惟大威德　　亦得安住正修行
  复生大家及尊姓　　众事端严见者喜
  彼虽处于有为中　　所作功德无能坏
  所生常受大功德　　往来多作人中王
  或为忉利释天尊　　时作光天及梵主
  凡所出声悉无比　　梵天妙响师子音
  诸龙美音遍行中　　大功德声牛王吼
  备于弦乐及歌声　　迦陵频伽音精妙
  能会义理令众欢　　以获三昧故得然
  善出精雅及好声　　多用爱言悦一切
  深婉妙音并善语　　彼声常有未曾绝
  行步举动若龙王　　普放电光照一切
  降雨滂洽于大地　　是谓龙德难称量
  如是人龙所游处　　住斯妙定胜神通
  无量无数诸化身　　遍诸佛前等供养
  偈颂譬喻诸种作　　言词雅正理趣安
  彼常法乐与众生　　得是胜定故无碍
  所生不离于诸佛　　亦见菩萨及圣僧
  恒居利益无难处　　成就三昧照十方
  欲遍诸佛有咨论　　或生无量难思刹
  现前供养一切佛　　成就三昧故若斯
  如是功德不可说　　超过数表绝称量
  道树等觉恒俱生　　诸佛咨嗟唯此定

    菩萨念佛三昧分正观品第十

尔时不空见菩萨摩诃萨白佛言。世尊。若诸菩萨摩诃萨欲得成就诸佛所说菩萨念佛三昧者。彼菩萨摩诃萨应当亲近修习何法。能得成就思惟三昧耶。尔时世尊。告不空见菩萨摩诃萨言。不空见。若诸菩萨摩诃萨欲得成就诸佛所说念佛三昧。欲得常睹一切诸佛。承事供养彼诸世尊。欲得疾成阿耨多罗三藐三菩提者。当住正念远离邪心。断除我见思惟无我。当观是身如水聚沫。当观是色如芭蕉虚。当观是受如水上泡。当观是想如热时焰。当观是行如空中云。当观是识如镜中像。菩萨若欲入是三昧。当应深生怖畏之想。当念远离讥嫌。免他诃责。当念除去无惭无愧成就惭愧。当应成就奢摩他毗婆舍那。当应远离断常二边。常念一心精勤勇猛除去懈怠。发广大心常念观察三解脱门。常念先生三种正智。常念断灭三不善根。常念成就诸三昧聚。常念成就一切众生。常念等为众生说法。当观四念处。所谓身念处受念处心念处法念处。当念四食过患。所谓抟触思识等。于是食中生不净想。当念四无量。所谓修于大慈。行于大悲。安住大喜。具足大舍。当念成就诸禅而不味着。然复思惟一切诸法。常念不惜其身不保其命。舍身及心摄受多闻。念如是法。应如是护不得诽谤。多闻法财如所闻法如义受持。于诸佛所起尊重心。又于法僧生肃恭意。亲善知识远离恶友。除灭世间无义语言。不着世乐不舍空闲。住于一切生平等心。于诸众生无有退没。无损害心亦无妒嫉。于一切法起称量心。不作罪恶心无垢染。一切诸法无处可得。常求甚深广大经典。于中恒起增上信心。莫生嫌疑无为异意。如是经典最胜广大。常念诵持常思演说。何以故。是为诸佛世尊道法。独能生成佛菩提故。于当来世得彼无量诸佛功德。应当为他如法宣说。降伏憍慢莫乱正闻。恭敬尊重供养是法。舍诸欲求息诸诤竞。除诸睡眠灭诸疑网。殄绝迷惑明识我见。不事戏论远离尼干邪命自活遮罗迦波梨婆阇语言论等。常应善住檀波罗蜜中。圆满尸波罗蜜。常念羼提波罗蜜。不舍毗梨耶波罗蜜。游戏禅波罗蜜。具足般若波罗蜜。弃舍身命无爱惜心。如四大性不可改变。如于地界起平等心。水火风界亦复如是。成就身业心意精勤。无不活畏不贪衣食汤药床铺房舍殿堂一切众具。乐行头陀常住知足。不求利养不事名闻。凡是爱着悉灭无余。观四念处断四颠倒。不念恶刺永度四流。修四如意住四威仪。当具五根亦增五力。应灭五盖不用五情。远离五浊成五解脱。得入内自思惟。广大圣智正观五阴。不行六尘降伏六根。亡灭六识断绝六受。除六渴爱行六念处及六智分法。于六通中常求利益。修七觉分通达七界(七界谓害界恚界出界欲界色界无色界及灭界故)。灭除七使及七识住。离八怠惰除八妄语。明了世间八法所因。应得八种大人觉法。证八解脱修八正道。亲近思惟广大分别。专精远离九众生居。灭九种慢捐弃九恼。常思九种欢喜等法。亲近修习九次第定。终不念行十种恶业。而勤造作十善业道。常求如来十种力智。不空见。我今为汝略说如是菩萨摩诃萨念佛三昧法门。诸所当得大利益事。若有菩萨摩诃萨应当修学念佛三昧。如是修者名报佛恩。思惟是者即不退转于阿耨多罗三藐三菩提。亦当满足彼诸佛法。乃至能为一切众生作大依止。亦令成就无上种智故。不空见。斯诸菩萨摩诃萨有大智故。乃能思惟非彼声闻辟支佛人得观察也。不空见。若人于此念佛三昧。或时亲近思惟修习。若受持若读诵。若书写若教书写。若教读诵受持若少开发。若为解说若能广宣。彼虽少时勤苦疲劳然其所作终不虚弃。必获果报得大义利。不空见。彼菩萨摩诃萨以为他受持法故。速得不退阿耨多罗三藐三菩提。于当来世决定作佛。不空见。当知如是念佛三昧。则为总摄一切诸法。是故非彼声闻缘觉二乘境界。若人暂闻说此法者。是人当来决定成佛无有疑也。尔时世尊。为重宣此义。以偈颂曰

  若人欲修此三昧　　能念一切诸如来
  彼既思惟是法门　　诸非法处当远离
  亦当远离无惭愧　　破除断见及与常
  复应安住三空门　　当念勤修解脱智
  既拔三种不善根　　即亦思惟三善本
  若知观察三受处　　得斯妙定良非难
  若人欲求胜三昧　　先应持戒后修智
  自然远离诸邪见　　亦无戏论及语言
  次第观受斯皆苦　　然后观察生灭心
  若人思惟三昧时　　当应深念出世事
  诸法有疑咸悉除　　得此三昧甚为易
  亦应善通四念处　　先当观身不暂住
  恒求解脱及禅定　　不爱寿命岂惜身
  弗以多闻陵侮人　　宁当诽谤于正法
  闻正法已能思惟　　昼夜受持身所诵
  尊重诸佛深敬法　　承事僧众不敢轻
  善知识所常念恩　　远离一切诸恶友
  不与恶人同坐起　　除彼为众说法处
  为求最上菩提故　　终勿舍离阿兰若
  一切众生皆平等　　于诸法中莫分别
  欲求彼法真实际　　诸法相中无著心
  彼轻慢意悉能除　　不久必得此三昧
  明识我见及疑心　　亦当觉察诸调戏
  不得起于恶欲意　　应灭诤竞与睡眠
  若不学彼外道法　　诸是戏论自然除
  但能随顺佛法言　　求此三昧须臾获
  常行布施及戒忍　　勇猛精进无倦时
  恒处禅思及智慧　　自然得斯三昧行
  能施头目无爱畏　　舍余诸物终不疑
  彼趣菩提无艰难　　亦速获斯凝静定
  若能持心如大地　　又同水火及与风
  更等虚空无边崖　　彼人速得此禅定
  若有精诚身口意　　彼不贪食及衣财
  其于众具既无求　　能如是修证三昧
  应常专念四正勤　　亦当成彼诸神足
  速须远离颠倒想　　烦恼棘刺先断除
  当念杜绝四流河　　亦思干消诸渴爱
  具足五根及五力　　分裂破坏五盖衣
  五种欲事不俱怀　　内心幻伪亦宜舍
  复当愿求五解脱　　思惟五身三摩提
  应速观知五阴处　　正心和敬于六缘
  彼不恭慎应远离　　亦当减损六触身
  于六受处心正观　　常念断除六种爱
  复以六通成就世　　亦修六念及智明
  勤求七觉七圣财　　必须舍彼疑惑处
  欲得三昧恒若斯　　渐当散灭诸烦恼
  彼常远离七识住　　斯八颠倒亦拔除
  若能住于八正道　　自当速证此深定
  恒住八大丈夫行　　复以八解自娱心
  不染八法离世间　　获最胜智当不远
  于他人所无嗔心　　先应除此九种慢
  思九欢喜根本法　　得彼次第九种禅
  绝此十恶不善因　　应修智人十种善
  若能修行十种力　　得是三昧终无难
  当念摄持诸善法　　放舍不善众恶缘
  前后勤求彼正念　　证此三昧岂能久
  若住如是三昧已　　当转智力不思议
  遍见诸佛金色身　　所生常得闻正法
  若欲见彼诸世尊　　或已灭度及现在
  当来一切愍世者　　应思惟此胜三昧

    菩萨念佛三昧分思惟三昧品第十一之一

尔时不空见菩萨摩诃萨白佛言。世尊。若诸菩萨摩诃萨念欲成就诸佛所说念佛三昧者。云何思惟而得安住。佛告不空见菩萨言。不空见。若诸菩萨摩诃萨必欲成就是三昧者。先当正念过去所有诸如来应供等正觉。次念现在所有诸如来应供等正觉。次念未来所有诸如来应供等正觉。彼如是念一切三世十方世界中。是等一切诸如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。天降成就。入胎成就。住胎成就。出胎成就。出家成就。诸功德成就。诸根成就。诸相成就。诸好成就。庄严成就。戒品成就。三昧成就。智慧成就。解脱成就。解脱知见成就四无畏慈悲成就。喜舍成就。惭愧成就。威仪成就。诸行成就。奢摩他成就。毗婆舍那成就。明解脱成就。解脱门成就。四念处成就。四正勤成就。四如意足成就五根成就。五力成就。觉分成就。正道成就。往昔因缘成就。双教示成就。诸通教示成就大通教示成就。戒品成就。一切三昧成就。无碍利益成就。为他利益无碍成就。一切善法成就。清净色成就。清净心成就。清净智成就。诸入成就。金色百福成就。时彼菩萨念诸如来如是相已。复应常念彼诸如来应供等正觉。心无动乱。亦当安住无所著心。心无著已彼复应作如是思惟。是中何等名曰如来。为当即色是如来耶。为当离色是如来乎。若以色法为如来者。彼诸众生皆有色阴。一切众生应是如来。若以离色为如来者。离色则是无因缘法。无因缘法云何如来。菩萨如是观知色已。次复观受。彼时更作如是思惟。为当即受是如来耶。为当离受是如来耶。若即受法为如来者。彼诸众生皆有受阴。一切众生应是如来。若离受法为如来者。离受则为无因缘法。彼无缘法云何如来。彼既如是观色受已。乃至观识亦如是。时彼菩萨复如斯念。若此诸阴非如来者。岂彼诸根是如来乎。如是念已则先观眼。为当即眼是如来耶。为当离眼是如来乎。若即彼眼是如来者。一切众生皆有是眼。一切众生应是如来。若离彼眼是如来者。离眼则为非因缘法。彼非缘法云何如来。菩萨如是观察眼已。观耳观鼻乃至观意亦如是。时彼菩萨复如斯念。若此诸根无如来者。岂彼诸大有如来乎。如是念已则先观地。为即地界是如来耶。为离地界是如来乎。若即地界为如来者。彼内外法皆属于地。如是地界应是如来。若离地界为如来者。离地即为无因缘法。彼无缘法云何如来。彼既如是观察地界。乃至观彼水火风界亦如是。而彼菩萨能作如是正思惟时。不以色观察如来。不离色观察如来。如是不以受不离受。不以想不离想。乃至不以识不离识。观察如来亦如是。又彼观时亦不以眼观察如来。不离眼观察如来。如是不以耳不离耳。不以鼻不离鼻乃至不以身意不离身意。观察如来亦如是。又彼观时不以色观察如来。不离色观察如来。如是不以色不离色。不以声不离声。乃至不以触法不离触法。观察如来亦如是。又彼观时。不以地观察如来亦不离地。观察如来如是。不以水不离水。乃至不以风不离风。观察如来亦如是。彼菩萨如是观时。即能于彼一切法中。善通达知明了无碍。尔时彼菩萨复应当作如是思惟。是中更以何等真法。而能得彼阿耨多罗三藐三菩提。为以身得菩提耶。为用心得菩提乎。若身得者。而今此身无觉无识顽痴无知。譬如草木若石若壁。然彼菩提非色非身非行非得。不可见闻不可触证。此身如是。云何能得成就菩提。若心得者而即此心本自无形无有相貌。不可见闻不可触证不可执持。犹如幻化。菩提如是亦无有心无有触对。不可见闻不可知证。此心如是。云何能得成就菩提。不空见。是为菩萨正念思惟。不以身心亦不离身心。而能证得阿耨多罗三藐三菩提耶。佛言。不空见。然彼菩萨常应如是观察思惟。若能如是观诸法时。即得安住于正法中。心无迁变不可移动。当知尔时具足菩萨摩诃萨法。自然远离不善思惟。速疾成就阿耨多罗三藐三菩提。正觉平等真实法界。尔时世尊。为重明此义。以偈颂曰

  过去未来诸世尊　　现在一切遍见者
  冥心空寂行慈爱　　欲睹诸佛无艰难
  往昔诸佛大威光　　怜愍世间等与乐
  彼念人中分陀利　　调御丈夫功德满
  更念下生及入胎　　住胎尊母皆具足
  思彼生家众妙相　　当见等觉弗为难
  亦念诸好胜庄严　　及彼本愿先所行
  微言妙义初中后　　彼皆善逝解脱身
  住解脱门及供养　　正勤与彼四神足
  应念诸根具满者　　力菩提分亦复然
  若念诸佛解脱尊　　不久当到胜寂地
  一切世间利益念　　善法功德难思量
  妙色及与清净心　　复思世尊众好分
  金刚身体百福相　　当知如来诸念满
  何得法中名如来　　正当观察无边处
  诸佛非色复非受　　非彼想行非识心
  如是等法非如来　　正见智人亦应体
  亦非离彼是诸佛　　应供善逝但有名
  诸佛非眼非耳鼻　　非舌身意及法等
  亦非离彼为如来　　正觉庄严惟名耳
  唯有大名无真佛　　离名何处有实者
  智人若知尽和合　　当取等觉实非难
  若以诸阴为如来　　彼诸众生皆有阴
  众生即应是诸佛　　以阴平等斯共有
  不以色等为诸佛　　亦不离阴名如来
  无量数劫正思惟　　不思议智乃成就
  身如草木及石壁　　菩提无色寂无生
  亦无顽身及草木　　云何说身证菩提
  是心无相复无形　　菩提非心亦无状
  非身非心能得证　　亦非无证难思议
  是为最胜寂静地　　外道于中皆荒迷
  若于此法求正勤　　必当速得是三昧

大方等大集经菩萨念佛三昧分卷第七大方等大集经菩萨念佛三昧分卷第八

        隋天竺三藏达磨笈多译

    思惟三昧品之余

尔时不空见菩萨摩诃萨复白佛言。世尊。菩萨摩诃萨当何证知舍离我见耶。佛言。不空见。若诸菩萨摩诃萨得证知时。无有住着则离我见。如是菩萨虽无住着。而能为彼一切世间天人众生作大利益。云何利益。所谓为大法明然大法炬。吹大法蠡。击大法鼓。奋大法鞀。乘大法船。设大法桥。方当欲渡一切众生出于生死四流瀑河。置于涅槃无为彼岸。即当观察是身本性。次当观身不净臭秽腐烂痈脓屎尿盈溢。是身无常不暂停住。破坏枯槁不可长久。诳惑小儿危脆不坚。犹水沫聚户虫充满。筋骨相辅空负而行。无实用处。或经百年及百千岁。纵八万劫一切乐具。守护长养终归堕坏。此身长夜不离烦恼不出颠倒。恒为诸恶鸟兽食啖。又亦常与地狱饿鬼畜生共行。生死往来受诸苦恼。或为奴隶种种苦事。常系于他不得自在。而彼所生云何当能见苦断集证灭修道。今我此身但是虚空。诳曜愚痴无一坚法。以是我今当应持此一切身分施诸众生。若有众生宝重己身。我当为彼放舍身命。若有众生须我精气。我当给与彼之精气。若有众生须我肉者。我当以肉供奉彼等。何以故。宁我先施令彼得食。无容不施使彼自食。今我以此净心布施。所获善根愿即灭除我见根本。而彼菩萨如是观时不着我见。灭我见已然后舍身。令众生用为惜命者弃舍命根。须精气者授以精气。须肉食者便以肉施。若有众生须其力用。即时为奴充彼驱策。不空见。以是因缘彼菩萨摩诃萨。除舍我见。不住我见。证知我见。而能于此不牢固中求牢固身。不空见。譬如都城邑聚村落之中。多有童男或多童女。自舍出已至河岸边见水沫聚。以彼水沫更相嬉戏。所谓破坏水沫分段磨灭。令其消散无有遗余。而彼沫聚不作是念。谁于今日能分散我。是沫虽坏无恼恨心。不空见。如是菩萨摩诃萨。自观己身无常破坏。如彼沫聚不可长久。当知是人得此三昧。疾成阿耨多罗三藐三菩提。尔时世尊。为重明此义。以偈颂曰

  若能远离我见者　　一切无有住着处
  为利世间天人故　　当证难见大菩提
  彼若厌身诸不净　　痈疮所处脓血流
  此身变坏不坚牢　　无常羸劣斯破法
  暂住如幻无实体　　犹彼聚沫空无真
  长夜养育终无宜　　鸟狗斯食最可恶
  虽以众具供赡之　　是身会当归败灭
  既不能得牢固法　　经无量劫唯有苦
  地狱畜生饿鬼苦　　饥渴众恼恒炽然
  世间催切超百罗　　初不觉知彼如实
  我身今日自空虚　　不常之体须臾变
  谓诸众生食肉者　　精气仆役我甘为
  我思此时常发言　　其有食肉及精血
  我为其故今放舍　　任从啖食我此身
  当令一切宝身者　　悉得观我舍斯命
  我今躯命不敢爱　　愿速成彼三摩提
  犹如彼沫常破坏　　未曾起一嗔恨心
  今我此身如沫团　　岂有生于嫌怨事
  若能观身如水沫　　此人必定求菩提
  非但得奉十方尊　　彼当速获胜三昧

    菩萨念佛三昧分示现微笑品第十二

尔时世尊怡然微笑。诸佛世尊法如是故。即微笑时。世尊口放种种光明。所谓青黄赤白金色颇梨。其光远照上至梵宫。而复还下右绕三周入世尊顶。时尊者阿难见斯事已即从座起。整理衣服右膝着地。合十指掌向佛世尊。以偈问曰

  最胜世尊非无因　　今现微笑当有以
  世间调御应为说　　而复微笑何因缘
  金刚色体百福身　　由证真如能利益
  一切世间所归依　　今此微笑有何缘
  世尊无上亦无比　　何处当有能超胜
  功德备具无可毁　　今斯微笑有何缘
  一切世间皆归趣　　调御丈夫今当宣
  谁于今日获大利　　世尊无何微笑者
  今日谁当受大位　　今日谁得真福聚
  今日谁为安隐王　　能致世尊是微笑
  一切世间所归依　　天人大师今应说
  若闻佛尊斯妙音　　天人欢喜众圣赞

尊者阿难设斯问已。于是世尊告阿难曰。阿难。我当说是正念三昧法门义。时此大众中有三万人。远离尘垢得法眼净。复有八万亿百千那由他诸天子。远尘离垢得法眼净。复有三万比丘比丘尼众得阿那含果。复有三万比丘比丘尼优婆塞优婆夷得无生忍法。复有三万众生发阿耨多罗三藐三菩提心。此辈皆于星宿劫中成等正觉。此即前发菩提心者是也。复有九万亿那由他菩萨摩诃萨。安住菩提无有退转。此辈当来皆得成佛。彼诸世尊有四种号。或号光明。或号毗卢遮那。或号释迦牟尼。或名日月岁星。有如是等诸种名号。随其刹土出现于世。复有九十二亿百千那由他众生。但发声闻心。是辈未来皆证声闻果

尔时世尊知是事已。以净天眼过于人眼。观察十方见九十亿百千那由他诸佛世界。应作如是大利益故。更出殊大微妙之声。遍此三千大千世界。咸得闻已。然后及彼诸佛国土。所有众生亦皆得闻。然后复从眉间白毫相中。放大光明名无边威。此光遍照十方佛国。令无量亿百千那由他众生得须陀洹果。斯陀含果阿那含果。阿罗汉果。复有过于前数众生发阿耨多罗三藐三菩提心。彼等当来皆得不退转于阿耨多罗三藐三菩提。然后于彼十方国土皆得成佛。号曰难伏如来应供等正觉出现于世。尔时世尊。为重宣此义。以偈颂曰

  过百千数无减少　　三种三十复九十
  如是一切见菩提　　彼为发心利益故
  彼满十千诸众生　　复三万智得净眼
  闻已正思等正觉　　解脱人身诸恶道
  复过八亿那由他　　诸天获于圣净眼
  以闻如来妙音故　　永灭恶趣无遗余
  得忍三万亿由他　　发心即离三恶道
  彼辈当来悉成佛　　其犹盛春草木敷
  复有三万亿众生　　从座而起发大心
  以此威德当成佛　　于大地上利世间
  复有六万诸天子　　皆发无上菩提心
  彼等斯同弥勒尊　　以修乐因证乐处
  以是因缘天人师　　为斯广大故微笑
  我已宣扬微笑旨　　阿难当知此笑缘

    菩萨念佛三昧分神通品第十三之一

尔时不空见菩萨摩诃萨白佛言。世尊。云何当知菩萨摩诃萨住于惭愧。远离于彼无惭愧已。然后当得此三昧耶。尔时佛告不空见菩萨言。不空见。若有菩萨摩诃萨常行惭愧。而是菩萨行惭愧时。或能造作种种恶事。所谓身恶行时即生惭愧。口恶行时亦生惭愧。意恶行时亦生惭愧。起嫉妒心亦生惭愧。起懈怠心亦生惭愧。于诸如来所亦生惭愧。于大菩萨摩诃萨所亦生惭愧。于住菩萨乘诸众生所亦生惭愧。于声闻乘人所亦生惭愧。于辟支佛乘人所亦生惭愧。于人天所亦生惭愧。云何惭愧。所谓常愧于他亦惭自身。住于一切不善法中故常惭愧。住惭愧已远离一切无惭无愧。除灭不善思惟善事。荷负重担体性清净。终无毁犯他不能谤。而是菩萨常能具足无毁身业。亦能具足无毁口业。亦能具足无毁意业。具足斯已。然后乃能住是三昧。住三昧已。常不远离见一切诸佛。常不远离听闻诸佛所说妙法。常不远离恭敬供养一切圣僧。具足如斯已。然后乃能疾成阿耨多罗三藐三菩提

复次不空见。我念往昔过无量无边阿僧祇劫。时有大劫名曰善来。于彼善来劫中。后有第三劫名曰宝炬。不空见。彼于劫中复有小劫名九庄严。于彼时中名多劫浊。复次有劫名曰千岁。彼中有转轮王。名善观作。而彼善观作王。宿植德本具大威德。不空见。时善观作王所居大城。名曰净华妙香充满。其城东西广六十由旬。南北长七十由旬。墙壁周围有一千二百重。彼城身量纯以真金。众具庄严间用七宝。不空见。汝今欲知净华香城善观作王。果报众具庄严殊丽如先所说。无边精进王。善住大城无差异也。不空见。彼城北面有一内门。名曰华鬘门。外有园名曰无畏。其园纵广四十由旬。周匝皆有七宝树林而为围绕有一大池形量方广面十由旬。八功德水弥满其间。如忉利天镘陀吉尼池也。彼池四面周匝皆有宝多罗树。其金多罗树银为花果。银多罗树琉璃华果。如是乃至真珠多罗树金为华果。如善住城一等无异。复次不空见。当尔之时有佛世尊。号鸯耆罗娑(隋言分味)如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。不空见。时彼鸯耆罗娑如来。处游居止无畏园中。与大比丘众九十九亿百千那由他人俱。前后围绕皆阿罗汉。诸漏已尽无复烦恼。皆得自在心善解脱。慧善解脱。所作已办捐舍重担。尽获己利不受后有。随顺正教达于彼岸。不空见。时彼鸯耆罗娑如来应供等正觉。于晨朝时着衣持钵。与九十九亿百千那由他声闻大众。左右围绕入净华香城。不空见。时彼善观作王知彼世尊晨朝入城。即自庄严乘大调象。名曰乐手。与无量亿百千那由他众前后导从。自彼净华香城而出。为奉迎彼佛世尊故。不空见。时善观作王既遥见彼鸯耆世尊寻路而来。光仪端远状若金山。诸根寂静神志和穆。已达第一调柔彼岸。犹如大龙降伏一切。亦如大象所为自在。又如大池澄清映彻。如是见已。自乘而下进诣世尊。头面作礼右绕三周而启白言。唯愿世尊。受我明朝所设供养。复次不空见。时彼鸯耆罗娑如来应供等正觉。闻善观作王如是请已。为诸众生作利益故默然受请。复次不空见。时善观作王闻彼世尊许纳其请。即于斯夜速命厨官。严办众种上味美食。人间所有靡不毕具。于净华城平治道路。以诸香泥涂饰其地。所在街巷建立宝幢。妙善名幡处处罗布。兼列种种金宝器具。又用上妙牛头栴檀。以为香水洒散其地。复以种种末香种种散华。上撤于佛而为供养。然后于彼如来应等正觉前。烧种种名香。积种种华鬘而为供养。又以种种歌颂赞叹偈句法言而为供养。又作种种上妙乐音及诸玩具而为供养。彼王如是作诸供养。然后奉献上妙饮食。供养世尊及比丘众。复次不空见。尔时彼善观作王。广设如是微妙第一最上众具。满足供养鸯耆如来应供等正觉已。更于异时庄严大驾。躬自率彼无量千数诸众生等。诣无畏园。至彼鸯耆如来应供等正觉所。顶礼尊足已而白佛言。世尊。今正是时。唯愿垂慈作所应作也

复次不空见。时彼鸯耆罗娑如来闻善观作王殷勤请已。知诸众生堪受化故。于是为彼如所应作种种神通。现神通已。遂与九十九亿百千那由他诸阿罗汉等身升虚空。住虚空已即放九十九亿百千那由他光明。照于东方无量世界。如是复放前数光明。照彼南方及以西北四维上下。周遍十方亦皆如是。彼一一方各有九十九亿百千那由他诸大光明。彼一一光皆各化作八十亿百千那由他等大莲华座。彼诸华座皆各有一化如来坐。彼诸如来形量长短乃至一切威仪多少。一如鸯耆罗娑如来应供等正觉无差别也

不空见。如彼变化诸佛世尊。各有无量亿那由他诸比丘众。前后围绕住虚空中。又亦各有化天帝释及化梵王。形量大小皆如今此无超胜梵天及大供养天帝释等无有异也。不空见。时彼鸯耆罗娑如来应供等正觉。示现如是神通事时。于须臾间一切诸天。所有音乐不鼓自鸣。一切众具不作自现。不空见。时彼欲界诸天既睹鸯耆世尊。示现如是大神变时。即以天栴檀末香沉水香多伽罗香多摩罗跋牛头栴檀黑沉水香等奉散佛上。复以种种妙华。所谓鸡娑罗华。大鸡娑罗华等。奉散于彼鸯耆罗娑如来应等正觉

复次不空见。尔时鸯耆世尊告彼善观作王言。大王。诸行无常。大王。诸行皆苦。大王。诸行无我。大王。诸行暂住不得久停。大王诸行不坚是破坏法。大王。诸行炽然如猛火焰。大王。诸行深奥如大火坑。大王。乃至应当念舍诸行。当生深厌亦不可乐。当念远离终思解脱。不空见。尔时善观作王。一心合掌恭敬向彼鸯耆如来。具领赞曰。如是如是。大德修伽陀。大德婆伽婆。诸行无常。大德婆伽婆。诸行是苦。诸行无我。大德婆伽婆。诚如圣教。一切诸行皆应远离。亦须弃舍终当免脱。不空见。尔时彼鸯耆罗娑如来。为彼善观作王。说如斯法。令其欢喜。令其专念。令其奉行。令欢喜已。令专念已。令奉行已。然令发阿耨多罗三藐三菩提心

复次不空见。尔时鸯耆罗娑如来。见善观作王闻法欢喜发菩提心一切众生咸得益已。即与九十九亿百千那由他诸阿罗汉比丘大众。举身腾踊足步虚空出净花城。然后还下如常威仪。前后围绕入无畏园。不空见。时彼善观作王。既得亲睹鸯耆罗娑如来应等正觉广现如是神通事时。发菩提心更作誓曰。当令我等于未来世。悉获如是大神通慧。复当令我悉得如是统诸大众。复当令我于未来世悉得如是天人众前大师子吼。一如今日鸯耆如来应供等正觉无有异也。不空见。时彼善观作王。见彼世尊鸯耆罗娑如来应供等正觉及诸大众乘空而返。王便严驾奉从世尊达本住所。然后乃还。复次不空见。后于异时。彼鸯耆如来应供等正觉。与诸大众次第而行。至善观王宫殿中已当铺而坐。诸比丘僧亦次第坐已。尔时彼善观作王及诸大臣。与其眷属各自围绕。城内人民及其眷属亦各围绕。又皆自持所有供食。各自手奉鸯耆世尊及诸弟子声闻大众。其食香美众味具足。随意奉上佛及众僧。一切啖食皆得充满。然后更以种种妙香。种种花鬘种种衣服种种珍宝一切众具微妙音乐。供养恭敬已。即于是日呼召太子。加以天冠受以王位。弃四天下及诸眷属。深厌生死。请佛出家。即于鸯耆佛世尊所。释除须发法服着身。时有八万四千亿百千那由他人民。善根既淳熟故。亦深厌世从王出家

复次不空见。时彼善观作王既出家已。即于众中整理衣服。恭敬合掌。遂便请彼鸯耆如来应供等正觉言。世尊。云何菩萨修习思惟念佛三昧耶。菩萨摩诃萨云何证此念佛三昧。即得住于不退转地。速疾成就阿耨多罗三藐三菩提。现前成就诸功德法。不空见。时彼善观作王比丘如是问已。彼鸯耆如来即便告彼王比丘言。善观作。汝应当知有二种法。菩萨摩诃萨具足修习。即便得此菩萨念佛三昧。能速成就阿耨多罗三藐三菩提。何等为二。一者信诸如来不生违逆。二者信佛所说不敢谤毁。作如斯念。是为诸佛广大境界不可思议。善观作。是为菩萨摩诃萨得此三昧能速成就阿耨多罗三藐三菩提。善观作。复有二法。菩萨摩诃萨具足修习能速成就阿耨多罗三藐三菩提。何等为二。一者奢摩他。二者毗婆舍那。善观作是为菩萨摩诃萨具足修习得此三昧能速成就阿耨多罗三藐三菩提。善观作。复有二法。菩萨摩诃萨具足修习得此三昧。能速成就阿耨多罗三藐三菩提。何等为二。一者远离断见。二者灭除常见。善观作。是为菩萨摩诃萨具足修习得此三昧能速成就阿耨多罗三藐三菩提耶。善观作。复有二法。菩萨摩诃萨具足修习得此三昧。能速成就阿耨多罗三藐三菩提。何等为二。一者住于羞惭。二者修于耻愧。善观作。是为菩萨摩诃萨具足修习得此三昧能速成就阿耨多罗三藐三菩提

复次不空见。时彼如来如是说已。彼善观作王比丘。复白鸯耆罗娑如来言。世尊。云何菩萨摩诃萨住惭愧已而能得斯念佛三昧耶。尔时鸯耆罗娑如来应等正觉。即告彼善观作比丘言。善观作。若诸菩萨摩诃萨于诸所作常行惭愧。谓起身恶行生惭愧心。起口恶行生惭愧心。起意恶行生惭愧心。起嫉妒时生惭愧心。起懈怠时生惭愧心。于诸佛所生惭愧心。于诸菩萨摩诃萨所生惭愧心。于住诸菩萨乘众生所生惭愧心。于诸声闻乘所生惭愧心。于诸辟支佛乘所生惭愧心。于诸天人所生惭愧心

大方等大集经菩萨念佛三昧分卷第八大方等大集经菩萨念佛三昧分卷第九

        隋天竺三藏达磨笈多译

    神通品之余

云何惭愧。所谓常惭于人亦愧自身。住于一切不善法中常行惭愧。成就惭愧远离不善。念求善事身荷重担。种性清净无所亏犯。时彼善观作王比丘。既从彼佛闻教诲已住于惭愧。为灭一切不善法故。勤求精进及以意欲。一心回向住诸善法。又令满足更广思惟不令忘失。专精摄心住于正观深入法界。如是比丘观法界时。不见一法增。不见一法减。彼既观法无增减已。当彼如是见一切法无有去来。彼当如是见一切法无得无丧。彼当如是见一切法无有生灭。彼当如是见一切法无有差别。彼当如是见一切法无有异。彼当如是见一切法因缘生。彼当如是见一切法犹如梦想。彼当如是见一切法犹如阳焰。彼当如是见一切法犹如镜像。彼当如是见一切法犹如形影彼当如是见一切法犹如声响。彼当如是见一切法犹如幻化。彼当如是见一切法无有胜负。彼当如是见一切法本无优劣。彼当如是见一切法不可成就。彼当如是见一切法本来不生。彼当如是见一切法无有生处。彼当如是观一切法皆悉平等。不空见。彼既能作如是观已。亦即能作如是修行。不久便能得是三昧。不空见。而彼善观作王比丘得此三昧已。即能成就无碍辩才。说诸法义无有穷尽。又彼善观作王比丘。即于尔时过六十亿百千那由他劫已。然后得成阿耨多罗三藐三菩提。不空见。汝今于此犹有疑心。我为汝释令得除断。不空见。当知彼时善观作王。舍四天下五欲众具。与彼八万四千亿那由他臣民大众。于彼鸯耆佛世尊所。同时出家剃除须发。精勤修道者非谓异人。汝亦不应更作他观。何以故。不空见。当知彼时善观作王比丘。今彼莲华上如来是也。又于尔时善观作王。舍四天下一切乐具。与八万四千亿那由他臣民大众。鸯耆佛所出家修道住惭愧行。正观诸法一心思惟。未几即便证此三昧也

复次不空见。以是因缘。我于今者殷勤郑重。为汝宣说此三昧门所作功德甚深广大不可思议。当知非彼不能广种胜妙善根。诸众生辈而得听闻。而能读诵受持修行。乃至为他解说义理。复次不空见。若有诸善男子善女人。但能耳闻此三昧者。当知彼诸善男子善女人辈。终非薄福种少善根也。亦非一如来所种诸善根也。亦非二三四五诸如来所种诸善根也。亦非一十二十三十四十五十。乃至非一百诸如来所种诸善根也。亦非二百三百乃至千万亿诸如来所种诸善根也。如是乃至亦非于无量亿百千那由他。乃至亦非于无量阿僧祇。及过无量阿僧祇尔许诸如来所。种诸善根厚集功德。而获闻此宝三昧王名字少分。何况当能书写披读赞诵受持。思量义趣如法修行。为多人众分别解释也。复次不空见。若彼一切善男子善女人辈。但得耳闻此菩萨念佛三昧门者。应知彼善男子善女人。非是薄福种少善根者。当知彼诸善男子善女人等。即是具足菩萨乘者何以故。不空见。若人得闻此三昧王。当知彼辈依其次第。自然证成阿耨多罗三藐三菩提。唯除一切诸漏尽者

尔时不空见菩萨白佛言。大德世尊。所住行阿耨多罗三藐三菩提。大德世尊。彼等常证此三昧王耶。彼佛报言。不空见。汝见如是彼等亦证此三昧王也。复次不空见。譬如有药名曰真正。若以其药用涂军鼓。于斗阵时以椎击打。假彼阵中有为毒箭刀槊所伤。彼药力故皆即平复安隐无患。如是不空见。若有善男子善女人但能耳闻此三昧王名字少分者。彼等以此三昧名声威力。皆当得成阿耨多罗三藐三菩提。唯除漏尽身证之人。复次不空见。譬如须弥山王四宝所成。若诸众生至其所者即同其色。何以故。以彼山威光皆同一色。如是不空见。若彼善男子善女人。耳暂闻此宝三昧名。彼等皆以三昧名声威德力故。自然速成阿耨多罗三藐三菩提。唯除漏尽正位诸富伽罗。何以故。不空见。以此三昧有不思议胜功能故。复次不空见。譬如一切大河陂池及以诸流。皆入大海同一碱味。悉由大海德力弘故。如是不空见。彼诸善男子善女人。但能耳闻此三昧名。假令不读不诵。不受不持不修不习。不为他转不为他说。亦复不能广分别释。然彼诸善男子善女人。皆当次第成就阿耨多罗三藐三菩提。何以故。以此三昧名声胜故。威德力故。复次不空见。若有诸善男子善女人。诚言时。善说时。但能诚言及与善说。诸佛法门必定当得。开示兴显能广利益诸世间者。是名诚言。是名善说。不空见。若彼善男子善女人能得正言及善说者。必定当得无量无边过阿僧祇不可思议大功德聚。何况彼能善说于此菩萨念佛三昧法门所获功德聚也。不空见。假使无量无边恒河沙菩萨摩诃萨。复经无量无边过恒河沙劫数。修行布施无暂休废。我若说是所得功德不可思议。今更为汝广分别说。若复有一菩萨摩诃萨能听受斯念佛三昧。若读诵若受持。若少分修行。若少分论说。所得功德望前布施。不可喻比。不可称量。不可计挍。不可算数。不可宣说。何况有能具足听受修行。演说是功德聚而可校量耶。尔时世尊为重明此义。以偈颂曰

  我念往昔无量劫　　有佛世尊鸯耆罗
  一切世间所归依　　具大慈悲演妙法
  于彼所见无不知　　过去未来悉明了
  亦能通达现在事　　等见幽微斯觉察
  诸佛智慧难思议　　怜愍众生故为说
  愚痴众生苦煎迫　　观彼一切兴悲心
  时彼如来有如是　　九十九亿声闻众
  咸具自在有生尽　　悉共围绕正法王
  彼城东北有园林　　具足庄严名无畏
  如来大仙住于此　　兼彼亿众阿罗汉
  彼善观作转轮王　　严备宝驾自出城
  无量臣民众围绕　　一切众生皆爱乐
  王睹世尊心寂静　　身口清净诸根调
  具足胜妙诸威仪　　彼善观王转增敬
  王便往诣彼佛所　　头面顶礼世尊足
  启口请佛受其供　　世尊许纳故默然
  王以如来许受故　　即敕城内诸臣民
  今宜具办微妙供　　吾欲奉献鸯耆佛
  众事既严王亲告　　唯愿哀愍照此时
  大师世尊及圣僧　　受我今日微末饭
  鸯耆如来赴王请　　大功德聚广现神
  遂作无量千亿光　　普照十方诸佛土
  彼一一光出无量　　百千亿数大莲花
  微妙鲜明人喜乐　　为发众生诸善本
  汝不空见知诸花　　各出化诸如来形
  意念现前人瞻仰　　十方同说如斯法
  诸行无常亦实苦　　复说无我极羸劣
  终是破坏不坚牢　　孰云智者生贪乐
  诸行焚烧如猛火　　炎赫烗炽甚难当
  鸯耆世尊如如宣　　佛为众生发深厌
  诸天睹斯大神通　　百千乐音俱时作
  香花自然而雨下　　异哉希有难思议
  彼王见佛神变故　　设诸供事不可量
  此四天下可重尊　　投弃五欲如脱履
  佛前释发服袈裟　　便尔请问微妙定
  当住何等胜法已　　丈夫能入三昧门
  鸯耆世尊如是说　　住于二法善思惟
  当自证此微妙禅　　得不思议最上乐
  王蒙彼佛诚实言　　深心欢喜触斯定
  常念菩提奉诸佛　　即受尊号上莲华
  若能信受如来语　　于是经典无复疑
  入佛境界深法门　　自然得入此三昧
  若闻实际不惊疑　　于法亦无我人想
  勤念奢摩毗婆舍　　如是深思触胜禅
  住于惭愧及恭敬　　常应修习诸正勤
  知已恶现生耻心　　证三昧王岂能久
  恒观诸法不见增　　亦自弗知诸法减
  见一切法如虚空　　菩萨智人通达此
  诸法非兴复非丧　　本性清净常湛然
  知一切法同睡梦　　如是见者逮三昧
  于彼不作差别相　　本不见灭亦无生
  犹如阳焰及镜像　　能如是见得三昧
  法相平等无高卑　　亦无存亡及优劣
  如彼声影与幻化　　如是见人证三昧
  诸法寂然无胜负　　不见外相及内心
  无有成就复无名　　如是见者证三昧
  比丘如是专精观　　初中后夜常思惟
  顶受尊教于佛所　　不久当证此三昧
  彼当证此三昧时　　已于菩提无缺减
  亦见十方一切佛　　供养功德大众生
  过是六十亿百千　　那由他劫修诸行
  承事无量诸佛已　　然后证彼大菩提
  汝不空见今应知　　尔时彼王其谁是
  智人不当生异见　　莲花上佛即善观
  我今教诫于汝辈　　一切世间诸天人
  若欲究竟诸法源　　当念速净此三昧
  彼必大集功德聚　　不可算数难称量
  欲得妙乐不思议　　要先净修此三昧
  若欲尽见一切佛　　现在未来及十方
  或复求转妙法轮　　亦先修习此三昧
  若欲圆满诸妙相　　具足众好上庄严
  及求转生清净家　　必先受持此三昧
  汝不空见诸众生　　即欲远离诸恶道
  悉欲知于下生者　　应常赞诵此三昧
  彼非供养于一佛　　亦非二三及四五
  乃至亿数那由他　　方得闻斯胜三昧
  彼供诸佛过僧祇　　为证无上大菩提
  及众所欲皆悉得　　乃得闻此胜三昧
  彼供无量百数佛　　过去久种诸善根
  常生欢喜尊敬心　　方得说此胜三昧
  彼事无量千数佛　　天中胜天能放光
  精勤修习无懈倦　　尔乃赞诵三昧经
  彼见无量亿数佛　　无边净光若日轮
  厚习一切诸善根　　然始得闻妙三昧
  又如世间攻战场　　其中多有被毒害
  彼或遇闻药鼓音　　众毒消除得安乐
  若人说此三昧时　　其或得闻胜定者
  三昧威力证菩提　　非彼漏尽正位人
  彼定功德等须弥　　若人证时无异相
  其或能往到山所　　即同其色难别知
  若人得闻三昧声　　诸定中胜犹如海
  由斯三昧威德力　　彼证菩提不复疑
  亦如众流归大海　　大河小河及陂池
  等同一味难别知　　彼亦如是无异相
  若人闻此三昧时　　即念十方一切佛
  三昧威力登正觉　　非彼身证富伽罗
  若诸菩萨唯修檀　　过于无边恒沙劫
  供养十方一切佛　　下及法界诸众生
  如是旷劫行布施　　所获功德虽言多
  犹不及说妙定门　　起一念慈被一切
  三昧善思如慈母　　光显圣德难度量
  智人若能一心求　　当速成佛具自在

    菩萨念佛三昧分说修习三昧品第十四之一

尔时不空见菩萨摩诃萨白佛言。世尊。菩萨摩诃萨具足几法当能入斯念佛三昧耶。佛告不空见菩萨言。不空见。若诸菩萨摩诃萨具足三法。即能入此念佛三昧。何等为三。一者具足不贪善根。二者具足不嗔善根。三者具足不痴善根。若能具足三善根已。即得成就六波罗蜜。而彼菩萨摩诃萨。以能住彼不贪善根故。而常行施具足成就檀波罗蜜。所生常得家产丰饶财宝具足。所须便至永离贫穷。有大威德有大势力。其心弘广无复狭劣。自然摄彼贪不善根。以能具足诸福德故。众生见者莫不尊敬。凡所言说人皆信行。不用多功获此三昧。速疾成就阿耨多罗三藐三菩提。又彼菩萨以于一切世间天人诸众生所。无有嗔恚忿恨之心故。故能具足不嗔善根。而常住彼尸波罗蜜羼提波罗蜜。能具足满忍波罗蜜已。或逢骂詈谤毁楚挞挝捶割截手足挑髓破脑一切诸苦竞来迫切。不怒不恨不恚不嗔。于是除灭嗔不善根。起大慈心遍覆一切众生界已。所生不离诸佛世尊。梦寤常安天神卫护。刀仗不害毒不能中。火不能烧水不能溺。常足饮食汤药衣服卧具种种众物。一切世间天人众生见者赞美。不久即能证此三昧。当能速成阿耨多罗三藐三菩提。又彼菩萨以能具足无痴善根故。长夜修习奢摩他毗婆舍那。具足方便善能断除痴不善根。成就微妙甚深智慧。于一切法了了分明。诸异论门无有挂碍。若他问难辩释无疑。不空见。是为菩萨摩诃萨具足三法证此三昧当能速成阿耨多罗三藐三菩提。复次不空见。菩萨摩诃萨复有三法能入三昧。复能速成阿耨多罗三藐三菩提。何等为三。一者观一切行无常如实知。二者观一切行苦如实知。三者观一切法无我如实知。菩萨若能如是观已。不久即能入此三昧。不空见。是为菩萨摩诃萨具足三法能证三昧亦速成就阿耨多罗三藐三菩提。复次不空见。菩萨摩诃萨复有三法能入三昧。亦能速证阿耨多罗三藐三菩提。何等为三。一者如来现在修诸供养。若灭度后或时供养诸佛舍利。或以种种上妙香花。及以花鬘涂香末香烧众名香然灯幡盖宝幢音乐等。若自供养或复教他常发誓愿。愿我所生以此供养行愿善根。令我速得念佛三昧。亦当证成阿耨多罗三藐三菩提。二者若佛现在及入涅槃。赞说如来真实功德。若戒若定若智慧若解脱若解脱知见。若威仪若神通若辩才若无诤。若慈悲若喜舍。及余世尊诸功德法皆常赞说。亦发誓愿。愿我从今赞叹诸佛所获福聚所得功德。藉此善根当令我得念佛三昧。复能速成无上道果。不空见。是为菩萨摩诃萨成就三法能入三昧亦能速成阿耨多罗三藐三菩提。复次不空见。菩萨摩诃萨复有三法。不久则能成就三昧。亦当速证阿耨多罗三藐三菩提。何等为三。一者若诸菩萨摩诃萨。或从一切佛世尊所。闻此三昧真实功德。或时但闻三昧名字即自思念。如彼过去诸如来应等正觉。本行菩萨求菩提时。彼辈皆求如此三昧。是以闻此三昧即生随喜。我于今日为大菩提。亦应勤求如是三昧。成就具足大利益故。是故我今闻此三昧功德名字深生随喜。是名具足第一随喜法也。二者如彼未来一切诸如来应等正觉。为求菩提行菩萨时。修此三昧为大利益。是故我今闻此三昧亦生随喜。是名第二具足随喜法也。三者如今现在所有十方无量无边诸如来应等正觉现住世者。已度诸有已拔习根。断灭语言远离觉观。证甚深定具大慈悲。亦于往昔行菩萨时。闻此三昧皆生随喜。我今既获闻此三昧。何独不可起随喜乎。如是念时深生随喜。是名具足第三随喜法也。不空见。是为菩萨摩诃萨具足成就三种随喜。所获功德及诸善根。愿与众生同证三昧。亦速成就阿耨多罗三藐三菩提

复次不空见。若复诸善男子善女人辈。于此三昧生随喜时。所得功德真实广大。无量无边难可称说。我今为汝引诸譬喻。开示少分令汝知耳。不空见。如此三千大千世界。其间所有诸恒河沙。若人取彼诸恒河沙聚置一处。然后于彼大沙聚中。取一一沙末为微尘。然后将此沙之一尘。过恒河沙世界。更复过彼无量无边阿僧祇不可思议不可称不可量恒河沙等世界已。然后方乃置一微尘。如是次第一切沙尘。计诸世界悉皆布尽。不空见。汝意云何。假使彼世间人颇能少知世界数不。不空见言。无也世尊。不空见。且置是事。假使世间聪明智慧第一算师尽其智力及以算术。颇能称量颇能思察。复能数知世界数不。不空见言。无也世尊。无也世尊。今我所见唯有上座舍利弗。及彼不退转地诸菩萨摩诃萨辈。应少仿佛耳。佛言不空见。若有善男子善女人。以上尔所诸世界盛满七宝及余众具。持用供养一切众生。不空见。汝意云何。彼人如是供养行檀。所获功德宁为多不。不空见言。甚多世尊。无量世尊。佛言。不空见。我更语汝。彼善男子善女人。虽能以上一切世界盛满七宝众具。供施一切众生功德虽广。然故不及前善男子善女人等。闻此三昧宝王名字。发起三种随喜之。心誓愿回向阿耨多罗三藐三菩提所得功德。何以故。不空见。以彼三种由多闻生也。彼多闻从正说起故。不空见。由彼正说故。能生一切善根。即此三昧也。何等三昧能生一切善根。所谓即此菩萨念佛三昧也。又复能生一切善根。亦即正说。何等正说。谓正说时善说是也。以是义故。彼三种随喜所获功德。望布施福。不可称量不可挍比

复次不空见。我念往昔过于无量阿僧祇。复无量阿僧祇劫。尔时世界名动不动。彼界有佛号曰宝山庄严如来应供等正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出兴于世。得大自在调伏一切。具足解脱永度彼岸。最上最妙最胜无比。能为众生作大归依。能与众生为大覆护。能治众生诸烦恼病。通达三世无不明了。以自证法为众生说。其所说法初中后善其义深远。其言巧妙纯一无杂。具足清白梵行之相。为诸众生常如是说。时彼宝山如来应等正觉。住一王城。城名伏怨。与三十亿那由他百千声闻大众皆是学人。当有所作。当有所断。当有所得。应受世间天人供养。不空见。时彼宝山如来从三昧起作如斯念。今我此三十亿那由他百千声闻皆是学人。所作未办未到彼岸。我于今者应为此等如法而说。当令一切速得漏尽。不空见。尔时彼宝山庄严佛。广现如是大神通事。令彼三千大千世界尽皆烟出猛焰炽然。不空见。尔时彼声闻众。睹彼如来广作如是大神通事。见已欢喜踊悦遍身。犹如比丘入第四禅。彼声闻众身心快乐亦复如是。复次不空见。尔时彼佛于静夜中显示如是神通事已。因即告彼声闻众言。汝诸比丘。应当观此三千大千世界满中烟出。又复猛火焰炽烔然。诸比丘。一切诸行无常亦尔。诸比丘一切诸行苦事亦尔。诸比丘。一切诸法无我我所。无有坚牢虚妄不真。可破可坏皆灭尽相。诸比丘。我今略说一切诸行。乃至一切放舍莫着。深生厌离自然解脱。不空见。尔时彼三十亿那由他百千声闻众等。蒙彼如来说如是法如是教诫。皆得漏尽通达诸法。于诸法中无有挂碍。善住诸法度诸疑网。于教师所听受法已。于诸法中了无所畏。发大声言。如是婆伽婆。如是世尊。诸行无常。如是世尊。诸行是苦。如是世尊。诸法暂住。如是世尊。诸法破裂不可依止。如是世尊。诸法炽然。犹如草木及以石壁。如是世尊。一切诸行。乃至可放可舍可厌可脱。不空见。时彼宝山庄严如来以如是神通。以如是说法。以如是教诏三种示现。化诸声闻众令入三解脱门谓空无相愿已。复有三十亿那由他百千诸菩萨众。皆当得成阿耨多罗三藐三菩提。不空见。尔时彼佛。为彼三十亿那由他百千诸菩萨众。说此三昧宝王。如是显示已。复为彼天人世间作利益故。经八万四千亿那由他百千岁。转正法轮已。然后于彼无余涅槃而般涅槃

尔时不空见菩萨摩诃萨白佛言。世尊。彼宝山庄严如来现前教化几菩萨众。复佛灭度后法住几时耶。佛告不空见菩萨摩诃萨言。不空见。于此三千大千世界所有星宿其数可知。然彼宝山庄严如来应等正觉边际数量难可得知。而彼如来般涅槃后。正法住世。满八十亿那由他百千年。像法住世二十亿岁其后未几。复有佛出。名曰慈行如来应等正觉。出现于世寿命无量。其佛身量满一由旬。尔时众生身以量足长六拘卢舍。其莲花床大者高十三由旬。小者犹高六由旬遍满大地。所有众生往返周旋行住坐卧。皆各在于莲花之上。尔时世界名盛莲花。其地柔软犹如羊毳毛。众生触着如天妙衣。其色光泽状忉利天黄白之石。彼诸众生等受快乐。亦如他化自在天宫。彼诸众生欲度东海。瞬息之间便到彼岸。南西北海骏速亦然。彼诸众生凡所之从发心即至。而彼慈行如来初成佛时。其地广博尽四海边。时彼大地纵广正等。满八十亿那由他百千由旬。诸声闻众皆悉充满。诸阿罗汉多一坐食。唯除侍者阿难。及金刚密迹阿斯多等。复有八十那由他诸大菩萨摩诃萨众。一切皆住不退转地。彼诸菩萨请问甚深妙定法门。而彼慈行如来为诸菩萨开发显示深法门时。慈行世尊唯出一音。即说斯偈

  若人方便求出家　　应当一心思妙法
  彼必摧坏恶魔军　　犹如香象破草屋
  谁求疾成大菩提　　应为世间常说法
  而欲净斯最胜地　　此三昧乐则能为

大方等大集经菩萨念佛三昧分卷第九大方等大集经菩萨念佛三昧分卷第十

        隋天竺三藏达磨笈多译

    说修习三昧品之余

时彼慈行如来大化将末。有一比丘名曰树王。广为众生说此三昧示教利喜。于彼如来应供等正觉灭度之后。正法之际有转轮王。名曰天主。具足威德有大神通。七宝金轮正法治世。不空见。彼天主王所居大城名曰因陀罗跋帝(隋名天主城亦名帝幢)。纵广正等十二由旬。其城内外楼观台殿。皆以七宝杂色所成。复以金廊而覆城上。不空见。彼城四面各有三门。若说其城诸庄严事如上所说。精进力王善住大城。庄严华丽殊妙无差也。不空见。后于一时夜过半已。彼天主王睡犹未觉。有净居天下降王所令王梦见。即于梦中为王说此念佛三昧法门名字。大王。汝应求此念佛三昧。何以故。若诸菩萨摩诃萨能得成就此三昧者。常不远离诸佛世尊。亦于世间出世间。文字章句音名语言。皆悉明了具足辩才。自然速成阿耨多罗三藐三菩提。不空见。时天主王梦见天已。即便觉寤白彼天言。诸天人辈。如是三昧谁能持者。彼天报曰。大王。汝宁不闻耶。今有比丘名曰树王。现能受持如斯三昧。广为世间分别演说。利益一切人天大众。不空见。彼天主王当得闻此三昧名时。即能受持思惟观察。并亦诵念彼比丘名。过是夜已。即于晨朝。舍四天下金轮王位。亦复弃舍八十亿百千那由他后宫妃后女侍之属。又尽放弃五欲众具。斯皆为是三昧王故。王时复与九十六亿百千那由他众生求彼比丘舍家出家。不空见。时彼树王比丘。与四部众天龙夜叉及人非人周匝围绕。复有九十亿欲界诸天左右听法。复有八十那由他诸菩萨众在前赞说。是三昧王分别解释显其义趣。彼天主王至其所已。即以众宝散比丘上。然后方始五体投地。一心顶礼彼比丘足。又以八十宝箱各容一斛。盛满金花奉散其上。复以天花。所谓优钵罗花。钵头摩花。拘物头花。分陀利花。曼陀罗花。摩诃曼陀罗花。用散其上。复以天诸妙香。所谓天沉水香。多伽罗香。多摩罗跋。牛头栴檀。黑沉水栴檀末香等。用散其上广设如是众供具已。然后请为比丘弟子。即于是日与九十六亿百千那由他臣佐民人在比丘前。剃除须发服袈裟衣厌世出家。皆为求此妙三昧故。是后其天主比丘。常得与彼九十六亿那由他百千眷属比丘。亲近供养恒河沙等诸佛世尊。亦皆为此胜三昧故。不空见。尔时彼天主比丘。经八十四亿那由他百千岁。以种种众具供养事彼树王比丘求此三昧。读诵受持如说修行。教诸弟子终不暂懈。又彼眷属比丘大众勇猛精进亦无倦心。不空见。彼天主比丘及其眷属。于树王法师生尊重心。起诸佛想闻说妙法。一心受持长夜精勤初不休息。彼树王比丘皆悉成就。彼九十六亿百千比丘。行菩萨行住不退地。然后灭度。彼诸眷属皆亦命终。时复有佛。名阎浮幢如来应供等正觉出现于世。而彼天主比丘与诸眷属。而更于彼阎浮幢如来应供等正觉所。勤求咨问如此甚深三昧经典读诵受持。思惟其义如说修行。为他解释利益世间一切天人。为证无上大菩提故。又彼天主比丘为此无上胜三昧故。广分别说诸佛所宣甚深经典。过三千劫已然后作佛。又能教化无量大众。皆得成熟毕竟安住不退转地。悉受阿耨多罗三藐三菩提记。佛告不空见。汝今当知。尔时彼天主王者岂异人乎。即今之最上行如来应供等正觉是也。是故汝今不应疑惑

复次不空见。汝当一心思惟观察此三昧王善根浅深功德少多。吾今为汝少分说耳。若彼世间无量无边亿那由他百千众生。但能耳闻此三昧名。当来必定成等正觉。何况此众菩萨摩诃萨。亲于我前或在我后。闻我广说此三昧王。若读诵若受持。若思惟义若修行。若能为他称扬广说也。不空见。若有菩萨摩诃萨住菩萨乘。闻此三昧经于心耳。彼亦不久必当成就阿耨多罗三藐三菩提。复有初住菩萨乘诸菩萨等。即便速证不退转地。于阿耨多罗三藐三菩提亦不为远。复次不空见。譬如夜分将尽其日未出东方明相始现之时。阎浮提人莫不欢喜。何以故。知彼日轮不久当现。广为世间作大照明。令阎浮人咸得睹见。若善若恶。净秽诸色得有所作。如是不空见。若有善男子善女人。若但能闻此念佛三昧经于耳者。彼辈不久尽得成于阿耨多罗三藐三菩提。是故汝等于此三昧。作决定心起不坏信。莫生异见勿怀疑网。复次不空见。如劫将尽彼第六日现世间时。如是一切三千大千世界大地尽皆烟出。烟既出已。当知不久第七日出。一切世界皆悉烔然。如是不空见。若有善男子善女人。或已住彼菩萨乘中及未住者。若曾闻此念佛三昧经于耳者。或时读诵或有受持。或思惟义或如说行。乃至或能为他广说。彼等决定速得成就阿耨多罗三藐三菩提。复次不空见。如人穿井若见湿土黏污手足。或时复见水泥杂和。智者当知去水不远。如是不空见。若有善男子善女人。闻此菩萨念佛三昧。正意受持谛善思惟分别义理。广为他人宣扬解释。当知彼诸善男子善女人。不久自成阿耨多罗三藐三菩提。复次不空见。譬如有人吞金刚丸。当知是人不久必死。何以故。彼金刚丸不可消故。如是不空见。若有善男子善女人。但能听闻如是三昧。或复思惟或常亲近。或亦修习或能宣说。当知彼诸善男子善女人。不久必成阿耨多罗三藐三菩提。何以故。此三昧者即是过去现在未来三世一切诸如来应供等正觉。思惟修习清净成就真实金刚。无有虚伪不可破坏。复能教化诸菩萨辈令其安住。以诸菩萨必能安隐住于大乘故。复次不空见。譬如三十三天见欢喜园皆生安乐。如是不空见。彼一切菩萨摩诃萨。皆因闻此三昧名字故。能速成阿耨多罗三藐三菩提。以是三昧法门名字。往昔诸佛之所赞叹。为他广说释解理义。开发显示名味句身。具足圆满安住法界拥护摄持。诸大菩萨教化增长。令乐真道正直淳和常受安乐。不空见。以是因缘。汝应知此若诸菩萨闻此三昧暂经心耳。如是诸善男子善女人。不久当证阿耨多罗三藐三菩提。不空见。吾故语汝汝当善知。若诸菩萨摩诃萨闻此甚深念佛三昧。能受持者。彼等善男子善女人。自然疾成阿耨多罗三藐三菩提。复次不空见。汝应受持如是三昧。常念为彼一切世间比丘比丘尼优婆塞优婆夷。及诸国王大臣宰相刹利婆罗门毗舍首陀一切乞士。并余种种外道尼犍遮罗迦波利婆阇迦等颁宣广说。何以故。以此三昧大德威力。能令彼等速成阿耨多罗三藐三菩提故

复次不空见。若有善男子善女人。净信敬心分明知此念佛三昧。过去诸佛之所赞叹。一切如来之所印可。如是知已。当即读诵当即受持。当即修行当即敷演。复应当作如是思惟。今此三昧为不思议大功德聚。如是思已。当更信敬当更尊重。当更深入当更证知。所以者何。今此三昧乃是一切诸佛之所说也。一切诸佛之所行处也。一切诸佛之所印可也。一切诸佛之正教也。一切诸佛之辩才也。一切诸佛之所觉也。一切诸佛之选择也。一切诸佛之所作也。一切诸佛之财宝也。一切诸佛之府库也。一切诸佛之伏藏也。一切诸佛之仓廪也。一切诸佛之印玺也。一切诸佛之舍利也。一切诸佛之体性也。不空见。若彼善男子善女人等。能如是知即得无量无边善根。缘此功德。所生常处大刹利家。大婆罗门家。及余一切大威势家。大尊重家。大德天处。乃至当证阿耨多罗三藐三菩提。何以故。不空见。由此三昧具足能得不思议出世间果报聚故。不空见。彼善男子善女人。若但耳闻此三昧名。当得无量无边福聚。亦复当作无量无边福行。然彼所得福聚善根。福行功德广大甚深。不可挍计不可算数不可称量不可得知。复次不空见。言粗若此义尚未明。我今为汝更引譬喻。令诸智者少分解之。不空见。若有菩萨摩诃萨专心信乐修行檀波罗蜜。日三时施。于日初分以神通力故即令七宝及余众具。充满于彼恒沙世界。还用奉上恒沙如来应供等正觉。及诸弟子声闻众等。如日初分如是行施。日中后分行施亦然。日别如是三时行施。乃至经彼无量无边亿那由他恒河沙劫。而常行是无有休废。亦复求于阿耨多罗三藐三菩提。不空见。于意云何。彼菩萨摩诃萨能于如是长时行施。所获功德可谓多不。不空见言。甚多世尊。无量无边不可算数。不可称量不可思议也。时佛复告不空见菩萨言。不空见。吾更语汝汝宜谛听。假彼菩萨摩诃萨如是修行檀波罗蜜。所种善根所获福聚实为广大。然犹不及斯善男子善女人但能耳闻此三昧名。或时书写或时读诵。或时信解如来所说深妙法门少功德也。不空见。然此善男子善女人。但以闻名所获功德。尚超前福无量无边。不可称量不可挍比。何况彼善男子善女人。具足得闻是三昧。能即书写读诵受持思惟义理。善能为诸人天大众宣扬广释也。不空见。汝今当知我但略说三昧功德。若欲广说此定善根假经多劫终不能尽

    菩萨念佛三昧分诸菩萨本行品第十五

尔时不空见菩萨摩诃萨。善现菩萨摩诃萨。善喜光菩萨摩诃萨。无边见菩萨摩诃萨。无边庄严菩萨摩诃萨。无边幢菩萨摩诃萨。无边光明菩萨摩诃萨。无边称菩萨摩诃萨。无边禅菩萨摩诃萨。无边智菩萨摩诃萨。无边发王菩萨摩诃萨。无边自在王菩萨摩诃萨。思惟最胜无边菩萨摩诃萨。思惟一切法意菩萨摩诃萨。思惟虚空意菩萨摩诃萨。思惟无碍意菩萨摩诃萨。无边宝意菩萨摩诃萨。能灭一切怖畏菩萨摩诃萨。善净意菩萨摩诃萨。如是等菩萨摩诃萨为首。与九十亿那由他百千菩萨摩诃萨俱从座起。偏袒右肩右膝着地。合掌恭敬而白佛言。世尊。我等从佛闻是菩萨念佛三昧功德利益。我等要当躬自书写读诵受持。思惟义理广为他说。亦令他人如说修行。何以故。我等为欲摄受阿耨多罗三藐三菩提故。世尊。我等于此诸佛世尊所说三昧甚深经典。令诸众生闻已欢喜。我等亦当益其气力与其安乐。所以者何。彼等若能于是大乘修多罗中。次第修行闻已书写。读诵受持分别思惟广为他说。亦令他人分别解说。必得成就阿耨多罗三藐三菩提故

尔时世尊。知诸菩萨摩诃萨等一心念求。遂便微笑。诸佛世尊法如是故。即微笑时世尊面门放种种光。所谓金银琉璃颇梨马瑙车磲真珠。如是一切诸宝光中。各皆复出无量百千异色光明。皆自世尊面门而出。遍游十方无量世界。上至梵宫还住佛顶。如天帝释建立宝幢。端直光华见者欢喜。时此三千大千世界。庄严壮丽微妙无比

尔时彼诸菩萨摩诃萨众。见是神变庄严事已。咸皆惊叹。奇哉希有世尊神通。于是众中有一菩萨摩诃萨。名如意定智神通。即从座起正持威仪。合掌恭敬顶礼世尊已。用天沉水香。多伽罗香。多摩罗跋香。牛头栴檀末栴檀等。奉散佛上。复以天曼陀罗花。摩诃曼陀罗花。天优钵罗花。波头摩花。拘物头花。分陀利花。鸡娑罗花。摩诃鸡娑罗花等。供养世尊已。说偈赞曰

  世尊调御无伦匹　　金色相好具足人
  光明威德遍十方　　状若林间开花树
  妙行圆满智无边　　大威能为世间益
  最胜方便愿演说　　今复微笑有何缘
  世尊无等无边智　　挺超众类谁能加
  无上威德今应宣　　何因今日复微笑
  今此世界遍大千　　花敷尽若帝天树
  一切众生皆欢喜　　今更微笑何所因
  盲者能视聋得闻　　哑者得言蹇能步
  狂乱失心获本念　　今复微笑何因缘
  群兽喜跃悉鸣吼　　异鸟欢欣吐清音
  众乐不鼓自然鸣　　今者何因复微笑
  一切乐音同时作　　本非天人之所鼓
  而令人天获安乐　　今更微笑何所缘
  彼天观人明照此　　斯人今亦见彼天
  天人交发希有心　　何缘今更现微笑
  无上丈夫世依止　　大尊今日为我宣
  若闻大慈怜笑者　　唯深庆幸岂能报

尔时世尊。即为如意定智神通菩萨摩诃萨。宣说大士所有妙问。亦即宣彼恒沙诸如来应供等正觉名号。其偈词曰

  诸善男子等　　闻法王妙声
  彼六十八千　　悉发菩提愿
  亦于当来世　　正法毁坏时
  世尊自护持　　如是深妙典
  我闻大名称　　终无有厌倦
  不思议法门　　诸佛之所说
  汝听我今说　　斯诸菩萨众
  非但一佛所　　发此诚敬心
  我念往昔诸生处　　六十六亿那由他
  尔时皆亦如斯起　　唯为护持此深法
  又复过去前于兹　　无量恒沙诸佛所
  于彼为首修虔敬　　最上妙法我护持
  斯诸大士为法故　　能舍重命岂爱身
  其何甘法不惮苦　　独为菩提无上证
  不可思议恒沙数　　无量威德诸如来
  彼时上首皆敬起　　亦唯爱乐斯法故
  宝光火光大光佛　　电光普光不思议
  斯辈三等摄持法　　为求菩提无上道
  唯我神力能知汝　　果报今日皆明现
  不空汝久发斯愿　　经昔无量百千生
  汝于诸佛大师前　　不思议行悉圆满
  常业歌赞两足尊　　苦行熏修诸大誓
  由往积集胜因缘　　今获偈叹大法王
  往昔世尊号善眼　　亦名火幢无边威
  斯辈彼时为上首　　欲求无上正觉故
  往昔有佛庄严王　　刹若他化天宫所
  斯辈多是胜上士　　彼时已就大菩提
  过去有佛名放光　　亦无边光无量相
  斯辈于彼己为首　　初求如是妙三昧
  大摩尼珠火光佛　　普光明聚调御师
  彼时摄法为首起　　求于菩提安乐故
  大光日光不思议　　无量精进无边定
  于彼摄法上首起　　为求安乐菩提故
  善华香佛及金华　　无漏如来无诤行
  彼时皆为护法首　　为求如是上菩提
  如是过去诸如来　　无边智尊雨足尊
  于彼三种摄持故　　祈愿最上佛菩提
  八万丈夫通达士　　为证第一妙菩提
  斯辈因是胜善根　　当来奉侍人中觉
  所生常处尊胜家　　一切永除诸恶道
  斯等集会为法朋　　终不远离世间觉
  长违一切外论师　　亦舍一切邪智友
  摄诸功德不可说　　此福要登以菩提
  当来得值弥勒尊　　此辈尔时皆集会
  于是三业持护法　　因此能成胜菩提
  复于弥勒涅槃后　　有佛师子调御师
  亦求彼法三业持　　因此得成等正觉
  当来千佛无上尊　　即是贤劫众生导
  斯等法师世恒说　　因证无碍妙色身
  过是贤劫诸佛已　　复有正觉无量威
  更有如来厥号贤　　及以世尊毗婆尸
  贤与毗婆尸灭后　　复有佛出名娑罗
  彼时智者皆摄持　　广设众具兴供养
  娑罗世尊既涅槃　　有佛如来名观察
  斯辈于彼求法故　　而复供养妙法王
  观察如来涅槃已　　有佛世尊名遍见
  遍见如来涅槃已　　有佛厥名莲花上
  花上如来涅槃已　　有佛称号优钵罗
  尔时诸智还求法　　承事供养两足尊
  优钵罗佛涅槃已　　有佛世尊名曰花
  彼花如来涅槃已　　有佛世尊号庄严
  庄严如来涅槃已　　有佛世尊名胜智
  斯辈于彼亦求法　　兴建供养无有边
  胜智如来涅槃已　　有佛世尊名善见
  善见如来涅槃已　　有佛世尊名善持
  善持如来涅槃已　　有佛名曰具威仪
  彼亦三种法摄持　　唯求证斯菩提道
  具威仪佛涅槃已　　有佛世尊无量威
  无量威佛涅槃已　　有佛世尊名胜王
  胜王如来涅槃已　　有佛世尊名现前
  现前如来涅槃已　　有佛世尊最炽王
  尔时此等为法故　　广设供养不思议
  如是未来诸世尊　　世间胜智超一切
  于已身命无爱吝　　但为求证佛菩提
  因藉如斯胜善根　　将来奉承胜威德
  是佛人中最第一　　如彼调御阿弥陀
  于彼殊胜世尊所　　即欲修证上菩提
  为求法故常精勤　　当设无边妙供养
  彼方所有诸世界　　远离衰恼除五尘
  唯求法乐利群生　　供养忆数恒沙佛
  当来成佛无边智　　能多利益灭众苦
  为求安乐诸众生　　供养无量无边佛
  当得成佛大名称　　彼刹庄严难思议
  尽是众宝人乐观　　犹安乐国殊广大
  多亿那由诸菩萨　　咸受佛记人中尊
  以不思议诸佛智　　如是赞称大法王
  我于今者为汝说　　一切大众诸天人
  其有求于正觉真　　终自同彼如来证
  若能愿乐胜菩提　　彼号上人蒙威护
  诸天守卫及龙鬼　　鸠槃金鸟并夜叉
  若欲祈愿成菩提　　心常乐修佛胜道
  世尊哀愍如一子　　身金色力智多闻

大方等大集经菩萨念佛三昧分卷第十


大方等大集经贤护分卷第一

    No. 416 [Nos. 417-419]

大方等大集经贤护分卷第一

        隋天竺三藏阇那崛多译

    思惟品第一

如是我闻。一时佛在王舍城迦兰陀竹园精舍。与大比丘众五百人俱。皆是阿罗汉。诸漏已尽无复烦恼。咸得自在。心善解脱慧善解脱。调伏一切犹如大龙。所作已办众行具备。弃舍重担不受后生。行于平等获真己利。安住正教得到彼岸。唯除长老阿难一人。尔时复有五百诸比丘。于晨朝时。各从住处诣世尊所。恭敬合掌顶礼佛足退坐一面

尔时尊者舍利弗。尊者大目连。在舍卫城夏安居已。亦与五百诸比丘俱。次第游行城邑聚落至王舍城。入迦兰陀竹园精舍诣世尊所。到已恭敬顶礼佛足退坐一面

尔时世尊。以神通力放大威光。令彼诸国城邑聚落。一切诸有诸比丘众。咸各来诣王舍大城。入迦兰陀竹园精舍至世尊所。恭敬合掌顶礼佛足退坐一面

尔时迦兰陀竹园精舍。有百千数诸比丘等。承佛威光皆已云集至世尊所。恭敬合掌顶礼佛足退坐一面

尔时复有彼摩诃波阇波提比丘尼。亦承世尊威神力故。亦与二万比丘尼俱悉皆大集。入迦兰陀竹园精舍诣世尊所。恭敬合掌顶礼佛足退坐一面

尔时王舍大城有优婆塞。名曰贤护。为众上首。亦与五百优婆塞俱。受持五戒具足威仪。是大菩萨。久已住于阿耨多罗三藐三菩提行。本愿力故。常随世尊乐闻正法。恒勤精进。为满一切助道法故。于朝旦时。承佛威神从本住处。入迦兰陀竹园精舍至世尊所。恭敬合掌顶礼佛足退坐一面

尔时毗耶离大城有一离车子。名曰宝生。为众上首。亦与二万八千诸离车俱。于晨朝时。承佛神力。皆自彼城发来入此迦兰陀园至如来所。恭敬合掌顶礼佛足退坐一面

尔时瞻婆城有一长者子。名曰星藏。为众上首。亦与二万八千长者子俱。于晨朝时。承佛神力。自瞻婆城发来入此迦兰陀园。至世尊所。恭敬合掌顶礼佛足退坐一面

尔时复有一摩那婆(隋言净持亦云少年亦云仁童子等)。名那罗达多。为众上首。亦与二万八千人俱。于晨朝时。自本住处发来入此迦兰陀园诣世尊所。恭敬合掌顶礼佛足退坐一面

尔时舍卫国复有长者。名大善商主。并彼给孤独长者。为众上首。亦与二万八千人俱。自彼舍卫国诣王舍城入迦兰陀园至世尊所。恭敬合掌顶礼佛足退坐一面

尔时王舍大城复有长者。名曰水天。为最上首。亦与二万八千人俱。从本住处发来入此迦兰陀园诣世尊所。恭敬合掌顶礼佛足退坐一面

尔时摩伽陀国主韦提希子阿阇世王。亦与百千诸眷属俱。于晨朝时。亦来入此迦兰陀园。诣世尊所。顶礼佛足退坐一面

尔时复有四大天王。及天帝释乃至欲界一切天众。各与无量百千亿那由他眷属天众俱。亦于晨朝。悉来入迦兰陀园至如来所。顶礼佛足退坐一面

尔时复有娑婆世界主大梵天王。亦与无量百千亿那由他眷属天众俱。于晨朝时。悉入迦兰陀园至如来所。顶礼佛足退坐一面

尔时复有大自在天王。亦与无量百千净居诸天众俱。于晨朝时。悉入迦兰陀园。顶礼佛足退坐一面

尔时复有四阿修罗王。各与无量百千眷属阿修罗众俱。亦于晨朝。入迦兰陀园诣如来所。顶礼佛足退坐一面

尔时复有难陀龙王及跋难陀龙王。各与无量百千眷属诸龙众俱。亦于晨朝。入迦兰陀园诣如来所。顶礼佛足退坐一面

尔时复有裟伽罗龙王阿那婆达多龙王。及摩那斯龙王伊跋罗龙王等。各与无量百千眷属诸龙众俱。亦于晨朝。入迦兰陀园诣如来所。顶礼佛足退坐一面

尔时此三千大千世界。一切诸比丘比丘尼优婆塞优婆夷。及以一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。乃至人非人。及诸王等信如来者。为听法故。一切皆集迦兰陀园诣如来所。顶礼佛足各坐一面

尔时迦兰陀园。其地弘广如此。三千大千世界所有地方大众充满无空缺处。若杖头许而不遍者。如是上至有顶下逮梵宫。所有一切大威德神通诸天大众。乃至一切诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等皆来集会

尔时贤护菩萨摩诃萨即从座起偏袒右肩右膝着地。合掌向佛白佛言。世尊。我于今者欲得咨问如来应供等正觉。心中所疑。不审世尊。见垂听不。尔时世尊复告贤护菩萨言。贤护。如来世尊随汝所疑。恣汝所问。为汝宣释令汝欢喜。时彼贤护菩萨。既蒙听许复白佛言。世尊。菩萨摩诃萨。具足成就何等三昧。而能得彼大功德聚。云何得入多闻大海获智慧藏。问无疑惑故。云何复得无意戒聚不失成就于阿耨多罗三藐三菩提。无退减故。复云何得不生愚痴。邪见空处故。云何当得宿命智。遍知去来故。云何当得不离奉见诸佛世尊。听闻正法乃至梦中故。云何当得殊特端正上妙色身。具足威仪众生乐见故。云何当得常生大姓之家尊贵之位。见者恭敬故。云何复得父母兄弟宗亲眷属及以知识左右围绕。恒无别离故。云何当得广达博通所为殊异。亦终无缺减于阿耨多罗三藐三菩提心故。云何当得正念正行。节度不移心知足故。云何当得常生惭愧。远离耻辱故。云何当得正智谦恭。降伏我慢故。云何当得策勤精进远离懈怠故。云何当得大慈大悲大喜大舍。平等与乐故。云何当得闻说甚深真空无相无愿法时。一切无有惊怖退没故。云何当得不乐懒惰。摄受正法故。云何当得智慧通达。明了一切无与等者故。云何当得于一切佛刹。随意得生故。云何当得不为一切外道所摧坏故。云何当得如海。能受纳众问疑释难无减无尽故。云何当得如月满。白净法具足故。云何当得如日初出。破诸闇冥故。云何当得如灯炬。光明照了故。云何当得如虚空性。无有挂碍故。云何当得无所住着。心如虚空故。云何当得如金刚。穿彻通达一切法故。云何当得如须弥山。不可动摇故。云何当得如门阃。一切正住故。云何当得如猫狗兽等。心业成就故。云何当得无为。一切诸法中故。云何当得如飞鸟。随意而去故。云何当得摧折憍慢。如旃陀罗子故。云何当得住阿兰若。如诸兽猕猴等不乐城邑聚落。一切出家在家不相参乱故。云何当得统领大众。教诏导示故。云何当得不乐生一切众生中。不动于一切众生故。云何当得不为一切外道。降伏天魔惑乱故。云何当得大辩才。于一切法决了知故。云何当得于一切佛法。不随他行故。云何当得大坚固信。无可毁坏故。云何当得大慈力信。不可动故。云何当得深入信。无所行故。云何当得润泽信。于一切法中多欢喜故。云何当得最胜信。供养承事一切诸佛无厌足故。云何当得种种入信。种诸善根故。云何当得真妙信。增长无虚伪行故。云何当得净喜信。除灭一切嫉妒故。云何当得清净信。得一切种智光明故。云何当得喜乐行信。除灭诸盖障恶故。云何当得智喜信。摄受诸佛境界故。云何当得庄严行信胜一切世间璎珞庄严。佛国清净成就故。云何当得清净戒行。永灭一切声闻辟支佛心故。云何当得庄严大誓。一切所作皆究竟故。云何当得为一切众生中上首。欲行诸善法故。云何当得无有疲倦。为欲教授一切菩萨所学诸波罗蜜故。云何当得不退转。多求一切佛法故。云何当得不可坏。不为一切外道邪师所破故。云何当得深信一切诸佛。不舍此念常见诸佛故。云何当得如父想。绍隆一切佛法故。云何当得佛力加持于一切佛法光明中生故。云何当得无障碍。一切佛法悉现在前故。云何当得如幻人。于一切法无思念故。云何当得如化者。观一切法无生灭故。云何当得如梦。观察三世无来去故。云何当得如镜像。一切世界斯现身中故。云何当得如响声。一切法无作无为因缘生故。云何当得如形影。于一切生法自无心取舍故。云何当得空无所有。远离一切诸佛想故。云何当得无相。观一切法无有二故。云何当得法界边际。菩提心无限量故。云何当得不起着。一切世界性无分别故。云何当得无碍行。遍游一切诸佛刹中故。云何当得诸陀罗尼。闻一知万善达一切文字分别说故。云何当得如诸法师。善知一切佛法故。云何当得一切诸佛所护念。一切佛威力加持故。云何当得雄猛不怯弱出声。如大牛王及大师子王步故。云何当得无畏。令一切世间欢喜故。云何当得无疑惑。于一切佛平等无二故。云何当得通达如如。灭除疑惑不着诸法故。云何当得证深法界。善能解释所问义故。云何当得师利益他。具足大慈故。云何当得灭除懒惰。恒乐说法故。云何当得如法住。不舍一切众生故。云何当得不谄曲。性淳直故。云何当得如眼目。为一切世间灯明故。云何当得不可轻蔑。胜出一切三界故。云何当得无诤论。如教说行故。云何当得无艰难。行无住着故。云何当得知于实际。不分别诸法故。云何当得说一切语言智。令诸众生住于大乘故。云何当得至无畏处。远离恐怖永无一切毛竖等事故。云何当得知佛方便说。善达一切修多罗等故。云何当得不空生世间。恒入一切众中获利故。云何当得为一切智首。于一切世间应受供养大名闻故。云何当得无边赞叹功德。为一切众生福田故。云何当得大欢喜踊跃无量。常在诸如来师子座下故。云何当得胜上辩才。能问一切佛法故。云何当得意不怯弱辩才。于一切大众中无怖畏故。云何当得一切论议辩如师子王。降伏一切外道摄受诸异论师故。云何当得不坏本誓庄严。欲摧一切邪异朋党故。云何当得善巧说法常处师子座。一切诸佛印可故。云何当得远离一切世间无义语言。以通达一切正教故。云何当得深爱一切诸佛法。于诸如来生处行故。云何当得乐欲真法。知诸如来不生故。云何当得不懈慢。善承事知识故。云何当得不染着。游行一切世界故。云何当得愿行具足。为教化一切众生故。云何当得如珊瑚。得诸相故。云何当得如虚空。一切法无得相故。云何当得如菩萨。不断佛种故。云何当得不休息行。诸菩萨道未曾远离大乘故。云何当得着大铠甲。诸佛广大戒中决定住故。云何当得一切诸佛所赞灌顶。住于诸如来十力地中故。云何当得一切所想。通达一切诸法行故。云何当得一切算数。巧方便知故。云何当得善知一切成坏。远离一切障碍行故。云何当得一切不住行。不取不舍故。云何当得一切大施主。能施无悔故。云何当得入诸法海。能施胜上法宝藏故。云何当得一切世间行。能舍世间诸相故。云何当得广大神通。随顺诸佛神通满足欢喜故。云何当得一刹那时间行。即能遍至一切诸佛前故。复云何当得住此佛刹遍见一切十方诸佛听闻正法供养众僧。非但未得出世六通。而实未得世间五通。而亦未舍此世界身。亦无生彼诸佛国土。唯住此土见余世界诸佛世尊。悉闻诸佛所宣正法。一切听受如说修行。世尊。譬如今时圣者阿难。于世尊前亲闻法已。皆悉受持如说奉行。彼诸菩萨身居此土不至彼界。而能遍睹诸佛世尊。听闻法已悉能受持。如说修行亦复如是。从是已后一切生处。常不远离诸佛世尊听闻正法。乃至梦中咸若斯也

尔时世尊告贤护菩萨摩诃萨言。善哉善哉。贤护。汝今乃能请问如来如是妙义。汝为利益一切世间诸众生故。亦为安乐诸众生故。复为怜愍诸天人故。复为摄受未来世中诸菩萨故。贤护。而汝往昔已曾供养无量诸佛种诸善根。听闻正法。受持正法。爱乐正法。敬重正法。汝今但以摩诃迦叶教化行故。少欲知足。恒乐闲静阿兰若处。或居冢间。或在树下。亦露地坐。常坐不卧一敷不移。受乞食法一食不再。或一坐食。或唯一抟。唯畜三衣及粪扫衣。赞叹头陀。劝请诸菩萨。教菩萨行法。令诸菩萨喜。诃责诸菩萨。教示诸菩萨。成就诸菩萨。能为利益行大慈悲。于诸众生生平等心。咸得自在到于彼岸。随意得见一切诸佛。发广大愿行深妙行。乐一切智菩提梁柱。善能随顺如来种性。发菩提心犹如金刚。通达世间众生所念。广大妙行不可校算。不可称量。常在一切诸佛目前。贤护。于汝功德中未说少分也

贤护。今有菩萨三昧名曰思惟诸佛现前三昧。若有菩萨。具足修习如是三昧。当得成就如上所问诸功德等。贤护当知。更有无量无边胜上功德说不可尽

尔时贤护菩萨复白佛言。善哉世尊。唯愿说此菩萨念一切佛现前三昧。令此世间天人梵魔沙门婆罗门。诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。多获利益多受安乐故。亦令当来无量众生多得利益受安乐故。又为未来诸菩萨辈作大光明承受威力故。又愿现在未来诸菩萨等。普得闻此念一切佛现前三昧。彼既闻已皆悉受持。既受持已一切皆当如实修学如教奉行。既学行已当令得不退转于阿耨多罗三藐三菩提。现前即能具足成就如是功德及余胜上功德等

尔时世尊复告贤护菩萨言。贤护。如汝言者。汝当谛听善思念之。吾今为汝分别解脱。贤护复言。善哉世尊。我深乐闻如来所说。佛复告言。贤护。云何名为菩萨思惟一切诸佛现前三昧。若有菩萨具足成就此三昧者。即获如前诸功德事。亦得其余殊异功德。所谓心念诸佛皆现在前。其心不乱。不舍作业。求胜上智。勇猛精勤。荷负重担度脱众生。承事供给诸善知识。常修空寂广大思惟。亲善知识灭除诸盖。远离恶友息世语言。塞诸根门。初中后夜减损睡眠。不贪衣服食饮汤药堂房屋宇床座众具。恒乐空闲住阿兰若。不爱己身不重我命。不着形色不纵其心。修以慈心薰以悲行。一切时喜常行舍心。破坏烦恼成就诸禅。于中思惟不着滋味。观察色想。唯得空心不乱正念。不取诸阴不着诸入。不思诸界不贪生处。调伏慢高不妒他财。为诸世间多作饶益。于诸众生起平等心。又于众生生父母想。亦于众生所作一子心。一切法中无有诤想。虽念持戒而不执着。常在禅定亦无耽染。好乐多闻不起分别。戒聚不缺定聚不动。智聚不妄诸法无疑。不背诸佛不谤正法。不坏众僧不好乖离。亲近众圣远离愚痴。不志求出世。虽闻语言意不乐听。亦不耽着世间六味。习近熏修五解脱法。除灭十恶念修十善。断灭众生九种恼处。心常不离九想观门。常思弃捐八种懈怠。一心修习八大人觉。不着禅味不恃多闻。摧伏我慢一心听受。求法殷重修道证知。怜愍众生离我分别。求寿命想毕竟难得。观察诸阴无有物想。不住涅槃不着生死。诸行烦恼轮发大恐怖想。诸阴怨家想。诸入空宅想。诸界毒蛇想。三界衰恼想。涅槃利安想。观诸欲恶犹如唾涕。深乐出家不违佛教。于众生所劝行功德。于诸世界无复染心。见一切佛皆悉现前。受一切身皆若幻梦。一切诸相观察灭除。思惟往来不见三世。于信清净深信真妙。念一切佛三世平等无有动转。而能持诸善根。一切诸佛三昧自在。终不染着诸佛相身。于一切法皆悉平等不与一切世间共诤。所可应作不相违背。通达甚深十二因缘。穷尽一切如来道地。得胜上忍入真法界。见众生界性无生灭。见涅槃界本来现前。慧眼清净观法无二。彼菩提心无中无边。一切诸佛体无差异。入于无碍清净智门。明见菩提自然觉知。于善知识起诸佛想。于菩萨所不念乖离。已于生死破坏魔军。一切众事皆悉如化。见诸如来如镜中像。应当求彼菩提之心。诸波罗蜜莫不平等。实际无尽集佛功德。贤护。是为菩萨思惟诸佛现前三昧。若有菩萨摩诃萨欲具成就如是三昧。当先成就如是功德。贤护。当知更有无量功德。然亦缘此三昧而生

佛复告贤护言。是中何等三昧能生如是诸功德行。所谓菩萨思惟诸佛现前三昧。能生如是诸功德法。复次贤护。云何名为菩萨思惟诸佛现前三昧也。贤护。若有比丘比丘尼优婆塞优婆夷。清净持戒具足诸行。独处空闲如是思惟。于一切处随何方所。即若西方阿弥陀如来应供等正觉。是人尔时如所闻已。即应自作如是想念。如我所闻。彼阿弥陀如来应供等正觉今在西方。经途去此过百千亿诸佛国土彼有世界名曰安乐。如是如来今现在彼。为诸菩萨周匝围绕。处大众中说法教化。然而是人依所闻故。系念思惟观察不已。了了分明。终获见彼阿弥陀如来应供等正觉也。复次贤护譬如世间若男若女。于睡梦中见种种事。所谓金银众宝珍财仓库。或见朋友诸知识辈或见觉时心不乐者。是人梦中所对境界。或违或顺或忧或喜。有时语言欢欣极乐。有时躁戚尽意悲哀。是人寤已思惟忆念。如梦所见为他广宣。追念梦中便生忧喜。如是贤护。彼善男子善女人。端坐系念专心想彼阿弥陀如来应供等正觉。如是相好如是威仪。如是大众如是说法。如闻系念一心相续次第不乱。或经一日或复一夜。如是或至七日七夜。如先所闻具足念故。是人必睹阿弥陀如来应供等正觉也。若于昼时不能见者。若于夜分或睡梦中。阿弥陀佛必当现也。复次贤护。譬如世间若男若女远行他国。于睡梦中见本居家。时实不知为昼为夜。而亦不知为内为外。是人尔时。所有眼根墙壁石山终不能障。乃至幽冥黑闇亦不为碍也。贤护。菩萨摩诃萨心无障碍亦复如是。当正念时于彼所有佛刹中间。凡是一切须弥山王及铁围山大铁围山。乃至自余诸黑山等。不能与此眼根为障。而亦不能覆蔽此心。然是人者其实未得天眼能见彼佛。亦无天耳闻彼法音。复非神通往彼世界。又亦不于此世界没生彼佛前。而实但在此世界中。积念熏修久观明利故。终得睹彼阿弥陀如来应等正觉。僧众围绕菩萨会中。或见自身在彼听法。闻已忆念受持修行。或时复得恭敬礼拜尊承供养彼阿弥陀如来应等正觉已。是人然后起此三昧。其出观已次第思惟。如所见闻为他广说。复次贤护。如此摩伽陀国有三丈夫。其第一者。闻毗耶离城有一淫女名须摩那。彼第二人闻有淫女名庵罗波离。彼第三人闻有淫女名莲华色。彼既闻已各设方便。系意勤求无时暂废。然彼三人实未曾睹如是诸女。直以遥闻即兴欲心专念不息。后因梦已在王舍城。与彼女人共行欲事。欲事既成求心亦息。希望既满遂便觉寤。寤已追念梦中所行。如所闻见如所证知。如是忆念来诣汝所。具为汝说者。汝应为彼方便说法随顺教化。令其得住不退转地。究竟成就阿耨多罗三藐三菩提。彼于当来必得成佛。号曰善觉如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。如是三人既得忍已。还复忆念往昔诸事了了分明也。贤护。彼善男子善女人等。若欲成就菩萨摩诃萨思惟一切诸佛现前三昧。亦复如是。其身常住此世界中。暂得闻彼阿弥陀如来应供等正觉名号。而能系心相续思惟次第不乱。分明睹彼阿弥陀佛。是为菩萨思惟具足成就诸佛现前三昧。因此三昧得见佛故。遂请问彼阿弥陀佛言。世尊。诸菩萨等成就何法。而得生此佛刹中耶。尔时阿弥陀佛语是菩萨言。若人发心求生此者。常当系心正念相续阿弥陀佛便得生也。既得生已世尊于是知彼心故亦即念彼。彼方得见佛世尊耳。贤护。时彼阿弥陀如来应等正觉。告彼人言诸善男子。汝当正念精勤修习发广大心必生此也。贤护。时彼菩萨复白阿弥陀佛言。世尊。是中云何念佛世尊。精勤修习发广大心得生此刹耶。贤护。时彼阿弥陀佛复告彼言。诸善男子。若汝今欲正念佛者。当如是念。今者阿弥陀如来应等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。具有如是三十二相八十随形好。身色光明如融金聚。具足成就众宝辇轝。放大光明坐师子座。沙门众中说如斯法。其所说者。谓一切法本来不坏亦无坏者。如不坏色乃至不坏识等诸阴故。又如不坏地乃至不坏风等诸大故。又不坏色乃至不坏触等诸入故。又不坏梵乃至不坏一切世主等。如是乃至不念彼如来。亦不得彼如来。彼作如是念如来已。如是次第得空三昧。善男子。是名正念诸佛现前三昧也。贤护。尔时彼菩萨从三昧起已来诣汝所说此三昧相者。汝时即应为彼说法随顺教化。令于阿耨多罗三藐三菩提得不退转

贤护菩萨所问经卷第一大方等大集经贤护分卷第二

        隋天竺三藏阇那崛多译

    思惟品第一之二

贤护。我时则亦授彼佛记。是人当来必得成佛。号曰德光明如来应供等正觉乃至佛世尊。贤护。是中三昧谁当证知。今我弟子摩诃迦叶。帝释德菩萨。善德天子。及余无量诸菩萨辈。咸已修得此三昧者。是为证。云何证。所谓空三昧也。贤护。我念往昔有佛世尊。号须波日。时有一人行值旷野。饥渴因苦遂即睡眠。梦中具得诸种上妙美食。食之既饱无复饥虚。从是寤已还复饥渴。是人因此即自思惟。如是诸法皆空无实。犹梦所见本自非真。如是观时悟无生忍。得不退转于阿耨多罗三藐三菩提。如是贤护。有诸菩萨若在家若出家。闻有诸佛随何方所。即向彼方至心顶礼。心中渴仰欲见彼佛。故作如是专精思惟。复应当观如是色相。亦即作彼虚空之想。而彼成就虚空想已。得住如是正思惟中。住思惟已。得见彼佛光明清彻如净琉璃。其形端正如真金柱。如是念者彼见如来亦复如是。复次贤护。譬如有人忽从本国至于他方虽在他方而常追忆本所生处。曾如是见。亦如是闻。如是忆念。如是了知。久追忆故于睡梦中明见自身在本生处。游从见闻如前所更。是人后时向诸眷属。具论梦中所见之事。我如是见。我如是闻。我如是营。为如是获得。如是贤护。有诸菩萨若在家若出家。若从他闻有佛世尊。随何方所即向彼方。至心顶礼欲见彼佛正念不乱。应念即见彼佛形像。或如琉璃或纯金色亦复如是。复次贤护。譬如比丘修不净观。见新死尸形色始变或青或黄或黑或赤。或时膖胀或已烂坏脓血俱流。虫兽食啖肉尽骨白其色如珂。如是乃至观骨离散。而彼骨散无所从来亦无所去。唯心所作还见自心。如是贤护。若诸菩萨欲得成就彼念诸佛现前三昧。随何方所。先念欲见彼佛世尊。随所念处即见如来。何以故。因缘三昧得见如来。得见彼佛有三因缘。何者为三。一者缘此三昧。二者彼佛加持。三者自善根熟。具足如是三因缘故。即得明见彼诸如来应供等正觉亦复如是。复次贤护。如人盛壮容貌端严。欲观己形美恶好丑。即便取器。盛彼清油。或持净水。或取水精。或执明镜。用是四物观己面像。善恶好丑显现分明。贤护。于意云何。彼所见像。于此油水水精明镜四处现时。是为先有耶。贤护答言不也。曰是岂本无耶。答言不也。曰是为在内耶。答言不也。曰是岂在外耶。答言不也。世尊。唯彼油水精镜诸物。清明无浊无滓。其形在前彼像随现。而彼现像不从四物出。亦非余处来。非自然有。非人造作。当知彼像无所从来。亦无所去。无生无灭无有住所。时彼贤护如是答已。佛言贤护。如是如是。如汝所说。诸物清净彼色明朗。影像自现不用多功。菩萨亦尔。一心善思见诸如来。见已即住。住已问义解释欢喜。即复思惟。今此佛者从何所来。而我是身复从何出。观彼如来竟无来处及以去处。我身亦尔。本无出趣岂有转还。彼复应作如是思惟。今此三界唯是心有。何以故。随彼心念还自见心。今我从心见佛。我心作佛。我心是佛。我心是如来。我心是我身。我心见佛。心不知心。心不见心。心有想念则成生死。心无想念即是涅槃。诸法不真思想缘起。所思既灭能想亦空。贤护当知。诸菩萨等因此三昧证大菩提

    大集经贤护分三昧行品第二

尔时世尊复告贤护菩萨摩诃萨言。贤护。若诸菩萨摩诃萨具行四法。则能得是现前三昧。何等为四。一者不坏信心。二者不破精进。三者智慧殊胜。四者近善知识。贤护。是为菩萨具足四法则得成就现前三昧也。贤护菩萨摩诃萨复有四法。能具足行则能成就现前三昧。何等为四。一者乃至于刹那时无众生想。二者于三月内不暂睡眠。三者三月经行唯除便利。四者若于食时布施以法。不求名利无望报心。贤护。是为菩萨具足四法则得成就现前三昧也。贤护。菩萨摩诃萨复有四法。能具足行则得成就现前三昧。何等为四。一者劝他见佛。二者教人听法。三者心无嫉妒。四者劝他发菩提心。贤护。是为菩萨具足四法则得成就现前三昧也。贤护。菩萨摩诃萨复有四法成就三昧。何等为四。一者造佛形像劝行供养。二者书写是经令他读诵。三者慢法众生教令发心。四者护持正法令得久住。贤护。是为菩萨具足四法则得成就现前三昧也。尔时世尊。为重明此义。而说偈言

  汝等当住佛法中　　勿藏正言及我法
  念勤精进除睡盖　　三月不坐唯经行
  食时广说而施他　　宣扬诸佛无比法
  不求名闻及利养　　无所著故得此禅
  莫生嫉妒及嗔恚　　当思解脱诸欲心
  乐此三昧求住者　　勤念无懈尔乃得
  金色百福庄严相　　端正圆满若花荣
  世间乐见光明体　　常睹诸佛在现前
  往古诸佛及将来　　现在一切人中胜
  汝等一心恭敬礼　　亦常专念修供养
  汝若供养彼诸佛　　应以华香及涂香
  慧施美食起净心　　证此三昧殊非难
  诸佛塔前作众乐　　蠃鼓钲铎诸妙音
  欢喜踊跃难称量　　必当成就此三昧
  劝造尊像无比身　　彩画庄严具足相
  金色光大无瑕垢　　证此三昧良非难
  各各常念修法施　　清持禁戒及多闻
  精勤勇猛除懈怠　　得此三昧终不久
  不应他所怀毒心　　亦舍世间诸欲事
  常以慈悲念一切　　三昧岂远在现前
  于法师所常随喜　　尊重恭敬等如来
  莫生轻慢与悭贪　　喜心供养除嫉妒
  无量诸佛共称扬　　汝但勤求自当得
  世尊郑重演说斯　　为修如是妙法故

    大集经贤护分见佛品第三

尔时世尊复告贤护菩萨言。贤护。若诸菩萨摩诃萨欲得成就此三昧者。当应于彼说法师所生诸佛想。起尊重心勿生憍慢。乃至无有诤竞违逆。不顺心故。然后于此胜三昧中。精勤修学方能克证。贤护。若人于彼说法法师或比丘所。起不善心苟违异心。诤竞之心故陵辱心诸不净心。乃至不生如诸佛想。如是菩萨假令修行。终不能证如是妙定。若得证者无有是处。贤护。譬如清净虚空无诸云翳。有明目人。于静夜时仰观空中。无量星宿区别方所。形色各异了了分明。如是贤护。菩萨摩诃萨思惟观彼法性虚空。以想成故见诸如来。其事若此。然彼菩萨观东方时。多见诸佛。多见百佛。多见千佛。多见百千佛。多见亿佛。多见亿百千佛。多见亿百千那由他佛。不假作意自然现前。而彼菩萨既作如是观东方已。欣观南方及西北方四维上下。十方世界各多见佛。所谓多见百佛。多见千佛。多见百千佛。多见亿佛。多见亿百千佛。多见亿百千那由他佛。不假功用皆现在前。复次贤护。如彼阿弥陀如来应供等正觉。其世界中诸菩萨等生彼国者。于初一日观察东方多见诸佛。多见百佛。乃至多见百千亿那由他佛已。然后于第二日观察南方如是。乃至十方事皆若此。如是贤护。若菩萨摩诃萨成就菩萨思惟诸佛现前三昧。如是菩萨。于自土中观察十方多见诸佛。多见百佛。乃至多见百千亿那由他诸佛也。复次贤护。如诸如来成就佛眼。如是具已于一切处悉如是知悉如是见。如是贤护。若菩萨摩诃萨。亦既成就菩萨思惟一切诸佛现前三昧已。自然满彼檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至满彼一切菩萨诸功德等。尔时世尊。为重明此义。以偈颂曰

  犹如静夜除云雾　　有明眼者仰观空
  见彼众星过百千　　昼念明了亦无失
  菩萨如是得定已　　多见无量亿千佛
  复于起斯三昧后　　还为大众演最尊
  如我佛眼清净故　　无有障阂见世间
  是诸佛子菩萨眼　　出此三昧最胜观
  以无相想思如来　　而见十方诸等觉
  破除恼毒及诸想　　汝听菩萨妙功德
  若听彼法清凉心　　能入空寂无畏处
  如我当今说斯法　　为令众生证菩提
  如彼安乐诸菩萨　　多见无量佛世尊
  菩萨如是入思惟　　亦见百千多调御
  如此比丘唯阿难　　一闻我说悉能受
  菩萨如是得三昧　　听一切法能总持
  成就信惭具三昧　　悉舍一切世语言
  常以慈心慧他说　　要当到斯寂静地

    大集经贤护分正信品第四

尔时世尊复告贤护菩萨言。贤护。若诸菩萨摩诃萨为求如是三昧宝故。当应勇猛发勤精进。自然速能入此三昧也。贤护。譬如有人乘御大船入于大海。恣意载满众妙珍宝。已过一切诸大难处。垂至此岸未几之间。船忽破坏众宝沉没。当尔之时阎浮提人。发大叫声生大悲苦。以失如是无价宝故。贤护。有善男子善女人。亦复如是。耳闻如斯胜三昧宝。不能书写读诵受持。复不能思惟如法而住。贤护。当知尔时一切世间诸天神等。亦应如是发大叫呼生大悲恼作如是言。是诸众生深可怜愍。云何于此诸佛世尊胜三昧宝。一切诸佛之所称扬。一切诸佛之所印可。一切诸佛之所教诫。一切诸佛最上功德。具足成就圆满无缺。菩萨闻已当应勤求。反更远离不肯书写。不乐读诵。不能受持解释义理。不能思惟如法而住。如是放逸懈怠众生。未来必当受大损减。贤护。何等名为众生损减。所谓于如是三昧宝中。闻已远离不能书写读诵受持。不能解说思惟义理。不如法住专念修行。丧灭功德是为减损。贤护。是懈怠人恶众生辈。于斯法中得利益者无有是处。复次贤护。譬如有人持赤栴檀示愚痴人。而彼痴人以愚痴故。于赤檀香起臭秽想。时主智人卖檀香者。告愚人曰。汝今不应于妙栴檀生臭恶想。何以故。是檀最精香气第一。汝今何故反为臭恶。若不信者。应先臭尝为臭为香。又汝眼明亦应以目观察是檀。光色文彩为瘦为肥为善为恶。然彼愚者。虽闻智人如是语言种种称赞。以愚痴故转生憎恶。以手捻鼻不用嗅闻。掩闭其目不肯观视。如是贤护。当来之世有恶比丘。憎恶是经其事亦尔。彼恶人辈不知修习身戒心慧。愚痴无智犹如白羊顽騃佷弊。彼诸恶人又薄福故。虽复得闻如是妙典正念诸佛现前三昧。不用书写不能读诵。不能受持不能思惟。不能为人宣扬广说。又亦不能广生随喜。云何能得如说修行。若彼恶人能说行者。无有是处。又复闻已更兴诽谤。都无信心谓为真实。虽闻多说终无开解。复作是言。若斯法者但为戏论故神异其事。又为炽盛言教故过饰其词。诱诳世间造斯经典。岂得方比圣者阿难诸比丘辈现在世时宣说如是诸修多罗也。又于异时发如是言。此修多罗非佛所说。乃是恶人自造文章妄言经耳。贤护当知。如斯恶人。长夜远离如是微妙无上大宝。如彼痴人见妙香已。掩眼塞鼻不用见闻。如是贤护。彼愚恶辈。闻此妙经三昧宝已。不欲书写不乐读诵。不念受持不能宣说。所谓无心亲近不愿闻故。复次贤护。譬如有人卖摩尼宝。有愚痴人见彼宝已。即便问言。仁者斯宝其价云何。宝主答言。汝今当知是宝精胜世间所无。非可造次以世价论也。吾今且说此宝功能威德力用。粗为约耳。卿若欲知此摩尼宝光明所照近远若干。卿今若须当以真金布满斯地。尔乃相与。彼愚痴人闻是语已。便大嗤笑种种呰毁。是摩尼宝竟不酬价。如是贤护。彼未来世诸恶比丘。闻此经中胜三昧宝。无有信心多生嗤笑。更兴诽谤其事亦尔。或有比丘信根深厚慧根明利。已于过去诸如来所。亲近承事听闻正法。如教修行种诸善根。彼等闻此菩萨念佛现前三昧。即能读诵思惟义理。为人广说能多利益一切世间。所谓广宣流布。生大信心。发大智慧。成就纯直。具足威仪。常行惭愧。怖畏众罪。修持禁戒。不受诸欲。信甚深法。能多受闻。得深智忍。常行慈悲。然而斯等信根深固得是三昧。得三昧已游诸方国。为他广说解释义理。常作是愿。令此菩萨念佛三昧甚深经典。广行流布常住于世。或有众生。善根微薄福德鲜少。过去未曾亲近诸佛。供养承事听闻正法。但为我慢所降。嫉妒所导。利养所覆。名闻所牵。广行放逸不持戒善。常乐乱心不修禅定。远离经教不求多闻。未遇善师唯逢恶友。斯人如是闻此三昧。诽谤轻毁无一信心。谓为不实。志性顽愚意无开解。复作是言。如斯经典非佛所说。乃是世间钝根比丘。愚痴邪见自作文章严饰词句。若处众中应如是说。亦如是教。汝诸众生。当知今此修多罗典非佛所说。如是痴人。不知亲近诸佛世尊。不种善根不修供养。习近恶友多作众恶。当知是人。远离无上深妙法宝。永失无上最胜法利也。佛告贤护。吾复语汝。我今现在一切世间。梵魔沙门婆罗门。及诸天人阿修罗等诸大众前。宣说如是妙三昧时。若彼善男子善女人。闻已随喜读诵受持念佛三昧。思惟信解最以为真。发如是言。是为真实诸佛说者。当知彼人所获福聚不可思议。贤护。若复有诸善男子善女人。持满三千大千世界种种珍宝。以用供养一切诸佛如来应供等正觉。所得功德虽为广大。然望持经所获福聚。百千万分不及其一。乃至更以无量无边阿僧祇诸福德聚。亦不及一尔时世尊。为重明此义。而说偈言

  邪曲愚惑人　　放逸根不熟
  恶友之所坏　　无有正信心
  破戒造众罪　　深着于我慢
  彼各言此经　　非是诸佛说
  此诸修多罗　　非是法王教
  彼辈自意言　　我何能说此
  若见大调御　　世尊放光明
  我为彼广宣　　彼亦能传说
  其或于此经　　闻已生欢喜
  斯人无疑网　　不言非佛说
  如有戒清净　　所见能了知
  敬法起重心　　我为此陈说
  若以三千宝　　持奉诸如来
  为求大菩提　　其福不可说
  若有诸比丘　　说佛所叹定
  闻者生信心　　此福过于彼

    大集经贤护分受持品第五

尔时世尊复告贤护菩萨言。贤护。此众有人今在我前。亲闻我说如是三昧。于我灭后其所生处。还复得闻是三昧宝。虽闻不信诽谤毁呰。远离善友随逐恶人。贤护。复有一人。于善人所闻是三昧深妙经典。尚不生信不以为实不能开解。况恶人处闻是经典。宁能生信而复开解。何以故。贤护。诸佛如来所言难信。诸佛世尊智慧难知故。贤护。若当成就如是三昧。然后乃能于当来世。与诸众生增长佛法。复次贤护有诸菩萨摩诃萨。若在家若出家。闻此三昧不怖不惊。不悔不退不谤不毁。闻已随喜生信敬心。决定真实无复疑网。读诵受持思惟义趣。贤护。如是等人。世尊悉见悉知悉识也。贤护。诸佛世尊。云何见斯诸善男子及善女人。复云何知。又云何识。贤护。若能读诵受持思念此三昧门。如是之人终不为恶不破净戒。不坏正信不入邪聚。贤护。是诸善男子善女人等。必定深信成就思惟。能分别成就思惟。于是法中具足信心。常能读诵摄持是法。贤护当知。是人决不求少功德。亦不种少善根。贤护。是善男子善女人。凡所生处或乏资须。然诸善根广大不少。贤护。是故斯诸善男子善女人。已于过去诸如来所。修行供养种诸善根。贤护当知。此辈非于一如来所修行供养种诸善根也。亦非于二三四五乃至十如来所种诸善根也。亦非于百千亿数诸如来所种诸善根也。贤护当知。此诸善男子善女人。已于过百千数无量无边诸如来所。修行供养种诸善根。方得闻此念佛现前三昧。闻已生信心开意解。即以为实无复疑网。既获闻已乐欲书写读诵受持。乃至为他广宣是义。何以故。贤护。斯诸善男子善女人。往昔已于诸如来前。闻是三昧读诵受持。以是义故如来灭后。于最末世五百年终。法欲灭时。法将坏时。还当得闻如是三昧。闻即生信无有惊疑。不退不没生大欢喜遍满身心。读诵受持思惟其义为他解说。乃至一日一夜行是三昧。贤护。若复有人。闻此三昧无有惊怖。亦不退没不生谤毁。闻已随喜即以为实。思惟分别心开意解。但能为他暂时称善。所获福聚尚不可量。况能读诵受持勤思而行。为他广说至一日夜。贤护当知。是善男子善女人。因是事故。即便获得过于无量阿僧祇大功德聚。遂得住于不退转地。随所愿欲如意即成。贤护。其事虽尔。我今为汝更宣譬喻明显此义。复次贤护。譬如有人取此三千大千世界一切大地尽末为尘。复取一切草木枝叶。不问大小皆为微尘。彼人尔时于彼尘聚。取一微尘破坏分析。还令得作尔许微尘。然后复取彼一切尘。次第分析皆令等彼初微尘数。贤护。于意云何。是微尘数可谓多不。贤护答曰。甚多世尊。佛言贤护。若有善男子善女人。取前尔许微尘数佛刹。盛满众宝持用布施。贤护。于意云何。彼善男子善女人。所获福聚复为多不。贤护报曰。甚多世尊。然彼善男子善女人。因是事故获得过彼无量无边阿僧祇福聚。佛复告言。贤护。吾更语汝。如彼善男子善女人。以尔许尘数佛刹盛满七宝。持用布施获如斯福复有善男子善女人。闻此念佛现前三昧。暂生随喜。信心分别以为真实。心开意解读诵受持。乃至暂时为他解说。是善男子善女人。所获福聚胜前施福无量无边。非可称算。非可校计。非可思量。贤护。如是善男子善女人。闻此三昧生随喜心。乃至暂时为他解说。尚获无量无边福聚。何况是善男子善女人。于此三昧修多罗中。如闻而信。如信而受。如受而说。如说而行也。尔时世尊。为重明斯义。以偈颂曰

  若以三千大千界　　盛满七宝用行檀
  我说彼福虽为多　　不如闻经少功德
  菩萨为求多福聚　　信解读诵复思惟
  解说修行念三昧　　斯所获福过于彼
  末三千界尽为尘　　复分一尘等前数
  尽取如是诸尘刹　　盛满珍宝以行檀
  诸佛所赞三昧经　　单以一偈为他说
  我言斯人获功德　　超彼檀福不可量
  若复为他具足说　　下至一构牛乳间
  思惟增广诸善根　　何况长远无量福
  一切众生尽作佛　　净慧终竟证彼如
  假于亿数多劫中　　说斯偈福不可尽
  其间彼佛皆灭已　　多亿数劫常广宣
  终亦不尽彼福边　　缘此深经四句偈
  一切所有诸世界　　四方上下及四维
  满中众宝持与他　　为求胜福奉诸佛
  彼诸功德难可量　　称计与诸世界等
  其有闻受是三昧　　善能宣说福过前
  若人于此无迟疑　　其于诸法亦明了
  彼则永绝诸恶趣　　能入胜寂三昧禅
  彼若常能供养我　　必受多福不思议
  增长多闻证菩提　　由思诸佛所赞定
  今我语汝诚实言　　当念精进莫放逸
  一心欢欣发勇猛　　自然速证彼菩提
  彼为供养百数佛　　乃能受是三摩提
  假于后世恐怖时　　自当速证微妙定
  若有见我与比丘　　及汝大士贤护等
  如是菩萨乐多闻　　决定当得此三昧
  若得闻此圣三昧　　为他解释或书写
  是陀罗尼世尊叹　　能证一切佛菩提
  若人善思此三昧　　一切诸佛咸共称
  当得种姓及多闻　　诸佛次第而演说

    大集经贤护分观察品第六之一

尔时世尊复告贤护菩萨言。贤护。若诸菩萨摩诃萨即欲思惟此三昧者。当云何思。贤护。彼诸菩萨欲思惟者。即应当作如是思惟。如我世尊今者现在天人众中宣说法要。贤护。菩萨如是一心思惟。诸佛如来坐师子座宣说正法。具足成就一切相好。最妙最极殊特端严乐观无厌。如是观察诸大人相。于一一相应当至心。即得明了见诸如来应等正觉既得见已当先咨问不见顶相。既得问已。然后次第遍观诸相皆令明了。如是观已更复思惟。诸佛如来众相微妙是为希有。愿我未来还得如是具足成就诸妙相身。愿我未来亦得如是清净禁戒具足威仪。愿我未来亦得如是具足三昧。愿我未来亦得如是具足智慧。愿我未来亦得如是具足解脱。愿我未来亦得如是解脱知见。愿我未来成满如是诸相身已。即得成就阿耨多罗三藐三菩提。既成佛已亦当如是处彼天人大众之中。具足宣说如斯妙法。菩萨如是具足观察诸佛如来。乃至成就一切种已。复应更作如是思惟。是中何者是我。谁为我所法。谁能得成诸佛菩提。为身得耶。为心得耶。若身得者。是身顽騃无觉无知。犹如草木石壁镜像。然彼菩提无色无形非像非相。不可见知不可触证。云何更以顽騃无知无见无识。无所分别无作之身。得彼菩提。菩提如是既无形色。非相非像不可见知不可触证。谁复于中而行证者。若心得者。是心无色不可得见。是心无相不可得知。此心如是同于幻化。然彼菩提亦尔。无色不可见。无相不可知。无漏无为亦同幻化。云何可证。云何觉知。而言身心得菩提耶。彼菩萨摩诃萨如是观时。分明了了见是身相不得菩提。亦知是心不得菩提。何以故。诸法无有以色证色心证心故。然彼于言说中知一切法。虽无色无形无相无漏无可睹见无有证知。亦非无证。何以故。以一切诸如来身无有漏故。又诸如来身无漏故心亦无漏。又诸如来心无漏故色亦无漏

贤护菩萨所问经卷第二大方等大集经贤护分卷第三

        隋天竺三藏阇那崛多译

    观察品第六之二

又诸如来。色无漏故受亦无漏。乃至行识亦无漏。又诸如来戒亦无漏。所有三昧智慧亦无漏。乃至解脱解脱知见亦无漏。如是乃至诸如来。诸如来所有言说。已说今说当说。及一切法斯皆无漏也。贤护。诸如是等一切佛法。智人能达。愚者莫知。彼若能作如是观时。一切诸法悉不可得。云何不可得。所谓谁能证也不可得。云何证也亦不可得。何缘证也亦不可得。彼能作是观已。如是入灭寂定分别诸法。亦不分别诸法。何以故。诸法无故。贤护。如火未生。或时有人发如是言。我于今日先灭是火。贤护。于意云何。彼人是语为诚实不。贤护答言。不也世尊。佛告贤护。如是诸法从本以来毕竟无得。云何于今乃作斯说。我能证知一切诸法。我能了达一切诸法。我能觉悟一切诸法。我能度脱一切众生。于生死中此非正言。所以者何。彼法界中本无诸法亦无众生。云何言度。但世谛中因缘度耳。贤护。于意云何。彼如是说得为实不。贤护答言。不也世尊。佛告贤护。是故彼诸善男子善女人。若欲成就无上菩提。乃至欲成缘觉菩提声闻菩提者。皆应如是观一切法。作是观时则入寂定。无有分别非无分别。何以故。贤护。彼一切法无所有不生。然彼定有分别即是一边。定无分别复为一边。然此二边所有。是无寂定非无寂定。无思量处无分别处。无证知处无经营处。无聚集处无思念处。无发起处。贤护。是名中道。所有数事处等但依世谛说故

复次贤护。于彼真实第一义中。若中若边皆不可得。何以故。贤护。一切诸法犹如虚空。本来寂灭非断非常。无有积聚。无有住处。无可依止。无相无为无有算数。贤护。彼不可数云何为有。不可数故不入于数。不入数故乃至无有智算名言也。贤护。彼菩萨摩诃萨。如是观察诸如来时。不可执着。何以故。一切法无执着故。以无处所而可执着。亦无根本是可断绝。除灭根本故无依处。贤护。彼菩萨摩诃萨。当作如是思惟诸佛现前三昧。若如是见诸如来已。不应取着不当执持。何以故。贤护。一切诸法不可执持。犹如虚空体性寂灭。贤护。譬如金锤安置火中。善作炉[橐-石+非]融消炼冶炽然毒热。又如铁丸新从火出炎赫炽然。有智之人不应执触。何以故。铁流金炽。触则炽然故。如是贤护。菩萨观佛不应取着。其事若此。是故菩萨观佛色时不应生着。如是观受乃至行识不应生着。又彼菩萨若观戒时亦不应着。如是观定乃至智慧解脱解脱知见亦不应着。何以故。夫取著者。终不能离生死苦法。以是苦法皆由取着故。是故菩萨观察如是诸如来时。不应生于取着之想。贤护。虽无取着。然应勤求诸佛世尊胜妙功德。所谓佛智。如来智。广大智。自然智。自在智。不思议智。难称量智。无等等智。一切智智。若欲求入如是智者。常当精勤思惟观察见佛三昧也。尔时世尊。为重明此义。以偈颂曰

  譬如明镜与油器　　女人庄饰曜其形
  愚夫于是生染心　　处处驰骋为求欲
  彼于无中颠倒想　　不知是法虚妄生
  彼欲炽火之所烧　　斯妇起欲还自发
  若有菩萨作是念　　是名无智着我心
  菩提甘露在当来　　我拔众生出重苦
  第一义中无众生　　世间独有生老死
  诸法无形如水月　　岂有菩提而可求
  众色形貌若镜像　　如幻如炎如虚空
  凡夫着想而受羁　　彼辈虽缚空无实
  若斯智者诸菩萨　　知世颠倒故见真
  了达无人谁受苦　　彼则当成无上觉
  无意分别佛菩提　　其心本来自明净
  不见生死诸滓浊　　彼证真实最胜尊
  一切色法诸无漏　　不可分别妄与空
  灭除诸欲解脱心　　如是知者证三昧
  初念诸佛无相身　　后闻诸法本清净
  如是思惟无余念　　证此三昧诚非难
  常作空相而思惟　　即能灭彼微尘聚
  不分别成及与坏　　一切外道失于中
  于一切色无分别　　其眼虽睹不累心
  彼见诸佛如日轮　　法界世间挺超出
  其心清净眼亦明　　虽勤精进常在定
  彼得多闻不可说　　证此三昧真思惟
  若以不见证三昧　　一切盲者应证知
  亦不以见非不见　　是中外道皆迷没
  常离相想而思惟　　见彼诸佛清净心
  如是见已一切观　　其人速成此三昧
  彼无地水及火风　　亦非空界现前住
  若欲观察一切佛　　当想处座演妙音
  如我今日宣妙法　　心乐法者睹我身
  彼应无复余思惟　　唯当想佛说法事
  如是专念莫他观　　为求若斯多闻故
  一心观我说此定　　总持诸佛之所宣
  无有一佛在过去　　亦无现世及当来
  唯此清净微妙禅　　彼不可言证能说
  我于三界无上尊　　为利世间故特出
  念证诸佛菩提故　　宣此三昧无等伦
  若欲身乐及心乐　　求佛功德不思议
  乃至证彼妙菩提　　要当修此胜三昧
  欲净深广多闻海　　为众生故常勤求
  彼应速去诸欲尘　　要当修此胜三昧
  若欲一生见多佛　　见已恭敬复咨询
  彼应速离勿生着　　要当观此妙三昧
  是处无欲复无嗔　　亦无愚痴与嫉妒
  又无无明及疑网　　要当住此深寂禅

    大集经贤护分戒行具足品第七

尔时贤护菩萨。复白佛言。希有世尊。乃有如斯最胜三昧。世尊。若诸菩萨舍家出家。深心乐欲说此三昧。亦当思惟此三昧者。彼等应当安住何法。而能宣说及思惟耶。佛告贤护言。贤护。若有菩萨舍家出家深乐广宣。复欲思惟如是三昧者。彼出家菩萨当先护持清净戒行。不缺戒行。不染戒行。不污戒行。不浊戒行。不着戒行。不动戒行。不被呵戒行。智者所赞戒行。圣所爱敬戒行。应当念知如是诸戒也。贤护。彼出家菩萨云何当得清净戒行。乃至云何当得圣所爱敬戒行也。贤护。彼出家菩萨。应当依彼波罗提木叉。成就威仪成就众行。乃至成就微尘数等戒行。见已惊怖清净活命。于诸戒中当念成就。应信甚深不得着忍。于空无相无愿诸法中。闻说之时心不惊怖。无有悔没。贤护。以是因缘。彼出家菩萨成就如是清净戒行。不见戒行不着戒行。乃至成就圣所爱敬戒行也

尔时贤护菩萨。复白佛言。世尊。彼出家菩萨。云何得有如是不清净戒行缺戒行染着戒行污戒行依倚戒行智所诃毁戒行圣所不爱戒行也。佛告贤护菩萨言。贤护。若有出家菩萨。取着色。受持禁戒修于梵行。如是取着受。取着想。取着行。取着识。受持禁戒修行梵行。修行已。作如是念。我今如是持戒如是苦行。如是修学如是梵行。愿我未来得生天上或生人间自在有生受诸果报。贤护。以是因缘。彼出家菩萨成就如是不清净戒。乃至圣者所不爱戒。是谓为求有故。为有生故。为受欲果故。为生处所故。贤护。是故彼出家菩萨。念欲说此三昧思此三昧者。要当先具清净戒行乃至成就圣所爱戒。亦念常行檀波罗蜜。所谓最胜施。诸法施。上施妙施微妙施。精妙施无上施。亦常勇猛精进不休。不舍重担。不忘正念常行一心。正信清净无有嫉妒。不着世间利养名闻。如法索求以济形命。恒行乞食不受别请。厌离人间乐阿兰若。尊崇圣种敬事头陀。息世语言但论出世。处众静默假言不多。常敬于他不敢轻慢。于一切时常行惭愧。有恩必知知恩必报。于善知识常念亲近。诸师尊所谨事无违。若闻如是甚深经典。专心听受终无疲厌。于法师所起慈父心善知识心。乃至生于诸如来想。以为如是微妙法故。成就无上大菩提故。转增爱敬尊重心故。复次贤护。若彼菩萨或时至于声闻人所。闻说如是甚深经法。彼法师所无爱敬心。无尊重心。不生慈父想。不生善知识想。不生诸佛想。不生教师想。不能亲近承事供养。随于何所闻是经典。当知是人不能听受书写解说令法久住。如是之人若能听受。若能书写若能解说。令法久住无有是处。复次贤护。若彼菩萨或复至于声闻人所。闻说如是增上妙法。不生爱敬心。不生尊重心。及至不生诸佛想。不能尽心亲近供养者。若能读诵若能受持若能解说。令是经典不速灭者。无有是处。何以故。以不尊重是经典故。是故斯法不久必灭。复次贤护。若彼菩萨。或复至于声闻人所。闻说如是微妙经典。生爱敬心生尊重心。乃起教师想诸如来想。亲承供养即能听受。亦能书写复能解说。能令是经久住利益。斯有是处。复次贤护。若彼菩萨复于声闻人所。闻说如是微妙经典。即于彼所生尊重心。如诸佛想亲近承事。恭敬供养者。如是之人虽未修学如是经典。即为修习。虽未解释即为解说。令是妙法久住世间。不毁不灭斯有是处。何以故。以能爱敬尊重法故。是故此经久住世间贤护。以是因缘吾今语汝。是人于是说法师所。生爱乐心生敬重心。生尊贵心起善知识想。起教师想起诸佛想。尽心承事恭敬供养。贤护。若能如是是则名为行我所行受我教诫也。复次贤护。彼出家菩萨必欲解说如此三昧。复欲思惟此三昧者。常当乐行阿兰若事。不得居处聚落城邑。舍离朋党多求之处。不贪衣食。不得贮聚谷米食具。不得受畜财物生资。不得贪求名闻利养。不惜重命常念舍身。远离贪着恒修死想。常行惭愧不造诸恶。摄受正法无有疑心。常念远离不取众相。当修慈心勿怀嫌怨。常起慈悲无行嗔恚。安心喜舍莫想爱憎常。当经行破除睡盖。贤护。出家菩萨若能安住如是法行。则能修学解说思惟。如是念佛现前三昧也

尔时贤护菩萨复白佛言。希有世尊。如来应供等正觉。所说经典甚深甚深。最胜微妙不可思议。然彼未来诸菩萨等懈怠懒惰。虽闻如是深妙经典。生大恐怖惊疑退没。不发欢喜爱乐之心。彼等当复作如是念。我今当应余诸佛所乃可修习如是经典。所以者何。我今自知多诸障难。身遇病苦气力甚微。宁堪修行如是经典。世尊。彼辈如是。于甚深法更生放舍远离之心。不能发勤勇猛精进。乐欲成就如是经典。世尊。尔时亦当有诸菩萨。精进勤求专念之者。爱乐是法劝持是法。摄受是法。若诸法师说是法者。于是法中如法行故。能舍身命。不著名闻不求利养。不自宣说己身功能。不染衣钵不乐城邑。常趣空闲山林静处。其或闻是微妙法故生大欢喜。更当具足发勤精进。听受如是微妙法门。常读诵故常念持故。思惟义故如说行故。彼等于未来世诸如来所。非徒直欲求彼多闻。亦无但求在于有处。唯为成就诸功德故。常念勤求精进勇猛。世尊。然复应有往昔己曾供养诸佛宿种善根。诸善男子善女人辈。发大精进为闻如是微妙法故。更发如是大誓庄严。愿我当得干渴肌肤。散骨消髓炽然身心。苦行不息。必欲成就如是妙典。终无暂时懈怠懒惰。而不听闻微妙胜法。亦无不思甚深义理。复无舍他不为宣说。而常勇猛行大精进。但为摄受诸菩萨故。听闻如来如是妙典。闻已即便生欢喜心

尔时世尊赞彼贤护菩萨言。善哉善哉。贤护。如是如是。如汝所说。我今随喜。贤护。我随喜故。一切三世恒河沙等诸佛世尊皆亦随喜。时彼贤护菩萨复白佛言。若有在家菩萨。处于世间闻是三昧。欲自思惟即为他说。乃至一日或经一夜。是人安住几种行法。当得成就思惟三昧为他说也。佛言贤护。彼在家菩萨处于世间。若欲修习思惟三昧。或一日一夜乃至一[(殼-一)/牛]牛乳时者。吾今语汝。彼在家菩萨既居世间。当应正信不起悭贪。常念行施随多少施。当一切施不求果报。应归依佛又归依法亦归依僧。不事天神亦无礼拜。不生嫉妒常念随喜。当须清净如法活命。不爱儿女不着妻妾。不染居家不耽财宝。常乐出家念除须发。修八关斋恒住伽蓝。常怀惭愧发菩提心不念余乘。见有持戒清净比丘修梵行者。终无调戏常行恭敬。从谁闻学如此三昧。当于师所生爱敬心。起尊重心善知识想。生教师想起诸佛想。一切众具悉以奉之。常当识恩恒思报德。以能教我微妙法故。贤护。彼在家菩萨处俗之时。应住如是诸法行已。然后教示如是三昧。如是思惟如是修习。时彼贤护菩萨复白佛言。希有世尊。如来应供等正觉。今乃为彼出家在家诸菩萨辈。正信成就乐深法者。宣说如是无上妙法。令住如是无量法行。然后当得思惟解说如是三昧。世尊。如来灭后如是三昧。于阎浮提能广行不。佛告贤护菩萨言。贤护。我灭度后此三昧经。于阎浮提四千年中广行于世。而后五百年末一百岁中。正法灭时比丘行恶时。诽谤正法时。正法破坏时。持戒损减时。破戒炽盛时。诸国相伐时。当斯之际颇有众生炽然善根。往昔已曾亲近诸佛。供养修行殖善种子。为彼诸丈夫辈得是经故。此三昧典复当流行于阎浮提。所谓佛威神故。故令彼等于我灭后。闻此经已欢喜书写。读诵受持思惟其义。为他解释如说修行。尔时贤护菩萨。及宝德离车子。闻如来说正法灭时。悲泣雨泪。从座而起整理衣服。偏袒右肩右膝着地。合掌恭敬而白佛言。世尊。我等当于如来灭后。后五百岁末百年中。沙门颠倒时。正法欲灭时。诽谤正法时。破坏正法时。持戒损减时。破戒增长时。正法护减时。非法护增时。众生浊乱时。诸国相伐时。能于如来所说经典妙三昧中。读诵受持思惟义理为他广说。何以故。我心无厌终不知足。是故我于如来所说修多罗中。能听闻故能书写故。能读诵故能受持故。能思惟故能修行故能广说故

尔时商主优婆塞。伽诃岌多居士之子。那罗达多摩纳等。闻如来说未来世中正法坏灭。为正法故悲哀泣泪。从坐而起整理衣服。偏袒右肩右膝着地。恭敬合掌而白佛言。世尊。我等能于如来所说妙修多罗。及能受持修多罗者。我皆摄护令得增长。世尊。我今复为如来所说微妙经典。作其加护。令得广宣久住于世。何以故。以是经典能于无量阿僧祇劫。多所成就阿耨多罗三藐三菩提故。世尊。我等得闻未曾有法。至心受持思惟其义。为他解说广行流布。世尊。我今闻此甚深经法一切世间无有信者。我先为其造善根器。然后为解。尔时众中有五百比丘比丘尼优婆塞优婆夷四部众等。闻如来说未来世中正法坏灭。为正法故悲泣雨泪。从坐而起整持衣服。偏袒右肩右膝着地。恭敬合掌而白佛言。世尊。我等受持如来正法。然诸大士善丈夫辈。尔时于我当作正依当作覆护。为我经理。能令我等于如来所说如是甚深修多罗中。取真实义如法修行。唯愿世尊。付嘱我等诸善丈夫分明立记。何以故。世尊。我及彼等皆能护持摄受正法及摄受者故

尔时世尊。即便微笑放金色光。其明遍照十方世界诸佛国已还至佛所。右绕三匝从顶上没。尔时尊者阿难作如是念。世尊昔来已多微笑。然于笑时必为异事。我今应问微笑因缘。如是念已。即从坐起整持衣服。偏袒右肩右膝着地。合掌向佛。以偈白言

  其心清净行无秽　　有大威德巨神通
  一切最尊世中上　　显现无垢如明月
  无碍圣智解脱心　　迦陵伽声天中最
  一切异轮莫能动　　今忽微笑有何缘
  通达正真为我说　　能多利益两足尊
  闻是如来微妙音　　一切皆当大欢喜
  诸佛世尊岂虚笑　　佛复放光有胜人
  谁于斯日获大利　　是故今应宣笑旨
  谁于今日得证真　　谁于今日受法王
  谁于今日自灌顶　　谁于今日登佛位
  谁于今日利世间　　谁当总宣佛法藏
  谁于佛智得常住　　以是尊应显笑缘

尔时世尊。即以偈告长老阿难曰

  阿难汝见大集不　　摄护五百从坐起
  身心欢喜发诚言　　我辈当来获斯法
  此等一心瞻察我　　我于何时亦复然
  咸于我前兴大誓　　我辈当来证斯道
  复有八辈从坐起　　五百上首此为尊
  彼于末世法坏时　　为世间法故宣说
  我今告汝如是言　　于此众中无碍智
  是辈非于一佛所　　起立合掌敬诸尊
  我观往昔无量世　　八万诸佛皆现前
  八人为首从坐起　　还为护持是妙法
  前此八万亿由他　　复值如是数诸佛
  心得解脱大名称　　彼时此辈已摄持
  今复于我胜法中　　能为摄护利益首
  教化无量菩萨众　　断除嫉妒诸大人
  此等于我灭度时　　取我舍利兴供养
  善持我斯诸佛事　　安置箧笥遍十方
  平地造塔或在山　　付嘱天龙及金鸟
  斯等依仗于此经　　寿终皆得生天上
  后虽转生于人间　　而常不离胜家姓
  善持我斯菩提事　　还发大愿随本心
  或时为法至他国　　恒值如是深妙典
  得已转授众多人　　以欢喜心除嫉妒
  求法精诚无懈倦　　轻财贱命岂爱身
  降伏一切诸外论　　常以妙法惠施彼
  时世无能受斯经　　亦无读诵转教人
  唯有此辈五百贤　　今于我前从坐起
  复此八士诸菩萨　　当来北天授斯法
  乐恒广宣多利益　　弘是甚深修多罗
  此八正士为上首　　彼五百数复无增
  远离嫉妒弃名闻　　来世当授广大法
  如是比丘及尼辈　　诸优婆塞优婆夷
  巧智无妒登法师　　当成正觉大威德
  彼不思议神德具　　百福之体相庄严
  得微妙乐除众苦　　长拔三毒烦恼根
  此等从今舍命已　　终不受生恶道中
  一切生中常和合　　所遇菩提最胜事
  既舍一切恶趣生　　亦能永离诸难处
  功德不可知边际　　如是无量受多福
  复当得见弥勒佛　　于彼常起和合心
  恭敬供养利益他　　唯求无上菩提故
  彼时此辈恒集会　　承事超世两足尊
  为此诸佛妙菩提　　当度生死登彼岸
  于后末世法坏时　　彼等亦常持此法
  如是所处恒修行　　遇弥勒世事若斯
  所可于此贤劫内　　广为利益世间灯
  彼一切处护是经　　安住三世无所畏
  将来亿数多诸佛　　不可思议难得边
  斯皆供养广修行　　常护如是胜佛事
  其有在前成菩提　　彼彼咸同修供养
  而或于先取灭度　　我住多世那由他
  今此贤护大菩萨　　及是宝得出众珍
  商主岌多伽摩那　　当见恒沙无数佛
  于彼亦受无上经　　前已经历多劫数
  妙算不能尽其形　　无量亿劫谁能知
  若有众生得闻名　　或于觉时及睡梦
  能发勇猛师子吼　　彼辈皆得天人尊
  若有众生但闻名　　直能信敬及随喜
  一切作佛无疑虑　　何况供养于彼身
  其所受法不思议　　寿命住法亦无量
  利益广大无穷尽　　功德智慧不可知
  彼过去佛难思量　　清净持戒洹沙数
  此辈于彼广行施　　唯求无上佛菩提
  彼诸功德不可数　　多劫宣说莫能穷
  于菩提中无增减　　常念护持是经法
  阿难若人护此经　　书写读诵及忆念
  汝应决定兴爱敬　　终不离是五百中
  阿难若人持此经　　自当勤心求坚固
  净持禁戒舍睡眠　　决定得斯妙三昧
  我毗尼处说木叉　　诸比丘学居兰若
  若能头陀不舍离　　得此三昧定无疑
  一切别请尽能舍　　凡是美味皆断除
  师所常起诸佛心　　谁云不证斯三昧
  贪恚痴患先觉知　　我慢嫉妒咸远离
  情无垢着念无为　　读诵思惟胜三昧
  清净意处无可染　　调伏诸根息怨嫌
  一心专念如来身　　读诵受持妙三昧
  若有菩萨在居家　　心常坚住出家事
  受持读诵口业成　　心常念学此三昧
  恒应修持五种戒　　亦常数受八戒斋
  常住寺庙舍资生　　读诵思惟此三昧
  不当耽着众妇妾　　勿爱儿女及珍财
  住优婆塞行羞惭　　但当忆持此三昧
  莫于他所起害心　　唯思除去诸调戏
  无处可着住于忍　　但念思惟此三昧
  莫于财物生执着　　花香涂粉及诸鬘
  无处染着安彼忍　　但当受持此三昧
  若比丘尼求此经　　当勤归敬除嫉妒
  调戏贡高及我慢　　证彼菩提亦不难
  应发精进破睡眼　　一切诸求皆当断
  心爱乐法净命存　　唯当读诵此三昧
  心常不共贪欲俱　　莫起恚恨无迫恼
  不以魔缚系众生　　唯当受持此三昧
  无以谄曲有所为　　勿贪好衣及涂薰
  莫行两舌离别他　　唯当受持此三昧
  男女声色不系念　　寂绝无诸邪念事
  于教师所生佛想　　唯当受持此三昧
  所生永离众恶道　　于佛法中不空信
  破除三有诸障难　　要当受是三摩提

贤护菩萨所问经卷第三大乘大集经贤护分卷第四

        隋天竺三藏阇那崛多译

    称赞功德品第八

尔时贤护菩萨。及宝得离车子。善商主长者。伽诃岌多居士子。那罗达多摩纳。水天长者与五百徒众等。闻佛所说皆大欢喜。即以五百上服奉覆世尊。复以多种供具供养世尊。心乐法故各以己身奉承如来。尔时世尊。告阿难言。是贤护菩萨。当于彼等五百徒众。而作义师说诸法要。教化慰喻令彼欢喜。以欢喜故彼辈即得随顺之心真实之心清净之心离欲之心。除诸烦恼无复盖缠。时五百人一心合掌。恭敬顶礼退住一面。尔时贤护。即白佛言。世尊。菩萨摩诃萨具足几法。而能得此念佛三昧也

尔时世尊。告贤护言。贤护。若菩萨摩诃萨具足四法得是三昧。何等为四。一者不着一切外道语言。二者不乐一切诸爱欲事。三者常不远离头陀功德。四者常厌三界诸有生处。贤护。是为菩萨摩诃萨具足四法得此三昧。复次贤护。若有善男子善女人。读诵受持是三昧典。或时复能为他解说。现前即获五种功德。何等为五。一者一切众毒不能损害。二者一切兵仗不能破伤。三者一切诸水不能漂没。四者一切猛火不能焚烧。五者恶王县官不能得便。所以者何。由是三昧慈心力故。贤护。若彼善男子善女人。一心勤求是三昧时读诵受持是三昧时。思惟修习是三昧时。为他解释是三昧时。若有众毒及以兵仗一切水火恶王县官。能伤害者无有是处。复次贤护。假使世间坏劫之火。世界炎赫天地洞然。若彼受持此三昧典。诸善男子及善女人。设令堕落大劫火中。三昧威神彼火即灭。贤护。又如罂水能灭小火。如是贤护。假使持经诸善男子及善女人落彼火中。三昧力故大火随灭。若不灭者无有是处。复次贤护。若彼善男子善女人受持经时。若彼恶王若恶官若劫贼若师子若虎狼若蛇毒。若能作障碍者无有是处。又设彼等行是经时。若被夜叉若罗刹若饿鬼若鸠槃茶。若毗舍阇乃至一切非人能为障碍。亦无有是处。又若彼男子女人读诵经时。正思惟时为他说时。入三昧时行梵行时。若失衣若失钵。乃至有诸障碍事者。无有是处。唯除宿殃不可转者。复次贤护。若彼受持三昧经典诸善男子善女人辈。若患眼若患耳若患鼻若患舌若患身若患心复有诸余种种患难。乃至命难梵行难者。亦无是处。复次贤护。若彼男子女人于此经中。得如是闻得如是见得如是知。如是具足已。若不值佛。若谤正法。破和合僧。背佛菩提者。亦无是处。贤护当知即彼持经男子女人。如上诸事莫能为碍。唯除宿殃不能转耳

复次贤护。彼善男子善女人持是经者。常为一切诸天称赞。亦为一切诸龙称赞。又为一切夜叉称赞。又为一切乾闼婆等之所称赞。又为一切阿修罗等之所称赞。又为一切迦楼罗等之所称赞。又为一切紧那罗等之所称赞。又为一切摩睺罗伽之所称赞。又为一切人非人等之所称赞。又为一切四大天王之所称赞。又为一切帝利天王之所称赞。又为一切大梵天王之所称赞。如是乃至常为一切诸佛世尊之所称赞也。复次贤护。又彼诸善男子善女人持是经者。常为一切诸天爱敬。如是乃至常为一切诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗迦人非人等之所爱敬。又为一切四天大王之所爱敬。如是常为一切帝利天王乃至一切大梵天王之所爱敬。如是常为一切诸菩萨辈乃至一切诸佛世尊之所爱念也。复次贤护。又彼诸善男子及善女人以经力故。常为一切诸天守护。如是常为一切诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽及人非人之所守护。又为一切四天大王如是帝利天王乃至大梵天王之所守护。如是当为一切诸菩萨辈乃至一切诸佛世尊。悉皆覆护十方世界无量阿僧祇世界中现持法者。复次贤护。又彼诸善男子善女人。以经威力故。一切诸天皆欲见之。如是一切诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽及人非人等皆思欲见。又彼一切四天大王。如是一切忉利天王乃至一切大梵天王皆思欲见。如是一切诸菩萨辈。乃至一切诸佛世尊各欲见之。复次贤护。又彼诸善男子善女人以经威故。一切诸天常至其所亲见其形。令彼观睹如是一切诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆见其形随宜利益。又彼一切四天大王。帝利天王乃至一切大梵天王等皆亲临视。如是一切诸菩萨辈乃至一切诸佛世尊。非但昼日或于梦中为现形像。自称名号摩顶慰安称扬劝发也。复次贤护。又彼诸善男子善女人。虽未曾闻诸余经典。以是三昧威神力故。自然有人来至其所。乃至梦中为其宣说。令彼得闻忆持不失也。复次贤护。我若说彼诸善男子及善女人。暂持三昧微妙经典所得功德。设经劫数终不能尽。我之智辩虽复无穷亦不能说。何况彼辈闻此三昧依教修行如法而住也。尔时世尊为重明此义。而说偈曰

  若人有能解释斯　　诸佛大寂胜三昧
  假令我今说功德　　犹彼恒河取一沙
  若能为他说三昧　　水不能溺火不烧
  刀杖毒害所不伤　　王贼恶官不得便
  若能读诵三昧经　　不畏一切恐怖事
  如彼大蛇诸大毒　　此等经力能灭除
  若有受持是经典　　不畏一切诸恶人
  夜叉罗刹及诸龙　　彼徒终无得其便
  若常守护供养者　　便在兰若为朋类
  师子虎狼诸兽等　　犀牛豺豹及野干
  若能护持此三昧　　彼有威力不可当
  远离一切恶心人　　及诸夜叉啖精气
  若能解说此三昧　　彼无诸病及障灾
  所生报眼终不衰　　言词清妙有大辩
  若人证知深寂禅　　身体雄健无众病
  一生永绝诸恶色　　后终不畏地狱道
  若有能读三昧典　　诸天守护及龙神
  夜叉罗刹与怨仇　　彼虽恶临不惊惧
  若能为他说斯经　　人龙夜叉皆欢喜
  诸天昼夜常歌叹　　一切世尊爱若子
  若人为他常转读　　一切法中无有疑
  彼诸容色无等伦　　岂于菩提有退减
  若能转教诸众生　　遭值恶王民人乱
  时年亢旱谷价贵　　终无受弊及饥荒
  若人解说此三昧　　所有功德不思议
  假虽魔娆诸众生　　不能动斯一毛发
  我前说彼持经人　　众患恐怖及烦恼
  彼终不能加损害　　唯除往业先定殃
  若有护持于此经　　是则于吾为长子
  我已称赞于彼等　　当来之世亦复然
  若能护持如斯法　　自应恒发欢喜心
  咸共宣通勿放舍　　我今为汝如是说

    大集经贤护分饶益品第九

尔时世尊。复告贤护菩萨言。贤护。我念往昔过于无量阿僧祇劫。时有一佛号无畏王如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出兴于世。当尔之时。有长者子名须达多。与二万人俱诣彼佛无畏王所。到已顶礼彼世尊足。敬礼毕已退坐一面。时须达多即便请彼无畏王如来。广宣如是三昧深义。贤护。尔时彼无畏王如来应供等正觉。知长者子有深信心。乐欲听闻如是三昧。应时随顺而为敷演。贤护。时须达多于彼佛所。闻三昧已读诵受持。思惟其义即如说行。既修行已。还即于彼无畏王如来法中舍家出家。剃除须发服袈裟衣。经八万岁思惟住持如是三昧。又复在彼无畏王如来所。闻一切法皆悉受持。是后复经诸如来所。闻说斯法亦皆能持于诸佛所种诸善根。能广成就不思议已。然后舍命即得上生三十三天同受果报。即彼劫中还复值遇第二如来。而彼如来从刹利生出家成道。名曰电德如来应供等正觉。而复于彼电德如来法中。出家修行经八万四千岁。还复思惟如是三昧。而更值遇第三如来。彼第三佛于婆罗门家生已亦出家成道。号曰光王如来应供等正觉。复于彼如来所出家修行。亦于八万四千岁中。常得思惟如是三昧。贤护。时彼长者子须达多。自是之后过百余劫。即得成就阿耨多罗三藐三菩提。贤护。汝应当知。尔时彼长者子须达多者岂异人乎。即彼过去然灯如来应供等正觉是也。贤护是故当知。彼长者子须达多者。以有如是爱乐法故。复有如是求法行故。能速成就阿耨多罗三藐三菩提也。复次贤护。汝今当观是三昧王。为诸菩萨及众生辈。而作几许大弘益事。所谓当得一切诸佛智地故。复能摄受一切诸佛多闻海故。贤护是故汝等当应勤求如是三昧。常乐听闻读诵受持思惟修行。既闻受已。当复为他读诵受持解释义理。令他勤求咸得闻受。正念思惟如说修行。所以者何。贤护若能勤求读诵受持正念修行。广宣流布是三昧者。不久当得证诸佛智。诸如来智大自在智。不思议智不可称智。无等等智一切智智。乃至得彼不共他智故。贤护。若复有人能善宣说。彼应正言。今此三昧即是一切诸菩萨眼。诸菩萨父。诸菩萨母。能与一切诸菩萨辈诸佛智者。贤护。如是说者是为善说时善说是三昧也。贤护。若复有诸男子女人。能善说时彼当正言。是三昧者。即是佛性即是法性即是僧性即是佛地是多闻海。是无尽藏头陀。是无尽藏头陀功德。是无尽藏诸佛功德。是无尽藏能生深忍。是能生大慈能生大悲能生菩提也。贤护。是为彼能善说时说是三昧也。贤护。若复有人能善宣说是三昧时。彼应正言。是三昧王。能破一切诸法黑闇。能作一切大法光明。贤护。是为彼能善说三昧也。贤护。汝宜观此菩萨念佛现前三昧。为诸众生作大利益。乃至一切诸菩萨辈。住于此土。遍见十方一切世界诸佛世尊。到诸佛所恭敬礼拜。听闻正法供养众僧。亦不贪着。贤护。以是义故诸菩萨等。若欲成就三昧王者。常当专心精勤观察彼四念处。贤护。云何菩萨观四念处。贤护。菩萨摩诃萨常当专心观察身行。毕竟不见一切诸身。常当专心观察受行。而亦不见一切诸受。常当一心观察心行。而亦不见一切诸心。常当一心观察法行。而亦不见一切诸法。贤护。如是等事谁能信者。唯彼漏尽阿罗汉及以阿毗跋致诸菩萨等。贤护。是中一切愚惑凡夫。于彼念佛现前三昧。常当思惟诸佛世尊不得生着。又亦思惟诸佛世尊。说如斯法而亦不着。又亦思惟我听闻法。一切所为皆不得着。何以故。贤护。诸法皆空本来无生故。贤护。诸法不可念。无念处故。贤护。诸法远离。绝心想故。贤护。诸法不可执持。真如无得故。贤护。诸法无染。如虚空故。贤护。诸法清净。远离众生故。贤护。诸法无浊因缘灭故。贤护。诸法无为。福伽罗不可得故。贤护。诸法即涅槃相。本性清净故。贤护。诸法无所有。一切物不可得故。贤护。是故诸菩萨等。若欲思惟此三昧者。不可异相而能得入无得相故。得见诸佛正念诸佛和合相应。亦得思惟助菩提分。念闻正法思量分别选择菩提分。而不见自身亦不证诸法。所以者何。贤护。是中不可以色相故而得见佛。不可以声相故而得闻法。不可以希望心成就檀波罗蜜。不可以乐着诸有具足尸波罗蜜。不可以悭吝秘法而得涅槃。不可以深着福伽罗想而获多闻。不可以攀缘诸行而能远离诸事。不可以乐着住处而得证果。不可以随顺贪爱诫诸过非。不可以常乐斗诤成就诸忍。不可以常行恶业而得善果。不可以声闻乘人而证菩萨念佛三昧。亦不可得诸菩萨忍。亦不可以嫉妒取着而得空三昧。亦不可以行爱欲而入奢摩他。亦不可以懈怠懒惰证诸圣道。乃至不可以不舍异念诸物而能成就思惟也。贤护。是故我今以此三昧付嘱世间诸天王辈。受持守护。亦付于汝。当来宣布勿令断绝。于是世尊说斯法时。有八那由他欲色界诸天子。皆发阿耨多罗三藐三菩提心。复有无量百千人。亦发阿耨多罗三藐三菩提心。然而斯辈皆于未来过恒沙劫。尽得成就阿耨多罗三藐三菩提。皆同一号。名正解脱如来应供等正觉。住世教化寿命亦等。贤护。以斯初发菩提心故。尚得如是无量功德。具足成就阿耨多罗三藐三菩提。况复我昔行菩提时供养我者。彼宁不速成就阿耨多罗三藐三菩提也。贤护。复有无量无边众生。闻说此法得净智眼。复有八百诸比丘等。于诸漏中心得解脱。尔时世尊为重明此义。而说偈言

  谁当受持此三昧　　彼于福聚不可量
  斯等戒行无尘垢　　本心清净犹如镜
  谁当受持是三昧　　多闻深广无边崖
  智慧自然无缺减　　功德盛满若明月
  谁当受持是三昧　　得睹诸佛不思议
  智慧观察希有法　　不思议人皆守护
  谁常受持此三昧　　曾见无量诸世尊
  彼佛说法难称量　　皆当奉承修供养
  谁能受持此三昧　　彼为世间作灯光
  大悲如斯拔众生　　所有世尊悉供养
  谁能受持此三昧　　未来无数诸圣尊
  若有菩萨欲见者　　清净信心修供养
  谁能受持此三昧　　彼胜得利难思议
  善能下生于人间　　常得出家善求食
  谁能护持此三昧　　彼受多福不思议
  复能住持于将来　　获斯功德最后利

    大集经贤护分具五法品第十

尔时贤护菩萨。从坐而起整理衣服。偏袒右肩右膝着地。恭敬合掌而白佛言。世尊。唯愿世尊及比丘僧。明日食时临顾我家受我供养。怜愍我等诸众生故。世尊默然受贤护请。时彼贤护知佛受已。顶礼尊足右绕三匝于是辞还。遂复诣彼摩诃波阇波提比丘尼所。到已顶礼波阇波提比丘尼足。而即白言。愿阿梨耶。及诸尼众怜愍我故。受我明朝所设微供。尔时摩诃波阇波提比丘尼。默然受请。贤护知已顶礼辞还。时彼贤护复诣宝德离车子所。语宝德言。宝德。汝来汝之所有亲戚眷属朋友知识。及此会中优婆塞众。乃至一切王舍大城。及以自余城邑聚落诸新来者。为我请曰。受我明朝所设饭食。尔时宝德离车童子受贤护言。即告会中诸优婆塞亲戚眷属等曰。仁辈当知。彼贤护菩萨。令我告汝。明日食时受我微供。尔时贤护菩萨。宝德离车子。及善商主长者。伽诃岌多居士子。那罗达多摩纳水天长者。并及一切诸余眷属朋友知识等。顶礼佛足已。还彼贤护菩萨舍宅。到已佐彼贤护经营。即于其夜约敕家人。办具诸种精妙上膳。所谓世间凡可食啖。色香美味百物备有。乃至外国远来贫穷乞丐。亦为办具种种精膳而供给之。与诸大众一等无异。所以者何。凡诸菩萨心无憎爱不敢轻他。于诸众生皆平等故。尔时娑婆世界主大梵天王。乃至忉利天王释提桓因。四天大王提头赖吒等。及彼善德天子与诸眷属。咸为人身赞助其事。欲令贤护菩提果报速成就故。尔时贤护。与诸眷属善友知识等扫洒其家乃至王舍大城街巷道路。处处皆悉悬妙幡盖。广设种种诸庄严具而庄饰之。又以诸种微妙华香布散其地。复烧世间第一名香而为供养。时彼贤护。如是庄严王舍大城及妙食已。于明旦时。与诸眷属诣世尊所。头面礼敬而启白言。世尊。我事已办愿知此时。尔时世尊于晨朝时。为贤护故着衣持钵。与彼无量比丘比丘尼优婆塞优婆夷天人大众。左右围绕。向彼贤护菩萨舍宅。于是贤护发如斯念。我家隘小不受多众。自非世尊威灵加护。令宅宽广尽为琉璃。令诸城内一切人民莫不明见。亦令今此天人大众随意受用无所乏少。不亦快乎。尔时世尊知彼贤护心所念已。即以神力令其家宅严丽宽广。所有众具变成琉璃。亦令城内一切人民皆得睹见分明显了。足令大众随意用之

尔时世尊入贤护宅。随其床座安详而坐。亦令一切诸比丘比丘尼优婆塞优婆夷人天大众。随其部类次第而坐。时彼贤护。及宝德离车子。善商主优婆塞。伽诃岌多长者子。那罗达多长者子。既见世尊。与彼四部天人大众皆安坐已。于是贤护躬以自手。持最妙食奉上世尊。世尊受已。然后授与诸四部众及与一切天人大众。种种上妙香美味食。咸令自恣悉皆丰满。如是一切饭食斯毕。澡手漱口乃至洗涤钵器持举皆竟。贤护于是别置小座。在世尊前头面顶礼。然后退坐一心瞻仰。尔时世尊即为贤护菩萨。及宝德离车子。善商主优婆塞。伽诃岌多长者子。那罗达多摩纳等。乃至四部天人大众等。如应说法令其解知。开导慰喻令其欢喜。然后与诸比丘比丘尼天人大众归还本所。时彼贤护菩萨后食毕已。将诸眷属善友知识。及百千众左右围绕。至世尊所恭敬礼拜。退坐一面胡跪合掌。而白佛言。世尊。菩萨摩诃萨具足几法。当能证此现前三昧。佛言贤护。菩萨若能成就五法。则便得此现前三昧。何等为五。所谓一者具甚深忍灭除至尽。二者实无所尽无有尽处。三者本无有乱灭除诸乱。四者本无有垢灭除诸垢。五者本无有尘断离诸尘。贤护。是为菩萨摩诃萨具足成就无生忍故。而能得此现前三昧。复次贤护。菩萨摩诃萨复有五法能得三昧。一者深厌诸有不受诸行。二者一切生处念菩提心。三者所生常见诸佛世尊。四者终不耽着阴界诸入。五者终不爱着受欲乐事。贤护。是为菩萨摩诃萨具足五法成就三昧。复次贤护。菩萨摩诃萨复有五法能得三昧。一者常当思念无边际心。二者常能善入禅定思惟。三者分别思惟一切诸法。四者于诸众生无有诤心。五者常以四摄摄受众生。所谓布施爱语利行同事。贤护。是为菩萨摩诃萨具足五法成就三昧。复次贤护。菩萨摩诃萨复有五法能得三昧。一者于诸众生所常行慈心。二者于一切时念修圣行。三者常行忍辱见破戒者恒生敬心。四者于自和上阿阇梨所不说己能。五者于一切处不敢轻他。贤护。是为菩萨摩诃萨具足五法则能证是现前三昧。复次贤护。菩萨摩诃萨复有五法能得三昧。一者常依圣教如说修行。二者清净意业灭身口恶。三者清净戒行断除诸见。四者常求多闻深信诸善。五者常念如来应等正觉。贤护。是为菩萨摩诃萨具足五法则能获得现前三昧。复次贤护。菩萨摩诃萨复有五法能得三昧。一者常行大施能为施主不起悭贪。心无嫉妒弘广心施纯直无谄。于诸沙门及婆罗门贫穷孤独一切乞人。无所爱惜。无有胜上可重之物而不施者。所谓一切微妙饮食。名衣上服第一房舍。诸种敷具灯烛花香。凡所受用皆悉舍之。虽常行施而不求报。怜愍一切无疑惑心。既施之后终无变悔。二者常为施主而行法施。所谓常为众生说如斯法。所谓第一最上最胜最妙最精。修行如是大法施时能出一切无碍辩才。文义次第相续不断。如来所说甚深法中。皆能安住成就深忍。或时被他诽谤骂辱捶击鞭打。终无嗔恨秽浊毒心。亦无惊惧种种苦恼。而心无畏常怀欢喜。三者若闻他说此三昧时。至心听受书写读诵思惟其义。广为他人分别演说。令是妙法久住世间终无秘藏使法疾灭。四者常无嫉妒远离诸恼。弃舍盖缠断除尘垢。不自称誉亦不毁他。五者于诸佛所常重信心。于诸师长常行敬畏。于知识处常生惭愧。于诸幼稚常怀慈怜。乃至受他小恩尚思厚报。何况人有重德而敢辄忘常住实言未曾妄语。贤护。是为菩萨摩诃萨具足五法则能获得如是三昧。尔时世尊为重明此义。以偈颂曰

  若于深法心欲乐　　厌离一切诸后有
  智者不愿一切生　　若能如是得三昧
  不用一切诸外论　　乃至语言不听受
  永断世间诸五欲　　若能如是证三昧
  清净持戒住梵行　　所生不念诸女人
  深厌五欲真佛子　　若能如是证三昧
  常行大施不求报　　亦无住着悔恨心
  一舍已后不重缘　　唯当摄念思诸佛
  怜愍众生行施时　　决定除疑无变退
  安住调柔而修施　　若能如是得三昧
  若于财施为大主　　无有憍慢嫉妒心
  行一切施常踊跃　　若能如是得三昧
  又于法施为上首　　善解微妙修多罗
  能知甚深寂灭法　　若能如是得三昧
  安住甚深诸法中　　善能堪忍无嫉妒
  虽被挝骂无恼恨　　若能如是得三昧
  或时闻说此经典　　书写读诵巧广宣
  唯为法住利世间　　若能如是得三昧
  于诸法中不秘吝　　不求利养及名闻
  但为绍隆诸佛种　　若能如是证三昧
  远离睡眠与衰恼　　除断嫉妒及盖缠
  不自称赞轻毁他　　能灭我相得三昧
  正信诸佛及法僧　　常行诚心无欺诳
  不忘一切诸恩报　　彼证三昧无艰难
  若能真说无妄言　　凡有所行亦不失
  所作虽微获报广　　彼于证法无障碍
  若人有能具斯法　　清净持戒护有恩
  彼得菩提尚不难　　何况甚深微妙定

    大集经贤护分授记品第十一

尔时世尊。告贤护菩萨言。贤护。我念往昔过于无量阿僧祇。复过无量阿僧祇劫初于然灯佛世尊所闻此三昧。闻已即证如斯三昧见诸如来常现在前。从是已来经于无量阿僧祇诸世尊所。皆受是经修行供养。彼佛世尊授我记曰。摩纳。汝于来世当得作佛。号释迦牟尼如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。贤护。汝辈亦当专精一心思惟修习如斯圣法。非是凡夫所见境界。甚深寂静众相灭处。如是学已未来自然。成就阿耨多罗三藐三菩提。无有艰难如我不异。汝等当知。若有安住是三昧者。自然当得近大菩提。尔时世尊为重明此义。以偈颂曰

  我昔遇彼然灯佛　　见已即得三摩提
  从是常睹诸如来　　具足功德大名称
  汝但多集诸功德　　一切专念即得成
  若人能行此法中　　当得无上菩提道

    大集经贤护分甚深品第十二

尔时贤护菩萨复白佛言。世尊。云何思惟如是三昧。佛言贤护。若有善男子善女人。念欲思惟此三昧者。观彼色时不应取着。于彼声中不应取着。于彼香中不应取着。于彼味中不应取着。于彼触中不应取着。于诸法中不应取着。于诸生中不应取着。于一切处不应取着。于是法中当起真实大慈行也。是中何等名为三昧。所谓于一切法中如法行故。若诸菩萨观念处时当应如是。观察身行终不分别见身行处。观察受行亦不分别见受行处。观察心行亦不分别见心行处。观察法行亦不分别见法行处。菩萨当应如是观察思惟三昧。何以故。贤护。彼菩萨观身行时于身不起思惟分别。观受行时于受不起思惟分别。观心行时于心不起思惟分别。观法行时于法不起思惟分别故。所以者何。一切法不可得故。如是诸法既不可得。云何当有分别思惟。贤护。是故一切法无有分别。无分别者无有思惟。无思惟者。当知彼中无法可见。贤护。无可见故便为无碍。一切法中无障碍故。即是菩萨现前三昧。菩萨成就是三昧故。即得睹见无量无数过阿僧祇诸佛世尊。并所宣说皆悉听闻。闻彼法已咸能受持。彼诸如来应等正觉。所有一切无碍解脱解脱知见。亦即能得彼无碍智。复次贤护。菩萨观察四念处时。无法可见无声可闻。无见闻故则无有法可得分别。亦无有法可得思惟。而亦复非瞽盲聋类。但是诸法无可见故。是故观时不生住着而见诸道。思惟道故。即于诸法无有疑网。无疑网故见佛如来。见如来故永离迷谬。无迷谬故知一切法终无可见。何以故。菩萨若有如斯见者。则取彼见。取彼见故则取法相。取法相故则取事业。取事业故则见众生。见众生故则见寿命。见寿命故则见富伽罗。见富伽罗故则见诸阴。见诸阴故则见诸入。见诸入故则见诸界。见诸界故则见诸相。见诸相故则见诸物。见诸物故则见彼因。见彼因故则复见缘。以见缘故则便求取。以求取故则有有生。何以故。贤护。一切诸法终不可取。无可取故。菩萨于彼一切诸法。不思不念不见不闻。贤护。终不如诸外道若外道弟子。取着富伽罗及以我见也。贤护。菩萨终不作如是见。云何见。菩萨见者如如来见终不退转。菩萨见如辟支佛见如阿罗汉见。菩萨当应作如斯见。如斯见故不忆不念不见不闻。以不忆念及见闻故灭诸妄想。即得思惟如斯三昧也

复次贤护。譬如虚空本无形色。不可观见无有障碍。无所依止无有住处。清净无染亦无垢浊。诸菩萨辈见一切法亦复如是。所谓于彼有为无为一切法中无有处障碍乃至亦无处所。以眼清净无障碍故。一切诸法自然现前。彼诸菩萨如是念时即见诸佛。其所庄严状如金辇。具足威仪如百千光。炎赫斯照如秋满月。众星围绕如转轮王。军众炽盛如天帝释。四辅中尊如大梵王。处彼天座如师子王威伏众兽。如鲜白鹄处空而飞。如须弥山王安住大海。如大雪山出诸良药。如铁围山摄持猛风。如彼水界住持大地。如大风轮净虚空界。如须弥顶壮丽天宫。如是贤护。彼诸如来应等正觉。以智德光照明一切三千大千诸佛世界其事若此。贤护。彼诸菩萨于正观中复如斯念。而诸如来有所宣说。我昔听闻。闻已读诵受持修行。如是念已从三昧起。如彼定中所闻诸法。思惟其义为他宣说。贤护当知。是三昧王。为诸菩萨作斯利益。能与如是诸功德聚。所谓世间出世间一切诸法也。贤护是故。若彼善男子善女人。随欲求证无上菩提。当应听闻如是三昧。闻已书写读诵受持。修习思惟广为他说。令是妙法流布世间。尔时世尊为重明此义。以偈颂曰

  诸佛清净离尘垢　　功德深广无所依
  钟鼓铿锵众妙音　　万种咸备修供养
  布散诸种超世香　　精异花鬘上宝盖
  然灯供养众塔庙　　所为求此三摩提
  佛法甚深难可见　　开示世谛令人知
  彼如自性初不迁　　汝当随顺智无碍
  犹日月天初出时　　帝释佐天三十二
  众具庄严实周普　　求彼三昧亦复然
  譬如梵天处梵众　　威仪寂静功德圆
  勇猛精进不可称　　彼求三昧亦如是
  又如医王处世间　　给施病者众妙药
  随顺诸佛清净心　　初未曾离本空性
  譬如雪山诸山王　　炜烨同于转轮帝
  亦如宝辇妙庄严　　彼见诸佛众相满
  又犹鹄王绝明白　　处空自在无碍游
  如是诸佛金色身　　世尊真子如斯念
  无垢三昧净智灯　　能破大冥诸黑闇
  彼除一切众物想　　念诸佛智无碍光
  诸垢消灭无嗔毒　　无明清净妙智人
  若能观是无自他　　彼终无有诸色相
  无疑惑中净智生　　悉能断斯诸有见
  亦已灭亡阴界想　　闻法除恼得清凉
  比丘当知诸佛子　　及以清净比丘尼
  彼优婆塞优婆夷　　若能念此得三昧

贤护菩萨所问经卷第四大乘大集经贤护分卷第五

        隋天竺三藏阇那崛多译

    现前三昧中十法品第十三

尔时世尊。复告贤护菩萨言。贤护。若有比丘。乐欲修习此三昧者。先当思惟彼无相想。既思惟已我慢不生。贤护。除慢高已心意泰然远离众相。尔时即应为他宣说如是三昧。不应起诤。是中云何名为诤也。所谓妄想诽毁即谤于空名为诤也。贤护。是故彼比丘以无诤故。当能修学为他宣说此三昧也。贤护。有诸善男子善女人。若欲修学为他解释此三昧者。应当具足成就十法然后为他解斯三昧。何等为十。所谓一者彼诸善男子善女人。先摧我慢起恭敬心。二者知恩不忘心常念报。三者心无倚着亦无嫉妒。四者除断疑惑及诸障碍。五者深信不坏系念思惟。六者精进勤求经行无倦。七者常行乞食不受别请。八者少欲知足调伏诸根。九者正信甚深无生法忍十者常念谁所有是三昧。即于彼师生诸佛想。然后修习如是三昧。贤护。是为彼善男子善女人具足如上十种法已。应当修习如是三昧。亦令他人受持读诵。如是行者当得八事。何等为八。一者毕竟清净。于诸禁戒无毁犯故。二者知见清净。智慧和合不与余相应故。三者智慧清净。更不复受诸后有故。四者施与清净。不愿一切诸行果报故。五者多闻清净。既闻法已毕竟不忘故。六者精进清净。于一切时求佛菩提故。七者远离清净。于一切名利不染着故。八者不退清净。当得阿耨多罗三藐三菩提初不动摇故。贤护。是为彼善男子善女人所获八法也。尔时世尊为重明此义。以说偈曰

  智人不起有相想　　亦当除慢及我心
  于深忍中无取着　　彼能速宣此三昧
  空中本来灭诤根　　涅槃无相大寂定
  于佛无嫌不谤法　　彼能速宣此三昧
  智者不兴嫉妒意　　念佛知恩及法僧
  所生降伏无迁移　　如是寂静持三昧
  无有嫉妒亦无疑　　思惟深法真实信
  精进不懈离诸欲　　彼能如是得三昧
  常行比丘乞食法　　舍诸别请况求财
  断除垢染证真如　　彼能如是得三昧
  谁能有此三摩提　　我应听受广流布
  于教师所起佛想　　彼能如是得三昧
  若人修行此三昧　　当具功德超世间
  彼应速受八种法　　称诸佛心净无垢
  持戒清净无有边　　三昧菩提及胜见
  彼能清净诸有中　　住以最妙功德聚
  智慧清净不受有　　布施离垢入无为
  得彼多闻未曾忘　　其为智人功德藏
  勇猛精进得菩提　　于世名利不贪染
  若诸智者善行此　　彼入无上深妙禅

    大集经贤护分不共功德品第十四

尔时世尊。复告贤护菩萨摩诃萨言。贤护。彼诸菩萨摩诃萨。复当成就十八不共法。何等名为不共法也。所谓如来初成阿耨多罗三藐三菩提。乃至般涅槃。于其中间如来所有三业智慧为首。一切身业随智慧行。一切口业随智慧行。一切意业随智慧行。又诸如来知见过去无有障碍。知见未来无有障碍。知见现在无有障碍。又诸如来所为无有错误。言无漏失意无忘念无别异想。常在三昧无不知已舍。又诸如来意欲无减精进无减禅定无减智慧无减解脱无减解脱知见无减。贤护。是为如来十八不共法。彼菩萨摩诃萨当应修习具足成满

复次贤护。若菩萨摩诃萨。成就具足甚深难见摄受正法。即欲宣说是三昧者。应当更受十种胜法。何等为十。所谓如来十力。云何十力。贤护。是中如来是处非处力者。如来于诸处非处事。能以正智如实知故。贤护。如是处非处事。如来能以正智如实知者。此则如来处非处力。如来得此力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若有沙门婆罗门若天若梵若魔若人。一切世间终无有能如是转者。贤护。是为如来第一智力。菩萨摩诃萨应当修学具足成满

复次贤护。是中如来一切至处道力者。如来于一切处道差别。皆以正智如实知故。贤护。如是一切至处道事。如来能以正智如实知者。此则如来至处道力也。如来得此力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若诸世间沙门婆罗门。若天若梵若魔若人。终无有能如是转者。贤护。是为如来第二智力。菩萨摩诃萨应当修学具足成满。复次贤护。是中如来世间种种界力者。如来于世间种种诸界无量差别。能以正智如实知故。贤护。如是世间种种界事。如来皆以正智如实知者。此则如来世间界力也。如来得此力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若诸世间沙门婆罗门。若天若梵若魔若人。终无有能如斯转者。贤护。是为如来第三智力。菩萨摩诃萨应当修学具足成满

复次贤护。是中如来心行力者。如来于诸众生种种心行无量差别。皆以正智如实知故。贤护。如是众生种种心行无量差别。如来能以正智如实知者。此则如来知心行力也。如来得此力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若诸世间沙门婆罗门。若天若梵若魔若人。终无有能如是转者。贤护。是为如来第四智力。菩萨摩诃萨应当修学具足成满

复次贤护。如来知众生诸根差别力者。如来于众生诸根种种差别。皆以正智如实知故。贤护。如是众生诸根种种差别。如来皆以正智如实知者。是则如来诸根差别力也。如来得此力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若诸世间沙门婆罗门。若天若梵若魔若人。终无有能如是转者。贤护。是为如来第五智力。菩萨摩诃萨应当修学具足成满

复次贤护。是中如来禅定力者。如来于一切禅定解脱三昧。生起烦恼及以灭除。斯以正智如实知故。贤护。如是一切禅定解脱三摩跋提生起烦恼乃至清净。如来皆以正智如实知者。是则如来禅定力也。如来得已知真正处。于大众中作师子吼转大梵轮先所未转。若彼世间沙门婆罗门。若天若梵若魔若人。终无有能如是转者。贤护。是为如来第六智力。菩萨摩诃萨应当修学具足成满

复次贤护。如来业力者。如来于彼一切诸业种种差别。及彼未来和合得报亦无量差别。如来斯以正智如实知故。贤护。如是诸业种种差别。未来得果亦复差别。如来皆以正智如实知者。斯则如来知业力也。如来得已知真实处。于大众中作师子吼。转大梵轮先所未转。若彼世间若沙门婆罗门。若天若梵若魔若人。终无有能如斯转者。贤护。是为如来第七业力。菩萨摩诃萨应当修学具足成满

复次贤护。如来天眼力者。如来常以清净天眼过于人眼。见彼未来诸众生辈死此生彼。其所受身或美或丑或善或恶。所得诸色或好或恶或妙或粗。或生善道或生恶趣。又见众生所作诸业或善或恶。有诸众生。具身恶业具口恶业具意恶业。诃骂圣人诽谤正法坏和合僧。具足如是诸恶业故。身坏命终生于恶道。又诸众生。具身善业具口善业具意善业。恭敬圣人尊重正法供养众僧。具行如是诸善业故。命终得生人天善趣。如是等事皆如实知。贤护。如来以净天眼见诸众生死此生彼。乃至命终生于天上。是则如来生死智力。得是力已知真实处。于大众中作师子吼。转大梵轮昔所未转。若彼世间若沙门婆罗门。若天若梵若魔若人。终无有能若斯转者。贤护。是为如来第八智力。菩萨摩诃萨应当修学具足成满

复次贤护。如来宿命智力者。如来能以诸宿命智。知于过去诸宿命事。所谓众生生此死彼。或于一处初受一生或二或三或五或十或百或千。乃至或受无量百生无量千生无量百千生。如是乃至无量转劫。无量定劫无量转不转劫等。皆如实知。又于彼所生趣。如是处如是家。如是种姓如是名字。如是相貌如是生中。如是服食如是所作。如是善恶如是忧喜。如是苦乐乃至若干寿命等。亦如实知。又于某处舍彼身已复生某处。如是身相如是所说如是所经。乃至寿命诸过去事。皆悉知故。贤护。如来能以种种无量诸宿命智。知彼众生宿命所经。始自一生及无量生。乃至寿命诸过去事如实知者。是则如来宿命智力也。得是力已处大众中作师子吼。转大梵轮昔所未转若彼世间沙门婆罗门。若天若梵若魔若人。终无有能若斯转者。贤护。是为如来第九智力。菩萨摩诃萨应当修学具足成满

复次贤护。如来漏尽力者。如来能尽一切诸有。无复诸漏。心慧解脱自觉法已。是故唱言。我生已尽梵行已立。所作已办不受后有。贤护。如来如是能尽诸漏。心慧明脱自证知故。故言我生已尽乃至不受后有。如实知者。是则如来漏尽智力也。如来得已处大众中作师子吼。转大梵轮昔所未转。若彼世间沙门婆罗门。若天若梵若魔若人。终无有能若斯转者。贤护。是为如来第十智力。菩萨摩诃萨当应修学具足成满。贤护。若诸菩萨摩诃萨。读诵受持思惟修习是三昧者。则能摄受如来十力也。尔时世尊为重明此义。以偈颂曰

  十八不共等觉法　　十力明智诸佛同
  菩萨修习此妙禅　　自然成就斯二种

    大集经贤护分随喜功德品第十五

尔时世尊。复告贤护菩萨言。贤护。若菩萨摩诃萨具足成就四随喜故。即当得斯现前三昧。速疾成满阿耨多罗三藐三菩提。何等名为四种随喜也。所谓彼菩萨摩诃萨应作如是念。如彼过去一切诸如来应供等正觉各于往昔行菩萨时。皆因随喜得是三昧。因三昧故具足多闻。由多闻故速疾成就阿耨多罗三藐三菩提。如我今日亦应如是。依因随喜得是三昧。因三昧故具足多闻。由多闻故速得成就无上菩提。贤护。是为菩萨摩诃萨第一随喜功德聚也。贤护。彼菩萨摩诃萨。复应如是念。如彼当来一切诸如来应供等正觉行菩萨时。皆因随喜得是三昧。因此三昧故具足多闻。由多闻故速疾成就阿耨多罗三藐三菩提。如我今日亦应如是。当因随喜得是三昧。归凭三昧求满多闻。由多闻故速疾成彼无上菩提。贤护。是为菩萨摩诃萨第二随喜功德聚也。贤护。是菩萨摩诃萨。复应如是念。而今现在无量无边阿僧祇诸世界中。一切诸如来应供等正觉。各于往昔行菩萨时。亦因随喜得是三昧。因是三昧具足多闻。由多闻故现皆得成无上菩提。然我今日亦应随喜。乃至为欲速成无上菩提故。贤护。是为菩萨第三随喜功德聚也。复次贤护。彼菩萨摩诃萨。复应如是念。我今已得仰学。三世一切诸如来本于过去行菩萨时。皆因随喜得是三昧。皆因三昧具足多闻。皆由多闻而得成佛。今我以此随喜功德。愿与一切众生共之。同生随喜同获三昧。同具多闻同悉成就阿耨多罗三藐三菩提。贤护。是为菩萨摩诃萨第四随喜功德聚也。复次贤护。而彼菩萨既得成就。如是随喜如是三昧。如是多闻如是速疾成就菩提。以是功德悉与众生。共同回向阿耨多罗三藐三菩提。如是功德难可称量。我今为汝略开少分。汝宜谛听善思念之。贤护。譬如有人定寿百岁。身轻气猛行骏若飞。是人生已便即能行一世界先行东方尽世界边。如是次第行于南西北方四维上下。周旋十方穷极地际。贤护。于意云何。假使有人聪明出世善通算术。能计是人所行地界道路近远长短耶。贤护白言。不也。又能称量耶。不也。又能观察耶。不也。亦能思惟耶。不也世尊贤护。且置初行。即使是人满足百年速疾往返。遍至十方无量世界。彼明算人复能知否。贤护报言。不也世尊。彼明算人尚不能知初时所行地界近远。云何能计是人一世尽力飞行周遍十方。无数世界道路由旬其数多少。若欲的知。唯独世尊及大弟子舍利弗与彼不退诸大菩萨等乃能知耳。佛告贤护。如是如是。我今语汝。若有善男子善女人。起信敬心。于彼风行壮人所经世界盛满珍宝。持用奉献十方诸佛。其所获福虽曰极多。然尚不如随喜三昧功德少分。何以故。贤护。由彼菩萨摩诃萨修此三昧。具足如上四大随喜。回向阿耨多罗三藐三菩提。为求多闻成正觉故。贤护。以是因缘持彼施福。望前随喜所获功德。百分不及一。千分不及一。百千万分不及一亿百千分不及一。乃至算数譬喻所不能及。贤护。汝今当知。诸菩萨等。随喜回向所得功德。是故我今更为汝说菩萨随喜功德少分。汝宜谛听也。贤护。我念往昔过于无量无边阿僧祇劫。尔时有佛。号师子意如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。贤护。时此世界阎浮提中。人民炽盛多饶财宝。丰乐安隐甚可爱乐。贤护。尔时此阎浮提其地弘广。具足一万八千由旬。其间城郭聚落乃有一万八千。一切皆以七宝所成。其城纵广十二由旬。于诸城内城别皆有九亿民家。贤护

尔时大城名曰贤作。城中居民有六十亿。彼城即是师子意如来现生处也。贤护。尔时师子意如来。初会说法有九十亿人证阿罗汉果。过七日已。于第二会。复有九十亿人得阿罗汉果。过第二会。第三会中。复有九十亿人得阿罗汉果。过三会已。复有九十亿人咸从他方而来大集。悉是清净诸菩萨众。自后彼佛恒有无量阿僧祇诸声闻众。贤护。尔时人民行十善业。如彼未来弥勒佛世教诸众生。具足成就十种业行。尔时人寿八万四千。如弥勒时人寿无异。贤护。时彼大城有转轮王名曰胜游。如法治世具足七宝。所谓金轮宝象宝马宝摩尼宝女宝长者宝主兵宝。是为七宝。满足千子身相端严。成就威雄降伏怨敌。彼王所统尽世界边。不用刀兵亦无威迫。无所税敛众具自然。时胜游王诣师子意如来应供等正觉所。顶礼尊足然后退坐。尔时师子意如来。知胜游王渴仰心已。即为广宣现前三昧。时彼王既闻如是三昧。深自庆幸发随喜心。以一把宝奉散佛上。彼王缘此随喜善根。命终之后还生阎浮。为彼王子名曰梵德。复绍王位如法治化。彼佛灭后于正法中有一比丘。其名曰宝。聪明精进。常为四众宣扬广说如是经典。贤护。尔时彼梵德王于比丘所闻三昧已。得深净信起随喜心。持上妙衣价直百千覆比丘上。贤护。又梵德王从比丘所闻三昧已。即发阿耨多罗三藐三菩提心。为爱法故舍家出家。剃除须发被服袈裟。是时亦有百千人众。成就信心即随彼王法服出家。亦为如是三昧经故。时彼梵德比丘。与彼百千诸比丘众。经八千岁供养承事。彼宝比丘无有疲倦。终不能得如是三昧。唯除一闻。闻已随喜具以四种随喜功德。回向阿耨多罗三藐三菩提。如初随喜如是广行。然后梵德比丘及百千众。缘此善根寻得值遇六万八千诸佛世尊。凡所生处常得为众颁宣广说如是三昧。彼王比丘因彼善根。复更值遇六万八千亿数诸佛。如是次第种诸善根得此三昧。具足圆满助菩提法已。寻得成就阿耨多罗三藐三菩提。号曰坚固精进如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。而彼百千诸比丘众得此三昧。亦能成就助道法故。皆已成于阿耨多罗三藐三菩提。名曰坚勇如来应供等正觉。复令无量百千众生住于阿耨多罗三藐三菩提。贤护。彼但耳闻尚获如是。何况菩萨闻受三昧。读诵忆持为他广说。复勤思行而不得也。贤护。以此义故。诸菩萨等闻是三昧谁不随喜。谁不读诵谁不受持。谁不修习谁不广说。何以故。贤护。以彼菩萨闻是三昧。即得成就助道法等。速疾成于阿耨多罗三藐三菩提故。贤护。以是因缘吾今语汝。若人正信净心欲求阿耨多罗三藐三菩提者。要先至心求此三昧。菩萨若闻百由旬内有此甚深三昧经者。菩萨即应躬自往诣听是经典。闻已即应读诵受持修习思惟为他广说。贤护。且置百由旬内当往听受。又彼菩萨若闻二百由旬。三百四百五百。乃至千由旬内有是三昧。在某都城某聚落所。菩萨即应躬往听受习诵受持。何以故。贤护。以是菩萨清净信心。为求成就阿耨多罗三藐三菩提故。是故菩萨不应起懈怠心生懒惰心起散乱心。当更发精进心发猛利心。应当为是三昧速至千由旬所。乃至但得闻是三昧。何况读诵受持思惟解说。何以故。贤护。以是三昧能摄一切助道法故。复次贤护。是中若有菩萨。以纯净心为求菩提。应当往诣千由旬所。为听如是三昧法时。菩萨应当承事供养彼说法师。一切众具悉皆奉上。常当随逐法师而行。或时一年或复二年。或十二十或经百年。乃至尽寿随逐法师不得舍离。乃至但求闻是三昧。何况能得读诵受持。思惟义理为他解释。如是菩萨随法师时。当舍自心诸所为事。常当随顺彼阿阇梨法师意行。谨心承事不得违教。起尊敬心及重爱心。除舍一切无爱敬事。于法师所发善知识想。乃至当起如诸佛心。贤护。彼菩萨于是法师阿阇梨所。能生如是敬爱心已。若当不得读诵受持思惟广说。乃至听闻是三昧者终无是事。唯除往昔诽谤如是甚深经典业时已熟定堕恶道业不净耳。复次贤护。假彼菩萨或欲须离彼法师者。常当知恩常当念恩常当报恩。何以故。贤护。以是法师宣讲因缘。令斯经典久住不没

复次贤护。若有菩萨为是三昧。尚当应往千由旬处。况复随近城都国邑聚落空处或山野中。而当不往听受读诵思惟义理为他广说也。复次贤护。我今语汝。若有菩萨为三昧故。即能往至千由旬所。乃至不得闻是三昧。而彼菩萨虽复不得闻是三昧。于是法中念求善根。当发精进莫即懈惰。汝应当知如是之人。则为已得不退转于阿耨多罗三藐三菩提。何况听闻受持读诵。思惟修习为他广宣。贤护。汝今当观彼菩萨辈。闻此三昧已而能受持思惟修行。即得尔许大功德聚。乃至求已不能得闻。亦当具足几大善根。若闻不闻。皆为已住不退转地。毕竟成就阿耨多罗三藐三菩提。何况闻已读诵受持。思惟修习广为他说。亦令多人闻已诵持修习思惟炽然流布也。尔时世尊为重明此义。以偈颂曰

  我念过去有如来　　号师子意人中上
  彼时有王为众首　　亲往诣佛求三昧
  时大智王得闻已　　欢喜遍满不可宣
  以手持宝奉散之　　供养人尊师子意
  内心思惟发是言　　我今归依无上觉
  为诸世间作饶益　　唯愿善说三摩提
  时王兴建此业已　　舍身还生于彼宫
  寻得值遇宝比丘　　大德名闻满十方
  彼闻比丘善说时　　心生欢喜无称量
  即以胜妙众宝服　　答彼比丘为菩提
  复与数千众出家　　供养承事彼比丘
  经历满于八千岁　　为求如是三昧故
  彼唯一说不再宣　　闻受深妙如大海
  尔时心智都无倦　　求此如实胜寂禅
  彼辈如是修行已　　值遇诸佛大威雄
  具满六万有八千　　其间亦闻此三昧
  余世供养复承事　　六万八千亿世尊
  所闻深妙悉随喜　　斯由师子如来故
  彼王如是具修行　　终得成佛号坚进
  教化众生无量数　　所在生死皆远尘
  从王出家数千众　　亦同得佛名坚勇
  德声遍满于十方　　闻三昧名证大觉
  何况复能为他说　　不染着彼诸世界
  当更广显妙思惟　　若斯三昧诸佛演
  若知三昧百由旬　　为求菩提诣彼听
  于言教中莫辞倦　　闻者功德不可量
  若至于彼不得闻　　尚获若干诸福聚
  何况闻已思说者　　唯当速求此三昧
  当念彼具梵德人　　亲近承事勿生厌
  谁比丘所有此经　　即当诣彼修供养

    大集经贤护分觉寤品第十六

尔时世尊复告贤护菩萨言。贤护。我念往昔过多无量阿僧祇劫。有佛出世名萨遮那摩如来应供等正觉。十号具足。时有比丘名曰和轮。于佛灭后称扬广说是三昧经。我于尔时为大国王。一心专求是妙三昧。即于梦中闻有告言。是三昧处既觉寤已。遂便躬诣比丘师所求是三昧。因请法师剃发出家。为求听受是三昧故。躬用承事和轮法师。备经三万有六千岁。天魔障蔽竟不得闻。时佛复告诸比丘比丘尼优婆塞优婆夷言。我今语汝。汝等当应急疾听受是三昧王。无得赊迟亦无忘失。善承事师无令失所。求是三昧以得为期。若经一劫乃至百千。不生懈心无不得也。贤护。若人一心求是三昧。常随逐师不得远离。当设供养。所谓汤药饮食衣服床敷种种众具。及以一切金银珍宝。凡是资用尽奉于师无所爱惜。如其自无乞求而与。趣得三昧勿生厌心。贤护。且置如斯寻常供具。夫求法者。师若有须。乃至应当自割其身。肌肤肢体供奉于师。师若须命尚无爱惜。况余外物而不奉师。贤护。其求法者。承事法师将护随顺其事若此。又承事师如奴随主。如臣事君。事师亦尔。斯人如是疾得三昧。得三昧已当念忆持。常念师恩恒思报答。贤护。是三昧宝不易可闻。正使有人过百千劫。但求闻名尚不得闻。何况闻已书写诵持。转复为他分别说也。贤护。假使恒河沙数诸佛世界。盛满珍宝持以行檀。其福虽多犹亦不如闻此经名。书写一偈所获功德无可校量。尔时世尊。为重明此义。以偈颂曰

  我念过去无量时　　具足数满六千岁
  常随法师不蹔舍　　初不闻是三昧名
  有佛厥号为至诚　　时彼比丘名和轮
  其于世尊灭度后　　比丘广说是三昧
  我时为彼天下王　　梦中闻告三昧处
  和轮比丘常宣转　　王当听受是妙经
  从梦寤已即推求　　躬诣比丘请三昧
  遂舍王位而出家　　恭敬供养不暂休
  经历三万六千年　　但愿得逢彼宣流
  常为天魔来固扰　　终竟未果一听闻
  是故比丘比丘尼　　诸优婆塞优婆夷
  吾故诫汝此诚言　　汝当趣持是三昧
  其欲敬承彼法师　　若经一劫及多劫
  备奉药汤诸妙膳　　求闻如是三昧经
  又办亿数众衣服　　床敷灯烛及诸珍
  精勤如是不觉疲　　为听如是妙三昧
  比丘自无当乞奉　　乃至身命无吝情
  何况余物有惜心　　如是求者得三昧
  受恩常念思报恩　　智人闻已应广说
  亿那由劫专精求　　斯妙三昧尔乃闻
  假使恒沙诸世界　　盛满珍宝用行檀
  能于是中说一偈　　此人功德过于彼
  正言宣说一偈者　　过于诸劫那由他
  何况闻已能广传　　斯人功德不可说
  若人乐行于菩提　　当为一切求是法
  必能正觉无上道　　闻已安住斯定中

    大集经贤护分嘱累品第十七

尔时世尊告贤护菩萨言。贤护。是故彼善男子有净信者。常当精勤听此三昧。既闻受已读诵总持思惟其义。广为世间分别演说。宜善书写安置藏中。所以者何。贤护。于我灭后当来之世。有诸菩萨摩诃萨辈净信心者。为众生故当求多闻。求多闻故当诣诸方听受正法贤护。是故彼诸善男子。有欲乐者。具足信心者。摄受正法者。爱乐正法者。总持修多罗者。为如是等广宣说故。以如来力加持故。书写如是大乘经典。以如来印印封之已。然后安置于匣藏中。贤护。是中何等为如来印。所谓一切诸行无造无作。无造作者。未曾有无为无相无想无依无摄无取无住。一切诸行尽苦因尽。有尽一切烦恼尽。无生无灭无道无道果。一切诸圣无有覆藏。愚痴所毁。智者所称。巧者能受。如来世尊说此经时。无量众生皆于阿耨多罗三藐三菩提。种诸善根。彼恒河沙等诸佛世界。有无量阿僧祇诸菩萨摩诃萨众。皆从本国发来至此。咸为听受是三昧者。彼辈皆得不退转于阿耨多罗三藐三菩提。时此三千大千世界一切大地六种震动。所谓动大动等遍动。涌大涌等遍涌。起大起等遍起。震大震等遍震。吼大吼等遍吼。觉大觉等遍觉。乃至边涌中没中涌边没。时此世界如是大动

尔时世尊告尊者摩诃迦叶。尊者舍利弗。尊者目揵连。尊者阿难及贤护菩萨。宝德离车子。商主长者。星德长者子。伟德摩纳水天长者等。五百人众并余诸天世人四部众等言。迦叶。我今以是三大阿僧祇劫修成阿耨多罗三藐三菩提法。付嘱汝等。如是等义一切世间所不能信。何以故。如来所说修多罗。最胜微妙第一甚深。于当来世能与一切众生阿耨多罗三藐三菩提。是故我今殷勤嘱汝。汝当听受。汝当读诵。汝当忆持。汝当思惟。汝当修行。汝当开发。汝当广宣。汝当解释。汝当尽善。汝当流布勿令断绝。复次阿难。若有诸善男子善女人。念欲修习此三昧经者。欲读诵者欲受持者。欲思惟者。欲开示者。欲广说者。当应令他生正信故。令他读诵故。令他受持故。令他思惟故。令他开示故。令他广说故。我今为彼安住大乘诸善男子善女人辈。广开发已。当如是学。常当念我如斯教敕。尔时世尊说是经已。尊者摩诃迦叶舍利弗大目揵连阿难。自余一切诸大声闻。及彼贤护宝德善商主星德伟德水天长者等五百优婆塞众。及彼从十方他佛国土诸来菩萨摩诃萨众。乃至一切天龙鬼神人非人等。闻如来说皆大欢喜。奉教修行

贤护菩萨所问经卷第五


大方广十轮经

    No. 410 [No. 411]

大方广十轮经卷第一

        失译人名今附北凉录

    序品第一

如是我闻。一时佛在佉罗堤耶山牟尼仙所住之处。与大比丘众俱。无量无数声闻大众。菩萨摩诃萨无量无边不可称计。说月藏讫

尔时南方有大香云雨大香雨。大华云雨大华雨。无量璎珞云雨种种璎珞雨。大衣云雨大衣雨。于佉罗堤耶山牟尼仙所住处。是诸大雨皆悉遍满。大阴云雨而雨香华衣服璎珞。亦说种种无量法音。如是次第乃至广说三归声。持戒声。忍辱声。精进声。禅定声。具足智慧声。降伏四魔声。名称普闻遍满三界声。念定总持声。空无相无愿声。离欲声。色如聚沫声。受如水泡声。想如热炎声。行如芭蕉声。识如幻声。无常苦空无我之声。惭愧声。念处声。慈悲喜舍声。证诸法声。涅槃声。无窟宅声。三乘声。转法轮声。成熟众生声。度三恶道声。六波罗蜜声。善巧方便乃至具足十地声。游戏神通声。游戏无上大乘声。阿鞞跋致声。无生法忍声。入佛海声。诸来大众悉见种种雨。亦闻无量诸法音声。随意衣服严饰之声。又复皆悉见其两手有如意珠雨如意宝。其如意宝各出光明。如是光中皆见十方恒沙世界一切诸佛。是诸佛所各有菩萨而自围绕。其光明中尽见十方诸佛世界。若有病者蒙光触身众病除愈。一切系缚及应死者。光触身故皆得解脱。若身行恶口行恶意行恶。光触身时悉除三恶。若诸饥渴众生蒙光触身亦皆饱满种种谪罚身受苦切。乏少衣服严饰璎珞种种之物。蒙光触身随所念忆悉得满足。若有杀生偷盗邪淫妄言绮语两舌恶口骂詈。蒙光触身如是等恶皆悉得除。若诸众生有求不得苦。蒙光触身皆悉受乐。光明清净悉无翳障风云尘雾及诸臭秽。苦恼辛酸不善音声。乃至怖畏恶触皆得除灭。远离诸恶一切邪伪谄曲亦皆无余。一切恶欲悉得弃舍。诸妙胜乐一切皆集

尔时众会皆悉坚固。难动如地。心无去来不可毁坏。如是大众得未曾有。以何因缘我等身体今皆大重不能自胜。当于尔时有一帝释名曰净有。于大众中不远而坐。于是净有。即从座而起整衣服。右膝着地合掌向佛。以偈问曰

  实语实见者　　实住牟尼尊
  久住于法行　　惟愿演说法
  佛为实因缘　　能灭众生苦
  何故于此处　　而雨种种雨
  大众皆喜悦　　心生信安乐
  开示诸疑惑　　令住于大乘
  身难动如地　　及一切人天
  皆见如是相　　大众悉有疑
  两手各皆出　　摩尼宝光明
  一切诸衣鬘　　杂饰严身具
  十方之福田　　离一切过恶
  众苦得休息　　皆因于救世
  一切诸天人　　无能说因缘
  是谁神通力　　而来至此处
  为佛诸菩萨　　梵魔帝释等
  唯愿救世说　　神通之因缘

尔时世尊。告净有帝释言。如是如是。汝今谛听。吾当说之。是地藏菩萨摩诃萨。于无量阿僧祇劫。为五浊恶世成熟众生故而来至此与八十频婆那由他百千亿等大菩萨俱。悉为礼拜供养恭敬故。欲见大众集会故。欲听大众起随喜故

是地藏菩萨作沙门像。现神通力之所变化。有如是等大庄严事。亦是如来不可思议无量功德。亦名声闻辟支佛正法伏藏。亦名解脱智宝之大宝渚。亦名菩萨救世之法。亦名涅槃导师商主。犹若如意宝珠所求满足。亦如宝渚一切商人所趣。亦如大地能生善根。亦是涅槃大法神器。亦是功德清净之瓶。亦是日月照明行处。亦是黑闇幽冥大炬。如月清凉除烦恼热。如无足者得如意乘。如乱心者得甘露味。如羸老者遇其机杖。是大福田之根本也。舍心无碍如彼浚流。救苦不难如赴亲友。除结使炎之大云盖。如净水珠能除秽浊。若趣险道回示正路。是疲极者安隐床座。是四使流生死桥梁。亦度彼岸无上大船。是三善根胜妙果报。是诸施者最上大乘。持戒不动如须弥山。精进难坏犹如金刚。忍辱坚固亦如大地。总持正法心无二相。禅定庄严如妙华鬘。智慧深广犹如大海。心无所依犹如虚空。方便无染如众华聚。处于外道如师子王。远离烦恼如犀一角。灭诸结使如洗尘垢。能除臭秽如疾飘风。将护有疾如彼良医。消除众病如妙药王。断诸烦恼结如持利剑。为怖畏者作大亲友。防诸怨敌如坚城堑。能除其渴如清净水。济诸饥乏犹如甘果。亦是裸者最胜衣服。与盛热者为密云盖。具足如是善根果报。清净第一坚固不坏。微妙色处能生爱乐。于大会处而生惭愧。除诸结使禅定行处。乘四正勤四摄駃流。忍辱大地亦如须弥。总持深广如彼大海。神足无碍自在虚空。降伏诸魔一切结习。修行正道无量禅定。亦为一切种智之渚。能转无作清净法轮

地藏菩萨摩诃萨。为欲来故先现此瑞。亦为供养恭敬我故来至于此。佛复赞叹地藏菩萨言。汝从南方来。八十频婆百千那由他菩萨以神通力俱来至此。悉作声闻像在如来前。顶礼佛足右绕三匝。即为合掌而说偈言

  两足最胜大导师　　恒修于慈发善心
  能生忍辱如大地　　解脱众生除嗔恚
  具足最大诸相好　　而能严饰一切界
  能满一切诸福田　　常修实语及大慈
  能悉断除诸爱网　　皆能如实善安住
  舍余清净诸佛国　　其中众生具善根
  本愿欲度浊恶世　　成熟一切诸众生
  能生坚固勤精进　　超过无量诸苦行
  常修难行恐怖处　　超过无量诸苦行
  布施持戒忍精进　　修习禅定与智慧
  无数诸佛菩萨等　　声闻大众皆供养
  充给饥渴病汤药　　救度一切诸系缚
  我从本来舍身命　　为利众生无贪惜
  常为法故而舍身　　皮骨血肉施众生
  已所得乐皆悉舍　　有大慈悲为一切
  于诸众生烦恼网　　修行寂灭悉超度
  关闭一切六情根　　常能远离于诸欲
  修苦无常空无我　　亦善观察于世谛
  诸苦所因爱欲本　　悉能干竭诸烦恼
  以是义故摄六根　　能善断除一切爱
  能修无量大悲门　　普给一切诸群生
  我要不舍本誓愿　　而亦不住胜菩提
  一切众生如如相　　亦见群盲受苦切
  如是思惟为众生　　便能勤修大精进
  发起精进施戒忍　　修诸禅定及智慧
  犹如其母唯一子　　而以慈心育养之
  汝于众生亦如是　　常能赈给于一切
  是故汝速得菩提　　度脱一切无量众
  汝本修习菩提时　　誓愿不舍一众生
  无不使住施戒忍　　精进禅定修智慧
  常能于彼末世中　　求于无上胜菩提
  是故救世于末劫　　速得无上最胜道
  调伏恶魔夜叉等　　诸恶龙神及与人
  犹如金刚断诸结　　悉能安住诸圣道
  为无量众而授记　　当成菩提无上道
  功德最胜明智者　　是真福田之大将
  于无量界为救世　　普覆一切诸群生
  于十方界作福田　　名声远闻遍一切
  是故一切诸菩萨　　皆悉能舍于己事
  是汝神足而来集　　俱诣世尊大牟尼
  愿令如来时演说　　若得闻者皆欢喜
  既闻法已勤精进　　常得修学菩提道
  皆由于汝大将力　　当得疾近于菩提
  未曾闻见今大集　　是故汝等俱来会
  有十三亿诸夜叉　　甚为残害食血肉
  疾舍诸恶到于此　　安住最胜无上道
  有得忍辱陀罗尼　　有得最妙诸禅定
  有已获证诸漏尽　　无著罗汉人中尊
  有能善修四无量　　有能住于四摄法
  有得最胜四辩才　　复有得修诸法忍
  有得三昧首楞严　　有得虚空智慧眼
  有得无生诸法忍　　皆因世尊所说法
  悉制一切诸异学　　九十六种外道等
  摧伏一切魔怨已　　皆是救世大将力
  关闭地狱鬼畜生　　利益一切天人众
  是故真实诸众生　　而皆来集佛神力
  饥馑疾疫刀兵劫　　悉于今日而消灭
  若有盲冥失正道　　此诸众生令解脱
  无量烦恼狂乱者　　皆悉安置寂灭道
  合众悉能舍己业　　为礼如来故至此
  无量世界亿佛土　　皆是救世之所住
  名闻十方称无量　　我等闻已故至此
  一切种智功德海　　得闻如是真实相
  度脱一切诸众生　　我今欢喜故敬礼
  令我增长无量德　　是故稽首今顶礼
  而于百千万亿劫　　常勤修习种种施
  我今当学发弘誓　　我今来此佛神足
  我当修学处浊世　　能到第一胜菩提

尔时地藏菩萨摩诃萨。以若干种天华香华璎珞而散佛上。所散之华变成宝盖。是时地藏菩萨。在佛前坐听受经法。诸来会众。见地藏菩萨生希有想。以种种香华璎珞缯盖幢幡及诸衣服。以散地藏菩萨上作如是言。我等快得善利。佛神力故得见如是诸大丈夫礼敬问讯

尔时复有渴仰菩萨摩诃萨。从座而起整其衣服。右膝着地合掌向佛。白佛言。世尊。此善男子。从何佛国而来至此。修何善根能作如是种种赞叹说佛功德。我从昔来未曾闻见

尔时世尊告渴仰菩萨。止止大士。不须是问。一切大众及诸天人。除佛如来无有能知此善男子功德数量。如来今日必当显说。但诸天人愚闇自蔽。是族姓子。成就不可思议功德首楞严三昧。入如来行处得无量法忍。于诸佛法而得自在。入深法忍已度一切智海。此善男子。游戏以师子光三昧。登一切智山须弥之顶。摧伏异学成熟众生。在所佛国悉皆止住

随诸佛国入智三昧。以是三昧力故。令一切国土众生见诸菩萨

随诸佛国入智乐三昧。于彼国土所有供养随供养佛

随诸佛国入清净乐三昧。入是三昧悉见诸欲一切过患。而于心相清净无染

随诸佛土入惭愧三昧。而于彼国令诸众生悉得惭愧。远离诸恶无有愚闇。随诸佛国入水澋三昧。亦能令彼一切众生悉入是定。令诸众生得宿命智。能知先世死此生彼。善于禅定

随诸国土入无忧明三昧。亦能令彼一切众生悉离忧愁。于诸佛国入神通三昧。亦能令彼一切众生。皆入神通三昧

随佛国土入智明三昧。亦能令彼一切众生悉离愚痴。便见十方一切佛国。随诸佛国入佛炬三昧。亦能令彼一切众生皆归三昧

随诸佛国入金刚光三昧。入是三昧已。亦能令彼一切诸佛国土。铁围大铁围。乃至须弥山王。一切溪涧沟壑。皆悉不现地平如掌。能令一切诸恶毒蛇。及以蛊道皆悉消灭

随诸佛国入智力降伏三昧。亦能令彼魔及魔眷属。皆悉惊怖归依三宝。随诸佛国入电光三昧。亦能令彼一切众生。离后世怖得法安慰

随诸佛国入味乐三昧。亦能令彼一切众生。随其所念饮食悉得充足

随诸佛国入精气悦乐三昧。亦能令彼一切众生。得坚牢身离诸病苦

随诸佛国入乐具三昧。亦能令彼一切众生。悉得床敷卧具衣服璎珞无所乏少。病瘦医药身皆端正

随诸佛国入无诤智三昧。亦能令彼一切众生。身皆长壮端严殊大。远离一切怨憎系缚皆得受乐。皆好布施持戒忍辱精进禅定心无散乱。具足智慧深入法门

随诸佛国入无忧怖三昧。而能于彼一切众生。皆得欢乐心离忧怖

随诸佛国入光乐三昧。于彼佛国一切众生。得无碍智离于事务

随诸佛国入善住金刚三昧。亦能令彼一切众生。得诸根具足悉不缺坏。随诸佛国入观幢三昧。亦能令彼一切众生。皆悉厌离弃舍诸恶。护持十善上生天道。随诸佛国深入大慈音声三昧。亦能令彼一切众生。各相哀愍皆起慈心。得无畏心。得无恼心等心。更相悲念

随诸佛国入集福处三昧。亦能令彼一切众生。得离斗诤疾病饥馑非时风雨。饮食苦涩辛酸等味。皆悉消灭。是地藏菩萨。所至佛土入海电三昧。随所至国。一切皆悉变成宝地离诸秽恶。衣树璎珞树华果树严饰佛界。于晨朝时。入恒河沙世界三昧。为成熟众生故。从禅定起。令无量无边诸佛世界于五浊恶世成就众生悉空无余。有佛世界。刀兵起时。此族姓子。以晨朝时入三昧力故。刀兵钾仗皆悉消灭

随诸佛土有疾疫劫起害诸众生。亦令病疫自然消除

随诸佛土若有饥馑劫起。令彼饥馑亦尽消灭悉得充满

此族姓子。以是三昧威神力故。能令成熟一切众生。地藏菩萨。以不思议功德成熟众生。于过去无量恒河沙诸佛所。久发大悲坚固誓愿。皆悉成熟一切众生。庄严势力犹如雷震。于一食顷而能成熟无量亿等那由他人具足善根

若有众生为无量亿种种诸苦恼。饥渴切逼。有称地藏菩萨名者。悉能令彼饮食充足灭诸苦恼。置涅槃道皆得快乐

若有众生乏少衣服宝冠璎珞。病瘦医药种种众具。若称地藏菩萨名者。随其所欲皆令充足。安住涅槃道得第一乐

若有众生离喜乐心。而与不喜乐集会者。若称地藏菩萨名者。一切乐具尽皆归之。所不喜者亦悉远离。是意所乐者。能令皆得安住涅槃得第一乐

若有众生身心受苦众病所持。能称地藏菩萨名号。身心苦恼皆悉除愈。安置涅槃得第一乐

若诸众生恶心相向。能称地藏菩萨名号一心归依者。令彼众生柔和忍辱更相惭愧。慈心忏悔安住涅槃

若诸众生系闭牢狱。枷锁其身具受众苦。能称地藏菩萨名号一心归依者。令诸众生皆得解脱自在无碍。乃至应被系缚囚执鞭杖。能称地藏菩萨名号一心归依者。亦复如是皆悉解脱。安住涅槃得第一乐

若有众生诸根不具疲极懈怠。颠狂放逸忘失本心。贪欲嗔恚愚痴嫉妒。悭吝邪痴。憍慢睡眠等恶皆悉炽盛。能称地藏菩萨名号一心归依者。如是众苦皆令解脱安住涅槃得第一乐

若有众生为大水漂流猛火所焚。或坠高岩投身山险。或坠树木及诸屋舍而身颠覆。有如是等无量怖畏。称地藏菩萨名号一心归依者。有如是等怖畏之事悉令解脱安住涅槃得第一乐

若有众生为诸毒蛇种种禽兽之所螫者。或被种种毒药所中。能称地藏菩萨名号一心归依者。是诸怖畏悉得解脱

若有众生为阿波魔罗掩蔽伤害。若一日二日三日乃至四日。能令心狂心乱心战心调心颠倒乃至失心。能称地藏菩萨名号一心归依者。如是族姓男女。于诸怖畏悉皆解脱。安住涅槃得第一乐

若有众生为诸罗刹恶鬼所捉。鸠槃茶所捉。富单那所捉。迦吒富单那。师子虎狼。恶毒蛊道。或为军阵战斗怨贼围绕。临敌惧死贪生求乐。能称地藏菩萨名号一心归依者。如是族姓子男女。速离众苦悉除患难。安住涅槃得第一乐

若有众生为多闻为信为戒为施为禅定为神通为解脱。为色声香味触为诸功德。为工巧华果树木敷具。为增益财利。为诸医药房舍屋宅。为使水雨顺时。为得清凉。为求男女妻子方便修福。为除寒热令得正念。求如是等种种因缘。能称地藏菩萨名号一心归依者。此善男子。威德力故。悉能称彼无量众生功德所愿

譬如下种于彼荒田。能称地藏菩萨名号一心归依者。皆悉变成微妙胜果。何以故。此善男子。以于过去无量阿僧祇不可数劫。如来之前发坚誓愿犹如大地。令一切众生皆得受用是善男子。功德力故。能令善根牙茎枝叶乃至华果。皆悉润泽增长成熟。若有众生造作诸恶十不善业。能称地藏菩萨名号一心归依者。一切结使烦恼消灭。远离十恶成就十善。于诸众生起慈悲心兴利益心。是善男子。以精进力于一食顷。无量阿僧祇诸佛世界于一一佛国以一食顷。度脱无量恒河沙阿僧祇众生。以是相貌令脱诸恶。皆悉成就不可思议功德。此善男子。以是坚固誓力。能令成熟一切众生。如是族姓子。或作梵天身成就众生。或作自在天。大自在天。摩醯首罗天。或作欲界他化自在天．化乐天．兜率陀天．炎摩天．帝释身．四天王身。或作菩萨身。或作辟支佛身。或作声闻身。或作转轮圣王身。或作婆罗门．刹利．毗舍．首陀等身。或作男身女身。或作童男童女身。或作乾闼婆．紧那罗．摩睺罗伽．天．龙．夜叉身。或作罗刹身。或作鸠槃茶身。或作毗舍阇身。或作富单那身。或作师子身。或作虎狼身。或作象身．马身。或作水牛身。或作种种鸟身。或作阎罗王身。或作地狱卒身。或作地狱身。为诸众生种种说法。随诸众生显示三乘。皆悉令住不退转地。此善男子。成就如是不思议功德伏藏。以解脱宝而自庄严。亦是菩萨诸法之母。向大涅槃无上商主。善男子。弥勒．文殊．观世音．普贤等而为上首如是等恒河沙诸大菩萨。若人于百劫中。礼敬供养欲求所愿。不如于一食顷礼拜供养地藏菩萨。功德甚多所愿速得皆悉满足。何以故此地藏菩萨。于一切众生能大饶益为如意宝故。此族姓子。若欲成熟众生故。能发坚固大悲伏藏。令满一切众生心愿。是故善男子善女人。应当供养地藏菩萨

时会大众十方来者。菩萨摩诃萨及诸声闻。一切天人．夜叉．乾闼婆等。从坐而起随力供养。或以金银等屑散彼地藏菩萨上。或以种种宝华衣服．摩尼宝珠．及华鬘．珠璎．金缕幡盖。以散地藏菩萨上。复以无量音乐种种赞颂。供养地藏菩萨。

尔时地藏菩萨摩诃萨。复以此供施修伽陀即说偈言

  天人龙神所供养　　十方菩萨皆来集
  闻有救世大功德　　愿佛受我最胜供

尔时地藏菩萨摩诃萨。说是偈已顶礼佛足。于是世尊。复说偈言

  欲起坚固净智者　　能灭众生诸烦恼
  令众得乐如宝手　　能断结网如金刚
  汝起大悲诸精进　　以是供养最胜尊
  其心如海救一切　　度诸众生苦彼岸

尔时地藏菩萨摩诃萨。作礼而起。白佛言。世尊。我当济度此四天下。增长比丘比丘尼。优婆塞优婆夷。增长护念。增长寿令身无疾病。增长色力。增长名称。增长资业。增长亲友。增长眷属。增长信戒。增长多闻。增长于施。增长忍辱。增长方便。增长觉意及诸圣谛。增长入于大乘一切正道。增长照明真实法相。增长成熟一切众生。增长发大慈悲喜舍。增长无量一切净法。增长妙称名闻三界。增长法雨润三有流。增长大地一切物味。增长众生所有善业。增长法气无数福行。增长智慧皆悉照明。增长六波罗蜜所行之道。增长五眼通达无碍。增长灌顶。增长涅槃。增长威德照明一切未曾有法。众德究竟记莂咒术陀罗尼章句。我于过去恒河沙佛所。皆悉受持如是等咒。增长白净具足之法。增长种子根茎华果一切药谷。增长云雨地水火风。增长福乐。增长财物。增长无量最胜果报。增长基业。此咒利益能除一切苦恼系缚。即说咒曰

閦浮(一)閦閦浮(二)阿含閦浮(三)婆吒迦罗閦浮(四)庵罗閦浮(五)毗罗閦浮(六)婆阇罗閦浮(七)阿卢伽閦浮(八)达摩閦浮(九)婆吒摩閦浮(十)婆帝耶尼梨呵罗閦浮(十一)鞞婆卢伽叉摩閦浮(十二)忧婆舍摩閦浮(十三)那耶那閦浮(十四)阇那娑牟致啰那閦浮閦浮閦浮(十五)毗尼梨夜那閦浮(十六)奢多婆閦浮(十七)娑遮修踬(十八)摩醯梨(十九)咃弥(二十)[賒-示+未]弥(二十一)遮迦啰斯(二十二)遮加摩私梨(二十三)差梨(二十四)奚隶(二十五)迦啰娑啰娑啼(二十六)呵梨波啰鞞(二十七)波遮啰婆陀祢(二十八)啰遮陀祢(二十九)婆啰遮遮遮醯梨(三十)摩梨(三十一)伊迦他他仚(三十二)他丘楼(三十三)闼梨(　三十四)舍梨(三十五)弥梨(三十六)摩叉(三十七)多叉(三十八)鸠梨(三十九)弥梨(四十)鸯久之多毗(四十一)頞梨(四十二)只梨(四十三)波罗只梨(四十四)久吒苦婆梨(四十五)真只真(四十六)真求梨(四十七)休楼休楼休楼(四十八)鸠流晃弥梨(四十九　)弥梨叉(五十)婆茶婆茶(五十一)罗窥窥梨(五十二)嚧[口*留]嚧楼留(五十三)婆婆阇毗(五十四)输檀祢(五十五)私婆呵(五十六)摩诃复陀楼迦沙毗输祢私婆呵(五十七)迦楼沙罗婆毗输檀祢私婆呵(五十八)迦楼沙乌阇毗输檀祢私婆呵(五十九)萨婆阿奢波利富啰檀祢私婆呵(六十)萨婆娑斯耶三波陀祢私婆呵(六十一)萨婆多咃迦多阿[券-刀+衣]底私婆呵(六十二)萨婆菩提萨埵阿[券-刀+衣]底阿[少/(兔-、)]无地底私婆呵(六十三)

世尊今所说咒。是未曾有威德照明。是众德本。记莂章句陀罗尼神咒。我于过去恒河沙诸佛所受持是咒。增长一切白净之法。增长善种根茎枝叶华果药谷。增长雨泽地水火风。增长喜乐。增长财物。增长胜妙。增长产业。此咒威力。善能系缚。亦名善解。世尊说此陀罗尼咒。与四天下声闻弟子。比丘．比丘尼．优婆塞．优婆夷．皆悉护念。增长财物一切产业。增长佛法能令流布广大无量三界受乐

大方广十轮经卷第一大方广十轮经卷第二

        失译人名今附北凉录

    诸天女问四大品第二

尔时地藏菩萨。广说如是大记莂经时。佉罗堤耶山六种震动。一切音乐不鼓自鸣。雨众宝华。一切大众皆悉战栗生希有想

尔时功德天女。功德乐天女。妙音声天女。坚固地神天。未曾有天。大光明天。如是等天以为上首。与一万八千及余大自在鬼神。从坐而起。合掌向佛白佛言。希有世尊。希有善逝。我等虽于四大得自在力。而不能知四大根本初中后相起灭因缘。不识怨憎。不知是善不善乃至亲友。若善男子。得是甚深般若波罗蜜能善分别如是四大初中后相知诸生灭。

佛言。如是如是。天女。此善男子。得甚深般若波罗蜜。善知四大初中后者。譬如善神有如意珠。能雨种种无量宝雨有大利益。如是善女天。此善男子复能雨于种种觉意无量诸宝。皆悉遍施一切众生

譬如宝渚能出无量若干种宝。是善男子满足种种觉意等宝亦复如是。譬如波利质多罗树。华初开时光色妙好。如是善男子以无量佛法而自庄严亦复如是。如师子王于一切众生中无能惊者。如是善男子于诸众中亦复如是得无所畏

譬如日出灭一切闇。如是善男子能除众生一切谄曲结使之闇亦复如是。譬如明月照四天下。能令迷者还得正道。如是善男子能令未入三乘迷于生死旷野道者。皆使回向得其正道安住三乘

譬如大地百谷种子及诸药木。一切众生悉依增长。如是善男子。一切助道诸余善法皆得增长

譬如须弥山王能善坚固。安住一切令无增减。如是善男子。安住佛法而不舍于一切众生。善根坚固无有缺减不令漏失

譬如虚空一切众生行住出入依止而住。如是善男子。一切众生亦皆依止。增长一切无量功德

尔时一切大众。闻是地藏菩萨名号。生希有心得未曾有。恭敬尊重皆大欢喜。皆悉谛观地藏菩萨目不暂舍。尔时世尊欲重宣此义。而说偈言

  头陀功德尽和合　　诸声闻众无异相
  地藏菩萨真大士　　为礼世尊而来此
  度三恶趣诸苦恼　　为礼世尊而来此
  诸天普雨无量种　　皆为供养世尊故
  而谛观察于四方　　离垢照明天帝释
  合掌一心向于佛　　皆欲劝请于世尊
  我今欲见此大众　　摩尼宝珠出光明
  一切福田最广大　　悉见光明而普照
  世尊神通光明照　　今为谁故而显现
  诸来大众最勇猛　　地藏至此真佛子
  伏藏七宝满足施　　佛藏珍宝是无畏
  种子即是大菩萨　　一切众生之商主
  此主能生佛法宝　　大功德海而精进
  大悲体性甚聪哲　　能救一切众生苦
  亦能救度诸怖畏　　譬如明月示正道
  能生善根如大地　　亦如金刚摧诸结
  为大施主解脱宝　　漂诸烦恼如大水
  如盖普覆烦恼热　　亦如良医除众病
  于一食顷赞地藏　　过诸菩萨百亿劫
  如诸智者无量德　　是故地藏大名称
  烦恼系缚诸众生　　皆令远离得解脱
  得首楞严大三昧　　能度诸禅至彼岸
  十二因缘悉清净　　其智广大如虚空
  无量佛国诸众生　　皆悉能灭黑闇聚
  而于一切四禅中　　遍观佛国修诸行
  能令众生入三昧　　皆悉得离烦恼热
  众生过去恶业故　　常处刀兵疾疫劫
  于此世间受苦恼　　彼善男子能救脱
  一切六道诸众生　　常为苦恼之所逼
  当悉归命于地藏　　当令苦恼悉消灭
  众生轮转没诸苦　　互相残贼起斗诤
  若能归命地藏者　　令彼斗诤皆悉忍
  趣于三恶甚可畏　　所求不得常苦恼
  亦当归命于地藏　　一切皆得除怖畏
  若修持戒及念定　　欲得多闻智慧者
  皆当归命于地藏　　随心所愿悉满足
  欲得如是诸功德　　及以工巧善种子
  皆当归命于地藏　　令彼所愿悉满足
  一切药谷诸福田　　乃至欲求男女等
  皆当归命于地藏　　令彼所愿悉满足
  若欲修行诸功德　　一切所有依大地
  药谷滋茂而润泽　　亦因地藏得增长
  结业烦恼所覆障　　造作十恶诸不善
  皆当归命于地藏　　悉除结使重恶罪
  能以正法示众生　　作种种形随应说
  具修布施诸功德　　欲救众生起大悲
  假使满足于百劫　　不可分别其功德
  是名功德之大藏　　一切皆当供养之

    佛说大方广十论经发问本业断结品第三

尔时地藏菩萨摩诃萨。从座而起整其衣服。长跪叉手右膝着地。合掌向佛白言。世尊。如我今者欲发少问。唯愿听许时为解说。佛言。汝是真善丈夫。为欲显示一切众生无碍智慧。亦令他人作大丈夫。若有所问随汝意答。勿生疑难。如来今日当为解说令汝欢喜。尔时地藏菩萨。以偈问曰

  曾于十三劫　　修行佛福田
  饥馑与疾疫　　悉为众生灭
  为亿诸佛等　　造不思议供
  今见大会集　　清净众俱来
  聪哲勤精进　　皆来至此会
  一时而云集　　无有诸浊恶
  浊世多讥嫌　　作恶损净行
  云何不善识　　扰乱毁威仪
  皆与恶逆俱　　诽谤于正法
  毁訾诸贤圣　　妄着于断常
  造作十恶业　　不畏后世苦
  破坏三乘法　　谄曲趣恶道
  无明蔽其目　　贪嫉多奸伪
  云何转法轮　　解脱诸谄曲
  烦恼金刚俱　　云何得断离
  云何为总持　　忍辱能柔和
  此集未曾有　　令我值世将
  诸处未曾见　　如是之大众
  具足头陀行　　久修菩提道
  云何于此处　　成佛转法轮

尔时佛告地藏菩萨。善哉善哉。善男子。汝于过去恒河沙佛所已问此义。如是之法汝亦曾闻。具智慧行功德满足。以方便力渡于彼岸。汝为成就诸余众生安乐利益故。亦欲令一切菩萨摩诃萨众满足一切方便伏藏。为具六波罗蜜。欲满一切智海。为回诸帝王使不堕恶道。欲令十方世界三宝炽盛诸法久住。以是义故问于如来。善男子汝今谛听谛听。当为汝说。地藏菩萨白佛言。唯然世尊。愿乐欲闻。佛言。此是如来过去本誓愿力成就十轮。如此国土有五浊恶世。一切净法皆悉损减。离圣七财远诸智人。为断常网之所覆障。载恶道车不畏后世。常处无明黑闇之中。具行十恶能造五逆。诽谤正法毁訾贤圣。远离一切诸善功德成就恶法。能于如是多恶世界。悉令安隐得无所畏成就先圣最胜之法能转法轮。制诸怨敌皆悉际伏。摧灭烦恼犹如金刚。令诸众生安住三乘阿鞞跋致地

善男子。譬如有人远离功德。世界国土或自境内。而有军起。或为邻国外来强兵之所践害。忧愁恼乱种种斗诤。及诸谄伪欺诳妄语有种种病。愚闇所蔽目视不了。为童子鬼魍魅所持。阿钵摩罗之所惑着。身体干枯狂乱失心。诸根丑陋手足不具。常乏财产无有福禄。不为一切之所喜乐。多归异道起诸邪见。心意颠倒趣三恶道。如是国土多诸耆旧。以为辅相臣佐吏民。爵禄有序而与同好不相侵害。如是建国。则有无量种种明制调伏人民。施戒慈忍威仪具足。难行苦行一切备满。以如是福德因缘。众生诸根皆悉具足。身体长大威德炽盛相好端严。常为一切尊重恭敬。皆共亲友仁性宽慈聪敏多智。若有尊重及诸王子备此德者。以诸香汤。调和冷暖以用洗浴。着鲜净衣其光如宝。顶上复有如是宝珠真金华鬘。手系素缯种种华鬘金银真珠以为珰环。杂宝珠网而作臂指。种种环玔如是等宝庄严其身。先所奉事天及诸仙一切帝释。悉皆听许敷置高座。如前父王登尊位时。升如是座绍王位已。一切龙王。天帝阿修罗帝。鸠槃茶帝。是前父王所有钟鼓。今受位时亦击此鼓。如是音声遍满城邑。一切刹利．婆罗门．毗舍．首陀澡浴身体着鲜净衣。种种诸宝缯盖．幢幡．金．银．摩尼真珠．珊瑚．琉璃．珂贝．一切珍宝。以新王立。见有如是吉祥等相故种种献奉。尔时新王绍灌顶位。先王所置宿旧先臣。随其所能各为职司。若己国内自有军兴。及以邻国起诸兵众。随有怨敌悉皆殄灭。守护己国无诸毁损善增眷属更相亲友

善男子若能如是名为初轮灌顶王位。于其国土得安乐住初伏怨敌。寿命长远守护身命。如是如是。善男子。若人处于五浊诸恶世界。远难于佛。是故此中一切众生。心多嗔恚更相侵逼。一切人民皆悉愁恼。愚闇痴冥起于断常。种种斗讼贪嫉谄伪。作诸欺诳悉具十恶。取着众生恼乱人民。种种烦恼及诸过患。是故远离甚深法眼。为嗔恚病之所扰害。心常远离弃舍真实一切法味。意想散乱讥诃善法乐所爱味。常为烦恼及诸邪见惑网所覆。归依六师伤败圣道趣向三恶。有诸菩萨摩诃萨。已曾亲近供养过去无量诸佛。能度一切智慧大海。安住诸佛所行之道。皆悉集会到于我所。汝以修集种种布施。善能调伏成就苦行远离诸恶。久修诸佛难行苦行。常念智慧方便福德大慈大悲庄严璎珞广大伏藏。一切禅定总持忍辱。诸地大海皆已具足。不生谄诳幻伪之心。身相柔和满足忍辱。而常善顺以自庄严。皆悉近于一切智海。其色盛妙光明具足。能为一切声闻辟支佛作大导师。亦与一切生死怖畏众生为作安慰。即是拘楼孙佛。拘那含牟尼佛。迦叶佛。如是等如来之子。于贤劫中最为上首。以禅定智水而自洗浴。着惭愧衣。是最胜大仙所行之处。亦是解脱功德华鬘。亦名一切种智无生真实而自庄严。是三善行能为三界作密云盖已。于过去一切佛土善得安住。处于金刚三昧之座。亦于过去声闻辟支佛所。安置尊座四念处座。亦是先佛所安置座。于一切智渚住于菩提。能转法轮绍三宝种令使不绝。击于法鼓出大音声遍满三界。以此法轮。声使诸天人．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人非人等．鸠槃茶．富单那．迦吒富单那．饿鬼．毗舍阇．皆以四圣谛寂灭之相而自庄严。三转十二行法轮。昔所未转如今转之。一切沙门婆罗门。若天若魔若梵皆不能转。为欲利益安乐一切诸天人故

善男子。是名转于初轮。若今世后世是处非处如实而知。到于安隐无畏之处。一切怨敌自然降伏。如实而知能转梵轮。处处现于五浊恶世。诸弟子等正师子吼。若作五逆罪业众生成就十恶。如是人等碎诸烦恼犹如金刚。断诸有漏令得解脱。随其所欲安置三乘住不退地

善男子。譬如有人初登王位。受灌顶已观察去来三世若干等种无量王事。而以智慧观察业因一切果报。随其性相而置爵位。以此三业故。令其国土增长安乐。邻国怨敌悉皆摧伏。何等为三。如灌顶王刹利。为护命故防备怨敌与他战斗。经营王宫及诸国土一切奉禄人民产业。是名灌顶大王成就第二轮。邻国怨敌不能侵害。守护身命长寿安乐。如是善男子。如来始成佛道得无上智。过去未来现在一切法眼。亦如三世诸佛所得法眼。故修行正法。为欲观察一切业报差别之相。具深法眼分别业因。能令善根一切炽盛长夜安隐。悉使众生成就种种无量之乐。能使一切外道怨敌自然降伏

何等为三业。坐禅诵经营理僧事。云何为禅。禅有十种。何等为十。第一知身。知身六入。知我我所。知业因为因自在受生。知种种爱无明黑闇。知所亲爱无有真实。属众因缘欲苦相续流注不绝。为灭此等令悉除断

云何为业流。观察一切三种业行。是名业流。生死无际爱因缘有。是名烦恼流。烦恼因缘故。无明和合能生名色。名色和合因缘故能生六入。六入因缘故能生触。触因缘故能生受。受因缘故能生后有。后有因缘故能生生。生因缘故能生老病死苦。是名苦流。如是三流皆从爱生。何以故。因无明业爱为水润。为欲枯涸此三流故。乐观无常名无常忍。能观无常苦空无我。信一切法愚痴无智。如幻如炎如水中月如梦。空无相无愿。寂灭无生空无诸相常观五阴空无相无愿。随顺忍乐观察出息入息。系念安般增数减数。观住观灭并观住灭。还数有二种。意与觉观俱。灭于觉观取出息入息相。减数有二。依止有出能除觉观。出息入息取其相貌。观住有二种。观出入息见其灭想心能住定。灭有二种尽除诸结深净于见。修出入息观察五阴。何以故。此出入息名色盛阴。亦名受想行识等盛阴。是名五盛阴种种不相应相

复有五种非新非故非有非聚非言。如是五种。以此五阴观三种业。以此三业观究竟尽。复观六处。有我我所。有业无明为田爱为湿润。究竟灭尽以是观察。具四念处。修集满足。四念处．四正勤．四如意足。五根．五力．七觉分．八圣道分。乃至能满十八不共法。得无生忍及一切智。具足首楞严三昧。修出入息安般三昧。满足一切正法住处。若能如是修诸禅定。则是供养过去未来一切诸佛。是名佛子。从佛口生从正法生。有能如此善修禅者。或是大士诸菩萨等。或是漏尽辟支罗汉如所修集。是名菩萨摩诃萨。则能满足十八不共法具一切智

善男子。是人不久当得阿耨多罗三藐三菩提。亦是三世如来世尊甚深法眼。满足业行观察果报。安住众生于十种禅定。如是善男子。则能转于如来所转禅定法轮。彼善男子。云何修于如来诵习。若有比丘．比丘尼．优婆塞．优婆夷。善男子。有少信心微薄善根。于世谛中善根未熟。令彼众生于初中后夜。以时诵习修禅喜悦求无上智。我于尔时安置大乘修习禅定。读诵受持种种供养。自诵教人诵。自说教人说。自供养教人供养。自住大乘亦教人住大乘。互相教化灭诸烦恼。皆为得于无上道利。亦欲灭诸众生无量等苦。亦为得入无所畏处涅槃之城。若有众生乐求辟支佛者。为说十二因缘法。乐求声闻者。为说百千四种阿含。及与无量阿毗昙等教。令诵习如说修行。善男子。是名如来修诵习轮。善男子。若有钝根众生。为欲发起善根因缘。懈怠少智忘失正念。贪着住处衣服饮食四事供养。远离一切诸善知识。如此众生。教令劝化料理僧事及与佛法和上阿阇梨故。是善男子。则为安置如来劝化营事福处。如是善男子。如实知于修习业法。善男子。是名第二佛轮具足三业成熟众生轮。到于安隐无畏之处。能师子吼转梵法轮。令诸外敌皆悉降伏。如实能知众生因缘

善男子。譬如灌顶刹利王。沙门．婆罗门．毗舍．首陀。谛善观察谁有勇健。种种伎能多闻持戒。善知分别有功德者。方便智慧能勤精进坚固不退。种种福德而自庄严。于是众中作灌顶刹利王。随其相貌金银珍宝仓库谷帛。及诸田宅奴婢仆使。皆悉给与此国。若有于众生中能持戒者。如此众生亦给短乏。若有众生不持戒者。少于精进懈怠懒惰忘失正念。无慈愍心亦无返复。不畏后世在欲淤泥。如是灌顶刹利大王。随其事相谪罚安慰。或以教令谪罚。或以系闭谪罚。或以财物谪罚。或复有夺种种产业。或有罚其鞭杖。或有截其支节。或有斩其身首。有如是等无量教授。是名灌顶刹利大王第三轮也。能令增益己之国土。降伏一切诸恶外敌。守护身命令得长寿。如是如是

善男子。若我声闻弟子。离于智慧方便福德及诸调伏。忘失正念乱心放逸归依于我。我知体性随其相貌而调伏之。若有贡高难可调伏。心不恭敬不坚持戒。为法久住而调伏之。若起心念教令心悔。又须言语而谪罚者。驱令下意终不与语。亦于僧中谪罚令其礼拜。呵诘嫌责不同僧利。或在僧前四体投地自归伏罪。或时驱出不得共住。我知众生种种体性。心所趣向。能生信解。为利彼故除其黑闇干竭驶流得涅槃乐。为欲调伏破戒众生。广说诸经地狱等苦。若有众生能起信敬净意方便随彼体相说诸善根。为具善故乃至令得到无畏城。善男子。是名第三轮也。以如是轮。随彼众生得种种解。修行诸业悉具善本。使得安隐到无畏处。如彼贤圣转佛法轮。外道怨敌自然降伏。能师子吼

善男子。譬如灌顶刹利大王。于国人民有若干种。邪归邪见邪解邪出家。或于吉相专修如此。无量苦恼伤害众生。灌顶大王以先王旧法。为彼众生令专修学断除倒见。先王旧善治国之法亦使修行。灌顶刹利大王制法。令诸众生悉同一意俱共调伏。同一悕望同所乐欲。同共归趣皆令和合。随顺先王旧国之法听受诏命。皆共随伏同奉国法。尔时灌顶刹利大王。常与国人同其饮食。而共戏乐不相疑猜。心相体信共行王法。是名灌顶大王第四轮也

以如是轮能令己国悉得增长。并制怨敌皆悉降伏。能保国土守护寿命。善男子。如来世尊。见诸众生有若干种。邪归邪见悕乐邪业。观诸众生。以是因缘。己于过去诸佛如来在大众前。数数开示佛法因果。说六波罗蜜修行正道。说佛法僧三宝圣种。数数显现一切业报。示教利喜而将导之。令诸邪见悉得解脱。及与四众亦皆解脱。具修善行柔和调顺。游戏四念处。于诸解脱知见正道。悉得快乐令法久住。使三宝种终不断绝。乃至四正勤四如意足。五根五力。七觉分八圣道分。一切禅定解脱知见。悉得自在游戏无碍。如是善男子。是名如来第四轮也

如来成就如是轮故。令诸众生一切归依。皆修善业同其知见。安隐快乐悉令住于无畏之地。高胜大仙所证之处转佛法轮。一切沙门婆罗门诸梵魔天所不能转。摧伏天魔一切外道。于四众中能师子吼

善男子。譬如灌顶大王。能令己国及他人民。若自妻色心无厌足。于他产业并诸妻色皆生贪着。守护城郭禁诸杂物。国土村邑及以王宫。乃至戍逻皆悉遮制致密坚固。善男子。是名第五灌顶大王禁制轮也

时灌顶王。如是成就轮已。能令外诸怨敌皆悉降伏。亦使己国常得增长救护身命

善男子。如来多陀阿伽度。能令魔王波旬。九十五种众邪外道。及诸无量一切众生。于己产业心无厌足。乃至欲害我故。以火坑毒饭。推山欲压。放其醉象。或拔利剑。以如是等而逐于我。或以尘秽而坌于佛。或以淫欲而谤如来。或言非人亦非丈夫。如是种种诽谤毁呰。而口恶骂于佛法僧。为诸利养众因缘故。而生嫉妒诽谤声闻。如来世尊善守六根住四梵处。教诸声闻或以四念处。以四辩才。为说声闻三解脱门。如是如来有若干种。或以世间法及出世间法。能令一切如实而知。善男子。是名如来第五轮也

如来修如是轮。以出世间智。令他众生种种归依。皆同产业共其知见。安隐快乐住无所畏。是诸高胜大仙居处转佛法轮。沙门婆罗门。诸梵魔天所不能转。悉能摧伏一切天魔及诸外道。于四众中能师子吼

大方广十轮经卷第二大方广十轮经卷第三

        失译人名今附北凉录

    灌顶喻品第四

善男子。譬如灌顶刹利大王。诸秘要法守护之事皆悉备已。然后与诸宫人婇女而自围绕。游戏五欲放逸自恣。不摄六根肆情快乐。是名灌顶刹利大王第六轮也。外诸怨敌悉皆降伏。增益己国寿命长远。族姓子。如来世尊及诸菩萨摩诃萨诸声闻众。深自防护得无所畏

尔时如来入于初禅。第二第三。乃至第四禅。入于空处识处不用处。非想非非想处。悉入诸佛行处三昧

尔时如来入三昧已。无量亿那由他天．龙．夜叉．乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人非人等。饿鬼．毗舍阇．富单那．迦吒富单那．粗弊恶心其意佷戾无有愍伤。于诸众生不起慈心言无后世。而彼见我入一切佛行处三昧故得胜欢悦。于诸三宝得最胜盛。爱乐欢喜尊重恭敬得未曾有。离一切恶心多悔过。于一切种无量无数业障烦恼障法障。于一刹那顷悉能灭尽。功德智慧皆得具足。背离生死趣向涅槃。一切皆悉护持佛法。是名如来第六轮也

如来成就如是轮故。禅定解脱三摩跋提断众生结。以是智慧灭诸烦恼。到安隐处得无所畏。高大胜仙转于梵轮。若沙门婆罗门。及诸魔梵所不能转。一切外道尘劳怨敌皆悉降伏。于四众中而师子吼

善男子。譬如灌顶刹利大王与四兵众。一切己国城邑聚落。园树田泽泉池溪谷。丘涧及诸旷野。遍观己国。于其中间所有产业。若于彼处多有疑畏敌国怨贼。刹利大王便随其处。置同心人防诸怨贼。善守己国令得安乐。是名刹利灌顶大王第七轮也。外诸怨敌皆悉降伏。增益己国寿命得长。如是族姓子。如来世尊。为诸众生开示佛眼。若欲心如实知欲心。若嗔心如实知嗔心。若痴心如实知痴心。亦知众生为诸烦恼有种种病。随其所行如实而知。如来悉于如是等处。皆以方便精进势力。令诸众生随其类根。以禅定药除灭烦恼。若有众生多贪爱者教以不净。若有众生可以四梵堂治者教修四梵堂。若有众生多愚痴者教观因缘。若有众生应修数息者教以数息。若有众生应修三解脱门者教以三解脱门。若有众生应修禅定者教以禅定。若有众生应修无色定者教以无色定。乃至应以首楞严三昧断诸众生烦恼病者。亦即教修首楞严三昧。何以故。不使众生堕于四魔。令得自在断人天道。亦复不令诸众生等。入于恶趣断三宝种。是善男子。如来能知一切至处。是名如来第七轮也

如来成就如此轮故。到安隐处得无所畏。高大胜仙能转法轮。一切沙门婆罗门。及诸魔梵所不能转。诸余外道一切怨敌皆悉降伏。于四众中而师子吼

善男子。譬如灌顶刹利大王。为诸众生念先种姓。幼小嬉戏所生之处。及诸澡浴偃卧饮乳。剪治手足一切爪甲。案摩支节。乃至戏弄灰土供奉事者。习学无量种种伎术。游行他国晨夜住处。敬事王者及诸大臣。并作太子至今登位。得为大王受诸娱乐自在无碍。尔时诸方四维上下有大音声说偈赞叹。愿使常以正法治国不恼众生。为护国土故。是名刹利灌顶大王第八轮也

成就如是轮已。是时灌顶刹利大王。能令一切外道怨敌皆悉降伏。自保寿命令得增长。如是善男子。如来世尊于大众中观宿命因缘。一生二生三生。乃至无量百千亿生忆念劫成劫坏。乃至无量亿劫一切成坏。我生彼处如是种姓。如是名字如是生处。食如是食受如是苦乐。如是长寿如是久住。如是寿命边际。于彼没已而来生此。复于此没往生于彼。能知彼相一切方所。若干种别本宿命事。是名如来第八轮也

如来成就如是轮已。到安隐处得无所畏。最胜大仙转于法轮。一切沙门婆罗门。及诸魔梵所不能转。外道怨敌皆悉降伏。于四众中能师子吼

善男子。譬如灌顶刹利大王。于其国界所有人民。悉知根原。种姓眷属皆悉勇健种种伎术。知其贫富端正丑陋。乃至死时。或以自业命终而死。或犯王法刑戮而死。或更相残害夭寿而死。或以鞭杖闭系囚缚。或以伎术战阵斗诤。或以财物。或以爱欲。或以嗔恚。或以饥渴。或以己过患。或以老死。或以中年。或以幼少。或作善业。或作恶业。一切死者皆悉察知因缘本未

如是思惟。若有众生修善因缘为欲生天。或有众生修恶因缘趣向恶道。如是思惟。修身善行。修口善行。修意善行。我常方便教修布施。皆令调伏随顺此行若命终时当生天上。常处善趣远离恶道。如是灌顶刹利大王。勤修一切身口业善。好行布施饮食衣服象马乘骑。卧具医药种种所须。乃至给使奴婢僮仆皆悉施与。并舍头目及诸手足。不惜身命。悉断杀生偷盗邪淫妄言恶口两舌绮语贪嗔邪见

如是灌顶刹利大王。有十种利益。护善名称而得财业。身相微妙多得眷属。少病少恼得贤智眷属。趣向善处。皆悉供给亲近供养。名闻十方一切皆为说偈赞诵。诸大天神悉来拥护。身坏命终得生天上。是名灌顶刹利大王第九轮也

成就如是轮已。增益国界寿命延长。如是善男子。如来世尊为诸众生。悉知他人死此生彼如实而知。若有众生成就身业不善．口业不善．意业不善．诽谤贤圣。邪见颠倒。以是邪见因缘业故。身坏命终堕于恶趣生地狱中。或生畜生及诸饿鬼。若有众生。成就身善业．口善业．意善业。不诽谤贤圣。具足正见。成就正见业因缘故。身坏命终入于善趣得生天上。生天上已或生人中尽诸结漏

如是如来。善知众生诸业因缘。如来于诸众生。悉能发于大慈大悲。常勤精进现三种神通。能令安住世间出世间信。何等为三。一者神通。二者说法。三者知他心。以此三种神通。令诸众生安置世间出世间信。知一切趣一切有为一切受生皆得解脱。善男子。是名如来第九轮也

如来成就如是轮故。到安隐处得无所畏。最胜大仙转于法轮。一切沙门婆罗门。及诸魔梵所不能转。一切外道诸余怨敌皆悉降伏。于四众中能师子吼

善男子。譬如灌顶刹利大王。于四天下。一切众生为病所恼。弃舍王位。以种种香汤而以澡浴。洗沐头发着鲜净衣。端坐思惟。为除一切众生病苦皆得解脱。如是灌顶刹利大王。以华香璎珞及众伎乐。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽皆悉供养已。各相谓言。如是灌顶刹利大王多诸功德。应为转轮圣王统四天下。我等应当建立此王治国政事

尔时一切天帝。乃至摩睺罗伽等亦如是言。当立此王主四天下。尔时刹利大王具足七宝统四天下。为转轮圣王千子具足。皆多勇健形貌端正。能降伏外敌游巡四海。案行天下一切大地。终不讁罚刀杖加害。如法教敕皆悉受用。善男子。是名转轮圣王第十大轮也

以是力故。转轮圣王王四天下及八万四千海渚。皆使修集一切善法无不建立。守护身命寿得增长

如是善男子。如来从初发心已来。于己身命乃至他身。所有烦恼若干种病。悉以禅定净水洗浴。以如实法大慈大悲溉灌其顶着惭愧衣。十方如来以禅定智力．大精进力．无量方便定意观察。欲灭一切众生烦恼种种过患。如佛世尊作如是言。最大智者福德庄严堪为法器。三解脱门。四无所畏。如来十力。十八不共法。一切智器大悲利益。救济一切诸苦众生。佛大商主。度脱无量苦恼众生与涅槃乐。加其愿力欲使满足成等正觉。无上法王

如是福德具足智慧勇猛精进。如实正观了四真谛。得阿耨多罗三藐三菩提。是名如来能尽一切诸漏根本第十法轮也

善男子。譬如转轮圣王。于四天下游戏自在。如来亦复如是。于诸四禅心得自在。四无色定修四梵堂。具四辩才正观四谛．四无所畏．十力．十八不共法。于一切智得自在力

善男子。譬如转轮圣王七宝具足。如来世尊具足七觉亦复如是。善男子。转轮圣王具足千子。如来亦有一切声闻诸大弟子。憍陈如以为初首须拔陀罗为最后也。真是我子从佛口生。从法化生断一切漏。勇猛精进修四梵堂。犹如四兵降伏魔怨

善男子。譬如转轮圣王王四天下。有八万四千海渚皆随言教。如来世尊。亦有百亿阎浮提。百亿瞿耶尼。百亿弗于逮。百亿郁单曰百亿海水。百亿须弥山王。百亿四天王。乃至百亿非想非非想天。百亿铁围大铁围山。是佛国土广大无量。一切皆随如来教化。善男子。是名如来第十轮也

如来成就如此轮故。若五浊恶世。一切佛法功德退没。离圣七财及诸智者。为欲除断覆一切患灭三恶趣。乃至后世无明黑闇一切世间。皆与十恶共相和合。造于五逆。诽谤正法。远离诸善。悉染一切不善根本。如是成就十种佛轮。到安隐处得无所畏。高胜大仙能转法轮。一切沙门婆罗门。及诸魔梵所不能转。摧伏一切外道怨敌。以金刚智能破众生一切烦恼。令使三乘得不退转。于四众中能师子吼

尔时菩萨摩诃萨。及以一切诸大声闻。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽饿鬼毗舍阇人非人等皆称善哉。雨众华雨。雨杂宝雨。雨衣服雨。雨妙香雨。一切大地皆悉震动

佛说如是十轮经时。在会大众。有八万四千亿百千那由他菩萨摩诃萨得无生法忍。复有无量菩萨摩诃萨得深禅定忍辱陀罗尼。复有无量众生未发菩提心者。今皆发心住不退转地。尔时复有无量大众有得须陀洹．斯陀含．阿那含阿罗汉者。次第修学证沙门果

    大方广十轮经相轮品第五(丹本云证相品)

尔时大梵天。名曰天藏。久殖善根住第十地。是大菩萨摩诃萨。是时众中有天藏大梵。从座而起整其衣服。右膝着地以偈问佛

  我今稽首问　　功德海无边
  愿时赐听许　　除断诸疑悔
  渴仰持功德　　法味中最上
  众生咸乐闻　　如是第一义

尔时世尊告天藏大梵。随汝所问。如来世尊。亦当随问而答。令汝欢喜得未曾有。尔时天藏大梵言。唯然世尊。以偈问曰

  智慧修禅定　　安住不放逸
  为住第一义　　而处于生死
  勤修于诵习　　能度烦恼海
  为当证不退　　为当堕恶道
  常勤而劝化　　为定趣涅槃
  为在于生死　　为堕于恶道
  智慧刹利种　　依止十种轮
  为处于生死　　为得成佛道
  心浊难调伏　　烦恼多散乱
  以何净其心　　禅诵而劝化

尔时佛告天藏大梵。善哉善哉。大梵所问纯善第一。汝已满足一切诸行。于过去恒河沙佛所修行三业。摄心禅定常勤诵经。营理僧事炽然佛法。建立三宝如大梁柱。又复能为多人无量众生问于如来如是之义。若善男子。依止威仪大记莂论。过去诸佛之所演说神通住持。是名如来成熟众生令悉厌离。为灭一切烦恼病故。为欲满足三乘道故。十方乃至恒河沙现在诸佛。亦说如是依止威仪大记莂论。为成熟一切诸众生故。令得厌离故。欲使摧灭一切结使故。为得满足三乘道果住持正法故。汝于过去诸佛所闻。我亦如是。依止威仪大记莂论。为欲成熟一切众生故。令得厌离故。灭诸结使。为得满足三乘法故。是故大梵。汝当谛听善思念之。天藏大梵言。唯然世尊。佛言。若有依止于十不善轮。则不具足欲界禅定。亦不能具足欲界善根。况能成就色无色界一切禅定。亦复不能成就三乘及余诸善

何等为十。有欲修禅众事不具。有欲破戒成就恶法。生于倒见亦着吉相。恶心难调不顺贤圣。诸根轻懆而不具足微少善根。但作两舌多喜斗乱。作粗恶语而恒骂詈。好作绮语及诸妄言。生于贪嫉。见他得利常生嫉妒。一切众生有恼害心。作大邪见说无因果。天藏大梵。满足十事虽欲修禅。不能成就欲界小善。况能成就色无色界善根及三乘善法。复次大梵。又有十事而不能得成就禅定。何等为十。乐著作伎。乐着言说。多好睡眠。种种所求。贪着美色。乐着于香。乐着诸味。乐着音声。乐着于触。乐着觉观。大梵。是名十种。而不能得成就于禅。设使成就寻即退失终不能成。而但为得檀越信施。因其利养心生恶法。若在刹利诸王众中。多诸过罪为他骂詈。及加鞭杖截其支节。或犯大罪久受诸苦。若疾命终必堕恶趣。乃至入于阿鼻地狱。譬如阿兰迦兰．郁头蓝弗．蛭数拘迦梨．提婆达多。如是等毁坏禅定。乃至阿鼻地狱受大重罪

尔时佛告阿若憍陈如。我今听汝清净比丘受于第一床敷卧具饮食肴膳。能除一切众生疾疫。何以故。若坐禅比丘阙少众具。一切心数多起散乱。但念诸恶而不能得成就禅定。乃至到于阿鼻地狱受诸罪报。若众缘备足修诸禅定。则易成就心得专一。若已得者皆令增长。一切不善觉观散心。皆悉能知不令得起。趣向涅槃到于彼岸。若有坐禅未成就者。初中后夜当勤修习远离愦闹少欲知足于一切结使起于舍心。一切贪欲嗔恚憍慢贡高两舌恶口妄语。如是等悉得远离。应受释梵四天王等百千那由他供养恭敬。况复婆罗门刹利居士毗舍首陀所有供养。尔时世尊即说偈言

  修禅灭诸结　　余业则不能
  是故禅第一　　智者应供养

尔时天藏大梵白佛言。世尊。若有比丘能修禅者。刹利大臣应加谪罚鞭杖。乃至兀其手足不耶

佛言。善男子。若诸比丘佛法出家剃除须发披着袈裟。一切天人阿修罗皆应供养。若护持戒不应谪罚闭系兀其手足乃至夺命悉无是法。何以故。除其多闻及持戒者若有破戒比丘。于我法中而出家者。成就诸恶如败脓坏。非婆罗门自言婆罗门。非梵行而言梵行。退失堕落圣道果证。为诸烦恼结使所胜结使所坏。又复破戒诸恶比丘。能示天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。无量功德珍宝伏藏。若有依我而出家者。众生应作十种胜想。得无量无边福德

何等为十。有诸众生见依我出家者。应作念佛想。以是净心欢喜因缘。不信一切诸余外道。及外道经书。若当见时即应思惟决定圣戒。以是因缘能断杀生偷盗邪淫妄语。乃至不饮酒等。入涅槃城

见有依我而出家者当起施心。以是因缘。于将来世财富无量。善去善向。殊胜供养常得充给。乃至入于无畏大涅槃城。又见依我佛法出家。柔和质直常行忍辱不生卒暴。心无狂乱喜乐正法。常好闲静阿练若处。乃至欲入涅槃无畏之城

若有众生。破戒非法作恶威仪。见如是人当共软语乃至礼足。以是因缘。此人后世生尊贵家有大势力。常为一切之所瞻视。乃至当得入涅槃城。天藏大梵。若依我法出家造作恶行。如是比丘盲无所睹。此非沙门自称沙门。非梵行自称梵行。退没堕落为诸烦恼之所败坏。如此比丘修行恶法。犹能开示一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切善法功德伏藏。为善知识。虽不少欲知足。剃除须发披着袈裟服。以是缘故。能为众生增长善根。于诸天人开示善道。是以依我出家比丘。若持戒若破戒。我悉不听转轮圣王大臣宰相。不得谪罚系闭加诸鞭杖。截其手足乃至断命。况复余轻犯小威仪破戒比丘。虽是死人是戒余力犹如牛黄。是牛虽死人故取之。亦如麝香死后有用。能大利益一切众生。恶行比丘虽犯禁戒。其戒势力犹能利益无量天人

譬如估客入于大海。断于无量众生之命挑其眼目。持阿摩那果捣蓰和合成其宝药。若有众生盲冥无目。乃至胎胞而生盲者。以此宝药而用涂之。众病得除其眼明净。如是如是。若诸比丘虽破禁戒造作恶行。于佛法中名为死人。复能令他一切众生。使得清净智慧法眼。能令见者尚得如是。况复为开示说种种法

大梵。譬如烧香香体虽坏勋他令香。破戒比丘亦复如是。自堕恶道能令众生增长善根。恶行比丘为不信所烧。身坏命终。堕三恶道。能使他人得大利益示涅槃道。以是因缘。一切白衣不应侵毁轻蔑破戒比丘。皆当守护尊重供养。不听谪罚系闭其身乃至夺命。四方众僧。若至布萨自恣之时。听使驱出不共法事。三世僧物饮食敷具皆不听用。一切羯磨说戒律处。悉皆驱出不得在众。而悉不听王及大臣加其鞭杖系闭谪罚乃至夺命。尔时世尊。而说偈言

  瞻卜华虽萎　　胜于诸余华
  破戒诸比丘　　犹胜诸外道

复次天藏大梵。有五种逆罪为最极恶。何者为五。故心杀父母阿罗汉。破坏声闻和合僧事。乃至恶心出佛身血。诸如是等名为五逆。若人于五逆中作一一逆者。不得出家受具足戒。若听出家则犯重罪应摈令出。若已有出家诸威仪者。不应加其鞭杖及诸系闭

复有四种大罪。同于四逆犯根本罪。何者为四。杀辟支佛。是名杀生犯根本罪。淫阿罗汉比丘尼。是名邪淫犯根本罪。若人舍财与佛法僧主掌此物而辄用之。是名为盗犯根本罪。若人倒见破坏比丘僧。是名破僧犯根本罪。若人于四根本罪中犯一一罪。皆悉不听佛法出家。设使出家不得听受具足戒。若受具者应驱令出。以有出家威仪法故。不应鞭杖系闭夺其生命。如是皆犯根本罪非逆罪也有是根本罪亦是逆罪。有是逆罪非根本罪。有非根本罪亦非逆罪。何者为逆罪亦是根本罪。若人出家受具足戒得见谛道。断其命根是名逆罪亦是根本罪也。如是众生。于我戒律中应驱令出。何者为根本罪非逆罪。若人在我法中出家。如是凡夫众生故害其命。若以毒药或堕其胎。是名根本罪非逆罪也。若有四方僧物饮食敷具。悉不应与同共利养

若有众生于佛法僧而生疑心。此中出家自言更有世尊。或于种种诸吉相中生疑惑心。若复有人。于诸如来所说之法而生疑惑。于声闻辟支佛乃至大乘。于中诽谤出其过恶。见他读诵而作留难乃至一偈。此非根本罪亦非逆罪。是名甚恶近于逆罪。如是众生。若不忏悔除其罪根。终不听使佛法出家。设出家受具足戒不悔过者亦驱令出。何以故。不信正法毁谤三乘。坏正法眼欲灭法灯断三宝种减损人天。而无利益堕于恶道。此二种人名谤正法毁訾贤圣。地狱劫寿增长。如是诸恶业已。是名根本大重罪也

何者是不威仪根本法。若比丘故淫犯根本罪。故杀凡夫人犯根本罪。除三宝物不与而取犯根本罪。故妄语犯根本罪。于此四根本中。若犯一罪。一切比丘所作法事悉不听入。四方僧物饮食卧具。皆悉不得共同受用。然帝王大臣一切群官。不应加其鞭杖系闭刑罚乃至夺命。是名根本罪体性相也。何以名为根本重罪。若人作如是行。身坏命终堕于恶趣。作如是行是恶道根本。是故名为根本罪也

譬如铁丸虽掷空中。终不暂住速疾投地。如是五逆等罪。犯四重禁。及二种众生。毁坏正法。诽谤贤圣。如是等十一种罪中。若人犯一一罪者。身坏命终皆堕阿鼻地狱。是故作逆业犯根本重罪者。皆悉不听度令出家。犯逆罪者如此人等。于其一身终不能尽诸烦恼结成就禅定。况能超出决定菩萨。命终之后必堕地狱受恶道苦。若有族姓男女。以深信心归依佛法。或趣声闻辟支佛或趣大乘。于我法中而得出家。受于具戒极有信心。护持根本四重等罪。常勤精进勇猛不休。日日拥护一切人非人等。终不虚受人天供养。于三乘中随所乐欲。何以故。志求解脱乃至舍命终不毁犯。何以故。如是三种众生。皆求涅槃修行其因。依止世尊。依止经律。依止声闻正位弟子。若有众生犯四重禁非佛弟子。我所显示甚深法相。一切无常苦空无我。为诸众生利益安乐。说解脱法波罗提木叉。如是经论及诸禅定盲无所见。破戒退没坠三恶道。若有族姓男女。于是波罗提木叉清净法中不犯根本者。我是彼世尊。彼是我弟子。随顺我语安住佛法。一切所作皆悉成就。安立戒身及诸善法。亦能建立能大利益安乐天人。世尊。如是之人。则具足一切声闻辟支佛乘乃至大乘皆悉善住

何以故。是根本戒守护一切正法。及诸有漏无漏等法。皆悉因此而得成立。是故名为戒根本也

譬如因地一切万物。百卉药谷皆因生长。如是善学四根本戒。一切善法皆因得生。譬如大地一切诸山。乃至铁围大铁围须弥山王皆依得住。如是善解四根本戒。声闻辟支佛乘乃至无上大乘皆依而住

譬如大地一切物味依地而住。如是善学四根本戒。禅定解脱总持。乃至阿耨多罗三藐三菩提亦因而成

譬如大地净不净物一切悉载。如是族姓男女。善学四根本戒。持戒毁戒。是法器及非法器。皆悉满足。谛自观察不讥彼短。而不自高亦不毁他。能为一切善法洲渚。犹如大地一切众生之所依止

如是族姓男女。善能修学四根本戒。一切如来所说经论。皆生爱乐欢喜受持。不起种种非法之想。一切众生皆依四摄而自存活。尔时尊者优波离。从座而起。整其衣服叉手合掌白佛言。世尊。若世尊作如是言。是法器及非法器悉不讥诃。他未来时作诸恶行。如是比丘。非沙门而作沙门。非梵行而作梵行。今当云何呵责其心驱遣令出

佛言。我悉不听俗人讥呵。复有十种非法讥呵即得大罪。何等为十。若僧不和合。于国王前而讥呵者是名非法。若僧不和合。于婆罗门众中而讥呵者亦名非法

若僧不和合。于王眷属及诸大臣而讥呵者是名非法

若僧不和合。于白衣中而讥呵者是名非法

若僧不和合。于妇女小儿等中而讥呵者是名非法

僧不和合。于僧净人前而讥呵者是名非法

僧不和合。于比丘尼众中而讥呵者是名非法

僧不和合。于本怨嫌前而讥呵者是名非法

若僧不和合。以嗔恚心而相讥呵者是名非法。有如此等十非法不应讥呵。假使举得少罪亦不应受。若复少有如佛法讥呵者亦不应受

又复十种非法讥呵不应受。何等为十。若余外道来讥呵者亦不应受。非持戒白衣而犯逆罪。诽谤正法。毁坏贤圣。若起狂心。若散乱心。为诸余天地四方僧净人。若是一切犯禁比丘所举之罪皆不应受。是名为十非法讥呵所不应受

若有比丘。造诸恶行共僧中住。清净比丘威仪具足。于非法处一切不行。成就五法。应顶礼僧足。诸恶比丘言。我今欲举汝罪。是实不虚。是时非时慈心软语。为使佛法久得安住。为欲炽然一切佛法。若听我说。我当如法举汝。彼若不听。我当顶礼持戒比丘上座等足白言。大德。此比丘犯如是事。依于五法而举彼罪。上座比丘应察是语如毗尼。如修多罗。当以灭诤法如法除灭若犯重罪应以重治。若犯中罪应以中治。若犯微细罪当以微细治教令悔过

优波离白佛言。世尊。若造恶行比丘实有过罪。而恃白衣一切势力。或恃巨富财物等力。或恃多闻。或恃辞辩。或恃弟子。如是等力。众僧当共和合持修多罗持毗尼持有戒德僧者。不取其语而用势力。有如是等应当云何。佛即答言。应诣国王大臣宰相如法治罪。优波离复白佛言。世尊。如此恶行比丘。若财物力。若多闻力。若辞辩力。能令国王大臣欢喜。或有非法朋党。为应舍置不耶

佛言。优波离。若事未现应当舍去。若事已出僧应和合速疾驱摈不得共住。优波离。譬如瞿麦妨麦稗莠。根茎枝叶与麦相似。若未莠出时不可分别。穟既出已。田隽农士并根俱弃。何以故。坏净麦故

优波离。如是破戒恶行比丘。若恃白衣及诸势力住居僧中。过未出时人不敢呵。其事现已诸天便讥。当言僧中无有禁制。若恶行比丘。众僧应速和合疾共摈出

优波离。譬如大海不宿死尸。如是我诸声闻大弟子众破戒谄曲。此等恶人不应共住亦复如是。若破戒比丘。为刹利王及诸辅相朋党非法。如此比丘。则得自恃多闻财物巨富辞辩。如是等力肆心无畏强僧中住

尔时惭愧持戒比丘。心有所疑不应共诤。不应守护共作伴党。如是持戒比丘。便语国王及诸大臣。更至他国

大方广十轮经卷第三大方广十轮经卷第四

        失译人名今附北凉录

    刹利旃陀罗现智相品第六

尔时地藏菩萨白佛言。世尊。是刹利旃陀罗。辅相旃陀罗。少于善根不肯信向。谄曲愚痴自称多知。皆生憍慢不畏后世恶业果报离善智识。乃至趣向阿鼻地狱。为财利故。与此恶行诸比丘等。作非法朋党。佛言。如是如是。善男子。于未来世。刹利旃陀罗乃至婆罗门旃陀罗。善根微少无有信心欺诈谄曲。是诸愚痴现智慧相。不随善知识语。实是愚痴现为智慧。心常疑悔不畏后世。而无禁戒作诸杀生。乃至邪见欺诳于他。于诸世间常行诽谤语。刹利旃陀罗婆罗门旃陀罗坏乱佛法。于我法中而得出家。常毁破戒作诸恶行。而刹利婆罗门。尽心供养多畜钱财。贪心染着取空言语。通致信命治生贩卖。好读外典垦土种殖。守护钱财产业舍宅。守护妻子咒说仙药。贪着衣服饮食之物。破戒恶行其声如贝实非沙门自言沙门。实非梵行自谓梵行。乃至为刹利婆罗门。恭敬供养听受。刹利旃陀罗。婆罗门旃陀罗。好喜破戒远离持戒。于我法中。若见有人持戒修善能谦下者。学与无学一切得向。如是比丘。皆悉不得恭敬供养。有所言说皆不听受。善男子。譬如有人到宝渚所。舍帝释青宝及大青宝。金银真珠皆悉舍离。大价之宝取于水精。若我法中。如是持戒有大功德。心常谦下而便舍之。取于破戒造恶行者。成就恶法不生羞耻心无惭愧。远离一切大慈大悲。反取如是诸恶福田。听受其语。供养如是造作恶人。师及弟子俱堕地狱。悉具于此十种恶轮。刹利旃陀罗。婆罗门旃陀罗。沙门旃陀罗。大臣旃陀罗。先修善根今悉消灭。乃至堕于阿鼻地狱。何等为十破戒恶行。如是比丘。乃至刹利婆罗门。忍乐恶见。诽谤阿练若比丘。愚痴谄曲非毁贤圣。诳惑世间。饮食钱财及诸利养。求名称故自苦其身。毁谤他人嫉妒斗乱。纯为利养。莫肯听受信用其语。退弃令下远离实法。皆言无有得道果者。亦无离欲能尽结者。但为利养而自显现。慎莫奉事供养是等。乃是谄曲诳惑之人。实非福田趣向道者。是时刹利栴陀罗。婆罗门栴陀罗。于阿练若比丘。不生恭敬希有之心。其心颠倒而不承事恭敬供养。不肯听受信用彼语。即是不能护持法眼绍三宝种。尔时国土天龙鬼神。而于三宝信心深重。皆同嗔恚如是刹利婆罗门等。互相语言。汝今谛观刹利栴陀罗。沙门栴陀罗。婆罗门栴陀罗。大臣栴陀罗。悉起憍慢。一切三宝断于善根近恶知识。退失善法当入恶趣。我等今日不复拥护如此国土刹利婆罗门等。一切天龙诸善鬼神既舍离已。于其国中堪任法器为福田者皆生舍心。若一切天神及堪任法器应为福田者。于彼刹利旃陀罗等生舍心已。于自国土及余邻国。皆悉兵起饥馑疾疫。更相残害不复欢乐。先所爱乐皆悉别离。忿心悭吝无有矜愍。于一切众生不起慈心。杀生乃至邪见无惭无愧。一切塔寺及僧祇物。皆悉食啖供其衣服。嗔诸左右悉生嫌隙。若与他战。令己军众自然退散。若欲死时皆结其舌口不能语趣向地狱。复次善男子。刹利旃陀罗。乃至婆罗门旃陀罗。皆悉远离诸善知识。轻慢三宝无恭敬心不畏后世于声闻乘得少信心谓己聪哲。而于辟支佛乘及大乘经法。诽谤不信不读不诵。下至一偈。生不信心是名谤法。若复有人。少信辟支佛法及大乘法。而不信于声闻之法毁呰讥呵。亦名诽谤正法。是名诽谤三世诸佛正法之藏。断八正道破于无量众生法眼。若复有人。于如来所说声闻乘．辟支佛乘．及菩萨乘。若作障碍若隐蔽覆藏。乃至一偈。而不恭敬于三宝者。以是因缘令使守护一切国土。天龙善神。以不动信即便嗔恚。是刹利诸臣乃至结舌不语而死堕阿鼻地狱。复次善男子。若持戒有功德者。在彼国住具足法器。善入舍心安住静室。而不数数至檀越舍。亦不轻呵恶行比丘使彼觉知。亦不讥嫌呵责破戒。而恶行比丘。于清净持戒者所反生讥嫌。言作奸伪种种妄语。于刹利大臣。及至国中一切人民男女大小。悉于其前生诸诽谤。而彼刹利栴陀罗等。于诸清净持戒具足修行功德有名闻者。如是比丘真我弟子。具足一切禅定解脱。善巧言辞便起毁呰而生嗔恚。种种恶口粗语逼切令受苦恼。或夺衣钵及四方僧物资业敷具。驱遣令出。或时系闭或斩截其首。善男子。谛观亲近恶行比丘者。为得几所罪。乃至当堕阿鼻地狱。若众生造作五逆等罪及四根本罪。诽谤贤圣诽谤正法。超过一切根本之罪。如是恶行诸比丘等。我亦不听刑罚鞭杖系闭乃至断命。以是因缘得大罪报。况复坚持禁戒清净行者。若有比丘。于性重罪中。若犯一罪者虽犯重罪。和上众僧和合羯磨。所受之戒犹有余势。譬如妙香虽无香质。余分芬馨不可轻蔑。破戒比丘亦复如是。无戒白衣不应轻慢。虽非法器。于贤圣毗尼中。退没堕落弃出家法。不得受用四方僧物。于众僧和合所受得戒余不犯者。其戒香气多有势力。是故不听白衣谪罚。善男子。往昔过去有国名迦尸。时王名梵摩达多。敕旃陀罗言。雪山下有六牙白象王。名郁波罗华眼。可拔其牙。若不得者汝等五人悉断其命。尔时旃陀罗。护惜身命诈作沙门。外现精进被着袈裟。如王所敕往至彼山到象王所。母象见之。张弓挽箭生怖畏心。语象王言。此是猎师。今已张弓挽箭而来。将非我等命欲尽耶。尔时象王即便见之。剃除须发被着袈裟。而说偈言

  彼恒沙诸佛　　幢相之法衣
  悉舍于诸恶　　云何害众生

尔时母象。复说偈言

  身虽被袈裟　　持弓执毒箭
  作恶旃陀罗　　无有悲愍心

尔时象王。复说偈言

  袈裟决定服　　以哀愍为本
  是必归佛者　　慈悲诸众生
  于此衣无疑　　汝当自摄心
  能被此服者　　欲度生死岸

尔时旃陀罗。即以一毒箭射其象王。是时母象见射象王已。大唤悲号。复说偈言

  如是之衣服　　应当归依佛
  威仪虽寂静　　而心怀大恶
  速疾踏彼身　　断除其命根
  灭此怨令尽　　是射汝身者

尔时象王。复说偈言

  宁速舍身命　　不应生恶心
  彼虽怀恶心　　犹似佛弟子
  智者不为己　　卒暴起嗔心
  常思为众生　　修行于菩提

尔时象王心生慈悲。即唤彼人而问之言。汝须何物。彼便答言。欲须汝牙。尔时象王即自拔牙。发大誓愿。而说偈言

  我今以白牙　　求佛故奉施
  不嗔不贪惜　　令众灭烦恼

善男子。我于往昔曾见如是畜生身中。求无上道能作如是。不惜身命为护佛法。终不于被着袈裟者而作留难。于未来世。刹利旃陀罗。辅相旃陀罗。婆罗门旃陀罗。居士旃陀罗。以谄曲心欺于世间不畏后世。若诸世间有求无上道者。入我法中而得出家生心恼害。我诸弟子应成法器及不成者。恶口骂詈鞭杖谪罚逼切其身。于过去未来现在诸佛犯诸重罪。趣阿鼻地狱。断诸善根除灭信心。一切智者之所远离譬如丈夫虽自无目能示他道。我诸弟子亦复如是。虽毁禁戒犹能利益世间众生。若未来世旃陀罗王。乃至居士旃陀罗。见有依我法中出家。若成法器不成法器而便扰恼我诸声闻一切弟子。则于三世无量诸佛作大过罪。消灭善心难复人身。何况毁呰正位声闻辟支佛。及诸大乘无量功德。善男子。譬如过去有国名般阇罗。王号胜军。人罪应死系着可畏轲蓝冢间。令使恶鬼食啖其身。时守狱人以五系缚。送着可畏轲蓝冢间。是人闻已即剃须发。以纳袈裟着于颈下。尔时守狱之人受王敕已。即捉缚送至可畏轲蓝冢间。是时冢间。有罗刹。名曰恶眼。共五千罗刹俱至冢间。即见是人被五系缚在于冢间。剃除须发以纳袈裟系着于颈。尔时罗刹右绕是人。而说偈言

  今可自安慰　　我终不害汝
  剃发服袈裟　　令我忆念佛

尔时罗刹子。复说偈言

  白母甚饥渴　　当须食此人
  我得除饥渴　　身心快安乐

尔时罗刹母。说偈答子

  恒沙等诸佛　　法式之幢相
  于此起恶心　　当堕阿鼻狱

尔时罗刹子与其眷属。右绕匝已。而说偈言

  我等父母共为恶　　身口意等造不善
  我已舍恶不害汝　　被着染衣解脱相

尔时罗刹。名为牛齿。有五百眷属。俱共围绕入大冢间。见被缚人剃除须发。以纳袈裟系其颈下。右绕竟已。而说偈言

  归依众圣妙幢相　　袈裟系颈谓其人
  我为此故而恭敬　　唯愿勿怖不害汝

尔时罗刹子。复说偈言

  母今当知人肉美　　应当食肉而饮血
  益其气力得具足　　增益身体无所畏

尔时罗刹母。复为其子。而说偈言

  一切世间众乐具　　天龙夜叉及罗刹
  悉当恭敬染衣者　　当获种种上妙乐

尔时罗刹子。与其眷属。右绕恭敬。而说偈言

  悉应恭敬而归依　　剃除须发着袈裟
  我于过去无数劫　　见佛世尊救世者

尔时第三罗刹。名曰黄发。亦有五千眷属。而自围绕入大冢间。见被缚人剃除须发。系纳袈裟而着颈下。复右绕已。而说偈言

  仙人幢相我归依　　若能供养得胜利
  为袈裟故修供养　　应悉除断诸有缚

尔时黄头罗刹子。而说偈言

  我得此人应食啖　　国王所遣故来此
  当食其肉复饮血　　母语子言应供养

尔时黄头罗刹。复为其子。而说偈言

  如是相人非我食　　若起恶心大苦器

尔时罗刹子。右绕恭敬。复说偈言

  如是大仙堪福田　　是故应供离有缚

尔时刀口罗刹。复与五千罗刹来到冢间。见系缚者剃除须发。以纳袈裟系其颈下。心恭敬已而说偈言

  有余生死得涅槃　　纳袈裟者不应害
  若害此人佛所呵　　应当尊重而供养

尔时罗刹子。复说偈言

  我等常吸人精气　　食啖其肉复饮血
  是故当食此众生　　令我身体益气力

尔时罗刹母。复为其子。而说偈言

  若有生心欲加害　　剃除须发袈裟者
  必堕恶趣阿鼻狱　　受苦无量甚长远

尔时罗刹子。与其眷属。右绕被缚着袈裟者。复说偈言

  我今怖畏地狱苦　　终不恶心害汝命
  我等同心当放汝　　亦求解脱地狱苦

尔时罗刹等。即便解放彼被缚人。时被缚人。待至天明到于王所。王即广告一切人民。诸人集已皆请问王及侍从左右群臣百官。是人得来未曾有也。彼王即便立制普告内外。若我国中。有佛声闻诸弟子等。若成法器及不成者。不起恭敬或加谪罚。以是因缘。我当刑戮乃至致死。族姓子。阎浮提王及与夜叉食血肉者。恶心炽盛无怜愍心。乃至见剃除须发。系纳袈裟以着其颈。尚不加害况余众生。而起轻慢。未来世中。当有刹利旃陀罗居士旃陀罗造作诸恶。复有恶鬼断于善根趣阿鼻地狱。若于我法而能出家。若成法器及不成法器剃除须发当夺命根。族姓子。譬如过去有王名曰福德。若人有犯罪过者乃至系缚。尔时彼王。不欲夺人身命。有辅相大臣语王莫愁。若杀此人或能令王而得大罪。大臣自以智慧将付狂象。尔时狂象捉其二足欲扑其地。而见此人着染色衣故。狂象即便安徐置地。不敢损伤共对蹲坐。以鼻舐足而生慈心。族姓子。象是畜生堕于八难。见染衣人尚不加恶生于害心。乃至未来世若有旃陀罗王。见我法中有人出家。堪任法器及不成法器。故作逼恼或夺其命。若作是行则口不能语。命终之后必定堕于阿鼻地狱。善男子。是名第三轮。刹利旃陀罗。乃至居士旃陀罗。虽有过去宿殖善根。现造恶故今尽消灭。复次善男子。当有刹利旃陀罗乃至居士旃陀罗。见有施四方僧物床敷卧具。塔庙住处及与园林屋舍田宅。一切净人牛驴骡马种种畜生。衣服饮食汤药所须资生杂物。持戒清净有德比丘辩才聪明言辞应机。如是人等悉不与之。破戒比丘作恶行者。给其所须床褥敷具。自恣受用并与白衣同共食啖。以是因缘。刹利旃陀罗居士旃陀罗。命终皆堕阿鼻地狱。复次族姓子。当有刹利旃陀罗居士旃陀罗。见有依我法中出家。若声闻辟支佛。乃至大乘说法法师。诽谤骂辱欺诳正法。而作留难恼乱法师。以是因缘堕阿鼻地狱。复次族姓子。若有刹利旃陀罗居士旃陀罗。见人有与四方僧物。华树果树杂味树荫树香树。我声闻弟子持戒多闻坐禅诵习者。所有资生众具。若自夺或使人夺。自食使人食。以是因缘。命终之后堕阿鼻地狱。复次族姓子。于未来世。当有刹利旃陀罗居士旃陀罗毁坏我法。若见依我法中而出家者。于此人所数数嗔恚骂詈毁辱。我所说法不肯信受。破坏塔寺僧坊堂舍杀害比丘。先所修习一切善根皆悉灭尽。命欲终时支节皆疼如火焚烧。其人舌根如被系缚。于多日中口不能语。命终之后堕阿鼻地狱。若成就如是十种恶轮。不善众生难得人身。况复能成声闻辟支佛果。乃至成就具足大乘。一切诸佛所不能救。善男子。譬如押油一一麻中皆生诸虫。以押油轮而押取之即便得油。善男子。汝等当看押油之人。于其日夜为应定杀几所众生。若复有人。以是十轮而押油者。一轮一日一夜押油千斛。如是乃至满于千年。是押油人得几所罪。地藏菩萨言。甚多世尊。无量无边阿僧祇数。此押油人得如是罪。无有能知是人罪量其数多少。唯佛与佛乃能知之。佛言。善男子。譬如十轮之罪等一淫女舍。其舍有十女人皆为求欲。如是十淫女舍。其罪等一酒家。如是十酒家等一屠儿舍。如是十屠儿舍罪等刹利旃陀罗居士旃陀罗十轮中等于一轮一日一夜罪。尔时世尊。而说偈言

  十轮罪等一淫舍　　十淫罪等一酒家
  十酒家等一屠儿　　十屠儿罪等一王

尔时地藏菩萨摩诃萨白佛言。世尊。若有真善刹利辅相大臣。真善沙门。真善婆罗门。真善居士。自护护他。于将来世守护佛法。守护堪任法器及不堪法器者。乃至守护剃除须发着染衣者。持戒清净有功德者。供养恭敬听受言教。于声闻辟支佛法。皆悉守护。谛听受持守护大乘。如闻信受住大乘者。持戒多闻言辞清辩。与如此人对相欢娱。则心悦乐咨问议论敬受教诲。远离破戒非梵行者。四方僧物而自食啖。私窃费用不依戒律。随顺十恶不善轮者。亦令舍离不与从事。教学先王治国旧法典礼制度。绍三宝种常令炽然。亲近一切诸善知识。遵用前王所行政法。是名真善刹利。得几所福灭几所罪。佛言。族姓子。譬如丈夫欲求出世。集诸珍宝满阎浮提。若值佛出并声闻众。于其晨朝修行布施日中亦施。如是次第乃至千年。常修布施种种供养。族姓子。如是行施得大福不。地藏菩萨白佛言。世尊。其福甚多无量无边阿僧祇数。无能称量如此福者。唯佛世尊乃能知之。佛言如是。如汝所说。若有真善刹利。远离不善十恶之轮。亦能遮制断他诸恶如上所说。是人功德倍多于前。假设有人。以四天下尽为四方众僧建立房舍。卧具医药悉皆给足。使百千亿声闻弟子及菩萨摩诃萨。修行种种无量法门。坐禅诵经教化诸善。如此之人其福多不。于上千年修行布施。供养功德复倍于前。假设有人于四天下。尽为建立僧房堂阁。卧具医药皆悉具足。满百千亿声闻弟子菩萨摩诃萨。修诸法门一切诸善。坐禅诵经教化功德得几所福。答言。世尊。其所得福无量无边阿僧祇数。善男子。假设满三千大千世界。为舍利故起诸塔庙。遍满三千大千世界。如是造塔功德无量。其福日夜常得增长。四方造作僧房。卧具医药所须一切悉给。起塔功德复倍于前。假使三千大千世界满中菩萨。具足六波罗蜜如稻麻竹苇。设满三千大千世界。声闻罗汉具八解脱。亦如稻麻竹苇丛林。皆被囚执坚固系缚乃至一劫。复有一人出现于世。为福因缘故。悉解诸菩萨及阿罗汉被系缚者。并与洗浴。给其衣服瓶钵房舍饮食医药种种卧具。乃至百千万岁尽入涅槃。复取舍利而供养之。为一一舍利起七宝塔。供养如是七宝塔故。各以香华及诸伎乐缯盖幢幡。若复有人。为如来故起诸塔庙。乃至满三千大千世界。其所得福百千亿分。不如解此被缚功德。真善刹利。真善婆罗门。真善居士。真善沙门。如是福聚增长无量阿僧祇数。于末法中法欲灭时。能善自护亦护他人。于未来世常护佛法。亦复护我声闻弟子。堪任法器及不任者。乃至剃除须发被着袈裟。不应娆乱而作恼害。若有亲近供养声闻乘者亦不得恼乱。亦复不应愿乐。供养于大乘者。终不欺毁。修辟支佛乘者。亦自亲近供养。坚固受持大乘之法安住大乘有功德者。善巧机辩恒乐．亲近咨问义论。问已随顺受持。而于一切恶行比丘皆悉远离。不应与同四方僧食共受利养。自不染着十恶之轮。亦不教他令生染着。皆悉修习先王之道具行十善。常当亲近诸善知识炽然法眼。如是真善刹利。得福倍多无量无边。终不虚食国民禄俸。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。乃至富多那等。皆悉爱念同共拥护者。若有一切堪任福田成法器者。皆悉爱念。同共拥护己国增长。若他国土亦令增广。涸竭恶道利益天人。守护寿命令得久长。自灭结使亦能灭他一切烦恼。成就菩提满足六波罗蜜。远离一切恶道。而随生死流转无数。于生死中而无讥嫌。常值善知识。悉与诸佛菩萨共俱。远恶知识。如是不久成就佛国。得阿耨多罗三藐三菩提。尔时一切天帝及诸眷属。乃至毗舍阇帝释及诸眷属。从坐而起合掌向佛。白佛言。世尊。于未来世。有真善刹利王乃至真善居士。若能远离此十恶轮。守护己身亦能护他。及护持正法绍三宝种。炽然不断成熟三乘。于佛所说悉能信受如法供养。诸佛所说终不覆藏。我等眷属。与真善刹利王乃至真善居士。当以十法守护此人令得增长。何等为十。为护寿命终不横死。除诸非法常得少病。眷属安隐财产增长。具足大富名称远闻。亲近善知识智慧增长。如是真善刹利。乃至真善居士。远离一切十恶轮者。如佛所说。当以十种善法而守护之令得增长。何等为十。所谓怨贼外敌不能侵害。色声香味触无不可喜者。一切病痛。邪缚。邪归依。一切疑悔。一切邪谄。一切恶友。一切不善根本。一切夭横死亡。真善刹利具足功德。如上所说皆悉除灭。当以十善法守护是人。复次世尊。若真善刹利。如上所说功德满足皆悉修行。我当以此十法。守护刹利国土之人。何等为十。惧邻国怨敌。畏非人。畏于亢旱。畏于霖雨。畏非时风。畏非时恶星变怪。畏饥馑。畏非时病死。畏恶邪见。畏真善刹利。于上所说能修行者。我等当以十法。守护国土及诸人民。尔时世尊。赞天帝释乃至富多那等。善哉善哉。善男子。皆是汝等之所应作。尔时天藏大梵。即从坐起整其衣服。右膝着地长跪叉手。白佛言。世尊。唯愿听我说。是真善刹利。转不退转地陀罗尼心咒章句。以此不退转地陀罗尼神咒力故。使未来世真善刹利。令边国怨敌自然退散。使身口意戒成就得胜智慧。为一切智人之所赞叹。远离诸恶常修行善。远离一切邪见邪归依。精进坚固成熟无量诸众生故得自在智。六波罗蜜珍宝伏藏具足增长。远离一切嗔恚悭贪诸恶嫉妒。常为天人之所守护。得不退转菩提之心。不舍一切众生。得四摄法无所疑问。成熟法器具足福田。亲近菩萨诸声闻众利益一切。善男子。真善刹利。终不退转菩提之心。得陀罗尼神力功德。于未来世最胜不坏无所讥嫌。常亲近诸佛一切菩萨。尔时天藏大梵即说咒曰

多阇他　牟尼置梨　牟那舍啰鞞　牟尼夷梨地夜　末啼卢阇毗阇隶　牟那栗芝　阿昵伽弥　[口*叔]迦罗博差　波罗舍博差　蜜罗博差　扫啰裟栗啼　兜罗挐栗隶钵哆叉栗婆隶　旧旧拏弥隶　阿鞞叉婆婆阿[少/兔]阿只梨梵　牟尼波陀鞞　私婆呵

尔时天藏大梵说是咒已。白佛言。我愿世尊。于此陀罗尼心生随喜。佛言。善哉善哉。大梵。我于此咒心生欢喜。时会大众亦称善哉。快说此陀罗尼耶。尔时佛告大目揵连。弥勒菩萨摩诃萨。汝等受持不退转地心陀罗尼。能令真善刹利安乐利益。为转法轮故。为名称利故。为威德故。为灭诸邪见故。为建立正见故。为守护法眼故。为无边众生令得成熟故。为使坚固大乘不退故。为使满足六波罗蜜故。尔时世尊。欲重宣此义而说偈言

  尔时天藏梵　　发问两足尊
  利根等众生　　修禅而诵习
  勇猛强劝作　　刹利有智者
  云何灭烦恼　　云何住不退
  佛时答彼言　　犯重堕落者
  虽意有明利　　急趣阿鼻狱
  此十种恶轮　　无智所修行
  则断善根本　　速疾堕地狱
  禅定亦灭结　　非独多闻智
  若欲得解脱　　应当勤修禅
  智者常精进　　守护我正法
  以恭敬袈裟　　能度烦恼海
  乐处于空林　　远离五逆罪
  持戒修禅定　　能度烦恼海
  若有信三乘　　炽然于佛法
  供养染衣者　　得大功德海
  能调难伏心　　不举比丘罪
  圣种修少欲　　获得两足尊
  远离恶比丘　　恭敬亲贤圣
  不食僧祇物　　速到于菩提
  三界得妙乐　　三宝出于世
  若欲得安乐　　当供养三宝
  三宝旃陀罗　　刹利作过者
  恶比丘伴党　　速疾堕地狱
  如是十轮罪　　等于一淫女
  以是十淫罪　　亦等同一酒
  如是十酒罪　　复等于一屠
  以是十屠罪　　亦同于一王
  有真善刹利　　供养于正法
  三乘得炽盛　　当获功德海
  具足七宝等　　遍满阎浮提
  持用施诸佛　　其福犹有限
  乃至四天下　　造僧房供养
  彼虽得大福　　不如护正法
  假使为诸佛　　满中造塔庙
  彼虽得大福　　不如护正法
  罗汉诸菩萨　　解缚而供养
  显现于我法　　其福倍于彼
  修禅亿千劫　　不为诸佛护
  若不隐正法　　诸佛速护念
  若真善刹利　　远离十恶轮
  能守护佛法　　及持袈裟者
  不谤毁正法　　我所说三乘
  闻已能供养　　护持法器者
  譬如五日出　　能竭于大海
  若护我法者　　则竭烦恼结
  譬如风灾起　　悉摧一切山
  若护正法者　　亦灭诸烦恼
  譬如水灾起　　漂荡坏大地
  若护正法者　　亦消诸烦恼
  世有如意宝　　能满人所愿
  若说三乘法　　随愿亦皆得
  譬如获德瓶　　尽破于贫穷
  如是破烦恼　　速疾得菩提
  如月十五日　　光明满虚空
  得是智慧者　　满足护正法
  如空无所有　　无物亦无相
  守护正法者　　是智无疑惑
  如日所照处　　能除诸闇冥
  守护正法者　　是则得照明

大方广十轮经卷第四大方广十轮经卷第五

        失译人名今附北凉录

    众善相品第七

尔时金刚藏菩萨。于大众中从坐而起。偏袒右肩右膝着地。长跪叉手合掌向佛。以偈问曰

  毁破禁戒失头陀　　以造逆故非我灭
  如过去佛之所说　　破净戒者不入众
  诸有一切沙门事　　犹如燋炷皆弃舍
  三垢所污离解脱　　不堪消受国供养
  四方众僧资生业　　悉不听取微少分
  若犯四重根本罪　　为众弃舍如死尸
  云何此经说忍辱　　于恶比丘起悲心
  遮制一切诸谪罚　　复令供养恶比丘
  昔于余经复说言　　汝等皆当信大乘
  是名质直胜菩提　　汝等应当离二乘
  复于此经说三乘　　及诸根力觉道分
  禅定解脱三乘法　　谛听信受解脱因
  此有沙门四圣果　　除此经外无沙门
  三乘皆同八正道　　欲求解脱勤精进
  若有智者诸人天　　菩萨大士来至此
  此诸大众皆已证　　如是大乘诸人等
  有能正说开示义　　若能听者得何利
  十种分别声闻人　　能如是说谁不利
  若有人听得何法　　云何能听得增长
  复有谁听而损减　　复有听者尽老死
  诸有为法悉厌离　　昼夜修习于禅定
  何时当得而济脱　　能度四流名救世

尔时佛告金刚藏菩萨。善男子。善哉善哉。利益安乐一切众生。若人及天无能如是问于如来。善男子。谛听谛听。善思念之。吾当为汝分别解说。唯然世尊。我今谛听愿乐欲闻。善男子。复有十种难得人身。何等为十。不宿殖善根。未修福者心常愦闹。随恶知识不畏后世。耽着贪欲嗔恚愚痴。颠狂失心乃至邪见。是名十法难得人身。复有十法。无依止因缘犯根本罪。以破戒故坠于恶道。何等为十。无依止威仪。有依我法而出家者。内心不坏修道坏。修道不坏内心坏。有内心修道俱坏。有戒坏见不坏。有见坏戒不坏。有戒见俱坏。有内心修道戒见俱不坏

若随恶知识无依止威仪。虽遇善知识。而复愚痴犹如白羊。闻善法已不能受持。亦不为他分别演说。不识善不善。无依止威仪。众具无量而不知足。以是因缘心常散乱。是名无有依止威仪。为种种病之所苦恼。以是因缘修诸咒术

若有依止是十无威仪。犯根本重罪。而复战惧。心怀惭愧而不数数作诸恶行。如来为欲利益如是等故。是名污道

何以故。若作如是恶者应当忏悔。弃舍发露终不覆藏。若能如是令罪消灭则不更作。虽为众弃一切众僧基业敷具。所须之物不得受用。如是等人以成法器故。如来为说声闻．辟支佛．大乘之法。斯有是处。若二世三世遇善知识。一切恶业消灭无余。得声闻果辟支佛果。乃至入于甚深大乘正法。如是之人名为破戒。不名破见。若有人内心坏行不坏见不坏者。如来为是等说四无量心。亦堪任为声闻器辟支佛器。若有人行坏体坏。于此二乘悉不成器。为如是众生故。如来便为说布施法

复有人见坏戒不坏者。为如是众生故。说十二因缘法。得离坏见已于一身得入声闻法。若革身得辟支佛法。若有人戒坏见不坏。于圣法中堪任为器

若有人内心行见戒俱坏者而从善知识。以是因缘。如来为说十善正法。若有愚痴随恶知识。不知善不善。如来为是等故教令诵习。若有人为邪见所惑欲求解脱。如来即便以声闻乘为说四谛法

若有人起断见者。为说十二因缘法。若人起常见者。为说三界生死轮回。知如是法死此生彼。为说声闻法。如来观察终不妄说。若有成熟众生及不成者。悉以方便通达。无碍一切重罪诸逆罪等

若有众生作不饶益。乃至破毁清净法眼。如我为欲利益一切众生故。随顺一切声闻乘辟支佛乘及菩萨乘。若诽谤正法遮障覆藏不显现者。乃至一偈。如是人等名谤正法。坏八正道。亦坏一切众生法眼。如是之人则失大利。亦为众生作不饶益。依愚痴僧诽谤正法

复次族姓子。有四种僧。何等为四。第一义僧。净僧。哑羊僧。无惭愧僧。云何名第一义僧。诸佛世尊。大菩萨摩诃萨。辟支佛。于一切法悉得自在。阿罗汉。阿那含。斯陀含。须陀洹。是七种人名为第一义僧。诸有在家无法服者。不能具受波罗提木叉戒。不入布萨自恣而得圣果。得圣果已亦名第一义僧

云何名为净僧。诸有能持波罗提木叉具足戒者。如律修行威仪不犯是名净僧

云何名哑羊僧。不知根本罪。不知犯不犯。不知轻重。不知微细罪而可忏悔。愚痴无知不见有罪可畏。亦不依止善知识丈夫。不数亲近善知识丈夫故。不能咨问经中深义。何者是善非善。何者犯重何者犯轻。修行何事为善何事为恶。如是等相名哑羊僧。云何名无惭愧僧。若有人为自活命来入佛法。而受波罗提木叉戒悉皆毁犯。破和合僧无有惭愧。不畏后世内怀臭秽。其声如贝言辞坚[革*卬]。常怀嫉妒愚痴憍慢。弃舍三业但为利养。放恣六情贪着五欲色声香味触诽谤正法。如是等人。依止我法心无惭愧。是故名为无惭愧僧

云何名为第一义僧。虽有圣道隐而不现。乘八正道能度烦恼三有驶流。是名真道。何以故。诸佛世尊缘觉罗汉。断一切有名为真道

又诸菩萨摩诃萨。自省己过求一切法。得无碍智而不取证。为众生故示灭结道

若复有人。不成就波罗提木叉戒。名为依止第一义僧乃至净僧

若有真善凡夫。乃至真善正见及诸凡夫。神通变化示他正道。如是之人皆悉名为能示道者。第二须陀洹。第三斯陀含。第四阿那含。第五菩萨摩诃萨住于初地。乃至住于十地一生补处。如是等者名为示道

若复有人。成就波罗提木叉戒。是名依道而活。菩萨摩诃萨为摄一切成熟众生。修行六波罗蜜。如是等亦名示道。亦名依道而活。亦名灭结道。如是名为世间福田。除此以外皆名污道。亦名恶福田依止无惭愧僧。于佛法中亦名死尸。是可弃者。于僧大海亦名不成法器。彼非我弟子。我亦非彼师

复有不成法器者。称佛是我世尊。我灭度后得信向心法僧圣戒。自不起恶见。亦不讥他恶。而广为人显说我法。不生诽谤发正誓愿。已所作恶数数忏悔。能除无量种种诸罪。作如是信。令使九十五种异学外道。犹悉能度向于涅槃。非转轮圣王所有功德之所能及

以是义故。如来观察一切众生本业。作如是说。以是因缘故。于我法中出家。剃除须发被染衣者不应起恶。一切过去未来现在。诸佛大悲皆悉护持如是出家被服染衣。以是故。若于出家一切人边起恶心者。则同过去未来现在诸佛等前为恶无异

若复有人破戒不成法器者。诸如是等。当作恶见亦讥他恶

譬如真善刹利。真善辅相。真善大臣。真善沙门。真善婆罗门。真善居士。真善毗舍首陀。若男若女。无父无母。世间阿罗汉。无正道无趣向正见者。亦无修善恶果报。无有得果者。一切法皆无因缘

或有作如是说。色界是常是不坏法。或计无色界是常不坏法。或说外道苦行。编椽棘刺。五热炙身。以为第一。或说纯声闻乘。以为第一。不说辟支佛乘。乃至诽谤大乘摩诃衍法。隐蔽覆藏。不能显发开示分别。或有一向纯信摩诃衍。讥嫌声闻辟支佛乘。或有说言。施为第一。持戒乃至智慧非是第一。或有说言。戒为第一。布施乃至智慧非是第一。或有说言。忍辱为第一。布施持戒乃至智慧非是第一。或有说言。精进以为第一。布施持戒忍辱乃至智慧非是第一。或有说言。禅定以为第一。布施持戒忍辱精进乃至智慧非是第一。或有说言。智慧最为第一。布施持戒忍辱精进禅定非是第一。或有说言。外道苦行以为第一

如是族姓子。破戒恶行诸比丘等。于成法器者边生种种毁谤。向恶见者说如是言。有颠倒见者。破坏真善刹利。信戒闻舍智慧。皆悉破坏。真善辅相。真善沙门婆罗门。真善居士。真善毗舍首陀。真善男女。破坏信戒闻舍智慧。如是破坏。名为刹利旃陀罗。乃至居士旃陀罗。破戒比丘自断善根。亦能令真善刹利亦失善根。乃至堕于地狱

善男子。譬如脓烂死尸。有所近处皆悉臭秽。有所至处自臭亦令他臭。如是真善刹利。亲近恶知识破戒比丘。随所近处悉生恶见臭秽如是。能使刹利断于善根。趣阿鼻地狱。如是真善辅相。乃至真善妇女。亲近破戒恶行比丘。皆为旃陀罗。断于善根趣向地狱。族姓子。汝观是亲近破戒恶行比丘退一切善。是故欲得大涅槃乐。皆应亲近供养灭结修道者。于彼修学具足三乘示道者边。应亲近供养。具足内心。具足修道。具足知见。应听声闻辟支佛道。不诽谤贤圣。于摩诃衍亦不诽谤。随其所欲精进。于三乘中随其发愿修学一乘。不应诽谤大乘经典。乃至一句一偈若诽谤者。不应共住亦不应亲近。若亲近共住者。即趣阿鼻地狱

是故族姓子。于三乘中。当随所乐趣向一乘。欲得远离一切苦者。应信如来所说声闻辟支佛乘。悉应依止摩诃衍所说诸法。不应诽谤隐蔽覆藏。乃至一句一偈应当谛听发正誓愿。若有谤正法者不应共住。亦不应于是人所咨受听法。若就听法。以是因缘。常趣阿鼻地狱受大苦恼。何以故。族姓子。我本为菩萨行时求无上道。依声闻乘为求一偈。乃至舍身手足支节头目髓脑。如是求于辟支佛乘。及求佛乘。我本为菩萨时。为无上道故。亦复如是。为一偈故。舍身手足头目髓脑血肉皮骨。如是苦行。乃至究竟成无上道。此三乘法皆是三世恒沙诸佛之所演说。神力守护。为欲悲愍诸众生故。亦为欲绍三宝种故不令断绝

复于未来世。若有刹利旃陀罗。乃至妇女旃陀罗。以愚痴故自谓为智。多恶粗犷不畏后世。作诸杀生乃至邪见嫉妒悭贪随恶知识

又于三乘不成法器。于声闻乘得少闻已。于辟支佛乘乃至大乘。一切诸佛之所护持而生诽谤。覆障不令显现。若于摩诃衍得少闻者。于诸声闻辟支佛乘。诸佛神力之所护持。而生诽谤毁訾。不信我大乘及能分别说大乘者。若言我听大乘不受声闻辟支佛乘。以己少智愚闇力故。亦是过去未来现在诸佛大悲力故

为欲利益一切众生。有二种护持。第一为欲绍三宝种令不断绝。出家修道剃除须发而着袈裟

第二说应四谛法趣向三乘如是二种如来护持。非声闻辟支佛所能持也。乃至百千帝释梵天亦不能持。百千那由他转轮圣王亦不能持

复有刹利旃陀罗。若见有人于我法中而出家者。如是声闻弟子。闭系牢狱鞭杖谪罚或至夺命。于此甚深一切诸佛菩萨所护持法。悉使坏乱三乘正道诽谤覆藏。如此之人不识大乘。如是刹利旃陀罗。尚不堪任为声闻器。况复大乘

复有妇女旃陀罗欺诳世人。自言我是行摩诃衍者。以愚闇故。悭贪嫉妒故。毁坏我法。言我自当速趣涅槃

而于诸佛如来世尊所得生其罪过。一切菩萨摩诃萨。一切诸佛声闻弟子边。亦皆犯罪令寿命短促。多诸苦恼诸根缺坏。支节不具恒多疾病

刹利旃陀罗。乃至妇女旃陀罗作诸恶业皆生倒见。断一切善根。虽多布施于畜生中受种种身而得果报。于未来世身坏死时。终不能生色界善根成无碍智。亦不能趣一切种智。而多疾病舌不能语向阿鼻地狱。是故如来。为欲利益真善刹利使得安乐。亦令真善妇女得其利益。以是因缘。不听恼乱于我法中而出家者

又复于我所说法中起诸诽谤。以如是事获大罪报。如前所说。何以故。披着袈裟是一切诸佛解脱之相

是故一切诸佛。护持声闻解脱等味大正法幢。亦是辟支佛第一大乘解脱味幢。是故求解脱者。应先读诵声闻乘等谛听其法。远离一切诸恶知识。亲近一切诸善知识供养恭敬。然后读诵方等大乘六波罗蜜。一切所作诸恶不善。皆悉发露如法忏悔发大誓愿。身坏命终于后世中。悉能成就声闻法器。斯有是处。亦是辟支佛种子。乃至大乘阿鞞跋致无上种子。何以故。善男子。复有十种依止轮。若成就是轮已。真善刹利。乃至真善妇女。则能速疾成声闻器种。辟支佛种。大乘阿鞞跋致种。何等为十

如是真善刹利。乃至真善妇女。信有业报具足惭愧。远离邪见及恶知识。持戒不杀乃至不饮酒。慈心一切离嗔恼害。具足悲心救济忧苦。羸劣众生得于喜心。远离两舌妄言绮语。得无诤心离悭贪嫉妒。终不依止诸邪异道。离一切疑网及众吉相。发大精进于一切法而得坚固。疾证寂静得法欢悦

族姓子。是十种依止轮。真善刹利。乃至真善妇女。成就十轮。则便速得声闻法器。辟支佛种。大乘阿鞞跋致种子。是名依止轮也。如是轮者。悉与声闻辟支佛共。尔时世尊欲重宣此义而说偈言

  于众中第一　　剃头着袈裟
  云何恶比丘　　破戒得供养
  毁禁失头陀　　诡语邪见持
  非器毁于道　　不应使谪罚
  若从彼听法　　信寂灭涅槃
  若得解脱者　　为彼之良药
  于诸余经中　　但说一乘道
  言无有二乘　　第一之解脱
  利益诸众生　　尽业报烦恼
  恒有悲愍心　　刹利乐正法
  婆罗门毗舍　　首陀等染罪
  欲恼于比丘　　必趣向恶道
  如是一切佛　　护持染袈裟
  诸佛解脱道　　是说名第一
  着于解脱服　　速疾舍恶见
  趣向于涅槃　　犹如药治病
  虽破于禁戒　　亦能灭他苦
  我终不听彼　　在众而布萨
  若为他说法　　彼此俱得福
  称我为世尊　　归依于三宝
  遮断诸恶业　　犹胜于外道
  譬如罗刹王　　商人入怖畏
  捉揽马一毛　　必度大海难
  破戒舍恶邪　　离烦恼罗刹
  是故护解脱　　诸佛之所持
  不恼破戒者　　必舍诸罪恶
  是故有福者　　欲求于解脱
  能护器非器　　解脱亦不难
  于此无势力　　愚闇于声闻
  非彼缘觉等　　而能说大乘
  不觉于缘觉　　而赞于大乘
  彼已破于信　　读诵大乘经
  不护于余乘　　身口意所犯
  唯说于断见　　破坏于正法
  后当得成人　　还堕阿鼻狱
  是以观众生　　勿有非器者
  若犯毁禁戒　　无愍矜谄曲
  亦应知是因　　恶口而断见
  非声闻缘觉　　亦复非大乘
  毁谤三世佛　　必趣阿鼻狱
  谄曲而持戒　　散心悭惜法
  厌恶诤贪嫉　　是名为声闻
  有智乐行施　　能起生灭相
  执心常独处　　是名为缘觉
  持戒不惜身　　犹如猛师子
  志求寂灭道　　是名为大乘
  守护于正法　　善说而显示
  得深诸法忍　　是名为大乘
  法器非法器　　心常行平等
  不染于世法　　是名为大乘
  是故于三乘　　智者如法说
  守护我声闻　　速成最正觉

大方广十轮经卷第五大方广十轮经卷第六

        失译人名今附北凉录

    刹利依止轮相品第八

复次善男子。十种依止行轮。一切声闻辟支佛。乃至如来皆与同等。若有成就依止轮者。真善刹利。乃至真善妇女。速疾得成声闻法器辟支佛种。亦能成就如来法器

何等为十。族姓子所谓真善刹利。乃至真善妇女。身口意业净修法行有惭有愧。厌恶己身畏五盛阴。不见生死大河彼岸。乐于寂静离诸愦闹。无有诤心不讥他短。守护诸根心常念定。善观因果能成就禅定。常乐摄心善解生灭。如是则能成就十依止轮。是名为真善刹利。乃至真善妇女。速疾成就声闻乘辟支佛种。亦得大乘阿鞞跋致。如是族姓子。能成声闻辟支佛乘。依止此轮度诸有海入涅槃城。云何名依止威仪轮。云何名依止。我所谓依止五受阴故。名为依止。于五受阴而作己想决定依止

云何名威仪。有阴威仪有界威仪。是名威仪。云何名轮。诸佛神力所持言教。皆名为轮及与剑轮。如是声闻辟支佛人。依止此轮求涅槃道。染着依止。不任大乘清净法器

云何依止。依止阴界心生惊怖。依止厌离依止于身而求解脱。度脱己苦以己受阴。为求一切众生解脱。以着己受故。而不堪受大乘法也。但自为己不为众生。无大悲心。以是故不住大乘。久住生死便舍他苦。为欲断己烦恼故。不能舍于手足头目。是故不任大乘法器。亦不求于大乘道轮。而亦不求梵音轮也。是故不任大乘之器。独一无伴入涅槃城。以是义故。若有众生。不闻声闻辟支佛乘。诸行不具善根不熟微少精进。若此人前有所说法二俱得罪。亦是扰乱一切诸佛。以是义故。若有众生。于声闻辟支佛乘。而不成熟诸善根者。若听微妙大乘经者。彼人愚痴自谓为智堕于断见。如是人等说无因果无善恶业。亦于我法而作坏乱。非法言法。非沙门自称沙门。非比丘言是比丘。遮断一切声闻辟支佛乘而不流布

若于声闻辟支佛法。出家受具足戒。为集一切诸善根故。故任法器及不任者。学无学人善巧言辞。机辩无碍已证诸果。乃至真善凡夫具足持戒。于是等边而作骂詈。夺其衣钵执缚系闭。如是断常是人中罗刹得人身难。宁堕地狱得无量罪。不受人身起于断见。是故生常愚痴口不能语。乃至命终趣阿鼻地狱人身难得。于阿僧祇劫设得人身。于诸佛界生五浊世。身常喑哑口不能语耳无所闻。如是等病逼切其身志意错乱。无有饮食资产财业。远离善知识成就诸恶。亦为恶见之所覆障。造众逆罪而说断见。恼乱我等声闻弟子。持戒清净修功德者为恶所染。若人下根下精进。不求声闻辟支佛乘。于大乘道而生断见。欲求人身尚难可得。况求声闻辟支佛乘。于此二乘尚不能行。况复能了甚深大乘

譬如坏瓶多诸穿穴。若盛油水则皆漏尽而俱失坏。何以故。是器过故。若有众生根不熟者。亦复如是同彼瓶相。善男子。如盲人前示种种宝。如是无智慧者。憍慢放逸乃至断见。广示大乘亦复如是不能了知

譬如有人其身臭秽。虽以旃檀沉水香等。种种涂身犹不能香。如是不勤求声闻辟支佛乘。不断恶业乃至邪见。若以摩诃衍大乘香涂。犹故不香。譬如薄田虽殖好种终不能成。如是不能勤求声闻辟支佛乘。于彼五欲不生厌离。如是之人若以摩诃衍道。而为说之则不能成。譬如毒瓶着少石蜜不任食用。若不能修声闻辟支佛乘乃至大乘。言无因果者。若欲为说大乘经典。不能令彼如闻修学。则不信受犹如毒瓶置少石蜜。如是不任声闻辟支佛器。而置大乘味者。当知是等二俱无用。亦如狂人前。若弹箜篌筝笛鼓贝。作众伎乐不能解了。如是不能勤求声闻辟支佛乘。有重贪欲嗔恚愚痴。乃至于声闻乘根不熟者。若为说摩诃衍道亦不能了

譬如有人不持铠杖而入战阵。既入之后必当得于无量苦恼。如是不能勤求声闻辟支佛乘根不熟者。若为显示摩诃衍乘亦复如是。必当得彼无量苦恼

是故善男子。有智之人先观众生然后说法。以慈悲喜舍心。及利益心。不懈怠心。以忍辱心。不憍慢。放逸心。无嫉妒心。无吝惜心。以修定心。为人说法。亦不令他堕坠恶趣不如意处。是故如来能知他心救济众生。随其信轮而为说法。以大庄严而自庄严

若为菩萨摩诃萨说法。恒以大悲因缘。为断众生一切结使而为说法。度诸有海为于三乘中随使成就一乘故而为说法。终不欲令堕于生死而为说法。分别诸阴而为说法。分别诸入而为说法。分别诸界而为说法。分别欲界道而为说法。分别色界无色界道而为说法。不为今世有。不为后世有。不为行有。不为心想有。不为心行有。不为意思有。不为无明有。乃至不为生老病死有。不为行无行众生而为说法。乃至行非行寂灭而为说法。一切想无生而为说法

云何名行。行者名为死此生彼。若能覆此生死名灭行非行

云何名轮。如如意宝能持一切。遍满虚空度诸国土。观察世间诸行起灭犹如幻化。不与声闻辟支佛共。是故名断一切行轮

如是善男子。如来以如是相。为诸众生种种说法。亦如虚空无有分别。与无量三昧自在游戏而为说法

如是菩萨以大庄严而自庄严。为诸众生。说色非空。离色非空。乃至识非空。离识亦非空。眼非空。离眼亦非空。乃至意非空。离意亦非空。眼识非空。离眼识亦非空。意识非空。离意识亦非空。空处非空。离空处亦非空。识处非空。离识处亦非空。无所有处非空。离无所有处亦非空。非想非非想处非空。离非想非非想处亦非空。四念处非空。离四念处亦非空。道亦非空。离道亦非空。十二因缘。三不护法。十力。四无所畏。十八不共法。大慈大悲大喜大舍。乃至涅槃非空。离涅槃亦非空。善男子。是名如来中道实义决定性相。为他众生分别演说诸行无生。住持正法。遍满虚空。乃至无量禅定一切法相。皆如日光照明开示令入三乘。为得涅槃令得解脱

菩萨摩诃萨如是说法。为最第一利益众生。谛听甚深法已。随意所欲。于三乘中。随所修习种种善根则善住一乘。亦不增益诸不善法。其行坚固不退涅槃。

菩萨摩诃萨为断无量生死劫苦而为说法。亦为声闻辟支佛乘众生令度四流

菩萨摩诃萨为断一切众生四流而为说法。声闻辟支佛乘但为自己断四流故而为说法

菩萨摩诃萨为断众生烦恼病故而为说法。声闻缘觉为断己烦恼故而为说法

菩萨为断众生烦恼业习使无余故而为说法。声闻缘觉虽断烦恼习有余故而为说法

菩萨摩诃萨为令众生得大悲果报故而为说法。声闻缘觉离于大悲而为说法

菩萨摩诃萨但为悲愍诸众生故而为说法。声闻缘觉虽复说法。实无悲愍利益之心。菩萨摩诃萨为灭众生诸毒苦故而为说法。声闻缘觉但灭己苦故而为说法

菩萨摩诃萨为满一切法味故而为说法。声闻缘觉自满己法故而为说法

菩萨摩诃萨为一切众生得法光照成大明故而为说法。声闻缘觉但为自得法之照明。不为众生演说法相。善男子。是名略说灭除一切大无明闇得大明故。而欲成就一切种智悉觉悟故。乃为他人分别说法。声闻缘觉为欲灭己无明闇障。内自照明得正觉悟

善男子。声闻缘觉不为众生而生厌恶。不为愍救度脱他人。不为于他令得名誉称扬赞叹。不喜他人而生谄曲但自护己不护于彼。不为安乐一切众生。声闻缘觉若见他人有微少过。必起身口意业等罪

善男子。菩萨摩诃萨住大乘者。皆悉救护慈愍于他。乃至不见众生身口意业过

善男子。若有众生。起于粗弊愚痴恶口自谓为智。乃至不离邪见。为求他利而生嫉妒。贪著名称自举轻他。不能守护身口意等。心常念恶无有愍伤。而喜恼乱选择福田。若有依我而出家者。不见其过轻毁骂詈心常散乱。不自省己念讥彼阙。于大乘人虽生愿乐无寂静心。起重恶心永离他人。恒作是语而自称说。是大乘人亦教他读诵。但自赞己非毁于他。以是义故。赞叹大乘自不调伏。于大乘道而欲教他修行大乘便作是说。自谓大乘。譬诸恶行律师。而教人言。如是谄曲难得人身。亦失声闻辟支佛乘。常趣恶道。不欲亲近诸有智者。而唱是言作师子吼。我是大乘。善男子。譬如有驴着师子皮。自以为师子。有人远见亦谓师子。驴未鸣时无能分别。既出声已远近皆知非实师子。诸人见者皆悉唾言。此弊恶驴非师子也。我今所说亦如是等。若造十恶烧灭人种。非诸声闻辟支佛器败坏种子。如是愚痴诳惑他言。我是大乘。善男子。譬如有人而无手足欲至战阵无所堪施。破戒之人亦复如是。欲与结使烦恼战斗。我说是人终无果报。毁犯禁戒作恶行者。于一切处不成法器。若自说言。我是大乘。能破一切众生烦恼尘劳大阵。亦为众生住八正道入无畏城则无是处

何以故。若有众生。威仪清净惭愧具足。畏于后世远离一切不善等法。喜乐一切诸善功德。而于众生起大悲心。亦能济度一切苦厄。救护生死诸怖畏者。不着己乐庆于彼乐。常勤精进专念不舍。心乐寂定舍于谄伪邪惑欺诳。善知业知业果报。不着五欲世间八法所不能染。乐观阴界如救头然如救衣然。安住声闻种。有如是相名声闻乘。则于大乘所不堪任。辟支佛乘复有何相。若人具上二十法者。则能常观五受阴生灭等相。明观诸法皆因缘生。亦知灭相。如是之人不任大乘。不能成于大乘法器。尔时如来以是义故而说偈言

  刹利依止十　　婆罗门首陀
  若修真善行　　堪为声闻器
  辟支佛胜乘　　三业悉清净
  守护于诸根　　所说好柔软
  分别观诸阴　　界入亦复然
  乐独空闲处　　善慧观因缘
  常摄于诸根　　依止是十轮
  于诸无坏乘　　堪任为法器
  念度于有海　　等行于三轮
  不依于结使　　而近解脱门
  不任大乘器　　不具大胜轮
  不勤求大乘　　并诸下根者
  若有愚痴人　　心常怀懈怠
  是故非大乘　　亦不堪大器
  独一求解脱　　痴谄无愍行
  常行于断见　　彼亦趣恶道
  弃舍于正法　　而说于非法
  遮断三乘道　　舍律欲爱具
  恼坏贤圣法　　打掷袈裟者
  毁訾而诽谤　　亦自坏其身
  为欲修人身　　不舌[病-丙+今]而死
  常值诸佛者　　显示三乘法
  欲炽然三乘　　及与分别者
  欢喜而显示　　必成佛无疑
  破戒而嫉妒　　自赞复毁他
  是智者所弃　　得佛三界尊
  以悲心说法　　随心之所乐
  具分别三乘　　必成佛无疑
  说法如虚空　　而心无所依
  阴界入皆空　　必成佛无疑
  佷戾喜破戒　　若闻赞大乘
  诈称为菩萨　　驴披师子皮
  我今为众说　　欲得胜菩提
  护持于十善　　莫坏于我法
  我于余经说　　行第一菩提
  离声闻缘觉　　为净众生说
  曾供亿诸佛　　灭恶心解脱
  我从彼所闻　　但一无二乘
  此众说三乘　　有住声闻者
  心恼多造作　　不任道器故
  有住于缘觉　　愚闇于胜法
  不任上乘器　　随所欲而说
  头陀闻解脱　　当堕于恶道
  冷阴而服乳　　终不能差病
  如是声闻器　　狂心说断见
  是故先观察　　然后应说法

尔时世尊说是偈已。于大众中。无量百千人民。多有空乱意众生。断于善根说无因果趣向恶道。若得正见。在世尊前能至心忏悔。而白佛言。我于如来正法之中。久修声闻殖诸善根。而不能成声闻法器。方复更求辟支佛乘。愚惑不了更起断见获无量罪。我等今悉于世尊前诚心忏悔。唯愿哀愍受我等忏悔。拔除罪根不受恶报。还修善根求声闻乘。佛言。善哉善哉。善男子。汝等若能发露诚心忏悔。于我法中说有二种得无所犯。一者本不作恶。二者作已能悔。是二种人俱获清净。尔时世尊为无量百千众生。随顺其心说四谛法。有得法忍。有得世间第一法。有得须陀洹果。有得斯陀含果。有得阿那含果。复有八万四千比丘。不受诸法漏尽意解得阿罗汉

尔时众会复有七千五那由他百千人等。堕于断见断诸善根应趣恶道者还得正见。悉于佛前自归发露诚心忏悔。作如是言。我等本种辟支佛因缘而不能成。今闻大乘心生爱乐。我等愚闇便起断见言无因果。以是因缘造作无量身口意业诸余恶业。以是义故。于多劫中常堕恶道受无量苦。今于佛前皆悉发露。至心忏悔不敢覆藏。为欲满足缘觉乘故。随彼意说得光明三昧。逮不退转辟支佛乘。时彼众中复有八十那由他百千众生舌不能语。皆于过去诽谤无量恒沙诸佛所说正法。乃至诽谤一句一偈。以是罪业不能忏悔。佛神力故令使今日皆悉能言

尔时世尊知而故问。汝等宿世作何恶业。于此会中口不能语。彼即答言。我于过去毗钵尸佛法中诽谤大乘。或有说言谤声闻乘。或有说言谤辟支佛乘。以是业障罪报因缘。于九十一劫坠堕生死。常处地狱及受饿鬼舌不能语受大苦恼。始于今日得复人身。蒙佛神力始今得语。佛神力故得宿命智。能知过去一切所作恶业因缘

有说尸弃佛。随叶佛。拘楼秦佛。拘那含牟尼佛。迦叶佛所。诽谤正法乃至一句一偈。以佛神力悉知过去所作恶行。一切业障皆悉明了

尔时众会无量百千声闻。无量百千菩萨摩诃萨。从座而起自归向佛发露忏悔。我等皆于过去无量诸佛法中。若任法器及不任者。诸声闻众多起讥诃。自举轻他诽谤毁骂扬恶遏善。以是业障堕三恶道具受苦痛。虽复供养过去诸佛。及大菩萨摩诃萨众。乃至忏悔受持禁戒。得闻佛法自学教他。但以诽谤余业障故。不能得趣寂灭涅槃及禅定乐。如是罪缘。今向世尊自归发露至心忏悔。复有说言。我等于诸如来声闻弟子。夺其财业及诸饮食或系牢狱。以是业故堕三恶道受大重苦。我等虽于过去诸佛世尊及大菩萨前。发露忏悔受持读诵种种禁戒。但以余罪业障因缘。不能得向寂灭涅槃及禅定乐。今于佛前皆悉忏悔。一切余业无量罪障。唯愿世尊受我等忏。拔除一切三恶道苦。自今以后愿佛神力。令我所乐随意无碍。得于涅槃及禅定乐

尔时世尊告诸声闻及大菩萨。此是五逆余业罪障。但有名字无有实法。皆由恼乱声闻弟子能生大罪。何以故。破毁禁戒诸恶比丘。犹能为诸无量百千万那由他人。而作珍宝之大伏藏。况持净戒炽然三宝者而起扰乱。是即名为断三宝种成就恶业。亦名坏于一切众生法眼毁佛正法

若见有人依我出家而扰乱者。如是业障过诸逆罪。我今当以悲心哀愍汝等。如是业障悉听忏悔永尽无余。于贤劫中千佛出世。汝于其所亦悉忏悔。终不复起诽谤正法。其最后佛。号曰楼至如来应供至真等正觉汝于彼佛皆悉发露一切业障永尽消灭。时诸菩萨及大声闻俱共白佛。唯然世尊。如教修行。我等于贤劫中。当堕三恶及阿鼻狱。受种种苦犹能堪忍。况复于彼楼至如来。令我忏悔使得正见。解诸邪见业障众罪皆悉消除。尔时如来赞诸声闻及大菩萨。善哉善哉。汝等能以如是勇猛精进。令本恶业皆悉消灭。能生信解第一恭敬值遇诸佛得诸三昧。弃舍结漏得阿罗汉

尔时世尊告金刚藏菩萨摩诃萨。善男子。我以佛眼皆悉观见。无量阿僧祇百千那由他众生。刹利旃陀罗。乃至男女旃陀罗。于未来世少种善根而得人身。为恶知识之所破坏。于甚深法不生信乐多起谤毁。于炽然法具足声闻辟支佛乘者。或有遮断大乘者。于我声闻弟子。成器不成器者如上所说。以愚痴故自谓为智。于此终没。无数百千劫。于地狱中受无量苦如先所说

是诸人等虽得人身。宁受阿鼻地狱诸大重罪。终不受是谤法人身何以故。随顺恶知识憍慢自恣。常作如是诸恶业者。终不得度生死彼岸。四流所漂受大苦恼

当于尔时有大智者。而为涕泪作如是言。视诸众生难得人身。远离信心及大誓愿。离于心相。离于正见。离善知识。离于时节。离于方所。离于持戒禅定智慧。如是众生以愚痴故憍慢自恣。有如是想毁坏佛法悉如上说。世尊。我从今日亦于佛前而发誓愿。我等虽处生死不坏正法。愿于未来世诸佛法中不断三宝

尔时复有大士聪明智慧。从座而起合掌叉手而发誓言。我等虽在生死。不得法忍已来。于其中间愿莫受身。莫作辅相大臣。乃至令长村邑聚落等主。不作国师军幢将师长宿之处。不作祠祀主估客商人处。不作居士处。不作粗人处。不作断事处。若不得法忍。不于众生居自在处。若作是等则于佛法名重因缘。必当堕于阿鼻地狱。一切大众天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。皆悉泣泪而白佛言。世尊。我等本处生死所作恶业。若身业。若口业。若意业。多所造作。或复随喜。今于佛前皆悉发露。忏悔除灭更不敢作。如是第二第三亦复如是。不于生死随恶知识。亦愿我身不造恶业悉如上说

尔时世尊告诸大众。善哉善哉。善男子。汝能如是畏于后世。欲度生死诸有流苦欲入无畏大涅槃城发此誓已。善男子。具足十法。则得成就无著法忍

善男子。菩萨摩诃萨。不着内身。不着外身。不着内外身。不着过去未来现在身。是名菩萨初得成就无余法忍。复次不着内身受。不着外身受。不着内外身受。不着过去未来现在身受。乃至不着想行。不着内识。不着外识。不着内外识。不着过去未来现在识。不着前世。不着今世。不着后世。不着色界。不着无色界。是名菩萨摩诃萨成就十法得无著忍

若能如是于如来所说法。是时七十二亿那由他百千菩萨得无生忍。八万四千那由他菩萨皆得顺忍。无量那由他百千声闻。断诸结漏得阿罗汉。无量那由他百千众生。未发菩提心者今皆发心。复有无量众生。亦得发于辟支佛心

尔时世尊告金刚藏菩萨。若有众生成就法忍者。应得灌顶转轮圣王。所有饮食无量财业。其余众生不得法忍者。亦不能得灌顶转轮王位

金刚藏菩萨白佛言。世尊。为灌顶刹利王不得忍者。云何而得饮食财业。佛言。灌顶王虽不得法忍。能成就十善者。我亦听作国主。饮食财业任意自在

善男子。灌顶刹利王若不得法忍。又不具足修行十善。名为刹利旃陀罗。如是愚痴。当破甚深炽然佛法断三宝种。而便扰乱声闻弟子。亦作无量种种谪罚。夺其财物基业。诽谤善法而心覆藏不令显现。或夺塔物僧祇物。如是之人皆悉趣向阿鼻地狱

金刚藏菩萨白佛言。世尊。若灌顶刹利王不得法忍。复不具足修行十善。必当不得免斯恶耶

佛言。假使灌顶刹利王不得法忍。而复不修十善道者。能成就信力归依三宝。不谤正法乃至一句一偈。亦不扰恼声闻弟子持戒清净有德之者。不取佛物僧祇物

若人见有扰乱如此比丘。而复夺于佛物僧祇物者。能为遮制令无侵毁。数数听受顺于实法。于三宝中常应供养亲近是人清净比丘得坚固愿。于摩诃衍心无疑惑。亦能成就大乘众生。建立正法信大乘者

如是灌顶刹利王者。已于宿世诸如来所。得其城邑资生财物。我亦知之不堕恶道。若欲永灭一切恶者。应当修行如是正法。于过去世所作恶业悉得除尽

大方广十轮经卷第六大方广十轮经卷第七

        失译人名今附北凉录

    远离讥嫌品第九

尔时金刚藏菩萨复白佛言。世尊。云何菩萨摩诃萨于声闻乘辟支佛乘不生讥嫌。于诸菩萨亦无讥嫌。云何于如来声闻众中。成器不成器得无讥嫌。于大乘道常善修行。云何得利智一切三昧诸陀罗尼及诸地忍。云何得升进不退转法。云何常得善知识。云何常得不离佛法。供养众僧及诸菩萨云何于善根不生厌足。云何于菩萨行愿得无厌足

尔时世尊告金刚藏菩萨言。善男子。菩萨摩诃萨有十种轮。若有成就如是轮者。则于声闻辟支佛乘无所讥嫌。乃至于菩萨乘亦无讥嫌。若于如来声闻众中。成器不成器者悉无讥嫌。常得升进不退法轮。而于大乘亦得增长无有阙失。常得禅定诸陀罗尼及诸地忍。不离佛法。供养众僧及诸菩萨。求于善根悉无厌足。得坚固精进。发无量行愿。过去所作一切恶业。皆以贤圣金刚地智。令使永尽悉得究竟。一切现在所有恶业。皆使无余更不复作。能速成就无上法轮。七觉意宝而无厌足。能除一切众生结使人所依止

善男子。譬如转轮圣王。若欲行时宝轮最在其前。其余诸宝皆悉随后。能灭一切诸四天下众生浊恶。亦令四天下一切人民身意受乐。菩萨摩诃萨亦复如是。若成就十轮。于声闻乘无所讥嫌。乃至一切众生亦依止而存。善男子。譬如大车具足四轮。多人依止乘于正路。边有块石众草。乃至根茎华果。为轮所辗皆悉消灭。如是菩萨摩诃萨为诸众生若有障法一切罪业。辗断消灭令不受报。善男子。譬如剑轮悉能斩截怨敌等首。既断支节手足更不任用。菩萨摩诃萨若能成就如是十轮。一切六趣欲界诸恶。皆悉断除令尽无余不复受报

善男子。譬如五日出时。一切四天下大地。所有水处无不干竭。如是菩萨成就十轮。能为众生除诸业障及障法等罪。众苦根本一切消灭

譬如风灾起时。四方大风一时俱起。能吹一切大石诸山皆为微尘。如是菩萨摩诃萨能成就十轮。为诸众生同共依止。令四倒山结使诸业障法重罪灭苦根本。令得无余。善男子。譬如师子王若欲吼时。一切畜生诸众生等皆悉怖畏。如是菩萨摩诃萨亦复如是。乃至外道及诸异学恶知识等。皆令惊畏忘失言辩

善男子。譬如释提桓因以军围绕。手执金刚杵破坏阿修罗。如是菩萨摩诃萨成就十轮者。一切倒见外道之属。恶知识等皆悉坏灭

善男子。譬如如意宝珠。着高幢上雨种种宝。如是菩萨摩诃萨成就十种轮者。能持戒幢雨众法雨。以施一切无量众生

善男子。譬如夜闇明月出现灭一切闇。若有一切迷失道者令得正道。如是菩萨摩诃萨成就十轮者。无明黑闇如是众生失八正道。亦为众生说种种法。令其照明尽诸苦际示八正道。善男子。譬如日初出时一切谷米皆悉增长。诸华开敷及诸药谷尽得成熟。雪山消流诸河充溢。以渐次第满于大海

如是菩萨摩诃萨成就十轮者。但调伏戒慈悲炙暖故。为诸众生说无量法。能生善根种种华果。一切结使业报恶行。及邪见山悉得消灭。乃至究竟证于涅槃。一切妙果无不悉得。信戒施闻慧无量三昧如是次第。犹如大河以渐满足。以渐满故能令众生入于无畏涅槃之城

善男子。云何名菩萨摩诃萨十种轮者。所谓十善是也。菩萨成就此十轮故。乃能成熟一切众生。菩萨以离杀生故。能令一切众生无惊无怖。无有一切忧悲苦恼。善根成熟具足果报。若于前际流转六趣没生死河。以如是等不杀生因缘。先世所作身口意等恶业诸罪一切烦恼。能令众生障于正法。自作教他作乃至见作随喜。受持如是不杀轮故。皆悉辗坏一切恶业障碍罪报令无有余。亦以不杀因缘。能令一切诸天人等。皆生爱乐无有疑悔寿命得长。临欲终时所爱妻子及诸眷属。悉皆围绕身不受苦。乃至神逝所往之处。终不见阎罗王及诸狱卒。若临死时遇善知识。清净持戒心乐福田。舍此身已得生人中诸根聪利。复值善知识清净持戒。常乐福田断除诸恶。而求一切大菩萨行。入深智海遂得菩提。其所生处。常离刀杖诸恶国土。寿命长远自在净国离诸惊怖。如彼佛寿无量无边。亦复能作如是寿命。为诸众生说法教化。乃至佛涅槃后令法久住。善男子。是名菩萨摩诃萨最初轮也

菩萨若成就此轮。于声闻乘辟支佛乘无所阙失。于一切如来声闻弟子亦无阙失。不退大乘一切三昧诸陀罗尼及诸忍等。到于一切自在之地。常随善知识佛及菩萨得闻正法。供养众僧殖诸善根恒无厌足。修诸菩萨一切行愿亦无厌足。何以故。过去诸佛于此十恶皆悉远离。于一一恶不善业等亦不赞叹。以是之故。善男子。于此十善若能守一善业。以如是相所获果报亦如前说

复次善男子。菩萨摩诃萨修行不盗。能施一切众生。无惊无怖无畏亦无愁恼。己所有物如法饮食资身财业。恒求一切如法利益无非法欲。以此善根行业果报。假使曾于六趣流转没生死河。以不盗力故。身口意业所作众罪能障正法。乃至财业等障。自作教他见作随喜以不盗轮。皆悉辗除令无有余。亦令人天一切爱乐而无疑悔。乃至临命终时。妻子眷属一切围绕身不受苦。若命终后神逝所往。不见阎罗王及诸狱卒。恒遇所爱诸善知识。持戒清净心乐福田。乃至能离一切恶法。成就一切无量善法。随所生处得大财业有财业已能离怖畏。而悉不与水火贼共。乃至到于菩提。悉得众宝严饰佛国宝树具足。无我我所无取无著。成就一切众生行业。无我所无所受。无寿无众生。而悉调伏于彼佛国。善男子。是名菩萨摩诃萨第二轮也

若菩萨成就此轮。于声闻辟支佛乘悉无阙失。乃至如来声闻弟子亦无讥嫌而自于彼摩诃衍乘无有厌足。悉得一切诸三昧门及陀罗尼忍地。亦不舍于一切誓愿

复次善男子。菩萨摩诃萨终身远离邪淫。一切众生皆为欲流之所沉没。而能施于无畏无嫉无热恼害。于己妻色恒生知足无非法欲。以是善根果报力故。若有宿世邪淫果报。六趣生死流转诸有。自作教他见作随喜。而令悉离诸邪淫轮。辗断恶业令无有余。乃至成菩提道生于净国。无女人处第一清净。彼诸众生皆悉化生。不从父母和合受身。善男子。是名菩萨摩诃萨第三轮也

菩萨摩诃萨成就此轮。乃至不舍一切愿行

复次善男子。菩萨摩诃萨尽其形寿。离诸妄语常随顺语。以是因缘人天欢喜。乃至逮得菩提。不谄众生而生其国。所言真实无有虚伪。是名菩萨摩诃萨第四轮也

若菩萨成就此轮。乃至常求一切菩萨愿行。而无厌足终不暂舍

复次善男于。菩萨摩诃萨于终身中常离两舌。乃至以此善根至成菩提调伏众生。修六和敬来生其国。皆共一心互相恭敬。而无违失修质直法。善男子。是名菩萨摩诃萨第五轮。也

菩萨摩诃萨成就此轮。乃至常求菩萨行愿。无有厌足终不暂舍

复次善男子。菩萨摩诃萨远离恶口乃至成就菩提。耳终不闻不适意事。常生佛国恒闻种种柔软人声及音乐声。闻诸法声周遍佛国。志念成就梵音清彻。如是众生来生其国。善男子。是名菩萨摩诃萨第六轮也

若有菩萨成就此轮。从初发心乃至成佛。恒求菩萨一切行愿。而无厌足终不舍离

复次善男子。菩萨摩诃萨于其终身远离绮语。乃至菩提。常于佛国闻诸菩萨摩诃萨百千法音周遍佛国。而恒远离一切绮语。成就善语法语。如是众生来生其国。善男子。是名菩萨摩诃萨第七轮也

若菩萨成就此轮。乃至菩提。常求菩萨一切行愿。而无厌足终不暂舍

复次善男子。菩萨摩诃萨于其终身远离贪欲。乃至菩提。常生净国地平如掌众宝充满。亦以宝树而严饰之。复有若干种无价宝衣。璎珞幢幡金绳珠璎。而彼世界种种庄严罗网宝树。彼中众生远离憍慢我心贡高。颜貌端严诸根具足其心平等。如是众生来生其国。善男子。是名菩萨摩诃萨第八轮也

若菩萨能成就此轮。乃至菩提恒求菩萨一切行愿。而无厌足终不暂舍。复次善男子。菩萨摩诃萨。于其终身远离嗔恚。乃至菩提悉除一切垢恼秽浊尘云暴风。于彼净国无诸浊恶断除憍慢。生彼国已形色端正。相好第一诸根不缺。禅定慈悲以自严饰。如是众生来生其国。善男子。是名菩萨摩诃萨第九轮也

若菩萨成就是轮。乃至菩提。恒求菩萨所作愿行。而无厌足终不暂舍

复次善男子。菩萨摩诃萨于其终身远离邪见。复能以此离邪见轮。令诸人天一切爱乐。若有众生流转六趣没生死河。如是人等起身口意。一切业障及烦恼障而障正法。自作教他见作随喜。以此离邪见轮。碾断业结令灭无余。妻子眷属围绕左右。临命终时身不受苦。神逝所往亦终不见阎罗王等及诸狱卒。随善知识持戒清净。心乐福田恒生正信。命终之后得生人中。亦与善知识及诸持戒福田之人。而相遭遇还相依止令得正见。为善知识之所教授。修习善法恒离一切不善等恶。于诸善根皆悉成就。一切菩萨所行之道无不修习。以是因缘能度一切众生。入摩诃衍正法大海。乃至得菩提道。一切疑网及诸吉相常见断见。离我我所见。如此众生来生其国寿命无量。悉同法味皆是大乘。弃舍声闻辟支佛。及诸天魔一切外道并魔眷属。皆悉已离如是等恶来生其国。彼佛寿命无量无边。恒于其中而作佛事。般涅槃后令法久住。无所损减而更炽然皆悉一味。善男子。是名菩萨第十轮也

若菩萨摩诃萨成就此轮。于声闻乘辟支佛乘不生讥嫌。及二乘人亦无讥嫌。乃至大乘亦复如是。于大乘人能令增广炽然三宝。于诸如来声闻弟子。成器及不成器者亦无讥嫌。而能庄严摩诃衍道。一切三昧诸陀罗尼乃至忍地。恒善修学证胜进法。不离诸佛及大菩萨善知识等听法信受。乐供养众心无厌足。求诸善根终不暂舍。菩萨所行六波罗蜜亦无厌足。善男子。若能成就如是十轮者。菩萨摩诃萨。疾成无上正真道觉。何以故。过去诸佛修行十善离一切恶。能现如是种种果报因缘无量相貌。具菩提道悉断一切烦恼结使。尽竭三恶皆使无余。是故能令绍三宝种。久住于世常得炽然。使不复受三有之身向于涅槃。为断阴入界等入无畏城。以此远离十恶因缘。具足果报如上所说。以是义故。善男子。若于此十善不修一者。求于佛道而复自言。我是大乘皆应当得无上菩提。如此之人是大妄语。多行谄曲种种欺诳。于诸佛所能断一切众生善根趣向三恶。是故善男子。具足十善刹利大姓。婆罗门大家。四天王天。乃至非想非非想天。声闻乘辟支佛乘。修行如是十善功德。悉能具足阿耨多罗三藐三菩提故。善男子。以此十善而自庄严。求无上果修学大乘疾成佛道者。此则安立一切功德善根处所。若能守护十善。便于善根誓愿满足成无上道。尔时世尊欲重宣此义而说偈言

  以十轮觉悟　　欲离一切苦
  不应讥声闻　　恼着袈裟者
  随顺缘觉乘　　信心勤精进
  安乐诸众生　　而受行大乘
  一切诸缘觉　　觉了最胜法
  净修于佛道　　速证得菩提
  远离于杀生　　人天皆爱念
  生生得长寿　　善修无害业
  一切所生处　　常乐于佛法
  亲近世尊者　　速证得菩提
  若离于偷盗　　一切智所敬
  悉灭诸悭贪　　守护不盗戒
  生处常大富　　为他作施主
  而得严净国　　以众宝庄饰
  灭除烦恼秽　　干竭于爱欲
  能远离邪淫　　速得清净国
  永离欲淤泥　　解脱净众生
  令入于大乘　　由离邪淫故
  欲得圣智者　　赞叹于实语
  弃舍诸妄语　　悉灭于苦恼
  究竟得实语　　常值于诸佛
  速疾成菩提　　远离妄语故
  堪任为善器　　而远离两舌
  常与诸佛会　　永舍于断见
  得圣无染着　　逮总持辩才
  能知深法海　　不久得菩提
  常说柔软语　　远离于恶口
  众生所爱乐　　能灭先世业
  令众生欢悦　　菩萨之法将
  悉知诸佛行　　得入第十地
  智者所爱敬　　远离于绮语
  具足五功德　　所说皆觉了
  欲闻尊贤教　　及与求圣道
  供养诸佛海　　速得一切智
  一心除贪淫　　不坏于正法
  供养染衣者　　炽然三乘道
  常生清净国　　法将之住处
  于彼获妙智　　第一无上乘
  常行于慈心　　远离诸嗔恚
  速疾得禅定　　志乐贤圣行
  生于清净国　　远离一切过
  随佛所住处　　永离一切嗔
  专一修纯信　　远离诸邪见
  显示三乘道　　是名法供养
  免离于恶趣　　解脱值贤圣
  具足菩萨行　　逮得最上智
  安住而说法　　能成于菩提
  三昧总持忍　　皆由十善故
  具足轮威德　　悉碾除恶趣
  尽灭业结障　　疾成正法将

    大方广十轮经布施品第十

复次善男子。若成就十轮菩萨摩诃萨。从初发心一切五欲皆悉舍离。胜于一切声闻辟支佛人。亦能为彼二乘而作福田。何等为十。常行布施。所谓饮食衣服象马辇舆。乃至己身手足头目髓脑耳鼻皮骨血肉一一皆舍。若行施时不着躯命。亦不为己求世间法出世间乐。恒念度脱一切众生。修大慈悲巧方便智。如是心施于诸众生。为令一切皆得安乐故施。为灭一切众生结使故施。不受后有故施。不粗心故施。无嫉妒故施。乃至最下乞人亦如是施。不为受报故施。不求声闻辟支佛故施。求一切种智故施。乃至一人亦常如是修行于施。是名菩萨摩诃萨心施。成就初轮庄严法施

如是菩萨从初发心。能为一切声闻辟支佛作大福田。应当守护恭敬供养。何以故。一切声闻辟支佛。为断己身三恶趣贫。但自饶益而不为他修行布施。菩萨摩诃萨为断一切众生苦恼。以大慈悲哀愍心施。是故能为声闻辟支佛而作福田。不为于己而求果报。唯为最上第一乐故常行于施。终不染着人天生死五欲乐故修行于施。而为利益一切众生不念自身所受善恶修行于施。为断一切众生苦报修行于施。菩萨能如是行檀波罗蜜故。堪任为声闻辟支佛福田。若不染着世间五欲。而为具足大慈大悲能如是施。名为菩萨摩诃萨。亦名声闻辟支佛福田。假设修行无量布施。若不断于世间五欲不名为施。亦不名菩萨。不能与声闻辟支佛作大福田。不为贤圣所印。是故应断五欲无染着施。若染五欲则不名菩萨。亦非福田。如斯施者不能灭于烦恼少分。何况能除一切结习

尔时世尊欲重宣此义而说偈曰

  成就于施轮　　智者清净心
  尽离于五欲　　令众得妙乐
  乃至施少分　　皆为除众苦
  不令受少果　　应获上福田
  虽复种种施　　而不离五欲
  此施非圣印　　不堕决定聚
  舍欲而行施　　施微而报重
  声闻辟支佛　　俱以为福田
  是故应离欲　　常得清净施
  安乐诸众生　　是名真福田

复次善男子。菩萨摩诃萨有十种法施轮。若能成就十种法施轮者。速疾得日光三昧。能为一切声闻辟支佛作大福田。何等为十。所谓依止佛法。依止声闻法。依止辟支佛法。依止摩诃衍法。依止世间出世间法。依止有漏无漏法。尊重恭敬一切听受。随顺受持为他广说

若为声闻人说。应四谛法究竟涅槃。而无嫉妒憍慢之心。不为利养一切名称。亦不自举亦不轻他。恒为一切发大慈悲分别演说。不为说辟支佛法及与大乘

若为辟支佛人说。应十二因缘法。离老病死得尽苦际。都不为说声闻小乘菩萨等法

若为大乘人说。应六波罗蜜。具足诸行证无上道。亦不为说声闻辟支佛法。但随诸众生所应修行而为说之。于诸如来所演言教。乃至一句一偈。恭敬尊重终不诽谤。亦不隐没而作障碍。于说法人作世尊想。于听法者作病人想。于正法中作妙药想。弃舍五欲。为欲说法心常平等而不取相。善男子。是名菩萨摩诃萨十种法施轮也

若菩萨成就如是十种法施轮者。便速疾得日光三昧。能为一切声闻辟支佛作大福田。常为一切守护供养。尔时世尊欲重宣此义。而说偈言

  智者修法施　　演说于三乘
  不堪法器者　　终不令谤法
  声闻及缘觉　　多人而修习
  辟支佛利智　　教令入大乘
  但为成法器　　非法不妄说
  随诸根利钝　　渐教令升进
  于法常恭敬　　信受不诽谤
  有能说法者　　供养如世尊
  听法诸众生　　令灭于烦恼
  不贪著名誉　　利养而说法

    大方广十轮经持戒相品第十一

复次善男子。菩萨摩诃萨发大庄严具足戒轮。若成就此轮。从初发心远离五欲。于声闻辟支佛中。第一最胜为大福田。皆应供养而守护之

何等为菩萨摩诃萨庄严戒轮。善男子。菩萨摩诃萨。有能出家受其具足。成就波罗提木叉。而不与声闻辟支佛共。若菩萨不以此戒能为众生除诸烦恼一切邪见。是则不名为摩诃萨。亦不名为声闻辟支佛大福田也。善男子。若菩萨摩诃萨。于一切众生心常平等。护持净戒志念坚固而不退转。心恒专一不生异想。若见持戒破戒悭贪布施上中下等。有若干种无量众生。嗔恚恼害行住坐卧。于三有中阴入诸界而无分别。如是持戒。不着欲界持戒。不着色无色界持戒。不分别观察有想持戒。不为到不到故持戒

善男子。菩萨摩诃萨。以如是相貌。发大庄严清净戒轮。从初发心常离五欲。如是菩萨摩诃萨。则能为一切声闻辟支佛作大福田。亦为众生守护供养。尔时世尊欲重宣此义。而说偈言

  优婆塞律仪　　住于解脱戒
  虽与二乘共　　不名摩诃萨
  若修于空法　　不依于世间
  亦不依诸有　　智者护净戒
  不取于戒相　　清净离诸漏
  如是护戒者　　最胜之福田

    大方广十轮经忍辱品第十二

复次善男子。云何名菩萨摩诃萨发大庄严具足忍轮。若菩萨成就此轮者。从初发意能除五欲。堪为声闻辟支佛作大福田。亦为众生尊重恭敬供养守护

善男子。菩萨摩诃萨。忍辱有二种。一者世间。二者出世间。又菩萨有漏忍者则受诸有。亦不能无众生之想。依止果报依止功德。亦名住色声香味触忍。亦名羸劣忍。无所堪忍。悲愍念众生而修行忍。但是谄曲悦彼故忍。不为安乐众生故忍

如是忍者。则与声闻辟支佛同。非大庄严亦非菩萨但有假名。如是菩萨。终不堪任为诸声闻辟支佛作大福田。是名菩萨世间忍轮

云何名菩萨以大庄严出世间忍。为诸众生故。修行于忍而不染着。若于一切所作事务。言语相貌音声名字圣所住处。皆悉随顺而不舍于三结三受。三相三世。三有三业。如是等事悉不依止心恒寂灭而修行忍。是名菩萨出世间忍轮

善男子。菩萨摩诃萨成就如是大庄严忍轮。从初发心常离五欲。是诸菩萨摩诃萨。能为声闻辟支佛作大福田。为一切众生守护供养。尔时世尊欲重宣此义。而说偈言

  此忍说二种　　有相及无相
  有相修行忍　　智者所不贵
  有相说三业　　即依于忍聚
  是名有漏忍　　非是大人相
  于四颠倒中　　修于无著忍
  寂灭于三业　　是忍为最胜
  灭于一切行　　不依相无相
  心犹如虚空　　是忍为最胜
  众生皆一相　　诸法空寂灭
  心无有所著　　是忍最大利

大方广十轮经卷第七大方广十轮经卷第八

        失译人名今附北凉录

    精进相品第十三

复次善男子。菩萨摩诃萨成就大庄严精进轮。从初发心离五欲者。能为声闻辟支佛而作福田。亦为一切守护供养

善男子。菩萨摩诃萨精进有二种。一者世间。二者出世间。世间精进复有三种。一者修福精进。二者勇猛精进施戒禅定。三者缘于有漏及诸众生。依于果报福行住处。是名世间精进。则非摩诃萨也

复次菩萨摩诃萨。于一切众生心常平等。但为除灭烦恼业结而勤精进。于圣无漏无取无舍。亦无依止。无杂秽心。亦无乱想。持戒破戒。精进懈怠。布施悭贪。浊心慈心。如是一切皆悉平等而行精进。不于三界起种种想。于诸众生若闻言语造业处所。于阴界入无所取想而修精进。不依欲界。不着色界及无色界。不生到不到想而修精进。不着一切行。不依三种福而勤精进。菩萨摩诃萨成就如是大庄严轮。从初发意离于五欲。名为摩诃萨。亦复堪与声闻辟支佛作大福田。为诸众生守护供养

尔时世尊欲重宣此义。而说偈言

  染着六情根　　愚闇于四流
  精进常勇猛　　智者所讥嫌
  境界处精进　　善取于有漏
  不名为福田　　亦非摩诃萨
  智者勤精进　　除灭一切着
  心无所依止　　是名为福田
  不着于名色　　为众作归依
  勇猛离诸阴　　是名为福田
  照了于愚闇　　超度到彼岸
  如是精进轮　　断众烦恼缚

    大方广十轮经禅相品第十四

复次善男子。菩萨摩诃萨有大庄严禅定轮。若菩萨成就此轮。从初发意断除五欲。是则堪为声闻辟支佛福田。一切众生守护供养。善男子。菩萨摩诃萨修禅有二一者世间。二者出世间。云何名世间禅。若菩萨依于阴相。染着欲界色界无色界修禅。依止三解脱四念处四正勤四如意足五根五力七觉分八圣道分。乃至地水火风空识等。皆悉依止而生染着。如是修禅。是名菩萨修世间禅。亦与一切声闻辟支佛共。不得名为摩诃萨也。云何名出世间禅

善男子。所谓菩萨能出世间放大光明。不着四念处四正勤四如意足五根五力七觉分八圣道分。如是等法皆无依止而修于禅。乃至身口意戒。三解脱门。阴界诸入。三受四大。空处识处。不用处非想非非想处。今世后世悉离空静。不依止空大空。是名菩萨摩诃萨出世间禅

善男子。以如是相故。菩萨摩诃萨则能成就大庄严禅轮。从初发意离于五欲。堪为声闻辟支佛福田。亦为一切守护供养。尔时世尊欲重宣此义。而说偈言

  为舍重担故　　修于有相禅
  但断于己结　　不名为智者
  染着而修禅　　依止于解脱
  取着于彼岸　　不能利众生
  若为弃重担　　欲利诸众生
  灭结修诸禅　　是名真智者
  若断于有爱　　为利诸众生
  修于无相禅　　是名摩诃萨
  断除众生缚　　令世间无畏
  寂灭而修禅　　是名摩诃萨

    大方广十轮经智相品第十五

复次善男子。菩萨摩诃萨有大庄严智轮。若能成就如是大庄严智轮。从初发意离于五欲。则能堪为声闻辟支佛而作福田。亦为一切守护供养。善男子。菩萨摩诃萨有二种智一者世间。二者出世间。云何名世间智。所谓菩萨依止读诵。欲灭一切众生愚闇作大照明。如来所说种种无量。于声闻乘皆悉听受。自书使人书。自读诵亦教人读诵。若说辟支佛法及大乘法。皆悉随顺一切信受。若自读诵教人读诵。自书亦教人书。能为众生广说分别显示其义。读诵经法求诸无漏。八圣道分解脱之味。而不求于寂灭智慧。常有存相取着之心。是名菩萨世间智轮。亦与声闻辟支佛等无有异也。不可名为菩萨摩诃萨。云何名出世间智轮。菩萨摩诃萨修道之时。随其精进行住诵习。而于彼相不取不着不念不思惟。如是行类则非下劣心。如虚空同于寂灭。观法平等都无所著亦无所系。无生无灭心无退转。常行平等诸法实际。深入寂灭得无生忍。不取诸相心无增减。不依诸地亦不住智慧。菩萨若得如是具足智者。是名菩萨出世间智。有此行类则能成就大庄严智轮。从初发意不染五欲。亦能堪为声闻辟支佛福田。一切众生守护供养

复次善男子。菩萨摩诃萨有大庄严轮。若菩萨成就如此大庄严轮者。从初发心断除五欲。堪为声闻辟支佛作大福田。亦为一切守护供养

善男子。菩萨方便复有二种。一者世间。二者出世间。云何名菩萨世间方便。自为及人常怀彼此。种种伎艺而成就众生。能现如是若干种身。或现佛身。或现辟支佛身。或现声闻身。或现父母身。随所应见而为现相。若有病人及看病者。瞻视羸劣无有能救。一切怖畏乃至应死。悉以方便救令解脱。常行四摄成就众生住于大乘若声闻辟支佛人。有不堪任为大乘器根不熟者。即于二乘法中。令使修习如是甚深微妙之法。开示显现第一义谛。超过凡夫颠倒境界。依于四依具四辩才。四念处四正勤四如意足五根五力七觉分八圣道分。住善取道入方便智道成熟众生。若诸众生有为名称。染着利养诸根动摇。而不成就涅槃善根。如是等人教令习诵。如来所说声闻辟支佛乘。成就离施功德教令劝助。若有众生多起嗔恚。其心甚恶而无哀愍。教令修行四无量心而得成熟。若见懈怠如是众生教令精进。多嗔众生教行忍辱。散心众生教令禅定。愚痴众生为说正法。令修智慧教化成就。若有众生无所依止无恭敬教。心令开示归依三宝。有如是等教使修习优婆塞戒。亦教八戒斋法。或有众生以种种伎术著作务处。教化成就如是等辈。恒沙菩萨有世间方便智慧。菩萨摩诃萨成就如此方便智轮。以诸经论作务伎术。摧伏一切外道异学苦行智轮。是名菩萨摩诃萨。成就世间方便智。与一切声闻辟支佛共。

善男子。若有菩萨不依明师。亦不依止善知识。以是行类相貌。染着世间而自迷惑。如是菩萨。则不能住出世方便智轮。不名福田。亦不能善知众生诸行。若见不成法器众生。及声闻辟支佛乘根不熟者。于是人所显示大乘是名愚痴。无巧方便而教大乘人。舍菩萨道令修声闻辟支佛法。是为错谬不识人根。若见辟支佛人。教令舍离修声闻乘。不识人根而谬说法。有如是失堕于咎过。若见声闻人厌于生死者。为说世间三界果报乐着生死。不识人根而谬说法。有如是失堕于咎过。若有众生不断杀盗。乃至不断邪见。具行十恶诸不善根。见如是等而为显示菩萨大乘甚深之法。竟不说于恶道果报。生死受苦轮转诸趣。不识人根妄说诸法。堕于咎过亦名愚痴无方便智。若见乐持戒者为说布施。乐精进者为说持戒。乐忍辱者为说精进。乐禅定者为说忍辱。乐智慧者为说禅定。是名菩萨愚痴。无巧方便智轮。亦名世间智。则与一切声闻辟支佛共。亦不可名为摩诃萨也。云何名菩萨摩诃萨出世间方便智轮。若诸菩萨有所作业。皆为他人不念己身。作若干等种种伎术。乃至悉欲与人共之。如前所说。若有己利回施他人。见堪任器者而为说法。渐教声闻辟支佛乘。见辟支佛人。教令渐修摩诃衍乘。亦不为声闻人根不熟者。而为说乐生死法。为有杀生乃至邪见。为说声闻法生死所趣。若乐修施者。为说无上伎术。乃至乐智慧者。为说贤圣无漏智道。以是智慧成就众生。不取众生想及智慧想。是名菩萨摩诃萨能出世间最大庄严方便智轮。若菩萨摩诃萨成就此轮。从初发意断除五欲。是名菩萨摩诃萨堪为声闻辟支佛作大福田。常为一切守护供养。尔时世尊欲重宣此义。而说偈言

  应说一乘道　　而为演二乘
  则为目欺诳　　不名度众生
  决定堕邪聚　　而示下劣乘
  是则为愚痴　　不名摩诃萨
  趣向一乘者　　为欲听法故
  乐处于生死　　智者之所说
  决定专一心　　随欲而教化
  是名为方便　　智者所赞叹
  一向为声闻　　教令生厌恶
  堪任为器者　　教以摩诃衍

复次善男子。菩萨摩诃萨。取法之慈而庄严轮不取众生相。何以故。取众生慈而庄严者。则是声闻辟支佛行。不能庄严大乘道也。声闻辟支佛虽修于慈。但自为己不为利人。为自调伏灭己结业。尽诸烦恼已得涅槃。为我人众生而修行慈。于他众生心常放舍。是故不名为大庄严轮。唯断己结不能为人除诸烦恼。菩萨摩诃萨则不如是。常为一切众生修行慈心庄严大慈。名为菩萨摩诃萨。无依止慈。不依止阴界入故而修行慈。不依止四念处四正勤四如意足五根五力七觉分八圣道分而修行慈。不依止欲界色界无色界而修行慈。不依止此世后世故而修行慈。不依止此岸而修行慈。不依止彼岸而修行慈。不为不到故而修行慈。菩萨摩诃萨。唯缘法故而修行慈。此非声闻辟支佛之所能行。唯诸菩萨摩诃萨。乃能成就如是大庄严缘法慈轮。若菩萨从初发意离于五欲。如是菩萨摩诃萨。堪任声闻辟支佛作大福田。亦为一切众生守护供养

复次善男子。菩萨摩诃萨修大悲轮。从初发意断除五欲。名为摩诃萨堪为声闻辟支佛作大福田。常为一切众生守护供养。何以故。一切声闻辟支佛。但自为己而修悲故。菩萨摩诃萨则不如是。而自亡己为一切众生故而修行悲。是故堪为一切众生作大福田。如是菩萨摩诃萨。能兼他人修四摄法。为成熟众生故。乃至舍己支节身命及以财物。以此大悲为欲安乐诸众生故。亦不得众生相。不得施者相。不得受者相。乃至不得施业果报相。行檀波罗蜜时。不取行相爱语利益及同事相。虽行四摄而不取相。常以最胜心第一心寂灭心。乃至无量阿僧祇心。无行阴界入心。无动摇而常安住。庄严大悲寂灭心成就众生。

善男子。以如是相能大庄严。不与一切声闻辟支佛共。菩萨摩诃萨具足成就此大悲轮。从初发意断除五欲。堪为声闻辟支佛作大福田。常为一切众生守护供养。尔时世尊欲重宣此义。而说偈言

  此法难思议　　甚深如虚空
  无色无所住　　大悲之所成
  常勤行头陀　　菩萨最上智
  大悲勇进力　　超过一切人
  众生无归依　　生死苦所缚
  普欲令解脱　　大悲水洗除
  干竭生死海　　则非声闻地
  及与缘觉乘　　菩萨所哀愍
  贪欲恚愚痴　　众生没恶道
  以此大悲水　　洗浴苦众生

复次善男子。又有广遍虚空无边无有量数种种差别音声辩才一切三昧总持忍辱大庄严轮。菩萨摩诃萨若成就此轮。从初发意断除五欲。则能堪为声闻辟支佛作大福田。一切皆应供养守护

云何名为菩萨摩诃萨广遍虚空无边无量种种差别音声辩才一切三昧总持忍辱大庄严轮。所谓菩萨照明一切法。犹如月光普照天下。无相无依心无所染。于诸三昧身心不动。眼眼触眼识悉皆不动。若眼缘触内生三受。苦受乐受不苦不乐受。生寂灭心与无生心。耳鼻舌身。乃至心意意识无生亦如是。能生三受寂灭心无生心。三世阴界入一切亦皆无生无有动摇。三界三行三戒。三乘三解脱。三根三触。亦寂灭心无生心。一切处无住。皆行无相檀波罗蜜。乃至持戒忍辱。精进禅定。智慧波罗蜜皆住寂灭心无动乱。四念处四正勤四如意足五根五力七觉分八圣道分。皆住不动。九次第定亦不动。乃至三行如不如相亦悉不动。知一切法悉无所障住八圣道。窟宅及非窟宅。有取无取。有漏无漏。有此彼岸。无此彼岸。无大无小。有作无作。有善无善。有记无记。于一切处而心不动。乃能如是大慈大悲兴大方便。为成熟众生守护三乘及四无畏。分别十地乃至十八不共法。于一切处皆住无作无起心常安住。取相三受皆悉寂灭。菩萨摩诃萨离一切相。得虚空眼火光照明三昧一切三昧王方便大庄严轮。若菩萨住是三昧。则能灭除过去诸业。三恶趣苦皆悉消灭令尽无余

善男子。譬如五日出时。一切泉流河池及诸大河。四大海水皆悉枯竭。如是菩萨摩诃萨。以广遍虚空无边无量阿僧祇譬喻言辞巧说辩才一切三昧总持忍辱大庄严轮。菩萨若能成就此轮。灭尽三有除诸恶趣。于过去世所有业障永灭无余

善男子。譬如世界劫欲尽时。此四天下及八万四千诸河渚等。并四天王一切诸山。皆悉败坏消灭永尽令无有余

善男子。菩萨摩诃萨亦复如是。成就一切三昧诸陀罗尼忍辱轮者。能灭先世所作恶业。乃至三有一切恶趣永尽无余

善男子。譬诸黑闇遍满虚空。日轮出时一切黑闇皆悉除灭。菩萨摩诃萨亦复如是。若能成就是大庄严轮。乃至一切三昧总持忍辱轮。己身及他颠倒诸闇皆悉消灭。如是虚空无边智日。悉能消灭先世诸恶不善使业永尽无余。是菩萨不随恶知识。常不离诸佛而听正法。乃至不离诸菩萨行。于其梦中心常念佛

何等是菩萨摩诃萨大庄严遍满虚空广大无边无量阿僧祇种种言辞音声辩才一切三昧总持忍辱轮

菩萨摩诃萨。入于初禅乃至第四禅。入空处乃至非想非非想处。入满足灭尽定。乃至满足灭三行心。无动受心。想触意行寂灭不动。或住一日一夜。乃至七日七夜住于禅味。亦住第一义空。身诸毛孔出于暖气。烧灭一切结使业薪。如是次第逮深正念。一切身体悦乐满足

譬如自在天子入现一切乐三昧。入是三昧已。一切身毛孔中皆悉受乐。如是乐相触菩萨身。而便自忆念佛。念佛已即便见佛无复余相

若念一佛则见一佛。若念无量佛则见无量佛。若念佛身少分则见少分。若念佛无边身则见无边身。若观自身作佛相者。则见己身同佛相好具足庄严。若观他身欲作佛者。则见他身亦同其佛庄严相好。若欲随观众生皆作佛相者。则随所观同佛身相余无所见。心所起念皆实不虚。知一切法如幻如水中像。悉观三受三行永尽消灭

如是观已还入灭尽定禅悦味食或于一七日二七三七。乃至七七日。或十日五十日。如是乃至百千万亿劫。还入实谛空观如前念佛。成就作是观已

善男子。以如是相广大遍满虚空无量无边阿僧祇种种言辞音声辩才一切三昧总持忍辱轮

菩萨成就如是轮故。断除五欲。灭尽过去一切恶业。三有六趣皆悉消灭令无有余。堪为声闻及辟支佛作大福田。亦为一切守护供养。离四颠倒愚痴大闇。不复更随诸恶知识。常不离佛得闻正法。乃至梦中见佛听法供养众僧。于一切菩萨所行之道。疾成阿耨多罗三藐三菩提得净佛土。于彼佛国一切众生悉皆化生相好如佛。住摩诃衍结使微薄。尔时世尊欲重宣此义。而说偈言

  堪任法器者　　则破诸结使
  能住于善住　　皆悉无疑难
  为欲断有缚　　当作大庄严
  修学诸禅定　　智慧不思议
  修学于诸禅　　观第一寂灭
  以此念佛智　　能尽一切恶
  相与无相等　　以空悉能灭
  永断于恶趣　　不离见诸佛
  善修学诸法　　供养一切佛
  疾成于正觉　　以修空相故
  为众作亲友　　除舍诸结使
  是名净福田　　疾近于菩提
  众生作佛相　　遍满诸世界
  为求佛道故　　远离于二乘

说是法时。恒河沙等无量菩萨。本所曾闻念佛正法。若有废忘今悉还得。无量众生闻是念佛百千三昧。悉入一切三昧方便。皆得忆念总持华鬘。无量众生而皆依止首楞严三昧。乃至成就电光三昧。得一切法照明逮无生忍。远尘离垢得法眼净。无量众生得须陀洹果。斯陀含果。阿那含果。阿罗汉果

无量众生皆求出家入佛法中。无量众生住于十善。有发声闻心者。有发辟支佛心者。有发阿耨多罗三藐三菩提心者。得不退转者。无量众生得世间正见。以正见因缘故断恶趣结。皆得生天及在人间。归依三宝弃舍五欲。于佛法中而得出家。离一切邪见得清净信

尔时世尊告金刚藏菩萨摩诃萨。善男子。汝当以此不退法轮。授地藏菩萨记。若有众生读诵此经。为他解说住是法者。应当拥护十法

何等为十。拥护一切财物。离一切恶。一切邪见。邪归依十恶。一切身过。一切口过。一切诽谤。一切破戒。一切横病。一切横死。如是众生临命终时。皆得见佛即生天上。若有众生读诵此经。应当拥护如是十法。是名诸佛伏藏。佛说是经已时。四部众及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。及地藏菩萨等。闻是经已欢喜奉行

大方广十轮经卷第八


大集大虚空藏菩萨所问经

    No. 404 [No. 397(8)]

大集大虚空藏菩萨所问经卷第一

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

如是我闻。一时薄伽梵。在如来境界宝庄严道场。而此道场皆是如来之所加持。积集广大福德资粮。大行等流之所成就。是诸菩萨所住宫殿。演说无边甚深法处。亦是如来游戏神通无碍智境。能生广大善巧念慧。入无所有智所行处。尽未来世称赞无量殊胜功德。世尊现证一切诸法。平等自在善转无上清净法轮善能调伏诸弟子众。善达一切有情意乐。善知一切诸根彼岸。善断一切烦恼结习。于诸佛事任运施作无有休息与大苾刍众六百万人俱。此诸苾刍皆是如来法王之子。心善解脱慧善解脱。已断一切烦恼结缚。善说一切甚深佛法。复能通达于无相法。端严殊特具足威仪。为大福田增长之处。善住如来之所教令

复有菩萨摩诃萨众。从诸佛刹而来集会。其数无量不可思议不可譬喻不可言说。此诸菩萨于刹那顷。游戏无边诸佛世界。供养奉事一切如来。劝请说法闻法不厌。常恒成熟一切有情。善巧方便能到第一清净彼岸。住无碍解超越种种分别戏论。位皆邻近一切智智。其名曰电天菩萨战胜菩萨。遍照菩萨勇健菩萨。摧疑菩萨奋迅菩萨。观察眼菩萨常舒手菩萨。与如是等上首菩萨摩诃萨俱

尔时世尊为诸菩萨摩诃萨。说大集会甚深法时。一切大众处在虚空住宝楼阁。而此楼阁庄严殊胜。犹如大庄严世界中一宝庄严佛土。诸菩萨众所住楼阁无有异也。是诸大众各各相见皆坐其中。时此三千大千世界一切色像。苏迷卢山轮围山。大轮围山赡部洲等。聚落城邑江河泉流。陂池大海丛林草木。一切地居所有宫殿。悉皆隐蔽而不复现。欲色空居乃至有顶。诸天宫殿及诸有情。形色之类亦悉不现。犹如劫烧火灾之后。大地焚爇唯有虚空。中无一色为眼所见。此亦如是三千大千世界之中。无一色相为诸有情眼所睹见。唯除此宝庄严道场声闻菩萨。诸天龙药叉乾闼婆等。一切众会所有色像了然显现。又此道场有师子座自然涌出。其量高广万踰缮那。此师子座出净光明。普照三千大千世界。映蔽日月释梵护世。所有诸光皆不复现。佛坐其上时诸大众。见此奇特胜妙相已。踊跃欢喜叹未曾有。互相谓言如是殊胜庄严楼阁善巧差别。假使我等住一劫寿说莫能尽

尔时舍利子承佛威神。从宝楼阁起住虚空。整理衣服偏袒右肩。胡跪合掌而白佛言。世尊是何因缘先现此瑞。于此三千大千世界所有色像。悉皆隐蔽如大虚空。唯有如是所居众宝庄严楼阁自然显现。佛告舍利子汝今见此宝楼阁不。答言已见。佛言舍利子汝能赞叹此宝楼阁功德尽不。舍利子言尽我寿量不能称赞真实功德。如是舍利子有世界名大庄严。彼中所有妙宝楼阁一切众会皆住虚空。今此楼阁如彼所现。舍利子白佛言。世尊彼大庄严世界今在何许。佛告舍利子。东方过此八佛世界微尘数佛土。有世界名大庄严。佛号一宝庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。舍利子以何因缘名大庄严。彼世界中所有庄严殊胜之事。若我住世以一劫寿说不能尽。是故名之为大庄严。复以何缘名为一宝庄严。彼佛常说唯以大菩提心而为其宝。是故名为一宝庄严。彼佛说法与诸菩萨升师子座及宝楼阁。踊在虚空高八十俱胝多罗树。为诸菩萨说虚空清净法印。善男子云何名为虚空清净法印。所谓一切法离性无性故。云何离性无性。谓一切法无所表示故。云何无表示。谓一切法无光显故。云何无光显。谓一切法远离缘虑故。云何无缘虑。谓一切法寂静相故。云何寂静相。谓一切法无二相故。云何无二相。谓一切法远离别异故。云何无别异。谓一切法入一道相故。云何入一道相。谓一切法自性相清净故。云何自性相清净。谓一切法超过三世故。云何超过三世。谓一切法无依处故。云何无依处。谓一切法无影像故。云何无影像。谓一切法超过境界故。云何过诸境界。谓一切法内外清净故。云何内外清净。谓一切法性无杂染故。云何无杂染。谓一切法性寂静故。云何性寂静。谓一切法远离心意识故。云何离心意识。谓一切法出离相本不生故。云何出离相本不生。谓一切法无我摄受故。云何无我摄受。谓一切法无主宰故。云何无主宰。谓一切法性无我故。云何性无我。谓一切法本来清净故。云何本来清净。谓一切法本无涅槃故。云何无涅槃。谓一切法性。如幻故云何性如幻。谓一切法无实事故。云何无实事。谓一切法无造作相故。云何无造作相。谓一切法远离身心相故。云何远离身心相。谓一切法离相无相故。云何离相无相。谓一切法自相不动故。云何自相不动。谓一切法无所依止故。云何无所依止。谓一切法无所缘故云何无所缘。谓一切法远离阿赖耶故。舍利子彼一宝庄严如来。为诸菩萨说如是三十二虚空清净法印。时无量菩萨知诸法性与虚空等。得法自在清净智忍。舍利子彼大庄严世界所有菩萨。以布施庄严。于无量劫随顺舍故。以净戒庄严身心清净无诸垢故。以忍辱庄严于诸有情无害心故。以精进庄严积集一切法资粮故。以静虑庄严游戏一切解脱等持等至故。以智慧庄严远离一切烦恼习故。以大慈庄严拔济一切有情故。以大悲庄严不舍一切有情故。以大喜庄严于一切有情常喜悦故。以大舍庄严于一切有情无憎爱故

复次舍利子。彼一宝庄严如来世界中。有菩萨摩诃萨名大虚空藏。以大福德及大威力。而自庄严获无碍智。以相好庄严于身。以辩才庄严于语。以胜定庄严于心。以多闻总持庄严于念。以平等舍庄严于实。以慧庄严于诸趣意乐。以胜进加行庄严于增上意乐。到于一切法无疑惑故。以神足庄严游戏自在诸神通故。以福德庄严获宝手功德常施舍故。以智庄严分别有情种种意乐故。以觉庄严令诸有情悟胜法故。以眼庄严能于五眼得清净故。以耳庄严闻诸法义如响应故。以无碍解庄严法义词辩无尽说故。以力庄严得佛十力坏魔怨故。以无畏庄严摧诸外论无所屈故。以功德庄严获佛无边诸功德故。以法庄严于众毛孔演法如响故。以明庄严能见一切佛法藏故。以光庄严照耀一切诸佛刹故。以记心庄严无错谬故。以教诫庄严令如说行故。以神境庄严变现一切种种相故。以一切佛赞叹庄严住无系属得自在故。以一切善法庄严入一切佛法境故。舍利子。彼虚空藏菩萨摩诃萨。成就如是无量功德。与诸菩萨发意欲。来诣此娑诃世界。瞻仰于我恭敬礼拜奉事供养。亦为分别此大集会微沙法门。令斯十方诸来菩萨。生大喜悦清净信乐。又令菩萨摄受大摄受道法故

尔时大虚空藏菩萨摩诃萨。与十二俱胝菩萨前后围绕。一心瞻仰一宝庄严如来。白言世尊我今欲诣娑诃世界礼拜供养释迦牟尼佛。愿见听许。彼佛告言今正是时。随汝意往。即时顶礼一宝庄严如来足已住对面念。承佛游戏无行神通。从彼国没忽然不现。一念之顷与众菩萨。至此娑诃世界宝庄严道场。住于虚空散彼世界众妙花香如雨而下。所谓末香涂香幢幡缯盖。月花大月花妙殊胜花。日月光花日灯花日精花。爱花大爱花照曜花娑闼罗花。胜妙娑闼罗华遍无垢花。清净无垢花金光照曜花。虚空照曜花大白香照触花。百叶千蕊花除忧花。作喜花天所赞花。龙花安乐生喜花。禅枝花令身快乐花。令心欢喜花香遍三千世界花。息除众病华妙威德庄严花。流出无边福德花照触十方菩萨华。雨如是等种种妙华积高至膝。周遍三千大千世界。时诸大众见此花已。白言世尊如是种种胜妙诸华。众妙妓乐。昔所未见昔所未闻。从何所来愿见开示。佛言是彼大虚空藏菩萨摩诃萨。从大庄严世界而来此会住在虚空。先雨如是胜妙诸花。供养于我及此经法

尔时大虚空藏菩萨摩诃萨。与俱来菩萨从空而下。头面礼足绕佛三匝。住一面立而白佛言。世尊彼一宝庄严如来。问讯世尊少病少恼起居轻利安乐行不。此有十二俱胝菩萨。昔以曾受世尊化导。与我俱来诣此娑诃世界。为欲听闻大集经故。彼世尊为欲令诸菩萨。于一切法得自在故。成就大法故。唯愿世尊哀愍摄受。为说如是甚深法要

尔时大虚空藏菩萨。即于空中变大宝盖。众宝庄严覆如来顶。光明照耀遍彻十方。升于如来师子之座。其座高广万踰缮那。于是大虚空藏菩萨。合掌赞佛说伽他曰

  上法功德妙智尊　　清净无垢无限量
  如空平等寂无动　　敬礼甚深无与等
  能示身相微妙色　　不离法身现是身
  悲随有情身亦然　　普现百福庄严相
  已离音声无闻见　　断诸言词无说示
  虽知语性如空响　　以大悲心而演说
  于诸有情心平等　　知心如幻无自性
  悉知心行无思虑　　平等究竟心为心
  示现种种度世间　　善逝身形无所得
  以妙所依功德体　　随其所乐为现身
  法无所得佛亦然　　不着于法离分别
  知法能度有情故　　随宜为说常无间
  大众普共观佛身　　所现色相皆差别
  世尊已离身心相　　随现皆令众欢喜
  因缘和合诸法生　　虚妄分别非真实
  以知诸法悉如是　　得成正觉证涅槃
  既断分别离中边　　知其空寂无自性
  虽知诸法性清净　　善脱业果无差违
  法无有情寿及人　　寂然如空离名字
  了彼有情实非有　　悉令证入甘露门
  已修百亿行难思　　精进求于无上道
  由此因缘已成办　　到无行处觉涅槃
  妙觉诸法性无殊　　于上中下皆平等
  住平等智无分别　　故佛常无不定心
  知蕴处界皆如幻　　三界犹如水中月
  有情如梦性非真　　为说如此非真法
  世谛说成无上觉　　不可说得无得相
  菩提无得轮亦然　　转无转相无所转
  自度度他于彼岸　　自解解他诸系惑
  自安安他置大乘　　自他俱证涅槃乐
  有情无生亦无灭　　有情本来常清净
  有情自性如幻相　　有情既悟证菩提
  色如虚空无有生　　一切世间亦如是
  是法无色离色相　　由知是义色寂静
  以喻称赞如来德　　有请闻赞皆深着
  佛德如空不可量　　如是无二真赞佛
  敬礼能觉诸有情　　无观无心至无得
  唯有诸佛能赞佛　　我礼如如真德尊
  了诸有情无我人　　诸佛法界同一相
  已知诸法离欲相　　故我供养平等尊

尔时大虚空藏菩萨摩诃萨。说是伽他已。即时宝庄严道场妙宝楼阁六种震动。空中出声而作是言。释迦牟尼世尊。于无数俱胝那庾多百千劫中。所有积集阿耨多罗三藐三菩提法。此大虚空藏菩萨。以妙伽他悉能称扬。善男子若于梦中。尚未曾闻何况得见。若有善男子善女人闻此伽他。能生信解解已修行。当知此人渐次不久。能师子吼如虚空藏菩萨

尔时大虚空藏菩萨摩诃萨白佛言。世尊我为欲闻大集经典。故来至此娑诃世界。瞻仰世尊礼拜供养听闻斯法今此众中诸来正士。各各于法而有疑心。唯愿世尊。令于诸法得法光明生决定慧。善哉世尊。我今欲问决定之义。唯愿如来少赐方便。何以故世尊是无碍智者。善知一切有情诸根前后熟故。世尊得光明者。离诸闇瞑故。世尊知义者。善能分别诸句义故。世尊知时者。不越时授记故。世尊智宜者。于诸有情随宜说法故。世尊游戏者。于诸神通得自在故。世尊净观察者。了有情心行如掌中故。世尊高大者无能见顶故。世尊勇健者。三千界中无能陵屈故。世尊自然者。无师证悟一切法故。世尊导师者。于诸道中示正路故。世尊大医王者。以甘露药能永除断有情惑障缠盖病故。世尊持大力者。得于是处非处乃至三明故。世尊大无畏者。于一切世间沙门婆罗门诸天魔梵之中。大师子吼无所畏故。世尊成就不共法者。获得三世无碍智身口意清净。三摩钵底解脱知见等不共法故。世尊住大慈者。以无碍慧于诸有情。平等观察如虚空故。世尊住大悲者。以平等慧于诸有情。善行恶行若苦若乐无所动故。世尊住大喜者。行于禅定解脱到彼岸故。世尊住大舍者。心无憎爱如虚空故。世尊住平等者。入一切如来平等智故。世尊无希望者。智慧满足远名利故。世尊一切智者。五眼清净见一切法悉究竟故。我知世尊成就如是无量无边功德。我等今者爱乐法故。于此法中欲小咨问。令诸有情于平等法。方便出生一切智智

尔时佛告虚空藏菩萨摩诃萨言。善哉善哉正士汝于殑伽河沙佛所。已得授记。我今听汝随有所问。当为分别令得欢喜。于是众中有菩萨摩诃萨。名功德王光明。问虚空藏菩萨言。汝为何故问于如来。时大虚空藏菩萨即以伽他而答之曰

  普心等于诸有情　　妙心等住于彼岸
  悟心无心入妙理　　是故我问于世尊
  得光无暗清净者　　无疑能断彼疑惑
  为令决定得解脱　　是故我问于世尊
  知我无我悉清净　　常利有情住无我
  解脱有情我见缚　　为此等故问世尊
  威仪善住于净戒　　意乐清净虚空等
  坚固不动若迷卢　　是故我问功德者
  精进无边勇无退　　能摧我慢众魔怨
  自净净彼烦恼缠　　故我请问端严者
  乐闻施戒忍精进　　禅定解脱发诸通
  清净无垢胜慧明　　故我问于清净义
  住空无相无愿者　　示现生死或涅槃
  无生无住无去来　　故我问于清净智
  甚深知见无涯际　　声闻缘觉及余众
  无能难问不可测　　我为如是问世尊
  乐于正法能通达　　法与非法俱无取
  常于善法心不乱　　是故我问如来法
  不断佛种诸贤士　　能护正法及僧伽
  名闻三世诸佛称　　故我问于功德海

尔时大虚空藏菩萨。以伽他答功德王光明菩萨已。白佛言世尊。云何菩萨修行布施波罗蜜多犹若虚空。云何修行净戒忍辱精进禅定般若波罗蜜多犹若虚空。云何修行福德智慧二种庄严犹若虚空。云何不舍离佛随念不舍离法随念僧随念舍随念戒随念天随念。云何菩萨修行诸行等于涅槃。云何菩萨善知一切有情行相。云何能持佛法宝藏。如来等觉彼法性相如实而知。云何菩萨善知有情本来清净而成熟之。云何菩萨如理相应。修习佛法至于究竟。云何菩萨不坏神通。于一切法而得自在。云何菩萨得住甚深佛法理趣。一切声闻及辟支佛所不能测。云何菩萨入缘起善巧智。远离一切边见。云何菩萨以如来印印于真如。不间断善巧智。云何菩萨入于法界甚深理趣。见一切法互相周遍平等一性。云何菩萨意乐坚固犹若金刚。于此大乘无有倾动。云何菩萨于自境界清净如佛境界。云何菩萨得陀罗尼无忘法行。云何菩萨获得如来加持无碍辩才。云何菩萨于生死中而得自在。云何菩萨摧伏怨敌超越四魔。云何菩萨积集无量福德资粮。为诸有情作所依止。云何菩萨出无佛世。为诸有情而作佛事。云何菩萨获得海印三摩地。不染一切有情心行。云何菩萨得无染着。心如虚空风无有障碍。云何菩萨善知轨仪。修行离暗获得光明。不随他缘得自然智。速到大乘一切智智

尔时佛告大虚空藏菩萨摩诃萨言。善哉善哉正士。复言善哉善哉正士。汝今善能问于如来如是深义。能为有情发如是问。汝能明了一切佛法。已曾供养奉事过去无量诸佛。于诸佛所种诸善根。被精进甲求法无厌。以智慧器杖出诸魔境。常乐利益一切有情。超越世间毁誉八法。心行平等犹若虚空。久已积集一切智智。如汝功德边际叵量。已于恒沙过去佛所曾问斯义。是故正士谛听谛听善思念之。吾当为汝分别解说菩萨摩诃萨所获功德。到于大乘一切智智。虚空藏菩萨言。唯然世尊愿乐欲闻

佛告大虚空藏菩萨言。善男子菩萨成就四法。修行布施波罗蜜多犹若虚空。云何为四。所谓以我清净故有情清净。以有情清净故施即清净。以施清净故回向清净。以回向清净故菩提清净。善男子是为菩萨成就四法。修行布施波罗蜜多犹若虚空。复次若菩萨成就八法。能净修行布施波罗蜜多。云何为八。所谓我清净施。我所清净施。因清净施。见清净施。相清净施。异相清净施。不望果报清净施。心平等如虚空清净施。是为菩萨成就八法。能净修行布施波罗蜜多。善男子。譬如虚空无有边际。菩萨无限行施亦复如是。譬如虚空宽广无碍。菩萨回向行施亦复如是。誓如虚空无色。菩萨离色行施亦复如是。譬如虚空无有受者。菩萨离受行施亦复如是。譬如虚空无所染着。菩萨远离染着行施亦复如是。譬如虚空无所为作。菩萨远离有为行施亦复如是。譬如虚空无有识想。菩萨离于识想行施亦复如是。譬如虚空遍诸佛刹。菩萨大慈行施遍缘恒沙诸佛国土一切有情亦复如是。譬如虚空无有穷尽。菩萨不断三宝种回向行施亦复如是。譬如虚空无有暗瞑。菩萨行施离烦恼暗亦复如是。譬如虚空无相显现。菩萨行施心体清净亦复如是。譬如虚空含容一切。菩萨行施普摄有情亦复如是。又如变化人施变化者。无心分别不希其报。菩萨行施亦复如是。皆如幻化远离能所不希果报。善男子菩萨行施以胜智慧舍诸烦恼。以方便智不舍有情。是为菩萨修行布施波罗蜜多犹若虚空

尔时灯手菩萨摩诃萨。在于会中即从座起白佛言。世尊菩萨摩诃萨。以何等相修行如是布施波罗蜜多。佛言善男子菩萨摩诃萨。应以无相修行如是布施波罗蜜多。何以故以一切法无身相身相清净故。无有情相有情相清净故。无法相法相清净故。无智相智相清净故。无慧相慧相清净故。无心相心相清净故。无世间相世间相清净故。无色相色相清净故。无见相见相清净故。如是乃至无暗无明离一切相。无相究竟边际获无尽忍。得于如来决定记莂。住于菩萨尼夜摩位。以不退印印之。得佛灌顶成就一切平等佛法。善知一切有情行相。菩萨以如是行修行布施波罗蜜多。说是法时万六千菩萨。于诸法中见诸法性。犹若虚空获无生法忍。尔时世尊说伽他曰

  心常清净恒行施　　为求菩提不望报
  施已欢喜无追悔　　是为妙施得解脱
  智者知法皆如幻　　不顾身命及以财
  于余资具皆不贪　　志佛菩提心决定
  悉皆等施无憎爱　　不生退没恒进修
  由观诸法如虚空　　是故无喜亦无厌
  知法性相本清净　　菩提与施亦复然
  由于所施不生贪　　故常能舍无戏论
  平等普施离思虑　　于上中下无分别
  意乐清净常无垢　　所有慧施离悕望
  知身幻化皆无常　　财亦不坚如梦电
  即生悲愍世间故　　而能常施不染世
  无我行施烦恼净　　即能建立于佛教
  不为魔罗所得便　　如是施心难校量
  十力所说此施心　　应住清净尸罗行
  由此善修获静虑　　智慧便能速圆满
  施戒与心俱清净　　烧诸结使不复生
  自他皆获于利益　　能得无为涅槃乐
  为除贪结行于施　　是故不染亦不着
  惠彼令无于苦恼　　自成清净菩提因
  所施心无于退没　　由斯得见菩萨性
  已见菩提清净德　　则能度于无量众

大集大虚空藏菩萨所问经卷第一大集大虚空藏菩萨所问经卷第二

        开府仪同三司持进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时世尊复告大虚空藏菩萨摩诃萨言。善男子菩萨成就四法。修行净戒波罗蜜多犹若虚空。云何为四。所谓知身如影像。知声如谷响。知心如幻化。知慧如虚空。是为菩萨成就四法。修行净戒波罗蜜多犹若虚空。复次若菩萨成就八法。能净修行净戒波罗蜜多云何为八。所谓不离菩提心戒清净故。离声闻缘觉心得无限量心戒清净故。不舍一切学处智慧清净故。于一切处受生愿清净故。于戒不缓任运无作行清净故。回向菩提魔罗心清净故。心无热恼烦恼清净故。大愿圆满菩提清净故。是为菩萨成就八法。能净修行净戒波罗蜜多。善男子譬如虚空清净。菩萨持戒清净亦尔。譬如虚空无有垢秽。菩萨持戒无垢亦尔。譬如虚空寂静不乱。菩萨持戒寂静亦尔。譬如虚空无有边际。菩萨持戒无边亦尔。譬如虚空无有系属。菩萨持戒无系亦尔。譬如虚空无有执着。菩萨持戒离着亦尔。譬如虚空无可积集。菩萨持戒无积亦尔。譬如虚空不离于性。菩萨持戒不离亦尔。譬如虚空其性常住。菩萨持戒常住亦尔。譬如虚空究竟无尽。菩萨持戒无尽亦尔。譬如虚空无有形相。菩萨持戒离相亦尔。譬如虚空无有来往。菩萨持戒无动亦尔。譬如虚空无有戏论。菩萨持戒离戏亦尔。譬如虚空远离诸漏。菩萨持戒无漏亦尔。譬如虚空无所为作。菩萨持戒无为亦尔。譬如虚空无有变易。菩萨持戒不变亦尔。譬如虚空无有分别。菩萨持戒无取亦尔。譬如虚空遍一切处。菩萨持戒周遍亦尔。譬如虚空无有破坏。菩萨持戒无犯亦尔。譬如虚空无有高下。菩萨持戒平等亦尔。譬如虚空性离于染。菩萨持戒无染亦尔。善男子是为菩萨修行净戒波罗蜜多犹若虚空。尔时世尊说伽他曰

  护戒寂静心无垢　　能除热恼无所得
  身语意业无瑕疵　　一切律仪皆具足
  智者不以戒憍逸　　内心恒寂而无乱
  智者常依菩提心　　而于心意不染着
  远离诸业无思虑　　如是不生诸分别
  既离青黄及赤白　　亦不住于名色中
  无取无舍无染心　　譬如虚空无障碍
  此戒智者所称赞　　不见所赞诸句义
  是戒能令心寂静　　亦能寂静诸烦恼
  悉得止观之边际　　了然显现得解脱
  解脱诸缚之圣者　　悉皆安住于尸罗
  是故戒为胜解脱　　亦为菩提根本句
  诸有杜多居兰若　　小欲喜足绝贪求
  远离愦闹而住禅　　心获轻安离烦恼
  如是戒是为根本　　思惟寂静解脱句
  是故尸罗为庄严　　一切处为安乐道
  亦令远离于散动　　断诸烦恼及诸见
  慈心遍布如虚空　　能静边执令清净
  决定不舍菩提故　　而于菩提无分别
  智者若具如是德　　皆由于戒到彼岸

善男子若菩萨。成就四法修行忍辱波罗蜜多。犹若虚空。云何为四。所谓他骂不报知语如虚空。他打不报知身如虚空。他嗔不报知心如虚空。掉戏不报知意如虚空。是为菩萨成就四法。修行忍辱波罗蜜多犹若虚空。复次若菩萨成就八法。能净修行忍辱波罗蜜多。云何为八。所谓于诸有情心无限碍犹若虚空。修行忍辱得清净故。于诸利养不生贪着犹若虚空。修行忍辱得清净故。于诸有情利益平等犹若虚空。修行忍辱得清净故。身心无坏犹若虚空。修行忍辱得清净故。离诸惑结犹若虚空。修行忍辱得清净故。离所观境犹若虚空。修行忍辱得清净故。观诸法性不生不灭犹若虚空。修行忍辱得清净故。于色无色以慈遍缘犹若虚空。修行忍辱得清净故。是为菩萨成就八法。能净修行忍辱波罗蜜多犹若虚空。善男子复有八法。能谛观察修行忍辱波罗蜜多。云何为八。所谓性空忍辱不坏诸见故。无相忍辱不遣于相故。无愿忍辱不舍菩提故。无行忍辱不尽有为故。无生忍辱不住无为故。无起忍辱不住生灭故。无有情忍辱不坏体性故。如如忍辱不坏三世故。如是善男子是为八种谛察法忍能修忍辱波罗蜜多。又善男子行忍辱波罗蜜多时。若有毁骂于我。我当忍受名我忍辱。非忍辱波罗蜜多。若见骂者及以骂法。我当忍受名我忍辱。非忍辱波罗蜜多。住无诤行是音声忍辱。非忍辱波罗蜜多。作是加行彼我俱空。思惟忍受彼我无常。思惟忍受此名施设忍辱。非忍辱波罗蜜多。善男子都不见有能行所行。譬加大娑罗林若复有人手持利斧。入彼林中斫其枝叶。彼树终无一念之心。彼为能斫此为所斫不生憎爱。善男子菩萨摩诃萨。行忍辱波罗蜜多时。亦复如是无有憎爱。无能分别无所分别。是为菩萨修行忍辱波罗蜜多犹若虚空。尔时世尊说伽他曰

  尽智无生清净忍　　于境不染意成就
  内外寂静无所依　　心净忍辱虚空等
  是身如影如草木　　心形如幻无真实
  是法性空无所见　　身心变异等于彼
  设有毁誉无喜怒　　无所分别无高下
  知忍如地如门阃　　依教忍辱度有情
  虽知一切法性空　　无人无我无寿命
  不违因缘及造作　　此忍最为真实行
  闻彼恶言不嗔恚　　知语言性如虚空
  修习身心空亦然　　当净有情修此忍

善男子云何菩萨修行精进波罗蜜多犹若虚空。若菩萨成就四法。修行精进波罗蜜多犹若虚空。云何为四。所谓勤修善根知一切法未成就故。于诸佛所作大供养了知如来身平等故。常乐成就无量有情知诸有情无所得故。从诸佛所受持正法不见诸法所厌离故。是为菩萨成就四法。修行精进波罗蜜多犹若虚空。复次善男子若菩萨成就八法。能净修行精进波罗蜜多。云何为八。由庄严身勤行精进。知身如影像无所得故。由庄严语勤行精进。知语如露性无所得故。由庄严心勤行精进。得致于定知心无所得故。为具诸波罗蜜分勤行精进。展转修习思惟无所得故。由成就一切菩提分法勤行精进。菩提性相思惟无所得故。为净佛土勤行精进。知诸佛国等于虚空无所得故。为成就一切所闻悉皆能持勤行精进。知所闻法犹如响应究竟无所得故。为成就一切佛法故。勤行精进知诸法界平等一相。思惟无所得故。是为菩萨成就八法。能净修行精进波罗蜜多。善男子菩萨复有二种精进。所谓加行精进限齐精进。以加行精进策身口意。修习成就一切善法。无有所住思惟无所得故。以限齐精进应住不出不入。随顺法界无所去来。则如虚空无所得故。如虚空无色于诸有情成就所作。菩萨精进亦复如是。依诸佛法成就一切有情事故。如虚空含容一切色。菩萨精进含容一切有情。离一切见亦复如是。如虚空一切草木生长无根无住。菩萨精进生长一切佛法。不住我见亦复如是。如虚空遍一切处无所动摇。菩萨精进遍一切善法。无所动相亦复如是。如虚空等现种种色。菩萨精进等为有情。示现修习平等思惟。皆无所得亦复如是。善男子是为菩萨修行精进波罗蜜多犹若虚空。尔时世尊说伽他曰

  勇猛所生精进力　　无吝于身及命财
  能行威德大菩提　　于诸有情恒利益
  往昔所修功德利　　不生厌倦常修习
  爱乐解脱诸有情　　于诸如来常供养
  愿游无量诸佛刹　　推伏一切诸魔罗
  常乐给施一切人　　常乐护持于净戒
  常乐大慈相应念　　常乐勤集诸善根
  思惟无量禅定心　　以大智慧常观察
  无量慈心舍嗔恚　　功德利益正修行
  于身于命无所悭　　善能解脱诸烦恼
  常修无我空解脱　　离相无相大威德
  永离诸见修菩提　　如幻阳焰观自性
  乐说空法无思虑　　依世净行读诸经
  于法无法二俱亡　　不舍音声及文字
  于世常说诸经典　　赞佛功德亦无边
  有情心行既难量　　智者应生大精进
  悟于无量有情性　　不滞于生及不生
  能以无边精进心　　常习度生诸净法

善男子云何菩萨修行禅定波罗蜜多犹若虚空。若菩萨成就四法。修行禅定波罗蜜多犹若虚空。云何为四。所谓安心于内内心无所见。制心于外外心无所得。由自心平等故知一切有情心亦平等。彼心及平等思惟证知皆如幻化。是为菩萨成就四法修行禅定波罗蜜多犹若虚空。复次善男子若菩萨成就八法。能净修行禅定波罗蜜多。云何为八。所谓不依蕴而修禅定。不依处而修禅定。不依界而修禅定。不依现世而修禅定。不依他世而修禅定。不依欲界而修禅定。不依色界而修禅定。不依无色界而修禅定。是为菩萨成就八法。能净修行禅定波罗蜜多犹若虚空

复次善男子菩萨以专注心禅定清净。云何专注。于法名字不除不加。无变异无差别无损无益。无取无舍无暗无明。无分别非不分别无想无作意。无一无二亦无无一二。无动无思无戏论。无积聚亦无无积聚。不思惟一切相。心无所住名为专注。专注心不流散。于色眼色识远离故自相清净。观行专注心不流散。于声耳声识远离故自相清净。专注心不流散。于香鼻香识远离故自相清净。专注心不流散。于味舌味识远离故自相清净。专注心不流散。于触身触识远离故自相清净。专注心不流散。于法意法识远离故自相清净。善男子譬如虚空。于劫烧时不为所烧。于水灾时不为所湿。如是菩萨修习禅定。不为一切诸烦恼火之所焚烧。一切解脱等持等至。诸禅定水之所漂溺。常无间杂令散动有情。安住禅定而于禅定不生爱味。出定亦然无复障碍。于诸圣人常现寂静。非圣人所勤成就之。常令定心住于平等。不平等者说法化导。不见平等及不平等。于等不等亦不相违。心无有碍犹如虚空。是故名为修禅定者。亦名胜慧修禅定者。亦名不住识修禅定者。由此定故而彼菩萨。获得如是无住禅定犹若虚空

尔时世尊说伽他曰

  善护诸根修静虑　　常定不着于有情
  等引平等度世间　　于内于外常安住
  不依于蕴及处界　　远离境界住寂静
  智者其心常在禅　　于等不等皆平等
  达于法界无高下　　见心与意皆寂静
  为令世间成就故　　示现诸禅及变易
  彼无变易及禅定　　自在心趣亦复然
  现境无色禅定中　　示现欲界亦如是
  皆为有情成就故　　彼复不着于有情
  境界如空如幻化　　阳炎水月梦及云
  已知禅定及世间　　即转世心成智慧
  不能覆蔽于心故　　则得生于自在心
  了达禅定及神通　　游历遍于俱胝刹
  普能供养于诸佛　　无知惑障悉断除
  诸根调伏意寂然　　度奢摩他无分别
  世间及意俱清净　　常恒智力寂亦然
  以无所得住平等　　故名平等遍无相
  若于平等无所住　　是故名为得定者

善男子云何菩萨修行般若波罗蜜多犹若虚空。若菩萨成就四法。修行般若波罗蜜多犹若虚空。云何为四。所谓由虚空清净故入一切有情清净。由智清净故入一切识清净。由法界清净故入我人有情寿者清净。由义清净故入一切文字清净。是为菩萨成就四法。修行般若波罗蜜多犹若虚空

复次善男子若菩萨成就八法。能净修行般若波罗蜜多。云何为八。所谓勤集一切善法不着常见。勤断一切不善法不着断见。知缘起法而不违于无生法忍。现四无碍解而不着于四辩。善能决择四邬驮南不见无常苦无我寂静。善说业果而亦不动。于无业果住无戏论。智常显说一切法句差别之相。善得一切净法光明。于诸有情说于清净及杂染法。是为菩萨成就八法能净修行般若波罗蜜多。善男子当知般若是清净句能摧恶觉故。是无变异句自相清净故。是无分别句无可限齐故。是如实句性真实故。是谛句无动瑶故。是诚实句无虚诳故。是聪慧句解诸缚故。是满足句圣者功德故。是通达句善能观察故。是第一义句无所言说故。是平等句无差别故。是坚牢句不可坏故。是不动句无所依故。是金刚句能穿凿故。是济度句所作已办故。是清净句性无染故。是无暗句明无所得故。是无二句无有建立故。是尽句究竟尽灭故。是无尽句无为常住故。是无为句非生灭所摄故。是空句最清净故。是虚空句无障碍故。是虚空道句无行迹故。是无所得句自性无故。是智句智识无二故。是无推句离对治故。是无身句无转易故。是苦遍知句离遍计苦故。是集断句害贪欲故。是证灭句究竟无生故。是修道句入无二道故。是佛陀句能生正觉故。是达摩句究竟离欲故。善男子如是等类句义差别。智慧光明不属于他。于所说法随入少分。都无分别及所分别。是名修行般若波罗蜜多犹若虚空。尔时世尊说伽他曰

  明慧能断烦恼习　　示现作业及因缘
  不依我见及有情　　不住寿者并人相
  于我无我二俱离　　显说般若到真源
  般若能推于所有　　般若能度于瀑流
  般若能作清净因　　般若能安胜解脱
  净慧能离诸缠盖　　于蕴处界悉遍知
  明慧照曜三界空　　于能所相皆解脱
  修行般若令清净　　一切世间无所著
  通达能行般若行　　常修净慧照真空
  五眼清净五根明　　能除五趣净五蕴
  至于彼岸常安住　　入于法界亦复然
  平等犹若大虚空　　高广善顺于佛智
  于得无得二俱离　　能示中道甘露门
  随顺圣人之所行　　善能分别无分别
  能知苦集断贪爱　　修道示灭显无为
  成就实智慧光明　　故了三世无来去
  于诸刹土皆平等　　诸法寂静等亦然
  了诸有情无我人　　是则真修智慧者

善男子云何菩萨修行福德犹若虚空。善男子一切法性犹如虚空。以菩提心而为种子。所修福聚皆不舍离于菩提心。积集善根而皆回向萨婆若海。由是获得无量福德皆如虚空。善男子菩萨应当发如是心。虚空无量故。感招福聚亦复无量。何以故由意无量故福亦无量。菩萨于彼应作是观。善男子复有十种无量庄严。菩萨应满如是福聚。云何为十。所谓无量身庄严相好圆满故。无量语庄严随说法轮皆清净故。无量心庄严通达一切有情心故。无量行身庄严成熟无量诸有情故。无量行相庄严净无量佛刹故。无量福德禅定精进庄严成满无量佛威仪故。无量大菩提场庄严应满一切相及行故。无量无遮施会庄严成满无量佛毫相故。无量恭敬无我庄严成满如来无见顶相故。无量无间定心庄严成满无量无谄曲心顺净意故。善男子是为十种无量庄严。菩萨若能如是发广大心犹如虚空。所获福德如虚空故

善男子云何菩萨修行智慧犹如虚空。若菩萨遍缘一切有情。有欲心无欲心如实知。有嗔心无嗔心如实知。有痴心无痴心如实知。有杂染心无杂染心如实知。自既离欲。复能为他补特伽罗说调伏欲法。自既离嗔。复能为他补特伽罗说调伏嗔法。自既离痴。复能为他补特伽罗说调伏痴法。自离杂染。复能为他说调伏一切诸烦恼法。不见有贪嗔痴烦恼者为下劣心。离贪嗔痴烦恼者为胜上心。何以故以彼菩萨。于不二法界清净法门以证知故。如是法界即贪嗔痴界。如是法界即离染界。是故法界与一切法互相涉入。法界即法。法即法界无所不遍。若知我界即知法界。法界我界无有二故。所以者何我清净故法界清净。如是一切法清净故。光显容受亦无容受。离于一切相无相故。无所安立。犹如虚空名无碍智由无碍智了一切法无所障碍。是为菩萨修行智慧犹如虚空

善男子云何菩萨佛所印可佛随念。所谓念无漏戒是戒佛随念。一切法平等不散是定佛随念。一切法无所分别是慧佛随念。不住于二心是解脱佛随念。不着一切智是解脱知见佛随念。三世平等不动是力佛随念。不住一切漏是无所畏佛随念。如是当念佛身所有一切功德皆是佛随念。法界平等无所分别。复次佛随念。念佛所有色自性清净由见色自性清净故无念智随至。乃至受想行识。见识自性清净故无念智随至。如是十二处十八界亦复如是。由一切法自性智故。最殊胜慧一切作意。远离一切见缠远离如是知色无垢浊。念无垢浊。是谓佛所印可佛随念。复次佛随念。谓念于佛行住坐卧一切威仪。不生执着。于佛说法于佛寂嘿不生执着。亦不执着念与非念。所以者何。佛无念无作意非色非相非法非非法。由一切相缘虑不现行故。善男子是名佛所印可佛随念

善男子云何菩萨佛所印可法随念。法名离欲。于法无染故。亦无法随念。法名无阿赖耶。于法无隐没故。亦无法随念。法名寂静。以无心意识染着故。亦无法随念。法名无相。于法无随相识故。亦无法随念。法名无为。于法无施设住故。亦无法随念。复次法随念。若念无间断不起法想。即入正位证无生忍。观一切法本来不生无法可证。即是一切学无学缘觉菩萨。正等菩提所证之处。如是一切圣所证解脱法。亦无自性。是为菩萨佛所印可法随念

善男子云何菩萨佛所印可僧伽随念。僧名无为。彼不可以造作而作。而无现行身语意业。但是施设而有所行。是无为僧离施设住超诸言论。善男子是为佛所印可僧伽随念。善男子云何菩萨。佛所印可舍随念。所谓舍于一切所依资具。及舍于法亦无所舍。此名最胜舍。于一切法无取无舍亦无所求。无有缘虑非无缘虑。彼无心行亦无施设。亦不住于识。不生于心以无住心故。名为佛所印可舍随念。复次菩萨舍随念者。以所修行回向平等萨婆若智。不见菩提为所随念。何以故。以萨婆若与彼随念性无二故。善男子如是法智相应。是名菩萨佛所印可舍随念。善男子云何菩萨。佛所印可戒随念。戒名无为。无漏无碍永息功用成就一切禁戒。无识无相亦不住心作三摩地。最胜所依亦是发生净慧根本。离於戏论及解脱相。亦无二种分别之相。智者所赞无有现色。能息烦恼亦无施设。安乐随行亦无对治一切分别。菩萨常于如是类戒无有垢浊。是名菩萨佛所印可戒随念

善男子云何菩萨佛所印可天随念。应随念二种天。一者五净居天。有圣者故。二者睹史多天。以一生补处菩萨在彼天故。复次此一生补处菩萨住彼天宫。有十种顶法。何者为十。所谓一切波罗蜜中。般若波罗蜜多而为其顶。一切神通之中。不退神通而为其顶。一切地中。唯灌顶地而为其顶。一切菩提分法之中。不退正见胜三摩地而为其顶。一切无碍解中。义辩无碍而为其顶。一切智中。无著无碍智而为其顶。一切根中。知上中下根无碍智而为其顶。一切力无畏中。照耀随入智而为其顶。一切眼中。佛眼观察一切佛法。了如掌内而为其顶。坐菩提场中当成正觉。一刹那心相应正慧而为其顶。是为十种顶法之相。应随念之。若菩萨得是念已。见则不乱随眠缠。不乱作意戏论。不乱于如是类。念无垢浊。应当如是随念彼天。善男子是名菩萨佛所印可天随念

善男子云何菩萨所行诸行等于涅槃。涅槃名寂静。悉除一切烦恼。灭一切受。离一切所缘。出蕴处界。即彼正士获得涅槃平等。以本愿力游戏大悲。方便智慧得如来加持故。善修智慧意乐。清净住于如幻妙三摩地。悉知有情烦恼生死皆如幻化。示现受生。由此能断诸生死缚无所染污。名曰涅槃。既得自在不生而生。无所不生亦无所生。常在涅系不断生死。而成熟有情无有休息。善男子此名菩萨大悲方便双智慧门。若菩萨住此门者。获得涅槃平等行菩萨行。善男子云何菩萨。善知一切有情行相。善男子菩萨。有八万四千行。是于根本。邬驮南句有情行相。无量差别不可思议不可言说。唯佛能知。非诸声闻缘觉所了。亦非菩萨之所能了。彼菩萨蒙佛加持及自智力。随知一切有情行相。所谓如是自性相。如是行相。如是因相。如是缘相。如是作相。如是和合相。或种种相离相欲相。嗔相痴相等分相。地狱相傍生相琰魔界相天相人相。或声闻尼夜摩相。或缘觉尼夜摩相。或佛尼夜摩相。或远因相中因相近因相。如是有情一切行相如实知之。除一切智不被摧伏。善男子是为菩萨善知一切有情行相

大集虚空藏菩萨所问经卷第二

丙午岁高丽国大藏都监奉　敕雕造大集大虚空藏菩萨所问经卷第三

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广知大兴善寺三藏沙门不空奉　诏译

善男子云何菩萨能持世尊佛法宝藏。善男子诸佛法藏无有穷尽。以一切有情根性行相差别无量。诸佛世尊为令趣入。随其尔所差别根性。说法宝藏。亦有尔所无量无边。是故名为佛法宝藏。复次如来证菩提夜般涅槃夜于其中间已说今说当说。所有一切悉名如说不异说真说。云何名为如说。如彼真如平等而说故名如说。云何不异说。所说之法依胜义谛。平等无二名不异说。云何真说。称法自性名为真说。复次诸佛法藏。不可以文字说。假使满于三千大千世界一切有情。皆如阿难陀多闻第一。于百千俱胝劫中。说于一义不可究尽。如是诸佛无边法藏。菩萨悉能如法受持。一切文字皆不废忘。于一切义无有差异。使诸有情皆得欢喜。供养奉事一切如来。摧坏一切魔怨。制伏一切外道。息灭烦恼显扬正法。如是善男子。是名持佛世尊佛法宝藏。复次善男子。如我等觉彼法自性。菩萨如是如彼法性应当受持。云何名为如来等觉彼法自性。谓知法自性。悉皆如幻不成就相故。悉皆如梦无境界相故。悉如阳炎毕竟无生相故。悉如光影无移动相故。亦如影像无自性相故。知空自性究竟如露故。知无相自性无分别故。知无愿自性心无住故。知离欲自性一切欲远离故。知无为自性超诸数相故。善男子如是言说为他了别故。我已现证是法自性彼法性相不可言说。若菩萨欲受持诸佛法藏。应如如来觉了诸法自性。而以文字语言为诸有情如是说法。是为菩萨能持诸佛正法宝藏。善男子云何菩萨。善知有情本来清净。而成熟之。善男子有情界本来清净。于彼根本性。有情不可得。若菩萨欲成熟彼有情。应如是知根本清净。复应念彼无我见。无有情见。无命者见。无受者见。复次所说有情名者。但从颠倒见。缠无明有爱。虚妄分别诸烦恼。生无有实性。而彼菩萨。应当断除虚妄颠倒一切烦恼。而为有情说如此法。不坏其性。为令了如有情无故。有情离故。应当如是成熟有情。善男子是名菩萨善知有情本来清净而成熟之

善男子云何菩萨如理相应修习佛法。如理者名入缘生。何以故。如彼彼因缘。感彼彼果报。谓如布施因。获大财富。是故菩萨。行布施已尽将回向一切智智。满足成就檀波罗蜜。尸罗是生人天之因。菩萨普令污戒有情。安住净戒。要期回向萨婆若已。满足成就戒波罗蜜。忍辱柔和为庄严身口意之因。菩萨常行自利利他。不为恼害住于忍辱。回向萨婆若已。满足成就忍波罗蜜。精进为能引摄一切佛法之因。菩萨应发勤精进心。积集一切所有善根。尽将回向萨婆若已。满足成就精进波罗蜜。禅定为于正知之因。菩萨为欲求正知故。修习奢摩他资粮。尽以回向萨婆若已。满足成就禅波罗蜜。般若多闻为大慧之因。菩萨不取不执闻相。回向萨婆若已。满足成就般若波罗蜜。如是能于一切善法。知如是因感如是果。是名因缘如理作意。复次如理作意者。谓如于我及一切法如理作意。如是知我无我。一切法悉皆无我。知我是空一切法悉皆是空。我但有名一切法亦唯有名。菩萨如是如理作意。于一切法平等相应。即是具足一切佛法。是为菩萨如理相应修习佛法

善男子云何菩萨不退神通。于一切法而得自在。善男子若有沙门或婆罗门。不害身见。起于神通彼还退失。若时菩萨已害身见。及能远离六十二等一切诸见起于神通。名为具智具慧具觉具施具戒具定。亦即名为身心远离具足智已。内常寂静外无所行。遍所知心可所欲心。善决择心善清净慧。无烦恼浊得光明。无翳智积集福资粮。积集智资粮。积集奢摩他资粮。积集毗钵舍那资粮。资以檀那净戒庄严。被以忍辱精进甲胄。依于禅定善修般若。随顺大慈安住大悲。超出方便成如是法。起妙神通高升无碍。乃至坐于菩提道场。以神通故于一切法皆得自在。现一切色闻一切声入一切心。忆念无量劫。获得一切游戏神通。伏断诸漏乃至随意转变皆得自在。于一切法无复功用。善男子是为菩萨不退神通。于一切法而得自在

善男子云何菩萨入甚深佛法理趣。一切声闻缘觉难测。善男子甚深者名为缘生理趣所谓无明缘行行缘识。识缘名色名色缘六处。六处缘触触缘受。受缘爱爱缘取。取缘有有缘生。生缘老死忧悲苦恼。由集为因为缘。生大苦蕴。令诸有情流转杂染。菩萨于彼善能了知此。则名为缘生理趣。云何名为缘灭理趣。谓无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六处灭。六处灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。由是因缘灭则大苦緼灭故。令有情获得清净。如是名为缘灭理趣。若菩萨于彼如是了知。是名为入甚深理趣。非诸声闻缘觉能于杂染得清净者。此是诸佛如来境界。若菩萨以佛威神加持之力。则能于此随分觉悟。复次甚深者名萨迦耶。萨迦耶清净故一切法清净。何以故。此萨迦耶推求根本无所得故。其无所得则为甚深。诸佛于我皆无所得。我本清净如我清净一切法亦清净。以何因缘而名清净。谓彼诸法本来不生。无所起灭故名清净。复次无暗无明无阿赖耶。真实胜义名为甚深。彼无眼灭。乃至亦无意灭。无有境界。是无境界则是真实。第一义谛名为甚深。亦无心意执着。胜义以难测难见不可觉故。于此诸类甚深法理。但以假名随顺世谛。于他有情分别显示。是为菩萨得入甚深佛法理趣一切声闻缘觉难测。善男子云何菩萨。入缘起善巧智远离一切边见。善男子缘起者无所缘是缘起。无事无成就是缘起。无常苦无我寂静是缘起。无我无有情无命者无养育。无补特伽罗无人无儒童是缘起。无生无起是缘起。无所有无功用空无相寂静无所行无戏论。是故名无戏论法如是生是为生。如是灭是为灭。复次无我无有情无寿命无养育。无补特伽罗无人无儒童。则无有法可为缘生。于彼无我主宰名故。譬如草木墙壁影像。一切诸法亦复如是。如外诸法之所生时。生无所有。灭时灭无所有。内法亦尔。生时生无所有。灭时灭无所有。除缘起法无实所生。阙缘无灭。如是相应则一切边见悉皆离也。云何边见。边见者名断名常。生时不生坏时不坏。无生无坏于断常边自然清净。自清净故于诸边见皆得清净。善男子是为菩萨入缘起善巧智远离边见。善男子云何菩萨。以如来印印于真如。不间断善巧智。善男子如来印。印者不间断印。无生无转无所取无动无所动。一切世间人天阿修罗。无所倾动。何以故。世间人天阿修罗。以彼印印。如是如来印。究竟不生印。究竟空性印。究竟无相印。究竟无愿印。究竟无为印。究竟离欲印。究竟真如印。究竟实际印。究竟虚空印。善男子譬如空中印无所现。如是如来印。于五眼而不现于光明之相。以自相印而印之。故乃至如来于一切法施设言说。皆以如来印印之。是为施设。彼所有识及境界法皆是作法。安立而于彼法。不作种种安立之相。以真如印印之。无有间断。云何于真如间断。若分别诸法见上中下名为间断。若于诸法无所分别名无间断。复次于多分别而生分别。于彼真如无能坏乱。譬如有情于空中行。而彼虚空无有破坏。如是一切有情于真如中。行而彼真如无有断坏。菩萨如是由以智故。于色于法以真如印印之。不于真如间断破坏。是为菩萨以如来印。印于真如不间断善巧智

善男子云何菩萨。入于法界甚深理趣。见一切法与诸法界。互相周遍平等一性。法界者亦名离欲界离一切尘故。亦名不生界无聚集故。不相违界本无生故。无往界无等故。无来界无碍故。无住界不生起故。如如界三世平等故。无我界本来清净故无。寿者界由胜义故。无了别界无所住故。无阿赖耶界无染污故。无生起界性决定故。如虚空界。性清净故。如涅槃界无戏论故。如是名为入法界理趣。若菩萨入如是理趣。凡所演说一一语言。皆与法界理趣互相周遍。即知欲界法界无二无别。复次欲性法界嗔性法界无二。嗔性法界痴性法界无二。痴性法界烦恼性法界无二。烦恼性法界欲界性法界无二。欲界性法界色界性法界无二。色界性法界无色界性法界无二。无色界性法界空性法界无二。空性法界眼界性法界无二。眼界性法界色性法界无二。色性法界眼识界性法界无二。眼识界性法界乃至意界性法界无二。意界性法界意识界性法界无二。意识界性法界蕴界性法界无二。蕴界性法界地水火风界性法界无二。地水火风界性法界空性法界无二。乃至八万四千法蕴行一切法法界无二是为。一切法法性界若菩萨由平等智入如是法界。则能见一切法平等性理趣。善男子是为菩萨入法界理趣

善男子云何菩萨。意乐坚固犹若金刚。住此大乘无有倾动。善男子菩萨成就十二种法。意乐坚固犹若金刚。不为人天世间所坏。云何十二。所谓菩提心。意乐增上意乐不坏故。于施戒忍精进禅定般若不坏故。大慈大悲不坏故。四摄法不坏故。成熟有情不坏故。净佛国土不坏故。不厌患生死不坏故。无厌足善根不坏故。为庄严相好设无遮施会不坏故。为护正法弃舍身命不坏故。所有善根回施一切有情不坏故。积集一切佛法不坏故。善男子若菩萨。于如是法修习不坏。当知尔时名为成就坚固金刚不坏意乐。如金刚宝能摧诸宝自体不坏。如是菩萨成就坚固意乐。能摧一切有情烦恼随眠而自体不坏。善男子是为菩萨成就金刚坚固意乐。于此大乘无有倾动。善男子云何菩萨于自境界。清净如佛境界。善男子佛境界者无有境界。离于境界一切清净。彼菩萨由自境界及佛境界悉清净故。而净眼境界即佛境界。亦无佛境界。及眼境界。无近无远。何以故。远离境界。与佛境界。亦无远离境界及眼境界。其耳境界即佛境界。亦无佛境界无有远近。何以故。远离境界与佛境界。亦无远离境界及耳境界。其鼻境界即佛境界。亦无佛境界无有远近。何以故。远离境界与佛境界。亦无远离境界及鼻境界。其舌境界即佛境界。亦无佛境界无有远近。何以故远离境界与佛境界。亦无远离境界及舌境界。其身境界即佛境界。亦无佛境界无有远近。何以故。远离境界与佛境界。亦无远离境界及身境界。其意境界即佛境界。亦无佛境界无有远近。何以故。远离境界与佛境界。亦无远离境界及意境界乃至蕴处界十二因缘。亦复如是。善男子若菩萨入佛境界。远离境界一切境界。若自境界清净平等。是即名为入佛境界。如是六种境界所有影现。彼皆入于诸佛境界。不生取着悉远离故。如是如来境界无有染碍。一切境界不染不碍亦复如是。善男子如是解者。是为菩萨成就随入佛界清净自界清净

善男子云何菩萨。获得陀罗尼无忘法行。善男子菩萨。应于此陀罗尼修持作业。云何修持。善男子有三十二种修陀罗尼法。所谓求法故。爱乐法故。法苑乐故。随法流故。随顺法故。尊上法故。承事供养多闻者故。常于和上及阿阇梨。无有我慢恭敬供养故。求法无厌故。于教授者随顺不逆故。于说法者敬爱如佛不求其短故。于所闻法悉皆受持故。不懈怠故。于法不吝故。所行法施无悕望故。于所闻法如理作意故。于所闻法善观察故。求于多闻无齐限故。常于梵行无休息故。常乐远离心寂静故。常勤修习六随念故。于六染法常弃舍故。于六和敬恒不舍故。于一切有情起无碍心故。于缘生法修顺忍故。于三脱门作意观察不惊怖故。不舍圣种杜多功德故。护持正法心无下劣故。观于众生起大悲故。求于正法不惜身命故。修大智行离愚惑故。成就有情不懈倦故。如是名为修陀罗尼无忘失业。复次善男子。若菩萨得是陀罗尼已。于佛所说悉能遍持令不忘失。谓所闻法无有忘失。以念不忘。以舍觉悟以慧照了。入于一切无尽文字。得诸言音随类善解智。得无碍辩演说无滞智。于了义经入理趣智。不了义经入理趣智。入于世俗无尽说智。入于胜义不断说智。于正断精进得无退智。于四神足起游戏智。于诸根中得差别智。于诸力中得无动智。于七觉支得开悟智。于八圣道得入理智。于奢摩他得心住智。于毗钵舍那得法决择智。于智解脱得随顺智。于诸辩说得深入智。于诸神通得生起智。于诸波罗蜜得分别智。于四摄法得随机智。于诸音声得语路智。于决定法得决择智。于诸经义得无间断智。于诸文字得无尽智。于诸有情得欢喜智。于求法者得称根说法智。于佛所说得念总持智。于一切文字得入词句智。于诸垢净得如实觉智。于诸业缘得悟果报智。于一切法得光明无翳智。是名陀罗尼。得陀罗尼平等身语心者。能雨无尽法。能息诸烦恼。能生一切诸佛法故。由得此陀罗尼甚深理故。常无忘失。是故名为菩萨得陀罗尼无忘法行。善男子云何菩萨。获得如来加持无碍辩才。善男子若菩萨常蒙如来之所加持。得二十四种无碍辩才。云何名为二十四种。所谓迅疾辩利捷辩。无碍辩无滞辩。善词辩甚深辩。间错众音辩胜妙庄严辩。无沉没辩无畏辩。种种偈赞辩修多罗缘起本事辩。能摧伏他辩说差别无尽句辩。显现微妙辩端严威德辩。说法无间辩天众庄严辩。断诸疑惑辩世出世法辩。不错失辩慈悲喜舍悦可众心辩。宿命通辩佛所加持辩。善男子如是二十四种辩。修二十四种业而得成就。何者二十四种业。所谓不逆师长教诲故获迅疾辩。往来无谄故获得利捷辩。离诸烦恼故得无碍辩。不好杂住故得无滞辩。不离间语故得善词辩。悟缘生故得甚深辩。以种种施故得间错众音辩。严饰如来塔庙故得胜妙庄严辩。不舍菩提心故得无沉没辩。善护戒蕴故得无畏辩。施种种幢幡铃盖故得说种种偈赞辩。承事恭敬种种舍施诸师长故得说修多罗缘起本事辩。不逼恼贫匮有情故得能摧伏他辩。施无尽宝藏令他入法故得说差别无尽句辩。所说真实无粗犷故得显现微妙辩。不轻毁尊教及离间他人故得端严威德辩。于自得法住持故得说法无间辩。不谤毁他以欢喜心施所爱物故得天众庄严辩。于法不师拳如闻说故得断一切疑辩。观于一切皆如师长不加逼恼施病者药故得世出世法辩。不求他过常自省察故得不错失辩。以平等心观诸有情置涅槃道不着一切利养恭敬及名闻故得慈悲喜舍悦可众心辩。善言柔软如说修行心无浊乱故得宿命通辩。不谤大乘不乐小乘悲愍有情故得佛所加持辩。是名成就二十四种辩才之业。复次令他有情。到究竟故。名为辩才。于他住持。能警觉故。名为辩才。于他欢喜意相续故。名为辩才。于他有情说随心智故。名为辩才。善男子成就如是法功德智。是为菩萨获佛加持无碍辩才。善男子云何菩萨于生死中而得自在。善男子菩萨成就十二种法。于生死中而得自在。云何十二。所谓远离恶友故。亲近善友故。于佛所许见清净故。戒蕴清净从三摩钵底起于智慧方便而双运故。获不退神通故。观诸法无生故。为满本愿于生死中而受生故。观于有情起大慈故。以大悲定观察诸法如幻化故。知一切法不生灭故。于如梦性法不虚妄法如实观察故。以佛世尊威神加持或现生死而不染生死故。是为十二。若菩萨成就此十二法。能于无量阿僧祇所生之处。示现受身广大利益一切有情。善男子如是一切从二种根之所建立。所谓神通智及大悲根。如是名为菩萨摩诃萨于生死中。获于神通而得自在

善男子云何菩萨。摧伏怨敌超越四魔。善男子若菩萨。以如幻智通达一切五蕴诸法皆如幻化。超越蕴魔。通达诸法本性清净超烦恼魔。通达缘起超越死魔。不退菩提心故超越天魔。复次菩萨如是观故。能害所有障。于菩萨一切魔业魔不得便。何谓魔业。谓爱乐小乘是为魔业。不护菩提心是为魔业。于诸有情简别行施是为魔业。乐求生处而持禁戒是为魔业。为求色相而修忍辱是为魔业。作世间事相应精进是为魔业。于禅味着是为魔业。以慧厌离于下劣法是为魔业。在于生死而有疲倦是为魔业。作诸善根而不回向是为魔业。厌离烦恼是为魔业。覆藏已过是为魔业。憎嫉菩萨是为魔业。诽谤正法是为魔业。背恩不报是为魔业。不求诸度是为魔业。不敬正法是为魔业。悭惜于法是为魔业。希利说法是为魔业。离于方便成就有情是为魔业。舍四摄法是为魔业。毁破禁戒是为魔业。轻持戒者是为魔业。顺声闻行是为魔业。顺缘觉乘是为魔业。要求无为是为魔业。厌离有为是为魔业。心怀疑惑不利有情是为魔业。所闻好疑不善通达如理作意是为魔业。好怀谄诳假示哀愍是为魔业。粗犷恶骂是为魔业。于罪不厌是为魔业。染着自法是为魔业。少闻便足是为魔业。不求正法是为魔业。乐求非法是为魔业。于障盖缠不乐对治是为魔业。不净心口是为魔业。忍沙门垢是为魔业。善男子如是乃至好行十不善业。舍于善法。如是一切悉为魔业。若菩萨成就四法。而能超越。云何为四。所谓不忘菩提心故。勤修六度不放逸故。住于善巧智成就有情故。住甚深理护持正法故。善男子菩萨若与此法相应。决定能摧诸魔怨敌。是为菩萨超出四魔

善男子云何菩萨。积集无量福德资粮。为诸有情作所依止。善男子若菩萨于一切有情。起同体大悲住于禅定。见来求者悉皆舍施以福无尽得于宝手令他受用。意乐清净心如平地离于高下。有所悕望丰饶利益。戒清净故得心无著善护诸根。复能成办一切施会。得陀罗尼成就辩才。以如是等积集善根。回向菩提普施有情。如外四大一切世间依住。如是内四大为一切有情依住。菩萨作是思惟。我所积集一切善根法智善巧。无有一法不与有情而为依住。是为菩萨获得无量福德资粮。为诸有情作所依住

善男子云何菩萨。出无佛世为诸有情而作佛事。善男子若菩萨。为出生处非处智故修十力业。为出生漏尽智故修四无畏业。为出生三十无碍智修十八不共法业。为出生得佛眼光明故修五眼悉知业。为出生一切神通故修宿命业。为获成就满足菩提故修具足一切善法。断身口意诸烦恼业。为出生相好庄严故修集一切福资粮业。为出生十地得灌顶一切佛法故修集一切智资粮业。如是善男子若菩萨。具修如是业已。于无佛世能为有情广作佛事而成就之

善男子云何菩萨。获得海印三摩地。不染一切有情心行。善男子以何因缘名为海印三摩地。如赡部洲诸有情等若干色类。皆于海中而现影像故名大海。如是若干有情一切心色之类。乃至音声彼诸影像。皆于菩萨心海中现。是故名为海印三摩地。譬如大海同一碱味。菩萨一味法解脱智亦复如是。譬如大海不越潮限。菩萨观时非时故不越成菩提时。坐于道场亦复如是。譬如大海不宿死尸。菩萨不与一切习气烦恼及声闻缘觉心俱亦复如是。譬如大海容纳万流不增不减。菩萨容受一切诸法无有增减亦复如是。譬如大海其广无涯。菩萨慧用无边亦复如是。譬如大海深难得底。菩萨智海一切声闻缘觉难测亦复如是。譬如大海能作。无量世界依止。菩萨作诸有情依止亦复如是。善男子是为菩萨善入海印三摩地已。不染一切有情心行

善男子云何菩萨。得无染着心如虚空风无有障碍。善男子若菩萨。于一切法远离见缠心无所著。譬如大风于虚空中无所染着。如是菩萨于一切法心无所著亦复如是。是为菩萨得无染着。心如虚空风无有障碍

大集大虚空藏菩萨所问经卷第三

丙午岁高丽国大藏都监奉　敕雕造大集大虚空藏菩萨所问经卷第四

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

善男子云何菩萨善知轨仪。修行离暗获得光明。不随他缘得自然智。速到大乘一切智智。善男子若菩萨。于彼所行轨仪一切诸行。不退不动获得光明。名为正法自智光明。亦名于法无障碍智。能离于暗获得光明。不随他缘得自然智。何以故。彼菩萨住自然智光明之时。于他有情及于此法。照了决定。不随他缘。速疾能证萨婆若智。尔时世尊说伽陀曰

  已脱诸见之智者　　于生死中具福德
  住于瑜伽离诸相　　回向菩提无尽处
  应具一切智资粮　　无边智慧虚空性
  无色无相亦无法　　则能满足一切智
  应念佛身胜生子　　于彼心意不散动
  不取色相及种姓　　是故名为念如来
  法体远离于诸欲　　湛然寂静常无相
  若能远离于所缘　　是故名为真念法
  无为无染常解脱　　是故名为念僧伽
  一切资缘诸事物　　悉能舍施无所著
  无思清净无分别　　是故名为念于舍
  无为尸罗无诸漏　　离身语意不流转
  不生三有无所依　　是为正念无漏戒
  净居诸天体无垢　　及住兜率绍法王
  应念如是清净天　　不久我常亦如彼
  若持诸佛之正法　　不应执着烦恼事
  于法非法皆解脱　　如是能持诸佛法
  如佛所得菩提相　　受持法者亦复然
  若知本际无有尘　　是则名持诸佛法
  由我净故有情净　　法净智者随行之
  智诸有情心性净　　以如是行而成就
  不作断灭有情界　　亦不见彼有增减
  为说断除颠倒见　　化无量众令清净
  应说世间诸境界　　不异如来之境界
  佛之境界如虚空　　世间之境亦如是
  一切语言及文字　　悉皆犹如空谷响
  中间无有所闻者　　如是知已获总持
  受持修习及读诵　　尽能宣说法理趣
  无我无人无法相　　如是安住陀罗尼
  能持一切诸佛法　　善说闻者皆欢喜
  正念不离三摩地　　由此决定于总持
  于法不动无散心　　亦于诸法无疑惑
  譬如龙王降大雨　　彼人说法亦复然
  无著无缚无障碍　　能说千亿俱胝典
  于诸有情无法想　　彼得辩才胜功德
  承佛威神说妙法　　千俱胝劫常无碍
  令诸有情心欢喜　　安住辩才佛功德
  若知一切法理趣　　体性皆若于虚空
  无入无命无寿者　　彼即名持佛正法
  有情本性皆圆寂　　究竟诸法悉无生
  是忍境界无垢净　　得此名为不放逸
  见于诸蕴皆如幻　　则见诸法真实性
  知于六处如空邑　　是则能超于蕴魔
  譬如空中起浮云　　一切诸惑亦如是
  常于正理勤观察　　彼则能超烦恼魔
  若知无生常不生　　则知寂灭亦无灭
  法无过去未来世　　决定不为死魔侵
  于法无动亦无思　　不住菩提无觉想
  无我无人起悲济　　是降天魔之眷属
  见于识智二平等　　不住无为及有为
  心如幻化知世间　　是名勇健难摧伏
  于此彼岸无所著　　说法修习相应者
  拔济有情无人想　　是名菩萨之导师
  观察三有如旷野　　亦如空性不变异
  无路无人无拔济　　是为说法大商主
  善说有无真实法　　了法本来常清净
  悲与寂灭理相应　　是名菩萨导师者
  前后流转心相续　　如此二心不和合
  了知流注心体性　　是名菩萨之勇健
  知诸法性本清净　　犹如虚空如水月
  不着一切诸烦恼　　是净萨埵常称赞
  若知一法同诸法　　如幻阳炎无所取
  虚妄空寂不常恒　　彼人不久成真觉

说此决定法门时。七万二千那庾多天人紧那罗摩睺罗伽等。皆发无上正等觉心。三万二千菩萨得无生法忍。于此三千大千世界。六种震动大光普照。百千诸天雨种种花奏诸伎乐以邬驮南而共赞叹。此诸有情。已为如来法印印之。若有闻此法门。能生胜解受持演说。如法修行一切智者。于此佛刹皆应礼敬以自庄严。所以者何。由佛世尊出兴于世。演此秘密决定法门。令我等闻。非余有情所闻见故

尔时大虚空藏菩萨。从佛世尊闻说是已即时获得六无垢清净三摩地门。以价直三千世界摩尼宝网。覆于佛上而为供养。一心合掌作如是言。如来今者以无碍智。观察一切有情根性前后善巧。宣说无障碍法甚深理趣。由此众会皆大欢喜赞叹大乘。时十方世界所来集会诸菩萨等。复放光明皆言由于如来说如是法门。令我等闻深生庆幸靡不欢喜

尔时会中有菩萨摩诃萨名曰迅辩。白大虚空藏菩萨言。正士汝名虚空库藏。而汝岂以虚空为库藏那。虚空藏菩萨言。善男子我亦是虚空亦是库藏。迅辩菩萨言。善男子我愿见汝虚空库藏差别之相。虚空藏菩萨言。善男子如汝之心所思惟物。我令空中为汝雨之。迅辩菩萨言我昔。曾见亦优波罗吉祥如来莲花庄严世界。彼有莲花名曰一切光明遍照。其量广于一俱卢舍。有多千叶香洁柔软。犹若迦止栗那绵。身触之时受极快乐。其香芬馥遍于无量百千世界。彼中菩萨闻香见花即皆得定。唯愿仁者于此众会而雨是花。时迅辩菩萨。一心净意。未久之间于是大虚空藏菩萨以大威神加持力故。即于空中雨如是花。时此会众见是花已。各各获得爱乐花三摩地。从定出已异口同声。赞大虚空藏菩萨言。善哉善哉。正士由汝加持智力故。令一切有情悉皆获得如是之力

尔时众中复有菩萨名宝庄严。白大虚空藏菩萨言。大士唯愿为我及诸有情。于虚空中雨细粖金。所言未讫即有无量粖金。从虚空中如雨而下。宝庄严菩萨复言。愿于空中雨一切宝。所言未讫即于空中。有无量无数种种名种种色种种摩尼之宝如雨而下。所谓金银颇胝迦。吠琉璃码瑙赤珠牟娑罗藏宝。吉祥藏宝髻娑罗无垢光宝。月光宝日光宝照曜宝珠胜光宝。赡部光宝火光宝。砗磲璧玉珊瑚帝青宝。德藏宝寂静光宝澄清浊水宝。不坏光明宝建立眼宝。旋转宝释迦楞伽宝。胜宝大胜宝。威德炽盛宝吉祥藏王宝。金刚蕊宝世光宝。光味宝持光半月宝。赡部檀宝赡部洲光宝。千光宝矩火光宝。胜庄严宝息热宝。无热恼宝除病宝。净眼宝净耳鼻舌身意宝。照曜支宝照曜宝。青光宝黄光宝。颇威迦宝白颇胝迦宝网宝。以要言之余如是类。无量之宝悉皆雨之。如是无边众宝名字。若于一劫不可说尽

尔时复有时王菩萨。白大虚空藏菩萨言。大士此娑诃世界。有无量受苦有情。贫匮饥饿无诸饮食。着破弊衣复有裸形。及诸饿鬼露体饥渴被发覆身。常思所弃涕唾脓血。为如是类愿生怜愍。雨以衣食而充济之。时虚空藏菩萨。以加持力即于虚空。雨种种饮食异类衣服。百千色相无量无边不可算数。上妙细软过于迦止栗那绵。身触之时受极快乐。于此三千大千世界。一切贫匮孤露有情及诸饿鬼。蒙此饮食胜妙衣服悉皆充足

尔时会中复有菩萨名曰医王。白大虚空藏菩萨言。大士今此世界。无量有情婴诸疾病。复无眷属所能瞻视。以病缠绵受大苦恼。愿为此等诸有情类。雨上药草令彼患者悉皆除愈。所言未讫。即时虚空雨于无量甘露妙药。由此药故一切病者服皆除差。复有菩萨名摧恶趣。白大虚空藏菩萨言。善男子愿以大悲。息三恶趣受诸剧苦一切有情。所言未讫。即于空中出大光明。照捺落迦傍生鬼趣。彼诸有情皆息众苦得受安乐。又于虚空雨众花鬘涂香末香。幢幡伞盖灯浊音乐。奴婢妻妾童子婇女。象马车乘宅舍。城郭村邑聚落国土。宫殿楼阁花园窗牖床榻。珍宝辈舆四牛十六牛。乃至千牛所驾之车。悉于虚空如雨而下。皆由大虚空藏菩萨加持力故。复告众言。善男子汝等皆取如是等物随用舍施。当令满足檀波罗蜜。复有菩萨名戒庄严。白大虚空藏菩萨言。善男子汝已雨于檀波罗蜜。何不复雨戒波罗蜜。所言未讫。即时十方诸佛及诸菩萨。皆共赞叹戒波罗蜜庄严功德。如是赞叹戒功德声从空中出。如是赞叹忍辱精进禅定智慧庄严功德。所出之声亦复如是。又闻诸佛菩萨百千词句。称赞诸法无增无减。由此法音警觉三千大千世界。令无量无数有情。修学三乘而得成就

复有菩萨名普遍光明。白大虚空藏菩萨言。汝虚空库藏。为唯于此世界中现饶益有情。为复亦能于余世界现汝斯事

尔时大虚空藏菩萨。告普遍光明菩萨言。善男子汝获无垢妙净天眼。当观十方诸佛世界。为见何物说是语已。时普遍光明即以天眼。观见十方无量阿僧祇世界。所雨宝物饮食衣服。一如此界无所减少。又闻空中所说一切微妙法音亦不增减

尔时普遍光明菩萨。见是事已深生奇特叹未曾有。以邬驮南称赞大虚空藏菩萨。不可思议难可测量。而能顿于一切世界。现如是等种种宝物。唯愿以佛威神之力及于仁者加持之力。令此众会及余世界一切有情。普皆得见如是众宝。普皆得闻虚空法音。尔时大虚空藏菩萨。即如其言更雨如是种种诸宝。皆令此会及他方国土一切有情。悉皆得见各各皆发无上正等菩提之心

尔时王舍大城有五百女人。共诣大虚空藏菩萨所。到已白言。我闻正士能满一切有情所愿。然今我等夫主并死不知所趣唯愿大士示我令见

尔时大虚空藏菩萨。以威神力故。即为五百女人。各各现其本夫形状住菩萨前。时虚空藏告诸女言。姊妹当观此是汝等本夫。以不彼诸女等各见本夫。悲喜交集。时彼丈夫各自随逐是诸女等还归本家。七日之中为女说法令得成就咸发无上菩提之心。住不退转。时五百女相共来诣大虚空藏菩萨之所。一心同声以伽陀赞曰

  我等今知是法相　　犹如幻化虚空性
  而为我等示现夫　　今我成就最胜业
  以是诸法皆变化　　本空无心无所动
  由此通达无漏法　　永不随逐诸烦恼
  是故皆发菩提心　　愿欲拔济有情类
  蒙为我等授记莂　　当得成佛度有情
  同名善调之如来　　广于后世修诸行
  我等获斯妙法雨　　是故称赞大导师

尔时复有五百丈夫被贼欲害。即闻空中声曰。汝等当知有菩萨名大虚空藏。能于怖畏诸有情类施于无畏。汝等应当归依稽首必无所害。时彼诸人以恐怖故。皆共一心异口同声作如是言。南无大虚空藏菩萨。作是语时虚空藏菩萨。化五百人从虚空下。住彼人前告诸贼言。是等贫匮何用害为。宁杀我等。今当与汝衣服璎珞所须之物。令无所乏勿断彼命。时彼诸贼即杀化人。其五百人咸离怖畏泰然安隐。皆共往诣大虚空藏菩萨之所。恭敬合掌头面礼足作如是言。我等今者皆从大师得全性命故来顶礼。莫知所报广大之恩。唯愿为我说微妙法。当共受持成二利行

尔时大虚空藏菩萨告言。善男子汝等今者既无所惧。各各宜发阿耨多罗三藐三菩提心。则得自利利他成就。说是语已彼等一时。皆发阿耨多罗三藐三菩提心。即以上妙衣服价直百千。奉虚空藏菩萨以申供养。如是供养虚空藏菩萨已。即为供养一切诸佛。尔时世尊悉与彼等授于记莂。于当来世过无量劫。修菩提分法已。当得成佛。同号无怖畏如来多陀阿伽度阿罗诃三藐三佛陀

尔时舍利子白大虚空藏菩萨言。善男子汝得此虚空库藏已来。经今几何不枯不竭。周给一切无有穷尽。虚空藏言。大德于意云何。岂有虚空而竭尽耶。不也大士。虚空藏言。如是大德舍利子。虚空自性无尽。我今所有善根功德亦复如是。所以者何我为菩提。于无量劫积集无量无边善根。悉皆回向如彼虚空无有穷竭。是故周给不竭不尽。如汝所言而此空中施设库藏经几何者。乃至我发菩提心来。空中库藏久近如是。时舍利子复言。汝发菩提心复经几时。答曰如佛世尊知其近远。舍利子即白佛言。世尊此虚空藏菩萨。发菩提心经几许时。佛言善男子我若具说。人天闻者皆生疑惑。舍利子言。善哉世尊。唯愿垂慈为我开示。又此会中有无量众皆共渴仰。愿为解说令得净信

尔时佛告舍利子。譬如恒河沙数世界所有微尘。一一微尘复为一劫。如是尘劫为一洛叉。复有无量那由他洛叉微尘劫。尽是微尘所有劫数。彼虚空藏发于无上正等觉心。经尔所时。舍利子复白佛言世尊。彼虚空藏初发心时。所遇如来名字何等佛。告舍利子。彼时如来出现于世。名一切胜愿宝威德王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名现一切佛刹。劫名宝庄严。舍利子彼现一切佛刹世界。所有功德庄严成就。我以劫寿说不能尽。舍利子彼佛世尊所坐道场。周千世界。复有超过数量诸菩萨众。以为眷属。舍利子彼时世界有转轮王。名一切天灌顶王。于三千大千世界。彼王复有不可思议宝藏有三万六千子。悉皆化生有大威德。彼佛世界乃至无有女人之名。舍利子彼佛世尊寿百千劫。其一切天灌顶王。于四十中劫承事彼佛。一日之中用千俱胝上妙资具。积高须弥以为供养。所积福聚不可思议。其王诸子及诸眷属。皆发阿耨多罗三藐三菩提心舍利子彼时一切天灌顶王莫作异观今虚空藏菩萨是

尔时舍利子白佛言。甚奇世尊。此大虚空藏菩萨。被不可思议甲胄。乃至久远住于大乘。能证如是威德法行。佛言舍利子。是大虚空藏菩萨。所供养佛超过无量恒河沙数。于彼佛所净菩提心。恒河沙数佛所菩提心净则意乐净。恒河沙数意乐净则加行净。恒河沙数加行净则增上意乐净。恒河沙数增上意乐净则檀波罗蜜多净。恒河沙数檀波罗蜜多净则尸罗波罗蜜多净。恒河沙数尸罗波罗蜜多净则忍辱波罗蜜多净。恒河沙数忍辱波罗蜜多净则精进波罗蜜多净。恒河沙数精进波罗蜜多净则禅那波罗蜜多净。恒河沙数禅那波罗蜜多净则般若波罗蜜多净。恒河沙数般若波罗蜜多净则方便波罗蜜多净。恒河沙数方便波罗蜜多净则一切有情无碍心无碍光净。恒河沙数有情无碍心无碍光净则大慈净。乃至大悲大喜大舍大神通智净则身语心净。由恒河沙数心清净则一大人相净。如是广说三十二大人相乃至一切大人相善根净则虚空库藏净。舍利子由如是故。此虚空藏菩萨。能于空中示现一切菩萨之行。舍利子譬如虚空无有穷尽。善男子如是菩萨一切愿行清净无尽亦复如是。是故名为虚空库藏。说是法时会中有一万菩萨。获得无尽财宝干虚空库藏满足愿忍

尔时会中复有菩萨名曰法王。白大虚空藏菩萨言。我愿从空中闻妙法音。虚空藏言善男子汝极生恭敬。心住虚空作大师想。我当令汝闻妙法音。尔时法王菩萨。并诸大众一心合掌。向空礼敬瞻仰而住。以虚空藏菩萨加持力故。即于空中出伽陀曰

  心意与诸法　　皆如于虚空
  我今说少分　　汝等次第听
  虚空无高故　　下亦不可得
  诸法亦如是　　其性无高下
  虚空无有生　　灭亦无所得
  诸法亦如是　　生灭不可得
  空中无损减　　复无增益性
  诸法如虚空　　平等无增减
  空中无有暗　　亦无于所染
  心性亦如是　　无暗亦无染
  譬如日月光　　虚空无爱染
  心亦同虚空　　无爱亦无染
  譬如于虚空　　鉾槊无伤损
  菩萨观众苦　　亦无忧惧心
  如空雨甘露　　虚空无爱悦
  菩萨于名利　　不生染爱心
  毁誉空不动　　苦乐心恒静
  大地虽摇动　　虚空性常住
  菩萨于世法　　远离分别心
  如空火不烧　　菩萨惑无染
  虚空离生灭　　法界无去来
  众色现于空　　诸法依心住
  空无色非色　　心性亦复然
  虚空唯假名　　心意识如见
  如空无边故　　智者德如斯
  犹空迹难成　　菩提行无相
  虚空无前际　　五蕴性亦然
  过现四大空　　未来亦如是
  如劫烧空界　　难满诸有情
  五欲流注心　　难满亦如是
  佛说大法句　　离欲出世间
  教法广无涯　　如空无所得
  了知真实法　　不坏不住性
  知性即无性　　正见住实际
  声性空无有　　言说性亦然
  法体本无言　　无声亦无说
  诸法如幻炎　　梦影响皆空
  寂静无比方　　引导故为喻
  法无相说相　　能所相皆无
  菩萨了真如　　如空无所得
  无著无所有　　无觉无戏论
  不度有情故　　如性为菩萨
  有情本涅槃　　闻此不惊怖
  被勇猛甲胄　　名住菩提者
  犹如于幻师　　害多幻化众
  实无有所害　　所度生亦然
  幻化及有情　　诸佛法亦尔
  若悟同一性　　无自性为性
  虚空藏菩萨　　得虚空库藏
  充足诸有情　　此藏无穷尽
  无边功德聚　　得此清净藏
  汝观诸法性　　其性无移动
  应知一切法　　因缘和合生
  由此无有穷　　法藏难思故
  世尊常演说　　四种法无尽
  有情及虚空　　菩提心佛法
  如诸世间物　　可说有穷尽
  无物无所尽　　是故说无尽
  究竟灭尽法　　尽法无所尽
  无尽无不尽　　是故说无尽
  若人闻此法　　名菩萨觉悟
  则知如是人　　速住菩提道

尔时大众闻是伽陀已。即于会中有八千菩萨得无生法忍。一万二千天子住虚空中。发于阿耨多罗三藐三菩提心

大集大虚空藏菩萨所问经卷第四大集大虚空藏菩萨所问经卷第五

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时众中。有菩萨名常希奇。从座而起白世尊言。未知此声从何而出。佛言善男子。汝当问彼大虚空藏菩萨。当为汝说。尔时常希奇菩萨。即白大虚空藏菩萨言。大士我今不知如此法声从何而出。唯愿仁者为我说之。虚空藏菩萨言。善男子于意云何。彼谷中响从何而有。常希奇菩萨言。因于他声之所显出。虚空藏菩萨言。善男子彼之谷响为是身耶为是心耶为是色耶为是声耶。可实有不。不也大士。响无自体因声显发岂有实耶。善男子响既不实因声而有。如是虚空所出法声亦复如是。从不思议智之所显。由心摄持自空而出故有流转。非即流转能显其声。善男子。汝观因缘和合所作甚深之理。依因感果亦无因果性不流转。而此二法无自性故无作者故。若知因缘不能感果。则了诸法本无和合。所以者何如世尊说。若知杂染是则清净。不断杂染亦自清净。何以故。烦恼自性本清净故。如此二法名施设句。所谓杂染及以清净。依胜义际所建立故。胜义际中杂染清净皆不可得。胜义际者名为无际。即彼无际名为实际。是实际即空际。是空际即我际。是我际即一切法际。若知一切法际空际寂静际极寂静际所有际门。则于一切诸法。无所取着获无碍智。尔时舍利子。问常希奇菩萨言。善男子汝以何故名常希奇。答曰大德舍利子我于一切法。常勤精进生希奇心。乐欲满足而不能解。又于一切菩萨之行生希奇心。当愿入于一切有情心行之智而不能解。愿于一切烦恼魔业令不得便而不能解。是故于法常生希奇。由此因缘名常希奇。尔时长老舍利子白佛言。甚奇世尊。而此正士辩才如是明了。一切诸佛之法无所染着。所说之法亦不取着。尔时会中有菩萨名宝吉祥。白大虚空藏菩萨言。善男子唯愿为我说三摩地。我当如说而修行之。时大虚空藏菩萨告宝吉祥菩萨言。善男子有三摩地名为菩萨清净意乐。能除道障诣菩提故。有三摩地名一切有情无碍光明。谓与有情作照明故。有三摩地名护自他。超越一切他恼害故。有三摩地名为无垢。能令获得心清净故。有三摩地名为遍照。谓能增长诸善法故。有三摩地名为端严。谓能获得澄净性故。有三摩地名为高广。谓能获得无见顶故。有三摩地名为远离。谓能调伏诸烦恼故。有三摩地名为回旋。能右回旋入真道故。有三摩地名为退转。能转外道邪因见故。有三摩地名为作乐。游诸法苑受快乐故。有三摩地名到究竟。殖清净行到后地故。有三摩地名为威德。获心自在无羸劣故。有三摩地名入平等。于诸有情心平等故。有三摩地名知作业。能随所作知业果故。有三摩地名师子幢。能离怖畏身毛竖故。有三摩地名心勇健。能消一切烦恼魔故。有三摩地名芬陀利。于诸世间获无染故。有三摩地名跛度摩。谓能获得心庄严故。有三摩地名光庄严。能照一切诸佛刹故。有三摩地名善作业。谓能永害憎爱心故。有三摩地名幢庄严。谓能照耀诸佛法故。有三摩地名为有炬。能照一切诸习气故。有三摩地名为日灯。能离一切诸黑暗故。有三摩地名为日旋。能观一切有情心故。有三摩地名功德藏。诸功德法随顺转故。有三摩地名那罗延。能伏一切他论难故。有三摩地名为坚固。能获金刚不坏身故。有三摩地名为具坚。能超一切世间慧故。有三摩地名曼荼罗。能获不退诸神通故。有三摩地名金刚场。谓能往诣菩提场故。有三摩地名金刚喻。善能穿凿诸漏法故。有三摩地名为具行。能知有情诸心行故。有三摩地名为治地。能令远离爱欲过故。有三摩地名为摧坏。能令摧坏四魔怨故。有三摩地名日观身。能观一切色身相故。有三摩地名为不[月*旬]。能令专注一境性故。有三摩地名入虚空。能净一切精进心故。有三摩地名为无诤。能超一切所缘境故。有三摩地名无垢轮。能转清净妙法轮故。有三摩地名为电光。能观察心刹那坏故。有三摩地名善作胜缘。能速圆满诸善法故。有三摩地名为能净。能断一切不善法故。有三摩地名身庄严。能满大人相随好故。有三摩地名语庄严。梵音说法令众喜故。有三摩地名心庄严。令诸善法不失坏故。有三摩地名为无畏。能得坚固不退转故。有三摩地名为等施。于诸有情无简别故。有三摩地名戒积集。令一切愿悉满足故。有三摩地名忍甲胄。能于身命无顾惜故。有三摩地名精进坚固。能获速疾诸神通故。有三摩地名无量藏。能令梵王所摄伏故。有三摩地名无所有。令无色界有堪能故。有三摩地名为高幢。不为有情所陵伏故。有三摩地名为高灯。善能观察于十方故。有三摩地名为慧炬。能摧一切障盖缠故。有三摩地名为海印。能现种种所作业故。有三摩地名无量旋。能断一切诸恶见故。有三摩地名为空性。能离一切诸相见故。有三摩地名为无相。能断遍计诸分别故。有三摩地名为无愿。善能清净诸愿相故。有三摩地名为不动。能害一切动意思故。有三摩地名具足音。能善获得无碍辩故。有三摩地名为遍持。能持一切所闻法故。有三摩地名为净念。能善受持诸佛法故。有三摩地名为无尽。悉令有情生欢喜故。有三摩地名为宝严。能令一切得宝手故。有三摩地名为随去。能随有情获心智故。有三摩地名知所趣。于有情趣令觉悟故。有三摩地名为意入。能令心意皆清净故。有三摩地名为法云。随其胜解雨法雨故。有三摩地名为念佛。能证甘露清净法故。有三摩地名为念法。能证离欲诸善法故。有三摩地名为念僧。令于佛法不退转故。有三摩地名为念舍。令于资具悉能舍故。有三摩地名为念戒。建立诸佛法根本故。有三摩地名为念天。令于净法无过失故。有三摩地名入法界。知一切法互相入故。有三摩地名虚空性。令一切法悉无碍故。有三摩地名无生性。能令获得无生忍故。有三摩地名类不类。于文句差别以善巧智悉能持故。有三摩地名妙说无垢印菩萨。由得此三摩地。一刹那顷。能以慧证大菩提故。善男子如是八十三摩地门。一一皆有五百三摩地门。以为眷属合集算计。成于四万三摩地门。清净杂染。足为八万三摩地门。彼前后中际及无尽智。各有五百三摩地门。并清净杂染。合成八万四千三摩地门。乃至如是尔所三摩地。为尔所法鄡驮南。复成如来八万四千差别法蕴。由彼有情八万四千心行别故。善男子根本鄡驮南。令诸有情入佛智行生警悟故。复次一切佛智。入一切有情心行。所说法藏。无量无边不可思议。非百千劫之所能说。我今于此三摩地门略说少分。说此法时会中有一万六千菩萨。于三摩地门证无生法忍。八万四千人天发阿耨多罗三藐三菩提心。尔时世尊赞大虚空藏菩萨言。善哉善哉善男子。快说如是三摩地功德法门。显扬如来微妙胜智。而此法门汝身自证。不由他悟。尔时宝吉祥菩萨白佛言。世尊以何因缘。虚空藏菩萨于如来所。能从虚空雨于众宝。佛告宝吉祥菩萨言。善男子我念过去无量不可数劫。尔时有佛出兴于世。号无垢炎无量光王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名弥佉罗。劫名功德光。善男子其弥佉罗世界。国土安乐人民炽盛。七宝为地其平如掌。清净柔软犹若迦止栗多绵。行随触时受胜快乐。阎浮檀金以覆其上。种种诸宝而为严饰。界以八道宝树行列。如他化天。随所受用皆适其意。诸人天众悉共居止宫殿楼阁。心念饮食随意皆至。善男子彼无垢炎无量光王如来。有六十那由他菩萨摩诃萨众。当于彼时。有转轮圣王名曰福报庄严。七宝具足。其王国城如赡部洲所居宫殿。东西南北四方皆各四瑜缮那。间错七宝以为庄严。复有五百园苑严饰交映。善男子是福报庄严王。有八万四千婇女端正殊妙。有四万子皆悉端严。力勇无敌。有二宝女一名吉祥威。二名吉祥光。王与婇女及诸王子。前后围绕。往诣于彼爱庄严园。游观歌舞而自娱乐。是二宝女各于怀中化生一子。端正无比色相光明。宿植善根成就愿力。志求无上正等菩提。一名师子二名师子勇步。适化生已即共同声。向于父王说伽陀曰

  昔造善恶皆不亡　　供养如来亦不失
  不舍菩提意乐故　　坚固多闻亦不忘
  不失檀那及净戒　　忍辱柔和行成就
  知恩报恩作善业　　精勤不舍菩提愿
  一心禅定得解脱　　定与慧俱心不惑
  能修智业常不动　　是故速得证菩提
  灭诸烦恼而不染　　由此不生胞胎藏
  化生处在莲花上　　如莲在水而无染
  东方有佛名医王　　我等自彼来求法
  亲近供养无垢佛　　成就三世无碍智
  父王可共往佛所　　奉事礼敬以修治
  如来出世遇甚难　　犹若优昙钵华现
  王闻是语极欢喜　　悉与妻子并侍从
  一千俱胝诸眷属　　往诣于彼见如来
  殷勤致敬彼世尊　　妙华涂香以供养
  头面礼足而右绕　　合掌端身住佛前
  师子并及彼勇步　　亦复顶礼于佛足
  礼佛足已伽他赞　　为求正法利有情
  愿为拔济胜归依　　于世盲瞑作灯烛
  妙达有情心意乐　　随彼胜解能开悟
  今我父王恃尊位　　为诸五欲之所缠
  不往亲近于如来　　亦失供养及闻法
  善哉世尊生悲愍　　愿说最胜菩提道
  咸令一切闻法已　　皆得不退于佛乘
  时佛踊在虚空中　　高于八十多罗树
  王今听我最胜法　　闻已如说而修行
  五欲无常命难保　　身如朝露水上泡
  欲乐如梦如嬉戏　　谁有智者生贪着
  习欲之人无厌足　　转令炽盛增渴爱
  愚夫随境无休已　　唯圣慧者能知足
  五蕴如幻而不坚　　诳惑世间应善察
  诸界如彼毒蛇类　　六处喻若空村邑
  无王无国无妻子　　助伴但有于无常
  唯施戒定及精进　　今世他世为伴侣
  观我神通威德力　　相好端严具辩才
  汝乐来世如是业　　应发无上菩提意
  福报大王闻法已　　并与七十俱胝众
  妻子侍从诸眷属　　皆发无上菩提心
  咸言已发最胜心　　悉愿广度众生类
  誓行殊胜菩提行　　愿得成佛世间尊

善男子时福报庄严王。从佛所闻是伽陀已。与其眷属合掌恭敬。稽首作礼而白佛言。世尊唯愿垂慈受我供养。尔时世尊心生怜愍即受其请。时福报庄严王即以种种衣服饮食卧具医药。皆是殊胜上妙珍异离过之财。于八万四千岁以为供养。时师子及师子勇步。并余二万王子。发净信心舍世荣位。于彼佛法出家为道。时王二子勤行精进。于菩提分法。修习不久获五神通。以如意通力及知愿力。能于一切诸佛世界施作佛事。广为有情说于妙法。令无量无数阿僧祇有情。安住阿耨多罗三藐三菩提心。善男子其福报庄严王。过八万四千岁已。为闻法故。往诣无垢炎无量光王如来所。见二童子出家修道穷自思惟是童子出家有何所获。不知于我八万四千岁中。以种种乐具供养功德。善男子时无垢炎无量光如来知王心念。即告师子勇步童子言。善男子汝应示现慧神通福神通力神通。映蔽大众所有威光并魔宫殿一切光明显菩提相。令此大众生希有心。得于正见降伏异论。然大法炬息诸烦恼。游戏菩萨自在神通。尔时师子勇步菩萨。即时举手扪大虚空。三千世界六种震动。复更举手扪摸虚空。即于空中而有百千俱胝天乐。不鼓自鸣其音和雅。复更举手扪摸如前。即雨无量昔未闻见极妙天花。柔软犹如迦止栗那绵。手触之时受胜快乐。并种种宝末香涂香。缯盖幢幡衣服饮食。一切受用庄严资具。积满三千大千世界。一切众会得未曾有。尔时无垢炎无量光王如来。告福报庄严王言。如是雨宝广大惠施可得知其数量以不。王白佛言。世尊所雨宝施犹如虚空不可知量。佛言大王此师子勇步菩萨。若以神通智慧之力。是刹那顷雨如是宝。遍于恒河沙数世界。一切有情随意所取。皆得满足悉令欢喜。善男子当尔之时。有地居天唱如是言。此菩萨于当来世。必得成就虚空库藏。能随有情心之所求。皆从空中雨如是宝。如是四大王众天三十三天夜摩天。睹史多天乐变化天。他化自在天大梵王天。展转相告悉皆如是

尔时无垢炎无量光王如来即便印可。如是当成虚空库藏。作是言已恒沙诸佛。悉共发声同时印可亦复如是。善男子彼福报庄严王。见师子勇步菩萨神变如是。合掌向佛白言。世尊菩萨神通福德之力。乃能如是不可思议。即立王子胜慧继嗣为王。自舍国位剃除鬒发。于彼佛法出家为道。既出家已作是思惟。所舍施者为欲利益身口意故。夫出家者令身口意悉清净故。所舍施者为济阙乏。夫出家者无所阙乏。所舍施者得报危脆。夫出家者获果坚实。所舍施者有我所摄。夫出家者无所摄受。所舍施者有于身见。夫出家者离一切见。所舍施者犹如婴孩。欢喜游戏而无所知。夫出家者寂静智慧悉皆遍知。作是思惟已闲居寂静。不生放逸勤加修道。其后未久获五神通。善男子尔时福报庄严王者莫作异观。即拘留孙如来是也。尔时师子菩萨者即我身是。师子勇步菩萨者即大虚空藏菩萨是。是虚空藏菩萨。于无量百千俱胝那庾多劫。从虚空库藏。常能雨宝无有休息。善男子尔时胜慧王子者。今慈氏菩萨是。善男子悦意清净。宿植善根所闻法教。当知皆是有情依处。说此大虚空藏菩萨昔因缘时。有十二万人。皆发阿耨多罗三藐三菩提心

尔时大虚空藏菩萨白佛言。世尊云何菩萨出世间道。佛告大虚空藏菩萨言。善男子出世间道者。所谓六波罗蜜。三十七菩提分法。奢摩他毗婆舍那。四摄法。四无量心。四禅四无色定。五神通。善男子此名菩萨出世间道。世间者所谓五蕴。菩萨为求菩提。以慧方便知色无常。行于布施知色苦知色无我。知色寂静知色空。知色无相知色无愿。知色无行知色不生。知色不起知色缘生。知色远离知色无执。知色无阿赖耶知色不发起。知色如幻知色如梦。知色如阳焰水月谷响光影。知色如影像如草木瓦砾。而行布施。菩萨如是行施之时。知色真如。由知色真如故即知施真如。知施真如故即知回向真如。知回向真如故即得菩提真如。得菩提真如故即知有情真如。知有情真如故即知我真如。知我真如故即知一切法真如。知一切法真如故非真如不妄真如。不异真如随知如是而行布施。善男子是为菩萨出世间道。如是知受想行识无常已而行布施。如是知识无我知识寂静。知识空知识无相。知识无愿知识无行。知识无生知识无起。知识缘生知识远离。知识无执知识。无阿赖耶。知识不发起知识如幻如梦阳焰水月谷响光影影像。知识无形相已而行布施。如是行施之时。知识真如故即得施真如。由得施真如故即得回向真如。得回向真如故即得菩提真如。得菩提真如故即得有情真如。得有情真如故则得我真如。得我真如故则得一切法真如。得一切法真如故。非真如不妄真如不异真如而行于施。善男子是为菩萨出世间道。复次善男子菩萨。知色无常已而护于戒。乃至知色如草木瓦砾已而护于戒。菩萨如是护戒之时。知色真如。由知色真如故则知戒真如。戒真如故则得回向真如。回向真如故则得菩提真如。菩提真如故则得有情真如。有情真如故则知我真如。我真如故则得一切法真如。一切法真如故。非真如不妄真如不异真如。则随护于戒。善男子是名菩萨出世间道。如是知受想行识无常已。而护于戒。如是乃至知识无形相已。而护于戒。如是护戒之时。由知识真如故则得戒真如。戒真如故即得回向真如。回向真如故则得菩提真如。菩提真如故则得有情真如。有情真如故则知我真如。我真如故则得一切法真如。一切法真如故。非真如不妄真如不异真如则随护戒。善男子是为菩萨出世间道。复次善男子菩萨。知色无常已而行忍辱精进禅定般若。乃至知色如草木瓦砾已而行般若。菩萨如是行般若之时。知色真如。由知色真如故则得般若真如。般若真如故则得回向真如。回向真如故则得菩提真如。菩提真如故则得有情真如。有情真如故则知我真如。我真如故。则知一切法真如。一切法真如故。非真如不妄真如不异真如行于般若。善男子是为菩萨出世间道。如是知受想行识无常已。而行般若。如是乃至知识无形相已。而行般若。如是行般若时。由知识真如故则得慧真如。慧真如故则得回向真如。回向真如故则得菩提真如。菩提真如故则得有情真如。有情真如故则知我真如。我真如故知一切法真如。一切法真如故。非真如不妄真如不异真如。而行般若。善男子是为菩萨出世间道。复次善男子菩萨。知色无常已。于身观身修身念处。乃至知色如草木瓦砾已。修身念处。菩萨如是修身念处之时。知色真如知色真如故。知身真如。乃至知一切法真如。一切法真如故。非真如不妄真如不异真如修身念处。不共身俱行寻伺。善男子是为菩萨出世间道。如是受想行识。知无常已修身念处。如是乃至知识无形相已修身念处。如是修身念处之时。由知识真如故则得身念处真如。身念处真如故则得回向真如。回向真如故则得菩提真如。菩提真如故则得有情真如。有情真如故则知我真如。我真如故则知一切法真如。一切法真如故。非真如不妄真如不异真如修身念处。乃至修受心法念处。亦复如是。不与法俱行寻伺。善男子是为菩萨出世间道。如是知色无常已。修四正勤四如意足五根五力七菩提分八圣道分奢摩他四摄四无量四禅四无色五神通。亦如是知色苦色无我色寂静色空色无相色无愿色无行不生不起缘生远离。乃至知色如草木瓦砾已。引神通智。如是知受想行识无常已引神通智。乃至知识无表相已。引神通智。如是蕴真如神通真如故。乃至一切法真如。一切法真如故。非真如不妄真如不异真如引神通智。亦复如是。善男子是为菩萨出世间道。何以故。此道超越世间道故。知色真如不坏其色。不断不常从于缘生无生自性。如是知受想行识真如。不坏其识。不断不常从于缘生无生自性。超蕴世间并欲色无色。而无染着以不染故。为于五趣受生有情。说此名为出世间道。由佛假说有于世间。是故不坏。何以故无常相不坏世间苦相无我相寂静相空相无相相无愿相无行相。乃至真如相不坏世间故。善男子是为菩萨出世间道。此道清净。菩萨若住此清净道。即能于彼恶道有情作大光明。由得光明名为安住出世间道。此道最胜能令住趣菩提场故。此道净胜。能离一切不善心故。此道殊胜。能到于佛智慧顶故。此道无上。能度生死诸瀑流故。此道无比。能超一切偏异道故。此道无等。无有一法能相类故。此道无等等。不离往昔因佛道故。此道安隐。善能摧伏诸魔怨故。此道无碍。如意通智所游戏故。此道无暗。有慧光明故。此道平正。无诸谄曲故。此道端直。离诸邪曲故。此道平等等有情心故。此道广大。容诸有情故。此道宽博。互不相逼故。此道能生。无有疲倦故。此道福资粮。檀波罗蜜故。此道无热恼。戒波罗蜜故。此道无怖畏。忍波罗蜜故。此道不退转。进波罗蜜故。此道离诸境。禅波罗蜜故。此道遍虚空。慧波罗蜜故。此道随顺智。能令变化故。此道常满足。集诸善法故。此道随法轮所闻不忘故。善男子是为菩萨出世间道。如是殊胜清净无比。若菩萨欲住此清净道。当被大甲胄成就大乘。由此往诣菩提场故。何等名为被大甲胄。此诸菩萨。若被未度者令度甲胄。修治大船故。被未解脱者令解脱甲胄。解脱烦恼诸见缚故。被未安者令安甲胄。令舍一切摄受怖故。被未涅槃者令得涅槃甲胄。令颠倒者获正道故。被解脱一切有情甲胄。令着我有情命者寿者无所得故。被受持正法甲胄。不贪身命故。被净佛刹土甲胄。修习善根无厌足故。被庄严相好甲胄。积集种种福资粮故。被摧诸魔外道所说甲胄。获神通力故。被令一切有情欢喜甲胄。获四无碍智故。被求诸佛正法甲胄。得陀罗尼智故。被观一切有情心甲胄。得神通智故。被知一切有情根前后智甲胄。由方便智慧故。被满足十力甲胄。积集智慧力故。被无所畏甲胄。于一切处心无退没故。被满足十八不共法甲胄。修一切善法断一切不善法故。被闻一切法不惊不怖不畏甲胄。知一切法如幻梦光影谷响水月故。被大悲甲胄。知诸有情本来涅槃悉成就故。被善巧方便甲胄。闻空无相无愿无行一切法不生。而能示现处生死故。被先加持不动甲胄。闻说超过尼夜摩相。一切诸法不生一切行不灭。不取果证故。是为菩萨大乘甲胄。菩萨被此二十大甲胄已。乘于大乘到于彼岸。复次乘者。以四摄法为轮。善能摄取诸有情故。以净十善为辐。善能通达诸正行故。以净意乐善根为轴。善作甚深行根本故。以广大缘生智为毂。堪任荷负有情善故。以大慈悲为辋。摄受法宝眷属而庄严故。以坚固力为系缚。最胜功德无退失故。以先誓愿及善巧智为运动。大悲方便能双运故。以奢摩他为辕。引发正慧善能遍知四圣谛故。以无遮施辐为资粮故。以如意足游诸佛刹故。以正念绳持菩提心不退失故。复次乘者。广博容受一切有情。摧伏二乘制诸外道破坏魔众显现明智。能到究竟一切菩萨所应学故。梵释诸天皆赞仰故。如师子座安处一切说法者故。亦能显现微妙色相观无厌故。金刚钩锁坚固意乐。常无坏故。以菩提心而为先导。令身行愿功德满故。以净天眼常观察故。以净光明照十方故。常雨清净觉支花故。常奏无碍法音乐故。善说正理相应法故。善化同类诸有情故。一切菩萨为眷属故。无量功德所庄严故。流出无上萨婆若故。善男子如是菩萨擐彼二十清净甲胄。乘此大乘住出世道。以作佛事安立有情。说此大乘甲胄庄严时。七万二千人天。发于无上正等菩提之心。三万二千菩萨。于出世间道。皆得清净获无生忍

大集大虚空藏菩萨所问经卷第五

丙午岁高丽国大藏都监奉　敕雕造大集大虚空藏菩萨所问经卷第六

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时宝吉祥菩萨。问大虚空藏菩萨言。仁者汝已净出世间道耶虚空藏菩萨言。善男子如是已净。复问言云何已净。答言我清净故已净。复问言云何我清净。答言世间清净故我清净。复问言云何世间清净。答言善男子色前际清净无去故。色后际清净无来故。色中际清净不住故。如是受想行识。识前际清净无去故。识后际清净无来故。识中际清净不住故。善男子是故名为世间清净。复问仁者如是世间清净。欲何所显。答言善男子显一切法悉皆清净。复问云何显一切法清净。答曰以智慧故。知一切法前际后际之分齐故。复问云何一切法前后分齐。答曰不断不常故。复问于彼不断不常是何言说。答曰不断不常是不生不灭言说。复问于彼不生不灭是何言说。答曰不生不灭是无言说。复问云何法无言说。答曰是法无数故。复言仁者法若无数云何随于名数。答曰善男子譬如虚空不随名数。但以名数假名虚空。如是名数即非名数。复问云何数非数门答曰数门者说有为法。非数门者说无为法。又数非数法皆是无为。是故佛说应以智慧远离一切称量数法。于有为数以识称量如理观察。尔时不见是法应断是不应断。是法应证是不应证。是法应修是不应修。不见诸法亦不作限量。若无见无量。是时即获无所执着得无怖望。若无怖望则无所缘。得无所缘则得无我。若得无我则无所执。云何无所执。不执色是常无常。不执受想行识是常无常。不执色是苦是乐。不执受想行识是苦是乐。不执色是我无我。乃至不执识是我无我。不执色是净非净。乃至不执识是净非净。不执色是空非空。乃至不执识是空非空。即获无所执着三摩地。得是三摩地已。常起大悲度诸有情。不见流转生死烦恼。所以者何生死涅槃性无别故。于诸有情现见涅槃。亦知自身本来涅槃。是名菩萨般涅槃行。善男子云何菩萨般涅槃行。般涅槃者名无有观行。回向萨婆若。于萨婆若不作色求。不作受想行识求。以无求心住清净戒满足本愿。于一切法不见增减。获于平等住于法界。由住法界行菩萨行。亦无行法而为所行。善男子是为菩萨般涅槃行。复问云何无行有行观察涅槃。善男子菩萨作意观察涅槃。名为有行证于无行。以无行故名为涅槃。复次菩萨于言说诠表不生分别。名为涅槃。又涅槃者名为彼岸。而彼岸者无有诸相。于彼诸相心不取着。名为涅槃。又彼岸者名无分别。于彼不起分别心故名为涅槃。又彼岸者无阿赖耶。于彼不起阿赖耶心故名为涅槃。善男子。如是行已名为菩萨般涅槃行。尔时世尊赞虚空藏菩萨言。善哉善哉正士。快说此法契于菩萨般涅槃行。说此法时。会中有五百菩萨。得无生法忍

尔时大虚空藏菩萨摩诃萨白佛言。世尊由于如来智慧光明照曜我等故得斯辩。非我能也。譬如日光照阎浮提所有色像。如是世尊大调御士慧光明力。能令我等晓了诸法。亦复如是

尔时宝吉祥菩萨。谓虚空藏菩萨言。善男子汝今云何隐其自智。皆言尽是如来加持。虚空藏言。一切菩萨所获辩才。皆是如来之所加持。非唯于我。善男子若无如来所说诸法菩萨从何而有辩才宝吉祥言若因如来生菩萨辩。当知佛辩可移转耶。虚空藏言。如来辩才无有移转。但为其因。以因如来所说之法。生菩萨辩。譬如无明不转至行。但为行因生起行故。如是佛辩无所移转。但为作因生菩萨辩。又如象马人声不转至谷。因彼等声生于谷响故。彼声等但与谷响而作其因。佛辩亦尔无有移转。但与菩萨辩才作因。宝吉祥言。如来常说甚深缘生。又说诸法而无所生。善男子岂无缘生一切法耶。虚空藏言。若缘有作者。是法有生。因缘之法无有作者。是故诸法说无有生。宝吉祥言。如来今者出现于世。岂非生耶。虚空藏言。若真如有生。可说如来有其生也。若许真如无有生者。不应征责如来出世以为有生。是故无生说为如来。如来者于一切法随所觉悟。名为如来。汝善男子复云何言如来生耶。此应置答。复问云何置答。对曰如法性住。是名为置。复问法性云何住。虚空藏言。住不生不灭不住非不住。是名法性住。如法性住无所住。一切诸法亦复如是住无所住。如来亦尔。住无所住。不生不灭非住非不住。如是非住非不住。名如来住处。善男子言如来生者。是着一边。言不生者亦着一边。离此二边。名为中道。善男子观如来者应如是观。若异观者非正观也。宝吉祥言。如来生义。如是甚深。住无所住不生不灭。虚空藏言。善男子若解此佛生之义者。不生增上。复问善男子云何名增上。虚空藏言。增上者名增益句。谓于无中妄生增益。法无增益。若能于法不生增益。名平等句无等句。无句无句句。无文字句无了别句。于彼无心意识所行无所行句。其无所行句。譬如空中实无鸟迹。假以音说说鸟迹声。如是如来实无有生。假以言说说佛出世。其智慧者。方能晓了不生句义。所以者何此不生句义。即是一切诸法自性。所谓无生。而此无生亦无自性。无自性者无有所住。无所住际是一切法际。住一切法际名为实际。亦名边际际遍一切处故。由是证得一切法实际。犹如虚空平等无有限齐。彼法实际亦无限齐。若限齐际者。不名一切法实际。如是平等一切法实际则我际。知我际则知一切有情际。若知一切有情际则知一切法实际。是实际是我际。是一切有情际。是一切法际。是名尽际。夫尽际者涅槃之谓也。证此理者名得涅槃。又一切法者无有相待。离相对治。譬如虚空无能对治。如是诸法亦无对治。若言有涅槃可入可求。是生灭见。此法应生此法应灭。彼人则为行于生灭。不知涅槃平等一性。以不知故则着诸法妄生诤论。如世尊言若知我教授。应知则为满足沙门最胜功德。尔时具寿阿难陀白佛言。甚奇世尊。大虚空藏菩萨无碍辩才。乃能如是由自身证。能作斯说。时大虚空藏菩萨语阿难陀言。大德不应说言我自身证。所以者何我身即虚空。以身虚空故。知一切法悉为虚空。云何大德言我身证。阿难陀言。身若空者。汝以何身而作佛事。虚空藏言。以法身故法身者无有迁变。蕴处界等不生不灭。非颠倒身得随意现。意所成身而作佛事。阿难陀言。大士汝证法身耶。虚空藏言。大德如我所解离法无身。我身即法法即我身。若法若身无有二相故言身证。阿难陀言。大士若身证者汝得阿罗汉耶。答言无所得故而得。所以者何。阿罗汉者。善能通达无诤法故。不染不恚亦不痴故。复言大士若如是者。汝应究竟般涅槃耶。虚空藏言。大德阿罗汉者不般涅槃。何以故知一切法究竟涅槃断涅槃想。但诸异生作是分别言我涅槃。乃至分别计有种种涅槃差别。阿难陀言。大士如汝所说。菩萨非阿罗汉。非异生非学非无学。非辟支佛非菩萨非如来。虚空藏言。善哉善哉具寿阿难陀。以非阿罗汉非异生非学非无学非辟支佛非菩萨非如来故。菩萨于一切处皆能示现。亦不住于一切位地。说是法时。会中有五百阿罗汉。各各脱身所著上服。而以供养虚空藏菩萨。作如是言。愿一切有情获得辩才如虚空藏。尔时大虚空藏菩萨。以加持力故。令其所奉上妙法衣。尽入虚空隐而不现。彼等罗汉苾刍。问虚空藏菩萨言。大士如是等衣。为何所在。虚空藏言并入于我虚空库藏

尔时世尊熙怡微笑。阿难陀白佛言。世尊何因缘故而现微笑。如来微笑非无因缘。唯愿演说。佛告阿难陀言。彼诸苾刍所奉衣服。以虚空藏菩萨威神力故。令衣尽入虚空。库藏往彼袈裟幢世界山王如来所。而作佛事。虚空藏菩萨所说法音。于彼世界皆从袈裟之所流出。无量菩萨闻此法已。皆得无生法忍。阿难陀当知菩萨神通智胜。以如是等种种言音。成就有情以是因缘故我笑耳。说是法时忽于空中。雨无量日月光花。皆如火色昔所未见。花中出声而作是言。若人闻此大虚空藏菩萨所说不退法印得生信解。必定当趣菩提道场

尔时诃难陀白佛言。世尊如是之花从何所来。佛告阿难陀。有一梵王名光庄严。为百千世界主。是彼梵天为供养虚空藏菩萨故雨如是花。阿难陀言。世尊我等咸愿见彼梵王。佛言且待须臾汝当自见

尔时光庄严梵王。与诸梵众六十万八千人。前后围绕。从彼天没至于佛前。头面礼足右绕三匝。退坐一面合掌向佛。白言甚奇世尊。此虚空藏菩萨不可思议。具足净戒。威德三摩地威德。神通威德智慧威德。满愿威德善巧方便威德。增上意乐威德法身自在威德。身庄严威德口意庄严威德。于一切法自在威德。世尊是虚空藏菩萨。都不从于身口意业。勤发示现一切化事。但由往昔修习之力。积集善根满足诸佛甚深之行。由此能作大师子吼。佛言如是如是。梵王如汝所说。菩萨皆由昔善根力积集福智资粮。而于无上正等菩提。誓不退转。能现如是神通化事

尔时光庄严梵王白佛言。世尊云何为菩萨善根。云何为福云何为智。佛告梵王言。善根者谓诸有情。最初发于阿耨多罗三藐三菩提心。福者谓发心已起。于一切声闻缘觉。为诸有情修行布施持戒。及修所成一切福业。智者谓以所集善根回向萨婆若故。复次善根者谓净意乐无矫诳故。福者加行积集一切福故。智者增上意乐悉殊胜故。复次善根者于诸善法愿坚固故。福者集善资粮无厌足故。智者所有善根观如幻故。复次善根者谓获善友。福者不舍善友。智者数问善友。复次善根者乐求佛法。福者所闻不忘。智者悦于法乐。复次善根者常求佛法。福者说法无所悕望。智者于法无吝。复次善根者常乐听法。福者如理观察。智者如法修行。复次善根者常乐见佛。福者常供养佛。智者随顺佛教。复次善根者谓获出家。福者修圣种行。智者乐住兰若。复次善根者善能修习少欲知足。福者于诸衣食任运不贪。智者于所受用任运无染。复次善根者修念处观。福者满四正断。智者获如意足。复次善根者谓入信根。福者修于进念。智者观三摩地慧。复次善根者住于五力。福者随顺觉支。智者入圣道智。复次善根者心住妙理。福者求奢摩他资粮。智者得毗钵舍那善巧。复次善根者谓施所成福业事。福者谓戒所成福业事。智者谓修所成福业事。复次善根者谓增上戒学。福者增上心学。智者增上慧学。复次善根者说悔诸罪。福者随喜众善。智者劝请诸佛。复次善根者舍诸所有。福者不悕望报。智者回向菩提。复次善根者于戒要期。福者持戒不缺。智者持戒回向。复次善根者于诸有情不怀损害。福者所闻恶语而能忍受。智者能舍身命成就有情。复次善根者勤求善法不生厌倦。福者以所有善根回施有情。智者积集善根回向菩提。复次善根者谓能修习诸禅支等。福者谓获禅定一切善根。智者从诸禅定现生欲界。复次善根者慧力多闻。福者所闻观察。智者慧得圆满。复次善根者等视有情。福者证得慈定。智者慈心平等犹如虚空。复次善根者谓修习三地资粮。福者积集四地资粮。智者圆满八九十地资粮。复次善根者谓初发心菩萨。福者住行菩萨。智者不退菩萨。复次善根者谓平等行。福者相好庄严。智者无见顶相。复次善根者庄严佛上。福者心念惠施。智者利诸有情。复次善根者闻说魔业。福者觉察魔业。智者能超魔业。复次善根者谓具大悲。福者善巧方便智者谓修般若。复次善根者庄严菩提道场。福者善能摧坏诸魔。智者谓一刹那心相应慧成于正觉。梵王如是名为善根福智

尔时光庄严梵王白佛言。甚奇世尊。能以三句义说一切法。时大虚空藏菩萨摩诃萨。告光庄严梵天言。梵天有一句能摄一切法。云何为一谓性空句。所以者何由一切法同空性故。是谓一句。复有一句摄一切法。谓无相句无愿句。皆摄一切法。如是广说。乃至无行句离欲句。寂静句无阿赖耶句。法界句真如句。实际句不生句。不起句涅槃句。各摄一切法亦如是。复次梵王欲者是离欲句。以离欲性即是欲故。一切佛法亦同是性。嗔者是离嗔句。以离嗔性即是嗔故。一切佛法亦同是性。痴者是离痴句。以离痴性即是痴故。一切佛法亦同是性。乃至身见者是无身见句。以无身见性即是身见故。一切佛法亦同是性。色者是无色句。以无色性即是色故。一切佛法亦同是性。如是受想行识。识者是无识句。以无了别性即是识故。一切佛法亦同是性。如是广说处界十二缘生。无明者即是明句。以明性即是无明故。一切佛法亦同是性。乃至生者是不生句。以不生性即是生故。一切佛法亦同是性。一切法句者是无法句。以无法性即是诸佛法故。一切佛法亦同是性。梵王是为一句摄一切法。若菩萨入此法门者。则于一句入一切佛法。梵王譬如大海吞纳众流。是一一句摄一切法亦复如是。譬如虚空能包万像。此一一句摄一切法亦复如是。是故此句无尽展转无量。譬如算师数以算筹布在局上。然局中无筹筹中无局而能展转成无量数。如是一句成无量句亦复如是。梵王如是等百千劫。所说校量佛法。若身若心皆无所得。亦不可以数知。何以故一切法者是佛法故。是佛法者即非法故。所以者何以想分别以想遍知。假名说故。于中无相亦非无相无法非无法究竟无相。此相清净自相远离。犹如虚空同一自性。佛法亦尔性相皆空。虚空藏菩萨说是法时。于彼梵众二万二千梵天。皆发阿耨多罗三藐三菩提心。复次五千梵王。以宿植善根获无生法忍

大集大虚空藏菩萨所问经卷第六

丙午岁高丽国大藏都监奉　敕雕造大集大虚空藏菩萨所问经卷第七

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时宝手菩萨摩诃萨。问大虚空藏菩萨言。善男子菩提心者。以何法摄持得不退转。虚空藏菩萨言。善男子菩提心者。以二法摄持住不退转。云何为二。所谓意乐及增上意乐。复问言善男子。此意乐及增上意乐以何所摄。答言善男子以四法摄。云何为四。所谓意乐以无谄及无诳所摄。增上意乐以不杂心及胜进修行所摄。是为四法摄于二法。复问言而此四法于几法摄。答言以八法摄。云何为八。所谓无谄以正直及正住所摄。无诳以无虚假及清净意乐所摄。不杂心以不退没心及不退精进所摄。胜进修行以福德资粮及智慧资粮所摄。是为八法摄于四法。复问善男子。又此八法以几法摄。答言以十六法摄。云何为十六。所谓正直以寂静及柔和所摄。正住以无我及无矫所摄。无虚假以大慈及大悲所摄。清净意乐以身清净及心清净所摄。不退没心以坚固及力所摄。不退精进以如说所作及正修行所摄。福德资粮以加行及增上加行所摄。智慧资粮以多闻及思所闻所摄。是为八法以十六法摄。复问言此十六法以几法摄。答言善男子此十六法。以三十二法摄。云何为三十二。所谓寂静以惭及愧所摄。柔和以善语及安乐住所摄。无我以谦下及不动所摄。无矫以无垢及无伤语所摄。大慈以于一切有情平等心及无碍心所摄。大悲以无疲倦及供给有情一切作使所摄。身清净以不害及自财知足所摄。心清净以调柔寂静性所摄坚固以不缺要期及决定拔济所摄。力以善住慧及不动慧所摄。如说所作以如说性及能作所摄。正修行以正加行及正精进所摄。加行以超胜及不退转所摄。增胜加行以从他闻及如理作意所摄。多闻以亲近善友及随顺善友所摄。思所闻以正行勇猛及静虑观察所摄。善男子是为以三十二法摄十六法。复问言善男子此三十二法。以几法摄。答言此三十二法。以六十四法所摄。云何为六十四。所谓惭以内观察及摄诸根所摄。愧护外境及敬有德所摄。善语以求法及爱乐法所摄。安乐住以身静及心静所摄。谦下以不贡高及如法语所摄。不动以身不曲及心不曲所摄。无垢以除三垢及修三脱门所摄。无伤语以无粗犷及无离间语所摄。无碍心以自护及护他所摄。于一切有情平等心以无简别及一味性所摄。不疲倦以如梦自性及如幻自性所摄。供给有情一切作事以神通及方便所摄。不害以羞耻及信业报所摄。于自财知足以少欲及知足所摄。调柔以不躁动及不欺诳所摄。寂静性以舍吾我及无我所所摄。不缺要期以观菩提心及顺菩提场所摄。决定拔济以觉悟魔业及诸佛加持所摄。善住慧以不轻躁及不掉动所摄。不动慧以心如山及不移转所摄。如说性以善作业及不追悔所摄。能作以实性及真性所摄。正加行以顺缘生及离断常所摄。正精进以加行及如理所摄。不退转以正断及不懈慢所摄。超胜以勇猛及精进所摄。从他闻以善友及求法所摄。如理作意以奢摩他资粮及毗钵舍那资粮所摄。亲近善友以承顺及恭敬所摄随顺善友以身轻利及心轻利所摄。正行勇猛以涅槃及离欲所摄。静虑观察以因不坏及果不坏所摄。善男子是为三十二法以六十四法所摄。复问言善男子此六十四法以几法摄。答言善男子。此六十四法以一百二十八法所摄。所谓内观察。以观空及观性所摄。摄诸根以正念及正知所摄。护外境以防诸根及不驰散所摄。敬有德以观自过智者及不求他过智者所摄。求法以自要期勇猛不退及于他作恶不念所摄。爱乐法以求法及顺法所摄。身静以离昏沉及离痴性所摄。心静以遍知及断除烦恼所摄。不贡高以不憍慢及断暴恶所摄。如法语以断不善法及满一切善法所摄。身不曲以不粗语及不恶语所摄。心不曲以正念及正三摩地所摄。除三垢以不净观及慈悲观所摄。修三解脱门以无数取趣及胜义所摄。不粗犷以利益语及安乐语所摄。无离间语以不坏语及和合语所摄。自护以不作一切罪及积一切福所摄。护他以忍辱及柔和所摄。无简别以等虚空心及如风心所摄。一味性以真如及法界性所摄。如梦自性以见闻觉知法及所经不受用法所摄。如幻自性以诳惑及遍计分别所摄。神通以成辨利益及顺智慧所摄。方便以慧光明及观有情所摄。羞耻以悔已不生及无覆藏自过所摄。信业报以现证诸法不生放逸及畏后世苦所摄。少欲以清净受用及离无厌足心所摄。知足以易满及易养所摄。不躁动以究竟尽及无诤所摄。不欺诳以实语及法柔和所摄。舍吾我以不计因及摧恶见所摄。无我所以无我慢及无贪所摄。观菩提心以不希望劣乘及悲愍有情所摄。顺菩提场以摧伏诸魔及现证佛法所摄。觉悟魔业以善友教授及修习般若波罗蜜多所摄。诸佛加持以如说所作及不舍一切有情所摄。不轻躁以心如地及断爱憎所摄。不掉动以离恶作及观无常所摄。心如山以不高及不下所摄。不移转以不退坏愿行及胜进愿行所摄。善作业以智所作及不追念魔事所摄。不悔以戒清净及三摩地清净所摄。实性以世俗谛及胜义谛所摄。真性以真如及真实所摄。顺缘生以因及缘所摄。离断常以无生及无灭所摄。所加行以信业果及拔除业所摄。如理以远离道及不生道所摄。正断以断不善及不断善所摄。不懈慢以心力及身。力所摄。勇猛以审谛及不失修行所摄。精进以不杂心及不退转所摄。善友以恭敬及供养所摄。求法以求正智及求解脱所摄。奢摩他资粮以身远离及心远离所摄。毗钵舍那资粮。以闻法不厌及如理作意所摄。承顺以礼拜及合掌所摄。恭敬以实语及不欺诳所摄。身轻利以于食知量及初中后夜警策睡眠相应所摄。心轻利以无欲及正思惟所摄。涅槃以离无常及苦所摄。离欲以无我及无摄受所摄。因不坏以寂灭因及胜解所摄。果不坏以如瑜伽不欺诳及如胜解果赞叹所摄。善男子是为六十四法以一百二十八法所摄。善男子如是我已略说一切法所摄。若倍倍说诸法增数。以我无断办才。或于一劫或余一劫不可穷尽

尔时宝手菩萨闻大虚空藏菩萨说是诸法所摄之时。得未曾有踊跃无量。即以右掌覆此三千大千世界。于刹那顷。尽十方界所有花鬘涂香末香。幢幡衣服众妙音乐。皆从宝手右掌之中如雨而下。遍满三千大千世界。花至于膝。幢幡衣服周遍虚空严饰交映。百千音乐不鼓自鸣。于其声中出伽陀曰

  持德显德百福满　　摧魔念慧具修行
  善说法要大沙门　　能摧十方有漏行
  殊胜修持吉祥满　　降伏怖畏离尘惛
  能度人天置涅槃　　十力尽漏心无相
  以微妙音演说法　　不失不谬三垢除
  人天无比三界尊　　随顺世间能与乐
  念慧修持悉圆满　　十力最胜坏魔军
  由是能开甘露门　　无有尘累善调御
  游行不动出于众　　十方调伏利人天
  妙慧如空无所依　　法界不动安如地
  声光能坏诸尘暗　　是故妙赞离垢尊
  慧光照曜满吉祥　　光显牟尼蔽魔众
  随化人天在三有　　示定示乱离攀缘
  世间无碍悉如空　　故佛调伏人天者
  三千大海量可悉　　十方虚空犹可步
  一切有情心可知　　如来功德难思测

说此伽他赞叹佛时。天魔波旬严四种兵。来诣佛所住众会前。现其自身如长者形。头面礼足住在一面。白佛言。世尊此大虚空藏菩萨。及宝手菩萨是二正士。成就无量无边功德。又能示现如是种种奇特神通利益之事。于未来世。而有有情闻此经典开悟信解思惟者不。佛告波旬未来世中。信此经者其数甚少。如以一毛端折为百千分。以此一分于大海中取一滴水。善男子信此经者如毛端水。不信之者如大海水。时魔波旬闻是语已。心大欢喜。踊跃歌舞出于众会

尔时舍利子白佛言。世尊此是何人。欢喜踊跃出于众会。佛告舍利子是天魔波旬。现长者形来至我所。欲隐蔽正法闻说后世信经者少心生庆快。是故唱言。沙门瞿昙眷属减少。我眷属多

尔时魔波旬生欢喜已。出于众会欲还天宫。作如是念。此虚空藏及余菩萨。并于瞿昙所有功德。皆悉减少时。虚空藏菩萨。即以神力制魔波旬及其眷属。住于空中令不得去。而告魔言。波旬虚空无碍。何不速去还

尔时天宫魔即答言。汝见虚空无有障碍。我观空中尽唯暗黑。不知所从。唯向下观见佛世尊光明普照。时虚空藏菩萨。告波旬言。波旬岂有内心意乐白法外见暗耶。无如是理。时魔波旬自知内心常怀嫉恼。深生愧耻白虚空藏菩萨言。我从今日之后更不复作魔罗之业。虚空藏菩萨言。波旬是为希有是为难事。能发如是坚固之愿。波旬汝及眷属。宜应下来于如来所听闻法要。所以者何。佛世难值。时魔波旬意还本宫志不乐听。以虚空藏告敕之故。与诸眷属从于空中。俯仰而下

尔时虚空藏菩萨。告众菩萨言。诸仁者颇能宣说超越诸魔之法门耶。各随所乐说之。时彼会中有菩萨名曰山王。作如是言。若有求离魔之境界。是堕魔界。若知一切境界皆是佛界无有魔界。是人则名随佛境界。入佛境者尚不见有佛之境界。况余境界。菩萨由此超越魔道。是故名为超魔法门。宝吉祥菩萨曰。心缘虑者为魔境界。若复于法无所缘虑。知一切法皆无所得。则获无阿赖耶。彼何有魔之所为作。是为菩萨超魔法门

宝手菩萨曰。若有执着则堕魔境。若不取着则无诤竞。与一与二不共心俱。何况诸魔。若菩萨证此不俱法门。则超魔境是为菩萨超魔法门

宝勇菩萨曰。若堕空有是为有诤以有诤故。则住魔境。若不堕空有随顺相识。而无所转住无相际。则超魔境。是为菩萨超魔法门。宝思惟菩萨曰。如来说一切妄想烦恼。如光影如影像。不转非不转。不来不去不住内外。若如是知者。则于分别烦恼不起。于分别烦恼不灭。则断遍计。超于魔境。是为菩萨超魔法门

宝藏菩萨曰。若有染不染则有爱憎。以有爱憎则堕魔行。若离憎爱名住平等。若住平等则于诸法种种相离。离诸相故平等思惟。得是平等名超魔境。是名菩萨超魔法门。离宝菩萨曰。起于我者则为魔业。若我清净何有魔为。所以者何。由我净故烦恼清净。烦恼净故一切法清净。由一切法净故虚空清净。住是虚空清净法者则超魔境。是为菩萨超魔法门

法王菩萨曰。譬如大王得灌顶已有大营从无所怖畏。得灌顶菩萨亦复如是。以众法宝而为眷属。于一切魔无有怖畏。所以者何。彼灌顶位。满足一切无量佛法法宝眷属。能持十方一切诸佛所说之法。若菩萨住如是心则超魔境。是为菩萨超魔法门

山相击王菩萨曰。譬如有孔隙处风入其中。摇动于物有往来相。菩萨亦尔。若心有间隙心则摇动。以摇动故魔则得便。是故菩萨守护于心不令间隙。若心无间隙则诸相圆满以相圆满故。则空性圆满。是为菩萨超魔法门。喜见菩萨曰。于诸见中见佛见法。是为最胜。此中见佛者不以色见。不以受想行识见。于一切法都无所见。是真见佛见法者。于一切法离于作意。不见文字不生贪着。是真见法。以见佛见法得成就故。能超魔境。是为菩萨超魔法门

帝网菩萨曰。起念思惟名为魔业。菩萨于彼因缘。若有动念思惟。不如理作意。皆是魔作。若不动不念。不起思惟不生于触。则超魔境。是为菩萨超魔法门

功德王光明菩萨曰。若有对治则为魔业。若无对治即为法界。一切诸法皆顺法界。若入法界则无魔界。所以者何。离于法界魔不可得。法界魔界同真如性无有少异。菩萨解此则入一道超于魔境。是为菩萨超魔法门。香象菩萨曰。无力者魔得其便。有力者魔不得便。无力者谓于三解脱门闻生惊怖。有力者于三解脱门闻不惊怖。何以故。若证解脱则不惊怖。通达此者不生惊怖。善修行者亦不惊怖。无惊怖故则超魔境。是为菩萨超魔法门

慈氏菩萨曰。犹如大海同一碱味。佛法智海同一法味。亦复如是若佛若法。悉皆平等空无相愿。不生不起一相平等一味平等。若菩萨了知一味相者则超魔境。是为菩萨超魔法门。虚空藏菩萨曰。仁者譬如虚空起过一切所有境界。亦无眼耳鼻舌身意。菩萨如是知一切法自性清净。犹如虚空等身口意入智光明。若得智光则超魔境。是为菩萨超魔法门。文殊师利菩萨曰。仁者汝等所说悉是魔境。何以故。施设文字皆为魔业。乃至佛语犹为魔业。无有言说。离诸文字魔无能为。若无施设即无我见及文字见。以无我故。则于诸法无有损益。如是入者则超魔境。是为菩萨超魔法门

尔时大虚空藏菩萨。告魔波旬言。汝闻说此超魔境界法门不邪。波旬答言。唯然已闻。虚空藏言。波旬汝敢于此诸大菩萨所说超魔境界法门。作魔事不。答言大士。我或昔闻超魔境界殊胜法门。或复当闻终不敢能为其魔业。何况现证

尔时会中。有四护菩提场眷属天。一名畠却梨。二名三牟得却梨。三名具香。四名净信。时此四天告波旬言。我昔见汝于菩提树下。如来正坐道场成正觉时。汝率营从与作留难。世尊彼时以慈悲调柔戒闻定慧坚固勇猛精进福智。以其宝手击触于地。无量世界应时震动。世尊神力已摧伏汝及其眷属。应自证明。今复更于佛菩萨所欲为魔业。波旬汝及眷属。而今之后于佛菩萨。宜应尊重修诸供养

尔时波旬。即时变化八万四千俱胝宝盖遍覆大众。又以种种无量天诸妙花涂香末香。持散佛上及诸众会作如是言。所有一切欲界庄严。及一切佛刹庄严。乃至我宫殿所有庄严殊胜珍宝。天上人间妙受用具。悉以奉献佛及众会。亦以供养虚空藏菩萨。时虚空藏菩萨语波旬言。汝及眷属皆应发于无上正等菩提之心

尔时波旬并其八万四千眷属。悉发阿耨多罗三藐三菩提心。时彼众中有一魔子名为恶面。于众魔中最为上首。心不敬信乐为非法。作如是言。何用发此菩提心为。我等当设种种方便。令如是经隐没于地不得流布。尔时世尊告大虚空藏菩萨言。善男子汝今闻是魔言不耶。汝当宣说摧伏制止诸魔眷属明真言句。令无能为。亦使由此明真言句。恒沙魔众悉得安住无上菩提

尔时虚空藏菩萨摩诃萨。即说明真言曰

怛儞也(二合)他阿靺[齒*來](知谐反)尾靺[齒*來]三靺鞮娑呬多奴散地怒噜怛啰(二合)奶(平声呼)涅(奴一反)伽怛儞(平奴政反)昧怛啰(二合)庾羯鞮(二合)迦噜拏儞(奴政反)删泥婆底(鞮以反)也(二合)靺底(鞮以反)步多[口*落]乞洒(二合)达摩涅(奴一反)物哩(二合)鞮达磨[口*落]乞史(二合)鞮乌驱(上声)里儞企里户卢户卢户卢户卢怛羯[口*犁]怛他嚩儞低始罗奴靺底(丁以反)恶乞晒(二合)耶涅(宁逸反)儞势(平声)羯犁(二合)奢跛羯哩(二合)势(平声)没驮地瑟耻(二合)帝达牟入嚩(二合)罗儞僧伽奴哦迷阿努杜[口*禮]阿那底羯啰(二合)摩抳曳　儞[卄/(阿-可+辛)/女]啰(二合)呵尼么啰跛乞洒(二合)斯庾纥底(二合)纥哩(二合)鞮安拏嚟阿奢娑怛[口*梨](二合)萨尾洒也努誐铭阿哩也(二合)虞拏迦[口*梨]悉第悉[馬*犬]跛泥母乞洒(二合)努句黎儞[卄/(阿-可+辛)/女]啰(二合)呵抳跛啰嚩儞喃达哩洒(二合)儞么啰钵哩洒(二合)诺阿尾扇睹者怛嚩(引二合)嚧摩诃啰惹诺舍羯嚧(二合)泥(平声)嚩那泯捺[口*洛](二合)没啰(二合)诃摩(二合)娑憨跛底母驮钵啰(二合)萨那泥嚩那哦药乞洒(二合)羯哩(二合)担(平声)跛哩怛啰(二合)喃萨他(二合)比担娑嚩(二合)娑丁也(三合)也喃达摩婆拏迦那摩[口*洛]乞洒(二合)曳萨达摩写跛哩[卄/(阿-可+辛)/木]啰(二合)诃耶裟嚩(二合引)诃

尔时大虚空藏菩萨。说是真言已。即时三千大千世界六种震动。时彼恶魔心无净信不乐法者。闻空中声曰。若有闻此明真言句。若魔若魔男若魔女若魔民不发阿耨多罗三藐三菩提心。不舍魔业者。则令金刚手药叉。以大火焰金刚之杵摧碎其顶尔时魔众心惊毛竖。即皆同时仰观虚空。见有五百大金刚手。各各临于恶魔头上垂欲下击。皆悉怖惧一时咸发阿耨多罗三藐三菩提心尔时世尊熙怡微笑。时具寿阿难陀。一心合掌白佛言世尊。世尊微笑非无因缘。唯愿如来为我解说

尔时世尊告阿难陀言。汝见此五百众魔以怖惧故发菩提心不。阿难陀言。唯然已见。佛复告阿难陀言。此魔波旬当成佛时。与诸眷属于彼彼世界。各各异名。尔时具寿阿难陀白佛世尊经于几时。此魔当成无上菩提。得菩提已佛及世界名为何等。佛告阿难陀。此魔波旬。当于来世十千佛所。为作魔事。从彼佛所闻金刚场摧坏烦恼清净法门。又于彼佛所闻于秘密甚深轨则威仪功德尸罗处行。勤行方便于最末后无边无垢幢如来所。当作魔事于彼佛所。善根淳熟心得决定。获得一切佛法光明。发菩提心。然后经于过阿僧祇数量佛所。恭敬供养于彼佛法。出家修道护持正法。教化成就无量有情。复更过于四万阿僧祇劫。当得成于阿耨多罗三藐三菩提。名为妙住得法光如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名清净安立。劫名清净。复次阿难陀。清净安立世界。国土丰盛人民快乐。如睹史多天宫所有受用乐具。彼国菩萨受用乐具亦复如是。彼妙住得法光如来寿命四十中劫。有六十四俱胝诸声闻众一万二千大菩萨众。阿难陀如是诸魔若魔男若魔女若魔民悉发住于无上正等菩提之心。皆随生彼清净世界。时妙住得法光如来知其深心。皆悉与授阿耨多罗三藐三菩提记

大集大虚空藏菩萨所问经卷第七大集大虚空藏菩萨所问经卷第八

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

尔时会中释梵护世。见与波旬授菩提记。一切皆生奇特之心。叹言希有甚奇世尊。彼等诸魔于佛善说法毗奈耶。而作魔事犹见如来。福不唐捐皆蒙授记。当证无上正等菩提究竟涅槃。世尊岂有善男子善女人。以善信心入于佛法。所获福业而得校量。当知皆是诸佛境界。非余声闻缘觉所测

尔时佛告释梵护世诸天人等。如汝所说诚谛不虚。实是诸佛如来境界善男子。夫心者是缘生法。譬如染缬或处受色或处不受。有情心行亦复如是。或起烦恼或复不起。或有利根或有钝根。如来随根设法教化。悉令解悟引入法中。善男子。夫烦恼者无有方所。亦无住处复无积聚。从不如理作意和合而生。若如理观察是杂染性则为清净。然我密意说名邪见。若如实知则为正见。非邪正见过现实有。若于邪见正见。知己不生取着。是则名为入正见道。善男子烦恼如皮清净为性。由彼所覆慧明无力。是故不见根本清净。复次有分别者名为烦恼。无分别者名清净性。善男子譬如大地依水而住。水依风住风依空住。是四界中空无所依。以其虚空不坏不动无所积聚。无积聚故住不生灭自性相应。是故三界不久不住。无常变异非虚空界。如是蕴处界依业烦恼而住。业烦恼依非如理作意而住。非如理作意。依自性清净心住。是清净心不为客尘烦恼所染。所有非如理作意业烦恼蕴处界等。一切皆是因缘和合故有。因缘若阙则不生起。彼清净性无有因缘。亦无和合亦不生灭如虚空性。非如理作意如风。业烦恼如水。蕴处界如地。由是一切诸法无有坚牢。根本无住本来清净。善男子是名自性清净法光明门。菩萨由证此法门故。不为一切诸烦恼垢之所染污。亦不思惟此清净法。以不思故。则灭一切寻伺缘虑证清净性。由证清净。则超魔境。以超魔境则安住佛境。以住佛境则超有情境入不动法界。以入不动清净法界。则入平等无差别境。则名获得一切智智。说此法时有无量菩萨。于业烦恼障一切缠垢。悉得远离证无生忍

尔时室利鞠多优婆塞。于大众中即从座起。头面礼足而白佛言。世尊我今从佛闻此解脱清净法门。顿除疑悔。所以者何我昔曾设深大火坑及和毒食。于如来所起损害意。世尊威德无所损伤。为我说法虽少信向。心犹疑惑仍生追悔。今于佛前复得闻此甚深经典。疑网悉除心无忧悔。获法光明发阿耨多罗三藐三菩提心。世尊我于今者名为大益得殊胜利。尔时佛赞室利鞠多长者言。善哉善哉善男子。汝今闻我所说法故生净信乐。由是因缘于贤劫中所有诸佛。悉皆承事恭敬供养。于彼佛所广修梵行护持正法。过七百万阿僧祇劫。当得成佛号曰离一切缠如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。时室利鞠多优婆塞。闻佛与授阿耨多罗三藐三菩提记。欢喜踊跃得未曾有。即解严身上妙珞。散于佛上作如是言。世尊今我宅中有四大藏。无量金宝充满其中。以第一藏舍与妻子僮仆及营事者。第二大藏舍与一切贫穷下贱孤独乞人。第三大藏舍与一切往来苾刍及四方僧。第四大藏奉献如来及上首苾刍。唯愿世尊令我速获无住相施功德成就。我今欲于如来善说毗奈耶中。出家受戒修习梵行。于是世尊听其出家。时室利鞠多优婆塞。即便出家受具足戒

尔时大虚空藏菩萨白佛言。世尊如来于无量阿僧祇劫之所积集。甚深难得阿耨多罗三藐三菩提法。于佛灭后谁当奉持。时彼众中有六十俱胝菩萨摩诃萨。即从座起合掌礼佛。异口同音说伽他曰

  如来灭度后　　我等悉皆能
  不惜于身命　　护持佛正法
  舍一切名利　　及离诸眷属
  不舍此正法　　为证佛智故
  毁呰及骂辱　　粗言不善语
  由护正法故　　如此皆能忍
  轻贱及掉弄　　诽谤不称赞
  如此悉皆忍　　为持此经故
  当来诸苾刍　　往相希名利
  为魔之伴党　　于法为障碍
  毁戒破法者　　亲近于俗人
  贪着供养故　　不专求正法
  好习于外道　　无知怀憍慢
  自赞叹己身　　恼乱寂静者
  弃舍阿兰若　　常乐无利言
  好习恶咒术　　计着于身见
  或乐知僧事　　与僧作留难
  舍离于禅诵　　交杂诸世务
  常求于利养　　不乐戒多闻
  虽行于布施　　心恒怀杂染
  计种种我相　　但念于乞食
  乐往白衣家　　论说世俗事
  田农诸俗务　　贸易并贩卖
  好作如是事　　自称是沙门
  坚执于诸有　　计着种种见
  闻说真空法　　怖畏如深崄
  不信有业果　　言无后世报
  但作虚诳语　　非法言是法
  恶世中苾刍　　自在力如王
  于此末法时　　我能持正法
  于诸修多罗　　不求亦不读
  各自师己见　　执异互相非
  所有深经典　　与解脱相应
  于如是正法　　心皆不乐说
  及乐世俗论　　称扬为希有
  如斯恶人辈　　不久灭正法
  微妙甚深经　　文义俱善巧
  于彼恶世时　　悉皆被灭坏
  非法无道王　　人庶皆流窜
  于如是恶世　　无不怀恐怖
  我等悉皆能　　处如是末世
  护持佛所说　　无上之正法
  以慈于有情　　设破于正法
  亦起悲愍心　　由持此经故
  若见持戒人　　起于贪爱心
  我以怜念故　　方便令弃舍
  若见恶心者　　谤毁于正法
  为之起慈悲　　令见我欢喜
  随力护彼人　　不加粗恶语
  亦不与之言　　彼当自安住
  复以四摄行　　成熟彼等人
  又令生警觉　　省悟虚妄过
  我当舍愦闹　　住于阿兰若
  不亲近俗务　　犹如鹿自在
  少求及知足　　修行四圣种
  住戒及头陀　　具禅定智慧
  我当无间修　　调柔静解脱
  若入于聚落　　为说微妙法
  若有求法者　　令远住空闲
  寂嘿自修持　　常安于法乐
  若有于现前　　作诸过失者
  我为利众生　　当自观身行
  住法常寂静　　于敬与不敬
  安住如须弥　　不染世间法
  我当为导师　　苾刍毁戒者
  来加以恶言　　观是自受业
  亦不起报心　　于他无害想
  常住于正法　　此非我应作
  我是于沙门　　彼无沙门行
  闻我正教诲　　则谤修多罗
  或断于耳鼻　　亦不乐见我
  若闻实警觉　　则谤于正法
  当来诸苾刍　　受持正法者
  为其作留难　　不令闻正法
  于王离间语　　破坏于大众
  我等承佛力　　皆今得闻法
  当彼恶世时　　宁舍于身命
  为持正法故　　作众生利益
  先知他意乐　　后方共语言
  当来大怖时　　住是真实行
  我问世间眼　　法王光明尊
  由持此经典　　为得几所福

尔时世尊告大虚空藏菩萨及诸菩萨摩诃萨言。善男子譬如东方一世界析为十三千大千世界。如是南西北方四维上下。各各析为十三千大千世界。如是世界尽末为尘。复以一尘为一世界。若复有人于东方过尔所尘世界下于一尘。复更东行过尔所尘世界又下一尘。如是展转尽尔所尘。于东方诸佛世界无有边际。南西北方四维上下亦复如是。善男子于汝意云何。如是十方世界。所下微尘知其数不。不也世尊。如是微尘世界唯有如来以无碍智之所究了。非余能知。佛言善男子是诸世界。若下微尘及不下处。尽诸世界以为大城围绕墙壁。上至有顶下穷水际。满此城中着净芥子。以一芥子为一佛世界。善男子于意云何。是诸芥子世界宁为多不。甚多世尊。佛言善男子。如是芥子及诸世界。我知其数知百知千。乃至知紧迦罗弥未罗阿閦婆等。若有善男子善女人求菩提故。以七宝满尔所世界。施于尔所芥子数住功德法。菩萨诸佛及恭敬供养若复有人闻此甚深微妙经典。能净信忍所得福德胜前福德。若复有人以尔所芥子数行无遮施。或复有人得闻此经。于诸有情生无碍心住调柔忍。如七步顷系念思惟。所得福德胜前福德。若复有人修诸福业。成就尔所芥子数天主帝释大梵天王转轮圣王。或复有人受持此经。能知无常苦空无我涅槃寂静。如是知已于诸有情生于大悲。为不断三宝种故。发无上正等菩提之心。如是福德胜前福德

尔时大虚空藏菩萨白佛言。世尊唯愿如来加持此经。后末法时于赡部洲广令流布。是时佛告虚空藏菩萨言。善男子我以此法付四天王。所以者何由此四王护持世界故。令此法久住世间广得流布。我今复以微妙真言。加持四大天王。即说真言曰

怛儞也(二合)他度度[口*梨]他地梨持嚩(二合)惹跛底特嚩(二合)惹楞迦(引)[口*梨]阿(引)靺怛儞舍迷舍么钵底扇底(丁以反)目溪儞誐啰(二合)贺博乞叉(二合)哆阿奴娜啰鄡那啰尾誐摩三摩钵地簸他输地钵他奴誐摩钵他输地钵啰(二合)枳娘(二合)目溪阿哩也(二合)句梨　步多[口*洛]　乞晒(二合)阿儞泥洒遮茗泥洒遮多(引)么洒遮多怛簸洒遮没驮簸那达摩奴散地阿哩也(二合)誐拏怒誐摩阿那哩也(二合)儞伽哆儞嚧瑟吒(二合)钵啰(二合)娑娜宁咿湿嚩(二合)啰簸那鲁迦失止(二合)怛唎(二合)讫哩(二合)多阿奴啰讫沙(二合)演都伊[牟*含](引)达摩散地(啼寝反)尼婆惹都儞鲁讫鞮(二合)涅泥(上)世(引)钵啰(二合)底路乞洒(二合)睹达摩驮哩尼

尔时四大天王。由此真言所加持故。心怀悚栗身毛皆竖。即往佛所头面礼足白佛言。世尊我等四王护持此经。当令未来久住于世。我能摄持如是经典所流行处。有不乐法诸神天龙夜叉乾闼婆阿修罗迦楼罗无能障碍。若有乐法善神。即当令彼心得寂静。若有法师于说法会。忘失文句能令忆持。获得辩才增长慧解

尔时世尊告四天王。善哉善哉汝等四王。皆是我子从法化生。由我劝汝守护正法功德因缘得为天王。当超世间速证圆寂

尔时世尊。复告大虚空藏菩萨言。善男子我今亦以真言加持帝释。令护此经久住于世。说真言曰

怛儞也(二合)他输第输婆末底输婆尾庾(二合)系那捺[口*梨]那哩奶睹哩奶纳迷舍迷邬波舍迷屈吠鸣驱黎阿苏目溪驮啰尼阿啰奶轮输嚧(二合)晒婆[口*皿]低阿[月*坒]那散地三迷三摩嚩底三摩啰湿弥(二合)阿世呼呼奚奚驱嚧驱梨阿那底羯啰(二合)铭儞嚩[口*洛]乞洒(二合)摩[口*皿]低摩诃嚩婆娑钵啰(二合)[月*坒]阿[卄/(阿-可+辛)/女]车睹舍羯嚧泥嚩曩泯捺啰(二合)那捺舍多那夜那嚩罗摩矩吒达啰伊舍嚩(二合)噜末噜捺婆(二合)嚩那儞嚩斯娑嚩(二合引)诃(引)

尔时天帝释。闻此真言已欢喜踊跃。所住宫殿悉皆震动。即与百千脊属围绕。来诣佛所头面礼足。白佛言。世尊我等诸天拥护此经。于赡都洲广宣流布令得修行。若有法师受持此经。我等眷属咸共拥护。令无恼患使得欢喜生净信乐。受持斯经皆得成就以法庄严。若于王城聚落村邑说法之处。我当率诸眷属。相共往诣彼法师所与作卫护。若有轻贱嗔骂彼法师者令发净心。若有诸魔作诸障难。我当拥护悉使退散不令得便

尔时佛告天帝释言。善哉善哉憍尸迦。汝当获得天妙自在。住法自在。于一切佛所护持正法能师子吼何以故憍尸迦以能受持一佛正法。即于三世诸佛所说正法。皆能守护

尔时世尊复告大虚空藏菩萨言。善男子我为娑诃世界主大梵天王。说威德真言句义由此真言故。大梵天王护持此经。即说真言曰

怛儞也(二合)他每怛哩(二合下同)输婆每怛哩(二合)达摩每怛哩(二合)每怛哩(二合)也怒娑呬鞮三摩每怛哩(二合)珊地每怛哩(二合)阿努誐摩每怛哩(二合)阿怒啰讫叉(二合)每怛哩(二合)阿努度啰每怛哩(二合)萨丁那(二合)每怛哩(二合)达磨每怛哩(二合)阿努檗啰(二合)诃每怛哩(二合)阿尾钵啰(二合)底(丁以反)娑啰每怛哩(二合)嗢卢迦那每怛哩(二合)尾卢迦那每怛哩(二合)母[亭*夜]努誐摩每怛哩(二合)没驮地瑟姹(二合)那每怛哩(二合)阿努啰乞叉(二合)每怛哩(二合)达摩钵啰(二合)底(丁以反)[口*洛]乞叉(二合)拏每怛哩(二合)母乞叉(二合)每怛哩(二合)阿那奴哩嚧驮尾嚧驮每怛哩(二合)阿多牟每怛哩(二合)没啰(二合)贺么(二合)簸他每怛哩(二合)[亭*夜]那楞迦啰每怛哩(二合)怛写努珊地迦嚧那每怛哩(二合)怛写奴珊地暮儞多每怛哩(二合)怛写奴珊地庾(二合)闭讫叉(二合)每怛哩(二合)没啰(二合)贺摩(二合)钵地努誐摩那每怛哩(二合)质都儞尾哩也(二合)每怛哩(二合)阿奴娑啰拏每怛哩(二合)儞娑底(二合)啰拏每怛哩(二合)萨嚩怛啰(二合)拏誐么那每怛哩(二合)阿[薛/女]车末啰(二合)含门(二合)嗢悉[口*梨](二合)惹[亭*夜]那素大尾(入)蜜逾底(丁以反)瑟姹(二合)娑嚩(二合)婆嚩(二合)三摩提儞瑟羯啰(二合)摩摩诃尾么难(引)尾也(二合)嚩鲁迦耶染摸儞尾崩(补甘反)句嚧湿嚩(二合)达摩[口*洛]讫叉(二合)么底(丁寅反)羯啰(二合)弥没驮地瑟吒(二合)南

尔时娑诃世界主大梵天王在于梵世。由此慈心真言加持及佛威神力故。天耳闻已。即共六十六万梵众来诣佛所。头面礼足退坐一面。白佛言世尊我等蒙佛大慈大悲加持力故。令护此经。若当来世有诸法师。于此甚深秘密经典。受持读诵乃至书写奉持供养。若彼法师在阿兰若。及于衢路村邑聚落王城处所若为宣说如是经者。我等当共拥护摄受加其气力令得精勤。念慧辩才悉皆增长。不信者令信。其净信者令住正行。世尊我等今于如来所说正法之眼。皆共奉持广令流布

尔时世尊告大梵王言。善哉善哉梵王如来。今者随喜汝等守护正法。梵王汝当不久坐于道场。转正法轮如我今转。如汝今者拥护斯经。诸余梵天于当来世。护持正法亦应如是

尔时世尊。复告慈氏菩萨摩诃萨言。慈氏我今以此无量阿僧祇俱胝劫积集无上正等菩提希有之法。付嘱于汝。乃至欲令受持读踊为他广说报佛恩故。亦满自己希求愿故。令诸有情增长善根故。令诸菩萨护法光明故。摧一切诸魔外道故。护持正法不断三宝种故。慈氏菩萨白佛言。世尊我今当于如来在世及涅槃后常护法藏。何以故我亦曾于过去护斯正法。世尊我虽在于睹史多天。于是类经倍增护持令久住世。世尊若未来世其有众生于如是等经闻已受持书写读诵。如法修行为他广说。当知皆是我之威力所加持故。世尊当彼之时。若有魔及魔民共为朋党。不能障难如我一毛成就善根析为百分千分歌罗分乃至优波尼沙陀分。若三千大千世界之中。一切有情悉并为魔若魔眷属。而于我所成就善根一分福智之力。犹不能得生于障难。何况如来于无量阿僧祇俱胝劫积集无上菩提之法。而能障碍。尔时世尊告慈氏菩萨言。善哉善哉善男子。有四种法为菩萨行。何者为四。所谓破烦恼魔坏诸外道。成熟有情护持正法。善男子如是四种是菩萨行。而此四种以一行收。云何为一。所谓护持正法

尔时世尊。告尊者大伽叶波具寿阿难陀言。我以此经付嘱汝等。汝当受持此经为他广说。大伽叶波言。世尊我当随力于如来无上菩提之法。勤加守护为他宣说。阿难陀言唯然世尊。我已受持如是法要。于当来世以佛威力。广宣流布令不断绝。尔时福庄严菩萨摩诃萨。从座而起叉手合掌。白佛言世尊如是之经。如来所说甚深希有。断诸疑网最胜了义难见难悟。是第一义空性相应。以戒念定慧而为庄严。显说解脱寂静无染。是诸智人之所知境。一切诸佛之所称赞。亦是一切诸经之王。以陀罗尼印印之。令受持者得无碍辩。增长念慧坚固不退。摧魔怨敌不为于他异宗所坏。能摧恶戒增长头陀无贪功德。复是正住大舍功德。出生无量诸佛智法。若有善男子善女人。能于此经受持读诵。系念思惟为他广说。书写供养审谛观察。如理作意正行相应得几所福。尔时世尊即以迦他。告福庄严菩萨摩诃萨曰

  我以佛眼见十方　　广大无边诸刹土
  于中盛满诸七宝　　尽皆普施诸菩萨
  若人受持是经典　　如佛所说无所得
  而能习诵为他说　　如是功德超于彼
  众花涂香并伞盖　　衣服缯彩及幢幡
  遍满积彼世界中　　供养诸佛并菩萨
  于后末世法灭时　　若有受持此经典
  如说修行不放逸　　所获福聚超于彼
  十方世界诸巨海　　尽皆盛满种种油
  其炷高大如须弥　　然灯供养佛制底
  若有于彼法灭时　　世间尽为诸暗覆
  能燃如此大法炬　　所获功德倍于前
  若于无量诸导师　　奉事经于亿千劫
  以天适意妙供养　　勤求最胜佛菩提
  为报如来深重恩　　护持三宝令久住
  安诸有情住佛法　　持此经福多于彼
  以佛眼观诸有情　　能致梵王帝释位
  若有能持此经典　　获大胜福过于彼
  令诸有情得罗汉　　复能成就缘觉乘
  若有能发菩提心　　受持此经福过彼
  假令经福皆为色　　尽虚空界不能受
  除佛世尊一切智　　于此胜福无能了
  若于俱胝千亿劫　　持此如来所说经
  所生功德不可量　　犹如十方无有际

尔时福庄严菩萨。从佛闻是护持此经。所得功德不可限量。生大欢喜踊跃无量。而白佛言世尊后末世时诸有情类。若有不能持此经者。当知是人堕于魔界。世尊我观护持自余正法。所获善根犹如芥子。若有能护此经法者。所得功德如十方虚空。无有穷尽不可譬喻。世尊我今被于勇猛甲胄。宁舍身命护持是经。不为吝望已身之利。但求一切有情安乐。说此法时。以大虚空藏菩萨福德力故。有十方无量恒沙佛刹。虚空藏菩萨及无量佛诸菩萨众。从于虚空雨种种花以为供养。空中有声而作是言。善哉善哉大虚空藏菩萨摩诃萨。乃能作此广大佛事。乃至于此大集法要殊胜庄严。亦能摄受未来有情庄严正法。令彼不失菩提之心。于此经中受持读诵书写解说。尔时世尊为欲嘱累此经典故。以神通力即从身中放大光明。遍照十方无量佛刹悉皆振动。有无量阿僧祇有情。发阿耨多罗三藐三菩提心。无量有情得无生法忍。复有无量有情心得解脱。复有无量有情得法眼净。复有无量有情离诸贪染。复有无量有情得于人天福德胜因当得见佛。一切大众皆生随喜。佛说是经已。时大虚空藏菩萨摩诃萨。具寿大迦叶波。具寿阿难陀。娑诃世界主大梵天王。释提桓因四大天王。诸苾刍众。及大菩萨天人阿修罗乾闼婆等。一切众会闻佛所说。皆大欢喜信受奉行

大集大虚空藏菩萨所问经卷第八


大集譬喻王经

    No. 422

大集譬喻王经卷上

        隋天竺三藏阇那崛多译

复次说此法时。命者奢利弗。从座而起。一肩优多罗僧伽作已。右膝着地合掌白言。大德世尊。我欲少问。愿佛听许。如我所问。赐为解说。如是言已。佛告命者奢利弗言。奢利弗。随汝所欲当问如来阿罗诃三藐三佛陀。其所问者。我为汝说令心欢喜。如是语已。命者奢利弗言。大德世尊。此阎浮洲若有雨时。于何处雨当名善雨。如是语已。佛告命者奢利弗言。甚善奢利弗。汝以妙辩善思念。如是义欲问如来。汝欲利益多众生故。欲令多人得安乐故。怜愍世间。利益安乐诸天人故。亦为现在未来发菩萨乘诸善家子善家女等。令生精进力故。奢利弗。善听善念。我为汝说。奢利弗言。如是世尊。我今乐闻。佛告奢利弗言。奢利弗。阎浮洲人。所有甘蔗蒲桃大麦小麦胡麻稻粟小豆大豆江豆毕豆迦荼诃利那豆(似大豆此土无)。如是等田及余苗稼。于彼处雨名为善雨。何以故。若于彼处成就诸味。阎浮洲人得用活命。是故于彼处雨名为善雨。奢利弗。复言世尊。善家子善家女。若欲法施。于何处与名为善与。佛告奢利弗言。奢利弗。我说法施。若于诸处普法施时名为善与。奢利弗。我今复说。若法施时与诸菩萨摩诃萨。于法施中名为胜上善与。何以故。彼善家子为诸众生求法。是故施彼法时。名为胜上善与。奢利弗。譬如于大海雨。非不有果。非无受用。如是奢利弗。若于菩萨摩诃萨所。与法施时。非不有果。非无受用。何以故。彼善家子为诸众生求法故。奢利弗。譬如有人磨拭摩尼宝时。若勤用力名为善作。何以故。奢利弗。磨拭摩尼宝时。与作百千水精珠等。如是奢利弗。于诸菩萨摩诃萨所。若作力者名为善作。何以故。彼善家子为诸众生。当求阿耨多罗三藐三菩提。发行无上菩提故。奢利弗。譬如大海无处不得下无处不得入。何以故。大海渐深大海渐下。是故无处不得下无处不得入。如是奢利弗。菩萨摩诃萨于般若波罗蜜巧方便中。修菩萨行。亦无有法而不能说。奢利弗。譬如一滴水池种优钵罗华叶出生。虽同一池其华外叶不如是妙。不得如是称赞贵重。然彼内华则为男子女人称赞贵重。如是奢利弗。声闻独觉同一法界证已。不得如是称赞贵重。然彼如来阿罗诃三藐三佛陀。则为世间天人阿修罗等称赞贵重。是故奢利弗。见是义故。善家子善家女应发是心。莫同一法界证而得声闻独觉名字。不得如是称赞贵重。如彼如来阿罗诃三藐三佛陀。我等今者应发阿耨多罗三藐三菩提心。当得如是称赞贵重。如彼如来阿罗诃三藐三佛陀。奢利弗。譬如若沉水树若栴檀树。其叶不得称赞贵重如自体香。如是奢利弗。同一法界证已。声闻独觉智慧。不得具足如真实香。然彼如来阿罗诃三藐三佛陀。真香具足。奢利弗。见是义故。善家子善家女所有善根。皆应回向阿耨多罗三藐三菩提。奢利弗。我说彼等由善友满。于阿耨多罗三藐三菩提中。欢喜爱者。教彼勤行令欢喜爱。何以故。奢利弗。我昔亦由善友摄故。今成阿耨多罗三藐三菩提。奢利弗。如有一人欲取珍宝。更第二人亦欲取宝。彼者前人示第二人向宝洲道所出宝处。我说是人无有悭吝。如是奢利弗。若示遍智宝洲道者。我说是人亦无悭吝。奢利弗。如大价宝直多百千。出大海中。宝在海时无人磨拭。至阎浮洲乃有磨拭。如是奢利弗。若有欲见如来者。发阿耨多罗三藐三菩提心。各各见佛胜功德已。彼即广行当成声闻。彼广行已当成独觉。彼广行已当成阿耨多罗三藐三菩提。余诸善根由值善友皆成广大。奢利弗。见是义故善家子善家女。应求善友亲近承事。既承事已须修多业。不久当成阿耨多罗三藐三菩提。何以故。我昔亦由善友摄故。今成阿耨多罗三藐三菩提。奢利弗。如摩尼宝。若磨拭时细末流下。然其细末。不得如是称赞贵重。如彼摩尼大宝。则为国王若王大臣及余智人能别宝者。称赞贵重。如是奢利弗。声闻独觉虽同一法界证。不得如是称赞贵重。然彼如来阿罗诃三藐三佛陀。则为世间诸天及人若乾闼婆阿修罗等。称赞贵重。奢利弗。譬如有人。自将金抟诣金师所若金师弟子所。到已告言。汝取此金为我作钏。我着脚上。时彼金师若彼弟子。告言丈夫。我以此金为作璎珞。随汝顶戴若颈若手击已。多有百千人众。见生欢喜赞叹于汝。奢利弗。时彼愚人不用金师利益善语。报金师言。汝但为我作于脚钏。如是奢利弗。善家子善家女。若如来所若声闻所。作胜上施法时。或有善友来至其所。告言丈夫。汝今作此胜上施法。是不顺善。所谓以此胜上施法。而于有量法中回向。若声闻地若独觉地。汝今作此胜上施法。所有善根。堪能回向阿耨多罗三藐三菩提。奢利弗。于世间出世间法中。诸佛世尊最是第一巧胜智慧。奢利弗。是故诸佛世尊。赞叹阿耨多罗三藐三菩提。何以故。此是无上回向。所谓阿耨多罗三藐三菩提。奢利弗。见是义故。善家子善家女。所有善根皆应回向阿耨多罗三藐三菩提。奢利弗。如有二人。于中一人善作金色劫波娑缕。同一树生。所作细衣价直百千。一人欲作仆使粗衣。到织师所。告言丈夫。我此金色劫波娑缕善料理讫。同一树生为我好织。织师报言。丈夫我当与汝作衣价直百千。何用粗衣。彼人不纳织师善语。报织师言。但为我作仆使粗衣。如是奢利弗。虽同一法同一善根。或有攀缘声闻地者。或有攀缘独觉地者。或有住于无上道者。奢利弗。于中若有攀缘声闻独觉地者。应当语言。汝此善根是如来因。若求无上佛菩提者。应亦语言。汝此施法所有善根。当同一聚回向阿耨多罗三藐三菩提。如是回向。以彼善根施诸众生。作无尽心当摄取之。因此善根愿诸众生。当得具足不可思智不可称智。三界最胜无上智等。如彼如来阿罗诃三藐三佛陀。奢利弗。见是义故。善家子善家女。应种善根于阿耨多罗三藐三菩提。奢利弗。譬如国王第一夫人产生八子。于诸子中惟有一子具足王相。得绍王位以水灌顶。余诸王子复悉围绕依法奉事。奢利弗。于意云何。非彼母腹而有过失。令余王子不得灌顶大王位耶。奢利弗言。不也大德世尊。何以故。彼余王子。自于往昔不作王业不种善根。以是因缘。彼余王子悉不得绍灌顶王位。佛言如是。奢利弗。同证一法界已。如来阿罗诃三藐三佛陀。得名法王。余诸善家子等。得声闻名。非此法界有过失耶。奢利弗言。不也世尊。非此法界有其过失。然由彼等于往昔时所作善根不能回向无上菩提。不行此道。亦不发愿。不作胜上善根。又不愿求遍知利益。是故今但生声闻事。彼等亦不行如来行。又无如来功德。不具神通。如诸如来阿罗诃三藐三佛陀。奢利弗。以是义故。善家子善家女。所作善根皆应回向无上菩提。奢利弗。譬如波利质多罗俱毗陀罗树。有时初生三十三天皆大欢喜。作如是言。此树既生三十三天不应久空。如是奢利弗。有时善家子善家女。发无上菩提心。彼时所有正信。三宝天龙夜叉乾闼婆阿修罗伽留茶紧那罗摩睺罗伽人非人等。心生忻跃。云此道场不应久空。菩萨摩诃萨得成无上菩提。奢利弗。譬如彼波利质多罗俱毗陀罗树。三十三天见叶出时不赞不重。若见华时心生忻跃。如是奢利弗。声闻独觉证一法界。诸天世人不赞不重。若见如来阿罗诃三藐三佛陀。心生欣跃。何以故。如来阿罗诃三藐三佛陀。具诸善根及三十二大丈夫相。所有光明胜于日月。能照无量诸佛刹土怜愍众生。奢利弗。譬如彼波利质多罗俱毗陀罗树。若增长时。三十三天。应知此树不久当有多叶。百千俱致那由多叶。乃至无量阿僧祇叶以覆其上。如是奢利弗。彼初发心菩萨摩诃萨。生时长时应知当有百千俱致那由多等声闻。乃至无量无边阿僧祇诸声闻众。围绕在前。多有声闻独觉出现。奢利弗。譬如须弥山王。有别峰处高百踰阇那。或高二百踰阇那。乃至七百踰阇那。此等别峰不得言是大须弥山。如是奢利弗。从如来智出生声闻。亦不得言其智具足如诸如来阿罗诃三藐三佛陀。彼亦不具足如来十力四无畏智无碍智等。然其如来阿罗诃三藐三佛陀。则具诸力无畏无碍智等。奢利弗。譬如须弥山王住处。应知即有多天子众。百千俱致那由多等。乃至无量无边诸天子众。出现于彼在其山顶。受天福报心甚爱乐。天欲游处随意即游。如是奢利弗。彼初发心菩萨摩诃萨。生时长时。善根回向无上菩提。应知当有多声闻众。百千俱致那由多等乃至无量无边诸声闻众出现于世。诸圣行处随意即游。奢利弗。譬如须弥山王住处。即有四畔俱时而住终无先后。如是奢利弗。菩萨摩诃萨。善根回向无上菩提。尔时即有佛性佛地佛智佛功德等。俱时出生亦无先后。奢利弗。譬如须弥山王住处。若分分断比于余山犹为高大。如是奢利弗。彼初发心菩萨摩诃萨。善根回向无上菩提。若即以比诸余善根。足为最上高大住持。奢利弗。譬如须弥山王有金色边。若诸鸟兽至其边者。皆同一色所谓金色。即与师子兽王同色。奢利弗。虽与师子兽王同一金色。然其力势功德名称。彼悉不共师子王等。亦复不如师子兽王游戏频申无畏吼声。如是奢利弗。声闻独觉虽与如来同于一味。谓解脱味不得即共如来阿罗诃三藐三佛陀等。彼无如来如是功德诸力无畏师子吼声。然其如来则具方便智慧诸法。此方便智声闻独觉尚皆不闻。况能出生。如来功德。如来游戏。如来雷声。如来以师子吼而吼高出诸世。奢利弗。如诸鸟兽与师子王虽同一色。而余功德悉不共等。不得名为师子兽王。如是奢利弗。声闻独觉虽与如来同解脱味。而亦不共如来齐等。以彼不得功德名称。不得如来无上上名及如来体。又亦不得无上菩提诸力无畏无碍智等。以是诸力无畏无碍智等具足故。名如来阿罗诃三藐三佛陀。奢利弗。见是义故。善家子善家女。所作善根皆当回向无上菩提。奢利弗。譬如四天王天普于须弥山边而住。三十三天住于山顶。奢利弗。于意云何。须弥山上岂不容受四天王天。而彼四王不住顶耶。奢利弗言。不也世尊。须弥山上非是不容四天王天。而彼不住。但彼往昔不种山上受用福报。以其不作如是业故。不得住于须弥山顶。如是奢利弗。我此法体亦无过失。而不容受诸声闻等。令其不得十方世界智。以彼往昔所作善根。不知回向无上菩提。亦不发愿修如是行。不发最上遍智智心是故今作声闻。不得游于如来行处。又无如来功德。亦不具足诸力无畏无碍智等。以佛具足是智故。名如来阿罗诃三藐三佛陀。奢利弗。譬如大海不停死尸。如是奢利弗。阿鞞跋致菩萨摩诃萨。不共悭居。奢利弗。譬如大海潮不过时。如是奢利弗。阿鞞跋致菩萨摩诃萨。若乞士来终不过时。奢利弗。譬如有人若取滴水于大海中。皆是一味所谓碱味。如是奢利弗。菩萨摩诃萨若以种种百千诸门。所作善根回向无上菩提。皆成一味谓遍智味。奢利弗。譬如金性出金(谓金矿也)。随种种意作诸璎珞。转得种种璎珞名字。如是奢利弗。以一佛智转成多种百千璎珞。所谓出生众生善根。奢利弗。如王作钱。若已印有文者得名为钱。若未印无文者不得钱名。如是奢利弗。菩萨摩诃萨。未得无生法忍。诸佛世尊未授阿耨多罗三藐三菩提记。若得无生法忍已。诸佛世尊然后记言。汝善家子。于未来世。当得如来阿罗诃三藐三佛陀。奢利弗。譬如外道仙人有天眼者。若见有人初住胁胎未记色类。以其未成男女相故。后时若成男女相已。外道仙人方以天眼。记言当生是男是女。如是奢利弗。菩萨未得无生法忍。诸佛世尊未授阿耨多罗三藐三菩提记。若彼后得无生法忍。诸佛世尊方与其记。汝善家子。于未来世。当得如来阿罗诃三藐三佛陀。奢利弗。譬如日轮出时不作是念。我光当照此阎浮洲。但使日轮共光出时。于阎浮洲必作照明。令阎浮洲所有诸人显明诸色。如是奢利弗。菩萨摩诃萨。若得遍智智时。亦不作念。我当照明三千大千世界。奢利弗。菩萨摩诃萨。行是法行坐是地分。具是生相具是善根。彼当如是觉智。以是觉智。彼菩萨摩诃萨。必自照明三千大千世界。奢利弗。譬如二人皆欲得宝入于宝洲。于中一人取无价宝。其第二人取有价宝。于时智人言。丈夫此处有无价宝。汝可取之。此宝多价。国王大臣若城邑人及余智人别识宝者皆共称赞贵重为上。此人不用彼人语故取有价宝。如是奢利弗。此佛教法亦似宝洲。有人到已即作无价念行具足。谓遍智智宝相应念。远离声闻独觉等念。复有第二人。以声闻独觉相应念行。奢利弗。同一法界证已。如来阿罗诃三藐三佛陀在法王数。复有自余诸善家子。成声闻已在声闻数。得遍智者在普见数。如如来阿罗诃三藐三佛陀。奢利弗。譬如如意宝珠。随到谁手彼即自在。无有一宝而不得者。如是奢利弗。菩萨摩诃萨。无有一众生所而不与作宝事。无有一众生所而不教作善根乃至无为涅槃。奢利弗。譬如作摩尼人。若作摩尼弟子。随所有宝外畔浊恶。若磨拭已光色胜上。知色胜已彼作珠人。若彼弟子当得多种百千财聚而用活命。如是奢利弗。菩萨摩诃萨。随于他心令生善根。如彼善根皆以自心方便智摄。以此善根成诸佛法。奢利弗。如摩尼宝若未净时须好覆藏。何以故。彼摩尼宝是无价故。如是奢利弗。彼初发心菩萨摩诃萨。初发心时诸天及人若乾闼婆阿修罗世当须守护。何以故。彼善丈夫为诸大人阿修罗世。发阿耨多罗三藐三菩提心。奢利弗。如摩尼宝虽未磨拭。当知即为国王大臣若城邑人及余智人别识宝者称赞贵重。如是奢利弗。彼初发心菩萨摩诃萨。当知亦为诸佛世尊菩萨声闻称赞贵重。奢利弗。譬如有人若见佛时。当须如是生希有心。彼如来阿罗诃三藐三佛陀。时时出世。我今可发阿耨多罗三藐三菩提心。丰正法业。以此正法教诸众生善根聚集。彼诸善根。皆当回向阿耨多罗三藐三菩提。彼回向时。若有无信比丘比丘尼优波塞迦优波斯迦。若摩罗波卑。若摩罗身天来到其所。说大乘过令其舍离令不乐欲。奢利弗。于意云何。彼等岂不为多众生百千俱致那由多等。乃至无量无边阿僧祇诸众生等。作无义利作不安隐令苦令堕耶。奢利弗言。如是大德婆伽婆。如是大德修伽多。何以故。为诸众生。作无义利作不安隐令苦令堕。所谓于发大乘诸善家子善家女所。说大乘过令不乐欲阿耨多罗三藐三菩提。令退令离。佛言。奢利弗。若欲不舍如来阿罗诃三藐三佛陀者。应求阿耨多罗三藐三菩提。是故奢利弗。诸发大乘善家子善家女。于阿耨多罗三藐三菩提。应当乐欲莫退莫离。何以故。我说不舍如来阿罗诃三藐三佛陀者。谓发大乘善家子善家女。于阿耨多罗三藐三菩提。乐欲不离不退者。是奢利弗。譬如饥馑恶世所种不生。如在石上种。时若王若王大臣若刹帝利。若刹帝利大臣。若婆罗门若婆罗门大家。若长者若长者妇。若长者大家。在于城邑为众人故。集种种谷而作大仓。时众人等皆诣仓所。取种种谷将归而食。时有一人到彼仓处放火烧之。奢利弗。于意云何。是不善人。岂不于多百千俱致那由多等。乃至无量无边阿僧祇诸众生所。作无义利作不安隐令苦令堕耶。所谓是不善人。于彼仓处放火烧坏不令受用。奢利弗言。如是世尊。佛言。奢利弗。如是如是。正法欲灭于时有人闻如来阿罗诃三藐三佛陀或时出世。彼人闻已于众生所而生大悲。生大悲已。发阿耨多罗三藐三菩提心。于时若有不善人出。于发大乘诸善家子善家女所。说大乘过令不乐欲。阿耨多罗三藐三菩提令退令离。奢利弗。于意云何。是不善人。乃与无量无边阿僧祇诸众生等。作无义利作不安隐令苦令堕。所谓于发大乘诸善家子善家女所。说大乘过令不乐欲。阿耨多罗三藐三菩提令退令离。奢利弗言。如是世尊。奢利弗。譬如商主多将商人在道而去。逢大险河多有流水。时有一人语第二人作如是言。丈夫当作方便计挍用力求船。其第二人语彼人言。我正住此不能求船。于时彼人有志有力。勤作方便求船将来置于河边。乃有无量无边阿僧祇众生。得从此岸度至彼岸。既得度已于彼岸住。其第二人懒堕无智少力薄福。仍住本处不能度河。更有余人来到河所亦欲求度。见彼懒堕无智少力薄福人已。语云丈夫。汝何不度。时懒堕人作如是言。共我伴者方便用力。求得船来置于河边。已令百千那由多俱致众生得从此岸度至彼岸。时彼余人语是人言。奇懒堕人。何不学伴而堕此处受无量苦。如是奢利弗。我见二人行布施时。一人语彼第二人言。丈夫。汝可相应善作方便计挍用力。聚集善根于阿耨多罗三藐三菩提。第二人言。我不取阿耨多罗三藐三菩提。但欲到阿罗汉。若欲到阿罗汉者。亦须相应方便计挍用力。当得出生初第耶那。如是出生第二第三第四第耶那。虚空无边处。识无边处。无所有无边处。非想非非想处。三摩跋帝。于其中间即便命终。乘此得生非想非非想天。身当得长寿久住。乃至八万四千劫限而住。尔时彼人证觉阿耨多罗三藐三菩提。觉已为多众生百千那由多俱致。乃至为无量无边阿僧祇众生说法。说法已于后以无余涅槃而取涅槃。时第二人。乘此仍在彼非想非非想天住。如是语已。命者奢利弗言。如是大德婆伽婆。如是大德修伽多。实如如来所说。世尊。当知彼人是其懒堕。若乐初第耶那乃至非想非非想天。乐着彼处。即乐着已更不能与上人法合。不作方便计挍用力。不近善友随顺承事。不如实观三解脱门。当知是懒堕人。世尊。彼菩萨摩诃萨大勤精进。声闻少信是其懒堕。世尊。见是义故。善家子善家女所有善根。皆当回向阿耨多罗三藐三菩提。奢利弗。譬如有摩尼宝具多功能。将问作摩尼宝人言。此摩尼宝有何功能。问已彼随所知如是为说。于中若多知者说多。若少知者说少。如是奢利弗。同证一法界已。乃有转生声闻智者。彼等随胜功德而知。随胜功德而说。随其所问还如是答。依有限智。以昔有限发愿故。然如来阿罗诃三藐三佛陀有无限智。以昔无限发愿故。有无限无碍智。无限六波罗蜜。善巧方便成熟众生。何以故。如来阿罗诃三藐三佛陀。昔行菩萨道时集无边愿。以是无边功德法庄严故证于遍智。奢利弗。譬如波利质多罗俱毗陀罗树。初生小华其有香气。彼阎浮洲诸生华香。若稣摩那。若婆梨师。若占波迦。自余诸生华香。彼皆不及波利质多罗俱毗陀罗树初生诸小华香。如是奢利弗。其诸声闻独觉所有善根。若名闻若香。若威德若力。皆不及彼初发菩提心菩萨摩诃萨。何况入行。何况不退。何况一生补处。何况至灌顶时。何况住普贤菩萨行。何况在胜道场。何况如来阿罗诃三藐三佛陀。所有香。所有威德。所有力。具足此力所谓诸佛世尊。奢利弗。譬如此阎浮洲所有流泉浴池泊河小河大河等皆入大海。然其大海亦不厌足。如是奢利弗。菩萨摩诃萨于陀那波罗蜜而不厌足。如是尸罗波罗蜜羼帝波罗蜜。毗梨耶波罗蜜。弟耶那波罗蜜。般若波罗蜜。方便遍智。所有善根亦不厌足。奢利弗。譬如此阎浮洲所有流泉浴池泊河小河大河等大海之内悉能含受。如是奢利弗。所有天龙夜叉乾闼婆阿修罗伽留荼紧那罗摩睺罗伽人非人等。乃至所有众生界等。菩萨摩诃萨悉能含受。与甘露味令彼等喜。奢利弗。譬如大那伽那(大力士神)所著铠甲。阎浮洲人皆不能着。如是奢利弗。菩萨摩诃萨。于佛法中所著铠甲。为诸众生着彼铠甲。其诸声闻独觉不能着彼铠甲。如是奢利弗。从初发心乃至坐胜道场。不舍菩萨摩诃萨如是铠甲行菩萨行。奢利弗。初发大乘善家子善家女。应如是学。相应用力勤修于业。则当速成阿耨多罗三藐三菩提。奢利弗。如雪山王南畔所有诸树。具足诸华诸果诸香。彼等诸树。阎浮洲人皆不得用。如是奢利弗。声闻独觉虽有无漏戒定智解脱解脱知见善根。彼等众生皆不得用。如诸菩萨摩诃萨戒定智解脱解脱知见善根。诸众生等皆当得用奢利弗。是故菩萨摩诃萨应着如是铠甲。所有戒定智解脱解脱知见善根。彼诸众生皆当得用。若诸众生不得用者。我无如是善根戒定智解脱解脱知见。奢利弗。譬如恒伽大河所流行时。彼流行处润此大地令其津泽。又彼流行逼地而去。凡诸尘土草木叶等。彼流行时悉摄将去。如是奢利弗。菩萨摩诃萨于阎浮洲行住坐卧。如是等处摄诸众生。令其善根皆得润泽。又复行住坐卧逼切。诸无智行欲嗔痴行及颠倒行。皆摄受已行住坐卧。奢利弗。若发大乘善家子善家女。闻此上说。虽多懒堕必须发大精进。奢利弗。譬如恒伽大河。有处流时作声大声。有处少声有处无声。如是奢利弗得无生忍菩萨摩诃萨有处示现出生善根。有处自身示现随顺承事善友。有处自身为他而作善友。随众生器所堪。如是自身示现。奢利弗。譬如镜轮若未善磨不善净时。见其形像即不善净。若彼镜轮善磨净时。然后分明见其形像。如是奢利弗。初业菩萨摩诃萨。如见自善根即承事善友。如承事善友然后增长佛法。奢利弗。譬如恒伽大河增长满时。于其两岸草木枝叶皆漂将去。乃至于四大海。如是奢利弗。菩萨摩诃萨应着如是铠甲。所有此岸助堕黑事。行于诸见险道。我皆将去乃至到无余涅槃界。奢利弗。譬如恒伽大河有时增长多沫。于中有多树等。根茎叶果拔已将去。于中复有第二大树。犹生而住。后时第二年中。恒伽大河更长过前。前者大树更及诸木拔已将去。如是奢利弗。若有善家子善家女。承事善友发阿耨多罗三藐三菩提心已。而为恶友力故。以昔业行力故。受五欲福娱乐受乐皆共随行。于后必须承事善友。乃至当得无生法忍。何以故。于诸佛所种诸善根终不虚弃。彼等必当出世作佛号遍智者号普见者。奢利弗。譬如有时劫烧。彼时三千大千世界皆大炽然。而作光明同一炽然。若烧若坏无墨无影。如是奢利弗。菩萨摩诃萨应着如是铠甲。无一众生可见。于彼众生界中。所有众生皆不知者。我于彼等当令作不退法。奢利弗。譬如彼大焰聚然时。所有诸毒诸药。彼等皆同被烧。如是奢利弗。菩萨摩诃萨应着如是铠甲。若有乘众生。若无乘众生。我于彼等皆当平等说法。如彼愿如彼信。彼诸众生种种信行。当速令度不作二相。何以故。诸法无二不作二相。诸法无我于如不知。奢利弗。譬如彼大焰聚然时有焰。乃至光音天有焰。不能至尔许远处。如是奢利弗。同一法界证已。声闻独觉虽平等入。而于十方世界智慧不转。如彼如来阿罗诃三藐三佛陀。法界证已具无量智。奢利弗。譬如彼大火聚。十方世界不来不去。而烧三千大千世界。彼火亦非无因。如是奢利弗。彼诸佛智十方世界不来不去。亦不共聚。如来阿罗诃三藐三佛陀具足智者。如实知十方世界诸众生心行。彼智亦非无因。最上遍智。当如是见。奢利弗。譬如日轮出时。当知蔽诸萤火而作照曜。如是奢利弗。初发心菩萨生时长时。当知蔽诸具足分智声闻独觉光明而作照曜。何以故。彼作善根回向阿耨多罗三藐三菩提。是故具无边光。奢利弗。譬如日轮出时。当知蔽诸星宿色光而作照曜。诸处星光皆不复见。如是奢利弗。菩萨摩诃萨从兜率天下时。多有百千俱致那由多诸天。来阎浮洲。出如是声。告如是声。说如是声。汝诸人辈。此菩萨摩诃萨。今从兜率天宫舍身。尔时此阎浮洲所有独觉大智具者。皆闻声已发心向于涅槃。何以故。最胜福田菩萨摩诃萨。从兜率天下时。有如是自在力。何况生时。何况行七步时。何况初出言时。我于世间最大最胜。我当必尽生老病死。何况出时。何况至道场时。何况证阿耨多罗三藐三菩提时。是故如来于诸众生。可云最胜最上最大最妙无上无上上。奢利弗。见是义故。善家子善家女所作善根。皆当回向阿耨多罗三藐三菩提。奢利弗。譬如大地所有种子。彼等牙生有种种名。同一地尘而有诸相。如是奢利弗。于一法界证已。种种界众生出种种名。而不破法界。是故奢利弗。菩萨摩诃萨应着如是铠甲。当于彼时。我证一法界已。种种界众生种种名字以智当说。以是若干大智。而亦不坏法界。法界亦不作二。法界亦无增减可知。奢利弗。见是义故菩萨摩诃萨。当思如是法行。虽恒伽河沙数诸佛灭度。法界亦无增减可知。现在十方世界所有诸佛世尊具无碍智。所有声闻具于少智。法界亦无增减可知。虚空界极法界相应。如是当知。法界为极。佛法相应亦如是知。是故奢利弗。菩萨摩诃萨。此深法中当以智观觉无我法。奢利弗。譬如虚空界无与相似者。如是奢利弗。法界亦无与相似者。是故奢利弗。菩萨摩诃萨于此深法当以智观。奢利弗。譬如有人于大海中取诸滴水。彼皆一味所谓盐味。如是奢利弗。于一法界出生声闻。何以故。法界一而无二。是故奢利弗。菩萨摩诃萨。此深法中深处应当以智分别。于此法中般若波罗蜜当随顺行。非在余处广说譬喻。于无我法。当思当观当求当合。当生欲心。当发精进作业用力。善家子善家女。此深法中当以智观觉无我法。奢利弗。譬如大海有鱼身长百踰阇那者。乃至身长七百踰阇那者。彼诸鱼身虽复增长七百踰阇那。大海亦无增减可见。然彼七百踰阇那鱼身死时。大海亦无增减可见。如是奢利弗。菩萨摩诃萨当如是学。虽有恒伽河沙数等诸佛世尊灭度。而法界亦无增减可见。复有无量声闻灭度。法界亦无增减可见。此虽一味谓解脱味。而诸声闻不能转生是智。如诸如来阿罗诃三藐三佛陀。奢利弗。譬如转轮王有诸宝出。彼等诸宝余处不生。唯于宫内出生诸宝。何以故。彼转轮王昔作转轮王业。以作业故唯于宫内出生诸宝。如是奢利弗。净心菩萨摩诃萨。净心发阿耨多罗三藐三菩提。若欲施他随其所欲。彼则出生。何以故。以彼先世善净心故

大集譬喻王经卷上大集譬喻王经卷下

        隋天竺三藏阇那崛多译

奢利弗。譬如有人入宝性中(谓出宝处)。问先入者言。丈夫。诸宝何似何相。于先入者报彼人言。丈夫。汝痴云何名入宝性。自见诸宝复问此宝。如是奢利弗。若善家子善家女作如是问。法界何似法界何相。奢利弗。于时诸菩萨摩诃萨应着如是铠甲。我今当示众生如此法界为说令住。奢利弗。宝性者。所谓法界。入宝性丈夫问宝者。所谓愚凡夫辈。于先入宝性丈夫者。所谓如来阿罗诃三藐三佛陀。奢利弗。譬如大海不作是念。我出有价诸摩尼宝。或出无价诸摩尼宝。如是奢利弗。法界亦不作是念。有知我已出有限智。或有出无边智。奢利弗。但于法界定随所知得有限智。又于法界定随所知得无边智。奢利弗。譬如未竟一日即知若干刹那。若干罗婆。若干瓶。若干筒。皆知一日有若干残。如是奢利弗。未竟出生苦集灭道。是故奢利弗。菩萨摩诃萨。当知此是证信我说菩萨乘。善家子善家女未到菩提。奢利弗。譬如水聚下大地彼不令虚空多。如是奢利弗。虽恒伽河沙等诸佛世尊已入涅槃。而法界不见增减。无边诸声闻众灭度。而法界亦不见增减。是故奢利弗。菩萨摩诃萨应着如是铠甲。所有众生界不见增减。法界亦不见增减。我等作如是师子吼。乃至觉阿耨多罗三藐三菩提。奢利弗。譬如无有是处我分别说。有人至海龙王边。作如是言。我欲得破毛端为百分以一分毛出一滴水。时海龙王语彼人言。丈夫。汝欲百分破于毛端。以一分毛出一滴水。我不舍大海。如是奢利弗。于无边众生界。教授作力令喜大喜。彼作是言。我等不堪发阿耨多罗三藐三菩提。而我于法亦不作分。奢利弗。譬如春后夏月热时。有人往诣恒伽大河欲饮其水。而有一人障不听。饮奢利弗。于意云何。彼人于彼无主大水聚中而作障碍。得是顺不。答言。不也世尊。佛言。如是奢利弗。无摄法界。无摄诸佛法中。有发大乘善家子善家女信解渴仰。而有众生说大乘过令离令断。奢利弗。于意云何。彼人顺不。答言。不也婆伽婆。不也修伽多。佛言。是故奢利弗。善家子善家女。闻是说已应当速发阿耨多罗三藐三菩提。生欲精进相应用力。善家子善家女。此深法中。当以智观觉无我法。奢利弗。譬如此大地中有地分所。于阎浮洲诸人无用。彼何者是。所谓坑坎缺崖棘刺高峻废处。如是奢利弗。众生界中有诸众生。于诸众生亦无所用。彼何者是。所谓发声闻乘独觉乘者。彼等于诸众生则无所用。奢利弗。譬如有大地分。阎浮洲人得有用处。彼何者是。所谓具足园林华池。若有出金银处。彼等阎浮洲人得有受用。如是奢利弗。众生界中有诸众生。于诸众生得有所用。而彼等少。彼何者是。所谓若发阿耨多罗三藐三菩提。彼等为诸众生而作归依。毕竟作乐故。奢利弗。譬如大海中有无价诸摩尼宝。而阎浮洲诸人不得受用。如是奢利弗。虽诸阿罗汉声闻有无边善根戒定智解脱解脱知见。而彼等于诸众生则无所用。如诸菩萨摩诃萨所有善根戒定智解脱解脱知见。彼等为诸众生受用。是故奢利弗。菩萨摩诃萨应着如是铠甲。若不为诸众生受用。毕竟能作乐者非我善根。奢利弗。譬如尼瞿陀子其形虽小而生时长时多引多覆。如是奢利弗。其初发心菩萨摩诃萨善根生时长时。当知他诸善根皆所不及最上而住。是故奢利弗。发菩萨乘善家子善家女。虽小善根不可轻贱。莫言不增长耶。何以故。发大乘人善根若增长时。当知作无量阿僧祇。奢利弗。譬如有人大富多财多受用具。多有贝玉珊瑚金银等。所谓若刹帝利大家子。若婆罗门大家子。若长者大家子。彼等出街市时。谁欲看者看。谁欲至者至。谁欲问者问。尔时所有诸宝大摩尼宝。直多百千欲看者看。欲至者至。欲问者问。何以故。彼等心大于此卖买。如是奢利弗。菩萨摩诃萨。于诸佛法此大乘中。欲问者问。欲说者说。何以故。彼等信大如是言说不断。欲至者至。欲问者问。欲看者看。欲说者说。奢利弗。譬如所有大摩尼宝。其价乃大直多百千。奢利弗。于意云何。彼大价摩尼宝。颇与水精得共居不。答言。不也婆伽婆。不也修伽多。何以故。世尊。其摩尼宝。自与摩尼宝居。不共水精等。亦不可为喻。佛言。如是奢利弗。菩萨乘善家子善家女。与发大乘众生。应当共居共行共游。亲近承顺给侍善事共修多业。彼于其间发觉令忆。以如是故即随当学。奢利弗。譬如有人欲学于射。彼当忆念亲近射师。何以故。彼学此处。当须其间发觉令忆而慰喻之。如是取弓。如是作拳。如是把弓。如是放箭。以其射师发觉令忆及慰喻故。彼即随学当得成就。如是奢利弗。彼发大乘诸善家子善家女。应当亲近如来阿罗诃三藐三佛陀随顺供养。于发大乘诸善家子善家女所。应当共居共行共游共念。彼发大乘诸善家子善家女。亲近随顺供养已。彼应其间发觉令忆。复当慰喻。彼于其间发觉令忆及慰喻时。即随当学。此是陀那波罗蜜。此是尸罗波罗蜜。此是羼帝波罗蜜。此是毗梨耶波罗蜜。此是弟耶那波罗蜜。此是般若波罗蜜。此是方便波罗蜜。如是当学。普遍种智。所有善根。彼应其间发觉令忆复当慰喻。彼即随当学而得成就。奢利弗。譬如转轮王。于阎浮洲中所去游处。阎浮洲人不惊不怖不伤不损。多舍金银令住十善业道。作如是行。其转轮王行时。多有百千俱致那由多众生。悲泣忆念转轮王功德。如是奢利弗。菩萨摩诃萨。于诸佛刹行时游时。彼应当学诸佛胜德。在在行处顺法界行。彼去游处。令诸众生不惊不怖不伤不损。多舍金银。令诸众生住于十善业道。于十善业道上上令生。当如是行至无漏地。当如是作。所有行处彼诸人等。当学当念。此是我善友行。于诸善法摄者。作力者。作觉者。说甚深处者。摄我等者。所行去处。奢利弗。菩萨摩诃萨。应学如是胜上功德。奢利弗。譬如彼转轮王所去游处次第行处。彼时多有百千俱致那由多无量众生欢喜欲得彼来。何以故。彼以善法教诸众生。彼以善法摄诸众生。如是奢利弗。菩萨摩诃萨应着如是铠甲。我所去处次第行处。于种种方诸佛刹中。彼时多有百千俱致那由多众生欢喜欲得彼来。何以故。彼当教诸众生善法。又有种种善巧方便当摄众生。奢利弗。譬如彼大价摩尼宝直多百千。彼欲求时从何处得。当于卖处。如是奢利弗。菩萨摩诃萨。随其方便见诸众生。堪为成器。彼处彼处而作方便教以善根。后当与取。种种善巧方便求已。教诸众生合善法中。劝于菩提心中。奢利弗。譬如若诸王子若王大臣诸子聚集坐已共作是议。如是当取王位。当制王法。当持王位。当宣王教。如是奢利弗。诸菩萨摩诃萨。炽盛修诸善根。承事多百千俱致那由多诸佛种诸善根。善修于慈常能普念。行于大悲喜菩提心。念道场故而行于舍。彼如是等大信者。欲作师子吼者。欲澍法雨者。欲击法鼓者。欲吹法螺者。欲竖法幢者。欲安法船者。欲度诸堕四流众生者。无量劫欲着铠甲者。欲着大慈大悲大喜大舍牢铠甲者。欲转无上法轮者。欲降伏魔罗及眷属者。欲着不思铠甲者。欲着无比铠甲者。欲着诸三界最胜最上铠甲者。如是等类诸善家子。一处集坐共作是议。我等应当摄诸众生于彼无漏诸善根中。我等应当令诸众生回向涅槃界。我等应当苏息诸众生于无为涅槃界中。奢利弗。譬如若诸王子若王大臣诸子聚集坐时。余下贱人不得至于彼处。如是奢利弗。诸菩萨摩诃萨聚集坐时。余少分智具足诸众生等。不能见示如是境界。如诸菩萨摩诃萨示现。奢利弗。譬如大海有众生身大如虮子。复有众生身大百踰阇那。复有众生身乃至七百踰阇那。奢利弗。于汝意云何。岂彼大海不容彼等小身众生。若彼大身诸众生耶。答言。不也婆伽婆。不也修伽多。非是大海不容。世尊。由造业故彼诸众生成于小身。由造业故彼诸众生成于大身。佛言。如是奢利弗。以发愿力故。诸声闻少智。然如来阿罗诃三藐三佛陀。有不可量阿僧祇不可思不可称无边不可说智。何以故。彼昔行菩萨行。有不可量阿僧祇不可思不可称无边不可说愿。以造彼业成就乃至到无碍智最胜功德。奢利弗。譬如大海有诸众生与摩尼宝不相近合不知彼名。何况受用。如是奢利弗。有诸善家子等于此法律中生。于彼法海具足游者。其诸声闻独觉犹不知彼三摩地名。何况具足诸三摩地而欲当行。以具足三摩地故名如来阿罗诃三藐三佛陀。奢利弗。譬如射师作手作法。所放箭处彼处不虚。如是奢利弗。有善方便菩萨摩诃萨。以善方便摄取。般若波罗蜜具足。彼若发心当即不虚。无不摄取。无不回向阿耨多罗三藐三菩提。彼菩提心即不入欲嗔痴。非欲所染。非嗔所恶。非痴所迷。彼若发菩提心。即不入色乃至不入识。不入我乃至不入受。非眼界非色界。不入眼识界。乃至非意界非法界。不入意识界。彼若发菩提心。即离欲嗔痴。若无欲嗔痴。即有大慈大悲大喜大舍。若有大慈大悲大喜大舍即不可得。若不可得即无生灭。若无生灭即无断常。若无断常是名发菩提心。虚空界极法界究竟。虚空界业合方便智。是名发菩提心。奢利弗。譬如宝树生时长时非无诸宝功能。如是奢利弗。菩萨摩诃萨以诸善根回向阿耨多罗三藐三菩提。共摄大慈大悲大喜大舍。奢利弗。以是义故。当知菩萨摩诃萨发阿耨多罗三藐三菩提心犹如宝树。奢利弗。譬如此三千大千世界所有诸树诸草枝叶。彼等皆为灯炷。此三千大千世界所有诸须弥山王。轮山大轮山王。目真邻陀山大目真邻陀山王。余诸黑山及诸石山。彼等皆为灯器。此三千大千世界所有流泉陂池泊河小河大河大海。彼等皆为油满。若有声闻乘独觉乘善家子善家女。在如来阿罗诃三藐三佛陀前。然彼诸灯。奢利弗。于意云何。彼善家子善家女。彼因缘故福德多不。答言甚多。大德婆伽婆。甚多大德修伽多。佛言。奢利弗。于意云何。若发大乘善家子善家女。乃至施一灯。彼因缘故何者福多。如是语已。奢利弗言。世尊发大乘者乃至施一灯。福德是多。非声闻乘独觉乘以无边阿僧祇无量灯施。如是语已。佛言。奢利弗。甚善甚善。奢利弗。如是如是。如汝所说。何以故。若诸菩萨摩诃萨陀那波罗蜜。即诸众生陀那波罗蜜。若诸菩萨陀那波罗蜜。彼诸众生。即得饮食衣服璎珞乘等受用众具。若诸菩萨陀那波罗蜜。彼诸众生即得长者财谷仓库等受用众具。亦得田宅园林殿堂城邑聚落国土王都等受用众具。奢利弗。略说诸菩萨尸罗。羼帝。毗梨耶。第耶那。般若。彼破尸罗众生。乃至无智众生。当得智慧。何以故。彼初发心如散种子。当如是见。彼修行已犹如种子增长。不退转地如成枝叶。一生补处犹如出华。彼如来地犹如成果。随众生欲如是聚果。如来涅槃当如是见。奢利弗。以是义故。当知由初发心如来出生。由于如来出诸众生所有乐具。亦由如来出诸声闻独觉。奢利弗。以是义故。善家子善家女所有善根。皆当回向阿耨多罗三藐三菩提。奢利弗。譬如月轮出时。此阎浮洲所有流泉陂池泊河小河大河。彼处皆见月轮。而彼月天子于自宫不动。彼之月轮不近一处。而于诸处现月轮影。如是奢利弗。住十地菩萨摩诃萨。多诸佛刹。乃至多百千俱致那由多佛刹。自身示现。彼诸佛刹所有村城聚落国土王都诸处。菩萨摩诃萨自身示现。有处示现陀那波罗蜜。或复舍头手足眼耳。或舍皮肉筋骨髓心。或舍子女妻妾宅舍村城聚落国土王都。或现无罪法祀大会。须食与食。须饮与饮。如是乃至骑乘衣服鬘香涂香床座倚枕灯明等。示现舍时。为摄悭惜众生故。乃至为舍五受聚故。有处示现尸罗波罗蜜。不缺不穿不斑不杂。亦如牦牛护尾。为摄破戒众生故。乃至令住三解脱门故。有处示现羼帝波罗蜜。若截手足及以挑眼自无嗔恚。为摄高慢嗔毒众生耽富贵者故。乃至令住无生法忍故。有处示现毗梨耶波罗蜜。为懈怠众生炽然精进故。厌离自乐令诸众生住乐故。为摄懈怠小精进众生令住精进故。乃至令住十地故。有处示现弟耶那波罗蜜。游戏弟耶那解脱三摩地三摩钵帝。为摄失念不正知无三摩地心乱心众生故。乃至令住金刚三摩地故。有处示现般若波罗蜜。说难度深佛法故。处非处地非地。如众生行为说法故。如是奢利弗。住十地菩萨摩诃萨。巧摄方便般若波罗蜜具足。如所欲得如是能作。如诸众生信诸波罗蜜。如是为诸众生示现诸波罗蜜。如诸众生信色。如是为诸众生示现于色。如信法本。如是为诸众生说法。令彼众生当得不退转阿耨多罗三藐三菩提。奢利弗。譬如有树能与诸欲。若有众生欲得诸宝来到其边。令彼众生所欲得满。若食若衣若璎珞。若其众生所须诸宝。金银毗琉璃颇梨赤真珠马瑙车磲。如彼众生有所须欲。诸宝即生。彼与众生。诸所欲树。若割若破若斫。不见其树割处破处及斫损处。转更增长出种种宝。如是奢利弗。住十地菩萨摩诃萨。有处示现陀那波罗蜜。有处示现尸罗羼帝毗梨耶弟耶那般若波罗蜜。巧方便为首。有处示现生四天王天。三十三天。须夜摩天。兜率多天。化乐天。他化自在天。诸魔罗身天。乃至诸梵身天。梵光天梵众天梵辅天大梵天。光天少光天无量光天。净天少净天无量净天遍净天。广天少广天无量广天广果天。无热天善见天善现天。乃至生阿迦尼吒天。示现自身说法。有处示现有想无想众生。乃至非想非非想天。有处示现此阎浮洲作转轮王身。为众生说法。有处示现转轮王四分中一分王形色。有处示现力转轮王形色。有处示现刹帝利长者大臣王臣小男小女归女丈夫沙门婆罗门尼楗梵志天龙夜叉楗闼婆阿修罗伽留茶紧那罗摩睺罗伽人非人等乃至依城者形色。有处示现声闻独觉形色。有处示现下兜率宫。或入母胎。或出生。或梵释捧接。或行七步。或口出言。我是世间尊胜当穷生死。或诣学堂。或入天祠。或处宫内。或在阎浮树下。或身出家。或至道场。或降魔罗军众。或证无上菩提。或转法轮。或为四众八部说法。或现涅槃。或一全身。或如芥子。或炽正法或现法灭。奢利弗。略说如诸众生所信说法者。是诸菩萨摩诃萨。自身示现。为成熟诸众生故。如诸众生信诸法本。是诸菩萨摩诃萨。为诸众生说于法本。令彼诸众生等得不退转阿耨多罗三藐三菩提。奢利弗。譬如幻师。若幻师弟子。住四大道示种种幻。所谓象马车步。奢利弗。于意云何。彼四分兵来处去处。十方诸世界中可得知不。答言。不也婆伽婆。不也修伽多。彼幻来去不可得知。而彼幻非无因。佛言。如是奢利弗。彼佛智若来若去。十方诸世界中亦不可知。如来阿罗诃三藐三佛陀。以是智具足故。十方诸世界中。诸众生所有心行皆如实知。而彼智非无因。彼智最上当如是见。奢利弗。譬如有人被捉咽喉。则诸处根皆当被捉。如是奢利弗。若善家子善家女。以遍智心菩提心中入诸佛法。请诸众生。摄诸众生。持诸众生。奢利弗。譬如有人寿命百岁。将一滴水来与如来阿罗诃三藐三佛陀。作如是言。世尊。我寄此一滴水。愿为持之莫杂余水。如来取已掷恒伽大河中。掷已彼一滴水向于大海。时彼寿百岁人过岁还来作如是言。世尊。与我前所寄一滴之水。不令杂余水者。奢利弗。如来阿罗诃三藐三佛陀。有如是智。谓不思智。无比智。出三界智。如来阿罗诃三藐三佛陀。具是智已从大海出彼前所寄一滴之水不杂余水。还与彼人。如是奢利弗。如来阿罗诃三藐三佛陀。非一佛刹中说法。亦非二三四五。乃至非千佛刹中说法。种种善巧方便教化众生。何以故。如来阿罗诃三藐三佛陀。不可量阿僧祇不可称不可说无量千佛刹中说法。种种善巧方便教化众生。奢利弗。譬如春后夏月正炽热时。有一丈夫乃与大众欲过旷野。彼于行时远见焰动。彼人慰喻彼大众言。汝等但来有水可饮。尔时彼人令彼大众望水不绝。速出旷野便得苏息。不损不伤安隐无畏至自境界。如是奢利弗。如来阿罗诃三藐三佛陀。令诸声闻欲入阿罗汉果为其说法如阿罗汉所作相应精勤用力。彼既作已便获其利。奢利弗。若信是法。彼即信无尘法。若信无尘法。彼即信如来阿罗诃三藐三佛陀。若信如来阿罗诃三藐三佛陀。彼即于无尘法解脱。若于无尘法解脱。彼即解脱生老病死忧悲苦恼。奢利弗。譬如漏尽阿罗汉在阿兰拏山远险之处诵时。彼处有响。彼时更有异人闻已。即得阿罗汉果。奢利弗。于意云何。彼人是谁调伏。答言。世尊。是阿罗汉。佛言。奢利弗。于意云何。彼漏尽阿罗汉。岂作如是念言。我若诵时当有众生得调伏耶。答言。不也婆伽婆。不也修伽多。佛言。奢利弗。于意云何。彼响从内从外从内外出。莫作是见。若诸众生所出音辞当如是信。若有是说彼亦随我。奢利弗。譬如丈夫妇女于睡梦中。乃见如来与声闻众围绕说法。奢利弗。于意云何。如来声闻其实来不。答言。不也婆伽婆。不也修伽多。佛言。如是奢利弗。若人现见我声闻众围绕说法。当信如梦。彼即现前见我及以法僧。奢利弗。譬如大海非无有宝而不取宝。何以故。彼于先世不曾作取宝业。是故彼摩尼宝黑不识不取。若人曾作摩尼宝业。彼即得入宝洲。入宝洲已取摩尼宝。如是奢利弗。非无法界。而不觉阿耨多罗三藐三菩提。奢利弗。但彼先世于佛境界。不作善根亦不发起。是故今入声闻。彼等不行如来行处。亦无如来功德。不具如来力无畏等及无碍智。如来阿罗诃三藐三佛陀。则具如来力无畏等及无碍智。奢利弗。譬如丈夫妇女执镜自看面轮。见自面相便生喜跃。如是奢利弗。无闻凡夫不知影喻法本故。驰走流转而生爱乐。是故奢利弗。菩萨摩诃萨应着如是铠甲。我今为诸众生说法。令于流转当知当断。奢利弗。菩萨摩诃萨当信诸法空虚不牢。如是当行。奢利弗。譬如如来阿罗诃三藐三佛陀。有所作化。彼化生时无所生。灭时无所灭。于佛境界若问若答此非二法。如来所化生时无所生。灭时无所灭。如是奢利弗。得无生法忍菩萨摩诃萨觉诸法无生。觉已不得一法。若生时生无处法生。若灭时灭亦无有为无为。何以故。菩萨摩诃萨觉诸法无二故。奢利弗。譬如沫搏无有牢固。彼无牢固当随顺知。如是奢利弗。诸法无牢固。诸法是空。当随顺知。诸法如海本性无有二相。奢利弗。譬如水泡从因缘生。以一一因不能得生。如是奢利弗。凡有众生因不正念欲取于生。彼皆虚无空不牢固。彼诸众生于实际中不如实知。不见不入不觉。我为彼等众生。昔着如是铠甲。云何令彼诸众生等当见实际。我应为说流转轮回。奢利弗。譬如鸟行虚空无法障碍。如是奢利弗。菩萨乘善家子善家女等。于诸法无碍际。无尘际。无二际。信于遍智。我说是菩萨乘善家子善家女等。决定阿耨多罗三藐三菩提。奢利弗。譬如神通比丘行虚空时。虽见其行不见步迹。如是奢利弗。见菩萨行。而不能说彼法及善根回向处。何以故。奢利弗。我所觉法不可言说。彼法诸天龙夜叉揵闼婆阿修罗伽留荼紧那罗摩睺罗伽人非人等不能成就。唯除诸菩萨摩诃萨于诸世界最胜具足上智着大铠甲。何以故。彼菩萨摩诃萨诸天等世皆不能及。奢利弗。譬如手足能作诸事。如是奢利弗。于此法本当如是见。奢利弗。譬如有人能以一指示现五指。于意云何。彼难作不。奢利弗言。甚难婆伽婆。甚难修伽多。佛言。奢利弗。我此说难。如虚空等法界。虚空等法觉已。为他解说此难于彼。我说希有。何以故。奢利弗。彼菩萨摩诃萨。虚空等法觉已。不作戏论而能增长。如是奢利弗。所有善根菩萨摩诃萨。当觉阿耨多罗三藐三菩提。彼诸善根皆是虚无空不牢固。阿耨多罗三藐三菩提示现已。彼诸善根乃不欺诳。觉阿耨多罗三藐三菩提。是故奢利弗。菩萨摩诃萨应着如是铠甲。我信诸法是不牢固。若不入此忍者。不能成就八人法。须陀洹法。斯陀含法。阿那含法。阿罗汉法。何况觉阿耨多罗三藐三菩提。唯除诸菩萨摩诃萨于诸三界最胜具足上智。奢利弗。是故菩萨摩诃萨应近善友承事供养。何者善友。所谓示教行六波罗蜜。若以余教彼非善友。若菩萨摩诃萨。如是言如是教。如是应学诸波罗蜜。如是应学诸菩萨法。当知彼名菩萨摩诃萨真实善友。奢利弗。譬如以一滴稣掷大海中。于意云何。此为多不。奢利弗言。不也婆伽婆。不也修伽多。于彼水中还是一滴。佛言。如是如是。奢利弗。诸声闻独觉戒定智解脱解脱知见。少摄不能为诸众生而作利益。奢利弗。譬如以一滴油掷华池中。彼则遍满不知其油滴法。如是奢利弗。诸菩萨摩诃萨戒定智解脱解脱知见。乃至诸有善根。为诸众生当得受用。乃至究竟涅槃。奢利弗。譬如有一丈夫于大海中破百分毛取一滴水。于意云何。彼一滴水比于大海水聚。何者为多。奢利弗言。世尊。假使取百踰阇那。犹当是少。何况彼人破百分毛取一滴水。佛言。奢利弗。如是诸声闻独觉智如一滴水。诸菩萨摩诃萨知见如大海水聚。诸菩萨摩诃萨具足是知见故。能成熟诸众生。乃至将到无余涅槃界。佛说此赞诸菩萨摩诃萨功德法本时。无量阿僧祇无边诸众生等发阿耨多罗三藐三菩提心。无量阿僧祇无边诸菩萨摩诃萨善根炽然增长劝行成就。无量阿僧祇无边天人等世远尘虽垢。于诸法中得法眼净。佛说此经时。尊者奢利弗。及余诸比丘比丘尼优婆塞迦优波斯迦。天人楗闼婆阿修罗等闻佛所说。皆大欢喜

譬喻王经卷下


地藏菩萨本愿经

    No. 412

地藏菩萨本愿经卷上

        唐于阗国三藏沙门实叉难陀译

    忉利天宫神通品第一

如是我闻。一时佛在忉利天。为母说法。尔时十方无量世界不可说不可说一切诸佛。及大菩萨摩诃萨。皆来集会。赞叹释迦牟尼佛。能于五浊恶世。现不可思议大智慧神通之力。调伏刚强众生知苦乐法。各遣侍者问讯世尊。是时如来含笑。放百千万亿大光明云。所谓大圆满光明云。大慈悲光明云。大智慧光明云。大般若光明云。大三昧光明云。大吉祥光明云。大福德光明云。大功德光明云。大归依光明云。大赞叹光明云。放如是等不可说光明云已。又出种种微妙之音。所谓檀波罗蜜音。尸波罗蜜音。羼提波罗蜜音。毗离耶波罗蜜音。禅波罗蜜音。般若波罗蜜音。慈悲音喜舍音。解脱音无漏音。智慧音大智慧音。师子吼音大师子吼音。云雷音大云雷音。出如是等不可说不可说音已。娑婆世界及他方国土。有无量亿天龙鬼神。亦集到忉利天宫。所谓四天王天忉利天。须焰摩天兜率陀天。化乐天他化自在天。梵众天梵辅天大梵天。少光天无量光天光音天。少净天无量净天遍净天。福生天福爱天广果天。无想天无烦天无热天。善见天善现天色究竟天。摩醯首罗天乃至非想非非想处天。一切天众龙众鬼神等众悉来集会。复有他方国土及娑婆世界。海神江神河神树神。山神地神川泽神苗稼神昼神。夜神空神天神。饮食神草木神。如是等神皆来集会。复有他方国土及娑婆世界诸大鬼王。所谓恶目鬼王啖血鬼王。啖精气鬼王啖胎卵鬼王。行病鬼王摄毒鬼王。慈心鬼王福利鬼王。大爱敬鬼王如是等鬼王。皆来集会。尔时释迦牟尼佛告文殊师利法王子菩萨摩诃萨。汝观是一切诸佛菩萨。及天龙鬼神。此世界他世界此国土他国土。如是今来集会到忉利天者。汝知数不。文殊师利白佛言。世尊若以我神力千劫测度不能得知。佛告文殊师利。吾以佛眼观故犹不尽数。此皆是地藏菩萨久远劫来。已度当度未度。已成就当成就。未成就。文殊师利白佛言。世尊我已过去久修善根证无碍智。闻佛所言即当信受。小果声闻天龙八部。及未来世诸众生等。虽闻如来诚实之语必怀疑惑。设使顶受未免兴谤。唯愿世尊广说地藏菩萨摩诃萨。因地作何行立何愿。而能成就不思议事。佛告文殊师利。譬如三千大千世界。所有草木丛林稻麻竹苇。山石微尘一物一数。作一恒河。一恒河沙一沙之界。一界之内一尘一劫。一劫之内所积尘数。尽克为劫。地藏菩萨证十地果位已来。千倍多于上喻。何况地藏菩萨在声闻辟支佛地。文殊师利。此菩萨威神誓愿不可思议。若未来世有善男子善女人。闻是菩萨名字。或赞叹或瞻礼。或称名或供养。乃至彩画刻镂塑漆形像。是人当得百返生于三十三天永不堕恶道。文殊师利。是地藏菩萨摩诃萨。于过去久远不可说不可说劫前。身为大长者子。时世有佛号曰师子奋迅具足万行如来。时长者子见佛相好千福庄严。因问彼佛。作何行愿而得此相。时师子奋迅具足万行如来。告长者子。欲证此身当须久远度脱一切受苦众生。文殊师利。时长者子因发愿言。我今尽未来际不可计劫。为是罪苦六道众生广设方便尽令解脱。而我自身方成佛道。以是于彼佛前立斯大愿。于今百千万亿那由他不可说劫尚为菩萨。又于过去不可思议阿僧祇劫。时世有佛号曰觉华定自在王如来。彼佛寿命四百千万亿阿僧祇劫。像法之中有一婆罗门女。宿福深厚众所钦敬。行住坐卧诸天卫护。其母信邪常轻三宝。是时圣女广说方便。劝诱其母令生正见。而此女母未全生信。不久命终。魂神堕在无间地狱。时婆罗门女知母在世不信因果。计当随业必生恶趣。遂卖家宅广求香华及诸供具。于先佛塔寺大兴供养。见觉华定自在王如来其形像在一寺中。塑画威容端严毕备。时婆罗门女瞻礼尊容。倍生敬仰私自念言。佛名大觉具一切智。若在世时我母死后。傥来问佛必知处所。时婆罗门女垂泣良久。瞻恋如来忽闻空中声曰。泣者圣女勿至悲哀。我今示汝母之去处。婆罗门女合掌向空而白空曰。是何神德宽我忧虑。我自失母已来昼夜忆恋。无处可问知母生界。时空中有声再报女曰。我是汝所瞻礼者。过去觉华定自在王如来。见汝忆母倍于常情众生之分。故来告示。婆罗门女闻此声已。举身自扑支节皆损。左右扶侍良久方稣。而白空曰。愿佛慈愍速说我母生界。我今身心将死不久。时觉华定自在王如来告圣女曰。汝供养毕但早返舍。端坐思惟吾之名号。即当知母所生去处。时婆罗门女寻礼佛已即归其舍。以忆母故端坐念觉华定自在王如来。经一日一夜。忽见自身。到一海边其水涌沸。多诸恶兽尽复铁身。飞走海上东西驰逐。见诸男子女人百千万数出没海中。被诸恶兽争取食啖。又见夜叉其形各异。或多手多眼多足多头。口牙外出利刃如剑。驱诸罪人使近恶兽。复自搏攫头足相就。其形万类不敢久视。时婆罗门女以念佛力故自然无惧。有一鬼王名曰无毒。稽首来迎白圣女曰。善哉菩萨何缘来此。时婆罗门女问鬼王曰。此是何处。无毒答曰。此是大铁围山西面第一重海。圣女问曰。我闻铁围之内。地狱在中是事实不。无毒答曰实有地狱。圣女问曰。我今云何得到狱所。无毒答曰。若非威神即须业力。非此二事终不能到。圣女又问。此水何缘而乃涌沸。多诸罪人及以恶兽。无毒答曰。此是阎浮提造恶众生新死之者。经四十九日后。无人继嗣为作功德救拔苦难。生时又无善因当据本业所感地狱。自然先渡此海。海东十万由旬又有一海其苦倍此。彼海之东又有一海其苦复倍。三业恶因之所招感。共号业海其处是也。圣女又问鬼王无毒曰地狱何在。无毒答曰。三海之内是大地狱。其数百千各各差别。所谓大者具有十八次有五百苦毒无量。次有千百亦无量苦。圣女又问大鬼王曰。我母死来未久。不知魂神当至何趣。鬼王问圣女曰。菩萨之母在生习何行业。圣女答曰我母邪见讥毁三宝。设或暂信旋又不敬。死虽日浅未知生处。无毒问曰。菩萨之母姓氏何等。圣女答曰。我父我母俱婆罗门种。父号尸罗善现母号悦帝利。无毒合掌启菩萨曰。愿圣者却返本处。无至忧忆悲恋。悦帝利罪女生天以来经今三日。云承孝顺之子为母设供修福。布施觉华定自在王如来塔寺。非唯菩萨之母得脱地狱。应是无间罪人此日悉得受乐俱同生讫。鬼王言毕合掌而退。婆罗门女寻如梦归悟此事已。便于觉华定自在王如来塔像之前立弘誓愿。愿我尽未来劫。应有罪苦众生广设方便使令解脱。佛告文殊师利。时鬼王无毒者当今财首菩萨是。婆罗门女者即地藏菩萨是

    分身集会品第二

尔时百千万亿不可思不可议不可量不可说无量阿僧祇世界。所有地狱处分身地藏菩萨。俱来集在忉利天宫。以如来神力故。各以方面与诸得解脱从业道出者。亦各有千万亿那由他数。共持香华来供养佛。彼诸同来等辈。皆因地藏菩萨教化。永不退转于阿耨多罗三藐三菩提。是诸众等久远劫来。流浪生死六道受苦暂无休息。以地藏菩萨广大慈悲深誓愿故。各获果证既至忉利。心怀踊跃瞻仰如来目不暂舍。尔时世尊舒金色臂。摩百千万亿不可思不可议不可量不可说无量阿僧祇世界诸分身地藏菩萨摩诃萨顶。而作是言。吾于五浊恶世。教化如是刚强众生。令心调伏舍邪归正。十有一二尚恶习在。吾亦分身千百亿广设方便。或有利根闻即信受。或有善果勤劝成就。或有暗钝久化方归。或有业重不生敬仰。如是等辈众生。各各差别分身度脱。或现男子身或现女人身。或现天龙身或现神鬼身。或现山林川原河池泉井。利及于人悉皆度脱。或现天帝身或现梵王身。或现转轮王身或现居士身。或现国王身或现宰辅身。或现官属身。或现比丘．比丘尼．优婆塞．优婆夷身。乃至声闻．罗汉．辟支佛．菩萨等身。而以化度。非但佛身独现其前。汝观吾累劫勤苦。度脱如是等难化刚强罪苦众生。其有未调伏者随业报应。若堕恶趣受大苦时。汝当忆念。吾在忉利天宫殷勤付嘱。令娑婆世界至弥勒出世已来众生。悉使解脱永离诸苦遇佛授记。尔时诸世界分身地藏菩萨。共复一形涕泪哀恋白其佛言。我从久远劫来蒙佛接引。使获不可思议神力具大智慧。我所分身遍满百千万亿恒河沙世界。每一世界化百千万亿身。每一身度百千万亿人。令归敬三宝永离生死至涅槃乐但于佛法中所为善事。一毛一渧一沙一尘。或毫发许。我渐度脱使获大利。唯愿世尊不以后世恶业众生为虑。如是三白佛言。唯愿世尊不以后世恶业众生为虑。尔时佛赞地藏菩萨言。善哉善哉吾助汝喜。汝能成就久远劫来发弘誓愿。广度将毕即证菩提

    观众生业缘品第三

尔时佛母摩耶夫人。恭敬合掌问地藏菩萨言。圣者。阎浮众生造业差别。所受报应其事云何。地藏答言。千万世界乃及国土。或有地狱或无地狱。或有女人或无女人。或有佛法或无佛法。乃至声闻辟支佛亦复如是非但地狱罪报一等。摩耶夫人重白菩萨。且愿闻于阎浮罪报所感恶趣。地藏答言。圣母。唯愿听受。我粗说之。佛母白言。愿圣者说尔时地藏菩萨白圣母言。南阎浮提罪报名号如是。若有众生不孝父母或至杀害。当堕无间地狱。千万亿劫求出无期。若有众生出佛身血。毁谤三宝不敬尊经。亦当堕于无间地狱。千万亿劫求出无期。若有众生侵损常住点污僧尼。或伽蓝内恣行淫欲。或杀或害如是等辈。当堕无间地狱。千万亿劫求出无期。若有众生伪作沙门心非沙门。破用常住欺诳白衣。违背戒律种种造恶。如是等辈当堕无间地狱。千万亿劫求出无期。若有众生偷窃常住财物谷米饮食衣服乃至一物不与取者。当堕无间地狱。千万亿劫求出无期。地藏白言。圣母。若有众生作如是罪。当堕五无间地狱。求暂停苦一念不得。摩耶夫人重白地藏菩萨言。云何名为无间地狱。地藏白言。圣母。诸有地狱在大铁围山之内。其大地狱有一十八所。次有五百名号各别。次有千百名字亦别。无间狱者其狱城周匝八万余里。其城纯铁高一万里。城上火聚少有空缺。其狱城中诸狱相连名号各别独有一狱名曰无间。其狱周匝万八千里。狱墙高一千里悉是铁为。上火彻下下火彻上。铁蛇铁狗吐火驰逐。狱墙之上东西而走。狱中有床遍满万里。一人受罪自见其身遍卧满床。千万人受罪亦各自见身满床上。众业所感获报如是。又诸罪人备受众苦。千百夜叉及以恶鬼。口牙如剑眼如电光。手复铜爪拖拽罪人。复有夜叉执大铁戟中罪人身。或中口鼻或中腹背。抛空翻接或置床上。复有铁鹰啖罪人目。复有铁蛇缴罪人颈。百肢节内悉下长钉。拔舌耕犁抽肠剉斩。洋铜灌口热铁缠身。万死千生业感如是。动经亿劫求出无期。此界坏时寄生他界。他界次坏转寄他方。他方坏时展转相寄。此界成后还复而来。无间罪报其事如是。又五事业感故称无间。何等为五。一者日夜受罪以至劫数。无时间绝故称无间。二者一人亦满多人亦满故称无间。三者罪器叉棒鹰蛇狼犬。碓磨锯凿剉斫镬汤。铁网铁绳铁驴铁马。生革络首热铁浇身。饥吞铁丸渴饮铁汁。从年竟劫数那由他。苦楚相连更无间断故称无间。四者不问男子女人羌胡夷狄老幼贵贱。或龙或神或天或鬼。罪行业感悉同受之故称无间。五者若堕此狱。从初入时至百千劫。一日一夜万死万生。求一念间暂住不得。除非业尽方得受生。以此连绵故称无间。地藏菩萨白圣母言。无间地狱粗说如是。若广说地狱罪器等名及诸苦事。一劫之中求说不尽。摩耶夫人闻已。愁忧合掌顶礼而退

    阎浮众生业感品第四

尔时地藏菩萨摩诃萨白佛言。世尊。我承佛如来威神力故。遍百千万亿世界。分是身形救拔一切业报众生。若非如来大慈力故。即不能作如是变化。我今又蒙佛付嘱。至阿逸多成佛已来。六道众生遣令度脱。唯然世尊愿不有虑。尔时佛告地藏菩萨。一切众生未解脱者。性识无定。恶习结业善习结果。为善为恶逐境而生。轮转五道暂无休息。动经尘劫迷惑障难。如鱼游网将是长流。脱入暂出又复遭网。以是等辈吾当忧念。汝既毕是往愿。累劫重誓广度罪辈。吾复何虑。说是语时。会中有一菩萨摩诃萨。名定自在王。白佛言。世尊。地藏菩萨。累劫已来各发何愿。今蒙世尊殷勤赞叹。唯愿世尊略而说之。尔时世尊告定自在王菩萨。谛听谛听善思念之。吾当为汝分别解说。乃往过去无量阿僧祇那由他不可说劫。尔时有佛号一切智成就如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛寿命六万劫。未出家时为小国王。与一邻国王为友。同行十善饶益众生。其邻国内所有人民多造众恶。二王议计广设方便。一王发愿早成佛道。当度是辈令使无余。一王发愿若不先度罪苦。令是安乐得至菩提。我终未愿成佛。佛告定自在王菩萨。一王发愿早成佛者。即一切智成就如来是。一王发愿永度罪苦众生。未愿成佛者即地藏菩萨是。复于过去无量阿僧祇劫。有佛出世名清净莲华目如来。其佛寿命四十劫。像法之中有一罗汉福度众生。因次教化。遇一女人字曰光目。设食供养。罗汉问之欲愿何等。光目答言。我以母亡之日资福救拔。未知我母生处何趣。罗汉愍之为入定观。见光目女母堕在恶趣受极大苦。罗汉问光目言。汝母在生作何行业。今在恶趣受极大苦。光目答言。我母所习。唯好食啖鱼鳖之属。所食鱼鳖多食其子。或炒或煮恣情食啖。计其命数千万复倍。尊者慈愍如何哀救。罗汉愍之为作方便。劝光目言。汝可志诚念清净莲华目如来兼塑画形像存亡获报。光目闻已即舍所爱。寻画佛像而供养之。复恭敬心悲泣瞻礼。忽于夜后梦见佛身。金色晃耀如须弥山。放大光明而告光目。汝母不久当生汝家。才觉饥寒即当言说。其后家内婢生一子。未满三日而乃言说。稽首悲泣告于光目。生死业缘果报自受。吾是汝母。久处暗冥。自别汝来。累堕大地狱。蒙汝福力方得受生。为下贱人又复短命。寿年十三更落恶道。汝有何计令吾脱免。光目闻说知母无疑。哽咽悲啼而白婢子。既是我母合知本罪。作何行业堕于恶道。婢子答言。以杀害毁骂二业受报。若非蒙福救拔吾难。以是业故未合解脱。光目问言。地狱罪报其事云何。婢子答言。罪苦之事不忍称说。百千岁中卒白难竟。光目闻已啼泪号泣。而白空界。愿我之母永脱地狱。毕十三岁更无重罪及历恶道。十方诸佛慈哀愍我。听我为母所发广大誓愿。若得我母永离三涂及斯下贱。乃至女人之身永劫不受者。愿我自今日后。对清净莲华目如来像前。却后百千万亿劫中。应有世界所有地狱。及三恶道诸罪苦众生。誓愿救拔令离地狱恶趣畜生饿鬼等。如是罪报等人尽成佛竟。我然后方成正觉。发誓愿已。具闻清净莲华目如来。而告之曰。光目。汝大慈愍善能为母发如是大愿。吾观汝母十三岁毕舍此报已生为梵志寿年百岁。过是报后当生无忧国土。寿命不可计劫。后成佛果广度人天数如恒河沙。佛告定自在王。尔时罗汉福度光目者即无尽意菩萨是。光目母者即解脱菩萨是。光目女者即地藏菩萨是。过去久远劫中如是慈愍。发恒河沙愿广度众生。未来世中若有男子女人。不行善者。行恶者。乃至不信因果者。邪淫妄语者。两舌恶口者。毁谤大乘者。如是诸业众生必堕恶趣。若遇善知识劝。令一弹指间。归依地藏菩萨。是诸众生即得解脱三恶道报。若能志心归敬及瞻礼赞叹。香华衣服种种珍宝或复饮食。如是奉事者。未来百千万亿劫中。常在诸天受胜妙乐。若天福尽下生人间。犹百千劫常为帝王。能忆宿命因果本末。定自在王。如是地藏菩萨。有如此不可思议大威神力广利众生。汝等诸菩萨当记是经广宣流布。定自在王白佛言。世尊愿不有虑。我等千万亿菩萨摩诃萨。必能承佛威神广演是经。于阎浮提利益众生。定自在王菩萨白世尊已。合掌恭敬作礼而退。尔时四方天王俱从座起。合掌恭敬白佛言。世尊。地藏菩萨于久远劫来。发如是大愿。云何至今犹度未绝。更发广大誓言。唯愿世尊为我等说。佛告四天王。善哉善哉吾今为汝及未来现在天人众等广利益故。说地藏菩萨于娑婆世界阎浮提内生死道中。慈哀救拔度脱一切罪苦众生方便之事。四天王言。唯然世尊愿乐欲闻。佛告四天王。地藏菩萨久远劫来。迄至于今度脱众生犹未毕愿。慈愍此世罪苦众生。复观未来无量劫中因蔓不断。以是之故又发重愿。如是菩萨于娑婆世界阎浮提中。百千万亿方便而为教化。四天王。地藏菩萨若遇杀生者说宿殃短命报。若遇窃盗者说贫穷苦楚报。若遇邪淫者说雀鸽鸳鸯报。若遇恶口者说眷属斗诤报。若遇毁谤者说无舌疮口报。若遇嗔恚者说丑陋癃残报。若遇悭吝者说所求违愿报。若遇饮食无度者说饥渴咽病报。若遇畋猎恣情者说惊狂丧命报。若遇悖逆父母者说天地灾杀报。若遇烧山林木者说狂迷取死报。若遇前后父母恶毒者说返生鞭挞现受报。若遇网捕生雏者说骨肉分离报。若遇毁谤三宝者说盲聋喑哑报。若遇轻法慢教者说永处恶道报。若遇破用常住者说亿劫轮回地狱报。若遇污梵诬僧者。说永在畜生报。若遇汤火斩斫伤生者说轮回递偿报。若遇破戒犯斋者说禽兽饥饿报。若遇非理毁用者说所求阙绝报。若遇吾我贡高者说卑使下贱报。若遇两舌斗乱者说无舌百舌报。若遇邪见者说边地受生报。如是等阎浮提众生。身口意业恶习结果。百千报应今粗略说。如是等阎浮提众生业感差别。地藏菩萨百千方便而教化之。是诸众生先受如是等报。后堕地狱动经劫数无有出期。是故汝等护人护国。无令是诸众业迷惑众生。四天王闻已。涕泪悲叹合掌而退

    地狱名号品第五

尔时普贤菩萨摩诃萨白地藏菩萨言。仁者。愿为天龙四众及未来现在一切众生。说娑婆世界及阎浮提罪苦众生所受报处地狱名号。及恶报等事。使未来世末法众生知是果报。地藏答言。仁者。我今承佛威神及大士之力。略说地狱名号及罪报恶报之事。仁者。阎浮提东方有山号曰铁围。其山黑邃无日月光。有大地狱号极无间。又有地狱名大阿鼻。复有地狱名曰四角。复有地狱名曰飞刀。复有地狱名曰火箭。复有地狱名曰夹山。复有地狱名曰通枪。复有地狱名曰铁车。复有地狱名曰铁床。复有地狱名曰铁牛。复有地狱名曰铁衣。复有地狱名曰千刃。复有地狱名曰铁驴。复有地狱名曰洋铜。复有地狱名曰抱柱。复有地狱名曰流火。复有地狱名曰耕舌。复有地狱名为剉首。复有地狱名曰烧脚。复有地狱名曰啖眼。复有地狱名曰铁丸。复有地狱名曰诤论。复有地狱名曰铁呋。复有地狱名曰多嗔。地藏白言。仁者。铁围之内有如是等地狱其数无限。更有叫唤地狱．拔舌地狱．粪尿地狱．铜锁地狱．火象地狱．火狗地狱．火马地狱．火牛地狱．火山地狱．火石地狱．火床地狱．火梁地狱．火鹰地狱．锯牙地狱．剥皮地狱．饮血地狱．烧手地狱．烧脚地狱．倒刺地狱．火屋地狱．铁屋地狱．火狼地狱．如是等地狱．其中各各复有诸小地狱．或一或二或三或四乃至百千。其中名号各各不同。地藏菩萨告普贤菩萨言。仁者。此者皆是南阎浮提行恶众生。业感如是业力甚大。能敌须弥能深巨海能障圣道。是故众生莫轻小恶以为无罪。死后有报纤毫受之。父子至亲岐路各别。纵然相逢无肯代受。我今承佛威力。略说地狱罪报之事。唯愿仁者暂听是言。普贤答言。吾以久知三恶道报。望仁者说令后世末法一切恶行众生。闻仁者说使令归佛。地藏白言。仁者。地狱罪报其事如是。或有地狱取罪人舌使牛耕之。或有地狱取罪人心夜叉食之。或有地狱镬汤盛沸煮罪人身。或有地狱赤烧铜柱使罪人抱。或有地狱使诸火烧趁及罪人。或有地狱一向寒冰。或有地狱无限粪尿。或有地狱纯飞[金*疾]鑗。或有地狱多攒火枪。或有地狱唯撞胸背。或有地狱但烧手足。或有地狱盘缴铁蛇。或有地狱驱逐铁狗。或有地狱尽驾铁骡。仁者如是等报。各各狱中有百千种。业道之器无非是铜是铁是石是火。此四种物众业行感。若广说地狱罪报等事。一一狱中更有百千种苦楚。何况多狱。我今承佛威神及仁者问。略说如是。若广解说穷劫不尽

    如来赞叹品第六

尔时世尊举身放大光明。遍照百千万亿恒河沙等诸佛世界。出大音声普告诸佛世界一切诸菩萨摩诃萨及天龙鬼神人非人等。听吾今日称扬赞叹地藏菩萨摩诃萨。于十方世界现大不可思议威神慈悲之力。救护一切罪苦之事。吾灭度后汝等诸菩萨大士。及天龙鬼神等。广作方便卫护是经。令一切众生证涅槃乐。说是语已会中有一菩萨。名曰普广。合掌恭敬而白佛言。今见世尊赞叹地藏菩萨。有如是不可思议大威神德。唯愿世尊为未来世末法众生。宣说地藏菩萨利益人天因果等事。使诸天龙八部及未来世众生顶受佛语。尔时世尊告普广菩萨及四众等。谛听谛听吾当为汝略说地藏菩萨利益人天福德之事。普广白言。唯然世尊愿乐欲闻。佛告普广菩萨。未来世中若有善男子善女人。闻是地藏菩萨摩诃萨名者。或合掌者赞叹者。作礼者。恋慕者。是人超越三十劫罪。普广。若有善男子善女人。或彩画形像。或土石胶漆金银铜铁。作此菩萨一瞻一礼者。是人百返生于三十三天。永不堕于恶道。假如天福尽故下生人间。犹为国王不失大利。若有女人厌女人身。尽心供养地藏菩萨画像。及土石胶漆铜铁等像。如是日日不退。常以华香饮食衣服缯彩幢旛钱宝物等供养。是善女人尽此一报女身。百千万劫更不生有女人世界。何况复受。除非慈愿力故要受女身度脱众生。承斯供养地藏力故及功德力。百千万劫不受女身。复次普广。若有女人厌是丑陋多疾病者。但于地藏像前志心瞻礼。食顷之间。是人千万劫中所受生身相貌圆满。是丑陋女人如不厌女身。即百千万亿生中。常为王女乃及王妃宰辅大姓大长者女。端正受生诸相圆满。由志心故瞻礼地藏菩萨获福如是。复次普广。若有善男子善女人。能对菩萨像前。作诸伎乐及歌咏赞叹香华供养。乃至劝于一人多人。如是等辈现在世中及未来世。常得百千鬼神日夜卫护。不令恶事辄闻其耳。何况亲受诸横。复次普广。未来世中若有恶人及恶神恶鬼。见有善男子善女人。归敬供养赞叹瞻礼地藏菩萨形像。或妄生讥毁。谤无功德及利益事。或露齿笑或背面非。或劝人共非。或一人非或多人非。乃至一念生讥毁者。如是之人贤劫千佛灭度。讥毁之报尚在阿鼻地狱受极重罪。过是劫已方受饿鬼。又经千劫复受畜生。又经千劫方得人身。纵受人身贫穷下贱诸根不具。多被恶业来结其心。不久之间复堕恶道。是故普广。讥毁他人供养尚获此报。何况别生恶见毁灭。复次普广。若未来世有男子女人。久处床枕求生求死了不可得。或夜梦恶鬼乃及家亲。或游险道或多魇寐。共鬼神游。日月岁深转复尪瘵眠中叫苦惨凄不乐者。此皆是业道论对未定轻重。或难舍寿或不得愈。男女俗眼不辨是事。但当对诸佛菩萨像前。高声转读此经一遍。或取病人可爱之物。或衣服宝贝庄园舍宅。对病人前高声唱言。我某甲等为是病人。对经像前舍诸等物。或供养经像或造佛菩萨形像。或造塔寺或然油灯。或施常住。如是三白。病人遣令闻知。假令诸识分散至气尽者。乃至一日二日三日四日至七日已来。但高声白高声读经。是人命终之后宿殃重罪至于五无间罪永得解脱。所受生处常知宿命。何况善男子善女人。自书此经或教人书或自塑画菩萨形像。乃至教人塑画。所受果报必获大利。是故普广。若见有人读诵是经。乃至一念赞叹是经或恭敬者。汝须百千方便。劝是等人勤心莫退。能得未来现在千万亿不可思议功德。复次普广。若未来世诸众生等。或梦或寐见诸鬼神乃及诸形。或悲或啼或愁或叹或恐或怖。此皆是一生十生百生千生。过去父母男女弟妹夫妻眷属在于恶趣未得出离。无处希望福力救拔。当告宿世骨肉。使作方便愿离恶道。普广。汝以神力遣是眷属。令对诸佛菩萨像前。志心自读此经或请人读。其数三遍或七遍。如是恶道眷属。经声毕是遍数当得解脱。乃至梦寐之中永不复见。复次普广若未来世有诸下贱等人或奴或婢。乃至诸不自由之人。觉知宿业要忏悔者。志心瞻礼地藏菩萨形像。乃至一七日中念菩萨名可满万遍。如是等人尽此报后。千万生中常生尊贵。更不经三恶道苦。复次普广。若未来世中阎浮提内。刹利婆罗门长者居士一切人等。及异姓种族有新产者。或男或女七日之中。早与读诵此不思议经典。更为念菩萨名可满万遍。是新生子或男或女。宿有殃报便得解脱。安乐易养寿命增长。若是承福生者转增安乐及与寿命。复次普广。若未来世众生。于月一日八日十四日十五日十八日二十三二十四二十八二十九日乃至三十日。是诸日等诸罪结集定其轻重。南阎浮提众生举止动念。无不是业无不是罪。何况恣情杀害窃盗邪淫妄语百千罪状。能于是十斋日。对佛菩萨诸贤圣像前读是经一遍。东西南北百由旬内无诸灾难。当此居家若长若幼。现在未来百千岁中永离恶趣。能于十斋日每转一遍。现世令此居家无诸横病衣食丰溢。是故普广当知。地藏菩萨有如是等不可说百千万亿大威神力利益之事。阎浮众生于此大士有大因缘。是诸众生闻菩萨名见菩萨像。乃至闻是经三字五字或一偈一句者。现在殊妙安乐。未来之世百千万生。常得端正生尊贵家。尔时普广菩萨闻佛如来称扬赞叹地藏菩萨已。胡跪合掌复白佛言。世尊。我久知是大士有如此不可思议神力及大誓愿力。为未来众生遣知利益故问如来唯然顶受。世尊当何名此经。使我云何流布。佛告普广此经有三名。一名地藏本愿。亦名地藏本行。亦名地藏本誓力经。缘此菩萨久远劫来。发大重愿利益众生。是故汝等依愿流布。普广闻已。合掌恭敬作礼而退

地藏菩萨本愿经卷上地藏菩萨本愿经卷下

        唐于阗国三藏沙门实叉难陀译

    利益存亡品第七

尔时地藏菩萨摩诃萨白佛言。世尊。我观是阎浮众生。举心动念无非是罪。脱获善利多退初心。若遇恶缘念念增益。是等辈人如履泥涂负于重石。渐困渐重足步深邃。若得遇知识替与减负或全与负。是知识有大力故。复相扶助劝令牢脚。若达平地须省恶路无再经历。世尊。习恶众生从纤毫间便至无量。是诸众生有如此习。临命终时父母眷属。宜为设福以资前路。或悬旛盖及然油灯。或转读尊经或供养佛像及诸圣像。乃至念佛菩萨及辟支佛名字。一名一号历临终人耳根。或闻在本识。是诸众生所造恶业。计其感果必堕恶趣。缘是眷属为临终人修此圣因。如是众罪悉皆销灭。若能更为身死之后七七日内广造众善。能使是诸众生永离恶趣。得生人天受胜妙乐。现在眷属利益无量。是故我今对佛世尊及天龙八部人非人等。劝于阎浮提众生。临终之日慎勿杀害及造恶缘。拜祭鬼神求诸魍魉。何以故。尔所杀害乃至拜祭。无纤毫之力利益亡人。但结罪缘转增深重。假使来世或现在生。得获圣分生人天中。缘是临终被诸眷属造是恶因。亦令是命终人殃累对辩晚生善处。何况临命终人。在生未曾有少善根。各据本业自受恶趣。何忍眷属更为增业。譬如有人从远地来绝粮三日。所负担物强过百斤。忽遇邻人更附少物。以是之故转复困重。世尊。我观阎浮众生。但能于诸佛教中。乃至善事一毛一渧一沙一尘。如是利益悉皆自得。说是语时。会中有一长者名曰大辩。是长者久证无生化度十方现长者身。合掌恭敬问地藏菩萨言。大士是南阎浮提众生命终之后。小大眷属为修功德。乃至设斋造众善因。是命终人得大利益及解脱不。地藏答言。长者。我今为未来现在一切众生。承佛威力略说是事。长者。未来现在诸众生等。临命终日得闻一佛名一菩萨名一辟支佛名。不问有罪无罪悉得解脱。若有男子女人。在生不修善因多造众罪。命终之后。眷属小大为造福利。一切圣事七分之中而乃获一。六分功德生者自利。以是之故未来现在善男女等。闻健自修分分已获。无常大鬼不期而到。冥冥游神未知罪福。七七日内如痴如聋或在诸司辩论业果。审定之后据业受生。未测之间千万愁苦。何况堕于诸恶趣等。是命终人未得受生。在七七日内念念之间望诸骨肉眷属与造福力救拔。过是日后随业受报。若是罪人动经千百岁中无解脱日。若是五无间罪堕大地狱。千劫万劫永受众苦。复次长者。如是罪业众生命终之后。眷属骨肉为修营斋资助业道。未斋食竟及营斋之次。米泔菜叶不弃于地。乃至诸食未献佛僧。勿得先食。如有违食及不精勤。是命终人了不得力。如精勤护净奉献佛僧。是命终人七分获一。是故长者阎浮众生。若能为其父母乃至眷属。命终之后设斋供养志心勤恳。如是之人存亡获利。说是语时忉利天宫。有千万亿那由他阎浮鬼神。悉发无量菩提之心。大辩长者作礼而退

    阎罗王众赞叹品第八

尔时铁围山内有无量鬼王。与阎罗天子俱诣忉利来到佛所。所谓恶毒鬼王．多恶鬼王．大诤鬼王．白虎鬼王．血虎鬼王．赤虎鬼王散殃鬼王．飞身鬼王．电光鬼王．狼牙鬼王．千眼鬼王．啖兽鬼王．负石鬼王．主耗鬼王．主祸鬼王．主食鬼王．主财鬼王．主畜鬼王．主禽鬼王．主兽鬼王．主魅鬼王．主产鬼王．主命鬼王．主疾鬼王．主险鬼王．三目鬼王．四目鬼王．五目鬼王．祁利失王．大祁利失王．祁利叉王．大祁利叉王．阿那吒王．大阿那吒王．如是等大鬼王。各各与百千诸小鬼王。尽居阎浮提。各有所执各有所主。是诸鬼王与阎罗天子。承佛威神及地藏菩萨摩诃萨力。俱诣忉利在一面立。尔时阎罗天子胡跪合掌白佛言。世尊。我等今者与诸鬼王承佛威神及地藏菩萨摩诃萨力。方得诣此忉利大会。亦是我等获善利故。我今有小疑事敢问世尊。唯愿世尊慈悲宣说。佛告阎罗天子恣汝所问吾为汝说。是时阎罗天子瞻礼世尊。及回视地藏菩萨而白佛言。世尊我观地藏菩萨。在六道中百千方便而度罪苦众生不辞疲倦。是大菩萨有如是不可思议神通之事。然诸众生脱获罪报。未久之间又堕恶道。世尊。是地藏菩萨既有如是不可思议神力。云何众生而不依止善道永取解脱。唯愿世尊为我解说。佛告阎罗天子。南阎浮提众生。其性刚强难调难伏。是大菩萨于百千劫头头救拔如是众生早令解脱。是罪报人乃至堕大恶趣。菩萨以方便力拔出根本业缘。而遣悟宿世之事。自是阎浮众生结恶习重。旋出旋入劳斯菩萨。久经劫数而作度脱。譬如有人迷失本家误入险道。其险道中多诸夜叉及虎狼师子蚖蛇蝮蝎。如是迷人在险道中。须臾之间即遭诸毒。有一知识多解大术。善禁是毒乃及夜叉诸恶毒等。忽逢迷人欲进险道。而语之言。咄哉男子。为何事故而入此路。有何异术能制诸毒。是迷路人忽闻是语。方知险道。即便退步求出此路。是善知识提携接手引出险道。免诸恶毒至于好道。令得安乐而语之言。咄哉迷人自今已后勿履是道。此路入者卒难得出复损性命。是迷路人亦生感重。临别之时。知识又言。若见亲知及诸路人若男若女。言于此路多诸毒恶丧失性命。无令是众自取其死。是故地藏菩萨具大慈悲救拔罪苦众生。生天人中令受妙乐。是诸罪众知业道苦。脱得出离永不再历。如迷路人误入险道。遇善知识引接令出。永不复入。逢见他人复劝莫入。自言因是迷故。得解脱竟更不复入。若再履践犹尚迷误。不觉旧曾所落险道。或致失命如堕恶趣。地藏菩萨方便力故使令解脱。生人天中旋又再入。若业结重永处地狱无解脱时。尔时恶毒鬼王合掌恭敬白佛言。世尊。我等诸鬼王。其数无量在阎浮提。或利益人或损害人各各不同。然是业报使我眷属游行世界。多恶少善过人家庭。或城邑聚落庄园房舍。或有男子女人修毛发善事。乃至悬一旛一盖少香少华。供养佛像及菩萨像。或转读尊经烧香供养一句一偈。我等鬼王敬礼是人。如过去现在未来诸佛。敕诸小鬼各有大力。及土地分便令卫护。不令恶事横事恶病横病。乃至不如意事。近于此舍等处。何况入门。佛赞鬼王善哉善哉汝等及与阎罗。能如是拥护善男女等。吾亦告梵王帝释令卫护汝。说是语时。会中有一鬼王名曰主命。白佛言。世尊。我本业缘主阎浮人命。生时死时我皆主之。在我本愿甚欲利益。自是众生不会我意。致令生死俱不得安。何以故。是阎浮提人初生之时不问男女。或欲生时但作善事增益舍宅。自今土地无量欢喜拥护子母。得大安乐利益眷属。或已生下慎勿杀害。取诸鲜味供给产母及广聚眷属。饮酒食肉歌乐弦管。能令子母不得安乐。何以故。是产难时有无数恶鬼及魍魉精魅欲食腥血。是我早令舍宅土地灵只荷护子母。使令安乐而得利益。如是之人见安乐故。便合设福答诸土地。翻为杀害集聚眷属。以是之故。犯殃自受子母俱损。又阎浮提临命终人不问善恶。我欲令是命终之人不落恶道。何况自修善根。增我力故。是阎浮提行善之人。临命终时。亦有百千恶道鬼神。或变作父母乃至诸眷属。引接亡人令落恶道。何况本造恶者。世尊。如是阎浮提男子女人临命终时。神识惛昧不辩善恶。乃至眼耳更无见闻。是诸眷属当须设大供养。转读尊经念佛菩萨名号。如是善缘能令亡者离诸恶道。诸魔鬼神悉皆退散。世尊。一切众生临命终时。若得闻一佛名一菩萨名。或大乘经典一句一偈。我观如是辈人除五无间杀害之罪。小小恶业合堕恶趣者寻即解脱。佛告主命鬼王。汝大慈故能发如是大愿。于生死中护诸众生。若未来世中有男子女人至生死时。汝莫退是愿。总令解脱永得安乐。鬼王白佛言。愿不有虑。我毕是形念念拥护阎浮众生。生时死时俱得安乐。但愿诸众生于生死时。信受我语无不解脱获大利益。尔时佛告地藏菩萨。是大鬼王主命者。已曾经百千生作大鬼王。于生死中拥护众生。是大士慈悲愿故。现大鬼身实非鬼也。却后过一百七十劫。当得成佛号曰无相如来。劫名安乐世界名净。住其佛寿命不可计劫。地藏。是大鬼王其事如是不可思议。所度天人亦不可限量

    称佛名号品第九

尔时地藏菩萨摩诃萨白佛言。世尊。我今为未来众生演利益事。于生死中得大利益。唯愿世尊听我说之。佛告地藏菩萨。汝今欲兴慈悲。救拔一切罪苦六道众生。演不思议事。今正是时唯当速说。吾即涅槃使汝早毕是愿。吾亦无忧现在未来一切众生。地藏菩萨白佛言。世尊。过去无量阿僧祇劫。有佛出世。号无边身如来。若有男子女人。闻是佛名暂生恭敬。即得超越四十劫生死重罪。何况塑画形像供养赞叹。其人获福无量无边。又于过去恒河沙劫。有佛出世。号宝性如来。若有男子女人。闻是佛名一弹指顷发心归依。是人于无上道永不退转。又于过去有佛出世。号波头摩胜如来。若有男子女人。闻是佛名历于耳根。是人当得千返生于六欲天中。何况志心称念。又于过去不可说不可说阿僧祇劫。有佛出世。号师子吼如来。若有男子女人闻是佛名一念归依。是人得遇无量诸佛摩顶授记。又于过去有佛出世。号拘留孙佛。若有男子女人。闻是佛名志心瞻礼。或复赞叹。是人于贤劫千佛会中。为大梵王得授上记。又于过去有佛出世。号毗婆尸。若有男子女人。闻是佛名永不堕恶道。常生人天受胜妙乐。又于过去无量无数恒河沙劫。有佛出世。号宝胜如来。若有男子女人。闻是佛名毕竟不堕恶道。常在天上受胜妙乐。又于过去有佛出世。号宝相如来。若有男子女人闻是佛名生恭敬心。是人不久得阿罗汉果。又于过去无量阿僧祇劫。有佛出世。号袈裟幢如来。若有男子女人。闻是佛名者超一百大劫生死之罪。又于过去有佛出世。号大通山王如来。若有男子女人。闻是佛名者是人得遇恒河沙佛。广为说法必成菩提。又于过去有净月佛．山王佛．智胜佛．净名王佛．智成就佛．无上佛．妙声佛．满月佛．月面佛。有如是等不可说佛世尊。现在未来一切众生。若天若人若男若女。但念得一佛名号功德无量。何况多名。是众生等生时死时。自得大利终不堕恶道。若有临命终人。家中眷属乃至一人。为是病人高声念一佛名。是命终人除五无间罪。余业报等悉得销灭。是五无间罪虽至极重动经亿劫了不得出。承斯临命终时他人为其称念佛名于是罪中亦渐销灭。何况众生自称自念。获福无量灭无量罪

    校量布施功德缘品第十

尔时地藏菩萨摩诃萨。承佛威神从座而起。胡跪合掌白佛言。世尊我观业道众生。校量布施有轻有重。有一生受福有十生受福。有百生千生受大福利者。是事云何。唯愿世尊为我说之。尔时佛告地藏菩萨。吾今于忉利天宫一切众会。说阎浮提布施校量功德轻重。汝当谛听吾为汝说。地藏白佛言。我疑是事愿乐欲闻。佛告地藏菩萨。南阎浮提有诸国王宰辅大臣大长者大刹利大婆罗门等。若遇最下贫穷乃至癃残喑哑聋痴无目。如是种种不完具者。是大国王等欲布施时。若能具大慈悲下心含笑。亲手遍布施。或使人施软言慰喻。是国王等所获福利。如布施百恒河沙佛功德之利。何以故。缘是国王等于是最贫贱辈及不完具者发大慈心。是故福利有如此报。百千生中常得七宝具足。何况衣食受用。复次地藏。若未来世有诸国王。至婆罗门等遇佛塔寺或佛形像乃至菩萨．声闻．辟支佛像。躬自营办供养布施。是国王等当得三劫为帝释身受胜妙乐。若能以此布施福利回向法界。是大国王等于十劫中常为大梵天王。复次地藏。若未来世有诸国王。至婆罗门等遇先佛塔庙。或至经像毁坏破落。乃能发心修补。是国王等或自营办或劝他人。乃至百千人等布施结缘。是国王等百千生中常为转轮王身。如是他人同布施者。百千生中常为小国王身。更能于塔庙前发回向心。如是国王乃及诸人尽成佛道。以此果报无量无边。复次地藏。未来世中有诸国王及婆罗门等。见诸老病及生产妇女。若一念间具大慈心。布施医药饮食卧具使令安乐。如是福利最不思议。一百劫中常为净居天主。二百劫中常为六欲天主。毕竟成佛永不堕恶道。乃至百千生中耳不闻苦声。复次地藏。若未来世中。有诸国王及婆罗门等。能作如是布施获福无量。更能回向不问多少。毕竟成佛。何况释梵转轮之报。是故地藏普劝众生当如是学。复次地藏。未来世中若善男子善女人。于佛法中种少善根毛发沙尘等许。所受福利不可为喻。复次地藏。未来世中若有善男子善女人。遇佛形像．菩萨形像．辟支佛形像．转轮王形像。布施供养得无量福。常在人天受胜妙乐。若能回向法界。是人福利不可为喻。复次地藏。未来世中若有善男子善女人。遇大乘经典。或听闻一偈一句发殷重心。赞叹恭敬布施供养。是人获大果报无量无边。若能回向法界。其福不可为喻。复次地藏。若未来世中有善男子善女人。遇佛塔寺大乘经典新者布施供养瞻礼赞叹恭敬合掌。若遇故者或毁坏者修补营理。或独发心或劝多人同共发心。如是等辈三十生中。常为诸小国王檀越之人。常为轮王还以善法教化诸小国王。复次地藏。未来世中若有善男子善女人。于佛法中所种善根。或布施供养或修补塔寺或装理经典。乃至一毛一尘一沙一渧。如是善事但能回向法界。是人功德百千生中受上妙乐。如但回向自家眷属。或自身利益。如是之果即三生受乐舍一得万报。是故地藏布施因缘其事如是

    地神护法品第十一

尔时坚牢地神。白佛言。世尊。我从昔来。瞻视顶礼无量菩萨摩诃萨。皆是大不可思议。神通智慧广度众生。是地藏菩萨摩诃萨。于诸菩萨誓愿深重。世尊。是地藏菩萨于阎浮提有大因缘。如文殊．普贤．观音．弥勒。亦化百千身形度于六道。其愿尚有毕竟。是地藏菩萨教化六道一切众生。所发誓愿劫数如千百亿恒河沙。世尊。我观未来及现在众生。于所住处于南方清洁之地。以土石竹木作其龛室。是中能塑画乃至金银铜铁。作地藏形像烧香供养瞻礼赞叹。是人居处即得十种利益。何等为十。一者土地丰壤。二者家宅永安。三者先亡生天。四者现存益寿。五者所求遂意六者无水火灾。七者虚耗辟除。八者杜绝恶梦。九者出入神护。十者多遇圣因。世尊。未来世中及现在众生。若能于所住处方面。作如是供养得如是利益。复白佛言。世尊。未来世中。若有善男子善女人。于所住处有此经典及菩萨像。是人更能转读经典供养菩萨。我常日夜以本神力卫护是人。乃至水火盗贼大横小横。一切恶事悉皆销灭。佛告坚牢地神。汝大神力诸神少及。何以故。阎浮土地悉蒙汝护。乃至草木沙石稻麻竹苇谷米宝贝从地而有。皆因汝力。又常称扬地藏菩萨利益之事汝之功德及以神通。百千倍于常分。地神。若未来世中有善男子善女人供养菩萨及转读是经。但依地藏本愿经一事修行者。汝以本神力而拥护之。勿令一切灾害及不如意事辄闻于耳。何况令受。非但汝独护是人故。亦有释梵眷属诸天眷属拥护是人。何故得如是圣贤拥护。皆由瞻礼地藏形像。及转读是本愿经故自然毕竟出离苦海证涅槃乐。以是之故得大拥护

    见闻利益品第十二

尔时世尊从顶门上放百千万亿大毫相光。所谓白毫相光．大白毫相光．瑞毫相光．大瑞毫相光．玉毫相光．大玉毫相光．紫毫相光．大紫毫相光．青毫相光．大青毫相光．碧毫相光．大碧毫相光．红毫相光．大红毫相光．绿毫相光．大绿毫相光．金毫相光．大金毫相光．庆云毫相光．大庆云毫相光．千轮毫光．大千轮毫光．宝轮毫光．大宝轮毫光．日轮毫光．大日轮毫光．月轮毫光．大月轮毫光．宫殿毫光．大宫殿毫光．海云毫光．大海云毫光．于顶门上放如是等毫相光已。出微妙音告诸大众天龙八部人非人等。听吾今日于忉利天宫。称扬赞叹地藏菩萨于人天中利益等事不思议事。超圣因事证十地事。毕竟不退阿耨多罗三藐三菩提事。说是语时。会中有一菩萨摩诃萨。名观世音。从座而起。胡跪合掌。白佛言。世尊。是地藏菩萨摩诃萨。具大慈悲怜愍罪苦众生。于千万亿世界化千万亿身。所有功德及不思议威神之力。我闻。世尊与十方无量诸佛异口同音赞叹地藏菩萨云。正使过去现在未来诸佛。说其功德犹不能尽。向者又蒙世尊普告大众。欲称扬地藏利益等事。唯愿世尊为现在未来一切众生。称扬地藏不思议事。令天龙八部瞻礼获福。佛告观世音菩萨。汝于娑婆世界有大因缘。若天若龙若男若女若神若鬼。乃至六道罪苦众生。闻汝名者见汝形者。恋慕汝者赞叹汝者。是诸众生于无上道必不退转。常生人天具受妙乐。因果将熟遇佛授记汝今具大慈悲怜愍众生。及天龙八部。听吾宣说地藏菩萨不思议利益之事。汝当谛听吾今说之。观世音言。唯然世尊愿乐欲闻。佛告观世音菩萨。未来现在诸世界中。有天人受天福尽有五衰相现。或有堕于恶道之者。如是天人若男若女。当现相时或见地藏菩萨形像。或闻地藏菩萨名。一瞻一礼。是诸天人转增天福。受大快乐永不堕三恶道报。何况见闻菩萨。以诸香华衣服饮食宝贝璎珞布施供养。所获功德福利无量无边。复次观世音。若未来现在诸世界中六道众生。临命终时得闻地藏菩萨名。一声历耳根者。是诸众生永不历三恶道苦。何况临命终时父母眷属将是命终人舍宅财物宝贝衣服。塑画地藏形像。或使病人未终之时。眼耳见闻知道眷属将舍宅宝贝等。为其自身塑画地藏菩萨形像。是人若是业报合受重病者。承斯功德寻即除愈寿命增益。是人若是业报命尽。应有一切罪障业障合堕恶趣者。承斯功德命终之后。即生人天受胜妙乐。一切罪障悉皆销灭。复次观世音菩萨。若未来世有男子女人。或乳哺时或三岁五岁十岁已下。亡失父母乃及亡失兄弟姊妹。是人年既长大。思忆父母及诸眷属。不知落在何趣。生何世界生何天中。是人若能塑画地藏菩萨形像。乃至闻名一瞻一礼。一日至七日莫退初心。闻名见形瞻礼供养。是人眷属假因业故堕恶趣者。计当劫数。承斯男女兄弟姊妹。塑画地藏形像瞻礼功德。寻即解脱生人天中受胜妙乐者。即承斯功德转增圣因。受无量乐。是人更能三七日中一心瞻礼地藏形像。念其名字满于万遍。当得菩萨现无边身。具告是人眷属生界。或于梦中。菩萨现大神力亲领是人。于诸世界见诸眷属。更能每日念菩萨名千遍。至于千日。是人当得菩萨遣所在土地鬼神终身卫护。现世衣食丰溢无诸疾苦。乃至横事不入其门。何况及身。是人毕竟得菩萨摩顶授记。复次观世音菩萨。若未来世有善男子善女人。欲发广大慈心救度一切众生者。欲修无上菩提者。欲出离三界者。是诸人等见地藏形像及闻名者。至心归依或以香华衣服宝贝饮食供养瞻礼。是善男女等所愿速成永无障碍。复次观世音。若未来世有善男子善女人。欲求现在未来百千万亿等愿。百千万亿等事。但当归依瞻礼供养赞叹地藏菩萨形像。如是所愿所求悉皆成就。复愿地藏菩萨具大慈悲。永拥护我。是人于睡梦中即得菩萨摩顶授记。复次观世音菩萨。若未来世善男子善女人。于大乘经典深生珍重。发不思议心欲读欲诵。纵遇明师教视令熟。旋得旋忘动经年月不能读诵。是善男子等有宿业障未得销除故。于大乘经典无读诵性。如是之人闻地藏菩萨名。见地藏菩萨像。具以本心恭敬陈白更以香华衣服饮食一切玩具供养菩萨。以净水一盏经一日一夜。安菩萨前。然后合掌请服。回首向南临入口时。至心郑重服水既毕。慎五辛酒肉邪淫妄语及诸杀害。一七日或三七日。是善男子善女人。于睡梦中具见地藏菩萨现无边身。于是人处授灌顶水。其人梦觉即获聪明。应是经典一历耳根。即当永记更不忘失一句一偈。复次观世音菩萨。若未来世有诸人等。衣食不足求者乖愿。或多病疾或多凶衰。家宅不安眷属分散。或诸横事多来忤身。睡梦之间多有惊怖。如是人等闻地藏名见地藏形。至心恭敬念满万遍。是诸不如意事渐渐消灭。即得安乐衣食丰溢。乃至于睡梦中悉皆安乐。复次观世音菩萨。若未来世有善男子善女人。或因治生或因公私。或因生死或因急事。入山林中过渡河海。乃及大水或经险道。是人先当念地藏菩萨名万遍。所过土地鬼神卫护。行住坐卧永保安乐。乃至逢于虎狼师子。一切毒害不能损之。佛告观世音菩萨。是地藏菩萨于阎浮提有大因缘。若说于诸众生见闻利益等事。百千劫中说不能尽。是故观世音。汝以神力流布是经。令娑婆世界众生。百千万劫永受安乐。尔时世尊而说偈言

  吾观地藏威神力　　恒河沙劫说难尽
  见闻瞻礼一念间　　利益人天无量事
  若男若女若龙神　　报尽应当堕恶道
  至心归依大士身　　寿命转增除罪障
  少失父母恩爱者　　未知魂神在何趣
  兄弟姊妹及诸亲　　生长以来皆不识
  或塑或画大士身　　悲恋瞻礼不暂舍
  三七日中念其名　　菩萨当现无边体
  示其眷属所生界　　纵堕恶趣寻出离
  若能不退是初心　　即获摩顶受圣记
  欲修无上菩提者　　乃至出离三界苦
  是人既发大悲心　　先当瞻礼大士像
  一切诸愿速成就　　永无业障能遮止
  有人发心念经典　　欲度群迷超彼岸
  虽立是愿不思议　　旋读旋忘多废失
  斯人有业障惑故　　于大乘经不能记
  供养地藏以香华　　衣服饮食诸玩具
  以净水安大士前　　一日一夜求服之
  发殷重心慎五辛　　酒肉邪淫及妄语
  三七日内勿杀害　　至心思念大士名
  即于梦中见无边　　觉来便得利根耳
  应是经教历耳闻　　千万生中永不忘
  以是大士不思议　　能使斯人获此慧
  贫穷众生及疾病　　家宅凶衰眷属离
  睡梦之中悉不安　　求者乖违无称遂
  至心瞻礼地藏像　　一切恶事皆消灭
  至于梦中尽得安　　衣食丰饶神鬼护
  欲入山林及渡海　　毒恶禽兽及恶人
  恶神恶鬼并恶风　　一切诸难诸苦恼
  但当瞻礼及供养　　地藏菩萨大士像
  如是山林大海中　　应是诸恶皆消灭
  观音至心听吾说　　地藏无尽不思议
  百千万劫说不周　　广宣大士如是力
  地藏名字人若闻　　乃至见像瞻礼者
  香华衣服饮食奉　　供养百千受妙乐
  若能以此回法界　　毕竟成佛超生死
  是故观音汝当知　　普告恒沙诸国土

    嘱累人天品第十三

尔时世尊举金色臂。又摩地藏菩萨摩诃萨顶而作是言。地藏地藏。汝之神力不可思议。汝之慈悲不可思议。汝之智慧不可思议。汝之辩才不可思议。正使十方诸佛赞叹宣说汝之不思议事。千万劫中不能得尽。地藏地藏。记吾今日在忉利天中。于百千万亿不可说不可说一切诸佛菩萨天龙八部大会之中。再以人天诸众生等未出三界在火宅中者。付嘱于汝。无令是诸众生堕恶趣中一日一夜。何况更落五无间及阿鼻地狱。动经千万亿劫无有出期。地藏。是南阎浮提众生。志性无定习恶者多。纵发善心须臾即退。若遇恶缘念念增长。以是之故吾分是形百千亿化度。随其根性而度脱之。地藏吾今殷勤以天人众付嘱于汝。未来之世若有天人及善男子善女人。于佛法中种少善根。一毛一尘一沙一渧。汝以道力拥护是人。渐修无上勿令退失。复次地藏。未来世中若天若人随业报应落在恶趣。临堕趣中或至门首。是诸众生若能念得一佛名一菩萨名一句一偈大乘经典。是诸众生汝以神力方便救拔。于是人所现无边身为碎地狱。遣令生天受胜妙乐。尔时世尊而说偈言

  现在未来天人众　　吾今殷勤付嘱汝
  以大神通方便度　　勿令堕在诸恶趣

尔时地藏菩萨摩诃萨。胡跪合掌白佛言。世尊。唯愿世尊不以为虑。未来世中若有善男子善女人。于佛法中一念恭敬。我亦百千方便度脱是人。于生死中速得解脱。何况闻诸善事念念修行。自然于无上道永不退转。说是语时。会中有一菩萨名虚空藏。白佛言。世尊。我自至忉利。闻于如来赞叹地藏菩萨威神势力不可思议。未来世中若有善男子善女人。乃及一切天龙闻此经典及地藏名字。或瞻礼形像得几种福利。唯愿世尊为未来现在一切众等略而说之。佛告虚空藏菩萨。谛听谛听吾当为汝分别说之。若未来世有善男子善女人。见地藏形像及闻此经。乃至读诵香华饮食衣服珍宝布施供养赞叹瞻礼。得二十八种利益。一者天龙护念。二者善果日增。三者集圣上因。四者菩提不退。五者衣食丰足。六者疾疫不临。七者离水火灾。八者无盗贼厄。九者人见钦敬。十者神鬼助持。十一者女转男身。十二者为王臣女。十三者端正相好。十四者多生天上。十五者或为帝王。十六者宿智命通。十七者有求皆从。十八者眷属欢乐。十九者诸横销灭。二十者业道永除。二十一者去处尽通。二十二者夜梦安乐。二十三者先亡离苦。二十四者宿福受生。二十五者诸圣赞叹。二十六者聪明利根。二十七者饶慈愍心。二十八者毕竟成佛。复次虚空藏菩萨。若现在未来天龙鬼神闻地藏名礼地藏形。或闻地藏本愿事行。赞叹瞻礼得七种利益。一者速超圣地。二者恶业销灭。三者诸佛护临。四者菩提不退。五者增长本力。六者宿命皆通。七者毕竟成佛。尔时十方一切诸来。不可说不可说诸佛如来。及大菩萨天龙八部。闻释迦牟尼佛称扬赞叹地藏菩萨大威神力不可思议。叹未曾有。是时忉利天雨无量香华天衣珠璎。供养释迦牟尼佛及地藏菩萨已。一切众会俱复瞻礼合掌而退

地藏菩萨本愿经卷下


奋迅王问经

    No. 421 [No. 420]

    奋迅王问经翻译之记

一初菩萨。功行普修。依德立名。字号平等。随所显发。称谓不同。说法问论。多依自字。故奋迅王问奋迅法。如来为说四种奋迅。其有人能具此奋迅。则于一切皆能奋迅。魏尚书令仪同高公。今欲以此四种奋迅。于一切处普奋迅故。置能译人。在宅上面。出此四种奋迅法门。沙门昙林。瞿昙流支。兴和四年岁次壬戌。月建在申。朔次乙丑。甲午之日。启夹创笔。凡有一万八千三百四十一字

奋迅王问经卷上

        元魏婆罗门瞿昙般若流支译

如是我闻。一时婆伽婆住舍婆提城只陀树林给孤独园。与大比丘众二万人俱。菩萨摩诃萨一万人。一生当得阿耨多罗三藐三菩提。弥勒菩萨。德大势菩萨。师子意菩萨。师子幢菩萨。大幢菩萨等。而为上首。尔时众中有一菩萨摩诃萨。名奋迅王。在大会坐。尔时世尊。无量百千眷属围绕。恭敬供养而为说法。谓大乘者之所修行。尔时奋迅王菩萨摩诃萨。从坐而起。整服右肩右膝着地。合掌向佛头面礼足。白言世尊。我于今者。欲以少法问于如来应正遍知。唯愿世尊。为我解说。佛告奋迅王菩萨摩诃萨言。奋迅王。恣汝所问。我为汝说。奋迅王。汝若问者随汝心意。彼彼所问。如是如是。我为汝说令汝心喜。奋迅王菩萨言。如是世尊。愿乐欲闻。奋迅王菩萨。既蒙听许心大欢喜。白佛言。世尊。云何诸菩萨摩诃萨大乘奋迅。复为众生说此大乘。以彼奋迅破一切魔一切慢人一切诤人一切分别喜乐见人。令住大乘大愿满足戒行成就。得阿耨多罗三藐三菩提

佛告奋迅王菩萨摩诃萨言。善哉善哉。奋迅王。善哉奋迅王。汝今善能问于如来如是之义。当善忆念。汝奋迅王。谛听谛听善思念之。我今为汝分别解说。如菩萨如大乘奋迅。复为众生说此大乘。以彼奋迅破一切魔一切慢人一切分别喜乐见人。令住大乘大愿满足戒行成就。得阿耨多罗三藐三菩提

奋迅王菩萨言。如是世尊。愿乐欲闻。佛告奋迅王菩萨摩诃萨言。奋迅王。有四种奋迅。何等为四。一者戒奋迅。二者通奋迅。三者智奋迅。四者慧奋迅。奋迅王。此是菩萨四种奋迅。奋迅王。何者戒奋迅。此菩萨戒具足。谓不缺戒。不穿戒。不杂戒。不分别戒。不悔戒。不毁戒。不热戒。善护戒。智赞戒。顺道戒。成就他法戒。护一切法戒。喜爱戒。不依一切有道生戒。安住奢摩他戒。随顺毗婆舍那戒。深法解脱戒。不退通戒。空无相无愿戒。清净寂静戒。说佛法僧戒。不舍一切众生戒。慈护心戒。大悲根戒。信清净戒。不分别威仪戒。头陀功德戒。福德田戒。毕竟净戒。不断如来种戒。护法种戒。见圣僧戒。善住菩提心戒。六波罗蜜住戒。修行念处正勤神足根力菩提八圣道戒。生一切菩提分法戒

奋迅王。菩萨如是戒具足已大愿成就。彼云何愿戒具。菩萨劫尽烧时。火满三千大千世界。若如是愿此大寂灭火即寂灭。若欲令水满此三千大千世界。水即充满。欲令华满即随意满。欲令宝满。即时满中一切珍宝。又若欲令恒河沙等诸世界中须弥山王彼一切山为一山者。即为一山。奋迅王。菩萨如是戒具足已。若欲令彼恒河沙等诸世界中所有大海彼一切海为一海者。即为一海。彼住戒力随心所愿皆悉成就。一切所念无不随意。奋迅王。住戒菩萨如是奋迅。若人住戒随愿成就。所谓阿耨多罗三藐三菩提

奋迅王。过去久远过阿僧祇阿僧祇劫。无量大劫不可思议。彼时有佛。号曰光明无垢光王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。奋迅王。彼时光明无垢光王如来法中。有一菩萨名金刚齐。安住戒力善清净戒。彼金刚齐阿兰若处经行精进。乐修圣法欲满佛法。彼金刚齐如是观察。若不分别一切法者乃得名戒。若不喜乐一切物者乃得名戒。若能寂灭一切烦恼乃得名戒。若身镜像平等知者乃得名戒。若于语言响声平等乃得名戒。若观心法如幻无异乃得名戒。若善不善二法不二乃得名戒。若不净观除灭贪欲乃得名戒。若慈悲观除灭嗔恚乃得名戒。若以智慧灭除愚痴乃得名戒。若不分别贪欲嗔痴乃得名戒。若分别见一切诸法不分别者乃得名戒。若非我见非众生见。亦非命见富伽罗见。亦非常见乃得名戒。若一切法不和合行乃得名戒。若于一切心不惊怖乃得名戒。若于三界心不依止乃得名戒。若信诸法一切不生乃得名戒。若心信解不生法忍乃得名戒。若不悕望财利供养乃得名戒。若不畏空乃得名戒。若修无相乃得名戒。若离愿求乃得名戒。若于戒聚心不取戒乃得名戒。若不自戒持聚自高陵蔑他人乃得名戒。若于诸入不赞叹者乃得名戒。若于境界不行不着乃得名戒。若于五阴法阴平等乃得名戒。若于界中法界平等乃得名戒。若不诤讼乃得名戒。若不休息一切善法乃得名戒。若毕竟知一切诸法皆悉寂灭。知寂灭已身则正行乃得名戒。奋迅王。尔时金刚齐菩萨。以如是法住戒成就。修行圣法勤行精进不离正观。魔子名遮。见彼比丘以如是法住戒成就。修行圣法勤行精进。不离正观如是经行。将诸军众八万四千。一切着钾自隐其身。到比丘所而求其便。经一千年随比丘行。彼魔如是于一千年。而彼比丘无有一念乱心可得。彼魔如是伺其心乱。若得乱心则与障碍怖畏恼乱。尔时遮魔并其军众。经一千年求便不得。复自现身。皆执刀槊种种器仗。在彼比丘面前。怖吓欲令惊畏

彼金刚齐菩萨比丘。见魔军众手执刀槊种种器仗怖吓之已。即作誓言。我今真实于此法中。正观修行清净戒聚。此事若实。诸魔眷属手执刀槊种种器仗。一切变为忧钵罗华。钵头摩华。拘物头华。分陀利华。瞻婆迦华。苏摩那华。婆师迦华。种种华鬘。此天魔身一切军众。如我形色正住威仪。奋迅王。金刚齐菩萨比丘。作是誓已。一切魔军所执刀槊种种器仗。即时变成种种妙色无量种色杂色华鬘。有善妙香。见闻心爱可喜殊特。一切魔身色相形服如彼比丘。一切皆如出家举动。身着袈裟剃除须发自他皆见。奋迅王。尔时遮魔。见彼比丘胜神通已。生希有心。并诸军众礼彼比丘金刚齐足。问言。大仙汝得何法住神通力能如是耶。奋迅王。时金刚齐菩萨比丘。答遮魔言。大仙当知。如是法者非有得住。以一切法不可得故。大仙当知。身口意等皆无依止。此无依止是我所住。以一切法无依止住。大仙当知。如是住者非有相住非无相住。如是名住。如是住者非有法住无住无处。故名为住

尔时遮魔语金刚齐菩萨比丘。作如是言。我一千年观汝心行。常求汝便而不能得。时金刚齐菩萨比丘语言。大仙。假使汝于恒河沙劫。求我心行亦不能得。何以故。心不在内亦不在外。不在二处不在中间。又复大仙。幻人心行汝得不耶。魔言。比丘不可得也。彼幻人者无心无思。何处可得。菩萨比丘答言。大仙。如来常说一切诸法皆如幻相。无心可得。无思可得。魔言。比丘若汝无心无思可得汝云何行。若去若来。又复云何有所言说。菩萨比丘答言。大仙。如幻人行。若来若去有所言说。我如是行。如是去来。如是言说

魔言。比丘若如是者汝勤精进。安住持戒修行圣法。如是发行何所悕求。比丘答言。无发无行无处悕求。魔言。云何无发无行无处悕求。比丘答言。如是处者。无有人去。无有人来。无人当去。大仙当知。无发无行名为无愿。又复大仙。若汝问言。汝勤精进安住持戒修行圣法。如是发行何所悕求。如是问者。汝今当听我此求者。非色生求非色灭求非色处求。如是非受非想非行。非识生求非识灭求非识处求。至一切法亦非生求。亦非灭求亦非处求。大仙当知。若彼正处非色所摄。如是非受非想非行。非识所摄是我求处。我求彼处。若不可见是我求处。若彼正处非色所摄。如是非受非想非行。非识所摄。如是正处是我求处。而我不见彼我求处。大仙当知。如圣人求我如是求

魔言。比丘彼圣人处云何而求。菩萨比丘答言。大仙。若凡夫法若佛法。此一切法平等不二。若学法若无学法若佛法。此一切法平等不二。若缘觉法若佛法。此一切法平等不二。若过去法若未来法若现在法。此一切法平等不二。不生平等是故平等。不出平等是故平等。不灭平等是故平等。若人不舍如是平等彼修平等。是故能为众生说法。大仙当知。如是正处我如是求。大仙当知。如是正处非欲界处。非色界处。非无色界处。若人如是住平等者。如法不动。非行不行。非他令行。大仙当知。此名正处。如彼发行一切诸法如是发行。如法界发行。一切诸法如是发行。如实际发行。一切诸法如是发行。若如是求。彼人如是不见行处。心不喜乐故名正处

尔时遮魔语金刚齐菩萨比丘。作如是言。此正修行为何所得。比丘答言。我此正修得无所得。无无所得平等满足。又汝问言。得何法者。若有所得非正修行。以离慢故名正修行。正修行者无所得法。言正修者则无所修

尔时遮魔问金刚齐菩萨比丘。作如是言。此戒具足为何所求。比丘答言。我住此戒。为求阿耨多罗三藐三菩提觉。得不灭法得不生法。魔言。菩提为何所觉。比丘答言。色平等觉是菩提觉。受想行识悉平等觉。一切诸法悉平等觉。是菩提觉。魔言。比丘彼菩提者于何处求。答言。大仙言菩提者身见中求。魔又问言。云何而求。比丘答言。菩提非起身见非起。如求身见菩提亦尔。我如是求

尔时遮魔问金刚齐菩萨比丘。作如是言。汝师是谁。何人教汝如是辩才。答言。大仙不嗔自身得菩提者。彼是我师。若不住染不住净者。彼是我师。若何等人。识不住常不住无常。彼是我师。若有人来从其闻法。谓不住法不分别法。如是闻已得度痴海。彼是我师。若智能知一切诸法非次第知。彼是我师。若能遍知一切言语。非次第知而不分别。彼是我师。若一切法不生不出转圣法轮。彼是我师。若非彼住亦非此住非中间住。彼是我师。若说一切诸法不生而自生者。彼是我师。若说一切诸法不灭而自灭者。彼是我师。我于彼师得如是辩

魔言。比丘云何如来转于法轮。比丘答言。非是色转。非色真如。非是色法。非是色空。非色无相。非色无愿。非色寂静。非是色离。非色不生。非色本性。非色自体。非自体转。非是不转。如是次第受想行识非转不转。识如识法。识空无相无愿寂静。识离不生本性自体非转不转。如来法轮如是而转。一切法轮是则轮转。彼法轮转若或不转。无量法界报际不舍。彼法轮转若人能知。于如是人彼轮则转

尔时遮魔并诸军众。与金刚齐菩萨比丘。以为弟子。作如是言。今我等众归依仁者。彼比丘言。勿归依我。汝当归依光明无垢光王如来。此所说法是彼佛法。彼言。去来当共相随至如来所。时金刚齐菩萨比丘。即与遮魔八万四千诸魔众俱。往诣世尊光明无垢光王佛所。到佛所已头面礼足。合掌向佛住在一面。时彼如来为彼魔众说此住戒次第乃至修行圣法。如法而说。如是诸魔。一切不退阿耨多罗三藐三菩提

奋迅王。汝意云何。彼金刚齐菩萨比丘。岂异人乎。莫作异观。何以故。汝身即是彼金刚齐菩萨比丘。持地菩萨是彼遮魔。奋迅王。此是菩萨戒奋迅。菩萨得是戒奋迅已。不可思议胜愿亦现。成熟无量众生菩提。破坏魔怨。速得阿耨多罗三藐三菩提觉

奋迅王。何者菩萨通奋迅。云何名为通奋迅耶。奋迅王。彼有五种。何等为五。一者天眼。二者天耳。三者知他心。四者念宿命。五者神通。奋迅王。何者菩萨天眼通奋迅。若有眼根壁所不障。树木山林须弥轮山。世界中山不能作障。彼无障眼。能见十方无量无数诸佛世界。如一世界。于有物处视若虚空。彼此世界皆悉不障。平等一见彼佛世界。诸佛世尊诸声闻众之所围绕。一切皆见一切佛。一佛信解一切法界。不坏修故。若见一佛一切佛皆悉清净。见一切佛一佛清净。如是若以见佛清净自入清净。彼若以是自入清净。则一切法皆见清净。自见清净法见清净。二相不取。若彼世尊诸声闻见。见佛清净见诸声闻则不异见。彼见声闻即是见佛。彼见佛者即见声闻。若彼无量无边世界所有众生。众生所摄。若地狱身。若畜生身。若饿鬼身。若人天身。若阿修罗。若欲界行。除无色界。彼一切见若退若生若减若增。如是众生业报皆知。知见众生及知业报。而实不生众生之想。以知众生皆无我故。虽知业报无业报想。入一切法无业报故。彼人天眼见一切色。而于色相不取应知。以一切色皆无体故。一切色相知不实故。以一切色本际空故。彼人天眼。以何因缘能如是见。以智力故能如是见。如彼所见亦如是见。随自心欲一切不见。若心悕望见一切色随心即见。非有少色眼所不见。彼人则于无量百千诸众生中。能修禅定解脱三昧三摩跋提。而彼众生眼所不见。何以故。如是菩萨以知真如法无我故。彼人悕望。若色界天。微细之身。善妙之身。光明之身。不相似身。现于彼天示菩萨身。能令彼天见菩萨身。如是菩萨见彼天身。若欲令天见菩萨身。及自见身即能令见。若欲令天自见其身不见菩萨。彼即自见不见菩萨。若欲令天见菩萨身不见自身。即见菩萨不见自身。奋迅王。菩萨成就如是天眼

奋迅王。何者菩萨天耳通奋迅。彼菩萨成就天耳。乃至无量无边世界所有诸声。天声龙声夜叉声乾闼婆声阿修罗声迦楼罗声紧那罗声摩睺罗迦人非人声。如是等声一切皆闻。虽闻彼声不取自相及众生相。不取声相而知一切音声之相。虽闻音声于声声处信解不实。前声后声皆悉无声。如是通达。彼声无处。无处信解。耳根识界则无障碍。闻彼声已知彼声义。何者声义。谓一切声不可分别不可说者。则是声义。寂静义者一切声义。彼菩萨者顺行此义。闻一切声不生依止。以一切法悉不生故。若于十方无数世界。于今现在现命现住诸佛世尊。彼一切佛有所说法。而彼菩萨天耳悉闻无障无碍。不取声处而闻一切说法音声。闻已受持无所忘失。云何不忘。若彼菩萨得一句者可得有忘。以彼菩萨不得一句。是故无忘。彼菩萨闻有漏法闻无漏法。若闻常法闻无常法。闻世间法出世间法。善不善法增法减法若声闻法若缘觉法若大乘法。彼一切法一体一味。如是顺行。谓闻法已得离欲味。闻一切法一切境界不取不着。又复闻法一切相中不住不着。一切法中随顺而行。于非法中不随顺行。何者为法。何者非法法名离欲。法名无相。法名无为。法名无处。不可譬喻。无尘无得不生不出。此名为法。若如是法忆念分别。心想观察戏论取舍。此名非法

奋迅王。彼菩萨唯取于义而不取语。不为取语听法闻法。为取义故是以听法。云何取义。若见空义不取不着。若无相义不取不着。若无愿义不取不着。是名取义。彼若取义而听于法。于所取义不生分别。于不分别亦不分别。如是菩萨于诸佛所如是听法。又奋迅王。彼菩萨随顺了义修多罗义。不随不了修多罗义。彼了义者。其义云何。以彼一切修多罗义皆是了义。修多罗义皆随顺说。无异义故。一切了义修多罗义不可说故。如是了义修多罗义。彼随顺行。若于了义修多罗义。不随顺者则非了义。以何因缘。非了义耶。若不了义修多罗义。于彼了义修多罗义不相随顺。与彼了义则不相应。以何因缘而不相应。不随顺故离彼法行。所随顺者。谓声随顺。如是了义修多罗者非声随顺。何以故。以彼了义不可说故彼无处着。如是菩萨善知一切不了义法皆如了义。奋迅王。此义如是随顺了义修多罗义。如是随顺一切了义修多罗义

又奋迅王。彼菩萨从佛世尊听闻法已。唯取于智而不取识。何以故。以识知故。以如幻故。不可取故。无自体故。以无色故。不可见故。无障碍故。若如是知则是智知。是故菩萨唯取于智而不取识。识为他知如是知识。于识于智皆不贪着。以识真如说智真如。奋迅王。若菩萨唯取于智不取识者。不为众生说于识法。此天耳通奋迅。得已得此智界

又奋迅王。彼菩萨富伽罗语相应法说。唯取于法而不取人。何以故。奋迅王。若实有人。众生毕竟于佛法中不可清净不可解脱。奋迅王。若如是者一切诸法毕竟无人。佛依世间是故说人。而实诸法一切无人。如是菩萨唯取于法而不取人

奋迅王。法名法界。此法界者名不生界。奋迅王。不生界者名不出界。奋迅王。所言名者以不可说。是故名名。何以故。依彼彼名知彼彼法。彼彼法中名不可得。若不可得随人情故强说言语。一切言语皆随俗说。若我知语彼是佛语。若起意相非是佛语。佛语无意。以无语故名为佛语。若入佛语彼入非语。若入非语彼入佛语。若欲入语应入佛语。欲入佛语。取说人语取说法语。若如是取不入佛语。何处不二亦无不二。彼是佛语。何处有声及以无声。彼非佛语。若不可说非不可说。彼是佛语。如是奋迅王。若菩萨入佛语者。彼则名为得天耳通。一切音声随顺证法得佛菩提。奋迅王。此是菩萨第二通智所谓天耳

又奋迅王。菩萨复得他心通智。于他众生他富伽罗知心知思。彼人如是入大众中而为说法。初如是观众会之心。何者众生有何深心。何所修行。何因何相。既观察已如应说法。自心净故能入一切众会净心。奋迅王。譬如镜轮以清净故现如是色。若青黄等若形若相。彼相似见不增不减。镜轮净故。而彼镜轮无所分别而示众像。奋迅王。菩萨如是自心清净。白法界轮如是相似。众生心行种种异生彼一切知。而彼菩萨心亦不坏。彼众会中若人欲行。知彼人心。知离欲心。何以故。以心本性无欲染故。彼众会中有嗔痴行。知彼人心。知离痴心。何以故。以心本性无嗔痴故。若复有人信声闻乘。彼人心行菩萨能知法界不下。若复有人信缘觉乘。彼人心行菩萨能知法界不减。彼众会中若复有人心行大乘。彼人心行菩萨能知法界不增。知彼众生心行界已。而为说法。然不分别心之本性。如应说法令住诸乘于一切界不破坏中。一切众生若干种行皆悉遍知。彼菩萨心自心观察。非心相续亦非断灭。然彼菩萨以相续心。而能遍知一切众生心亦如是。若界心界如知彼界。法界亦尔不一不二。如是奋迅王。菩萨得是他心通智。以得通故则名通人。一切天人之所识知

又奋迅王。菩萨复得宿命通智。以三昧根。能知过去恒河沙劫自他宿命。忆念不忘。如是知已然后说法。如是忆念。我于某处如是名字。曾如是生。如是命量。如是受乐。如是受苦。自心能知他众生心。知此众生前因善根。知此众生善根因力。知此众生善根缘力。知此众生声闻乘因。知此众生缘觉乘因。知此众生有大乘因。知彼众生前因缘已。然后乃为如是众生如应说法。彼菩萨自知宿命。知宿命已后复能知本修具足。自知过去于几佛所种诸善根。若彼善根。前已愿取阿耨多罗三藐三菩提。如是忆念诸善根已。复更发愿。彼菩萨念本宿命。而于过去一切诸法。心不分别不着不取。于前后行心不分别。于后前行心不分别。于一切法不分别处。若去若来。菩萨忆念过去世已。然于过去不取不着。虽知未来。然于未来亦不取着。知一切法无前无后亦无中间。故不分别不取不着。彼菩萨如是忆念众生宿命。前后色离菩萨能知。如是前后受想行识一切皆离。菩萨能知。乃至五阴前后中间。一切诸法空无自体。菩萨能知。奋迅王。彼菩萨忆宿命已。过去所修一切善根皆悉增长。过去所作一切业行皆悉尽灭。何以故。业不朽故是故能知

菩萨如是成就彼知。于一切行信解如梦。譬如梦中见生见死见苦见乐。菩萨信解一切诸行。亦复如是。既信解已于彼生死不受苦恼。复于众生而生悲心。知一切法不起生相。又彼菩萨有如是心。我于过去世间生死。多千劫行知皆无实不贪不着。亦如是知一切众生世间生死虚妄不实。不贪不着。若其不实彼不实处。大大不生。大大不实

奋迅王。彼菩萨忆宿命已。实见诸行皆悉无常。何以故。彼菩萨忆念过去转轮王乐。乃是无常败坏之法。忆念过去帝释王乐。彼是无常败坏之法。忆念过去梵天王乐。彼是无常败坏之法。思惟忆念诸佛世尊世界庄严。声闻之人功德庄严。菩萨之人功德庄严。又复忆念彼佛世尊色身具足。如来转法轮具足。彼忆念已则不贪着。一切有为一切所摄皆悉放舍。何以故。彼菩萨有如是心。若彼如是佛世界胜。佛色身胜。彼亦无常是尽灭法。我之所摄亦复如是皆悉无常。复作是念。诸行如是一切无常。而诸众生生于常想。菩萨如是于众生中起大悲心。于一切法皆悉舍离。如是奋迅王。此是菩萨第四通智。彼菩萨成就此智。则知一切诸法无常。心正思惟摄取有生。成就众生。虽摄有生而不贪着。菩萨离有而取诸有成熟众生。又奋迅王。何者菩萨神通奋迅。奋迅王。彼菩萨心自在故。得圣神足。谓欲精进寂静信解。彼菩萨现得神通是有为行。彼人悕望。于一念间悉能遍到恒河沙等诸佛世界。到彼处已。彼处众生见菩萨身。而菩萨身此处不动。彼处众生见闻说法。然于此处说法不断。奋迅王。此是菩萨神通奋迅。以此神通调御众生。若彼众生或天或人。生常想者示劫尽烧。彼见三千大千世界皆悉烧燃。而彼世界。实无烧坏。若慢众生手中金刚示其夜叉。示金刚炎令大怖畏。彼憍慢者破坏慢心即时向礼。若有众生信转轮王。彼即为现轮王形服而为说法。若有众生信帝释王彼即为现帝释王色而为说法。若有众生信于梵王。彼即为现梵王形色而为说法。若有众生信于魔王。彼即为现魔王形色而为说法。若有众生信如来者。彼即为现如来形色而为说法。若有众生应见菩萨虚空中住加趺而坐身出光明。即住空中身放光明而为说法。若有众生于大胜事生信解者。即示三千大千世界幡盖庄严幡鬘庄严幢幡庄严。铃鬘具足香薰等乐百千种乐。示如是已然后说法。若有众生应见三千大千世界合为一海。忧钵罗华。拘物头华。分陀利华。遍覆水上。于莲华上有师子座。坐彼座上而说法者。彼即示现而为说法。若有众生应见菩萨住须弥顶梵声说者。彼即示现而为说法。若有众生应不见身。唯闻菩萨大声说者。彼即示现而为说法。若有众生应见龙身乾闼婆身。菩萨即现歌相应声而为说法。若有众生应见龙轮雷声电声及雨堕者。彼即示现而为说法。若有众生饥渴疲惓。以天饮食具足与之。令身饱满一切乐足乃为说法。若地狱中一一众生常受大苦。以神通力灭地狱火。与力令入一切毛根。彼得乐已乃为说法。若盲众生离眼众生。以神通力与其天眼。令得眼根乃为说法。若聋众生离于耳根。以神通力令得耳根乃为说法。若有种种病患众生。以神通力为除众病。令离病已乃为说法。若有众生临欲被杀。将欲断命。以神通力设诸方便。偷劫彼人令不得罪。或与财物救赎命已乃为说法。若有众生身分下劣根阙不具。或有小姓怖畏羞惭身心下劣。以神通力令其身分一切具足。暂时示现。令身胜己乃为说法。若有众生藏中聋哑。生来顽钝卧在屎尿。先为疗治。以神通力。示宝庄严宫殿坐已乃为说法。令其心意智慧生已乃为说法。若有未生已生众生。根未淳熟。以神通力令根熟已乃为说法。奋迅王。彼时菩萨。成就如是神通力已。又复更有不可思议神通说法。若有众生信解日月入法律者。以神通力。三千大千诸世界中。所有日月置手掌中。掷过无量无边世界。一切众生所应度者。皆见日月空中而去。然其日月本处不动。又复能以恒河沙等诸佛世界。置一毛头掷着梵世。然后复掷无量无边世界之外。然诸众生不觉不知。若来若去无往返想。又彼菩萨以一口气。能令无量恒河沙等诸佛世界劫烧火灭。又彼菩萨一加趺坐。即时令身到恒河沙诸佛世界。又彼菩萨能以两手覆日覆月。以自光明遍照世界而为说法。奋迅王。彼菩萨于如来前加趺而坐。起心悕望供养如来。即时能以须弥山等种种妙华。散如来身。令一切华映覆如来。唯见半身。若化三千大千世界一切树林。以为灯明。如前供养随意即能。天若雨时能令见火示现己身。一切众生皆悉遍见。随彼众生若干信解。见何等色。或以自身示帝释身。或示梵身。或声闻身。或缘觉身。奋迅王。此是菩萨神通奋迅。所谓天眼见不障碍。清净天耳闻不障碍。一切众生知心行智。阿僧祇劫而能忆念。一切神通悉能示现。名通奋迅

奋迅王。所言通者。云何名通。遍见一切诸佛业通。知他一切众生根通。胜声闻乘所有法律。胜缘觉乘法毗尼通。大乘律通坐退出通。于诸众生淳熟智通。正知出行通。善方便通。布施愿通。戒忍精进禅慧愿通。坏魔摄魔善根成就。是故名通。复次奋迅王。菩萨得通。他所识知色青等。威德名称力姓种族财众围绕。是故名通。复次奋迅王。菩萨得通。天龙夜叉乾闼婆阿修罗伽楼罗紧那罗摩睺罗伽人与非人。帝释天王转轮圣王梵世界主阿罗汉人。正遍知者一切皆知。是故名通。奋迅王。此菩萨通。菩萨以通不退本愿。能示他人一切诸法

奋迅王。何者智奋迅。奋迅王。智奋迅者。所谓阴智界智入智因缘智实谛智。奋迅王。何者阴智。谓知色空。色前际空。色后际空。色中际空。受想行识。皆亦如是。识前际空识后际空。识中际空。此五阴空。谓毕竟空。知此阴空故名阴智

奋迅王。何者界智。地界法界水界法界。火界法界风界法界。何以故。以此四界法界一界。所谓空界复法界界。此非地界。亦非水界。亦非火界。亦非风界。何以故。不异界法界。不二界法界。不生界法界。不染界法界。善净界法界。如法界。如我界。如众生界。如命界。如富伽罗界。如生死界。如涅槃界。彼界欲界。彼界色界。彼界无色界。彼界有为界。彼界无为界。故名涅槃界。如若法界智。如是色界智不异因缘智。故名界智

奋迅王。何者入智。奋迅王。眼之本性不生不出无造作者。奋迅王。如是耳鼻舌身意性。不生不出无造作者。奋迅王。彼眼无主故无见者。彼耳无主故无闻者。彼鼻无主故无嗅者。彼舌无主故无尝者。彼身无主故无觉者。彼意无主故无知者。奋迅王。眼不见色。耳不闻声。鼻不嗅香。舌不尝味。身不觉触。意不知法。何以故。眼者无觉。如草如木如壁如块。如是耳鼻舌身意等一切无觉。如草如木如壁如块

奋迅王。眼者无染亦无不染。如是耳鼻舌身意等。一切无染亦无不染。何以故。以眼本性性离染故。如是耳鼻舌身意等。本性如是性离染故。奋迅王。若一切入如是知已心得离欲。故名入智。若如是知阴界入等。不生不出。如是毕竟入涅槃已。摄取生退阴界入等。如阴界入而亦不舍。此智奋迅。知阴界入若相若体。彼一切舍犹行三界而不染着。亦现生死而无生死。此智奋迅

奋迅王。何者因缘智。无明缘行。无明不念我能生行。行缘于识。行亦不念我能生识。识缘名色。识亦不念我生名色。名色缘六入。名色不念我生六入。六入缘触。六入不念我能生触。触缘于受。触亦不念我能生受。受缘于爱。受亦不念我能生爱。爱缘于取。爱亦不念我能生取。取缘于有。取亦不念我能生有。有缘于生。有亦不念我能生生。生缘老死。生亦不念我生老死。奋迅王。菩萨如是观察因缘则无诸见。无有断见无有常见。彼如是知一切诸法皆因缘生。彼人如是推求因缘。亦不可得。彼于因缘得因缘智。云何得智。因缘不生此二平等。如是平等空无相愿。十二因缘皆悉平等。若以平等如是所觉。一切诸法因缘平等。如是因缘则非因缘。彼因缘中无少法生。故名因缘。若知不生亦是因缘。名因缘智。明与无明此法不二。若知此者名因缘智。行与非行此法不二。若知此者名因缘智。识与非识此法不二。若知此者名因缘智。名色非名色此法不二。若知此者名因缘智。六入非六入此法不二。若知此者名因缘智。如六入非六入不二。如是触非触不二。受非受不二。爱非爱不二。取非取不二。有非有不二。生非生不二。老死非老死不二。若知此者名因缘智。如因缘处如彼因缘。皆空无我。如彼因缘不来不去。如彼因缘虚妄不实。如彼因缘无取可取。如是因缘无行无相。若如是知名因缘智

若见因缘不见无明。亦不见行。亦不见识。不见名色。不见六入。亦不见触。亦不见受。亦不见爱。亦不见取。亦不见有。亦不见生。不见老死。若如是见彼见因缘。若见因缘彼则见法。见何者法。见离欲法。离何等欲。一切法中种种见欲。离如是欲故名离欲。彼所见法不增不减。如是所见则是真如不得不染。如是所见则是法界不坏不成。如是所见实际不穿。如是所见虽见不见。如是所见非肉眼见。非天眼见。非慧眼见。何以故。肉眼不觉。以其不觉是故不见。天眼有为。以有为故不见无为。是故不见。慧眼不见以不分别。不分别故亦不能见。奋迅王。菩萨如是见一切法则见如来。非是色见。非受非想非行非识非相等见。非法界见。非戒定慧。非解脱见。亦非解脱知见法见。非过去见。非未来见。非现在见。若如是见则见如来

奋迅王问经卷上奋迅王问经卷下

        元魏婆罗门瞿昙般若流支译

尔时奋迅王菩萨白佛言。世尊。若有法者可有见法。若有见法可见如来。佛言有。何以故。奋迅王。色相不生本性不生。如是见色则见如来。如是受想行识之相。皆悉不生本性不生。如是见识则见如来。戒有为相而是无为。如是见戒则见如来。三昧平等则清净见。如是我于燃灯佛所得清净见。我于彼佛得见因缘。以见因缘即得见法。以见法故即见如来。奋迅王菩萨白佛言。世尊。燃灯佛来。所有如来。彼云何见。佛言。奋迅王。皆以色相分别而见。非见法身。奋迅王。我为汝说。汝今应知。我从初发菩提心来更不见佛。惟除燃灯。何以故。非见色相净见如来。奋迅王。菩萨如是欲见佛者。应如我见燃灯如来。以一法故。云何一法。如我之身。彼燃灯身亦复如是。如燃灯身我身亦尔。一身一法证法不二不分别证。是因缘智。若见因缘彼则见法。以见法故则见如来。若于一切有心生处。皆悉证灭不入涅槃。不得生死方便智说。此是奋迅

彼实谛智何者是耶。声闻之人何者实时则触解脱。如是实时菩萨亦得不触解脱。此是奋迅。缘觉之人何者实时则触解脱。如是实时菩萨亦得不触解脱。此是奋迅。实谛智者。所谓知苦非谛非实。何者为智。谓不实智。以是无穷颠倒生故。知苦不生毕竟不生。若如是知苦不生者。此名苦智。云何断集。如彼集法如是断集。云何名集。集故名集平等断集。若未来集于未来断。此法法尔。非少有法若生若断。爱使集有。彼断爱使故名断爱。何者苦灭。若彼苦集性毕竟灭无法失灭。是故名灭。若灭一切攀缘相者。义不相应。有何法生。有何法灭

何者为道。所谓有道。若善不善。若漏无漏。若垢无垢。有为无为。皆不可得。此名为道。平等名道。以一切法皆真实故。寂静名道。以一切热皆悉离故。安隐名道。不离一切善方便故。无漏名道。诸漏尽故。不行名道。分别见人不能行故。易行名道。正修行者所能行故。不舍名道。过去如来所不舍故。离相名道。以能断除一切疑故。若于此道不入二者。此得名道。若解如是四谛之义。名实谛智。若此四谛。声闻乘愿。缘觉乘愿。于二乘愿不生悕望。是乃得名实智奋迅

又奋迅王。智奋迅者。知声闻乘不取不住。知缘觉乘不取不住。是智奋迅。又奋迅王。智奋迅者。若以一心遍知一切众生之心。以一心体遍知一切众生心体若心若智二心不转。是智奋迅

又奋迅王。智奋迅者。知见过去无障无碍。而于过去心亦不转。知见未来无障无碍。未来过去心亦不转。知见现在无障无碍。而于过去未来现在心不戏论。是智奋迅

又奋迅王。智奋迅者。若尽智知而善根行不尽亦知。无生智知知集亦知。是智奋迅

又奋迅王。智奋迅者。若一切法毕竟寂灭。知一切法非他因缘。以智力故不取涅槃。以为成熟诸众生故。此是菩萨智奋迅也

如是奋迅王。菩萨欲以此智奋迅而奋迅者。应当善作智所作业勿作慢业。何者慢业。诸有意行皆是慢业。诸有识行皆是慢业。诸有心行皆是慢业。诸乐善行诸堕见施皆是慢业。诸堕想戒皆是慢业。诸依自他而行忍者。皆是慢业。诸有起心分别精进。皆是慢业。诸分别身般若亦尔。皆是慢业。诸起我慢皆是慢业。我菩萨者此是慢业。我菩萨住此是慢业。我能不断佛种法种众僧种者。此是慢业。我于众生利益行者。此是慢业。未度众生我令得度。未解脱者我令解脱。未安慰者我能安慰。未涅槃者我令涅槃。此是慢业。我行布施我持戒我忍我行精进我禅我慧。此是慢业。我行慈心。我行悲心。我行喜心。我行舍心。此是慢业。我行少欲我行知足。我远离行我不染行。此是慢业。我头陀行空闲正行忆念分别。此是慢业。我行空行。我无相行。我无愿行。此是慢业。我能实语我能真语。我如说行忆念分别。此是慢业。我过魔业过四魔罥。断一切见。我修行忍忆念分别。此心意业。诸如是等此中略说。我菩提觉我转法轮。我令众生得解脱已。然后乃入无余涅槃。忆念分别此心意业。奋迅王。诸有心行起心作说。皆是慢业。奋迅王。何者智业。于如是处非是心意意识转行。彼是智业。菩萨如是常作智业。菩萨云何常作智业。所谓菩萨常作二业。二者所谓成熟众生摄取正法。云何菩萨成熟众生。谓自智知成熟众生。自智知者自住离慢。如是自知随于何处。自离住知非意非识。菩萨如是非意非识。菩萨如是成熟众生

云何菩萨摄取正法。菩萨若于一切诸法皆不摄者。此是菩萨摄取正法。非色摄者是摄正法。如是非受非想非行非识摄者。是摄正法。如是次第非界摄者。是摄正法。非入摄者是摄正法。非善法摄不善法摄。是摄正法。非净不净。非漏无漏有为无为。非世间法出世间法。非如是摄是摄正法。非施相摄是摄正法。非戒非忍精进禅摄是摄正法。何以故。诸攀缘生皆有相生。非法非律非摄正法。何以故。无相无碍如来正觉。彼不可得相攀缘摄。菩萨若知如是业者。是则名智。若以是智作智所作彼非尽智

奋迅王。何者慧奋迅。谓为法分以句分析取四无碍。何等为四。一者义无碍。二者法无碍。三者辞无碍。四者乐说无碍。义无碍者。于一切字惟取于义而不取字。所言义者。正知一切诸法之义。又复义者不可说义。于种种字皆悉不忘知前后声。此名为义。非取语故得随顺义。若能如是语义平等则随顺义。若如是知名义无碍。于一切义皆无碍故。名义无碍

法无碍者。谓法随顺不顺非法。随顺法者不念非法。何以故。彼一切法离名字智。法无碍者。若乘若法不异法说。于法界相不坏法界。何以故。法界一相所谓无相。彼于何者说法言语。闻彼语已响声平等随顺信解。信说法语法界平等。随世俗知而不取着。以是诸义名法无碍

辞无碍者。谓知字语。若龙夜叉。若乾闼婆。若阿修罗。若迦楼罗。若紧那罗摩睺罗伽人非人等。诸字语智。释提桓因。梵世界主。诸字语智。一语多语略语广语。女语男语。若内官语。若过去语。若未来语。若现在语。一切皆知如法字语。若以字语令他众生自意知解。如是而说自语他语。彼此不障亦不取着。何以故。知一切法无字无语。彼如是念何者字语。若说何法。彼如是法字语中无。故不可得亦不可说。又彼字语于法中无。故不可得亦不可说。若说字语字语无声。若当真实有此言辞。善法言辞。恶法言辞。则不可得。应知此辞不在于法。辞无碍者。于一切法皆不障碍诸法不行。何以故。法不行故一切诸法毕竟不行。如是知已而为他说教他令知。名辞无碍。何者名为乐说无碍。若一切语皆悉乐说。于一切声皆悉乐说。于一切名皆悉乐说。云何乐说。于义乐说。于法乐说。于真乐说。于实乐说。若有众生于修多罗。语声信解。为彼众生。修多罗语响声乐说。若于祇夜语声信解。则为祇夜响声乐说。如是伽他。和伽罗那。若忧陀那。若尼陀那。阿波陀那伊帝曰多伽。若阇多迦。若裴不略。阿浮陀达摩语声信解。为裴不略阿浮陀达摩响声乐说。若于前修语声信解。则为前修响声乐说。一切众生诸根乐说。谓于信者信根乐说。于精进者进根乐说。于有念者念根乐说。于有定者定根乐说。于有慧者慧根乐说。如是广说一切诸根。二万一千菩萨乐说。欲行者根八万四千如来所知。彼一切根如来乐说。菩萨随顺相似乐说。彼一切根二万一千。嗔行者根八万四千如来所知。彼一切根如来乐说。菩萨随顺相似乐说。彼一切根二万一千。痴行者根八万四千如来所知。彼一切根如来乐说。菩萨随顺相似乐说。彼一切根二万一千。等行者根八万四千如来所知。彼一切根如来乐说。菩萨随顺相似乐说。彼一切根二万一千如是名为乐说无碍

奋迅王。彼义无碍。法无碍。辞无碍。乐说无碍。如是一切以慧为根。依慧而住。随慧而行。菩萨依慧此等及余种种奋迅。而皆奋迅。又奋迅王慧何为根。慧依何住。慧随何行。奋迅王。闻为慧根。慧依闻住。慧随闻行。又奋迅王。闻何为根。闻依何住。闻随何行。奋迅王。善知识者则是闻根。闻者则依善知识住。闻者随顺善知识行。又奋迅王。彼善知识以何为根。依何而住。随顺何行。奋迅王。彼善知识敬重为根。依敬重住。随敬重行。又奋迅王。如是敬重以何为根。依何而住。随顺何行。奋迅王。如是敬重深心为根。依深心住。随深心行。又奋迅王。如是深心以何为根。依何而住。随顺何行。奋迅王。如是深心不谄为根。依不谄住随不谄行。又奋迅王。如是不谄以何为根。依何而住。随顺何行。奋迅王。如是不谄大悲为根。依大悲住。随大悲行。又奋迅王。如是大悲以何为根。依何而住。随顺何行。奋迅王。一切众生是大悲根即依一切众生而住。随顺一切众生而行。何以故。奋迅王。菩萨为令一切众生得解脱故。发起大悲一切智心

奋迅王。此慧奋迅。菩萨发此一法门己。若于一劫若余残劫。异异法说无法妨碍。欲令众生不见其身而为说法。随意即能。欲令自身一切毛根皆出法声随意即能。如彼众生深心修行。而为说法辩才乐说如彼众生身色示现而为说法。他来斗诤不能破坏。若诸外道五通所知。咒读智论。若鞞陀智种种语论。月日星智。知阴阳智。或有梦相。或时地动。陀毗罗咒种种方术。若乌语等。以咒术力能令鹿等轮聚不行。咒龙夜叉乾闼婆等。或有王鹿余人身相。丰相俭相。星行戏相。一切皆知。复知世间种种伎能。若书若印若数若算一切解知。歌声乐声打钹等声。节脉处等一切皆知。彼婆罗门外道之人。如是一切下劣种姓不得为说。彼菩萨如是一切皆悉现得。有慧菩萨此一切法能示他人。如是一切皆悉善解。如是菩萨善知咒毒。知咒毒处知种种论。如是一切菩萨悉知而不恼乱。一切众生不信此等以为正道

奋迅王。菩萨如是有慧奋迅。千万梵俱坐住语言。迭互相见。色色相示。语语相示。如是菩萨青等诸色。威德光明胜彼诸梵。于彼梵处心不悕望。如是诸梵到菩萨所心生敬重。如是一切天宫殿中示现自在。菩萨于彼不生悕望不生贪乐。生无常想苦无我想。菩萨如是随顺一切众生解脱。奋迅王。此慧奋迅

奋迅王。又彼菩萨以慧奋迅。于魔世界化作宫殿。胜彼魔宫过百千倍。令彼诸魔于胜宫殿悕望贪着。生贪着已心则离慢。既离慢已。令住阿耨多罗三藐三菩提。然后乃为说无常法。奋迅王。彼慧菩萨一切处行。如是应知。以是慧故。若施若受若发愿等一切应知。以是慧故。若自护戒令他持戒。以是持戒愿取菩提。应如是知。以是慧故。若自修忍令他修忍。以是修忍愿取菩提。应如是知。以是慧故。若自精进令他精进。以是精进愿取菩提。应如是知。以是慧故。若自入禅三摩跋提。令他入禅三摩跋提。以是入禅三摩跋提愿取菩提。应如是知。以是慧故。若自摄法。若为他说如闻观察。应如是知。以是慧故。一切行来。一切威仪。一切放舍。应如是知。有慧菩萨以慧力故。则能具得一切善力。有慧菩萨慧自在故得一切财。有慧菩萨慧奋迅故。于一切法得胜奋迅。有慧菩萨执慧力故。得佛相似庄严庄严。有慧菩萨于一切法。皆随顺行而无功用。奋迅王。譬如世人放箭向上。奋其势力自然向下。乃至到地而无功用。奋迅王。有慧菩萨亦复如是。以慧势力能放愿箭而无功用。自然如是堕在一切善法之地。谓道场地示现慧力。复有何力。以慧力故右手能动恒河沙等诸佛世界。以慧力故胜魔眷属。胜魔庄严。乃至获得菩提所摄如来十力。何者为力。他不能胜。所谓天人阿修罗等。一切世间所不能坏。奋迅王。此是戒通智慧奋迅。奋迅王。如是戒通智慧奋迅。若有不种善根众生耳所不闻。奋迅王。若人得闻此法门已心欢喜者。如是之人于此奋迅则能奋迅。何以故。如是奋迅。一切声闻缘觉所无

如奋迅王。菩萨所问世尊说已。奋迅王闻心生欢喜。合掌向佛。一心瞻仰目不暂舍。而作是言。一切众生以如是等四种奋迅而为奋迅。犹如如来应正遍知之所奋迅

尔时世尊。于奋迅王菩萨面前。出种种色微妙色华种种妙香叶相盛华。时彼菩萨即取彼华。用散如来并众会中一切菩萨。如是散已。彼众会中华所著者。一切悉为金相庄严。举众皆见

于虚空中百千诸天。如是见已。一切同声说言。世尊。若有信解如是奋迅。既信解已。能发阿耨多罗三藐三菩提心者。如是之人以佛庄严而自庄严。何以故。以如是等一切奋迅。悉皆随顺一切智心。又复世尊。若有未发菩提心者。何处当得闻如是等不可思议奋迅法门

尔时世尊。赞彼空中诸天子言。善哉善哉。赞善哉已。告奋迅王大菩萨言。奋迅王。我念过去然灯如来。次前复有第七如来。名普无垢净光明王。彼佛如来广说如是奋迅法门。时有菩萨名具境界。以此法门问彼如来。如来既说此法门已。八千众生得此奋迅。又复更得无生法忍。会中众生三万二千。一切皆发阿耨多罗三藐三菩提心。我于尔时得此奋迅。次后复于然灯佛所菩提满足。如是奋迅王。我涅槃已。若有能听此法门者。彼人为取菩提之心。必定速得无生法忍。说此奋迅法门之时。会中众生三万二千诸天及人。一切皆发阿耨多罗三藐三菩提心。彼诸天子雨种种华。百千天乐供养如来。以佛力故。彼乐音中出妙声言。若有众生胜信解心诸根猛利。信解佛法慧行成就。善知识摄宿种善根。大悲怜愍一切众生。尔乃得闻如是法门。闻已信解受持读诵

尔时奋迅王菩萨白佛言。世尊。如来十力。四无所畏。四无碍智。如是十八不共佛法。世尊所有。如是十力。菩萨有不。此四无畏。菩萨有不。如是十八不共之法。菩萨有不。佛言皆有。奋迅王。一切菩萨于八地中。作业成就乃得九地。谓具辩才得不退忍。摄善方便慧波罗蜜。奋迅王。菩萨如是具足十力四无所畏。成就十八不共之法乃得九地

奋迅王。何者菩萨十菩萨力。一者发起一切智心。坚固深心大慈满足。不舍一切诸众生力。二者不求一切财利供养名闻。一切世间希有之事不贪乐力。三者满足大悲之心。一切佛法清净信解法究竟力。四者勤心不生懈怠。增上精进不离忆念威仪行力。五者不动安住三昧远离二边顺因缘法。一切见行皆寂静力。六者菩萨一切分别及不分别。戏论疑网皆悉灭故。满足般若波罗蜜力。七者成熟一切众生。无量生死摄取未足。摄取世间一切善根。世间生死信解如梦。于生死中不疲倦力。八者菩萨观察法性本无众生。本性无命无富伽罗。信解诸法不生不出。能于轮法信解不生。一切轮法不生忍力。九者入空无相无愿观解脱门。于声闻乘。于缘觉乘解脱知见解脱门力。十者菩萨于甚深法而能自知。观察一切众生心行。知无障碍满足之力。奋迅王。此是菩萨十菩萨力

奋迅王。何者菩萨四无所畏。一者菩萨一切闻持。得陀罗尼忆念不忘。不畏大众而为说法。二者菩萨信解诸法则得忍力。不生不出信解法已得无生忍。得法忍已入空无相无愿之法。不畏大众而为说法。三者菩萨于声闻乘观解脱门。辟支佛乘信解知见。信一切入亦信解脱。如诸众生病药所须。如是而知一切众生诸根成熟。亦如是知如应说法。菩萨如是不畏大众而为说法。四者菩萨离大众畏。尔时无心。东西南北若有人来。难问我者我不能答。不畏不能不见畏相。菩萨如是一切众生。若有问难皆悉能答。如彼问难相应说答无所怖畏。能断众生一切疑心。不畏大众而为说法。奋迅王。此是菩萨四无所畏。奋迅王。何者菩萨十八不共菩萨之法。奋迅王。所谓菩萨无有人教。而舍财物以用布施。又复初生即能起心舍财布施。又若魔王作佛身来说如是言。若人布施则入地狱。而彼菩萨不生悭嫉。又复菩萨一切自物皆用舍施。施心转胜如是布施。是菩提因不望果报。皆愿回与一切众生。奋迅王。此是最初菩萨不共法

奋迅王。又复菩萨无有人教。而彼菩萨如来未出无受戒处。于波罗提木叉正行悕学。不舍此不共法。菩萨在家如说护戒。虽不出家复无教者。如波罗提木叉说学。失命因缘不舍戒学。一切戒学随顺菩提。愿断一切众生破戒。奋迅王。此是第二菩萨不共法。奋迅王。又复菩萨一切众生骂詈毁辱割其身分。不生嗔心。若贫穷人。若栴荼罗。若逼迦婆。若工作师种种骂辱。而菩萨心亦不生嗔。于彼众生慈心普覆。有大势力。能加其恶而不作恶。如是菩萨为随顺法。如是众生乃是菩萨佛法因缘。如是菩萨于彼众生。令心寂静为作饶益。着忍辱铠起勇猛力。奋迅王。此是第三菩萨不共法。奋迅王。又复菩萨设多衰恼。而勤精进头陀不舍不生劣心。见声闻乘入于涅槃。见生死苦而心不求声闻涅槃。见缘觉乘入于涅槃。见生死苦心亦不求缘觉涅槃。见佛世尊一切义成一切佛法。所作已办入于涅槃。自未有力知诸众生。未满佛法。而心不劣起精进心。我亦如佛入于涅槃。奋迅王。此是第四菩萨不共法

奋迅王。又复菩萨若转轮王。若帝释王。若魔自在妇女围绕。有天歌乐一切妙乐皆悉具足。于中入禅修习无量而心乐于离欲之法。不随异语。于生死中心大怖畏。于淫欲法生不净想。于诸阴中生于怨想。于诸界中生毒蛇想。于诸入中生空聚想。于自眷属生于死想。于妇女中生冢墓想。心常乐求摄取正法。悕望见佛亲近供养。亦常不毁一切众生。能令伎乐弦歌等中出禅分声。魔既闻已遮则声灭。以彼菩萨前善根力。于虚空中即出佛声法声僧声。又彼菩萨弃舍国土富乐自在入于山林。奋迅王。此是第五菩萨不共法

奋迅王。又复菩萨一切世间诸禅定中。不生坚想。有黠慧行。远离使见取义取法。如是菩萨乃至梦中。不生自见。不生他见。不生法见。此不共法。若有自见则有使见。以无自见则离疑网。魔王波旬不能令其生于疑见。若有疑见则离于法。菩萨如是。成熟众生饶益众生。不顾自惑无有疑心。奋迅王。此是第六菩萨不共法

奋迅王。又复菩萨离一切生无有功用。身业清净远离杀生。于诸众生施与无畏。若手若块若杖若刀不加众生。远离刀杖手不执持。自财知足。于他所有至一把草不与不取。设宝满地不生贪心。宁失身命。终不邪命而取财利衣服饮食。常行梵行乃至不生欲食之心。菩萨如是离欲斗诤及诸烦恼。不行淫欲因缘恶法。是彼菩萨不共法处。先思量已身业成就。奋迅王。此是第七菩萨不共法。奋迅王。又复菩萨清净口业。实语真语如说而行。不诳如来天龙夜叉。若乾闼婆。若阿修罗。若迦楼罗。人非人所。口不恶言。不坏眷属自眷属爱。不恶口语。爱语软语。不粗犷语。作相应语。作利益语。常于先语面状笑语。如是菩萨所有恶语恶口说语。他不爱语。自他热语一切不说。不违心语。若无言无。若有言有。如是净语。深心净信得不共法。一切生处常得如法法相应语。以如是语。能令一切不净心人心得清净。心清净者则能供养。彼以深心不共法故。常得实语。有所言说如语不异。随其所说一切皆尔。奋迅王。此是第八菩萨不共法

奋迅王。又复菩萨自心自在。不贪不嗔正见不邪如是菩萨菩提之心无与等心不忘不失。远离一切谄心曲心浊心乱心。昼夜常行清净慈心。奋迅王。此是第九菩萨不共法。奋迅王。又复菩萨即于生时具足世智。若咒若诵若医若药。书印数算一切皆知。一切师术皆悉现知。一切伎能诸论善知。于世间法出世间法。不因他知自智成就。不观他面。一切天人。观察菩萨有如是心。若菩萨说我闻修学。奋迅王。此是第十菩萨不共法

奋迅王。又复菩萨若以种种利益众生。能为他人疗治病患。不求财利供养名称。大悲为首疗治世间。然后令住出世间法。如是菩萨心常忆念。如是恶界苦恼众生。以何方便何时何法令彼得脱。既得脱已毕竟断灭一切烦恼。所谓断除一切苦恼令住涅槃毕竟之乐。奋迅王。此第十一菩萨不共法

奋迅王。又复菩萨心不悕愿帝释天王。若梵天王。若转轮王统王国土。而亦得之。彼菩萨如是不求帝释天王梵世界处转轮圣王统王国土。虽不悕望自然而得。又彼菩萨不为色故求于梵行。不求身色。不求国土。不求眷属。不求财富。不求名闻。不求色相。如是梵行虽不悕望具足而得。奋迅王。此第十二菩萨不共法

奋迅王。又复菩萨住好国土富乐之处。不知念佛。而有诸天曾见佛者。教令忆念。先呵责已如是教言。此法应作此不应作。若作此业则得菩提。当如是愿。汝如是作如是行已调伏诸根未来当得阿耨多罗三藐三菩提。彼天如是教令忆念。于菩提道不越不舍。奋迅王。此第十三菩萨不共法

奋迅王。又复菩萨何等恶人多恶多嗔。垢心众生于菩萨所不能加恶。菩萨于彼亦不报恶。彼大恶人多嗔心人。若身若口若心意恶。若见菩萨心即清净。何以故。菩萨于彼不报其恶。置彼恶者住正法中令心清净。彼虽作恶以菩萨力不入恶道。何以故。以彼菩萨本来如是不共法戒清净满足。有如是心。若有众生。若以身业。若以口业。若以意业。于我起恶。愿彼众生不入恶道。以有戒故随愿成就。奋迅王。此第十四菩萨不共法

奋迅王。又复菩萨。若有众生不信悭贪邪见懈怠不信业报。离佛法僧。若于沙门若婆罗门。心不清净。见则不礼亦不供养不生敬重。亦复不生希有之心。如是众生若见菩萨即住威仪。若闻语说心即清净。起迎礼拜供养恭敬生希有心。何以故。以彼菩萨之势力故。奋迅王。此第十五菩萨不共法

奋迅王。又复菩萨。若有天龙。若有夜叉若乾闼婆。若有仙人若婆罗门。于菩萨所生于师想。诸世间中为师首者。皆师菩萨。以通力故。能令世间天龙夜叉若乾闼婆若诸仙人若婆罗门皆来归敬。彼既来已归菩萨语。礼拜菩萨供养恭敬。是等皆悉先为归首。既见菩萨即便礼拜恭敬尊重。生尊胜想深相敬信。奋迅王。此第十六菩萨不共法

奋迅王。又复菩萨随生何处于何种姓。若村若城或人集处。彼处众生善法增长断不善法。成熟众生摄取正法。生正见家。父母正信正行正入。随何方处何处人中。菩萨生彼师中最胜。彼处众人供养恭敬。无一众生入恶道者。如彼菩萨善根所摄。彼处众生死则生天若生人中。奋迅王。此第十七菩萨不共法。奋迅王。又复菩萨随顺一切菩提分法。胜通满足。一切诸魔不能得便。奋迅王。此第十八菩萨不共法

奋迅王。不共法者。云何不共。一切佛法随顺正行。故名不共法

尔时奋迅王菩萨白佛言。世尊。希有世尊。如来乃能与诸菩萨。大法光明能作无量殊胜光明。如我解佛所说法义。若有菩萨闻此法门。一经于耳得清净心。余修多罗则不能尔。若得闻已受持读诵。彼人则摄一切佛法。若人能于此法门正观察者。则为已修一切佛法。于此法门所有法忍。得随顺忍。若有能行此法门者。一切佛法皆已修行。应如是知。又复世尊。若人不离此法门者彼则得通。如是菩萨既得通已当住道场

佛言。如是如是。奋迅王。如汝所说。若人不离此法门者彼则得通。如是菩萨既得通已当住道场。奋迅王。过去往世然灯如来前复久远有佛。号曰波多婆那。次前又远复有如来号曰提沙。次前又远复有如来号曰弗沙。次前久远复有如来号波除大。次前久远复有如来至佛世尊。号曰天王。出现于世。尔时于彼天王如来佛之世界。一切充足安隐丰乐。天人炽盛地平如掌。以毗琉璃阎浮檀金钵头摩华。种种间错。其地柔软。触力犹如迦遮邻提。人民安乐如兜率陀。所须饮食随念速至。身色形相戏乐之处。及诸宫殿与天不异。惟天与人二名不同

彼三千界中更无有王。唯有如来故名天王。譬如转轮圣正坐饶益座。以法治世非是非法。天王如来亦复如是。坐于法座师子座上。为诸天人如应说法。欲说法时。东西南北纵广八万四千由旬大众充满。尔时如来。说法音声遍三千界。彼诸天人供养恭敬。礼拜如来尊重如来所谓无上佛法供养。彼无下劣信解众生。惟信佛法。如是彼处无有声闻缘觉之名。岂有乘处。况复有行。惟有清净大菩萨众围绕世尊。彼处清净无有女人。耳初不闻欲行之名

彼诸众生皆悉化生于莲华中结加趺坐。如是化生。彼诸人天受三种乐。何等为三。见如来乐及闻法乐。观察正法离欲之乐。彼诸天人心不放逸。具足财富迭互说法。常勤精进。寿命长远无量无数。业尽退时不生余道。生佛世界。如是菩萨临欲退时。上升虚空高七多罗。出声说言。我今于此佛世界退。无量菩萨闻彼声已。皆共和合而来集会。观彼菩萨示于法忍。作如是言。于何法退。于何法生。彼退菩萨。于彼菩萨集会众中。说如是言。大仙当知非有少法若退若生。如来所觉一切诸法。皆无有退皆无有生。非色有退。非色有生。非受非想非行非识。有退有生。第一义中无我无命。亦无众生无富伽罗。无人非人若退若生。世尊正觉。一切法空无相无愿。彼空无相无愿法中无退无生。如来世尊。证离欲际。证无为际。证不生际。非不生际有退有生。无退因缘是故不退。无生因缘不相和合。是故不生。如是因缘无有和合。无退无生。如是菩萨。为菩萨众说此法已然后乃退。彼退菩萨如是退已。无身无皮。无块无可知见。退已复到余佛世界。现见如来

大王如来并诸菩萨。不着袈裟皆着清净妙好天衣。彼不学戒而悉调顺。一切皆得无生法忍。为菩萨众不广说法。何以故。彼众一切少闻多解。以利根故。若彼如来为诸菩萨众会说法。既说法已彼处彼处乃至彼佛世界之中。若人若天一切皆知。彼彼众生有得忍者。或有获得陀罗尼者。或有众生得辩才者得三昧者。时彼如来名闻十方

奋迅王。天王如来。为诸天人广演分别如是法门。有诸菩萨七万二千皆得授记。彼有菩萨名曰无垢清净光明。不得授记。有如是念。此诸菩萨威仪无碍。忆念意行。若慧若通得陀罗尼及得三昧。不胜于我皆得授记。若彼得记。我何因缘不得授记。天王如来。知彼菩萨心所念已。而语之言。汝未来世当得授记。善男子。于未来世然灯如来应正遍知。为汝授记。无垢清净光明菩萨。闻是语已心生欢喜。上升虚空说如是言。若未来世恒河沙劫。然灯如来出现于世。我到彼时得一切智。如来真语。如来实语不异语故

奋迅王。汝意云何。彼时无垢清净光明大菩萨者。岂异人乎。莫作异观。何以故。我是彼时无垢清净光明菩萨。奋迅王。次后如来名波除大。我于尔时供养彼佛。彼佛为我说此法门。我既闻已受持读诵。尔时获得光印三昧。次后如来名曰弗沙。我于尔时供养彼佛。闻此法门受持读诵。尔时获得光明三昧。次后供养堤沙如来。闻此法门受持读诵。复得毗卢遮那三昧。次后供养波多般那如来世尊。闻此法门受持读诵得柔顺忍。次后供养然灯如来。尔时我得无生法忍。我时得此四种奋迅。谓戒奋迅。通奋迅。智奋迅。慧奋迅。奋迅王。此门如是应当善知。若有何人。若善男子若善女人。行菩萨行今于我所。闻此法门受持读诵一切速疾得通菩萨。得此奋迅。得奋迅已转大法轮。于此无上光明法中得智光明

如来说此法门之时。会中一万六千菩萨一切得忍。复有一万二千众生发菩提心。三千大千世界震动。百千诸天皆赞叹言。若此法门所在之处。则为有佛。若有深种善根众生乃能得闻如是法门

尔时慧命阿难陀白佛言。世尊。当以何名名此法门。如是法门云何受持。佛言阿难。此法门者名四奋迅神通法门。如是受持

世尊说已。奋迅王菩萨。慧命阿难陀。并诸天人。及乾闼婆阿修罗等。闻如来说。欢喜赞叹

奋迅王问经卷下


佛说般舟三昧经

    No. 417 [Nos. 416, 418, 419]

佛说般舟三昧经

        后汉月支三藏支娄迦谶译

    问事品第一

闻如是。一时佛在罗阅只加邻竹园中。与大菩萨比丘比丘尼优婆塞优婆夷。及诸天龙阿须轮诸夜叉迦楼罗甄陀罗摩睺勒等。无央数众。一切都在大会坐。是时颰陀和菩萨。从坐起整衣服。长跪叉手白佛。愿欲有所问。听者今当问。佛言善哉。恣汝所问。今当为汝说之。颰陀和问佛言。菩萨当行何等法得智慧。如巨海揽万流。云何行。博达众智所闻悉解而不疑。云何行。自识宿命所从来生。云何行。得长寿。云何行。常在大姓家生。父母兄弟宗亲知识无不爱敬。云何行。得端正颜好美艳。云何得高才与众绝异。智慧通达无所不包。云何行。功立相满自致成佛威神无量。成佛境界庄严国土。云何行。降魔怨。云何行。而得自在所愿不违。云何行。得入总持门。云何行。得神足遍至诸佛土。云何行。得勇猛如师子无所畏。一切魔不能动。云何行得佛圣性。诸经法悉受持。皆了知而不忘。云何行得自足离谀谄。不着三处。云何行。得无挂碍持萨云若教不失佛意。云何行。得人信。云何行。得八种声入万亿音。云何行。得具足相好。云何行。得彻听。云何行。得道眼睹未然。云何行。得十力正真慧。云何行。心一等念十方诸佛悉现在前。云何行。知四事之本无。云何行。便于此间见十方无数佛土。其中人民天龙鬼神及蠕动之类善恶归趣皆了知。所问如是。当云何行。愿佛说之释一切疑。佛告颰陀和。善哉。汝所问多所过度。不可复计。汝所以能作是问者。汝乃前世过去佛时。所作功德。供养诸佛。乐于经法。守禁戒行清净所致。常行乞食不就请。多成就诸菩萨合会。教语令弃众恶。视一切悉平等所致。常有大慈大悲所致。汝功德不可复计。佛告颰陀和。有三昧名十方诸佛悉在前立。能行是法。汝之所问悉可得也。颰陀和白佛。愿为说之。今佛说者。多所过度安隐十方。为诸菩萨现大明相。佛告颰陀和。有三昧名定意。菩萨常当守习持。不得复随余法。功德中最第一

    行品第二

佛告颰陀和。菩萨欲疾得是定者。常立大信。如法行之则可得也。勿有疑想如毛发许。是定意法。名为菩萨超众行

  立一念　　信是法　　随所闻
  念其方　　宜一念　　断诸想
  立定信　　勿狐疑　　精进行
  勿懈怠　　勿起想　　有与无
  勿念进　　勿念退　　勿念前
  勿念后　　勿念左　　勿念右
  勿念无　　勿念有　　勿念远
  勿念近　　勿念痛　　勿念痒
  勿念饥　　勿念渴　　勿念寒
  勿念热　　勿念苦　　勿念乐
  勿念生　　勿念老　　勿念病
  勿念死　　勿念身　　勿念命
  勿念寿　　勿念贫　　勿念富
  勿念贵　　勿念贱　　勿念色
  勿念欲　　勿念小　　勿念大
  勿念长　　勿念短　　勿念好
  勿念丑　　勿念恶　　勿念善
  勿念嗔　　勿念喜　　勿念坐
  勿念起　　勿念行　　勿念止
  勿念经　　勿念法　　勿念是
  勿念非　　勿念舍　　勿念取
  勿念想　　勿念识　　勿念断
  勿念着　　勿念空　　勿念实
  勿念轻　　勿念重　　勿念难
  勿念易　　勿念深　　勿念浅
  勿念广　　勿念狭　　勿念父
  勿念母　　勿念妻　　勿念子
  勿念亲　　勿念疏　　勿念憎
  勿念爱　　勿念得　　勿念失
  勿念成　　勿念败　　勿念清
  勿念浊　　断诸念　　一期念
  意勿乱　　常精进　　勿懈怠
  勿岁计　　勿日倦　　立一念
  勿中忽　　除睡眠　　精其意
  常独处　　勿聚会　　避恶人
  近善友　　亲明师　　视如佛
  执其志　　常柔弱　　观平等
  于一切　　避乡里　　远亲族
  弃爱欲　　履清净　　行无为
  断诸欲　　舍乱意　　习定行
  学文慧　　必如禅　　除三秽
  去六入　　绝淫色　　离众受
  勿贪财　　多畜积　　食知足
  勿贪味　　众生命　　慎勿食
  衣如法　　勿绮饰　　勿调戏
  勿憍慢　　勿自大　　勿贡高
  若说经　　当如法　　了身本
  犹如幻　　勿受阴　　勿入界
  阴如贼　　四如蛇　　为无常
  为恍惚　　无常主　　了本无
  因缘会　　因缘散　　悉了是
  知本无　　加慈哀　　于一切
  施贫穷　　济不还　　是为定
  菩萨行　　至要慧　　起众智

佛告颰陀和。持是行法便得三昧。现在诸佛悉在前立。其有比丘比丘尼。优婆塞优婆夷。如法行持戒完具。独一处止念西方阿弥陀佛今现在。随所闻当念。去此千亿万佛刹。其国名须摩提。一心念之。一日一夜若七日七夜。过七日已后见之。譬如人梦中所见。不知昼夜亦不知内外。不用在冥中。有所蔽碍故不见。颰陀和。菩萨当作是念。时诸佛国境界中。诸大山须弥山。其有幽冥之处。悉为开辟无所蔽碍。是菩萨不持天眼彻视。不持天耳彻听。不持神足到其佛刹。不于此间终生彼间。便于此坐见之。譬如人闻堕舍利国。有淫女字须门。复有人闻淫女阿凡和利。复有人闻优婆洹复作淫女。时其人未曾见此三女人。闻之淫意即动。是三人皆在罗阅只国同时念。各于梦中到其女边。与共栖宿。觉已各自念之。佛告颰陀和。我持是三女人以为喻。汝持是事为人说经。使解此慧。至不退转地无上正真道。若后得佛号曰善觉。佛言。菩萨于此间国土。念阿弥陀佛专念故得见之。即问。持何法得生此国。阿弥陀佛报言。欲来生者当念我名。莫有休息则得来生。佛言。专念故得往生。常念佛身有三十二相八十种好。巨亿光明彻照。端正无比。在菩萨僧中说法不坏色。何以故。色痛痒思想生死识魂神地水火风。世间天上上至梵摩诃梵不坏色。用念佛故得是三昧。佛告颰陀和。是菩萨三昧谁证者。我弟子摩诃迦叶因坻达须真天子。及时知者。有行得者。是为证也。如是颰陀和。欲得见十方诸现在佛者。当一心念其方莫得异想。如是即可得见。譬如人远出到他郡国。念本乡里家室亲族。其人于梦中归到故乡里。见家室亲属。喜共言语。觉为知识说之如是。佛言。菩萨闻佛名字欲得见者。常念其方即得见之。譬如比丘观死人骨。着前观之。有青时有白时。有赤时有黑时。其色无有持来者。是意所想耳。菩萨如是持佛威神力。于三昧中立自在。欲见何方佛即得见。何以故。持佛力。三昧力。本功德力。用是三事故得见。譬如人年少端正着好衣服。欲自见其形。若以持镜。若麻油若净水水精。于中照自见之。云何宁有影从外入镜麻油水水精中不也。颰陀和言。不也天中天。以镜麻油水水精净故。自见其影耳。影不从中出。亦不从外入。佛言善哉。颰陀和。色清净故。所有者清净。欲见佛即见。见即问。问即报。闻经大欢喜作是念。佛从何所来。我为到何所。自念佛无所从来。我亦无所至。自念欲处色处无色处。是三处意所作耳。我所念即见。心作佛。心自见。心是佛心。佛心是我身。心见佛。心不自知心。心不自见心。心有想为痴心。无想是涅槃。是法无可乐者。设使念为空耳。无所有也。菩萨在三昧中立者。所见如是。佛尔时说偈言

  心者不自知　　有心不见心
  心起想则痴　　无心是涅槃
  是法无坚固　　常立在于念
  以解见空者　　一切无想愿

    四事品第三

菩萨有四事法。疾逮得是三昧。一者所信无有能坏者。二者精进无有能退者。三者智慧无有能及者。四者常与善师从事。是为四。复有四事。疾得是三昧。一者不得有世间思想。如弹指顷三月。二者不得睡眠三月。如弹指顷。三者经行不得休息三月。除其饭食左右。四者为人说经。不得望人供养。是为四。复有四者。疾得是三昧。一者合会人至佛所。二者合会人使听经。三者不嫉。四者教人学佛道。是为四。复有四事。疾得是三昧。一者作佛形像。用成是三昧故。二者持好素写是三昧。三者教自贡高人内佛道中。四者常护佛法。是为四。佛尔时说偈言

  常信乐于佛法　　精进行解深慧
  广分布为人说　　慎无得贪供养
  意善解便离欲　　常念佛有威德
  悉见知无数变　　过去佛及当来
  并现在人中尊　　诸相好若干种
  黄金色无秽漏　　坚固教无极慧
  听是法无乱心　　常舍离懈怠行
  无恚害向他人　　敬于师当如佛
  慎无得疑斯经　　一切佛所歌叹
  常造立佛形像　　常教人学是法
  行如是得三昧

佛告颰陀和。欲学是三昧者。当敬于师承事供养。视当如佛。视善师不如佛者。得三昧难。菩萨敬善师从学得是三昧已。持佛威神于中立。东向视见若干百千万亿佛。十方等悉见之。譬如人夜起观星宿甚众多。菩萨欲得见今现在佛悉在前立者。当敬善师。不得视师长短。当具足布施持戒忍辱精进一心。不得懈怠

    譬喻品第四

佛告颰陀和。菩萨得是三昧不精进行者。譬如人载满船珍宝渡大海。船中道坏。阎浮利人皆大愁忧念失我尔所宝。菩萨闻是三昧不学者。一切诸天人民皆悲忧言。乃失我尔所经宝。佛言。是三昧经者。是佛所嘱。佛所称举。闻是深三昧。不书学诵守持如法者。是为愚痴。譬如痴子人持栴檀香与之。而不肯受谓之不净香。主言。此栴檀香也。卿莫谓不净。嗅之知香。视之知净。其人闭目不嗅不视也。佛言。闻是三昧不肯受持者。如彼痴子是为无知。反呼世间为有。不入空不知无。自谓如法。反作轻戏言。佛亦有深经乎。亦有威神乎。反相形言。世间亦有比丘如阿难乎。佛言其人从持是三昧者。所去两两三三相与语言。是何等说。从何得是语。为自合会作是经。非佛所说。佛告颰陀和。譬如贾客持摩尼珠示田家痴子。曰评此直几钱。贾客言。持是珠置冥中。其光所照直满中宝。佛言。其人不知是珠而言。其价能与一头牛等不。宁可贸一头牛与我者善。不肯者休。如是颰陀和。菩萨闻是三昧不信。反形相者。如彼痴子。佛言。菩萨闻是三昧信受持修行者。四面皆拥护无所畏持戒完具。是为高明。智慧深入当分布语人展转相教。当令是三昧久在世间。佛言。痴人自于前世不供养作功德。反自贡高。多行诽谤嫉妒。贪财利故欲求名誉。但欲哗说不信深经。闻是三昧不信不乐不学。反诽谤是经。言非佛所说。佛告颰陀和。今我故语汝如是若善男子善女人。持珍宝满三千国土布施。设有是功德。不如闻是三昧信乐者。其福过彼上

佛告颰陀和。如我所说无有异。今故说是语耳。今见我说是三昧有疑者。其人却后除在恶师边。正使善师所其功德不足言。如是辈人。转与恶师从事。闻是三昧不信不乐不学。何以故。其人所更佛少。智慧少故不信耳。佛告颰陀和。其有闻是三昧。不轻笑不诽谤。不疑不乍信乍不信。欢喜乐书学诵持者。我悉豫知见之。其人不独于一佛二佛所作功德。悉于百佛所闻是三昧。却后世时闻是三昧。书学诵持守之一日一夜。其福不可计。自致得阿惟越致。所愿者得。佛告颰陀和。听我说譬喻。有人取一佛刹悉碎如尘。取一尘皆复尽破。如一佛刹尘。云何是尘数宁多不也。颰陀和言。甚多甚多天中天。佛言。有菩萨尽取一尘置一佛刹。其数尔所佛刹。满中珍宝悉持供养诸佛。其福功德少少耳。不如闻是三昧学书诵持。为他人说守。须臾间闻。是功德不可复计。何况已得是三昧悉具足者。佛尔时说偈言

  若有菩萨求众德　　当说奉行是三昧
  信乐讽诵不疑者　　其功德福无齐限
  如一佛国之世界　　皆破坏碎以为尘
  一切佛土过是数　　满中珍宝用布施
  不如闻是三昧者　　其功德福过上施
  引譬功德不可喻　　嘱累汝等当劝教
  力行精进无懈怠　　其有诵持是三昧
  已为面见百千佛　　假使最后大恐惧
  持是三昧无所畏　　行是比丘已见我
  常为随佛不远离　　如佛所言无有异
  菩萨常当随其教　　疾得正觉智慧海

    四辈品第五

颰陀和白佛。难及天中天。若有弃爱欲作比丘闻是三昧。当云何学。云何持。云何行。佛言。弃爱欲作比丘欲学是三昧者。当清净持戒。不得缺如毛发。常当怖畏于地狱痛苦。远离于谀谄。是为清净。云何为缺戒也。佛言。求色。云何为求色。佛言。其人意念我持戒自守。使我后世生。若作天若作遮迦越王。如是为乐爱欲。是为缺戒。佛告颰陀和。其有欲学是三昧者。清净自守持戒完具。不谀谄。常为智所称誉。于经中当布施当精进。所志当强。当多信当劝乐。承事于师视当如佛。得三昧疾设不恭敬。轻易欺调于师。正使久学是三昧疾忘之。佛告颰陀和是菩萨若从比丘比丘尼。优婆塞优婆夷。闻是三昧当视如佛常敬尊。不当持谄意向。菩萨不得有谄意。常当至诚。常乐独处止。不惜身命。不得悕望人所索。常行乞食不受请。自守节度所有趣足而已。经行不得懈卧。如是经中教。学是三昧当守如是。颰陀和白佛。难及天中天。后世若有懈怠菩萨。闻是三昧不肯精进学。当云何若有菩萨精进欲学者。我辈当随是经教之。佛言。善哉颰陀和。我助其欢喜。过去当来今现在佛皆助欢喜。佛尔时颂偈言

  如我所说悉受持　　常独处止行功德
  自守节度不聚会　　常行乞食不受请
  敬于法师视如佛　　除去睡眠志开解
  常自精进无懈怠　　如是行者得三昧

颰陀和白佛。比丘尼求菩萨道。欲学是三昧。当云何行。佛言。比丘尼求是三昧者。不得自高。常当卑谦。不得自贵。不得自大。不得嫉妒。不得嗔恚。不得贪财利色。常当清净不得惜躯命。常乐经法念多学问。当弃淫怒痴不得贪好服饰珠环。当为智者称誉。当敬善师视如佛。不得有谄意。佛尔时颂偈言

  若比丘尼求三昧　　常当精进勿懈怠
  无得听于贪欲心　　除去嗔恚自高贵
  不得慢欺及调戏　　常行至诚立一信
  恭敬善师视如佛　　如是行者得三昧

颰陀和白佛。若有居士修道。闻是三昧欲学者。当云何行。佛言。居士欲学是三昧者。当持五戒令坚。不得饮酒。亦不得饮他人。不得与女亲熟。不得教他人。不得有恩爱于妻子男女不得贪财产。常念欲弃家作沙门。常持八关斋。当于佛寺中。常当念布施。布施已不念我自当得其福。用为一切施。常当大慈敬于善师。见持戒比丘。不得轻易说其恶。作是行已。当学守是三昧。佛尔时颂偈言

  居士欲学是三昧　　当持五戒勿毁缺
  常当思欲作沙门　　不贪妻子及财色
  常八关斋于佛寺　　不得贡高轻蔑人
  心无荣冀思所欲　　奉行经法心无谄
  弃舍悭贪常惠施　　常当奉敬比丘僧
  常志一行勿懈怠　　学是三昧当如是

颰陀和白佛。优婆夷闻是三昧欲学者。当云何行。佛言。优婆夷欲学者。当持五戒自归于三。何等为三。自归命佛。归命法。归命比丘僧。不得事余道。不得拜于天。不得祠鬼神。不得视吉良日。不得调戏。不得慢恣有色想。不得有贪欲之心。常当念布施。欢乐欲闻经。念力学问敬重善师。心常拳拳不得有懈。若有比丘比丘尼过者。以坐席宾食之。佛尔时颂偈言

  优婆夷欲学三昧　　奉持五戒勿缺毁
  承事善师视如佛　　不得拜天祠祀神
  除去杀盗及嫉妒　　不得两舌斗彼此
  不得悭贪常念施　　见恶覆藏唯叹善
  不得谀谄有邪淫　　常当卑谦勿自大
  敬事比丘比丘尼　　如是行者得三昧

    拥护品第六

颰陀和菩萨。罗邻那竭菩萨。憍日兜菩萨。那罗达菩萨。须深菩萨。摩诃须萨和菩萨。因坻达菩萨。和轮调菩萨。是八菩萨。见佛所说皆大欢喜。持五百劫波育衣布施。持身自归。持珍宝供养。佛告阿难颰陀和等五百人。人中之师。常持正法随顺教化。莫不欢喜。乐随侍者心净无欲。时五百人。皆叉手立佛前。颰陀和白佛。菩萨持几事。疾得是三昧。佛言有四事。一者不信余道。二者断爱欲。三者当清净行。四者无所贪。是为四。如是行者。今世即得五百功德。譬如慈心比丘终不中毒。兵刃不加。火不能烧。入水不溺不害。正使劫尽烧时。堕是火中火即为灭。喻如大水灭小火。菩萨持是三昧者。若帝王若贼若水火。若龙夜叉蟒师子虎狼。[狂-王+加]玃薜荔鸠坻。一切毒兽及鬼神。欲娆人欲杀人。欲夺人衣钵。坏人禅夺人念故。欲中是菩萨。终不能也。除其宿命不请。如我语无异也。佛言。持是三昧者。终不痛目若耳鼻口身体。心终不忧。除其宿命所作。佛言。是菩萨为诸天龙神。及阿须轮。夜叉鬼神。迦楼罗鬼神。甄陀罗鬼神。摩睺勒鬼神。若人非人。皆共赞誉是菩萨。皆共拥护承事供养。瞻视敬仰思欲相见。诸佛世尊亦然。是菩萨所未诵经前所不闻持。是三昧威神悉自得之。若昼日不得者。夜于梦中悉得之。佛告颰陀和。其有持是三昧者。我说其功德。一劫复过一劫。不可尽竟。略说其要尔

    劝助品第七

佛告颰陀和。菩萨于是三昧中。将有四事助其欢喜。过去佛持是三昧。助欢喜自致得阿耨多罗三耶三菩阿惟三佛。其智悉具足。今现在十方无央数佛。亦于是三昧中。四事助欢喜得。当来亦当从是四事助欢喜得。我悉助欢喜。佛告颰陀和。是三昧中四事助欢喜。我于是中说少所譬喻。人寿百岁随地行至者不休息。其人行过于疾风。宁有能计其道里不。颰陀和言。无有能计者。独佛弟子舍利弗罗。阿惟越致菩萨。乃能计之耳。佛言。我故语诸菩萨。若有善男子善女人。取是人所行处满中珍宝布施。不如闻是三昧四事助欢喜。其福过布施者。百千万亿倍。当知是助欢喜福甚尊大。佛告颰陀和。乃久远不可计阿僧祇。尔时有佛。名私诃摩提等正觉无上士道法御天人师佛世尊。在空闲之处。是时阎浮利纵广十八万亿里。凡有六百四十万国。悉丰熟人民炽盛。有大国名颰陀和。有转轮王惟斯芩。往到佛所礼毕却坐一面。佛知其意便为说是三昧。其王闻之助欢喜。即持珍宝散佛上。自念曰。持是功德令十方人民皆安隐。时私诃提佛般涅槃后。惟斯芩王寿终。还自生其家作太子。名梵摩达尔时有比丘名珍宝。是时为四部弟子说是三昧。梵摩达闻之助欢喜。踊跃持宝直百亿散其上。复持好衣供养之。以发意求佛道。与千人俱。于是比丘所作沙门。求学是三昧。与千人共承事师八千岁不休懈。得一闻是三昧四事。助欢喜入高明智。因是却后更见六万八千佛。辄于一一佛所。闻是三昧自致得佛。名坻罗惟逮等正觉无上士道法御天人师佛世尊。是时千比丘从得等正觉。皆名坻罗郁沈。教不可计人民皆求佛道。佛告颰陀和。何人闻是三昧。不助欢喜学持守诵为人说者也。佛言。若有守是三昧者疾逮得佛。但闻其功德不可计。何况学持者。若去百里千里。有是三昧当求之。何况近而不求学也。若有闻是三昧欲学者。当承事其师十岁。供养瞻视不得自用。当随师教常念师恩。佛言。我故为汝说之。闻是三昧去四千里者。往到其所。正使不得闻。其功德不可计也。所以者何。专精进故。会当得之自致作佛

    至诚品第八

佛言。乃往昔有佛。名萨遮那摩等正觉无上士天人师佛世尊。时有比丘名和轮。其佛般涅槃后。是比丘持是三昧。我时作国王刹利种。于梦中闻是三昧。觉已便行。求是比丘即依作沙门。欲得闻是三昧。承事其师三万六千岁。魔事数数起竟不得闻。佛告比丘比丘尼。优婆塞优婆夷。我故语汝等。疾取是三昧无得忘失。善承事其师持是三昧。至一劫若百劫若百千劫。莫得有懈倦。守善师不离。若饮食资用。衣被床卧珍宝以上勿有爱惜。设无者当行乞食给师。趣当得是三昧莫厌。常当自割身肉供养于善师。何况宝物此不足言耳。承事善师当如奴事大家。求是三昧者当如是。得三昧已。当坚持常念师恩。是三昧难得值。正使求是三昧至百千劫。但欲得闻其名不可得。何况学而不精进。得是三昧精进学转教人者。正使如恒河沙佛刹满中珍宝。用布施甚多。不如学是三昧者。佛告颰陀和。若有人欲学者。当助欢喜。欲学而得。学者持佛威神使学。当好书是三昧着素上。当得佛印印之。当善供养。何谓佛印。所谓不当行无所贪无所求无所想。无所著无所愿。无所向生。无所取无所顾。无所住无所碍。无所结无所有。尽于欲。无所生无所灭。无所坏无所败。道要道本是印。阿罗汉辟支佛所不能及。何况愚痴者。是印是为佛印佛言。我今说是三昧时。千八百亿诸天阿须轮鬼神龙人民。得须陀洹道。八百比丘得阿罗汉。五百比丘尼得阿罗汉。万菩萨得是三昧。得无从生法于中立。万二千菩萨不复退转。佛告舍利弗目揵连比丘颰陀和等。我从无数劫求道。今已得作佛。持是经嘱累汝等。学诵持守无得忘失。若有欲学者。当具足安谛教之。其欲闻者。当为具足说之。佛说经竟。颰陀和菩萨等舍利弗目连比丘阿难及诸天阿须轮龙鬼神人民。皆大欢喜。为佛作礼而去

佛说般舟三昧经


佛说大集会正法经

    No. 424 [No. 423]

佛说大集会正法经卷第一

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众万二千人俱。尊者阿惹憍陈如。尊者摩诃目干连。尊者舍利子。尊者摩诃迦叶。尊者思胜。尊者罗睺罗。尊者善容。尊者贤护。尊者贤吉祥。尊者月吉祥。尊者大势至。尊者满慈子。尊者善吉。尊者哩嚩谛。尊者栴檀军。如是等皆大阿罗汉。是时有菩萨摩诃萨。其名曰慈氏菩萨摩诃萨。普勇菩萨摩诃萨。童子吉祥菩萨摩诃萨。童子住菩萨摩诃萨。童子贤菩萨摩诃萨。无所减菩萨摩诃萨。妙吉祥菩萨摩诃萨。普贤菩萨摩诃萨。善现菩萨摩诃萨。金刚军菩萨摩诃萨。药王军菩萨摩诃萨。如是等六万二千菩萨摩诃萨众。复有最胜树王天子。贤天子。善贤天子。法爱天子。栴檀藏天子。香住天子。栴檀香天子。如是等一万二千天子众。复有妙身天女。极信天女。自在主天女。吉祥目天女。世吉祥天女。大世主天女。大力天女。妙臂天女。如是等八千天女众。复有优钵罗龙王。伊罗钵怛啰龙王。底民誐隶龙王。胜器龙王。最上器龙王。妙喜龙王。妙枝龙王。象头龙王。如是等八千龙王众俱来集会。到佛所已咸各头面礼世尊足。右绕三匝退坐一面。是时世尊默然而住

尔时会中有菩萨摩诃萨。名曰普勇。即从座起偏袒右肩。右膝着地合掌恭敬。而白佛言。世尊。此会菩萨及诸声闻天人众等悉皆来集。乐欲听佛宣说妙法。此诸大众咸一谛观如来应供正等正觉殊善色相。乐入佛法。以乐法心观佛相故。久修习者即能远离一切障染。初修习者即发无上修善法心。不复暂起诸不善想。作是白已

尔时佛告普勇菩萨言。我有正法名大集会。于阎浮提广大流布。若有众生暂得闻者。是人设有五逆重罪皆得销灭。不复退转于阿耨多罗三藐三菩提。普勇。于汝意云何。汝谓是人得闻法者。所获福聚与一佛等。普勇菩萨白佛言。如是世尊。佛言。普勇。汝莫作是见。作是见者非真实见。普勇菩萨复白佛言。世尊。当云何见。即知是人真实福聚。佛言。普勇。彼闻法者所获福聚。与殑伽沙数量如来应供正等正觉所有福聚等无有异。又复普勇。若有闻是正法者。一切皆住不退转地。即得一切如来常所观察。一切如来常现在前。降伏魔军圆满善法。是人即能于生灭理皆悉了知。一切皆得成就阿耨多罗三藐三菩提。尔时会中诸菩萨众。从座而起俱白佛言。世尊。如一佛福聚其量几何。佛言。诸善男子。汝等谛听。一佛福聚所有数量。譬如有人竭大海水尽洒阎浮。于此水中唯取一渧。作一殑伽河沙数量。如是一渧而复一渧。穷大海水一一渧成一殑伽河。此一一河满中沙数。尽为菩萨皆住十地。彼诸菩萨所有福聚宁为多不。诸菩萨众俱白佛言。甚多世尊。佛言。诸善男子。一佛福聚复多于彼。有闻法者转倍是数。又复诸善男子。若有众生于后末世。闻是正法生信解心。所获福聚转增于彼。无量无边不可称计

尔时普勇菩萨复从座起而白佛言。世尊。诸有众生乐求法者。当云何求。佛言。普勇。诸求法者略有二种。一者于一切众生起平等心。二者如所闻法为众生说。普勇菩萨白佛言。世尊。如所闻法。又复云何为众生说。佛言。普勇。亦有二种。一者以所闻法回向菩提。二者于大乘法爱乐趣求。而复长时心无懈退。若能如是为众生说。是得名为真求法者

尔时会中诸天子天女众。各从座起住立佛前。合掌向佛而白佛言。世尊。我等深心乐求正法。如佛世尊大慈大悲。能满一切众生心愿。愿为我等广分别说

尔时世尊。即于会中。放大希有净妙光明。普照大众。是时普勇菩萨白佛言。世尊。以何因缘放是光明。佛告普勇菩萨言。汝今当知。今此会中有发阿耨多罗三藐三菩提心者。于佛世尊生难遭想。尊重恭敬劝请说法。以是因缘放斯光明。普勇菩萨复白佛言。世尊。诸有众生发阿耨多罗三藐三菩提心者。云何修习而能成就。佛言。善哉善哉。汝大勇猛。于大众中能以此义问佛世尊。利益一切疾成佛道。汝今亦能以此善根成就阿耨多罗三藐三菩提。如汝所问。今为汝说。汝当谛听。我念往昔过阿僧祇劫。有佛出世。号宝吉祥如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。我于彼时为摩拏嚩迦。令诸众生安住佛智。忽于一时见一鹿王受诸苦恼。我于是时窃作是念。云何当能代此鹿王而受诸苦。复自思惟。一切众生轮转三界未离苦者皆亦如是。即发愿言。愿我当来得成佛已。一切众生离诸苦恼。生我佛刹安住佛智。普勇。我以如是善根大愿力故。即得阿耨多罗三藐三菩提

尔时普勇菩萨闻是说已复白佛言。世尊。彼佛世时众生寿量其数几何。佛言。众生寿量满八十劫。普勇菩萨又复问言。以何劫量而登彼寿。佛言普勇。彼劫量者。譬如有人造一大城。广十二由旬。高三由旬。于彼城中置以胡麻悉皆充满。忽有一人百年一来。取一胡麻而掷于外。如是一来一掷。乃至胡麻掷尽城亦破坏。此劫数量亦复未尽。又复譬如有一大山。广二十五由旬。高十二由旬。有长寿天。百年一来一坐其上。以憍尸迦衣拂其山石。如是一来一拂。乃至彼山拂尽。其劫数量亦复未尽。普勇。如是名为劫量。是时普勇菩萨又白佛言。世尊。若人以一善根回向菩提获大福聚。得寿命八十劫。何况有人于佛深妙法中广大修习。其所得福不可称计。佛言普勇。若有众生得闻是大集会正法者。所获寿命。八万四千劫。何况更能于此正法书写读诵。彼获福聚转倍于前不可等比。又复普勇。若人闻此正法。起净信心恭敬尊重。是人九十五劫得宿命智。六万劫为转轮王。为一切人之所尊重悉皆爱敬。不为刀杖毒药所能侵害。临命终时有九十五俱胝佛。面现其前安慰彼人。作是告言。勿生怖畏。汝先已闻大集会正法有大福聚。是时彼九十五俱胝佛。皆为授记。一一来生我佛刹中。何况以此正法。令尽有情界。广大流布皆悉得闻。普勇菩萨复白佛言。世尊。我今于此大集会正法。乐欲听受心无厌足。佛言。善哉善哉。非唯汝心乐法无厌。我于此法喜大宣说。亦复无厌。何况诸凡夫类。于此正法起厌足心。又复普勇。若有善男子善女人。于此正法深生信乐。是人于千劫中不坏正信。五千劫中不堕恶趣。万二千劫中远离愚痴。八千劫中不生边地。二万劫中勇猛布施。二万五千劫中常生天界。二万五千劫中常行梵行。四万劫中远离眷属之所痴缚。不为烦恼所能昏蔽。五万劫中受持正法。六万五千劫中安住正念。普勇。彼善男子善女人。更不复起作罪业心。一切魔怨不能侵害。在在所生不处胎藏。又复有人于此正法听受读诵。是人八万劫中。得闻持具足。于千劫中离杀生业。九万九千劫中离妄语业。一万三千劫中离两舌业。普勇当知。以是事故。此大正法不可得遇。至于名字亦不可得闻

尔时普勇菩萨摩诃萨。益加恭敬右膝着地。礼世尊足前白佛言。世尊。若有人。于此正法生轻谤者。是人得几所罪。佛言甚多。普勇菩萨复白佛言。彼所获罪其数几何。佛言普勇。若人于十二殑伽沙数诸佛所。起大恶心其罪尚轻。若于是正法起轻谤心者。其所获罪甚多于彼。何以故。普勇。若人于彼正法起轻谤者。是即发起破大乘心。以烦恼火而自焚烧。普勇菩萨复白佛言。世尊。一切众生业习所缠。轮转生死不能解脱。佛言普勇。如是如是。譬如有人自断其头。时有一人持以良药。所谓摩叱迦良药。虞尼那嚩良药。竭哩多嚩良药。带梨那嚩良药。如是等良药涂所断头。普勇。于汝意云何。汝谓是人还活其命不。普勇菩萨白佛言。不也世尊。是人虽涂良药其何能活。普勇彼轮转者亦复如是

复次普勇。譬如一时有二丈夫。各持利刀互欲害命。以力相敌故俱不能害。唯致疮损苦痛亦甚。时忽有人持以良药。为涂其上其疮即愈。彼二丈夫既得愈已。忆念往苦互相谓言。我等从今不复更起相杀害心。普勇。诸有智者亦复如是。虽复造业即能追悔。而于正法不生弃背。如是渐能趣向一切离生死法

复次普勇。如世间人舍寿报已。虽有父母忧恼啼泣。而更不能为依为怙。彼凡夫类不能自利。亦不利他。不造善业亦复如是。临命终时无所依怙。略有二种。一者自造诸不善业。复劝他作。二者于佛正法起轻谤心。普勇菩萨复白佛言。世尊。若有于佛正法生轻谤心者。是人命终当堕何处。佛言普勇。彼谤法者命终已后。当堕地狱受大苦恼。所谓大可怖地狱。众合地狱。炎热地狱。极炎热地狱。黑绳地狱。阿鼻地狱。噜摩诃哩沙地狱。呼呼尾地狱。如是等八大地狱中。一一地狱受一劫苦。普勇菩萨复白佛言。甚苦世尊。我今于此不忍听闻。尔时世尊。即为普勇菩萨。说伽陀曰

  我所说地狱　　汝怖不忍闻
  彼地狱苦恼　　众生业自造
  若作诸善业　　定获安乐果
  作诸不善者　　必得苦恼报
  生苦与死苦　　忧苦等缠缚
  不造诸乐因　　愚人常苦恼
  智者得安乐　　信乐大乘法
  念佛最上智　　永不堕恶趣
  普勇汝当知　　前前世业感
  少种一善因　　定获广大果
  如世种增长　　百谷皆无失
  善因生佛刹　　获果亦如是
  智者修善法　　远离诸苦因
  彼成众德本　　获最上安乐
  若能平等施　　善法一毫量
  于八万劫中　　获广大财富
  在在所生处　　常念行布施
  以施三宝故　　展转报无尽

尔时普勇菩萨。闻佛说是伽陀已。即白佛言。世尊。云何于此大集会正法。乃能了知而得听受。佛言普勇。若人于十二殑伽沙数如来应供正等正觉所圆满善根。即得听闻此大集会正法。普勇菩萨复白佛言。世尊。云何能得如是善根圆满。佛言普勇。若能于一切如来平等知见。是即善根圆满。普勇复言。云何能于一切如来平等知见。佛言若于法师尊重恭敬。是即能于一切如来平等知见。普勇又言。而复云何于法师尊重恭敬。佛言若人于出世道发趣向心。是即于法师所尊重恭敬。普勇。如是等皆能圆满善根

佛言普勇。此大集会正法。有大功德利益一切。若人能听受书写读诵者。是人获大福聚不可称计。普勇。正使四方一一方。各有十二殑伽沙数如来应供正等正觉。皆住十二劫。说此大集会正法。听受功德而不能尽。又复四方各有如上殑伽沙数如来应供正等正觉。皆住如上劫。说此书写功德。亦不能尽。又复四方各有如上殑伽沙数如来应供正等正觉。皆住如上劫。说此读诵功德。亦复不尽。普勇菩萨白佛言。世尊。愿佛略说读诵福聚其数几何。尔时世尊。即说伽陀曰

  若人能读诵　　一四句偈者
  彼所获福聚　　与彼八十四
  殑伽沙数佛　　福聚等无异
  何况能一心　　安住于正法
  彼福聚无尽　　诸佛出于世
  宣说无边法　　而实难得值

尔时有十八俱胝尼乾陀众。来诣佛所咸入会中。各坐一面作如是言。瞿昙。我等胜汝。如是三复皆作是言。我等胜汝

是时佛告诸尼乾陀众言。唯佛如来得真胜名。于一切处无能胜者。尼乾陀言。汝一瞿昙云何得胜。佛言。若汝尼乾陀定计胜者。是颠倒见非真实见。汝等以何为胜恣汝等说。是时尼乾陀众。咸一默然互窃相视。佛言汝等当知。唯佛世尊。于一切众生。若已入佛慧。若未入佛慧。利根钝根咸使得度。平等利益无有差别。是可名为无能胜者。汝善思惟。于自身心诸苦所逼尚不能知。云何而能于此称胜。我今示汝诸佛微妙广大正法。诸尼乾陀众闻佛是言已。忽大嗔恚生不信心。是时帝释天主。居善法堂以天眼见。即持金刚杵来入会中。而欲破坏诸尼乾陀众。咸皆惊怖生大忧恼啼泣良久。即时世尊。于大众中隐身不现。诸尼乾陀众。于佛世尊方生瞻仰。忽不见佛转增忧苦。即说伽陀曰

  譬如人独处　　空寂旷野中
  无父复无母　　恐畏无救者
  如江河无水　　游鱼无所依
  树木皆摧折　　飞禽无所止
  我等今怖畏　　苦恼亦如是
  不见佛世尊　　谁为救护者

是时诸尼乾陀众。说是伽陀已欲从座起。彼二膝轮适按地时。其所按地忽发大声。普震一切人天大众。诸尼乾陀咸作是念。如来最胜二足尊者。唯愿慈悲救度我等

尔时世尊。即时现身还复本座。告普勇菩萨言。汝可为诸尼乾陀众说法化度。普勇菩萨白佛言。不也世尊。譬如须弥山王殊妙高显。有小黑山而居其侧。云何可言相与等比。今佛世尊居大众中。遣我说法亦复如是。佛言止止。善男子。如来方便善巧。于十方世界随所说者。皆是如来慈悲愿力之所建立。此诸尼乾陀等欣乐于我。我当为说无上法要。普勇。汝今可往十方世界。亲近诸佛宣扬法化。普勇菩萨白佛言。世尊。我神通力而甚微小。非佛大慈假我神力终不能行。佛言普勇。汝今以自通力及佛神力如是可往。普勇菩萨承佛圣旨。即从座起绕佛三匝。忽于会中隐身不现。尔时世尊。告诸尼乾陀众言。汝等当知。所谓生为大苦。由生苦故起诸怖畏。谓生有病怖。有病怖故而有老怖。有老怖故即有死怖。生何缘怖。谓为众苦之所逼故。以生为因即有诸怖。生法若无怖从何起。由是即有啰惹难怖。陬啰难怖。恶毒难怖。火难怖。水难怖。风难怖。乃至雷雹等难怖。及自作诸不善业怖。如是等怖因生而有。若了生法即离诸怖。是时世尊。为诸尼乾陀众。略说是怖畏法已。时诸尼乾陀众。廓然开悟悔过自责。俱白佛言。世尊。我等愚痴起不正见。背真实道违佛正法深为过咎。愿佛慈悲摄受我等。作是言已。时十八俱胝尼乾陀众。俱发阿耨多罗三藐三菩提心。即时为十八俱胝大菩萨众。一一皆得圆满十地。乃以神通力各现种种神变。及现种种身佛身菩萨身缘觉身声闻身乃至天人龙神一切趣类等身已。复各自变宝莲华座。等分其半于佛左右。礼佛足已。各坐其座

佛说大集会正法经卷第一佛说大集会正法经卷第二

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时世尊。化诸尼乾陀众已。即以方便善巧善说法。心住三摩呬多。舒金色臂经七昼夜。乃至普勇菩萨游十方世界。广作佛事已来还此土。是时普勇菩萨。从彼莲华上佛刹。譬如力士屈伸臂顷。到于佛前礼佛足已。右绕三匝住立一面。是时世尊。出三摩呬多已。普勇菩萨前白佛言。世尊。我承佛旨往彼十方世界。以自神通力。过九十九千俱胝佛刹。以佛神通力。又过百千俱胝佛刹。乃至最后。到下方莲华上世界。其中过八千俱胝佛刹。见彼诸佛现大神通。又过九十二千俱胝佛刹。见诸如来现为众生说深妙法。又过八十千俱胝佛刹。于一时中见八十千俱胝如来应供正等正觉出现于世。我时于彼一一佛前恭敬供养。又过三十九俱胝佛刹。见三十九千俱胝菩萨摩诃萨同时出现。皆证阿耨多罗三藐三菩提。我即于彼初成道者。如是等如来应供正等正觉所。一一恭敬礼拜供养已。即复以自神通力隐身不现。又过六十俱胝佛刹。见诸如来一一恭敬。又过百俱胝佛刹。见彼诸佛入般涅槃。我时还复。一一于彼恭敬供养。从是复过九十五佛刹。知彼如来皆久灭度。所有正法将欲灭坏。我于是时窃自思惟。此佛正法将欲灭坏深为大苦。作是念已生大悲愍。是时复有欲色界天人龙神夜叉等皆大忧恼。又见其中有一佛刹。彼佛正法久已灭尽。劫火炽然从四面起。乃至大地须弥山王。大海江河一切树木。皆悉已焚无所依止。唯一空界荡然无际。过是刹已即到下方。于一世界见百千俱胝如来。各坐宝莲华座。又见四方亦复如是。彼等诸佛。各各现为一切众生说法化度。世尊。我既到彼佛刹已即作是念。今此佛刹名字何等。彼有一佛而告我言。善男子。今此佛刹名莲华上。我时即问化主世尊其名若何。彼佛答言。名莲华藏如来应供正等正觉。我于尔时善皆作礼。一心恭敬作是白言。我今见此百千俱胝那庾多佛。一一皆处宝莲华座。而复不知何者即名莲华藏佛。唯愿示我化主世尊。时彼莲华藏如来于多佛中发是告言。善男子。莲华藏佛即我身是。作是言已。彼诸佛等而各忽然。隐如来身现菩萨相。我当是时唯见化主莲华藏如来。一佛世尊居大众中。相好威神无能胜者。即以头面作礼恭敬。是时彼佛指莲华座而谓我言。善男子。可就此座。我于尔时既就座已即见彼佛。于其左右。复有无量宝莲华座。殊妙庄严甚为希有。忽作是念。如是等座云何皆空无能登者。乃问彼佛。而答我言。善男子。如此等座。皆是不可思议。上妙功德之所建立。非少善根所能成就。若人于佛法分。有未入者。尚不能见。况复能登。我时又问世尊。当种何善根于此等座而乃得升。彼佛答言。善男子。若有人能于此大集会正法暂听受者。以是善根得升此座。何况更能书写读诵常所修习。善男子。汝于过去无量劫来。已能受持如是大集会正法。若不以是善根力故。我此佛刹亦未能到。况复得见此座而欲升耶。彼佛作是言已。我即白言。如是如是。世尊。我复又问彼佛。此大集会正法。有几所功德而能生诸善法

尔时彼莲华藏如来。亦放希有净妙光明。普照佛会已而谓我言。善男子。汝大菩萨得大势力智慧无碍。能于一切诸佛刹土。为诸众生称扬佛事。汝先已曾问彼娑婆世界释迦如来。今以是法还复问我。我当为汝亦分别说。譬如有人于四大洲置以胡麻悉皆充满如是相合都为一聚。是为多不。我即答言。甚多世尊。时彼佛言。假使有人。取一胡麻置于他处。如是从一至一欲知其数。善男子。于汝意云何。是人可能知其数不。我复答言。不也世尊。是人虽竭其力经于多劫。终不能知如是数量。彼佛又言。善男子。此大集会正法。所有福聚亦复如是。非算数譬喻之所能知。正使如上所说数量。一一皆是诸佛如来复经俱胝那庾多劫。称量赞叹此大正法。听受功德亦不能尽。何况有人书写读诵其福甚多。我复又问。若书写者得几所福。愿佛略说。时彼佛言。善男子。譬如三千大千世界所有草木丛林。尽取断为一指节量。一一量数皆是转轮圣王。又如三千大千世界。所有土石尽碎微尘。一一尘数皆是转轮圣王。如是等所有福聚。若算师等欲知其数。汝谓是人知其数不。我时答言。不也世尊。如是福聚。虽算师等亦不能知。彼佛又言。若有书写此大集会正法者。所获福聚亦复如是。复多于彼。算数譬喻所不能知。但能于此正法书写一字。是人所获福聚已胜于彼。况复有人。于此正法受持一四句偈。是人功德不可称计。一切宝藏常所出现。一切烦恼皆得销灭。一切法炬光明普照。一切天魔无能胜者。一切菩萨尽所观察。一切法门皆悉能入。彼佛作是说已。我即白言。世尊。若有众生。能于如是大集会正法修正行者。乃得名为最上梵行。而彼梵行即如来行。若勤修习无间断者。是人即得百佛如来于昼夜中常现在前。若见如来即入佛刹。入佛刹已。一切法藏皆能了知。我于尔时作是言已。彼莲华藏佛又告我言。善男子。诸佛如来时一出现。若得遇者是亦为难。说此正法复甚为难。得闻持者转复甚难。何以故。若有闻此正法者。是人于六十万六千八十劫中。或得宿命智。或为转轮王帝释净光天大梵世主等能不坏正信。不堕诸恶趣。不生阿修罗。无刀杖斗诤。又复远离愚痴得大智慧。相好端严犹如诸佛。一一色相等无有异。不为眷属痴恼所缠。常离病苦。常得天眼。不为那誐。不生嗔恚。又常远离一切贫窭。为铜轮王受大快乐。诸根圆满忍辱具足。乃至临命终时。正念现前心不颠倒。即时东方有十二殑伽沙数佛面现其前。南方有二十殑伽沙数佛。西方有二十五殑伽沙数佛。北方有八十殑伽沙数佛。上方有九十千俱胝佛。下方有百俱胝佛。如是等诸佛皆为现前。安慰其人咸作是言。汝善男子。勿生怖畏。汝先已能有大功德而为依怙。汝今见此百千俱胝那庾多殑伽沙数佛世尊不。彼答言见。时诸佛言。善男子。此诸如来。以汝功德力故俱来至此。彼人复言。我今以何善根力故而获如是。彼诸佛言。以汝久闻大集会正法大善根力。彼人又言。如我一人得闻正法。尚获如是无量功德。何况能令尽有情界普得闻知。时莲华藏如来广说。彼临命终人见诸佛已。又告我言。善男子。若人得闻此大正法一四句偈者。与彼供养十三殑伽沙数如来应供正等正觉。所获福聚等无有异。又若有人。得闻此大集会正法者。所有福聚。譬如遍满三千大千世界悉置胡麻。是等麻量一一皆是转轮圣王。假使有人。以诸珍宝各行布施。如是轮王所获福聚。不如唯施一须陀洹。若施一须陀洹。不如施彼遍满三千大千世界如前数量须陀洹。若施如是须陀洹。不如施一斯陀含。若施一斯陀含。不如施彼遍满三千大千世界如前数量斯陀含。若施如是斯陀含。不如施一阿那含。若施一阿那含。不如施彼遍满三千大千世界如前数量阿那含。若施如是阿那含。不如施一阿罗汉。若施一阿罗汉。不如施彼遍满三千大千世界如前数量阿罗汉。若施如是阿罗汉。不如施一缘觉。若施一缘觉。不如施彼遍满三千大千世界如前数量所有缘觉。若施如是缘觉。不如施一菩萨。若施一菩萨。不如施彼遍满三千大千世界如前数量所有菩萨。若施如是菩萨。不如于一如来发净信心布施供养。若于一如来信心供养。不如于彼遍满三千大千世界如前数量一切如来信心供养。虽于如是一切如来信心供养。不如有人于此大集会正法暂得闻持。所获福聚倍多于彼。何况更能书写读诵。如是功德不可称计。是时彼佛又告我言。善男子。汝可于此正法发净信心宣扬流布。诸凡夫类于此正法不能得闻。设有闻者生疑不信。如何能入此大法聚。譬如有人入于大海。而欲尽见其水边际。汝谓是人而能见不。我即答言。不也世尊。又如有人临于大海。以手勺水欲尽枯涸。汝谓是人而能成不。我复答言。不也世尊。是等愚人。虽于海水欲知边际欲尽枯涸。终不能就徒自疲劳。深为大失。时彼佛言。诸凡夫类亦复如是。于此正法不能听受。于生死海妄生颠倒增长愚痴。深为太失。是人虽经百千俱胝那庾多如来应供正等正觉出现于世。不种善根。不得见佛。不闻是法。不为诸佛之所护念。若有智者。能于百千俱胝那庾多佛所发净信心。见彼诸佛生大欢喜。乃从诸佛得闻是法。闻是法已即如实知不生轻谤。是人得大善利。即为诸佛共所护念。若人于此正法。能听受书写一四句偈者。是人当生过九十五千俱胝佛刹已。得生极乐世界佛闻法。寿命八万四千劫。彼莲华藏佛复告我言。若人于五逆罪。或自所作。或教他作。或见闻随喜。是人当受五无间苦。若有得闻此大集会正法一四句偈。即得销灭如是等业。是时彼佛。即复为我宣说伽陀

  汝今听我说　　闻此经功德
  往劫有一人　　具造五种业
  谓杀父害母　　破和合僧伽
  毁菩萨三昧　　坏如来正智
  彼人作是罪　　后即生追悔
  忧恼复啼泣　　心生如是念
  我造众恶业　　非唯坏此身
  后世及多劫　　其身皆破坏
  从苦生于苦　　苦受转复深
  远离众善友　　为世所轻诮
  世出世间法　　我悉皆已焚
  无量劫善因　　破坏不增长
  如世间舍宇　　众彩所庄严
  而忽为火焚　　人皆绝爱乐
  我作罪亦然　　此世与他世
  为业火所焚　　自他非爱乐
  在在世所生　　人讥骂捶打
  常贫困饥渴　　苦恼众所侵
  如是等报应　　非别因所感
  皆从五业生　　不善果无失
  我今苦既然　　谁为救护者
  亲友力不能　　一切无依止
  复作是思惟　　我不如今时
  往彼高山顶　　坠身终此命
  免增长恶业　　转生于苦恼
  此世及他世　　为恶业所坏
  内既无依怙　　身外亦复然
  现为过失因　　当受极恶报
  彼作是念已　　而复自啼泣
  即时虚空中　　有天人告言
  悲哉汝愚痴　　心生诸苦恼
  无归复无救　　汝自作五业
  杀父害母等　　苦恼今自受
  何故作是思　　欲高山殒命
  我今劝于汝　　勿起愚痴见
  但生悔过心　　何须损身命
  贪嗔痴三毒　　从汝心所生
  恶趣中苦恼　　无由得免离
  虽欲绝身命　　不得名精进
  此处命速尽　　后恶报速生
  汝今听我言　　为汝设方便
  佛菩萨圣道　　汝未能趣向
  今可往一山　　仙人修行处
  汝当亲敬礼　　彼能为救护
  有最胜方便　　谓上妙正法
  能离诸怖畏　　销除极恶业
  彼人于是时　　闻空中言已
  即诣于山中　　仙人修行处
  到已见一仙　　即时头面礼
  合掌白是言　　愿仙救护我
  我怖畏苦恼　　造极重五业
  必堕于恶趣　　云何得免离
  我于昼夜中　　饮食及坐卧
  常忧生苦恼　　暂时无少乐
  我今于仙人　　生信心尊重
  如我所问者　　愿仙为我说
  我造众恶业　　如何得销灭
  时彼仙答言　　汝问我当说
  是时彼仙人　　食已濯手足
  即跏趺而坐　　听彼亲自首
  彼人时右绕　　礼仙而退坐
  白言我愚痴　　杀父及害母
  破和合僧伽　　毁菩萨三昧
  坏如来正智　　造此五种业
  彼仙闻是说　　即时而谓言
  汝实不善人　　作如此等罪
  彼人闻仙言　　又复生忧恼
  恐畏无所救　　必当堕恶趣
  是时从座起　　礼彼仙人足
  转复生恭敬　　作如是白言
  仙人悲念我　　极重恶业者
  疑惑苦恼深　　唯愿作依怙
  我虽如是悔　　无出离方便
  仙人大慈悲　　令我罪销灭
  仙闻是说已　　安慰彼人言
  汝今勿怖畏　　我能为救护
  一心开导汝　　令汝离众苦
  得重罪销灭　　我即是所归
  佛有妙法门　　名为大集会
  是最上方便　　汝昔曾闻不
  彼人答仙言　　我昔未曾闻
  仙人复告言　　哀哉罪业者
  如人火已焚　　谁当为说法
  我今以悲心　　示汝微妙法
  汝今当善听　　我念往昔时
  过无量无边　　阿僧祇数劫
  时有一啰惹　　无垢月为名
  眷属甚炽盛　　以正法治世
  啰惹于一时　　而生育一子
  即令召相师　　观彼善恶相
  乃问相师言　　今我此一子
  为善为恶相　　汝观当云何
  相师前白言　　怪哉此一子
  如我所观者　　其相极不善
  啰惹复谓言　　不善相云何
  如汝所观相　　谛实为我说
  相师作是白　　此子至七岁
  当起痴害心　　断于父母命
  啰惹复告言　　其相虽如是
  宁弃我身命　　此子终不坏
  我若弃是者　　当不复人趣
  即令诸眷属　　善养育我子
  其后彼童子　　不久渐长大
  是时无垢月　　忆彼相师言
  即生如是念　　今我业恐至
  有何所吝惜　　既作是念已
  乃敕令童子　　汝今继我位
  复谓童子言　　汝今当谛听
  今我此境界　　广大复殊异
  如日月照世　　富贵而自在
  今我此提舍　　悉当付于汝
  我于此境中　　不复为所有
  时诸臣仆等　　忽闻是事已
  来诣无垢月　　咸作是白言
  我尊今何故　　弃舍于境界
  其事知云何　　愿尊为我说
  无垢月答言　　汝等今当知
  付提舍与子　　亦非无因缘
  我念于往昔　　啰惹名莲华
  境界甚广大　　自在而富贵
  而彼于一时　　亦生于一子
  其年渐长大　　即害其父母
  我今若不以　　此提舍与子
  当如彼莲华　　受无量苦恼
  我常自思惟　　不应生后悔
  以是因缘故　　我今当付彼
  是时彼仙人　　为造五业者
  说是因缘已　　复告彼人言
  汝今造五业　　极重过于彼
  我生悲愍心　　为汝设方便
  汝可诣佛所　　听大集会法
  若得听受者　　罪业皆销灭
  所有烦恼障　　悉皆得无碍
  以闻正法故　　免堕于恶趣
  若人能一心　　听大集会法
  一四句偈者　　获无量福聚
  灭五逆重罪　　得广大果报
  一切诸盖缠　　刹那能解脱
  时彼造业人　　闻仙所言已
  即合掌恭敬　　一心头面礼
  作如是赞言　　善哉善知识
  能引示于我　　大集会法门
  仙人说此已　　时有万二千
  诸天子众等　　来诣仙人所
  各恭敬合掌　　头面礼仙足
  复有四俱胝　　诸大龙王众
  亦来诣仙所　　以头面礼足
  又有万八千　　俱胝夜叉王
  来诣于仙所　　亦头面礼足
  俱白如是言　　善哉大仙人
  深了诸佛法　　善开天界门
  及灭亿僧祇　　三涂受苦趣
  称扬大集会　　微妙最上法
  有殊胜功德　　能息诸重罪
  若人于一偈　　随喜而听受
  乃可得名为　　深种善根者
  何况更一心　　生尊重恭敬
  以华鬘涂香　　栴檀末香等
  珍宝盖幢幡　　供养此正法
  自作及劝他　　见闻生随喜
  所获诸福报　　广大无有穷
  善哉汝仙人　　真实具悲者
  天子龙王众　　及夜叉王等
  作是称赞已　　礼仙而不现

尔时普勇菩萨。于释迦牟尼佛前。广说莲华藏如来称赞大集会正法如是功德已。合掌恭敬前白佛言。世尊。若复有人。于此正法但能合掌顶礼恭敬。所获善利而复云何。佛言普勇。是人所获福聚亦复无边。譬如无热恼池龙王所居。而彼宫殿日所不照。有五大河。池水流出无有穷尽。假使有人欲知池水一一滴数。汝谓是人而能知不。普勇白言。不也世尊。佛言。此大集会正法。所有善根广大无比亦复如是。假使有人。欲知此法功德限量。纵经千劫终不能尽。又复普勇。此法甚深难解难了。一切如来所共尊重。若复有人须臾听受。即得如是广大利益。普勇菩萨复白佛言。世尊。彼五大河其名何等。佛言五大河者。所谓殑伽河。细多河。嚩刍河。阎牟那河。赞捺啰婆誐河。此五大河。一一各有五百小河而共围绕。其水流注入于大海。彼五大河一一河中。而复各有一大龙王。所谓欢喜龙王。商珂龙王。嚩汉底龙王。唧怛啰西那龙王。法思惟龙王。如是等龙王。各与一千眷属俱。于阎浮提时降甘雨。百谷苗稼皆悉滋茂。乃至山川溪壑林薮泉池。花卉果蓏枝叶根茎。雨之所及无不丰足。普勇当知。若有众生于此正法。起不善语业而生轻谤。彼所获罪无量无边。又复若有众生于此正法。发善语业而行赞叹。彼所获福聚亦无量无边。是人即能亲近善友。得见如来。若得见佛。即能销灭一切罪障。普勇。譬如四大洲中有铁轮王为一洲主。威猛自在广大快乐。复能利益一切人民。今此大集会正法亦复如是。于阎浮提中。为诸众生作大利益。若不得闻此正法者。是人不能成就阿耨多罗三藐三菩提。不能住菩提场处师子座转大法轮击大法鼓。亦复不能入涅槃界放大光明普照世间。普勇菩萨复白佛言。世尊。彼莲华上世界。莲华藏如来所说仙人。而能令彼造五业者得灭重罪。我实不知居何等位。愿佛慈悲当为开示。佛言普勇。彼仙人者已得不退转地。久已成就大集会正法。普勇当知。诸佛语言甚深微妙。若有闻此正法深生信受。是即见彼仙人。亦同见彼殑伽沙等诸佛如来殊妙色相。诸佛爱敬诸佛称赞。常所安住诸佛三昧。而能通达如是大集会正法

佛说大集会正法经卷第二佛说大集会正法经卷第三

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时世尊。告普勇菩萨言。汝今谛听我念过去无量无数阿僧祇劫前。值遇十二俱胝如来应供正等正觉。同名宝上我于尔时修勇施行。即以饮食衣服殊妙庄严珍宝璎珞及诸华鬘涂香等。一一供养彼等诸佛。时诸如来。皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇十八俱胝如来应供正等正觉。同名宝光。我亦是时修勇施行。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念。过去劫中。值遇二十俱胝如来应供正等正觉。同名顶生。我亦是时修勇施行。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念。过去劫中。值遇二十俱胝如来应供正等正觉。同名饮光。我亦是时修勇施行。亦以如上诸供具等。一一俱养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇十六俱胝如来应供正等正觉。同名无垢光。我亦是时修勇施行。为大长者甚大财富。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇九十五俱胝如来应供正等正觉。同名能寂。我亦是时修勇施行。为大国王能以正法治于一切。自在快乐世财无量。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇九十俱胝如来应供正等正觉。同名作庄严。我亦是时修勇施行。为婆罗门有大宝聚。于一时中尽舍所有。办如上等诸妙供具。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇十八俱胝如来应供正等正觉。同名金仙人。我亦是时修勇施行。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇十三俱胝如来应供正等正觉。同名吉祥光。我亦是时修勇施行。亦以如上诸供具等。一一供养彼等诸佛。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇二十五俱胝如来应供正等正觉。同名妙华。我于尔时初发信心。出家修道常行精进。于如是等诸如来所。一一恭敬承事供养。如彼阿难等无有异。时诸如来亦皆与我授阿耨多罗三藐三菩提记。普勇。我复又念过去劫中。值遇十二俱胝如来应供正等正觉。同名胜观。我时于彼亦复出家。是时阎浮提中所有众生悉皆大富。七宝具足快乐无碍。无一众生受不足苦。彼诸佛等既出于世。广为众生宣说大集会正法。我时于彼诸如来所。恭敬尊重承事供养。求授阿耨多罗三藐三菩提记。时诸佛等皆不与我授记。我即白言。诸佛世尊。我于何时当得授记。彼诸佛言。善男子。汝从是过阿僧祇劫。有佛出世号曰然灯。彼佛世尊当授汝记。我时闻是诸佛言已。修菩萨行转复精进。即时又过阿僧祇劫。然灯如来出现于世。我时于彼为摩拏嚩迦名为胜云。修诸梵行得见彼佛。生大欢喜恭敬尊重发希有心。即持优钵罗华七茎。供养彼佛。作是愿言。愿我以此善根。回向阿耨多罗三藐三菩提。是时燃灯如来。于大众中与我授记作如是言。善男子。汝于未来世过阿僧祇劫当得成佛。名释迦牟尼。十号具足。我于尔时得授记已。于彼佛前踊身虚空。高十二多罗树。却复于地一心欢喜。即时证得无生法忍。普勇当知。我于如是无数劫中。修诸梵行种诸善根供养诸佛。皆为圆满诸波罗蜜故。自圆满已。复令无数百千俱胝那庾多众生悉皆圆满。如是一切诸波罗蜜法。我于今日。已得成就阿耨多罗三藐三菩提。普为众生广大宣说最上甚深微妙法门。若有众生乐见诸佛。即现佛身而为说法。若有众生乐见菩萨。即现菩萨身而为说法。若有众生乐见缘觉。即现缘觉身而为说法。若有众生乐见声闻。即现声闻身而为说法。又复若在天趣。即现天身而为说法。若在人趣。即现人身而为说法。若在龙趣。即现龙身而为说法。若在夜叉趣。即现夜叉身而为说法。若在鬼趣。即现彼身而为说法。随诸趣类一切众生彼彼色相而为现身。以善方便为宣妙法。使无怖畏令深信解。普勇。我今何故以诸方便。现种种身而为说法。以诸众生闻是法已。于胜义谛得大总持。观诸世间起无常想。常念修行一切善法。而能究竟离诸杂染。真实善根无所损减。我于长夜以是方便。利益安乐一切众生。普勇。如我上说。此大集会正法。有如是功德。于此会中有生疑者互相谓言。正法果报为有耶为无耶。阿耨多罗三藐三菩提为可得耶。为不可得耶。一切众生为能度耶。为不能度耶。有作是言。如佛所说。诸法实有因能生果。果必从因。种善因者善法何失。有作是言。诸法非有果报亦无。因本自空何能有果。因果既无妄言归趣。普勇。一切众生差别心行。明暗相违因果自异。彼正说者起真实见。是即名为建立正法。此人福报汝今听说。二十劫中不生北俱卢洲。二十五劫中皆生三十三天。彼天报尽乃生百千诸佛刹中。见彼诸佛听闻正法。是人不复退转于阿耨多罗三藐三菩提。彼邪说者起断灭见。是即名为破坏正法。此人罪报汝今复听。从此命终生大地狱受苦一劫。如是一劫而复一劫正满八劫。一一别生一大地狱。于如是等八大地狱受大苦已。复于九千二十八劫中。尚于三恶趣。展转复生受大苦恼。过是劫已虽得人身。于万六千劫中死母胎藏。万四千劫中舌根不具。万二千劫中为莽娑宾拏。万一千劫中生便无目。普勇当知。一切众生无有穷尽。若此界若他界。若生缘若死缘。若是处若非处。若可意若不可意。唯心造作随业发现。或有众生修诸善法得生天趣。或有众生为菩提故修诸行愿。或有众生渐得究竟无上寂灭。以是因缘。诸佛如来。为无数百千俱胝那庾多众生。若已发趣若未发趣。若天人龙神等说法化度。于刹那顷无有休息。尔时世尊当说法时。复有八万四千婆罗门众。九十千俱胝外道尼乾陀等众。互相议言。今沙门瞿昙。居王舍城鹫峰山中。普会大众知说何等。我等今者可共往彼相与论义。正当是时诸婆罗门外道既相议已。乃与无数眷属来诣佛所。是时世尊。即于会中。放大希有净妙光明普照大众。时慈氏菩萨摩诃萨即从座起。偏袒右肩右膝着地。合掌恭敬前白佛言。世尊。非无因缘而放是光。今此大众咸欲闻知。愿佛慈悲为我等说。佛言善男子。汝今当知。今此会中有无量众皆来集会。慈氏菩萨复白佛言。世尊。为何等众。若天众耶。若人众耶。若龙神夜叉等众耶。佛言慈氏。如汝所言皆来集会。复有诸婆罗门外道尼乾陀等众。来入会中与我论义。既调伏已。我即当为如应说法。彼八万四千婆罗门。九十千俱胝外道尼乾陀等众。皆发阿耨多罗三藐三菩提心。慈氏。复有万八千俱胝龙王众。来入会中闻我说法已。亦皆发阿耨多罗三藐三菩提心。复有六万俱胝净光天子众。三万二千俱胝诸天魔众。万二千俱胝阿修罗众。如是等皆来入会听受正法。复有诸大国王。所谓欢喜王。妙喜王。最上喜王。人仙王。净军王。梵音王。善现王。爱军王。喜军王。妙色王。胜军王。增长王。如是等五百大国王。各与千俱胝眷属俱。皆来入会听受正法。一一皆住坚固阿耨多罗三藐三菩提心。慈氏。以是因缘放此光明

尔时慈氏菩萨。闻佛说是大众集会。于天人非人等中。有发阿耨多罗三藐三菩提心者。有闻正法生信受者。生大欢喜礼佛足已右绕三匝。即于会中隐身不现。是时诸婆罗门外道尼乾陀左啰迦波哩没啰惹迦。若天若龙。乃至五百大国王等。到佛所已随自修敬各坐一面

尔时东方有三万俱胝大菩萨众。东南方亦复如是。南方有五万俱胝大菩萨众。西南方亦复如是。西方有六万俱胝大菩萨众。西北方亦复如是。北方有八万俱胝大菩萨众。东北方亦复如是。上方有十万俱胝大菩萨众。下方有九万俱胝大菩萨众。如是等十方诸大菩萨众。一一皆已圆满十地。随方而来入佛会中。到佛所已各各头面。礼世尊足退坐一面

尔时世尊。告普勇菩萨言。普勇。汝今复往十方世界。宣示诸菩萨众。作如是言。如来今日当为众生宣说大集会正法。令彼十方一切菩萨合掌顶礼生随喜心

尔时普勇菩萨承佛圣旨。即以头面礼世尊足右绕三匝。忽于会中隐身不现。遍往十方世界。随一一方发大音声。作是唱言。今娑婆世界释迦牟尼如来。当为众生宣说大集会正法。如是三复皆唱是言。今娑婆世界释迦牟尼如来。当为众生宣说大集会正法。是时十方诸佛及诸菩萨。皆闻是言各各称赞。善哉善哉。释迦牟尼如来。能与众生利益安乐。及赞普勇菩萨。能于十方世界宣扬佛事

尔时普勇菩萨。遍于十方世界。宣示诸大菩萨已。一弹指顷还复此土住立佛前。礼世尊足退坐一面。是时四方有四风神王来入会中。尽王舍城所有境界过百由旬。悉令清净无诸尘秽。帝释天主持金刚杵来入会中。诸魔外道慑然而视十方世界。于虚空中布大香云降大香雨。沉水栴檀不可为喻。又复雨众天华。所谓优钵罗华俱母那华。奔拏利迦华等。种种妙华。住于空中变成伞盖。又于佛上变作八万四千楼阁。一一皆是七宝所成。众彩杂饰殊妙庄严。又于空中现大宝座无量无边。一一座上悉皆有佛。现为众生宣说妙法。时彼三千大千世界六种震动

尔时普勇菩萨摩诃萨。合掌恭敬前白佛言。世尊。以何因缘于虚空中。现斯瑞相甚为希有。而彼大地忽然震动。愿佛慈悲当为宣说

佛言普勇。今此会中十方诸大菩萨。及天人龙神等皆悉来集。我今当为宣说正法。又复为诸外道。破彼邪心令归正见。以是因缘故现斯瑞。普勇当知。诸凡夫类虽得值遇如来应供正等正觉出现世间。不能于佛殊妙色相。起尊重心生难遭想。设得闻佛宣说正法。不能依法修行。复生取相起我慢心。暂得听闻妄生多解。而复起于易所得想。疑惑不信作如是言。如佛所说若契经若祇夜。我昔不闻知何所说。我今不能听受记念。我于诸法悉自了知。此人以是迷惑心故。恣己愚痴违背佛法作罪业因。自造经书撰集义理。于世间中而为正说作如是言。我所造集是巧便智。转劝他人使令修习。虽复以己所造经书劝人修习。设使种种方便。终不能令一补特伽罗而获利乐。于多生中自坏其身。业因缘故临命终时受大苦恼。普勇。此诸外道起迷惑心。生不正见不能解脱。如彼初生飞禽未生翅羽其何能飞。说能飞者是为虚诳。此外道辈若不回心归佛正法。其何能得究竟无上清净涅盘。彼常自计为涅盘者亦为虚诳。何以故。此外道辈造不正因起戒禁取。破坏自身断灭正法。坚着我见无由解脱。设得人身尚非胜报。云何实得清净涅盘。于其自身犹未能知。本何所来当何所往。生灭唐捐受诸苦恼。增长恶趣无有休息。我观是辈深可悲愍

尔时世尊作是说已。告诸外道尼乾陀等言。汝等当知。阎浮提中有大珍宝。无能护者随意当用。我所宣说是大法聚。诸有求者无所吝惜。汝等若有疑惑及所希求当恣汝问。如来大悲一一为汝分别开示

尔时诸外道尼乾陀等各从座起。合掌向佛作是问言。世尊。佛于长夜度诸众生令出轮回。云何众生生灭相续无有间断。我于是事不能了知。愿佛宣说

尔时世尊即于会中。告药王军菩萨言。今此会中诸外道辈。以我大法光明威神照故渐能开解。被精进铠息疑惑心。能以此义问佛世尊。药王军。一切生者略有二种。一者久生。二者初生。譬如有人富贵自在。忽于一时以水沐发。复以鲜洁上妙衣服。而为严饰乃出其舍。时有贫人见已欣乐。即自还家亦沐其发。复以故衣洗濯令净。是人虽复多汲其水。濯彼故衣徒使疲劳。终不能令服饰新好。一切生中。若久生者同彼贫人。濯其故服终不能净。若初生者如彼富人。衣新好衣未生尘垢

尔时诸婆罗门外道尼乾陀等。闻佛作是说已即白佛言。何者初生。何者久生。佛言彼六趣中相续展转。受苦众生名为久生。何以故。此等众生于六趣中。不生厌离不求解脱。时诸婆罗门外道等。复白佛言。世尊。如佛所说。久生众生于轮回中。受诸苦恼不能解脱。初生众生愿佛显示。作是言已。尔时忽有九十四千俱胝摩拏嚩迦。来入会中。于世尊前不伸礼敬。复无所问默然而住。是时药王军菩萨。见是事已即白佛言。世尊。何因缘故。今此辈等来入佛会。而不礼敬复无所问。其事云何。佛言药王军。此诸摩拏嚩迦是初生者。于佛世尊未有所问。是时彼诸摩拏嚩迦。即作是言。世尊。我等是初生者。佛言。如是如是。汝等初生如日初出。光明普照遍于一切。无量众生所共瞻睹。汝等久于佛道心已成熟。诸菩萨法昔已通达。虽名初生而久修习。是时九十四千俱胝初生摩拏嚩迦。即各踊身虚空从空中下。一一皆得圆满十地

尔时药王军菩萨。合掌恭敬生希有心。前白佛言。世尊。此等众生得大善利。久已尽彼轮回苦恼具大精进。是名初生。今日见佛于刹那间即得解脱。是时诸婆罗门外道尼乾陀等众中有诸盲者。以闻法故忽见光明。各得观佛殊妙色相。见佛相已咸作是言。如来应供正等正觉。是最胜师我等归依。即起合掌生净信心。俱白佛言。我等今者得见世尊。佛言。汝等应当重复审谛。观佛如来殊善色相。汝等当知。汝等今者。诸善根力已成熟故得见世尊。又得听闻大集会法。是时诸盲外道。得是利已生大欢喜。各各皆发阿耨多罗三藐三菩提心

尔时会中诸婆罗门外道尼乾陀等。闻佛说法。亦皆发阿耨多罗三藐三菩提心。证得无生法忍。悉皆圆满十地。即时又成大菩萨众。乃各踊身虚空高七多罗树。于其空中各现种种神通变化。及化种种华鬘璎珞。伞盖幢幡七宝楼阁等。住于佛上而为供养。各作是念。今我此身从佛智生。从正法生。一切如来是真归处。作是念已从空而下。礼世尊足退住一面

是时会中有无数百千天子。见是事已。即说伽陀

  我佛大沙门　　得最上善利
  于一切世间　　最尊无与等
  三摩地愿力　　皆悉已具足
  一切胜义法　　无余不知者
  一切众生类　　无始轮回苦
  佛善巧方便　　普令得解脱
  婆罗门外道　　咸得大利乐

佛说大集会正法经卷第三佛说大集会正法经卷第四

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时药王军菩萨摩诃萨从座而起。益加恭敬。膝轮着地礼世尊足。礼已合掌前白佛言。世尊。以何因缘。此诸菩萨能于空中现诸神变。于如来前现诸色像。佛言谛听。药王军。此诸善男子。已得一切如来共所摄受。不久即成阿耨多罗三藐三菩提。处大法座转妙法轮。以法光明普照群品。以是因缘能为变化

是时药王军菩萨复白佛言。如佛世尊于长夜中。度脱三界一切众生其数甚多。云何是等无有穷尽。佛言。善哉善哉。药王军。譬如有人以诸谷麦而为种莳。各各分别而无间杂。其后依时彼诸种子皆悉成熟。是人即时次第而收。若谷若麦亦无间杂。如是展转收已复种。种已复收无有穷尽。药王军。此诸众生亦复如是。业因缘故布诸种子。若善若恶无有间杂。后时成熟受诸果报亦无间杂。如是展转生已复生亦无穷尽

药王军。诸有修习菩萨行者。能布一切善法种子。一一成熟。既成熟已即能出生一切善法。善法生已生大欢喜爱乐佛法。彼善法种虽经多劫终无能坏。药王军。当知是名初发心菩萨。而彼所得一切善法。聚集了知转倍增胜。虽复梦有所见。而能离诸怖畏。何以故。一切业障悉得清净。不造恶法离诸苦恼。恶境现前而不能动。若于梦中见大火聚光焰炽盛。菩萨见已不生怖畏。何以故。诸烦恼薪为智慧火之所焚烧。无能乱故。又于梦中若见大水。而不清洁彻底浊秽。菩萨见已亦不生怖。何以故。已尽一切所作业故。如牛撤轭而得自在。又于梦中持以利刀。自断其头复断他头。菩萨尔时亦不生怖。何以故。贪嗔痴法诸烦恼中而为根本。菩萨已断无所惧故。药王军。彼初发心菩萨于六趣轮回已得解脱。而复于中随顺受生。皆是菩萨以方便力。示现化度一切众生。而实菩萨常生诸佛清净刹中。一切如来所共摄受

药王军。汝今当知。于后末世若有众生。能发回向菩提心者。是即安住一切佛智。得见诸佛圆满善法。永不复生诸疑惑心。药王军。我于无数百千那庾多劫。勤行苦行修诸善法。于一切法觉了自性。即得成就阿耨多罗三藐三菩提。既圆满已复以方便善巧智慧广说诸法。令诸众生得生诸佛清净刹中受胜妙乐。而能了知诸灭道法。了知胜妙诸根本法。了知胜妙善处法。了知胜妙神通法。了知胜妙善处寂灭法。药王军。所言灭者其义云何。药王军菩萨言。世尊。所谓法处。佛言。法处者何。药王军菩萨言。其法处者。所谓精进持戒二法。若已发起。若未发起。戒行具足。是名法藏。世尊。诸法从是法藏所生。佛言。善哉善哉。药王军。于如来前能答是义。药王军菩萨复白佛言。世尊。诸佛如来以何义故出现世间。佛言药王军。诸佛出世。为欲令诸众生持戒多闻得具足故。令悉了知胜妙乐处故。令于一切胜妙法门通达趣入故。入是法门已即能广修一切善法。以方便力增长善根。于世出世最胜妙法皆悉通达。药王军菩萨白佛言。世尊。云何名出世法。佛言药王军。出世法者所谓涅槃法。若了诸法自性。是即了知涅槃胜法。彼诸法者即正法蕴。若于是法如实而知。如实而证。于出世法中是为第一。药王军。诸异生类。于佛世尊深妙法中。自不生信趣向修习。亦复不能转劝他人。此等异生身坏命终。而无善法为所依怙。药王军。汝今谛听。我念往昔有一商人。为求利故借千两金。欲往他国而为贸易。其人父母以爱念故谓其子言。此等金宝非己所有。若自持往或时散失苦恼倍增后悔何益。是时其子反生恚恨不听是言。即负此金便往他国。既至彼已时分未久。其所负金皆已散坏。复无所得渐不能住。即便追悔生大苦恼。其人后时虽复还国不自归舍。以苦恼心生大疾病。时彼父母知子虽还不便归舍。又闻金宝皆已散坏。忧愁迷闷窃相谓言。此非我子是大恶友。破坏我族悉使贫匮。复致他怨何所依赖。我等今者作何方便得免斯苦。是时父母以忧苦故。厌己身命欲自殒灭。时彼商人既闻父母忧恼如此。即便还家向彼父母哽然而住。父母忽见其子。顿失前怒即同谓言。我子何能受斯病苦。我闻是事恐汝命终。汝今既来宽我忧虑。时彼商人告父母言。我身与心苦恼如是。支节痛逼命将不救。何以故。我于今时眼不欲视。耳不欲闻。心识迷闷众苦所集。设使父母如何救护。父母告言。我子于此勿生怖畏。汝命未尽我皆救汝。汝今苦恼必是虐疾。心识迷乱妄有所见。时子答言。我非虐疾亦无所见。诸可爱境皆不现前。唯见死苦大可怖事。定趣命终无能救者。父母告言。我子所苦。多是天神所持。世间诸有被执持者。皆诣天祠以求救护。若如是者方得脱免。子言可尔。是时父母持以妙香即诣天祠。既至彼已告守门者。引至天前焚香启愿祈求悔谢。时守门者谓父母言。汝若欲子病得脱免。天神欢喜。当设祭祀必获如意其所祭物。法应当须断一人命。及一钵戌方名为祭。是时父母闻彼言已共相谓言。我今若不祀彼天神。我子何由得免斯苦。然我今者家复穷困。何能办彼祭所须物。宜共还家作诸方计。既相议已即便还家。尽其家中一切所有。而为贸易得一钵戌。复共出舍诣一富人作是告言。我今求贷黄金少分。当期十日即便归还。若违是言过十日者。我皆以身为君婢仆。作是言已富人即与。时彼父母既得金已不复还家。即持是金而得一人。其所鬻人不知何作。即随其主诣彼天祠。至天祠已谓守门者言。我等今者持所祭物来祀天神。守门者言。汝当随意。时彼父母于天神前焚香启愿作如是言。愿我此子病苦得免。天神欢喜。言已即时以所祭人及彼钵戌。自手断命而为祭祀。其所祭人当断命时。既被持缚无所能避。唯念诸佛一称是言。那谟没驮耶。言已命断时彼天神受其祭已诳父母言。汝子所疾是我所执。我今放舍令子得脱。是时父母闻其言已。欢喜踊跃拜谢而出。父母相庆互相谓言。我子从今既得病愈。又复决定而得长命。我等今者虽复无金。可还富人当如本言。为彼婢仆而无所恨。是时父母方共言议。未及还家忽逢人告。子命已尽。时彼父母一闻是言。生大苦恼俱死躄地。佛言药王军。我观世间愚痴异生惑业所缠。不善知识共相集会。互为衰损亦复如是。此等异生身坏命终堕于恶趣。受大苦恼无能救护

药王军菩萨白佛言。世尊。如佛所说祀天神者。此等异生死堕何处。佛言药王军。止不须问。药王军复白佛言。世尊。我等众中有乐闻者愿佛为说。佛言药王军。汝今当知。时彼父母既命终已。俱堕众合地狱受大苦恼。时彼子者堕炎热地狱中受大苦恼。彼天祠中为守门者。以导引故见作随喜。命终已后堕阿鼻地狱受大苦恼。药王军复白佛言。世尊。彼所祭人当生何处。佛言药王军。此人命终生三十三天。六十劫中受胜妙乐。药王军复白佛言。世尊。此人以何因缘得生于彼。佛言药王军。此人临命终时。纯善相应发净信心。归依如来一称那谟没驮耶故。是人即为深种善根。又复于八十劫中得宿命智。在在所生离诸烦恼息一切苦

尔时药王军菩萨前白佛言。世尊。诸有众生。乐欲趣证涅盘法者。当修何行。佛言药王军。当修精进行勇猛坚固。药王军言。云何名精进行。又于何处而能发起。佛言。精进行者。于诸果法而不懈退。是名精进行。精进处者。所谓预流果名精进处。一来果名精进处。不还果名精进处。阿罗汉果名精进处。缘觉果缘觉智果名精进处。菩萨果菩萨智果名精进处。药王军。诸修菩提者。于如是等处。而能发起广大精进

尔时佛告药王军菩萨言。我念往昔。于一时中有一摩拏嚩迦。于平实地才种一树。即生芽茎枝叶华果光润可爱。其树盘根广一由旬。于少时间悉皆具足。次复有一摩拏嚩迦。寄前树侧亦种一树根才置地。忽为大风之所偃拔。芽茎枝叶尚不能生。况复华果而能成就。彼次种树人见是事已。即移其树欲种他处。是时先种树人作如是言。云何于我平实地上而致破坏。彼次种树人言。我今自为移所种树。非特破坏汝平实地。如是往来互相诤竞。是时有人潜告于王。王既闻已敕令往捉。使者奉命奔至于彼。时二诤人各大惊怖。使者执持来至王所。是时王问彼二人言。汝等何故互相诤竞。先种树人具如实说。次种树者作如是言。大王当知。我为自无地土种植。暂于此人借地种树。我所种者为风所拔根不能固。至于芽茎枝叶华果皆不能生。此人种树于少时间即生芽茎。枝叶华果悉皆具足。又复盘根一由旬量。我见是事内自羞愧。即移其树欲种他处。彼获如意而复生嗔。以是缘故共相诤竞。愿王察我无赐罪罚。时王即敕召集臣寮。是时诸臣寮等有三十俱胝。闻王有命齐至王所。俱白王言。有何宣令。王言。汝等当知。今我国中适闻一事甚为希有。此有一人才种一树。于少时间即生芽茎。枝叶华果悉皆具足。又复盘根一由旬量。汝等颇曾见是事不。如我所见诸有树木。开华结果极甚疾者。亦半月分。或一月分。今此树者昔未闻见。汝等云何。是时臣寮中。有一人前白王言。我于是事亦未决定如实可信。如王所说我亦生疑。愿王更召此种树人。审谛而问知其实不。王即宣召先种树人而复问言。汝所种树于少时间开华等事当如实不。汝若虚妄我必罪汝。时彼人言。王如父母能生于我。我今对王何敢虚妄。愿王无疑是事诚实。王言。我昔未闻况复能见。我于是事如何生信。是时彼人复白王言。大王若或不信。愿王诣彼亲自观察。时王即与三十俱胝臣寮同诣树所。既至彼已即见其树枝叶滋茂果实繁多。见已生信叹其希有。王时于彼亦种一树。亦不即生芽茎枝叶况复华果。王既见已惭对臣寮。生大嗔恚即敕令伐。彼先种树诸力士等。咸遵王命持斧竞伐伐一树时有十二树同时复生。七宝庄严广大殊妙。时王见已转复生嗔。又敕令伐如是等树。时诸力士又共持斧伐十二树。伐此树时是处复有二十四树同时还生。彼一一树枝叶华果转复繁茂。又复皆有一命啄鸟游戏其上。众色严身音声清妙。时王见已复甚嗔恚。自索一斧欲断一树。斧所及处甘露流溢。时王见已便生信悔。敕令召彼先种树人。是时此人先被持缚。今方得解奔诣王所。王复问言。汝何缘故始种一树。即生芽茎枝叶华果。我令伐已生十二树。七宝庄严广大无比。如是又伐即复又生转倍于前。异鸟奇音甚为希有。我亦种树不即能生。况复华果庄严等事。是义云何汝当实说。彼人答言。大王。是我福德力之所致故。如是又言。大王。是我福德力之所致故。时诸臣寮闻是语已。皆大嗔怒咸作是念。如何此人对王自矜我福德力。即共责彼而作。是言。汝愚痴人如何对王自矜福德。若如是者汝莫胜王或与王等。尔时彼人向诸臣寮。稽首恭敬说是伽陀

  我不乐王位　　广集诸财宝
  久发最胜愿　　成佛二足尊
  我至涅盘界　　而不住寂灭
  以方便愿力　　出现于世间
  说法度众生　　咸令至彼岸
  离缚而自在　　得最上安乐
  我以宿业故　　今被王持缚
  胜愿力既然　　我业尽销灭

尔时复有二十四俱胝金啄鸟。飞于空中出清妙声奏诸音乐。是时复有三万二千妙宝楼阁同时出现。一一楼阁其量高广二十五由旬。彼楼阁间一一别有二十五俱胝金啄鸟。翔集其上说是伽陀

  大王何故起恶心　　伐彼可爱即生树
  佛神力故刹那间　　二六倍等复生长
  王以我心亦种树　　不生芽茎及华果
  见如是事信不生　　徒增烦恼起嗔恚
  王善力故后生信　　当来定获最胜果

尔时王言。空中声者是大贤善。我本何心故生破坏。我今已信深自悔责。时王又闻空中作如是言。大王。彼先种树者。即当成佛出现世间为天人尊。王即仰问空中贤者。彼次种树人。以何缘故种树不生。空中答言。大王当知。此人广造罪业无少善根。以是缘故一切破坏。尔时彼王以善根力久成熟故。得见如是希有事已。又闻空中如是言等。发起增上最胜善心。是时即得安住十地平等善法。彼三十俱胝臣寮。亦以善根成熟力故。亦复安住彼十地法

尔时药王军菩萨。闻佛世尊作是说已。生大欢喜叹未曾有。合掌恭敬前白佛言。世尊。昔时王等以何缘故。即得安住彼十地法。佛言药王军。彼王与臣。诸佛如来久已授记。皆得成佛。药王军当知。彼所种树皆是诸佛神力所现。我于今日复现是事。与彼昔时等无有异

尔时世尊于众会中。从其面门放大希有八万四千净妙光明。彼一一光各有无数百千种色。所谓青黄赤白红紫碧绿。如是等种种色光。普照无边诸世界已。其光旋还右绕佛身。复从世尊顶门而入

尔时药王军菩萨。合掌恭敬礼世尊足。而白佛言。世尊。何因缘故。放是希有广大光明普照世界。若无因缘。如来应供正等正觉不放光明。愿佛慈悲略为宣说

佛言药王军。汝今见彼随方来者。诸世界中无数人众。咸来集此大众会不。药王军言。不也世尊。我今不见。佛言。汝当审谛重复观察

尔时药王军菩萨承佛圣旨。四方上下皆悉观察。即于东方见一大树殊妙庄严。其量高广七千由旬。有二万五千俱胝人众。周匝围绕入佛会中。于佛世尊不伸问讯亦无所说。寂然无声住佛一面。南西北方上下方等亦复如是。尔时药王军菩萨见是事已。前白佛言。世尊。我有少疑欲伸请问。愿佛世尊为分别说。佛言药王军。汝今有疑恣汝所问。我当为汝一一开示。是时药王军菩萨复白佛言。世尊。今此四方上下世界。一一大树有诸人众。周匝围绕来入会中。寂无言说各住一面。何因缘故其事如是。佛言药王军。汝今欲知其事因缘。自可往彼随方世界一一亲问彼佛世尊。必当为汝如实宣说。药王军菩萨白佛言。世尊。我承佛旨今当自往随方世界问彼世尊。然我以何神力而能往彼。佛言。汝当以自神力往诸世界。吾复为汝神力加被。药王军菩萨即于会中。绕佛三匝已隐身不现。从是东方过九十六俱胝世界。到一世界名为月灯。彼有佛名月上境界。十号具足。有八十俱胝大菩萨众围绕说法。药王军菩萨既到彼已。即时头面礼彼佛足。合掌恭敬而白彼佛言。世尊。我于娑婆世界释迦牟尼佛所。见此东方。有一大树殊妙庄严。其量高广七千由旬。有二万五千俱胝人众。周匝围绕来入佛会。南西北方上下方等亦复如是。我不能知是事因缘。化主释迦牟尼佛。遣我来此自问其故。唯愿世尊为决所疑

尔时月上境界如来告药王军菩萨言。善男子。彼佛会中所来大树广大殊胜。能于彼方施作佛事。彼诸人众从树所生。为显诸佛神通力故

药王军菩萨复白彼佛言。世尊。是事希有我昔未闻。况复能见。又复世尊。今此会中无数人众住世尊前。周匝围绕无空隙处。此诸人众仅容其身。皆不能见彼二手臂。是事云何愿佛为说。彼佛言。善男子。此诸人众若行若住。或复屈伸皆悉无碍。药王军菩萨复白彼佛言。世尊。我所未了是义云何。彼佛言。善男子。汝今乐见此诸人众伸其臂不。药王军菩萨言。我今乐见愿佛显示。尔时月上境界如来。即于会中舒金色臂普示大众。是时在会百千俱胝人众。即各一时亦舒一臂。一一皆雨无数百千种香。所谓涂香末香等供养于佛。是时彼佛告药王军菩萨言。善男子。汝今见此人众各舒一臂雨众妙香供养世尊如是事不。答言已见。彼佛言。善男子。汝今当知。此诸百千俱胝人众。皆是化生如梦所见

尔时药王军菩萨见是事已。即白彼佛言。世尊。此诸人众于须臾间各舒一臂。尚能雨彼无数妙香。何况尽令舒其二臂。雨是香等倍复甚多。彼佛言。如是如是。善男子。如此等类皆是如来神力所化不可限量。诸众生界亦复如是。若生若灭如梦如幻。一切有为皆无实法。药王军菩萨复白彼佛言。世尊。诸众生类有初生者。有久生者。彼佛言如是。药王军菩萨言。不知何者是名初生。又复何者得名久生。彼佛言。今此会中百千俱胝人众。适舒一臂各雨香者是为久生。彼娑婆世界释迦牟尼佛所。从树生者是为初生。药王军菩萨重白彼佛言。世尊。我今于此而欲复见彼初生者。愿佛显示

尔时月上境界如来即时复舒右臂。是时四方有百千俱胝人众。上方下方亦各有二十五俱胝人众。同时而来入佛会中。亦复于佛不伸问讯亦无所说。寂然无声住佛一面。是时药王军菩萨前白彼佛言。世尊。云何是等无数人众。于刹那间来入佛会。亦各寂然住佛一面。彼佛言。善男子。此诸人众是初生者。不知生法。不知灭法。亦复不知老病死忧悲。爱别离。怨憎会等如是诸法。亦复不知苦及苦受不从苦生。于一切法非所修习。非所了知。云何于今能有所说。是故各各寂然而住。药王军菩萨复白彼佛言。世尊。如佛所说。此诸人众是初生者。不知此等从何所来。于一切法皆不能知。彼佛言。善男子。此等众生非业报生。非诸功巧所能造作。亦不由彼父母缘生。不从诸受相应所生。亦非过去业因缘生。亦不思念苦受等想。生已无住从如是来故无所说。乃于诸法不能了知。亦复不生我我所想。药王军菩萨复白彼佛言。世尊。此既名为初生者。为从何生。复从何灭。彼佛言。善男子。如佛所生彼如是生。如佛所灭彼如是灭。善男子。譬如有人违背王法。为王系闭久处牢狱。而彼狱中极甚黑闇。不为日光所能照烛。受大苦毒多生惊怖。是时其狱忽为火焚。四面炽然人皆惊唤。彼所系人尚未能出。时王闻已即遣力士。作诸方便令救。是人既得离彼狱火难已。而见于王王言赦汝。自今已往莫复更作如是罪犯。若更作者为彼系缚无有出期。善男子。如来亦复如是。已断贪嗔痴等一切烦恼。圆满一切出世善法。又能息除一切病苦。复以种种大悲方便。于六趣中救度一切受苦众生。一一皆令离诸缠缚。如彼日光破诸冥闇。灭诸罪垢生善作意。善男子。若久生。若初生。一切众生皆令解脱。是时彼佛说是法时。空中有声说是伽陀

  如来大悲者　　处清净刹中
  从善法种生　　因果无所失
  佛境界清净　　开微妙法门
  以大悲方便　　度诸众生类
  次第而开导　　皆令至涅槃
  常寂静世间　　诸所作无染
  自从无始劫　　若久生初生
  三界六道中　　无数众生聚
  佛悲愿力故　　咸归解脱门
  若世出世间　　普得大利乐

尔时月上境界如来即于会中放大希有净妙光明。于其光中出广大声普震十方。复于声中出如是言。善哉诸佛神通力。善哉妙法功德力。善哉和合大集会。种种神变不思议。善哉宣说妙法门。一切众生得利乐

尔时药王军菩萨见大光明。又闻空中作如是声。称扬赞叹合掌恭敬。礼彼佛足前白佛言。世尊。何因缘故放是光明。彼佛言。善男子。汝今见此会中诸初生者不。答言已见。彼佛言。善男子。此诸人众根缘成熟。即于是日闻我说法。一一皆当圆满十地

尔时药王军菩萨即从座起。踊身虚空高八万由旬。是时复有八万俱胝天人。于虚空中雨诸妙华供养彼佛。时诸初生者。各各恭敬顶礼世尊。是时十方有诸菩萨。乃至一切龙神夜叉等又悉云集。时药王军菩萨于虚空中合掌。一心而向彼佛说是伽陀

  善哉佛神力　　放光出大声
  三千世界中　　无有不闻者
  三十二地狱　　受苦诸众生
  得闻是音声　　苦恼皆停息
  三界诸天众　　亦闻是音声
  各起恭敬心　　欢喜而称赞
  三千大千界　　普闻广大声
  以佛大神通　　皆六种震动
  三万俱胝数　　大海诸龙王
  闻是大音声　　皆来至佛会
  三万俱胝数　　诸啰刹娑王
  闻是大音声　　皆来至佛会
  二万五千数　　俱胝必隶多
  闻是大音声　　皆来至佛会
  毗沙门宫内　　无数诸夜叉
  闻是大音声　　皆来至佛会
  十方诸世界　　有百千俱胝
  菩萨以神通　　皆来至佛会
  月上境界佛　　为初生众生
  欲说妙法门　　是故皆云集

尔时药王军菩萨。说是伽陀已。从空而下住立佛前。合掌恭敬白彼佛言。世尊。今此会中诸来菩萨。乃至一切龙王鬼神皆已来集。各各乐欲听佛说法。今正是时愿佛为说。彼佛言。善男子。汝今当知。此初生众已得远离一切罪业。梵行具足得大总持。一切善法皆已圆满。我今为彼说大法蕴时药王军菩萨复白彼佛言。世尊。此诸大众渴仰欲闻。愿佛为说

佛说大集会正法经卷第四佛说大集会正法经卷第五

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时月上境界如来。告药王军菩萨言。汝等当知。一切众生有身皆苦。生老病死忧恼悲痛。怨憎会。爱别离。所欲不成就。如是等法悉皆是苦。逼迫众生不能解脱。此一切苦甚可怖畏。而诸众生于是苦义不闻不知。尔时会中诸初生者。闻佛说是诸苦法名。即皆合掌前白佛言。世尊。我等乐闻此诸苦义愿佛为说。佛言。诸善男子。非唯汝等乐闻。一切众生皆亦如是。诸初生者复白佛言。世尊。所言死者其义云何。佛言。诸善男子。所谓识灭身坏故名为死。一切众生命欲终时。有三种风而来破坏。所谓灭识风。动转识风。起识风。此三种风。众生命欲尽时。令识散灭动转改易。诸初生者言。世尊彼灭识风。云何能令众生识灭身坏。佛言。彼灭识风复有三种。所谓刀针大力。由是三种能灭其识。识既灭已身即破坏。诸初生者言。世尊。云何名身。佛言。身者所谓如幻如焰。又如重担。复如涎洟腐烂等物。诸无智者不能觉了。生为大苦由生发起。缘法聚集命根连持。而无其实非爱相应。如是等法假名为身。诸初生者言。世尊。云何名命。复何名灭。佛言。识所连持是名为命。业报衰谢识法离散。命根断绝身分破坏故名为灭。诸善男子。我今复为汝说身分所有。当知人身诸分筋脉有一俱胝数。有八万四千毛孔。有千二百身分支节。有三百八身骨。此等共成人身。复有八万四千族虫。如是生类同依人身。于人身中昼夜[口*(一/巾)]食。而复诸虫互相食啖诸苦随生。如是八万四千族虫。其中有二大者。于七昼夜互相交斗。至第七日彼一虫死。又复一虫而共交斗。一虫死已一虫复生。如是展转。乃至人命断时。此诸虫类一切坏灭无所依止。诸异生类不能觉了。内外苦法相续生灭。老病死法皆不能怖。若顺若违互相交斗。如身二虫苦恼随生而不觉了。身坏命终都无所有。诸善男子。有一异生命将不久。有善知识来为安慰问其人言。汝现生中叵曾知见生老病死诸艰苦不。彼人答言。我曾知见。善知识言。汝今既自知见如是等苦。何不生厌起增胜心。于二世中种少善根。断诸恶法修诸正行。若能如是舍此报已。生他胜处离诸怖畏。以其善法为所依怙。况复世间诸有苦法。一一分明尽可观察。汝岂不闻。大地若击能发大声。善法若作有大胜力。是故于诸如来清净刹中种诸善法。所谓以其华鬘涂香饮食衣服卧具医药。供养如来及诸苾刍苾刍尼优婆塞优婆夷清净四众。如是供养是为于佛刹中种诸善种。当能出生一切善果。汝今于此遇大法王出现世间。若不种诸善根而无所益。时善知识为彼异生说伽陀曰

  如来出世间　　击广大法鼓
  开微妙法门　　令一切趣入
  广度诸众生　　归涅盘寂灭
  汝今见是事　　何不起精进

尔时彼人亦说伽陀。答善知识言

  若愚痴无智　　复会遇恶友
  广造染法因　　谓贪欲等事
  起我见增盛　　破和合僧伽
  毁坏于塔寺　　不深信三宝
  但造众恶业　　不作善因缘
  于一切时中　　常生诸过失
  恼乱于父母　　不生孝敬心
  出非法语言　　轻谤诸贤善
  造此恶因故　　必堕地狱中
  自受苦恼身　　无能救护者
  可畏与众合　　炎热及阿鼻
  如是诸狱中　　展转受诸苦
  从是大狱出　　复入小狱中
  谓刀兵莲华　　受苦而相续
  如是大小狱　　有无数众生
  随自业因缘　　轻重而受报
  或百劫千劫　　或复更长时
  恶业绳所缠　　无由能解脱
  彼刀兵地狱　　纵广百由旬
  不见彼狱门　　唯诸受苦者
  百千俱胝数　　剑树与刀山
  驱彼罪人登　　身分皆断坏
  暂时虽死灭　　复被业风吹
  即时还复生　　而受诸苦恼
  地狱无边际　　众生亦无穷
  以恶业因缘　　相续不间断
  我造诸恶业　　定堕彼趣中
  善知识今时　　听说所造业
  我曾起贪心　　广造于舍宅
  彩画复雕镂　　金宝以庄严
  复置诸园林　　仓库及产业
  畜牛马生类　　皆以为资具
  父母及眷属　　内外数甚多
  奴婢与妓人　　其数无有限
  常令于昼夜　　动种种歌音
  但纵己乐心　　不念于他苦
  恃彼不富贵　　作种种庄严
  凡所受用物　　悉金银珍宝
  以香水澡沐　　复涂诸妙香
  龙脑与栴檀　　及彼麝香等
  香水澡沐已　　次第而严身
  手钏及指环　　皆用珍宝作
  以真珠璎珞　　而为项庄严
  最上好真金　　复为耳珰等
  身分庄严已　　顶戴诸妙华
  苏摩那瞻波　　及诸异香者
  复着妙好衣　　谓最上细[疊*毛]
  鲜白复清洁　　皆妙香所薰
  饮食最上味　　甘美复馨香
  侍者供所须　　暂无饥渴想
  地敷好茵蓐　　履践而游行
  左右有侍人　　自在复尊贵
  如是广严饰　　而爱乐其身
  常保惜护持　　不生破坏想
  既富乐具足　　余复无所思
  恣其染欲心　　造不善过失
  眼贪于色境　　诸根亦复然
  彼为过失因　　自不能觉了
  见闻觉知处　　诸烦恼随生
  于顺违境中　　起贪嗔痴法
  柔软等诸触　　触身心起爱
  彼爱想既生　　诸罪业皆作
  我曾于一时　　无故害有情
  以箭射鹿身　　令彼命断灭
  但取其肉食　　不念后世中
  果报自当受　　谁人能代者
  我愚痴无智　　但资养其身
  一日死苦来　　识灭身破坏
  唯集诸苦恼　　无一可爱心
  父母及诸亲　　相视不能救
  良医妙药等　　亦唐设其功
  徒增悲恼心　　无救济方便
  我若命断已　　弃于尸陀林
  为鸟兽诸虫　　充足而食啖
  一切无所有　　空幻法现前
  诸境悉皆空　　唯果报不失
  是时无所托　　唯善法可依
  如我造恶因　　当堕于地狱
  广积罪业蕴　　后苦恼随生
  于彼三世中　　破坏善法种
  受想行二法　　以诸触为因
  触故诸爱生　　而成忧苦缚
  善法如良药　　能治贪爱心
  贪等既不生　　诸恶不能作
  我实无福慧　　虚受于人身
  佛宣方便门　　布施持戒等
  我不能自作　　不随喜见闻
  正法不能听　　愚痴日增长
  无明等烦恼　　随转而无穷
  障善法因缘　　何由能解脱
  迷惑心散乱　　无少时静住
  烦恼火所烧　　受种种缠缚
  于身无少乐　　乐法不暂生
  命将不久时　　一切皆破坏
  唯诸佛胜法　　能救苦众生
  戒法真实门　　登者得大乐
  如我所造业　　深自生追悔
  今遇善知识　　是故如实说

尔时月上境界如来。告药王军菩萨言。善男子。诸异生类临命终时生大惊怖。苦恼其心无所救护。唯诸善法能为所依。殊胜果报而无所失。尔时彼佛即说伽陀曰

  众生作恶业　　定堕地狱中
  饥时吞铁丸　　渴复饮铜汁
  身出猛火焰　　恶业故自烧
  身分皆破坏　　受惊怖大苦
  彼不见乐境　　不闻正法名
  唯苦逼身心　　一切皆非爱
  众生作善法　　定生善趣中
  善知识会遇　　劝导修善法
  发生正信解　　具戒慧多闻
  诸烦恼灭除　　而成正等觉
  精进行最上　　佛出世所宣
  策发诸善根　　不生于退屈
  慈悲真梵行　　摄一切众生
  自利复利他　　皆令得解脱
  善男子谛听　　佛所说真实
  出微妙法音　　令一切调伏
  大悲心为父　　菩提心为母
  善法为知识　　能救护众生
  正觉出于世　　说最胜法门
  方便化众生　　令住寂灭地
  佛为大悲者　　最上世间尊
  普观诸有情　　等同为佛子
  平等无有二　　使一切归依

尔时彼佛说是法时。三千大千世界六种震动。时药王军菩萨合掌恭敬白彼佛言。有何因缘大地震动。愿佛慈悲当为我说。彼佛言。善男子。汝当四方观察有何所见。是时药王军菩萨承佛圣旨。即时四方观察。见此大地震动。于少时间而复破裂。有六十五俱胝人从地而生

尔时六十五俱胝初生者。即皆合掌俱白佛言。我等从何所生。佛于会中指前初生者。告彼从地生者言。诸善男子。汝等见此诸人众不。答言已见。佛言。如彼所生汝等亦然。从地生者又言。此诸人众当应灭不。佛言。如是如是。彼等皆灭。诸善男子。非唯此众。一切有情悉皆归灭。是时先在佛会诸初生者。各起合掌白彼佛言。世尊。如佛所说生死二法。我等厌患非所爱乐。佛言。汝等既能厌患生死。云何不能发起精进。此诸初生者又白佛言。世尊。我等于如来前听受正法。见此菩萨声闻大众。有大神通威德具足。是我所乐。我等亦欲趣进修习远离生死

尔时药王军菩萨复见有诸从地生者。即时与五百大菩萨。各各以自通力于其会中。又复踊身虚空高二万由旬。于其空中或现经行相。或现跏趺相。或现师子王步相。或现象王步相。或现诸异兽等步相。现如是等诸相已。复于空中作诸神变。时此菩萨等各有身光。于虚空中如百千俱胝日月光明

尔时诸从地生者俱白彼佛言。世尊。何因缘故有是广大光明。及于空中现诸神变希有等事。佛言。诸善男子。汝等见诸菩萨住空中不。答言已见。佛言。此大光明是诸菩萨各各身光。此诸菩萨一一皆能现诸神通变化等事。是时药王军等诸菩萨众。即于空中出微妙声。俱白彼佛言。愿佛慈悲为诸众生宣说法要。若天若人得闻法者。皆得最上利益安乐。我等今时皆是如来大悲方便。精进愿力所建立故。愿佛于今显法光明普照世间。作是言已俱从空下住于佛前。彼佛告药王军菩萨言。善男子。汝今见此三千大千世界六种震动不。药王军菩萨言。已见世尊。然今我等不能了知。以何缘故有如是事。又复我今有少疑惑。欲问世尊愿为开决。彼佛言。善男子。汝今有疑恣汝所问。若过去未来现在三世等事。我当为汝一一如实分别演说。药王军菩萨白彼佛言。世尊。今此会中何故有八万四千天子众。八万四千俱胝大菩萨众。一万二千俱胝龙王众。一万八千俱胝部多众。二万五千俱胝必舍左众。以何义故如是等众其数甚多。彼佛言。善男子。汝今当知。此诸大众俱来集会。皆是于此听佛说法。即于是日获大利乐永出轮回。又复其中有得安住十地法者。有得安住涅盘界者。有得解脱老病死苦住安乐法者。有得解脱烦恼缚者。有得深入佛正法者。药王军菩萨复白彼佛言。世尊。如来善为一切众生作诸善巧。方便事业随顺摄化。云何是中而无懈倦。彼佛言。善男子谛听。如来起大悲心设诸方便。普摄有情皆令解脱常无懈倦。但诸异生愚于善法。虽遇如来不能亲近。听受修习不求解脱。善男子。如来今日于大众中吹大法螺。击大法鼓。出大法声。演大法义。若天若龙。乃至八部四众。及诸初生者。如是一切大众。咸于今日得大总持。圆满善法安住十地。普获利乐一切。皆是如来神通方便所作。令诸众生住精进地。得法具足如佛世尊

尔时六十五俱胝数中。有五千初生者。俱从座起合掌向佛。而白佛言。世尊。我等有身而为重担。深为大怖何由解脱。又复一切众生处轮回中暂无寂静。所欲碍心不能了知。住黑闇地不能明了。唯愿世尊。摄受我等及诸众生。施以无畏令得安乐。劝请世尊宣说妙法。令诸少慧众生增长正慧。苦恼众生皆得解脱。世世所生见佛闻法

尔时药王军菩萨向彼初生者。说是伽陀曰

  汝等乐欲闻正法　　先须饮食资身命
  后起无畏广大心　　深得最上妙法味

彼初生者亦说伽陀。答药王军菩萨言

  汝尊者大智　　善调寂诸根
  有广大名称　　一切皆爱敬
  已圆满善法　　一切无不知
  云何作是言　　饮食资身命
  如我等意者　　饮食为过因
  食已于腹中　　成种种杂秽
  虽增长色力　　而恶法随生
  三涂恶趣中　　当生大怖畏
  诸众生罪业　　皆从饮食生
  所有贪爱心　　由饮食所起
  世间愚痴者　　生种种贪心
  营广大田园　　舍宅楼阁等
  诸妙好服饰　　及最上庄严
  众妙宝七珍　　真珠璎珞等
  象马及车乘　　奴婢数甚多
  富贵虽暂时　　终归无常法
  如其寿命尽　　流转诸趣中
  正法不能闻　　善知识远离
  假使四大洲　　为彼转轮王
  七宝皆具足　　圆满千子众
  富贵大自在　　勇猛复威严
  一切所归依　　悉恭敬称赞
  尽一生胜报　　是等亦无常
  彼寿限既终　　善恶业随受
  虽富有珍宝　　勇猛大威德
  寿命若尽时　　自力不能救
  尊者如我说　　一切无所依
  唯诸佛如来　　是真所归仗
  如父复如母　　能养育出生
  平等而爱怜　　一切皆如子
  譬日月光明　　普照诸冥闇
  所有轮回苦　　断灭令不生
  拔彼烦恼根　　使离诸怖畏
  普令有情类　　证无上菩提
  宣说正法门　　令住不退转
  世间饮食等　　无利生过失
  不得生诸天　　非为可爱果
  于世间无乐　　当招极苦报
  损减于寿命　　造不善业因
  生富乐贪爱　　不能了无常
  不造最胜业　　不了知妙法
  不念离过失　　不住寂静心
  寿命既尽已　　诸趣受诸苦
  无常杖所打　　五欲绳所缚
  苦恼而转增　　业报不能脱
  过去业所照　　无救无所依
  当识法灭时　　徒增悲恼怖
  我宁以珍宝　　金银及玻璃
  广施一切人　　终不生吝惜
  我宁以身力　　为他人仆使
  设经彼长时　　终不生疲倦
  若起贪爱想　　广集诸珍财
  及饮食上味　　我即生怖畏
  愿尊者谛听　　如我等所言
  假使彼诸天　　受胜妙乐报
  以诸妙宝器　　盛种种上味
  甘美复馨香　　食者生适悦
  益天人身分　　色力及威力
  彼受报若终　　一切皆非实
  以是故我等　　不爱乐饮食
  唯乐正法门　　求解脱众苦
  远离贪爱缚　　得自在无碍
  归依佛世尊　　大仙真圣者
  汝尊者大智　　我恭敬顶礼
  具广大慈悲　　众生皆乐见
  汝名字何等　　愿尊为我说
  若见闻随喜　　得诸根清净

尔时药王军菩萨复说伽陀。答初生者言

  汝今欲闻我名字　　彼一切名唯佛知
  百千俱胝众初生　　彼名一一佛能了

彼初生者。又说伽陀曰

  我曾从佛亲听受　　初生久生一切名
  唯汝名字最甚深　　未曾闻佛为广说

是时药王军菩萨复说伽陀。答初生者言

  当知我名字　　号为药王军
  妙药救众生　　是故得其号
  一切众生类　　种种病所缠
  我以方便门　　随顺而救济
  贪为病最大　　恼害于世间
  由此病为因　　而生诸过失
  嗔病如大火　　焚烧寂静心
  唯甘露法药　　能除诸苦恼
  痴病大可怖　　覆没智慧心
  死堕恶趣中　　不得闻正法
  由此三种病　　展转诸病生
  益愚痴闇冥　　我皆施法药
  普令离过失　　灭一切业因
  息苦恼不生　　永绝诸怖畏
  既得离诸病　　速见正觉尊
  因我妙医王　　应病而授药
  一切有情类　　常为火所焚
  炽然不能息　　转生诸苦恼
  贪欲为重担　　无有解脱时
  嗔痴法亦然　　展转增过失
  虽常负重担　　不求解脱门
  复不念无常　　不思出离道
  烦恼业随逐　　苦恼亦不知
  众病逼其身　　不能求妙药
  由无明因故　　诸行即随生
  行等法既起　　贪爱生过失
  诸行不究竟　　一切法皆空
  无智不能知　　无由生正念
  不修寂静行　　识灭苦恼增
  经无数劫中　　不能得解脱
  佛出现于世　　为彼天人师
  如父母爱子　　开示正觉道
  复雨大法宝　　普济诸群生
  除彼邪智人　　不摄受正法
  发菩提心者　　得入正法门
  了一切行空　　于空亦无碍
  若了空无我　　一切无所依
  诸烦恼亦空　　远离诸过失

尔时诸初生者。复说伽陀言

  菩萨大悲者　　普救诸众生
  精进大医王　　长时无懈倦
  念彼轮回苦　　以功德摄持
  我谛信归依　　起勇猛精进

尔时药王军菩萨。复为说伽陀曰

  汝等今当知　　佛为最上尊
  世间出世间　　福智皆具足
  具三十二相　　及众好庄严
  以最上大悲　　广度诸群品
  佛威容高显　　犹如妙高山
  智慧无有穷　　复如彼大海
  善开诸方便　　随顺化众生
  瞻礼与归依　　皆得安乐果

尔时月上境界如来。出如迦陵频伽清妙音声普闻十方。又从面门出八万四千种种色光。所谓青黄赤白红紫碧绿。如是光明广大炽盛。普照三千大千世界。所有三十二大地狱。蒙光所照皆悉破坏。诸天宫殿光所照处广大明耀。如是光明。照于三千大千世界已。复于光中。出一切众生所有乐具现于虚空。作如是变化已。其光旋还绕佛七匝。复从彼佛顶门而入。尔时药王军菩萨复从座起。合掌恭敬白彼佛言。世尊。何因缘故。如是重复放大光明普照世界。尔时彼佛告药王军菩萨言。善男子。我于今日作大佛事。今此会中有诸众生得大利乐。以是缘故重复放光。药王军菩萨复白彼佛言。我有所疑欲当请问。唯愿世尊为我开决。彼佛言。善男子。如汝所疑当恣汝问。药王军菩萨言。世尊。何故此会诸初生者。世尊为现种种希有等事。复为宣说微妙法门。诸久生者。云何世尊不皆如是。岂此等类于佛正法不能了知。彼佛言。善男子。汝今何故作如是言。于如来前而伸请问。此不得名柔顺等语。何以故。如来于诸众生平等化度。随顺方便而为说法。诸有闻者皆获利益。具足得入诸总持门。一切功德皆悉成就。尔时虚空中复有无数广大殊妙七宝楼阁现于佛上。是时彼佛告药王军菩萨言。善男子。汝今见此殊妙楼阁不。药王军菩萨答言。已见世尊。彼佛言。汝今当知。此等皆是诸初生者所共变现。何以故。此诸初生者。皆于是日圆满一切善法。又复我于今日击大法鼓。有无数天人得法具足。无数地狱众生得离苦恼。复有无数众生。暂生正念归依佛智皆得解脱。彼佛说是语时。会中有九万九千俱胝久生众生。证得须陀洹果得法具足。断除业障远离众苦。如此等类皆从如来正法出生

尔时东方有五十俱胝殑伽沙数诸菩萨众来入彼会。南方有六十俱胝殑伽沙数诸菩萨众来入彼会。西方有七十俱胝殑伽沙数诸菩萨众来入彼会。北方有八十俱胝殑伽沙数诸菩萨众来入彼会。下方有九十俱胝殑伽沙数诸菩萨众来入彼会。上方有百俱胝殑伽沙数诸菩萨众来入彼会。是时药王军菩萨白彼佛言。世尊。云何虚空周匝皆作赤黑二色。彼佛言。善男子。汝今不知如是因缘。答言世尊。我不能知。彼佛言。唯佛如来而自知察。善男子。汝今当知。诸方世界各有若干俱胝殑伽沙数诸菩萨众来入佛会。如是诸菩萨众随方来已。从空而下住立佛前。礼彼佛足各住一面。是时药王军菩萨白彼佛言。世尊。何因缘故又复有此大菩萨众而来集会。彼佛言。善男子。此诸菩萨大众集会。皆以初生者为缘而起发故。彼佛作是言时。所有会中诸初生者。即时皆得诸法具足安住十地。又复彼佛会中无数修菩萨行者。皆得安住诸菩萨法。得大神通见闻随喜。一切众生皆获利乐。诸有已住菩萨地者。不复退转增胜坚固菩萨行法。佛说此经已。普勇菩萨等诸大菩萨。阿惹憍陈如等诸大苾刍。乃至世间天人阿修罗等一切大众。闻佛所说皆大欢喜信受奉行

佛说大集会正法经卷第五


佛说海意菩萨所问净印法门经

    No. 400 [No. 397(5)]

佛说海意菩萨所问净印法门经卷第一

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

如是我闻。一时世尊。住于如来神通境界大宝庄严最胜道场大菩萨宫中。而彼道场皆是如来威神建立。积集广大胜福庄严。圆满广大福智妙行。现转一切佛法胜报。显示如来无边神变加持之力。善入无碍境界大智。一切见者生大喜悦。入念慧行普遍运行。无动妙智。于无边劫修集无量众功德聚。而佛世尊。现证诸法平等觉道。转妙法轮。能善调伏无边学众。已于诸法得大自在。善知一切众生心意及诸根性。已能到于最上彼岸。善断一切种子习气。得无发悟佛身轻安。是时与大苾刍之众六百八十万人俱。皆住近心。悉断一切烦恼种习。皆是如来法王之子。能善出生诸无所得甚深法行。身相端严威仪圆备。作大福田正智具足。复有无量无数不思议无等比不可说不可说诸大菩萨摩诃萨众。悉获无所得菩萨智忍。已超菩萨灌顶之位。而能游戏无加行位菩萨神通。得无尽陀罗尼及诸菩萨陀罗尼门。于诸菩萨首楞严王三摩地中而得自在。一切众生欢喜乐见。已得菩萨诸无碍解。出生菩萨无发悟行。深心安住殊妙庄严。其名曰无尽藏菩萨摩诃萨。无量慧菩萨摩诃萨。无边慧菩萨摩诃萨。无缘观菩萨摩诃萨。常精进菩萨摩诃萨。精进慧菩萨摩诃萨。无断辩才菩萨摩诃萨。无著无畏积菩萨摩诃萨。毕竟义慧菩萨摩诃萨。如是等无量无数不思议无等比不可说不可说诸大菩萨摩诃萨众而共集会

尔时世尊。以菩萨行位。方便出生无障碍门甚深正法。而用庄严诸菩萨道。成办一切佛法力无畏等真实智行。入一切法最上自在总持印门。入无碍解决定出生大神通智妙境界门。宣示一切不退转轮。普摄诸乘住平等理。混入法界无分别性。随诸众生根性意乐开示演说。随知真实决定正法。破诸魔境。以深固法理。止息一切烦恼见等。入无著慧。宣说普遍广大回向善方便智。入一切佛平等性智。以无著加持法门如实决定宣说诸法。于无分别非无分别悉入平等。觉了甚深缘生之法。积集无量福智妙行。佛身语心平等庄严。随知一切念慧行等无尽慧门。以四圣谛理显示声闻乘法。以觉了身心智显示缘觉乘法。以得一切智灌顶显示大乘之法。入一切法自在理中。出生如来无边功德。是故如来开示演说。施设表了。分别解释。显明宣畅

尔时世尊。将说如是广大甚深决定法时。忽然于此三千大千世界之中大水充满。犹如大海。下至地界。上至大宝庄严最胜道场。又如劫坏水灾现时。一切三千大千世界。大水充满。下至水轮混如一海。今此大水亦复如是。然此三千大千世界。如是大水一切充满。其中国土城邑聚落及诸人民悉无所坏亦无障碍。及阎浮提诸四大洲乃至大海须弥山等。欲界诸天一切宫殿。悉无少分损坏障碍。先现如是相已。后复于此大水之中。出现俱胝那庾多百千广大莲花。其花高显。琉璃为茎。帝青为枝。阎浮檀金而为其叶。吉祥藏宝以为其须。马瑙为台。真珠交络。一一花有无数俱胝多百千叶。其叶量广一俱卢舍。是诸莲花于大宝庄严最胜道场中。涌现虚空。高一多罗树。一切大众坐莲花上。于莲花中随其色相放大光明。是光普照十方无量阿僧祇佛刹。此诸光明广照耀时。而此会中一切大众叹未曾有。合掌恭敬咸作是言。今现如是希有瑞相。将非世尊说妙法邪

尔时慈氏菩萨摩诃萨。见是广大神变事已。即于所坐莲花台上。遍袒右肩右膝着地。合掌向佛。恭敬顶礼而白佛言。世尊。何故今时先现是相。而此三千大千世界之中大水充满混如一海。其中复现俱胝那庾多百千莲花高显。世尊。昔所未闻。昔所未见。如是广大希有神变。愿佛为说

佛告慈氏菩萨言。慈氏当知。下方去此佛刹。过十佛刹不可说俱胝那庾多百千微尘等数诸佛刹土。有世界名无量功德宝无垢殊妙庄严。彼土有佛。号海胜持慧游戏出高神通如来应供正等正觉。今现住彼说法教化。彼有菩萨名曰海意。与出过算数诸大菩萨摩诃萨众。将同来此娑婆世界。瞻礼恭敬供养于我。又复于我所说法中而有所问。以是因缘。先现瑞相

尔时尊者舍利子白佛言。世尊。彼海意菩萨去此甚远。何故世尊说彼菩萨能闻此会佛说法邪。佛言。舍利子。如汝今时于我前闻所说正法。海意菩萨虽复住于彼世界中。而能闻我所说之法。亦复如是。舍利子。又如汝今现前观我及诸大众。彼海意菩萨能见我身及诸大众。亦复如是。舍利子言。希有世尊。诸菩萨摩诃萨所有神通智力不可思议。而彼海意菩萨居于极远刹中。能以无障碍眼见此色相。无障碍耳闻此音声。世尊。若有闻是诸菩萨摩诃萨不可思议功德威神者。其谁不发阿耨多罗三藐三菩提心。尊者舍利子作是说时。二万四千天子皆发阿耨多罗三藐三菩提心

尔时海意菩萨摩诃萨与彼出过算数诸大菩萨摩诃萨众。恭敬围绕。同时瞻仰彼佛世尊海胜持慧游戏出高神通如来已。即受教敕。承彼如来神足通力。及无加行菩萨已办神通。于一念间瞬目之顷。于彼世界隐伏身相。即时于此娑婆世界大宝庄严最胜道场中。涌现虚空。高一多罗树。于最高广莲花台上师子座中安详而坐。余诸菩萨亦各处于莲花台座。下方世界无量无数诸佛刹中。复有无量无数菩萨之众随从海意菩萨而来听法。是时大宝庄严最胜道场中所有十方世界普来集会一切菩萨摩诃萨众。皆悉处于莲花台座。周匝充满。殊妙奇特。而彼一切诸来大众。心生欢喜。悉得清净。叹未曾有。合掌顶礼彼诸菩萨。时海意菩萨。以彼无量功德宝无垢殊妙庄严世界之中诸胜妙花。其花名为无忧适悦爱乐喜见。量广一俱卢舍。花有无数多百千叶。随其所应供养如来。令诸菩萨一切见者深心无垢。宿世善根悉得清净。是诸众会皆生欢喜悦意爱乐。花有光明。复有妙香。此诸胜花于世尊前作供养已。复雨广大殊妙花雨。其一一花可七人量。遍布充满大宝庄严最胜道场。一切大众悉得离生喜乐禅悦之味。空中自然击种种鼓鼓出微妙可爱之音。一切大众闻者悉得禅定妙乐

尔时海意菩萨摩诃萨。作如是等供养事已。从空而下。头面着地礼世尊足。右绕七匝合掌恭敬。住立佛前。作是白言。世尊。海胜持慧游戏出高神通如来。问讯世尊释迦牟尼如来。少病少恼。起居轻利。势力安不。得妙乐邪。时彼同来一切菩萨。悉从空下。亦各头面礼佛足已。右绕七匝。各各还复本座而坐

尔时此三千界。有大梵王。名大悲思惟。居此梵世此四大洲无忧安隐。忽然见是三千大千世界。大水充满混如一海。复有俱胝那庾多百千广大莲花高显出现种种胜相。及此道场菩萨充满。见是相已即自思惟。劫火未然坏相。安有大水充满。此复何缘。将非如来神变力邪。我今宜往问佛世尊。此希有相。何因何缘。时大悲思惟大梵天王作是念已。即与六万八千梵众隐于梵界。恭敬围绕。来诣大宝庄严最胜道场佛世尊前。住虚空中。曲躬合掌顶礼世尊。作是白言。世尊。何故今此三千大千世界大水充满混如一海。复有俱胝那庾多百千广大莲花高显而出。及诸菩萨大士皆悉处于莲花座上。而此三千大千世界一切国土城邑聚落诸人民众。及阎浮提四大洲等欲界天宫。乃至大海须弥诸山。悉无损坏亦无障碍。如是等相甚为希有。此何因缘。复何神力。愿佛为说

尔时佛告大悲思惟梵天言。大梵当知。下方世界有佛刹。名无量功德宝无垢殊妙庄严。其佛世尊。号海胜持慧游戏出高神通如来。彼有菩萨名曰海意。与出过算数诸大菩萨摩诃萨众。而共来此娑婆世界。瞻礼恭敬供养于我。又复于此广大集会正法之中而有所问。是彼菩萨神通之力。于此世界先现瑞相。梵天白佛言。世尊。大集会中所有正法今尚说邪。佛言。大梵。诸佛境界。不可思议。所有如来智慧辩才及威神力。不应限量。汝或见于如来默然。勿谓无说。而我常为十方世界所来菩萨。广大宣说决定正法

尔时大悲思惟大梵天王复白佛言。世尊。佛所说言现神变者海意菩萨其谁是邪。佛言。大梵今此会中有大莲花广十由旬。花中有台。台上复有众宝庄严师子之座。座中有一菩萨大士处于其上身真金色相好端严。唯除如来。余诸菩萨所有身相皆能映摄。有无数千菩萨之众围绕顶礼者。汝可见不。答言。已见。佛言。大梵。圆具如是神通相者。即是海意菩萨。是时大悲思惟梵天。乃向海意菩萨恭敬顶礼已。即白佛言。世尊。若有众生得闻如是海意菩萨名字之者。当知是人得大善利。我于今日闻此菩萨大士名字。得见菩萨如是色相。深自欣庆快得善利。梵天复白佛言。世尊。此大集会正法当住为久如邪。佛言。大梵。今此正法。随佛寿量久近而住。佛涅槃后。有诸菩萨。于此正法受持读诵。广为佗人开示演说。何以故。大梵。所有过去未来现在世中诸佛菩提从此中出

尔时海意菩萨摩诃萨。承佛神力。普为此会一切大众生欢喜故。及为大悲思惟大梵天王起信敬故。复为庄严此正法故。亦为显示己之智慧辩才力故。即时同彼高广莲花及师子座。俱涌虚空高七多罗树。乃于空中说伽陀曰

  下方过于尘数刹　　有佛刹名功德严
  彼佛化主现居中　　其名海胜神通慧
  刹中众德皆圆具　　菩萨依止无所畏
  其佛如来说法门　　我等闻已能持受
  我等故来兹刹土　　瞻仰敬礼十力尊
  其诸菩萨此所来　　佛大牛王各伸问
  我今礼此法王已　　亦礼无比佛大智
  所应供养随所施　　广伸供养佛正觉
  若能观佛色无色　　离受离行亦离识
  三种领纳此亦无　　是中洁白常清净
  若无色相及种好　　是为正观佛世尊
  慧眼清净照法身　　乃见无垢真实义
  若法无取亦无舍　　二边无我无我所
  安住内入性寂然　　止息心外诸所取
  有无分别离分别　　是心寂默如虚空
  即能供养诸世尊　　于正法幢善建立
  若观诸法犹如幻　　此中施受二皆空
  虽知造作本所无　　亦不舍离于诸法
  而不决定求菩提　　又不决定住生死
  亦无施者无悭心　　远离施中诸过失
  止息调寂身语心　　随行三业无逼恼
  除诸烦恼息烧然　　利智诸根常寂静
  虽知菩提无所得　　不舍众生住无我
  为度破戒诸众生　　修持广大净戒行
  觉了诸法刹那性　　亦不为诸境所坏
  内心寂静若虚空　　外观世间犹如幻
  节节支解于身分　　亦复不起嗔恚心
  乃至坐树成菩提　　坚持忍行佛所说
  能观诸法如水月　　如泡如幻如阳焰
  了知无寿亦无人　　及无摩拏嚩迦等
  菩提众生虽无得　　为利他故求菩提
  若闻此理怖不生　　是中能发精进行
  若能于心无所著　　乃于外境不生厌
  知他众生心所行　　于三世中随顺转
  令诸魔众不能知　　心之所行随所转
  到于彼岸善住心　　圆满禅定神通慧
  我闻诸佛所说法　　随所闻已能受持
  设经无边劫数中　　佛之辩才不能断
  复于一切佛法中　　众生无堕亦无著
  具智慧藏有力尊　　三界自在寂默者
  能到所到二俱离　　是中无去亦无来
  随诸众生心所行　　所向无住亦无动
  虽到彼岸具众德　　亦于众德无取相
  无比释迦大牛王　　是故我今伸顶礼
  如日清净大明曜　　能蔽萤光星宿光
  又如劫火映诸明　　上腾梵世下至地
  复如须弥大山王　　持地亦持诸山等
  释迦牛王毫相中　　最胜光明出三界
  十方一切菩萨众　　皆从百佛刹中来
  瞻佛色相及威光　　一切皆生大欢喜
  随诸众生心意愿　　如来各各为开示
  我知如来大威神　　故从本土来斯刹
  佛以一音演说法　　随诸众生各知解
  乃至众生差别音　　如来普为随宜说
  一切众生意差别　　如尘如沙尚可数
  牟尼种种妙音声　　量等虚空不可数
  虚空不能度其边　　众生不能穷其数
  乃至生死先际中　　亦复不能知其限
  虚空边量众生数　　生死先际尚可知
  诸佛戒定慧境中　　毕竟不能知少分
  众生无量咸归命　　牛王法主人中尊
  多劫精修众德严　　色相边际无比度
  我佛具大威神力　　遍知众生诸信解
  见此希有难思尊　　顶礼善调诸趣者

佛说海意菩萨所问净印法门经卷第一佛说海意菩萨所问净印法门经卷第二

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

尔时海意菩萨摩诃萨。说是伽陀已从空而下。向佛合掌恭敬顶礼。前白佛言。世尊。我于如来应供正等正觉。今有所问。若佛世尊。听许我者。我即当问。佛告海意菩萨言。善男子。恣汝所问。如来应供正等正觉。随有疑者。一一能为宣示演说令心开晓。海意菩萨乃白佛言。世尊。我先闻有诸菩萨自说净印三摩地法门。若有菩萨摩诃萨住是三摩地者。而能速证阿耨多罗三藐三菩提。菩萨应当云何获得如是净印三摩地门。又复以何行相名为自说。云何是净印。何能得入彼境界门。又诸菩萨若得闻是三摩地已。云何速证阿耨多罗三藐三菩提。唯愿世尊善为宣说

尔时佛告海意菩萨摩诃萨言。善哉善哉菩萨大士。今汝所问极为贤善。善男子。汝应专一深固作意谛听谛受。今为汝说。若诸菩萨。得是自说净印三摩地者。即能速证阿耨多罗三藐三菩提。海意菩萨白佛言。唯然世尊。愿乐欲闻。于是海意菩萨受教而听。佛言海意。若有菩萨于诸善根发勤精进。善心具足住正定聚。于生死中能以利根积集诸善。为善知识之所摄受。诸佛威神之所建立。因力具足。常当亲近诸佛世尊。尊重恭敬。以妙香花涂香抹香花鬘衣服缯盖幢幡。而供养之。若复得见诸佛如来具足相已。或闻正法美妙言已。或见圆满清净众已。又复得闻无碍之智。或见如来神境智通。或见如来调伏众生诸变化事。或教诫神变。或赞叹神变。如是见已。于众生所。常以大悲发阿耨多罗三藐三菩提心。起大精进勤求善法。于一切智心而不忘失。以相应行清净初心。初心净已。即得清净彼三摩地。海意。譬如种性所出大摩尼宝。善治宝人授其掌中。妙巧修治复加磨莹。乃至其宝得清净已。彼治宝人即自说言。此摩尼宝去除虚假。离诸瑕[醫-酉+土]。是为清净大摩尼宝。诸有智者共所爱乐。海意。从菩萨种性。发一切智心宝。亦复如是。毕竟能成阿耨多罗三藐三菩提故。由彼菩萨。初以宿世善根。及现闻善法。而用磨治。彼一切智心宝乃至是宝。去除意中诸虚假法。远离过失。十方三世诸佛世尊共所爱乐。而彼菩萨乃可自说。获得净印三摩地门。海意。又如清净大摩尼宝。离九种宝性。何等为九。一者金性。二者银性。三者颇胝迦性。四者吠琉璃性。五者马瑙性。六者珊瑚性。七者赤珠性。八者鸡萨梨宝性。九者吉祥藏宝性。离如是等九种宝性已。乃名悦意清净光明大摩尼宝。最胜无价。转轮圣王之所受用。乃非余王而受用之。又彼大摩尼宝光明殊妙。亦非余宝光明等比。海意。诸菩萨一切智心宝。亦复如是。而能超越九种宝性。何等为九。一者异生性善宝性。二者随信行人宝性。三者随法行人宝性。四者无相行宝性。五者须陀洹宝性。六者斯陀含宝性。七者阿那含宝性。八者阿罗汉宝性。九者缘觉宝性。超越如是九宝性已。第十乃名一切诸佛共所加持深心坚固大悲宝性。菩萨如是磨治。所发一切智心宝。时超胜一切声闻缘觉。而能照明一切众生相续种子。海意。又如真实大摩尼宝。而能容受磨治。堪任摧压穿亦不坏。彼摩尼宝能于世间善所作用。为诸众生施作福事。菩萨久植诸善根者。亦复如是。而彼所发一切智心宝。容受磨治堪任摧压。穿亦不坏。是宝真实离诸过失。而彼一切智心宝。能为一切众生作大饶益

复次海意。云何是为能善磨治一切智心宝。所谓先当具修三戒净十善业慈心随转故。以清净心观视一切众生。悲心随转故随诸众生何所作事皆往营助。喜心随转故一切众生诸有善法悉为成办。舍心随转故于一切众生而无损害。无谄诳故其心正直。无怠堕故于利益事深心勤行。心自在故即能发起一切善根得正念正知善伏心故其心调畅。常少欲故而能遍修头陀功德。能善资养生喜足故即不断圣种。于师尊圣贤之所不生侮慢故。即能谦下常起恭敬。心安定故。能离我慢及增上慢。无浊乱故无不清净心。不恃己故能知自行。不毁他故能护众生离增上慢故能亲近正法随授法药。于诸义中能领解故是求法者。于诸法中初浅次深渐增广故能具法欲。修无诤行故即常得法乐。远离非法故能勤求正法。于三宝中常惭愧故能不断净信。信业报故于一切善法中如理作意。修正行故于威仪道隐密寂静。心不高故而常柔软。勤行奢摩他故能离掉举。慧善安住故无毁无誉。安然不动故心如山王。能离高下诸对碍故其心如地。内意清净故其心如水。无异想故其心如火。无系着故其心如风。妙无垢故心如虚空。勤求出家故能令佛眼永不丧失。身能离故乐修寂静之行。心能离故常修正法之行。于诸所行不为尘境之所盗故说真实语。誓愿昭明故如说能行。不为烦恼所摧伏故心常清净。毕竟无破坏故能修集净戒。乃至小罪犹怀惧故即能于戒无缺无坏。不为求生天故于戒不断。纯一洁白行故戒无浊染。常能亲近善知识故。而得开明大菩提道。眼清净故得无碍光。耳清净故得无碍声。鼻清净故得无碍香。舌清净故得无碍味。身清净故得无碍触。意清净故得无碍法。复次海意菩萨。若欲离贪结者。应当常修不净之观。欲离嗔结修慈心观。欲离痴结修缘生观。欲除五盖善观五根。欲拔诸障清净五力。欲蠲现起诸烦恼故于出离道应常清净。修正行故能离贪嗔痴慢等怖。无悭心故能行法施。无吝摄故能行财施。大菩提心常坚固故不乐余乘之法。内心寂静故能隐密诸根。外境寂静故善观诸过失。于生死中常怖畏故不作诸罪。心无懈倦故。积集善根而无厌足。为渡四流故常善修治大乘法船。为令众生到彼岸故。善作桥梁。菩萨常以不懈退心。拔诸众生出生死泥到安隐处。海意。菩萨若能具修如是诸行相者。即得圆满布施之行。亦能清净持戒之行。此为菩萨能善磨治所发一切智心宝。尔时世尊。重说颂曰

  先当善戒身语心　　防护十种清净业
  慈心观视诸众生　　一切智心此磨莹
  悲心助营他所作　　喜心他法为成办
  舍心不害诸众生　　一切智心此磨莹
  无谄诳故心常正　　止罪能修利益事
  深心增长诸善根　　一切智心此磨莹
  心自在故念正知　　善伏心故心调畅
  少欲能修头陀因　　一切智心此磨莹
  喜足善行于圣种　　复常恭敬于师尊
  而能不生轻侮心　　我慢邪慢皆远离
  定心不起增上慢　　无浊乱故心清净
  不恃己故自了知　　不毁他故为他护
  亲近深固妙法药　　离增上慢治诸病
  希法名为求法人　　勤求法乃具法欲
  修无诤行名乐法　　离非法故能求法
  不坏三宝具信心　　一切智心此磨莹
  于不善中心怀愧　　于诸如来起惭心
  惭愧具足护诸根　　一切智心此磨莹
  明了业报胜所作　　信解不着边执心
  于缘生法不相违　　一切智心此磨莹
  善护威仪修正行　　心无高故常柔软
  掉举不生止行修　　一切智心此磨莹
  慧善住故无毁誉　　安然众睹如山王
  坚固愿中无退心　　一切智心此磨莹
  苦乐无动心如地　　意净如水涤尘劳
  心如火无异想生　　心如风行无系着
  心如虚空妙无垢　　勤求出家佛眼明
  身离能修寂静心　　心离常依正法行
  所行常说真宝语　　如说能行誓愿明
  清净不为染所摧　　无破毁故修戒行
  于戒无缺亦无坏　　小罪能坏大惧心
  护戒亦不求生天　　戒常洁白无浊染
  常能亲近善知识　　悉为开明菩提心
  无碍光明照世间　　斯由获得清净眼
  智者随闻种种声　　不生欣乐不生厌
  一切声中表义无　　斯由获得清净耳
  鼻香舌味皆如是　　身触意法亦复然
  触等高下想不生　　斯由获得诸根净
  欲离贪染及嗔痴　　当修不净慈心观
  于缘生法复善修　　一切智心此磨莹
  若欲除去五种盖　　应当善观于五根
  欲拔诸障之所缠　　善住清净于五力
  知出离道除现障　　离不深固住深固
  于四念处常勤修　　正断神足亦如是
  复常增进七觉分　　圣八正道亦增修
  无贪无嗔怖不生　　善护诸根离痴结
  无悭能行于法施　　不生鄙吝爱护心
  于财无摄常施他　　彼菩提心此成就
  于诸财宝无希取　　不舍菩提不求报
  为摄众生故常行　　布施爱语利同事
  于菩提心不舍离　　亦不爱乐于余乘
  随观如来功德门　　如须弥山心坚固
  内心寂静省己过　　外护他非不讥毁
  诸所作中离瑕疵　　怖生死故不造罪
  勤行善法无懈倦　　严净佛土不疲劳
  护法不生减失心　　度脱众生无退堕
  常勤修治大法船　　济渡四流生死海
  复为桥梁接众生　　引到涅槃安隐地
  拔众生出深淤泥　　致于清洁无畏处
  怖畏众生施慰安　　自渡渡他到彼岸
  若于此法善成就　　即诸菩萨大无畏
  彼能常净菩提心　　诸烦恼垢不能染
  虚空无垢尚能染　　空中鸟迹尚可见
  烦恼不染菩提心　　自性本来常清净

复次海意。云何是为菩萨。于其所发一切智心宝。堪任摧压。又复何谓摧压行相。海意。若此菩萨。于其一切智心宝中。或有破戒不可意人。或复诸魔或魔徒众。或魔力所加魔宫贤圣。或魔使者固来娆恼。振击动摇期克打掷当于尔时。菩萨坚固大菩提心。令无所坏。亦复不坏度脱一切众生大悲精进。亦复不坏勤力护持。令三宝种不断不绝。亦复不坏诸佛法中勤行积集一切善根。亦复不坏为成办相好故积修福行。亦复不坏为严净佛土故勇力增进。亦复不坏为护正法故不惜身命。亦复不坏普为度脱诸众生故不着己乐。菩萨若能如是深心具足。起如是意。乃能于彼诸众生所。或遇嗔恚打掷骂辱讥毁之者。菩萨尔时悉能忍受。或为一切众生之所摧压。亦悉堪任。以其菩萨普为救度一切众生。不疲不懈。不退不没。增发势力。勇起精进。捍劳忍苦。摄受心故。若有他人固来起嗔。菩萨尔时不以嗔对。他来打掷或复破毁。菩萨尔时皆不以对。作是思惟。我今应被大乘忍铠。何以故。此大乘法。与诸世间极相违故。世间众生顺生死流。我大乘法逆生死流。世间众生互相违背。我大乘法。令诸众生断相违故。世间众生嗔恚炽盛。我大乘法忍力增强。世间众生互相欺诳。我大乘法令诸众生慧心圆满。又复世间。或有众生周行十方。执持器仗随逐菩萨。于诸方处。若行若住若坐若卧。或有一人发大菩提心者。或修布施心者。或修持戒忍辱精进禅定智慧心者。乃至或闻发一善根心者。我当随于彼彼方处。断割其身节节支解犹如枣叶。菩萨设遇如是等事。悉能堪忍。又若世间一切众生。皆起嗔恚。巧出恶言骂辱讥毁。菩萨尔时。于诸众生不起少分娆动之心。所以者何。今我此身于无量无数生死之中。先际已来遍历诸趣无所不作。或在地狱。或在饿鬼畜生等趣。乃至今在人趣之中。耽味饮食诸欲受用。听受非法。艰苦追求。邪命资养多种逼迫。于己身命都无果利。虽复多所营作。不能自利亦不利他。是故我今乃至生死后际之中。设使一切众生于我身分断割支解。宁受众苦我终不舍一切智心。亦复不舍一切众生。亦复不舍诸善法欲。何以故。今我此身。多种逼恼苦切残毁。比地狱中所受之苦。百分千分乃至优波尼杀昙分皆不及一。是故我于佛法之中。永不舍离。亦复不舍度脱众生所缘大悲。何以故。如佛所说。一切善法多诸障难。世间众生多于不善法中而能营助。少能营助于诸善法。是故我今于善法中发勤精进营助修习。非于不善法中而助其力。故我于彼一切众生嗔恚等事。悉能堪忍。若诸众生随所起事。我即旋当施所对治。若有众生于我起嗔加复嫌恨。我即施其辱忍之法。由我施彼忍辱法已。忍力现故。我于彼所宁舍身命终不起嗔。是故菩萨。若如是修。即不难得阿耨多罗三藐三菩提果。又复若时。或以因缘嗔恚起时。菩萨当念我起断嗔之法。断法云何。谓若爱乐于身。若系属身。若取着身。如是等法皆悉舍离。由能如是弃舍身故嗔恚不起。海意菩萨。若于如是等法。能善思惟勤修习者。即能堪任一切众生之所摧压。于一切智心。不坏不失。海意当知。堪任摧压有其三种。一者堪任摧压于身。二者堪任摧压于语。三者堪任摧压于心

佛说海意菩萨所问净印法门经卷第二佛说海意菩萨所问净印法门经卷第三

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次海意。云何是为菩萨堪任摧压于身。谓若菩萨或遇身分欲断坏时。菩萨应当依法观察余诸众生。又若有具善巧方便菩萨。即能修行圆满六波罗蜜。何等行相是为善巧方便菩萨圆满六波罗蜜。所谓菩萨或遇己身欲断坏时。若不惜其身。弃舍其身亦不爱乐。此即能修施波罗蜜。又复若遇身欲坏时。于一切众生起大慈心而不弃舍。此即能修戒波罗蜜。又复若遇身欲坏时。菩萨为度一切众生故。设身断坏堪任忍受。其心不动忍力发现。此即能修忍波罗蜜。又复若遇身欲坏时。不舍一切智心。发大精进勇力摄受。于生死中起诸善根。此即能修精进波罗蜜。又复若遇身欲坏时。于其所发一切智心宝。而不弃舍。当善伺察大菩提心。如是伺察内外寂静。此即能修定波罗蜜。又复若遇身欲坏时。菩萨应当伺察其身。犹如草木土石等类。悟了己身不实如幻。如实义者。诸行无常。诸行是苦。诸法无我。涅槃寂静。若能如是谛察其身。此即能修慧波罗蜜。如是行相。是为菩萨修行圆满六波罗蜜。乃得不退转于大乘之法。此等名为菩萨堪任摧压于身

复次海意。云何是为菩萨堪任摧压于语。谓若菩萨或有人来若虚若实恶言讥毁嗔恚骂辱。菩萨尔时。堪任容受不起嗔恚断彼怨缚。又若有具善巧方便菩萨。或遇他来恶言讥毁骂辱之时。菩萨闻已。应当修行圆满六波罗蜜。何等行相是为善巧方便菩萨圆满六波罗蜜。所谓菩萨。或遇他来恶言讥毁骂辱之时。菩萨闻已即作是念。此人先世造悭吝因。由如是故悭吝垢染。今所发现亦复不曾亲近善友。是故此人不舍于嗔。我今为说断嗔之法。何以故。我能信解施舍法故。不悭吝故。亦曾亲近诸善知识。是故我今护其恶语。舍离嗔恚。此即能修施波罗蜜。又复他来讥毁骂辱。菩萨尔时即作是念。此人破戒恶业发现。故来嗔恚骂辱于我。我今修集清净禁戒。故我于彼不生嗔恚。我复守护菩提心故。念业报故。此即能修戒波罗蜜。又复他来讥毁骂辱。菩萨尔时即作是念。此人粗猛过失多所嗔恚。故来讥毁骂辱于我。我今具其忍辱之力广修慈行。故我于彼不生嗔恚。此即能修忍波罗蜜。又复他来讥毁骂辱。菩萨尔时即作是念。此人懈怠远离善法。故来于我嗔恚骂辱。今我发起广大精进。勤行修习植诸善本曾无厌足。我愿此人先得坐于菩提道场。我乃最后取证阿耨多罗三藐三菩提果。若被如是精进铠者。此即能修精进波罗蜜。又复他来讥毁骂辱。菩萨尔时即作是念。此人失念复不正知。而亦不能止息烦恼。故来于我嗔恚骂辱。今我止息烦恼。正念正知专注一境。复不忘失大菩提心。我今应为此等众生不调伏者不寂静者不护诸根者不止息者。作利益故被大乘铠。若能如是安定心者。此即能修定波罗蜜。又复他来讥毁骂辱。菩萨尔时即作是念。此人执着我相情见有所得境。故来于我讥毁骂辱。今我依法。于已起嗔若未起嗔。二种之中如实伺察。嗔者嗔法皆不可得。如理推求。若自若他而悉远离。有所得见故能堪任。此即能修慧波罗蜜。海意。如是行相是为善巧方便菩萨修行圆满六波罗蜜。乃得不退转于大乘之法。此等名为菩萨堪任摧压于语

复次海意。云何是为菩萨堪任摧压于心。谓若菩萨。遇诸魔来相娆坏时。菩萨应当坚固不动大菩提心。又复一切邪异之语。以有所得有所著相来相娆时。亦应如实安住内心。于一切智心勿当忘失。何以故。彼魔有大威力。乃至最后变佛形像来现汝前。作如是言。汝于大乘法中何有力能。汝宜弃舍如是重担。止息所行勤苦精进。菩提难得。佛法难得。于生死中徒历多苦。今汝大士。若欲息其苦者。宜速取证声闻涅槃。若诸菩萨。或遇魔来以如是相固娆坏时。当被如先坚固之铠不应弃舍。亦当内心无动无坏。若如是者。即于无等等心不能减没。菩萨尔时乃作是念。我当决定诣菩提场。我当决定以大智力摧魔军已。然后取证阿耨多罗三藐三菩提果。我当决定转妙法轮。我当决定普于三千大千世界说广大法。我当邀以一切众生普与法施悉令满足。一切诸佛以他心智照明于我。一切贤圣证知我此大菩提心。实能堪任诸所摧压。我不虚诳一切诸佛一切贤圣一切众生。乃至亦不自为虚诳。海意。若诸菩萨如是修者。即能堪任摧压于心。乃得不退转于大乘之法。此等行相。是为菩萨于其所发一切智心宝堪任摧压。若于忍辱波罗蜜被坚固铠。即于精进波罗蜜而不懈退。若复此二波罗蜜中能圆满者。是即菩萨摩诃萨于一切智心宝。堪任摧压

尔时世尊。重说颂曰

  大菩提道心不坏　　亦复不坏大悲心
  于三宝中善护持　　积集佛法亦无失
  三十二相八十好　　十力庄严妙相身
  多种修作福智圆　　堪任摧压故无退
  佛土功德无边量　　无愿力故悉严净
  法宝无上最胜门　　我愿坚固常守护
  多百众生无边际　　我愿普令得度脱
  内心不坏利乐因　　是故堪任于摧压
  所有十方世界中　　乃至无边众生界
  普尽一切诸众生　　各执器仗来逼恼
  作大恐怖生嗔恚　　如是期克而打掷
  菩萨为修功德因　　起勇胜心能堪忍
  经历无边多百劫　　从本生死先际来
  众生恶言骂辱时　　彼菩萨心无恼害
  为大智故能堪忍　　不生忿怒不生嗔
  如是摧压随了知　　故能忍受得清净
  又复普尽诸众生　　各执器仗来加害
  于我身分悉支离　　乃至叚叚而破折
  菩萨尔时心无动　　不生少分嗔恚心
  大菩提意坚固持　　堪任摧压此清净
  菩萨若行若复住　　坐卧威仪他所随
  于中伺求或有人　　大菩提心不舍者
  或行布施等诸行　　或复发起余善心
  即当断割彼人身　　节节支解而离散
  菩萨设遇此苦时　　亦于此人心生喜
  思念无边百劫来　　遍历诸趣靡不作
  地狱鬼畜三涂界　　乃至今得生人中
  身虽破坏果利无　　为求佛智身弃舍
  今我虽得于人身　　无数众苦常逼迫
  若比阿鼻地狱中　　此苦百分不及一
  我宁处彼地狱中　　忍受其苦经百劫
  佛及正法与众生　　此三我终不弃舍
  我观此身无常法　　刹那谢灭犹如幻
  四界虚假共合成　　佛说此四如蛇毒
  我若弃舍于此身　　速离身中诸毒害
  彼烦恼毒欲消除　　自他成佛自然智
  今我此身处世间　　多怖畏事生恐怖
  为求身诸安乐缘　　因诸所欲饮食等
  我若弃舍于此身　　止息诸缘离诸怖
  若能解入此思惟　　即能堪任诸摧压
  世间众生多百千　　不善法中常营助
  少人能于善法中　　随应勤力而营助
  故我于诸不善法　　是中不复助其力
  我当助修忍辱门　　忍辱之言佛所说
  所有十方一切佛　　一一皆为证明我
  如我所起决定心　　于佛乘中永不坏
  彼大威力诸贤圣　　亦悉证我堪忍心
  我所堪任摧压因　　是中不作诸过失
  如佛所说身语意　　此三摧压有多种
  彼彼勇猛悉堪任　　如先所说皆不坏
  是身具有多种苦　　彼一一苦无边际
  于如是苦若堪任　　此身摧压而清净
  若身遭苦而离散　　节节支解断坏时
  六波罗蜜若圆成　　彼善方便大智德
  所谓布施及持戒　　忍辱精进与禅定
  最胜慧等若同修　　须臾摄受皆圆满
  或时若能弃舍身　　亦复不爱而不惜
  尔时应当如是修　　圆满布施波罗蜜
  若于众生广行慈　　即不破毁净戒行
  现证菩提摄受因　　圆满净戒波罗蜜
  其身设欲断坏时　　应当坚固忍辱力
  由斯忍力若勤行　　圆满忍辱波罗蜜
  精进重担荷无倦　　内心亦复不生厌
  身虽破坏力坚持　　圆满精进波罗蜜
  其身设欲断坏时　　不念弃舍菩提心
  于诸烦恼尘暗中　　勤力为令皆消灭
  为修禅定解脱力　　宁当破坏于己身
  普令众生得离尘　　圆满禅定波罗蜜
  我观此身实无我　　是身如幻复如电
  作者受者二俱无　　是中实无有少法
  于身艰苦缠缚中　　善为众生作度脱
  到胜彼岸自他圆　　圆满胜慧波罗蜜
  若能于此深固法　　方便思惟常善修
  彼能堪任摧压身　　是中不起诸过失
  菩萨若时闻恶言　　不善讥毁而轻谤
  闻已不生嗔恚心　　能起慈心善调伏
  弃舍嗔恚诸过失　　清净布施波罗蜜
  慈心广大普运行　　清净持戒波罗蜜
  忍力发现彼对治　　清净忍辱波罗蜜
  数起精进佛智求　　清净精进波罗蜜
  于诸境中定其心　　清净禅定波罗蜜
  了不可得诸音声　　清净胜慧波罗蜜
  菩萨闻诸恶言已　　应当思惟于深法
  堪任摧压于语言　　是故不着诸过失
  假使百千诸魔众　　邪异外见悉从来
  劝令弃舍方便修　　菩提分位言难得
  菩萨尔时心不动　　势力增进转精修
  是故堪任摧压心　　多种摧压皆无坏
  忍辱精进此二行　　善修安住如山王
  诸所摧压悉堪任　　诸众生同一勇猛
  磨治心宝摧压者　　如来十力悉能知
  得见现证菩提尊　　亦复得受成佛记

复次海意。云何是为菩萨于其所发一切智心宝穿亦不坏。谓若菩萨于彼一切智心。无所领纳无所依着。亦无所住不出不入。无戏论无分别。坏诸分别无所安立。当以正智于甚深法如实伺察。何等是为彼甚深法。所谓随顺缘生之法如实觉了。无因所缘不断不常。远离边见自性无我。我无自性故一切法亦无自性。诸法本来生无所生。解了于空。信顺无相无愿无求。于真实慧无所造作。毕竟无常。色如聚沫。受如浮泡。想如阳焰。行如芭蕉。识如幻法。诸界无所动。诸入互相生。心无所住亦无作意。于增上所作非增上所作。于平等法如实觉了。无种种行相等同一味。而悉同住一乘之道。修道行智依于胜义。以智了知于义无著。彼一切声悟入非声。智知一切声。前后际断故。文义二种智入无二。现证诸法不可说义。无我义是苦智。毕竟义是集智。不和合义是灭智。有为无为平等悟入是道智。离前后际是身念处生灭无住是受念处。观无所缘是心念处。法界非界性平等平等义是法念处。心自在义是四正断。离诸障碍是四神足。出生义是信根。无念是精进根。无作意是念根。超越戏论是定根。无他信是慧根。所缘无障碍是信力。通达诸力是精进力。心止息住是念力。无所动转是定力。于念随念是慧力。于一切法平等相应是念觉分。不出不入是择法觉分。无我所是精进觉分。身心善住是喜觉分。平等觉悟是轻安觉分。离二法是定觉分。远离诸见是舍觉分。一切分别无分别中离诸遍计是正见。一切音声平等悟入是正思惟。离身心法是正语。一切所作悉得轻安名为正业。无高无下是正命。若善不善随施设已平等而住是正勤。于心所缘平等悟入是正念。寂静安住妙奢摩他是正定。于见非见而悉清净无所生义是无常义。本来不生义是苦义。无所行义是无我义。止息义是寂灭义。善调伏心是布施义。住清凉性是持戒义。随知尽法是忍辱义。于一切法能善决择是精进义。止息内心是禅定义。如实了知诸法无相是胜慧义。一切众生本来清净是慈义。与虚空等是悲义。喜无所得是喜义。一切发行皆悉究竟是舍义。一切诸法先际已来三轮清净是空义。后际清净是离义。现在清净是无我义。海意。若诸菩萨。于如是等诸甚深法。无起无灭离诸文字与虚空等。于顺于违智入平等。若能如是思惟观察如实所行。而彼菩萨即能于其所发一切智心宝穿亦不坏。虽复如是穿彼一切智心而无发悟。即于诸法自在理中乃能现证。海意。譬如日月各处自宫。于四大洲周遍普照。而彼日月天子都无发悟。亦不作是念我能往诸方处。或复不往而为照曜。但由一切众生福果报力照明如是。海意。彼具善决择智菩萨。亦复如是。虽于无量诸佛刹中广为众生作大利益。而彼菩萨都无发悟。未尝数起诸作意想。然彼所作随应发现

复次海意。若具决择智菩萨。应于定波罗蜜及慧波罗蜜中。如理伺察。何以故。住等引心菩萨。不修观法。修观行菩萨。不住等引心。若复修观行者彼即有慧。由有慧故能善观察。何所观察。所谓观于诸法实相。云何是为诸法实相。若于诸相而无所行。此即是为诸法实相。何等是诸法相。谓有所表即诸法相。如是表中如实之相。此亦说名诸法实相。若复如是一切了知。即能悟达无相无无相。何者是相。何者是无相。相即是生。无相是灭。若无相无无相。即无生亦无灭。若法无生亦无灭者。即诸法性本来常住法界无坏。真如无动实际不变。如是法性。此即说名如实解了缘生之法。觉悟诸法真实之相。现证实际无二真理。如是乃以现量智知。海意。此即名为具决择智菩萨摩诃萨。当佛世尊宣说如是容受磨治堪任摧压穿亦不坏法时。此会中有十那庾多天人。悉发阿耨多罗三藐三菩提心。万六千菩萨皆得无生法忍

佛说海意菩萨所问净印法门经卷第三佛说海意菩萨所问净印法门经卷第四

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时世尊。重说颂曰

  菩萨若闻菩提心　　乃能贯穿一切法
  即此所有贯穿智　　于诸法中无所著
  虽复了知甚深法　　菩萨于中不生怖
  而亦不起恐怯心　　彼能获得最胜道
  诸法若因若所缘　　如实觉了缘生法
  有慧随顺诸法生　　而实不执于边见
  诸法若断若常中　　智者不生于着碍
  觉了中际亦复然　　是故实际不思议
  若法自性本无我　　是中我亦无自性
  诸法无性亦复然　　本来不生皆空寂
  诸法无生亦无起　　空无所取常清净
  远离戏论无相门　　一切皆与虚空等
  无心亦复无求愿　　远离一切诸欲贪
  现观诸色自性中　　其犹聚沫知无实
  受如浮泡暂起灭　　想如阳焰妄相生
  行如芭蕉中不坚　　识如幻法非久固
  所有四界性无动　　与彼虚空界同等
  内外诸入亦复然　　境互相生而冥默
  应知心法不在内　　亦非于外有所得
  意法无我亦复然　　是中诸识皆无住
  彼一切法无作意　　而亦远离于我相
  于一切法平等中　　如实觉了于正性
  法本一味无异性　　一道一乘皆同等
  道智如实若了知　　此义显示于胜义
  智者于义能悟入　　观声非声能觉了
  世间所有一切声　　前际后际二俱断
  若文若义虽善解　　于中了知无二法
  解此不可说义门　　即能现证真实性
  诸法不生是苦智　　诸法平等是集智
  诸法尽义是灭智　　诸法无为是道智
  于彼身受心法中　　如理随观一一法
  无念复无作意行　　此说是为四念处
  若观法界非界性　　平等正尽而平等
  无断之断正法门　　此说是为四正断
  于心若得大自在　　此说是为四神足
  超越一切有着心　　此即是名为信根
  若于一切法寂静　　此说名为精进根
  无念之念正法门　　此说是名为念根
  若了诸法无作意　　此说是名为定根
  超越诸法戏论门　　此说是名为慧根
  若法不起于他信　　即能获得真实智
  于心亦无所觉知　　此名信力精进力
  若了无生无灭智　　此即是名为念力
  寂定于心无所行　　此即定力得成就
  非有非离于分别　　此即是名为慧力
  诸法义中实觉知　　此说是为七觉分
  于法平等无差别　　此说是名为正见
  无二法中如实观　　无生是观诸正道
  无生是为无常义　　无起是名为苦义
  无行是名无我义　　止息句是寂静义
  调伏心即是布施　　寂静心即是持戒
  尽法随向是忍门　　正慧伺察名精进
  毕竟寂止是禅定　　如实了知是为慧
  众生本来清净心　　了知此说名为慈
  与虚空等名为悲　　清净适悦是为喜
  一切所缘无住心　　此说是名为舍行
  若复三轮得清净　　即能了知一切法
  如是贯穿诸法门　　而复永断诸见执
  此中所有定及慧　　即此二法能贯穿
  遍入无量境界门　　此说是名正法智

尔时世尊。复告海意菩萨摩诃萨言。海意。若菩萨得如是净遍净已。于一切众生所起无虚假意。若为众生之所摧压。不生逼恼及诸障碍。得善觉了智。得决定慧。而彼菩萨。即能于此自说净印三摩地根本。无住中住。云何是为安住三摩地根本。谓于一切众生无障碍故。起大悲故。若得一切众生常所恭敬。心亦不高。若不恭敬。心亦不下。由是之故。即法无所起。亦不生慢心。是故乃能随住诸法。不住痴法。能生法智。普遍皆得。智为先导身业具足。智为先导语业具足。智为先导意业具足。若身语意诸所作业。一切皆以智为先导。菩萨即能随智而转。云何是菩萨智为先导身业具足。谓若众生应见色身而可化度及调伏者。菩萨即当现威仪相。令彼众生心得调伏。菩萨虽复如是现相。然无发悟。亦无分别。若或菩萨身起过失。爱着于身。身起异相。身行屈曲。身有动乱身生计度。若如是者。而彼菩萨诸有过失集现其前。如断多罗树心。而于诸法后不复生。又若菩萨身得清净。一切胜相庄严其身。手足柔软殊妙可爱。成福生身。诸根无劣身分圆满。菩萨虽具如是庄严之身。然于色相亦不骄恃。身虽严好而不生于和合之想。菩萨若见一切众生种种色相有缺坏者。菩萨尔时不起慢心。为求法故谦下恭敬。所以者何。若自身法性与一切众生身之法性。皆悉平等依止于智。菩萨于身及身法性。悉了知已。即得法身。不受分叚身。何名法身。谓以禅悦而为饮食。非分叚食。菩萨为欲顺世间故。愍众生故。示现受彼世间之食。不为身支治瘦劣故。菩萨但于法身。以其法命而为资养。非假世间叚食所资。何名法命。谓所资养。不从因缘所造作故。不越圣行。何名圣行。所谓无贪无嗔无痴。离诸烦恼。随所施设密护于戒。是名圣行。菩萨由此智为先导。身业具足。故获诸智通。神力成就。以无发悟心。于一切佛刹中普为现身。随诸佛刹一一众生。应见菩萨色相光明庄严身者。菩萨即住无所发悟无分别中。具足光明庄严身相。于其身中放大光明。是光普照无量无数诸佛刹土。一切地狱恶趣众生。蒙光照触悉得快乐。由快乐故乐触现前。得乐触故。一切众生烦恼烧然。皆悉止息。咸得清凉身心调畅。彼诸众生得调畅故善作佛事。海意。如是等法。名为菩萨智为先导身业具足

复次海意。何名菩萨智为先导语业具足。谓若菩萨凡出语言。而常远离语中一切粗恶过失。海意。何名语中粗恶过失。所谓菩萨常当远离六十四种语之过失。何等六十四。一者菩萨无粗涩语。二者无浊乱语。三者无坏器声语。四者无衰弱声语。五者无极高声语。六者无极下声语。七者无猛恶声语。八者无坚硬语。九者无謇吃语。十者无逼恼语。十一者无离散语。十二者无烧然语。十三者无迷惑语。十四者无怨恨语。十五者无密切语。十六者无染着语。十七者无呻吟语。十八者无童稚语。十九者无震吼声语。二十者无炽盛语。二十一者无掁触语。二十二者无不知时语。二十三者无贪随卑语。二十四者无嗔障碍语。二十五者无痴狂乱语。二十六者无惊怖语。二十七者无慢执语。二十八者无作破坏语。二十九者无谄曲语。三十者无高慢语。三十一者无离慢卑下语。三十二者无随爱覆藏语。三十三者无非爱讦露语。三十四者无不实说语。三十五者无缺失语。三十六者无虚妄语。三十七者无斗乱语。三十八者无两舌语。三十九者无恶口语。四十者无绮语。四十一者无破朋友语。四十二者无极利语。四十三者无极柔软语。四十四者无凡俗语。四十五者无不藏护语。四十六者无繁多语。四十七者无嗔害语。四十八者无斗诤语。四十九者无贱劣语。五十者无动乱语。五十一者无轻浮语。五十二者无面讥语。五十三者无戏剧语。五十四者无歌音语。五十五者无非法语。五十六者无离间语。五十七者无自赞语。五十八者无毁他语。五十九者无侮玩语。六十者无激动语。六十一者无违背佛法僧语。六十二者无毁谤贤圣语。六十三者无非理作证语。六十四者无一切粗恶过失等语。海意。如是六十四种语中过失。菩萨凡所发言皆悉远离。即得语业清净。凡所发言皆说无间断语。说如实语。说正真语。说诚谛分位语。说随谛转语。随入一切众生语言。知一切众生意乐。令诸众生皆生欢喜。照明一切众生根性。息诸烦恼。住佛威神。任持正法。所发语言。分明显了。美妙可爱离诸过失。皆由福行之所成故。不生于贪摄功德语。不生于嗔深无源底。不生于痴。十方世界施设语言。非无义利。随往一切处。皆无作相。海意。此为菩萨智为先导语业具足

复次海意。何名菩萨智为先导意业具足。所谓菩萨刹那于一心中。遍入一切众生心行。皆悉明了。住三摩呬多中。现诸威仪事。然亦不起彼三摩地。一切魔众。悉不能知菩萨心业。遍入一切声闻缘觉之心。彼亦不知。而是菩萨。终不生心自害害他。亦不俱害。非心意所表。无少法中而生障碍。于一切法中。起智了知。由彼心意无表了故。即无所了知。不受而受。未具佛法。亦不灭受而为取证。海意。此名菩萨智为先导意业具足。海意。如是等法。是为菩萨安住自说净印三摩地根本。此根本者。谓即菩萨身语意业。皆以智为先导。由其三业智先导故。即能获得自说净印三摩地法。海意当知。有十种法。此三摩地名为自说。何等为十。一者初发起行。名为自说深心清净故。二者菩萨之行。名为自说六波罗蜜多清净故。三者显示洁白之行。名为自说一切善法清净故。四者相好圆满之行。名为自说无碍福行清净故。五者得辩才行。名为自说随闻法行善令他得清净故。六者念定不散乱智。名为自说远离一切粗重盖障。现起烦恼清净故。七者菩提分法智。名为自说不放逸清净故。八者表示奢摩他毗钵舍那智。名为自说心意识清净故。九者十地次第之智。名为自说。一切对治建立法中。超越障碍悉清净故。十者大菩提场庄严之智。名为自说断一切不善法。集一切善法清净故。海意。具是十种法故。此三摩地名为自说。海意当知。复有二十种法。此三摩地名为净印。何等二十。一者内净名为净印。我清净故。二者外净名为净印。我所清净故。三者身净名为净印。一切见中悉清净故。四者一切法无我清净。名为净印。本来清净故。五者于一切法平等觉了清净。名为净印。一味清净故。六者空无相无愿清净。名为净印。一切解脱清净故。七者虚空清净。名为净印。毕竟清净故。八者众生界法界清净。名为净印。离诸所作故。九者现所见清净。名为净印。自智通清净故。十者日轮光明清净。名为净印。常照曜清净故。十一者三世无碍知见清净。名为净故。离诸障碍清净故。十二者表了门清净。名为净印。识智无住清净故十三者无为清净。名为净印。有为自性清净故。十四者了知缘生清净。名为净印。善观缘法故。十五者随证力无所畏佛法清净。名为净印。无能敌实智清净故。十六者了知佛法相清净。名为净印。先业清净故。十七者大慈大悲清净。名为净印。不舍众生清净故。十八者降伏诸魔外道清净。名为净印。一切所行清净故。十九者破一切烦恼种习清净。名为净印。诸法自性清净故。二十者于一刹那心中。普尽一切佛法之门。随知清净名为净印。积集圆满清净故。海意。具足二十种法故。此三摩地名为净印。海意当知。菩萨当坐菩提场时。乃能获得是三摩地。得是三摩地后。当获八种不共大神通相。何等为八。一者忽然此三千大千世界。悉变金刚所成之地。二者一切树林花果枝叶。皆悉开敷俱向菩提树。低垂曲折作恭敬相。三者一切众生于刹那间。不为一切烦恼之所恼害。四者一切地狱恶趣众生。悉见菩萨坐菩提场。见已皆获快乐具足。五者一切世界。空中悉现金色光明广大照曜。六者大地皆悉震动。然于其中亦无少分众生而生娆害。七者所有十方现住说法教化诸佛世尊。以无畏法施其安慰。作如是言。汝善男子。最胜最胜。是大导师。八者于一刹那心中。一切佛法集现其前。海意。而是菩萨得彼净印三摩地已。后获如是八种不共大神通相。而能出生无量功德之事。一切悉同此三摩地神通威力

佛说海意菩萨所问净印法门经卷第四佛说海意菩萨所问净印法门经卷第五

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时世尊。重说颂曰

  此法善净复明亮　　本无和合与空等
  无住无灭无起生　　是印随摄于佛印
  住彼根本得总持　　长时修习慈悲行
  若敬若慢世所行　　平等慧中无喜恚
  等智随住于法性　　不住痴暗及痴法
  虽住智中无得心　　安止等智常清净
  智常觉了身所作　　以诸智行利世间
  众生若见清净身　　皆得离尘胜佛智
  威仪善戒无散乱　　有无分别中随行
  身诸过失虽无边　　本来不生无所断
  彼获庄严妙相身　　手足柔软福严具
  清净圆满诸根身　　不恃色相智所作
  若见贫贱苦众生　　谦下尊敬而不慢
  尊奉知法持戒人　　从彼闻法得圣道
  实知自他身法性　　知诸众生实性身
  获得净胜妙法身　　不受分叚身离染
  常受定中禅悦食　　不以叚食益威光
  顺世受食非力资　　法命滋养成甘露
  常获圣行善寂静　　解脱贪嗔痴染聚
  密护戒学无顺违　　宁舍己身不造罪
  神力能往俱胝刹　　随应现身而说法
  世间瞻睹妙相身　　彼皆获得身高胜
  身放光明妙清净　　广照无边诸刹土
  光照福胜软触生　　众生悉除烦恼害
  地狱众生常受苦　　蒙光照触得快乐
  身意调畅酸楚停　　由斯得离地狱苦
  如是及余诸身业　　随智无边善殊妙
  能开佛事调伏门　　菩萨身业此清净
  语言妙音净悦意　　天人世间闻皆喜
  凡所说法果不虚　　此法能成甘露灭
  语言随堕语过失　　清净福智善能断
  众生语业及音声　　普令同等皆欢喜
  相续平等真实说　　言无浊乱皆如实
  凡所说言诚实行　　智随谛转善清净
  语言甘美贪止息　　摄功德语嗔解脱
  甚深无底断除痴　　于千刹中作善利
  此所说言无分别　　不假勤力随解脱
  应众生根欢喜生　　此智所作语清净
  善修意业常无障　　一刹那心世悉知
  不起灭定现威仪　　魔不能知菩萨意
  声闻缘觉不能测　　菩萨甚深心意道
  不生自他损害心　　无高无碍智平等
  菩萨随世善觉知　　无受无思无伺察
  不入灭定证乐门　　无边辩才总持具
  闻法所行智常住　　念定无乱住等引
  清净诸障烦恼除　　极微瑕秽悉不见
  菩提分法无边量　　悉能普摄离放逸
  智常随住止观中　　十地次第今成证
  乃至道树成智果　　若具十种法清净
  菩萨得定名自说　　现修诸行净圆满
  一切善道净胜上　　随诸地位净诸度
  一切善法超胜高　　相好殊妙圆福果
  坐菩提场善毕竟　　染法胜怨悉能断
  积诸善法等须弥　　不思议光净成就
  得是三摩地获福　　具二十法名净印
  如日光明照世间　　证大菩提佛胜智
  菩萨当坐道树已　　得八不共神通相
  能于百佛刹土中　　广作利乐世间事
  诸佛皆来施无畏　　赞言勇猛汝最胜
  悉能已伏诸魔军　　证佛菩提胜无上
  获此身心胜功德　　决定能成此佛印
  此功德门若欲修　　当于菩提心坚勇

尔时世尊。复告海意菩萨摩诃萨言。海意。以是缘故。若诸菩萨欲得如是自说净印三摩地法门。及自说无垢慧者。当住二种之心。一者无浊乱心。二者无滓秽心。无浊乱心者。谓心自性清净明亮。而不容受客尘烦恼。法性常住本自光明。一切作意无所积集。无尘故离贪。无分别故离嗔。无我故离痴。清净遍净。毕竟无垢。自在光明如所解脱。一切法亦然。随住真如平等故。如所解脱一切法亦然。随住法界平等故。如所解脱一切法亦然。随住实际平等故。如所解脱一切法亦然。随住空平等。随住无相无愿无造无作无生无起诸平等故。如所解脱有为法亦然。随住无为法平等故。即此随住平等之法。无集无散。非智所知。此说名为无浊乱心。即以此法为他众生。及余补特伽罗。显明开示。于自他法不起动乱之想。此即是为无滓秽心。海意。具是无浊乱心。无滓秽心者。即能获得自说净印三摩地门

尔时海意菩萨白佛言。世尊。此三摩地而极甚深。佛言。不得涯底故。海意又言。世尊。此三摩地而极难见。佛言。离二法故。又言世尊。此三摩地极难觉了。佛言。无我我所故。又言世尊。此三摩地而极难知。佛言。识智二法平等知故。又言世尊。此三摩地而无浊乱。佛言。得无碍解脱故。又言世尊。此三摩地而极微妙。佛言。离诸譬喻故。又言世尊。此三摩地而极精实。佛言。得金刚喻智故。又言世尊。此三摩地而不破坏。佛言。先后不破故。又言世尊。此三摩地悉无所著。佛言。一切有着随超越故。又言世尊。此三摩地得大光明。佛言。离诸痴瞑故。又言世尊。此三摩地而极清净。佛言。毕竟无染故。又言世尊。此三摩地本性无垢。佛言。离贪尘故。又言世尊。此三摩地而无所行。佛言。三界无行故。又言世尊。此三摩地而无戏论。佛言。超越戏论故。又言世尊。此三摩地无动。佛言。毕竟寂静故。又言世尊。此三摩地随入一切处。佛言。与虚空等故

尔时海意菩萨复白佛言。世尊。若如是者。何能发起胜行。云何当获自说净印三摩地门。佛言海意。譬如有人欲与虚空而共战敌。时彼虚空乃被甲胄。菩萨亦复如是。欲得自说净印三摩地者。应当被于诸法平等甲胄庄严。何以故。海意。随有所灭即有所起。又复海意。识种子是有为。无表种子是无为。此三摩地非眼识所知。非耳鼻舌身意识所知。此三摩地不可表了。应知无知亦非无知此三摩地无表了相。于一切法平等觉了故。此名三藐三佛陀。又复海意。我不见有法是染相故。成等正觉。亦不见有法是净相故。成等正觉。若有相是染。即彼相是净。所谓自性清净相故。若彼自性清净相者。即是无相。若其无相即无行相。若无行相。即无少法而可表了。由无表故即一切法无所了知。若法无能表及无所表故。是中即无文字集现。若无文字可集现者。即所说如。此复何名即所说如。谓后如于前中亦复然。此即是名一切诸法三世皆空。复何名空。所谓无作。即此无作。亦复无作。亦非无作。是故此说名之为空。所言无作义复云何。无作者。谓无现前诸行造作。以无少法可造作故。是故此说名为无作。复何名为无现前行。谓无身现前行。语现前行。心现前行故。此说名无现前行。若无现前行。彼即无为。若其无为。即无生无灭。亦无处所。即此无生无灭无处所法。亦复无处。何名无处。所谓现前诸行无处。是故此说名为无处。所以者何。所谓识不住色中。不住受想行中。若识无所住即是正智。而彼正智即智无领纳。若智无领纳即无增上意乐。若无增上意乐即无诤论。若无诤论即无动乱。若无动乱即无逼恼。若无逼恼即无烧然。若无烧然即得止息。若得止息即住遍寂。若住遍寂即住近寂。若住近寂。此即名为得大寂默。是故前言智无领纳。是佛所说。海意。此法甚深难见难解。若有得闻如是之法生信解者。是人所有一切颠倒烦恼执着缠缚等法。悉得解脱。即能任持过去未来现在诸佛世尊法藏。为大导师。开示一切众生无量正道。为大医王。善疗众生一切无相烦恼之病。是为能以广大供养普供如来。不久当得自说净印三摩地门。所作决定。于此大乘法中能善积集。为大法船。而能济渡无量众生出生死海。为大正士降伏诸魔。永不复随魔境中语

尔时海意菩萨白佛言。世尊。菩萨云何而能降伏一切魔怨。佛言海意。若菩萨以无所为心。能于一切普摄受者。而彼菩萨即能降伏一切魔怨。又若菩萨以无所为心。于彼一切所缘相中。能发起者。而彼菩萨即能降伏一切魔怨。海意当知。魔有四种。何等为四。一者蕴魔。二者烦恼魔。三者死魔。四者天魔。若或伺察幻法即能降蕴魔。安住空法能降烦恼魔。伺察无生无起之法能降死魔。俱时依止一切意法趣向灭道能降天魔。又复知苦能降蕴魔。断集能降烦恼之魔。证灭能降死魔。修道能降天魔。又复伺察诸行是苦能降蕴魔。伺察诸行无常能降烦恼魔。伺察诸法无我能降死魔。伺察涅槃寂静能降天魔。又复菩萨内断烦恼垢而不忘失大菩提心。行于布施。即能摄伏蕴魔。若菩萨不惜其身亦不系着。行布施已。而能回向于一切智。即能摄伏烦恼之魔。若菩萨能念财富无常。我当与彼一切共用。真实施与。如是施已。而能回向于一切智。即能摄伏死魔。若菩萨于一切众生所。而不越失大悲之心。以解脱慧普摄众生。行布施已。而能回向于一切智。如是即能摄伏天魔

佛说海意菩萨所问净印法门经卷第五佛说海意菩萨所问净印法门经卷第六

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次海意。若菩萨虽生诸趣。无所希望。善护戒行。即能降蕴魔。若我见无依止善护戒行。能降烦恼魔。若以净戒。令诸众生出离老死。自护戒行能降死魔。若起是念。我令一切毁禁众生皆悉安住圣净戒中。自护戒行能降天魔。又复菩萨于我无所得修行忍辱能降蕴魔。于众生无所得修行忍辱能降烦恼魔。于生死无所得修行忍辱能降死魔。于涅槃无所得修行忍辱能降天魔。又复菩萨身寂静故发起精进。能越蕴魔。心寂静故发起精进。能越烦恼魔。了达无生无起故发起精进。能越死魔。于生死中未尝懈倦。成熟众生摄受正法。发起精进能越天魔。又复菩萨蕴无依止而修于定。能越蕴魔。界无依止而修于定。能越烦恼魔。处无依止而修于定。能越死魔。于余禅支。亦悉一一回向菩提。能越天魔。又复菩萨。能以正慧善知诸蕴。能降蕴魔。善知诸界能降烦恼魔。善知诸入能降死魔。虽善知缘生。而于实际亦不取证。能降天魔。又复菩萨解诸法空。即彼蕴魔伺不得便。意能信顺诸法无相。即烦恼魔伺不得便。知一切法无求无愿。即彼死魔伺不得便。知一切法无所造作。亦无疑惑。然于善行心不厌足。即彼天魔伺不得便。又复菩萨随观身中身念处而修。亦不与身俱起于寻求。能破蕴魔。随观受中受念处而修。亦不与受俱起于寻求。能破烦恼魔。随观心中心念处而修。亦不与心俱起于寻求。能破死魔。随观法中法念处而修。亦不与法俱起于寻求。于菩提意亦无所动。能破天魔

复次海意。汝今当知。此如是等诸有魔业皆由我为根本。若或菩萨。于根本我而不起者。即于我无我。是中亦无少法可起。如是即以现量智知。又若菩萨。为彼无智诸众生故。被大乘铠者。菩萨应当不与自他俱时依止。故被其铠。菩萨乃自思惟。我当云何而得此铠。坚固不坏。又复惟忖我所被铠不为坏我。亦不坏众生。不坏寿者士夫养者补特伽罗意生等类。若或依止我人众生寿者补特伽罗等见。即有所著。是故我今诸所依止而悉弃舍。何依止邪。谓于蕴处界中颠倒依止。何所颠倒。以诸众生于无常中而生常想。苦生乐想。无我我想。不净净想。菩萨若能正知彼想。即为如应说其法要。云何正知想邪。谓若无受无取。即能正知。何以故。此若不受彼即不取。此若不取彼亦不受。若如是者。即无痴昧。能正知想。海意菩萨白佛言。世尊。想云何知。或过去耶。未来邪。现在耶。佛言。非过去未来现在。所以者何。过去想已尽。未来想未至。现在想无住。是故当知。于三世中想无所得。如是乃能正知于想。由正知想故。即能清净菩萨一切所行之行。复能了知一切众生种种之行。海意。若菩萨不能清净菩萨之行。即不能知众生之行。若复能知众生诸行。乃能清净菩萨之行。如是了知众生行故。即为众生如应说法。乃能随诸众生心转。所应示现而悉能知。海意当知。或有众生贪意中行嗔。有嗔意中行贪。有痴意中行嗔。有痴意中行贪。有贪意中行痴。有嗔意中行痴。有嗔痴意中行贪。有痴贪意中行嗔。又有众生。假现于贪而取于嗔。假现于嗔而取于贪。假现于嗔而取于痴。假现于痴而取于嗔。假现于痴而取于贪。假现于贪而取于痴。假现贪嗔而取于痴。假现嗔痴而取于贪。假现痴贪而取于嗔。又有众生先贪后嗔。先嗔后贪。先嗔后痴。先痴后嗔。先痴后贪。先贪后痴。先贪嗔后痴。先嗔痴后贪。先痴贪后嗔。先痴嗔后贪。又有众生。于色起贪于声起嗔。于声起贪于色起嗔。于香起贪于味起嗔。于味起贪于香起嗔。于触起贪于法起嗔。于法起贪于触起嗔。又有众生。因离色故而得调伏。不因离声有离声故而得调伏。不因离色。有离香故而得调伏。不因离味。有离味故而得调伏。不因离香。有离触故而得调伏。不因离法。有离法故而得调伏。不因离触。又有众生。因身离故而得调伏。不因心离。因心离故而得调伏。不因身离。有亦因身离亦因心离而得调伏。有不因身离不因心离而得调伏。又有众生。因无常声而得调伏。不因苦无我寂静等声。有因苦声不因无常无我寂静之声。有因无我声不因无常苦寂静声。有因寂静声不因无常苦无我之声。又有众生。有因说法神变而得调伏。不因教诫神变。有因教诫神变而得调伏。不因说法神变。有因神境神变而得调伏。不因说法教诫神变。又有众生。因说法神变故而生信解。有因教诫神变故而得远尘。有因神境神变故而得解脱。又有众生。利根勤行钝根解脱。有钝根勤行利根解脱。有钝根勤行钝根解脱。有利根勤行利根解脱。又有众生。由因得解脱而不由缘。有由缘得解脱而不由因。有亦由因亦由缘故而得解脱。有不由因不由缘故而得解脱。又有众生。因内观过失故而得解脱。不因外观。有因外观过失而得解脱。不因内观。有亦因内观亦因外观诸过失故而得解脱。有不因内观不因外观诸过失故而得解脱。又有众生。修行于乐成证解脱不因于苦。有因于苦不因于乐。有亦因苦亦因于乐。有不因乐亦不因苦。又有众生。因警发相而得调伏。因安止相而得调伏。因降伏相而得调伏。因善摄相而得调伏。有因善相而得调伏。有因不善相而得调伏。有因嗔相而得调伏。有因三相而得调伏。有因容缓相而得调伏。有因缘生法而得调伏。有因随顺行而得调伏。有因默然行而得解脱。有因差别行而得解脱。有因念处法声。有因正断声。有因神足声。有因根声。有因力声。有因觉支声。有因正道声。有因奢摩他声。有因毗钵舍那声。有因四圣谛声而得解脱。海意。此如是等不可思议。众生所行不可思议。众生心意不可思议。众生境界。若菩萨入不思议智。入已即能遍入一切众生不可思议境界。海意。譬如有人周遍四方以绳为网。是人忽以因缘入其网中。此人普欲解除其网。而以此人善咒力故。其网后时为咒力所加而悉断坏。是人随意得出无碍。菩萨亦复如是。由具善巧方便故。遍入一切众生心意。入已即能以般若波罗蜜多明咒之力。普断一切众生烦恼缠缚。菩萨然亦不证佛智。普为一切众生现起施作一切佛事

尔时尊者舍利子。前白佛言。希有世尊。所有无量众生心行。乃至不思议佛智。又复甚奇。世尊。若新发意菩萨。或闻说此无量众生心行无量佛智。闻已岂非生惊怖邪。佛言。舍利子。于汝意云何。譬如新生师子之子。闻师子吼可惊怖不。舍利子言。不也世尊。佛言舍利子。新发意菩萨。亦复如是。闻佛如来师子吼已。不生惊怖。闻说无量众生心行。亦无恐畏。舍利子。又如小火光明。于彼一切草木不生惊怖。火亦不作是念。我无力能烧诸草木。新发意菩萨亦复如是。智慧光明虽复甚少。而于一切众生所有烦恼。不生惊怖。菩萨亦不作是念。我不能息众生烦恼。何以故。菩萨若起深固作意。以所成慧如实观察。即能息诸众生烦恼。舍利子。又如有火。与彼大地一切草木树林花果。要期尽劫而共斗战。至第七日当起战事。时彼大地草木。并余一切草木等众而共集会。乃相谓言。汝有力能与我援助。时诸草木积聚既广量等须弥。时或有人来谓火言。草木众多。汝唯单己。汝今何不多求援助。汝力何能敌草木众。彼火答言。我今不须求其助力。何以故。而诸草木虽复众多。随彼一切我力能敌。令彼草木悉灭无余。菩萨亦复如是。随彼无量众生一切烦恼。菩萨即放无量慧火。其力敌胜。又复菩萨起深固意。于一切众生烦恼聚中。以所成慧如实观察。即能息诸众生烦恼。若或菩萨取证离烦恼法。舍烦恼者。彼即速堕声闻缘觉之地。舍利子。以是缘故。汝应当知。若菩萨随于一切烦恼聚中。能深固作意如实伺察者。即于彼彼一切烦恼力能胜伏。舍利子。若有得闻如是说已不惊怖者。当知是为善巧方便菩萨。舍利子。又如蛇毒。凡所伤[口*赦]而无助伴。新发意菩萨。亦复如是。修集菩提分法时。亦复单己而无助伴。但自修集菩提分法。又如萤火。不能胜彼百千日轮广大光明。一切烦恼亦复如是。不能胜敌菩萨慧光。又如除毒之药。状虽至小。而能解除广大之毒。菩萨亦复如是。智慧之药。虽复至小。而能息除诸烦恼毒。又如天降一味之雨。随所堕处。器有差别成种种味。菩萨亦复如是。修集一味解脱之智。随诸众生种种根性。种种说法而各有异。又如阎浮檀金。出现世间。映蔽一切余诸珍宝。菩萨大宝出现世间。亦复如是。映蔽一切声闻缘觉。又如转轮圣王。出现世间。一切小王皆悉归向。菩萨法王之子。亦复如是。若发大菩提心。一切世间天人阿修罗等。各各顶奉而悉归向。又如薄福众生。虽遇宝雨而无所获。不种善根诸众生等。亦复如是虽发菩提心而无所成。又如世间若无甘蔗种子。即不能生于甜味。菩萨亦复如是。若无大菩提心种子。即不能成就阿耨多罗三貌三菩提果

佛说海意菩萨所问净印法门经卷第六佛说海意菩萨所问净印法门经卷第七

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次佛告舍利子言。譬如耆婆医王。普观大地一切草木无非是药。修行般若波罗蜜多菩萨。亦复如是。观一切法无非菩提。又舍利子。譬如罗睺阿修罗王虽有势力。不能于其日月道中而为障碍。一切魔众亦复如是。虽有势力。不能于其勤行精进菩萨所修菩提道中而为障碍。又舍利子。譬如色界诸天子众所有宫殿依空而住。修甚深行诸菩萨众亦复如是。犹如虚空平等无碍。诸法亦然。与虚空等。如是乃得阿耨多罗三貌三菩提果。又舍利子。譬如世间诸有器用。既成就已。随彼大小。空量现中。然彼虚空不增不减。菩萨亦复如是。修诸善力得成熟已。随其深浅能受佛法。然彼佛法不增不减。又舍利子。譬如力士。极尽其力举箭射空。终不能至虚空边际。菩萨亦复如是。尽其信力。于佛法中而生信解。然不能得佛法边际。又舍利子。如世陶器未成熟时。即不能得器用之名。菩萨亦复如是。菩提善根未成熟时。即不能得波罗蜜名。又舍利子。如人得见转轮圣王已。不复乐见诸小国王。菩萨亦复如是。得见如来大法王已。不复乐见诸声闻缘觉。又舍利子。譬如牛迹水中而不能出一切珍宝。声闻戒中亦复如是。不能出生佛法僧宝。又舍利子。譬如大海乃能出生诸妙珍宝。菩萨亦复如是。闻戒海中而能出生佛法僧宝。又舍利子。譬如新生太子。不名为王非不名王。初发心菩萨。亦复如是。不名为佛。非不名佛。又舍利子。譬如世间未经治莹摩尼之宝人不爱乐。初发心菩萨虽复说法。未得无畏亦复如是。又舍利子。如摩尼宝经治莹者。清净明亮人所爱乐。具修胜行菩萨亦复如是。获得无畏而善说法。一切众生皆生忻乐。又舍利子。如江湖中所出小宝亦不可轻。何以故。是宝虽小。若在房舍。或复闇中。能以光明普遍照耀。初发心菩萨亦复如是。勿生轻慢。何以故。而是菩萨得菩提已。能于一切佛刹土中。普放光明广大照耀。又舍利子。譬如无价大摩尼宝最极殊妙离诸尘垢。不退转菩萨亦复如是。离诸慢心。又舍利子。譬如世间谷稼成熟实穗垂[禾*耑]。菩萨亦复如是。所修善法。得圆满已。于诸众生谦下无碍。又舍利子。譬如世间劫火欻起。而此大地一切草木烧爇无余。菩萨亦复如是。智火若然一切烦恼种子习气。悉爇无余。既灭尽已。然后乃证阿耨多罗三貌三菩提果。又舍利子。譬如有火。若小若大烧三千界。而虚空性本自如是。菩萨亦复如是。若有菩萨成等正觉。若无菩萨成等正觉。而一切法自性如是。舍利子。如是等诸有譬喻如来所说。而能摄受诸菩萨众。若有菩萨闻此说已。生胜解者而能于彼一切喻中。悉得成就。当佛说是见边法时。会中有二万四千人。发菩提心

尔时世尊。重说颂曰

  难得最上佛菩提　　深妙无垢无所有
  若人于此欲圆成　　是中勿当生疑惑
  净妙智慧无虚假　　真实光明普照耀
  安住无垢妙印中　　此佛菩提能观见
  心自性净而明亮　　前际后际亦复然
  烦恼染污意中时　　应当勿离深固意
  是中无作无受者　　诸法自在无主宰
  无我人故说无我　　如空如梦无自性
  当观此法非身业　　非语非心所分别
  无为实性异想无　　譬喻言词不能说
  与虚空等自性净　　非色相故不可观
  非眼耳鼻识所知　　非舌非身亦非意
  远离非相非无相　　无依寂静湛如月
  非意亦非心所行　　非识非想非思度
  此非智业可能知　　云何识心而晓了
  由佛无上大悲心　　假以文字而说法
  众生先世胜行业　　为善知识所摄受
  如是相中闻法已　　获无等喜无爱着
  非彼诸魔伺得便　　不能知心及境界
  随何所作何所行　　而彼魔业不能胜
  菩萨超越四魔已　　如理如教修福慧
  善住诸佛境界中　　此名修胜菩提者
  众生不能知所行　　修菩提者所行胜
  施设多种行门中　　随彼彼相为说法
  如是世间种种行　　互相所缘而和合
  大智了知诸行中　　随所宣说无间断
  或有众生多贪染　　或复多嗔悉了知
  见嗔烦恼逼迫时　　彼痴性中起诸害
  如是世间种种行　　菩萨随了而能入
  行相所缘及缘成　　随其相言为宣说
  譬如周遍置绳网　　大智持明者善知
  普遍能破诸网已　　随意所观出无碍
  菩萨勇智亦如是　　世间心意悉能入
  普使令诸烦恼除　　周遍所行无覆障
  如日舒光无援助　　蛇毒亦无于等侣
  师子振吼亦复然　　菩萨所修无助伴
  菩萨单己而无二　　积集最上诸佛法
  精进势力悉具圆　　摧灭世间诸烦恼
  譬如有火得干薪　　随处增长其势力
  菩萨增长慧光明　　悉能照破诸烦恼

尔时世尊复告海意菩萨摩诃萨言。菩萨若能发起精进。常所坚固勤行乐欲。所起精进无有休息。而诸菩萨即于阿耨多罗三藐三菩提不为难得。何以故。海意。由精进故乃得菩提。若懈怠者于佛菩提远中复远。无懈怠者能行布施。无懈怠者而能持戒。无懈怠者能起精进。无懈怠者能修禅定。无懈怠者能集智慧。无懈怠者能行自利。无懈怠者而能利他。以是缘故。汝今当知。菩萨若能发起精进。彼诸菩萨乃于阿耨多罗三藐三菩提不为难得。海意。我念过去世中大阿僧祇劫前。彼时有佛出现世间。号勇猛精进如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名善见。劫名花积。以何缘故。劫名花积。海意。是时三千大千世界大水充满。水中复出八万四千广大莲花。花有无数俱胝那庾多百千叶。殊妙可爱。观者悦意。尔时净居天众见是花已咸生欢喜。意乐适悦。俱发是言。若此莲花广大出现。决定当有正等正觉出此劫中。此劫不空。有佛世尊出现于世。犹如花积。是故此劫名为花积。又复何缘而彼世界名为善见。以其世界最胜清净。十方一切诸佛刹中。无量无数诸菩萨众。咸悉往诣于彼世界而共瞻仰。当瞻仰时。一切大众。于彼世界皆得喜相三摩地。一切妙乐皆悉具足。于彼世界所观善妙。故名善见。海意。此善见世界七宝所成。有众宝树及宝楼阁。是宝光明普遍照耀。而彼世界无有女人。不受胎藏。于莲花中自然化生。加趺而坐。又其世界无有余乘。诸修行者唯住大乘。其土人民诸所受用如兜率天。须饮食者悉得如意。复得神通游戏。能履虚空。彼勇猛精进如来法中。有二十六俱胝出家菩萨。具菩萨道入菩萨众。复有无量在家之众。修大乘行。是时彼佛为诸菩萨宣说勤行精进之法。彼佛告言。汝诸大士。当勤精进。常所坚固。深极勤劳。深极乐欲。无令休息。海意。其佛会中有一菩萨名坚固铠。从座而起白其佛言。世尊。云何菩萨能发精进。复以何法如来教授诸菩萨众。时勇猛精进如来告坚固铠菩萨言。善男子。所谓精进有其四种。而能普摄一切善法。何等为四。一者发起。二者勤作。三者伺察。四者修行。如是四种而能普摄一切善法。又复云何名为发起。何名勤作。何名伺察。何名修行。善男子。发起者。所谓发起大菩提心。勤作者。广大积集一切善根。伺察者。于诸众生作利益事。修行者。随何等法悉住于忍。又发起者。勤求多闻。勤作者。如闻能说。伺察者。深固作意。修行者。起圣正见。又发起者。摄止悭心。勤作者。舍诸所有。伺察者。所有善利与一切众生共之。回向菩提。修行者不求果报。又发起者。振大舍声。勤作者。诸来求者起善知识想。伺察者。诸所受用观无常分。修行者。施已无悔。又发起者。诸所受用依法而求。勤作者。净命自资。伺察者。行真实施。修行者。施时不起意念。又发起者。涤破戒垢。勤作者。禁戒无缺。伺察者。破戒众生而将护之。修行者。虽具戒德不起意念。又发起者。身业清净。勤作者。语业清净。伺察者。心业清净。修行者。诸法清净。又发起者。诸有嗔心而不容受。勤作者。忍力发现。伺察者。自他作护。修行者。虽住忍辱不起意念。又发起者。诸有忿恚。皆令欢喜。复得清净。勤作者。令诸忿恚欢喜和合。伺察者。内心清凉而无热恼。修行者。自他无所得。又发起者。遣除懈怠。勤作者。于精进力而善决择。伺察者。懈怠众生而救护之。修行者。随何等法皆住于忍。又发起者。积集善法。勤作者。成办善法。伺察者。不乐余乘。修行者。不坏诸业。又发起者念。勤作者行。伺察者慧。修行者住。又发起者理。勤作者教。伺察者门。修行者出离道。又发起者。积集文字。勤作者。文义总持。伺察者。若声若文皆悉不着。修行者。觉了诸法悉不可说。又发起者。亲近善友。勤作者。远离恶友。伺察者。于善恶友起心平等。修行者。如所说言随能忆持。又发起者起出家心。勤作者。于爱非爱所观平等。伺察者。随何等善悉乐希求。修行者得现量智。又发起者。乐居旷野。勤作者。远离愦闹。伺察者。乐处寂静。修行者。修寂静行。又发起者少欲。勤作者知足。伺察者。获得妙乐。修行者。知所应量。又发起者。修增上戒学。勤作者。所修无杂。伺察者。修增上心学。修行者。修增上慧学。又发起者布施。勤作者爱语。伺察者利行修行者同事。又发起者大慈。勤作者大悲。伺察者大喜。修行者大舍。又发起者。刹土清净。勤作者。相好圆满。伺察者。护持正法。修行者。救度众生。又发起者。了知蕴魔。勤作者。越烦恼魔。伺察者。远离死魔。修行者。摧伏天魔。又发起者知苦。勤作者断集。伺察者修道。修行者证灭。又发起者。修身念处。勤作者。修受念处。伺察者。修心念处。修行者。修法念处。又发起者信。勤作者精进。伺察者念定。修行者慧。又发起者。防断不善之法。勤作者。圆满生起一切善法。伺察者。若身若心轻安调畅。修行者。获得无加行神足。又发起者。修七觉分。勤作者。行八正道。伺察者。修习止观。修行者。得明解脱。又发起者。发起诸行。勤作者。表示洁白之行。伺察者。心得轻安。修行者。不转境界相智

复次海意。彼勇猛精进如来复告坚固铠菩萨言。善男子。由精进故身心轻安。即此精进。若因若见悉当远离。又此精进能知名色。又此精进能灭我我所见。又此精进能解所取之缚。又此精进能除五盖及现所起一切烦恼。又此精进能断恶作及彼疑惑。又此精进破诸结病。又此精进而能勤力除断诸障。又此精进离慢过慢。又此精进超越一切所依所著。又此精进离诸喜恚。又此精进于无明有爱悉不染着。又此精进于贪嗔法而悉不行。又此精进于其痴法而常伺察。又此精进。知觉内外十二处法。又此精进。了知五蕴及十八界本来不生。又此精进。心住寂静遍寂近寂。又此精进。决了诸法悉无所得。又此精进。于一切法不取二相。又此精进。了知法性本来常住。又此精进。知一切法不来不去。又此精进。知一切法无取无舍。又此精进。知一切法无作无止。又此精进。知一切法无高无下。又此精进。知一切法不出不入。又此精进。知一切法无缚无解。又此精进。知一切法无勤无堕又此精进。知一切法无放逸无不放逸。又此精进。知一切法无能作无所作。又此精进。知一切法无观无不观。又此精进。知一切法无止息无炽然。又此精进。知一切法无所护无不护。又此精进。知一切法无集无散。海意。彼勇猛精进如来。为诸菩萨说如是等勤行精进法时。会中有一万人得无生法忍。坚固铠菩萨。于彼佛所。得闻如是精进法已。转复发起精进勤求善法。如是精进常无休息经俱胝岁。过是已后得柔顺忍。如是精进勤求善法。经尔所时。即于彼灭。灭已还于彼如来前。重复化生听受宣说大集会正法。又复精进勤求善法。海意。其坚固铠菩萨。以是缘故。经尔许时。普遍亲近八万四千佛。于彼花积劫中。发起精进勤求善法。经如是时一切勤行。海意。汝今勿生疑念。是时坚固铠菩萨者岂异人乎。即我身是。我昔曾历多菩萨位。弃背生死勤求菩提。乃至我今得成正觉。广行精进深历艰苦。况复世间懈怠众生。起下劣精进者。而能获得菩提果邪。海意。若诸众生能发精进者。于我法中即得清净。非懈怠者而能成就。以是缘故。汝今当知诸有精进不放逸者。即得菩提。当佛说是过去所行精进法时。会中有五千菩萨得无生法忍。七千天人发阿耨多罗三藐三菩提心

佛说海意菩萨所问净印法门经卷第七佛说海意菩萨所问净印法门经卷第八

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

尔时世尊重说颂曰

  我念过去佛出世　　号曰勇猛精进尊
  劫名花积妙可观　　最上世界名善见
  八万四千莲花出　　有佛出现彼劫中
  世界犹如兜率天　　所须饮食皆如意
  彼无女人不处胎　　众生化生悉严好
  而复不修于余乘　　菩萨皆住大乘法
  十方所来菩萨众　　于彼世界善可观
  皆获喜相妙定门　　受诸快乐未曾有
  菩萨俱胝二十六　　是众庄严二足尊
  复有余多天及人　　最上佛乘皆安住
  其佛大仙智德海　　数数宣说精进门
  有菩萨名坚固铠　　于佛发问如斯义
  所欲安住精进力　　菩萨云何精进修
  此义愿佛为我宣　　我于是中修行住
  彼大法王知意已　　为说发勤精进德
  发起勤作行相应　　常所伺察修行住
  发起所谓菩提心　　勤作成辨众善法
  伺察利益诸众生　　修行随何法住忍
  发起恭敬此听受　　勤作宣说而开明
  深固作意伺察门　　修行谓起圣正见
  发起涤除于悭垢　　舍诸所有是勤作
  具菩提心伺察门　　修行所作不求报
  发起谓振大舍声　　慈于丐者是勤作
  伺察受用观无常　　修行施已不生悔
  依法所受名发起　　净命自资是勤作
  我真实施伺察门　　修行施时无意念
  发起涤除破戒垢　　禁戒无缺是勤作
  伺察将护破戒人　　修行具戒无意念
  发起所谓身业净　　语业清净是勤作
  心业清净伺察门　　修行是为诸法净
  不容受嗔名发起　　忍力现行是勤作
  自他作护伺察门　　修行忍辱无意念
  恚者常净名发起　　勤作于彼不舍离
  内心清净伺察门　　修行自他无所得
  发起谓除懈怠垢　　择精进力是勤作
  护懈怠者伺察门　　修行随何法住忍
  积集善法名发起　　成办善法是勤作
  伺察不乐于余乘　　修行不坏诸业报
  发起了知于正念　　勤作悟入法行中
  善护正慧伺察门　　修行所谓坚固住
  发起谓理勤谓教　　彼诸法门谓伺察
  知出离道即修行　　此发精进善方便
  发起所谓文总持　　善宣说义名勤作
  不着于声伺察门　　修行了法不可说
  亲近善友名发起　　远离恶友是勤作
  观善恶性伺察门　　修行忆持于诸法
  法中出家名发起　　舍爱非爱是勤作
  希求善法伺察门　　修行于法无障碍
  发起乐居旷野中　　远离愦闹是勤作
  乐居寂静伺察门　　修行谓修寂静行
  少欲善言名发起　　欢喜知分是勤作
  获受妙乐伺察门　　修行谓知所应量
  增上戒学名发起　　所修无杂是勤作
  增上心学伺察门　　增上慧学修行住
  布施持戒名发起　　忍辱精进是勤作
  禅定慧行伺察门　　修行总起智方便
  财法二施名发起　　爱语所谓是勤作
  利行是为伺察门　　修行真实而同事
  大慈圆满名发起　　大悲具足是勤作
  法中大喜伺察门　　修行此说大舍智
  发起清净佛刹土　　圆满相好是勤作
  护持正法伺察门　　度脱众生修行住
  不着蕴魔名发起　　出烦恼魔是勤作
  摄伏死魔伺察门　　摧伏天魔修行住
  了知苦果名发起　　不立爱故是勤作
  修道是为伺察门　　灭智所谓修行住
  发起身念处离缚　　观受念处是勤作
  观心念处伺察门　　修行谓观法念处
  发起所谓信根方　　精进根力是勤作
  念定根力伺察门　　修行谓即慧根力
  防断不善名发起　　不坏善法是勤作
  身心轻利伺察门　　修行智起四神足
  发起谓修七觉分　　行八正道是勤作
  修习止观伺察门　　修行真实明解脱
  发起勤作起诸行　　心得轻安伺察门
  不转诸相境界中　　此说是为修行住
  若身若心轻安故　　于见于因当出离
  是中名色若了知　　诸圣称赞此精进
  于我我所若能灭　　即解一切所取缚
  现起五盖悉蠲除　　恶作疑惑皆断灭
  又复能破诸结病　　此力除障无所覆
  于慢过慢断无余　　所作皆由精进力
  遣除一切诸有相　　止息一切诸戏论
  断灭一切烦恼因　　智者称赞此精进
  闻此精进功德已　　勇发精进咸称赞
  菩萨会中有十千　　悉得无生妙法忍
  释迦如来此会中　　为诸菩萨广宣说
  闻说精进先行时　　五千菩萨忍清净
  复有天人阿修罗　　紧那罗等诸会众
  尔时会中有百千　　发菩提心善安住
  我昔曾名坚固铠　　得最上忍菩萨位
  弃舍身命精进修　　经尔许时常无懈
  亲近八万四千佛　　弃舍己身而奉事
  近侍诸佛一劫中　　后居无数菩萨位

尔时大悲思惟大梵天王白海意菩萨言。善男子。所言佛法是何等增语。海意菩萨言。大梵。此言佛法者。是一切法增语。何以故。如来以无分别相。如量取证菩提。无分别相者。即一切法平等相。如来是中如量取证菩提。大梵。若了一切法平等。即是菩提。是故此说一切法即是佛法。若一切法如是即佛法。亦如是所有一切法自性。即佛法自性。一切法离故。应知佛法亦离。一切法空故。应知佛法亦空。大梵。一切法缘生。若能觉了。诸法缘生即是菩提。如如来于一切法如是见而彼佛法亦如是见。梵天言。善男子。岂非佛法越三界邪。菩萨言。大梵。三界自性即是佛法。何以故。大梵。而彼佛法平等相中无高无下。犹如虚空亦无高下。佛法亦复如是。同彼虚空无高无下。大梵。一切法亦然。自性空中等无高下。大梵。若善男子及善女人。欲知佛法者。应如是知。然于所知方便不应取着

复次大梵。佛法无方分。无处所。不生不灭非青非黄非赤非白。故无显色。非有形相故无形色。无形显色故即是无相。大梵。无相义者即佛法义。佛法义者即不堕句义。不堕句义者即寂静义。寂静义者即是离义。离义者即是空义。空义者即无系着义。无系着义者即实性义。实性义者即真如义。真如义者即毕竟不生义。不生义者即不灭义。不灭义者即无住处义

尔时海意菩萨重说颂曰

  所说无相义　　是胜佛法义
  其说佛法义　　即不堕句义
  不堕寂静义　　寂静是离义
  离义即空义　　空义无著义
  无著实性义　　实性真如义
  真如即毕竟　　不生不灭义
  不灭无处义　　法义如是住
  如所住法界　　诸法亦然住
  如诸法所住　　佛法亦然住
  如佛法所住　　生灭法亦然
  无著法等义　　真如无异住
  声闻缘觉法　　亦平等随住
  如是处住法　　佛法胜无上
  无方分处所　　故佛法安住
  勿于生灭中　　随观诸佛法
  彼非形显色　　无少法可得
  无形亦无相　　佛法而开明
  如诸法自性　　佛法亦如是
  此所说平等　　无差别无相
  如是求佛法　　诸法亦然求
  若法无所得　　彼即无分别
  佛及诸佛法　　一切法皆然
  大仙处道场　　得平等正法
  佛及诸佛法　　于道场观察
  彼所说佛法　　平等等故常
  等无高下法　　如虚空清净
  若佛及佛智　　彼佛此所说
  谓诸法缘生　　自性无所有
  若自性不有　　即无少法生
  实际此若知　　世间等无际
  是际中起智　　随转一切法
  所谓过去法　　及彼未来法
  此名现在法　　此是诸佛法
  如是三时中　　佛智无所著
  由智无著故　　牟尼乃说法
  所谓佛十力　　及四无所畏
  诸佛十八种　　不共功德法
  于是中普摄　　所有一切法
  如是一切法　　是即诸佛法

复次大悲思惟大梵天王重白海意菩萨言。善男子。汝于如是法中。云何所见。菩萨言。大梵。夫佛法者堕色数邪。梵天言不也。菩萨言。若法非色即不可见。若无对碍即无表了。是中云何有所见邪。梵天言不也。善男子。菩萨言。大梵。若佛法不可见者。即一切法亦如是。何以故。法本无二。此无二者即是一切法。大梵。若法有所见。彼即是有相。谓以无别可见无别佛法。若此如是见。彼如是佛法。若如是佛法。彼即如是见。梵天言。善男子。若尔者如来于一切法。不复有见。菩萨言大梵。若如来于佛法中有所见者。即彼如来及诸佛法。有实定性可得。梵天言。善男子。若如是者。佛法不有邪。菩萨言。大梵。若法无实定性。是中有无悉不可说。若法非有无。彼即无所见。梵天言。若尔何故。世尊今此会中说佛法邪。菩萨言。大梵。如说虚空。非彼虚空有实定性。佛法亦复如是。此说佛法。非彼佛法有实定性。梵天言。希有善男子。若初发心菩萨。闻此说已不生惊怖者。而是菩萨于佛法中被坚固铠。菩萨言。大梵。若诸众生。得佛加持已发菩提心者。闻此所说甚深佛法。即不生惊怖。又复大梵。有取有执者即生惊怖。无取无执者不生惊怖。有依止有系著者即生惊怖。无依止无系著者不生惊怖。有我我所见者即生惊怖。离我我所见者不生惊怖。梵天言。善男子。菩萨有几种力。若诸菩萨。具是力者。即于如是甚深佛法中不生惊怖。菩萨言。大梵。诸菩萨有八种力。若诸菩萨具是力者。乃于如是甚深佛法中不生惊怖。何等为八。一者无障碍信力。于诸佛法生胜解故。二者尊重出生善知识力。谛意随顺如师尊故。三者多闻出生慧力。出世闻法悉圆满故。四者福行出生承事之力。无量福行悉圆满故。五者深固作意出生智力。破诸魔故。六者大慈出生大悲之力。于无我法离疑惑故。七者安定出生善思惟力。大菩提心不忘失故。八者无佗信出生忍力。获得无生妙法忍故。大梵。此等是为菩萨八种胜力。若诸菩萨摩诃萨具是力者。能于甚深诸佛法中不生惊怖

尔时世尊赞海意菩萨摩诃萨言。善哉善哉。海意。汝善说此菩萨八力。若诸菩萨具是力者。能于甚深诸佛法中不生惊怖。又复于佛法中。随所闻已皆不生怖。海意当知。诸说法声皆是分别。若于菩提胜义谛中即不能说。何以故。彼胜义谛。非语言非诠表。亦非文字积集所行。尚非心心所法而可能转。况复文字有所行邪。海意。如汝所观诸佛世尊有所说者。但为不可思议一切众生大悲转故。乃于如是甚深法中成正觉已。于无文字无语言无记说无诠表法中。为他众生及补特伽罗。假以文字建立宣说。海意。譬如有人知此虚空。非色相故不可见。非对碍故无表了。然于空中以种种色彩画形像。所谓象马车乘天龙夜叉乾闼婆等。现诸色相。海意于汝意云何。是人所作斯为难不。海意菩萨白佛言。世尊。是人所作最极为难。佛言海意。诸佛世尊。如复为难过极于彼。何以故。谓于不可说法中成正觉已。假以言说。为他众生及补特伽罗建立宣说。由于不可说义中如实觉了。是故。诸佛难作能作。海意。若复有人于此甚深佛法之中。不惊不怖不生恐畏者。当知是人于先佛所深种善根作诸胜行。是故。于此甚深佛法不生恐畏。若复有人于此甚深经典一切世间难信解法如实知已。受持读诵广为他说者。当知是人能持如来一切法藏。能持一切众生诸善法分。又复海意。若有菩萨得佛眼照明。能于无量诸佛刹中。满积珍宝持用供养。彼彼如来广行布施。于汝意云何。而彼菩萨以是缘故得福多不。海意白佛言。甚多世尊。甚多善逝。此之福蕴无量无数。乃至譬喻所不能及。佛言海意。我今语汝。如汝应知。若有菩萨能于如来法中善为作护。令三宝种不断不绝。于诸众生不舍大悲。于如是等甚深经典如来大智法中能了知已。受持读诵。何况是中如理修行。而此菩萨所得福蕴倍多于彼。何以故。所有财施。但是世间之所爱乐。若法施者。彼即出过一切世间

复次海意。若有菩萨能护持正法者。而此菩萨得四种摄受。何等为四。一者得佛摄受。二者得天摄受。三者得福摄受。四者得智摄受。若诸菩萨得佛摄受者。当得四种最胜之法。何等为四。一者常得不离瞻仰如来。二者一切魔众伺不得便。三者获得无尽陀罗尼门。四者速具神力住不退转地。海意。诸有菩萨为佛摄受者。获得如是四种最胜之法。又诸菩萨若得天摄受者。当获四种清净。何等为四。一者天众神力。令其菩萨众会清净。二者使令听受正法专注一心。三者遣除一切魔外之众。四者由天威神。能令一切无不清净。悉得净心。海意。诸有菩萨为天摄受者。获得如是四种清净。又诸菩萨若得福摄受者。当获四种庄严之相。何等为四。一者身庄严。谓相好圆满。二者语庄严。谓胜出一切众生语言音声。三者国土庄严。谓诸所施作悉能显示。四者所生庄严。谓在所生处或为梵王帝释护世天等。海意。诸有菩萨为福摄受者。获得如是四种庄严。又诸菩萨。若得智摄受者。当获四种照明之法。何等为四。一者照明一切众生根性。如其所应即为说法。二者照明一切烦恼之病。积集法药随为治疗。三者神力照明。余佛刹中悉能遍往。四者法界照明。于一切法如实了知。海意。诸有菩萨为智摄受者。获得如是四种照明。以是缘故。菩萨摩诃萨欲得如是摄受称赞功德法者。应当勤行护持正法。若诸菩萨而能勤行护正法者。当获无量最胜功德

佛说海意菩萨所问净印法门经卷第八佛说海意菩萨所问净印法门经卷第九

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

尔时世尊重说颂曰

  诸佛正法能护持　　当得种种善称赞
  彼称赞法我略宣　　如大海中水一渧
  知诸佛恩能报者　　诸佛付托持法藏
  诸佛正法能护持　　是即普供十方佛
  佛眼照明观佛刹　　妙宝供养诸世尊
  诸佛正法护持时　　比前福蕴此最胜
  虽以世财供养佛　　不能解脱世间行
  出世胜法若求时　　智者出离世间法
  诸佛正法护持者　　即得诸佛所摄受
  诸天龙等亦摄持　　福摄智摄皆获得
  诸佛正法护持者　　得念慧行悉具足
  广大胜慧普遍知　　智者拔除烦恼种
  诸佛正法护持者　　非彼诸魔伺得便
  恶作疑惑悉蠲除　　彼无诸障亦无缚
  诸佛正法护持者　　所生刹土不空过
  一切生中见佛身　　见已即得心清净
  诸佛正法护持者　　获得宿命大智法
  出家善利数能成　　所修真实清净行
  诸佛正法护持者　　戒闻胜生诸梵行
  得五智通妙轻安　　禅定解脱悉无碍
  诸佛正法护持者　　趣入甚深诸法中
  佛境界空无所疑　　信解众生无我法
  诸佛正法护持者　　获无碍解捷利慧
  得无碍言无畏门　　破诸众生疑惑网
  诸佛正法护持者　　得大总持胜善利
  不能听受百劫中　　由具辩才悉无碍
  诸佛正法护持者　　得诸智者常称赞
  天阿修罗等悦心　　诸佛赞护如佛子
  诸佛正法护持者　　帝释梵王得非难
  及彼人中转轮王　　乃至菩提胜妙乐
  诸佛正法护持者　　具三十二殊妙相
  大智圆成无坏身　　一切观者无厌足
  诸佛正法护持者　　得善知识亦非难
  彼为宣明法印门　　听受无尽正法藏
  诸佛正法护持者　　身语心业皆清净
  戒定慧净亦复然　　得解脱智善清净
  诸佛正法护持者　　常不舍离菩提心
  波罗蜜行不弃捐　　而能普摄多善法
  诸佛正法护持者　　若广称赞彼功德
  正使住寿一劫中　　亦不能说其边际

尔时会中有一菩萨。名功德光王。从座而起。前白佛言。世尊。如佛向者作如是言。我于不可说法中而成正觉。世尊。若法不可说。何故今言护持正法。佛言。如是如是。善男子。如汝所言。我于不可说法中而成正觉。然善男子不可说者。谓以世俗文字语言。于无为法中而不可说。若以文字语言诠总持门。施设建立显明开示。乃有所说。此即是为护持正法。又善男子。有说法师。于如是等甚深经中。广大受持为他演说如理修行者。若人能于此法师所恭敬尊重承事。种种供养密为护持。饮食衣服坐卧之具。病缘医药善作供施。能护善法善护语言。于非语言而为藏覆。此即是为护持正法。又善男子。若有人能解了。于空信顺无相无愿无求。于无加行中真实安止。此即是为护持正法。又善男子。若有人能于自所说无诤胜语。及他所说非法语言。是二同于法中所摄。此即是为护持正法。又善男子。若人能以无障碍心。相续普摄一切众生。入解脱慧中。不以世间财利之心为他法施。此即是为护持正法。又善男子。若有人能弃舍身命。于如是等甚深经典密为作护。居寂静处依法修行。此即是为护持正法。又善男子。若有人能为听法因缘。或为说法因缘。乃至行于一步。或一出入息间能专注者。此即是为护持正法。又善男子。若了一切法无所护无所取。此即是为护持正法。复次功德光王。如是等缘汝应当知。善男子。我念过去阿僧祇劫复过阿僧祇劫数之前。彼时有佛出现世间。名大智力声如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名净光。劫名喜上。善男子。彼净光世界琉璃所成。广博清净光照十方。彼有清净诸大菩萨摩诃萨众。依止游戏大神通力。从甚深法之所出生。彼菩萨众诸所受用。皆如化乐天子。悉以天子之状。于彼佛所听受说法。无复在家出家种种形相。时彼大智力声如来。常为彼会诸菩萨众。广大宣说护持正法。作如是言。汝等善男子。应当勤行不惜身命护持正法。时彼会中有一菩萨摩诃萨。名曰法语。白彼世尊大智力声如来言。世尊。云何是诸菩萨能护正法。又复云何是所护法。彼佛告言。善男子。若于色心境界之中。善护诸障专注一境。调伏止息住寂静法。此即是为护持正法。何以故。眼根色境眼识此三非法非非法故。耳根声境耳识。鼻根香境鼻识。舌根味境舌识。身根触境身识。意根法境意识。非法非非法故。若能了知眼色空已。即眼及色无所分别。眼识无住此即正法。菩萨若于如实智中。善令他得如是法者。此即是为护持正法。如是耳声鼻香舌味身触意法。了知空已。即意及法无所分别。意识无住此即正法。菩萨若于如实智中。善令他得如是法者。此即是为护持正法。又善男子。若有法于诸法中而可转者。彼法即无所护无所取。如是解者。此即是为护持正法。又复于诸见中。依止邪见者。彼见即无所护无所取。如是解者。此即是为护持正法。又复以其无智痴障故。心不清白。若彼无智痴障中。无所护无所取。如是解者。此即是为护持正法。又善男子。若法有集有散即非法非律。若无集无散即是法是律。何等法集散。谓有为道诸法集散。若非法非律。何无集无散。是故当知。若无取即无生。由无生即无集亦无散。以无集无散故。即是法是律。何者是法是律。谓自性不生。诸烦恼等不令生起。此即名为是法是律。若是法是律故。即不生不灭者即是无尽。此无尽者。即是无生法律。如是无生法乃无所护。此无所护。是即真实护持正法。复次功德光王。彼大智力声如来说是法时。彼众会中三万二千菩萨。得无生法忍。法语菩萨于彼佛所。得闻法已心意快然。踊跃欢喜前白佛言。稀有世尊。善说如是护持正法甚深法门。世尊。如我解佛所说义。如我所得。即一切法无法。若无法即有法。何以故。世尊。若一切法有所取着即无法。若无所取着即有法。以法与非法二想。于一切法中。无法非法。二想可知。世尊。一切法与非法。若于胜义谛中。即无法可得。亦无非法可得。由无法想亦无非法想故。即无法可数。以无法可数故。即住实际。若住实际即是无际。何以故。虚空际即是诸法实际。以其虚空无所从来。是故无际。如虚空无所从来故无际。诸法亦然。无所从来故亦无际。乃说诸法即虚空际。世尊。若有菩萨。得闻如是实际法已。如实解者。彼即了达诸法无有二相。世尊。我不见有少法可得。若法无所有。是故我说护持正法。又复世尊。我说此法时。契顺如来所说语不。是法语不。法随法说我为正说不。佛言。善男子。如汝所说。真实契顺如来之语。是实法语。法随法说是为正说。复次功德光王。彼法语菩萨说是法时。彼天子众中。有十千天子得柔顺法忍。功德光王。汝勿生疑念。彼时法语菩萨者岂异人乎。即汝功德光王是。汝今于此大众会前。劝请于我。是故我今以彼阿僧祇俱胝劫中。积集阿耨多罗三藐三菩提法付嘱于汝。汝当受持。广为他说宣演流布

尔时世尊说是法已。而此会中有六十俱胝大菩萨众。悉住佛前。异口同音咸作是言。世尊。我等愿为护持如来菩提正法。广演流布

佛告诸菩萨言。诸善男子。汝等修行住何法已。乃于如来阿僧祇俱胝劫。积集菩提之法而为护持

尔时会中有菩萨。名山自在王。前白佛言。世尊。若护惜身命。斯即不能护持正法。我不惜身命故。如是乃能护持正法

吉祥峰王菩萨言。世尊。若于利养有所希求。斯即不能护持正法。我于名闻利养等事而悉弃舍。非圣所许亦悉远离。如是乃能护持正法

大幢菩萨言。世尊。若法非法有其二想。斯即不能护持正法。若离二想得法平等。如是乃能护持正法

胜密菩萨言。若烦恼病之所逼迫。斯即不能护持正法。我得诸圣智慧之力。胜伏烦恼。如是乃能护持正法

持炬菩萨言。世尊。若处痴暗境界之中。斯即不能护持正法。我得无碍智光离诸痴暗。如是乃能护持正法

电天菩萨言。世尊。法中若起比量智者。斯即不能护持正法。我已证得现量之智。于诸法中不起他信。如是乃能护持正法

普密菩萨言。世尊。若世俗根性及散乱心。斯即不能护持正法。我于诸根诸门诸处。善调深密。如是乃能护持正法

净光菩萨言。世尊。若众生法有种种性及种种想。斯即不能护持正法。我于一切众生起平等心。及一切法亦得平等。如是乃能护持正法

最胜步菩萨言。世尊。若起散乱非等引心。斯即不能护持正法。我住等引不散乱心。如是乃能护持正法

导师菩萨言。世尊。若不了知正道之法。修行邪道。斯即不能护持正法。我已了知正道智法。邪道众生置如实道。如是乃能护持正法

善慧菩萨言。世尊。若犹豫心起于分别。斯即不能护持正法。我今已离犹豫之心。断诸分别。复令一切众生得除疑惑之病。如是乃能护持正法

遍照菩萨言。世尊。若住非法坏修行道。斯即不能护持正法。我住正法真实修行。复置一切众生皆住如实道中。如是乃能护持正法

明观菩萨言。世尊。若具染慧离法光明。斯即不能护持正法。我得决定慧圆善巧智具法光明。如是乃能护持正法

无碍慧菩萨言。世尊。若有碍心不能随护众生之慧。斯即不能护持正法。我以无障碍心随护众生令住胜慧。如是乃能护持正法

行净慧菩萨言。世尊。若不善解诸众生根。又不能知诸众生行。斯即不能护持正法。我于一切众生根行智解入已。如是乃能护持正法

庄严王菩萨言。世尊。于法若有分别之想。依止我人及依止法。斯即不能护持正法。我于一切分别非分别。悉离遍计。三轮清净。无我无人无法依止。亦无造作。如是乃能护持正法

师子幢菩萨言。世尊。世间众生闻一切法无生无起。咸皆惊怖。斯即不能护持正法。我已了知一切法无生无起。无复惊怖。不见有法。若近若远如实住已。如是乃能护持正法

慈氏菩萨言。世尊。若于菩提起悬远想。斯即不能护持正法。若有菩萨作是思惟。我虽得阿耨多罗三藐三菩提。而不见菩提。若身若心有所和合。非不和合。彼菩萨者如是乃能护持正法

功德光王菩萨言。世尊。若住非功德离真实功德。不求如来胜功德者。斯即不能护持正法。我已远离诸非功德。安住菩萨真实功德。勤求如来最胜功德。如是乃能护持正法

妙吉祥菩萨言。世尊。如世狂乱之人作如是言。我能护持如来正法。此非诚信。所以者何。如佛世尊坐道场时。无法可得亦无所证。是中云何有法可护。世尊。我于一切法都无所护。离诸执着。而以大悲持诸法性。然于诸法无所成办。非不成办

尔时世尊赞妙吉祥童真菩萨言。善哉善哉。妙吉祥。如是如是如汝所说。我坐道场时无少法可得。无所得时乃作是言处于道场。妙吉祥白佛言。世尊。为于何时坐道场邪。若有所坐。即于菩提而有所得。斯乃有二对碍有别菩提有别。世尊。谓以佛及菩提无二对碍故。佛言。妙吉祥。菩提场自性我了达已。是故我乃坐菩提场。以我自性即是菩提场自性。而菩提自性即一切众生自性。彼一切众生自性即一切法自性。妙吉祥。同一自性等一味故。我于菩提场成正觉时。观菩提场。无有少法而不解脱。谓以菩提平等故。现证诸法而亦平等。然平等法中不堕诸数。数与非数皆悉离故。彼平等法。是故如来说名无为。妙吉祥如来得是无为。超越一切有为之法。如来说是法时。妙吉祥菩萨深生信解。及一切众会信解如来解脱之法。由信解故。普遍皆于平等法中无所违越

尔时无量功德宝无垢殊妙庄严世界。先同海意菩萨。来此娑婆世界。诸大菩萨摩诃萨众闻是法已。心意快然踊跃欢喜。咸皆忻乐俱发是言。我等来此佛刹快得善利。见佛世尊。又见妙吉祥童真大士。得闻说此甚深正法。见佛出世见此正法现住世间转大法轮。世尊。若此正法所在之处广流布者。彼诸众生得大善利。又若有人于佛在世或涅槃后。而能听受如是正法。闻已信解。受持读诵广为他说。当知是人得大利益。佛言。诸善男子。如汝所知。菩萨善得几种大利。彼菩萨白佛言。世尊。菩萨善得十种大利。此即不思议善利所转。何等为十。所谓一者值佛出世而能亲近得此大利。二者得见佛已深心清净。三者起清净心听受正法。四者闻正法已离诸疑惑。五者离疑惑已于中出家。六者既出家已净命自资。七者净命资故能善说法。八者善说法已发菩提心。九者由不忘失菩提心故。而能听受菩萨藏法。十者闻菩萨藏甚深法已。依法修行得此大利。世尊。如是等法。是为菩萨十种大利。此即不思议善利所转若诸菩萨如是住者。此即说名善得大利

时佛赞言。善哉善哉。汝诸大士。善说菩萨所得大利。说是法时。会中有三万六千人。发阿耨多罗三藐三菩提心

佛说海意菩萨所问净印法门经卷第九佛说海意菩萨所问净印法门经卷第十

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时海意菩萨摩诃萨白佛言。希有世尊。多所饶益。修大乘者一切众生。谓诸天人虽受天人中乐。乃能亲近无上涅槃最胜妙乐。世尊。有几种法而能随转摄受大乘。复有几法于大乘中而能多作。复有几法于大乘中而极难作。复有几法增长大乘。复有几法于大乘中而为障难。世尊。复以何缘说名大乘

佛告海意菩萨言。汝当谛听。我今为说。海意当知。有一种法摄受大乘。何等为一。谓不忘失大菩提心。复不放逸。海意。复有一法摄受大乘。谓信所作悉堕业报。复有一法谓起正见。于缘生法不相违背。复有一法离爱非爱。于一切众生起平等心。复有一法。随住大慈而自救度。复有一法。起大悲心不着己乐。复有一法。希求佛身随念于佛。复有一法。依法真修随念于法。复有一法。住不退转众中随念于众。复有一法。蠲除一切烦恼随念于舍。复有一法。常不忘失菩提心故随念于戒。复有一法。住清净法随念于天。复有一法。随住利乐令他欢喜。复有一法。住坚固意极善乐欲。复有一法。起欢喜心为一切众生施作解脱。复有一法。从甚深法如理出生勤求正法。复有一法。不以财利之心而行法施。复有一法。于听法者作病人想。复有一法。于所说法如良药想。复有一法。己说法者如医王想。复有一法。常行卫护令法久住。复有一法。令三宝种不断不绝。复有一法。无贪相续常生喜足。复有一法。舍诸所有不起爱着。复有一法。虽自守戒。而常将护诸破戒者。复有一法。诸恶作者不观彼过而住于忍。复有一法。诸善作者现起饶益而住于忍。复有一法。于背恩者起悲愍慧。复有一法。于知恩者起恭敬悲。复有一法。于无智者不起慢心。复有一法。于有智者随彼受学。复有一法。深固善根心无厌舍。复有一法。于诸善法心常随转。复有一法。无谄曲故三戒清净。复有一法。于说法者爱敬承事如师尊想复有一法。舍诸外道文籍善听正法。复有一法。修诸善根虽复艰苦。于生死中亦不疲懈。复有一法。于现住世及已涅槃诸佛如来。承事供养而无厌足。复有一法。与诸众生为不请友。复有一法。以无依无取无著之心修四摄法。复有一法。了知在家诸过失已常乐出家。复有一法。于正士之业常自开发。复有一法。所作决定住菩提道增修胜行。复有一法。于同住大乘者不生恼恚。复有一法。教授菩提心法不生疲懈。复有一法。善护秘密法使不流散。复有一法。常当勤求法工巧智。复有一法。以真实语建立法幢。复有一法。所发誓愿当令毕竟。复有一法。以无变悔心钧行布施。复有一法。常当觉了诸魔事业。复有一法。常应发起离慢智业。复有一法。远于知识乐居寂静。复有一法。离增上慢及贡高心不起他谤。复有一法。虽复了知诸烦恼已。而亦随顺世间行相。复有一法。净命自资离诸贪染。复有一法。深固相应而常宴坐。复有一法。虽复多闻而常寂定。复有一法。如理正修瑜伽行地。复有一法。如实伺察空境界法。复有一法。于其利衰心无高下。复有一法。怖畏愦闹独处园林。复有一法。若得法利与他同分。复有一法。善解四圣谛智。复有一法。于诸智法而无秘惜。复有一法。为未学者成办学故心无高胜。复有一法。若得若失。信业报故不生热恼。复有一法。恭敬听法之者善为说法。复有一法。于亲友中离诸贪爱。于一切众生起平等心。复有一法。于说法师所不起谄心而常赞叹。复有一法。以调顺心故荷担一切众生。复有一法。于诸波罗蜜多相应勤求。复有一法。精进长养菩提道行。复有一法。建立信根令无动转。复有一法。于国城中不空受食。复有一法。积集七种圣财而不匮乏。复有一法。内意真实安固命根。复有一法。以方便善巧成熟众生。复有一法。行法施故而善摄法。复有一法。离诸诤论说最上法。复有一法。以无所得心听受正法。复有一法。离沙门垢故而成沙门。复有一法。以无染爱心入王城聚落。复有一法。常当伺察过失善护一切众生。复有一法。弃舍世间诸杂艺者。复有一法。于善知识所常当诚实。复有一法。自心清净已起智复令一切众生心得清净。复有一法。无虚假故内意清净。复有一法。趣向最胜道故深心清净。而此一法善作胜业方便清净。复有一法。福清净已诸相清净。复有一法。智清净已烦恼清净。复有一法。众生清净已刹土清净。复有一法。虽观无相而善回向。复有一法。修随顺忍。复有一法。于三解脱门常当伺察修习出离。复有一法。住无所住。复有一法。证漏尽智神通游戏。复有一法。住于止观所作成办得明解脱。复有一法。勤修方便所摄之慧。复有一法。住三界轮得菩提场庄严。复有一法。谓一切法平等现成正觉。复有一法。摄受大乘。谓一切法自性无性无生无起。如是知已即得无生法忍。海意。此之一法而能摄受大乘。如是等一法摄受大乘已。余诸摄受依止而悉舍离

复次海意。有二种法。于大乘中而能多作。何等为二。一者于佛法中生净信解。二者不乐声闻缘觉乘法。有二种法。于大乘中而极难作。何等为二。一者自解脱已善护未解脱者。二者随为彼说解脱之法。复有二法多作。一者常不坏灭大菩提心。二者伺察众生善为建立。复有二法难作。一者观菩提心犹如幻法。二者观一切众生皆悉无我。复有二法多作。一者心无厌离。二者所修方便而不虚假。复有二法难作。一者内心清净而为根本。二者无作无不作故修诸福行。复有二法多作。一者勤修善根方便。二者所修方便而令毕竟。复有二法难作。一者无戏论故而修方便。二者所修方便住毕竟故其心寂静。复有二法多作。一者深心趣向胜道。二者于最胜法中作最胜所缘。复有二法难作。一者说悔自罪。二者出离他罪。复有二法多作。一者舍诸所有。二者不求果报。复有二法难作。一者起平等心而行施舍。二者善能回向。复有二法多作。一者护戒无缺。二者不求生天。复有二法难作。一者于毁戒者起悲愍心。二者自具戒德不作贡高。复有二法多作。一者善乐于忍。二者回向菩提。复有二法难作。一者舍离高心。二者尊敬忍者。复有二法多作。一者发起精进求诸善法。二者于诸善根生欢喜心。复有二法难作。一者身心寂静。二者心离依着。复有二法多作。一者积集禅支。二者心业调畅。复有二法难作。一者不着禅味。二者不厌欲界。复有二法多作。一者勤求正法。二者常生法欲。复有二法难作。一者伺察于法。二者于法寂定。复有二法多作。一者亲近善友。二者于师长所增加尊重。复有二法难作。一者专勤承事。二者善言随顺。复有二法多作。一者于时非时而常请问。二者随所得义领纳于心。复有二法难作。一者修义智。二者修法智。复有二法多作。一者闻财无厌。二者闻慧无厌。复有二法难作。一者伺察深固之法。二者远离不深固法。复有二法多作。一者如理为他说法。二者于听法者起悲愍心。复有二法难作。一者于法不吝。二者不以财利之心为他说法。复有二法多作。一者止息外听。二者摄受诸心。复有二法难作。一者息除五盖。二者修七觉分。复有二法多作。一者获得欢喜。二者喜受相应。复有二法难作。一者知法知量。二者知自境界。复有二法多作。一者信于业报。二者善修胜行。复有二法难作。一者解了诸非业报。二者增长一切善法。复有二法多作。一者出诚实言。二者不诳圣人。复有二法难作。一者如说能行。二者不坏佛眼。复有二法多作。一者身业清净。二者离三不善。复有二法难作。一者观身犹如影像二者观如草木瓦砾。复有二法多作。一者语业清净。二者离语四过。复有二法难作。一者解悟不可说法。二者智了诸声犹如对响。复有二法多作。一者心业清净。二者远离贪嗔邪见。复有二法难作。一者内心寂止。二者外无所行。复有二法多作。一者修慈心观。二者于诸众生起平等心。复有二法难作。一者心如虚空清净无垢。二者自度度他而善回向。复有二法多作。一者常不厌离大悲之心。二者勤修善根而无懈倦。复有二法难作。一者伺察无生。二者善护出离。复有二法多作。一者游戏法园。二者除厌离心。复有二法难作。一者圆满寂默之法。二者未具法者而令修行。复有二法多作。一者舍离爱染。二者断诸损害。复有二法难作。一者修于舍行。二者观察众生而无艰苦。复有二法多作。一者修念佛观。二者住于无念而起念心。复有二法难作。一者观于法身。二者成办诸相好身。复有二法多作。一者修念法观。二者成办诸众生法。复有二法难作。一者伺察离贪。二者于其贪行众生起大悲心。复有二法多作。一者随念诸菩萨众。二者归向不退转众。复有二法难作。一者观察无为。二者护得果者。复有二法多作。一者随念于戒。二者常不忘失大菩提心。复有二法难作。一者伺察无加行戒。二者摄受将护破戒众生。复有二法多作。一者随念于舍。二者舍己不生变悔。复有二法难作。一者蠲除己之烦恼。二者为众生说断烦恼法。复有二法多作。一者随念于天。二者不求生天。复有二法难作。一者住正念慧。二者散乱心者令住念处。复有二法多作。一者增修福行。二者增修智行。复有二法难作。一者善修无加行智。二者于诸福行不生厌离。复有二法多作。一者超越诸着。二者于诸爱着悉能解脱。复有二法难作。一者极善乐欲。二者不生谄诳。复有二法多作。一者知恩。二者报恩。复有二法难作。一者断除欲贪。二者于善法欲而无厌弃。复有二法多作。一者说悔诸罪。二者不作诸罪。复有二法难作。一者不起恶作。二者不起随眠。复有二法多作。一者随喜他福。二者自福无厌。复有二法难作。一者于一切罪起尽灭智。二者于一切福起长养智。复有二法多作。一者劝请诸佛。二者护持正法。复有二法难作。一者虽知法界本无分别。二者智善分别说诸句义。复有二法多作。一者善解回向。二者随所回向与一切众生共之。复有二法难作。一者决择无相。二者修诸有相。复有二法多作。一者虽观于空。二者观照众生。复有二法难作。一者慧起悉无所乐。二者方便而有所乐。复有二法多作。一者希求善根。二者为诸众生成办善根。复有二法难作。一者修习无愿。二者积集所生之智。复有二法多作。一者无著。二者无动。复有二法难作。一者无慢。二者爱乐。复有二法多作。一者乐居寂静。二者领纳寂静功德。复有二法难作。一者修寂静行。二者自度复度一切众生。复有二法多作。一者少欲。二者知足。复有二法难作。一者省察己之烦恼。二者审观断除一切众生烦恼。复有二法多作。一者安定。二者伺察。复有二法难作。一者常省己过。二者不观他过。复有二法多作。一者自离贡高。二者不起他谤。复有二法难作。一者观我无我。二者观众生无众生。复有二法多作。一者自常行施。二者容受他施。复有二法难作。一者出离轮回。二者度轮回中一切众生。复有二法多作。一者勤求波罗蜜多。二者随诸所求波罗蜜多如所说住。复有二法难作。一者得现量智。二者成办他智。复有二法多作。一者不求世间名闻利养。二者勤求正法。复有二法难作。一者不饶益者为作饶益。二者已饶益者而令增极。复有二法多作。一者所作大慈而无边际。二者所行大悲而无间断。复有二法难作。一者已得度者而令证悟。二者未得度者而为济度。复有二法多作。一者为诸众生成就功德。二者无德众生起大悲心。复有二法难作。一者不饶益者作饶益行。二者已作饶益而无异想。复有二法多作。一者常作身念处观。二者身住清净。复有二法难作。一者虽作身中身随念观。二者不与身俱起于寻伺及寻伺道。复有二法多作。一者常作受念处观。二者于苦乐等受而无领纳。复有二法难作。一者虽作受中受随念观。二者不与受俱起于寻伺及寻伺道。复有二法多作。一者常作心念处观。二者心住清净。复有二法难作。一者虽作心中心随念观。二者不与心俱起于寻伺及寻伺道。复有二法多作。一者常作法念处观。二者常起决择法智。复有二法难作。一者虽作法中法念处观。二者不与法俱起于寻伺及寻伺道。复有二法多作。一者已生诸不善法悉令除断。二者已生一切善法而能守护。复有二法难作。一者未生诸不善法防令不生。二者未生一切善法当令生起。复有二法多作。一者常修欲勤心慧四种神足。二者应以神足得度众生而善度之。复有二法难作。一者虽获无加行神变。二者不动法界能于一切佛刹之中显诸神应。复有二法多作。一者自所得信而无动转。二者诸未信者令具于信。复有二法难作。一者自心而无杂染。二者染心众生令得清净。复有二法多作。一者发起诸精进根。二者安住念根不生散乱。复有二法难作。一者决择善观诸精进根。二者不着空相而起于念。复有二法多作。一者于定慧根勤修诸行。二者所修诸行不生疲懈。复有二法难作。一者智无所行。二者成熟众生而有所行。复有二法多作。一者于诸烦恼观离烦恼二者已生烦恼勤求出离。复有二法难作。一者一切法不和合本离烦恼故。二者于三界和合。为断一切众生诸烦恼故

佛说海意菩萨所问净印法门经卷第十佛说海意菩萨所问净印法门经卷第十一

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次海意。复有二法。于大乘中而能多作。一者精进修七觉支。二者深心说觉支法。复有二法难作。一者不住尽智。二者无生智忍。复有二法多作。一者善行正道。二者善知非道不行。复有二法难作。一者修向道智。二者安立正道。复有二法多作。一者随顺缘生之法。二者离二边见。复有二法难作。一者善知一切众生染因染缘。二者善知一切众生净因净缘。复有二法多作。一者觉知魔事。二者远离魔业。复有二法难作。一者出离诸魔。二者令魔隐伏。复有二法多作。一者已尽之法复无所尽。二者无尽之法而不可尽。复有二法难作。一者本来无尽。二者谛观诸法刹那破坏。复有二法多作。一者从初发心而即伺察大菩提场。二者伺察菩提场故不乐余乘。复有二法难作。一者初发心时。是即出生菩提场因。二者虽复起诸善心而无取着。复有二法多作。一者生死相续之者为断诸结。二者善根相续之者。令其发心不生厌离。复有二法难作。一者若有方分若无方分。一切善根悉用回向无上菩提。二者虽复回向菩提。起心谛观皆如幻法。复有二法多作。一者令诸众生普观菩提。二者已观菩提众生令观解脱。复有二法难作。一者伺察菩提平等故众生亦平等。二者成熟众生精进无倦。复有二法。于大乘中而能多作。一者发心如理决择一切善法。二者发起大悲之心。以诸众生置涅槃道。海意。此之二法于大乘中而能多作。复有二法。于大乘中而极难作。一者无生而生。二者无起而起。海意。此之二法于大乘中而极难作

复次海意。有三种法增长大乘。何等为三。一者发菩提心增修善根。二者为善知识之所摄受不生疲懈。三者建立大悲而无退转。此之三法增长大乘。复有三法增长大乘。何等为三。一者勤修胜行。二者伺察诸行。三者于胜行中为诸众生而善成办。复有三法。一者摄止悭心。二者广行施舍。三者回向菩提。复有三法。一者自集净戒。二者将护破戒之人。三者回向菩提。复有三法。一者心无障碍。二者忿恚众生令得清净。三者回向菩提。复有三法。一者精进无倦。二者懈怠众生而能将护。三者回向菩提。复有三法。一者从禅定生。二者不着禅定。三者回向菩提。复有三法。一者勤求多闻。二者如闻伺察。三者回向菩提。复有三法。一者起于缘众生慈。二者起于缘法之慈。三者起于无缘之慈。复有三法。一者自所作故起于悲心。二者为他作故起于悲心。三者离二边故起大悲心。复有三法。一者勤求自利之智。二者勤求利他之智。三者发勤精进二利圆满。复有三法。一者过去已尽之智。二者未来未至之智。三者现在住法界智。复有三法。一者于其正定众生起方便慈。二者于其不定众生起解脱慈。三者于其邪定众生起大救度慈。复有三法。一者得乐受故身业调畅。二者善护他故语言甘美。三者行正直故心业堪任。复有三法。一者虽修不净之观。而于贪行众生类中不生厌离。二者虽修慈心之观。而于嗔行众生类中不生厌离。三者虽修缘生之观。而于痴行众生类中不生厌离。复有三法。一者利益修胜行故。二者欢喜常知足故。三者清凉永无热恼故。复有三法。一者任持所闻。二者总持文句。三者入于智声前后际断故。复有三法。一者摄集七圣财故而不匮乏。二者法施无障碍故能行大舍。三者所有财利。钧众分故常得大富。复有三法。一者诚谛入胜义谛故。二者真实无虚诳故。三者如常无变异故。复有三法。一者自知今我云何。二者知诸众生当何施作。三者知时解时非时诸分位故。复有三法。一者蕴法蕴平等。二者界法界平等。三者处观如空聚。复有三法。一者不坏因果。二者能善长养诸缘。三者和合互相涉入。复有三法一者不违背佛。二者不毁谤法。三者不轻慢众。而常尊重恭敬承事。复有三法。一者止息于贪。二者远离于嗔。三者开晓于痴。复有三法。一者入世俗谛。二者真实说相。三者胜义谛无住。复有三法。一者于诸众生不起轻慢。二者于阿罗汉常生尊敬。三者不为烦恼之所制伏。复有三法。一者不染欲界。二者不乐色界。三者不着无色界。复有三法。一者于衰讥毁苦其心不下。二者于利称誉乐其心不高。三者不染世之八法。犹如山王安固无动。复有三法。一者隐密诸根。二者善解诸结。三者善调其心。复有三法。一者建立地位功德。二者能离地位过失。三者于地地中善能胜进。复有三法。一者内心起胜上智。二者深心起差别智。三者方便起安立智。复有三法。一者定清净已得增上戒学。二者慧圆满已得增上心学。三者解脱圆满已得增上慧学。复有三法。一者乐受断除贪爱。二者苦受断除嗔恚。三者不苦不乐受断除无明。复有三法。一者虽转于因而无加行。二者虽转烦恼而无分别。三者虽转三界而无愿求。复有三法。一者决择于空远离诸见。二者决择无相止息寻伺。三者决择无愿三界寂灭。复有三法。一者眼空。二者色境离性。三者眼识无住。复有三法。一者耳空。二者声境离性。三者耳识无住。复有三法。一者鼻空。二者香境离性。三者鼻识无住。复有三法。一者舌空。二者味境离性。三者舌识无住。复有三法。一者身空。二者触境离性。三者身识无住。复有三法。一者意空。二者法境离性。三者意识无住。复有三法。一者密修于戒。二者善护于定。三者决择于慧。复有三法。一者修念任持正法。二者修慧深固伺察。三者修行觉了行义。复有三法。一者随住声闻圣谛声中说解脱法。二者随住缘觉缘生法中说解脱法。三者随住菩萨六波罗蜜诸胜行中。说解脱法。复有三法。一者舍。谓舍一切珍宝。二者大舍。谓舍妻子奴婢眷属。三者极舍。谓舍身分头目手足。复有三法。一者护持正法。二者护持诸说法师。三者护持大乘之法。复有三法。一者不令生死相续。二者觉悟生死过失。三者远离生死罪业。复有三法。一者无盖障心听受正法。二者无随眠心而常宴坐。三者以出离心能正修行。复有三法。一者所闻依义。二者观察依智。三者解脱依法。复有三法。一者多闻乐居寂静。二者住寂静已深固作意。三者深固作意相应而能觉了诸法平等。复有三法。一者恭敬智者。二者请问多闻。三者护修定者。复有三法。一者不以得利之心而行法施。二者于听法者慈心摄受。三者起一切智心现前所作。复有三法。一者心平等故众生平等。二者无种种性故诸法平等。三者智平等故诸佛平等。复有三法。一者智。知三世平等。二者慧解三解脱平等。三者了。悟三界平等。复有三法。一者善观诸行无常亦复是苦。二者善观诸法无我。三者善观涅槃寂静。复有三法。一者誓愿真实住毕竟故。二者所闻真实如理修行。三者三摩地真实发生胜慧。复有三法。一者已作之罪而不覆藏。二者未作之罪防令不起。三者现所有罪悉令悔灭。复有三法。一者远离恶作。二者远离随眠。三者远离疑惑。复有三法。一者乐居寂静。二者离于贪爱。三者起善法欲。复有三法。一者住深法忍。二者说种种法。三者得一切处通达辩才。复有三法。一者所闻决定总持。二者得佛加持辩才。三者诸所说法贤圣摄护。复有三法。一者从初发心坦平如地。二者诸行毕竟诸行相续。三者虽转诸想而住不退转地。复有三法。一者圆满闻所成忍。二者思所成忍而不流散。三者获得无生法忍。复有三法增长大乘。一者方便与慧和合修诸道行。二者大慈大悲和合成熟众生。三者精进不放逸和合护持正法。海意此之三法而能增长大乘

复次海意。有四种法。于大乘中而为障难。何等为四。一者恶闻。所谓寻求外道文籍。二者于其六波罗蜜菩萨藏正法不乐听受。三者增上慢心起诸魔业。四者业障随逐毁谤正法。海意。此之四法于大乘中而为障难。复有四法。于大乘中而为障难。何等为四。一者贪爱。二者嗔恚。三者愚痴。四者烦恼增盈不求善法功德。复有四法。一者嫉他得利。二者谄曲亲近诸说法师。三者起黠。利慧诳行饶益。四者以不实心而作欺诳。复有四法。一者于善友所起恶友想。二者于恶友所起善友想。三者于非法中起正法想。四者于正法中起非法想。复有四法。一者常起悭染之心。二者见乞丐人即起损害过失之心。三者施已生变悔心。四者起背一切智心。复有四法。一者欲心行施。二者过失心行施。三者怖畏心施。四者愚痴心施。复有四法。一者为求名称故施。二者为求美誉故施。三者为求善声故施。四者为求赞叹故施。复有四法。一者以世俗情义故施。二者有所为事故施。三者不显明施。四者不自手施。复有四法。一者以粗物施。二者不贵重施。三者不恭敬施。四者增上慢施。复有四法。一者以利刀施。二者以毒药施。三者不轨法施。四者损害心施。复有四法。一者于持戒人生嗔恚心。二者于破戒人起彼损害不将护心。三者自所修戒而常杂乱。四者于说戒人起杀害想。复有四法。一者好求艰苦财利。二者若得法利不钧他分。三者不欲他人所得利养。四者于自得利不生知足。复有四法。一者身曲非威仪道。二者语曲所言不实。三者心曲欲作诸罪。四者一切处曲不以净命而资养故。复有四法。一者于其同住大乘之者起嗔恚心。二者不能觉了诸魔事业增上慢故。三者闻非所说而即喜行。四者闻说诸善功德而生恼意。复有四法。一者高慢正法不能亲近。二者于说法师不起尊重。三者于其父母师长及亲教师不生归敬。四者身心坚犷诸所起行常生违背。复有四法。一者举扬自德。二者隐覆他德。三者我慢炽然。四者坚猛嗔恚。复有四法。一者懈怠。二者惛沈。三者不正顺。四者执着。复有四法。一者不调伏。二者不寂静。三者不隐密。四者不柔善。复有四法。一者少闻入于国城聚落。二者不具戒蕴而求利养。三者不护身仪入女人舍。四者不住等引之心。解入一切众生根性。复有四法。一者不能勤修四摄之法。二者弃舍成熟众生。三者毁谤正法不作护持。四者于说法人而生娆恼。复有四法。一者愚痴常生多欲。二者嗔恚乐作诸罪。三者贪爱不生喜足。四者求利心常无厌。复有四法。一者不信而常掉举。二者亲近恶友不厌舍罪。三者懈怠减没善法。四者放逸所作善根而皆丧失。复有四法。一者不能内观察故而常无惭。二者慧解不明晓故而常无愧。三者与无间业等故而不知恩。四者虽于他人少行善利。而自伐灭返生诬谤。复有四法。一者嗔。二者忿。三者恨。四者害。复有四法。一者虚诳诸圣。二者不护诸圣。三者轻慢施主。四者于阿罗汉起增上慢。复有四法。一者身业不能清净。二者语业不能善护。三者心业杂染。四者于大乘中而生疲倦。复有四法。一者于众聚中而起两舌。二者于师长阿阇梨所而发恶语。三者于诸来求者而兴绮语。四者虚诳人天。复有四法。一者不护戒蕴。二者不越他世。三者散失善根。四者破坏长养胜行。复有四法。一者于大众中起强胜心。二者于集会所执高慢心。三者常出恶言欲离于罪。四者以杂乱语说世间典。复有四法。一者以不勤行心居寂静处。二者多损害心居愦闹中。三者不种善根起有福想。四者窃菩萨名求利活命。复有四法。一者心不柔顺。二者其心粗犷。三者心不调伏。四者于诸众生起艰苦心。复有四法。一者憍恃持戒。二者憍恃多闻。三者憍恃住阿兰若。四者憍恃头陀功德。复有四法。一者计我为胜。二者计法为胜。三者以少善根计为高胜。不回向菩提。四者先修大乘之行。中乐声闻缘觉乘法。复有四法。一者执着于身。二者执着于心。三者执着于戒。四者不向胜道。复有四法。一者亲友家乞于非家用。二者追求利养自谓清净。而复喜见破戒之者。三者耽乐俗舍。四者于具戒人而生嗔恚。艰苦所作起诸缠缚。复有四法。一者多作事。二者多求利。三者多语言。四者多知识。复有四法。一者我见取着于我。二者众生见取着众生。三者断见取着无作。四者常见取着身命。复有四法。一者虽于诸事有所发起。二者既发起已不能摄持。三者不摄持故而生疲懈。四者以疲懈故乃起怖畏。复有四法。一者不修升进地地之智。二者不能善修禅定。三者弃舍众生胜慧不行。四者虽修愿及方便。而起有得之想。复有四法。于大乘中而为障难。一者法障随眠而根性钝。二者业障随眠。于诸善根而不勤行。三者烦恼障随眠三蕴随转。四者魔事随逐忘失菩提心。海意。如是等四法于大乘中而为障难

佛说海意菩萨所问净印法门经卷第十一佛说海意菩萨所问净印法门经卷第十二

        西天译经三藏朝散大夫鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

世尊说是摄受大乘等诸法时。会中四万四千众生及千天人悉发阿耨多罗三藐三菩提心。二万八千菩萨得无生法忍。而此三千大千世界六种震动。有大光明广照十方。有千天人处于空中。言音互发喜跃回旋。复雨殊妙天诸宝花。鼓吹歌音奏天妙乐。而为供养。以妙偈词而赞叹曰

  如是最上大法藏　　如来今日亲开示
  久已安住大悲心　　为诸众生明显了

说此偈已。又作是言。世尊。若人于此如来所说大法宝藏。而能受持极少分者。是人速能解脱一切地狱恐怖。次第当转无上法轮。世尊。譬如有人去彼州城聚落不远。见地伏藏中有无尽珍宝充满。是人以具利益心故。见已即时诣州城中语诸人言。汝等善来。汝若欲求诸珍宝者。我知方处。当示于汝无尽伏藏。世尊。彼州城中有一类人。虽闻其言而不信受。有一类人信其所说。即同其人诣伏藏所。随自力能恣取其宝。如其智量得宝而还。然彼伏藏取而无尽。亦无分别此人我与彼人不与。此人应取彼不应取。何以故。而是伏藏无分别故。世尊。诸佛所说大法宝藏。亦复如是。佛于阿僧祇俱胝那庾多百千劫中。积集如是无上广大妙法宝藏。既积集已。诣菩提场成正觉果。后于波罗奈国鹿野苑中转大法轮。今日世尊。又复转此集会正法。开示无上大法宝藏。而佛世尊以无取心。于诸众生起大悲行作利益事。诸不知者。以妙梵音普遍告谕诸天及人阿修罗等。而表示言。汝等来此受持无上广大法宝。此法能尽生老病死诸苦边际。能施一切无尽妙乐。世尊。或有一类不具于信愚痴之人。于此正法不生胜解。复不正顺不能分别故不生信。或有一类具信之者。于此正法。能善分别而生胜解。复起正顺以能分别故深生净信。是人乃能于佛如来大法宝藏。随力堪任取其法宝。自取宝已。复令他人于彼诸乘解脱法中而生信解。或有乐住声闻乘性。或有乐住缘觉乘性。或有乐住阿耨多罗三藐三菩提者。然佛如来无上最胜大法宝藏而无穷尽。亦无分别。又复世尊。今此无上大法宝藏。如是广大开发显示。而诸众生于此法宝总略乃至极少分中。有不能取者。是人不得宝故。于长夜中行三恶趣无有穷尽。世尊。若复有人于此无上大法宝藏少略。乃至或能受持一四句偈者。是人具足七种圣财而不贫匮。何况有能于此广大集会正法少略一品信奉受持。或复二三四五。若十二十。逮七十品。乃至终毕能受持者。是人所获功德不可称计。何以故。今此法门不离菩提心故。为诸众生起大悲心所逼切故。是故若人能起净心。受持读诵为他说者。应知彼人得受阿耨多罗三藐三菩提记。当坐道场降伏诸魔。于大乘中得大神通。尔时世尊赞诸天子言。善哉善哉。诸天子众。汝等善说。当知善能于此正法受持读诵而生胜解如理修行者。是人建立一切语言胜妙功德。是人得至一切智顶。复知是人广为一切世间作智慧光普遍照曜。诣菩提场。不久当成阿耨多罗三藐三菩提果。何以故。由能乘御此大乘故。尔时世尊重说颂曰

  建立此最胜　　广大诸佛乘
  如虚空光明　　越诸世间故
  出离三有已　　往诣菩提场
  无彼有着心　　已离诸系着
  俱胝劫积集　　广大清净说
  布施调止门　　令内心深固
  由戒止诸罪　　身心得清净
  离诸怖畏心　　往诣菩提场
  平等心及意　　容受诸众生
  超胜于余乘　　谓诸下乘等
  趣此大乘法　　令众生欢喜
  高建大法幢　　神足御如马
  闻精进相续　　禅定为床坐
  忍辱力随得　　大智慧灌顶
  摧伏诸外众　　破诸魔军已
  诣净菩提场　　趣向大乘法
  慈心为甲胄　　怨恶不能坏
  行坚固大悲　　趣向深法理
  四禅四神足　　乘四无量行
  调御菩提心　　不舍诸正道
  十方无边际　　一切众生界
  悉于此大乘　　乘御而修进
  无苦亦无乐　　非减亦非增
  最上佛乘中　　具如是神力
  修行四念处　　及彼四正断
  四神足亦然　　五根五力等
  如佛所赞说　　具七觉支宝
  游行八正道　　往诣菩提场
  寂止诸烦恼　　圆具法光明
  破一切暗尘　　显出于三有
  神力普能召　　帝释梵王等
  汝等各善御　　此无比大乘
  诸波罗蜜多　　谓施戒及忍
  精进禅定门　　胜慧智神力
  及彼方便行　　所摄真实愿
  纵百千魔军　　此悉能摧伏
  毁戒诸众生　　勤造诸罪业
  高胜诸菩萨　　集多种功德
  若所起诸心　　菩提心广大
  能御大乘人　　彼悉能观察
  所有世间典　　种种义及行
  乃至出世间　　真实诸善法
  有学及无学　　缘觉诸圣人
  住于佛乘者　　悉入彼彼门
  若种种烦恼　　及种种心行
  诸苦恼众生　　轮转有为界
  住于佛乘者　　菩萨悉能观
  令彼等息苦　　趣向毕竟乘
  又诸懈怠人　　劣弱无势力
  而不能运心　　尽众生苦际
  由闻大乘已　　彼心生恐怖
  唯求自乐因　　不作利他行
  若明解大力　　有大智菩萨
  精进力具圆　　众生常利益
  行大悲方便　　内心性清净
  由乘最上乘　　故彼心欢喜
  普尽诸世间　　无边种种行
  上中下等差　　根性及意乐
  乘此最上乘　　具大智菩萨
  刹那能遍知　　诸众生心行
  身得妙相好　　庄严诸身分
  语出悦美音　　一切闻皆喜
  心意得清净　　具禅定神通
  由乘最上乘　　获广大功德
  此最上佛乘　　三界遍闻故
  乃至一切佛　　圣佛眼不断
  增长最上眼　　谓法眼炽然
  超越三界众　　即诸阿罗汉
  此乘净微妙　　不堕秽土中
  菩萨御此乘　　刹那见诸佛
  十方界往已　　无疲亦无减
  观此无比乘　　有如是神变
  御佛乘大士　　遍行诸世间
  超胜及比伦　　求之俱不得
  世间一勇猛　　菩萨大威神
  由乘最上乘　　能怖魔军众
  获色力威势　　及得广大富
  或帝释梵王　　轮王护世等
  乃至天及人　　得是三界乐
  由乘最上乘　　妙乐悉圆具
  菩萨心无高　　而亦复无下
  能施诸所爱　　施已不求报
  以欢喜慈心　　亦施于头目
  由乘最上乘　　回向菩提故
  菩萨持净戒　　或具于梵行
  禁戒净光明　　焕耀踰日月
  色相及富盛　　悉无所希求
  由乘最上乘　　为救度众生
  菩萨闻恶言　　不忿亦不恚
  正使碎其身　　亦护诸群品
  此身即易得　　法王值极难
  由乘最上乘　　得此忍清净
  菩萨于无边　　百千劫已来
  循环恶趣中　　流转生死界
  发大精进力　　为救度众生
  由乘最上乘　　精进力成就
  菩萨得寂静　　柔软胜妙乐
  知定功德法　　慈眼视众生
  是中无少分　　味着禅定乐
  唯思念希求　　得见于诸佛
  菩萨知诸法　　因缘所生空
  我法及众生　　彼皆无所得
  诸见善清净　　胜慧调伏心
  由乘最上乘　　此妙慧清净
  所有四圣谛　　四无量四定
  及五种智通　　四无碍解等
  于四摄法中　　法施为最上
  如是功德门　　皆从佛乘出
  所有十力等　　无边诸佛法
  佛人中师子　　说法若其吼
  眉间及口中　　无见顶放光
  由乘最上乘　　菩萨不难得
  诸佛有三种　　最胜大神通
  调伏于世间　　照明诸心意
  诸佛所说法　　其果利不虚
  由乘最上乘　　疾速皆获得
  佛语义相应　　无染无过失
  紧那罗梵音　　软美复悦意
  普摄诸世间　　众生言音等
  闻佛妙音声　　一切皆欢喜
  菩萨非久获　　如是佛言音
  等空佛刹中　　一切皆表示
  普遍悉能闻　　法义相应语
  众生闻皆乐　　烦恼悉蠲除
  假使以神力　　能至虚空边
  十方海水中　　亦能知其量
  无边众生行　　刹那心尚知
  唯佛最上乘　　功德说无尽

尔时世尊复告海意菩萨摩诃萨言。海意。是故当知。若有菩萨欲于如是广大正法。密作护持令法久住。自心洁白已。于他众生及补特伽罗。所有一切上中下根能遍知者。应当受持如是句义。所谓门句。印句。及金刚句。得受持已。如义解了。以慧相应。最胜方便如理伺察。海意。何者名为门句。所谓诸施设门。表示一切法分别义。阿字门。表示一切法无生义。波字门。表示一切法胜义谛。那字门。表示一切法了知名色义捺字门。表示一切法调伏寂静义。娑字门。表示一切法出过诸着义。多字门。表示一切法随住真如义。迦字门。表示一切法了达业报义。又娑字门。表示一切法平等无差别义。摩字门。表示一切法大悲义。誐字门。表示一切法最极甚深难彻源底义。惹字门。表示一切法超越老死义。驮字门。表示一切法法界无分别义。设字门。表示一切法圆满奢摩他义。佉字门。表示一切法虚空焕明义。叉字门。表示一切法普尽无生义。倪野字门。表示一切法智无著义。他字门。表示一切法善解处非处义。塞迦字门。表示一切法了知诸蕴义。姹字门。表示一切法毕竟无边际义。身寂静门。表示一切法无贪染义。心寂静门。表示一切法调伏嗔痴义。止息门。表示一切法归趣无著义。深固门。表示一切法出离三际义。住实性门。表示一切法住法界义。无取门。表示一切法解脱相义。无执着门。表示一切法离诤论义。无杂染门。表示一切法清净相义。法自性门。表示一切法本来明净义。妙光明门。表示一切法焕明义。观想门。表示一切法离散义。无摄藏门。表示一切法不和合义。菩提门。表示一切法平等一味义。涅槃门。表示一切法离诸烦恼义。海意。如是等门句。能受持者。得自心洁白已。于他众生及补特伽罗上中下根。悉能了知

复次海意。何名印句。所谓一切法解脱印所印。法本无二。二清净故。一切法二边无边印所印。断常清净故。一切法尽离贪印所印。尽门尽际中无尽无边际故。一切法无高无下印所印。平等性实际清净故。一切法如虚空印所印。出过五眼道故。一切法住虚空印所印。法界即虚空界故。一切法无分别印所印。法界涉入故。一切法法界印所印。法无分别相故。一切法真如印所印。前后际如实故。一切法实际印所印。本来清净故。一切法空印所印。有为同等故。一切法无相印所印。远离差别诸所缘故。一切法无愿印所印。离诸所求故。一切法无常印所印。自性无性无相故。一切法苦印所印。五蕴善积集相故。一切法无我印所印。自性无我故。一切法寂静印所印。毕竟无动故。一切法诚谛印所印。普遍摄入胜义谛故。一切法无动印所印。种子无住故。一切法不坏印所印。毕竟决定故。一切法如如印所印。前后际不断故。一切法三世平等印所印。于一切处同一味故。一切法无生印所印。自性无所有故。一切法无灭印所印。自性无生故。一切法不相待印所印。离增上慢故。一切法无戏论印所印。一切寻伺无积集故。一切法明了无相印所印。无诸色相所表示故。一切法无染印所印。依止断故。一切法无成办印所印。对治不可得故。一切法非业报印所印。一切无造作故。一切法无为印所印。悉离生灭诸分位故。一切法平等性印所印。诸法等虚空悉无差别故。海意。此等名为印句。是诸印句。乃是过去未来现在诸佛世尊菩提之印。如是印句。所有八万四千法蕴于中出生。如是印句。普摄诸佛及诸菩萨最上智印。速疾证得无生法忍。海意。如是等印句。所有不种善根诸众生等而不得闻。又此法门善能降伏一切魔业。海意。所有无尽总持宝箧。而能藏摄彼一切法。是法皆从印句中出。又复八万四千三摩地门。及遍入八万四千众生心行。及千波罗蜜门。悉从如是印句中出。而此印句亦复随入彼彼法门

佛说海意菩萨所问净印法门经卷第十二佛说海意菩萨所问净印法门经卷第十三

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次海意。云何是金刚句。谓即自身是金刚句。自性无分别故。海意。此金刚句于诸见中决择而转无明。是金刚句。入诸明故。此金刚句。于所缘事中遍知而转五无间际。是金刚句。无加行平等故。此金刚句。于诸加行遍知而转贪际。是金刚句。离贪际平等故。此金刚句。于贪离贪平等而转嗔际。是金刚句。慈际平等故。此金刚句。破诸嗔恚痴际。是金刚句。慧光明平等故。此金刚句。开显明慧一切众生一众生。是金刚句。遍入众生平等故。此金刚句。而随觉了众生自性一切众生心一众生心。是金刚句。入无心故。此金刚句。而随了知心之自性本来明澈一切佛一佛。是金刚句。遍入真如平等故。此金刚句。而随觉了平等性智一切刹土一刹土。是金刚句。遍入无尽刹土故。此金刚句。随知虚空平等一切法一法。是金刚句。入一切法性平等故。此金刚句。而随了知无二法门一切法佛法。是金刚句。于一切处智随入解故。此金刚句。而随觉了金刚喻定诸魔事业诸佛事业。是金刚句。入诸魔业随警悟故。此金刚句出过一切魔之事业一切语言。如来语言。是金刚句遍入一切音声随解了故。此金刚句。而随了知不可说法一切法无生。是金刚句。入无灭故。此金刚句。超越生老病死之道一切法无起。是金刚句。入无止息故。此金刚句。而能随转诸法寂灭。海意。此如是等诸金刚句。是不破坏句。是精妙句。是平等句。是圣谛句。是坚固句。是无种种句。是爱乐句。是不断句。是寂静遍寂近寂之句。是无作用句。是不和合句。是入无趣之趣句。是无行句。是真性句。是如实句。是不背佛句。是不谤法句。是不破僧句。是如所说句。是三轮清净句。是勇猛句。是梵行句。是空寂句。是虚空句。是觉支句。是无相句。是无愿句。是法相句是心意识无住句。是摧伏诸魔外道句。是清净无垢明澈句。是观照菩提句。是慧光明句。是无法显示句。是毕竟不生不灭句。是自境界清净句。是入佛境界句是无思惟分别遍计句。是法界无差别句。是入无句之句句。海意。如是等金刚胜妙诸句。若有菩萨随能领受决择其义者。我说是人决定当坐菩提道场。作师子吼。当佛世尊说是门句印句金刚句时。此会中有八千菩萨获得入一切法门印陀罗尼。及得遍入一切众生意乐三摩地

尔时十方世界所来集会一切菩萨摩诃萨众闻是法已踊跃欢喜。心意快然。各以神力。随自所来诸佛刹土。彼彼刹中各各所有花鬘涂香。及抹香等而悉集来。于此会中广雨众妙花鬘香等。普用持奉供养世尊释迦牟尼如来及此正法。愿此正法久住世间。是诸菩萨作供养已。同发妙音。赞叹世尊。说伽陀曰

  无相显示于色相　　一相离相大圣尊
  诸相平等相无相　　稽首安住真实相
  遍入一切众生语　　所入音声智随入
  一切音声解脱门　　稽首平等心解脱
  世间差别诸心行　　心如幻故无所觉
  无行等行无所行　　我礼虚空心明显
  有无平等边无边　　法法分别离分别
  一切心意本寂然　　我今顶礼心寂静
  佛知因缘诸运用　　佛能宣说诸因行
  因缘解脱本际中　　佛知实际真平等
  今此遍入平等相　　我观善逝身非身
  不可分别有相身　　故现差别诸妙相
  所有十方佛刹土　　皆同入此佛刹中
  而此佛刹无所增　　彼刹无动亦无减
  诸心平等心无心　　幻心无异无分别
  了知平等菩提心　　世尊常行平等法
  法界混入平等界　　诸法无性而可入
  性常平等染净中　　我礼世间利益者
  日月尚可使坠地　　风无形相亦可系
  须弥山可吹如尘　　唯佛世尊无妄说
  真实语言本清净　　净心如空心明焕
  世法贪爱不染心　　如莲不染居三有
  或闻称赞不生喜　　或闻讥谤不生嗔
  如须弥山不动摇　　我礼世间与乐者

尔时彼诸菩萨摩诃萨众说是伽陀赞叹佛已俱白佛言。世尊。由佛世尊出世间故。即是宝出。佛出世故。即是乐出。即念慧行智出。即布施持戒忍辱精进禅定胜慧出。即慈悲喜舍出。即胜义出。即实谛出。即正法出。即作证法出。即念处正勤神足根力觉道之法出。即奢摩他出。即毗钵舍那出。即六通三明八解脱出。以要言之。即断一切不善法集。一切善法出

尔时会中有一菩萨。名曰慧积前白佛言。世尊。如我解佛所说义者。以有身见生故。佛出世。以无明有爱生故。佛出世。贪嗔痴生故。佛出世。四颠倒生五盖六入七识处。八邪法九恼处。十不善业生故。佛出世。何以故。为断一切众生诸不善业故。佛出世。然佛世尊。亦无对治及增胜力。以无所对治故。佛出世。世尊。若诸菩萨欲知诸佛出世因者。应如是知如是修学。佛言。善男子。如是如是。如汝所说如佛出世应如是知如是修学。以佛出世如是因故。诸法出世亦如是知

尔时海意菩萨摩诃萨白佛言。世尊。彼初发心菩萨闻如是说佛出世因。彼不解了故。谓佛出世者。云何如是。佛言海意。佛出世因而诸菩萨随其所应心得清净。所以者何。海意当知。菩萨有四种。何等为四。一者初发心菩萨。二者修行位菩萨。三者不退转菩萨。四者一生补处菩萨。海意于此四种菩萨之中。若初发心菩萨观佛如来色相庄严心得清净。若修行位菩萨观佛如来成办一切胜妙功德心得清净。若不退转菩萨。观佛法身心得清净。若一生补处菩萨者。彼不观佛色相庄严。亦不观佛种姓族氏。亦不观佛成办功德。是中而悉无法可观。何以故。慧观照故。慧眼力故。慧所摄故。慧无行故。离诸戏论。彼不如是观亦非无观。何以故。有见无见斯为二种。此位菩萨于见非见离彼二边。如是观佛。以如是观佛故。观身亦然。观身清净已。即观佛清净。观佛清净已。应知一切法亦如是清净。如是观中若清净者。是为智观。此即名为真实观佛。海意。由如是故。我昔得见然灯如来。我时见已获得无生法忍。及无所得相应忍。即时涌身虚空。高七多罗树处虚空中。得一切智智。无差别力永断诸见。越诸思惟分别遍计。于诸境界意无所住。尔时复得六万三摩地门。是故然灯如来。为我授记。汝于来世当得作佛。号释迦牟尼如来应供正等正觉。我当彼佛说记之时。我于耳根无所对碍。亦非余识有所了知。我于和合有所得见中而无所住。我于尔时无佛及佛想。无我及我想。亦无授记及授记想。海意。是故菩萨三轮清净。授成佛记。三轮清净者。谓无佛及佛想。无我及我想。亦无授记及授记想。海意。复有三轮清净。何等为三。谓无我执。无众生执。无法执。复有三轮清净。谓无名执。无色相执。无所缘执。复有三轮清净。谓过去已尽智。未来未至智。现在住法界智。复有三轮清净。谓身如影像智。语如响智心如幻智。复有三轮清净。谓五蕴与法蕴平等。十八界与法界平等。十二处观如空聚。复有三轮清净。谓解了于空。信顺无相无愿无求。海意。若此三轮清净即一切法清净。是故诸菩萨若三轮清净者应修善巧之智

尔时海意菩萨复白佛言。希有世尊。彼不退转菩萨而能具足甚深法智。世尊。若诸菩萨能具如是法智之者。彼即善能成熟功德。佛告海意菩萨言。海意。当知此位菩萨以本愿力故善作胜业。而彼菩萨设在散位之中。以本愿力。而亦不坏成熟功德。海意。世有一等无智之人。不能解我所说。今以喻言当令闻者由譬喻得解。海意。譬如世间有甘蔗田。或复稻田。或复豆田。农作之人。于彼诸田作治事已。开其水道。随彼畎浍。流注周遍。水悉盈满。是农作人善安布已。憩于他所。彼诸田中。随处所经水自然入。不假田人更施功力。所植诸田各得成熟。菩萨亦复如是。或时虽居散位有善方便于一切众生相续善根之中而能成熟。随其所说一切佛法中。诸有善根悉能圆满。而彼菩萨心意清净。善护戒蕴。或在定位之中。以本愿力故。而能成熟一切善根。令诸众生于佛法中。相续滋长一切善法。海意。以是缘故。当知诸菩萨随其所应不假施力。而自圆满一切善根。复善回向于一切智。是故诸菩萨若定若散。以本愿力。于诸善根中身心调畅。念不散乱。不堕下乘趣向大乘。海意。譬如城中有一大树。或有人来断彼树根。断已即去。当断树时。树渐低下。毕竟须随斫处堕地。菩萨亦复如是。于长夜中修习善法。趣向一切智。渐入一切智。毕竟成熟一切善根。既成熟已。悉用回向于一切智。回向一切众生共其功德。回向愿令三宝圣种不断不绝。回向圆满身相庄严具诸相好。回向圆满语业庄严。广为众生说无诳法。回向圆满心业庄严。常念诸佛定愿成就。而是菩萨不假功用。无所发悟悉能成熟一切善根。普用回向于一切智。不堕余乘若定若散。于菩提分法修习圆满。皆由本愿方便善巧回向之力。海意。又如苾刍欲入灭定。先当要期闻犍椎声然后出定。彼入定已而犍稚声亦不入于定中。而是苾刍后假犍椎之声乃从定起。菩萨亦复如是。为欲解脱一切众生。起大悲誓愿。我当救度一切众生普令解脱。悉当成办菩提事业。于诸众生广行慈心。于生死流中运心意识普为济度。虽入定中以本度脱众生大悲愿故。终不堕于声闻缘觉之地。后从定起开发正慧。还复积集菩提分法。广为众生成熟化度。海意。汝且观是诸菩萨者所作事业而悉最胜。虽入寂静三摩地中。而能出过声闻缘觉解脱境界

佛说海意菩萨所问净印法门经卷第十三佛说海意菩萨所问净印法门经卷第十四

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次海意。我今复以喻明斯义。譬如世间。或有二人。一被金刚坚固甲胄。入于大火炽焰聚中。一被枯草而为甲胄。入于大火炽焰聚中。海意。于汝意云何。彼二人中。何人为火所焚。何人不为火焚。海意白佛言。世尊。若被金刚甲胄之者。虽入大火炽焰聚中。以其坚固甲胄能善作护。是人不为火焚。世尊。若被枯草为甲胄者。入大火中。是人决定为其所焚何以故。为彼枯草于炽焰中力无能护。佛言。海意。彼身所被金刚甲胄入大火中。不为焚者。即是菩萨。常以大慈大悲而为甲胄内心坚固。金刚力护解脱众生。所缘誓愿。曾不弃舍。虽常观察一切法空无相无愿无作无生无起。入于空寂三摩地中。而常超越声闻缘觉正位。不求得果。于彼定中。虽受胜味而不嗜着。还从定起。从定起已。严净佛土。成熟众生。圆满佛智。海意。彼以枯草而为甲胄入大火中。为所焚者。即是声闻乘人。于诸行中而生怖畏。复观三有炽然不息。弃舍众生远离大悲。于寂静三摩地中。生味着已。无所容受。若复不得第八果证。能起是定者。无有是处。何以故。声闻乘人于其福行罪行不动行中不能修习。诸菩萨者。能于无量福智行中修习成熟。不于中间取证实际。毕竟圆满一切佛法海意。是故菩萨于空无相无愿无作法中。常生大火炽焰之想。虽于此法审伺察已而复于是法中起智善行。终不取证实际。是故诸菩萨不成熟善根不应修习。海意。菩萨成熟善根者。谓于甚深佛法之中如理修行。不于中间取证实际。此即名为成熟善根。何故如是。以彼菩萨俱为成熟大乘之法。渐向渐入渐复增胜。非余乘法而成熟之。海意。如陶家轮。日光未照。未成熟时。但是坏模。无有诸器用之名。后成熟已乃可得彼器用之名。菩萨亦复如是。虽复广多修诸善根。若不回向于一切智。即不能得波罗蜜多之名。若复回向一切智者。乃得波罗蜜多之名。海意。又如妙好真金。未经工作。即不能得庄严具名。但名真金若经工作得成熟已。乃可得诸庄严具名。菩萨亦复如是。所修善根。若不回向于一切智。即不能得波罗蜜多之名。若复回向一切智者。乃得波罗蜜多之名。海意以是缘故。而诸菩萨常当运发广大之心成熟诸善。随所成熟诸善根已。即当回向于一切智。以其回向一切智故。菩萨当于甚深法中如理修行。不于中间取证实际

尔时海意菩萨复白佛言。世尊。诸菩萨者难作能作。善能防护诸有过失。于所作中不生过染。世尊。若诸菩萨具于善巧方便之者。即能回向。所以者何。菩萨有方便故。虽入禅定解脱三摩地三摩钵底中。而不为禅定解脱三摩地三摩钵底过失所著。彼具善巧方便而能现诸所作。不堕无作见中。善住诸法平等之性。若有趣向邪定聚中诸众生类。菩萨为说正定聚法。而彼菩萨为令圆满众生愿故。自亦不住正定聚中

佛告海意菩萨言。如是如是。如汝所说。菩萨于一切处。常应修习善巧方便。何以故。海意。善巧方便者。即是菩萨菩提。若无善巧方便。即不成菩提。譬如世间于一器中置三种色。一者青色。二者赤色。三者黄金色。是三种色。同一器中染三种衣。一者毳衣染其青色。二者[疊*毛]衣染其赤色。三者无价上妙天衣染黄金色。彼三种衣。于一器中。从彼染师所治事已。随诸意乐皆得妙色。须青得青。须赤得赤。须黄得黄。然其染器曾无分别。海意。其染器者即是空无相无愿。有三种人合一器中者。一声闻乘人。二缘觉乘人。三大乘人。是三种人。随诸作用如心所乐。各随所应皆取智色。而彼空无相无愿之器。曾无分别彼毳衣者。当知即是声闻乘人。[疊*毛]衣即是缘觉乘人。无价天衣即是安住大乘之人。海意。汝观诸法无有实性。无作者性。无我性。无人性。无众生性。无寿者性。无主宰性。随欲所生。生已聚集。无所觉了。亦无分别。海意。若能解了此诸法生。即诸菩萨于诸法中无有少法而生懈倦。若得如是知见清净。诸所作中亦无饶益无不饶益。即能如实了知诸法平等之性。如是如实了知诸法平等性已。常不弃舍大悲之铠。海意。譬如世间琉璃珠宝。自体莹洁净无瑕翳。置尘秽中经于千岁。过千岁已取之治事。去其尘秽涤浣清净。依然莹洁离诸瑕翳。菩萨亦复如是。了知众生心之自性。本来清净明澈洁白。但为客尘烦恼之所覆蔽。菩萨观已。即作是念。众生心性本来清净。但为客尘烦恼之所覆蔽。而彼烦恼实无所住。众生横起虚妄分别。我当为彼诸众生类宣说断除烦恼之法。起无懈心。于众生所转复增胜运心。普令皆得解脱。又复思惟。此诸烦恼能坏众生诸有力势使令劣弱此诸烦恼能令众生于无实烦恼中虚妄分别。若能如实深固作意如理伺察者。彼即不为烦恼所动。如所伺察已。即彼烦恼不复和合。若与烦恼不和合者。斯即为善。又复我今若与诸烦恼合。云何能为烦恼系缚诸众生等宣说断除烦恼之法。故我今时不与诸烦恼合。应为烦恼系缚众生说断除法。然我欲为化度众生于轮回中令诸善根相续不断。亦复应当与烦恼合。云何名为于轮回中与烦恼合相续善根。所谓勤求福行而无厌足。菩萨作是思惟已。于三有中故现受生愿值诸佛誓度众生而无懈倦护持正法。诸所施作勇进无退。常生法欲。永不弃舍波罗蜜多胜行。海意。此即名为于轮回中与烦恼合相续善根。菩萨当于是中虽合烦恼。不为烦恼过失所染。海意白佛言。世尊。今说善根。何缘故说诸烦恼邪。佛言。海意。菩萨了知此如是等诸烦恼法与三界合。从烦恼中出生三界。而彼菩萨具善巧方便故。积集善根缘力与三界合。此即名为诸有善根与烦恼合。以其三界合故。即不复心生诸随烦恼。海意。譬如世间有大长者唯有一子。慈育怜愍深加爱念。时彼童子愚小无智。于秽井边而为戏舞。以幼稚故忽堕井中。尔时其母及彼亲族。俱见其子堕秽井中。见已忧愁竞前观井。深不可测。徒极悲苦。无能为计入其井中。虽痛爱子不能救拔。是时其父知已奔至。见彼童子堕秽井中。临视哀恼苍惶旋转。深爱此子不生厌舍。即设方计入其井中。善为救拔令子得出。海意。当知彼秽井者。即是三界。其子即是一切众生。菩萨观于一切众生如一子想。童子之母及亲族者。即是声闻缘觉乘人。见诸众生堕轮回中。见已虽复心怀忧恼。无有方便而为救拔。彼大长者即是菩萨。而诸菩萨虽以无垢洁白清净之心住无为法。然复和合三界所修之行化度众生。海意。此即菩萨大悲之行。菩萨毕竟自能解脱诸缠缚已。而复于其三有之中示现受生。具善巧方便胜慧所摄。己之烦恼无复有碍。能为一切众生宣说断除烦恼缠缚之法。海意菩萨白佛言。世尊。诸菩萨者难作能作能以无垢洁白清净之心。于轮回中不生厌弃。如其所说甚深之法。如理伺察不住无为。不求果证。佛言。海意。此菩萨者。所修正道与禅支合。所谓般若波罗蜜多。及善巧方便。海意当知。若诸菩萨无垢洁白清净心者。此即般若波罗蜜多。于轮回中不生厌弃。示现受生化度众生。此即善巧方便

复次海意。若诸菩萨于空无相无愿无作无生无起一切法中如理伺察者。此即般若波罗蜜多。若复发起大悲现前之心。不住无为。不求果证。此即善巧方便

复次海意。若诸菩萨善住三世平等法故。即无有少法见种种相。若彼法界平等。即众生界平等。若众生界平等。即涅槃界平等。若涅槃界平等。即法界平等。若能入此法界平等性中。所入即是般若波罗蜜多。若复能入一法界。了知众生界。不证涅槃界。是故不舍众生界。不住于法界。不取于果证。此即善巧方便

复次海意。若布施清净此即是慧。若回向清净即是方便。若持戒忍辱精进禅定清净此即是慧。若回向清净即是方便。以要言之。一切善根清净此即是慧。回向清净即是方便。海意白佛言。世尊。何者是菩萨善根清净。何者是回向清净。何者是慧清净。何者是方便清净。佛言。海意。菩萨善根清净者。为离我人。众生寿者之见。然后积集诸有善根。回向清净者。谓于空无相无愿法中。成熟善根回向菩提。慧清净者。谓于一切众生初后根性智悉了知。方便清净者。善为一切众生如应说法。复次海意。又善根清净者。虽于诸有诸趣示现受生而无依止。然后积集诸有善根。回向清净者。谓离一切声闻缘觉作意。善摄诸乘所有善根。悉用回向大乘法中。慧清净者。普为断除一切烦恼种子习气。方便清净者。谓欲化度诸众生故。先同其事。后为教示大乘之法

复次海意。又善根清净者。所谓菩萨舒其宝手。普施无尽一切受用。回向清净者。谓以一切众生。一切学无学人。一切缘觉。一切菩萨。及一切佛诸有善根。普用收摄入回向中。慧清净者。所谓任持诸佛所说。悉以陀罗尼印印之。其所任持而无坏失。方便清净者。谓以无断辩才。无碍辩才。为诸众生善说无诳之法。令诸众生悉得欢喜

复次海意。又善根清净者。谓于生生之中。常不舍离大菩提心。回向清净者。谓不忘失大菩提心。以诸善根悉用回向于一切智。慧清净者。谓善知安住大菩提心而为根本。方便清净者。谓于菩提心住平等故。为他教示菩提之法

尔时海意菩萨复白佛言。世尊。如我解佛所说义者。诸善巧方便。是菩萨菩提。般若波罗蜜多清净一切处通达。皆是菩提。无有少法非菩提者。何以故。世尊若了一切法平等性。即是菩提。是故诸菩萨勿于菩提生极远想。菩萨于诸法中若六尘境来为障碍尔时应当如实觉了。即是菩提。若诸菩萨如是解者。即得善巧方便清净。及般若波罗蜜多清净

尔时世尊赞海意菩萨言。善哉善哉。如汝所说。菩萨具善巧方便及般若波罗蜜多清净者。于诸法中若六尘境来为障碍。尔时应当如实觉了即是菩提。海意。以是缘故诸菩萨者应如是知

佛说海意菩萨所问净印法门经卷第十四佛说海意菩萨所问净印法门经卷第十五

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次海意。我念过去无量无边阿僧祇无等比劫数之前。彼时有佛出现世间。名无边光照如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。世界名善变化。劫名光味。以何缘故。彼佛如来名无边光照。以彼世尊初坐菩提场。未证一切智。居菩萨位。尔时身放种种色光。是光普遍十方无量阿僧祇出过算数诸佛刹土。皆悉照曜而彼一切佛刹之中所有一切不退转菩萨。及一生补处菩萨。见彼菩萨坐菩提场。见已即各向彼菩萨。散掷妙花。其所掷花。以佛威神力故。皆悉向彼菩萨身聚。而一一花。于彼善变化世界之中。广大积集高七人量。以是缘故。建立彼佛及光味劫如是名字。海意。彼劫之中有十四俱胝如来出现世间。而彼善变化世界。具大威神安隐丰乐。一切天人众多炽盛国土广远。有九十六俱胝那庾多百千大洲。彼一一洲纵广八十四百千由旬。一一百千由旬有八万四千州城。一一州城有八万四千县邑聚落。一一城中各有十俱胝那庾多百千人民而共居止一。一县邑各有八俱胝人民居止。彼世界中人民富盛尚尔许数。何况大威德诸天龙鬼。又彼世界四宝所成。所谓金银琉璃颇胝迦宝。又复彼土随意所念。饮食衣服庄严具等自然充足。又彼人民无我我所。海意。彼无边光照如来应供正等正觉。寿量十中劫有三十六俱胝那庾多百千诸声闻众。一千二百俱胝菩萨摩诃萨众。有一王城名善清净。是彼世尊本所生地。彼佛出王宫已。别止一城其名乐生。而彼乐生大城之中。有转轮圣王。名善净境界。统王三千大千世界七宝具足。所谓轮宝象宝。马宝女宝。摩尼宝。主藏臣宝。主兵臣宝。如是七宝王之受用。海意。彼善净境界王。已发阿耨多罗三藐三菩提心。深心具足。于一切众生起无障碍心。王有八十四俱胝那庾多百千宫嫔婇女。端正殊妙如天女相。是诸宫女。悉发阿耨多罗三藐三菩提心。彼善净境界王。延请世尊无边光照如来及菩萨声闻大众。经二中劫而伸供养。如法清净离诸过失。依沙门法所应受用。衣服饮食病缘医药坐卧具等一切供给。其王为佛世尊别立精舍。清净严洁纵广百千由旬。琉璃珠宝而为其地。七宝墙界重重间作。处处皆用赤旃檀香及乌啰娑旃檀之香间为其柱。巧妙殊特与天宫等。次复安布十千楼阁。命诸菩萨声闻大众次第安止。海意。彼善净境界王。谛奉彼佛清净之法。受持五戒精修梵行。与宫嫔眷属。经二中劫。承事供养彼佛世尊。过二中劫已。其王即与诸眷属俱。诣彼无边光照如来应供。正等正觉所。到已头面礼足。右绕七匝。退住一面

尔时善净境界王。白无边光照如来言。世尊。云何菩萨于大乘中得不随他信云何菩萨虽复趣向最胜之道而无我相。云何菩萨善能安住无动无不动慧。云何菩萨得方便慧清净。云何菩萨得久远观察不断根本。云何菩萨于六尘境界。虽复增长而无放逸。云何菩萨能于甚深义理之中不生惊怖。云何菩萨得名真实菩萨。时彼无边光照如来应供正等正觉。告善净境界王言。大王。谛听谛听。极善作意。今为汝说。大王。有四种法。若诸菩萨能具足者。即得于大乘中不随他信。何等为四。一者从胜解出生故信出世圣法。二者勇猛不退故勤行精进化度众生。三者善观察故起神通智作诸游戏。四者智随知法故于一切法起决择相。大王。如是四法。菩萨若具足者。即得于大乘中不随他信。大王。有四种法。若诸菩萨能具足者。趣向最胜道而不生我相。何等为四。一者不着禅味而心业调畅。二者不着己乐施于他乐。三者成大慈行安住大悲。四者得广大信解。能起最上最胜乐欲。如是四法。菩萨若具足者。即得趣向最胜道而不生我相。大王。有四种法。若诸菩萨能具足者。即得安住无动无不动慧。何等为四。一者内心远离谄诳。二者内心清净具善方便。三者深心方便而不退转。四者深心不舍所行。如是四法。菩萨若具足者。即得善住无动无不动慧。大王。有四种法。若诸菩萨能具足者。得方便慧清净。何等为四。一者虽观一切法无我。而常以其四摄之法化度众生。二者虽知一切法不可宣说。常以音声文字。为诸众生演说法要护持正法。三者虽观诸佛法身。而常信解一切如来功德。成办相好精进无懈。四者虽观一切佛刹空寂。而常严净佛土勤行不息。如是四法。菩萨若具足者。即得方便慧清净。大王。有四种法。若诸菩萨能具足者。即得久远观察根本不断。何等为四。一者能善观察菩提道场。以菩提心不舍离故。二者善观佛智。自智无著故。三者善观转妙法轮。随所闻法皆能为说不懈倦故。四者善观大涅槃法。而不厌离生灭法故。如是四法。菩萨若具足者。即得久远观察根本不断。大王。有四种法。若诸菩萨能具足者。于六尘境界。虽复增长而无放逸。何等为四。一者为转轮圣王化度人民。善观诸行无常。虽复六尘境界增长而无放逸。二者为帝释天主。化诸天众。善观诸行是苦。虽复六尘境界增长而无放逸。三者现作魔王化诸魔众。善观诸法无我。虽复六尘境界增长而无放逸。四者为大梵王化诸梵众。善观涅槃寂静。虽复六尘境界增长而无放逸。如是四法。菩萨若具足者。即于六尘境界。虽复增长而无放逸。大王。有四种法。若诸菩萨能具足者。即于甚深义理不生惊怖。何等为四。一者亲近真实善友。二者于善友所相续无间。开示甚深佛菩提法。三者于如是等甚深经典。乃至多百由旬。亦往听受决择其义。四者如所闻法。起慧推求。但依于义不依于文。如是四法。菩萨若具足者。即于甚深义理不生惊怖。大王。有四种法。若诸菩萨能具足者。即得名为真实菩萨。何等为四一者勤行精进修诸波罗蜜多。二者趣大悲心勤行化度一切众生。三者以精进力。勤行圆满一切佛法。四者能于无量生死之中。勤行摄化不生疲倦。复能积集福智胜行。如是四法。菩萨若具足者。即得名为真实菩萨。海意。彼无边光照如来。说如是等四种法门时。彼会之中有十千俱胝那庾多人。发阿耨多罗三藐三菩提心。八俱胝那庾多百千苾刍。不受诸法漏尽意解。彼王太子妃主宫嫔。皆得柔顺法忍。其善净境界王。得利顺法忍。彼王即时心大欢喜悦怿踊跃。即以王之一切所有诸妙受用。持献彼佛。时彼无边光照如来。告善净境界王言。大王。汝已舍诸所有献佛如来。汝宜于我最上法中净信出家舍于非家。何以故。大王。若于如来最上法中净信出家者。有大威力得大称赞。大王当知。出家菩萨得二十种广大善利。是即圆满彼一切智无上胜利。何等为二十。一者弃舍王之所有富贵受用。得无我我所大利。二者乐出家已而能出离烦恼大利。三者被服袈裟得心无杂染大利。四者于其圣种生欢喜已即能圆具长养大利。五者修行头陀功德断除多欲得离染大利。六者戒蕴清净已生天人中得斯大利。七者不舍菩提心得圆满六波罗蜜多大利。八者居寂静处得离愦闹大利。九者心无爱着得思惟法乐大利。十者修习禅支得心调畅大利。十一者勤求多闻得大慧大利。十二者离诸慢故得大智大利。十三者少求少事故得决择圣法大利。十四者于一切众生心平等故得大慈大利。十五者起解脱一切众生心故得大悲大利。十六者不惜身命故得护持正法大利。十七者心轻安故得神通大利。十八者常念佛故(此下合有一句得大利文梵本脱落)。十九者常所伺察深固法故得无生法忍大利。二十者积集一切胜功德故速成一切智大利。大王。此如是等二十种法。是即出家功德胜利。诸出家菩萨不为难得。是故大王。汝今宜应于最上法中净信出家。海意。时彼世尊。为善净境界王。如应教授。王出家已。其王即舍一切所有。于王胜福乃至厌离。须发自落袈裟着身成苾刍相。其王于彼世尊法中。净信出家已。王诸宫嫔亦随出家。太子妃主而亦出家。乃至国境之中所化庶民。有九十九俱胝那庾多百千人众。悉随出家皆发精进勤求善法。海意。汝且观是诸佛诚言。能生净信。一切福行与诸众生而为依止。彼善净境界王既出家已。后复与诸出家眷属。同诣无边光照如来所。到已作礼而白佛言。唯愿世尊。教授于我。当如佛言坚固修行。令我于诸国土之中不空受食

尔时彼佛告善净境界苾刍。汝从今已往。名字苾刍。堕苾刍众。应当于自境界清净所作。及自境界深固伺察。随所伺察如理而住。何名自境界。谓六尘境来为障碍。汝于尔时。应当如实现前觉了谛观菩提。应于菩提起深远想。勿起近想。时善净境界苾刍。承彼世尊如所教授已。深固志意不生放逸。求离烦恼如理修行。于自境界如实伺察。复云何是深固伺察。所谓眼境界即空境界。空境界即一切众生境界。一切众生境界空境界即佛境界。如是耳鼻舌身意境界即空境界。空境界即一切众生境界。一切众生境界。空境界即佛境界。又眼境界即无相境界。无相境界即一切众生境界。一切众生境界无相境界即佛境界。乃至意境界即无相境界。无相境界即一切众生境界。一切众生境界无相境界即佛境界。又眼境界即无愿境界无作境界无生无起境界。无起境界即一切众生境界。一切众生境界无起境界即佛境界。海意。彼善净境界苾刍。闻所说已。即入是法中。乃得身心堪任调畅。是故能修欲勤心慧四种神足。不久能起五种神通。一心专注而不放逸。得入总摄一切言义陀罗尼门

尔时佛告海意菩萨摩诃萨言。汝今应当勿生疑念。彼时善净境界苾刍。舍转轮王最胜之位。于佛法中出家修道者。岂异人乎即汝身是。彼时随王出家九十九俱胝那庾多百千苾刍者。岂异人乎即此会中随汝海意同来听法菩萨众是。当佛世尊说是往昔因缘时。此大会中有一万八千人。发阿耨多罗三藐三菩提心。八千菩萨得无生法忍

佛说海意菩萨所问净印法门经卷第十五佛说海意菩萨所问净印法门经卷第十六

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时世尊。告海意菩萨言。海意。若诸菩萨欲证阿耨多罗三藐三菩提者。应当修学。汝等大士诸所施作。菩萨不应但修捷语利辩。应当如说亦然能行。云何是菩萨如说不能行。海意。谓若菩萨虽具辩慧。而不积集诸善菩提分法。而作是言。我当成佛已。普召一切众生。广行法施。令诸众生得法满足。然此菩萨。不能勤行修习多闻。亦不积集诸善菩提分法。虚诳一切众生。此即是为如说不能行。海意。若有菩萨作如是言。我当成佛已。普召一切众生。广行法施。令诸众生得法满足。时彼菩萨而能勤行修习多闻。亦复积集诸善菩提分法。此即是为如说能行

海意。又复如说不能行者。譬如世间若王若臣普召国中一切人民。欲饷美膳悉令饱满。而不备办所须饮食。虚诳国中一切人民。是诸人众既误所食。各于异处求以食之。心怀恚恨呵责而出。海意。菩萨亦复如是。愿为一切众生未度者令度。未解脱者令得解脱。未安隐者令得安隐。未涅槃者令至涅槃。而彼菩萨虽有是愿而不勤修多闻。亦不积集诸善菩提分法。此即是为如说不能行。彼菩萨者。虚诳天人世间。贤圣呵毁亦复嫌弃。安立诤讼而不能为大智之主。不能毕竟圆满誓愿。海意。若欲发起最极难得最上大智。应当于彼无上大乘不生懈退。是故当知。菩萨不应但以语言虚诳一切天人世间

复次海意。诸菩萨者。或有人来求请说法时。彼菩萨即当随言。我为汝说如是之法。以如是法化度于汝。乃至弃舍己身亦不吝惜。而是菩萨即不虚诳一切众生。如是因缘汝应当知。复次海意。我念过去无量无数阿僧祇劫之前。有一师子兽王。名不坏身。处于深山岩窟之中。常行慈心。视护一切众生。但以草叶花果而为所食。时彼岩中有二猕猴雄雌共居。后生二子。欲有陀行。乃以其子付托兽王而为守护。付已他行。有一鹫王名曰利见。飞处空中忽然至地。搏取猴子旋转于空。时师子王见其被搏。即向鹫王。说伽陀曰

  奇哉鹫王汝知我　　放舍此二猕猴子
  我此守护令无畏　　与彼归趣勿生害

尔时鹫王。即说伽陀答师子王曰

  兽王若能舍己身　　我当舍此二猴子
  我处空中此为食　　无食居空何所为

师子兽王。又复答曰

  我宁舍身与汝食　　汝今速放此二猴
  我愿视护至菩提　　智者应无虚妄语

于是师子兽王说伽陀已。深心坚固而无虚妄。将舍其身

尔时鹫王见是事已。叹未曾有。说伽陀曰

  世间性命为滋长　　能舍己身为护陀
  我今舍此二猴子　　令汝久住修法行

海意。汝今当知。彼时不坏身师子王者。勿起异见即我身是。雄猕猴者大迦叶是。雌猕猴者贤护苾刍尼是。二猕猴子者。今罗睺罗及阿难是。利见鹫王者。善爱苾刍是。以是当知。菩萨摩诃萨宁舍己身。终不弃舍为他作护。此即圆满如说能行

复次海意。又云何是如说能行显明之相。所谓菩萨如说布施。即当弃舍一切所有。如所显示此名能行。菩萨如说持戒。即当成办一切戒学及头陀功德。如所显示此名能行。菩萨如说忍辱。即于忿恚诸有过失皆悉断除如所显示此名能行。菩萨如说精进。即当于诸善法勤求修习。如所显示此名能行。菩萨如说禅定即当修诸禅定解脱三摩地三摩钵底。如所显示此名能行。菩萨如说智慧。即当分别一切章句。起善巧智辩才决定。如所显示此名能行。以要言之。乃至菩萨如说断一切不善法。集一切善法。即当断除一切不善之法。勤求修习一切善法。如所显示此名能行。菩萨如说质直。即当无诸谄诳虚妄此名能行。如说方便。即当开示方便之门此名能行。如说勤勇。即当策勤离诸懈退此名能行。如说深心坚固。即当离着趣向胜道此名能行。如说誓愿。即当毕竟圆满诸愿此名能行。如说闻持。即当如闻而善修习此名能行。如说积集善行。即当身心俱无懈倦此名能行如说离慢。即当圆满胜智。此名能行。如说积集戒行。即当于戒无所缺漏。此名能行。如说初发心位。即当成办菩萨胜行此名能行。如说无生法忍之位。即当进趣不退转地此名能行。如说一生补处之位。即当进向坐菩提场此名能行。如说坚固积集。即当现证一切智果此名能行。如说转妙法轮。即当于三宝种使令不断此名能行。海意。如是等法。是为菩萨如说能行。当佛世尊说是如说能行法时。会中有五千菩萨。悉得无生法忍

尔时有一菩萨。名莲花庄严。前白佛言。希有世尊。诸佛如来。以如说能行故。即得一切最上佛法。世尊。如佛所言修行。是即如说能行。佛言。善男子。汝知修行法不。菩萨白佛言。我知世尊。佛言。善男子。随汝乐说修行之法。汝今当说。菩萨白佛言。世尊。修行者。如佛所说。即一切法平等。平等知已。于正位中。以善巧智而不取证三摩钵底。此为菩萨正所修行

山王菩萨言。世尊。我亦乐说修行之法。佛言。善男子。随汝意说。菩萨白佛言。世尊。无所修是修行。何以故。菩萨观一切法都无所得。若有所修而非修行。此即是为正修行

功德光照王菩萨言。世尊。心若随流乃识有所转。何名修行。若菩萨识心于一切法无住。彼即无有少法可住。若无少法可住。彼即是为正修行

高炬王菩萨言。世尊。无所乐是为修行。无所厌是为修行。世尊。菩萨于一切法中。无高无下。是故无有少法而可乐厌。此即是为正修行

日藏菩萨言。世尊。若有所依即有所转。若无所依即无所转。菩萨以无依止无动转故。即于一切法无所动摇。此即是为正修行

勇猛心菩萨言。世尊。心者世间所行。世间驰流。若菩萨于一切心得无心者。即无所思亦无分别。此即是为正修行

爱见菩萨言。世尊。如佛所说一切所知皆悉是苦。若菩萨于一切所知得醒悟者。即无所知亦无所取。是故不入灭受想定。不舍众生不失大悲。此即是为正修行

香象王菩萨言。世尊。愚夫异生荷诸重担。起于五蕴深重之见。若菩萨了知五蕴得轻利者。即舍诸重担。复能为诸愚夫。宣说弃置五蕴重担之法。是故无有少法起真实想。了知诸法无生无灭。此即是为正修行

持世菩萨言。世尊。正所行是修行。非邪恶所行。菩萨应当修正方便。云何是正方便。谓一切法平等性。智虚空等故。此即是为正修行

坚固意菩萨言。世尊。若菩萨有慧方便智。即无生而生。无起而起。于生灭中亦无所住。此即是为正修行

吉祥峰王菩萨言。世尊。若菩萨观一切法自性寂灭。即不弃舍大悲之铠。见诸勤力不虚果利此即是为正修行

无碍光菩萨言。世尊。若有所行之迹。是为魔事。若为魔事即非修行。若无所行亦无所住。而彼诸魔伺不得便。乃能超越诸恶魔道。此即菩萨真实修行

勤精进菩萨言。世尊。若有少法乐欲成办。彼即虚其勤力。以一切法无所成办故。是中若有智及所知。即非无意。此即是为正修行

灭恶趣菩萨言。世尊。若有种类分别所行。何名修行。无种类。无分别。是为修行。彼无种类无分别。即心自性。若能了知心自性者。此即是为真实修行

善思而思菩萨言。世尊。菩萨随入一切众生心。彼随入已。即了一切众生心而无心。此中无心智所入故。此即是为正修行

寂意菩萨言。世尊。近寂是为修行。非近寂是为修行。菩萨于其大寂遍寂近寂诸心所缘。若增若减悉无造作。离增减故平等觉了。此即是为正修行

导师菩萨言。世尊。菩萨发起善根。是正修行。若有所成。即非发起善根。何以故。菩萨发起福行。即是发起智行。福平等故即智平等。智平等故即福平等。福智平等故即菩提平等。菩提平等故即一切法平等。此即是为正修行

嬉戏王菩萨言。世尊。一切法无分别。是为修行。若菩萨了知一切法法界普摄已。即无有少法若离若合。此即是为正修行

善思义菩萨言。世尊。诸法依义不依于文。若菩萨解了义故。即于八万四千法蕴。慧能受持读诵解说。然于真实不可说义中。无所动转。此即是为正修行

清净意菩萨言。世尊。深固心是为修行。菩萨深心具足。即非语言记说。最上所得。但修真实正道。观彼真实道亦无去无来。此即是为正修行

毕竟无垢思惟菩萨言。世尊。如有垢之衣濯令清洁。无垢之衣其何涤邪。菩萨亦复如是。不以本来清净之心。如实伺察使令清净。若复菩萨。一切心垢烦恼本不转者。彼即清净。若如是清净。此即是为真实修行

海意菩萨言。世尊。菩萨为善知识所摄受者。即少历辛勤能成正行。何以故。若菩萨力。不能超越诸魔事者。当知彼为诸恶知识之所摄受。若力能超越诸魔事者。当知彼为诸善知识之所摄受。世尊。是故菩萨若欲超越诸魔事者。应当亲近承事诸善知识。菩萨为善知识所摄受故。即少历辛勤能成正行

尔时世尊。告海意菩萨言。善男子。汝知魔事不。海意白佛言。世尊。我知魔事。佛言海意。随汝意说。令诸菩萨闻已。即能超越摧伏诸魔外道。速证阿耨多罗三藐三菩提果。于是海意菩萨而白佛言。如世尊敕当说魔事。唯愿世尊。威神建立。世尊。所谓魔事。有十二种。何等十二

一者菩萨行布施波罗蜜多时。以非爱物而行惠舍。其心乐欲。以可爱物而行惠舍。心不乐欲。人不乐之物而固与之。人所乐之物而不与之。于所施物起种种想。于所与人起种种想。此为菩萨行布施时第一魔事

又复世尊菩萨行持戒波罗蜜多时。若见彼于善法戒行律范轨式。而能具足。乃至小罪犹怀大惧。净命自资坚持戒行。诸沙门婆罗门。即当亲近尊重。见破戒人呵毁恚怒。于彼之前。自恃戒德毁谤于他。此为菩萨持戒之时第二魔事

又复世尊。菩萨行忍辱波罗蜜多时。欲成忍行。身虽能忍语不能忍。心生嗔恚。见有力人于彼即忍。见劣弱人于彼不忍。复于有力人前显示忍力。于劣弱人前现嗔恚相。彼如是即忍。彼如是不忍。何等处可忍。何等处不忍。若行忍处起憍倨心。于不忍处不速忏悔。此为菩萨行忍辱时第三魔事

又复世尊。菩萨行精进波罗蜜多时。发起精进。化度声闻缘觉乘人。亦复化度大乘中人。但为声闻缘觉乘人。相续说法。返以大乘之法化诸愚人(此下据梵本标列文义次第于海意菩萨说十二种魔事中止有上三段半少下八段半于佛说十种破魔法门中止有下四段阙上六段既梵本脱落无以补之)。此为第六破魔法门

复次海意。一切法自性无染。以无染相。化度染污众生。此为第七破魔法门

复次海意。一切法自性无生无起。以无生无起相。为诸众生宣说断除生老病死之法。此为第八破魔法门

复次海意。诸法自性。同于一味而无差别。以同一味无差别相。建立三乘各为说法。令诸众生亦不舍离大乘意乐此为第九破魔法门

复次海意。若菩萨心意识虽无所依着。而常不忘失大菩提心。虽离诸发起。然不舍离解脱一切众生之心。虽超越诸行。而亦成办菩萨胜行。此为第十破魔法门。海意。如是十种破魔法门。若诸菩萨勤行修习者。即当超越一切魔事

佛说海意菩萨所问净印法门经卷第十六佛说海意菩萨所问净印法门经卷第十七

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时世尊。说是破魔法门时。一切魔宫皆悉暗瞑。六种震动。如佛初坐菩提道场。未成正觉居菩萨位。尔时眉间放大光明。而诸魔宫亦皆暗瞑。同于今日。等无有异。是时诸恶魔众。见斯广大变异之相。速疾严整于四兵众。犹如往昔诣菩提场所庄严相。今者亦然。领四兵众。广三十六由旬。皆悉遍满。来至世尊大宝庄严大集会所。以佛世尊威神力故。而悉不能还复魔宫。又佛神力。魔众来时。或见余诸刹土有佛世尊。与不退转诸菩萨众。化度众生。及断诸有结证阿罗汉者。或有正见具足补特伽罗

尔时世尊。告海意菩萨言。海意。汝今见此诸恶魔众如是庄严来众会不。海意白佛言。世尊。唯然已见。佛言海意。是诸魔众至此会中。于我正法欲兴难事。而汝今者当何所为。海意白言。世尊。我今以此恶魔之众。置于他方诸乐庄严世界之中

尔时会中尊者舍利子。即白海意菩萨言。善哉大士。诸乐庄严世界。为在何所。其佛说法复何名字。海意菩萨言。尊者舍利子。东方去此佛刹。过十二殑伽沙数等国土。有世界名诸乐庄严。其土有佛。号曰摧魔如来应供正等正觉。见在说法。以何缘故而此世界名诸乐庄严。尊者。谓彼世界有诸乐事诸功德事诸庄严事。若广宣说彼胜妙事。纵一劫中说不能尽。以是缘故。其世界名诸乐庄严。又其佛号摧魔如来应供正等正觉者。谓彼世尊初坐菩提道场居菩萨位。未证一切智时。身放光明普照诸魔。其光所照。彼魔界中百俱胝魔众。而一一魔各有千俱胝眷属。是时诸魔诣菩萨所。欲于菩萨兴诸难事。而此菩萨威神力故。其魔不能作诸障难。即时各发希有之心。向彼菩萨归依顶礼。菩萨即为如应说法。魔闻法已深心清净。即发阿耨多罗三藐三菩提心。其后彼佛证道果已。是故立名摧魔如来。又复彼佛。于过去世庄严劫中。居菩萨位时。名降伏魔。今此贤劫之中。得菩提已。能令诸魔发菩提心而为承事。其佛但为诸菩萨众。唯说最上大乘之法。无复二乘之名。尊者。是故我今置此魔众。往彼诸乐庄严世界之中。置于彼已。使诸魔众不复兴于魔之事业。于彼佛刹。与其降伏魔菩萨。同发菩提心已。圆满菩提分法。尔时诸恶魔众闻是语已。生大惊怖身毛悚竖。即欲离彼众会。以佛威神力不能去。又不能隐蔽其身而极增惧。即各向佛归依顶礼。作是白言。救我世尊。救我善逝。无令海意菩萨置我于彼世界之中

尔时佛告诸魔众言。汝等诸魔勿生惊怖。菩萨大士。于诸众生不起娆害。汝等应当自于海意菩萨之前求忍悔谢。必当为汝善作救护。尔时魔众即各合掌。向海意菩萨稽首白言。我今悔谢大士。忍可。勿置我于诸乐庄严世界之中。如我所作。不复第二往彼众会。海意菩萨言。诸魔当知。我今于汝无复可忍。何以故。菩萨于一切众生。究竟常忍。汝等诸魔今宜往彼诸乐庄严世界之中。观彼世界众庄严事。彼摧魔如来。于汝魔众无所娆害。尔时海意菩萨。即舒右臂金色晃耀。安于魔顶而为加持。作如是言。若法真实。此真实语。诸菩萨者。于法无悭亦无秘吝。以此真实语故。如我所有如是神力。令此魔众皆悉获得。海意菩萨作是语已。而诸魔众即得自在神力具足。尔时此三千大千世界六种震动。而诸魔众。于此会中隐身不现。于须臾顷。到彼诸乐庄严世界之中。皆是海意菩萨加持力故。是时魔众到彼国已。即诣摧魔如来应供正等正觉所。头面着地礼佛双足。右绕七匝退住一面。于是彼佛刹中有一菩萨。名降伏魔。见是相已。白其佛言。世尊。今此劣弱鲜有威光。状貌异常人可恶者。从何所来。其佛答言。善男子。西方去此佛刹。过十二殑伽沙数等世界。有一世界名曰娑婆。彼佛世尊号释迦牟尼如来应供正等正觉。今现在彼大宝庄严道场。广大宣说大集会正法。复有十方世界无量阿僧祇出过算数诸大菩萨。皆悉来集听受正法。而彼会中有一菩萨。名曰海意。善被不可思议大坚固铠。而能请问释迦牟尼如来如是正法。当说法时有恶魔众。至彼会中欲兴难事。于是海意菩萨大士。置其魔众而来至此。为欲化度作成办故

尔时降伏魔菩萨。白诸魔言。我等今者与汝诸魔。同发阿耨多罗三藐三菩提心。何以故。我昔亦尝处于魔类。于诸众生种善根时。而生障难。其后于此如来法中。发阿耨多罗三藐三菩提心。是故今时汝等诸魔。宜应速发阿耨多罗三藐三菩提心。尔时诸魔深心坚固。各发阿耨多罗三藐三菩提心。既发心已咸作是言。我等已发阿耨多罗三藐三菩提心。永不复作魔之事业。于是降伏魔菩萨。即命其魔。同处于彼众宝庄严师子之座。而劝请言。善男子。云何是彼释迦牟尼如来所说大集会正法。随汝所乐今当演说

尔时诸魔。承海意菩萨威神之力所加持故。寻即处于师子之座。从其口门及诸毛孔出清净音。犹如释迦牟尼如来所说大集会正法。如是文字如是章句。一一宣说满足无遗。于其中间亦无增减。时降伏魔菩萨。于其魔所。得闻如是大集会正法已。生希有心。白彼佛言。世尊。我今欲见娑婆世界及释迦牟尼如来。又欲见彼海意菩萨并十方世界所来集会诸大菩萨摩诃萨众。时彼世界摧魔如来。即于眉间放大光明。名曰普现一切色相。是光遍照西方去此十二殑伽沙数等诸佛刹土乃至娑婆世界。广大明耀相续不断。彼诸乐庄严世界诸菩萨众。皆见释迦牟尼如来在于大宝庄严道场之中。处百千种色相严饰宝师子座。为十方世界诸来集会大菩萨众。广大宣说大集会正法。又复见此娑婆世界大水盈满。犹如大海。普观是中悉无障碍。又见十方世界所来集会诸大菩萨。各各坐于众宝庄严大莲花上。听受正法。其花纵广一俱卢舍。而诸大士见是相已。生欢喜心适悦庆快。即以妙花。遥向释迦牟尼如来散掷供养。所散之花。以佛世尊威神力故。悉于释迦牟尼如来顶上。结成广大殊妙花盖。时此佛会。一切大众见是花盖于佛顶上乘空而住。生希有心。俱白佛言。世尊。今此花盖从何所来。佛言。诸仁者。而此花盖。是彼诸乐庄严世界之中菩萨大众。遥向此会散掷妙花而伸供养。而此众会。咸白佛言。世尊。我等乐欲见彼诸乐庄严世界及彼世尊摧魔如来。亦欲见此所往诸魔之众并其世界所施作事。

尔时世尊。知其众会之所乐欲。即告海意菩萨言。善男子。今此众会乐见诸乐庄严世界。亦欲见彼摧魔如来。汝可现之使诸大众咸悉瞻奉。于是海意菩萨。承佛教敕。即时于其足十指间。放十千光明。其光普照东方去此十二殑伽沙数等诸佛刹土乃至诸乐庄严世界。广大明耀相续不断。时此会中一切大众。悉见诸乐庄严世界。及得见彼摧魔如来。又见诸魔在彼佛会。处于法座。广为众说大集会正法。此会大众见是相已。生希有心。各各从于莲花座起。遥向摧魔如来合掌顶礼。各以妙花散掷供养。所散之花。以佛世尊威神力故。于彼摧魔如来顶上。结成广大妙花楼阁

尔时魔众。白彼摧魔如来言。世尊。我等今欲还复娑婆世界释迦牟尼佛所。彼佛告言。诸善男子。汝可还复。今正是时。于是诸魔头面着地。礼彼佛足。右绕七匝。以海意菩萨威神力故。于彼刹中隐而不现。经须臾顷还于娑婆世界。到已头面礼释迦牟尼佛足。右绕七匝。退住一面摄心谛意恭敬归向

尔时尊者舍利子。告诸魔言。诸仁者。汝等见彼诸乐庄严世界不。诸魔答言。我等已见。尊者彼土希有清净可爱。是为清净无垢最上所居。我等见已。皆发阿耨多罗三藐三菩提心。尊者舍利子言。诸仁者。汝等已发阿耨多罗三藐三菩提心。不应复作诸魔事业。魔言不也。尊者。若有善住深固心者。诸菩萨众乃能施作诸魔事业。何以故。如诸菩萨善住深固心者。即有力能随其所应发起魔事。以是缘故。尊者当知。诸有菩萨施作魔事。此说即是佛之事业。非魔事业

尔时诸魔。于此佛刹现神变已。此众会中。有二万人发阿耨多罗三藐三菩提心。于魔众中。复有一万天子。发阿耨多罗三藐三菩提心。异口同音作如是言。世尊。我等悉愿生彼诸乐庄严世界之中作是语已。于是释迦牟尼如来。即记之曰。汝等当生彼佛刹中

尔时海意菩萨复白佛言。世尊。诸佛如来菩提之法。诸魔外道多生障难。惟愿世尊威神建立。令此正法久住世间。复于如是甚深经典摄受护持。世尊若此经典。得佛如来所加持故而不隐没。受持读诵广大流布。令诸魔众伺不得便。佛告海意菩萨言。海意。我今建立此之正法。若有众生欲发精进。种诸善根为作成熟。化度之者。当于如是甚深经典。如法受持为他演说

复次佛告海意菩萨言。汝今谛听极善作意。今为汝说。呼召四大天王秘密章句。而此章句速能召集四大天王。有此正法之处来为作护。亦当摄护其说法师。尔时世尊。即说陀罗尼曰

怛[寧*也](切身)佗(引一句)三弥(引二)三摩散底(三)萨啰尼(引四)娑(引)啰嚩底(五)达泥(引六)达那嚩底(七)度度弥(引八)度度摩底(九)阿(引)缚哩多(二合)泥(引十)阿末里(引十一)尾末里(引十二)尾啰[口*爾](引十三)葛葛哩(引十四)葛葛尼(引十五)虎鲁(十六)虎鲁嚩底(十七)虎鲁散提(十八)儞哩伽(二合引)萨儞(十九)阿(引)嚩致(引二十)尾嚩致(引二十一)末末枯末底(二十二)摩(引)啰[口*爾]帝(引二十三)尾戍提(引二十四)尾戍驮嚩底(二十五)弥弥里(引二十六)末努(引)贺啰莎(引)贺(引二十七)

海意。如是秘密章句。速能呼召四大天王来护持此甚深正法。及能摄护其说法师。又此章句。能令法师善说此法。如所作已谛观四方起大慈心。是时四大天王以此秘密章句所呼召故。皆来摄受诸说法者

尔时四大天王现在此会。即从座起前诣佛所。合掌顶礼而白佛言。世尊。若有众生。于此最上甚深正法。真实了知。而能为他如理宣说者。我等四王并诸眷属。常来营卫护持正法。复当摄护其说法师。令无障难。及无衰恼

佛说海意菩萨所问净印法门经卷第十七佛说海意菩萨所问净印法门经卷第十八

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次海意。我今为汝宣说呼召帝释天主秘密章句。而此章句。速能呼召帝释天主。来护正法。尔时世尊。即说陀罗尼曰

怛[寧*也](切身)佗(引一句)惹曳(引二)惹野嚩底(三)阿胝(引四)摩酤哩(引五)悉驮末底(六)戌毗(引)扇底葛哩(引七)那祢(引)儞(引八)难(引)帝(引九)难(引)多末底(十)怛哩葛(二合)哩(引十一)叉曳(引十二)叉野目契(引十三)阿嚩吒儞(十四)尾嚩吒儞(十五)波哩嚩吒儞(十六)波哩砌(引)祢(引十七)悉蜜哩(三合)底(十八)悉蜜哩(三合)底散提(十九)阿(引)誐蹉憍(引)尸迦儞哩[口*爾](二合)多(引二十)阿苏啰(引)惹炀底祢(引)嚩(引二十一)三摩踰(引)帝(引)阿(引)半努(引二十二)达哩摩(二合)怛哩[口*爾](二合)睹(引)啰摩(引)呬(二十三)莎悉爹(二合)野曩部(引)多(引)喃(引)摩(引)啰叉(引)达哩摩(二合)左(引)哩赧(引二十四)

海意。如是秘密章句。而能呼召帝释天主。有此正法之处。来为作护。及能摄护其说法师。而彼法师。应当以此秘密章句。作持诵已。洁净身心。依法沐浴。着新净衣。处师子座。向于东方散掷妙花。祈求诸佛。愿赐摄受。于诸众生起大悲念。虔想帝释天主哀愍。故来为我安布听法之众。令其严肃。复令此陀罗尼文句和合。如是等事现前所作。若彼法师。内心清净戒行洁白。即能令其帝释天主来为摄受。安布众会。和合文句。善作加护。尔时帝释天主现在此会。即从座起前白佛言。如世尊敕。于后末世。若有法师而能受持此正法者。我当往彼。为其安布众会。和合文句。而作加护又此正法所在之处。为其摄受。令法久住。世尊。又此正法于后末世。我当为彼三十三天诸天子众。常广宣说。何以故。今此正法。即是过去未来现在诸佛世尊菩提之法。佛所赞故。又复我于过去未来现在诸佛世尊菩提之法。起尊重已。是故我当说此正法。尔时世尊。赞帝释天主言。善哉善哉。憍尸迦。汝能作师子吼。发如是言。于后末世护持正法。如汝所言应如是行。又憍尸迦。以此正法摄受力故。能令诸天随所愿求常得最胜。阿修罗众威光退失

复次海意。我今为汝宣说摄伏诸魔天众秘密章句。而此章句。速能摄伏诸魔天众。来护正法。尔时世尊。即说陀罗尼曰

怛[寧*也](切身)佗(引一句)设弥(引二)设摩嚩底(三)设弥多设讫啰(二合四)盎酤哩(引五)[牟*含]酤哩(引六)摩(引)啰[口*爾]帝(引七)葛啰(引)腻(引八)枳(引)踰(引)哩(九)帝(引)野啭底(十)乌路(引)野儞(十一)尾设姹(十二)儞哩摩(二合)梨(引十三)摩罗(引)钵那曳(引十四)枯枯哩(引十五)珂誐(十六)誐啰(二合)细(引十七)誐啰(二合)萨泥(引十八)乌目契(引十九)钵啰(引)目契(引二十)阿(引)目契(引二十一)设弥多(引)儞萨哩嚩(二合)誐啰(二合)贺满驮那儞(二十二)儞屹哩(二合)系(引)多萨哩嚩(二合)波啰钵啰(二合)嚩(引)祢那(二十三)尾目讫多(二合引)摩(引)啰播(引)舍(引二十四)塞陀(二合引)必多(引)没驮母捺啰(二合引二十五)阿耨捺伽(二合引)致多(引)萨哩嚩(二合)摩(引)赖(二十六)苏左哩多钵哩戍[亭*夜](切身引二十七)尾誐蹉睹萨哩啭(二合)摩(引)啰葛哩摩(二合引)尼(二十八)

海意。如是秘密章句。而能摄伏诸魔天众。复能消除一切烦恼。彼说法师。以此秘密章句作持诵已。处于法座。普观众会悉住道场。广运无量大慈之心。当于己身起医王想。法如药想。于听法众起病人想。于佛如来起正士想。法眼不失起久住想。如是等事。以此秘密章句加持力故。现前施作。广为一切如应说法。是时周匝百由旬内诸魔天众。悉不能来作破坏事。设复诸魔至法会者。亦复不能作诸障难

尔时诸魔天众现在此会。即从座起前白佛言。世尊。我今见此海意菩萨大士。以威神力加持我故。置我于彼诸乐庄严世界之中。世尊。我今最初。已悉弃舍诸魔事业。是故我等于此正法常当护持。后末世中。若城邑聚落若僧坊中。有人宣说此正法者。我等往彼离诸慢心。恭敬尊重专注听受。尔时世尊。赞诸魔言。善哉善哉。汝等诸魔而能尊重如是正法。最先已舍诸魔事业。汝等今于如是法中有所获得。此由海意菩萨大士神力所致。复次海意。我今为汝宣说呼召娑婆界主大梵天王秘密章句。而此章句。速能呼召大梵天王。来法师所当为作护。尔时世尊。即说陀罗尼曰

怛[寧*也](切身)佗(引一句)昧怛啰野(三合引)哥(引)哩(引二)葛鲁拏(引)哥(引)哩(引三)母祢多(引)哥(引)哩(引四)乌闭(引)叉(引)哥(引)哩(引五)没驮(引)哥(引)哩(引六)达哩摩(二合引)哥(引)哩(引七)僧伽(引)哥(引)哩(引八)苏讫哩(二合)多尾左曳(引九)摩贺(引)尾多(引)泥(引十)儞瑟波(二合)哩(引)那只(引十一)乌惹钵底(十二)乌儒(仁祖切)誐弥(引十三)达哩摩(二合)那捺儞(十四)萨爹钵啰(二合)底瑟姹(二合引)那(十五)乌波钵底尾戍提(引十六)莎唧睹钵设弥(引十七)咩嚩路(引)葛野没啰(二合)贺摩(二合)末踰(二合)底瑟姹(二合十八)三摩(引)地阿(引)吠(引)叉(十九)达哩摩(二合)左啰赧酤噜(二十)萨达哩摩(二合)波哩誐啰(二合)[亢*欠]讫哩(二合)多摩耨播(引)罗野(二十一)没驮泥帝零(二合)摩(引)咩嚩亲那(二十二)娑摩(二合)啰多达哩摩(二合)作葛啰(二合)钵啰(二合)嚩哩多(二合)喃酤噜(二十三)萨埵(引)尾输(引)达喃钵啰(二)底屹哩(二合)贺(引)拏(二十四)达哩摩(二合)那誐啰播(引)罗(引)担(引二十五)没驮(引)提瑟姹(二合引)喃摩(引)尾酤(引)钵野(二十六)

海意。如是秘密章句。而能呼召大梵天王。其说法师以此秘密章句作持诵已。应当依止梵行。住无碍心。隐密诸根。善护诸念。所言决定。于其身业善令清净。于其语业真实摄护。善固心慧。善修忍行。善净戒蕴。善发精进之力。善持多闻谛。善观想令心调畅。极利慧根。善修正行。善护菩提心。善修慈观。安立大悲。普令众生毕竟解脱一切苦恼。普令众生获得妙乐。其说法师起是心已。当处师子之座。祈求大梵天王。愿垂摄受。然后如应为佗说法。即时大梵天王与诸梵众。来法师所而为护持。又复海意。其说法师应当觉知。大梵天王至法会时。有诸善相。所谓一切众会咸起慈心。或复众会诸根无缺。或复互相安住菩提法中。或复爱乐法及法师。起尊重想。或离诸染污。或专注一心离散乱意。或复系念于诸善法。或摄敛诸念止绝外闻。谛意听法。或于法师所。昔未曾说。昔未曾闻诸妙法门。闻已能说。若有如是等诸相现时。当知即是大梵天王来至法会

尔时大梵天王现在此会。即从座起前白佛言。世尊。在在处处若复有人宣说如是甚深正法者。我居梵界。虽有无量禅定之乐。悉能弃置。即当往彼说法师所为作加护。世尊加护之法。有其八种。何等为八。一者加护其念。令彼如所闻法而不忘失。二者加护其慧。令彼于甚深法不相违背。三者加护其行。令彼于义皆悉解了。四者加护辩才。令彼断诸疑惑。五者加护记说。令彼一切语言音声闻者皆喜。六者加护化度之法。令彼超胜一切众会。七者加护现法光明令无暗钝。八者加护得出离门。令其依法修证。世尊。我以如是八法。善作加护其说法师。而复我等于法师所。密常营卫令法久住。诸魔怨诤咸悉除灭。此等皆是如来威神之所建立。令其正法广大流布。尔时海意菩萨复白佛言。世尊。今此正法。惟愿世尊威神建立。使令久住。于佛如来入涅槃后末世之中。若有深种善根诸众生等。令得如是甚深经典。受于手中。或安箧笥展转流布令不隐没。尔时世尊。受海意菩萨伸劝请已。即于眉间放众色光。其光遍照此三千大千世界。广大明耀。而此三千大千世界之中。一切药草树林砂石如是种类。蒙光照触。皆悉变成如来形像。所变之像。皆于大宝庄严道场之中而为供养。以佛威神所建立故。其所变化如来之像。即时各各异口同音作如是言。世尊释迦牟尼如来。威神建立此正法故。即彼十方一切如来。亦以威神共所建立。若彼诸佛威神建立故。即彼诸魔不能作其障难。世尊。正使魔众其数犹如殑伽沙等。威势增强尽其勇力。毕竟不能于此正法而兴难事。所以者何。假使大地分裂破坏。一切大海而悉枯涸。诸须弥山碎若微尘。风可系缚。日月坠地。空现色像。火中得水。水中得火。四大种中各有异性。一切众生而同一心。虚空与地二事相合。假使若有如是等事。而亦不能于佛如来加持力中。而有少法可动可转

尔时世尊。即举右手。置于尊者阿难顶上。而告之言。阿难。汝当受持此之正法。于后末世广宣流布。令得受持读诵演说。使佛正法久住世间

尔时海意菩萨白佛言。世尊。见何义故。乃以如是甚深正法。付嘱阿难苾刍。而阿难者具分限智。此会中有诸大菩萨。念慧深广犹如大海莫知渊际。此诸菩萨不付嘱邪。佛言海意。非彼阿难己之慧力。而能受持如是正法。皆由如来威神建立。汝今当知。于后末世有诸众生。于阿难所。听受如是甚深正法。闻已信乐。生大欢喜。发希有心应作是言。皆是如来不可思议威神建立。声闻之人。乃能如是受持甚深广大经典。此即如来威神加持力故。时众会中。或有天人作是思念。彼海意菩萨。念总持力岂有间邪。何故世尊。但说阿难多闻第一

尔时尊者大迦叶。知众有疑。观察大会。前白佛言。世尊。海意菩萨念总持力岂有间邪。何故世尊。但说阿难多闻第一。佛言迦叶。假使殑伽沙数等佛刹土中。摄聚众生皆悉遍满。于汝意云何。彼众生界宁为多不。迦叶白佛言。甚多世尊。甚多善逝佛言迦叶。正使如是诸众生等。无前无后一时皆得人。身。一一皆具念总持力。悉与尊者阿难等无有异。若以如上诸众生等念总持力。比海意菩萨念总持力。百分不及一。乃至乌波尼杀昙分亦不及一。迦叶。此海意菩萨。能以十方诸佛世尊所说之法。皆悉任持而无障碍。非于一佛二佛所说之法无障碍故。譬如天雨入大海中。非但容受一渧二渧而无障碍。乃至容受一切雨滴悉无障碍。而彼大海不增不减。海意菩萨亦复如是。悉能任持诸佛世尊所说之法。皆无障碍。非于一佛二佛所说之法无障碍故。而是菩萨念总持力。亦无增减说是法时。会中有八千众生。发阿耨多罗三藐三菩提心。咸作是言。我等当愿各得念总持力。如海意菩萨

尔时会中诸天及人。各以妙花向佛世尊。及海意菩萨。散掷供养。于是会中有一菩萨。名莲花庄严。前白佛言。世尊。若善男子善女人。于此甚深法门。闻已信解。受持读诵。如理伺察依法修行者。是人得几数福

尔时世尊。即说伽陀。答莲花庄严菩萨曰

  正使大千世界中　　遍满真金用施佛
  闻是法藏信解时　　此福比前为最胜
  正使十千世界中　　满中珍宝施如来
  若能持读此深经　　其福比前不可数
  又若十千世界中　　满中珍宝广行施
  若能宣说此深经　　其福胜前不可数
  正使千俱胝刹土　　广积珍宝满其中
  普施诸佛世间尊　　修行此法胜于彼
  十方殑伽沙数量　　宝严佛刹施如来
  此法真实修学时　　其福比前不可数
  四种法具无边福　　佛亦不能说边际
  发菩提心并护法　　起大悲及修法行
  四种法具无量福　　智者闻已不生疑
  虚空界与众生界　　菩提心及诸佛智
  我此宣说正法宝　　震动十方俱胝刹
  放净光明及雨花　　不鼓自鸣百种乐
  一切菩萨大智士　　发最胜心伸偈赞
  闻此所说妙法门　　各得善利无虚果
  从我得闻如是法　　众生普获诸善利
  皆由如来所护持　　令菩提心无忘失
  千俱胝数十方佛　　各各合掌而顶礼
  称赞德海大圣尊　　善住加持释师子
  天龙修罗紧那罗　　乾闼婆及夜叉等
  梵王帝释护世天　　各处空中作是语
  愿释师子久住世　　最上正法无减没
  勇猛菩萨圣众尊　　护持如是深妙法
  有受持此法眼者　　我等当往现其身
  于彼尊重及策勤　　密护令其无衰恼

尔时世尊。告海意菩萨言。海意。今此正法是大法眼。是妙法印。是胜法幢。决择诸法。分别诸法。而彼过去未来现在诸佛世尊。皆说是法。海意。我先已说。汝等应当尊重恭敬。志诚坚固如理修行

佛说此经已。海意菩萨等诸大菩萨摩诃萨众。及诸世间天人阿修罗乾闼婆等。一切大会闻佛所说。皆大欢喜。信受奉行

佛说海意菩萨所问净印法门经卷第十八

澄。举意刻藏。赵水臣。历授此方撰述数卷。读之心知其非佛语。不愿刻。送还水臣。后得净印经。则字字句句。无非甚深妙义。信是世尊金口所宣。快意踊跃。数十年前。曾梦大水充满世界。而人民国土都无损碍。澄游衍其中。如常安乐。觉而异之。此非心想所及。无乃妖祥乎。今是经首。称瑞应。适与梦符。则昔之现梦。今之值经。似非偶然。澄愿藉是因缘。首度先父大学士。文靖公严讷。先母一品夫人吴氏。即生莲界。见佛闻法。得阿耨多罗三藐三菩提。次度一切冤亲。一切众生。悉成佛道。有一众生不得度者。澄不取自度

万历三十六年。岁在戊申。十月朔吉。邵武守道澈严澄书


佛说无言童子经

    No. 401 [No. 397(6)]

佛说无言童子经卷上

        西晋月支三藏竺法护译

闻如是。一时佛游罗阅只耆阇崛山中。与大比丘众千二百五十人俱。摩诃菩萨无央数。尔时城中。师子将军。第一夫人孕有德男。天虚空唱大音声而告之曰。童子。汝当怀抱道教思惟经典。慎莫宣说世之言谈。晓了方便度世之法。少言鲜辞舍方俗事。当归正义不取美辞严饰之说。童子遥闻如是音教。未曾啼泣亦不出声。初不自现婴儿之相。至于七日颜貌悦豫无有憔瘁。众人来观视之无厌。或有人言。此儿无声用为育养。父母答曰。是非随宿吾当育之。所以者何。今观此儿威容颜貌端正姝妙巍巍难量。非是凡庶之所能及。实不虚妄。于时父母亲属知识见儿无声。因共字之号曰无言

于是无言童子。渐遂长大至于八岁。四方众人来观察者无有懈厌。其有方面。或有法会分别义者。辄诣其所咨受法言。寂然静思亦无所说。时彼童子而于异日。与其父母五种亲属朋友知识。至耆阇崛山而诣佛所。稽首足下右绕三匝。于世尊前叉手而立。睹无央数十方世界诸菩萨会亿百千垓各各处于严净之座。心大欢然善意生焉。时舍利弗前白佛言。唯天中天。是无言者师子将军之子。端正姝好威光难量巍巍如此。离于言谈而无所说。其人前世有何余殃。生无有声又不能言。佛告舍利弗。止止勿得辄慢无言童子。所以者何。此人则是菩萨大士。于过去佛殖众德本。供养无数诸佛正觉。稽首足下得不退转。当成无上正真之道。初生之时。天于虚空宣扬大音。童子。汝当抱道意。思惟经典勿有世谈。以是之故。今此菩萨寂然不言。受柔顺教于兹八岁。一心结舌而无所说。以斯憺怕奉行四禅。世尊复告舍利弗言。其有众生。若能睹无言菩萨。悉顺道教由此无言。以是之故。今有大会。当说经法开化导利。于无央数不可称人民之众。于是无言菩萨即如其象。三昧正受而现瑞应。令诸声闻及众菩萨天龙鬼神揵沓和阿须伦伽留罗真陀罗摩睺勒比丘比丘尼优婆塞优婆夷一切众会。各于右掌化生莲华大如车轮。其色若干微妙鲜好。其香难量见者心欢。彼莲华上则有自然诸化菩萨。结加趺坐。三十二相庄严其身。无言菩萨见大神足。稽首世尊重自归命其莲华上诸坐菩萨。叉手卑身。亦三自归。无言菩萨。口适宣此稽首归命。应时自然恒边沙等诸佛世界六反震动。大音普闻。天于空中叹若雷震。则雨众华。箜篌乐器不鼓自鸣。无言菩萨承佛威神。大愿所致踊在空中。去地四丈九尺。大菩萨众亦复如是。无言大士而于中。与菩萨异口同音。以偈赞佛

  无形而现形　　亦不住于色
  欲以开化众　　现身而有教
  佛者无色会　　亦不著有为
  皆度一切数　　导师故现身
  显相三十二　　奇好八十种
  以严其身体　　为众讲说法
  法者则无相　　亦无有音响
  无声不可得　　无念寂微妙
  佛法觉了法　　处在佛树下
  彼道无言教　　言辞无所说
  其法无形法　　求相不可得
  以无相之法　　安可有所说
  愍伤于群生　　此佛之大恩
  分别无所获　　所说不失时
  晓了无所得　　解空无所获
  能如此养者　　佛义无名字
  有为之言教　　诸佛因所说
  彼数无所有　　无为无自然
  如无常形色　　导师缘见象
  此法无所有　　为众说此经
  又始至八岁　　口未曾有言
  我初生之时　　诸天唱大音
  以入惟经典　　其耳不闻声
  如是怀道业　　口亦无所说
  无言假有教　　辞语无所畅
  以言谓有说　　清净妙光曜
  念誓愿佛道　　志在于大乘
  当宣于尊教　　得佛人中上
  道心不可获　　无言无相念
  是故曰道空　　解结成晖曜

于是童子。谓诸众会。道与言教等无有异。不可见。不可持。所可说无能睹。口说志道。人计于道而有所求。其所处愿斯无所有。不可得处则无所住。如是住者道之所立也。诸度无极亦复如是。及余无数众德之本。说于言教亦无所说。但是音声无有言辞。又说布施者。以施当施者。惠与有所向。道住一切等。口说愍哀。施道教亦行慈。其道为自然。平均如虚空。心所晓了有所说。计彼一切悉为清净。其道为普虚端如是。身行口言心有所思。舍施施斯一切尘劳。是乃名曰施度无极。所可劝助亦复如是。布施非是道之恩惠。有计道者不依布施。是二事者但假声耳。永无所著亦无形像。假使如是受道教者。为菩萨行。彼乃名曰施度无极。于布施主则为清净。有所惠与不想报故。耳闻禁戒不住于色。则无所生亦无所灭。是为戒者。亦复如是。身口心事若无所造。悉无所有而反分别。所讲说因缘合成。口有所说因名曰戒。如口所说戒亦如是。此二事者俱无形像。诸禁戒业。一切假言语无章句。计于道者无所言说。其口所畅及心意。以业是禁戒劝助道德。言戒为道欲曜于戒。一切无像犹如虚空。能晓了此。是谓独步报行禁戒。所可游志超绝无侣。入平等觉。亹亹深妙难及之道。于是赞曰

  如言道亦然　　无持不可见
  所说无所睹　　我宣者佛道
  誓愿求于道　　所愿无所住
  无住无处所　　道所立亦然
  诸度无极然　　及所作众德
  言辞托音声　　所说无所说
  所可谓布施　　所施当所施
  方当所宪者　　悉住平等道
  口所畅布施　　敷演于道事
  彼道亦自然　　等犹如虚空
  若能晓了心　　口之所说者
  彼一切清净　　闻净皆至道
  身口及心念　　舍一切尘劳
  所劝亦如斯　　是施度无极
  布施不归道　　道不倚于施
  此二者假名　　无著亦无象
  若无所依倚　　其受道若斯
  若不望想报　　是名曰布施
  而假闻禁戒　　不住于形色
  不起无所灭　　是为戒之相
  不行戒亦尔　　身口心无异
  无作无所有　　假有言说耳
  因缘合有辞　　说号禁戒耳
  如吾戒正等　　此二事无漏
  诸可禁戒事　　一切假于言
  道义所获者　　无言亦无业
  口说心所作　　禁戒劝助道
  计戒及道教　　一切如虚空
  若晓了此者　　独步普入戒
  则游居于道　　深妙难解句

童子又谓诸来会者。所可谓言。忍辱教者亦是言辞。解空空义乃为忍辱。忍如平等三界亦如。说忍形类无像无见。等心于此乃名曰忍。若能虚静为忍辱根。音声香味因缘合成。彼无所有但文字耳。是故宣畅言忍辱矣。如来正觉。说有三忍身口心念。若能晓了此忍辱者。是曰为忍。解断其身节节离散。心无嗔恚。恩爱及身譬如墙壁。察身如是为忍辱。远闻恶口所畅说。若能堪任。于诸言辞不味所说。乃为忍辱。若复游志一切瑕秽。其心静然而无忧结。意能分别诸文字者。心乃入于忍辱。计如忍道亦如此。身口意俱同尔。乃名曰道。宣传于圣教。多所劝助者。一切精进上妙细微。及诸中间。亿劫合集而不可得至于成就。假使精进不可逮得。计于道德亦无所获。不得诸法。是曰精进。所修精进。设能如是不怀怯弱。亦无恐懅是谓极上通大精进猛勇菩萨仁义备悉。于是童子重颂曰

  可所谓忍辱　　口之所宣畅
  空空义故忍　　如忍等三世
  说于忍色像　　不貌不可见
  若心等于斯　　尔乃名曰忍
  忍类为空静　　缘合声香味
  彼无有文字　　此乃名曰忍
  讲宣此三忍　　身口及心念
  若人晓了此　　畅乃名曰忍
  节节解其身　　而心不怀恚
  身受如墙壁　　是为身忍辱
  远闻有恶言　　不报于骂辞
  入此音乃忍　　悉能住所说
  若于诸瑕疵　　心不怀爱结
  设能了字空　　是心入忍辱
  如忍道亦然　　身口意如是
  此乃名曰道　　名所而劝助
  若诸所精进　　最上中微下
  合集亿垓劫　　不得便成就
  精进不可得　　道亦无所获
  不逮一切法　　是曰为精进
  若勤力行此　　无怯不怀难
  彼则大精进　　为猛勇菩萨

童子复谓诸来会者。所谓禅思亦不有念。计于禅者亦无所住。弃一切想。是乃名曰寂度无极。则能寂然澹泊无言无放逸。离诸漏而烧灭一切尘。是名曰寂度无极。心于诸法不遣往反。于心离心是则名曰寂度无极。心及禅定常至道意。恒以平等观此众事。若能平等。于诸所观无有邪正。斯谓佛道不为难得。无有文字亦无所说。不可究竟亦无所有。无有放逸亦不自恣。此乃曰智度无极。无有此际不度彼岸。又于此彼而无所住。正立法界以无所住。亦无所著。亦无文字。无所颁宣。无文字已。不复举假一切思想。若能启受于此法者。尔乃名曰智度无极。六度无极亦复如是。假使有人等观此义。则能均平一切诸法。亦能等于一切众生。若能同象一切诸法。则能均平一切众生。若能平均一切众生。则能平等一切诸佛。等诸佛已。则能奉修于一切智。是故菩萨勇猛无畏。犹斯名曰无极智慧。若能顺从此教命者。则顺法眼不可思议。于是童子以偈颂曰

  禅行无所思　　专心不有住
  断一切诸想　　名寂度无极
  寂然而澹泊　　不逸无诸漏
  弃捐众尘劳　　是寂度无极
  其心一切法　　未曾遣往反
  无心脱于心　　寂然度彼岸
  计心及与道　　观之悉平等
  若能察平等　　佛道不难得
  舍文字无言　　无本无所有
  不乐不自恣　　乃名为智慧
  无此不度岸　　不住彼此际
  正立于法界　　不住无所著
  文字无班宣　　不与一切想
  以是受诸法　　乃名曰智慧
  诸度无极然　　所见一同类
  则能等诸法　　平均于众生
  以能等诸法　　则能等众生
  亦等于诸法　　便等一切智
  是故大智慧　　菩萨其勇猛
  能随此教令　　法眼不可议

彼诸正士。说此章句分别所趣。以千二百人皆发无上正真道意。六万菩萨得无所从生法忍。时莲华上诸坐菩萨。寻即退下稽首佛足。及复礼于无言菩萨。俱共启白。无言菩萨。吾等以报圣师之恩。钦乐正法奉事经典。修行孝顺而有反复。贤者舍利弗。前白佛言。唯然世尊。此诸菩萨。何故口宣如来言辞。吾等孝顺而有反复。佛告舍利弗。此诸菩萨。悉是无言菩萨大士之所劝发。令宣道教演于恩慈仁义礼节。无上正真大乘之教。开化未闻令发道意。是为孝顺而有反复报师之恩。今者故来行供养德。亦欲睹见于此大会奉觐佛圣。听省经典咨受所闻

于是无言菩萨。白世尊曰。我欲启问如来至真等正觉所怀疑结。设见听者。乃敢自陈。世尊即告无言菩萨。恣意所问。诸不了者。如来一一当为发遣可悦其心令无余疑。时舍利弗。语无言菩萨。汝族姓子。不能语言。云何欲问如来义乎。无言答曰。一切语法。悉无文字亦无言辞。所以者何。一切众生皆悉自然。无诸言教及众想念。唯舍利弗。因心所念口说言辞。若无所思则无所言。心所念者悉虚无实。言不可说。不可示人。亦不可得。咨问行念。其想著者悉无所有。而无文字。其虚无者亦无想念。亦不宣畅文字之说。其诸行念不自想言。吾当宣布文字之说。文字不念当行想念畅文字说。唯舍利弗。十二缘起深奥难逮。巍巍如是。因缘所生。彼则自然了无所有。假使自然无所有者。彼则无有逮成道者。唯舍利弗。一切诸法无所成因缘之事。依无所住有所造作。因于缘合。是故因缘无所兴立。唯舍利弗。一切诸法悉无有主。而君长亦无常主。无有志念。因己思想多所驰骋。从对有念处于众想。颠倒之党从其起生。彼若有问见难问者。所想知一切此法。有想无想悉为一相。谓无有想。彼所以问。是为菩萨行于大哀。唯舍利弗。吾以是故。兴发大哀咨问如来。不以言辞声音问事倚口言教。住于大哀菩萨所问。舍利弗问。若族姓子。设无众生无有人物。何因菩萨。而于众生兴大哀乎。无言答曰。唯舍利弗。设使众生不求成就至于道者。尔乃菩萨。不于众生兴发大哀。然而众生。无有众生起众生想。是故菩萨处于众生兴发大哀。设说有人则反逆矣。一切五趣犹如幻化。呜呼痛哉诸人颠倒。无有众生想。是故为彼讲说经道。使无我本末皆空。由是菩萨为诸众生兴发大哀。无所破坏不毁所有。不坏吾我及人寿命。故曰菩萨入于大哀导利众生。见畅审如分别空事。为诸客尘之所沾污。所可游入等一切色。而自观见本悉清净。是故菩萨而于众生兴发大哀。时舍利弗。赞无言菩萨曰。善哉善哉。族姓子。实如所云一无有异。又从仁贤。向者听者。所讲辩才。故欲发问。当从正士启受如是不可思议。所班宣法。设问所说。当令弊魔不得其便。使如来法得久存立。此诸众会。天龙鬼干沓和阿须伦加留罗真陀罗摩睺勒等人非人。逮得无量道法光明。于是无言菩萨。前白佛言。世尊。常说修正见者。有二因缘。从他闻音思惟其行。善哉大圣。唯愿如来至真正觉。分别宣扬。何谓菩萨承于他音。何谓思惟何贤圣之正见也。佛告无言菩萨。族姓子。谛听善思念之。今当分别。犹如菩萨承他音声。因而思惟。奉顺贤圣之正见。善哉世尊愿乐欲闻。无言菩萨与大众会。受教而听。佛言。族姓子。若有菩萨。劝化众生入于佛道。是为菩萨承于他音。设令其人心不怀乱。是为思惟。假使等观于道意者。是为贤圣之正见也。又若听省柔顺道法。此承他音。若能奉持佛之道义。是为思惟。若能奉行菩萨之道逮得法忍。是为贤圣之正见也

复次无言。若能宣于所闻微妙之慧无上正真。承此他音。假使能通达不计吾我。是为思惟。志性清净无有谀谄发起洪业。是为贤圣之正见也。所闻顺义而不违法。是承他音。修众德本是为思惟。所行微妙劝助于道。是为贤圣之正见也。专精听受是承他音求殊特义。是为思惟。劝助道意未曾忘舍。是为贤圣之正见也。顺念如应劝助道意。初不废退等观贤圣。放舍一切所可闻念是承他音。一切所有敢可尊敬。悉能施与无所爱惜。是为思惟。不望其报。不贪着道。至于大乘。是为贤圣之正见也。闻于禁戒弘雅之教。此承他音。所执戒心无所习舍。是为思惟。戒无所行。笃信至真劝助于道。是为贤圣之正见也。听省忍辱仁义大慈。此承他音。而怀愍伤无有害心。是为思惟。究竟闲静。信诸法尽劝助佛道。是为贤圣之正见也。听省精进则而顺之。是承他音。其心不住懈怠垢秽。是为思惟。无合无散无所违失。殷勤精进以劝助道。是为贤圣之正见也。令闻禅定三脱之门三昧正受此承他音。心所为事而不可得观察心本。是为思惟。所修禅定不堕颠倒劝助佛道。是为贤圣之正见也。听闻智慧身根华实。此承他音。所闻法观察本末之所归趣。是为思惟。弃捐诸流众崖底源开化之意。是为贤圣之正见。示以四恩。听摄所闻了无所著。此承他音。未曾放废四恩之教。是为思惟。所可救济恩及众生。斯平等义。开度立之于一切智。是为贤圣之正见也。修四梵行慈悲喜护。此承他音。而不坏除愍爱众类亦无所毁。所可奉行不求名称。是为思惟。遵乐空无。为众生故而修愍哀。以法之故而行欢悦。为二报故劝助道德。是为贤圣之正见也。设令听省四分别辩。此承他音。观察诸法威仪礼节。是为思惟。从法义等于平均。所行具足劝发道意。是为贤圣之正见也。若闻所当奉行微妙导利之事。此承他音。念御顺行而不远离。是为思惟。章句道迹。所由处所宣布佛道。是为贤圣之正见也。若能令闻三十七品正觉之法。此承他音。修于意止悉不愦乱。行于断意。未曾惑随不善之心。而常顺从德义之志。其神足者。精进禅定不怀怯弱。笃信如是。明解章句而不退还。慧能寻对一一观察。心由力不行尘劳。入觉意法等于道心。是为思惟。假使无意无所思念。于四意止不起不灭。于四意断柔和身心。于四神足审如真谛。晓了如是。所趣若斯。执智慧刀截断众垢。情欲不散入于正法。而于觉意下入等观无有二事。所归径路劝助道心。是为贤圣之正见也。若使听闻四圣谛者。此承他音。五阴苦患。恩爱之难。灭尽所习因缘之报。入于径路。是为思惟。虽处诸苦慧无所起。于诸所习慧无所习。于诸所尽慧究竟尽。由于径路慧无所著。劝发大道。是为贤圣之正见也。若以听受于三脱门。此承他音。笃信于空不畏无相。而于无愿无所志求。是为思惟。不生空行开化诸见兴于无相教导一切。诸所相行发于无愿。所生至诚。是为贤圣之正见也。令初发意顺从大业。此承他音。修菩萨行不舍一切。是为思惟。不退转地当成正觉。是为贤圣之正见也。得善知识而从其教。此承他音。目见世尊咨受圣路。是为思惟。如口所言不违所言身口相应。是为贤圣之正见也。听所讲法等于惑乱。此承他音。观察诸法义之所归。是为思惟。奉行法义不失道教。是为贤圣之正见也。亲近如来咨受所宣。此承他音。识分别道心不舍大猷。是为思惟。受奉行有所开化能使成就。是为贤圣之正见也。设能听受八万四千诸道品法。此承他音。晓了分别八万四千诸佛之行也。是为思惟。八万四千众生之类各异根者。如应说法。是为贤圣之正见也。在在所由悉无所乐。发功德心。此承他音。假使其心不舍功德。是为思惟。以是德心专精劝助于一切智。是为贤圣之正见也。此族姓子。设随顺念则为长命。寿不可极无始无终。贤圣正见。所以者何。五趣周旋。如幻化梦影响野马水月芭蕉。晓了若斯。是承他音。一切诸法悉为平等而无偏邪。是为思惟。若致平等。乃为贤圣之正见也。名曰思惟。不举不下。于一切法无应不应。无进不进。无处不处。无行不行。无念不念。无想不想。无意不意。无惟不惟。无心意教。是为名曰不二入法门。晓了一品。无合无散无违无顺。晓了深念本性清净。极为显曜而当讲说。无冥无明。无浊无清。无有品第。则为法界无所破坏。而于本际不为动摇。入于无本。处于三世而无所处。无我无人无寿无命。无音无声等诸文字。义无所获。无有财业。无所毕置。得诸所尽。一切所行无有众念。离一切想。皆悉断于放逸之事。灭除一切诸所惟行。而无所著舍诸所著。巍巍乃至如来所叹。无为之事。刈去众想是为平等。无有形貌一如应思惟。假使行者从三昧起。则以此法而为众生及他人说。便于其所推求斯本。如应思惟而疗治之。无所动摇。是为名曰立于大哀贤圣正见。佛说贤圣正见之时。一万菩萨寻即逮得贤圣正见。于是舍利弗。谓无言菩萨。仁族姓子。从何闻法乃能兴此贤圣正见。无言答曰。唯舍利弗。吾所从闻法无所造。不从过去心得至于道。亦不当来。亦不现在。平等三世等一切法。有所有趣者而无所归。亦无有法亦无所等。吾从于彼而听闻法。不有为不无为。无识无住无心意识。于一切法莫有所奉。制止一切众生之心。可悦诸人。义无所获亦不动摇。于无力毒而无著。吾正从彼而听闻法。见生于世者不生不起。一切法若不所兴。分别无本而无所说。吾正从彼而听闻法。其住法界等御人界。法界人界及虚空界不以差别。平等诸界而无所生。不造若干。吾正从彼而听闻法。不处道场。不坐树下。亦不经行。亦不得佛。不倚于道。不舍于俗。不令诸着人民之等作是念心。如来得道亦不得道。得于相好若不得相。作证不作证。悉从本净自然之性。惟舍利弗。法者无持。而不可捉则无有身。以无有身无所成就。以无所成就则无所生。以无所生则无所起。以无所起则无终没。以无终没则无所著。以无所著则不动摇。以不动摇则无所作。以无所作则游驶水。已游驶水则无所得。已无所得身度彼岸。已度彼岸无下。不下则无有器。已无有器则无所应。已无所应则离爱欲。已离爱欲则无有想。已无有想则断众乱。已断众乱本性清净。以至清净则无有垢。已无有垢则无尘劳。已无尘劳则无同像。以无同像则住平等。以住本平等则立无动。以立无动则无所求。以无所求则如真谛。已如真谛则如审实。以如审实则无所有。以无所有则于诸缘而无有缘。以于诸缘无有缘者则度境界。以度诸界所起无起则无所举。以无所举则无所下。以无所下则无有门。以无有门便离言教。以离言教则度识句。以度识句则不复还。以不复还则无有处。以无有处则无非处。以无非处。则无种稷。以无种稷则无根芽。以无根芽则无为。超度诸识之迹。寂之然。以至寂然究竟澹泊。已至澹泊则至无惟然。以无惟然究竟无恨。已至无恨则至了意。以至了意不复更兴。以不复兴。则归平等无为之道。是为法。唯舍利弗。法如是比说经如兹。其正见者为何像类。其正见者。等于己身。以等己身则离合会。以离合会。于诸平等不见平等。睹诸所见若无所想。是舍利弗。宣畅法律贤圣正见

无言菩萨。谓舍利弗。如等无明恩爱之着。亦等慧明解脱之事。等于灭度无作不作。是为等致贤圣正见。若有所睹不取异见。是为贤圣之正见也。复次念舍利弗。若能等于淫怒愚痴。亦等于空。无相无愿解脱之相则为一相。谓归无相已能归此平等事者。是为贤圣之正见也。复次处正见者。于诸平等不造二事。已无二事不住相应。已无相应不有所住逮得诸法。一切平等而无差特。是为贤圣之正见也。复次等无二者则等众生。则等诸佛。则等诸法。已等诸法则等国土。已等国土则等虚空。其于此等若不转移。能于此等平等住者。修无所处。是为贤圣之正见也。是故舍利弗。如法像类。听者亦然。正见若兹。又舍利弗。耆年为兴正见乎。从何闻法。所见何类。舍利弗答曰。如我于今族姓子。闻所说法。察其义归。有所讲说皆堕短乏。无言答曰。如是如是。舍利弗。敢有言辞皆顾短乏。舍利弗又问。族姓子。如来至真无量福会有所宣畅。其所说者岂堕短乏。无言答曰。如是说者而无所说。不堕短乏。所以者何。如来至真不兴名德。不当慕于如来上福。所以者何。其如来者无德无称。若如来义无本。如来亦复如是。在于无本而不动转。若有不欲如来上德。彼所慕者则无平等。亦无偏邪于欲无欲。有所慕者则堕短乏。舍利弗问。唯族姓子。何谓于法而无短乏。无言答曰。无大五阴六入。不以顶受。无所招致。悉无所行。不有言辞。无诲不诲。而于道法。令心意识无所起生。是法无短。假使有起心意识者。则堕短乏。若于诸法有作无作。则堕短乏。设于诸法无作不作。乃无短乏。复次若于诸法有所分别有所蠲除。而有所行有所造证。则堕短乏。若无晓了无除所去。亦无所行不有造证。乃无短乏。假有所见无所闻说。教化获致识知所趣。则堕短乏。于一切界而无所行。乃无短乏。其有睹见功德瑕秽。则堕短乏。设使所行无有瑕秽。无有德称。亦无所见。乃无短乏。时佛嗟叹无言菩萨。善哉善哉。族姓子。若欲讲法当作是说。是时万二千菩萨。逮得无所从生法忍

无言菩萨。复白佛言。我识如来为诸菩萨讲说四力。一曰信力。二曰精进力。三曰意力。四曰智力。唯如来至真正等正觉。广分别说此四品力。何谓菩萨笃信精进意智慧力。佛告无言菩萨。谛听善念。善哉世尊。愿乐欲闻。无言菩萨受教而听。佛言族姓子。假使菩萨信诸佛法。爱乐顺从不怀狐疑。亦无犹豫。是为信力。诸佛精进本求道时。志慕此典不以懈废。不怀怯弱亦不退转。是为精进力。若摄其志合集德本无所忘失。其意不乱不舍道心。所可兴废真正之心劝助于道。是为意力。所修智明于一切法。不须他慧而得自在。慧无所碍。是为智慧力。佛复告无言菩萨。信于贤圣。独步三界无所疑难。是为信力。所施精勤恭敬奉顺。是为精进力。心之所念常思贤圣之所班宣。未曾忘舍。是为意力。若从至圣。所闻智慧经典之本则能奉行。是为智力。复次假使笃信罪福之报而不疑乱。是为信力。若能勤行不当作而不为之。是为精进力。念所兴业终无腐朽。是为意力。若能晓了无有罪福报应。有能分别一切诸法。是为智力

佛复告无言菩萨。假使其心清澄无秽。能摄其意顺道教者。是为信力。意所启受而将养之。是精进力。若令其心常顺志一。是为意力。心观诸法一切如幻。是为智力。复次信一切法皆悉为空。是为信力。所修精进解诸见缚。是为精进力。于内外空不怀恐怖。是为意力。观究竟空本末悉空。为智慧力。无相无愿于一切法无所造行。是为信力。以此道法而为他人分别说者。是精进力。设使于此念于诸法所行安详。是为意力。昔所讲说方当宣畅令班宣者。一切推求永不可得。是为慧力。一切所有心自当思。欲以放舍信布施处。是为信力。有所放舍不怀懈倦。未曾怯劣大道。未曾违。舍施与发布施。又劝助道意。是为意力。不得施者亦无受者。不蒙想报。是智慧力。奉顺禁戒成就真正信戒果实。是为信力。以所精进灭除诸毁戒之心。是为精进力。若以道心念之不忘。所尊禁戒。皆以劝助于一切智。是为意力。观身如影言如呼响心如幻化。察于禁戒而无所行。是为智力。成就忍辱信于威势。是为信力。所行精进不听众想。不演粗辞欲加于人从邪径。假使令支解割截身肉。集忍辱力。未曾怀嗔。慈心忍辱。是为精进力。所行忍辱则以劝助于一切智。是为意力。无身意识不得身心。是智慧力。道为精进不为懈怠。信于此者而心欢乐兴盛笃信。是为信力。常行精进不舍须臾。亦无所著用化众生。将护正典殖众德本。奉事于佛供养随顺。皆为一切众生之故。修治佛土庄严清净名德之称。是精进力。蠲除一切众生嗔恚懈怠垢秽。以被德铠所修精进。则以劝助于一切智。是为意力。若不殷勤望想于道。不失威仪礼节之正。选择精进。不得一切诸法处所。是智慧力。乐于闲居宴静独处。不慕众会发兴悦力。是为信力。所行精进修于禅定。兴发脱门三昧正受。是精进力。因由所从致禅思者而不动摇。是为意力。于彼一心观于无常苦空非身。而不乱禅。不轻慢禅。不退转禅。晓了善权方谋宜适。是为善权方便诱进牵致至于智力。闻于一切诸度无极道品之法。若能信此是为信力。一切所闻执持不忘。能为他人嗟叹方便。设于彼法。若能奉遵若不奉遵。自察本末。是精进力。处于众生其心不乱。游于爱欲譬如莲华。教化一切。是为意力。察三界空犹如泡沫芭蕉野马影响幻化。开示未闻。是为智力。以清澄心慈向众生仁靡不周。是为信力。信于大哀。心所兴造不以懈怠。是精进力。心好正典不舍法乐常执奉行。是为意力。心无所著而不怀害。不造有二。无进不进。逮得静观修行正法。是智慧力。思惟人身。以无央数众恶瑕秽荒乱众力。不得久存。供养于此[怡-台+龍]悷蛇蚖。因由邪行。晓了如此。是为信力。若速众没苦痛之患众恼并至。此则为是死生之义。观察佛法。是精进力。假使心变在于不善终不听从。心亦不随声闻缘觉。又心不随尘欲贪嫉。心亦不从毁戒恶智。是为意力。若入法慧分别慧句。入于宣畅体解之慧过去当来今现在慧。是为智力。欢乐为信相。不退精进相。观为意相。晓了为智相。行于信力。不舍进力。不失意力。修智慧力。为人说法应病与药。晓了挂碍则为笃信。度诸挂碍而为精进。无所复着。是名曰意。而审晓碍则为智慧。好喜佛法兴于笃信。以兴笃信即发道意。是为信力。奉修众行合集积累道品之法。是精进力。柔顺法忍则为意力。设使逮得无所从生法忍。是则智力。信根为忍。则为意力。设使逮得无所从生法忍。是则智力。信根为信力。进根为精进力。意根为意力。禅思伏根。大圣达根。靡不周至。是智慧力。佛说是时。八千菩萨逮得无所从生法忍。四万二千人皆发无上正真道意

无言童子经卷上佛说无言童子经卷下

        西晋月支三藏竺法护译

尔时会中有一菩萨。名莲华净。问无言菩萨。如族姓子属者兴意。白问如来。宁见答解及微妙行。如受法染可悦心乎。无言答曰。唯族姓子。吾始以来未曾问法。亦无所受。当以何缘而致法染可染心耶。曰族姓子。仁为不曾因于如来听受法乎。答曰不也。又问何故。答曰。非其器故。又问。仁于讲法为非器乎。答曰如是。又问。仁何所器。答曰。吾于诸法之类而为非器。无复奇异。又问族姓子。若为非器。何因当逮无上正真之道成最正觉。答曰道者。非为法器。又问。察其道者非佛法器乎。答曰。假使其道离佛法者佛法非器。又其道者不离佛法。又计佛法则为是道。又其道者则为佛法故。族姓子。吾不欲令诸佛道法离于尘劳。常不志道。况乐佛法离于道乎。所以者何。有佛法者不离尘劳。又其尘劳不离于道。觉了欲尘则名曰道。吾以是故不计我所不别佛道。其异意者各各计别。不当异处而求道也。假使有人于异处求。此等诸异。设复有人。无有异求不以为别。又问。以何为异。答曰。谓吾我别与道不同。是名曰异。谓四大异我人寿命。而心意异。淫怒痴异。是谓为异。若能晓了。吾我自然本末清净。道者自然本末清净。乃谓无异我人寿命。淫怒愚痴自然清净。道亦自然究竟清净。乃谓无异。假使异者。不可求异。则当于此四大之身于吾我中求一切法。如是求者。求无所得。设无所得中造所著。无所著者则无处所。一切诸法悉无所住。无有本际。设无本际则真本际。以真本际无断绝际。不计当际。无有限际。无无量际。一切诸法本际如是。若入此际则不有念亦不无念。不在生死亦不灭度。究竟灭度了一切法。若以此法而灭度者则逮寂然。诸不灭度令得灭度。如世尊曰。不能调己不寂灭脱。而不随教不得灭度。欲开化人令得灭度。未之有也。其自寂然解脱随律。得度无为能度未度。此事如言是菩萨行。设使欲得至灭度法。辄当遵修菩萨之行。则能晓了一切诸行。达法界相。如是行者便能皆见众德之本。目不复睹诸魔官属轮迹之行。当遵修此合集佛法不失三昧。如是行者开化众生。宣畅一切诸界度于无我。如是行者受一切法。皆使尘劳自然悉除。如是行者虽行于世不着方俗。如是行者执持五阴不住于识。如是行者受诸四大立于法界而不动摇。如是行者摄于诸入致解脱门。如是行者所现诸界而度无极。独步大猷入于三界。示现尘劳而无垢秽。如是行者施度无极。不想无极亦无所住。戒忍精进一心智慧。慧度无极不想智慧亦无所住。如是行者不舍众行。所修审谛究竟清净。如是行者修菩萨行。所可遵习道无若干。行菩萨者则无有二。无有二者乃菩萨行。行菩萨道无有吾我及与我所。不计有身亦无所受乃菩萨行。其修道者无有结滞。除诸福废乃为菩萨。其修道者不患危害。觉了分别无会无为乃为菩萨。又问何谓正号为菩萨乎。答曰。为不晓了道义者故。因曰菩萨。顺从道教兴发寂然不毁佛教。奉持法言将护圣众。而于道心则不动转。心不住于声闻缘觉。不乱净性而不宣说无称之辞。究竟要誓。度诸未度。安诸不安。诸不灭度令得灭度。受持尘劳不堕无欲。观于无生所生。而审观于空无将济群生。观于无相不想着道。行于无愿随俗而生。求于佛身不为众欲之所沾染。观于有为觉了所会。亦无所失而不愚颠。得世间慧。执智兵仗降五阴贼六衰之难。开化憍慢。施自庄严。严净佛土。戒庄严心所愿具足。被忍辱铠教授嗔恚。精进坚强能成就已犹如金刚。处于愦乱志执禅定而无所著。智慧明了。而不恶厌所生之秽。行权方便。所在一切推极道源。修于慈心安详柔和。发起众生行于大悲。见于众生未得度者。抚育使安遵修行喜。常为无依令护诸根。行于护观不永寂灭修于观也。遵承深奥难及之事。声闻缘觉所不能逮。念本义藏不思世典。多所将顺一切群生。庄严其身以相饰姿。庄严其口言行相应。庄严其心不舍道意。神通娱乐普能示现。一切所住持心如地。一切众生之所戴仰。洗一切垢。譬如火烧焦一切。艰难衰入譬若如火。心犹若风无有恼热游步无碍。心如虚空未曾愁想。着一切诸法逮得总持。一切所闻识念不忘。辩才具足可悦众生欢然解释。而为诸佛之所建立。能自修心则令清净。顺于法界晓了四食。不想诸应。威仪礼节清修己身。威仪礼节径路清净。为修正业。行步进止具足成就而修空行。乐于闲居开化众生。而不秽厌于诸聚会。乐于禅思不患其意。未曾贫匮。备悉一切诸贤圣财。修于祠祀伏弊恶心。游旷野者修于坚强。其心刚毅不可毁坏。遵行仁慈究竟灭度。身顺反复而不虚尽。往宿德本志常随顺。报前所由念行思好。为众生故所学精勤。选择举要劝化无智。所修善业无烦恼热。悉能分别行于大哀。一切普游导于三乘不怀狐疑。于一切法众所瞻察。所问能答靡不戴仰。辩才无碍莫不受言。本愿所立明说和雅。所至到处靡不欢悦。所语随时未曾失节。功勋布施人所钦仰如月盛满。志性柔和辞无粗犷。得对能忍诸根不悴。善修其意等度往来犹如桥梁。度脱众生于四使水譬如大舡。亦如导师将导一切诸行来者。常主救济一切异学。为众群黎兴立佛事。故曰菩萨。而不退转如是众行及余德勋。不可思议具足导慧。乃谓菩萨

于是莲华净菩萨白佛言。唯然世尊。今我观察无言菩萨智慧辩才宣畅道教如是。不久当成无上正真之道为最正觉。当转弘广无上法轮。若复有人。得闻无言菩萨所说。信乐爱敬顺而不讪不久亦当具足致此功德之法。佛言。如是如汝所言。诚无有异。无言菩萨逮得慧明三昧。发意之顷以一句法于百千劫分别说之。义不可尽。莲华净菩萨复白佛言。善哉世尊。愍伤我等及此众会。宿之本德众人云集。为经典故当令庄严。惟愿如来至真等正觉。敷演说此慧明三昧。若有菩萨得闻此教。悉当逮得慧明三昧。设有受者多所将济一切群生。疾成无上正真之道为最正觉

佛告莲华净菩萨。谛听善思。当为善说慧明三昧。善哉世尊。愿乐欲闻。莲华净菩萨受教而听。佛言。族姓子。所云慧明圣曜之谓。所以名曰慧明。圣曜者何。蠲除众覆蔽结垢闇通过诸碍。离于秽浊荏若之谓。故曰慧明三昧。解法无二。所观明彻无有犹豫。慧无有侣。不戴仰人。灭众瑕疵。卒发寻对。分别灭度。晓了一慧。解畅过去当来现在三世之慧。严净三场。明识三界。体三脱门。通三达智。广布三宝。畅示三乘。净于三眼。毁三垢本。明三峻聚。决定未定处耶。此谓三峻聚也。识畅入于心意识中。分别阴种诸入之事。觉了因缘和合报应。断不调定沉疑邪见。解知法界能说本无。审如本际最上第一方便至圣。明识一切文字音响。其所入处。若崇讲说言无所毁。辩才无碍莫能制止。若敷演法无能抑者。知识一切诸根各异。决断柔劣中容之源。有明无明入于三教。执持所应入于总持。班宣光晖归趣日行三昧。无量颂三昧。分别宣畅金刚道场三昧。如金刚三昧。觉无嗔三昧。意勇三昧。降除魔场三昧。日光明三昧。曜魔不照无境界三昧。慧无齐限入无想念幢英至三昧。淳淑亲近一切诸法照明华三昧。放无量光入音三昧。了别一切音声所趣德事三昧。普能示现一切功勋善住三昧。知一切法所立之处光曜三昧。等入一切众生之心尽尊王三昧。分别诸法一切悉尽无住三昧。了众平等无恚三昧。一切诸法究竟永无无动三昧。不着诸法钩锁三昧。开化诸见超表三昧。于一切慧无所蔽碍。佛言。族姓子。如是等类六万三昧。吾于往昔见定光佛而见授决。寻时逮得此诸三昧。又计于此六万三昧门。皆来入于慧明三昧。慧明三昧则为元首。入于此中乃致大明

佛告族姓子。如日宫殿照于水中。显现未曾兴立四事。何谓为四。灭除一切闇冥蔽碍。放其光明所照广远。示现一切诸色形像。所当作者。皆由是日兴业安。慧明三昧亦复如是。若有菩萨住此定者。现昔未有。亦兴四事。何谓为四。灭除一切尘劳垢冥。照曜无量广远智慧。察见一切众生心行像貌诸色。随其所学三乘之行。名为指示建立道业

佛告族姓子。譬如八角大如意珠。妙光晖善清净玄妙。无诸瑕垢无有秽恶。建于幢首曜四十由旬。众人所志敢有所求皆令得愿。各各得所不失其侥。大如意珠无所爱吝。若有菩萨。得立于此慧明三昧。圣智超绝巍巍如是。清净鲜明若如意珠除诸尘劳结秽众垢。住八清净微妙禁戒三昧之定。智慧解脱度知见品。诚谛鲜洁。善权方便。总持辩才。分别忍辱。靡所不畅。彼以清净。莫能当明。离于瑕疵。无极大哀以为大幢。照曜一切无量佛土。各随众生心本所愿悉得解释。菩萨如是。救济五趣三处之碍。皆至大道。亦无想念

佛告族姓子。譬如虚空。虚空无际悉能容受一切佛土。执持众水。一切诸火劫烧之时。一切众生无进退处。听其所归为作处所。虚空之域广远玄旷。不可限量无所挂碍。慧明三昧。亦复如是。若有菩萨住此定者。为诸众生一切诸法示导处所。无所归者为受其归。殖众德本因缘之报。开解己心。为无央数一切众生。导示径路教化与眼。强于因缘。未得解脱永处邪见群萌之类。听示处所。假使有人。不兴德本。不反道器。不在无本。各各开化为示弘器。显发无上正真道意。而示声闻缘觉处所。闻吾说法寻受奉行。则获果报。声闻缘觉之所慕乘。当为宣畅曾所忘失六典之要。令入法门。缘是之故。诸菩萨众欲求道者。当为颁宣六度无极四等之恩。善权方便劝助指道。各各为畅令心欢然。使不退转逮成无上正真之道。是为一切众生之类开示处所。于彼何谓为一切法示现处所。假使菩萨口自敷演八万四千经典法藏。若有众人心怀狐疑犹豫不决来启问者。菩萨皆常秉志一心。一一为人决其结滞。一句之义亿百千垓。难限劫数普演分别。其慧无量玄旷广远。无所挂碍而不可尽。无有边际。是为一切示法处所。佛告族姓子。譬如大炬光明照远。诸有覆蔽曀匿形色悉为现矣。炬之光曜所益如此。慧明定意亦复如是。若有菩萨住此定者。则能以一慧明之心显示章句。十方无量不可计会诸佛国土。诸佛菩萨一切众生。莫不睹见。亦不违远志不动移。慧明之心所察无边

佛告族姓子。慧明之宅处于意止见诸法源于四意断未发意者。为兴慧源。于诸神足身意寂源。而于诸根处圣达源。所谓力者。云智慧力。于觉意法入于慧源。所谓道者。处正见源。寂然观者观察憺怕。行真诚者善灭之源。其圣谛者善寂慧源。所归念者如义趣源。分别道者法义之源。神通达者漏尽之源。修梵行者兴于大哀四等心源。一切普念思法之源。诸度无极。智度无极以为源首。善权方便应众生心源。十种力者知限无限有处无处。以此为源。无所畏者。晓了平等佛道之源。不共法者。而于三世无所碍源。所言眼者。谓佛之眼庄严其身。眉间顶相无能睹源。庄严口者。颁宣经法无侵损源。庄严其心。行三昧定而不移源。是族姓子。一切诸法皆以归趣智慧之源。是则名曰慧明三昧一切诸法之源首。说是语时。莲华净菩萨逮得是慧明三昧。复有万菩萨亦逮斯三昧。三千大千世界六反震动。其大光明普照十方。尔时诸来一切众会。诸天人民各各赍华供养散佛。于时会中诸菩萨众志大乘者。悉白佛言。我等本来未曾得闻此三昧名。何况广解分别义者。今所可供世尊之福。愿令我等逮是三昧渐渐进行。缘是所誓逮此定意。必获无疑。吾等善利为致善庆。乃能遭遇闻是三昧。若有逮闻于是三昧而欢喜信。功祚难限。未曾违失菩萨之心。亦当不久致此三昧。佛言。如是如仁所言。而无有异。无德之人不种善本。不能值遇此三昧矣。何况得闻。欢喜信者未之有也。假使在于善知识边。若随明师。乃能信乐此定意耳

佛说是语向欲竟时。世尊脐中一菩萨出。紫磨金色三十二相庄严其身。八十种好而饰其姿。适出于脐。其菩萨身。寻即演放巍巍光明无极弘曜。皆悉覆蔽一切众明。唯世尊光独得显现。时彼菩萨。稽首佛足右绕七匝。则在前住。启白佛言。唯然世尊。执慧曜如来至真等正觉。敬问无量。进止康强游步轻利力势安乎。使我宣传问于大圣。斯六十亿垓数菩萨。来诣此会听说经典。奉觐世尊稽首咨受。又复欲见十方世界大会菩萨。无言菩萨。智慧辩才所可宣畅。启受未闻听是慧明三昧之定。唯天中天。为诸菩萨如应说法。使逮得是慧明三昧。获致无极大法光曜。而数周旋诣此佛土

于是舍利弗前问佛言。唯然世尊。执慧曜如来至真等正觉。为在何方。今宁现世讲说法乎。去是远近。国土何类。并说于此正士名号。及六十亿垓数菩萨。为何所处。佛告舍利弗。东方去此恒河沙等诸佛国土。有世界名住于坚固金刚之根。执慧曜如来。在于彼土今者现在。佛告舍利弗。彼之世界。何故名曰住于坚固金刚之根。其国下地从底至上。坚固甚牢不可破坏。悉是金刚。斯皆其佛本愿所致。所以者何。其佛坚固金刚之行独步无难。及诸菩萨造金刚行。勇猛牢固无能坏者。己身威力巍巍具足乃如是也。假使世界泥土成者。则当破坏碎落微散。若其有人生彼世界。身如金刚皆亦坚固不可破坏。是故彼土。名曰住于坚固金刚之根。又舍利弗。卿属所问。今此菩萨名曰何等。号金刚脐。此金刚脐菩萨。一发意顷通过铁围大铁围山。越江沙等诸佛国土。各各在于江河沙等诸佛脐出。悉是诸佛威神功德之所建立。亦复是己六通之慧神足之力。是故菩萨号金刚脐。又舍利弗。向者复问六十亿垓诸菩萨众为处何所。卿当以此问于正士。为汝发遣。贤者舍利弗问金刚脐菩萨。唯族姓子。六十亿垓诸菩萨众为住何所。金刚脐答曰。佛叹耆年智慧最尊。贤者舍利弗。以智慧眼推索本末。此诸菩萨为在何所。时舍利弗。以圣慧眼周遍普求。诸菩萨等不知所在。金刚脐菩萨答曰。尊者舍利弗。自有等类同学志脱。令求所在。即舍利弗。谓阿那律。佛叹耆年天眼最尊。求其所在。时阿那律。则以天眼清净之目超越天人。于是三千大千世界遍察求之。如观掌中果及宝珠。索诸菩萨永不能知。亦复不见之所住处。贤者阿那律报舍利弗。吾普推索。永不能知此诸菩萨为何所处。金刚脐菩萨谓舍利弗。诸贤者等。但有肉眼。不可复言谓有天眼。云何思惟共三昧禅。遍观诸国而不睹见诸国。而不睹诸菩萨众为何所住。舍利弗问。仁族姓子。天眼何类。谓我等辈所未见焉。金刚脐曰。唯舍利弗我之天眼未曾见色。舍利弗等及众弟子诸大声闻。从本以来不能见我。天眼之德为何等类。亦无能当巍巍之明。舍利弗又问族姓子。说所见形像为何等类。而言我等本来未睹。金刚脐曰。耆年曾见住于坚固金刚世界及执慧曜如来至真。舍利弗答曰。今日造闻彼世界名。何因得见。金刚脐曰。唯舍利弗。如是等类。不可称计诸佛国土及众菩萨人民众生。各各异趣所生不同。菩萨大士则以天眼。皆悉见之无有遗脱而不遍者。一切缘觉虽有天眼所不能睹。何况声闻而能及见乎。说是语时。有六万人。曾求声闻缘一觉乘。欢然大悦。寻发无上正真道意。同时发声如嗟叹言。令吾等身得佛法眼。不用声闻及缘一觉之天眼也。荫蔽挂碍。佛之法眼无有限齐。亦无所碍。于是金刚脐菩萨。即如其像。三昧正受建立感应。而现神足佛之圣旨。金刚脐菩萨。威德之变。宿福善本巍巍之力不可称限。普令一切诸来会者。皆共目见六十亿垓诸菩萨众。在于佛身。各处莲华结加趺坐。叉手听经。不近佛身。亦复不远。皆是如来弘恩无极之感应也。又世尊身不增不减无所挂碍。悉现如故若前不损。一切众会惊喜踊跃。得未曾有。一心叉手礼佛而立。各各叹言。难及难及。诸佛世尊。身形广长威圣无量。神变功德不可称限。乃能容受六十亿垓。在于佛身而坐听经。见本圣之体不增不减。时金刚脐菩萨。普察众会而举声告。以是之故当共知之。如来至真等正觉身。则为法身广长无极。无有相好而不方圆。身无边际不可度量。如来至真发意之顷。欲令三千大千世界诸有众水大海江河川流泉源国土州域丛林草木诸山土地。悉入佛身不增不减。悉现如故。又诸贤者。诸无央数亿百千垓诸佛国土众菩萨等若千万数。遥睹世尊微妙光明相好清净无有尘垢。咸皆发来欲见圣尊咨受经典。悉为天下。劝诸天人民释梵四天王。使蒙拥护。令得自归故往听经。设不来者。不见道变不能发心。佛欲开化度众生故。是以如来。取诸菩萨着于身内。而听受法不见挂碍。无所疑难。或有菩萨住于地里。入宝交露。而自省见坐于莲华。皆佛威神之所感动。道德高远巍巍难量。时诸菩萨承佛圣旨及金刚脐至愿威力。六十亿垓一切同时皆从大圣毛孔中出。稽首佛足右绕七匝。各以威德神足之力。化微妙床身处其上

于是金刚脐菩萨前白佛言。唯然世尊。无言菩萨何故字无言。佛言。汝自以是问于正士。当为汝说。时金刚脐问无言曰。仁族姓子。何故自号为无言耶。无言默然。如是问三。亦不答报。时金刚脐复重问曰。何故三问而不相答。无言答曰。我求此辞永不得处。以是之故不相答耳。又于族姓子。理不宜问于无言者。用何以故而字无言。计其无言则无辞说。亦无音声。金刚齐又问。设无有言。今何以故口有所说。无言答曰。吾悉法效诸佛所说。亦复效于众生所语。又问。云何法于诸佛所说。答曰。如一切佛所讲经法。吾以意力承其威神。亦复如之。以是之故。吾今悉法诸佛所说。假其音声而等文字无所毁坏。演说经法。是为法于诸佛所说。又问。云何复效众生之言。答曰。随一切人众生之类音响言语。而为说法。是为效于一切众生人民所言。又问。卿族姓子。失言以来为几何乎。答曰。从失心念以来。又问。族姓子。此言何谓。答曰。以是之故不亲心念。亦非不乐。心无所念口则无言。又问。族姓子。言从何出。为从心出从身出乎。答曰。不从身出。亦不从心出。所以者何。身非常存不得自在。其心如幻。以是之故。不从身出亦不从心。又问。为从何出。答曰。设欲问之。所讲言辞为从何出。为从空出。空无有色亦不可见。今仁问吾。为何由乎。曰实因于空无见无像。答曰。是故族姓子。言如虚空而不可见。所问亦如其所言辞。亦如虚空而不可见。虚空如是永不可睹。亦无有相。以是之故。求一切法及所言辞。都不可得。如求言辞不可得者。一切诸法寂寞澹泊。论语音辞亦复如是。一切诸法亦如人言。忽不知处。言如虚空无能见处。一切诸法亦如虚空。亦无处所。所言辞者因缘合成。一切诸法亦从缘起。推求诸法根源所在。缘从何起而不可得。其不可得则无所起。便无所生。又无所起则无所兴。其无所兴者则无所发。其无所发彼无眼迹亦无色迹。亦无识迹。亦无耳鼻口身意之迹。亦无法迹。无意识迹。其无迹者无去无来。无去来者名曰独步。其独步者则无所去。于一切行而无所见。当作是观。宁当睹见本所不见乎。又问。本何不见。答曰。不生不起。又问。云何不生不起。答曰。所不可察无有来者。又问。何谓所不可察无有来者。答曰。虚空不可见。无有来者。虚空平等。一切诸法亦等如空。以是之故。诸法平等亦如虚空。故曰不遍一切诸法等如虚空。又问。何谓诸法等如虚空。答曰。无有侣故。以用诸佛平等之故。一切诸法究竟平等。过去本等。来本亦等。中本亦等。无有分别。计此诸等。以一切诸法本际。如是如真。本际无本。本际如真。本际如审。本际无本。本际等无有异。是则名曰无有二际亦无若干。何谓言二。用计吾我则名曰二。若不贪身不计吾我。则无有二。何谓有二。有眼有色则名曰二。耳声鼻香舌味身更意法。是名曰二。取要言之。若有计着一切诸法。故名曰二。从使有二亦不可得。所以者何。观无所此得则无二。亦无言辞。其法心意及所有识。假使不修于此三事。是名无二。此之无二不当讲说。所以者何。有所说者不离于二。无所言者乃无有二。又问。所云无二谁为造二。答曰其无二者不可造二。所以者何。正使兴发若干方便。欲变无二使有二者。终不可辩。又问。所说法律为是二乎为无二耶。答曰。其法律者无有二也。坚固难移。所以者何。无言乱相亦无所御。以无言说而开导之。无能破坏。不可毁缺用不可坏。是故名曰坚固导御。则无有二。于是金刚齐菩萨前白佛言。唯然世尊。无言菩萨所可宣畅。皆是慧明三昧勇猛之恩德也。佛言。汝所言皆慧明三昧之威恩也。尔时执慧曜国土诸菩萨来者。问于无言。仁族姓子。为学何法。辩才之慧巍巍无量乃如是乎。无言答曰。如佛所说。一切诸法皆从诫立。又复问曰。唯族姓子。宁可垂意顾愍我等。分别敷演建立诫者。答曰。贤者其不住身。不住口心。是为立诫。不住内外亦无中间。是为立诫。若无思想无所惟念。及与教令言辞之事。是曰立诫。无应不应。无念不念。亦无异念。是曰立诫。不住于善亦无不善。不处于世亦不度世。无在不在。无害不害。无漏不漏。无为不为。无生死无灭度。此曰立诫。假使建立如是比像。住于诫者。于一切法则无所住。不住诸法。不作是念。吾有所说宣畅分别。是故贤者。是名曰诫。有所说者则住于二。其真本际。及其住处并至无本。又法界处。吾以住彼而有所论。有所论者永不可得。斯所语者亦无所念。其所宣畅亦无所想。又问。族姓子。其不可得无所念者及无所想。有何言说。答曰自然之数而不可获。亦无所念无有思想。自然说之。又问。其所辞者谁为说之。答曰。贤者吾所辞者。即时灭尽亦无所生。所以者何。向者诸所讲法皆归于尽。一切诸法悉无所生。所生法不可知处。现在有形悉无有形。不可得处。所以者何。斯闲尽而无诸相。其本际者无有言教。故世尊曰。不可想像取过去心。当来现在亦复如之。即起即灭碎散消尽。卒暴易转。不可捉持形像何类。彼欲取想着念虚伪。倚受思想悉如化幻。是故推极一切所言。悉虚无实其义无获。亦不可以有所讲说。不可口宣若心念矣。所以者何。无所造作亦无所行。其有解识兴趣此义。则不复用口之言辞。亦不以心有所念也。有所宣畅分别说者。犹如呼响音声之报。如化如来有所颁宣。其人所讲亦复如兹。是为诸佛及众菩萨一切世人所可保义。不可思议。善权方便无能制止。辩才之辞所建立法。不可动移。时诸菩萨赞无言曰。善哉善哉族姓子。快说斯言。是入法门我等亦闻。所归于门实无有门。等如虚空。其佛世尊及诸菩萨。现说如是。吾等所受亦复如此

于是金刚齐菩萨问无言曰。来族姓子。俱共往至住于坚固金刚根世界。见执慧曜如来至真等正觉。观彼国土。无言答曰。又族姓子。斯闻则是住于坚固金刚根世界。执慧曜世尊亦复在此。吾身何为舍此就彼。金刚齐问曰。今此世界泥土所成。非为金刚。无言答曰。汝族姓子。发意之顷。越恒沙等诸佛国土。通过铁围无所蔽碍。为能堪任取是佛土举一土尘。不尔乃当知而此世界泥土所成。无言菩萨。寻声则以金刚道场三昧正受。应时于此三千大千世界自然化成。甚大坚固不可伤毁。悉为金刚。于是金刚齐。作大威力兴显神变。被大坚固诫德之铠。欲举此地一土之尘而不能胜。心自念言。怪未曾有。为是大圣之所建立巍巍之变。斯是无言之所感兴。前白佛言。唯然世尊。我者前时发心之顷。通过铁围大铁围山。越恒沙等诸佛国土。今者欲举于此土地一土之尘而不能胜。唯天中天。此谁威神之所兴立。是天中天。慈恩圣旨。为是无言之所变动乎。佛言。无言菩萨之所建立也。所以者何。无言菩萨。金刚道场三昧正受。使此三千大千世界甚大坚固。不可毁缺悉成金刚。若有菩萨住是三昧。自恣其意。欲变几何诸佛国土悉成金刚。辄如所志。智慧圣心兴显道德。以是三昧而以正受。令诸佛土悉成金刚无能毁触。皆是三昧威神境界。于是金刚齐及其所从六十亿垓菩萨前白佛言。菩萨行何法。乃能逮得金刚道场三昧。佛告族姓子。菩萨有四法。逮得于此金刚道场三昧。何谓为四。一曰持志坚如金刚。常怀道心超越一切诸功德本。二曰性行具足无央数劫修治方便庄严大业。三曰入于深法分别十二缘起之原。四曰圣慧备悉无所缺漏。是为四。复有四而自欢娱。何谓为四。一曰超度慧德具足五通。二曰空无相愿一心脱门。三昧正受心不戏逸而自娱乐。三曰建立于戒而住法界。所处无源成就慧明。四曰究竟至诚如深之义。晓了经义寂灭诸法靡所不达。复有四。何谓为四。一曰遵于大哀修四梵行。二曰奉行般若波罗蜜及六度无极。三曰行善权方便三十有七道品之法。四曰为诸众生修诸脱门及四圣谛。是为四。复有四。何谓为四。一曰身所造业犹如金刚。二曰口之所言清微柔和亦如金刚。三曰执心坚固不可动转亦如金刚。四曰志性秉毅不可毁坏。是为四法。菩萨所行速疾逮是金刚道场三昧。说是语时。是诸菩萨寻即获此金刚道场三昧。于是无言菩萨自白其父师子将军。大人岂见诸佛兴出。德馨之称威圣无量。道慧高远超绝无侣。得未曾有难及难及。如是比像不可譬喻。本所悲忆今悉现矣。为无央数众生之类。导示灭度至于大安。惟愿大人。发于无上正真道意。师子将军报无言曰。子当知之。生七日后天来相令而见告语发大道意。佛天中天。道目所观知我志操。其心夙夜念于佛道。无复异师发心可归。惟当归命无极大圣。师子将军及正夫人。男女内外亲属五百群从。皆发无上正真道意。无言菩萨自报父母兄弟姊妹及其亲族并大众人。仁者今日以发大意。当精进行庄严道心。即时问言。何谓发意庄严道心。无言答曰。有四十事庄严道心。何谓四十事。至信佛道心不疑毁(一)。喜乐于法而令久存(二)。不慢圣众恭敬谦逊(三)。常当习善友(四)。见诸菩萨视之如佛(五)。未曾怀害向于众生(六)。恭敬奉事尊长众祐(七)。等心爱憎(八)。入法无厌(九)。勤听经典(十)。闻趣尊习(一)。为他人说(二)。无希翼心(三)。法无有师(四)。所念如应(五)。奉行无本(六)。一切所爱而不珍惜(七)。奉顺禁戒未曾缺漏(八)。宣畅分布忍辱之力(九)。所行精进靡不周遍(二十)。令备修习禅定一心而顺念于智慧之品(二)。以权方便开化众生(三)。所可劝助未曾忘舍(四)。随护群黎(五)。自调其心降伏他意(六本阙一法第七)。于欲教授不着尘劳(八)。常弃愦闹乐于寂静(九)。思处闲居以为德称(三十)。修贤圣行而知节限(一)。常行止足不可动移(二)。在于俗法不与同尘(三)。而以顺从六坚之法(四)。又不舍废于四恩行(五)。而常奉遵坚固志愿(六)。恒不毁失善德之本(七)。所学业者而不放逸(八)。不乐小乘(九)。道心无动(四十)。笃信微妙志不怯弱。舍一切恶无所犯负。皆悉具足一切功勋。合集名称无量福会。怀佩道法处于道场。而不退转是为丈夫四十事行。显发一切诸通慧矣。珍宝道心。以此功德而自庄严。发意之顷三千大千佛之境界所兴德本悉现目前不复远求。譬如日殿处于虚空靡所不曜。师子将军报其子曰。正士汝当数数往来念亲相见。因告示诫将济拥护。令不退转究竟无上正真之道。无言答曰。大人欲知。复有十法菩萨所行。诸佛大士所见常念。何谓为十。恒行精进欲安众生。不念己身独获大安。身力坚强多所诱进。见羸弱人而以慰喻。所造德本皆以放舍施一切人。未曾怀忧。所可化人劝发道者。被大德铠而自誓愿。此诸众生若得佛道受于正法。当以供养而奉事之。然后我乃取最正觉。用正法故没弃身命。不舍正典。宣畅分别一品之义。于百千劫流布一切。被大德铠不以懈惓不怀怯弱。一切诸法皆悉本净。设闻此言不以恐惧。不限大道。不舍佛法。不以为空。所观睹者适知不虚。等于吾我亦等众生。已等众生则等于法。以等经法则便信乐。虚空平等不堕止观。不复堕落生老病死恼患之径。为诸世间所见动转。无央数众勤苦瑕秽。诸魔波旬所可兴者来说众难故诫诽谤。佛道难得。经法难遇。不如早求声闻而速度矣。菩萨闻此。坚持一心发无极志。不以懈厌。不退不转。不舍大乘。住于真正审谛之法。言行相应未曾虚妄。身行至诚不欺己身。诸天众生及十方佛。是为大人十法之事。菩萨所行则为诸佛及诸正士所见常念。说是语时。师子将军及与眷属。寻时逮得柔顺法忍

尔时世尊告贤者何难。受是经法持讽诵读。具足广普为他人说。所以者何。过去当来今诸佛大圣道德所兴。皆出是法经典藏门。无言菩萨今来至此。思惟真谛宣畅于斯无量法门。劝化无数一切人民。令学佛道也。是故阿难。欲奉过去当来现在诸佛世尊启受法藏。当奉此经怀抱在心。广为人说是法藏门发无央数众生人民。使成佛道。如来在世灭度之后。假使有人受此经者。悉是佛旨建立所致。持讽诵读行如上教。佛语阿难则有三事福不可量。何谓为三。一曰将护正法。二曰身知道心。三曰未发意者劝发道心。是为三。功德之福不可限量。假使如来叹其功勋而不可尽。何况声闻。尔时会中有七亿垓诸菩萨众。闻佛所说皆从坐起。欲护正法。各各说言。我等辈类。当共奉持世尊正典广远流布。持此经卷为他人说劝发道意。无言菩萨前白佛言。唯然世尊。所可解畅建正觉者。彼法宁可受取持乎。佛言不也。又问。佛言。以何等故。诸族姓子。向者佛说此。诸菩萨悉起住立。欲护正法。佛言。吾以将育诸族姓子故。以是像欲有所护。彼无为事不可得法而为颁宣。因文字教言护于法将顺其意。所言护者。不以言问。不用文字而行道也。是则名曰护于正法。又族姓子则有二事护于正法。何谓为二。一曰不可得者乃逮正法。所当拥护常将顺之。不以所说而拥护也。二曰亦不将济于诸虚妄。闻所说者即能奉行。不以慢恣求于名称。是为二。时诸菩萨欲供养佛无言菩萨及此经典。普雨天华散于佛上及诸菩萨。周遍大会。口宣此言。愿令世尊释迦文尼久在世间。使此经法自然流布遍阎浮利。佛说如是。无言菩萨师子将军与诸群从金刚齐菩萨及六十亿垓诸菩萨等舍利弗大目揵连阿难诸天世人阿须伦。闻佛所说莫不欢喜

无言童子经卷下


佛说虚空藏菩萨神咒经

    No. 406 [Nos. 405, 407-408]

佛说虚空藏菩萨神咒经

如是我闻。一时佛在佉罗帝耶山仙圣住处。与无数大比丘众俱。大菩萨众数如恒沙无量无边。演说如来功德经已。尔时西方有如意宝珠。自然而现。百千释迦毗楞伽宝珠以为眷属。彼如意宝珠所出光明。皆悉瞙彻。此间人天声闻菩萨所有四大光明色像皆灭无余。唯除如来及如意宝珠。其余皆与无量无边不可言说虚空同相

尔时世尊光色益明。时会众生各不相见。亦不得触身色形相其所视方不见日月星宿光明。眼不见色。耳不闻声。鼻不嗅香。舌不知味。身不觉触。心心数法无我我所。唯见如来色相光明如意宝珠。在会菩萨住十地者。得首楞严三昧者。一生补处者。最后身者。心不怖畏。何以故。以解诸法真如宝相第一义空故。其余菩萨诸声闻众天龙夜叉阿修罗紧那罗呴槃荼毗舍遮富多那迦吒富多那人及非人诸来会者。皆悉惊怖。或于此彼不相知见。是何事乎无咨问处

尔时会中有菩萨摩诃萨。名曰梵音。从坐而起合掌向佛。而说偈言

  诸法真实义　　众生不能知
  愚于六根中　　贪着色阴故
  以不见一阴　　推求于色相
  今有如是众　　疑惑于佛法
  唯愿佛世尊　　为说真实相
  得解于此彼　　速证如空忍
  禅定勇猛士　　不可论说身
  如意摩尼宝　　在顶而显现
  释迦楞伽宝　　相去亦不远
  彼来诸众生　　勇健到彼岸
  皆有大智慧　　欲来见世尊
  必说甚深法　　决定无有疑
  唯愿佛世尊　　安慰诸来众
  成就于众生　　大士之所行

尔时世尊便说偈言

  如汝之所说　　三昧力所为
  其有智慧者　　乃得闻是事
  虚空藏菩萨　　大士之所行
  无依无戏论　　三昧力如是
  坚住于二见　　愚惑之所行
  以着断常故　　不解于此彼
  若于此二见　　欲得解脱者
  不应着诸欲　　速得证诸地

佛告梵音。善男子。初行菩萨。先当为说有缘想行六波罗蜜。若能解知四大之性是生灭法。然后为说一切诸法不可言说。无有自相不生不灭无缘无所有。一切诸行皆悉如是。能如是观则离断常亦无怖畏。于一切法无缘无触则能速满六波罗蜜。亦复不着断常诸见。佛神力故令此大众诸来会者。见闻觉知皆悉如前

尔时世尊。即举右手告大众言。虚空藏菩萨今从彼来。而此菩萨禅定如海。净戒如山。智如虚空。精进如风。忍如金刚慧如恒沙。诸菩萨幢。趣涅槃者导。善根河池。贫者宝瓶。闇冥者日。失道者月。怖畏者山。烦恼病者良药。净诸见水摧诸魔怨。犹如霜电治。破戒者如安阇那药。诸善根地。众华中鬘。照恶行者镜。无惭愧者眼。病者良医。疲懈者床坐。能充饥虚如尸利天能除渴乏。如月爱珠。照禅定者如日爱珠。行菩提道者车。游戏禅定者池。修助道法者华鬘。行诸波罗蜜者妙果。照十地者如意宝珠。覆住首楞严三昧者如波利质多罗树。断诸见结如利刀。除去习气如金刚。能伏魔怨智如猛火。其身即是诸佛法器。缘觉华鬘声闻衣服。诸天眼目人之正导。畜生所依饿鬼所归。地狱救护众生法器。菩萨般车三世诸佛辅佐守法城门。已能庄严佛十八法具一切智。彼族姓子应受一切众生最胜供养唯除如来。汝等诸来会者皆应往近。随其意力供养。恭敬尊重赞叹。以种种珍宝宝幢幡盖华香璎珞。净治道路而严饰之。汝等不久亦当得成如是法器。时会一切诸来大众皆从坐起。叉手合掌向虚空藏菩萨所来方面。欣喜敬礼瞻仰无厌

尔时会中。诸大菩萨摩诃萨。及大声闻天王龙王夜叉王阿修罗王迦楼罗王紧那罗王摩睺罗王五通诸仙皆作是念。我等当以何等最胜供具奉献供养彼族姓子。尔时虚空藏菩萨摩诃萨即变此娑婆世界。无有山陵旷野堆阜沟壑。除去臭秽风尘恶声。化生七宝诸树华果出微妙香。依地草木皆成七宝。一切众生所有病苦及地狱苦皆悉除灭。衣服饮食诸庄严具随意满足。身色端正诸根完具。无有烦恼其心寂静。乐修善根深信三宝。诸来会者一一众生两手皆有如意宝珠。一一宝珠皆出光明遍照娑婆世界普令大明。出妙天乐种种音声。雨种种天衣璎珞华果。多摩罗跋牛头栴檀碎末杂香盛以妙器。其道两边化作宝堂犹如帝释毗者延堂。其堂皆有端严天女。如第六天王胜妙婇女作天伎乐。世尊顶上虚空中有大宝盖。纵广一百由旬。众宝庄严如梵华盖。诸宝罗网金缕真珠。以为间错皆出音乐。地生草木华果枝叶亦出天乐。其音皆演大乘正法六波罗蜜。众生闻者皆得不退阿耨多罗三藐三菩提。时会大众见虚空藏菩萨现大庄严。心生欣庆得未曾有。皆作是言。我等当以何物于世尊前敷置法坐。令彼族姓子而坐其上。尔时佛前有大莲华自然而出。纵广十里白银为茎黄金为叶马瑙为台梵光宝为须。复有如是百千莲华而围绕之。虚空藏菩萨于莲华上结跏趺坐。顶上有如意宝珠。虚空藏菩萨所将眷属皆悉坐于莲华之上

尔时弥勒菩萨即以偈问药王菩萨。昔来诸菩萨有大名称者先礼佛世尊

  然后乃就坐　　今此大士众
  现妙庄严事　　亦不礼世尊
  辄便就于坐

尔时药王菩萨摩诃萨以偈答弥勒菩萨摩诃萨

  今此大士者　　已住佛深法
  不见有众生　　不分别己身

弥勒菩萨复以偈问

  若不见众生　　必住于实际
  何故现庄严　　愿答以决定

药王菩萨复以偈答

  勇猛方便者　　欲成就众生
  凡愚分别行　　不解真实义
  唯知于世谛　　不达真故苦

尔时世尊告族姓子。善哉善哉。如汝所说。一切凡夫不能知一须陀洹所行方便及以解脱。假令一切众生是须陀洹不能知一斯陀含所行方便及以解脱。如斯陀含阿那含阿罗汉不能知一辟支佛所行方便及以解脱。一切众生皆是法伽劫。辟支佛不能知。一得无生法忍菩萨摩诃萨所行方便成就众生及以解脱。一切众生皆得无生法忍。不能知一得首楞严三昧诸无碍智通达第一义菩萨摩诃萨所行方便及以解脱。此虚空藏菩萨摩诃萨已过无量无边劫得无生法忍诸无碍智首楞严三昧通达第一义。悉能知此诸来会众心之所行及诸烦恼。或有众生见大庄严微妙之事皆得住于离欲之地。是族姓子于彼处没而来此间现。如虚空神通智慧三昧令诸众生生厌离心。然后复现世谛庄严三昧。令无量众生得成就如是三昧。不与声闻辟支佛共。若彼族姓子现第一义无生庄严者。一切人天乃至八住菩萨皆生惊疑。而不能知所行相貌。如是甚深佛法功德。彼族姓子以方便智于一切佛法海中。心无有疑不由他知一切菩萨摩诃萨秘密法中。犹如胜幢能示众生善道及涅槃道。能治众生烦恼心病及以身病。有诸众生于生死旷野为邪见所没。而不能知趣向善道及涅槃方便者。常应深心称虚空藏菩萨名号。礼拜恭敬烧阿伽楼香而供养之。彼族姓子。视其染心及以烦恼。随彼烦恼诸见愚痴及先善根调伏之心。若于佛所法所僧所而种善根。或行布施福业持戒福业修定福业。随其所应若梦若寤。以大方便示其正道。以正方便故速离邪见邪行邪愿邪心邪趣。令彼众生身口意正行正愿。善友速能消除秽恶烦恼离诸恶趣。不坏善因心得自在住甚深忍。若有众生种种身病颠狂心乱。眼不见色口不能言身分坏者。当以深心称虚空藏菩萨名号。为除病故烧阿伽楼香若多伽楼香。礼拜供养。彼族姓子。于其梦中现梵天众若帝释象尸利天象。若萨罗婆沙帝天象若刹帝利象。若大臣象若父母象。若男女象。在其前立。随其所应示所方药及所须物。令彼病人因此一方病灭无余。若有劝导求财物者学问求多闻者。坐禅求智慧者求名誉者。求巧术者求聚落者。求尊贵者求色力者。求种族者。求音声者。求男女眷属者求布施持戒乃至智慧者。求妙音声令众乐闻者欲远离恶者。欲令他住布施乃至住智慧者。欲得长寿者欲得资生无亡者。欲令悭吝者修舍毁戒者。住戒懈怠者精进邪慧者。正慧未住乘者住乘自求乘者为他求乘者。无大悲心者不自为身但为众生。以何方便令此众生于阿耨多罗三藐三菩提不退转。住大方便四无量心。应当礼拜恭敬虚空藏菩萨。若于空处若园林中。烧多伽楼香若迦荼阿菟罗香。合掌归向敬礼十方。礼已应说是咒

啰[可*丁]侄他　阿弭唎铄　阿弭唎铄　迦噌奶迦(上)柘(上)罗(上)柘罗毗(上)柘(上)罗(上)珊柘(上)罗迦噌奶(奴绮反余同)迦(上)曷啰(上)磨啰(上)曷啰(上)磨啰(上)毗(上)伽(上)阿唎磨磨法(上)菩(上)噌阇(上)磨那(上)迦噌奶迦(上)真多磨奶(奴绮)车啰(上)夜迦噌奶迦(上)娑(上)啰(上)皤奢(尽何)迷娑(上)他跋夜　阿贤禳(如何)阿唎娑(上)[湖-古+目](眀曾反下同)共(翟栱反下同)娑(上)[湖-古+目]共(音同上)户噌底(都弥反下)毗(上)[卄/豍](父迷)伽(上)共(同上)提(徒尔)唎瑟知(上)[壹*(支/早)]伽(上)共(同上)迦噌儞迦(同上)连唎夜睹磨阿奢(同上)夜娑(上)啰(上)皤跋陀(上)柘(上)阿(上)输迦(上)伽(上)底娑(上)婆诃

若能如是诵持是咒。彼族姓子。若作人形若鸟兽形。以示其人。随彼福德。而为说法示一方便。以一方便能令百千那由他众生来住乘者。或住声闻辟支佛乘。以少时方便令住不退无上大乘。得种种三昧诸陀罗尼诸忍诸地。彼族姓子有不可思议大方便智成就大悲。或有众生能量虚空分齐无有能量。虚空藏菩萨大方便智大慈大悲禅定三昧力成就众生者。彼族姓子成就如是不可思议诸善功德。若有众生其心质直无有谄曲。安住正见不自高身不他人。离于悭嫉无有虚伪心清净者。彼族姓子起怜愍心。教令精进示正方便。令彼众生以是方便精进力故。离诸衰患能发阿耨多罗三藐三菩提心。回一切善根于阿耨多罗三藐三菩提不退转。以此方便精进力故能遍满足六波罗蜜。勤行精进疾成阿耨多罗三藐三菩提。虚空藏菩萨成就如是不可思议功德勤行精进成就众生尔时弥勒菩萨白佛言。世尊。何因缘故彼族姓子顶上独有如意宝珠。余菩萨无邪。佛告弥勒。彼虚空藏菩萨成就大悲。于诸苦危犯根本罪趣向恶道烧灭善根而自毁。怀于此众生是大良药住。黑暗众生为作大明犹如日照。若有众生犯根本罪。疑箭在心破坏法器。永堕弃损丧失善根。必堕恶趣无归无依智者所弃耶恶众生。彼族姓子能示正道。除灭烦恼令离恶趣。若有众生贪欲嗔恚愚痴多者。言无因果不畏后世。积聚无厌常行贪嫉。乃至专行十不善业。亦教他行。彼族姓子犹如船车能示善道及涅槃道。是故彼族姓子。唯除如来。一切世间人天皆应供养

尔时弥勒菩萨白佛言。世尊。何等是根本罪。若有众生犯根本罪。烧灭善根趣向恶道。永堕弃损离人天乐。彼族姓子云何除罪。以善道乐及涅槃乐而充足耶。佛告弥勒。刹帝利王有五种根本罪。若刹帝利王犯此罪者。烧灭善根趣向恶道永堕弃损离人天乐。何等为五。刹帝利王若取佛物招提僧物。若教他取。是名初罪。谤声闻法谤辟支佛法谤大乘法。为作留难隐蔽覆藏。是第二罪。若有信心出家。剃除须发身着染衣。或有持戒或不持。戒。脱其袈裟逼令还俗。或时系闭或加杖楚。或断其命。是第三罪。若作五逆。杀父杀母杀阿罗汉破和合僧恶心出佛身血。于此五业若造一业。是第四罪。谤无因果不畏后世。常行十不善业亦教他行。身自坚住教他坚住十不善业。是第五罪。若刹帝利王于此五罪若犯一罪。是刹帝利王烧灭善根趣向恶道永堕弃损离人天乐。彼族姓子为是人故。于离车出现身受生。或作沙门形象威仪。或作婆罗门形象威仪。为刹帝利王说。一切智所说甚深未曾有。修多罗经诸陀罗尼诸忍诸地。令刹帝利王发露忏悔修戒。闻定慧勤行精进得生善处。大臣辅相有五种根本罪。何等为五。大臣辅相若取佛物僧物。是名初罪。若破坏城邑聚落毁害人民。是第二罪。诽谤正法如上所说。是第三罪。毁出家人令其苦恼如上广说。是第四罪。于五无间若作一业。是第五罪。大臣辅相于此五罪。若犯一罪如上所说。声闻弟子有五种根本罪。何等为五。一者杀。二者盗。三者淫。四者妄语。五者恶心出佛身血。声闻弟子于此五罪。若犯一罪如上所说。初行菩萨有八种根本罪。毁坏大乘烧灭善根趣向恶道永堕弃损离人天大乘之乐。久住生死离善知识。何等为八。此诸众生以恶行故生此险恶五浊世界。以少善根故近善知识得闻甚深大乘经典。其人浅智善根微薄。发阿耨多罗三藐三菩提心。初行菩萨闻说甚深法空经典如其所闻受持读诵。为浅识者随其所闻义而为演说。彼人闻法心生怖畏便退阿耨多罗三藐三菩提发声闻心。此初行菩萨犯根本罪。以犯罪故烧灭善根趣向恶道永堕弃损离于人天涅槃之乐毁菩提心。是故菩萨应当先知众生心行然后渐次而为说法。譬如入海渐渐转深。为此人故虚空藏菩萨处处受身。令初行菩萨随所犯罪畏堕恶道。若闻虚空藏菩萨名号。闻已欢喜欲得睹见忏所犯罪。于夜后乃烧阿伽楼香多佉罗香。合掌恭敬称虚空藏菩萨名号。彼族姓子。随其所应现种种身。或现自身或梵释身乃至现男女之身。在其人前即令初行菩萨随其所犯忏悔除罪。亦复为说无上大乘甚深方便三昧陀罗尼诸忍诸地。令离恶道怖畏不退阿耨多罗三藐三菩提。发大精进犹如金刚。行六波罗蜜速证阿耨多罗三藐三菩提。虚空藏菩萨若不现身应当求请阿楼那天。作如是言。南无阿楼那天。成就大悲有大威势菩萨现时。光明照曜遍阎浮提并照我身。愿以我言白虚空藏菩萨。便我梦中而得见之示我方便令我忏悔根本重罪。得摩诃衍智慧圣眼。尔时应当眠寝本处至阿楼那出时。虚空藏菩萨为初行菩萨梦中现身。为说大智方便令其悔罪。亦不忘失菩提之心逮得三昧坚住大乘速满足六波罗蜜。不久当得阿耨多罗三藐三菩提。是名初行菩萨第一之罪

若初行菩萨语众生言。汝于大乘不能善修般若波罗蜜。亦复不能得成阿耨多罗三藐三菩提。汝应速发声闻辟支佛心。汝可速得出离生死。余如上说。是名初行菩萨第二之罪

复次若初行菩萨说众人言。汝何为坚持波罗提木叉戒。应速发阿耨多罗三藐三菩提心。读诵摩诃衍经。若以烦恼故起身口意不善业不者。皆当除灭不受果报。余如上说。是名初行菩萨第三之罪

复次若初行菩萨语众生言。族姓子。汝不应听受声闻经法应当覆藏。何以故不能令汝得大果报。永断烦恼应当听受摩诃衍经。令汝恶行一切消灭。速证阿耨多罗三藐三菩提。若彼众生受是见者。犯根本罪。是名初行菩萨第四之罪

复次若初行菩萨为名利故。读诵解说摩诃衍经。作如是言。我是摩诃衍人。见他得利心怀嗔恨。自高其身卑下他人。以嫉妒故自说己身得过人法。是人于摩诃衍中而犯重罪趣向恶道永堕弃损。犹如有人欲入大海。修治船舫欲至宝所。中路船坏丧失身命。初行菩萨亦复如是。欲入摩诃衍海以嫉妒故而作妄语。毁破信船断智慧命。是摩诃罗凡小菩萨犯根本罪。是名初行菩萨第五之罪

复次族姓子。未来世中当有出家在家初行菩萨。受持读诵甚深空义。三昧陀罗尼诸忍诸地。大人所行诸庄严事。大乘经典。作如是心。为他解说此诸法者。是我所证我令以大悲故为汝解说。汝应修习汝亦不久于此深法当自知见。彼人不言我但读诵此甚深法为他解说而实未证。忘说己身得三世诸佛菩萨摩诃萨诸贤圣人量过大海所证之法犹如有迳过旷野饥渴所逼。甚大疲乏趣彼树林树。求索饮食舍甘果树往趣毒树。食其果实即便命终。我说此人亦复如是。得难得身值善知识遇大乘法。贪利养故虚自称举卑下他人。如是之人。犯根本罪趣向恶道。永堕弃损智者所贱。是人不应亲近刹利波罗门毗舍首陀罗及诸智人。若亲近者皆悉犯罪是名初行菩萨第六之罪

复次族姓子。未来世中刹帝利王。有旃陀罗国师宰相辅佐大臣旃陀罗医。又有愚痴自谓明智。起大憍慢。如是等人多饶财宝广修种种布施福业。持布施故憍慢放逸向刹利王说。诸沙门种种过恶。亦向沙门说王过恶。国王力故谪沙门侵夺财物。时诸比丘为彼所逼。便取佛物招提僧物及己身物而用与之。诸栴陀罗得是物已。以上王如是之人。俱犯重罪是名第七之罪

复次未来世中有恶国王。旃陀罗沙门。非法是法。舍修多罗毗尼正戒。亦复不依黑印大印大悲导师所说。般若波罗蜜戒。及余修多罗中善方便戒。更作异法造新制限。恼乱行法比丘。以恼乱故不能修习。毗婆舍那及舍摩他多行学问欢作众事。行是业故不能制伏诸结烦恼。是诸比丘既失善心又破威仪所行怠慢。实非沙门。自称沙门。不修梵行自称梵行。无所忌难高声言论。犹如具音善能说法。令刹利王大臣辅佐恭敬供养。向诸白衣妄说行法比丘种种过恶。令王大臣起嫌责心取行法比丘资生之物回与居家比丘。如是之人俱犯重罪。何以故。禅定比丘是良福田。是三昧陀罗尼。诸忍诸地之器。演说正道能作照明。度脱众生烦恼诸业。佛为不具法初行菩萨。说此八根本罪。初行菩萨于此八事若犯一罪。是初行菩萨烧灭善根趣向恶道。永堕弃损离人天乐。毁菩提心。虚空藏菩萨为是人故。于诸方土处处现身。或现沙门形相威仪乃至畜生形相威仪。广说如首楞严经处处为诸众生解说如来甚深修多罗三昧陀罗尼诸忍诸地。令彼犯罪无方便慧。初行菩萨心生惭愧。深怀怖畏发露忏悔。若诸众生闻虚空藏菩萨名号。欲得都见忏悔重罪永得除灭恶道畏者。应当礼敬称虚空藏菩萨名号。彼族姓子。随其福力。或现自身。或现梵释身乃至现男女身。在其人前。令初行菩萨随所犯罪而得忏悔。亦为演说无上大乘甚深方便三昧陀罗尼。令其坚住诸忍诸地。永得远离恶道怖畏。于阿耨多罗三藐三菩提而不退转。有大精进勇猛之力。犹如电光修行六波罗蜜。速成阿耨多罗三藐三菩提

若彼族姓子。不为现身令得见者。彼若有罪。初行菩萨于夜后分向于东方烧香礼拜求请阿楼那天。作如是言。南无阿楼那天。成就大悲有大威势。若出现时。光明照曜遍阎浮提并照我身。愿以我言白虚空藏菩萨使我梦中而得见之。示我方便令我忏悔根本重罪。得摩诃衍智慧圣眼。尔时应当眠寝本处。至阿楼那出时。虚空藏菩萨为初行菩萨。梦中现身为说大智方便。令其悔罪永忘失菩提之心逮得三昧坚住大乘。速满足六波罗蜜。不久当得阿耨多罗三藐三菩提。以有如是精进勇猛不可思议大功德故虚空藏菩萨顶上有此如意宝珠

复次族姓子。若有众生闻虚空藏菩萨名号。图画形像而供养者。其人所生之处。火不能烧。水不能溺。兵刃不害毒。不能伤人。与非人无能侵害。终不横死。王事不加不犯根本重罪。无有疾病。亦不饿死。命欲终时乃至眼不见色。耳不闻声。鼻不闻香。舌不知味。身不觉触。犹有微细出入气息。身少识在乃至最后微识。尔时虚空藏菩萨即为现身。若此众生先事梵天现梵天象。先事魔王那罗延天摩醯首罗释提桓因转轮圣王日月天子提头赖吒乃至毗沙门王随其所事。于彼人前示现其身。而说偈言

  如是四圣谛　　智慧者所见
  以知于生死　　能度诸有海

时彼众生于意识中知此法已。皆生善处。若有众生信敬佛者即现佛身而说偈言

  佛正智清净　　能度诸有海
  速得证诸地　　远离一切苦

尔时众生闻说是语。思惟佛功德故。命终之后所往生处。国土清净无有五浊。面见诸佛。现在说法念法念僧亦复如是。虚空藏菩萨成就如是不可思议甚深功德。若有众生欲得种种心自在者。于夜后分应净澡浴恭敬礼拜虚空藏菩萨。于诸众生起慈愍心。作如是言。念我念我有大智得大慈悲。虚空藏菩萨愿与我念定方便。即说是咒

跢侄他户噌娆曷啰(上)那(上)溪跛叉(器我反余同)儞黎三慕(上)驮啰(上)皤多嚟跢那(上)夜摩诃迦噌奶迦(同上)阿(上)弩跛蟾(时吕反下同)婆(上)从弭唎底阿(上)伽(上)罗(上)蟾婆从[方*耳]唎底皤阇(上)嚂(上)蟾婆(上)从[方*耳]唎底曷嚧输从[方*耳]唎底阿(上)那(上)摩从[方*耳]唎底蒲跢俱知从[方*耳]唎底沙(上)婆诃

若诵持是咒。即得入念定方便。复次若欲读诵种种经论若佛所说若弟子所说者。应净澡浴余如上说。即说咒曰

跢侄他阿(上)儞罗(上)阇(上)[壹*(皮/?)]钳蒲(上)沙(疏可)阇(上)[壹*(皮/?)]夜皤那(上)阇(上)[壹*(皮/?)]跛叉娑(上)迷跛奼(刃下)罗(上)阇(上)沙(疏可)沙(上)他那(上)娑(上)罗(上)[壹*(皮/?)]奢(同上)娑(上)跢罗(上)迦(上)啰(奴皆反)虎磨虎磨摩诃迦噌奶迦(同下)娑(上)婆诃

若欲入大海者。欲入幽穴求珍异者。欲服神仙药者。被系闭者。受刑罚者。若临死者。爱别离者。怨憎会者。水火刀兵畏者。虎狼师子毒蛇盗贼所劫。长病乃至乏衣食者。当礼拜恭敬虚空藏菩萨摩诃萨余如上说。若诸王子欲求王位者。求长寿者。求威德波罗门者。求威德居士者。求巧方术者。求名闻者。求容貌端正者。求修定者。求解脱者。如是众生闻虚空藏菩萨名号。于夜后分应净澡浴着新好衣。升高座上。至心水求请作如是言。南无虚空藏菩萨。有大悲者与我福德满我志愿。彼族姓子以天耳闻随其福力即为现身。彼族姓子有如是不可思议大智方便。诸善功德已度甚深佛法大海。善男子。或有众生能数四大海水知其渧数。无有众生能量虚空藏菩萨大智方便成就众生者。或有众生能量度无量无边虚空分齐。无有众生能筹量虚空藏菩萨摩诃萨。为成就众生故现种种身。或现佛身婆罗门身。乃至示现畜生之身。若于窹时若于梦中。乃至众生临命终时。最后意识而为现身。除其恶业离恶趣畏令住善道。彼族姓子成就如是不可思议大智方便诸善功德。已度甚深佛法大海。是故顶上有如意宝珠。尔时大众诸来会者。见虚空藏菩萨摩诃未曾有事。皆悉尊重合掌恭敬。以种种偈颂而赞叹之。尔时虚空藏菩萨前礼佛足白佛言。世尊云何如来能于此五浊世界无明闇冥众生之中。而作佛事。佛告。彼族姓子。譬如虚空无染无患无痴其性清净。以风雨尘雾因缘故而不清净因缘散灭。如本清净便见日月星宿。知有刹那罗由须臾之间昼夜时岁。如是善男子。如来于第一义空心得自在。以诸众生为客尘烦恼染污其心。是故如来而为说法令染污心还得清净。若有众生得遇如来智慧光照便能明了。证知甚深佛法。所谓四念处八圣道分乃至安住十八不共法大慈大悲大功种智。是故便有阿罗汉辟支佛菩萨摩诃萨诸佛如来出现世间。善男子于意云何。虚空依眼依眼识生触邪。不也世尊。于意云何。虚空依内眼缘触生三受邪。不也世尊。耳鼻舌身亦复如是。善男子于意云何。虚空依意依意识耶。不也世尊。善男子于意云何。众生依虚空虚空依众生邪。不也世尊。展转不相依。各无所行。一切诸法亦复如是。无观无行同一空性皆归实际如如之相。世尊。譬如虚空无破无坏无性无相无有分别亦无动摇无种无子无果无报无变异相。世尊。菩萨摩诃萨若能随顺观一切法如是相者。是名于无生法中得无生法忍。即说咒曰

跢侄他婆(上)檀跢婆(上)伽(上)槃弊(鼻可反)皤啰(上)阇(上)磨弩叉夜是那(上)阇(上)夜阇(上)那儞摩媎儞诃(上)啰(上)阿(上)那(上)夜颇罗(上)瞿(上)颇伽(上)啰(上)婆儞磨阿(上)毗(上)那(上)夜索(上)皤铄(上)铄(上)皤铄(上)那(上)铄(上)磨那(上)铄　(上)跢跢迦(上)啰(上)磨铄(上)磨迦(上)唎摩睹毗(上)沙疏可铄(上)磨犁(支[羊*久])跢那夜结[黍-禾+利]铄(上)睹僧输[(ㄆ/ㄆ/木)*(犮-乂+又)]儞(奴绮)娑(上)婆诃

佛告。族姓子。善哉善哉。汝能为众生故说此离垢师子游步欠呿陀罗尼。令诸众生临命终时。最后意识离烦恼障业障报障得生清净佛土。汝能于无量无边国土城邑聚落在在人民所住之处。现种种身形相威仪。为诸众生解脱甚深大乘经典令刹帝利旃陀罗王及诸行恶者逮得善法

尔时世尊说是法时。无量人天有得三昧者。得陀罗尼者。得诸忍者。乃至住十地智者。十千众生得无生法忍。时诸比丘在会大众天龙及人阿修罗等闻佛所说。皆大欢喜作礼而去虚空藏菩萨神咒经一卷


观虚空藏菩萨经

    No. 409

观虚空藏菩萨经

        宋罽宾三藏昙摩蜜多译

如是我闻。一时佛住佉陀罗山。依正觉仙人所住之处。与千二百五十比丘俱。贤劫千菩萨弥勒为首。尔时长老优波离。即从坐起整衣服。为佛作礼。白佛言世尊。先于功德经中。说虚空藏菩萨摩诃萨名。能除一切恶不善业。治王旃陀罗乃至沙门旃陀罗诸恶律仪。如此恶事若欲治。当云何观虚空藏菩萨。设得见者云何共住布萨僧事。若优婆塞破五戒犯八戒斋。出家比丘比丘尼。沙弥沙弥尼。式叉摩尼犯四重禁。在家菩萨毁六重法。出家菩萨犯八重禁。如是过人。世尊先于毗尼中说。决定驱傧如大石破。今于此经说。大悲虚空藏能救诸苦。及说咒以除罪咎。设有此人云何知之。以何为证。惟愿天尊。分别解说。佛告优波离。汝及未来世一切善持毗尼者。应当教此犯罪众生安慰其意。世尊大慈弘誓无量不舍一切。于深功德经说治罪法。名决定毗尼。有三十五佛救世大悲。汝当敬礼。汝敬礼时当着惭愧衣。如眼生疮深生愧耻。如癞病人随良医教。汝亦如是应生惭愧。既惭愧已。一日乃至七日礼十方佛。称三十五佛名。别称大悲虚空藏菩萨名。澡浴身体。烧众名香坚黑沉水。明星出时长跪合掌。悲泣雨泪称虚空藏。白言大德。大悲菩萨。愍念我故为我现身。尔时当起是想。是虚空藏菩萨顶上有如意珠。其如意珠作紫金色。若见如意珠即见天冠。此天冠中。有三十五佛像现。如意珠中十方佛像现。虚空藏菩萨身长二十由旬。若现大身与观世音等。此菩萨结加趺坐。手捉如意珠王。其如意珠演众法音与毗尼合。若此菩萨怜愍众生故。作比丘像及一切色像。若于梦中。若坐禅时。以摩尼珠印印彼人臂。印文有除罪字。得此字已。还入僧中如本说戒。若优婆塞得此字者不障出家。设不得此字。便使空中有声唱言罪灭罪灭。若无空声使知毗尼者。梦见虚空藏菩萨。告言毗尼萨毗尼萨。某甲比丘。某甲优婆塞。更令忏悔。一日乃至七七日。礼三十五佛虚空藏菩萨力故。汝罪轻微。知法者。复教令涂治圊厕。经八百日。日日告言。汝作不净事。汝今一心涂一切厕莫令人知。涂已澡浴礼三十五佛。称虚空藏。向十二部经。五体投地说汝过恶。如是忏悔复经三七日。尔时智者应集亲厚。于佛像前。称三十五佛名。称文殊师利称贤劫菩萨。为其作证更白羯磨如前受戒法。此人因苦行力故。罪业永除。不障三种菩提业。佛告优波离。汝持是观虚空藏法。为未来世无惭愧众生多犯恶者广分别说。说是语时。时虚空藏菩萨。结加趺坐放金色光。如意珠中见三十五佛已。白佛言世尊。我此如意珠宝从首楞严出。是故众生见珠者。得如意自在。尔时世尊敕优波离。汝持此经。不得为多众广说。但为一人持毗尼者。为未来世无眼目众生。作眼目故。慎莫忘失。时优波离闻佛所说。欢喜奉行

右观虚空藏菩萨经。按开元录。系是单译。止有二纸。经后旧尚有八纸经文。准校勘大藏竹堂讲师批。该是后人采集虚空藏经咒并诸经中佛名及咒。以为劝世修行法。不可连在观虚空藏经后。下竺本及福本皆无。又按此经。世尊先于深功德经。说治罪法。名决定毗尼。有三十五佛者。即出宝积经第九十卷优波离会。与决定毗尼经同本。余文皆例此。然详观所批理。亦可以意会。徒存似是。姑为删之

阿弥隶奢阿弥隶奢迦留尼迦(一)遮罗遮罗毗遮罗珊遮罗迦留尼迦(二)罗茂罗罗茂罗毗伽陀隶(三)摩懵呿复阇摩那迦留尼迦(四)真陀摩尼富罗栘迦留尼迦(五)萨婆阿奢弥咃[口*皮]栘(六)陀溃陀利(七)破仇破仇(八)留坻脾脾伽仇(九)儨脾脾伽仇迦留尼迦(十)富隶栘埵摩摩阿奢(十一)萨埵波咃遮阿输迦竭坻莎呵(十二)

    三十五佛名

释迦牟尼佛　金刚不坏身佛　宝光佛龙尊王佛　精进军佛　精进喜佛　宝力佛　宝月光明佛　现无愚佛　宝月佛　无垢佛　离垢佛　勇施佛　清净佛　清净施佛　婆留那佛　水天佛　坚德佛　栴檀德佛　无量光佛　光德佛　无量气光佛　那罗延佛　功德华佛　莲华游戏神通佛　才功德佛　念功德佛　善名称佛　洪炎幢王佛　善游步功德佛　斗战胜佛　善游步佛　周匝庄严功德佛　宝莲华游步功德佛　莲华光善住娑罗树王佛

过去三十五佛名

    虚空藏菩萨陀罗尼

多掷哆　阿弥阇　迦留尼迦　遮罗遮罗毗遮罗　迦留尼迦　茂罗罗啰茂罗毗迦陀罗　摩摩劫呿　复奢摩那　迦留尼迦真多摩尼　富罗栘　迦留尼迦　萨埵舍摩　哆婆蛇　阿若陀梨　婆破穷穷留提　毗脾伽穷　持栗履毗脾加穷　迦留尼迦　富梨蛇[自/兒](音兜)摩摩阿舍　萨埵波利波遮　阿输迦竭提　莎呵

若有众生。种种诸病逼切其身。其心散乱。聋盲喑哑诸根不具。肢节各异。时有死相如是等事。一向称虚空藏菩萨摩诃萨名。除诸病故。欲无病故。烧沉水黑坚沉水若多竭流香。礼虚空大善丈夫。是善丈夫于夜梦中。作婆罗门像。在其人前。即现释像功德天像妙音天像。或罗刹之像。或大臣之像。或兵吏之像。良药之像。或父母之像。于夜梦中在病人前。如实说种种随病汤药等者一服除差无余。复有如是取营求事。欲多问义。若寂静处欲行禅定。欲智慧。欲得名称。欲求巧。欲求自在。欲得妙色。欲封欲得势力。欲财能欲得妙声。欲得子息。欲得眷属。欲得功德。欲得布施持戒忍辱精进禅定。欲得义语。欲得人恭敬。欲脱诸恶灾止于施乃至住慧。欲得长命。欲得种种所须之具得以能用。是人礼虚空藏菩萨摩诃萨。若阿练若在林中若在路地。烧于沉水黑坚沉水若多竭流香。至心合掌。五体投地。遍礼十方。说陀罗尼句。即得所愿

    过去五十三佛名

普光佛　普明佛　普静佛　多摩罗跋栴檀香佛　栴檀光佛　摩尼幢佛　欢喜藏摩尼宝积佛　一切世间乐见上大精进佛　摩尼幢灯光佛　慧炬照佛　海德明光佛　金刚牢疆普散金光佛　大强精进勇猛佛　大悲光佛　慈力王佛　慈藏佛　栴檀窟庄严胜佛　贤善首佛　善意佛　广庄严佛　金华光佛　宝盖照空自在王佛　虚空宝华光佛　琉璃庄严王佛　普现色身光佛　不动智光佛　降伏诸魔王佛　才光明佛　智慧胜佛　弥勒仙光佛　世静光佛　善寂月音妙尊智王佛　龙种上尊王佛　日月光佛　日月珠光佛　慧幡胜王佛　师子吼自在力王佛　妙音胜佛　常光幢佛　观世灯佛　慧威灯王佛　法胜王佛　须弥光佛　须蔓那华光佛　优昙钵罗华殊胜王佛　大慧力王佛　阿閦毗欢喜光佛　无量音声王佛　才光佛　金海光佛　山海慧自在通王佛　大通光佛　一切法常满王佛

若有善男子善女人及余一切众生。得闻是五十三佛名者。是人于百千万亿阿僧祇劫。不堕恶道。若复有人。能称是五十三佛名者。生生之处常得值遇十方诸佛。若有人能至心敬礼五十三佛名者。除灭四重五逆及谤方等皆悉清净

毗婆尸佛　尸弃佛　毗舍佉佛　拘留孙佛　拘那舍牟尼佛　迦叶佛　释迦牟尼佛

东方宝光月殿妙尊音王佛　南方树根华王佛　西方造王神通炎华佛　北方月殿清净佛　下方善寂月音王佛　上方无数精进愿首佛

佛告宝网菩萨。若善男子善女人。起立讲堂如三千大千世界。讲堂内造立精舍。计有亿数。皆以赤栴檀而合成之。以一切乐具供养诸佛。于百千劫。于佛灭后复起塔庙。幢幡华盖宝瓶香炉伎乐歌叹。于意云何。是人功德宁为多不。宝网白佛。甚多世尊。佛言不如有人讽诵念此六方佛名恭敬作礼。其人世世常生转轮王家。端正威德。临欲终时。百亿诸佛授手令不堕三恶趣。设有五逆重罪。应入地狱。令现世轻受头痛则除。以此当之。不入三恶道受。是故至心恭敬作礼。广说如是宝网童子经

东方须弥灯光明佛　东南方宝藏庄严佛　南方栴檀摩尼光佛　西南方金海自在王佛　西方大悲光明王佛　西北方优钵罗莲华胜佛　北方莲华须庄严王佛　东北方金刚自在王佛　上方殊胜月王佛　下方日月光王佛

舍利弗。若有菩萨犯于初戒。于十众前以正直心殷重忏悔。手犯戒者。于五众前以正直心殷重忏悔。手捉女人。眼见恶心。或一人二人前。以正直心殷重忏悔。若有菩萨。成就五无间罪。犯于女人。或犯男子。或有手犯。犯塔犯僧。如是等余犯。菩萨应当于三十五佛边。所犯重罪昼夜独处至心忏悔。忏悔法者归依佛。归依法。归依僧

妙音菩萨　文殊师利菩萨　药王菩萨　勇施菩萨　宿王华菩萨　上行意菩萨　庄严王菩萨　药上菩萨　得勤精进力菩萨　观世音菩萨　无尽意菩萨　持地菩萨　庄严相菩萨　普贤菩萨

是十四菩萨。法华中妙音来所欲见。若念礼者得现世福

种种行菩萨　无量行菩萨　清净行菩萨　建立行菩萨

诵四菩萨名。念礼者命终不经三恶道

东方空无菩萨　南方善思议菩萨　西方喜信净菩萨　北方神通华菩萨

念礼四菩萨。得三世福。经趣佛道

跋陀和菩萨　罗邻那竭菩萨　憍目[自/兒]菩萨　那罗达菩萨　须深弥菩萨　摩诃须萨和菩萨　因坻达菩萨　和伦调菩萨

是八菩萨从般舟中出。是八人求道以来无央数劫。于今未取佛。愿言。彼十方天下人民皆得佛道。有急疾皆呼我八人名字。即得解脱。寿命终时。我八人便当飞往迎逆之。诵礼八菩萨者得现世福。命终八人迎接将往极乐国土。化生莲华中作无生菩萨。

舍利弗．目揵连．大迦叶．须菩提。此四声闻。念礼者令人得现世福

富楼那　阿难　罗睺罗

声闻士。此三权声闻。念礼者。令人得大乘福

第一分舍利在拘尸那国城

第二分舍利在波婆国

第三分舍利在罗摩国

第四分舍利在庶勒国

第五分舍利在毗[少/兔]国

第六分舍利在毗耶离国

第七分舍利在迦毗罗国

第八分舍利在摩伽他国

第九分舍利在瓶头罗国

第十分舍利在罗延那国

佛初去世后起此十塔。当尔时。阎浮提二十八万里中正有十塔。念礼者得无量福德。舍身不堕三恶道

天上四塔者

忉利天城东。照明园中有佛发塔

忉利天城南。粗涩园中有佛衣塔

忉利天城西。欢喜园中有佛钵塔

忉利天城北。驾御园中有佛牙塔

人间四塔者

第一所生塔在拘萨罗国迦毗罗城岚鞞林

第二道场塔在摩伽陀国伽耶城菩提树下

第三转法轮塔在伽尸国波罗奈城鹿野苑中

第四般涅槃塔在摩罗国拘尸罗城双树间

人间八塔念礼亦令人得现世福

    集法悦舍苦陀罗尼经

南无佛陀耶　南无达摩耶　南无僧伽耶　南无毗首陀遮耶　南无阿伽竭浮遮耶　南无摩诃萨婆婆伽利耶　多掷侄哆(敕贺反)林弥利　婆簸婆弥留遮呵　檀摩陀那阇那唏希　知汦底　婆居婆遮耶　那耶波罗　萨婆摩呵唏知底利殃求知利默求知利　比婆萨婆耶那　比林婆阇呵陀舍耶输　萨婆娑罗　三蔓(无拌反)钵汦波　波波利摩诃阿那莎呵

尔时佛告诸大众言。吾本无数劫中。处于凡夫时。字遮他陀。在加伦逻国。作于商客贩卖治业。虚妄无实造诸恶行不可称计。淫荒无道不可具说。是时愚痴害父爱母。经数年中。举国人民一皆知之。称声唱言。是遮他陀。害父爱母经今数年。吾时思念与六畜无异。更无人事。时于加伦逻国。跳城奔走趣于深泽。时此国王名毗阇。告令国中人民。此遮他陀淫荒无道致为此事。其有能得此人者。当重赐宝物。时此国人各各受募欲捕吾身。是时惊怖即出国作沙门。在于他国修行十善。坐禅学道昼夜泣泪。经三十七年。以五逆罪障故心不定。忧悲叵处。以三十七年中。在于山窟常举声泣。苦哉苦哉。当以何心去此苦也。悲叹下窟乞食。时道中地得一大钵。中有一匣经更无余经。唯有集法悦舍苦陀罗尼。说过去恒河沙诸佛泥洹。时常在毗悦罗国。说此陀罗尼付诸大菩萨。后有人得闻此陀罗尼者。此人过去世时。修持五戒十善。当令得闻。有人虽闻。而不在心不修集者。是名无缘。此陀罗尼能除去百亿劫生死五逆大罪。若有人受持读诵者。终不堕于三涂地狱饿鬼畜生。何以故。过去诸佛。以欲泥洹时。会当说之。尊重叹仰称其功德。不可计量。付诸菩萨。后有众生得闻此陀罗尼者。修习着心福报难计。犹如须弥宝海。凡夫不能得量。若有人作诸恶行。窃闻此陀罗尼名。不及修习一用在怀。堕于地狱。一切地狱中。蒙此人恩苦痛不行。有人能行现身精勤修习得者。睹见百千万佛刹土。得福无量不可具说。唯有诸佛与诸菩萨乃能究尽。声闻二乘人者不能得知。何以故。此陀罗尼非一佛二佛所说。过去恒河沙诸佛所说。是时吾得此经。即不乞食欢喜向窟。到于窟中烧香礼拜。悲泪赞仰。于窟中修习读诵经一年始得。以罪业障故不能得入心怀。是时吾即以秋月夜。洗浴修行经一七日。如童子初学愦愦者不少便。更行于七日。亦如是愦愦无异。心中愁恼。不知云何。意中沾思此陀罗尼字。经于数反。心中忽定。我时欣悦。如人地得百千斤金。人无知者内欣不止。吾时亦然。修行数年飞行无碍。睹见十方三世诸佛。后有行者如法行之

    虚空藏菩萨陀罗尼咒

南无佛兜佛多　摩诃目揵连莎　多掷(绖)他(敕贺反)欹利吉利弥利踟利　萨婆伽欹利弥利　萨婆伽弥利莎呵

此陀罗尼。要月十四日十五日明星出时诵之八百遍。烧好沉水香。香烟不绝。要用黄花八百枚。令人得福。若善男子。现身安隐求心中所愿无不获得。若是女人化成男子。能至心一日一夜六时行道诵持之者。一劫二劫之罪永不入恶趣。要用春秋凉时三月四月八月九月观虚空藏菩萨经


菩萨念佛三昧经

    No. 414 [No. 416]

菩萨念佛三昧经卷第一

        宋天竺三藏功德直译

    序品第一

如是我闻。一时佛住王舍城耆阇崛山。与大比丘众一千二百五十人俱。皆是阿罗汉。诸漏已尽无复烦恼。调伏纵任善脱无脱。深知无知所作已办。逮得无我舍诸重担。除灭九结决定解脱。诸心自在犹如大龙。唯除阿难尔时难陀天子。修难陀天子。栴檀天子。修摩那天子。自在天子。大自在天子。阿逸多天子。修行天子。如是无数净居天子。于夜后分光色倍常耆阇崛山欻然大明。时诸天子往世尊所。一心恭敬顶礼佛足。以天细末栴檀之香。多摩罗跋沉水天香。天花鬘香俱修摩等种种花香。以散佛上。重礼佛足右绕三匝。却住一面合掌向佛。时栴檀天子默然生念。过去诸佛皆为诸天世人沙门婆罗门。演诸佛所说菩萨念佛三昧。复作是念。今我世尊亦应如昔过去诸佛。安乐世间诸人天故。宣说菩萨念佛三昧。时诸天子俱白佛言。世尊。过去诸佛皆说菩萨念佛三昧。安乐世间人天八部。唯愿世尊。如昔诸佛广为众生说此三昧。尔时世尊默然许之时诸天子绕佛三匝。顶礼佛足忽然不现

尔时世尊于夜后分明相出时。熙怡微笑作大师子[口*磬]咳之声。耆阇崛山别住诸僧。承佛神力俱到佛所。王舍大城诸比丘尼。蒙佛威声亦悉同集。摩竭提国阿阇世王先尼梵子。与无量亿眷属围绕。承佛神力于一念顷俱到佛所。复有阿罗婆迦夜叉。伽陀婆夜叉。金毗罗夜叉。修脂路摩夜叉。摩罗陀利夜叉。如是等夜叉神王有大威力。一一皆有百千眷属。乘佛神力于一念顷至耆阇崛山。复有罗睺罗阿修罗王。毗摩质多罗阿修罗王。修婆睺阿修罗王。波呵罗头阿修罗王。及其眷属。如是乃至三千世界。天龙龙王无量无边。生希有心肃然毛竖。承佛神力于一念顷往到佛所。东方世界如恒河沙梵天天王。闻佛謦咳。肃然毛竖往到佛所。自余三方及上下方亦复如是

时给孤独须达长者。亦与无数百千眷属。从舍卫城往到佛所。时毗耶离有大长者名曰善思。次名降怨次名吉祥。复有离车诸王子等。名欢喜象次名举象。复有断事庶士首陀名曰光象。如是一切皆大乘学。与无量众承佛神力往到佛所。时瞻婆城有庶士子。名曰庠序次名饶益复有大长者子名无量力。如是等众已于过去种诸善根有大威德。承佛神力往到佛所。时波罗奈无量众生。宿殖德本今已成熟。从波罗奈鳞次相继步至佛所。稽首作礼侍立左右

是时拘尸那竭大城。无量力士。及力士子。已于过去供养诸佛。殖诸善业具大威德。从拘尸那共相和顺。随路贯次往到佛所。至心恭敬前顶礼足。是时三千大千世界纵广正等。佛神力故。一切八部天龙夜叉乾闼婆王阿修罗王迦楼罗王紧那罗王摩睺罗伽。如是等众皆来集会间无空缺

尔时世尊见众已集。复更发大师子之声。从僧坊出近至异处。遥见彼方其地众宝。世尊见已复更微笑。即时世间人天阿修罗。各持无量末香杂花以散佛上。至心恭敬尊重赞叹。是时众中长老舍利弗。长老大目揵连。长老摩诃迦叶。长老须菩提。长老富楼那弥多罗尼子。长老罗睺罗。长老摩诃金毗罗。长老摩诃迦旃延。长老阿[少/兔]楼驮。长老劫宾那。长老轮卢那二十亿子。长老难陀。长老阿难陀。皆有威德具足神通。如是圣众悉已俱集

尔时众中长老弥勒菩萨。三界菩萨。越三界菩萨。初发心即转法轮菩萨善思菩萨。大音声菩萨。持地菩萨。文殊师利童子菩萨不空见菩萨。如是等众无量无边。已曾供养过去诸佛。深种菩萨无数行愿。久发无上菩提之心。尔时长老不空见菩萨。欲知如来神通之相微笑之意。更正衣服绕佛三匝却住一面。合掌向佛。即说偈曰

  最胜无为　　两足世尊　　为调御故
  现斯熙怡　　富能开惠　　令贫满足
  佛演法施　　明发亦然　　一切世间
  之所归趣　　以何因缘　　示此微笑
  无上正觉　　愿为我说

尔时世尊告不空见。汝见彼处众宝地不。不空见言。唯然已见。如是不空见。彼地乃是往昔诸佛之所游化。时不空见心自念言。我宜速疾至彼地所。如其相貌心入三昧。入三昧已为佛世尊。化作种种众宝法座。即如其念施置座已。往诣佛所劝请如来。升此宝座白言世尊。此处皆是往古来今。诸佛如来游践之地

是时世尊往到彼处即就法座。于一念顷如来应正遍知力故。此刹三千大千世界六种震动。踊遍踊等遍踊。震遍震等遍震。吼遍吼等遍吼。动遍动等遍动。摇遍摇等遍摇。起遍起等遍起。东踊西没西踊东没。南踊北没北踊南没。西踊东没东踊西没。北踊南没南踊北没。光明遍照无量世界。一念之间一切众生。乃至阿鼻地狱。悉受快乐

  佛升法座　　如日晖曜　　一切世间
  之所归仰　　震动大千　　咸生欣悦
  佛登宝座　　如日显照　　一切世间
  顶戴法王　　欲令众生　　普获安乐
  佛就座已　　如日融朗　　一切世间
  尊承法王　　放净光明　　照诸刹土
  奇哉斯乘　　乘之最胜　　异哉斯乘
  无能过者　　暂现之处　　已不可量
  善哉斯乘　　乘之弘大　　乘是乘者
  不可思议　　诸天魔梵　　所不能测

尔时世尊广长舌相。遍覆三千大千世界。普告声闻及众菩萨。诸善男子一心静听。是夜难陀天子。修难陀天子。栴檀天子。修摩那天子。自在天子。大自在天子。阿逸多天子。修行天子。如是无数净居天子。于夜后分光色倍常。耆阇崛山欻然大明。尔时诸天来诣佛所。一心恭敬顶礼佛足。以天细末栴檀之香。多摩罗跋沉水天香。天花鬘香俱修摩等种种花香。以散佛上。重礼佛足右绕三匝却住一面合掌向佛。供养恭敬尊重赞叹

是时栴檀天子默然生念。过去诸佛应正遍知。皆为人天沙门婆罗门。敷演诸佛所说菩萨念佛三昧。今我世尊亦应如昔过去诸佛安乐众生。宣说菩萨念佛三昧。时诸天子作是劝请。我默然许。如是比丘栴檀天子。难陀天子。无量净居诸天子等。知我许已忽然不现。尔时世尊。即说偈言

  告诸比丘　　于后夜时　　诸天身色
  光炎倍常　　耆阇崛山　　欻然大明
  供养尊重　　围绕世主　　难陀天子
  善喜天子　　善意天子　　栴檀天子
  自在天子　　及大自在　　阿逸天子
  善行天子　　如是无量　　净居天子
  有大神力　　来至我所　　广设种种
  珍妙供养　　皆共恭敬　　右绕三匝
  头面礼足　　却住一面　　栴檀天子
  默然住已　　发心欲为　　教化众生
  请说菩萨　　念佛三昧　　往昔诸佛
  已曾说故　　善哉释迦　　十力如来
  说三摩提　　欲令一切　　得安乐故
  佛默然许　　时诸天子　　已知垂允
  我亦于此　　耆阇崛山　　如过去佛
  所说三昧　　时诸天子　　已知如来
  默然许之　　欢喜快乐　　右绕三匝
  礼足而去　　比丘听我　　所演三昧
  如昔诸佛　　莫生疑惑　　如来智慧
  不可思议　　过去诸佛　　最上菩提
  于诸知见　　心无疑网　　如今现在
  第一菩提　　我皆了知　　心无滞碍
  若当来世　　欲成菩提　　欲为怜愍
  将来世故　　我亦明晓　　心无毫疑
  是故如来　　深解无穷　　智力无碍
  不可思议　　如彼所知　　我悉究尽
  一切众生　　不测其奥

    菩萨念佛三昧经不空见本事品第二

尔时世尊。告长老舍利弗。长老目揵连。长老大迦叶。长老须菩提。长老富楼那弥多罗尼子。诸天世人皆已来集。汝等比丘各升法座作师子吼。所以者何。此众多有诸声闻人。闻师子吼悉得解脱

尔时世尊告弥勒菩萨。越三界菩萨。不思议菩萨。不空见菩萨。汝等即时请如来演诸佛所说真实功德师子吼音。不空见言如是世尊。唯然已闻。即说偈赞

  身色如金　　百福庄严　　为怜愍故
  了达真谛　　功德具足　　名誉远流
  今日世尊　　以何因缘　　于大众中
  令我请问　　正觉无伦　　最上莫过
  功德法王　　大智难穷　　调伏世间
  以何因缘　　于大众中　　令我请问
  如来净戒　　定智解脱　　解脱知见
  悉皆无等　　今我善逝　　以何因缘
  于大众中　　令我请问　　威德无比
  得度彼岸　　法王世尊　　能为众生
  作大利益　　善逝何因　　于大众中
  令我请问　　百劫修慈　　习近悲处
  辩才无滞　　善逝何因　　于大众中
  令我请问　　最上法王　　普利群生
  贫者得富　　盲者得视　　楚毒永息
  恐畏获安　　以何因缘　　令我请问
  佛身净妙　　尘垢不污　　如来之衣
  种种杂色　　世尊族姓　　王中之王
  以何因缘　　令我请问　　佛所著衣
  去身四指　　而不离身　　身能降怨
  以何因缘　　令我请问　　如来行处
  无诸坑坎　　智慧力故　　所履皆平
  以何因缘　　令我请问　　如来之身
  不增不减　　行步平正　　不邪不曲
  妙绝常伦　　难可思议　　以何因缘
  令我请问　　仰瞻尊颜　　目不暂徙
  佛行不假　　神足之力　　威仪自然
  庠序可观　　若为魍魉　　之所捉持
  迷闷失心　　无所觉省　　若睹世尊
  于一念顷　　诸恶永离　　还得正念
  若有众生　　触佛足尘　　于七月中
  身心快乐　　命终之后　　得生善处
  归命世尊　　施一切乐　　若有人病
  极受众苦　　佛以手摩　　即得除愈
  善逝旷劫　　悉得一切　　不可思议
  无数安乐　　佛昔勇猛　　摄取当来
  无量劫中　　所得净法　　我于是处
  无疑异心　　以何因缘　　令我请问
  过去当来　　天中特尊　　今遇调伏
  人中大仙　　以何因缘　　令我请问

尔时世尊告不空见。谛听谛听善思念之。不空见言唯然世尊。告不空见。我忆往昔无央数劫。尔时有王名无量力。有大神通势力自在。是王住处造立大城。城名善建纵广正等十二由延。其城七重面有三门。门城皆以金银琉璃颇梨马瑙真珠珊瑚庄校严丽。堑亦七重皆悉七宝。是诸门外以金银沙布饰其地。一门两边各有金银四阙相对

如是不空见。又以金银作大罗网弥覆门上。金网处处悬于银铃。银网往往垂于金铃。风吹铃网皆作箜篌乐器之声。宫商调畅更相应和。王造城已安处其中。斯城堑外有七池沼。金银颇梨珊瑚所成。此诸池沼有七阶道。亦是七宝之所庄校。金阶道者银为栏楯。银阶道者金为栏楯。银为阶道真珠栏楯。真珠阶道琉璃栏楯。颇梨阶道珊瑚栏楯。珊瑚阶道真珠栏楯。真珠阶道金为栏楯。如是不空见。无量力王植众奇花。优钵罗花。钵头摩花。拘物头花。分头利花。那梨尼花。香气调柔无吝惜者。随意采之。其池岸上种种花树。所谓伊曾花树。尼曾花树。迦多曾尼花树。阿提目多迦花树。瞻卜花树。婆利师花树。拘毗陀罗花树。陀[少/兔]迦梨花树。此诸花树气若天香。亦无守护随意而取

又不空见。是善建城有多罗树七重行列。悉以七宝互相间错。金多罗树银叶花果。银多罗树赤真珠叶花果亦然。白真珠树琉璃为叶花果亦然。琉璃树者颇梨为叶花果亦然。颇梨树者马瑙为叶花果亦然。马瑙树者赤真珠叶花果亦然。赤真珠树珊瑚为叶花果亦然。珊瑚树者金为其叶花果亦然。不空见。风吹诸树更相掁触出微妙声。譬如乐师善能击发五种之音。又不空见。王所住处如是众声恒不断绝。象声马声车声军声。螺声鼓声箫声笛声。箜篌琵琶歌舞之声。如是众声未曾暂废。王常宣令境内人民。若有所须衣服饮食象马车乘。恣随其意一切给与。多罗树间常出乐音。诸人游之五欲自娱。王视国人如父念子。一切奉王犹若慈父

又不空见。善建城内开诸街巷廛邑市肆。处处复有四宝池沼。其池相去尽一箭道。是池四岸众宝阶陛。金阶银栏银阶金栏。颇梨珊瑚间错亦然。又不空见。王于诸池植众名花。复于池上种杂花树。伊尼曾花树。迦昙婆花树。阿提目多伽花树。瞻卜花树。陀[少/兔]迦利花树。芳如天香亦无惜者。城内又建诸园林观。种种花果行列其间。复于园中四方周匝。处处皆有诸妙花池。亦以七宝庄严如前。有众婇女更相娱乐。一切人民恣意游适

又不空见。无量力王族姓豪杰。大刹利种所生父母。乃至七世胄胤相承。悉皆清净容色端雅。人中独绝。财宝巨亿不可称计。又不空见。无量力王深信弘惠虚心大施。施诸沙门及婆罗门。乃至盲聋[癃-(阿-可)]残百疾。贫穷孤独困厄之人。王所统领八万四千城邑聚落。净业果报七宝庄饰。一一城上复造八万四千栴檀众妙楼橹。是诸门外开四衢路。路首悉起严丽台观。一切人民任意游戏。常于昼夜楼观台殿巷陌廛里悉然灯烛。其明猛盛遍照国界。众生蒙光身心快乐

又不空见。王有二子一名师子二名师子意。久发无上菩提之愿。名称远闻具大威德。尔时有佛号曰宝肩如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。作是唱言。我于今世及以后世。沙门婆罗门天人阿修罗大众之中。一切知见普为群生说诸妙法。初中后善语善义善。具足清白梵行之相。与大罗汉七百千万亿。皆具神通威德自在。宝肩如来于晨朝时。齐整衣服执持应器。比丘翼从入城乞食。时无量力共其二子。在高楼上欢娱受乐。王遥睹佛功德相好。生奇特心欣跃无极。眷属围绕俱到宫门告其二子。速赍香花幢幡伎乐疾至佛所。即以牛头栴檀末香诸妙珍异。以供养佛及比丘僧。右旋三匝头顶礼足却住一面

又不空见。王与二子请宝肩佛及声闻众。尽其形寿施诸所安。宝肩如来于天人中。教化已周将般涅槃。时王知佛不久住世。与其二子臣民眷属。前后导从至涅槃所。如来尔时灭度已讫。头面敬礼悲号啼哭。以身投地如大山崩。作是唱言世间眼灭。重更哀嗟世间眼灭。如来涅槃一何驶哉。犹商失主佛灭亦然。世间黑闇盲无慧目。捶胸拍头举声大叫。呜咽扪泪告其二子办诸香汤洗浴如来。又以种种妙香涂身。一切散花及诸花鬘。无量妙衣缠如来身。七宝为棺以铁为椁。聚赤栴檀高一由旬。纵广正等一拘卢舍。复以花香散于[卄/積]上。苏油千器以灌栴檀。然后起火火既发已。复更号恸洒泪如雨

尔时师子作是念言。世尊涅槃我生何为。亦当随佛入于涅槃。立此誓讫。重以种种珍妙香花散于[卄/積]上。白[疊*毛]缠身手执火炬自投火中。火即猛盛为利众生归依世尊。而说偈愿。赞咏如来

  如大珍宝聚　　世间之所尊
  生死苦永尽　　于斯般涅槃
  自从今已往　　不睹转法轮
  我所奉法王　　已入于涅槃
  宣扬广大义　　不可复重布
  何当在大众　　闻说于菩提
  诸天及世人　　欢喜赞善说
  我于今日后　　绝不思议声
  世间胜调御　　于此而沉沦
  龙神阿修罗　　及以紧那罗
  欣悦常歌叹　　不复闻斯音
  贫者得满足　　苦恼蒙救护
  世尊今涅槃　　悉丧所依怙
  父王无量力　　及弟师子意
  亦复无慈荫　　更不闻说法
  我亦随世尊　　速取于灭度
  世间无明道　　何用苦生为
  今焚此毒身　　愿获不思议
  我昔与父王　　常于长夜中
  勤供佛法僧　　今得获果报
  若我于佛所　　修习诸善行
  为调伏世间　　得不思议故
  为令诸众生　　发不思议愿
  世尊般涅槃　　我投火盛时
  若人见闻者　　一切得成佛
  唯除邪谤人　　及证正位者
  若我修菩萨　　广大无量行
  众生梦见者　　皆令得佛道
  唯除邪谤人　　及证正位者
  此身如聚沫　　要当必有死
  一切众生类　　若食我肉者
  是等不可量　　疾当得成佛
  我修菩萨行　　恶口骂詈者
  是人值调御　　必当得成佛
  唯除邪谤人　　及证正位者
  若人于我身　　修于慈悲观
  求第一菩提　　速得成佛道
  唯除邪谤人　　及证正位者
  以是烧身缘　　为求彼此愿
  若我心真实　　即还见佛起
  设得更睹佛　　如先住世者
  我身投火中　　犹前侍佛时
  佛起如真身　　今睹不异昔
  尔乃证诸佛　　相续常不断
  唯愿普眼尊　　愍摄于世间
  佛知王子心　　渴仰甚殷重
  即于焰聚中　　奋大神通力
  如从三昧起　　光明倍明显
  不可思议众　　咸叹未曾有
  广为时会人　　更作大利益
  所化既已毕　　还入于涅槃
  师子既见佛　　示大威神力
  身心甚欣悦　　坦然快安乐
  深知诸佛法　　不可得思议
  如来虽涅槃　　犹应众生愿
  不思议戒定　　智慧与解脱
  及解脱知见　　神化不可量
  归依于世尊　　然后当放身
  世间妙威仪　　最胜无伦匹
  自在诸神力　　亦复无等双
  如来还涅槃　　一切咸惊惋
  是故我至心　　归依普眼尊
  归命于善逝　　累尽无为主
  归命永离苦　　怜愍于世间
  正智遍观察　　了达知他心
  除诸烦恼病　　成就无量众
  大医人中尊　　施不思议药
  能善除世间　　一切众疾苦
  归依无上师　　哀矜众生者
  若我赞如来　　一念之功德
  烧身微毫善　　须臾供养福
  如是诸净业　　愿施于一切

如是不空见。时天魔梵及余一切世间人民。悉见师子投身盛火。皆大悲愕生奇特心。命终之后即生梵天有大神力威势自在。是梵尔时中心念言。云何忽然来生此间。重更思惟往昔人中。已曾奉侍宝肩如来。至心恭敬尊重赞叹。佛涅槃已烧身供养。复说偈颂发弘誓愿。乘此善业得生梵天。我今当往至烧身所。是梵即时忽然不现。譬如壮士屈申臂顷。便到如来阇维之处。以天栴檀沉水碎香。俱修摩花多摩罗跋。种种香花不可称数。遍散空中如雨而下。十方交纷若风旋雪。供养宝肩如来舍利。向无量力说其本缘。我是王子师子之身。投火供养命过之者。唯愿大王不加慈念。我今已蒙获诸善利。由昔至诚虔恭奉侍。尊重歌叹宝肩如来。功福果报得生梵天。是故大王与师子意。应共珍敬受持妙法。收取舍利分布供养。无令遗落而生懈怠。大王当知我生梵天。亦常敬持受此胜法。作是言已忽然不现

又不空见。无量力王与师子意。取水灭火以诸妙香众花宝鬘幢幡伎乐种种供养。须臾之顷周遍八万四千城邑。悉起八万四千塔庙。皆以七珍庄校严丽是诸宝塔高一由延。纵广正等一拘卢舍。于一一塔周匝各然。八万四千众香油灯。是诸塔间复以种种香花伎乐供养如前。尊敬受持如此妙法。无量力王以是善根与师子意。经历八万四千劫中不堕恶道又于八万四千亿劫。亲近供养六万诸佛。次第奉敬常不断绝。世世恒作转轮圣王

又不空见。宝肩如来涅槃之后。时有菩萨现于世间名普密王。为愍世间出家学道。菩提树下结加趺坐。一心定意正智解脱。豁然大寤得无上道。又不空见。是师子梵至普密王佛世尊所。住在虚空以天栴檀供养于佛。右绕三匝稽首作礼。请转法轮而白佛言。唯愿世尊从道场起摧诸魔军。于净神智无所毁损愿世间师哀从定寤调御有解诸声闻众。开演美妙善逝之法。如来前身久修智慧。摄受善法今为人尊。过去世中已发弘誓。愿得佛时当度未度。今愿已满得安隐处。最胜无为寂然妙乐。当开甘露解众三结。尔时世尊默然许之

时彼大梵及无数天。既知如来当转法轮。咸共欢喜踊悦无量。梵天于时设诸妙供。即发大愿求无上道。遇普密王应正遍知。生我净妙功德之聚。以此果报于生死中。常得亲近睹十方佛。若我供养佛菩提树。如是种种所修功德。愿慈愍故为我说法。以此果报。于生死中。常得赞叹诸佛塔庙。又不空见。师子王子烧此一身。以是功德所修善根。恒住梵世值五千佛。供养敬侍尊重赞叹。殖诸善根发不思愿。汝不空见莫生此疑。时无量力王岂异人乎我身是也。时不空见即白佛言。是二王子为今现在为已灭度。唯然世尊愿为说之。告不空见。尔时王子师子意者弥勒是也。时师子者汝身是也。王子师子舍此一身。宝肩如来佛法之中。教化成就三万众生。安住阿耨多罗三藐三菩提心。尔时世尊。即说偈言

  忆念宿世时　　宝肩无量眼
  出现于世间　　广利一切众
  金色百福严　　慈矜哀愍故
  深解真实谛　　为度诸世间
  显示甚深法　　济苦恼众生
  宝肩正遍知　　一切世间尊
  三轮善逝众　　七十二亿千
  与是诸大众　　入城共分卫
  昔有大国王　　名为无量力
  自在大威德　　势能伏一切
  其王与二子　　俱游高台观
  王于台观上　　遥睹调伏仙
  宝肩天人师　　翼从诸比丘
  时王与二子　　速迎人中尊
  既至如来所　　即广设妙供
  顶礼绕三匝　　却立合掌住
  请佛及众僧　　尽寿奉所安
  衣服及肴馔　　极世之珍异
  八万四千岁　　奉施未常息
  时王及二子　　静心求菩提
  时佛既灭度　　收取尊舍利
  为彼宝肩佛　　敬造七宝塔
  八万有四千　　微妙甚端雅
  一一佛塔然　　八万四千灯
  时王无量力　　复于善逝处
  香花众伎乐　　深心以供养
  已种不思议　　无量诸善根
  历事六万佛　　一切世间依
  至诚求第一　　无上胜菩提
  比丘莫疑惑　　往昔有国王
  汝善聪慧者　　勿生于异见
  时彼无量力　　今则我身是
  杂花及众香　　昼夜明诸灯
  为利阎浮提　　供养诸如来
  布施恒不足　　闻法亦复然
  曾无懒惰意　　一心求菩提
  宝肩正觉尊　　无上大明智
  汝昔曾烧身　　供养于大仙
  自投猛焰中　　初无畏苦心
  烧身如然炷　　以油渧其上
  渐渐不顿尽　　譬如净灯炷
  为利众生故　　供养涅槃佛
  彼佛已烧身　　汝知方便请
  睹佛从火起　　光明更明显
  见佛不异昔　　心生恃怙想
  即时舍此身　　为益一切故
  若我果斯愿　　敬佛亦如前
  所获诸功德　　不可得思议
  我若有宿愿　　摄受先世业
  合集百千万　　必当得见佛
  我愿若真实　　佛应从火起
  佛智甚清净　　究竟无染着
  澹然常寂灭　　相续恒不断
  知师子心净　　亦先照其意
  佛便从火起　　相好更殊特
  不空见菩萨　　世间怙既起
  一切愿无余　　彼复发誓愿
  其愿不思议　　不可得称数
  法主矜世故　　起于猛焰中
  善逝难思力　　光明更殊胜
  彼时一切众　　皆悉怀惊愕
  净心发高叹　　欣跃未曾有
  奇哉大神通　　势力无伦匹
  甚深佛境界　　不可得思议
  一千诸众生　　见此神变已
  于诸法不受　　善得心解脱
  不空见当知　　师子为世间
  请佛还起时　　一千诸众生
  于彼善逝处　　睹佛神变化
  其心正趣向　　无上菩提道
  大悲为世间　　广作利益已
  佛还入涅槃　　师子亦舍身
  即于命终时　　忽然生梵天
  梵天从上来　　以天栴檀末
  散之以供养　　如来阇维处
  宝肩灭度已　　有佛普密王
  最胜人中尊　　天王之大仙
  哀愍众生故　　出现于世间
  是佛坐道树　　得成菩提已
  梵天设美肴　　供养于世尊
  头面接足礼　　请佛转法轮
  普密王如来　　即知梵天心
  默然而许之　　梵天大欣庆
  复于烧身所　　更发诸大愿
  是梵已曾修　　不可思议善
  昔于一劫中　　供养五千佛
  至心敬世尊　　奉持人中尊
  又告不空见　　慎莫怀疑惑
  汝若有聪慧　　勿生于异见
  昔日梵天者　　今即汝身是
  过去五千佛　　善逝般涅槃
  我悉明见汝　　一一诸佛前
  烧身以供养　　求第一菩提
  过去多千佛　　灭度遗舍利
  如是诸佛所　　舍身及手足
  为利众生故　　修习菩萨行
  近世及远世　　我悉咸了知
  常于百千生　　勤修诸苦行
  佛在及涅槃　　汝愿恒满足
  复告不空见　　如此诸大愿
  摄取过去世　　无量百千生
  我住自在力　　今悉照知之
  汝圣果成就　　即时皆明见
  摄取不思议　　真实诸行等
  住佛前赞叹　　供养两足尊
  是故今劝请　　众圣之法王
  普密王佛所　　摄取最胜愿
  蒙佛现神通　　汝今获此果
  不空见菩萨　　白言牟尼尊
  百千生诸愿　　云何得摄取
  愿少为敷拆　　令我得开解
  不空见昔誓　　雷音成佛时
  见坐菩提树　　我当请说法
  先佛名帝幢　　普眼之世尊
  一切诸众生　　所共归依处
  是时广发愿　　求无上菩提
  为日光如来　　作大七宝轮
  汝时于彼处　　已发最胜愿
  不空见菩萨　　此愿我悉知
  造七宝僧坊　　杂色以庄严
  奉今修伽陀　　广施未来佛
  发此誓愿已　　即时而舍去
  第一众尊佛　　人中上师子
  名不可思议　　善生之世尊
  奉上七宝盖　　端饰甚微妙
  天中天大仙　　盖身普眼佛
  明灯供养已　　是处发大愿
  近世及远世　　多有诸如来
  千亿那由他　　其数复倍上
  于是诸佛所　　发无量大愿
  令一切众生　　悉获快安乐
  普密王佛前　　先生如是念
  我今说汝昔　　修行至菩提
  愿一切大地　　皆生种种花
  云雷音佛所　　为利世间故
  尔时发誓愿　　若有诸众生
  闻我名字者　　一切皆得佛
  于帝幢佛所　　设大珍妙供
  复发诸善愿　　若眼见我者
  于此世界中　　皆当得成佛
  在日光佛所　　奉上七宝轮
  无量大光焰　　炫晃甚辉丽
  时复发愿已　　誓生佛刹土
  七宝严僧坊　　杂色甚雅好
  以此珍奇特　　奉施于善逝
  又发誓愿已　　得天妙宫殿
  斯处快欢乐　　皆悉成佛道
  人中师子王　　无上如来所
  奉上珍宝盖　　发于殊胜愿
  愿诸众生类　　不为日所曝
  身心得安乐　　无复热恼患
  盖身善逝所　　供施灯明已
  复发弘誓愿　　若我命过处
  众生食肉者　　愿皆成佛道
  若闻我名者　　无有贪吝心
  乃至梦中闻　　亦无爱惜意
  一切成佛道　　唯除见谛者
  若眼见汝者　　除诸贪嫉意
  昼夜梦见时　　亦舍染吝心
  一切当得佛　　唯除见谛者
  若有愍念汝　　或生憎嫉者
  是等于汝所　　当得佛法王
  若汝临终时　　又勤求菩提
  我今如实说　　汝之真功德
  必于当来世　　获是无上尊
  若有处水陆　　空行众生等
  食我身肉者　　愿悉得成佛
  我已知汝为　　安乐众生故
  勤修菩萨道　　满足大千行
  众生多疑谤　　是故不显现
  如此众生类　　即时于是处
  若得信念等　　及以欢喜心
  悉当成正觉　　唯除见谛者
  若人愿乐见　　世间所尊怙
  或乐转法轮　　有乐勉众苦
  是人为菩提　　利益故发心
  若有乐供养　　三世诸法王
  若人欲出生　　一切功德聚
  如是众生等　　应持此三昧

尔时世尊说是偈已。即从坐起还入僧坊。于常静室。右胁而卧

菩萨念佛三昧经卷第一菩萨念佛三昧经卷第二

        宋天竺三藏功德直译

    神通品第三

尔时长老舍利弗。长老目揵连。长老阿难。诸天魔梵。及阿修罗。沙门婆罗门。阎浮提人咸生是念。今日如来应正遍知。以何因缘于大众中。直说念佛三昧名字。不为一切广演分别。便从座起而入静室。时不空见心自念言。诸天魔梵悉已集会。世尊今者右胁而卧。我当微现神通变化。示神通已种种赞叹。宣扬如来大悲功德。当如其相摄心入定。以是定力变此三千大千世界地平如掌。皆作众宝微妙杂色。复列八道七宝诸树。金多罗树银叶花果。银多罗树琉璃花果。余宝庄严亦复如此。一切佛刹悬缯幡盖。妙幢宝鬘种种绮饰。优钵罗花钵头摩花。拘物头花分陀利花。如是诸花布一切处。时不空见即如所念现大神通。乃至三千大千世界。令诸众生天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽人非人等。皆坐众宝莲花之上。花叶无数色香具足。各相知见坐宝莲花

时不空见又以定心。入此三昧现大神通。复令三千大千世界地大震动。如摩竭国赤圆铜钵。置平石上倾危不定。大地震动亦复如是。若有众生闻此音声。觉悟之者皆得快乐。譬如东方不动国土。亦如西方安乐世界。其中众生欢娱踊悦。时不空见复以清净恬寂调和柔润端正。至直无曲甚深定心。如其相貌示无作神通。于是三千大千世界满虚空中雨大猛火。无一众生身心热恼。此诸群生大火触身。觉是相已快乐无比。譬如比丘入火三昧。身心欣跃彼亦如是。时不空见复以定心现无作神通。又令三千大千世界。雨天栴檀细末之香香。气氤氲遍满大千。若有众生嗅斯香者。开神适体快乐无极。譬若释迦牟尼如来于昔劫中修菩萨行。定光佛所受记莂时。获不思议无生妙乐。一念之顷不可计众。亦得如是随意欢娱

尔时阿难在大众中而作是念。佛入静室是谁神力而现斯变。为余声闻目揵连等。将非弥勒菩萨。越三界菩萨。文殊师利菩萨。不空见菩萨。为是修习大乘之人。乃能示此神变之相。尔时阿难问目连言。世尊说汝于声闻中神通变化为最第一。今此通变非尔为耶。目连答言。长老阿难。汝问何缘有是神通。如此变化非我所为。长老阿难我所能者。以此三千大千世界内置口中。无一众生生觉知相。复次阿难我游梵天。发言音响遍闻大千。如是阿难。我在佛前作师子吼。能以须弥内置口中。若经一劫若过一劫。阿难。我又住彼炎天。言语音声。此间世界皆悉闻知

长老阿难。我能移于天神堂阁。置阎浮提而不动摇。又告阿难。我能降伏恶性毒害。难陀龙王优钵难陀诸龙王等。又能摧靡弊魔波旬。复次阿难。我往东方。过三千大千。还住第三世界之中。彼有大城号曰宝门。凡有六万亿千家属。令彼家家皆见我身。复能使此诸众生等。闻说无常苦空之音。复次阿难。我实有此诸妙神通。未曾示现。我今处在莲花之座。悉见诸方一一方分。有阿僧祇无数如来。皆名释迦牟尼世尊。处处僧坊右胁而卧。睹佛刹土有如是相。犹我天眼见千世界。若斯相貌是谁神通。时目揵连。即说偈言

  善修最胜　　获四神足　　今我神通
  无与等者　　唯除自然　　世间之师
  我今住此　　阎浮提界　　动彼东方
  诸佛刹土　　帝释宫殿　　诸婇女等
  觉此震动　　皆悉惊悚　　我能含吐
  诸佛刹土　　大海山川　　城邑聚落
  难陀龙王　　及跋难陀　　如斯族类
  性甚毒害　　我之神力　　悉能摧伏
  我住梵宫　　言语之音　　令此世间
  皆悉闻知　　能住佛前　　吞须弥山
  经百千岁　　乃至旷劫　　住炎世界
  凡有声响　　使此刹土　　莫不闻之
  我往宝城　　变身普现　　遍在六万
  亿千之家　　我于此生　　未现斯变
  阿难当知　　吾今所见　　善哉奇特
  灵化神通　　我自见身　　及诸众生
  悉共坐此　　宝莲花上　　历观十方
  大威世尊　　我从昔来　　未见斯瑞
  不疑如来　　自然神变　　或是菩萨
  威神之力

尔时长老大目揵连。说此神通师子吼时。十千众生皆得人身。远尘离垢获法眼净。尔时阿难问舍利弗。如来说汝智慧第一。今此神变将不汝耶。答言阿难。非我为也。我所能者二十年中。常勤修习毗婆舍那。行住坐卧正念观察。其心澄寂曾无动乱。分别显说无量诸法。方便精求不出法界。唯有如来乃能究尽。长老阿难。汝颇知不。若我以衣置于大地。目连虽有自在神通。尽其势力不能令动。长老阿难。汝今当知。我于佛前作师子吼。诸大声闻具大神通。三果学士天人魔梵。阿修罗神沙门婆罗门一切阎浮外道异学尼揵子等来在会中。若能自知身无我者。我今当以三摩跋提。决定为之师子吼说。大丈夫说不思议说。唯除世尊一切知见。弥勒菩萨一生补处。住无生忍菩萨摩诃萨。海德三昧菩萨摩诃萨。善建德三昧菩萨摩诃萨。诸佛现前三昧菩萨摩诃萨。大德声闻今可问我。如此身者何者是我。为可见耶不可见耶。又问异学诸外道等。汝所计身有神我者。为是过去为当现在。长老阿难我如是相。种种神通变化非一。声闻缘觉所不能知。亦不能见。何者是我。所言我者为住何处闻如是声。长老阿难吾常精勤修丈夫业。亦复恒习知解之行。我今更有心自在力。我能伏心心不伏我。长老阿难吾见自身。及以天人坐大莲花。又见诸方在在处处。无数难思阿僧祇界。睹佛世尊坐道树下。大能天子请转法轮。吾当随顺闻如是声。我眼悉见诸世界中。种种缯盖幢幡花鬘。如我即时见此忍土。长老阿难。我心念言。为是世尊作此神通。大德声闻之所为乎。菩萨往昔曾种善根。今获如斯变化果报。时舍利弗。即说偈言

  如来不思议　　如是佛功德
  若有善逝众　　神通广难思
  及诸佛弟子　　有学无学众
  于此刹土中　　我智最第一
  唯除诸菩萨　　信念深固者
  长老阿难陀　　我慧无等双
  现在及未来　　无能见过者
  除世调御尊　　及趣菩提人
  我恒勤修习　　毗婆舍那行
  满足二十年　　观察一切法
  精心方便求　　未曾得边际
  我所有智慧　　不可得称量
  我以智慧力　　现在于佛前
  能师子吼说　　唯除异学人
  及行声闻乘　　求我真实者
  若我现神通　　飞腾虚空时
  此刹无人见　　吾之所游处
  声闻亦不睹　　唯除世间雄
  蠲别两足尊　　及以善逝子
  如是诸人等　　知我之所在
  外道众邪见　　悉非其境界
  心常自在转　　禅悦不思议
  若有大士业　　修习深空行
  长老阿难陀　　我现此神通
  一切声闻众　　终不能得知
  奇哉于今日　　悉睹十方佛
  我在于花座　　明见诸刹土
  建列不思议　　宝幢妙花香
  一切世界中　　变化不可称
  长老我心念　　不疑是世尊
  威德善逝众　　种种变化事
  或是不空见　　菩萨之所为

是舍利弗师子吼时。一万三千诸众生等。远尘离垢得法眼净。时大迦叶亦在众中。阿难心念。是大迦叶。威德具足神通自在。今者变化将非己耶。于是阿难问迦叶言。此之灵奇是大德乎。迦叶答言。斯神化相非我所为。吾以智力悉能分别显示一切。长老阿难。我今住于世尊之前。作师子吼。能以三千大千世界。其中诸水江河溪壑泉源池沼。百千万亿无量巨海。一切水聚吸置口中悉使枯涸。令诸水性鱼龙之属。都不觉知亦无恼害

长老阿难。汝今当知。我于佛前诸天世人梵魔沙门一切众中。师子正说无畏之言。我力能吹须弥山王。大转轮山。雪山山王。乃至三千大千世界。一切诸山皆成微尘。依此山者都不觉知。长老阿难我能如是。得此自在神通之力。复次阿难。我又能吹三千大千诸世界中。一时皆成猛炎炽火。譬如劫烧将尽之时。一切众生亦不觉知。又无烧害热恼之者又不生念烧刹土想。我神力相具足如是

长老阿难。吾住此间。天眼远瞩东方世界。亿百千刹诸佛国土。始处处烧终同一火。我既见已心生念言。今当示现神通变化。即如其相以三昧力住此世界。过于东方亿百千刹。能以一气吹彼猛火悉令俱灭。火既灭已从三昧起。复更发大炎盛之火。长老阿难。我神通相。及波罗蜜如是满足。若有人天生疑不信。世尊今者右胁而卧。若从定起汝可往问。唯佛如来能知此耳。世尊于时于静室中遥语阿难。大德迦叶说师子吼。汝善受持

尔时人天阿修罗等。皆共叹言。奇哉上座。摩诃迦叶师子吼时。三亿众生皆得人身。远尘离垢得法眼净。八十五百千那由他诸天。亦皆离垢得法眼净。长老不空见菩萨。弥勒菩萨。文殊师利童子菩萨。越三界菩萨。如是无量诸菩萨等。皆被坚固弘誓之铠。闻大迦叶师子吼说。以箧盛花搏如须弥。作此变化供养迦叶。爰及一切声闻之众。空中复化作七宝盖。一一声闻各荫一盖。尔时长老摩诃迦叶。见是宝盖语阿难言。此众决定大乘之行。作是种种神变之事

长老阿难我坐莲花。处处方所见佛世尊。不可称计阿僧祇数。复睹诸刹七宝严净。杂色间错微妙无极。其中众生更相迎接。悉见彼国丰乐之相。譬如三十三天之上。贪醉花鬘爱着璎珞。诸天身色如月光明。于虚空中有化宝盖。一一众生各荫一盖。亦如我今等无有异。处处佛刹无量菩萨。从兜率天降神母胎。长老阿难。我今所见。奇哉达行及师子吼。此实非凡之所能为。如是瑞相现大神通。尔时长老摩诃迦叶。即于众中。而说偈言

  阿难汝当知　　我以念定力
  现在于佛前　　以是三千界
  此佛之刹土　　一切诸巨海
  大小江河等　　无量种水聚
  我以神通故　　悉能吸彼水
  置之于口中　　虽皆令枯涸
  众生无伤损　　不恼于水性
  此刹众须弥　　黑山诸山等
  我住神奇力　　悉能吹散之
  我以聪慧智　　又用神通化
  令此佛刹土　　一切成烟焰
  众生不热恼　　亦无畏惧想
  我住于此界　　见彼东方国
  阿僧祇刹土　　悉为火所焚
  奇哉难思力　　令彼火即灭
  既见诸神力　　如此自在行
  令无数佛刹　　悉无有毁损
  我处莲华座　　见此诸刹土
  种种皆端妙　　殊杰鲜俦匹
  又睹兜率天　　菩萨降神时
  不疑诸善逝　　心达自在者
  为是诸声闻　　不空见菩萨
  为弥勒大士　　而有斯瑞相

尔时阿难心生念言。是富楼那弥多罗尼子。说法人中最为第一。今在此会有大神德。决定诸法得到彼岸。如是神通将非己耶。我今当问。即便白言。唯富楼那。如是瑞相大德为乎。答言非也。长老阿难。我之神通调伏利益诸众生故。力能示现以手掌摩此之三千大千世界。不令众生有伤损者。若有众生乐神通力。示现翻覆大千世界。譬如勇健巨力丈夫。以指捻取迦利沙槃。上下抛掷不以为难。我以右手转侧三千大千世界亦复如是。无一众生有恼害者。长老阿难。若此三千大千水界。我以手指一点取之。悉着口中亦无众生生知觉想。我于佛前作此神通

长老阿难。于夜初分。我以清净胜妙天眼。于此三千大千世界。历观诸方何者众生。于法疑滞当为除断。即以天眼观诸方时。处处见有四方世界。其土广大无数众生迷于正法。长老阿难。我心念言。不起此坐往破彼疑。即如三昧清净寂定。调和柔润正直之心。断彼众生于法疑惑。我于会中演说法时。一一众生谓在其前。长老阿难。夜既初分。四方各有无数千众。悉得安住于圣法中。三万众生皆受禁戒。六万众生归依三宝。从三昧起。我如是相神通变化。悉能断除众生疑惑。长老阿难。我能安住于此世界。以净天眼见于北方除怨国界。从此佛土过三万刹。有一众生于法疑惑。是世界中佛般涅槃。应声闻法之所化度。我心念言当断其惑。不往彼处即于此坐。遥令众生自然调顺

长老阿难。我今即时如定心相入此三昧。无数众生作法光明。如是相貌我之声闻。诸波罗蜜皆已满足。若使有人于此众中脱生疑网。不信受者如来起时自可往问。即于是时佛神力故。虚空之中出大音声。阿难。汝今如是受持。如富楼那师子正说。时诸人天阿修罗等。皆叹奇哉实为希有。声闻神通相貌如此。岂况如来真境界乎。时诸人天作此赞已。富楼那弥多罗尼子。即于众中。而说偈言

  我诸漏已尽　　决定到彼岸
  永脱一切生　　为世所归依
  既入于众数　　异佛神通力
  右手能翻覆　　天地山河等
  不令一众生　　而有伤损者
  长老我神通　　势力实如此
  若有三千界　　大千之水聚
  于此佛土中　　或见或不见
  我能以一指　　悉点内口中
  不使诸众生　　而有觉知想
  我于初夜时　　天眼观诸方
  何者众生等　　于法有疑惑
  当住神通力　　悉为除断之
  我见一众生　　于法堕疑网
  若有淳善心　　贪慕求法者
  吾不起此坐　　悉除彼痴惑
  四方千亿众　　我以净眼施
  能令彼生信　　使发菩提心
  时有三万人　　从我受禁戒
  六万诸众生　　归依于如来
  其心得寂静　　安住正法中
  我于初夜时　　示现妙神通
  一念于此坐　　历观东北方
  周观过千刹　　正降怨世界
  彼有一众生　　心疑于诸法
  我住此佛刹　　彼人疑于法
  欲令见正路　　今决其迷惑
  长老我神通　　智力实如斯
  唯佛能哀愍　　一切诸世间
  此处人不信　　可往问世尊
  我今坐莲花　　见彼佛涅槃
  处处方刹土　　阇维如来身
  及见佛殊特　　为是谁神力
  又如我所见　　诸佛般涅槃
  广远甚弘雅　　不可得思议
  为是佛所作　　声闻之人耶

尔时阿难心生念言。此罗睺罗是佛之子。有大威德神通自在。今亦在此大众之中。如是变化将非己耶。阿难即便问罗睺罗。汝于戒学得到彼岸。此之神通汝所为乎。罗睺答言。非我所作。长老阿难。我如是相。种种百千威德神力。随意自在为佛之子。或隐或显未曾忆念。不尝在前亦未示现。长老阿难。我能以此三千大千世界之中。百亿四天下百亿日月。百亿大海百亿须弥。百亿大小转轮之山。如是广大诸余山等。以四神足置一毛端。不令众生有伤损者。于四天下不相逼迫。彼此去来亦无妨碍。吾之神通自在如此。长老阿难。我能以此三千大千一切水界。大海江河溪涧池沼。以一毛孔[口*束]置口中。渟流派别本相分明。其中众生适性不改。水之盈竭亦不觉知

长老阿难。我住此土。如定心相入此三昧。见东北方难生如来。我在此刹白净王所。撮取一把栴檀末香。供养彼刹一切诸佛。其香芬烈。乃至十方难生世尊化作台观。高十由延七宝所成。即在此处烧众天香。复于台上化作宝盖。其盖足高亿千由延。纵广正等百千由延。彼世界中一切众生。皆共幻作栴檀楼阁。其楼上高百千由延。纵广正等五千由延。如是无量在宝台中。各各庄严不相障碍。长老阿难。瑞相如是。我于声闻具波罗蜜。或有生疑不能信者。世尊若起自可往问。我师子吼如来证知。时罗睺罗。即说偈言

  长老阿难陀　　我以大千界
  百亿四天下　　及无数佛刹
  如是诸刹土　　悉入一毛孔
  我神通如此　　无所譬类者
  世界甚广大　　不满一毛孔
  各安去来业　　悉不见妨碍
  我能如是示　　神力不虚行
  须弥宝山王　　及大小转轮
  复有诸余山　　皆入一毛孔
  以我神变力　　彼此不相碍
  长老我如是　　示此神奇相
  悉见入毛孔　　而身不疲惓
  我又神足力　　以此大千界
  江河大海水　　吸内毛孔中
  而此佛刹土　　一切大水聚
  当入毛孔时　　区别不浑乱
  我在善逝前　　示现于神通
  若疑不信者　　往问普眼尊
  我处莲华坐　　见十方菩萨
  头目及妻子　　施以求菩提
  奇哉我所见　　实生希有心
  不疑于世尊　　所作之神变
  为诸大威德　　善逝声闻众
  为是不空见　　弥勒菩萨等

长老罗睺师子吼时。八十七亿百千那由他。诸天人等得法眼净。是诸天等见法到法。选择众法明了于法。如是相貌当设供养。以天栴檀细末之香。以用奉散罗睺罗上。奇哉佛子离垢清净。住大乘行深妙之法。能演师子殊妙之音。善哉罗睺未来之世。当师子吼犹若今日

尔时阿难心生念言。此须菩提阿兰若行。最为第一而无等双。今是大德在此会中。世尊常说此须菩提。能作种种无量神通。阿难即问须菩提言。如是变化将非汝耶。答言长老。非我所为我能常乐不舍闲处。如彼定心入此三昧。以是三千大千世界。置一毛端极微之分。周回旋转如陶家轮。其中众生无觉知者

长老阿难。我于佛前。能师子吼正说无畏。吾以一气吹此三千大千世界。悉令烧尽。不使众生有热恼想。我曾示现如此神变。能在佛前说师子吼。以此大千世界众生。置一指端上升虚空。彼此寂然无诸音声。不相触碍及觉知者

长老阿难。我之所能。如彼定心入此三昧。以清净眼一时瞩对八方上下六万诸佛。一一方中又睹六万百千世界诸佛如来。彼处次第见无前后。长老阿难。我如定心。如其相貌作神通行。住此阎浮须弥山顶。释提桓因所居天宫。撮取一把栴檀末香。俱时遍散十方诸佛。纷纶弥漫以用供养。我住此刹见彼众生。恭敬尊重赞叹如来。彼土众生悉知我是释迦如来应正遍知声闻之中空闲第一。长老阿难。我之神通。如是相貌究竟彼岸。若此人天于我生疑。有不信者往问世尊。如来自当知此三昧。时佛神力于虚空中。震大音声告阿难言。如须菩提正说师子无畏之音。汝可受持。时诸人天梵魔沙门。一切阎浮阿修罗等。既得法利生希有心。惊愕毛竖叹言奇哉。声闻神变乃能如此。岂况如来种种神力。无数三昧真实者哉。时须菩提知诸人天已得法利。即说偈言

  世间师称我　　阿兰若最胜
  安住禅解脱　　现无量神力
  长老阿难陀　　我能以大地
  置于一毛端　　旋之而不危
  亦如陶家轮　　虽转不倾侧
  又于世尊前　　破碎一切地
  及以诸山岳　　无有损伤者
  我住神足力　　威势皆如此
  我能以手掌　　举刹及众生
  安置虚空中　　从上次第下
  亦无一众生　　惊疑怖畏者
  我入三昧时　　见彼东方佛
  其数有六万　　南方亦复然
  我复见西方　　六万世间尊
  北方及上下　　斯数亦如是
  及睹众楼阁　　妙绝无等伦
  以少栴檀末　　供养诸世尊
  我实有若斯　　无垢神通行
  能大师子吼　　及诸示现等
  不能深信者　　可往问如来
  我无众生想　　亦无无生想
  无佛无法想　　一切无相故

    菩萨念佛三昧经弥勒神通品第四

尔时弥勒菩萨摩诃萨心生念言。是诸声闻有大威德无数神通。各各自说大师子吼。我当于此人天魔梵。沙门婆罗门。声闻菩萨大众之前。微现神变。即于晨朝语阿难言。大德。今可正衣持钵共往佛所。到已头面礼如来足白言。世尊。我今欲入王舍城中分卫乞食。世尊知时默然而许。于是弥勒告阿难曰。我向心念。初受食处于此众生。先当令发无上道心。然后乃取此人饭食。大德阿难。我已发意。今便共行入城乞食。诣大长者婆罗门家。到已持钵默然而住。长者见已即便白言。善来比丘久望慈顾。愿圣今者受我蔬食。弥勒菩萨语长者言。我今未能受尔供养。汝若能种无上菩提善根因缘。当受汝食

是时长者即白弥勒。若能以我所施之食。供养恒沙诸佛世尊。然后乃当发菩提心。决定大乘真实之行。所以者何。我于先佛种善根故。时阿逸多答长者言。若能安住如是誓愿。我当以食供养恒沙诸佛世尊。皆使周遍。长者复言。唯然仁者。我当真实发大誓愿。愿以此食供养恒沙诸佛世尊悉令周普。如是三白。尔时弥勒语长者言。汝今便可时施所供。当以献上恒沙诸佛

尔时长者即以名膳奉授弥勒。弥勒受已。于长者前一念之须。忽然往彼恒沙佛所。供养周遍奉设既毕。还长者家。长者见是神通之相。叹言希有踊悦无量。我今复应种诸善根。奉施甘果肴膳美味。严饰床座皆悉丰足。长者复持一切珍宝。香花花鬘金衣素叠。俱共往诣至如来所。到已头面敬礼佛足。于如来前发菩提心。又立大愿而作誓言。若有众生修菩提行。闻我施食善根因缘。一切当得无上菩提。若吾斯愿诚谛不虚。必当获得阿耨多罗三藐三菩提。时无数菩萨及诸声闻。一切大众咸来集者。此之三千大千世界。即时应当六种震动。发是誓已大千刹土。便大起踊具十八相。是时长者语阿难言。大德。今者现为我证。若不信者问于世尊。神通相貌具足如是。我今未得无上菩提。自在变化已能如此

弥勒菩萨语阿难言。我忆过去阿僧祇劫。造光佛所。修得少分诸佛如来所行三昧。获是定已见于东方无数诸佛各住彼刹。以三昧力于无量劫方便度脱。不可计众得阿僧祇神通变化。住于阿耨多罗三藐三菩提道。犹今王舍婆罗门也。大德阿难。我于往昔莲华上佛应正遍知所。以一神通化度三万亿那由他百千众生。住无上道。大德阿难。我于往昔最高如来应正遍所。得普世定度脱六万欲界诸天。发菩提心。我具如是神通相貌。时阿逸多。即说偈言

  正服持应器　　往诣能仁尊
  头面礼佛足　　白言行乞食
  佛即许其去　　当广利众生
  吾般涅槃后　　汝应次作佛
  名誉及功德　　一切皆具足
  我时心念言　　今日行分卫
  若初施食者　　令住三菩提
  时彼大长者　　见我行乞食
  即便从坐起　　恭敬意无量
  善来阿逸多　　希现乃如此
  今来一何晚　　唯愿前坐食
  大士法难思　　当设鲜微膳
  长者汝若能　　为利诸人天
  发无上菩提　　我当受汝食
  即时若能尔　　我当立誓愿
  阿逸汝即时　　能以所施食
  奉献恒沙佛　　悉令周遍者
  然后我当发　　无上菩提心
  长者若定能　　作此真实誓
  施于恒沙佛　　愿得大果报
  我今保此誓　　建立必不虚
  持钵受食已　　普供人中尊
  修行菩提道　　利益诸众生
  阿难是长者　　见我神通事
  心敬大欢喜　　叹仰未曾有
  其心即安住　　无上坚固愿
  复施珍果膳　　严饰妙香花
  素叠及名宝　　种种众妙供
  共我诣如来　　深发菩提愿
  长者发誓已　　更作广大愿
  其愿无限量　　不可得思议
  众生若闻者　　此刹成佛道
  造光如来处　　得此微妙定
  诸佛之所说　　施不思议乐
  造光世尊所　　获得此三昧
  尔时我悉睹　　十方诸如来
  若得大威力　　乃能见是事
  安住此三昧　　示现诸神通
  百阿僧祇劫　　修习种种行
  利益诸众生　　未曾有休息
  莲花上佛所　　得是三昧已
  我以种种化　　七十千众生
  皆悉令得修　　无上菩提道
  最高如来所　　专修诸梵行
  得微妙三昧　　施不思议乐
  最高善逝处　　又得普世定
  尔时复安住　　月出三摩提
  迦叶如来所　　得是深三昧
  大德我如此　　示现神变时
  摄取于往昔　　百千世神通
  若住此威势　　能作种种化
  我亦见诸佛　　现作如此行
  若有欲乐见　　诸佛世之师
  复有欲愿闻　　法轮深妙音
  亦乐拔世间　　一切生死苦
  当勤受持此　　清净三昧王

尔时诸天世人魔梵。一切阎浮及阿修罗。闻阿逸多师子吼已。生希仰心叹未曾有

    菩萨念佛三昧经赞佛音声辩才品第五之一

尔时不空见菩萨摩诃萨。即从三昧庠序而起。时诸人天龙神魔梵沙门婆罗门阿修罗等一切世间。皆悉赞言异哉至法。时不空见告阿难言。妙哉诸佛实为希有。世尊大悲无不具足。故名如来应正遍知。获得无上菩提之道。知一切法无生无行无得无失。波罗奈国仙人鹿苑。三转十二行无上法轮。沙门婆罗门诸天魔梵。一切世间无能转者。所谓是苦是苦集是苦灭是苦灭道。八圣道分无数章句。无量诸相无限行处如此义味赞诵解说。分别敷拆无不具足

时不空见复告阿难。善哉诸佛大悲满足。故名如来应正遍知。得是无上菩提之道。今此大会诸声闻众。未曾闻法当令闻之。先所未说今当为说。不思议法当思议说。所未得法今当使得。未学之法令得修习。无相之法作有相说。略说少法启悟弘多。今告此众诸阿罗汉。毕竟作证无著真人。永得解脱无始生死

阿难当知。譬如有人以一把[麥*戈]投恒河中。谓能以此断彼驶流。此人所作为难不耶。阿难答言。如是甚难。时不空见语阿难言。诸佛如来应正遍知得无上道。为诸声闻说未闻法倍难于彼。复次阿难。譬如有人生无口舌。声震恒沙一切世界。此为难不。阿难答曰。如是甚难。不空见言。诸佛如来应正遍知得无上道。为诸声闻不思议法作思议说尤难于彼。复次阿难。譬如有人指虚空中示种种色。为难不耶。阿难答曰。如是实难。不空见言。诸佛如来应正遍知得无上道。令诸声闻所未得法今当令得弥难于彼。复次阿难。譬如有人无有手足及咒术力担须弥山或欲履水。或持浮木渡于大海。此为难不。阿难答曰。如是甚难。不空见言。诸佛如来应正遍知得无上道。为诸声闻以无相法作有相说。以未学法作有学说又难于彼。时不空见。即说偈言

  诸佛不思议　　深行大慈悲
  常施法光明　　相继恒不绝
  无数那由他　　亿劫甚难见
  无比最胜尊　　未闻当令闻
  有为缘起转　　无实恒虚伪
  毕命常无生　　一切法空故
  诸佛所行慈　　不可得思议
  佛说所未说　　如此难见法
  利益诸人天　　普及于一切
  诸如来深解　　不可思议法
  能为声闻众　　说有思议法
  佛说无相法　　能作有相说
  外道痴所迷　　不识生死源
  如来既知已　　皆悉令摧伏
  住十力敷演　　未得法令得
  世尊真实说　　利益诸人天
  欲以一把[麥*戈]　　断截恒河水
  长老此虽难　　未足称为难
  世依说无生　　斯难过于彼
  若人无口舌　　声震遍诸刹
  虽复能如此　　不足以为难
  未学令得学　　是则最甚难
  若人指空中　　言有种种色
  诚能为此事　　岂足称甚难
  未得法令得　　我说最为难
  若人无手足　　担负须弥山
  欲渡于大海　　未足以为难
  无相说有相　　此则倍难彼

菩萨念佛三昧经卷第二菩萨念佛三昧经卷第三

        宋天竺三藏功德直译

    赞佛音声辩才品第五之二

时不空见复告阿难。诸佛世尊希有殊特。于阿僧祇无量诸法。决定究竟到于彼岸。故名如来应正遍知。戒定慧解脱知见等众一切法相无取着行。建胜宝幢出一大音。若有众生乐闻施惠得解脱者。即生念言。如来为我说施利益。若有众生乐闻禁戒得解脱者。即生念言。如来为我说戒饶益。若有众生乐闻三昧得解脱者。即生念言。如来为我说于三昧。若有众生乐闻智慧得解脱者。即生念言。如来今者为我说智。若有众生乐闻解脱得济度者。即生念言。如来今日为说解脱。若有众生乐闻解脱知见之者。即生念言。如来为我说于知见。若有众生乐于生天得解脱者。即生念言。如来为我说于生天。若有众生乐闻无常得解脱者。即生念言。如来为我说于无常。若有众生乐闻说苦而得解脱。即生念言。如来今者为我说苦。若有众生乐闻无我得解脱者。即生念言。如来今者为说无我。若有众生乐闻寂灭得解脱者。即生念言。如来为我说寂灭法。若有众生乐闻不净得解脱者。即生念言。如来为我说不净法。若诸众生乐闻无上道得解脱者。即生念言。如来今者为我赞叹诸佛功德说大乘法。无一众生闻如来说如此法已不解脱者。时不空见。即说偈言

  此闻调御师　　于众中演说
  戒定慧解脱　　解脱知见等
  如是一切法　　宣说皆作佛
  乐闻说施戒　　而得解脱者
  各闻世间依　　叹施戒功德
  乐闻说定智　　解脱功德者
  即闻佛世尊　　演不思议音
  乐生天解脱　　牟尼即为演
  乐闻智慧者　　天中天今说
  乐闻无常苦　　无我不净说
  寂灭等诸音　　而得解脱者
  即时便得闻　　不可思议声
  若有欲乐闻　　辟支佛功德
  善逝今便为　　说斯缘觉乘
  闻佛诸功德　　如此解脱乘
  世尊说法已　　众生求菩提
  如此一切音　　不可得思议
  佛所宣诸法　　利益于世间
  既蒙解种种　　清净之妙声
  即时悉皆发　　无上菩提心

时不空见复告阿难。诸佛世尊殊特希有。成满一切无数善根。故名如来应正遍知。亲近供养无量诸佛。布施调伏一心寂定。今得无上菩提之道。具足成就无数辩才。释迦如来得无量辩。最无上辩。无能答辩。无取着辩。胜解脱辩。无挂碍辩。成就性辩。成教化辩。施无热辩。有无问辩。豫知之辩。若有相辩。若无相辩。静默然辩。能除恚辩。种种章句及名字辩。甚深句字及宣示辩。宣示甚深调柔之辩。无量譬辩。无问答辩。具足定辩。具广大辩。具难思议辩。具开敷辩。具清净辩。具无毁辩。具足聪慧无毁损辩。具心无著辩。具心无吝辩。具足无失字句之辩。具无盗辩。具无妄辩。具足开发说法意辩。具足说法开发烦恼生净心辩。具足亲近说章句辩。具说过去辩。具说未来辩。具说现在辩。具说希有辩。具足无生胜妙智辩。具足一切大众喜辩。时不空见。即说偈言

  昔已曾至心　　供养无量佛
  是以人中尊　　今得无上道
  不思议善根　　阿僧祇诸辩
  无碍开发辩　　佛得此众辩
  无上解脱辩　　成就教化辩
  广宣诸相辩　　有问无问辩
  种种说甚深　　随顺譬类辩
  清净难思音　　具足妙说辩
  淳净义成就　　决定众相辩
  不思及不退　　无卑无下辩
  善哉明慧人　　无著无毁辩
  不失字章句　　无妄摄乐辩
  能断烦恼心　　不忘十力辩
  最上及亲近　　宣说三世辩
  若圣与不圣　　如此随顺辩
  无远无生等　　近听远闻辩
  说善逝功德　　音声清畅辩
  若人以一毛　　点取大海水
  可知其数量　　能令干竭尽
  无有知诸佛　　如来大胜辩
  或有量虚空　　能知其边际
  能秤须弥山　　亦可识斤两
  如来智辩力　　无能摧伏者
  虽复历劫数　　不测如斯辩

时不空见复告阿难。长老当知。诸佛世尊大梵音声。师子音声。雄猛之声。龙王音声。弦声歌声。柔软好声。大小雷声。不思议声。无量妙声。无边胜声。满足音声。不退之声。迦陵频伽声。清净欢喜声。如来分别声。如来识了声。如来甚深声。如来无毁声。如来不却声。如来清彻声。无衰无损声。如来美妙声。如来最美声。如来无不美声。如来广具足一切功德声。是处说如来应正遍知。以一音声令一世界。其中众生皆悉乐闻

又以一音令二世界。其中众生亦愿乐闻。如来一音乃至百千万亿那由他无边世界。其中众生乐闻亦然。彼处众生闻如来声。如是解了如是识知。皆言如来为我说法。如是阿难。诸佛如来不思议音利益之声。譬如日轮照阎浮提。有目众生皆蒙慧利。如是如来应正遍知。音声法轮清净微妙。济拔一切亦复如是。长老阿难。譬如初春十五日夜月轮圆满。清明澄照无诸霞翳。阎浮提人皆出游观。得恣欢娱。缘月盛故。如是如来应正遍知。音声法轮清净微妙。众生所以得利益者。缘遇如来法光明故。长老阿难。譬如众川江河溪壑。巨细诸水悉入大海皆成一味。而此一味具足众味。亦有无量诸妙珍宝。人及非人虽贪此宝。大海深广难可得渡。如是如来应正遍知。清净音声法轮难解。令诸众生得法宝利。无量安乐亦复如是。长老阿难。譬如大地开发种子生长万物。利益众生无不丰溢。聚落城邑帝王京畿。一切境界皆依此地。如是如来应正遍知。音声法轮清净微妙。拯救一切无量众生。悉令欢乐亦复如是。长老阿难。譬如虚空。世间去来无所妨碍。而此虚空能安乐物。如是如来应正遍知。音声法轮清净微妙。饶益一切亦复如是。长老阿难。譬如三十三天上。波利质多。拘毗罗树花叶芬敷。诸天游观莫不欢适。如是如来音声法轮。清净敷演一切法声。甘露利乐亦复如是。时不空见。即说偈言

  世尊梵王音　　阎浮提第一
  师子雄猛声　　及以大龙声
  弦竹调软音　　十方不思议
  钟鼓雷吼声　　无边普震声
  佛土满足声　　未曾衰减声
  迦陵频迦声　　爱顺欢喜声
  圣喜无浊声　　教与无教声
  甚深无为声　　无讥毁谤声
  难见善分别　　句字之音声
  无诸衰损声　　美妙普遍声
  无有系缚声　　及无遗忘声
  一切功德声　　世间依所说
  能以一音声　　遍满一切界
  调伏群萌类　　欢喜悉乐闻
  皆云今如来　　独为我说法
  如来以一音　　乃至恒河沙
  无量世界中　　众生皆乐闻
  譬如出晖明　　照耀一切物
  世尊如是音　　为众演说法
  初春十五日　　满月光澄净
  如此明月轮　　遍照阎浮提
  皆令得欢乐　　利益亦无边
  世依犹斯月　　睹者无不欣
  清净妙音声　　能为利一切
  阎浮提最上　　不可得思议
  如大海无边　　众宝之所出
  深广难可济　　饶益一切众
  大胜佛如是　　最上无过者
  有教无教等　　音声甚难解
  清净无所毁　　能施一切乐
  于此三千刹　　安置一切众
  佛音声如是　　利物难思议
  虚空无挂碍　　能通诸飞行
  世尊音如是　　广润一切众
  如天香花树　　敷荣善利益
  如来诸音声　　具足益世间
  我于一劫中　　说佛声功德
  虽复历百劫　　不测其始终
  诸佛亦如是　　不可思议音
  十方诸众生　　异口无边辩
  说佛声功德　　不能尽其际
  世间依如是　　不可思议音
  若有诸水陆　　一切众生等
  假令悉得佛　　不测声涯底
  诸善逝如是　　不可思议音
  如此调御师　　音声无与匹
  若能随顺念　　终不堕恶趣
  若有诸菩萨　　闻佛具足音
  当得佛法王　　不思议音声

时四天王。释提桓因。焰摩天子。兜率天子。自在天子。及大自在。并与其子名曰商主。大梵天王。净居诸天。复有大力威德诸天。欲色二界诸天子等。闻不空见菩萨所说佛声功德。叹未曾有。以天栴檀细末之香。散不空见菩萨摩诃萨。乃至十方供养已毕。时有六十亿百千那由他欲色诸天。闻此音声皆种无上菩提善根。五千比丘亦发无上菩提之心。被弘誓铠。七百千万诸比丘尼发无上心及弘誓愿。百千优婆塞从花座起。诣不空见大菩萨所。复有二亿百千那由他诸女人等。各脱身上珠宝璎珞。奉不空见菩萨摩诃萨。亦发无上菩提大愿

    菩萨念佛三昧经赞如来功德品第六

尔时不空见菩萨摩诃萨告阿难言。奇哉希有诸佛如来。具足深知生死往来。忆识生处亲戚眷属。善知烦恼诸恶过患。具足相好具足行舍。大舍意念戒定智慧。解脱解脱知见。具足六通到于彼岸。若慈大慈若悲大悲。若喜大喜若舍大舍。最胜无伦到于彼岸。威仪神通一切诸法。最胜无碍到于彼岸。若处非处示导诸方。利益最胜到于彼岸。及舍摩他毗婆舍那。最胜无比到于彼岸。一切禅定解脱三昧三摩跋提。最胜无上亦到彼岸。无贪无嗔无痴无慢。无惛无过无有慢慢。无惑无恚。度脱五道四毗舍罗(此或言施戒法世间皆无悭义)众生善根业报论议。最胜无等到于彼岸。一切众生戒聚不断。不漏不浊无杂无言。慧明清净勇猛殊胜。沙门婆罗门人天魔梵。一切世间之大法主。无一众生能测如来戒定之分如毛发许。更无有人能超过者。长老当知。应如是观。我能究尽虚空边际。不能度量诸佛世尊戒定智慧解脱知见。所以者何以无边故。如来戒定神通诸法。非是浅识之所思议。深不可测无能穷者。时不空见。即说偈言

  世尊生死尽　　住胎难思议
  法性以为母　　不可得为比
  具足善功德　　世间无能及
  身相三十二　　八十种妙好
  世间叵思议　　摄取诸善业
  妙哉人中尊　　具足善超出
  若舍及大舍　　烦恼心解脱
  方便诸胜业　　满足无与等
  具足戒定智　　解脱知见分
  诸佛法无边　　六通到彼岸
  如来具慈悲　　喜舍诸行处
  能解众生缚　　拔济种种苦
  诸佛深智聚　　不可得思议
  威仪无等比　　神通到彼岸
  无诸烦恼行　　善解于真谛
  若处及非处　　利益悉具足
  定解脱如此　　不可得思议
  善解舍摩他　　毗婆舍那等
  已到世所无　　永离诸恶心
  善学定解脱　　除灭愚痴患
  净戒不断绝　　不漏亦不浊
  善学戒无失　　勇健明哲人
  无有一众生　　而怀疑谤心
  沙门婆罗门　　人天及魔梵
  心信不怀疑　　常善学清净
  我能知虚空　　四方广大相
  不能测勇猛　　无上清净戒
  能以一气吹　　海水令枯涸
  不能测如来　　清净法明戒
  能以一气吹　　须弥令碎尽
  大小转轮山　　亦复成粉尘
  不能测如来　　净戒之崖际
  虽复历劫数　　不能得其量

时不空见菩萨心生念言。善哉如来应正遍知。愿屈威神降临众会。我今欲为诸菩萨等。请问如来念佛三昧。世尊先于大众之中。虽说其名竟不敷演。便入静室右胁而卧。尔时世尊即知其念。佛神力故令此三千大千世界。六种震动具十八变。亦如前说放大光明。普照此土娑婆世界。日月星宿欲界诸天。无边恒沙众梵天等。其明隐蔽悉不复现。唯佛神光显耀殊特。愍众生故即从卧起。齐整衣服往大会所。时诸世间人天沙门婆罗门等及阿修罗。各见如来殊胜光明。从花座起往诣佛所。恭敬合掌却住一面

时不空见遥睹佛来。容色端严威仪庠序。仰瞻相好无不具足。见已即告长老阿难。世尊今从静室而来。必当敷演显发最胜第一义谛无虚妄说。巧妙宣说无分别说。善能思量不起恶业。身业无毁口业无讥。意业无失三业皆净。戒定智慧及以解脱。解脱知见亦悉具足。无上方便神通利益。不思议辩殊特具足。善知生死无能过者。住胎清净母族豪胜。众善功德最为具足。不可思议相好具足。往昔因缘及意具足。烦恼解脱心得具足。若舍大舍超出具足。五识无取离染具足。五分法身清净具足。究竟已到六通诸法。及法性相皆到彼岸。毗婆舍那及舍摩他。根力觉道到于彼岸。慈悲喜舍不可思议。深心惭愧到于彼岸。已至诸法自在彼岸。过去未来现在诸法。皆悉知见不着不退。能知一切过去身业。亦知转变到于彼岸。口意二业亦复如是

长老阿难。如来世尊一念能知一切众生心行善恶莫不了达。时不空见告阿难言。譬如大海深广难渡。诸佛戒品渊旷亦然。譬如须弥永不可倾。如来定品难动亦然。长老阿难。譬如虚空。清净容纳无有齐限。诸佛三昧摄取无边清净智品。又摄一切众生净心。长老阿难。譬如日光。悉能临照无量色像。如来法光无幽不烛。长老阿难。譬如大火。焚烧山野一切众物。如来法火能烧众生无量烦恼永得清净。长老阿难。譬如涌泉。盈流出外成于渊池。能洗万物皆令洁净。如来法水亦除众生一切结累常得获安。长老阿难。譬如医王。善疗众生种种疾患。如来法药能消众生生死重病皆使永除。长老阿难。譬如时雨。润益卉木无不增长。如来法雨亦润一切枯槁众生。长老阿难。如师子吼。能使众兽皆令慑伏。如来法音能坏众生计我见者永得远离。长老阿难。譬如大船能济彼岸。如来法船渡诸众生四流彼岸。长老阿难。如优昙花希有难见。如来出世亦复难遇。长老阿难。譬如波梨质多罗树。其花敷荣馨香殊特。佛大人相明发亦然。长老阿难。譬如父母能育诸子。如来亦尔善利众生。长老阿难。若人说言如来出世。无边正说是名真说。若人说言如来出世。说不思辩是名正说

长老阿难。略说如来有无边辩。无取着辩。无挂碍辩。胜解脱辩。成就妙辩。常随顺辩。渐亲近辩。有无问辩。微妙净辩。最上辩。慈大慈辩。悲大悲辩。喜大喜辩。舍大舍辩。佛出世辩。又利益辩。长老阿难。若人说言如来出世。具足利益一切众生是名正说。长老阿难。若人说言众生无安。无救无归无趣无主。如来出世能作安救。及归趣主是名正说

长老阿难。我若一劫或至百劫。宣说诸佛世尊功德智慧辩才。亿不及一。又于无量一切诸劫。宣述如来应正遍知功德辩才不能穷究。长老阿难。譬如有人。羸老挛癖住他人所。语彼人言奇哉丈夫。我虽如此能以一毛点取一切无量诸水。内置口中悉令枯竭。此人既无神通咒术。能为斯事为可信不。阿难答言。此为难信。不空见言。实不能也。徒空言耳。如是阿难。我说诸佛功德辩才不能穷极。犹如彼人无竭水理。长老阿难。假使我于亿百千那由他劫。不能宣说诸佛功德。智慧辩才一毛之分。唯佛与佛乃能尽耳。长老阿难。如此大地容受众生。乃至有足及以无足。四足多足有色无色。有想无想非有想非无想。若此世界若他世界。若千世界百千世界。无量无边一切世界。其中众生当得成佛。是诸世尊于亿百千那由他劫。说佛功德不能穷尽一毛之分。如是功德无不具足。时不空见。而说偈言

  长老阿难陀　　法王从彼来
  一切诸世众　　无不兴供养
  胜炎光明主　　功德皆无数
  最胜利益说　　真说不生说
  谛说无妄说　　无异及善说
  出微妙音声　　大智善宣说
  身口意清净　　不缘虑诸恶
  如来胜戒定　　第一智解脱
  解脱知见等　　威仪常难思
  无上神通智　　利益最无比
  善得无垢行　　最胜微妙辩
  无上人中尊　　具足知生死
  住胎既无比　　母族亦复然
  不思议殊相　　八十种妙好
  容色甚挺特　　端正无有比
  具足无惑心　　舍大舍亦尔
  超出一切欲　　五识无不具
  证智超六通　　具足四无碍
  备无量知见　　难思众神变
  舍摩毗婆那　　皆悉度彼岸
  达舍离垢主　　威仪恒自在
  众中大神王　　徐行从彼来
  无著修伽陀　　住于十力智
  行慈演法光　　一切胜智说
  能知大海水　　无边深广量
  不测无上力　　净戒定崖畔
  虽历亿千劫　　不知其限齐
  以手接须弥　　上掷至梵天
  不能动如来　　最初甚深定
  游猎虚空中　　可知其边际
  无有能测度　　如来不毁智
  能以足履虚　　穷极其限量
  不能测离垢　　弃累人中尊
  如日能除闇　　悉见善恶色
  自然世间师　　能灭愚痴瞑
  譬如月盛满　　一切皆欣乐
  法月光明王　　睹者皆欢喜
  如夜然明灯　　有眼无不见
  调伏无比灯　　能演法光明
  世师法灯炬　　善灭一切阴
  宣说自然法　　普闻于众生
  大智胜医王　　犹如涌流泉
  法药消众病　　能施一切乐
  譬如大龙王　　普降于甘露
  能令此大地　　一切皆沾洽
  大悲哀世尊　　法雨亦如此
  譬如师子吼　　蠕动皆怖畏
  如来震法音　　降伏诸外道
  譬如大牢船　　能运载一切
  佛度多亿众　　济彼四流岸
  譬如优昙花　　奇哉称希有
  人中尊难遇　　乃复过于此
  一切诸世间　　常所归依处
  如天喜见城　　婆梨质多花
  芬敷垂光彩　　诸天所游乐
  世依踰于彼　　相好甚微妙
  世尊已为我　　示现诸神变
  我今少宣说　　诸佛之功德
  以我所修业　　以施利众生

    菩萨念佛三昧经如来神力证正说品第七

尔时世尊以金色手。摩不空见菩萨顶上。出广长舌而告之言。善哉善哉。汝不空见。善说如来应正遍知真实功德。信如所言。又不空见。若人说言无安无救。无归无趣无主众生。如来出世能为如是诸众生等。作安作救归趣主者是名正说。又不空见。若人说言如来出世。说不思辩及无边辩是名正说。又不空见。若人说言一切众生。深着贪欲嗔恚邪见。如来出世悉能除断贪欲等病是名正说。又不空见。若人说言一切众生。嫉妒缠垢之所染着。如来出世悉令除断是名正说又不空见。若人说言一切众生无惭无愧。如来出世能使众生。惭愧具足是名正说。又不空见。若人说言一切众生深着悭慢。如来出世悉能除断。令无悭慢是名正说

又不空见。若人说言一切众生。无慈无悲无喜无舍不善恶念。如来出世悉令具足四无量心利益善念是名正说。又不空见。若人说言一切众生无诸善根。如来出世教化一切令种善业是名正说。又不空见。若人说言五浊恶世众生病增。如来出世能作安乐。此人所言即是我说。所以者何。我出恶世说法利益诸众生故。尔时如来摩不空见菩萨顶时。于一念顷。此界众生承佛神力。悉见东方清净刹土。无量无边阿僧祇佛。及闻诸佛说法音声。如是南方乃至十方。如观掌中庵摩勒果。一切众生悉皆见彼清净佛刹。又一念顷。如来世尊应正遍知。以金色手摩不空见菩萨顶已。以佛威神示现往昔最胜愿力。即见上方清净佛刹。无量无边阿僧祇数已灭度佛。又复受持三昧力故。得见未来一切诸佛。时不空见睹诸佛已。即从坐起齐整衣服。右膝着地合掌恭敬。白佛世尊。而说偈言

  三千大千水　　人或知其限
  善调御世尊　　戒品不可量
  假使旷劫思　　不能测其岸
  如有勇健士　　一吹震须弥
  佛入初禅定　　千劫不能动
  足履虚空游　　能知其边量
  纵使穷劫中　　不能度佛智
  虚空无形量　　狂风亦能动
  世尊无烦恼　　莫能断其辩
  如日照虚空　　其光甚明彻
  大仙尊辉相　　映蔽于一切
  犹月星中最　　圆光甚可乐
  如是法月王　　一切皆归仰
  譬如优昙花　　世间所希有
  调御天中天　　难值过于此
  今者大圣尊　　哀矜摩我顶
  金色百福严　　怜愍利一切
  深解真实谛　　功德悉具足
  世依善宣说　　言论人中上
  敷演难思音　　普闻十方界
  自然尊慈念　　以手摩我顶
  得见恒河沙　　最胜世间王
  人中大牟尼　　一念摩我顶
  悉睹恒沙佛　　犹如阿弥陀
  天中尊利益　　一念摩我顶
  得见不动界　　阿閦两足尊
  大悲所行处　　一念摩我顶
  得见灭度佛　　一切世间师
  大慈所行处　　善调伏诸根
  我乘昔愿力　　即于摩顶时
  得见未来佛　　弥勒世依等
  即摩我顶时　　得见过去佛
  亦得睹当来　　十方难思尊
  佛眼调伏尊　　即时摩我顶
  复因宿妙愿　　得见清净刹
  如来不思议　　神通亦复然
  智定诸功德　　皆不可称量
  世尊慈悲故　　哀愍见教化
  如来金色手　　以摩我顶上
  得见十方佛　　金塔如恒沙
  复见十方界　　无数诸如来
  殊胜银宝塔　　庄校种种色
  百千众伎乐　　供养常不绝
  我又见他刹　　诸佛众具塔
  金银及颇梨　　各高一由延
  端严甚精妙　　不可以言宣
  见诸牟尼塔　　种种七宝严
  住于虚空中　　天花悉周布
  又见殊胜塔　　高十二由延
  及睹灯明佛　　净光照诸刹
  我复见处处　　不思议众塔
  又睹余胜尊　　以手摩我顶
  佛以柔软手　　一念摩我顶
  见彼诸如来　　安住于刹土
  或复在空中　　而现种种相
  复睹诸菩萨　　未脱众惑累
  在无量佛刹　　修习诸苦行
  日夜常勤心　　以求胜菩提
  又见处处有　　无数诸菩萨
  常能为众生　　作诸利益事
  烧身发光明　　以求道因缘
  复见诸菩萨　　安住于佛前
  供养灭度佛　　无量珍妙塔
  以求菩提利　　及以大威德
  见十方法缘　　烧身如灯炷
  昼夜常修心　　不懈于食息
  又见诸菩萨　　舍国城妻子
  头目及髓脑　　为安乐众生
  我悉见彼此　　普眼世间尊
  威力得自在　　不可以言宣
  如我所知者　　世间最为上
  天中天以手　　哀摩我顶时
  即得见彼众　　归命人中尊

    菩萨念佛三昧经不空见劝请品第八

尔时不空见菩萨摩诃萨白佛言。世尊。如来处室宴寂既久。此会大众皆悉渴仰。严座已讫。唯愿世尊。哀愍一切屈就斯座。时不空见更正衣服。合掌向佛白言。世尊今欲请问愿少宣说。我当至心听受奉行。佛告不空见。恣汝所问。当为决疑令尔欢喜。诸天世人亦当证知。时不空见白言。世尊。菩萨摩诃萨亲近修习何等三昧。得见法乐增长其心。所闻三昧旷如大海。菩提之心安若须弥。外道邪风所不能动。于无碍法心亦无著。犹如虚空无所染污。破无明闇亦如朝日。施法光明若月盛满。烧一切阴炽然猛炎。焚诸烦恼之大火聚。譬如江海一切诸水。水性之属依之而活。又如大船能渡彼岸。亦如桥梁能令众生。不堕生死烦恼驶流。犹若波梨质多罗树生诸众生。七菩提花悉能普薰十方世界。如优昙花世所希有。亦如良医善疗诸患。大悲广救应病授药。如栴檀树能消热恼

又如大雨润施一切。胜妙之法味若香蜜。令众无畏如师子王。安乐众生过于慈母。深知法性达义趣相。得义巧便法相亦然。善于正道具足方便。如实说法得安摄众。开发众生生死根源。一切法性如海一味。三昧安静犹若山王。道心不动譬如帝幢。得坚固力身相端严。威仪具足无所染污。族姓豪胜功德备足。得无边辩无所著辩。无异句辩不思议辩。无边量辩深解脱辩。成就胜辩常忍辱辩。渐亲近辩问无问辩。无毁坏辩无退转辩。甚深句字种种说辩。甚深广说章句字辩。无量无边喻譬之辩。如是一切悉皆具足。未得道者当令得道。及得梵音意欢乐音。迦陵频伽师子等音。大龙牛王钟鼓美音。歌音弦音雷震之音。得于一切世间供养。具足六通到于彼岸。得无忘失忆持之法。获诸善根容仪轨则。时不空见。以偈问曰

  金色百福严　　深解于真谛
  怜愍善利益　　听我问诸佛
  应修何三昧　　具足净功德
  人中无比尊　　众智无过者
  我今问世间　　最胜无上主
  为行何三昧　　功德不思议
  云何诸菩萨　　而得人中上
  应当勤修习　　最胜寂静定
  行此三昧已　　为世作利益
  云何得自然　　多闻如大海
  云何获不动　　深妙之智慧
  住佛诸功德　　犹如转轮山
  云何心不着　　自然如虚空
  摧伏诸外道　　不起于恶心
  云何当修得　　犹若日月等
  又复当云何　　同彼大灯炬
  求习何三昧　　光明照一切
  云何得消除　　众生老病累
  云何令一切　　得度于苦海
  云何得发心　　敬礼三界尊
  云何如天花　　相好甚明着
  优昙时一现　　值佛难于是
  云何如医王　　施药灭众病
  善调伏诸根　　安住于戒品
  云何如法王　　度无边功德
  云何见法满　　犹如甘净蜜
  云何师子音　　施利于众生
  云何如慈母　　施众难思乐
  云何得四辩　　行甚深菩提
  为我说最胜　　无上第一道
  云何能得说　　无著大智慧
  云何义巧便　　得法不思议
  善知巧便相　　知世出世法
  云何能得意　　云何复得道
  云何得忆念　　云何安具足
  云何得多闻　　深广若大海
  云何说诸佛　　真实之功德
  云何说众生　　生死之源本
  诸法无异相　　如海同一味
  云何得三昧　　不动如山王
  菩提心安寂　　犹如帝释幢
  云何得诸余　　不思议菩提
  云何得端严　　成就诸威仪
  云何得豪族　　为功德法王
  云何得无边　　及得无著辩
  云何得成就　　不思句字义
  唯愿世间依　　为我分别说
  云何得最胜　　无上莫能过
  及以无著说　　无失与忍辱
  亲近不思议　　有问无问等
  梵音意乐音　　迦陵善妙音
  得修菩萨行　　愿尊教诏我
  云何得师子　　大龙牛王音
  云何得钟音　　弦歌与美音
  云何获聪慧　　愿世调伏说
  云何得说法　　心常无厌足
  无毁诸功德　　常演震雷音
  云何当得宣　　种种甚深法
  云何众譬喻　　善说到六通
  云何不失法　　百千岁生念
  勤修不懈惓　　善法普眼尊
  若为十方界　　说修不思议
  于诸智不疑　　归趣求解脱
  是以我今日　　请问于如来

时不空见菩萨摩诃萨。如彼神通无作行力。于虚空中当世尊上。自然变成天妙宝盖。七宝庄严种种微妙。于此盖中雨众杂花。绕佛三匝住在顶上。花倾恭敬向佛世尊。即于花中而说偈曰

  归命于大圣　　正觉两足尊
  诸天及世人　　无能与等者

尔时此花堕佛足上。复更踊起。起已自然遍散三千大千世界。复于盖中雨栴檀末。空中交纷堕于佛上。俄尔之间忽然不现。香气芬芬充溢大千。是诸众生闻此香者。身心安隐皆得快乐。犹如菩萨得四禅乐。时不空见现神通讫。即白佛言。云何菩萨得大智慧速疾智慧。猛利智慧无相智慧。甚深智慧广大智慧。普遍智慧不惧智慧。云何获得无上善根。心如金刚坏诸法相。身心柔软心大如海。戒品难量心如磐石。其心柔和正直端严。心如山王摄众善法。心如大地能安一切。得不信他不讥彼阙。得善趣行安住诸法。正向不谤无上世尊。生生恒得无离见佛。住此世界得见他方。无量诸佛闻法遇僧。又得摄取清净国土。常得善根自利利他。是以我今请问世尊。我为解脱饶益众生。为诸菩萨得不思议。具足善根请问如来。为被僧那忍苦大铠。悲一切故请问如来。为欲利乐诸众生故。被弘誓铠无众生想。欲度生死无生死想。我恒如此利益众生。是故我今请问如来。世尊我于诸众生所。不起坏心亦无嗔骂。诽谤毁呰及轻凌心。初无恚恨忿戾怼恨。无忘失意亦不嫉妒。不怀楚毒行于慈悲。我如是相修学大乘。为利益故请问如来。世尊。我今为众生故舍五欲乐。能忍众苦施一切乐。为诸众生作法光明。世尊。我于内外诸法心无吝惜。我如是相利众生故请问如来。世尊。我今被弘誓铠。为一众生于恒沙劫。入大地狱受诸苦恼。我未曾于一念之顷。退失无上菩提心也。是故我今利众生故。悉能忍受无量极苦。而不退于菩提之心。为一切故请问如来。我今如此被弘誓铠。为诸众生作其僮仆。为利彼故请问如来。世尊。我今为众生故。舍于头目髓脑之属。悉忍斯苦不退菩提。如是相貌请问如来。时不空见。即说偈言

  云何习大智　　广智与疾智
  我今故请问　　大雄世间师
  云何得甚深　　微妙大智慧
  最胜菩提道　　唯愿普智说
  云何无惧智　　善巧随顺说
  复得金刚心　　于法不生惑
  云何得柔和　　心无有垢染
  清净戒如海　　不宿于死尸
  复得心如山　　不动难思议
  云何不信他　　亦不讥彼阙
  决定行善趣　　闭塞诸恶道
  安住坚固志　　欢喜心不坏
  云何得生念　　又得于调伏
  住此而得见　　他方刹土佛
  既得闻说法　　亦得值遇僧
  欲得求供养　　他方刹土佛
  种种妙花香　　随意以奉献
  欲求住此界　　见诸无边刹
  世依示神通　　向诸十方国
  我自饶众生　　亦无善友劝
  安住诸惭愧　　自舍于己利
  以利于他故　　请问大胜尊
  若为求佛智　　摄取不思善
  为此利益故　　请问于如来
  无著世间依　　当修何三昧
  如是为众生　　发弘誓大愿
  免济诸群生　　种种诸剧苦
  虽复勤修行　　而无众生想
  为利善趣故　　请问于如来
  于一切众生　　常起平等心
  未曾有分别　　恒修于慈悲
  我为利益故　　请问于如来
  亲近何等法　　疾得难思定
  调御说斯定　　显示无边德
  我发弘誓愿　　为利一众生
  于不思议劫　　恒受烧煮苦
  善哉令一切　　长得获安乐
  永无幻惑心　　常修正直意
  恒舍内外法　　摄取诸众生
  为作利益故　　请问普眼尊
  不嗔不恶口　　秽谤结恨等
  自身能忍苦　　为他作仆使
  是故我请问　　大威德世尊
  常以欢喜心　　勤修菩萨行
  捐弃无量头　　以求胜菩提
  为益世间故　　舍目及手足
  众生随生死　　痴暝无智慧
  何方救济彼　　令得永解脱
  舍所爱妻子　　珍妙诸器服
  金银颇梨珠　　无数众宝藏
  为趣正道故　　请问于如来
  慧施常无厌　　闻法亦复然
  住于阿兰若　　心无有懈退
  为此利益故　　请问于如来
  常求善言教　　闻恶恒舍离
  于诸群生类　　初无不善念
  为是利益故　　请问于如来
  慈心观众生　　如母念一子
  于仇不追怨　　更生邻愍心
  为利一切故　　请问人中王
  若获诸福报　　设复无所得
  亦当为众生　　请问大威尊
  我请自然尊　　若得少福者
  以此业果报　　疾得菩提定

菩萨念佛三昧经卷第三菩萨念佛三昧经卷第四

        宋天竺三藏功德直译

    赞三昧相品第九

尔时世尊告不空见菩萨摩诃萨言。善哉善哉。不空见。无劝汝者。乃能如是为诸众生请问三昧。欲以解脱利众生故。欲令众生具不思议净善根故。欲令众生获得三界最胜利故。为令众生超出三界一切行故。为令众生于诸有为得善义故。为令众生深解随顺得饶益故。为令众生于甚深法决定义故。欲令众生尊说法故。欲令众生敬重施故。欲令众生舍诸有故。欲令众生趣无上戒故。欲令众生具足忍故。欲令众生勤精进故。欲令众生得禅定故。欲令众生深重智慧。如金刚心善修定故。欲令众生心离尘故。欲令众生善摄心故。欲令众生其心不动犹帝幢故。欲令众生重法义故。欲令众生不惜身命厌诸行故。以是等缘请问如来

尔时世尊告不空见。汝今谛听善思念之。吾当为汝分别演说。时不空见即白佛言。唯然世尊。愿乐欲闻。告不空见。诸佛所说菩萨所行念佛三昧。此三昧者。诸菩萨等常应亲近精勤修习。既得修习此三昧已。即便增长见法安乐。增长无贪及以嗔痴。增长惭愧六神通等。增长得见一切诸佛。增长无数清净佛土得知宿命生死因缘。住胎清旷母族豪胜。得微妙善大人相好。具足出家及舍大舍。得知众生其行相续。具足多闻世出出法。又得种种诸善法处。当得善学世无比法。复得善巧说一切法。及得了知前际后际。字章句相智慧备足。得善转心神通变化。善知过患得广大力。得知他方诸菩萨等。及以众生精粗白黑。长短大小处及非处。未成佛道趣向具足。得不动念神通具足。常得大姓高族具足。端正威势功德具足。得梵音等及以诸辩。无不具足悉如上说。同如来生无生之生。常生中国不处边地。欲求遍往他方世界。至诸佛所咨受正法。欲乐住此或游十方。觐诸如来恭敬供养。彼此菩萨功德具足

尔时世尊。即说偈言

  不空见菩萨　　有妙三昧王
  我住智力故　　深知此三昧
  菩萨应当修　　得见十方佛
  到六通彼岸　　疾得菩提道
  见诸净妙土　　摄知生死缘
  住胎既无比　　母族又殊胜
  善修诸法行　　相好皆具足
  出家弃诸爱　　人天所滞欲
  为利世间故　　求于菩提道
  生在豪姓家　　永到甘露境
  具得六神通　　圆足说真智
  多闻持正法　　获得大自在
  多闻广于海　　如闻皆修行
  具众决定义　　及知众生本
  学习世出世　　善法之所趣
  获得聪利智　　捐去无知业
  弃舍有为事　　行于无为法
  亦得天眼智　　天耳闻诸法
  忆念宿世行　　知他心意识
  欲乐现种种　　诸妙神通事
  常善转变心　　开演于明脱
  开发十力慧　　广利于世间
  知处及非处　　诸法之所归
  说烦恼过患　　常应修此定
  得趣向具足　　得意无与等
  得念及威力　　得安行亦然
  姓族最殊胜　　端严甚清显
  弃于有为行　　无毁诸功德
  得大威势力　　人中最殊胜
  犹如天帝释　　天中独尊严
  欲得无比音　　雄猛诸威音
  成就义大仙　　当求此三昧
  如龙欢喜行　　普施电光耀
  复降甘润雨　　沾洽于大地
  是龙所游境　　实为不思议
  若安住最上　　神通王三昧
  能作诸供养　　奉献无边佛
  犹如龙王雨　　泽及于一切
  欲成就善教　　亲近最上说
  摄取无为乐　　当修此三昧
  种种深解脱　　当宣诸妙偈
  欲令一切众　　咸使得安乐
  常修是三昧　　不离佛菩提
  及与声闻众　　得见他方刹
  若欲得咨问　　此土之世尊
  及诸他方佛　　应修此三昧
  若欲见他方　　不思议世尊
  亲近彼诸佛　　蒙光设供养
  往返诸刹土　　得无数功德
  应当修诸佛　　所说深三昧
  往往从生处　　恒得与佛俱

    菩萨念佛三昧经正观品第十

尔时不空见菩萨白佛言。世尊。菩萨摩诃萨。若欲成就诸佛所说。菩萨念佛三昧者。应当亲近修习何法。尔时世尊告不空见。若诸菩萨欲得修习诸佛所说念佛三昧。欲得亲近诸佛如来。复欲疾得阿耨多罗三藐三菩提者。应当安住决定之心。又应永舍不决定心。舍我见心知无我心。当观此身如水聚沫。观于色阴当如芭蕉。次观受阴如水上泡。复观想阴如热时焰。又观行阴如空中云。观于识阴犹如幻化。菩萨若欲入此三昧。应当深生怖畏之想。又宜具足惭愧之心。舍不怖畏而作怖畏。舍无惭愧修惭愧心。具舍摩他毗婆舍那。以方便智舍我无我。应习智脱及三空门。又当深知三受生起。亦应舍离三不善根。即当起于三昧之聚。观诸众生犹如我身。观四念处身受心法。观四食患作无食想。所谓抟食触思识等。修不净想及以慈悲。安住于喜令舍具足。起诸禅定而不味着。亦不毁呰一切诸法。此身不实犹如幻焰。不乐长寿应当舍离。善防护心习学多闻。不慢于法勤护不谤。即得闻才及以法才。既闻法已守护是义。尊重佛法恭敬僧宝。近善知识远离恶友。不着世俗言论之味。恒能不离阿兰若行。心常平等怜愍众生。其心不退不怀嫉妒。称量诸法心不染累。分别一切无数诸法。常求甚深方等经典。信心坚固不生疑虑。常能精勤读诵此经。即是诸佛无上道也

诸佛功德之所生处。应当如是真实其心。摧伏憍慢至意听受。增长正法离杀盗淫。懒惰贡高是非之心。舍存真我邪谤之说。除秽乱语灭诸诤论。心乐安住布施持戒。忍辱精进禅定智慧。诸波罗蜜皆悉具足。能舍头目心不退没。如四大姓不可改易。身意精勤不顾躯命。于四供养心无贪着。安住十二头陀之行。不求己利及以名誉。舍心爱滞得四神足。离四颠倒及烦恼刺。渡于四流于四威仪。修四念处令得五根。修行五力舍于五结。不求五欲福报之庆。舍五秽心修五解脱。善知五阴弃六欲处及六身受。除六爱身修于六念。知六识分勤求六通。修七觉意深知七界。所谓害界恚界出界欲界色界无色界及以灭界。除断七使及七识住。舍八懒惰去八妄语。知世八法得八大人觉。知八解脱修八正道。舍于众生九居之处。除九慢法放弃九恼。亲近修学喜等九法。又复勤习九次第定。舍十不善行于十善。方便精勤求佛十力

又不空见我今略说一切诸佛所说三昧。应当勤修念报佛恩。学三昧已。即得不退阿耨多罗三藐三菩提。而是菩萨以大智力。能为众生说此三昧。其余声闻不能观察宣说书写受持读诵。若能观察书写受持读诵之者。此人福业亦不唐捐。要当得值佛出于世。若诸菩萨教化受持。疾得不退菩提之道。又不空见诸佛所说。念佛三昧名为要法。诸大声闻所不能行。若人闻说此三昧者。将来之世必当值佛尔时世尊。即说偈言

  若有修诸佛　　所说深三昧
  观法心相续　　舍不相续念
  善观于阴身　　离我无我想
  此身不牢固　　犹如水聚沫
  虚诳犹如化　　亦如婴儿语
  观色如浮云　　见受若水泡
  想如热时焰　　观行阴无实
  犹如彼芭蕉　　观五识如幻
  修惭愧恐畏　　舍摩毗婆那
  应远无惭愧　　除我无我见
  习如与解脱　　及以三空门
  又应知三受　　舍三不善根
  常学三善根　　求最胜三昧
  勤行戒定智　　速得甚深定
  离诸邪见等　　正习此三昧
  舍世众诤论　　常修出世法
  观察身念处　　受心亦复然
  于法无疑惑　　不久得此定
  常行禅解脱　　不惜身寿命
  多闻不贡高　　不诽谤诸法
  闻法应受持　　持已谛观察
  常供养诸佛　　法僧亦如是
  若于善知识　　恒念报其恩
  远诸恶知友　　不闻邪师论
  应求赞善者　　常共俱游处
  不远阿兰若　　应求胜菩提
  等心于群生　　不毁呰诸法
  不染一切法　　应知真实法
  舍诸非法行　　不久得此定
  除一切诸恶　　及见真我者
  杀害慢淫盗　　毁呰懒惰等
  不作诸恶口　　邪论诤讼等
  次第说佛法　　当求此三昧
  施戒及忍辱　　精进禅智等
  常勤精修习　　成就此诸度
  不久当得斯　　功德定法行
  若舍内身分　　及外财眷属
  不久得菩提　　最静心三昧
  若人心如地　　水火风空等
  皆悉当速疾　　获此妙三昧
  若有诸人等　　身心甚端直
  不贪着衣食　　床褥及医药
  是人当疾得　　如此之三昧
  成就四正勤　　具足四如意
  舍于四颠倒　　及四烦恼刺
  永度于四流　　弃舍诸受取
  修行五根力　　除断于五结
  不求五欲报　　舍诸烦恼心
  应修五解脱　　及五身三昧
  谛知五阴法　　深修六和敬
  远离不恭敬　　除去六触身
  观六度相续　　舍彼六爱身
  成就于六通　　深修六念处
  亦复勤专行　　六识之法分
  修七菩提分　　复行于七财
  念舍憍慢处　　除断七种使
  当修如此行　　以求胜三昧
  舍彼七识住　　除此八妄语
  常修八正道　　得三昧不难
  得八大人觉　　行八解脱门
  知世间八法　　即为最胜智
  如此常修行　　得三昧不难
  自离于九恼　　亦不恼他人
  修喜等九法　　次当得三昧
  聪慧舍十恶　　修行十善业
  又能遵十力　　得三昧不难
  常受持善法　　舍诸不善法
  昼夜常摄心　　得三昧不难
  住此三昧已　　不思议力说
  常见佛金色　　亦得闻演法
  若欲见十方　　灭度现在佛
  及以未来世　　饶益众生者
  是人当修此　　最上妙三昧

尔时不空见菩萨摩诃萨白佛言。世尊。菩萨若欲成就一切诸佛所说念佛三昧。云何当令其心相续。佛告不空见。是诸菩萨若能至心。忆念过去未来现在。十方一切无量如来。应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。悉知众生往来生死。住胎具足母族亦然。及善相好四毗舍罗。慈悲喜舍惭愧恐畏。威仪等行悉亦具足及舍摩他毗婆舍那。解脱知行诸解脱门。念处正勤神足根力。觉道等法皆悉具足。知昔四流及生具足。亦知众生源始具足。生诸六通起大神足。戒定智慧及以解脱解脱知见无不具足。无碍解脱及无碍利。一切善法亦皆具足。色心清净境智清净。金色等身清净具足。而此菩萨应如是念。诸佛如来至心不动。亦当安住无所著心

复应如是心相续观。为何等法是如来耶。为以即色是如来耶。为当异色是如来乎。若以即色是如来者。色处众生具足色阴。而是众生应是如来。若以异色是如来者。除十二缘岂有如来。又以即受是如来耶。为当异受是如来乎。若以即受是如来者。一切众生具足受阴。而是众生应是如来。若以异受是如来者。除十二缘何有如来。想行识等亦复如是。为即眼根是如来耶。为异眼根是如来乎。若即眼根是如来者。一切众生应是如来。若异眼根是如来者。除十二缘何名如来。耳等诸根亦复如是。为即四大是如来耶。为异四大是如来乎。若即四大是如来者。内外四大亦是如来。若离四大是如来者。除十二缘何有如来。地水火风皆亦如是

菩萨如是相续观已。明见色阴既非如来。异彼色阴亦非如来。又见受阴即非如来。若异受阴亦非如来。即想行识非如来者。异想行识亦非如来。又见眼根非即如来。见异眼根亦非如来。耳鼻舌身非即如来。异耳鼻等亦非如来。见色声等非是如来。异色声等亦非如来。见香味触非是如来。异香味触亦非如来。见意及法非是如来。若异意法亦非如来。见即四大非是如来。见异四大亦非如来。地水火风亦复如是。菩萨如是心相续观。于一切法得方便智

又不空见。汝以何法能得无上菩提道耶。为以身得为以心得。若以身得此身不净。无所觉知如草木瓦砾。菩提非色无有形质。其相空寂不可见法。此身既如草木无知。云何当得菩提道耶。若以心得无上道者。心无形相犹如幻化。菩提无心亦无色貌。如幻如化云何可得。若诸菩萨得如此解。非身能得无上菩提。亦非心得无上菩提。不离身心得无上道。尔时佛告不空见言。应当如是观于如来。作是观者名为正观。又不空见。菩萨如是相续观法心不动摇。菩萨应当如是深解。则不退于三昧法也。又常离于不相续心。必当疾得无上菩提。尔时世尊。即说偈言

  心心相续念　　去来今现在
  一切普眼尊　　不久当见佛
  住佛大威力　　慈哀利世间
  忆念人中华　　调御功德尊
  当念昔生死　　住胎母族姓
  容相悉具足　　不久当见佛
  念佛八十好　　及宿世因缘
  恒集最胜业　　正念善法意
  念佛六神变　　及大自在通
  戒定智解脱　　皆悉得成就
  云何最上师　　得此寂静地
  念慈世间尊　　悲喜舍最上
  惭愧力无畏　　世间威德师
  念佛舍摩他　　毗婆舍那等
  又念智解脱　　及以三空门
  具念修正勤　　神足亦复然
  念根力具足　　及以菩提分
  念佛离生灭　　获此寂静处
  念难思善法　　色受皆清净
  想行及以识　　清净亦如是
  念佛真金色　　安住无著心
  观何法名佛　　摄心恒相续
  念色非如来　　四阴亦如是
  离阴非如来　　想识应当知
  念眼非如来　　耳等法亦然
  离眼非如来　　五情法皆尔
  念十二因缘　　调心得见佛
  念四大非佛　　异此四亦非
  应了十二缘　　见佛不为难
  若使诸佛阴　　而是如来者
  众生悉有阴　　亦应即如来
  若欲得根力　　当念十二缘
  阴非世间师　　异阴亦如是
  往昔诸因缘　　相续恒分别
  是以能摄取　　不思议智力
  此身常无知　　如草木瓦砾
  菩提无形色　　寂灭恒不生
  身不触菩提　　菩提不触身
  心不触菩提　　菩提不触心
  而能有触相　　实为不思议
  此是佛世尊　　最胜寂静处
  善能灭一切　　外道诸邪见

尔时不空见菩萨摩诃萨白佛言。世尊。菩萨云何得知我见。云何复当得离斯见。尔时世尊告不空见。菩萨若欲舍我见者。莫着住处当依无依。欲以法明利益一切。欲吹法螺击大法鼓。欲造法船建立法桥。度诸众生生死有流。欲观身相及不相续。此身不净秽恶充满。脓血涕唾九孔恒流。无常败坏眴息不住。危脆难信不可爱乐。犹婴儿语虚妄无知。是身不实如水聚沫。纵复假以衣服饮食。香熏庄严种种宝饰。于百千岁恣随其意。会当磨灭长夜无益。如此身性是生死法。又为虫兽之所食啖。复于长夜或在地狱畜生饿鬼阎罗王所。受无量苦未曾暂息。又于永劫处生死中。为他僮仆策使万端。此身长勤受众苦恼。而初不能知苦断习。证灭修道行诸功德。此身虽小受污甚多。应以是身施诸众生。若有惜命施其以寿。若须力者当惠其力。须肉与肉须血与血。当施须者不求勿与。或于彼人无所利益。愿以舍身善心因缘。除我见惑得解无我。住是舍身思惟观时。不复着于我见之惑。以不坚身修于坚身。又不空见。譬如村邑多有童子相随出村。游戏水边见水聚沫。是诸童子竞取弄戏。而此聚沫不自觉知。为他所弄亦无痛痒。如是不空见。若有菩萨观自己身当知此心。犹彼聚沫无有分别。若此菩萨作是观者。不久当得此深三昧。亦当疾得无上菩提。尔时世尊。即说偈言

  欲求最胜定　　得不思菩提
  永舍于我见　　常应观此身
  无常苦不净　　涕唾臭污等
  九孔流诸秽　　甚为可厌患
  虚诳无真实　　此是磨灭法
  眩惑犹幻化　　亦如水聚沫
  我此身危脆　　疮疣之窟宅
  周遍皆臭毒　　无一可乐处
  养之初无益　　卒为虫狼食
  一切诸乐具　　供膳于此身
  会归当朽灭　　终不得一实
  长勤无边劫　　苦痛恒万端
  地狱畜生报　　根本受苦处
  长夜增饥渴　　不可不思议
  众苦所逼迫　　为此乖菩提
  我此身不实　　应施诸众生
  解法心无惜　　所须便给之
  作此思惟已　　即唱如是言
  我今舍此身　　血肉随意取
  若有惜命者　　我当惠其寿
  亡躯济众生　　为疾得三昧
  段段求水沫　　未曾得坚实
  我身亦如是　　求真不可得
  若得此正观　　疾成菩提道

尔时世尊即便微笑。诸佛如来法皆如是。当于世尊微笑之时。面门即放种种色光。青黄赤白红绿颇梨。上至梵天从彼还下。绕佛三匝复至顶上。斯光俄顷忽然不现。长老阿难即从坐起。更整衣服右膝着地。合掌向佛以偈问曰

  最胜调御尊　　微笑非无缘
  无上世间师　　愿为我宣说
  为以何因缘　　而现此微笑
  金色百福严　　善解于真谛
  哀矜利益者　　世间所归趣
  为以何因缘　　而现此微笑
  无等人中尊　　最上无过者
  如来诸功德　　清妙无瑕秽
  复以何因缘　　而现此微笑
  住圣大悲尊　　一切所归者
  已离诸烦恼　　以净调御音
  唯愿为我说　　微笑之因缘
  今日谁应得　　若此深广义
  谁住坚固地　　谁国遇吉祥
  世间所归尊　　何故现微笑
  一切所归趣　　调御为我说
  愿闻清净人　　微笑之因缘
  若蒙圣开演　　疑惑则永除

尔时世尊告阿难言。我向说此相续观时。三万人得法眼净。八万百千亿那由他天。亦悉离垢法眼清净。复有三万亿那由他。比丘比丘尼证阿那含。复有三万比丘比丘尼。及清信士女得无生忍。三万众生发菩提心。即皆修习菩萨之行。于人尊劫悉当成佛。此是初发无上道心。复有九万亿那由他诸众生等。悉皆不退菩提之道。当得作佛号曰放光及离垢尊释迦牟尼日光相佛月光明佛天中尊佛。九十二亿那由他众。发声闻心当成罗汉。尔时世尊作是语时。声震三千大千世界。佛以天眼见于十方。九十亿百千那由他诸佛刹土。其中众生皆见如来放眉间光。名曰明焰。遍照十方。众生见已心惊毛坚。时彼刹土无量百千万亿那由他诸众生等。遇斯光者。其中有得须陀洹果斯陀含果阿那含果阿罗汉果。有多众生发菩提心。皆不退转无上菩提。于未来世当得作佛。皆同一号号不退转。尔时世尊。欲令此义光宣明显。重说偈言

  我向宣说此　　心相续观时
  即有六十千　　九十九亿众
  以闻法利故　　而发菩提心
  复有三万人　　皆得圣慧眼
  已闻相续念　　寂定之菩提
  此等悉得免　　恶道之苦难
  八万亿诸天　　既闻如来音
  获得净法眼　　永离恶趣苦
  三万亿四众　　得不起法忍
  度脱诸恶道　　无复苦恼患
  当得成佛道　　如春之敷荣
  三万亿诸人　　学于菩提道
  是人亦当得　　诸佛大威力
  既成无上道　　怜愍于世间
  六万千天子　　学习于菩提
  乐中之乐行　　犹如弥勒尊
  无碍世间依　　以笑广利益
  阿难汝当知　　皆有因缘故
  是以我今日　　示发此微笑

    菩萨念佛三昧经微密王品第十一

尔时不空见菩萨摩诃萨白佛言。世尊。菩萨摩诃萨。云何当知安住惭愧恐畏等法。舍无惭愧得此三昧。尔时世尊告不空见。此诸菩萨所以惭愧。身作诸恶而怀羞怖。口意行恶复生耻辱。嫉妒懒惰亦复如是。若起不善恭敬诸佛。畏惧诸天及以世人。恶不善法可羞耻故。菩萨如是则住惭畏。舍无惭畏诸不善法。勤修众善护清净行。默然闲寂三业具足。不久亦当得此三昧。生生恒得值遇诸佛。当疾得于阿耨多罗三藐三菩提

又不空见。奇哉希有。我念过去经阿僧祇亿百千万那由他劫。初第三劫名为善生。次复有劫名曰宝炬。次复有劫名莲花池。时浊劫起余一千年。次复有劫名曰乐住。时有国王生此劫中。名胜微密。有大威德势力自在。王所住城名拘修摩清净香聚。其城纵广七十由延。有十二重七宝庄校。严丽光明如善建城。城北有地名为离垢。此处有苑苑名安隐。纵广正等面十由延。周匝皆有诸多罗树。其苑法式犹善建园。又不空见。尔时有佛。号曰明相如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。佛告不空见。时明相佛与其眷属住安隐园所从比丘九十九亿百千那由他。皆阿罗汉。诸漏已尽无复烦恼。心得自在所作已办。所应学者皆悉已学。明相如来应正遍知。于其晨朝着衣持钵。翼从比丘入城乞食。时微密王闻佛当来。即乘大象象名乐手。前后导从无数百千。皆共出城奉迎世尊。又不空见。是微密王遥见佛来。光色相好微妙殊特。皆大欢喜。即便下象趣如来所。头面礼足右绕三匝。即于道路请佛及僧。时明相佛默然许之。王既知佛已受其请。即于其夜扫洒烧香。严办种种珍妙供具。复于城内遍竖幢幡。悬诸华鬘璎珞宝盖。牛头香汁以洒尘坌。散种种花严饰于地。以箧盛花置于座前。作众妙伎以用供养

又不空见。王办供已。于晨朝时与诸营从。诣安隐园顶礼如来。白言世尊。食时已至。时明相佛闻王请已。即如其相现大神通。与诸比丘俱升虚空。放净光明九万百千照于东方。三方亦然。一一光中有八十亿那由他等诸妙莲华。一一华上有化如来。相好具足如明相佛。是诸如来眷属无量。左侍帝释右侍梵王。犹如真实释梵无异

又不空见。明相如来现此种种神变相时。一念之顷欲色诸天。即作无量众妙伎乐。以天栴檀多摩罗跋沉水华鬘。如是诸香以用供养明相如来。时彼世尊为王说法。大王当知。诸行无常有为皆苦不实故空。一切诸法悉无有我。所以者何。此身不净九孔流秽犹粪中虫。破坏危脆念念不住。四大诸阴假以为身。饥渴寒热恒来侵迫。虚诳幻炎犹水聚沫。不得自在磨灭之法。强名为人无一可恃。是故大王当深观察。生死诸行甚可压患。当勤方便求速远离。时微密王闻是语已。合掌向佛而作是言。如是世尊。诚如圣教。有为诸行无常苦空。一切诸法皆悉无我。现见此身不净臭秽。众苦之聚甚可厌患。时王见佛神通相貌。及闻如来所说之法。即发阿耨多罗三藐三菩提心。又不空见。时彼如来。知王已发菩提之心。与诸大众俱受王请。乘虚而往至城便下。是王从佛步入宫门。献座已讫次第而坐。王与群臣宫内眷属。及国人民侍立左右。擎诸供膳前受嚫愿。各各授食皆令充足。饭食已讫漱口澡手。复以种种华香伎乐。名衣上宝而以供养。时微密王即于是日。舍四天下及八十四亿那由他妃后婇女。以国王位付其长子。与八十亿那由他人。俱共往诣明相如来。于彼佛所出家修道。王出家已将欲请法。白言世尊。云何菩萨得诸佛所说念佛三昧。若人能得此三昧者。当疾成于阿耨多罗三藐三菩提具足见法。时明相佛告微密比丘。菩萨有二法得此三昧。亦当疾成无上菩提。何谓二法。菩萨应当信于如来所说经典。此大方等诸佛行处。菩萨具足此二法者。得此三昧当疾成佛。复有二法。何谓为二。舍摩他毗婆舍那。复具二法。舍我无我。安住惭愧恐畏等法。菩萨若能具足二法。得此三昧疾成正觉

告不空见。是微密比丘白明相佛。云何菩萨安住惭愧恐畏之法。得此三昧。明相如来告比丘言。菩萨应当舍三恶业。无惭愧等诸不善法。住于惭愧恐畏之法。而是菩萨惭畏具足。舍诸不善修行善法。应护清净身口意业。又不空见。是时比丘。于彼佛所闻说过患。即舍无惭恐畏诸恶。精勤摄心住诸善法。不失善法欲令满足。复更摄心安住正观。观一切法不增不减。亦不见法去来生灭

微密比丘作是观时。不见诸法有种种。相观十二缘如梦如炎。观于诸法如影幻化。观于诸法无增无减。观于诸法无名无性。观一切法无灭无生。微密菩萨如是修行。不久当得此三昧也。获三昧已辩才不断。过六万亿那由他劫。当得阿耨多罗三藐三菩提。佛告不空见。汝莫生疑。尔时舍国出家学道微密王者岂异人乎。莲花上佛如来是也。微密菩萨安住惭愧。修习成就一切善法。不久便得如此三昧

又不空见。我今语汝诸佛所说念佛三昧。若有众生不种善根。终不得闻如此三昧。告不空见。若善男子善女人等。曾于过去无量佛所。亲近供养殖众善本。方得闻此三昧宝王。何况书写读诵受持。分别解说观其义趣。是善男子善女人等。所种善根无量无边不可称计。是诸人等修菩萨乘。方得少闻如此三昧。次第当得阿耨多罗三藐三菩提。唯除身证

时不空见白言世尊。是诸众生不学大乘。为能得此三昧宝不。佛言如是。亦当能得。又不空见。譬如有药。其质坚[革*卬]不可斫刺。以石磨取用之涂鼓。若有怨敌临阵战时。彼军亦以毒涂其箭。闻鼓音声毒不能行。如是不空见。若善男子善女人等。少得遇闻三昧光声。是人皆当得于无上菩提之道。唯除身证。又不空见。譬如众生若依须弥金色之边。其身即与彼山同色。所以然者山势力故。如是不空见。若有善男子善女人等。少闻三昧威光之力。当得阿耨多罗三藐三菩提。唯除身证。所以者何。而此三昧。功德最胜不思议故

又不空见。譬如诸水悉入大海同其一味。所以然者以海力故。若善男子善女人等。不能读诵持说书写。但得暂闻此三昧宝。一切皆当得无上道。所以者何三昧力故。又不空见。若人正说诸佛法门得三昧母。说此三昧是名正说。若人正说如是三昧。无量无边功德之聚。摄取长养是名正说。又不空见菩萨摩诃萨修行布施。于一念顷以众妙宝。奉献恒沙诸佛世尊。以此功德当得成佛。若人读诵受持解说书此三昧。功德胜彼布施之福不可称计。尔时世尊。即说此偈

  我念往昔生　　调御明相佛
  一切诸世间　　咸共所归趣
  慈悲哀众生　　为说众妙法
  是佛大知见　　明了三世法
  如此普明尊　　世间最为上
  如来不思议　　无量深智力
  开显诸法门　　为利群生故
  发起大悲心　　拔济无量苦
  明相善逝尊　　八亿声闻众
  皆是阿罗汉　　诸漏悉已尽
  是诸应真等　　随从法王逝
  时有安隐园　　在城东北隅
  大仙经行处　　恒与圣众俱
  时有转轮王　　微密勇健士
  怜愍一切故　　导从出彼城
  是王遥睹佛　　其心甚寂怕
  相好殊世表　　威仪亦无比
  王即步奉迎　　往到世依所
  既至如来前　　头顶接足礼
  合掌恭敬已　　往住于一面
  请佛受明供　　世尊默然许
  王知佛垂许　　还敕诸官属
  洒扫宫城内　　严办诸肴膳
  王复到佛所　　白言食时至
  世尊若矜愍　　愿时屈威神
  与诸圣众俱　　至当奉微供
  时佛闻王请　　即现大神变
  普放千亿光　　遍满十方刹
  一一光明中　　化作亿莲华
  大悲愍众生　　为众现斯瑞
  又告不空见　　彼诸莲华中
  有大威德王　　相好特端严
  各以最胜意　　广说诸佛法
  诸行皆无常　　苦空亦如是
  无我恒不实　　此为磨灭法
  有何聪慧人　　而生乐着心
  诸行犹幻炎　　破坏流动法
  大悲明相佛　　演说如是法
  诸天见世尊　　奋大神通时
  作众上妙伎　　广设香花供
  善哉佛威力　　不可得称说
  王睹神化已　　兼设妙供养
  捐去四天下　　及以五欲乐
  出家守一心　　以修菩提道
  是王学道时　　问彼明相佛
  安住何等法　　得佛力三昧
  时佛说二法　　如是应当修
  得此深妙定　　施不思议乐
  闻佛说法已　　踊跃充遍身
  即发菩提心　　当得此三昧
  微密比丘者　　莲华上佛是
  若人信如来　　不诽谤此经
  是人住佛境　　疾得此三昧
  若人畏生死　　心不着于我
  常修舍摩他　　及毗婆舍那
  是人如此相　　疾得此三昧
  安住惭恐畏　　常修于止舍
  利智勤苦行　　速得此寂定
  观法无增减　　一切如虚空
  是聪慧菩萨　　疾得此三昧
  不见诸法起　　亦不见其尽
  恒观法无常　　亦如梦幻等
  常能勤习行　　不久得此定
  不见法异相　　唯睹无生灭
  又如影响炎　　当得此三昧
  观诸法平等　　无有差别相
  内既无身想　　观外亦复然
  不见其名字　　亦无有生灭
  若能如是观　　疾得此三昧
  时微密比丘　　如是谛观已
  初中及后夜　　其心常相续
  既闻如来说　　不久得此定
  即于一念顷　　而证此三昧
  得不断菩提　　即睹十方佛
  具诸有为行　　其心渐清净
  比丘在生死　　满十六千劫
  曾供无量亿　　诸佛之世尊
  然后获寂定　　得于无上道
  佛告不空见　　莫心疑不信
  汝是聪哲人　　勿怀于异见
  尔时比丘者　　莲华上佛是
  我今语于汝　　诸天及世人
  若欲观一切　　无量诸法者
  是人当应修　　如此妙三昧
  若有人乐欲　　生无量功德
  施众难思乐　　当持此三昧
  若人乐欲见　　十方三世佛
  复乐转法轮　　当持此三昧
  若有人乐欲　　具足诸相好
  深知生死缘　　亦备众善本
  是以当勤持　　如此胜三昧
  若有人乐欲　　远离诸恶趣
  为利众生故　　当持此三昧
  如是善人等　　昔已曾供养
  非一二与十　　无量亿诸佛
  求最上菩提　　得持此三昧
  若人乐欲求　　正念闻三昧
  已曾多供养　　过去无量佛
  是人久勤修　　过去所行道
  若人于彼处　　闻说胜三昧
  即发欢喜心　　踊跃意无量
  昔已曾供养　　多亿天中天
  若人于此经　　常修相续心
  读诵及解说　　受持与书写
  是人已曾见　　无量大明力
  譬如战场所　　他阵放毒箭
  以闻药鼓声　　毒消得欢乐
  若人闻如是　　胜定妙三昧
  为他说此法　　得明三昧力
  当来必成佛　　唯除身证者
  如须弥功德　　依者同其色
  行者有深慧　　闻定亦复然
  若有人得闻　　最胜三昧声
  斯人功德聚　　犹如大海量
  决定明三昧　　当得于菩提
  譬如江河水　　悉入于大海
  异本众流相　　皆同一碱味
  若人闻如是　　微妙之三昧
  即同菩提性　　无异无分别
  若有诸菩萨　　于多亿劫中
  勤修行布施　　为利一切众
  诸佛世依所　　广植无量业
  是诸菩萨等　　涉历无数劫
  虽行布施业　　得福未为多
  慈心说三昧　　功德胜于彼
  如母能生育　　此三昧亦然
  显现难思议　　诸佛之功德
  是人聪慧故　　常修此三昧
  不久当疾得　　无上自然佛

菩萨念佛三昧经卷第四菩萨念佛三昧经卷第五

        宋天竺三藏功德直译

    三法品第十二

尔时不空见菩萨摩诃萨白佛言。世尊。菩萨摩诃萨。具足几法得此三昧。世尊即告不空见言。菩萨若能具足三法。得此诸佛所说三昧。何者为三。所谓不贪不嗔不痴。如此善根。若是菩萨住于无贪。便得满足檀波罗蜜。心得安住如此法已。摄取不贪清净善根。永离贫穷恒得豪富。具大威势如日光曜。如是菩萨所修功德。皆为一切诸众生故。所可宣说无不信受。得此三昧不以为难。亦当疾成无上菩提。菩萨具此妙善功德天人敬信

菩萨若复能修不嗔善根之行。满足忍辱波罗蜜也。若是菩萨安住忍度。若人骂詈刀杖加之。解其支节断其头首。不生一念忿恼之心。亦不说他诸恶过咎。摄取不嗔清净善根。慈心为利一切众生。是以修行如此三昧。菩萨安住此三昧已。得与诸佛世尊常俱。乃至梦中不离见佛。经行坐卧皆获安乐。诸天护念不见恶梦。寤寐欢喜。刀不能伤毒亦不害。水所不[漂*寸]火所不烧。所资四事恒得丰足。亦为一切皆令欢喜。疾当得于无上菩提。若是菩萨除舍无明。具足不痴善根之时。正观修行毗婆舍那。即便摄取不痴善根。于一切法决定巧便。满足般若波罗蜜也。他来问难疾能答对。菩萨具足如是三法。速当得此三昧之宝

又不空见。若是菩萨复具三法当得此定。何谓为三。应观一切诸行无常。应观一切诸行皆苦。应观一切诸法无我。菩萨具足如此三法。当得斯定疾成佛道。又不空见。若是菩萨复具三法当得此定。疾成无上菩提之道。何者为三。所谓供养现在诸佛。及以灭度如来舍利。若以花香幢盖缯幡种种珍妙而以奉献。若自供养劝人令行。复应发愿作如是言。以我善根布施因缘。愿得诸佛所说三昧。又不空见。复当赞叹现在如来般涅槃佛真实功德。赞戒功德定慧解脱解脱知见威仪神通。教化辩才阿兰若行。及以慈悲喜舍之法。复更殊胜赞叹佛法仪容相好无量功德。既赞叹已复发愿言。若我赞叹诸佛功德。设获微福以此善根。当得诸佛所说三昧。疾当得成无上菩提

又不空见。菩萨摩诃萨于诸佛所。闻此三昧功德名字。有三随喜。何谓为三。如过去佛往昔已曾修菩萨行。求阿耨多罗三藐三菩提。如彼诸佛求是三昧。我亦随学求此三昧。亦为自利及利他人。闻三昧已即生随喜。我亦当复随彼随喜。此是第一随喜者也。又不空见。如彼未来诸佛世尊。亦当修习菩提之行。闻此三昧自利利他生于随喜。我亦随喜。是名第二。若诸如来住现在世安隐住快乐。断不善行舍诸恶趣。变化幻术种种伎乐围棋博弈。一切诸恶悉皆离之。深定大悲无不具足。如彼诸佛往昔已曾修菩萨行闻此三昧。即便求之生随喜心。我今亦尔。如过去佛随而喜之。是名第三

又不空见。此三随喜与发愿俱。若我所获善根功德。愿使众生常得是定。又不空见。菩萨具足此三随喜。亦当疾得如是三昧。又不空见。若善男子善女人等。随喜斯定得此善根功德之聚。为此善根以譬明之。如有一人以彼三千大千世界恒河沙为聚。于大聚中捻取一沙。掷过无量不可思议亿那由他无边世界。复取一沙掷过无量无数世界。如是次第尽大沙聚。此诸世界。若善算师算师弟子。能得边际知其数不。时不空见即白佛言。如此人者不能知也。唯舍利弗不退菩萨。乃能知此世界之量。告不空见。不可思尽若干世界满中珍宝。其高过于诸天所居。乃至非想非非想处。以此珍宝施诸众生。此善男女得福多不。时不空见即白佛言。甚多世尊无量无边。尔时佛告不空见言。我当语汝。若善男女于诸佛刹满中珍宝。以用施于一切众生。若善男子善女人等。闻此三昧三随喜已。发愿求于无上菩提。亦复欲乐修于多闻。是善男子善女人等。所获功德胜彼施福。无量无边不可称计。佛告不空见。此念佛三昧即是一切善根之母。如是说者名为正说

    菩萨念佛三昧经劝持品第十三

尔时世尊告不空见。乃往昔世过阿僧祇阿僧祇无边大劫。尔时有佛。号宝胜光如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世无与等者。一切人天所共恭敬。解脱调伏度生死岸。无上最胜第一世尊。为护一切世间之师。今世后世皆悉明了。所可说法初中后善。其义深远其语巧妙。具足清白梵行之相。时宝胜光如来世尊于彼经行。与三万亿百千声闻。皆住学地人天恭敬。是宝胜光佛从卧而起心生念言。此诸声闻皆住学地当随所乐为说深法。令彼速得尽诸有漏

告不空见。宝胜光佛即时便现大神通力。令此三千大千世界。遍满其中皆成烟炎。是诸声闻见此神变。不生怖畏皆大欢喜。譬如比丘得四禅乐。告不空见。宝胜光佛于夜后分为说法故。即现种种神通变化。时宝胜光佛告诸声闻。汝等比丘见此三千大千世界烟炎不耶。比丘白佛。唯然已见。比丘当知。有为诸行无常苦空。一切诸法皆无有我。所以者何。此身不净九孔常流臭秽充满。诸行无常轮转之法。危脆不坚一念不住。生老病死之所逼切。犹如幻炎水聚泡沫。无人无主犹若草木。甚可患厌应速远离。佛告不空见。是三万亿百千声闻。闻宝胜光佛说是法时。是诸比丘见法住法。选择善法度四颠倒。于佛法僧得净善法。能不信他皆得漏尽。时诸声闻同声白佛。如是世尊。有为诸行无常苦空。一切诸法皆悉无我。此身不净九孔流溢。甚可厌恶应速舍离。诚如圣教诚如圣教

又不空见。有三示现。神通示现教诏示现说法示现。时宝胜光佛以此示现。如是调伏诸声闻众。度三脱门空无相愿。及三万亿百千那由他诸菩萨等。皆当得成无上菩提。告不空见。是诸菩萨闻彼世尊说宝三昧闻化人天。八万四千亿百千岁。转法轮已然后灭度。时不空见白佛言。世尊。彼宝胜光如来出世。调伏声闻为有几何。正法像法住世几岁。尔时世尊告不空见。如是三千大千世界。一切星宿可知其数。宝胜光佛诸声闻众。无量无数不可限量。宝胜光佛般涅槃后。正法住世足八十亿那由他岁。像法住世十二亿岁。于是中间有佛出世。号曰慈行。寿不可称量。其佛身长足一由延。国人身量六拘卢舍。莲花周圆亦复如是。悉以此花遍布大地。一切众生游息其上

尔时世界名多莲花。其地柔软犹如鹿茸。若触身时状若天衣。一切众生快乐无极。又如自在诸天宫殿。是诸众生欲度东海。眴顷之间便到彼岸。南西北方亦复如是。若有众生凡欲所之发心即至。是宝胜光佛初成道已。时四海内其地纵广。足八万亿百千那由他。诸声闻众悉满其中。诸阿罗汉皆各一食。唯除阿难。金刚密迹及阿逸多。八十那由他不退菩萨。请彼慈行如来世尊。为诸菩萨说此三昧。将欲分别显示之时。一音之中而说偈言

  若人勤方便　　求习出家行
  竞修最胜法　　摧破四魔军
  犹如大象王　　践踏众小草
  若人欲疾得　　寂定菩提道
  为诸众生故　　修行此三昧
  敷演净妙法　　施彼一切乐
  是人则与佛　　同其大悲心

尔时慈行佛般涅槃后。有一比丘名曰树王。族正法中广宣流布是妙经典三昧宝王。有转轮王号帝幢天。有大威德政法治世。是王有城名帝幢处。纵广正等十二由延。城郭楼观皆是真金。种种彩画众宝庄严。其城四面各有三门。国界严饰如善建城。又不空见。时王帝幢于夜后分眠寐之中。有净居天来至其所。即于梦中而告之曰。大王当知。有三昧名诸佛所说念佛三昧。若有菩萨修是三昧。恒生净土不离见佛。世出世辩无不具足。必当疾得无上菩提。时王忽然于梦惊寤。犹见此天故在其前。即白天曰。谁能受持如是甚深念佛三昧。天告王曰。去此不远有大比丘名曰树王。常乐受持读诵敷演。如说修行是深三昧

尔时帝幢从彼天所。受此三昧及比丘名。至心忆持不令忘失。即于晨朝舍四天下金轮七宝。及八万亿无数百千宫人婇女。为求三昧甚深法故。即与眷属同时舍家。俱共往诣树王比丘。又不空见。时彼四众天龙八部皆共围绕。有九万亿欲界诸天。八万那由他诸菩萨等。亦与眷属恭敬围绕。树王比丘时为大众。说此甚深念佛三昧。帝幢大王即至其所。以天真宝散比丘上。五体投地至心顶礼。复持八万净妙金花。天曼陀罗沉水末香。又以敬心奉散比丘。供养既毕即与眷属。皆悉出家被净法服。为欲修习此三昧故。供养恒沙无量诸佛。与其眷属求是三昧。八万四千亿那由岁。衣服饮食及诸珍宝。亲近供养树王比丘。常自受持读诵解说。如说修行是妙三昧。亦化一切无量众生。大悲为心初无懈惓。帝幢菩萨及其眷属。闻树王师说此妙法。至心受持未曾暂舍深生恭敬恒如佛想。精勤修习初不休息。树王比丘皆悉成就彼八万亿百千比丘。修菩萨行往不退地。然后灭度。彼诸眷属皆亦命过。尔时复有佛出于世。号阎浮幢如来世尊十号具足。帝幢比丘既值世尊供养恭敬。咨禀如是甚深三昧。受持读诵如说修行。饶益一切人天世间。皆得无上菩提大利。帝幢比丘广宣流布诸佛所说甚深定故。过三千劫当成正觉。又能成就九亿百千那由他等无量眷属。皆悉安住不退菩提

尔时世尊告不空见。时帝幢王大比丘者岂异人乎。今现成佛号曰高行如来世尊应正遍知十号具足。又不空见。汝今当知。以是三昧威神势力。饶益如是无量众生。以少闻故常值佛世。又不空见。若有菩萨少得闻此三昧名故常值佛世。何况菩萨于今现在。若得闻遇此三昧经。受持读诵其福如上已不可量。何况复能广闻受持读诵解说如说修行。又不空见。若有菩萨乘于大乘辟支佛乘。及声闻乘人天之乘。若善男子善女人等。或得暂闻是妙三昧。是诸菩萨及善男女。皆当疾得无上正觉。又不空见。是诸人等。譬如有人在阎浮提。见彼明相决定必知日出不久大光普照。阎浮提人因日光明。能得分别青黄等色。如是不空见。若有行者略闻诸佛所说三昧。是善界子善女人等。不久当得无上菩提。犹彼明相知日必出。汝当深信此妙三昧。受持忆念勿生疑惑。又不空见。善男子等如劫将尽六日出时。一切大地皆成烟焰。七日出时三千大千世界之中一切洞然。如是不空见。善男女等学大乘者有不学者。若得少闻此三昧宝。书持读诵解说其义。皆当疾得无上菩提。又不空见。善男子等譬如堀井若见淤埿。必定知水不复远也

又不空见。若有菩萨及诸众生。于佛所说念佛三昧。应当书写受持读诵。解说其义如说修行忆而不忘。是善男子善女人等。不久疾得无上菩提。又不空见。善男子等譬如有人吞金刚丸。时诸聪慧善男子等。必知此人定死不久。以此金刚极难消故。如是不空见。善男子等若人于是妙三昧宝。受持读诵广说深义。乃至少闻三昧妙法。此善男子善女人等。不久当得无上菩提。所以者何。诸佛所说念佛三昧如金刚故。过去未来现在诸佛。应正遍知之所宣说。分别选择威神守护。令诸行者不失作业。菩萨应当如是修习。恒欲利益一切世间。是名菩萨乘此乐行。如忉利天欢喜之园。若有见者身心踊悦。菩萨如是得此三昧。疾成无上菩提正觉。于所未闻诸章句等。若欲习学得亦不难。妙哉往古一切诸佛。为利益故分别示现。令满句义安住法界。诸大菩萨摄持拥护。敷演教化令乐正道。如是法门次第仪式。菩萨大士皆应当知。又不空见。若有菩萨于此诸佛所说三昧。若少闻者是诸人等。皆当疾得无上菩提。又不空见。是故我今为汝分别开示演说。汝又当知若得闻此诸佛所说念佛三昧受持解说。不久疾得无上正觉菩提之道。是故汝今应当受持读诵修行乃至书写。亦当广为一切四众。国王大臣沙门婆罗门。及诸异学。分别解说。所以者何。此等若闻当得满足无上菩提

又不空见。若善男子善女人等应当决定至心净信此深三昧。所以者何。皆是往古一切诸佛之所称赞。汝今当以不思议意。至心忆持深信此定。精勤修习令心相续。所以者何。此三昧者皆是诸佛真实之说随顺佛说至佛行处。选择分别佛所证知。甚深宝财诸佛本事。往生因缘诸佛法藏。究竟秘密诸佛圣印。如实知性诸佛真身。又不空见。此三昧者出生行人无量善根。恒得生于大刹利家。大婆罗门及余胜家。得大威力终成菩提。所以者何。诸佛所说念佛三昧甚深妙典。能施众生不虚果故。亦令行者得无边福。若有闻者是人获得无量无边阿僧祇等不可思议诸功德聚。又不空见。我今当说譬况之法成满此义。如有智人开譬则解。犹若大施诸菩萨等。常于清旦及以中晡日皆三时。如来三昧忆念力故。以诸珍妙一切杂宝。遍满恒沙大千世界。常以奉施亿千恒沙如来世尊及声闻众。经百千亿那由他等恒河沙劫如是大施。以求阿耨多罗三藐三菩提。告不空见。此大菩萨所得功德宁为多不。不空见言。甚多世尊。无量无边不可思议。告不空见。我当为汝分别解说此施善根。如此诸佛所说三昧。第一真实佛口所说。若能书写受持读诵敷演分别解说之者。出生无量诸功德聚。比前功德其福甚多。何况闻已劝人受持。广为四众分别解说。又不空见。我今说此功德宝聚不可穷尽

    菩萨念佛三昧经诸菩萨本行品第十四

尔时不空见菩萨。善现菩萨。善欢喜菩萨。无量示现菩萨。无量力菩萨。无量幢菩萨。无量明菩萨。无量胜菩萨。无量智菩萨。无量修王菩萨。无量意菩萨。无量胜思菩萨。无量定菩萨。分别一切法意菩萨。分别虚空意菩萨。分别无著意菩萨。无量宝意菩萨。一切寂定自在菩萨。善教诏意菩萨。如是等比九万百千亿那由他。此诸菩萨而为上首。即从坐起更正衣服。右膝着地合掌恭敬白佛言。世尊。我等于此诸佛所说菩萨念佛甚深三昧。忆念受持书写读诵。广分别说如说修行。令心相续乃至菩提。常当受持分别宣说。所以者何。我等皆于诸佛所说甚深经典。种种相貌未曾满足。若有多人欣乐勤修。即能增长建立安乐。所以者何。若能次第修行是法书写读诵。亦教他人受持解说。必能满足无上菩提。渐渐增进成就无余。尔时世尊知诸菩萨摩诃萨等心之所念。以佛常法即现微笑。于其面门放杂宝光。所谓金银琉璃车磲马瑙珊瑚虎珀赤真珠宝。种种无量微妙众色。其光普照无量世界。明耀朗彻乃至梵世。从上还下住佛顶上。譬如净喜天宝帝幢。微妙修直甚可爱乐。此刹三千大千世界。皆悉庄严犹若璎珞。尔时大众诸菩萨等。睹斯神变咸共惊叹。善哉希有如来神通。时有菩萨摩诃萨。名惭愧安定发众意行。即整衣服右膝着地。恭敬合掌瞻仰世尊。以天沉水细末妙香。及天曼陀奉散世尊。即于佛前。而说偈言

  调御无与等　　色身妙相严
  犹如天花树　　香气遍十方
  具足善行意　　修习无量智
  调御大威尊　　愍利诸恶趣
  唯愿无量智　　为说微笑缘
  最胜无边智　　大威无等等
  何故现微笑　　愿说其因缘
  此三千大千　　一切诸世界
  严饰如花缨　　净若忉利天
  见者皆欢悦　　何因现斯笑
  盲瞑得明视　　聋者获聪听
  狂乱果正念　　喑哑皆能言
  以何因缘故　　示现斯微笑
  象马及众鸟　　皆发和雅音
  一切诸乐器　　不鼓而自声
  今以何因故　　天尊忽微笑
  上方诸天等　　及下世间人
  一切妙音乐　　悉演殊美声
  何因示斯笑　　唯愿为显说
  善哉甚希有　　人天皆相见
  以何因缘故　　示现此微笑
  调御两足尊　　矜愍众生故
  愿闻尊笑意　　令我得净善

尔时世尊。知惭愧安定发众意行菩萨。及余大士请问意故。佛即宣说如恒沙等应正遍知之所说偈

  告诸菩萨众　　汝等且应观
  彼六万八千　　诸善男子等
  往昔已堕落　　今还修菩提
  皆誓言我等　　各住生死中
  当来牟尼所　　当受持此经
  皆乐闻此典　　最胜不思议
  诸佛所说法　　心常无厌足
  我今当告汝　　此诸菩萨众
  非唯一佛所　　发斯深敬心
  忆念于往昔　　三万六亿等
  百千那由生　　为摄法利故
  尔时于是处　　初起一切行
  又于彼前生　　恒沙大智所
  是处初起行　　摄取最胜法
  明慧人求法　　心常不满足
  恒舍身命财　　以求菩提道
  忆昔恒沙等　　不可思议劫
  时有正觉尊　　无量大胜光
  是处初起行　　为求法利故
  又于宝胜炎　　大明及电光
  难思照一切　　是等大仙所
  三业持此法　　为摄最胜道
  日光及月光　　难思功德海
  具足一切行　　如是诸佛所
  是处初发心　　为求胜菩提
  又于彼前生　　值遇猛盛光
  及与师子佛　　于彼如来所
  三业受斯法　　求第一菩提
  于彼过去世　　诸佛恒相继
  师子幢如来　　功德悉具足
  是处又发心　　为求法利故
  复有他方佛　　号曰胜帝幢
  调伏闻世间　　于彼诸佛所
  为求胜法故　　摄取无上慧
  无量智生等　　不思议诸佛
  法音闻高远　　如是世尊所
  三业受斯法　　求第一菩提
  昔于善眼佛　　犹无边火幢
  发此猛利心　　求无量菩提
  又于光力王　　变化神刹土
  住是大仙所　　以求胜菩提
  光炎生调御　　无量相德明
  于彼初发心　　求此三昧宝
  炎光及大众　　明聚降怨佛
  如是世尊所　　求法施众乐
  一切光如来　　难思及日明
  无量力善逝　　无边定意佛
  于彼诸世尊　　发心施法乐
  金花大圣尊　　善花香正觉
  阿兰若行佛　　无漏如来等
  如是诸佛所　　敬求最胜道
  此方及他刹　　过去无量智
  于彼两足尊　　受持此三昧
  身口意勤修　　求第一菩提
  以此诸善业　　供养天中尊
  具足满八万　　常求无上道
  是诸菩萨等　　死此离恶道
  一切共俱生　　恒奉人天尊
  永离邪惑法　　不生卑贱家
  远离恶知识　　亲近于善友
  摄取诸功德　　乃至于菩提
  当于未来世　　值遇弥勒尊
  供养天中天　　摄取胜菩提
  慈氏尊灭后　　师子佛调御
  于彼世尊所　　为法净三业
  摄持诸胜行　　以求正觉道
  贤劫中千佛　　无上两足尊
  当为此菩萨　　宣说深妙法
  是诸善逝子　　必获无碍色
  过此贤劫已　　无量光如来
  月显及贤观　　相继出于世
  贤观佛灭度　　其间甚久远
  多罗幢如来　　绍继广开化
  彼诸敏慧人　　为法设妙供
  多罗大圣尊　　既入于涅槃
  分别世如来　　其后次成佛
  为深三昧故　　奉敬彼法王
  分别佛灭后　　示现尊出世
  示现圣日没　　花上世所依
  次第成正觉　　当生一切见
  花上既善逝　　优钵罗胜佛
  出现调世间　　当供两足尊
  优钵罗灭度　　拘修摩世依
  其次成菩提　　彼佛慧日没
  庄严大势尊　　于是出于世
  庄严圣眼灭　　次有众智胜
  于彼为法故　　广设无量供
  众智胜灭后　　善现佛大智
  当兴于世间　　善现泥曰已
  妙持世依师　　次为调御尊
  妙持如来后　　善围绕世尊
  第一智当兴　　于彼求菩提
  善围绕佛灭　　无量光正觉
  大胜无边明　　现前最法王
  如是三调御　　相继出于世
  现前慧日没　　最炽念王兴
  为此法利故　　供养难思议
  知彼当来佛　　一切世主上
  受行此菩提　　为求法寿命
  以是诸善业　　于此界命终
  得供无量寿　　大威降怨佛
  既值人中尊　　广设无边供
  为得法义利　　摄第一菩提
  住彼诸世界　　众多世智所
  为利益众生　　不求五欲乐
  奉敬多亿佛　　当成无碍智
  怜愍脱众苦　　安乐诸世间
  获最胜菩提　　彼刹广难议
  众宝妙庄严　　无边净妙乐
  若亿那由他　　是诸菩萨等
  赞人中法王　　不思议佛智
  我今告汝等　　诸天及世人
  若求学佛智　　则与如来等
  是人乐佛智　　求习胜菩提
  以求菩提故　　应获人尊法
  诸天龙夜叉　　迦留摩睺罗
  及诸拘槃茶　　常深护佛法
  若人求菩提　　护法应如子
  若求佛菩提　　则得大果力
  端严甚殊妙　　色像如真金
  常为一切众　　普慧深远义
  具足不思议　　一切诸功德
  净色百福严　　世间最上宝
  人天无比尊　　龙鬼莫能议
  是人依菩提　　得供最胜仙
  为利众生故　　开示深定法

    菩萨念佛三昧经正念品第十五

尔时众中思义菩萨。舍非义菩萨。心勇健菩萨。分别心菩萨。无悭意菩萨。拔烦恼菩萨。善思义菩萨。众智菩萨。无缚菩萨。众光菩萨。智灯光菩萨。造智知识菩萨。无等烦恼菩萨。帝幢天子。他化天子。皆共恭敬而白世尊。今言诸佛之所说者。何故名为诸佛所说。云何诸佛何者是佛。当云何念名为念佛。为起身念为起法念。尔时世尊告诸菩萨。善哉善哉。诸善男子。汝等所问甚深难思。皆是承佛威神之力。生此乐说无碍辩才。诸佛所说名为佛说。正念诸法真实之相。是名念佛。何谓正念。莫着一切诸恶诽谤。应修一切无讥谤法。当离于我及以非我。不见众生寿命宰主。育养士夫人及生者。莫著作者使作之者。阴界诸入想所缘处。于一切法今世后世。乃至三界无依无染。我见诸行无取无舍。禅定解脱及六神通。如意根力菩提觉分。毗舍罗等无量善法。略说九万亿那由他不可思议甚深三昧一切诸佛常所念法佛方便慧。随而书写读诵敷演方等经典。说佛功德名佛所说。尔时世尊。即说偈言

  常能舍一切　　有为虚危相
  不得诸法性　　则获是三昧
  莫着诸诽谤　　及忆想分别
  永离我我所　　如是得三昧
  不于诸阴法　　见众生寿命
  我人及起者　　士夫养育等
  亦无分别想　　是名为说法
  于诸法不染　　我性及我所
  见我非阴生　　则得此三昧
  色受想行识　　一切空无相
  根本皆不净　　知此得三昧
  观诸有为法　　从缘不自在
  一切不真实　　虚诳不可取
  如彼从缘法　　是则名眼入
  耳鼻等亦尔　　皆无有自性
  若能谛分别　　得生此三昧
  是身虚无实　　阴聚无一净
  九孔流脓血　　谁当乐此处
  意入念念灭　　虚妄常如幻
  若能深分别　　则得是三昧
  一切诸入等　　皆空无有实
  凡夫犹小儿　　痴惑计有身
  贪爱之所迷　　不知是虚妄
  是身如空聚　　众贼之所止
  可患虚诳法　　智者常厌离
  如是深观察　　则得是三昧
  阴界入诸法　　皆空无一实
  若人能分别　　得生此三昧
  如炎泡聚沫　　幻化芭蕉等
  当观身危脆　　不实倍于此
  若此诸菩萨　　如是智不毁
  疾得一切佛　　所说深三昧
  诸法不自生　　亦不从他有
  毕竟无所住　　无漏法亦然
  若能如是观　　则生此三昧
  舍一切有为　　诸行变异相
  此法如虚空　　生者不可得
  菩萨如是知　　修学一切法
  疾得胜菩提　　转无上法轮
  是菩萨则能　　建立于法幢
  以不思议智　　分别一切法
  皆见是虚诳　　毕竟不真实
  我今虽为汝　　宣示此三昧
  如是仪式相　　其义甚难知

尔时世尊说此法时。有诸菩萨得无生忍。又复安住念佛三昧。是诸菩萨皆见东方。如恒沙等诸佛世尊。说此三昧清净平等。无增无减无二无异。其余诸方亦复如是。皆有无量亿那由他如来世尊。俱时皆演诸佛所说念佛三昧。时诸菩萨闻佛所说身心欢喜。快得安乐不胜踊跃。即于佛前重以偈颂说其相貌

  归命世光明　　正觉牟尼尊
  大法圣医王　　释迦佛智海
  人依师子王　　普示诸色相
  见彼东方刹　　那由他诸佛
  非愍众生故　　说法如师子
  调伏那由他　　如是诸菩萨
  安住童真地　　得无生法忍
  善顺甚深性　　于法无所坏
  其余九方等　　相貌亦如是
  悉见多亿众　　那由他诸佛
  譬如师子王　　恐畏之所依
  无漏寂无等　　转第一法轮
  是处无去来　　其相亦不住
  一切法无实　　性空无生灭
  众生及寿命　　士夫亦如是
  一切阴界入　　无实如空卷
  譬如诸野兽　　毕竟无所依
  诸法实无生　　或有常不净
  秽心贪生死　　如彼痴婴儿
  多亿那由劫　　恒苦而不厌
  是以佛慈悲　　为此说菩提
  是故诸佛子　　常舍身手足
  头目及髓脑　　妻息妙珍宝
  皆悉能弃舍　　以此行菩提
  既能施妻子　　眷属诸外财
  又弃天世位　　身肉及筋骨
  能舍是难舍　　疾得成正觉
  施戒最胜果　　忍进禅慧等
  行慈悲喜舍　　以求无上智
  菩萨应修是　　为利众生故

尔时世尊。即以偈颂答诸菩萨

  菩萨若多劫　　修行是真如
  不异不分别　　以此说菩提
  其性甚寂静　　难得难可见
  当起无尽意　　修习如是行
  是菩萨则得　　进智近菩提

尔时世尊为诸菩萨略说四法。满菩提故。而告之言。诸善男子。当学戒品善自防慎。守护观察生智方便。常勤修习乃至菩提。于诸众生恒起慈心。为除我见及我所想。求于最胜无上菩提。乃至舍身及以命财。应当守护成就增长。如是四法三昧根本

    菩萨念佛三昧经大众奉持品第十六

尔时世尊知九万亿那由他等诸大菩萨摩诃萨众皆悉已集。复有百千万亿菩萨。是等当于弥勒佛时。悉得住于不退转地。是时东方九万九亿百千那由他诸菩萨众。梵上菩萨而为上首。南方复有九万九亿诸菩萨众。持诚菩萨摩诃萨等而为上首。西方复有九万九千诸菩萨众。大智菩萨摩诃萨等而为上首。北方复有九万九千诸菩萨众。大光菩萨摩诃萨等而为上首。复有住彼欢喜世界。无量菩萨皆悉来集。梵身天王大花梵王无量梵王皆悉来集。复有无边百千那由他释提桓因众念天主。而为上首。复有无量百千亿万那由他等四大天王。复有无量迦流夜叉持鬘夜叉常醉夜叉。复有诸余天龙夜叉。乾闼婆王阿修罗王。迦留罗王紧那罗王。摩睺罗王罗刹夜叉。拘槃茶鬼富丹那鬼。及与迦吒富丹那鬼。如是种种无数百千。大力鬼神亦来在座。尔时世尊应正遍知。知诸大众皆悉已集。将为此等略说斯经功德深重次第之法。为欲调伏诸人天故。复作师子[口*磬]咳之声。即为时会说未曾有。此经法者去来现在。三世诸佛之所修行。能灭一切诸大苦恼。是故诸佛尊重是法。已行当行今亦修行。是故大士欲求我身。应当尊重真实之法。敬事法者当如敬佛。所以者何。法不异佛。是人求法应到于此。若天若龙人及非人。能求法者疾舍诸苦。行法除苦佛说最胜。是故菩萨为欲利益一切世间求菩提法。是诸菩萨则为已施一切众生菩提之乐。疾得度于生死大海。当我须臾说此三昧。微妙经王教世间时。一切山河及以大地。皆悉俱时六种震动。时诸众生皆称善哉。所以者何。当佛说此菩萨念佛大三昧王。大乘方等微妙经典。无边功德大智海时。亿百千数那由他等。无数世界佛之刹土。皆悉六种十八相动。及放净光大明普照。尔时虚空无量诸天。击大天鼓声若雷震。又奏和雅调畅之音。复有八万亿那由他地神天女持众宝座从地踊出至世尊前。至心恭敬而以奉献。复有主乐乾闼婆王。作亿百千那由他等种种妙音甚可爱乐。复有诸龙及诸龙王子。兴大密云普覆世界。雨天曼陀及众妙花。周布大地高百由延。时娑竭罗诸大龙王。于虚空中变成宫殿。众宝庄校微妙殊特。天栴檀末普散此刹。三千大千佛之世界。复有色界诸梵天王。于如来上作宝花盖。遍覆三千大千刹土。是盖处处垂诸宝铃。其铃皆出微妙之音。譬如他化自在天乐。尔时此会一切众生。皆修慈悲喜舍之心。既闻法音不胜喜悦。各各至心重归三宝。时会闻法无边众生。皆发无上菩提之心。复有无量诸众生等。悉深发辟支佛心。复有无数诸众生等。皆发声闻菩提之心。复有无量诸刹利王。沙门婆罗门。毗舍首陀长者居士。皆悉获得须陀洹果斯陀含果阿那含果。复有无边诸众生等。皆证无著阿罗汉果。尔时世尊说是经已。一切大众皆大欢喜。不空见等诸大菩萨大声闻众。及诸世间人天八部阿修罗等。闻佛所说皆大欣乐顶戴奉行

菩萨念佛三昧经卷第五


僧伽吒经

    No. 423 [No. 424]

僧伽吒经卷第一

        元魏优禅尼国王子月婆首那译

如是我闻。一持婆伽婆。在王舍城灵鹫山中。共摩诃比丘僧二万二千人俱。其名曰慧命阿若憍陈如。慧命摩诃谟伽略。慧命舍利子。慧命摩诃迦叶。慧命罗睺罗。慧命婆俱罗。慧命跛陀斯那。慧命贤德。慧命欢喜德。慧命网指。慧命须浮帝。慧命难陀斯那。如是等二万二千人俱。共菩提萨埵摩诃萨埵六万二千人俱。其名曰弥帝隶菩提萨埵。一切勇菩提萨埵。童真德菩提萨埵。发心童真菩提萨埵。童真贤菩提萨埵。无减菩提萨埵。文殊师利菩提萨埵。普贤菩提萨埵。金刚斯那菩提萨埵。如是等六万二千人俱。复有万二千天子。其名曰畴阿那天子。跋陀天子。须跋陀天子。希法天子。栴檀藏天子。栴檀天子。如是等万二千天子俱。复有八千天女。其名曰弥邻陀天女。端正天女。发大意天女。岁德天女。护世天女。有力天女。随善臂天女。如是等八千天女俱。复有八千龙王。其名曰阿波罗罗龙王。伊罗钵龙王。提弥罗龙王。君婆娑罗龙王。君婆尸利沙龙王。须难陀龙王。须赊佉龙王。伽婆尸利沙龙王。如是等八千龙王俱。皆向灵鹫山诣世尊所。头面礼足绕佛三匝却住一面

尔时一切勇菩提萨埵摩诃萨埵。从座而起偏袒右肩。合掌向佛白佛言。世尊。唯愿世尊演说正法利益众生。世尊。无量亿天众。无量亿婇女。无量亿菩提萨埵。无量亿声闻。皆悉已集欲闻正法。世尊。如是大众皆欲闻法。唯愿如来应供等正觉。为说妙法令长夜安隐断诸业障。尔时世尊赞一切勇菩提萨埵。善哉善哉。一切勇。能为大众请问如来如是之事。汝今谛听善思念之。当为汝说。唯然世尊。愿乐欲闻。尔时世尊告一切勇菩提萨埵。有法门名僧伽吒。若此法门在阎浮提。有人闻者。悉能除灭五逆罪业。于阿耨多罗三藐三菩提得不退转。一切勇。于汝意云何。若人闻此法门福德之聚。过于一佛福德之聚。一切勇白佛言。云何世尊。佛告一切勇。如恒河沙等诸佛如来所有福德。若人闻此法门。所得福德亦复如是。一切勇。若人得闻如是法门。于阿耨多罗三藐三菩提。一切不退转。见一切佛。一切得阿耨多罗三藐三菩提。恶魔不恼。一切善法皆得成就。一切勇。闻此法者能知生灭。尔时一切大众。从座而起偏袒右肩。右膝着地合掌向佛。白佛言。世尊。一佛福德有几量也。佛言。善男子谛听。一佛功德譬如大海水渧。如阎浮提大地微尘。如恒河沙等众生。悉作十地菩萨。如是一切十地菩萨所有福德。不如一佛福德之聚。一切勇。若人闻此法门福多于此。算数譬喻所不能及。尔时一切大众。闻是说已。踊跃欢喜多增福德。时一切勇菩提萨埵白佛言。世尊。何等众生渴乐正法。尔时世尊告一切勇菩提萨埵摩诃萨埵。一切勇。有二众生渴仰于法。何等为二。一者于一切众生其心平等。二者既闻法已等为众说心无悕望。一切勇菩提萨埵白佛言。世尊。闻何等法得近菩提。一切勇。渴仰闻法得近菩提。常信乐听受大乘法者得近菩提。尔时人天诸龙婇女从座而起。白佛言。世尊。我等渴法。愿佛世尊满我所愿。尔时世尊即便微笑。种种色光从口中出。遍照十方上至梵世还从顶入。尔时一切勇菩提萨埵。从座而起偏袒右肩。右膝着地。白佛言。世尊。以何因缘。如来现此希有之相。尔时世尊告一切勇菩提萨埵。于此会中一切众生。当得阿耨多罗三藐三菩提。成就一切如来境界。是故佛笑。一切勇菩提萨埵白佛言。世尊。何因缘故。此会众生得阿耨多罗三藐三菩提。佛言。善哉善哉。一切勇。能问如来如是之义。一切勇。以愿胜故。一切勇。乃往过去无数阿僧祇劫。有佛世尊号曰宝德如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。一切勇。尔时我作摩纳之子。此会众生住佛智慧者。往昔之时悉在鹿中。我时发愿。如是诸鹿。我皆令住佛智慧中。时鹿闻已寻皆发声言。愿得如是。一切勇。此会大众因彼善根。当得阿耨多罗三藐三菩提。尔时一切勇菩提萨埵摩诃萨埵。白佛言。世尊。若有众生闻此法者寿命几劫。佛言。其人寿命满八十劫。一切勇菩提萨埵白佛言。世尊。劫以何量。佛言。善男子。譬如大城纵广十二由旬高三由旬。盛满胡麻。有长寿人过百岁已取一而去。如是城中胡麻悉尽劫犹不尽。一切勇。又如大山纵广二十五由旬。高十二由旬。有长寿人过一百岁。以轻缯帛一往拂之。如是山尽劫犹不尽。是名劫量。时一切勇菩提萨埵摩诃萨埵白佛言。世尊。一发誓愿尚得如是福德之聚寿八十劫。何况于佛法中广修诸行。善男子。若有闻此法门者。所得寿命满八十劫。何况书写读诵之者。一切勇。若有人以净信心读诵此法门福多于前。九十五劫自识宿命。六万劫中为转轮王。于现在世人所敬重。刀不能害。毒不能伤。妭蛊不中。临命终时。得见九十五亿诸佛。安慰之言。汝莫怖畏。汝在世时闻僧伽吒法门。九十五亿佛。各将其人至其世界。一切勇。况复有人得具足闻如是法门。尔时一切勇菩提萨埵白佛言。世尊。我当听受如是法门得何福德。佛告一切勇。如恒河沙诸佛如来所有福德。闻是经者所得福德亦复如是。时一切勇菩提萨埵白佛言。世尊。我听此法心无疲厌。佛告一切勇。善哉善哉。汝能如是闻法无厌。我亦如是闻法无厌。况复凡夫心生厌想。一切勇。若有善男子。闻此法门生信心者。于千劫中不堕恶道。五十劫中不堕畜生。万二千劫不堕愚痴。万八千劫不生边地。二万劫中生处端正。二万五千劫常得出家。五万劫中作正法王。六万五千劫修行念死。一切勇。彼善男子善女人。无少不善。恶魔不得其便。不入母胎。一切勇。闻此法门者。生生之处。九十五阿僧祇劫不堕恶道。于八万劫常得闻持。十万劫离于杀生。九万九千劫离于妄语。一万三千劫离于两舌。一切勇。如是法门难值难闻。尔时一切勇菩提萨埵摩诃萨埵。从座而起偏袒右肩右膝着地。合掌白佛言。世尊。谤此法者其罪多少。佛告一切勇。其罪甚多。时一切勇菩提萨埵。白佛言。世尊。得几数罪。佛告一切勇。莫问此事。善男子。若有于十二恒河沙诸佛如来起于恶心。若有谤者罪多于彼。一切勇。若于大乘起恼心者。如彼众生被烧焦然。一切勇菩提萨埵白佛言。世尊。如是众生云何可救。佛告一切勇。譬如有人刀断其头。使医治之。涂以石蜜酥油诸药。以用涂之。一切勇。于汝意云何。如是众生还可活不。一切勇白佛。不也世尊。一切勇。又如有人刀害不断。若得良医治之则差。彼人差已知其大苦。我今知已更不复作恶不善业。一切勇。若善男子。念布施时亦复如是。离一切恶。集诸善法诸善具足。譬如死尸父母忧愁啼泣不能救护。凡夫之人亦复如是。不能自利。不能利他。无依父母。如是如是。一切勇。彼诸众生临死之时无所依止。一切勇。无依众生有二种。何等为二。一者作不善业。二者诽谤正法。如是二人临死之时无依止处。时一切勇菩提萨埵白佛言。世尊。彼谤法者生何道中。佛告一切勇。谤法之人入大地狱。在大叫唤地狱一劫受苦。众合地狱一劫受苦。烧然地狱一劫受苦。大烧然地狱一劫受苦。黑绳地狱一劫受苦。阿鼻地狱一劫受苦。毛竖地狱一劫受苦。睺睺地狱一劫受苦。一切勇。谤法众生。于此八大地狱。满足八劫受大苦恼。尔时一切勇菩提萨埵摩诃萨埵白佛言。世尊。大苦大苦我不能闻。尔时世尊而说颂曰

  何故不能闻　　此语甚可怖
  地狱为大苦　　众生受苦痛
  若造善业者　　则有乐果报
  若造不善业　　则受于苦报
  生则有死苦　　忧悲苦所缚
  凡夫常受苦　　无有少乐时
  智慧人为乐　　能忆念诸佛
  信清净大乘　　不堕于恶道
  如是一切勇　　本业得果报
  作业时虽少　　得无边果报
  种子时虽少　　得无量果实
  植种佛福田　　能生果实处
  智者得安乐　　乐于诸佛法
  远离于恶道　　修行诸善法
  若以一毫物　　用布施诸佛
  八十千劫中　　巨富具财宝
  随所受生处　　常念行布施
  如是一切勇　　施佛得福深

尔时一切勇菩提萨埵摩诃萨埵白佛陀言。世尊。云何修佛智慧。云何闻此法门增长善根。佛告一切勇菩提萨埵。若有人供养六十二亿恒河沙诸佛。施诸乐具。若复闻此法门者。所得福德与前正等。一切勇菩提萨埵白佛言。世尊。云何善根满足。尔时世尊告一切勇菩提萨埵摩诃萨埵言。功德如佛者当知满足。一切勇白佛言。世尊。何人功德与如来等。佛告一切勇菩提萨埵。善男子。法师善根与如来等。一切勇菩提萨埵言。世尊。何等是法师。佛告一切勇菩提萨埵。流通此法门者。名为法师。一切勇菩提萨埵白佛言。世尊。闻此法门得何等福。书写读诵此法门者。得几所福。佛告一切勇菩提萨埵言。善男子。于十方面一一方各十二恒河沙诸佛如来。一一如来住世说法满十二劫。若有善男子。说此法门功德。与上诸如来等。若有善男子。书写此经。四十八恒河沙诸佛如来。说其功德不能令尽。况复书写读诵受持。时一切勇菩提萨埵问佛言。世尊。若读诵者得几所福。尔时世尊说颂答曰

  读诵四句偈　　得此最胜福
  如八十四恒　　诸佛所说法
  读诵此法门　　得如是福德
  如是诸功德　　言说不能尽
  十八亿诸佛　　住世满一劫
  十方一切佛　　常赞大乘法
  善说此法门　　而无有穷尽
  诸佛难值遇　　此法亦如是

尔时八十四亿天子至于佛所。合掌顶礼白佛言。善哉世尊。如是法藏愿住阎浮提。尔时复有十八千亿尼揵子。来诣佛所白佛言。胜也沙门瞿昙。佛告尼揵。如来常胜。汝等住颠倒。云何见汝等胜。汝无胜也。汝等善听。今为利益汝等。为汝等说

  凡夫无慧乐　　何处得有胜
  不知于正道　　云何得有胜
  我视众生道　　以甚深佛眼

尔时尼揵子。于世尊所心生嗔恚。尔时帝释捉金刚杵。以手摩之用拟尼犍。时十八千亿诸尼犍子。惶怖苦恼悲泣啼哭。如来隐形令其不见。尔时诸尼揵子不见如来。悲泣颂曰

  父母及兄弟　　无能救济者
  见旷野大泽　　空无人行路
  彼处不见水　　亦不见树阴
  亦不见人众　　无伴独受苦
  彼受诸苦恼　　由不见如来

时诸尼犍从座而起。右膝着地出大声言。如来哀愍愿见救济。我等归依佛。尔时世尊即时微笑。告一切勇菩提萨埵摩诃萨埵言。善男子。汝往外道尼犍子所。为其说法。尔时一切勇菩提萨埵摩诃萨埵白佛言。世尊。譬如须弥山王小山无能出者。如是世尊。于如来前我不能说。尔时世尊告一切勇菩提萨埵摩诃萨埵。善男子。莫作是说。如来有多方便。一切勇。汝往观十方一切世界。如来在何处。住于何处所。敷如来座。一切勇。于尼犍所我亦当自说法。一切勇白佛言。世尊。乘何神力。为以自神力去。以佛神力去也。佛告一切勇。汝以自神力去。还时以佛神力而来。尔时一切勇菩提萨埵摩诃萨埵。从座而起偏袒右肩。为佛作礼即没不现。尔时世尊。为尼犍说法。生苦生恼。人生多怖。生有病苦。病有老苦老有死苦。复有王难贼难水难火难毒难自作业难。时诸外道心怀恐怖。白佛言。世尊。我等于今更不忍生。尔时世尊说此法时。十八千亿诸外道等得离尘垢。发阿耨多罗三藐三菩提心。自身十八千亿。住于十地大菩提萨埵。现菩提萨埵种种神力。或作象形马形师子虎形金翅鸟形。或作须弥山形。或作老形。或作猕猴。或作华台结加趺坐。十千亿菩提萨埵在其南面作。九千亿菩提萨埵在其北面。皆作如是神通变化。如来常在三昧。以方便力故为众生说法。尔时如来。知一切勇菩提萨埵自用神力去已。七日至华上世界。时一切勇菩提萨埵。以佛神力屈伸臂顷来至佛所。到已右绕三匝。发清净心合掌礼佛。白佛言。世尊。我以一神力。至十方诸佛世界。见九十九千亿诸佛世界。第二神力。见百千亿诸佛世界。至第七日到华上世界。亦至不动如来世界。世尊。我至彼国。见九十二千亿诸佛说法。又见八十亿千世界。八十亿千诸佛。即日成阿耨多罗三藐三菩提。我悉供养复过而去。世尊。我即日至三十九亿百千佛国。见三十九亿百千菩提萨埵出家。得阿耨多罗三藐三菩提。世尊。我悉恭敬礼拜。右绕三匝复过而去。世尊。又于六十亿世界。见六十亿佛。我悉供养恭敬礼拜而去。世尊。我见百亿世界。百亿如来入般涅槃。我亦供养恭敬礼拜复过而去。世尊。我见六十五亿世界。诸佛正法灭尽。我心燋恼而怀悲泣。见天龙夜叉忧恼啼哭如箭入心。世尊。彼佛世界劫火所烧。大海须弥悉皆烧尽无有遗余。我亦供养复过而去。乃到花上世界。世尊我到彼世界。见敷百千亿座。世尊。见彼南面敷百千亿座。东西北方及以上下。各敷百千亿高座。世尊。彼一一座七宝成就。一一座上有一如来。结加趺坐为众说法。世尊。我既见已生希有心。问彼世尊。此世界者名为何等。彼佛如来即告我言。此世界者名曰花上。世尊我礼彼佛。问其佛言。如来世尊名号何等。彼佛答我。号莲花藏。于此世界常作佛事。我复问言。此世界中无量如来。何者是莲花藏如来之身。彼世尊曰。我当示汝莲花藏佛。尔时诸佛悉隐不现。唯见一佛。其余座上悉是菩萨。我时礼佛。时有一座从地踊出。我于此座结加趺坐。时我坐已。有无量座忽然而出空无人坐。我问彼佛。此座何故空无人坐。时佛世尊而告我言。善男子。不种善根众生。不得在于此会之中。世尊。我时问彼如来言。世尊。作何善根得在此会。时佛告言。谛听善男子。得闻僧伽吒法门者。以是善根得在此会。何况书写读诵。一切勇。汝闻僧伽吒法门故得在此会。无善根人则不能得见此佛国。尔时一切勇菩提萨埵摩诃萨埵白彼佛言。世尊。得闻此法门者得何福德。尔时莲花藏如来即便微笑。世尊。我时作礼。问彼佛言。佛何故笑现希有相。时莲花藏如来告一切勇。善男子。一切勇菩提萨埵得大势力。譬如转轮圣王主四天下。于四天下种满胡麻。善男子。如彼胡麻其数多不。一切勇菩提萨埵白世尊言。甚多世尊。甚多善逝。佛告一切勇。有人聚彼胡麻以作一聚。一切勇。有人能数知其数不。一切勇菩提萨埵白彼世尊。不可数也。善逝世尊。时莲华藏如来告一切勇菩提萨埵。善男子。若胡麻等数诸佛如来。说闻经功德不能令尽。何况书写读诵。一切勇菩提萨埵白佛言。世尊。书写得何等福。佛告一切勇。善男子。譬如三千大千世界。一切沙尘树叶草木。以如此等数转轮王。如是轮王宁可数不。一切勇菩提萨埵白佛言。世尊。不可数也。善逝世尊。佛告一切勇。善男子。听此法者。如是一切诸转轮王。所有福德不及此福。于此法门书一字者。功德胜彼一切轮王所有福德。如是善男子。此法门者摄于一切大乘正法。不得以轮王福德为喻。如是一切勇。此法门功德非譬喻说。如此法门能示法藏。灭诸烦恼。然大法炬。降诸恶魔。照明一切菩提萨埵之舍。说一切法。尔时一切勇菩提萨埵摩诃萨埵白佛言。世尊。行梵行者甚为希有。何以故。世尊。如来行难得。佛告一切勇。如是善男子。梵行难得。若行梵行。若昼若夜常见如来。若见如来则见佛国。若见佛国则见法藏。临命终时其心不怖。不受胎生无复忧恼。不为爱河之所漂没。尔时世尊复告一切勇菩提萨埵摩诃萨埵。善男子。如来出世难可值遇。一切勇言。如是世尊。如是善逝。如来出世难得值遇。佛告一切勇菩提萨埵摩诃萨埵言。此法难值亦复如是。一切勇。若有得闻如是法门经于耳者。八十劫中自识宿命。六十千劫作转轮王。八千劫中作天帝释。二十五千劫作净居天。三十八千劫作大梵天。九十九千劫不堕恶道。百千劫中不堕饿鬼二十八千劫不堕畜生。十三亿百千劫不堕阿修罗中。刀剑不伤。二十五千劫不生愚痴中。七千劫中具足智慧。九千劫中生处端正。具足善色如如来身。十五千劫不作女人。十六千劫身无病恼。三十五千劫常具天眼。十九千劫不生龙中。六千劫中无嗔恚心。七千劫中不生贫贱家。八十千劫主二天下。极最贫穷受如是乐。十二千劫不生盲冥。十三千劫不生聋中。十一千劫修行忍辱。临命终时识行将灭。不起倒想。不生嗔恚。见东方恒河沙等诸佛如来。面见南方二十亿佛。面见西方二十五恒河沙诸佛如来。面见北方八十恒河沙等诸佛如来。面见上方九十亿恒河沙诸佛世尊。面见下方百亿恒河沙等诸佛世尊。善男子。彼诸世尊安慰其人。善男子。汝莫恐怖。汝已听受僧伽吒法门。善男子。汝见如是恒河沙等百千亿佛世尊不。唯然已见。世尊告曰。此诸如来故来见汝。是善男子问言。我作何善诸佛见我。诸佛告言。善男子。汝在人中曾闻僧伽吒法门。是故诸佛故来见汝。是善男子白佛言。世尊。我曾少闻得如是福。况复具足受持是经。彼佛告言。善男子。莫作是说。闻四句偈所有功德我今说之。善男子。譬如十三恒河沙诸佛如来所有福德。闻此法门福德胜彼。若有供养十三恒河沙诸佛如来。若有于此法门闻一四句偈。此福德胜彼。况具足闻。佛复告一切勇菩提萨埵言。善男子。若三千大千世界满中胡麻。以此胡麻数转轮王。若有人布施如是转轮王。不如布施一须陀洹。若施三千世界一切须陀洹所得福德。不如施一斯陀含。若施三千世界诸斯陀含。不如施一阿那含。若施三千世界诸阿那含。不如布施一阿罗汉。若施三千世界诸阿罗汉所得福德。不如布施一辟支佛。若施三千世界诸辟支佛所得福德。不如施一菩提萨埵。若施三千大千世界菩提萨埵。不如于一如来所起清净心。若于三千大千世界诸如来所生清净心。不如凡夫闻此法门功德胜彼。何况书写读诵受持。一切勇。况复有人以清净心忆念此经。一切勇。于意云何。颇有凡人能度大海不。一切勇言。不也世尊。佛告一切勇。于意云何。颇有凡夫以手一撮能竭海不。一切勇言。不也世尊。佛告一切勇。乐小法者亦复如是。不能听受如是法门。一切勇。若不曾见十八亿恒河沙诸佛如来。不能书写如是法门。若不曾见九十亿恒河沙诸如来者。不能闻此法门。若人曾见百千亿如来者。闻此法门不生诽谤。一切勇。若有曾见百千亿恒河沙如来。闻此法门能生净信。起如实想不生诽谤。一切勇。听若有书此法门一四句偈。彼过九十五亿千世界。如阿弥陀国。彼人佛土亦复如是。一切勇。彼诸众生寿命八万四千劫。一切勇。若菩提萨埵摩诃萨埵。于此法门闻四句偈。诸众生设使造五逆罪。教人随喜。若能听受一四句偈。所有罪业能令除灭。尔时世尊复告一切勇菩提萨埵摩诃萨埵言。往昔有人破塔坏僧。动菩提萨埵三昧。坏灭佛法。杀害父母。作已生悔。我失今世后世之乐。当于恶道一劫受苦。生大愁忧受大苦恼。一切勇。如是之人一切世人所共恶贱。作如是言。此人失于世间出世间法。此众生于无量劫犹如焦树不能复生。譬如画堂不以焦柱而作庄严。此人亦尔。今世后世所生之处。人皆轻贱打骂毁辱不施饮食。彼受饥渴打骂苦恼。自忆念言。我造逆罪。破塔坏僧。作是思惟。我向何处谁能救我。作如是念。我当入山自灭其身。无人救我。尔时彼人而说偈言

  我造不善业　　犹如燋木柱
  今世不庄严　　他世亦如是
  室内不庄严　　在外亦如是
  恶因造恶业　　因之入恶道
  后世受苦痛　　不知住何处
  诸天悉闻我　　悲泣啼哭声
  无有救护者　　必入于地狱
  自作不善业　　自受苦痛受
  我无归依处　　必受苦痛受
  杀父母坏塔　　我作五逆业
  我登高山顶　　自坠令碎灭
  时诸天告言　　莫去愚痴人
  莫作不善业　　汝作多不善
  作已今悔过　　杀害自身命
  必受地狱苦　　寻即堕于地
  如被忧箭射　　不以此精进
  而得成佛道　　不得菩萨道
  不得声闻果　　更起余精进
  汝诣仙圣山　　往见大圣主
  头面礼彼仙　　愿救苦众生
  善作利益我　　惊怖不安隐
  仙人闻告言　　汝坐暂时听
  惊怖苦不安　　当悔众恶业

仙人告言。我为施汝食汝可食之。愁忧苦恼饥渴恐怖世间无归。我施汝食汝当食之。然后我当为汝说法。令汝罪业悉得消灭。彼食讫已须臾澡手。绕仙人已前面[跳-兆+互]跪。仙人问言。汝说作恶业。答仙人言。我杀母杀父破塔。乱菩提萨埵三昧。坏灭佛法。尔时仙人告彼言。汝作不善造斯恶业。自作教人诸不善业。汝当忏悔。尔时彼人心惊惶怖悲泣而言。谁救护我。我作恶业必受苦报。尔时彼人长跪合掌而作是言。我作恶业自作教人。莫使我得不善之报。勿使受苦。愿大仙人当见救济。我为仙人常作僮仆。所作不善愿令消灭。尔时仙人慰喻彼人。汝莫惶怖。吾当救汝令汝轻报。汝今现前听法。汝曾闻僧伽吒法门不。白仙人言。我未曾闻。仙人言。火烧之人谁能为其说法。唯大悲者乃能说耳

僧伽吒经卷第一僧伽吒经卷第二

        元魏优禅尼国王子月婆首那译

尔时仙人告彼人言。乃往古昔无数阿僧祇劫。时有国王名曰净月。如法治世。善男子。时净月王。生一太子。时净月王。召诸占相婆罗门等。而问之言。今此童子有何等相。尔时相师白大王言。今此太子有不祥相。生此太子必有不祥。大王问言汝何所说。相师白言。如是太子若至七岁当害父母。王时答言。宁当杀我。不杀我子。人身难得。于无量劫修行乃得人身。不应以此身而杀人物。尔时太子始生一月如一岁儿。王知太子当杀我身。时净月王舍位与子。作如是言。汝治国事。一切财物自在随意。如法治世勿为非法。既授位已。时净月王于其国内。不复行于王之教令。尔时无量亿大臣。至净月王所。白言大王。何故不行王之教令。大王答言。我无量劫常为王事心无厌足。我已厌矣舍之修行。尔时太子未经多时。并杀父母集五逆罪。善男子。我亦忆念往昔之时。既杀王已愁悲啼泣自责悔过。尔时我以大悲之心为彼说法彼闻法已逆罪消灭。问言。当于尔时说何等法。答言。尔时演说僧伽吒法门。若闻此法。当至阿耨多罗三藐三菩提。灭一切罪烦恼伏息。汝今谛听。当为汝说。令汝闻已速得解脱。闻四句偈令不中阙。尽一切恶得须陀洹。然后布施远离诸苦。受苦众生令得解脱。怖畏众生令得远离。尔时彼人合掌顶礼。赞言。善哉善哉。真善知识。善能除灭诸不善业。善说增伽吒法门。善哉闻者。尔时虚空中万二千天子。至大仙所。合掌顶礼。白如是言。大仙忆念几时事耶。复有四龙王。十八千亿夜叉王。头面礼敬白大仙言。忆念几时事耶。大仙答言。我忆念百千亿阿僧祇劫。问大仙言。以何善根忆尔许事。答言。以曾听受僧伽吒法门。在彼众中闻此法门发净信者。皆得授阿耨多罗三藐三菩提记。若人造作五逆之罪。闻此法门须臾之间。悉能除灭无量百千亿劫。闭恶道门开生天道。于此法门闻四句偈功德如是。况复书写读诵。供养华香幡盖。恭敬尊重。合掌礼拜一言赞善。如是功德不可思议。尔时一切勇菩提萨埵白佛言。世尊。云何合掌得功德等。谁读此经一合掌礼。佛告一切勇。善男子。若人造作五逆之罪。若教人作若随喜作。于此法门闻四句偈。合掌净信能灭五逆。何况有人。于此法门具足书写读诵供养如此功德多彼无量。善男子。譬如阿那婆达多池日光不照。从彼池中出五大河。一切勇。于意云何。颇有人能数此五大河水渧数不。一切勇言。不也世尊。佛告一切勇菩提萨埵。善男子。闻此法门善根亦复如是。百千万劫数不可尽。一切勇。于意云何。须臾得闻如是法门。是难有不。一切勇言。难有世尊。佛告一切勇。于此法门能生信者复难于彼。譬如阿那婆达多池出五大河。如是五河水之渧数。数不可尽。一切勇菩提萨埵摩诃萨埵白佛言。世尊。何等名为五大河也。佛告一切勇菩提萨埵。五大河者所谓恒伽河。私陀河。博叉河。耶牟那河。月分河。是五大河悉皆入海。此五大河。一河各有五百小河。以为眷属。一切勇。复有五大河。在虚空中。一河各有一千小河。以为眷属。一切勇菩提萨埵白佛言。世尊。何等是五河有千眷属。佛告一切勇菩提萨埵。第一河者名须陀罗有千眷属。第二河者名曰膻佉有千眷属。第三河者名婆呵帝有千眷属。第四河者名质多斯那有千眷属。第五河者名曰法盖有千眷属。一切勇。是名五大河有千眷属。一切勇。是五大河利益阎浮提。时时降雨增长华果。于阎浮提雨清净水增长苗稼。一切勇。如护世天安乐阎浮提波(提波渚也)。此经亦尔。利益安乐阎浮提波。一切众生如三十三天。一切勇菩提萨埵白佛言。世尊。何等是三十三天。佛告一切勇菩提萨埵言。释迦提婆之所住处。是三十三天。一切勇。彼三十三天作如是语。若有众生口行善语者。彼人功德不可数知。若有众生行口恶者。彼堕地狱饿鬼畜生不可数知。众生堕于地狱畜生饿鬼受大苦恼。时彼众生无救护者。于三恶趣独受剧苦。口行恶者是恶知识。口行善语是善知识。若见善知识则见如来。若见如来则灭一切不善之法。一切勇。如护世天为阎浮提波而作利益。一切勇。此经亦如是。于阎浮提波而作佛事。若不闻此法门者。不能至阿耨多罗三藐三菩提。不能转法轮。不能击法鼓。不能坐于师子法座。不能入于涅槃之界。不能成就无边光明。如是如是。一切勇。不闻如是法门。不能坐于菩提树下。时一切勇菩提萨埵摩诃萨埵白佛言。世尊。我有少疑欲问世尊。佛告一切勇。随汝所问。当断汝疑。一切勇白佛言。世尊。尔时仙人。度彼五逆人。令住不退地者。是何人也。佛告一切勇菩提萨埵。善男子。汝今谛听。如来所说微细难知。此僧伽吒法门。示仙人像。如此法门能示佛身。如恒河中处处见沙。此法亦尔。自作示现为人说法。唯佛如来量与佛等。此法如是与佛平等。有此法处常有诸佛。尔时世尊复告一切勇菩提萨埵。善男子。我念往昔九十九阿僧祇劫。尔时有佛号曰宝上如来。次第有十二亿佛。皆号宝上。我于尔时名曰净月。行大布施。时十二亿如来。我悉供养。以衣服卧具饮食汤药。香花灯明一切乐具。悉以供养。彼诸如来。不为我授阿耨多罗三藐三菩提记。一切勇。我念往昔。有十八亿如来出兴于世。皆号宝明。我于尔时名曰龙正。行大布施。以香花璎珞供养彼佛。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有二十亿佛出兴于世。皆号式弃如来应供正遍知。我于尔时行大布施。以诸乐具供养彼佛。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有二十亿诸佛出兴于世。皆号迦叶。我于尔时行大布施。以诸香华幡盖衣服一切乐具。供养彼佛。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有十六亿诸佛如来出兴于世。皆号净光。我于尔时作大长者子。行大布施舍一切物。彼十六亿诸佛如来。我悉供养。以香花幡盖衣服卧具食饮汤药。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。九十五亿诸佛如来出兴于世。皆号释迦牟尼应供正遍知。我于尔时作大国王如法治世。彼九十五亿释迦如来。我悉供养。以香花幡盖饮食衣服卧具汤药一切乐具。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有九亿佛出兴于世。皆号迦罗迦鸠村陀如来应供正遍知。我于尔时作婆罗门子。巨富无量行一切施。以诸香花幡盖衣服卧具饮食一切乐具。供养诸佛。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有十八亿如来出兴于世。皆号迦那伽牟尼如来应供正遍知。我于尔时行大布施。彼诸如来我悉供养。以香华幡盖衣服卧具。饮食汤药一切乐具供养。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有十三亿诸佛如来出兴于世。皆号光明德如来应正遍知。我悉供养。以诸花香幡盖衣服卧具饮食一切乐具。供养尊重。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。二十五亿诸佛如来出兴于世皆号弗沙如来应正遍知。我于尔时出家作沙门行。如法供养以诸香华璎珞幡盖。衣服卧具饮食一切乐具。尊重赞叹。彼诸如来。亦不授我阿耨多罗三藐三菩提记。一切勇。我念往昔。有十二亿诸佛如来出兴于世。皆号毗婆施如来应正遍知。彼诸如来我悉供养。以花香幡盖衣服饮食卧具汤药一切乐具。悉以供养。我时出家。彼诸如来亦不授我阿耨多罗三藐三菩提记。最后毗婆施如来说此法门。阎浮提众生闻已。于虚空中即雨七宝。尔时阎浮提众生悉无贫穷。我于尔时。亦不得授阿耨多罗三藐三菩提记。但闻空声而告我言。汝不久当得受阿耨多罗三藐三菩提记。一切勇菩提萨埵。白佛言。世尊。经于几时。得授阿耨多罗三藐三菩提记。佛告一切勇菩提萨埵言。谛听善男子。过九十二亿阿僧祇劫。有佛出世。号然灯如来应正遍知。我于尔时作摩那婆子。名曰弥伽(弥伽者魏言云)。于然灯佛所。作摩那婆。修清净行。我见彼佛。以七茎青莲花。供养然灯如来。以此善根。回向阿耨多罗三藐三菩提。尔时然灯如来即授我记。摩那婆。未来过阿僧祇劫当得作佛。号释迦牟尼如来应正遍知。一切勇。我于尔时闻授记声。踊身虚空高十二多罗。住虚空中得无生法忍。无量阿僧祇劫所修净行。与六波罗蜜相应。一切善根悉皆现前。如视掌中庵摩罗果。一切勇。我于尔时。令无量百千亿众生住于善法。一切勇。况今我成阿耨多罗三藐三菩提。利益众生。我观众生以何应度。随其方便为其说法。若为诸天现作天身而为说法。若在龙宫示作龙身而为说法。于夜叉中示夜叉身而为说法。于饿鬼中作饿鬼身而为说法。若为人道示作人身而为说法。应以佛身而受化者。示作佛身而为说法。应以菩提萨埵身而受化者。示菩提萨埵身为之说法。我观众生以何应度。如是如是。为众生现随应说法。一切勇。我为众生演说诸法有多方便。何以故。一切勇。具足善根众生得闻此法。一切善根悉得增长。悭者布施。无福德者修行福德。自利利他修于念死。彼闻法故作此善根。以听法故过去善根亦得增明。彼得长夜利益安乐一切天人。一切勇。如是法门一经于耳。得生无量功德。一切勇。尔时众生各相谓言。更有余善法修行得阿耨多罗三藐三菩提不。善众生言。有法布施修行。口说善语。如是等法得善果报至无上道。愚痴之人作如是言。无法无施。无善恶果。无口善报。彼愚痴人得大罪报。展转堕于恶道之中。于八大劫堕于地狱受大苦报。十六劫中堕阿修罗。九千劫中生堕鬼神。十二劫堕饿鬼中受饿鬼苦。万四千劫生处喑哑。万六千劫母胎肠堕。万二千劫生作肉搏。万一千劫生处目盲。彼诸父母作如是言。我所生子虚受勤苦九月护胎。饥渴寒热诸苦具受。而不得子报恩之力。一切勇。如是如是。谤法众生堕于地狱畜生饿鬼。临命终时为忧恼箭射之而去。一切勇。口善语者作如是言。有法有施。有善恶业果报。彼人以是善根因缘。二十五劫生郁单曰。二十五劫生三十三天受诸天乐。从天命终生郁单曰。不入母胎目见百千世界。悉名安乐。见一切国土诸佛。不移本处成三菩提。一切勇。如此法门有大神力。能发清净信心。不生边地具清净戒。一切勇。复有众生作如是言。如来昼夜度诸众生。而众生界犹不尽耶。无量众生愿于菩提。无量众生生于天上。无量众生入般涅槃。何因缘故而不尽耶。时诸外道婆罗门等作如是语。我当问难沙门瞿昙如是之义。尔时有九十四亿诸外道婆罗门等。来诣王舍城。尔时世尊熙然微笑。尔时弥帝隶菩提萨埵(弥帝隶者魏云慈也)。从座而起顶礼佛足。向佛合掌。白佛言。世尊。何因缘故如来微笑。若无因缘。如来终不现希有事。愿世尊说。何故现笑。佛告弥帝隶菩提萨埵。善男子。汝今谛听。当为汝说。弥帝隶。今日王舍城必有大众集会。弥帝隶菩提萨埵白佛言。世尊。何众集会。为天龙夜叉若人非人。佛告弥帝隶菩提萨埵。善男子。此诸天龙夜叉等悉来集会。复有八万四千诸婆罗门。九千亿诸尼干子。来欲谈论。我悉降伏诸婆罗门为其说法。皆发阿耨多罗三藐三菩提心。九千亿尼揵陀。皆得须驴多波帝(魏言逆流)。万八千亿龙王悉来集会。闻我说法悉发阿耨多罗三藐三菩提心。六万亿净居天子亦来集会。复有三万亿恶魔及其眷属亦来集会。有万二千阿修罗王悉来集会。五百大王及诸眷属悉来集会听我说法。既闻法已。皆发阿耨多罗三藐三菩提心。尔时弥帝隶菩提萨埵。从坐而起顶礼佛足。右绕三匝即没不现。尔时一切勇菩提萨埵摩诃萨埵。从坐而起偏袒右肩。右膝着地向佛合掌。白佛言。世尊。彼五百国王名字何等。佛告一切勇。谛听善男子。一名欢喜王。二名善欢喜王。三名忧波难陀王。四名胜踊王。五名梵将军王。六名梵响王。七名善见王。八名善欢喜王。九名欢喜将军王。十名欢喜正王。十一名频婆娑罗王。十二名波斯那王。十三名增长王。如是等有五百大王。一一大王有千亿眷属。皆发阿耨多罗三藐三菩提心。唯除增长王。从于东方有三万亿菩提萨埵俱来集会。从于南方有五万亿菩提萨埵俱来集会。从于西方有六万亿菩提萨埵俱来集会。从于北方有八万亿菩提萨埵俱来集会。从于下方有九万亿菩提萨埵俱来集会。从于上方有百千亿菩提萨埵俱来集会。彼诸菩提萨埵悉住十地。一切皆诣王舍大城至如来所。于阿耨多罗三藐三菩提得不退转

尔时世尊告一切勇菩提萨埵摩诃萨埵言。善男子。汝诣十方诸佛世界。告诸菩提萨埵。今日如来于王舍城演说大法。汝等十方菩提萨埵。合掌恭敬。汝于须臾速还。及此众会听法。尔时一切勇菩提萨埵。从座而起顶礼佛足。绕佛三匝忽然不现。时一切勇菩提萨埵。到十方国。告诸菩提萨埵言曰。今日如来于王舍城演说大法。汝等今者应赞善哉。令汝永得安乐利益。尔时一切勇菩提萨埵。到十方国供养诸佛。告诸菩提萨埵。言已还归此土。譬如壮士屈申臂顷。至王舍城住如来前。时一切婆罗门。诸外道悉已集会。天龙夜叉阿修罗人非人等皆悉集会。五百大王及其眷属亦来集会。三万亿恶魔及诸眷属亦来集会。尔时王舍城地大震动。时十方诸佛世界。雨栴檀末香雨天妙华。雨如来上成大华台。金刚力士执金刚杵在如来前。尔时四方有四风王。入王舍城悉吹城内粪秽土沙远置城外。尔时十方世界雨众香水。十方世界雨优钵罗华。拘物头华。分陀利华。在虚空中化成华盖。于虚空中有八万四千亿师子之座。七宝所成。一切座上皆有如来宣说妙法。尔时三千世界六种震动。时一切勇菩提萨埵摩诃萨埵白佛言。世尊。何因缘故。于王舍城现希有事。佛告一切勇菩提萨埵善男子。汝今善听。譬如有人吾我自高家居贫穷日至王门。既到王门自高直入。时守门者寻捉打缚。王闻有人直入王门。王作是念。此人直入必欲相害。时王嗔恚敕诸臣言。汝将此人断其命根。并其父母兄弟姊妹。其人眷属皆悉忧愁悲泣啼哭。如来说法亦复如是。吾我自高喻诸凡夫。得见佛身耳闻说法。自生高慢说种种语。住吾我地自不听受亦不说法。若人说法一偈一喻亦不听受。作如是言。如此之法我已先知。何以故。住我慢地。或恃多闻自从放逸。与愚痴人共住不闻正法。自以多闻放逸不如法说。自作手笔而自说之。一切世人欺诳自身。作如是言。有财施我我是福田。彼愚痴人自诳其身。亦诳世间。食他信施不能消故。命欲终时生大恐怖。诸人告言。汝足伎术何不自救。答言。今日伎术不能自救忧悲苦恼。众人语言为一人故。父母兄弟亲里眷属无事诛戮。众生如是近恶知识。堕于地狱畜生饿鬼。如是如是。诸婆罗门诸尼揵子。我今告汝汝莫放逸。譬如鸟子未生羽翼。不能高翔飞于虚空。汝等如是无有神力。不能飞至涅槃之界。所以者何。汝所行法非毕竟道终归破坏。汝等临终自生悔心。我等虚受如是身命。修行不得天乐。不受人乐。不得涅槃。我等此身便为虚过。我当生何道。受何等身。尔时世尊。告诸婆罗门尼干子诸外道言。阎浮提中满中珍宝。汝等莫失所望。于佛法宝中莫作异学。汝等所疑悉问如来。佛当为汝分别说之。尔时一切婆罗门尼干子等。从座而起偏袒右肩。右膝着地合掌礼佛。白佛言。世尊。如来昼夜多度生死众生。众生界不减不增。世尊何因缘故。众生等而是生灭。尔时药上菩提萨埵摩诃萨埵。大誓庄严为然法炬欲问大事。白佛言。世尊。当来世无小众生。无老众生作生灭者。佛告药上。众生有老作小。如是生灭。善男子。如人沐发着新衣服从舍而出。余人语言。善沐头发着新净衣。又如有人洗沐头发着故洗衣。善沐头发衣服非妙。如是如是。药上。众生老者于阎浮提以为非妙。少者虽妙现有生灭。尔时一切婆罗门诸外道尼干子白佛言。世尊。何等名老。何者为小。佛告诸外道。所言老者。数数往来饿鬼畜生地狱之中受苦无厌。尔时一切诸婆罗门天龙大王白佛言。世尊。我等更不能受生死苦恼。彼诸尼干作如是言无小众生。尔时药上菩提萨埵白佛言世尊观此众生如是难度。佛告药上菩提萨埵。如来今日分别解说。汝善谛听。有九万四千亿新学众生。在如来前不礼如来。亦不问讯。尔时药上菩提萨埵白佛言。世尊。何因缘故。此诸众生不礼如来。亦不问讯请决所疑。佛告药上菩提萨埵。善男子。汝今谛听。当为汝说。善男子。若作是说无小众生。如是之人是小众生。彼人问言。我等诸人是小众生。世尊。我等是小众生。佛言。如是如是。汝等是小众生。以不能知自身量故。尔时九万四千亿新学众生。皆得十地住于虚空。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。此诸众生快得善利得尽生死。世尊。此诸众生离于生死得住十地。尔时一切婆罗门诸外道尼干子。诸龙国王恶魔眷属。来到佛所。白佛言。世尊。我等诣佛听此法门。愿我等辈皆得如来妙色之身形色像貌。愿如如来应正遍知。佛言。如是如是。善男子。汝等来诣佛所听此法门。发阿耨多罗三藐三菩提心。汝等不久当得阿耨多罗三藐三菩提。尔时如来说此语已。诸外道尼干子等。皆得无生法忍住于十地。时诸菩提萨埵以自神通。踊在空中高七多罗。于虚空中化成七宝台奉施如来。在于虚空中作种种神通而自变化。尔时诸天。于虚空中当如来上。雨众妙花念佛如来。于其自身起佛身想。无量百千诸天子。以华散佛作如是言。得大利益。沙门瞿昙真是世间大良福田。具足三昧自在之力。如是等众生渐具方便。说一善语得离生死。尔时药上菩提萨埵摩诃萨埵。从座而起偏袒右肩右膝着地。合掌白佛言。世尊。此诸天子。何因缘故作如是语。现诸神通善赞如来。佛告药上菩提萨埵言。善男子。彼诸菩萨不赞叹我。自赞其身。以其自身坐法王位。以其自身坐于法座。以其自身放法光明。诸佛所护。于阿耨多罗三藐三菩提。正觉说法。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。大德世尊。日夜常度无量众生。然诸众生犹不可尽。尔时世尊告药上菩提萨埵摩诃萨埵言。善哉善哉。善男子。能以此义问于如来。善男子。譬如有人大富饶财。多有奴婢。多有田宅园林谷米大小麦豆稻秫胡麻。彼于春时一切种植。至时则熟熟复收获。各各别盛盛已食之。至于春时种之如前。善男子。众生本业亦复如是。受乐报尽复作善业种诸善根。种善根已增长善法。增善法已得大欢喜。药上。以欢喜心于百亿劫乐报不失。善男子。如初发意菩提萨埵。不堕恶道总知诸法。药上菩提萨埵白佛言。世尊。云何初发意菩提萨埵而见梦也。佛告药上菩提萨埵言。善男子。初发意菩提萨埵。于其梦中多见怖畏。何以故。净一切业不可以身而受众苦。以是罪故梦见怖畏。药上白佛言。世尊。初发心菩提萨埵。梦中见何等怖。佛告药上菩提萨埵。善男子。其人梦见炽然火聚。彼菩提萨埵应作是念。以此火聚烧我一切烦恼。药上。是名第一梦见怖畏。又见水流垢浊不净。彼初发心菩提萨埵应作是念。漂我一切结缚烦恼。药上。是名初发心菩提萨埵第二梦见大怖畏也。药上菩提萨埵白佛言。世尊。见何怖畏。佛告药上菩提萨埵言。于其梦中自见剃发。药上菩提萨埵。见已不应恐怖。何以故。应作是念。剃贪嗔痴堕六道生。善男子。如是菩提萨埵不堕地狱。不堕畜生。不堕饿鬼。不堕龙中。不堕天中。药上。初发心菩提萨埵。唯生清净佛国土中。佛告药上。当来末世后五百岁。有诸菩提萨埵。心愿菩提。以发心故。得众多人毁辱打骂。药上于彼但应为其说法。菩提萨埵不应起于嗔恚之心。佛告药上。我于无量百千亿劫行诸苦行。善男子。我不为资生国土财产。为知诸法实相故。药上。我行苦行。不得阿耨多罗三藐三菩提。善男子。我闻此法。即日得阿耨多罗三藐三菩提。药上。此法甚深。如是法门难得闻名。若得闻此法门名者。一切得阿耨多罗三藐三菩提。药上。是人得超千劫生死。生净佛国。善知灭道。知第一道。识第一善根。成就无比神通知无比灭。药上。于汝意云何。云何名灭。药上菩提萨埵白佛言。世尊。法处名灭。佛言药上。何等法处。药上白佛言。世尊。法是法处。如世尊说。勤行精进。勤持戒。勤忍辱。是名法藏。佛赞药上菩提萨埵言。善哉善哉。善男子。佛问此义汝善解说

僧伽吒经卷第二僧伽吒经卷第三

        元魏优禅尼国王子月婆首那译

尔时药上菩提萨埵摩诃萨埵白佛言。世尊。何因缘故如来出世。佛告药上菩提萨埵言。善男子。为令众生多闻具足。是故如来出现于世。如来出世开甘露法。若如来出世则知一切法。以方便故。知世间法出世间法。知世间智出世间智。药上菩提萨埵白佛言。世尊。世尊知何等法。佛告药上菩提萨埵言。药上。如来知正法智。药上。以是智故总摄一切法。药上。若众生闻如来出世信法者。此是第一利益。药上。譬如有人出行治生。为得利故将千人众担负金宝。彼人父母告其人言。子善谛听。此金宝者是他之物。汝好守护莫使亡失。其人持宝未经多时自纵放逸。所持金宝悉皆散失。是时彼人忧箭射心。羞愧惭耻不能归家。时彼父母闻已忧愁悲泣而说此言。我等生此恶子。但有子名生我家内。财物悉皆散失。令我等贫苦。为他奴仆绝望而死。子闻父母既丧亡已亦绝望死。如是如是。药上。佛说此法。于我法中无净信者。彼无所望。临命终时。为忧恼箭射心而死。如彼父母。为彼金宝绝望忧恼。如是药上。于我法中无净心者。临命终时受诸苦痛。先福受尽彼不种善。临死时至忧恼箭射。堕于地狱畜生饿鬼受诸苦痛。作如是言。谁救济我。令我得离地狱畜生饿鬼之苦。又如父母告其子言。未来病苦。病有死苦。汝等得解脱时见行识生。身受苦痛遍体燋恼。自观已死眼不见色。耳不闻声。四支皆痛必归于死。遍体顽痴犹如木石无所觉知。子答父母语言。莫作是语。令我怖畏。观身无热。亦无余病。唯见死怖。我当归谁。谁救济我。父母若天谁能救拔。父母答言。祭祀天神必得安隐。子答父母。当速祭祀以求安乐。速至天祠问守庙人。时彼父母到天祠中。烧香求愿守庙者言。天神嗔怒。须杀羊杀人以用祭祀。汝子可脱。尔时父母自思惟言。我等云何我既贫穷。若天神嗔我子必死。若天神喜必得大恩。时速归家尽卖家财得羊一口。复语余人。且贷我金十日相还。若无相还我身当为君作奴仆。其人得金诣市买人。所买之人不知当杀以祭天祠。病人父母愚痴无智竟不至家。直诣天祠语守庙者。汝速为我设祭天祠。尔时父母自杀羊杀人然火祭天。然后天下告彼父母。汝等莫怖。我护汝子令得安隐。尔时父母踊跃欢喜作如是言。天神与我大恩令我子差。时彼父母欢喜还家见儿已死。尔时父母见子死已生大愁恼。忧箭射心绝望而死。佛告药上。善男子。近恶知识亦复如是。尔时药上菩提萨埵白佛言。世尊。如是众生堕于何处。佛告药上菩提萨埵。善男子。莫问是事。药上菩提萨埵白佛言。世尊。愿佛慈悲说如是人堕在何处。佛告药上菩提萨埵言。善男子。汝今谛听。其人母者堕于大叫地狱之中。其父堕于众合地狱。其子堕于火烧然地狱。守天庙者堕于阿鼻大地狱中。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。彼枉死人生于何处。佛告药上菩提萨埵言。彼枉死人生于三十三天之上。药上菩提萨埵白佛言。世尊。彼枉死人何因缘故。生于三十三天之上。佛告药上菩提萨埵言。善男子。汝今谛听。彼人临死时。起一念净心归依佛陀。以此善根当六十劫。受于三十三天之乐。八十劫中自识宿命。所生之处离诸忧恼。生生之处离诸忧恼一切苦灭。药上近恶知识。不得入于涅槃。药上菩提萨埵白佛言。世尊。云何众生不能入于涅槃。佛告药上菩提萨埵言欲求涅槃者当勤精进。药上菩提萨埵白佛言。世尊。云何名精进。佛告药上菩提萨埵。善男子。精进者名须驴多波帝。逆流之果名精进处。娑吉利陀伽弥果名精进处。阿那伽弥果名精进处。阿罗诃果名精进处。波罗提迦佛陀果名精进处。缘觉之智名精进处。菩提萨埵名字。菩提萨埵地果。名精进处。药上。如是等处名精进处。药上菩提萨埵白佛言。世尊世尊云何逆流。云何逆流果。佛告药上菩提萨埵。善男子。譬如有人种于树木。彼种树已即日生芽。彼树一日上下各生长一由旬。复有一人。亦复种树不得其所。风动不生移置异处。二人共诤互相诽谤。彼人如是共相诤论。国王闻之即敕臣言。某处二人互相诽谤速往唤来。傍臣受教遣使往捉。时彼使人微服而去。至彼人所作如是言。王唤汝等。时彼二人惊怖忧愁。王今何故命我二人。是时二人既至王所默然而立。时王问言。汝等何故共相诽谤而起斗诤。时彼二人白大王言。大王听我所说。我借得少许空闲之处。种植树林。即日生芽及叶。华果熟者中半。此人种植不生芽叶及以华果。须臾数移彼种不生。来见谤毁而起斗诤。大王如是之事。大王应知我无罪过。尔时大王。集诸大臣满三十亿。告诸臣言。汝等各说诸臣。白言。我等不知说何等语。王问诸臣汝等颇见即日种树即生芽叶及以华果熟者中半。尔时诸臣从座而起。白大王言。大王。我等不能决定信受如此之言。何以故。大王。此事希有。尔时大王问彼人言。如汝所说。是事实不。尔时彼人白大王言。此实不谬。王复答言。如汝所说。如此之事。即日种树即生芽叶及以华果。此事难信。尔时彼人白大王言。愿王自植知其虚实。时王集三十亿臣禁守彼人。然后大王自种其树。不生芽叶。不生华果。尔时大王。心大恚怒敕诸臣言。汝等速取利斧。彼所种树仰令斫伐。尔时诸臣受王教令斫断彼树。一树断已生十二树。斫十二树断生二十四树。茎叶华果皆是七宝。尔时二十四树。变生二十四亿鸡鸟。皆是金嘴七宝羽翼。尔时大王复生嗔怒。自执利斧往伐彼树。王斫树时。从树出生甘泉美水。时王惭愧敕诸臣言。放彼二人。诸臣白言。大王受教诸臣去已。放彼二人将至王所。王问其人。汝种此树。斫汝一树生十二树。斫十二树生二十四树。我所种树不生芽叶。不生华果。此事云何。其人答王。如我此福德大王则无如是福德。尔时三十亿大臣。胡跪白其人言。汝可治国而居王位。尔时其人。为诸臣众。而说偈言

  我不求王位　　不求世财宝
  心怀无上愿　　愿成二足尊
  得寂灭涅槃　　至彼成如来
  为汝等说法　　令到涅槃城
  往昔作不善　　令我入王狱
  狱缚受诸苦　　罪报悉已尽

尔时有三万三千高座。一一高座高二十五由旬。一高座上有二十五亿鸡而在其上。以金为嘴。七宝羽翼。出人音声告彼王言。大王不善不善斫伐诸树。以此罪业必入恶道。王不知耶。种此树者是何等人。大王答言。我未审之愿为我说。何等大人种此树耶。鸡鸟告王。如此人者照明世间名无上士。当度一切众生生老病死。王复问言。彼是何人种树不生。彼作何等不善之业不生。当为我说。鸟答王言。彼是提婆达多种树不生。无少善根树云何生。尔时三十亿大臣。闻此法门。皆得十地成就神通。时彼国王亦得十地。得通达一切善法三昧。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。何因缘故。此三十亿臣。皆得十地成就神通。尔时世尊。告药上菩提萨埵。善男子。汝今谛听。即时微笑。从其面门放八万四千光明。无量种种青黄赤白红紫光明。其光遍照无量世界。照世界已还至佛所。绕佛三匝从佛顶入。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。何因缘故。如来现此希有之相。若无因缘如来终不现希有事

佛告药上菩提萨埵言。善男子。汝见众人从十方来集会此不。药上菩提萨埵白言。不见也世尊。佛告药上菩提萨埵言。善男子。汝观十方一切世界。尔时药上菩提萨埵摩诃萨埵即观十方。见东方面有一大树。覆七千由旬。见二万五千亿众生在彼集会。默然而坐不饮不食。复见南方有一大树。覆七千由旬。下有二万五千亿众生俱共集会。不语不食不行默然而住。复见西方有一大树。覆七千由旬。下有二万五千亿众生俱共集会。不语不食不行默然而住。复见北方有一大树。覆七千由旬。下有二万五千亿众生俱共集会。不语不食不行默然而住。复见上方有一大树。覆七千由旬。下有二万五千亿众生俱共集会。不语不食不行默然而住。复见下方有一大树。覆七千由旬。下有二万五千亿众生俱共集会。不语不食不行默然而住。尔时药上菩提萨埵白佛言。世尊。我欲少问如来应正遍知。若佛听许乃敢发问。尔时世尊。告药上菩提萨埵言。善男子。随汝所问。如来悉能为汝解说。尔时药上菩提萨埵白佛言。世尊。何因缘故。从于十方有无量众生而来集会。以谁神力而来至此。佛告药上菩提萨埵言。自以神力而来至此。尔时药上菩提萨埵白佛言。世尊。我欲观诸世界。以谁神力而往至彼。佛告药上菩提萨埵。以汝神力自往至彼

尔时药上菩提萨埵。绕佛三匝忽然不现。过九十六亿世界有一世界名日月明。彼国有佛号日月土如来应供正遍知。与八万亿菩提萨埵。恭敬围绕而为说法。药上菩提萨埵摩诃萨埵。既到彼国。至日月土如来前。顶礼佛足白佛言。世尊。何因缘故。于娑婆世界。在释迦牟尼前观于十方。见无量众生集会。在此不见。尔时药上菩提萨埵摩诃萨埵。至日月土如来前白佛言。世尊。我过九十六亿诸佛国土。来至于此不见一人。世尊谁见谁闻。无知无觉树上而生众生。佛告药上菩提萨埵言。不也。善男子。汝颇见颇闻。无知无觉之树能生人不。药上白佛言。世尊。不见不知。佛告药上菩提萨埵。汝欲见不。我今示汝。药上白佛言。世尊。愿欲见之。尔时日月土如来。屈申臂顷百千亿众皆悉来集。一一众生手执香华供养如来。药上。汝今见不。药上菩提萨埵白佛言。已见世尊。已见善逝。佛告药上。善男子。此诸众生无觉无知悉皆如幻。时彼三万亿众生各申两手。以诸香华供养如来。药上菩提萨埵白佛言。世尊。此事希有。须臾之间此诸众生。各生百手供养如来尚不得脱。况两手者。佛告药上菩提萨埵言。如是如是。善男子。此诸众生无觉无知而生而灭。善男子。我身亦如是。如幻如化而示生灭。药上白佛言。世尊。何等是少众生。何者是老众生。佛告药上。善男子。亦有老者。亦有少者。药上白佛言。世尊。愿佛解说。何者是也。佛告药上。无福衰者是老众生。从彼树生者是少众生。药上白佛言。世尊。我欲见彼少众生等。尔时日月土如来即伸右臂。从于四方有百千亿众生。俱来集会至如来所。顶礼佛足绕佛三匝。在佛前立默然而住。药上白佛言。世尊。此众生。何故佛前默然而住。佛告药上。善男子。汝不知耶。地大之性无言无说。法聚无知无觉。何以故。药上。此诸少众生。不见生不见灭。不见老病死忧悲苦恼。具受一切苦痛之恼。云何而语。是故药上。如是众生应当教之。尔时药上菩提萨埵摩诃萨埵白佛言。世尊。少众生者从何所来。何处终。当生何处。不知法者。佛告药上。善男子。汝今谛听。此诸众生非是人作。非金师作。非铁师作。非木师作。非陶师作。非王者作。男女和合恶业而生受诸苦痛。作不善行受如是苦名少众生。药上彼不与。佛言。不礼如来彼受无量无边之苦。药上有少众生不共佛语者。受如是无量无边苦恼。药上以不善知苦因缘故不共佛语。不共佛语故不知善不知恶不知生。虽得人身不知生不知灭。药上。是名年少众生。药上菩提萨埵白佛言。世尊。年少众生云何生云何灭。佛告药上菩提萨埵言。善男子。譬如有人以木挑火木则渐烧。如是药上。众生之类初生时苦中苦死苦。药上白佛言。世尊。生时谁生。灭时谁灭。佛告药上。善男子。如佛之生。如佛之灭。譬如有人闭在闇室眼无所见。复有异人曾受苦恼作是思惟。此人受苦甚为可愍。若不得脱是人必死。以火与之令得少明。时闇室人见火叹喜心得安乐。尔时彼火以少因缘炽然火焰烧彼闇室。尔时彼人被烧而死。时王闻之作如是念。我国众生若有所犯更不系缚。尔时国王告下人民。汝等诸人莫生怖畏。于我国内施汝无畏。若有所犯不加害。汝亦不杀。汝皆当安隐莫生怖畏。药上。如来亦复如是。烧诸烦恼灭诸病苦。犹如彼人为令闇室众生安隐。自烧而死。如来如是。为诸众生令得安隐。不惜身命拔诸系缚令得解脱。如是药上。如来永离三毒之恼。为诸世间作大灯明。于地狱畜生饿鬼阿修罗。老少众生拔令解脱

尔时诸天。于虚空巾。而说偈言

  最胜好福田　　一切田中胜
  世间无上尊　　增长诸佛子
  佛田最胜田　　能除诸怖畏
  大师善方便　　守护诸众生
  住于涅槃界　　而示在世间
  令世间寂灭　　佛为无上师
  救护少众生　　亦救老众生
  三界诸众生　　方便而度之
  闭诸地狱门　　及畜生饿鬼
  此世得安乐　　他世亦安乐

尔时如来。即时微笑。而说偈言

  善哉见善人　　善哉见佛陀
  善哉闻法者　　善哉能敬僧
  善哉此法门　　灭除一切恶

尔时药上菩提萨埵摩诃萨埵白佛言。世尊。何因缘故如来微笑。若无因缘如来终不现希有相。佛告药上。善男子。汝见此等少众生不。药上白佛言。世尊。唯然已见。佛告药上。善男子。此诸众生今日皆得住于十地。尔时药上菩提萨埵摩诃萨埵。踊身虚空高八万由旬。共八万亿天子。于如来上散众妙花。地上年少诸众生等皆礼佛足。尔时药上。于虚空中而作是言。三千大千世界众生皆闻此声。地狱众生闻此声者悉得解脱。三十三天闻此音声皆来集会。时三千大千世界六种震动。时大海中八万四千龙王。动而来集。三万亿阎浮提夜叉俱来集会。二万五千亿罗刹饿鬼俱来集会。时如来所大众悉集。尔时如来。为诸年少众生说法。从十方世界有百千亿诸菩萨众。各以自神力俱来集会。尔时药上菩提萨埵白佛言。世尊。从十方国有无量菩萨俱来集会。无量天龙夜叉揵闼婆阿修罗迦楼罗饿鬼地狱。皆来集会欲闻正法。唯愿世尊当为说之。佛告药上菩提萨埵摩诃萨埵言。善男子。汝下至此。尔时药上菩提萨埵。以自神力从上而下向佛合掌顶礼佛足白佛言。世尊。法聚。法聚者何因缘故。名为法聚。佛告药上。善男子。法聚者名曰净行。净行者能离一切不善之法。善男子。汝见如此少众生不。药上白佛。唯然已见。佛告药上。此诸众生离邪淫故。必得诸陀罗尼。必得具足一切诸法

僧伽吒经卷第三僧伽吒经卷第四

        元魏优禅尼国王子月婆首那译

尔时药上菩提萨埵摩诃萨埵白佛言。世尊。以何方便。令诸众生悉闻正法。佛告药上菩提萨埵摩诃萨埵言。善男子。有诸众生我说生苦。而不听受老苦病苦。忧悲之苦。怨憎会苦。爱别离苦。死灭之苦。药上是名一切苦。时少众生闻此法已。合掌礼佛白佛言。世尊。我等亦有死耶。佛告年少等。汝一切众生亦归于死。彼少众生白佛言。世尊。云何死至。佛言善男子。临死之时灭行识风起。识转风起。识相应风起。善男子。是三种风。临死之时动于行识。彼少众生白佛言。世尊。何等三法。临死之时恼于身识。佛言。善男子。一者刀恼。二者针恼。三者杖恼。是三种风恼切其身。彼少众生白佛言。世尊。何者是身。佛言善男子。身名火聚。身名烧然。身名愚痴。身名崩坏。身名刺聚。身名丘冢。身名水泡。身名重担。身名生恼。身名老病苦恼。身名为死爱别离怨憎会。是名为身。彼诸年少复白佛言。世尊。如此之身云何名死。云何名生。佛言善男子。识灭名死。福德因缘识起名生。善男子。名为身者有无量亿筋脉相缠。身有八万四千毛孔。复有八万四千户虫。在中而住。彼诸虫等。亦有死灭。人将死时。诸虫怖畏。互相啖食。受诸苦痛。男女眷属。生大悲恼。迭相食啖。诸虫相食。唯有二虫。七日斗诤。过七日已。一虫命尽。一虫犹存。如彼虫斗临死不息。凡夫之人亦复如是。乃至临终诤论不息。不畏生苦。不畏老苦。不畏病苦。不畏死苦。如彼二虫至死不息。凡夫众生亦复如是。死至之时贤圣呵言。丈夫汝作不善。汝岂不见世间苦耶。不见生苦。不见病苦。不见老苦。不见死苦。答言。如是已见生苦病苦老苦死苦。汝若见如是苦。何不作诸善根。何故不为后世乐故修诸善法。丈夫我复问汝何不作善离于生苦老苦病苦及以死苦。云何不修正念之观。汝于阎浮提。岂可不闻犍椎声耶。不见众生行布施耶。不见众生于佛福田种善根子香华幡盖施佛之时汝不见耶。如来所有四众弟子。比丘比丘尼。优婆塞优婆夷。于佛法中有此四众能救苦厄。贤圣呵言。不善丈夫造作如是不善之业。尔时法王说偈告曰

  见如来出世　　闻击法鼓音
  见演说法时　　寂灭至涅槃
  见于多众生　　作福者甚少
  福能后世乐　　何故而不作

尔时彼人。以偈答法王言

  我愚痴无智　　亲近恶知识
  造作不善业　　由欲迷于心
  我以多习欲　　今受苦痛报
  多杀害众生　　破坏和合僧
  破坏佛塔寺　　愚痴无智慧
  口作不善语　　呵骂于父母
  我以不觉知　　自多造众过
  我见所生处　　在于大叫狱
  于众合地狱　　受于大苦痛
  复于阿鼻狱　　受无量剧苦
  大莲华地狱　　受于无量苦
  黑绳大地狱　　百千生受苦
  于一切地狱　　遍受诸苦恼
  无数百千劫　　受于大苦痛
  行于黑暗狱　　不见其门户
  复堕火镬中　　展转受众苦
  复有一地狱　　名曰刀剑狱
  百千亿刀剑　　行列在我前
  以此割截身　　自业受苦恼
  非工师所作　　业感自然生
  大风吹令起　　割切遍其身
  我应受如是　　地狱诸苦恼
  一切诸众生　　见我受此苦
  我所有财宝　　尽留在世间
  男女及兄弟　　姊妹亲眷属
  父母及知识　　奴婢作使人
  牛羊诸畜生　　我意迷于此
  贪着金银宝　　及精妙衣服
  贪着造舍宅　　善工画舍师
  众婇女娱乐　　箜篌箫笛音
  以此痴心者　　香汤自澡浴
  如是自娱乐　　顽痴无智身
  种种而供养　　我亦无兄弟
  虚妄心贪着　　今日受无量
  苦痛不可尽　　世间胜上味
  贪着而啖食　　香泽以涂发
  宝珠以为鬘　　贪色自迷醉
  今无救济者　　眼为恶业因
  见已则生贪　　耳因诸音声
  闻已则生贪　　臂贯以宝钏
  指着金宝镮　　咽颈着宝璎
  脚着于金钏　　作金宝罗网
  交露覆其身　　身着种种宝
  以此自庄严　　世间第一者
  以为身庄严　　细软上妙触
  增长于爱欲　　种种妙床榻
  以自悦其身　　种种好妙香
  以涂其自身　　栴檀龙脑香
  以此自涂身　　麝香等诸香
  用之自涂身　　瞻卜须摩那
  以此涂其发　　第一精妙衣
  白[疊*毛]自衣身　　若舍白象乘
  复乘于马乘　　为王治国政
  人众悉敬重　　宫中诸妃后
  善学歌舞戏　　禽兽在旷野
  无事猎残害　　作如是等恶
  不知后世报　　贪啖他肉故
  受如是苦报　　愚痴无智慧
  不知当有死　　我以愚痴意
  养育于身命　　今日至死门
  无能救济者　　汝等诸亲族
  何用视我为　　何不服胜衣
  何故自忧哭　　何故不梳发
  而受于苦恼　　我命终不存
  造恶增多故　　狐狼乌鹊等
  食我此身肉　　长养此身体
  为诸虫所食　　生死因此身
  众生则有生　　应如是授药
  令得离此难　　世医不能治
  无人救济者　　今日授法药
  令灭烦恼病　　种种养此身
  会必归于死　　世间无上尊
  救度诸众生　　寂灭诸佛子
  亦能救众生　　施诸妙法药
  令远离生死　　食肉长此身
  不知诸苦报　　长养于此身
  无有少利益　　此身顽痴聚
  不知少恩分　　妻妾男女等
  不知其恩力　　长养得成立
  无能救济者　　绝望无有知
  忧愁入死地　　众生生有苦
  后则有死苦　　想行触受等
  是则为中苦　　愚痴爱所缚
  生在于诸有　　为爱欲所缚
  乐着于境界　　众生无知故
  唯有忧恼苦　　善法不识知
  心但著名字　　不知于后世
  犹如恶毒蛇　　无明转众生
  远离于解脱　　不识解脱故
  恶业所流转　　心有烦恼故
  众生住生死　　烦恼烧众善
  如火焚干木　　流转于五道
  无有少乐受　　不知好妙乐
  在于何处所　　清净佛国土
  世尊转法轮　　如来净音声
  说戒定智慧

尔时世尊。复告药上菩提萨埵摩诃萨埵言。如是如是。恶行众生命终之后。受诸苦恼无救济者。善果报者今说伽他

  造恶不善业　　必入于地狱
  吞啖热铁丸　　饮于沸融铜
  雨火洒其身　　遍身体火烧
  无处而不遍　　展转受苦恼
  不知于净乐　　于法亦不知
  愚痴作非法　　远离于乐果
  信佛禁戒法　　修习于智慧
  以净戒具足　　速疾成菩提
  精进为第一　　生净佛国土
  宣说善法要　　摄护诸众生
  具足慈悲心　　修行净梵行
  且解脱知见　　成如来善名
  世间之父母　　菩提心第一
  说此法门者　　第一善知识
  听此法门者　　必作无上尊
  具世尊十号　　寂灭心相应

尔时药上菩提萨埵摩诃萨埵白佛言。世尊。何因缘故大地震动。尔时世尊。告药上菩提萨埵言。汝观何故大地震动。尔时药上观四方时。见下方界有二十亿众生从地踊出。见上方界二万五千亿众生同时而生。时诸年少见是事已。白佛言。世尊。今出生者是何等人。佛言。汝等见此大众不耶。白佛言世尊。唯然已见。佛言。此众生出为汝徒伴。问言世尊。此诸众生亦有死不。佛告年少。一切众生悉皆有死此亦不免。时诸年少。合掌向佛顶礼佛足。而白佛言。世尊。我等更不能忍流转生死。佛告年少。汝等能起大精进不。年少白佛言。世尊。我等面见如来。耳闻如来说甘露法。见菩提萨埵现大神力。见佛弟子诸声闻众集会。于此世尊愿修精进。不能忍受生死流转。尔时药上菩提萨埵。及五百眷属。以神通力踊身虚空。身出师子猛虎白象现大神通。于高山顶结加趺坐。满二万由旬。化作十千亿日月。时诸年少白佛言。世尊。何故世间有此光明。尔时世尊告诸年少。善男子。汝等见此日月不耶。时诸年少。白佛言世尊。唯然已见。佛告年少。此是菩提萨埵自身光明。现作日月示于众生。为之说法安乐利益一切天人。人中修行得此神通。时诸年少白佛言。世尊。愿说如此光明因缘。尔时世尊。告药上菩提萨埵摩诃萨埵言。善男子。汝见此三千大千世界六种震动不。时药上菩提萨埵白佛言。世尊。唯然已见。我有少疑欲问如来愿佛听许。佛告药上菩提萨埵言。善男子。随汝意问。当为汝说令汝欢喜。过去未来现在三世之事当为汝说。药上白佛言。世尊。我见如来有八万四千天子围绕恭敬。复有八万四千菩萨亦围绕恭敬。又见万二千亿诸龙围绕恭敬。复有万八千亿天神等围绕恭敬。复有二万五千亿诸饿鬼围绕世尊。何因缘故有此众集尔时世尊。告药上菩提萨埵摩诃萨埵言。善男子。在此众集为欲听法。药上此诸众生今当背生死。今日当得住于十地。住十地已得离烦恼得寂灭佛法。药上菩提萨埵白佛言。世尊。此诸众生杂业所生。如来云何净此众生。佛告药上菩提萨埵言。善男子。汝今谛听当为汝说。药上。此诸众生愚痴无智。不知解脱在于何处。多有年少诸众生等。今日当得法陀罗尼。得知一切法。得于十地。至十地已能作佛事。能转法轮雨于法雨。绍无上佛法安乐众生。天龙阿修罗健闼婆饿鬼等。闻法欢喜皆住十地。击大法鼓。吹大法螺。此年少等勤修行故得此十地。今所得法如十方佛

尔时五千年少众生。从座而起白佛言。世尊。此身为重担大可怖畏。不知道以非道。我等犹如盲冥之人。愿佛怜愍。我等劝请世尊。愿佛说法。我等生无智慧。不知法药。愿世尊为我等说法。令得远离生死之苦。所生之处愿见佛身。尔时药上菩提萨埵摩诃萨埵。语诸年少众生言。汝等食已然后为汝演说正法。时诸年少语药上言。我不识汝汝为是谁。色相寂灭离三恶道怖。如汝身相离诸恶法。见汝掌中七宝庄严。身服宝璎以功德聚。我不知汝是何等人。我等不须食。亦不须饮。以食入身甚可憎恶。变成屎尿。作血肉筋皮。是故我等不须食饮。不须一切细软衣服。不须臂印金钏。真珠璎珞庄严身具皆所不欲以无常故。我等亦不顾惜身命。为离恶道。我等求于法施。为安乐天人。为求善知识。不求转轮圣王。以转轮王虽主四方不免磨灭。男女妻子不能随从。所有七宝亦不逐去。无量人众亦不随去。于四天下无复自在。一身为王多见无常。作恶业故堕叫唤地狱。七宝自在游四天下竟何所在。仁者且听我等所说速至佛所。佛观一切愍之如子。我等无父无母。无兄弟亲族。一切皆无。佛为我父。如来是母。佛如日月示人善道。于生死中能救众生令不复生。诸烦恼河甚可怖畏。众生在中烦恼漂溺。如来救之令不复入。世尊怜愍为说正法。示人无上菩提之处。我等不贪饮食。不欲世间富贵。不愿生天。不畏堕恶道。得人身已愿见世尊。众生短寿流转无常。以恶业故贪着五欲不觉死至。知死必至亦不怖畏。不念生灭。不知细法。不修细业。不知寂灭界。无明覆心。生已归死。死已复生。心亦不生厌离之想。长夜受苦鞭挞挝打不生厌离。但起劫夺受狱缚苦五缚所系。本恶业故命识欲灭悲泣而言。谁救济我。一切悉与金银杂宝。身为奴仆一切作使我悉能为。王位自在我悉不欲。不须财物但求活命。如是仁者我等不须饮食。诸王自在食则上味会归于死。天食甘露亦归磨灭。种种百味王所贪着求实则无。饮食等味我等不须。我等求闻正法。令得离苦。愿离爱缚诸结烦恼。归依世尊愿离诸缚。我等敬礼大仙世尊。为诸众生未知仁者名字何等。愿自说之。药上菩提萨埵言世界广博众生名字宁可尽知。诸年少言。我等愿知仁者名字。甚深名字愿为宣说。药上答言。我名药上。治众生病。药中最上。我今为汝等说。令离诸病灭除一切世界病苦。世间贪为大病。能除灭之。嗔为大病。无智众生流转地狱畜生饿鬼。痴为大病。众生受苦皆能灭除。诸年少言。闻此妙法离诸苦难。凡夫无智受诸苦恼。闻此净法离诸恶业离恶业故无恶道畏。速见如来救一切病。医王施药疗治众苦。仁者速去礼敬如来。以我等语向世尊说。世尊能除我等之病灭烦恼火。欲火烧身不能灭除。我等极苦愿佛怜愍。身为重担甚可怖畏。三毒所压不可得胜。去来常担不能远离。不知死至。不生惊怖。不知解脱道。亦不知示解脱者。以愚痴意自谓不死。见父母死犹不生怖。诸业烦恼浊乱其心受诸苦恼。云何而食。我等无明覆心有如是苦。大怖重担想行及受。痴爱无智流转诸有。世间妄生不识解脱。世人愚痴浴以香汤。衣以上服。食以上味。耳听乐音种种自娱。种种好色乐欲观之。一切好味舌求贪食。细软之触身欲着之。二身和合痴心谓乐。此身顽痴何处有乐。着好履屣衣服饮食无如之何。临终困至无有能救自不能救。衣服之具岂能救济。生在世间驰诸象马。常作恶业不求解脱。自作教人不知后报。我等前死有生。今生有死忧悲苦恼。我具见父母兄弟姊妹妻子。丧亡悲哀忧愁苦恼皆悉见之。诸行皆空。智者云何而生乐着。不求寂灭法。不求离生死法。以贪覆心。生在世时不行布施。一切过中无过贪心。着于世法多作有行。不知修习禅定解脱之道。不知发大誓愿成无上道。佛是父母。佛是示解脱道者。能雨利益众生愚痴众生不知护法。发心愿求无上菩提。名为护法。一切行空财物亦空。若观我空不复受生。愿仁者怜愍。以我等语具向佛说。为诸菩提萨埵故。诸菩萨法不应懈怠。勤修精进舍恶行善。仁者为我往至佛所。礼敬如来作如是言。世尊。知一切法悉无有疑。恶魔眷属佛已调伏。如来已能然大法炬令众得乐。如是之法能成佛者我等未闻。仁者速往佛所。为我等故。我等不见如来。犹未得度三十二相八十种好。见此身已然后得度。尔时药上菩提萨埵。语诸年少。汝观上方有何等相。诸人闻已观上方。见五百化佛。又见三千大台七宝严饰。七宝罗网以覆其上。如莲华叶出种种香。时诸众生问药上言。此诸华座是何等相。药上答言。此是汝座速至佛所礼敬如来。诸年少言。我等不知所行之路。不见如来。知诣何方。礼敬如来。药上告言。汝但礼敬如来世尊。如虚空尘无有住处。如来亦如是。如来安住处如须弥山。如来等须弥山。如大海水。三千世界微尘数等十方菩萨。欲求佛住不知所在。十方诸菩提萨埵但遥礼敬。诸年少言。愿仁慈恩满我所愿。心欲见佛亲近礼敬。药上告言。如来不求香华。为众生作因令离生死。恶魔眷属不共诤论。归依佛者不入死门。速得法陀罗尼。发净心愿即得见佛。尔时世尊。以加陵频伽音熙然微笑。从其面门放八万四千光明。遍照三千大千世界。下至十八地狱。上至阿迦尼吒天。其光杂色青黄赤白颇梨等色。如是等光从面门出。遍照三千大千世界。遇斯光者一切众生皆得安乐。照世界已还至佛所。绕佛七匝从佛顶入。尔时药上菩提萨埵。从座而起合掌向佛白言。世尊。我欲少问。若佛听者乃敢发言。尔时世尊告药上言。善男子。随汝所问。如来为汝分别解说令汝欢喜。药上白佛言。世尊。此三万亿年少。欲听如来微妙深法。愿为说之。佛告药上。善男子。若闻如来深妙法者。当觉诸法得具足一切功德。日即得住于十地。能击大法鼓。建大法幢。药上汝见如是大台不耶。药上言世尊。唯然已见

佛告药上。此诸年少。今日得坐此台。证一切法。满足一切善根之法。今日当得击大法鼓。无量天人。得闻法已悉得利益。无量地狱众生。得闻法已得背恶道。说此语时。众中九千亿老众生。得须陀洹果。药上。闻此法者。得离一切苦具一切善法。药上。一切皆能成就佛身。药上。汝观四方诸大菩提萨埵。尔时药上即观四方。见东方界五十亿恒伽河沙菩提萨埵而来向此。见南方界六十亿恒伽河沙菩提萨埵而来向此。见西方界七十亿恒伽沙菩提萨埵而来向此。见北方界八十亿恒伽沙菩提萨埵而来向此。见下方界九十亿恒伽沙菩提萨埵而来向此。见上方界百亿恒伽沙菩提萨埵而来向此。到已皆于佛前在一面住。药上白佛言。世尊。于虚空中见黑色黄色是何等相。佛告药上。汝不知耶。药上白佛。唯佛如来能一切知。佛告药上。此是恶魔及诸眷属欲来至此。药上汝欲见不。药上白佛言。世尊。我欲见之。佛令药上即见恶魔。药上见已白佛言。世尊。何因缘故恶魔至此。佛告药上。魔欲乱此法座。药上白佛言。世尊。此诸菩提萨埵。为观诸年少受位故来。药上。汝见此诸菩提萨埵。种种形色种种相貌种种力不。药上白佛言。世尊。唯然。我见百千亿恒伽沙菩提萨埵。自在神通而来至此。尔时世尊说此法已。一切勇菩萨。药上菩萨。一切老少众生。一切天人世间。阿修罗揵闼婆。闻佛所说皆大欢喜

僧伽吒经卷第四


虚空藏菩萨经

    No. 405 [Nos. 406-408]

虚空藏菩萨经

        姚秦罽宾三藏佛陀耶舍译

如是我闻。一时佛住佉罗底翅山。依牟尼仙所住之处。与无量大比丘众。复与无量无边阿僧祇恒河沙数菩萨摩诃萨俱。皆从他方异佛刹来。尔时世尊。欲为大众说四辩才三明梵行住破恶业障陀罗尼经。尔时西方过八十恒河沙世界。有一佛刹。名一切香集依其中众生成就五浊。彼国有佛。名胜华敷藏如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛今正为诸大众转妙法轮。彼有菩萨摩诃萨。名虚空藏。已从彼佛闻深妙法得诸禅定。时彼菩萨见于他方无量无边阿僧祇数诸大菩萨。身升虚空往诣东方。又复遥见东方世界有大光明。即便往诣胜华敷藏佛所。头面礼足。绕百千匝。胡跪合掌而白佛言。世尊。我见他方无量无边阿僧祇数诸大菩萨。身升虚空往诣东方。又复遥见东方世界有大光明。以何因缘而有斯事。唯愿为我具解说之。时胜华敷藏佛告虚空藏菩萨言。善男子。东方去此过八十恒河沙世界。有一佛刹名曰娑婆。其中众生成就五浊。彼国有佛。名释迦牟尼如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今者在于佉罗底翅山。依牟尼仙所住之处。为令法流不断绝故。为令三宝常住世故。为降诸魔建法幢故。为闭生死开般涅槃故。为诸菩萨及以声闻诸来大众。欲说四辩才三明梵行住破恶业障陀罗尼经故。欲令十方诸佛刹土一切菩萨。从欢喜地乃至补处。住不共法不随他信。善于方便具无碍辩。如此大士悉云集故。是以彼佛放斯光明。其诸菩萨见此光已。乘虚而往至彼恶世。为诸众生说破恶业障陀罗尼。彼佛国土亦具五浊。与此世界等无有异。汝今应往娑婆世界。礼拜供养听受正法。并为彼国诸恶众生。说破恶业障陀罗尼。时虚空藏菩萨摩诃萨。闻佛语已欢喜踊跃。与八十亿菩萨。同时发声而白佛言。世尊。我今渴仰欲见彼佛今当承佛威神诣娑婆世界释迦牟尼佛所。礼觐供养听受正法。亦为彼国诸恶众生。说破恶业障陀罗尼。时胜华敷藏佛答虚空藏菩萨摩诃萨言。善哉善哉。汝自知时。时虚空藏菩萨摩诃萨即与八十亿菩萨俱顶礼佛足。身升虚空诣娑婆世界。尔时西方有如意宝珠光现。以无量释迦毗楞伽宝而为围绕。其珠光明。蔽于一切人天八部声闻菩萨日月星辰地水火风界所有光明。皆不复现。时会大众唯睹佛光及以珠光无量无边不可思议不可言说。无复余色唯见虚空。尔时如来光相照曜。时会大众各不自见。亦不见他。一切诸色悉灭无余不与眼对。不得自身色相形貌。及于所触无彼无此亦无中间。随所视方皆悉如是。亦复不见日月星宿地界水界火界风界。悉皆无有与眼对者。耳不闻声鼻不嗅香。舌不知味身不觉触。诸心数法亦无所缘。于我我所无复起相。亦无六入分别之想。不得诸大诸来大众。唯见佛光及以珠光。其珠纯以无量释迦毗楞伽宝。而为围绕。于其会中诸大菩萨。位登十住得首楞严三昧及一生补处者。见此相已身心安隐不惊不怖所以者何。缘解法相自性真实。及以于如第一义空故。其余菩萨及声闻众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽鸠槃茶饿鬼毗舍遮富单那迦吒富单那人非人等。见此相已。惊怖迷闷其心扰乱。各不相见亦无问处。心自思惟。不知何缘有此异相。亦复不知是谁神力。尔时众中有一菩萨摩诃萨。名曰梵顶。稽首佛足。长跪合掌而说偈言

  一切法自性　　众生无知者
  系着于色阴　　六情所愚惑
  不见于一阴　　推寻求色阴
  于佛法生疑　　今会有此人
  愿说决定法　　为断诸疑网
  使知彼此岸　　逮得虚空忍
  勇健入三昧　　身相不可说
  如意大宝珠　　常在其顶上
  释迦毗楞伽　　而以围绕之
  此会诸大士　　位皆十地者
  得首楞严定　　及一生补处
  斯等诸菩萨　　悉皆遥见之
  睹此瑞相已　　必知胜士来
  礼觐无上尊　　因说深妙法
  安慰怖众生　　归依天人师
  勇猛所行处　　教化熟众生

尔时世尊。而说偈言

  善哉如汝说　　定者所行处
  身相不可见　　修慧能推求
  此是虚空藏　　常所行止处
  无依无戏论　　三昧力示现
  众生着二见　　常为所迷惑
  以彼迷惑故　　不知彼此岸
  欲离于二见　　修不可说行
  速疾得究竟　　满足于诸地

复次善男子。初发心菩萨摩诃萨。初可说相及攀缘相修六波罗蜜。乃至知于地水火风虚空及识。生灭之相如实之性。复知诸法不可言说。无有自性无生无灭。无有攀缘不动不摇空无所有。一切诸法如是修行。离断常见不生怖畏。于一切法不起触想。心无攀缘空无所有。如是修行速疾具足六波罗蜜。更不复住断常见中。当于如来说此语时。一切大众见闻觉知。如本色像而于境界不取其相。尔时世尊。即申右手指于西方。而作此言。如斯光瑞。是虚空藏菩萨摩诃萨欲来之相。是菩萨具诸三昧犹如大海。住菩萨戒如须弥山。忍辱之心犹如金刚。精进勇猛犹如疾风。智如虚空慧如恒沙。诸菩萨中如大胜幢。向般涅槃之大导师。善根之地。是贫穷者吉祥之瓶。入闇者日。失道者月。是怖畏者所归依处。烦恼焦热甘露之水。善根者杖。般涅槃桥。生天者梯。度生死船。由旷路乘。诽谤恶口热恼者盖。降诸外道犹如师子。能净诸见犹如雨水。破烦恼怨犹如霹雳。毁戒者药。生善根牙犹若春泽。庄严菩萨犹如华鬘。显善恶行犹如明镜。无惭愧者上妙衣服。三苦病者之大良医。是热渴者明月之珠。疲极者床。具诸三昧犹如日珠。趣菩提路大牛之车。游禅定者清凉华池。助菩提鬘波罗蜜果。是十地中如意摩尼。是求首楞严者波利质多罗树。伐恶见刀。断烦恼习犹如金刚。降伏诸魔生诸功德。智慧宝藏。依于一切诸佛功德。是诸缘觉所依窟宅。是声闻眼生天者眼。行邪道者正直之路。是畜生归饿鬼之怙。是地狱救。一切众生无上福田。三世诸佛第一辅臣。能护法城。已具庄严十八不共诸佛秘藏。满足成就佛之智慧。一切人天所应供养。唯除如来余无及者。汝等大众。皆应深心恭敬奉迎虚空藏菩萨摩诃萨。随力所能。应以妙宝幢幡伞盖华香璎珞末香涂香衣服卧具。歌呗赞叹。平治道路种种庄严尊重供养。汝等大众。皆亦应成如是功德器

尔时大众。有从座起向虚空藏菩萨所现瑞方。踊跃欢喜颜貌怡悦。端目专注俱共奉迎。余菩萨摩诃萨及大声闻。天主龙主夜叉主乾闼婆主阿修罗主迦楼罗主紧那罗主摩睺罗伽主五通仙人主。各作是念。我等当办何等最上最妙供具。而以供养彼大士耶

尔时虚空藏菩萨摩诃萨。即以神力变娑婆世界。除众秽恶及诸丘山瓦砾荆棘坑坎堆阜旷野险隘风尘云雾。皆悉澄霁。七宝为地平坦如掌。无量众宝以为林树。枝叶花果皆以宝成。名华软草亦复如是。香气芬烈普熏世界。娑婆界中一切众生无诸苦患。盲聋喑哑癃残百疾一时除愈。其怨恶者咸生慈心。地狱饿鬼诸楚痛声皆悉休息。饮食衣服庄严之具自然丰足。其诸众生妙色端正支节具足威德第一。除诸结使。心得寂静于诸善根深生欣乐。以清净信安住三宝。一切大众两手皆有如意摩尼。于其珠内出大光明遍照世界。并奏天乐。雨种种宝杂色宝衣。又雨种种妙庄严具。宝鬘宝盖种种宝器种种天衣金锁璎珞真珠璎珞。青红赤白杂色莲华。雨沉水香牛头栴檀遍满世界其路两边有七宝台如帝释殿。又其台中婇女盈满。颜貌端严犹如魔后。作天伎乐出五音声。又于佛上有天七宝。大梵王盖悬处虚空。供养如来。其盖周圆百千踰阇那。复以宝网罗覆其上。真珠毦带垂饰四面。盖中演出种种乐音。清妙和雅超绝人天。一切大地草木丛林华果枝叶。皆出妙声。宣畅大乘六波罗蜜诸地行法。闻其声者于无上道皆不退转。亦有逮得无生忍者

尔时大众见虚空藏菩萨摩诃萨神变奇特。心生欢喜叹未曾有。各作是念。此菩萨摩诃萨。既现如斯大神通力。不久必来至此世界。我等今者当设何座以供待之。当于众会作此念时。即于佛前有宝莲华从地踊出。白银为茎。黄金为叶。金刚为台。琉璃为实。马瑙为须。梵色宝珠以为须本颇梨为蕊。其华纵广百踰阇那。有八十亿诸宝莲华。周匝围绕尔时虚空藏菩萨忽然在彼宝莲华上。结加趺坐。又见顶上如意宝珠。以无量释迦毗楞伽宝而为围绕。其八十亿菩萨。各各坐余宝莲华上

尔时弥勒菩萨摩诃萨。即便说偈。问药王菩萨摩诃萨言

  我自从昔来　　见诸菩萨众
  有来觐世尊　　先围绕恭敬
  头面接足礼　　然后退就坐
  云何此大士　　现斯神通力
  不修菩萨仪　　而坐宝莲华

尔时药王菩萨摩诃萨。以偈答曰

  此大智慧士　　善住深妙法
  不依妄想心　　而来见世尊

尔时弥勒菩萨摩诃萨。复以偈问

  若不见众生　　及以诸法相
  其心常安住　　诸法真实际
  云何而示现　　自在神通力
  唯愿为演说　　除我此疑惑

尔时药王菩萨摩诃萨。复以偈答

  今此大士夫　　勇健入方便
  为熟众生故　　现此神通力
  若不住实际　　愚惑诸凡夫
  明智开俗谛　　为入真谛故

尔时世尊告药王菩萨摩诃萨。善哉善哉。善男子。如汝所说。一切凡夫众生。不能思量一须陀洹解脱行处。一切众生得须陀洹。不能思量一斯陀含解脱行处。一切众生得斯陀含。不能思量一阿那含解脱行处。一切众生得阿那含。不能思量一阿罗汉解脱行处。一切众生得阿罗汉。不能思量一辟支佛解脱行处。一切众生成辟支佛。不能思量一与般若波罗蜜相应菩萨摩诃萨方便行处成熟众生。一切众生得般若波罗蜜相应菩萨摩诃萨方便行处成熟众生。不能测量乃至得无生法忍菩萨摩诃萨举足下足方便行处及解第一义谛成熟众生。一切众生得无生法忍菩萨摩诃萨方便行处及解第一义谛成熟众生。不能测量得四辩才菩萨摩诃萨举足下足方便行处及解第一义谛成就众生。一切众生得四辩才菩萨摩诃萨方便行处及解第一义谛成熟众生。不能测量住般若波罗蜜究竟首楞严三昧菩萨摩诃萨举足下足方便行处及解第一义谛成熟众生。善男子。是虚空藏菩萨摩诃萨。已无量劫。得无生忍具无碍辩。究竟满足首楞严定。住最上地决定坚固终无倾动。善知众生深心所行。应睹神变庄严之事。又复应见虚空藏菩萨摩诃萨欲来瑞相。又有见虚空藏菩萨摩诃萨得离欲地住地入地故。示入无边空处三昧。于西方没而来现此。时诸众生怖畏惑乱。入于俗谛现大庄严。为欲成熟诸众生故。又善男子。是虚空藏菩萨摩诃萨。若现第一义谛无生庄严。诸天及人乃至八地菩萨。皆当迷闷无能见其境界行相。善入如是深妙功德。善男子。虚空藏菩萨摩诃萨。巧方便慧深入一切诸佛法海。离诸疑惑不依他故。智慧善巧。于诸菩萨摩诃萨中。最上幢王。善男子。虚空藏菩萨。是一切众生生天般涅槃大明导主。能断一切烦恼心患。善治身毒及四大病。若有众生起恶邪见。轮回迷没生死旷野。无善方便不知生天般涅槃路。若有众生称虚空藏菩萨摩诃萨名。至心归命。烧坚黑沉水及多伽罗香。恭敬礼拜时。虚空藏菩萨观此众生心心善根。若见众生诸见烦恼之所惑乱。若见过去善根种子心所行业。于佛法僧布施持戒忍辱精进禅定智慧。及余功德随所堪能。时虚空藏菩萨摩诃萨。观彼众生随所应见。于其梦中现种种形。即以方便而为说法。善男子。若有众生应于寤觉见虚空藏菩萨摩诃萨。即于目前见种种形。即以方便开正直道。破诸众生恶业邪见恶愿恶归恶处恶取。如是计着悉令解脱。身口意业无诸邪曲。趣正直道正业正见正愿正归正处正取。常获亲近诸善知识。速疾舍离臭结烦恼。永免三涂八难之苦。常行善业得自在力。乃至渐渐入深法忍。若诸众生种种身病。及心狂乱聋盲喑哑。手足拘躃诸根不具。称虚空藏菩萨摩诃萨名。至心归命。烧坚黑沉水及多伽罗香。恭敬礼拜。或从乞药或愿除愈。时虚空藏菩萨摩诃萨。即随其愿。或现梵天像。或现释提桓因像。或现毗沙门像。或现四天王像。或现焰摩天像。或现兜率陀天像。或现自在天像。或现大自在天像。或现婆罗门像。或现刹利像。或现长者像。或现居士像。或现大臣官属像。或现童男童女像。或现父母亲属像。或现执金刚像。或现天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人像。现如是等种种诸像。在于梦者及寤者前。为说病相。并为分别诸药对治。病状如此应服此药。若如是病宜服彼药。诸众生等既闻说已。各随所应而合诸药。若自无者菩萨悉与。是诸众生或有一服二服三服众病皆愈。或有但见所现之身病即除者。如是善男子。是虚空藏菩萨摩诃萨。具大慈悲。若有众生贫穷困苦欲求大富。欲多诵习欲乐多闻。欲求解脱欲求离欲。欲求禅定欲求名称。欲得第一欲求善巧。欲得自在欲得端正。欲求好色欲得妙声。欲求好香欲得上味。欲求好触欲得饮食。欲求勇健欲得种姓高贵。欲愿生男欲愿求女。欲得眷属欲求福德。欲得成就六波罗蜜。欲得巧言。欲求覆护一切众生。欲得免脱一切牢狱。欲断一切诸恶律仪。有施心者愿建立之。乃至智慧亦复如是。欲得长寿。欲愿多财得已能用。欲令悭者能行布施。其毁禁者令坚持戒。若嗔恚者令修忍辱。其懈怠者使住精进。散乱心者教修禅定。其愚痴者令修智慧。不定乘者劝学声闻。着我众生教缘觉乘。若有众生离大慈悲自惜己身舍诸众生。愿离此心生大慈悲不自护身摄取众生。发阿耨多罗三藐三菩提心。善男子。时虚空藏菩萨摩诃萨。知彼心已即现方便。令此众生舍离先心起大慈悲。不护己身不舍众生。发菩提心住四梵行。若有众生乐大慈悲。欲求救济一切众生。欲愿安住阿耨多罗三藐三菩提。于阿练若处若在林中若于露地。烧坚黑沉水多伽罗香。合掌恭敬向于十方。五体投地至心归命。虚空藏菩萨摩诃萨。而便说此陀罗尼咒

阿蜜栗舍阿蜜栗舍　迦楼尼迦　遮罗遮罗毗(薄履反下皆同)遮罗珊(素干反)遮罗　迦楼尼迦罗母罗母　母楼(力斗反下同)鞞(步倪反下皆同)迦陀履摩目佉(去佐反)浮楼阇婆(步可反)奈迦楼尼迦真多摩尼富罗耶迦楼尼迦萨埵(都果反下同)舍迷(莫隶反吴音读)他跛夜　阿若(而夜反)陀梨踣(怖得反下同)钤(巨耽反下皆同)踣钤罗底(都履反下同)毗鞞迦铃台(徒履反)栗致毗鞞迦钤迦楼尼迦否(方久反)梨夜斗磨磨(武佐反)阿奢(始迦反)萨埵跛履　波迦夜阿输迦(居佐反)伽(巨左反)底　娑婆呵

善男子。是虚空藏菩萨摩诃萨。或现天像或示人像。或獐鹿像或为鸟像。或不现形随彼所应。以诸方便而为说法。化度无量那由他百千众生。令住声闻乘辟支佛乘及住大乘。又于少时建立众生。住于大乘得阿鞞跋致。乃至令得诸深三昧及陀罗尼。满足十地者。善男子。是虚空藏菩萨摩诃萨。具大慈悲。若人思量乃可能知虚空边际无能测量。虚空藏菩萨摩诃萨。智慧方便大慈大悲。及三昧力成熟众生之边际者。善男子。是虚空藏菩萨摩诃萨。成就如是不可思议功德智慧。善男子。若有众生心无谄曲。亦不幻伪其心纯至。顺入正流所见真实。不讥彼阙不自矜高。不卑他人离诸嫉妒。不自显异矫惑众人。心本具足。善男子。是虚空藏菩萨摩诃萨。怜愍此等诸众生故。以方便智勇猛精进修善方便。除灭此等诸众生罪。令发阿耨多罗三藐三菩提心。一切善根皆悉回向无上菩提得不退转。获大势力及精进力。为欲满足六波罗蜜故。常勤修习大慈大悲。乃至究竟得阿耨多罗三藐三菩提。善男子。是虚空藏菩萨摩诃萨。成就如是不可思议功德。勇猛成就一切众生。尔时弥勒菩萨摩诃萨。即从座起顶礼佛足。而白佛言。世尊。虚空藏菩萨摩诃萨。以何因缘。独其顶上有此殊妙如意宝珠。以无量释迦毗楞伽宝。而为围绕。光明显曜蔽于众色。不与诸余菩萨摩诃萨等。尔时世尊。告弥勒菩萨摩诃萨言。是虚空藏菩萨摩诃萨。具大慈悲能拔众生危厄险难。若有众生犯根本罪应堕恶趣。一切善根皆已烧然。虚空藏菩萨摩诃萨。是大无明邪见黑暗清净朗日。是灭根本罪者之大良师。能拔疑箭。破善法器能令完全。善男子。若有众生犯波罗夷。断善根栽趣向地狱。无所归依智者所弃。悉能济拔开示真路。能洒众生臭恶烦恼令离恶趣。是升人天解脱者梯。若有众生贪愚惑乱能令觉悟。嗔恚害心及以痴暗。谤无因果放逸不信不畏未来。贪求无厌极怀嫉妒。具十恶业日夜增长。如此众生。是虚空藏菩萨摩诃萨。能除如上诸重罪业。安处人天解脱之处犹如大车。善男子。是虚空藏菩萨摩诃萨。是诸天世人所应尊重奉迎供养

尔时弥勒菩萨摩诃萨。白佛言。世尊。云何名为犯根本罪波罗夷耶。若有众生犯斯罪者善根烧然堕于恶趣离安隐处。永失一切天人之乐。是虚空藏菩萨摩诃萨。能令此等诸恶众生。还得具足人天福乐。尔时世尊。告弥勒菩萨摩诃萨。善男子。若灌顶刹利王有自在力。犯五根本罪先所修习皆悉烧然。失安隐处远人天乐堕于恶趣。何等名为五根本罪。善男子。所谓灌顶刹利王。领国土有自在力。取兜婆物及四方僧物。或教人取。是则名犯初根本罪。复次善男子。灌顶刹利王领国土有自在力。毁谤正法。舍声闻乘辟支佛乘。舍无上乘。又制他人不令修学。是名第二犯根本罪。复次善男子。灌顶刹利王领国土有自在力。若复有人以如来故。剃除须发身被法服。持戒毁戒有戒无戒。脱其袈裟逼令还俗。或加杖捶或复系缚。或截手足乃至断命。自作使他造如此恶。是名第三犯根本罪。复次善男子。灌顶刹利王领国土。有自在力作五逆罪。何等为五。一者杀母。二者害父。三者杀阿罗汉。四者破和合僧。五者出佛身血。如是五无间罪若犯一者。是则名为犯根本罪。是名第四犯根本罪。复次善男子。灌顶刹利王领国土有自在力。谤无因果不畏未来造十恶业道。亦教他人令行十恶。是名第五犯根本罪。善男子。是名灌顶刹利五根本罪。若犯一者。此则名为犯波罗夷。先所修习一切善根皆悉烧然。离安隐处失人天乐堕于恶趣。善男子。是虚空藏菩萨摩诃萨。为此人故起大慈悲现生边地。随所应见现种种形。或沙门像婆罗门像。刹利长者居士等像。而为其说一切种智甚深大乘未曾有法诸陀罗尼及忍辱地。以如是等种种妙法。而引导之。灌顶刹利既闻法已。心生惭愧极怀怖惧。向说法者发露忏悔。先所犯罪誓不更作。安住布施持戒忍辱精进禅定智慧。勤修慈悲。生人天乐般涅槃乐

复次善男子。大臣亦有五根本罪犯波罗夷。若有犯者。先所修习一切善根皆悉烧然。堕于恶趣离安隐处。永失一切天人之乐。何等为五。谓彼大臣统理国土依倚王力。取兜婆物及四方僧物。或教人取。是则名犯初根本罪。复次善男子。若彼大臣统理国土依倚王力。破坏村邑城郭国土。或教人破。是名第二犯根本罪。复次善男子。若彼大臣统理国土依倚王力。毁谤正法。舍声闻乘辟支佛乘。舍无上乘。亦制他人不令修学。是名第三犯根本罪。复次善男子。若彼大臣统理国土依倚王力。若见有人以如来故。剃除须发身被法服。持戒毁戒有戒无戒。脱其袈裟逼令还俗。或加杖捶或复系缚。或截手足乃至断命。自作使他造如此恶。是名第四犯根本罪。复次善男子。若彼大臣统理国土依倚王力作五逆罪。何等为五。一者杀母。二者害父。三者杀阿罗汉。四者破和合僧。五者出佛身血。如是五无间罪若犯一者。是则名为犯根本罪。是名第五犯根本罪。善男子。是名大臣五根本罪。若犯一者此则名为犯波罗夷。先所修习一切善根皆悉烧然。离安隐处失人天乐堕于恶趣。善男子。是虚空藏菩萨摩诃萨。为此人故起大慈悲现生边地。随所应见现种种形。或沙门像婆罗门像。刹利长者居士等像。而为其说一切种智甚深大乘未曾有法诸陀罗尼及忍辱地。以如是等种种妙法。而引导之。彼时大臣既闻法已。心生惭愧极怀怖惧。向说法者发露忏悔。先所犯罪誓不更作。安住布施持戒忍辱精进禅定智慧。勤修慈悲。生人天乐般涅槃乐

复次善男子。声闻亦有五根本罪犯波罗夷。若有犯者。先所修习一切善根皆悉烧然。堕于恶趣离安隐处失人天乐。何等为五。谓杀生偷盗淫泆妄语出佛身血。善男子。是名声闻五根本罪。若犯一者。此则名为犯波罗夷。先所修习一切善根皆悉烧然。离安隐处失人天乐堕于恶趣。善男子。是虚空藏菩萨摩诃萨。为此人故起大慈悲现生边地。随所应见现种种形。或沙门像婆罗门像。刹利长者居士等像。而为其说一切种智甚深大乘未曾有法诸陀罗尼及忍辱地。以如是等种种妙法。而引导之。时彼声闻既闻法已。心生惭愧极怀恐怖。向说法者发露忏悔。先所犯罪誓不更作。安住布施持戒忍辱精进禅定智慧。勤修慈悲。生人天乐般涅槃乐

复次善男子。初发心菩萨趣向大乘。有八根本罪犯波罗夷。先所修习一切善根皆悉烧然。堕于恶趣离安隐处失人天乐。亦失大乘境界之乐。久在生死离善知识。何等为八。谓彼菩萨宿业因缘生五浊世。有余善根近善知识。归趣甚深大乘之法。发无上心智慧微浅。是初发心菩萨。又从他闻甚深空法读诵受持。复于少智愚痴人前读诵解说。余人闻已惊疑怖畏。于阿耨多罗三藐三菩提。心生退没乐声闻乘。是名初发心菩萨犯于第一根本重罪。先所修习一切善根皆悉烧然。堕于恶趣离安隐处。失人天乐及以大乘境界之乐。坏菩提心。是故菩萨。宜应先知众生善根及了彼心。随其所堪次第说法。如入大海渐渐至深。善男子。是虚空藏菩萨摩诃萨。随其所应以种种形现生其土。而为说法令生惭愧。于所犯罪发露忏悔。不堕恶趣增进善根。长养阿耨多罗三貌三菩提心。善男子。又有初发心菩萨犯根本罪畏堕恶趣。闻虚空藏菩萨摩诃萨名。至心愿见。欲发露忏悔所犯罪故。于初夜后分烧坚黑沉水及多伽罗香。至心合掌。称虚空藏菩萨摩诃萨名。善男子。时虚空藏菩萨摩诃萨。随其所应现种种形或现自身。或声闻身。或刹利身婆罗门身。乃至童男童女等身。在彼犯罪初发心菩萨前。教令发露忏悔除罪。以善巧方便。开示甚深无上正真大乘之行三昧总持忍辱之地。舍诸恶趣。得不退转阿耨多罗三藐三菩提心。精勤修行六波罗蜜。得力坚固犹如金刚。乃至自得阿耨多罗三藐三菩提。又善男子。虚空藏菩萨摩诃萨。若不现身在其人前教发露者。是初发心菩萨。应于后夜合掌至心而向东方烧坚黑沉水及多伽罗香。请明星言。明星明星成大慈悲。汝今初出照阎浮提。大悲护我。可为我白虚空藏菩萨摩诃萨。愿于梦中示我方便。发露忏悔犯根本罪。令得大乘方便智眼。善男子。彼初发心菩萨。即于梦中明相出时。虚空藏菩萨摩诃萨。随其所应而为现身。以诸方便。令彼初发心菩萨发露忏悔。先所犯罪。示方便智。令彼菩萨深怀惊怖。于阿耨多罗三藐三菩提心。得不忘三昧坚住大乘。疾得满足六波罗蜜。不久成就一切种智。复次善男子。初发心菩萨语余人言。汝今不能乐于大乘。亦不能行六波罗蜜。终不能得阿耨多罗三藐三菩提。不如早发声闻辟支佛心。速尽生死入般涅槃。余如上说。是名初发心菩萨犯于第二根本重罪

复次善男子。初发心菩萨语余人言。汝今何用受学波罗提木叉。律仪。当速发阿耨多罗三藐三菩提心。受持读诵大乘经典。先所造作身口意业诸不善行。当得清净。不受未来诸恶果报。余如上说是名初发心菩萨犯于第三根本重罪。复次善男子。初发心菩萨语余人言。汝今不应听受读诵声闻经典。汝当覆蔽声闻经典。声闻法中无大果报。不能断除结使烦恼。汝当听受读诵清净大乘甚深经典。又能消除诸不善业。疾得阿耨多罗三藐三菩提。作此说已有信受者。二人俱名犯根本罪。余如上说。是名初发心菩萨犯于第四根本重罪。复次善男子。初发心菩萨欺妄两舌。希求名称利养恭敬。赞大乘经为他解说。而语人言。我是善解摩诃衍者。为贪利故。见他解说大乘经典得供养者。憎毁轻疾而自贡高。虚诳妄语得过人法。作此行者离安隐处犯波罗夷。于大乘中为犯最重根本罪也。善男子。譬如有人欲趣宝洲乘船入海。而于中路自坏其船。没溺而死不自济命。岂能得宝。如初发心菩萨亦复如是。乘正信船入于大乘深广法海。始得入海自坏信船失智慧命。如是愚痴初发心菩萨。以嫉妒故虚诳妄语得过人法。而犯大乘重根本罪。余如上说。是名初发心菩萨犯于第五根本重罪。复次善男子。未来世中。初发心菩萨语在家出家初发心菩萨言。修多罗中甚深空义。及以三昧诸陀罗尼忍辱之地种种庄严。是大明智诸菩萨等所可观行。受持读诵大乘经典。又能为他分别演说。我自解了以慈悲故为汝等说。汝等亦当随所说行。于深妙法而得知见。彼初发心菩萨不作是言。我读诵思惟从他闻解。而言自得。皆是贪求利养因缘而自炫卖。违负三世诸佛菩萨及众贤圣。犯于大乘最深重罪。失人天路。尚不能得声闻辟支佛乘。何由渐进到于大乘。善男子。譬如有人将导众人游行旷野。经过丛林极大饥渴。见彼林中有诸美果而弃舍之。取于毒果食已命终。善男子。彼人犹尚不能自济。况复兼能度于余人。彼初发心菩萨亦复如是。人身难得今已得之。遇善知识发大乘心。而贪利养轻自炫卖。犯重根本罪。违负三世诸佛菩萨。为诸贤圣之所弃舍。堕于恶趣。是故婆罗门刹利毗舍首陀罗。不应亲近此恶菩萨。若亲近者亦皆得罪。余如上说。是名初发心菩萨犯于第六根本重罪。复次善男子。未来恶世。初发心菩萨造作诸杂旃陀罗行。谓刹利旃陀罗。婆罗门旃陀罗。大臣旃陀罗。大将军旃陀罗。毗舍旃陀罗。首陀罗旃陀罗。何等名为旃陀罗义。彼谓造作诸恶心业。此恶比丘自言智慧。自恃财宝行于布施。放逸憍慢。嗔嫌憎嫉余善比丘共相斗诤。恃王臣力。取善比丘物以奉大臣。大臣得已传以上王。佛法僧物亦复如是。善男子。王与大臣及恶比丘犯根本罪。余如上说。是名初发心菩萨犯于第七根本重罪。复次善男子。未来恶世。初发心菩萨造作诸杂旃陀罗行。谓刹利旃陀罗。婆罗门旃陀罗。大臣旃陀罗。大将军旃陀罗。毗舍旃陀罗。首陀罗旃陀罗。此恶比丘恃怙国王及大臣力。自言智慧自恃财宝行于布施。轻戏毁辱诸善比丘斗诤恼乱。法说非法非法说法。舍正经律颠倒义论。断学般若离慈悲心。不信如来所说经典巧方便戒。违法立制。令诸清净善行比丘废于坐禅读诵经典。无苦恼者生其苦恼。有苦恼者复令增长。恒怀恶心坏善威仪。行住坐卧无复时节毁禁破戒。实非沙门自言沙门。实非梵行自称梵行。不解经典为他解说。邀致四众供养恭敬。善男子。王与大臣及恶比丘犯根本罪。余如上说。是名初发心菩萨犯于第八根本重罪

善男子。彼善比丘坐禅诵经。皆是佛法出要正因是上福田。又是忍辱三昧法器。能说妙法成就众生。破无明黑暗开世间眼。济拔众生烦恼业恶。若彼恼乱故犯重罪。是善男子犯八根本重罪者。未能深入于佛正法。以功德智慧极微少故。善男子。是初发心菩萨犯此八根本重罪已。先所修习一切善根皆悉烧然。犯波罗夷离安隐处。失人天乐及以大乘境界之乐。坏菩提心堕于恶趣。轮回生死离善知识。善男子。是虚空藏菩萨摩诃萨。现种种形示生其土。或现刹利形。或现婆罗门形。或现声闻形。或现辟支佛形。乃至童男童女等形。在彼犯罪初发心菩萨前。而为说法。令生惭愧极大惊怖又教发露忏悔除罪。以善巧便。开示甚深无上正真大乘之行三昧总持忍辱之地。舍诸恶趣得不退转阿耨多罗三藐三菩提心。精进修行六波罗蜜。得力坚固犹如金刚。乃至疾得无上菩提。又善男子。虚空藏菩萨摩诃萨。若不现身在其人前教发露者。是初发心菩萨。应于后夜合掌至心而向东方。烧坚黑沉水及多伽罗香。请明星言。明星明星成大慈悲。汝今初出照阎浮提。大悲护我。可为我白虚空藏菩萨摩诃萨。愿于梦中示我方便。发露忏悔犯根本罪。令得大乘方便智眼。善男子。彼初发心菩萨。即于梦中明相出时。虚空藏菩萨摩诃萨。随其所应而为现身。以诸方便。令彼初发心菩萨于所犯罪深怀惊怖。示方便智。令彼菩萨发露忏悔。于阿耨多罗三藐三菩提心。得不忘三昧坚住大乘。疾得满足六波罗蜜。不久成就一切种智。善男子。彼虚空藏菩萨摩诃萨。勇猛饶益一切众生故。其顶上得有如此如意宝珠。复以无量百千释迦毗楞伽宝。而为围绕。不与一切诸菩萨等。善男子。是虚空藏菩萨摩诃萨。成就如斯不可思议方便智慧。复次善男子。若有众生。闻虚空藏菩萨摩诃萨名。或造形像或设供养。是人现世无诸灾患。水不能漂火不能烧。刀不能伤毒不能中。人及非人无能为害。亦无囹圄盗贼怨家诸恶疾病饥渴之苦。随寿长短必无夭横。临命终时。眼不见色。耳不闻声。鼻不闻香。舌不知味。身不觉触。手足诸根不能为用。唯余微识及身温暖。时虚空藏菩萨摩诃萨。随彼众生所事之神。而现其身。或转轮圣王身。或提头赖吒身。或毗沙门身。或毗楼勒迦身。或毗楼博叉身或余天身。或龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等身。在其人前而说偈言

  四圣谛义　　智者应观　　若解了者
  能离生死

善男子。时彼众生于命临终。既见其昔所事之神。又闻为说如此要偈。既终之后不堕恶趣。因斯力故速免生死。又善男子。若有众生心乐佛法。虚空藏菩萨摩诃萨。于其临终而现佛形。为说偈言

  佛智真实　　度生死海　　速求佛智
  得尽诸苦

善男子。时彼众生得见佛身。又闻此偈至心。观察。欢喜踊跃不能自胜。命终之后得生净国。永不更在五浊世界。常获亲近彼佛如来。又闻妙法。不久当得阿耨多罗三藐三菩提。善男子。是虚空藏菩萨摩诃萨。随彼众生临终之时。应闻妙法及应见僧。亦皆普示。善男子。是虚空藏菩萨摩诃萨。成就如此不可思议方便智慧

复次善男子。种种众生欲得三昧自在之力。应于后夜净自洗浴着新洁衣。烧坚黑沉水及多伽罗香。于一切众生起慈悲心。向于东方至心合掌。称虚空藏菩萨名。而作是言。忆持大智虚空藏得大慈悲。唯愿施我不忘三昧。即便说此陀罗尼言

殴(于后反)漏母漏诺踦(去支反)博叉(楚垢反)底(都履反下皆同)隶(吴音读之下同)娑勿陀逻婆(步可反)[多*頁](都可反)隶奈夜奈夜

摩诃迦楼尼迦　阿[少/兔](奴后反)播阎(市盐反)婆(薄贺反下阎婆皆同)悉寐(莫履反下皆同)栗底　西伽(巨左反)罗阎婆悉寐栗底跋(薄葛反)阇逻阇婆悉[寐-爿+(怡-台)]栗底卢舍悉[寐-爿+(怡-台)]栗底　阿婆(步可反)遮奈悉[寐-爿+(怡-台)]栗底　浮侈(邪贺反)俱致悉[寐-爿+(怡-台)]栗底　娑婆呵

善男子。是虚空藏菩萨摩诃萨。即令彼人得于三昧自在之力

复次善男子。若有众生。乐欲读诵种种书论欲伏众生。所谓彼论。或是佛说。或菩萨说。或声闻说。或世人说。是人应于后夜净自洗浴着新洁衣。烧坚黑沉水及多伽罗香。于一切众生起慈悲心。向于东方至心合掌。称虚空藏菩萨摩诃萨名。而便诵此陀罗尼咒

阿祢(奴履反)逻阇鞞　(步倪反下皆同)钤(巨耽反)浮娑阇鞞耶婆奈阇鞞　博厕(初器反)娑迷(莫隶反吴音读之)波吒(张伽反)逻阇鞞　他奈婆逻鞞　萨(始达反)多罗伽(已佐反)逻泥(奴帝反)休磨(武佐反下皆同)休磨　摩诃伽楼尼迦　娑婆呵

善男子。是虚空藏菩萨摩诃萨。即令彼人得于忆持不忘之力

善男子。若有众生欲入大海。欲为商贾。欲服汤药而求力验。欲脱系缚。欲脱枷锁。欲求免脱输送财物。若爱别离。若怨憎会。欲避水火。欲避盗贼。欲避师子。欲避虎狼毒蛇之难。欲免疾病饥渴之患。欲求尊位。有如是等诸所求欲。称虚空藏菩萨摩诃萨名。恭敬供养虚空藏菩萨摩诃萨。皆令满愿

复次善男子。若有王子贪乐王位。欲希灌顶得自在力。应于后夜净自洗浴着新洁衣。烧坚黑沉水及多伽罗香。于一切众生起慈悲心。向于东方至心合掌。称虚空藏菩萨摩诃萨名。而便诵此陀罗尼咒

阿祢(奴履反)逻阇鞞(步倪反下皆同)钤(巨耽切)浮沙阇鞞耶婆奈阇鞞　博厕(初器反)婆迷(莫隶反吴音读之)波吒(张伽反)逻阇鞞　他奈婆逻鞞　萨(始达反)多逻伽(已佐反)逻泥(奴帝反)休磨(武佐反下同)休磨摩诃迦楼尼迦　娑婆呵

善男子。是虚空藏菩萨摩诃萨。皆令彼人得满所愿

复次善男子。若有婆罗门众。愿乐欲得大婆罗门处。复有众生求长者处。或居士处或工巧处。或多闻处或威力处。或思惟处或解脱处。应于后夜净自洗浴着新洁衣。烧坚黑沉水及多伽罗香。于一切众生起慈悲心。向于东方至心合掌。称虚空藏菩萨摩诃萨名。而作是言。唯愿施我大慈悲力。令我所求疾得满足。时虚空藏菩萨摩诃萨。以净天耳闻彼请已。随其所应现种种形而为说法。令彼所愿皆得满足。善男子。是虚空藏菩萨摩诃萨。成就如是不可思议方便智慧。久已得入佛功德海。善男子。大海之水乃可有人能知滴数。无能测量虚空藏菩萨摩诃萨巧方便智成就众生之限数也。又善男子。虚空之量尚可得知。无有能知虚空藏菩萨摩诃萨所可成熟种种众生及其变化。或作佛形或菩萨形。辟支佛形或声闻形婆罗门形。或童男童女形。乃至人非人等形。各随所应或令目睹或使梦见。若有众生临命终时。唯除最后极微一息。先造恶业烧诸善根当堕恶趣。是虚空藏菩萨摩诃萨。皆能拔济令得安立天人之路。如斯等事之边际者。善男子。是虚空藏菩萨摩诃萨。成就如此不可思议巧方便者。佛功德海久已得入。善男子。以此缘故顶上得有如意宝珠。以百千释迦毗楞伽宝。而为围绕。有大光明。当于如来说此法时。一切大众咸生奇特叹未曾有。皆悉合掌。向虚空藏菩萨摩诃萨。时虚空藏菩萨摩诃萨。即从座起偏袒右肩。长跪合掌而白佛言。世尊。今此世界具于五浊众生愚暗。云何世尊。能于其中施作佛事。尔时世尊。告虚空藏菩萨摩诃萨言。善男子。汝见虚空。无有贪欲无嗔无痴自性清净。风尘暗障以为不净。既澄朗已即见日月星辰。及知刹那罗婆时数。善男子。如来久于第一义空已得自在。见一切法无有贪欲嗔恚愚痴。无缚无解自性清净。但以众生客尘烦恼之所覆障。不能觉悟。如来慈悲为此等故方便说法。而为除断客尘烦恼。开其智眼。使见如来净日照明。现在获睹甚深妙法四念处法。乃至八圣道法。令诸众生建立安住。又令疾发阿耨多罗三藐三菩提心。得大慈悲。乃至具足十八不共法。成一切种智。善男子。如来出世则能成熟诸菩萨众。及以缘觉声闻之众。善男子。今是虚空为倚于眼。为倚眼识。为倚眼触而得住耶。虚空藏菩萨摩诃萨。白佛言。不也世尊。佛言。善男子。为是内起眼触之缘生彼三受而倚空耶。虚空藏菩萨白佛言。不也世尊。佛言。善男子。耳鼻舌身意亦复如是。佛言。善男子。众生今者为倚于空。为是虚空倚于众生。虚空藏菩萨白佛言。世尊。各各相倚互作境界。又复各各不为境界。一切诸法皆悉空寂。一切诸法皆悉虚假。一切诸法皆依于如及以实际。世尊。犹如虚空无坏无成。无忆想分别。无动无摇无爱无憎。无牙无种子。无果无业无报离于文字。世尊。一切诸法亦复如是。菩萨若知此者。是名善知诸法之性得无生忍。尔时虚空藏菩萨摩诃萨。即说陀罗尼言

阿[少/兔](奴侯反)柰阿婢(夫者反)婆(薄贺反)逻阇(市夜反)摩(莫可反)[少/兔](奴后反)叉夜　视柰视柰　阇柰毗(夫尼反)磨(武佐反下皆同)牟尼呵罗阿柰夜　颇逻(力可反下同)臼呵(乎贺反)揭(巨谒反)婆祢(奴履反)婆(薄贺反)薮毗(薄履反下同)毗柰夜　薮舍舍婆　舍柰磨舍柰[多*頁](都可反下皆同)他(吐贺反)磨柰末兜梵(扶艳反)毗沙(所贺反)舍磨支[多*頁]奈枳(已纸反)黎舍庵(于甘反)复(扶豆反)僧输沙(疏马反)泥(奴帝反)娑婆呵

尔时世尊。告虚空藏菩萨摩诃萨言。善哉善哉。汝今说此无尽降伏师子奋迅陀罗尼。一切众生临命终时最后神识。有重烦恼障及重恶业。此陀罗尼悉能烧然。令得往生清净佛国。善男子。汝今善能以此成熟无量众生。又能成熟无量佛刹村园城邑一切众生。又随所应现种种形。又随其根说种种法。或为演说大乘经典。开深法门。若沙门旃陀罗。婆罗门旃陀罗。刹利旃陀罗。毗舍旃陀罗。首陀罗旃陀罗。此诸人等。所犯重罪以因汝故悉得烧然。今于善法建立增长。尔时世尊而说偈言

  众生诸贪诤　　皆因诸根起
  若能摄诸根　　疾得于解脱

尔时如来说此经已。有十千人天得无生法忍。无量人天得诸三昧。又无量人天得陀罗尼。又无量人天逮得忍辱。又无量人天于十地中各得增进。尔时世尊。告阿难及弥勒菩萨摩诃萨言。汝等应当恭敬奉持此经。尔时阿难及弥勒菩萨。即从座起偏袒右肩。长跪合掌白佛言。世尊。此妙经典我已受持。当何名此经。佛言。善男子。此经名忏悔尽一切罪陀罗尼经。亦名不可思议方便智救济一切众生经。亦名能满一切众生所愿如如意宝珠经。亦名虚空藏菩萨经。如是奉持。阿难当知。若有善男子善女人。久发阿耨多罗三藐三菩提心。于无量百千阿僧祇劫。修行六波罗蜜。于十方世界一切佛所。种种供养。乃至满无量阿僧祇恒河沙劫。不如有人读诵书写为人解说虚空藏菩萨经。及持名号。比前功德。百分千分百千万亿分不及其一。算数譬类所不能知。尔时阿难及弥勒菩萨白佛言。世尊。我当如是奉持。时诸大众。闻佛所说。欢喜踊跃。以诸供具。供养于佛虚空藏菩萨经


虚空藏菩萨神咒经

    No. 407 [Nos. 405, 406, 407]

虚空藏菩萨神咒经

        宋罽宾国三藏昙摩蜜多译

如是我闻。一时佛住佉罗山依正觉仙所住之处。与无数大比丘声闻众俱。亦与无量阿僧祇恒河沙等菩萨摩诃萨。演说如来功德经已。尔时西方有如来宝现。以无量百千释迦毗楞伽宝。周匝庄严。是宝珠光隐蔽一切余色光明。唯见如来及如意宝。余无量无边不可说色见如虚空。如来威光极更明显。此诸会众。不睹自身各不相见。大众诸色悉灭无余。不与眼对。不得色身及以所触。随所观视唯见虚空。亦不见于日月星辰地界水界火界风界。不与眼对耳不闻声鼻不嗅香。无心心数。无我我所及六入起想。瞻睹他方不得诸大。在在方所唯见佛身色相光明。亦复遥见如意宝珠。以无量百千释迦毗楞伽宝。周匝庄严余无所见。于此众中有住十地菩萨摩诃萨。得首楞严三昧。一生补处最后有身。见如是相不惊怖畏。解诸法空如实际性。是故不惊不怖不畏。余诸菩萨摩诃萨声闻天龙夜叉乾闼婆阿修罗紧那罗拘槃茶毗舍遮富单那迦罗富单那人及非人。在会中者。极惊怖畏生于忧愁。此彼闇蔽其心动乱。各不相见睹无问处。其事云何。何因缘尔。为是谁力。尔时众中有菩萨摩诃萨。名曰梵德。合掌向佛而说偈言

  一切法如性　　人无有知者
  依住于色阴　　六情根闇蔽
  不见于一阴　　思惟求色阴
  于佛法有疑　　此中有是人
  如此彼亦尔　　总知虚空相
  彼三昧勇健　　其身不可说
  如意大宝珠　　见在其顶上
  释迦毗楞宝　　皆遥远见彼
  是大慧众生　　度首楞三昧
  一切大慧者　　欲来见世尊
  今说甚深法　　决定无有疑
  安慰于此众　　悉来归世尊
  勇健者行处　　教化熟众生

尔时世尊。而说偈言

  如是如汝说　　三昧者行处
  若闻正住处　　是慧众生住
  此是虚空藏　　菩萨所行处
  无依无戏论　　彼三昧示现
  众生着二见　　常为所劫夺
  着断常二见　　彼此常闇蔽
  如是二见等　　将欲得解脱
  其性不可说　　速疾证诸地

复次善男子。是初发心菩萨摩诃萨。说初境界相。谓六波罗蜜。乃至知诸大生灭如实之性。然后知于一切诸法不可言说。无性无生无灭无境界。不动不摇。如是修行一切诸行。如是悉离断常二见不生怖畏。于一切法不起境界心。疾得具足六波罗蜜。更不复住断常见中。佛说是已。一切大众。见闻觉知如本色相

尔时世尊申其右臂说如是言。是虚空藏菩萨摩诃萨来。作是语已。告诸大众言。是菩萨得诸三昧犹如大海。持菩萨戒如须弥山。智所通达犹如虚空。勤行精进犹如疾风修行于忍犹如金刚。其慧如空。诸菩萨中犹如胜幢。向涅槃者导。是一切善根之藏。贫者得瓶。入闇者日。失道者月。是怖畏者大须弥山。是烦恼燋热者甘露。是一切种善根者栽。是趣大涅槃者桥。是堕恶道者船。生天者梯。是诽谤恶口者救。热恼者盖。于诸外道如师子王。摄取诸见犹如水镜。魔怨中铠。毁戒者药。是诸善本行之地。造鬘者华。具行者藏。无惭愧者上妙衣服。病者良医。饥者得食。渴者月珠。疲极者床。修三昧正行者日。向菩提者大车。游禅定者胜地。助菩提者宝轮。善男子。此是向波罗蜜者果报。是善男子又是进修行十地者如意宝珠。是善男子是进行首楞严三昧者波利质多罗树。是断邪见结使者刀。破诸习气犹如金刚。能降诸魔是良方便。是开发意。是诸一切佛法所依。是缘觉华鬘。声闻衣服。诸天眼目。人之正道。是畜生归。是饿鬼护。地狱尊救。是一切众生福田。是诸菩萨摩诃萨大车。是善男子是三世如来应供正遍知最大辅臣。护法城门。是善男子乃至具足十八不共法以自庄严。得于佛智成就具足。是善男子悉是一切众生应供。唯除如来。诸余一切应供中最。汝等大众。皆应奉仰各随力能应办供具。供养恭敬而尊重之。种种珍宝幢幡宝盖涂香末香衣服璎珞种种杂物。净治道路种种庄严。以种种赞叹而赞叹之。汝等一切不久当得是功德器

尔时一切大会皆共和合。从坐而起。向虚空藏菩萨摩诃萨所现之方。叉手合掌其心欢喜颜貌怡悦。以清净目谛观视之。于时众中诸大菩萨及大声闻。天主龙王夜叉主阿修罗主伽留罗主紧那罗主摩睺罗伽主及五通仙。各作是念。当设何等最上最胜供具供养是善男子。尔时虚空藏菩萨摩诃萨。变娑婆界。地平如掌七宝庄严。除去诸山旷野堆埠墙壁瓦砾灰粪臭秽尘雾云雷乾闼婆声。一切树木变成七宝。华叶果香皆悉具足。依地草木枝节茎叶。亦变化成七宝。尽娑婆世界除一切病。一切地狱畜生饿鬼无诸苦恼。皆得衣服饮食璎珞之具。娑婆世中一切众生。得成如意妙色端严威德第一肢体具足。除诸结使心得寂静。于诸善根其心欣乐。以清净心安住三宝。此所集众。两手自然有化如意宝。一一如意宝各出光明。遍照于此娑婆世界。又是宝珠出妙乐音。雨种种宝种种妙衣种种璎珞。雨种种金锁璎珞真珠璎珞。又雨种种妙华青莲红莲赤莲白莲及水坚华。复雨多摩钵香牛头栴檀末香。庄严于道。其道二边化七宝堂如帝释堂。于其堂内化诸婇女犹如魔后。作于五乐欢娱受乐。当于佛上虚空之中。化天宝盖满百由旬。清妙鲜洁宝网庄严。垂真珠贯庄严其中。作众伎乐过于天乐。田地草木树林华叶诸果实中。各出妙音殊过天乐有闻音者。于阿耨多罗三藐三菩提得不退转。尔时一切诸大会众。见虚空藏菩萨摩诃萨作是庄严。得未曾有。作是念言。我等云何为是善丈夫。于世尊前当设何座。尔时佛前出宝莲华。白银为茎。黄金为叶马瑙为台。梵摩尼宝以为其须。纵广十里。复有如是无量百千诸宝莲华。周匝围绕。见虚空藏菩萨摩诃萨忽在华上结加趺坐。见其顶上如意宝珠。见虚空藏所将眷属。亦各坐余莲华台上

尔时弥勒菩萨摩诃萨。以偈问于药王菩萨

  如诸本先来　　大名称菩萨
  恭敬礼世尊　　然后乃就坐
  是善丈夫来　　示现大庄严
  不敬礼世尊　　忽见其已坐

尔时药王菩萨。以偈答于弥勒菩萨

  见是大丈夫　　善住于佛法
  是不见众生　　不依一切想

尔时弥勒菩萨。复以偈言

  若不见众生　　安住于实际
  何义故庄严　　为我显现说

尔时药王菩萨。复以偈答

  是方便勇健　　教化众生故
  不知第一义　　凡夫妄想行
  世谛聪慧者　　迷真故受苦
  为脱是等故　　现如是庄严

尔时世尊赞药王菩萨言。善哉善哉。是善丈夫。如汝所说。假令一切诸凡夫。不能知一须陀洹解脱行处。一切众生得须陀洹。不能知一斯陀含解脱行处。一切斯陀含阿那含阿罗汉。亦复不知一辟支佛解脱行处。一切众生作辟支佛独一骐麟。亦不知一无生忍菩萨摩诃萨善行方便教化众生。一切众生得无生忍。不知一得首楞严三昧无碍辩才菩萨摩诃萨第一义谛解脱之行。善男子。是虚空藏得无生忍。得无碍辩。得首楞严三昧。知此大众过无量劫心之善根。应当现于大庄严故。住离欲地故。此善男子从西方没而来至此。示现同诸声闻缘觉。入于无量空处三昧。现于神通。一切众生生奇特心。复于世谛示现庄严。教化无量诸众生故。是善男子若现第一义谛无生庄严。乃至天人皆当惊怖迷惑失心。至八地菩萨亦复失心。无有能见其行相貌。入如是等深功德法。是善男子善知方便。度于一切诸佛法海。断于疑惑。自然善知诸方便度。于一切菩萨摩诃萨中犹如王幢。善男子。是虚空藏菩萨摩诃萨。示诸众生天道涅槃道。能解众生结使心病。亦治四大身内增损诸患。若有众生诸邪见逼。迷于生死旷野之中。不知方便。云何名为天道涅槃道。是诸众生。若称虚空藏菩萨名。礼拜供养烧众名香。是善男子观心善根见结覆心。及知过去心种善根。亦知现在供养佛法僧宝修施戒德。如是诸事。或于梦中方便示现正直之道。方便力故。及于一切恶见恶事恶愿恶求恶归恶趣。心得解脱。身口意行悉皆正直。所愿正直。得近正直真善知识。疾得解脱诸恶臭结恶见诸病。速疾得尽恶道恶业。所愿善故。行善业故。速疾得作心自在者。住甚深忍。若有众生。种种诸病逼切其身其心散乱。聋盲喑哑诸根不具。支节各异将有死相。如是等事。一心称是虚空藏菩萨名。除诸病故欲无病故。烧沉水香坚黑沉水。若多竭流香。礼虚空藏。是善大丈夫于夜梦中。作婆罗门像在其人前。或现释像。大功德天像。妙音天像。刹利像大臣像。兵使像良医像。或父母像或男女像。于夜梦中在病人前如实为说种种随病汤药。病者一服所患悉除。复有如是所营求事。欲多闻义。若欲寂静。欲修禅得慧。欲得名称。欲求工巧。欲得自在。欲得妙色。欲得封邑。欲得势力。欲得才能。欲得妙声。欲得子息。欲得眷属。欲得功德。欲得布施持戒忍辱精进禅慧。欲得美语。欲人恭敬。欲脱诸恶安止于施乃至住慧。欲得长寿。欲得种种所须之具得已能用。欲劝悭人令行布施。欲令破戒安住持戒欲令懈怠安住精进。欲劝愚痴令住于慧。未定乘者劝住声闻。自摄乘者劝住缘觉。是善男子作是方便示诸众生。若有众生舍离大悲。自护己身心舍众生。若有是心。我何方便能劝彼人。令住阿耨多罗三藐三菩提。安住方便四梵行处。乃至令其住于大悲。是人敬礼虚空藏菩萨摩诃萨。若阿练若处。若在林中。若露地。烧沉水香坚黑沉水。若多竭流香。至心合掌。五体投地遍礼十方。尔时说是陀罗尼句

阿弥隶奢阿弥隶奢迦留尼迦(一)遮罗遮罗(二)毗伽陀隶(三)摩懵呿复阇摩那伽留尼迦(四)真陀摩尼富罗移迦留尼迦(五)萨婆阿奢弥咃罗[口*皮]离移(六)阿清陀梨(七)破仇破仇(八)留坻脾脾伽仇(九)儨致脾脾伽仇迦留尼迦(十)富隶移埵摩阿奢(十一)萨埵波咃罗遮阿输迦竭抵莎呵(十二)

是善男子为于彼人。现人色像鹿色像马色像或天色像。随彼功德现于如是色像。言说示一方便。是方便故。能教化无量百千那由他众生。不定乘者。声闻乘者缘觉乘者。令是众生于一时中一弹指顷少方便慧。能令安住无碍大乘得不退转。乃至得于种种三昧。得陀罗尼。亦得于忍安住十地。是虚空藏菩萨摩诃萨。成就如是不可思议方便智慧大悲之力。善男子。假使能得虚空边际。无有能知是善男子智慧方便大慈大悲三昧之力。教化众生得其边者。是虚空藏菩萨摩诃萨。成就如是不可思议无边功德。善男子。若有众生。无谄幻惑正行威仪。成就正见质直无诳。不自赞誉离于嫉妒。无有奸诈善心成就。如是等人。是善男子而怜愍之。示方便智正行精进。以是方便智慧正行精进力故。脱诸苦恼。发阿耨多罗三藐三菩提心。一切善根悉皆回向于无上道。得不退转。以精进力满足六波罗蜜故。大勤进行速疾正觉阿耨多罗三藐三菩提。虚空藏菩萨摩诃萨。成就如是不可思议无量功德。教化众生。尔时弥勒菩萨摩诃萨白佛言。世尊。何缘独见此善男子顶上如意宝。极为妙色端严赫焰非余菩萨。佛言。善男子。是虚空藏菩萨摩诃萨成就大悲为利众生脱大苦事。若有众生犯根本重罪。当堕恶道。拔断一切诸善根行。如是众生。是善男子为作妙药。若有众生堕大无明。闇蔽恶见牢狱系闭。为大照明犹之如日。令其悔过断根本恶。能除众生疑心毒箭。或有众生破坏心器犯根本重罪。失诸善法当堕恶道。无归无趣。一切明慧之所舍弃。是善男子能示是等罪闇众生。安于善道犹如宝杖。又能洗一切臭恶结使。能转恶道安止人天。逮涅槃乐犹如大车。若有众生多欲所转。极多嗔恚忿怒心乱。或多愚痴无明覆蔽。说无因果不见不怖。不畏后世贪财无厌。乃至常行十种恶业。如是众生。是善男子为闭恶道安止天人。逮涅槃乐犹如大车。以是缘故。一切天人皆应供养是善男子。唯除如来应供正遍知。尔时弥勒菩萨白佛言。世尊。何等名为犯根本罪。众生犯是根本罪已。拔断一切诸善根行。当堕恶道。犯堕根本罪故。离于一切人天之乐。复因由是善男子故。令彼众生具满人天涅槃之乐

佛言。善男子。灌顶刹利王。犯根本重罪有五事。灌顶刹利王。犯五根本罪已。诸先所种一切善根悉皆败坏。犯堕根本罪故。离于一切人天之乐。当堕恶道。何等为五。善男子。若灌顶刹利。劫夺塔物。或夺僧物若招提僧物。若自取若使人取。是名初犯根本重罪。若诽谤法故。闻佛为声闻说为缘觉说为大乘说。诽谤遮固不令流布。是名犯第二根本重罪

若为我出家剃除须发被服袈裟。或能持戒或不持戒。或破戒或不破戒。脱其袈裟罢令还俗。或捶打其身而谪罚之。收闭囹圄。或断其命。是名第三犯根本重罪

若刹利王以自在力。作五无间罪。劝他人作五无间罪。于五无间罪。随作一罪

是名第四犯根本重罪

若刹利王。说无因果舍于他世。行于十恶。劝多众生作十恶业。是名第五犯根本重罪

善男子。若灌顶王于此五根本重罪之中。若犯一一。则破过去一切善根。犯堕重罪。离于一切人天之乐。当堕恶道。以是缘故。虚空藏菩萨摩诃萨。现生边地。或现沙门形服威仪。或现婆罗门。形服威仪。在在现生随彼彼处。为诸刹利说未曾闻法。如一切智说甚深经典。说陀罗尼及忍辱地。敷演开示。以是缘故。灌顶王先所作恶不善之业。惭愧悔过更不复作。安住布施。寂静调伏。大勤进行。趣向大道

复次大臣亦有五事犯根本重罪。何等为五。若彼大臣劫夺塔物。及夺僧物招提僧物。是名第一犯根本重罪

若大臣破于国城村邑聚落。是名第二犯根本重罪

若大臣诽谤正法。闻佛为声闻说为缘觉说为行一切智者说。诽谤遮固藏匿隐覆。是名第三犯根本重罪

若诸大臣见人为佛出家剃除须发被服袈裟。若持戒若不持戒。若破戒若不破戒。脱其法服罢令还俗。挝打其身谪罚系闭。若断其命。是名第四犯根本重罪

若大臣犯五无间一一恶业。是名第五犯根本重罪

善男子。若大臣犯一一五根本重罪。则坏过去一切善根。离于一切人天之乐。当堕地狱。以是缘故。是虚空藏为是等故。现生边地。作沙门形色若婆罗门乃至男女等像。而为说法。在在处处为于大臣说甚深法。如一切智说诸甚深经典及陀罗尼忍辱之行。开示演说。大臣闻已。所造恶业惭愧悔过更不敢作。安住布施。寂静调伏。勤行精进。趣向大道

善男子。声闻弟子犯根本重罪。亦有五事。何等为五。杀生淫欲偷盗妄语若出佛身血。是名声闻犯五根本重罪。若有声闻犯一一根本重罪。疑箭在心燋灭诸根。必定趣向恶道。虚空藏菩萨为是等故。在在现生。或作沙门形色威仪乃至男子等像。而为说法。令求声闻人惭愧悔过更不敢作。安住寂静调伏。趣向无上大道

善男子。初向大乘善男子。犯根本等重罪有八。何等为八。若有众生。恶业因缘生五浊世。以少善根近善知识。闻此大乘甚深妙法。少觉少知少善根故。发阿耨多罗三藐三菩提心。闻第一无相等经。转为凡愚分别解说。是凡愚人闻已惊畏。退失阿耨多罗三藐三菩提心。愿求声闻乘。是名初发心菩萨犯初根本重罪。以是罪故所修善根一切破坏。犯堕重罪。离于天人及涅槃乐。退菩提心当堕恶道。是故菩萨应知他心及善根已如应说法。如度大海渐渐深广。是故虚空藏现生其土。同彼色像而为说法。是名初犯根本重罪

行者欲见虚空藏菩萨忏悔所犯恶罪。于夜后分。烧沉水坚黑沉水若多竭流香。合掌称虚空藏菩萨名。是善男子随功德分。见虚空藏所现形色。若见其身。若沙门。若婆罗门。若男若女。种种形色。而为说法。是初发心菩萨所犯根本重罪即得忏悔。堪忍无上大方便行三昧忍辱及陀罗尼。至安住地能断恶道。于阿耨多罗三藐三菩提得不退转。于六波罗蜜。得大精进力犹如金刚。当疾觉于阿耨多罗三藐三菩提。若于其前不现身者。是初行菩萨。明星出时从坐而起。向于明星说如是言。南无呵喽那。南无阿喽那。成就大悲。今者初出于阎浮提。愿以大悲覆护于我。以我言说白大悲虚空藏菩萨。于夜梦中示我方便。以是缘故。得悔所犯根本重罪。成就大乘方便智眼。寻于眠中明星出时。虚空藏菩萨即于梦中自现色身令其悔过。灭除诸恶已即得三昧。名不忘菩提之心。善住大乘具六波罗蜜。若初行菩萨语余人言。汝等不能行六波罗蜜。亦不能觉阿耨多罗三藐三菩提。汝等速发声闻辟支佛心。可得度于生死。余如上说。是名初行第二犯根本重罪

复次初行者或说是言。汝用善持调伏戒为。但当速发菩提之心。汝当读诵大乘经典。身口意恶当得清净无有恶报。余如上说。是名初行第三犯根本重罪

复次初行者若说是言。汝有大德。应离声闻法勿听勿读勿为他说。汝善男子。当隐藏声闻经法。声闻法中不得大乘。不能令汝使得边际。唯当听受大乘经典为他人说。汝诸恶业当得清净疾成佛道。若受是语摄取是见。二俱犯罪。是名初行菩萨第四犯根本重罪

复次初行者妄语两舌。异思说大乘异经典。为于名誉利养受持读诵。如其所闻为他广说。作如是言。我知大乘非余人也。见他得利心生嫉妒。说他恶名诽谤毁呰。自说得过人法。是人破坏犯堕重罪。离大乘法当堕恶道。如人入海求宝船败没死。是初行者亦复如是。是名初行第五犯根本重罪

复次未来当有。若在家出家初行菩萨。读诵方广经典。为利养故言我解是妙法。愍汝等故为汝等说。是初行菩萨实无饶益众生之心。如人饥乏入大果林舍诸美果服毒果而死。是初行菩萨亦复如是。得入大乘正觉宝林。为利养名誉故说大乘经。犯根本重罪。为诸智者之所呵责。人天四众不应亲近。是名初行第六根本重罪

复次刹利王。有国相旃陀罗臣旃陀罗兵吏旃陀罗医旃陀罗。如是痴人自持财宝虽行施惠。放逸憍慢破坏众僧。因倚王臣劫夺僧物。是名初行第七犯根本重罪

复次若刹利旃陀罗臣旃陀罗比丘旃陀罗等。嗔嫌沙门。法说非法。非法说法。舍诸经律。非时义论。非法立制。断学般若。恼乱比丘。令诸沙门失净信心坏破威仪。实非沙门自言沙门。实非梵行自言梵行。令诸四众增致供养。是王臣及比丘二俱得罪。是名初行第八犯根本重罪。是初行菩萨犯此根罪。不名修行。断诸善根离人天乐当堕恶道。善男子。虚空藏菩萨为是等故。随形入类现同色像。而为说首楞严等种种经律。令犯罪者悔诸恶业。成就善根究竟涅槃。若善男子。礼拜称赞虚空藏菩萨。是人现在得大功德。复次若有众生。闻虚空藏菩萨名。造立形像。供养恭敬尊重赞叹。种种供养具而以供养。是人现身水不能漂火不能烧。刀不能伤毒不能害。人与非人无有能害。亦无病痛饥渴之患。临命终时。是虚空藏现其所事种种天像日月等像。令诸众生各见所归充满其愿。说如是偈

  是四圣谛　　慧者若见　　知生死过
  度诸有流

若有众生深心信佛。即现佛身。而说是偈

  佛智真实　　若度诸有　　得证佛智
  脱一切苦

是诸众生临命终时。得见佛身深心爱乐欢喜踊跃。既命终已离五浊世。生净佛土见佛闻法。善男子。是虚空藏菩萨摩诃萨。成就如是不可思议功德。若欲增长修诸禅定智慧自在。当澡浴清洁于夜后分礼虚空藏已设诸供养。作如是言。于诸众生大慈悲者。愿施与我念定方便。即说陀罗尼句

单牟兰那唅(一)颰钵尼隶(二)茂呢阿婆多隶(三)那那移(四)那移摩诃迦留尼迦(五)阿猱婆阎婆[口*蜜]呧(六)阿迦阇婆[口*蜜]呧(七)跋阇阎婆[口*蜜]呧(八)路奢[口*蜜]栗呧(九)阿那摩[口*蜜]呧(十)复多句[口*致][口*蜜]呧莎呵(十一)

即与彼人念定方便。若欲读诵种种经论。亦于明星出时。供养礼拜虚空藏菩萨已。作如是言。大悲虚空藏极拯济诸众生。愿愍念于我。与我念慧力。即说陀罗尼句

阿弥罗阇鞞(一)唅蒱沙阇鞞(二)咃婆那阇鞞(三)唻差三弥(四)癹咤罗阇师(五)悉[口*炭]那[口*束*頁]鞞(六)世罗迦尼(七)呼摩呼摩(八)摩诃迦留尼迦莎呵(九)

若欲渡海。欲求伏藏。欲求仙道。若系闭。若有别离。若怨憎会。若水若火。若刀若毒。若病蛊道。师子虎狼毒蛇盗贼等。种种怖畏及所须之物。是人应当称虚空藏菩萨名礼拜供养。应于彼起大慈父想。说如是偈

  愍我愍我大悲称　　利益世间虚空藏
  愿以大悲谛观我　　救我如是诸怖畏
  大德施我功德利　　我今苦逼最贫穷
  归依我尊大寂静　　愿得现乐及来世

尔时虚空藏菩萨。或现自身或现他身。种种形色而安慰之令得解脱。所须之物亦悉具足。若复王子欲绍王位。婆罗门处。长者工巧处。大威德处。大思惟处。大解脱处。是人亦于夜后分。称虚空藏菩萨名。礼拜供养诚心归依。虚空藏菩萨清净天耳远闻音声。往其人前而为说法令满所愿。善男子。虚空藏。成就如是不可思议功德智慧方便。假令众生数知海水。不能得知虚空藏菩萨功德之量。复有众生能知十方虚空边际。亦不能知虚空藏菩萨神通变化权智之力。是故虚空藏顶上宝珠光色如是。尔时会众闻佛所说。欢喜踊跃顶礼佛足。白佛言。世尊。云何能于五浊恶世教化众生。佛言善男子。犹如虚空无缚无解无嗔无爱其性清净。善男子。如来亦尔。于第一义空心得自在其性清净。虽处浊世。不为尘垢之所染污。为化众生故出现于世。善男子。而是虚空依于六识而得住耶。不也世尊。虚空藏白佛言。世尊。各不相依各无行处。一切法空无有积聚。本际如实犹如虚空。无坏无成。无忆想分别。无动无爱。无子无果。无报无有文字。世尊。菩萨摩诃萨如是知诸法性得无生忍。如是世尊。即说咒曰

卑婆罗阇(一)摩[少/兔][口*飲]移(二)慎那阇移(三)禅那尼摩(四)牟尼呵罗(五)阿那咃(六)破罗仇呵(七)竭婆尼摩(八)阿毗咃(九)修婆奢奢阇婆(十)舍那舍那(十一)舍那哆咃(十二)剑摩舍摩(十三)祢摩浮摩(十四)毗沙舍摩(十五)遮那咃那(十六)翅隶唵蒱三[口*輸][网-(ㄨ*ㄨ)+又]呢莎呵(十七)

佛言。善哉善哉。善男子。汝今能说是降伏眼师子吼步水陀罗尼。令诸众生临命终时。破烦恼障业障报障得生净土。汝能愍念众生游诸佛土。示现色身利益众生。说大乘经能断诸恶。令王旃陀罗乃至沙门旃陀罗修诸善法。佛说此经时。无量阿僧祇人得天种种三昧陀罗尼。住于诸忍得地十智。十千人得无生法忍。佛说偈言

  若众生诤讼　　因根本所摄
  能摄诸根本　　速疾得见彼

佛说经已。一切大众。欢喜奉行虚空藏菩萨神咒经


虚空孕菩萨经

    No. 408 [Nos. 405-407]

虚空孕菩萨经卷上

        隋天竺三藏阇那崛多译

如是我闻。一时婆伽婆。住佉罗坻迦山古昔神仙所居之处。与大一切比丘众俱。度量已过皆悉漏尽诸大沙门。复有菩萨摩诃萨众无量无边阿僧祇恒河沙数诸大人俱。乃至世尊授功德天记莂讫已。尔时世尊默然而住。及诸大众亦复如是。尔时西方有一应珠。是摩尼宝忽然出现。复有百千帝释天宝。左右围绕摩尼应珠。时彼应珠最在其前。应珠现已。彼山所有诸色光明皆悉不现。并诸天人大神王等。声闻菩萨大地火风诸水色光莫不隐蔽。唯除如来光明不灭。尔时大会睹如来光无量无边不可说不可说。遍满十方犹如虚空。而世尊光威严殊特照曜显赫最妙最胜。时彼大会所有众生集会之者。各见自身所有光明。并及诸大妙色隐蔽不现。自己色相触受等事亦复如是。凡所观处状若虚空。亦复隐蔽日月星宿地水火风一切诸色种种光明。不与眼对耳不闻声。鼻不闻香舌不得味。心意识等亦不能缘。亦无彼我。亦无六入。一切诸大凡所求觅。欲有观视一切方处。皆悉不见所视诸方。唯见佛身光明相好显现特尊。遥见彼珠。无量无数释提桓因着身妙珠左右围绕。彼胜摩尼独在于前。时大众中。唯诸菩萨十住地者。或得首楞严三昧者。或复有得一生补处。彼等菩萨见斯瑞相。不惊不怖不没不悔。所以者何。彼诸菩萨。于一切法皆达真理。晓了实相勤入空门。以是义故。不惊不怖亦不悔没。其余菩萨摩诃萨等。及诸声闻天龙夜叉阿修罗迦楼罗紧那罗鸠槃茶。及诸饿鬼毗舍遮富单那迦吒富单那人非人等集会之者。皆悉惊怖恐惧滞没。于此彼岸不能晓了。以惊怖心各各相求而不显现。心怀疑惑各作是念。此是何相此事何因。此谁威力。欲自决疑而无问处。尔时于彼海会之中。有一菩萨摩诃萨。名曰梵橛。即从坐起合掌向佛。而说偈言

  一切诸法相　　真实无知者
  若人住诸阴　　六根皆闭塞
  观一阴不实　　所谓色阴是
  彼疑诸佛法　　迷惑众生等
  善哉大世尊　　愿为说实法
  如来此彼岸　　教知空忍门
  彼大精勤者　　得定身难说
  最大摩尼宝　　顶戴彼庄严
  天帝着身珠　　无量左右绕
  彼等欲来故　　先现是瑞相
  彼等诸菩萨　　悉得首楞严
  如是诸智辈　　欲见佛世尊
  彼等来诣此　　说深法无疑
  愿佛慰此众　　彼当哀矜汝
  是等欲来故　　先现是境界
  于时佛世尊　　告彼菩萨言
  一如汝所说　　此是三昧境
  若人闻无住　　彼人能住智
  此是虚空孕　　三昧威力境
  得住无说处　　三昧先相现
  若人住二见　　彼等常迷惑
  染着断及常　　即失此彼岸
  此等二见者　　若欲速解脱
  是等莫言说　　速得证诸地

尔时世尊说此偈已。告彼菩萨作如是言。仁者虽然但初学人诸菩萨等。应欲教者应教彼等言说之相。以方便力亦教攀缘六波罗蜜。乃至诸大本相次第相生。应教令证既证知已。然后能于一切诸法无言无说。须知本体生处。应灭攀缘。诸阴无体应证应知。不令彼堕断常见中。舍二边已。即不惊怖不没不悔。于诸一切法中不生攀缘之想。于诸一切波罗蜜。速得圆满具足成就。亦不住于断常二见。尔时世尊说是法已。时会大众。还得相见如本无异。如旧所见诸色光明。如前所闻还闻如故。所证所触亦复如是。尔时世尊即举右手。唱如是言。此是虚空孕菩萨摩诃萨。来诣我所得诸三昧如大海水。于菩萨行成就具足如须弥山。于大智内犹若虚空。勤行精进犹如大风。于诸忍中犹若金刚。于般若中犹如虚空。于菩萨众犹如大幢。向涅槃路如大商主。于诸善根犹如地藏。为众贫穷犹如德瓶。为幽众生犹如日光。为失路者犹如盛月。为惊怖众如须弥山。为诸烦恼病苦众生如甘露药。为断善根诸众生等犹如拄杖。于生天路及涅槃道犹如桥梁。于度彼岸犹如大船。于上生天犹如阁道。若有被人诽谤恼者为作伞盖。于诸外道犹如师子。于诸恼热犹如冷水。于魔怨敌犹如铠钾。于学错误犹如智师。于诸善根犹如大地。于爱鬘者犹如香花。于诸持戒及知足者犹如明镜。于诸无惭无愧人所犹如刀剑。于诸病患众生之内犹如良医。于饥众生如功德天于渴众生犹如月珠。于疲乏众犹如床铺。于诸勤求三昧人所犹如日珠。于向菩提道心众生犹如车乘。于诸爱乐禅定众生如清凉池。于乐菩提助道众生犹如花鬘。彼善男子。又于行诸波罗蜜者犹如大果。彼善男子。于修诸地如彼应现摩尼之宝。若人修习首楞严三昧者。如波利质多罗树。彼善男子。犹如利剑。割截一切诸见结故。彼善男子犹如金刚。破坏一切习气烦恼故。能降伏一切魔众。于方便众生如解地藏者。彼善男子。显现胜智善巧方便。彼善男子。于一切法真实体中能作住持。又于一切辟支佛所为作花鬘。又于一切声闻众所犹如衣覆。于一切天犹如净眼。于诸人中犹如直路。于诸畜生能作归依。怜愍饿鬼拔地狱苦。又于一切诸众生所。为大宝器是大福田。于诸菩萨犹如大车。彼善男子犹如大臣。于三世中诸佛如来怛他阿伽度阿罗呵三藐三佛陀。常能守护诸法城门。彼善男子。以十八不共法。而庄严身。具足一切诸佛智慧。堪受一切众生供养种种供具而供养之。唯除如来。汝等此会。应须迎逆持诸供具。随力随分而供给之。尊重赞叹。以种种宝及诸幡盖香花宝幢诸花鬘等。末香涂香花鬘庄严种种璎珞。以诸宝器安置香汤净洒道路。种种璎珞庄严道侧。种种赞叹而歌咏之。何以故。汝等一切不久当得如是种种功德之器。尔时一切集会大众。皆从坐起面向西方。于虚空孕菩萨摩诃萨所来之处。低头合掌遥礼致敬。心生欢喜踊跃无量。熙怡含笑正立而住。彼大众中最胜菩萨摩诃萨。及大沙门天王龙王夜叉王阿修罗王迦楼罗王紧那罗王摩睺罗加王五通诸仙。各各思惟。我等今者作何供具。最胜最胜庄严供具。供养恭给彼善男子。尔时虚空孕菩萨摩诃萨。现神通力变此三千大千世界。平正如掌七宝合成。除灭一切山川沙卤高峰石崖丘陵坑坎土块礓石。臭处粪秽荆棘沙砾。无复遗余。除诸云雾尘烟等秽及诸恶声种种音乐。于此大千种种诸树变为七宝。其诸宝树枝叶花果出微妙香。于地所生种种药草。若小若大。若有枝叶若无枝叶皆成七宝。于此娑婆大千世界。诸病患者莫不除愈。一切地狱饿鬼畜生皆悉除灭一切诸苦。彼等众生饥者得食。渴者得饮。裸者得衣。复得种种微妙璎珞。于是娑婆世界之内。所有众生随心所乐莫不满足。身色端正世间无比最胜殊特。六根具足支节洪满。离诸烦恼心得寂定。乐行善行。于佛法僧心得净信。如是此会所集种种一切大众。左右二手皆持应珠。于应珠中。复出种种微妙光明。照此三千大千世界。悉皆遍满无不明耀。而彼应珠复出种种微妙音声。雨种种宝种种幡盖种种璎珞种种花香。雨种种鬘种种宝器种种甘果。复雨种种无价衣服种种金缕。复雨种种真珠罗网。复雨种种优钵罗花分陀利花波头摩花拘物头花沉水等香。复雨种种诸末香等。所谓牛头栴檀及赤栴檀白栴檀等。于彼菩萨所来之路自然洒扫。于道二边变成七宝庄严廊庑。犹如天帝难胜法堂。于其廊内自然化成种种玉女状。如欲界魔王妻妾。皆作五种微妙音声。自相娱乐或歌或舞。化作如是宝步廊已。于佛顶上虚空之中化成一盖。如梵天王所受用者。纵广正等满百由旬。宝綖为繐真珠垂露。四散垂下。诸余璎珞处处庄严。其璎珞中出五音声。一切大地所生草木。若大若小若长若短若好若恶皆悉出于五种天乐。一切众生莫不闻者。闻彼声已。无有不得不退转地。毕竟得至阿耨多罗三藐三菩提。尔时彼会一切大众。见虚空孕菩萨现大神力如是庄严。心生欢喜踊跃无量。生殊特想复作是念。我等今者。于世尊前。云何当为彼善男子敷设别座。尔时佛前自然即有一莲华座。白银为茎。紫金为叶。马瑙为台。梵摩尼宝以为花蕊。纵广正等一俱卢舍。其叶无量百千等数。其花周匝自然踊出无量无边百千花座。一如前花等无有异。又复于彼大莲华上。见虚空孕菩萨摩诃萨结加趺坐自然显现首戴应珠。于彼围绕莲华之上。复有无量无边眷属诸菩萨等。结加趺坐自然显现。尔时弥勒菩萨摩诃萨。即以偈告药王菩萨摩诃萨言

  先来大菩萨　　有大名闻者
  顶礼世尊足　　退坐莲花上
  此胜人来已　　显现大庄严
  不礼世尊足　　迳坐莲花座

尔时药王菩萨摩诃萨。还以偈颂。报弥勒菩萨摩诃萨言

  此是仁者见　　诸佛真如法
  不见有众生　　不染于分别

尔时弥勒菩萨摩诃萨。复以偈颂。报药王菩萨摩诃萨言

  若不见众生　　是住于实际
  何故现庄严　　汝决我心疑

尔时药王菩萨摩诃萨。复以偈颂。报弥勒菩萨摩诃萨言

  此是智者诸方便　　为化一切诸众生
  所有不解真如者　　愚痴执着住分别
  是智出现为世谛　　众苦逼恼不会真
  欲为令彼等解脱　　故现如是庄严事

尔时世尊。赞叹药王菩萨摩诃萨言。善哉仁者。如是如是如汝所说。假使一切凡夫众生。彼等众生终不能知须陀洹人境界方便解脱之事。假使一切诸众生等悉得成于须陀洹果。彼等众生亦不能知一斯陀含境界方便解脱等事。乃至斯陀含人亦不能得知阿那含境界方便。其阿那含亦不能得知阿罗汉境界方便。其阿罗汉亦不能知一辟支佛方便解脱。假使一切诸众生等。悉得独觉辟支佛道。犹如犀牛独一无侣。彼等缘觉不能得知无生法忍境界方便解脱之事而化众生。假使一切诸众生等得无生忍。亦不能得知一辩才首楞严三昧菩萨摩诃萨方便信行契会真如观察建立。本不能知从何处生从何处灭。是善男子虚空孕菩萨。得无生法忍已。过无量无边数劫。亦复已得无碍辩才首楞严三昧。知诸众生心心所趣。以是菩萨故。令无量无边众生见大庄严显现神力得住厌地。如此善男子从此处没。隐身不现。于西方出。知于此刹三乘杂教。以是义故。故现无边虚空三昧神通胜智。现三昧已。令诸众生生厌离想。然后现于世谛。现入庄严三昧。现入三昧已。因此三昧。教化无量无边众生。善男子。此善男子若径示现真如境界无生法忍庄严事者。即时世间一切天人心生扰乱即便迷惑。乃至八地菩萨犹尚迷没。况余人也。善男子。此大菩萨无人能知心行境界显现之相。此善男子得入如是甚深微妙功德之法故。有如是无量无边巧方便智。已入一切诸佛法海。无有疑心不由他悟。自知方便堪为一切大众生等而作大王。善男子。此善男子虚空孕菩萨。犹如宝幢。能为一切众生。示现天道解脱之路。能除众生心烦恼病。能灭其身诸大苦毒。善男子。若有众生。堕在邪见旷野之中。厄难迷惑不解方便。欲求生天。欲求涅槃。彼等众生若能至心烧沉水香。顶礼致敬彼虚空孕菩萨摩诃萨足者。此善男子知彼众生心心所行真实敬信。而彼众生起烦恼见迷惑颠倒。如其往昔所作心业。种诸善根随其所能。于诸佛边种诸善根。或于法边。或于僧边。或作施业。或持戒业。或复欲于内心证法。此善男子或于梦中。或于白日在于现前。以善方便示现至真之道。作是方便已。令诸众生解诸邪见发生善愿。断诸邪路灭诸邪道归于正见。如实得彼真正三行。即得真正深心所愿。或复得于真善知识。因善知识。悉得断除臭处烦恼邪见之病。复得速解恶道之愿。即得善行胜愿因缘。彼等速得心行自在。亦得安住十深忍中。若有众生自于身起种种诸病逼切之者。或有众生忘失本心。或复失眼。或复失舌。于六根内不具足者。或于身分小不遂者。彼等众生。若能至心顶礼虚空孕菩萨。或复称名皆得如意。若有众生欲治患者。于晨朝时香汤澡浴。当净身口面正向东烧沉水香。顶礼虚空孕菩萨摩诃萨大德之足。而彼善男子于睡眠梦中。或作婆罗门身。或作天帝释身。或作功德天身。或作大辩天身。或作刹利身。或作大臣身。或作断事官身。或作医师身。或作父母身。或作童子身。成作童女身。在病者前忽然来现。以是方便。而令彼病速得除愈。或复示作良药。方便令彼病者一切诸患悉得除差。若有众生或求资财。或求多闻读诵经论。若好寂静深思禅定。或求多智或求名闻。或求伎艺或求苦行。或求官位或求身色。或求财宝或求善根。或求音声或求饶子。或求妻妾或求眷属。或求多众或求行施。或求持戒或求忍辱。或求精进或求禅定。或求般若。或求好声言语清辩。或求事他称彼心意。或求解脱一切众罪。或求劝人令行布施乃至行智。或求长命。或有众生乏少资财恒作悭贪。欲令彼等除舍悭贪行于布施。或破戒者欲令持戒。若懈怠者欲令精进。乃至无智慧者令学智慧。若有众生未得定乘教行小乘。自度身者教缘觉乘。而此善男子于彼众生。示现方便令解上业。若有众生无有慈心。唯护自身不救他苦。或有众生作如是念。我今当作何等方便。若有众生欲发道心为他障碍。彼等众生欲回彼心。欲作如是方便示现。教彼众生。住四梵行。乃至教行大慈大悲。彼等众生应当顶礼虚空孕菩萨。或住阿练若处。若在空闲。烧沉水香。或烧多伽罗香。或烧栴檀香。香汤澡浴身口清净。胡跪合掌。五体投地。顶礼十方一切诸佛。而诵此咒

多地他(一)阿蜜利舍(二)阿蜜利舍(三)迦喽尼迦(四)这啰这啰(五)毗这啰(六)膻这啰(七)迦喽尼迦(八)何啰没啰(九)何逻末啰(十)毗伽陀唎(十一)摩摩佉(十二)蒱阇末那迦喽尼迦(十三)真多末腻(十四)逋啰夜迦喽迦(十五)萨婆贳迷萨他钵夜(十六)阿阇若陀履(十七)萨破钳(十八)萨破钳(十九)喉喽帝毗毗伽钳(二十)地唎杀吒毗比伽钳(二十一)迦喽尼迦哺唎夜妒摩摩(二十二)萨迦赐夜(二十三)阿贳夜(二十四)萨婆钵达舍(二十五)阿舒迦伽帝(二十六)莎呵(二十七)

诵此咒时。彼善男子即来现前。或作人形。或作野兽形。或作鸟形。或虽复来隐身不现。观彼众生福业深浅。随所受身或出音声。示现一乘善巧方便。令彼众生从一方便能化无量百千众生。未住定乘令住定乘。或住声闻或住缘觉。彼诸众生于一时顷。发智方便用少功业。令入大乘不退转地。乃至教示种种三昧诸陀罗尼忍辱度等。乃至令住第十菩萨行地之中。善男子。此虚空孕菩萨。得如是等善巧方便大慈悲智。善男子。我今为汝要略说之。假使有人度量虚空能尽边际。而此善男子方便大智大慈大悲总持三昧难可度量。此大菩萨得如是等不可思议功德之法。善男子此虚空孕菩萨。见有众生舍离谄曲远离邪心。发淳厚意成就正见。不毁于他不赞自己。舍离悭妒无有谄曲。不求名闻信心净者。是善男子怜愍彼等清净众生。示现方便智慧精进。如是方便。如是智慧。如是精进。得度厄难。发菩提心当得阿耨多罗三藐三菩提。教彼众生所有善根回向菩提。当得正道不退转地。速至阿耨多罗三藐三菩提。教作如是方便之利。智慧精进。圆满成就六波罗蜜。发大力心。当速成就阿耨多罗三藐三菩提。善男子。此虚空孕菩萨。得如是等不可思议殊特方便善巧胜智。教化众生。尔时弥勒菩萨摩诃萨白佛言。世尊。此善男子以何义故。首戴应珠。如是光焰。如是威力。善能示现。诸余菩萨无有是事。佛告弥勒菩萨摩诃萨言。善男子。此善男子虚空孕菩萨摩诃萨为诸众生成就大慈。常化众生而无休息。见诸众生在大厄难。欲拔苦故常不休息。若有众生犯四重禁。将堕恶道舍诸善根散灭众善。而此善男子为彼众生作大医师。见彼众生堕于无明入邪见网在危厄狱。此善男子为彼众生。犹如日光照明彼罪灭四重业。为彼众生拔心疑刺。若有众生破坏心器。而此善男子见彼众生破灭法行为烦恼陵。失于正法欲入恶道。无有归依无有救护弃舍诸智。此善男子为彼等辈罪恶众生。犹如拄杖示现正道。于诸罪垢烦恼秽恶洗令香净教背恶道。犹如大车将入天处速得涅槃。若有众生以欲逼心迷惑热恼。若有众生嗔恚炽盛共相斗诤。憍慢嫉妒心无暂息。烦恼所乱失于本心。若有众生无明闇障无出离心。不识有因不畏来世。或有众生广集财宝心无厌足。或有众生具行十恶曾无休息。此善男子为彼等故。闭恶道门开天人路。犹如妙车运令上生安置涅槃解脱正道。以是义故。此善男子于诸天人应受供养。唯除如来阿罗呵三藐三佛陀。尔时弥勒菩萨摩诃萨白佛言。世尊。佛于前说有四重者。何等为四。而诸众生犯四重已。退失诸善。断灭善根。堕于恶道。违本誓愿。烦恼所押。为诸天人之所憎恶。而此善男子见如是等诸恶众生。拔彼苦恼置安乐处。令得充足。尔时佛告弥勒菩萨。善男子。凡刹利王有五重恶。若彼国王犯五恶者。失于往昔所造善根。忘本誓愿被烦恼盖。远离天人一切乐事。堕于恶道无有出时。善男子。若有刹利灌顶王者。强夺佛物。或夺僧物招提僧物。或夺信心所施之物。或自身夺或教人夺。是名第一极恶重罪。若有刹利灌顶之王。诽谤正法。或声闻乘。或缘觉乘。或复大乘。诽谤不信。不令他行教令隐藏。是名第二极恶重罪。若有刹利灌顶之王。为我出家诸弟子等剃除须发着袈裟者。若持戒者。若无持戒。身脱袈裟令彼还俗。科彼与罪若打若缚。若复骂辱流徙诸方。或遣输物。或令入狱。或断命根。是名第三极恶重罪。若有刹利灌顶之王。故断父命。故断母命。或复断我弟子阿罗汉命。破和合僧出佛身血。此等五逆。若犯一种。或始发心。是名第四极恶重罪。若有刹利灌顶之王。不说有因弃于来世。行十恶业。十恶业中多教众生行十不善建立十恶。是名第五极恶重罪。善男子。若有刹利灌顶之王。此等五恶。但犯一者。彼刹利王失于往昔。所作善根。悉令散灭。违本誓愿被烦恼盖。失天人乐后堕恶道。于无量劫无有出期。善男子。此虚空孕菩萨摩诃萨。为彼众生故生边地显示其身。或作沙门婆罗门等。威仪庠序。观彼众生随何身化。方便示现如是身相。在在处处于国王前如是说法。昔未闻者如来所说一切智法甚深经典。持戒忍辱诸地行相为说示现。知彼刹利灌顶之王。昔造诸罪作不善行。自悔自惭欲得谢过更不敢造。舍离恶事有悔过者。后作福德行大布施建立善业。往生上界即得解脱。善男子。一切大臣有五重罪。若有大臣。夺取佛物或夺僧物招提僧物。是名第一重罪。若有大臣。破国村邑或破聚落。或破城隍或破他国。是名第二重罪。若有大臣。诽谤正法。或声闻乘。或缘觉乘。或一切智乘。若自诽谤若教他谤。不令修行。隐没不显。是名第三重罪。若有大臣。于佛世尊出家弟子。故生扰乱而恐怖之。若有持戒若不持戒。若有精进若不精进。脱彼袈裟逼令还俗。或与身罪或打或缚。禁系骂辱呵叱恐怖。或令输物。或令入狱。或断命根。如是名为第四重罪。若有大臣。造作五逆。或一或二或三或四。或具五种造罪恶业。如是名为第五重罪。善男子。若有大臣此五种中若犯一者。彼等大臣失于往业。所作善根皆悉灭尽。违本誓愿失天人乐。堕于恶道受大极苦。善男子。此虚空孕菩萨摩诃萨。为彼众生生于边地。故住边地示现身相。作沙门身威仪庠序为彼说法。或复现于婆罗门身。容仪齐肃。或作童子而为说法。在在处处示现生相。知彼等辈随有善根而为说法。未曾有者诸佛所说深妙经典诸陀罗尼忍辱诸地。慰喻说法。作是方便。令诸臣等悔过发露心生惭愧。忏彼恶业舍离众罪。教修布施精进持戒。建立善业往生上方得涅槃道。善男子。声闻之人有五种事犯大重罪。何等为五。一者杀生。二者行淫。三者劫盗。四者妄语。五者破坏形像出佛身血。是名五种犯大重罪。若我声闻诸弟子等。于五事中但犯一者。乃至如上所说之事。是虚空孕菩萨摩诃萨。为彼等故往生彼处示现身相。或作沙门及婆罗门。以彼威仪现彼身相。为说种种微妙法义一切智人所说甚深种种法门修多罗等诸陀罗尼一切诸地。显扬宣说。令彼等闻悔昔所造种种诸恶。忆念不忘深生惭愧。忏悔彼罪更不敢作。忏悔罪已。修行布施。备行苦行精勤勇猛。命终上生后得涅槃。即便发心入于大乘行菩萨行。善男子。大乘之人有八种事。犯于大罪。造八重已。令彼初行诸菩萨等。失彼往昔所种善根皆悉灭失。违本誓愿为烦恼盖。使诸天人之所轻忽。违背大乘即堕恶道。于多时间在烦恼处离善知识。善男子。何等为八。若有众生。以于往昔造恶因缘。生不净刹。彼等众生。以不多种善根因缘故。因善知识乃能得闻甚深大乘微妙经典。彼众生等心意狭劣。亦复不能多种善根。是初行菩萨。虽复发于阿耨多罗三藐三菩提心。闻是甚深空相经典。为他解说读诵。如其所闻如其所诵。为种种愚痴哑羊众生如是之辈宣扬敷演。于彼前说一切智法。教令读诵。而彼凡夫无有功劳。以凡夫心。不能得解甚深法意。闻是法已生恐怖心。心生悔没。即便背于阿耨多罗三藐三菩提。于声闻行中。发心修学

虚空孕菩萨经卷上虚空孕菩萨经卷下

        隋天竺三藏阇那崛多译

善男子。是名菩萨最初犯于第一大罪。是善男子犯是罪已。失于一切往昔所造诸善根等。违本誓愿被烦恼降不得上生。亦复不能得涅槃乐。徒自虚行于菩萨行。忘菩提心后堕恶道。善男子。是故菩萨欲化众生。先须知心应知其行。如其彼行次为说法。譬如有人欲入大海。应先知彼水之深浅然后当入。乃至略说。此虚空孕菩萨摩诃萨。为于彼等诸众生辈。现生彼国示现身相。善能知彼若干众生犯于重罪畏堕恶道

若复有人怖畏罪故。或闻他说称彼虚空孕菩萨名者。或复欲乐见彼菩萨。而彼菩萨为欲忏悔深重罪故。于后夜时。香汤澡浴着净衣裳。烧沉水香多伽罗香。右膝着地合掌向东。当至心称彼虚空孕菩萨名号

时虚空孕菩萨。知彼初发菩提道心人行罪福轻重。随其根性而为现身。或复作于婆罗门身。乃至童男童女之身。在现前住。现前住已。为欲怜愍初发心故。观彼菩萨本起重业。罪过因缘。教令忏悔。为彼示现甚深善巧微妙方便。说于最上大乘法要。教令建立三昧忍门诸陀罗尼说地等法。令其解脱一切恶道重罪因缘。住不转地。向于阿耨多罗三藐三菩提。又得大力犹如金刚。成牢固心。于六波罗蜜中。又得成就阿耨多罗三藐三菩提。是虚空孕菩萨。或众生前示现己身。现自身已而为说法。若虚空孕菩萨。未为现于身时。时彼初行菩萨大士。更于后夜。香汤澡浴着净衣裳。烧沉水香。求彼东方黄白大士名阿楼那。而口唱言。仁阿楼那。汝大慈悲欲出现照此阎浮提。怜愍我故。起慈悲心覆护于我。为我咨白虚空孕菩萨。令虚空孕菩萨示我方便。我今欲忏所有重罪。令我于圣大乘之中得大智眼。作是劝请礼拜已讫。还归本处安隐睡眠

尔时东方黄白大士阿楼那出时。虚空孕菩萨。即来现身。于睡眠梦中。在彼犯重菩萨之前。示现己身。教彼重罪初行菩萨大智方便悔所犯罪。或复示现大方便智。令彼初发道心菩萨得彼三昧。名无忘失菩提之心。安止住于大乘法中。速满成就六波罗蜜

复次善男子。或有初行菩萨。见行菩萨行者。至其人所而告彼言。汝不能行菩萨六波罗蜜。亦不能成就阿耨多罗三藐三菩提。汝当发声闻辟支佛心。汝于烦恼即得解脱。乃至如前说。善男子。是名第二菩萨犯于重罪

复次善男子。或有初行菩萨。见他众生作如是言。人者勿行波罗提木叉毗尼戒律。于是法中勿为精进。汝速发阿耨多罗三藐三菩提心。汝速读诵大乘经典。汝所作三种诸烦恼行。谓身口意。因此恶业诸烦恼故。即得清净。乃至如前所说。善男子。是名初行菩萨第三犯于重罪

复次善男子。或有菩萨。见于他人作如是说。汝诸人辈。舍声闻乘莫听读诵。莫为他说覆藏勿示。汝等善男子莫示声闻乘。汝若行此声闻乘者。不得大果。不能断除诸烦恼结。汝但说清净大乘经典。听诵受持为他显说。以此因缘。汝得度脱一切恶道。得灭一切诸恶等业。当速成就阿耨多罗三藐三菩提。彼人若闻初行菩萨如是言者。随顺此行。彼等二人皆犯重罪。善男子。是名第四犯于重罪

复次善男子。初行菩萨。常行两舌以心口相违。凡所读诵大乘经典。求名闻故。为利养故。为得尊重求供养故。作如是心读诵经典。为他解说受持宣通。若为他说方便随宜。于他边闻复向他说。我今身是大乘之人。自余非也。发如是等嫉妒之心。以利养故。或见其余大乘行者从他人边所得财宝四事供养。以是因缘彼等即便生嗔恨心。为彼菩萨处处流布鄙恶名闻。毁辱骂詈诽谤轻贱称誉自己。以如是等嫉妒心故。向于他人说上人法。我得上人。如是上法。我得我知。以是因缘。是人违于本誓愿故。被烦恼降背大乘法。彼等众生于大乘中。犯大重罪乃至舍身堕于恶道。譬如有人欲采珍宝诣宝洲边而不入海。虽复入海在于中路自破船舶。而彼痴人于海水内便取命终。善男子。如是如是其初行菩萨等。发心欲入大乘之海。而彼痴人因嫉妒故毁谤妄语。以是因缘。彼等痴人破信行船。破信行已灭智命根。善男子。其初行菩萨如是愚痴无智少闻。以嫉妒因缘。妄语毁他遂犯大罪。善男子。是名初发心菩萨第五犯大重罪

复次善男子。有当来世初行菩萨。或复俗人出家人等。所有甚深空相法门微妙经典。以诸陀罗尼诸地诸忍。以种种行等而庄严之。为诸大智诸菩萨等。作于勤求苦行境界。于大乘经或读或诵。或解说宣扬。为他敷演分别广宣。而语他言。我自然解如是经典。自然证知。自然明了。唯我一人为汝等故。慈悲演说。汝从我闻已。如是思惟。如是读诵。如是甚深法中自然晓了。汝以是因缘当得知见如我今者。而不肯言我读我诵。如是甚深微妙经典为汝说也。如是之人。从其四辈求利养故自卖其身。以是因缘。一切三世多陀阿伽度阿罗诃三藐三佛陀。及大菩萨摩诃萨。一切诸圣富伽罗所。彼诸痴人得波罗夷罪。犯彼大重。虚妄诳惑一切天人。如是痴人亦复无有大乘之分。况入大乘耶。况得胜处。况复当得成就阿耨多罗三藐三菩提耶。譬如有人欲行远路。至于旷野以饥渴所逼。忽值果林便入彼处。求食因缘。欲活命故。而彼之人。忽遇大树花果充足香美成就。遇已得味。得是味已更上毒树而服毒果。服已命终。善男子。如是如是愚痴人辈。今已获得人身值善知识。依倚知识入于大乘。彼等众生求利养故。好自称誉毁谤他人。得如是等犯大重罪。犯重罪已。为诸智人之所轻慢。当堕恶道。以是因缘。一切刹利婆罗门毗舍首陀不得亲近。若有诸人亲近彼者。如是人辈即违一切大智圣人。成大过罪。善男子。是名初行菩萨犯于第六大重罪耶

复次善男子。当来之世或有刹利诸国王等。为诸恶行婆罗门国师恶行大臣恶行医师等。实是愚痴。谓己大智有大才能。多受封禄。而彼人等。修诸施行造众福业。彼诸人辈。因少布施修行义故。憍慢放逸谓己有道。劝刹利王共我弟子诸沙门等。互相诤竞更相破坏或劝沙门共刹利王更相斗诤。彼恶人辈依刹利王。与比丘罪或税财物。彼诸比丘以刹利王诸大臣等逼迫因缘故。或输己物。或输僧物。或输招提僧物。以是诸物输税供官。与彼恶人。而彼恶人从诸比丘。取是诸物奉刹利王。彼等二人悉皆犯于大重罪耶。彼诸刹利及恶人等。共诸比丘互相斗诤。以是因缘。舍彼正法建立非法。取彼非法远离正法。舍依大乘所说经典毗尼戒律忧波提舍摩诃忧波提舍。远离慈悲般若波罗蜜善巧方便及余经典戒律之行。如来所说莫不弃舍。为欲扰乱诸比丘故。虚心横遘违佛戒律自造法制。造法制已扰乱比丘。令诸比丘皆悉远离奢摩他观正行正念。乃至使于禅定之者皆生忿恚扰乱之心常恒斗诤。以是因缘。令诸比丘生诸烦恼不得寂定

尔时彼等诸比丘辈。失正信法。失善比丘威仪法式。令堕诸见。以是因缘。令诸比丘皆悉懈怠多事世念不能持戒。破戒舍戒。不复能依沙门法则。口言我是沙门比丘。虽复唱言我是梵行。举动声气犹如贝声。不依正法而说于法。如是之等诸比丘辈及诸眷属。于刹利王所并诸臣民。以输物故。增倍供养。如是等辈诸恶比丘。于俗人前说诸有德阿兰若等空闲比丘不善之事。令彼刹利诸恶臣等并诸眷属。遂于精进持戒比丘生不善心诽谤之心。于精进比丘所有资财。皆悉夺取。夺已转施诵经比丘。彼等二人悉犯重罪。何以故。其禅定比丘真实福田。如是观已应令修业。不令彼等知彼僧务。而禅定比丘。当得三昧诸陀罗尼诸忍地等。当作法器。真是福田。真实福器。为世间眼。为彼世间作大光明显示善路。为建业地于烦恼田。教彼众生皆令得度。度已建立涅槃之道。善男子。是名初行菩萨有八种重罪而不用功舍离二处。彼初行菩萨犯大重罪因缘力故。所有往昔作诸善根皆悉忘失。忘失已后堕于恶道。违于本誓。被烦恼降失天人乐。虚妄迷惑失菩提心。善男子。为如是等诸善男子故。此虚空孕菩萨。生彼国中。为彼众生示现身相。或作比丘身威仪庠序。或作婆罗门身。显现威仪具足成就。乃至应以畜生而得化者。即现畜生威仪之相。略说乃至如首楞严三昧所说。当知是处亦复如是。巧知根机种种心器。随应现身。于彼众生随顺说法。教彼种种未曾有法。于一切智之所宣说微妙经典诸陀罗尼诸忍地等。普为显现。令彼诸恶犯重罪者初行菩萨教生惭愧。令其怖惧悔没之心忏彼重罪远离弃舍永不敢作

善男子。彼等众生以犯重罪恐怖因缘。闻是虚空孕菩萨名号。欲自见身者。畏堕恶道悔彼罪故。是诸众生应当顶礼虚空孕菩萨摩诃萨足。复应至心称其名号。时彼虚空孕菩萨摩诃萨。随其根业以菩萨身相即在现前。应以比丘身得度者。即现比丘身相。应以婆罗门身度者。即现婆罗门身相。应以童男童女身度者。即现童男童女身相。观彼初行菩萨如所犯重即现如是。如是方便教令忏悔。于甚深法无上乘中。显示善巧方便之行。若正地若非正地。若诸三昧。若诸陀罗尼。若诸忍中示现教行。乃至次第教令建立八正道处。以虚空孕菩萨力故。彼等众生得脱一切诸恶道苦。脱恶道已建立置于不退转地。后得建立。必得阿耨多罗三藐三菩提。善男子。如是如是。彼菩萨等。于六波罗蜜行中。大力精勤犹如电光。速得成就阿耨多罗三藐三菩提道

善男子。若虚空孕菩萨摩诃萨。于犯重罪菩萨前。不现身相者。其犯重罪初行菩萨。知自罪失故。欲请虚空孕菩萨。于后夜时以香汤洗浴。着净衣裳。胡跪合掌。向于东面烧沉水香。至心劝请东方黄白阿楼那天子。应作是言。阿楼那。阿楼那。汝有大慈悲有大功德。汝初出东方普照阎浮提。以慈悲故愿覆护我。为我速疾劝请虚空孕菩萨具大悲者。令彼菩萨特为我故。于睡眠中显示巧便。以巧方便故。教我忏悔所犯重罪。于大圣大乘中速得智眼。作是语已。彼重罪初行菩萨。还入室中寝卧睡息

尔时东方黄白阿楼那阎浮提显现之时。彼虚空孕菩萨。即随后来作菩萨身。在彼初行菩萨目前。于睡梦中现巧方便。教犯罪者忏悔恶业。于初行菩萨前。作如是等方便知见。作是方便已。其初行菩萨即时得一三昧。名不忘失菩提。于大乘中得决定住不可退动。速得成就六波罗蜜。不久当证阿耨多罗三藐三菩提

善男子。此虚空孕菩萨。最大勤劳办最胜事。成就胜妙如意摩尼微妙宝珠。贯在其顶奇特显现。善男子。此虚空孕菩萨。有如是等无量无边不可思议功德之聚

复次善男子。若有众生闻是虚空孕菩萨名者。或作形像以种种供具供是菩萨。尊重恭敬礼拜赞叹。以种种香花花鬘涂香。末香烧香。以种种幡盖宝幢。供养于彼。供养是已。复更供养尊重恭敬。将自身命付彼菩萨。彼等众生以是菩萨威神力故。火不能烧水不能溺杖不能伤。一切国土所不能害。于一切处人与非人。毕竟不能夺其精气。唯除命尽。设有重病不得久停。不为饥逼而取命终。不为县官横所触娆。不犯重罪。乃至命尽之时。眼不睹色。耳不闻声。鼻不闻香。舌不得味。身不得触。唯有微细气息身中暖气。及微细识犹在未离。当是时间。虚空孕菩萨为彼众生示现己身。若有众生在世之时信婆罗门者。是善男子于最后识欲离身时。作婆罗门身于前显现令生欢欣。若有众生先事魔王者。后命尽时。是虚空孕菩萨现魔王身。乃至在世事那罗延天者。若大自在天。若帝释天。若转轮圣王。若日月天。若提头赖吒天。若毗楼勒叉天。毗楼博叉天。若毗沙门天。乃至世间种种山神树神河神泉井之神。如是众生。随其所有归依之者。是虚空孕菩萨还作如是如是身相。临命终时在彼众前显现身相。随彼众生所有心愿。皆现与之。于前现身。现彼身已作如是言

  若人以智慧　　能见四谛者
  是人烦恼中　　即能度彼岸

彼诸众生。以意识知见此法已。得生善处。若有众生应以佛身化者。即现佛身。在众生前说如是言

  若于佛智底　　能度烦恼海
  即速证智慧　　诸苦得解脱

尔时彼诸众生。以念佛故。以闻佛音故。心生欢欣。命终已后。舍五浊世即生净土。值遇诸佛听受正法。乃至略说法僧亦尔。善男子。此虚空孕菩萨。得如是等不可思议功德之法。善男子。若复有人。于自心中欲取种种三昧得大自在。彼等众生于后夜时。应从卧起以香汤澡浴烧沉水香。随力随分以种种供具。供养虚空孕菩萨。顶礼足下。供养礼拜已。于一切众生边。当生慈心作如是言。虚空孕菩萨得大慈悲门。已得智慧。速念我。速念我。愿常与我正念三昧方便。即诵咒曰

多地他(一)嚧慕(二)啰那弃(三)博叉尼隶(四)萨慕达啰多隶(五)多那耶那耶(六)摩诃迦流尼迦(七)阿奴波阇婆三勿利帝(八)阿迦罗阇婆三勿利帝(九)拔折啰阎婆三勿利帝(十)胡卢舍三勿利帝(十一)阿那摩三勿利帝(十二)蒱多俱致三勿利帝(十三)莎呵(十四)

诵此咒已。彼菩萨威神力故。即得正念入诸三昧门。若复有人。欲诵种种经论。或诸佛所说。或声闻所说。彼人于后夜时。于东方处黄白现时。以香汤澡浴着净衣裳。东面胡跪烧沉水香。随力所办供养顶礼虚空孕菩萨。于一切众生所生慈悲心。作如是言。虚空孕菩萨。善男子。已得一切众生边不思议。慈悲之心。以大智慧念我念我。汝是菩萨最胜富伽罗。与我正念诸胜三昧方便巧妙深大智慧。即诵咒曰

多地他(一)尼罗涉鞞(二)钳蒱沙涉鞞(三)耶婆那涉鞞(四)博察萨迷(五)波吒罗阇驶(六)萨他那苏嚧鞞(七)户摩户摩(八)摩呵迦流尼迦(九)莎呵(十)

善男子。乃至若有众生。欲入大海采诸珍宝。或复心欲入于地下阿修罗宫。或复欲得服定年药。或复被禁牢狱系闭。或恩爱别离。或有怨憎交会而不能离。若在火难。若在水难。若刀杖难。若蛊毒难。若被咒咀言说。若被师子虎狼之难。若被蟒蛇蝮蝎之难。若被盗贼。或被幻惑之难。或被一切恐怖之难。若有众生。杻械枷锁禁系之难。若被县官所录。若被刑流将断命根。或有长病困笃着床疫病所逼恐怖畏死。若乏衣食卧具汤药资财之物。彼等众生。于后夜间黄白出时。香汤澡浴着净衣裳。顶礼虚空孕菩萨。胡跪合掌以面向东。随力随分所办供具供彼菩萨。为诸众生发慈悲心。口唱是言。虚空孕具大慈悲。为诸众生常作利益。念我念我。以慈悲心愿观我心。愿解脱我。如前所说之难。应说偈言

  我之无福相　　愿与我功德
  我今贫贱苦　　今应与我愿
  虚空孕菩萨　　是我归依处
  如于此世中　　未来与我乐

尔时虚空孕菩萨摩诃萨。闻彼众生音声之辞。或复现本菩萨之身。乃至或现童男童女身。在于彼前慰喻彼言。护诸怖难。所有恐怖皆悉除灭。乃至略说。有诸贫穷孤露众生。或无资财活命之者。观彼心意令满彼愿乃至所须一切施与。善男子。若有王子欲得灌顶之位。欲得称职。彼诸王子。应当供养彼大菩萨称其名号。随力随分供养彼虚空孕菩萨。乃至如是等欲得婆罗门位。欲得大富长者位。欲得大居士位。欲学诸伎术。欲证内法。欲得咒术。欲学工巧。欲闻一颂。欲望解脱。彼诸众生闻是虚空孕名字。于后夜间黄白现时。以香汤洗浴着净衣裳以面向东胡跪合掌。顶礼虚空孕菩萨。归依彼已。合掌劝请。作如是言。虚空孕具大慈悲。我既薄福与我福相。满我心愿。应当说于如是偈言

  我心所求者　　勿令乏少耳
  愿发怜愍心　　慈悲称我愿

尔时虚空孕菩萨。以净天耳过于人耳。闻彼众生此音声已。为彼众生或现自身在众生前。观察众生心心所行。随堪可与。如是如是。为彼众生示现方便。善男子。是虚空孕菩萨。得如是方便功能具足入大智海。此虚空孕菩萨摩诃萨。有如是等不思议事。善男子。若复有人。于四大海水滴滴数之能知多少。此虚空孕菩萨摩诃萨善巧胜智方便教化诸众生等现作方便不可数知。善男子。假使有人十方虚空可现不可现处可知边际多少。此虚空孕菩萨摩诃萨善巧方便教化众生不可得知边际之数。为诸众生作巧方便。变化自身而为显现。或作佛身而化众生。或作婆罗门身教化众生。乃至随所应现种种身相得受化者。即现彼身而不分别。应以畜生身而受化者。即现畜生。应以地狱身而受化者。即现地狱身。有诸众生在于现前化身显现。有诸众生应以睡梦现身益者。于睡梦中即为现身。有诸众生临至命终。唯有细识欲灭众罪令断恶道欲将善道为彼众生化种种身。是诸众生生存之日归依何天。应见彼天即得安乐者。乃至应将善处。即现彼天令其欢欣。善男子。是故此虚空孕菩萨。无人能知教化身数边际之量

善男子。是虚空孕菩萨。得如是等不可思议方便胜智功能具足殊妙之法。此虚空孕菩萨摩诃萨。已入诸佛功德之海。善男子。是故虚空孕菩萨摩诃萨。头戴显现摩尼应宝。尔时一切大众在会中者。从佛所闻赞叹虚空孕菩萨已。于虚空孕菩萨即生希有殊特之心。生极尊重恭敬之心。皆悉合掌瞻仰而住持种种香花末香涂香幡盖宝幢杂色衣服杂宝璎珞。歌诵赞叹种种音乐。供养虚空孕菩萨。时虚空孕菩萨摩诃萨。持前供具供奉世尊。奉世尊已。在世尊前。长跪合掌。而白佛言。世尊。云何于五浊之世被大黑闇无明所覆诸众生内。能作佛事

佛言。善男子。譬如虚空不缚不解无见无迷。而虚空体本性清净。而虚空内。因风动现尘雾烟云。故名虚空为不净耳。因水雨故离彼尘等诸障碍法。即得显现日月星宿。便知刻漏罗婆时节昼夜长短半月满月年岁度数。如是如是。善男子。如来一切诸法真如。随于虚空心之本相。本性清净。但诸众生以客尘烦恼心意成浊。为彼等故。如来以慈悲等法门。雨慈悲雨。被烦恼所浊诸众生辈。即得清净无有诸垢。而彼众生心得清净。即见佛日出现于世。得智光明润已。于不思议诸佛功德之内。自得晓了。建立彼于胜四念处及圣道中。乃至建立十八不共法大慈大悲真实法中。是故有诸阿罗汉辟支佛等诸菩萨辈出现于世

善男子。于汝意云何。虚空之性能住于眼不。答言。不也世尊。佛言。眼能住于识不。答言。不也世尊。佛言。眼住触不。答言。不也世尊。佛言。眼内因触所生三种之受。于是之中虚空住不。答言。不也世尊。佛言。略说乃至耳鼻舌身亦复应当作如是观

善男子。于汝意云何。意住空界不。答言。不也世尊。乃至意中虚空住不。因是法中诸佛如来应正遍知出现于世不。答言。不也世尊。佛言。善男子。诸众生等依住虚空不。答言。不也世尊。佛言。善男子。于意云何。虚空之性依众生住不。佛作是语已。虚空孕菩萨摩诃萨白佛言。世尊。各各不相倚住。于自境界各不相侵。世尊。一切诸法无有境界。空故无染。一如实际。一如如如。应作是知。世尊。譬如虚空。不可破坏。不可分别。不作分别。不动无碍无牙无子无果。无名无字。无思无念。如是如是。世尊。一切法相如是知已。菩萨摩诃萨。于一切法中得无生忍。尔时世尊而说咒曰

多地他(一)缚婆何啰阇(二)末奴叉夜(三)只那阇耶(四)阇那腻莫(五)牟尼呵啰(六)阿那也(七)破罗漂颇(八)伽罗婆腻莫(九)阿儞捺也(十)阿婆舍舍婆(十一)舍那舍莫(十二)那舍哆多(十三)迦罗莫舍莫(十四)吉唎摩妒毗沙莫(十五)支多那也(十六)鸡梨奢都(十七)三舒沙腻(十八)莎呵(十九)

佛言。善哉善哉。善男子。汝能于如是眼降伏胜师子安庠步水频申吼陀罗尼。为诸众生命终之时。最后出息命欲过时。能灭烦恼障业障法障。灭是障已令生清净刹中。善男子汝能行无量无边诸佛世界为诸众生起慈悲心。至于村落城邑府省县官宫殿及诸国土至是处已。现种种形种种威仪。说大乘经典教化众生。于刹利恶行乃至沙门恶行所。断于种种不善之法。安置一切诸善法中

尔时世尊说是法时。于大众中无量无边诸天世人得种种三昧陀罗尼诸忍。或复有得十地法中真实智慧。十千人等于无生法中得无生忍。若有众生执着虚空是有为者。得此灯光明已。有为施根皆悉断灭。无为施行速现成就。佛说经已。于大众中。诸比丘等及天龙夜叉乾闼婆阿修罗迦娄罗紧陀罗摩睺罗伽。梵释护世四大天王。闻佛所说此妙经典。一切皆悉欢欣奉行

虚空孕菩萨经卷下


自在王菩萨经

    No. 420 [No. 421]

自在王菩萨经卷上

        姚秦三藏鸠摩罗什译

如是我闻。一时佛在舍卫城只陀树林给孤独园。与大比丘众二万人俱。菩萨摩诃萨皆是一生补处。其名曰弥勒菩萨。得大势菩萨。师子意菩萨。师子相菩萨。大相菩萨如是上首一万人俱。尔时世尊。大众围绕恭敬为发大乘意众生演说经典。尔时众中有菩萨。名自在王。从坐而起。偏袒右肩右膝着地。合掌白佛言。世尊。欲有所问。若蒙听许乃敢发言。佛告自在王。诸有所问佛无不听。随意所问。当为汝说令汝得解。自在王菩萨。得蒙听许喜悦无量。白佛言。世尊。云何菩萨摩诃萨。于大乘法中得自在行。而能为人演说此法。以自在力。摧伏诸魔增上慢者。及诸外道有所见得诸贪著者。令住大乘具足大愿成就戒行。得阿耨多罗三藐三菩提。佛告自在王菩萨。善哉善哉。汝能问佛是义当为汝说。一心谛听善思念之。诸菩萨云何能令众生得住大乘。具足大愿成就戒行。得阿耨多罗三藐三菩提。自在王菩萨受教而听。佛告自在王。菩萨摩诃萨有四自在法。以是法故。能自在行令诸众生得住大乘。何等四。一者戒自在二者神通自在。三者智自在。四者慧自在。戒自在者。菩萨摩诃萨行具足戒。不毁不缺不穿不浊。不有所得不悔不诃不有热恼。智所称赞随顺道戒。教众生戒。护法戒。欢悦戒。不依生处戒。住定戒。随慧戒。信解深法戒。不退神通戒。空无相无作戒。寂灭戒。摄佛法戒。说佛法戒。不舍一切众生戒。慈护戒。大悲根本戒。信净戒。不转仪式戒。头陀细行戒。随顺福田戒。毕竟净戒。不断佛种戒。护法种戒。示圣众戒。安住菩提心戒。助六波罗蜜戒。修四念处戒。修四正勤四如意足五根五力七菩提分八圣道分戒。能生一切助菩提法戒。自在王。若菩萨摩诃萨能持如是戒。戒则具足所愿皆得。若菩萨持如是净戒者。三千大千世界劫尽烧时。愿欲灭火。言火当灭火即为灭。欲令三千大千世界皆变为水。欲令三千大千世界普雨众华。欲令三千大千世界皆为珍宝。欲令如恒河沙世界诸须弥山合为一山。欲令如恒河沙世界大海合为一海。即皆如意无不成者。持戒力故所愿皆得。所为神力无不称意。菩萨安立如是戒中。得如是自在力。持净戒故深愿毕成。得阿耨多罗三藐三菩提。自在王。乃往古世过无量阿僧祇劫。有佛名净明光王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时有菩萨比丘。名金刚齐。得持戒力。行净戒故常在闲处林中经行。欲具佛法故修习正行。修正行已作如是念。不得一切法是则名戒。不贪一切法是则名戒。灭一切结是则名戒。观身如镜中像是则名戒。于诸言辞如呼声响是则名戒。观心相如幻是则名戒。善不善法无二无别是则名戒。为贪欲故观身不净是则名戒。为嗔恚故生于慈心是则名戒。以智慧破痴网是则名戒。不得贪恚本是则名戒。于法无观无想分别是则名戒。无我见无众生见无寿者见无人见无常见无灭见是则名戒。于一切法不作不起是则名戒。心无所畏是则名戒。不依三界是则名戒。信无生法是则名戒。信解无生法忍是则名戒。不贪利养是则名戒。于诸法空心不惊畏。坏离诸相蠲除诸愿是则名戒。心无所念是则名戒。不自高不轻彼是则名戒。不着诸入是则名戒。不起五欲是则名戒。了知诸阴同于法阴是则名戒。了知诸性同于法性是则名戒。乐无诤讼是则名戒。于善法中不舍勤行是则名戒。知一切法必寂灭相而以身证是则名戒。自在王。金刚齐比丘。如是安住于戒。修习圣法正念无倒。时有魔子名曰障碍。见金刚齐比丘如是持戒。修习圣法正念无倒。与八万四千诸魔及其眷属。贯钾持兵来到其所。自隐其身观是比丘心在何行。千岁随逐乃至不见一念心散可得恼坏。于是魔子及与眷属现其魔身。执持刀鉾在比丘前。欲以相怖。比丘见魔大众兵仗欲以相怖。作是誓言。若我戒净习于圣法正行不倒。以是缘故。魔众兵仗皆当变成青黄赤白杂色莲华。须曼那华。婆梨师华。奇妙名华以为璎珞。是时魔子与其眷属。形色仪法皆如我身。自在王。金刚齐比丘说是语时。魔众兵仗即皆变成妙色之华。殊妙香洁以为璎珞。一切诸魔皆自见身。如此比丘剃除须发着染袈裟。魔子见比丘现大神力。怪未曾有发希有心。与其眷属俱礼其足。作如是言。汝得何法乃有是力。比丘言。此力不从有所得生。亦不依于身口意及一切法生。是力不以住相故生。以无住处故魔言比丘。我于千岁求汝心行不能知处。比丘言。汝若以恒河沙劫求之。亦不能得。何以故。是心不在内不在外不在中。汝宁能得幻化人心所行处不。答言。幻化之人尚无有心。况心行处。比丘言。如来说一切法空皆如幻化。此中亦无心无思魔言。若不得心不得思。云何有来去有言说。比丘言。幻人去来言说。我去来言说亦如是。魔言。汝以是进行住于持戒。修习圣法为何所趣比丘言。趣无所趣。魔言。云何趣无所趣。比丘言。是中无先去。无今去。无当去。无所趣者。即是无作脱门。汝问。以是进行安于戒修习圣法。何所趣者。我不趣色生。不趣色灭。不趣色住。不趣受想行识灭。不趣受想行识住。于一切法。亦不趣生。亦不趣灭。亦不趣住。是名正趣。魔子。正趣者。名不取色不取受想行识。无所见法是我所趣。我所趣者。不取色不取受想行识。我所趣者是诸圣所趣。魔言比丘。于是法中云何有趣。比丘言。诸凡夫法及诸佛法。同是一法无二无别。学法阿罗汉法。辟支佛法佛法。同是一切法无二无别。若过去法。若未来法。若现在法。同是一法无二无别。无出无生以等相故。不舍如是诸法等相者。欲以是法示众生故而为说法。如是趣者名为正趣。魔子。夫正趣者。不趣欲界。不趣色界。不趣无色界。住等法者。于法实相不动不退。是名正趣。如如趣。一切法趣亦如是。如法性趣。一切法趣亦如是。如实际趣。一切法趣亦如是求。如是趣者。亦不念不着诸趣。是名正趣。魔子语金刚齐比丘。汝以是正行为得何法。答言。我以是正行得离诸法分别。以是无念无分别故具足等相。汝问得何法者。是正行中无有得相。无增上慢。以是正行于法无所得。正行者即是无行义。魔子问金刚齐比丘。汝以此戒当得何法。答言。我以此戒当得阿耨多罗三藐三菩提。乃至小法不可得故。魔子言。云何得菩提。比丘言。色等则是得菩提。受想行识等则是得菩提。一切法等则是得菩提。魔子言。如是菩提于何处求。比丘言。当于我见性中求。魔子言。云何而求。比丘言。求时不起菩提见。魔言。比丘汝师是谁。谁所教诲辩乃如是。比丘言。不坏我见性而得菩提是则我师。不在垢不在净是则我师。若识不在有为不在无为。是则我师。若不从他闻于诸法。不住不舍能度诸流。是则我师。若遍知一切法而不至一切法。是则我师。若一切所说音声言辞。于不可说诸法相中。而不动转。是则我师。若一切法不生不起不出。而能转圣法轮是则我师。不住此岸不在彼岸不在中流。是则我师。若一切法不生故生。是则我师。若一切法不灭故灭。是则我师。我随如是师教故辩如是。魔子言。如来以何而转法轮。答言。如来于色不转不还。色如。色法。色空。色无相。色无作。色灭。色离。色无生。色相。色性。亦不转不还。受想行识不转不还。识如。识法。识空。识无相。识无作。识灭。识离。识无生。识相。识性。亦不转不还。如来以是一切法不转故。转于法轮。如是法轮若转若不转。于无量法性终不出过若能解此转法轮者。是人则能转于法轮。尔时魔子及其眷属。皆为金刚齐比丘。作弟子。发是言。我从今日归依于师。比丘言。汝莫归依我。当归依净明光王佛。我所说者是佛所教。魔子言。可共诣佛。时金刚齐比丘。与魔子及八万四千魔众。俱诣净明光王佛所。头面礼佛足。合掌恭敬在一面立。净明光王佛。因其净戒及圣法行。为说如是法。皆得不退于阿耨多罗三藐三菩提。自在王。彼时金刚齐比丘岂异人乎。汝身是也。障碍魔子者。持地菩萨是。自在王。是名菩萨摩诃萨戒自在。菩萨得是戒自在者。能示众生不思议愿力。教化无量众生于阿耨多罗三藐三菩提。亦能自降魔怨。疾成阿耨多罗三藐三菩提

佛告自在王。何谓菩萨摩诃萨神通自在。谓天眼。天耳。他心智。宿命智。如意足。自在王。何谓菩萨天眼自在也。若菩萨眼根。不为墙壁山林须弥铁围。世界中间之所障碍。是名天眼自在。菩萨以是无碍眼根。见十方无量阿僧祇佛土。为一佛土。何以故。空相无别异故。而诸佛土彼此虽别而不合不异。又见诸佛大众围绕皆为一佛。以法性不坏相故。以见一佛净故见一切佛净。以一切佛净故见自身净。自身净故见一切法净。于自身净诸净之中不生二相。又见诸佛弟子。不异见佛净。菩萨以见弟子正见见佛。以见佛正见见弟子。又菩萨于十方无量阿僧祇世界。所有众生。若地狱若畜生若饿鬼。若人若天。除无色界。即以天眼。悉皆能见生死所趣善恶之处。又知众生行业及报。菩萨虽见众生不取众生相。何以故。信无我际故。虽见行业及报。而知一切法无业无报。菩萨以是天眼。见一切色皆无色相。信一切法无所有故。知诸形色皆是虚妄。本来不生故。是名菩萨天眼。菩萨得是天眼智力故。随所能见。或见有数色。或见无数色。或无所不见。菩萨虽在百千万种众生之中。而能入于禅定背舍三昧。乃至不见有一众生。何以故。菩萨达诸法无我如故。是菩萨于色界诸天净妙形前。为现其身令诸天子见。而是菩萨亦见诸天身。菩萨又能令诸天见其身。而诸天不自见身。或令诸天自见其身。而不见菩萨身。自在王。是名菩萨天眼自在

自在王。何谓菩萨摩诃萨天耳自在。若菩萨得是天耳。于十方无量阿僧祇世界。所有诸声。天声夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人声。悉皆得闻。闻是声时于诸声中无所分别信一切声是不可说相。又闻是声。不生我相众生相及音声相达一切声本来不可说相。信知是声无有住时。菩萨耳性耳识性无有碍故。闻是声时解其实义者。一切声不可说是灭相故。以是实义。而依于义不依于声。一切法无生相故。又闻十方无量阿僧祇现在诸佛之所说法。而无有碍。如所闻能持。持已不忘。何以故。菩萨乃至无有一句不知而灭。菩萨有所问法。若有漏若无漏。若有为若无为。若世法若出世法。若善若不善。若有罪若无罪。若声闻乘。若辟支佛乘。若佛乘。能令是法入一性味。谓离自性虽有所问不着六尘。虽复闻法不住诸相。菩萨贵法。依法不依非法。何等为法。法名离染。法名无相。法名无为。法名无归处。法名无生无起无得。法名无比。于是法中以相分别。取舍戏论是名非法。自在王。菩萨依于义不依语。不离语入义心听法。云何名入义心。不堕空义见。无相义见。无作义见。是名入义心。菩萨以是入义心听法依于义。是义不可得。不可得亦不可得。又自在王。菩萨若能如是听诸佛法。依了义经不依不了义经。了义经者。一切诸经皆是了义。以依义故。一切法不可说故。菩萨如是名为依了义经。若人于一切经。不能如是依义。是名不了义。何故名不了。是人不了义故。行尘垢道常为所牵。为谁所牵。为声所牵。了义者不随于声。何以故。其义不可说故。菩萨知一切法离诸边非了相。自在王。依如是义趣法者。一切诸经皆是了义。不如是依者。一切诸经皆是不了义。又自在王。菩萨于诸佛所听受法时。依于智不依识。何以故。菩萨知识虚妄如幻离相。无性无色无形无对不可识。如是知识相即名为智不名为识。菩萨依智故不随识。知他识亦不是识。是故不着识如。故说智如。自在王。依智菩萨不住于识。能知他说而为说法。又自在王。菩萨说法时。虽说众生名。而依于法不依众生。何以故。若于我法中实有众生者。终无净无解。是故自在王。一切法毕竟无我无众生。如来以世法故说有众生。诸法实无众生。是故菩萨依于法不依众生。法者即是法性义。法性者是不生性义。不生者是毕竟不起不作义。义者是不可说义。何以故。以语说法法不在语中。是故以语示义。有所示说皆非语非说。有所分别有所说者即非佛法。无分别无所说即是佛法。是故言无说是佛法。若人欲入佛法应如是入。而以语说众生。若说法不应生见。若有二者不名佛语。无二无分别即是佛语。若有言声即非佛法。若有论说亦非佛法。若无言声亦无论说是名佛法是故自在王。若菩萨入佛法中。则得如是天耳。以一切声。随诸法实相行。能得阿耨多罗三藐三菩提。自在王。是名菩萨天耳自在

自在王。何谓菩萨摩诃萨他心智自在。若菩萨得他心智自在者。以己心知他心。所至之处为众说法先观众心。知是众生有何深心。何行何因何相。随而为说。菩萨自心净故。入一切众生心净。自在王。譬如明镜照诸形色。相貌长短大小粗细随其本形皆有像现。不增不减镜无分别。以明净故能示诸像。菩萨亦如是。以自心净法性照明故。众生所起心心数法。皆能得知而无所碍。若是众中有多欲者。能知其心。亦见离欲相。何以故。心相非染故。若众中有多恚多痴。有能知其心。亦见离恚离痴相。何以故。心相非恚非痴故。若众中有乐声闻乘者。知其行道法性不作小。若众中有乐辟支佛道者。知其行道法性不作中。若众中有乐大乘者。知其行道法性不作大。菩萨随知众生心性。而为说法。不取心相。虽知诸乘而为说法。不坏法性。不坏法性故不坏一切性。而知众生所行。菩萨自以心观他心。自心他心无违无顺。亦知众生心相续生。又知心性即是法性。自在王。是名菩萨他心智自在。以是自在故。于天上人中无不知识。自在王何谓菩萨摩诃萨宿命智自在。若菩萨得宿命智自在。以念力强故。定根利故。忆本所生自身他身恒沙劫事。而为他说。我于彼处如是种类姓名寿命。受如是苦乐。又知众生宿世所种善根。有因力者。有缘力者。是人有声闻因。是人有辟支佛因。是人有大乘因。知其先世所因。如是随其所应而为说法。菩萨得是宿命智故。自知本生于诸佛所种诸善根。若先世有善根。而不回向阿耨多罗三藐三菩提者。今当以是善根回向菩萨。虽知宿命亦知先世法无有来者。不见法从先世至后世。亦不见今世至先世。知一切法无所从来亦无所去。又念先际不生先见。亦不生后际中见边见。知一切法无边无中。菩萨虽念众生宿命。亦知先际色离相。知先际受想行识离相。先际五阴离相。即是后际五阴离相。后际离相。即是现在离相。菩萨知先际一切法性空。知现在一切法性空。知后际一切法性空自在王。菩萨如是知宿命时善根增长。先世罪业因缘灭尽。何以故。菩萨达一切法相无新无故。成如是智已。信解一切有为法皆空如梦。自在王。譬如梦中见生死苦乐。菩萨信解一切有为法亦如是。如是信解者。往来生死心不疲倦。于众生中而生悲心。于一切法生假作相。菩萨作是念。如我若干千万亿劫生死往来。皆虚妄无所有。一切众生亦如是。生死往来虚妄不实。实名不起四大。四大是虚妄法。自在王。菩萨见宿命时。诸有为法皆是虚妄。何以故。菩萨念先世转轮王乐。皆悉无常变异之相。念帝释乐。亦皆无常变异之相。亦见诸佛严净世界。声闻众严净。菩萨众严净。所用诸物严净。亦念诸佛色身具足而转法轮。皆悉无常变异之相。如是念时于有为法无所贪惜。何以故。菩萨作是念。如是净土诸佛色身无常灭尽况我所著。即入无我无我所法中。依于无常变异之相。作如是念。诸有为法皆悉无常。众生于此而生常想。即于众生生大悲心。于一切法生放舍想。自在王。是为菩萨宿命智自在。菩萨得是自在。信一切法无常。而为成众生故受身。为不受故受。为不取故取。但为教化一切众生故。自在王。何谓菩萨摩诃萨如意足自在。若菩萨心自在故。从圣相生如意足欲力进力断行信解力。菩萨得是信解如意足。非作非起。若欲普至恒沙世界。一念之顷皆能得至。彼诸众生皆见其来。而自于先本处不动彼见说法。而于此处说法不绝自在王。是名菩萨如意足自在。菩萨以是如意足自在力。若有众生应以如意足度者。以如意足度之。若诸天人着常相者。示其劫烧。是诸众生见三千大千世界普皆烧尽。而是世界无所损减。若有众生慢心自大。则作执金刚神。执火焰金刚杵而以示之。令生恐畏除其慢心自归礼敬。若有众生乐转轮王形者。以转轮王身而为说法。若有众生乐释提桓因形者。以释提桓因身而为说法。若有众生乐梵天王形者。以梵天王身而为说法。若有众生乐魔王形者。以魔王身而为说法。若有众生乐见佛身者。则现佛身而为说法。菩萨或为众生住于空中结跏趺坐。身放光明而为说法。或有众生乐严净世界者。则为庄严三千大千世界。悬缯幡盖竖诸幢幡。以宝罗网遍覆其上。烧诸名香作众伎乐。然后说法。或为众生现三千大千世界。为一海水。青红赤白种种莲华遍覆其上。于其水中现师子坐。身处其上而为说法。或为众生自现其身。坐须弥山顶而为说法声至梵天。或为众生不现其身。但以音声而为说法。或为众生现乾闼婆身。以众乐音而为说法。或为众生现龙王身。起云雷震放大电光。又霔大雨而为说法。或有众生饥渴逼切。则与天食身得充满。具足悦乐而为说法。若有地狱众生苦恼逼迫。而以神力灭地狱火。以天精气令其毛孔皆得安乐而为说法。若有盲者如意神力以天眼与。令得开明而为说法。若有聋者如意神力与其耳根。令得闻声而为说法。若有种种病。自以神力令其除愈而为说法。若有犯罪送至死处。如意神力化人代之。令得免罪心得安乐而为说法。若有众生。刖足斩手刓截耳鼻形残丑陋。常自愧耻而心退没。如意神力皆令完具而为说法。若有众生。在于胎中藏血屎尿不净之处。如意神力化作宝台楼阁。令处其中。亦成意识而为说法。若其始生诸根未成。如意神力令其具足。堪任听受而为说法。自在王。是名菩萨成如意足。以如是等种种不思议神力。而为说法。菩萨如意神力故。为度奉事日月众生。以三千大千世界置其右掌远掷他方无量世界。令诸人众皆见其去。而此世界本处不动。又以恒河沙世界。入一毛孔举至梵天。掷置他方无量世界。令诸众生无去来想。若恒河沙无量世界劫尽火烧。能一吹令灭。或以两手障蔽日月。身出光明照诸世界而为说法。自在王。是菩萨或坐诸佛前。若欲供养佛。以一掬华如须弥山散佛身上。华至半身。又三千大千世界一切草木皆成为炬。遍满世界火落如雨。自在王。是菩萨随诸众生所贵形色。皆悉为现。若释若梵若声闻形。若辟支佛形。是名菩萨神通自在。谓天眼见无碍故。得天耳闻无障故。得他心智达一切心心心法故。证宿命智忆过去无量阿僧祇劫故。得如意足于一切形色随意示现故。自在王。神通自在者。能以一切佛事示诸众生。亦能了达分别众生诸根利钝。能以声闻乘度众生。辟支佛乘度众生。大乘度众生故。于生死中众所知识。成众生故众所知识。于善法中出家行道故众所知识。以方便力故众所知识。檀波罗蜜回向故众所知识。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜回向故众所知识。降伏诸魔令种善根故。名为神通自在。又自在王。菩萨得是神通自在故。色身之力名闻称赞家姓财物眷属人民。普皆殊胜众所知识。是故名为神通自在。又自在王。菩萨得是神通自在故众所知识。谓诸天龙夜叉乾闼婆阿修罗紧那罗迦楼罗摩睺罗伽人非人。帝释梵王诸护世者。诸佛正遍知者。皆所知识。是故说名多识。自在王。菩萨以是神通不退本誓。而能示现一切众事

自在王。何谓菩萨摩诃萨智自在。谓阴智。性智。入智。因缘智。谛智。自在王。何谓阴智。色前际空。后际空。中亦空。受想行识前际空。后际空。中亦空。五阴毕竟空。是名阴智。自在王。何谓性智。地性是法性。水性是法性。火性是法性。风性是法性。何以故。四性入于法性皆为一性。谓之空性。空性法性同一无性。此中无地性无水性。无火性无风性。何以故。不坏性是法性。无二性是法性。无生性是法性。无垢性是法性。无净性是法性。如法性寿性众生性。生死性涅槃性亦如是。如涅槃性欲性色性无色性有为性无为性亦如是。如是性智不随他得。是名性智。自在王。何谓入智。眼从本来。不生不起无有作者。耳鼻舌身意从本已来。不生不起无有作者。自在王。眼无有主。是中无有见者。耳无有主。是中无有听者。鼻无有主。是中无有嗅者。舌无有主。是中无有尝者。身无有主。是中无有觉者。意无有主。是中无有识者。自在王。眼性不能见色。耳性不能听声。鼻性不能嗅香。舌性不能知味。身性不能觉触。意性不能识法。何以故。眼无所作与草木土石无异。耳鼻舌身意亦无所作。与草木土石无异。自在王。眼不染不离。耳鼻舌身意不染不离。何以故。眼从本来是离相。耳鼻舌身意从本已来是离相。自在王。若能如是知一切入则能离欲。是名入智。自在王。菩萨如是知诸阴性入不生不起。以毕竟灭。灭已而受生退没。虽受阴性入。而不舍阴性入智。是名智自在。谓知阴性入。知阴性入相。而能不舍。现于三界而不住诸结。示有生灭而不生不灭。是名智自在。自在王。何谓缘智。无明缘行。无明不作是念我起行。行缘识。行不作是念我起识。识缘名色。识不作是念我起名色。名色缘六入。名色不作是念我起六入。六入缘触。六入不作是念我起触。触缘受。触不作是念我起受。受缘爱。受不作是念我起爱爱缘取。爱不作是念我起取。取缘有。取不作是念我起有。有缘生。有不作是念我起生。生缘老死。生不作是念我起老死。老死缘忧悲苦恼。老死不作是念。我起忧悲苦恼。自在王。若菩萨能如是观十二缘者。不堕诸见若断见若常见。菩萨作是念。法属众缘。推求众缘则不可得。即于十二缘而得真智。何谓真智。知十二缘生法同于无生。无生同空无相无作。空无相无作同众缘生法。如来所用等得一切法。是法同十二缘生法。十二缘生法无有法生。是故说应见十二缘生无生。十二缘无生智即是十二缘生智。自在王明无明无二。知如是者则知缘。生法行非行无二。知如是者则知缘生法。识非识无二。知如是者则知缘生法。名色非名色无二。知如是者则知缘生法。六入非六入无二知如是者则知缘生法。触非触无二知如是者则知缘生法。受非受无二。知如是者则知缘生法。爱非爱无二。知如是者则知缘生法。取非取无二。知如是者则知缘生法。有非有无二。知如是者则知缘生法。生非生无二。知如是者则知缘生法。老死非老死无二。知如是者则知缘生法。从缘生者无有是处。从缘生则是无我。则是空也。从缘生者则是无来无去。从缘生者则非真实。从缘生者则无一相。从缘生者则无所行。如是知者是名缘生智。见缘法者不见无明。不见行。不见识。不见名色。不见六入。不见触。不见受。不见爱。不见取。不见有。不见生。不见老死。若不见如是法者。是名见缘生法。若见缘生法是名见法。云何见法见离染法。云何离染行者。于一切法离染见故名为离染。是故说见离染法。云何为见不为增不为减。如是见如不动不着。如是见如不坏法性。亦不见合。如与法性不坏不合。如是见者不毁实际。如是见者亦不见。非以肉眼见。非以天眼见。非以慧眼见。何以故。肉眼无无作故不见。天眼作起相故不见无为法。慧眼无分别相。无分别故不见。自在王。若菩萨能如是见一切法。则能见佛。不以色故见。不以受想行识故见。不以诸相故见。不以法故见。不以戒故见。不以定慧解脱知见故见。不以过去故见。不以未来现在故见。如是见者是名见佛

自在王菩萨白佛言。世尊颇有所缘。菩萨见如是诸法。而能见佛耶。佛言有。何以故。色是尽相。性无生故。能见色如是。是名见如来。受想行色是尽相。性无生故。能见识如是。是名见如来。戒是无为无作无起相。能见戒如是。是名见如来。定慧解脱知见等亦如是。是名见如来。自在王。我于过去燃灯佛时。得见佛净。我于尔时。见缘生法故见法。以见法故见如来。自在王言。于燃灯佛已前。云何见诸佛。佛言。以色身相见故见。不以不二法身见故见。今为汝说。我从初发心未曾见佛何以故。不以色相见故。名为见佛。是故自在王。若菩萨欲得见佛应如我见燃灯佛。以诸法一相故。云何一相。如我身燃灯佛身亦如是。如燃灯佛身。亦如是。一身故以不二不别入一法相。是名见缘生法。以见缘生法名为见法。以见法故名为见佛。若菩萨能于一切念中。证灭而不实灭。生死不可得。而以方便智故示是名菩萨智自在

自在王菩萨经卷上自在王菩萨经卷下

        姚秦三藏鸠摩罗什译

自在王。何谓菩萨摩诃萨谛智。求声闻者。以谛法证声闻解脱。菩萨得此谛而不证解脱。是名自在。求辟支佛者。以谛法证辟支佛解脱。菩萨得此谛而不证解脱。是名自在。谛智者。苦谛虚妄知见。云何知见苦虚妄不实得时故为苦。以倒故有。若菩萨知苦无生无起。是名知见苦谛。云何断集诸法随集断。云何为集集平等故断亦如是。无所从来故集无所去故断。是名诸法性。是中无有实法。生已当断。随所爱使故有集。若断爱使是名断集。云何苦灭谛。毕竟灭苦集而无法可坏故。是名苦灭。一切诸缘相灭故一切法如是灭相。于此中不生不灭名为灭谛。云何道谛。随以何道求一切法不得。若善若不善。若有漏若无漏。若有为若无为。是名道谛。是道平等不分别一切法故。是道寂灭离诸结热故。是道安乐离一切忧恼故。是道无漏一切漏尽故。是道一切有所得者所不能行。正行禅定者易修行故。是道诸佛所不舍。是道无相断一切相故以如是道不堕于二。是名道谛。若菩萨以如是门知四谛者。是名谛智。若菩萨先以四谛。为求声闻辟支佛者说。于此乘中亦无所贪。是名谛智自在。又自在王。菩萨知声闻乘不于中住。知辟支佛乘不于中住。知佛乘不于中住。是名谛智自在。又自在王。若以一心知一切众生心。以一心性知一切心性。而于心智不作二行。是名智自在。又有智自在。知见过去世无碍。心不至过去世。知见未来世无碍。心不至未来世。知见现在世无碍。心不至现在世。不于过去未来现在世而生戏论。又有智自在。知一切有为法尽灭。而不尽诸善根。知法无生而以摄法摄集众生。是名智自在。又不从他知一切法毕竟灭相。以是智力而自不灭教化众生。是名智自在。自在王。菩萨于此。若欲得智自在力而自在者。应随智行不随意行。云何意行。所有意业皆是意行。所有识业皆是意行所有心业皆是意行。所有着心起诸善根皆是意行。堕见行施。堕相持戒。依我行忍皆是意行。我是菩萨则是意行。我发菩提亦是意行。我不断佛种。不断法种。不断僧种。亦是意行。我为利众生故发心亦是意行。我当度未度者。解未解者。安未安者。灭未灭者皆是意行。我是施主。我是持戒。我是行忍。我是行进。我是行定。我是行智皆是意行。我是行慈者。行悲者。行喜者。行舍者皆是意行。我是少欲知足离行者。不杂行者。头陀行者。阿兰若者。细行者。如是分别皆是意行。我是空行者。我是无相行者。我是无作行者。如是分别皆是意行。我是谛语者。实语者。如说行者皆是意行。我是过诸魔业离四魔者。我断一切见得忍。如是分别皆是意行。我当得阿耨多罗三藐三菩提转法轮度众生。当于无余涅槃而般涅槃。如是分别皆是意行。自在王。云何菩萨智业。随无心意识行处。是名智业。菩萨常作智业不起意业。云何菩萨智业。菩萨智业有二种。何等二。一者成众生。二者受持正法。云何成众生。菩萨随以所知能成众生。云何受持正法。若不受一切法。是名受持正法。若受持色。非受持正法。受持受想行识。非受持正法。若受诸入诸性。非受持正法。若受善不善法。非受持正法。若受罪不罪。有漏无漏。有为无为。世法出世法。非受持正法。若受施相。非受持正法。若受戒忍进定智。非受持正法。何以故。所可取缘皆是非法非善。非受持正法。何以故。如来所得法是法无相无碍。若取缘相非受持正法。如是菩萨业中智。是名智业。以如是智而作智业。不尽于智是名智自在

自在王。何谓菩萨摩诃萨慧自在。菩萨得慧自在。能知诸法解释章句得四无碍智力故。谓义无碍智。法无碍智。辞无碍智。乐说无碍智。云何义无碍智。若菩萨于诸语中。依义不依语。义者于一切法正智。云何正智。谓不可说义是。此义在语中更无异声。从本已来离诸相故。是名为义。不应离语依于义。语中等相即是义。能如是知。名义无碍智。又达一切法义。亦名义无碍智。云何法无碍智。菩萨依于法不依非法。依于法者不见非法。何以故。知一切法离相但有名故。又法无碍者。虽说三乘不坏法性。何以故。法性是一性。谓无相是。菩萨以语说法。即知语同响相。有所说法信解皆同法性。于智于语而无所碍是名法无碍智。云何辞无碍智。知诸天言辞。知龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人言辞。知帝释梵天王护世者言辞。知一言二言多言略言广言。男言女言。非男言非女言。过去言未来言现在言。随以方便言辞令其得解。自以净妙言辞。亦不轻毁他语。何以故。知一切法无有言辞。菩萨作是念。以言辞说法令其得解。是法于言辞中不可得。言辞于法中亦不可得。从本已来无有言辞。若有言辞。不应以善言辞说不善法。是故当知。言辞能示善恶。又辞无碍者。即以众生言辞而使行法。何以故。法不行法。能如是行一切法。以言辞说此行使彼得解。是名辞无碍智。云何乐说无碍智。若菩萨于一切文字皆能乐说。于一切音声亦能乐说。一切名字亦能乐说。是名乐说。云何为乐。菩萨若说法时。乐法乐实乐谛。若信乐修多罗者。为说修多罗。信乐岐夜。伽陀。弊迦兰奈。讴陀那。祢陀那。阿波陀那。伊提郁多伽。阇陀伽。裴佛略。阿浮陀达摩者。皆为说之。信乐过去者为说本事。一切众生所乐诸根。皆随所乐而为说法。乐信根者因信根为说法。乐进根者因进根为说法。乐念根者因念根为说法。乐定根者因定根为说法。乐慧根者因慧根为说法。如是诸根皆因而为说法。淫欲多者分别有二万一千。佛知有八万四千根。如来因此诸根皆能乐说。菩萨次能乐说。嗔恚多者分别有二万一千。佛知有八万四千根。如来因此诸根皆能乐说。菩萨次能乐说。愚痴多者分别有二万一千。佛知有八万四千根。如来因此诸根。皆能乐说菩萨次能乐说。杂分者分别有二万一千。佛知有八万四千根。如来因此诸根皆能乐说。菩萨次能乐说。自在王。是名乐说无碍智。于此义无阂法无碍辞无碍乐说无碍。皆以慧为本。慧所住处。慧之所摄菩萨以慧力故用四自在及余自在皆得自在世尊。慧以何为本。为住何处。何处所摄。自在王慧以多闻为本。住多闻处。多闻所摄。世尊。多闻以何为本。为住何处。何处所摄。自在王。多闻以善知识为本。住善知识处善知识所摄。世尊。善知识以何为本。为住何处。何处所摄。自在王。善知识以敬心为本。住于敬心。敬心所摄。世尊。敬心以何为本。为住何处。何处所摄。自在王。敬心以深心为本。住于深心。深心所摄。世尊。深心以何为本。为住何处何处所摄。自在王。深心以质直为本。住于质直。质直所摄。世尊。质直以何为本。为住何处。何处所摄。自在王。质直以大悲为本。住于大悲。大悲所摄。世尊。大悲以何为本。为住何处。何处所摄。自在王。大悲以众生为本。住于众生。众生所摄。何以故。自在王。菩萨为度一切众生。生大悲心。生一切智心。是名菩萨慧自在。又慧自在菩萨。以慧自在故因一法门。若一劫若减一劫。种种异辞广说诸法。于实相中无所违失。菩萨或欲不现其身为众生说法。或从身毛孔演出法音。随众生所行而为说法。菩萨或欲现其身为众生说法。一切外道论师不能穷尽。又外道仙人所作。若曼哆逻咒术经。韦陀若语论。若钵追。若诸神通。若诸智门。若日月五星经。若梦经。若地动经。若陀魔陀咒术。若鸟语经。若鸟兽经。若龙乾闼婆夜叉入身经。若王相经。若丰乐饥馑相经。若诸遑游戏经。如是世界经书智慧。伎艺文章算数色相。音乐歌舞箜篌筝笛。如音曲折菩萨转身。自然在心皆能通了。以慧力故皆能得知皆能示现。皆能达知。菩萨虽知如是方术。不恼众生。亦不以是为净妙道。自在王。慧自在菩萨。与百千万诸梵王。共住共坐。自现其身与共语论。亦不着梵王光明德相。而诸梵王迎送菩萨生尊敬心。如是皆于一切天宫。现自在力而亦不着。但生无常苦空无我想。依无生法依度一切众生之心。自在王。是名菩萨慧自在。又自在王。慧自在菩萨。如魔所有天宫。复令殊胜自现其身。胜魔所有百千万倍。令诸魔等生渴爱心生贪着心。以此自严破魔慢心。令住阿耨多罗三藐三菩提。然后说法。自在王。慧是菩萨遍行法。若施若受若以施回向。而于此处必应用慧。若自持戒教他持戒。以持戒回向。而于此处亦应用慧。若修行忍若教他忍。以忍回向。而于此处亦应用慧。若自行进教他行进。以进回向。而于此处亦应用慧。若自行禅若教他禅。以禅回向。而于此处亦应用慧。若读诸经若为他说法。若如所闻以慧正念。一切行立坐卧。一切仪法。一切舍心。皆应用慧慧力菩萨。则是一切善法力者慧增上菩萨。于一切法得增上自在。慧自在菩萨。于一切法能自在行。执慧力菩萨。知佛能拒魔军。有慧菩萨自在随行诸法而不用力。如人仰射其箭还时不须弓力。菩萨亦如是。以慧力故遣自在智入诸善法。坐道场时得是智力。以是力故以右手动十方世界。破大魔军得佛十力。以是十力一切天人无能伏者。自在王。是戒自在。神通自在。智自在。慧自在。若人不种善根。不能得闻如斯经典。自在王。若人得闻是经心欢悦者。当知是人得四自在。以是自在现自在力。何以故。自在王。是诸自在。一切声闻辟支佛之所无有。尔时自在王菩萨。闻佛所说心大喜悦。合掌礼敬瞻仰尊愿目不暂舍。作如是言。世尊。佛今以是四自在力。一切众生亦当得是四自在力。佛以神力。使自在王菩萨以种种好色香华满其衣裓。以散佛上及诸菩萨。蒙华散者皆成金色。三十二相以严其身。空中百千万亿诸天。同声叹言。若有众生信受如是四自在力。发阿耨多罗三藐三菩提心者。是诸众生以佛庄严而以自严。何以故。是四自在皆随一切智心。世尊若佛本不发阿耨多罗三藐三菩提心者。是诸众生。云何得闻如是不可思议诸自在经。诸天子叹已。佛告自在王菩萨。我念过世。于燃灯佛前。第七十佛号普净光王如来。亦广说此四自在法。时有菩萨名智行足。亦以此法问佛。佛说此法时。八千菩萨得此四自在及无生法忍。三万二千人发阿耨多罗三藐三菩提心。自在王。我于尔时。初闻此四自在。闻已受持。至燃灯佛时乃得具足。是故自在王。若于今世若我灭后。有人一心求佛道者。受持是经。当知是人疾得无生法忍。说此自在王经时。三万二千天人发阿耨多罗三藐三菩提心。诸天子供奉佛故。作百千伎乐雨于天华。以佛神力从众伎乐出如是音若有众生闻此自在王经。信解受持。当知是人诸根明利。乐于佛法其智广博。为善知识所护。深种善根。于诸众生行大悲道

尔时自在王菩萨白佛言。世尊。佛有十力四无所畏十八不共法。菩萨亦有十力四无所畏十八不共法不。佛告自在王。有阿鞞跋致菩萨。已久习行得无生法忍住第八地欲入九地为般若波罗蜜方便所护。如是菩萨则能具成菩萨十力四无所畏十八不共法。自在王。云何菩萨十力。为萨婆若故。发深坚心力具慈心故。不舍一切众生力。不求一切利养故。舍一切世界饰好故。具大悲力。信一切佛法故。能成是法故。心不退没故。具大进力。行念安慧故。不坏仪法故。住不动定力离二边故。顺缘生法故。断一切见不别戏论故。具般若波罗蜜力成众生故。受无量生死故。习善德无厌足故。信解有为法如梦故。于生死中无疲倦力。观诸法相故。无我无人无众生故。信解不生不起法故。信乐无生法论故。无生法忍力入空无相无作法故。观诸脱门故。得声闻辟支佛乘解知见故。得脱门力。于深法中不随他智故。观一切众生心所行故。具无碍智力。自在王。是名菩萨十力。自在王。何谓菩萨四无所畏。得陀罗尼故。一切所闻能持故。常不忘念故。于大众中说法无所畏。随一切众生所信解。而为说法如随病合药。知见一切众生诸根。随应说法。于大众中而无所畏。是菩萨众中说法无所疑难。无有东方南方西方北方。有来问我我不能答。乃至无有微畏之相。恣于众生之所问难。随问为答而无所畏。善能断疑故。于大众中说法而无所畏。自在王。是名菩萨四无所畏。自在王。何谓菩萨十八不共法。菩萨从生已来。自能行施无有教言。汝当行施乐行舍心。若魔作佛形来语之言。汝行于施当堕地狱。菩萨若生悭悔之心无有是处。乐舍一切分布施与。以是行施为阿耨多罗三藐三菩提。不求果报利益众生故。是为菩萨初不共法。自在王。菩萨自能持戒无有教者。虽不值佛而亦不从他人受戒。善能护持一切诸戒常乐持戒。谓虽在家如戒所说尽能奉持。若其出家戒经所说。不须教导皆能履行。乃至不为寿命诸缘而舍于戒。所持诸戒皆顺菩提。为断众生破戒法故。是为菩萨二不共法。自在王。若贫穷下贱及旃陀罗工巧之人。嗔恚加恶苦言骂辱节节支解。菩萨尔时其心不动。于此众生慈心普润。有力能报而不加害。但依于法。我以佛法缘故忍受此苦。亦愿是人心得善净发大庄严。是为菩萨三不共法。自在王。菩萨虽遭急难犹故进行。不懈不息而终不生退没之心。若见声闻入于涅槃。见世苦恼而于声闻灭度法中心不贪乐。若见辟支佛灭度。又见生死苦恼。于辟支佛涅槃法中心不贪乐。若见诸佛已成大利。佛法具足入于涅槃。自见其身未得具足六波罗蜜及诸佛法。于此法中心亦不没而勤行进。我当于此大乘涅槃而取灭度。是为菩萨四不共法。自在王。菩萨若作转轮王。若作帝释。若作魔王。百千侍女作天伎乐。具受欲乐。而于禅定及无量心。皆现在前。常乐舍离愦闹之处。于生死中生大恐畏想。于五欲中生大不净想。于五阴中生怨仇想。于四大中生毒蛇想。于诸入中生空聚想。于己眷属生怨贼想。于宫宅侍女中如在死尸间想。但求行法。但求见佛。但念欲度一切众生。于伎乐之声出禅定法音。或时魔障其声。先世善根力故而于空中。得闻佛音法音僧音。闻此音已弃舍世界自在之乐。出家入林。是为菩萨五不共法。自在王。菩萨于世禅定之中不生坚想。以智分别离于诸见。依法依义。此不共法乃至梦中不生我见不生法见。菩萨不为诸结见缠所使。离诸疑悔。乃至恶魔不能障蔽令其疑悔离于正法。菩萨为成众生故。或破仪法而于其中无有疑悔。自在王。是为菩萨六不共法。自在王。菩萨从生已来自得身净。离于杀生不以手足刀杖瓦石有所恼害。常舍刀杖。资生丰足无所乏少。一把之草不与不取。珍宝满地不生贪心。饥穷死困不以邪命而自活也。常修梵行至于心想。不念五欲离诸欲恼。不以五欲之缘而行非法。以智为首成善身业。是为菩萨七不共法。自在王。菩萨净于口业真语实语。言行相应不自欺身。不诳诸佛诸天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。菩萨不行两舌。眷属亲爱终始不离。菩萨不行恶口。常行爱语软语和柔语。不恶语不粗语。有理语安乐语。先意语和悦语。菩萨于诸恶口粗言侵克苦语。人不喜闻。自恼恼他。如是诸语终不出口。菩萨不为无义语。有则言有。无则言无。深心净故口业皆净。自在王。菩萨得此不共法故。世世所生。常得如是随法语口。能以是语。不净之人令其得净。已净人者令起礼敬供奉之心。以是深心不共法故。得实语口。诸有所说皆实无虚。是为菩萨八不共法。自在王。菩萨己心自在得自在行。不贪他物。不恚恼众生行于正见。于菩萨心无等等心终不忘失。菩萨常离一切谄曲不直之心。昼夜常行善净慈心。是为菩萨九不共法。自在王。菩萨所生之处。一切经书咒术医方算数。为最为上。不须师教自能知之皆悉了达。亦于世法出世法中。得不随他慧。又不承望听采他语。常为诸天世人之所瞻仰。有所言说皆悉随学。是为菩萨十不共法。自在王。菩萨或为众生疗治诸病。不求利养以大悲为首。疗治病时发心愿言。当令众生得出世法灭诸苦恼令至涅槃。是为菩萨十一不共法。自在王。菩萨不求不愿转轮王位释梵天王之处。而自得之。何以故。菩萨不为身色端严故行道。不为世界眷属荣位名闻称赞故行道。如是之福不求而得。是为菩萨十二不共法。自在王菩萨住尊贵处长寿诸天。曾见佛者常来拥护。如是劝发应作是行。行是业者能至菩提。是则退法是则进法。如是行者。诸根随顺阿耨多罗三藐三菩提。是诸天神常以如是随宜劝发。令不违失阿耨多罗三藐三菩提。是为菩萨十三不共法。自在王。若有凶暴嗔恚恶人。见此菩萨身口心业。不能加恶心得善净。若或有人恼此菩萨忍受不报。令其心净得住于法。若有众生侵害菩萨。不令以此堕于恶道。何以故。菩萨本来已得具足不共善净之愿。若有众生以身口意侵害恼我。令不以此堕于恶道。菩萨净持戒故随愿皆得。是为菩萨十四不共法。自在王。或有众生悭贪不信。不见业行。不依果报。不识佛法僧。于诸沙门婆罗门。心不善净不能敬礼。听受其语心不尊重。不生希有之想。是诸众生见此菩萨身口意行仪法语论。心即得净礼敬随顺。便生尊重希有之心。何以故。菩萨得不共法故。是为菩萨十五不共法。自在王。若一切诸天龙神夜叉乾闼婆诸仙大人婆罗门等世之大师见此菩萨生师尊想。于此诸人名称最胜。又诸天龙神夜叉乾闼婆仙人婆罗门等世界之师。诣此菩萨曲躬礼敬供给使令。诸师弟子亦皆礼敬尊重迎送心念知胜。得是信心。是为菩萨十六不共法。自在王。菩萨所在国界聚落城邑。能修善法离不善法。能化众生护正法者。而生其中得正见。父母所生之处。常为师长礼敬尊重。国界之中众生命终无堕恶道。何以故。菩萨以善法摄众生令行福故。命终之后皆生人天。是为菩萨十七不共法。自在王。菩萨随顺一切助道之法。诸明神通皆具足故。一切诸魔不能得便。是为菩萨十八不共法。自在王。何故名为不共法。菩萨随顺一切佛法故。诸声闻辟支佛初发意者之所无有。而况凡夫

尔时自在王菩萨白佛言。希有世尊。世尊今者。与诸菩萨大智法明无量法光。如我解佛所说义者若有菩萨得闻此经不乐余经。若人闻此经受持读诵。已为受持一切佛法。若人受持此经已为他人说。则为能以佛之正法以成众生。若人正习此经。则为正习一切佛法。若人于此经中得忍名为顺忍。若人于此经中如所说行。则为随顺一切法行。世尊。若有菩萨不离此经。当知是人已得诸明神通为坐道场。佛告自在王。如汝所说。若人不离此经。当知是人得诸明神通为坐道场。自在王。过去然灯佛前。威德佛。提沙佛。弗沙佛。光明佛前有佛。号天王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛世界严净丰乐天人充满。其土平正琉璃为地。阎浮檀金以为莲华遍覆其土。柔软细滑譬如天衣。是时世人身色长短资生所有园林池观。皆如兜率天上。所须饮食应念即至与天无异。唯有名别。其三千世界佛为法王。是故其佛号为天王。如转轮王坐于正座。以法化民无不承顺。天王如来亦复如是。坐师子法座为一切天人演说于法。大众坐处东西八万四千由旬。南北亦尔八万四千由旬。天王如来说法之时。音声遍满三千大千世界。其诸天人尽敬尊重赞叹。行无上法以为法供。其土众生无有乐下法者。唯乐佛法。无有声闻辟支佛名。况发心行者。唯有菩萨以为眷属。无有女人亦不闻有淫欲之名。皆于莲华结加趺坐自然化生唯乐三法。何等为三。一者乐喜见佛。二者乐喜闻法。三者乐观于法好喜离行。其诸人众修习经法常不放逸。福慧具足寿命无量阿僧祇劫。命终生天。谓到他佛土。若有菩萨命欲终时。上升于空高七多罗树。唱大音言。我于此土今当退没。时众坐菩萨闻此声已。皆共集会试其法忍。作如是言。何等法退。何等法生。时是菩萨于大众中而作是言。此中无法若退若生。如来得阿耨多罗三藐三菩提时。知一切法无退无生。何以故。色不退不生。受想行识不退不生。更无异法必定可得。若我若众生若寿命。退者生者。如来得阿耨多罗三藐三菩提时。知一切法皆空无相。空无相法不退不生。诸法离际。不作际不起际无生际。佛以为证。如是诸际亦不退不生。退名众缘离。生名众缘合。而是诸缘亦不退不生。是菩萨于大众中说是法已。然后乃退。其身灭已无灰无烟。即生他方现在佛前。是天王佛及诸菩萨。不着袈裟皆着自生净妙天衣。亦无结惑。世人调顺皆得无生法忍。不为众生广说诸法。而诸众生其根明利小发即悟。若天王佛。为诸菩萨演说法时。其诸天人普皆能知。或得法忍。或得陀罗尼。或得乐说无碍。或得诸三昧。自在王。是天王佛其大名闻普流十方。于一切天人之中。广说此四自在经。七万二千菩萨得受阿耨多罗三藐三菩提记。时有菩萨名曰净光。不得受记。作如是念。今诸菩萨得受记者。持戒仪式。行道念慧。方便神力。陀罗尼三昧。不胜于我。以何缘故。今得受记。而我不得。时天王佛。知其心念。告净光言。善男子。于未来世当有佛出。号曰然灯。彼佛当与汝受记。时净光菩萨。闻佛语已心大喜悦。上升于空作如是言。若然灯佛。过恒沙劫而后乃出。当知我已得受阿耨多罗三藐三菩提记。何以故。诸佛所言皆无虚妄。诸佛皆是真实语者。自在王。于意云何。彼时净光菩萨。岂异人乎。则我身是。我从是来得值光明佛。我从彼佛得闻是法。闻已受持得光印三昧。从是已后复值弗沙佛。我从彼佛得闻是法。闻已受持得众明三昧。从是已后复值提沙佛。得闻是法。闻已受持得照明三昧。从是已后复值威德佛。我从彼佛得闻是法。闻已受持得顺法忍。从是已后复值然灯佛。我从彼佛得无生法忍。证此四自在。谓戒自在。神通自在。智自在。慧自在。自在王。以是缘故。若于今世若我灭后。善男子善女人求菩萨乘者。得闻是经闻已受持。当知是等皆疾得为菩提真智。得此四自在能转法轮。于佛无上正法之中当得慧光。说是经时。万六千菩萨得无生法忍。万二千人皆发阿耨多罗三藐三菩提心。三千大千世界六种震动。百千万诸天喜而唱言。在在处处有说是经。当知此中则为是佛。若有众生得闻此经。当知此人善根深厚。尔时慧命阿难白佛言。世尊。当何名此经。云何受持。佛告阿难。此经名为四自在神力。当奉持之。佛说此已。自在王菩萨及阿难一切天人。闻佛所说欢喜受持

自在王菩萨经卷下


阿阇世王授决经

    No. 509 [No. 510]

阿阇世王授决经

        西晋沙门释法炬译

闻如是。一时佛在罗阅只国耆阇崛山中。时阿阇世王请佛。饭食已讫佛还祇洹。王与只婆议曰。今日请佛。佛饭已竟更复所宜。只婆言。惟多然灯也。于是王乃敕具百斛麻油膏。从宫门至祇洹精舍。时有贫穷老母。常有至心欲供养佛而无资财。见王作此功德乃更感激。行乞得两钱。以至麻油家买膏。膏主曰。母人大贫穷。乞得两钱何不买食。以自连继用此膏为。母曰。我闻佛生难值百劫一遇。我幸逢佛世而无供养。今日见王作大功德。巍巍无量激起我意。虽实贫穷故欲然一灯为后世根本者也。于是膏主知其至意。与两钱膏应得二合。特益三合凡得五合。母则往当佛前然之。心计此膏不足半夕。乃自誓言。若我后世得道如佛。膏当通夕光明不消。作礼而去。王所然灯或灭或尽。虽有人侍恒不周匝。老母所然一灯光明特朗。殊胜诸灯通夕不灭。膏又不尽至明朝旦。母复来前头面作礼叉手却住

佛告目连。天今已晓可灭诸灯。目连承教以次灭诸灯。灯皆已灭。惟此母一灯三灭不灭。便举袈裟以扇之灯光益明。乃以威神引随蓝风以次吹灯。老母灯更盛猛。乃上照梵天。傍照三千世界悉见其光。佛告目连。止止。此当来佛之光明功德。非汝威神所毁灭。此母宿命供养百八十亿佛已。从前佛受决。务以经法教授开化人民。未暇修檀。故今贫穷无有财宝。却后三十劫。功德成满当得作佛。号曰须弥灯光如来至真。世界无有日月。人民身中皆有大光。宫室众宝光明相照如忉利天上。老母闻决欢喜。即时轻举身升虚空。去地百八十丈。来下头面作礼而去。王闻之。问只婆曰。我作功德巍巍如此。而佛不与我决。此母然一灯便受决何以尔也。只婆曰。王所作虽多心不专一。不如此母注心于佛也。乃更往请。佛宿敕诸园监。各令晨采好华。早送入宫至中。佛便晨出祇洹徐徐缓行。随道为人民说法。投日中至宫。有一园监持华适出园巷。正与佛会于大道之衢。闻佛说经一心欢喜。即以所持华悉散佛上。花皆住于空中当佛头上。佛即授决曰。汝已供养九十亿佛。却后百四十劫汝当为佛。号曰觉华如来。其人欢喜。即时轻举身升虚空。来下作礼毕。即更自念。我王为人性大严急。故宿敕我斋戒将华当以供佛。而我悉自以上佛。空手而往必当杀我。便径归家置空华箱于户外。入告妇言。我朝来未食。王今当杀我急为具食。妇闻大惶懅曰。王何故相杀。便为妇本末说之。妇即出。至窖下具食。天帝释便以天华满空箱中。妇持食还。见户外箱中华满如故光色非凡。即以告夫。夫出户视。知是天花心大欢喜。止不复食便持华入。王适出迎佛。道与王相逢。王见华大好世间希有。即问监曰。我园中大有此好华乃尔。而汝前后不送上。汝罪应死宁知之不。监曰。大王园中无有此华。臣朝早将园华道路逢佛。不胜欢喜。尽以上佛。即授与我决。知当杀故过家索食。比其顷出视空箱中。复见此华。必是天华非园所有。今我生既卑贱。为王守园。拘制县官不得行道。一已授决。正尔而死。必生天上。十方佛前无所拘制。可得恣意行道。王若相杀我无所在也。王闻授决。便生惭怖。肃然毛竖。即起作礼。长跪忏悔。佛至宫饭食已讫。咒愿而去。王复问只婆曰。我前请佛而老母受决。今日设福而园监受决。我独何故初无所获。心甚于悒。当复宜作何等功德耶。只婆曰。王虽频日设福。但用国藏之财。使人民之力。心或贡高意或嗔恚。故未得决。今宜割损身中自供之具。并脱璎珞七宝珠环以作宝华。当与夫人太子并力合掌。自就功勤一心上佛。佛照王至诚必得决也。于是王减彻厨膳昼夜斋戒。脱身上诸宝。合聚诸师曰前作华。王及夫人太子皆自着手。至九十日所作悉成。敕外驾当往上佛。傍臣白言。闻佛前到鸠夷那竭国。已般泥洹也。王闻心大悲号。涕泪哽咽曰。我故至心手作此华。佛虽般泥洹。我故当赍诣耆阇崛山。以上佛坐处展驰我意也。只婆曰。佛者无身亦无泥洹。亦不常住无灭无在。惟至心者为得见佛。佛虽在世间无至心者为不见佛。大王至诚乃尔。佛虽般泥洹往必见佛。便至耆阇崛山中。见佛且悲且喜。垂泪而进。头面作礼以七宝华前散佛上。华皆住空中化成宝盖正当佛上。佛便授与王决曰。却后八万劫劫名喜观。王当为佛。佛号净其所部如来。刹土名华王。时人民寿四十小劫。阿阇世王太子。名旃陀和利时年八岁。见父授决甚大欢喜。即脱身上众宝以散佛上曰。愿净其所部作佛时。我作金轮圣王得供养佛。佛般泥洹后我当承续为佛。其所散宝化为交露帐正覆佛上。佛言。必如汝愿。王为佛时必当作金轮圣王。寿终便上生兜率天上。寿尽便下作佛。在药王刹土教授。佛号栴檀。人民寿命国土所有。皆如净其所部。佛时授决适竟王及旃陀和利。前为佛作礼便[火*霍]然不见佛所在阿阇世王授决经


阿阇世王问五逆经

    No. 508

阿阇世王问五逆经

        西晋沙门法炬译

闻如是。一时婆伽婆。在罗阅城灵鹫山。与大比丘众五百人俱。提婆达兜。诣阿阇世王所。到已即就座坐。时王阿阇世。即从坐起。头面礼调达足。还就座坐。时王阿阇世。白调达言。我曾闻尊者调达。彼沙门瞿昙。常作是语。有五逆罪。若族姓子族姓女。为是五不救罪者。必入地狱不疑。云何为五。谓杀父。杀母。害阿罗汉斗乱众僧。起恶意于如来所。如是五不救罪。若有男女施行此事者。必入地狱不疑。我今调达。躬杀父王。我亦当入地狱耶。时调达告阿阇世王。大王勿怀恐惧。为有何殃。为有何咎。谁为殃而受报。谁作殃当受其果。然大王亦不为恶逆。所作恶者。自当受报。时众多比丘。到时着衣持钵。入罗阅城乞食。时众多比丘。入罗阅城乞食。闻王阿阇世语调达言。尊者调达。我闻沙门瞿昙。作是说言。有五不救罪。若有男女。施行此五事者。必入地狱不疑。我无辜躬杀父王。我当入地狱中耶。时调达报言。勿惧大王。谁作殃殃由何生。谁作恶后受报。王亦不作殃。所作殃者。自当受报。时众多比丘。从罗阅城乞食已。食后收摄衣钵。以尼师坛着肩上。至世尊所。头面礼足。在一面坐。便说阿阇世王所共论议。具向世尊说。时世尊便说此偈

  愚者知是处　　言殃谓无报
  我今观当来　　受报有定处

是时世尊。告诸比丘。彼摩竭国阿阇世王。虽杀父王。亦当不久。来至我所。当有等信于我所。命终之后。当堕地狱如拍鞠。时有一比丘。白世尊言。从彼泥犁命终。当生何处。世尊告曰。从彼泥犁命终。当生四天王处。比丘白言。从彼命终。当生何处。世尊告曰。比丘。从彼命终。当生三十三天。比丘白言。从三十三天命终。当生何处。世尊告曰。比丘。从三十三天命终。当生炎天上。比丘白言。世尊。从彼命终。当生何处。世尊告曰。从炎天上命终。当生兜术天。比丘白言。世尊。从兜术天命终。当生何处。世尊告曰。从兜术天命终。当生化自在天。比丘白言。从化自在天命终。当生何处。世尊告曰。比丘。从化自在天命终。当生他化自在天。比丘白言。世尊。从他化自在天命终。当生何处。世尊告曰。比丘。从他化自在天命终。当生化自在天。生兜术天炎天三十三天四天王天。复当来生人间。比丘白言。世尊。从此命终。当生何处。世尊告曰。比丘。摩竭国王阿阇世。二十劫中。不趣三恶道。流转天人间。最后受身。剃除须发。着三法衣。以信坚固。出家学道。当成辟支佛。名无秽。比丘白言。甚奇甚特。世尊作如是殃罪。受是快乐。成辟支佛。名曰无秽。世尊告曰。摩竭国王阿阇世。发意成就。众善普至。比丘堪任发意成就得拔济地狱。若发意不成就者。因缘成就。虽未生地狱。犹可设方便不至地狱。比丘白言。若彼人二事俱成就者。彼当生何处。世尊告曰。彼二事成就。当生二处。云何为二。生天人间。比丘白言。彼发意成就。因缘不成就者。此二事有何差别。世尊告曰。比丘。发意成就。因缘不成就。此是濡根。发意不成就。因缘成就。比丘此是利根。比丘白言。钝根利根。有何差别。世尊告曰。钝根者。比丘所为不进。利根者。比丘聪明黠慧比丘白言。此二有何差别。当还何业。是时世尊。便说此偈

  智慧世为上　　当至安隐处
  诸能知等业　　断彼生有死

是谓比丘有是差别。是时彼比丘。闻佛所说。欢喜奉行已。即从坐起。头面礼足。绕三匝便退而去。是时彼比丘。即其日到。时着衣持钵。入罗阅城乞食。诣彼摩竭王宫门外。时王阿阇世。遥见彼比丘来。见已便敕守门人。云何守门人。我先已敕。释种比丘。勿放入此。除尊者调达。时彼守门人。执彼比丘手。驱出门外。时彼比丘举右手。语摩竭国王言。我是大王大善知识。是安隐处。无有众恼。时王报言。云何比丘。而观何义。作是说言。我是大王善知识是安隐处。时彼比丘。告王阿阇世言。世尊说王作是言。摩竭国王。虽杀父王。彼作恶命终已。当生地狱如拍鞠从彼命终。当生四天王宫。从彼命终。当生三十三天。从彼命终。当生炎天兜术天化自在天他化自在天。从彼命终。复当生化自在天兜术天炎天三十三天四天王宫。复当生此间受人形。如是大王。二十劫中。不趣三恶道。流转人间。最后受人身。当剃除须发。着三法衣。以信坚固。出家学道。成辟支佛。名曰无秽。所以然者。如是大王。当得是无根之信。时彼比丘。说是语已。便退而去。时王阿阇世。闻彼比丘所说。亦不欢喜。复不嗔恚。亦不受彼所说。便告耆域王子曰。耆域。沙门来至我所。而作是言。彼如来至真等正觉见授决。杀父王而作是恶逆。命终后当生地狱如拍鞠。从彼命终。当生四天王天三十三天炎天兜术天化自在天他化自在天。从彼命终。复当生化自在天兜术天炎天三十三天四天王宫。从彼命终。当生人间。最后受人身。剃除须发。着三法衣。以信坚固。出家学道。成辟支佛。名曰无秽。汝往耆域彼沙门瞿昙所。审有是语不。对曰如是。大王。时耆域王子。受摩竭国王教。便出罗阅只城。诣灵鹫山。至世尊所。到已头面礼足。在一面坐。时耆域王子。从摩竭国王所说言教。尽向如来说。世尊告曰。如是耆域。佛世尊言无有二。所说随事。所以然者。耆域。彼王阿阇世。当成无根信。耆域。诸有男女。彼一切亦当有是趣而无有异。时耆域王子。从如来受是教已。即从坐起。头面礼足。便退而去。诣摩竭国王所。到已便语王阿阇世言。彼如来至真等正觉。实有是语。所以然者。诸有得无根信者。而无有异。愿王当诣彼如来至真等正觉所。时王报言。耆域。我闻彼沙门瞿昙。有是咒术。能降伏人民。使外道异学无不受其教。是故我不堪任往见沙门瞿昙。且住耆域。我当观察。彼沙门瞿昙。为有一切智不。设当有一切智者。然后我当往见彼沙门瞿昙。时耆域王子。从摩竭国王。闻是语出罗阅城。诣灵鹫山。至世尊所。到已头面礼足。在一面坐。以此义白世尊言。时世尊告曰。耆域摩竭国王。不久当来至我所。当成无根信。设我取泥洹日后。当供养我舍利。耆域王子。欢喜踊跃。不能自胜。时世尊。与耆域王子。说微妙法。令发欢喜。时耆域王子。从如来闻此深法。即从坐起。头面礼足。绕三匝。便退而去。时耆域王子。闻佛所说。欢喜奉行阿阇世王问五逆经


阿难七梦经

    No. 494

阿难七梦经

        东晋天竺三藏竺昙无兰译

阿难在舍卫国。有七种梦。来问于佛。一者陂池火炎滔天。二者梦日月没星宿亦没。三者梦出家比丘。转在于不净坑堑之中。在家白衣。登头而出。四者梦群猪来抵揬栴檀林怪之。五者梦头戴须弥山。不以为重。六者梦大象弃小象。七者梦师子王名华撒头上。有七毫毛。在地而死。一切禽兽。见故怖畏。后见身中虫出。然后食之。以此恶梦。来问于佛。佛时在舍卫国普会讲堂上。与波斯匿王。说法苦习灭得道。为乐见阿难忧色愁苦叵言。佛告阿难。汝于梦者。皆为当来五浊恶世。不损汝也。何为忧色。第一梦陂池火炎滔天者。当来比丘。善心转少。恶逆炽盛。共相杀害。不可称计。第二梦者日月没星宿亦没。佛泥洹后。一切声闻。随佛泥洹不在世。众生眼灭。第三梦出家比丘。转在于不净坑堑之中。在家白衣。登头出者。当来比丘怀毒嫉妒。至相杀害。道士斩头。白衣视之。谏诃不从。死入地狱。白衣精进。死生天上。第四梦者。群猪来抵揬栴檀林怪之者。当来白衣。来入塔寺。诽谤众僧。求其长短。破塔害僧。第五梦者。头戴须弥山。不以为重者。佛泥洹后。阿难当为千阿罗汉。出经之师。一句不忘。受悟亦多。不以为重。第六梦者。大象弃小象。将来邪见炽盛。坏我佛法。有德之人。皆隐不现。第七梦师子死者。佛泥洹后。一千四百七十岁。我诸弟子修德之心。一切恶魔不得娆乱。七毫者七百岁后事阿难七梦经


阿难问事佛吉凶经b

阿难问事佛吉凶经

        后汉沙门安世高译

阿难白佛言。有人事佛得富贵谐偶者。有衰耗不谐偶者。云何不等同耶。愿天中天普为说之。佛告阿难。有人奉佛。从明师受戒。专信不犯。精进奉行。不失所受。形像鲜明。朝暮礼拜。恭敬然灯。净施所安。不违道禁。斋戒不厌。心中欣欣。常为诸天善神拥护。所向谐偶。百事增倍。为天龙鬼神众人所敬。后必得道。是善男子善女人。真佛弟子也。有人事佛。不值善师。不见经教。受戒而已。示有戒名。愦塞不信。违犯戒律。乍信乍不信。心意犹豫。亦无经像恭恪之心。既不烧香然灯礼拜。恒怀狐疑。嗔恚骂詈。恶口嫉贤。又不六斋。杀生趣手。不敬佛经。持着弊箧衣服不净之中。或着妻子床上不净之处。或持挂壁。无有座席恭敬之心。与世间凡书无异。若疾病者。狐疑不信。便呼巫师。卜问解奏。祠祀邪神。天神离远。不得善护。妖魅日进。恶鬼屯门。令之衰耗。所向不谐。或从宿行恶道中来。现世罪人也。非佛弟子。死当入泥犁中被拷掠治。由其罪故。现自衰耗。后复受殃。死趣恶道。展转受痛。酷不可言。皆由积恶其行不善。愚人盲盲。不思宿行因缘所之。精神报应。根本从来。谓言事佛致是衰耗。不止前世宿祚无功。怨憎天地。责圣咎天。世人迷惑。不达乃尔。不达之人。心怀不定。而不坚固。进退失理。违负佛恩。而无返覆遂为三涂所见缀缚。自作祸福。罪识之缘。种之得本。不可不慎。十恶怨家。十善厚友。安神得道。皆从善生。善为大铠。不畏刀兵。善为大船。可以度水。有能守信。室内和安。福报自然。从善至善。非神授与也。今复不信者。从后转复剧矣。佛言。阿难。善恶追人。如影逐形。不可得离。罪福之事。亦皆如是。勿作狐疑自堕恶道。罪福分明。谛信不迷。所在常安。佛语至诚。终不欺人。佛复告阿难。佛无二言。佛世难值。经法难闻。汝宿有福。今得侍佛。当念报恩。颁宣法教。示现人民。为作福田。信者得植。后生无忧。阿难受教。奉行普闻。阿难复白佛言。人不自手杀者。不自手杀为无罪耶。佛言。阿难教人杀生。重于自杀也。何以故。或是奴婢愚小下人。不知罪福。或为县官所见促逼。不自出意。虽获其罪。事意不同。轻重有差。教人杀者。知而故犯。阴怀愚恶。趣手害生。无有慈心。欺罔三尊。负于自然神。伤生杌命。其罪莫大。怨对相报。世世受殃。无有断绝。现世不安。数逢灾凶。死入地狱。出离人形。当堕畜中。为人屠截。三涂八难。巨亿万劫。以肉供人。未有竟时。令身困苦。啖草饮泉今世现有是辈畜兽。皆由前世得为人时。暴逆无道。阴害伤生。不信致此。世世为怨。还相报偿。神同形异。罪深如是。阿难复白佛言。世间人及弟子。恶意向师及道德之人。其罪云何。佛语阿难。夫为人者。当爱乐人善。不可嫉之。人有恶意。向道德之人善师者。是恶意向佛无异也。宁持万石弩自射身。不可恶意向之。佛言。阿难。自射身为痛不。阿难言。甚痛甚痛世尊。佛言。人持恶意。向道德人。其善师者。痛剧弩射身也。为人弟子。不可轻慢其师恶意向道德人。当视之如佛。不可轻嫉。见善代其欢喜。人有戒德者。感动诸天。天龙鬼神。莫不敬尊。宁投身火中。利剑割肉。慎莫嫉妒人之善。其罪不小。慎之慎之。阿难复白佛言。为人师者。为可得呵遏弟子。不从道理。以有小过。遂之成大。可无罪不。佛言。不可不可。师弟子义。义感自然。当相讯厚。视彼如己。黜之以理。教之以道。己所不行。勿施于人。弘崇礼律。不使怨讼。弟子亦尔。二义真诚。师当如师。弟子当如弟子。勿相诽谤。含毒致怨。以小成大。还自烧身。为人弟子。当孝顺于善师。慎莫举恶意向师。恶意向师。是恶意向佛向法向比丘僧向父母无异。天所不覆。地所不载。观末世人诸恶人辈。不忠不孝。无有仁义。不顺人道。魔世比丘四数之中。但念他恶。不自止恶。嫉贤妒善。更相沮坏。不念行善。强梁嫉贤。既不能为。复毁败人。断绝道意。令不得行。贪欲务俗。多求利业。积财自丧。厚财贱道。死堕恶趣大泥犁中饿鬼畜生。未当有此。于世何求。念报佛恩。当持经戒。相率以道。道不可不学。经不可不读。善不可不行。行善布德。济神离苦。超出生死。见贤勿慢。见善勿谤。不以小过证入大罪。违法失理。其罪莫大。罪福有证。可不慎耶。阿难复白佛言。末世弟子。因缘相生。理家之事。身口之累。当云何。天中天。佛言。阿难。有受佛禁戒。诚信奉行。顺孝畏慎。敬归三尊。养亲尽忠。内外谨善。心口相应。可得为世间事。不可得为世间意。阿难言。世间事。世间意。云何耶。天中天。佛言。为佛弟子。可得商贩营生利业。平斗直尺。不可罔于人。施行以理。不违神明自然之理。葬送之事。移徙姻娶。是为世间事也。世间意者。为佛弟子。不得卜问请祟符咒厌怪祠祀解奏。亦不得择良日良时受佛五戒福德人也。有所施作。当启三尊。佛之玄通。无细不知。戒德之人。道护为强。役使诸天。天龙鬼神。无不敬伏。戒贵则尊。无往不吉。岂有忌讳不善者耶。道之含覆。包弘天地。不达之人。自作挂碍。善恶之事。由人心作。祸福由人。如影追形。响之应声。戒行之德。应之自然。诸天所护。愿不意违。感动十方。与天参德。功勋巍巍。众圣嗟叹。难可称量。智士达命。没身不邪。善如佛教。可得度世之道。阿难闻佛说。更整袈裟。头脑着地。唯然世尊。我等有福。得值如来。普恩慈大。愍念一切。为作福田。令得脱苦。佛言。至真。而信者少。是世多恶。众生相诅。甚可痛哉。若有信者。若一若两。奈何世恶。乃弊如此。佛灭度后。经法虽存。而无信者。渐衰灭矣。呜呼痛哉。将何恃怙。惟愿世尊。为众黎故。未可取泥洹。阿难因而谏颂曰

  佛为三界护　　恩广普慈大
  愿为一切故　　未可取泥洹
  值法者亦少　　盲盲不别真
  痛矣不识者　　罪深乃如是
  宿福值法者　　若一若有两
  经法稍稍替　　当复何恃怙
  佛恩非不大　　罪由众生故
  法鼓震三千　　如何不得闻
  世浊多恶人　　还自堕颠倒
  谀谄諀訾圣　　邪媚毁正真
  不信世有佛　　言佛非大道
  是人是非人　　自作众罪本
  命尽往无择　　刀剑解身形
  食鬼好伐杀　　镬汤涌其中
  淫泆抱铜柱　　大火相烧然
  诽谤清高士　　铁钳拔其舌
  乱酒无礼节　　迷惑失人道
  死入地狱中　　洋铜沃其口
  遭逢众厄难　　毒痛不可言
  若生还为人　　下贱贫穷中
  不杀得长寿　　无病常康强
  不盗后大富　　钱财恒自满
  不淫香清净　　身体鲜苾芬
  光影常奕奕　　上则为大王
  至诚不欺诈　　为众所奉承
  不醉后明了　　德慧所尊敬
  五福超法出　　天人同俦类
  所生亿万倍　　真谛甚分明
  末世诸恶人　　不信多狐疑
  愚痴不别道　　罪深更逮冥
  蔽圣毁正觉　　死入大铁城
  识神处其中　　头上戴铁轮
  求死不得死　　须臾已变形
  矛戟相毒刺　　躯体恒残截
  奈何世如是　　背正信鬼神
  解奏好卜问　　祭祀伤不仁
  死堕十八处　　经历黑绳狱
  八难为界首　　得复人身难
  若时得为人　　蛮狄无义理
  痴骏无孔窍　　跛躄哑不语
  朦胧不达事　　恶恶相牵拘
  展转众徒聚　　禽兽六畜形
  为人所屠割　　剥皮视其喉
  归偿宿怨对　　以肉给还人
  无道堕恶道　　求脱甚为难
  人身既难得　　佛经难得闻
  世尊为众祐　　三界皆蒙恩
  敷动甘露法　　令人普奉行
  哀哉已得慧　　愍念群萌故
  开通示道径　　黠者即度苦
  福人在向向　　见谛学不生
  自归大护田　　植种不死地
  恩大莫过佛　　世祐转法轮
  愿使一切人　　得服甘露浆
  慧船到彼岸　　法磬引大千
  彼我无有二　　发愿无上真

阿难颂如是已。诸会大众。一时信解。皆发无上正真之道。僧那大铠甘露之意。香熏三千。从是得度。开示道地。为作桥梁。国王臣民。天龙鬼神。闻经欢喜。阿难所说。且悲且恐。稽首佛足。及礼阿难。受教而去阿难问事佛吉凶经


八佛名号经

    No. 431 [Nos. 427-430]

八佛名号经

        隋天竺三藏阇那崛多译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘僧千二百五十人俱。复有大乘众菩萨摩诃萨十千人俱。尔时世尊。与无量无数百千万众。前后围绕而为说法

尔时尊者舍利弗。于大众中即从座起。偏袒右肩右膝着地。向佛合掌而白佛言。世尊。我有疑心今欲发问。惟愿如来怜愍众生为我解说

尔时世尊告舍利弗言。善男子。随汝所问。若有疑心。吾当为汝分别解说。时舍利弗蒙佛印可许决疑网。欢喜踊跃即白佛言。世尊。颇有现在十方世界诸佛世尊。往昔愿力常为众生现在说法。彼诸如来所有名号。若善男子及善女人。欲得诵持此诸佛名。若读若闻及以书写。缘是功德。便于阿耨多罗三藐三菩提得不退转。无所缺减。至于无上正真之道。速得成于阿耨多罗三藐三菩提者不

尔时世尊告舍利弗言。善哉善哉善男子。汝所咨问真妙辩才。为于来世无量众生广作利益。慈悲哀愍一切天人。能问如来如斯奥义。是故汝今谛听谛受善思念之。吾当为汝分别解说。舍利弗言。唯然世尊。愿乐欲闻

尔时世尊告舍利弗言。善男子。东方去此过一恒河沙世界。有一佛刹名难降伏。于彼国土有佛世尊。号善说称功德如来至真等正觉。于今现在为诸大众说微妙法

复次舍利弗。从此东方过二恒河沙世界。有一佛刹名无障碍。于彼国土有佛世尊。号因陀罗相幢星王如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过三恒河沙世界。有一佛刹名曰爱乐。于彼国土有佛世尊。号普光明功德庄严如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过四恒河沙世界。有一佛刹名曰普入。于彼国土有佛世尊。号善斗战难降伏超越如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过五恒河沙世界。有一佛刹名曰净聚。于彼国土有佛世尊。号普功德明庄严如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过六恒河沙世界。有一佛刹名无毒主。于彼国土有佛世尊。号无碍药树功德称如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过七恒河沙世界。有一佛刹名侧塞香满。于彼国土有佛世尊。号步宝莲华如来至真等正觉。于今现在亦为大众说微妙法

复次舍利弗。从此东方过八恒河沙世界。有一佛刹名妙音明。于彼国土有佛世尊。号宝莲花善住娑罗树王如来至真等正觉。于今现在亦为大众说微妙法。舍利弗。是等诸佛如来至真等正觉。如是佛刹清净无秽。无有五浊复无五欲。其中众生无有谄曲虚伪之心。亦无欲行及以女人

复次舍利弗。若善男子及善女人。得闻彼等诸佛世尊如是名号。既得闻已能自受持读诵修行。复为他人宣扬显说。彼善男子及善女人。若堕三恶道者无有是处。惟除五逆诽谤正法及谤圣人

复次舍利弗。若善男子善女人。得闻彼等诸佛世尊如是名号。既得闻已能自受持读诵修行。复为他人宣扬显说。如是之人乃至菩提。于其中间生生之处常具五通。兼复逮得诸陀罗尼。六根完具无诸残缺。常得欢喜身毛右旋

复次舍利弗。若善男子及善女人。得闻彼等诸佛世尊如是名号。既得闻已能自受持读诵修行。复为他人宣扬显说。彼等众生所在之处。县官恶贼不能得便。火不能焚水不能漂。恶龙恶蛇不能毒害。若行若住师子虎狼态罴豺豹。夜叉罗刹诸恶鬼神鸠槃荼等及人非人。能作惊惶无有是处。惟除宿殃

复次舍利弗。若有女人能厌其身。系念专心受持读诵如是世尊诸佛名号。复为他人分别显说。寿终之后更复受于女人身者。无有是处

复次舍利弗。若有善男子善女人。于静夜中能诵如是诸佛名号。是等众生。于现世间所作功业皆速成就。日日增长无诸障碍。尔时世尊欲重明此义而说偈言

  若有诸众生　　能持是佛名
  悉舍诸恶道　　速生于善处
  常在诸佛前　　恒闻说妙法
  既睹无上尊　　随心而供养
  诵持佛名故　　超亿千万劫
  一切诸烦恼　　疾成得菩提
  若人满七日　　能诵是佛名
  即得清净眼　　便能见诸佛
  若有闻佛名　　即能诵持者
  随其所生处　　常为他所敬
  相好形端正　　常生福乐家
  喜心行大舍　　聪明不放逸
  若有诸女人　　闻此佛名故
  自诵为他说　　其福不可量
  于此寿终已　　必舍女人报
  得受丈夫身　　生生常利根
  诵持佛名故　　多百亿劫中
  口气常芬馥　　恒如栴檀香
  彼等诸大仙　　如是诸名字
  若能诵持者　　细心不放逸
  诵持佛名故　　父母及兄弟
  并余诸眷属　　终无异苦恼
  诵持佛名故　　一切魔波旬
  黑闇众眷属　　终不能障碍
  恶毒不能害　　刀杖及火等
  县官恶贼盗　　一切不能伤
  诵持佛名故　　千亿诸劫中
  常生宝莲华　　威相神通具
  常在虚空中　　遍不思议刹
  观诸异佛土　　刹中清净者
  证无上道已　　普为诸杂类
  诸天及世人　　能作归依处

佛说是经已。长老舍利弗及天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切大众闻佛所说欢喜奉行八佛名号经


八吉祥经

    No. 430 [Nos. 427-429, 431]

八吉祥经

        梁扶南三藏僧伽婆罗译

如是我闻。一时佛住舍卫国祗树给孤独园。与大比丘众一千二百五十人俱。菩萨摩诃萨八万人。及诸天龙鬼神等。尔时世尊告舍利弗。从此佛世界。向东方过一恒河沙世界。有世界名曰天胜。彼土有佛。名善说吉如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过二恒河沙等世界。有世界名念意。彼土有佛。名普光明如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过三恒河沙等世界。有世界名可爱游戏。彼土有佛。名战斗胜吉如来应供正遍知。今现在说法。舍利弗。从彼世界。向东方过四恒河沙等世界。有世界名善清净聚。彼土有佛。名自在幢王如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过五恒河沙等世界。有世界名无尘聚。彼土有佛。名无边功德光明吉如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过六恒河沙等世界。有世界名无妨碍游戏。彼土有佛。名无障碍业柱吉如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过七恒河沙等世界。有世界名金聚。彼土有佛。名妙华勇猛如来应供正遍知。今现在说法。舍利弗。从彼佛世界。向东方过八恒河沙等世界。有世界名美声。彼土有佛。名宝莲华安住王如来应供正遍知。今现在说法。舍利弗。此八佛土皆悉清净。无有女人亦无五浊。舍利弗。若善男子善女人住大乘者。闻此八佛名号。受持不忘并为他说。若生三涂八难处者无有是处。若有女人闻八佛名号。自能忆持兼为他说。若更受女身无有是处。舍利弗。若善男子善女人住于大乘。闻此八佛名号。闻已受持为他人说。今世后世常有神通得乐说辩。深修禅定具陀罗尼。六根清净恒值圣人。无天龙夜叉人及非人盗贼水火毒药等畏。一切怖畏皆悉除灭。卧觉常安无诸恶梦。常为诸天之所守护。尔时世尊说此祇夜

  若有善男子　　及以诸女人
  闻八佛号名　　忆持为人说
  身心常安隐　　无有诸恐怖
  系念不忘失　　灭无量劫罪
  后生天人中　　远离诸恶趣
  六根常清净　　端正有威德
  八部诸善神　　是夜常守护
  人天所恭敬　　供养生忻喜
  夜叉及非人　　盗贼与刀杖
  水火毒药等　　此畏皆悉无
  卧觉恒安隐　　无有诸恶梦
  利根有智慧　　常乐闻正法
  闻已生信心　　得深妙法者
  口气无臭秽　　精进为他说
  众魔及外道　　无有敢干乱
  女人闻佛名　　忆持为他说
  尽此女人报　　后生不复受
  诵持为人说　　八佛之名号
  得诸功德果　　如上之所说
  是故有智者　　惟当念受持
  一心怀忻喜　　不应起放逸

佛说此经已。长老舍利弗等诸大比丘。并诸菩萨摩诃萨众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。闻佛所说欢喜奉行八吉祥经


谤佛经

    No. 831

谤佛经

        元魏天竺三藏菩提流支译

如是我闻。一时婆伽婆。住王舍城耆阇崛山中。与大比丘众千二百五十人俱。菩萨八十千。尔时会中有菩萨摩诃萨。名离忧悲。在大会坐。师子游戏菩萨摩诃萨。智光明菩萨摩诃萨。梵雷音响云声菩萨摩诃萨。善作功德宝华光明菩萨摩诃萨。师子游步云雷音声菩萨摩诃萨。光明威德名闻菩萨摩诃萨。无边智聚思惟庄严菩萨摩诃萨。无边宝华名称菩萨摩诃萨。智慧光明辩才说意菩萨摩诃萨。此十菩萨摩诃萨集在会坐。已于七年为陀罗尼精勤修习而不能得。满七年已则生忧愁。心尚不定况陀罗尼。所求不得心生疲倦。既于七年离痴覆盖。恒常经行求陀罗尼而不能得。舍戒还家远离佛法作鄙劣行。于佛法中心生疑惑。有如是过。阿阇世王在大会坐

尔时世尊于先已为阿阇世王断除疑悔。阿阇世王既除疑悔。一切忧恼皆得解脱。于七日中舍财大施。如是大施满七日已。为听法故七亿众生俱到佛所。彼十菩萨诸善男子。于佛法中已得罪过。亦在会坐

尔时会中有菩萨摩诃萨。名不畏行。得陀罗尼。阿僧祇劫法忍成就。得无生忍种种辩才。能知一切智智之门。能说法门。能知众生深心信解而为说法

尔时不畏行菩萨摩诃萨。从坐而起整服一厢。右膝着地合掌向佛。白言。大德。此众会中十善男子。已于七年为陀罗尼精勤修行所愿不成。舍离佛法而作俗人。善哉世尊。如方便说。此善男子令速解知

尔时世尊告不畏行菩萨言。善男子。当知如是十善男子。未曾得闻谤佛法门。此善男子曾谤佛来。是故不能速疾得通。尔时不畏行菩萨摩诃萨。即以偈颂问如来曰

  我今问仁曰　　光明之法王
  若行菩萨行　　恶业云何净
  无量胜智名　　十力无障智
  解脱无戏论　　说菩萨净行
  我问无量智　　我问断恶意
  我问无比尊　　云何菩萨行
  已脱一切缚　　离烦恼破魔
  知众生心意　　愿说菩萨行
  如华开笑面　　有有行欲断
  说法断有意　　愿说菩萨行
  能与无量乐　　善功德善行
  于一切世间　　作利益安乐
  已于无量世　　为舍所爱物
  象马宝百头　　无量妻子舍
  以忍自调伏　　乐戒功德行
  决定勤精进　　意常不忧恼
  百种苦已尽　　所求事究竟
  愿如应说法　　除断众生苦
  愿说离三垢　　云何离不善
  愿说菩萨行　　调御益众生

尔时世尊告不畏行菩萨摩诃萨言。善男子。此十菩萨本曾谤佛。不畏行菩萨言。世尊。云何谤佛。佛言。不畏行。此十菩萨乃往过去第三十劫。有佛号曰观世自在如来应正遍知。出焰世界。不畏行。今此会中十善男子。于彼观世自在如来入涅槃后。皆作大姓大富长者。造五百寺。于一一寺置千比丘。时有法师。名曰辩积。得陀罗尼。坐法座上为众说法。五千诸佛皆与辩才。八万亿天守护供养。辩积法师一说法时。七万众生悉皆不退阿耨多罗三藐三菩提。一万众生得须陀洹果。善男子。彼时有王。名曰月得。自共五百婇女相随。俱往供养辩积法师。敬重法故歌声作乐。种种宝花散彼比丘。栴檀等香用涂其身。以五百领好衣覆之。于七日中一切乐具尽心供养。如法师法而供养之

当于尔时彼长者子。说彼比丘毁破净戒。彼恶业报九十千年堕大地狱。于五百世虽生人中受黄门身。生夷人中生邪见家。于六百世生盲无舌。七百世中。虽复出家求陀罗尼而不能得。何以故。以彼往世恶业障故

善男子。汝应善知如是法门。我今已说。既得闻已。若见法师实破戒者。不得生嗔尚不应说。何况耳闻而得说耶。善男子。若有挑拔一切众生眼目罪聚。若以嗔心看法师者。所有恶业过彼罪聚。若断一切诸众生命所有罪聚。若有于法师生于恶心。迳回面顷所得罪聚。彼前罪聚于此罪聚。一百分中不等其一。于千分中亦不等一。于百千分阿僧祇分。若歌罗分。若数分中不等其一。于譬喻分乃至忧波尼沙陀分。不等其一。何以故。若谤法师即是谤佛

善男子。若有悕望供养佛者。彼人则应供养法师。若有悕望供给佛者。彼人则应供给法师。若有悕望礼拜佛者。彼人则应礼拜法师。何以故。以从菩萨生一切智。以从菩萨生诸佛故。善男子。菩萨何曰发菩提心。既发心已不住欲乐烦恼不染。不住一切非梵行事。应如是知。如是菩萨入无色定不生无色。何以故。菩萨不随三昧力生。以愿力生。如是菩萨解脱一切毛道凡夫愚痴人行。若有能见虚空色者。彼人能见菩萨烦恼

善男子。譬如阿那婆达多龙王龙众数摄与一切龙体相无异龙三种过悉皆远离。何等为三。一者热沙不堕其头。二者不以蛇身行欲。三者无有伽楼罗畏。如是善男子。此三龙过所不能于。菩萨摩诃萨亦复如是。一切戏乐皆悉具有。于三有中欲烦恼苦不能覆蔽。应如是知

又善男子。譬如取鱼众生之类于水中行水中见物入水不死。善男子。菩萨摩诃萨亦复如是。行于生死住凡夫行。常求智行修集正法。心不迷乱。凡夫之事所不能污。三有之苦所不能于。是故菩萨摩诃萨。常应自护勿谤法师。尔时世尊。而说偈言

  若欲供养佛　　若欲礼如来
  但供养佛子　　第一供养佛
  我说以衣钵　　坐卧经行处
  如是等应施　　发菩提心者
  如是供养佛　　如是供养法
  佛为世间上　　皆从法中生
  是人孤独智　　与暗眼者明
  示迷者正道　　将向不死处
  若一切财宝　　常施一切佛
  虽如是奉施　　不能报佛恩
  若从今已去　　常供养法师
  不谤不说者　　则报诸佛恩

尔时不畏行菩萨摩诃萨白佛言。世尊。有方便门令此菩萨净恶业不。佛言有。不畏行。有陀罗尼。此善男子。若能出家专心诵此陀罗尼句恶业则净

多轶他(台逻反是长音不言长者尽是短音句)阿制(句)阿车婆坻(句)阿那(长音)毗丽(句)阿施黎杀(诗债反句)阿讫吏帝(句)阿那由系(句)阿系(句)阿毗何(长音)离(句)阿婆(重音不言重者悉是轻音)婆(句)头楼唐鹅磨(句)由多若多(长音)纳波啰颇闭(句)尼伽地(持债反句)忧伽啰系(句)侯侯迷(无诣反句)遮波丽(句)娑迟摩细(句)三摩提(句)余(长音)知(句)那耶波离舒(长音)池(重音)帝(句)

善男子。此十善男子。若能诵此陀罗尼句。于七日中一切放舍。不食杂食心不散乱。不着诸色心不分别。舍憍慢意常诵不止。更无所作不与人杂。行平等心常行利益。心常修习五阴无常而不舍离。常修念佛。若如是行。于十方中现见千佛

尔时彼会十善男子。闻佛说已即尔出家。专心诵此陀罗尼句。七日精进随顺摄取。亦常修习念佛三昧见一千佛。彼恶业障忏悔尽灭。尔时即得一切智门集陀罗尼。灭三十劫生死之业。不退阿耨多罗三藐三菩提

不畏行。当知尔时供养法师月得王者。今无量寿如来应供正遍知是。阿閦如来应正遍知则是尔时辩积法师。尔时谤说辩积法师十长者儿大姓童子。即是此会十善男子。彼十长者大姓童子。尔时谤说辩积法师毁犯净戒

如是善男子。随诸菩萨于何等寺若善恶住乃至失命身死因缘不见其过。何以故。善男子。菩萨具有四种净法。何者四种。一者修空。二者常于一切众生不破坏心。三者于诸菩萨常与利益。四者说法不求资生。善男子。此是四法菩萨摩诃萨清净菩提法。尔时世尊。为明此义。以偈说曰

  若能信解空　　佛说第一法
  如是清净行　　行常不放逸
  不破坏众生　　不说破坏语
  彼人得成佛　　光明照世间
  此第二净道　　闻已作利益
  于众生行忍　　莫作破坏行
  有法善无垢　　施发心菩萨
  若不求恩报　　第三菩提道
  决定生悲心　　说法不求利
  如深心怜愍　　第四道智净

复次善男子。修陀罗尼菩萨摩诃萨。阿兰若行。亲近闻法。着鲜净衣。独住闲居。四威仪中常思惟行。以种种物布施法师。生正信心不随他语。不生疲倦。常精进行心不谕谄。不离念佛心无所得。善修无相如说而行。以信解心请佛忏悔。随喜回向恒常正行。不越威仪不畏教诫。依止尊住一切名行。于此法中不疲倦修

说此法时三万众生本未曾发菩提之心。闻此法已发菩提心。五千众生远尘离垢。于诸法中得法眼净。三万菩萨一切皆得无生法忍

善男子。若诸菩萨摩诃萨等。闻此法门得福甚多。若以七宝满于三千大千世界。于日日中布施三宝。如是乃至恒河沙劫。若复得闻如是法门。其福为胜。若复能行五波罗蜜经一千劫。惟除般若波罗蜜门。若人得闻如是法门。其福为胜。善男子。若复有人于一千佛。晨起日中日暮供养。尊重赞叹如意供给。若有得闻如是法门。其福为胜

如是善男子。应当护念如是法门。我今付汝为令拥护受持读诵。解说其义为令书写。乃至失命身死因缘。应当护念随顺修行。如来说已。不畏行菩萨摩诃萨及余菩萨。彼诸比丘一切众会。并诸天人及阿修罗乾闼婆等闻佛所说。皆大欢喜谤佛经


宝授菩萨菩提行经

    No. 488

宝授菩萨菩提行经

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

如是我闻。一时佛住广严城大林楼阁中。与大苾刍众千二百五十人俱。皆是大阿罗汉。诸漏已尽无复烦恼。逮得己利尽诸有结。除诸重担所作已办。如大龙王。心善解脱慧善解脱。得深解脱心达正道。调伏诸根威仪详审。唯一补特伽罗尊者阿难。受于佛记奉持法藏

复有大菩萨众一千人俱。皆得不退转地总持法门平等法忍。是大智者。具大信重言行相应。断诸疑惑面相圆满。亦无颦蹙常大欢喜具大精进。是法王子。知法自性说法无倦。所说之法离诸戏论。化度众生发起佛智。凡所导利功不唐弃。得大忍辱离诸颠倒境界之法。满足十地善知三时。明了自性不生不灭。永断缠缚威仪具足。证得空三摩地无相三摩地无愿三摩地。虽出生死常行轮回。不乐声闻缘觉之行。唯以发起大菩提心应根说法。其名曰

慈氏菩萨。妙吉祥菩萨。辩积菩萨。宝手菩萨。香光菩萨。无边光菩萨。除盖障菩萨。胜义心菩萨。得光王菩萨。断一切忧暗菩萨。萨哩嚩尾沙摩那哩尸菩萨。内行菩萨。无边意菩萨。具大精进步意菩萨。宝海菩萨。装严王菩萨。具大神通王菩萨。无差步菩萨。胜意菩萨。普满菩萨。阿那嚩啰拏那哩尸菩萨。常喜菩萨。上金光菩萨。观一切法意菩萨。阿秫巘驮那罗拘酥弥多菩萨。首积菩萨。无忧吉祥菩萨。须弥藏菩萨。观自在菩萨。香自在王菩萨。欢喜王菩萨。无边慧藏菩萨。持一切妙法藏菩萨。师子吼音菩萨。如是等大菩萨摩诃萨。而为上首

尔时世尊食时着衣持钵。与二千苾刍众而共围绕。入广严城乞食。是时世尊入城门时。以大慈悲现神通力。放大光明照耀一切。变广严城而为琉璃。令四衢道皆悉清净。其有众生蒙光所照。盲者得视。聋者得听。喑哑之者皆悉能言。迷惑之者咸得正念。天花如雨降满城中。天乐自呜妙音清亮。下至阿鼻地狱。上至阿迦腻吒天。其中众生唯受大乐。是时广严城星贺里蹉尾王。有子名曰宝授年始三岁。乳母抱持在于殿上。时彼宝授忽见光明希瑞之相。又闻城中种种异事。从其怀抱速下于地。向乳母前端然而立。说伽陀曰

  何人威德力　　现此希有相
  如俱胝日光　　照耀三千界
  其中诸恶趣　　一切得清净
  如是之神通　　母速为我说
  天雨众妙花　　遍散于佛刹
  复成妙伞盖　　悬覆于空中
  十方有异鸟　　翔鸣而萃集
  男女皆大喜　　异常而严饰
  盲者复瞻见　　聋者还听闻
  喑哑者得语　　迷惑得正念
  诸丑陋粗恶　　变成妙色相
  一切不善人　　皆发慈悲心
  何人行世间　　发起神通力
  此为最上事　　母速为我说

尔时乳母答宝授童子。说伽陀曰

  功德宝出现　　清净难思议
  清净最上行　　无垢无增减
  世尊为眼目　　视生如的亲
  化行于世间　　无亲疏分别
  为现乞食来　　不住世间相
  不染世间法　　如莲花在水
  能断众生疑　　慈悲常利物
  众生所有苦　　唯佛悉能除
  称赞不生喜　　讥谤亦不嗔
  无障复无碍　　行世如清风
  来者世间师　　最上大法王
  善解甚深法　　明了第一义
  常说中道法　　言离于取舍
  法句最寂静　　远离一切处
  智积无我相　　最上大福聚
  善逝世间解　　来者无边相
  佛身如须弥　　高显无伦匹
  亦如尼俱陀　　上下皆相称
  其色如真金　　晃耀而璨镧
  清净若玻璃　　又如秋满月
  头顶圆如盖　　发鬒而绀青
  髻相若螺纹　　一一皆右旋
  面相如满月　　湛然而清净
  眉间之白毫　　右旋而宛转
  两目如青莲　　光莹善观察
  唇妙频婆果　　齿白正齐密
  舌相如莲叶　　长广覆面门
  鼻高而修直　　额广而平正
  两眉色绀青　　延袤及于耳
  两耳极端正　　轮朵垂至肩
  如来梵音声　　清亮如频伽
  美妙复柔软　　众生闻者喜
  所有紧那罗　　孔雀鹅鹦鹉
  鸲鹆拘枳罗　　拘那罗鸳鸯
  [口*爾]母多命命　　如是等音声
  及彼诸天乐　　一切美妙声
  皆不及如来　　于十六分中
  不及于一分　　项细复圆满
  两臂而佣直　　二手指纤长
  具轮螺等相　　软如兜罗绵
  甲妙赤铜色　　胸臆广平正
  脐轮而深密　　阴藏若马王
  藏覆而不现　　乃至二足下
  其色如红莲　　平满复柔软
  具千辐轮纹　　及与钩幢等
  如是诸相备　　百福悉装严
  具力大丈夫　　一切世间师
  常作师子吼　　说于不二法
  所出诸言辞　　真实无差忒
  爱语复柔顺　　众生闻者喜
  觉悟诸众生　　应根而启发
  有义利功德　　为最上第一
  具如是装严　　名为佛世尊
  十方世界中　　凡圣无有比

尔时宝授童子。得闻乳母说是伽陀赞叹佛已即白母言。云何令我得见于佛。佛知其意速往宫门现身而立。乳母指言斯即是。佛宝授童子。乃于殿上遥见世尊。举手顶礼即作是念

若有众生睹见如来如是具足功德之相。不发大菩提心者难得己利。又复思惟。经于百千俱胝劫中难遇于佛。我今值遇甚为希有。当舍此身而为供养。是时童子。手持千叶金莲。即于殿上投身而下。时彼童子佛力所持住于空中。捧以金莲用献于佛。是时金莲离童子手。乃于佛上虚空之中。变成花盖众宝严饰殊妙第一

尔时宝授童子。即于空中向佛合掌。说伽陀曰

  我所献莲花　　不为断烦恼
  及于一切法　　唯为佛菩提
  如菩提不生　　非有亦非无
  非取亦非舍　　我从佛现化
  非愚迷所著　　相与无相等
  我离一切相　　供养佛世尊
  所获诸功德　　亦离一切相
  今奉献此花　　不愿证二乘
  以彼第一乘　　常转于佛刹

尔时尊者大目干连。侍佛之右。见是事已。即说伽陀。问宝授童子曰

  如是释迦佛　　汝信重供养
  汝何心颠倒　　云菩提不生

尔时宝授。答尊者大目干连。说伽陀曰

  诸法本不生　　所施空无为
  法性本如是　　云何有所生
  圆顶被袈裟　　住于罗汉相
  如不能知空　　佛智何能了
  汝若有妄想　　供养俱胝佛
  虽供如是佛　　实为非供养
  尊者至于今　　犹不断妄想
  汝心当云何　　无相称有相

尔时尊者大目干连。复谓童子曰。如来不证无上正等正觉耶。亦不说法耶。宝授童子曰。夫大智者不住菩提相。不住如来相。诸法性无为法本无有生。若如是了知是即知法性。不惊不怖。舍离亲疏无来无去。无行无相不住佛法。不住缘觉法。不住声闻法。亦不住贪法。不住嗔法。不住痴法。乃至不住愚迷众生无明烦恼等法。亦复不住有色无色有想无想。有相无相。清净不清净。及身口意。平等不平等。一切诸法皆无所住

尔时尊者大目干连又复问言。宝授童子。如来于阿耨多罗三藐三菩提莫有所证耶。童子言不也。若有所证即住如来相。住菩提相。住解脱相。若住是相即为愚迷。大目干连言。童子我亦无相。汝谓有相。大目干连又复告言。童子我前所问为俗谛故。童子言。大目干连。一切众生愚迷虚妄。乃生诸根不能调适。大目干连言。若众生具足虚妄者法亦虚妄。若虚妄者汝云何说。童子言。大目干连。说法无相是名说法。如是说者无有所至亦无所证。亦无所知亦无所见。大目干连言。童子若如是者。汝今何故供养如来。童子言。大目干连。汝若如是见如来相见施者相。时大目干连闻童子言已。默然而住

尔时童子又复告言。大目干连。若复众生见有是相者。不能解脱不得己利。远离如来寂静涅槃。必当发趣声闻乘也

尔时大目干连。说伽陀曰

  童子虽年幼　　智慧如大海
  经于几多时　　学成无生法

尔时宝授童子答大目干连说伽陀曰

  所学即非学　　一切学无性
  大智如是学　　我学亦如是
  汝之所问我　　着于众生相
  众生本无相　　诸法不可得
  说有菩提相　　愚迷非正见
  尊者今云何　　犹住于诸见
  智者于诸见　　一切悉清净
  佛法愚迷法　　及彼种种法
  如是观皆空　　是知诸法性
  若住有无相　　求证菩提者
  法本非有无　　菩提云何得
  说法无边际　　众生亦如是
  不住差别相　　斯即名涅槃
  如是行轮回　　师资无所有
  此无相法中　　智者不迷惑
  愚迷言得证　　彼皆住轮回
  无明转增长　　是即为魔着
  安坐菩提场　　为示俗谛故
  诸佛之所证　　非俗非寂静
  菩提不可说　　远离见非见
  若见如是实　　彼能解妙法

尔时尊者舍利弗白佛言。世尊。此宝授童子。从于何时于法修行。佛言。舍利弗。我初发阿耨多罗三藐三菩提心时。此宝授童子。已证无生法忍经三百千劫

又舍利弗。我于往昔燃灯佛处得授记时。我初证得无生法忍。宝授童子。于彼法中为大菩萨解空第一。舍利弗复白佛言。世尊。宝授菩萨。何因何缘经如是时不证阿耨多罗三藐三菩提

佛告舍利弗。汝将此义自问宝授菩萨必为汝说。时舍利弗承佛圣旨。即伸问言宝授菩萨言。今云何不成佛耶。宝授菩萨言。尊者。阿耨多罗三藐三菩提不可得故。由是我不成佛。舍利弗言。宝授菩萨。于意云何。如来成佛莫有相耶。宝授菩萨言。如来若于菩提有所证者即是取相。若取相者即是妄想。舍利弗言。宝授菩萨。汝从尔来住何忍何行。复以何法化度平等。宝授菩萨言。我于一法而尚不住。何况有四。舍利弗。汝勿谓我有法说耶证菩提耶。是如来耶。得解脱耶。舍利弗言。希有善男子。若能于法如是了知。汝向于佛宜可出家。尔时宝授菩萨。说伽陀曰

  诸有出家者　　多着出家相
  心妄想迷惑　　称谓有所得
  执见于事法　　修行布施因
  欲求无为果　　所证即有为
  不了无相地　　见有生不生
  得与无得相　　谓得甘露味
  是人于佛法　　乃名破法者
  如来释师子　　说法寂无相
  不住心非心　　不住性无性
  若见如是说　　是即见佛说
  若见有相者　　斯人眼非净
  我见非解脱　　智者不应行
  我见即愚迷　　执见有常相
  以自有相见　　谓得于涅槃
  不识梦幻性　　及背空无相
  佛说如是人　　是大无智慧
  又复调诸根　　持戒着禅定
  起于妄想心　　住相迷求果
  此则法中贼　　智者应当知
  以斯种种法　　我出家何益
  法界本湛然　　诸法无分别
  譬如山响等　　智者不见相
  当住于如如　　无别有性相
  若了如是法　　何住出家相

尔时妙吉祥菩萨告宝授菩萨言。云何说为菩提。宝授菩萨言。离诸语言名为菩提。妙吉祥言。汝当云何作如是说。宝授菩萨言。法本无言故作是说

妙吉祥言。为初地菩萨。当何所说令云何学。宝授菩萨言。当如是说。不断贪欲嗔恚。不舍愚痴不断烦恼。乃至五蕴六处等。又复于智慧愚痴不生疑惑。不心念佛不思惟法。不供养众。亦不持戒。不于朋友而求寂静。乃至诸难亦不越度。妙吉祥。当为初地菩萨说如是法令如是学。于意云何。亦复不应于是诸法而有住相。若住相者是为住法。彼即愚迷起生灭法。若于是法说无疑惑。即于法界知其性也。若能如是了法性者。是得名为说菩提也。妙吉祥。若有菩萨闻斯法已不惊不怖。当知是为得不退转

尔时会中有八苾刍。忽闻说此无相正法心不爱乐。出于法会吐血命终。皆堕阿鼻大地狱中

尔时妙吉祥菩萨白佛言。世尊。云何此八苾刍闻此正法乃有如是大恶相耶。佛言。妙吉祥莫作是说。然此苾刍经十千劫。不曾闻法不近善友。是故今日闻此正法心不爱乐。妙吉祥。此八苾刍。当来之世于阿鼻狱中忽思正法。寻便命终生兜率陀天为彼天子。或生人间为转轮王。经六十八劫当得承事十那由他佛。于彼劫后有佛出世。号无垢光如来应供正等正觉。彼无垢光佛。如我今日住广严城广为人天说法授记时彼天子。天耳遥闻说法授记。即与八万天子同诣佛所。到佛所已散众天花遍广严城。供养瞻礼却坐一面。白佛言。世尊。我等随喜乐闻正法。愿佛为说菩提之行。时无垢光如来。为说正法便令发起大菩提心。彼诸天子才发心已。应时皆于阿耨多罗三藐三菩提得不退转。是时广严城中有八万四千人。亦于阿耨多罗三藐三菩提得不退转。复有千二百人。远尘离垢得法眼净

尔时世尊告妙吉祥言。假使菩萨于百千劫。修行六波罗蜜无方便慧。不如暂时闻此正法。何以故。闻此正法功德无量。何况爱乐听受。乃至书写受持读诵为他广说。妙吉祥。若复有人乐求阿罗汉果。及乐求辟支佛者于此法中不应修学。若乐求阿耨多罗三藐三菩提者当学此法

尔时宝授菩萨知佛世尊及苾刍众未有食处。乃告乳母。可于宫中速取食来用施佛僧。于是乳母。速取百味饮食盛满一器。授与宝授菩萨。菩萨得食即于佛前发誓愿言。如来之所说一切法无尽。斯言真实者此食亦无尽。乃至苾刍众悉令得饱足

尔时宝授菩萨。即以饮食盛满一钵。奉献佛已。告诸苾刍言。尊者慈愍我故各各受食。又复告言。我所施者。不以身施不以心施。离于三业不求福果。不住有为法不住无为法。亦不着世法。亦复不住声闻缘觉及佛菩提。时彼苾刍众无有一人伸钵受食者。宝授菩萨言。诸尊者当受此食。尊者乐乞我今乐施。我于尊者亦无所求。时宝授菩萨复发愿言。佛语真实。如妙吉祥及百千俱胝菩萨。当来之世。于功德装严王佛刹。皆得成佛同一名号。若真实者。今此器中所有饮食。令诸苾刍所持之钵悉皆充满。此器中食愿得无尽。以愿力故。诸苾刍众各各钵中自然食满。时宝授菩萨。复以器中余食。施广严城中一切人民悉令饱满。器中饮食犹尚不尽

尔时世尊告宝授菩萨曰。有五种宝。于菩萨行施能令清净。何等为五。一者行施无有希望。二者于施心无所著。三者所施不起于相。四者不见施之果报。五者不令受者有所还报。佛言。复有四种宝行施。菩萨应常思念。何等为四。一者常念空三摩地。二者常念于佛。三者常念大悲。四者常念于己不求果报。菩萨若如是行施是为净施

佛告妙吉祥言。此宝授菩萨。于当来世过三十劫。得成阿耨多罗三藐三菩提。号不空力称如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。出兴于世。彼佛众会有无边菩萨。是诸菩萨皆住不退转地。威力无边寿亦无量

尔时世尊及大苾刍众。受彼食已还归本处

尔时妙吉祥菩萨白佛言。世尊。当何名此经。我等云何受持。佛言。此经名为菩提行。亦名一切法为首。如是受持

佛说此经已。宝授菩萨并诸大众。天人阿修罗乾闼婆等。闻佛所说皆大欢喜。信受奉行宝授菩萨菩提行经


宝云经

    No. 658 [No. 659]

宝云经卷第一

        梁扶南三藏曼陀罗仙译

如是我闻。一时佛在伽耶山顶。与大比丘僧七万人俱。所作已办舍诸重担其心自在。尽诸有结正见解脱。皆如大龙善解法界。是法王子能舍利养。善具出家善受具戒。意所欲者悉得满足住涅槃道。唯除阿难在于学地。诸大菩萨八万四千人俱。皆是一生补处。向一切智无有退转。志求佛地近于彼岸。得阿僧祇诸陀罗尼。逮得诸禅首楞严三昧。游戏神通。大慈大悲遍满十方乃至无量无边佛土行空境界。除诸盖障尽三毒根。善游无相室宅。恒欲救济一切众生。善知诸佛世界。得无碍智。心如虚空深广如海。犹如须弥八风不动。心如莲华不着尘水。意如真宝内外明彻。如净真金中无瑕秽。其名曰宝光菩萨。宝掌菩萨。宝印手菩萨。宝天冠菩萨。宝鬘菩萨。宝积菩萨。宝藏菩萨。宝山顶菩萨。宝幢菩萨。金刚胎菩萨。金胎菩萨。宝胎菩萨。功德胎菩萨。净无垢胎菩萨。如来胎菩萨。智胎菩萨。日胎菩萨。三昧胎菩萨。莲华胎菩萨。解脱月菩萨。普月菩萨。观世音菩萨。普贤菩萨。普眼菩萨。莲花眼菩萨。大眼菩萨。普威仪菩萨。普端严菩萨。普行菩萨。知定意菩萨。法意菩萨。胜意菩萨。增长意菩萨。金刚意菩萨。师子神通菩萨。大音声王菩萨。师子吼意菩萨。深音声菩萨。无染污菩萨。离一切垢菩萨。月光菩萨。日光菩萨。智光菩萨。智功德菩萨。月功德菩萨。莲花功德菩萨。宝功德菩萨。文殊师利菩萨。跋陀婆罗等十六贤士。贤劫千菩萨摩诃萨等。弥勒最为上首。四天王诸天等。四天王最为上首。忉利诸天等。帝释最为上首。焰摩天焰摩天王最为上首。兜率陀天兜率陀天王最为上首。化乐诸天化乐天王最为上首。他化自在诸天他化自在天王最为上首。善党诸天萨陀最为上首。一切诸梵天王大梵最为上首。首陀会诸天摩醯首罗最为上首。毗摩质多罗阿修罗王。婆稚阿修罗王。罗睺阿修罗王等。无量百千亿阿修罗王。阿那婆达多龙王。摩那斯龙王。娑伽罗龙王。难陀龙王。和修吉龙王。德叉迦龙王。如是等百千亿诸龙及诸龙子诸龙彩女。如是等百千万亿众。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。百千亿众皆来集会。尔时伽耶山顶方四由旬。微尘针锋虚空及地大众充满。悉敷师子座。庄严光显高一由旬。严饰第一广半由旬。八千天衣遍布其上。地悉平正变为金刚。悬诸缯幡香汁洒地。无量天花遍满在中。其座左右生诸莲花大如车轮。百千万叶真金为茎。皆以绀琉璃为台。因陀尼为鬘。香洁适意触时快乐。如是妙花以供养佛。彼师子座于其四角各生宝树。高十五里。其树荫盖及半由旬。如是庄严师子之座。佛坐其上心意清净。善转法轮降伏魔怨。不为八法之所污染。得无所畏智辩无滞。心无怯弱犹如师子。意行清净如明渊池。深广如海能出众宝。犹如须弥处于大海。如日盛明照于一切。如月盛满悉令清净。雨大法雨如彼龙王。处众高显如大梵天。无量弟子悉皆调顺。无量释梵四天王等。瞻仰观佛心无高下。能令大众温光如日众宝庄严。尔时世尊身色熙怡。如日温照一切大众。如宝庄严。顶上放光名曰周遍。普照百千世界。无量诸光以为眷属。俱照十方绕佛三匝。光从口入而口无异相。譬如净月明照虚空。然于虚空亦无异相。光从口入亦复如是。譬如沙聚苏油注中不见增损。佛光入口亦复如是

尔时东方过无量恒河沙世界有国。名莲华自在。彼世界有佛。名莲华眼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸菩萨说一乘法。彼国无有声闻辟支佛名。时诸众生皆得阿鞞跋致。趣向阿耨多罗三藐三菩提。此诸众生无有揣食。唯有法喜禅悦等食。彼国虽有日月星辰不以为明。唯有佛光照于彼土。无有山林株杭荆棘地平如掌。彼有菩萨摩诃萨名除一切盖障。闻其名者一切罪障皆悉除灭。时除盖障菩萨摩诃萨。蒙光触身。即诣莲华眼佛所。头面着地为佛作礼。却住一面坐莲华上。复有无量菩萨。亦蒙光明。往诣佛所头面着地。顶礼佛足却坐一面。除盖障菩萨。从坐而起整其衣服。偏袒右肩右膝着地。合掌向佛而白佛言。世尊。以何因缘有斯光明。遇斯光者心意快乐。如是之光从何而来。莲华眼佛答言。善男子。西方有世界名娑婆。佛号曰释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。闻彼佛名皆得阿鞞跋致。如是之光彼佛所放。除盖障菩萨复白佛言。世尊。以何因缘。闻彼佛名皆得阿鞞跋致趣阿耨多罗三藐三菩提。莲华眼佛复告除盖障菩萨言。彼佛行菩萨道时发大誓愿。若我成佛闻其名者。皆发阿耨多罗三藐三菩提心得阿鞞跋致。除盖障菩萨复白佛言。世尊。若闻彼佛名皆发阿耨多罗三藐三菩提得阿鞞跋致者。彼国众生皆已得不。莲华眼佛答言。善男子。有得不得。除盖障菩萨复白佛言。世尊。彼国众生可不闻耶。莲华眼佛答言。善男子。亦得闻名。除盖障菩萨白佛言。世尊。如其闻者云何有得不得。莲华眼佛答言。善男子。彼国众生悉是阿鞞跋致。亦非阿鞞跋致。除盖障菩萨白佛言。世尊。云何悉是阿鞞跋致亦非阿鞞跋致。莲华眼佛答言。善男子。闻彼佛名者虽得阿鞞跋致种子因缘。不具行未满足不得受记。善男子。我今为汝说喻。譬如种树有其种子离于腐败具足生牙因缘。当言为生为不生耶。除盖障菩萨白佛言。世尊。是名为生。莲华眼佛答言。善男子。闻佛名者得其种子。具足因缘便得受记。除盖障菩萨摩诃萨白佛言。世尊。我欲往娑婆世界礼拜恭敬释迦牟尼佛。莲华眼佛即便答言。善男子。今正是时可往礼拜。彼诸菩萨白佛言。世尊。我等亦当随从除盖障菩萨往诣娑婆世界礼拜恭敬尊重赞叹。莲华眼佛告诸菩萨言。今正是时可往诣彼。莫生下劣放逸之心。何以故。彼界众生多诸贪欲嗔恚愚痴。不肯恭敬沙门婆罗门。好作非法。心意粗弊恶口骂詈。佷悷难调悭贪嫉妒。懈怠懒堕放逸破戒。无量烦恼之所缚缠。于恶生中而为说法。尔时彼诸菩萨白佛言。世尊。释迦牟尼佛甚为希有。能于彼恶世界众生中而为说法。莲华眼佛答言。善男子。彼佛世尊实为希有。如汝所言。常处恶众生中而为演法。彼恶世界能起一念善心者此亦难有。何以故。清净世界众生。守信修善不难。恶世界中于弹指顷发生信心归依佛法僧。于弹指顷能修持戒。于弹指顷生离欲心。于弹指顷生于慈悲发阿耨多罗三藐三菩提心。此则甚难诸菩萨。白佛言。希有世尊。希有善逝。尔时诸菩萨。除盖障菩萨摩诃萨最为上首。尔时除盖障菩萨摩诃萨并诸菩萨。受佛教已欢喜踊跃。顶礼佛足各还本坐。此诸菩萨有赍宝树华果具足。有赍琉璃树者。有赍颇梨树者。有赍金树者。有赍众宝树者。有赍华树者。有赍果树者。有赍衣云者。有赍环玔璎珞者。有赍香云者。有赍华鬘云者。有赍宝盖云者。有赍宝幢幡云者。有赍音乐云者。悉皆来集。除盖障菩萨摩诃萨。所共诣娑婆世界。除盖障菩萨摩诃萨告众菩萨言。彼娑婆世界众生多受苦恼。汝等各各现神通力。令彼众生使得快乐。时诸菩萨皆言唯然。尔时除盖障菩萨摩诃萨以神通力身出光明清净无垢。遍照娑婆三千大千世界。此光能照地狱饿鬼畜生阎罗王趣。诸苦恼者蒙光触身身受快乐。贪欲嗔恚悉令除灭。慈心相向犹如父母。三千大千世界诸闇冥处。日月诸光所不及处。以菩萨光故皆得相见。三千大千世界铁围山大铁围山。目真邻陀山摩诃目真邻陀山。及诸余山幽冥之处悉蒙光照。上及梵天。下至阿鼻地狱。如是中间光明普照。又诸菩萨皆放身光。蒙其光者。饿者得食。渴者得饮。裸者得衣。贫者得财。盲者能视。聋者能听。哑者能言。躄者能行。狂者得正。苦者能乐。诸怀孕者令安隐产。当尔之时众苦悉除。共诸菩萨俱时而到伽耶山顶。宝网弥覆三千大千世界。于虚空中莲华云雨莲华。妙果云雨妙果。华鬘云雨华鬘。香云雨香。白叠云雨白叠。末香云雨末香。衣服云雨衣服。宝盖云雨宝盖。宝幢云雨宝幢。宝幡云雨宝幡。如是众云随种而雨。雨触身时柔软快乐。尔时伽耶山。坑坎堆阜自然平坦。诸山树木变为宝林。亦作栴檀沉水及诸香树。周遍严饰。百千天乐于虚空中不鼓自鸣。诸乐音中俱出偈颂

  生于林毗罗　　不由结业有
  挺特无有比　　我今礼于彼
  心平如虚空　　至于伽耶山
  我今归最妙　　无上胜菩提
  坐于道树下　　始悟于正觉
  指地以为证　　魔怨皆退散
  我今到伽耶　　稽首无垢尊
  世间皆幻化　　亦如沫泡炎
  虚诳如水月　　法相亦如是
  我今来至此　　敬礼正智树
  譬如伎艺人　　能现诸权变
  诸法若干种　　譬如天马红
  稽首礼不动　　功德之伏藏
  我今从彼来　　敬礼无上尊
  深起大悲心　　无量百千劫
  修于戒定慧　　积集诸善业
  我今从彼来　　礼于净月面
  百千亿菩萨　　无量诸天众
  皆从彼而来　　为礼除闇尊
  获得法伏藏　　慈悲为众演
  能作利益者　　最是无等尊
  我今从彼来　　稽首于正觉
  慈悲济众生　　寂静而憺怕
  莲华不着水　　烦恼不染心
  我今来归命　　礼此最胜德
  清净身无垢　　众相开花敷
  八十好为果　　世间得依怙
  我今从彼来　　稽首于宝树
  具无量枝条　　我等悉供养

尔时尊者目连从坐而起。长跪合掌偏袒右肩。白佛言。世尊。我今不见其形而闻众妙偈颂。佛告目连。东方过此无量恒河沙佛土。莲华世界有佛名为莲华净眼。今现在彼为大众说法。彼有菩萨摩诃萨名除盖障。复有无量百千亿菩萨。皆来至此娑婆世界。为欲礼拜恭敬于我至心听法故。彼诸菩萨造此偈颂。佛语以讫。彼诸菩萨即到佛前。除盖障菩萨摩诃萨最为上首。皆共头面顶礼佛足。却住一面合掌向佛。以偈赞曰

  归命大名称　　具足智慧者
  归命大精进　　最胜牟尼尊
  能拔于三有　　越渡烦恼岸
  神光照世间　　归命无等尊
  四方蒙光照　　周遍悉解脱
  归命无等称　　不动如山王
  深广如大海　　智慧无有量
  一切诸外道　　无能扰乱者
  我今稽首礼　　归命于法王
  第一寂灭道　　无生亦无灭
  体相如涅槃　　归依说法王
  能转法轮者　　显现于正道
  安住于真谛　　开演于涅槃
  而授菩提记　　善知于法相
  及以烦恼性　　如说而修行
  观察于律仪　　贪欲诸嗔恚
  无量心垢秽　　一切诸尘障
  于菩提树下　　智火悉烧尽
  济度于众生　　自度亦度彼
  生死旷野中　　勉济诸众生
  长寝于重昏　　三有之狱缚
  劝令早觉悟　　趣向归依处
  当为作亲友　　究竟不放逸
  随从而来者　　皆住于菩提
  为欲听正法　　愿时而解脱

尔时除盖障菩萨摩诃萨。偈赞佛已。佛告诸菩萨各还本坐。除盖障菩萨摩诃萨及诸菩萨。皆坐莲华台上。除盖障菩萨摩诃萨。从坐而起整其衣服。偏袒右肩右膝着地。合掌向佛而白佛言。世尊。欲有所问唯愿听许。佛即答言。若有疑者随汝所问。我当为汝分别解说。除盖障菩萨白佛言。世尊。云何菩萨。具足于施。具足于戒。具足于忍。具足精进。具足禅定。具足智慧。具足方便。具足于愿。具足于力。具足于智。云何菩萨与地等。云何菩萨与水等。云何菩萨与火等。云何菩萨与虚空等。云何菩萨如月。云何菩萨如日。云何菩萨如师子。云何菩萨为善调。云何菩萨为善御。云何菩萨如莲华。云何菩萨得大意。云何菩萨得净意。云何菩萨得无疑网心。云何菩萨甚深如大海。云何菩萨得微细智。云何菩萨得随顺辩。云何菩萨得无尽辩。云何菩萨得净辩。云何菩萨能令众生得少欲知足。云何菩萨得随应辩。云何菩萨作法师。云何菩萨得随顺法。云何菩萨得善解法界。云何菩萨行空境界。云何菩萨行无相境界。云何菩萨行无愿境界。云何菩萨行慈。云何菩萨行悲。云何菩萨行喜。云何菩萨行舍。云何菩萨得游戏神通。云何菩萨得离八难处。云何菩萨得不忘菩提心。云何菩萨得宿命智。云何菩萨得不离善知识。云何菩萨得离恶知识。云何菩萨得佛清净身。云何菩萨得金刚身。云何菩萨得大商主。云何菩萨得善知诸道。云何菩萨得示不颠倒道。云何菩萨常得定心。云何菩萨得粪扫衣。云何菩萨得三衣。云何菩萨得旃衣。云何菩萨得乞食法。云何菩萨得一坐食法。云何菩萨得一受食法。云何菩萨得非食后食。云何菩萨得阿练若行。云何菩萨得树下坐。云何菩萨得露地坐。云何菩萨在冢间行。云何菩萨常坐不卧。云何菩萨能随敷坐。云何菩萨善知教授禅法。云何菩萨能持修多罗。云何菩萨能持律藏。云何菩萨能持威仪。云何菩萨善知可行处。云何菩萨善知修行法。云何菩萨除于贪嫉。云何菩萨于一切众生能起等心。云何菩萨善知供养如来。云何菩萨除于憍慢。云何菩萨善得信敬心。云何菩萨善解第一义谛。云何菩萨善知十二因缘。云何菩萨善知己体相。云何菩萨善知世间相。云何菩萨生净佛国土。云何菩萨处胎不污。云何菩萨舍家出家。云何菩萨得清净命。云何菩萨心不愁恼。云何菩萨善随佛教。云何菩萨常和颜语舍离颦蹙。云何菩萨具足多闻。云何菩萨善持正法。云何菩萨作法王子。云何菩萨为四天王帝释梵天之所供养。云何菩萨知他体相。云何菩萨善知成熟众生。云何菩萨善修柔和行。云何菩萨共住安乐。云何菩萨善修四摄法。云何菩萨得威仪端正。云何菩萨善为众生作依凭处。云何菩萨喻如药树。云何菩萨常修诸善。云何菩萨善作变化。云何菩萨摩诃萨速成阿耨多罗三藐三菩提

佛告除盖障菩萨摩诃萨。善哉善哉。善男子。汝欲利益天人拔济一切众生故发是问。我今当为汝说。除盖障菩萨摩诃萨白佛言。善哉世尊。愿时演说。佛即告言。善男子。我今当说汝等谛听。菩萨成就十法能具足檀。何等为十。法施具足。无畏施具足。财施具足。不望报施具足。怜愍施具足。不轻心施具足。尊重施具足。恭敬承事施具足。不求有施具足。清净施具足。善男子。云何名菩萨法施具足无悕望心。自受持法为人演说。不求利养不为名誉。为除一切众生过恶不为于利。心无高下平等说法。若为王若王等旃陀罗等说法等无差别。不以此施贡高憍慢。若能如是。是名菩萨法施具足。云何名菩萨无畏施具足。菩萨自离刀杖亦教人离刀杖于一切众生生父母想男女想亲友想。何以故。佛说一切众生从无始劫来无非父母男女。菩萨常于微细中舍身而与。况复余大众生是名菩萨无畏施具足。云何名菩萨财施具足。菩萨见众生多作诸恶。便积聚财宝而施与之。令离恶业安置善处。又闻佛世尊作如是说。檀是菩萨能除悭贪嫉妒之垢。如佛所说习行于施。不以施故而心自高。是名菩萨财施满足。云何名菩萨不望报施具足不为得眷属故施。不为得亲友故施。不为欲故施。菩萨作是念施。菩萨净戒是常行法。以是因缘故。是名菩萨不望报施具足。云何名菩萨成就怜愍施具足。菩萨见众生饥渴受苦裸形弊衣无所依怙无归无趣无居住处离于福业。便生殷重怜愍之心。我今为苦众生故发阿耨多罗三藐三菩提心但以众生轮转受苦裸形弊衣无怙无归无趣饥寒困苦。我当何时为是众生。作衣服饮食乃至归依舍宅。现有财物悉施与之。虽作是施而不生念存有我人财物等想。如是施者。是名菩萨怜愍施具足。云何名菩萨不轻心施具足。不分别施。等大悲施。不轻心施。心不吝惜施。不嗔忿施。不憍逸施。不为得名称施。不为我能多闻故施。如是之施。名为专心施尊重施恭敬施自手施。如此等施。是名菩萨不轻心施具足。云何名菩萨承事施具足。若同梵行可尊事者。若和尚阿阇梨等。如是之人深生殷重。起迎合掌瞻仰恭敬。若有所作躬代营佐。如是施者。是名菩萨承事施具足。云何名菩萨恭敬施具足。供养佛供养法供养僧。香华伎乐绕如来塔涂扫佛地。若诸塔庙朽故崩落修治严饰。如是名为恭敬佛。恭敬法者。听法读诵受持书写解说。思惟其义如法修行。不颠倒取义。是名恭敬法。恭敬僧者。衣服饮食卧具汤药种种杂物。供给所须奉施于僧。乃至贫下无所有时。当用净水敬心持施。如此施者名恭敬僧施。若能如是供养三宝。是名菩萨恭敬施具足。云何名菩萨不求有施具足。菩萨施时不生是念。我当生天。亦不生念。我当为王及诸辅相大臣官属。是名菩萨不求有施具足。云何名菩萨清净施具足。菩萨谛观此施。无垢无秽无杂。如是施者。是名菩萨清净施具足。善男子。具此十事。是名菩萨具足于檀。善男子。菩萨复有十法名成就净戒。何等为十。善学波罗提木叉戒善持菩萨致密戒灭诸烦恼除不善觉。怖畏恶业。于小罪中尚生惊怖心常恐畏。受持头陀法坚固不阙。持戒不为求有造业。净三业戒。云何名菩萨善学波罗提木叉戒。菩萨于戒律诸经是佛所制。皆专心受持。不为种族故持戒。不为我见故持戒。不为摄徒众故持戒。不见他瑕缺而轻毁戒。是名菩萨善持波罗提木叉戒。云何名菩萨善持致密戒。菩萨作是念。非但波罗提木叉戒。能使我成阿耨多罗三藐三菩提。诸余菩萨威仪戒行。我亦当学如法修行。云何是菩萨戒。菩萨不应行处终不往来。非时不语善知时节。善知方俗顺适人心。不令众生起于讥嫌。善护众生令至菩提。亦自具足菩提威仪。言辞柔软少于言说。不好亲近大臣群官。恒修阿练若行。和颜悦色。能具如是菩萨威仪戒。及余经中诸菩萨戒悉具修行。是名菩萨致密戒。云何名菩萨灭一切结使皆悉燋然。贪欲嗔恚愚痴及余缠障一切众具亦皆燋然。于贪欲处生对治法。能起欲处皆悉除断。云何是贪欲处于美色边能起欲因缘。云何名不净想。如观己身发毛爪齿皮肤血肉筋脉骨髓汗泪涕唾肪膏脑膜咽喉心胆肝肺脾肾肠胃百[月*葉]生藏熟藏屎尿脓汁。菩萨常观三十六物。若能如是不生贪心。若愚痴婴儿颠狂心乱。见是三十六物。犹不起欲想。况复智者诸菩萨等常观是不净。云何当复起于欲想。菩萨摩诃萨。见所爱色适意之时便生染心。初见色时即自念言。如佛所说。色如梦响无有实事。云何智者妄于梦中而生欲想。是故菩萨能生欲处悉皆远离。云何菩萨。于可嗔中生对治法。而能离嗔及嗔因缘。菩萨于诸众生常生慈心。以是因缘便得除嗔。若有恼害因缘嗔恚起时。当深系念对治之法。是名菩萨除嗔方便。云何菩萨除痴方便。当念痴心不识善恶。常守愚闇后受苦果。无智自蔽恼他缘少。不如贪嗔多有怨害。如是观时则灭痴心。是名菩萨燋然烦恼。云何名菩萨除不善觉。住于空静阿练若处。作如是念。我今远离于愦闹处。在闲静地履行佛教。诸余沙门婆罗门。亲近愦闹多有扰乱远离佛教。是名菩萨除不善觉。云何名菩萨怖畏恶业。观察选择曾闻佛说。专心修福坚持净戒善学智慧。以何因故最得胜报。具福德业远离诸恶。是名菩萨怖畏恶业。云何名菩萨畏于微恶。于小罪边常生大畏心。终不轻微小之恶。以何因缘曾闻佛说。少毒杀人况复多毒。微细恶中尚能将人至三恶道。况复多恶而心不畏。是名菩萨畏微小恶。云何名菩萨心常恐畏。为人体信婆罗门刹利居士等。以体信故即寄金银种种珍宝。信心用付不立时证。菩萨终不生于隐匿之心。若佛物法物僧祇物四方僧物。菩萨宁当自食己肉终不侵他。若饮若食供身之具不敢辄毁。是名菩萨心常恐畏。云何名菩萨受持头陀法坚固不阙。若魔眷属及诸天等。以妙财色欲来扰逼菩萨。菩萨即时志固不动而心不毁。是名菩萨受持头陀法坚固不阙。云何名菩萨持戒不为求有造业。菩萨持戒不求世间果报。但为满足一切善法得无上道。是名菩萨持戒不为求有造业。云何名菩萨净于三业。云何净身业。离杀盗淫。以是义故名为净身业。云何净于口业。离恶口妄言两舌绮语。是故名为净于口业。云何净于意业除贪嗔痴邪见。是名净于意业。是名为菩萨净于三业。善男子。具此十事。是名菩萨成就净戒

善男子。菩萨摩诃萨。复有十法能净于忍。何等为十。内忍。外忍。法忍。随佛教忍。无方所忍。修处处忍。非所为忍。不逼恼忍。悲心忍。誓愿忍。云何名菩萨内忍。菩萨饥渴寒热忧悲疼痛身心楚切。能自忍受不为苦恼。是名菩萨内忍。云何名菩萨外忍。菩萨从他闻恶言骂詈毁辱诽谤。或毁辱父母兄弟姊妹眷属和上阿阇梨师徒同学。或闻毁佛法僧有。如是种种毁訾菩萨。忍辱不生嗔恚。是名菩萨外忍。云何名菩萨法忍。佛于诸经说微妙义。诸法寂静诸法寂灭。如涅槃相不惊不怖。菩萨作是念言。我若不解是经不知是法。终不得阿耨多罗三藐三菩提。是故菩萨勤求咨问读诵。是名菩萨法忍。云何名菩萨随佛教忍。菩萨嗔恼毒心起时。作是思惟。此身从何而生从何而灭。从我生者何者是我。从彼生者何者是彼。法相如是从何因缘起。菩萨作是思惟时。不见所从生亦不见所缘起。亦不见从我生。亦不见从彼起。亦不见从因缘生。作是思惟。亦不嗔亦不恼亦不毒。嗔怒之心即便减少。是名菩萨随佛教忍。云何名菩萨无方所忍。或有夜忍昼不忍。或昼忍夜不忍。或彼方忍此方不忍。或此方忍彼方不忍。或知识边忍不知识边不忍。或不知识边忍知识边不忍。菩萨不尔。于一切时一切方常生忍心。是名菩萨无方所忍。云何名菩萨修处处忍。有人于父母师长夫妻男女大小内外如是中生忍。余则不忍。菩萨忍者则不如是。如父母边生忍。旃陀罗边生忍亦尔。是名菩萨修处处忍。云何名菩萨非所为忍。不以事故生忍。不以利故生忍。不以畏故生忍。不以受他恩故生忍。不以相亲友故生忍。不以愧赧故生忍。菩萨常修于忍。是名菩萨非所为忍。善男子。云何名菩萨不逼恼忍若嗔因缘烦恼未起不名为忍。若遇嗔因缘时。拳打刀杖手脚蹴蹋恶口骂詈。于如是中心不动者则名为忍。菩萨若有人来起发嗔恚亦忍。不起发嗔恚亦忍。是名菩萨不逼恼忍。云何名菩萨悲心忍。尔时菩萨。若作王若王等有大功业。为苦众生而作其主。是苦众生若来骂辱触恼之时。菩萨不以我是主故而生嗔恚。如是众生我当拔济常为拥护。云何而得生于嗔恼。是故我今悲心怜愍不生忿恚。是名菩萨悲心忍。云何名菩萨誓愿忍。菩萨作是念。我先于诸佛前曾作师子吼发誓愿言。我当成佛于一切生死淤泥中为拔诸苦众生。我今欲拔不应嗔恚而恼于彼。若我不忍尚不自度况利众生。善男子。譬如良医善知治眼。见诸众生多有患目。或患眼翳或患眼膜。种种患眼不可称计。是医若言。我欲疗治众生眼患。彼时医师后自盲冥。佛言。如此医师能治他眼不。除盖障菩萨摩诃萨白佛言。不也世尊。佛告除盖障菩萨摩诃萨。欲除一切众生无明冥者。应先自除闇障后及于人。若内无智慧能治他疾。是义不然。以是因缘。当修于忍不应生嗔。是名菩萨大誓愿忍。善男子。具此十事是名菩萨能净于忍。善男子。菩萨复有十法。名为精进满足。何等为十。如金刚精进。无等精进。处中精进。显胜精进。炽盛精进。常恒精进。清净精进。不共二乘精进。不轻贱精进。不退转精进。云何菩萨如金刚精进。未解者令解。未涅槃者令得涅槃。未安者令安。未度者令度。未得阿耨多罗三藐三菩提者。当令得阿耨多罗三藐三菩提。若作如是修行精进时。天魔波旬来谓菩萨言。汝今何故作如是精进。徒自勤苦终无所获。何以故。我亦曾作如是精进。未解者令解。未涅槃者令得涅槃。未安者令安。未度者令度。未得阿耨多罗三藐三菩提者。当令悉得如是等事。皆是妄语但诳凡愚无有真实。我未曾见如是精进而得阿耨多罗三藐三菩提者。善男子。我曾见无量众生如是精进有得阿罗汉涅槃。如是精进有得辟支佛涅槃。魔王复言。善男子。虽行精进未有得阿耨多罗三藐三菩提。汝今思惟疾舍是心。空无所获徒自劳苦。汝今速求二乘。可得早离生死。菩萨即作是念。此是魔说欲坏我心。汝但少事而自忧己。莫为多事反忧我耶。随所造业各得受报。依止于业业为亲友。汝亦有此随业受报。依止于业业为亲属。恶魔波旬。汝今速疾复道还去。汝恼我故当长夜受苦。魔即惭愧隐形而去。是名菩萨如金刚精进魔不能坏。云何名菩萨无等精进。尔时菩萨所行精进。超诸菩萨百千万亿算数譬喻所不能及。况余声闻二乘学者而能及乎。一切诸佛善法。以精进力故悉能摄取。一切恶法无不舍离。是则名为无等精进。云何名菩萨处中精进。勤不过分亦不懈退。如是精进名为处中精进。云何名菩萨高胜精进。菩萨发大精进。愿使现身如佛色相。若我得佛。无见顶相圆光一寻。佛之相好无碍智慧大自在者愿我悉得。是名高胜精进。云何名菩萨炽盛精进。譬如真金摩尼珠宝无有垢秽。光明炽盛端严殊显。真金精曜无量焰炽。摩尼宝珠焕然炳彻。菩萨精进亦复如是。无诸垢秽。何者是精进垢。何者是精进翳。懈怠是精进垢。懒堕是精进翳。食不知足是精进垢。贪嗜睡眠是精进翳。好乐亲近是精进垢。不见无我是精进障。如是名为精进垢精进障。除如是垢障。是名菩萨炽盛精进。善男子。云何名菩萨常恒精进。举动威仪不离精进。行住坐卧不曾休废身心不懈。是名菩萨常恒精进。云何名菩萨清净精进。如上常恒精进。有所起恶不善之业能障道法能作衰损。皆悉除断一切善法于涅槃因不作障碍。能助道法安止道处。皆悉修广增长炽盛。乃至微细一念之恶不令得起况复大恶。是名菩萨清净精进。云何名菩萨不共二乘精进。菩萨摩诃萨。周遍十方。如恒河沙数世界满中阿鼻地狱猛火炽盛。如此世界外。有极苦众生无依无救。乃至若一众生如是苦恼。菩萨能忍大火。过无量恒河沙世界。拔济成熟一众生苦。为一尚尔。况多众生而不救济。一切外道二乘学人所不能及。是名菩萨不共二乘精进。云何名菩萨不自轻贱精进。菩萨作是思惟。三世诸佛。皆从微少精进修无量德。乃能久积苦行成等正觉。是故我今因少精进渐殖德本。不久亦应得佛不疑。是名菩萨不自轻贱精进。云何名菩萨不退转精进。菩萨不以己身精进微薄。不以贫穷又少财宝而生舍心。常修精进向阿耨多罗三藐三菩提。过去未来现在三世诸佛。皆以积善微细精进悉得菩提。我今不以微贱而自轻毁。以微精进故。为一切众生积集众善。成阿耨多罗三藐三菩提。不为己乐而入涅槃。宁为众生久处地狱。是名菩萨不退转精进。善男子。具此十事。是名菩萨满足精进

宝云经卷第一宝云经卷第二

        梁扶南三藏曼陀罗仙译

善男子。菩萨摩诃萨。复有十法名具禅波罗蜜。何等为十。多集福德深厌诸恶。能勤精进具于多闻。不颠倒解解法向法。利根聪明有纯善心。善解定智不着禅相。云何名为多集福德。久于大乘积集善根。在所生处常护持善戒遇善知识。世世恒生种族刹利大姓婆罗门大家居士。生处恒生正见家增长善法。忆所修善方便不舍。常不离善知识菩萨诸佛。渐渐增长观察诸法。世间大苦常为灾患之所逼恼。无有暂停长为众苦。无明所盲皆因爱欲欲为根本。我今不应同于凡夫亲近于欲。欲者诸佛世尊说从妄想生。无量因缘毁訾过患。譬如以木贯人心肾。欲如利戟欲如剑刃欲如毒蛇欲如锋焰。欲如脓烂不可触近。欲如聚沫欲如热焰。欲如幻化欲如梦想。欲为不净令人臭秽。欲如熟痈欲如腐败烂肉。作如是厌恶欲想。剃除须发舍离产业。出家学道被服法衣。而作沙门。正法出家信家非家。出家学道发大精进。未得善法者能令使得。未得智者能令得智。未得证者当令得证。如是因如是缘。以是事故即得多闻。于世谛第一义谛悉能宣说。善知世谛即第一义谛。善知不颠倒法如法体相。何者是善知法相。正见正志正语正业正命正方便正念正定。得见正道。利根转胜心常在道。以利根故多生厌恶。远离大众愦闹之处。远离欲觉贪嗔邪见残害之心。远离眷属。远离名闻利养。远离一切身心。常念自观察己心。为念善不善无记。若念善应念胜善。念胜善者。心生欢喜起发信乐。云何是胜善心。三十七品。云何是三十七品。四念处四正勤四如意足。五根五力。七觉分八正道法是名胜善是真道支。心犹不善极生厌恶多作观察。勤行方便断于不善。何等不善。贪欲嗔恚愚痴。贪欲有三种上中下。何者是上贪欲。欲心逼身正见衰损。离欲心少离于惭愧。云何离惭愧心。若摄身静念独处林野。尔时思惟欲觉增长炽盛。贵于欲觉赞叹欲觉。以欲觉故。作是思惟时。无有愧心。云何无惭。以欲业欲作欲因缘。于父母所生怼恨语。于尊重处而无畏难。亦不羞愧自现有德。以是欲故命终之时堕于恶趣。是名上欲。云何名为中欲。若受欲已心生厌离或起悔心。是名中欲。云何名为下欲。若摩触之时欲想即息。或共言语。虽有染想生念即灭。或见欲时欲想亦息。是名下欲。欲者一切衣服饮食供身之具悉名为欲。嗔恚亦有三种上中下。何者为上嗔。若恼彼时深生忿怒或作五逆。或五逆中作一一逆。或诽谤正法等。如是之罪。非算数譬喻之所能及。身坏命终堕大地狱受罪。余报得生人中。肤体黑瘦两目皆赤。志逞常怒多怀扰害。以是义故名为上嗔。云何名为中嗔。所作诸恶速疾变悔。即修对治之法。是名中嗔。云何名为下嗔。或出恶言或起讥诃。或集微恶业。或时时起发寻生对治。是名下嗔。愚痴亦有三种上中下。何者为上痴。作恶不悔不生惭愧心无厌时。如是名为上痴。云何名为中痴。身作恶时寻生变悔。于同梵行边发露忏悔不显己德。是名中痴。云何名为下痴。依如来所制非性重罪少有所犯。是故名为下痴。菩萨摩诃萨。善心起时。能回贪嗔痴能除欲爱。能除欲乐能除欲着。以善心故令欲不起。云何名为无记心。此心起时不缘外不缘内。不缘善不缘不善。不从定不从智。如从眠起目视不了。不缘善恶名为无记。若无记心生时。菩萨方便自策发起善心。令生欢喜安住于善。是名菩萨得于善心。以善心故观察一切诸法。如幻如梦如热时焰如呼声响。此是善法此非善法。此法迹乘此法不迹乘。菩萨摩诃萨。观于一切法发起善心。以法为想心为先导。当善持其心调顺其心。善持诸法调伏诸法。见正法已。以是缘故便得寂定。心为境界以心系心渐入寂定。以心住心正住三昧。心寂定故便能专一。心专一故次第无间。得定心故心常寂静。心寂静故心生喜乐。便除欲爱诸恶不善。有觉有观定生喜乐成就初禅。无觉少观定生喜乐成就二禅。除喜得乐念舍得第三禅。离喜乐行舍心得第四禅。除我见离忧喜舍苦乐净念舍行四禅。一切解脱离色相如虚空。众生心相虚空相等作一解脱观。以是故色相灭空相生。恼坏相已灭无边虚空相成。从无边虚空相以次观识。识无边故虚空相灭。观识渐损乃至少识。名为不用处。复观此识若有若无。是名非想非非想处。灭诸想受是名灭定。菩萨虽入灭定。而不舍教化众生。亦不永乐灭定以为寂静。不舍灭定而能慈悲普覆众生。于灭定中乃至起悲喜舍心亦复如是。菩萨尔时便获五神通。而不以十二门禅五神通等以为自足。方求上法阿耨多罗三藐三菩提。庄严之具功德满足。善男子。具此十事。是名菩萨具禅波罗蜜

善男子。菩萨复有十法。名为智慧满足。何等为十。具无我善。善解业报。善解有为法。善解生死相续不绝。善解生死出要之法。善解声闻辟支二乘之法。善解摩诃衍。善解遮魔业智慧不颠倒智慧无等智慧。善男子。云何具无我善。菩萨以智观察色受想行识。观色不生不起不见起因。受亦不生不起不见起因。想亦不生不起不见起因。行亦不生不起不见起因。识亦不生不起不见起因。灭亦不生不起不见起因。第一义谛亦不见不生不起。世谛第一义谛。但有假名而无实体。虽知诸法虚寂。而不舍于精进。深矜一切众生。如救头然如救衣裳然。勤修方便不懈不舍。为一切众生故。而求阿耨多罗三藐三菩提果。庄严具足。是名菩萨无我善根。云何名菩萨善知业报。菩萨选择观察一切众生皆如幻相。如乾闼婆城水中之月体性空寂。一切众生染着我见及我所见。以是因缘不见正道。众生作如是想。若无我无人无众生无寿命无丈夫者。若悉皆无。谁受善恶六趣差别。菩萨摩诃萨。虽知业报不断不常而受不舍。是名菩萨善知业报。云何名菩萨善知有为而不取有为相。如实正见知有为法迅速不停。念念流动犹华上露。如山涧水駃流赴下间无暂息。亦如沙卤无有牢固。何有智者当生乐着而恋亲爱。见有为法如是之相。云何智者而生忧悲。以是因缘深乐涅槃厌恶生死。是名菩萨善知有为法。云何名菩萨善解生死流转。菩萨观察一切众生。无明所盲漂流生死。恒为爱罥诸结所缚。以是因缘故受。以受故造善恶业。以业因缘故有。有因缘故生。生因缘故死忧悲苦恼众苦聚集。生死流转互为上下犹如火轮。是故菩萨正观生死如实而知。是名菩萨善解生死流转。云何名菩萨善解生死出要之法。无无明则无行。无行则无识。无识则无名色。无名色则无六入。无六入则无触。无触则无受。无受则无爱。无爱则无取。无取则无有。无有则无生。无生则无老死忧悲苦恼众苦聚集。菩萨以如实知见十二因缘。是名菩萨善解生死出要之法。云何名菩萨善解声闻辟支二乘之法。菩萨观察如此法时。成须陀洹。成斯陀含。成阿那含。成阿罗汉。断诸结漏得成辟支佛。成辟支佛已如犀一角。善解声闻辟支佛法而不取证。何以故。我摄受一切众生故。作师子吼而作是言。我当拔一切众生旷野生死之苦。以是故我今不应独出生死。是名菩萨善解声闻辟支佛法。云何名菩萨善解摩诃衍法。菩萨善学一切诸法而不得诸法相。善修学道而不得是道相。不见能行者。不见所行法。亦不见所至到处。以是因缘相貌而不堕于断见。是名菩萨善解摩诃衍。云何名菩萨善知遮魔业智慧。菩萨善知不亲近恶知识。亦不至恶国而常远离世俗谈话。不乐亲近诸余非法。不求利养。亦于此法不生欣乐。一切结使能障菩提者悉皆远离。善知对治法。是名菩萨善知遮魔业智慧。云何名菩萨不颠倒智慧。善学世谛第一义谛及诸经论。善学世间杂论。为成熟众生故虽广闻多学。而不为于显己功德。但为成熟众生。虽明知世典。而常尊佛法以为最胜。终不染于外道邪见。是名菩萨不颠倒智慧。云何名菩萨无等智慧。不见若天若人沙门婆罗门诸外道与菩萨智慧等者。除诸如来世尊等正觉。余天人阿修罗无有能及菩萨智者。是名菩萨无等智慧。善男子。具此十事。是名菩萨满足智慧

善男子。菩萨复有十法。名满足方便。何等为十。善解方便回向。善回外道诸见。善回五尘。善除疑悔。善救护众生。善知众生济命。善受供养。善移声闻辟支二乘学者入于大乘。善知示教利喜。善知供养恭敬。云何名菩萨善解方便回向。一切所有若华若果。若香若香树。若宝若宝树。若叠若叠树。一切空泽旷野无主非我所诸物。尽皆昼三时夜三时回心施佛。以是善根。回向阿耨多罗三藐三菩提。于修多罗经中。赞叹供养三宝之处。深生随喜十方世界一切菩萨及诸众生。若起一念善根。身心随喜悉皆回向。香华供养诸佛形像塔庙。以是善根。愿令一切众生悉除破戒非法臭秽。当使一切众生皆得诸佛戒香之身。若有扫塔涂地。愿使一切众生悉得端正庄严之具。若以华盖供养佛塔。愿一切众生除烦恼热。若入僧坊塔寺。愿一切众生入涅槃城。若出塔寺。愿一切众生永离生死。若开门时。愿一切众生开善趣门。若闭门时。愿一切众生闭恶趣门。若欲坐时。愿一切众生当坐道场。若欲起时。愿一切众生于烦恼淤埿悉令超出。若右胁卧时。愿一切众生得右胁涅槃。若着衣时。愿一切众生着惭愧衣。若捉钵时。愿一切众生满足佛法。若欲食时。愿一切众生悉得法食。若大小便利时。愿一切众生蠲除垢秽无淫怒痴。若洗手时。当愿众生悉离染秽。若洗脚时。愿一切众生除烦恼垢。若嚼杨枝时。愿一切众生种种垢秽皆悉得除。若身行止及举动时。愿一切众生悉得安乐。若礼塔寺时。愿一切众生亦皆敬礼。是名菩萨善解方便回向。云何名菩萨善回外道诸见。能令异学九十六种调伏出家。欲调伏时而不贡高。为作师范要先恭事。现为弟子然后调伏。随诸外道所有威仪法则。悉皆习学究尽胜彼。令调伏已而反制之。使为弟子信受其语。尔时便为说言。汝先所学法。无有离欲亦无出要。乃以正道诱化其心令立佛法。是名菩萨善调外道诸见。云何名菩萨善回五尘。见诸众生贪欲炽盛。为化彼故现作女身。端正殊妙超诸女人。使彼染着。即复现身变为死尸。膖胀臭烂。众生见者悉生惊怖。即便厌恶。我今云何疾得远离臭秽之身。菩萨尔时即复本形而说法要。皆令坚固无上道心。是名菩萨善回五尘。云何名菩萨善除疑悔。若见众生作五逆罪及余诸恶。菩萨即语众生言。汝今何为愁苦如是。彼人答言。我作五逆罪愁忧悔恨。舍此身已当久受苦恼。长夜衰损无有义利。菩萨为现神变适其心念。令彼信服便生信敬爱乐。菩萨又复化作父母而加逆害。彼作是念。菩萨神足威力无量犹害父母。况我愚痴而能不作。菩萨答言。我真汝伴同作逆罪。菩萨便为说种种法。令彼逆罪即得轻微犹如蚊翅。是名菩萨善除疑悔。云何名菩萨善能救拔众生。菩萨观彼众生。堪为法器而造诸恶。菩萨即为现形种种说法。应现王身得度者。即现王等身。应现刹利身得度者。即现刹利身。应现婆罗门身得度者。即现婆罗门身。应现天身得度者。即现天身。应现金刚力士身得度者。即现金刚力士身。应现恐怖身得度者。即现恐怖身。应见系闭鞭打惊怖身得度者。即现系闭鞭打惊怖身。应见亲友爱乐身得度者。即现亲友爱乐身。所应见者皆为现之。是名菩萨善能救拔众生。云何名菩萨善知众生济命。菩萨摩诃萨。见众生无所堪任不识正法。惟知贪欲饮食衣服更无余求。菩萨尔时为示算数医方种种伎术。如是善者皆令学习。悉令不乏衣服饮食。是名菩萨善知众生济命。云何名菩萨善解受供

菩萨尔时得大宝聚。如须弥山悉能受之。若得少施微毫缕綖亦皆受用。菩萨以何缘故大小皆受。见众生悭贪嫉妒无有施心。又见众生出没生死如水中鱼。深愍众生漂溺巨海。为作利益令使快乐。受财宝已为供养佛法僧给施穷乏。随所施处而为说法。皆发阿耨多罗三藐三菩提心。是名菩萨善解受供。云何名菩萨善能移于二乘入于大乘。菩萨见众生堪任大器。乃至作声闻辟支佛二乘精进勤修苦行。尔时菩萨令住大乘。及其徒众悉皆令转舍于小心。为继佛种不断三宝故。是名菩萨移于二乘安住大乘。云何名菩萨善能示教利喜。未发菩提心者能令发心。懈怠懒堕者令勤精进。若以少善而自足者。方便发起令具诸善。若有亏损少戒生大障碍而心远离一切诸善者。菩萨即为说法。令其欢喜具修戒行。是名菩萨善能示教利喜。云何名菩萨善能恭敬供养三宝。出家菩萨少欲知足不积财宝。唯以法施为利。尔时在闲静处独坐思惟。我今何为不作供养佛想。即自思惟种种运心供养诸佛。如是思惟已便能具足六度。云何具足六度。以种种供养而具檀波罗蜜。恒与一切众生善。是名尸波罗蜜。欢喜忍乐。是名羼提波罗蜜。心身不懈。是名毗梨耶波罗蜜。专心不散。是名禅波罗蜜。庄严众行皆悉具足。是名般若波罗蜜。菩萨如是静处思惟时。能具六波罗蜜。是名菩萨善解恭敬供养三宝。善男子。具此十事是名菩萨具足方便

善男子。菩萨复有十法名方便发愿。何等为十。不作卑下发愿。不畏生死发愿。出过一切众生发愿。一切诸佛赞叹发愿。能摧伏一切魔发愿。不为他教故发愿。无边发愿。不恐畏发愿。无忧发愿。具足发愿。云何名菩萨不卑下发愿。菩萨摩诃萨。不为三有受乐故发愿。是名菩萨不卑下发愿。云何名菩萨不畏生死发愿。不求二乘不为厌恶生死。不为灭除生死故发愿。是名菩萨不畏生死发愿。云何名菩萨出过一切众生发愿。菩萨愿使一切四生众生悉成菩提如般涅槃。而我或入涅槃。或不入涅槃。是名菩萨出过一切众生发愿。云何名菩萨一切诸佛赞叹发愿。菩萨发愿。我化一切众生皆发阿耨多罗三藐三菩提心。行菩萨道乃至坐于道场。我当劝请令转法轮。佛若入涅槃。我当劝请令久住世利益众生。是名菩萨一切诸佛赞叹发愿。云何名菩萨摧伏一切诸魔发愿。菩萨愿使一切众生成佛时。国土不闻恶魔名字。是名菩萨摧伏一切诸魔发愿。云何名菩萨不为他教故发愿。终不受他教故。发阿耨多罗三藐三菩提心。自以智慧观察世界众生受无量苦。为拔济故发阿耨多罗三藐三菩提心。是名菩萨不为他教故发愿。云何名菩萨无边发愿。菩萨不为方所少缘发愿。菩萨整其衣服右膝着地叉手合掌心生厌恶。于十方一切世界所有菩萨若坐道场勤修苦行初成佛者转法轮者。当悉观察照见我心。劝请随喜愿转法轮。一切十方菩萨从初发意行六波罗蜜。皆作无量难行苦行。及至坐于道场。降魔成佛及转法轮。于此一一善心我皆随喜。发阿耨多罗三藐三菩提心。是名菩萨无边发愿。云何名菩萨不恐畏发愿。菩萨从初发心闻深妙法不生惊畏。闻佛本行无量功德不生惊畏。闻菩萨深远游戏神通不生惊畏。闻菩萨深远善权方便不生惊畏。菩萨作是念。佛菩提无量无边。世界无量无边。佛所成熟众生无量无边。非我智力之所能知。惟佛与佛乃能究竟。是名菩萨不恐畏发愿。云何名菩萨无忧发愿。菩萨见诸众生痴无慧目。[怡-台+龍]悷难调不可降伏。破戒懒堕众恶悉具。为如此等深起厌心求生净土。愿令我等不闻如是诸恶之名。当行慈悲智慧具足。菩萨发心便作是念。一切世界中少智众生。愚痴喑哑无涅槃分不生信心者。而为一切诸佛菩萨之所弃舍。如此众生我皆调伏。乃至坐于道场。得阿耨多罗三藐三菩提。发此心时。一切魔宫悉皆震动。十方诸佛发声赞叹。庄严净土速成正觉。是名菩萨无忧发愿。云何名菩萨具足发愿。菩萨发心誓愿降魔成阿耨多罗三藐三菩提。是名菩萨具足发愿。譬如油钵若已平满。更投一渧终不复受。菩萨成佛众愿满足亦复如是。更无减少一尘之愿。善男子。具此十事是名菩萨方便具足发愿

善男子。菩萨复有十法名力具足。何等为十。人不轻力。不为他所伏力。具福业力。具智慧力。具徒众力。得神通力。自在之力。陀罗尼力。菩萨定持不可动力。所言无二力。云何名菩萨人不轻力。一切外道声闻二乘无能过者。一切众生亦无有与菩萨力等者。是名菩萨人不轻力。云何名菩萨具福业力。无有世间出世间所修之福功德庄严能与菩萨力齐等者。是名菩萨具福业力。云何名菩萨具智慧力。菩萨智力有所举动。于前后际无有错谬。是名菩萨具智慧力。云何名菩萨具徒众力。菩萨徒众不坏正见。无毁威仪常修净命。所摄大众皆同菩萨正直之行。是名菩萨具徒众力。云何名菩萨具神通力。菩萨以世俗五通胜于声闻二乘五通。能以一尘容阎浮提及四天下。或千世界或二千世界或三千大千世界。乃至恒河沙等三千大千世界。而微尘不增世界不减。其中众生亦不迫迮。无觉知想不相妨碍。是名菩萨具神通力。云何名菩萨得自在力。菩萨有自在力。欲使三千大千世界种种珍宝遍满其中。即如其意。是名菩萨自在之力。云何名菩萨得陀罗尼力。菩萨若闻无量无边诸佛说法异闻异字。能于一念种种音声。悉皆受持思惟修行。是名菩萨陀罗尼力。云何名菩萨定持无戏动力。一切众生无能扰坏令其心乱。是名菩萨定持不戏动力。云何名菩萨所言无二力。菩萨心思后言口无二语。惟除方便。利益之说。是名菩萨言无二力。若有记莂终不错谬一切众生所有智慧。无能出过菩萨之者。善男子。具此十事。是名菩萨得力具足

善男子。菩萨复有十法名具足智。何等为十。知人无我智具足。知法无我智具足。遍知诸方智具足。善知禅定境界处所具足智。持具足无等智具足。善知众生根行智具足。无作智具足。善知一切法相智具足。善知出世间智具足。云何名菩萨知人无我。观五阴不坚无牢固。虚妄无真实。乃至灭谢亦不见有去。菩萨作是念。此五阴无我无众生无寿命无养育无人。凡夫愚人谓实有我故妄取我想。犹如鬼魅妖异所著。众生妄计亦复如是。或阴即是我。我即是阴。或阴是我所。我所是阴。着虚妄我不见真实。于生死中如旋火轮虚妄无实。菩萨如实能知。是名菩萨知人无我具足。云何名菩萨观法无我知。如实相见生见灭。知一切物犹如假借。但有名用假施设生。无有实体。假施设法亦不断不常。但从缘而生从缘而灭。菩萨如实而知诸法真实。是名观法无我具足。云何名菩萨一切处遍知。一切处遍知者。非一刹那中知。非一刹那中不知。非此方知彼方不知。而能普于十方得无碍智。是名菩萨一切处遍知。云何名菩萨善知禅定境界处所。知声闻定。知辟支佛定。知菩萨定。知诸佛定。如是诸定皆悉了知。声闻二乘但知自分境界余则不知。菩萨定者知己境界。兼知二乘及如来禅定究竟定相。以佛力故亦悉能知。是名菩萨善知禅定境界处所。云何名菩萨智持具足。菩萨善知声闻持辟支佛持菩萨持。况余众生而不能知。是名菩萨智持具足。云何名菩萨无等智具足。一切外道二乘诸智。无有能及菩萨智者。惟除如来一切种智。是名菩萨无等智具足。云何名菩萨善知众生根行具足。菩萨能以净无碍智。遍观世界。有众生能生菩提。有众生不能生菩提。有众生满足菩提。有众生不满足菩提。有众生住于初地乃至住于十地。有众生坐于道场。有成正觉有转法轮乃至入般涅槃。有声闻乘涅槃。有辟支佛乘涅槃。有生善趣者。有生恶趣者。是名菩萨善知众生根行具足。云何名菩萨无作智具足。于四威仪行住坐卧。念念无作心恒成就。譬如有人于出入息乃至睡眠常无所作。菩萨如是心无思惟亦非造作。而无碍智自然成就。是名菩萨无作智具足。云何名菩萨善知一切法相具足。了达诸法皆同一相。云何一相。皆尽空相。如幻相虚妄相。是名菩萨善知一切法相具足。云何名菩萨善知出世间智具足。菩萨知无漏智。出一切世间诸智。是名菩萨出世间智具足。善男子。具此十事。是名菩萨得一切智满足。善男子。菩萨复有十法名得地三昧。何等为十。如地广大无边。如地一切众生依止存济。如地于一切众生悉有育养之恩终不计恩。如地普能容受诸大云雨。能为一切众生依止住处。能生善种及一切种。如大宝器。能出一切大药。不可倾动不惊不畏。云何名菩萨如地广大无边。周匝十方无边无量。菩萨亦尔。功德智慧庄严愿行无边无量。是名菩萨如地广大无边。云何名菩萨如地一切众生依止存济。各从所欲称意拯给周济无碍。菩萨亦尔。施戒忍辱精进禅智乃至众具。皆悉与之而心无限碍。是名菩萨如地一切众生依止存济。云何名菩萨有育养之恩而不望报。犹如大地等无好恶。加报不欣无亦不恨。是名菩萨育养之恩而不望报。云何名菩萨如地普能容受大法云雨。亦如大地天注云雨普皆容受无不堪持。菩萨摩诃萨亦复如是。一切诸佛兴大密云普注法雨。如其所说悉能受持。是名菩萨如地普能容受大法云雨。云何名菩萨能为一切众生依止住处。又如大地草木丛林一切众生行住坐卧皆依于地。菩萨亦尔。一切众生修行善趣二乘学法及以涅槃。一切皆因菩萨而有。是名菩萨能为一切众生依止住处。云何名菩萨善种子之所依处。譬如大地一切种子依地而生。菩萨亦尔。一切善业天人种子皆依菩萨而生。是名菩萨善种子之所依处。云何名菩萨如大宝器。譬如大地能出众宝。是诸宝物皆出于地。菩萨摩诃萨亦复如是。功德善宝一切乐果悉出菩萨。是名菩萨如大宝器。云何名菩萨能出一切大药。譬如大地出众妙药能治种种诸病。菩萨摩诃萨亦复如是。能出一切诸妙法药。能除一切诸烦恼病。是名菩萨能出一切大法药器。云何名菩萨不可倾动。譬如大地风不能动蝇蚋蚤蝎不能[虛*予]损。菩萨摩诃萨亦复如是。一切内外诸缘逼恼不能扰动。是名菩萨不可倾动。云何名菩萨不惊不畏。譬如大地师子虎狼龙象雷电哮吼不能惊畏。菩萨摩诃萨亦复如是。一切外道九十六种所不能动。是名菩萨不惊不畏。善男子。具此十事。是名菩萨得地三昧

善男子。菩萨复有十法譬如大水。何等为十。如水流注溉润赴下。能生众生善芽种子。欣乐敬信。浸烂一切烦恼根芽。如水清净不浊。除灭一切炽热之患。能除贪欲爱心之渴。深广难度如水浇溉高下皆满。能除一切诸结尘垢。云何名菩萨如水流注溉润赴下。生长草木而各滋茂。菩萨亦复如是。以诸功德如水溉下。流润微善亦令增长。是名菩萨如水流注溉润赴下。云何名菩萨能生众生善芽种子。如水能润草木丛林悉得生长。菩萨以禅定水浇润觉意正直道支令得增长。渐渐长养成一切智树。是名菩萨能生善牙种子。以若干种诸佛法果利益众生。菩萨摩诃萨亦复如是。以清净法增长流润。是名菩萨能生善牙种子。云何名菩萨欣乐敬信。如水自湿亦能湿彼。菩萨亦复如是。身自恭敬信乐。亦能令他恭敬信乐。是名菩萨恭敬信乐。云何名菩萨浸烂一切烦恼根牙。譬如大水能浸草木根牙令使烂坏。菩萨摩诃萨亦复如是。修禅定水浸烦恼根牙令悉烂坏。乃至结使习气垢秽悉皆无余。是名菩萨浸烂一切烦恼根芽。云何名菩萨如水清净不浊。水之体性常恒不浊。菩萨摩诃萨亦复如是。体性不浊。云何菩萨体性不浊。结使贪欲嗔恚愚痴悉断无余。善护诸根清净如水。是名菩萨如水清净不浊。云何名菩萨除灭一切炽热之患。譬如夏月以水洗浴身则清凉。菩萨亦复如是。能以法水除烦恼热。是名菩萨除灭一切炽热之患。云何名菩萨能除贪欲爱心之渴。譬诸泉水能除人渴。菩萨摩诃萨亦复如是。能以法水悉除众生五欲之渴。是名菩萨能除贪欲爱心之渴。云何名菩萨深广难渡。禅定智水一切众魔及诸外道无能度者。是名菩萨深广难度。云何名菩萨如水浇溉高下皆满。菩萨亦复如是。于善恶众生以法水普润令不苦恼。是名菩萨如水浇溉高下皆满。云何名菩萨能除一切诸结尘垢。菩萨以禅定水淹洒六尘。诸根清净色声不染。是名菩萨能除一切诸结尘垢。善男子。具此十事。是名菩萨譬如大水

善男子。菩萨复有十法譬如大火。何等为十。能烧一切结使之薪。能成熟一切佛法。能干烦恼淤埿。如炬火聚。如火照明。能令惊怖。能令安慰。若有利养与众共之。为人供养。人不敢轻。云何名菩萨能烧一切结使之薪。如火能烧草木及诸丛林。菩萨亦尔。以智慧火能烧烦恼结使丛林。是名菩萨能烧一切结使之薪。云何名菩萨如火能成熟一切诸物。菩萨亦复如是。以智慧火悉能成熟一切佛法坚固不坏。是名菩萨成熟一切佛法。云何名菩萨能干烦恼淤泥。如火能干湿物。菩萨亦尔。能以智火干有漏淤泥。是名菩萨能干烦恼淤埿。云何名菩萨如炬火聚。若人为寒所逼得火则除。菩萨亦复如是。见诸众生为于烦恼寒苦所逼。菩萨以智慧火能令悉暖。是名菩萨如炬火聚。云何名菩萨如火照明。譬如有人在雪山顶然大炬火。周匝百里及二百里皆悉照明。菩萨摩诃萨亦复如是。于无明山顶然智慧火聚。于百千世界皆得照明。是名菩萨如火照明。云何名菩萨能令惊怖。譬如獐鹿虎豹见火惊恐皆悉远走。若天若魔及魔眷属。见菩萨智火威德皆悉远走。是名菩萨能令惊怪。云何名菩萨能令安慰。譬如有人在旷野黑闇中迷失方所。遥见火聚便往趣之。或值聚落放牧人处。得到彼已恐怖悉除心得安慰。菩萨摩诃萨亦复如是。众生于生死旷野黑闇之中迷失方所。遥见菩萨火聚而往趣之。到已烦恼怖畏悉得消除。是名菩萨能令安慰。云何名菩萨利养与众共有。譬如大火能令王若王等旃陀罗男女等悉得火熅。菩萨摩诃萨亦复如是。与一切众生王若王等若旃陀罗男女等。以智慧火消烦恼冰悉令得熅。是名菩萨利养与众共有。云何名菩萨为人供养。譬如大火刹利婆罗门城邑聚落悉皆供养。菩萨摩诃萨亦复如是。为天人阿修罗及魔眷属。悉皆恭敬供养如世尊像。是名菩萨为人供养。云何名菩萨人不敢轻。譬如有人得一少火以能烧故心不敢轻。菩萨摩诃萨亦复如是。初发一念之善未有大力。天人阿修罗及魔眷属无能敢轻者。何以故。是人不久当坐道场成阿耨多罗三藐三菩提。是名菩萨人不敢轻。善男子。具此十事。是名菩萨譬如大火

善男子。菩萨复有十法犹如虚空。何等为十。广大无碍。寂灭无相。无边空智。无边空慧。广大如法界。知一切法。相如虚空。一切法不住。出过一切形相。出过一切思议量数。善男子。具此十事。是名菩萨犹如虚空

善男子。菩萨复有十法心如虚空。何等为十。若心所喜乐亦不着。心不喜乐亦不嗔。于色声香味触亦不着不嗔。乃至于一切法亦不着不嗔。于利衰毁誉称讥苦乐。于此四法亦不着不嗔。善男子。具此十事。是名菩萨心如虚空。善男子。菩萨复有十法犹如满月。何等为十。能使一切众生得清凉乐。见者爱乐。能使善法日日渐增。能令恶法日日损减。如月盛满。体相胜妙体性清净。得无上乘。常自庄严。得法喜乐。乘第一乘。有大神通威德自在。云何名菩萨能与一切众生作清凉乐。如月天子初出之时。悉与众生清净快乐。而众乐观心无疲厌。菩萨之月亦复如是。除其烦恼郁蒸之热。皆令众生得清凉乐欢喜爱乐。是名菩萨能与一切众生作清凉乐。云何名菩萨见者爱乐。如月初出众生喜见利快乐。菩萨之月亦复如是。初出之时众生喜见无不悦乐。诸根寂定如水澄清威仪具足。是名菩萨见者爱乐。云何名菩萨能使善法日日增长。如月初出日日圆满。菩萨之月亦复如是。从初发心渐渐增长。乃至菩提坐道树下功德满足。是名菩萨能使善法日日增长。云何名菩萨能令恶法日日损减。譬如黑月圆满光明以渐损减。至月尽时光明悉灭隐蔽不现。菩萨一切众恶次第渐灭。乃至菩提悉皆除尽。是名菩萨能令恶法日日损减。云何名菩萨如月盛满。如从月初至盛满时众所瞻仰。刹利婆罗门城邑聚落一切男女无不称赞。菩萨之月亦复如是。常为天人一切众生皆悉称赞。是名菩萨如月盛满。云何名菩萨体相清净。如月天子身相清净。是本业果报。菩萨摩诃萨亦复如是。无垢清净从化而生。不由父母精气而生。从法而生。是名菩萨体相清净。云何名菩萨得无上乘。如月天子乘于净乘照四天下。菩萨摩诃萨亦复如是。乘于大乘。能使无量百千万亿世界众生悉皆照明。是名菩萨得无上乘。云何名菩萨常自庄严。如月天子华鬘显现。菩萨摩诃萨亦复如是。常以功德璎珞而自庄严。是名菩萨常自庄严。云何名菩萨得法喜乐。如月天子游戏五欲心常乐着。菩萨亦复如是。游戏诸法心常喜乐不染五欲。是名菩萨得法喜乐。云何名菩萨有大神通威德自在。如月天子有大威德。菩萨亦复如是。具诸功德自在智慧神通变化随意无碍。是名菩萨有大神通。善男子。具此十事。是名菩萨如月天子

宝云经卷第二宝云经卷第三

        梁扶南三藏曼陀罗仙译

善男子。菩萨复有十法名为如日。何等为十。能除无明黑闇。能令信心开敷。能令十方周匝皆暖。能令善法生长。能令有漏灭没。能作照明。能使邪道异见蔽障不现。能令高下丘坑悉显。能令善业皆悉得起。能令智者喜乐愚者增恶。云何名菩萨能除无明黑闇。譬如日出众闇皆息。菩萨日出能除众生无明之闇譬如日出众华开敷。菩萨日出应受化者亦皆开敷。如日出时周匝十方能令使暖。菩萨日出功德智慧令十方暖不扰众生。如日将出见其明相知有日出。菩萨亦复如是。以智光明照诸世间。众生则知菩萨日出。如日入时诸方昏冥众物不现。菩萨以智慧光入诸三昧。烦恼昏冥一切结漏悉灭不现。如日出时光照阎浮提灭一切闇。菩萨智光亦能普照。如日出时翳诸小明荧火之光悉不复现。而日无心翳诸小明法相自尔。菩萨日出则翳诸异见群邪外道。如日出时于阎浮提高下好恶悉皆显现。菩萨日出时。正道邪道亦各差别。邪谓八邪。正谓八正。如日出时田夫耕农诸作悉起。菩萨日出。信心众生普皆修善。如日出时善人乐见。奸盗众生悉恶不喜。菩萨日出贤智乐见。群邪外道一切不喜。善男子。具此十事。是名菩萨如日

善男子。菩萨复有十法譬如师子。何等为十。无所畏。不畏大众。去终不还。能师子吼。具足辩才。乐处林野。在于山窟。摧伏大众。具勇猛力。善能守护。善男子。云何无所畏。譬如师子往还出入无所忌难。何以故。不见与己等故。菩萨摩诃萨亦复如是。周旋往返无所畏难。何以故。不见与己等故。譬如师子不畏大众。菩萨摩诃萨亦复如是。诸有大众欲来讲论不生畏难。心亦不高不下。譬如师子心无怯弱。临阵战斗而心不退直进不还。菩萨亦尔。如师子吼飞落走伏。鲛鱼龟鳖水性之属潜隐水底人畜皆惊。菩萨亦尔。作无我师子吼。能令一切外道野干着我见者十方惊走。菩萨不欲令彼生其惊怖。但欲除彼我见心故。亦为化余信心众生。如师子王勇猛无畏。遍观四方心无怯弱。菩萨摩诃萨亦复如是。其行纯净常谛观察三昧智慧。譬如师子乐处林野。菩萨摩诃萨亦复如是。常乐闲独离于愦闹。又如师子乐处山窟。菩萨亦尔。乐处禅定三昧山窟。譬如师子无所结缚。菩萨摩诃萨亦复如是。已悉远离结使重担而行无染着。譬如师子无有伴党能摧诸军众。菩萨摩诃萨亦复如是。独坐道场摧伏魔众。善男子。犹如师子近聚落住。能令獐鹿不害苗稼。菩萨亦尔。随住方面能令众魔一切外道不坏正法。善男子。具此十事。是名菩萨譬如师子

善男子。菩萨复有十法。名为善调。何等为十。菩提心坚牢。修治菩提。守护诸根。趣向正道。善持重担。为众生故不辞劳苦。正命自活。能除谄曲虚妄之说。幻惑悉除。心常正直。善男子。具此十事。是名菩萨善调

善男子。菩萨复有十法名为善乘。何等为十。虽行禅定恒修空相。虽尽烦恼障而常修道。善顺佛教而无所违。等观诸法善解法界。心常自卑如旃陀罗。善除憍慢贡高吾我。见法决定无有疑悔。善察诸法得决定相。善于正道不随他教。善向菩提为世福田。善男子。具此十事。是名菩萨善乘

善男子。菩萨复有十法譬如莲华。何等为十。其体清净。不着于水。不染少恶。戒香具足。修清净行。和颜悦色。柔软不[革*卬]。见者皆吉。心意调熟。生已有想。云何不着。如莲华生水淤泥不染。菩萨虽生世间。而不为世法所著。何以故。得方便智慧故。犹如莲华水不能染。菩萨亦尔。不为少恶之所染着。如莲华生处香气满中。菩萨亦尔。随所生处戒香悉满。譬如莲华随所住处体性清净。刹利婆罗门城邑聚落之所称赞。菩萨摩诃萨亦复如是。戒行清洁。天人阿修罗夜叉乾闼婆迦楼罗紧那罗摩睺罗伽人非人等之所称赞。常为诸佛之所护念。如莲华开敷众皆爱乐。菩萨摩诃萨亦复如是。和颜悦色诸根清净。譬如莲华柔软不[革*卬]。菩萨如是。体性柔软言无粗犷。譬如莲华常是吉相。乃至梦中亦名为吉。有义有吉。菩萨摩诃萨亦复如是。一切是吉。究竟必得证一切智。以是义故名一切吉。譬如莲华未开敷时不名具足。华既开敷则名清净一切具足。菩萨摩诃萨亦复如是。慧觉开敷是名为佛。如莲华开敷能令眼见快乐。香气充满身触柔软。心得喜悦则意受乐。菩萨摩诃萨亦复如是。智慧成熟慧光明相。能令见时眼得清净。闻时耳得清净。戒香远闻鼻得清净。触身供养身得清净。思惟功德意得清净。莲华生时生已有想。佛及菩萨四天王等。若见菩萨出时亦皆守护生已有想。善男子。具此十事。是名菩萨譬如莲华

善男子。菩萨复有十法名胜大心。何等为十。满足诸波罗蜜故名胜大心。满足一切佛法故名胜大心。化一切众生故名胜大心。成佛道树得阿耨多罗三藐三菩提故名胜大心。初成正觉转于法轮。若沙门婆罗门若人若天魔梵所不能转。及余世间亦不能转。而我当转故名胜大心。菩萨为欲利益众生。不但于此世界。乃至无量无边世界。悉以正法摄取众生故名胜大心。菩萨以智慧船为欲度此生死大海流转众生故名胜大心。众生无救无依无舍无主。我当亲友为作归依舍宅故名胜大心。欲示如来威德自在。我当为作佛师子吼。我当游戏佛之神通。欲现龙象威仪视不回顾。欲使天人一切众生无与等者。若魔与梵沙门婆罗门及阿修罗无与等者故名胜大心。佛大威德所化度者我欲度之。非凡小行非粗弊行非是难行非下劣行故名胜大心。善男子。具此十事。是名菩萨最胜大心。善男子。菩萨复有十法名清净心。何等为十。体性具足。体性不动。体性质直。无虚伪相。除诸恶行。不发声闻心。不发辟支佛心。不自为己结使垢障而修功德。少恩尚忆况复大恩而不念报。施恩于人而不自恃。言行相应终不谬失。不隐己过不讥他短。菩萨终不外现软语而心怀恨。亦不颦蹙嗔色卒暴令恼众生。自无诤心亦不令他而起于诤。不作两舌破坏斗乱于人。身常恭敬所言真实。言行相称作业皆善。于如来法不说过恶。云何不说过恶。菩萨发菩提心。剃除须发被着法服。如来法中而得出家。不畏王故出家。不畏王臣故出家。不作盗贼故出家。不负债故出家。不怖畏故出家。不为邪命故出家。信心故出家。得出家已恒求善法。亲近善友随顺善友。于善知识所听受善法。闻法修行心不憍慢。终不颠倒妄取于法。为除颠倒令入正道。入正道已便得正见。得正见已去阿耨多罗三藐三菩提不远。善男子。具此十事。是名菩萨清净心

善男子。菩萨复有十法名深信不疑。何等为十。信如来身密。信如来口密。信如来意密。信诸菩萨所行。信菩提法。信于诸佛随所起作皆令满足。信诸佛出生。信诸佛一乘。信诸佛深远音声。信诸佛随应众生说法。云何信如来身密。信如来法身。信如来寂灭。信如来无等无量身。信如来坚固身。信如来不坏身。信如来金刚身。从如实生。信知不虚诳亦不生疑惑。是名信如来身密。又复思惟。闻如来口密。现前受记。密受记。未发心受记。初发心受记。信诸佛常以四依说法。信诸佛知无失。信诸佛口无失。信诸佛如上所说言不虚妄。何以故。诸佛已尽一切过故。离一切垢故。除一切尘无一切热。尽诸结业自在无碍。心常寂灭不浊不秽澄洁清净。若使如来有身口过则无是处。如实不虚不妄。决了此处不生疑惑。是名信如来口密。菩萨又作是念。闻如来意密。心有所作皆随智慧。声闻缘觉一切菩萨则不能了。唯除如来欲使知者。何以故。如来智海甚深难度不思议故。超过一切心意表故。无量无边与虚空界等。出过一切外道占相卜筮咒术所知。心常如实无有虚妄。复闻菩萨为众生故所作事业。不生疲厌不生惊畏。志力坚实荷负重担。能生大欲满足诸波罗蜜。一切佛法以渐而满。其心无碍无与等者。坚固精进坚固庄严。坚固智慧坚固誓愿。不动誓愿无等誓愿。何以故。称菩提相故。以渐增广乃至满足。如实知之无有虚妄心无疑惑。云何能修信不疑。作是念。从初发心乃至坐于道场。得无障无碍。遍知一切法明了无翳。得天眼天耳他心宿命如意足智漏尽智。于一刹那顷悉知三世。以如是智观众生界。见众生身业不善口业不善意业不善。诽谤贤圣起大邪见。亦知作邪见因缘身坏命终堕大地狱。观如是众生身业修善口业修善意业修善。不谤贤圣正见成就。以是因缘身坏命终生于天上。如是观诸众生善恶差别而作是念。我本修菩萨道时发大誓愿。若我自成菩提。亦使他成。我誓愿满足。言行真实无有虚妄。而于此处亦无疑惑。我闻如来唯有一乘。此事真实而不颠倒无有虚妄。何以故。譬如阎浮提多诸小渚。是诸小渚皆依阎浮提住。亦同名阎浮提。如来一乘亦复如是。一切诸乘皆出大乘。是故一乘名如来大乘。亦于此中不生疑惑如实而知。是以菩萨信如来乘。亦曾闻如来种种说法种种修多罗无不真实。何以故。如来随所化众生。随问何法称彼而答。然于此处如实能知信受不疑。曾闻诸佛深远妙声此事真实心无所惑。何以故。诸天以少修福尚得深妙柔软之声。况复如来具足无量百千万亿功德。深信此处不生疑惑。是名菩萨信于如来深远之声。又信如来能以一音演说诸法。随其类根悉除疑惑。而诸众生皆谓。世尊独为己说。佛以一音演说诸法。众生随类亦各信解。非作想亦非不作想。如实而知无有虚妄。能于此处不生疑惑。善男子。具此十事。是名菩萨深信不疑

善男子。菩萨复有十法譬如大海。何等为十。是大宝藏。深远难度。广大无量。次第渐深。不与烦恼同处而宿。寂灭一相。众流竞注皆悉容受。潮不失时。能为他人作归依处。而无竭尽。云何菩萨是大宝藏。亦如大海一切众宝皆出其中。阎浮提人悉来竞取不能令减。菩萨亦尔。犹如宝藏。无边众生悉以信心修菩萨行。功德宝藏亦复不减。是名菩萨如大宝藏。譬如大海深广难度。菩萨亦复如是。智慧法海。一切众魔及诸外道无能度者。是名菩萨深广难度。譬如大海广大无边。菩萨亦尔。功德智慧广大无边。是名菩萨犹如大海深广无边。譬如大海次第渐深。菩萨摩诃萨。成一切智以渐转深。是名菩萨犹如大海以渐转深。譬如大海不宿死尸。何以故。海法尔故。菩萨法海一切结漏烦恼死尸及恶知识亦不同宿何以故。菩萨法尔故。譬如大海众流注中皆同一味。菩萨摩诃萨亦复如是。白净善业无量一切功德到种智海。亦同一味等无差别。譬如大海能容百千众流。然其大海不增不减。菩萨亦尔。听受一切佛法。亦为众生分别解说而无增减。是名菩萨犹如大海不增不减。云何譬如大海潮不过限。菩萨亦复如是。于所应成熟众生亦不过限。犹如大海一切大身众生依止窟宅。菩萨摩诃萨亦复如是。为一切大心众生作依止窟宅。是名菩萨犹如大海依止窟宅。譬如大海无有穷尽。菩萨摩诃萨亦复如是。为一切众生如应说法亦无穷尽。善男子。具此十事。是名菩萨譬如大海

善男子。菩萨复有十法名微细智。何等为十。善知出要。善知出要法。善知一切法等同一相。善知一切法如幻相。善知一切法相。善知甚深十二因缘。善知诸业不可思议。善知一切法义。善知如实义。善知如实智。善男子。云何名菩萨善知出要法。菩萨能以智慧观察一切众生贪嗔炽然愚痴闇冥。思惟如是。众生云何出要。观察等同一相。知一切法如幻相。如实知一切法。能度甚深因缘。能知业不可思议。知一切诸法无相。而知种种诸业。能知缘起及诸业相。以如是微细智故。于诸佛所说法悉了其义。以解义故所见真实。以见真实故便能度脱众生生死。善男子。具此十事。是名菩萨微细智

善男子。菩萨复有十法得随应辩。何等为十。佛如是说一切诸法无我无众生无寿命无人无作者无知者无见者。一切诸法悉如是相。一切法空。一切法虚妄欺诳无主。一切法妄想无实。皆从因缘起。善男子。具此十事。是名菩萨随应辩

善男子。菩萨复有十法名为辞辩。何等为十。言论无滞。语无竭尽。言辞柔润。悦泽无穷。不惧大众。辞不卑小。辞无畏忌。辞无与等者。言不为他所恶。言虽无量而不离四依义。善男子。具此十事。是名菩萨辞辩

善男子。菩萨复有十法名为净辩。何等为十。辞无謇吃。辞无恐畏。辞不卑劣。辞不粗高。义不卑小。辞无阙短。其声清彻。声无阙短。言则应时无有漏失。辩不粗犷。云何名菩萨得不謇吃辩。以无大众威德畏故言不蹇吃。云何名菩萨得不恐怖辩。以体性正直故无所忌。云何名菩萨得不卑劣辩。以何因故。菩萨处于大众犹如师子无所忌难。云何名菩萨辞不粗高。以何因故除结使故。善男子。有烦恼故辞必粗高。云何名菩萨义不卑小。以何因故善得法故。已深解法其义明了。云何名菩萨辞无阙短。以何因故善解诸论故。若解论鲜少则言辩有阙。云何名菩萨声无阙短。何以故。菩萨悉解一切诸音声故。云何名菩萨知时而语。若应前语不着于后。若应后语亦不着前。何以故。菩萨善知时故。云何名菩萨辩不粗犷。非所喜者则不为说。何以故。一切口过由诸结习。以断恶故所言柔软。菩萨摩诃萨无不了辩。何以故。菩萨诸根已悉利故。善男子。诸根闇钝故有不了辩。利则不尔。善男子。具此十事。是名菩萨净辩

善男子。菩萨复有十法名乐说辩。何等为十。爱语。不颦蹙语。义语。法语。等语。不自高语。不轻他语。不染语。不恼触语。种种言辩。善男子。菩萨爱语。能令众生心生喜乐。和颜悦色咸使安慰。菩萨义辩能以美语令众悦乐。菩萨法辩教授利益。菩萨等辩常以等心为众生说法。能令一切悉皆喜悦。菩萨不自高说法。除诸憍慢自是心故。菩萨同事说法。悦众生故。菩萨不轻他说法。心能专一故。菩萨不染语。坚持净戒悦众生故。菩萨不恼触语。以忍辱力悦众生故。菩萨种种言辩。能以乐说悦众生故。善男子。具此十事。是名菩萨乐说之辩。善男子。菩萨复有十法。名善说法。能令众生信受。何等为十。堪任法器者而为说法。称其根性而为说法。不为讥呵者说法。不为外道异见者说法。不为憍慢无诚心者说法。不为无信心者说法。不为谄诳伪者说法。不为求活命者说法。不为求利养悭贪嫉妒者说法。不为颠狂愚痴聋哑者说法。善男子。菩萨以何因故不作法悭。己所得法悉与众生令他信解。不为师匠秘而不说。菩萨终不于众生起不慈愍心。亦不外于众生。但不任法器者则入舍心。除盖障菩萨白佛言。世尊。而此众生若不为说者当为谁说。佛言。有信心者我当为说。善根成熟堪任法器者当为说之。于过去佛种诸善根。心不谄曲无虚伪者。亦非幻惑诈现威仪者。不求名闻为利养者。常为善知识之所守护者。有智闻之能随信解者。诸根利者。闻法能行勤精进者。能随顺佛教者。若有如是善男子等。诸佛菩萨而为说法。善男子。具此十事。是名菩萨善能说法。令众生信受

善男子。菩萨复有十法。名为说法法师。何等为十。修集佛法而能说法。亦不见法而能修集。亦不见法能断结使而为说法。亦不见所断结使。亦不见法厌恶离欲寂灭。作如是说。法亦不得厌恶。亦不得离欲。亦不得寂灭相。得须陀洹果说法。不见有须陀洹相。得斯陀含果说法。不见有斯陀含相。得阿那含果说法。不见有阿那含相。得阿罗汉果说法。不见有阿罗汉相。得辟支佛果说法。不见有辟支佛相。断除着我说法。亦不见我不见着。见业果报说法。亦不见业果报相。何以故。菩萨观诸假名不必依法。名中无法法中无名。但以世俗假设名字流布世间。世谛故而有假名。于第一义谛观之则无。悉是虚妄诳惑凡夫。善男子。具此十事。名菩萨说法法师。善男子。菩萨复有十法名为坚法。何等为十。菩萨摩诃萨。虽观色真实而不坏色相。观受想行识真实亦不坏受想行识相。菩萨虽观欲界真实而不坏欲界相。虽观色界真实而不坏色界相。虽观无色界真实而不坏无色界相。虽观诸法真实而不坏诸法相。虽观诸法真实而不坏于假名众生。虽观法虚寂而不毕竟堕于断见。虽观诸法真实而不坏于正道。菩萨以巧方便智。善知有无而不取相。善男子。具此十事。是名菩萨坚法

善男子。菩萨复有十法善知法界。何等为十。有慧依善知识。能勤精进。远离阴盖。清净恭敬。多习空观。除着诸见。趣向于道。所见真宝。善男子。菩萨有慧习近善知识。见善知识爱敬喜悦。于善知识生世尊想。依善知识住。因善知识故得勤精进。因善知识故能除一切恶法。虽满足一切善法。而勤精进不惓除灭阴盖。已无盖障故而勤修道。得身口意业清净除诸习恶。得清净故能恭敬供养。得恭敬供养故而得空观。修空观故除诸假名。除诸假名故能向正道。向正道故能见真实。除盖障菩萨白佛言。世尊。云何名为见真实。佛即答言。所见不虚名为真实。除盖障菩萨白佛言。世尊。云何名真实。佛复答言。不虚妄法名为真实。除盖障菩萨白佛言。世尊。云何名为不虚妄。佛即答言。如实非不如实名不虚妄。除盖障菩萨白佛言。世尊。云何名为如实。佛即答言。此法惟可心知难以口说。非是文字所能宣释。除盖障菩萨白佛言。世尊。云何法相离于文字。言语道断出过一切心所行处。离诸戏论无造无作亦无彼此。非筹量计挍之所能及。亦非相貌。过于一切凡愚所见。出过魔界。出过一切结使处所。出过一切心意识表。不住寂灭贤圣处所。而诸贤圣之所证知。善男子。具此十事。是则名为究竟如实。是一切智所说。不思议境界不二境界。除盖障菩萨白佛言。世尊。是如实相云何证云何见。佛告。善男子。出世间智。乃能证见自得此法。除盖障菩萨复白佛言。世尊。此法体性究竟清净非染污法。是澄静法微妙最胜法。常住不动非败坏法。有佛无佛法性常尔。菩萨摩诃萨。精勤修行难行苦行。百千万亿难行苦行。为得此法安立众生。除盖障菩萨复白佛言。世尊。如是名以闻慧闻以思慧思身得证不。佛言。善男子。不尔。何以故。以智慧观如实法而身得证。除盖障菩萨白佛言。世尊。不从闻慧闻思慧思身得证耶。佛言。善男子。不也。不以闻思慧故身能得证。善男子。汝今谛听我当说喻。善男子。譬如春末盛热。大旷野中有人从东来欲向西。有人从西来欲东过。从西来者为热所逼。语彼人言。我今为热所逼极甚渴乏。示我道路何处当有清凉池泉可止渴乏。东方来人。善知涂径善知道相。即答彼云。道中有好清冷美水无诸碱苦。我以于彼洗浴饮饱得来至此。善男子。汝欲趣彼其路众多。去此不远便有二道。一者是左道。二者是右道。汝今当从右道而往弃其左道。去此不久。当见丛林郁茂清凉。此丛林中多妙池泉众流美味。可以洗浴饮除渴乏。佛言。善男子。彼渴乏者。闻水思惟时。得已止渴不。除盖障菩萨白佛言。不也世尊。虽闻清凉而身未证知。佛言。善男子。此亦如是。不以闻思慧等便能证知实相之法。大旷野者譬如生死。渴乏之人是具缚凡夫。烦恼热逼便生爱渴。善知道者譬如菩萨善知一切智道。能饮水者譬如善得法味。洗浴清凉譬如身证。澄清净洁无诸碱苦譬如实法。善男子。汝今善听我更说喻。假使如来住阎浮提。若寿一劫说须陀味。香气胜妙甘美清净。食时受乐悉皆赞叹其味无比。若使有人虽见其色。而未食者已得味不。除盖障菩萨白佛言。不也世尊。佛言。善男子。我今为汝复更说喻。譬如有人曾食美果。于未得者前。赞叹此果色香味具。彼人闻说是果时。已知彼果色香味不。除盖障菩萨白佛言。不也世尊。佛言。善男子。凡夫愚人亦复如是。不以闻思中慧便能证知真实法相。除盖障菩萨白佛言。世尊。今为我故快说此喻。若得闻者不久亦当获得法利。何以故。若闻此法必证阿鞞跋致。当得阿耨多罗三藐三菩提。佛即答言。如汝所说。闻此法者必证阿鞞跋致。当得阿耨多罗三藐三菩提。善男子。具此十事。是名菩萨善知法界

善男子。菩萨复有十法名善住空处。何等为十。善知力空。善知无畏空。善知不共法空。善知戒聚空。善知定聚空。善知慧聚空。善知解脱聚空。善知解脱知见聚空。善知空空。善知实谛空。虽知于空而不取空相。不作空见不依止空。不以此空因缘相貌堕于断见。善男子。具此十事。是名菩萨善住空处。善男子。菩萨复有十法名住无相。何等为十。除外相。除内相。除戏论相。除一切计有相。除一切境界相。除一切举动相。除一切趣向处所相。除一切造作相。除一切识相。除一切识所缘相。除盖障菩萨白佛言。世尊。若诸菩萨。已能如是住于无相者。佛住无相当复云何。佛即答言。如来境界不可思议。何以故。非智思量故。若欲思者心则狂乱。一切众生尽共度量。不能知于如来此彼岸事。何以故。如来境界深远不可思议。犹如虚空。出过一切诸数量表。取着见者心常颠倒故。非算数之所思计。除盖障菩萨白佛言。世尊。欲有疑问唯愿听许。善男子。随汝意问。吾今当为分别解说。一切诸佛亦悉听许。除盖障菩萨白佛言。世尊。若着我所非智人法。世尊。是大法主。云何当得而自称誉。佛言。善哉善哉。善男子。谛听谛听当为说之。除盖障菩萨白佛言。唯然世尊。诸佛如来不以憍慢而自称誉。不为利养不为名闻。不为使他知。不虚妄自称。不谄曲欺伪。何以故。但为利益一切众生。令得安乐修行法故。何以故。欲令众生于如来所深生信敬。心甚欢喜堪为法器者使长夜安隐获得善利常受快乐。乃至得阿耨多罗三藐三菩提。除盖障菩萨白佛言。世尊。众生岂不知。如来是天中尊自在法王。佛言。善男子。不知。何以故。下劣众生业行卑漏。少智少信。常为不善诸恶所持。不知如来有大威德。为如此等。是以如来自称实德。令彼众生信受修行。善男子。譬如医师善知医法。医所住处多诸病苦。更无余医能疗治者。是诸人等不知此医有大威德。是时良医观诸病者。不识方药亦复不知所不应食。尔时良医起大慈悲。我当疗治除其病苦。尔时良医于众人前。自叹己德而作是言。我善知是病及知病因。善知药病随应而授。尔时众生于良医所心生信敬。以信心故便即依凭。尔时良医以若干种药随授而与。诸人服已病悉除愈。善男子。尔时彼医是自称誉不。除盖障菩萨白佛言。不也世尊。佛言。善男子。如来世尊如大医王。能治众生烦恼之病。亦知烦恼所因起处。以大法药而普与之。众生愚痴为烦恼所覆。不知如来是大医王。如来处处于众生前常自叹说。尔时众生便生信敬归依如来。圣主世尊犹如医王。以大法药能灭众生烦恼之病。云何名为是大法药。贪欲者以不净治。嗔恚者以慈心治。愚痴者以因缘法治。如是等无量法药。悉能对治诸烦恼病。善男子。如来见有如是无量利故而自赞叹。善男子。具此十事。是名菩萨住于无相

善男子。菩萨复有十法名为无愿。何等为十。虽行布施不依布施而有愿求。虽持禁戒亦不依禁戒而有愿求。忍辱精进禅定智慧亦复如是。虽依三界而不愿求三界相。虽求菩提而不取菩提相。虽行正道而不取正道相。虽求涅槃而不取涅槃相。何以故。菩萨离一切愿求相故。虽行一切佛法。而心常无所愿求。善男子。具此十事是名菩萨无愿

善男子。菩萨复有十法名修慈无量。何等为十。不作方所慈。不随所亲慈。常行法慈。依定修慈。不为离嗔修慈。恒为利益一切众生而起于慈。常为众生修等之慈。不为离恼害修慈。遍于十方普皆修慈。出世间修慈。具此十事。是名菩萨修慈无量

善男子。菩萨复有十法名悲无量。何等为十。见众生无依无救无怙为苦所恼。菩萨即发菩提心。得如法修行。获得法已利益众生。于贪众生教令布施。破戒众生教修持戒。恼害众生教修忍辱。懈怠众生教修精进。乱心众生教修禅定。愚痴众生教修智慧。若见刚强诸恶众生不受教者。而菩萨心亦不退没。虽为众生久受诸苦。志必济彼无有疲厌。善男子。具此十事。是名菩萨修悲无量

善男子。菩萨复有十法名喜无量。何等为十。见诸众生于生死炽然。得离三有虚伪之主而生欢喜。断绝生死震动来往结业之索生欢喜心。见生死海中魔竭恶觉水罗刹难。今得远离生死大海如是众难生欢喜心。倾倒魔幢生欢喜心。以智金刚摧结使山令无尘末生欢喜心。我今自得止息。亦令他得止息生欢喜心。我今自于生死长眠境界心得觉悟。而诸众生为爱所缚无明所盲。亦当令彼悉得觉悟生欢喜心。我今自得解脱。离诸恶趣崄难之处。亦当度脱诸堕恶趣崄难之者生欢喜心。于生死旷野六趣崄路。独行无侣周回往返。不善知道不识方所。我今得知正道识于方所生欢喜心。我今得近一切智城邻于佛坐生欢喜心。善男子。具此十事。是名菩萨喜心无量

善男子。菩萨复有十法名舍无量。何等为十。眼见好色而无染着入于舍心。耳闻声鼻嗅香舌尝味身触细滑意知诸法。如是五尘不取其相。亦不恼逼常行舍心。苦苦行苦坏苦。于此三受心无增减。而不恼逼常行舍心。所作已办尽诸有结常行舍心。菩萨作是思惟。我欲度之彼已自度常行舍心。善男子。具此十事。是名菩萨舍心无量

善男子。菩萨复有十法名游戏神通。何等为十。现舍寿。现受生。现为童子种种戏笑。现作出家。现作苦行。现向菩提树。现降魔劳怨。现乐寂静。现转法轮。现入涅槃。除盖障菩萨白佛言。世尊。以何因缘。现兜率陀天舍寿。乃至现入涅槃。佛答言。兜率陀天染着五欲多生常想见。菩萨于一切众生中最上最胜。不染五欲而身终没。能破众生常想之病。得无常想心不放逸。兜率陀天多诸放逸。不生恭敬信乐之心。染着爱欲不受正法。长夜喜戏自恣娱乐。是以菩萨。为欲除彼放逸心故示现舍寿。尔时众生见菩萨舍寿。皆除放逸生厌离心。除放逸故便发阿耨多罗三藐三菩提心。菩萨现处母胎多有异相。亦令众生信受其化。虽处母胎为众说法。皆得阿毗跋致。疾向阿耨多罗三藐三菩提。若有众生。见菩萨婴孩时善根得熟。菩萨为此众生得成熟善根故现处婴孩。若有众生。见菩萨出家善根增长。菩萨便为是等舍家出家。若有众生志着粗弊。菩萨现作苦行而成熟之。天龙夜叉乾闼婆。应见苦行成熟者。即为现之而使成熟。亦为调伏诸外道等。无量众生长夜发愿。菩萨疾趣菩提树我当随逐。尔时菩萨即便现趣菩提树下。时是众生得阿毗跋致。乃至发阿耨多罗三藐三菩提心。又为众生憍慢贡高自恃势力。菩萨为欲破彼憍慢心故现坐道场摧伏魔怨令使信伏。菩萨为乐寂静众生增长善根故现坐道场。菩萨坐道场时。能使三千大千世界。一切众声悉皆不现。三千大千世界即便寂静。令乐寂静者生希有想。皆发阿耨多罗三藐三菩提心。能令众生悉得寂静。又有众生自谓大师。作一切智想。不知出要道。不识出世法。亦不知现生后报。为欲摧伏如此众生故。见堪任法器成熟众生。为是等故现成无上三菩提道。诣波罗奈三转四谛法轮。又有众生应现涅槃而成熟者。为欲成熟彼众生故现入涅槃。菩萨以如是缘如是义故。现坐道场乃至现入涅槃。善男子。具此十事是名菩萨游戏神通

善男子。菩萨复有十法名离八难。何等为十。离恶业不善。如来所制禁戒终不毁犯除贪嫉。于过去佛所种诸善根。恒修福业智慧具足。善知方便善知发愿。多厌恶心能勤精进。菩萨不造恶业而入地狱。虽处地狱终不受于地狱苦报。所不喜者亦不能恼。虽堕地狱而不久处。亦复不生恼害之心。菩萨志性调柔恒修十善。以十善故不堕地狱。菩萨不毁佛戒堕畜生中。虽现畜生而不受于畜生之苦。菩萨不起贪嫉堕饿鬼中。虽现饿鬼而不受于饿鬼之苦。菩萨终不生邪见家。虽生邪见处必遇善知识。何以故。己于过去修诸善故。亦于过去佛久植善根故。常生正见家具善因缘。具善因缘故功德增广。菩萨终不诸根毁缺。若根减少不任法器。菩萨积德久远修福不倦。于诸形像塔寺及法僧中。处处修福心常不懈。以常修故诸根具足无有阙少堪为法器。菩萨终不生边地愚騃聋哑诸恶之处。譬如白羊愚痴无智。而不能识善恶义趣。不任法器。亦复不识沙门婆罗门。菩萨生于中国聪慧利根有大智见。又心信乐亲近有智。而于善恶善知分别堪为法器。深信沙门婆罗门。何以故。菩萨本修智慧力故。菩萨不生长寿天。若生长寿天。不睹佛出世。远离道果。不能成熟众生。是故菩萨生于欲界佛出世时。必当遭遇能化众生。以何因缘善方便故。菩萨终不生于无佛世界。亦不生于不闻法处。乃至不生无众僧可供养处。菩萨生处必遇三宝。何以故。本誓愿力故。菩萨生处必有厌恶。心不憍慢而自贡高。若闻八难诸恶之处。必生厌离心不喜乐。勤修精进具诸善法除灭恶法。善男子。具此十事。是名菩萨离于八难

宝云经卷第三宝云经卷第四

        梁扶南三藏曼陀罗仙译

善男子。菩萨摩诃萨复有十法。名不忘失菩提之心。何等为十。心无谄伪亦无幻惑。心常吉实澄清净白。于佛法僧终不生疑。受持佛法者亦不生疑。不生师想而吝于法。除却法悭终不作灭佛法因缘。言行相应终不虚妄受持大乘。若见受持者常能恭敬。于摩诃衍以渐深入。于说法者生于佛想生善知识想。善男子。具此十事。是名菩萨常不忘失菩提之心

善男子。菩萨复有十法能识宿命。何等为十。曾多恭敬供养诸佛。受持诸佛法。能净持戒。除诸疑悔除诸盖障。多欢喜心乐于禅定。常受化生得不妄识。供养佛者恒于正法常生恭敬。受持正法者亦常恭敬。以是因缘能受持法。读诵书写广为人说。不惜身命专为正法。净修戒行身口意业悉皆清净。以戒清净故心无疑悔。净持戒故无有盖障。无盖障故心得欢喜。心欢喜故得修禅定。得修禅定故生处清净。生处清净故便得化生。得化生故得不妄识。得不妄识故便得宿命。得宿命故能知一身二身。乃至知百千身。善男子。具此十事。是名菩萨得宿命智。善男子。菩萨复有十法。得不离善知识。何等为十。得不离值佛若闻佛若忆佛。得不离常闻法。得不离常供养僧。得不离诸佛菩萨礼拜问讯恭敬合掌供养等。得不离多闻人值说法人。得不离闻诸波罗蜜。得不离闻诸道品觉意之法。得不离闻三解脱门。得不离闻四梵当。得不离闻一切种智。善男子。具此十事。是名菩萨得不离善知识

善男子。菩萨复有十法。得远离恶知识。何等为十。远离破戒恶知识。远离破正见者。远离坏威仪者。远离邪命者。远离乐世俗言说多愦闹者。远离多懈怠者。远离乐着生死者。远离背菩提者。远离在家之众。远离一切结使。菩萨虽乐远离如是等事终不生恼害。亦不生轻毁之心。菩萨作如是念。我曾闻佛说众生性欲相染。以习近故多有所坏。是故我应一切远离。善男子。具此十事。是名菩萨远离恶知识

善男子。菩萨复有十法。得如来法身。何等为十。等身无二身。清净无尽身久习善身。法身。非算数筹量甚深之身。不思议身。寂灭身。虚空身。智身。善男子。具此十事。是名菩萨得如来法身。除盖障菩萨白佛言。世尊。菩萨何时当得如来法身满答言善男子。初地菩萨得等身。何以故。初地菩萨除一切恶身。与诸菩萨同是名等身。二地菩萨得清净身。以持戒清净故。三地菩萨得无尽身。付除嗔恼害故。四地菩萨得久积一切善身。以修集一切佛法故。五地菩萨得于法身。以禅定力知一切佛法故。六地菩萨非世间算数筹量所不能知身。以深远故。七地菩萨得不思议身以善方便故。八地菩萨得寂灭身善除调戏尽一切烦恼故。九地菩萨得虚空身。得无碍身遍虚空故。十地菩萨得妙智身。何以故。遍知一切菩萨诸地法故。除盖障菩萨白佛言。世尊。菩萨法身。如来法身无差别耶。佛言。身无差别但功德有异。除盖障菩萨白佛言。世尊。云何身无差别功德有异。佛言。身名无异。何以故。身口一相故。而功德相各有差别。云何身中别见功德相。佛言。善男子。我今为汝说喻以释此义。譬如摩尼珠皆同名摩尼。此珠名虽是一。若莹磨治饰光则明显心意悦乐。譬如如来身不莹治者犹如菩萨身。如来身摩尼宝。菩萨身摩尼宝如实无异。然如来摩尼宝。菩萨摩尼宝。然其光明色相各异。何以故。如来身摩尼宝无量。满众生界满虚空界。清净离一切尘垢。菩萨身摩尼宝有限。不能满虚空界。何以故。有垢障故。善男子。譬如月初至十五日名盛满月。后十五日亦名为月。乃至月尽皆名为月。虽月名同。而明不如十五日月盛然月。法尔而如来身菩萨之身俱名为月。如月名同而实亦同。然光明照曜菩萨如来而各不同。菩萨之身光明照曜。不及如来其光炽盛。譬如月末时月月初之月不可相比。善男子。以是故。如来身菩萨身。二身虽同功德有别。善男子。菩萨复有十法。名金刚不坏身。何等为十。贪欲嗔恚愚痴不能坏。恼害憍慢着我自恃见颠倒不能坏。世八法不能坏。恶道不能坏。一切苦不能坏。生老病死忧悲苦恼不能坏。一切外道异见不能坏。一切魔天及魔眷属不能坏。一切声闻辟支佛不能坏。一切欲界不能坏。善男子。具此十事。是名菩萨金刚不坏身

善男子。菩萨复有十法。名大商主。何等为十。能使商人随顺言教。能使商人供养恭敬。能作引导不畏诸难。能为众人作依凭处。能令人依。常得活命。丰饶资粮。多诸珍宝。心无止足。常为前导得至一切种智大城善男子。云何名菩萨能使商人随顺言教。譬如商主善导众商若有所说皆悉随从。菩萨亦尔。善化众生能令一切悉皆随从。譬如商主为诸商人恭敬供养。菩萨商主亦复如是。学无学人天龙鬼神乾闼婆阿修罗迦楼罗人非人等。亦皆悉来恭敬供养。譬如商主善于旷野贼难之处。能令众伴安隐得过。菩萨商主亦复如是。于生死旷野烦恼贼处能将诸人安隐得过。譬如商主能将诸人。出于旷野令济身命。菩萨亦复如是。令诸外道钵罗婆殖尼乾陀等。于生死旷野将导使出济其躯命。或有王者大臣官属及诸众生乐生死者。亦依菩萨大商主故悉得全济。如大商主善备资粮所须珍宝。能将众人过险道已便得安隐乃到大城。菩萨商主亦复如是。欲至佛所多共众伴。经历生死险远旷野到彼岸城。当修功德以自庄严。禅定解脱悉令具足。菩萨商主。欲至一切种智大城。具一切佛法功德珍宝。譬如商主集诸珍宝无有止足。菩萨亦尔。集法财宝无有厌足。譬如商主善导众商。聪慧最胜财产巨富。所有言说众悉奉用。菩萨商主亦复如是。为众导首功德无量。于法自在所言无二。善能将导超过险路至彼大城。菩萨商主亦复如是。将导诸众生。超生死险。能到涅槃种智大城。善男子。具此十事。是名菩萨为大商主

善男子。菩萨复有十法名善知道。何等为十。知于平道。知险恶处。知安隐道。知不安隐处。知诸奇道。知诸道处。知止住处所。知于道相。知道曲直。知道出要。善男子。具此十事。是名菩萨善知于道

善男子。菩萨复有十法知道不颠倒。何等为十。应示大乘道度者。即示大乘道不示声闻道。应示声闻道度者。即示声闻道不示大乘道。应示一切种智道得度者。即示一切种智道不示声闻道。应示缘觉道得度者。即示缘觉道不示一切种智道。着我见众生不为说空无我。不着我见者不为说苦无常无我。着二边者不为说中道。着中道者不为说二边。失心狂乱者不为说奢摩他毗婆奢那。着邪道者为说正道。令离结使棘刺之属。善男子。具此十事。是名菩萨不颠倒道

善男子。菩萨复有十法。名为常在禅定。何等为十。观身身念处。观受受念处。观心心念处。观法法念处。阿练若处摄心而行。观于五欲摄心而行。于村里营舍城邑聚落国土方所摄心而行。于名闻利养摄心而行。于如来所制禁戒摄心而行。诸于烦恼起嗔恚处及心谄曲摄心而行。云何观身念处摄心而行。以正智慧选择诸恶除去不善。从足至顶乃至脑膜。观察诸分无我我所。念念不住是败坏法。筋脉所缠臭秽可恶纯集恶色。如是观察。横生身想我所之想。以是因缘以是相貌。谛观身相心得自在。云何观受念处。菩萨作是念。观察一切诸受悉皆是苦。凡夫愚人倒生乐想。愚痴无智不识苦乐。贤圣之人悉观是苦。勤修方便断除是苦。亦教余众生如是观受。不憎不爱断于诸受。云何观心意止观心。无常而作常想。苦作乐想。无我我想。不净净想。心甚猿猴如风动摇。念念不住速疾变异。是结使根本恶道之源。常生谄曲为烦恼主。亦是贪欲嗔恚愚痴因缘。是一切法宗主工匠心为前道。心从缘起悉知诸法。心如画师画一切像而心不知。心集诸业善恶所由。心如循环如旋火轮。心如火种然三有薪。心能生物犹如大水。观察之者。当知心相是大患本。不令是心而得自在。若能于心得自在者。于一切法亦得自在。云何观法念处。不善之法如实而知贪欲嗔恚愚痴及所依起一切恶法能修对治贪嗔痴等。断除不善观诸善法心乐随顺。系心专念顺行诸善。亦教他人同己所观。云何观于五欲摄心修行。于五欲中不生喜乐亦不憎恶。于色声香味触。亦不生爱亦不憎恶。于此无体相法生憎爱心。便同愚痴凡夫婴孩不善之者。又世尊说。若于法生爱乐亦生染着。若生染着便成愚痴。若生愚痴便是不识善恶。以是因缘堕于恶道。是故于此空法不应憎恶。若憎恶者名不堪忍。若不堪忍则增长恚心。为阿耆梨之所呵责。亦为同梵行者之所讥嫌。如是观察五欲修行正念。心不染着亦不憎恶。亦教他人作如是观。云何名阿练若处。摄心离乱如法修行名阿练若处。名为无诤住处。亦名寂灭住处。此阿练若处。有诸天龙鬼神他心智者善见我心。是故我今不应起不善思觉。断除不善觉勤修善觉。当令善觉常得增广。云何菩萨。于里巷村营城邑聚落国土方所。是中行住坐卧。于不善处于出家所。不应行处悉皆远离。何处是不应行处。酤酒家淫女家王家。棋博之处。醉客之处。歌舞伎乐之处。如是种种非是出家所应到处皆悉不往。如是村邑聚落之处摄心而行。云何于名闻利养摄心而行。于得利养处欲使檀越增长福业不为贪着。所得财利不作己想。与一切苦恼众生悉皆共之。以是施因缘得名称赞叹。虽得名称赞叹。而不自举不生憍慢不自憍逸。如是名称赞叹不久自灭。谁有智者。于无常迅速不住之法不可保信。云何于中生于爱憎。何有智者。生己有想生憍逸心。是名菩萨于名闻利养摄心而行。云何菩萨于如来所制禁戒常念修行。过去诸佛履行禁戒。而得成佛乃至涅槃。未来诸佛亦履行禁戒。而得成佛乃至涅槃。现在诸佛亦履行禁戒。而得成佛乃至涅槃。作是观察能持禁戒终不毁犯。是名善修是名善持。云何菩萨于诸烦恼尘垢盖障。能善修习摄心而行。菩萨善知烦恼结使尘垢盖障。善知其因。善知所因起处从是因出。菩萨于结使盖障常念摄心如是修行。善男子。具此十事。是名菩萨常在禅定。善男子。菩萨复有十法。名为粪扫衣。何等为十。以能受持终不毁坏。心常卑下而不疲厌。不以此事而得解脱。不见其过。见切德利。不自高己。不多聚积。善持禁戒。诸天亲近。云何受持能不毁坏。菩萨有信敬心体性具足。于如来所深生敬信。宁舍身命不舍所受。所受不动以所受坚固心能卑下。以卑下故不生我慢。以意卑下故。便于恶贱粪扫之物。取以净洗。洗以缝染。心不疲厌。不疲厌故常取粪扫衣。亦不以小行而怀自足。方进求上法必获前利。亦不现此粪扫衣过我常着粪扫衣。乃至今老。不以此衣而为粗弊。亦不作念。此衣粗弊多有蚤虱。若常著者令身垢污当念思惟着粪扫衣有诸功德。贤圣所服远离欲者之所修行。是名圣种。诸佛所赞如来所誉。以是因缘故不自称誉。不应自高亦不下他。是名戒具足。戒具足故诸天亲近。诸佛赞叹菩萨守护。善能观察人非人等刹利婆罗门聚落邑主恭敬礼拜。同梵行者之所赞叹。善男子。具此十事。是名菩萨粪扫衣。除盖障菩萨白佛言。世尊。菩萨志大。何缘乐此下劣粗弊。佛答言。善男子。菩萨为护众生德力所能。非诸凡愚下劣所堪。为未生烦恼作障碍故。佛语除盖障菩萨。善男子。汝谓如来为是大志为是小乎。除盖障菩萨白佛言。世尊。我无此辩当何能答。何以故。无有能知如来量者。现见如来知一切法。受粪扫衣者能制结使。不见如来有所遮制。此四天下天人龙鬼。皆有卑下之志。如来虽见卑下。但为成熟彼众生故。于诸众生前赞叹头陀。汝今当知如是因缘。除盖障菩萨白佛言。世尊。为成熟众生及新学者。菩萨遮断结使故说此事。善男子。威德力菩萨。为化众生现受粪扫衣。非志卑漏。以是义故菩萨受粪扫衣

善男子。菩萨复有十法。名受取三衣。何等为十。少欲知足不多贪求不多积聚。无积聚故离诸过患。无失坏故离诸忧恼。离忧恼故离众苦聚集。离众苦聚集故无有爱欲。无爱欲故能尽诸漏。少欲菩萨。趣得为足。知足之人少得而足。以少欲故无多所求。离所求故无多积聚。离积聚故无恼失苦。无恼失苦故无有忧愁。无有忧愁故无有苦恼。无有苦恼故无有受用。无有受用故便得漏尽。善男子。具此十事。是名菩萨受持三衣

宝云经卷第四宝云经卷第五

        梁扶南三藏曼陀罗仙译

善男子。复有十法。名菩萨具旃衣。何等为十。不随染欲名为旃衣。不随嗔故名为旃衣。不随痴故名为旃衣。不随恼害故名为旃衣。不随贪嫉故名为旃衣。不随憍慢吾我故名为旃衣。不为人知故名为旃衣。不为名闻利养故名为旃衣。不使魔得自在故名为旃衣。心不高下故名为旃衣。善男子。具此十事是名菩萨旃衣

善男子。菩萨复有十法名为乞食。何等为十。为益众生令得福故。是以乞食次第乞食。好恶随时不生悔恨。小欲知足。乞食得已与人共同。于食好恶不生增减不生贪着。于食知量趣向于善。修集善根离诸取着。云何乞食为益众生。菩萨乞食见诸众生善根鲜少。受乞食法为利益众生故。若城邑聚落到中乞食。系念不舍威仪具足。若顾视时终不轻躁。举动安庠诸根寂定。谛视目前不过一寻。于佛法僧深生信敬。然后乞食。次第乞食心无算择。刹利婆罗门富贵之家一向次第食足便止。除恶狗新生犊母先破禁戒堕畜生中。若男若女童男童女诸能扰恼者皆悉不往。可讥嫌处亦皆不往。次第先食。不得生着不得生嗔。于诸众生不起憎爱。于好于恶其心正等。少欲知足随得多少。还至僧坊安置衣钵。至洗足处。若到佛像塔寺众僧所恭敬供养。乞食之食分作四分。一分与同梵行者。第二分与穷下乞食之者。第三分与诸鬼神。第四分自供身食。我今食者但念修道不应于食而起染着。亦不憍逸贪嗜无厌。作如是食为存此身济其躯命。是故于食趣得安身。不使羸乏亦不令肥。何以故。若身羸瘦妨废行道。若食厚重复多睡眠。为行道故。于食知节不多不少。勤修精进除去懈怠。为满菩提觉支。满菩提觉支故我见得灭。我见灭故能以身肉施于众生。善男子。具此十事。是名菩萨乞食法。善男子。菩萨复有十法。名为一处坐。何等为十。于菩提树一坐道场。降伏魔官皆悉惊怖。此处不动得出世定。此处不动得世间慧。此处不动得出世间智。此处不动得空三昧。此处不动得觉一切法。此处不动得八正道。此处不动得于真实。此处不动得于如实。此处不动得一切种智坐。善男子。一坐者即是法坐。菩萨不动摇故名为一坐。善男子。具此十事。是名菩萨一坐法

善男子。菩萨复有十法名一受食。何等为十。不贪食。不染着食。以言食足一切不受苏油黑石蜜阿摩勒汁甘蔗汁及诸果汁。时非时都不饮食。见他饮食而不生恼常一受食。菩萨设有患苦。若为命难善法留难。当尔之时不生疑悔。作药想服。善男子。具此十事。是名菩萨一受食法

善男子。菩萨复有十法。名为阿练若处。何等为十。久习梵行。善解毗尼。诸根具足。具足多闻。广博多智。除去我见。譬如獐鹿。不肥不瘦。心常厌恶。乐处闲静阿练若处。云何久修梵行。善男子。菩萨摩诃萨。于佛法中出家学道。三业清净净持禁戒善知诸法。善知威仪行止之处。来去坐卧尽依法律。于如来法中上中下坐教戒威仪能教禅法。如此之法已自体解不从他受。知义知出要。知坐知出罪。避诸毁犯精勤修戒。少有所犯讥呵忏悔随所犯处及以不犯悉能了知。若犯重事乃至中下。悉能分别受报轻重近远。诸根具足依阿练若处。所依之处不为他恼。常乐乞食。往返不近不远。近清净水不污不浊。多诸林树无恐怖处花果具足。远离恶兽多诸龛窟。往返不难寂静第一。菩萨如此处。昼诵三遍夜亦三遍。声不高下善守诸根心不散乱。深信欢喜能忆偈句。善取因相除去睡眠。王若王等若诸王子。婆罗门刹利及余人民。往至菩萨阿练若处。比丘唱言。善来大王可坐此处。彼若坐时菩萨共坐。彼若不坐菩萨不坐。彼王根若不定应当赞叹。大王善得大利。王之国界多诸持戒沙门婆罗门住王界中。不为恶臣盗贼之所恼害。王若利根柔和善顺堪为法器。当为种种说法。若不乐种种说法。当为说五欲无常令知厌恶。若不乐厌恶。当复为说诸佛有大慈悲威德自在之所行处。刹利婆罗门邑主长者及以国人随宜为说。如是多闻堪法器者。即便为说种种之法。闻已信受心生悦乐皆令欢喜。多闻广博故无烦恼起善修对治。能除我见故不生怖畏。智辩具足故无大众畏。勇猛无难具如是事。能得阿练若处安止而住。继心厌恶乐独静处。犹如野鹿常在山林。阿练若比丘不如野鹿恒怀惊怖。譬如野鹿见人避走以畏死故。菩萨摩诃萨亦复如是。于愦闹处一切男女悉皆远离。何以故。令我心乱远离定故。不得厌恶修于功德复乐寂静。我今不应染近愦乱令失定心住阿练若处善男子。具此十事。是名菩萨阿练若处

善男子。菩萨复有十法名树下止处。何等为十。不近聚落依止树木而住。不近于饶棘刺处依止而住。不近摩楼陀兰草之处依止而住。不依枯叶处住。不依猿猴处住。不依鸟樔窟处住。不依恶兽处住。不依盗贼危难处住。菩萨所依止处。无诸恐怖令心悦乐。善男子。具此十事。是名菩萨树下止处

善男子。菩萨复有十法。名为露地坐。何等为十。春秋冬夏不依墙壁住。亦不依树下住。不依蘘草[卄/積]住。不依山掩处住。不依河岸住。不作障寒具。不作障风具。不作障遮雨具。不作遮热具。不作障露具。菩萨在于露地而身有病形体羸弱。应至僧坊。便作是念。如来为遮诸结使故说于头陀。我今虽在僧坊当断除结使。我今虽在僧坊中不生贪着心。我不为己身。但为僧坊檀越成诸功德故常作露地想。具此十事。是名菩萨露地而坐

善男子。菩萨复有十法名冢间坐。何等为十。随所住处多厌恶心。常修死想啖残想血涂想青淤想膖胀想烧然想解散想骨想。冢间坐者常修慈心。生利益想怜愍众生。净持禁戒威仪不阙终不食肉。何以故。不远冢间有诸非人及恶鬼神。以食肉故心皆厌贱。无喜见者常作恼害。冢间比丘往至僧坊先礼佛塔。却礼上坐与诸下坐。谈论语说立住而去。不坐僧祇旃蓐。何以故。为护惜僧物故。如凡夫愚人鄙贱冢间。设若有人。施于床敷请命使坐。问言。为是汝己有。为是僧有观前人意不生悔心然后始坐。心生下劣如旃陀罗子。善男子。具此十事。是名菩萨冢间坐法

善男子。菩萨复有十法。名常坐不卧。何等为十。不为苦身故常坐。不为苦心故常坐。不为止睡故常坐。不为疲极故常坐。为满足菩提故常坐。欲使心专一故常坐。欲使向正道故常坐。欲坐道场为得菩提故常坐。欲利益众生故常坐。为断一切结使故常坐。善男子。具此十事。是名菩萨常坐不卧。善男子。菩萨复有十法。名为随敷坐。何等为十。不贪着敷故随敷而坐。不自安敷亦不使他敷。不作形相使他敷。敷若草若枯树枝叶随在上坐。若有蚁子蚊蚋蝇蚤毒蝎之处。即时舍去不住于中。若欲卧时右胁而卧。足足相叠善敛衣服不令解散。若睡眠时当系心。明相作必起。意不着睡眠以为喜乐。右胁卧时若有疲极。终不更转左胁而卧。为调和四大常不离善。善男子。具此十事。是名为菩萨随敷而坐法

善男子。菩萨复有十法。名成就禅。何等为十。多修不净观。多修慈心。多修十二因缘。多修离过患法。多修于空。多修无相。多修习禅。多修不悔恨持戒完具。善男子。云何多修不净观。菩萨独处闲静默然摄意。厌恶现前正身端坐。支节完具深心喜悦。结加趺坐作是思惟。如人饮食美味好浆及余粗涩。是诸美味及不美味。皆依此身变成不净。脓血臭秽悉皆可恶。一切众生贪嗜美味心恒乐着。我今当愿依佛正法如实之相观察此身。不可染着亦不厌离速求涅槃。是名菩萨多观不净。云何菩萨多修慈心。如上染处端身独坐寂静思惟。众生多有嗔恚。便生恼害作诸不善。若有众生与我等者。云何来世自生怨恨。如是众生我当方便断其嗔恚。作如是念深心思惟不但口说。云何菩萨多修十二因缘。众生多起贪欲嗔恚。有如是等皆因缘生。假使余法一切皆从因缘而起。云何智者见如是相。一刹那顷从因缘法皆悉是空。不应为此而自毁害。云何菩萨多修离过患法。若自生过寻能除断。见他过患深入舍心。云何寻自除患。患者于诸佛不生信敬心。于法僧所亦不生信敬心。于戒不生信敬心。于和上阿阇梨时类宿旧有智者边上中下坐亦不生信敬心。自高己身卑下他人。于五欲所心乐趣向背舍涅槃。我见众生见寿者见人者见。计有虚空起于断见。深著有想起于常见。于贤圣所背舍远离亲近凡愚。远离持戒者亲近破戒者。近恶知识远离善知识。诽谤经法常生不信。闻诸深义心生惊畏。懈怠懒堕。于修法所轻而不为。意志下劣无有言辩。应不疑处返生疑惑。于可疑处而不生疑。为五盖所覆。幻惑谄诡睡眠所覆。贪着利养世间名称。爱乐种姓恃于居业。爱着徒众远离正法。乐俗谈话舍离禅思。见善不欣闻恶贪乐。而心不肯亲近出家。但念亲近年少妇女童男童女。不悕阿练若处。食不知量。不亲近有智师友善人。不知诵习经行时节。亦不知所应行来往返之处。于微细戒而作轻心。轻于小恶视瞻不端。举动轻躁恒作左法言语粗犷。于好恶色心皆贪着。好喜嗔恚不修慈心。于苦众生不生怜愍。见病苦者亦不厌恶闻死不惊。常处炽然不求出要。不观察身不守禁戒。不观己身。可作不可作。可觉不觉。可思不思。非道为道。道为非道。未得谓得。若少营福便多封着而心错乱。于大功德终不修行。谤毁摩诃衍。诽谤声闻。诽谤乐大乘者。诽谤乐小乘者。亦生诽谤讥呵于戒。为戒斗诤。为人刚强言常粗恶。而自贡高无怀惭色。不知羞厌躁恶粗弊言辞不逊。好喜绮语常行恶口。多诸妄语调戏无度。有如是等过。为离此过患法。离一切调戏。修习空定。多修空故处处观察体性悉空。能观空智此亦是空。作是观已。系心无相观内外法。不得身相亦不得系念相。尔时不见系心。于身亦不得身相。亦不得外相。亦不得念外相。去除外相身相亦除。除断内眼心乐善法。修道增广次第不断。常念定慧修功德本。正观诸法如实深义。是名为慧善摄乱意。欢喜无悔。是名为定。何以故。净持戒故菩萨能净持戒。必成就禅戒具足禅道。是故持戒具足名为修禅。善男子。具此十事。是名菩萨善修禅法

善男子。菩萨复有十法。名持修多罗。何等为十。为守护法闻则能持。不为财物饮食故持。为绍三宝种佛法不断。不为利养故持。为使摩诃衍广流布故持。不为恭敬利养故持。无救众生为作救护故持。不为名称赞叹故持。为苦恼众生使得乐故持。为令众生得慧眼故持。为求声闻者令得声闻道故持。为修摩诃衍成就摩诃衍故持。为成一切种智故持。不为求下乘故持。善男子。具此十事。是名为菩萨持修多罗

善男子。菩萨复有十法。名为律师。何等为十。善解毗尼所起因缘。善解毗尼甚深之处。善解毗尼微细之事。善解毗尼此事得彼事不得。善解毗尼性重戒。善解毗尼制重戒。善解毗尼制起因缘。善解声闻毗尼。善解辟支佛毗尼。善解菩萨毗尼。善男子。具此十事。是名为菩萨善持律师

善男子。菩萨复有十法。名善知威仪。善知可行不可行处。善知行法。善知威仪举止。何等为十。善学声闻戒。善学辟支佛戒。以善学故威仪具足。威仪具足故。不可行处终不往彼。不应往方亦不往彼。非时不行。沙门所行处行。不可行处不行。是故威仪具足。沙门婆罗门所讥呵处亦终不住。以是故沙门婆罗门无讥呵者。亦能教他修行如是威仪禁戒。以是义故威仪具足。寂灭威仪。无谄诳威仪。善男子。具此十事。是名菩萨威仪进止所行具足

善男子。菩萨复有十法。名除嫉妒。何等为十。自行布施亦教他人行布施。赞叹布施法。见他布施心生随喜。为说法要赞叹彼人。令使欢喜终不生念。但施于我莫施于彼。愿一切众生皆得施利。所须具足皆得快乐。得世间利乐。得出世利乐。我今勤为众生修无上道。为欲利益故。云何当起嫉妒之心。善男子。具此十事。是名菩萨能除嫉妒

善男子。菩萨复有十法。能为众生起平等心。何等为十。为一切众生作修福因缘。令一切众生心无嫌恨。不使一切众生起于嗔忿。为一切众生故布施持戒忍辱精进禅定智慧。为一切众生故发一切种智心。为一切众生故自满一切种智心。皆不生二想。所作功德与一切众生悉皆共之。缘一切众生以为境界。如是思惟时。能速成就菩萨之法。速成就菩萨法故。能观生死如火炽然。自乘此法能出生死。亦使众生得济苦海。皆起等心不生增减。善男子。譬如长者唯有六子其心爱着。于诸子中悉皆平等。为设方便。然诸子等幼小无智。不能行来不识善恶。其家火起。是诸小儿各在异处。善男子。而此长者宁可作心。此子应出彼不应出。此子先出彼应后出。除盖障菩萨白佛言。不也世尊。何以故。是长者等心于子无差别故。善男子。菩萨亦复如是。于诸众生心皆如子。愚小无智。于生死摩竭炽然世界。是诸子等各处六道。菩萨随应成就。皆悉拔济。咸令得出置寂灭处。善男子。具此十事。是名菩萨于一切众生得平等心

善男子。菩萨复有十法。名善供养佛。何等为十。以法供养于佛。以救拔济众生供养于佛。以教化众生令立诸善供养于佛。常与一切众生利供养于佛。不舍愿行供养于佛。不舍菩萨所行供养于佛。言行相应供养于佛。心无疲厌供养于佛。不舍菩提供养于佛。不以财施供养于佛。何以故。善男子。如来法身不待财施供养。惟以法施供养为上。以具足供养利益众生。令得安乐常获善利。善男子。若不能利益众生。放舍善法所作疲厌。好喜妄语志意下劣。心生疲惓离菩提心。有如是等不能为诸众生而作利益。何以故。菩萨要依众生修诸功德。乃至成阿耨多罗三藐三菩提。若无众生。终不能成阿耨多罗三藐三菩提无上正觉为具佛道。以法供养为最第一。不以财施为真供养。善男子。具此十事。是名菩萨能善供养

善男子。菩萨复有十法。名摧伏憍慢。何等为十。菩萨或时出家作是思惟。父母眷属已舍出家。犹如被弃坏烂死尸。云何于中当起憍慢。我今剃除须发。毁形向道节身知足。着坏色衣改先所好。修出家法舍俗威仪。云何当起憍慢之心。剃头持钵而行乞食。作乞丐想不应憍慢。当自卑下如旃陀罗子。我今乞丐由他济命。云何憍慢而自毁伤。是故思惟摧伏憍慢。我今受乞食法为他所贱。人与食时如似舍弃。如是思惟云何憍慢。我今于一切众生。恒如和上阿阇梨想。应加谦敬摧伏憍慢。我与诸同学同梵行者。善护威仪常念顺行。不应到于非律仪处。当使诸同梵行者见我欢喜。如此思惟时摧伏憍慢。我未曾得行佛法今得修行。于嗔恚恼害众生中当念忍辱。如是思惟时摧伏憍慢。善男子。具此十事。是名菩萨摧伏憍慢

宝云经卷第五宝云经卷第六

        梁扶南三藏曼陀罗仙译

善男子。菩萨复有十法名为信敬。何等为十。善根深厚宿殖德本。得于正见不随他信不归依他。志性恒正不为虚妄。其心质直无有谄曲。利根智慧功德具足。除诸阴盖其心清净。常依善知识远离恶知识。摧伏憍慢。闻深妙法能善谛受。终不颠倒妄解如来甚深法藏威德自在。善男子。具此十事。是名菩萨能多信敬

尔时除盖障菩萨白佛言。世尊。我今于如来大威德所。愿说少法令我得闻。善男子。汝今善听。当为说之。如来要法威德少分。善哉世尊。愿为演说。佛言。如来大慈等与一切众生乐。若于一众生起慈心时。乃至十方众生亦复如是。遍一切众生界。亦满虚空界。无能遍知如来甚深境界边际。如来有大悲心。不与声闻辟支佛共。如来于一众生起于悲心。乃至一切众生亦复如是。为作利益。如来大悲无有边际。非诸二乘所能究竟。善男子。如来说法不可穷尽。能于一时普为十方众生说法。若一劫。百千万亿劫。无量阿僧祇劫。作如是说。一切众生无有能知如来说法边际本末。假使无量众生一时问难。而如来于一念中。各随其类一音能答。然如来辩才无有穷尽。如来有无量阿僧祇禅定三昧之所行处。善男子。假使一切众生皆得十住。各各皆入无量三昧。于百千劫中各入异定。如是经无量劫。犹不能尽知如来三昧境界。如来又作无量阿僧祇应身。令一切众生应受化者。悉见如来皆现其前。于一念顷一一色相皆生信解各有差别。如来又复一时皆现其前。随其所应而为说法。令诸众生悉皆受行。善男子。如来天眼所见境界无量无边。非肉眼所见。是天眼境界。如来于一念中悉皆见之。如观掌中阿摩勒果。如来天耳所闻境界无量无边。如上天眼。一切众生异类音声。随其大小。于一念顷悉分别知。如来复有无量无边无碍智慧。无与等者不可为譬。一切众生若心念所知。随其根性种种差别。如来于一刹那顷悉分别知。随彼众生各各所念各各所作。随造善恶所得业报。如来能以三达无碍智慧。于刹那顷悉分别知。善男子。如来常在禅定。何以故。如来终无忘念。如来诸根无有错谬。如来断一切结使其心寂静。若杂结使其心散乱离清净法。如来已离一切业习。尘垢永尽无漏无为。于法自在。一切三昧三摩提无量境界已度彼岸。如来常在三昧。常一威仪乃至涅槃。如来于无量百千亿劫修集所得。无有众生能思惟分别知其量者。除盖障菩萨白佛言。世尊。如来不从阿僧祇劫积集功德耶。佛言不尔。何以故。善男子。菩萨不能思议如来境界。如来境界不可思量。但为浅近众生。说三阿僧祇修集所得。菩萨而实发心以来不可计数。除盖障菩萨白佛言。世尊。若众生久修善根。植诸业行除去盖障。多有信解近于阿耨多罗三藐三菩提。得闻如来无量威德。闻是法已欢喜信乐。况复受持读诵书写供养为人广说。如是之人。不久亦当得大威德堪任法器。佛言。如汝所说。如是如是。如此众生。为佛所护久种善根。亲近诸佛闻佛有大威德。善男子善女人。而于其中不生疑惑。善男子善女人心不错乱。不错乱故思惟如来有大威德。深生殷重信乐之心。七日七夜着鲜净衣。恭敬供养。专念如来大功德宝。心不移易必得见佛。若不满七日乃至一日一夜。命终之时亦得见佛。除盖障菩萨白佛言。世尊。颇有众生于如来所说不信受者。佛即答言。善男子有。或有众生闻佛所说。不肯信受深生恼害。于说法者生恶知识想。以是因缘身坏命终堕于地狱。善男子。若闻如来有大威德。生世尊想生大师想。如此之人。已于前世得闻如来无量功德。以是因缘今复续闻。即自思惟。我等先身必曾从佛闻如此法。尔时如来。即出广长舌相自覆其面。其舌广长踰于发际乃至覆头。覆头已复覆其身。覆身已覆师子座。又覆菩萨声闻缘觉护世四天王梵天帝释。遍覆一切无量大众。佛还摄舌相告诸大众。善男子等。如是舌相无虚妄耶。善男子。若信是事长夜安隐得诸利乐。说是语时。八万四千众生得无生法忍。无量众生远尘离垢得法眼净。无量众生未发菩提心者。皆发阿耨多罗三藐三菩提心

佛复告除盖障菩萨言。善男子。菩萨复有十法。名满世间善。何等为十。虽说于色而于实谛不见有相。亦不着色相。受想行识亦复如是。虽说于地而于实谛不见有相。亦不着地相。水火风空识亦复如是。虽说于眼而于实谛不见有相。亦不着眼相。虽说鼻舌身意法而于实谛不见有相。亦不着意法等相。虽说有我而于实谛不见有相。亦不着我相。众生寿者命者丈夫人。而于实谛不见有相亦不取着。但世谛假施设有。第一义谛则不可得亦不取着。世谛假施设有。第一义谛无有体相亦不取着。世流布中而有佛法差别。若于实谛亦无佛法善恶之相。但世谛中而有菩提。第一义谛则无菩提亦无取着。善男子。假施设法名为世谛。终不说世谛为第一义谛。善男子。菩萨摩诃萨。善于世谛不名为善于第一义谛。善男子。具此十事。是名菩萨满世间善。善男子。菩萨复有十法。名为善说第一义谛。何等为十。成就无生法忍。成就灭法。成就不坏法。非造作法。是究竟法。非处所法。无言语法。无调戏法。是寂灭法。是贤圣法。何以故。善男子。第一义谛不生不灭。非坏非所作亦非尽。非文字亦非调戏所得。善男子。第一义谛非言语道。法相寂灭贤圣之所证觉。善男子。第一义谛非坏败相。诸佛出世及不出世法相常尔。以是因缘故。菩萨剃除须发。信家非家出家学道。正信出家身服袈裟着坏色衣。精勤修道如救头然。舍诸虚妄志求实法善男子。若无实法则虚出家。诸佛如来亦虚出世。以是因缘有真实法。善男子。具此十事。是名菩萨善解第一义谛

善男子。菩萨复有十法。名为善知十二因缘。何等为十。善知体相空。善知刹那法。善知不坚法。善知如影如水中月如呼声响。善知法如幻。善知法如电。善知法如焰。如因缘生法此悉是空。一刹那顷不坚法。如是乃至因缘生法。此法生亦见生。住亦见住。异坏亦见异坏。菩萨如是思惟。以何因缘生以何因缘灭。菩萨复更思惟。因无明故能生诸法。无明力故诸法得出。一切诸法无明为导。一切诸法依止无明。依无明故能生于行。依行故生识。识因缘生名色。名色因缘生六入。六入因缘生触。触因缘生受。受因缘故凡愚众生于受少分便起染爱。爱因缘生取。取因缘生有。有因缘生生。生因缘有老死丈夫人老死。死因缘忧悲苦恼众苦聚集。以是因缘生大苦阴。以深智慧殷勤方便。当断无明拔无明根。灭于无明。无明相应法一切尽灭。譬如命根尽时诸根都尽。无明尽时。依无明法一切悉尽。无明灭故诸烦恼灭。烦恼灭故生死因皆灭。生死灭故近于涅槃。善男子。具此十事。是名菩萨善知十二因缘

善男子。菩萨复有十法。名善知我何等为十。菩萨作如是观察。我生谁家。为是婆罗门家。为是刹利家。为是长者家。为是下贱家。菩萨虽生上族家而无憍慢想。若生下贱处而作是念。我本曾作不善诸业。以恶业故今生下贱家。以是因缘多修厌恶。多修厌恶故欲得出家。既出家已作是思惟。我为何事而求出家。夫出家法为自度脱亦度于彼。以是因缘。不应懈怠而自懒堕。作是思惟。我今出家当何不善。若有少恶速疾除断。于诸善法深起爱乐欢喜无厌。所未断恶方便令断。如是复更观察。我等出家。云何增广善法。善法增已当倍爱乐深心欢喜。善法未增当令增广。我今依怙师僧增广善法。以是因缘于和上所。若持戒若破戒。若多闻若少闻。若聪明若无智。悉皆恭敬生世尊想。于诸世尊恭敬供养信乐欢喜。于和上所亦复如是。于阿阇梨复生恭敬。我依阿阇梨故善法增广。菩提法分未满足者当令使满。诸结未断者当令使断。于阿阇梨复生和上想。供养如前爱乐欢喜。增长右法损减左法。如是左法不令增长。复更观察。谁是我世尊。一切种智是我世尊。能一切觉。能一切说。救济世间怜愍众生具大悲心。是大福田。是我世尊。天人之师。以是因缘。以是相貌应生信敬爱乐欢喜。又复思惟。我得大利遇佛世尊如来制戒。我今宁舍身命终不毁犯如来制戒。是名善受佛教。我今当应从谁受供。如我今者。当从刹利婆罗门聚落城邑受彼供施。令彼果报尊贵富乐。我亦不应虚受人供。如是刹利婆罗门聚落城邑皆作何想。我今思惟。有何功德而施饮食。刹利婆罗门聚落城邑。当念我是沙门作福田想。我今应当具满沙门所行之道。比丘功德沙门功德。福田净业宜称其名。我今处生死中当自拔出。我今已得出家善利。我今初得无上大利。我得出家即是无上大利。我今能称出家之法。亦是无上大利。我今当勤精进远离懈怠。亦疾速出生死灾患。善男子。菩萨出家常应执念如是思惟。善男子。具此十事。是名菩萨善知于我。善男子。菩萨复有十法。名善知世法。何等为十。于自高人起卑贱想。于憍慢人起恭敬想。于谄曲人起质直想。于妄语人起真实想。于憎恶人起爱乐想。于刚强人起柔软想。于不忍人起忍辱想。于嗔忿人起慈心想。于苦恼人起悲心想。于多贪人起施与想。善男子。具此十事。是名菩萨善知世法。善男子。菩萨复有十法。名能生净佛国土。何等为十。持戒清净无阙戒无嫌戒。于一切众生心常平等。同其事业具诸功德。远离名闻赞叹利养。不染八法深信不疑。勤修精进无有懈怠。摄心禅定无诸错乱。善修多闻远离无智。利根聪慧灭除愚闇。于嗔恼众生恒修慈心。除盖障菩萨白佛言。世尊。若十事不具能生净土不。佛即答言。善男子。若能于一事具足无阙。当知十事悉皆清净。以是义故。名具十事得生净土。善男子。具此十事。是名菩萨能生净佛国土

善男子。菩萨复有十法名胎不染污。何等为十。作诸形像。如来塔寺若有毁坏严饰修治。复以诸香泥涂于佛塔如来形像。常以香汤洗浴于如来塔涂扫清净。于父母所躬自供养。于和上阿阇梨同梵行者。心常恭敬供养不为财利。以此善根回与一切众生。愿令皆得胎不染污。心常殷重如是思惟。善男子。具此十事。是名菩萨胎不染污。善男子。菩萨复有十法名舍家出家。何等为十。无所受用。于可染处终不亲近。背于五欲。除诸爱渴。于如来所制禁戒终不毁犯。少欲知足。衣服饮食床敷卧具。趣得支命终不贪积。于五欲所常生畏怖。恒念厌离修集善法。善男子。具此十事。是名菩萨舍家出家

宝云经卷第六宝云经卷第七

        梁扶南三藏曼陀罗仙译

善男子。菩萨复有十法。名为正命。何等为十。心不谄曲。不外现相貌而求利养。不作抑扬显己异众。不外弊五欲而心求利养。不取非法财。不取不清净财。不着利养。不染利养。而常知足。于如法利恒生知足。云何菩萨心不谄曲。不以利养令身口意曲。云何不身谄曲。菩萨不为见檀越故现诸威仪。云何作威仪。见檀越时。低视徐行如猫伺鼠。是名身谄曲。云何口谄曲。菩萨不为利养作柔软语。作爱语。作庠序语。随他所爱语。随他意语。如是等语皆悉不作。云何意谄曲。口说知足而心贪着。佛言。内烧内热。口言知足心常贪着。若不如是名不谄曲。云何名不外现相貌。菩萨不以见檀越时作诸相貌。我衣服短少。我钵器减少。汤药卧具减少。菩萨不以见檀越故作如是说。云何名不作抑扬方便鼓动。菩萨口终不言。彼有檀越与我此物为怜愍故受。我今持戒清净。具足多闻少欲。信心檀越皆乐施给。不作此说者。是名不作抑扬。云何名外弊五欲而心求利养。菩萨终不外现苦行。作五热炙身拔发自饿。如是等苦而要财利。于他利养不怀憎嫉亦无热恼。是名不外弊五欲心求利养。云何名不取非法利养。不轻秤小斗欺诳于他受人财物。终不侵欺。云何名不取不清净财。若有人施佛法僧物及僧祇物。如是之物取为己用。乃至博贸贩卖出息生利而自入己如是等物名非法财。菩萨摩诃萨远离如是等物。是名清净活命。菩萨若得利养。不生我所想。财利归己。亦不生能得想。亦不作积聚守护想。常念施与沙门婆罗门父母师长眷属贫穷乞丐。恒作是想。若须食时当求支命。于诸美味心无染着。若不得时亦不忧恼亦不生热。不得令彼信心檀越生于不信。若得如法利养皆与僧同。能如是者佛亦印可。诸菩萨众所不讥呵。亦为诸天常随赞叹。同梵行者心无讥嫌。于利养中常生知足得离邪命。善男子。具此十事。是名菩萨清净活命

善男子。菩萨复有十法名不疲厌。何等为十。常为众生久处生死心无疲厌。为众生故能受生死。于无量苦亦无疲厌。为声闻人教修禅法不生疲厌。心不轻贱修行觉法不生疲厌。具菩提法不生疲厌。虽求涅槃而不证涅槃。渐深流注至菩提法岸。善男子。具此十事。是名菩萨心不疲厌

善男子。菩萨复有十法名随顺佛教。何等为十。不住放逸处除诸放逸。善摄其身亦不令身起诸过恶。善摄其口亦不令口起诸过恶。善摄其心亦不使令心起诸过恶。畏后世苦而具一切善法。修行一切善法而断一切不善法。说一切善法而毁呰一切恶法。毁呰一切恶业修行一切善业。于如来法不说其过。消灭一切诸垢烦恼。守护如来所制圣戒。善男子。具此十事。是名菩萨顺如来教

善男子。菩萨复有十法。名和颜悦色离于颦蹙。何等为十。诸根澄净。诸根清净。诸根不阙。诸根离垢。诸根白净。除于恼害。除诸结使。得不起结使。除嫌恨心。远离嗔恚。除盖障菩萨白佛言。世尊。如我解佛所说。诸根清净故得和颜悦色。和颜悦色故离诸结使。离诸结使故得不颦蹙。佛言。善男子。如是如是。诸根清净和颜悦色。除诸结使离于颦蹙。善男子。具此十事。是名菩萨和颜悦色离于颦蹙

善男子。菩萨复有十法名为多闻。何等为十。见生死炽然如实而知。见嗔恚炽然如实而知。见无明闇乱生死炽然如实而知。见一切有为法悉皆无常如实而知。见一切有为法悉皆是苦如实而知。见世间空如实而知。一切法无我如实而知。一切众生着于调戏如实而知。解一切法从因缘生如实而知。寂灭涅槃如实而知。但从闻思慧不取口语。如是知已。为众生故深发大悲。勤加修习具于精进善男子。具此十事。是名菩萨多闻

善男子。菩萨复有十法名持正法。何等为十。法欲坏时有五浊恶起。德薄众生多住邪道智灯欲灭。无有导师能说正法。诸大修多罗虽有深义无能说者。亦无读诵受持之者。尔时菩萨见法坏时。能受持经藏。赞叹读诵。为人开示分别解说。其中有人闻已生信心乐欢喜。不为财利但欲听法。于说法者生世尊想于所闻法生甘露想。作不死想。如诸妙药。不惜身命勤求正法。闻已修行。善男子。具此十事。是名菩萨善能持法

善男子。菩萨复有十法名法王子。何等为十。以相具严身。众好如妙华。诸根满足无有缺减。如来所亲近法亦能亲近。如来所行道亦能顺行。如来所解法亦能顺解。成熟苦恼众生。善修学戒。长夜勤行四无量心。于如来所止之城亦能住中。善男子。具此十事。是名菩萨法王之子

善男子。菩萨复有十法名出过帝释护世之法。何等为十。于菩提心无有退转。一切众魔不能动摇。于一切佛所种诸善根。能入一切甚深法藏。于一切法得平等智。于佛法中不从他信。得清净智。不共声闻辟支佛法。住无生忍。出过一切护世之法。善男子。具此十事。是名菩萨出过一切帝释护世之法

善男子。菩萨复有十法。能知众生根性内外结使。何等为十。若体性贪欲如实能知。体性嗔恚如实能知。体性愚痴如实能知。善知烦恼上中下差体性内外如实能知。善知善体性如实能知。善知坚体性如实能知。善知长体性如实能知。善知惨恶体性如实能知。善知一众生。亦知一切世界众生体性。善男子。具此十事。是名菩萨善知根性结使内外

善男子。菩萨复有十法名能成熟众生。何等为十。应见佛身得度者即现佛身。应见菩萨身得度者即现菩萨身。应见缘觉身得度者即现缘觉身。应见声闻身得度者即现声闻身。应见帝释身得度者即现帝释身。应见魔身得度者即现魔身。应见梵王身得度者即现梵王身。应见婆罗门身得度者即现婆罗门身。应见刹利身得度者即现刹利身。应见长者身得度者即现长者身。如是等身随其所应悉为现之。善男子。具此十事。是名菩萨成熟众生

善男子。菩萨复有十法名善调顺。何等为十。质直柔软。无谄曲心。无恼害心。无垢污心。常清净心。无粗犷心。除嗔恚心。除粗恶语。多诸忍辱。能止诤论。善男子。具此十事。是名菩萨能善调顺

善男子。菩萨复有十法名安乐共住。何等为十。正见清净。具足修行。具足清净戒。具足诸所行处。应出家法。起烦恼处不于中住。其心调柔于同梵行者。如牛念犊修行平等。常乐菩提第一正道。唯佛为尊不求余神。善男子。具此十事。是名菩萨安乐共住

善男子。菩萨复有十法名为摄法。何等为十。以施摄众生。以乐摄众生。无尽施摄众生。利益摄众生。义益摄众生。说法摄众生。化导摄众生。除衰与利摄众生。同饮食摄众生。资命所须悉与共之摄众生。云何施摄众生。常以法施永济其苦。是名为施。云何施乐。施食令安无饥渴想。是名施乐。云何无尽施。教修禅定远离散乱。是名无尽施。云何利益施。教授善法增长信心。是名利益施。云何义益施。教如实法深了空相。是名义益施。云何说法施。依修多罗随所应闻终不邪说。是名说法施。云何化导施。说如实法无错谬相。是名化导施。云何名为除衰与利施。勤灭恶法安置善法。是名除衰与利施。云何同饮食施。所有饮食悉与众共。是名同饮食施。云何名资命所须施。象马七珍乃至供身众具杂物尽与众共。是名资命所须物施。善男子。具此十事法。是名菩萨修行摄法。善男子。菩萨复有十法名为端正。何等为十。寂灭威仪。不诈诡威仪。清净威仪。人见爱敬威仪。如月威仪。视不厌足威仪。意所悦乐威仪。一切乐见威仪。能使一切欢悦威仪。能使一切信乐威仪。善男子。具此十事。是名菩萨端正

善男子。菩萨复有十法名可依凭。何等为十。能拥护众生使离烦恼。能令众生出于生死旷野崄难。能使众生出生死魔竭。能为无救众生作亲友处。能为烦恼病众生而作良医。无救护者能为救护。无舍宅者为作舍宅。无归依者为作归依。无洲渚者为作洲渚。未到者能令作到。善男子。具此十事。是名菩萨常可依凭

善男子。菩萨复有十法名大药树。何等为十。譬如药树名曰善见。若有众生得树根者而病除愈。有得茎者而病除愈。有得枝者而病除愈。有得叶者而病除愈。有得华者而病除愈。有得果者而病除愈。有见色者而病除愈。有闻香者而病除愈。有得味者而病除愈。有得触者而病除愈。善男子。菩萨摩诃萨亦复如是。从初发心。为无量众生有若干种诸烦恼病。有依舍得活。有依戒得活。有依忍得活。有依精进得活。有依禅定得活。有依智慧得活。有见法得活。有闻声得活。有知味得活。有同事得活。善男子。具此十事。是名菩萨如大药树

善男子。菩萨复有十法名勤修福业。何等为十。常于三宝随力供养。于病者所施给医药。于饥渴者随施饮食。见裸寒者施其衣服。于和上阿阇梨常恭敬供养信受言教。于同梵行者起迎恭敬礼拜问讯。造作园林池井乃至谷帛施与一切。及家奴婢仆使内外眷属亦等施之。与持戒沙门婆罗门。常念亲近往反恭事。善男子。具此十事。是名菩萨勤修福业

善男子。菩萨复有十法名为善能作化。何等为十。于一佛国身相不动而能遍诸佛刹问答咨请。于一佛国不动亦能悉遍一切佛国听受妙法。于一佛国不动能遍供养十方诸佛。于一佛国不动而能遍诸佛国庄严菩提悉皆满足。于一佛国不动而于一切佛国初成佛时坐于道场菩提树下恭敬供养尊重赞叹。于一佛国不动能以自身现一切佛土坐于道场现成佛道。于一佛土不动能现一切佛土转于法轮。于一佛土不动能现一切佛土入于涅槃。于一佛土不动能现一切十方佛土应受化者悉现其身。菩萨得无作神力。于一切十方佛土。不作变化想亦不作变化。随诸众生所应见者悉皆现之。尔时除盖障菩萨白佛言。世尊。云何菩萨能作如是变化。复言。亦不作变化想。亦作不变化。善男子。汝今谛听我当说喻。譬如日月光照四天下利益世间。能于众生常作利安。而日月亦不作想。我能照诸众生有大利益。然诸众生悉蒙光照。菩萨亦尔。以本善业誓愿因缘。得无作法自然成就故。能不作变化想。亦不作变化。然于一切有利益处悉现变化。善男子。具此十事。是名菩萨变化

善男子。菩萨复有十法名速疾成阿耨多罗三藐三菩提。何等为十。修行布施令使布施满足。修行持戒不阙戒。不讥嫌戒。出过声闻辟支佛戒。清净戒身满足。忍辱满足。精进满足。禅定满足。智慧满足。方便满足。愿满足。力满足。智满足。过一切声闻辟支佛。从初地乃至九地菩萨所不能及。善男子。具此十事。是名菩萨速疾得阿耨多罗三藐三菩提。说是经时。三千大千世界六种震动。此三千大千世界中间诸须弥山王。目真邻陀山摩诃目真邻陀山。铁围山大铁围山。宝山黑山。如是诸山悉皆曲躬向伽耶山。何以故。如来自在神通力故。三千大千世界中一切华树一切果树一切香树。皆来曲躬向伽耶山。何以故。如来自在神通力故。无量亿那由他百千亿诸菩萨。悉脱身上妙衣及诸璎珞供养如来。神通力故积过须弥若干种衣服璎珞。无量百千亿帝释护世梵天王等合掌顶礼。曼陀罗华摩诃曼陀罗华散诸佛上。曼殊沙华摩诃曼殊沙华。卢之华摩诃卢之华。以散佛上。百千万亿诸天在虚空中。皆散天衣作众伎乐。欢喜踊跃出大音声。各以天华供养于佛。而作是言。佛更出世再转法轮。众生有福宿殖德本。于过去佛所久种善根得闻此经。闻之尚难。况复信解书写受持。尔时无量百千摩睺伽。于此演法出大雷音遍三千大千世界。以种种香汁雨伽耶山。无量百千龙王。在于佛前作众伎乐。无量百千乾闼婆紧那罗。以柔软音赞叹供养绕伽耶山。无量百千夜叉。雨诸莲华放清凉风。无量百千他方诸佛。皆出白毫相光。供养如来及所说法。出白毫相光。作种种色。青黄赤白紫颇梨色。绕于三千大千世界除一切闇。绕伽耶山从佛顶没。无量百千婆罗门刹利聚落城邑。香华璎珞末香衣服缯盖幢幡以供养佛。说是经时。如是等无量供养。七十二那由他菩萨得无生法忍。无量百千众生离诸尘垢得法眼净。无量百千亿众生发阿耨多罗三藐三菩提心。伽耶山神名为无死。与其眷属皆从坐而起自入宫室。取供养具而供养佛。供养佛已白佛言。世尊。我忆往昔共七万二千佛。皆在此一伽耶山说是经典。文字章句如今不异。佛言。快得善利。汝等得闻如是宝云经。有一天子作如是念。是伽耶山神。久闻此法。供养七万二千佛。云何不转女身。除盖障菩萨摩诃萨。知彼天子心之所念。白佛言。世尊。以何因缘。无死天神有大神德。闻是法宝供养尔所诸佛。云何不转女身。佛答言。善男子。为利益众生故。以何因缘。为不可思议解脱。善男子。我忆过去于算数佛所。见是无死天神。发阿耨多罗三藐三菩提心。无死天神有大威德神通。供养贤劫千佛。于此国土当得成佛。号曰无死阿罗诃三藐三佛陀。佛告无死。今可现汝所成佛国土。尔时无死天神。即入现一切色三昧。现一切色三昧已。此三千大千世界地平如掌皆绀琉璃。一切秽恶诸黑山等悉皆灭没。处处皆见劫钵之树众宝树众香树。处处皆见流泉浴池。八功德水充满其中。一切恶趣下贱之人悉皆不现。国中无有女人之名。处处皆有莲华大如车轮。菩萨而在其上结加趺坐。彼无死佛。在莲华上坐。为诸菩萨演说法要。无量百千亿释梵四天王等围绕。又有无量百千万亿众生悉来供养。佛为说法次第谛听。无死天神。从现一切色三昧起。顶礼佛足。右绕佛已即隐不现。除盖障菩萨摩诃萨白佛言。世尊。善男子。善女人。作几许福得闻是经。佛言若人至心善听此经。忆念受持读诵书写广为人说。佛言。复有善男子善女人。于此三千大千世界百千亿劫修行布施。不如善男子善女人信心清净书写供养。以清净心故得福甚多。何以故。财施微少法施广大。生死众生于生死中作无量财施。未曾得闻出世法施。若善男子善女人。使三千大千世界众生皆立十善。复有善男子善女人。闻此正法次第受持读诵广分别说。其福亦过于上。何以故。十善果报生此世界故。若善男子善女人。能令三千大千世界众生。悉得须陀洹果斯陀含果阿那含果阿罗汉果得辟支佛果。设得如是功德。犹故不如闻上一句之义。次第受持读诵书写为人广说。何以故。声闻辟支佛功德皆从此经出故。因于此经能出一切菩萨。及诸佛出现于世。若读诵此经次第句义分别解说。即是受持一切佛法。何以故。此经即是一切经母。若不得此经。诸大胜法皆悉不得。此经即是菩萨具戒。一切诸声闻弟子皆从坐而起偏袒右肩。合掌白佛言。世尊。我等于大生死闻是经故皆得出离。佛言。比丘。如是如是。尔时世尊普告大众。善男子善女人。若国土方域。有是经典文字章句次第。当知此处即是道场处。即是转法轮处。即是诸佛大塔像处。有此经处即是世尊。何以故。善男子。法即是菩提。法即是转法轮。善男子。此法即是佛。供养于法即是供养佛。若有说法法师处。此处即是佛塔。于此法师当生殷重想。善知识想。作示正道想。见是法师应生爱乐信敬欢喜。应起远迎请令就坐。应当赞叹善哉善哉快说法要。若一劫若减一劫。若过一劫赞叹。如是赞叹犹不能尽。何以故。若人好乐法者。种种赞叹尊重恭敬。犹不能尽所行之处。假使有人能以血洒地。犹故不名尽心供养。何以故。如此法师则为受持如来一切佛种。如此法师应如师子无异。不应作下劣想。不作毁害心。着净洁衣深生信敬。得他赞叹而心不高。亦不起我慢亦不轻他不为财利专心说法。尔时释提桓因白佛言。世尊。若有世界能说是经文字章句次第之处。我当躬自将诸眷属。往彼供养拥护法师。佛言。善哉善哉。憍尸迦。是汝应作。尔时除盖障菩萨摩诃萨白佛言。世尊。此次第所说。当云何名斯经。善男子。此经文字章句次第。当名宝云。亦名宝藏。亦名智灯。亦名除盖障菩萨之所受持。尔时除盖障菩萨及诸菩萨。闻已。诸大声闻帝释大梵护世天王摩醯首罗并诸天子而为上首。乃至天龙夜叉乾闼婆阿修罗迦楼罗摩睺罗伽无量百千亿众。皆称善哉善哉。欢喜奉行

宝云经卷第七


贝多树下思惟十二因缘经(亦名闻城十二因缘经)

    No. 713 [Nos. 714, 715]

贝多树下思惟十二因缘经(亦名闻城十二因缘经)

        吴月氏优婆塞支谦译

闻如是。一时佛在舍卫国。止祇树给孤独园。是时佛告比丘。比丘便应唯然。比丘从佛听。佛便说言。诸比丘。我本未得佛道为菩萨时为念是。咄是世间极剧。为生老死。为往受但苦。当何时从老死得要也。诸比丘便自思惟得是意。何以故有老死。亦何因缘复老死。比丘便念。本得应意。生故为有老死。亦生因缘复老死。比丘便思惟念。何以故为生。亦何因缘复生。比丘便自思惟案本念。便得是应意。为有故生。亦因缘有复生。比丘便思惟生是意。何以故为有。有亦何因缘复有。比丘便思惟案本念。便生应是意。为受故有。有亦受因缘复有。比丘便思惟。是何以故受。有亦何因缘复受。比丘便案本念。得是应意。为爱故受。亦爱因缘复受。比丘便思惟念。何以故为爱。有亦何因缘复爱。比丘便思惟案本念。得要。痛乐故爱。亦痛乐因缘复爱。比丘便思惟念。何以痛乐有。亦何因缘痛乐复有。比丘便思惟案本念。复是应意。更故痛乐有。亦更因缘痛乐复痛乐。比丘便思惟念。何以故有。更亦何因缘复更。比丘便思惟案本念。便生应意。六入故有。更亦六入因缘复更。比丘便思惟念。何以故有六入。亦何因缘复有六入。比丘便思惟案本念。得是应意。名像故有六入。亦名像因缘复有六入。比丘便思惟念。何以故名像有。亦何因缘复有名像。比丘便思惟案本念。得是应意。识故为名像有。亦识因缘复有名像。比丘便思惟念。何以故有识。亦何因缘复有识。比丘便思惟案本念。有是应意。名像故为有识。亦名像因缘复识。比丘便思惟。生是意。是何等。咄是识还不复前在。名像因缘识。亦识因缘名像。名像因缘六入。六入因缘更。更因缘痛。痛因缘爱。爱因缘受。受因缘有。有因缘生。生因缘老死忧哭苦。不可意愁从是致有。如是但为从五阴。一切苦从习生。比丘便自思惟念。何以故。无有老死。亦何故老死灭尽。比丘便案本念思惟得是应可意。无有生亦不老死。已生尽老死亦尽。比丘便自思惟念。何以故。不复生。亦何因缘复生尽比丘便思惟案本念。生是应意。有无是有者便不复生。有尽复生尽。比丘便思惟念。何等无有为有无有。何等尽为复有尽。诸比丘便思惟案本念。自生应意。受无有便有无有受已尽便有尽。诸比丘便思惟念。何等无有。令受无有。亦何等尽令受尽。诸比丘便思惟案本念。得应意。无有爱亦无有受。爱已尽便受尽。诸比丘便思惟念。何无有为爱无有。何尽复是爱尽。诸比丘便思惟案本念。意生如应。痛痒无有便爱无有。痛痒尽则爱尽。诸比丘便思惟念。何等无有则痛痒无有。何等尽是痛痒尽。便自思惟案本念。得是应。更乐无有则痛痒无有。更乐尽复痛痒尽。便复思惟念。何等无有更乐无有。何等尽是更乐尽。便复思惟念本。得应意。六入无有即更乐无有。六入尽更乐尽。便复思惟念。何等无有六入无有。何等尽则六入尽。便复思惟案本念。有是应意。名像无有则六入无有。名像尽复六入尽。便复思惟念。何等无有为名像无有。何等尽复名像尽。便复思惟案本念。有是意应。无有识亦无有名像。识尽复名像尽。便复思惟念。是何等无有则识无有。何等尽复识尽。便复思惟案本念。得是应意。无有殃种识亦无有。殃种已尽则识尽。便复思惟念。何等无有为殃种无有。何等尽为殃种尽。便复思惟念本。得应意。无有痴亦无有殃种。痴已尽则殃种尽。殃种已尽识尽。识尽名像尽。名像尽六入尽。六入尽更尽。更尽痛痒尽。痛痒尽爱尽。爱尽成就尽。成就尽有尽。有尽生尽。生尽老死尽。忧愁苦不可意剧便尽。如是最无有量苦阴便尽

佛告诸比丘。彼时念是。以自得故道所。佛从是往得便随。已随便知老死。亦知老死习。亦知老死灭。亦知老死行令度。生亦尔。有亦尔。受亦尔。爱亦尔。痛痒亦尔。更亦尔。六入亦尔。名像亦尔。识亦尔。殃种亦尔。便知痴。亦知痴习本。亦知何痴尽。亦知受行令痴尽。譬比丘。若人在空泽间闲处行。便见故道。故有行者迹。人便随迹。已随迹便见故城。好足园好足饶树好足池好足河好山。堑亦好处炽饶园乐。便念是。若我今往当白王。我为行在空泽间闲处。便见故道故人行处。便随已随见故城。好足园好足饶树好足池好河好山。堑亦好处炽饶园乐。可王居。王便取居。却后稍严稍增炽多人饶。佛告诸比丘。我亦如是。得故道所。佛本从是行者我便随。已随便知老死从所。亦知老死从聚。亦知老死何尽。亦知老死何行得度世。知生亦尔。知有亦尔。知受亦尔。知爱亦尔。知痛痒亦尔。知更亦尔。知六入亦尔。知名像亦尔。知识亦尔。知作行亦尔。知痴亦知痴从生。亦知从何痴灭。亦知何行除痴度世

佛便告比丘比丘尼优婆塞优婆夷。若比丘为比丘如有应受行。便得道不失道能巧道。比丘尼亦尔。优婆塞亦尔。优婆夷亦尔。若谛受正行。便随道得道。能如应法行。如是无为行者。增多方至。天亦人已见佛说如是宜。比丘取着意佛。行者受贝多树下思惟十二因缘经


本事经

    No. 765

本事经卷第一

        大唐三藏法师玄奘奉　诏译

    一法品第一之一

吾从世尊。闻如是语。苾刍当知。我观世间。无别一法。覆障群生。驰骋流转生死长途。如无明盖。所以者何。世间群生。由无明盖所覆障故。驰骋流转生死长途。是故汝等。应如是学。我当云何修起慧明。破无明盖。出贪爱网。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  无别有一法　　覆障诸群生
  驰流生死途　　如无明盖者
  无明大愚闇　　由斯久流转
  彼此有往来　　升沉高下趣
  若破无明盖　　解脱贪爱网
  不处生死流　　以无彼因故

吾从世尊。闻如是语。苾刍当知。我观世间。无别一法。系缚群生。驰骋流转生死长途。如贪爱结。所以者何。世间群生。由贪爱结所系缚故。驰骋流转生死长途。是故汝等。应如是学。我当云何修莹慧刀断贪爱结。破大闇聚。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  无别有一法　　系缚诸群生
  驰流生死途　　如贪爱结者
  贪爱大系缚　　由斯久流转
  彼此有往来　　升沉高下趣
  若断贪爱缚　　破大黑闇聚
  不处生死流　　以无彼因故

吾从世尊。闻如是语。苾刍当知。若一有情。于一劫中。流转生死。所受身骨。假使有能积聚下烂。其聚高广。如王舍城毗补罗山。况彼有情。无初后际。驰骋流转生死长途。所受身骨。而可测量。所以者何。苾刍当知。我说有情。于四圣谛。不了知故。不照见故。不现观故。不通达故。不审察故。驰骋流转生死长途。受诸骨身。是故汝等。应如是学。我当云何于四圣谛。了知照见。现观通达。审察究竟。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  一有情一劫　　受身骨不烂
  其聚量高广　　如毗补罗山
  况无初后际　　久流转生死
  所受诸骨身　　其量而可测
  受是大苦聚　　由不见圣谛
  故应修妙智　　正观四真实
  所谓苦圣谛　　苦因及苦灭
  能灭苦苦因　　八支真圣道
  此补特伽罗　　极七有流转
  定断一切结　　能尽诸苦边

吾从世尊。闻如是语。苾刍当知。我以佛眼。遍观世间。诸有业果。皆缘心意。一类有情。心意所使。行如是行。履如是道。身坏命终。如舍重担。堕诸恶趣。生地狱中。所以者何。彼诸有情。心意染污。由此为因。身坏命终。堕诸恶趣。生地狱中。尔时世尊。重摄此义。而说颂曰

  一类诸有情　　心意起染污
  我今当为汝　　记别其所生
  彼身坏命终　　如舍于重担
  必堕诸恶趣　　生于地狱中
  应知恶慧者　　由心意染污
  因斯染污故　　当生地狱中

吾从世尊。闻如是语。苾刍当知。我以佛眼。遍观世间。诸有业果。皆缘心意。一类有情。心意所使。行如是行。履如是道。身坏命终。如捐重担。升诸善趣。生于天中。所以者何。彼诸有情。心意清净。由此为因。身坏命终。升诸善趣。生天界中。尔时世尊。重摄此义。而说颂曰

  一类诸有情　　心意起清净
  我今当为汝　　记别其所生
  彼身坏命终　　如捐于重担
  必升诸善趣　　生于天界中
  应知善慧者　　由心意清净
  因斯清净故　　当生天界中

吾从世尊。闻如是语。苾刍当知。一切有情。皆由自业。业为伴侣。业为生门。业为眷属。业为依趣。业能分定。一切有情。下中上品。是故汝等。应当善知。诸业自性。诸业因缘。诸业品类。诸业异熟。诸业尽灭。趣业灭道。因缘资具。苾刍汝等。如我所说。应正了知。云何应知诸业自性业自性者。谓或思业。或思已业如是应知诸业自性。既正了知业自性已。云何应知诸业因缘业因缘者。谓诸贪爱如是。应知诸业因缘。既正了知诸业自性业因缘已。云何应知诸业品类。业品类者。谓别品类业。趣地狱身别品类业。趣傍生身别品类业。趣鬼界身别品类业。趣阿素洛界身别品类业。趣人界身别品类业。趣天界身。如是应知诸业品类。既正了知诸业自性诸业。因缘业品类已。云何应知诸业异熟。业异熟者。谓于此生。造作诸业。即此生中。能感诸有。或受未受。如是应知诸业异熟。既正了知诸业自性诸业因缘诸业品类业异熟已。云何应知诸业尽灭。业尽灭者。谓爱灭故。诸业尽灭。如是应知诸业尽灭。既正了知诸业自性诸业因缘诸业品类诸业异熟业尽灭已。云何应知趣业灭道因缘资具。趣业灭道因缘资具者。谓八支圣道。即是正见正思惟正语正业正命正精进正念正定。如是应知趣业灭道因缘资具。苾刍当知。诸有沙门。或婆罗门。若能正知诸业自性。诸业因缘。诸业品类。诸业异熟。诸业尽灭。趣业灭道。因缘资具。即能信我法毗奈耶。若能信我法毗奈耶。即能入我法毗奈耶。若能入我法毗奈耶。即能达我法毗奈耶。修行梵行。若能达我法毗奈耶。修行梵行。即能究竟。正尽诸业。所以者何。是诸沙门。或婆罗门。既正了知诸业自性。诸业因缘。诸业品类。诸业异熟。诸业尽灭。趣业灭道。因缘资具已。即于诸业。能厌离灭。究竟解脱。得善解脱。既善解脱。即能独立。既能独立。即具善修。既具善修。彼身坏已。法尔无有一切施设。尔时世尊。重摄此义。而说颂曰

  世间诸有情　　居前中后际
  皆属于自业　　业为其伴侣
  业为彼生门　　业为其眷属
  业为所依趣　　业能定三品
  随业彼彼生　　不定如轮转
  或处天人中　　或居四恶趣
  世间诸有情　　皆随业力转
  非国财妻子　　随从往余生
  彼于命终时　　所有皆顿舍
  独随业而往　　故皆由自业
  当来诸有情　　虽受如是业
  若能依佛教　　正信而出家
  彼于愚痴类　　无师开导中
  名能善修行　　不愚正法者
  故汝等苾刍　　精勤勿放逸
  应善知诸业　　相续正修行
  为尽业自性　　及业因缘等
  修八支圣道　　速令得圆满

吾从世尊。闻如是语。苾刍当知。世间所有恶不善法。于生起时。诸不善品。诸不善类。一切皆由意为前导。所以者何。意生起已。恶不善法。皆随后生。尔时世尊。重摄此义。而说颂曰

  诸不善法生　　为因能感苦
  皆意为前导　　与烦恼俱生
  意为前导法　　意尊意所使
  由意有染污　　故有说有行
  苦随此而生　　如轮因手转

吾从世尊。闻如是语。苾刍当知。世间所有白净善法。于生起时。善品善类。一切皆由意为前导。所以者何。意生起已。白净善法。皆随后生。尔时世尊。重摄此义。而说颂曰

  诸净善法生　　为因能感乐
  皆意为前导　　与善法俱生
  意为前导法　　意尊意所使
  由意有清净　　故有说有行
  乐随此而生　　如影随形转

吾从世尊。闻如是语。苾刍当知。世有一法。于生起时。与多众生。为不利益。为不安乐。引诸世间天人大众。作无义利。感大苦果。云何一法。是谓破僧。所以者何。苾刍当知。僧若破坏。一切大众。互兴诤论。递相诃责。递相陵蔑。递相骂辱。递相毁呰。递相怨嫌。递相恼触。递相反戾。递相诽谤。递相弃舍。当于尔时。一切世间。未敬信者。转不敬信。已敬信者。还不敬信。苾刍当知。如是名为世有一法。于生起时。与多众生。为不利益。为不安乐。引诸世间。天人大众。作无义利。感大苦果。尔时世尊。重摄此义而说颂曰

  世有一法生　　能起无量恶
  所谓僧破坏　　愚痴者随喜
  能破坏僧苦　　破坏众亦苦
  僧和合令坏　　经劫无间苦

吾从世尊。闻如是语。苾刍当知。世有一法。于生起时。与多众生。为大利益。为大安乐。引诸世间。天人大众。作大义利。感大乐果。云何一法。是谓僧和。所以者何。苾刍当知。僧若和合。一切大众。互无诤论。不相诃责。不相陵蔑。不相骂辱。不相毁呰。不相怨嫌。不相恼触。不相反戾。不相诽谤。不相弃舍。当于尔时。一切世间。未敬信者。便生敬信。已敬信者。转增敬信。苾刍当知。如是名为世有一法。于生起时。与多众生。为大利益。为大安乐。引诸世间。天人大众。作大义利。感大乐果。尔时世尊。重摄此义。而说颂曰

  世有一法生　　能起无量福
  所谓僧和合　　慧利者随喜
  能和合僧乐　　和合众亦乐
  僧破坏令和　　经劫受天乐

吾从世尊。闻如是语。苾刍当知。世间有情。一结断时。余一切结。皆亦随断。云何一结。是谓我慢。所以者何。诸所有结。细中粗品。一切皆以我慢为根。从我慢生。我慢所长。是故我慢一结断时。余一切结。皆亦随断。譬如世间楼观中心。普为楼观。众分依止。中心若坠。余亦随堕。如是我慢。诸结所依。我慢若断。余亦随灭。若诸苾刍。已断我慢。当知即是已断余结。若诸苾刍。已断余结。当知即是已尽苦边。已修正智。心善解脱。慧善解脱。无复后有。尔时世尊。重摄此义。而说颂曰

  如楼观中心　　众分所依止
  中心若坠堕　　余分皆堕落
  如是我慢结　　众结之所依
  我慢结断时　　诸结皆随灭
  苾刍断我慢　　余结悉随断
  余结既已断　　即得尽苦边
  既得尽苦边　　名已修正智
  心慧善解脱　　后有毕竟无

吾从世尊。闻如是语。苾刍当知。世有一法。若善修习。善多修习。摄持二利。令至圆满。谓现法利。令至圆满。及后法利。令至圆满。能成现法。利益安乐。能成后法。利益安乐。能成现后。利益安乐。云何一法。谓于所修诸善法中。修不放逸。所以者何。若于所修诸善法中。于不放逸。能善修习。善多修习。便能摄持二种义利。令至圆满。广说乃至能成现后利益安乐。是名一法。若善修习。善多修习。摄持二利。广说乃至能成现后利益安乐。尔时世尊。重摄此义。而说颂曰

  诸有多闻人　　能舍贪财位
  勤修不放逸　　证常乐涅槃
  智人无放逸　　能摄持二利
  谓现法当来　　俱令至圆满
  诸有善能成　　现后俱利乐
  前后众贤圣　　皆称为智人

重摄前经嗢拖南曰

  盖结劫两心　　业二意前行
  僧破及僧和　　断慢修不逸

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于贪。所以者何。一切有情。由贪染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由贪之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此贪者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于嗔。所以者何。一切有情。由嗔染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由嗔之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此嗔者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于痴所以者何。一切有情。由痴染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由痴之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此痴者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于覆。所以者何。一切有情。由覆染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由覆之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此覆者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于恼。所以者何。一切有情。由恼染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由恼之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此恼者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于忿。所以者何。一切有情。由忿染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由忿之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此忿者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于恨。所以者何。一切有情。由恨染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由恨之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此恨者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于嫉。所以者何。一切有情。由嫉染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由嫉之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此嫉者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于悭。所以者何。一切有情。由悭染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由悭之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此悭者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于耽。所以者何。一切有情。由耽染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由耽之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此耽者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于慢。所以者何。一切有情。由慢染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由慢之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此慢者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永断一法。我证彼定。得不还果。云何一法。谓是于害。所以者何。一切有情。由害染故。数数还来。堕诸恶趣。受生死苦。若能永断。如是一法。我证彼定。得不还果。不复还来。生此世间。是故我说。若诸有情。永断一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由害之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此害者
  定得不还果　　不来生此间

重摄前经嗢拖南曰

  贪欲嗔恚痴　　覆藏恼及忿
  怨恨嫉与悭　　耽嗜慢将害

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念佛。所以者何。一切有情。由不念佛故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念佛故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于佛者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念法。所以者何。一切有情。由不念法故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念法故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于法者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念圣众。所以者何。一切有情。由不念圣众故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念圣众
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于圣众
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念戒。所以者何。一切有情。由不念戒故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念戒故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于戒者
  定得不还果　　不来生此间

吾从世尊闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念施。所以者何。一切有情。由不念施故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念施故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于施者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念天。所以者何。一切有情。由不念天故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我说彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念天故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于天者
  定得不还果　　不来生世间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念休息。所以者何。一切有情。由不念休息故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念休息
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于休息
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念安般。所以者何。一切有情。由不念安般故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念安般
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于安般
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念身。所以者何。一切有情。由不念身故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念身故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于身者
  定得不还果　　不来生此间

吾从世尊。闻如是语。苾刍当知。若诸有情。永念一法。我证彼定。得不还果。云何为一法。谓是念死。所以者何一切有情。由不念死故。数数还来。堕诸恶趣。受生死苦。若能常念如是一法。我证彼定。得不还果。不复还来生此世间。是故我说。若诸有情。能念一法。我证彼定。得不还果。尔时世尊。重摄此义。而说颂曰

  我观诸有情　　由不念死故
  还来堕恶趣　　受生死轮回
  若能正了知　　永念于死者
  定得不还果　　不来生此间

本事经卷第一本事经卷第二

        大唐三藏法师玄奘奉　诏译

    一法品第一之二

吾从世尊。闻如是语。苾刍当知。若有于贪未如实知。未正遍知。未能永断。彼于自心。未离贪故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于贪已如实知。已正遍知。已能永断。彼于自心。已离贪故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于贪应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说偈言

  若于贪未知　　彼去涅槃远
  于贪已知者　　去涅槃不遥
  我观诸有情　　由贪之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此贪者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于嗔未如实知。未正遍知。未能永断。彼于自心。未离嗔故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于嗔已如实知。已正遍知。已能永断。彼于自心。已离嗔故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于嗔应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于嗔未知　　彼去涅槃远
  于嗔已知者　　去涅槃不遥
  我观诸有情　　由嗔之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此嗔者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于痴未如实知。未正遍知。未能永断。彼于自心。未离痴故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于痴已如实知。已正遍知。已能永断。彼于自心。已离痴故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于痴。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于痴未知　　彼去涅槃远
  于痴已知者　　去涅槃不遥
  我观诸有情　　由痴之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此痴者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于覆未如实知。未正遍知。未能永断。彼于自心。未离覆故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于覆已如实知。已正遍知。已能永断。彼于自心。已离覆故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于覆。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于覆未知　　彼去涅槃远
  于覆已知者　　去涅槃不遥
  我观诸有情　　由覆之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此覆者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于恼未如实知。未正遍知。未能永断。彼于自心。未离恼故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于恼已如实知。已正遍知。已能永断。彼于自心。已离恼故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于恼。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于恼未知　　彼去涅槃远
  于恼已知者　　去涅槃不遥
  我观诸有情　　由恼之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此恼者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于忿未如实知。未正遍知。未能永断。彼于自心。未离忿故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于忿。已如实知。已正遍知。已能永断。彼于自心。已离忿故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于忿。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于忿未知　　彼去涅槃远
  于忿已知者　　去涅槃不遥
  我观诸有情　　由忿之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此忿者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于恨未如实知。未正遍知。未能永断。彼于自心。未离恨故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于恨。已如实知。已正遍知。已能永断。彼于自心。已离恨故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于恨。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于恨未知　　彼去涅槃远
  于恨已知者　　去涅槃不遥
  我观诸有情　　由恨之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此恨者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于嫉未如实知。未正遍知。未能永断。彼于自心。未离嫉故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于嫉已如实知。已正遍知。已能永断。彼于自心。已离嫉故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于嫉。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于嫉未知　　彼去涅槃远
  于嫉已知者　　去涅槃不遥
  我观诸有情　　由嫉之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此嫉者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于悭未如实知。未正遍知。未能永断。彼于自心。未离悭故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得。无上安乐。若有于悭已如实知。已正遍知。已能永断。彼于自心。已离悭故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于悭。应如实知。应正遍知应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于悭未知　　彼去涅槃远
  于悭已知者　　去涅槃不遥
  我观诸有情　　由悭之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此悭者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于耽未如实知。未正遍知。未能永断。彼于自心。未离耽故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于耽已如实知。已正遍知。已能永断。彼于自心。已离耽故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于耽。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于耽未知　　彼去涅槃远
  于耽已知者　　去涅槃不遥
  我观诸有情　　由耽之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此耽者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于慢未如实知。未正遍知。未能永断。彼于自心。未离慢故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于慢已如实知。已正遍知。已能永断。彼于自心。已离慢故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于慢。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于慢未知　　彼去涅槃远
  于慢已知者　　去涅槃不遥
  我观诸有情　　由慢之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此慢者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若有于害未如实知。未正遍知。未能永断。彼于自心。未离害故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若有于害已如实知。已正遍知。已能永断。彼于自心。已离害故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。是故于害。应如实知。应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄上义。而说颂曰

  若于害未知　　彼去涅槃远
  于害已知者　　去涅槃不遥
  我观诸有情　　由害之所染
  还来堕恶趣　　受生死轮回
  若能正了知　　永断此害者
  得上沙门果　　毕竟不受生

吾从世尊。闻如是语。苾刍当知。若于一切。未如实知。未正遍知。未能永断。彼于自心。未离一切故。不能通达。不能遍知。不能等觉。不能涅槃。不能证得无上安乐。若于一切。已如实知。已正遍知。已能永断。彼于自心。已离一切故。即能通达。即能遍知。即能等觉。即能涅槃。即能证得无上安乐。故于一切。应如实知应正遍知。应求永断。于佛法中。当修梵行。尔时世尊。重摄此义。而说颂曰

  若一切未知　　彼去涅槃远
  一切已知者　　去涅槃不遥
  我观诸有情　　由一切所染
  还来堕恶趣　　受生死轮回

重摄前经嗢拖南曰

  食恚及愚痴　　覆藏恼忿恨
  嫉悭与耽嗜　　慢害将一切

吾从世尊。闻如是语。苾刍当知。一切修习。福业事中。慈心解脱。最为第一。所以者何。慈心解脱。威德炽盛。映蔽一切诸福业事。以彼诸事所有威德。欲比所修。慈心解脱。十六分中。亦不及一。苾刍当知。譬如小大诸国王中。转轮圣王。最为第一。所以者何。转轮圣王。威德炽盛。映蔽一切小大诸王。以彼诸王所有威德。比转轮王。十六分中。亦不及一。诸福业事。亦复如是。欲比所修慈心解脱。十六分中。亦不及一。又如小大诸星之中。其满月轮。最为第一。所以者何。是满月轮。威光炽盛。映蔽一切小大诸星。以彼诸星所有威光。比满月轮。十六分中。亦不及一。诸福业事。亦复如是。欲比所修慈心解脱。十六分中。亦不及一。尔时世尊。重摄此义。而说颂曰

  一切福业事　　比慈心解脱
  于十六分中　　亦不能及一
  于一有情所　　能修慈善心
  其福尚无边　　何况于一切
  诸有大国王　　威伏于大地
  世间祠施会　　一切无不为
  如是祠施福　　比所修慈心
  于十六分中　　亦不能及一
  如转轮圣帝　　威德蔽诸王
  亦如满月轮　　其光映诸宿
  如是诸所修　　一切福业事
  皆为慈善心　　威德之所覆
  修慈心解脱　　若人若非人
  一切诸有情　　皆不能为害

吾从世尊。闻如是语。苾刍当知。我观世间。无别一法。为诸有学未得心者。希求无上安乐果时。作外强缘。如善知识。所以者何。彼诸有情。因善知识。所求皆遂。谓断众恶。修习诸善。得无杂染真净之身。尔时世尊。重摄此义。而说颂曰

  我观诸世间　　无别有一法
  学未得心者　　求无上果时
  为作外强缘　　如彼善知识
  亲近善知识　　所求无不成
  恭敬受其教　　无放逸奉行
  速证于涅槃　　离怖常安乐

吾从世尊。闻如是语。苾刍当知。我观世间。无别一法。为诸有学未得心者。希求无上安乐果时。作内强缘。如正作意。所以者何。彼诸有情。因正作意。所求皆遂。谓断众恶。修习诸善。得无杂染真净之身。尔时世尊。重摄此义。而说颂曰

  我观诸世间　　无别有一法
  学未得心者　　求无上果时
  为作内强缘　　如彼正作意
  修习正作意　　所求无不成
  如理审观察　　无放逸修行
  速证于涅槃　　离怖常安乐

吾从世尊。闻如是语。苾刍当知。若诸有情。能知惠施。所感果报。明了现前。如我知者。必无悭吝。缠染其心。设彼唯有所食一抟。要分施他。然后自食。以不知故。为诸悭吝缠染其心。虽有无量饮食财宝。而不施他唯自食用。所以者何。惠施果报。生人天中。无量往返。受诸快乐。尔时世尊。重摄此义。而说颂曰

  世间诸有情　　若了知惠施
  能感大果报　　明见似如来
  其心必不为　　悭吝所缠染
  唯有食一抟　　而亦能分施
  由不知施果　　明见似如来
  虽有多财食　　悭吝不能舍
  若于凡圣田　　三时心喜施
  感人天果报　　往返量无边

吾从世尊。闻如是语。苾刍当知。若诸有情。能知犯戒。所感果报。明了现前。如我知者。行住坐卧。皆不能安。言笑饮食。都无思念。其心惊惶。狂乱吐血。身形萎悴。如被刈芦。以不知故。安然无畏。所以者何。诸犯戒罪。能感恶趣。增上猛利。诸苦果报。尔时世尊。重摄此义。而说颂曰

  世间诸有情　　若了知犯戒
  能感苦果报　　明见似如来
  四威仪不安　　不思言笑等
  心惊狂吐血　　身悴如刈芦
  由不知犯戒　　能感恶趣苦
  明见似如来　　安然不惊惧
  诸有犯戒人　　定堕于恶趣
  受增上猛利　　苦果报无边

吾从世尊。闻如是语。苾刍当知。若诸有情。能知持戒。所感果报。明了现前。如我知者。彼于自身。深生厌离。欣乐当来。坚持禁戒。以不知故。乐着自身。毁犯禁戒。所以者何。诸持戒福。能感善趣。增上猛利。诸乐果报。尔时世尊。重摄此义。而说颂曰

  世间诸有情　　若了知持戒
  能感乐果报　　明见似如来
  便于不净身　　深能生厌离
  求当来胜果　　坚守净尸罗
  由不知持戒　　能感善趣乐
  明见似如来　　故毁犯净戒
  诸有持戒人　　得生于善趣
  受天诸妙乐　　证无上涅槃

吾从世尊。闻如是语。苾刍当知。若诸有情。知而妄语。无惭无愧。无改悔心。我说彼于恶不善业无不能造。尔时世尊。重摄此义。而说颂曰

  知而故妄语　　无惭愧悔心
  如是诸有情　　无恶而不造

吾从世尊。闻如是语。苾刍当知。若诸有情。知而妄语。深生惭愧。有改悔心。我说彼于白净善法无不能造。尔时世尊。重摄此义。而说颂曰

  知而故妄语　　有惭愧悔心
  如是诸有情　　无善而不造
  精勤不放逸　　如说正修行
  得无上涅槃　　永离诸怖畏

吾从世尊。闻如是语。苾刍当知。有一最胜补特伽罗。彼于世间。若不出现。无量有情。退失圣慧。云何为一补特伽罗。所谓如来应正等觉。所以者何。若诸如来应正等觉。不现世间。无能宣说修圣慧法。故诸有情退失圣慧。苾刍当知。诸有退失亲友财位。名小退失。退失圣慧。名大退失。所以者何。若诸有情。退失圣慧。于现法中。多诸忧苦。无喜乐住。有灾有患。有恼有烧。及于当来长夜受苦。及受种种猛利灾害。增长血滴。常游死路。数堕地狱饿鬼傍生阿素洛趣。数受人天生死忧苦。所以者何。由彼有情。于其圣慧。未能随觉。未能通达。故于六趣。生死轮回。若诸有情。证得圣慧。便能出离。正尽苦边。是故汝等。应如是学。我当云何修习圣慧。令不退失。我当云何于诸圣慧。随觉通达。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  如来不出现　　世间诸有情
  无救无归依　　皆退失圣慧
  失亲友财位　　是名小退失
  若失真圣慧　　是名大退失
  我观诸世间　　失无上圣慧
  轮转于生死　　受诸名色身
  彼于现法中　　有苦无上乐
  于当来长夜　　久生死轮回
  若欲求圣慧　　正尽众苦边
  当愿诸如来　　数出现于世

吾从世尊。闻如是语。苾刍当知。有一最胜补特伽罗。彼于世间。若出现者。无量有情。增长圣慧。云何为一补特伽罗。所谓如来应正等觉。所以者何。若诸如来应正等觉。出现世间。有能宣说修圣慧法。令诸有情增长圣慧。苾刍当知。诸有增长亲友财位。名小增长。增长圣慧。名大增长。所以者何。若诸有情。增长圣慧。于现法中。多诸喜乐。无忧苦住。无灾无患。无恼无烧。不于当来长夜受苦。不受种种猛利灾害。不增血滴。不游死路。不堕地狱饿鬼傍生阿素洛趣。不受人天生死忧苦。所以者何。由彼有情。于其圣慧。已能随觉。已能通达。不于六趣生死轮回。若诸有情。未增圣慧。无能出离正尽苦边。是故汝等。应如是学。我当云何修习圣慧。令其增长。我当云何于诸圣慧。随觉通达。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  如来若出现　　世间诸有情
  有救有归依　　皆增长圣慧
  得亲友财位　　是名小增长
  若得真圣慧　　是名大增长
  我观诸世间　　得无上圣慧
  不流转生死　　定取于涅槃
  彼于现法中　　离苦常安乐
  于当来长夜　　离生死轮回
  若欲增圣慧　　正尽众苦边
  当愿佛世尊　　长久住于世

吾从世尊。闻如是语。苾刍当知。世有一法。于生长时。令诸有情愚痴增益颠倒坚固。垢秽随增。恶趣成满。与多众生为不利益。为不安乐。令诸世间人天大众。无义无利。增长忧苦。云何一法。所谓邪见。所以者何。由邪见故。令诸有情愚痴增益。颠倒坚固。垢秽随增。恶趣成满。与多众生为不利益。为不安乐。令诸世间人天大众。无义无利。增长忧苦。如是名为世有一法。于生长时。令诸有情愚痴增益。广说乃至。令诸世间。人天大众。无义无利。增长忧苦。尔时世尊。重摄此义。而说颂曰

  邪见生长时　　令愚痴增益
  及颠倒坚固　　诸垢秽随增
  成满诸恶趣　　为无利乐等
  邪见害愚夫　　如火烧众物

吾从世尊。闻如是语。苾刍当知。世有一法。于生长时。令诸有情愚痴损减。颠倒除灭。净法随增。脱诸恶趣。善趣成满。与多众生为大利益。为大安乐。令诸世间人天大众。有义有利。增长喜乐。云何一法。所谓正见。所以者何。由正见故。令诸有情愚痴损减。颠倒除灭。净法随增。脱诸恶趣。善趣成满。与多众生为大利益。为大安乐。令诸世间人天大众。有义有利增长喜乐。如是名为世有一法。于生长时。令诸有情愚痴损减。广说乃至。令诸世间人天大众。有义有利。增长喜乐。尔时世尊。重摄此义。而说颂曰

  正见生长时　　令愚痴损减
  及颠倒除灭　　诸净法随增
  脱恶满善趣　　为有利乐等
  正见现在前　　速证涅槃乐

吾从世尊。闻如是语。苾刍当知。我观世间。无别一法。速疾回转。犹如其心。所以者何。是心于境。速疾回转。世出世间。无可为喻。汝等应取如是心相。善取相已。应善思惟。善思惟已。应善观察。善观察已。应善安住。善安住已。若不觉有内贪欲缠。汝等复应审谛观察。我今为有内贪欲缠。而不觉耶。我今为无内贪欲缠。而不觉耶。审观察已。复应作意。思惟随一可爱境相。如是作意。思惟随一可爱相时。若心随顺趣向喜乐可爱境相。当知此心。随顺诸欲。违背出离。汝等尔时。应自觉了。我今犹有内贪欲缠。而不能觉。非为无有。我今未断五欲贪缠。所证与前未有差别。我今犹未证所修果。譬如有人。于驶流水。牵重船筏。逆上而行。此人尔时。多用功力。若暂懈慢。便顺下流如是汝等。思惟随一可爱相时。若心随顺趣向喜乐可爱境相。当知此心。随顺诸欲。违背出离。汝等尔时。应自觉了。我今犹有内贪欲缠。而不能觉。非为无有。我今未断五欲贪缠。所证与前未有差别。我今犹未证所修果。汝等作意。思惟随一可爱相时。若心随顺趣向喜乐。出离之相。当知此心。随顺出离。违背诸欲。汝等尔时。应自觉了。我今无有内贪欲缠。非彼犹有。而不能觉。我今已断五欲贪缠。所证与前已有差别。我今已能证所修果。如以筋羽投置火中。便即焦卷。而不舒缓。如是汝等。思惟随一可爱相时。若心随顺趣向喜乐出离之相。当知此心。随顺出离。违背诸欲。汝等尔时。应自觉了。我今无有内贪欲缠。非彼犹有。而不能觉。我今已断五欲贪缠。所证与前已有差别。我今已能证所修果是故汝等。应如是学。我当云何善转自心。令其调伏。违背诸欲。随顺出离。汝等苾刍。应如是学。尔时世尊重摄此义。而说颂曰

  无别有一法　　性躁动如心
  难调御难防　　大仙之所说
  譬如有智人　　以火等众具
  调直于利箭　　令远有所中
  如是诸苾刍　　应善学方便
  调直于心性　　令速证涅槃

重摄前经嗢拖南曰

  修慈修二缘　　施犯戒持戒
  二妄二圣慧　　邪见正见心

本事经卷第二本事经卷第三

        大唐三藏法师玄奘奉　诏译

    二法品第二之一

吾从世尊。闻如是语。苾刍当知。若有苾刍。成就二分。于现法中。多诸忧苦。无喜乐住。有灾有患。有恼有烧。有罪有责。为诸有情同梵行者之所诃毁。身坏命终。生诸恶趣。云何为二。一于根门。不能守护。二于饮食。不善知量。诸有苾刍。成就此二。于现法中。多诸忧苦。无喜乐住。有灾有患。有恼有烧。有罪有责。为诸有智同梵行者之所诃毁。身坏命终生诸恶趣。尔时世尊。重摄此义。而说颂曰

  若不能守护　　眼等六根门
  饮食不知量　　成不信懈怠
  彼于现法中　　身心多受苦
  及有灾有患　　有恼有烧然
  行住与坐卧　　若觉若梦中
  由彼二因缘　　恒有罪有责
  居聚落空闲　　众中及静处
  有智常诃责　　当生恶趣中

吾从世尊。闻如是语。苾刍当知。若有苾刍。成就二分。于现法中。多诸喜乐。无忧苦住。无灾无患。无恼无烧。无罪无责。为诸有智同梵行者之所称赞。身坏命终。生诸善趣。云何为二。一于根门。能自守护。二于饮食。能善知量。诸有苾刍。成就此二。于现法中。多诸喜乐。无忧苦住。无灾无患。无恼无烧。无罪无责。为诸有智同梵行者之所称赞。身坏命终。生诸善趣。尔时世尊。重摄此义。而说颂曰

  若自能守护　　眼等六根门
  饮食善知量　　成就信精进
  彼于现法中　　身心多受乐
  及无灾无患　　无恼无烧然
  行住与坐卧　　若觉若梦中
  由彼二因缘　　恒无罪无责
  居聚落空闲　　众中及静处
  有智常称赞　　当生善趣中

吾从世尊。闻如是语。苾刍当知。有二种法。能生焦恼。云何为二。谓有一类补特伽罗。唯造众恶。唯作凶狂。唯起杂秽。不修众善。不习调柔。不救怖畏。彼于后时。身婴重疾遍体发生增上猛利。严切苦受。楚毒垂终。不可医疗。受此苦时。呻吟怨叹。作是念言。我从昔来。唯造众恶。唯作凶狂。唯起杂秽。本修众善。不习调柔。不救怖畏。若诸有情。唯造众恶。唯作凶狂。唯起杂秽。不修众善。不习调柔。不救怖畏。彼之所趣。我定当往。彼由唯造众恶等故。心生焦恼。及以不修众善等故。心生焦恼。如是名为有二种法。能生焦恼。尔时世尊。重摄此义。而说颂曰

  有二法能生　　愚者心焦恼
  谓唯作罪业　　及不修福因
  后遭病苦时　　呻吟而怨叹
  恨有罪无福　　心悔恼焦然
  有罪无福人　　所生诸恶趣
  我亦当随往　　决定无有疑

吾从世尊。闻如是语。苾刍当知。有二种法。心不焦恼。云何为二。谓有一类补特伽罗。唯修众善。唯习调柔。唯救怖畏。不造众恶。不作凶狂。不起杂秽。彼于后时。身婴重疾。遍体发生增上猛利。严切苦受。楚毒垂终。不可医疗。受此苦时。虽有呻吟。而无怨叹。作是念言我从昔来。唯修众善。唯习调柔。唯救怖畏。不造众恶。不作凶狂。不起杂秽。若诸有情唯修众善。唯习调柔。唯救怖畏。不造众恶。不作凶狂。不起杂秽。彼之所趣。我定当往。彼由唯修众善等故。心不焦恼。及以不造众恶等故。心不焦恼。如是名为有二种法。心不焦恼。尔时世尊。重摄此义而说颂曰

  有二法能生　　智者心欢喜
  谓唯修福业　　及不作罪因
  后遭病苦时　　呻吟无怨叹
  庆有福无罪　　不悔恼焦然
  有福无罪人　　所生诸善趣
  我亦当随往　　决定无有疑

吾从世尊。闻如是语。苾刍当知。为汝略说二速通行。云何为二。一者乐行。二者苦行。谓由乐行。证彼速通。及由苦行。证彼速通。所修加行。无涩难故。所得诸根。皆猛利故。是则名为乐速通行。所修加行。有涩难故。所得诸根。皆猛利故。是则名为苦速通行。是名略说二速通行。尔时世尊。重摄此义。而说颂曰

  今为汝略说　　二种速通行
  谓乐行苦行　　因斯证速通
  无涩难加行　　有猛利诸根
  由是大仙尊　　名乐速通行
  有涩难加行　　有猛利诸根
  由是大仙尊　　名苦速通行

吾从世尊。闻如是语。苾刍当知。为汝略说二迟通行。云何为二。一者乐行。二者苦行。谓由乐行。证彼迟通。及由苦行。证彼迟通。所修加行。无涩难故。所得诸根。皆羸钝故。是则名为乐迟通行。所修加行。有涩难故。所得诸根。皆羸钝故。是则名为苦迟通行。是名略说。二迟通行。尔时世尊。重摄此义。而说颂曰

  今为汝略说　　二种迟通行
  谓乐行苦行　　因此证迟通
  无涩难加行　　有羸钝诸根
  由是大仙尊　　名乐迟通行
  有涩难加行　　有羸钝诸根
  由是大仙尊　　名苦迟通行

吾从世尊。闻如是语。苾刍当知。若有一类补特伽罗。成就二法。不能发生白净善法。设已发生。不能决定。设已决定。不能圆满。彼于如是白净善法。能为障碍。能作衰损。能生忧悔。身坏命终。如弃重担。堕于地狱。受诸剧苦。云何为二。一者恶戒。二者恶见。诸有一类补特伽罗。成就如是所说二法。定不能生白净善法。设复已生。不能决定。广说乃至。身坏命终。如弃重担。堕于地狱。受诸剧苦。尔时世尊。重摄此义。而说颂曰

  若成就二法　　谓恶戒恶见
  彼人终不能　　生白净善法
  虽生而不定　　设定不圆满
  于白净善法　　能衰损障碍
  彼临命终时　　有忧悔悲恼
  如弃舍重担　　定生地狱中

吾从世尊。闻如是语。苾刍当知。若有一类补特伽罗。成就二法。定能发生白净善法。若先已生。能令决定。若先已定。能令圆满。彼于如是白净善法。不为障碍。不作衰损。不生忧悔。身坏命终。如弃重担。生天趣中。受诸快乐。云何为二。一者善戒。二者善见。诸有一类补特伽罗。成就如是所说二法。决定能生白净善法。若先已生。能令决定。广说乃至。身坏命终。如弃重担。生天趣中。受诸快乐。尔时世尊。重摄此义。而说颂曰

  若成就二法　　谓善戒善见
  彼人终定能　　生白净善法
  若生而决定　　决定必圆满
  于白净善法　　不衰损障碍
  彼临命终时　　无忧悔悲恼
  如弃舍重担　　定生天趣中

吾从世尊。闻如是语。苾刍当知。若有一类补特伽罗。成就二法。临命终时。能生忧悔。身坏命终。堕诸恶趣。生地狱中。云何为二。谓作不作。云何为作。谓身恶行。语恶行。意恶行。是名为作。云何不作。谓身妙行。语妙行。意妙行。是名不作。诸有一类补特伽罗。成就如是所说二法。临命终时。能生忧悔。身坏命终。堕诸恶趣。生地狱中。尔时世尊。重摄此义。而说颂曰

  诸有愚痴人　　作三种恶行
  不作三妙行　　引余过令生
  彼临命终时　　决定有忧悔
  死堕诸恶趣　　生于地狱中

吾从世尊。闻如是语。苾刍当知。若有一类补特伽罗。成就二法。临命终时。不生忧悔。身坏命终。升于善趣。生天界中。云何为二。谓作不作。云何为作。谓身妙行。语妙行。意妙行。是名为作。云何不作。谓身恶行。语恶行。意恶行。是名不作。诸有一类补特伽罗。成就如是所说二法。临命终时。不生忧悔。身坏命终。升于善趣。生天界中。尔时世尊。重摄此义。而说颂曰

  诸有智慧人　　作三种妙行
  不作三恶行　　引余德令生
  彼临命终时　　决定无忧悔
  死升诸善趣　　生于天界中

吾从世尊。闻如是语。苾刍当知。有二妙智。应修令生。能得未得。能触未触。能证未证。能超愁叹。能灭忧苦。能会正理。能获甘露。能证涅槃。云何为二。一者法智。二者类智。法智生时。便能无倒。遍知有为。于有为法。既遍知已。便能令彼感后有因不得生起增长广大。类智生时。便能如实断灭无明。灭无明故。便无戏论。无戏论故。便无寻伺。无寻伺故。便无乐欲。无乐欲故。便无爱憎。无爱憎故。便无悭嫉。无悭嫉故。便无种种执持刀杖。违害斗诤。互相骂辱。不真实语。相离间语。诸杂秽语。及余无量恶不善法。无彼诸恶不善法故。感后有业。便不增长。感后有业。不增长故。诸业灭尽。业灭尽故。众苦灭尽。苦灭尽故。生死路绝。此路绝已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是名为有二妙智。应修令生。能得未得。能触未触。能证未证。能超愁叹。能灭忧苦。能会正理。能获甘露。能证涅槃。尔时世尊。重摄此义。而说颂曰

  有二种妙智　　应修习令生
  能得未得等　　谓法智类智
  若法智生时　　遍知有为法
  便能令后有　　因不生不增
  若类智生时　　无明便断灭
  由此展转法　　绝生死轮回
  自知我生尽　　及梵行已立
  所作皆已办　　更不受后有

吾从世尊。闻如是语。苾刍当知。有二妙智。应正寻思。应善称量。应审观察。能得未得。能触未触。能证未证。能超愁叹。能灭忧苦。能会正理。能获甘露。能证涅槃。云何为二。谓世间智。及出世智。世间智者。谓于色蕴。能正了知。此为色蕴。于受想行及识蕴中。亦复如是。于其地界。能正了知。此为地界。于水火风及空识界。亦复如是。于其眼界。能正了知。此为眼界。于其色界及眼识界。亦复如是。于其耳界。能正了知此为耳界。于其声界及耳识界。亦复如是。于其鼻界。能正了知。此为鼻界。于其香界及鼻识界。亦复如是。于其舌界。能正了知。此为舌界。于其味界。及舌识界。亦复如是。于其身界。能正了知。此为身界。于其触界及身识界。亦复如是。于其意界。能正了知。此为意界。于其法界及意识界。亦复如是。于如此等世俗法中。如是如是。如实了知。智见通慧。现观等觉。周遍照了。名世间智。诸圣弟子。于此所说世间智中。应正寻思。应善称量。应审观察。此世间智。正修习时。为能令生生法有情永脱生不。为能令彼老法有情永脱老不。病法死法。愁法叹法。忧法苦法。不安隐法。亦复如是。既审察已。能正了知。此世间智。正修习时。不能令彼生法有情永脱于生。不能令彼老法有情永脱于老。病法死法。愁法叹法。忧法苦法。不安隐法。亦复如是。所以者何。此世间智。非贤圣法。非能永出。非趣涅槃。非能永厌。非能永离。非能永灭。非能永寂。非真通慧。非正等觉。不证涅槃。是感生法。是感老法病法死法愁法叹法忧法苦法不安隐法。彼于如是。寻思称量。审观察时。于世间法。住怖畏想。于出世法。住安静想。以于世间生怖畏故。都无执受。无执受故。不生渴爱。不渴爱故。便自内证究竟涅槃。证涅槃已。便自了知。我生已尽。梵行已立。所作已办。不受后有。是名于此世间智中应正寻思应善称量应审观察。出世智者。谓于一切蕴界处中。能正了知。如是诸法。是无常性。苦性病性。痈性箭性。恼性害性。怖性热性。坏性灭性。灾性横性。有疫疠性。虚性伪性。空性妄性。无实我性。难保信性。于如是等诸法性中。如实了知。智见通慧。现观等觉。周遍照了名出世智。诸圣弟子。于此所说出世智中。应正寻思应善称量应审观察。此出世智。正修习时。为能令彼生法有情永脱生不。为能令彼老法有情永脱老不。病法死法。愁法叹法。忧法苦法。不安隐法。亦复如是。既审察已。能正了知。此出世智。正修习时。定能令彼生法有情永脱于生。定能令彼老法有情永脱于老。病法死法。愁法叹法。忧法苦法。不安隐法。亦复如是。所以者何。此出世智。是贤圣法。是能永出。是趣涅槃。是能永厌。是能永离。是能永灭。是能永寂。是真通慧。是正等觉。能证涅槃。非感生法。非感老法。病法死法愁法叹法忧法苦法不安隐法。彼于如是寻思称量审观察时。于出世法。生珍宝想。于世间法。生下贱想。以于出世。生珍宝故。便生欢喜。生欢喜故。其心安适。心安适故。身得轻安。身轻安故。便受悦乐。受悦乐故。心得寂定。心寂定故。能实知见。实知见故。能深厌背。深厌背故。能正离欲。正离欲故。能得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。是名于此出世智中。应正寻思应善称量应审观察。如是名为有二妙智。应正寻思应善称量应审观察。能得未得。能触未触。能证未证。能超愁叹。能灭忧苦。能会正理。能获甘露。能证涅槃。尔时世尊。重摄此义。而说颂曰

  有二种妙智　　知者应寻思
  谓世出世间　　能正尽众苦
  应观世间智　　发生怖畏想
  都无有执受　　展转证涅槃
  应观出世智　　发生珍宝想
  由此生欢喜　　便得身轻安
  轻安故悦乐　　悦乐故心定
  由心得定故　　便能生觉支
  觉支观圣谛　　永断诸疑网
  无疑无所取　　永脱众苦边

重摄前经嗢柁南曰

  二根二焦恼　　二行二戒见
  二作及不作　　二智有二种

吾从世尊。闻如是语。苾刍当知。若有苾刍。为欲矫诳诸众生故。为求名誉远所闻故。为求利养及恭敬故。而出家者。不名真实。于如来所。修行梵行。若有苾刍。为通达故。为遍知故。而出家者。是名真实。于如来所。修行梵行。所以者何。是诸苾刍。为通达故。为遍知故。而出家已。便能如实。通所通达。知所遍知。既能如实。通所通达。知所遍知。便能如实。断所应断。修所应修。证所应证。既能如实断修证已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是若有为通达故。为遍知故。而出家者。是名真实。于如来所。修行梵行。尔时世尊。重摄此义。而说颂曰

  为矫诳名誉　　利养及恭敬
  非真修梵行　　是虚妄出家
  为通达遍知　　速证最上义
  是真修梵行　　非虚妄出家

吾从世尊。闻如是语。苾刍当知。若有苾刍。为欲矫诳诸众生故。为求名誉远所闻故。为求利养及恭敬故。而出家者。不名真实。于如来所。修行梵行。若有苾刍。为律仪故。为正断故。而出家者。是名真实于如来所。修行梵行。所以者何。是诸苾刍。为律仪故。为正断故。而出家已。便能如实。守护六根。不亏禁戒及能速证最上正断。既能如实。守护六根。不亏禁戒及能速证最上正断。便能如实。断所应断。修所应修。证所应证。既能如实断修证已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是若有为律仪故。为正断故。而出家者。是名真实。于如来所。修行梵行。尔时世尊。重摄此义。而说颂曰

  为矫诳名誉　　利养及恭敬
  非真修梵行　　是虚妄出家
  为正断律仪　　速证最上义
  是真修梵行　　非虚妄出家

吾从世尊。闻如是语。苾刍当知。若有苾刍。为欲矫诳诸众生故。为求名誉远所闻故。为求利养及恭敬故。而出家者。不名真实。于如来所。修行梵行。若有苾刍。为求厌背。为求离欲。而出家者。是名真实。于如来所。修行梵行。所以者何。是诸苾刍。为厌背故。为离欲故。而出家已。便能如实厌背离欲。既离欲已。便得解脱。既解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是若有。为厌背故。为离欲故。而出家者。是名真实。于如来所。修行梵行。尔时世尊。重摄此义。而说颂曰

  为矫诳名誉　　利养及恭敬
  非真修梵行　　是虚妄出家
  为厌背离欲　　速证最上义
  是真修梵行　　非虚妄出家

吾从世尊。闻如是语。苾刍当知。一切如来应正等觉。所说法门。略有二种。云何为二。一者于恶应正了知。二者于恶应深厌背一切如来应正等觉。略说如是二种法门。所以者何。诸修行者。于诸恶法应正了知。既于恶法。正了知已。便能厌背。既厌背已。便能离欲。既离欲已。便得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是行者。永断诸爱及众结缚。无倒现观。正尽苦边。尔时世尊。重摄此义。而说颂曰

  当知诸如来　　应正等觉者
  哀愍众生故　　说二种法门
  于众恶正知　　及厌背离欲
  心解脱自在　　正尽众苦边

吾从世尊。闻如是语。苾刍当知。有二种法。若修若习。若多修习。能断二法。云何二法。若修若习。若多修习。能断二法。谓不净观及慈悲观。能断贪欲及与嗔恚。所以者何。一切已贪现贪当贪。皆由作意思惟净相。一切已嗔现嗔当嗔。皆由作意思惟怨相。一切已断现断当断所有贪欲。皆由作意修不净观。一切已断现断当断所有嗔恚。皆由作意修慈悲观。于不净观。若修若习。若多修习。决定能断一切贪欲。于慈悲观。若修若习。若多修习。决定能断一切嗔恚。若欲决定断贪欲者。当勤精进修不净观若欲决定断嗔恚者。当勤精进修慈悲观。修不净观。无有贪欲。而不能断修慈悲观。无有嗔恚。而不能断。如是名为有二种法。若修若习。若多修习。能断二法。尔时世尊重摄此义。而说颂曰

  修习多修习　　二法断二法
  谓不净慈悲　　断贪欲嗔恚
  是故有智者　　当观自饶益
  修不净慈悲　　断贪欲嗔恚

吾从世尊。闻如是语。苾刍当知。其涅槃界。略有二种。云何为二。一者有余依涅槃界。二者无余依涅槃界。云何名为有余依涅槃界。谓诸苾刍。得阿罗汉。诸漏已尽。梵行已立。所作已办。已舍重担。已证自义。已尽有结。已正解了。心善解脱。已得遍知。宿行为缘。所感诸根。犹相续住。虽成诸根。现触种种好丑境界。而能厌舍。无所执着。不为爱恚缠绕其心。爱恚等结。皆永断故。彼于诸色。求欲见时。虽复以眼观于诸色。而不发起贪嗔痴等。虽复有眼及好丑色。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。彼于诸声。求欲闻时。虽复以耳听于诸声。而不发起贪嗔痴等。虽复有耳及好丑声。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。彼于诸香。求欲嗅时。虽复以鼻嗅于诸香。而不发起贪嗔痴等。虽复有鼻及好丑香。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。彼于诸味。求欲尝时。虽复以舌尝于诸味。而不发起贪嗔痴等。虽复有舌。及好丑味。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。彼于诸触。求欲觉时。虽复以身觉于诸触。而不发起贪嗔痴等。虽复有身及好丑触。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。彼于诸法。求欲知时。虽复以意知于诸法。而不发起贪嗔痴等。离诸贪欲证得究竟寂灭涅槃。作是思惟。世尊。为彼怖畏诸有阿赖耶者。恒为断见所系缚者。令知业果无失坏故。所说正法。现见应时。易见饶益。智者内证一切世间真实对治。谓能除灭憍慢渴爱害阿赖耶。断诸径路。证真空性。离诸贪欲。证得究竟寂灭涅槃。如是名为有慧眼者。能正观察。如是名为由二缠故。令诸天人。一类怯劣。一类勇猛。有慧眼者。能正观察。尔时世尊。重摄此义。而说颂曰

  由二缠所缠　　令诸天人众
  一类有怯劣　　一类有勇猛
  有慧眼声闻　　能如实观察
  能除慢厌离　　究竟证涅槃
  复如实了知　　佛所说正法
  能灭断常见　　及二爱无余
  有慧眼龙王　　能普雨法雨
  灭诸烦恼焰　　令证大清凉

本事经卷第三

    挍正后序

此一卷经宋乡则同。同有四十三段。丹本唯有十八段耳。多少如是不同文义。始终迥异如何去取。今捡宋乡本经有四大错。丹有二事以知其正。何则此卷品名既是二法。则应始终唯说二法。而宋乡本经四十三段皆是一法。则名义不相当。是一错也。又宋乡本卷初二段及第三段前六行文。则是诸本初卷三幅。心义经一段十二行耳。宋乡于此三重重写。是二错也。第三段中一类有情已下。即是诸本初卷七幅。破僧经一段十七行耳。宋乡于此重重写之。其乃至于四十一重。是三错也。其卷末颂云。贪欲嗔恚痴。覆藏及恼忿。不恨嫉与悭。耽嗜慢将害者。即是诸本第二卷九幅结经颂。正云贪恚及愚痴。覆藏恼忿恨。嫉悭与贪嗜。慢害将一切。之小讹变耳。宋乡于此闲重写之。是四错也。故知大错耳。今此丹本十八段经始从成就二分。终至二果二缠。皆是二法即与品目名义相当。是一正也。又按诸本第四卷中七幅有结颂云。为通达律仪。厌知不净果。缠觉悟宴坐。愧所作寻求者。则结十二经为一颂。其觉悟已下五经。即是诸本万四卷卷初五经。其缠经果经已上七经。即是丹本此卷卷末七经耳。则列结相应。是二正也。余本则非。故今取此丹本为正云

虽复有意及好丑法。而无贪欲。亦无嗔恚。所以者何。爱恚等结。皆永断故。乃至其身。相续住世。未般涅槃。常为天人。瞻仰礼拜。恭敬供养。是名有余依涅槃界。云何名为无余依涅槃界。谓诸苾刍。得阿罗汉。诸漏已尽。梵行已立。所作已办。已舍重担。已证自义。已尽有结。已正解了。已善解脱。已得遍知。彼于今时。一切所受。无引因故。不复希望。皆永尽灭。毕竟寂静。究竟清凉。隐没不现。惟由清净。无戏论体。如是清净。无戏论体。不可谓有。不可谓无。不可谓彼亦有亦无。不可谓彼非有非无。惟可说为不可施设究竟涅槃。是名无余依涅槃界。苾刍当知。如是名为略有二种涅槃之界。尔时世尊。重摄此义。而说颂曰

  漏尽心解脱　　任持最后身
  名有余涅槃　　诸行犹相续
  诸所受皆灭　　寂静永清凉
  名无余涅槃　　众戏论皆息
  此二涅槃界　　最上无等伦
  谓现法当来　　寂静常安乐

吾从世尊。闻如是语。苾刍当知。由二缠故。令诸天人。一类怯劣。一类勇猛。有慧眼者。能正观察。云何二缠。谓有见缠。无有见缠。云何天人一类怯劣谓有天人。爱有乐有。欣有喜有。为灭有故。说正法时。不能恭敬。摄耳听受。亦复不能住奉教心。不能随顺。修如实见。惟生怯劣。退转惊怖。我等尔时当何所有。我等尔时当如何有。如是天人一类怯劣。云何天人一类勇猛。谓有天人。怖有厌有。欣求无有。彼彼苦法。所逼切故。摄受执着。如是如是。诸恶见趣。作是念言。我若断坏隐没不现。尔时乃名寂静微妙。如是天人一类猛盛。云何名为有慧眼者。能正观察。谓圣声闻。如实观察既观察已。不于如实而生憍慢。不依如实而生憍慢。不因如实而生憍慢。不恃如实而生憍慢。如实见已。便生厌背。既厌背已。便能离欲。既离欲已。便得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。作是思惟。世尊为彼喜乐诸有阿赖耶者。恒为常见所系缚者。令灭有故。所说正法。微细甚深。难见难悟。寂静胜妙。非诸寻思所行境界。是诸审谛慧者。所证一切世间。真实对治。谓能除灭憍慢渴爱害阿赖耶。断诸径路。证真空性本事经卷第四

        大唐三藏法师玄奘奉　诏译

    二法品第二之二

吾从世尊。闻如是语。苾刍当知。若有苾刍。减省睡眠。具念正知。心常安住。悦豫清净。于诸善法。善观时宜。而正修习。如是苾刍。减省睡眠。具念正知。心常安住。悦豫清净。于诸善法。善观时宜。而正修习。于二果中。随证一果。谓于现法。或证有余依涅槃界。或不还果。尔时世尊。重摄此义。而说颂曰

  觉悟能闻法　　修行得胜果
  耽着于睡眠　　都无有所得
  减省睡眠者　　具正念正知
  善安住其心　　常悦豫清净
  于诸善法中　　知时宜修习
  能究竟超越　　生老病死苦
  是故应勤修　　减省睡眠法
  常委观寂静　　得二果无疑
  或断下分结　　证得不还果
  或断上分结　　度生老病死

吾从世尊。闻如是语。苾刍当知。若有苾刍。于空闲处。常乐宴坐。勤修内心奢摩他定。不离静虑。成就明净毗钵舍那。守护自心。令无散乱。于诸善法。修集无厌。如是苾刍。于二果中。我说定能随证一果。谓于现法。或证有余依涅槃界。或不还果。尔时世尊。重摄此义。而说颂曰

  乐空闲宴坐　　具正念正知
  善安住其心　　离虚妄分别
  善防护自心　　速断无明闇
  及诸欲烦恼　　无忧悔归真
  常寂定其心　　具正念静虑
  无所执解脱　　永尽诸有贪
  常乐不放逸　　见放逸生怖
  诸见能永断　　速证般涅槃

吾从世尊。闻如是语。苾刍当知。若有苾刍。无惭无愧。彼人决定。不能通达。不能遍知。不证等觉。不证涅槃。不能证得无上安乐。若有苾刍。有惭有愧。彼人决定。能得通达。能得遍知。能证等觉。能证涅槃。能证究竟无上安乐。尔时世尊。重摄此义。而说颂曰

  无惭无愧者　　懈怠不精进
  多惛沉睡眠　　去结尽为远
  有惭有愧者　　常无有放逸
  乐静虑深定　　去涅槃不遥
  彼能断众结　　及生老病死
  速证三菩提　　得无上安乐

吾从世尊。闻如是语。苾刍当知。诸出家者。略有二种。所应作事。若能正作。得所未得。触所未触。证所未证。能超愁叹。能灭忧苦。能触如理。能得甘露。能证涅槃。云何为二。一者静虑。二者听说。云何静虑。谓诸苾刍。远离诸欲恶不善法。有寻有伺。离生喜乐。具足安住。最初静虑。寻伺静息。内净一趣。无寻无伺。定生喜乐。具足安住。第二静虑。离喜住舍正念正知。身受快乐。众圣所说。有舍有念。安住快乐。具足安住。第三静虑。断苦断乐。先灭忧喜。不苦不乐。舍念清净具足安住。第四静虑。云何听说。谓诸苾刍。于佛所说。初中后善文义巧妙。纯满清白梵行之法。所谓契经应颂记别伽他自说本事本生及与方广。未曾有法。于如是法。受诵听习令其通利。宣畅解释。是名听说。如是名为诸出家者。略有二种。所应作事。若能正作。得所未得。触所未触。证所未证。能超愁叹。能灭忧苦。能触如理。能得甘露。能证涅槃。尔时世尊。重摄此义。而说颂曰

  出家有二种　　正所应作事
  谓静虑听说　　速证于涅槃
  静虑慧为因　　慧必由静虑
  有静虑有慧　　速证于涅槃
  百千哑羊僧　　无慧修静虑
  设经百千岁　　无一得涅槃
  勤修智慧人　　乐听法说法
  敛念须臾顷　　能速证涅槃

吾从世尊。闻如是语。苾刍当知。寻求有二。更无第三。云何为二。谓圣寻求。非圣寻求。云何名为非圣寻求。谓有一类。已有老法。寻求老法。已有病法。寻求病法。已有死法。寻求死法。已有愁法。寻求愁法。已有染法。寻求染法。云何老法。所谓妻子奴婢仆使。象马牛羊鸡猪田宅。金银财谷是名老法。如是老法。是诸有情生死苦本。愚夫异生。于此守护。染爱耽着。由此不能解脱生死故名老法。云何病法。所谓妻子奴婢仆使。广说乃至。由此不能解脱生死故名病法。云何死法。所谓妻子奴婢仆使广说乃至。由此不能解脱生死故名死法。云何愁法。所谓妻子奴婢仆使广说乃至。由此不能解脱生死故名愁法。云何染法。所谓妻子奴婢仆使。象马牛羊。鸡猪田宅。金银财谷。是名染法。如是染法。是诸有情。生死苦本。愚夫异生。于此守护。染爱耽着。由此不能解脱生死故名染法。若有于此。爱乐寻求。当知是名非圣寻求。如是寻求如来终不称扬赞叹。唯劝导之令知舍离。何缘如是非圣寻求。如来终不称扬赞叹。唯劝导之。令知舍离。由此寻求。非贤圣法。非能出离非趣涅槃。非厌非离。非灭非静。非得通慧。非成等觉。非证涅槃。由此寻求。能引一切生老病死愁叹忧苦诸热恼法。是故如是非圣寻求。如来终不称扬赞叹。唯劝导之。令知舍离。云何名为是圣寻求。谓有一类。已有老法。能自了知我有老法。能如实知老法过患。寻求毕竟。无老无上安乐涅槃。已有病法。能自了知。我有病法。能如实知病法过患。寻求毕竟。无病无上安乐涅槃。已有死法。能自了知。我有死法。能如实知死法过患。寻求毕竟。无死无上安乐涅槃。已有愁法。能自了知。我有愁法。能如实知愁法过患。寻求毕竟。无愁无上安乐涅槃。已有染法。能自了知。我有染法。能如实知染法过患。寻求毕竟。无染无上安乐涅槃。如是名为是圣寻求。如是寻求。一切如来。称扬赞叹。何缘如是是圣寻求。一切如来称扬赞叹。由此寻求。是贤圣法。能永出离。能趣涅槃。能厌能离。能灭能静。能得通慧。能成等觉。能证涅槃。由此寻求。能超一切生老病死愁叹忧苦生死热恼。是故如是。是圣寻求。一切如来。称扬赞叹。如是名为寻求。有二更无第三。是故汝等。应如是学。我当云何。远离如是非圣寻求修行。如是是圣寻求。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  一切有情类　　有二种寻求
  更无有第三　　谓圣与非圣
  不知老病死　　愁染法过患
  希求深爱着　　名非圣寻求
  此增长众苦　　出离未为期
  从生复至生　　或高或下趣
  善知老病死　　愁染法过患
  希求彼寂灭　　名真圣寻求
  此损减众苦　　速证于涅槃
  永安乐清凉　　常无漏无怖
  彼非圣寻求　　诸佛所呵毁
  是生死根本　　智者当远离
  此真圣寻求　　诸佛所称赞
  是趣涅槃道　　有智者应修

重摄前经嗢拖南曰

  为通达律仪　　厌知不净界
  经觉悟宴坐　　愧所作寻求

吾从世尊。闻如是语。苾刍当知。略有二种白净善法。能护世间。云何为二。谓惭与愧。若无此二白净善法。世间有情皆成秽杂。犹如牛羊鸡猪狗等。不识父母兄弟姊妹。不识轨范亲教导师似导师等。由有此二白净善法。世间有情离诸秽杂。非如牛羊鸡猪狗等。了知父母兄弟姊妹。了知轨范亲教导师似导师等。是故汝等。应如是学。我当云何成就如是二种最胜。第一惭愧白净善法。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  二白净善法　　能护诸世间
  令不失人天　　谓惭及与愧
  若无此二法　　都不识尊卑
  秽杂似牛羊　　鸡猪狗等类
  由有此二法　　能了别尊卑
  非如牛羊等　　行诸杂秽事
  诸有智慧人　　成就二白法
  常守人天趣　　终不堕三涂

吾从世尊。闻如是语。苾刍当知。我为如来应正等觉。未成佛时。居菩萨位。多分安住。二种寻思。云何为二。一者如来。居菩萨位。多分安住不害寻思欣喜悦乐。如是安住不害寻思欣喜悦乐。是名第一多分寻思。由住如是修习行迹。于诸有情都无捐害。由此寻思。证得无量圆满梵住。二者如来。居菩萨位。多分安住。永断寻思欣喜悦乐。如是安住永断寻思欣喜悦乐。是名第二多分寻思。由住如是修习行迹。于不善法。能正永断。由此寻思。证得善根圆满胜道。我于尔时。安住如是二种寻思。精进勇猛。乃至自身。一切血肉。悉皆枯竭。唯余身肉骨筋皮缠裹。亦不放逸。乃至未知未见未得未解未证。所应知见得解证法。于其中间住不放逸。精进勇猛。曾无懈废。由不放逸。精进勇猛。无懈废故。速证无上正等菩提。速证无上清凉涅槃。速证无上一切智见。是故汝等应如是学。我当云何安住不害欣喜悦乐多分寻思。安住永断欣喜悦乐多分寻思。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  佛为菩萨时　　多安住二法
  谓不害永断　　欣喜悦乐思
  不害诸有情　　修慈悲喜舍
  证无量梵住　　圆满不为难
  永断不善法　　一切烦恼缠
  证得诸善根　　圆满殊胜道
  常精进勇猛　　无放逸而住
  证无上菩提　　清凉涅槃等

吾从世尊。闻如是语。苾刍当知。诸婆罗门。长者居士。刹帝利等。多有所作。谓施汝等。如法衣服饮食卧具病缘医药房舍资具。汝等苾刍。多有所作。谓能为彼宣说正法。初中后善。文义巧妙。纯满清白梵行之法。由此俱能解脱生法老病死法。愁叹忧苦热恼之法。汝等与彼力轮法轮。展转相依。于如来所。勤修梵行。速至无上般涅槃城。尔时世尊。重摄此义。而说颂曰

  出家与居家　　展转互相依
  由力法二轮　　速至涅槃乐
  出家依在俗　　得如法资具
  在俗依出家　　获微妙正法
  二众互相依　　受人天快乐
  度生老病死　　至清凉涅槃

吾从世尊。闻如是语。苾刍当知。依住尸罗。能修二法。云何为二。谓奢摩他毗钵舍那。谓修行者。依住尸罗修奢摩他。既修如是奢摩他已。修心令满。为何事故。修习其心。修习心者。为断贪故。诸修行者。依住尸罗。精勤修习毗钵舍那。既修如是毗钵舍那已。修慧令满。为何事故。修习其慧。修习慧者。为断痴故。贪染污心。令不解脱。痴染污慧。令不明照。若永离贪。心善解脱。若永离痴。慧善解脱。若于如是二种解脱。已能正知见得触证。我说彼为心善解脱。慧善解脱。独一修习最上丈夫。诸圣弟子。正证如是心解脱者。若他骂詈诃责轻弄毁辱等时。不由此缘发生种种不忍不信害恨等心。所以者何。以能照见他骂詈等。于彼有罪。于已无损。诸圣弟子。正证如是心解脱者。若他赞美恭敬礼拜供养等时。不由此缘发生种种欢喜踊跃悦豫等心。所以者何。以能照见他赞美等。于彼有福。于己无益。若能如是。名于世法得心平等。无戚无欣。安隐自在。是故汝等。应如是学。我当云何依住尸罗修奢摩他毗钵舍那。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  依住净尸罗　　修无罪止观
  密护根及意　　证甘露涅槃
  修止令心调　　心调离贪欲
  离欲证解脱　　证解脱心平
  修观令慧明　　慧明灭痴闇
  灭闇证解脱　　证解心平等
  故汝等苾刍　　精进勿放逸
  常依住尸罗　　修无罪止观

吾从世尊。闻如是语。苾刍当知。修学胜利。于如来所。修行梵行。慧为上首。解脱坚固。念最尊胜。若有成就。修学胜利。于如来所。修行梵行。慧为上首。解脱坚固。念最尊胜。彼终不为味着色贪缠扰其心。亦复不为味着声香味触法贪缠扰其心。心不为贪所缠扰故。无随味着色相貌识。无随味着声香味触法相貌识。于二果中。随证一果。谓于现法。证有余依般涅槃界。或不还果。尔时世尊。重摄此义。而说颂曰

  修学胜利人　　依佛修梵行
  慧为其上首　　及懈脱坚牢
  念最居尊胜　　二果随证一
  谓现法涅槃　　及永不还果
  由慧为上首　　贪不扰其心
  无随色等缘　　相貌所生识
  学胜利圆满　　生胜定上慧
  尽生老死边　　证有余依界
  故汝等苾刍　　应勤修戒定
  生微妙胜慧　　尽生老病死
  住我法律中　　能无放逸者
  定坏魔军力　　永尽众苦边

吾从世尊。闻如是语。苾刍当知。一切世间。恶不善法。皆以无明。为其前导。而得生长。以无惭愧。为其后助。而不损减。所以者何。诸趣有生生老病死愁叹忧苦热恼等法。一切皆用无明为根。而得生长。既生长已。依之复能生起一切恶不善法。恶法既生由无惭愧。都无悔变。无悔变故。而不损减。一切世间。善清净法。皆以慧明。为其前导。而得生长。以惭与愧。为其后助。而不损减。所以者何。明处其前。惭愧为后。能永断灭。诸趣有生生老病死。能超一切。愁叹忧苦热恼等法。能触如理。能得甘露。能证涅槃。是故汝等。应如是学。我当云何。永断无明。发起慧明。永断一切。诸趣有生生老病死。永超一切。愁叹忧苦热恼等法。触于如理。得于甘露。证于涅槃。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  此世及后生　　生老病死等
  贪爱等烦恼　　皆无明为根
  无明为大愚　　令久处生死
  此世与他世　　高下趣往还
  最初有无明　　最后无惭愧
  生长诸恶法　　堕众恶趣中
  故应勤精进　　离贪爱愚痴
  发起智慧明　　断生死苦本

吾从世尊。闻如是语。苾刍当知。一切如来应正等觉。怜愍世间出兴于世。为欲永断除舍二法。转于贤圣无上法轮。一切世间。所有沙门。或婆罗门天魔梵等。曾未有能如法转者。云何二法。一者无明。二者有爱。一切如来应正等觉。怜愍世间出兴于世。皆为永断。除舍此二。转于贤圣无上法轮。广说乃至曾未有能如法转者。若能永断除舍一切所有无明及诸有爱。令其永尽。无有遗余。便能永断一切烦恼诸杂染法。是则名为出诸坑堑。越诸垣墙。破诸关键摧伊师迦。是真贤圣。是正法幢。是大沙门。是婆罗门。是真聪慧。是真沐浴。是真智者。是真调顺至调顺地。名世福田。尔时世尊。重摄此义。而说颂曰

  无上正等觉　　商主世间尊
  大雄大丈夫　　拔众毒箭者
  哀愍诸世间　　为断除二法
  谓无明有爱　　转无上法轮
  是苦是苦因　　是众苦永灭
  是八支圣道　　趣灭苦涅槃
  智者闻斯法　　信解等坚牢
  达诸法正真　　断无明有爱
  无明有爱除　　诸杂染皆灭
  至善调顺地　　名世良福田

吾从世尊。闻如是语。苾刍当知。有二苦事。最为难忍。一剃须发。二常乞求。所以者何。世间怨嫌。兴咒诅者。作是愿言。愿彼贫穷。剃除须发。服故弊衣。手持瓦器。从家至家。行乞自活。诸有净信善男子等。受持此法。而出家者。非为王贼债主怖畏之所逼切。非恐不活。而舍居家。但为超度生老病死愁叹忧苦热恼等法。但为灭除纯大苦蕴。我诸弟子。求如是事。正信出家。为利自他。受持此法。或有如是。而出家已。未经几时。则便宽慢。放逸懈怠。下劣精进。亡失正念。无有正知。心乱不定。纵任诸根。多欲贪着。心怀嗔忿。愚钝无知。耽染诸欲。虚妄思惟。毁诸禁戒。实非沙门。自称沙门。实非梵行。自称梵行。内朽顺流。如秽蜗螺贝音狗行。覆藏己恶。诈现自善。或就种种恶不善法。譬如有人。从闇入闇。从坑堕坑。从怨至怨。我说如是痴出家人。亦复如是。又如有木。两头火燃。中涂粪秽。若在聚落及与空闲。皆无复用。我说如是痴出家人。亦复如是。失在家法。复非沙门世出世间。皆无胜分。尔时世尊。重摄此义。而说颂曰

  出家而破戒　　二俱无所成
  谓失在家仪　　及坏沙门法
  宁吞热铁丸　　洋铜而灌口
  不受人信施　　而毁犯尸罗
  诸毁犯尸罗　　无悔无惭愧
  多受人信施　　定当生地狱
  诸有智慧人　　应坚持净戒
  勿受人信施　　而毁犯尸罗

吾从世尊。闻如是语。苾刍当知。世有二种补特伽罗。摄受增益。恶趣地狱。恶不善法。云何二种补特伽罗。一者一类补特伽罗。毁犯净戒。实非沙门。自称沙门。实非梵行。自称梵行。内朽顺流。如秽蜗螺贝音狗行。覆藏己恶。诈现自善。如朽隧级。无所复用。唯增恶趣。二者一类补特伽罗于具净戒。无所毁犯。精进修行。清白梵行。有德苾刍。以诸无根。非梵行法。诽谤毁辱。令失威光。如是二种补特伽罗。摄受增益。恶趣地狱。恶不善法。尔时世尊重摄此义。而说颂曰

  二补特伽罗　　生长恶趣业
  谓毁犯净戒　　及诽谤贤良
  如是二种人　　俱名为下贱
  现在人所鄙　　受苦在当来
  是故诸苾刍　　常应不放逸
  受持清净戒　　勿毁谤他人

吾从世尊。闻如是语。苾刍当知。世有二种补特伽罗。恩深难报。云何为二。所谓父母。假使有人。一肩荷父。一肩担母。尽其寿量。曾无暂舍。供给衣食。病缘医药。种种所须。犹未能报父母深恩。所以者何。父母于子。恩极深重。所谓产生。慈心乳哺。洗拭将养。令其长大。供给种种资身众具。教示世间所有仪式。心常欲令离苦得乐。曾无暂舍。如影随形。父母于子。既有如是。所说深恩。当云何报。若彼父母。于佛法僧。无清净信。其子方便。示现劝导赞励庆慰。令生净信。若彼父母。无清净戒。其子方便示现劝导。赞励庆慰。令其受持清净禁戒。若彼父母。无有多闻。其子方便。示现劝导赞励庆慰。令其听闻诸佛正法。若彼父母。为性悭贪。不乐布施。其子方便。示现劝导赞励庆慰。令行布施。若彼父母。为性闇钝。无有胜慧。其子方便。示现劝导赞励庆慰。令修胜慧。其子如是。乃名真实报父母恩。尔时世尊。重摄此义。而说颂曰

  二补特伽罗　　恩深重难报
  所谓父及母　　能生长世间
  假使以两肩　　尽寿荷父母
  常供养恭敬　　犹未为报恩
  父母于世间　　能生育教导
  慈心求利乐　　如彼影随形
  若父母先无　　信戒闻舍慧
  子令其修习　　名真实报恩
  恭敬给所须　　唯现世安乐
  令修信戒等　　究竟证涅槃

吾从世尊。闻如是语。苾刍当知。世有二种无欺诳法。云何为二。谓业与智。若诸有情。已集诸业。其异熟果。若未现前。终不尽灭。若诸有情。已生诸智。一切烦恼。若未永除。终不舍离。如是名为世有二种无欺诳法。尔时世尊。重摄此义。而说颂曰

  二无欺诳法　　诸佛共所谈
  谓已集已生　　诸业及诸智
  异熟果未生　　诸业终不灭
  烦恼若未尽　　智终不舍离
  业是生死因　　智为灭惑本
  是故应修智　　永尽众苦边

吾从世尊。闻如是语。苾刍当知。世有二种补特伽罗。应深尊重礼拜供养。以敬爱心。亲近而住。云何为二。所谓父母。若诸有情。于其父母。深心尊重。礼拜供养。以敬爱心。亲近而住。生无量福。诸有智人。咸共称叹。声誉普闻。处众无畏。后不焦恼无悔。命终身坏死后升诸善趣。生于天中。何缘有情。应于父母。深心尊重。礼拜供养。以敬爱心。亲近而住。父母于子。有深重恩。所谓产生。慈心乳哺。洗拭将养。令其长大。供给种种资身众具。教示世间所有仪式。心常欲令离苦得乐。曾无暂舍。如影随形。是故父母。应深敬重。礼拜供养。以敬爱心。亲近而住。若诸有情。敬爱父母。亲近而住。父母于其深心慈愍。除无益事。授有益事。制止众恶。劝修众善。为其娉娶。贞良妻室。有时赐与珍宝财谷。世间天人。咸共称叹。恭敬供养。亲近加护。令无衰恼。是故有情。于其父母。应深尊重礼拜供养。以敬爱心。亲近而住。尔时世尊。重摄此义。而说颂曰

  诸有乐福人　　应尊重父母
  礼拜修供养　　敬爱亲近居
  世间聪慧人　　恭敬于父母
  恒时修供养　　常生欢喜心
  父母于世间　　恩深重难报
  除无益制恶　　授利劝修善
  与妻室资财　　慈心常覆护
  是故修供养　　无量福聚生
  现得胜名闻　　咸供养恭敬
  死生天善趣　　受妙乐无穷
  欲得生天人　　受五欲妙乐
  犹如天帝释　　当供养父母

重摄前经嗢拖南曰

  善寻轮戒学　　无明慧断除
  苦毁谤报恩　　无欺诳父母

本事经卷第四本事经卷第五

        大唐三藏法师玄奘奉　诏译

    二法品第二之三

吾从世尊。闻如是语。苾刍当知。施有二种。云何为二。一者财施。二者法施。云何财施。谓有一类补特伽罗。能施种种美妙饮食。香鬘衣乘房舍卧具。资产灯明病缘医药。舍如是等。分布惠他。名为财施。云何法施。谓广为他宣说正法。初中后善。文义巧妙。纯满清白梵行之法。令诸有情。闻已解脱。生老病死愁叹忧苦诸热恼法。是名法施。于此财法二种施中。法施最上胜妙第一。譬如世间。从牛出乳。从乳出酪。酪出生酥从此生酥。出于熟酥。复从熟酥出于醍醐。于是种种牛诸味中。醍醐最上胜妙第一。如是财法二种施中。法施最上胜妙第一。于法施中。能无颠倒行法施者。唯有如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。尔时世尊。重摄此义。而说颂曰

  于二种施中　　法施为第一
  能行法施者　　善逝最为尊
  受财施田中　　如来为第一
  行财施不定　　受法施众生
  财施令众生　　得世安隐乐
  法施令受者　　究竟证涅槃

吾从世尊。闻如是语。苾刍当知。祠祀有二。云何为二。一财祠祀。二法祠祀。财祠祀者。谓有一类补特伽罗。祠祀种种美妙饮食。香鬘衣乘。房舍卧具。资产灯明。如是等类。名财祠祀。法祠祀者。谓能祠祀契经应颂记别伽他自说本事本生方广。未曾有法。以无量门。如理宣说。施设建立。分别开示。名法祠祀。于此财法二祠祀中。法祠最上胜妙第一。譬如世间。从牛出乳。从乳出酪。酪出生酥。从此生酥。出于熟酥。复从熟酥。出于醍醐。于是种种牛诸味中。醍醐最上胜妙第一。如是财法二祠祀中。法祠最上胜妙第一。于法祠中。能无颠倒。行法祠者。唯有如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。尔时世尊。重摄此义。而说颂曰

  于二种祠中　　法祠为第一
  能行法祠者　　善逝最为尊
  受财祀田中　　如来为第一
  行财祀不定　　受法祀众生
  财祀令众生　　得世安隐乐
  法祠令受者　　究竟证涅槃

吾从世尊。闻如是语。苾刍当知。诸修行者。同集会时。应作二事。一者法言。二者宴默。由法言故。审知有德。审知德故。便深敬信。深敬信故。便往诣彼。往诣彼故。亲近供事。亲供事故。求闻正法。求闻法故。摄耳不乱。耳不乱故。听闻正法。闻正法故。于法通利。法通利故。能记持法记持法故。能观察义。观察义时。堪能于法。审谛思惟。堪能于法。审谛思时。便生欲乐。生欲乐已。便得势力。得势力已。便能称量。由称量故。便能决择。能决择故。于谛随觉。便自了知。我生已尽。梵行已立。所作已办。不受后有。由宴默故。心便寂定。清净鲜白。无有瑕衅。离随烦恼。调顺堪任。安住不动。堪能引发。能引发故。如实了知。如实知故。便能厌背。能厌背故。便能离欲。既离欲已。便得解脱。得解脱已。便自了知。我已解脱。我生已尽。梵行已立。所作已办。不受后有。汝等苾刍。应说上法。应了上法。若能如是。乃名真实。摄受仙幢。非众集会。戏论语言。能正了知。诸法实相。能断诸漏。能证涅槃。我常集会。宣说上法。了知上法。故名第一。摄受仙幢。尔时世尊。重摄此义。而说颂曰

  行者集会时　　应修作二事
  谓寂然宴默　　及说正法言
  由说正法言　　及寂然宴默
  知诸法实相　　究竟证涅槃
  汝等当苾刍　　若说了上法
  乃得名真实　　摄受大仙幢
  我常处众中　　宣说照了法
  是故名第一　　摄受大仙幢
  若依正法幢　　能说能修行
  定速脱生死　　至究竟涅槃

吾从世尊。闻如是语。苾刍当知。若诸苾刍。于言说时。非理作意。起欲寻思。起恚寻思。起害寻思。如是苾刍。名多恶者。行慢缓者。趣向多恶为方便故。于断于离。弃舍善轭。放逸懈怠。下劣精进。亡失正念。有不正知。不定心乱。纵任诸根。无出离见。不知出离。如实正慧。趣向恶魔。恶不善法。为诸恶魔恶不善法之所摧伏。增长一切恶不善法。若诸苾刍。于宴默时。非理作意。广说乃至。增长一切恶不善法。如是苾刍。为诸有智同梵行者之所诃毁。我亦于彼。常不称赞。如是苾刍。虽得出家受具足戒。而名恶慧乐有痴人。是故汝等。应如是学。我当云何方便断除。非理作意。方便修习。如理作意。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  言说宴默时　　纵诸根造恶
  不奉行我教　　是愚昧痴人
  故汝等苾刍　　应修不放逸
  离非理作意　　当如理思惟
  汝等若正勤　　语默无放逸
  不久度生死　　证无上涅槃

吾从世尊。闻如是语。苾刍当知。若诸苾刍。于言说时。如理作意。出离寻思。无恚寻思。无害寻思。如是苾刍。名多善者。无慢缓者。趣向多善为方便故。于断于离。不舍善轭。离诸放逸。勇猛精进。正念正知。心定无乱。密护诸根。有出离见。能知出离。如实正慧。弃背恶魔恶不善法。摧伏恶魔恶不善法。损减一切恶不善法。若诸苾刍。于宴默时。如理作意。广说乃至。损减一切恶不善法。如是苾刍。为诸有智同梵行者之所称赞。我亦于彼。恒常称赞。如是苾刍。名真出家受具足戒。有大智慧。不乐诸有。名不痴人。是故汝等。应如是学。我当云何方便修习。如理作意。方便断除。非理作意。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  言说宴默时　　不纵根造恶
  能奉行我教　　是聪慧智人
  修出离寻思　　及无恚无害
  有出离正见　　于如实能知
  能摧伏恶魔　　诸恶不善法
  永断诸烦恼　　证究竟涅槃
  故汝等苾刍　　应修不放逸
  当如理作意　　离非理思惟
  汝等若正勤　　语默无放逸
  不久度生死　　证无上涅槃

吾从世尊。闻如是语。苾刍当知。有学苾刍。有二种力。云何为二。谓思择力及修习力。云何苾刍。有思择力。所谓一类有学苾刍。受用种种衣服饮食房舍卧具病缘医药资生具时。皆善思择。非不思择。而便受用。于所未得衣服饮食房舍卧具病缘医药诸资生具。不甚希求于所已得衣服饮食房舍卧具病缘医药诸资生具。不深耽着。堪能忍受。寒热饥渴。风日蚊虻。蛇蝎等触。堪能忍受。他所毁谤。骂辱等言。堪能忍受。身内所生。猛利辛楚。酸疼难忍。夺命临终。难治苦受。堪能忍受。一切世间。极难忍事。能善思择。诸身语意。三种恶行。能照现法生法后法。不可爱乐苦异熟果。作是思惟。我今定当断身语意三种恶行。我今定当修身语意三种妙行。能正了知三种恶行所有过患。复正了知三种妙行所有功德。既正知已。勤断勤修。恶行妙行。修治自身。令其清净。离诸罪法。如是名为有学苾刍初思择力。云何苾刍有修习力。所谓一类有学苾刍。所得忆念。一切皆与觉支相顺。而不相违。所得择法及精进喜轻安定舍一切。皆与觉支相顺。而不相违。修念觉支。皆依止厌。皆依止离。皆依止灭。回向于舍。修习择法及精进喜轻安定舍觉支。皆依止厌。皆依止离。皆依止灭。回向于舍。如是名为有学苾刍后修习力。是名有学苾刍二力。尔时世尊。重摄此义。而说颂曰

  诸有学苾刍　　略有二种力
  思择及修习　　能伏恶魔军
  见恶过能断　　知妙德能修
  能忍受思惟　　是名思择力
  依止厌离灭　　及回向于舍
  而修七觉支　　是名修习力

吾从世尊。闻如是语。苾刍当知。由二种法。尽灭故死。云何二法。一业。二寿。由业尽故。及寿尽故。决定命终。若时有业。尔时有寿。若时有寿。尔时有业。所以者何。如是二法。恒常和合。无不和合。如是二法。不可施设。分析离散。此时有业。彼时有寿。此时有寿。彼时有业若有其业。即有其寿若有其寿。即有其业。若无其业即无其寿。若无其寿即无其业。譬如燃灯生焰发明。若有其焰即有其明。若有其明即有其焰。若无其焰即无其明。若无其明即无其焰。业寿亦尔。若有其业即有其寿。若有其寿即有其业。若无其业即无其寿。若无其寿即无其业。如是二法。尽灭故死。尔时世尊。重摄此义。而说颂曰

  二法恒相随　　谓业及与寿
  业有寿亦有　　业无寿亦无
  寿业未消亡　　有情终不死
  寿业若尽灭　　含识死无疑

吾从世尊闻如是语。苾刍当知。有二种行。世间众生。皆共造作。云何为二。一者能感短寿之行。二者能感长寿之行。云何能感短寿之行。谓有一类补特伽罗。常乐杀生。为性凶暴。血涂其手。伤害物命。无有惭羞。无有慈愍。于诸众生。常行杀害。乃至杀害。折脚蚁子。是名能感短寿之行。云何能感长寿之行。谓有一类补特伽罗。远离杀生。弃舍杀具。惭羞慈愍。于诸众生。常不杀害。乃至不害。折脚蚁子。是名能感长寿之行。如是名为有二种行。世间众生。皆共造作。尔时世尊。重摄此义。而说颂曰

  世间诸有情　　略有二种行
  由二行差别　　感寿有短长
  谓常乐杀生　　凶暴血涂手
  无惭羞慈愍　　感短寿无疑
  常乐离杀生　　弃舍诸杀具
  有惭羞慈愍　　感长寿无疑

吾从世尊闻如是语。苾刍当知。由二行相应取心相。云何为二。一者名为所缘行相。二者名为作意行相。所有一切。已取现取当取心相。皆由如是二种行相。汝等苾刍。由二行相。应当正勤善取心相。取心相已。应善作意。善作意已。应善观察。善观察已。应善安住。善安住已。应同地界。正勤修习。无量无损。应同水界。火界风界。正勤修习。无量无损。苾刍当知。譬如地界。若于其中。安置粪秽洟唾脓血如是等类。净不净物。虽置其中。而其地界。曾无违顺欣戚高下。如是安心应同地界。正勤修习。无量无损。既同地界。正勤修习。无量无损。虽遇种种违顺众缘。而心都无分别计着。终不由此差别因缘。其心高下。又如水界。火界风界。若于其中。安置粪秽洟唾脓血如是等类净不净物。虽置其中。而其水界。火界风界。曾无违顺。欣戚高下。如是安心。应同水界。火界风界。正勤修习。无量无损。既同水界。火界风界。正勤修习。无量无损。虽遇种种违顺众缘。而心都无分别计着。终不由此差别因缘。其心高下。由此定故。于有识身。及外一切所缘相中。我我所执。见慢随眠。善伏善断。于彼二种。其心超越。离一切相。寂静安乐。得善解脱。所有一切。心善解脱。慧善解脱。皆于其中。我我所执。见慢随眠。善伏善断。于彼二种。其心超越。离一切相。寂静安隐。得善解脱。于其所得。利誉称乐。其心不欣。于其所遭衰毁讥苦。其心不戚。是名超过世间八法。其心平等。犹如世间地水火风。世间八法。所不能染。尔时世尊。重摄此义。而说颂曰

  难调躁动心　　远行无第二
  能正勤取相　　是谓世聪明
  善取心相已　　复作意观察
  正念住其心　　勤修同四界
  如是正安住　　能弃舍诸欲
  于世八法中　　名善巧无染

吾从世尊闻如是语。苾刍当知。有二种法。虽共乖违未尝和合。然于其中。无缺无间。云何为二。谓生与死。譬如世间光明影闇。虽共乖违未尝和合。然于其中。无缺无间。光明发时影闇便没。影闇起时光明便谢。生死亦尔。恒共乖违未尝和合。然于其中。无缺无间。生法有时死法便没。死法有时生法便谢。尔时世尊。重摄此义。而说颂曰

  如光明影闇　　虽恒共乖违
  然于二法中　　未曾有间缺
  生死亦如是　　虽恒共乖违
  然于二法中　　未曾有间缺
  无明根所生　　爱水所滋润
  才死生便续　　中无间缺时

吾从世尊闻如是语。苾刍当知。死有二种。云何为二。一者不调伏死。二者调伏死。云何名为不调伏死。谓诸愚夫。无闻异生。未能亲觐正见善士。未能了知善士之法。于善士法未自调顺彼随观见。色即是我。色属于我。色在我中。我在色中。彼随观见。受即是我。受属于我。受在我中。我在受中。彼随观见。想即是我。想属于我。想在我中。我在想中。彼随观见。行即是我。行属于我。行在我中。我在行中。彼随观见。识即是我。识属于我。识在我中。我在识中。眼见色已。执取其相。执取随好。由是因缘。于其眼根。不能正念防守而住发起贪忧。便有无量恶不善法。随心流漏不可堰塞。于其眼根。不能防守。纵荡眼根。行诸境界。贪着色味。缠扰其心。缘此贪故。受长夜苦。受猛利苦。受匮乏苦。增血镬身。增空旷路。无量往返生那落迦傍生鬼界及阿素洛人天趣中。受诸剧苦。皆由眼根不调伏故。如是或时。耳闻声已。鼻嗅香已。舌尝味已。身觉触已。意了法已。执取其相。执取随好。由是因缘。于其意根。不能正念防守而住。发生贪忧。便有无量恶不善法。随心流漏不可堰塞。于其意根不能防守。纵荡意根。行诸境界。贪着法味。缠扰其心。缘此贪故。受长夜苦。受猛利苦。受匮乏苦。增血镬身。增空旷路。无量往返生那落迦傍生鬼界及阿素洛人天趣中。受诸剧苦。皆由意根不调伏故。如是名为不调伏死。云何名为调伏而死。谓诸贤圣多闻弟子。已能亲觐正见善士。已能了知善士之法。于善士法。已自调顺不随观见。色即是我。色属于我。色在我中。我在色中。不随观见。受即是我。受属于我。受在我中。我在受中。不随观见。想即是我。想属于我。想在我中。我在想中。不随观见。行即是我。行属于我。行在我中。我在行中。不随观见。识即是我。识属于我。识在我中。我在识中。眼见色已。不执其相。不执随好。由是因缘。于其眼根。善能正念。防守而住不起贪忧。所有无量恶不善法。随心流漏。皆能堰塞。于其眼根。善能防守。不纵眼根。行诸境界。不贪色味缠扰其心。不缘此贪受长夜苦受猛利苦受匮乏苦增血镬身增空旷路。不复往返生那落迦傍生鬼界及阿素洛人天趣中受诸剧苦。皆由眼根善调伏故。如是或时。耳闻声已。鼻嗅香已。舌尝味已。身觉触已。意了法已。不执其相。不执随好。由是因缘。于其意根。善能正念防守而住。不起贪忧所有无量恶不善法。随心流漏。皆能堰塞。于其意根。善能防守。不纵意根。行诸境界。不贪法味。缠扰其心。不缘此贪受长夜苦受猛利苦受匮乏苦增血镬身增空旷路。不复往返生那落迦傍生鬼界及阿素洛人天趣中受诸剧苦。皆由意根善调伏故。如是名为调伏而死。苾刍当知。不调伏死。沉没无量生死苦海。调伏而死。超度无量生死苦海。是名二死。尔时世尊。重摄此义。而说颂曰

  略说诸有情　　死法有二种
  调伏不调伏　　更无有第三
  若不调伏死　　定于诸趣中
  受诸苦轮回　　经无量往返
  调伏而死者　　终不堕恶趣
  于人天趣中　　能永尽众苦

吾从世尊闻如是语。苾刍当知。一切诸法。略有二种。云何为二。一者杂染。二者清净。应正观察由一法生。所以者何。若于一法。能正守护。则于一切。能正守护。若于一法。不能守护。则于一切。不能守护。云何一法。谓众生心。若有于心不能守护。则不能护身语意业。若不能护身语意业。是人即为身语意业皆悉败坏。身语意业。皆败坏故。其心即有扰浊垢秽。心有扰浊及垢秽者。能正了知自利乐事他利乐事俱利乐事。无有是处。能正了知善言说义恶言说义。无有是处。能证一切胜上人法真圣智见。亦无是处。所以者何。心有扰浊及垢秽故。譬如世间所有台观。若一中心。不善覆蔽则椽梁壁。皆被淋漏。以椽梁壁被淋漏故。皆悉败坏。又如世间邻近村邑聚落池沼。扰浊垢秽。有明眼人。住其岸上。作意观察。其中所有。螺蛤龟鱼。砾石等类。行住普侧。极难可见。所以者何。水有扰浊及垢秽故。如是众生。若有于心不能守护。则不能护身语意业。若不能护身语意业。是人即为身语意业皆悉败坏。身语意业皆败坏故。其心即有扰浊垢秽。心有扰浊及垢秽者。能正了知自利乐事他利乐事俱利乐事。无有是处。能正了知善言说义恶言说义。无有是处。能证一切胜上人法真圣智见。亦无是处。所以者何。心有扰浊及垢秽故。若有于心能善守护。则能善护身语意业。若能善护身语意业。是人即为身语意业皆不败坏。身语意业不败坏故。其心即无扰浊垢秽。心无扰浊及垢秽者。能正了知自利乐事他利乐事俱利乐事。期有是处。能正了知善言说义恶言说义。斯有是处。能证一切胜上人法真圣智见。斯有是处。所以者何。心无扰浊及垢秽故。譬如世间所有台观。若一中心。极善覆蔽则椽梁壁。皆无淋漏。以椽梁壁无淋漏故。皆不败坏。又如世间远离村邑聚落池沼。无有扰浊及诸垢秽。有明眼人。住其岸上。作意观察。其中所有。螺蛤龟鱼。砾石等类。行住普侧。极易可见。所以者何。水无扰浊及垢秽故。如是众生。若有于心能善守护。则能善护身语意业。若能善护身语意业。是人即为身语意业皆不败坏。身语意业不败坏故。其心即无扰浊垢秽。心无扰浊及垢秽者。能正了知自利乐事他利乐事俱利乐事。斯有是处。能正了知善言说义恶言说义。斯有是处。能证一切胜上人法真圣智见。斯有是处。所以者何。心无扰浊及垢秽故。苾刍当知。心杂染故。有情杂染。心清净故。有情清净。是故杂染清净二法。皆依止心。从心所起。尔时世尊。重摄此义。而说颂曰

  若不护于心　　随顺于诸欲
  恒驰散放逸　　一切无不为
  若善护于心　　不随顺诸欲
  无驰散放逸　　一切皆防护
  世间聪慧人　　能防身语意
  令不造诸恶　　名真健丈夫

复从世尊闻如是语。苾刍当知。有二种见。令诸有情展转相违互为怨害。云何为二。所谓有见。及无有见。诸有沙门或婆罗门。摄受有见。习行有见。耽著有见。与诸爱乐。无有见者。展转相违互为怨害。称赞有见。最为第一。诸有沙门或婆罗门。摄无有见。习无有见。着无有见。与其爱乐。诸有见者。展转相违互为怨害。赞无有见。最为第一。若有沙门或婆罗门。于此二见。诸集灭味。过患出离。不以正慧。如实了知。我说彼人。名无智见。有贪嗔痴。有违有害。无慧无明。不能解脱生老病死愁叹忧苦热恼等法。不能解脱生死众苦。若有沙门。或婆罗门。于此二见。诸集灭味。过患出离。能以正慧。如实了知。我说彼人名有智见。无贪嗔痴。无违无害。有慧有明。定能解脱生老病死愁叹忧苦热恼等法。定能解脱生死大苦。尔时世尊。重摄此义。而说颂曰

  世间由二见　　展转互相违
  彼此作怨仇　　谓见有无有
  诸有于此见　　爱乐不能舍
  是谓愚痴人　　恒毁他自赞
  若不知此见　　集灭味患出
  见毒箭所伤　　无明闇所覆
  具足贪嗔痴　　无智见明慧
  定不能解脱　　生老病死等
  若能知此见　　集灭味患出
  见毒箭不伤　　破无明黑闇
  远离贪嗔痴　　具智见明慧
  决定能解脱　　生老病死等

复从世尊闻如是语。苾刍当知。有二正见。应谛寻思称量观察。若谛寻思称量观察。能得未得。能触未触。能证未证。能超愁叹。能灭忧苦。能得如理。能触甘露。能证涅槃。云何为二。所谓一切世间正见。出世正见。云何名为世间正见。谓有一类。起如是见。立如是论。决定有施。有受有祠。有善恶业。有异熟果。有此世间。有彼世间。有父有母。有诸有情化生种类。于其世间。有诸沙门婆罗门等。正至正行于此世间及彼世间。自然通达。作证领受。如是名为世间正见。诸圣弟子。于此所说世间正见。应谛寻思称量观察。依此所说世间正见。能令众生毕竟解脱生老病死愁叹忧苦热恼等法。不谛观察已。便正了知。依此所说世间正见。不令众生毕竟解脱生老病死愁叹忧苦热恼等法。所以者何。如是所说世间正见。非真圣见。非出离见。非能究竟证涅槃见。非厌非离。非灭非静。不证通慧。非成等觉。非得涅槃。而能感得生老病死愁叹忧苦热恼等法。如是知已。于世间法生怖畏想。于出世法生安静想。以于世间生怖畏故。都无执受。无执受故。无所希求。无希求故。于内证得究竟涅槃。如是证已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是汝等。于此所说世间正见。应谛寻思称量观察。云何名为出世正见。谓知苦智。知苦集智。知苦灭智。知能趣向苦灭道智。如是名为出世正见。诸圣弟子。于此所说出世正见。应谛寻思称量观察。依此所说出世正见。能令众生毕竟解脱生老病死愁叹忧苦热恼等法。不谛观察已。便正了知。依此所说出世正见。能令众生毕竟解脱生老病死愁叹忧苦热恼等法。所以者何。如是所说出世正见。是真圣见。是出离见。是能究竟证涅槃见。能厌能离。能灭能静。能证通慧。能成等觉。能得涅槃。能超一切生老病死愁叹忧苦热恼等法。如是知已。于出世法生珍宝想。于世间法生下贱想。于出世法生珍宝想故。便生欢喜。生欢喜故。其心安适。心安适故。身得轻安。身轻安故。便受悦乐。受悦乐故。心得寂定。心寂定故。能实知见。实知见故。能深厌背。深厌背故。能正离欲。正离欲故。能得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。如是汝等。于此所说出世正见。应谛寻思称量观察。如是名为二种正见。应谛寻思称量观察。能得未得。能触未触。能证未证。能超愁叹能灭忧苦。能得如理。能触甘露。能证涅槃。尔时世尊。重摄此义。而说颂曰

  正见有二种　　世间出世间
  智者谛寻思　　能正尽众苦
  谛思于世间　　便生怖畏想
  由无执受等　　究竟证涅槃
  谛思出世间　　便生珍宝想
  欢喜心安适　　从此获轻安
  轻安故受乐　　乐故心寂定
  心定生觉支　　知见四如实
  见实断诸疑　　疑除无所取
  解脱一切苦　　证无上涅槃

重摄前经嗢拖南曰

  施祠与集会　　如不如学终
  行相相违死　　染净及二见

本事经卷第五本事经卷第六

        大唐三藏法师玄奘奉　诏译

    三法品第三之一

吾从世尊闻如是语。苾刍当知。诸有情界。互相亲近。不相乖违。诸劣胜解种类有情。与劣胜解种类有情。更相亲近。参染承事。诸妙胜解种类有情。与妙胜解种类有情。更相亲近。参染承事。在过去世诸有情界。已相亲爱。不相乖违。诸劣胜解种类有情。与劣胜解种类有情。已相亲近。参染承事。诸妙胜解种类有情。与妙胜解种类有情。已相亲近。参染承事。在未来世诸有情界。当相亲爱。不相乖违。诸劣胜解种类有情。与劣胜解种类有情。当相亲近参染承事。诸妙胜解种类有情。与妙胜解种类有情。当相亲近。参染承事。在现在世诸有情界。现相亲爱。不相乖违。诸劣胜解种类有情。与劣胜解种类有情。现相亲近。参染承事。诸妙胜解种类有情。与妙胜解种类有情。现相亲近。参染承事。是故尊者解憍陈如。与其同类。有六十人。恒集同修阿练若行。摩诃迦叶。与其同类。有无量人。恒集同修杜多妙行。其舍利子。与其同类。有无量人。恒集同修大智慧行。大目干连与其同类。有无量人。恒集同修大神通行。拘瑟祉罗。与其同类。有无量人。恒集同修无碍解行。其满慈子。与其同类。有无量人。恒集同修说正法行。迦多衍那。与其同类。有无量人。恒集同修辩释经行。尊者善现。与其同类。有无量人。恒集同修无诤住行。缬丽伐多。与其同类。有无量人。恒集同修诸静虑行。其优波离。与其同类。有无量人。恒集同修持律之行。物力士子。与其同类。有无量人。恒集同修为僧敷设卧具等行。尊者不灭。与其同类。有无量人。恒同修集净天眼行。尊者阿难。与其同类。有无量人。恒集同集乐多闻行。其罗怙罗。与其同类。有无量人。恒集同修乐持戒行。童子迦叶。与其同类。有无量人。恒集同修巧辩说行。其劫比拏。与其同类。有无量人。恒集同修教诫教授大苾刍行。尊者难陀。与其同类。有无量人。恒集同修教诫教授苾刍尼行。优波西那与其同类。有无量人。恒集同修具威仪行。妍美难陀。与其同类。有六十人。恒集同修端严之行。愚人天授。与其同类。有六十人。恒集同修勃逆恶行。是故当知。诸有情界。互相亲近。不相乖违。诸劣胜解种类有情。与劣胜解种类有情。更相亲近。参染承事。诸妙胜解种类有情。与妙胜解种类有情。更相亲近。参染承事。尔时世尊。重摄此义。而说颂曰

  如草木丛林　　亦如风火等
  物各以类聚　　有情界亦然
  愚者狎于愚　　智者亲于智
  体知朋侣别　　应亲有智人
  如凭破浮囊　　必沈于大海
  亲近怠慢者　　定失智光明
  故应舍怠慢　　乐栖止空闲
  亲近有智人　　速能殄众苦

吾从世尊闻如是语。苾刍当知。三因三缘。能感后有。云何为三。所谓无明未永断故。爱未弃故。业未息故。由是因缘。能感后有。所以者何。业为良田。识为种子。爱为溉灌。无明无智。无了无见之所覆蔽。识便安住。欲有色有。无色有处。欲最为下。色为其中。无色为妙。若欲界业。感异熟果。不现在前。不可施设。此为欲有。由欲界业。感异熟果。正现在前。故可施设。此为欲有。当于尔时。业为良田。识为种子。爱为溉灌。无明无智。无了无见之所覆蔽。识便安住。下欲有处。若色界业。感异熟果。不现在前。不可施设。此为色有。由色界业。感异熟果。正现在前。故可施设。此为色有。当于尔时。业为良田。识为种子。爱为溉灌。无明无智。无了无见之所覆蔽。识便安住。中色有处。若无色业。感异熟果。不现在前。不可施设。为无色有。由无色业。感异熟果。正现在前。故可施设。为无色有。当于尔时。业为良田。识为种子。爱为溉灌。无明无智。无了无见之所覆蔽。识便安住。妙无色处。苾刍当知。由远离故。出离欲有。由无色故。出离色有。由永灭故。出离一切。有为有起。思虑缘生。汝等苾刍。应以正慧如实随观。出离欲有。应以正慧如实随观。出离色有及无色有。云何汝等。应以正慧如实随观。出离欲有。谓离诸欲恶不善法。有寻有伺。离生喜乐。具足安住。最初静虑。能以正慧如实随观。其中诸色受想行识。如是法性。皆是无常。皆是其苦。如病如痈。如中毒箭。有恼有害。有怖有猜。有怨有敌。迅速败坏。多诸疾疫。多诸灾横。虚伪不实。离散无我。不可保信。如是汝等。应以正慧如实随观。出离欲有。云何汝等。应以正慧如实随观。出离色有。谓正超过一切色想。灭有对想。不复思惟种种异想。具足安住。无边虚空。空无边处。能以正慧如实随观。其中所有受想行识。如是法性。皆是无常。皆是其苦。如病如痈。如中毒箭。有恼有害。有怖有猜。有怨有敌。迅速败坏多诸疾疫。多诸灾横。虚伪不实。离散无我。不可保信。如是汝等。应以正慧如实随观。出离色有。云何汝等。应以正慧如实随观。出无色有。谓正了知。是为寂静。是为微妙。谓离憍慢。息诸渴爱。灭阿赖耶。断诸径路。空无所得。爱尽离欲。寂灭涅槃。如是汝等。应以正慧如实随观。出无色有。若能如是。以其正慧如实随观。出离三有。便于欲有色无色有。能深厌背。深厌背故。能正离欲。正离欲故。能得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办。不受后有。尔时世尊。重摄此义。而说颂曰

  以正慧随观　　三界出离相
  能止息诸行　　得最上涅槃
  已解脱诸漏　　善修习瑜伽
  任持最后身　　降伏魔所使

吾从世尊闻如是语。苾刍当知。三因三缘。令诸有情希求利养生多过患。云何为三。一者贪欲为因为缘。令诸有情希求利养生多过患。二者耽着为因为缘。令诸有情希求利养生多过患。三者受用不见过患为因为缘。令诸有情希求利养生多过患。汝等苾刍。不应起此三因三缘希求利养生多过患。有诸苾刍。具此所说三因三缘。往施主家。求胜利养。或时其家。忽遽无赖。见已戚然。默不敬问。不起承迎。不延就座。不共谈论。彼见此相。便起念言。此施主家。恒相敬待。谁所诡佞。顿使其然。由此因缘。便于彼所。不忍不悦。起恚害心。或发身语恶不善业。因斯坠堕诸恶趣中。受不爱果。苾刍当知。我观世间。诸有情类。或由利养。扰乱其心。身坏命终。堕诸恶趣。生地狱中。受不爱果。我观世间。诸有情类。或由衰损。扰乱其心。身坏命终。堕诸恶趣。生地狱中。受不爱果。我观世间。诸有情类。或由利养及以衰损。扰乱其心。身坏命终。堕诸恶趣。生地狱中。受不爱果。所以者何。愚痴凡夫。被诸利养。先破其膜。既破膜已。复破其皮。既破皮已。复破其肉。既破肉已。复断筋脉。断筋脉已。复破其骨。既破骨已。复伤髓脑。然后方住。是故汝等。应如是学。我当云何。不被利养扰乱其心。我当云何不被衰损扰乱其心。我当云何不被利养及以衰损扰乱其心。独处空闲。勤修圣行。速证无上常乐涅槃。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  由三种因缘　　希求诸利养
  坏种种功德　　及退失人天
  诸有聪明人　　遇利养衰损
  其心善安定　　不动如山王
  常静虑安然　　正观诸法义
  修深细智见　　证常乐涅槃

吾从世尊闻如是语。苾刍当知。欲界胜生。略有三种。于彼虽成极大福聚。而受诸欲生死轮回。不能出离。所以者何。彼胜生处。是欲所行境界地故。云何为三。一欲住天欲界胜生。二乐化天欲界胜生。三他化天欲界胜生。如是三种欲界胜生。于彼虽成极大福聚。而受诸欲。生死轮回。不能出离。所以者何。彼胜生处。是欲所行境界地故。我圣弟子。于此三种欲界胜生。如实随观。有诸过患。故于欲界深生厌背。生厌背故。能正离欲。正离欲故能得解脱。得解脱已。便自了知我生已尽。梵行已立。所作已办。不受后有。尔时世尊。重摄此义。而说颂曰

  欲界三胜生　　恒受诸欲乐
  谓欲住乐化　　他化自在天
  生如是三处　　虽成就大福
  而生死轮回　　不能生上地
  于此诸欲中　　若能知过患
  舍人天等趣　　证无上涅槃

吾从世尊闻如是语。苾刍当知。世有一类诸恶苾刍。成就三法。而似驴鸣。云何为三。谓有一类诸恶苾刍。无敬无承。无惭无愧。懈怠忘念。如是一类诸恶苾刍。具足成就如是三法。而似驴鸣。谓实无德而随僧众。唱如是言。具寿当知。我亦是真沙门释子。然此一类诸恶苾刍。无有增上戒定慧学。如余清净真苾刍僧而随僧众。唱如是言。具寿当知。我亦是真沙门释子。如世有驴随牛群后。高声唱言。我亦是牛宜相顾待。然此驴身。头耳蹄喙毛色音声。皆与牛别而随牛后。高声唱言。我亦是牛宜相顾待。如是一类诸恶苾刍。实无其德而随僧众。唱如是言。具寿当知。我亦是真沙门释子。然此一类诸恶苾刍。依止村城聚落而住。日初分时。整理裳服。执持衣钵。往入村城聚落乞食。不能护持身语意业。不住正念。不守诸根。诣于净信诸施主家。为利养故身处下座。为居高座白衣说法。我说此类诸恶苾刍所有言说。皆似驴鸣。尔时世尊。重摄此义。而说颂曰

  剃发服染衣　　手执持应器
  实无戒定慧　　而自号沙门
  如世间有驴　　与牛形相异
  而逐牛群后　　自号是真牛
  如是恶苾刍　　成无敬等法
  虽常厕清众　　而不证菩提

吾从世尊闻如是语。苾刍当知。学有三种。若能于中。离诸放逸。昼夜精勤。绝诸缘务。独处空闲。无倒修学。未生诸漏令永不生。已生诸漏令永尽灭。云何为三。一者增上戒学。二者增上心学。三者增上慧学。何等名为增上戒学。谓诸苾刍。具净尸罗。安住守护别解脱戒。轨范所行无不圆满。于微小罪见大怖畏。具能受学所应学处。成就清净身语二业。成就净命。成就净见。如是名为增上戒学。何等名为增上心学。谓诸苾刍。能正离欲恶不善法。有寻有伺。离生喜乐。具足安住。最初静虑。广说乃至。具足安住。第四静虑。如是名为增上心学。何等名为增上慧学。谓诸苾刍。如实了知。是苦圣谛。苦集圣谛。苦灭圣谛。及能趣苦灭道圣谛。如是名为增上慧学。如是三学。若能于中。离诸放逸。昼夜精勤。绝诸缘务。独处空闲。无倒修学。未生诸漏令永不生。已生诸漏令永尽灭。尔时世尊。重摄此义。而说颂曰

  戒心慧学三　　智者应修学
  勤精进常安　　密禁守诸根
  昼夜处空闲　　绝世诸缘务
  勤修戒心慧　　如救自头燃
  名学圣学处　　至所学后边
  脱所脱无遗　　成清净妙智
  得不动解脱　　已永断诸漏
  尽生死苦边　　后有更无有

吾从世尊闻如是语。苾刍当知。学有三种。若有勤修。不空无果必至究竟。能得甘露。能证涅槃。云何为三。一者增上戒学。二者增上心学。三者增上慧学。何等名为增上戒学。谓诸苾刍。尊重尸罗戒为增上。不重等持定非增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住尸罗。能住所学。彼人定能永尽三结。证预流果。得无堕法。定趣菩提。极于七返人天往来。尽诸苦际。如是名为增上戒学。何等名为增上心学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住等持。能住所学。彼定能尽五下分结。证不还果。得不还法。当受化生。于彼世间。当般涅槃。如是名为增上心学。何等名为增上慧学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。尊重般若慧为增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住般若。能住所学。彼人定能永尽诸漏。得真无漏。心善解脱。慧善解脱。于现法中。具足安住。自证通慧。能自了知。我生已尽。梵行已立。所作已办。不受后有。如是名为增上慧学。若有于此所说三学勤修学者。我说必定不空无果。必至究竟。能得甘露。能证涅槃。如是名为学有三种。若有勤修不空无果。必至究竟。能得甘露。能得涅槃。尔时世尊。重摄此义。而说颂曰

  勤修增上戒　　住戒住所学
  能永尽三结　　定证预流果
  勤修增上心　　住定住所学
  能尽五下结　　定证不还果
  勤修增上慧　　住慧住所学
  能尽一切结　　定证无生果
  三学不唐捐　　必证第一义
  故尊重三学　　达法性无疑

吾从世尊闻如是语。苾刍当知。学有三种。若少分修得少分果。若圆满修得圆满果。云何为三。一者增上戒学。二者增上心学。三者增上慧学。何等名为增上戒学。谓诸苾刍。尊重尸罗戒为增上。不重等持定非增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住尸罗。能住所学。彼人定能永尽三结。证预流果。得无堕法。定趣菩提。极于七返人天往来。尽诸苦际。或复有能令其欲界贪恚微薄。证一来果。一来此间。尽诸苦际。如是名为增上戒学。何等名为增上心学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所刺学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住等持。能住所学。彼定能尽五下分结。证不还果。得不还法。当受化生。于彼世间。当般涅槃。如是名为增上心学。何等名为增上慧学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。尊重般若慧为增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住般若。能住所学。彼人定能永尽诸漏。得真无漏。心善解脱。慧善解脱。于现法中。具足安住。自证通慧。能自了知。我生已尽。梵行已立。所作已办。不受后有。如是名为增上慧学。如是名为学有三种。若少分修得少分果。若圆满修得圆满果。尔时世尊。重摄此义。而说颂曰

  多住尊重戒　　名于少分修
  常精进炽然　　便得少分果
  多住尊重定　　名于少分修
  常精进炽然　　亦得少分果
  多住尊重慧　　名于圆满修
  常精进炽然　　便得圆满果
  少分圆满修　　各得同类果
  知如是胜劣　　应舍分修圆

吾从世尊闻如是语。苾刍当知。学有三种。若正修习。令诸有情成下中上贤圣差别。云何为三。一者增上戒学。二者增上心学。三者增上慧学。何等名为增上戒学。谓诸苾刍。尊重尸罗戒为增上。不重等持定非增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住尸罗。能住所学。彼人定能。永尽三结。证预流果。得无堕法。定趣菩提。极于七返人天往来。或成家家。或一来果。或成一间。如是名为增上戒学。何等名为增上心学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。不重般若慧非增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办清净梵行。于诸学处。能住等持。能住所学。彼定能尽五下分结。证不还果。得不还法。当受化生。于彼世间。当般涅槃。或成中般。或成生般。或有行般。或无行般。或成上流。趣色究竟。或趣非想非非想处。而般涅槃。如是名为增上心学。何等名为增上慧学。谓诸苾刍。尊重尸罗戒为增上。尊重等持定为增上。尊重般若慧为增上。彼于少小所学戒中。微有所犯即能出离。所以者何。我说彼人终不毁犯所制学处。不深惭愧。定能随顺清净梵行。定能成办。清净梵行。于诸学处。能住般若。能住所学。彼人定能永尽诸漏。得真无漏。心善解脱。慧善解脱。于现法中。具足安住。自证通慧。能自了知我生已尽。梵行已立。所作已办。不受后有。如是名为增上慧学。如是名为学有三种。若正修习。令诸有情成下中上贤圣差别。尔时世尊。重摄此义。而说颂曰

  随学因势力　　常精进炽然
  下中上品修　　随得果差别
  谓下精进修　　还成下品果
  中修得中果　　上修亦复然
  既知三品修　　所得果差别
  故应舍中下　　宜遵上品修

吾从世尊闻如是语。苾刍当知。若诸苾刍。具调善戒。具调善法。具调善慧。彼于我法毗柰耶中。已具修行。名最上士。云何苾刍。具调善戒。谓诸苾刍。具净尸罗。安住守护别解脱戒。轨范所行无不圆满。于微小罪见大怖畏。具能受学。所应学处。成就清净身语二业。成就净命。成就净见。是名苾刍具调善戒。既具如是调善戒已。云何苾刍。具调善法。谓诸苾刍。勤修七种菩提分法。具足安住。是名苾刍具调善法。既具如是调善尸罗调善法已。云何苾刍具调善慧。谓诸苾刍。永尽诸漏。得真无漏。心善解脱。慧善解脱。于现法中。具足安住。自证通慧。能自了知。我生已尽。梵行已立。所作已办。不受后有。是名苾刍具调善慧。如是名为若有苾刍具调善戒。具调善法。具调善慧。彼于我法毗柰耶中。已具修行。名最上士。尔时世尊。重摄此义。而说颂曰

  若身语意思　　离诸恶不善
  名具调善戒　　有惭愧苾刍
  若能善修行　　七菩提分法
  名具调善法　　有妙定苾刍
  若能正了知　　自永尽诸漏
  名具调善慧　　真无漏苾刍
  若具三调善　　威德世难思
  若已具修行　　最上聪明士

吾从世尊。闻如是语。苾刍当知。诸有苾刍。成就三分。应知是人于净尸罗。已得圆满。于究竟位已得圆满。于修梵行已得圆满。已能穷至梵行后边。云何为三。谓有苾刍。成就无学戒定慧蕴。是名苾刍成就三分。应知是人于净尸罗已得圆满。于究竟位已得圆满。于修梵行已得圆满。已能穷至梵行后边。若诸苾刍。于净尸罗。已得圆满。于究竟位已得圆满。于修梵行已得圆满。已能穷至梵行后边。应知是人。必不乐居村城聚落房舍卧具。亦不乐与诸苾刍众。苾刍尼众。邬波索迦。邬波斯迦。勤策男等。同一园林。喧杂而住。应知是人成就第一寂静心法。独守空闲。依四依住。离诸垢秽。内守真实。弃舍所求。无染分别。不为世法之所涂染。譬如世间嗢钵罗花。拘牟陀花。钵特摩花。奔陀利花。依水而生。依水而长。虽从水出。而不为水之所染着。是人亦尔。依世间生。依世间长。虽现世间而不为诸世法所染。尔时世尊。重摄此义。而说颂曰

  无学三分成　　尸罗究竟位
  修梵行圆满　　至梵行后边
  如是苾刍众　　得最上瑜伽
  永尽诸苦边　　证无上安乐

吾从世尊闻如是语。苾刍当知。若有希求三种乐事。应于净戒不缺不穿不秽不杂。于净尸罗。应起上品。欲勤精进。终无懈废。云何为三。一者希求名誉乐事。应于净戒不缺不穿不秽不杂。于净尸罗。应起上品。欲勤精进。终无懈废。二者希求利养乐事。应于净戒不缺不穿不秽不杂。于净尸罗。应起上品。欲勤精进。终无懈废。三者希求生天乐事。应于净戒不缺不穿不秽不杂。于净尸罗。应起上品。欲勤精进。终无懈废。是名希求三种乐事。应于净戒不缺不穿不秽不杂。于净尸罗。应起上品。欲勤精进终无懈废尔时世尊。重摄此义。而说颂曰

  为求三种乐　　智者护尸罗
  谓世尚名誉　　利养生天乐
  观如是胜乐　　智者护尸罗
  当远恶亲知　　如避崄恶道
  虽不造众恶　　而亲近恶人
  如以吉祥茅　　裹臭烂鱼肉
  亲所不应亲　　狎所不应狎
  如持鲜净物　　投粪秽深坑
  世间乐净人　　常惧秽涂染
  有智者亦尔　　深怖恶亲知

吾从世尊闻如是语。苾刍当知。有三种香。唯顺风熏。不能逆风。云何为三。一者根香。二者茎香。三者花香。如是三种。唯顺风熏。不能逆风。汝等苾刍。勿作是念。更无余香。或顺风熏。或逆风熏。或复顺逆。皆悉能熏。所以者何。我佛法中。有一妙香。能顺风熏。能逆风熏。能顺逆熏。天上人中。皆闻芬馥。世间贤圣。无不珍爱何等名为我佛法中。有一妙香。能顺风熏。能逆风熏。能顺逆熏。天上人中。皆闻芬馥。世间贤圣。无不珍爱。所谓戒香。由此戒香。能顺风熏。能逆风熏。能顺逆熏。天上人中。皆闻芬馥。世间贤圣。无不珍爱。如是名为我佛法中。有一妙香。能顺风熏。能逆风熏。能顺逆熏。天上人中。皆闻芬馥。世间贤圣。无不珍爱。尔时世尊。重摄此义。而说颂曰

  世间诸所有　　根茎花等香
  皆不逆风熏　　以势力微故
  唯我佛法中　　有一妙香类
  顺风逆风等　　无不普皆熏
  天上及人中　　诸世间贤圣
  一切皆珍爱　　所谓净戒香
  若能于此香　　无放逸而住
  生无倒定慧　　永尽众苦边

重摄前经嗢拖南曰

  同界感后有　　求利及欲生
  恶说似驴鸣　　四学与四戒

本事经卷第六本事经卷第七

        大唐三藏法师玄奘奉　诏译

    三法品第三之二

吾从世尊闻如是语。苾刍当知。于此世间。子有三种。云何为三。一者等子。二者胜子。三者劣子。云何等子。谓有一类父母。具戒成调善法。能离杀生。离不与取。离欲邪行。离虚诳语。离饮诸酒生放逸处。子亦具戒。成调善法。能离杀生。离不与取。离欲邪行。离虚诳语。离饮诸酒生放逸处。是名等子。云何胜子。谓有一类父母。犯戒成诸恶法。乐行杀生。行不与取。行欲邪行。行虚诳语。行饮诸酒生放逸处。子能持戒。成调善法。能离杀生。离不与取。离欲邪行。离虚诳语。离饮诸酒生放逸处。是名胜子。云何劣子。谓有一类父母。具戒成调善法。能离杀生。离不与取。离欲邪行。离虚诳语。离饮诸酒生放逸处。其子犯戒。成诸恶法。乐行杀生。行不与取。行欲邪行。行虚诳语。行饮诸酒生放逸处。是名劣子。如是名为于此世间子有三种。尔时世尊。重摄此义。而说颂曰

  世间聪慧人　　欣乐等胜子
  不欣乐劣子　　勿损坏家门
  应知三子中　　一劣二为胜
  佛正觉而说　　诸贤圣亦然
  二俱信尸罗　　聪慧无悭吝
  如晴夜满月　　处众曜威光
  应亲近供养　　诸佛所称扬
  远离诸垢尘　　所行无怖畏

吾从世尊闻如是语。苾刍当知。若有苾刍。尊重正法爱乐正法。欣正法乐。精进修行。爱乐法行。如是苾刍。随念正法。常乐永断贪不善根。无贪善根。修令圆满。常乐永断嗔不善根。无嗔善根。修令圆满。常乐永断痴不善根。无痴善根。修令圆满。修三善根。得圆满已。修四念住。亦令圆满。修四念住。得圆满已。修四正断。亦令圆满。修四正断。得圆满已。修四神足。亦令圆满。修四神足。得圆满已。修习五根。亦令圆满。修习五根。得圆满已。修习五力。亦令圆满。修习五力。得圆满已。修七觉支。亦令圆满。修七觉支。得圆满已。修八圣道支。亦令圆满。修八圣道支。得圆满已。明及解脱。皆得圆满。尔时世尊。重摄此义。而说颂曰

  尊重法乐法　　欣法乐法行
  于法常随念　　能不退正法
  法念修善业　　不念行恶行
  行法定能招　　此世他世乐
  法护行法人　　如雨时大伞
  行法获法利　　定不坠三涂

吾从世尊闻如是语。苾刍当知。世间略有三种寻思。有学苾刍。未得心者欣求无上安乐法时。能令退失。云何为三。一者亲里相应寻思。二者利养相应寻思。三者妒胜相应寻思。如是略说三种寻思。有学苾刍未得心者。欣求无上安乐法时。能令退失。是故汝等。应如是学。我当云何不起亲里相应寻思。不起利养相应寻思。不起妒胜相应寻思。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  依耽嗜寻思　　略说有三种
  学求无上乐　　为障必无疑
  依亲里相应　　利养及妒胜
  去大乐大净　　结尽甚为遥
  舍亲属利养　　及妒胜寻思
  摄止观勤修　　速能尽众苦

吾从世尊闻如是语。苾刍当知。略有三法。有学苾刍未得心者。欣求无上安乐法时。能令退失。云何为三。一者苾刍喜乐事业。贪爱事业。耽着事业。二者苾刍喜乐谈话。贪爱谈话。耽着谈话。三者苾刍喜乐睡眠。贪爱睡眠。耽着睡眠。如是三法。有学苾刍未得心者。欣求无上安乐法时。能令退失。是故汝等。应如是学。我当云何不乐事业。不爱事业。不着事业。我当云何不乐谈话。不爱谈话。不着谈话。我当云何不乐睡眠。不爱睡眠。不着睡眠。汝等苾刍。应如是学。尔时世尊。重摄此义。而说颂曰

  求无上果时　　有三法令退
  乐爱着事业　　谈话及睡眠
  有学诸苾刍　　若具此三法
  终不能证得　　最胜三菩提
  若欲求速证　　最胜三菩提
  应少事话眠　　正勤修止观

吾从世尊。闻如是语。苾刍当知。有三种法。和合现前。能令净信。诸善男子。生无量福。云何为三。一者净信。和合现前。能令净信诸善男子。生无量福。二者施物和合现前。能令净信。诸善男子。生无量福。三者福田和合现前。能令净信诸善男子。生无量福。是名三法。和合现前。能令净信诸善男子。生无量福。尔时世尊。重摄此义。而说颂曰

  三法合现前　　能生无量福
  谓净信施物　　及真净福田
  具慧具尸罗　　善调伏三毒
  修沙门梵行　　名真净福田
  具慧具净信　　手持如法财
  奉施良福田　　必当获大果
  身四威仪中　　于三宝四谛
  正顺无瑕秽　　名为净信心
  于诸惠施中　　法施为最胜
  净心演正法　　诸佛所称誉

吾从世尊。闻如是语。苾刍当知。诸有智者。应以三种不坚之法。贸易三坚。云何为三。一者应以不坚之财。贸易坚财。二者应以不坚之身。贸易坚身。三者应以不坚之命。贸易坚命。云何应以不坚之财贸易坚财。谓有净信诸善男子或善女人。如法精勤。劳役手足。竭力流汗。所获珍财。应自供身。奉上父母。赈给妻子奴婢仆使朋友眷属。昼夜集会。欢娱受乐。而遇沙门。或婆罗门。具净尸罗。成调善法。勤修梵行。除去憍逸。忍辱柔和。履正直路。弃诸邪道。趣涅槃城。以净信心。欢喜恭敬。如应如时。持用布施。远求无上安乐涅槃。或希当来人天乐果。是名应以不坚之财贸易坚财。云何应以不坚之身贸易坚身。谓有净信诸善男子或善女人。成就正见。能离杀生。究竟圆满。无犯清净。离不与取。究竟圆满无犯清净。离欲邪行。究竟圆满。无犯清净。离虚诳语。究竟圆满。无犯清净离饮诸酒。生放逸处。究竟圆满。无犯清净。如是等类。是名应以不坚之身贸易坚身。云何应以不坚之命贸易坚命。谓我法中。诸圣弟子。如实了知。是为苦谛。如实了知。是苦集谛。如实了知。是苦灭谛。如实了知。是能趣向苦灭道谛。是名应以不坚之命贸易坚命。如是名为诸有智者应以三种不坚之法贸易三坚。尔时世尊。重摄此义。而说颂曰

  如世有智人　　以贱而贸贵
  正见者亦尔　　以不坚易坚
  知此财身命　　不净不坚牢
  求清净坚牢　　世出世间乐
  天上财身命　　是世净坚牢
  证常乐涅槃　　是真净坚法

吾从世尊。闻如是语。苾刍当知。根有三种。其性甚深。显了甚深。其性难见。显了难见。云何为三。一者未知当知根。二者知根。三者具知根。何等名为未知当知根。谓我法中诸圣弟子。于未见知诸苦圣谛。为见为知。发生乐欲。策励精进。摄心持心。于未见知苦集圣谛。为见为知。发生乐欲。策励精进。摄心持心。于未见知苦灭圣谛。为见为知发生乐欲。策励精进。摄心持心。于未见知能趣苦灭真道圣谛。为见为知。发生乐欲。策励精进。摄心持心。是名未知当知根。何等名为知根。谓我法中。诸圣弟子。如实了知。是苦圣谛。是苦集圣谛。是苦灭圣谛。是能趣苦灭真道圣谛。是名知根。何等名为具知根。谓我法中。诸圣弟子。诸漏已尽。得真无漏。心善解脱。慧善解脱。能正了知。我生已尽。梵行已立。所作已办。不受后有。是名具知根。如是名为根有三种。其性甚深。显了甚深。其性难见。显了难见。尔时世尊。重摄此义。而说颂曰

  于我正法中　　圣弟子有学
  顺修正直路　　是名第一根
  正知苦圣谛　　及苦集苦灭
  能趣苦灭道　　是名第二根
  第三根当知　　诸漏皆永尽
  证得真无漏　　心慧善解脱
  知我生已尽　　及梵行已立
  所作皆已办　　不受后有身
  身心常寂静　　善摄护诸根
  任持最后身　　降伏魔所使

吾从世尊。闻如是语。苾刍当知。略有三种补特伽罗。为义利故。应当亲近。云何为三。一有一类补特伽罗。成就劣戒劣定劣慧。二有一类补特伽罗。成就等戒等定等慧。三有一类补特伽罗。成就胜戒胜定胜慧。诸有一类补特伽罗。成就劣戒劣定劣慧。为何义利。应当亲近。谓于此类补特伽罗。无所希求。唯深悲愍。劝令胜进。为此义利。应当亲近。诸有一类补特伽罗。成就等戒等定等慧。为何义利。应当亲近。谓于此类补特伽罗。作是思惟。彼当为我说相似戒。我当为彼说相似戒。更互听闻。令得相续。多有所作。作是思惟。彼当为我说相似定。我当为彼说相似定。更互听闻。令得相续。多有所作。作是思惟。彼当为我说相似慧。我当为彼说相似慧。更互听闻。令得相续。多有所作。为此义利。应当亲近。诸有一类补特伽罗。成就胜戒胜定胜慧。为何义利。应当亲近。谓于此类补特伽罗。作是思惟。我当依彼所有戒蕴。若未圆满。修令圆满。若已圆满。内摄正念。坚固任持。作是思惟。我当依彼所有定蕴。若未圆满。修令圆满。若已圆满。内摄正念坚固任持。作是思惟。我当依彼所有慧蕴。若未圆满。修令圆满。若已圆满。内摄正念坚固任持。为此义利。应当亲近。如是名为略有三种补特伽罗。应当亲近。尔时世尊。重摄此义。而说颂曰

  亲劣为慈悲　　亲等为相益
  亲胜为已德　　圆满或坚持
  亲下士德劣　　亲中士德中
  亲上士德胜　　故应亲上士

吾从世尊。闻如是语。苾刍当知。应于其身住不净观。应于其息住随息念。应于诸行住无常观。苦无我观。若能于身住不净观。便于净界。当断贪欲。若能于息住随息念。便能断外寻思障品。若能于行住无常观。苦无我观。便于诸有能断有爱。断有爱故。便于世间。无所执受。无执受故。便无怖畏。无怖畏故。便自内证究竟涅槃。证涅槃已便自了知。我生已尽。梵行已立。所作已办。不受后有。尔时世尊。重摄此义。而说颂曰

  于身观不净　　于息住随念
  观诸行无常　　及与苦无我
  达诸行性空　　得最胜寂静
  爱尽无执受　　证究竟涅槃

吾从世尊。闻如是语。苾刍当知。诸有情身。常为三种勇健怨贼随逐切害。云何为三。一者衰老勇健怨贼。二者疾病勇健怨贼。三者无常勇健怨贼。如是三种勇健怨贼。常随切害诸有情身。有情身中。略有三法。一者寿命。二者暖气。三者心识。如是三法。远离身时。名为死没。臭秽尸骸。弃在冢间。无所复用。所以者何。是身虚伪。诸法合成。其中胜者。谓寿暖识。而此诸法。依因缘生。无常无强。无坚无力。迅速灭坏。老病死贼。常随不舍。而诸愚夫。无明所覆。宝爱耽着。无厌舍心。我圣弟子。能于如是假合成身。如实知见。多诸过患。便于一切内外身中。能深厌背。深厌背故。能离贪欲。离贪欲故。便得解脱。得解脱已。便自了知。我生已尽。梵行已立。所作已办不受后有。尔时世尊。重摄此义。而说颂曰

  一切有情身　　三怨贼随害
  所谓老病死　　曾无暂舍时
  众法合成身　　虚伪无坚实
  若舍寿暖识　　弃之于冢间
  愚夫无所知　　常宝爱耽着
  贤圣有智见　　厌之踰粪坑
  修无漏圣道　　断三贼因缘
  证常乐涅槃　　永解脱三贼
  世间有智者　　当深厌自身
  求常乐涅槃　　精勤勿放逸

吾从世尊。闻如是语。苾刍当知。诸福业事。略有三种。应修应习。应多修习。云何为三。一者施福业事。二者戒福业事。三者修福业事。何等名为施福业事。谓有净信诸善男子或善女人。能施种种饮食肴膳香鬘衣服车乘卧具堂宇室宅灯烛庭燎诸资生具。如是名为施福业事。何等名为戒福业事。谓有净信诸善男子或善女人。能离杀生。究竟圆满。无犯清净。离不与取。究竟圆满。无犯清净。离欲邪行。究竟圆满。无犯清净。离虚诳语。究竟圆满。无犯清净。离饮诸酒生放逸处。究竟圆满。无犯清净。如是名为戒福业事。云何名为修福业事。谓有净信诸善男子或善女人。修慈俱心。遍满一方。具足安住。如是第二第三第四。上下方维。一切世界。悉皆遍满。具足安住。令慈俱心广大无量。无怨无害。遍满而住。修悲俱心。遍满一方。具足安住。如是第二第三第四。上下方维。一切世界。悉皆遍满。具足安住。令悲俱心广大无量。无怨无害。遍满而住。修喜俱心。遍满一方。具足安住。如是第二第三第四。上下方维。一切世界。悉皆遍满。具足安住。令喜俱心广大无量。无怨无害。遍满而住。修舍俱心。遍满一方。具足安住。如是第二第三第四。上下方维。一切世界。悉皆遍满。具足安住。令舍俱心广大无量。无怨无害。遍满而住。如是名为修福业事。于此所说三福业事。应修应习。应多修习。尔时世尊。重摄此义。而说颂曰

  有三法应修　　应习多修习
  能得三种乐　　所谓施戒修
  修施感多财　　修戒得长寿
  修慈悲喜舍　　当生清净天
  世间有智人　　欲求殊胜乐
  应修此三福　　定当得无疑

吾从世尊。闻如是语。苾刍当知。世间最胜。略有三种。云何为三。一于一切施设有情。无足二足。四足多足。有色无色。有想无想。及与非想非非想中。佛为最胜。所谓如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。若于佛所。起净信心。于诸信中。最为第一。如是净信。所感果报。于天人中。最为第一。二于一切施设法门。世出世间。为无为等。诸法门中。涅槃最胜。诸离憍慢。息诸渴爱。灭阿赖耶。断诸径路。爱尽离欲。寂静涅槃。若于如是涅槃法中。起净信心。于诸信中。最为第一。如是净信所感果报。于天人中。最为第一。三于一切施设徒众。朋侣邑义。诸集会中。佛圣弟子。僧为最胜。谓四向四果。八补特伽罗。诸有情中。为真为妙。为最第一。应奉延请。恭敬供养。称扬赞叹。不吝身财。是诸世间。人天等众。无上福田。若于如是贤圣僧中。起净信心。于诸信中。最为第一。如是净心所感果报。于天人中。最为第一。如是名为三种最胜。尔时世尊。重摄此义。而说颂曰

  最胜有三种　　所谓佛法僧
  依生净信心　　能见最胜法
  依佛生净信　　知两足中尊
  证无上菩提　　天人等应供
  依法生净信　　知离欲中尊
  证无上涅槃　　寂静常安乐
  依僧生净信　　知诸众中尊
  证无上福田　　天人等应供
  施最胜良田　　生最胜功德
  感最胜安乐　　寿色力名闻
  供养最胜人　　修行最胜法
  得最胜安乐　　天上或人中
  施三宝福田　　名最胜施者
  所在常安乐　　后当证涅槃

重摄前经嗢拖南曰

  子尊重二学　　福坚根补罗
  不净等及怨　　福业事最胜

吾从世尊。闻如是语。苾刍当知。有三大师出现世间。利益安乐无量众生。哀愍世间天人大众。令得无量义利安乐。云何为三。所谓如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。出现世间。为诸众生。开阐正法。初中后善。文义巧妙。示现纯满。清白梵行。谓是苦谛。是苦集谛。是苦灭谛。是能趣向。苦灭道谛。如是名为第一大师出现世间。利益安乐无量众生。哀愍世间天人大众。令得无量义利安乐。复有如来应正等觉无学弟子。是阿罗汉。诸漏已尽。梵行已立。所作已辨。弃诸重担。得自义利。尽诸有结。已正奉行如来圣教。已得解脱。已证遍知。出现世间。为诸众生。开阐正法。初中后善。文义巧妙。示现纯满。清白梵行。谓是苦谛。是苦集谛。是苦灭谛。是能趣向苦灭道谛。如是名为第二大师出现世间。利益安乐无量众生。哀愍世间天人大众。令得无量义利安乐。复有如来应正等觉有学弟子。具修梵行。具正多闻。所谓正闻契经应颂记别伽陀无问自说本事本生方广希法。善知其义。出现世间。为诸众生。开阐正法。初中后善。文义巧妙。示现纯满。清白梵行。谓是苦谛。是苦集谛。是苦灭谛。是能趣向苦灭道谛。如是名为第三大师出现世间。利益安乐无量众生。哀愍世间天人大众。令得无量义利安乐。如是名为有三大师出现世间。利益安乐无量众生。哀愍世间天人大众。令得无量义利安乐。尔时世尊。重摄此义。而说颂曰

  有三种大师　　若出现于世
  能利益安乐　　天人等世间
  一者谓如来　　二无学弟子
  三有学弟子　　具净戒多闻
  如是三大师　　天人等应供
  能宣说正法　　广开甘露门
  令无量众生　　永尽诸有结
  解脱生死苦　　证常乐涅槃
  譬如善导师　　能示人善道
  正顺而行者　　得安乐无疑
  如是三大师　　示众生四谛
  修行无放逸　　定超生死边

吾从世尊。闻如是语。苾刍当知。有三时中诸天集会。欢喜详议。更相劝励。来降人间。云何为三。谓我弟子。或少资财。或多资财。或少眷属。或多眷属。或姓尊贵。或姓卑微。初发净信。厌背家法。欣乐出家。尔时诸天。欢喜集会。咸相谓言。天仙当知。今佛弟子。与恶魔军。将兴战诤。我等宜应帅诸天众往降人间。冥加祐助增彼信心。令无障难。作是语已。来降人间。作所应作。如是名为第一时中诸天集会。欢喜详议。更相劝励。来降人间。又我弟子。剃除须发。被服袈裟。以正信心。弃舍家法。出趣非家。与诸苾刍同修和敬。安住守护别解脱戒。轨范所行。无不圆满。于微少罪。见大怖畏。受学一切所应学处。成就清净身语意业。成就净命。成就净见。尔时诸天。欢喜集会。咸相谓言。天仙当知。今佛弟子。与恶魔军。正兴战诤。我等宜应帅诸天众往降人间。冥加祐助增彼威力令胜魔军。作是语已。来降人间。作所应作。如是名为第二时中诸天集会。欢喜详议。更相劝励。来降人间。又我弟子。诸漏永尽。证真无漏。心善解脱。慧善解脱。于现法中。自证通慧。具足安住。能自了知。我生已尽。梵行已立。所作已办。不受后有。尔时诸天。欢喜集会。咸相谓言。天仙当知。今佛弟子。与恶魔军。已兴战诤。已断魔首。已碎魔军。已自称言。我生已尽。梵行已立。所作已办。不受后有。我等宜应帅诸天众持妙香花。往降人间。礼拜供养。称扬赞叹。请说正法。度脱己身生老病死。作是语已。来降人间。作所应作。如是名为第三时中诸天集会。欢喜详议。更相劝励。来降人间。苾刍当知。若有国土城邑聚落。有净信心求出家者。有剃须发正出家者。有出家已诸漏尽者。于彼国土城邑等中。诸大天仙。及善神等皆来降下。勤加守护。令其丰乐。风雨顺时无诸疾疫。其中众生。慈心相向。同修善业。现在当来。长夜安隐。速证无上常乐涅槃。如是名为有三时中。诸天集会。欢喜详议。更相劝励。来降人间。尔时世尊。重摄此义。而说颂曰

  诸天于三时　　欢喜共集会
  详议相劝帅　　来降于人间
  最初求出家　　第二剃须发
  第三漏永尽　　摧伏诸魔军
  诸天见出家　　能永尽诸漏
  咸恭敬供养　　如是赞颂言
  归命殊胜人　　归命最上士
  归命摧魔众　　获得大名闻
  诸天欢喜心　　祐助修供养
  希求剃须发　　漏尽证无生
  是故应正勤　　系念乐静虑
  勇猛无放逸　　摧伏诸魔军
  于佛法律中　　正信出家者
  能解脱诸漏　　永尽众苦边

吾从世尊。闻如是语。苾刍当知。略有三事。天胜于人。云何为三。一者长寿。二者端严。三者快乐。如是三事。天胜于人。百千万倍。不可称计。所以者何。如此人间五十年量。当彼天上四天王天一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。四天王天寿量五百。当于人间九百万岁如此人间一百年量。当彼天上三十三天一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。三十三天寿量千岁。当于人间三千六百万岁。如此人间二百年量。当彼天上夜摩天中一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。夜摩天中寿量二千岁。当于人间一亿四千四百万岁。如此人间四百年量。当彼天上睹史多天一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。睹史多天寿量四千。当于人间五亿七千六百万岁。如此人间八百年量。当彼天上乐变化天一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。乐变化天寿量八千。当于人间二十三亿四百万岁。如此人间千六百年。当彼天上他化自在天一日一夜。如是日夜。数至三十。以为一月。积十二月。以为一年。以如是年。他化自在天。寿量一万有六千岁。当于人间九十二亿一千六百万岁(此中算数万万为亿)。如是名为诸天长寿。诸天端严。诸天快乐。人间所有。不可为喻。如是诸天。三种胜事。一切皆是。无常无恒。不可保信。变坏之法。死力所吞。系属于死。彼诸天众。临命终时。有余天众。来诣其所。教授教诫言。诸天仙当愿汝等往生善趣。生善趣已。获得善利。得善利已。有所成办。此中诸天。往何善趣。得何善利。何所成办。谓彼诸天。既命终已。来生人中。得人同分。名往善趣。至人趣已。于佛所说法毗柰耶。获得正信。名得善利。如是正信。增长广大。根深坚固。世间沙门。或婆罗门。诸天魔梵。无能如法引令退转。故名成办。由成办故。于佛法中。多有所作。谓净信心。出家受戒。修奢摩他毗钵舍那。观四圣谛。永断诸漏。证得涅槃。尽苦边际。尔时世尊。重摄此义。而说颂曰

  诸天三事胜　　长寿端严乐
  人中与挍量　　算数甚难及
  如是三胜事　　非常亦非恒
  难保变坏法　　死魔力所系
  天将舍命时　　余天集其所
  善教授教诫　　令生欢喜心
  当愿汝天仙　　往生于善趣
  得预人同分　　生中国聪明
  于佛法律中　　获得于正信
  增长根坚固　　邪教不能转
  身语意恶行　　能方便弃舍
  彼所生过失　　亦能方便除
  多修身语意　　三殊胜善业
  如理正思惟　　令无量广大
  修诸福业事　　谓施戒多闻
  于佛正法中　　出家修梵行
  正信修法行　　恒忍辱柔和
  或生天人中　　或证涅槃乐
  如是诸天仙　　来教诫教授
  将舍命天众　　如母愍于子
  诸天常发愿　　善趣转增益
  令阿素洛等　　退散永无增

本事经卷第七


比丘避女恶名欲自杀经

    No. 503

比丘避女恶名欲自杀经

        西晋沙门法炬译

如是我闻。一时佛住舍卫国。祇树给孤独园。时有异比丘。在拘萨罗人间。住一林中。时彼比丘。与长者妇女。嬉戏起恶名声。时彼比丘。作是念。我今不应共他妇女起恶名声。我今欲于此林中自杀。时彼林中。止住天神作是念。恶不善不类。此比丘不坏无过。而于林中。欲自杀身。我今当往方便开悟。时彼天神。化作长者女身语比丘言。于诸巷路四衢道中。世间诸人。为我及汝。起恶名声言。我与汝共相习近。作不正事。已有恶名今可还俗共相娱乐。比丘答言。以彼里巷四衢道中。为我与汝起恶名声。共相习近。为不正事。我今且自杀身。时彼天神还复天身。而说偈言

  虽闻多恶名　　苦行者忍之
  不应苦自害　　亦不应起恼
  闻声恐怖者　　是则林中兽
  是轻躁众生　　不成出家法
  仁者当堪耐　　下中上恶声
  执心坚住者　　是则出家法
  不由他人语　　令汝成劫贼
  亦不由他人　　令汝得罗汉
  如法自知已　　诸天亦复知

尔时比丘。为彼天神所开悟已。专精思惟。断除烦恼。得阿罗汉比丘避女恶名欲自杀经


比丘听施经

    No. 504

比丘听施经

        东晋天竺三藏昙无兰译

闻如是。一时佛在舍卫国。祇树给孤独园。时有一比丘。到讲堂诸比丘所言。诸贤者。今我不可经法。大著睡眠。不乐道行。疑诸经法。座中有一比丘。即行白佛。有一比丘。字听施。来到讲堂。谓诸比丘言。今我不可经法。大著睡眠。不乐道行。疑诸经法。佛便报言。是比丘痴。不守诸根门。不少食不上夜后夜警顺行。不观诸善法。如是当那可经法。离睡眠乐道行。不疑诸经法。听施终不从此得是

佛言比丘。以不守诸根门。不少食不上夜后夜警顺行。不观诸善法。彼当那可经法。离睡眠乐道行。不疑诸经法。终不从此得是。若比丘守诸根门。少食上夜后夜警顺行。观诸善法。便可经法。离睡眠乐道行。不疑诸经法。从是可得此

佛告比丘。便呼听施来。比丘便起。头面礼佛足。往呼听施。听施即至佛所。头面礼佛足已就座。佛便言。听施汝所欲便说之。听施言。今身不可经法。大著睡眠。不乐道行。疑诸经法。佛语听施。我欲问若事。随若所以知事说之。佛言。若宁知。贪色不离。欲不离。恋慕不离。慷慨不离。爱不离。以彼色别离。时便生他变。忧愁悲哀痛乱意殟。殟有是无。听施言。如是若干从彼有。佛言。善哉善哉。贤者如是应听施。佛言。如彼不离。若宁知痛痒思想作行识。若人贪识不离。欲不离。恋慕不离。慷慨不离。爱不离。以彼识别离。时便生他变。忧愁悲哀。痛乱意殟。殟有是不。听施言。彼有是。佛言善哉善哉。贤者如是应听施

佛言。如彼不离。若宁知离贪色离欲离恋慕离慷慨离爱。以彼色别离。时不生他变。忧愁悲哀。痛乱意殟。殟彼有是无有。听施言。彼有是。佛言。善哉善哉。贤者如是应听施

佛言。如彼离痛痒思想生死行识。若不贪识。无有欲。无恋慕。无有慷慨。无有爱。以彼识别离。时不生他变。忧愁悲哀。痛乱意殟。殟宁彼有是无有。听施言。彼有是。佛言善哉善哉。如是应听施

佛便告听施。我欲为若说经法。上亦善。中亦善。至竟亦善。具为若现道行至竟。但诸善善好。当听之持着意中。听施言。唯诺

佛言。曾有二人。俱出在道。其一人晓道径。其一人不晓道径。不晓道径者。便往问晓道径者言。我欲至某聚乡郡县国。愿语我道所由。晓道径者便言。汝从是道。直右行前。当有两道。舍左道上右道。直右行须臾前。当见溪谷。溪谷上亦当复有两道。舍左道上右道。直右行须臾当见丛树。丛树上亦当复有两道。舍左道上右道。直右行须臾稍稍便得。若所欲至聚乡郡县国

佛言。我上头所譬喻说。当知是一切所说。亦当谛观此所说。上头所说。不晓道径者。谓世间邪道。亦复谓诸所受邪者所说。上头晓道径者。谓如来不着正觉。亦复谓诸所受正觉者。所说左道者。谓诸恶人三恶念。一者欲念。二者乱念。三者贼害念。亦复谓邪见邪念邪说邪意邪行邪方便邪志邪定。亦说右道者。谓三善念。一者出家念。二者不乱念。三者不贼害念。亦复谓正见正念正说正意正行正方便正志正定。所谓两道者。谓人所疑。所说溪谷者。谓嗔恚。所说丛树者。谓五乐。一者眼乐色。爱欲可以好色贪着。二者耳乐声。三者鼻乐香。四者舌乐味。五者身乐细软。爱欲可以好色贪着。所说聚乡郡县国者。谓无为德。佛告听施。是诸佛事。我以悲心故说。是其欲度脱者者。已愍伤之。今彼是若事。当以寂静树下。空闲一处。一心体行。若山泽冢间。当以果蓏为食。比丘莫贪欲。于世间居后悔之。是诸佛行。亦诸佛教。今佛已说。是贤者听施。便欢喜思惟佛所说比丘听施经


辩意长者子经

    No. 544

辩意长者子经

        后魏沙门法场译

闻如是。一时佛在舍卫国祇树给孤独园。与千二百五十沙门俱。菩萨万人。尔时世尊与无央数大众共会围绕说法。时舍卫城中有大长者子。名曰辩意。从五百长者子。各有五百侍从。来诣佛所。前以头面着地。为佛作礼却坐一面。于时辩意长者子察众坐定。承佛威神从坐起正衣服。俨然而前为佛作礼。长跪叉手。白佛言。欲有所问。唯愿世尊慈愍敷演。世尊至真。三界无上道德神化。济度群萌普演权道令众得所。当来之世五浊鼎沸三毒炽盛以此相烧。无尊无卑毒念相向。若当臣王以贪国位。兴师相伐身死名灭。当尔之时灾及小民。若佛弟子四辈之众。蒙佛遗恩得为道名。外着法衣内怀嫉妒。无有敬顺转相诽谤。扬恶遏善贡高非彼。此之人辈。皆是地狱饿鬼畜生之分。利一时之荣。不知后世劫数之殃。当以何法而开化之。唯愿世尊。具示教化。使将来人可蒙此福。得离三涂永处福堂。佛言。善哉善哉。辩意长者子。乃于佛前作师子吼。有所发起开化一切。当来愚闇凶恶之人。得蒙是义快如是乎。所欲问者莫得疑难。如来当为分别说之

长者子辩意白佛言。人何因缘得生天上。复何因缘来生人中。复何因缘生地狱中。复何因缘常生饿鬼中。复何因缘生畜生中。复何因缘常生尊贵众人所敬。复何因缘生奴婢中为人所使。复何因缘生庶民中。口气香洁身心常安。为人所誉不被诽谤。复何因缘得生为人。常被诽谤为人所憎。形状丑恶身意不安常怀恐怖。复何因缘所生之处常与佛会。闻法奉持初不差违。遭遇知识逮得好心。若作沙门常得所愿。所问如是。唯愿世尊。分别解说。令此众会得闻正教。愿使一切得济彼安

佛告长者子辩意。谛听谛听。善思念之。吾当为汝解说妙要。有五事行得生天上。何谓为五。一者慈心。不杀群生悉养物命令众得安。二者贤良。不盗他物布施无贪济诸穷乏。三者贞洁。不犯外色男女护戒奉斋精进。四者诚信。不欺于人护口四过无得贪欺。五者不饮酒。不过口行。此五事乃得生天。尔时世尊。以偈颂曰

  不杀得长寿　　无病常鲜肥
  一切受天位　　身安光景至
  不盗常大富　　自然钱财宝
  七宝为宫殿　　娱乐心常好
  男女俱不淫　　身体香洁净
  所生常端正　　德行自然明
  不欺口气香　　言语常聪明
  谈论不謇吃　　所说众奉行
  酒肉不过口　　无有误乱意
  若当所生处　　天人常奉侍
  若其寿终后　　二十五神迎
  五福自然来　　光影甚炜炜

佛告辩意。复有五事得生人中。何谓为五。一者布施。恩润贫穷。二者持戒。不犯十恶。三者忍辱。不乱众意。四者精进。劝化懈怠。五者一心。奉孝尽忠。是为五事。得生人中大富长寿端正威德。得为人主一切敬侍。尔时世尊。以偈颂曰

  布施得大富　　钱财而自然
  所生常尊贵　　辄得父余财
  持戒常完具　　奉受三尊教
  尽心不犯恶　　便得寿命长
  忍辱不乱众　　嗔恚不犯人
  挝骂不还报　　所生常端正
  精进不懈怠　　常念奉持行
  所生辄豪强　　得为一切将
  一心不退转　　忠信念反复
  供事诸尊长　　所生无艰难
  若行此五事　　转得为人主
  财力色端正　　自然勇猛将

佛复告辩意。有五事行。死入地狱亿劫乃出。何谓为五。一者不信有佛法众。而行诽谤轻毁圣道。二者破坏佛寺尊庙。三者四辈转相谤毁。不信殃罪无敬顺意。四者反逆无有上下。君臣父子不相顺从。五者当来有欲为道者已得为道。便不顺师教而自贡高轻慢谤师。是为五事死入地狱。展转地狱无有出期。尔时世尊。以偈颂曰

  世间愚痴人　　不信佛法众
  愚意欲毁坏　　言佛无有神
  眼见善恶事　　故作众罪行
  神祠而坏之　　利少得罪多
  末世诸四辈　　含毒怀嫉妒
  名利故相毁　　不知后罪重
  世间诸群臣　　父子恶相加
  财宝利名故　　无有敬顺意
  当来诸恶人　　以得为沙门
  不奉受师教　　死受罪不轻
  行此五事者　　其罪不可说
  亿劫地狱中　　诸佛不能救

复次长者子。有五事行堕饿鬼中。何谓为五。一者悭贪不欲布施。二者盗窃不孝二亲。三者愚冥无有慈心。四者积聚财物不肯衣食。五者不给父母兄弟妻子奴婢。是为五事堕饿鬼中。尔时世尊。以偈颂曰

  悭贪不布施　　私窃不养亲
  藏积恐亡遗　　无慈于老人
  妻子及奴婢　　一皆不给与
  坐守财物死　　饿鬼甚为苦
  身不见衣裳　　腹大咽如针
  东西行求食　　洋铜灌其口
  不欲得饮之　　拍口强令咽
  一口入腹中　　肝肺肠胃烂
  如是之勤苦　　更历数万年
  罪毕乃得出　　生为贫贱人

复次长者子。又有五事。作畜生行堕畜生中。何谓为五。一者犯戒私窃偷盗。二者负债抵而不偿。三者杀生以身偿之。四者不喜听受经法。五者常以因缘艰难斋戒施会以俗为缘。是为五事生畜生中。于是世尊。以偈颂曰

  常私窃盗人物　　负钱财抵不偿
  喜杀生猎鱼网　　作俗缘不法会
  无诚信不知道　　去来事今现在
  作众罪不自觉　　稍稍积堕畜生
  牛马象驴骆驼　　猪羊犬不可数
  常负重死剥皮　　如是苦甚叵当

复次长者子。又有五事。得为尊贵众人所敬。何谓为五。一者布施周惠普广。二者礼敬佛法三宝及诸长老。三者忍辱无有嗔恚。四者柔和谦下。五者博闻学诵经戒。是为五事得为尊贵众人所敬。尔时世尊。以偈颂曰

  布施常等心　　普济令众安
  色力寿无病　　亲厚皆蒙恩
  敬佛三宝者　　礼事诸尊长
  所生为尊贵　　常得一切礼
  忍辱无嗔恚　　生辄得端正
  众人见欢喜　　视之无厌足
  心调能柔和　　谦让而敬顺
  学问诵习经　　乃为人中尊

复次长者子。又有五事。常生卑贱为人奴婢。何谓为五。一者憍慢不敬二亲。二者刚强无恭恪心。三者放逸不礼三尊。四者盗窃以为生业。五者负债逃避不偿。是为五事。常生卑贱奴婢之中。尔时世尊。以偈颂曰

  若有愚騃人　　憍慢于二亲
  无有恭恪心　　后生辄卑贱
  三宝不礼事　　刚强于尊老
  无慈孝于人　　生辄为奴婢
  放心恣其意　　盗窃人财物
  负债不欲偿　　后生奴婢中
  衣食仰于人　　走使不自在
  功力偿其主　　罪毕乃得出

复次长者子。又有五事。得生人中口气香洁身心常安。为人所誉不被诽谤。何谓为五。一者至诚不欺于人。二者诵经无有彼此。三者护口不谤圣道。四者教人远恶就善。五者不求人之长短。是为五事。生于人中口气香洁身意常安。为人所誉不被诽谤。尔时世尊。以偈颂曰

  恭敬于三宝　　不憍慢二亲
  至诚不欺诳　　是行人所敬
  护口不诽谤　　等心于一切
  劝人远罪行　　诵习念正法
  世人不憍慢　　相敬如父母
  遏恶而扬善　　如是得佛疾

复次长者子。又有五事。若在人中常被诽谤。为人所憎形体丑恶。心意不安常怀恐怖。何谓为五。一者常无至诚欺诈于人。二者大会有说法处而诽谤之。三者见诸同学而轻试之。四者不见他事而为作过。五者两舌斗乱彼此。是为五事。若在人中常被诽谤。为人所憎形体丑恶。心意不宁常怀恐怖。尔时世尊。以偈颂曰

  欺诈迷惑众　　常无有至诚
  心口而作行　　令身受罪重
  若生地狱中　　铁钩钩舌出
  洋铜灌其口　　昼夜不懈休
  若当生为人　　口气常腥臭
  人见便不喜　　无有和悦欢
  常遇县官事　　为人所讥论
  遭逢众厄难　　心意初不安
  死还入地狱　　出则为畜生
  展转五道中　　不脱众苦难

复次长者子。又有五事。所生之处常与佛法众会初不差违。见佛闻法便得好心。若作沙门即得所愿。何谓为五。一者身奉三宝劝人令事。二者作佛形像当使鲜洁。三者常奉师教不犯所受。四者普慈一切与身正等如爱赤子。五者所受经法昼夜讽诵。是为五事。所生之处常与佛法众会初不差违。见佛闻法便得好心。若作沙门即得所愿。尔时世尊。以偈颂曰

  奉敬三尊宝　　教化劝令事
  作佛形像好　　奉诸尊师教
  当视一切人　　与身等无异
  彼我悉平等　　行是会佛前
  昼夜常学问　　智慧是大宝
  开悟诸盲冥　　普使知道真

于是长者子辩意。闻佛说五十事要法之义。欣然欢喜逮得法忍。五百长者子皆得法眼净。又诸会者各得其志。于是辩意即从座起。为佛作礼长跪叉手白佛言。善哉世尊。快说此法。乃令会者得闻其所。复使将来济度厄难。唯愿世尊过于贫聚及诸众会。明日日中屈于舍食。尔时世尊默然而许。诸长者子为佛作礼欢喜而去。辩意到舍白父母言。今所请者人中难有。名曰如来无上法师。三界无比。便告其妻令设饭食即寻具馔。明日世尊与诸大众。往到其家就坐俨然。时辩意长者子父母眷属。前礼佛足各自供侍。辩意起行澡水敬意奉食。下食未讫有一乞儿前历座乞。佛未咒愿无敢与者。遍无所得嗔恚而出便生恶念。此诸沙门放逸愚惑有何道哉贫者从乞无心见与。长者迷惑用为饭此无慈愍意。吾为王者以铁辋车轹断其头。言已便去。佛达嚫讫。有一乞儿来入乞丐。座中众人各各与之。大得饭食欢喜而去。即生念言。此诸沙门皆有慈心。怜吾贫寒施食充饱得济数日。善哉长者乃能供事此等大士。其福无量。吾为王者当供养佛及众弟子。乃至七日之中。当报今日饥渴之恩。言已便去。佛食已讫说法。即还精舍之中。佛告阿难。从今以后嚫讫下食以此为常

时二乞儿展转乞丐。到他国中卧于道边深草之中。时彼国王忽然崩亡无有系嗣。时国相师明知相法。谶书记曰。当有贱人应为王者。诸臣百官千乘万骑案行国界。谁应为王。顾见道边深草之中。上有云盖。相师指曰。中有神人。即见乞儿。相应为王。诸臣拜谒各称曰臣。乞儿惊愕自云。下贱非是王种。皆言应相非是强力。沐浴香汤。着王者之服。光相俨然称善无量。导从前后回车入国。时恶念者在于深草中。卧寐不觉。车轹断其头。王到国中。阴阳和调四气隆赫。人民安乐称王之德。尔时国王自念昔者贫穷之人。以何因缘得为国王。昔行乞时得蒙佛恩。大得饭食便生善念。得为王者供养七日。佛之恩德今已果之。即召群臣遥向舍卫国。烧香作礼。即遣使者。往请佛言。蒙世尊遗恩得为人王。愿屈尊神来化此国愚冥之人得见教训。于是佛告诸弟子。当受彼请。佛与弟子无央数众往到彼国。时王出迎。与诸群臣稽首佛足。烧香散华伎乐供养。佛入宫中即以就座。王起行水供设饭食。须臾以讫。尔时国王为佛作礼前白佛言。我本是小人。有何福行得享斯位。愿佛解说。令此国人得蒙开眼

佛告王曰。往日舍卫城中有长者子。名曰辩意。施设大檀请佛及僧。时佛坐定下食未嚫。有一乞儿来入欲乞。一无所得。嗔恚而出。恶念生曰。若吾为王以铁辋车轹断僧头。一人后来乞丐大得饭食出。即念言。若我为王。供养此等众圣之僧七日之中。时善念者今王是也。时恶念者卧深草中。王受正位回车入国。车骑侍从轹断其头。死入地狱为火车所轹。亿劫乃出。王今请佛报誓过厚。世世受福无有极已。尔时世尊。以偈颂曰

  人心是毒根　　口为祸之门
  心念而口言　　身受其罪殃
  不念善恶人　　自作身受患
  意欲害于彼　　不觉车轹头
  心为甘露法　　令人生天上
  心念而口言　　身受其福德
  有念善恶人　　自作安身本
  意念一切善　　如王得天位

是时国王闻经欢喜。举国臣民得须陀洹道。供养佛七日之后。佛于是欲去。王及臣民为佛作礼而别。于是世尊还到舍卫祇树精舍。贤者阿难政衣服。从坐起为佛作礼长跪白佛言。当以何名此经。云何奉行。佛告阿难。是经名为辩意长者子所问。当奉持之。一名诸法要义。佛复告阿难。若有善男子善女人。有行斯经奉持讽诵宣传后世。令人受持者。是人如侍我身福无有异。诵斯经者当为弥勒佛所授决。如来广长舌所语无有异。佛说经已。时诸天龙鬼神四辈弟子。闻经欢喜。为佛作礼辩意长者子经


不必定入定入印经

    No. 645 [No. 646]

    不必定入定入印经翻译之记

出世智道。亦名为印。此经印义。或然不然。私情有指。未许官用。何者私情。今且当向发心修行。证会名入。所乘强劣。有定不定。圣说定入。说不定入。言义如是。决定名印。说如是故。名如是经。其门要密。通必有寄。魏尚书令仪同高公。深知佛法。出自中天。翻为此典。万未有一。采挟集人。在第更译。沙门昙林。瞿昙流支。兴和四年岁次降娄。月建在戌。朔次甲子。壬午之日。出此如左九千一百九十三字

不必定入定入印经

        元魏婆罗门瞿昙般若流支译

如是我闻。一时婆伽婆。住王舍城耆阇崛山中。与大比丘众一千二百五十人俱。六十亿百千那由他菩萨。其名曰文殊师利童子。观世自在菩萨摩诃萨。得大势菩萨。药王菩萨。药上菩萨。常雷音王菩萨。如是等上首六十亿百千那由他菩萨。一切皆得寂静论义神通三昧。游首楞严勇伏三昧。得深海水潮不过限三昧。得受位陀罗尼。得集无边诸佛身色究竟陀罗尼。尔时文殊师利童子白佛言。世尊。惟愿世尊。为诸菩萨说必定不必定入智印法门。以彼印故令我得知此菩萨必定此菩萨不必定。此不定阿耨多罗三藐三菩提退无上智道。佛言。文殊师利。此中则有五种菩萨。何等为五。一者羊乘行。二者象乘行。三者月日神通乘行。四者声闻神通乘行。五者如来神通乘行。文殊师利。如是名为五种菩萨。文殊师利。初二菩萨。不必定阿耨多罗三藐三菩提退无上智道。后三菩萨。必定阿耨多罗三藐三菩提不退无上智道。文殊师利言。世尊。何者二菩萨不必定阿耨多罗三藐三菩提退无上智道。世尊。何者三菩萨必定阿耨多罗三藐三菩提不退无上智道。佛言。文殊师利。羊乘行菩萨。象乘行菩萨。此二菩萨不必定阿耨多罗三藐三菩提退无上智道。文殊师利。月日神通乘行菩萨。声闻神通乘行菩萨。如来神通乘行菩萨。此三菩萨必定阿耨多罗三藐三菩提不退无上智道。文殊师利。应云何知羊乘行菩萨。文殊师利。譬如有人他方五百佛之世界微尘等数世界之外。彼有因缘有大因缘。彼有所作有大所作。彼有所重有大所重。为彼事故欲过如是微尘世界到于彼处。如是思惟。我乘何乘而能得过如是世界得到彼处。如是之人即便思惟。若我今者乘于羊乘。则应得过如是世界到于彼处。文殊师利。如是之人既思惟已。即乘羊乘发行彼道。经长久时到百由旬。大风轮起吹令回还八十由旬。文殊师利。于意云何。如是之人乘彼羊乘。于彼世界能过到不。若经一劫若一百劫。若一千劫亿百千劫。若不可说不可说劫。彼人能过一世界不。文殊师利答言。世尊。彼若能过一世界者。无有是处。如是之人乘彼羊乘。若经一劫若一百劫。若一千劫亿百千劫。若不可说不可说劫。若能得过一世界者。无有是处。佛言。如是文殊师利。若善男子若善女人发阿耨多罗三藐三菩提心已。声闻乘人相随止住。近声闻人习声闻人。恭敬供养声闻乘人。共为知识财物交通与共同住。若在林中若在寺舍。若经行处同一处行。读声闻乘。诵声闻乘。思声闻乘。信声闻乘。复教他人读诵思信。如是之人住声闻乘。摄声闻乘种善根行。声闻所牵故得钝智退无上智道。如是菩萨修菩提心慧根慧眼。而复后时住声闻智种善根行。则还愚钝破坏不成。文殊师利。譬如有人若患眼病。若有目瞑。如是之人为开眼故。一月疗治勤不休息。过一月已眼得少开。彼有怨恶常伺其便。把碎荜茇着其眼中。令彼人眼转闇更闭不得开明。如是如是。文殊师利。若彼菩萨修菩萨心慧根慧眼。而复后时住声闻智种善根行。则还愚钝破坏不成。文殊师利。此羊乘行菩萨应知。文殊师利。应云何知象乘行菩萨。文殊师利。譬如有人如是微尘世界之外。彼有因缘有大因缘。彼有所作有大所作。彼有所重有大所重。为彼事故欲过如是微尘世界到于彼处。如是思惟。我乘何乘而能得过如是世界到于彼处。如是之人即便思惟。若我今者八分相应乘象乘者。则应得过如是世界到于彼处。文殊师利。如是之人既思惟已。即乘八分相应象乘发行彼道。百年常行二千由旬。大风轮起吹令回还一千由旬。文殊师利。于意云何。如是之人乘彼象乘。于一世界为能过不。若经一劫若一百劫。若一千劫亿百千劫。若不可说不可说劫。彼人能过一世界不。文殊师利答言。世尊。彼若能过一世界者。无有是处。如是之人乘彼象乘。若经一劫若一百劫。若一千劫亿百千劫。若不可说不可说劫。若能得过一世界者。无有是处。佛言。如是。文殊师利。若善男子若善女人发阿耨多罗三藐三菩提心已。声闻乘人相随止住。近声闻人习声闻人。共为知识与共同住。若在林中若在寺舍。若经行处同一处行。读声闻乘。诵声闻乘。思声闻乘。信声闻乘。复教他人读诵思信。如是之人住声闻智。摄声闻乘种善根行。声闻所牵故得钝智退无上智道。如是菩萨修菩提心。种善根行安住大乘。而复后时住声闻智种善根行。则还愚钝破坏不成。文殊师利。譬如大木广千由旬大海所漂。于大海中济渡众生。空行夜叉出置陆地。系缚在于五百由旬大铁块上。文殊师利。于意云何。如是大木彼大海水复能漂不。复能海中济众生不。文殊师利。答言不能。佛言。如是。文殊师利。若彼菩萨修菩提心种善根行。修行一切智智海道。牵回令退。则不能向一切智智大海之道。不能救拔生死大海一切众生。文殊师利。此象乘行菩萨应知。文殊师利。应云何知月日神通乘行菩萨。文殊师利。譬如有人如是微尘世界之外。彼有因缘有大因缘。彼有所作有大所作。彼有所重有大所重。为彼事故欲过如是微尘世界到于彼处。如是思惟。我乘何乘而能得过如是世界到于彼处。如是之人即便思惟。若我今者乘于月日神通乘者。则应得过如是世界到于彼处。文殊师利。如是之人既思惟已。即乘月日神通之乘发行彼道。文殊师利。于意云何。如是之人乘于月日神通之乘。于彼世界能过到不。文殊师利答言。世尊。久时则能。佛言。如是。文殊师利。若善男子若善女人发阿耨多罗三藐三菩提心已。不与一切声闻乘人相随止住。不近一切声闻乘人。不习一切声闻乘人。不作知识。财物不交。不共同住。若在林中若在寺舍。若经行处不同处行。亦不读诵声闻乘法。不思不信声闻乘法。不教他人读诵信学。乃至一偈亦不学习。不读不诵。彼人若读则读大乘。彼人若诵则诵大乘。若有所说则说大乘乃至一偈。文殊师利。此是月日神通乘行菩萨应知。文殊师利。譬如有大迦楼罗王大力少壮随意所念须弥山顶能到异处。如是如是。文殊师利。月日神通乘行菩萨。戒闻深心大力少壮。勇健能得随心所念。佛佛世界皆能过到。于诸如来众会轮中皆能示身。文殊师利。应云何知声闻神通乘行菩萨。文殊师利。譬如有人如是微尘世界之外。彼有因缘有大因缘。彼有所作有大所作。彼有所重有大所重。为彼事故欲过如是微尘世界到于彼处。如是思惟。乘何神通而能得过如是世界到于彼处。如是之人即便思惟。我今若乘声闻神通。则应得过如是世界到于彼处。文殊师利。如是之人既思惟已。即尔便乘声闻神通发行彼道。文殊师利。于意云何。如是之人声闻神通于彼世界能过到不。文殊师利。答言能过。佛言。如是。文殊师利。若善男子若善女人发阿耨多罗三藐三菩提心已。不与一切声闻乘人相随止住。不近一切声闻乘人。不习一切声闻乘人。不作知识财物不交。不同修行。不共语说。不共同住。若在林中若在寺舍。若经行处不同处行。不读不诵声闻乘法。不思不信声闻乘法。不教他读不教他诵乃至一偈。于声闻乘不相应诵。亦不教他。彼人若读则读大乘。彼人若诵则诵大乘。亦教他人读诵大乘。若有所说则说大乘。彼于信解大乘菩萨摩诃萨等读大乘人诵大乘人摄大乘人。敬重正信随顺修学。与共相应随逐不舍。依附亲近如法供养。共为知识与共同住。若在林中若在寺舍。若经行处与共同行。于大乘人摄大乘人受大乘人持大乘人。第一敬重最胜供养。所谓灯明种种华香末香涂香妙鬘涂身。如是供养。如是之人读诵大乘。第一喜心为他人说。心不轻蔑未学菩萨。正面言语先意问讯。不作恶语不粗犷语。常说爱语说美妙语。如是之人乃至失命身死因缘不舍大乘。常摄一切行大乘人学大乘人读大乘人诵大乘人摄大乘人。如力摄取。如法摄取。如心所堪。彼人如是。无人憎恶无与诤对。常求一切未曾闻经。心常敬重所从闻者。心不轻蔑未学菩萨。于他人过若实不实不说不抂。不求他便。常勤修学慈悲喜舍。文殊师利。此是声闻神通乘行菩萨应知。文殊师利。应云何知如来神通乘行菩萨。文殊师利。譬如有人如是微尘世界之外。彼有因缘有大因缘。彼有所作有大所作。彼有所重有大所重。为彼事故欲过如是微尘世界到于彼处。如是思惟。乘何神通而能得过如是世界到于彼处。如是之人即便思惟。我今若乘如来神通。则应得过如是世界到于彼处。文殊师利。如是之人既思惟已。即尔便乘如来神通发行彼道。文殊师利。于意云何。如是之人。如来神通于彼世界能速过不。文殊师利。答言能过。佛言。如是。文殊师利。若善男子若善女人发阿耨多罗三藐三菩提心已。不与一切声闻乘人相随止住。不近一切声闻乘人。不习一切声闻乘人。不作知识财物不交。不同修行不共语说。不共同住。若在林中若在寺舍。若经行处不同处行。不读不诵声闻乘法。不思不信声闻乘法。不教他读不教他诵乃至一偈。于声闻乘不相应读不相应诵。亦不教他。彼人若读则读大乘。彼人若诵则诵大乘。亦教他人读诵大乘。若有所说则说大乘。如是之人身口意净善持戒法。亦令他人身口意净令住善法。彼于修行大乘菩萨摩诃萨等读大乘人诵大乘人摄大乘人。敬重正意随顺修学。与共相应随逐不舍。依附亲近如法供养。共为知识与共同住。若在林中若在寺舍。若经行处与共同行。于大乘人摄大乘人受大乘人持大乘人。第一敬重最胜供养。所谓灯明种种华香末香涂香妙鬘涂身。如是供养。如是之人读诵大乘。第一喜心教他人读教他人诵。心不轻蔑未学菩萨。于余菩萨安住令学。常说爱语说美妙语。如是之人乃至失命身死因缘不舍大乘。常摄一切行大乘人学大乘人。读大乘人诵大乘人摄大乘人。第一敬重。心生大喜设大供养。亦令他人如是修学有大深心。彼人如是。无人憎恶不与诤对。常求一切未曾闻经。第一深心殷重心求。心常敬重所从闻者。于彼人所生于师心。亦令他人如是修学。心不轻蔑未学菩萨。于他人过若实不实不说不抂。不求他便。亦教他人如是修学。文殊师利。如是菩萨恒自观察失菩提心诸众生界。亦常教他如是观察失菩提心诸众生界。如是菩萨恒自观察失菩萨行诸众生界。亦常教他如是观察失菩萨行诸众生界。如是菩萨恒自观察失菩提业诸众生界。亦常教他如是观察失菩提业诸众生界。如是菩萨恒自观察失菩萨道诸众生界。亦常教他如是观察失菩萨道诸众生界。如是菩萨恒自观察失于一切菩萨威仪诸众生界。亦常教他如是观察失于一切菩萨威仪诸众生界。如是菩萨恒自观察失菩萨取诸众生界。亦常教他如是观察失菩萨取诸众生界。如是菩萨恒自观察失于一切菩萨方便诸众生界。亦常教他如是观察失于一切菩萨方便诸众生界。如是菩萨恒自观察失菩萨意诸众生界。亦常教他如是观察失菩萨意诸众生界。如是菩萨恒自观察失于菩萨有为行力诸众生界。亦常教他如是观察失于菩萨有为行力诸众生界。如是菩萨恒自观察失于如法住菩萨行诸众生界。亦常教他如是观察失于如法住菩萨行诸众生界。如是菩萨恒自观察失于菩萨慈悲喜舍诸众生界。亦常教他如是观察失于菩萨慈悲喜舍诸众生界。如是菩萨恒自布施亦教他施。如是菩萨自不抂他。亦教他人令不抂他。如是菩萨恒自观察失于佛法诸众生界。亦常教他如是观察失于佛法诸众生界。如是菩萨。恒自观察离善法欲诸众生界。亦常教他如是观察离善法欲诸众生界。如是菩萨恒自观察缚众生界。亦常教他如是观察缚众生界。如是菩萨恒自观察长久远时病众生界。亦常教他如是观察长久远时病众生界。如是菩萨恒自观察失正法行诸众生界。亦常教他如是观察失正法行诸众生界。如是菩萨恒自观察失于具足福德智等诸众生界。亦常教他如是观察失于具足福德智等诸众生界。如是菩萨恒自观察失于如来善根种子诸众生界。亦常教他如是观察失于如来善根种子诸众生界。如是菩萨恒自观察一切孤独诸众生界。亦常教他如是观察一切孤独诸众生界。如是菩萨恒自观察一切久睡诸众生界。亦常教他如是观察一切久睡诸众生界。如是菩萨恒自观察下劣种姓诸众生界。亦常教他如是观察下劣种姓诸众生界。如是菩萨恒自观察失大乘信诸众生界。亦常教他如是观察失大乘信诸众生界。如是菩萨恒自观察失于持戒诸众生界。亦常教他如是观察失于持戒诸众生界。如是菩萨恒自观察失顺入法诸众生界。亦常教他如是观察失顺入法诸众生界。如是菩萨恒自观察失忍乐行诸众生界。亦常教他如是观察失忍乐行诸众生界。如是菩萨恒自观察失奢摩他毗婆舍那诸众生界。亦常教他如是观察失奢摩他毗婆舍那诸众生界。如是菩萨恒自观察失施调御持戒乐行诸众生界。亦常教他如是观察失施调御持戒乐行诸众生界。如是菩萨恒自观察失念意行知足惭愧诸众生界。亦常教他如是观察失念意行知足惭愧诸众生界。如是菩萨恒自观察失次第入波罗蜜道诸众生界。亦常教他如是观察失次第入波罗蜜道诸众生界。如是菩萨恒自观察失佛善根诸众生界。亦常教他如是观察失佛善根诸众生界。如是菩萨恒自观察失善知识诸众生界。亦常教他如是观察失善知识诸众生界。如是菩萨恒自观察失于利益一切众生诸众生界。亦常教他如是观察失于利益一切众生诸众生界。如是菩萨恒自观察失法随顺诸众生界。亦常教他如是观察失法随顺诸众生界。如是菩萨恒自观察失智随顺诸众生界。亦常教他如是观察失智随顺诸众生界。如是菩萨恒自观察失义随顺诸众生界。亦常教他如是观察失义随顺诸众生界。如是菩萨恒自观察失于了义修多罗义诸众生界。亦常教他如是观察失于了义修多罗义诸众生界。如是菩萨恒自观察失四正勤诸众生界。亦常教他如是观察失四正勤诸众生界。如是菩萨恒自观察失实法律语说善行诸众生界。亦常教他如是观察失实法律语说善行诸众生界。如是菩萨恒自观察贫众生界。亦常教他如是观察贫众生界。如是菩萨恒自观察一切世界慈心普遍。亦常教他如是观察一切世界慈心普遍。有如是心。彼诸众生无主无归。彼诸众生一切焰然。彼诸众生一切无舍。彼诸众生一切无救。彼诸众生一切无明。我于何时能为作主。与作归依。与作舍宅。与作救护。与作灯明。文殊师利。譬如有大迦楼罗王少壮多力随心忆念何所悕望。则能飞上须弥山顶。尔乃下入大海之中。取龙妇女举在虚空。如是如是。文殊师利。如来神通乘行菩萨。有大福德善根势力。速疾奋迅随何等处。如来众会随心欲往则能疾到。一切恶道恶业众生所生之处。皆悉能到。能与作主作归依处令离诸恶。与作舍宅。与作救护。与作灯明。文殊师利。此是如来神通乘行菩萨应知。文殊师利。若善男子若善女人以天妙衣天百味食。于日日中施与十方一切世界微尘等数诸佛如来。一一如来日日如是。复持珠宝满于恒河沙等世界。以用布施。如是乃至恒河沙劫常如是施所有福德。文殊师利。若复更有若善男子若善女人。教一众生令其得住须陀洹果。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉令得住须陀洹果所有福德。文殊师利。若复更有若善男子若善女人。教一众生令其得住斯陀含果。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉令得住斯陀含果所有福德。文殊师利。若复更有若善男子若善女人。教一众生令其得住阿那含果。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉令得住阿那含果所有福德。文殊师利。若复更有若善男子若善女人。教一众生令其得住阿罗汉果。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉令得住阿罗汉果所有福德。文殊师利。若复更有若善男子若善女人。教一众生令其得住辟支佛道。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉令得住辟支佛道所有福德。文殊师利。若复更有若善男子若善女人。令一众生住羊乘行菩提之心。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。住羊乘行菩提之心所有福德。文殊师利。若复更有若善男子若善女人。令一众生住象乘行菩提之心。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。住象乘行菩提之心所有福德。文殊师利。若复更有若善男子若善女人。令一众生住于月日神通乘行菩提之心。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能令十方一切世界微尘等数一切众生。悉住月日神通乘行菩提之心。所有福德。文殊师利。若复更有若善男子若善女人。令一众生住于声闻神通乘行菩提之心。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界微尘等数一切众生。悉住声闻神通乘行菩提之心所有福德。文殊师利。若复更有若善男子若善女人。令一众生得住如来神通乘行菩提之心。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数一切众生。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一优婆塞信入三归受持五戒于佛法中清净心者。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数诸优婆塞信入三归受持五戒于佛法中信清净者。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与八辈僧中最初一人。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数八辈僧中初第一人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一须陀洹。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数须陀洹人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一斯陀含。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数斯陀含人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一阿那含。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数阿那含人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一阿罗汉。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数阿罗汉人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一辟支佛。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中。施与十方一切世界微尘等数辟支佛人。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一羊乘行菩萨众生。此福胜彼过阿僧祇。何以故。文殊师利。菩萨何时何所攀缘发菩提心。彼心生时乃至无有一不善业而不舍离。无一佛法而不生者。文殊师利。菩萨如是不可思议功德成就。文殊师利。譬如世间迦罗频迦可喜鸟王在卵藏中[穀-禾+卵]未开时深响美音已胜一切群众诸鸟。如是如是。文殊师利。菩萨初发菩提心者。在无明[穀-禾+卵]。虽业烦恼闇翳障碍蔽覆其眼。而胜一切声闻缘觉。已能摄取善根愿行妙音声说。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数诸羊乘行菩萨众生。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施与一象乘行菩萨众生。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数诸象乘行菩萨众生。如是乃至恒河沙劫。常如是施所有福德。文殊师利若复更有若善男子若善女人。惟以一食于一日中。一时施一月日神通乘行菩萨。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数月日神通乘行菩萨。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施一声闻神通乘行菩萨。此福德胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数声闻神通乘行菩萨。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。惟以一食于一日中。一时施一如来神通乘行菩萨。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数如来神通乘行菩萨。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人。闻此法门。闻已生信。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能作十方一切世界微尘等寺。一一寺中皆悉安置百万三千大千世界微尘等数诸辟支佛令住其中。以天阎浮那陀金宝电摩尼珠及真珠宝。作璎珞形庄严房舍。竖立宝幢悬缯幡盖。以自在王珠宝网帘周遍悬铃。龙坚栴檀处处涂治。曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。婆离师迦华。多罗尼华。葋多罗尼华。婆罗华。善香华。檀奴师迦离迦华。天须摩那华。优钵罗华。钵头摩华。拘物头华。分陀离迦华。散如是等种种妙华。于日日中以天妙衣天百味食与辟支佛。如是乃至恒河沙劫。于一切时如是供养所有福德。文殊师利。若复更有若善男子若善女人。若闻佛名一切智名。若如来名世间主名。若自称说。或见画像或见乃至土木等像。此福胜彼过阿僧祇。何况复有合十爪掌。此福尚多过阿僧祇。何况复有若与灯明华香涂香。乃至口说一切德者。所有福德转胜转多。于是次第受大富乐。乃至终得到一切智。文殊师利。譬如一渧极微细水堕大海中不尽不减。乃至劫尽大火烧时。如是如是。文殊师利。若种极少如来善根不尽不减。乃至一切智智火生。文殊师利。譬如月轮胜一切星。第一端严有多光明其体圆满。所谓高广增上宽大。如是如是。文殊师利。极细微少如来善根。诸余一切善根中胜。有多光明其体圆满。所谓高广增上宽大。文殊师利。如是如来正遍知不可思议功德成就。文殊师利。若善男子若善女人。能以天衣天百味食。于日日中施与十方一切世界微尘等数一切诸佛一切菩萨一切声闻。如是乃至恒河沙劫。常如是施所有福德。文殊师利。若复更有若善男子若善女人闻此法门。闻已生信。此福胜彼过阿僧祇。何况复有若自书写令他书写。此福转胜过阿僧祇。以此福德证佛智因。是故为胜。文殊师利。若有男子若有女人。若夺若偷无量无数声闻缘觉若衣若食所有罪聚。文殊师利。若复更有若是男子若是女人。以嗔恶心若夺若偷信大乘人若一小食若一中食。此罪多彼过阿僧祇。何以故。文殊师利。一切过去未来现在声闻缘觉。于无量亿阿僧祇劫。修行布施持戒忍辱精进禅慧。皆为自断己身烦恼。菩萨不尔。乃至微少舍一揣食施于畜生。皆为不断三宝种子。文殊师利。若有男子若有女人。嗔心破坏无量无数声闻缘觉所有戒聚定聚慧聚及解脱聚。破其解脱知见之聚。如是破坏乃经劫数所有罪聚。文殊师利。若复更有若是男子若是女人。以嗔恶心破信大乘一菩萨戒。若令他破乃至一戒。此罪多彼过阿僧祇。何以故。文殊师利。所有一切声闻缘觉布施持戒忍辱精进禅慧解脱解脱知见。如是等聚。皆为自断己身烦恼。菩萨不尔。乃至一日乃至一戒所有福聚。皆为断除一切众生堕恶道因一切恶业。乃至为证一切智智。文殊师利。若有男子若有女人。系缚十方一切世界一切众生在牢狱中所有罪聚。文殊师利。若复更有若是男子若是女人。于菩萨所起嗔恶心。不用眼看捩身回面。此罪多彼过阿僧祇。文殊师利。若有男子若有女人。拔出十方一切世界一切众生所有眼目所有罪聚。文殊师利。若复更有若是男子若是女人。以嗔恶心不看菩萨信大乘者。此罪多彼过阿僧祇。文殊师利。若有十方一切世界一切众生劫数眼闇。文殊师利。若善男子若善女人。慈心怜彼一切众生令其得眼。乃经劫数所有福德。文殊师利。若复更有若善男子若善女人。以清净心看于菩萨信大乘者。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能使十方一切世界一切众生开狱系缚。令得出已复令得作转轮圣王王国安乐。复令得住帝释王乐所有福德。文殊师利。若复更有若善男子若善女人。以清净心欲见菩萨信大乘者。以清净心赞彼菩萨。此福胜彼过阿僧祇。文殊师利。若善男子若善女人。能安十方一切世界一切众生住缘觉道所有福德。文殊师利。若复更有若善男子若善女人。令一菩萨信大乘者增长佛种至一善根。此福胜彼过阿僧祇。文殊师利。若有菩萨信大乘者。能安十方一切世界一切众生住菩提心所有福德。文殊师利。若复更有其余菩萨信大乘者不求资生。乃至诵一无余伽他。此福胜彼过阿僧祇。文殊师利。若有男子若有女人。能令十方一切世界微尘等数缘觉之人劫数堕于地狱畜生所有罪聚。文殊师利。若复更有若是男子若是女人。断一菩萨发菩提心。菩提心断。此罪多彼过阿僧祇。文殊师利。若有男子若有女人。能断十方一切世界微尘等数一切众生发菩提心。菩提心断所有罪聚。文殊师利。若复更有若是男子若是女人。断一众生信于大乘不作菩萨。大乘行断。此罪多彼过阿僧祇。文殊师利。若有十方一切世界一切众生生于地狱畜生饿鬼阎魔罗处。文殊师利。若有菩萨能令如是一切众生出于地狱畜生饿鬼阎魔罗处住菩提心所有福德。文殊师利。若复更有其余菩萨令一众生信于大乘入于大乘。此福胜彼过阿僧祇。文殊师利。若有男子若有女人。能令十方一切世界微尘等数缘觉退还所有罪聚。文殊师利。若复更有若是男子若是女人。令信大乘一菩萨退。此罪多彼过阿僧祇。文殊师利。若有男子若有女人。若于十方一切世界微尘等数诸辟支佛供养财利生嫉妒心。断其供养财利因缘。四方四维恶说毁呰彼辟支佛而不赞说所有罪聚。文殊师利。若复更有若是男子若是女人。于一菩萨信大乘者供养财利生嫉妒心。断其供养财利因缘而不赞说。此罪多彼过阿僧祇。文殊师利。若善男子若善女人为摄正法。乃至微少一小瓶水。净心施与信大乘者。至一菩萨所得善根业因果报。得阿僧祇转轮圣王国土富乐。何况施与精勤读诵大乘经典菩萨之人。此福胜彼过阿僧祇。尔时世尊说此经已。文殊师利法王之子。彼诸菩萨。诸大声闻。诸天及人并阿修罗乾闼婆等。闻世尊说欢喜奉行不必定入定入印经


不思议光菩萨所说经

    No. 484

不思议光菩萨所说经一卷

        后秦龟兹国三藏鸠摩罗什译

如是我闻。一时佛在舍卫国只陀林中给孤穷精舍。与大比丘僧千二百五十人俱。菩萨摩诃萨五百人。众所知识。尔时世尊。依舍卫大城。时王大臣婆罗门居士。及诸眷属。供养恭敬尊重赞叹。多诸供养衣服饮食卧具医药。是如来应供正遍觉明行足善逝世间解无上士调御丈夫天人师佛世尊。生处成就。种性成就。三昧具足。智慧具足。解脱具足。解脱知见具足。具足十力四无所畏佛十八不共法。演说正法初中后善文义美妙。具足清白梵行鲜净五眼具足。所谓肉眼天眼慧眼佛眼法眼。善知此世他世所住

于时世尊。善降外道尼乾陀若提子等。佛法炽盛人天宗敬。世尊时到着衣持钵。及比丘僧眷属围绕。趣入舍卫大城乞食。去来进止威仪庠序。视瞻容豫屈伸俯仰。执持衣钵皆悉庠序。金色妙身光明照曜。犹猛火聚宝珠日月照曜闇夜。三十二相庄严其身。以金色足蹈门阃上。当于是时舍卫大城。示现种种未曾有事。如偈所说

  人仙来入时　　释师子蹈阃
  现多希有事　　净心听我说
  盲者得目视　　聋者得闻听
  裸者得衣服　　狂乱得正意
  皆欢喜合掌　　观佛无厌足
  众鼓自然鸣　　箫笛自出声
  雁鸲鸠鸳鸯　　俱出妙软音
  失财得宝藏　　众宝物出声
  时地六种动　　不信得净心
  胜觉下转足　　净莲花承接
  触众生安乐　　命终得生天
  女人妊娠苦　　安乐生妙子
  无贪嗔痴恼　　父母子俱尔
  阶陛妙庄严　　多亿天雨花
  众生无病患　　脱一切众苦
  善逝入城时　　一切受安乐
  各谓我奉食　　各谓佛看我
  人仙福德力　　非我说能尽

尔时世尊。于舍卫大城。次第乞食至于中路。有一空处捐弃婴儿。容貌端严极为鲜白自[口*束]右指。而此空处多狐狼狗。见是婴儿舐已而去无能逼恼。此婴儿者是福德人久种善根。多人住观生希有心。往来观看空处弃儿。端严可爱欢喜乐见于是婴儿。尔时世尊。见多人众往来空处。知而故问。告阿难言。汝可往彼看。是诸人往来空处。何所作为。阿难白言。如是世尊。大德阿难即往空处。见是婴儿容貌端严自嗽右指。谛视众人其目不瞬。阿难见已便还佛所如见而说。世尊。此空闲处有弃婴儿。容貌端严甚可敬爱犹如宝像。观视诸人其目不瞬。于时世尊。于彼婴儿起悲愍心。观本善根知已成熟。堪能知我所说法义。又知众生善根成熟。即往婴儿所。到已于一面住。向此婴儿。而说偈言

  本所造恶业　　今此报应现
  弃捐此空处　　婴儿苦如是

尔时婴儿。承佛神力。自本善力以偈报佛

  瞿昙犹故有　　见弃空处想
  尊在道场时　　不知是想耶

尔时世尊。复以偈答

  我已知于想　　而我永无想
  以怜愍汝故　　来至此空处

尔时婴儿。复说偈言

  若不得众生　　毕竟不可得
  尊怜愍于谁　　谁所转悲心

尔时世尊。复说偈言

  众生不知是　　无我空寂灭
  为觉悟彼故　　我行村城邑

尔时婴儿。复说偈言

  达解空寂灭　　觉了空寂灭
  犹有众生想　　如来不断耶

尔时世尊。复说偈言

  佛悲力如是　　觉了空寂已
  教化众生故　　导师演说法

尔时婴儿。复说偈言

  犹故有颠倒　　如来未断耶
  无众生生想　　如是生悲耶

尔时世尊。复说偈言

  佛之所护持　　菩萨生精进
  为不达众生　　人尊发庄严

尔时婴儿。复说偈言

  此是痴庄严　　若不得于物
  若法非是物　　何由起庄严

尔时世尊。复说偈言

  此大悲神力　　调御世如是
  犹不着于物　　为众生说法

尔时婴儿。复说偈言

  法无有文字　　云何可演说
  世间大败失　　非法作法说

尔时世尊。复说偈言

  我不败坏世　　我不非法说
  众生自倒惑　　我解脱彼结

尔时婴儿。复说偈言

  结使无根本　　亦无有方所
  又不在内外　　于何脱彼结

尔时世尊。复说偈言

  从于妄想生　　与颠倒共俱
  为断彼妄想　　婴儿我说法

尔时婴儿。复说偈言

  心性自常净　　彼中无垢结
  正使多妄想　　性净不生垢

尔时世尊。复说偈言

  如是如汝说　　心性自常净
  客烦恼尘结　　无慧者生染

尔时婴儿。复说偈言

  结无有方所　　亦非方所得
  云何名为生　　愿为我演说

尔时世尊。复说偈言

  犹如空中云　　可睹无真实
  结使生如是　　虽见无有实

尔时婴儿。复说偈言

  法同等如如　　其生性即如
  法若是真实　　非如不可得

尔时世尊。复说偈言

  一切非如法　　等住于如中
  觉了是如已　　无过无功德

尔时婴儿。复说偈言

  若不得众生　　瞿昙和合谁
  先观察法本　　从谁有烦恼

尔时世尊。复说偈言

  过去及未来　　及与现在世
  佛知觉了了　　为众生说法

尔时婴儿。复说偈言

  所演说三世　　及说我能知
  便为是大慢　　则为自称誉

尔时世尊。复说偈言

  我不自称誉　　亦不轻慢他
  如如等显现　　是故名如来

尔时婴儿。复说偈言

  如无有可得　　非言说相应
  非言以言说　　是则非是如

尔时世尊。复说偈言

  凡夫随于想　　如中生妄想
  为断除我想　　如来出于世

尔时婴儿。复说偈言

  正觉无出世　　善修无生故
  于无生法中　　佛出不相应

尔时世尊。复说偈言

  无生现有生　　佛出世显现
  此是世谛说　　非是第一义

尔时婴儿。复说偈言

  犹故有二想　　世谛第一义
  于一乘道中　　瞿昙相违说

尔时世尊。复说偈言

  我不道相违　　我住不相违
  为相违众生　　婴儿如是知

尔时婴儿。复说偈言

  悔过于正觉　　我上所言说
  是佛力持故　　我能如是说

尔时世尊。从于衣里出金色臂。起彼婴儿。尔时婴儿。执佛手指从地而起。尔时世尊从彼空处。将是婴儿趣向正陌。是时大众得未曾有。于世尊所倍生敬礼。叹言希有。如来世尊得成如是胜妙之法。乃能令此极苦厄者安住是法。尔时世尊告婴儿言。汝业行尽汝可忆念本造善根。令此大众生希有心。现大神力。尔时婴儿上升虚空。过七多罗树。身放光明。此光遍照三千大千佛之世界。以此光故。释梵护世。及余百千天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。见斯光已来诣佛所。到已顶礼佛足。以诸天华散供于佛。供养佛已向佛世尊。作如是言。菩萨光明不可思议。身出光明。普遍照此佛之世界。令诸无量众生得于不思议利。当名此儿不思议光

尔时释迦牟尼世尊。即可是名。此儿当名不思议光。尔时婴儿不思议光。从空而下住于地已。以佛神力自善根力。其形犹如八岁童子。尔时释提桓因。即以天衣施与婴儿。便语之言。婴儿汝今愍我等故。受此天衣。勿裸形住。尔时不思议光菩萨婴儿。语释提桓因。憍尸迦。菩萨不以衣服为妙。当被法服以为严饰。憍尸迦。菩萨所服汝今善听。憍尸迦。菩提之心是菩萨服乃至道场成满具足一切佛法有惭有愧是菩萨服。调伏成就一切众生置无过中。坚誓庄严是菩萨服。办诸事故。质直无伪是菩萨服。成就断除幻惑伪故。勤加精进是菩萨服。成满具足诸善根故。志欲喜乐是菩萨服。成满一切诸佛法故。除舍憍慢是菩萨服成满一切诸禅定故。欲法闻法是菩萨服。成满般若波罗蜜故。不起智慢是菩萨服。成满具足无著智故。作于利益是菩萨服。悲诸众生具觉知故。舍一切物是菩萨服。成满具足诸相好故。护持净戒是菩萨服。成满愿故。调和忍辱是菩萨服。究竟成满梵音声故。牢强精进无懈退心是菩萨服。成满出过一切事故。得诸禅定解脱三昧是菩萨服。成就满足大通智故。不坏智慧是菩萨服。成就断除一切结使诸见障故。大方便智是菩萨服。成就教化诸众生故。大慈是菩萨服。成就救济诸众生故。大悲是菩萨服。成就生死中无疲厌故。大喜是菩萨服。成就具足于法喜故。大舍是菩萨服。成就舍离爱嗔心故。于诸众生无恼害心是菩萨服。成就不恼于自他故。敷演说法是菩萨服。成就不自誉毁他人故。如说修行是菩萨服。成就断除诸结使故。憍尸迦。应如是知菩萨法服。以法庄严生不裸形。尔时释提桓因。于婴儿所增加恭敬爱念尊重。白言世尊。愍我等故。令是婴儿受取此衣。尔时世尊。告不思议光菩萨婴儿。受帝释衣。于时世尊。右手取衣授与婴儿。尔时婴儿。右膝着地。以其右手受取是衣。受已便着。尔时世尊。将不思议光菩萨婴儿。于舍卫大城次第乞食。是时大众。男女大小。长者居士。刹利婆罗门。王及辅臣。见不思议光菩萨婴儿。生希有心。亦为见佛礼敬供养悉皆来集。尔时世尊。次第乞食。到不思议光菩萨婴儿所生母舍。尔时不思议光菩萨即入其舍。前至母所。向所生母。而说偈言

  母无有过咎　　应当自喜庆
  是我本恶业　　今生在母腹
  母是我福田　　哀愍所生恩
  母勿生羞耻　　速往如来所
  母今得大利　　腹怀妊我故
  如是之功德　　往问于导师

尔时不思议光菩萨。语释提桓因。憍尸迦。与我香华衣服所须。欲奉上母。母当以是供养于佛。当发阿耨多罗三藐三菩提心。尔时释提桓因。以天曼陀罗华及以天香天诸衣服。与彼菩萨。尔时不思议光菩萨复向其母。而说偈言

  受此适意华　　天妙曼陀罗
  妙香及衣服　　奉上供释仙
  非饮食及宝　　能报父母恩
  引导向正法　　便为供二亲
  供二足尊已　　发净上道心
  我长夜常劝　　常数数时勤
  其母生喜心　　毕竟不生耻
  往诣人仙所　　礼已在前住
  华散如来上　　奉华及衣服
  佛所种善根　　即发菩提心
  坚住菩提心　　问于释师子
  怀妊净众生　　愿说是福报
  汝以此善业　　不生诸难趣
  供多亿佛已　　当得成为佛

尔时世尊。于舍卫大城。次第乞食已。与不思议光菩萨及诸大众。出王舍大城。向只陀林给孤穷精舍。世尊食已净自澡嗽。而起就座演说正法。尔时憍萨罗国波斯匿王。闻不思议光菩萨婴儿。有大不可思议神通。闻已庄严四种兵众。向只陀林给孤穷精舍。诣世尊所。到已顶礼佛足。却坐一面。波斯匿王白世尊言。大德世尊。不思议光菩萨婴儿。为在何处。闻有如是不可思议神通之力。时佛即示波斯匿王不思议光菩萨婴儿。时王见是不思议光菩萨婴儿。形色端严殊特于天无所畏惧。具戒定慧以自庄严。如是见已便作是念。种何善根修集何福有是妙身。尔时不思议光婴儿。承佛神力。知憍萨罗国王心之所念。向是大王。而说偈言

  常修慈心净众生　　无粗秽恶修正念
  摄身口意净梵行　　彼有如是净妙身
  远离恶者不自造　　增长修集无量善
  舍离一切恶诤讼　　彼有如是净妙身
  恭敬佛法及圣僧　　常恒奉施众妙供
  不毁骂他不逼恼　　彼有如是净妙身
  调弄呵骂及毁呰　　于他人所不生是
  叹美赞善不说恶　　彼有如是净妙身
  悭贪嫉妒及憍慢　　谛观己行不毁他
  彼有如是净妙身

尔时波斯匿王。白世尊言。是不思议光菩萨婴儿。成就如是胜妙大法。有何业障。而生于是淫女腹中。捐弃空处。佛告大王。乃往过去九十一劫。尔时有佛。号毗婆尸。出现于世。如来应供正遍觉明行足善逝世间解无上士调御丈夫天人师佛世尊。大王当知。尔时毗婆尸如来法中有二菩萨。一名贤天。二名饶财。贤天菩萨。于无上道得不退转。得陀罗尼及无碍辩。获无生忍。有福德威势。少欲少事。常乐独处。逮得神通。彼时饶财菩萨。习学头陀。为贤天菩萨而作给使。彼人恒往聚落城邑。多诸事务。是贤天菩萨呵啧教诲。何故多造是诸事务。而不断除。数数教呵。彼便生嗔忿心不喜。以忿恚故毁败身心。败身心已嗔恚骂言。轻贱淫女儿。私通所生从他人得。不识其父又不识母。况汝当有戒闻定慧。彼嗔骂已复不悔过。又不舍离。结使所缠恒有忿心。嗔贤天菩萨。时贤天菩萨即便舍弃。既舍弃已倍生嗔恚骂詈扬恶。以此不善业行因缘。身坏命终生淫女胎。为彼贤天菩萨所护。不生地狱。淫女生已恒常弃之。为狐狼狗之所啖食。大王。以是缘故。九十一劫常如是死。生生常弃。为多人众之所骂言。是淫女子。被弃空处狐狼狗食。大王莫疑。何以故。彼时饶财嗔骂菩萨。即是今此不思议光菩萨是也。恶业行尽以善业力。净于结心悦可佛意。是人恶道悉皆永尽。大王。此不思议光菩萨。已曾值遇六十四亿佛。恭敬供养尊重赞叹。是诸佛所常修梵行勤进求法。此本善力得如是事及神通力。大王。如是黑白之业终不败亡。是故智者善护身口及以意业。宁舍身命不造恶业。尔时波斯匿王。白言。世尊。彼贤天菩萨。为已得成于一切智。为故修集菩萨行耶

佛言大王。彼贤天菩萨。今者在彼阿閦佛土修菩萨行。名曰德藏。尔时波斯匿王。白言世尊。若善男子善女人。常应当亲于善知识近善知识。何以故。世尊。近善知识恭敬围绕听闻善法。闻善法已得于善心。已有善心则修善行造作善业。趣向善处得善知识。得善友故不作诸恶修习诸善。习诸善已自无逼热不逼热他。若有菩萨自护护他能得菩提。若已住道有大势力能有所利。佛言。善哉大王。快说此言。大王。菩萨亲近于善知识。具满一切功德善法。尔时不思议光菩萨白言。世尊。菩萨成就几法。疾得阿耨多罗三藐三菩提。获净法忍

佛言婴儿。菩萨成就四法。疾得无上正真之道及净法忍。何等四。解因缘忍。远离断常。解无我人众生寿命。解了空寂修行于空。是为四。复有四法。何等四。过去寂灭。未来无来知。现在不住。三世平等。是为四。复有四法。所谓自净。净诸众生。净法。净禅定。是为四。复有四法。谓寂身。寂心。寂道。寂法。是为四。复有四法。谓以法观佛不以色。以离观法不以我。以无为观僧不以众。净于慧眼。是为四。复有四法。所谓满足诸波罗蜜。不舍四摄法。善知方便。说无众生而行大悲。是为四。婴儿。是为菩萨成就四法。疾得阿耨多罗三藐三菩提及深法忍。说是法时。不思议光菩萨。得无生法忍。欢喜踊跃上升虚空高七多罗树。时此三千大千世界六种震动。大光普照天雨众华。百千伎乐不鼓自鸣

尔时世尊。知不思议光菩萨心已。即便微笑。佛之常法。若微笑时。种种若干百千色光。从面门出。青黄赤白红颇梨色。是光普照遍于无量无边世界。隐蔽魔宫及日月光。断除地狱饿鬼苦已上至梵世。还绕佛三匝从顶相入。尔时大德阿难。从座而起偏袒右肩。右膝着地合掌向佛。说偈问曰

  色相甚微妙　　杂好庄严身
  圆光善答问　　以何因缘笑
  上戒行无畏　　胜定慧庄严
  示坚解脱果　　以何因缘笑
  忍力及十力　　忍勇进难动
  乐见示四谛　　以何因缘笑
  金刚身坚固　　那罗延力尽
  梵音声悦意　　愿演说笑义
  梵身天在上　　不见如来顶
  次第合掌敬　　以何因缘笑
  树王下降魔　　得无垢净道
  知诸众生行　　愿显何缘笑
  转无上法轮　　说无常动地
  调人天龙等　　大德何故笑
  照明除闇冥　　无垢遍净眼
  功德如虚空　　以何因缘笑

尔时世尊。告阿难言。汝今见是不思议光菩萨。去地七多罗树住虚空不。阿难白言。已见世尊。阿难是不思议光菩萨。过百千阿僧祇劫。当得作佛。亦号不思议光。出现于世。如来应正遍觉明行足善逝世间解无上士调御丈夫天人师佛世尊。国名净洁。劫名无咎。阿难是净洁佛土甚为清净。如此他化自在诸天宫殿。彼佛寿命二十中劫。大声闻众其数八万。诸菩萨僧三万二千。阿难以何因缘故劫名无咎。阿难。彼时多有百千劫中无佛出世。是不思议光佛。于彼劫中最初成佛。净居诸天欢喜赞叹。此劫无咎。此劫无咎。以有如来出现于世故。是故当名此劫无咎。说是不思议光菩萨时。三万二千众生。发阿耨多罗三藐三菩提心。六万菩萨得无生法忍。五百比丘断诸结漏。心得自在成阿罗汉。尔时佛告阿难。汝受此经持读诵说。于大众中广敷演之。令我正法久住在世。亦多利益未来菩萨。大德阿难。白言。世尊。我已受持。世尊。此经何名。云何受持。佛言阿难。此经名为除净业障。亦名为神力所持不思议光菩萨所说。如是受持。阿难。若善男子善女人。尽其寿命奉诸如来。供养恭敬尊重赞叹。以杂色花裓如须弥。烧香末香涂香。幢幡宝盖。皆亦如是以用供养。复有善男子善女人。受持于此不思议光所说经法。读诵通利。在大众中广为人说。如说修行。是福多彼。阿难。若欲法供供养如来。欲作大智慧光明者。应当受持读诵此经。佛说是经已。不思议光菩萨。大德阿难。一切大众。人天龙鬼乾闼婆阿修罗等闻佛所说皆大欢喜不思议光菩萨所说经


采花违王上佛授决号妙花经

    No. 510 [No. 509]

采花违王上佛授决号妙花经

        东晋天竺三藏竺昙无兰译

昔者世尊。游罗阅只说经散慧。初语亦善中语亦善竟语亦善其义微妙。净修梵行。所讲广普。时王便给使数十余人。常采好花以给王家。后宫贵人婇女大小。一日俱出城外采华。欲还入城路迳遇佛。遥见世尊相好威光巍巍无量。犹星中月。若日初出照于天下。与圣众俱弟子菩萨前后围绕。往诣佛所稽首为礼。心自念言。人命难保。佛世难遇。经法难值。今遭大圣。犹病者得良医。身既贫贱加属县官。羁役之患恒不自从。国王严急。主给采花常以早进。设失时节或能见诛。日不再中。圣众难遇亿世时有。宁弃身命。以花上佛并散圣众。因受经戒听省深法无穷之慧。我于无数劫。为人所害不可称载。未曾为法而惜身命。今供世尊三宝之业。纵使见害。不堕苦痛必生安处。便以华散佛及圣众上。却自归命一心重礼。佛知其念发大道意。甚慈愍之。具为散讲大乘之法六度无极四等四恩三脱菩萨时。诸采华人皆发无上正真道意心解佛慧。至不退转无所从生。佛即授决后当得佛。号曰妙华如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。其边人闻莫不怡悦。启受大法供奉三宝。时采华夫供养受决。稽首佛足还归家中。与家二亲妻子辞别。我今命尽为王见杀。父母愕然问何罪咎。诸子答曰。为王所使行采诸华。中遥见佛以华贡上。王大严急既违失时。复无有华必见危命。故辞别耳。二亲闻之益以愁戚。当奈之何。发箧视之满中好华须曼杂香。香薰郁郁远彻四面。父母告曰。可以进王。诸子各曰。众人见之必传至王。又复违时恐不得安。时王大嗔。见不时来复散众华。遣边大臣多将人兵收取将来。则受王教反缚入宫。罪当弃市。诸人不恐面色不变。王怪问之。汝等罪过命在不测。缚来当杀。何故不懅面色不改。即白王曰。人生有死物成有败。我从无数劫每以非法不惜身命。朝早采华值遇世尊。以华供上稽首归命。尔时以知违令当死。宁以有德而死。不以无德而存。还视华箧续满如故。皆是如来恩仁所覆。王甚怪之心不信然。故往诣佛稽首足下。却坐一面叉手问佛。有是意不。佛言然王。此人至心欲度十方不惜身命。故取众华以散上佛。意无想报以得受决。将来成佛号曰妙华至真等正觉。用发大意受决之故。慈心之香华满箧器莫不闻知。王大欢喜。疾解众缚悔过自责。愚意不及系缚菩萨。惟原其罪。佛言。善哉善哉。能自改者与无过同。佛说如是。王及臣民莫不悦豫。作礼而去。采华违王上佛授决号妙花经


差摩婆帝授记经

    No. 573

差摩婆帝授记经

        元魏北印度三藏菩提流支译

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众二十千人俱。多有诸菩萨。谓弥勒菩萨。文殊师利等。诸大菩萨众

尔时世尊于晨朝时着衣持钵。弥勒菩萨相随。俱入王舍大城而行乞食。遂尔往到频婆娑罗大王宫殿。到已欲入。尔时即见频婆娑罗大王夫人差摩婆帝在重楼上。既见世尊心更清净。从楼而下敷大价衣名波都拏。如来坐上。弥勒菩萨坐尼师坛

尔时世尊弥勒菩萨二俱坐已。时王夫人差摩婆帝。一切庄严庄严其身。礼世尊足并即礼敬弥勒菩萨。于世尊前敛容正坐心生敬重。欲闻说法。尔时世尊见王夫人差摩婆帝。一切庄严庄严身已。为欲利益一切众生。饶益一切诸众生故。知而故问差摩婆帝王夫人言。差摩婆帝彼名何树。汝身今着如是色果。第一光明端严殊妙。时王夫人差摩婆帝。以偈答曰

  第一大丈夫　　知而故问我
  彼树名何树　　汝着如是果
  彼树名福德　　我于往世种
  此果是彼果　　我今如是食
  又已种彼树　　于正觉声闻
  安住菩提道　　求正觉者地
  施戒水湿润　　令彼树增长
  彼树增长已　　生此端严果
  忍辱精进力　　能增长彼树
  彼树增长已　　生此无垢果
  禅慧开敷花　　令彼树端严
  我今食此果　　如世尊所见
  如树林果等　　一切依止山
  枝叶等增长　　上下皆不动
  如是彼大树　　我前世善种
  利益诸众生　　为得诸佛法
  如是福德树　　我此唯其花
  我今且尔食　　果犹故在后
  第一菩提果　　无上佛菩提
  舍妇女劣身　　后必得彼果
  我当得丈夫　　众生中上上
  一切法彼岸　　一切智遍见
  我解脱众生　　一切苦怖畏
  一切当归我　　愍一切众生

尔时世尊告王夫人差摩婆帝。作如是言。善哉善哉。差摩婆帝。汝能如是利益多人。安乐多人。怜愍世间。饶益安乐一切大众诸天人等。时王夫人差摩婆帝。闻佛赞已。白言世尊。世尊。此身三十二种大丈夫相八十种好。何因缘得十如来力四无所畏及四无碍。复有十八不共佛法大慈大悲大喜大舍。如是种种无量无等不可说尽。无数佛法从何而生。时王夫人差摩婆帝。如是问已。佛说偈言

  我亦复如是　　往世种彼树
  为利益众生　　悕求正觉智
  修行施戒忍　　精进禅和集
  复于一切时　　恒常习禅慧
  于一切众生　　不曾起恶心
  常行平等心　　今日得成佛
  常于爱不爱　　善友怨平等
  得平等心已　　福德树增长
  我此身大树　　摄无量功德
  曾为转轮王　　亦作帝释王
  复作大梵王　　种种多富乐
  不思议佛法　　相等今复得

时王夫人差摩婆帝。闻说如是诸功德已。赞言善哉。于世尊语极生随喜。即向如来而说偈言

  如胜人中胜　　如是随顺学
  如本学善学　　无边功德海
  我今学佛学　　诸功德彼岸
  当离生死苦　　得如是牟尼
  我本诸生处　　曾修行布施
  愿彼一切福　　得佛无等智
  过现诸生处　　我护持禁戒
  愿彼一切福　　当得如来智
  我修忍精进　　三昧般若等
  愿如是一切　　皆成就佛法
  我身口意业　　所修行诸善
  愿得大菩提　　求佛智功德
  我舍妇女体　　得胜丈夫身
  得丈夫身已　　次第得佛身
  得胜菩提已　　转无上法轮
  与缚生死狱　　众生除解脱

尔时世尊为王夫人差摩婆帝。偈说善哉而赞之言

  善哉此语说　　善哉心善愿
  汝当破坏魔　　而得成正觉

时王夫人差摩婆帝。既蒙世尊现自授记。闻已欢喜起胜上心生决定意。多奉世尊。佉陀尼食。蒲阇尼食。娑陀尼食。事事丰足。如是并奉弥勒菩萨摩诃萨食

尔时世尊既食。食已离钵洗手。既洗手已。为王夫人差摩婆帝复更说法。示已教已。劝已导已。令欢喜已。与授记言。差摩婆帝。汝于未来过无量劫当得作佛。号曰功德宝胜如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。汝佛世界第一清净。无有恶道苦恼之事。心喜心乐庄严殊妙。第一清净菩萨住处。如是严净佛之世界汝当得之。佛说如是法门之时。有多千数诸优婆塞。一切皆发阿耨多罗三藐三菩提心。多千众生人天世间。于法不疑得随顺心。如来说已。差摩婆帝。弥勒菩萨。一切众会并诸天人。及阿修罗乾闼婆等。闻世尊说。皆大欢喜差摩婆帝授记经


禅法要解

    No. 616

禅法要解卷上

        姚秦三藏鸠摩罗什等于长安逍遥园译

行者初来欲受法时。师问五众戒净已。若淫欲多者。应教观不净。不净有二种。一者恶厌不净。二者非恶厌不净。何以故。众生有六种欲。一者着色。二者着形容。三者着威仪。四者着言声。五者着细滑。六者着人相。着五种欲者令观恶厌不净。着人相者令观白骨人相。又观死尸若坏若不坏。观不坏断二种欲威仪言声。观已坏悉断六种欲。习不净有二种。一者观死尸臭烂不净。我身不净死尸一等无有异也。如是观己心生恶厌。取是相已。至闲静处若树下若空舍。以所取相自观不净。处处遍察系心身中不令外出。若心驰散还摄缘中。二者虽不眼见。从师受法忆想分别。自观身中。三十六物不净充满。发毛爪齿涕泪涎涶。汗垢肪[月*冊]皮膜肌肉。筋脉髓脑心肝脾肾肺胃肠肚胞胆痰癊。生藏脓血屎尿诸虫。如是等种种不净聚。假名为身。自观如是。所著外身亦如是观。若心厌恶淫欲。心息则已。若心不息当勤精进。呵责其心作是念言。老病死苦其为至近。命如电逝。人身难得善师难遇。佛法欲灭如晓时灯。有破定法众患甚多。内诸烦恼外有魔民。国土饥荒内外老病。死贼其力甚大坏习禅定。我身可畏。于诸烦恼贼中未有微损。于禅定法中未有所得。虽服法衣。内实空虚俗人无异。诸恶趣门一切皆开。诸善法中未入正定。于诸恶法未能必不为恶。我今云何着是屎囊而生懈怠。不能精勤制伏其心。如此弊身贤圣所呵。不净可恶九孔流出。而贪着此身。与畜生同死。俱投黑闇甚所不应。如是鞭心思惟自责还摄本处。又时亦复应令心悦。作是念言。佛是一切智人。直说道教易解易行。是我大师。如是不应忧畏。如依大王无有怖畏。诸阿罗汉所作已办。是我同伴。已能伏心如奴衷主。心已调伏具种种果六通自在。我亦应自伏其心求得此事。唯有此道无复异路。如是思惟已还观不净。复自欣欢作是念言。初习道时。诸烦恼风吹破我心。我欲得道。上妙五欲尚不能坏。何况弊者。如长老摩诃目揵连得阿罗汉道。本妇将从伎乐盛自庄严饰欲坏目连。目连尔时说偈言

  汝身骨干立　　皮肉相缠裹
  不净内充满　　无一是好物
  韦囊盛屎尿　　九孔常流出
  如鬼无所直　　何足以自贵
  汝身如行厕　　薄皮以自覆
  智者所弃远　　如人舍厕去
  若人知汝身　　如我所厌恶
  一切皆远离　　如人避屎坑
  汝身自严饰　　华香以璎珞
  凡夫所贪爱　　智者所不惑
  汝是不净聚　　集诸秽恶物
  如庄严厕舍　　愚者以为好
  汝胁肋着脊　　如椽依栋住
  五藏在腹内　　不净如屎箧
  汝身如粪舍　　愚夫所保爱
  饰以珠璎珞　　外好如画瓶
  若人欲染空　　终始不可着
  汝欲来娆我　　如蛾自投火
  一切诸欲毒　　我今已灭尽
  五欲已远离　　魔网已坏裂
  我心如虚空　　一切无所著
  正使天欲来　　不能染我心

行者如是思惟决定坚固。住心本缘不畏众欲。若利根者。一心精勤。远至七日心得定住。中根者。乃至三七。钝根者。久久乃得。如攒酪成酥。必可得也。若不任习行。是身虽复久习种种方喻。空无所得。譬如攒水终不成酥。问曰。何事不中。答曰。若犯禁戒不可忏者。若邪见不舍。若断善根及三覆障。所谓厚利烦恼。五无间罪。三恶道报。如是等罪不应习行。又摩诃衍中。菩萨利根。有实智慧福德因缘。不同其事。若不任习行。当诵经修福起塔供养。说法教化行十善道。问曰。云何当知得一心相。答曰。心住相者身软轻乐。嗔恚愁忧诸恼心法皆已止息。心得快乐未曾所得胜于五欲。心净不浊故身有光明。如清净镜光现于外。如明珠在净水中光明显照。行者见是相己心安喜悦。譬如渴人掘地求水已见湿泥得水不久。行者如是。初习行时如掘干土。久而不止得见湿相。自知不久当得禅定。一心信乐精勤摄心转入深定。作是念已毁訾五欲。见求欲者甚为可恶。如人见狗不得好食而啖臭粪。如是种种因缘。呵欲为过。心生怜愍。受五欲者。自心有乐而不知求。反更外求不净罪乐。行者常应精进昼夜集诸善法助成禅定。诸障禅法令心远离。集诸善法者。观欲界无常苦空无我。如病如疮如痈如箭入心。三毒炽燃起诸斗诤嫉妒烟相甚为恶厌。如是观者。是名初习禅法。若习法时。中间或有五盖覆心。即应除灭。如黑云翳日风力破散。若淫欲盖起。心念五欲即应思惟。我今在道自舍五欲云何复念。如人还食其吐。此是世间罪法。我今学道。除剃须发被着法衣。尽其形寿。五欲情愿永离永断。云何还复生着。甚非所宜。即令除灭。如贼毒蛇不令入室。以其为祸甚深重故。复次五欲之法。众恶住处。无有反复。初时尚可。久后欺诳受诸苦毒。嫉妒恚怒无恶不作。如囊盛众刀以手抱触左右伤坏。复次设得五欲犹不厌足。若无厌足则无有乐。如渴饮浆。未及除渴不得有乐。犹如搔疥。其患未差不可为乐。复次欲染其心不见好丑。不畏今世后世罪报。以是之故除却淫欲。已却淫欲或生嗔恼。嗔恼心生即应除却。众生可念。处胎已来无时不苦。众苦备具云何更增其恼。如人临欲刑戮。何有善人重增苦痛。又复行道之人。应舍吾我爱慢等结。虽不障生天而行道之人尚不生念。何况嗔恚拔乐根本。复次如水沸动不见面像。嗔恚心生不识尊卑父母师长。乃至不受佛教。嗔为大病。残害无道犹如罗刹。当以思惟。慈心消灭嗔恚。淫欲嗔恚既止。若得禅定则为快乐。若未得禅乐。情散愁愦心转沉重。瞪瞢不了。即知睡眠害心之贼。尚破世利。何况道事。睡眠法者与死无异。气息为别。如水衣覆水不睹面像。睡眠覆心不见好丑。诸法之实亦复如是。即时除却应作是念。诸烦恼贼皆欲危害何可安眠。如对贼阵。锋刃之间不应睡眠。未离老病死患。未脱三恶道苦。于道法中乃至暖法未有所得。不应睡眠。作是念已若睡犹不止即应起行冷水洗面。瞻视四方仰观星宿。念于三事除灭睡眠不令覆心。一者怖畏。当自思惟。死王大力常欲为害。念死甚近如贼疾来无可恃怙。又如拔刀临项。睡则斩首。二者欣慰。当作是念。佛为大师。所有妙法未曾有也。我以受学自幸欣庆。睡心即灭。三者愁忧。当复念言。后世展转受身经历。苦痛毒害无边无量。如是种种因缘呵睡眠法。如是思惟睡眠则止。若掉悔盖起。应作是念。世人欲除忧。求欢喜故而生掉戏。今我苦行坐禅求道。云何自恣放心掉戏。甚所不应。佛法所重摄心为本。不应轻躁纵心自放。如水波动不见面像。掉戏动心不见好丑。悔如禅度中说。问曰。贪欲恚疑各别为盖。何故睡眠掉悔二合为盖。答曰。睡虽烦恼势力微薄。眠不助成则不覆心。掉戏无悔不能成盖。以是故二合为盖。譬如以绳系物单则无力合而能系。复次睡眠心法因睡心重。以心重故身亦俱重。因睡微覆眠覆转增遮坏道法。是故二合为盖。眠既觉已心不专一。驰念五欲行诸烦恼。是名为掉。譬如猕猴得出羁闭。自恣跳踯戏诸林木。掉亦如是。已念五欲行诸结使。身口意失而生忧悔。作是念言。不应作而作。应作而不作。是故掉悔相因二合为盖。问曰。作恶能悔不应为盖。答曰。如犯戒自悔。从今以往不复更作。如是非盖。若心作罪常念不息。忧恼乱心故名为盖。如是种种因缘。呵掉悔盖。系心缘中。若心生疑即应令灭。所以者何。疑之为法非如爱慢。今世不生欢心。后世令堕地狱。有疑遮诸善法。如岐路犹豫不知那进。便自止息。行者如是。本所习法疑不复进。即知疑患遮覆正道。当疾除却。复作是念。佛为一切智人。分别诸法。是世间法是出世间法。是善是不善。是利是害。了了分明。今但受行不应生疑。当随教法不应拒违。复次佛法妙者。修定智慧如实如法。我无是智云何自心筹量诸法。如人手执利器。乃可与贼相御。若无所执而对强敌反以为害。我今未得修定智慧。云何欲筹量诸法实相。是不应然。复次外道非佛弟子故应生疑。我是弟子云何于佛而复生疑。佛常毁訾疑患。是覆是盖是遮是碍。自诳之法。如人既知刺客即应除避。疑亦如是。诳惑行者。欲与疑慧而碍实智。譬如病疥搔之转多身坏增剧。良医授药疥痒自止。行者如是。种种诸法而生疑想。随事欲解疑心转多。是以佛教直令断疑。疑生即灭。如是种种呵疑。当疾除却。行者如是思惟除舍五盖集诸善法。深入一心。断欲界烦恼得初禅定。如佛经说。行者离欲恶不善法。有觉有观离生喜乐入初禅。问曰。得初禅相云何。答曰。如先以正念呵止五欲。未得到地。身心快乐柔和轻软身有光明。得初禅相转复增胜。色界四大遍满身故。柔和轻软离欲恶不善一心定故能令快乐。色界造色有光明相。是故行者见妙光明照身内外。行者如是心意转异。嗔处不嗔喜处不喜。世间八法所不能动。信敬惭愧转多增倍。于衣服饮食等心不贪着。但以诸善功德为贵。余者为贱。于天五欲尚不系心。何况世间不净五欲。得初禅人有如是等相。复次得初禅时心大惊喜。譬如贫者卒得宝藏。心大欢喜作是念言。初夜中夜后夜。精勤苦行习初禅道。今得果报如实不虚。妙乐如是。而诸众生狂惑顽愚。没于五欲不净非乐。甚可怜愍。初禅快乐内外遍身。如水渍干土内外沾洽。欲界身分受乐不能普遍。欲界淫恚诸火热身。入初禅池凉乐第一除诸热恼。如大热极入清凉池。既得初禅念本所习修行道门。或有异缘。所谓念佛三昧。或念不净慈心观等。所以者何。是行思力令得禅定转复深入。本观倍增清净明了。行者得初禅已进求二禅。若有漏道。于二禅边地厌患觉观。如欲界五欲五盖令心散乱。初禅觉观恼乱定心亦复如是。若无漏道。离初禅欲。即用无漏初禅。呵责觉观。问曰。如初禅结使亦能乱心。何故但说觉观。答曰。初禅结使名为觉观。所以者何。因善觉观而生爱着。是故结使亦名觉观。始得初禅未有余着。复次本未曾得觉观大喜。以大喜故坏败定心。以破定故先应除舍。复次欲入甚深二禅定故除却觉观。为大利故而舍小利。如舍欲界小乐而得大乐。问曰。但说觉观应灭。不说初禅烦恼耶。答曰。觉观即是初禅善觉观也。初禅爱等亦名觉观。以恶觉观障二禅道。是故宜灭。以善觉观能留行者令心乐住。是故皆应当灭。寻复思惟。知恶觉观是为真贼。善觉观者虽似亲善亦复是贼。夺我大利故。当进求灭二觉观。觉观恼乱如人疲极安眠众音恼乱。是故行者。灭此觉观已求二禅。譬如风土能浊清水不见面像。欲界五欲浊心如土浊水。觉观乱心如风动水。以觉观灭故内得清净。无觉无观定生喜乐入于二禅。问曰。云何是二禅相。答曰。经中说言。灭诸觉观。若善若无记。以无觉观动故内心清净。如水澄静无有风波。星月诸山悉皆照见。如是内心清净故。名贤圣默然。三禅四禅虽皆默然。以二禅初得。为名有觉观语言因缘。因缘初灭故得名默然定生喜乐妙胜初禅。初禅喜乐从离欲生。此中喜乐从初禅定生。问曰。二禅亦离初禅结使。何以不言离生。答曰。虽复离结。但依定力多故。以定为名。复次言离欲者则离欲界。言离初禅未离色界。是故不名离生。如是等是二禅相。行者既得二禅。更求深定。二禅定有烦恼覆心。所谓爱慢邪见疑等。坏破定心。是二禅贼遮三禅门。是故当求断灭此患以求三禅。问曰。若尔者。佛何以故说。离喜行舍得入三禅。答曰。得二禅大喜。喜心过差心变着。喜生诸结使。以是故喜为烦恼之本。又复诸结使无有利益不应生着。喜是悦乐甚为利益滞着难舍。以是故佛说舍喜得入三禅。问曰。五欲不净罪。喜则应当舍。是喜净妙众生所乐。云何言舍。答曰。先已答生着因缘则是罪门。复次若不舍喜。则不能得上妙功德。以是故舍小得大。有何过也。行者进求三禅。观喜知患忧苦因缘所可喜乐。无常事变则生忧苦。复次喜为粗乐。今欲舍粗而求细乐。故言离喜更入深定求异定乐。云何三禅相灭喜。舍此妙喜心不悔念。知喜为害。譬如人知妇是罗刹。则能舍离心不悔念。喜为狂惑粗法非妙。第三禅身受乐。世间最乐无有过者。圣所经由。能受能舍无喜之乐。以念巧慧身。则遍受入于三禅。问曰。此说一心念慧。初禅二禅何以不说。答曰。第三禅者。身遍受乐心行舍法。不令心着分别好丑。故言一心念慧。复次三禅中有三过。一者心转细没。二者心大发动。三者心生迷闷。行者常应一心念此三过。若心没时。以精进智慧力。还令心起。若大发动则应摄止。若心迷闷应念佛妙法还令心喜。常当守护治此三心。是名一心行乐者入第三禅。问曰。如经。第三禅中二时说乐。何等为二乐。答曰。前说受乐。后说快乐。问曰。有三种乐。受乐快乐无恼乐。以何乐故三禅名为第一之乐。答曰。三乐上妙皆胜下地。但以受乐第一。说名乐地。究竟尽故。余二乐者上地犹有。此中不以为名。问曰。喜乐无喜乐。有何差别。答曰。乐受有二种。一者喜根。二者乐根。喜根喜乐。初禅二禅所摄。乐根无喜乐。三禅所摄。复次欲界初禅乐受。粗者名乐根。细者名为喜根。二禅三禅乐受。粗者为喜根。细者为乐根。譬如热极得清冷水持洗手面。是名为喜。入大凉池举身沐浴。是名受乐。行者如是。初禅觉观故乐不遍身。二禅大喜惊故不能遍身。三禅无障碍故乐遍其身。是名差别。复次乐受有四种。欲界六识相应乐。名为喜根亦名乐根。初禅四识相应乐。名为乐根亦名喜根。二禅意识相应乐受名为喜根。三禅离喜故。意识相应乐受。名为乐根。行者既得三禅。知上三乐。一心守护常恐畏忘失。则为是恼。是故乐复为患。当求离乐。譬如人求富贵之乐。求时既苦。得时无厌则复为苦。得已守护亦复为苦。有人以求乐为苦故舍。或有得乐无厌觉苦故舍。或有既得守护为苦故舍。行者患乐亦如是。求初禅乐。以觉观恼乱故舍。二禅大喜动故舍。三禅知乐无常难守故舍。以是故。当舍此乐求于四禅安隐之地。问曰。行者依禅定乐舍于欲乐。今依何等而舍禅乐。若舍禅乐得何利益。答曰。行者依于涅槃乐能舍禅乐。得三利故。所谓罗汉辟支佛佛道。是故舍禅定乐。行于四禅安隐快乐。以三乘道随意而入涅槃。问曰。云何知是第四禅相。答曰。如佛说四禅相。若比丘断乐断苦先灭忧喜。不苦不乐护念清净入第四禅。问曰。断三禅乐应尔。离欲时已断苦。今何故复言断苦。答曰。有人言。断有二种。一别相断。二总相断。如须陀洹。以道比智。总断一切见谛结使。是事不然。何以故。佛说断苦断乐先灭忧喜。若欲界苦。应说先断苦忧喜。而不说者。以是故知非欲界苦。以三禅乐无常相故则能生苦。是故说断苦。又如佛说。乐受时当观是苦。于三禅乐生时。住时为乐灭时为苦。以是故言断乐断苦。先灭忧喜者。欲界中忧。初二禅喜者。问曰。欲界中有苦有忧。离欲时灭。何以但说断忧。不说断苦。答曰。离欲时虽断二事。忧根不复成就。苦根成就。以成就故不得言灭。问曰。若三禅中乐生。住时乐灭时为苦。今说初禅二禅中喜。何独不尔。答曰。佛经所说。离三禅时。断乐断苦无灭忧喜。初禅二禅不作是说。问曰。佛何因缘不作是说。答曰。三禅中乐。于三界中受乐最妙。心所著处。以其着故无常生苦。以喜粗故不能遍身虽复有失不大生忧。以是故佛经不说也。不苦不乐者。第四禅中虽有不苦不乐受。舍者舍三禅乐。行不苦不乐受不忆不悔。念清净者。以灭忧喜苦乐四事故念清净。问曰。上三禅中不说清净。此中何以独说。答曰。初禅觉观乱故。念不清净。譬如露地风中然灯。虽有脂炷。以风吹故明不得照。二禅中虽一识摄。以喜大发故定心散乱。是故不名念清净。三禅中着乐心多乱此禅定故不说念清净。四禅中都无此事故言念清净。复次下地虽有定心。出入息故令心难摄。是中无出入息故心则易摄。易摄故念清净。复次第四禅名为真禅。余三禅者方便阶梯。是第四禅譬如山顶。余三禅定如上山道。是故第四禅。佛说为不动处。无有定所动处故。有名安隐调顺之处。是第四禅相。譬如善御调马随意所至。行者得此第四禅。欲行四无量心随意易得。欲修四念处修之则易。欲得四谛疾得不难。欲入四无色定易可得入。欲得六通求之亦易。何以故。第四禅中不苦不乐。舍念清净调柔随意。如佛说喻。金师调金洋炼如法。随意作器无不成就。问曰。行者云何得慈心无量。答曰。行者依四禅已。念一城众生愿令得乐。如是一国土。一阎浮提四天下。小千国土。二千国土。三千大千国土。乃至十方恒河沙等无量无边众生。慈心遍覆皆愿得乐。譬如水劫尽时消水火珠灭不复现。大海龙王心大发动。从念生水出海盈漫。及天澍雨遍满天下。是时天地弥漫无不充溢。行者亦尔。以大慈水灭嗔恚。消慈火珠。慈水发溢渐渐广大。遍至无量无边众生。悉蒙润泽常出不断。或听说法增益慈心。譬如大雨无不周普。行者慈念众生。令得世间清净之乐。亦以所得禅定快乐持与众生。亦以涅槃苦尽之乐。乃至诸佛第一实乐。愿与众生。以慈力故。悉见十方六道众生无不受乐。问曰。如阿毗昙说。何等是慈三昧。观一切众生悉见受乐。又经中说慈心三昧。遍满十方皆见受乐。云何但言愿令众生得乐。答曰。初习慈心愿令得乐。深入慈心三昧已。悉见众生无不受乐。如钻燧出火。初然细软干草。火势转大湿木山林一时俱然。慈亦如是。初入观时。见人受乐愿与苦者。慈力转成悉见得乐。问曰。众生实无得者。云何皆见得乐而不颠倒。答曰。定有二种。一者观诸法实相。二者观法利用。譬如真珠师。一者善知珠相贵贱好丑。二者善能治用。或有知相而不能用。或有治用而不知相。或有知相亦能治用。行者如是。贤圣未离欲者。能观法相四真谛等而不能用。不行四无量故。如凡夫离欲行诸功德。能有利用。生四无量心。不能观实相故。如俱解脱阿罗汉等。能观实相。具禅定故生四无量。四无量者得解之法。以利用故非为颠倒。复次佛法之实无有众生。云何观苦者为实。乐者为倒。所谓颠倒。无众生中而着我相。若常若无常。若边若无边等。是为颠倒。行慈之人知众生假名。如轮等和合名之为车。是故行者。慈心清净则非颠倒。复次若无众生以为实者。众生受乐应是颠倒。而有众生无众生皆为是边。不应但有众生以为颠倒。复次慈三昧力故。行者皆见众生无不得乐如一切入观。禅定力故于缘境界转青作赤。何况众生皆有乐相而不见也。如贵贱贫富禽兽之属。各自有乐互相怜愍。贵者之患贫者所无。贫者之患贵者所无。问曰。余道可尔。地狱云何。答曰。地狱众生亦有乐分。远见刀山灰河。皆谓林水而生乐想。见树上女人亦生乐想。又我心颠倒故爱乐其身。若欲杀时逃避啼哭请求狱卒愿见放舍。若语赦汝。得脱此苦心亦可乐。如是之等皆有乐分。又复神通力故。行慈之心。种种教化令众生得乐。或随所有而能与之。及身口行助成利益。如诸佛菩萨深心爱念坏诸恶趣。实令众生得种种乐。以是故不但愿与。亦实令得乐。问曰。行慈者得何功德。答曰。行慈者诸恶不能加。如好守备外贼不害。若欲恼害反自受患。如人以掌拍矛。掌自伤坏矛无所害。五种邪语不能坏心。五种者。一妄语说过。二恶口说过。三不时说过。四恶心说过。五不利益说过。譬如大地不可破坏。种种嗔恼谗谤等不能毁也。譬如虚空不受加害。心智柔软犹若天衣。复次行者入慈。虎狼毒兽蛇蚖之属皆不能害。如入牢城无能伤害。得如是等无量功德。问曰。慈德如是。何者名慈法。答曰。爱念众生皆见受乐。是心相应法行阴所摄名为慈法。或色界系或不系。心数法。心共生。随心行。非色法。非是业。业相应。业共生。随业行。非报生。是应修得修行修。应证身证慧证。或思惟断或不断。或有觉有观。或无觉有观。或无觉无观。或有喜或无喜。或有出入息或无出入息。或贤圣或凡夫。或乐受相应。或不苦不乐受相应非道品。先缘相后缘法。在四禅亦余地。缘无量众生故名为无量。清净故。慈念故。怜愍利益故。名为梵行梵乘。能到梵世名为梵道。是过去诸佛常所行道。问曰。云何修习慈心。答曰。若行者作是念。我除剃须发不在饰好破憍慢相。若称此者宜应行慈。今着染衣。当应行慈令心不染。食他之食不虚受施。如经所说。若有比丘。渐修慈心则随佛教。如是不虚食人信施。复次若出家若在家行者作是念。慈心力故。于恶世中安隐无患。于破法众中独随法行。于热烦恼令心清冷。如近聚落有凉清池。复次行慈力故。怨家毒害不能复害。如着革屣刺不能伤。行者处于欲界。多嗔怒害。斗诤怨毒种种诸害。慈心力故无能伤损。譬如力士着金刚铠执持利器。虽入大阵不能伤坏。复次是慈能利益。利益三种人。凡夫行慈除诸嗔恚。得无量福生于净果。世间福德无过是者。求声闻辟支佛者。欲界多嗔慈力能破。及余烦恼则亦随灭。得离欲界渐出三界。如佛所说。慈心共俱近修七觉。大乘发心为度众生。以慈为本。如是慈心。于三种人无量利益。又习慈初门。又十六行令速得慈。又使牢固。亦常修行。一者持戒清净。二者心不悔。三者善法中生喜。四者快乐。五者摄护五情。六者念巧便慧。七者身离心离。八者同行共住。九者若听若说随顺慈法。十者不恼乱他人。十一者食知自节。十二者少于睡眠。十三者省于言语。十四者身四威仪安隐适意。十五者所须之物随意无乏。十六者不戏论诸法行。是十六法助慈三昧。悲者观众生苦。如地狱饿鬼畜生世间刑徒饥寒病苦等。取其苦相故悲心转增。乃至乐人皆见其苦。问曰。云何以乐为苦。答曰。乐是无常乐无厌足从因缘生。念念生灭无有住时。以是故苦。复次如欲天受乐。如狂如醉无所别知。死时乃觉。色无色界众生。于深禅定爱味心着。命终随业因缘还复受报。如是众生当有何乐。于地狱三恶道。是旧住处。天上人中犹如客住。暂得止息。以是因缘故。佛但说苦谛无有乐谛。是故一切众生无不是苦。众生可愍不知实苦。于颠倒中而生乐想。今世后世受种种忧恼而无厌心。虽暂得离苦还复求乐作诸苦事。如是思惟。见诸众生悉皆受苦。是为悲心。余悲心义如摩诃衍论四无量中说。喜者行人知诸法实相。观苦众生皆为乐相。观乐众生皆为苦相。如是诸法无有定相随心力转。若诸法无有一定相者。成阿耨多罗三藐三菩提尚无有难。何况余道。随意可得故心生欢喜。复次行者作是念。我因少持戒精进等便得离欲。逮诸禅定无量功德。念诸善功德故心生欢喜。譬如贾客赍持少物百千倍利。心大欢喜复作是念。如是法利皆由佛恩。佛自然得道与人演说。随教修行得如是利益。是时心念十方诸佛身有金色相好庄严及十力等无量功德法身。因是念佛心生欢喜。复次佛法于九十六种道中。最为第一。能灭诸苦能趣常乐。心生欢喜。又复分别三种佛法。一者涅槃无量常相。是究竟不坏法。二者涅槃方便八直圣道。三者十二部经宣示八道。如是念法心生欢喜。复次能知如是实相。行于正道离诸邪径。是为正人。所谓佛弟子众于一切众中最为第一。自思惟言。我已在此众中。是我真伴彼能益我。以是因缘故心生欢喜。愿令众生悉皆欢喜。定力转成故。悉见众生皆得是喜。舍者行人如小懈极心暂止息。但观众生一相不观苦乐。喜相犹如小儿。若常爱念憍恣败坏。若常苦切怖畏羸瘦。是故有时放舍不爱不憎。行者如是。若常行慈喜心则放逸。以喜乐多故。若常行悲心则生忧恼。以念苦多故。是故行舍莫令苦乐有过。复次行者入道得禅定味。分别众生好丑。是善是不善。善者恭敬爱念。不善者则生轻慢。如人得大珍宝轻慢贫者。见有宝者恭敬爱念。破是二相故而行舍心。如经中说。修行慈心除破嗔恚。修行悲心除恼众生。修行喜心除破愁忧。修行舍心除破憎爱。但观众生得解脱故随心所作。如人观林不观树也。又如世人寒时得温热时得凉。资生随意者。是名为乐。若得官位宝藏歌舞戏笑。是名为喜。若失此众事者。是名忧苦。若无此三事者。是名为舍。行者亦如是。具有四心。自身受乐愿及众生。心既柔软。见一切众生悉得是乐。又复见诸天上世间豪贵。取其乐相愿及众生。心既柔软。见一切众生。悉得是乐。修行慈时心生大喜。以此大喜愿与众生。或从定起礼佛法众赞叹供养。亦得心喜愿与众生。及取外喜愿与众生。或时自见其苦老病忧恼饥寒困苦。欲令众生离是苦恼。我能分别筹量。心忍犹尚苦恼。何况众生无有智慧忍受众苦。何得不恼。则生悲心。复见外人刑戮鞭挞。又闻经说恶道苦痛。取是苦相观一切皆苦。而生悲心。舍者自舍憎爱。亦观众生无有憎爱。及取外众生受不苦不乐者。从第四禅乃至非有想非无想处。及欲界无苦无乐时。取是相已观一切众生。亦都如是无苦无乐。复次如贵人唯有一子。爱念甚重心常慈愍。世间诸乐愿令悉得。自能得者亦皆与之。其子或时遭诸恼患。父甚悲念。若子从因得免。其父大喜。心生喜已。即便放舍任子自长。父得休息。行者如是。于四无量心中。观诸众生亦如子想。随己所有乐事。及取世间种种诸乐。愿令得之。慈定力故悉见一切皆是乐者。行人从慈心起。若见众生受诸苦痛。取是相已而生悲心。悲心力故见诸众生悉皆受苦。见受苦已愿令众生皆离是苦。从悲三昧起。若见众生受乐得道入涅槃者。取是相已而生喜心。欲令彼得而彼自得。心识柔软悉见众生皆得欢喜。从此定起。见众生不苦不乐者不忧不喜者。取是相已而生舍心。愿令众生不苦不乐不忧不喜。以善修舍定力故。悉见众生不苦不乐不忧不喜。得离烦恼热。复次若众生有诸过衅。舍而不问。若恭敬爱着不以为喜。是为舍心。如是等四无量义。如摩诃衍中说

禅法要解卷上

净观者三品或初习行。或已习行。或久习行。若初习行当教言。破皮却不净。当观白骨人。系意在观不令外意。外念诸缘摄之令还。若已习行当教言。心却皮肉。具观头骨不令外念。外念诸缘摄之令还。若人习行。却身中一寸皮肉系意五处。顶上额上眉间鼻端心处。如是等处住意在骨不令外念。外念诸缘摄之令还。当复观心。若心疲极舍诸外想注念在缘。譬如猕猴被系在柱终日驰走。锁常摄还极乃休息。所缘如柱。念则如锁。心喻猕猴。亦如乳母。常观小儿不令堕落。行者观心亦复如是。渐渐制心令住缘处。若心久住是应禅法。若得禅定即有三相。身悉和悦柔软轻便。白骨流光犹如白珂。心得静住是为净观。是时便得色界中心。是名初学禅法门。若定得胜心。则不如制之令住。是名一心。若能一寸中住。便得遍却。不得但观赤骨人。得此观已。弃赤骨人观白骨人。不令外念。外念诸缘摄之令还。心若清净住于骨观。骨边白光遍身中出。如天清明日光极净。此光既出。以心目观了了见之。因光力故见骨人中相。似诸心心相应法生灭。如毗琉璃筒中水流。是时心息得乐。淫人欲乐不足喻也。外身观亦复如是。如是一身观。次第转多。乃至阎浮提。复从一阎浮提。还至一寸心得自住。是为不净中净三昧门。复次此身空骨以薄皮覆。有何可乐甚可患也禅法要解卷下

        姚秦三藏鸠摩罗什等于长安逍遥园译

若行者欲求虚空定。当作是念。色是种种众苦具。如鞭杖割截杀害饥寒老病苦等。皆由色故。思惟如是则舍离色得虚空处。问曰。行者今以色为身。云何便得舍离。答曰。诸烦恼是色因缘。又能系色。是烦恼灭故则名离色。复次习行破色虚空观法则得离色。复次如佛所说。比丘观第四禅五阴。如病如痈如疮如刺。无常苦空无我。如此等观则离第四禅五阴。以余阴随色故但言离色。所以者何。色究竟尽故。复次行者观色。分分破裂则无有色。如身有分。头足肩臂等各各异分则无有身。如头眼耳鼻舌口须发骨肉等分分令异。则无有头。如眼者四大四尘身根眼根十事和合白黑等。肉团名为眼。各各分别则无有眼。地等诸分各亦如是。问曰。眼根四大所造。不可定色。云何分别。答曰。四大及四大造。净色和合故名为眼。若除是色则无有眼。又此净色虽不可见。以有对故有分。有分故无眼。复次能见色者。是名为眼。若除四大及四大造色则无眼。若无眼能见色者。耳亦应为眼。若眼是色法。一切色法有处有分故。应可分别。若可分别则为多眼。若言四大所造众微尘为眼者。不应一眼。若都非眼亦无一眼。若言微尘为眼者。是亦不然。何以故。若微尘有色则有十方。不名为微尘。若非色者则不名为眼。复次微尘体定有四分色香味触。是眼非四事。何以故。眼是内入摄。四为外入摄。以是故。不得以诸微尘为眼。如佛说众事和合见色假名为眼。无有定实。耳鼻舌皮肉骨等亦如是破。是为破内身相。外色宫殿财物妻子等。亦皆如是分别破。如佛告罗陀。从今日当破散色坏裂色。令无有色。能如是分别是名离色。复次如佛说。若比丘欲离色。度一切色相。灭一切对相。不念一切异相。入无量虚空处。度一切色相者。是可见色。灭一切对相者。是有对不可见色。不念一切异相者。不可见无对色。复次度一切色相者。青黄赤白红紫等种种色相。灭有对者。声香味触等。不念一切异相者。大小长短方圆远近等。如是离一切色相。得入虚空处。复次行者系心身内虚空。所谓口鼻咽喉眼耳胸腹等。既知色为众恼。空为无患。是故心乐虚空。若心在色摄令在空。心转柔软。令身中虚空渐渐广大。自见色身如藕根孔。习之转利。见身尽空无复有色。外色亦尔。内外虚空同为一空。是时心缘虚空无量无边。便离色想安隐快乐。如鸟在瓶瓶破得出。翱翔虚空无所触碍。是名初无色定。行者如虚空中受想行识。如病如痈如疮如刺。无常苦空无我。更求妙定则离空缘。所以者何。知是心所想虚空欺诳虚妄。先无今有已有还无。既知其患。是虚空从识而有。谓识为真。但观于识舍于空缘。习于识观时。渐见识相相续而生。如流水灯焰。未来现在过去识。识相续无边无量。问曰。何以故。佛说识处无边无量。答曰。识能远缘故无边。无边法缘故无边。复次先缘虚空无边。若破无边虚空。识应无边。行者心柔软故能令识大乃至无边。是名无边识处。问曰。是识处具有四阴。何以故。但说识处。答曰。一切内法识为其主。诸心数法皆随属识。若说识者则说余事。复次欲界中色阴为主。色界中受阴为主。虚空处识处识阴为主。无所有处想阴为主。非想非非想处行阴为主。复次三法身心心数法。欲界色界以身为主。心随身故。若无身已心力独用。心有二分。一分缘空一分自缘。是故应有二处空处识处。但初破色故虚空受名。破虚空故独识为名。心数法亦有二分。一分想一分行。是故亦应有二处。想无所有处。行非想非非想处。复次缘识故得离虚空处。以是故虽有余阴。但识受名

行者得识处已。更求妙定观识为患如上说。复次观识如幻虚诳属诸因缘而不自在。有缘则生无缘则灭。识不住情亦不住缘亦不住中间。非有住处非无住处。识相如是。世尊说言。识如幻也。行者如是思惟已。得离识处。复次行者作是念。如五欲虚诳。色亦如是。如色虚诳。虚空亦尔。虚空虚诳识相亦尔。是皆虚诳。而众生惑着即谓诸法。空无所有是安隐处。作是念已即入无所有处。问曰。虚空处无所有处。有何差别。答曰。前者心想虚空为缘。此中心想无所有为缘。是为差别。行者入无所有处已。利根者。觉是中犹有受想行识。厌患如先说。钝根者则不能觉。复次离无所有处因缘有三见。有见无见非有见非无见。有见从欲界乃至识处。无见即是无所有处。非有非无见非想非非想处。是无见应当舍离。何以故。非想非非想虽细尚应舍离。何况无所有处。作是念已离无所有处。问曰。如佛法中亦有空无所有。若是为实。云何言邪见应当舍离。答曰。佛法中为用破着故。说不以为实。无所有处谓为是实。邪见爱着故。是中众生受定果报已。随业因缘复受诸报。以是故应舍。名虽相似其实各异。复次行者作是念。一切想地皆粗可患。如病如痈如疮如箭。无想地则是痴处。今寂灭微妙第一处。所谓非想非无想处。如是观已。则离无所有处想地。即入非有想非无想处。问曰。是中为有想为无想。答曰。是中有想。问曰。若有想者。何以但下七地名为想定耶。答曰。此地中想微细不利。想用不了故不名为想。行者心谓是处非有想非无想。是故佛随其本名。说是名非有想非无想处。钝根者。不觉是中有四阴。便谓涅槃安隐之处生增上慢。寿八万劫已还堕诸趣。是中四阴虽微深妙。利根者则能觉知。觉知已患厌作是念。此亦和合作法。因缘生法虚诳不实。如病如痈如疮如箭。无常苦空无我。亦是后生因缘。应当舍离。以其患故当学四谛。问曰。舍余地时。何以不言学四谛。答曰。前以说如病如痈如疮如箭无常苦空无我。便为略说四谛。但未广说。复次余地无遮无难。凡夫有漏道亦能过故。而此世间之顶。唯有圣人学无漏道乃能得过。譬如绳系鸟脚。初虽得去绳尽摄还。凡夫人亦如是。虽过余地。魔王不以为惊。若过有顶之地。魔王大惊如绳断鸟去。以是故。离余地时不说四谛。有顶地是三界之要门。欲出要门当学四谛。问曰。云何为四谛。答曰。苦谛集谛灭谛道谛。苦有二种。一者身苦。二者心苦。集亦二种。一者使。二者恼缠。灭亦二种。一者有余涅槃。二者无余涅槃。道亦二种。一者定。二者慧。复次苦谛有二种。一者苦谛。二者苦圣谛。苦谛者恼相故。所谓五受阴名为苦谛。苦圣谛者。以知见故修道。是名苦圣谛。集谛有二种。一者集谛。二者集圣谛。集谛者出生相。所谓爱等谛烦恼名为集谛。集圣谛者。以断故修道。是为集圣谛。灭谛有二种。一者灭谛。二者灭圣谛。灭谛者寂灭相。所谓四沙门果。是名灭谛。灭圣谛者。以证故行道。是为灭圣谛。道谛有二种。一者道谛。二者道圣谛。道谛者出到相。所谓八正道。是名为道谛。道圣谛者。以修故行道。是为道圣谛。复次谛有二种。总相别相。总相苦者。五受阴。别相苦者。广分别色阴受想行识阴。总相集者。能生后身受。别相集者。广分别爱等诸烦恼及有漏业五受阴因缘。总相灭者。能生后身爱尽。别相灭者。广分别八十九种尽。总相道者。八圣道。别相道者。广分别从苦法忍乃至无学道。若不通达四谛者。则轮转五道。往来生死无休息时。以是因缘故。行者应念老病死等一切苦恼皆由有身。譬如一切草木皆从地出。如经中说。十方众生所以有身。皆为受苦故生。譬如毒食。若好若丑皆为杀人。若无身心者。死苦则无所寄。如恶风摧折大树。若无树者则无所坏。如是略说身心受苦之本。如虚空风之本。木是火之本。地是水之本。身是苦之本。复次如地常是坚相。水常为湿相。火常为热相。风常为动相。身心常为苦相。所以者何。以有身故。则老病死饥渴寒热风雨等苦常随逐之。以有心故。忧愁怖畏嗔恼嫉妒等苦常随逐之。若知现在身苦。过去苦亦尔。如现在过去身苦。未来亦尔。譬如见今谷种生谷。比知过去未来亦皆如是。又如现在火热相。比知过去未来火亦热如是。若无身心。前则无苦今亦无苦后亦无苦。当知三世苦痛皆从身心而有。是故应观苦谛。如是心生厌患。是苦因缘。唯从爱等诸烦恼生。非天非时非自然亦非无因缘。若离烦恼则不有生。当知世间皆从爱等烦恼生。如人造事皆欲以为先。以是故诸烦恼是苦因缘。复次由爱水故受身。若无爱水则不受身。如干土不能着壁。以水和之则有所著。复次因诸烦恼是故受身种种不同。如多欲者受多欲形。多嗔恚者受多嗔恚形。多痴者受多痴形。烦恼薄者受薄烦恼形。见今果报异故。知昔因缘各别。来世随烦恼受身差别亦如是。随业受身。若不为嗔恚则不受毒蛇形。一切余形亦如是。以是故当知爱等诸烦恼一切苦因缘。苦因缘尽故则苦尽涅槃。涅槃名离欲。断诸烦恼常不变异。是中无生无老无病无死。无爱别离苦怨憎会苦。常乐不退。行者得涅槃灭度时都无所去。名为寂灭。譬如然灯膏尽则灭不至诸方。是名灭谛。得涅槃方便道。定分有三种。慧分有二种。戒分有三种。住是戒中修行定慧。所谓于四谛中慧能决了。是名正见。随正见觉法发起。是为正思惟。是名慧分二种。正定正念正精进。是名定分三种。正语正业正命。是名戒分三种。住净戒故。诸烦恼芽不令增长。势力衰薄。如非时种芽不增长。诸烦恼力来。定分能遮。如大山堰水。水不能破坏。譬如咒术能禁毒蛇。虽复有毒不能害人。定分亦如是。慧能拔诸烦恼根本。如夏水暴涨岸上诸树无不漂拔。行此三分八道真直正路。能灭苦因。毕竟安隐常乐无为。若方便初习其门则有十事。一者心专正。种种外事来坏不能移转。如四边风起山不倾动。二者质直。闻师说法不见长短。心无增减随教无疑。譬如入稠林采木直者易出曲者难出。如是三界稠林。直者易出曲者难出。佛法中唯直是用曲者遗弃。三者惭愧。是第一上服最妙庄严。惭愧为钩制诸恶心。有惭有愧真为是人。若无惭愧畜生无异。四者不放逸。一切善法之根本。如世间放逸失诸利事。行者放逸失涅槃利。当知放逸如怨如贼。心常远离。当知不放逸如君父师长。应遵承不舍。五者远离。因此远离成不放逸。若近五欲诸情开发。先常身离聚落。次心远离不念世事。六者少欲。资生之物心不多求。多求故则堕众恼。七者知足。有人虽复少欲。乐着好物则败道心。是故智者趣足而已。八者心不系着。若弟子檀越知识亲里。若问讯迎送多营多事。如是等者毁败道故不应系着。九者不乐世乐。若歌舞伎乐。良时好日选择吉凶。一切世事悉不喜乐。十者忍辱。行者求道时。当忍十事。一蚊虻侵害。二蛇蚖毒螫。三者毒兽。四者骂詈诽谤。五者打掷加害。六者病痛。七饥。八渴。九寒。十热。如是恼事。行者忍之莫令有胜。常胜此事。复次如人识知病相。知病因缘。知除病药。得看病人。随意所须不久当差。行者如是。知实苦相。知苦因缘。知苦尽道。知得善师同学。如是不久得安隐寂灭。问曰。以得非想非非想处入深禅定。唯有上地结使微薄。心已柔软。不应种种因缘种种譬喻观是四谛。似若不信。答曰非但为有顶者说。总为一切有顶之人。但观无色界四阴无常苦空无我。如病如疮如箭入心无常苦空无我。皆是因缘虚诳作法。观涅槃上妙安隐快乐非为作法真实不虚。灭三毒三衰。身心苦灭。常呵四阴及其因缘。则名苦谛集谛。赞叹涅槃及涅槃道。是名尽谛道谛。行者得四禅四无色定。心已柔软。若求五神通。依第四禅则易得。若依初禅二禅三禅虽复可得。求之甚难得亦不固。所以者何。初禅觉观乱定故。二禅喜多故。三禅乐多故。与定相违。四如意分皆是定相。唯第四禅无苦无乐无忧无喜。无出入息。诸圣所住快乐安隐。是故行者当依第四禅修四如意分。所谓欲定行法成就如意。精进定心定思惟定行法成就如意。依是住者无事不得。问曰。云何欲定行法成就如意。答曰。欲名欲于所求之事。定名一心无有增减。行法名信念巧慧喜乐等助成欲定。因欲为主。得定故名为欲定。精进定心定思惟定亦如是。行者观欲莫令有增有减。莫令内多摄外多散。柔软平等调和堪用。犹如弹琴调其缓急。随作何曲。精进心思惟亦尔。如行者。学飞欲飞是名欲。摄诸散心集助行法。是名精进心。能举身离身心粗重睡掉等。心则轻便。以心轻故能举其身。是名心。筹量欲精进心多少。能举身未能坏内外诸色味。是名思惟。依四如意分。能具足一切功德。何况五通。问曰。五神通何者先生。答曰。随所乐者为先。问曰。若尔者何以变化神通在初。答曰。五神通多为众生。所以者何。如慧解脱阿罗汉。既得阿罗汉作是念言。有众生多钝根者。不信道事轻慢佛法。我得难事漏尽神通。如何不起神通教化众生而令堕罪。又佛大悲利益众生。我为弟子。应以神通助益众生。然诸众生多以现事而得利益。神变感动贵贱大众无不倾伏。余通无有是者。以是故变化神通在初。问曰。天身火大多故身有光明。亦能升虚疾去。鬼神风大多故身则轻疾。无所触碍。龙身水多故心念生水。亦能变动。人身地大多故轻动相少。云何能飞。答曰。以人身地种轻动相少故。求学神通。如天如神何用通为。如地虽重。以水力故地则为动。如是心力故能举其身。譬如猕猴从高坠落而不伤身。人堕则伤。以猕猴心力轻疾强故无损。当知身通如是。心力强故。又如人能浮。虽在深水而不沉没。心方便力故能持其身。以是故当知。人身虽重。心力强故身飞虚空。问曰。如是可信云何当学。答曰。若行者住于第四禅。依四如意分。一心摄念观身。处处虚空如藕根孔。取身轻疾相。习之不已。身与心合。如铁与火合。灭身粗重相。但有轻疾身。与欲精进思惟及助行法合。欲等善行力故。身则随逐如火在铁轻软中用。又复色界四大造色。在此身中与身和合。令身轻便随意能去。如人服药。令心了了身则轻便。譬如色界四大造色明净。在此身故眼则明净。如人学跳习之转工绝于余人。如鸟子学飞渐渐转远。身通如是。初得之时。或一丈二丈。渐能远飞。是变化神通有四种。一者身飞虚空如鸟飞行。二者远能令近。三者此灭彼出。四者犹如意疾。弹指之顷有六十念。一念中间能越无量阿僧祇恒河沙国土。随念即至。用是神通身得自在。一身能为多身。多身能为一身。大能为小小能为大。重若须弥轻如鸿毛。如是等所作如意。复次菩萨得是身通。一念之顷度恒河沙国土。然众生见菩萨到彼。而菩萨不动于本处。于彼说法教化。此亦不废。或有天人着常颠倒。可以神通度者。现烧三千大千国土。而众生见三千大千国土焚烧破坏。而国土无损。有众生心生憍慢。现作手执金刚杵。从金刚中出火。见者怖畏归伏礼敬。有人乐着转轮圣王身。即现转轮圣王而为说法。或现释提桓因。或现魔王。或现声闻辟支佛。或现佛身。随所乐身而为说法。菩萨或复在虚空中结加趺坐。从身四边悉放种种光明而为说法。或时众生乐杂色庄严。即为现三千大千国土七宝庄严幢幡华盖百种伎乐。处中说法。或令三千大千国土为一海水。青莲红华覆盖水上。于上说法。或坐须弥山上。以梵音声说法。普闻诸国。或时众生不见其形。但闻说法之声。或作乾闼婆身。伎乐音声令其心悦。然后说法。或现龙王雷电霹雳。而以说法。如是种种因缘方便。而现神变开引众生。问曰。是神通变化诸物。云何而不虚妄。答曰。行者先知诸法虚诳如幻如化。譬如调泥随意所作。如福德之人尚能夏有雪冬生华河不流。又如仙人嗔怒令虎狼师子变为石身。何况神通定力而不变物。复次一切物中各有气分。取其分相神力广之。余者隐没。如经说。有比丘神力心得自在。见有大木欲令为地即皆是地。所以者何。木有地分故。若水火风亦如是。若作金银种种宝物。随意悉作。何以故。木有净分故。问曰。物变如是化无本末。其事云何。答曰。有言虚空中四大所造微尘。化心力故令诸微尘合成化人。譬如人死或生天上或生地狱。罪福因缘故。和合微尘为化亦如是等是物变化神通相。若行者欲求天耳。亦以第四禅为本。修四如意分。如上所说。调柔其心。属念大众音声。取种种声相。所闻之声常当想念。若心余缘摄之令还。常当一心修念。即于耳中。得色界四大所造清净之色。是名修习天耳。以是天耳。闻十方无量国土音声。所谓天声人声龙声。阿修罗声。乾闼婆声。栴陀罗声。摩睺勒声。及畜生饿鬼之声。地狱苦痛粗细大小音声等。皆悉听闻。菩萨定心转深。乃闻十方诸佛音声。从佛闻法而不取相。以法为真法为最上。而依深义不依于语。云何深义。所谓知诸法空无相无作。不生邪见。于义亦不得义。不可得中亦无得相是依深义不依语言。复次行者依了义经。不依非了义经。了义经者。若能依义。一切诸经皆是了义。义毕竟空不可说相故。是以诸经皆是了义。若不依义。是人于诸经皆不了义。所以者何。以无深智。随逐音声故。是音声实相亦入深义。俱不可说。是名分别了义经不非了义经。复次行者依智而不依识。何以故。行者知是识相。从因缘和合生。无有自性。无色无对不可见。无知无识虚诳如幻。如是知识相。识即为智。是故依智而不依识。行者虽复生识。若识若智而不生着。知识如相。识即为智相。以是智相为众生说。复次行者依法不依人。何以故。若佛法中实有人者。无有清净得解脱者。而一切法无我无人。但随俗故说有人有我。以是故行者依法不依人。所谓法者诸法之性。法性者无生性。是无生性者毕竟空。是毕竟空者不可说者是。何以故。以语说法。法中无语语中无法。语则是无语相。一切语言非语言相。以是故经说。无示无说是名佛法。行者以天耳闻诸佛法。若人若法不生着见。若分别二相非为佛法。若无二相则是佛法。行者依止天耳力故。闻甚深之法。以教化众生。是名天耳神通。若行者欲得他心智。先自观心。取心生相住相灭相。亦知心垢相净相定相乱相等。复观心所缘垢净近远多少等。自取内外心相已。然缘观众生色。取欲相心。嗔相心。慢相心。悭相心。嫉相心。忧相心。畏相心。语言音声种种所作相心等。作是念。佛如我心。生时住时灭时。彼亦如是。自知心所缘。他亦如是。我心有如是色相语言所作相。他亦如是。常修学心相。如是习已得他心通。是时但缘他心心数法。如明眼者观净水中鱼。有大小好丑悉皆见之虽有水覆。以水净故不以为碍。行者如是。知他心通力故。众生虽身覆心而能见之。既得心通。或时在大众说法。先知其心。知是众生以何深心行何法。何因缘有何相喜何事。知自心清净故。知众生心亦可清净。如净镜中随所有色若长若短方圆粗细等如本相现不增不减。所以者何。镜清净故。镜虽不分别而显其相。行者亦如是。自心清净故。诸法无一定相。常清净故。众生心心数法皆悉知之。若众中多淫欲者。即知其心。为说离淫欲法。恚痴亦如是。何以故。心实相无染无嗔无痴。若众中求声闻乘者。亦知其心而为说法。虽为说法。知法性亦无有小。求辟支佛道者。亦知其心而为说法。虽为说法。知法性亦无有中。若求大乘者。亦知其心而为说法。虽为说法。知法性亦无有大。行者如是。等随众生心而为说法。亦不分别心相。虽分别三乘说法。而不坏法性。不坏法性故悉知一切众生心所行。虽自用心知他心。于彼此心无逆无顺。亦知一切众生心心相续如水流。如知心性。法性亦如是。以他心智知众生心而为说法。则不害也。是名知他心智神通

若行者欲知宿命。先自觉知今所经事向所经事。转至昨夜昨日前日。如是一月。从今岁乃至孩童。譬如行道。到所至处思惟忆念所经游处。如是习已。善修定力故。忆念生时处胎时。知某处死此胎生。知是一世二世三世乃至百世千万无量亿世。以宿命智。自知己身及他恒河沙劫所经由事。悉皆念知。以宿命事教化众生。作如是言。我某处如是姓字如是生如是寿命所经苦乐。亦说彼所经之事。行者以宿命力故。知是众生先世罪福因缘。所谓种声闻因缘辟支佛因缘佛因缘。随其因缘而为说法。复次行者宿命智力故。自知从诸佛种善根不回向阿耨多罗三藐三菩提。今当回向阿耨多罗三藐三菩提。行者亦知过去诸法灭时无所去。知未来世诸法生时无所从来。虽知过去世无始。不生无始见。虽观未来世众生灭入涅槃。亦不生边见。行者念宿命时。增益诸善根。及灭无量世罪因缘。何以故。知一切法无新相无故相。得如是智慧已观一切有为法及所经生死苦乐。如梦中所见。以是故于生死中心不生厌。于一切众生而起悲心。知一切法皆是作相。作是念。如我千万亿无量劫往来生死。皆为虚妄非实。一切众生来往生死皆亦如是。若无四大四阴者。是则为实。四大四阴亦毕竟不生。复次行者以宿命智忆念。曾为转轮圣王。所受之乐无常磨灭。释提桓因乐亦无常磨灭。有诸国土清净庄严。及诸菩萨诸佛上妙之色。转于法轮皆悉无常。何况余事。念如是已心厌远离。行者依宿命智入无常空。观一切诸法皆空无常。而众生颠倒故着。为是众生故而生悲心。行是悲心。渐渐得成大悲。得大悲已。十方诸佛念是菩萨赞叹其德。是名宿命神通

若行者欲求天眼者。初取明光相。所谓灯火明珠日月星宿等。取是明相已。若昼日则闭目。夜则无在念上明相如眼所见。常修习明念。系心在明不令他念。若去摄还心得一处。是时色界四大所造清净之色在此眼中。是眼名天。以天四大造故。名为天眼。又诸贤圣清净眼故。名为天眼。行者得是天眼已。诸山树木铁围须弥及诸国土。都无障蔽。以无碍眼。能见十方无量阿僧祇诸佛及庄严国土。尔时行者能知一切佛为一佛。又见一佛为一切佛。以法性不坏故。如见佛相。自见身相亦如是。自身相净故。一切法相亦如是。如见佛清净弟子亦尔。无有二相。及十方无量国土众生。若地狱畜生饿鬼人天。除无色者。生死好丑皆悉见之。皆知十方六道众生业因缘及果报。是众生以善业因缘故生天人中。是众生以不善业因缘故生三恶道中。行者于天眼中得智慧力故。虽见众生不生众生想。一切法无众生想故。虽见业及果报相续。亦入一切法无业无果报中。虽天眼见一切色。以智慧力故亦不取色相。是色悉皆空故。复次若障若不障近远上下无不悉见。行者见色界诸天清净微形者。而彼不见。乃至大天亦复不见。如是等种种神通义。如摩诃衍神通义中广说

禅法要解卷下


禅秘要法经

    No. 613

禅秘要法经卷上

        后秦弘始年鸠摩罗什等于长安逍遥园译

如是我闻。一时佛住王舍城迦兰陀竹园。与大比丘众千二百五十人俱。复有五百大德声闻。舍利弗大目揵连摩诃迦叶摩诃迦旃延等。尔时王舍城中。有一比丘。名摩诃迦絺罗难陀。聪慧多智。来至佛所。为佛作礼。绕佛七匝。尔时世尊。入深禅定。默然无言。时迦絺罗难陀。见佛入定。即往舍利弗所。头面礼足白言。大德舍利弗。唯愿为我广说法要。尔时舍利弗。即便为说四谛。分别义趣。一遍乃至六遍。时迦絺罗难陀。心疑未寤。如是乃至遍礼五百声闻足。请说法要。诸声闻等。亦各七遍。为转四真谛法。时迦絺罗难陀。心亦不寤复还佛所。为佛作礼。尔时世尊。从禅定起。见迦絺罗难陀顶礼佛足。泪如盛雨。劝请世尊。唯愿为我转正法轮尔时世尊。复为广说四真谛法。一遍乃至七遍。时迦絺罗难陀。犹故未解五百天子。闻佛所说。得法眼净。即持天华。以供养佛。白佛言。世尊我等。今者因迦絺罗难陀比丘。快得法利见法。如法成须陀洹。时迦絺罗难陀闻诸天语。心怀惭愧。悲咽无言。举身投地。如太山崩。即于佛前。四体布地。向佛忏悔。尔时阿难。即从坐起。整衣服。偏袒右肩。为佛作礼绕佛三匝。胡跪合掌。白佛言。世尊此迦絺罗难陀比丘。有何因缘。生而多智。四毗陀论。违世羁经。日月星辰。一切技艺无不通达。复有何罪。出家以来。经历多年。于佛法味。独不得尝。如来世尊。亲为说法。如生聋人。无闻无得。佛法大将随顺转法轮者数有五百。为其说法。亦无有益。唯愿天尊。为我分别说此比丘往昔因缘。阿难问时。佛即微笑。有五色光。从口中出。绕佛七匝。还从顶入。告阿难言。谛听谛听。善思念之。我当为汝分别解说。阿难白佛言。唯然世尊。愿乐欲闻。佛告阿难。此迦絺罗难陀比丘。过去久远无数劫时。有佛世尊。名曰然灯如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛法中。有一比丘。名阿纯难陀。聪明多智。以多智故憍慢放逸。亦不修习四念处。法身坏命。终堕黑闇地狱。从地狱出。生龙象中。五百身中。恒作龙王。五百身中。恒作象王。舍畜生身。因前出家持戒力故。得生天上。天上命终。来生人间。前身读诵三藏经故。今得值佛。由前放逸不修四念处。是故今身不能觉寤。尔时迦絺罗难陀。闻佛此语。即从坐起。合掌长跪。白佛言。世尊唯愿天尊教我系念。尔时佛告迦絺罗难陀。谛听谛听。善思念之。汝于今日。快问如来灭乱心贼。甘露正法。三世诸佛。治烦恼药。关闭一切诸放逸门。普为人天。开八正道汝好谛观。莫令心乱。佛说此语时。众中有五十摩诃罗比丘。亦白阿难。世尊今者欲说除放逸法。我等随顺欲学此事。唯愿尊者。为我白佛说此语时。佛告诸比丘。非但为汝。亦为未来诸放逸者。我今于此迦兰竹园。为迦絺罗难陀比丘。说系念法。佛告迦絺罗难陀。汝受我语。慎莫忘失。汝从今日。修沙门法。沙门法者。应当静处敷尼师坛。结跏趺坐。齐整衣服。正身端坐。偏袒右肩。左手着右手上。闭目以舌拄齶。定心令住。不使分散先当系念着左脚大指上。谛观指半节。作泡起想。谛观极使明了。然后作泡溃想。见指半节极令白净。如有白光。见此事已。次观一节。令肉劈去。见指一节。极令明了。如有白光。佛告迦絺罗难陀。如是名系念法。迦絺罗难陀。闻佛所说。欢喜奉行

观一节已。次观二节。观二节已。次观三节。观三节已。心渐广大。当观五节。见脚五节。如有白光。白骨分明。如是系心。谛观五节。不令驰散。心若驰散摄令使还。如前念半节。念想成时。举身暖熅心下热。得此想时。名系心住。心既住已。复当起想。令足趺肉两向披。见足趺骨。极令了了。见足趺骨。白如珂雪。此想成已。次观踝骨。使肉两向披。亦见踝骨。极令皎白。次观胫骨。使肉褫落。自见胫骨。皎然大白。次观膝骨。亦使皎然分明。次观臗骨。亦使极白。次观胁骨。想肉从一一胁间两向褫落。但见胁骨。白如珂雪。乃至见于脊骨。极令分明。次观肩骨。想肩肉如以刀割。从肩至肘。从肘至腕。从腕至掌。从掌至指端。皆令肉两向披。见半身白骨。见半身白骨已。次观头皮。见头皮已。次观薄皮。观薄皮已。次观膜。观膜已。次观脑。观脑已。次观肪。观肪已。次观咽喉。观咽喉已。次观肺腧。观肺腧已。见心肺肝大肠小肠脾肾生藏熟藏四十户虫。在生藏中。户领八十亿小虫。一一虫从诸脉生。孚乳产生。凡有三亿。口含生藏。一一虫有四十九头。其头尾细犹如针锋。此诸虫等二十户是火虫。从火精生。二十户是风虫。从风气起是诸虫等。出入诸脉。游戏自在火虫动风。风虫动火。更相呼吸。以熟生藏。上下往复凡有七反。此诸虫等各有七眼。眼皆出火。复有七身吸火动身。以熟生藏。生藏熟已。各复还走入诸脉中复有四十户虫。户领三亿小虫身赤如火。虫有十二头。头有四口。口含熟藏。脉间流血。皆观令见。见此事已。又见诸虫从咽喉出。又观小肠肝肺脾肾。皆令流注入大肠中。从咽喉出。堕于前地。此想成已。即见前地。屎尿臭处。及诸蛔虫。更相缠缚。诸虫口中。流出脓血。不净盈满。此想成已。自见己身。如白雪人。节节相拄。若见黄黑。当更悔过。既悔过已。自见己身。骨上生皮。皮悉褫落。聚在前地。渐渐长大。如钵多罗。复更长大。似如堈。乃至大如乾闼婆楼。或大或小。随心自在。又渐增长。犹如大山。而有诸虫。唼食此山。流出脓血。有无数虫。游走脓里。复见皮山。渐渐烂坏。唯有少在。诸虫竞食。有四夜叉。忽从地出。眼中出火。舌如毒蛇。而有六头。头各异相。一者如山。二者如猫。三者如虎。四者如狼。五者如狗。六者如鼠。又其两手。犹如猿猴。其十指端。一一皆有四头毒蛇。一者雨水。二者雨土。三者雨石。四者雨火。又其左脚似鸠槃荼鬼。右脚似于毗舍阇鬼。现丑恶形。甚可怖畏。时四夜叉。一一荷负九种死尸。随次行列。住行者前。佛告迦絺罗难陀。是名不净想最初境界。佛告阿难。汝持是语。慎莫忘失。为未来众生。敷演广说此甘露法三乘圣种。时迦絺罗难陀。闻佛说此语。一一谛观。经九十日。不移心想。至七月十五日。僧自恣竟。时诸比丘。礼世尊已。各还所安。于日后分。次第修得四沙门果。三明六通。皆悉具足。心大欢喜。顶礼佛足。白佛言。世尊我于今日。因思惟故。因正受故。依三昧故。生分已尽。不受后有。知如道真。必定得成清净梵行。世尊此法是甘露器。受用此者。食甘露味。唯愿天尊。重为广说。尔时世尊。告迦絺罗难陀。汝今审实得此法者。可随汝意作十八变。时迦絺罗难陀。住立空中。随意自在。作十八变。时诸比丘。见迦絺罗难陀。我慢心多。犹能调伏。随顺佛教。系心一处。不随诸根。成阿罗汉。尔时会中。有千五百比丘。乱心多者。见此事已。皆生欢喜。即诣佛所。次第受法。尔时世尊。因此憍慢比丘摩诃迦絺罗难陀。初制系念法。告诸四众。若比丘。若比丘尼。若优婆塞优婆夷。自今以后。欲求无为道者。应当系念专心一处。若使此心驰骋六根。犹如猿猴。无有惭愧。当知此人。是旃陀罗非贤圣种。心不调顺。阿鼻狱卒。常使此人。如是恶人。于多劫中。无由得度。此乱心贼。生三界种。依因此心。堕三恶道。时诸比丘闻佛所说。欢喜奉行

佛告阿难。汝今见此摩诃迦絺罗难陀比丘。因不净观。得解脱不。汝好受持。为众广说。阿难白佛。唯然受教。佛告阿难。谛听谛听。善思念之。第二观者。系念额上。谛观额中。如爪甲大。慎莫移想。如是观额。令心安住。不生诸想。唯想额上。然后自观头骨。见头骨白如颇梨色。如是渐见举身白骨。皎然白净。身体完全。节节相拄。复见前地诸不净聚如上所说。不净想成时。慎莫弃身。当教易观。易观法者。想诸节间。白光流出。其明炽盛。犹如雪山。见此事已。前不净聚。夜叉吸去。复当想前作一骨人。极令大白。此想成已。次想第二骨人。见二骨人已。见三骨人。见三骨人已。见四骨人。见四骨人已。见五骨人。如是乃至见十骨人。见十骨人已。见二十骨人。见二十骨人已。见三十骨人。见三十骨人已。见四十骨人。见四十骨人已。见一室内。满中骨人。前后左右。行列相向。各举右手。向于行者。是时行者。渐渐广大见一庭内。满中骨人。行行相向。白如珂雪。各举右手。向于行者。心复广大。见一顷地。满中骨人。行行相向。各举右手。向于行者。心渐广大。见一由旬。满中骨人。行行相向。各举右手。向于行者。见一由旬已。乃至见百由旬。满中骨人。行行相向。各举右手。向于行者。见百由旬己。乃至见阎浮提。满中骨人。行行相向。各举右手。向于行者。见一阎浮提已。次见弗婆提。满中骨人。行行相向。各举右手。向于行者。见弗婆提已。次见瞿耶尼。满中骨人。行行相向。各举右手。向于行者。见瞿耶尼已见郁单越。满中骨人。行行相向。各举右手。向于行者。见四天下满中骨人已。身心安隐。无惊怖想。心渐广大。见百阎浮提。满中骨人。行行相向。各举右手。向于行者。见百阎浮提已。见百弗婆提。满中骨人。行行相向。各举右手。向于行者。见百弗婆提已。次见百瞿耶尼。满中骨人。行行相向。各举右手。向于行者。见百瞿耶尼已。次见百郁单越。满中骨人。行行相向。各举右手。向于行者。见此事已。身心安乐。无惊怖想。心想利故。见娑婆世界。满中骨人。皆垂两手。伸舒十指。一切齐立。向于行者。于时行者。见此事已。出定入定。恒见骨人。山河石壁。一切世事。皆悉变化。犹如骨人。尔时行者。见此事已。于四方面。见四大水。其流迅駃。色白如乳。见诸骨人随流沉没。此想成时。复更忏悔。但纯见水。涌住空中。复当起想令水恬静。佛告阿难。此名凡夫心想白骨白光涌出三昧。亦名凡夫心海生死境界相。我今因迦絺罗难陀。为汝及未来一切众生等。说是白骨白光涌出三昧门。为摄乱心渡生死海。汝当受持慎勿忘失。尔时世尊。说此语已。即现白光三昧。一一相貌。皆令阿难悉得见之。尔时阿难。闻佛所说。欢喜奉行。此名白骨观最初境界。佛告阿难。此想成已。更教余想。教余想者。当自观身作一白骨人。极使白净。令头倒下入臗骨中。澄心一处。极使分明。此想成已。观身四面。周匝四方。皆有骨人。此想成已。即于前地。作一白骨人。如似己身。亦复倒头入臗骨中。想一成已。次当想二。想二成已。次当想三。想三成已。次当想四。想四成已。次当想五。想五成已。乃至想十。如是满一房内。见诸骨人。皆悉倒头入臗骨中。见一房内已。乃至见于百房之内。是诸骨人。皆悉倒头入臗骨中。见百房已。见一由旬。满中骨人。皆悉倒头入臗骨中。见一由旬已。乃至见无量诸白骨人。皆悉倒头入臗骨中。此想成已。见诸骨人。各各纵横。悉在前地。或见头破。或见项折。或见颠倒。或见缭戾。或见腰折。或见伸脚。或见缩脚。或见脚骨分为二分。或见头骨倒入胸中。或见头骨。偃仰掣缩。纷乱纵横。悉在前地。周匝上下。满一室内。此想成已。乃至见于无量无边诸白骨人。纷乱纵横。或大或小。或破或完。如此众事。皆当住心谛观。极令分明。佛告阿难。是时行者。见此事已。当自思惟。前骨完具。今者破散纵横纷乱。不可记录。此白骨身。犹尚无定。当知我身。亦复无我。谛观是已。当自思惟。正有纵横诸杂乱骨。何处有我及与他身。尔时行者。思惟无我。身意泰然。安隐快乐。佛告阿难。此想成已。复当更教令心广大。使彼行人见一阎浮提。纵横乱骨。见诸骨外。周匝四面。有大火起。焰焰相次。烧诸乱骨。见诸骨人。节节火起。如是火相。或有众火。犹如流水。明炎炽盛。流诸骨间。或有众火。犹如大山。从四面来。此想成已。极大惊怖。出定之时。身体蒸热。还当摄心。如前观骨。观一白骨人。极令明了。是时行者。入定之时。不能自起。要当弹指。然后得起。此想成者。当自起念而作是言我于前世无数劫来。造热恼法。业缘所牵故。使今者见此火起。复当作念。如此火者。从四大有。我身空寂。四大无主。此大猛火。横从空起。我身他身。悉皆亦空。如此火者。从妄想生。为何所烧。我身及火。二皆无常。佛告阿难。行者应当至心谛观。如是等法。观空无火亦无众骨。作此观者。无有恐惧。身意恬安。倍胜于前。尔时阿难。闻佛所说。欢喜奉行。此想成者。名第二观白骨竟。佛告阿难。观第二白骨竟已。复当更教系念法。系念法者先当系心着左足大指上。一心谛观足大指。使肉青黑津腻。犹如日光炙于肥肉。渐渐至膝。乃至于臗。观左足已。观其右足。亦复如是。观右足已。次当观腰。至背至颈。至项至头。至面至胸。举身支节。一切身分。皆亦津黑。犹如日光炙于肥肉。不净流溢。如屎尿聚。谛观己身。极使分明。想一成已。复当想二。想二成已。复当想三。想三成已。复当想四。想四成已。复当想五。想五成已。复当想十。想十成已。见一室内。满中津黑。犹如日光炙于肥肉。如屎尿聚。诸不净人。行列纵横满一室内。见一室已。复见二室。见二室已。乃至见无量众多不净人。四维上下。皆悉充满娑婆世界。此想成已。行人自念。我于前世。贪淫愚痴。不自觉知。盛年放逸。贪着情色。无有惭愧。随逐色声香味触法。今观我身。不净流溢。他身亦尔。何可爱乐。见此事已。极自厌身。惭愧自责。出定之时。见诸饮食。如屎尿汁。甚可恶厌。次教易观。易观法者。当更起想念。想念成时。见其身外。诸不净间。周匝四面。忽然炎起。如热时焰。其色正白。如野马行。映诸不净。尔时行者。见此事已。当大欢喜。以欢喜故。身心轻软。其心明朗。快乐倍常。佛告阿难。是名第三惭愧自责观。尔时阿难。闻佛所说。欢喜奉行。此想成者。名第三津腻惭愧观竟

佛告阿难。此想成已。复当更教系念住意左脚大指上。令谛观脚大指节。起膖胀想。见膖胀已。起烂坏想。见烂坏已。起青黑赤白诸脓血想。是诸脓血。极使臭处。难可堪忍。如是渐渐。至膝至臗。皆令膖胀烂溃不净。观左脚已。右脚亦然。如是渐渐。至腰。至背。至颈。至项。至头。至面。至胸。举身支节。一切膖胀。皆悉烂坏。青黑赤白。诸脓流出。臭恶杂秽。不可堪处。想一成已。复更想二。想二成已。复更想三。想三成已。复更想四。想四成已。复更想五。想五成已。乃至想十。想十成已。见一室内。周匝上下。诸膖胀人。皆悉烂坏。青黑赤白诸脓。悉皆流出。杂秽臭处。不可堪忍。复当更想一由旬。想一由旬已。乃至想百由旬。想百由旬已。乃至见三千大千世界。周匝上下。地及虚空。一切弥满。膖胀烂坏。青黑赤白诸脓流出。杂秽充满。不可堪处。佛告阿难。尔时行者。见此事已。自观己身。不净充满。观于他身。亦复如是。当作想念。我此身者。甚可患厌。众多不净。弥满一切。谛观是已。畏生死患。其心坚固。深信因果。出定入定。恒见不净。欲求厌离舍弃此身。作此想时。自见己身。举体皮肉。如秋叶落。见肉堕地。在前地已。即大动心。心生惊怖。身心震掉。不能自宁。身气热恼。如热病人。为渴所逼。出定之时。如人夏日行于旷野渴乏无水。身体疲极。此想成已。乃至食时。见所食物。如膖死尸。见所饮浆。犹如脓血。此想成已。极大厌身。观于身内及于身外。求净不得。佛告阿难。复当更教令其易想。莫使弃身。唐无所得。易观法者。当于远处臭秽之外。作一净物。教其系心想一净物。心眼明了。即欲往取。如是渐渐。所见广远。诸不净外。有诸净地。如琉璃地。见此净处。即便欲往。转复广远。意不能达。佛告阿难。尔时当教如此行人而作是言。汝所见事。是不净想。此不净想。而杂秽物。当知此想从颠倒起。皆由前世颠倒行故。而得此身。如此身者。种子根本。皆为不净。汝今实见此不净不。虽见不净。于外见净。当知此净及与不净。不可久停。随逐诸根。忆想见是。此不净身。属诸因缘。缘合则有。缘离则无。尔所见事。亦属缘想。想成则有。想坏则无如此想者。从五情出。还入汝心。诸欲因缘。而有此想。此不净想。来无所从。去无所至。汝当一一谛观不净。求索彼我了不可得。世尊说我及他。皆悉空寂。何况不净。如是种种。呵责其心。教令观空。见发毛爪齿一切悉无豁然舍诸不净之物。如前住意还观骨人。佛告阿难。汝持是语。慎莫忘失。此不净观。及易想法。尔时阿难。闻佛此语欢喜奉行。此想成时。名第四膖胀脓血。及易想观竟

佛告阿难。此想成已。次当更教系念一处。端坐正受。谛观右脚大指上。令指上皮。携携欲穿。薄皮厚皮。内外映彻。其薄皮内。有一薄膜。亦当谛观。如是渐渐。至膝至臗。左脚亦然。至腰至背至颈至项至头至面至胸。举身皆尔。薄皮厚皮。内外映彻携携欲穿。如被吹者。其皮膖胀。不可具说。身诸毛中一一毛孔。百千无量。诸脓杂汁。犹如雨滴。从毛孔出。疾于震雨。内外俱流。脓血盈满。不净之极难可堪忍。犹如脓池。亦如血池。诸虫满中。此想成已。当观胸里。举身是虫。犹如虫聚。复当更观左脚大指。膖胀脓溃。青脓。黄脓。赤脓。黑脓。红脓。绿脓。白脓。烂溃交横。与屎尿杂。复有诸虫。游戏其中。秽恶臭处。不可堪忍。厌患此身不贪诸欲。不乐受生。此想成时。见大夜叉。身如大山。头发蓬乱。如棘刺林。有六十眼。犹如电光。有四十口。口有二牙。皆悉上出。犹如火幢。舌似剑树。吐至于膝。手捉铁棒。棒似刀山。如欲打人。如是众多其数非一见此事时。极大惊怖身心皆动。如此相貌。皆是前身毁犯禁戒。诸恶根本。无我计我。无常计常。不净计净。放逸染着。贪受诸欲。于苦法中。横生乐想。于空法中。起颠倒想。于不净身。起于净想。邪命自活。不计无常。此想成时。复当更教。汝莫惊怖。如此夜叉。是汝恶心猛毒境界。从六大起。六大所成。汝今应当谛观六大。此六大者。地水火风识空。如此一一。汝当谛推。汝身为是地耶。为是水耶。为是火耶。为是风耶。为是识耶。为是空耶。如是一一。谛观此身。从何大起。从何大散。六大无主。身亦无我。汝今云何畏于夜叉。如汝心想。来无所从。去无所至。想见夜叉。亦复如是。但安意坐。设使夜叉来打汝者。欢喜忍受。谛观无我。无我法中无惊怖想但当正心结加趺坐。谛观不净及与夜叉。作一成已。复当作二。如是渐渐。乃至无量。一一谛观。皆令分明。佛告阿难。汝好受持。观薄皮不净法。慎莫忘失。尔时阿难。闻佛所说。欢喜奉行。此想成时。名第五观薄皮竟

佛告阿难。此想成已。复当更教系念着右脚大指上。当谛观脚指使脚膖胀。从脚至头。如吹皮囊膖胀津黑。青瘀难堪。满中白虫。如粳米粒。虫有四头。蠢蠢相逐。更相唼食。肌肉骨髓。皆生诸虫。一切五藏。虫皆食尽。唯有厚皮。在其骨外。其皮厚薄。犹如缯练。诸虫出入。如穿竹叶。内外携携。其皮欲穿。眼中躁痒。有无数虫。穿眼欲出。生眼眶间。身分九孔。亦复如是。诸虫尔时。从厚皮出。入薄皮中。皮遂穿尽。虫皆落地。其数众多。不可称计。作一大聚。犹如虫山。在行者前。更相食啖。或相缠绕。尔时行者。见众多虫已。复当系念谛观一虫。使此一虫。啖诸虫尽。既啖虫已。一虫独在。其心渐大。见向一虫。大如狗许。身体困顿。鼻曲如角。嗅行者前。其眼正赤。如烧铁丸。见此事已。极大惊怖。当自忆念。我身云何。忽然乃尔。作如此事。先见诸虫。更相食啖。今见此虫。形体丑恶。何甚可畏。此想成时。当自观身。我此诸虫。本无今有。已有还无。如此不净。从心想生。来无所从。去无所至。亦非是我。亦非是他。如此身者。六大和合。因缘成之。六大散灭。身亦无常。向者诸虫。来无所从。去无所至。我身虫聚。当有何实。虫亦无主。我亦无我。作是思惟时。所见虫眼。当渐渐小。见此事已。身心和悦。恬然安乐。倍胜于前。佛告阿难。汝好受持是厚皮虫聚观法。慎莫忘失。阿难闻佛所说。欢喜奉行。此想成已。名第六厚皮虫聚观竟

佛告阿难。复当住意系念一处。谛观右脚大指上。从足至头。好谛观之。当使皮肉都尽。肠胃腹肝。肺心脾肾。一切五藏。悉落堕地。唯有筋骨。共相连持。残膜着骨。其色极赤。或如淤泥。或如浊水。作浊水想。持用洗皮。从足至头。皆使如是。自观己身。极令分明观己身已。于现前地。复作一身使在前立。如己无异。想一成已。复当想二。想二成已。复当想三。想三成已。复当想四。想四成已。复当想五。想五成已。乃至想十。想十成已。见一室内。周匝上下。满中皆是。赤色骨人。或有淤泥色者。或有浊水色者。以浊水洗皮。如是众多。渐渐广大。满一由旬想一由旬已。想二由旬。想二由旬已。渐渐广大。想百由旬。想百由旬已。乃至见三千大千世界。满中赤色骨人。或有淤泥色者。或有浊水色者。以浊水洗皮。周匝上下。纵横弥满。佛告阿难。汝今谛观此赤色相。慎莫忘失。尔时阿难。闻佛所说。欢喜奉行。此想成时。名第七极赤淤泥浊水洗皮杂想竟

佛告阿难。复当更教系心住意。观左脚大指。从足至头。如新死人。其色萎黄。当观己身。亦复如是。见萎黄已。当令黄色变成青赤。此想成时。见于前地。有一新死人。其色黄赤。见一已见二。见二已见三。见三已见四。见四已见五。见五已心想利。故恒见己身。如新死人。如是想成见一切人。满阎浮提如新死人。此想成已。转复广大。见三千大千世界。满中新死人。自见己身及以他身。等无有异。此想成时。心意惙然。贪欲转薄佛告阿难。汝好谛观是新死想。慎莫忘失。尔时阿难。闻佛所说欢喜奉行。此想成时。名第八新死想竟

佛告阿难。复当更教系念住意。谛观左脚大指上。从足至头。使心不散。见身诸骨。一一分明。共相支拄。亦相连持。无有破者。毛发爪齿。皆悉具足。皎然大白。见己身已。往复反覆。想令白净。想一身已。复想二身。想二身已。复想三身。想三身已。复想四身。想四身已。复想五身。乃至于十。想十身已。见一室内。周匝上下。悉是骨人。毛发爪齿。皆悉具足白中。白如珂雪。见一室已。复见百室。见百室已。见一阎浮提。见一阎浮提已。乃至见三千大千世界。满中骨人。毛发爪齿。皆悉具足。其色极白。白如珂雪。此想成时。心意恬安。欢喜倍常。佛告阿难。汝好谛观具身骨想。慎莫忘失。尔时阿难。闻佛所说。欢喜奉行。此想成时。名第九具身想竟

佛告阿难。复当更教系心住意谛观右足大指两节间。令心专住。无分散意。观两节使相离去。唯角相拄。观两节已从足至头。皆令如是。使节节解。唯角相拄。从头至足。有三百六十三解一一谛观。令节节各解。若不足者。安心谛观。令节节各解。唯角相拄。观己身已。当观他身。观见一已。观见二。观二已。观见三。观三已。观见四。观四已。观见五。观五已。乃至观见无量。诸白骨人。节节各解。唯角相拄。见此事已复见四方。众多骨人亦复如是。得此观时。当自然见诸骨人外。犹如大海。恬静澄清。其心明利。见种种杂色光围绕四边。见此事已。心意自然安隐快乐。身心清净无忧喜想。佛告阿难。汝好谛观此节节解想。慎莫忘失。阿难闻佛所说。欢喜奉行。得此观者名第十节节解观竟

佛告阿难。此想成已。复当更教系念住意。谛观右脚大指两节间。令节相离。如三指许。作白光想。持用支拄。若夜坐时作月光想若昼坐时。作日光想。连持诸骨。莫令解散。从足至头。三百六十三解。皆令相离。如三指许以白光持。不令散落昼日坐时。以日光持。若夜坐时。以月光持。观诸节间。皆令白光出。得此观时。当自然于日光中。见一丈六佛。圆光一寻。左右上下。亦各一寻。躯体金色。举身光明。炎赤端严。三十二相。八十种好。皆悉炳然。一一相好。分明得见。如佛在世等无有异。若见此时。慎莫作礼。但当安意谛观诸法。当作是念。佛说诸法无来无去。一切性相。皆亦空寂。诸佛如来。是解脱身。解脱身者。则是真如。真如法中。无见无得。作此想时。自然当见一切诸佛。以见佛故心意泰然。恬怕快乐。佛告阿难。汝今谛观是流光白骨。慎莫忘失。尔时阿难。闻佛所说。欢喜奉行。得此观者。名第十一白骨流光观竟

佛告阿难得此观已。复当更教系心住意。谛观脊骨。于脊骨间。以定心力作一高台想。自观己身。如白玉人结加趺坐。以白骨光普照一切。作此观时。极使分明。坐此台已。如神通人。住须弥山顶。观见四方。无有障阂。自见故身。了了分明。见诸骨人。白如珂雪。行行相向。身体完具。无一缺落。满于三千大千世界。此名白光想成。次见纵骨。亦满三千大千世界。复见横骨。亦满三千大千世界。见青色骨人。行行相向。满三千大千世界。复见黑色骨人。行行相向。满三千大千世界。复见膖胀人。行行相向。满三千大千世界。复见脓癞人。复见脓血涂身人。满三千大千世界。复见烂坏举身虫出人。满三千大千世界。复见薄皮覆身人。满三千大千世界。复见皮骨相离人。满三千大千世界。复见赤如血色人。满三千大千世界。复见浊水色人。满三千大千世界。复见淤泥色人。满三千大千世界。复见白骨人。毛发爪齿。共相连持。满三千大千世界。次见三百六十三节解。唯角相拄。如此骨人。满三千大千世界。次见节节两向解离相去三指许间有白光人。满三千大千世界。次见散白骨人。唯有白光。共相连持。满三千大千世界。如是当见众多白骨人。数不可说。得此观时。当起想念。我此身者。从四大起。枝叶种子。乃至如是不净之甚。极可患厌。如此境界。从我心起。心想则成。不想不见。当知此想是假观见。从虚妄见。属诸因缘。我今当观诸法因缘。云何名诸法因缘。诸法因缘者。从四大起。四大者。地水火风。复当观是风大。从四方起。一一风大。犹如大蛇。各有四头。二上二下。众多耳中。皆出是风。此观成时。风变为火。一一毒蛇。吐诸火山。其山高峻。甚可怖畏。有诸夜叉。住火山中。动身吸火。毛孔出风。如是变状。遍满一室。满一室已。复满二室。满二室已。渐渐广大。满一由旬。满一由旬已。满二由旬。满二由旬已。满三由旬。满三由旬已。转复广大满阎浮提。见诸夜叉。在火山中。吸火负山。毛孔出风。周慞驰走。遍阎浮提。复惊夜叉以逼行者。见此事时。心大惊怖。求易观法。易观法者。先观佛像。于诸火光端。各作一丈六佛像想。此想成时。火渐渐歇。变成莲华。众多火山。如真金聚。内外映彻。诸夜叉鬼。似白玉人。唯有风大。回旋宛转。吹诸莲华。无数化佛。住立空中。放大光明。如金刚山。是时诸风静然不动。时四毒蛇。口中吐水。其水五色。遍满一床。满一床已。复满二床。满二床已。次满三床。如是乃至。遍满一室。满一室已。次满二室。满二室已。次满三室。如是乃至遍满十室。水满十室已。见五色水。色色之中各有白光。如颇梨幢。有十四重。节节皆空。白水涌出。停住空中。此想成。时行者自见身内心中。有一毒龙。龙有六头。绕心七匝。二头吐水。二头吐火。二头吐石。耳中出风。身诸毛孔。各生九十九毒蛇。如是诸蛇。二上二下。诸龙吐水。从足下出。流入白水。如是渐渐。满一由旬。皆见是事。满一由旬已。复满二由旬。满二由旬已。满三由旬。如是乃至满阎浮提。满阎浮提已。是时毒龙。从脐而出。渐渐上向。入于眼中。从眼而出。住于顶上。尔时诸水中。有一大树。枝叶四布。遍覆一切。如此毒龙。不离己身。吐舌树上。是龙舌上。有八百鬼。或有鬼神。头上戴山。两手如蛇。两脚似狗。复有鬼神。头似龙头。举身毛孔。有百千眼。眼中火出。齿如刀山。宛转在地。复有诸鬼。一一鬼形。有九十九头。各有九十九手。其头形状。极为丑恶。似狗野干。似狸似猫。似狐似鼠。是诸鬼颈。各负猕猴。是诸恶鬼。游戏水中。或有上树腾跃透掷。有夜叉鬼。头上火起。是诸猕猴。以水灭火。不能制止。遂使增长。如是猛火。从其水中颇梨幢边忽然炽盛。烧颇梨幢。如融真金。焰焰相次。绕身十匝。住行者上。如真金盖。有诸罗网。弥覆树上。此真金盖。足满三重。尔时地下。忽然复有四大恶鬼。有百千耳。耳出水火。身毛孔中。雨诸微尘。口中吐风。充满世界。有八万四千诸罗刹鬼。双牙上出。高一由旬。身毛孔中。霹雳火起。如是众多。走戏水中。复有虎狼师子豺豹鸟兽。从火山出。游戏水中。见是事时。一一骨人。满娑婆界。各举右手。时诸罗刹。手执铁叉。擎诸骨人。积聚一处。尔时复有九色骨人。行行相次。来至行者所。如是众多。百千境界。不可具说。佛告阿难。此想成时。名四大观。汝好受持慎勿忘失。尔时阿难。闻佛所说。欢喜奉行。此想成时。名第十二地大观火大观风大观水大观。亦名九十八使境界

佛告阿难。此想成已。复当更教系念住意。谛观腰中脊骨。想诸脊骨。白如珂雪。见脊骨已。见举身骨。节节相拄。转复明净。白如颇梨。见一一骨。支节大小。一一皆明。如颇梨镜。火大风水地大。是诸境界。皆于一节中现。此想成时。见下方地。从于床下。渐渐就开。见一床下地已。复见二床下地。见二床下地已。复见三床下地。见三床下地已。渐见一室内。见一室内已。次见二室内。见二室内已。渐见三室内。见三室内已。复见一庭中地。渐渐就开。见此事时。应当谛观。乃至下方。无有障阂。下方风轮中。有诸风起。向诸夜叉。皆吸此风。吸此风已。身诸毛孔。生鸠槃荼。一一鸠槃荼。吐诸山火。满大千世界。是诸山间。忽然复有无量妙女。鼓乐弦歌。至行者前。罗刹复来。争取食之。行者见已。极大惊怖。不自胜持。出定之时。恒患心痛。顶骨欲破。摄心入定。如前悉见四大境界。见此境界已。四大定力故。自见身体。白如玉人。节节上火起。节节下水流。耳中风出。眼中雨石。见此事已。于其前地。有十蚖蛇。其身长大。五百由旬。有千二百足。足似毒龙。身出水火。宛转于地。此想成时。但当至心忏悔先罪。出定之时。不得多语。于寂静处。一心系念。唯除食时。复当忏悔服诸酥药。然后方当易此观法。佛告阿难。此观名为第二四大观。汝好受持。慎勿忘失。尔时阿难。闻佛所说。欢喜奉行。此想成时。名第十三结使根本观竟

佛告阿难。此想成已。当更易观。易观法者。火大动时。应起山想。当想诸山。犹如冰霜。为火所融。如是猛火。极大炽盛。火炽盛时。身体蒸热。复更想龙。令雨诸石。以掩猛火。复当想石使碎如尘。龙复吐风。聚诸微尘。积至成山。无量林木。荆棘丛刺。皆自然生。尔时白水。五色具足。流诸刺间。如是诸水。住山顶上。犹如积水。凝然不动。此想成已。名第十四易观法

佛告阿难。若有比丘比丘尼。优婆塞优婆夷。三昧正受者。汝当教是易观法。慎勿忘失。此四大观。若有得者。佛听服食酥肉等药。其食肉时。洗令无味。当如饥世食子肉想。我今此身。若不食肉。发狂而死。是故佛于舍卫国。敕诸比丘。为修禅故。得食三种清净之肉。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。教易观已。复当更教如前系念住意。谛观脊骨。复使白净。过前数倍。于二节间。以明净故。得见一切诸秽恶事。此想成时。当自观身作一骨人。节节之中。白净明显。如颇梨镜。阎浮提中。一切骨人。及四大观。所有境界。皆于一节中。现见此事已。见诸骨人。从东方来。向于行者。行行相次。数如微尘。如是东方。满娑婆世界。诸白骨人。皆行行相次。来向行者。南西北方。四维上下。亦复如是。复有青色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有淤泥色骨人。行行相次。来向行者。满阎浮提渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有浊水色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有赤色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有红色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有脓血涂身骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有黄色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有绿色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有紫色骨人。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。复有那利疮色骨人。于诸节间。二节流出十六色。诸恶杂脓。行行相次。来向行者。满阎浮提。渐渐广大。乃至东方。满娑婆世界。南西北方。四维上下。亦复如是。此想成时。行者惊怖。见诸夜叉。欲来啖己。尔时复当见诸骨人。节节火起。焰焰相次。遍满娑婆世界。复见骨人顶上。涌出诸水。如颇梨幢。复见骨人头上。一切众火。化为石山。是时诸龙。耳出诸风。吹火动山。是时诸山。旋住空中。如窑家轮。而无分阂。见此事已。极大惊怖。以惊怖故。有一亿鬼。担山吐火。形状各异。来至其所

佛告阿难。若有比丘。正念安住。修不放逸。见此事时。当教诸法空无我观。出定之时。亦当劝进令至智者所。问甚深空义。闻空义已。应当自观我身者依因父母不净和合。筋缠血涂。三十六物。污露不净属诸业缘。从无明起。今观此身无一可爱。如朽败物作是思惟。时诸骨人。皆来逼己。当伸右手。以指弹诸骨人。而作是念。如此骨人。从虚妄想强分别现。我身亦尔。从四大生。六入村落。所共居止。何况诸骨。从虚妄出。作是念时。诸白骨人。碎散如尘。积聚在地。如白雪山。众多杂色骨人。有一大虺。忽然吞食。于白雪山上。有一白玉人。身体端严。高三十六由旬。颈赤如火。眼有白光。时诸白水并颇梨幢。悉皆自然入白玉人顶。龙鬼蛇虺。猕猴师子狸猫之属。悉皆惊走。畏大火故。寻树上下。身诸毛孔。九十九蛇。悉在树上。尔时毒龙。宛转绕树。复见黑象在树下立。见此事时。应当深心六时忏悔。不乐多语。在空闲处。思诸法空。诸法空中无地无水。亦无风火。色是颠倒从幻法生。受是因缘。从诸业生。想为颠倒。是不住法。识为不见。属诸业缘。生贪爱种。如是种种。谛观此身。地大者从空见有。空见亦空。云何为坚想地。如是推析。何者是地。作是观已。名观外地。一一谛观。地大无主。作是想时。见白骨山。复更碎坏。犹如微尘。唯骨人在于微尘间。有诸白光。共相连持于白光间。复生种种四色光明。于光明间。复起猛火。烧诸夜叉。时诸夜叉。为火所逼。悉走上树。未至树上。黑象踏蹴。夜叉出火。烧黑象脚。黑象是时。作声鸣吼。如师子吼音。演说若空无常无我。亦说此身是败坏法。不久当灭。黑象说已。与夜叉战。夜叉以大铁叉刺黑象心。黑象复吼。一房地动。是时大树。根茎枝叶。一时动摇。龙亦吐火。欲烧此树。诸蛇惊张。各申九十九头。以救此树。是时夜叉。复更惊起。手执大石。欲掷黑象。黑象即前。以鼻受石。掷置树上。石至树上。状似刀山。是夜叉奋身大踊。身诸毛孔。出诸毒龙。龙有四头。吐诸烟焰。甚可怖畏。此想成时。自见己身。身内心处。深如坑井井中有蛇吐毒上下。现于井上。有摩尼珠。以十四丝系悬在虚空时彼毒蛇。仰口吸珠。了不能得。失舍躄地。迷闷无知。是时口火还入顶中。行者若见此事。当起忏悔。乞适意食调和四大。极令安隐。当坐密屋无鸟雀声处。佛告阿难。若比丘比丘尼。优婆塞优婆夷得此观者名得地大观当勤系念。慎莫放逸若修不放逸。行疾于流水。当得顶法。虽复懒惰已舍三涂恶道之处。舍身他世。生兜率天。值遇弥勒。为说苦空无常等法。豁然意解。成阿那含果。佛告阿难。汝今谛受地大观法慎勿忘失。为未来世一切众生敷演广说。尔时阿难。闻佛所说。欢喜奉行。得此观者。名第十四地大观竟。亦名分别四大相貌。复名见五阴粗相。有智慧者。亦能自知结使多少。四念处中。名身念处唯见身外。未见身内。身念处境界四分之中。此是最初。得此观者。身心悦乐。少于诤讼

佛告阿难。此想成已。次当更观身外火。从因缘有。有缘则起。缘离则灭。如此众火来无所从来去无所至。恍忽变灭。终不暂停。作是思惟时。外火即灭。更不复现。复当思惟。外诸水等。江河池流。皆是龙力变化所成我今云何横见此水。此诸水等。来无所从来。去无所至作是思惟时。外水不现。复当起念。此风者与虚空合诸龙鸣吼。假因缘有如此想者。亦不在内。亦不在外。不在中间。颠倒心故。横见此事。作是思惟时。外风不起。复当更系念思惟身内脊骨。见身内骨。白如珂雪。一一节间。三十六物。秽恶不净。皆于中现。或见身皮。犹如皮囊。盛诸不净。无量瘭疽。百千痈疾。悉在其中。诸脓流出。滴滴不绝。当在骨人头上。极可厌患。或见身内。五藏悉皆走入于大肠中大肠膖胀。烂溃难堪。尔时行者。以定力故。出定入定。见一切人及与己身。同不净聚。见诸女人。身如虫狗。秽恶不净。自然当得不贪色想。佛告阿难。此想成时。名第十四观外四大亦名渐解学观空。佛告阿难。汝持佛语。慎勿忘失。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。此想成已。复当更教系念。谛观身内地大。身内地大者。骨齿爪发肠胃腹肝心肺。诸坚实物。悉是地大。精气所成。外地无常。所以知之。譬如大地。二日出时。大地焦枯。三日出时。江河池沼。悉皆枯竭。四日出时。大海三分减二。五日出时。大海枯尽。六日出时。大地焰起。七日出时。大地然尽。外地犹尔。势不支久。况身内地。当复坚牢。尔时行者。应自思惟。今我此身。发是我耶。爪是我耶。骨是我耶。身诸五藏。为是我耶。如是谛观身诸支节。都无有我。自观诸骨。一一谛观。此骨者。从何处生。父母和合。赤白精时。如乳时。如泡时。如是歌罗逻时。如安浮陀时。如是诸时。何处有骨。当知此骨本无今有。已有还无。此骨者。同虚空相。外地无常。内地亦尔。作是思惟时。谛观己身。一切诸骨。自然破散。犹如微尘。入定观骨。但见骨处。不见骨相。出定见身。如前无异。复当更观身内诸火。从外火有。外火无常。无有暂停。我今身火。何由久热。作是观时。观诸骨上。一切火光。悉灭不现。复当更观身内诸水。我此诸水。因外水有。外水无常。势不支久。内水亦尔。假缘而有。何处有水及不净聚。外风无常。势不支久。从因缘生。还从缘灭。今我身内所有诸风。假伪合成。强为机关。何处有风。从妄想起。是颠倒见。作是思惟时。不见身内。诸龙耳中。所有诸风。悉灭不现。如是种种谛自思惟。何处有人及地水火风。观此地是败坏法。观此火犹如幻。又观此风。从颠倒起。观此水从虚妄想现。作是观时。行者见身。犹如芭蕉。中无坚实。或自见心。如水上泡。闻诸外声。犹如谷声。作是观时。见诸骨上。一切火光。见白光水。见诸龙风。悉在一处。观身静寂。不识身相。身心安隐。恬怕悦乐。如此境界。名第十五四大观竟

禅秘要法经卷上禅秘要法经卷中

        后秦弘始年鸠摩罗什等于长安逍遥园译

佛告阿难。汝今至心受持此四大观法。慎勿忘失。为未来世一切众生当广演说。尔时阿难。闻佛所说。欢喜奉行。作此观时。以学观空故。身虚心劳。应服酥及诸补药。于深禅定。应作补想观。补想观者。先自观身。使皮皮相裹。犹如芭蕉。然后安心。自开顶上想。复当劝进。释梵护世诸天。使持金瓶盛天药。释提桓因在左。护世诸天在右。持天药灌顶。举身盈满。昼夜六时。恒作此想。若出定时。求诸补药。食好饮食。恒坐安隐。快乐倍常。修是补身。经三月已。然后更念其余境界。禅定力故。诸天欢喜。时释提桓因。为说甚深空无我法。赞叹行者。头面敬礼。以服天药故。出定之时。颜色和悦。身体润泽。如膏油涂。见此事者。名第十六四大观竟

佛告阿难。此想成已。复当更教系念住意。令观外色。一切色者。从何处生。作此观时。见外五色。如五色光。围绕己身。此想现时。自观身胸。胸骨渐渐明净如颇梨镜。明显可爱。复见外色。一一众色。明如日光得此观时。四方自然生四黑象。黑象大吼。踏众色灭。如是众色在地者灭。于虚空中。玄黄可爱。倍复过常。尔时大象。以鼻绕树。四象四边。乐拔此树。不能倾动。复有四象。以鼻绕树。亦不能动。尔时行者。见此事已。出定之时。应于静处。若在冢间。若在树下。若阿练若处。覆身令密。应当静寂更求好药。以补己身。如上修习补身药法。复经三月。一心精进。如救头然。心不放逸。于所受戒。不起犯心。昼夜六时。忏悔诸罪。复更思惟身无我空。如前境界。一一谛观。极令明了。此想成时。胸骨渐明。犹如神珠。内外映彻。心内毒蛇。复更踊身。腾住空中。口中有火。欲吸摩尼珠。了不能得。如前失舍。自扑于地。身心迷闷。望见四方。尔时诸象。复更奔竞。来至树所。时诸夜叉罗刹恶兽诸龙蛇等。俱时吐毒。与黑象战。尔时黑象。以鼻绕树。声吼而挽。象挽树时。诸龙夜叉。吐毒前战。不肯休息。尔时地下。有一师子。两眼明显。似如金刚。忽然踊出。与诸龙战。尔时诸龙。踊住空中。象故挽树。终不休息。地渐渐动。是时行者。地动之时。当观此地。从空而有。非坚实法。如此地者。如乾闼婆城。如野马行。从虚妄出。何缘而动。作是思惟时。自分己身。胸骨乃至面骨。渐渐明净。见诸世间一切所有。皆悉明了。得此观时。如执明镜自观面像。行者尔时。见诸身外一切众色。及诸不净。亦见身内一切不净。此想成时。名第十七身念处观。佛告阿难。汝好受持此身念处灌顶章句。慎勿忘失。开甘露法门。为未来世一切众生。当广演说。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。此想成已。复当更教系念思惟谛观面骨。自见面骨。如白玉镜。内外俱净。净如明镜。渐渐广大。见举身骨。白如颇梨镜。内外俱净。一切众色。皆于中现。须臾见身。如白玉人。复见澄清。如毗琉璃。表里俱空。一切众色。皆于中现。复见己身。如白银人。唯薄皮在。皮极微薄。薄于天劫贝。内外映彻。复见己身。如阎浮檀那金人。内外俱空。复见己身。如金刚人。见此地时。黑象倍多。以鼻绕树。尽己身力。不能令动。尔时众象。吼声震烈。惊动大地。大地动时。有金刚山。从下方地出。住行者前。尔时行者。见已四边。有金刚山。复见前地。犹如金刚。复见诸龙。寻树上下。吐金刚珠。树遂坚固。象不能动。唯五色水。从树上出。仰流树枝。从于树端。下流叶间。乃至树茎亦流。金刚山间。布散弥漫。满于大地。金刚地下。乃至金刚山。此五色水。放五色光。或上或下。游行无常。尔时黑象。从金刚山出。欲吸此水。诸龙吐毒。与大象战。尔时诸蛇。入龙耳中。并力作势。共黑象战。尔时黑象。尽力蹴掣。亦无奈何。见此事时。诸水光明。皆作伎乐。或有变化。状如天女。歌咏作伎。甚可爱乐。此女端正。天上人间。无有比类。其所作乐。及妙音声。忉利天上。亦无此比。如是化女。作诸技术。数亿千万。不可具说。见此事时。慎勿随着。应当系心念前不净。出定之时。应诣智者问甚深空义。尔时智者。应为行者。说无我空。尔时行者。复应系念如前。自观身骨。自见胸骨。明净可爱。一切不净。皆于中现。见此事已。当自思惟。如我今者。发是我耶。骨是我耶。爪是我耶。齿是我耶。色是我耶。受是我耶。想是我耶。识是我耶。一一谛观。无明是我耶。行是我耶。识是我耶。名色是我耶。六入是我耶。触是我耶。受是我耶。爱是我耶。取是我耶。有是我耶。生是我耶。老死是我耶。若死是我者。诸虫唼食。散灭坏时。我是何处。若生是我者。念念不住。于此生中。无常住想。当知此生亦非是我。若头是我。头骨八段。解解各异。脑中生虫。观此头中。而实无我。若眼是我。眼中无实。地与水合。假火为明。假风动转。散灭坏时。乌鹊等鸟。皆来食之。瘭蛆诸虫。所共唼食。谛观此眼。若心是我。风力所转。无暂停时。亦有六龙。举此心中。有无量毒。心为根本推此诸毒。及与心性。皆从空有。妄想名我。如是诸法。地水火风。色香味触。及十二缘。一一谛推。何处有我。观身无我。云何有我所。我所者为青色是我。黄色是我。赤色是我。白色是我。黑色是我。此五色者。从可爱有。随缚着生。欲水所染。从老死河生。从恩爱贼起。从痴惑见。如此众色。实非是我。惑着众生。横言是我。虚见众生。复称我所。一切如幻。何处有我。于幻法中。岂有我所。作是思惟时。自见身骨。明净可爱。一切世间。所希见事。皆于中现。复见己身。如毗琉璃人。内外俱空。如人戴琉璃幢。仰看空中。一切皆见。尔时行者。于自身内及与身外。以观空故。学无我法。自见己身。两足如琉璃筒。亦见下方。一切世间所希见事。此想成时。行者前地。明净可爱。如毗琉璃。极为映彻。持戒具者。见地清净如梵王宫。威仪不具。虽见净地。犹如水精。此想成时。有无量百千无数夜叉罗刹。皆从地出。手执白羊角龟甲白石。打金刚山。复有诸鬼。手执铁槌。打金刚山。是时山上。有五鬼神。千头千手。手执千剑。与罗刹战。毒蛇毒龙。皆悉吐毒。围绕此山。复有诸女。作妭歌咏。作诸变动。护助此山。若见此事。当一心观。诸女现时。当观此女。犹如画瓶中盛臭处不净之器。从虚妄出。来无所因。去亦无处。如此相貌。是我宿世恶业罪缘故见此女。此女人者。是我妄想。无数世时。贪爱因缘。从虚妄见。应当至心观无我法。我身无我。他身亦然。今此所见。属诸因缘。我不愿求。我观此身。无常败坏。亦无我所。何处有人及与众生。作此思惟已。一心谛观空无我法。观无我时。上方琉璃地际。有四大鬼神。自然来至。负金刚山。时诸夜叉罗刹。亦助此鬼。破金刚山。时金刚山。渐渐颓毁。经于多时。泓然都尽。唯金刚地在。尔时诸象。及诸恶鬼。并力挽树。树坚难动。见此事已。复更欢喜。忏悔诸罪。忏悔罪已。如前系念。观琉璃人。琉璃地上。于四方面。生四莲华。其华金色。亦有千叶。金刚为台。有一金像。结加趺坐。身相具足。光明无缺。在于东方。南西北方。亦复如是。复自见琉璃身。益更明净。内外洞彻。无诸障碍。身内身外。满中化佛。是诸化佛。各放光明。其光微妙。如亿千日。显赫端严。遍满一切三千大千世界。满中化佛。一一化佛。有三十二相八十种随形好。一一相好。各放千光。其光明盛。如和合百千日月。一一光间。有无数佛。如是渐渐。复更增广。数不可知。一一焰间。复更倍有无数化佛。是诸化佛。回旋宛转。入琉璃人身中。尔时自见己身。如七宝山。高显可观。复更严显。如杂宝须弥山。山映显在金刚地上。时金刚地。复更明显。如焰摩天紫绀摩尼珠。身转复明净。如无数诸佛光明。化成宝台。亦入琉璃人顶。复见前地。在铁围山。满中诸佛。结加趺坐。处莲华台地及虚空。中间无缺。一一化佛。身满世界。是诸化佛。不相妨碍。复见铁围诸山。净如琉璃。无障碍想。见阎浮提。山河石壁。树木荆棘。一切悉是诸妙化佛。心渐广大。见三千大千世界。虚空及地。一切悉是微妙佛像。是时行者。但观无我。慎勿起心随逐佛像。复当思惟。我闻佛说。诸佛如来。有二种身。一者生身。二者法身。今我所见。既非法身。又非生身。是假想见。从虚妄起。诸佛不来。我亦不去。云何此处。忽生佛像。说是语时。但当自观己身无我。慎勿随逐诸化佛像。复当谛观。今我此身。前时不净。九孔脓流。筋缠血涂。生藏熟藏。大小便利。八万户虫。一一虫复有八十亿小虫。以为眷属。如此之身。当有何净。作是思惟时。自见己身。犹如皮囊。出定亦见身内。无骨身皮如囊。亦观他身。犹如皮囊。见此事时。当诣智者问诸苦法。闻苦法已。谛观此身。属诸因缘。当有生苦。既受生已。忧悲苦恼。恩爱别离。与怨憎会。如是种种。是世间苦法。今我此身。不久败坏。在苦网中。属生死种。风刀诸贼。随从我身。阿鼻地狱。猛火炽然。当焚烧我。驼驴猪狗。一切畜生。及诸禽兽。我悉当经受诸恶形。如此诸苦名为外苦。今我身内。自有四大毒龙无数毒蛇。一一蛇有九十九头。罗刹恶鬼。及鸠槃荼。诸恶鬼等。集在我心。如此身心。极为不净。是弊恶聚。三界种子。萌芽不断。云何我今于不净中而生净想。于虚妄物。作金刚想。于无佛处。作佛像想。一切世间。诸行性相。悉皆无常。不久磨灭。如我此身。如弹指顷。亦当败坏。用此虚想。于不净中。假伪见净。作是思惟时。自见己身。净如琉璃。皮囊诸相自然变灭。观身及我。了不能得。但见四方。有诸黑象。践踏前地。前地金刚。一切摧碎。见地树荄。乃至下方。众荄甚多。不可称数。尔时黑象。如前以鼻绕树。无量诸龙。及诸夜叉。与黑象共战。狂象蹴踏是诸鬼神。闷绝躄地。于虚空中。有诸鬼神。其数众多。手捉刀轮。佐助黑象。欲拔此树。如是多时。树一根动。此树动时。行者自见绳床下地。自然震动。日日如是。满九十日。如是应当乞好美食。及诸补药。以补身体。安隐端坐。复如前法。如前所见。从初境界。一一谛观。往复反覆。经十六反。极令明净。既明净已。复还系念。观身苦空无常无我。悉亦皆空。作是思惟时。观身不见身。观我不见我。观心不见心。尔时忽然见此大地。山河石壁。一切悉无。出定之时。如痴醉人应当至心。修忏悔法。礼拜涂地。放舍此观。礼拜之时。未举头顷。自然得见如来真影。以手摩头。赞言法子。善哉善哉。汝今善观诸佛空法。以见佛影故。心大欢喜。还得醒悟。尔时尊者摩诃宾头卢。与五百阿罗汉。飞至其前。广为宣说甚深空法。以见五百声闻比丘故。心大欢喜。头顶忏悔。复见尊者舍利弗摩诃目揵罗夜那。及千二百五十声闻影。尔时复见释迦牟尼佛影。见释迦牟尼佛影已。复得见过去六佛影。是时诸佛影。如颇梨镜。明显可观。各伸右手。摩行者顶。诸佛如来。自说名字。第一佛言。我是毗婆尸。第二佛言。我是尸弃。第三佛言。我是毗舍。第四佛言。我是拘楼孙。第五佛言。我是迦那含牟尼。第六佛言。我是迦叶毗。第七佛言。我是释迦牟尼佛。是汝和上。汝观空法。我来为汝作证。六佛世尊。现前证知见。佛说是语时。见佛色身。了了分明。亦见六佛。了了分明。尔时七佛。各放眉间白毫大人相光。光明大盛。照娑婆世界及琉璃身。皆令明显。尔时诸佛。现此相时。身诸毛孔放大光明。化佛无数。遍满三千大千世界。地及虚空。纯黄金色。是诸世尊。中有飞行者。中有作十八变者。中有经行者。中有入深禅定者。中有默然安住者。中有放大光明者。唯大和上释迦牟尼佛。为于行者。说四真谛。分别苦空无常无我诸法空义。过去六佛。亦复分别十二因缘。或复演说三十七道品。赞叹圣行。尔时行者。见佛闻法。心生欢喜。应时自思惟。诸佛世尊。有二种身。今我所见。见佛色身。不见如来解脱知见五分法身。作是思惟时。复更忏悔。殷勤不懈。昼夜六时。恒修三昧。应作是念。此色身。如幻。如梦。如焰。如旋火轮。如乾闼婆城。如呼声响。是故佛说一切有为法。如梦幻泡影如露亦如电。如是诸法等。我今一一应当谛观。极令了了。作是观时。化佛不现。若有少在。复更观空。以观空故。化佛即灭。唯七佛在。尔时七佛。与诸声闻眷属大众。广为行者。说三十七助圣道法。闻此法已。身心欢喜。复更谛观苦空无常无我等法。作是观时。狂象大吼。挽树令动。树初动时。见一房地。六变震动。复有夜叉。刺黑象杀。众多黑象。死卧在地。不久烂溃。白脓黑脓。青脓黄脓。绿脓紫脓。赤脓赤血。流污在地。复有蜣螂诸虫。游集其上。复有诸虫。眼中出火。烧蜣螂杀。尔时下方金刚地际。有五金刚轮。有五金刚人。在其轮间。右手执金刚剑。左手执金刚杵。以杵捣地。以剑斫树。见此事时。大地渐动。见城内地。六种震动。见一城已。复见二城。渐渐广大。见一踰阇那。见一踰阇那已。复更广大普见三千大千世界一切地动。动时东踊西没。西踊东没。南踊北没。北踊南没。中踊边没。边踊中没。此地动时。见大树荄。乃至金刚际。时金刚人以刀斫之。令树荄绝。树荄绝时。诸龙诸蛇。皆悉吐焰。寻树而上。尔时复有众多罗刹。积薪树上。时金刚人。以金刚杵。捣树枝折。捣此树时。一杵乃至八万四千杵。树枝方折。尔时杵端。自然出火。烧此树尽。唯有树心。如金刚锥。从三界顶。下至金刚际。不可倾动。是时行者。得此观时。出定安乐。出定入定。心恒静寂。无忧喜想。复勤精进。昼夜不息。以精进故。世尊释迦牟尼。与过去六佛。当现其前为说甚深空三昧。无愿三昧。无作三昧。闻已欢喜。随顺佛教。谛观空法。如大水流。不久当得阿罗汉道。佛告阿难。此不净想观。是大甘露。灭贪淫欲。能除众生结使心病。汝好受持。慎勿忘失。若佛灭度后。比丘比丘尼。优婆塞优婆夷。闻此甘露灌顶圣法。能摄诸根。至心系念。谛观身分。心不分散。敛心使住。经须臾间。此人命终。得生天上。若复有人。随顺佛教。系念谛观一爪一指。令心安住。当知此人。终不堕落三恶道中。若复有人。系念谛观。见举身白骨。此人命终。生兜率陀天。值遇一生补处菩萨。号曰弥勒。见彼天已。随从受乐。弥勒成佛。最初闻法。得阿罗汉果。三明六通。具八解脱。若复有人。观此不净。得具足者。于此身上。见佛真影。闻佛说法。得尽诸苦。尔时阿难。即从坐起。整衣服。为佛作礼。叉手长跪。白佛言。世尊。此法之要。云何受持。当何名此法。佛告阿难。此名观身不净杂秽想。亦名破我法观无我空。汝好受持为未来世。浊苦众生。贪淫多者。当广分别。佛说是语时。释梵护世。无数天子。持天曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上及诸大众顶礼佛足。赞叹佛言。如来出世。甚为希有。乃能降伏骄慢邪见。迦絺罗难陀。亦为未来贪淫众生。说甘露药。增长天种。不断三宝。善哉世尊。快说是法。龙神夜叉。乾闼婆等。亦同诸天。赞叹于佛。尊者阿难。迦絺罗难陀。及千比丘。无量诸天。八部之众。闻佛所说。欢喜奉行。礼佛而退。得此观者。名十色不净。亦名分别诸虫境界。是最初不净门。有十八方便。诸境界性。不可具说。入三昧时。当自然得此第十八一门观竟

如是我闻。一时佛住舍卫国。祇树给孤独园。尔时世尊。与千二百五十比丘俱。是时会中有一比丘。名禅难提。于深禅定。久已通达。成阿罗汉。三明六通。具八解脱。即从坐起。正衣服。叉手长跪。而白佛言。如来今者。现在世间。利安一切。佛灭度后佛不现在诸四部众。有业障者。若系念时。境界不现在前。如是烦恼。及一切罪。犯突吉罗乃至重罪。欲忏悔者。当云何灭是诸罪相。若复有人杀生邪见。欲修正念。当云何灭邪见杀生恶烦恼障。作是语已。如大山崩。五体投地。顶礼佛足。复白佛言。唯愿世尊。为我解说令未来世一切众生。恒得正念。不离贤圣。尔时世尊。犹如慈父安慰其子。告言。善哉善哉。善男子。汝行慈心与慈俱生。今具大悲无漏根力觉道成就。汝于今日。为未来世一切众生。问除罪法谛听谛听。善思念之尔时世尊即放顶光。此光金色有五百化佛。绕佛七匝。照只陀林。亦作金色。现此相已。还从佛枕骨入。尔时世尊告禅难提及敕阿难汝等当教未来众生罪业多者。为除罪故。教使念佛。以念佛故。除诸业障报障烦恼障。念佛者当先端坐。叉手闭眼举舌向齶。一心系念心心相注。使不分散心既定已。先当观像。观像者。当起想念。观于前地。极使白净取相长短壁方二丈。益使明净犹如明镜见前地已。见左边地。亦使明净见右边地。亦使明净。及见后地。亦使明净。使四方地悉平如掌。其一一方各作二丈地想。极使明净。地既明已。还当摄心观于前地。作莲华想。其华千叶。七宝庄严。复当作一丈六金像想。令此金像结加趺坐。坐莲华上见此像已应当谛观顶上肉髻。见顶上肉髻。发绀青色一一发舒长丈三。还放之时右旋宛转。有琉璃光。住佛顶上如是一一孔。一毛旋生。观八万四千毛皆使了了。见此事已次观像面像面圆满。如十五日月。威光益显。分齐分明复观额广平正眉间毫相。白如珂雪。如颇梨珠。右旋宛转复观像鼻。如铸金铤似鹰王嘴。当于面门复观像口唇色赤好。如频婆罗果。次观像齿口四十齿。方白齐平。齿上有印印中出光。如白真珠。齿间红色。流出红光次观像颈。如琉璃筒显发金颜。次观像胸德字万字。众相印中。极令分明。印印出光。五色具足。次观佛像。臂如象王鼻。柔软可爱次观像手十指参差。不失其所。手内外握。手上生毛。如琉璃光。毛悉上靡。如赤铜爪。爪上金色。爪内红色。如赤铜山与紫金合。次观合曼掌。犹如鹅王。舒时则现。似真珠网。摄手不见。观像手已。次观像身。方坐安隐。如真金山。不前不却。中坐得所。复观像胫。如鹿王腨。佣直圆满。次观足趺。平满安庠。足下莲华。千辐具足。足上生毛。如绀琉璃。毛皆上靡。脚指齐整。参差得中。爪色赤铜。于脚指端。亦有千辐相轮。脚指网间。犹如罗文。似雁王脚。如是诸事。及与身光圆光项光。光有化佛诸大比丘众化菩萨。如是化人。如旋火轮。旋逐光走。如是逆观者。从足逆观。乃至顶髻。顺观者。从顶至足。如是观像。使心分明。专见一佛像。见一像已。复当更观得见二像。见二佛像时。使佛像身成琉璃。出众色光。焰焰相次如烧金山。化像无数。见二像已。复见三像。见三像已。复见四像。见四像已。复见五像。见五像已。乃至见十像。见十像已。心转明利。见阎浮提。齐四海内。凡夫心狭。不得令广。若广大者。摄心令还。齐四海内。以铁围山为界。见此海内。满中佛像。三十二相。八十随形好。皆使分明。一一相好。有无数光。若于众光。见一一境界。杂秽不净。从罪报得。复应更起扫兜婆涂地。造作净筹。谦卑下下。修诸忏悔。复当安心正念一处。如前观像。不缘余事。谛观像眉间。观像眉间已。次第观其余诸相。一一相好。皆使分明。若不分明。更复忏悔作诸苦役。然后摄心。如前观像。见诸佛像。身色端严。三十二相。皆悉具足。满四海内。皆坐华上。见坐像已。复更作念。世尊在世。执钵持锡。入里乞食。处处游化。以福度众生。我于今日。但见坐像。不见行像。宿有何罪。作是念已。复更忏悔。既忏悔已。如前摄心。系念观像。观像时。见诸坐像。一切皆起。巨身丈六。方正不倾。身相光明。皆悉具足。见像立已。复见像行。执钵持锡。威仪庠序。诸天人众。皆亦围绕。复有众像。飞腾虚空放金色光。满虚空中。犹如金云。复似金山。相好无比。复见众像。于虚空中。作十八变。身上出水。身下出火。或现大身。满虚空中。大复现小。如芥子许。履地如水。履水如地。于虚空中。东踊西没。西踊东没。南踊北没。北踊南没。中踊边没。边踊中没。上踊下没。下踊上没。行住坐卧。随意自在。见此事已。复当作念。世尊在世。教诸比丘。右胁而卧。我今亦当观诸像卧。寻见诸像牒僧伽梨。枕右肘右胁而卧。胁下自然生金色床。金光栴檀。种种杂色。众妙莲华。以为敷具。上有宝帐。垂诸璎珞。佛放大光。满宝帐内。犹如金华。复似星月。无量宝光。犹如团云。处空明显。中有化佛。弥满虚空。见卧像已。复当作念。过去有佛。名释迦牟尼。唯独一身。教化众生。住在此世。四十九年。入大涅槃而般涅槃。犹如薪尽火灭。永灭无余。我今心想。以想心故。见是多像。此多像者。来无所从。去无所至。从我心想。妄见此耳。作是念时。渐渐消灭。众像皆尽。唯见一像。独坐华台。结加趺坐。谛观此像。三十二相。八十种好。皆使明了。见此像已。名观像法。佛告禅难提。及敕阿难。佛灭度后。若比丘比丘尼。优婆塞优婆夷。欲忏悔者。欲灭罪者。佛虽不在。系念谛观形像者。诸恶罪业。速得清净。观此像已。复当更观。从像脐中。便放一光。其光金色。分为五支。一光照左。一光照右。一光照前。一光照后。一光照上。如是五光。光光之上。皆有化佛。佛相次第。满虚空中。见此相时。极使明了。复见化佛。上至梵世。弥满三千大千世界。于三千大千世界中。见金色光。如紫金山。内外无妨。见此事时。心意快然。见前坐像。如佛真影。见佛影已。复当作念。此是影耳。世尊威力。智慧自在。现作此事。我今应当谛观真佛。尔时寻见佛身。微妙如净琉璃。内有金刚。于金刚内。有紫金光。共相映发。成众相好。三十二相。八十种好。犹如印文。炳然明显。微妙清净。不可具说。手执澡瓶。住立空中。瓶内盛水。状如甘露。其水五色。五光清净。如琉璃珠。柔软细滑。灌行者顶。满于身中。自见身内。水所触处。八十户虫。渐渐萎落。虫既萎已。身体柔软。心意悦乐。当自念言。如来慈父。以此法水上味甘露。而灌我顶。此灌顶法。必定不虚。尔时复当更起想念。唯愿世尊。为我说法。罪业除者。闻佛说法。佛说法者。说四念处。说四正勤。说四如意足五根五力。说七觉。说八圣道。此三十七法。一一分别。为行者说。说此法已。复教观苦空无常无我。教此法已。以见佛故。得闻妙法。心意开解。如水顺流。不久亦成阿罗汉道。业障重者。见佛动口。不闻说法。犹如聋人。无所闻知。尔时复当更行忏悔。既忏悔已。五体投地。对佛啼泣。经历多时。修诸功德。然后方闻佛所说法。虽闻说法。于义不了。复见世尊以澡瓶水。灌行者顶。水色变异。纯金刚色。从顶上入。其色各异。青黄赤白。众秽杂相。亦于中现。水从顶上入。直下身中。从足跟出。流入地中其地即时变为光明。大如丈许。下入地中。如是渐深。直到水际。到水际已。复当作意。随此光去。复观此水。水下淳空。复更当观空下有绀琉璃地。琉璃地下有金色地。金色地下有金刚地。金刚地下复见虚空。见此虚空。豁然大空。都无所有。见此事已。复还摄心。如前观一佛像。尔时彼佛光明益显。不可具说。复持澡瓶水。灌行者顶。水相光明。亦如上说。如是七遍。佛告禅难提。此名观像三昧。亦名念佛定。复名除罪业。次名救破戒。令毁禁戒者。不失禅定。佛告阿难。汝好受持此观佛三昧灌顶之法。为未来世一切众生。当广分别。佛说是语时。尊者禅难提。及诸天众。千二百五十比丘。皆作是言。如来世尊。于今日为诸众生乱心多者。说除罪法。唯愿世尊。更开甘露。令诸众生。于佛灭后。得涅槃道。禅难提比丘。闻佛说此观佛三昧。身心欢喜。应时即得无量三昧门。豁然意解。成阿罗汉。三明六通。皆悉具足。佛告阿难。此想成者。名第十九观佛三昧。亦名灌顶法。汝好受持。慎勿忘失。为未来世一切众生。分别广说。佛说此语时。诸比丘众。闻佛所说。欢喜奉行

佛告阿难。贪淫多者。虽得如此观佛三昧。于事无益。不能获得贤圣道果。次当更教自观己身。令如前法。还作骨人。使皎然大白。犹如雪山。复当系念住意在脐中。或在腰中。随息出入。一数二随。或二数三随。或三数四随。或四数五随。或五数六随。或六数七随。或七数八随。或八数九随。或九数十随。终而复始。随息往反至十复舍数而止。尔时心意。恬静无为。自见身皮。犹如练囊。见此事已。不见身骨。不知心处。尔时复当更教起想。还使身内心意。身体支节。如白玉人。既见此已。复当系念在腰中脊骨大节上。令心不散。尔时复当自然见身上。有一明相。大如钱许。渐渐广大。如摩伽大鱼耳。周遍云集。复似白云。于白云内。有白光明。如颇梨镜。光明渐盛。举体明显。复有白光。团圆正等。犹如车轮。内外俱明。明过于日。见此事时。复更如前。一数二随。或二数三随。或三数四随。或四数五随。或五数六随。或六数七随。或七数八随。或八数九随。或九数十随。或单或复。修短随意。如是系念。在于密处。使心不散。复当系念。如前更观腰中大节。观大节时。定心不动。复自见身。更益明盛。胜前数倍。如大钱许。倍复精进。遂更见身。明倍增长。如澡罐口。世间明物。无以为譬。见此明已。倍勤精进。心不懈退。复见此明。当于胸前。如明镜许。见此明时。当勤精进如救头然。殷勤不止。遂见此明。益更增盛。诸天宝珠。无以为譬。其明清净。无诸瑕秽。有七种色。光光七宝色。从胸而出。入于明中。此相现时。遂大欢喜。自然悦乐。心极安隐。无物可譬。复更精进。心不懈息。见光如云。绕身七匝。其一一光。化成光轮。于光轮中。自然当见十二因缘根本相貌。若不精进。懈怠懒惰。犯于轻戒乃至突吉罗罪。见光即黑。犹如墙壁。或见此光。犹如灰炭。复见此光。似败故衲。由意纵逸轻小罪故。障蔽贤圣无漏光明。佛告阿难。此不净观灌顶法门。诸贤圣种。敕诸比丘比丘尼。优婆塞优婆夷。若有欲修诸贤圣法。谛观诸法苦空无常无我因缘。如学数息。使心不乱。当勤持戒一心摄持。于小罪中。应生殷重惭愧忏悔。乃至小罪。慎勿覆藏。若覆藏罪。见诸光明。如朽败木。见此事时。即知犯戒。复更惭愧。忏悔自责。扫兜婆涂地。作诸苦役。复当供养恭敬师长父母。于师父母。视如佛想。极生恭敬。复从师父母。求弘誓愿。而作是言。我今供养师长父母。以此功德。愿我世世。恒得解脱。如是惭愧。修功德已。如前数息。还见此光明显可爱。如前无异。复当更系念。谛观腰中大节。念心安定。无分散意。设有乱心。复当自责惭愧忏悔。既忏悔已。复见脐光。七色具足。犹如七宝。当令此光。合为一光。鲜白可爱。见此事已。如前还教系念思惟。观白骨人。白如珂雪。既见白骨人已。复当更教。系念住意。在骨人顶。见骨人顶。自然放光。其光大盛。似如火色。长短粗细。正共槊等。从其顶上。颠倒下垂。入顶骨中。从顶骨出。入颈骨中。从颈骨出。入胸骨中。从胸骨出。还入脐中。从脐中出。即入脊骨大节中。入大节中已。光明即灭。光明灭已。应时即有一自然大光明云。众宝庄严。宝华清净。色中上者。中有一佛。名释迦牟尼。光相具足。三十二相。八十种随形好。一一相好。放千光明。此光大盛。如亿千万日。明赫炎炎。彼佛亦说四真谛法。光相炳然。住行者前。以手摩头。化佛复教言。汝前身时。贪欲嗔恚。愚痴因缘。随逐诸恶。无明覆故。令汝世世受生死身。汝今应当观汝身内诸萎悴事。身外诸火。一切变灭。作是语已。如前还教不净观法。观身诸虫。一切萎落。见此事已。复当起火烧诸虫杀。虫既不死。复自见身。如白颇梨。自然鲜白。见白骨已。从头出光。其光大小粗细如槊。令长丈五。复当作念。使头却向。复当作意使头却向。令身皆倒。以头拄脊骨。对脐大节。见此事已。复当谛观。使白骨人。与光同色。既同色已。见其光端。有种种色果。见是果已。复见众光。从果头出。有白色光。其光大盛。如白宝云。是诸骨人。其色鲜白。与光无异。复见诸骨。摧折堕落。或有头落地者。或有骨节各各分散。或有全身白骨。犹如猛风吹于雨雪。聚散不定。譬如掣电。随现随灭。此诸骨人。堕地成聚。犹如堆阜。似腐木屑。集聚一处。行者自观见于阜上。有自然气出。至于虚空。犹如烟云。其色鲜白。弥满虚空。右旋宛转。复还云集。并在一处。见此事时。复当教作一骨人想。见此骨人。身有九色。九画分明。一一画中。有九色骨人。其色鲜明。不可具说。一一骨人。复当皆使身体具足。映显前骨人中。使不妨碍。作是观已。复当自观。一一色中。犹如琉璃。无诸障蔽。于其色中。九十九色。一一色复有九色众多骨人。是诸骨人。有种种相。其性不同。不相妨碍。见此事已。应勤精进灭一切恶。见此事已。前聚光明云。犹如坏器。来入其身。从脐中入。既入脐已。入脊骨中。入脊骨已。自见己身。与本无异。平复如故。出定入定。以数息故。恒见上事。见此事时。复当还教。系心住意。在本脐光中。不令心散。尔时心意。极大安隐。既安隐已。复当自学审谛分别诸圣解脱。尔时复当见过去七佛。为其说法。说法者。说四真谛。说五受阴空无我所。是时诸佛。与诸贤圣。恒至行者前。教种种法。亦教观空无我无作无愿三昧。告言法子。汝今应当谛观。色声香味触。皆悉无常。不得久立。恍忽如电。即时变灭。亦复如幻。犹如野马。如热时焰。如乾闼婆城。如梦所见。觉不知处。如凿石见光。须臾变灭。如鸟飞空。迹不可寻。如呼声响。无有应者。汝今亦当作如是观。三界如幻。亦如变化。于此即见一切身内。及与身外。空无所有。如鸟飞空无所依止。心超三界。观诸世间。须弥巨海。皆不久停。亦如幻化。自观己身。不见身相。便作是念。世界无常。三界不安。一切都空。何处有身。及眼所对。此诸色欲。及诸女人。从颠倒起。横见可爱。实是速朽败坏之法。夫女色者。犹如枷锁。劳人识神。愚夫恋着。不知厌足。不能自拔。不免杻械。不绝枷锁。行者既识法相。知法空寂。此诸色欲。犹如怨贼。何可恋惜。复似牢狱。坚密难舍。我今观空。厌离三界。观见世间。如水上泡。斯须磨灭。心无众想。得知世法是重患累。凡夫迷惑。至死不觉。不知众苦。恋着难免。纵情狂惑。无所不至。我今观此狂惑女色。如呼声响。亦似镜像。求觅叵得。观此女色。为在何处。妄见衰害。欺诸凡夫。为害滋多。今观此色。犹如狂华。随风零落。出无所从。去亦无所至。幻惑无实。愚夫乐着。今观此色。一切无常。如癞病人。良医治差。我今观苦空无常。见此色相。皆无坚实。念诸凡夫。甚可愍伤。爱着此色。敬重无厌。耽愚惑着。甘乐无穷。为诸恩爱。而作奴仆。欲槊刺己。痛彻心髓。恩爱枷锁。捡系其身。如是念已。复观一切。都皆空寂。此诸淫欲。诸色情态。皆从五阴四大而生。五阴无主。四大无我。性相俱空。何由而有。作是观时。智慧明显。见身大明。如摩尼珠。无有妨碍。似金刚精。青白明显。如鹿突围得免猎师危害之苦观于五阴。性相皆净。观六大如鸟高翔。身无所寄。以吞色钩。俯仰得度。离诸女色。更不起情。自然超出诸淫欲海。一切结使。犹如众鱼。竞走随逐堕黑闇坑。无明老死。为智慧火之所焚烧。观色杂秽。陋恶不净犹如幻惑。无有暂停。永离色染。不为色缚

佛告阿难。若有比丘比丘尼。优婆塞优婆夷。贪淫多者。先教观佛。令离诸罪。然后方当更教系念。令心不散。心不散者。所谓数息。此数息法。是贪淫药。无上法王之所行处。汝好受持。慎勿忘失。此想成者。名第二十数息观竟

尔时尊者阿难。及禅难提。并诸比丘。闻佛所说。欢喜奉行

如是我闻。一时佛在舍卫国。游行教化。至多罗聚落。至聚落已。与千二百五十比丘。入村乞食。乞食还已。止于树下。洗足讫收衣钵。敷尼师坛。结加趺坐。尔时众中有一比丘。名迦栴延。有一弟子。名槃直迦。出家多时。经八百日。读诵一偈。不能通利。昼夜六时。恒诵此言。止恶行善。修不放逸。但诵此语。终不能得。尔时尊者迦栴延。尽其道力。教授弟子。不能令得。即至佛所。为佛作礼。绕佛三匝。而白佛言。如来出世。多所利益。利安天人。普度一切。唯我弟子。独未蒙润。唯愿天尊。为我开悟。令得解脱。佛告迦栴延。谛听谛听。善思念之。如来今者。当为汝说往昔因缘。迦栴延白言。世尊。愿乐欲闻。佛告迦栴延。乃往过去九十一劫。有佛世尊。名毗婆尸如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛出世。教化众生。度人周讫。于般涅槃。而取灭度。佛灭度后。有一比丘。聪明多智。读诵三藏。自恃憍慢。散乱放逸。有从学者。不肯教授。专愚贡高。不修正念。命终之后。堕黑闇地狱。经九十劫。恒在闇处。愚蒙无智。由前出家功德力故。从地狱出。得生天上。虽生天上。天宫光明。及诸供具。一切黑闇。卑于诸天。诵三藏故。天上命终。生阎浮提。得值佛世。因前贡高。虽遇于佛。不解法相。我今当为说诸方便。教系念法。尔时迦栴延白佛言。世尊。唯愿如来为此愚痴槃直迦比丘。及未来世一切愚痴乱想众生。说正观法。佛告槃直迦。汝从今日。常止静处。一心端坐。叉手闭目。摄身口意。慎勿放逸。汝因放逸。多劫之中。久受勤苦。汝随我语。谛观诸法。时槃直迦。随顺佛语。端坐系心。佛告槃直迦。汝今应当谛观脚大指节。令心不移。使指节上。渐渐疱起。复令膖胀。复当以意。令此膖胀。渐大如豆。彼当以意。使膖胀烂坏。皮肉两披。黄脓流出。于黄脓间。血流滂滂。一节之上。饥肤烂尽。唯见右脚指节。白如珂雪。见一节已。从右脚渐渐广大。乃至半身。膖胀烂坏。黄脓流血。令半身肌皮。皆两向披。唯半身骨。皎然大白。见半身已。复见全身。一切膖胀。都已烂坏。脓血可恶。见诸雄虫。游戏其中。如是种种。亦如上者。观见一已。复见二。见二已。复见三。见三已。复见四。见四已。复见五。见五已。乃至见十。见十已。心渐广大。见一房中。见一房中已。乃至见一天下。见一天下已。若广者。复摄令还。如前观。一观已。复当移想系念。谛观鼻头。观鼻头已。心不分散。若不分散。如前观骨。复当自想身肉肌皮。皆父母和合不净精气。所共合成。如此身者。种子不净。复当次教系念观齿。人身中。唯此齿白。我此身骨。白如此齿。心想利故。见齿长大。犹如身体。尔时复当移想。更观额上。使额上白骨。白如珂雪。若不白者。复当易观教作九想。广说如九想观法。作此观时若钝根者。过一月已。至九十日。谛观此事。然后方见。若利根者。一念即见。见此事已。复更教观腰中大节白骨。见已即如前应观种种色骨人。此法不成。复当教慈心观。慈心观者。广说如慈三昧。教慈心已。复教更观白骨。若见余事。慎勿随逐。但令此心。了了分明。见白骨人。如白雪山。若见余物。起心灭除。当作是念。如来世尊。教我观骨。云何乃有余想境界。我今应当一心观骨。见白骨已。令心澄静。无诸外想。普见三千大千世界。满中骨人。见此骨人已。一一皆灭。如前观苦

尔时槃直迦比丘。闻佛说此语。一一谛观。心不分散。了了分明。应时即得阿罗汉道。三明六通。具八解脱。自念宿命。所习三藏。了了分明。亦无错谬。尔时世尊。因此愚痴贡高槃直迦比丘。制此清净观白骨法。佛告迦栴延。此槃直迦愚痴比丘。尚以系念。成阿罗汉。何况智者而不修禅。尔时世尊。见此事已。为说偈言

  禅为甘露法　　定心灭诸恶
  慧杀诸愚痴　　永不受后有
  愚痴槃直迦　　尚以定心得
  何况诸智者　　不勤修系念

尔时世尊。告迦栴延。及敕阿难。汝今应当受持佛语。以此妙法。普济群生。若有后世愚痴众生。憍慢贡高。邪恶众生。欲坐禅者。从初迦絺罗难陀观法。及禅难提观像之法。复当学此槃直迦比丘所观之法。然后自观己身。见诸白骨。白如珂雪。时骨人。还来入身。悉见白骨。流光散灭。见此事已。行者自然心意和悦。恬静无为。出定之时。顶上温暖。身毛孔中。恒出诸香。出定入定。恒闻妙法。续复自见。身体温暖。悦豫快乐。颜貌熙怡。恒少睡眠。身无苦患。得此暖法。恒自觉知。心下温暖。心常安乐。若后世人。欲学禅者。从初不净。乃至此法。得此观者。名和暖法。佛告阿难。佛灭度后。若有比丘比丘尼。优婆塞。优婆夷。于浊世中。欲学正受思惟者。从初系念。观于不净乃至此法。是名暖法。若得此法。名第二十一暖法观竟

佛告阿难。汝今持此迦栴延子所问暖法。慎勿忘失。尔时阿难白佛言。世尊。后世众生。若有能受持是三昧者。一心安隐。得于暖法。此人云何当自觉知。佛告阿难。若有谛观诸结使相。从初不净。乃至此法。自觉身心。皆悉温暖。心心相续。无诸恼恚。颜色和悦。此名暖法。复次阿难。若有行者。得暖法已。次当更教系念在诸白骨间。皆有白光。见白光时。白骨散灭。若余境界现在前者。复当摄心还观白光。见诸白光。炎炎相次。遍满世界。自观己身。复更明净。颇梨雪山。不得为比。自见骨人。各各杂散。作此观时。定心令久。心既久已。当自见顶上。有大光明。犹如火光。从脑处出。佛告阿难。若见此事。便当更教。从头至足。反覆往复。凡十四遍。作此观已。出定入定。恒见顶上火出。如真金光。身毛孔中。亦出金光。如散粟金。身心安乐。如紫金光明。还从顶入。此名顶法。若有行者。得此观时。能得顶观。佛告阿难。汝好受持是顶观法。广为未来一切众生说。尔时阿难。闻佛所说。欢喜奉行。得此观者。名第二十二观顶法竟

佛告阿难。此想成已。复当更教系念观诸白骨。令诸散骨。如风吹雪。聚在一处。自然成[卄/積]。白如雪山。若见此事。得道不难。若有先身犯戒者。今身犯戒者。见散骨[卄/積]。犹如灰土。或于其上。见诸黑物。复当忏悔向于智者。自说已过。既忏悔已。见骨[卄/積]上。有大白光。乃至无色界。出定入定。恒得安乐。本所爱乐。渐渐微薄。复当更观。如前覆寻。九孔脓流不净之物。皆令了了。心无疑悔。复当如上。骨间生火。烧诸不净。不净已尽。金光流出。还入于顶。此光入顶时。身体快乐。无以为譬。得此观者。名第二十三观助顶法方便竟。复当更教系念住意。自观己身。犹如草束。出定之时。亦见己身。犹如芭蕉。皮皮相裹。复当自观众芭蕉叶。犹如皮囊。身内如气。亦不见骨。出定入定。恒见此事。身体羸劣。复当更教令自观身。还聚成一。如干草束。见身坚强。既见坚强。复当服酥。饮食调适。然后观身。还似空囊。有火从内烧此身尽。烧身尽已。入定之时。恒见火光。观见火已。见于四方一切火起。出定入定。身热如火。见此火大从支节起。一切毛孔。火从中出。出定之时。亦自见身。如大火聚。身体烝热。不能自持。尔时四方。有大火山。皆来合集。在行者前。自见己身。与众火合。此名火想。复当令火烧身都尽。火既烧已。入定之时。观身无身。见身悉为火所烧尽。火烧尽已。自然得知身中无我。一切结使。皆悉同然。不可具说。此名火想真实火大第二十四火大观竟

佛告阿难。汝好受持是火大无我观。此火大观。名智慧火。烧诸烦恼。汝好受持。为未来世一切众生。当广敷演。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。若有行者得。火大观已。复当更教系念思惟。令系念鼻端。更观此火从何处起。观此火时。自观己身。悉无有我。既无有我。火自然灭。复当作念。我身无我。四大无主。此诸结使。及使根本。从颠倒起。颠倒亦空。云何于此空法之中横见身火。作是观时。火及与我。求觅无所。此名火大无我观。佛告阿难。汝好受持此火大观。为未来世一切众生。当广分别敷演解说。阿难闻佛所说。欢喜奉行。是名第二十五观竟

佛告阿难。我见火灭时。先从鼻灭。然后身体一时俱灭。身内心火。八十八结。亦俱得灭。身中清凉。调和得所。深自觉悟。了了分明。决定无我。出定入定。恒知身中无有吾我。此名灭无我观竟

佛告阿难。复当更教观灌顶法。观灌顶者。自见己身。如琉璃光。超出三界。见有真佛。以澡瓶水。从顶而灌。弥满身中。身弥满已。支节亦满。从脐中流。出在于前地。佛常灌水。尔时世尊。灌顶已。即灭不现。脐中水出。犹如琉璃。其色如绀琉璃光。光气遍满三千大千世界。水出尽已。复当更教系念。愿佛世尊。更为我灌顶。尔时自然见身如气。粗大甚广超出三界。见水从顶入。见身粗大。与水正等。满于水中。复自见脐犹如莲华。涌泉流出。弥满其身。绕身如池。有诸莲华。一一莲华。七色光明。其光演说苦空无常无我等法。声如梵音。悦可耳根。此相现时。复当更教。叉手闭目。一心端坐。从于顶上。自观身内。不见骨想。出定入定。自见己身。如琉璃罂。复当起念。使自己心四大毒龙想。见己心内。如毛孔开。有六种龙。一一龙有六头。其头吐毒。犹如风火。弥漫池中。在莲华上。一一华光。流入龙顶。光入顶时。龙毒自歇。唯有大水。满其身内。此想成时。名观七觉华。虽见此想。于深禅定。犹未通达。复当更教。如上数息。使心安隐。恬然无念。此想成时。名四大相应观。佛告阿难。汝好受持是七觉意四大相应观。慎莫忘失。普为未来一切众生。当广分别。为诸四众。敷演解说。尔时阿难。闻佛所说。欢喜奉行。复当更教系念住意。谛观水大。从毛孔出。弥漫其身。出定入定。见身如池。其水绿色。如此绿水。似山顶泉。从顶而出。从顶而入。见有七华。纯金刚色。放金色光。其金色光中。有金刚人。手执利剑。斩前六龙。复见众火。从龙口出。遍身火然。众水枯竭。火即灭尽。水火灭尽已。自见己身。渐渐大白。犹如金刚。出定入定。心意快乐。犹如酥灌。如服醍醐。身心安乐。复当更教系念观他。观外境界。以外想故自然见有一树。生奇甘果。其果四色。四光具足。如此果树。如琉璃树。弥漫一切。见此树已。普见一切。四生众生。饥火所逼。一切来乞。见已欢喜。生怜愍心。即起慈心。见此乞者。如己父母受大苦恼。我今云何当救拔之。作是念已。即自观身。如前还为脓血。复为肉段。持施饥者。是诸饿鬼。争取食之。食之既饱。四散驰走

禅秘要法经卷中禅秘要法经卷下

        后秦弘始年鸠摩罗什等于长安逍遥园译

尔时复当自观己身及以他身。我身他身。从颠倒起。实无我所。若有我者。云何忽然。见此饿鬼来在我边。尔时复见无量饿鬼。其身长大。无量无边。头如太山。咽如丝发。饥火所逼。叫唤求食。见此事已。当起慈心以身施鬼。饿鬼得已。噆食其体。即便饱满。见是事已。复当更教观众多饿鬼。见诸饿鬼。绕身四匝。如前以身食诸饿鬼。见此事已。复教摄身使心不散。自观己身是不净聚。作是观时。寻自见身。脓血诸肉。皆段段坏。聚在前地。见诸众生。争取食之。既见此事。复当自观其身。从诸苦生。从诸苦有。是败坏法。不久磨灭。饿鬼所食。作是相时。忽见身内。心处有猛火。烧前池上。一切莲华。及诸饿鬼。众恶丑形。及与池水。泓然都尽。见此事已。复当更教谛观己身。如前完具。身体平复。复当更观己身。一切毛孔。以慈心故。血变成乳。从毛孔出。在地如池。众乳盈满。复见众多饿鬼。至此池上。以宿罪故。不得乳饮。尔时慈心视鬼如子。欲令饮乳。以鬼罪故。乳变成脓。斯须之间。复更慈心。以慈心故。身毛孔中。一切乳出。胜前数倍。念诸饿鬼。饥苦所逼。何不来饮。尔时饿鬼。其形长大。数十由旬。举足下足。如五百乘车声。来至行者前。唱言饥饥。尔时行者。即以慈心施乳。令饮饿鬼。饮时至口。变化为脓。虽复为脓。以行者慈心故。即得饱满。见鬼饱已。复自观身。即自见身。足下火出。烧前众生及以诸树。泓然都尽。尔时若见众多异类。复还系念谛观己身。使心不动寂寞无念。既无念想。当发誓愿。愿后世生。不受后有。不乐世间。作此誓已。寻见前地。犹如琉璃。见琉璃下。有金色水。自见己身。与地正等。与水色同。其水温暖。水中生树。如七宝树。枝叶蓊郁。上有四果。果声如铃。演说苦空无常无我。闻此声已。自见己身。没于水中。往趣树所。谛自观身。顶上水出。弥漫琉璃池中。忽然之顷。复有火起。火中生风。犹如琉璃。复见顶上。从顶坚强。至乎脚足。犹如金刚。复有火起。烧金刚尽。温水枯涸。寻更观身。我前见身内池中忽然有树。枝叶具足。树端有果。其声如铃。演说苦空无常无我清净之法。如此妙果。有好音声。香味具足。我今宜食。作此想已。即仰攀树。取果食之。才得一果。其味甘美。无物可譬。既食果已。见树干枯。其余三果。尚有光明。食果之后。身心恬澹。无忧喜想。自观心识。是败坏法。从诸苦有。诸苦根本。识为因缘。今观此识。如水上泡。无有暂停。四大无主。身无有我。识无依止。如是诸法。复七七四十九遍。谛观心识。是败坏法。尔时自见己身。白如珂雪。节节相柱。复当更教。自以右手。摩触此身。见身如尘。骨末如粉。如粉尘地。寻复更教。观身如气。从数息有。身如气囊。无有暂停。复当更教。寻自观身。如前还为一白骨人。见骨人已。自观己身。如前还散。犹如微尘。如人以粉用涂于地。寻见地上。有青色骨人。复如前观。末此青色骨人。以用涂地。复更观身。如青微尘。尘变成骨人。其骨尽黑。复当如前以末涂地。复自观身。犹如黑地。见黑地中。有四黑蛇。眼赤如火。蛇来逼身。吐毒欲害。不能为害。即变为火。自烧己身。尔时空中有自然声。恒说苦空无常无我等法。见此事时。一一毒蛇。八十八头。为火所焚。见此事时。空中自然有水。洒毒蛇身。众火尽灭。八十八头。一切都消。出定之时。觉身安乐恬怕无为。复当更教。自观己身。无高大想。寻复见身。自然高大。明显可观。如七宝山。自见己心。如摩尼珠。尔时复当如上观空。作观空时。自觉己身。和悦柔软快乐无比。前莲华上。七宝色光。流入己心。在摩尼珠中。满足十过。七支七色。皆悉具足。自观身空。亦无众想。尔时顶上有自然光。似金色云。亦如宝盖。色复似银。从顶上入。覆摩尼珠光上。出定入定。恒见此事。见此事者。自然不杀不盗不邪淫不妄语不饮酒。佛告阿难。佛灭度后。四部弟子。比丘比丘尼。优婆塞优婆夷。作此观者。名第二十六正观。亦名得须陀洹道。若得此观。要当审实。使身自然离五种恶。合修多罗。不违毗尼。随顺阿毗昙。此名须陀洹果相。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。若有行者。得此观者。宜当密藏勿妄宣传。但当一心勤行精进。勤行精进已。复当更教。谛观地大。地大观法。亦如上说。观地大已。次教观水大。观水大者。自观己身。身中诸水。身如琉璃。刚强难坏。若见自身。悉皆是水。当教易观。若复见身。尽成琉璃亦教易观。观于地大使琉璃身。犹如微气。见水从眼中现。若见此事。名细微四大观。复当更教。从头已上。使水满中。见水从眼中出。亦不堕地。自见己眼。如水上沫。亦满水中。若见此事。头水不温不冷。调和得所。水若温者。是假伪观。水色澄清。不温不凉。次当更教。观腰已上水。不温不冷。复观咽喉。如琉璃筒。水入胸中。次下至腹。乃至[月*坒]膝。莫令入臂。使水澄清。如颇梨精色。若觉水温。乃是真观。此想成已。复教通彻四支诸节。水皆满中。如琉璃器持用盛水。渐渐广大。见满一床。外人亦见。若见此水清冷。乃是真水。若见余相。不名真实。入水光三昧。渐渐广大满一室内。水皆澄清。如琉璃气。渐渐广大。遍满三千大千世界。见此事时。当于静处一心安坐。敕诸同学。皆使清净不令愦闹。尔时复当见水上紫焰起。当自忆想此水从何处起。云何当尽。若言我是水者。我身无我。前已观无我。今从无法中。水从何起。作是念时。水性如气。渐渐从顶上没。水稍稍尽。唯身皮在。自见己身。极为微薄。无物可譬。如微尘草束。复见身内。忽然有火。烧身都尽。观身无所。永无有我。我及众生。一切都无。尔时行者。心意恬怕。极为微细。无物可譬。此想成时。名第二十七真无我观。亦名灭水大想。亦名向斯陀含。其余微细贤圣法界。微妙难胜。不可具说。行者坐时。修诸三昧。得无我三昧时。当自然见佛。佛告阿难。汝今好受持是真实水大微妙境界。广为未来一切众生。敷演广说。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。得此观已。复当更教水大观法。此水大观。极为微细。使此水大与火大合。见身如气。如琉璃影。观脐四边。火焰俱起。见于火焰。犹如日映。若见脐上有火光起。或有从鼻中出。或有从口中出。耳眼随意出入。若见此事。见一切火。从毛孔出。火出之后。有渌色水。寻从火后。自见身中。水上火下。火上水下。观身无身。此想成时。见身水火。不温不冷。身心寂尔。安住无碍。此名斯陀含果。亦名境界实相。见此事时。出定入定。恒不见身。入定之时。外人亦见水火从毛孔出从毛孔入。贪淫多者。见火从顶上入从身根出。然后遍满身体。水亦复然。复当自观头上火。如阎浮檀那金光云盖。或见身下。如七宝华。心中恬静。安隐快乐。世间乐事。无以为譬。出定之时。身亦安乐。令外众生见已禅定三昧安隐金光金色。帝释诸天。恭敬礼拜并言。大德汝今苦尽。必定当成斯陀含果。闻已欢喜。修身禅定。心无系碍。安隐快乐。游戏无我三昧中。亦渐入空三昧门。无愿无作诸三昧等。悉现在前。如此微妙善胜境界。行者坐时。于禅定中。自然分别。若钝根者。大师世尊现前为说。以见佛故。闻法欢喜。应时即得斯陀含道。复当至心覆寻前观。经二十五反。极令明利

佛告阿难。汝好持此第二十九水大观。慎勿忘失。得此观者。亦名斯陀含。亦名善往来往宿世善根业因缘故遇善知识清净法行。汝乃当得此斯陀含道。尔时阿难。闻佛所说。欢喜奉行

佛告阿难。若有比丘比丘尼。优婆塞优婆夷。若得此微妙水大观已。复当更教安隐微妙最胜奇特火大观法。作此观时。自见脐中微妙火光。床如莲华。其色光明。如和合百千万亿阎浮檀那金。见此事已。复当更教观身内火。观内火时。自见心火。常有光明。过于百千万亿明月神珠。心光清净。亦复如是。出定入定。如人持明火珠行。虑恐他见。唯自心中。明了如是。他人不见。渐渐大明。见身犹如颇梨明镜。见心亦如明月神珠。虑他人见。他人其实不见此事。入定之时。以心明故。见三千大千世界粗相。见阎浮提须弥山。及大海水。悉皆了了。复见大海水中摩尼珠王。其摩尼珠王。焰出诸火。见此事已。尔时见佛。为其广说九次第定。九次第定者。九无阂八解脱。如此等观。不须豫受。佛现前故。佛自为说。其利根者。闻佛说法九无碍道中。应时即得阿罗汉道。超越阿那含地。如好白[疊*毛]易染为色。若钝根者。复当更教风大观法。风大观法者。见一切风。极为微细。细中细者。可以心眼见。而不可具说。风复杂火。火复杂风。水入火中。风入水中。火入风中。风火水等。各随毛孔。如意自在。或复有风。十色具足。如十宝光。从身毛孔出。从顶上入。从脐中出。从足下入。一切身分中出。从眉间入。从眉间出。从一切身分入。如此种种无量境界。贤圣光明。贤圣种子。诸贤圣法。皆从此风大中起。从此风大中入。此风大观。具足相貌微妙境界。唯阿罗汉。能广分别。不可具说。行者坐时。当自然见。若见此事。练诸烦恼。成阿那含。此风大观。名第三十阿那含相应境界相

佛告阿难。汝好受持是阿那含相应最胜。境界风大观法。慎勿忘失。尔时阿难。闻佛所说。欢喜奉行

如是我闻。一时佛在舍卫国。祇树给孤独园。与千二百五十比丘俱。尔时尊者摩诃迦叶。有一弟子。是王舍大城苦得尼揵子儿。名阿只达多。求尊者摩诃迦叶。出家学道。修行苦行。具十二头陀。经历五年。得阿那含果。不能增进成阿罗汉。即从坐起。至迦叶所。整衣服。叉手合掌。顶礼摩诃迦叶。白言。和上。我随和上。勤修精进。如救头然。已经五年。今得住于阿那含果。身心疲懈。不能增进无上解脱。唯愿和上。为我速说。尔时摩诃迦叶。即入三昧。观比丘心。知此比丘不尽诸漏。从此命终。生阿那含天。从三昧起。告言。法子。我今身心。一切自在。入自在三昧。观汝宿世所有业报。于此身上。无缘得成罗汉道。阿只达多闻此语已。悲泣雨泪。白言。和上。如我今者。不乐生天。如困病人求无常力。我畏生死。亦复如是。尔时迦叶。告言。法子。善哉善哉。善男子。夫生死恶。犹如猛火。烧灭一切。甚可厌患。我观汝根。不得明审。又复世尊。与诸比丘。在只陀林。我今与汝俱往佛所。时彼比丘。着衣持钵。随迦叶后。诣只陀林。到于佛所。见佛世尊。身如金山。处大众中。威德自在。三十二相。八十种好。皆悉备足。为佛作礼。绕佛七匝。却住一面。胡跪合掌。白言。世尊。我此弟子阿只达多。随从我后。修十二头陀。住深禅定。至阿那含。不能增进竭烦恼海。唯愿天尊。为说甚深灌顶甘露净解脱行

尔时世尊。告阿只达言。善哉善哉。阿只达。快问是事。吾当为汝分别解脱。谛听善思。乃往过去无央数世。彼世有佛。名大光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛出世。三种示现。教化众生。度人周讫。于像法中。有一大国。名波罗奈。王名梵摩达多。王有太子。名忍辱铠。坚发甚深阿耨多罗三藐三菩提心。求一切种智。自誓不杀。修十善业。于六波罗蜜。无疲厌心。时彼国中有一长者。名日月音。自在无量。唯有一子。忽遇热病。风大入心。狂乱无智。手执利剑。走入巷陌。杀害众生。时彼长者。爱念子故。手擎香炉。至四城门外。烧香散华。发大誓愿。而作是言。世间若有神仙圣人医师咒师。能救我子狂乱病者。一切所有。悉用奉施。尔时太子。出城游戏。见大长者。修于慈心。为子求愿。心生欢喜。而作是言。此大长者。勤修慈心。普为一切。而长者子。遇大重病。愿诸神仙。必兴慈悲。来至此处。救长者子。语顷即有一大仙人。从于雪山。腾虚而至。名曰光味。至长者所。告长者言。汝子所患。从热病起。因热病故。生大嗔恚。心脉悉开。风大入心。是故发狂。如此病者。如仙经说。风大动者。当须无嗔善男子心血。以用涂身。须善人髓。服如大豆。可得除愈。尔时长者。闻仙人说。即于路中。顶礼太子白言。地天大仙人。说我子所患。当用慈心无嗔人血及以骨髓。乃可得差。我今正欲自刺我身出血食子。破骨出髓。持与令服。唯愿太子。听许此事

尔时太子。告言。长者。我闻佛说。若有众生苦恼父母。堕大地狱。无有出期。云何长者。自破身体。欲令子差。且忍须臾。当为长者作大方便。尔时长者闻太子敕。心大欢喜。礼太子足。还至家中。象负其子。送与太子。太子见已。醍醐灌之

尔时仙人。告太子言。设以此药。灌此男子。经九十日。终不可差。要得慈心无嗔人血。尔时太子。内自思惟。除我身外。其余众生。皆当起嗔。我今为此救诸病苦。济生死命。誓求佛道。于未来世。若得成佛。亦当施此法身常命。作此誓已。即刺身以血涂彼大长者子。破骨出髓。与之令服。长者子服已。病得除愈。是时太子。以破骨故。迷闷躄地。尔时天地六种震动。释梵护世。无数天子。佥然俱下。到太子所。告太子言。汝今以身济病众生。欲求何等。为求帝释魔王梵天转轮圣王。三界之中。欲求何等

尔时太子白帝释言。我今所求。亦不欲三界之中尊荣豪贵。我所求者。乃愿欲成阿耨多罗三藐三菩提。尔时帝释闻此语已。告太子言。汝今刺身破骨出髓。身体战掉。有慨恨不。尔时太子即立誓愿。我从始刺身体。乃至于今。若无慨恨大如毛发。令我身体平复如故。作此誓已。身体平复。如前无异。尔时帝释。见此事已。白太子言。太子威德。奇特无比。有强大志。必得成佛。太子成佛时。愿先度我。作此誓时。太子默然。而说偈言

  愿我成佛时　　普度诸天人
  身心无挂碍　　普慈爱一切
  亦度于汝等　　令诸众生类
  皆住大涅槃　　永受于快乐

尔时太子。说此偈已。诸天雨华。持以供养。复雨无量百千珍宝。积满宫墙。太子得已。持用布施。布施不止。修诸波罗蜜。皆悉满足。得成为佛。佛告迦叶。尔时波罗奈国王者。今我父王阅头檀是。尔时月音长者。今汝摩诃迦叶是。尔时长者子。今阿只达比丘是。尔时忍辱铠太子者。今我释迦牟尼佛是。尔时帝释者。今舍利弗是

佛告迦叶。此阿只发比丘。乃往过去。风大动故。发狂无知。是故今者入四大定。于风定中。心疑不行。设使此人。入风大定。观四大者。头破七分。心裂而死。当教此人修于慈心。尔时世尊告阿只达。汝今当观。一切众生。悉为五苦之所逼切。汝今应当生大慈心。欲免众苦。观色受想行识。悉皆无常苦空无我。阿只达闻佛说此。豁然意解。应时即得阿罗汉道。三明六通。具八解脱。即于佛前。踊身空中。作十八变。作十八变已。从空中下。顶礼佛足。白言。世尊。如来今者为我宣说往昔因缘。及说慈心。广演四谛。我因佛力。寻时即破三界结业。成阿罗汉。唯愿天尊。为未来世浊恶众生。恶业罪故。生五浊世。如此众生。若修头陀行诸禅定。得阿那含。如我心疑停住不行。当修何法得离苦际

佛告阿只达。谛听谛听当善思之。如来今者因汝阿只达。普为未来世一切众生。广说从阿那含至阿罗汉。于其中间。所有微细一切境界。当自分别。若风病多者。入风大定时。因风大故。喜发狂病。当教观佛。教观佛者。教观如来十力四无所畏。十八不共法。大慈大悲。三念处法。观此法时。自然得见无量色身。微细妙相好。或有诸佛。飞腾空中。作十八变。或有诸佛。一一相好。普现无量百千变化。见此事时。当起恭敬供养之心。作香华想。普散诸佛。然后复当自思惟言。我今身中五阴四大。皆悉无常。生灭不住。结使枝条。及使根本。皆悉无常。我所念者。念佛十力四无所畏十八不共大慈大悲。如是功德。庄严色身。犹如宝瓶盛如意宝珠。宝珠力故。映饰此瓶。珠无我所。瓶亦无住。但为众生。佛亦如是。无有色性及与色像。解脱清净。云何我今谛观如来十力。是处非处力。乃至漏尽力。十八不共法。大慈大悲。云何更见无量色像。作此想已。见真金像。满娑婆世界。行住坐卧四威仪中。皆说苦空无常无我。虽见此事。复当起意想。是诸佛皆是戒定慧解脱解脱知见十力四无所畏十八不共法大慈大悲三念处。如此功德所共合成。云何有色。作此想时。一一谛观。令一切佛身心无碍。亦无色想。自见己身。如空中云。观五受阴。无诸性相。豁然欢喜。复还见身。如莲华聚。周匝遍满三千大千世界。见诸坐佛。坐己华上。为说甚深空无我无愿无作圣贤十四境界门。佛告阿只达。若有行者。见此事已。当教慈心。教慈心者。敬观地狱。尔时行者。即见十八地狱。火车炉炭。刀山剑树。受苦众生。皆是己前身父母。宗亲眷属。或是师徒。诸善知识。见一一人。阿鼻地狱猛火烧身。或复有人。节节火然。或上剑树。或踏刀山。或投镬汤。或入灰河。或饮沸屎。或啖热铁丸。或饮融铜。或卧铁床。或抱铜柱。或入剑林。碎身无数。或挑眼无数。持热铜丸。安眼眶中。或见饿鬼。身形长大。数十由旬。啖火啖炭。或饮脓血。变成融铜。举体火起。足跟铜流。或见闇冥铁围山间。满中众生。状如罗刹。更相食啖。见诸夜叉。裸形黑瘦。双牙上出。头上火然。首如牛头。角端雨血。复见世间虎狼师子诸恶禽兽。更相啖食。复见一切诸畜生苦。或见阿修罗。割截耳鼻。受诸苦事。复见三界一切众生。为欲所使。悉受苦恼。观无想天。犹如电幻。不久当堕大地狱中。举要言之。三界二十五有。一切众生。皆有三涂苦恼之业

尔时行者。观见三界受苦众生。其心明了。如观掌中。深起慈悲。生怜愍心。见诸众生。宿行恶业。故受恶报。见此事已。悲泣雨泪。欲生救护。尽其心力。不能救济。尔时心中极生怜愍。厌患生死。不愿久处。心生惊怖。如人捉刀欲来害己。见此事已。更起慈悲。欲拔苦者。无奈之何。尔时行者。内自思惟。是诸众生。因于无明。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼

尔时行者。内自思惟。此无明者。从何处来。孚乳产生。遍满三界。观此无明。假于地大。而得成长。依于风大。而得动摇。因于地大。体坚不坏。火大照育。水成众性。如是动作。风性不住。水性随流。火性炎盛。地性坚鞕。此四大性。二上二下。诸方亦二。东方者成色阴性南方者成受阴性。西方者成想阴性。北方者成行阴性。上方者成识阴性。此五受阴。依无明有。从触受生。乐触因缘。生于诸受。受因缘生爱取有。有因缘故生于三界。九十八使及诸结业。缠缚众生无有出期。如是诸业。从无明有。依痴爱生。此无明者。本相所出。从何而生。遍布三界。于诸众生为大缠缚。我今应观无明识相从何处起。此无明者。为是地大。为离地大。为与地合。为从地生。为从地灭。地性本空。推地无主。云何无明。起痴爱想缘行而有。而此诸行及爱取有。为从风起。为从水生。为火所照。如此四大。一一谛观。此诸大者。实无性相。同如实际。云何牵诸众生缠在三界。为大烦恼之所烧然。作此思惟已。怖畏生死。患生天乐。观诸天宫。如梦如幻。如露如电。如呼声响。普见一切三界众生。犹如环旋。受苦无穷。见此事已愁忧不乐。世间如驶水流。求涅槃道。刹那刹那顷。欲求解脱。尔时复当更教数息。一数二随。二数三随。三数四随。四数五随。五数六随。六数七随。七数八随。八数九随。九数十随。十数百随。百数千随。随息多少。摄气令住

尔时自见己身。如百千万亿莲华。一切萎脆。四面风来。吹去萎华变成琉璃。如琉璃器自见其心如大华树。从下方金刚际。乃至三界顶上有四果。其果微妙如如意珠。有六种光。遍照三千大千世界。行者见此事时。见金刚地际乃至上方三界之顶。满中诸佛。与大弟子眷属围绕。或有诸佛。飞腾虚空。身上出水。身下出火。身下出水。身上出火。东踊西没。西踊东没。南踊北没。北踊南没。中踊边没。边踊中没。或现大身满虚空中。大复现小如芥子许。变现自在随意无碍。或见诸声闻。入四大定。身如火聚。诸火焰端。犹如金筒盛众色水。复见己身。如彼入定。尔时当教行者而作是言。汝所见者。虽是多佛及诸声闻。汝今应观此诸世尊。是无相身。是大解脱。是无学果。应当善摄汝心。如前数息。此数息法。有十六科。不可具说

尔时行者。既数息已。心意恬怕。寂然无见复当更教观心莲华。犹如华树。树上有果。如摩尼珠。现六种光。其光明显。从三界顶。照于下方金刚地际。见心华树。荄垂欲绝。然深无量。尔时当观诸佛法身。诸佛法身者。因色身有。色身者譬如金瓶。法身者如摩尼珠。应当谛观色身之内。十力四无所畏。十八不共法。大慈大悲。无碍解脱。神智无量。绝妙境界。非眼所见。非心所念。一切诸法。无来无去。不住不坏。同如实际。凡夫愚痴。为老死大贼之所追逐。妄见颠倒。以颠倒故。堕落三涂爱欲河中。为驶水所漂。没溺三界。我今云何同凡夫行。妄想见佛。我大和上释迦牟尼佛。往昔之时。头目髓脑。国城妻子。持用布施。百千苦行。求解脱法。今者已得超越生死住大涅槃。寂灭究竟更不复生。如过去佛法住常乐处。亦无去来现在诸智。身心不动。恬怕无为。如此智慧所成就身。当有何想。云何变动。我今见者。从妄想现属诸因缘。故是颠倒色相之法。作是思惟时。一切诸佛及诸贤圣。寂然隐身更不复现。唯一佛在。有四大弟子以为侍者

尔时释迦牟尼世尊。为于行者。更说四大清净观法。告言法子。过去三世诸贤圣等。观此行时。自然皆观。风大观法。观风大者。先观身内。从心华树。生一微风。如是微风。渐渐增长。遍满身体。满身体已从毛孔出满一房内。满一房已。见此微风满一庭内。满一庭已。复见渐渐满一顷地。满一顷已复更增广满一由旬。满一由旬已满二由旬。满二由旬已满三由旬。满三由旬已满四由旬。满四由旬已满五由旬。满五由旬已。如此渐渐广大。满十由旬。微风才动。渐渐广大。遍满三千大千世界。上至于顶。下至金刚际。遍此诸处已。还从顶入。令其心树一切华叶渐渐萎落。自见己身。如颇梨镜。表里映彻。尔时复当教观水大。观水大者。先观身内。心华树端。出一微水。如琉璃气。渐渐增广。似白色云。遍满身内。满身内已。从六根出。顶上涌出。绕身七匝。如白云行。滴滴雨水。其水柔软。盈满一床。满一床已。渐渐广大。满一房内。满一房已。满一庭中。满一庭已。满一城中。满一城已。满十顷地。满十顷已。满百顷地。满百顷已。满一由旬。水色正白。如白琉璃光。其气微细。过于凡夫。眼根境界。渐渐广大。满二由旬。满二由旬已。满三由旬。满三由旬已。满四由旬。满四由旬已。满五由旬。满五由旬已。渐渐广大。满十由旬。满十由旬已。渐渐广大。满百由旬。满百由旬已。渐渐广大。满一阎浮提。满一阎浮提已。渐渐广大。遍满三千大千世界。上至三界顶。下至金刚际。如是水相。其气如云。还从顶入。见此事已。复更教观火大观火大者。自观身内。心华树端。诸华叶间。有微细火。犹如金光。从心端出。遍满身内。从毛孔出。渐渐广大。遍满一床。满一床已。满一房内。满一房已。渐渐广大。满一庭中。满一庭已。满一城中。满一城已。满十顷地。满十顷地已。满百顷地。满百顷地已。满一由旬。火色变白。如真珠光。更复鲜白。颇梨雪山。不得为比。红光照错。以成文章。渐渐广大。满二由旬。满二由旬已。满三由旬。满三由旬已。满四由旬。满四由旬已。满五由旬。满五由旬已。渐渐广大。满百由旬。满百由旬已。渐渐广大。满阎浮提。满阎浮提已。渐渐广大。遍满三千大千世界。上至三界顶。下至金刚际。还从顶入。见此事已。复当更教观于地大。观地大者。自见身内。心树诸华。渐渐广大。如金刚云。遍满身内。满身内已。复满一床。满一床已。遍满一房。满一房已。遍满一庭。满一庭已。遍满一城。满一城已。渐渐广大。遍满十顷。满十顷已。遍满百顷。满百顷已。满一由旬。满一由旬已。其色变青。渐渐广大。遍满二由旬。满二由旬已。满三由旬。满三由旬已。满四由旬。满四由旬已。满五由旬。满五由旬已。渐渐广大。满百由旬。满百由旬已。渐渐广大。满阎浮提。满阎浮提已。渐渐广大。遍满三千大千世界。上至三界顶。下至金刚际。还从顶入。见此事已。复当更教还观地大。观此地大。如金刚云。难可摧碎。当云何灭。作此观时。见佛世尊释迦牟尼。坐金刚座。与尊弟子眷属五百。坐行者前。异口同音。赞叹灭谛。闻此语已。当观地大从因缘起。无明所持。无明无性。痴爱无主。虚伪因缘。假名无明。爱取有等。皆属此相。作此思惟时。见自心内。众华树端。渐渐火起。烧金刚云。一一云。于诸叶间。与火合体。遍满身内。满身内已。地火俱动。遍满一床。满一床已。遍满一房。满一房已。遍满一庭。满一庭已。遍满一城。满一城已。渐渐广大。遍满十顷。满十顷已。遍满百顷。满百顷已。满一由旬。满一由旬已。满二由旬。满二由旬已。满三由旬。满三由旬已。满四由旬。满四由旬已。满五由旬。满五由旬已。渐渐广大。满百由旬。满百由旬已渐渐广大。遍满阎浮提。地火二大。其性各异。更相鼓动。遍满三千大千世界。上至三界顶。下至金刚际。还从顶入。见此事已。复当更教观于风大。观风大者。自观身内。心华树间。出紫色风。水大随入。灭此风色。同为水色。风动水涌。遍满身内。渐渐广大。遍满一床。满一床已。满一房内。满一房已。遍满一庭。满一庭已。遍满一城。满一城已。渐渐广大。遍满一由旬。满一由旬已。风水二性。其性各异。风吹此水。如琉璃沫。其色焰炽。更相鼓动。遍满二由旬。满二由旬已。满三由旬。满三由旬已。满四由旬。满四由旬已。满五由旬。满五由旬已。渐渐广大。满百由旬。满百由旬已。渐渐广大。遍满阎浮提。满阎浮提已。渐渐广大。遍满三千大千世界。上至三界顶。下至金刚际。见此事已。自见己身。身诸毛孔一切火起。此火光炎。遍满三界。出三界外。如真金华。华上有果。果叶相次。彼果光中。演说四谛及十二因缘度生死法。复见身内。一切水起。其水温润。从毛孔出。流布三界。无不遍满。水色出光。照三界顶。入火光果中。复见身内。一切风起。遍满身内。从毛孔出渐渐广大。驶速飘疾。遍满三界。化为金云。入火光果中。复有地气。极为微薄。弥满四大。见此事已。复当更教谛观五阴。观于色阴。此色阴者。依地大有。地大不定。从无明生。无明因缘。妄见名色。观此色相。虚伪不真。亦无生处。假因缘现。因缘性空。色阴亦然。受想行识。性相皆空。中无坚实。观此五阴。实无因缘。亦无受有。如此四大。云何增长遍满三界。作此思惟时。见一切火。从一切毛孔出。遍满三界。还从一切毛孔入。复见一切地大。犹如金刚云。从一切毛孔出。遍满三界。还从一切毛孔入。复见水大。犹如微尘。从一切毛孔出。遍满三界。还从一切毛孔入。复见风大。其势羸劣从一切毛孔出。遍满三界。还从一切毛孔入。如是四大。从毛孔出。从毛孔入。往复反覆。经八百遍。见此事已。如前数息已。闭气而住。经一七日。尔时自然见此大地渐渐空。见一床下渐渐空。见一房渐渐空。见一房已。见一庭地渐渐空。见一庭已。见一城地渐渐空。见一城已。见十顷地渐渐空。见十顷已。见百顷地渐渐空。见百顷已。见一由旬地渐渐空。见一由旬已。见二由旬地渐渐空。见二由旬已。见三由旬地渐渐空。见三由旬已。见四由旬地渐渐空。见四由旬已。见五由旬地渐渐空。见五由旬已。乃至见十由旬地渐渐空。见十由旬已。乃至见百由旬地渐渐空。见百由旬已。乃至见阎浮提八千由旬地渐渐空。见阎浮提已。见弗婆提地十千由旬渐渐空。见弗婆提已。见瞿耶尼地三万由旬渐渐空。见瞿耶尼已。见郁单越地四万由旬渐渐空。见郁单越已。见须弥山四大海水山河石壁四天下中一切所有见坚鞕物。一切悉皆渐渐空。见四天下已。心遂广大。遍满三千大千世界。诸坚鞕物。大地山河石壁。一切悉空。心无所寄。尔时自然见金刚际。有十四金刚轮。从金刚轮下。自然上踊。更相振触。至行者前。尔时心树诸妙花端。自然火起。烧诸华叶树上四果。堕行者顶。从顶而入。住于心中。尔时此心。豁然明了。见障外事。复有六象。其正色黑。踏大地坏。吸饮诸水。风吹象杀。象耳出火。烧象都尽。四大毒蛇。走上树端。见有一人。似大力士。拔此大树。下至金刚际。上至三界顶。令树动摇。行者心中。四明珠果。复出大火。烧树荄绝。是时大树。散如微尘。行者见已。我今观于水火风等及与水大。一切无常。须臾变灭。当自观我身内四大。火起无穷。地水风等亦复如是。此无明相。空无所有。假伪颠倒。犹如霜炎。属于三界。缘于痴爱。三十三亿念生法。九百九十转。次第念粗相。结使九十有八。枝条种子。弥覆三界。为是众结。受生无数。或堕地狱。猛火焚身。或为饿鬼。吞饮融铜。啖热铁丸。百千世中。不闻水谷。或为畜生。驼驴猪狗。数不可知。人中受苦。众难非一。如是众多。从痴爱得。今观痴爱。性无所有。作是思惟时。释迦牟尼佛。放金色光。与诸声闻眷属围绕。告行者言。汝今知不。色相虚寂。受想行识。亦复如是。汝今应当谛观空无相无作无愿三昧。空三昧者。观色色性。及一切诸法。空无所有。如是众空。名空三昧。无愿三昧者。观涅槃性。寂灭无相。观生死相。悉同如实际。作此观时。不愿生死。不乐涅槃。观生死本际空寂。观涅槃性相皆同入空。无有和合。是名无愿三昧。无作三昧者。不见心。不见身及诸威仪有所修作。不见涅槃有起性相。但见灭谛通达空无所有。尔时行者。闻佛世尊说是空无相无愿三昧。身心静寂。游三空门。犹如壮士屈申臂顷。应声即得超越九十亿生死洞然之结。成阿罗汉。不受后有。梵行已立。知如道真。豁然意解。无复余习。漏尽慧通。自然而得。其余五通。要假修得六通义。广说如阿毗昙。尔时世尊。为阿只达。说是贤圣。空相应心。境界分别。十一切入相已。默然安隐。入无诤三昧。放众色光。普照世尊。是时会中。二百五十比丘。心意开解。成阿罗汉。五十优婆塞。破二十亿洞然结。成须陀洹。天人大众。闻佛所说。皆大欢喜。尔时长老阿难。即从坐起。白佛言世尊。如来初为迦絺罗难陀。说不净门。为禅难提比丘。说数息法。为阿只达。说四大观。如是众多微妙法门。云何受持。当以何名宣示后世。佛告阿难。此经名禅法秘要。亦名白骨观门。亦名次第九想。亦名杂想观法。亦名阿那般那方便。亦名次第四果想。亦名分别境界。如是受持。慎勿忘失

佛告阿难。我灭度后。若有比丘比丘尼。式叉摩尼。沙弥沙弥尼。优婆塞优婆夷。若有欲学三世佛法。断生死种。度烦恼河。竭生死海。免爱种子。断诸使流。厌五欲乐。乐涅槃者学是观。此观功德。如须弥山。流出众光。照四天下。行此观者。具沙门果。亦复如是

佛告阿难。佛灭度后。若有比丘比丘尼。优婆塞优婆夷。欲学此法者。当离四种恶。何等为四。一者净持禁戒。威仪不犯。于五众戒。若有所犯。应当至心忏悔清净。戒清净已名庄严梵行。二者远离愦闹。独处闲静。系念一处。乐少语法。修行甚深十二头陀。心无疲厌。如救头然。三者扫偷婆涂地。施杨枝净筹。及诸苦役。以除障罪。四者昼夜六时。常坐不卧。不乐睡眠。身倚侧者。乐常塳间树下阿练若处。食若鹿食。死若鹿死。若有四众。行此四法者。当知此人。是苦行人。如此苦行。不久必得四沙门果

佛告阿难。若有四众。修系念法。乃至观见脚指端手指端一节少分白骨相。极令明了。若见一指。若见一爪。一切诸白骨。当知此人。以心利故。命终之后。必定得生兜率陀天。灭三恶道一切苦患。虽未解脱。不堕恶道。当知此人。功德不灭。已得免离三涂苦难。何况具足诸白骨人。见此骨人者。虽未解脱。无漏功德。当知此人。已免一切三涂八难苦厄之患。当知此人。世世所生不离见佛。于未来世。值遇弥勒龙华初会。必先闻法。得证解脱

佛告阿难。若有比丘比丘尼。优婆塞优婆夷。于佛法中。为利养故。贪求无厌。为好名闻。而假伪作恶。实不坐禅。身口放逸。行放逸行。贪利养故。自言坐禅。如此比丘。犯偷兰遮。过时不说。不自改悔。经须臾间。即犯十三僧残。若经一日。至于二日。当知此比丘。是天人中贼。罗刹魁脍。必堕恶道。犯大重罪。若比丘尼。妖冶邪媚。欲求利养。如猫伺鼠。贪求无厌。实不坐禅。自言坐禅。身口放逸。行放逸行。贪利养故自言坐禅。如此比丘尼。犯偷兰遮。过时不说。不自改悔。经须臾间。即犯十三僧残。若经一日。至于二日。当知此比丘尼。是天人中贼。罗刹魁脍。必堕恶道。犯大重罪。若比丘比丘尼。实不见白骨。自言见白骨。乃至阿那般那。是比丘比丘尼。诳惑诸天龙鬼神等。欺世间人。此恶人辈。是波旬种。为妄语故。自说言我得不净观。乃至顶法。此妄语人。命终之后。疾于雹雨。必定当堕阿鼻地狱。寿命一劫。从地狱出。堕饿鬼中。八千岁中。啖热铁丸。从饿鬼出堕畜生中。生恒负重。死复剥皮。经五百身。还生人中。聋盲喑哑。癃残百病。以为衣服。如是经苦不可具说。若优婆塞。实不坐禅。自言坐禅。实不梵行。自言梵行。是优婆塞。得失意罪。不净有作不起。堕落臭旃陀罗。与恶为伴。是朽败种。不生善芽。贪利养故。多求无厌。经于一日。乃至五日。犯大妄语。此大恶人。波旬所使。是旃陀罗。屠儿罗刹同类。必定当堕三恶道中。此优婆塞。欲命终时。十八地狱。火车炉炭。变化恶事。一时迎之。必定当堕三恶趣中。无有疑也。若优婆塞。实不得不净观。乃至暖法。于大众中。起增上慢。唱如是言。我得不净观。乃至暖法。当知此优婆塞。是天人中贼。欺诳世间天龙八部。此优婆塞。命终之后。疾于雹雨。必定当堕阿鼻地狱。满一大劫。地狱寿尽。生饿鬼中。经八千岁。啖热铁丸。从饿鬼出。堕畜生中。生恒负重。死复剥皮。经五百身。还生人中。聋盲喑哑。癃残百病。以为衣服。如是经苦。不可具说。若优婆夷。显异惑众。实非坐禅。谓言坐禅。此优婆夷。得失意罪。垢结不净不起。堕落不净有作臭旃陀罗。此优婆夷。与恶为伴。是魔眷属。必定当堕三恶趣中。是优婆夷。过时不说。不自改悔。经须臾间。一日乃至五日。是优婆夷。贪求无厌。实非梵行。自言梵行。实非坐禅。自言坐禅。此大恶人。必定当堕三恶趣中。随业受生。若优婆夷。实不得不净观。乃至暖法。于大众中。唱如是言。起增上慢。自言我得不净观。乃至暖法。此优婆夷。是天人中贼。命终之后。疾于雹雨。必定当堕阿鼻地狱满一大劫。地狱寿尽。生饿鬼中。经八千岁。啖热铁丸。从饿鬼出。堕畜生中。生恒负重。死复剥皮。经五百身。还生人中。聋盲喑哑。癃残百病。以为衣服。如是经苦。不可具说

佛告阿难。若比丘比丘尼。优婆塞优婆夷。系念住意。心不散乱。端坐正受。住意一处。闭塞诸根。此人安心念定力故。虽无境界。舍身他世。生兜率天。值遇弥勒。与弥勒俱。下生阎浮提。龙华初会。最先闻法。悟解脱道。复次阿难。佛灭度后。浊恶世中。若有比丘比丘尼。优婆塞优婆夷。实修梵行。行十二头陀庄严身。心行念定。修白骨观。观于不净。入深境界。心眼明利。通达禅法。如此四众。为增长佛法故。为法不灭故。当密身口意。犹如有人遇身心病。良医处方。当服醍醐。尔时病者。则诣国王。求乞醍醐。王慈愍故。即以醍醐。持用赐之。因敕病人服醍醐法。当于密屋无风尘处而取饮之。饮已闭口。调四大气。勿令失度。若比丘比丘尼。服此甘露灌顶药者。唯除知法教授之师。不得妄向他人宣说。若向他说。即失境界。亦犯十三僧残之罪。若诸白衣。欲行禅定得五神通。尚不应向他人宣说。言我得神通仙咒术一切宜秘。何况出家受具足戒。若得不净观乃至暖法。不得妄向他人宣说。若向他说。即灭境界。使多众生于佛法中生疑惑心。是故我今于此众中。制诸比丘比丘尼。若得不净观乃至暖法。当密修行。令心明利。唯向智者教授师说。不得广传向他人说。若向他说。为利养心。应时即犯十三僧残。过时不忏。心无惭愧。亦犯重罪。如上所说

复次阿难。佛灭度后。现前无佛。四部弟子。求解脱者。得不净观。当密藏秘勿令他知。譬如有人。贫穷孤独。生浊恶世。属无道王。彼贫穷人。掘地求水。宿世因缘。忽遇伏藏。大获珍宝。怖畏恶王密藏此宝。不令他知。但于屏处。取此珍宝。以供妻子。密受快乐。佛灭度后。四部弟子。得禅乐者。亦复如是。当密藏之。不得广说。若广说者。犯大重罪。复次阿难。譬如长者。独有一子。遇大重病。须眉落尽。尔时长者。内自思惟。我今衰祸。唯此一子。遇此重病。当何处求觅良医。作此语已。大出财宝。募访良医。长者宿福。忽遇一医多知经方。长者白言。唯愿大师。起大慈悲。我有一子。遇患多时。唯愿大师。救疗此患。设得愈病。今我家中。大有财宝。犹如北方毗沙门天王。若子得差。唯除我身。一切奉上。不敢违逆。时彼良医。告长者言。汝今能造七重闇室。极令深密。然后可令汝子服药。服此药已。不得见人。不向他说。轻四百日。儿乃可差。佛告阿难。佛灭度后。佛四部众弟子。若修禅定。求解脱者。如重病人随良医教。当于静处。若塳间。若林树下。若阿练若处。修行甚深诸贤圣道。当密身口于内心中修四梵行。修四念处。修四正勤。修四如意足修五根。修五力。修七觉道。修八圣道分。修四禅。修四无量。心游入甚深无量空三昧门。乃至得六神道。如是种种胜妙功德。但当一心密而行之。慎勿虚妄于多众前自说得过人法。若说得过人法。如上所说。必定当堕阿鼻地狱。为告阿难。我般涅槃后。初一百岁。此不净观。行阎浮提。摄放逸者。令观四谛。一日之中。修无常观。得解脱者。如我住世。等无有异。二百岁后。此阎浮提。四部弟子。二分之中。一分弟子。修无常观。得解脱道。三百岁时。四部弟子。四分之中。一分弟子。修无常观。得解脱道。四百岁时。四部弟子。五分之中。一分弟子。修无常观。得解脱道。我涅槃后。五百岁时。四部弟子。十分之中。一分弟子。修无常观。得解脱道。六百岁时。四部弟子。百分之中。一分弟子。修无常观。得解脱道。七百岁时。四部弟子。千分之中。一分弟子。修无常观。得解脱道。八百岁时。四部弟子。万分子中。一分弟子。修无常观。得解脱道。九百岁时。四部弟子。千万分中。一分弟子。修无常观。得解脱道。千岁之时。四部弟子。亿分之中。十人百人。修无常观。得解脱道。过千岁已。此无常观。虽复流行阎浮提中。亿亿千万众多弟子。若一若两。修无常观。得解脱道。千五百岁后。若有比丘比丘尼。优婆塞优婆夷。赞叹宣说无常苦空无我观者。多有众生。怀嫉妒心。或以刀斫。或以瓦砾。打拍彼人。骂言痴人。世间何处有无常观苦空无我。身肌白净无量。云何反说身为不净。汝大恶人。宜合驱摈。此相现时。百千人中。无有一人修无常观。此相现时。法幢崩。慧日没。一切众生。盲无眼目。释迦牟尼佛。虽有弟子。所著袈裟。如木头幡。自然变白。诸比丘尼犹如淫女炫卖色以用自活。诸优婆塞。如旃陀罗。杀生无度。诸优婆夷。邪淫无道。欺诳百端。此相现时。释迦牟尼。无上正法。永没无余。佛告阿难。汝持佛语。为未来世四部弟子。当广宣说分别其义。慎勿忘失。复次阿难。汝当为来世诸众生等。当宣此言。如来大法。不久心没。汝等于佛法中。应勤精进。当观苦空无常无我等法。佛说此语时。八千天子。悟解无常。远尘离垢。得法眼净。五百比丘。即于座上。不受诸法。漏尽意解。成阿罗汉。尔时长者阿只达。并千二百五十比丘。诸天龙神。闻佛说此无常观门。心开意解。皆悉达解苦空无常。顶礼佛足。欢喜奉行

禅秘要法经卷下


禅行法想经

    No. 605

禅行法想经

        后汉安息国三藏安世高译

闻如是。一时佛游于舍卫祇树给孤独园。佛告诸比丘。比丘受教。从佛而听。佛言诸比丘。若以弹指间。思惟死想。念有身皆死。是为精进行禅。为如佛教不。是愚痴食国人施也。何况多行者。取要言之。若念不净想秽食想。一切世间。无有乐想。无常想。无常为苦想。苦为非身想。非身为空想。弃离想。却淫想。灭尽想。无我想。身死为虫食想。血流想。膖胀想。青腐想。糜烂腥臭想。发落肉尽想。一切缚解想。骨节分散想。骨变赤白枯黑亦如鸠色想。骨糜为灰想世间无所归想。世间无牢固想。世间为别离想。世间闇冥想。世间难忍想。世为费耗不中用想。世为灾变可患厌想。一切世间归泥洹想。诸比丘。若以弹指间。念此诸想之事。皆为精进行。为奉佛教。不是愚痴食人施也。何况能多行。是故可念行法想。佛说是已。皆欢喜受禅行法想经


禅要经

    No. 609

禅要经

        失译人名在后汉录

    诃欲品第一

行者求道欲修定时。尔时法师应随根相行四摄道。示教利喜广净信戒。净信戒已次除六欲。所谓色欲。形容欲。威仪欲。言声欲。细滑欲。人相欲。着上五欲。令观可得不净之相。着人相欲。令观骨人分分断相。观彼全尸能断二欲威仪欲言声欲。若观坏尸悉断六欲。可得不净有二种观。一即死尸臭烂不净。我身不净亦复如是。如是观已心生厌患。取是相已至闲静处山泽冢间空舍树下。自观不净处处可得。系心身中不令驰散。二者闻法忆想。分别自观身中三十六物。发毛爪齿涕泪涎唾。汗垢肪[月*冊]皮膜肌肉。筋脉髓脑心肝脾肾。肺胃肠肚胞胆痰癊。生藏脓血屎尿诸虫。臭秽不净聚以为身。往来五道炽然众苦。犹如浮尸随流东西。所至之处物皆可恶。又念我身以骨为柱以肉为泥。筋缠血浇如疮如毒。皮毛九孔以为门户。肠胃胞膜以为库藏。妒慢恶心谓以为身。贪求无厌犹如溪壑。是故行者除三欲想。受信施时如火毒想。救诸虫想。系死尸想。涎沫齿垢污滋味想。我无空慧坏白净想。贪爱因缘成恶露想。如是思惟惭愧具足。能度生死为世福田。若观骨人二足甲骨。指骨趺骨踝骨胫骨。膝骨髀骨胯骨腰骨。脊骨颈骨头骨颔骨。两手甲骨指骨掌骨。腕骨臂骨肘骨膊骨。胸骨心骨齿骨肋骨。左右思惟皆如目见。所著外身亦如是观。三百二十骨相拄在内。皮囊九孔恶漏于外。如是观身犹如死尸为鬼所起。行来语默常是死尸。即于我身作死尸想。青瘀想膖胀想脓烂想破坏想血涂想食残想虫出想骨锁想分离想腐败想世界众生无可乐想。若心恐怖。应作因缘虚妄空观。犹如幻化无所有观。第一义空清净智观。若心懈怠。当自责言。老病死苦甚为至近。命如电逝须臾难保。人身难得善师难遇佛法欲灭正言似反。如晓时灯虽有无用。恶人出家助俗毁法。贪淫邪浊令道衰酢。恶法增长大闇将至。破定因缘众患甚多。内诸烦恼外魔魔民。鬼疫行灾世间空荒。恶对扬谤诸恼万端。八苦轮回昼夜无舍。我身可哀属当斯祸。于烦恼贼未有微损。于禅定法未有所得。虽服法衣犹思欲味。内实虚空俗人无异。诸恶趣门一切皆开。诸善法中未入正定。于诸恶法未毕不作。我今云何着是屎囊而生憍恣。不能精勤制伏其心。如此弊身贤圣所呵。不净可恶九孔流出。若贪此身与畜生同。死投大黑闇当复何依。今得人身不能出要。若生恶趣解脱何由。如是鞭心还摄本处。又时劝发令心喜悦。解脱法王慧命常住。神通光明恒照五道。直说道教易解易行。既是我师我得归命。香华赞叹心安喜悦。如依天帝游空无畏。诸大菩萨阿罗汉等皆我同伴。以能伏心如猫制鼠。诸根调顺六通自在。我亦如是应自伏心求出生死。如囚在狱四顾牢密。唯有厕孔更无异路。如人中毒唯粪能治更无余药。思惟是已谛观不净。复作是念。初习行时心多进退。八法恶风吹破我心。我若得道心安若山。上妙五欲尚不能坏。何况弊欲。如大目连得罗汉已妇将伎人盛自庄饰欲坏目连。目连尔时为说偈言

  汝身骨干立　　皮肉相缠裹
  不净内充满　　无一是妙物
  皮囊盛屎尿　　九孔常流血
  如鬼无所直　　何足以自贵
  汝身如行厕　　薄皮以自覆
  智者所弃远　　如人舍厕去
  若人知汝身　　如我所恶厌
  一切皆远离　　知人避屎坑
  汝身自严饰　　香花以璎珞
  凡愚所贪爱　　智者所不惑
  汝是不净聚　　集诸秽恶物
  虽服珍妙衣　　如庄严厕舍
  汝胁肋着脊　　如椽依梁栋
  五藏在复内　　不净如屎箧
  我观汝不净　　犹如五色粪
  饰以珠璎珞　　外好如画瓶
  若人欲染空　　终始不可着
  汝欲来娆我　　如蛾自投火
  一切诸欲毒　　我今已灭尽
  五欲已远离　　魔网已坏裂
  我心如虚空　　一切无所著
  正使天欲来　　不能染我心
  堕俗生世苦　　命速犹电光
  老病死时至　　对来无豪强
  无亲可恃怙　　无处可隐藏
  天福尚有尽　　人命岂久长
  最脆不过命　　如风吹浮云
  浮云坏甚速　　形命不久连
  身死魂灵散　　当知非我身
  勉时力精进　　难得不过人
  生死不断绝　　贪欲嗜味故
  养怒益丘冢　　唐受诸辛苦
  身臭如死尸　　九孔流不净
  如厕虫乐粪　　愚贪身无异
  虽明在宫中　　五欲色味间
  志意不甘乐　　常思幽隐禅
  昼夜观窗牖　　有天叉手言
  时至今可行　　众伎皆睡眠
  世间不足乐　　恒与忧恼俱
  恩爱正合会　　当复之别离
  家室转相哭　　不知死所趣
  慧人见苦谛　　是故行学道
  世间欢日少　　忧恼甚太多
  安由得此苦　　自作不由他
  俗人乐恩爱　　道以为怨家
  富贵是苦本　　如鸟堕网罗
  人命甚速驶　　五马不能追
  残命日灭尽　　各各自思惟
  恩爱正合会　　夫盛当有衰
  是故自拔出　　得道当来归　禅要经


长爪梵志请问经

    No. 584

长爪梵志请问经

        大唐三藏法师义净奉　制译

如是我闻。一时薄伽梵。在王舍城鹫峰山中。与大苾刍众千二百五十人俱。并余苾刍苾刍尼。近事男近事女。国王大臣。沙门婆罗门。外道之类。天龙药叉人非人等。瞻仰而住

尔时世尊。为说自证微妙之法。所谓初中后善。文义巧妙。纯一圆满。清净鲜白。梵行之相

尔时有一长爪梵志。来诣佛所。策杖而立。问言乔答摩。汝曾实作如是宣说。世由自业。业为能授。业为生处。业为亲族。业为所依耶

佛告婆罗门。我作是说。世由自业。业为能授。业为生处。业为亲族。业为所依。婆罗门曰。若如是者。沙门乔答摩。先作何业。令汝获得金刚不坏坚固之身。佛告婆罗门。我于前生。远离杀害有情命根。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得手指纤长网缦为相。佛告婆罗门。我于前生。远离偷盗他人财物。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得具足色力诸根圆满。佛告婆罗门。我于前生。远离女人欲染之事。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得出广长舌自覆其面。佛告婆罗门。我于前生。远离妄语诡诳于人。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得威仪庠序如师子行。佛告婆罗门。我于前生。远离诸酒放逸之处。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得微妙相好庄严其身。佛告婆罗门。我于前生。远离歌舞倡艳之事。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得上妙香气芬馥其身。佛告婆罗门。我于前生。远离香花璎珞庄饰。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得受用金刚胜妙之座。佛告婆罗门。我于前生。远离高床大床骄恣之物。由彼业力。今获斯果

沙门乔答摩。先作何业。令汝获得四十牙齿鲜白齐平。佛告婆罗门。我于前生。远离非时饮啖诸食。由彼业力今获斯果

沙门乔答摩。先作何业令汝获得顶上肉髻圆满姝好。佛告婆罗门。我于前生。于三宝二师沙门婆罗门父母尊长。应恭敬处。五轮着地。以无慢心虔诚致礼。由彼业力今获斯果

时婆罗门。见佛为说因果不虚。白言。乔答摩此名何福。云何受持。佛言。此名八支净戒。若能一日一夜。或复长时。从师受持。获果如是

尔时长爪梵志。既于佛所。闻说八支日夜净戒。由先远离鄙恶业故。便能获得胜妙庄严。深心信受。欢喜踊跃。即于佛前舍高慢心。投杖于地。合掌恭敬。礼佛双足。白言。世尊。我今始知善恶之业感报不虚。我从今日乃至尽形。归依佛陀两足中尊。乃至尽形。归依达磨离欲中尊。乃至尽形。归依僧伽诸众中尊。我受八支近住净戒。始从今时。乃至明旦日出已来于其中间

  不害一切命　　不盗他财物
  不淫不妄语　　饮酒放逸处
  花庄及歌舞　　高大非时食
  我今悉远离　　受持净八支

第二第三亦如是说

佛告婆罗门。善哉善哉。如是应作。如是应持。尔时世尊。说是法已。时婆罗门。及苾刍众。诸人天等。皆大欢喜。信受奉行长爪梵志请问经


称赞大乘功德经

    No. 840 [No. 841]

称赞大乘功德经

        大唐三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。住法界藏诸佛所行众宝庄严大功德殿。与无央数大声闻众大菩萨俱。及诸天人阿素洛等无量大众前后围绕

尔时会中有一菩萨。示为女相名德严华。承佛威神从座而起。稽首作礼而白佛言。何等名为菩萨恶友。新学菩萨知已远离。尔时佛告德严华言。我观世间。无有天魔梵释沙门婆罗门等。与新学菩萨。于无上菩提为恶知识。如乐声闻独觉乘者。所以者何。夫为菩萨。必为利乐诸有情故。勤求无上正等菩提。乐二乘人志意下劣。惟求自证般涅槃乐。以是因缘。新学菩萨不应与彼同住一寺。同止一房。同处经行。同路游适。若诸菩萨。已于大乘具足多闻得不坏信。我别开许与彼同居。为引发心趣菩提故。若彼种类善根未熟。不应为说大乘法教。令生诽谤获罪无量

新学菩萨但应亲近久学大乘多闻菩萨。为于无上正等菩提。所种善根速成熟故。不应亲近乐二乘者。所以者何。彼障菩萨菩提心故。彼令弃舍菩提心故。彼令亏损菩提心故。彼令毁犯菩萨行故。菩萨宁当弃舍身命。不应弃舍大菩提心。发起趣求二乘作意。若诸菩萨劝诸有情。舍菩提心趣二乘地。若诸菩萨劝诸有情。舍菩提心造诸恶业。俱堕地狱受诸剧苦。菩萨宁守大菩提心。造五无间受地狱苦。终不弃舍大菩提心。而欲趣求预流果证。菩萨宁守大菩提心。百千大劫受地狱苦。终不弃舍大菩提心。而欲趣求一来果证。菩萨宁守大菩提心。受傍生身或作饿鬼。终不弃舍大菩提心。而欲趣求不还果证。菩萨宁守大菩提心。造十恶业堕诸恶趣。终不弃舍大菩提心。而欲趣求无生果证。菩萨宁守大菩提心。入大火坑救诸含识。终不弃舍大菩提心。而同怯贼投涅槃界

菩萨哀愍一切有情。于生死中轮转无救。初发无上菩提心时。一切天人阿素洛等皆应供养。已能映夺一切声闻独觉极果。已能摧伏一切魔军。诸恶魔王皆大惊怖。时德严华闻佛语已。重请佛言。何谓魔军。惟愿世尊哀愍为说。佛告德严华。若有闻说大乘法教。不生随喜不乐听闻。不求悟入不能信受。反加轻笑毁訾凌蔑。离间谤讟捶打驱摈。应知此等皆是魔军。是则名为乐非法者。性鄙劣者。求外道者。行邪行者。坏正见者。应知此等谤毁大乘。当堕地狱受诸剧苦。从彼出已生饿鬼中。经百千劫常食粪秽。后生人中。盲聋喑哑支体不具。其鼻匾[匚@虒]。愚钝无知形貌矬陋。如是渐次罪障消除。流转十方。或遇诸佛亲近供养。复闻大乘闻已或能随喜信受。因此便发大菩提心。勇猛精勤修菩萨行。渐次进学。乃至菩提

诸佛世尊无别作意。为有情类说五乘法。由本愿力依法界身。于一切时。从诸毛孔任运流出无量法光。以一妙音等澍法雨于一众会无量有情。昔来信乐声闻乘者。闻佛为说声闻乘法。昔来信乐独觉乘者。闻佛为说独觉乘法。昔来信乐无上乘者。闻佛为说无上乘法。昔来信乐种种乘者。闻佛为说种种乘法。昔来信乐人天乘者。闻佛为说人天乘法。傍生鬼等。亦闻如来以随类音而为说法。若有昔来未闻法者。彼惟见佛处众默然。曾闻大乘而诽谤者。经无量劫堕大地狱傍生饿鬼及天人中备受苦已。闻大乘法即能随喜深生净信。便发阿耨多罗三藐三菩提心。时德严华闻佛说已。重请佛言。何谓大乘。此大乘名为目何义。世尊告曰。善哉善哉。汝能乐闻大乘功德。谛听谛听。善思念之。吾当为汝分别解说。此大乘名所目诸义。此乘综摄。笼驾弘远无所遗漏。故曰大乘。此乘功德甚深微妙过诸数量。故曰大乘。此乘坚固虚妄分别不能倾动。故曰大乘。此乘真实穷未来际无有断尽。故曰大乘。此乘寥廓该罗法界邈无边际。故曰大乘。此乘如海吞纳蕴积功德宝聚。故曰大乘。此乘如山作镇区域邪徒不扰。故曰大乘。此乘如空包含一切情非情类。故曰大乘。此乘如地普能生长世出世善。故曰大乘。此乘如水等润一切令无枯槁。故曰大乘。此乘如火焚灭诸障令无余习。故曰大乘。此乘如风扫除一切生死云雾。故曰大乘。此乘如日开照群品成熟一切。故曰大乘。此乘如月能除热恼破诸邪暗。故曰大乘。此乘尊贵。天龙八部咸所敬奉。故曰大乘。此乘恒为诸健达缚歌咏赞美。故曰大乘。此乘恒为四王梵释礼敬尊重。故曰大乘。此乘恒为诸龙神等敬事防守。故曰大乘。此乘恒为一切菩萨精勤修学。故曰大乘。此乘任持诸佛圣种展转增盛。故曰大乘。此乘圆满具大威德映夺一切。故曰大乘。此乘周给一切有情令无匮乏。故曰大乘。此乘威力犹如药树救疗众病。故曰大乘。此乘能害一切有情诸烦恼贼。故曰大乘。此乘能转无上法轮饶益一切。故曰大乘。此乘微妙甚深秘密不可宣说。故曰大乘。此乘神用绍三宝种能使不绝。故曰大乘。此乘能显世俗胜义理趣究竟。故曰大乘。此乘能显诸菩萨行无不具足。故曰大乘。此乘能显佛地功德无不备悉。故曰大乘。此乘利乐一切有情尽未来际。故曰大乘。此乘至功能建大义妙用无尽。故曰大乘。此乘幽玄下劣意乐不能信受。故曰大乘。此乘平等增上意乐方能信受。故曰大乘。此乘广大下愚不测而为轻笑。故曰大乘。此乘尊高上智能达常所宝玩。故曰大乘。此乘超过独觉乘等最上无比。故曰大乘。

佛说如是大乘名义体用殊胜诸功德时。于此三千大千世界六种震动。空中天乐百千万类。不鼓自呜。诸妙天花缤纷乱堕。无量天子无数声闻。闻此法音睹斯瑞应。皆发阿耨多罗三藐三菩提心。百千俱[并*氐]新学菩萨。同时证得无生法忍

尔时阿难即从座起。合掌恭敬而白佛言。今此法门甚为希有。能普利乐一切有情。当以何名奉持流布。佛告阿难。此经名为称赞大乘功德。亦名显说谤法业障。以是名字汝当奉持。时薄伽梵说此经已。阿难陀等无量声闻。德严华等无数菩萨。及诸天人阿素洛等一切大众。闻佛所说皆大欢喜。信受奉行称赞大乘功德经


持人菩萨经

    No. 481 [No. 482]

持人菩萨经卷第一

        西晋月氏三藏竺法护译

    持人菩萨经四事品第一

闻如是。一时佛游王舍城加邻竹园中。与大比丘众千二百五十。菩萨不可计。一切大圣神通以达。辩才无碍慧不可量。诸根寂定见一切本。应病与药靡蒙济。为法桥梁度脱三界也。尔时世尊。与无央数百千之众眷属围绕而为说经。时持人菩萨即从坐起正服长跪。前问佛言。菩萨何行建立誓愿。无限功勋晓了诸法。分别一切诸度无极。识解无量方便善权。弘要被不可喻。戒德大铠真正道义。为众生愿弘恩仁慈。覆如虚空不可测度。其心清净德行具足。布施持戒忍辱精进一心智慧。普度无极。若有众生欲奉斯业。殊特之原无上大道今故为斯。如此等类启问如来。菩萨大士咨问如来言教处所。周游三界所行备悉。勤修禁戒无所忘讲。奉清净行游居成办遵无极慧。无量方便随时开化。为此众生有心存法。不能自达故问如来。何谓菩萨晓了诸法。能以随时为人班宣。其心坚强力念不忘。致微妙慧解一切法。章句谊理所生之处。常识宿命不中忽忘。至成无上正真之道为最正觉也。佛言。善哉善哉。持人菩萨。多所哀念多所安隐。愍伤诸天及十方人。乃为一切咨问如来如斯要义。功勋之德不可尽极。决一切疑犹豫罗网。以大弘慈加于众生显示大明。现在将来诸菩萨施行无盖哀。为众生故普现大道。兴举弘誓将护一切。为开发化济众厄令得自归。使度彼我拔济众生。不堕三恶勤苦之狱。乃以劝之使立大道无上正真。欲脱众生生老病死啼哭之恼忧困之患使长安隐。将来最后末世流布正法。消大恐畏令无所惧。谛听谛听善思念之。持人菩萨与诸大众受教而听。佛语持人。菩萨有四事义。观其言教晓了诸法。能以随时为人颁宣。何谓为四。心念成就逮致正真。志存道法未曾忽忘。性行柔和庠序仁慈。其心所兴与众殊异。是为四。复有四事。何谓为四。分别道义决诸种姓。晓了众行义理所趣。宣布一切诸法至要。达诸法本随而开度。是为四。复有四事。何谓为四。解无央数所行诸法。以行超越畅无量法。所当应宜剖判所行。无底功勋识别诸法因断诸习。是为四。复有四事。何谓为四。因其正行逮无上正真之道。疾具足灭道行之法三十七品。通达诸法自然之智无所依仰。解权方便成一切愍。是为四。复有四事。何谓为四。心离秽垢不怀悭嫉。以是恩仁摄众生类。其戒清净所行解明。常奉精进未曾懈废。勤修清净建立成就。晓了顺行专思道业。是为四。复有四业。何谓为四。志性清净所愿解明。所行功勋至德清净。忍辱仁和建立妙法。以逮显明无所不照。分别经义畅入道门。是为四。复有四业。何谓为四。夙夜勤修求一切智。志存一心定意正受。晓了脱门奉于大哀。无极之慈喜护济厄。逮致深慧修清净行。畅达正义解了道行。是为四。复有四业。何谓为四。遵承智慧所行具足。圣明清净志愿弘大。爱乐至德无挂碍慧。心存普救未曾舍行。是为四。复有四事。察言观义心誓坚固。何谓为四。其意坚强所求具足。性行安详所思备悉。其行究竟不断道念。修四意止成就雅德。是为四。复有四事。察言观义志存坚固。何谓为四。意以得立心念佛业道品之法三十有七。意根通利晓了往宿无央数劫所生之处。意以平正圣慧清净。无能毁断疾成佛道。摄取至真佛一切智。是为四事。复有四事。何谓为四。察识方便慕具慧义。晓了勤修显真谛慧。缘是亲近得至佛道。所行精进未尝忽忘。是为四。复有四事。志性坚固。何谓为四。常奉精进不远佛道。志性安和能制其意。普解诸法未曾放逸。解畅众道诸根寂定。常应经义不违佛教。是为四。复有四事。志性坚固。何谓为四。立清净戒所行无秽。去五阴盖不为所蔽。心无所著未曾懈废。蠲除众罪所灭尘劳。是为四。复有四事志性坚固。何谓为四。心不愦乱求正真法。方便安心顺一切法。晓了随时不失仪节。所生之处不贪家业志存沙门。是为四。复有四事志性坚固。何谓为四。常亲善友远恶知识。志慕深法未曾放逸。归命诸佛诸菩萨俱。咨问禁戒晓了诸观。是为四。复有四事。观义察言普解法句。何谓为四。建众方便了诸道业。解诸法门因缘报应。志上慧义分别佛道。解畅诸法章句所趣。是为四。菩萨复有四事。观义察言晓了分别诸法章句。何谓为四。解畅宣布真实言教。敷演诸法无所不达。剖判诸法方便具足。明知诸义本所从习。是为四。复有四事观义察言。何谓为四。奉行圣慧分别道业。逮得势力宣布诸法。速成佛道清净之慧。明度无极普以备足。是为四。复有四事分别诸法。何谓为四。晓了所习精进修行。消灭因缘靡所不了。因其逮得应真之力。随时勤修奉受正典。是为四。复有四事分别诸法。何谓为四。晓了万物一切无常。分别万物本因所习。精练诸物皆归灭尽。解知无常便修道业八正真元。是为四。复有四事分别诸法。何谓为四。晓了众行合会诸习。分别一切灭尽诸习。逮得因缘无极大力。方便断别合散之行。是为四。复有四事分别诸法。何谓为四。解畅诸义言辞所趣。晓了众义不从他受。敷演诸法一切众相慧印之源。令一切法立无相慧。是为四。复有四事。所生之处常识宿命心念不忘。至成无上正真之意。何谓为四。诸根明利畅善恶法。以了他人意念是非。一切阴盖咸得休息。所生之处常念不忘。志在无上正真之道。是为四。复有四事。心念不忘至成正觉。何谓为四。常行定志晓习方便。智慧通畅明慧为首。明所行观无所不睹。分别道慧光明远照。是为四。复有四事。心念不忘至最正觉。何谓为四逮得总持无所生慧。以得超越永尽圣慧。以消灭慧观于三界。以无底慧睹见三世。是为四。复有四事。所生之处常识宿命。无能乱者至成正觉。何谓为四。以断结着莫能乱者。口之所言未曾阙漏。皆达一切诸有业患悉是无为。逮得佛行无极大道。是为四。佛于是颂曰

  其心念成就　　志性常明了
  未曾忽忘法　　由是致正觉
  晓了一切法　　柔和行仁慈
  以达诸法无　　解无央数行
  遵承真智慧　　圣达以具足
  去心之秽垢　　未曾怀嫉妒
  方便以随时　　分别无上慧
  志愿甚弘大　　乃至最正觉
  其意得自在　　道品三十七
  心根以通达　　识宿无数劫
  知苦所由生　　习因本根无
  一切所有尽　　解之悉本无
  以菩萨正法　　开化三界厄
  使诸无明者　　皆通无上道

佛告持人。菩萨有五事。行清净力逮斯德句。何谓为五。以仁和性本净慧力。所愿清净。圣明慧力德本清净。道力无量所誓清净。则是慧力休息罪业慧力清净。是为五。清净慧力复有五事。何谓为五。其力以畅威仪礼节。斯念成就清净慧力。善权方便晓无秽力。为众生故圣力解明。以通达力勤修瑞应。是为五。复有五事。清净慧力逮是一切功勋之业何谓为五。布施清净则谓慧力。救摄众生则清净力。建立大慈则净慧力。心怀大哀则净慧力。以无极喜护净慧力。是为五。复有五事。为清净力逮是功勋。何谓为五。其戒清净成无权慧。以戒禁行救济慧行。忍清净莫能怀恨。以净慧力救济无势。博闻清净力靡不通。是为五。复有五事具诸功勋。何谓为五。以精进行志性慧力。以能勤修应清净慧。一心慧力疾得定意。了禅定慧。以寂然净察三界空。是为五。复有五事逮是功勋。何谓为五。智慧清净博闻无厌。以见世力得度世力。强而有势救脱劣弱。以圣明力晓了清净。以净慧力畅达有无生死无为。是为五。复有五事。成圣明力逮是功勋。何谓为五。以承智力剖判诸观。以晓了力究竟本净。慧明解脱以成圣力。尽无生慧致于道力。以一相自然净。用智力察所有本净。是为五。佛告持人。菩萨大士常当奉行如是比像清净之法。佛于是颂曰

  五力无能当　　乃致清净慧
  五阴盖消除　　神通自然成
  布施持戒忍　　精进一心慧
  六度本无形　　行者因有名
  道行为一切　　诸有不达经
  解三界犹幻　　乃致无从生

佛告持人。菩萨大士有三事法。虽在盛色以法净力常勤修慧。何谓为三。好乐道法。精进不惓。行无放逸。是为三。复有三事。在于色法慧力清净。疾成佛道至一切智。所以者何。勤精进者无放逸本成就诸法。以是清净逮致道力。速成精进。一切愍慧行不回转。以不回转究畅道法。成就功德已成功勋。疾逮诸法通达慧力。以逮是者则世众祐。便致畅毕无碍之德。乃行如来。逮得圣慧观如来。不久证明如来道慧。佛告持人。佛往宿世行菩萨业无央数劫。为灯光佛所见授决。最后究竟。逮如是像清净慧力。所度无极。若有菩萨致是慧者便转法轮。我亦如今所转法轮。畅师子吼。亦复若斯。以致斯慧。便于诸法而得自在。已得自在便成大道。若欲逮是无极道慧。当学是法。亦复不久当疾得佛无极正觉

    持人菩萨经妙慧超王佛品第二

佛告持人。乃往过去久远世时。无央数劫不可称限。越是无量。尔时有佛。号妙慧超王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。其佛世时诸声闻众不可计数。其诸菩萨无央数会。皆是其佛本学道时至愿所致。佛国清净功勋巍巍。其佛国土无三恶趣八难之处。众生安隐福同快乐。皆离贪欲除去五盖。如是比像无世俗义。唯以道品而相娱乐。以四禅定而行正受。佛言。持人。其妙慧超王如来。寿八十亿垓百千劫。其国土人寿三十亿垓。当尔世时无有国王典制万民。唯以妙慧超王如来至真为法王。咸共称曰无上道王。其妙慧超王如来至真。诸菩萨众能为一切。普决疑网多所欢悦颁宣菩萨无极法藏。时诸菩萨闻佛所说如是比像清净法力。五百菩萨一心精进夙夜殷勤。不想念坐不想求食。尽其形寿不念服饰。唯念至真无极道王。思是像法清净法力。以是一心德本所致。于彼寿终生于东方。去是佛土八千亿国。适生未久亦逮此法。识念不忘悉见宿命。睿哲聪明诸根通达。无所不睹探古知今。又其佛土。佛号无量华王。讲说经法。是五百人生彼佛土。寻时其身年如十六。即报父母出家捐业。行作沙门净修梵行。在其佛所奉行精进六十亿岁。佛语持人。于彼世时五百菩萨。如是比像。值见诸佛二十亿。普在其所夙夜精进。妙慧超王如来至真。使五百人于万劫中。值二万佛而授其决。当逮无上正真之道。以亿万劫供养奉事二万佛讫。是五百人皆同一劫次第成佛。是故持人。菩萨大士速欲逮成无上正真为最正觉。当精进学如是比像。清净慧力经典之要。夙夜勤修。勿得懈废为放逸行。所以者何。诸佛本学皆由精进。无逸为本致最正觉普具道品。佛皆识念往昔古世精进如是。见是十二亿诸佛世尊所生之处。当得意力探古知今无所不通。各各识知一切宿命。如近不远悉睹见之。皆由精进学是法故无放逸行。夙夜勤修未曾懈废

尔时世尊以无极慈。兴大悲哀观于四方。即如其像三昧正受。化现诸佛周遍三千大千世界。各为众生颁宣经道决诸狐疑。闻各开解莫不欢悦。复重为演菩萨之法。尔时世尊寻现神足显其威德。使竹园中诸会菩萨。皆见十方诸如来。在其世界敷演经法。时诸菩萨各从坐起。叉手自归为佛作礼。各自叹曰。至未曾有。诸佛世尊威德圣慧不可思议。道法超殊巍巍无量。犹如虚空不可攀逮。时佛即告诸菩萨曰。是不为难。如来至真不可限喻。所以者何。族姓子。解诸法界无所不达。所解法界如来至真。其一毛德神足变化不可称限。光明普照江河沙等十方世界。其光明中各演音声颁宣经道。其一毛孔亿百千垓。神足变化不足为难。所以者何。如来至真神足功勋不可限量。巍巍如是。又族姓子。如来至真见众生心以为说法。少有信乐如是像法。精进勤修志乐慕求。是无量法亦复希有。所以者何。如来今兴在五浊世。何谓五浊。一者人多弊恶不识义理。二者六十二疑邪见强盛不受道教。三者人多爱欲尘劳兴隆不知去就。四者人寿命短。往古世时八万四千岁以为甚损。今寿百岁或长或短。五者小劫转尽三灾当起无不被害。若有在此五浊恶世能信乐是。如斯像法深妙道义。有一人好能受如此佛正真慧。是为甚难至未曾有。何况信乐如来所行受持乎。族姓子。佛从古无央数劫。被大德铠长夜遵习如是像法精进忍辱仁慈博爱。若见众生在于厄难。勤苦之患无救护者。心生恐惧堕于恶趣。愿生彼土导利众生。救济众厄令入正道。如来至真德不可量。如空无侣勇健独步度脱十方。是佛往昔过去世时本愿清净。今有信乐是无量法深妙之义爱喜受持。皆往古昔曾见被训故今信喜。现人少有信乐。于斯如来所显如来十力四无所畏。十八不共诸佛之法空无之慧。希有好喜入斯法者。若有入斯皆是如来威德所致。神足变化勇猛功勋。佛以慧力善权方便。长夜开化勤修不解。皆由往宿矜矜一心不舍此法。常行大慈修无盖哀。大喜大护救济众生。又族姓子。诸菩萨学少有愍念。于五浊世成最正觉。为诸众生在五浊世。开导大难亦复希有。如吾于今所立教训。所以者何。往古宿命通大精进积功累德。每生自克布施头目。肌肉支体妻子国邑。群从车乘无所爱吝。不计身命无所贪慕。三界无怙惟道可恃。以无极力行权方便开化众生。能成无上正真之道。佛悉忆念往宿世时。一日之中所施无量。并惠身命无所爱惜。皆由愍念众生之故。开化盲冥令见道明。亦识往宿无数世时。见饥馑者无有饮食。供养之具可用施者。割己股肉煮之炙之。持用授之不以作患。心不怀恨惟行大哀。愍伤众生奉无极慈。以是之故当作斯观。遵修如是通大精进开化众生。如斯精进积累功德。逮致无上正真之道。是故诸仁。诸族姓子。勤学如是微妙精进。以习如是无极道法。亦当如我往昔所行菩萨之业开化众生。如是无异颁宣经道。亦如我今有所救脱。是贤劫中所兴千佛皆当咨嗟。吾本所行各当说言。能仁如来本行精进。不可限量不可班喻。道慧巍巍所度无极。于五浊世五逆乱中开化众生。如是无穷不可计尽。是故族姓子。假使有人如是比像奉精进行。爱乐勤修而无放逸疾成正觉。又吾于是逮无上正真道为最正觉。临灭度时所度无量。若有能遵如是精进。应如至教而不懈废。取如芥子佛之舍利建立塔寺。皆当得佛灭度之业。所以者何。佛兴愍哀为诸将来众菩萨施。本为菩萨行佛道时曾所训诲。由是缘故显示大道。又复慈愍堕八难者。故兴大哀普布舍利。若取舍利大如芥子建立塔寺。面见如来手自供养。灭度自后睹其舍利。心怀悦豫所立地处。以是地施于舍利而兴塔寺。随心所愿兴于大哀。本宿命时行菩萨法。等心众生誓愿所致舍利遍流。佛所积功累德。光光不可限量。巍巍如是。愍念众生兴于大哀。最后末世立无极慈加于一切。若有菩萨受是像法。好喜慕乐勤修精进而不放逸。用至愿故最后末世受如是像。弘雅经典能持讲诵。为他人说令普流布建立菩萨。若有持诵为他人说。以是像典劝诸菩萨。令学讽诵转复宣布。所以者何。若是景摸久在天下。则佛正道永长现矣。如来常存以是观之。族姓子。佛本往世如是方便。摄护众生建是经典。以用将养未来俗世。在五浊世宣布斯典。若族姓子。所在郡国县邑。州域大邦。如是像典所流布现。受持讽诵广为人说。如是学士。族姓子等。见佛现在临灭度时如来游彼。佛则现在而不灭度。所以者何。族姓子。佛不曾说乎。佛者法身。若见法者则睹如来。莫以色身观于如来。若信正典闻见受持则睹如来。闻法奉行住如法教乃曰见佛。闻宣正典顺法入道乃曰见佛。佛以未曾以法生法。以能行法敷演正典。不怀妄想猗求诸法则睹如来。一切诸法悉无所著。尔乃名曰睹如来耳。若族姓子。不见诸法则睹如来。所以者何。如来至真不存有法非法之辞。不当观见如来。所以者何。如来曾说假引譬喻。犹如缚筏。尚当除法况非法乎。以除是法非法之行乃见如来。所以者何。如来至真皆除诸法。不宣诸法而有处所也。无所兴起亦无名号。况复讲说诸处所乎。所以者何。皆除一切诸法。若能顺斯如来观者。则见如来也。佛本以断一切诸法乃睹正觉。所以然者。一切诸法皆虚不真。睹一切法本无本净。观真谛者乃见如来。又族姓子。不得诸法则无诸法。谓无放逸。彼无有法亦无非法。以无有法亦无非法乃以了斯义。以了斯义乃见本净。以平等观乃见如来。见法如是则见如来。观如来然见平等觉。若有异观如来至真则为邪观。已邪观者。则为虚观。不真谛观也。又族姓子。其真谛者消除一切音声言辞。不真不虚亦无真虚。蠲去一切诸所有业。悉不复得一切所受乃见如来。所以者何。如来至真不睹诸法。有所生者若令生者。以除一切所见诸法。乃曰自然。以解自然。如是观佛乃谓吾等观佛如是。所见若斯。佛之所说也。如是观佛皆入一切诸法本无。已了一切诸法本无。便了诸一切本无兴显道法。分别诸行一切本净。一切诸法归于本无。一切诸法皆如来法也。自然入道。一切诸法皆以普入如来境界。一切诸法界不可议成最正觉。故族姓子。佛说言一切诸法皆如来界。无有境界为如来界。所以者何。一切诸法所有境界。计彼诸法无有境界。则如来界也。一切诸法以为境界。无斯诸界乃曰有界。所有界者亦如来界。一切众生行无境界。而悉晓了真谛净界。虽知是法永不解达。如来至真解达如是无所不通。是故名曰无有境界也。如来界无所有界。则如来界也。所以者何。佛说诸界真谛本末。无有诸界乃如来界。一切诸界如来界也。无界非界分别晓了靡所不达。是谓证明。无所有界。则如来界也。唯族姓子。解一切法是无境界。则如来界也。乃入道义。观如是法。尔乃逮致如来境界。乐无所乐是如来界。而无所著亦无憎爱。所以者何。以知无界乃曰佛界。故言无有界则如来界。用一切法不可得故无有处所。于一切法无所著故。是则名曰如来境界。游居入慧。一切诸法悉无所入。故无六门亦无所入。所以者何。族姓子。皆无有门亦无所入则无有见。所以者何。如来至真不得诸法。有所入处也。而有所见也。有所说者也。亦无善恶粗细微妙言辞本末。是则名曰入一切法。入无有相无应不应。一切诸法。不精进不懈怠。无合不散。是乃名曰一切法门。曰无名门。无言辞门。无所入门。无所著门。无训诲门。无生门。永寂然门。不以是门可用知法。若见法者不以法门。永寂然门。不以是门可用知法。若见法者不以法门能证诸法。亦无所出入。所以者何。一切诸法皆无有门门不可得。一切诸法为虚伪门。一切诸法悉本清净。一切诸法门不可量。一切诸法无断不断无有边际。故曰族姓子一切诸法悉不可得皆虚无实。一切诸法门不可量不可得限。其本际门不可尽极无能断坏。得本际者若坏本际。真实之义也。若族姓子及族姓女。至斯法门悉解达了。因得普入一切法门。皆能颁宣众生心。时佛复告持人菩萨。若有菩萨大士。欲以方便解一切法。分别诸法义之所趣。欲得意力具足成就。随时之宜入于诸法。所生之处心断绝。若以寂定心念。成无上正真之道。志习入斯比像法门。若能逮得是法门光。勤学斯法速疾归附

持人菩萨经卷第一持人菩萨经卷第二

        西晋月氏三藏竺法护译

    持人菩萨经持施王品第四阙第三品

佛告持人。乃往过去无央数劫。加复越是不可计劫。尔时有佛。号意普玉王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。其佛世时。有八十亿垓沙门众。皆阿罗汉诸漏已尽。习学不学阿那含斯陀含须陀洹。亦复如是各八十亿垓。诸菩萨八十四亿兆载集会佛所。佛言。持人。彼时如来寿八万岁。时世有王名曰持陀。君二万国。民人炽盛。风雨时节五谷丰饶万姓安隐。王所居城广长正方各四百八十里。其城皆以琦珍四宝成之。其墙七重。树木深堑栏楯周匝各复七重。网缦珠珞各复七重。诸墙壁上及诸行树。皆以四宝交露帐幔。而围绕覆。其二万国各有五百郡县属之。又其树上皆生好衣。自然七宝诸细被服。一一池水各有五百浴池从之。又其浴池皆七宝成。生七宝莲华。青红黄白满其池中。其华大如车轮。斯池中水自然八味。其土国王。有八万四千夫人婇女。中宫正后有二太子。一名无限意。二名无限界。其太子各十六。时二太子适卧寐。于梦中见如来形像。端正姝好紫摩金色。相好庄严威德巍巍。不可限量光照十方。梦中见是心中踊悦欣然无量。其二太子。从梦觉已心中坦然。各以宿怀识道正真。而叹颂曰

  我今夜梦见　　天人中最胜
  体紫摩金色　　百福成其相
  以在其梦中　　观一切功勋
  以得觐尊颜　　怀悦豫无量
  观圣神光明　　犹日演晖曜
  意中甚欢乐　　超越一切众
  威光极高峻　　犹如宝山王
  若目睹其形　　靡不抱欣喜

佛告持人。其二太子见是瑞应。往见父母具说此意。我等兄弟今日夜梦中。目见如来至真。故启二亲欲往奉诣如来。兴现在世。教化以来久矣。我等放逸没五所欲不觉佛兴。而为五阴之所缚结。诸恶罗网之所覆蔽。在于自大无恭恪心。以斯迷惑。不见如来咨受道慧。二亲然之。时二太子启父母已。往诣意普玉王如来所。前稽首足。白世尊曰。罪盖所覆迷世荣禄。邪位所惑不时奉觐。咨受训诲惭愧形颜。世尊大哀威光见照。开发愚冥乃得奉觐。今欲请佛菩萨圣众。尽斯三月供以饮食衣服床卧具病瘦医药一切所安。其彼大城园观楼阁。父王所居严饰庄校。悬缯幢盖浴池莲华。启其二亲贡上如来。诸菩萨学诸声闻等。供佛圣众见尽三月一切所安。父母同心亦皆哀之。供养尽节辞其二亲。在如来所信无慕家。出家学净行作沙门。时意普玉王如来至真。见二太子舍国出家。察其志性。则为二人无限意无限界。班宣于斯晓了菩萨五阴衰品。二太子闻咸共启受。八万四千岁未曾睡寐。亦不思食复不寝卧。唯坐思义经行讽诵。八万四千岁未曾起想有他异念。常正精思畅五盛阴了之虚无。本末慌惚悉空不实。存在颠倒是。五盛阴以解如是。不能觉者迷惑其中。当修梵行。思是法已解达深义。不见盛阴之所归趣。志存大猷无所希冀。寿终之后生兜术天。其时如来灭度之后。从兜术天下还生世间阎浮利地大长者家。至年十六。夜卧梦中见如来像。在于梦中复从如来闻如是法晓了菩萨斯五盛阴诸种入品。从梦觉起心怀悲喜。于一万岁净修梵行。复分别了是五盛阴诸种入品终而复始。寿终之后生忉利天。适生寻复终没。还生世间在梵志家。见本宿世意普玉王。最后末世余正法训。留一千岁以宿本德。信不慕家出家为道。博学广闻智如大海。晓了盛阴诸种衰入。求其本末觉如真谛。时方便劝立。二万世间人。二万亿天人。皆发无上正真道意。以是因缘。其二太子行菩萨业俱共和同。见十亿垓诸佛世尊。最后末世逮得无所从生法忍。更复值供亿垓兆载诸如来众。二人俱等。于一劫中逮得无上正真道为最正觉。一号无量音。二号无量光。是故持人。若有菩萨疾欲得成无上正真道为最正觉。当勤修学如是像典。如来所畅诸阴入种。分别有无诸法之无

    持人菩萨经十八种品第五

佛告持人。何谓菩萨晓了诸种。若能分别十八诸种。而顺思惟识别于观。眼种本末则无眼界。悉空无我我所。入不久存。眼种虚无则曰自然。用眼自然故曰不真。因迷惑思想而合成。眼无所成不得识行为虚空形。犹如虚空悉无所成。悉无所有亦无处所。眼无内外亦无中间。欺诈之业无有真实不可护持。从因缘生无去来今。则为自然本净无形。罪福所成从颠倒兴。为现在缘之所见转故曰眼空界不可见。计于眼者则无有界。识游其中因曰眼界。眼根清净其色晃耀合于意根。因缘所缚三事合会。眼色识集眼界空。其眼界不成界无界。其明智者乃觉知。是故菩萨分别眼界解了真谛。以了色本则无所有。何谓以了色无有界。不与色会亦不离矣。无所生长。虽说色界则无所有色无处所。何以故云色无有界。色无有色无内无外亦无中间。立存虚无。因其思想眼睹色光。眼种清净以见好色。假号曰色。无得有处。犹如明镜见其面像。无垢清净反想有色。虽现镜中有形色。其影乃从内出不从外入。用外形照内镜现。眼亦如是。以用清净虽由于色。为之见镜睹夫面像。以见色空色之自然。无有境界而不可取悉无所成。其色想者本无所生。众生不解。适见色已其以解色。界无所生则无有界。以解色界了色本末。无去来今虚无自然。叹咏光斯缘合所谓也。色界如是。以眼识故。真谛观者知之无界。云何观之。无眼识种。其眼色者则无处所。本净所致眼色叵得悉无所有。眼识无法假号现耳。眼识不合无真实形。眼识之界因颠倒杂。从宿世成。现在因缘之所见缚。与因缘会号曰眼识。用众生在颠倒。若至圣见分别了之。眼识无界。所以者何。眼无所成。十二因缘起对合生。托于所作假号眼识。慕乐识行起所习行合成于识。虽有所睹皆虚不真。托有形相因缘现耳。宣说眼识使众生了。如来班宣分别众形。诸想合成故曰识。无所成眼。以清净识之本相因行所趣。故曰所见。虽习眼识故曰无界。所以者何。眼不求斯我得眼识。及与不得了之。色识无获令自然。所以者何。无所成故也。假托有言而现斯义。为众生故救摄危厄。眼本所行意念是地识相自然。眼界色界识界。三事合成诸界集会。因缘业相宣诸法会。故有托眼色识。如是计惟。是以便入众生达彼无眼。无有色界亦无识界。如是所教断除诸着。若能有了如来所达觉众方便。则能晓解一切三界则无有界。所以者何。计于诸界实无有界。色不可得。耳声识界亦复如是。鼻香识。舌味识。身触识。意法识。计挍思惟观无所成。意界虚无不有真实悉无所有。又是种者则无所成。犹如有人下种在地稍稍生牙。水为因缘日光照之。其种所牙无所造行。其种不与牙共合成。因种生牙种不离牙牙不离种。意界如是。从其意业显现种矣。故有意界。意不离念念不离意。意界虽别因缘合成。其意界者无内无外意无中间。皆由宿命本行所立。悉由意业因界合会。现在因缘之所合生。故假曰意。从己所部罪福所生。十二缘起显有所宣。故曰意界。方便说之欲令众生解其本末。究竟求之实无本末不可得之。所以者何。心自放逸无处所故。所有至识柔软言辞。其意界者悉无真谛。无有过去当来现在。明者晓了意界无界法界无有。何谓观察法界自然。悉无所有而不可得。法界无成不得形像。唯颠倒立无有人寿。从虚伪生兴受识矣。故曰法界。何谓晓了法界之无显现其界。所以者何。其法界者则无所有。从因缘生。以因缘生故曰无界。所以其界因缘合成转成颠倒。如来至真解众生界。故曰法界。托集假号。法界无内亦无有外亦无中间。然住合结除善不善法。断一切诸义宣布道教。故曰奉行。论无所有法界虚空。无成就形假有号耳。法亦如是无所成像。以断法想取现要说。悉无境界故先叹之。无去来今为现在缘而见系缚。从缘合成。众生不解。明者晓了而证明。法界无界不多不少。则以方便因言法界。其了法界。皆除一切三界所生。以断诸法无说法界。因缘言相用处诸法。故曰究竟。明者宣曰无所生相。所以者何。法界之相悉无所成。法界无处。无处非处。无合住处。亦无不住。察了法界永无所住。法界无生。无能者。无合会处。无合无散。法无所造亦不成就。以能如是观法界者。则察意识而无有识。当作何观。无生界则曰识界。所以者何。计其意识无所有故。虚伪不实合于颠倒。从意念有故曰意识。由因愚冥凡夫所行。唯贤圣达见知之耳。以二事宣意识所缘。用众生类不能解了。明者所别从虚无。不真正想所生有意识。其意识界无有殊特。班宣究竟假托有言。借于众生。不解意识本末无界。因缘所集轮转无际。诸贤圣等不求识界。无内无外无有中间。明者晓了其意识者不睹意识。皆从缘起从颠倒兴。以二因缘而有众生。不真思想受于虚伪。从心行生。随俗相有意识耳。众生本心从是缘现。意识无去当来现在。意识计本亦无所著。意识所在无去无来无所存立。意无所住。所以者何。意识本净则无有二无相无二。所在立处而不可见。明者晓了意识如是。其意识者无有法说。无合会亦无离别。无所生想无言教相。独贤圣了。何谓识界。从所来者无所从来。无有因缘。所以者何。其意识界从因缘生。察其本末无有见者。明者晓了意成如是。本无有作。众生自造悉无所生。众生所出相无所生。佛言。持人。若有菩萨当作是观。晓了意识则无识着

    持人菩萨经晓三界品第六

佛告持人。菩萨大士以晓意识。则不着欲界色界及无色界。当作是观。虽存三界不见欲色无色之界。既有是界。悉畅无界班宣光显。众生本末在于欲界而自示现。在色无色而自示现。在是诸界现无有界。粗示要说。晓了诸法自然无界。三界之事无形无处。从因缘生。流于三界轮转无际。智者分别三界所有境界悉无所有。从虚无合颠倒而有。是能觉了则解虚伪。自然永无便舍生死。众生以除颠倒之业便弃三界。如来至真颁宣三界。众生所在悉无有界。无智习之迷惑作是。本净自然而无有界。不猗三界。明者解之。此无有界。观是三界众生无界。己身虚空无有若干。一切诸法从因缘生。从颠倒合假有号耳。则无所成空而无作。自然清净等御虚空。于一切界悉无所有。犹如虚空悉无所有。所以者何。究竟永寂。虚空本净而不可获。一切诸界亦如是矣。无内无外无有中间。界无有界悉无所著皆无所生。诸明智者不有所生亦无所得。无住无不住不等不邪本净无获。智者明了。不获假托无念不能。由是智者不以诸界为境界也。相无所生随俗名耳。无所分别以无生想。若灭是已无一切界。假有言耳。究畅本末悉不可知。以不可知一切亦然。明者所睹。佛言。持人。若有菩萨畅了如是。解十八种及与三界。众生之界及己身界。上虚空界达之平等。以观如是则应平等不见境界。以无所见解一切界。假托言矣。一切诸界悉无有界好喜入道晓了诸界。解脱众生其相无二。以见无二并见诸界。以权方便颁宣示众。十二因起假托有言。开化众生入究竟义。以畅见慧一切诸界。故曰无形。所以者何。持人。如来至真不得一切诸法处所亦非无得。无所亡失平等思惟。逮得无上正真之道。所以者何。一切诸法永无所有。本悉自然无成就者。诸界皆空睹实空无。以等如空无所生相。如来如是解一切界。如来不云诸界自然无界无形。所以者何。其无所有不可强有。以无所有则知自然。持人。当知如来所说。若有晓诸法所来。其菩萨大士便能分别一切众生境界本末。以解本末分别粗细。颁宣诸界合散之义。诸界所入晓无自然。一切诸界虚空界。还自烧然无界无入。假托有辞永不可得。众生无知故有是耳。犹如幻师工学其术。为诸众生现若干变。以现诸化不可计形。若干种人不能知者。闻信所化谓之实有。其晓知者知幻自然。佛言如是。若能晓了幻化虚无众生欺惑。若有明智。自解己身犹如幻化。了之假托。是世若斯自然知幻。若有菩萨晓了入是。畅幻自然以解自然。世之所居亦复如幻。以权方便为众生类。现说一切悉如幻化。若有闻见解了幻法皆无所有乃至正真。其愚冥者不能达之。故为颁宣畅一切法。若了诸法一切如幻欲入是义便当学者。深要之法不求得色。以不得色便不断除。说其不断除一切界。皆为假托。演诸合散分别诸界。宣权方便所造因缘。根元本末剖判真谛。现世度世有为无为。有顺无顺诸应不应。宣权方便究竟尽言。有义无义所畅因缘。而说分别处所无处。皆当达是一切如幻

    持人菩萨经诸入品第七

佛告持人何谓菩萨晓了诸入。于斯菩萨观十二入解其本末。云何观之。所可观者得不见眼之所入处。眼无成就悉无所有。所以者何。眼所入者皆从缘对从颠倒兴。色之所缚缘起所合。有二事因。一曰眼入二曰从对。坐色故曰眼入。如是眼色有二猗着。眼色所入色是眼品。自见色已以幻为门。故曰诸入。则盈生受。眼不着色色不着眼。色不着色目不着目。皆从缘起。以色为缘故号色入。自以见缘对。故曰有相。以入为业。何谓入业。由以颠倒用以丰饶以如究竟。不得入眼诸色之无。其明智者不求诸入便见真谛。从颠倒合愚冥凡夫有二相矣。眼以入色便显入谛。已解真谛色入于目。无内无外无有中间。其眼众色无去来今。现目睹色。现目睹色则贪受取。愚冥凡夫所行不可。明智达之虚无无真。思想颠倒便成诸入。诸入自然云何有乎。其无入相皆从缘起。故曰诸入。如来曰诸入虚无。悉从颠倒托于因缘。无有诸作无使作者。眼不召色色不召眼。亦无所知各各寂然。眼色诸入俱共淡泊。无有作者从因缘起。愚冥凡夫心处颠倒。贤圣达之。然无所生无所灭矣。无来无去。眼色诸入眼不断眼。目不想目色不舍色。便知自然。色不想色。所以者何。各各空故。各各淡泊知自然故。眼不猗眼色不知色。自然之故。眼色自然无成就者。眼不求眼亦不合散。各各空无。目不习目是我所眼。色不习色色是我所。幻自然相。眼色虚无则曰自然。假托言矣。耳声鼻香舌味身更心法而不可得。悉无所有亦无所成。所以者何。从因缘起。处在颠倒。立在二因从心法兴诸品入故。故曰诸入。以法因缘假托入门。法不着心。心不着法。法不着法心不着心。着从缘起以立法事。因心见相不得入法。明智达之。求诸入本睹见真谛。皆颠倒合。愚冥凡夫见有二相。无内外亦无中间。心不入法法不入心。无去来今。皆从缘生。愚者不了。明智达之。所以者何。悉无所有处自然故。无意入法无有真相。不得成就假托现耳。如是持人。菩萨以得晓了若斯诸所众入。便了一切十二诸入。不着不缚便断诸入。以造立证入诸分别使无所起。晓了无相犹如流水在所合矣。故曰水普无所不入。其十二入亦复如是。所云内外皆从因缘。其水流至多所成就。虽言自然不得处所以见缚着。其诸入者向尘劳门。愚冥凡夫不断尘劳。故曰入门。眼着于色。耳鼻口身心亦复如是。无所归趣。菩萨大士。晓了自然分别诸入。已分别入悉除众结。如是持人。菩萨大士晓了诸入

    持人菩萨经十二缘品第八

佛告持人。何谓晓了班宣诸入十二缘起观十二。以何观之。以用诸法悉无明业。故名曰痴。不了无处。故曰无明。不解诸法有生无明。故曰为痴。以不了是何故无明无明缘故有行。若不达法不行是法。故曰无明缘故便有行。有行缘故生其识。故曰从行致识。有其二相致名色矣。故从识缘而生名色。从名色便生六入。故曰从名色缘得致六入。因有更痛。故曰从六入缘便生所更。因有痛痒。故曰从所更缘致有痛痒。则生恩爱。故曰从痛痒缘便生恩爱。从恩爱缘生所受。故曰从恩爱缘便生所受。从所受便生所有。故曰从所受缘便致所有。从所有便致生矣。故曰从所有缘便致所生。从所生缘便有老病死啼哭愁戚不可意法大患苦会。故曰从生致若干苦。以何等故合是众恼。以无明故习诸颠倒。从恩爱行忻乐贪欲。其心在在乐慕不舍。是则世俗十二品有缘起自闭。盲冥无目无明罗网。志存疽癞入于幽闇。无明为首。十二缘以观如是。了斯无明虚伪不真。又其本际而不可知。何以故。不可知。不可知。不逮明故。用无明故。其生本际而不可知。若有明智当观察之。晓了本际则达无际。不起思想亦不无想。便断众想。以断众想不猗无明。一切诸法不违无明。是诸法者不去无明自大之心。所以者何。以舍无明。以故曰名一切诸法皆为无明矣。以能觉了一切诸法皆无明者。则达明业不更致明。以消无明则曰明业。何谓消无明者。解一切法悉无所有。一切诸法皆虚不真。处存颠倒法无所有。假托有耳。是则名曰以断无明。亦断有明。明与无明悉虚不真。所曰无明。用无明故有众行业。便致十二。愚冥凡夫所不能达自投邪冥。悉无所有反造所有。故曰为行。无处无言不言不知。明亦不冥。诸行之业悉本空无。所法无有反行所有。故曰无明之缘使成诸行。其行无常。从是非业致众行来。又察众行无去来今。其无明空分别无明。诸行本空行悉自然。行无所著。因其无明故生诸行。其无明者不着诸行。明行不断无明便消。行不除行。是行无明则发闇弊。处存颠倒无明叵得。则曰自然行不可得。亦曰自然。用幽冥塞。故曰无明。用冥无明便立行耳。若法无无明无所有。以虚伪法便成无明。行识行无所著行。不起识行。所以者何。行不知行行无有法所可至奏。从行识生众颠倒。其行与识。无内无外亦无中间。无起识者。以行逸生其识耳。彼若明智求识不得。识无所生亦无所见。不别于识名色六入所更痛痒。受有生老病死忧戚啼哭痛不可意大苦阴会。轮转无际生死不断。投于五江四渎之间不能自济。晓了无根悉无所著。无致无极平等之业。观十二缘亦复如是。斯名曰明无二。故勤精进求一切诸法。以慕诸法无想不想。是柔顺明入十二缘。是为持人诸菩萨众晓了颁宣十二缘起在合会缘有所生起。分别无会。是曰逮得解无所生。晓了缘起观十二缘。不当察生不至权慧。若能达知十二缘起无所生者。乃曰晓了逮无生慧。是故持人。菩萨大士欲入无生慧建立证明。当分别畅十二缘起而奉行之。以余奉行于诸缘起而无所生。以作是观。乃谓逮得无所生慧。以能逮得无所生慧。造立证明。乃曰逮得无所从生晓了道慧。是故持人。菩萨大士如是行者。于所生缘而无所生。悉断三界。因缘证明观无所生。若有菩萨至无生相。便疾逮得无所从生法忍。辄得亲近菩萨之行。己身所奉面缘诸佛而受道决。当逮无上正真之道为最正觉。得决不久以近受决。又以自己如是色像奉行佛教。是诸正士各便受决得许信乐。分别一切世间诸法以度方俗。晓了十二缘起之元以达缘起。诸佛世尊现在目前。不复恐惧诸魔波旬。若见现在陆地水中。一切诸物睹见生死。已度众厄拔无明根。如是比像永得安隐睹见正士。佛言。持人。若有菩萨如是解了。吾我所有皆因缘故。若有闻是晓了十二缘起本末。信乐不疑诸如来所成其根元。不久受决。得无所从生法忍。以受决本如来不久诸如来便得道决。当逮无上正真之道为最正觉

持人菩萨经卷第二持人菩萨经卷第三

        西晋月氏三藏竺法护译

    持人菩萨经三十七品第九

佛告持人。何谓菩萨晓了意止。若有菩萨分别观察。行四意止。何谓四意。自观其身痛痒想法。亦复如是。何谓自观痛痒想法。于斯菩萨自观身行察如真谛。无常苦空非身之要。身为疮病。危厄众害以用乐习。动摇游去荒秽不净。以观如是。若干瑕疵满是身中。九品疮孔夙夜流出。臭处不净犹如便厕。谛观如是。无如毛发可乐可取。不净秽浊皮覆其肉。筋缠裹之从罪福成。积聚众着便有盛阴。何谓积聚。何谓盛阴。皆宿世缘有是盛阴。由本倚慕虚伪覆之。沐浴文饰谓是我身由是积聚

何谓盛阴。从因缘起而报应成。从造行转因于四大。计身本末非真之有。受于四大而成色阴。因得假托。所以名曰身者何。已自造作。故曰为身。心以依之。故曰为身。罪福所为。故曰为身。从思想生不肖可贱。与行业合。故曰为身。从因缘成身适小安。便复坏败不得久长。不可常存寻当别离。故曰为身。无内无外亦无中间。虽立迫恼。身不知身。亦不可见。不为解明。不得度岸无有思想。犹如草木瓦石之类。身不成身。以作是观以立解达。则不贪身。无所慕乐。知身为患。身无过去当来现在。非身是身如聚沫。澡浴文饰。是身如宅。八十种虫。是身迫恼。无数百病。是身无救。三苦困厄。所云苦者。生死之患别离之难。是身苦器受诸危厄。以作是观思惟顺义。则不贪身不慕他人无所志乐。是身无我虽有便离。身无所有悉无有实。是身以空自然虚无。至无真正虚伪立耳。结在无益从本行成。虽有是身则非我身。当兴专精慕求不贪。已能观察己身寿命。不得合散。不见往返住立处所。不睹过去当来现在。无想不想悉无所著。不猗身命身非我有。亦无我所则无所受。不合不散无所从来。令心恼热不知所趣。计身本末无所起生住立灭尽。菩萨观身如是无身。已了身虚。若身欲盛辄自消灭。身意则止立存顺行。如义观身便无有身

佛告持人。何谓菩萨观身痛痒。若有菩萨察身三痛。乐痛苦痛不乐不苦痛。计其痛痒不知所趣。无去无来唯从虚无。因缘合成受罪福报。由颠倒兴知痛本无。因思想立。作是观者不得痛痒。无去来今不见处所。其过去痛了空无我。亦无我所。无常坚固悉颠倒法。过去痛空惔怕无想。当来现在亦复俱然。乃知痛痒不得成立。无形可获各自分离。其痛痒者无有起者。亦无所灭。亦无处所无内无外。愚冥凡夫由从颠倒而生痛痒。罪福报应适合便离。故曰痛痒悉空慌惚虚诈之法。以如是知从痛因缘得心处所。痛会有竟必归灭尽。不见痛痒所合聚处。心自念言。痛痒则空自然无形不见所生。痛无所生亦无有灭。无有成想。以无有成想已无有相。相无所生。普观如是。身所痛痒则无所猗。解知痛痒真谛本无。以断痛痒离诸入痛。不与其合不着痛痒。众行寂然速求方便。逮三昧定。菩萨察行痛痒如是。见行以了则睹十方

佛告持人。何谓菩萨观心意行。若有菩萨观心念行。发意念顷察于心法。若存异变以能观者。心自念曰。其心未曾有所奔逸。无所至到。异缘所使遣所凑相。心所兴发亦不成就。亦无形貌悉不可得。心无往返立无所处。无去来今。以因缘现而有所念。其心计之。无内无外无有中间有所迫恼。心无处所无自然矣。不可成办。心无所断。若有所断。心以名曰若干种变。使不可计。生相即灭。持人。心无住处心无存处。所在已能觉。是则无心念亦无所见。所以者何。又其心空自然无形无有众生。又无所有不得处所。无合心者无有散者。心无过去无有将来不得中间。无能见者。心不自然心不清净。心不知心心不断绝。心无有心则曰本净。处在颠倒愚冥凡夫。以虚因缘教在诸相。心自发念。又其彼心空无吾我。而计有身心存有常长久永安。以颠倒法而自投冥。观心如是逮得柔顺心意止也。心无想念亦无不相晓了其心。而于所生无所生想。所以者何。心无所发不得真际。不得其相心相不起。明者所解分别达之。知心所习所趣归灭。审知如有作是察心。不有合习无灭归处以不得心。若不得心。况复所习所归究竟。以是之故。心不想灭亦非无想逮心清净。心已清净不随尘劳不为污染。所以者何。知除所有心则清净。众生心乱便染尘劳。心净则净以能知除。心自念言。心有尘劳。以是之故计众生行。心有所著便为尘劳。心以解明则致清净。已作是观不得欲尘心。不得净心。尔乃达了心本清净。菩萨如是观心意行便通本净

佛告持人。何谓菩萨心存在法。观其法行。若有菩萨观一切法。不见内法不见外法不处中间。有所迫恼。法无过去当来现在。因十二缘而生有之。诸法颠倒法无成就。又察其法。无有内外亦无中间。法无合散。一切诸法悉无形貌。无所有无不有。托有音耳。一切诸法犹如虚空。亦若幻想。生自然本清净明。诸各有所猗劳。一切诸法无所睹见。察其真实犹如梦中所见。觉无所睹。一切诸法犹如照影。本净无形无名想。诸法无思。一切诸法。如呼声响。从虚无立诸法则无。自然之故不可得矣。诸法野马无所有故。以能如立观诸法者。愚冥凡夫见若干变。则知无法不用法无合无散。以见诸法永无所著。以作是观见一切法无往无返。不见诸法之所立处。所以者何。无处非处。一切诸法从因缘起。处在颠倒轮转无际。无言不言无有二想。亦非一想不有小想。明者所了而不可得亦非不得。所以者何。诸法不生亦无所起。无造无作不得作者。诸法舍形亦无身貌。亦无自然自然成矣。诸法无数本真谛故。以作是观解一切法。无有吾我无人无命。察于空无。心自念言。一切诸法悉云本性空。法以自然亦无有想。不见众想不造法愿。察一切法以无所生。自心念言。法无所起亦无所灭。以观如是得法意止。于一切法了无所生。知归习尽因法相成。自然离以则无有相。所以者何。无有成。其无相者乃舍相耳。诸明达者分别觉了。是一切法悉为本无。若有菩萨当作是观。诸法法行以作是行。不得诸法亦无所生不起诸法。有所住止亦无所灭。一切诸法悉灭度相。诸根寂然相亦惔相。菩萨如是观见诸法。了法意止已。无止处无所不止。悉入诸法慧明之相。自察心念致法意止。则名曰颂宣经典。于一切法而无所住。敷演诸法摄妄以慧。斯曰于一切法所睹真谛逮法意止。佛言。意以止者。便至意断身意痛意想法意。解三界空不见身及痛想法。则四意断

佛告持人。菩萨若有逮解五根度俗世本。顺谛察之。何谓为五根。一曰信根。二曰精进根。三曰意根。四曰定意根。五曰慧根。是为五根。当睹是行。云何观之。信一切法从因缘起。立有颠倒虚无合成。展转不定犹如车轮。所游无际。亦如所梦自然退逝。信一切法无常苦空非身。疾病疮痍老不长存。不得久在当复别离。诸法不真皆无有实。慌惚舍放等放诸根。犹如彩画如小儿力。思想欺戏以为真实。不知虚诈悉无所有。其信根者。一切诸法无去来今。无去无来亦无所住。空无相愿无起无行无想不惑。戒清定净。慧解度知见品净。以能奉斯信根行者。则不回还。笃信为首建立禁戒。悉无所失不违道业。以无所失便顺正法。住于笃信无能动摇。善德报应感来归护。则立直业而无谀谄。断诸邪见六十二缘。不求外学以为师主。如见日月不用烛火。唯归如来识知圣众。善具足成立净业戒忍辱仁和。如是笃信而不动摇。以无能动甚怀义信便具道法

佛告持人。何谓菩萨观精进根。云何具成晓了方便。若有菩萨笃道不违。以精进故休息五盖。设值得闻如是景模深妙经典勤顺奉行。夙夜精进不悒怯弱。心不忘远志慕博闻。无挂碍法以断诸蔽不废精进。若心生念恶不善法。以大精进而蠲除之。识法已兴建立勤修未曾懈惓。无猗精进摄加勤修。不以此行有所违失。而不还返所遵力务。晓了诸法分别如应不戴仰人。在于世治不失精进。以斯进根最有威德。以义勤学得号进根

佛告持人。何谓菩萨逮得意根。云何晓了奉行意根。若有菩萨制止其意。顺施戒闻具足梵行。究竟戒品清净之业。定意慧解度知见品。净身口意究竟谦恪建立正意。在一切法令无所生。住存殊异而察至行。苦习尽道以除断斯。存立意止。方便解达根力觉一心意定意三昧正受。解畅诸法而无想愿。得不起慧致忍辱圣。离欲灭度以得意止。具足佛法不行声闻缘觉地也。奉无碍慧心不迷惑。以能专精如是像法。身口谨慎不失其意不依仰人。察如是法最有威德逮得正本。是谓晓了逮定意根

何谓菩萨逮定意根。云何晓了斯定意根。若有菩萨以行禅思一心不虚。行贤圣业禅心无所著。以无逸禅善摄定意。明解正等晓了定意。无颠倒禅观定意门。以畅不乱入于寂志。从三昧起不复定意亦无正受。以能慕乐志立道业。而以禅思因用自娱不须仰人。禅思正受不随禅教。以逮威德定意一心。不贪利养行不愦闹。以最威德逮定意根所度无极

佛告持人。何谓菩萨行智慧根。云何晓了逮智慧根。若有菩萨灭身所行。为何谓也。尽除众苦常消身行。在在行慧普见离欲。灭习尽道向无为门。以行慧根皆睹三界。一切炽然知三界苦。其智慧者不猗三界。察之悉空无想不愿。心无所生无所复行。睹者有为悉放舍之。如救头然具足佛法。专习诸法虽处三界。戢灭一切悉放舍着。而于三界悉无所慕。断诸所乐舍诸有为。一切染污爱欲缚结。心无所著不慕五乐。不着欲界色无色界。心抱智慧圣明功勋。不可限量犹如江海。所行至诚而无崖底。晓了诸法。则以智慧分别三界悉无所著。是最德义奉于智慧所度无极

佛言。持人。何故曰根。所曰根者。义无能动。故曰为根。以无所动无所逸驰。故曰为根。永不回还不依仰人。义无伴侣顺随法教。故曰为根。不耻他人莫能摇者。无所杂错。故曰为根。如是持人。斯则菩萨晓了诸根。又复持人。菩萨分别众生诸根。善学方等。知众生根染不染者。有欲无欲根。有嗔恚无嗔恚根。有愚痴无愚痴根。知堕恶趣若生人间根。知生天上十方佛前根。心明达若柔劣及中间根。悉见知之。下贱粗犷根。诸根不具。若不损根而悉知之。诸根应法。有方便根。无方便根。悉复知之。有罪无罪根。猗着无著根。危害根。无害根。悉当知之。随顺根。不随顺根。有碍根。无碍根。欲行根。色行根。无色行根。畅诸善根。究竟善根。悉能知之。所归趣根。仁和根。处邪见根。立正见根。悭贪根。无悭吝根。悉能知之。卒暴根。无卒暴根。迷惑根。不迷惑根。速疾根。贤和根。忍辱根。嗔恚根。怀嫉妒根。无嫉妒根。具施根。非具施根。信根。无信根。贪欲根。离欲根。居家根。舍家根。戒具根。毁戒根。悉能知之。诫戒根。无诫戒根。清净根。忍具根。恚恨根。上精进根。懈怠根。乱心根。取要根。定意根。智慧名根。失智慧根。具圣明根。愚騃根。无所畏根。自大根。离自大根。逮得道根。从邪见根。心安和根。放心恣意根。悉能知之。散意根。寂静根。起生根。无所生根。清净根。瑕秽根。解明根。显曜根。声闻根。缘觉根。菩萨乘根。佛乘根。皆晓了知以逮得。是则谓得力而无等侣无有放逸。谓不回还致善方便。名曰意根。知诸天龙神阿须轮迦留罗真陀罗摩休勒人非人根。最为威尊无能胜者莫能动摇。所行方便普度无极。奉行勤修如是像典疾逮晓了。于一切法而得自在。旋十方界无所不济

佛告持人。何谓菩萨晓了道乎。云何致道耶。若有菩萨奉八圣道。一曰正见。二曰正念。三曰正语。四曰正命。五曰正业。六曰正方便。七曰正意。八曰正定。何谓正见。若有菩萨断除一切诸所邪见。所以者何。一切所见上至泥洹。若欲见佛皆去是等诸所见业。乃曰正见。以无见不受见成名诸见。悉无所猗普无所念。以无颠倒无所无想。是曰正见。所见平等为何谓也。舍世虚妄以弃邪见。以如见除诸所睹。住于正见悉无所著。无想不想不见泥洹。远诸欲见不习诸见。何谓正见。一切寂然无生清凉。亦无所灭等睹无为。本以清净于一切法无所望。亦无不想无所不应。是曰度世正见。何谓正见。不得现在亦不度世。正见断现世法亦及度世。不想现度除一切想。不得等邪等诸不等断诸等行。是名度世。乃曰正见。如是一切悉无所生。故曰正见。见所真谛正见无邪。是曰正见。如是持人。菩萨大士所行正见。何谓正念。如真谛解一切所念。皆是邪想及思无为佛法圣众。所以者何。断一切想所思平等。是念故正念。以无众相曰正念。所以者何。消一切思名察正。则无有邪不复怀想。乃住正念不得所思。离邪正想故曰正念。以除想诸等弃众念。舍虚颠倒消想不想等一切念。不猗诸念除诸想。故曰正念

何谓正语。一切言辞皆为虚妄处在颠倒。悉皆惑想见于平等。心自念言辞。正断一切言辞所宣。故曰正语。言无所凑无去无来。所见如是等无有异。已逮正语口之所宣皆实至诚。故曰正语。口言清净。所住之处断一切教言辞辩才。心中觉了口无所宣。悉舍邪言住于正语

何谓正业。以住正业皆知一切众邪之业。其一切业不真不谛。本无所作。所以者何。一切诸业无有至竟。业悉散故曰正业。不于正不于邪。不于是不于非。无想不想皆度众业。不造正邪等逮诸业无作非作。故曰正业。皆能等说邪正诸业。如真谛解一切诸业。亦真谛见无应不应。是谓正业。其以正行无有邪业等见谛行。故曰正业。何谓正命。知一切命皆堕反邪。所以者何。其想有命想有万物而怀妄想。无为泥洹清净之想及想见佛。一心清净以住是中欲以净命皆堕邪业。一切诸命若正性命不以为邪不以怀正命。是曰正命。言是邪命逮一切命悉成清净。是曰正命。解一切命无有正邪者。住净命行无有放逸。无正邪命无双无只无应不应。是曰正命。无住邪者逮得净命。无有命想无善无言无命不命。等行真正而见不虚。是曰正命

何谓正方便。弃众邪便。所以者何。一切方便皆堕反邪。方便所在心在结着。是曰邪便。所以者何。一切诸法。无真邪便。所行方便则不真正。其不真正名邪方便。无方便矣。无究竟无言辞。断诸方便彼无所有。弃泥洹想无佛法想。知行方便一切方便。悉不真正至无方便。其以平等则无方便。等一切法无有若干。无有方便超越方计。所有方义则无所计无应不应。是正方便。方便叵得此之谓也。所言方便是谓定意。断诸方便谓众真谛。等见如是不想方便。以无所想是正方便。何谓正意。一切所念皆为邪想。意之所念皆是邪思。所以者何。一切堕邪。彼若意生皆为邪。意无所念。所以者何。一切所念从因缘生。所曰因缘皆曰邪矣。其意所念不起不灭。是曰正念。所以名正念。若无意念住处发起业。不意无意意第一净。无邪意念皆断众思。其以邪者悉无意念。是住正意。其正意者不正不邪正念邪念。除一切意诸念思想。所晓了者心不起乱。常行六事曰住正意。意未曾生有意未意相。解一切意皆了诸意畅如真谛。不复思念有意无意应与不应。是住正意无意无邪。念于等行无念不念。无因无思无所惟念。一切无望逮致无言。无意不意住思平等。无言无说弃一切辞解如真谛。普无宣教无思无想。是乃名曰住于平等

何谓正定。见一切定皆为邪定。所以者何。若受三昧因缘之想。望正着除斯皆邪定。所谓取反此定不真。若于诸受而无所受。又不怀求三昧定想。无出家教无念定意。其无所猗无作无畅。消断喜悦永密安乐分别定相。于三昧定而无所住。是乃名曰正定三昧。所谓正定于一切定而无所著。则无放逸明了如慧。晓达定意不猗定行。而无希念等消正行。如以是者无想不想不想无想。乃曰正定。无正无邪一切无望。以断诸想并灭众希。乃曰正定。所云定者无正邪定。心无所生不正无邪。无正定无邪定。所以者何。以能觉解方便诸定。乃住正定无三昧想。不积平等普曰一切。乃曰正定。其不驰骋不造等逸。若等若邪普等诸法。一切定意以存正受。一切三界皆是有为。所思真谛以慧睹见。一切五趣往来所生。佛言。持人。如是菩萨晓了道义。以逮如斯剖判道趣。若斯圣业解畅真谛。乃曰正定

持人菩萨经卷第三持人菩萨经卷第四

        西晋月氏三藏竺法护译

    世俗度世品第十

佛告持人。菩萨何谓菩萨得晓了知现世度世经典之要。云何名曰现世度世。若有菩萨常顺思惟现世度世。云何顺思。何谓现世法。何谓度世法。若有住于颠倒法行皆从想有。由因缘生合于虚妄。有二缘立从二想生。一从虚妄。二从无生。其虚妄语欺迷惑法。得愚冥想犹如小儿。执若干种画于虚空。虚妄经行愚冥凡夫。想云有世。计其世俗皆归坏败。麋散悉尽以见一切世俗诸法从虚欺惑。所因无作本无所生。阴种诸入皆从缘对。色声香味触。由因缘法。不说色缘。犹愚凡夫心有所猗。所以诸见因无数见。而有猗着。若彼种性放存穷匮。令世间见处在颠倒。所睹世法度世在彼为何所是。世俗之法真谛如有。达其本净是为度世。明不求世了不可得。度世亦然。若不能得现世度世。无现世及度世业。宣其度世现世本净。何谓宣布度世之业。若世本净至于度世。所以者何。永不可得。现世本净悉空。其世亦然。本以自然世本净寂。以世自然世净寂然。计世俗法无究竟成。当作是观。现世度世悉不可得。不得度世不着于世不念度世。以不念世及度世者不与世谛。所以者何。以觉晓了世间悉虚欺诈惑法。以能睹见世猗虚无。不想于世不慕度世。所以者何。佛言。持人。所云世者谓五盛阴也。贪求合会一切世法。明知求阴永不可得。五阴自然而不可得。五阴本净亦不可得。五阴无来去无所至。凑处不可得。是曰度世。不知五阴所归处所也。以无五阴诸种本净及诸衰入之本净也。若有菩萨观于世俗之法。悉无所见以合度世。不见度世不与世合。则无有世惟睹度世。在于度世不见世法。而有异持也。不转二法云是世俗。是度世法。所以者何。持人。其所在世解世本末本无所有。度世亦然。虽见有世悉无世法。所作分别度世俱同。以了无世。假使有人。心自念言。世俗别异度世不同。则于其人佛不兴世。虽佛出世。普世颠倒。无发道行用真正解。以慧察世颁宣经法。处世颠倒贪受于世而救济之。故曰度世也。是故持人。用真正解以慧察之晓了世倒。故曰度世也。如来出世普通诸法。世俗度世皆无有二。以真正慧观察造证。故为宣布度世之法。佛言。持人。不以是法游于世间。无所至凑无所消除。不猗世诤乃得世义。不念度世晓了世辞。达本所想以着想二。不解能达如是像法。则无济者不能解了不畅度世。所以者何。用二行故。其二行者不能解了世俗度世。菩萨如是方便晓了一切诸法。现世度世靡所不达

    持人菩萨经有为无为品第十一

佛告持人。何谓菩萨晓了分别有为无为法。云何有为无为法。若有菩萨以真正觉。有为无为顺理求之。云何顺理。云何求之。亦不作有为法。有所见者自然得号。已造有为故曰有为。又有为法以虚伪转。云何为转。由已合会自然归之。以二缘立缘本际教。用以所有自因而生。一切诸法。无为作者劝使作者。自然生已。是有为法斯自然法。无有回还故曰有为。其有为法。无内无外亦无中间。住存欺惑。无合无散。由从虚妄思想兴立。从无明缘生愚痴业有一切法。自然转行无教造行。从有为事受其相业因其颠倒。以愚凡夫猗名之故。又明智者。觉了有为不可得边。不猗有为无合有法。乃曰明智。明智分别至实。有所造行灭一切为。明智剖判一切诸行虚无欺诈。是诸法者悉无所有。咸为自然亦无自然。从意念成一切有为。所以者何。不当奉行有为因缘。或晓无为未曾复习有为缘行。若晓无为尔乃通耳。云何晓之。一切有为皆为不真而无有形。悉无边际无至合会。明智观之。不以有为至生究竟。其有为者亦无所受悉以无异。有为无为亦复无异生。宣断有为业。是有为是无为。斯有为相斯无为相。彼何谓有为相。知生当死合会别离。何谓无为相。不生不灭不会无别。愚冥凡夫不能解了。入斯二义不晓有为。所由起相及灭坏相。不住异相。因无相生。住于异也。若无是相。如来所说。从是相生。从是相灭。住如是相。佛言。持人。如来所云一切诸法皆无有相。以能得成。无所生相。无灭坏相。无所住相。如来敷演无为之相。是相非相。其有为相不成无为导师。所以愚冥凡夫所宣道法。有为所起会归灭尽。惟无为安以能无为。不生不灭亦无所住。故曰无为。从其所习而令生灭。其无所习则无究尽。无行无究无异住处。其以真正解其斯慧。不致合会。有所起生而有灭也。无有异住。若有菩萨当作是观。其有为法及无为法。无有不无常见如应。不睹有为及无为法。有为不见无为。无为不见有为。不见异无为。而自谓念我身有矣。真有正是见有为业。无余有为是谛有耳。思念妄想。其有为无为法永无所想。有为无为以无所想分别诸想。皆断诸着以了无为。除去众缘本净无缘。其因本净所睹真正。以能晓了悉无所作则无合会。菩萨能逮是有为无为。则了诸法不有不无。亦复不猗有为无为。乃逮正觉也

佛告持人。若有菩萨分别五阴。晓了诸种解达六入。以能畅知十二缘。剖判四意止。五根八道。能觉世俗度世之业。明知有为无为之事。以晓了是。逮解一切诸法之无。宣布诸法。所不达得意力势。解畅一切诸法章句。断生老死心不能绝坏。能自究竟无上正真道。成最正觉

    持人菩萨经宝光菩萨品第十二

佛告持人。乃往过去无央数劫不可称计悬旷无限。尔时于世有佛。号紫金山王如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛世尊。其紫金山王如来寿住五劫。诸声闻众不可计数。诸菩萨会亦不可限。无能称了知其多少。其土炽盛。风雨时节五谷丰熟。人民安宁强不凌弱。各得其所心行平等。饮食消化不以为病。淫怒痴薄善自修身。家居义教顺律清净。彼时如来。为诸菩萨一切众生。决诸疑网令无怀恨。颁宣菩萨道法之藏。时有菩萨名曰宝光。闻佛说是诸菩萨业。解阴衰入诸种十八。十二缘起。诸根意止。八正道行。世俗度世。有为无为。即辄奉受。如是精进十二亿岁。未曾发起淫怒痴心。不贪利养饮食衣服床蓐卧具病瘦医药。惟心精修。入如是像晓了思惟。常修精进尽其形寿。净修梵行在其佛所。寿终之后还生本土。在于人间适生堕地。便复出家复受学斯。如是像法晓了奉行。复在于彼六十亿岁。净修梵行心不舍远。如是像法慕求不废。复寿终竟还生佛国。其紫金山王如来续存。复在其所净修梵行。一一劫中。五返生没终而复始。其紫金山王如来至真。临欲灭度终五劫已。因是景模博闻无量。晓了诸法。于五劫中所可闻受。观已从佛咨讲解者。逮其意力观戴如来。便为众生一一敷演。开发无量人。皆发无上正真道意。佛灭度后正法住世一劫。复五百返往来周旋。生于人间常出家学。奉是景模晓了正典。化无央数不可思议众生之类皆入至行。宝光菩萨见万亿佛。最后有佛。名无量光如来至真等正觉。所见授决。却无数劫。汝当成无上正真之道。过无数劫当复逮见亿百千垓兆载诸佛。逮得正觉。号决一切议如来至真等正觉。诸声闻众不可称计。难可限量。诸菩萨众无央数人。其国处世人寿二劫。米谷平贱人民安隐。是故持人。菩萨大士。欲逮得是如斯景模晓了正典。当精进学受持讽诵是经典要

佛复告持人。若有菩萨学是经典。逮权方便常修四法。何谓为四。一曰弃家捐业行作沙门。二曰舍于愦闹习在闲居。三曰住清净戒行不违阙。四曰去离懈怠精思不废。是为四。以行是四勤求博闻。常立忍辱疾逮四法。何谓为四。一曰虽生天下常住中国。二曰因值佛世不在边地。三曰常奉正法终无相违。四曰悉除罪盖无复殃衅。是为四。若有菩萨学如是像经典之要。辄逮力势。布施清净戒禁无秽忍辱精进一心智慧。圣明无瑕。以建是法致权方便。又复持人。菩萨学斯立知止足闲居功德。怀无盖哀愍于众生。以用大哀入于众生。然后乃学如是像法解了要行。又其菩萨入总持门学于勤修。何谓得入总持门而学勤修。志慕勤思晓了量法。方便观察奉无限行。又解了观诸定意门诸要法门。入不可计因缘正行。逮致如是比像力势。晓一切法分别诸法。得意力势以能晓了。断生老病死。志强无怯不失正法。乃成无上正真道意逮最正觉

佛复告持人。若有菩萨通总持门。普能晓了一切诸法言辞所趣。以用一事入百千事。以用道力分别诸法无所不达。又若菩萨逮定意门入音声。便入无限定意门辞。以得入是了若干品一切法门。以入一切诸法道门。颁宣诸法靡不蒙济。又其菩萨奉行智慧。以是慧力晓了诸想。勤解想已以是慧力逮一切法疾通无碍。又若菩萨晓了无量定意门行。以住是地。普致一切十方法。又若菩萨晓了无量总持门行。解不可计定意门力。以定意门畅不可限众法之元。以是道地普入诸法靡所不通。又其菩萨甚能晓了观世间行。极复分别有为无为。奉行诸法心所不著有为无为。行如是像一切诸法。疾解诸法逮得明慧。又菩萨行权方便。勤察一切诸法本无所行。虽作是观不为世事。不着世法亦无所猗。如是像法疾得晓了一切诸法。分别诸法。意力施财剖判章句。断除生老死意行具足。是故持人。菩萨大士于是摸法而度无极。何谓为四。于斯法典奉如道义。勤修正法。于斯经典逮无挂碍。普入道慧

    持人菩萨经往古品第十三

佛告持人。乃往过去无央数劫。不可称计长远无限。尔时有佛。号无量光超殊王如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。其佛世时。声闻众不可计数。大会无限。诸菩萨会不可称载。其佛在世时寿一劫。又彼佛土皆以七宝而遍覆成。七宝树生周匝围绕。以用庄严一切诸树。殊异珍琦交露帐覆。又诸树下皆施师子床。其诸床上细好帛[疊*毛]裹树布床。一切诸床琉璃为足。以赤真珠而挍诸树。自然熏香合成诸叶。华常茂盛而围旋之。其树前自然浴池有八味水。其水底沙悉以水精车磲赤真珠合成。又以三宝造成浴池。其诸浴池自生青莲红黄白莲华。又诸池水以七宝作挍饰栏楯。一切栏楯地平如掌。又其佛土清净无秽。其佛国土宝树炽盛。犹忉利天昼度大树。严饰巍巍明月珠树。诸亿千充满佛土。其光悉照覆日月耀令不复现。其诸宝树琦珍交露。出好音声哀鸾众鸟。天诸玉女歌音乐声。如是软音普流佛土。无三恶趣不犯诸恶。不为众生喧杂句说。惟以敷演如斯像法智度无极。是菩萨藏化无央数诸人物众。一日皆发道心。其本发心志存大道。便悉具足道品之法。如是持人。其无量光超殊王如来至真。因其方便化不可计无央数载众生发道心。今生下方去此佛土。在彼佛土成菩萨行。佛灭度后正法存立。竟至半劫时。佛灭度后正法便没。有一菩萨名意无限。从下方佛刹来生此土。其国去斯十佛世界。适生未久年十六岁。便舍捐业行作沙门。在无量光超殊王佛所咨受经典。临法没时为诸菩萨宣布阴种一切诸入分别解义。闻如是像精进之行。在于斯法所度无极摄权方便。因是德本。彼土复决见亿数佛普蒙斯法。所生之处常识宿命。皆以幼童不娶妻室净修梵行。以家有信出为沙门。所生之处逮得意力。常所受身成就功勋。而最后世。逮得无上正真之道。为最正觉号曰无量光珠王如来至真等正觉。若有菩萨疾欲得成佛。逮一切智具足佛道。在后五浊临法欲没。当勤志成如是像法辄受宣布。尽以爱乐常行精进。最后末俗受是经典。德勋无量。讽诵奉行为他人说。福不可喻

    持人菩萨经颰陀和五百人品第十四

尔时颰陀和等五百菩萨。桥曰兜菩萨。即从坐起长跪叉手。前白佛言。我等世尊最后末世。临法灭时当受是法。住于后世五浊之世。拥护正典持是景摸。讽诵奉持广为人说。复有无数诸菩萨等。各从坐起长跪叉手。谛视佛面各兴至愿。我等世尊最后末世。被弘誓铠受是景摸。顺斯深妙佛所宣慧。诸菩萨等所积德本。道品之藏并使具足。所在游居当拥护法。闻是经像益加喜乐受持讽诵。宣示未达深入大猷。时佛忻笑。口中五色光出。遍照三千大千佛土。地六返震动。贤者阿难即从坐起。长跪叉手前白佛言。佛何因笑。既笑当有意。光明普照地即大动。佛告阿难。汝宁见此诸菩萨众住立我前。在后末世当护正法。被弘誓铠以救危厄。佛识念之往无数劫。于诸佛所被如是像弘誓之铠。面从诸佛受斯经法持护三品。开导无数众生之类。令是等来在于佛所承三品义。受是正法今立佛前。然后末世法临没时。多所开化未达众生。如令受佛三品正法。在于贤劫诸佛兴见。亦当从受千佛训诲三品正法。又将来世诸佛圣所咸受亦然。是等阿难诸族姓子。功勋名德不可得察。莫能称计所行经法。是诸族姓子。安隐众生而供养。假使如来班宣是等。以受正道安隐众生。皆以不信。若不信者长夜不安。堕于恶趣。又复阿难。当为汝等现其证明。如斯等类安隐众生。正使三千世界一切众生。皆由想行故堕地狱。假使大众在地狱中。有一人生告地狱人。无得恐怖。当为汝等一一道利。以时方便出大地狱苦恼之患。则以己身一一济之。移着安处一一人故。无数千岁忍在地狱。未曾懈废普令致安。阿难。其人于众生慈愍弘哀。宁增多不。出大地狱立大安隐。阿难言。甚多甚多。天中天。佛言。假使彼人显示神足如是巍巍。令众生类立第一最有为之安。长乐无极成大哀愍。皆逮覆护其功德福。非心所思非言可畅。佛告阿难。今故语汝。如彼菩萨于大地狱。出无数众立之永安。所愍众生若合集是。前所安隐顺和众生。使济大难至有为安。百倍千倍亿万倍。巨亿万倍不如族姓子受是像经。所以者何。计其所兴有为之安。有极尽矣。不至无为不离贪欲不致灭度。逮神通正觉之业。不成寂志泥洹之要。又阿难。是诸菩萨。建立众生无上大安一切智业。又是菩萨以大士法志学道乘。建立佛道度诸众生。立诸声闻缘觉之地。观助佛法修菩萨行住于大道。斯诸族姓子。劝助众生行菩萨法。不料佛教咨启大雄。受立弘慈成一切智故功无限。佛言。阿难。由是正法。若千劫中若无数劫。不可计限亿百载劫。悬邈如是。诸佛世尊常不空间。展转相教。及余无数亿百千垓劫。转复相度使成佛。而无穷功故无限。所以者何。亿千百佛本住宿世。行菩萨业建立佛道。斯等之类在在所生。受是经典各用劝助。逮无上正真之道成最正觉。将来之世无数菩萨。多所开化不可计众。以是劝助具足佛法。成无上正真之道也。如是阿难。诸族姓子训立众生一切智安无上大道。欲平等有法父母者。正当谓之诸佛菩萨道法父母。今是菩萨拥护自归普得自立。是所谓安颰陀和。桥曰兜等五百人等。则法父母。斯诸菩萨护是正典。族姓子族姓女等。不违佛教。亦不绝一切智本。于将来世临法欲没。为诸众生建立大护。住在大哀开益一切。以是劝助在于末世。而安护之不堕恶趣。令无数千亿菩萨若无数佛共嗟叹。是族姓子等功勋之德不能究竟。所以者何。是诸族姓名勋至德不可思议

佛告阿难。佛无数劫亿千兆载。合集积累是正法宝。其受是法族姓子等。十方无数不可计会。诸佛世尊游无限土。今现在者咸共拥护。学是法者皆令安隐。佛言。阿难。天上世间。悉为是等诸族姓子。稽首敬礼归命咨受。十方诸佛悉嗟叹之。所演经法以示不逮。阿难。佛以豫印印是族姓决一切疑。若后末世受如是像无上正法。持讽诵说宣布同学。是族姓子及族姓女。以为疾近一切智业。临法灭时闻是景摸深妙经法。怀喜信者。佛以授决行菩萨乘。如是至真。最后末世爱护是法。建立己身而爱乐法。佛以劝助。是诸族姓子及族姓女。而不诽谤斯深妙法。佛预授决诸声闻乘。见弥勒佛出现于世。诸漏已尽无有爱欲。用受信是深妙法故。未曾诽谤致是功报。佛言。若菩萨学闻是深法信乐悦豫。亦皆授决。在于弥勒如来世时。出家学寂而复誓愿。乃有殊特。佛谓。是族姓子女。德本调柔功勋无际。临法欲没最后末世。受斯深法奉行精进。德不可量巍巍如是

    持人菩萨经嘱累品第十五

尔时持人菩萨前白佛言。愿佛建吾以转法者不求名利。最后末世闻是正典。显发忻悦受微妙义。以是之故疾解诸法。逮分别慧速得意力。剖判诸法晓了道慧。所生之处识念不忘。以大法光照于十方。佛言。持人。若有菩萨观是法品。大智慧业无极明本。积大功德不可限量。若将来世受是法品持讽诵读。及余深经菩萨箧藏。诸度无极勤心奉行。魔事因缘不能得便。不为罪盖之所覆蔽。佛预授决见两三佛。辄当逮得无所从生法忍。其得忍者亦当得是无上道品。自解诸法而得自在。严净佛土具足声闻。受其道教奉菩萨行。如是持人。佛下印封断一切疑。最后末世现得四义自在之业。行菩萨大士法。受是经典而拥护之。被弘誓铠。何谓为四。一曰受己德本甚大无极。不可限量不可计会。二曰当为众生显发善元。三曰咨受如来正法经要。四曰执持法藏无央数佛所宣道化。是为四。复有四法。最后末世将护深法。何谓为四。一曰摄取精进在弊恶世受行正法。二曰若在厄难第一苦毒诤乱正法。所持法品人共斗时化令和合拥护正法。三曰行发忍辱具足仁和。四曰在于末世心不怀恨。往来周旋常行慈愍。是为四。得致深法疾逮一切智

尔时颰陀和桥曰兜。五百菩萨及余菩萨。闻佛说是道品正法。咸住佛前心自念言。于后末世拥护正法。佛以右掌摩诸菩萨。而告之曰。诸族姓子。佛无数劫而积习是无上正真道。成大宝藏。甚用勤苦忍遭困厄。所济无限使得大安。舍身之安而忧一切。乃致道法成最正觉。以累仁等。若有学诵逮是法者。广为四辈而敷演义。若三品法欲毁坏时。当建立护尔乃震扬无极大光。佛重累族姓子等。如来犹父。诸贤如子。佛犹国君。诸仁如臣。父慈子孝君正臣忠。天下和平。吾无数劫习是正法道德宝藏。令普流布八极上下。诸天人民一切慈孝自归命佛。佛以大哀皆共蒙济。尔时诸菩萨众。从颰陀和桥曰兜等五百群众。稽首佛足前白佛言。承佛圣旨。任力尽意将护末世。佛所宣教惟愿如来建立垂恩。最后末世。令斯正法道宝之藏。使普流布八方上下。一切皆蒙。佛加威神说是法品。有无央数不可计会诸菩萨众。得一生补处。德本道慧皆以备悉。无数亿千诸天人民。皆发道心。佛悉授决。于将来世皆得佛道。各有名号。佛说如是。持人菩萨及一切菩萨。颰陀和桥曰兜等。五百群众。四部众会。诸天世人阿修罗。闻佛所说莫不欢喜。作礼而去

持人菩萨经卷第四


持世经

    No. 482 [No. 481]

持世经卷第一

        姚秦龟兹三藏鸠摩罗什译

    持世经初品第一

如是我闻。一时佛在王舍城迦兰陀竹园。与大比丘僧俱。尔时世尊与若干百千万众。恭敬围绕而为说法。会中有菩萨摩诃萨名曰持世。为诸菩萨摩诃萨无量功德庄严发心。欲善知一切法彼岸。欲善知发无量愿具足无量庄严。欲通达无量诸法决定相。欲发无量庄严愿深心所行清净。欲善知清净具足布施。欲善知毕定清净持戒。欲善知具足忍辱柔软之心。欲善知清净精进。欲善知清净禅定。欲善知通达般若波罗蜜彼岸。以如是等无量功德故。从坐而起偏袒右肩。合掌向佛白佛言。世尊。我欲问佛。为利益安乐一切众生。及诸菩萨摩诃萨不断佛种者。具足威仪行处不着持戒。具足清净戒受行大法。善知持无量行处道法。为是诸菩萨故。我今问佛世尊。云何菩萨摩诃萨能善知诸法实相。亦善分别一切法章句。云何菩萨摩诃萨能得念力。亦转身成就不断之念。乃至得阿耨多罗三藐三菩提

尔时世尊告持世菩萨言。善哉善哉。持世。汝能为诸菩萨摩诃萨故问如来是事。当知汝则多所安隐众生怜愍世间。利益安乐诸天世人。亦为今世后世诸菩萨等作大光明。汝之功德不可限量。能问如来如是之事。汝必欲断一切众生之疑。爱护一切众生。为作光明。欲示众生义利。欲令众生得度崄道。欲为众生作归作舍作洲作救。欲拔三恶道众生。欲置众生于无上道。欲脱众生生老病死忧悲苦恼。欲与众生无上涅槃之乐。汝欲于后世守护正法。于后恐怖恶世欲度众生。持世。汝今善听谛思念之。吾当为汝解说此事。唯然世尊。佛告持世。诸菩萨摩诃萨见四利故。勤修习诸法实相。亦善分别一切法章句。何等四。当得具足念。当得不断念。当以安慧而自增长念常在心。持世。是为诸菩萨摩诃萨见此四利故勤修习诸法实相。亦善分别一切法章句。持世。诸菩萨摩诃萨复见四利。勤修习诸法实相。亦善分别一切法章句。何等四。当善知决定诸法义。当善知诸法义。当善知诸法种种因缘。当善入诸法如实门。是为四。持世。诸菩萨摩诃萨复见四利。勤修习诸法实相。亦善分别一切法章句。何等四。当善知无量法相。当修习善知决定无量法。当行无量功德而自增长。当知见诸法生灭相。是为四。持世。诸菩萨摩诃萨复见四利。勤修习诸法实相。亦善分别一切法章句。何等四。当近阿耨多罗三藐三菩提。当疾具足助菩提法。当不随他语善知诸法方便故。当善知一切智慧。持世。是为诸菩萨摩诃萨见四利故勤修习诸法实相。亦善分别一切法章句。持世。诸菩萨摩诃萨复有四法。勤修习诸法实相。亦善善分别一切法章句。何等四。为利益众生故心无悭垢。常行清净戒安住毗梨耶波罗蜜故。发行精进不休不息。正思惟故善行般若波罗蜜。是为四。持世。诸菩萨摩诃萨复有四法。勤修习诸法实相。亦善分别一切法章句。何等四。成就具足深心清净之愿。具足成就清净所行功德。安住柔和忍辱功德。得分别诸法实相光明。是为四。持世。菩萨摩诃萨复有四法。勤修习诸法实相。亦善分别一切法章句。何等四。以大欲求一切智。善知分别禅定解脱诸三昧而生大欲。欲得大慈悲喜舍心故方便行清净行处。善修习决定义。是为四。持世。菩萨摩诃萨复有四法。勤修习诸法实相。亦善分别一切法章句。何等四。具足慧行。亦求清净智行处。乐无碍智。亦常不离一切智慧之愿。持世。是为菩萨摩诃萨有四法勤修习诸法实相。亦善分别一切法章句

持世。菩萨摩诃萨见四利故能求念力。何等四。当修集具足念根。当行安慧。当具足不断念。当修集具足四念处。是为四。持世。菩萨摩诃萨复见四利能求念力。何等四。具足诸助菩提法故念常在心。以利念根善修集宿命。具足清净智慧故当疾得不断念。当种一切智慧因缘。是为四。持世。菩萨摩诃萨复见四利能求念力。何等四。当修集具足思惟方便。当修习如实智慧。当发勤精进得诸佛法故。当不忘忆念得不断念力故。持世。是为菩萨摩诃萨见四利故能求念力

持世。菩萨摩诃萨有四法能得念力。何等四。念安慧故常勤精进不休不息。常一其心得诸法实相故。常不放逸正忆念诸法故。常护诸根正思惟故。是为四。持世。菩萨摩诃萨复有四法能得念力。何等四。安住清净持戒。成就清净威仪行处。除去心中五盖。不为世法所染离业障烦恼障。是为四。持世。菩萨摩诃萨复有四法能得念力。何等四。以不散心求善法。勤修习一心相。善知正入诸法门。不乐愦闹远离在家。是为四。持世。菩萨摩诃萨复有四法名能得念力。何等四。亲近善知识。常修习深法。常乐至诸佛菩萨所。常乐请问修习智慧。持世。是为菩萨摩诃萨有四法名得念力

持世。菩萨摩诃萨见四利。能修习一切法分别章句慧。何等四。当善知一切诸法实相。当分别一切法所因。当知诸法决定之义。当善知一切法言语章句。是为四。持世。菩萨摩诃萨见四法利。能修集一切法分别章句慧。何等四。当善知诸法随宜次第。当善知一切法因缘方便。当具足修集一切法方便。当分别知了义未了义经。是为四。持世。菩萨摩诃萨复见四法利。能修集一切法分别章句慧。何等四。当善学是道是非道慧。当得一切法义说力。当疾得清净智慧行处。当具足修智波罗蜜。持世。是为菩萨摩诃萨见四法利能修集一切法分别章句慧。持世。菩萨摩诃萨复有四法。能修集一切法分别章句慧。何等四。善知修集诸法集相。善知诸法因灭相。善知诸法缘相。能入因缘方便。是为四。持世。菩萨摩诃萨复有四法。能修集一切法分别章句慧。何等四。善知诸法苦。善知诸法集。善知诸法灭。善知诸法灭道。是为四。持世。菩萨摩诃萨复有四法。能修集一切法分别章句慧。何等四。善知诸法合散。方便得先因力。善知诸法所宜。善知分别文字章句。是为四。持世。菩萨摩诃萨复有四法。能修集一切法分别章句慧。何等四。善知不了义经。于了义经中不随他语。善知一切法相印。亦善安住一切法无相智中。持世。是为菩萨摩诃萨有四法能修集一切法分别章句慧

持世。菩萨摩诃萨有四法。转身常得不断念乃至得阿耨多罗三藐三菩提。何等四。明了善不善法。成就第一念安慧。能离五盖心。终不忘念阿耨多罗三藐三菩提心。是为四。持世。菩萨摩诃萨复有四法。转身常得不断念乃至得阿耨多罗三藐三菩提。何等四。善修集四念处。善修集学分别慧。于诸禅定智慧为首。于决定智慧中得通达。是为四。持世。菩萨摩诃萨复有四法。转身常得不断念乃至得阿耨多罗三藐三菩提。何等四。得诸陀罗尼门。亦修集无生智。入于尽智。亦观于灭智。是为四。持世。菩萨摩诃萨复有四法。转身常得不断念乃至得阿耨多罗三藐三菩提。何等四。断于爱恚。不贪着一切有为法。心通达无为智慧。至如来所行处。持世。是为菩萨摩诃萨有四法转身常得不断念乃至得阿耨多罗三藐三菩提心。持世。菩萨摩诃萨有五净智力。能具足得如上功德。何等五。深心净智力。愿净智力。善根净智力。回向净智力。障业净智力。是为五。持世。菩萨摩诃萨复有五净智力。皆具足能得如上功德。何等五。威仪行处净智力。念具足净智力。方便净智力。缘众生净智力。缘相净智力是为五。持世。菩萨摩诃萨复有五净智力。能具足得如上功德。何等五。舍心净智力。利益众生净智力。生大慈净智力。生大悲净智力。生大喜大舍净智力。是为五。持世。菩萨摩诃萨复有五净智力。皆能具足得如上功德。何等五。持戒净智力。不着持戒净智力。忍辱净智力。不着忍辱净智力。多闻净智力。是为五。持世。菩萨摩诃萨复有五净智力。皆能具足得如上功德。何等五。深精进净智力。受精进净智力。禅定净智力。禅定方便净智力。止观方便净智力。是为五。持世。菩萨摩诃萨复有五净智力。皆能具足得如上功德。何等五。慧净智力。多闻决定方便净智力。世间出世间净智力。慧方便净智力。有为无为净智力。是为五。持世。菩萨摩诃萨复有五净智力。皆能具足得如上功德。何等五。观方便净智力。明解脱净智力。无生相净智力。一相无相净智力。第一义世谛义净智力。持世。是为菩萨摩诃萨有是五净智力疾得具足如是一切功德。持世。以是利故。菩萨摩诃萨于是净智力中应勤修集。持世。菩萨摩诃萨成就三法。于是净智力中能勤修集。何等三。一者欲。二者精进。三者不放逸。菩萨摩诃萨成就此三法。能于是具足一切功德净智力中能勤修集。何以故。持世。欲精进不放逸。皆是一切法根本。菩萨摩诃萨得是净智力。能疾得一切智。亦名精进不退者。亦名不退法者。亦以此功德疾得增长。亦于一切法中疾得净智力。持世。若有人如是一切法中得净智力者。是为世间福田。是人次我能消供养。是人能至如来行处。是人能观如来法。是人不久能证如来智慧。持世。我本无量阿僧祇劫行菩萨道时。然灯佛与我受记。汝过阿僧祇劫当得作佛。即时边知如是净智力。持世。若有人于一切法中能成就如是净智力者。是人当得阿耨多罗三藐三菩提。如我今得。是人亦转法轮。如我今转。是人亦师子吼。如我今师子吼。是人亦于一切法中得自在力。如我今也。持世。汝等于此净智力中当勤精进。不久自然具足一切智慧

持世。过去无量阿僧祇劫。有佛号智高王如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。持世。是智高王如来。有无量声闻僧。亦有无量诸菩萨僧。是佛本愿因缘所致。是智高王佛土无三恶道。其诸众生不觉有苦。毕竟具足安隐快乐。离欲多者能障五盖。是诸众生成就如是清净快乐。如人入第四禅乐。是智高王佛寿六百万亿那由他劫。持世。是时国土唯佛为王。更无有王。国土众生皆号佛为法王。是智高王佛多为诸菩萨。说是断一切众生疑喜一切众生心菩萨藏经。尔时有五百菩萨。闻是诸菩萨净智力。发如是精进力。尽形不生坐心。尽形不生衣服想。尽形不生我想众生想人想男女想。尽形终不多食。但修集如是净智力。勤行精进。五百菩萨以是善根因缘。命终皆生过东方十万亿国土。既生不久。修集是法故。得识宿命成就利根。其国土佛号无量花积王。现在说法。其诸菩萨始年十六。于无量花积王佛所出家。六十亿岁行童子梵行。亦修行如是精进。持世。是五百菩萨得值如是等二十亿佛。于诸佛所勤行精进。成就第一念安慧。末后值无量力高王佛与其授记。过万劫已当得阿耨多罗三藐三菩提。是五百人于万劫中。得值二万亿佛具足佛道。于一劫中次第得阿耨多罗三藐三菩提。持世。当知菩萨摩诃萨欲疾得阿耨多罗三藐三菩提者。于是净智力中。应生欲精进不放逸。何以故。持世。诸佛阿耨多罗三藐三菩提。皆以欲精进不放逸为根本。及余助道法。能具足佛法者。持世。我以如是精进得值二十亿佛。于诸法中世世成就念力。世世得识宿命。修集是法不休不息。我终不失是欲精进不放逸。我当成就欲精进不放逸。尔时世尊。以大慈悲心顾视四方。现神通力使三千大千世界诸阎浮提。皆有化佛。为诸众生说是断一切众生疑喜一切众生心菩萨藏经。复以神力令竹园中在会大众皆见诸佛遍阎浮提各各说法。大众咸悦。从坐而起皆共礼佛作是言。希有世尊。诸佛如来神力不可思议。成就无量不可思议法。尔时佛告大众。诸善男子。如来是事未足为难。所以者何。如来善能通达法性故。若一毛孔出神通力。光明普照十方恒河沙世界。演说法音。于一毛孔百千万亿分未尽其一。如来成就如是不可思议功德。诸善男子。如来深观众生心而为说法。诸善男子。今世众生少有于是法中能行欲乐。诸善男子。今世众生少有于是法中能行精进。诸善男子。今世众生少有于是法中能行不放逸。何以故。如来今出五浊恶世。所谓众生浊。见浊命浊。烦恼浊劫浊。诸善男子。若有乃至一人能信受如是甚深清净法能至佛慧。是为希有。何况能信解如来所行。诸善男子。我常长夜庄严如是愿。如是精进忍辱行。为苦恼众生无救护者无依止者多堕恶道者。我于尔时当成佛道。利益无量阿僧祇众生。诸善男子。当知如来恩力本清净愿精进故。能令无量阿僧祇众生信解受持如是深法。诸善男子。我于先世教化众生。是诸众生能解我法。诸善男子。今佛以十力四无所畏。少能令众生信解如是甚深之法。若有众生住是法中者。皆是如来恩力方便故。我长夜不离如是深法。我亦长夜大慈大悲大喜大舍摄取众生。少有如来出五浊世利益众生。何以故。诸善男子。我于先世。以大精进力大方便力教化众生。集是阿耨多罗三藐三菩提

诸善男子。我念过世。一日之中舍千身布施利益众生。诸善男子。我于若干千万世。见饥饿众生故。自割身肉煮以与之。我于尔时心无忧悔。但于众生普行大悲。诸善男子。当知我如是以大精进大方便力教化众生。集是阿耨多罗三藐三菩提。是故诸善男子。应发如是欲精进不放逸修集阿耨多罗三藐三菩提如我行菩萨道时。汝等亦当如我利益教化众生。诸善男子。是贤劫中诸佛出世。无不赞我作如是言。释迦牟尼佛深行精进如是。释迦牟尼佛具足精进如是。释迦牟尼佛具足精进波罗蜜如是。释迦牟尼佛行菩萨道时。教化众生如是。出于五浊利益无量阿僧祇众生。诸善男子。如是行道故。应勤生欲精进不放逸。诸善男子。我今虽得阿耨多罗三藐三菩提。精进犹不休息。至涅槃时犹发精进。碎身骨如芥子解散支节。何以故。怜愍未来世众生故。我先世行菩萨道时。所化众生或行错谬堕诸难处。欲勉济之起大悲心。分布舍利乃至如芥子皆与神力。我灭度后若有众生。应以舍利度者心得清净。得清净已。处处地中随愿成就。诸善男子。我先世行道时。于众生中成就如是悲心。碎身舍利普使分布。是我本愿。我以如是无量福德因缘大悲心故。于后恶世普覆众生。诸善男子。若诸菩萨于此法中能生欲精进不放逸必发是愿。于后末世受持读诵为人广说如是等经。我当以神力令诸菩萨受持读诵为人广说。我亦以如是经嘱累是诸菩萨。以其能受持读诵为人广说故。所以者何。诸善男子。随是经所住。当知其土有佛不灭。是故如来以此经嘱累诸菩萨。诸善男子。当知我宿世以如是因缘摄取众生。今世亦复摄取众生。后世亦复摄取众生。所谓护念如是经法。于后五百岁普流布故。诸善男子。若于今世若我灭后。若聚落城邑山林旷野。有如是等经若能受持读诵为人解说。当知此中则为有佛。何以故。我说诸佛即是法身。以见法故则为见佛。佛不应以色身见。若人信法听法。是人则为信佛亦听佛语。若人于此法中。能如说修行。是人则为见佛。是人名为实语者法语者随法行者

诸善男子。我身非法非非法。是名随法行。是名第一法施。所谓不着法不着非法。何以故。若着法者不名见佛。诸善男子。不着一切法名为见佛。若于一切法中无所见者。是名见佛。何以故。如来不可以法说。不可以非法说。亦不可以法见。所以者何。诸善男子。如经中说。汝等比丘。若知我法如筏喻者。法尚应舍。何况非法。若能舍法非法。是名见佛。何以故。如来名为舍一切法者。不贪不受诸法名字。不堕名字法中。何况堕非法名字中。诸善男子。舍离一切法名字。名为如来。能如是见者。名为见如来。何以故。舍离见一切法故。名为见如来。以一切法不可得故。如实知见一切法故。名为见如来。诸善男子。若一切法不可得。舍离一切法。是中即无戏论。无是法非法名字。无行无示。是名见如来。若人能如是见法者。是名见如来。若能如是见如来者。是名正见。若异见者名为邪见。若邪见者则为妄见。是人不名为真见。诸善男子。真见者断一切语言道。非真非妄非有非无。离一切法不取一切法。不得一切法。如是见者名为见如来。何以故。诸善男子。如来不以法性见。见一切法性离者。名为如来。若能如是见者。名为正见。诸善男子。汝等应如是见如来。汝等且观。如我所说观于如来。如是观者。当知一切法皆是如来。当得一切法如。当得一切法实相。当得一切法非虚妄相。当知一切法是如来法。当知一切法是如来行处。当知一切法是不可思议行处。诸善男子。是故我说一切法是如来行处。如来行处是无行处。何以故。一切法行处。是中无法可行。是故说无行处是如来行处。一切法行处即是无行处。无行处即是如来行处。何以故。一切法行处无所有故。无行处是如来行处。一切行处入如来行处。则非行处。如来通达证是法故。是名无行处是如来行处

诸善男子。能知一切法无行处。是人能入如来行处。是人能观如来行处。是人能求如来行处。是人亦不着如来行处。何以故。是人知无行处是如来行处。离行处是如来行处。所谓一切法不可得。不可分别不可贪故。是名非行处是如来行处。是名入智行处。不入一切法故。何以故。一切法无门故。以是门入。诸善男子。一切法无入无出。一切法无形。所以者何。如来于法无所得。何法若出若入若见若说。诸善男子。是名入一切法门。以不入相故。一切法无合无散无缚无解。是一切法门以无门故。说是门名为不可出门不可入门。不可归门不可说门。毕竟无生门。以是法门。于法无所知无所见。以是法门。于法无证无所入。何以故。诸善男子。一切法无门。门不可得故。虚空是一切法门。从本已来性清净故。无断是一切法门。断无所有故。无边是一切法门。边不可得故。无量是一切法门。量不可得故。无际是一切法门。诸际无所有故。诸善男子。若有善男子善女人。能入是法门者。则入一切法门。则知一切法门。则说一切法门

    持世经五阴品第二之一

尔时佛告持世菩萨。持世。若菩萨摩诃萨欲得一切法实相。若欲善分别一切法章句。若欲得念力。若欲转身具足得不断念乃至得阿耨多罗三藐三菩提者。当疾入如是法门。于是法门得智慧光明。何以故。于是法中疾得具足故。又复持世。菩萨摩诃萨勤修集如是法门。入是法方便门者。则能得分别阴方便。界方便。入方便。因缘生法方便。四念处方便。五根方便。八圣道分方便。世间出世间法方便。分别有为无为法方便

持世。何谓菩萨分别五阴方便。菩萨摩诃萨正观五取阴。所谓无明阴是五取阴。苦阴是五取阴。痴阴是五取阴。病阴痈阴。如箭入身阴是五取阴。菩萨分别观察。选择色取阴。云何为分别观察选择色取阴。是色取阴从四大生。假名为色取阴。是色阴无有自性。但以四大和合。假名为色阴。色阴无有作者。无使作者。无作无起无出。名为色阴。但以先业因缘四大所摄数名色阴。非阴是色阴。譬如虚空。阴实无生相。若说虚空阴。是中无有法生。但有名字。故名为虚空阴。凡夫于此无阴阴相。以颠倒心故无实实相。贪着我五阴我所五阴。我色阴我所色阴。如是贪着。是诸凡夫贪着色已。于色中依止我我所。有色受色取色着色依色。受行种种恶不善业。我等不应随凡夫学。我等应勤修集助菩提法。今应正观色阴。菩萨正观色阴时。知同水沫聚。云何知同水沫聚。无聚是水沫聚。但从众缘生。不可执捉无有坚牢。水沫聚中无有。聚相无聚是水沫聚。色阴亦如是。色阴中无有阴相。菩萨如是观时作是念。凡夫不能正观虚妄色。不能如实知色无常。不能如实知色相。我等入正道。不应贪着虚妄。不应贪着色。何以故。色是不可贪着相。色但有名字无决定相。当观是色无决定相。离名字故名之为色。又说色名恼坏相。智者通达知是无相。我等应当善知修集色无相方便。不贪着色相。若人贪着色相。即贪着色。我等应善知入色相。菩萨如是正观时。如实观察选择色。是色阴皆从凡夫忆想分别起。若法从忆想分别起。即是不生。一切忆想分别皆非真实。凡夫依止颠倒所起色。为色所缚为色所害。往来苦恼。无明痴闇故。贪色不舍。见色有常牢固。是凡夫人为色缚。色所缚故。往来地狱畜生饿鬼天人。深贪色味。不观色中有诸过恶。我等不应随凡夫学。应当观察选择分别修习色方便。分别观察选择色时。见色性如梦。譬如梦中色。皆从忆想分别觉观起。曾所见闻觉知因缘起。是梦中亦知彼我。亦见地水火风。亦见山河丛林。梦中色相无有决定。但以忆想故有。色阴相亦如是。从先世业因缘出。无有决定性。菩萨如是思惟不取色。若我若我所。但正观色如实无常相虚妄颠倒。众生颠倒贪着取色。若我色。若我所色。若彼色。若彼所色。如是正观察选择色时。不得色。不见色性。亦不贪着色无常。菩萨尔时若于色中。爱念贪着皆悉除断。善知色正相善知色平等相。善知色灭相。善知色灭道相。善知色阴无所从来亦无所去。作是念。是身色阴。皆从业果报觉观起。四大所摄是身色阴。非我非彼无有所属。无所从起。观色阴如是。内色不贪不受。外色不贪不受。过去色不贪不受。未来色不贪不受。现在色不贪不受。即知一切色阴是无生相。是菩萨尔时不灭色亦不求灭色法。持世。菩萨摩诃萨观察选择色取阴如是

持世。何谓菩萨摩诃萨观察选择受取阴。菩萨作是思惟。是苦受乐受不苦不乐受。皆从因缘生。属诸因缘入受相中。此中无有受者。但以贪着故。贪著者即是不真。虚妄从忆想分别起。是菩萨如是思惟时作是念。是凡夫为虚妄受所缚。为三受所害。所谓苦乐不苦不乐受。是凡夫若受乐。为爱结所使。以爱结所使故。能起恶业。若受苦。为恚结所使。以恚结所使故。起诸恶业。若受不苦不乐受。为无明结所使。是人因无明结所使故。不脱忧悲苦恼。我等今不应随凡夫学。应正观诸法。我等应如实观诸受。菩萨如实观受阴作是念。非阴是受阴。从忆想分别起。颠倒相应无有受者。但从先世业因起。今世缘故。诸受自性空。受中无有受相。菩萨观达受阴。譬如雨渧水泡。有生有灭无有决定。受阴亦如是。次第因缘起。属诸因缘无有住时。虚妄不实从忆想颠倒相应起。菩萨尔时作是念。凡夫可愍为诸受所制。以不正观受阴故。故得乐受生着。得苦受亦生着。得不苦不乐受亦生着。为诸受所缚驰走往来。从身至身受结所缚。轮转五道无有休息。是凡夫着于诸受。为受所制为受所系。不脱受阴。于受阴所不见出处。不知正观受阴故。不知如实观受阴无常。于受阴中为欲染所缚。不知受阴如实相。我等今不应随凡夫学。应如实观察选择受阴。即时如实观受阴。无阴是受阴。不真阴是受阴。颠倒阴是受阴。不住阴是受阴。是时见受阴如实相。无有作者。无有使作者。于受阴中不见受阴相。如是观受阴。不见受阴在内不见受阴在外。不着受我不着受彼。知受阴无所从来无有所属。无法能生受者。但从颠倒相应先世业果报数名受阴。见受阴虚妄因缘相续行。尔时过去受阴。不受不贪不着。未来受阴。亦不受不贪不着。现在受阴。亦不受不贪不着。是人于乐受中除却爱结。于苦受中除却恚结。不苦不乐受中知见无明结故。勤行精进。菩萨尔时。若受乐受心不生爱。若受苦受心不生恚。若受不苦不乐受心不生痴。持世。凡夫多于乐受生爱。苦受生恚。不苦不乐受生痴。是诸凡夫以爱恚痴故深入闇冥。不能如实知受阴。亦不知爱恚痴相。深贪着爱恚痴。所谓是我我所。是此彼等。持世。菩萨摩诃萨于此中正观受阴者。不为爱恚痴所牵。若生爱恚痴。即能除断行于正道。于乐受中断爱结使故勤精进。于苦受中断恚结使故勤精进。于不苦不乐受中断痴结使故勤精进如实知三受相。尔时有所受若苦若乐若不苦不乐。皆离不着。离爱结使。离恚结使。离痴结使。诸受起时皆能知见知受阴如实无常。若能如是知已。于受阴中欲染悉断。入断受阴欲染道中。不为诸受所污。是菩萨若如是正观受阴。如实知受阴。知受阴集受阴灭受阴灭道。然后如实知受阴是无生相。以无生相。通达受阴无相。持世。菩萨摩诃萨如是观察选择受阴。持世。何谓菩萨摩诃萨观察选择想阴。菩萨摩诃萨正观想阴时。见想阴皆从颠倒起。虚妄不坚固不真实。从本已来不生相。以因缘和合从先世业力起。作是念。非阴是想阴。虚妄阴是想阴。颠倒阴是想阴。想阴中无想阴想。譬如春后月焰。以名字故说名为焰。阴想阴亦如是。以识相故说名想阴。凡夫于此为虚妄想所系。或识乐或识苦。或识不苦不乐。或识寒热。或识男女。或识五道生死。或识合或识散。或识过去。或识未来。或识现在。或识好或识丑。或识有或识无。是凡夫想。皆为颠倒虚妄。属诸因缘。但假名为想阴。此中若内若外。无有想者。凡夫人虚妄想所系故。或识贪欲。或识嗔恚。或识愚痴。或识妻子。凡夫依止是想阴贪着虚妄。以是想阴驰走往来。不能如实观想阴是虚妄。凡夫人以我想彼想男女想。系于想阴不能得脱。贪着想阴。我是想阴。我所是想阴。我等不应随凡夫学。菩萨摩诃萨如是正观想阴。想阴中想阴想不可得。如焰阴中焰。阴相不可得。菩萨见想阴如焰性。过去想阴不贪不受不着。未来想阴亦不贪不受不着。现在想阴不住。不分别若我若彼。即彼灭想受阴道。通达想阴是无生。不见想阴若来处若去处。但以颠倒相应先世业因所起。现在缘所系。无阴是想阴。观察选择想阴。无所从来亦无所去。即通达想阴无生。亦不分别想阴灭。但为灭一切想受阴故。亦住如实知见故。菩萨如实观想阴时。远离一切想道心。亦不住一切想道。但住知见想阴。亦如实想阴。不贪着想阴。如实观察一切想阴。如实知想阴集灭尽。持世。菩萨摩诃萨如是正观察选择想阴。则离想阴欲染。亦能行断想阴欲染道

持世。何谓菩萨摩诃萨观察选择行阴。持世。菩萨摩诃萨。观行阴从颠倒起虚妄忆想分别假借。而有菩萨尔时若身行口行意行。皆观不净无常苦空无我。如是观时作是念。非阴是行阴。苦阴是行阴。因缘生阴是行阴。像阴是行阴。诸行阴无增无减无集。若身行口行意行无有作者。智者不贪受是行阴何以故。是诸身行。不在身内。不在身外。不在中间。口行意行亦如是。不在意内。不在意外。不在中间。行阴中无行阴相。何以故。是行阴从众因缘颠倒起。虚妄不真。先业果报所摄。亦令因缘所系。能有所行诸所有行。若身行若口行若意行。皆非真行。是无所有行。是虚妄行。是颠倒行。是故说非阴是行阴。何以故。智者不决定得行阴相。是身行是口行是意行。此处彼处若内若外。又身口意行。尚无决定行相可得可说。何况行阴可得可说。是故说无阴是行阴。凡夫起颠倒想贪着身口意行。忆念分别是行阴。为行阴所缚驰走往来。是凡夫人以颠倒故。起身口意行。起已贪着归趣。无法生法想。无阴生阴想。贪着颠倒行故。为行阴所系往来五道。常随身口意行。不能如实观身口意行。不能如实观行阴故。以身口意而起诸行。是诸凡夫着颠倒故。着不真法故。着虚妄故。数名行阴。持世。菩萨于此中如是正观诸行无有根本。羸劣无力以众缘和合。可说行阴。是中无有真实行阴。无阴是行阴。从本已来不生是行阴。无性是行阴。诸行前际不可得。后际不可得。中际不可得。无有住时诸行念念生灭。持世。菩萨如是正观行阴空不可得。不坚牢相。乃至毫厘亦不可得。作是念。是诸凡夫为不坚牢法所系。行阴所系。贪着所缚。起身口意行。我是行我所是行。起如是业为行阴所缚。不知行阴性入无明痴冥。于诸行中生真实想。以颠倒故贪着受取行阴。是人贪着受取行阴故。或起乐行或起苦行。或起不苦不乐行。是人起乐行已得乐身。起苦行已得苦身。起不苦不乐行已。得不苦不乐身。是人得乐身已生爱。得苦身已生嗔。得不苦不乐身已生愚痴。是人以爱嗔痴故。不见诸行过恶。不能清净身口意行。是人身口意行不清净故。堕不清净道中。所谓地狱畜生饿鬼。或时暂生天人中。贪着身口意行。深着行阴。菩萨摩诃萨应如是正观。今我等不应随凡夫学。我等应清净身口意行。不应贪着行阴。应观行阴过恶。应求出行阴道。如是观者名为如实正观行阴。亦名正观行阴无常。即时如实观诸行。诸行集诸行灭。诸行灭道。不受不贪不着诸行。亦不贪不着行阴。如是观时远离行相。亦行无行阴道。即观诸行空。于一切诸行中。惊怖生厌离心。但起清净身口意行坏行相故。离行阴相故。是人有所得身皆是清净。何以故。是人身业清净。口业清净。意业清净。身行清净。口行清净。意行清净。是人远离行阴相。坏诸法及根本相。如是正观时见行阴无所从来亦无所去。不得诸行决定生相。亦不得决定灭相。即观诸行无生灭相。一切诸行亦无生灭。是人观一切诸行无生灭相。生厌离心。正通达诸行集灭相。虽证诸行无生相。而善通达诸行相。何以故。持世。是行阴无决定相。譬如芭蕉坚牢相不可得。无坚牢相亦不可得。行阴亦如是。坚牢相不可得。无坚牢相亦不可得。持世。菩萨摩诃萨如是观察选择思惟入于行阴

持世经卷第一持世经卷第二

        姚秦龟兹三藏鸠摩罗什译

    持世经五阴品第二之二

持世。何谓菩萨摩诃萨正观察选择识阴。菩萨摩诃萨观非阴是识阴。颠倒阴是识阴。虚妄阴是识阴。何以故。持世。是识阴从颠倒起。虚妄缘所系。从先业有。现在缘所系。属众因缘。虚妄无所有。忆想分别起。从识而生。有所识故名之为识。从忆想分别觉观生。假借而有。有所识故数名为识。以识诸物故。以起心业故。以思惟故。众缘生相故。起种种思惟故。数名识阴。从有所识。有识像出。示心业故。摄思惟故。数名识阴。或名为心。或名为意。或名为识。皆是意业分别故识阴所摄。识相识行识性示故。数名识阴。如是非阴是识阴。不生不起不作。但以颠倒相应缘虚妄识故。数名识阴。何以故。是识阴从众因缘生无自性。次第相续生。念念生灭。是识缘不生阴相。何以故。是识阴生相不可得。决定相亦不可得。生相不可得故。决定相不可得故。根本无所有故。自相无故。牢坚不可得故。智者正观察选择通达非阴是识阴。凡夫于非识阴生识阴相。以觉观分别忆想颠倒相应虚妄所缚。强名为识阴。贪着是识阴依止所识。依止识种种示思惟故生起识阴。是人种种分别。贪着内识。贪着外识。贪着内外识。贪着远识贪着近识。以识相故分别起识阴。是人以忆想分别若心若意若识。假借强名是心是意是识。如是知种种心相生。是凡夫贪着识阴。为识阴所缚。心意识合故。起种种识阴。分别虚妄事故。以一相故。以决定相故。能得是心是意是识。能得分别爱着。是人依止识阴深贪识故。亦得过去识阴贪着念有。亦得未来识阴贪着念有。亦得现在识阴贪着念有。诸凡夫于见闻觉知法中。计得识阴贪着念有。是人贪着见闻觉知法。为识阴所缚贵其所知。以心意识合系故驰走往来。所谓从此世至彼世。从彼世至此世。皆识阴所缚故。不能如实知识阴。识阴是虚妄不实颠倒相应。因见闻觉知法起。此中无有实识者。若不能如是实观。或起善识。或起不善识。或起善不善识。是人常随识行。不知识所生处。不知识如实相。持世。菩萨摩诃萨于此中如是正观知识阴从虚妄识起。所谓见闻觉知法中众因缘生。无法生法想故贪着识阴。我等不应随凡夫学。人我等当如实正观察选择识。如实正观察选择识阴。是诸菩萨如实观时。知识阴虚妄不实从本已来常不生相。知非阴是识阴。像阴是识阴。幻阴是识阴。譬如幻所化人识。不在内亦不在外。亦不在中间。识性亦如是。如幻性虚妄缘生。从忆想分别起。无有实事如机关木人。识亦如是从颠倒起虚妄因缘和合故有。如是观时。知识皆无常苦不净无我。知识相如幻。观识性如幻。菩萨尔时作是念。世间甚为狂痴。所谓从忆想分别识起于世间。与心意识合。三界但皆是识。是心意识亦无形无方。不在法内不在法外。凡夫为虚妄相应所缚故。于识阴中贪着若我若我所。是人贪着识阴在内。贪着识阴在外。贪着识阴在内外。贪着识阴在彼我。是人贵此识阴为识阴所缚。受识阴味说识阴相。所谓若心若意若识。随味行故贪受识阴。是人为识所缚。识阴合故为心意识所牵。以心意识因缘力故生是凡夫。若起下思得下身。若起上思得上身。若起中思得中身。是人随心意识力故。生依止诸入。贪着识阴故。不脱生老病死忧悲苦恼。菩萨于此中如实正观选择识阴。如实正观识阴无常相故。过去识阴不贪不着不念。知非阴是识阴。未来世识阴亦不贪不着不念。知非阴是识阴。现在识阴亦不依止。如实知识阴无常相。如实知识阴生灭相。若如是思惟正观识阴。是名正观入识阴道。所谓如实知识。如实知识集。如实知识灭。如实知识灭道。是人如实观识阴集灭相。能坏识阴。能断一切相。知识阴集灭相。亦通达识阴集灭相。菩萨尔时亦不生识阴。亦不灭识阴。是识阴从本已来无生。如是观时不分别识灭相。通达识阴无生相。何以故。持世。是识阴无生无相无成。是识阴生性虚妄故。入在无生相中。持世。识阴终不有生成相。是识阴相从众因缘生。持世。菩萨摩诃萨如是观因缘法。非阴是识阴。观察选择信解证知。通达诸所有识悉皆知实。菩萨知识阴实故。如是一切所缘知皆破坏。持世。菩萨摩诃萨如是观识阴。知是识阴无生者。无作者无起者。无受者无所受者。但以众缘生。众缘合故有。缘见闻觉识法故系有。从本已来常毕竟空。如是观识阴时。即知识阴是无作无起相。不贵不着。持世。菩萨摩诃萨如是正观察选择入识阴。若菩萨能如是方便入五阴。能如是方便正观五阴。是名通达入五阴集灭道。皆能断诸阴相。真知五阴方便。以是方便故。于五受阴中。不贪不着不缚不系。如实知色无常相。是菩萨若于色有欲染则能除断。亦如实知受想行识。亦如实知受想行识无常相。若于受想行识中。有欲染则能除断。菩萨于五受阴中除断欲染故。随顺通达决定五阴方便。如是观时。能知五受阴细微生灭相

持世。何谓菩萨摩诃萨能观察选择五受阴细微生灭相。菩萨摩诃萨观众生初入胎歌罗罗时。先五阴灭即更有五阴生。从是已来观五阴生灭相。虽先识灭亦知五阴非断灭相识。虽依止歌罗罗。亦知五阴不至不常。如是观初入胎一念五受阴生灭相。从歌罗罗乃至出生。及后增长乃至死时。观此五受阴念念生灭相。如是观察选择五受阴微细生灭相。持世。是五受阴微细生灭相者。所谓先五受阴灭。次第无物有至胎。识初合时五阴即有生灭。因歌罗罗五受阴假名为人。所以者何。持世。识无所依则不能住。识所依者五受阴是。持世。又无色界中诸天。五受阴细微生灭相亦应如是知。持世。如是细微五受阴生灭相。辟支佛智慧所不能及。何况声闻智慧。惟诸佛如来善知五受阴。从初入胎细微生灭相。及无色天诸阴念念生灭。所谓一切智慧。出一切世间智慧菩萨摩诃萨得无生法忍。至佛慧境界。是人虽如是观察选择五受阴细微相。从初入胎乃至无色天。亦不能究尽如诸佛所知。持世。诸佛如来无有随他智慧。自然得一切智慧方便。得阿耨多罗三藐三菩提。诸佛智慧无所不达。诸佛无碍智慧。于一切法中得决定慧。于一切法中得自在力。何以故。于无量无数千万亿阿僧祇劫行于深法故。持世。一切凡夫不能如是方便观五受阴。何况观五受阴细微生灭相。何以故。诸凡夫人不能知五受阴如实。凡夫不知取。不知受阴

持世。何谓为取。取名我取众生取。见取戒取。五阴取。十八性取。十二因缘取。是名为取。乃至所有法。若内若外。所谓欲取有取。见闻觉识取。我我所取。持世。凡夫于此虚妄取不知不见。颠倒因缘而取诸法。是人为取所系。无明因缘取诸行。诸行因缘取识。识因缘取名色。名色粗相众生染着归趣。所谓色取色合色缚。及取四无色阴。受想行识分别为名。持世。若无诸佛众生。则无所知无所见。不能正观五受阴。诸佛出于世间。坏众生依止色。坏依止受想行识。坏和合一相故。诸佛如来作如是分别说。汝等所依所归。是名为色。是色但以四大和合。受想行识但有名字。名色相成就故说五受阴。汝等众生莫贪归此不牢坚五受阴。持世。如来何故说五受阴。持世。是凡夫人。从颠倒生入无明网。驰走往来何所归趣。贪受五受阴相作是念。我依止此当以得乐。是人以是乐想贪归五阴。以苦想以不苦不乐想贪归五阴。凡夫人所归所依止处。是名五阴。持世。诸凡夫人从生以来盲不知五阴为是何等。不知五阴从何所来。不知五阴如实故。贪受五阴。是故说名受阴。于此中谁有受者此中受者不可得。但以颠倒贪着分别虚妄自缚无明痴闇故。取我取我所。取此彼。是故说受阴是五阴。无有取者亦无决定相。是故智者。知非阴是五受阴。颠倒阴是五受阴。无明阴是五受阴凡夫于此为所系缚。贪归五取阴。以贪归故不知何等是取。何等是取阴。但为贪着所归五阴。往来生死。贪着是五阴故驰走诸趣。贪归何等。贪归见贪归闻。贪归觉贪归识。贪归爱贪归无明。是诸凡夫。为爱缚所缚。贪爱五受阴。为诸盖所覆入无明闇冥。不知不觉我等今为贪归何处。系缚何处。以不知故。往来地狱畜生饿鬼人天道中。生死所缚贪归生死不放不舍。不断五阴亦不能知五阴如实相。不如实知故。为种种苦恼所害。堕虚空狱不知出处。是人不见出道故。于无始生死道中受诸生死。是故不能得脱生老病死忧悲苦恼。亦不得度无量生死险道。亦不得脱诸大苦聚。还复归趣于苦。贪着于苦。为苦所使。何等为苦。五受阴是。生时但苦生。灭时但苦灭。持世。我以是因缘故。为弟子说法。汝等比丘。当正观色阴。亦当如实知色无常相。汝等若于色中有欲染者。当疾除断。汝等当正观受想行识。亦当如实知受想行识无常相。若于受想行识中有欲染者。当疾除断。除断欲染故心得正解脱。持世。若有人知我所说法义如是能如说修行。当得脱生老病死忧悲苦恼。若人不能如说修行。为色缚所缚。为爱系所系。入无明闇冥贪取五阴。是人贪取五阴故。不能得脱生死险道。持世。以是义故。我说世间与我诤。我不与世间诤。何等为世间。所谓贪着五受阴者。为世间所摄。是人贪归五阴。为五阴所缚。不知五阴性。不知五阴空相。而与我诤。是人违逆佛语。与佛共诤故堕大衰恼。若有人于佛在世若佛灭后。能如是观虚妄五受阴空无所有。从颠倒无明闇冥起。虚诳妄想但诳凡夫。非五阴似五阴。如是之人不与佛诤。不逆佛语故。得脱地狱畜生饿鬼苦恼。持世。诸佛不与人诤。断一切诤讼名之为佛。但为众生演说实法作是言。汝等先所取者皆是颠倒。一切众生颠倒力故。贪归五阴往来世间。是人贪归五阴已。起种种邪见。贪归种种名字。贪归种种忧悲苦恼。是人为种种邪见烦恼种种忧悲苦恼之所残害。无有能为作救作舍作归作趣。唯佛能救。凡夫小心小智慧故贪嗜五欲。依止多过五阴。是凡夫人与救者归者依者脱一切苦恼者。而共诤讼。持世。我今举手其有见五阴者。见阴相者。贪五阴者。我则不与是人为师。是人亦非我弟子。不随我出家。不随我行。不归依我。是人入于邪道。入虚妄道取不实者。是为颠倒不知佛意。不知佛随宜说五阴。不知佛第一义。是人不受佛教。不应受供养而受。是人我尚不听出家。何况当得受人供养。何以故。如是之人是外道徒党。所谓生五阴相者。贪着归趣五阴者。持世。当来之世后五百岁法欲灭时。于我法中出家多是生五阴相者。决定说五阴相。深着五阴入虚妄邪道。于我法中而得出家。袈裟绕咽。常乐往来白衣居家。当知是人与外道无异。亦以我法多为众人恭敬供养。持世。我说是见五阴者。决定说五阴者。贪着五阴者。不听受人一杯之水。所以者何。是人于我法中。乃至无有柔顺法忍。是人违逆我法。背舍圣行。持世。是故菩萨摩诃萨于后恶世。应如是发大誓愿。于我如是甚深经典当共护持。亦断众生五阴见故而为说法

持世。我是经中说破一切阴相离贪着阴相。尔时多有在家出家闻如是等经。起于诤讼不生实相。菩萨摩诃萨于此中应发大誓愿。我等于后恶世贪着五阴邪见众生作大利益。所谓度脱贪着见五阴众生。随宜方便以法利益。是故持世。菩萨摩诃萨若欲得善知诸法实相。亦善分别诸法章句。欲得念力。欲得转身成就不断念。乃至得阿耨多罗三藐三菩提。应常观是五阴无常相。苦相。无我相。虚妄相。不坚牢相。毕竟空相。从本已来不生相。常正观时五受阴中。所有欲染则能除断。亦得如是等深法中方便。持世。过去无量阿僧祇劫。尔时有佛名大意山王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。持世。是大意山王佛。有八十亿那由他声闻众。皆是阿罗汉诸漏已尽。及八十亿那由他学地阿那含。谓菩萨摩诃萨众四十亿那由他。是大意山王佛寿八万岁。持世。尔时有王名为德益。是德益王有二万大城。具足丰乐人民充满。其城七重纵广十二由旬。四宝合成有七重堑。皆有栏楯七重行树。诸宝罗网遍覆其上。城堑诸树及上罗网。皆以黄金琉璃车渠马瑙四宝合成。一一大城各有五百园林。皆有七宝衣树充满其中。一一园林各有五百宝池。八功德水皆满其中。持世。是德益王有八万婇女。其大夫人有二子。一名无量意。二名无量力。持世。是二王子各年十六。梦中见佛端正无比如阎浮檀金幢。见大欢喜。觉已各说偈曰。其一人言

  我今梦见二足尊　　金色百福相庄严
  成就无量诸功德　　见已心得大欢喜

第二人言

  我梦见佛明如日　　端正姝妙第一尊
  犹如须弥众山王　　巍巍高显见欢喜

持世。即时无量意无量力二子。诣父母所具说是事。白父母言。今我二人于梦中见佛。惟愿父母。当听我等俱诣佛所。佛久出世我等放逸不能觉知。没五欲泥。为色缚所缚。为受想行识缚所缚。我等在家。以放逸故。不能见佛。持世。是二王子为父母说是事已。即诣大意山王佛所。到已头面礼佛足。请佛及僧三月四事供养衣服饮食卧具医药。于大城边庄严德益王所游园林。悬缯幡盖宝华覆地。奉佛及僧令止其中。其二王子三月之中。以一切乐具供佛及僧。供养已毕。于佛法中俱共出家。持世。其大意山王佛知此二王子深心所愿。而为广说是五阴十二入十八性菩萨方便经。于四万岁中终不睡眠。常不满腹食亦不倾卧。若坐若经行。又于四万岁中不念余事。但念五受阴虚妄空相。知是五受阴从颠倒起。通达是五受阴相毕。其年寿常修梵行。命终即生兜率天上。于佛灭后。还生阎浮提大居士家。至年十六复梦见佛。为说五阴十八性菩萨从方便经。闻是法已即觉惊怖。复于佛法。满万岁中常修梵行。亦复方便深观五阴十二入十八性菩萨所行方便经。命终生于忉利天上。毕天之寿。生阎浮提大姓婆罗门家。大意山王佛法末后千岁之中。其二人以本因缘故。复得出家学问广博其智如海。亦善观察选择是五阴性。入法如实通了。于其世中教化二万人及二十亿天于阿耨多罗三藐三菩提。持世。是二菩萨从是已后。世世同心共值十亿那由他佛。然后乃得无生法忍。得法忍已。复值一亿那由他佛。然后得阿耨多罗三藐三菩提。二人共劫次第作佛。一名无量音。二名无量光。持世。是故菩萨摩诃萨。若欲疾得阿耨多罗三藐三菩提。当于是清净无染法中。勤行修集此阴入性。及余有为法中说实知见相

    持世经十八性品第三

持世。何谓菩萨摩诃萨善知十八性。菩萨摩诃萨方便正观十八性。作是念。眼性眼性中不可得。是眼性无我无我所。无常无坚自性空故。眼性中眼性不可得故。眼性虚妄无所有。从忆想分别起。眼性无有决定相。虚空性是眼性。譬如虚空无决定相。无根本故眼性亦如是。无决定相亦无根本故。何以故。眼性中实事不可得故。眼性无处无方。不在内不在外不在中间。眼性无决定相以无事故。眼性事不可得。众因缘生故。眼性不过去不未来不现在。眼性眼相不可得。眼性但以先业果报。属现在缘故数名眼性。眼性者即是无性。眼性中眼性不可得。识行处故数名眼性

若眼根清净。色在可见处意根相应。以三事因缘合。说名为眼性。眼性中无决定眼性相。智者通达无眼性是眼性性

持世。菩萨摩诃萨若能如是观察选择眼性。即通达无性是色性。何以故。色性中色性不可得。是色性不合不散。色无决定相故说名色性。色无根本无分别何况色性。色性则是亦无根本。色性不在色内不在色外不在中间。但以忆想分别。色在可见处。眼根清净。以意识相应。见现在色故。数名色性。譬如镜中面像。若镜明净则生色相。镜中色无决定相。镜中无人而见色像。但以外有镜内起色相。如是眼性清净所缘之色。在可见处。如镜中像数名色性。色无性相无形性。无决定性是名色性。诸色相无我故。数名色性。随众生所知故。说名色性。若菩萨知是色性。即知无性是色性。无生性是色性。无作性是色性。何以故。是色性不过去不未来不现在示无所有性。示虚妄性。示假名性。名为色性。如是观察选择色性。是菩萨正观察选择眼识性。所谓眼识中无眼识。无眼识性无有常性。眼识性无有根本。无决定法。眼识性无所示。是眼识性非合非散无有根本。但以先业因缘起。属现在缘系色缘故数名眼识性。随凡夫颠倒心故。数名眼识性。贤圣通达眼识性即是非性。何以故。眼识性无决定故。从众因缘生。属诸因缘故数名眼识性。识所行处是眼识性。是识无决定故。说无决定相。无生故。示虚妄故。能分别色相故。能示缘故。说是眼识性。随众生所知。如来方便分别。破坏和合一相故。说是十八性示识无决定相。但眼清净能知色相。二法和合故说眼识性。示眼识实相故说眼识性。眼识性者示眼所行处。能识色是眼识。性即是说无性。何以故。智者眼识性中。求眼识性相不可得。眼识性中。亦不得眼识性根本。所以者何。无决定性是眼识性。眼识性者以假名说。所说性者即是说不取义。能有所见处是眼识。意业起是眼识相。故名为眼识。眼性色性眼识性。以是性门。说三事和合。以知诸缘相故。即是离诸性义。所谓是眼性。是色性。是眼识性。有如是数。得令众生入于实道。此中实无眼性色性眼识性。诸如来说是知见诸性相方便。分别说是诸性。若人通达是诸性方便者。则知三性无性。何以故。诸性中无性相故。诸性中相不可得故。耳性声性耳识性。鼻性香性鼻识性。舌性味性舌识性。身性触性身识性。皆亦如是

持世。何谓菩萨摩诃萨观择意性。菩萨作是念。意性无决定。根本无所有故。意性中无意性无决定性。是意性。譬如诸种子种于大地。因于水润。得日得风。渐渐芽出。芽不从种子出。种子亦不与芽和合。芽生则种子坏。种子不离芽。芽不离种子。芽中无种子。意性亦如是。能起意业故。示意识故。如种示芽。得名意性。离意性则无意。意性不能知意。假名字故说为意性。是意性不在意内不在意外不在中间。但以先业因缘故起。识是意业故。知所缘故。诸性名字合故。现在缘起故。数名意性。即是不决定意业相。即是众缘和合相。亦说意性从和合起随众生所知。于第一义中无有意性。何以故。根本无所有故。无生是意性。生无所有故。意性即是世俗语。第一义中决定无意性。过去未来现在不可得。智者通达无性是意性。诸菩萨观择法性。无性是法性。法性无自性。自性不可得。无决定性是法性。法性根本不可得故。决定事亦不可得故。但为起颠倒众生虚妄结缚。有所知故。说言法性。欲令众生入无性故。故说是法性。何以故。法性中无法性相。是法性从众缘生。众缘生法即无自性。诸因缘中无有自性。诸因缘皆从众缘和合颠倒故相续而生。如来于此欲教化众生说是法性。以世俗语言示无性法。是法性不在内不在外不在中间。但令众生知见善不善法。以法性说离一切法相。知见毕竟空相故。说毕竟空即是法性。何以故。无所有是法性。法性中无决定有相。譬如虚空无决定相而数名虚空。法性亦如是无决定相。破法相故说名法性。法性即是无性。何以故。是法性不在过去不在未来不在现在。但属众缘与缘合故。数名法性说名法性。如众生所知故。智者证知无性是法性。法性非合非散。法性中无法性相无多无少。以示性方便故。说法性名为性。若行者实通达是法性相。即知见无性。是三界法性中无分别相。众因缘和合故。分别诸法故。说是法性。示无决定性是法性。智者非以法性相故见法性。法性是无生相。何以故。法性中无有相。智者通达无相是法性。法性中无分别相。无相无分别故。说名法性。法性中无有住处。无处无起无住无依止。是法性从本已来不生故。是法性无有生者。何以故。法性中无性故。又法性不以合故有。无合无散。无作无决定。名为法性。菩萨摩诃萨观择法性如是。所谓无性是法性

持世。何谓菩萨摩诃萨观择意识性。菩萨摩诃萨作是念。不生性是意识性。不决定性是意识性。意识性无根本。无有定法。以意识性示无性相。何以故。意识性中。意识性不可得。是意识性虚妄无所有。颠倒相应以意为首。识诸法故名为意识。随凡夫所行故。说意识性。贤圣观知非性是意识性。虚妄无所有是意识性。但示因缘法故。以意为首故。识诸缘合故说为意识性。随众生所知故如是说。智者知非性是意识性。从众因缘生。忆想分别起。无有性相。即是第一义中无性相义。世俗法中为引导众生故。说是意识性。欲令众生知无性是意识性。但以小法坏离诸性故。说是意识性。何以故。圣人求之不可得。意识性不在意识性内。不在意识性外。不在中间。智者通达不合性是意识。意识不知意性。意性不知意识。但众因缘生。从颠倒起。以意为首。知于诸缘二事和合故。着虚妄故从觉观起。示众生识相故。说名意识性。是意识不在过去不在未来不在现在。是意识无所从来亦无所去无有住处。从本已来不生相。意识中无根本定法。何以故。是意识性相即是无二相即是无相。是相不以二相故有。无所示性是意识性。智者通达意识性。是意识性。不在一切法中无处无方。不与法若合若散。圣人通达不生相是意识性。是意识性无来无去无缘。何以故。第一义中意识性无缘。不可得不可示故。智者通达意识性。是不作是意识性。作者不可得故。无生是意识性。生相无所有故。持世。菩萨摩诃萨如是观择意识性。诸菩萨作是观时。观择欲界色界无色界皆是无生性无所有性。云何为观。所谓欲界中无欲界。色界中无色界。无色界中无无色界。以界示无界法。为取欲界相者示是欲界。为取色界相者示是色界。为取无色界相者示是无色界。以界寄说无界。如智者所知。无所有界是欲界色界无色界。智者不得欲界色界无色界。是三界皆无根本无有定法。从众缘起是故智者知见无界是三界。此中无有界相。是三界皆虚妄合颠倒行。何以故。智者不得三界。不说三界若过去若未来若现在。贤圣通达是三界虚妄无所有。无自性离诸法。但是颠倒起。为断众生颠倒故。知见三界故。如来分别说三界相。欲令众生知无界义故。说三界非以性相有。智者知见三界相是无界相。持世。菩萨摩诃萨如是观时。观众生性我性即是虚空性无所有性无生性。何以故。众生性我性虚空性无别无异。如是诸性皆虚空出。但从众缘生故名之为性。此中决定无性相。何以故。虚空中无一定性相。是诸性相皆入虚空。是无所有义。譬如虚空无性。是法毕竟离相无所有相。一切诸性亦如是离性相。诸性中无性相。性相不在内不在外不在中间。性中无有性。性中不摄性。性不依止性。一切性无所依止。一切性不生。智者于诸性中。不得生性。不得灭性。不得住性。一切诸性。不生不起不住。从本已来不可得。智者不贪不着诸性假名。不受不念。是故智者。通达知见一切诸性皆是无生相。若是无生相即无有灭。第一义中一切诸性不可得。世俗法故分别说诸性。第一义中不说诸性。智者知见通达一切诸性如第一义。持世。菩萨摩诃萨如是观择通达十八性及三界众生性我性虚空性。诸菩萨如是观择通达时。不得性不见性。亦通达一切诸性假名字。亦信解诸入一切性是无性。亦知分别诸性。以世俗故分别说诸性。令一切诸性入第一义中。亦善通达无性方便。亦为众生分别说诸性。亦令众生善住诸性。以世俗语言为众生说无性法。亦不以二相示诸性虽知一切诸性无二亦以方便说诸性从因缘起。虽以世俗言说引导众生。而示众生第一义。虽善知分别诸性。而信解通达一切诸性无所有何以故。持世如来以第一义故。于性无所得。亦不得诸性相。持世。我于诸性无所断无所坏。得阿耨多罗三藐三菩提。何以故第一义中无诸性。一切诸性无所有无决定。一切性同虚空。一切性入虚空。一切性无生相。如来通达一切性如是持世。如来不说诸性相。亦不说诸法力势。何以故。若法无所有。不应更说无所有性相。持世。如来亦说无所有性相。此中实无所说性相。持世。是名善分别诸性。菩萨摩诃萨得是善分别。能知一切诸性假名。能知世俗相能知第一义相能知诸性决定。能知世谛能分别诸相。能知随宜能知诸相合。能知诸相旨趣。能知诸相所入。能分别诸相。能知诸相无性。能令一切诸性同虚空性。亦于诸性不作差别。于诸性中不得差别不说差别亦为众生善说破坏诸性。持世。譬如工幻师能示众生种种幻事。令知种种幻相。若有知识亲友。语言是幻。说幻实事。是幻虚妄。示颠倒众生。若有智者则知是幻。持世。世间性如幻。诸菩萨摩诃萨入此幻法中。知世间是幻性。世间所行如幻。是人以方便力。示众生世间如幻。若有知此世间如实相。为说世间虚妄如幻。若有深智利根不开示之自能得知。知诸法空如幻无实无有根本。知一切法皆诳凡夫。一切法皆系虚妄缘中。持世。是故诸菩萨摩诃萨若欲入如是诸性方便。于如是等深经无染无得。说一切诸性知见相。说一切诸性无文字无和合。亦说诸性方便智慧。亦说因缘所作旨趣。亦说一切诸法如实相。所谓世间出世间。有为无为系不系。善知方便旨趣。说第一义世俗义了义经未了义经。种种因缘解说。于是甚深经中。应勤精进

持世经卷第二持世经卷第三

        姚秦龟兹三藏鸠摩罗什译

    持世经十二入品第四

佛告持世。何谓菩萨摩诃萨善知十二入。菩萨摩诃萨正观择十二入时作是念。眼中眼入不可得。眼中眼入无决定。又眼入根本不可得。何以故。眼入从众缘生颠倒起。以缘色故系在于色。二法合故有。因色有眼入。因色说眼入。二法相依故说名眼色。所谓眼色。色是眼入门与缘故。眼是色入门与见故。是故说入。以色缘故说眼入。以眼见故说色入。但以世谛故说。其实眼不依色色不依眼。眼不依眼色不依色。但从众缘起。色作缘故说名眼入。又从众因缘起。眼所知见相故。说名色入。云何为说。随世俗颠倒法故说。第一义中眼入不可得。色入不可得。智者求诸入。不见有实入。但以凡夫颠倒相应。以二相说是眼入是色入。是眼入是色入。即示虚妄入。欲令众生如实知诸法实相故。说是诸入皆从众因缘生颠倒相应行。此中诸入实相不可得。何以故。若眼入若色入。不在内不在外不在中间。眼入色入。亦非过去。非未来非现在。但现在因缘知色故说眼入如凡夫所行。智者通达诸入皆是虚妄无所有。从忆想颠倒分别起。知见非入是入。不说诸入性。诸入无决定相。但以众因缘生故说。如来说是诸入知见相。所谓是诸入虚妄无所有。属诸因缘颠倒相应行。诸入无有作者。无使作者。眼入不知不分别色入。色入亦不知不分别眼入。二俱离相。若法离相。此中不可分别。说是入相皆从因缘生。如凡夫颠倒。如贤圣所通达。是眼入色入。无生无灭。不来不去相。眼不知眼眼不分别眼。色不知色色不分别色。何以故。二俱空故二皆离故。眼不知眼性。色亦不知色性。眼色皆无性无法。此中无一决定相。眼不自作。眼亦不自知。色亦不自作。色亦不自知。二俱无所有故。眼不作是念我是眼。色亦不作是念我是色。眼色性如幻性。以虚妄假名故。说是眼是色。诸菩萨摩诃萨。观择眼入色入如是。耳声鼻香舌味身触亦如是

持世。何谓菩萨摩诃萨观择意入。菩萨摩诃萨观择意入时作是念。意入中意入不可得。意无决定入相。意入无根本。何以故。意入即是众因缘生。从颠倒起。系法入缘。二法和合能有所作。是意入因法入起。因法入可分别说。是二相依。意是法入处。意是法入门。法入是意入门。是故说名法入。缘法入门故说是意入。示意相门故说是法入。以世谛故说。其实意不依法法不依意。因缘生故以诸法为缘故说意入。因缘生故示意相故说法入。随世谛颠倒故说。第一义中意入不可得。法入亦不可得。智者求诸入不见有实。但凡夫颠倒相应。以二相说是意入是法入。是意入法入虚妄无所有。如来如实通达故示是诸入。如是诸入从因缘生。颠倒相应行。此中意入法入实不可得。又意入法入不在内不在外不在中间。又意入非过去非未来非现在。但能觉现在因缘故。说意入法入。随凡夫心故说。智者通达是意入法入虚妄无所有。从忆想颠倒分别起。非入是入。何以故。诸入中无决定入相。智者通达是诸入虚妄无所有。意入法入自性不可得。亦不得是意入法入所起实相。是意入法入但因缘生。如来说是诸入知见相。是诸入虚妄无所有。颠倒相应行属诸因缘。意入法入无有作者。无使作者。意入不知不分别法入。法入亦不知不分别意入。何以故。二俱离故。若法离相此中无可分别。是诸入皆从因缘生。随凡夫颠倒心故说。如贤圣所通达。意入法入不生不灭不来不去。意入不知意不分别意。法入不知法。不分别法。二俱空故二俱离故。意不知意性。法不知法性。是二性无所有。此中无一决定法。意不能成意。不能坏意。法不能成法不能坏法。二俱无所有故。意入不作是念我是意入。法入不作是念我是法入是二俱空皆如幻相。但假名字故分别说。菩萨摩诃萨观择意入法入如是。持世。何谓菩萨摩诃萨正观择内六入。外六入。所谓是十二入皆虚妄。从众缘生颠倒相应。以二相故有内外用。凡夫不闻真法。不知十二入如实相故。贪着眼入。我是眼入。我所是眼入。贪着色入。我是色入我所是色入。耳声鼻香舌味身触意法亦如是。我是意入我所是意入。我是法入我所是法入。以食着故为十二入所缚。驰走往来五道生死不知出道。菩萨摩诃萨于此中正观十二入时。见是十二入虚诳不牢坚。空如幻相。不贪着眼入若我若我所。乃至不贪着法入若我若我所。以不贪着故。不忆念分别。菩萨如是善知十二入。持世。菩萨摩诃萨得如是诸入方便。于一切十二入中。不系不缚亦证诸入。而能分别诸入。亦以众缘生法。通达十二入。亦以无相相。坏十二入。亦不堕是诸入所依道中。亦知诸入性则是无性。亦知诸入方便究竟到边。持世。譬如机关出水四面俱洒。十二入亦如是。内外因缘能有所作。此中实事不可得。是十二入先业机关所系故能有所作。持世。所谓入者。是诸凡夫。无知见者烦恼所入门。眼是色门。以生爱恚故。色是眼门。以生爱恚故。耳鼻舌身意是法门。以生爱恚故。法是意门。以生爱恚故。如是十二入。与爱恚共合故不知实相。持世。菩萨摩诃萨于此中善知诸入性。知是诸入实相故。不为爱恚所制。持世。菩萨摩诃萨善知诸入如是

    持世经十二因缘品第五

持世。何谓菩萨摩诃萨善观择十二因缘。菩萨摩诃萨观择十二因缘。所谓无有故说名无明。于无明中无法故说名无明。不知明故说名无明。云何不知明。不知无明决定法不可得。是名无明。何以故。说无明因缘诸行。诸行无所有。而凡夫起作故。说无明因缘诸行。从行起故有识生。是故说诸行因缘识。名色二相。是故说识因缘名色从名色生六入。是故说名色因缘六入从六入生触。是故说六入因缘触从触生受。是故说触因缘受从受生爱。是故说受因缘爱从爱生取。是故说爱因缘取从取生有。是故说取因缘有从有生生。是故说有因缘生从生有老死忧悲苦恼聚集。是故说生因缘老死忧悲苦恼聚集。如是大苦恼聚。于此中为集何法。但知颠倒与明相违。无明聚为后身爱。依止喜染求处处生。则是爱集。持世。世间如是为十二因缘所系缚。盲无眼故。入无明网堕黑闇中。无明为首故。具足起十二因缘。诸菩萨如是思惟观无明实相。知无明空故本际不可得何以故。无明无故本际无。智者观非际是本际。则不分别本际。断忆想分别故。不贪着无明。知一切法无所有。是法不尔如所说。若说一切法无所有。即是说知见不明。能通达一切法无所有。是为即得明。于此中更无余明。但知见无明是名为明。云何为知见无明。所谓一切法无所有。一切法无所得。一切法虚妄颠倒。一切法不尔如所说。是名知见无明。知见无明即为是明。何以故。明无所有故

无明因缘诸行者诸法无所有。凡夫入无明闇冥中。狂惑作诸行业。是行业无形无处是无明不能生行业。无法而起作故。说无明因缘诸行业。诸行业无有聚集。若是处若彼处来诸行业。亦非过去亦非未来亦非现在。无明无明性空。行业行业性空。诸行业无所依。但依无明起诸行业。诸行业不依无明。无明不依行业。无明不知无明。行业不知行业。如是无明诸行业。以颠倒故从无明生。此中不得无明。不得诸行业。不得无明性。不得诸行业性。但以闇冥数名闇冥。以是无明闇冥故。分别说行业。从无所有法而起作故。无明行业皆无所有

行业因缘识者。识不依行业。亦不离行业生识。行业亦不生识。何以故。行业不知行业。行业亦无持来者。但颠倒众生从行业生识。是识不在行业内。不在行业外。亦不在中间。是识无有生者。亦无使生者。但缘行业相续不断故有识生。智者求识相不可得。亦不得识生。识亦不知识。识亦不见识。识不依识。识因缘名色者。名色不依识。亦不离识生名色。是名色亦不从识中来但缘识故。凡夫闇冥贪著名色。识亦不至名色。智者于此求名色。不可得不可见。是名色无形无方。从忆想分别起。是名色相识因缘故有。识性尚不可得。何况从识缘生名色。若决定得是名色性者无有是处

名色因缘六入者。是六入因名色起名在身中故有出入息。利益身及心心数法。是六入皆虚诳无所有。从分别起有颠倒用

六入因缘触者。是触依色而有触不触色。何以故。色无所知与草木瓦石无异。但从六入起故分别说触。何以故。六入尚虚妄无所有。何况从六入生触。触空无所有。从忆想颠倒起。是触无方无处。触空以无触性故。触不知六入。六入亦不知触

触因缘受者。是受不在触内不在触外。不在中间。是触亦不余处持受来。而从触起受。是触尚虚妄无所有。何况从触生受。诸受无一决定相。诸受皆无所有。从颠倒起有颠倒用

受因缘爱者。是受不于余处持爱来。受亦不与爱合。受亦不知爱不分别爱。爱亦不知受不分别受。爱不与受合。是爱亦不依受。亦不离受有爱。受中尚无受相。何况受因缘生爱。爱不在受内不在受外不在中间。爱亦不在爱内亦不在爱外亦不在中间。爱中爱相不可得。是爱但从虚妄忆想颠倒相应故名为爱。是爱非过去未来现在。是爱非以缚相故起。是爱亦非缚相。但以因缘相续不断故。说受因缘爱。智者知见是爱无处无方。空无牢坚。虚妄无所有。爱因缘取者。爱不于余处持取来。爱不与取合。爱亦不能生取。有爱故说名取。随因缘和合故说。取不与爱合亦不散。爱不与取合亦不散。取不在爱内不在爱外亦不在中间。爱尚无有何况爱因缘生取。诸取决定相不可得。智者知见是取虚妄无所有。取中无取相。是取非过去未来现在。取不在取内不在取外不在中间。是取但从颠倒起因。本缘生。今众缘故有取。无有法若合若散。是取无有根本。无一定法可得。凡夫受是虚妄取。是诸行皆虚妄故。世间为取所系缚。智者通达是取虚妄空无牢坚。无有根本。无一定法可得。取因缘有者。是取不持有来。是取不能生有。而说取因缘有。是有不在取内不在取外不在中间。有不依止取。取不与有合亦不散。但以众缘和合故。说取因缘有。取不能生有。取不分别有。取尚虚妄无所有。何况从取因缘生有。有无有持来者。有中有不可得。有不在内有不在外有不在中间。是有非过去未来现在。智者通达是有虚妄。颠倒相应无合无散。有无所知无所分别。是有无处无方。是有无前际无后际无中际。是有非有故非无故。但随顺十二因缘故说是有。智者通达有相空无牢坚。有因缘生者。是有不持生来。生亦不与有合亦不散。是生不在有内不在有外不在中间。有不能生生。亦不离有有生。但示十二因缘相续。说有因缘生。有与生非缘非不缘。有尚不可得。何况从有生生。智者通达是生不依于有生。生中无生相。生中无自性。生中无根本。无一定法可得。智者通达是生无性无所有。但示十二因缘和合相续。故说有因缘生。生无有法若合若散。生不在有内不在有外亦不在中间。是生非过去非未来非现在。是生前际后际中际不可得。是生根本不可得。智者通达从众因缘生颠倒相应虚妄无所有如幻化相

生因缘老死忧悲苦恼者。是生不持老死忧悲苦恼来。生亦不能生老死忧悲苦恼。老死忧悲苦恼。不在生内不在生外不在中间。老死忧悲苦恼。亦不依生。以生故老死忧悲苦恼可说。但示众因缘生法故。生不与老死忧悲。苦恼合亦不散。生中生尚不可得。何况生因缘老死苦恼。老死苦恼中老死苦恼不可得。何以故。老死苦恼不在老死苦恼内。亦不在外亦不在中间。老死苦恼非过去非未来非现在。老死苦恼不与老死合亦不散。但颠倒相应众缘和合。具足十二因缘。故说生因缘老死苦恼。老死苦恼无所依止。老死苦恼决定相不可得。老死苦恼前际后际中际不可得。智者通达老死苦恼虚妄无所有颠倒相应无有根本不作不起不生。如是观十二因缘法。不见因缘法。若过去若未来若现在。亦不见因缘相。但知因缘是无缘。无生无相无作无起无根本。从本已来。一切法无所有故。通达是十二因缘。亦见是十二因缘无有作者受者。若法所从因生。是因无故是法亦无。菩萨随无明义故。一切法不可得。入如是观中。无缘即是十二因缘。此中无所生。菩萨观十二因缘是虚妄生。随顺无明义。通达十二因缘。若法无者是法亦无。是故说随顺无明义。通达十二因缘无明是不生不作不起无根本无一定法无缘无所有。菩萨尔时不分别是明是无明。无明实相即是明。因无明故一切法无所有。一切法无缘无忆想分别。是故随顺无明义。通达十二因缘。持世。是名菩萨摩诃萨十二因缘方便智慧。若菩萨能如是通达十二因缘合散。是名菩萨善得无生智慧。何以故。以生灭观则不能善知十二因缘。若观十二因缘集散。是名得无生智慧。若得无生智慧。是名通达十二因缘。持世。是故菩萨摩诃萨欲入通达欲证无生智慧。应当如是勤行修集是十二因缘智慧。则能观证十二因缘无生相。持世。若菩萨摩诃萨知无生即是十二因缘者。即能得如是十二因缘方便。是人以无生相知见三界。疾得无生法忍。当知是菩萨于诸现在佛得近受阿耨多罗三藐三菩提记。是菩萨不久当得受记次第受记。持世。如是善人因与受记得安隐心。于一切法旨趣方便中。得智慧光明。是人通达十二因缘是无生。是人得近现在诸佛。是人于诸恶魔无所怖畏。是人度生死流得到陆地。是人得度无明淤泥。是人得到安隐之处。持世。若我今世若我灭后。若闻若信若读诵若修习是十二因缘方便者。我与是人授记不久当得无生法忍。我亦记是人不久当于现在诸佛所。得受阿耨多罗三藐三菩提记

    持世经四念处品第六

佛告持世。何谓菩萨摩诃萨善知四念处。菩萨摩诃萨观择四念处。顺身观身。顺受观受。顺心观心。顺法观法。何谓为顺身观身。顺受心法观受心法。持世。菩萨摩诃萨顺身观身时如实观身相。所谓是身无常苦如病如疮。苦恼忧衰动坏之相。是身不净可恶恶露。身中种种充满其内。九疮孔中常流臭秽。身之不净犹如行厕。如是正观身时。不得是身一毫清净无不可恶者。知是身骨体筋缠。皮肉所裹。从本业因缘果报所起集取所缚。何等为集。何等为取。从先因缘起是身。是名为取。今以沐浴饮食衣被床卧被辱医药。是名为集。如是现在因缘为集取所缚。本业果报力故有用。又是身四大所造无决定实。色阴所摄数名为身。何故说名为身。能有所作故。说名为身。贪着依止处故。说名为身。随意有用故。说名为身。从忆想分别起故。说名为身。假合作故说名为身。与业合故说名为身。是身不久终归坏败。无常无定变异之相。是身不在身内。不在身外。不在中间。是身不知身。亦不见身。是身无作无动无有愿求。亦无有心。与草木瓦石等无有异。身中无有决定身相。如是正观择身。知是无有作者。亦无使作者。是身无前际无后际无中际。是身无一常定坚牢之相。如水沫聚不可撮摩。是身八万虫之所住处。是身百种诸病之所侵恼。以三苦故是身为苦。无有救者。所谓行苦坏苦苦苦。是身众苦之器。如是正观身时又复思惟。是身非我非彼。不得自在不得随意。作是不作是。是身无根本。无一定法可得。是身性空无一决定相。是身虚妄所起。系于机关作法。从本业因缘起。不应于身中生我我所想。我等不应惜身寿命。菩萨如是观时。不得身若合若散。不见有所从来。去有所至有所住处。不分别是身若过去若未来若现在。则不依止身命。不贪惜身若我若我所。常离身受。是菩萨观身空无我无我所。是身中我我所不可得故。是身相不可得。是菩萨若不得身相。即不愿身入。身不起作道。云何为入。是身无有作者无有起者。是身不作不起相。从众因缘生。是因缘能和合身。而是因缘亦虚诳无所有。颠倒相应空无牢坚。亦以是因缘故是身得生。是因缘亦无生无相。如是观身即入身无生相中。入已观身无相。以无相相观身。知是身无相。相不可得故无生。是身过去相未来相现在相不可得。何以故。是身无根本。无一定法可得。是身若此若彼不可得。如是观时。知身无所从来亦无所去。即入身不生不灭道。持世。菩萨摩诃萨如是愿身观身入如实相。于身欲染则能除断。疾令其念。正住身中。是名顺身观身。持世。何谓菩萨摩诃萨顺受观受。菩萨摩诃萨观苦受乐受不苦不乐受。见是三受。无所从来亦无所去。但虚妄缘合。本业果报所持颠倒相应。知诸受虚妄从忆想分别起。菩萨如是观诸受。不得过去受。不得未来受。不得现在受。是菩萨见过去诸受空。无我无我所。无常无牢坚。无不变异相。如是观是过去诸受空相。寂灭相无相相。观未来诸受空。无我无我所。无常无牢无坚。无不变异相。观未来诸受空相。寂灭相无相相。是菩萨如是观时作是念。诸受无决定相。无有根本无一定法。不相似故。新新生灭无有住时。菩萨作是念。是诸受无作亦无作者。但凡夫颠倒相应心中。起三种受属本业因。今世缘合故有是诸受。是诸受皆空无有牢固。虚妄之法犹如空拳。如是观受。心住一处。菩萨尔时得通达诸受集没灭相。见诸受不合不散。又受中不见受。作是念诸受空性空故。即通达诸受无生相。此诸受无生无灭无有成相。是诸受皆无相无成相。如是思惟。受诸受时皆能不着。如实知见诸受相。离诸所受。于此诸受亦无所依。于诸受中心皆放舍。则疾得舍三昧。持世。菩萨摩诃萨如是顺受观受

持世。何谓菩萨摩诃萨顺心观心。菩萨摩诃萨观心生灭住异相。如是观时作是念。是心无所从来亦无所去。但识缘相故生。无有根本无一定法可得。是心无来无去。无住异可得。是心非过去未来现在。是心识缘故从忆念起。是心不在内不在外不在中间。是心无一生相。是心无性无定。无有生者无使生者。起杂业故说名为心。能识杂缘故说名为心。念念生灭相续不断故。说名为心。但令众生通达心缘相故。心中无心相。是心从本已来。不生不起性常清净。客尘烦恼染故有分别。心不知心亦不见心。何以故。是心空性自空故。根本无所有故。是心无一定法。定法不可得故。是心无法若合若散。是心前际不可得。后际不可得。中际不可得。是心无形无能见者。心不自见。不知自性。但凡夫颠倒相应。以虚妄缘识相故起。是心空无我无我所。无常无牢无坚。无不变异相。如是思惟。得顺心念处。是人尔时不分别是心是非心。但善知心无生相。通达是心无生性。何以故。心无决定性。亦无决定相。智者通达是心无生无相。尔时如实观心生集没灭相。如是观时。不得心若集相若灭相。不复分别心灭不灭。而能得心真清净相。菩萨以是清净心。客尘所不能恼。何以故。菩萨见知心清净相。亦知众生心清净相。作是念。心垢故众生垢。心净故众生净。如是思惟时。不得心垢相。不得心净相。但知是心常清净相。持世。菩萨摩诃萨如是顺心观心

持世。何谓菩萨摩诃萨顺法观法。菩萨观一切法。不见内不见外不见中间。亦不得诸法若过去若未来若现在。但知诸法从众缘生颠倒起。诸法无有决定相。所谓是诸法属是人。诸法本体于诸法中无诸法。诸法不在诸法内。不在诸法外。不在中间。诸法不与诸法合亦不散。一切法无根本无一定相。诸法无所有故不动不作。一切法如虚空无所有故。一切法虚诳如幻。幻相无所有故。一切法常净相俱不污故。一切法是不受相。诸受无所有故。一切法如梦。梦性无所有故。一切法无形。形无所有故。一切法如像。性常无故。一切法无名无相。名相无所有故。一切法如响。虚妄所作无所有故。一切法无性。性不可得故。一切法如焰。知无所有故。菩萨如是观一切法时。不见诸法若一相若异相。亦不见法与法若合若散。亦不见法依止于法。如是观时。见一切法无所从来。亦不见一切法住处。何以故。一切法无住无依无起。一切法无住处。住处无所有故。住处不可得故。持世。诸法无有差别。一切法无分别相。从众生颠倒故有用。是诸法无处无方。智者得诸法。非一相。非二相。非异相。何以故。持世。一切法不生不作不起。无能作者。一切法离根本。一切法无自性。过诸性故。一切法无归处。诸归处无所有故。如是观诸法。善知诸法无我无人。观择诸法性空。是诸法皆空。性自空故。诸法无相不见相故。于诸法中不起愿。即时观择一切法无生。作是念。此中实无有法若生若灭。如是观时心住一处。尔时便得通达一切法无生。亦知见一切法集尽灭。亦能入一切法离相离性。何以故。持世。一切法无决定性。智者通达诸法无相离相。持世。菩萨摩诃萨顺法观法。如是观者。于法无所得无所受。于法不为生不为住不为灭。故行而见一切法尽灭相寂灭相。持世。是名菩萨摩诃萨善观四念处。何故说名念处。念处者。即是一切法无处。无起处无所有处。能如是入一切法则念不乱。名为念处。又念处。是一切法不住不生不取。如实知见处。名为念处

    持世经五根品第七

持世。何谓菩萨摩诃萨善知诸根。菩萨摩诃萨正观出世间五根。何等五。所谓信根。精进根。念根。定根。慧根。菩萨修习五根时。信一切法皆从众因缘生。颠倒所起虚妄缘合。似如火轮又如梦性。信一切法无常苦不净无我。如病如疮无有坚牢。虚伪不实败坏之相。又信一切法虚妄无所有。犹如空拳如虹杂色诳于小儿。忆想分别假借而有。无有本体无一定法。又信一切法。非过去非未来非现在。信一切法无所从来亦无所去。信一切法空无相无作。信一切法无生无作无起无相离诸相。而信持戒清净。禅定清净。智慧清净。解脱清净。解脱知见清净。菩萨如是成就信根得不退转。以信为首故能信持戒。是信常不退不失。成就不退法安住不动。信中常随业果报成就信人。断一切邪见。不离法。求师但以诸佛为师。常随诸法实相知僧行正道。住清净戒成就忍辱。得如是不动不坏信增上信故。名为成就信根

持世。何谓菩萨摩诃萨正观精进根。成就精进根善知精进根。菩萨摩诃萨行精进不休不息。常欲除五盖故勤行精进。乃至为听如是等深法。名为精进。是菩萨求法不休不息精进不退。亦欲断诸障碍法故。勤行精进而不怯弱。亦为断种种恶不善衰恼法故勤行精进。又为增长种种善法故勤行精进。是菩萨决定成就精进。不贪着是精进。而入是平等精进。成就不退精进。是人为正方便。通达一切法故发行精进。于精进中不随他人。于精进中得智慧明成不退相。能得如是不退精进增上精进故。得名成就精进根

持世。何谓菩萨摩诃萨能得念根。善修习念根。菩萨摩诃萨常摄念一处。布施柔和具足梵行。持毕竟清净戒众定众慧众解脱众解脱知见众。常思念净身口意业。常思念究竟其事。常思念一切法生灭住异相方便。常思念知见苦集灭道谛。常思念诸根力觉道禅定解脱诸三昧方便。常思念一切法不生不灭不作不起不可说相。常思念欲得无生智慧。常思念欲得具足忍智。常思念离智灭智。常思念欲得具足佛法。常思念不使声闻辟支佛法入心。常思念无碍智慧。常不忘不失不退是念。入如是观中而不随他。是人得如是坚牢增上念故。名为成就念根

持世。何谓菩萨摩诃萨能得定根。能得定根方便。菩萨摩诃萨于圣地中。常行禅定。不依禅定。不贪禅定。善取禅定相。善得禅定方便解善生禅定。亦能行无缘禅定。悉知诸禅定门。善知入禅定。善知住禅定。善知起禅定。而于禅定无所依止。善知所缘相。善知缘真相。亦不贪受禅味。于诸定中自在游戏而不随他。亦不随禅生。于诸定中得自在力。于诸定中不以为难不以为少。随意所欲。是人得如是增上禅定故。名得定根。得定根方便。持世。何谓菩萨摩诃萨成就慧根。得慧根方便。菩萨摩诃萨能成就通达慧根。所谓能正灭诸苦。是人成就是通达慧。处处所用皆得离观舍观。成就随涅槃智慧。成就是慧根故。善知三界皆悉炽然。善知三界皆是苦。以是智慧不处三界。是人观择三界一切皆空。皆无相无愿。无生无作无起。见出一切有为法道。为具足诸佛法故。勤行精进如救头然。是菩萨智慧无能沮坏。以是通达智慧能出三界。亦不依止三界事。断一切有为法中喜。一切可染可着系缚法中心不贪嗜。于诸五欲心皆厌离。心亦不住色无色界。成就增上智慧。成就无量功德犹如大海。以是智慧于一切法方便中无有疑难。是人以是智慧。通达三界。于三界中心无所系。得是增上慧故。说名度慧根。得慧根方便。持世。何故名之为根。增上义故说名为根。不动义故说名为根。无能坏故说名为根。无能退故说名为根。不随他故说名为根。不退转故说名为根。无能牵故说名为根。随顺正法故说名为根。不贪着故说名为根。不杂故说名为根。又持世。菩萨摩诃萨善知众生诸根。亦能善学分别诸根。菩萨知染欲众生诸根。知离染欲众生诸根。知嗔恚众生诸根。知离嗔恚众生诸根。知愚痴众生诸根。知离愚痴众生诸根。知欲堕恶道众生诸根。知欲生人中众生诸根。知欲生天上众生诸根。知软心众生诸根。知上众生知中众生知下众生诸根。知坏败不坏败众生诸根。知勤修不勤修众生诸根。知巧不巧众生诸根。知有罪无罪有垢无垢。知嗔碍不嗔碍。知随顺不随顺。知障碍不障碍众生诸根。知欲界行。知色界无色界行众生诸根。知厚善根薄善根。知毕定不毕定邪定众生诸根。知悭贪离悭贪。知戏调不戏调。知狂惑不狂惑。知轻躁不轻躁。知嗔恚不忍。知柔软能忍。知深厚悭。知具足施众生诸根。知信者。知不信者。知恭敬者。知不恭敬者。知具足持戒。知清净持戒。知具足忍辱。知懈怠知精进。知散心知得定。知无智慧知有智慧。知闇钝知不闇钝。知增上慢。知不增上慢。知行正道。知行邪道。知妄念。知得念安慧。知散根知摄根。知坏根不坏根。知净根不净根。知明根。知发小乘根。知发辟支佛乘根。知诸菩萨根。知发佛乘根。是菩萨得度如是诸根分别方便。于如是等众生分别诸根智慧中方便。不随他故。说名得诸根方便。亦名不为他所牵。亦名不可破坏。亦名不退转。亦名得方便力。亦名得人根。亦名得诸天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等根。亦名得最自在。亦名得不坏不动。亦名到彼岸者。成就如是功德者。于一切法中。疾得自在力

持世经卷第三持世经卷第四

        姚秦龟兹三藏鸠摩罗什译

    持世经八圣道分品第八

持世。何谓菩萨摩诃萨善能知道。菩萨摩诃萨安住道中。何等为道。所谓八圣道分。正见。正思惟。正语。正业。正命。正精进。正念。正定。持世。何谓菩萨摩诃萨名为行八圣道分。何谓名为得八圣道分方便。菩萨摩诃萨得正见安住正见。为断一切见故行道。为断一切诸见故安住于道。乃至断涅槃见佛见。何以故。持世。一切诸见皆名为邪。乃至涅槃见佛见。破坏一切贪着诸见故。名为正见。又无诸见无取诸见。不念不贪着不缘不行不分别一切诸见。是名正见。以是正见为见何等。见一切世间虚妄颠倒为诸见所缚。如是见时。名为安住断一切见。于是正见亦不念不见不贪着分别乃至涅槃见佛见。为不起一切见故行。云何名为正见。一切法寂灭。念相不生不灭同于涅槃。如是亦不念不分别是一切法。不念不分别不现在前。不正不邪不取不舍。是名出世间正见。何故名为出世间正见。是人不得世间。不得出世间。度世间已无所分别。是故名为出世间正见。正见者如知见世间。出世间亦如是。是人不复分别是世间是出世间。断诸忆想分别。名为出世间正见。是人不见邪不见正断一切心所念。名为正见。又正见者。于诸法中更无差别。是故说名正见。又正见者。如实知诸邪见义。又正见者。观诸邪见即是平等。是名菩萨摩诃萨安住正见

持世。菩萨摩诃萨住正见中。如实知正思惟。作是念。一切思惟皆为是邪。乃至涅槃思惟佛思惟。皆是邪思惟。何以故。断诸分别名为正思惟。无所分别名为正分别。断分别是正分别。何以故。是人知见一切思惟相已则无有邪。是人更不分别是此是彼。住如是正分别中。更不得诸分别若正若邪。如是之人离诸分别。过诸分别故说名正思惟。正思惟者。即是分别知见一切分别皆虚诳不实从颠倒起。诸分别中无有分别。是人安住正思惟。更不得分别若正若邪。离诸分别过诸分别。断诸分别故说名正分别。是人尔时于一切分别中无所系缚。知见诸分别性皆平等故。是名安住正思惟

持世。菩萨摩诃萨勤集正语。是人见一切语言虚妄不实从颠倒起。但忆想分别从众因缘有。作是念。是语言相语言中不可得。灭一切语如实知一切口业。名为正语。是语言无所从来亦无所去。能如是见者。名为正语。是人尔时安住实相中。有所语言皆是正语。是故说安住正语中。是人得住第一清净口业。亦知见诸口业相。亦通达一切语言。是人所说终不有邪。是故说名住于正语

持世。菩萨摩诃萨善知一切语业皆是邪业。知一切诸业虚妄无所有不作不起。何以故。诸业中无一决定。灭一切业名为正业。正业者。于业不分别若正若邪。入诸业平等故。不分别业若正若邪。是故说名正业。又正业者。则是不系三界义。如实知见义。如实平等中。更无分别是正是邪。菩萨行如是正业。如实知见一切业故。如实于法无取无舍。是故说名行正业。正业中无有邪业。是人如实知见故。说名住于正业中

持世。何谓菩萨摩诃萨善知一切诸命皆是邪命。何以故。若有命相法相取相。乃至涅槃相佛相。乃至清净佛法相。住于是中作清净命皆名邪命。正命者。舍诸资生所著断诸贩卖。不分别不戏论。过一切戏论。是名正命。正命中更不分别是邪命是正命。即得一切清净命。是故说名得清净正命。又一切诸命皆不生无有邪正。是人名为得清净命。安住正道无有戏论。住是正命中。不取正命不舍邪命。是故说名住正命中。是人尔时不名住正不名住邪。得清净平等命。离于命相无动无作。不念命不念非命。但名为如实知者如实见者。是故说名住正命中

持世。何谓菩萨摩诃萨善知正精进。菩萨摩诃萨住正精进。若菩萨为断一切精进道故。名为住正精进。何以故。一切精进皆为是邪。诸有所发有作有行皆名为邪。何以故。一切法皆是邪作。有所发作皆是虚妄。若虚妄者即亦是邪。正精进者。无发无作无行无愿。一切法中断有所作。是菩萨于一切法中断有所作。乃至涅槃相佛相中不生有所作相。是人善知一切所作皆为虚妄。为无所作故行道。若是正者则无所作。一切法平等无差别。无有所作过所作相。是菩萨善知精进非是精进道。不取不舍故说名住正精进。正精进者。即是诸精进不可得义。即是诸法如实知见义。所谓正精进如是见者。不复分别是邪精进是正精进。是故说名正精进

持世。何谓菩萨摩诃萨善知正念。菩萨摩诃萨知见一切念皆是邪念。有所念处皆是邪念。何以故。一切念是邪念。若于处所念生皆是邪念。无忆无念是名正念。何以故。一切念从虚妄因缘起。是故有生念处皆为邪念。若于处所无生无灭是名正念。无有处所起念业。是名安住清净念中。无处生邪念。是人知见一切法皆为是邪。是正法中无念。是故说安住正念中。又正念者。于法无有分别是正念是邪念。是人通达一切念皆无念相。常行六舍心故说名住正念。是人更无所贪乐。亦不分别是无念。以诸法平等通达一切念。是人如实知见一切念故。若念若非念无取无舍。是故说安住正念中。是人所念更不分别是等是不等。于念非念不随不缘。以无缘故知一切念非念。若念若非念不复在心。是人安住正念故。不可说不可示。断一切语言。离一切语言。如实知一切语言。不分别此彼故。说名安住正念

持世。何谓菩萨摩诃萨安住正定。菩萨摩诃萨观一切定皆是邪定。何以故。凡诸法中。所取缘定相。所取知定相。所取三昧戏论定相皆名为邪。邪者即是贪着义。是定不尔。如所缘取相不取相。无求无戏论无忆念。名为正定。若不贪着不分别此彼。断贪着喜不受定味。坏取定相心无所住。是名正定。又正定者。不依止一切定中而不戏论。如实通达法之本体。善知定相心不贪着。欲破彼此念道。如是语亦不分别。断一切分别故。名为正定。又正定中更不生邪正想。破一切想断一切想。灭一切想故。名为正定。正定者。不生邪正不分别邪正。是名正定。何以故。是菩萨通达诸定方便住是正定中。不复为若定若定相所系。过诸定相故说名正定。正定名于法无所戏论。诸法平等中无有戏论。所谓是正是邪。正定者。即是诸法平等义。正定者。能出诸禅定三界一切有为法。能如实知见一切五道生死义。持世。是名诸菩萨摩诃萨住如是定中。名为得正定方便。名为善知道善知道方便。所谓如实知见能至涅槃道

    持世经世间出世间品第九

持世。何谓菩萨摩诃萨善知世间出世间法。何谓得世间出世间法方便。持世。菩萨摩诃萨正观世间出世间法。何等为世间法

菩萨作是念。凡所有法忆想分别。从颠倒起众因缘生。系虚妄缘从二相起。空无所有如虹杂色。亦如火轮诳于凡夫。破坏义故假名世间。是名世间。诸世间法皆非是实。从虚妄缘起不作不起相。但因阴界入色声香味触法故说。因名色故说。随凡夫人心所贪着。又随种种贪着邪见。如乱丝无绪。如茅根蔓草互相连着。随颠倒相应故说名世间法。何等为出世间法。如是世间法。从本已来如实性离。是名出世间。何以故。智者求世间法不可得。求出世间法不可得。无世间无出世间。处是中无分别是世间是出世间。但为世间故说出世间。世间实相即是出世间。何以故。世间无定相可得。世间相从本已来常空。世间法不决定故。世间从本已来是寂灭相。是菩萨如是观世间出世间。不可得世间。亦不贪着出世间。是人不念不着世间出世间故。不与世间诤讼。何以故。智者通达世间是虚妄相。见世间实相故。更不分别是世间是出世间。何以故。持世。世间者即是五受阴义。一切世间法皆摄在中。智者求阴不得阴。不得阴性不得阴来处。不得住处不得去处。无五阴十二入十八性。无分别无名字。无性无相无行。即名出世间

持世。菩萨观世间出世间法时。不见世间与出世间合。不见出世间离世间。是人不离世间见出世间。亦不离出世间见世间。是人不复缘于二行。所谓是世间是出世间。何以故。持世。世间如实相即是出世间。世间中世间相不可得。世间法中世间法不可得。以无所有故。通达是法即是出世间。持世。若世间与出世间异者。诸佛不出于世。诸佛亦不说一切世间不可得一切世间不生。如实知见一切世间。持世。若不得世间不取世间。即是出世间。是故当知。如实知见世间。通达世间不可得故。即说出世间。是故诸佛出于世间。一切诸法若世间若出世间。以不二不分别证如实知见故。即是说出世间法。持世。如是世间甚深难可得底。依世间法者。得世间法者。悕望出世间法者。于世俗语生第一义相者。住在二法者。不能得入如是法中。何以故。是人不知世间。不知出世间。是皆行二法者。持世。行二法者。不能通达世间出世间。持世。菩萨摩诃萨如是善知世间出世间法。亦得世间出世间法方便

    持世经有为无为法品第十

持世。何谓菩萨摩诃萨善知有为无为法得有为无为法方便。持世。菩萨摩诃萨正观择有为无为法。云何为正观择。是有为法无有作者无有受者。是有为法自生自堕数中。是故名有为法。是有为法以虚妄因缘和合行。云何为行自堕数中。以二相缘知故。名有为法生。是法无有作者无使作者。是法自生无能起作者。是故说名有为法。是诸有为法。不在内不在外不在中间。不合不散。从虚妄根本分别起。无明因缘故皆无所有。但以诸行力故有用。是法无有作者无有起者。是名有为。有为者即是系义。随凡夫颠倒所贪着说。智者通达不得有为法。不得有为所摄法。智者所不数故名有为法。何以故。诸智者不得有为分别。为凡夫世俗假名故。分别是有为。贤圣不随一切诸法名数。诸贤圣离诸法名数。是故说得无为者。名为贤圣。智者通达一切有为法皆是无为。是故不复起作诸业。智者知见一切有为法起相虚诳妄想。是故不复起作有为。何以故。有为法无有定性。一切有为法。皆无性无起作。何以故。持世。无有行有为缘而能通达无为。通达无为者。更不复缘有为。云何为通达。智者见一切有为法皆虚妄。无有根本无所系属。不堕数中。如是观时不复贪著有为缘。亦不取有为法。何以故。持世。非离有为得无为。非离无为得有为。有为如实相。即名无为。何以故。有为中无有为。无为中无无为。但为颠倒相应众生。令知见有为法故。分别说是有为法是无为法。是有为相是无为相。于是中何等为有为相。所谓生灭住异。何等为无为相。所谓无生无灭无住异。是有为相无为相。但为引导凡夫故说。持世。有为法无生相无灭相无住异相。是故说生灭住异相无相无生。若是有为法定有三相。佛当决定说。如是相是生。如是相是灭。如是相是住异。持世。如如来说一切法皆是无相。持世。无生若当有相。无灭若当有相。无住异若当有相。佛应决定说是无为相。持世。若无为有相有说即非无为。以说相故。但凡夫以数法故。说有为三相。所谓生灭住异。无为三相。所谓无生无灭无住异。持世。若人通达知见有为无为法。是人更不复有生灭住异。是故说得无为者。持世。生灭者。即是见集没义。若法无集则无有没。若不起集则不有退亦无住异。持世。是名有为如实知见。若人如实知见有为则不堕数中。所谓生灭住异。菩萨如是思惟有为无为法。不见有为法与无为法合。亦不见无为法与有为法合。但作是念。有为法如实相。即是无为。则更不复有所分别。若不分别有为无为法。即是无为法。若分别是有为是无为。则不能通达无为。断一切分别。是名通达无为。如实通达缘性断诸缘故。不在数不在非数。持世。是名菩萨摩诃萨有为无为法方便。所谓于诸法无所住无所系。亦不贪受若有为若无为法

    持世经本事品第十一

持世。若菩萨摩诃萨能如是善知五阴。善知十八性。善知十二入。善知十二因缘。善知四念处。善知五根。善知八圣道分。善知世间出世间法。善知有为无为法。当得善知诸法实相。亦善分别一切法文辞章句。亦得念力。以是念力转身成就不断念。乃至得阿耨多罗三藐三菩提

持世。过去无量阿僧祇劫。尔时有佛。号阎浮檀金须弥山王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。持世。是阎浮檀金须弥山王佛。寿命五劫。有无量声闻众。其佛国土清净严饰丰乐安隐。其诸众生具足快乐。少于贪欲嗔恚愚痴。易化易度易净。持世。是阎浮檀金须弥山王佛。为诸菩萨亦说是断众生疑菩萨藏经。持世。时有菩萨名曰宝光。闻是阴界入缘四念处五根八圣道分世间出世间有为无为法方便。即时发于精进。二十亿岁终不生恶心。若贪欲若嗔恚若愚痴。若利养若饮食若衣钵。但为入如是法方便门故。常勤精进。持世。是宝光菩萨。于阎浮檀金须弥山王佛所。尽其形寿常修梵行。命终之后还生其佛国土人中。年少命终即复还生于其佛所。修行梵行。于一一劫五百生死。最后生阎浮檀金须弥山王佛欲涅槃时。在第五劫成就如是多闻法。亦得如是诸法实相方便。所从佛闻诸法皆能忆念。得如是念力故。白佛言。听我广演诸法。即于其世中。度脱无量无边众生。令住阿耨多罗三藐三菩提道中。是阎浮檀金须弥山王佛。入涅槃时为持法故。护念宝光菩萨。佛灭度后法住一劫。是人于是一劫。五百世中常生人间出家学道。亦常于是诸法实相得自增长。亦复利益无量无边众生。持世。是宝光菩萨。如是展转得值万亿诸佛。末后无量光佛为其授记。过阿僧祇劫当得阿耨多罗三藐三菩提。于阿僧祇劫中更值百千万亿那由他诸佛。后得阿耨多罗三藐三菩提。成佛号一切义决定庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。有无量无边阿僧祇菩萨众无量声闻僧。佛寿二劫。其佛国土丰乐安隐普皆庄严。持世。是故菩萨若欲得如是法中善知方便。当勤行精进勤求。读诵修集如是之法。又复菩萨摩诃萨欲得如是诸法方便故。于四法中勤行精进。何等为四。一者出家。二者独行。三者持戒清净。四者除懈怠心。是为四。菩萨有是四法。勤求多闻安住忍辱。当疾得值遇四法。何等四。一者生中阎浮提。二者得值佛。三者随法行。四者除罪业障。是为四。又复持世。菩萨摩诃萨如是法中。应勤行精进当得清净布施力。清净持戒。清净忍辱。清净精进。清净禅定。清净智慧力。菩萨摩诃萨住是法中疾得如是方便力。又持世。菩萨摩诃萨虽行头陀细法。亦能常于众生有大悲心。是人入大悲心。于是法方便中勤行精进

持世。复有菩萨摩诃萨欲得如是法。当入诸陀罗尼门勤行精进。何谓为入陀罗尼门故勤行精进。所谓善观一切法无量缘。观一切法无量方便。亦观无量方便起。如是观时。以三昧门方便。善入诸法门无量缘。亦入无量方便。亦入无量方便起。于是法中得力故。善知诸法实相。亦善分别一切文辞章句。亦得念力。亦得转身成就不断念不退法。乃至得阿耨多罗三藐三菩提。又复持世。菩萨摩诃萨入诸陀罗尼门故。通达一切诸法随宜因缘。以一因缘能入千种因缘。随智慧力得诸法方便。又复持世。菩萨摩诃萨如是法中勤精进故。入一相门三昧。得一相门三昧故。入无量相门三昧。如是入已。以种种因缘方便故。能入是诸法门。如是诸菩萨入一切诸法门已。当得一切诸法方便。又复持世。菩萨摩诃萨多行智慧故。善知诸禅定相。亦善知无缘三昧。是三昧力故。能善知无量缘无量禅定起。是菩萨住此地中。能得一切诸法实相方便。又复持世。菩萨摩诃萨常观世间缘方便。常观有为法缘方便。常观世谛缘方便。亦常勤行坏散一切法缘方便。亦无贪着处。是菩萨修集如是法。疾得诸法实相方便。又复持世。菩萨摩诃萨勤行精进起方便力。而亦常观诸法实相。不依止世乐。亦不杂行世间之法。成就如是法者。疾得诸法实相。亦善分别一切法文辞章句。亦得念力亦得转身成就不断念。乃至得阿耨多罗三藐三菩提。持世。是故菩萨摩诃萨欲得度如是诸法彼岸。当于是法如说修行。持世。汝等于是法中勤行精进。汝等不久当于此法得无碍智慧。持世。过去无量无边不可思议阿僧祇劫。尔时有佛。号无量光德高王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是无量光德高王佛寿命一劫。其佛国土以七宝网罗覆其上。普以七宝诸多罗树庄严世界。是诸多罗树。亦复以七宝网罗覆其上。一一树下敷师子座。诸多罗树皆出天衣。诸座皆以琉璃宝阎浮檀金赤真珠所成。诸多罗树四边皆有香树华树围绕庄严。一一树下各各有池。八功德水充满其中。诸池皆以颇梨车磲赤真珠所成。诸池水上皆有青赤白红莲华遍覆水上。诸池皆以七宝为栏楯。持世。彼佛国土。皆以如是众宝庄严世界。四边复有宝树。如忉利天波利耶多罗迦持毗陀罗树。如是宝树千万亿数围绕世界。是诸宝树光明。障蔽一切日月光明不复现。持世。诸多罗树及诸宝网。自然皆出种种妙香。如天伎女歌颂之声。其佛国土常出如是微妙音声。无三恶道亦无三恶道名。持世。是无量光德高王佛。为诸众生多说如是之法。所谓般若波罗蜜。及菩萨藏断一切众生疑喜一切众生心经。持世。其无量光德高王佛说法时。一日之中无量百千万亿众生。发阿耨多罗三藐三菩提心。已发心者皆得具足助菩提法。持世。是无量光德高王佛。以是因缘教化成就无量无边众生于阿耨多罗三藐三菩提。其佛国土菩萨摩诃萨其数甚多。持世。彼佛灭后法住半劫。是无量光德高王佛。灭度之后法欲尽时。下方过十佛世界。有菩萨名无量意。命终来生始年十六。出家学道。于无量光德高王佛法欲灭时。闻是菩萨摩诃萨解说是阴界入方便经。是无量意菩萨。闻此经已发大精进。于是法中尽到其边。成就深方便力。是菩萨善根因缘故。于彼命终得值二十亿佛皆得成就如是之法。常识宿命。童真出家。修行梵行常得念力。世世不离如是之法。世世成就不断念。然后得成阿耨多罗三藐三菩提。号无量光庄严王佛。持世。是故菩萨摩诃萨若欲疾得阿耨多罗三藐三菩提。若欲疾得具足一切智慧于我灭后后五百岁恶世之中。当勤护持发大誓愿。应生大欲大精进大不放逸。于后世中常当护持如是等经

尔时跋陀婆罗伽罗诃达多菩萨等为上首。从坐而起向佛合掌。白佛言。世尊。我等于佛灭后后五百岁法欲灭时。我等当为守护如是等经。勤行精进读诵听受。亦当复为他人广说。复有若干千数菩萨。从坐而起合掌向佛。瞻仰尊颜发是愿言。世尊。我等后世后五百岁。作是誓愿。于如是等甚深无染污诸佛所。听能生菩萨诸善功德。能具足诸菩萨助菩提法。我等当共护持闻如是法。当大清净其心欢喜。专心勤求受持读诵。佛便微笑。即时三千大千世界无量光明遍满其中。三千大千世界六种震动。尔时阿难从坐而起偏袒右肩。右膝着地合掌白佛言。世尊。何因缘故。今者微笑地大震动。佛告阿难。汝见此等菩萨发大誓愿。后世护持如是甚深无染污法不。阿难。是诸菩萨非但今世发是誓愿。阿难。我念是诸菩萨于无量无边诸佛所。发如是誓愿。三时护持诸佛之法。亦能利益无量众生。今者亦复三时护持我法。于今现在及我灭后法欲灭时。亦大利益无量众生。持世。如跋陀婆罗等三时护持我法。亦复于此贤劫之中。三时护持诸佛之法。亦于未来诸佛所。三时护持如是之法。阿难。我今赞说是人。成就如是无量功德说不可尽。怜愍利益安隐众生。阿难。若我悉说是人如是功德。人不能信。若人不信佛语。是人长夜失于利益。受诸苦恼坠堕恶趣。阿难。我今粗说是等菩萨利益众生。假使如三千大千世界满中众生。皆堕大地狱中。中有一人语诸众生。汝等莫怖。我今一一代汝受此大地狱苦。是人即时出地狱众生。一一皆为多千万岁受地狱苦。阿难。于汝意云何。是人为大利益大安乐不。阿难言。世尊。为大利益大安乐。阿难。是人出诸众生已。现其力势。皆使令得成就世间第一快乐。阿难。是人为能有恩能与众生乐不。阿难言世尊。是人所利益非言所说。阿难。我今实说是跋陀婆罗加罗诃达多菩萨等利益众生。是人利益众生。是二利益安乐之事。算数譬喻不可为比。何以故。阿难。是人乐具皆是有为相违之法。不为厌足故。不为离欲故。不为智慧故。不为沙门果故。不为涅槃故。阿难。是诸菩萨等。利益众生与无上乐。一切智人乐为求佛道者。皆作佛事。未入正位者令得声闻辟支佛地。以佛法化诸菩萨示教利喜。阿难。是诸菩萨能示教利喜诸菩萨众。为不断佛种故。为守护一切智种故。住于世间。阿难。是人过去本行菩萨道时。无量百千万亿那由他劫。皆使有佛不令断绝。亦于未来无量百千万那由他劫。皆使有佛亦不断绝。何以故。阿难。是诸菩萨本行菩萨道时。已令无量诸佛住于佛道。是诸菩萨世世护持教化成就百千万亿诸佛。皆使成阿耨多罗三藐三菩提。从是以后亦复教化无数百千万亿众生令住佛道。教化力故具足佛法。亦皆当得阿耨多罗三藐三菩提

阿难。是跋陀婆罗等。为与众生佛乐一切智慧乐故勤行精进。阿难。若人实说。何等是诸菩萨父母救舍依洲生。诸菩萨当说是跋陀婆罗伽罗诃达多等五百菩萨是。阿难。若人实问何等是诸菩萨种。当言跋陀婆罗伽罗诃达多等五百人是。如是善男子等。为不断佛种不断一切智慧种故。住于世间。是善男子等。亦于后世后五百岁。以是教化方便力故。以乐因缘令诸众生不堕三恶道中。亦令无量百千众生住菩萨乘。阿难。若干千佛说是善男子等功德不可得尽。何以故。是善男子等。成就如是不可思议功德。阿难。我于无量百千万亿阿僧祇劫所集法藏。是善男子等能受护持。阿难。我今以是无量亿劫所集法宝嘱累是人。是善男子等。为无量阿僧祇国土中现在诸佛之所护念。阿难。是善男子等。一切天人世间所应礼事。阿难。是人十方千佛。讲说法时常所赞叹。阿难我已印可。为断一切众生疑故。若人于后末世。受持是经读诵通利为人广说。当知是善男子善女人近一切种智。有人于后末世乃至得闻如是深经。信解而发誓愿我皆与受阿耨多罗三藐三菩提记。若于后世后五百岁。生信解心勤行精进护持是经。是善男子善女人。我今亦以是阿耨多罗三藐三菩提法而嘱累之。若声闻人信受如是深法。心无违逆我与受记。后当得值弥勒佛会。若求佛道者。闻如是法受持信解。是人皆为弥勒佛所授记。以本愿故出家学道。阿难当知。是善男子善女人等。若于后世后五百岁时。于是法中勤行精进。当知是人善根猛利

    持世经嘱累品第十二

尔时持世菩萨摩诃萨白佛言。世尊。惟愿利益诸菩萨摩诃萨故。护念是经。菩萨摩诃萨若于后世得闻是法心净喜乐。亦为具足如是法故。勤行精进。尔时世尊护念是经。即以神力令此三千大千世界香气遍满。所未曾有。一切众生慈心相向。佛护念已告持世菩萨。持世。我今护念是法印品经断一切疑故。持世。若有能受持读诵是经者。不久当得一切智慧。惟除本愿。我今亦与是人受记。疾得具足一切智慧故。持世。菩萨摩诃萨若受持读诵是法印品经。思惟广为人说。是人不久当疾得五阴方便十二入十八界十二因缘四念处五根八圣道分。世间出世间法有为无为法方便。亦疾得诸法实相。亦疾得分别一切法章句。亦疾得念力亦疾得转身成就不断念。乃至得阿耨多罗三藐三菩提。持世。是经后世能与众生。作大法明大智慧光福德因缘。亦能与诸菩萨。具足助阿耨多罗三藐三菩提法。持世。若诸菩萨于后末世时。得值是经及余深经。菩萨藏所摄与诸波罗蜜相应。是人不为魔事所覆。不为业障所恼。持世。若是人未得无生法忍者。我与受记。于当来世第二第三佛。当得无生法忍。已得无生法忍者。于一切法中疾得自在力。疾得净佛国土。疾得无量声闻众。疾得无量菩萨众。持世。我今说是法印为断后世一切疑故。持世。菩萨摩诃萨见四利故。于后末世护持如是等经而发誓愿。何等为四。诸菩萨作是念。我当疾得无量无边功德。亦令众生生大善根。亦为诸佛护持正法。亦作诸佛持法藏人。亦为无量诸佛所见赞叹。是名四。持世菩萨摩诃萨复见四利。于后末世护持是经而发誓愿。何等为四。诸菩萨作是念。我等于后恐怖恶世守护法故。行大精进。于后恶世正法坏时。能持法藏为此难事。于后恶世中法乱众生乱时。我等守护法故其心不乱。尔时当得具足忍辱。以无嗔道守护于法。是名四。持世。菩萨摩诃萨见是四利故。于后恶世。护持如是等深经而发誓愿。跋陀婆罗伽罗诃达多等五百菩萨。及余菩萨得闻是法印品经。佛前合掌。于后恶世发愿护持是深法者。佛以右手皆摩其头。作如是言。诸善男子。我于无量阿僧祇劫所集阿耨多罗三藐三菩提大法宝藏甚为难集。受诸无量无边忧悲苦恼。亦舍无量无边欢喜快乐。今以嘱累汝等。于后末世当以是无量劫所集法藏善开与人。广为四众分别解说此正法种令不断绝。汝等还当然大法炬。诸善男子。如来今者。请汝等佛子住佛所住。我于是无量百千万亿阿僧祇劫所集法宝藏。为诸天人广宣流布。即时跋陀婆罗伽罗诃达多等。即礼佛足作如是言。我等随力所能亦承佛威神。当于后世广宣流布是法宝藏。说是法印品经时。无量无边阿僧祇一生诸菩萨。善根成就。亦有无量百千万亿众生。发阿耨多罗三藐三菩提心。毕定受阿耨多罗三藐三菩提记。佛说是经已。持世菩萨及跋陀婆罗伽罗诃达多等。及余菩萨并诸四众。一切天人阿修罗等。闻佛所说皆大欢喜

持世经卷第四


除持入经

    No. 603

除持入经卷上

        后汉安息国三藏安世高译

佛经所[衛-韋+正]。亦教诫。皆在三部为合[衛-韋+正]。何等为三。一为五阴。二为六本。三为所入。五阴为何等。一为色。二为痛。三为想。四为[衛-韋+正]。五为识是为五阴。色阴名为十现色入。十现色入为何等。一眼。二色。三耳。四声。五鼻。六香。七舌。八味。九身。十乐。是为十现色入。是名为色种。痛种为何等。痛种为身六痛。一眼知痛。二耳知痛。三鼻知痛。四舌知痛。五身知痛。六心知痛。是为身六痛。名为痛种。思想种为何等。思想种为身六思想。一色想。二声想三香想。四味想。五更想。六法想。是为身六思想。名为思想种。行种为何等。[衛-韋+正]种名为身六更。一色所更二声所更。三香所更。四味所更。五触所更。六法所更。是为身六更。是名为行种。识种为何等。识种名为身六识。眼识耳识鼻识舌识身识心识。是为身六识。是名为识种。名为五阴种。当知。是是从何知。为非常苦空非身。从是知亦有二知。一为慧知。二为断知。从慧知为何等。为非常苦空非身。是为从慧知。从断知为何等。爱欲已断是为从断知。阴貌为何等。积为阴貌。足为阴貌。譬如物种名为物种。木种名为木种。火种名为火种。水种名为水种。一切五阴亦如是。有十八本持。十八本持为何等。一眼二色三识。四耳。五声。六识。七鼻。八香。九识。十舌。十一味。十二识。十三身。十四更。十五识。十六心。十七法。十八识。是名为十八本持。已知是从何知为非常苦空非身。是为知。从是知亦有二知。一为从慧知。二为从已断知。从慧知为何等。为非常苦空非身。是为从慧知。从断知为何等。爱欲已断是为从断知。彼为具足。具足为何等。或言无有余具足。已无有余。令眼明见明。一[衛-韋+正]者。说是已为断眼本耳本。遍说如是。为本持。譬是人为多热如是名遍。譬喻是为具足。亦有十二入。何等为十二。自身六外有六。自身六为何等。一为眼。耳鼻舌身心。是为自身六入。外有六为何等。色声香味更法。是为十二入。一切从何知。为非常苦空非身。是从是知。亦有二知。一从慧知。二从断知。从慧解知为何等。为非常苦空非身。是为从慧知。从断知为何等。爱欲已断是为从断知。何等为入。解从是致名为入。从入解。譬从金入名为金地。从银入名为银地。如是各各应是譬喻所从所入。是从是有。如是从所意念。有行罪苦法如是。从所致。是名为从是入。亦有从是入。譬如王有入所有名。是亦如是。为有四谛苦习尽道。苦名为要语。身亦念。习名为要。痴亦所世间爱。尽名为要。慧亦解脱。道名为要止亦观。亦有三十七品经法。四意止。四意断。四神足。五根。五力。七觉意。贤者八种道[衛-韋+正]。是为三十七品经法。过去佛亦有是。现在佛亦有是。未来佛亦有是。辟支佛亦从是得度世道。佛弟子亦从是。是为度世无为道。四意止为何等。或见比丘自身身身相观行止。外身身身相观[衛-韋+正]止。内外身身身相观行止。尽意念以却世间痴心。不便。自痛痛痛相观[衛-韋+正]止。外痛痛痛相观[衛-韋+正]止。内外痛痛痛相观[衛-韋+正]止。尽意念。以却世间痴心。不便。自意意意相观[衛-韋+正]止。外意意意相观[衛-韋+正]止。内外意意意相观[衛-韋+正]止。尽意念。以却世间痴心。不便。自法法法相观[衛-韋+正]止。外法法法观[衛-韋+正]止。内外法法法相观[衛-韋+正]止。尽意念。以却世间痴。不便

何等为从四意正断。或比丘有未生弊恶。意法发方便令不生。劝意不舍方便[衛-韋+正]。精进摄制意。舍散恶意。是为一断意。已生弊恶意发。清净法欲断。劝意求方便[衛-韋+正]。精进摄制意。舍散恶意。是为二断意。未生清净法。劝意发方便令生[衛-韋+正]。精进摄制意。舍散恶意。是为三断意。已生清净法。令止不忘令不减。令[衛-韋+正]不啻令[衛-韋+正]足。发方便[衛-韋+正]。精进摄制意。舍散恶意。是为四意正断。何等为四神足。或有比丘。为欲定断生死。随[衛-韋+正]增神足。恶生死猗。却欲猗尽猗。是为一神足精进定。断生死。随[衛-韋+正]增神足。恶生死猗。却欲猗尽猗。从不便。意生遣离去。是为二神足。意定断生死。随[衛-韋+正]增神足。恶生死猗。却欲猗尽猗。从不便。意生遣离去。是为三神足。戒定断生死。随[衛-韋+正]增神足。恶生死猗。却欲猗尽猗。从不便。意生遣离去。是为四神足。四意止四意断四神足。为已说具

何等为五根。信根精进根念根定根慧根。是名为五根。彼根应何义根为根义。属为根义。可喜为根义。不为同事为根义。是名为根义。何等为五力。信力精进力念力定力慧力。是名为五力。彼力应何义。无有能得坏为力义。有所益为力义。有胆为力义。能得依为力义。是名为力义。有七觉意。何等为七觉意。一念觉意。二法分别观觉意。三精进觉意。四爱可觉意。五猗觉意。六定觉意。七护觉意。是名为七觉意

有得道者八种道[衛-韋+正]。何等为八。一直见。二直[衛-韋+正]。三直语。四直治。五直利。六直方便。七直意。八直定。是名为八道[衛-韋+正]。八种道[衛-韋+正]为堕合三种。一戒种。二定种。三慧种。彼所直语直业直治。是名为戒种。彼所直方便直念直定。是名为定种。彼所直见直[衛-韋+正]。是名为慧种。皆从是教诫。令不啻教诫。令不啻教意。令不啻慧教诫。彼戒种比丘。为拔嗔恚亦[卄/惡]本。为散嗔恚结。为合恚疮。为识苦痛。为度欲界。彼定种比丘。为拔悭[卄/惡]本。为散欲结。为合欲疮。为知乐痛。为度色界

彼慧种比丘。为拔痴[卄/惡]本。为散痴结为合憍慢疮。为知不乐不苦痛。为得度无有色界。是为三种。比丘止为拔三[卄/惡]本。散三[卄/惡]使。合四疮。知三痛。度三界

何等为十二种。从求如求等生。从痴因缘令有[衛-韋+正]。从[衛-韋+正]令有识。从识令有名字。从名字令有六入。从六入令有致。从致令有痛痒。从痛痒令有爱。从爱令有受。从受令后有。从有令有生。从生令有老死忧悲苦。不可心致[病-丙+(止/(止*止))]。如是具足苦种。为致习。痴已尽便[衛-韋+正]尽。已[衛-韋+正]尽便识尽。已识尽便名字尽。已名字尽便六入尽。已六入尽便致尽。已致尽便痛痒尽。已痛痒尽便爱尽。已爱尽便受尽。已受尽便有尽。已有尽便生尽。已生尽便老死尽。已老死尽。忧悲苦不可心[病-丙+(止/(止*止))]便尽。如是具足苦种便得尽。彼痴名为不知四谛如有。不解不见。不相应不受。不解不解根。是名为痴。彼痴因缘[衛-韋+正]为何等。为六望受。何等为六。色声香味触法。是为身六望受。是名为[衛-韋+正]

彼[衛-韋+正]因缘识为六身识。眼耳鼻舌身心。是名为六身识

彼识因缘名字。字为色名为四不色阴。痛想[衛-韋+正]识是为名。色为四大本。谓地水火风是。上为名。是四为色。是二相连共为名字。彼名字因缘身六入受。眼耳鼻舌身心。是名身六入受。彼六入因缘身六思望。眼耳鼻舌身心。是名为身六思望

彼思望因缘身六痛。眼耳鼻舌身心。是名为身六痛

彼痛因缘六身爱。色爱声爱香爱味爱触爱法爱。是名为六身爱。彼爱因缘受为四受。一欲受。二见结受。三戒愿受。四身结[衛-韋+正]受。是名为四受

彼受因缘有为三有。一欲界。二色界。三无色界。是名为三有。彼有因缘生。为上五阴六持六入。己有如有。生聚。已往堕致分别根。已入得有。是名为生死。为何等名为人人所在。在所往。已往坏已过。死时是命亦根已闭塞是为死。上本为老。后要为死。是故名为老死

痴相为何等。为冥中见冥。如有不解。令从是致堕行相处。[衛-韋+正]相为何等。为令后复有是为[衛-韋+正]相。上从是发起。令从是致堕识处。识相为何等。为识物识事是为识相。令从是致堕名字处。名字相为何等。为俱猗。是为名字相。令从是致堕六入处。六入相为何等。为分别根是为六入相。令从是致堕思望处。思望相为何等。为相会更生。是为思望相。令从是致堕痛处。痛相为何等。为更觉是为痛相。令从是致堕爱处。爱相为何等。为发往是为爱相。令从是致堕受处。受相为何等。为受持是为受相。令从是致堕有处。有相为何等。令堕若干处。是为有相。令从是致堕生处。生相为何等。为已有五阴是为生相。令从是致堕老处。老相为何等。为转熟是为老相。令从是致堕死处。死相为何等。为命根尽。是为死相。令从是致堕苦处。苦相为何等。为身急是为苦相。令从是致堕不可处。不可相为何等。为心意急。是为不可相。令干从是致堕悒悒忧。悒悒相为何等。为忧五阴。令从是致堕愁[病-丙+(止/(止*止))]处。悲愁相为何等。口出声言。令致悲[病-丙+(止/(止*止))]懑。懑为[病-丙+(止/(止*止))][病-丙+(止/(止*止))]亦为懑

九绝处。为一切[卄/惡][衛-韋+正]令部伴。从流行。为有二本从有结罪。为三[卄/惡]本。亦有四倒。彼二本罪[病-丙+(止/(止*止))]为何等。一为痴。二为堕。有爱名为二本。三[卄/惡]本为何等。一为贪欲。二为嗔恚。三为痴惑。是名为三[卄/惡]本。有四倒。四倒为何等。非常念常。是为思想倒。为意倒。为见倒。是为一倒。计苦为乐。非身为身。不净为净。思想意见倒如上说。是名为四倒。彼痴名为不解四谛。不慧。不见。不相应。不解受为[卄/惡]。是为痴。彼有爱为何等。为所世间欲发往不舍。是为有爱。是名为二本。彼欲贪本为何等。为所在所种贪。为奇珍宝。为奇财产。为奇严事。为有嫉在奇。贪可贪欲。可往爱相。爱哀相。往不舍。是为贪[卄/惡]本。是本为谁。为所有贪。为身非法[衛-韋+正]。口非法[衛-韋+正]。心非法行。亦余俱相连。[卄/惡]种所作。意念是法本。是故名为贪[卄/惡]本。彼嗔恚非法本为何等。为在人为在[衛-韋+正]。恚相恚。不忍不识。因缘嗔嗔恚发评谆。念不可。说不可。所念说不好令意却。是为恚非法本。是本为谁。为非法本。所身罪。所言罪。所心罪。亦余所相连意念。为是法本。是故为嗔。名为非法本。彼痴惑非法本为何等。不知四贤者谛如有。不解不见。不相应不解受非法。或随或受。或在或不识。或痴冥在冥。蔽覆令冥令无眼。令慧坏。知尽不能致无为度世。是痴惑非法[衛-韋+正]本。是本为谁。为惑非法。身[衛-韋+正]作。口[衛-韋+正]作。心[衛-韋+正]作。亦所共相助非法。意所念非法本。是名为惑非法本

彼当知。倒亦当知。所倒当知。从所倒当知是

彼有一倒。从一倒为四倒。从所有为三倒。何等为一倒。为对或受。非常为常。苦为乐。非身为身。不净为净。是为一倒。何等为四倒。所有身痛意法。是为四倒。何等为三倒。一为想。二为意。三为见。是为三倒使。彼所可意根相连着。若色若像为受想。是为欲想。以为有欲想。相随久不断。在意念是。为欲念种。若彼所想分别受。是名为想倒。彼惑意不如有受。所从不应受解。是名为意倒。所以受不舍在意。念在色。不净意计净。听可意念已快所见受往。是名为见倒。彼所见已为相分别。应当为十二倒。何等为十二。在身有三。在痛有三。在意有三。在法有三。有四想倒。意倒亦有四。见倒亦有四。亦为在入因缘相会色。令为十二倒。身三痛三意三法。三合为十二倒。为如是六。为七十二倒。从本得因缘。起随因缘。多少无有量。不可数在人无有数无有数倒。彼五阴为四身有。从所有色阴。是属身。从有痛阴是属痛身。从有识阴是属意身。从有想阴亦[衛-韋+正]阴。是属法身。从有是五阴。令受四身因缘有

彼身不净计净。是为身倒。彼痛苦计为乐。是为痛倒。彼意非常计为常。是为意倒。彼法不为身计为身。是为法倒。为欲正四倒故。佛为现四意止为说分别

彼为身身相观[衛-韋+正]止。为不净意念净倒得解。彼为痛痛相观为苦计为乐倒。得解彼为意意相观。非常计为常倒得解彼。为法法相观非身计为身倒得解彼。冥中冥如有不解是为痴相。令堕所倒处。欲得往是为爱相。令从是受色为身。故令欺奇。是为贪相。令堕不与取。所可不如意是为恚相。令堕杀处。为不解事。是为痴惑相令受邪堕邪处。为作彼所[衛-韋+正]法不却受相。是为令堕有常想不知身。躯。物。为更相会相。令计乐想为堕身处。为不解。所法相为有身想。令堕。是为是我所处为堕。受色像相令计是为净想。令从是堕不摄守根处。是为九品为已分别为一切不可[衛-韋+正]非法伴已说。竟是多闻者能解。不多闻者。卒不解。是为慧人能解。不慧卒不解。是[衛-韋+正]者能解。不随行不解。有九绝处。令一切净法部堕聚合。何等为九。一止二观三不贪四不恚五不痴六非常七为苦八非身九不净。是为九。彼止名为意止。在处能止已止正止摄止不失止。不志心寂然一一向念是名为止。何等为观。观名为了阴。为了持。为了入。了名字。了从本生。了从本法已生。了苦了习了尽了道[衛-韋+正]。了从善[卄/惡]从是法生。了增复增。了白黑。了是可随。不可随。如有分别。为拖。不拖。为下。复下。为念。复念。为思观。为识。为慧。为眼。为谋。为满。为解。为慧。为明。为欲。为光。为敢不离。为观法。为觉意。为直见。为道种。是名为观。亦有若干二辈观。一为净观。二为不净观。三为清净观。四为不清净观。五为黑观。六为白观。七为可[衛-韋+正]观。八为不可[衛-韋+正]观。九为罪[衛-韋+正]观。十为殃福观。十一为缚观。十二为解脱观。十三为有所益观。十四为失无所益观。十五为往观。十六为还观。十七为受罪观。十八为除罪观。是故名为观。亦为二因缘令有是说止。为一切天下人有二病。何等为二。一为痴。二为爱。是二病故佛现二药。何等为二。一为止。二为观。若用二药为愈二病。令自证。贪爱欲不复贪。念意得解脱。痴已解令从慧得解脱

阴持入经卷上阴持入经卷下

        后汉安息国三藏安世高译

彼爱欲药为何等。为止。爱已解意。亦解意已解病便愈。彼痴药为何等。为观。痴已却解。从慧解脱为病愈。如是佛说。如是二法。当知一为字。二为色。二法当舍。一为痴。二为爱

二法当自知。一为慧。二为解脱。二法可[衛-韋+正]。一为止。二为观

彼止已行令识色。已识令爱得舍。爱已解意。便得解脱。自证知。止已行满足便得舍痴。已得舍痴。便从慧得解脱。自证知。若比丘已二法自知字亦色。已二法舍痴亦爱。如是齐是便无所著。应行毕。欲度世。是为尚有余无为未度。已无为竟。命已竟毕。便为苦尽。令后无苦。彼以有是阴。亦持亦入。已尽止寂然。从后无阴亦持亦入。无相连不复起。是为无余。已得度世无为。毕是为二无为种。彼不贪清净本为何等。为三界中不得不望不求。是名为不贪清净本。是本为谁。为不贪身清净言清净。亦余相连清净法意所念为本。是为不贪清净本。亦有清净本。佛说为八种行。是清净本。彼为三清净道种。是为不贪本。何等为三。一为直方便治。二为直念。三为直定。是为三清净道种本。是故名为不贪清净本。彼无恚不犯法本为何等。若忍所[衛-韋+正]。未来为不出恚忍因缘。为不恚不恚不受殃。无恚无嗔亦不嗔。无怨亦不想怨。是为无恚不犯法本。是故名为无恚不犯法本

亦有三清净道种。一无恚不犯法本。为正语。二为正业。三为正致利。是为三清净道种。是故名为无恚不犯法本

彼不惑清净本为何等。为从慧见四谛如有如有应受清净。不愚不惑不随惑。亦不堕惑慧明明相见。从清净法。是为不惑清净本。是本为谁。为不惑清净。所身[衛-韋+正]。所言[衛-韋+正]。所心[衛-韋+正]。亦所相连清净法。为意思惟相念所法本。亦为从二清净道种。为不惑本。一为直见。二为直[衛-韋+正]。是为从二清净道种本。是故名为不惑清净本。是为三清净。为八种道。已份在所随应。非常为如是

彼非常想为何等。一切所[衛-韋+正]是非常想。所想计知是为受。是为非常想。亦从有世间八法。何等为八。有利。无利。名闻。不名闻。有论议。无论议。若苦。若乐。为意不堕不受。从若干思不受。止护观思恶得止。是名为非常想。彼苦想为何等。为一切世间行是为苦所想觉知受。是名为苦想。从是要为何等。望苦想为已习已增所念已多。为贪。已足。为不堕贪。为意不受不堕。相牵不堕。不念。若干意护观为已。恶为得止。从是思望致是要。彼非身想为何等。为一切法不计身不堕身。为想知想受。是名为非身想。从是为何等。望致非身想。已为念思。为已增。令是是自计我。为是为意不受舍若干态。不受跓为观。[病-丙+歲]恶得止

是为从是要致。彼恶不净想为何等。为一切世间[衛-韋+正]。为不净所想。自知受是名为不净想。从是想为何等。望致不净想已为念为思为已增。令世间五乐意却舍意。不牵不受不复堕。若干念以得护。为[病-丙+歲]恶得跓。是为从是要致。彼为四思想念行。何以故。令知五阴。故佛说是分别见彼不净想[衛-韋+正]。为令色阴从是解。彼苦想[衛-韋+正]令痛阴从是解。彼非身想[衛-韋+正]。令思想阴亦[衛-韋+正]阴。从是解

彼非常想[衛-韋+正]。令识阴从是解

彼从止[衛-韋+正]。令爱从是解。彼从观[衛-韋+正]令痴从是解。彼从不贪为舍贪

彼从不恚为舍恚

彼从不惑为舍痴

彼从非常想。令解有常

彼从苦想为解乐想

彼从非身想为解身想

彼从不净想

为解净想。彼从止摄意能得还。是为止想。令从是止禅。

彼从一切法。寂然能得解受。是为观想。令止跓一切知

从欲能得还想。是为不贪相。令还不与取止

已后不复生痴。是为无有恚想。令从杀还得止。识事亦物是为不惑相。为令得止止所世间所[衛-韋+正]为所法能受相。是为非常想。令知从生。亦知从灭。识为是处。为世间[衛-韋+正]。作世间更。所所识想是为苦。为所思想。是为痛种处。一切所法不住想。是为非身想。是为思想。是已见身尸已坏。青膖为受是相。是为不净思想。从是为悔。却令寂然。止是为九品处。已分别说见。为一切无为部。说具足是为谁。知多闻。少闻不为慧者。不慧不为常意在经。为意相连生。为从不分别观。令不得非常想。不受非常想。令从是堕五乐。令五乐覆盖。从所应[衛-韋+正]。失令不解苦想。令堕五阴受入。令为意计是身。若干本非一本。不舍不观令不堕非身想。为意在颜色。乐计是身为净。不计是皮肌覆。令不堕不净想。不住受。止。是想不信令无有想。不受喜。为从是四种已除。堕得无为种处。佛说信根比丘欲见知。当求在四沟港种为清净法。不舍方便相。令致清净。从清净发起令堕四意止

佛说精进根。比丘欲见知。当在四意断。过去所更。相念不忘。为从不忘发生堕四意止

佛说念根。比丘欲见知。当观在四意止。为一意想。是为定从不惑起。令堕四禅处

佛说是比丘欲知定根。当知在四禅。从本校计为慧。如有能得持。从是发起令堕四谛

佛说慧根。比丘欲见。当在四谛。为有四轮。好郡县居轮。依慧人轮。自本正愿轮。宿命有福轮。彼为道德共居相。是为好郡县居。令得贤者依止处。以得道德依猗相。是为依慧人。从是为堕有正愿处。以得正愿相。是为身正愿。令堕福处。从清净行有所入相。是名为福。令致堕五乐处

彼为戒法十一本。一为色持戒无悔。二为已不悔令得喜意。三为已有喜令爱生。四为已意得爱为身得猗。五为已身得猗便得乐。六为已意得乐。便得正止。七为已意得正止。便知如有。八为已知如有便寂然。九为已寂然便得离。十为已得离便得解脱。十一为已得解脱便见慧。有慧便知生死已尽。道[衛-韋+正]已毕。所作[衛-韋+正]已竟。不复还受苦

戒相为何等。至命尽持戒。令从是致无悔。身不增罪相为无悔。从是致喜令得喜处。可意相为喜。令致爱处喜足相为处。令致有猗处。从[衛-韋+正]为是为得猗相。令致乐处。已无[病-丙+(止/(止*止))]为乐相。令从是致定处。意随使不忘为定相令致如有慧处不惑。如有相随相。是为寂然处。若知非身是为寂然相。令从是致相别离处。不近会为相别离。为从是致解脱。已为非行法不受殃。是为解脱相。令致解脱慧见

为有四道德地。何等为四。为四行者。福彼若如有知智。是为见地。为得道迹。是为得道福。彼如有如有知是为恶却离。是名为薄地。为有往来福。彼以恶却为不用。是名为相离地。彼已相离。是为不复还福。是名为欲竟地无所著。亦[衛-韋+正]者福是何义。为道弟子有八种道[衛-韋+正]。是名为[衛-韋+正]者。为是是福。是故名为[衛-韋+正]者福。何以故。为[衛-韋+正]清净为名。是为清净福。是为道德有八种清净道[衛-韋+正]。为是是福。是故名为清净福。彼为应得道迹。云何已谛相应道。弟子便断三缚结。彼为三缚结为何等。一为知身非身。二为无疑。三为不贸易[衛-韋+正]戒。已断是三缚结。道弟子便堕道迹。不复堕恶道。毕竟道七更天上。亦人间已更。所在往来便断苦。从苦得解。是名为见地为得道迹福。彼何等为令意堕是身。亦知是身。痴为以不闻。为世间人。不见觉者。亦不从闻者。受教戒闻者。亦为未分别。现正法为意念。是色为身。遍睹色为身。是色亦为身。色亦是我身。痛想[衛-韋+正]识。亦如上说。已如是得观。便受五乐。令为受是身。为堕身。令意念我为是。我为以是着。相连不得自在。牵相随如是有所忍。所可为意。为可受。已受见随[衛-韋+正]。是为邪见。堕受是身。彼为见是五邪令堕疑无有。何等为五。若为所色为见。是身比前。更想行识亦尔。是为五邪见。令堕无有。后有余十五。令堕常。如是见。是身已断。便六十二邪见已舍。令不堕常非常。已非常常为舍。便道弟子无倒邪见。但为度世。直见为何等。令不堕邪见身。若道弟子为闻。为直见。见通经家。为已受度世无为。为已解度世法。不复见是色为身。遍睹色为身。是色亦为身色。色亦是我身。痛想行识已不见如是。便解三结使。何等为三。一为不见是身。二为不恚。三为不疑。已如是道弟子为无疑。在佛亦无疑。为信为喜为佛。如是如来无所著正觉慧行已足为乐。为世间已解。无有过。是法驭法随为师。为教天上天下为佛最上。是得信不疑。为随是法[衛-韋+正]为在法。无结无疑为信为喜。佛说是法。现可学可致。现自更见。已解为慧。为是所贪饥渴相近已断。随已断。空无所应得。爱已坏。已离已尽。为无为。以是第二无结。无疑。得法随法[衛-韋+正]。为同学聚。为无结无疑。已有受有喜。如是受得道弟子。为学聚。正受[衛-韋+正]为如应受。戒已立。定已定。慧已得解脱。已成解脱慧。已现已致。是为佛弟子[衛-韋+正]者。聚为四人。从[衛-韋+正]四双。名为八人道[衛-韋+正]。为世间所重所尊。为无所。比可祠可事可恭。为福地无过。是天亦人所事。是为第三。已为无疑法。随法[衛-韋+正]一切[衛-韋+正]为苦。已无疑结。已受已喜。从爱为习。苦亦从爱习。已无疑结。已受已解。已喜已爱尽。是为苦尽。便无疑无结。已得是受。便得喜已爱尽。是为苦尽。无疑结。已解受便得喜。为八种道[衛-韋+正]。从是受[衛-韋+正]令苦尽。便不疑。不疑不复结。堕解得喜。若本有疑不解。在佛不解。在法不解。在[衛-韋+正]者聚。若本有疑。在苦在习在尽在道。[衛-韋+正]所惑所不解。随志所疑惑。是如是云何是疮。为是已解本已断。树不复住。已散不复现。从来本法不复生

彼持[衛-韋+正]戒转摸贸为二辈。一为渴爱堕。二为不解避持[衛-韋+正]戒转模贸。为意向。从是[衛-韋+正]戒摄守。从是当为得天亦天比。当为天上。彼字为甲玉女。当为是俱相乐共居。如是望。如是可。如是思结相见意向。是为渴爱。虽持[衛-韋+正]戒。为堕摸贸。彼为不解持[衛-韋+正]戒。转摸贸为何等。戒[衛-韋+正]者为转贸戒。转贸为何等。为意生从戒得净。从戒得解脱。从戒得要。为从苦乐得度。或意生从愿得度。是为不解持[衛-韋+正]戒转摸贸。何因缘为不解转摸贸。意生从被服。亦从愿得度世。从苦乐得却离。为从是二业被服。亦愿为摸。何等为摸。为是二戒被服。愿意计。从是得解脱。从是得要。从是得过苦乐。从是苦乐为得无为从是不正计法。不从是解脱。意计从是解脱。不正计为是正。随是[衛-韋+正]如是有。忍可意望结见。是从是为解。是为不解持戒转摸贸。是为二结。得道弟子已舍。为无有本已断。树已拔不复现。从后不复生。是法便为已净。戒如得道戒。随[衛-韋+正]不为破。不为穿。不为失。不为悔。但有增如。慧者可无有能夺。为得从是致定。是为三缚结。道弟子为已断。已堕道迹。不复堕恶法。必度世在七往来。天上亦人中。往来期毕。便得出苦要。有四相应。何谓四相应。一为已解相应。二为已断舍相应。三为自证相应。四为增满相应。彼道德弟子。从苦为已解相应。从习为已断舍相应从尽为自证相应。从道为增满相应。彼为止观俱随行。一处一时一意。本来有是有意。令为作四事。何等为四。一为苦。从苦已解为苦相应。二为习。从习已断舍为习相应。三为尽。从尽自证为尽相应。四为道。从道增满令道相应。何以故。从苦已解相应。何以故。从习已断舍相应。何以故。从尽已自证相应。何以故。从道已增满相应。为有譬喻。如水中沫行。上至竟为有四[衛-韋+正]。从是岸边。致度岸边。度就断脉。是亦如是。止观双俱行。一处一时一意。上要至竟。为成四事。譬如日出。上至竟。为现作四事。致明坏冥现色现竟。譬如船渡。舍是岸边致渡岸边。致物断脉。止观亦如是。双发行。为一处一时一意。上要至竟为作四事为解苦。如应相烛为断习。如应相应为尽自证。如应解相应为[衛-韋+正]道。要如应相应。何以故。为苦从更解相应。习从断解相应。尽从苦证解相应。道[衛-韋+正]要解相应。止观亦如是双相连行。一处一时一意。止要至竟为[衛-韋+正]竟四事为苦。更为习断。为尽自证为[衛-韋+正]道满。譬如然灯烛。上至竟为作四事。为作明。为去冥。为现色。为却疑。止观亦如是。为作四事。为识苦。为断集。为尽自证。为[衛-韋+正]道满。譬如然灯上至竟。为有四义。为现明。为去冥。为现色。为尽膏炷。止观亦如是。双随行。一处一时一意止至竟。为作四事。为识苦苦相应为断习习相应。为尽自证尽相应。为[衛-韋+正]道满道相应。何以故。为识苦苦相应。何以故。为断习习相应。何以故。为尽自证尽相应。何以故。为[衛-韋+正]道满道相应。为从谁应为从止观。何等为应。应云何持。意系观已意系观。便见五阴苦。彼所意系是为止。已见五阴为苦。是为观。彼所为五阴相近。可发往欲着。愿得相往不舍习所。是已断已尽。止观道亦如是。令是道德四谛。一处一时一意上至竟。为令四谛相应。如是道。道德弟子为是法相法。已应是名为见地。已得道脉。至道迹跓。为复止观。令是欲恚使缚为复除。得道弟子为往来受。以是[衛-韋+正]足。已从往来便坏苦。本是为薄地。便已竟往来福已来得在德止。复增止观。令余爱欲恚所使为毕舍。欲恚未毕舍。使结令毕已毕。为得道弟子。便解下五结已毕。何等为五。一为见身是非。二为解疑。三为不惑不贸戒。四为不望。五为不恚。是为五结已毕。便得道弟子。不复还世间。彼度世不复还。是世间是名为却地。是为不还福。已致得止不还福。复增翅止观。令为解舍上五结。何等为五。一为色欲。二为不色欲。三为痴。四为憍慢。五为不解。已上五[衛-韋+正]足。为已舍五结。便无所著。已度世无有漏。已竟从正得解脱。是为毕地。无所著尚有妙无为。为舍毕已。世间命根尽。亦世间苦尽。不复生苦。彼以为是阴持入。已尽寂然。不有阴持入。不相连不复发。是名为已毕无为。为已说谛相应。亦说份相应。亦说地。亦说福说断。说罪说离。说二无为。为一切如是说。佛已更度世毕。若人欲度世。当[衛-韋+正]是彼

何等为九次第思惟正定。为四禅亦无色正四定亦已尽毕定。为九次第正定。彼第一禅已舍五种。随正五种。已舍五种为何等。为五盖。一爱欲。二嗔恚。三睡眠。四不了悔。五为疑。是为五种。上禅已舍彼爱欲盖。为何等。爱欲名为所为。五乐爱着。发往可求。随愿发不舍使发起。是名为爱欲盖。彼嗔恚盖为何等。为若人为发行拖。[病-丙+(止/(止*止))]恚相恚非法本所使所从起。是名为嗔恚盖。彼睡瞑盖为何等。睡为身跓。为意跓。为身止。为意止为身痴。为意痴。为身重。为意重。为身不便。为意不便。为身不使。为意不使。是为睡瞑。为何等为意相。从令瞑动相动。令不作事。是为瞑。上头为睡后为瞑。是共名为睡瞑盖彼不了悔盖为何等。为身不止悔为何等。为所念可不可不得悔。是上头。为不了。后为悔。是共名为不了悔盖。彼疑盖为何等。若不信佛。不信法。不信[衛-韋+正]者聚。不解苦习尽道比结使。亦从发是名为疑盖。亦有五疑。有县聚疑。有发教疑。有道分别疑。有欲[衛-韋+正]定疑有得道福疑。如是是为说定疑。是为五盖。盖说为何等。盖为却对。为却一切清净法。却云何。爱欲为却清净。嗔恚为却等意。睡为却止。瞑为却精进。五乐为却[衛-韋+正]。亦止结为却不悔。疑为却慧。不知本从起。为却解明

阴持入经卷下

    佛说慧印百六十三定解

当知舍利弗如来之身为无身无作无起无灭无从有未曾造无合无游无至无知无习都清净无畜无憎无行无止无生无报无见无间无臭无尝无更无识无晓无喻无知忍无志无思非意离意意平无平去意无所与无五道五道断要具无闺无恼无有无畏无可无不可无业无成无言无耎不现非明非冥非灭不灭离灭已灭为净极净彼净不用非悦非爱非负离负已住应于无处非逝非亡非没非法非无法非土非无土非尽无有尽舍尽无怒离于天离于向离于说离于思非合非不合非极非不极非去非不去非二非不乐无彼受无所视无相离相不求相明安徐无著离着造信亦无二称如为审如审如义不负人度无度除无除救无救说无说二无有等无比等与空等无处等无生等无得等无休息离息已寂而寂满寂散解心善行转至要一切报断成具甚真身明质净无自惟无所行行解无解无应不齐不长不圆不方不赞阴不称种不誉入不是数不致数不复生不可见不有知亦不死不世因无不因身然不趺无有居处非终非始非念非忧非事非诤非恶相非灭度非灭讫非所造非不游


慈氏菩萨所说大乘缘生稻[卄幹]喻经

    No. 710 [Nos. 708, 709, 711, 712]

慈氏菩萨所说大乘缘生稻[卄/幹]喻经

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

如是我闻。一时婆伽梵。住王舍城鹫峰山中。与大苾刍僧千二百五十人俱。及大菩萨摩诃萨众。尔时慧命舍利子。往至慈氏菩萨摩诃萨经行处。其慈氏菩萨与舍利子。俱坐盘石上。时慧命舍利子问慈氏菩萨摩诃萨言。今日世尊观见稻[卄/幹]。告诸苾刍而说是语。汝等苾刍若见缘生即是见法。若见法即见佛。婆伽梵如是说已默然而住。如来所说是经当有何义。云何是缘生。云何是法。云何是佛。云何见缘生即见法。云何见法即见佛。说是语已。慈氏菩萨摩诃萨告舍利子言。薄伽梵常为苾刍说如此义。若见缘生即见法。若见法即见佛。缘生者所谓无明缘行。行缘识识缘名色。名色缘六处六处缘触。触缘受受缘爱。爱缘取取缘有。有缘生生缘老死。如来说此是为缘生。云何是法。如来略说八支圣道果得涅槃。是名为法。云何是佛。觉悟一切法故。以圣慧眼证于涅槃。见作菩提所学之法。是名为佛。云何见缘生。如来说此缘生常住。无人无我无众生无寿命不颠倒。无生无作无为无对无碍。见自性寂静即见法。若见如是种类常住。无人无我无众生无寿命不颠倒。无生无对无碍是即见法。从此已后即见法身。得见如来现证正智。又问缘生者是何义。答言有因有缘。非无因缘名为缘生。而于此中如来略说缘生之相。由是因故能生是果。若如来出世及不出世。法性法住法位。顺于缘生真如不颠倒如不异如真实不异。实不颠倒不错谬为如是等。复次缘生者由二种因起。云何为二。一者系属因。二者系属缘。其缘生法应知二种。所谓外内外缘生者系属因云何。所谓从种子生芽。从芽生叶。从叶生枝。从枝生茎。从茎生干。从干生花。从花生果。若无种子芽无从生。乃至无花果亦无所从生。有种故生芽乃至有花生果。其种不作是念。我能生芽。芽亦不作是念我从种生。乃至花亦不作是念我能生果。果亦不作是念我从花生。然有种子故生芽。乃至有花生果。如是外缘生应知系属于因。云何外缘生系属于缘。所谓六界和合缘生系属于缘。云何六界地水火风空时和合缘生系属于缘。云何地界水火风空时界。令种子摄持名为地界。令种子滋润名为水界。令种子成就名为火界。令种子增长名为风界。令种子作无障碍名为空界。令种子变易名为时界。若无众缘子不生芽。若不阙地界不阙水火风空时界。则一切和合种子生芽。其地界不作是念我能摄持种子。水界不作是念我能滋润种子。火界不作是念我能成就种子。风界不作是念我能增长种子。空界不作是念我能令种子作无障碍。时界不作是念我能变易种子。其种子亦不作是念。我从众缘而得生芽。然假如是缘种子生芽。其芽不自作不他作不二俱作。不自在天作。不时变易作。不自性生。不系属作者无因得生。如是种子以地水火风空时和合故。而生此外缘生法。应知五种不常不断不移转。因少果多。相似相续不生异物。云何不常。种子芽异故。不即是种是芽。亦不以坏种而得生。芽实种坏故而生。以种坏芽生故名不常。云何不断。先不坏种而生芽亦非不坏。如是种坏和合生牙名为不断。不移转者。种子芽为异故。因少果多者。种子少果实多。相似相续者。随其植种收果亦尔。如是外缘生法五种应知。云何内缘生。有二种得生。云何为二种。一者系属因二者系属缘。内缘生法系属于因云何。所谓无明缘行。乃至生缘老死。若无无明则无行。然有无明即有行。乃至有生缘老死得生。其无明不作是念我能生行。行不作是念我从无明生。乃至生不作是念我能生老死。然有无明即有行生。乃至有生即有老死生。如是内缘生法系属于因。云何内缘生法系属于缘。六界和合生。云何六界和合。所谓地水火风空识界。和合缘生系属于缘。云何地界。令身聚合坚体名为地界。云何水界。令身作摄持名为水界。云何火界。令身中食饮成就名为火界。云何风界。令身中作出入息名为风界。云何空界。令身中成窍隙名为空界。云何识界。令转名色如束芦。五识相应有漏意识名为识界。若无六界则不成身。若不阙内地界。不阙水火风空识界。则一切和合能生其身。其地界不念我能令身聚合坚体。水界不念我能令身作摄持。火界不念我能令身中食饮成就。风界不念我能令身作出入息。空界不念我能令身中成窍隙。识界亦不作是念。我能转名色犹如束芦。其身亦不作是念。我被众缘所生。然有如是众缘而生其身。是地界无我无人无命无寿者无意生无儒童。无女无男无非男女无吾我。亦无余水火风空识界。亦无我无人无命无寿者无意生无儒童无女无男无非男女无吾我无余。云何无明。于此六界起一想合想常想坚想常恒想乐想静想众生想命想寿者想意生想儒童想吾我作者想。生如是种种无知名为无明。于如是有无明境界生贪嗔痴。于彼贪嗔痴生行。于彼事施设名为识。其识生四蕴。彼名色所依诸根。则六处三法和合名为触。触生受。受耽着故生爱。爱广大故名为取。取复生有。业有作因生蕴。蕴熟故名老。蕴坏故名死。于爱迷惑贪着热恼故名愁。追感往事言音哀戚名为叹。五识身相应名为苦。意不悦故名忧。随烦恼故名为恼。愚闇名无明。造作名为行。了别名为识。互相摄持名为名色。依处所故名为六处。触境故名为触。领纳故名受。渴爱故名为爱。取着故名为取。取复生有故名为有。能生故名生。根熟故名老。灭坏故名死。哀戚故名愁。怅怏故名叹。意不悦故名忧。逼迫身故名为苦。不称情故名恼。不修真实行名邪行。无知名无明。有无明故种种造作。福近行行非福近行行不动近行行。起福近行行非福近行行者故名为识。是故名为无明缘行。起非福近行行非福近行行者亦即是识。是故名行缘识。起不动近行行不动近行行者亦是于识。是故名为识缘名色。名色增长作六处门。是故名为名色缘六处。六处身转。是故名为六处缘触。同类触生同类受。是故触缘受。于受差别耽着喜悦。是故名为受缘爱。爱耽着乐故爱不舍数数忻求。故名为爱缘取。如是营求复生有起业于身于语于意。是故名为取缘有。从业生五蕴转。名为有缘生。从生蕴令熟坏灭。名生缘老死。如是名为十二缘生。迭互为因不常不造作。无思亦无缘生无尽法无离欲法无灭法。无始来流转不间断。随转如河驶流设使缘生不间断随转如河驶流。是十二支缘生四支和合而作转因。云何为四所谓无明爱业识。是识种子自性为因。业田自性为因。无明爱烦恼自性为因。业烦恼识能生种子。如是业识作种子田。爱识作种子。沃润无明识令种子开发。其业不作是念我与识种子作田。爱不作是念我与识种子作沃润。无明不作是念我令识种子开发。识种子亦不作是念我从众缘而生。然实识种子安立业烦恼。以爱令沃润。以无明土覆生名色芽。其名色芽不自作不他作不二俱作。不自在天作不时变易作。不从自性生不系属因。无因亦不生。然复从父母和合时相应。及余缘相应相续生。是识种子于母腹中。名色芽生。于无主无我授法如幻相因缘不阙。从五种缘生眼识。云何五种眼缘色明虚空从彼生作意。眼识作依止色作所缘。光明以为照虚空作无碍从彼生作意以为审虑。若无众缘眼识不生。若阙内眼处如是色光明虚空作意。则眼识不生。如是五缘不阙则一切和合能生眼识。其眼不作是念我与眼识作所依。其色不作是念我与眼识为所缘。光明不作是念我与眼识作照缘。虚空不作是念我与眼识为无碍缘。所生意不作是念我与眼识作审虑。又眼识不作是念我为众多缘所生。然有众多缘而生眼识。余四根者应如前知。实无有法。不从此世移转至于彼。有业报施设因缘不阙故。譬如明镜现其面像。其面像不移转至于镜中。而此镜中有其面像。因缘不阙故。如是不从此灭至于余处。有业果感招因缘不阙故。譬如月轮去地四万由旬。于全器中而有少水则现月像。而实不从彼谢至于全器少水中现。然有众缘和合影现如是。不从此灭生于余处。有业报相感因缘不阙故。譬如无薪火则不生。有薪则火生。业烦恼所生识种子。从彼生处相续名色芽转。如是无主无我法无所摄法。互为因缘如幻相。自性法因缘不阙。内缘生法五种应知。不常不断不移转因少果多相似相续生。云何不常。从此边蕴死于余处边蕴生。非即死边蕴是彼生边蕴。然死边蕴灭于彼生边蕴起。是故不常。云何不断。不先灭于死边蕴。而起生边蕴。亦非不灭于死边蕴。即于彼时而生中有蕴。如秤不低昂名为不断。云何不移转。然于异类转先名不移转。云何因少果多。于此身作少善恶业。于来生身多受善恶报。云何相似相续。犹如现受身作业即于来生受报。若是此缘生法。如实以正慧眼。长时修无人无我不颠倒不生不灭无作无为无碍无所缘寂静无畏无夺无尽如幻自性空寂不坚如痛如痈质碍无常性苦性空性无我性。则前际不流转。谓我于过去为曾有耶。谁为我过去曾为有耶。我于过去云何有耶。复于后际流转。谓我于未来当有耶。谁谓我未来当有耶。我于未来当云何有耶。我于未来不有耶。谁谓我于未来不有耶。我于未来云何不有耶。复于中际不流转。我于今有耶。谁谓我今有耶。云何谓我今有耶。此有情于此殁复往何处。所有沙门婆罗门世间中异见。所谓我见系众生见系寿者系诸见系希望吉祥系。若以正见相应于此时。悉断诸结证得遍知。如断多罗树。无所有性入于胜义。于诸趣长时悟不生不灭。得成就忍广作无边利乐有情事。若有善男子善女人。于此经中若须臾顷。审谛观察缘生义理者。即能顿灭无始时来极重业障。广集福德智慧通达。永断耶见说法无畏。大德舍利子婆伽梵。与彼善男子善女人。授无上等觉大菩提记。具寿舍利子并天龙药叉彦达嚩阿苏啰蘖噜拏紧那啰摩护啰誐人。及非人。闻慈氏菩萨说是经已。心大忻悦深生随喜从此而起礼慈氏菩萨足欢喜奉行慈氏菩萨所说大乘缘生稻[卄/幹]喻经


达摩多罗禅经

    No. 618

达摩多罗禅经卷上

        东晋天竺三藏佛陀跋陀罗译

夫三业之兴以禅智为宗。虽精粗异分而阶籍有方。是故发轸分逵涂无乱[跳-兆+(轍-車)]。革俗成务。功不待积。静复所由。则幽诣造微。渊博难究。然理不云昧。庶旨统可寻。试略而言。禅非智无以穷其寂。智非禅无以深其照。然则禅智之要。照寂之谓其相济也。照不离寂。寂不离照。感则俱游。应必同趣。功玄于在用。交养于万法。其妙物也。运群动以至一而不有。廓大像于未形而不无。无思无为。而无不为是故洗心静乱者以之研虑。悟彻入微者以之穷神也。若乃将入其门机在摄会。理玄数广道隐于文。则是阿难曲承音诏。遇非其人必藏之灵府。何者心无常规其变多方。数无定像待感而应。是故化行天竺。缄之有匠。幽关莫辟。罕窥其庭。从此而观。理有行藏。道不虚授。良有以矣。如来泥曰未久。阿难传其共行弟子末田地。末田地传舍那婆斯。此三应真咸乘至愿。冥契于昔功在言外。经所不辩必闇軏无匠孱焉无差。其后有优波崛。弱而超悟。智绍世表。才高应寡。触理从简。八万法藏所存唯要。五部之分始自于此。因斯而椎固知形运以废兴自兆。神用则幽步无迹。妙动难寻涉粗生异。可不慎乎。可不察乎。自兹已来。感于事变怀其旧典者。五部之学并有其人。咸惧大法将颓。理深其慨。遂各述赞禅经。以隆盛业。其为教也。无数方便。以求寂然。寂乎唯寂。其揆一耳。而寻条求根者众。统本运末者寡。或将暨而不至。或守方而未变。是故经称满愿之德。高普事之风。原夫圣旨非徒全其长。亦所以救其短。若然五部殊业存乎其人。人不经世道或隆替。废兴有时则互相升降。小大之目其可定乎。又达节善变出处无际。晦名寄迹无闻无示。若斯人者复不可以名。部分既非名部之所分亦不出乎其外。别有宗明矣。每慨大教东流。禅数尤寡。三业无统。斯道殆废。顷鸠摩耆婆宣马鸣所述乃有此业。虽其道未融。盖是为山于一蒉。欣时来之有遇感奇趣。于若人舍夫制胜之论。而顺不言之辩。遂誓被僧那至寂为已任。怀德未忘故遗训在兹。其为要也。图大成于未象。开微言而崇体。悟惑色之悖德。杜六门以寝患。达忿竞之伤性。齐彼我以宅心。于是异族同气幻形造迹。入深缘起见生死际。尔乃辟九关于龙津。超三忍以登位。垢习凝于无生。形累毕于神化。故曰无所从生。靡所不生。于诸所生。而无所生。今之所译出自达摩多罗与佛大先。其人西域之俊禅训之宗。搜集经要劝发大乘。弘教不同故有详略之异。达摩多罗阖众篇于同道。开一色为恒沙。其为观也。明起不以生灭不以尽。虽往复无际。而未始出于如。故曰色不离如如不离色。色则是如如则是色。佛大先以为澄源引流。固宜有渐。是以始自二道开甘露门。释四义以反迷。启归涂以领会。分别阴界。导以正观。畅散缘起使优劣自辩。然后令原始反终。妙寻其极。其极非尽。亦非所尽。乃曰无尽。入于如来无尽法门。非夫道冠三乘智通十地。孰能洞玄根于法身归宗一于无相。静无遗照动不离寂者哉。庾伽遮罗浮迷。译言修行道地

    修行方便道安那般那念退分第一

  前礼牟尼尊　　炽然烦恼灭
  流转退住者　　度以升进道
  修行微妙法　　能离退住过
  亦灭一切恶　　成就诸功德

佛世尊善知法相。得如实智慧。灭烦恼盛火。出炽然之宅。乘诸波罗蜜船。度无量苦海。以本愿大悲力故不舍众生。为诸修行说未曾有法。度诸未度令得安隐。谓二甘露门。各有二道。一方便道。二曰胜道。清净具足甚深微妙。能令一切诸修行者出三退法。远离住缚增益升进。成就决定尽生死苦。究竟解脱兼除众生久远痴冥。佛灭度后尊者大迦叶。尊者阿难。尊者末田地。尊者舍那婆斯。尊者优波崛。尊者婆须蜜。尊者僧伽罗叉。尊者达摩多罗。乃至尊者不若蜜多罗。诸持法者以此慧灯次第传授。我今如其所闻而说是义

  我今如所闻　　演说修行地
  方便胜究竟　　如其修所生
  修行于善法　　先当知四种
  退减住升进　　决定诸功德
  修行退减时　　令住法不生
  亦不能升进　　是今当略说
  先当起等意　　习行慈心观
  须臾止嗔恚　　令暂息不行
  烦恼暂止息　　次当净尸罗
  尸罗既清净　　三昧于中起
  三昧已修起　　观察应不应
  善知应不应　　修向所应作
  既向所应作　　专念系心处
  已能乐彼处　　正观依风相
  正观依风时　　其心犹驰乱
  止心在入息(安般者二种一见二触钝根不见)
  如系调御马　　心既止入息
  思惟正忆念　　冷暖与轻重
  柔软粗涩滑　　修行谛觉知
  随顺善调适　　于触复不了
  是说修行退　　数一以为二
  数二以为一　　至九犹错乱
  是说修行退　　若于修行退
  更数从初起　　十数满足者
  远离诸过行　　不修与过修
  或有异修起　　有此诸过生
  是说修行退　　修行若俱数
  心据生惑乱　　惑乱若增长
  是说修行退　　气息不通流
  冲击于鼻面　　头顶悉苦痛
  内或绞风起　　息乱失其道
  而彼不知治　　身体极烧热
  其心生愦乱　　四种既错乱
  依风极违诤　　修行欲令息
  而不善方便　　不知对治法
  是必疾退减　　修行缘入息
  而反缘出息　　修行缘出息
  而反缘入息　　于二心俱净
  是应修行果　　寂止定意生
  而复更求数　　有此诸过谬
  是皆修行退　　急喘而安般
  则令念错乱　　由是错乱念
  修行心发狂　　其心发狂故
  不知应不应　　于二无分别
  是说修行退　　修行数已成
  息去亦随去　　去已处处住
  于彼善观察　　既观令息还
  还已起清净　　不善知六种
  是说修行退　　长短悉分别
  遍身尽觉知　　身行渐休息
  一切应决了　　于此不善知
  是令修行退(身念处四胜竟)　　知喜亦知乐
  勤方便意行　　当复制心行
  令不至掉乱(受念处四胜竟)　　次分别知心
  修行正观察　　又生欣悦心
  还复摄令定　　非是不定心
  定已心解脱(心念处四胜竟)　　善修解脱者
  不令心退没　　若入退减分
  则无有解脱　　观察无常断
  离欲与灭尽　　出息入息灭
  是名修行胜(此四相似法念处)　　如是十六行
  自在心回转　　觉触之所获
  见得亦复然　　若于见与触
  不善识分际　　是过应当知
  无智令修退　　修行上增进
  不应缘于下　　缘下亦如是
  不应上增进　　若见二增进
  心住而等观　　任之则自成
  还到修行处

方便道安般念退分第一竟

    修行胜道退分第二

  胜念已成就　　懈怠竟沉没
  是则为退像　　无堪于所求
  不染污无记　　起诸脑恼退
  垢浊热炎生　　由是失正见
  振掉或关钥(以灼反)　　浮飘粗涩滑
  是五退减相　　修行应分别
  望远绝所悕　　有见已坠落
  还顾睹深崄　　是皆退减相
  长病诵止诤　　多业远游行
  彼时解脱种　　是五退减因
  信戒闻舍慧　　于是渐衰退
  身重与惛钝　　耽睡及沉没
  是五应当知　　修行退转相
  恐怯多犹豫　　惊畏不欣乐
  懈怠离所欲　　不回向修行
  不习过修习　　是二俱为失
  彼时解脱种　　于是修行退
  三昧离相乐　　尔炎皆消尽
  粗涩四大种　　还从身内起
  掉动失正念　　由是意愦乱
  其心不恬静　　斯从行者生
  一切诸瑞相　　不显现分明
  修行如是观　　欲见为甚难
  诸根悉驰纵　　随欲向所缘
  邪意普流散　　乐着诸境界
  形消意愁惨　　其身皆烧然
  如是烧然者　　是说为忧退
  方便不精勤　　后则生悔恨
  闻所应成就　　欲进劣无能
  不趣喜胜处　　或见胜不取
  皆由无智故　　是说修行退
  自念有越戒　　疑悔及诸觉
  意淡无滋味　　是说修行退
  诸过定意羸　　三昧渐消减
  心乱盖所覆　　是说修行退
  心举调顺舍　　不观时非时
  不了住起缘　　无智故修退
  不知六时行　　六界亦不善
  亦愚六巧便　　是说修行退
  贪欲嗔恚觉　　十想巧方便
  得向诸禅地　　及法心妄解
  一切次第度　　无知故修退
  不观处非处　　业报及正受
  禅定诸解脱　　净味愚不了
  诸根到处道　　性欲不分别
  心随众杂相　　是悉无知退
  于苦乐速道　　其心不趣向
  如是意迷惑　　必向退转处
  起住与起缘　　入出及方便
  六法不成就　　是令修行退
  知法亦知义　　知时亦知量
  自知与知众　　及知福伽罗
  于七愚不了　　是令修行退
  兴起诸恶法　　习行卑贱业
  亲近不善友　　令是修行退
  错说违所应　　爱者心乐向
  当知是不久　　必于修行退
  所止处及人　　床卧等众具
  斯皆非所乐　　近令修行退
  喜随诸杂相　　损减所修慧
  弃舍所缘处　　心不得真实
  修行舍本相　　散心随外缘
  虽欲还彼处　　意众不复乐
  遂失长养分　　其心不一定
  身无复滋润　　悦乐亦不生
  所依不可乐　　身意俱错乱
  三昧不复起　　其心永不住
  如是不住心　　必于修行退
  爱见慢增禅　　于缘心味着
  有此累念生　　是说修行退
  身如利刺害　　或复极振掉
  举体皆烦壮　　如蛇毒充满
  有此三过恶　　必于修行退
  得未得服行　　他务意不闲
  习近三退法　　是说修行退
  业与烦恼报　　说是三障阂
  亦有解脱障　　是令修行退
  方便想恶行　　三摩提行地
  于彼不观察　　是令修行退
  方便想诸地　　三昧行及余
  所闻随悕望　　则于发趣退
  生时作灭想　　灭时作生想
  二想俱当失　　是则修行退
  若于住法中　　而作生灭想
  兴此诸颠倒　　是说修行退
  入时作出想　　出时作入想
  二俱作住想　　是说为颠倒
  欲断烦恼得　　修行正方便
  由彼得力故　　相似诸相生
  相似相既生　　修行心随转
  烦恼即时起　　是说修行退
  退过诸駚水　　漂浪修行者
  随我力所能　　少量退法海
  无量余退过　　是深非所恻
  诸深明智者　　自当广称说

胜道中退分竟

    修行方便道安般念住分第三

  如我力所能　　演说退过已
  今当说住过　　修行者善听
  若于入出息　　无见亦无觉
  不解方便求　　是则初门住
  闻慧既已生　　应起思慧念
  不善解次第　　愚痴住所缚
  若数已成就　　息去应随去
  不知随顺法　　是说修行住
  如佛问比丘　　谁习安般念
  有一比丘答　　是念我修习
  汝有安般念　　不言汝无有
  复更有胜妙　　牟尼说当修
  方便道安般

念住分第三竟

    修行胜道住分第四

  胜道修正观　　相行念已成
  不善升进法　　是则住所缚
  爱着所缘境　　进业心懈怠
  由是缚所缚　　不能至胜处
  或有不可动　　非软亦非坚
  或强极牢密　　亦如金刚像
  有此五障阂　　不进亦不退
  是则住缚相　　远离升进道
  乱光及黑闇　　忍自身不现
  譬燃浊油光　　亦如翳目视
  光明不显发　　背舍诸喜乐
  寂止息乐分　　彼终不复生
  犹如坚实物　　而有濡相现
  或时修行者　　住相亦复然
  相非随所欲　　而起随欲想
  虽欲令随意　　终不从所乐
  谓相非所留　　而欲强制持
  如是违反念　　则为住所缚
  是想已成就　　当知非所制
  住彼去留相　　能到最胜处
  欲令涌作没　　或欲高为下
  于去欲使来　　于住不欲住
  灭时欲不灭　　终不如所欲
  修行住生灭　　所行常转进
  诸法相已成　　终不舍自相
  若不舍自相　　自相则显现
  薄皮覆不净　　令不见身秽
  威仪及众具　　利乐翳身苦
  相似次第生　　前后续无间
  隐蔽非常相　　令不见身变
  施作服用受　　摄持吾我相
  能忆念本事　　隐身非我观
  是诸相似相　　修行不分别
  于彼起爱乐　　而生功德相
  染着妄想生　　不复乐升进
  不能取胜法　　住过日增长
  非我相似相　　此等不回转
  如是不回转　　行者痴惑生
  无智住所缚　　系着于彼处
  乐着生诸过　　是相今当说
  尔炎渐损坏　　分离及交乱
  破散叵和合　　是则住相缚
  于身不巧便　　自生分离想
  交乱或尘碎　　是为住所缚
  守常无异想　　众色不次生
  种种众妙想　　亦不次第起
  流出而不住　　其身渐消减
  相或来复去　　修行不增长
  寂止既不生　　于身无长养
  心不起悦乐　　是说不净舍
  彼不清净舍　　所见不鲜白
  亦不能升进　　亦复不退转
  如戏沙门像　　少时生悦乐
  譬如借衣服　　亦如梦所见
  为命不清净　　谄曲及余恶
  聚落知识所　　自显其功德
  覆藏诸过恶　　犯罪不发露
  及余一切缚　　垢污修行者
  仿佛有事相　　而便起实想
  未熟谓为熟　　未灭想已灭
  方便不等满　　而欲求升进
  如部含穟苗　　是则住所缚
  业始无方便　　相现坚守持
  过进心矜举　　如是住所缚
  或有修行者　　而起断常见
  是见令心乱　　则为缚所缚
  或有修行者　　身身细微观
  彼为住所缚　　厌心不增长
  厌心不增进　　不能离贪欲
  若不离贪欲　　何从有解脱
  解脱不成就　　终不得漏尽
  不断诸漏者　　则无实智慧
  于彼身念处　　住相已分别
  受心法念处　　如是应广说
  修行心不悦　　彼喜亦不生
  身无寂止乐　　当知是住相
  修行所受获　　信戒闻舍慧
  常守其少分　　是则为住相
  有住缚比丘　　往到阿难所
  迷于所住相　　是今当略说
  得无相三昧　　六年住所缚
  乐欲闻所说　　常随逐阿难
  不能进所业　　亦复不退转
  住于住境界　　不得解脱道
  不来亦不去　　解脱已而住
  住已复解脱　　解脱已还缚
  或有修行者　　住在不退地
  微细烦恼起　　而不能觉知
  不觉烦恼故　　不能到胜处
  于地无分别　　亦无有退过
  地诸过不起　　如是止于住
  或于住分中　　而失众妙相
  众妙相虽灭　　意犹顺彼地
  意顺彼地时　　余分乐相生
  已有少乐故　　心依寂止住
  因其寂止心　　自谓作已作
  安止不具足　　不得具足果
  无智翳心目　　而自谓为智
  修行无智障　　不觉所应用
  觉所应用者　　于地能究竟
  彼住共地中　　种种垢所污
  若使修行者　　成就不共地
  如是知过患　　彼终不为缚
  不识烦恼过　　愚痴无实智
  于禅觉吉安　　犹如象系树
  修行观尔炎　　莫知所起处
  从其所依出　　而自不能知
  不涌亦不没　　不见相所起
  亦不知灭处　　过亦无过是
  所说诸障碍　　皆是坚住相
  谓不由彼住　　斯非明智说
  兴造诸过患　　若干因缘缚
  能用诸对治　　众妙复显说
  所尊不恭敬　　亦不舍憍慢
  自隐覆其过　　不向明者说
  我年既衰老　　已为众所弃
  或能失利养　　令我生苦恼
  心常怀忧畏　　深虑长叹息
  我后当死时　　将欲作何计
  隐过心忧恼　　愚惑作所缚
  横自生罪累　　失大功德海
  味着现法乐　　贪餐黠无慧
  弃舍后世果　　兴此诸过恶
  如是诸住缚　　所起各各异
  修行无怯劣　　能治所应治
  怯劣无方便　　自谓无由进
  是则甚难拔　　如象溺深泥
  如是甚难拔　　懈怠心所欺
  长夜没住泥　　热迫而趣死
  业行烦恼报　　为此三障覆
  无智无势起　　永为住所没
  久远积痴冥　　业行诸烦恼
  系缚斯等类　　迷乱不自在
  习近诸过恶　　远离善功德
  令其意匆扰　　如箭旋虚空
  蛇毒盛充满　　蝮蝎恶龙处
  巨海深无底　　无泽大火聚
  盲人近彼游　　闇往而不见
  修行住所缚　　其过亦如是
  住过多无量　　升进德亦然
  如海无涯底　　是深不可量
  世间无知障　　真实慧为灯
  持灯无放逸　　彼明终不灭
  善说住分过　　缚诸无黠者
  决定知境界　　究竟非我分
  种种过所缚　　是缚非一相
  当知业众缘　　唯佛能觉了

    修行方便道升进分第五

  比丘安般念　　功德住升进
  能令智慧增　　我今次第说
  功德住已进　　进复功德住
  是故说修行　　功德住升进
  修行于鼻端　　系心令坚住
  专念谛思惟　　正观依风相
  入息与出息　　系心随忆念
  忆念若不忘　　是初功德住
  彼功德住已　　复起方便求
  更求功德时　　住则生升进
  升进等起时　　亦生功德住
  是名住已进　　进已功德住
  善解安般相　　功德及诸过
  息轻重冷暖　　软粗与涩滑
  阿那摄般那　　是摄持诸根
  于彼所缘境　　摄之令寂止
  外散心数法　　摄还义亦然
  持风来入内　　是故说阿那
  心转于所缘　　止令不复转
  心于所缘起　　亦复制令灭
  修行观若增　　制之令从止
  修行若止增　　起之令从观
  见增则以触　　触增则以见
  得证与智证　　二增俱相摄
  修行缘不寂　　意寂止摄来
  身中清凉起　　灭除诸热恼
  掉踊不静心　　摄之令寂止
  勤方便回转　　其身悉充满
  长养四大种　　当知从息起
  是种复增益　　行者报四大
  阿那力能起　　寂止善法分
  我所大恶刺　　亦能拔令出
  息短而渐灭　　修行心安静
  是故佛世尊　　说名为阿那
  复次般那相　　是今当略说
  毛孔诸窍处　　先净治息道
  前出名般那　　始由入风起
  修行出息时　　诸根随所缘
  心心法俱顺　　是亦说般那
  出息归于灭　　乃入根本地
  正受及命终　　斯由舍出息
  修行出息灭　　次第阿那生
  灭尽三摩提　　第四禅亦然
  般那既已灭　　次第阿那生
  阿那时悕望　　说阿世婆娑
  我观彼死者　　定无有是相
  彼息更生者　　观有如是相
  毒淤埿火蛇　　此相似境界
  出息能摄意　　不令随所缘
  犹如制象钩　　名波世婆娑(出息有摄心义)
  舍除颠倒想　　成就真实想
  离自在及常　　唯为空行聚
  本无所从来　　去亦无所至
  去来不可得　　亦不须臾住
  慧智明见此　　离诸知作者
  出息无作者　　见则堕颠倒
  出息已过去　　彼则不可见
  命断诸息灭　　过去亦复然
  安般诸功德　　出息与入息
  众物及字义　　我已略说竟
  是种增故说　　未曾相离用
  若为觉想乱　　当习安般念
  已能应于数　　则除内贪着
  于数若随顺　　是则离不顺
  志在无乱境　　能摄诸乱想
  先数从一起　　如是乃至十
  修行顺此数　　便得功德住
  已得功德住　　则能求升进
  灭一切乱觉　　佛说增上故(数门竟)
  数能灭一切　　觉佛但言灭
  一切不死者　　以增上故也
  内外出入息　　去则心影随
  决定善观察　　顺是趣涅槃
  修行出入息　　随到所起处(出入息所起处同在脐)
  如是知升进　　能离外贪着(随门竟)
  安止极风处(极上下风际)
  三摩提等起　　三昧既已起
  便得功德住(止门竟)　　修行正住已
  种种观察风　　先观于本处
  谓风所从起　　此处为云那
  为一为二耶　　冷暖悉观察
  八种如前说　　为总观诸大
  唯在一种耶　　观时悉俱有
  以一增上说　　修行观风大
  造色从彼生　　唯心与心法
  依彼造色起　　非彼造色已
  而复有种大
  诸有入出息　　是风名依种
  报风及长养　　是为三种风
  或说入在前　　出者在于后
  或说出在前　　入者在于后
  皆有因缘故　　彼作如是说
  如其真实义　　慧者乃决定
  于脐处所起　　净治毛孔道(此报风开毛孔故名出非出外)
  由此风义故　　彼说出在前
  毛孔已开净　　入者则在前
  如人初生时　　阿那入故起
  息风最先出　　是故说波那(此是真实义)
  息风诸种大　　割截不生苦
  当知彼非受　　谓受则不然
  以彼修行者　　不患诸断逼
  是故出入息　　于身复非受
  识命若断时　　息则不回转
  是则众生数　　必由命根起
  息则是身行　　世尊之所说
  亦名根本依　　众生所由转
  是息既已灭　　命则无所依
  以能持命根　　故说众生数
  阿那般那念　　缘风为境界
  虽曰正思惟　　而非真实行
  一切所修观　　彼悉缘风起
  于观有差别　　次第今当说
  阿那般那念　　分别有三种
  所谓从闻起　　思慧与修慧
  于是安般念　　比丘闻慧生
  一切时悉受　　名字为境界
  境界出入息　　正念思慧生
  当知彼缘名　　时或复缘义
  阿那般那念　　所起修禅慧
  悉已舍名观　　唯缘诸法义
  当知近境界　　无有种种异
  亦非相续缘　　说是等智行
  谓是安般念　　无痴智慧性
  亦名为舍性　　是则佛所说
  当知是慧性　　舍根共俱生
  若使是舍性　　则与余共起
  欲色二有系　　无色无身依
  非彼最后禅　　身密无息故
  或谓根本地　　亦复是眷属
  说言唯眷属　　非是根本地
  欲使彼舍性　　在于根本地
  阿那般那念　　应当在八地
  所言唯眷属　　如是说舍根
  知彼安般念　　唯在于五地
  此定在五地　　依是处回转
  欲中间未至　　及后二眷属
  最上顶四禅　　彼虽有舍根
  无有于彼身　　净治毛孔道
  第四及眷属　　彼中说二种
  报生与长养　　唯无有依风
  出息与入息　　是风名为依
  以身极厚密　　无依说二种
  佛说出入息　　四禅正受刺
  亦言咽喉处　　明知有所说
  是彼方便故　　亦以禅义摄
  出息与入息　　彼处定无有
  修行观出息　　上际第四禅
  已极风境界　　于彼正忆念
  云何我是心　　于缘究竟未
  或复更于上　　少进重观察
  或即于彼住　　不作余方便
  修行如是观　　则能除疑惑
  修行极风际　　是处善观察
  当知如是心　　则名除疑观(观门竟)
  于上观察已　　依风还止住
  观察所应已　　复起余所修
  若彼观风心　　于还善决定
  是说修行者　　回转巧方便
  如人游聚落　　所作讫已归
  修行如是观　　喜乐遂增长
  已舍入息念　　安处出息缘
  亦舍出息念　　安处入息缘
  于数已究竟　　息去亦随去
  如是一切种　　亦名为回转
  观察所应相　　相相而回转
  种种众事观　　次第转亦然
  善于回转者　　说此回转义
  当知是回转　　修行智慧处
  从彼方便起　　胜道现生前
  闻慧念已度　　次第思慧生
  已舍欲界行　　然后入修慧
  是悉名回转　　世尊之所说
  从彼未至地　　次第入初禅
  乃至第三禅　　其转亦如是
  第四禅眷属　　若彼有风者
  是亦应回转　　入于根本地
  从彼起巧便　　次第住起缘
  入出与优波　　此六悉回转
  舍共方便地　　共地现在前
  舍共方便地　　不共现在前
  舍不共方便　　不共现在前
  缘相方便地　　展转究竟地
  是名上回转　　明智所称说

(圣人凡夫共有法。名为共地。从缘至缘名为转诸相。诸方便诸地次第转亦如是也)

  如我智方便　　已说回转义
  无垢清净念　　今当次第说
  如令彼修行　　须臾抑止盖
  是则为清净　　不净非所应
  若已成就数　　能舍内贪着
  此义应当知　　慧者观清净
  随顺已成就　　能舍外贪着
  如是正思惟　　智者念清净
  比丘心已住　　不为乱所乱
  如是不动念　　修行智清净
  若已于风际　　观察离疑惑
  不复更求息　　是则为清净
  念地悉已竟　　所依诸过恶
  不为则清净　　是说须臾顷
  阿那般那念　　方便道所摄
  功德住升进　　是义我已说

方便升进第五竟

    修行胜道升进分第六

  功德住升进　　及余方便摄
  修行一切地　　共地不共地
  功德住升进　　彼依胜道起
  种种相行义　　今当说善听
  梯揥既已起(心住处名)　　修行心爱乐
  如是爱乐心　　巧便功德住
  慧者善方便　　起意勤修行
  如其功德住　　是则巧方便
  将入微妙境　　勿随流注想
  慧者摄心住　　如应善受持
  所住妙功德　　澄净无垢浊
  具足无减少　　清净安隐住
  淳一普鲜明　　凝定而不动
  是缘由感有　　时过复归无
  色相次第起　　种种众相生
  修行正思惟　　身心生喜乐
  于是功德住　　具足摄止观
  既能起身乐　　心亦正安隐
  自地亦他地　　功德住升进
  是今当略说　　修行广分别
  修行三摩提　　巧便随顺念
  智者开慧眼　　说名为功德
  心足处安立　　说名功德住
  圣道修对治　　说名功德进
  对治诸圣行　　功德住升进
  随地过恶心　　所起悉能除
  修行勤精进　　功德利增广
  信戒闻舍慧　　无贪恚痴根
  欲精进惭愧　　除喜不放逸
  悦乐念定舍　　正智余善法
  如是一切种　　自地离诸垢
  其功德住立　　即随地对治
  是由精进力　　助善长养心
  何于彼地中　　种数不摄受
  功德住升进　　自地以广说
  自地善根力　　他地功德生
  修行最胜义　　此相今略说
  自地既增上　　余胜净法生
  当知是功德　　他地而升进
  无量行方便　　一切诸度法
  种种对治相　　他地功德起
  谓于初念处　　三念兼已修
  暖来及顶忍　　世间第一法
  见道思惟道　　无学道亦修
  诸禅与神通　　无量无色定
  正法道品分　　究竟漏尽智
  背舍一切入　　妙愿智清净
  身念善根力　　乃起是诸法
  微妙功德相　　一切随顺生
  若住系心处　　是则自地相
  其相起在身　　亦现亦复触
  有时说近果　　有时说非近
  或复有与果　　或空无所与
  所谓近果者　　是相近边住
  若彼果不近　　当知是相远
  若使现而触　　是即与果相
  虽现而不触　　空相无功德
  譬犹无果树　　华繁而无实
  如人冷渴逼　　远见有水火
  彼终不起触　　但见相亦然
  空无功德故　　于身无快乐
  喜悦极增长　　息乐及寂止
  身心受斯乐　　是说与果相
  功德及余法　　自地与他地
  升进相回转　　四种俱亦然
  一切升进相　　殊妙种种印
  莲花众宝树　　靡丽诸器服
  光炎极显昭　　无量庄严具
  慧说为胜道　　功德住升进
  所起诸妙相　　我今当具说
  修行者谛听　　于上曼荼逻
  淳一起众相　　流光参然下
  清净如颇梨　　其光充四体
  令身极柔软　　又复从身出
  渐渐稍流下　　随其善根力
  远近无定相　　彼成曼荼逻
  势极还本处　　根本种性中
  其相三阶起　　功德住五相
  功德进五相　　不坏功德二
  半坏功德二　　尽坏功德一
  复还系心处　　住本种性已
  流散遍十方(十相生)　　功德十相上(十相各生十相)
  各复一相现　　又于流散边
  生诸深妙相　　于彼深妙际
  复生深妙相　　上下轮诸相
  亦复如是现　　于彼三阶处
  种种杂相生　　自相各已灭
  唯彼总相住　　诸杂既已无
  寂静行回转　　此三曼荼逻
  境分犹不移　　顺本功德住
  自体如前说　　入息三摩提
  遍充满下方　　出息三摩提
  遍充满上方　　二俱满十方
  正受妙甚深　　如是随意者
  是谓法自在　　清净系心处
  无法而不求　　既生有长养
  成就诸功德　　如天曼陀树
  曼陀池生长　　功德住升进
  种种众妙相　　是义我已说
  修行善守持

胜道升进第六竟

    修行方便道安般念决定分第七

  已说升进法　　所摄诸功德
  修行决定分　　是今次第说
  善于出息念　　入息俱亦然
  出入谛思惟　　分别具明了
  此则决定分　　世尊之所说
  一切诸善根　　各各尽自相
  最胜无上智　　说名为决定
  彼诸修行者　　安住决定分
  出息入息时　　正观无常相
  息法次第生　　展转更相因
  乃至众缘合　　起时不暂停
  当知和合法　　是性速朽灭
  法从因缘起　　性羸故无常
  一切众缘力　　是法乃得生
  虚妄无坚固　　速起而速灭
  非常毒所毒　　其性不久住
  修行如是观　　此则决定念
  譬如运行天　　息变疾于彼
  决定无常想　　修行趣涅槃
  非出息未灭　　而有入息生
  非入息未灭　　而有出息生
  如是谛观察　　修行决定分
  粗涩利刺生　　种种苦逼相
  谓息出与入　　一切时迫切
  于息能觉了　　具足众苦相
  如是谛思惟　　说名为决定
  自相无坚固　　寂灭空无我
  因缘力所起　　从缘起故灭
  舍利有我相　　常住不变易
  如是颠倒行　　一切悉远离
  唯作真实观　　是名为决定
  非我无牢固　　亦无有自在
  非彼出入息　　曾有觉知相
  谛知无我故　　是说为决定
  当知是智相　　相似圣行名
  此则为方便　　非彼真实行
  比丘安般念　　杂想觉所乱
  既乱心不悦　　应当从数起
  或从入息数　　或从出思数
  思乱觉观想　　由是究竟离
  慧者于入息　　系心行数时
  一入数为一　　不杂数出息
  专念不乱数　　如是乃至十
  舍彼十出息　　从此得决定
  此则说具足　　成就根本数
  更有余数法　　修行方便起
  若于根本数　　不能起决定
  促息使易觉　　方便令心生
  当舍二出息　　然后数入一
  定意心不乱　　第二数成就
  若于二方便　　犹不起决定
  乃至越十出　　然后数入一
  正念心不乱　　次第至具足
  是说修行者　　十种数成就
  如上十种法　　是则数究竟
  于上更复舍　　增数非修行
  修行如是数　　是则数法成
  成已应当舍　　复进余方便
  修行于数法　　若复不成就
  应更如前说　　还从初数起
  方便成数法　　便得决定分
  数法已成就　　慧者心随顺
  六种如前说　　修行正方便
  修行于六种　　疾生厌离想
  不乐着生死　　勤忧断烦恼
  修行心远离　　一切有为法
  当知是离欲　　清净决定分
  或说长在前　　或说短在前
  如其决定义　　今当次第说
  谓出息始起　　说言短在前
  是说非所应　　势渐增进故
  息去渐久远　　乃至未还间
  当知尽是长　　谓短则不然
  出息渐增长　　未到究竟处
  是中所观察　　说名长中短
  一心勤方便　　专念正思惟
  增长至究竟　　说名长中长
  观已风回转　　舍离余求想
  然后得决定　　此则短中长
  入息极短时　　还到所起处
  于是所观察　　说名短中短
  如是正思惟　　修行善明了
  已得决定分　　复进余方便
  满身遍觉知　　出入身行息
  修行如是觉　　则为决定分
  譬如火炽然　　光炎则长远
  薪尽火将灭　　光炎还渐短
  若更增益薪　　光炎普周遍
  势尽乃归灭　　四种风亦然
  或说于长短　　内外互立名
  或二俱长短　　如是种种说
  如彼汲深井　　瓶下转就远
  既摄令还上　　讫至复之短
  譬如仰射空　　矢发疾无阂
  其去渐高远　　势极还自下
  修行正思惟　　观察依风相
  初远然后近　　长短义亦然
  犹如牵旋轮　　屈伸互往来
  往远名为长　　来近则为短
  息风迭出入　　长短亦复然
  譬彼真谛观　　先苦而后集
  观息亦如是　　先长然后短
  若初禅息短　　第二禅息长
  以违正受义　　是说则不然
  于彼初禅中　　息风势极远
  第二禅息短　　正受渐差别
  满身遍觉知　　则依第三禅
  最后身行息　　以离毛孔故
  此说诸三昧　　随顺功德相
  修行安住彼　　不为觉想乱
  何故初禅中　　唯说长无短
  不舍诸所依　　由是故息长
  彼以觉想力　　能令息去长
  第二舍诸依　　势羸故息短
  甚深修多罗　　佛说山顶泉
  涓流势不远　　余处无来故
  如彼山顶喻　　第二依亦然
  唯从其处起　　是终不能远
  彼说健士夫　　负重而上山
  竭力令气奔　　息风急回转
  既到安隐处　　其息乃调适
  是喻说彼息　　前短而后长
  所说健士夫　　负重而上山
  以身力方便　　是乃令息长
  如彼劣方便　　不自力负重
  以无力方便　　息微故不远
  譬如壮夫射　　能令箭极远
  劣力无方便　　势弱去则近
  此喻应当知　　是说长短义
  修行细微觉　　一切谛明了
  如是十六分　　悉名为决定
  如方便升进　　分别功德住
  决定安般念　　亦应如是说
  如彼所未说　　诸余功德住
  是故我当说　　如其决定分
  观察风所起　　根本极清净
  修行妙微相　　则于是处现
  于彼究竟处　　摩尼宝三昧
  当知此功德　　方便根本生
  已说妙方便　　根本决定分
  余深正受相　　一切如前说

方便决定分竟

    修行方便胜道决定分第八

  已说方便道　　所摄决定分
  胜道决定相　　是今我当说
  修行善决定　　系心处坚固(谓尔炎也)
  身受与心法　　于是正观察
  说有六种因　　是能成就果
  成坏各三种(成熟熟亦坏也)
  修行决定相　　于是六种因
  方便善观察　　是则能次第
  疾得诸漏尽　　复更有余因
  种种成坏事　　如是多无量
  我今当略说　　何等为修行
  水种所坏相　　谓七日死尸
  毁变相已现　　彼彼诸死尸
  青黑瘀烂坏　　已坏脓血流
  恶汁相浇漫　　溃漏若分离
  杂恶极臭秽　　是悉水所坏
  内身俱亦然　　乃至劫成败
  斯由水大力　　水轮极沸涌
  大地皆瀸坏　　从彼三禅际
  周匝水来下　　洪注极漂荡
  有物皆消尽　　一切情识类
  百谷及藂林　　土地地所生
  悉为水所坏　　众生水所坏
  是皆依宿业　　如上水灾相
  无垢决定说　　此诸一切种
  皆从三昧地　　修行果所起
  当知是决定　　修行善系心
  安住三摩提　　是能于所缘
  明见彼种相　　此地熟时熟

(亦义言坏此地能坏烦恼时见坏相)

  充满境界海　　修行所见坏
  水大决定相　　火大所坏相
  今当说善听　　识类非识类
  斯亦如上说　　及自现火然
  一切皆消尽　　乃至劫成败
  世界悉灰灭　　于彼火轮处
  炽炎大火起　　亦从二禅际
  弥满悉雨火　　盛火普周遍
  世界俱洞然　　于彼三昧地
  正观思惟起　　修行见此变
  火坏决定相
  风大所坏相　　今当次第说
  如上诸种类　　悉为风所坏
  大地及须弥　　分散若粉尘
  一切尽磨灭　　是皆风大力
  上际第四禅　　下极风轮界
  灾风从彼起　　其中皆散坏
  一切风所坏　　智者见真实
  如是正思惟　　风坏决定相
  云何彼修行　　常起深忧厌
  于前见苦法　　随忆念不忘
  八苦大地狱　　各增十六分
  彼彼众苦类　　无量边地狱
  众生生彼处　　随行受众苦
  我于此恶道　　未离或牵来
  如八大地狱　　谁能尽称说
  其中无量苦　　难可得边际
  设人有百头　　头各有百舌
  欲说地狱苦　　穷劫不能尽
  如愚黠地经　　唯佛善分别
  我悉能究竟　　无有能测者
  轮回苦毒海　　往返无量劫
  颠倒不善行　　致此大苦果
  自见宿命时　　是痛曾悉经
  修行忆本苦　　便得顺涅槃
  闇冥心增上　　畜生不净业
  受痴不爱果　　种种苦报身
  九万九千种　　形类各别异
  空行水陆性　　蚑行蠕动类
  随业各受生　　宛转此剧处
  一切诸畜生　　展转相残食
  我以愚痴故　　悉增受此苦
  顾此而怀惧　　心与厌患俱
  修行深忧厌　　则于苦决定
  修行已如是　　方便生厌离
  又复自亿念　　饿鬼无量苦
  咽细如针孔　　巨身如沃焦
  于此无数劫　　饥渴极热恼
  见天降甘雨　　欲饮成炭火
  如彼四大海　　深广无崖底
  饮之令悉尽　　不能止饥渴
  裸形被长发　　状烧多罗树
  于中甚久长　　受此种种苦
  业风飘东西　　吹身令碎折
  亦如狂飙起　　摧破久枯树
  我积悭贪行　　不习惠施业
  故生饿鬼处　　受此诸苦痛
  三昧境界地　　修行思惟起
  种种别观察　　便得不放逸
  虽未断烦恼　　见此众苦迫
  楚毒深忧惧　　极厌生死苦
  既厌能离欲　　如观掌中宝
  贪欲既已离　　便速得解脱
  譬如香美食　　其中有蛊毒
  种种生死味　　杂苦亦如是
  亦如箧盛蛇　　有人负自随
  若能觉弃舍　　不为毒所中
  身亦复如是　　四大为毒蛇
  智者能舍离　　不为彼所害
  如愚执火炬　　急持即自烧
  明人知时舍　　不为火所焚
  乐着生死者　　灾炎常炽然
  若能觉舍离　　不为火所焚
  譬诸恐怖处　　亦如被烧舍
  蚖蛇毒[口*赦]聚　　生死畏过是
  譬犹空聚落　　又如彼虚器
  诸法空无我　　真实性亦然
  此三恶道中　　如是苦无量
  虽天有喜乐　　是亦为大苦
  譬彼盛火然　　贪爱炽如是
  久处在天上　　常为欲火焚
  自忆忉利天　　安处善法坐
  天女侍供养　　无量极快乐
  四园列宝树　　花果妙庄严
  随意五所欲　　一切曾悉受
  时乘白龙象　　游观诸浴池
  纵意林流间　　回顾弥日夕
  食必须陀味　　饮则甘曼陀
  充实无疑患　　受乐如大海
  又处内胜堂　　天女进音乐
  妖艳极姿态　　光色曜心目
  妙音六万种　　常闻美软声
  耳目随彼转　　令我心醉冥
  诸天发微歌　　声与弦管谐
  偃卧听音乐　　寤寐皆喜悦
  诸根回五欲　　犹如旋火轮
  须弥山王顶　　安处快自在
  百一众杂宝　　间错庄严地
  诸天共娱乐　　经历甚久长
  触彼五境界　　发动五情根
  一切悉奇特　　皆是快乐因
  诸天共器食　　随福有差别
  见此异色时　　心则生忧恼
  如是极愁惨　　犹如地狱苦
  食此不净饭　　低头内惭耻
  悔责本宿业　　令我致此苦
  诸天阿修罗　　自守贪彼利
  由是兴诤怒　　畏死大恐惧
  或为天给使　　或复极贫窭
  我虽生天上　　无异恶道苦
  于彼恒乐处　　衰死二五相
  是相及命终　　尔时最大苦
  方欲恣所乐　　五衰忽然至
  若见是相时　　愁怖不自安
  天眼卒便瞬　　浴已水着身
  一切妙境界　　其心不喜乐
  千种乐自然　　加陵频伽音
  今则寂无声　　当知七日死
  玉女悉舍去　　余天共从事
  见已生热恼　　命终入地狱
  唯有贤圣人　　了达无常变
  解脱生死苦　　凡夫为烧然
  腋下流汗出　　衣服卒垢腻
  见已大恐怖　　是则净业尽
  华冠皆鲜严　　而今忽萎熟
  身体本光泽　　一朝顿枯悴
  常所爱乐坐　　今恶不复乐
  是五恶瑞现　　当知死时至
  唯有见谛者　　无此诸恶相
  我今说比丘　　于是增厌患(梵本中无此一偈)
  诸天及天处　　衰变不久住
  明智修行者　　见斯无常变
  四宝须弥王　　真金山围绕
  修行慧眼净　　见此悉融消
  又诸大铁围　　周匝四天下
  消坏非常相　　行者见明了
  修行于天上　　如是观察己
  复于人道中　　思惟正忆念
  或时犯王法　　斩截身手足
  拷掠极楚毒　　我悉遍经历
  亲戚永别离　　悲恋为堕泪
  设集着一处　　过于四大海
  计我从本来　　人中所受生
  白骨悉积聚　　高广喻须弥
  流回三恶道　　楚毒无过者
  人天所受苦　　是亦多无量
  欲广分别说　　穷劫不能尽
  三昧境界地　　思惟所生果
  观察善明了　　修行深忧厌
  我虽舍家业　　不能成道果
  自谓为出家　　未出生死狱
  我虽弃恩爱　　名曰舍所生
  而不能免离　　痴爱业父母
  徒自为人子　　不从佛法生
  外假圣法衣　　力不离痴惑
  舍彼五欲利　　依止出家业
  而于佛法中　　不获少功德
  虽舍内贪着　　而不得出要
  四念未成就　　何从得心乐
  剃发毁形好　　而不舍憍慢
  空失欲味欢　　不得禅悦乐
  于五无间业　　未能定不起
  譬如无舟梁　　而欲越深水
  未入决定聚　　复无生天业
  无明覆心眼　　永没生死渊
  应勤业所务　　无有无作果
  作者终不丧　　修行宜善思
  常受人信施　　侵彼肌体分
  谓我有功德　　自顾空无实
  由此利养心　　翳我善功德
  深思克骨苦　　即时兴厌离
  未脱诸恶趣　　颠倒见所缚
  不向平等路　　牟尼一乘道
  得生难得趣　　诸根悉具足
  值佛兴于世　　又得闻正法
  而不舍苦器　　未渡贪欲海
  拔刀五恶贼　　是亦未摧灭
  如是正观时　　修行向解脱
  作是忧厌相　　则便生决定
  身为不净器　　三十六充满
  譬如大地种　　生育众杂类
  身为隐覆聚　　亦常假澡浴
  聚沫撮摩法　　不久必当灭
  譬如毒蛇箧　　四大箧亦然
  八万虫中舍　　常共竞侵食
  是身为灾宅　　四百四病恼
  种种苦不净　　一切内充满
  譬如故空舍　　亦如丘冢间
  坏器无坚固　　说身亦复然
  无量众恶聚　　虚妄非真实
  颠倒起贪着　　长夜婴楚毒
  将复处胞胎　　数数受生苦
  不见真实法　　生死轮常转
  始受迦罗逻　　次生泡肉段
  渐厚成肢节　　五种胞胎苦
  幽闭无日狱　　生熟藏所迫
  长养于行厕　　臭闷不净苦
  出胎受生苦　　轮转老病死
  一切诸阴起　　三相所迫切
  观色如聚沫　　受如水上泡
  想如春时炎　　众行如芭蕉
  识种犹如幻　　虚妄无真实
  逼迫是苦相　　因缘是集相
  寂静灭尽相　　出要是道相
  于此四圣谛　　修行渐观察
  思惟十六行　　解脱生死苦
  略说一切法　　自相及共相
  明知决定义　　修行正观察
  修行然慧灯　　正观四真谛
  能断恶趣分　　离诸受胎苦
  不复乐受身　　婴世之苦恼
  舍除利养行　　独处修远离
  已能修厌离　　不味生天乐
  况复着人间　　忍受诸苦痛
  观种如毒蛇　　阴为五怨贼
  自觉贪欲患　　长夜密侵害
  六根如空聚　　尘贼竞来集
  于此内外入　　修行真实观
  见爱如大河　　涅槃如彼岸
  修行慧眼净　　观法空无我
  如是知真实　　不乐处三有
  明见诸法者　　略说三成相
  及前说三坏　　方便勤修习
  次第相行义　　是今当更说
  一色种种观　　一一四种因
  决定知因果　　究竟身念处
  受与心相应　　观时惟自体
  因缘果无量　　其相同种性
  修行思惟起　　悉依所依现
  心犹不调马　　如幻如猿猴
  无量因缘相　　一切现所依
  二阴空无我　　次合观想色
  想合受与识　　行二亦如是
  次第想色受　　想色识亦然
  分别想受识　　行三同想说
  四五渐和合　　思惟坏自相
  总缘五盛阴　　七处三种观
  悦乐广境界　　还灭观生灭
  一念见真实　　具足法念处
  正观阴种相　　如化梦水月
  定慧转增广　　彼则暖法生
  其心极寂静　　总见五阴相
  自身欲火烧　　三界尽炽然
  诸相三三昧　　正向解脱门
  初观四圣谛　　真实十六行
  成就暖法已　　增进真实观
  见佛身相好　　无量诸功德
  第一寂灭法　　清净离烦恼
  圣众功德海　　甚深无崖底
  种种微妙相　　现身及境界
  见已心欢喜　　顶法具足相
  增进生法忍　　五趣现境界
  恶道炽然灭　　游息清凉处
  中住经生死　　最上唯一心
  先观无量苦　　次见苦种生
  种转增广大　　渐见苦集灭
  灭已然后观　　八圣平等道
  变灭无常相　　粗涩逼迫苦
  空寂无众生　　不自在无我
  苦种是因缘　　众缘合为集
  种生故说起　　兴果名为缘
  苦集尽故灭　　灭静说寂止
  清净离三有　　觉说为妙出
  径路是道相　　平直说正义
  进向谓之趣　　乘出故说乘
  四谛十六行　　具足真实欢
  忍法次第生　　世间第一法
  圣行正受地　　得是三决定
  见道思惟道　　次第渐究竟
  一切微妙相　　各各随地起
  成就实智慧　　具足诸功德
  当知上所说　　修行决定分
  诸有明智者　　应作正方便
  信勤勿懈怠　　常起欲惭愧
  于诸梵行者　　常当爱恭敬
  自守修净戒　　威仪令安谛
  假使得利养　　少欲知止足
  易满亦易养　　适身知量食
  亦如人膏车　　不为贪味故
  晓了一切有　　所生悉过患
  思惟善观察　　三有如火然
  如彼重病人　　信受医方疗
  闻善知识说　　观察谛思惟
  常以清净心　　系身莫放逸
  寂嘿少言说　　宴坐思实义
  丘圹林树间　　闲居修远离
  无事乐山岩　　窟中露地坐
  树下敷草叶　　如是清净住
  修行内思惟　　勤习无休懈
  专精求己利　　远离退住过
  必能得升进　　决定功德分
  修行勤方便　　具足诸善根
  我以少慧力　　略说诸法性
  如其究竟义　　十力智境界

达摩多罗禅经卷上达摩多罗禅经卷下

        东晋三藏佛陀跋陀罗译

    修行方便道不净观退分第九

  如我力所能　　已说安般念
  修行不净观　　次第应分别
  不净方便观　　思惟念退减
  明智所知相　　是今我当说
  修行初方便　　自于身少分
  背净开皮色　　观其所起相
  虽暂坏皮色　　不力勤方便
  净想还复生　　说名修行退
  不能起所应　　重令皮色坏
  净想仍不除　　亦名修行退
  修行爱欲增　　应往至冡间
  取彼不净相　　还来本处坐
  所见诸死尸　　我身亦复然
  一心内观察　　如彼冡间相
  彼为我作证　　由是得真实
  已得真实相　　不复起邪想
  如是方便修　　慧眼犹不净
  当知是颠倒　　无智痴冥聚
  若于足指缘　　闇乱心不住
  当于上系心　　观察求升进
  于上坏色处　　其心复驰乱
  当力勤精进　　方便离退过
  勿为烦恼染　　令不至解脱
  自勉勤方便　　疾得到涅槃
  自于身坏相　　系念无分散
  日夜勤修习　　莫令烦恼起
  修行微妙想　　世尊之所说
  常能守护想　　是终不退减
  具足观内身　　其念已坚固
  次应观外缘　　渐习令增广
  于外已周满　　坚固三摩提
  当知是不久　　次第尽诸漏
  如王无器甲　　安足不坚固
  而欲御怨敌　　必为彼所害
  修行于自身　　愚痴未决定
  而欲观外缘　　是必于行退
  我已说比丘　　无黠故修退
  更有余退过　　今当说善听
  当知修行退　　没在痴冥故
  或为盛烦恼　　业行所障蔽
  有人因色欲　　而起烦恼退
  于彼美艳色　　痴爱覆正念
  种种上衣服　　文彩发光泽
  璎珞庄严具　　金银众妙宝
  于先俗所乐　　修行还顾恋
  因此动欲想　　当知是必退
  形相计端严　　处处着姿好
  一切身肢节　　妄想起贪欲
  身体诸肢节　　细滑柔软触
  忆此本所更　　欲火还复炽
  或泣或言笑　　歌舞相顾盻
  彩服贯珠环　　文绣庄严具
  来去若容止　　流转行者心
  顾念是威仪　　欲起令退转
  有人情欲深　　不专在四种
  愚痴增烦恼　　遇形起淫乱
  是则极恶欲　　疾令修行退
  由是诸爱欲　　迷乱失正念
  相与想明了　　是终不退转
  谛自见内身　　次外善观察
  境界广增满　　周匝见崄岸
  不识究竟处　　修行疾退没
  于身深爱着　　怖异不能进
  修行生疑怖　　是必疾退减
  若欲离疑怖　　于身修厌患
  厌患想已生　　其心犹驰乱
  当知修行者　　是必复还退
  已说诸修行　　不净方便退
  若于胜道中　　退亦如前说

方便不净退分竟

    修行方便不净观住分第十

  我已略分别　　不净退减分
  如其住过相　　今当次第说
  修行烦恼业　　增长内充满
  不晓知度法　　愚痴缚令住
  自于身少分　　背净坏皮色
  不知升进法　　烦恼增故住
  或有渐升进　　遍身见坏相
  不能求外缘　　乐观内身住
  若于外境界　　修行心乐进
  欲去应随去　　方便勿令住
  未见究竟处　　而便中路止
  痴冥住所缚　　犹如象系树
  骨想有坚相　　其体密无间
  不次行众想　　亦不求升进
  又无厌离心　　亦不能决定
  修行虽成就　　不净奇特道
  不能起胜想　　令其身柔软
  若不柔软身　　流觉则不生
  不能生流觉　　是说修行住

不净观方便道住分竟

    修行方便道不净观升进分第十一

  已说不净观　　方便道住过
  若于胜道中　　住应如前说
  今当次第说　　不净升进法
  先总相思惟　　系念不净缘
  次住身少分　　正观察自相
  自在及外缘　　二种说无量
  行者于内身　　自在三摩提
  勤习正方便　　周满究竟处
  外缘无量者　　境界普周遍
  而于彼正受　　不能数自在
  又自观内身　　是亦说无量
  谓于自身处　　种种众多色
  筋连与肉段　　其数各五百
  提赖与揵大　　是皆有六种

提赖似果。揵大似痈。尽在腹内

  三十六动物　　三百二十骨
  节解九百分　　九十千种脉
  宣气通诸味　　三万六千道
  身中诸毛孔　　九十九万数
  身内侵食虫　　户有八十千
  内血外精气　　是二共和合
  先得迦罗逻　　身根与命根
  是身不净起　　出自迦罗逻
  结业之所起　　愚惑生乐着
  二种重烦恼　　爱恚痴冥心
  谓初受生时　　兴二颠倒想
  于内生爱欲　　于外起嗔恚
  男有如是想　　女则上相违
  不净迦罗逻　　迦罗逻起泡
  从泡生肉段　　渐厚成支节
  出胎名婴儿　　转次为童子
  如是渐增长　　盛壮谓中年
  年逝形枯悴　　朽耄日衰老
  识灭寿命终　　身坏白骨现
  青毁节节离　　消碎尽磨灭
  如是十五种　　修行观自相
  始从迦罗逻　　次第衰老死
  七日渐毁变　　乃至灰灭尽
  宿世曾修行　　先从迦罗逻
  出生至老死　　次第谛观察
  白骨青赤相　　肢节皆离散
  骨琐及羸朽　　腐坏尽磨灭
  彼诸修行者　　思惟不净念
  有从因观察　　或果方便学
  成就深妙慧　　能了是相义
  观察迦罗逻　　乃至一切分
  四大和合净　　造色五情根
  无量极微种　　一切从彼起
  当复更观察　　死后次第相
  日日渐变异　　乃至于七日
  无复有来去　　视瞻笑语言
  容止悉已灭　　舍离威仪姿
  死尸渐渐异　　其色日毁变
  青等诸不净　　如是次第现
  膖胀脓烂溃　　流漫极臭处
  种种诸虫出　　见已离色欲
  观察本所著　　已坏食不尽
  离散在处处　　能灭全具欲

上言端正非其本亦应言全具

  自见枯朽骨　　无复滋润相
  久故极粗涩　　能离细滑欲
  腐碎若尘塺　　磨灭无所有
  成就如是相　　远离有形欲(有形不必患是众生)
  五欲亦五坏　　随病而对治
  相对真实相　　修行正观察
  色变若离散　　威仪容止灭
  羸朽及磨碎　　是名五种坏
  此则自身中　　无量诸境界
  修行正忆念　　悉能得自在
  已说二无量　　自在及境界
  修行不自在　　亦已分别说
  于是不净念　　闻思与修慧
  正观开慧眼　　是说有三种
  作想有二种　　时复不想住
  俱开解思惟　　或时非开解(解即开也)
  第三性无垢　　离垢清净住
  不想不开解　　是慧修禅起
  起身寂止乐　　余二则不能
  心亦寂静乐　　是名为修慧
  滋润身柔软　　此则寂静相
  二俱不柔软　　当知非寂静
  彼二不寂静　　一则安隐住
  是说色有中　　修禅所起慧
  不净观一智　　依止十地起
  根本及未至　　亦说欲中间
  依住一界身　　境界于欲色
  化生既命终　　即灭无不净
  身净无余秽　　不能起厌患
  唯观彼生灭　　变易无常相
  胞胎所生身　　则有死尸形
  于身起净想　　不净观对治
  不求止贪欲　　思惟习厌患
  更有净对治　　不作厌患想
  方便净解脱　　智者开慧眼
  谓于不净缘　　白骨流光出
  从是次第起　　青色妙宝树
  黄赤若鲜白　　枝叶花亦然
  上服珠璎珞　　种种微妙色
  是则名修行　　净解方便相
  于彼不净身　　处处庄严现
  阶级次第上　　三昧然慧灯
  从彼一身出　　高广普周遍
  一切余身起　　庄严亦如是
  此则净解脱　　方便不净观
  若能须臾顷　　修习此胜观
  是则顺佛教　　堪受一切施
  世尊所称叹　　三界良福田
  说余一切相　　功德亦复然
  白骨青瘀想　　成就心厌离
  因是不净念　　方便度诸地
  所谓身念止　　受心法念处
  暖来及顶忍　　世间第一法
  见道及修道　　乃至漏尽智
  因是方便度　　一切功德地
  从初身念观　　乃至究竟处
  佛说不净念　　一切诸种子
  世尊说贪欲　　利入深无底
  正受对治药　　当修厌离想
  一切余烦恼　　悉能须臾治
  我已说不净　　方便升进法
  余有胜道进　　相行如前说

不净念升进分第十一竟

    修行方便道不净决定分第十二

  不净升进分　　相义我已说
  今当说修行　　不净决定分
  不为恶戒缚　　亦非业烦恼
  心不背解脱　　欢喜常志乐
  如是随顺生　　粗涩四大灭
  柔软寂止乐　　三昧于中起
  从定生智慧　　修行能厌患
  厌想已修起　　则能离有爱
  思惟离有爱　　解脱实智生
  已生解脱智　　于缚得解脱
  从是得无为　　究竟离三有
  是说名修行　　成就决定分
  天王五威相　　观相坏烦恼
  漏过渐衰薄　　由是究竟灭
  人王有五相　　兽王相亦然
  诸地相明了　　说名为决定
  动身四顾视　　奋威畅大音
  自在独游步　　师子王威相
  于此十五相　　修行生决定
  能令彼地中　　一切诸垢灭
  系念三摩提　　出诸烦恼缚
  恶露不净想　　能生厌离心
  青瘀等诸想　　修行善决了
  更有余三想　　明想及观想
  第三说空想　　修习寂灭慧
  净色及自身　　所起诸烦恼
  贪欲嗔恚痴　　从是正观灭
  此一一诸想　　各三想眷属
  能除贪欲等　　结缚使恼缠
  是诸一切想　　明审善观察
  是名修行者　　决定不净想
  久故朽白骨　　疏瘠羸相现
  破碎若尘塺(音昧)　　一切悉磨灭
  从下次第起　　方便坏所依
  净慧之所说　　修行决定相
  无量深妙种　　一切普周遍
  彼决定真实　　生如金翅鸟
  次起清净地　　平坦极庄严
  勇猛宝师子　　牛王若龙象
  此诸未曾类　　处处决定相
  始因不净生　　亦从不净长
  初起迦罗逻　　住于不净中
  观彼七日住　　念顷不暂停
  修行善明了　　是则说决定
  如是一切分　　悉能知相义
  明见彼真实　　念念有生灭
  因习诸骨想　　修行觉意生
  能起觉支想　　说名为决定
  彼诸修行者　　分别三种想
  或有始习行　　或已少习行
  或有久修习　　是悉近决定
  随彼智慧力　　趣向有差别
  初业者始起　　少习心已住
  久学能趣缘　　是说三种修
  初业名始种　　第二为长养
  最后能舍离　　说名为决定
  不净有二种　　或共或非共
  如前三眷属　　是离共不净
  闻思与修慧　　三种不净念
  于此一切种　　修行谛明了
  善分别离欲　　是说名决定

不净决定分第十二竟

    修行观界第十三

  安般不净念　　退住与升进
  决定真实相　　悉已分别说
  修行界方便　　广略差别相
  甚深微妙义　　今当次第说
  有因先修习　　安般不净念
  然后观诸界　　安乐速究竟
  自以方便度　　此苦难成就
  顶上两眉间　　系念令不乱
  寂止润泽生　　三摩提增长
  所依已柔软　　三昧安不动
  扰乱不净心　　智者悉调伏
  已随调伏心　　安住修行处
  是处起明想　　一切身分现
  初从一发始　　如其相忆念
  于一见自相　　然后总众发
  次第三十六　　自相总亦然
  佛说三十六　　各各有住处
  或时彼诸界　　合聚内观察
  犹如明眼人　　开仓见五谷
  时复有逆顺　　超越次第观
  一界藉其下　　余种悉处上
  次第相连持　　一一知其相
  杂色不杂色　　周满悉观察
  止心在一处　　境界遍十方
  处处安置已　　依是勤修习
  一发为百分　　思惟正忆念
  复于一分中　　分别五种界
  次于空界上　　识相别观察
  修行见无垢　　清净妙相生
  譬如水上泡　　明净无障翳
  是处观诸界　　各各见自相
  水湿地坚强　　风动火烧热
  虚空无障碍　　别知是识相
  青黄赤白绿　　及与颇梨色
  于此众杂色　　修行具足观
  虚空坚固相　　弥广周遍住
  难沮喻金刚　　金刚慧能坏
  于上曼荼罗　　则有熟相现
  譬如火炽然　　能破彼坚固
  或见生疑怪　　其心大恐怖
  明者能决定　　增益诸功德
  已坏虚空界　　能起升进相
  融坏若流注　　复碎如尘塺
  修行见真实　　则生解脱相
  空界既已坏　　上诸界亦然
  是则坏相上　　有余坏相起
  若复余一种　　于上观诸界
  次第普周遍　　俱坏如前说
  观察六六种　　六三及四二
  如是六十二　　世尊略说界
  色坏有三种　　刹那世极微
  无色唯二种　　无为无坏相
  修界不净念　　则能舍贪欲
  顺界方便观　　是治我慢药
  观界四无量　　除灭嗔恚毒(一无常顷名刹那)
  阿难说是言　　当修五念处
  世尊告之曰　　更有第六念
  发毛爪齿骨　　筋肉厚薄皮
  肪[月*冊]髓脑膜　　脾肾心肝肺
  胞胃大小肠　　屎尿脓涕唾
  垢污诸血泪　　黄白及痰癊
  三十六不净　　观察三种界
  是中湿相水　　火热地坚强
  诸有形色处　　内外飘动相
  出入息语言　　通利等回转
  一切总说五　　是相名风界
  眼耳鼻舌身　　毛孔咽喉空
  山岩室宅中　　内外无障碍
  如是一切种　　悉名为空界
  于彼六情根　　所生诸识种
  如是多无量　　总说名识界
  佛言应当知　　六界非有我
  不观阴界相　　计我及我所
  一切内外界　　是处意回转
  从是意行处　　三受十八种
  六触及四处　　世尊之所说
  爱慢诸烦恼　　悉于是中起
  是身众微合　　虚妄空无主
  非我非众生　　迷惑计真实
  佛告罗睺罗　　观界悉无常
  如是六种界　　说从六处起
  修习六巧便　　六时各观一
  色处悉具足　　无色唯识界
  彼种所依处　　相行地境界
  对治与所治　　如实知分数
  身中诸界种　　还自生苦恼
  譬如养毒蛇　　终为彼所害
  四大生造色　　即共造色住
  和合相间错　　还为四大坏
  不净方便观　　先于造色起
  安般方便念　　要从四大始
  若彼修行者　　增广二方便
  四大及造色　　和合等观察
  始入根本处　　彼先坏造色
  入已然后观　　所因四大坏
  定慧渐增广　　念处具成就
  和合总观察　　一切悉寂灭
  彼三十六物　　臭秽坏磨灭
  此三与十想　　修行增厌离
  佛说是根本　　能及一切恶
  四十九种法　　三昧于中起
  修行谛观察　　自身及欲界
  无量不净种　　秽恶悉充满
  众苦所逼迫　　盛火极炽然
  无常变坏相　　见已生厌离
  色界相似种　　微妙相显现
  深乐求出离　　增进厌患想
  有觉亦有观　　离欲生喜乐
  寂然入初禅　　内外悉清净
  所依及境界　　如练真金像
  自身处梵世　　于中极娱乐
  又见五支相　　身及境界现
  第二灭觉观　　内净心一处
  从定生喜乐　　四支身内现
  所依及境界　　譬如真珊瑚
  第三处离喜　　行舍念慧除
  身受乐三昧　　五支相明了
  所依青琉璃　　清净甚微妙
  缘少身无量　　诸根次第起
  第四断苦乐　　忧喜先已灭
  不苦不乐舍　　念净三摩提
  如是四支相　　现身及境界
  出息入息灭　　所依极淳白
  过色灭有对　　是说入空处
  过空相识定　　过识无所有
  过是无所有　　非想非非想
  善知诸界相　　不味亦不缚
  清净四梵行　　高广无有量
  慈悲普周遍　　喜舍亦复然
  根本四禅中　　修起五神通
  三昧现在前　　系心观自身
  作轻及软想　　渐举不令动
  境界现在前　　离地如胡麻
  稍进如大麦　　转次高四指
  此床至彼床　　渐渐能随意
  飞行及变化　　自在无障碍
  是名修行者　　微妙神通力
  系心于自身　　禅定现在前
  谛取外音声　　如其实皆闻
  系心于自身　　禅定现在前
  观他心所念　　一心皆悉知
  系心于自身　　禅定现在前
  自忆念此生　　从胎及中阴
  渐见前身事　　乃至百千劫
  一切诸所更　　如实忆念知
  系心于自身　　禅定现在前
  观察众生类　　生死及形色
  随其业果报　　中阴五道生
  修行天眼净　　一切如实见
  根本诸地中　　无量余功德
  修行心自在　　一切悉具足
  所谓八背舍　　胜处一切入
  背舍相有五　　不净与净相
  色相烦恼识　　略说是五相
  胜处先自身　　内色外少色
  若好若丑一　　外多二亦然
  内无有色想　　外观少多色
  二俱若好丑　　是前四胜处
  后四内无色　　外青黄赤白
  一切入四大　　四色与空识
  观外及内身　　一相无差别
  诸辩妙愿智　　无诤三摩提
  逆顺与超越　　无量三昧门
  明智决定观　　具足五种满
  一身二境界　　定相普周遍
  第三忆念满　　修行喜厌舍
  第四诸地满　　十处相明了
  三乘根具足　　是说第五满
  界方便成就　　久远痴冥灭
  能令意清净　　无垢如虚空
  如是诸功德　　一切悉究竟

观界第十三竟

    修行四无量三昧第十四

修行者。若欲广修慈心。先当系心所缘渐习令无量。灭除过恶心不诤竞亦无怨结。无恚清净。谓于亲中怨三种九品众生无量无数。安处十方尽三分际淳一乐行。唯除国土世界。于众生世界周普总缘成就游。行者修慈方便。先等心思惟。总缘一切众生。令心坚固灭除嗔恚而起慈心。是名总观慈无量三昧。如是总观犹为嗔恚所缚者。当于上亲修别相慈。次于中亲下亲中人怨家次第修习九品慈心。渐离嗔恚心生爱念与种种乐具。与是乐已然后于一切众生起法饶益心。修三种慈。广大慈极远慈无量慈。舍除嗔碍住仁爱心。随其所应功德善根。一切佛法皆悉与之。谓与种种法乐修种种慈。先与出家乐。次与禅定正受乐。次与菩提乐。次与寂灭乐。彼修行者本曾所更及所未更。种种乐具自得他得清净善根。乃至无上寂灭究竟无为。随其修行意所想念。无量法乐等与众生相现在前。乐想起已一一观察。以相自证便得决定。犹如明镜因物像现。慈三昧镜亦因乐事。种种乐相悉现在前。或时修行为嗔恚所乱。作是思惟。我从本来由是嗔恚多所杀害。兴诸罪逆入于恶道。于大地狱还受苦毒。或作蜂虿蜈蚣毒蛇恶龙害鬼罗刹。如是种种毒害之类。今不除灭复见烧迫。以是方便能止嗔恚。又复思惟。骂者受者彼我无常须臾不住。二俱过去恶声已灭后起。二人无故共诤。又今二人念念即灭虚妄无实。谁骂谁受何为颠倒。与空共斗计我。耳根从虚妄颠倒烦恼业起。彼人舌根亦复如是。因缘生灭谁骂谁闻。修行如是思惟时。嗔恚缚解能修慈心离垢清净。如佛说。修慈者于四念处能得决定修习增广。成就无量法门胜妙道果不复退还。是则三种方便大慈。若已离欲更修净妙离欲慈心。深心饶益增广无量得真实果。因此功德具足所愿究竟涅槃。所以者何。一切诸佛说慈为无畏。慈为一切功德之母。慈为一切功德钻燧。慈能消灭凶暴诸恶。是故修行当勤方便。修离欲大慈。悲无量者。如慈境界怨亲中人。悲亦如是。次第修习。如佛言曰。饶益众生说名慈心。除不饶益说名悲心。若先于众生起饶益心。以种种乐具悉施与之。然后观众生。唯见受乐是名慈心。若先观众生受无量苦。起除不饶益心。然后见众生除不饶益。除不饶益已受种种乐非与乐也是名悲心。见净相是慈。见虚空相是悲。乐行是慈。苦行是悲。是则差别。谓修行者见诸众生凶暴诤怒残贼杀害共相逼迫无有覆护。如是见已而起悲心为作覆护。又见众生斩截身首耳鼻肢体苦痛无量无能救者。修行见已而起悲心。又修行住悲心时。见五趣众生苦痛炽然无量烧迫。深起悲心兴救护想。如是修行悲无量善根生时无量功德相现。若见此众生受无量苦而不起悲。是则极恶无善根人。如是大悲一切诸佛本所修习。由是究竟一切智海。行者若能具足修习。当知不久必到是处

喜无量者。谓修行于慈境界。以六思念等诸善功德无量佛法。及自身成就戒定智慧一切功德。饶益众生自乐他乐尽皆与之。见一切众生得法乐已其心欢喜。其心欢喜则忧戚灭。忧戚灭已一向欣悦踊跃欢喜。念言快哉永使安乐。于一切众生欢喜时。见有乐相轻微明净成就此相。名为喜无量三昧。如佛说。修集喜等乃至识处。舍无量者。舍怨亲已等缘中品。此唯是众生无有差别。离慈悲喜唯作众生行近境界近相。是故世尊说舍种种舍各自有相。舍无量不与彼同。谓平等清净离苦乐相。舍相似相现。是名舍无量三昧。世尊说修舍无量乃至无所有处。已略说四无量相。余种种甚深相。行者应次第修习

    修行观阴第十五

若修行者。久积功德曾习禅定。少闻开示发其本缘。即能思惟观察五阴。了达深法灭除生死。犹如大风飘散重云。亦断一切魔所乐法观五阴义。今当说。修行者。内自思惟欲渡烦恼海。起离欲生润泽。自身快乐粗涩四大灭。随顺四大生。摄诸乱意能趣究竟成就智慧。若根本观处坚固明净。能起三昧离诸乱想灭除烦恼。诸微妙相于是悉现。如净妙琉璃如水净泡。行者见此明净无垢相起。善念守持心不放逸。既不放逸则熟相起。熟相起已坏相现。坏相现已唯起法想一切寂灭。如是修行法相具足成就。得增上厌离意。坚固精进不可动转。得甚深三昧坚固三昧不动三昧。修行住是三昧。能起五种明净三昧遍照五道。月光三昧日光三昧净琉璃三昧练金光三昧无垢颇梨三昧。因此五种明净三昧。复生光耀三昧遍光耀三昧无量光耀三昧

复次修行者。因五种坏相能坏诸缘。一曰穿二曰剥三曰裂四曰坏五曰灭。以是五坏相坏一切法。修行五种三昧。坏境界悉清净已。次复生五种三昧相。师子王三昧龙王三昧金翅鸟王三昧牛王三昧象王三昧。心无放逸故起此雄相。修行住此兽王三昧。各随其类一切悉摄。又三昧力男女十相起随类相。摄一切众生于是悉现。若能分别此诸三昧相而不恐怖。是则名曰于一切诸法自在功德

复次修行者于明净境界观察阴流。从一处出分为二分。如是观已还合为一。一一流中复见五相。相各别异布列境界。布列境界已还合为一。色如聚沫。受如水泡。观想如炎。行如芭蕉。观识如幻。是五虚妄欺诳之相。修行如是观已。其身安隐柔软快乐。复观流所起处无垢相现。如水净泡。渐渐增长充满其身。修行心不放逸专念受持。持已净相增广周遍覆身。如明净泡。离诸过恶更胜妙智生乃坏是相。是相既坏彼流流下远注无量。如净颇梨极知境界。极知境界已从彼摄还成曼荼罗。更有异相充满本处。然后流至十方无量世界。至十方已各住自相。尔时修行明见无量色种。犹如山水漂积聚沫。一切受相如大雨渧泡。种种诸想如春时焰行。如芭蕉无有坚实。观六识种犹如幻化。如是种种虚妄但欺诳愚夫。是名修行观阴自相。观阴自相已。复以智慧自照其身。专念观察。观察时见周匝炽然相起身处。其内有种种杂华净妙珍宝周匝绕身。又自见身种种杂宝诸功德相微妙庄严。修行见是诸相已。慧眼开广。自顾其身周遍观察。观察已复外观阴相。盛火炽然即生厌心。勇猛精进欲度生死无边苦海。修行于五阴炽然相厌离已。离欲相解脱相涅槃相一切功德相。次第起现。复次修行者具七处观。观五阴苦集灭道。复观因爱生五阴厌患出离。如是于真谛中。方便种子慧生。于是七处善修三种观义自相观成。成就决定坚固已。然后得无垢息止修慧。是慧起已境界平正淳一无杂。复次得胜妙无垢思慧决定观。五阴兴衰念念磨灭见真实相。譬如毒饭食者必死。修行观五阴三相所杂亦复如是。一念生一念苦。即一念时亦生亦住亦灭。彼念生时即与苦俱生。是故一念一念即坏。修行观五阴如是生灭破坏虚伪无常过恶。即起无常行苦行空寂行无我行穿漏法不实法速朽法破坏法。如是无常义。如修多罗广说乃至百句。修行尽行如是诸相。知诸法真实便得解脱。以贤圣地三昧想行。观此非常相便起深忧厌。见有为过患不乐三有。复次修行者若观生则非灭。若观灭则非生。如是则不生圣行。要一心一相正向解脱然后智生。是决定圣行。圣行既起一切法相寂灭无余。痴爱烦恼及诸罪垢。能转苦阴者皆悉除灭。灭已其心调伏。是见五阴无我亦无我所。以无常诸行观察苦阴。观察苦阴有八苦逼迫。于八苦相成就八行。所谓如病如痈如刺如杀无常苦空无我。四是圣行四非圣行。于苦阴决定观其真实。如是四谛十六圣行。是则修行暖法初相。于真谛地得真实慧。观察苦阴如烧铁丸亦无坚固。向涅槃背生死。不贵有不乐生。譬如群兽猎师围逼。以怖急力故超勇奔出。修行如是见生死炽然大苦围迫。以厌智力超出无碍。复次修行者。思慧生时暖法种起。息止修慧生时暖种增长。到暖自地暖相满足。息止修慧生时顶法种起。暖法生时顶种增长。到顶自地顶相满足。暖法生时忍法种起。顶法生时忍种增长。到忍自地忍相满足。复次于五阴悦可名为暖法。暖法观五阴。于三宝悦可名为顶法顶。法观十八界。于四谛悦可名为忍法忍。法观十二入。俱观三种。随彼善根一增上故说有差别。是一切尽观真谛。但忍于真实观增。暖法想增。顶法信观喜增。忍法智慧增。复次修行有三种缘。谓上下诸方三种善根。依此三缘各一增上故说(悦可本云出设)

复次三种修暖依厌离顶。依观喜忍依平等舍。亦随彼善根一增上故说。当知一种修尽成就三法

复次修行当知。譬如有人有五怨贼拔刀随逐常欲加害。前后五阴转相煎逼亦复如是。佛言。欲求阿鼻三磨耶(此是见道名也)。当作达磨摩那斯伽逻。常观真实义以圣行刀断除阴贼。莫如劣夫。不能执杖为彼所害。乃至一切贤圣皆应勤修如是正观。为现法乐故。为后世作大明故。断一切苦本故。饶益众生故。况于凡夫空无所得。而自放逸不勤修习

观五阴竟。达磨摩那斯伽逻。达磨法谓世间第一法也。摩那斯伽逻谓一经心。译者义言思惟

    修行观入第十六

六入各于境界。缚无智众生贪欲心故常起净想。修行当知。于诸根境界防制非法。摄心所缘系令不动正观六入。譬如空村离我我所不定义。是入处义牵下义。是入处义能将众生入恶道。又内入相如烧铁锵如极利剑亦如利刀。佛言。若观此相则能舍离。复次观外入恶贼劫善珍宝。若修行舍正念。开诸入门驰纵六境。六境恶贼劫夺净戒失诸功德。如鸟无两翼而欲飞空。人无两足而欲远游。修行如是。毁净戒功德故。止观两翅永不复生。欲出生死是终不能。如破瓶盛水须臾不住。破戒比丘亦复如是。三昧法水念顷不住。如天德瓶守护不坏。常出珍宝随意无尽。修行如是。不毁净戒则常出生圣功德宝。轻坏德瓶珍宝即灭。若破戒瓶则永失法宝。譬人截鼻照镜不自喜乐。破戒比丘亦复如是。内省其身心不自悦。百谷药木依地而生。诸善功德悉依净戒。如栴檀涂身能除热恼。净戒清凉能止欲火。如如意宝珠随所著处热时清凉。净戒如是。于烦恼火中能息炽然。犯戒比丘自惟罪深身逝命终必入恶道。心常忧悔死时恐怖。净戒之人心常欢喜。生无忧悔死时安乐。净戒为梯能升慧堂。戒为庄严具。亦为善戍卫。戒能将人至于涅槃。戒为良地生十善种子。教诫师水随时溉灌。信根则生。无漏阴为干。四如意为芽。慈心为枝条。少欲知足为柯叶。七觉意为华。解脱智为果。寂灭法为甘露。戒香流出一切普熏。贤圣鸟王栖宿其间。悲为重阴清凉广覆。辩才法师为蜜蜂王。和声相顾尝采精味。其树修直坚固贞实。无有虚伪谄曲腐病。是则名曰功德大树。诸修行者欲趣涅槃背三世苦向解脱城。渐次发行诸善功德息彼树下。饮法甘露止三渴患。其身安隐能至涅槃

复次戒有众多数。或一二三四或七或十二或二十一。若念念须臾顷。则有无量戒种。道共定共俱生戒。正语正业正命与心回转。观此诸戒其相各别。或淳净无垢。或轻薄明净。如是无垢戒相现于境界。修行于依缘念三处观察戒相。若涂香柔软离垢悦乐明净洁白。是所依中相。若其地平广妙华宝器。严饰之具众宝滑泽。是名修行境界中相。譬如牦牛护尾。一毛着树。守树而死。不令毛断。比丘护戒亦复如是。一微之戒守死不犯。妙相严身众好具足。犹如秋月停照虚空。修行三昧观此净相已。乃至命终无复忧悔。亦无热恼不复恐怖。安悦欢喜踊跃增长。生寂止乐粗涩四大灭。如是等名修行忆念中相。复次三种中更有杂相。娆乱障碍失念意不住。请求悔过。不善恶业守死不为。梦中无犯。增益持戒。佛说戒为花鬘涂香庄严众具。香风一方来是世界香。诸万来是戒德香。或身无手足眼耳鼻舌。一切肢节悉不貌具。或身没尘埃。或观察自身离诸尘垢。澡浴涂身名衣上服是名修行。于依缘忆念观察。尸罗种种杂相威仪。定共道共三种戒。悉已于中说此三种戒。更有无量诸深妙相。明智者当广演说。修行已观净戒。欲破诸入山者。当修二法。所谓止观。先当观离恶悦乐充满其身。粗涩四大灭柔顺四大生。趣寂止乐一心不乱。自于内身系心于入相。当善守护入相所起处。观察时白净相起。比丘见此相当善守护如佛所说。譬如伏鸡善护其子必得成就。比丘修行亦复如是。专精守护乃得成就。十二修果相现分明。修行善守护时。离诸放逸修果成就。境界净妙离诸垢污。明如宝珠亦如悬水。境界广满身处少分周遍远流。然后来还。还已一相现。复分为二分。还合为一。成曼荼逻境界。安住平正普现众相。犹如众星光耀布列然后乃坏。坏已各各流出还合为一。复周遍远流充满诸方。充满说方已复还安隐坚住。住已熟相现。熟相现已有种种众相周遍弥广。微妙器服诸奇特相悉现。境界内入空聚。外色声香味触及三世三种法。善不善无记。一切悉现观其真实。复次外六入如贼。内六入如空聚。亦说内外入为此彼岸。此十二入诸胜妙相增广无量。佛说修多罗中广说。复次修行者。于此境界熟相起起已复坏。间间有断离相。断离相流注极远停住一处。如宝瓶盛水然后还开渐见寂灭。寂灭已复有诸余一切功德相生。诸入门中常杂相流出。各各出已复于一处成曼荼逻。曼荼逻上复有自相起。起已复熟。熟已不久寂灭。然后修行复加专精。更现清净微妙禅相。现已如前次第寂灭

复次修行于诸入中更有种种妙相。于系心处决定相起。名髻中明珠。喻三昧。修行自观身作二分。众宝藏上有宝莲花。修行自见身在莲花上。众宝妙花庄严围绕。复次如世尊修多罗说六众生喻。行者于此具足观察。所谓眼为狗。走逐五色村。耳为鸟。随空声起。鼻为毒蛇。随逐香穴。舌为野干。贪五味死尸。身为输收磨罗。常乐入触海。意为猿猴。常乐游纵三世法林。若六种众生系着一处。不能自在。各游所乐。修行如是。以三昧正念系缚六根。不令自在驰散所缘。然后以清净智观法真实。痴冥凡夫六境中。贪着悕望无量恶法。如是正观悉能除灭一切众生乐着境界。自起障碍不至涅槃。是故修行欲坏生死趣涅槃者。当降伏诸根远离境界

    修行观十二因缘第十七

已说诸对治及所治。愚痴对治。是应分别。一切诸佛所设缘起。灭除痴冥生如实智。有甚深微妙随顺功德。今当略说。令诸修行功德增益。灭除愚痴观察缘起。远离断常二边诸想。知因缘和合有为法生。亦能降伏迷醉外道牵令随顺。第一空法慧眼明净无明悉灭。修行观缘起有四种。一名连缚。二名流注。三名分段四名刹那。连缚有六种。一曰生二曰分三曰趣四曰生门五曰刹那六曰成坏。生者从死阴次起中阴。中阴次起生阴。中阴众生无明昏乱愚痴所盲。造作有业。中阴众生见男女和合。无明增故生颠倒想。或生害想。或生爱想。欲与女俱者于男生害心。然后自见与彼和合。尔时欲心迷醉是名爱起身。见和合不净谓为己有。是名慢起身。因母饮食而得增长。令身敷起。是名食起身。四大与迦罗逻。俱生得报身。是名四大起身。结业为方便二支既过。次第识种生。是名种子识。始处迦罗逻时。其心沉没少所识知识不明利。是名为生得迦罗逻。已识明利故是名为识。是名生连缚也。分段者。从迦罗逻次起疱肉段。坚厚肢节。婴儿童子。盛壮衰分老分次第生。是名分连缚也。趣者。谓遍至诸趣。修行观诸趣相。是名趣连缚也。生门者。谓四生相续轮回不绝。是名生门连缚也。刹那者。观五阴。念念相续生灭不断。是名刹那连缚也。成坏者。一切境界起灭劫数始终。修行观此成坏相续。名为成坏连缚也。是则修行观缘起连缚也。流注者。谓修行观刹那流至怛刹那乃至罗婆摩睺路妒。是名流注迦罗逻分。流注七日疱肉段坚厚乃至衰老分。是名流注起分住分起缘分入分出分方便分。一切正受巧便流注次第起尽名流注。诸趣回转如旋火轮是名流注。如是一切无量流注。是则修行观缘起。流注分段者。修行观察从分至分故说分段能如是知则于缘起成就。谓无明增上。犹如盲人无有见相。如大黑冥远离光明。或于前无见。或于后无见。是则偏盲。若前后无见是二俱盲。若离二盲则舍痴冥。得明净慧眼。如是苦集灭道佛法僧宝无知。是名十种痴。十种痴灭名为十种慧。佛说无明为初因种三种业。若修行不知无明过患。则种三种业。业起已从是生识。诸识如幻种种悉现。从识相续起名色。于彼一身而有二相。譬如虚软沮烂之物。内有诸虫令外动摇。亦如野蚕初作茧膜。名色二相亦复如是。乃至诸根未成。说为名色二相。诸根既开名为六入。诸根始开未有所作。于触愚痴不知适与不适。如雨渧注水水则泡起。情尘生触亦复如是。外刺刺身触从中起。亦如然灯油炷所成。是名修行观尔炎触相。触相起已次第生受。譬如水泡三种相现。若分别诸根则有五受。受起已次生渴爱。譬如舌舐蜜涂刀。刃爱增诸烦恼名为取。取次生有。有三种业。业起当来果故名为有。已种生而未受名为未来生。生已熟谓为老死。二支说未来生时生相增上。佛说识分未来识生时名为生。名色六入触受名为老死。前世爱取有能集今有故。于此生为过去。爱取是烦恼分故说为无明。有则是行。现在三支能种来生过去二枝。转生死轮。彼众生轮转以无明覆故。八现在二过去二未来世差别故如是分别。当知转时一切皆十二

复次更有余分因缘。今当说。从迦罗逻疱肉段坚厚肢节婴儿童子壮年衰分老死分。于是十种分观察缘起。复次于起住起缘入出方便分乃至余一切分悉观缘起。复次是事起故是事起。谓彼眼色能起眼识。三事和合触生受想思。是名修行异种观缘起。复次修行方便观诸入缘起。以明净境界。自向观诸入门。如是见已各观自相处。破诸入山无量积聚熟相现已。流注十方极智境界。到彼观察明智升进者。修住巧便。尔时闻思修慧。熟相坏相次第而起。诸余升进义如前入处说。复次是事有故是事有。是事起故是事起。谓修行者先坏内身次观外色。犹如照镜因物像现。如是所依相起外相亦起也

复次修行于诸不净观。其缘起先于方便处。系念令坚固。然后于肢节分解观其缘起。起明相已无明相坏。依脚骨有[跳-兆+專]骨髀骨跨骨肩骨颈骨头骨充满十方。有漏业相普现。于下诸杂不净相阶级次第起。复次修行观四因能生众苦。展转因邻近因周普因不共因。复次修行观果从生因生从有因有从取因。如是乃至行从无明因。行是果亦是因。从因推果。还至老死亦如是。若于无明求因必大恐怖而起断见。无智闇冥余明甚微犹如萤火。如是犹复求因不已。自见唯与大黑闇俱。世尊说言。由不正思惟众生。若与是俱则轮转生死。无明缚故有轮常转。无明为本余支所作各有相现。一切有支轮无明最自在。自在力所转如奴属其主。是无故是不作。是灭故是不转。当知余枝皆如是说。死有四种。渐渐死顿死。行尽死刹那死。又说三种无常。一刹那无常。二分段无常。三种类无常。修行了此无常则远离四魔破坏无明。明相显现如明净灯能消众冥。乃至老死灭。诸明相起亦复如是。破坏无明诸积聚已。成就一相净妙境界。行者身体柔软光泽。光泽已身极明净如明镜像。如是相现明净观己。身内众物各各自相一切显现。如是观成就名曰于界得度。何以故。有五种痴五种对治相。一界二入三阴四卑贱五垢污。是名五种痴。或观界得度。或复观阴观入观彼增功德。观第一义而得度者。是名五种对治也

复次修行者入快净琉璃三昧。于明净境界观缘起支。观缘起枝时。便生易见想。如说。阿难白佛言。缘起易见。佛告阿难。十二缘起甚深无底难见难知。汝欲毁坏我三阿僧祇劫甚深微妙难得之果。云何欣悦而说是言。是深妙观。我今当度。汝当随我观佛境界。佛境界海浮漂。外道无智闇冥。二边愚痴离尔炎境界所不能入。声闻辟支佛虽能少入不得其底。尔时世尊说是语已。即入甚深微妙尔炎住三昧自在正受。正受境界有三师子王。师子王上各有七宝池。七宝池中各有七宝莲华。七宝莲花上皆有坐佛。放大光明极声闻境界。然后乃住是诸声闻。从初发心至最后身。所种善根及诸缘起一切悉现。从是复起三师子王。师子王上各有七宝池。七宝池中各有七宝莲花。七宝莲花上皆有坐佛。放大光明极辟支佛境界。然后乃住诸辟支佛。从初发心乃至究竟。所种善根及诸缘起一切悉现。从是复起无量师子王。师子王上各有七宝池。七宝池中各有七宝莲花。一一花上皆有坐佛。普放光明极菩萨境界。然后乃住是诸菩萨。从初发心至金刚座。所修善根一切功德。若业若果及诸缘起一切悉现从是复起无量师子。王师子王上各有七宝池。七宝池中各有七宝莲花。一一花上皆有坐。佛放大光明普照佛法甚深缘起一切悉现。尔时佛以神力示阿难佛之境界已。语阿难言尔炎中更有无量无边诸佛境界佛智所行如是甚深微妙境界。云何欣悦而言易见。汝智浅不及谓为易见耳。如上尔炎境界无量诸法现在前已。然后乃坏一切皆空清净寂灭。寂灭已复观胜妙。尔炎起佛法。身渐渐广大周满十方。无量法宝充满法身。法身光明无有边际。不共智慧所行境界。一切佛法甚深缘起悉现在前。然后乃坏一切皆空清净寂灭无有处所。犹如虚空无所依止。如宝入手名为得宝。修果如是名决定相。阿难如来境界不可思议。我今为汝示少少耳。阿难见佛境界欢喜踊跃。白佛言甚深世尊。世尊尔炎境界难得其底。若我先知如来境界如是深妙者。宁使我身碎如胡麻。要当究竟佛法彼岸。如是一切名修行观缘起。分叚刹那者。三世一刹那。一刹那三世。法未起名未来。起时名现在。已起名过去。一刹那生即一刹那。苦与无常俱故。当知众行刹那顷不住。亦无所从来去。亦无所至虽转亦无所去。去亦无积聚。一刹那起一刹那灭。刹那如一念。一念如刹那。前刹那聚已灭。灭时与后起。随顺四缘具足。后刹那起修行境界。观一刹那间。有无量微尘无量微尘。一一刹那次第相续犹如连珠。譬如四善射人俱放四箭。有一人健行箭未至地。能就空中接取四箭不令落地。地神迅疾复过于是。虚空神疾过于地神。日月天疾过虚空天。如是健行天疾倍过日月。当知诸行无常迅过于是不可譬喻。如修行观迦罗逻七日住分有无量刹那。当知余一切分亦如是。如是观已离诸愚痴增益明慧。如是无量名修行观缘起刹那

复次修行初入正受名为连缚境界。增长名为流注方便境界。安住名为分段境界。渐灭名为刹那

复次已说四种别相观缘起。佛说总缘起。今当说二支种二支熟二支起二支牵。所种二支生长二支成就二支受二支。作人二支田二支寄者二支所寄二支。受寄者是说名有支。修行观缘起。或五阴或四阴。五阴欲色界。四阴无色界无常空等诸行。于阴决定真实。决定真实已。决定相现在前。是事有故是事有。是事起故是事起。是事无故是事无。是灭故是不作。譬如有钻有燧。有人方便烟火。乃出因薪炽然。亦如因树有荫因日有光因灯有焰皆从缘起。无明不言我能生行。行亦不言我从无明生。当知一切有支皆如是。是空法寂灭法无所有法。作者不可得。但有无明诸行和合有漏法生。受为轴转有支轮生诸结缚。诸结中爱支增。诸缚中取支增。诸使中识支增。诸缠中无明增。向生结增。受生缚增。诸识漂利使增。于境界愚痴烦恼增。如是烦恼业缚能转生。果有轮常转漂。无智众生随义增故。说有差别。当知诸分皆有结缚使缠

复次修行六种观十二缘起。于十二支随顺义说。谓安般念观业支有支。以出息入息是身行。觉观是口行。想思是意行。是故安般念是彼对治。界方便观。观识支生支。识增上故处胎。识于诸界增上说七识界。是故界方便观是彼对治。阴方便观观名色支老死支。是故阴方便观是彼对治。破诸入出方便观。观六入支触支。是故入方便观是彼对治。缘起方便观。观无明支受支。是故缘起方便观。是彼对治。何以故受及无明。是诸烦恼根本。是故智慧是彼对治。爱取二支染着净故不净是对治

复次修行观十二缘。或时从因度或时从果度。或从无明行乃至老死。或观识乃至老死。或三事和合生触。触生受受生爱爱生取乃至老死。或从爱取有生老死。或从老死乃至无明。或观老死乃至识。如佛城喻经说

复次修行于四念处观十二支各增上。身念处观六入支。受念处观受支。心念处观识名色支。法念处总观余支。说此义已而说赞偈曰

  方便治地行　　乃至究竟处
  无上法施主　　说是传至今
  我从彼胜闻　　撰说深妙义
  章句庄严集　　欲令法久住
  佛法深无底　　修行亦无边
  以我少智力　　宣扬无量法
  是深非所测　　如蚊尝大海
  唯彼已度者　　然后乃究竟

六十二界六种六情六尘六识六界六觉。谓贪恚痴三不净觉反是三净觉也。苦乐不苦不乐忧喜舍六

三欲色无色界。又色无色灭界三世法。软中上法。善不善无记法。学无学非学非无学四。二者食非食漏无漏。依欲依出要有为无为。三十六不净。次第发毛爪齿薄皮厚皮筋肉骨髓脾肾心肝肺小肠大肠胃胞屎尿垢污泪涕唾脓血黄白痰癊肪[月*冊]脑膜

刹那数。百二十刹那名一怛刹那。六十怛刹那名一罗婆。三十罗婆名一摩睺路妒。三十摩睺路妒名一日一夜。一岁中唯二时二日。三十摩睺路妒昼夜等。谓羯提月白分八日八月名羯提。后半月名为白分。陛舍佉月白分八日二月名陛舍佉。后半月名白分。此二时二日昼夜。各十五摩睺路妒。从是后罗婆流或昼减夜增。或夜减昼增。名为流昼夜等。各三十摩睺路妒

(谓羯提月白分八日。陛舍佉月白分八日。羯提月者。谓七月十六日。至八月十五日。是八月名后半月名白分。陛舍佉月者。正月十六日。至二月十五日。是二月名后半月。名白分此二时二日。昼夜各三十摩睺路妒。从是后罗婆流或昼减夜增。或夜减昼增。名为流)

达摩多罗禅经卷下


大乘百福相经

    No. 661 [No. 662]

大乘百福相经

        大唐天竺三藏地婆诃罗译

如是我闻。一时佛在舍卫国普妙宫中。坐宝庄严师子之座。与大比丘僧千二百五十人俱。菩萨摩诃萨无央数众。恭敬围绕。瞻仰尊颜身心不动。尔时文殊师利菩萨。于大众中承佛威神。从座而起。偏袒右肩右膝着地。合掌向佛而作是言。世尊。一切众生根性差别欲乐不同。如来一音随类演说。种种无量咸蒙利益。如是所说大法言音。皆以如来福德成就。何等名为如来福德。所言福德其量云何。惟愿为我解说其义。饶益无数百千众生

尔时世尊告文殊师利菩萨言。善男子。汝已超过声闻及辟支佛。能以大慧大悲请问如来如是之义。谛听谛听善思念之。吾当为汝分别解说。文殊师利。假使阎浮提一切众生行十善道所有福德总为一聚。如是积数满百千倍。成一转轮圣王福德之量。文殊师利。转轮圣王成就七宝具足千子。何谓七宝。一者金轮宝。二者象宝。三者马宝。四者珠宝。五者女宝。六者主藏宝。七者主兵宝。千子皆悉端正勇健能伏怨敌。如是名为转轮圣王所有福德。文殊师利假使四天下一切众生。皆悉成就转轮圣王所有福德。如是积数满百千倍。成一帝释福德之量。文殊师利。假使四天下一切众生。皆悉成就帝释所有福德。如是积数满百千倍。成一第六他化自在天王福德之量。文殊师利。假使四天下一切众生。皆悉成就魔王福德。如是积数满百千倍。成一小千世界主初禅梵王福德之量。文殊师利。假使小千世界一切众生。皆悉成就初禅梵王所有福德。如是积数满百千倍。成一中千世界主二禅梵王福德之量。文殊师利。假使中千世界一切众生。皆悉成就二禅梵王所有福德。如是积数满百千倍。成一三千大千世界主第四禅梵王摩醯首罗福德之量。文殊师利。摩醯首罗有大福德。有大智慧。有大威神。非少善根而得成就。何以故。如劫烧已将更成立于第四禅降澍大雨经五中劫。其水积满三千大千。上至梵世。一一雨渧。摩醯首罗悉能知之。文殊师利。假使三千大千世界一切众生。皆悉成就摩醯首罗所有福德。如是积数满百千倍。成一独出辟支福德之量。文殊师利。且置如是三千世界。假使十方诸佛国土一切众生。皆悉成就辟支所有福德。如是积数乃至无量无边亿百千倍。成一最后身菩萨福德之量

文殊师利。如是最后身菩萨及十方尽虚空界一切众生。卵生胎生湿生化生。有色无色。有想无想非有想非无想。如是等众生。皆悉成就最后身菩萨所有福德。如是积数乃至无量无边亿百千倍。成如来身一毛孔中福德之量。文殊师利。当知如来身诸毛孔。其数正有九千九亿。一一皆具无量福德。如上所说。文殊师利。诸佛如来一一毛孔所有福德。乃至积数无量无边亿百千倍。以是福德成如来身一随好福。文殊师利。如是佛身所有随好。略说其数有八十种。一者肉髻高显无能见顶。二者鼻高修直孔不外现。三者眉如初月又绀青色。四者耳轮埵成。五者身坚如那罗延。六者骨节相连如钩锁。七者行时去地四寸印文成就。八者身回如象王。九者甲如赤铜薄而光泽。十者膝骨圆好。十一者身常鲜洁。十二者肤体柔软。十三者身体端直。十四者手指纤长。十五者指文严丽。十六者筋脉潜隐。十七者身色润好。十八者踝不露现。十九者身不逶迤。二十者身相圆满。二十一者识清净。二十二者威仪备足。二十三者住处安隐无能动摇。二十四者威振一切。二十五者众生乐见。二十六者面不狭长。二十七者容色不挠。二十八者面相姝广。二十九者唇色如频婆果。三十者音声深远。三十一者脐深圆好。三十二者脐分右旋。三十三者手足圆满。三十四者手足从心所作。三十五者手足文明彻。三十六者手足文不断。三十七者手足光有五彩。三十八者众生见皆喜悦。三十九者面如满月。四十者先意与语。四十一者毛孔出无上香。四十二者足下平满。四十三者威容如师子王。四十四者进止如象王。四十五者行步如鹅王。四十六者首如摩陀那。四十七者身极端正。四十八者一切声相具足。四十九者牙利鲜白。五十者舌色如赤铜。五十一者舌薄而长。五十二者诸根清净。五十三者身色光洁。五十四者手足润泽。五十五者手足有德相。五十六者面门相具。五十七者手足掌如红莲。五十八者腹不现。五十九者脐不出。六十者腰细称形。六十一者身毛上靡。六十二者身持重。六十三者臆前有室利婆瑳像。六十四者身相洪大。六十五者手足柔软。六十六者圆光一寻。六十七者常光照身。六十八者等视众生。六十九者不轻众生。七十者应众生音声不增不减。七十一者说法不着。七十二者一音普遍同众生语。七十三者说法有因缘。七十四者一切众生无能尽观。七十五者行顺于右。七十六者无嗔状。七十七者发长好。七十八者发不乱。七十九者发右旋。八十者发青绀

文殊师利。如上所说。名为如来随好福德积数满足无量无边亿百千倍。成如来身随相一文福德之量如是。随相复有八十。一者梵王像二者帝释像。三者提头赖吒像。四者毗楼勒叉像。五者毗楼博叉像。六者毗沙门像。七者水天像。八者日天像。九者月天像。十者火天像。十一者风天像。十二者龙王像。十三者仙人像。十四者童男像。十五者童女像。十六者贤圣座像。十七者宝幢像。十八者牛王像。十九者功德天女像。二十者山王像。二十一者摩竭大鱼像。二十二者金翅鸟王像。二十三者彪王像。二十四者马王像。二十五者孔雀王像。二十六者共命鸟像。二十七者迦陵频伽像。二十八者翡翠像。二十九者鹦鹉像。三十者蹠俱罗鸟像。三十一者鹅王像。三十二者鸠鸽像。三十三者象王像。三十四者宫殿像。三十五者摩尼珠像。三十六者璎珞像。三十七者大海像。三十八者莲华像。三十九者难陀跋多像。四十者浴池像。四十一者灵茅像。四十二者萨底迦像。四十三者华鬘像。四十四者宝冠像。四十五者尸利婆瑳像。四十六者伞盖像。四十七者江河像。四十八者云天像。四十九者宝剑像。五十者长钩像。五十一者频婆果树像。五十二者指环像。五十三者耳珰像。五十四者金刚杵像。五十五者戈戟像。五十六者矛槊像。五十七者长刀像。五十八者斗轮像。五十九者弓矢像。六十者钺斧像。六十一者罥索像。六十二者耒耜像。六十三者药草像。六十四者乳牛像。六十五者野牛像。六十六者羖羊像。六十七者白拂像。六十八者天鼓像。六十九者金椎像。七十者商佉像。七十一者宝镜像。七十二者大龟像。七十三者冲刃像。七十四者华瓶像。七十五者粉米像。七十六者华树像。七十七者果树像。七十八者雁王像。七十九者轮中师子像。八十者鹿王像

文殊师利。如上所说。名为如来随相福德。积数满足无量无边亿百千倍合成如来身之一相。如来身相有三十二。一者足下安平。二者手足千辐轮网。三者手足指纤长。四者手足柔软如兜罗绵。五者足跟满好。六者手足指网缦。七者足趺高平与跟相称。八者[跳-兆+專]佣长如伊尼鹿王。九者平身端立垂手过膝。十者阴藏不现。十一者身纵广等如尼拘陀树。十二者一毛孔有一毛生。十三者身毛上靡青色柔软而右旋。十四者身色微妙胜阎浮金。十五者身光一丈。十六者皮薄细滑不受尘垢。十七者两肩圆好。十八者身广端正。十九者臆如师子王。二十者两腋下满。二十一者牙白而大。二十二者四十齿。二十三者齿白齐密而根深。二十四者七处满足。二十五者方颊如师子王。二十六者味中得上味。咽中二处津液流出。二十七者舌软薄能覆面至发际。二十八者梵音深远如迦陵伽。二十九者眼如优钵罗华。三十者眼睫如牛王。三十一者眉间白毫色如珂雪。三十二者顶肉骨成

文殊师利。如是所说。名为如来三十二相。所有福德积数满足。无量无边阿僧祇不可度量。不可思议。不可说倍。合成如来大法言音。文殊师利。如是诸佛大法言音。能被无量无边阿僧祇世界。一切众生意乐差别。随其类解说法教化。文殊师利。诸佛如来所有言音。具足如是无量功德。普遍世界利益众生亦复如是。文殊师利。如上所说福德之量不可思议。不与声闻辟支佛共。何以故。如是福德从施戒修大悲大慧方便力等诸功德生。是故不与声闻辟支佛共。文殊师利。有二种法生如来身。何等为二。一者胜愿力。二者方便力。以此二法生如来身。乃至音声相好说法所行。皆从二因而得成就。文殊师利。如来为欲怜愍利益安乐诸众生故出现于世。而诸众生若干种性欲乐不同。随其差别现种种相说法教化。示其所行得入佛法

尔时文殊师利菩萨。闻佛所说诸功德已白佛言。世尊。我于今者得大善利。能知如来为无等等为无上上。为诸众生作大依止。清净无染犹如虚空。我今得值甚为希有。佛说是经已。文殊师利菩萨等。并诸比丘。合掌信受欢喜奉行大乘百福相经


大乘百福庄严相经

    No. 662 [No. 661]

大乘百福庄严相经

        大唐天竺三藏地婆诃罗再译

如是我闻。一时婆伽婆在舍卫大城普妙宫殿。为欲化导无量众生。坐宝庄严师子之座。与大比丘等千二百五十人俱。菩萨摩诃萨无央数众。皆共恭敬周匝围绕。瞻仰世尊身心不动。时彼众中有大菩萨。名文殊师利。承佛威神从座而起。偏袒右肩右膝着地。合掌向佛而作是言。世尊。我闻如来有大福聚。大福聚者其量云何。惟愿世尊为我解说。利益无量百千众生。令其意乐咸得满足

尔时世尊告文殊师利言。善男子。汝已超过一切声闻及辟支佛。能以智慧大悲之心。为诸众生请问如来如是之义。谛听谛听善思念之。吾当为汝分别解说

文殊师利。如一阎浮提所有众生十善福聚。如是福聚挍计筹量。数满百倍。成一转轮圣王王四天下。自在福聚七宝成就千子具足。何谓七宝。一者金轮宝。二者白象宝。三者绀马宝。四者神珠宝。五者玉女宝。六者主藏宝。七者主兵宝。彼之千子各各威猛端正勇健能破怨敌。文殊师利。如是名为转轮圣王所有福聚

文殊师利。如是转轮圣王及四天下。一切众生所有福聚。如是福聚挍计筹量复满百倍。成一忉利天王帝释福聚

文殊师利。如是忉利天王及四天下一切众生所有福聚。如是福聚挍计筹量复满百倍。成一欲界最第六天教受护持魔王福聚

文殊师利。如是第六自在天魔及四天下一切众生所有福聚。如是福聚挍计筹量满百千倍。成一慈心照察小千世界初禅梵王所有福聚

文殊师利。如是慈心照察小千世界初禅梵王及彼世界一切众生所有福聚。如是福聚挍计筹量复百千倍。成一中千世界二禅梵王所有福聚

文殊师利。如是中千世界二禅梵王。及彼世界一切众生所有福聚。如是福聚挍计筹量复百千倍。成一大千世界慈心照察第四禅内摩醯首罗所有福聚

文殊师利。是大千主摩醯首罗。非少善根之所成就。何以故。摩醯首罗。有大智慧大威神故。如器世间灾火焚已。将更成立。于第四禅天降大雨。经五中劫不断不绝。其水遍彼大千界。上至梵世无缺无减如是雨渧彼大千主摩醯首罗悉能得知

文殊师利。如是摩醯首罗所有福聚。如是福聚名为梵福

文殊师利。如是三千大千世界主摩醯首罗。及彼世界。一切众生所有福聚。如是福聚挍计筹量。无量无边亿百千倍。成一独出大辟支佛所有福聚

文殊师利。且置如是一大千界。假使十方诸佛世界一切众生及辟支佛所有福聚。如是福聚挍计筹量。至于无量亿百千倍。成一最后生身菩萨福聚

文殊师利。如是最后生身菩萨福聚。及彼十方尽虚空际。所有世界一切众生。若卵生若胎生。若湿生若化生。若有色若无色。若有想若无想。若非有想非无想。彼诸众生所有福聚。如是福聚挍计筹量。至于无量亿百千倍。成彼如来身一毛孔所有福聚。文殊师利。如是如来身诸毛孔。其数乃有九万九千。如是毛孔一一皆具如上所说无量福聚

文殊师利。如是如来一切毛孔所有福聚。如是福聚挍计筹量。复至无量亿百千倍。成如来身随好之中一好福聚

文殊师利。如是如来身诸随好。略说其数有八十种。何谓八十。一者首分圆满。二者发际严好。三者发色青绀。四者发香芬馥。五者发甚柔软。六者发不纷乱。七者发不稀概。八者发常增长。九者发本波委。十者发端螺旋。十一者发状华轮。十二者发如德字。十三者面部平正。十四者毫分充足。十五者眉色青绀。十六者眉不杂乱。十七者两目美好。十八者两目修广。十九者两目清净。二十者两目明朗。二十一者目色绀艳如青莲花。二十二者耳甚长好。二十三者耳无缺减。二十四者耳无过恶。二十五者鼻修高直。二十六者两颊满足。二十七者颊无缺减。二十八者颊无过恶。二十九者牙甚圆正。三十者其牙均等。三十一者唇色赤好如频婆果。三十二者舌赤柔软。三十三者声如雷震。三十四者其音朗彻。三十五者身普满足。三十六者身肉丰好。三十七者身肉平正。三十八者身肉柔软。三十九者身渐佣直。四十者身分相称。四十一者身极圆好。四十二者身无缺减。四十三者其身柔软。四十四者其身清洁。四十五者其身轻妙。四十六者身不动摇。四十七者身极端严。四十八者身无疵秽。四十九者身光破闇。五十者其腹美好。五十一者其腹圆满。五十二者其腹不现。五十三者其脐深密。五十四者其脐不曲。五十五者脐称其位。五十六者腋下平满。五十七者臂肘纤长。五十八者手指圆满。五十九者手指纤美。六十者手文深好。六十一者手文径彻。六十二者手文不乱。六十三者手文润泽。六十四者文无粗细。六十五者文端纤锐。六十六者膝轮圆广。六十七者足跟佣满。六十八者足善按地。六十九者行顺于右。七十者行如象王。七十一者行如牛王。七十二者行如鹅王。七十三者行步威猛如师子王。七十四者手足甲端微悉高起。七十五者手足等甲如赤铜色。七十六者手足等甲并皆润泽。七十七者筋脉不现。七十八者支节密致。七十九者诸根无染。八十者见者欢喜。文殊师利。如向所说。此八十种是名如来随好福聚

文殊师利。如是如来八十随好所有福聚。如是福聚挍计筹量。复满无量亿百千倍。成如来身手足等中随相之文一文福聚。文殊师利如是如来手足等中随相之文有八十种。何谓八十。一者梵王像。二者天帝像。三者提头赖吒像。四者毗楼勒叉像。五者毗楼博叉像。六者毗沙门像。七者功德天女像。八者日天子像。九者月天子像。十者水天像。十一者火天像。十二者风天像。十三者云天像。十四者大仙像。十五者山王像。十六者童男像。十七者童女像。十八者宝幢像。十九者伞盖像。二十者宝冠像。二十一者花鬘像。二十二者珠璎像。二十三者耳珰像。二十四者臂印像。二十五者宝钏像。二十六者指环像。二十七者宝镜像。二十八者白拂像。二十九者德字像。三十者花瓶像。三十一者摩尼像。三十二者宝剑像。三十三者金刚杵像。三十四者弓弧像。三十五者箭矢像。三十六者戈戟像。三十七者矛槊像。三十八者钺斧像。三十九者罥索像。四十者长钩像。四十一者冲刃像。四十二者金锤像。四十三者天棒像。四十四者天鼓像。四十五者金螺像。四十六者腰鼓像。四十七者花轮像。四十八者宫殿像。四十九者宝座像。五十者浴池像。五十一者莲花像。五十二者粉米像。五十三者麰麦像。五十四者药草像。五十五者灵茅像。五十六者花树像。五十七者果树像。五十八者金翅鸟像。五十九者迦陵频伽像。六十者共命鸟像。六十一者孔雀像。六十二者鸠鸽像。六十三者雁王像。六十四者青雀像。六十五者鹦鹉像。六十六者翠鸟像。六十七者轮中师子像。六十八者雪山白象像。六十九者龙王像。七十者象王像。七十一者马王像。七十二者鹿王像。七十三者牛王像。七十四者野牛像。七十五者牸牛像。七十六者羖羊像。七十七者大鳌像。七十八者大龟像。七十九者鱼王像。八十者螺王像。文殊师利。如是所说此八十种。是名如来随相福聚

文殊师利。如是如来八十随相所有福聚。如是福聚挍计筹量。复满无量亿百千倍。成如来身三十二种大人相中一相福聚。文殊师利。如是如来大人之相。其数乃有三十二种。何谓三十二种大人之相。一者顶有肉髻圆好高胜。二者发绀青色其毛右旋。三者其额广大平正严好。四者眉间毫相白逾珂雪。五者目睫青致犹如牛王。六者口四十齿无有增减。七者其齿齐密无有疏缺。八者其齿白净无有垢黑。九者口有四牙其色鲜洁。十者其颔圆满如师子王。十一者其舌柔薄广大红赤。十二者于诸味中而得上味。十三者其语雷震得梵音声。十四者缺骨不现其处平满。十五者两肩圆正无有缺减。十六者垂申两臂手摩其膝。十七者其身上分如师子王。十八者身所有毛皆悉上靡。十九者身相圆满如尼拘陀树。二十者其身高妙满足七肘。二十一者身体皮肤皆作金色。二十二者一一毛孔有一毛生。二十三者势峰藏匿隐密不现。二十四者两髀圆正其肉满足。二十五者[跳-兆+專]相严好如伊尼鹿王。二十六者两足丰满无诸缺减。二十七者两足掌下皆悉平满。二十八者足肤骨肉皆悉隆起。二十九者两手两足皆悉柔软。三十者两手两足皆有网鞔。三十一者两手两足皆悉纤长。三十二者两手两足皆有轮相。文殊师利。如是所说三十二种大人之相。是名如来正相福聚

文殊师利。如是如来三十二种大人福聚。如是福聚校计筹量。复满无量阿僧祇倍。不可量倍不思议倍。始成如来大法圆螺。随类教化一切众生音声福聚

文殊师利。如是如来大法圆螺。能随彼彼无量无边阿僧祇等无量世界一切众生所有意乐。如其意乐能悉遍满。随其类音说法教化。利益安乐如是众生

文殊师利。如彼如来所有音声。能有如是无量势力。如来威光亦复如是等彼音声能有如是无量势力

文殊师利。如彼如来所有威光。能有如是无量势力。如来之身亦复如是。等彼威光能有如是无量势力

文殊师利。如上所说。如是福聚不可思议不可算数。非诸声闻辟支佛等之所能得。何以故。如是福聚从大智慧及大慈悲普遍一切最上愿力所生起故。是故声闻辟支佛等所不能得

文殊师利。如来如是妙色之身。悉是一切最胜清净施戒修等及二因缘之所成立。何等为二。一者如来最胜愿力。二者如来化导善巧。何谓如来化导善巧。谓诸众生未种善根令种善根。已种善根令彼成熟。已成熟者令得解脱。由是二种因缘力故。是故获得妙色之身。文殊师利。如是如来妙色之身。由二因缘之所成就。如来音声亦复如是。以二因缘而得成就

文殊师利。如是如来所有音声。以二因缘之所成就。如来威光亦复如是。以二因缘而得成就

文殊师利。如是如来所有威光。以二因缘之所成就。如来说法亦复如是。以二因缘而得成就

文殊师利。如是如来所有说法。以二因缘之所成就。如来之行亦复如是。以二因缘而得成就

文殊师利。如来如是为欲哀愍诸众生故出现于世。为欲利益诸众生故出现于世。为欲安乐诸众生故出现于世。以诸众生若干种性愿乐差别各各不同。是故如来随其意乐。为现种种相好之身。说法教化令彼调伏。入佛法中使得成就

尔时文殊师利菩萨摩诃萨。闻佛所说如上福聚利益一切诸天世人。便作是言。世尊。我于今者得大善利。我于今者得大最胜。我于今者得无等等。我于今者得大吉祥。我思如来于世间中为诸众生作大依止。清净不动犹如虚空。难遇难遭我今得见。佛说是经已。彼诸比丘及诸菩萨摩诃萨等。欢喜合掌信受奉行大乘百福庄严相经


大乘宝月童子问法经

    No. 437

大乘宝月童子问法经

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大苾刍众五万五千俱胝。一心行菩提行。无能胜菩萨等八万百千无数俱胝那臾多。诸天人等百千那臾多

尔时世尊于其食时着衣持钵。与苾刍众并诸菩萨天龙神等。恭敬围绕入王舍大城于彼乞食。是时频婆娑罗王子。名宝月童子。因为事故。乘大龙象出王舍大城。遥见世尊即下龙象而诣佛所到已致敬。头面礼足住立一面。宝月童子白佛言。如来应供正等正觉。唯愿世尊。说彼十方如来所有名号。若有信心善男子善女人。闻是名已。所有五逆等罪及一切业障悉皆消除。于无上正等正觉速得不退

尔时世尊告宝月童子言。善哉善哉。汝能乐闻如来名号之义。此意贤善一切罪业决定消除。童子。汝今谛听善思念之我为汝说。童子。过于东方百千俱胝那臾多恒河沙等佛刹。彼有世界名曰无忧。彼有如来。名贤吉祥应供等正觉。少病少恼乃至为诸众生恒说妙法。彼佛寿命六万百千俱胝那臾多无数劫。彼世界中无其日月昼夜。唯有佛光普照一切。及照地狱傍生焰魔罗界一切众生令得解脱。无量众生得无生法忍

佛言童子。南方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰寂静。彼有如来。名无边光应供正等正觉。为诸众生恒说妙法

佛言童子。西方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰欢喜。彼有如来。名喜吉祥应供正等正觉。为诸众生恒说妙法

佛言童子。北方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰不动。彼有如来。名曰宝幢应供正等正觉。为诸众生恒说妙法

佛言童子。东南方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰正行。彼有如来。名曰无忧吉祥应供正等正觉。为诸众生恒说妙法

佛言童子。西南方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰宝幢吉祥。彼有如来。名曰宝幢应供正等正觉。为诸众生恒说妙法

佛言童子。西北方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰妙声。彼有如来。名吉祥花应供正等正觉。为诸众生恒说妙法

佛言童子。东北方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰安乐。彼有如来。名莲华光嬉戏智应供正等正觉。为诸众生恒说妙法

佛言童子。下方过百千俱胝那臾多恒河沙等佛刹。彼有世界名曰广大。彼有如来。名光明吉祥应供正等正觉。为诸众生恒说妙法

佛言童子。上方过百千俱胝那臾多恒河沙等佛刹。彼有世界名为月光。彼有如来。名财吉祥应供正等正觉。为诸众生恒说妙法

童子。如是一切世界佛刹。皆有清净旃檀楼阁。所有如来名号若人闻已。恭敬受持书写读诵广为人说。所有五逆等一切罪业悉皆消除。亦不堕地狱傍生焰魔罗界。于无上正等正觉速得不退。于意云何。童子。于过去大无数及广大无边无数劫。时有世界名曰宝生。彼有如来。名精进吉祥应供正等正觉。彼十如来于精进吉祥佛所为菩萨位。于其佛前供养发愿。我等各于佛刹成无上正等正觉之时。若有众生经刹那间至须臾之间。闻我十佛名号。闻已恭敬受持书写读诵广为人说。所有五逆等一切罪业悉皆消除。亦不堕地狱傍生焰魔罗界。于无上正等正觉速得不退

尔时宝月童子。如是闻已而复白言。世尊。彼佛如来寿量云何。世尊答言。彼佛寿十阿僧祇百千俱胝那臾多世界微尘等劫。童子闻已白佛言。彼佛如来甚为希有。如是悲心发愿为诸众生得此寿量。佛言童子。若有众生闻此十佛名号。恭敬受持书写读诵信乐修行。所有无量无边福德悉得具足。三业之罪亦不能生。童子。若有善男子善女人。于恒河沙等佛刹。满中七宝供养如来。经百千岁获福无量。若善男子善女人闻是十佛名号。恭敬信受书写读诵为他解说。所得福德胜前供养无量无边

尔时索河世界主大梵天王帝释天子四天大王稣枲么天子大自在天子。以最上旃檀香粖散世尊前而为供养。白世尊言。若有众生于此正法。书写读诵信解受持。得一切天人阿修罗尊重礼拜。所有地狱畜生焰魔罗界阿修罗身及饿鬼趣皆得解脱。佛言。若此正法耳根得闻受持读诵。罪恶魔冤不能侵害。于阿耨多罗三藐三菩提速得不退

尔时世尊而说颂曰

  持此世尊十名号　　如是寿命俱胝劫
  佛说功德不思议　　未来成就二足尊

尔时频婆娑罗王宝月童子。白于世尊而说伽他曰

  大无畏善说　　无边无量佛
  众生最上师　　我今归命礼
  如是今修学　　一切佛知见
  愿断于烦恼　　速成于菩提

尔时童子说此颂已。白世尊言。我今如是所有忍辱。菩萨大智总持法门。方广之教佛菩提行。如是修学行菩提行

尔时世尊复说颂曰

  若人受持佛名号　　水火盗贼不能侵
  毒药刀杖王难等　　一切诸苦自消除
  如是速得于菩提　　广令流布佛名号

若此正法于末世时有人受持读诵。此人命终速成佛道。若以香花供养一切诸佛经多劫时。不如有人于此正法暂时书写读诵。所得福德无量无边。若人以最上所爱七宝。满于一切刹土之中。供养一切诸佛。亦不如读诵此经得福甚多。佛说此经时。无量百千俱胝那臾多众生。发阿耨多罗三藐三菩提心。无量无边众生得无生忍。不退转于阿耨多罗三藐三菩提。佛说是语时。宝月童子等皆大欢喜。作礼而退大乘宝月童子问法经


大乘宝云经

    No. 659 [No. 658]

大乘宝云经卷第一

        梁扶南三藏曼陀罗仙共僧伽婆罗译

    序品第一

如是我闻。一时佛婆伽槃。住伽耶国伽耶顶山。与大僧众七万人俱。一切皆是大阿罗汉。诸漏已尽无复烦恼。心得自在心善解脱慧善解脱。众所知识皆大龙象。所作已办不受后有。舍离重担逮得己利。尽诸有结善俱解脱一切自在。究竟彼岸善达法性。法王之子其心调伏坚固不退。世间八风所不能动。众德具足所愿皆满住涅槃道。唯除一人所谓长老阿难。复与诸大菩萨摩诃萨众十六万大士俱。一切皆是一生补处。向一切智重一切智趣一切智就一切智。得无碍陀罗尼三昧。住于首楞严三昧。悉皆游戏藉大神通。成熟众生不暂休息。无复一切烦恼障碍。大慈大悲遍现十方一切国土。善能往反无量佛刹。以空境界住于无相。动止进退每为利益一切众生。善行一切诸佛境界。智慧无边同于虚空。三昧微妙甚深如海。心不摇动如须弥山。清净无秽犹如莲华。心善明净如摩尼宝。其心皎洁如炼真金。其名曰宝相菩萨摩诃萨。宝掌菩萨。宝印掌菩萨。宝冠菩萨。宝顶菩萨。宝首菩萨。宝积菩萨。宝髻菩萨。宝幢菩萨。金藏菩萨。金刚藏菩萨。宝藏菩萨。吉藏菩萨。庄严藏菩萨。如来藏菩萨。智慧藏菩萨。日月藏菩萨。三昧藏菩萨。莲华藏菩萨。解脱月菩萨。普月菩萨。观世音菩萨。大势至菩萨。观察自在菩萨。普贤菩萨。普眼菩萨。莲华眼菩萨。广眼菩萨。普威仪菩萨。普齐整菩萨。普悦意菩萨。普礼菩萨。智意菩萨。法意菩萨。胜意菩萨。上意菩萨。金刚意菩萨。师子奋迅菩萨。大雷声王菩萨。师子吼菩萨。深响音菩萨。无污菩萨。无垢菩萨。金刚明菩萨。日光菩萨。智光菩萨。智吉菩萨。月吉菩萨。芙蓉吉菩萨。宝吉菩萨。文殊师利童子菩萨等十六大士。贤护菩萨以为上首。及贤劫中诸大菩萨。弥勒菩萨以为上首。四天王天四大天王以为上首。三十三天天主帝释以为上首。夜摩天子须夜摩天以为上首。兜率诸天删兜率陀天以为上首。化乐诸天化乐天主以为上首。他化自在诸天自在天主以为上首。与诸梵俱助白诸梵王等。一切梵众是大梵王以为上首。一切净居诸天大自在天以为上首。阿修罗王毗摩质多以为上首。如是等无量百千阿修罗王。阿耨达龙王摩那斯龙王娑竭罗龙王婆修吉龙王如是等无量百千龙王。吉威德龙王以为上首。及诸龙女无量百千。天龙夜叉乾闼婆阿修罗迦留罗紧那罗摩睺罗伽人非人等。尔时大众围绕。伽耶顶山广四由旬。无有地所及虚空中有空缺处。犹若邻虚。是时大众聚集瞻仰尊颜一面安坐。是中宝师子座高一由旬。四方宝座高二十里。无量缯彩敷覆其上。悬七宝铃及诸罗网百千幡华。高座四面一切地界变为金刚七宝所成。悦众人意平坦如掌。扫洒净洁烧诸杂香。无量天华皆散其上。无量百千莲华大如车轮从地踊出。皆是金色琉璃为台。因陀尼罗珠以为其鬘。香气馚馥可爱柔软供养世尊。高座四角不近不远。有四宝树自然而出高六十里。四维各十五里。尔时世尊坐师子座。以平等心善转法轮降魔怨敌。世间八风所不能动。无怖无畏无怯弱想如师子王。亦如阿耨达池八功德水湛然盈满。犹若大海甚深无底。如须弥山安隐不动。如日照了一切世间。如月悦乐一切群品。如大龙王遍雨法雨。如大梵王出过三界。无量调顺弟子围绕。无量百千释梵护世诸天。恭敬礼拜心不高下。光明照曜一切大众。是时世尊从头顶上放大光明。其名普照。无量光明侍从而出。照曜十方无量无边一切世界。照已收还右旋三匝。而皆入于如来面门。如是入已而无增减。犹如酥油水等而写沙中不增不减。如来光明亦复如是。尔时东方过无量恒河沙数世界。彼有世界名芙蓉华。是中有佛名芙蓉眼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。正为菩萨摩诃萨众演说法要。所谓一大乘道。是中佛刹无有声闻辟支佛二乘之名。而彼世界一切众生。悉是菩萨阶位。不退于阿耨多罗三藐三菩提。彼佛世界无余杂食。一切菩萨唯羡禅味以为饮食。唯善法乐以为饮食。是中世界无复日月星宿之光。唯是如来光明照了是方世界。无有秽草砂砾荆棘及诸黑山。而彼世界平坦如掌。是中有菩萨摩诃萨。名曰萨婆尼弼沙敢毗阵国。言此降伏一切障碍菩萨。若有众生闻是菩萨名字。一弹指顷而发善心。即能得除一切障碍。尔时降伏一切障碍菩萨摩诃萨。遇是世尊所放光明往照其身。而从住处出诣彼佛。头面恭敬礼佛足已一所而坐。及与无量菩萨大众触是光明。各各从于住处出诣彼佛。头面作礼恭敬已毕却坐一处。尔时降伏一切障碍菩萨从座而起偏袒右肩。右膝着地在莲华台上。合掌向佛而前白言。世尊。何因何缘有此光明遍照。种种杂色不可思议。清净无垢悦乐一切菩萨身心。是时佛告菩萨言。善男子。去此西方过恒河沙数世界。彼有佛刹名娑诃世界。是中有佛。名释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。若有众生得闻释迦牟尼佛名号。是诸众生则不退转于阿耨多罗三藐三菩提。如是光明则是释迦如来所放光明。清净无垢微妙第一。悦乐一切菩萨身心。作是语已。复白佛言。世尊。以何义故。有诸众生得闻释迦牟尼佛名。而不退转于阿耨多罗三藐三菩提。作是问已。芙蓉眼佛告降伏一切障碍菩萨言。善男子。释迦如来于过去世行菩萨时已发誓愿。我成佛时凡是众生闻我名者。皆悉令得不退转于阿耨多罗三藐三菩提。世尊。彼世界中一切众生闻佛名者尽不退转耶。佛言。不然。世尊。彼土众生不闻释迦牟尼佛名耶。佛言。善男子。皆得闻也。世尊。彼土众生无退转者云何不退转耶。佛言。善男子。是诸众生种植不退转因。藉闻彼佛名号而生。今者如来见是事已。说彼众生无有退转。非但闻名而不退转。善男子。我今为汝当说譬喻成是义故。善男子。如树种子若大若小。但无事碍具诸外缘。即生萌牙乃至增长。善男子。云何说是为种子耶。对曰。世尊。无事碍故说为种子。佛言。如是。善男子。闻如来名则便得种不退转种。是诸众生即得名为不退转于阿耨多罗三藐三菩提。复白佛言。世尊我今往彼娑诃世界。愿乐欲得见释迦佛应供正遍知亲近恭敬礼拜供养。尔时芙蓉眼世尊告降伏一切障碍菩萨摩诃萨言。善男子。善哉佳矣。往时已到汝当知之。复有无量诸大菩萨。悉皆往诣芙蓉眼佛所。而白佛言。世尊。我等皆亦愿乐往彼娑诃世界。欲见释迦牟尼佛亲近恭敬尊重供养。尔时芙蓉眼佛告菩萨众。善男子。汝等随意往之。今正是时。至彼世界谨慎收摄莫放逸住。何以故。彼土众生贪欲甚多嗔恚甚多愚痴甚多。不持沙门清净梵行深乐非法。恶赖奸诈。碜毒粗犷。谗刺言语。秽曲逆耳。恶口骂詈。放逸自恣。傲诞独高。嘲调谄曲。形容丑陋。懈怠懒惰。破戒暗钝。勤行恶业嫉妒悭贪。无量烦恼之所缠缚。如是彼土众生众中。释迦如来正为说法。是等菩萨大众对如来曰。世尊。甚难甚难。释迦如来为彼众生而说法耶。佛言。如是如是。善男子。释迦如来为彼众生演说法要。甚难甚难。善男子。彼土众生如是粗犷。运一念善甚为艰难。何以故。若于清净世界众生清净。修行善法不足为难。娑诃世界如是秽浊。设彼众生能运善心一弹指顷甚为希有。一弹指顷归依于佛。归依正法。归依圣僧。甚为希有。一弹指顷受持净戒甚为希有。一弹指顷发离欲心甚为希有。一弹指顷运大悲心发阿耨多罗三藐三菩提心甚为希有。是诸菩萨而白佛言。希有世尊。希有善逝。尔时一切诸菩萨摩诃萨言。善哉世尊。如所教诲随顺正法如诲奉行。从佛闻已。顶礼佛足礼竟而出。复为释迦如来。化作种种供养之具。有化宝树华果庄严相好圆满。有化毗琉璃树。有化玻梨宝树。有化金银之树。及如意树华果之树。又化衣云及庄严云香云鬘云盖云并伎乐云。如是变化合成一云。是诸菩萨与降伏一切障碍菩萨俱而往娑诃世界。尔时降伏一切障碍菩萨报诸菩萨言。仁者。此娑诃世界众生。恒为众苦之所逼恼。善哉仁者。我等应当为诸众生作大神通。以神通力令彼众生远离众苦而受快乐。是诸菩萨答言。善哉善哉。仁者。尔时降伏一切障碍菩萨而作神通。即从身出种种光明。清凉微妙无有垢秽悦乐身心。以是光明遍照三千大千世界。是中一切地狱及诸畜生饿鬼之类及阎罗王。遇此光明皆离众苦受诸快乐。无复相杀害心。无忿恨心。无嗔恚心。互相恭敬作父母想。三千大千世界中间无光明处。日月光明神通道力不能照处。是菩萨光悉皆照了。是中众生互得相见。又三千大千世界。诸铁围山。目真邻山。大目真邻山。及余无量黑山。皆是菩萨光明照了。上至一切诸梵天处乃至有顶。下去乃至地狱。所谓活活地狱。黑绳地狱。合破地狱。叫唤地狱。大叫唤地狱。烧煮地狱。大烧煮地狱。阿鼻地狱。一百三十六诸大地狱。及诸寒冰地狱无有方所。诸地狱等非日光明之所能照。遇此光明悉得快乐息诸苦痛。以是神通。有诸众生。求食得食。求饮得饮。衣服车乘财帛。金银珍宝应念而得。无眼得眼。聋者得闻。哑者能语。失心颠狂而得正念。苦者得乐。怀娠之女产生安隐无有痛恼。尔时一切大地菩萨摩诃萨众。往诣伽耶顶山。是诸大士去山非远。此三千大千世界。七宝罗网遍覆其上。于虚空中雨大莲华诸天华云。果云鬘云。香云衣云。诸散香云。种种缯彩幢幡盖云。一切自然空中而现。凡诸众生触此云雨皆得快乐。伽耶顶山诸秽树木悉不复现。是诸地界悉大清净。唯有宝树意树华树果树檀树沉香之树遍满其中。无量天女于虚空中作天伎乐而供养佛。以是音乐出此偈颂歌咏佛德

  托生林苑世奇特　　清净无污无等等
  愿礼虚空等相故　　我等故来到此国
  于道树下成等觉　　破碎一切众魔怨
  愿礼无比具威神　　我等故来到此国
  众中转于妙法轮　　说法如幻水中月
  愿礼微妙如意树　　我等故来到此国
  了知世间如梦等　　种种色像如火轮
  愿礼不动福慧聚　　我等故来到此国
  于无量劫修双行　　福慧成满由大悲
  愿礼清净满月面　　我等故来到此国
  无量人天菩萨众　　恭敬供养稽首礼
  愿礼除暗踰日光　　我等故来到此国
  累劫苦行获法珍　　慈悲不吝施群品
  愿礼自利利他者　　我等故来到此国
  心净寂灭慈悲熏　　尘劳不污如莲华
  愿礼无量功德聚　　我等故来到此国
  无为本性非生灭　　神通道力现三相
  愿礼自在不思议　　我等故来到此国
  分明相好庄严身　　救护世间所归仰
  愿礼宝树无量枝　　我等并赍供养具

尔时偈颂出已未久。长老目连即从座起。偏袒右肩右膝着地。合掌向佛恭敬礼毕。而白佛言。世尊。如今瑞相是谁所作。本未曾有未曾闻见。说是语已。佛告长老目揵连言。目连。东方去此过恒河沙等数世界。彼有世界名芙蓉华。是中有佛名芙蓉眼如来应正遍知。即时存在正说法要。从彼佛土降伏一切障碍菩萨。与无量百千亿那由他诸大士俱。来至此娑诃世界现是瑞相。佛说是语未久之顷。降伏一切障碍菩萨。与百千亿那由他诸菩萨俱。以大神通悉诣佛所。与大士俱头面稽首敬礼佛足。围绕千匝俱立佛前。以此偈颂一时同音。而叹佛曰

  大名大勇猛　　大智大仙尊
  过有诸危崄　　归命度彼岸
  光明普照了　　普知众生性
  普愍普救拔　　敬礼至极尊
  不动如须弥　　如海深无底
  降诸外道群　　稽首礼法王
  本来无生灭　　法性体自然
  众中师子吼　　敬礼转法轮
  时为说正道　　时令达真如
  时令入涅槃　　或为授记别
  善达三聚性　　时机无不了
  所化诸众生　　法网如意满
  淫怒痴等垢　　及余无量惑
  坐于菩提树　　以智火烧尽
  自度而度他　　自脱脱世间
  久迷三有险　　唯佛能济拔
  三有长牢狱　　无明熟眠众
  法灯今觉悟　　顶礼群品亲
  如是诸菩萨　　皆是佛化生
  愿乐闻正法　　世尊为说之

尔时降伏一切障碍菩萨。与诸菩萨摩诃萨等。以是偈颂叹佛已毕。世尊怜愍听许复座。俱于莲华台上而坐。随其所应而从座起。偏袒右肩右膝着莲华台。合掌向佛而白佛言。世尊。我今欲问如来应供正遍知随处少分。唯愿世尊。如今所问怜愍答之。作是语已。佛告降伏一切障碍菩萨言。大士但问。如来世尊常自听许随意所问。如来当为分别答之。尔时降伏一切障碍菩萨。蒙佛听许而白佛言。世尊。菩萨摩诃萨。云何具足檀那波罗蜜。云何具足尸罗波罗蜜。云何具足羼提波罗蜜。云何具足毗梨耶波罗蜜。云何具足禅那波罗蜜。云何具足般若波罗蜜。云何具足优和俱舍罗波罗蜜。云何具足波尼牢那波罗蜜。云何具足婆罗波罗蜜。云何具足阇那波罗蜜。世尊。云何菩萨摩诃萨与地平等。云何菩萨与水平等。云何菩萨与火平等。云何菩萨与风平等。云何菩萨与虚空平等。世尊。云何菩萨如月如日。云何菩萨如师子王。世尊。云何菩萨善能调伏。云何菩萨世所知识。云何菩萨喻若莲华。云何菩萨发增广心。云何菩萨得清净心。云何菩萨无疑惑心云何菩萨意如大海。世尊。云何菩萨心解微细。云何菩萨辩才会理。云何菩萨辩才明了。云何菩萨辩才净洁。云何菩萨辩才能悦一切众生。云何菩萨入坏言语。世尊。云何菩萨利益说法。云何菩萨无不随顺。云何菩萨善了法界。云何菩萨行于空境。云何菩萨住于无相。云何菩萨远离一切心愿。云何菩萨以慈为身。云何菩萨以悲为身。云何菩萨恒欢喜住。云何菩萨住于舍中。云何菩萨神通游戏。云何菩萨永离八难。云何菩萨不忘失菩提心。云何菩萨得宿命智。云何菩萨亲近善知识。云何菩萨远离恶知识。云何菩萨得如来法身。云何菩萨得金刚不坏身。云何菩萨作大萨泊主。云何菩萨作大导师。云何菩萨示道不颠倒。云何菩萨恒正忆念。云何菩萨着粪扫衣。云何菩萨受持三衣。云何菩萨行不低昂。云何菩萨如法乞食。云何菩萨唯一坐食。云何菩萨不再饮食。云何菩萨住阿兰若。云何菩萨依止树下。云何菩萨习坐露地。云何菩萨住尸陀林。云何菩萨宴坐不眠。云何菩萨随宜敷座。云何菩萨摄心方法。云何菩萨用心与理相应。云何菩萨受持修多罗经。云何菩萨受持毗尼律。云何菩萨具足威仪法用举止。云何菩萨无悭嫉心。云何菩萨于诸众生生平等心。云何菩萨殷勤供养恭敬诸佛。云何菩萨断除憍慢。云何菩萨心多清净。世尊。云何菩萨了知世谛。云何菩萨通达第一义谛。云何菩萨善解十二因缘。云何菩萨于世间解。云何菩萨生净佛刹。云何菩萨不受胎生染污。云何菩萨出离家居。云何菩萨寿命清净。云何菩萨心无疲倦。云何菩萨行佛制法。云何菩萨姿颜悦豫面无颦蹙。云何菩萨多闻具足。云何菩萨持正法。云何菩萨生法王子。云何菩萨释梵护世诸天之所奉迎。云何菩萨了知众生机性。云何菩萨成熟众生。云何菩萨堪任正位。云何菩萨共住安乐。云何菩萨善行摄法。云何菩萨得身端正。云何菩萨为所依止。云何菩萨喻大药树王。云何菩萨福业相应。云何菩萨善能变化。世尊。云何菩萨速成阿耨多罗三藐三菩提

    大乘宝云经十波罗蜜品第二

尔时佛告降伏一切障碍菩萨摩诃萨言。善哉善哉。善男子。重复善哉。汝为利益一切众生。亦为安乐一切世间。特为庄严人天大众。是故汝今以如是义。应问如来。善男子。谛听谛听善思念之。我当为汝分别解说。唯然世尊。愿乐欲闻。佛言。善男子。菩萨摩诃萨。具足十法修行檀波罗蜜。何等为十。一者法施具足。二者无畏施具足。三者财施具足。四者无反报施具足。五者怜愍施具足。六者不轻慢施具足。七者殷重施具足。八者供养施具足。九者无所依施具足。十者净洁施具足。善男子。云何菩萨法施具足。善男子。菩萨无希望心受持正法。不为利养不为知识不为名闻。种种因缘但为欲灭一切众生剧苦因缘。以无著心于诸众生而为说法。一向平等无二心故。如于国王王子朝臣富贵之处。而为说法。于旃陀罗及下贱人。平等说法亦复如是。无二心故。何况于诸万民都邑一切众生。如是说法不生憍慢。善男子。是名菩萨法施具足。善男子。云何菩萨无畏施具足。善男子。菩萨自身舍弃一切刀仗。不令一切众生怖畏。以所行法传劝化他。于诸众生生父母想眷属妻子想善知识想。何以故。如佛所说。生生世世流转无始。无一众生非是汝等昔时父母眷属妻子知识。乃至蠕动一切众生四生之类。是故应施其无所畏。割肉饴之勿令怖畏。何况于大众生。善男子。如是菩萨无畏施具足。善男子。云何菩萨财施具足。菩萨若见众生心性弊恶行不善业。即施财物。施财物竟止其恶业令修善行。复更思惟。如来所说菩萨行施。即灭三种恶法。所谓嫉妒悭惜贪爱。是故我等依如来教而行布施。如是行施不生傲慢。善男子。如是菩萨财施具足。善男子。云何菩萨不望报施具足。善男子。菩萨行施。不为自身不为眷属不为世俗。往还因缘而行布施。是诸菩萨如法布施性乐布施。以是因缘菩萨无有求报恩心。善男子。如是菩萨不望报施具足。善男子。云何怜愍布施具足。善男子。菩萨见诸困苦众生。若饥若渴若裸若袒若披破弊。无救无护无归依处。无所安身福德微薄。见已则生怜愍殷勤之心。为是众生利益安乐。是故我应急行阿耨多罗三藐三菩提。是诸众生困苦无救无护无归无依。流转生死遍于六道。受诸剧苦无暂休息。我当独于一切众生。为尊为师为将为上为首为导为救为护为归为依。以大怜愍逼切其心。以怜愍故摄受众生。如是怜愍摄受无量无边一切众生。修是善根不生憍慢。善男子。如是菩萨怜愍布施具足。善男子。云何菩萨无憍慢施具足。善男子。菩萨行施。非掷与施不轻他施。不骂辱施不前恼施。不恃富贵恍惚而施。不求名誉不恃多闻。夫欲行施殷重而施。前作恭敬然后方自手施与之。善男子。如是菩萨无憍慢施具足。善男子。云何菩萨殷重施具足。善男子。菩萨若见和上师僧可尊重者及诸同学。以身恭敬而心殷重。合掌礼拜奉迎送去作和合意。于诸种种修行法事。与善相应常为朋友。善男子。如是菩萨殷重施具足。善男子。云何菩萨供养施具足。善男子。菩萨若于佛前于法前僧前而设供养。若至如来塔庙之处。以诸香华而供养之净洁扫洒。若如来塔有破坏者即为治理。如是供养诸佛。复于所听如来正法。读诵受持书写演说。思惟其义如法修行以无颠倒故。如是供养正法。以诸衣服饮食卧具汤药种种资生。乃至冷暖汤水悉皆施给。如是供养僧众。善男子。是名菩萨供养施具足。善男子。云何菩萨无所依施具足。善男子。菩萨行布施时不作是愿。以此善根令得生天若次诸天若生国王朝臣宰相富贵之处。善男子。如是菩萨无所依施具足。善男子。云何菩萨净洁施具足。善男子。菩萨如前所说。种种行施善观察之。如是观察布施过失布施垢秽布施障碍悉令不生。善男子。如是菩萨净洁施具足。善男子。以是十法菩萨檀波罗蜜满足。善男子。菩萨具于十法。尸罗波罗蜜具足。何者为十。一者护持波罗提木叉禁戒。二者护持菩萨所应学戒。三者远离一切烦恼烧热。四者远离不善思惟。五者信业因果。六者怖畏罪想。七者惭愧观察。八者受持坚固。九者无所依戒。十者三轮净戒。善男子。云何菩萨护持波罗提木叉戒。若修多罗若于毗尼及诸经中善哉如来所制禁戒。在在处处。我应当学如法受持。不恃种姓不着诸见。不规徒众不见人过。无下劣想不着杂艺。于是戒律生殷重心如法受持。如是菩萨守护波罗提木叉禁戒。善男子。云何菩萨守护菩萨所应学戒。善男子。菩萨作是思惟反覆筹度。非但受持波罗提木叉戒。我当证得阿耨多罗三藐三菩提。是故处处经中。凡是如来所说菩萨种种威仪。并于所制菩萨种种律仪。我应当学如法受持。何者菩萨修威仪戒。菩萨非处非时不可说法。要知时节善解国土。以软美音方为说之。何以故。勿令众生生不善心。将护彼意自收六情。菩萨方得菩提行满。何者律仪戒具足。所谓爱语软语不浑杂住。乐住闲静颜貌和悦。如是菩萨具威仪已。絓是如来所制诸法律仪。以殷重心悉皆受持。如是菩萨守护菩萨所应学戒。善男子。云何菩萨远离一切烦恼烧热。善男子。菩萨若欲烧热若嗔烧热若痴烧热。及诸无量一切烦恼火所烧热。或复种种财货资生因缘身心炽然。当修三种对治法门。仍速远离三毒因缘。何者是欲对治何者是淫欲因缘。修不净观是欲对治。一切女色是淫因缘。何者修不净观。所谓观此身分其中唯有毛发爪齿皮肤垢腻。泪汗涕唾大小便利。筋肉血脉脑膜肪[月*冊]。骨髓膏脓心肺脾肾。肝胆肠胃黄白涎癊生熟二藏。不净充满。菩萨如是身分。当善观察三十六物。如是观察复更思惟。有诸婴儿凡夫痴无晓了少分善根。尚能观察三十六物不生贪欲。何况有智具大人相厚种善根。如是菩萨修不净观。何者名为女色。所谓主家母村好能庄严色像外形姿态。三十六物假合丑秽以为形相惑诸凡愚。菩萨若眼见已而作是念。如来常说。一切境界如梦如幻皆是虚妄。何有智者。于诸境界如梦幻等而生贪欲。作是观察应速远离。是名菩萨离欲因缘。何者嗔恚对治。何者嗔恚因缘。善男子。菩萨于诸众生多生慈悲。凡是因缘能生嗔者皆悉远离。如是菩萨修嗔对治离嗔因缘。菩萨作是观已即得离痴。得离痴已不生恼热。若被损辱若失财物亦不生热。如是菩萨远离一切烦恼燋热。善男子。云何菩萨远离不善思惟。善男子。菩萨独无伴侣。住于空闲寂静之处。发如是心。我今安住无喧杂处住清净处。是故得住如来法律安乐清净。有诸沙门剃除须发。被坏色衣而行苦行。近恶知识不善思惟。是故失于如来所说法律。如是菩萨远离不善思惟。云何菩萨信业因果。菩萨作是思惟。如佛所说沙门夫作功德。应当至心持戒修智至到努力。何以故。至心造功德故。当受如意安乐果报。如是信故即得远离诸不善业。是名菩萨信业因果。善男子。云何菩萨怖畏罪想。菩萨于微细罪恒生怖畏尚不故犯。何以故。如佛所说沙门毒药体性若多若少俱能杀人。一切罪殃若大若小。俱令众生堕三恶道地狱饿鬼畜生剧苦之中。亦复如是。思惟是已则生怖畏一切罪想。是名菩萨怖惧罪业。云何菩萨惭愧观察。菩萨与四部众及诸国民无不亲狎。如是等人于菩萨边。而施金银真珠琉璃璧玉种种宝物。而是菩萨独不生贪。若塔庙物若僧鬘物。付嘱委之而不自用。何以故。如佛所说。菩萨于己身分。乍割其肉随意用之。而不可以非舍施物而应得用。如是菩萨惭愧观察。云何菩萨受持坚固。菩萨若魔眷属及诸天神之所娆乱。令生贪着一切财物及五欲乐。其心安住不动不摇亦不退转。如是菩萨受持坚固。云何菩萨无所依求戒。菩萨护持净戒。作如是念。不以此戒我当生天及诸天等国王帝主诸大朝臣。菩萨持戒为无所得故。如是菩萨无所依戒。云何菩萨三轮净戒。菩萨以身清净口心清净。何者菩萨身清净戒。絓是一切身业不善。所谓杀生偷盗邪淫等皆悉远离。是名菩萨身业清净。何者菩萨口业清净。絓是一切口业不善。所谓妄语两舌恶口骂詈破散戏语皆悉远离。是名菩萨口业清净。何者菩萨心业清净。絓是心业一切不善。所谓贪欲嗔恚愚痴等皆悉远离。是名菩萨心业清净。如是名为三轮净戒。善男子。是名菩萨摩诃萨尸罗波罗蜜清净具足。善男子。菩萨具有十法。羼提波罗蜜具足。何等为十。一者内忍具足。二者外忍具足。三者法忍具足。四者佛印可忍具足。五者无方所忍具足。六者平等忍具足。七者不见事忍具足。八者不摇动忍具足。九者慈悲忍具足。十者成就誓愿忍具足。善男子。云何菩萨内忍具足。内有忧悲苦恼愁毒惆怅愦闷。悉皆忍之默然不热。是名菩萨内忍具足。云何菩萨外忍具足。善男子。菩萨闻有恶口骂詈种种诽谤。及其父母一切眷属和上师僧。乃至诽谤佛法僧宝。闻已不嗔不恼。不入内怀而堪忍之无怨恨心。是名菩萨外忍具足。云何菩萨法忍具足。菩萨摩诃萨于诸如来所说甚深经教。断诸疑惑意趣难达诸佛境界。所谓诸法本来寂静。不生不灭性自涅槃闻如是法不恐不怖不惊不畏。即便作是进退思惟。颇有一人。不闻如来如是甚深微妙正法。得成阿耨多罗三藐三菩提耶。以是因缘。应当至心受持读诵观察修行如是正法。是名菩萨法忍具足。云何佛所印可忍具足。菩萨靡诃萨若生嗔恨。即当至心谛善思惟。如此嗔者何由而生又何处灭。复谁所生云何而生藉何因生。如是观察不见嗔因不见生处不见源由。以是因缘即便忍之不生烦恼。是名菩萨佛所印可忍具足。云何无方所忍具足。菩萨非昼日忍夜中不忍。非夜中忍昼日不忍。非此国忍彼国不忍。非彼国忍此国不忍。非知识不忍知识而忍。非不知识忍知识不忍。菩萨不尔。于一切时在在处处。皆悉安耐一切能忍。是名菩萨无方所忍具足。云何菩萨平等忍具足。菩萨不但于其父母尊长妻子一切眷属等所而为堪忍余处不忍。菩萨不然。何以故。菩萨堪忍无有亲疏不问尊卑及旃陀罗。以平等心而堪忍之。是名菩萨平等忍具足。云何菩萨不见事忍具足。菩萨不以事缘故忍。不为名闻故忍不为世流布忍。不为惭愧故忍。菩萨在在处处常修忍辱。是名菩萨不见事忍具足。云何菩萨不扰动忍具足。菩萨嗔恚未发之前。为恶不生而暂忍辱不名为忍。若遇恶境。或以手卷若以刀仗。或打或杀或口骂辱菩萨皆忍。是名菩萨不扰动忍具足。云何菩萨慈悲忍具足。菩萨若作国王王子朝臣。富贵多饶财宝得自在力。设被骂辱毁呰诽谤种种轻欺。悉皆堪忍不嗔不恨。不逞富贵而作是念。是等众生我皆荷负我所守护。是故不可于所守护增加嗔恚便弃舍之。以是因缘兴大慈悲。能堪忍之不生嗔恨。是名菩萨慈悲忍具足。云何菩萨誓愿忍具足。菩萨摩诃萨应作是念。我于如来应供正遍知前作师子吼。我当修行阿耨多罗三藐三菩提。见诸众生沉滞生死没深淤泥。我应拔济令得度脱。是故我今不可以于所度之众。多生嗔忿起怨憾心不耐不忍。若我不忍尚不自渡。何况渡人。善男子。譬如医王。见诸盲人便作是念。我今当为如是人等除其目中一切暗翳种种障膜。虽作是念而是医师本自盲冥。善男子。于意云何。如是医师能为众生除眼翳不。对曰。不也世尊。佛言。善男子。如是菩萨。于此无明生盲世界自无慧眼。云何能除世间无明。自眼翳障尚不能治。岂能治他。以是因缘。菩萨欲除一切众生无明暝者。应前自除一切暗障后及于人。是故菩萨应堪忍之不生嗔恨。如是菩萨自誓愿忍具足。善男子。是名菩萨摩诃萨具足十法忍波罗蜜满足

大乘宝云经卷第一大乘宝云经卷第二

        梁扶南三藏曼陀罗仙共僧伽婆罗等译

    十波罗蜜品之二

善男子。菩萨摩诃萨。具足十法毗梨耶波罗蜜满足。何等为十。一者金刚不坏精进。二者勇猛精进。三者离两边精进。四者增广精进。五者练治精进。六者无休息精进。七者清净精进。八者无比精进。九者无轻蔑精进。十者非策精进。善男子。云何菩萨精进不坏喻如金刚。菩萨摩诃萨勇猛精进发弘誓愿。为诸众生未涅槃者令得涅槃。未得度者而令得度。未解脱者令得解脱。未安立者令得安立。未觉悟者令得觉悟。如是勇猛运广大心时。魔波旬即便往到是菩萨所。而谏之曰。善男子。无劳如是勇猛精进。何以故。善男子。我昔已曾如是勇猛。亦为众生发弘誓愿。未涅槃者令得涅槃。如是誓愿皆是妄语。欺诳世间婴儿凡夫无有真实。善男子。我未曾见颇有一人。如是精进发弘誓愿。以愿力故得成阿耨多罗三藐三菩提。善男子。我唯见无量无边一切众生如是精进。以声闻乘辟支佛乘而般涅槃。以是义故急当舍离如是精进劳累身心艰苦疲极。尔时菩萨而作是念。咄哉波旬。将不故来娆乱我耶。岂不欲作障碍留难我法事耶。审知魔已而作是言。波旬善哉。少欲自持。何劳乐知世间事乎。波旬。如来说此一切世间业为师匠。依因于业缘力所使。波旬。汝当自摄复道还去。汝今恼我之因缘故。汝于来世长夜受苦空无利益。如是魔众及魔天民。故作障碍来相恼触。而是菩萨不破不散不坏不退。如是菩萨金刚精进具足。善男子。云何菩萨勇猛精进。菩萨摩诃萨以是精进即能超越过前修行。诸菩萨等不能及是菩萨一分。乃至算数譬喻皆不能及。何况声闻辟支佛等。于初发心以精进力。摄持一切如来法藏。即便远离一切不善。如是菩萨勇猛精进具足。云何菩萨离二边精进具足。菩萨摩诃萨。虽作如是勇猛精进。不得过分自苦其身。复不下劣懈怠懒惰。如是菩萨离二边精进具足。云何菩萨增广精进具足。菩萨摩诃萨如是精进。如如来身我身亦然。如来顶上无能见者。圆光一寻相好殊特。具足无量不可思议无碍智慧诸佛功德。恒师子吼力无所畏我皆亦尔。如是精进。是名菩萨增广精进具足。云何菩萨练治精进具足。善男子。如摩尼珠及金银等。以练治故却垢莹磨净洁光明。人见叹言。是摩尼珠及金银等。以得光明被练治故。如是菩萨修行精进。荡除一切垢秽不净亦复如是。何者精进垢污。所谓懈怠懒惰是精进垢。于食饮中不自知足。不识己身是精进垢。菩萨悉皆荡除。如是勇猛则为无垢无秽净洁光明显现。如是菩萨练治精进具足。云何菩萨不休息精进具足。菩萨摩诃萨。于四威仪常修精进。无时无处而暂休息。是名菩萨不休息精进具足。云何菩萨清净精进具足。如是菩萨常修精进。设有粗恶诸不善法障道因缘无利益事。悉应荡除。所有善法随顺涅槃不逆正道。助成菩提流向菩提。则为生长而增广之。于一念顷尚不故生微细诸恶。何况大恶。是名清净精进具足。善男子。云何菩萨无比精进具足。菩萨作如是念。若遍十方如恒河沙等世界。为阿鼻狱猛火烧然。是中世界见诸众生。无救无护无归依处困苦无向。菩萨即发勇猛之心独自无侣。设为一人度脱因缘。能以脚步度如是等世界猛火。而度脱之。何况众多。如是菩萨。与诸声闻辟支佛等及诸外道不可为比。如是菩萨无比精进具足。云何菩萨无轻蔑精进具足。菩萨不作是念。谓菩提者。非是世间凡人可得。而我今者所修精进盖不足言。下劣微薄我今懒惰。而菩提法勇猛精进如救头然。于无量劫之所修得。我今若不堪任荷负如是重担。是菩提法岂可得矣。菩萨应复谛想思惟。过去已有无量诸佛如来应供正遍知。今正等觉。当成等觉。皆悉用于如是等策。如是修行。如是精进。诸佛如来悉成正觉。而我今者用如是策勇猛精进。与诸众生不可为比。缘诸众生得成阿耨多罗三藐三菩提。亦复如是。是故我今宁为一切诸众生等受地狱苦。而不能为利益自身独证解脱而取涅槃。如是菩萨无轻蔑精进具足。善男子。云何菩萨无策精进具足。菩萨如是精进非人所策。不着其味。亦不以此勤精进故策怪他人。亦不自高。作是思惟。何有智者正务私事待人所策。是名菩萨无策精进满足。善男子。如是菩萨具是十法。毗梨耶波罗蜜满足。善男子。菩萨摩诃萨。具足十法禅波罗蜜满足。何等为十。一者福德佐助。二者多厌离想。三者勇猛精进。四者多闻具足。五者心不颠倒。六者如训相应。七者如法修行。八者自性利根。九者善解心地。十者善解奢摩他毗婆舍那无止息意。善男子。云何菩萨福德佐助。菩萨摩诃萨于大乘法宿植德本。在在处处流转生死。为善知识之所摄受。随愿受生。若富贵大姓。若居士大家信乐之家。既意欲得往彼受生。即便造作彼业因缘令得往生。生生世世值遇亲近真善知识。何者名为真善知识。所谓诸佛菩萨。如是增长宿世修集善业因缘。常作是念。苦哉世间痛哉世间。无安立哉一切世间。久遭重病痴暗无明。何以故。欲因缘故。是故我今不当于如是等困厄世间求受五欲。夫淫欲者。唯是妄想颠倒而已。于三苦中谬生乐想。是故如来处处经中种种因缘。具说淫欲多诸过失殊可患厌。所谓淫欲如炙肉法。肉[(夕/火)*束]俱燋。如舐刀刃贪味伪舌。如毒蛇头具四种毒。如猪在厕臭秽不净。如彼痴狗而啮枯骨。其口出血谓之为乐。亦如猕猴黏着[米*离]胶。是故菩萨当生厌离。剃除须发而被法服。于正法中如法出家。往无家地而慕精进。未得令得未证令证未至令至。以是因缘而取三慧。世谛所说第一义谛所说。善解二谛深妙之理。如所教训即为随顺。离诸颠倒如法修行。何者名为如法修行。所谓正见正思惟正语正业正命正精进正念正定。以能通达于道谛故。成就利根了知诸根。即乐寂静究竟远离。一切徒众混杂諠闹。匆遽多言淫怒痴等一切恶觉。亲里知识利养名誉毕竟远离。身心快乐柔软调和。复更思惟观察是心。何法处行于善不善无记法耶。若行于善即生欢喜。若生欲觉名为不善。欲有三种谓上中下。何者为上。以欲遍身深入心住。迷乱倡狂不能修于远离因缘。以深着故。云何深着。以其不能究竟生于惭愧心故。独居空闲而随忆念不曾暂忘。生恶觉观决云淫欲。定是精妙讽咏歌叹。妄想颠倒谓言好物。如痴猕猴见水中月便欲捉取。不见其恶无惭耻心。以欲因缘。亦能与其父母尊长而共争竞。乃至相杀不避亲疏。凡夫痴顽耽着爱染。不能舍离欲因缘故。死堕地狱畜生饿鬼受诸苦报。是名上欲。何者中欲。若人习行亲近淫欲。未交会前方便求觅。设遂其事便生厌离而有惭心。知欲不善呵责自悔。是名中欲。何者下欲。脱遇欲缘止申捉手共相磨触。或共言话或眼瞻视。是名下欲。夫名淫欲。若庄严身若爱寿命及诸资生。但能生贪悉名淫欲。何者名嗔。嗔亦三种。谓上中下。其上嗔者。生于忿毒怨憾恚怒恶赖憎嫉。于五无间重罪之中。皆能备造或谤正法。由谤正法所得重罪。于前五逆不及一分。乃至算数譬喻悉不能及。以是因缘。死后入于大地狱中受诸苦毒。久久之后无量劫中脱得生人。其眼光赤无赖恶性暴虐咆哮。生旃陀罗下贱之家。以是因缘展转生死无有出期。是名上嗔。何者中嗔。其虽发嗔造诸恶业。即生悔心发露忏谢嗔所生罪。速疾修其对治方法。是名中嗔。何者下嗔。当嗔发时而作恶口不爱之语。或恶眼视。虽作不善亦非恒嗔。一念之顷速疾修集对治方法是名下嗔。痴亦三种。谓上中下。何者上痴。于前所说如是之处痴所迷惑。而无忧愁不知改悔是名上痴。何者中痴。若痴暂发造作恶业速疾改悔。于同学边发露忏悔不敢覆藏。于所犯罪知非利益。是名中痴何者下痴。于所持戒若二若三。脱有毁犯皆是制罪。终不敢犯性重禁戒。是名下痴。是中菩萨善巧方便。制伏其心令不作罪。如是制心絓是淫欲缚着因缘。悉不复生。何以故。如是善巧制伏心故心若无记。是时忆念一向观察。令其心性与善相应。何者名为无记心耶。若有是心。不散于外不住于内。不住于善不住不善。不在奢摩他不在毗婆舍那。不能收摄令得寂静。睡眠所逼沉没而住。如人眠觉睡势未除心不明了。菩萨尔时以巧方便制御其心。令得起发欢喜安住于禅定中。如是菩萨善解于心。菩萨如是解于心已。观见诸法如幻如梦。是法不善是法是善。是法出离是法不出离。作如是知。是等诸法皆依于心。由心而生心为上首。若能摄心调伏制止。若达心性则能摄得一切诸法。则能调伏一切诸法。则能通达一切诸法。若如是见一切诸法。则能修心令得寂静以心系心。若心不静而制令静安心于心。若心如是寂静相应。是名一心。得一心已则入于定。得入定已寂静所生一向欢喜。心欢喜已灭于贪欲。贪欲灭已一切不善亦皆寂灭。有觉有观寂静所生。得欢喜乐入于初禅。是时菩萨。为灭觉观勤行精进。于欢喜乐不着其味。何以故。谓无常故。行于初禅而移其心。离于觉观心不复着。无觉无观三昧所生。得欢喜乐入第二禅。是时菩萨则见此乐决定是苦。何以故。三苦摄故。是时菩萨住于舍心。住舍心已唯正忆念。而有了知以身受乐。如是之乐一切圣人说名为舍。忆念乐住入第三禅。是时菩萨谓第三禅决定是空。故求四禅而使其心入于四禅。絓诸我见悉皆回转。乐亦随灭诸苦亦灭苦乐灭故。从初以来忧喜灭故不苦不乐。舍念清净入第四禅。复作观行则自见身。与虚空界以为一相。如是见已。絓是色想究竟超越。是隔碍想悉不复生。何以故。已得超越过色想故。无复絓碍。于一切想唯见无碍。无边虚空故入无边虚空而住。是时复见识与无边虚空相应。自谓此识无有边故。入识无边。过此识已是中但有无相之心。一切行灭无心功用。是名为灭。如是心灭。菩萨应知复更入定。是中进修而不休息。是处其心与慈相应。具如前说。乃至修得六通自在。是中亦复不息精进。当求修满菩提法行。善男子。如是菩萨具是十法。禅波罗蜜具足。善男子。菩萨摩诃萨具足十法。般若波罗蜜具足。何者为十。一者善解无我真理。二者善解诸业果报。三者善解有为之法。四者善解生死相续。五者善解生死不相续。六者善解声闻辟支佛道。七者善解大乘之道。八者善解远离魔业。九者智慧不倒。十者智慧无等。善男子。云何菩萨善解无我真理。善男子。菩萨摩诃萨以善正慧观察色阴。乃至受想行识皆善观察。如是观察不见色生不见色集不见色灭。乃至受想行识亦不见生亦不见集亦不见灭。何以故。以真实故。不以假名世俗性故。其真实性与世俗性。是二种性文字章句所不能说。以是因缘精进不息如救头然。精进勇猛利益众生。如是菩萨善解无我真理。云何菩萨善解诸业果报。菩萨应作如是观察。所言世间有诸果报。皆似伎儿乾闼婆城本性自空。所言众生则非众生。而横执相着于我见。以是因缘不达真理。既不能了真道理故。作如是见。若言无我无人无众生无寿者无士夫无养育无男女等。及诸善恶业因果报。谁生谁死。尔时菩萨虽无众生。有业有报如是悉知。非是众生非诸善恶业因果报菩萨亦知。以正慧故。以真实故。如是菩萨善解业因果报。云何菩萨善知诸有为之法。菩萨摩诃萨应于一切有为之法。以善慧故而善通达。作如是观。是诸行法摇动不住。如朝露滴日出消尽。如山水流唯去不归。何有智者。于行法中而生贪着其心恋慕。若能观见如是真实。见实因缘则生厌离寂灭之心。如是菩萨善知有为之法。云何菩萨善解生死流转。菩萨以善智慧通达有为诸法。作是思量。遍诸世间被无明暗之所覆蔽障其慧眼。如生盲人不见正路。何由能得出离生死。唯着生死贪爱绳索之所缠系。而取四取趣向三趣。沉滞生死以取因缘。而能造作善不善业。以善不善诸业行故。受三有生有因缘生。以生因缘有老有死。老死因缘忧悲苦恼种种不绝。如是流转犹若车轮。生死轮回无复断绝。如是菩萨善知生死流转。善男子。云何菩萨善知生死不复流转。菩萨摩诃萨作如是观。无明灭故不着生死。不执着故贪爱不生。贪不生故取则不生。取不生故有不相续。不接续故生则不生。生不生故老死忧悲诸苦恼等。悉皆断灭究竟无余。菩萨摩诃萨依此道理。以善慧故悉皆通达。如是菩萨善知生死不复流转。云何菩萨善知声闻辟支佛乘。作如是观。若行是法得须陀洹果。若得斯陀含果。若得阿那含果。若阿罗汉。流尽六通尽诸有结。无复系缚向涅槃道。若行是法得成缘觉。自度自脱等于犀角。如是诸法菩萨以善慧故皆得通达。虽尔通达而不取证。所以者何。菩萨摩诃萨作如是念。我今荷负诸众生类。作师子吼誓度脱之。是故我今不应未度一切众生生死稠林旷野险难。而独度身于生死险。如是菩萨善知声闻缘觉乘道。善男子。云何菩萨善知大乘。菩萨乃学一切诸佛所制戒律种种经法。究竟无余。不得学者不得学道。不得所学一切种法。不以如是之因缘故而堕断见。如是菩萨善知大乘正道。善男子。云何菩萨善知远离魔业。菩萨摩诃萨于恶知识究竟远离。及非所宜国土聚落。受持读诵路伽夜多外典咒术。贪求利养殷重恭敬。菩萨知已皆悉远离究竟避之。及诸结使诸缚恼惑。能障菩萨清净道者皆悉远离修对治门究竟断之。如是菩萨善知远离魔业。善男子。云何菩萨智慧不颠倒。菩萨摩诃萨一切世间技艺道术悉皆学知。何以故。为欲成就利众生故。不为欲得所知识故。但为光扬显示如来正法功德之最胜故。于诸外法不生优胜功德之想。唯作是解。如来经教最深最极。诸律毗尼功德无量。是故菩萨不取外道邪见法则而为清净。如是菩萨智慧不颠倒。善男子。云何菩萨无比智慧。菩萨摩诃萨于此世间若魔若梵若沙门若婆罗门若人若天一切十方。无有一人等于菩萨之智慧故。唯除如来应供正遍知。无有智慧能胜之者。若天若梵若人若魔。一切世间所有智慧无能及者。如是菩萨智慧无比。善男子。菩萨摩诃萨具足十法。般若波罗蜜满足。善男子。菩萨摩诃萨具足十法。善解方便波罗蜜。何等为十。一者善解回向满愿方便。二者善解转诸外道方便。三者善解转诸毒尘方便。四者善解调伏疑悔方便。五者善解救济众生方便。六者善解延众生命方便。七者善解摄受方便。八者善解处非处方便。九者善解劝化利喜教导方便。十者善解供养承事方便。善男子。云何菩萨善解回向满愿方便。善男子。菩萨设见若华若果无有主甲非人所护。以此华果于夜三时日中三时。而供养佛及诸菩萨。以是因缘所得功德。回向阿耨多罗三藐三菩提。设见香树宝树意树无有主甲非人所护。日夜六时而设供养。回向阿耨多罗三藐三菩提。又诸经中所闻种种供养之具胜妙殊特。以内深心皆悉回向。十方世界诸佛世尊。一切菩萨一切众生。所有善业菩提修行。以深心故皆悉随喜。回向阿耨多罗三藐三菩提。于佛塔像若华若果。而设供养皆悉回向。愿诸众生远离破戒臭秽之气。愿诸众生得于如来戒定慧等芬馥之香。若以扫洒供养佛时。愿诸众生皆得端正威仪具足。若设幡盖供养三宝悉皆回向。令诸众生远离烦恼一切蒸热。若入寺舍愿诸众生入涅槃寺。若从寺出愿令众生出离生死困厄牢狱。若开门户愿诸众生开善道门。若闭门户愿恶道门悉令闭塞。若坐息时愿诸众生坐于道场。若洗浴时愿诸众生离烦恼垢。若受水时愿诸众生离诸臭秽。若洗脚时愿诸众生离烦恼障。若用杨枝愿诸众生除诸不净。出入动止愿我此身。但为利益安乐六道一切众生。若礼佛时愿诸众生速成佛身。一切人天之所恭敬。如是菩萨善解回向满愿具足。善男子。云何菩萨善解回转外道方便。菩萨摩诃萨常于处处外道法中。化作道士梵志尼揵。为欲成就众生因缘。就学经法而作是念。是等众生多有憍慢。若作法师而往教化其不信受。以是义故。前作外道弟子学士就中出家。精进勇猛细密威仪。必令得胜外道徒众。以多闻故以苦行故。方能得作外道法师。可尊可重言语有用辩才具足。知其信已方贬其道示其过失。仁者。汝所学道非为清净。非为离欲。亦非厌离。不能灭障。从其邪道而回转已。以佛正法而安立之。为五通仙受持梵行。修是梵行勇猛精进。必令能得外道法术。如是勇猛成就三昧三摩跋提。必令得胜一切外道五通仙等。为诸仙人作大法师。世所崇仰。知成熟时而贬是等诸外道法现其过失。从其禅定而回转之。仁者。是道不为清净。不为厌离。亦不能灭一切障碍。从如是法回转竟已。以佛正法而安立之。如是菩萨善解回转外道方便。善男子。云何菩萨回转毒尘。菩萨摩诃萨见诸众生深着贪欲。但令灭其贪欲因缘。作是方便化作女色。形容端正具足相好胜余女人。众生见已生贪甚深爱乐耽着。于所眠息受乐之时忽然而死。一念之顷即成臭烂。可恶不净见即怖畏。大生厌离慞惶苦恼。此是臭秽谁能除之。尔时菩萨侍立其前即为说法。令得决定令入正位。于三菩提随得一种。如是菩萨善解回转毒尘方便。善男子。云何菩萨善解断除疑悔方便。菩萨摩诃萨见是众生作五逆罪。及余不善种种罪业。菩萨往诣而作是言。仁者。何故愁毒不安乐耶。心无宁赖如无精神。答曰。善男子。我以造作诸逆罪业。以是因缘我今失心怖惧无宁。以此罪故于未来世受诸苦恼诸非利益。是时菩萨前令信受。以是因缘或作神通或记于心。见神通者是人信已。于菩萨边得大欢喜。生信解心堪受说法。如是信已。是时菩萨于其人前。而作变化化作父母。而作是言。仁者见不。我之父母亦被杀害。杀父母已复作神通。而现是人令其欢喜。如是之人有大神通。尚杀父母何况于我。是时菩萨为是众生而说法要。令其罪业展转轻微薄如蝇翼。如是菩萨断除疑悔善巧方便。善男子。云何菩萨善解救济众生方便。菩萨摩诃萨若见众生堪闻正法而作恶业。为教化故。菩萨尔时巧作神通。若以王身应得度者则现王身。若宰相身应得度者而则为现宰相之身。若以富贵臣民刹利身应得度者则为现之。若以天身应得度者而现天身。若有众生以软语故应得度者。而作软语为教化之。若金刚身应得度者现金刚身。若有众生以怖畏故应得度者即现怖畏。若有打拍诃骂缚录应得度者即现是事。若有众生欲作逆事打拍损恼。菩萨摩诃萨见是等已。即生怜愍而作是念。是等众生欲来恼我。见是众生如观掌中阿摩勒果。生大愁恼而作是念。我今此身宁受阿鼻地狱大苦。令是众生即得入于无余涅槃而得解脱。见是众生作诸罪业。以是因缘若舍今身必受阿鼻地狱苦报是时菩萨生怜愍心。以慈悲故念彼众生。为治罚故而折伏之后方教悔。如是菩萨救济众生善巧方便。善男子。云何菩萨善解延众生寿命方便。菩萨摩诃萨若见众生不感利养无有势力。不能得知诸圣妙法。虽求饮食尚不能得存立身口。是时菩萨为是人等。教导文章技艺算计种种法术。善相应者令得存立。如是菩萨善解延众生寿命方便。善男子。云何菩萨善解摄受方便。菩萨摩诃萨若得种种珍宝之聚。高须弥山悉为纳受。随宜微细亦为纳受。所以者何。尔时菩萨而作是念。是等众生悭惜贪吝。耽着无厌保护坚捉。悭贪因缘流转沉溺生死大海。犹若江河一切川流俱入大海。是等众生堕三恶道。亦复如是。为是众生利益安乐。是故菩萨纳受所施不为自利。非为润己而受畜之不生贪心。但为一切众生利益同得用故。但为供养佛法僧宝。但为救济困乏众生。令彼檀越得欢喜故。得利益故。如是菩萨摄受善巧方便。善男子。云何菩萨善解处非处方便。菩萨摩诃萨若见众生有大威力。堪任成就阿耨多罗三藐三菩提。而行诸行求于声闻辟支佛道勇猛精进。是时菩萨从如是处。而作方便令得舍离。示大乘道而令修行。若不信受乃至示现作大斗诤令得降伏。如是菩萨处非处起善解方便。善男子。云何菩萨善解劝化利喜方便。菩萨摩诃萨于诸未发菩提心者。能令发于菩提之心。已发心者懈怠懒惰劝令精进。不持戒者令其持戒。若以少善而知足者。方便发起令具诸善。若见众生随所犯戒可忏悔者。以是因缘闭心而住不喜不乐。是时菩萨为是众生广说法要。令得忏悔灭如是罪。如是菩萨劝化利喜善解方便。善男子。云何菩萨善解供养承事方便。菩萨摩诃萨得出家已无人供养。随宜如法所得知足。独在闲处住于寂静。作是思惟。我今云何能得供养承事如来。作是思惟心心不绝。思诸供具愿得供养承事三宝。此则能得满足六波罗蜜行。于一念中运供养心舍于所重。是檀波罗蜜。运供养心缘诸众生而发是心。是戒波罗蜜。于是心中而坐安乐。是忍波罗蜜。于是心中无有疲倦。是精进波罗蜜。于是心中不散不动。是禅波罗蜜。于是心中而思种种供养之具。是般若波罗蜜。如是菩萨供养承事善解方便。善男子。菩萨具是十供养。善解方便波罗蜜具足。善男子。菩萨摩诃萨具足十法愿波罗蜜具足。何者为十。一者无下劣愿。二者无怯弱愿。三者为度脱利益一切众生愿。四者称叹一切诸佛功德愿。五者降伏一切魔怨愿。六者不由因信他愿。七者无边际愿。八者无怖畏愿。九者无疲倦愿。十者究竟圆满清净诸愿。善男子。云何菩萨无下劣愿。菩萨摩诃萨不乐受于三有之乐。而发誓愿。是名菩萨无下劣愿。善男子。云何菩萨无怯弱愿。菩萨摩诃萨发弘誓愿。不求远离出于三界而自取证。是名菩萨无怯弱愿。善男子。云何菩萨救济利益一切众生愿。菩萨摩诃萨作如是愿。诸众生界穷未来际。先令尽得无余涅槃。然后我乃于佛涅槃而般涅槃。是名菩萨救济利益一切众生愿。善男子。云何菩萨称叹一切佛功德愿。菩萨摩诃萨作如是愿。若有众生。于其未发菩萨心者教化令发。已发心者次第令行诸菩萨行。已修行者令坐道场。我设供养请转法轮。请住世间利益众生莫般涅槃。是名菩萨称叹一切诸佛功德愿。善男子。云何菩萨降伏一切诸魔怨愿。菩萨摩诃萨作如是愿。我今应作如是等事。得成阿耨多罗三藐三菩提已。是我刹土不闻魔名。一切魔民不生我国。是名菩萨降伏一切魔怨愿。善男子。云何菩萨不由信他愿。菩萨摩诃萨不信他故。愿得成就阿耨多罗三藐三菩提。何以故。以智慧故作是思惟。此众生界滞生死苦无救无护。为救护故。发阿耨多罗三藐三菩提愿。是名菩萨不由信他愿。善男子。云何菩萨无边愿。菩萨发愿无有齐限行无执着。是故菩萨偏袒右肩右膝着地。至心劝请。观于十方一切世界。有诸菩萨坐于道场。有诸菩萨于十方界而成等觉。请转法轮。随诸众生根性不同而善忆念。凡是诸佛所说法要皆悉信解。如是信解而随喜之。作随喜已回向阿耨多罗三藐三菩提。是名菩萨无边愿具足。善男子。云何菩萨无怖畏愿。菩萨摩诃萨从初发心。闻诸佛法甚深甚深。闻佛功德甚深甚深。闻诸菩萨神通游戏甚深甚深。闻诸菩萨方便甚深甚深。不恐不怖不畏不惊。而作是念。诸佛菩提无量无边。诸佛境界无量无边。成熟众生无量无边。如我等类何能思算如来境界。所以者何。诸佛如来自能知之我不能知。是名菩萨无怖畏愿具足。善男子。云何菩萨无疲倦愿。菩萨若见刚强众生难调难伏。放逸自恣不肯受化。是诸菩萨之所厌患。如是刚强难调难化所厌患者。以是因缘。即生疲倦而弃背之。发愿往生清净世界诸佛净土。是净土中无如是等刚强众生及其名处。菩萨不欲闻是人名。何况相见。若有菩萨弃背众生。亦不能得诸佛净土而往受生。是中有智诸菩萨等发如是心。一切世界有诸众生。顽嚣暗钝聋盲喑哑无涅槃性。从彼世界诸佛菩萨所弃舍者。是等众生愿悉来集。我所庄严佛国土中。是等众生勿令有余。我皆令得阿耨多罗三藐三菩提。坐于道场觉了佛果。菩萨摩诃萨作是思时。从初发心一切魔宫无处不动。十方一切诸佛世尊之所称叹。而是菩萨所严佛国。速得成就究竟清净。证于阿耨多罗三藐三菩提。是名菩萨无疲倦愿。善男子。云何菩萨善毕竟具足愿。菩萨摩诃萨坐于道场破碎魔军。乃至得成阿耨多罗三藐三菩提。后不复发愿。是名得如所愿满菩提愿。譬如器皿酥油盛满平齐缘边。不复能容如邻虚滴。是故说言。此钵盛满究竟具足。菩萨摩诃萨证得佛道不复发愿。犹若邻虚亦复如是。一切诸愿究竟满故。是名善究竟诸愿具足。善男子。菩萨摩诃萨以是十法。愿波罗蜜具足。善男子。菩萨摩诃萨具足十法。力波罗蜜具足。何者为十。一者不可降伏力具足。二者不可破坏力具足。三者福德力具足。四者慧力具足。五者眷属力具足。六者神通力具足。七者自在力具足。八者陀罗尼力具足。九者不扰动镇力具足。十者超越无智力具足。善男子。云何菩萨不可降伏力具足。菩萨摩诃萨一切外道悉不能伏。是名不可降伏力具足。云何不可破坏力具足。善男子。菩萨摩诃萨于诸人天众生聚中。无一众生以其道力能得破坏菩萨力者。是名菩萨不可破坏力具足。善男子。云何菩萨福德力具足。菩萨于诸德福行中。无有一行若世间若出世间所不经行。是名菩萨福德力具足。善男子。云何菩萨般若力具足。菩萨摩诃萨于诸佛法。无有一法以善慧故是所不见是所不证所不通达。唯除如来深智慧耳。是名菩萨般若力具足。善男子。云何菩萨眷属力具足。菩萨眷属无破戒者无邪见者非威仪者无邪命者。所以者何。菩萨眷属随有资生共相分张。具足自利利他义故。是名菩萨眷属力具足。善男子。云何菩萨神通力具足。菩萨摩诃萨于诸世间神通之力及诸声闻缘觉境界。悉皆超越。何以故。菩萨神通力最胜故。若阎浮提内一毛中。而安立之亦无损减。如是四洲若干世界。若三千大千世界。若如恒河沙数世界内于一邻虚尘中。而安立之亦无增减。若二若三若四若五若六若七若八若九若十恒河沙。若可说不可说恒河沙数世界。内于邻虚尘中亦无增减。是等世界亦无妨碍。是中众生亦无逼迮。是名菩萨神通力具足。善男子。云何菩萨自在力具足。菩萨摩诃萨变此三千大千世界。化作七宝盈满其中。自在力故事无不遂。乃至不可说不可说世界七宝盈满其中皆悉自在。是名菩萨自在力具足。善男子。云何菩萨陀罗尼力具足。菩萨于诸不可说不可说诸佛刹土。絓是诸佛所说之法。种种文字种种章句种种意趣。于一刹那一罗婆一牟休罗。菩萨一闻悉能受持通达解说。是名菩萨陀罗尼力具足。云何菩萨不可扰动镇力具足。菩萨摩诃萨所镇之处。于诸人天众生聚中。无一众生能扰动者。唯除如来应供正遍知。是名菩萨不扰动镇力具足。云何菩萨超越无智力具足。菩萨于一切智皆悉超越。一切众生尚不能及。何况能过。唯除如来善解方便。是名菩萨超越无智力具足。善男子。菩萨摩诃萨具足十法力波罗蜜满足。善男子。菩萨摩诃萨具足十法智波罗蜜满足。何者为十。一者人无我智具足。二者法无我智具足。三者无分限智具足。四者三昧境智具足。五者镇智具足。六者不破坏智具足。七者观众生行智具足。八者无功用智具足。九者一切法相智具足。十者出世间智具足。善男子。云何菩萨人无我智具足。菩萨摩诃萨观见诸阴生时灭时。是阴生时无真实生。不动不作皆是虚妄。而观见之。是阴灭时不见败坏。复作是念。是阴无我无人无众生无寿者养育士夫。有诸痴顽婴儿凡夫。深着我见而作是解。是阴非我我中无阴。于五阴中深生执着。决言有体。故不通达真实法性。以不通达真实道理。是故流转于生死中。犹若火轮无有休息。菩萨于是真实法性。究竟通达无复有余。是名菩萨人无我智具足。善男子。云何菩萨法无我智具足。菩萨摩诃萨于损减谤如实而知。于增上谤如实亦知。而作是念。于假名法而为安立分别诸名。虽作分别所可分别。一切诸法本无自性。是等文句能分别者亦无自性。是法体性不如分别。名字分别不当其体。所以者何。一切诸法但有名相唯假名说。于是法中不应执着。是假名法非为究竟。一向非有。但此诸法依因他缘。藉他缘合而便得生。因缘散故其亦随灭。如是等法。菩萨摩诃萨如实而知。是名法无我智具足。善男子。云何菩萨无分限智具足。菩萨不于一刹那中而生于智。第二刹那而不生也。何以故。菩萨摩诃萨于一切刹那之中。智慧悉生无边无碍无有分限。是名菩萨无分限智具足。善男子。云何菩萨三昧境界智具足。菩萨摩诃萨悉知一切声闻三昧。悉知一切缘觉三昧。悉知一切菩萨三昧。一切如来三昧皆悉知之。于是三昧声闻行处菩萨悉知。于是三昧缘觉行处菩萨亦知。于是三昧菩萨行处菩萨亦知。于是三昧如来所行是佛三昧菩萨亦知。复有果报所可成就。自得智者皆悉知之。是名菩萨三昧境界智具足。善男子。云何菩萨镇智具足。菩萨若于声闻所镇。若辟支佛所镇。若菩萨所镇。菩萨尚不知。何况一切诸众生等。是名菩萨镇智具足。善男子。云何菩萨不可破坏智具足。菩萨摩诃萨一切智慧不可破坏。若诸外道若诸魔兵。若诸声闻若诸缘觉悉不能破。是名菩萨不可破坏智具足。善男子。云何菩萨观众生行智具足。菩萨摩诃萨以清净智皎洁明白。观众生界是中而见。有诸众生已发菩提心。有诸众生未发菩提心。有诸众生已修菩提行。有诸众生未修菩提行。有住初地乃至十地有成等觉。成等觉已正转法轮。佛事已讫而般涅槃。有诸众生以声闻乘而般涅槃。有缘觉乘而般涅槃。有诸众生生于天上。有诸众生生于三途。菩萨悉皆了了得见。是名菩萨观众生行智具足。善男子。云何菩萨无功用智具足。菩萨摩诃萨若行若立若坐若卧若出若入。不加功用是智恒生。犹若有人正眠熟时喘息恒生。菩萨智生亦复如是。如是智慧无处不遍。是名菩萨无功用智具足。善男子。云何菩萨了一切法相智具足。菩萨摩诃萨于一切法若通相若别相。若无量相。皆悉知之。若如幻相若虚妄相菩萨悉知。是名菩萨了一切法相智具足。善男子。云何菩萨出世间智具足。菩萨摩诃萨以无流智得具足故。超越一切世间人天。是名菩萨出世间智具足。善男子。菩萨摩诃萨具足十法智波罗蜜具足

大乘宝云经卷第二大乘宝云经卷第三

        梁扶南三藏曼陀罗仙共僧伽婆罗等译

    平等品第三

佛告降伏一切障碍菩萨摩诃萨言。善男子。菩萨具有十法与地平等。何等为十。一者广大无量。二者养育众生。三者有恩无恩无有异想。四者能受大法云雨。五者一切众生所依止处。六者种善根处。七者为珍宝器。八者为妙药器。九者不可倾动。十者无所怖畏。善男子。云何菩萨广大无量。犹若大地遍于十方广大无量。菩萨亦尔。遍一切处广大无量。福德智慧具双行故。是名菩萨广大无量。云何菩萨养育一切众生。善男子。譬如大地一切众生因之存立。种种资生随意得用。菩萨亦尔。长养众生。种于施戒忍辱精进禅定慧等。一切菩萨清净行法。及余无量资生什物皆悉利益。是名菩萨养育一切众生。云何菩萨有恩无恩无有异想。善男子。譬如大地若被损辱亦不生嗔。若有供养亦不生喜是中不作二想。菩萨亦尔。损恼不嗔利益不喜。于彼众生不生憎爱不望反报。是名菩萨有恩无恩皆悉平等。云何菩萨能受一切大法云雨。善男子。譬如大地受诸洪雨。及余一切诸大水聚悉堪容受。菩萨亦尔。如来所雨大法云雨悉皆容受。是名菩萨能受大法云雨。云何菩萨一切众生所依止处。善男子。譬如大地一切众生若出若入依于大地。菩萨亦尔。一切众生行于六趣及涅槃道而为依止。如是菩萨一切众生所依止处。云何菩萨种善根处。善男子。譬如大地一切种子因之生长。菩萨亦尔。一切众生诸善种子。依因菩萨而得增长。是名菩萨种诸善法种子之处。云何菩萨为珍宝器。善男子。譬如大地为珍宝器。依因于地无量珍宝皆悉出现。菩萨亦尔。种种功德光明珍玩。依因菩萨而得出现。是名菩萨为珍宝器。云何菩萨为妙药器。善男子。譬如大地出诸妙药。能治一切众生病苦。菩萨亦尔。一切法药因之出现。能灭一切世间种种烦恼重病。是名菩萨能为药器。云何菩萨不可倾动。善男子。譬如大地一切苦具不能侵扰。时节寒暑蚊蚁毒虫触之不动。菩萨亦尔不可扰恼。众生所起一切内外种种苦具悉不能扰。是名菩萨不可倾动。云何菩萨无有怖畏。善男子。譬如大地一切龙王及诸象王师子王等。所出音声闻不怖畏。菩萨亦尔。闻诸魔声及外道声。不恐不怖不怯不畏。是名菩萨无有怖畏。善男子。菩萨摩诃萨具是十法与地平等。善男子。菩萨摩诃萨具足十法与水平等。何者为十。一者福德渐深。二者生白净法。三者欢喜咨嗟润泽。四者渍烂一切烦恼根栽。五者清净无浊。六者灭烦恼热。七者除诸渴爱。八者甚深难冒。九者能漂好丑。十者净烦恼尘。善男子。云何菩萨摩诃萨福德渐深。善男子。譬如诸水次第流注渐入深处。菩萨亦尔。流注善法渐渐向深。是名菩萨福德渐深。云何菩萨生白净法。善男子。譬如水聚能生一切草木丛林种种妙药。菩萨亦尔。以三昧故生长一切助菩提法。已生长者重复增广。乃至成于一切种智。树木丛林于佛刹土令生法果活立众生。是名菩萨生长善法。云何菩萨欢喜咨嗟润泽。善男子。譬如清水自性润泽复润余物。菩萨亦尔。自性欢喜咨嗟润泽复润于他。言欢喜者是出世法。言咨嗟者依佛法僧。言润泽者是心清净。是名菩萨欢喜咨嗟润泽。云何菩萨渍烂烦恼根栽。善男子。譬如清水若草若木若根若叶皆能渍烂。菩萨亦尔。因修三昧一切烦恼根栽相续而渍烂之。乃至名相亦皆灭尽不知所在。烦恼臭秽习气亦尽。是名菩萨渍烂一切烦恼根栽。云何菩萨清净无浊。善男子。譬如净水体性清净无有垢秽。菩萨亦尔。自性清净无垢无秽。言清净者。一切随眠烦恼结使贪嗔痴等皆消灭故。诸根无染无垢无秽。是名菩萨清净无浊。云何菩萨灭烦恼热。善男子。譬如水性夏月蒸热。一切地土并诸地上。一切众生为作清凉。菩萨亦尔。诸众生界烦恼蒸热。以法净水悉令清凉灭其炽热。是名菩萨灭烦恼热。云何菩萨除诸渴爱。善男子。譬如冷水于渴乏者转其渴乏。菩萨亦尔。一切众生渴爱六尘难忽难耐。于是众生为降法雨。以法雨故令诸众生回六尘渴。是名菩萨除诸渴爱。云何菩萨甚深难冒。善男子。譬如水聚甚深难冒。菩萨亦尔。修诸智慧甚深难冒。所谓一切天魔外道不可轻冒。是名菩萨甚深难冒。云何菩萨能漂好丑。善男子。譬如水流一切地境若好若丑悉皆能漂。菩萨亦尔。以法流水若好若丑诸众生界一切能漂。虽如是漂不恼众生水流亦尔。如是菩萨以大慈悲润泽众生。降大法雨无所损恼。是名菩萨能漂好丑。云何菩萨净烦恼尘。善男子。譬如水大一切地上。不净尘埃粗涩垢秽。悉令润泽净无有余。菩萨亦尔。有诸众生心性粗犷烦恼客尘。依因定慧净尽无余。是名菩萨净烦恼尘。善男子。具是十法一切菩萨与水平等。善男子。菩萨摩诃萨具足十法与火平等。何者为十。一者能烧烦恼粪秽。二者成熟一切佛法。三者干燥烦恼淤泥。四者譬如火聚。五者能作光明。六者能令恐怖。七者善能安慰。八者于诸众生平等。九者世所供养。十者不可轻蔑。善男子。云何菩萨能烧烦恼粪秽。善男子。譬如火性能烧一切粪扫秽恶草木丛林诸药树等。菩萨亦尔。以智慧火能烧一切随眠烦恼一切结使贪嗔痴等烦恼粪扫。及对治道钻火之具皆悉烧尽。是名菩萨能烧一切烦恼粪秽。云何菩萨成熟一切佛法。善男子。譬如火性成熟一切苗稼药草。菩萨亦尔。以智慧火成熟一切内诸佛法。如是成熟永无有失。是名菩萨成熟一切佛法。云何菩萨干燥烦恼淤泥。善男子。譬如火性炙燥一切诸地淤泥。菩萨亦尔。以智慧火炙燥一切有流之法。是名菩萨干燥烦恼淤泥。云何菩萨喻如火聚。善男子。如诸火聚于寒冰者却其寒冻。菩萨亦尔。一切众生烦恼寒疟。以智慧火而为却之。是名菩萨喻如火聚。云何菩萨能作光明。善男子。如大火聚绝炎炽盛。若雪山上频耶山顶。若一由旬若二由旬。三四由旬而作光明。菩萨亦尔。以智光明能远照了。若千由旬若万由旬。乃至无量阿僧祇界。为诸众生作大光明照了明彻。以智光明悉能却除一切无智盲暗之法。是名菩萨能作光明。云何菩萨能作怖畏。善男子。譬如禽兽若师子王。见大火聚而生怖畏。所谓畏损我身远避是处。如是恶魔及诸魔众。若见菩萨而生怖畏。无威德故即便远避。乃至不能得闻菩萨名号。何况视之。是名菩萨能作怖畏。云何菩萨善能安慰。善男子。譬如一人迷于稠林旷野失其道路。忽然得见一大火聚而往就之。能于是中得见聚落若见群牛。得见是已便生安慰离诸恐怖。如是一切无量众生。遭于生死稠林旷野。若见菩萨则得安慰离诸怖惧。是名菩萨善能安慰。云何菩萨一切众生平等。善男子。譬如火性于诸众生悉皆平等。如于国王及旃陀罗平等无二。菩萨亦尔。于诸众生悉皆平等。如于国王悉作利益。于屠杀者亦作利益。是名菩萨于诸众生皆悉平等。云何菩萨世所供养。善男子。譬如火性为诸刹利婆罗门等之所供养。菩萨亦尔。为诸天人阿修罗乾闼婆一切世间之所供养作师范想。是名菩萨世所供养。云何菩萨不可轻蔑。善男子。如火虽小不可轻触无憍慢故。菩萨亦尔。住于信行从初发心未得势力。于大乘法不可轻蔑。若天若人一切世间天龙夜叉乾闼婆等所知所悉。作如是言。今此菩萨不久当坐菩提道场。证得阿耨多罗三藐三菩提。是名菩萨不可轻蔑。善男子。菩萨摩诃萨具足十法与火平等。善男子。菩萨摩诃萨具足十法与虚空平等。何者为十。一者广大。二者无碍。三者寂静。四者无边慧。五者无边智。六者随顺法界。七者信一切法同虚空性。八者无处所。九者过想境界。十者超越思量。善男子。菩萨摩诃萨具是十法得与虚空平等。复次善男子。菩萨摩诃萨复有十法与虚空平等。何等为十。一者于色好丑不贪不嗔。二者于声好丑不爱不憎。三者于香好丑不欲不恚。四者于味好丑不耽不弃。五者于触好丑不淫不怒。六者于法好丑不执不责。七者于得不得不喜不恨。八者于苦不戚于乐不欣。九者于好恶名不慕不却。十者称叹毁谤不亲不疏。如是十法与虚空平等。善男子。菩萨摩诃萨具足十法引喻于月。何等为十。一者清凉众生。二者见之欢喜。三者增长白法。四者除灭黑法。五者世所称叹。六者形貌清净。七者乘最胜乘。八者常为庄严。九者游戏正法。十者有大神通威德巍巍。云何菩萨清凉众生。乃至有大神通威德。善男子。譬如月出一切众生悉得凉冷。以可爱故。菩萨亦尔。能除众生烦恼蒸热令得欢喜。怡悦踊跃而作清凉。善男子。如月出时见之欢喜。以清凉故欣悦其心。菩萨亦尔。灭烦恼热诸根清净。威仪动止功德具足。善男子。如上旬月从其初生渐渐增长。至十五日具足圆满。菩萨亦尔。从初发心至坐道场。日夜白法增长圆满种种具足。善男子。如下旬月。色相光明可爱之貌渐渐损减。乃至月尽不复现相。菩萨亦尔。得出世智一切妄相皆悉损减。坐道场时毕竟不现。善男子。如月出时。一切世间大小道俗臣民男女悉称叹之。菩萨亦尔。一切世间人天修罗皆悉光扬。善男子。如月天子身心清净光明照耀业报所生。菩萨亦尔。身心清净光明遍照。法性所出自然化生。非因父母迦罗罗等五时不净之所污染。善男子。如月天子乘清净乘而照四方。菩萨亦尔。乘最胜乘遍照无量无边世界。善男子。如月天子常为庄严无时有翳。菩萨亦尔。常为功德所庄严故。善男子。如月天子恒有自然欢喜快乐。菩萨亦尔。恒住法乐不住欲乐。善男子。如月天子有大神通有大威德。菩萨亦尔。具诸功德自在智慧。神通变化随意无碍。善男子。菩萨摩诃萨具是十法故喻于月。善男子。菩萨摩诃萨具足十法譬喻如日。何等为十。一者灭无明暗。二者能令开悟。三者能照十方。四者善法因起。五者能灭诸流。六者能作光明。七者能翳外道邪见。八者显现好丑。九者造作善法诸业。十者善人恭敬。善男子。云何菩萨摩诃萨。灭无明暗乃至云何善人恭敬。善男子。如日出时灭一切暗。菩萨日出灭无明暗亦复如是。善男子。如日出时莲华开敷。菩萨日出开悟众生。诸受化者亦复如是。善男子。如日出时照了十方。菩萨日出智慧光明遍照十方。而不损恼一切众生。善男子。如日出时放千光明照阎浮提。世人方知是日出已。菩萨日出智光明照。尔时方知有诸善法。善男子。于阎浮提。日光灭时即知日没。菩萨日出于诸众生作智光明。能灭众生一切痴暗。重昏盲冥痴暗灭故。名为漏尽菩萨不现。善男子。如日出时诸余光明翳不能照。日于尔时不作是念。我令是等诸余光明翳不令照。以法尔故自然不现。菩萨日出一切外道邪见盲暗自然退灭。是时菩萨亦不作念。我令是等退灭不现。善男子。如日出时于阎浮提一切众生。为现好丑高下邪正。菩萨日出亦复如是。为诸众生显了好丑高下邪正。所言好者。则是圣道。所言丑者。一切邪道。善男子。如日出时种植等业因之得成。菩萨日出善法方生。善男子。如日出时善人欢喜供养称叹。而诸不良愁毒不乐。菩萨日出有智之人。聪哲利根欢喜称叹。行邪道者。婴儿凡夫钝根不良无智慧眼。愿乐生死背涅槃道而不恭敬。是名菩萨灭无明暗。乃至善人恭敬。如是善男子。菩萨摩诃萨具足十法譬喻如日。善男子。菩萨摩诃萨具足十法喻师子王。何等为十。一者不怖。二者无有怯弱。三者不回转顾。四者能师子吼。五者不惊。六者行于山林。七者居住山窟。八者无所储畜。九者独步无侣。十者住阿兰若。善男子。云何菩萨不怖乃至住阿兰若。善男子。如师子王遍行诸处不怖不惊。恒见自身独步无敌。菩萨亦尔。诸处来往不怖不惊。恒见自身无对敌故。善男子。如师子王无怯弱想。菩萨亦尔。与诸外道设捔力时论议斗诤无怯弱想不勇不劣。善男子。如师子王脱被辱时亦不回顾。菩萨亦尔。若为外道之所损辱。亦不可转亦不默然。善男子。如师子王作师子吼。一切禽兽及诸豺狼远走退散。菩萨亦尔。说法无我作师子吼。执着我见外道豺狼退散灭尽。于十方界而是菩萨不为恼彼。以无我法作师子吼。但为回转所化众生故。善男子。如师子王无所怖畏遍观十方。菩萨亦尔。性乐寂静行于山林。善男子。如师子王住于山窟。菩萨亦尔。安住智慧寂静山窟。善男子。如师子王无所储畜。菩萨亦尔却除一切烦恼重担无所储畜。善男子。如师子王独步无侣降禽兽群。菩萨亦尔。坐于道场独自无侣而破魔军。善男子。如师子王所住之处。一切禽兽不得侵损一切苗稼。菩萨亦尔。国土聚落居住之处。外道禽兽不能损侵善法苗稼。如是菩萨不怖不畏。乃至能护众生善根。如是善男子。菩萨摩诃萨具是十法喻师子王。善男子。菩萨摩诃萨具足十法善能调伏。何者为十。一者菩提心坚固。二者领理菩提心。三者守护六情。四者修行圣道。五者荷负重担。六者利益众生心不疲倦。七者正命。八者实无贡高。九者无谄曲欺诳。十者质直。善男子。菩萨摩诃萨具是十法善能调伏。善男子。菩萨摩诃萨具足十法世所知识。何等为十。一者坐禅摄心。二者多修空行。三者学法不息。四者不缘境界离烦恼使。奉行如来一切经教一向不犯。随顺一切法宗平等。通法界宗故。五者行于世间如旃陀罗卑下之子。以下卑心远离自高傲慢狂醉故。六者恒乞食活次第平等故。七者心无疑惑住于世间。于佛法中如实知见故。八者心无犹豫内证法故。九者不复他信不可诱引。自见道理故。十者世间福田。善修行故。如是菩萨摩诃萨具是十法世所知识。善男子。菩萨摩诃萨具足十法譬如莲华。何等为十。一者身无染污。二者微细之恶不与共住。三者戒香芬馥。四者受生洁净。五者姿颜和悦。六者柔软微妙。七者睹见吉祥。八者心意开悟。九者心意成熟。十者善能摄受。善男子。云何菩萨摩诃萨。身无染污乃至善能摄受。善男子。譬如莲华从水出时自无染污。如是无染以法性尔。如是菩萨从生死水出而无染。何以故。得方便智慧故。一切菩萨善解方便行在生死生死过患不能染污。菩萨方便智慧所持。善男子。如莲华中一滴之水不能得住。如是菩萨微细罪过悉不中住。善男子。如诸地界生莲华处香气芬馥熏是方所。如是菩萨是处乡村国邑聚落所居之处。以戒香气无处不遍善男子。如地界处有生莲华净洁可爱。国王王民一切百姓悉往就之。菩萨亦尔。诸处受生自性净洁。戒德威仪无不具足。天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽人非人等之所恭敬爱重礼拜。诸佛菩萨称叹光扬。善男子。犹如莲华开敷之时。见则欢喜色貌可爱能悦众情。菩萨亦尔。密笑之时无有颦蹙诸根清净。善男子。犹如莲华柔软无有粗涩。菩萨亦尔。自然柔软本无粗犷。善男子。如见莲华于梦想时则为吉祥。而加称叹而利益故。见于菩萨利益亦尔。一切住处甚为吉祥。为得一切智故。善男子。犹如莲华渐渐开敷。菩萨亦尔。智慧觉分莲华开敷。是时说名为佛觉悟。善男子。如莲华敷见时悦于眼根。嗅时悦于鼻根。触时悦于身根。心欢喜时悦于意根。菩萨亦尔。成熟智慧光时。见时眼根清净。闻时耳根清净。已有戒功德香而悦鼻根。触时供养恭敬而悦身根。若能思惟叹功德时意根清净。善男子。如莲华生人天摄受。菩萨亦尔。出于世间诸佛菩萨乃至诸天。帝释梵天护世之所崇仰。是名菩萨自无染污乃至摄受。善男子。如是菩萨具是十法喻如莲华。善男子。菩萨摩诃萨具足十法心意广大。何者为十。一者我当修行一切诸波罗蜜故发增广心。二者我当成熟一切佛法故发增广心。三者我当教化一切众生故发增广心。四者我当坐于道场。得成阿耨多罗三藐三菩提。成等觉已当转法轮。若梵若天一切世间所不能转故发增广心。五者我当利益一切众生。于无量无边世界发增广心。六者我当造作智慧舟航。度诸众生于生死海发增广心。七者一切众生无救无护无归依处。无有亲识能度脱者。我当为其作亲属故发增广心。八者我当显现诸佛威神作师子吼。游戏诸佛神通道力。亦当视顾摩诃那伽发增广心。九者我当不共一切世间若天若人。无比无等故发增广心。十者以佛正法。我当教化一切众生。非陋行故。非苦行故。非下劣行故。发增广心。善男子。菩萨摩诃萨具是十法发增广心。善男子。菩萨摩诃萨具足十法心得清净。何等为十。一者心多信乐心内不动。心住坚固心无虚假。远离一切不善思惟。所谓不发心求声闻道。求辟支佛道。以少欲知足故。远离一切垢秽不净。离身贡高所谓不作虚假威仪。离口贡高。所谓不说非实语言。离心贡高。无谄曲故。身不混杂故。口少欲故。心无贪求故。知恩报恩。微细恩义尚不忘失。何况多者。言语谛实。于所作事不毁谤他。无利不说。唯叹有德利喜劝叹。是中唯见功德如说而行。菩萨不得以口慰喻而心含怨。菩萨以口劝叹心不令诤。口说爱语心无忿恨。菩萨不以身现善而心行恶。菩萨不以身恭敬而心轻慢。菩萨无贡高不懈怠不吝惜不嫉妒。菩萨既无贡高。亦不懈怠不悭不嫉。亦不幻惑亦无谄曲。菩萨不斗两边互相破散。何以故。菩萨以身恭敬口说谛实。三业相应不谤如来清净正法。菩萨不敢谤法。云何不谤诸佛正法。菩萨发阿耨多罗三藐三菩提心。剃除须发着坏色衣。于佛正法而得出家。如是出家非畏国王故。不畏劫贼所破坏故。不负债故。不怖畏故。不为生活故而作沙门。以信乐故出家学道。唯求法故亲近善友深心承事。就善知识深心听法。如法修行心无憍慢。虽无憍慢而颠倒取若无颠倒。则能通达于佛正道。以通达故则得正法。以得法故决定阿耨多罗三藐三菩提。如是学者不谤如来正教正法。善男子。如是菩萨具足十法心得清净。善男子。菩萨摩诃萨具足十法无有疑惑。何等为十。信于如来身有秘密。信于如来口有秘密。信于如来心有秘密。信菩萨行。信具神通信满本愿。信一乘道。信种种说。信佛音声妙响甚深。信化众生随其根性。善男子。云何菩萨信于如来有身秘密。乃至信于教化众生。善男子。菩萨作如是念。所闻如来有是法身。寂静身。无等身。无等等身。无量身。不共身。金刚身。皆是真实不虚不诳。菩萨是处不生疑惑无有二心。如是信于如来身有秘密。复作是念。絓是所闻如来有口秘密。如来自口授记相貌授记。若不了义所说经教悉皆信之。如来无有蹉跌非无义说。以是因缘悉非妄语。诸佛如来灭一切恶清净无垢。无复烦恼结使燋热自在具足。无所希望无浊无秽。若言如来有失如来无义语者。无有是处。至真至实无有欺诳。是处不疑不惑。如是信于佛口秘密。复作是念。絓是如来心中秘密。在心内怀依止于心。一切声闻缘觉所不能知。及诸菩萨一切众生。唯除如来神通力耳。何以故。如来甚深难冒难量。境界广大无边无量。同于虚空不可思议。唯真唯实无有虚诳是处不疑。如是信心秘密。复作是念。絓是所闻一切菩萨勤利众生。成就一切众生。于是事业都无疲倦亦不怖畏。荷负大担力势坚固。修行十度一切佛法。有无碍智无边智无等智不共智。勇猛坚固庄严坚固誓愿坚固。为菩提故次第满足。唯真唯实非是欺诳是处不疑。如是菩萨信于修行。复作是念。菩萨坐于道场所得无滞无障无碍清净。眼通乃至耳通他心智通。宿命通如意神通漏尽通。无著无滞无障无碍。于三世中得一刹那相应智。视众生界如实见之。是等众生具足行身恶业。具足行口恶业。具足行意恶业。诽谤贤圣邪见颠倒。行于邪法业因缘故。舍身死后生诸恶道受地狱苦。有诸众生。以身善业以口意业善。正见具足故不谤贤圣行于正见。以正见故三业清净。以是因缘舍身死后。生于善道天上受乐。如是真实观众生界。即见众生善不善业。复作是念。我昔作菩萨时。行菩提道作是誓愿。自成正觉方令觉他是我前愿。今已果满得如所愿。皆是真实无有虚诳。是处不疑亦不生惑。故说菩萨名为等觉。已自觉悟名三佛陀。善男子。如是菩萨信于菩提信佛出世。复作是念。所闻一乘唯一佛乘皆是真实。非是欺诳不虚不谬。所以者何。诸乘皆从大乘中出。譬如阎浮提洲乃有诸洲而相围绕各各名字皆悉属于阎浮提洲。总说其名入阎浮提一切诸乘亦复如是。依大乘出无二无三是处不疑。如是信于一佛乘道。复作是念。闻诸如来种种说法。于诸经中悉是真实。所以者何。为化众生故。而诸如来随机说法。是处不疑亦不生惑不作二心。如是信于三乘有异。复作是念。闻诸如来响音甚深微妙梵音悉皆真实。所以者何。诸梵天子少分善根。尚有音声微妙响彻。柔软了亮雅美可爱。何况如来于无量劫修行成就。百福庄严万德具足。是处不疑不惑。如是信于如来甚深响音。复作是念。闻佛如来了别机性诸根利钝。所化众生闻以一音说法。随类各各得解断其疑心。善根成熟者而前化之。一一众生作如是解。如来今者为我一人说如是法。而诸如来无是分别亦无思惟。是等悉皆真实非谬非诳。是处不疑不惑。生如是信。随机缘故教化众生。善男子。如是十法具足菩萨摩诃萨无疑惑心。善男子。菩萨摩诃萨具足十法喻如大海。何等为十。一切珍宝之所归聚。难冒广大渐渐转深。不宿死尸等为一味。复能容受一切川流。不过齐限。诸大众生之所依止。无有边际。善男子。云何菩萨众宝归聚。乃至云何无有边际。善男子。譬如大海一切珍宝。是中聚集无量无边。一切众生往彼采宝。菩萨亦尔。一切功德珍宝聚集无量无边。一切众生求福德者而往诣之。善男子。如海难冒。菩萨亦尔甚深难冒。善男子。如海广大菩萨亦尔。慈悲智慧甚广大故。善男子。譬如大海渐渐转深。菩萨亦尔。修道种智渐渐转深。善男子。如彼大海不与一切死尸共宿。所以者何。大海法尔。如是菩萨不与一切烦恼及恶知识而共止宿。何以故。菩萨法尔故。善男子。如此大海一切众流悉往入之。至成一味所谓碱味。菩萨亦尔。絓是所修一切白法悉成一味。所谓一切智味。善男子。如海容受无量众流不增不减。菩萨亦尔。受无量法无有增减。善男子。如彼大海不过齐限。菩萨亦尔。教化众生不过齐限。善男子。如大海水大身众生在中居住。菩萨亦尔。一切众生有白净法。于菩萨身依止而住。善男子。如大海水无有边际。一切众生不能知其水之多少。菩萨亦尔。为诸众生而说法要。无边无穷无能测量。如是菩萨大海福德珍宝聚集之处乃至无边。善男子。如是菩萨具足十法喻如大海

大乘宝云经卷第三大乘宝云经卷第四

        梁扶南三藏曼陀罗仙共僧伽婆罗译

    陀罗尼品第四

尔时佛告降伏一切障碍菩萨摩诃萨言。善男子。菩萨摩诃萨具足十法深解微细。何等为十。所谓解求出离。解究竟诸法。解具足一切法。解随顺一切法相。解分析一切诸法。解十二因缘甚深难冒。解业力不可思议。解如所说深义。解通达顺如道理。解一实谛。善男子。云何菩萨解求出离。乃至云何解一实谛。菩萨恒作是念。一切世间痛哉苦哉。八苦猛火之所焚然。淫欲炎盛烧其身首。嗔烟蓬勃妄想乱起。无明痴暗障蔽眼目。菩萨见已复作是念。是等众生云何出离三界火宅得脱火难。为是众生得脱因缘。是故求解诸法。求得随顺诸法平等。得平等已如实了知诸法幻相。了知幻已则如实知。如实知已而顺观察甚深难冒十二因缘。得缘观已观察业力不可思议。作是观已生大希有。而作是念。一切诸法虽无自体而能巧作种种色像。如是微细以意觉了。所说诸义则得明解。已了义故通达真如。达真如已得见实际。见实际已则能度脱一切众生生死火宅。善男子。如是菩萨解求出离。乃至解一实谛具足如是十法菩萨摩诃萨深解微细。善男子。菩萨摩诃萨具足十法辩才会理。何等为十。所谓一切诸法但是假名。无我无人无众生无寿者无养者无造者无受者无知者无见者。危脆灾厄不能自由空无所有。虚妄分别因缘假合。如是假合假名说之。善男子。有此道理随顺法相。无人无我众生寿者造者受者知者见者。无有自在虚妄分别。因缘假合。如是说法有此道理随顺法相。不违法相与理相应。如是观察实法道理。悉不颠倒显了法相。如是辩才与理相应。是故说名辩才会理。善男子。具足十法菩萨摩诃萨辩才会理。善男子。菩萨摩诃萨具足十法辩才明了。何等为十。所谓解结辩才。无尽辩才。无断绝辩才。无不润辩才。无下劣辩才。无怖畏辩才。无比辩才。不可沮坏辩才。无穷辩才。四无碍具足辩才。善男子。菩萨摩诃萨具是十法辩才明了。善男子。菩萨摩诃萨具足十法净洁辩才。何等为十。所谓无吃讷辩才。无恐怖辩才。无劣弱辩才。不自逞辩才。不损义辩才。不损文辩才。不失方法辩才。无失时辩才。无粗涩辩才。无不明了辩才。善男子。菩萨辩才无诸吃讷。所以者何。以无所畏故。菩萨在大众中如师子王不畏不怯。菩萨辩才不逞不谄。何以故。远烦恼故。有烦恼者而恒自逞非无烦恼。菩萨辩才义无损减。何以故。得法尔故。菩萨无无义辩才。何以故。证得法故。善男子。未证法者有义损减非得法者。菩萨辩才无文损减。何以故。通学一切诸经论故。不学经论有失文章。若学经论无有此失。菩萨不失方法。何以故。已修一切诸方法故。菩萨善学无量经法不失时节。无前后失。故菩萨无粗涩辩才。无有粗恶无逆耳语。何以故。远离恶口诸过失故。菩萨辩才无不明了。何以故。具利根故。善男子。菩萨摩诃萨具是十法辩才净洁。善男子。菩萨摩诃萨具足十法。能令一切众生欢喜辩才。何等为十。所谓爱语。姿颜悦豫无有颦蹙。恒说义理。恒说正法。说法平等。不逞自能无所轻蔑。心无污染不轻躁动种种辩才。善男子。菩萨爱语。能令众生心得欢喜。姿颜光悦无有颦蹙。咨嗟具足和悦众生。恒说义理。优量语故悦众生心。恒为说法。利益语故而悦众生。说法平等。于诸众生令悦其意。菩萨不自逞能。远离憍慢自恣矜高。随众生类而教导之必令欢喜。菩萨无所轻蔑。殷勤为说令得欢喜。菩萨无所染污。持净戒故令众欢喜。菩萨不轻躁动。多修忍故。菩萨种种辩才。以爱语故令众欢喜。善男子。菩萨摩诃萨具是十法辩才。能令一切众生欢喜。善男子。菩萨摩诃萨具足十法言语辩才人所信受。何等为十。所谓菩萨。于诸众生非是法器而不为说。谤法众生亦不为说。有来调弄亦不为说。外道邪见亦不为说。无恭敬者亦不为说。无信心者亦不为说。幻惑谄曲亦不为说。不为自身乏无资生故为说法。不为利养嫉妒悭吝故为说法。散头裸袒及喑哑者不为说法。所以者何。善男子。菩萨于诸众生无有悭吝亦无秘法。无不怜愍无不利物。但诸众生于佛法中非法器故。是故菩萨而不摄受。降伏一切障碍菩萨言。世尊。有何众生菩萨为其说法。佛言。善男子。菩萨说法为诸众生。有信根者可成熟者。具有法器于过去佛已种善根。无有谄曲离诸欺诳。所有威仪实无虚假。不着世间名闻利养。具足信心善友摄持。行诸善业易可开悟。利根众生于所说义能解意趣。精进勇猛能得佛果如说修行。善男子。如是众生诸佛菩萨而为说法。善男子。菩萨摩诃萨。具是十方所出语言悉可信受。善男子。菩萨摩诃萨具足十法善能说法。何者为十。所谓但为修行诸佛法故而演说法。如是说法而佛及法俱不可得。但欲修行诸波罗蜜而为说法。而是修行及波罗蜜亦不可得。为菩提行菩萨说法。而是菩提及菩提行皆不可得。为灭烦恼故为说法。不得烦恼及烦恼灭。为修厌离而证灭故。菩萨说法不得厌离亦不得灭。为须陀洹。为斯陀含。为阿那含。证得果故。菩萨说法亦不得是。须陀洹及斯陀含阿那含等悉不可得。为阿罗汉果故菩萨说法。亦不可得阿罗汉及阿罗汉果。为得辟支佛果故菩萨说法。缘觉及果俱不可得。为灭执着诸我见故菩萨说法。我与执着皆不可得。菩萨虽说有诸业报。业及业报亦不可得。何以故。作是思惟。所说之法依因名字。依此名字寻法不得。所以者何。所言法者。非文字体。夫文字者亦无法体。以是义故。依于假名俗谛故说于无名法而立名字。如是名字皆是虚妄而非真实。非真实者非第一义。既非真谛是虚妄法。诳惑一切婴儿凡夫。善男子。菩萨摩诃萨具是十法善能说法。善男子。菩萨摩诃萨具足十法无不随顺。善男子。菩萨随顺于法不出于色。随顺于法不出受想行识。随顺于法不出欲界。随顺于法不出色界。随顺于法不出无色界。随顺于法不出于法。随顺于法不顺众生。随顺于法不顺断见。随顺于法不出于道。以智善巧方便相应非不随顺。善男子菩萨摩诃萨具是十法无不随顺。善男子。菩萨摩诃萨具足十法善解法界。何者为十。所谓智慧具足为善知识之所摄受。勇猛精进远离一切障碍善能清净。于所教诲生殷重心。多修空相远离僻见。善行圣道了见真实。是为十法。善男子。慧命菩萨亲近善友。见善知识生欢喜心。于善友中生世尊想依止而住。依善友已勇猛精进。为灭一切不善之法。成就满足一切善法。如是勇猛一切障碍悉皆灭尽。无障碍已不息于道故得清净。远离一切身口意恶及破戒业。得清净已于所教诲生殷重心。殷重教已多修空相。修空相已不生倒见。离倒见已而修圣道。修圣道已而见真实。降伏一切障碍菩萨言。世尊。何者名为真实。佛言。善男子。夫真实名非颠倒名。世尊。何者是非颠倒。佛言。善男子。非是虚妄名不颠倒。世尊。何者是非虚妄。佛言。即是如如无变异法。世尊。何者名如如。佛言。夫如如者。谓是内所证知之法。不可文字之所显示。所以者何。是法一切言语道断。文字章句所不能诠。过音声界离诸口业绝诸戏论。不增不减不出不入不合不散。非可筹度不可思量。过算数境非心行处。无碍无想过想境界。过诸婴儿一切境界。一切婴儿所不行处。过一切魔境界。过一切烦恼境界。过识境界无所住处。无住寂静圣智行处。如是如是内所证。无垢无污无染清净。微妙第一毕竟最胜。常恒湛然无生灭法。如来出世及不出世法界常尔。善男子。菩萨为是法故精勤不懈修行精进忍种种苦。如是苦行证是法界。于是法中。复加安立一切众生。善男子。是名如如。是名实际。是名一切智。是名一切种智。是名不可思议界。是名无二界。降伏一切障碍菩萨言。世尊。云何应证云何应得。如是法界说名内所证得耶。佛言。善男子。以出世智故内应当证内应当得。降伏一切障碍菩萨复白佛言。世尊。以智所证得是内证得不。佛言。善男子。不也。何以故。以智慧故如实见法以身证之。菩萨复言。世尊。诸善男子。若以闻慧若以思慧。得证是法。名内证不耶。佛言。善男子不可也。何以故。不可以闻慧。不可以思慧内证此法。善男子。我今为汝说于譬喻。善男子。如大旷野林中夏月后分。设有一人从东方而往西域。复有一人从于西方而往东域。以蒸热所苦渴乏恼乱。路中逢见。东方来者而问之曰。仁者。我今热恼所苦渴乏烦躁。汝可为我示于道路。若池若湖有清净水凉冷无浊。能为我除此渴乏者。是时东方来人谙悉道路。经见善知水路之相。己曾自饮洗浴是水。便报之曰。仁者。以此道路汝但直去。若于是处见有二道。可避左边而行右道。乃至得见郁茂丛林。是丛林中有三池水。清净香美柔软轻冷八德具足。善男子。于汝意云何。是人为热所苦渴乏逼恼。但闻水名唯思是水除渴乏不。即证此水凉冷以不。对曰不也。世尊。如渴乏者。要须至彼清冷水处。得饮浴已渴乏乃除方自证知。善男子。闻思二慧不得内证。亦复如是。善男子。言丛林者。即生死之名也。热恼所苦者。一切众生也。何以故。三障烦恼热所逼故渴乏五欲。所言示道路者。则是菩萨之名也。善解一切智道经证是法内证得法故。言清冷水者。即是第一义谛之名也。复次善男子。我今为汝更说譬喻。汝当听之。善男子。于意云何。诸佛如来。若住世界一劫寿命。于阎浮提人前称叹甘露之味。所谓色香美味清净具足柔软。是诸众生。闻叹是食得饱以不。不也世尊。佛言。善男子。以此义故应当知之。闻思二慧不可内证得如是法。复次善男子。谛听譬喻。善男子。如有一人经食甘果知其美味。于众人前而称叹之。具足色香味触。善男子。汝意云何。是等众人闻说果味得果味不。不也世尊。佛言。善男子。依此义故应当知之。闻思二慧不可内证得如是法。降伏一切障碍菩萨言。善说世尊。善说善逝。世尊。是等众生何当得是法。由闻此经历耳因缘故。所以者何。世尊。是等众生为得此法。因闻是法无颠倒故。佛言。如是如是如汝所说。得闻是法以不颠倒故。当得是法如我不异。善男子。菩萨摩诃萨具是十法善解法界。善男子。菩萨摩诃萨具足十法行空境界。何等为十。所谓力空。无畏空。佛不共法空。戒藏空。定藏空。慧藏空。解脱藏空。解脱知见藏空。一切法空。空空。悉皆了知。不以此因缘故。而得空法亦不着空。亦无空见亦不依空。亦不以此因缘故堕断灭相。善男子。菩萨摩诃萨具是十法行空境界。善男子。菩萨摩诃萨具足十法住于无相。何者为十。所谓离于外相。亦离内相。离诸戏论。离一切分别。离一切有所得。离一切动转。离一切行处。离一切境界。不得于识亦不得所识之法。善男子。菩萨摩诃萨具是十法住于无相。尔时降伏一切障碍菩萨白佛言。世尊。诸佛菩萨云何观察是无相法。佛言。善男子。是处不可思议其义深妙。何以故。过意识境界故。一切众生于是法处皆生狂乱。善男子。是如来法不可思议。一切众生不能得见。是如来法微妙甚深。不可思算劳累心识。所以者何。善男子。是法难入甚深甚深不可思议。无彼无此等于虚空。一切论师非其境界。不能思量不能筹度。降伏一切障碍菩萨言。世尊。我于今日重欲咨启。愿垂听许。佛言。善男子。随汝所问我当答之。降伏一切障碍菩萨即白佛言。如佛所说。此无相法一切众生不能得见。是如来法谁能信者。如来法王而自称叹。将非贡高增上慢耶。夫贡高者非大人相。佛言。善男子。善能咨问。谛听谛听善思念之。唯然世尊。佛言。善男子。佛无憍慢亦无贡高。不为名闻不为利养不为知识。非虚自叹非虚自高。但为利益一切众生故。为得此法故而作是说。所以者何。是等众生于如来边闻是所说。得大欢喜无量清净。当得是法不异今日。为是法器长夜利安。乃至能得阿耨多罗三藐三菩提。降伏一切障碍菩萨言。世尊。是等众生将不知佛之威神耶。佛言。善男子。是等不知。何以故。心下劣故。善男子。此佛刹土多有众生。小意下劣薄弱卑陋。小智小信少分善根。是故不知如来威神之德。为是众生故佛自叹己。令彼于佛而生信故。善男子。如一医王善巧治病。时多众生深滞疾苦。是处聚落唯有此医无二无三。诸病人众都无一人识是医者。善能疗治具大威德。是时医师而作是念。此等病者困苦可矜。众恼所逼不识药性不识增损。我今当为是等众生疗治令差。是时医王于病众前而自叹己。汝等病人。应知我是大医之王。善巧治病了知病源善解诊药。病者闻已信知是医而往依附。是大医王即为病人而疗治之。种种疾病应时得差。善男子。于意云何。是医可得名贡高不。不也世尊。佛言。善男子。诸佛如来亦复如是。为大医王了知一切烦恼重病。亦知烦恼病之根源。普施众生大法妙药。烦恼病者所不识知。如来医王见是事已。于病众前而自称叹己之功德。诸众生等闻说如来真实功德。皆生信心归投如来。为是等人如来大医。以大法药种种微妙。疗治一切烦恼重病悉皆灭尽。何者名为大法药耶。所谓不净观。慈悲观。十二因缘等观。善男子。佛见如是无量利故。自叹己德非贡高也。善男子。菩萨摩诃萨。具足十法远离一切依愿。何者为十。所谓虽愿布施不依于施。虽愿戒忍精进禅定智慧。及以三界菩提涅槃悉皆不愿。所以者何。菩萨远离一切诸愿。以无所愿遍行世间。善男子。菩萨摩诃萨。具是十法远离一切依愿。善男子。菩萨摩诃萨。具足十法以慈为身。何者为十。所谓无少分慈具足。无彼此慈具足。法慈具足。寂静慈具足。不追过慈具足。利益慈具足。于诸众生生平等慈具足。无忿恨慈具足。于十方界普覆慈具足。出世间慈具足。善男子。菩萨摩诃萨。具足十法以慈为身。善男子。菩萨摩诃萨。具足十法以悲为身。何等为十。所谓见诸众生困苦无救无护无归依处。发菩提心。发是心已努力修行。勇猛精进为得是法。得是法已为诸众生而作利益。见悭惜者劝住于施。见破戒者劝令持戒。见嗔恨者劝修忍辱。见懈怠者劝修精进。见散乱者劝修摄心。见无智者劝修智慧。菩萨摩诃萨见诸众生剧苦所逼难可堪忍。是故不退于菩提行。善男子。菩萨摩诃萨。具足十法以悲为身。善男子。菩萨摩诃萨。具足十法住于欢喜。何者为十。所谓我已得出远离三有火宅牢狱。故生欢喜。我已断除生死罗网无始缠缚。故生欢喜。我已得度种种觉观蛟龙乱住生死大海。故生欢喜。久远戴立憍慢之幢我已倾倒。故生欢喜。我以金刚智杵破碎烦恼高山令究竟尽无复遗余。故生欢喜。我已稣息复为安慰未稣息者令得悦意。故生欢喜。我已觉寤无始久远世间睡眠渴爱所逼。无明痴暗障蔽眼目。未觉寤者复令觉寤。故生欢喜。我已得脱六趣恶道种种苦报。复当度脱诸余众生遭是恶道受苦报者。故生欢喜。我无始来迷于生死旷野稠林。独无伴侣慞遑乱走。未曾见路不识正道无示导者。今日欻然值遇导师。故生欢喜。我今渐近一切智城邻于佛座。故生欢喜。善男子。菩萨摩诃萨。具是十法住于欢喜。善男子。菩萨摩诃萨。具足十法住优毕叉。何者为十。所谓眼识所了诸色境界。此中舍离不以色境而自损害。不作疮疣。耳所听声。鼻所嗅香。舌所得味。身所觉触。意所了法。皆悉舍离。不以意识了诸法故。而自损害为作疮疣。亦不隔碍。于行苦中。于苦苦中。于坏苦中。舍离而住。于此三苦不自损害不作疮疣。亦无隔碍。于事已办。众圣人边舍心而住。于圣人边生大欢喜。复作是念。是等圣人本凡夫地我应化度。其今成圣我愿已得。故住舍心。善男子。菩萨摩诃萨。具是十法住于舍心。善男子。菩萨摩诃萨。具足十法神通游戏。何者为十。所谓从兜率下。托神母胎。示现受生。处宫受乐。踰城出家。乐于闲寂苦行修道。降制魔军。坐于道场而成正觉。转于法轮。示现涅槃。降伏一切障碍菩萨白佛言。世尊。何因缘故。菩萨摩诃萨。示现兜率天下。乃至示现涅槃。佛言。善男子。于彼兜率天宫。有诸众生执有常想。时见菩萨世间最胜。至尊至极无上无边。不染欲乐从彼退堕。是其所执常想即灭生无常想。依无常想故不放逸。善男子。于彼天宫有诸众生多放逸者。于菩萨所生欢喜心。恋着欲乐而不欲往。修觐菩萨亦不承事。其作是念。菩萨常在我等亦在。时节长远何虑不得往亲近之。是故菩萨为除是等众生放逸。故现退堕。彼诸众生忽见菩萨于彼堕坠。大生懊恼远离五欲不复放逸。无放逸故。决定当得阿耨多罗三藐三菩提。善男子。有诸众生宜于胎中受教化者。菩萨在胎威神巍巍。是等见已即生希有。为是众生菩萨处胎。随其所宜而为说法。必令决定当得阿耨多罗三藐三菩提。善男子。有诸众生。宜于菩萨作婴儿时。及在宫中应可成熟。而诸菩萨为彼众生得成熟故。及余下劣众生乐小法者为随顺故。是故示现作婴儿相住于宫中。善男子。有诸众生宜见菩萨踰城出家。是菩萨为彼众生令成熟故。而示是等踰城出家。善男子。有天龙夜叉乾闼婆等。乐于弊陋。为是等故示现苦行。复为降伏诸外道故示现苦行。善男子。有诸众生待菩萨坐道场时。我当到彼设诸供养。为是等故现坐道场。是诸众生诣菩萨所而设供养因缘决定。当得阿耨多罗三藐三菩提。善男子。有诸众生憍慢刚强。为折伏故菩萨坐于道场降伏魔军。善男子。有诸众生成熟善根。为进修德胜利益故。是故菩萨现登正觉。是时菩萨登于正觉。三千大千世界种种音声悉皆休息。三千大千世界无不寂静。是等众生见是事已发弘誓愿。愿我来世坐于道场。证得阿耨多罗三藐三菩提。善男子。有诸众生谓言自是世间之师。而未觉了究竟出离清净之法。于当来世亦无其分。但为折伏是众生故。有诸众生善根成熟堪为法器。为是等众示现道故。而是菩萨得道之时。往诣迦尸城转于法轮。其轮十二三转具足。于大众中而师子吼。善男子。有诸众生宜于涅槃受教化者。为化此等是故菩萨现般涅槃。善男子。以是因缘示现从兜率天下阎浮提。乃至涅槃而示现之。善男子。菩萨摩诃萨。具是十法神通游戏。善男子。菩萨摩诃萨。具足十法远离八难。何等为十。所谓远离一切诸不善业。于诸如来所制禁戒不敢故犯。远离悭贪。于过去佛种诸善根。福德相应智慧具足。善巧方便发弘誓愿。修厌离想勇猛精进。善男子。菩萨不造诸不善业。不感地狱。有诸众生堕于地狱受于种种不如意苦。受苦既久于彼众生在地狱者互生嗔恚。而是菩萨性戒清净十善具足。是故菩萨不堕地狱。善男子。菩萨摩诃萨。于诸如来所制禁戒不敢故犯随顺受持。是故不生畜生恶道。何以故。是诸畜生受畜生苦故。善男子。菩萨摩诃萨无悭贪心。悭贪因缘堕饿鬼道受饿鬼苦故。菩萨摩诃萨。不生邪见卑下之家。何以故。邪见众生不得亲近善知识故。所以者何。菩萨累劫久于过去诸如来所种诸善根。以是因缘生生世世。生正见家富足钱财。具足修道习因成就。展转增长福德智慧。菩萨摩诃萨所得诸根无不具足。以是因缘诸根具足为佛法器。是故菩萨功德成就。既与福德业相应故。于佛塔庙于法于僧设诸供养。供养因缘修习善业。是故而得诸根具足。诸根具故是则得为诸佛法器。菩萨摩诃萨不生边地。何以故。边地众生暗钝痴顽。喑哑不了不解言语似于羺羊。不堪听受善不善法。甚深意趣不识道理。而不堪为甘露法器。不名沙门不名信士。是故菩萨生于中国。中国众生利根聪哲。诸根明了智者称叹。堪受所说善不善法深解意趣。堪为诸佛甘露法器。名为沙门名为信士。何以故。过去愿力智慧力故。菩萨不生长寿天中。若生住彼。无量诸佛出于世间不沾法润不获法利。饶益众生便尔被废。是故菩萨生于欲界。教化成熟下界众生值佛出世。何以故。如是菩萨巧方便故。菩萨不生无佛出处。何以故。是中众生不闻佛名不闻法名不闻僧名不敬三尊。是故菩萨所生刹土有三宝处。如其过去所发誓愿具足满故。众生[怡-台+龍]悷刚强难化。菩萨不尔。何以故。闻八难苦无不厌离。以厌离故勇猛精进修行正勤。灭如是等不善法故。善男子。菩萨摩诃萨。具是十法远离八难。善男子。菩萨摩诃萨。具足十法不忘菩提心。何等为十。所谓远离幻惑谄曲贡高。质直和雅信心清净。于正法中断除疑悔。于诸众生乐受法者。而不吝惜不作秘师。絓是能损正法因缘皆悉远离。不相违犯如说修行。受持大乘一切诸典。若见有人持大乘者生殷重心。恭敬礼拜作同学想。一心一意听受大乘。于说法人生如来想。善男子。菩萨摩诃萨。具是十法不忘菩提心。善男子。菩萨摩诃萨。具足十法得宿命智。何等为十。所谓已多供养承事诸佛。已曾受持诸佛正法。戒品清净远离掉悔。无有诸障心多欢喜。修心令直得入禅定。恒受化生无疑惑心。善男子。菩萨摩诃萨。以多供养过去佛者敬重正法。于持法人生谦下心。以是因缘就听正法。受持读诵通利文句。广为他人分别解说。不惜身命而弘正法。禁戒清净者。所谓于三品戒若身口意持净戒故。离诸掉悔而生恭敬。所以者何。以戒清净故而无掉悔。无掉悔故而离障碍。离障碍故而生欢喜。多欢喜故而能堪任修心令直。以修心故则得入定。得禅定故六道清净。六道净故而受化生。受化生故无疑惑心。无疑惑故得宿命智。追忆过去一生二生三四五生十生二三十生四五十生乃至无量百万亿生。善男子。菩萨摩诃萨。具是十法得宿命智。善男子。菩萨摩诃萨。具足十法值善知识。何等为十。所谓不离见佛。不离闻法。不离供养众僧福田。不离恭敬礼拜谦卑合掌承事诸佛菩萨。不离多闻及说法者。不离闻诸波罗蜜行。不离闻三十七品助道之法。不离闻三解脱门。不离闻于四无量心。不离闻于一切种智。善男子。菩萨摩诃萨。具是十法得值善友。善男子。菩萨摩诃萨。具足十法远离恶知识。何等为十。所谓远离破戒人故。当知名为离恶知识。远离邪见人故。远离失威仪人故。远离邪命人故。远离喧闹混杂中住故。远离懈怠懒惰人故。远离乐住生死人故。远离背菩提行人故。远离交习在家人故。远离一切烦恼故。是则名为诸恶知识。菩萨摩诃萨当远离之。善男子。虽离是处。于众生边不生恶心亦不生嗔。心无恼热亦不轻蔑。于前众生而作是念。如佛所说一切众生是气类聚。为近恶知识故失于大利。是故我今速当远离诸恶知识。善男子。菩萨摩诃萨。具足十法离恶知识。善男子。菩萨摩诃萨。具足十法得佛法身。何等为十。所谓无等等身。清净之身。无疮疣身。非修得身。不可思算身。甚深法身。非思议身。寂静之身。虚空等身。佛智之身。善男子。菩萨摩诃萨。具是十法得佛法身。降伏一切障碍菩萨白佛言。世尊。菩萨摩诃萨何处住止。能得如来如是法身。佛言。善男子。于初地中得无等等身。何以故。远离一切身差别故。随顺一切菩萨平等法故。二地菩萨得清净身。戒品清净故。三地菩萨得无疮疣身。远离一切嗔恨故。四地菩萨得非修得身。已经修佛法故。五地菩萨得不思算身。已得通达一切法故。六地菩萨得甚深法身。已修不可思量法故。七地菩萨得不可思议身。已修善巧方便故。八地菩萨得寂静身。已远离一切戏论无烦恼故。九地菩萨得虚空等身。光明彻故。十地菩萨得妙智身。何以故。遍修一切所知境故。降伏一切障碍菩萨白佛言。世尊。如来法身菩萨法身。将无差别耶。佛言。善男子。得种种身无有差别。功德明昧亦有差别。降伏一切障碍菩萨言。世尊。云何种种身而无差别。功德威神独有差别。佛言。善男子。彼身此身无有差别。何以故。修一身故。而是功德威神之相。殊有差别。应当观之。降伏一切障碍菩萨言。世尊。两身差别当云何观。佛言。善男子。谛听谛听。我当为汝说于譬喻。成是义故。善男子。如摩尼珠磨莹治饰光曜明净以练治故。于诸摩尼未被练者。比前摩尼可相及不。不也世尊。被练治者光色净彻悦众意故。未被治者不得为类。佛言如是。菩萨身摩尼珠。及如来身摩尼之珠。虽复同是清净法身。菩萨法身于如来身。毕竟清净不可为比。所以者何。如来身者不可限量。齐众生界彻虚空界遍照而住。何以故。最极清净远离一切诸尘垢故。而菩萨身摩尼珠明彻不尔。何以故。有余垢故。善男子。譬如初月其光始显渐渐增长。至十五日方乃圆明。俱得月名。而此初月。不可比于十五日夜。何以故。得法尔故。诸佛菩萨虽复同得法身之名。而菩萨身于如来身。光明遍照不可为比。善男子。如是佛身及菩萨身。同是身相。与佛功德威神之相。非为一相。善男子。菩萨摩诃萨。具足十法获得金刚贞实坚固不破坏身。何者为十。所谓贪嗔痴等不能破坏。怨憾忿恨灾盖憍慢。贡高邪见颠倒不能破坏。世间八风不能破坏。三恶道苦不能破坏。众生诸苦不能破坏。生老病死不能破坏。外诸梵志诸邪论师不能破坏。一切众魔及诸天魔不能破坏。一切声闻及缘觉等一切欲乐亦不能坏。善男子。菩萨摩诃萨。具是十法获得金刚贞实坚固不破坏身。善男子。菩萨摩诃萨。具足十法作大萨泊主。何者为十。所谓堪可庆贺。堪为恭敬。能令济度。堪可依止。能为安立资粮丰厚。修理行具。无有厌足。引导上首。善能随入一切智城。善男子。云何菩萨堪可庆贺。乃至善能随入一切智城。善男子。如萨泊主。国王朝臣宰相所可庆贺。如是菩萨大萨泊主。诸佛菩萨所可庆贺亦复如是。善男子。如萨泊主。刹利百民之所恭敬。菩萨宗主。学无学人及余天龙夜叉乾闼婆所可恭敬。亦复如是。善男子。如大宗主。于大山林旷野险难。而能济度令得安乐而无疲倦。菩萨宗主。在于生死稠林旷野。众生群品遭诸烦恼劫贼逼切。而能济度令得安乐而无疲倦。亦复如是。善男子。如诸商贾贫穷困乏。而往依投大萨泊主。即得出于旷野稠林。尼揵梵志种种外道。依投菩萨大萨泊主。获得出离生死旷野诸大险难处。善男子。如萨泊主能为安立文武等众诸凭附者。菩萨宗主能为安立生死众生。亦复如是。善男子。如萨泊主随方发趣。与大群众冒涉山林险难旷野。为得至彼安乐大城。足有资粮。安隐得出旷野之难。不觉疲劳。乃得到彼丰乐之处。菩萨宗主亦复如是。是过去佛所行之方。而随行之。将领是等大群众生。欲令得度生死大险。欲令是等速至一切种智大城。而修种种福德资粮。丰足无限示导而行。善男子。如大宗主。多畜种种资生之具随方而行。所谓金银琉璃真珠璧玉珊瑚等宝。菩萨宗主亦复如是。趣向一切种智大城。善修佛法种种诸行。善男子。如萨泊主求诸财物不知厌足。菩萨宗主求圣法财不知厌足。亦复如是。善男子。如萨泊主于诸商贾引导之首。何以故。富财物故。众中胜故。以将领故。语言有用故。如是菩萨大萨泊主。于诸众生为引导主。何以故。丰功德故。阶位胜故。法自在故。所说无谬故。善男子。如萨泊主善能令至丰沃国土。如是菩萨大萨泊主。善领众生至于一切种智国土。善男子。如是菩萨具是十法作大宗主。善男子。菩萨摩诃萨。具足十法。作大导师了知正道。何等为十。所谓知路平坦。知路阻险。知路丰沃。知路安隐。知路有水无水。知路稣息处所。知路相貌。知路正直。知路回曲。知路速出。善男子。如是菩萨摩诃萨。具是十法了知正道。善男子。菩萨摩诃萨。具足十法能示导正路而不颠倒。何等为十。所谓若以大乘所应化者。而为是等说大乘道。而不为说声闻之乘。若有众生。以声闻乘而受化者。即为是等说声闻道。而不为说菩萨之乘。若有众生以一切智应得度者。即为是等说一切智道。而不为说二乘之道。若有众生以辟支佛道所应化者。即为是等说辟支佛道。而不为说大乘之道。若有众生执着我见执着诸法。为是等故而说无我空无相道。不说我人众生寿者。若有众生着于二边。而为是等不说二边。若有众生心有散乱。为是等故说奢摩他毗婆舍那。不说散乱。若有众生多有戏论。为是等故说如如道。不说戏论凡夫之道。若有众生乐住生死。为是等故说涅槃道不说生死。若有众生行于邪道。为是等故说平坦道。不说烦恼刺棘等道。善男子。如是菩萨摩诃萨。具是十法能示正道而不颠倒。善男子。我今为诸四部弟子大众安乐行故。说是经者。听是经者。护其身心。令其辩才明了无尽。使诸天龙八部拥护是众。令其获得四事供养。离诸疾恼四百四病令灭无余。生生世世得宿命智。见佛闻法遇善知识。展转增长乃至成佛。十力具足得无所畏。而说咒曰

怛绖咃　陀柯第(吴音)　陀柯婆罗第　陀柯那伽脚那呵利腻　毗梨履腻　迦兰阇兰那桎叉桎叉萨婆萨埵(耽音)　婆罗耶寐　莎呵阿只那伽多罗只　阿致那只　祢弟(吴音)　斯思伊履旨履　比詈　须呵罗怒　摩诃萨衣(吴音)　因陀罗阇　液叉　卑多屈(居勿反)　砂[璊-王+月]茶柯喃罗裳伽多喃　婆覆莎呵　南无般那伽寐詈　莎呵　怛绖咃　豆富豆富　柯支留　一柯支喜遏婆詈他　离楼地(吴音)　纪理矩镂蔗　魔磨　陀罕塼弥莎呵　怛绖咃　他弥他弥他弥他须　旨利旃陀利干他梨常伽利　拘波痴(吴音)　婆罗磨那　颇婆枳展那赊耶泥　展那合示　拘留师理　尼猗婆　弼地耶　娑莫伽罗呵祢　萨跋痤逻　毗那尸尼　萨婆鲁伽婆奢摩尼　摩诃摩由罗喜陀耶　[璊-王+月]多　婆摩波多　伊底莎呵

若火难。若王难。若灾厄难。若劫贼难。若恶鬼难。若两足难。若四足难。若多足难。若无足难。若有色难。若无色难。若烦恼难。一切诸难。当用一心忆念受持读诵此咒。即得消除远离诸难。便得安乐永无怖畏。得如所愿

大乘宝云经卷第四大乘宝云经卷第五

        梁扶南三藏曼陀罗仙共僧伽婆罗译

    安乐行品第五

尔时世尊。复告降伏一切障碍菩萨摩诃萨言。善男子。菩萨摩诃萨修行十法。在在处处心恒寂静而安乐住。何等为十。所谓善修忆念。观察于身及受心法。善修忆念。观察境界阿兰若处。于诸聚落国城都邑。于诸利养恭敬名闻。于诸如来所制禁戒。于皮肉心一切烦恼上中下品。善修忆念而观察之。善男子。云何菩萨观察于身而安乐住。菩萨摩诃萨以智慧故观察是身从足至顶。唯见是身三十六物假合成人。念念生灭无常败坏。筋脉连持不净充满无可乐者。如是观察即生厌离。以厌离故身染身贪身见身着悉不复生。以是因缘。凡诸不善与身相应皆得远离。有诸善法与身相应悉皆增长。云何观受善修忆念而安乐住。菩萨摩诃萨作是思惟。凡是诸受一切皆苦。所以者何。婴儿凡夫顽嚣无智。以颠倒故。以苦受中而生乐想。一切圣人唯见是苦。复能安立一切众生。于是法中令得随顺。如是学之已得观受善住念处。于苦乐受不嗔不贪。为灭受故勤修忆念。于是法中劝化他人令如是行。云何观察于心念处而安乐住。菩萨摩诃萨作是思惟。是心颠倒无常常想苦生乐想。于无我法而作我想。于不净中而作净想。躁动易转一念不住。为诸烦恼而作根本。长为众生开三涂门。为诸苦恼而作因缘。能闭善道。能为发起贪嗔痴等。为一切法作增上缘。一切诸法心为上首。若知于心则能得知一切诸法。心能尽作一切世间种种色像。唯心见心唯心造业若善不善。唯心轮转无暂休息犹若火轮。唯心奔逸犹如恶马。唯心能烧犹如野火。唯心润生犹若大。如是观察住心念处。则便能得不随于心能为心师。以心师故则能得为一切法师。若能于心得自在者。则于诸法而得自在。云何菩萨观法念处而安乐住。菩萨摩诃萨于如是等不善诸法如实而知。言不善者贪嗔痴等及诸烦恼因无明生。以是义故修对治门。若贪心生修不净观。若嗔心生修慈悲观。若痴心生而修十二因缘之观。修行正勤而令除灭。复为观察一切善法。见善法已于善法中摄心令住。忆念观察受持是法。于是法中转更劝化。令他众生安住其中。云何菩萨于诸境界摄念观察而安乐住。菩萨于色声香味触若好若丑。而不生于恋着隔碍贪嗔之心。作是思惟。我今不宜起如此心。一切诸法皆非是持。我今云何横生恋着。于是法中我若恋着。我是愚痴。我是不了。我是颠倒。所以者何。如佛所说。以恋慕故而生染着。以染着故而取境界。以愚痴故则不能了善不善法。以是因缘当堕恶道。复作是念。我今不宜生如是心。于危脆法而生隔碍。若生隔碍则不堪忍。由不忍耐便生嗔恚。以生嗔故为诸圣人之所呵责。一切同学而生毁呰所不称叹。作是观已。于憎恨境善修忆念而安乐住。云何菩萨于阿兰若而安乐住。菩萨摩诃萨作如是念。夫阿兰若无诤三昧之所居处。此阿兰若多有天龙夜叉乾闼婆等。得他心智证知我心及心数法。是故我今于此林中。不宜起诸不善思惟。于一切法若能不生不善思惟。观行得成多修善法。云何菩萨于村聚落国城都邑。而作观察得安乐住。菩萨摩诃萨行于聚落脱见是处。于出家人不相宜者。应远避之。何等是耶。所谓若酤酒家若淫女舍若国王家。若波罗塞等嬉戏之处。及以饮酒聚集之处。若白衣群作倡伎乐歌舞之处。凡是出家非所宜者悉远离之。是中观察而安乐住。云何菩萨于诸利养恭敬名闻。而作观察得安乐住。菩萨摩诃萨于诸利养檀越嚫施功德事中。于是利养而须自策调伏其心。勿令贪着不生爱乐。亦复不生我我所心。所得利养皆与一切困乏众生共同平等普受用之。若藉是缘而得名闻。于是名中亦不自高。不生憍慢亦不自恣。作如是念我今所得如是名闻。不久之顷自当歇灭。能得名者及所得名一切无常。何有智者于诸虚妄无常迅速败坏危脆无安立处。而生贪着起于憍慢轻蔑他人。如是观察得安乐住。云何菩萨于诸如来所制戒律。忆念观察得安乐住。菩萨摩诃萨作如是念。于过去世一切如来学此法律已成等觉而般涅槃。于未来世一切如来学此法律当成正觉而般涅槃。于现在世一切如来亦学是法今成正觉而般涅槃。作是观已。于诸法律至心恭敬。勤求是法修行诸善得安乐住。云何菩萨于皮肉心上中下品三种烦恼。忆念观察得安乐住。菩萨摩诃萨于皮烦恼而观察之。肉心烦恼亦观察之。以观察故知其因缘。是诸烦恼从何缘生。是诸因缘复依何生。即得知见烦恼因缘则是无明。无明因缘不善思惟。不善思惟复何因生。不听正法。不听正法复何因缘。不近善友。如是知已烦恼因缘。烦恼源由烦恼境界。悉能远离得安乐住。善男子。如是菩萨具是十法。在在处处心恒寂静得安乐住。善男子。菩萨摩诃萨。具足十法着粪扫衣。何等为十。所谓受持坚固。谦卑堪忍。无疲倦心。无染污心。不见其恶。唯见功德。亦不自高。不轻蔑人。具足净戒。感诸天人之所供养恭敬礼拜。云何菩萨受持坚固。善男子。菩萨摩诃萨信根成就内怀清净。随顺如来所制法律。若丧身命终不故犯。所受持法坚固持已得谦卑心。谦卑心故憍慢不生。无憍慢故摭拾弊坏世间所弃。异于世俗所著之衣。摭拾得已浣濯练治。坏其本色缝纳为衣。不生烦恼不辞劬劳。心无疲倦亦无污染。直为成就所作功德。于如是等粪扫衣中不见其恶。谓是粪扫大蓝缕哉。过粗弊哉。聚多虱哉。迮我身哉。出垢污哉。以是义故。菩萨观察于粪扫衣唯见功德。是粪扫衣一切仙圣所经受持。随于无欲顺于圣种。一切诸佛之所称叹。不以此缘生我慢心。亦不自高不轻蔑人。若离憍慢即不轻他。不轻他故戒品具足。戒具足已一切释梵及诸天众之所供养。称叹礼拜一切诸佛之所护念。一切菩萨之所拥护。人非人等之所恭敬。国王豪族及诸臣民之所供养。一切同学之所劝进。善男子。如是菩萨具足十法着粪扫衣。降伏一切障碍菩萨言。世尊。一切菩萨心地广大。何缘乐此下劣粗弊粪扫衣耶。佛言。善男子。一切菩萨欲使一切世间愿力自在成就。然诸菩萨于愿力中未成就者。为诸烦恼不得生故。对治法门而修习之。善男子。汝意云何。如来世尊广大心耶。弊陋意耶。鄙下心耶。对曰。世尊。我无此辩能答是言。所以者何。世尊。诸佛如来应现信解非我境界。何以故。唯是世尊了见是法。唯修伽陀了见是法。诸佛如来无有一法而不知见不可信者。佛言。善男子。汝意云何。何因缘故如来世尊于阎浮提人非人等。种种根性种种信解。于众生前现弊陋行。及诸天龙夜叉乾闼婆等于其前。说光扬称叹头陀功德。降伏一切障碍菩萨又言。世尊。为是众生所应化者而现是事。及诸无量新发心者。行菩提行烦恼未断。如来为示对治法门。善男子。如是菩萨得誓愿力。但为教导诸众生故着粪扫衣。非鄙下心。善男子。以是义故菩萨摩诃萨着粪扫衣。善男子。菩萨摩诃萨具足十法受持三衣。何等为十。所谓其心知足而常少欲。远离贪求远离储蓄。既无所蓄无去失忧。既无失忧离有失苦。离失苦故恶心不生。恶心无故无有愁毒。无愁毒故无所求取。无求取故能得修行尽诸有流。善男子。以知足故菩萨摩诃萨。随宜法服而为自足以自足故即得少欲。以少欲故远离贪求。离贪求故无所储蓄。无储蓄故无有失忧。无失忧故不生苦恼。无苦恼故恶心不生。无恶心故不生愁毒。无愁毒故无所求取。无求取故能得修行尽诸有流。善男子。如是菩萨具足十法受持三衣。善男子。菩萨摩诃萨具足十法不低昂住。何者为十。所谓不随贪欲。不随嗔恚。不随愚痴。安隐而住。是名不低昂住。无怨恨住。无嫉妒住。无悭吝住。无憍慢住。不显己德住。不求名闻住。不贪利养住。不轻蔑他住。不自高住。善男子。菩萨摩诃萨具是十法无低昂住。善男子。菩萨摩诃萨具足十法行乞抟食。何等为十。所谓发心利益诸众生故。次第行乞无渴爱求。已自知足性乐分施无贪婪想。于所乞食自知限量。趣向助道巧抟善根远离抟想。善男子。云何菩萨利益众生乃至远离抟想。善男子。菩萨摩诃萨见诸众生贫穷困苦。功德微薄不种善根。为利彼故行诣乞食。若入城郭若入聚落而行乞时。应善摄念内善思惟。于诸境界勿令驰骋。威仪庠序诸根不动。慎无于放逸。视地七尺低头而行。于诸善法勿使心散。以如是法次第行乞。不长出手敛钵在胸。若入大富长者之家。亦不多求知量受之。充足是日一食而已。勿妨法事。若处多有恶狗恶牛恶马恶象种种禽兽来相恼触。若男若女若小若大恶口戏调。或相是非毁呰诽谤。如是等处悉皆远离。修行乞法勿渴爱求。勿强逼求。于诸檀越勿起爱慕亦不嗔恨。既无渴乐随宜所得。已自知足持钵而还。至所住处安置衣钵而洗手足。若见佛像而前恭敬供养礼拜。然后入寺。于所食者分为四分。一分与同学。一分施贫穷。一分与畜生。一分而自食。如是取食无贪着心无希望心。随宜饮食但能持身。莫为过少莫为过多。于食多少筹量取足。所以者何。若食过少不能行道。若食过多睡眠身重。亦不堪任学问坐禅。夫求道者。皆应正勤而作是念。懈怠懒惰何由能得满助道法。若能合集助道法已则不着我。若不着我能自割肉以饴众生。善男子。如是菩萨具足十法行乞抟食。善男子。菩萨摩诃萨具足十法唯一坐食。何等为十。所谓坐于菩提道场。一切魔兵为作恐怖而坐不动。于出世座而坐不动。于出世慧而坐不动。于出世智而坐不动。于空三昧而坐不动。觉了诸法而坐不动。于八正道而坐不动。于真实际而坐不动。于如如中而坐不动。于一切智而坐不动。所言一坐唯是法座。是故名为一坐食也。善男子。如是菩萨见是十法唯一坐食。善男子。菩萨摩诃萨具足十法持不再食。何者为十。所谓一食之后无所希望。无所染着。劝食不食。是时非时悉皆不受。脱能治身种种汤药所可食者。所谓若苏若油若石蜜若白蜜若砂糖若根若果。设见他食亦不生嗔。亦不贪乐亦不吝惜。若菩萨中后不食而病困苦。若以病故恐失寿命恐废行道。以无疑心审知是药能治是病许为受用。善男子。如是菩萨具是十法持不再食。善男子。菩萨摩诃萨具足十法住阿兰若。何者为十。所谓久习梵行。善解毗尼。诸根不缺。广博多闻。持戒德业。离着我怖。譬如野鹿摄身威仪。修身轻利。趣向寂静。心无愁闷。善男子。云何菩萨久习梵行。乃至心无愁闷。善男子。菩萨摩诃萨出家已来。于正法律具足戒品三轮清净。善解法相威仪具足出入以时。凡是如来所示道法上中下品。皆悉通达不复求人。不易可动。不着邪论一切外典。于佛正法文义明了。犯与不犯忏悔方法无不具知。于所犯者皆悉远离。恭敬正法数数忏悔。一切恶法发露改往。是罪源由莫不洞达而远离之。上中下业上中下报亦悉了知。已信解故守护正法。眼耳等根具足身分无所残缺。住阿兰若。阿者言无。兰若谓诤。住山林中不与世诤。于是林中无相触恼。不近不远便于乞食。是山林中有清净水。无诸难事灌洗易得。树木荫映华果丰足无恶禽兽。自然石室不过峻阻登涉无难。寂静闲居独而无侣。曾所闻法而诵习之。日夜六时忆念不忘。声不高下诵之勿废。调伏诸根不令驰骋。摄心思惟勿生散乱。恬然自乐受持经典。取于三相谓止发舍。勿着睡眠。脱有国王大臣长者。及诸人民故来寻诣。应作是言。善来善来。若至住处。唤大王坐随宜坐处。王若能坐二人俱坐。王若不坐莫独自坐。王若躁动不就鄙座。应作爱语。大王。此山林地甚有利益。持戒道德多闻沙门。是中安止。无怖无畏无劫盗贼。若是国王安隐寂静。堪听说法而为说之。其若不乐广分别说。当为略说随顺厌离。其若不乐听厌离法。当说叹佛无上功德。若诸长者人民来至。随其所应为说法要。悉令得生信法之心。亦使受持三归戒等。令诸人辈生欢喜心。自利利他。已生诸恶及诸烦恼令得灭故。而修多闻不着于我。不着我故住于山林无忧无畏。无怯弱想不生恐怖。趣向寂静远离喧杂。独居如鹿少欲知足。善男子。菩萨居山不同于鹿怖畏驰走。不取其失。言如鹿者。远离郭邑聚落居家。其作是念。近恶人故或失寿命。如是菩萨离于喧杂若男若女若小若大。而作是念。亲近是等失我宿昔所习善根。勿生散乱。如是恒生怖畏心住故向寂静。于世间中生厌离心。住山林中唯见功德。唯见寂静。唯见毕竟。唯见安乐。无忧愁心。无迷闷心。不近恶友。不障山中寂定功德。受持修行一切善法。善男子。如是菩萨具是十法住阿兰若。善男子。菩萨摩诃萨具足十法依止树下。何等为十。所谓所依树下。去于聚落不近不远。无诸棘刺及毒草木秽杂之处。树叶不雕。非猿猴处众鸟巢处。非恶禽兽所居之树。无有恶人危难之处。所依树下身安乐处。心无闷处安心而止。善男子。如是菩萨具是十法依止树下。善男子。菩萨摩诃萨。具足十法坐于露地。何等为十。所谓冬时夏时春时。不得近于舂场之处。不近树木非丛聚处。不约山险莫近江河。不遮寒不遮风亦不遮雨。亦不遮热不遮霜露。唯除疾病。菩萨摩诃萨若坐露地身有疾病不堪行法。当住寺中而作是念。诸佛如来制头陀法。但为断除一切烦恼。如佛教法我当奉行。我虽住寺应学正勤。为断烦恼不得懈怠散乱闲住。虽居寺舍不生贪着。复作是念。如是寺舍皆是檀越之所起造。利益一切修道之人。是故我今不应于寺生我所心。虽住寺中恒不离于露地之想。善男子。如是菩萨具是十法坐于露地。善男子。菩萨摩诃萨具足十法住尸陀林。何等为十。所谓若在中住多生厌离。恒作死想。作八万户虫所唼食想。作赤血想。作青淤想。作臭秽想。作膖胀想。作血涂想。作脓烂想。作解离想。作骸骨想。善男子。菩萨摩诃萨住尸陀林恒兴慈悲怜愍众生。持戒清净具足威仪。恒习素食支持活命。所以者何。善男子。是尸陀林有诸非人。依止中住食人血肉。若见菩萨食鱼肉者。而起恶心来相触恼。善男子。住尸陀林菩萨。脱入寺舍前礼佛塔。次礼大德问讯上座。恭敬事毕一处而立。于众僧座不得坐之。何以故。菩萨之法将护世间诸俗人意。是尸陀林住止菩萨。翻于世间凡愚众生不违众圣。若于私座请菩萨坐。审如是僧心无变异乃可就坐。勿令前人而生悔心。以卑下心于己身中作旃陀罗想。善男子。如是菩萨具是十法住尸陀林。善男子。菩萨摩诃萨具足十法宴坐不卧。何等为十。所谓不为苦身故而坐不眠。不为恼心故不为眠。所牵故不萎身坐。菩萨摩诃萨凡坐不眠。但为满足菩提诸行。为一心故。为向正道故。为坐道场故。为利众生故。为灭一切烦恼故。坐而不卧。善男子。如是菩萨具是十法常坐不卧。善男子。菩萨摩诃萨具足十法随宜敷坐。何等为十。所谓于坐之处不过经营。亦不求他而为敷座。不作相貌令他敷座。所坐之处若叶若草随得而坐。若有地所多诸虫蚁蚊虻蝇蚤作窟住处。及阇维处悉远离之。若消息时右胁而卧。上下累脚袈裟覆身。正念专心作光明想。恒作悟想而暂眠卧。不取眠乐不取胁乐但调其身。持于四大勿令过困。昼夜用心趣助道法。善男子。如是菩萨具是十法随敷而坐。善男子。菩萨摩诃萨具足十法摄心与理相应。何者为十。所谓多修不净观。多修慈悲观。多修十二因缘观。善识污心之法。多修空相。多修无相。多修摄心。无所愿求。恒修不息不令悔恨。具足戒品。善男子。云何菩萨多修不净观。善男子。菩萨摩诃萨独居闲寂。不出人间隐山林中。一向默念其心调直。令身调直结跏趺坐。见其支节屈伸俯仰生厌离心。当观身内三十六物。念念相次莫观皮外。作如是观乃至众生种种饮食美味净洁。若粗若好才入腹中即成不净。触于内火则便臭烂秽气逆鼻。一切世间之所不耐。如此之身。一切婴儿凡夫众生之所恋着。当依圣教以善智慧如实观之。是故我今不应爱此臭处之身。以是因缘故厌离之。如是菩萨多修不净观。云何菩萨多修慈悲观。菩萨摩诃萨独居闲静具如前说。依前次第而作是念。是诸众生多诸嗔恚怨憾忿恨。造诸恶业结构怨家无缘责主。若于过去现在未来。一切嗔恚究竟灭已。我方得坐菩提道场。作是甚深观察思惟。真实慈悲非但口说。云何菩萨多修十二因缘观。菩萨摩诃萨若贪欲生若嗔恚生若愚痴生。作是思惟。是贪嗔痴藉因缘生。而此因缘复藉因缘。于是诸法因缘所生。无有自性悉是虚妄。何有智者以虚妄法因缘所生。于自己身而作疮疣。云何菩萨善知污心之法。菩萨摩诃萨观是污法。若在自心若在他心不可量度。为灭是等因缘法故当观察之。何者是耶。所谓不敬佛不敬法不敬僧不敬戒律不敬同学。若老若少并不恭敬。是名染污心法。唯重自身轻蔑他人。于诸境界驰骋散乱。背于涅槃着于我见人见众生见寿者见执着空见执着断见。执常无常憎忿善人。亲近凡愚离持戒者。近破戒众伏事恶友。远善知识诽谤诸佛甚深经典。于甚深法生怖畏相懈怠懒惰。于己身中生下劣想无有威德。讷于言语非处生疑。应疑不疑不疑而疑。诸盖诸结之所缠缚。幻惑世人间构谄曲。睡眠瞪瞢唯贪利养。求于名闻恃于姓族。恋于眷属染于邪见。恃怙国土恋慕群众。习学咒术路伽耶陀世俗文章。舍离正法废于道行。于不善法忽务经营。于功德业不勤其事。憎恶毁呰出家之人。但好歌咏叹诸女色。称美少年若男若女。不乐寂静于阿兰若愁愦不乐。于善不善不知量度。于可尊重不往问讯亲近供养。读诵经典不知时节。于所行处不避讥嫌。于诸戒律若轻若重悉不能持。于诸恶法皆无怖畏。诸根暗钝愚痴障重。心恒躁动恶业快利。无所忌难自恣独步。横理取法忧虑愁毒。于色好丑取相评量。于嗔恚境不修慈悲。于诸贫穷不起怜愍。见疾病苦不生厌离。见死不怖住火宅中不欲出离。但经营身不护戒律。于过去中经作何事。于现在中正作何事。于未来中当何所作。如是境界都无思惟。于不思议而作思议。于不可量而作限量。所不可求而竞勤求。于非清净作清净想。于非出离作出离想。于非正道作正道想。于所未得谓言已得。我正多事未得修善。我是凡夫那能修行诸圣道法。多恋俗务推斥度日。回避微妙功德善根。于大小乘不能称叹。设见信乐佛正法者。而诽谤之。乐于斗诤好相是非。粗犷恶口自大高举。恶赖骂詈卒暴匆扰凌轹于他。说无义语喜论人过。所不可说而好说之。乐於戏论耽着嬉戏。如是等事名染污法。能染污心而善知之。为灭一切诸戏论故。多修于空而入禅定。以调其心如是修空。于此境界随心着处。当寻是处求其体性遂无所有。无所有故通达于空。所缘之境及能缘心并须观察。作观察已。心境二法悉无所有而通达空。通达空故为修无相。而摄其心入于禅定。一切相貌显现相似。善观察之则见非相。既了非相不得己身则无身相。得无相已不着己身。不着身故不得一切外诸境相。于诸外境不作分别不更移心。于内外相心既不动。为灭无相之相故。于修观行不生忧喜。虽得是定习气尚多。为灭习气恒修是定。心心相续无令休息犹如[火*(替-曰+貝)]火。住于奢摩他毗婆舍那中。毗婆舍那者如实法观。奢摩他者一心寂默。得心定故后不致悔。不致悔故生欢喜心。何故欢喜由戒清净。一切菩萨具足戒品。清净摄心与理相应。何以故。持戒清净故摄心得成。是故说名与理相应。善男子。如是菩萨具足十法摄心与理相应。善男子。菩萨摩诃萨具足十法受持经典。所谓为护正法而往听闻不为资生。为护正教勤听正法不为利养。为三宝种不断绝故。勤求多闻不为世利。为欲利益学大乘者。而修多闻不为称叹。为诸众生无救护者。利益因缘而修多闻。为诸众生三苦所逼。作安乐故而修多闻。为无慧眼诸众生故。令得慧眼而修多闻。为小乘人说声闻法而修多闻。为大乘人说菩萨道而修多闻。为自得证无上智慧而修多闻。不求下乘而修多闻。善男子。菩萨具是十法受持经典。善男子。菩萨摩诃萨具足十法。受持毗尼。何等为十。所谓了知毗尼。并律宗体。毗尼甚深。毗尼微细。犯与不犯。性罪制罪。波罗提木叉。学之本源。声闻毗尼。菩萨毗尼。悉皆了知。善男子。如是菩萨具足十法受持毗尼。善男子。菩萨摩诃萨具足十法。威仪行处齐整具足。何等为十。所谓于声闻法已经修学。于缘觉法已经修学。于菩萨法已经修学。如是学已威仪具足。凡是沙门不宜处行皆悉远离。以是因缘非处不行。非时不行。非国不行。修行沙门所应行处。不失威仪。勿令沙门婆罗门之所讥诮。夫威仪者与理相应。复劝化他令住此法。使行法者具诸威仪庠序细密。内怀相应无有虚假。善男子。如是菩萨具是十法。威仪行处齐整具足。善男子。菩萨摩诃萨具足十法。心无悭贪亦无嫉妒。何等为十。所谓自能惠施。复劝他人令行布施。称叹布施。见他布施起随喜心。劝叹成奖令其欢喜。不作是念但施于我莫施余人。唯使我丰不令他得。应作是念。令诸众生得安乐具种种资生。若于世间若出世间具足安乐。我今所为是等众生利益安乐修诸苦行。是故我今于众生边不应起诸悭贪嫉妒。善男子。如是菩萨具足十法。无有悭贪嫉妒之心。善男子。菩萨摩诃萨具足十法。于诸众生行平等心。何等为十。所谓于诸众生业行平等。于诸众生无忿憾心。于诸众生平等利益。而行布施受持禁戒。修于忍辱勇猛精进。善思禅定修般若智。不依二边而修是心。缘诸众生起平等心。修行六度令得是法。生死火宅众苦炽然自得出已。复救余人令其得出。以心平等不生彼此隔碍之想。无有憎爱。善男子。譬如长者其家巨富。唯有六子爱念怜愍而悉平等。是等子息婴稚愚痴。于事不了匍匐而戏。是长者宅被火所烧。炽然猛焰炎盛遍起。是等诸子各各东西。善男子。于意云何。是时长者颇作是念。我今前可且救一子。然后方便救余子不。降伏一切障碍菩萨对曰。不也世尊。所以者何。而是长者于其诸子。平等救济无有偏心。而随近者前引出之。善男子。如是一切众生之类。皆是菩萨之婴儿也。未了苦乐。无所知解生死火宅。六道之中各各住处。菩萨摩诃萨随其善根有成熟者前救脱之。安置令住清净法界生死之外。善男子。如是菩萨具足十法。于诸众生行平等心。善男子。菩萨摩诃萨具足十法。殷勤恭敬供养诸佛。何等为十。所谓供养于法是供养佛。不以财物是供如来。为作安乐利益众生。为欲摄受一切众生。为欲成就众生善根不舍所受清净禁戒。不废一切菩萨行业。如所说法身即能行。如是修行心无疲倦。不舍无上菩提之心。如是恭敬供养诸佛不用财宝。若能修行诸佛正法即供养佛。所以者何。供养于法则是供养一切如来。是法所生利益群品令出世间。若背菩萨所行之业则为身口相乖。如所誓愿不得成满则心疲倦。便舍菩提则不能得利益众生。何以故。菩萨摩诃萨求阿耨多罗三藐三菩提。但为利益诸众生故。若无众生亦无菩萨取于正觉。善男子。当如是观法即是佛。一切诸佛法为身故。善男子。如是菩萨具足十法。殷勤恭敬供养诸佛。善男子。菩萨摩诃萨具足十法断除憍慢。何等为十。所谓出离家居勤苦求道。亲识朋友一切眷属不复相关。何异死人故无憍慢。改其形相着坏色衣。而我今者别有所求故无憍慢。剃头持钵家家乞食活此身故不生憍慢。以乞食故生谦下心。如栴陀罗不应憍慢。今我身命寄于人活。受他抟食犹若饿狗。人所轻蔑不应憍慢。我应绍续尊重福田不应憍慢。令诸同学见而欢喜不应憍慢。持诸威仪庠序齐整不应憍慢。所未得法我当得之不生憍慢。于弊恶性诸众生中。多修忍辱不生憍慢住。善男子。如是菩萨具足十法断除憍慢。善男子。菩萨摩诃萨具足十法心多清净。何等为十。所谓福业所持过去善根。宿因具足。正见具足。不着邪论不可移动不事余师。内怀清净无有谄曲。意无贡高亦不幻惑。其心质直备诸智慧。诸根明利离众障蔽。心行清洁亲近善友远恶知识。摧伏憍慢勤求妙理。于听法时不伺过失。诸佛功德皆悉了知。善男子。如是菩萨具是十法心多清净。降伏一切障碍菩萨言。世尊。诸佛功德不可思议。我于此法云何得闻能了知之。佛言。善男子。汝善谛听。我今为汝说于如来少分功德。唯然世尊愿乐欲闻。佛言。善男子。如来大慈具足圆满。于诸众生悉皆平等如于一人慈悲平等。于遍法界一切众生。其心亦尔如虚空界遍于一切众生界中。如来慈悲遍一切处。无量无边亦复如是。异于声闻缘觉菩萨。善男子。诸佛如来说法无尽。于无量劫不可穷竭。种种名字种种义趣。于无量众一时一音而为说法。随其类音各各得解无限无尽。善男子。诸佛如来问答具足。设有一切预众生类。以种种问俱问如来。如来随其种种类音种种名字。于一刹那一念一时。皆悉能答无滞无碍。善男子。诸佛禅定境界无碍。善男子。设有一切众生之类位阶十地。一时一念俱时入于百千万亿禅定三昧。于诸无量种种三昧。皆不能及如来三昧无边境界。善男子。如来具足无量色身。善男子。设有众生以如来身应受化者。一念之顷遍于众生。对其面前而现佛身随众生愿。一念之顷现种种身。善男子。如来具足天眼无量境界。善男子。有诸众生得天眼者。所见诸色无量无边诸世界中。如来悉见如庵摩勒在手掌中。善男子。如来无量天耳境界。善男子。设有众生得天耳者。满于无量无边世界。随其所闻种种音声。如来能于一刹那顷。皆悉得闻是等音声。善男子。如来具足知他心智无边无尽等于虚空。善男子。设有一切诸众生界。种种觉观种种思惟种种业行。如来能于一念之顷。悉能了知无量无边一切诸心。及所造业并业果报。于三世中以无碍智悉皆了知。善男子。如来恒在禅定不曾忘失。所以者何。佛无失念诸根不动内心无乱。何以故。一切烦恼烦恼习气。毕竟尽故恒在寂静。善男子。有烦恼人内心迷乱不得禅定。如来不尔。夫如来者无复烦恼无复尘累。无漏无为得一切法。自在游于一切甚深三昧境界。善男子。如来设住随一威仪中随一三昧中。乃至涅槃常住其中无有动移。故常在三昧。善男子。诸佛如来于无量劫。备修诸行得成正觉。不可思量不可思议。无有边限。降伏一切障碍菩萨言。世尊。如来不于无量劫中修功德耶。佛言。善男子。莫作是说。何以故。菩萨摩诃萨不应思量如来境界。如来境界不可思量。但为浅近诸众生等说三僧祇修习所得。而实菩萨发心已来不可称计。降伏一切障碍菩萨言。世尊幸甚。是等众生修诸善根。已灭业障多生信解。近于菩提闻佛功德心生欢喜。何况闻已尽能受持。读诵解说书写供养。世尊。是等众生不久当得如来功德无异今日。佛言。善男子。如是如是。如来摄受是等众生。于诸佛所已种善根。恭敬承事于无量佛。是等众生闻佛功德不生疑惑。善男子。若善男子若善女人七日七夜无余思想。内心不乱念念相续。忆持如来如是功德甚深微妙。着净洁衣设诸供养心心成就。是七日内即见如来三十二相色身具足。若有散乱不平其事。而恒一心于临死时如来现身立在其前。降伏一切障碍菩萨言。世尊。颇有众生闻佛所说如来功德生不信耶。佛言。善男子。有诸众生闻佛说是如来功德。以其恶口粗犷骂詈生嗔恚心。于说法者生怨家想。以是因缘。舍身之后生于地狱受无量苦。善男子。有诸众生闻佛功德生欢喜者。于说法人生善友想生如来想。善男子。是等众生信最极理。已于过去曾闻如来如是功德。是等众生于大众中而作是说。我于过去曾闻如来说佛功德。无异今日经中所说。尔时世尊。出长舌相以覆其面。覆于面已复覆其顶。覆于顶已复覆于身。覆于身已覆师子座。覆师子座已复覆菩萨及声闻众。覆声闻众已复覆释梵四天等众。如是普覆大众等已而缩舌相。问大众言。如来世尊有此舌相。颇复能作妄语不耶。善男子。汝等当信如来所说必非虚妄。若信此经于未来世。为汝等故长夜利益安乐无尽。说是语时。八万四千菩萨摩诃萨得无生法忍。无量无边诸众生等远尘离垢。于佛法中得法眼净。无量众生未曾发于菩提心者。即于是时皆发阿耨多罗三藐三菩提心

大乘宝云经卷第五大乘宝云经卷第六

        梁扶南三藏曼陀罗仙共僧伽婆罗译

    二谛品第六

尔时世尊。复告降伏一切障碍菩萨摩诃萨言。善男子。菩萨摩诃萨具足十法善解世谛。何等为十。所谓假说有色非第一义故。得于色法而不执着。假说受想行识非第一义故。虽得于识而不执着。假说地界非第一义故。虽得地界而不执着。假说水火风虚空识界非第一义故。虽得是界而不执着。假说眼入非第一义故。虽得眼入而不执着。假说耳鼻舌身意入非第一义故。乃得意入而不执着。假说有我非第一义故。虽得是我而不执着。假说众生非第一义故。虽得众生而不执着。假说寿命士夫养育众数人等。非第一义故。虽得是等而不执着。假说世间非第一义故。虽得世间而不执着。假说世法非第一义故。虽得世法而不执着。假说佛法非第一义故。虽得佛法而不执着。假说菩提非第一义故。虽得菩提而不执着得菩提者。善男子。假名言说名字论量名为世谛。于世法中无第一义。虽然若离世法。第一义谛不可得说。善男子。菩萨摩诃萨于是法处善解世谛。而不名解第一义谛。善男子。菩萨摩诃萨具是十法善解世谛。善男子。菩萨摩诃萨具足十法善解第一义谛。何等为十。所谓具无生法。具无灭法。具不坏法。具不增不减不出不入法。具离境界法。具无言说法。具无戏论法。具无假名法。具寂静法。具圣人法。所以者何。善男子。夫第一义不生不灭。不败不坏不增不减。文字章句所不能说。不可诠辩绝於戏论。善男子。第一义者。无言无说本性清净。一切圣人内自证得。若佛出世若不出世。法性常尔不减不增。善男子。为是法故一切菩萨。剃除须发着坏色衣。以善心故远离亲属。往空闲处出家修道。精进耐苦如灸头然。但为求得是妙法故。善男子。若无有此第一义谛。所修梵行皆悉无用。佛出于世亦复无用。善男子。是故汝当知有第一义谛。有第一义谛故。说诸菩萨解第一义。善男子。菩萨摩诃萨具是十法。善知第一义谛。善男子。菩萨摩诃萨具足十法善解十二因缘。何等为十。所谓诸法空虚无实厄缚危脆。如水中月如镜中影。如谷中响如梦如幻。无暂时停摇动不住。藉因缘生皆悉知之。作是观察是等诸法一切空虚。无有真实如是危脆。乃至藉因缘生见生住灭。复更思惟。以何因缘是等法生。以何因缘是等法灭。作是观已。即知无明为是等法作生因缘。无明所生。无明源由。无明根本。依因无明诸行法生。行缘于识以识因缘假说名色。名色立已而说六入。因于六入触方得生。触因缘故生于三受。受因缘故婴儿凡夫生渴爱苦。渴爱因缘而取四取。缘于四取而有接续。有因缘生。以生因缘老死忧悲苦恼等生。纯是大苦共相聚集。以是义故聪明智者。应当勤求灭是无明。破裂无明拔无明根令不复生。无明灭故一切诸法因无明者。皆灭无余犹若命根。命根灭时一切诸根皆悉随灭无明灭时。一切诸法依无明者。悉皆随灭无明灭故。烦恼不生。无烦恼故不生六道。何以故。生死因缘已灭尽故。是故能得于大涅槃常乐我净。善男子。如是菩萨具足十法善知十二因缘。善男子。菩萨摩诃萨具足十法知于自身。何等为十。善男子。菩萨摩诃萨作是观察。我今此生何等种性。婆罗门性耶。刹利性耶。居士大家性耶。若卑劣性耶。若下贱性耶。若生豪族大富家者。莫恃怙之而生憍慢。若生下贱贫穷家者。而作是念我于前世种是业缘。致使如是贫穷果报。以是因缘多修厌离。生厌离故乐求出家。得出家已作是观察。我今出家正何所为。即知出家自能度脱方度他人。以是因缘不应懈怠不宜懒惰。作是观已。我得出家何等不善未灭尽者。若灭是法则生欢喜。以是因缘为灭是法勇猛精进。复作是念。何等善法可得增长。以增长故。当生欢喜。为诸善法增长因缘勇猛精进。复作是念。依何等师一切善法而得增长。一切不善而得尽灭。以是因缘。依止师僧若多闻者。若不多闻若持戒者若不持戒。恒生尊想如敬诸佛。而于和上阿阇梨边。恭敬尊重至心承事亦复如是。而作是念。藉师僧力诸助道法。所未满者能令得备。烦恼未灭能令灭尽。是等人边生和上想。至心承事生大欢喜。于善法中而修顺行。于不善法逆之而行。复作是念我师是谁。作如是观则得知之。夫我师者是一切智说一切法。怜愍世间有大慈悲。是大福田为天人师。以是因缘当生欢喜。复作是念幸甚幸甚。我今已得最上胜利。能示于我学道正法。若失寿命亦不敢犯所受之法。若能不犯则是供养诸佛如来随顺而行。复作是念我今受谁饮食供养。若豪富家若贫穷家。令如是等饮食供养。生大果报生大利益。当受是等饮食供养。复作是念是等施主若贫若富。以何等心供养于我。供给饮食如是知之。是等施主。今谓我辈是出家人行沙门法。作福田想作持戒想作生善想作灭恶想。是故我今不违彼心。受持沙门戒律德业。出家福田诸功德事。而作是念无始生死我应度之。我今已得出家入道行沙门行。则是我初度于生死。我当进修沙门德业。即是第二我渡生死。我今勇猛不敢懈怠。但为得是清净法故。如是无始无量生死我应度之。善男子。如是菩萨作是观察则知己身。善男子。菩萨摩诃萨具足十法了知世间。何等为十。所谓于骜恨者而生谦卑。于憍慢者而生恭敬。于谄曲者自行质直。于妄语者自修谛语。于恶口者自说爱言。于粗强者而自柔软。于碜毒者多修忍辱。于恶赖者多修慈心。于困苦者多修悲心。于悭惜者多修喜舍。善男子。如是菩萨具足十法了知世间。善男子。菩萨摩诃萨具足十法生净佛土。何等为十。所谓戒品清净无隙无杂无瑕无疵。于诸众生起平等心。功用无二具大善根。远离利养恭敬名闻心无染污。信根成就心无疑惑。勇猛精进不暂懈怠。具足禅定心不散乱。多闻分别不习邪论。具足利智不生钝根。自然多慈不习嗔恚。降伏一切障碍菩萨言。世尊。具足十法生净土耶。若不具足亦得生乎。佛言。善男子。于此十法设有一法而得具足。不隙不杂不瑕不疵清净明白。一切诸法悉皆具足。所以者何。具足十法得生净土非不具足。善男子。如是菩萨具足十法生净佛土。善男子。菩萨摩诃萨具足十法不受胎生染污。何等为十。所谓起造如来形像。治理故败佛塔。于佛塔庙恒施涂香。洗浴佛像。于佛塔庙扫洒泥涂。供养父母洗浣摩拭。供养和上阇梨同学一无希望心。所修善根如是回向。而作是言。以此善根。愿诸众生不受胎生。得清净生无染污生。以深心故。善男子。如是菩萨具是十法不受胎生。唯除愿力。善男子。菩萨摩诃萨具足十法出离家居。何等为十。所谓无所恋着。不混杂住背于贪境。远离渴爱不染尘劳。于佛正法随顺奉行。努力精进善学知足。随宜衣裳随宜饮食随宜卧具随宜汤药。钵盂法服资生什物不作储畜。于诸尘境恒生怖惧。趣向寂静修道不废。善男子。如是菩萨具足十法出离居家。善男子。菩萨摩诃萨具足十法净命自活。何等为十。所谓远离贡高谄佞利养。远离相貌。远离摩揣不横求财。离非法财。离不净财不恋着财。不为利养之所污染。不渴爱求于如法财尚生知足。善男子。云何菩萨远离贡高谄佞利养。菩萨摩诃萨。不为利养作身贡高口贡高心贡高。云何不作身贡高。菩萨摩诃萨若见檀越施主之时。不自作身异相威仪。徐步而行现寂静相。观前一寻示如愁苦。或作任运如非虚假。是身贡高皆悉不作。云何不作口贡高。菩萨摩诃萨不以利养之因缘故。安徐软语及以爱语出随顺语。如是口贡高皆悉远离。云何心贡高。菩萨摩诃萨若有施主。欲以财物而为供养。口示少欲而其内心甚愿多取。善男子。此则名为内怀中热。所谓口称无贪心实欲得。云何远离相貌。菩萨摩诃萨若见檀越不作是相。示我衣钵多有破坏。乏诸汤药现其阙少。而以求施口无所言。云何远离摩揣。菩萨摩诃萨若见檀越不作是说。某甲檀越施我此物。我以恩德报答彼施。不作此言。令前施主知我持戒。知我多闻知我少欲。我以慈悲受彼嚫施。不作抑扬方便鼓动。云何菩萨离横求财。菩萨摩诃萨不作身疮不作心疮而求财物。言身疮者。为财物故不惮劬劳。四方役身疾急忽务违于戒律。言心疮者。于诸同学减利养者多生嫉妒。云何菩萨离非法财。不以轻称小斗欺诳于人。不以诈亲及诸欺罔而求财物。云何。萨离不净财。菩萨若于塔物相关法物相关僧物相关絓是不与。非随喜者悉不受用。云何菩萨不恋财利。菩萨摩诃萨若得财物不作我所。不谓是财不作积聚。于时节中回施之者。供养父母及诸亲识诸眷属等。于时节中复须自用。得此财时不生染着。不得财时亦不周慞亦不渴仰。于施主边不起恶心不取过失。于如法财与众共得。佛所称叹。菩萨大士所不讥嫌。天神光扬同学欢喜。以此财物知足而住。善男子。如是菩萨具足十法净命自活。善男子。菩萨摩诃萨具足十法心不疲倦。何等为十。所谓但为利益众生善因缘故。住在生死不觉疲倦。为利益众生故。受生死苦不觉疲倦。为劝众生令修善法不觉疲倦。为同众生诸事业故而不疲倦。为小乘众说声闻道而不疲倦。于声闻人而不憎恶。修助道法而不疲倦。为满菩提行不生疲倦。愿求涅槃不取涅槃。行菩提行心不暂息。善男子。如是菩萨是具十法心不疲倦。善男子。菩萨摩诃萨具足十法奉行佛教。何等为十。所谓远离一切放逸住无放逸。善自守护不作身之恶业。善自守护不作口之恶业善自守护不作心之恶业。恒畏恶道远离一切诸不善法。谛说道理离诸非道。恒说正法毁诸非法。远离鄙业随顺德业。不污如来正法戒律。远离一切烦恼毒臭广护佛法。于不善法常守自心。善男子。如是菩萨具足十法奉行佛教。善男子。菩萨摩诃萨具足十法。姿颜光悦面无颦蹙。何等为十。所谓诸根澄净。诸根清净。诸根光彻。诸根无染。诸根皎洁。远离忿恨。远离诸使。无复结缚。离盖怨憾离诸嗔恚。善男子。如是菩萨具足十法姿颜光悦面无颦蹙。降伏一切障碍菩萨言。世尊。如我解佛所说之义。诸根净故菩萨摩诃萨颜色和悦。离烦恼故面无颦蹙。佛言。如是如是。善男子。如汝所说。诸根净故菩萨摩诃萨颜色和悦。离烦恼故面无颦蹙。善男子。菩萨摩诃萨具足十法多闻具足。何等为十。所谓生死炽然淫欲猛火。菩萨摩诃萨如实知之。嗔恚猛火如实知之。愚痴乱心如实知之。诸行无常如实知之。三界皆苦如实知之。世间空虚如实知之。诸法无我如实知之。世间虚诳着于妄想。受生分别如实知之。一切诸法藉因缘生。如实知之。涅槃寂静如实知之。是三无性闻思修慧如实知已。不但音声分别说其名字而已。虽如是知发增广心。兴大慈悲誓愿坚固。为诸众生拔苦根栽正勤勇猛。善男子。如是菩萨具足十法多闻具足。善男子。菩萨摩诃萨具足十法受持正法。何等为十。所谓于末世时。后五百岁正法灭时。如来经教诤讼竞起。无量众生行于邪道。智灯欲灭无示导者。微妙甚深修多罗经。广大之义有大威德。是一切法摩德勒伽(此云法母)而能受持读诵宣说恭敬供养。亦能为他显示其义广为解释令得易解。于行法者生大欢喜。善护念之心无希望。乐听正法于说法人生世尊想。于正法中生甘露想生妙药想。不惜身命求于正法。得正法已努力修行。善男子。如是菩萨具足十法受持正法。善男子。菩萨摩诃萨具足十法生法王子。何等为十。所谓以相严身具随众好。微妙修饰诸根满足。随于如来所行之道住在如来境界之处。觉了诸佛不退还法。善能救济众生苦难。善能习学众圣轨则。善能游观四无量心。众梵住处如来所居。一切智城能随镇之。善男子。如是菩萨具足十法生法王子。善男子。菩萨摩诃萨具足十法。释梵四王之所奉迎。何等为十。所谓不退菩提之心。一切众魔不能恼乱。于佛正法不动不摇。深入诸法微妙秘藏。随顺一切法平等智。于佛法中不随他语。于佛法中得无碍智。不同一切声闻缘觉。于诸世间而登上首。安隐住于不生法忍。善男子。如是菩萨具足十法。释梵四王之所奉迎。善男子。菩萨摩诃萨具足十法知诸机性。何等为十。所谓有诸众生。性多淫欲如实知之。若嗔恚性。若愚痴性。若刚强性。若中庸性。若善软性。若碜毒性。若弊急性。若迟缓性。如实知之。如知一人遍众生界。亦如是知。善男子。如是菩萨具是十法知诸机性。善男子。菩萨摩诃萨具足十法。善知成熟众生。何等为十。所谓若以佛色身应得度者。即为示现如来色身。若以菩萨色身应得度者。即为示现菩萨色身。若以辟支佛身应得度者。即为示现辟支佛身。若以声闻身应得度者。则为示现声闻身。应以帝释身应得度者。即现帝释之身。若以魔身应得度者。则现魔身。若以梵身应得度者。则现梵身。若以婆罗门身应得度者。即现婆罗门身。若以刹利王身应得度者。即为现身。若以长者居士身应得度者。即为现之。善男子。随因随缘种种方法。但令众生得成熟者。随其因缘则为现之。善男子。如是菩萨具足十法成熟众生。善男子。菩萨摩诃萨具足十法堪任正法。何等为十。所谓质直柔软。无谄曲心。善调伏心。无垢污心。内心清净。性无粗疏。无嗔恚心。远离粗犷。心多忍辱。具足堪任法王子位。善男子。如是菩萨具是十法堪任正法。善男子。菩萨摩诃萨具足十法安乐共住。何等为十。所谓正见具足。净见具足。戒品具足。威仪清净。行于所宜。境界无烦恼住。动止细密。同学和睦。每事有分。行一乘道无余师范。善男子。如是菩萨具足十法安乐共住。善男子。菩萨摩诃萨具足十法善修摄法。何等为十。所谓以利益施摄受众生。以安乐施摄受众生。以无尽施摄受众生。以利益说。以实义说。以正法说。以道理说。以利益事。以资生供给事。以财物利益事。摄受众生。善男子。利益施者谓法施也。安乐施者是财物施也。无尽施者示正道理。利益说者劝令修善。实义说者谓不倒说。正法说者随顺佛教所摄之法。道理说者不违实际。利益事者回于不善令住善处。资生供给事者若饮若食。财物利益者。谓金银琉璃真珠玻璃琥珀珊瑚玛瑙象马车乘所须之物。善男子。菩萨具足十法善修摄法。善男子。菩萨摩诃萨具足十法端正具足。何等为十。所谓威仪庠序。于四威仪悉非虚伪。见之可爱犹若秋月。见之生乐。视不知足。悦人内心。于诸众生无憎恶者。众生见者无不欢喜。众生见者发清净心。善男子。如是菩萨具足十法端正具足。善男子。菩萨摩诃萨具足十法。能为众生之所依止。何等为十。所谓拥护众生于烦恼畏。将领众生出于生死稠林旷野。济度众生于生死海。孤独众生为作亲眷。于诸烦恼疾病众生为作医王。无救护者为作救护。无料理者为料理之。无归依者为作归依。于无洲无渚能为洲渚。无趣向者为示趣向。善男子。如是菩萨具足十法。能为众生之所依止。善男子。菩萨摩诃萨具足十法喻大药树。何等为十。所谓如大药树名曰善见。疾病众生随意得用。根茎枝叶皮肉华果。若见若嗅若尝若触。无不痊愈。善男子。菩萨若尔。从初发心见诸众生。为诸烦恼种种疾病。布施治疗。戒忍精进禅定般若。若得见闻菩萨功德。若得亲近。若得其味。病无不差。善男子。如是菩萨具是十法喻大药树。善男子。菩萨摩诃萨具足十法福业相应。何等为十。所谓于三宝处随力治理。于诸众生有疾病者布施汤药。于饥馑者布施饮食。若有众生寒热所逼施其温凉。于和上阿阇梨深心供养恭敬承事。于诸同学礼拜奉迎送去。合掌问讯作和睦事。处处建立伽蓝园林。应时布施米谷财物及诸仓库。于诸奴婢仆使下隶施其饮食。衣裳汤药而拥护之。时时往诣持戒多闻沙门亲近礼拜。善男子。如是菩萨具是十法福业相应。善男子。菩萨摩诃萨具足十法善能变化。何等为十。所谓于一佛刹不动不摇。则能遍于诸佛刹土咨禀如来。于一佛刹不动不摇。往诣无量诸佛刹土就彼听法。于一佛刹不动不摇。往诣诸佛无量刹土。供养承事彼佛世尊。于一佛刹不动不摇。往诣诸佛无量刹土。行菩提行令得满足。于一佛刹不动不摇。往诣诸佛无量刹土。彼土菩萨成等觉时。诣彼供养恭敬礼拜。于一佛刹不动不摇。往诣无量诸佛刹土现自成佛。于一佛刹不动不摇。往诣无量诸佛刹土转正法轮。于一佛刹不动不摇。往诣无量诸佛刹土现般涅槃。于一佛刹不动不摇。往诣无量诸佛刹土。彼有众生应得度者。悉为变化作诸神通令得度脱。虽作变化而无思惟亦无分别。降伏一切障碍菩萨言。世尊。云何菩萨作诸变化。云何不思惟。云何无分别耶。佛言。善男子。我今为汝说于譬喻。如此日月照了四洲。为是众生而作利益。而是日月无有思惟亦无分别。以光明故利益众生。但以过去业行因缘果报故。有如是日月利益事生。善男子。菩萨亦尔。虽作变化利益众生。皆无思惟悉无分别。不作功用运是业行。所以者何。是等变化皆由菩萨善业因缘之所成故。菩萨于因地中行菩萨时发弘誓愿。以本愿力而不思惟亦不分别。生诸变化不加功用。善男子。菩萨摩诃萨具足十法。速得成阿耨多罗三藐三菩提。何等为十。所谓万行具如前说。夫万行者。布施具足戒品具足。言戒品者。不隙不杂不瑕不玼。过于声闻缘觉戒品。清净明白戒品具足。忍辱具足。精进具足。禅定具足。善慧具足。善巧方便具足。善愿具足。诸力具足。微妙甚深正智具足。所修妙智具足。不共一切声闻缘觉过其境界。从于菩萨初地以上。乃至九地过境界故。善男子。菩萨具足十法。速得成于阿耨多罗三藐三菩提

大乘宝云经卷第六大乘宝云经卷第七

        梁扶南三藏曼陀罗仙共僧伽婆罗等译

    宝积品第七

尔时佛告宝积菩萨言。善男子。有四种法。退失菩萨智慧。何谓为四。于佛正法无尊重心亦不恭敬。是说法者悭嫉正法。设有人来求正法者而不为说。于乐法者为作留难。遮护覆藏自生憍慢。复加诽谤说正法者。宝积如是四法退失智慧。善男子。有四种法。增长菩萨摩诃萨广大智慧。何等为四。所谓敬重正法及说法者。随所听得微妙正法。广为他人分别解说。不求名闻无希望心而为说法。勤求正法如救头然。随所闻听坚固受持如法修行。不但说是名字而已。善男子。如是四法。增长菩萨广大智慧。善男子。具有四法。而皆忘失菩萨摩诃萨大菩提心。何等为四。所谓不随顺和上阿阇梨一切福田。他人不疑而为作疑。见行大乘者而诽谤之。自心欺诳复诳于他。善男子。如是四法失菩提心。善男子。有四种法。菩萨摩诃萨生生世世大菩提心自然现前。中间不失乃至坐于菩提道场。何等为四。所谓若失身命终不妄语。乃至戏笑知而不说虚妄之言。于诸众生起平等心。心无欺诳亦不诳他。于诸菩萨生世尊想。不乐小乘故。善男子。如是四法。生生世世大菩提心自然现前。中间不失乃至坐于菩提道场。善男子。具四种法。菩萨摩诃萨一切善根不得生长。何等为四。自生憍慢。勤求世间文章咒术。勤求利养贪著名闻。以欺诳心而诳于他善男子。具是四法。菩萨摩诃萨一切善根永不增长。善男子。具有四法。菩萨摩诃萨生生世世增长善根。转胜明净不复退失。何谓为四。舍离一切不净之法。勤求一切清净正法。夫正法者。所谓六波罗蜜菩萨法藏。于诸众生心无憍慢。犹若家犬。如法受施而自知量。舍离一切诸邪慢等。安心知足住于圣种。不说他人罪过虚实。不求人短。若于诸法心不通达。亦于世世增长善根转胜明净不复退失。善男子。菩萨有四种谄曲之心。常应舍离。何谓为四。于诸佛法心生疑悔不决了等。于诸不毁谤当作是念。唯佛作证。佛法无量为诸众生随机所说甚深难解。唯佛自知非我所解。是故不生违逆之心。善男子。是名四法令众生生憍慢心嗔恨恼等。于他利养起嫉妒心。呵骂菩萨广其恶名。善男子。是名四种谄曲之心。菩萨摩诃萨常应舍离。善男子。菩萨摩诃萨具有四种真实之相。何等为四。所谓于所犯罪终不覆藏。向他发露忏悔。改往心无盖缠。若以实言应失国土身命财物。如是急事不舍实语。亦不异缘作诸余语。一切恶事骂詈诽谤挝打系缚种种伤害。受此苦时但自咎责推于往业。不嗔恨他不怀其恶。善住信力自心净故。若于诸佛甚深之法难信难解。悉能信受读诵受持。善男子。是名菩萨有四真实质直之相。善男子。具有四法。[怡-台+龍]悷难调难伏之相。何谓为四。读诵经典翻为戏论。虽口说法不随顺行。于诸教诲违逆不信。不能随顺恭奉供养和上阇梨诸福田等令心喜悦。损他信施恭敬供养自违本誓而受信施。见诸调御菩萨大士。轻欺生慢而不恭敬。善男子。是名菩萨有四种法[怡-台+龍]悷难调难伏之相。善男子。菩萨有四调顺之相。何谓为四。随所闻法而善说之如说而行。依止于法不依言说。承奉师教能知意旨易与言语。所作皆善不失师意。不退戒定以调顺心而受供养。见诸善调信顺大士恭敬爱乐。随顺善训禀受德行。善男子。是名菩萨有四调顺之相。善男子。菩萨有四僻谬。何谓为四。不可信人与之同意是菩萨谬。非器众生说甚深法是菩萨谬。乐大乘者为说小法是菩萨谬。若布施时但施持戒供养善者不施恶人是菩萨谬。善男子。是名菩萨四种僻谬。善男子。菩萨有四正道。何谓为四。于诸众生生平等心。普信众生等以佛慧。于诸众生说法平等。等令众生等住正行。善男子。是名菩萨有四正道。善男子。菩萨有四非善知识非善等侣。何谓为四。求声闻者但欲自利。求缘觉者心乐少事。叹外经典路伽耶陀文章严饰。所亲近者但增世利不慕法利。善男子。是名菩萨有四非善知识非善等侣。善男子。菩萨有四善知识四善等侣。何谓为四。诸来乞者是善知识。道因缘故。能说法者是善知识。增长善故。劝令出家是善知识。出三界苦。诸佛菩萨是善知识。增长一切正妙法故。善男子。是名菩萨四善知识四善等侣。善男子。菩萨有四实非菩萨而似菩萨。何谓为四。贪求利养而不求法。贪求名称不求功德。贪求自乐不救众生。以灭苦法乐聚徒众不乐远离。善男子。是名四非菩萨而似菩萨。善男子。有四种真实菩萨。何谓为四。能信于空亦信业报。知一切法无有吾我。而于众生起大悲心。深乐涅槃而游生死。所作布施皆为众生不求果报。善男子。是为菩萨四种真实菩萨功德。善男子。菩萨有四大藏。何谓为四。若有菩萨值佛出世。因尔得闻六波罗蜜及其义趣。以无碍心侍说法者。不暂远离心无懈怠。住阿兰若而无放逸。善男子。是名菩萨有四大藏。善男子。菩萨有四种法能坏魔事。何谓为四。常不舍离菩提之心。于诸众生心无挂碍。于诸执着悉皆觉知。心不轻贱一切众生。善男子。是名菩萨有四种法能坏魔事。善男子。菩萨有四不可思量福德行业。何谓为四。以清净心而行法施。于破戒人生大悲心。于诸众生称扬叹咏菩提之心。于无力者修习忍辱。善男子。是名菩萨有四不可思量福德行业。善男子。菩萨有四种法。破碎烦恼无明住地。何谓为四。戒品清净若轻若重悉皆不犯。摄持正法不惮劬劳。布施灯明供养福田。舍施财物无有亲疏。是名四法破碎烦恼无明住地。善男子。有四种法得无碍智。何谓为四。无希望心常行法施。受持正法与理相应。于他利养不生嫉妒。恒自摄心不生憍慢。是名四法得无碍智。善男子。非但名字号为菩萨。能行善法行平等心名为菩萨。若能成就三十二法则名菩萨。何谓三十二法。常为众生深求安乐。皆令得住一切智中。常自称量无上法器。心不憎恶他人智慧。破坏憍慢深乐佛道。心地坚固敬无虚假。亲友究竟得至成佛。于亲非亲心常平等。言常含笑言语知量。前应问讯面无颦蹙。所为事业终不中息。普为众生等行大悲。心无疲倦多闻无厌。自责己过不讥彼短。于有罪者慈悲呵责。以菩提心行诸威仪。所行布施不求反报。不求生处而行持戒。于诸众生生无碍忍。为修一切诸善根故勤行精进。遣无色界取于禅定。行方便慧应四摄法。持戒毁戒慈心平等。至心听法心乐远离。住阿兰若而不乐着一切世间种种荣华。于大乘中见大利益。离恶知识亲近善友。常运平等。四种梵心游戏五通。常依真智。于诸众生邪行正行俱不弃舍。言常决定贵真实法。一切善根以菩萨心而为上首。若人具此三十二法。则得名为菩萨之位。善男子。菩萨功德无量无边当以譬喻因缘知之。善男子。譬如大地容受众生。无分别心不求报恩。菩萨亦尔。从初发心至坐道场。一切众生皆蒙利益。心无分别不求报恩。善男子。如一切水润生百种稻禾药草丛林树木。皆得增长。菩萨亦尔。自心净故慈悲普覆。润诸众生皆令增长一切善法善男子。譬如火种皆能成熟百种禾谷药草华果。菩萨智慧亦复如是。皆能成就一切善根。善男子。譬如风轮皆能成立一切世界诸佛刹土。菩萨方便亦复如是。皆能成立一切善法。善男子。如月初生。光明炎色日日增长。菩萨净心亦复如是。一切善法日日增长。善男子。如日初出一时发光。普为一切众生照明。菩萨亦尔。发智慧光一时普照一切众生。善男子。如师子王。随所至处不惊不畏。菩萨亦尔。持戒清净智慧真实。随所住处不惊不畏。善男子。譬如善调大龙象王。荷负重担身不疲极。菩萨亦尔。善调心故荷负一切众生之类。作大利益而无疲倦。善男子。譬如莲华生于水中水不染着。菩萨亦尔。生于世间诸世间法而不染污。善男子。如人伐树根在还生。菩萨亦尔。方便力故虽断结使。有善根爱还生三界。善男子。譬如诸方流水入于大海皆为一味。菩萨亦尔。以种种门习诸善根。回向阿耨多罗三藐三菩提皆为一味。善男子。譬如须弥山王。忉利诸天及四天王皆依止住。菩萨大菩提心亦复如是。为萨婆若所依止住。善男子。如大国王以群臣力能办国事。菩萨智慧亦复如是。以方便力。皆能成办一切佛事。善男子。譬如天净清明无诸云气必无雨相。寡闻菩萨无所知解无法雨润。亦复如是。善男子。譬如天阴云起必能降雨。充足众生生长萌牙。菩萨亦尔。从大悲云起大法雨利益众生。善男子。如转轮圣王所出之处则具七宝。菩萨亦尔。随所出处三十七品现于世间。善男子。如摩尼珠所在之处。则有无量金银珍宝。如是菩萨随所出处。则有无量百千声闻辟支佛宝。善男子。如忉利天入杂藏园。随意所用悉在其中。菩萨亦尔。真净心故于诸众生平等教化。善男子。譬如咒术药力毒不能害。菩萨结使亦复如是。智慧力故不堕恶道。善男子。如大城中所弃粪秽。若置甘蔗蒱萄田中则有利益。菩萨结使亦复如是。所余习气为一切智而作因缘。善男子。譬如有人不曾习学戈矛之法则无武用。菩萨亦尔。不曾习学一切诸法。而不能为算择分别受持修行。善男子。譬如陶师于诸坏器未燥之时。不堪大火。菩萨亦尔。于诸众生智慧微弱。不堪听闻诸佛大法。故不为说。彼设得闻则生狂乱。善男子。菩萨摩诃萨欲学宝云微妙经者。常应修习实法正观。云何正观。所谓真实思惟是法正观。不观我人众生寿命。是名中道真实正观。善男子。夫实观者。观色非常亦非无常。亦观受想行识。非常亦非无常。是名中道真实法观。所以者何。常是一边。无常一边。常与无常二边中间。无色无形无命无知。是名中道诸法实观。我是一边。无我一边。我与无我二边中间。无色无形无命无知。是名中道诸法实观。善男子。若心有实是为一边。若心非实是为一边。若无心识亦无心数。诸大地法是名中道诸法实观。如是善法不善之法。世间诸法出世间法。有罪之法无罪之法。有漏无漏有为无为。乃至有垢无垢。亦复如是。离于二边而不可取亦不可说。是名中道诸法实观。善男子。有是一边。无是一边。有无中间无色无形无命无知。是名中道真实法观。善男子。我之所说十二因缘。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是因缘。而为招集成大苦聚。若无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故如是老死忧悲众恼大苦聚灭。明与无明无二无别。若如是知。是名中道诸法实观。如是行及非行。识与所识。名色可见及不可见诸六入非六入。触及所触。受及受灭。爱与爱灭。取与取灭。有与有灭。生与生灭。老死与老死灭。皆是无二无别。若如是知是名中道诸法实观。复次善男子。夫真实观。不以空故令诸法空法性自空。非无相故令法无相。法性之体本自无相。不以无愿令法无愿。但诸法性本自无愿。不以无起无生无我无取无性。令法无起无取无性。但法本来自无起无取无性。若如是观是名实观。复次善男子。非无人故名之曰空。但空自空前际后际中际亦空。但法自空非色灭空。当依于空莫依于人。若以得空而依于空。佛说是人则为退堕。善男子。宁起我见积如须弥。莫以空见起增上慢。所以者何。一切诸见以空得脱。若起空见则不可治。善男子。如医授药令治彼病。是药在内秘而不出。于意云何。如是病人宁得差不。不也世尊。是药不出其病转增。善男子。如是诸见唯空能灭。若起空见则不可治。譬如有人怖畏虚空悲号捶胸。作如是言却此虚空。于意云何。如是虚空可除却不。不也世尊。善男子。如是若畏空法。我说是人狂乱失心。所以者何。常行空中而畏于空。譬如画师自手画作夜叉鬼像。见则怖畏迷闷躄地。一切凡夫亦复如是。自造色声香味触故往来生死。受诸苦恼不自觉知。善男子。譬如幻师幻作猛虎。幻虎成已还食幻师。行道沙门亦复如是。有所观法皆空皆寂。无有见者是观亦空。善男子。譬如两木本无火相。以两相揩从中火生遂烧是木。善男子。如是真实观故生圣智慧。圣智生已遂灭实观。善男子。譬如然灯。一切黑暗皆自无有。无所从来去无所至。非东方来去亦不至。南西北方四维上下。不从彼来去亦不至。而此灯明亦无是念我能灭暗。但因灯明法自无暗。明暗俱空无作无取。善男子。如是实智慧生无智自灭。智与无智二相俱空。无作无取。善男子。譬如千岁暗室未曾见明。设复有人于中然灯。于意云何。暗宁作念我久住此不欲去也。不也世尊。若灯然时。是暗无力必当灭去。善男子。如是百千万劫久集结业。以一观智即皆能灭。其灯明者圣慧根是。其黑暗者诸结业是。善男子。譬如种植空中。若能增长无有是处。菩萨取证亦复如是。增长佛法亦无是处。善男子。譬如种植在于良田。则能生长斯有是处。菩萨亦尔有诸结使杂世间垢能长佛法。善男子。譬如于彼高原陆地不生莲华。菩萨亦尔。于无为中不生佛法。善男子。譬如卑湿污泥乃生莲华。菩萨亦尔。生死污泥邪定众生能生佛法。善男子。譬如四大海水生苏满中。菩萨有为善根甚多无量亦复如是。善男子。譬如若破一毛以为百分。以一分毛取海一滴。一切声闻有为善根。亦复如是。善男子。譬如虫芥子孔所有虚空。一切声闻有为智慧。亦复如是。善男子。譬如十方虚空无量无边。菩萨有为智慧亦复如是。善男子。譬如转轮圣王有大夫人怀妊七日。是子具有转轮王相。诸天尊重过余诸子具身力者。所以者何。是胎王子。必绍尊位继圣王种。善男子。初心菩萨亦复如是。虽未具足诸菩萨相。如胎王子诸天神王深心尊重。所以者何。如是菩萨必绍尊位不断佛种。善男子。譬如一琉璃珠胜于水精。菩萨亦尔。从初发心便胜一切众生之类。善男子。譬如大王夫人生子之日。小王群臣皆来拜谒。菩萨亦尔。初发心时诸天世人所应礼拜。善男子。譬如雪山王诸药草。遍无所属无所分别。随有所病悉能疗治。菩萨亦尔。所集智药无所分别。普为众生平等救护善男子。如月初生众人爱敬踰于满月。善男子。如是众生信我语者。爱敬菩萨甚于如来。所以者何。由诸菩萨生如来故。尔时世尊。复告宝积菩萨摩诃萨言。善男子。菩萨摩诃萨常为利益一切众生。修集梵行清净功德无上善根。以平等心施与众生。所得智药遍到十方。疗治一切烦恼病苦。皆令毕竟永不复起。云何名为菩萨智药。谓不净观治于贪欲。以修慈心治于嗔恚。以因缘观治于愚痴。以修空观治诸妄见。以无相观治诸忆想分别境界。以无愿观治于一切生三界愿。以四非倒治于四倒。以无常观治无常中计常颠倒。以修苦观治诸苦中计乐颠倒。以法无我治无我中计我颠倒。涅槃寂灭治不净中计净颠倒。身受心法四念处观。则为对治四种颠倒。顺身相观不堕我见。顺受相观不堕我见。顺心相观不堕我见。顺法相观不堕我见。是四念处能治一切身受心法。开涅槃门以四正勤。能断已生诸不善法。不起未生诸不善法。未生善法悉能令生。已生善法能令增长。举要言之。能断一切诸不善法。成就一切诸善之法。四如意足。治于身心一合之相。令得如意自在神通。以此五根。治诸无信懈怠失念乱心无慧一切众生。以此五力摧诸烦恼。以七觉分。治诸法中疑悔妄谬。以八正道。治诸邪道一切论师善男子。是为毕竟智慧妙药。菩萨常应修集殷勤行之。善男子。阎浮提内耆婆医王最为第一。令三千大千世界一切众生皆如耆婆。若有人问心中结使烦恼邪见疑悔病。药尚不能答何况能治。菩萨于中应作是念。我终不以世药为足。我当修习出世智药。亦修一切善根福德。如是菩萨得智药已遍到十方。毕竟疗治一切众生烦恼等病。何谓菩萨出世智药。信知诸法从缘合生。信一切法无我无人亦无众生寿命知见。亦无作者亦无受者。信解通达无我我所。于是空法无所得中不惊不畏。勤加精进而求心相。菩萨摩诃萨如是求心。何等是心。若贪欲耶。若嗔恚耶若愚痴耶。若过去未来现在耶。若心过去过去已灭。若心未来未来未至。若心现在现在无住。是心非内非外亦非中间。是心无色无识无形无见无知无住处。如是之心。十方三世一切诸佛不已曾见。非今现见。非当来见。若一切佛过去来今所不见者。云何当有。但以颠倒妄想因缘。心生诸法种种差别。善男子。是心如幻忆想分别起种种业受种种身。善男子。心去如风于非境界远行难收。心如流水生灭不住。心如灯炎众缘故有。是心如电刹那不停。心如虚空客尘烦恼之所障蔽。心如猕猴取一舍一遍诸境界。心如画师能造种种业因缘故。心无暂定随逐种种诸烦恼故。心唯独一无第二故。心如大王一切诸法增上主故。心常独行无伴侣故。心如怨家能作一切诸苦恼故。心如狂象踏小儿诸土舍。能坏一切诸善根故。是心贪着如鱼吞钩。于苦受中生乐想故。是心如梦于无我中生我想故。心如青蝇于不净中起净想故。心如债主生苦楚故。心如恶鬼求人便故。心常高下贪嗔逼故。心如偷劫夺善根故。心常贪色如蛾投火。心常贪声如战鼓响。心常贪香如猪乐厕。心常贪味如驼爱蜜。心常贪触如蝇着油。善男子。菩萨如是求于心相而不可得。若不可得则非过去现在未来。若非过去现在未来则出三世。若出三世则非有无。若非有无则是不起。夫不起者则是无性。若无性者则是无生。若无生者则是无灭。若无灭者则无所离。若无离者无来无去无退无生。若无来去无退无生则无诸行。若无诸行是则无为。若无为者是为一切诸圣根本。是中无有持戒破戒。若无持戒无破戒者。是则无行亦无非行。若无有行无非行者。是则无有心心数法。若无心心数法者。则无有业亦无业报。若无有业无业报者则无苦乐。若无苦乐是则圣性。是中无业无起业者。无有身业亦无意业。是中无有上下差别。圣性平等犹若虚空。是性平等无有优劣。一切诸法等一味故。是性平等远离一切身心相故。是性远离一切诸法顺涅槃故。是性清净远离一切烦恼垢故。是性无我离我所故。是性真实顺如如故。是性寂静常安乐故。是性无有高下从平等出故。是性真实第一义故。是性无尽毕竟不生故。是性常住诸法常尔故。是性安乐涅槃第一故。是性清净离一切相故。是性无我求不可得故。善男子。汝等应当内善观察莫外驰骋。善男子。当来沙门如狗逐块。云何名为如狗逐块。譬如有人以块掷狗。狗即舍人而走逐块。如是善男子。有诸沙门清信士女。怖畏色声香味触故。住阿兰若空闲之处。独无等侣离众愦闹。身离五欲而心不舍。是人存念色声香味触等。心贪乐着而不内察。不知云何当离五尘。以不知故。有时来入城邑聚落在人众中。还为五欲之所系缚。若空闲处持有漏戒死得生天。又为天上五欲所缚。从天上堕终不得脱于三恶道。所谓地狱畜生饿鬼。是名沙门如狗逐块。善男子。云何沙门不如于彼逐块之狗。若有沙门为人所骂而不加报。打害嗔毁亦不报之。但自内责求伏于心。作如是观骂者是谁受者是谁。打者害者毁者嗔者亦复是谁。是名沙门不如于彼逐块痴狗。善男子。如调马师。马若[怡-台+龍]悷即为制伏。行者亦尔。随心所向则能收摄不令放逸。善男子。譬如有人咽喉闭塞则能断命。如是善男子。一切诸见唯有我见。则能断于智慧命根。善男子。譬如有人随所缚处而求解脱。如是善男子。随心所著当应求解。善男子。出家之人则有二种不净污心。何谓为二。一者读诵世间文章外道诸术。二者多畜诸好衣钵种种服饰。又出家人二种坚缚。何谓为二。一执着缚。二供养缚。又出家人二种障法。何谓为二。一者亲近白衣。二者憎恶善友。又出家人有二种垢。何谓为二。一者忍受烦恼。二者求诸檀越。又出家人二种雹雨。何谓为二。一者毁坏善根违逆正法。二者以破戒身受他信施。又出家人二种痈疮。何谓为二。一者求显他过。二者自覆其罪。又出家人二种烧热。何谓为二。一者以垢秽心爱着法服。二者持戒人边受其供养。又出家人有二种病。何谓为二。一者怀增上慢而调伏心。二者破坏他人发大乘心。善男子。夫沙门者凡有四种。何谓为四。一者形相诈现沙门。二者威仪欺诳沙门。三者求名沙门。四者实行沙门。何谓形相诈现沙门。有一沙门。形相具足服僧伽梨。剃除须发执持应器。而便成就不净身业。不净口业。不净心业。不善护身悭嫉懈怠。破戒怀恶。是名形相诈现沙门。何谓威仪欺诳沙门。有一沙门。具足沙门身四威仪。行立坐卧一心安详。断诸美味修四圣种。远离众会愦闹之所。言语柔软。如是德行欲为欺诳不为寂静。而于空法见有所得。于无所得而生怖畏如临坑想。于说法者而生忿怒如怨贼想。是名威仪欺诳沙门。何谓名闻沙门。有一沙门。伪作相貌现行持戒。欲令人闻努力读诵。欲令他知自为多闻。独处闲静不余杂闹。欲使人知住阿兰若。少欲知足修远离法。欲得人知我是厌离。不为寂静不为得道。不为沙门及沙门果。不为涅槃微妙胜果。是则名为求名沙门。善男子。何谓实行沙门。有一沙门。于自身命尚不生贪。何况利养名闻等事。于空无相无取之法闻大欢喜。顺达真如随说而行。不为涅槃而修梵行。岂乐三界无乐之处。空尚不执何况我见众生人见。依止于法而求解脱。夫求解脱不外驰骋。见一切法本来无垢毕竟清净。但依自身不依于他。于佛法身尚不执着。何况色身。以空远离而不见法。何况贪着音声言说。以无为法尚不见僧。何况当见有和合众。于诸法中无所断除无所修行。不生生死不着涅槃。知一切法本来寂灭。不见有得不求解脱。是名实行沙门。如是善男子。汝等当学实行沙门。莫著名字空无利益。善男子。譬如贫穷下贱之人。强为作字名为富贵。于意云何。是贫贱人称此名不。不也世尊。如是宝积。虽为沙门而无沙门实行之德。如彼贫人空荷名字。善男子。譬如有人漂溺海中渴乏而死。如是宝积。有诸沙门虽多读诵种种经典。而不能止贪恚痴渴。在法水中烦恼渴死堕诸恶道。善男子。譬如医王多畜众药。自身有病而不能治。多闻之人有烦恼病。亦复如是。虽有多闻不止烦恼何能自利。善男子。譬如有人服王贵药。不能将节为药所害。多闻之人有烦恼病亦复如是。得好法药不能修行自害慧命。善男子。如摩尼珠堕不净中未即可用。多闻之人贪着利养。未能利益一切天人。善男子。譬如死人着金璎珞。多闻破戒而被法服受他供养。亦复如是。善男子。如长者子。若男若女净自洗浴剪除爪甲。以香自熏着新净衣宝饰华鬘庄严身首。如是宝积。多闻之人受持净戒。而被法服受他供养。亦复如是。善男子。有四种破戒似善持律。何谓为四。设有一人具足持戒。大小罪中心常怖畏。所闻戒法皆能履行。身口意业悉皆明白正命清洁。如是之人说有我论。是初破戒似善持律。善男子。复有一人诵持戒律。随所说行身见不灭。是二破戒似善持律。善男子。复有一人具足持戒。取众生相而行慈心。闻一切法本来无生心大惊怖。是三破戒似善持律。善男子。复有一人。具足修行十二头陀。见有罪相。是四破戒似善持律。善男子。夫持戒者。无我无我所。无作无非作。无有作法亦无作者。无行无非行。无色无名无相无非相。无成无不成。无取无舍无可取无可弃。无众生无众生名。无心无心名。无世间无非世间。无依止无非依止。不以持戒而自矜高。亦不轻蔑毁破戒者。亦不忆想分别此戒。宝积。是名圣戒无流之戒。不着三有无所依戒。尔时世尊。欲重宣此义。而说偈言

  清净持戒者　　无垢无所有
  持戒无憍慢　　亦无所依止
  持戒无愚痴　　亦无有诸缚
  持戒无尘污　　亦无有违失
  持戒心善软　　毕竟常恒寂
  远离于一切　　忆想诸分别
  解脱诸乱念　　是净持佛戒
  不贪惜身命　　不用诸有生
  修习于正行　　安住于正道
  是名为佛法　　坚实净持戒
  持戒不染世　　亦不依世法
  逮得智慧明　　无暗无所有
  无我无彼想　　已知见诸相
  是名为佛法　　真实净持戒
  无有此彼岸　　亦无有中间
  于无此彼中　　亦不有所著
  无缚无诸漏　　亦无有欺诳
  是名为佛法　　真实净持戒
  心不著名色　　不生我我所
  是名为安住　　真实净持戒
  虽持诸戒行　　其心不自高
  亦不以为上　　过戒求智慧
  是名为真实　　清净持戒相
  不以戒为最　　亦不贵三昧
  过此二事已　　修习于智慧
  空寂无所有　　是诸贤圣性
  如是净戒者　　诸佛所称美
  心脱于身见　　除灭我我所
  信解于诸佛　　所行空寂法
  如是持圣戒　　则为无有等
  依戒得三昧　　三昧能修慧
  依因所修慧　　逮得于净智
  已得净智者　　具足清净戒

佛说是语时。五百沙门不受诸法心得解脱。三万二千人远尘离垢得法眼净。五百沙门得于禅定。闻此深法心不信解。不能通达不入内怀。从座而起还于山林。尔时大迦叶前白佛言。世尊。是五百沙门皆得禅定。不能信解入深法故从座起去。佛语大迦叶。是诸沙门以增上慢。闻是清净无流戒相。不能信解通达了知。佛所说偈其义甚深不入内怀。所以者何。诸佛菩提极甚深故。若无福德未种善根随逐恶友。多不能信受此深法。迦叶。是五百人于过去世迦叶佛时。外道弟子往到佛所欲求佛过。闻佛说法得少信心而自念言。是佛希有快说妙法。以是善心福德因缘。命终之后生忉利天。从彼堕落生阎浮提。于我法中而得出家。是诸沙门深着诸见。闻说深法不能信解。而不随顺不能通达。以闻深法因缘力故得大利益。不以此生更堕恶道。当用此身得入涅槃。尔时世尊。告长老须菩提言。汝往就彼诸沙门边。为教诲之令其得解。长老须菩提对曰。世尊。是等沙门于佛所说尚不信受。岂能信受于我语耶。是时如来即为化作二沙门像。随逐如是五百沙门所游道路。是诸沙门见是二人而问之曰。汝何去耶。答曰。我等欲去就阿兰若。住于山林闲寂之处修禅定乐。所以者何。佛所说法殊不可解。诸沙门言。长老。我等闻佛说法亦不能解。故欲入山修学禅定。时化沙门而对之曰。我等当离自高逆心。应当求解佛所说义。所以者何。无高无诤是沙门法。长老。如佛所说涅槃之名。空无所有。谁得涅槃为何所灭。何法当名为涅槃耶。于此身中颇有我人众生寿者作者士夫弗伽罗等得涅槃耶。又问何法名涅槃耶。诸沙门曰。长老。贪嗔痴尽故涅槃耶。化沙门曰。长老。是贪嗔痴可尽灭者当何处有。诸沙门曰。是贪嗔痴非内非外亦非中间。若无忆想虚妄分别。是贪嗔痴亦不得生。化沙门曰。长老。若尔不须分别。长老。若不分别贪嗔痴等岂得生耶。是贪嗔痴若不更生是名寂静。不为生死不为涅槃。长老。以戒定慧解脱解脱知见不生不灭。长老。如是等法显了涅槃。是等诸法性相空寂不取不舍。长老。当灭此相谓涅槃想。若于无相而作想解。若于有相而作想解。于此有无而起想者是名相缚。长老。应当入于灭受想定。若一能得入灭想定者所作已办。则为满足更无余事。是化沙门说是语时。五百沙门不受诸法心得解脱。得解脱已。往诣佛所头面作礼却坐一处。尔时长老须菩提问诸沙门言。汝等向者为何处去今何来耶。诸沙门曰。长老。佛所说法。来无所从去无所至。又复问曰。汝等沙门云何听法。沙门答曰。不为系缚不为解脱。又问汝等沙门习行何法。答曰不为得故不为失故。又问谁调伏汝。答曰身无决定心无所著。有此二者能调伏我。又问汝等云何解脱。答曰不断无明不生明故。又问汝等为谁弟子。答曰无证无觉是彼弟子。又问汝等几何当入涅槃。答曰犹如如来所作化人。其入涅槃我等当入。又问汝等已得己利耶。答曰自利不可得故。又问汝等所化已得办耶。答曰我及我所不可得故。又问汝等修梵行耶。答曰于三界中不行亦非不行。是我梵行。又问汝等烦恼尽耶。答曰一切诸法毕竟尽故。又问汝等破魔众耶。答曰阴魔不可得故。又问汝等承事如来耶。答曰不以身心故。又问汝等住福田耶。答曰无有住故。又问汝等断于生死诸往来耶。答曰无常断故。又问汝等断诸行耶。答曰无碍解脱故。又问汝等究竟当至何所。答曰随于如来化人所至。于是长老须菩提问沙门时。五百沙门不受诸流心得解脱。三万二千人远尘离垢得法眼净。尔时会中有菩萨摩诃萨名曰普明。在大众中合掌恭敬而白佛言。世尊。菩萨欲学是宝云经当云何学。佛言。善男子。汝当勤心学此经典。何以故。诸佛如来说此宝云微妙经典。但为实行有善根者大利益故。善男子。譬如有人乘土坏船欲渡大河。善男子。于意云何。以何精进乘是坏船。是人得渡如是大河。对曰世尊。以大勇猛精进力故。所以者何。是人念言。我今漂溺四种大流莫于中间是船破坏。勇猛精进乃可得渡。佛告普明菩萨摩诃萨言。菩萨亦尔。欲学此法当勤精进倍过于此。所以者何。是身无常无有决定。难信难养必当败坏。不得久住终归磨灭。未得法利勿令于中而破坏故。我在大河为渡众生于四流故。常习法船往来生死度诸群品。云何菩萨习于法船。谓平等心。于诸众生为船因缘。习无量善以为牢厚。清净戒行以为板障。布施及果以为装饰。信心佛道为诸林木。一切福德以为校具。慈悲喜舍坚固系缚。忍辱柔软忆念为钉。诸菩提分坚强精进。最上妙善诸法林中。出生如是不可思议无量禅定功德业慧。善寂调心以为师匠。毕竟不坏大悲所摄。以四摄法广度致远。以智慧刀防诸恶贼。善权方便种种诸法。合集奉行以为装饰。四正念处以为楼橹。四正勤行以为人力。四如意足以为疾风。五根善察以为船师。五力强壮以为防备。七觉觉悟能破魔贼。八直正道随意到彼。离外道法止为调御。观为利益不着二边。有因缘法甚为安隐。大乘广博无尽辩才广布名闻。能济十方一切群品。而自唱言。汝等当来上我法船。从安隐道得至涅槃。度于断常到无为岸。善男子。如是菩萨摩诃萨常应修习如是法船。以是法船无量无边百千万亿船。于阿僧祇劫在生死中。度脱漂没长流众生。佛复告普明菩萨摩诃萨言。善男子。又有法行能令菩萨疾得成佛。谓诸所行真实不虚。厚习善法身心清净不舍精进。乐近光明修善根故。常正忆念乐善法故。多闻无厌具足慧故。破碎憍慢增益智故。除灭戏论具功德故。乐住山林无争竞故。不处愦闹离恶友故。深求诸法决定依于第一义故。求于智慧通达真实诸法相故。求于空法所行正故。求于远离永寂灭故。如是善男子。是为菩萨摩诃萨获得速成诸佛神通。当如是学如是修行。尔时长老摩诃迦叶复白佛言。希有世尊。如是宝云微妙经典大为利益。一切天人无量无边。若善男子善女人。于此大乘宝云经典受持读诵。若为人说若称善哉。及诸幢幡华香灯烛而供养之。乃至读诵一四句偈。而不诽谤欢喜信受。是人得福无量无边。所以者何。财施果报但在三界。法施之力出于三界。无老病死得涅槃乐。设有女人能诵此经。彼则离于四种恶趣。从今以去永不复受女人之身。转女身已得成男身。聪明智慧生正信家。当速得成如来法身三十二相八十种好金刚不坏真实之身

大乘宝云经卷第七


大乘遍照光明藏无字法门经

    No. 830 [Nos. 828, 829]

大乘遍照光明藏无字法门经

        大唐天竺三藏地婆诃罗再译

如是我闻。一时佛住王舍城耆阇崛山。与大菩萨及比丘僧无量百千亿那由他众俱。其诸菩萨。一切皆得大智善权。悉能通达无字法藏。具乐说辩不违真俗。勇猛精进永离盖缠。调伏诸根无所执着。怜愍众生如视一子。爱重实智如大宝洲。惭愧为身定慧为首。以大慈悲而为体性。知善不善实不实法。照了二空住胜妙地。得大名称永安隐眠。决定修行最上之法。永离胎藏下劣之身。示现受生守护国土。诸所施为普遍贤善。离于三界能救三界。其行清净善达自他。皆得具足如是功德。其名曰胜思惟菩萨。胜趣行菩萨。妙音菩萨。美音菩萨。辩具菩萨。辩聚菩萨。珠髻菩萨。千辐菩萨。法辋菩萨。法响菩萨。莲花面菩萨。莲华眼菩萨。持地菩萨。持世菩萨。声遍大地菩萨。如是等菩萨摩诃萨。一切皆是童子像类。于此众中而为上首。各各与己眷属等俱

尔时观世音菩萨。与无量无数灌顶受职诸菩萨众之所围绕。得大势菩萨。与无量亿大梵天众之所围绕。胜思惟菩萨。与无量菩萨及天主帝释之所围绕。虚空藏菩萨。与无量四天王众之所围绕。众所知识菩萨。与无量婇女之所围绕。普贤菩萨。离疑菩萨。不空见菩萨。止诸盖菩萨。无量善巧药王菩萨。药上菩萨等。各与无量菩萨大众之所围绕。长老舍利弗。摩诃目干连。摩诃迦叶等。各与一切大阿罗汉之所围绕。乃至十方恒河沙等。一切世界所有日月诸天子等。各以威光来至佛所。以佛神力彼彼威光不能照曜。犹如聚墨比阎浮金。又有无量那罗延天。及以水天德叉迦龙王。阿那婆达多龙王等。亦与眷属之所围绕。美音乾闼婆王。亦与无量乾闼婆众之所围绕。无浊迦娄罗王。与七亿迦娄罗王眷属围绕。乃至十方恒沙世界。一切菩萨。各请己佛与眷属俱。来至此间娑婆世界。持诸上妙出世供具。供养于佛及菩萨已。各礼佛足却住一面。坐莲华座瞻仰世尊。尔时胜思惟菩萨摩诃萨。即从座起。偏袒右肩右膝着地。合掌向佛而作是言。世尊。我为四众欲问如来二字之义惟愿如来为我解说。令我等辈咸得利益

尔时世尊。告胜思惟菩萨言。善男子。如来岂为一众生故出现于世。乃为利益无量众生出现于世。善男子。汝今乃能为四众故。请问于我二字之义。随汝所问当为汝说

于是胜思惟菩萨。蒙佛听许。白佛言。世尊。有何等法。菩萨摩诃萨应当除灭及以守护。复有何法。如来克证及以觉知。如是二义惟愿为说

尔时佛赞胜思惟言。善哉善哉。善男子。汝已成就无量福慧。复为如来加威神力。乃能问我如是之义。谛听谛听善思念之。吾当为汝分别解说

善男子。有一种法。菩萨摩诃萨应当除灭。何等一法。所谓欲贪。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓嗔恚。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓愚痴。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓我执。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓懈怠。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓睡眠。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓染爱。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓疑惑。如是一法菩萨摩诃萨应当除灭。善男子。复有一法。菩萨摩诃萨应当除灭。何等一法。所谓无明。如是一法菩萨摩诃萨应当除灭。善男子。如上所说如是等法。菩萨摩诃萨应当除灭。善男子。汝问于我。复有何法。菩萨摩诃萨应守护者。今为汝说。善男子。有一种法。菩萨摩诃萨常当守护。何等一法。所谓己所不欲勿劝他人。如是一法菩萨摩诃萨常应守护。何以故。若菩萨摩诃萨守护此法。即是守护诸佛如来一切戒藏。如诸菩萨。自爱命者则不应杀。自爱财者则不应盗。自爱妻者不应侵他。自爱实语不应诳彼。自爱和合不应间他。自爱正直不应邪绮。自爱柔软不应恶骂。自爱止足终不于他而生贪欲。自爱仁恕终不于他而生嗔恚。自爱正见终不教他令生邪见。善男子。如是菩萨发意说言。我今敬顺如来正教。应当勤心守护此法。是名菩萨摩诃萨守护一法。善男子。我见如是诸菩萨等。欲求无上大菩提者。悉为乐故而求菩提。无有为苦求之者也。善男子。是故我说己所不欲勿劝他人。如是等法。菩萨摩诃萨应当守护

尔时胜思惟菩萨。复白佛言。世尊。何等之法如来克证及以觉知。惟愿为我开演其义。佛言。善男子。无有一法而是如来所觉所证。何以故。于诸法中无觉无证。此是如来所证所觉。善男子。一切诸法本无有法如来觉证。一切诸法本无有灭如来觉证。一切诸法性离二边如来觉证。一切诸法本无有实如来觉证

复次善男子。一切诸法皆从自业因缘力故而得生起。而是因缘念念不住犹如电光。如是业缘如来觉证。是故我说以因缘故而诸法生。以因缘故而诸法灭。若离因缘则无业报。如是等事如来觉知。善男子。如是所觉一切法性。是名遍照光明之藏。善男子。何故法性名之为藏。以诸众生世出世智。皆依此藏而得生故。如以实智观彼法性。智依彼生故名为藏

复次善男子。我亦复说一切诸法如幻如焰如水中月。如是等事如来觉证。又善男子。诸法性相一味解脱。如是等事如来觉证。善男子。如是解脱一味法性。是名遍照光明之藏

复次善男子。又有一法如来觉证。何等一法。所谓诸法不生不灭。不增不减不来不去。不取不舍非因非缘。如是等法如来觉证

复次善男子。如来了知一切诸法。无有自性不可为喻。无有文字之所辩说。如是之法如来觉证。善男子。如上所说如是之法。悉是如来所觉所证。当佛说此遍照光明藏无字法。时有微尘数诸菩萨等得住十地。又有无量诸菩萨等住于诸地。又有无量诸菩萨等证得百千诸大三昧。又有无量尘数众生发阿耨多罗三藐三菩提心。又有无量无边众生得阿罗汉果。又有无量无边众生。得脱地狱饿鬼畜生种种诸苦。生人天中受胜妙乐。诸在会众悉不唐捐。无有一人而空过者

尔时佛告罗睺罗言。善男子。我此法要汝当受持。时彼会中有九十亿菩萨摩诃萨。闻是语已承佛神力。白佛言。世尊。我等誓于娑婆世界后时后分。见有堪能为法器者。我当为彼宣说是经。惟愿世尊不以为虑。尔时四天王。复白佛言。世尊。若当来世有善男子及善女人。能有受持此经典者。我当拥护。诸有愿求皆令满足。何以故。此善男子及善女人。能持此经是法器故

尔时世尊。见九十亿诸菩萨等及四天王如是请已。便作是言善男子。我此所说遍照光明藏无字法门。我得佛来未曾演说。今为汝等而演说之。善男子。彼未来世诸众生等。若得闻此希有法门。当知是人久已成就无量福慧。当知是人则为承事供养于我。当知是人则为荷担佛大菩提。当知是人决定当得成就辩才。当知是人决定当得清净佛土。当知是人临命终时定当得见阿弥陀佛菩萨大众之所围绕。当知是人常见我身在灵鹫山。及见此等诸菩萨众。当知是人则为已得无尽法藏。当知是人得宿命智。当知是人不堕恶道

复次善男子。今我说是未曾有法。若当来世有善男子及善女人。设有已作五逆等罪。闻此法门若能书持读诵解说。或劝他人书持读诵及以解说。我见是人不堕恶道。其人所有诸烦恼障业障报障皆得清净。其人来世具得五眼。其人则为一切诸佛所共灌顶。其人则为诸佛世尊及诸菩萨之所护念。其人来世在在所生具足诸根无有缺减

佛说是经已。胜思惟菩萨摩诃萨等。及诸比丘天龙八部。闻佛所说。皆大欢喜信受奉行大乘遍照光明藏无字法门经


大乘顶王经

    No. 478 [Nos. 477, 479]

大乘顶王经

        梁优禅尼国王子月婆首那译

归命大智海圆满净觉尊

如是我闻。一时佛在毗舍离庵罗树园。与大比丘僧八百人俱。菩萨摩诃萨十千人俱。及诸天龙八部鬼神。尔时世尊食时着衣持钵。入毗舍离大城。乞食于其城中。次第游于净称里巷。尔时净称里巷有一童子名善思惟。乳母抱持在于高楼重阁之上手执莲华娱乐受乐。以宿善根即向乳母。而说偈言

  如是音乐声　　世所未曾有
  母今速放我　　我欲至阁下
  必是大精进　　世尊大光明
  我欲投右足　　因陀枳罗边
  微妙甚可乐　　众鸟悉围绕
  此声昔未闻　　亦生未曾睹
  必是大精进　　怜愍众生故
  以右足而蹈　　因陀枳罗边
  如母着璎珞　　贯之严其身
  未触出妙声　　令人意所乐
  必是天中尊　　功德光庄严
  放右足而下　　因陀枳罗边
  如人击铜鼓　　出于大音声
  于其一切处　　皆得闻此音
  必是人中日　　大牟尼光明
  入此大城中　　利益诸众生
  如树生花时　　种种花庄严
  随意出妙音　　令众生贪着
  必是大龙王　　善住天中尊
  我欲右足蹈　　因陀枳罗边
  如空净无垢　　周遍无尘翳
  光焰如金色　　令日光不现
  必是乐见者　　具足光明尊
  放右足而下　　因陀枳罗边
  如此诸天众　　住在于空中
  欢喜而赞叹　　旋转在空中
  必是利世者　　最胜天中尊
  放右足而下　　因陀枳罗边
  如此城众生　　悉生于慈心
  各各意相谓　　如母子相亲
  必是功德聚　　功德花庄严
  放右足而下　　因陀枳罗边
  如男子女人　　持种种妙花
  满掬而侍立　　欢喜相瞻视
  必是人中龙　　功德花庄严
  右足下而蹈　　因陀枳罗边
  天花及人花　　满于虚空中
  散以缤纷香　　令人心爱乐
  必是大精进　　欲请毗舍离
  无上尊入城　　利益诸众生

尔时乳母闻子语已惊怖毛竖。即将童子至于楼下。而作是念。向所言者为是谁作。为是天也若龙夜叉罗刹鬼神紧那罗摩睺罗伽为是人也。还住本处而不移动

尔时世尊至其门已。时彼童子见佛世尊。在其阁下瞻仰如来。以佛神力在虚空中。即向世尊。而说偈言

  世尊住大智　　安住无上人
  怜愍诸众生　　愿受此莲花

尔时世尊。以偈答童子言

  我住于实际　　非世间境界
  其际无有际　　此是实际相

尔时善思惟童子。以偈问曰

  云何住于际　　实际中导师
  其际无有际　　若无云何住

尔时世尊。以偈答言

  若际是实际　　即际是如来
  如住于实际　　导师如是住
  若际是实际　　即际是如来
  如住于实际　　童子我住然

尔时善思惟童子。以偈问言

  非际际为际　　其际有何相
  以何方便故　　名之为实际

尔时世尊。以偈答言

  无取际非际　　故名为实际
  虚空是际相　　其空无空相

尔时善思惟童子。而说偈言

  妙处是实处　　处处无有上
  愿一切众生　　住此如导师

尔时善思惟童子白佛言。世尊。唯愿世尊。怜愍我故受此莲花。尔时世尊即便受彼所施莲华。如来受已。时彼童子而作是言。世尊。以此善根愿我得成阿耨多罗三藐三菩提。为诸众生分别解说无凡夫法无声闻法。尔时慧命舍利弗在大众中。语善思惟童子言。汝学何法为众生说。尔时善思惟童子。以偈答言

  诸佛及声闻　　一切无得者
  我觉如是法　　为诸众生说
  其法世界无　　亦无有言说
  智者应当知　　其法性如是
  过去正遍知　　天人无上尊
  无得此法者　　导师入涅槃
  彼处无法界　　亦无众生界
  此是无上际　　非世间境界
  法界但是名　　名字而分别
  无分别分别　　分别毕竟无

尔时富楼那弥多罗尼子。以偈问善思惟童子言

  云何于此法　　童子而修学
  甚深难知处　　智者于此惑
  汝生来未久　　智慧甚通达
  与声闻谈论　　智慧无障碍
  处处巧明净　　如成炼真金
  如王在大众　　如月在于空

尔时善思惟童子。以偈答慧命富楼那曰

  汝今知己问　　彼处无有生
  诸法未曾生　　谁受于生者
  无一法生者　　自性不可得
  此是诸法性　　求法不可得
  法及于法性　　二俱不可得
  二俱未曾有　　而佛说妙法
  此是第一轮　　鹿苑中所说
  如卷把于空　　以觉诸声闻
  法音遍一切　　救度诸众生
  以得方便智　　如实而演说
  生者及与死　　是凡夫境界
  富楼那汝有　　颠倒未除尽
  生者及死者　　此世间言说
  无言说法中　　言说是密语

尔时富楼那弥多罗尼子白佛言。希有世尊。善思惟童子。于此甚深法中智慧通达。佛告富楼那。如是如是如汝所说。佛问善思惟童子。汝以何义求阿耨多罗三藐三菩提。尔时善思惟童子。而说偈言

  天人无上尊　　知已而故问
  如牟尼所说　　谁当有所求
  我今无所求　　而求无滞法
  甚深无上句　　清净离诸漏
  众生不可得　　非众生亦然
  于此不迷没　　能住于世间
  若能如是知　　甚深无上句
  一者及异者　　如上实际说
  觉悟诸众生　　众生不可得
  以无众生故　　亦无觉知者
  智慧及众生　　自性不可得
  若能如是知　　是名为智者
  世尊我如是　　自然能觉知
  为一切众生　　而说无上法

尔时阿难白佛言。希有世尊。善思惟童子。以此甚深辩才。于无证无得法中而能解说。一切世间天人阿修罗。于此法中皆生惊怖。世尊。谁于此法而不修学。于此深法应先修学。尔时慧命阿难而说偈言

  善思惟童子　　在于大众中
  如须弥宝山　　观者皆爱乐
  譬如须弥山　　安处于大海
  如是善说法　　世间所爱乐
  非有名无名　　童子之所说
  所说实际法　　非世间境界
  如是言说时　　不生惊怖心
  汝今为我说　　云何如是知

尔时童子。而说偈言

  我不顾身命　　求法无所著
  如是求菩提　　多闻应当知
  因欲堕愦闹　　世间受诸苦
  我已不贪着　　见世导师故
  此诸佛境界　　救护世间者
  今在于佛前　　身无有诸过
  虚空及我身　　二俱不可得
  若无法可得　　于法有何怖
  虚空及与佛　　二俱不可得
  若能如是忍　　于法无所畏
  虚空及与地　　自性不可得
  善思此自性　　于法无所畏
  善思虚空地　　本无当亦无
  无自性无生　　畏者无自性
  虚空无高下　　毕竟不可得
  如是知法者　　于法无所畏

尔时世尊问善思惟童子言。汝不畏也。不也世尊。汝不惊也。不也世尊。佛告童子。善哉善哉。汝能于此甚深法中不惊不怖。尔时世尊。而说偈言

  若于体生畏　　其体不可得
  若如是常忍　　其人求菩提
  说于众生想　　众生不可得
  若能如是知　　安住于此乘
  若不得菩提　　不得非菩提
  更无有所得　　彼则无所畏
  若能如是知　　不住有无中
  如是汝应知　　此道是菩提

是故善思惟。菩萨欲速得阿耨多罗三藐三菩提。欲觉知者。常想乐想净想众生想人想。应当修学此道。能向阿耨多罗三藐三菩提。我本行菩萨道时。亦常修学如是之行。我得如此无上道已。不得一法名得菩提。尔时世尊。而说偈言

  我说于常想　　常体不可得
  常无常无故　　求之不可得
  乐想众生者　　不知于乐想
  此是颠倒想　　分别生于人
  是故彼有想　　命者及以人
  若有知法者　　彼此不可得
  非道得菩提　　非道亦不得
  此是诸法性　　求法不可得
  性及于实事　　智者不分别
  汝应如是知　　此道是菩提
  不行此妙乘　　佛乘无上乘
  于此生分别　　是人不知法
  不行此妙乘　　佛乘无上乘
  若不修此行　　甚深定难证
  诸法无实事　　实事不可得
  若无实事者　　云何得有乐
  若乐若苦等　　犹如空中迹
  智者如说知　　其心得解脱
  我说有我者　　其法无实事
  以无有我故　　无有能知者
  无有知者故　　是智慧境界
  是以说命想　　毕竟不可得
  若我若命等　　自性无实事
  大智能解知　　少智则迷惑
  性及于实事　　此凡夫境界
  不知此乘中　　佛乘不思议
  甚深修多罗　　不闻不受持
  于此法门中　　无法可演说
  我不得一法　　亦无法可说
  我坐道场时　　不证一智慧
  无智亦如是　　菩提无得故
  菩提及道场　　说时不可得
  凡夫起分别　　称言佛说法
  此是微密言　　甚深佛所说
  若不闻此法　　最胜之所说
  甚深及与佛　　此是魔境界
  其人不知味　　守护一切法
  诸菩萨众等　　无不了此法
  诸佛及菩提　　二俱不可得
  如是妄言说　　称云佛说法
  如此云何有　　依止于可求
  若有智慧者　　分别甚深法
  如是信赞叹　　诸佛不思议
  是故善思惟　　当修学深法
  其法义甚深　　甚深智能觉
  如是言说此　　言说亦无得
  众生见颠倒　　此非其境界
  非唯三昧故　　能知于此义
  三昧非三昧　　于空中亦无
  此非智境界　　亦非非智境
  应觉知此际　　非是智慧境
  我昔闻此法　　行于甚深处
  众生所乐异　　信受者希有
  若不信此经　　最胜之所说
  多佛种善根　　是人乃能信

尔时世尊。复告善思惟言。童子。是故菩萨应如是自庄严。于世间惊怖处不生惊怖。应如是庄严。童子言。世尊。我于今者信乐受行。愚痴之人所不能信。佛告童子。菩萨摩诃萨甚深之行当为汝说。诸法无诤闻已不惊。一切法断闻已不惊。诸法不断闻已不惊。一切法有一切法无闻已不惊。一切法分别一切法无分别闻已不惊。诸法有为诸法无为闻已不惊。一切法有境界一切法无境界闻已不惊。一切法欢喜一切法无欢喜闻已不惊。一切法差别一切法无差别闻已不惊。一切法有求一切法无求闻已不惊。一切法清凉一切法无清凉闻已不惊。一切法明一切法无明闻已不惊。一切法有名一切法无名闻已不惊。一切法生一切法无生闻已不惊。一切法有畏一切法无畏闻已不惊。一切法生一切法灭一切法无灭闻已不惊。一切法是道一切法非道闻已不惊。一切法般涅槃一切法不般涅槃闻已不惊。说此法时。不生惊怖。尔时世尊。而说偈言

  于一切法中　　自性不可得
  以无自性故　　应观其相灭
  一切法无灭　　其中亦无心
  一切法无故　　自性不可得
  一切法中诤　　其心不可得
  若法不可得　　亦无有诤者
  一切法无故　　其性无有实
  若性无实者　　其法亦无灭
  一切诸法断　　智者解不二
  此称为断者　　非显示于断
  一切法不断　　微尘不可得
  微尘及多尘　　法中不可得
  一切法无故　　言说中而现
  如彼不可得　　实有而不现
  一切法无故　　方便而有见
  若言无实者　　此则皆戏论
  一切法和合　　无诤故宣说
  求诤之自性　　毕竟无有实
  一切法无合　　无作亦无灭
  如是不可得　　远离于诸法
  一切法无得　　求始不可得
  以其无始故　　名之为实际
  一切法欢喜　　喜悦不可得
  若法不可得　　亦无有言说
  一切法无喜　　以法无二故
  自性中无实　　此是甚深相
  一性法不动　　自性中无我
  以自性无故　　求动不可得
  无动是涅槃　　求法不可得
  以无有法故　　故名为涅槃
  一切法无常　　而说第一义
  此众生言说　　名之为分别
  诸法无分别　　无常无住故
  众生不可得　　此是法中法
  一切法如幻　　其幻不可得
  以法不可得　　依行故言说
  一切法无为　　此是其自体
  以法不可得　　是故名无边
  所说之境界　　自体无境界
  凡夫虚妄取　　称言有境界
  自在说境界　　亦说无境界
  以其说境界　　应知无境界
  一切法是实　　其数不可得
  若身不可得　　是故无有异
  以其无得故　　则知有所得
  以有所得故　　则知无所得
  其中无清凉　　亦无不清凉
  无法无清凉　　此是诸法实
  诸法不可得　　不可得说此
  以诸法无故　　则知诸法有
  一切法唯名　　名亦不可得
  若法不可得　　则知有涅槃
  受及与非受　　于受中而说
  此中无有说　　名之以为说
  非有名为有　　于有中而说
  以起分别故　　恒堕有无中
  凡夫见幻人　　取之谓为实
  有无法平等　　智者闻不惑
  法生及无生　　二俱不可得
  以下劣凡夫　　故说有生法
  法若有生者　　是则应有灭
  生法及灭法　　此二不可得
  一切法悉空　　无法而可得
  汝应如是知　　我所说深法
  菩提无言说　　亦无有作者
  若得菩提时　　于三有明了
  若分别菩提　　不名求菩提
  行及于菩提　　无有分别相
  一切物无生　　求自性亦无
  以自性无故　　此是涅槃相
  毕竟无有生　　求之不可得
  以自性无故　　非灭非非灭
  若知此义者　　一切法自性
  彼无有生故　　则无有违诤
  闻说甚深法　　不生惊怖者
  应知彼众生　　佛说为菩萨

尔时善思惟童子。以偈白佛

  世尊无上师　　为我故出世
  于此法中说　　异相求唯名
  牟尼出于世　　佛生不思议
  永断诸魔网　　而现正法网
  我断生死尽　　不久至道场
  若无异想者　　以相故演说
  世尊说可求　　见已入涅槃
  度脱诸世间　　断绝诸疑惑

尔时世尊。告善思惟童子言。无疑惑行是菩萨行。护念之行是菩萨行。无分别行离一切过。以甚深行怜愍一切诸众生等是菩萨行。善思惟。相行虚妄行是欲相。舍于欲行离诸嗔恨。于一切众生其心平等。以心不可得故。行大慈行以求法故。行大施行以不舍故。行无疑行以不见他故。行无恼热行以清凉故。行精进行无疲倦故。行三昧行心无边故。行于智行知一切法相故。行无畏行无怯弱故。行无障行成就如来影像胜行故。观察十方一切世界以无滞行故。尔时世尊。而说偈言

  说诸菩萨行　　远离诸疑惑
  行及于愚痴　　二俱不可得
  非行以为行　　是诸菩萨行
  若知此行者　　斯人行无碍
  说诸菩萨等　　护念于诸法
  以求无所得　　此是无上行
  若说我修行　　则住于颠倒
  以住颠倒故　　不能得无畏
  此是言说行　　言说不可得
  若能如是知　　行于无上乘
  大乘无上乘　　此乘无惊怖
  惊怖及不惊　　一切皆戏论
  我说一切行　　一切行皆无
  若一切行无　　是为无上行
  此行是甚深　　护念一切法
  护念及甚深　　此一切分别
  甚深及以行　　此中二俱无
  若知于此际　　不分别诸法
  无法可取着　　无法不可着
  此是诸法性　　无性而演说
  无坚无欲等　　以求故显说
  文字不可得　　此是无上句
  我以方便说　　闻者勿生怖
  以求不可得　　亦无破坏相
  此诸众生行　　理实不可得
  若能如是知　　是名善修学
  一切众生无　　故我说众生
  而众生法尔　　此道是无上
  若心若众生　　毕竟不可得
  此是第一义　　而大慈故说
  菩萨摩诃萨　　世间大施主
  以修常施故　　故名为施主
  若法不可得　　一切法皆无
  是时修施者　　菩萨无智故
  若法不可得　　于高下法中
  以不惊怖故　　名为真施主
  若佛不可得　　法则不思议
  此名真持戒　　诸法无所依
  佛境不思议　　为诸菩萨说
  愚者不觉知　　禁戒不清净
  于众生起忍　　众生不可得
  此是无上忍　　于此法中说
  若心不可得　　亦无有分别
  此是无上忍　　以法不可得
  若起疲倦时　　菩萨应远离
  如是上精进　　以名字故说
  身心直精进　　不倚于诸法
  此是上精进　　为诸菩萨说
  菩萨于法中　　若不起疲倦
  无功而精进　　勤精进无上
  于内外法中　　心性不可得
  其心善调柔　　以心无得故
  攀缘及以心　　自性无所有
  无心三摩提　　是故名三昧
  善逝为我说　　此三摩跋提
  若不离此法　　我说善调伏
  不以智慧知　　法有少自性
  自性及以法　　此二毕竟无
  不得一切法　　心识之境界
  不以智知法　　自性毕竟无
  若能如是知　　是菩萨念力
  行于第一义　　非世间境界
  一切众无实　　而为说正说
  于彼大众中　　不起众生想
  彼众生如幻　　其幻毕竟无
  闻如是说时　　不生于碍想
  若自他等法　　此二毕竟无
  闻说如是法　　不生于碍想
  内外等二法　　智者之所行
  心无高下故　　一切世间等
  一切法无碍　　犹如空中迹
  法自性亦尔　　如彼空中迹
  菩萨如是知　　名为善通达
  明了一切法　　知众生所行
  众生不可得　　求法亦复然
  智明了诸界　　其界毕竟无
  我说入此门　　行于无上道
  得如是道已　　知诸众生行
  界及于众生　　此二俱无实
  如是第一智　　知于一切法
  于内外法中　　智慧无所著
  远离无著法　　是名为实际
  此法不思议　　名为诸佛法
  彼法无所有　　无亦毕竟无
  如是修行时　　不着于此世
  此智名无滞　　名为诸佛智
  诸法不思议　　于法理无实
  以其法无故　　佛法名觉者
  诸佛及佛法　　一切皆不着
  不着于菩提　　是名诸佛智
  此乘是大乘　　摄一切法门
  度脱诸世间　　世间不可得
  一切诸世界　　所有诸众生
  菩萨为求法　　皆亲近恭敬
  深观此诸法　　佛法不思议
  以不得诸法　　是人得菩提
  菩提及以法　　一切皆无相
  如是观察者　　能尽于佛法
  如是观察时　　于世间不着
  以心不着故　　能尽于菩提

复次善思惟。诸菩萨摩诃萨。未具庄严者我今当说。若有得闻如是法门不生惊怖。当知是人已近道场。近佛境界住无障碍解脱之道。观察十方心无所著则为诸佛。以大慈大悲不共佛法。不观顶相之所覆护。闻说如是甚深法门生信乐者。则为如来悉见悉知。于此经中不信乐者如来悉知。若于此经生信乐者。是佛弟子我是其师。尔时世尊。而说偈言

  我已坐道场　　道场毕竟空
  以不得菩提　　安住于智中
  其法无障碍　　法体毕竟无
  若法毕竟无　　解脱时乃知
  于一切法中　　智慧能到佛
  一切法及智　　此是佛所说
  凡夫妄分别　　说言有无著
  诸佛不分别　　菩萨及智者
  观察诸世间　　世间毕竟无
  世间空寂故　　观智亦如是
  众生及以佛　　无有分别相
  以无分别故　　名为无上慈
  尽诸众生界　　虽为悲所触
  其悲无实事　　悲及于实事
  此凡夫境界　　如虚空尺寸
  本无当亦无　　世间亦如是
  是名无上悲　　此是无上法
  名为诸佛法　　求之不可得
  善逝之所说　　导师无上尊
  求色不可得　　如是法无色
  随世间故说　　虚空无有边
  处处不可取　　诸佛法如是
  随世间故说　　此无上智慧
  智慧不可得　　以智不可得
  彼智亦无实　　此岸若彼岸
  以相形故说　　以彼取相故
  不行甚深法　　当知此法中
  一切皆平等　　若以相说者
  则非善知识　　自众若他众
  若说有求者　　以取相说故
  彼非善知识　　若谓法为有
  除遣得无法　　童子我此法
  不作如是说　　我以知苦故
  性中无苦恼　　若如是说者
  不入于此法　　诸法本无集
  名之以为集　　若说断于集
  则远离此法　　若于此定法
  本无而分别　　于本无法中
  本来无有灭　　若以分别说
  本无今何灭　　童子汝当知
  此见非正见　　修习于道者
  以求故演说　　付嘱于求者
  于道中修学　　我说诸菩萨
  大智大名称　　于当来世中
  能解此深义　　若有持此经
  最胜之所说　　多种诸善根
  为诸众生故　　善说修多罗
  智者能受持　　是人当来世
  能护我正法　　说于此法者
  住如无分别　　如此是菩提
  菩提不可得

说此法时。善思惟童子。得无生法忍。踊跃欢喜得未曾有。诸佛法常为诸菩萨授记莂时现希有事。尔时世尊。从其面门放诸光明。青黄赤白紫颇梨色。此光出已遍照无量一切世界上至梵世。照世界已还至佛所。绕佛三匝从佛顶入。是时大地六种震动。尔时空中有诸天众。雨众天华沉水末香。于虚空中作天伎乐出妙音声。尔时三千大千世界清净庄严如郁单越。尔时阿难。从坐而起整理衣服。恭敬合掌白佛言。世尊。何因缘故如来现此希有之事。若无因缘如来则不现此瑞相。尔时阿难。而说偈言

  无上导师人中尊　　无缘则不现奇变
  唯愿世尊为众说　　今此瑞相何因缘
  诸天在于虚空中　　供养最胜无上尊
  欢喜踊跃而赞叹　　善说微妙胜法门
  譬如北方郁单越　　种种妙华而庄严
  此诸光明亦如是　　照此世界皆严净
  一切诸佛法如是　　为诸菩萨授记莂
  放此妙色大光明　　遍照十方从顶入
  无上精进牟尼尊　　现此光明希有事
  如来何缘放斯光　　唯愿大悲为我说

尔时世尊即为阿难。而说偈言

  善思惟童子　　于诸如来所
  广种诸善根　　当作人中尊

佛告阿难。此善思惟童子。于当来世当得供养无数亿佛。于诸佛所信乐恭敬。以诸供具饮食衣服卧具汤药。供养彼佛。彼诸如来般涅槃已。取佛舍利起大宝塔高百千由旬。一切众宝以为严饰。以一切华香宝幢幡盖。栴檀沉水种种末香伎乐歌颂。供养赞叹彼诸如来。当得作佛号净月如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时世尊。而说偈言

  十方诸世界　　珍宝满其中
  以此珍宝聚　　奉施诸如来
  世间无上师　　世尊之所说
  若闻能受持　　功德多于彼

尔时慧命舍利弗。以偈白佛

  甚深胜法门　　最胜之所说
  云何名此经　　我等顶受持
  于此法门中　　不说一法无
  有亦不可得　　胜法门所说
  一切有漏法　　及以无漏法
  于此不可得　　微妙经所说
  一切有为法　　及以无为界
  二俱不可得　　于此经中说
  世尊无上师　　说于一切行
  一切不可得　　于此经中说
  佛之所说法　　于此亦不说
  所说甚微妙　　求我不可得
  十方诸世界　　世尊之所说
  世界无自体　　于此经中说
  导师无上尊　　唯愿为我说
  云何名此经　　我等当受持
  闻如是语已　　佛告舍利弗
  此经名顶王　　其顶毕竟无
  大智汝当知　　应如是受持
  若能受持此　　最胜之所说
  彼人能觉知　　诸天及世人
  佛说此法时　　众中百万人
  诸善根增长　　悉发菩提心
  以得闻此经　　甚深无上法
  此众必当得　　世间无上尊
  于甚深法中　　皆悉明了知
  此众毕当作　　受持此章句
  若能受持此　　所说顶王经
  于一切法中　　不生悕望心
  此中无一忍　　亦无第二忍
  若法不可得　　亦无法可说
  若有能受持　　顶王修多罗
  以观此法故　　能生于辩才
  若有智女人　　能受持此经
  能速转女身　　成就丈夫法
  以一知一切　　以此一切知
  诸法陀罗尼　　于此经中说
  言说一切法　　容受于一切
  如是说此分　　法光靡不遍
  彼彼诸世间　　种种名应知
  于处处说者　　其法不可得
  法不可攀缘　　求之不可得
  一切法如是　　总持者安乐
  若法不可得　　法中无有无
  此是诸法性　　名之为总持
  若有能持此　　所说顶王经
  持法之光明　　遍照一切处
  一切法甚深　　其法不可得
  若法不可得　　亦无所有无
  若人具智慧　　辩才无所碍
  乃能知此义　　毕竟无有实
  如阿耨达龙　　处空注大雨
  水非从外来　　不思议力尔
  若欲知诸法　　分别无所碍
  学此修多罗　　不依一切法
  于此法门中　　法无所从来
  一切法无生　　于此经中说
  譬如日光明　　光无所不至
  此经亦如是　　遍照一切法
  若辩才比丘　　应受持此经
  学此修多罗　　微妙顶王经
  速疾能得成　　不思议辩才
  修学此经已　　能利益世间
  若有于此经　　能信生随喜
  总持者难得　　以不知味故
  比丘比丘尼　　若不修行此
  行余虚妄行　　去我法甚远
  于我弟子中　　若能修行此
  能为世间眼　　一切无与等
  如忉利天王　　能覆护世间
  此经亦如是　　能为世间舍
  如住须弥顶　　见一切世间
  如是住此经　　观察一切法
  如夜火星流　　一切皆悉见
  持经者光明　　一切法中胜
  譬如日光明　　遍照一切处
  此经亦如是　　能灭一切闇
  如月在空中　　照已而不住
  此经亦如是　　能照十方界
  此印是法印　　一切印所印
  此印住世间　　为诸菩萨故
  如虚空中印　　本无当亦无
  虚空及与印　　二俱是分别
  如是诸佛法　　于此经中说
  诸佛不可说　　法亦复如是
  如王命将终　　国嗣付长子
  敕告群臣众　　悉以付我子
  如是圣法财　　贤圣所守护
  付阿难比丘　　为诸菩萨说
  守护持此经　　为诸菩萨故
  成就善根者　　此经入其手
  若有能受持　　演说此经者
  是人必得佛　　决定无有疑
  若人求辩才　　于法无依止
  应受持演说　　顶王胜法门
  说于世间法　　即名为菩提
  如是无差别　　通达于此经
  于一切世间　　此人无疑惑
  能受持此经　　亦为他人说
  闻如是经已　　觉知诸佛法
  以此甚深法　　利益诸众生
  佛说此经时　　诸佛皆称赞
  善哉无上尊　　所说甚微妙
  建此大法幢　　法幢不思议
  能以四句偈　　为众生解说
  此不思议经　　若为他解说
  能观无量法　　法观不思议
  诸佛无上尊　　永断一切法
  皆同说此经　　不思议法门

尔时世尊说此偈已。告阿难言。若有比丘比丘尼优婆塞优婆夷。闻是法已。受持读诵为他解说。所得功德甚多无量不可穷尽。譬如虚空不可穷尽。如是阿难。若人于此甚深法门。受持读诵一四句偈为他解说其人功德亦复如是说不可尽。尔时世尊。而说偈言

  无边甚深法　　此经说大义
  受持解说者　　应善护此经
  若以分别说　　虚空尚可穷
  于此经功德　　说之不可尽
  若受持此经　　则为已供养
  十方世界中　　一切诸世尊
  十方世界中　　所在大牟尼
  受持此经者　　则礼拜供养
  十方世界中　　十号具足尊
  若有闻此经　　则为已供养
  过去诸世尊　　及以当来佛
  十方世界中　　现在人中尊
  若有受持此　　如来所说经
  皆悉已供养　　师子牟尼尊
  以资生供养　　此是世间智
  受持此经者　　无上智慧供
  若人以珍宝　　充满十方界
  持以施诸佛　　其福德甚多
  若复于此经　　善学为人说
  此人所供养　　佛说为第一
  我所说法中　　求佛不可得
  于此不惊怖　　即是供养佛
  此第一供养　　世间所不及
  若不毁呰者　　亦名为供养
  诸佛及以法　　求之不可得
  此第一供养　　最胜之所说
  然灯正遍知　　以此法供养
  此第一供养　　为诸菩萨说
  我于彼世尊　　以此供养已
  然后得授记　　当来世作佛
  若欲求佛道　　为众生上首
  净修行此道　　而供养导师
  如是供养已　　得菩提不久
  应修此供养　　通达一切法
  此第一供养　　一切诸佛法
  诸导师世尊　　一切悉皆得
  得入佛境界　　佛智不思议
  能作师子吼　　我应受世供
  作师子吼已　　一切法无畏
  度无量众生　　入无漏涅槃

佛说此经已。善思惟童子及诸比丘僧。一切世间天人阿修罗乾闼婆等闻佛所说。皆大欢喜信受奉行大乘顶王经


大乘伽耶山顶经

    No. 467 [Nos. 464-466]

大乘伽耶山顶经

        大唐天竺三藏菩提流志译

如是我闻。一时婆伽婆住伽耶城山顶精舍。与大比丘众一千人俱。其先悉是长发梵志。皆阿罗汉诸漏已尽所作已办。舍诸重担逮得己利。尽诸有结正知解脱。心得自在到于彼岸。复与无量诸菩萨摩诃萨众俱

尔时世尊得成正觉其日未久。寂然宴坐入于三昧观察法界。作是念言。我已证菩提。已得圣智慧。已办所应作。已舍诸重担。已出生死旷野。已舍离无明获于智明。已拔毒箭。已尽渴爱。已证法界。已击法鼓。已吹法螺。已建法幢。已舍离生死眼说于法眼。已闭恶道。开众善道。已舍非田示诸福田。我今审观如是之法。谁能现证已证当证。为身证耶。为心证乎。若身证者。身是顽钝无觉无思。犹如草木墙壁瓦石。从于四大父母所生。无常败坏散灭之法。必假涂洗衣食等缘而得存立。若心证者。心如幻化无相无形。无所依处无所容受。又菩萨者随于世间而立名字。无音响无形色。无成实无相状。无来无去不出不入。过于三界无有处所。不可见闻不可忆念。离攀缘处非戏论境。无所入无文字。不可动摇不可安立。绝于一切语言之道。而言现证已证当证。但惟名字虚妄分别。无生无起无有体性。不可取不可说不可爱着。是中实无已成正觉现成正觉及当成者。若能如是无证无成。乃得名为成正觉耳。何以故。菩提者离于一切变动相故

尔时文殊师利菩萨摩诃萨。知佛所念而作是言。世尊。若菩提如是相者。诸善男子善女人。发菩提心应云何住。佛言。文殊师利。如菩提相应如是住。文殊师利菩萨言。世尊。何者是菩提相。佛言。文殊师利。菩提相者独超三界。虽随世俗而有名字。远离一切音声言说。诸菩萨众发趣菩提。从初发心则无所趣。是故文殊师利。诸善男子善女人。应以远离发趣之心而住菩提。文殊师利。若诸菩萨能发趣于无所趣者。是则趣向菩提之道

文殊师利。趣于无自性。是趣向菩提。趣于无处所。是趣向菩提。趣于法界性。是趣向菩提。趣于一切法中无所执着。是趣向菩提。趣于实际无差别。是趣向菩提。趣于如镜中像如光中影如水中月如热时焰。是趣向菩提。尔时众中有天子名净月威光。白文殊师利菩萨言。大士。诸菩萨摩诃萨。修习何行依何处修。文殊师利菩萨言。天子。诸菩萨摩诃萨修大悲行。依于一切众生处修。净月天子又问言。菩萨大悲依何心起。文殊师利菩萨言。菩萨大悲依无谄诳心起。又问言。无谄诳心依何而起。答言。无谄诳心依于一切众生平等心起。又问。于一切众生平等心依何而起。答言。依于入非一非异法性心起。又问。入非一非异法性心依何而起。答言。依深信心起。又问。深信心依何而起。答言。依菩提心起。又问。菩提心依何而起。答言。依六波罗蜜起。又问。六波罗蜜依何而起。答言。依方便慧起。又问。方便慧依何而起。答言。依不放逸起。又问。不放逸依何而起。答言。依三种净行起。又问。三种净行依何而起。答言。依十善业道起。又问。十善业道依何而起。答言。依持净戒起。又问。持净戒依何而起。答言。依如理思惟起。又问。如理思惟依何而起。答言依观察心起。又问。观察心依何而起。答言。从忆持不忘起。尔时净月威光天子复问文殊师利菩萨言。大士。诸菩萨发菩提心凡有几种。于因于果而得成就。文殊师利菩萨言。天子。诸菩萨发菩提心凡有四种。于因于果而得成就。何等为四。一者初发心。二者解行住发心。三者不退转发心。四者一生补处发心。应知初发心为解行住因解行住发心为不退转因。不退转发心为一生补处因。一生补处发心为一切智因。复次天子。应知初发心如田中下种。解行住发心如牙渐增长。不退转发心如枝叶花果次第出生。一生补处发心如果实成熟

复次天子。第一发心如造车人先集于材。第二发心如得材已各别治净。第三发心如彼匠人造车成就。第四发心如以其车引重致远

复次天子。第一发心犹如初月。第二发心如五日夜至七夜月。第三发心如十日夜月。第四发心如十四日夜月。应知如来所有智慧。譬如明月至十五夜。一切光色悉皆圆满

复次天子。第一发心超声闻地。第二发心超辟支佛地。第三发心超不定地。第四发心住决定地

复次天子。第一发心譬如有人初学字母。第二发心如彼学人渐解分析。第三发心如学已久善算数。第四发心如学成熟了达诸论

复次天子。第一发心菩萨住因。第二发心菩萨住智。第三发心菩萨住断。第四发心菩萨住果

复次天子。第一发心因所摄。第二发心智所摄。第三发心断所摄。第四发心果所摄

复次天子。第一发心从因而起。第二发心从智而起。第三发心从断而起。第四发心从果而起

复次天子。第一发心因差别分。第二发心智差别分。第三发心断差别分。第四发心果差别分

复次天子。第一发心如采集众药。第二发心如分辩药性。第三发心如随病合药。第四发心如服药除愈

复次天子。第一发心生法王家。第二发心学法王法。第三发心学得解了。第四发心学得自在

尔时会中有天子名决定光明。白文殊师利菩萨言。大士。何者是菩萨摩诃萨速疾道。诸菩萨摩诃萨行此道。疾得阿耨多罗三藐三菩提。文殊师利菩萨言。天子。菩萨摩诃萨速疾道有二种。诸菩萨摩诃萨行此道。疾得阿耨多罗三藐三菩提。云何为二。一者方便道。二者般若道。方便道者摄诸善法。般若道者了知简择。方便道者不舍众生。般若道者能舍诸法。方便道者知法和合。般若道者知不和合。方便道者能为因缘。般若道者能至寂灭。方便道者能知诸法差别之相。般若道者能知法界无差别理。方便道者能具庄严诸佛国土。般若道者能知诸佛国土平等。方便道者能知众生根行不同。般若道者能知根行空无所有。方便道者令诸菩萨诣于道场。般若道者能令菩萨逮无所觉。天子。菩萨摩诃萨复有二种速疾道。云何为二。一者资粮道。二者决择道。资粮道者谓施等五波罗蜜。决择道者谓般若波罗蜜。有着道无著道有漏道无漏道。皆如是说。复有二种速疾道。云何为二。一者有量道。二者无量道。有量道者谓有相位。无量道者是无相位。复有二种速疾道。所谓智道及以断道。智道者谓从初地至第七地。断道者从于八地至第十地。尔时会中有菩萨名勇修智信。白文殊师利菩萨言。大士。云何为菩萨摩诃萨所知义。云何为菩萨摩诃萨所修智。文殊师利菩萨言。善男子。义非和合。智是和合。勇修智信菩萨言。大士。以何因故。义非和合智是和合。文殊师利菩萨言。善男子。义是无为无为则非义。非义中无有法若和合若不和合。义是无变异无成实不可取不可舍。皆如是说。善男子。智名为道道与心和合非不和合

复次善男子。智惟是和合非不和合。勇修智信菩萨言。大士。何因缘故。智惟是和合非不和合。文殊师利菩萨言。善男子。智善能观察蕴处界。善观察缘起法。善观察处非处。以是故。惟和合非不和合

复次善男子。菩萨摩诃萨有十种智。何等为十。一者因智。二者果智。三者义智。四者方便智。五者般若智。六者摄智。七者波罗蜜智。八者大悲智。九者教化众生智。十者于一切法无所著智。善男子。如是名为菩萨摩诃萨十种智

复次善男子。菩萨摩诃萨有十种发起。何等为十。一者身发起。为一切众生净治身业故。二者口发起。为一切众生净治口业故。三者心发起。为一切众生净治意业故。四者内发起。于一切众生无所取着故。五者外发起。于一切众生行平等行故。六者智发起。修习一切佛智故。七者国土发起。示现一切佛刹功德庄严故。八者教化众生发起。知诸烦恼病药故。九者真实发起。能成就决定聚故。十者无为智满足发起。于一切三界心无所著故。善男子。如是名为菩萨摩诃萨十种发起

复次善男子。菩萨摩诃萨有十种行。何等为十。一者波罗蜜行。二者摄物行。三者般若行。四者方便行。五者大悲行。六者求慧资粮行。七者求智资粮行。八者清净信心行。九者入诸谛行。十者不分别爱憎境行。善男子。如是名为菩萨摩诃萨十种行

复次善男子。菩萨摩诃萨有十种无尽观。何等为十。一者身无尽观。二者事无尽观。三者法无尽观。四者爱无尽观。五者见无尽观。六者资粮无尽观。七者取无尽观。八者无所执着无尽观。九者相应无尽观。十者道场识自性无尽观。善男子。如是名菩萨摩诃萨十种无尽观

复次善男子。菩萨摩诃萨有十种调伏行。何等为十。一者调伏悭嫉行。舍施如雨故。二者调伏破戒行。三业清净故。三者调伏嗔恚行。修习慈心故。四者调伏懈怠行。求法无倦故。五者调伏不善行。得禅解脱神通故。六者调伏无明行。生决定善巧慧资粮故。七者调伏诸烦恼行。圆满一切智资粮故。八者调伏颠倒行。出生真实不颠倒资粮道故。九者调伏不自在行。于时非时自在故。十者调伏着我行。观察诸法无我故。善男子。如是名为菩萨摩诃萨十种调伏行

复次善男子。菩萨摩诃萨有十种寂静地。何等为十。一者身寂静地。远离三种身不善业故。二者口寂静地。净治四种口业故。三者心寂静地。永舍三种意恶行故。四者内寂静地。不执着自身故。五者外寂静地。不执着一切诸法故。六者智资粮寂静地。不执着所行道故。七者不自高寂静地。观察圣智自性故。八者究竟边际神通寂静地。出生般若波罗蜜故。九者灭戏论寂静地。不欺诳一切众生故。十者不顾恋身心寂静地。大悲教化众生故。善男子。如是名为菩萨摩诃萨十种寂静地

复次善男子。诸菩萨摩诃萨如实行者能得菩提。不如实行则不能得。如实行者如其所说则如是行。不如实行者但有言说。不能信受不能修习。复次善男子。菩萨摩诃萨有二种如实行。何等为二。一者道如实行。二者断如实行。善男子。菩萨摩诃萨复有二种如实行。何等为二。一者自调伏如实行。二者教化众生如实行。善男子。菩萨摩诃萨复有二种如实行。何等为二。一者有功用智如实行。二者无功用智如实行。善男子。菩萨摩诃萨复有二种如实行。何等为二。一者善建立诸地如实行。二者善观察诸地无差别如实行。善男子。菩萨摩诃萨复有二种如实行。何等为二。一者善远离诸地过失如实行。二者善圆满诸地功德如实行。善男子。菩萨摩诃萨复有二种如实行。何等为二一者善说声闻辟支佛地如实行。二者善说诸佛菩提不退转法如实行。善男子。菩萨摩诃萨有如是等无量无边如实行法。若能如是如实行者。当知是人不久得阿耨多罗三藐三菩提。诸菩萨摩诃萨应勤修学

尔时世尊赞文殊师利菩萨言。善哉善哉。文殊师利。快说此语

佛说此经已。文殊师利菩萨摩诃萨。勇修智信菩萨摩诃萨。净月威光天子。决定光明天子。及余众会一切世间天人阿修罗等。皆大欢喜。信受奉行大乘伽耶山顶经


大乘离文字普光明藏经

    No. 829 [Nos. 828, 830]

大乘离文字普光明藏经

        大唐天竺三藏地婆诃罗译

如是我闻。一时佛在王舍城耆阇崛山中。与大菩萨无量百千亿那由他数。皆是大智精进善巧。证无言法获妙辩才。是处非处不相违反。善调身心具诸解脱。常游三昧不舍大悲。惭愧为身智慧为首。多所饶益如大宝洲。了知诸法善不善相。不著文字而有言说。于真俗门洞达无碍。深明实际不住其中。善能分别而无所受。虽厌生死常护世间。周遍十方有大名称。于真妙藏寂然宴息。虽现受身永出三界。而行诸有勉济众生。平等教诲志常贤善。平等怜愍心无染着。能令自他莫不清净。成就如是无量功德。其名曰胜思惟菩萨。法震音菩萨。妙身菩萨。法辋菩萨。辩积菩萨。持地菩萨。持世菩萨。大名称菩萨。具诸辩菩萨。千容相菩萨。功德山菩萨。莲华眼菩萨。莲华面菩萨。珠髻菩萨。妙音菩萨。如是等菩萨摩诃萨。皆如童子色相端严。于此众中而为上首

尔时观自在菩萨。与恒河沙等绍尊位者诸菩萨俱。殊胜见菩萨与无央数天帝释俱。虚空藏菩萨与无量菩萨及无量四天王众俱。大势至菩萨与无量亿梵天众俱。遍吉祥菩萨与无量婇女俱。普贤菩萨。不空见菩萨。星宿王菩萨。离疑菩萨。息诸盖菩萨。药王菩萨。药上菩萨。各与无量菩萨众俱。其中亦有无量诸佛。自变其身作菩萨像。尊者舍利弗。摩诃目干连。摩诃迦叶。如是等大阿罗汉。各与无量声闻众俱。那罗延等无量天众。乃至恒沙国土日月诸天。威光照耀悉来佛所。至佛所已。彼天威光不能复现。犹如聚墨对阎浮金。婆楼那龙王。德叉迦龙王。阿那婆达多龙王。美音乾闼婆王。无扰浊迦楼罗王。各与无量诸眷属俱。来入此会。十方世界如恒河沙所有菩萨。咸于本土启请如来。与诸四众同时到此。各持种种出过世间殊好供养。奉上于佛诸菩萨已。即于会中坐莲华座

尔时胜思惟菩萨摩诃萨从座而起。偏袒右肩右膝着地。合掌向佛。而作是言。世尊。我今欲请二字之义。惟愿如来垂哀见许

佛告胜思惟菩萨言。善男子。欲有问者随汝意问。如来不为一众生故出现世间。为欲利益无量众生而出现耳。于是胜思惟菩萨。即白佛言。世尊。何者一法。是诸菩萨所应永离。何者一法。是诸菩萨应常护持。何者一法。是诸如来现所觉了。佛言。善哉善哉善男子。汝以如来威神之力。乃能问我如是深义。谛听谛听善思念之。当为汝说

善男子。有一种法菩萨应离。所谓欲贪。善男子。如是一法是诸菩萨所应永离。善男子。复有一法菩萨应离。所谓嗔怒。如是一法是诸菩萨所应永离。善男子。复有一法菩萨应离。所谓愚痴。如是一法是诸菩萨所应永离。善男子。复有一法菩萨应离。所谓我取。善男子。复有一法菩萨应离。所谓疑惑。善男子。复有一法菩萨应离。所谓憍慢。善男子。复有一法菩萨应离。所谓懈怠。善男子。复有一法菩萨应离。所谓惛眠。善男子。复有一法菩萨应离。所谓爱着。善男子。如是一法。是诸菩萨所应永离

善男子。汝复问我。何者一法。是诸菩萨应常护持。善男子。谓诸菩萨非己所安不加于物。若诸菩萨守护此法。即是能持诸佛如来一切禁戒。何以故。自爱身命不应杀生。自重资财不应偷盗。自护妻室不应侵他。如是等行皆名一法。善男子。若有敬顺如来语者。于此一法常当忆念。何以故。无有众生爱乐于苦凡有所作悉求安乐。乃至菩萨求阿耨多罗三藐三菩提。亦为自他皆得乐故。善男子。以如是义我说此言。非己所安不加于物。如是一法是诸菩萨应常护持

善男子。如汝所问何者一法是诸如来现所觉了。善男子。无有少法是如来觉。何以故。如来觉者无所觉故。善男子。一切法无生是如来觉。一切法无灭是如来觉。一切法离二边是如来觉。一切法不实是如来觉。善男子。诸业自性是如来觉。一切法从因缘生。是如来觉。因缘之法犹如电光。是如来觉。以因缘故而有诸业。是如来觉。善男子。一切法性普光明藏。是如来觉。善男子。何故法性名普光明藏。善男子。世出世智依之以生。如母怀子故名为藏。若智生时反照其本。如是法性为般若波罗蜜之所摄藏。是故名为普光明藏。善男子。一切法如幻如焰。是如来觉。善男子。诸法实性一味解脱。是如来觉。一味解脱是即名为普光明藏。善男子。一相法是如来觉。云何一相。所谓诸法不来不去非因非缘不生不灭无取无舍不增不减。善男子。诸法自性本无所有不可为喻。非是文词之所辩说。如是一法。是诸如来现所觉了。当佛说此庄严王离文字普光明藏法门之时。有十地菩萨所见微尘数众生。悉发阿耨多罗三藐三菩提心。复有如是微尘数众生。皆发声闻辟支佛心。复有如是微尘数众生。在地狱者皆得离苦生人天中。无量菩萨得入初地。无量菩萨得百千三昧。无量众生悉蒙利益无空过者

尔时佛告罗睺罗言。善男子。我此法要汝当受持。说是语时。会中有九十亿菩萨摩诃萨。承佛威神即皆避座。白佛言。世尊。我等誓当受持如来所说法要。于此娑婆国土最后时中。见有其人流通为说

尔时四天王白佛言。世尊。若有能持此经典者我当拥护。令其志愿皆得满足。所以者何。能持此经是法器故。尔时世尊。普观众会而作是言。诸仁者。我此所说甚深方广希有法门。非诸众生有少善根而能听受。能听受者即为承事供养于我。亦为荷担无上菩提。是人当得辩才无碍。决定生于清净佛土。是人临终定得亲见阿弥陀佛菩萨大众而现在前。我今在此耆阇崛山诸菩萨众所共围绕。彼临终时亦如是见。当知是人即为已得无尽法藏。当知是人得宿命智。当知是人不堕恶道。善男子。我今说此一切世间难信之法。设有众生作五逆罪。闻是经已书持读诵为人解说。所有业障咸得消除。终不受于恶趣之苦。斯人即为诸佛菩萨之所护念。在在所生诸根具足。蒙佛灌顶五眼清净。善男子。取要言之。我见是人已成佛道

佛说此经已。胜思惟等一切菩萨。及诸声闻天龙八部。皆大欢喜信受奉行大乘离文字普光明藏经


大乘密嚴經

    No. 681 [No. 682]

大乘密嚴經

大乘密嚴經卷上

        唐天竺三藏地婆訶羅奉　制譯

    密嚴會品第一

如是我聞。一時佛住出過欲色無色無想於一切法自在無礙。神足力通密嚴之國。非諸外道二乘行處。與諸鄰極修觀行者。十億佛土微塵數菩薩摩訶薩俱。皆超三界心意識境。智意生身轉於所依。成就如幻首楞嚴法雲三昧。處離諸有蓮花之宮。為無量佛手親灌頂。其名曰摧異論菩薩。大慧菩薩。如實見菩薩。持進菩薩。解脫月菩薩。觀自在菩薩。得大勢菩薩。神通王菩薩。文殊師利菩薩。金剛藏菩薩。如是等菩薩摩訶薩而為上首。爾時如來應正等覺。從自證智境現法樂住神通辯才現眾色像三昧而起。出虹電光妙莊嚴殿。與諸菩薩入於無垢月藏殿中。昇密嚴場師子之座。諸菩薩眾亦皆隨坐。眾坐已定。於時世尊四方周顧。從眉間出清淨光明名髻珠莊嚴。有無量光周匝交映。成光明網。是光明網流照之時。一切佛土莊嚴之相。分明顯現如一佛土。餘諸佛土嚴飾細妙同於微塵。密嚴佛土超諸佛國。無有日月及諸星宿。如無為性不同微塵。此密嚴中諸佛菩薩。并餘國土來此會者。皆如涅槃虛空及非擇滅

爾時世尊。現諸國土及佛菩薩勝功德已。復以佛眼遍視十方諸菩薩眾。謂如實見菩薩言。如實見。今此國土名為密嚴。是中菩薩從色無色無想之處。以三昧力生智慧火。焚燒色愛及以無明。轉所依止而得智定。意生之身神足力通以為嚴飾。無竅隙無骨體。如日月虹電紫金明珠頗梨珊瑚訶利多羅占波迦孔雀花月鏡中之像。住於諸地淨有漏因三昧自在。十究竟願及以迴向。獲殊妙身而來住此

爾時如實見菩薩在大眾中。即從座起偏袒右肩右膝著地。曲躬合掌白佛言。世尊。我於今者欲有所問。惟願如來哀許為說。佛告之言。善哉善哉恣汝所問。常為開演。時如實見即白佛言。世尊。唯此佛土出過欲色無色無想眾生界耶。佛言。善男子。上方去此過百億佛國。有梵音佛土。娑羅樹王佛土。星宿王佛土。過如是國復有無量百千國土。廣博殊麗種種莊嚴。彼中諸佛咸為菩薩說現法樂住內證智境離諸分別真如實際大涅槃界究竟之法。是故當知此佛土外。有如是等無量佛國。如實見。非唯汝今於佛國土菩薩眾會心生疑怪請問如來。此有菩薩名曰持進。曾於佛所生疑怪心。便以神通昇于上方。過百千億乃至如恒河沙諸佛世界。不能一見如來之頂。心生希有念佛菩薩不可思議。還娑婆世界舍衛城中。至於我所悔謝己過。歎佛無邊猶如虛空。住內證境來密嚴國

爾時會中金剛藏菩薩摩訶薩。善能演說諸地之相。微妙決定盡其源底。從座而起偏袒右肩右膝著地。曲躬合掌白佛言。世尊。我於如來應正覺所欲問少法。願佛慈哀為我宣示

佛言金剛藏。汝於我所欲有所問。如來應正等覺。當順汝心為汝開演

爾時金剛藏菩薩摩訶薩蒙佛許已。即白佛言。世尊。佛菩提者是何句義。所覺是何請說。第一義境示法性。佛除去來今在行地者。色相之見及取著外論。行分別境起微塵勝。性自在時方虛空。我意根境和合。如是諸見復有計著。無明愛業眼色與明。是時復有觸及作意。如是等法而為因緣等無間緣所緣緣增上緣。和合生識虛妄憶度。起有無等種種言論。此法之中復有諸人於蘊眾生墮空性見。為斷如是妄分別覺。唯願世尊。說離五種識所知相。能於諸法最自在者。佛大菩提所覺知義。令得聞者知其了悟。所知五種而成正覺。爾時佛告金剛藏菩薩摩訶薩言。善哉善哉。金剛藏。十地自在超分別境。有大聰慧能欲顯示。法性佛種最上瑜祇。非惟汝今於佛菩提所覺之義生希有念請問於我。有賢幻等無量菩薩。咸於此義生希有心。種種思惟而求佛體。如來者是何句義。為色是如來耶。異色是如來乎。如是於蘊界處諸行之中。內外循求不見如來。皆是所作滅壞法故。以智定意審諦觀察。乃至分析至於微塵。皆悉不見蘊麤鄙故。如來者常法身故。善哉佛子。汝能善入甚深法界。諦聽諦聽善思念之。當為汝說。金剛藏菩薩摩訶薩。唯然受教佛言。善男子。金剛三昧藏勝自在者。如來非蘊亦不異蘊。非依蘊非不依蘊。非生非滅非智非所知非根非境。何以故。蘊界處諸根境等皆麤鄙故。不應住內不應住外而見如來。善男子。色無覺知無有思慮。生已必滅同於草木瓦石之類。微塵集成如水聚沫。受以二法和合而生。猶如浮泡瓶衣等。想亦二和合因緣所生。如熱時焰。譬如盛熱地氣蒸涌。照以日光如水波浪。諸鳥獸等為渴所逼。遠而見之生真水解。想亦如是。無有體性虛妄不實。分別智者如有性見各別體相名字可得。定者審觀。猶如兔角石女兒等。但有假名初無實義。如夢中色唯想妄見寤即非有。無明夢中見男女等種種之色。成於正覺即無所見。譬如芭蕉皮葉既除中無有實。行亦如是。離於身境即無體性。識如幻事虛偽不實。譬如幻師。若幻師弟子。以草木等物。幻作於人及諸象馬種種形體具足莊嚴。愚幻貪求非明智者。識亦如是。依餘而住而異分別。謂能所取二種而生。若自了知即皆轉滅。是故無體同於幻事

金剛藏。如來常住恒不變易。是修念佛觀行之境名如來藏。猶如虛空不可壞滅。名涅槃界亦名法界。過現未來諸佛世尊。皆隨順此而宣說故。如來出世不出世間此性常在。名法住性亦名法尼夜摩性。金剛藏。云何名為尼夜摩。後有諸惡此皆離故。又此三昧。能決定除後有諸惡。以如是義名尼夜摩。若有住此三昧之者。於諸眾生心無顧戀。證於實際及以涅槃。猶如熱鐵投清冷水故。諸菩薩捨而不證近住而已。常為眾生而作利益。不捨精進大悲諸度。不斷佛種。不行外道二乘之徑。如大力象。不為三昧淤泥所溺。心不味著識之境界。趣佛法門恒無退轉。以究竟慧入佛法身。開顯如來廣大威德。當成正覺轉妙法輪。智境眾色而為資用。入如來定遊涅槃。境。漸次修行超第八地。善巧積習乃至法雲資用如來廣大威德。住於諸佛內證之地。與無功用三昧相應。遍遊十方不動本處。而恒依止密嚴佛國轉於所依。智定意身力通自在皆得具足。譬如空月影遍眾水。佛亦如是。化形普降於諸世間。隨眾生心所樂不同。皆使蒙益無空見者。復令當詣密嚴佛國。如其性欲而漸開誘。為說一切欲界天王自在菩薩摩尼宮等諸安樂處。乃至諸地次第十方佛土功德莊嚴。盡於未來隨機應現。如因持咒安繕那藥及諸靈仙宮殿之神。與人同止而不可見。如來變化所為事畢住於真身晦而不現。亦復如是。爾時世尊而說偈言

  根蘊如蛇聚　　境界緣所觸
  癡愛業以生　　眾習縛難解
  心及諸心法　　動慮恒不安
  覺觀所纏繞　　如龍共盤結
  瞋毒從此興　　譬如炎盛火
  諸修觀行者　　為捨眾蘊法
  於此常諦觀　　一心而不懈
  譬如虛空中　　無樹而有影
  風衢與鳥迹　　此見悉為難
  能造及所造　　色與非色法
  於彼見如來　　其難亦如是
  真如實際等　　及諸佛體性
  內證之所行　　超諸語言境
  涅槃名為佛　　佛亦名涅槃
  離諸分別想　　云何而可見
  碎末於金礦　　礦中不見金
  智者巧融鍊　　真金方乃顯
  分剖於諸色　　乃至為微塵
  及析求諸蘊　　若一若異性
  佛體不可見　　亦非無有佛
  定者觀如來　　三十二相具
  若樂等眾事　　施作皆明顯
  是故不應說　　如來定是無
  三昧一緣佛　　善因善根佛
  一切世勝佛　　及正等覺佛
  如是五種佛　　所餘皆變化
  三十二勝相　　如來藏具有
  是故佛非無　　定者能觀見
  出過於三界　　無量諸佛國
  如來微妙剎　　淨佛子充滿
  禪慧互相資　　以成堅固性
  遊於密嚴土　　思惟佛威德
  密嚴中之人　　一切同於佛
  超過剎那壞　　恒遊三昧中
  世尊有大定　　湛然而正受
  相好諸功德　　內外以莊嚴
  眾謂佛化身　　從於兜率降
  佛常密嚴住　　像現從其國
  住真而正受　　隨緣眾像生
  如月在虛空　　影鑒於諸水
  如摩尼眾影　　色合而明現
  如來住正定　　現影亦復然
  譬如形與像　　非一亦非異
  如是勝丈夫　　成於諸事業
  非微塵勝性　　非時非自在
  亦非餘緣等　　而作於世間
  如來以因性　　莊嚴其果體
  隨世之所應　　種種皆明現
  遊戲於三昧　　內外無不為
  山川及林野　　朋友諸眷屬
  眾星與日月　　皎境而垂象
  如是諸世間　　身中盡包納
  復置於掌內　　散擲如芥子
  佛於定自在　　牟尼最勝尊
  無能作世間　　唯佛之所化
  盲暗無知者　　馳流妄分別
  計著於有無　　若我及非我
  或言一切壞　　或言少分滅
  如是諸人等　　常自害其身
  云何於此中　　而生是諸見
  佛是遍三界　　觀行之大師
  觀世如乾城　　所作眾事業
  亦如夢中色　　渴獸所求水
  因於種種業　　風繩而進退
  佛於方便中　　自在知見者
  譬如工巧匠　　善守於機發
  亦如海船師　　執拖而搖動
  如來最微妙　　寂靜無有邊
  超諸有著根　　淨根之所證
  是修行定者　　微妙定所依
  一切觀行人　　明了心中住
  佛體最清淨　　非有亦非無
  遠離於限量　　及以能所覺
  妙智相應心　　最上之境界
  知相皆無性　　是即見如來
  破諸相應心　　不著於三昧
  住於無染路　　一切皆無染
  諸天乾闥婆　　阿修緊那羅
  仙人及外道　　讚歎而供養
  於彼不耽求　　而興世間業
  以住本清淨　　相應妙理中
  天人等見者　　變化之所作
  佛非彼此現　　而同於日月
  住於圓應道　　現除諸貢高
  異學各不同　　隨宜而攝御
  種種眾智法　　王論三毘陀
  悉是諸如來　　定力持而說
  國王王臣等　　乃至山林處
  所有諸儀則　　皆從佛出生
  十方眾寶藏　　出生清淨寶
  悉是天中天　　自在威神故
  一切三界中　　有諸明智者
  種種方便業　　因佛而成就
  現從兜率降　　婇女眾圍繞
  歌舞共歡娛　　日夜常遊集
  或如堅利智　　舍陵波居士
  執世之直繩　　與奪而招放
  雖於一切處　　現為明智者
  而在密嚴中　　寂然無動作
  此大牟尼境　　凡愚異分別
  譬如翳目人　　亦猶眾渴獸
  如世觀於幻　　夢中諸所取
  天中天境界　　佛子見其真
  如是觀行人　　如從於睡覺
  那羅與伊舍　　梵天娑旦那
  難陀鳩摩羅　　劫比首迦等
  處定而思審　　於此常迷惑
  去來現在世　　一切諸牟尼
  習氣覆於心　　亦所不能見
  善哉金剛藏　　普行諸地中
  復以佛威神　　而居密嚴土
  是汝之境界　　我今為汝說
  或有妄分別　　勝性與微塵
  如工作諸物　　種種諸形相
  生唯是法生　　滅亦唯法滅
  妄計一切物　　細塵能造作
  因能了於果　　譬如燈照物
  先不得其相　　後壞亦復然
  非於過去中　　有體而可得
  未來亦如是　　離緣無有性
  一一諸緣內　　遍求無有體
  不見性有無　　亦無無有見
  於蘊瓶衣等　　微細而分別
  三百有六十　　邪宗壞正道
  往來生死中　　無有涅槃法

    大乘密嚴經妙身生品第二之一

爾時如實見菩薩。有大威力世中自在。其身妙好上服莊嚴。在於佛前避座而立。曲躬合掌一心恭敬。向金剛藏菩薩摩訶薩而作是言。尊者。善能通達自智之境現法樂住。於三乘世間心得無違。為大定師於定自在。能隨順說諸地之相。常在一切佛國土中。為諸上首演深妙法。是故我今勸請尊者。說諸聖人不隨他行。現法樂住內證之境。令我及餘諸菩薩眾得見斯法。安樂修行趣於佛地。獲意生身及言說身。力通自在皆得具足。轉所依止不住實際。如眾彩摩尼現諸色像。於一切佛國說密嚴行。金剛藏菩薩摩訶薩言。善哉仁主。能請我說入於密嚴無我之法。仁主。先應覺了諸分別境。是心之相於境界中捨諸分別。仁主。一切世間是分別見見世間體。即於所緣而得三昧。我今為汝開示彼法王。應善聽。即說偈言

  一切諸世間　　譬如熱時焰
  以諸不實相　　無而妄分別
  覺因所覺生　　所覺依能現
  離一則無二　　譬如光共影
  無心亦無境　　量及所量事
  但依於一心　　如是而分別
  能知所知法　　唯知心妄計
  若了所知無　　能知即非有
  心為法自性　　及人之所濁
  入於八地中　　而彼得清淨
  九地行禪定　　十地大開覺
  法水灌其頂　　而成世所尊
  法身無有盡　　是佛之境界
  究竟如虛空　　心識亦如是
  無盡亦無壞　　眾德以莊嚴
  恒住不思議　　密嚴諸佛土
  譬如瓶破已　　瓦因而顯現
  瓦破顯於塵　　塵析極微顯
  如是因有漏　　而成無漏法
  如火燒盡木　　復於餘處然
  味於不動智　　轉依離分別
  密嚴佛國中　　如是而常現
  不生眾品類　　莫住於世間
  捨於一切見　　歸依此無我
  斷諸相續流　　無生亦無壞
  盡於一切見　　歸依此無我
  諸患皆已息　　寂住不思議
  淨於一切見　　歸依此無我
  世間種種法　　本來無我性
  非由擊壞無　　及喻之所顯
  如火焚薪已　　自於是中滅
  觀察於三界　　無我智亦然
  是名現法樂　　聖人自智境
  依此入諸地　　淨除無始惡
  捨離世所依　　出世而安住
  其心轉清淨　　恒居密嚴土

爾時如實見菩薩及諸王眾俱作是言。金剛自在我等今者咸欲歸依。願示於我歸依之處。於是金剛藏菩薩摩訶薩。以偈答曰

  佛體非是有　　亦非無有佛
  蘊樹已焚燒　　魔軍咸退殄
  住於如來地　　密嚴之妙國
  所覺淨無垢　　仁主可歸依
  遠離諸分別　　證於無處所
  密嚴諸定者　　仁主可歸依
  密嚴勝淨剎　　眾聖之依處
  觀行者充滿　　應歸此嚴土

爾時金剛藏菩薩摩訶薩說是語已。復告如實見菩薩言。仁主。已得住地。諸觀行者觀一切世間。如繢像中而有高下。如夢所見端正女色。如石女人忽夢己身誕育於子。如乾闥婆城內諸所施為。如旋火成輪。如空中垂髮。如幻化所作人馬等形樹林花果。如浮雲之影。如奔電之光。皆是虛偽非真實有。分別所成猶工造器。仁主。世間眾生習氣覆心生種種戲論。意與意識及餘諸識。相續而轉五法三性。二種無我恒共相應。譬如瀑流為風所擊起諸波浪。浪起相尋而流不息。阿賴耶識在於世間亦復如是。無始習氣猶如瀑流。為境界風之所飄動。起諸識浪恒無斷絕。仁主。是八種心雖無如是若干體異。而隨緣漸起或一時生。心生之時取諸境界。亦有如是漸頓差別。若於屋宅及諸星宿。軍眾山林枝葉花果如是等處。多是一時或次第取。若在眠夢見昔所更。或想念初生至于老死。及算數眾物尋思句義。觀異文彩受好飲食。於是境界次第了知。或有一時頓取之者。仁主。心性本淨不可思議。是諸如來微妙之藏如金在礦。意從心生餘六亦然。如是多種於世法中而為差別。仁主。阿賴耶識。雖與能熏及諸心法。乃至一切染淨種子。而同止住性恒明潔。如來種姓應知亦然。定不定別體常清淨。如海常住波潮轉移。阿賴耶識亦復如是。諸地漸修下中上別。捨諸雜染而得明現。於是金剛藏菩薩摩訶薩。復說偈言

  善哉如實慧　　於斯微妙法
  從我已聽聞　　心淨能開了
  十方一切國　　諸王眾會中
  汝當隨所應　　廣為其宣說
  若人聞法已　　漸淨阿賴耶
  或作人中王　　轉輪四天下
  或復為帝釋　　兜率須夜摩
  乃至自在宮　　而為欲天主
  或為色界主　　及生無色天
  無想眾生中　　受諸禪定樂
  證真而不住　　譬如師子吼
  眾定皆自在　　喜樂以相應
  一心求密嚴　　不染著三界
  至於密嚴已　　漸次而開覺
  轉依獲安樂　　寂靜常安住
  無量諸佛子　　圍繞以莊嚴
  為法自在王　　眾中之最上
  非如外道說　　壞滅為涅槃
  壞應同有為　　死有復生過
  十業上中下　　三乘以出生
  最上生密嚴　　諸地轉增進
  得解脫智慧　　如來微妙身
  云何說涅槃　　是滅壞之法
  涅槃若滅壞　　眾生有終盡
  眾生若有終　　是亦有初際
  應有非生法　　而始作眾生
  無有非眾生　　而生眾生界
  眾生界既盡　　佛無爾焰法
  是則無能覺　　亦無有涅槃
  妄計解脫者　　而說於解脫
  譬如種已焦　　燈滅及薪盡
  彼說解脫性　　是壞有成無
  於解脫妙樂　　遠離不能證
  遍處及諸禪　　無色無想定
  逆順而入出　　力通皆自在
  於彼不退還　　亦不恒沈沒
  審知諸法相　　諸地得善巧
  如是而莊嚴　　而來密嚴國
  若言解脫性　　壞有以成無
  斯人住諸有　　畢竟不能出
  亦壞三和合　　因等四種緣
  眼色內外緣　　和合所生識
  世間內外法　　互力以相生
  如是等眾義　　一切皆違反
  若知唯識現　　離於心所得
  分別不現前　　亦不住其性
  是時攀緣離　　寂然心正受
  捨於世間中　　所取能取見
  轉依離麤重　　智慧不思議
  十種意生身　　眾妙為嚴好
  作三界之主　　而來密嚴國
  色心及心法　　不相應無為
  內外眾世間　　諦觀無別異
  如是諸智者　　來於密嚴國
  相名與分別　　正智及如如
  定者能明照　　體性皆平等
  入佛所讚揚　　密嚴之淨國
  若壞三和合　　及以四種緣
  不固於自宗　　同諸妄分別
  惡習分別者　　彼之五種論
  譬喻不成立　　諸義皆相違
  五種悉成過　　惑亂於智眼
  顛倒不顛倒　　同異法斯壞
  捨離於自宗　　依止他宗法
  初際等諸見　　皆從滅壞生
  大王應當知　　眾生在諸有
  如輪而運轉　　初際不可得
  如來以悲願　　普應諸有緣
  如淨月光明　　無處不周遍
  各順其根性　　隨宜而說法
  涅槃若壞滅　　佛有何功德
  增上有三種　　解脫亦復然
  四諦及神足　　念處無礙解
  四緣無色住　　根力及神通
  覺支諸地等　　有為無為法
  乃至眾聖人　　皆依識而有
  苦法苦觀智　　及苦隨生智
  集智三亦然　　滅道亦如是
  如是十二種　　名之為現觀
  學人數有十　　第八七返生
  家家一往來　　一間而滅度
  中般與生般　　有行及無行
  上流於處處　　然後般涅槃
  如是一切種　　諸智之品位
  修行觀行者　　下中上不同
  菩薩增上修　　功業最殊勝
  十一與十二　　乃至於十六
  此諸修定者　　復漸滅於心
  所盡非是心　　亦非心共住
  未來心未至　　未至故非有
  心緣不和合　　非此非彼生
  第四禪無心　　有因不能害
  有因謂諸識　　意識及五種
  妄想不自覺　　猶如波浪生
  定者觀賴耶　　離能所分別
  微妙無所有　　轉依而不壞
  在於密嚴中　　如月恒明顯
  密嚴諸智者　　與佛常共俱
  恒遊定境中　　一味無差別
  密嚴定者處　　定力生於彼
  是故應修習　　相應妙定心
  欲界有六天　　梵魔十二處
  無色及無想　　一切諸地中
  若生密嚴國　　於彼為天主
  欲求密嚴土　　當修十種智
  法智隨生智　　世俗知他心
  及苦集滅道　　盡智無生智
  仁者真實見　　舍君羅帝族
  與甘蔗月王　　種姓無殊異
  當求密嚴國　　勿懷疑退心
  如羊被牽拽　　喘懼而前卻
  意在於身中　　似幻獸而住
  亦如幻為樹　　河中之葦荻
  如王戲園苑　　運動諸身分
  意及於意識　　心心法共俱
  譬如空中雲　　共聚而無實
  種子賴耶識　　諸習所纏覆
  譬如摩尼寶　　隨緣現眾色
  離住眾生身　　體淨而無垢
  是決定種姓　　亦為大涅槃
  名因於相生　　相從因緣起
  以諸形相故　　而起於分別
  分別從二因　　外相心習氣
  第七末那識　　應知亦復然
  諸根意緣會　　發生於五識
  心法共相應　　如是身中住
  正智常觀察　　一切諸世間
  從於如是因　　而生彼諸果
  真如非異此　　諸法互相生
  與理相應心　　明了而觀見
  此即是諸法　　究竟真實性
  亦為妄所計　　一切法不生
  諸法性常空　　非無亦非有
  如幻及陽焰　　乾城等眾物
  種種諸形相　　名句及文身
  如是執著生　　成於遍計性
  根境意和合　　熏習成於種
  與心無別異　　諸識從此生
  資於互因力　　是謂依他起
  內證真實智　　現前所住法
  是即說圓成　　眾聖之境界
  佛及諸佛子　　證此名聖人
  若人證斯法　　即見於真際
  唱言生已盡　　梵行皆已立
  所作莫不成　　永離於諸有
  解脫一切苦　　滅除眾怖畏
  生法二無我　　善能明了知
  普燒諸習氣　　永斷於分別
  從於無始來　　戲論而積聚
  無量眾過惡　　一切皆已除
  譬如熱鐵團　　熱去鐵無損
  解脫者亦爾　　惑盡而清涼
  入於無漏界　　密嚴之妙土
  此土最微妙　　非餘所能及
  佛與諸菩薩　　清淨之所居
  三昧樂現前　　以此而為食
  欲生斯土者　　當修真實觀
  復為諸有緣　　如理廣宣說
  名生本於相　　相起復從緣
  種種諸分別　　皆因相而有
  根境瓶衣等　　蘊法所合成
  分別從此生　　了知而簡異
  若動若非動　　一切諸世間
  皆因癡暗生　　愚冥以為體
  長短等諸色　　音聲與香界
  甘苦堅滑等　　意識之所緣
  善與不善性　　有為無為法
  乃至於涅槃　　斯為智之境
  念念常遷轉　　皆依識以生
  譬如磁石力　　吸鐵令迴轉
  末那於藏識　　當知亦復然
  如蛇有二頭　　各別為其業
  染意亦如是　　執取阿賴耶
  能為我事業　　增益於我所
  復與意識俱　　為依而轉謝
  身中煖觸生　　運動作諸業
  飲食及衣服　　隨事而受用
  騰躍或歌舞　　種種自歡娛
  持諸眾生身　　斯由意功力
  於如夢翳等　　一切諸境界
  起種種分別　　不知唯自心
  如人在空中　　走索以遊戲
  飄危不安固　　分別亦如是
  分別無所依　　但行於自境
  譬如鏡中像　　識種種而見
  愚夫此迷惑　　非諸明智者
  仁主應當知　　此三皆識現
  於斯遠離處　　是即名真實
  持進菩薩等　　及聖目乾連
  遍觀諸億剎　　種種皆嚴好
  於彼莊嚴中　　此土最殊勝
  極樂及現喜　　乃至於下方
  無量億土中　　諸佛所稱讚
  皆言密嚴國　　威德化自然
  無始亦無終　　本昔如來地
  出過於三有　　寂靜無所為
  自利及利他　　功業悉成滿
  非不此成佛　　欲中施佛事
  要從於密嚴　　化為無量億
  常依於正定　　遊戲諸神通
  一切國土中　　如月無不見
  隨諸眾生類　　所應而化益
  十地花嚴等　　大樹與神通
  勝鬘及餘經　　皆從此經出
  此經最殊勝　　眾經莫能比
  仁主及諸王　　宜應盡尊敬
  欲色無色界　　無想等天宮
  佛已超過彼　　而依密嚴住
  此土諸宮殿　　如蓮備眾飾
  是一切如來　　淨智之妙相
  佛及諸菩薩　　常在於是中
  世尊恒住禪　　寂靜最無上
  依自難思定　　現於眾妙色
  色相無有邊　　非餘所能見
  極樂莊嚴國　　世尊無量壽
  諸修觀行者　　色相皆亦然
  或見天中天　　赫奕含眾彩
  訶利占波色　　真金明月光
  孔雀素羅瞿　　珊瑚蓮電等
  或見身羸瘦　　弊服寢茅中
  或如千日光　　處大蓮花上
  或見諸菩薩　　頂飾龍王髻
  或以帝青寶　　莊嚴為寶冠
  或見輪幢文　　魚螺等眾相
  或見光麗色　　如蜺而拖空
  或見以須彌　　置之於右掌
  或持大海水　　其狀如牛迹
  或見作人王　　冕服當軒宇
  輔佐眾圍繞　　共宣於國化
  或見諸菩薩　　最上修行者
  說於自境界　　先佛所知法
  或說以智定　　速轉於所依
  得如幻之身　　種種皆無礙
  或示了於境　　斷諸取著業
  諸見皆已除　　不受於諸有
  譬如膏炷盡　　燈滅而涅槃
  或有示修行　　一切波羅蜜
  衍那之大會　　周給無窮盡
  苦行持戒等　　種種諸儀則
  極樂莊嚴國　　人非胎藏生
  身相如真金　　光色常圓滿
  瑜伽自在者　　安樂及光明
  斯人之境界　　百分無其一
  極樂中之人　　自然隨念食
  牟尼勝自在　　定為甘露味
  寶樹名如意　　遊憩於其下
  妙金為碎末　　布地以莊嚴
  地蓮及眾花　　數榮而菡萏
  如是具嚴飾　　不可得為喻
  若人有淨信　　善巧行諸禪
  愛樂佛功德　　專精以迴向
  即於佛勝土　　蓮華而化生
  眾相以莊嚴　　皎鏡無塵垢

爾時金剛藏菩薩摩訶薩。說是偈已自現其身如一指節。或如芥子乃至毫端百分之一。或現佛身或現獨覺身或現聲聞身。及餘無量種種之形而說於法。或說菩薩入於諸地。了知五法八識三性及二無我。得如幻三昧隨意受身。自在神通力無所畏。皆不退轉淨所依止。入於佛地無漏蘊界常無變易。或說菩薩善能遊履。如夢如像如水中月。諸觀行人所行之道。得首楞嚴三昧十幻喻身。諸究竟願莫不成滿。逮于正覺坐妙蓮花。諸佛子眾所共圍遶。或說菩薩以願力故。現種種形遊諸國土歷事諸佛。是諸菩薩其身微妙不在有無。譬如天仙乾闥婆眾。依須彌住或在虛空。地行眾生所不能睹。彼諸菩薩亦復如是。非觀行者不能得見。或說菩薩得禪自在三昧力故。於十方國土蓮花之宮。示現受生及般涅槃。或說菩薩以三昧力。轉於所依而不住實際。於一切有眾生處差別現身。其心平等如地如水如日如月。或說菩薩以大悲心。愍諸眾生輪轉生死孤窮下賤眾苦所逼。譬如黑蜂依船而住遊於大海。隨船飄蕩或一由旬乃至百千無量由旬。為說非我生死無常。令知速滅剎那不住。或說諸佛及諸菩薩。見一切眾生渴愛迷亂。為分別苦之所逼迫。於無相法中而取於相。虛妄計著有能所取。是能所取縲絏其心。於生死海馳蕩不息。貧窮孤露無有所依。如大海中蛛蝥之網。佛及菩薩猶住船人。於諸眾生心生憐愍。欲令解脫生死苦難。隨其所應而為現身。說布施等種種諸行

大乘密嚴經卷上
大乘密嚴經卷中

        唐天竺三藏地婆訶羅奉　制譯

    妙身生品第二之餘

爾時普賢眾色大光菩薩摩訶薩。與諸同類持世菩薩。持進菩薩。文殊師利菩薩。神通王菩薩。得大勢菩薩。聖者月菩薩。金剛齊菩薩。大樹王菩薩。虛空藏菩薩等。乃至摩尼寶殿無量諸天。密嚴土中諸佛子眾。并餘佛國來聽法者。聞說密嚴微妙功德於法尊重。決定轉依恒居此土不生餘處。然皆愍念未來眾生。普欲為其而作利益遂共同心。白金剛藏菩薩摩訶薩言。尊者願為我說。一切世間若干色像誰之所作。如陶工埏埴而造瓶等世間眾像。為如是作為不然耶。又如伶人擊動絲竹匏木之類繁會成音。一切世間豈亦如是。如隨一物有三自性。世間眾物已成體相。若未成者。此豈咸在一物中乎。為夜摩天兜率陀天他化自在及以大樹緊那羅作。為是善現色究竟天螺髻梵王無色天作。為是一切諸天主等同心戮力而共作耶。為是此方及他方中諸佛菩薩以變化力。作是一切世間眾像。而於此中起諸迷惑。是迷惑見如陽焰水。譬如瓶處為德所依。一切世間住於處者。非諸德者繫屬於德。亦非是德依於德者。展轉合故眾德集成。如是世間若干色像。為唯惑亂為有住耶。或有言是大梵天王那羅延天自在天作。或謂力沙迦拏提那劫比羅仙自力而作。或有妄執從於勝性自然及時。無明愛業而得生起。諸天仙等及餘一切修世定人悉懷疑惑。為無有體如幻如夢。如熱時焰如乾闥婆城。無始分別有能所取。如蛇二首如起屍行。亦如木人因機動轉。空中垂髮旋火輪耶。爾時金剛藏菩薩摩訶薩。以偈答曰

  世間眾色像　　不從能作生
  非是矩鞞羅　　因陀羅等作
  亦非大施會　　祠祭之福果
  毘陀所說因　　互違無定義
  亦復非無有　　能持世間因
  所謂阿賴耶　　第八丈夫識
  運動於一切　　如輪轉眾瓶
  如油遍在麻　　鹽中有鹹味
  亦如無常性　　普遍於諸色
  沈麝等有香　　日月光亦爾
  非能作所作　　非有亦非無
  遠離諸外道　　一異等眾見
  非智所尋求　　不可得分別
  定心無礙者　　內智之所證
  若離阿賴耶　　即無有餘識
  譬如海波浪　　與海雖不異
  海靜波去來　　亦不可言一
  譬如修定者　　內定清淨心
  神通自在人　　所有諸通慧
  觀行者能見　　非餘之所了
  藏識亦如是　　與轉識同行
  佛及諸佛子　　定者常觀見
  藏識持於世　　猶如線貫珠
  亦如車有輪　　隨於業風轉
  陶師運輪杖　　器成隨所用
  藏識與諸界　　共力無不成
  內外諸世間　　彌綸悉周遍
  譬如眾星象　　布列在虛空
  風力之所持　　運行常不息
  如空中鳥迹　　求之不可見
  然鳥不離空　　頡頏而進退
  藏識亦如是　　不離自他身
  如海起波濤　　如空含萬象
  藏識亦如是　　蘊藏諸習氣
  譬如水中月　　及以諸蓮花
  與水不相離　　不為水所著
  藏識亦復然　　習氣莫能染
  如目有童子　　眼終不自見
  藏識住於身　　攝藏諸種子
  遍持壽煖識　　如雲覆世間
  業用曾不停　　眾生莫能見
  世間妄分別　　見牛等有角
  不了角非有　　因言兔角無
  分析至微塵　　求角無所有
  要待於有法　　而起於無見
  有法本自無　　無見何所待
  若有若無法　　展轉互相因
  有無二法中　　不應起分別
  若離於所覺　　能覺即不生
  譬如旋火輪　　翳幻等眾事
  皆因少所見　　而生是諸覺
  若離於所因　　此覺即無有
  名相互相繫　　習氣無有邊
  一切諸分別　　與意而俱起
  證於真實境　　習氣心不生
  從於無始來　　沈迷諸妄境
  戲論而熏習　　生於種種心
  能取及所取　　眾生心自性
  瓶衣等諸相　　離心無所有
  一切唯有覺　　所覺義皆無
  能覺所覺性　　自然如是轉
  習氣擾濁心　　凡愚不能見
  如海風所擊　　波浪無停止
  心為境風動　　識浪生亦然
  種種諸分別　　自內而執取
  如地無分別　　庶物依以生
  藏識亦復然　　眾境之依處
  如人以己手　　還自摩握身
  亦如象以鼻　　取水自霑沐
  復似諸嬰兒　　以口含其指
  如是自心內　　現境還自緣
  是心之境界　　普遍於三有
  久修觀行者　　而能善通達
  內外諸世間　　一切唯心現

爾時金剛藏菩薩摩訶薩。說此語竟默然而坐。住無處所微妙之禪。遊法界門入諸佛境。見有無量佛子當來此國住修行地。便從定起放大光明。其光普照欲色無色無想天宮。是光明中復現無量殊勝佛土。有無量佛相好莊嚴。隨諸世間之所欲樂而為利益。皆使受持密嚴名號。彼諸佛子互相觀察而作是言。密嚴佛土能淨眾福滅一切罪。諸觀行人所住之處。於諸佛國最上無比。我等聞名心咸悅樂可共俱往。時諸佛子各從所住而來此國。爾時淨居諸天與阿迦尼吒螺髻梵王同會一處。咸於此土佛及菩薩生希有心請梵王言。天主。我等今者咸興是念。何時當得陪侍天王詣密嚴土。爾時梵王聞是語已。與諸天眾遽即同行。中路遲迴罔知所適。梵王先悟作是思惟。密嚴佛國觀行之境。若非其人何階可至。非是欲色無色諸天及外道神通所能往詣。我今云何而來至此。復自念言。或天中天。假吾威力而能亟往。作是念已發聲歸命。即時見有無量諸佛在於道中威光照曜。時螺髻梵王即白佛言。世尊。我等今者當何所作。而能速詣密嚴佛土。佛告之言。汝可退還。所以者何。密嚴佛國觀行之境。得正定人之所住處。於諸佛剎最勝無比。非有色者所能往詣。時螺髻梵王聞佛語已。與諸天眾尋還天宮。爾時淨居諸天共相議言。螺髻梵王。有大威力而不能往。當知此土最為殊勝。但是得如幻三昧。諸觀行人所行之境。如是稱揚密嚴功德。其聲展轉靡不傳聞。爾時諸佛子眾來此會者。聞是語已益加欣敬。白金剛藏菩薩摩訶薩言。我等於法深懷渴慕。惟願大明為我宣說。金剛藏言。佛所說法誰能具演。唯除如來之所護念。夫如來者於觀行中最勝自在。所有境界不可思議。云何可為非觀行人開示演說。時持進菩薩及須夜摩諸佛子等。復共同聲請言速說。爾時神通王菩薩。文殊師利菩薩。慈氏菩薩。緊那羅菩薩。及餘無量諸菩薩眾。復作是言。善哉仁者。願速為說。是時復有無量諸天。於虛空中作天妓樂同心勸請。當爾之時螺髻梵王。承佛威力而來此會向金剛藏菩薩摩訶薩。而說偈言

  今此諸大會　　嚴飾未曾有
  悉是尊弟子　　聰慧無等倫
  皆於尊者處　　渴仰而求法
  我今猶未知　　所問為何等
  為問憍羅婆　　勝墮及頂生
  乃至盛年馬　　轉輪王所作
  為問甘蔗種　　千弓持國王
  欲色無色中　　人天等之法
  為問菩薩行　　獨覺及聲聞
  乃至阿修羅　　星象等眾論
  惟願如其事　　次第而演說
  我等及天人　　一心咸聽受

爾時金剛藏菩薩摩訶薩告諸大眾。汝豈不聞螺髻梵王淨居天眾。及諸佛子勤心請法。爾時解脫月菩薩。無盡慧菩薩。虛空王菩薩。持世菩薩。得大勢菩薩。觀自在菩薩。陀羅尼自在菩薩。寶髻菩薩。天冠菩薩。金剛手菩薩。寂靜慧菩薩。寶手菩薩。及餘無量諸億土中俱來佛子。咸共瞻仰金剛藏尊。而說偈言

  過去及未來　　如來清淨智
  尊於佛親受　　明了心不疑
  此眾皆樂聞　　願尊時演說

爾時金剛藏三昧王。普觀大眾。以偈答曰

  如來所說法　　非我具能演
  唯除佛菩薩　　威神之所護
  我今至心禮　　自在清淨宮
  摩尼寶藏殿　　佛及諸佛子
  我以敬心說　　如來清淨智
  紹隆佛種姓　　汝等應聽受
  非說過去等　　最勝諸王法
  但示於密嚴　　如來之種姓
  佛智甚微妙　　牟尼勝功德
  正觀之所行　　離諸心妄計
  是故非我力　　能演此甚深
  但以佛威神　　從佛而聽受
  此智最微妙　　是諸三昧花
  佛在密嚴中　　正受而開演
  遠離諸言說　　及以一切見
  若有若無等　　如是四種邊
  是名最清淨　　中道之妙理
  密嚴諸定者　　於此能觀察
  離著而轉依　　速入如來地

爾時會中諸佛子眾。聞金剛藏菩薩摩訶薩說是語已。稽首恭敬而白之言。我等於法深生愛樂。如渴思漿如蜂念蜜。今此會中諸佛子眾。於深定智皆得自在有大神力王諸世界。願聞如來所說之法。唯願尊者以梵音聲因陀羅聲。及以如來眾所悅可深遠之音。演殊勝義令得顯了。金剛藏菩薩言。如來所說語義真實希有難見。譬如空中無樹等物而見其影甚為希有。如來所說希有亦然。如空中風及以鳥迹無能見者。牟尼所說種種義趣。難可得見亦復如是。世間之法有智慧者。能以譬喻分明顯說。佛口所宣過諸譬喻非言所及。我之所見譬如夢境乾闥婆城。今此會中諸觀行者有大智慧。於真實義已得明了。我今云何能為是人。說不思議諸佛境界。雖然當承如來威神之力為眾宣述。汝諸佛子咸應諦聽。如來所說文義相應。出過心意非喻所及。譬如妙花眾蜂競採。先至之者取其精粹。後來至者但味其餘。如是如來得法精粹。我味其餘為眾說耳。即說偈言

  天中天境界　　增悅諸明智
  非心口所能　　度量分別說
  為欲普降伏　　世間憍慢心
  云同人之形　　佛相為嚴飾
  圓光及足輪　　種種皆成就
  遊處諸宮殿　　人天具所瞻
  如來四時中　　常依密嚴住
  而於諸世界　　現生及涅槃
  淳善少減時　　惡生及濁亂
  隨諸眾生類　　所應而利益
  業用無暫停　　密嚴恒不動
  密嚴無垢處　　觀行者所依
  惡生濁亂時　　顯示如來相
  譬如淨滿月　　影遍於眾水
  如是諸色像　　普現於世間
  如來淨智境　　智者所觀見
  以諸眾生類　　所樂各不同
  佛以種種身　　隨宜而應化
  或見大自在　　或見毘紐天
  或見迦毘羅　　住空而說法
  或見毘陀者　　或復見常行
  或見娑旦那　　鳩摩及尸棄
  羅睺熟部等　　乃至緊那羅
  甘蔗月種王　　一切所瞻奉
  金剛等眾寶　　乃至於鉛錫
  皆由佛威力　　隨應而出生
  天女及龍女　　乾闥婆之女
  治容而進趣　　不能惑其心
  欲界中諸境　　如來已降伏
  色無色亦然　　無有能迷動
  無想諸定者　　未離於惑纏
  非安非清淨　　退墮而流轉
  有身者所生　　非如密嚴國
  密嚴微妙土　　清淨福為嚴
  解脫知見人　　最勝之依處
  十種大自在　　力通三昧法
  如佛而嚴飾　　意生之妙身
  修行於十地　　施等波羅蜜
  眾相以莊嚴　　其身甚清淨
  遠離於分別　　亦非無覺了
  無有我意根　　慧根常悅樂
  施等諸功德　　淨業悉圓滿
  得佛勝所依　　密嚴之淨國
  此土最微妙　　不以日為明
  諸佛及菩薩　　舒光而普照
  其光甚威曜　　逾於百千日
  無有晝夜時　　亦無老死患
  密嚴最勝處　　諸天所希仰
  最上修行者　　地地而進修
  了知一切法　　皆以心為性
  善說阿賴耶　　三性法無我
  其身轉清淨　　而來生此國

    大乘密嚴經胎生品第三

爾時金剛藏菩薩摩訶薩。復告螺髻梵天王言。天主當知。眾生之身九物為性。有為眾相恒共遷動。大種諸色微塵之聚。以諸不淨精血合成。為無量業常所纏覆。譬如毒樹扶疏蓊鬱。貪恚及癡而共增長。經於九月或十月餘。業力驅馳生機運動。從於產門倒首而出。煩冤逼迫受無量苦。天主。此諸眾生或從人中。或從畜生餓鬼羅剎阿修羅等而來生此。或有曾作轉輪之王。乃至天中威力自在。或是持咒外道仙人并其眷屬。或修禪者退失禪定。從如是等處而生此中。既生之已諸根長大。隨所親近宿習因緣而造諸業。復因此業輪迴諸趣。若有智者遇善知識聞法思惟而得解悟。不著文字離諸分別。入三脫門見法真理。最上清淨最上上清淨。而來住此密嚴佛國。於無量億諸佛土中隨宜應現。天主。如是生者永得解脫生死險趣。名為丈夫名為智者。亦復說名天中之天。諸佛子眾所共圍繞。天主。胎藏之身虛偽不實。非自性生亦非無明愛業所生。何以故。無明愛業因相而有。若能了達悉滅無餘。亦無名字及以分別。斯人即生密嚴佛土。天主。若諸定者住於三昧。心有攀緣即為色聲之所誑惑。而生取著不能堅固。此即名為散動之道。是三昧力生於欲界及色無色。乃至無想眾生之處。是人即為三昧所縛。若住三昧善調其心離能所取。離二取已心即不生。是名真實觀行之者。若欲生於密嚴佛國。常當住此真實三昧

    大乘密嚴經顯示自作品第四

爾時金剛藏菩薩摩訶薩。復告螺髻梵天王言。天主。心有八種或復有九。與無明俱為世間因。世間悉是心心法現。是心心法及以諸根。生滅流轉為無明等之所變異。其根本心堅固不動。天主。世間因緣有十二分。若根若境能生所生剎那壞滅。從於梵世至非非想皆因緣起。唯有如來離諸因緣。天主。內外世間動不動法。皆如瓶等壞滅為性。天主。諸識微細遷流速疾。是佛境界非諸世間仙人外道所能知見。眾仙外道為愛所纏。不能了知心相差別。天主。假使有人勉意勤行。歌讚祠祀毘陀之法而祭於天。經於一月或滿四月。如是一歲至于千歲。生於梵境終亦退還。天主。汝不知耶。三毘陀行所得之果。譬如芭蕉性不堅固。天主。密嚴佛土是諸如來解脫之處從智定得。若樂解脫應善修行。天主。密嚴中人無有眷屬生死之患。其心不為諸業習氣之所染著。如蓮花出水。如虛空無塵。如日月高昇淨無雲翳。一切諸佛恒共攝受。沐淨戒流飲智慧液。得真實解度生死岸。天主。眾生身中諸界五蘊識等眾法。皆無所有。眼色為緣而生於識。譬如因木火得熾然。天主。一切境界隨妄識轉。如鐵動移逐於磁石。又如陽焰乾闥婆城。是諸渴鹿愚幻所取。此中無有能造等物。但是凡夫心之變異。天主。如乾城之中人眾往來馳騖所作見而非實。眾生之身進止云為亦復如是。如夢中所見寤即非有。世間之人見蘊等法。覺心明照本來寂靜。天主。地等和合微塵之聚。若離於心即無所得。世間諸物可持舉等。孰非大種之所合成。譬如風痰病緣惑亂見種種物。又如起屍無能作者。世間諸法悉亦如是。汝諸佛子應勤觀察。天主。一切世間動植之物。譬如水沫共聚成形。瓶衣等想同於陽焰。苦樂諸受猶如浮泡。行如芭蕉中無有堅。識如幻事虛偽不實。天主。三界之中動不動法。同於夢境迷心所現。亦如幻事乾闥婆城但誑愚夫。若諸佛子於如是法。能正覺知心無所畏。以智慧火焚燒一切。諸患因緣。即生妙樂密嚴之土。天主。一切世間皆無有相。相為繫縛無相即解。相是心境心境不實。真實之法是智境界。遠離眾相非心所行。天主。一切諸相是三界法。色聲等法名之為相。諸根境界一切眾生繫縛之因。若能於相而不貪著。眾縛悉除安樂自在

爾時寶髻菩薩摩訶薩。在大眾中坐殊妙座。向金剛藏菩薩摩訶薩而作是言。尊者。於諸億佛國菩薩眾中最為上首。成最上智了所知法。無量悉檀皆已明見。在瑜祇眾能淨彼疑。善知眾生身之本起。能於一劫或一劫餘。以妙音詞演而不倦。何故不為諸仁等說。離諸逆順似非似因。真實之法令諸智者心淨無疑。捨蘊因緣疾得解脫。法與非法是蘊因緣。生於此身及後身故。智能脫苦愛為堅縛。尊者。眾生之心因色與明。作意等緣馳散於境。其心速疾難可覺知。無明愛業以之濁亂。尊者。眾生身中種種諸法。意為先導意最速疾意為殊勝。隨所有法與意相應。彼法皆以意為其性。如摩尼珠顯現眾彩。如是之義仁何不說。又如眾色摩尼之寶。隨所相應種種明現。仁亦如是。具如來像住自在宮。諸佛子眾所共圍繞。亦應如是隨宜說法

爾時金剛藏菩薩摩訶薩言。密嚴佛土是最寂靜是大涅槃。是妙解脫是淨法界。亦是智慧及以神通。諸觀行者所止之處。本來常住不壞不滅。水不能濡風不能燥。非如瓶等勤力所成尋復破壞。非諸似因及不似因之所成立。何以故。宗及諸分是不定法。諸宗及因各差別故。密嚴佛土。是轉依識超分別心。非諸妄情所行之境。密嚴佛土是如來處。無始無終非微塵生。非自性生非樂欲生。不從摩醯首羅而生。亦非無明愛業所生。但是無功用智之所生起。出過欲界及色無色無想天中闇冥之網。密嚴佛土阿若悉檀。非因明者所量境界。亦非勝性自在聲論毘陀如是等宗之所顯示。乃至於資糧位智慧之力不能照了。唯是如來十地所修清淨智境。諸仁者。一切凡夫迷於世間為業非業。我今當說業非業義。令諸定者獲於安樂。即說偈言

  內外一切物　　所見唯自心
  眾生心二性　　能取及所取
  心體有二門　　即心見眾物
  凡夫性迷惑　　於自不能了
  所見眾境界　　皆是自所為
  瓶等相現前　　求之悉無體
  諸仙智微劣　　不能明了知
  捨於真實理　　而行分別路
  是心有二性　　如鏡含眾像
  亦如水現月　　翳者見毛輪
  毛輪瓔珞珠　　此皆無所有
  但從病翳眼　　若斯而顯現
  瓶衣皆自識　　眾生亦復然
  虛妄計著人　　不知恒執取
  眾生及瓶等　　種種諸形相
  內外雖不同　　一切從心起
  此密嚴妙定　　非餘之所有
  若有能修行　　生於眾福地
  或生欲自在　　及以色界天
  乃至無想宮　　阿迦尼吒處
  空識無所有　　非想非非想
  如是諸地中　　漸次除貪欲
  住彼非究竟　　尋來生密嚴
  佛子眾圍遶　　自在而遊戲
  汝應修此定　　何為著親屬
  眷屬相羈縛　　輪迴生死因
  男女相耽愛　　精血共和合
  如蟲生臭泥　　此中生亦爾
  九月或十月　　諸根漸成就
  時至出母胎　　譬如蟲蠕動
  從此而長大　　乃至心了知
  我觀諸眾生　　生生悉如此
  父母無有數　　妻子亦復然
  一切諸世間　　無處不周遍
  譬如石女人　　夢已忽生子
  捧對方歡樂　　尋又見其亡
  悲哀不自勝　　忽然從睡覺
  不見有其子　　初生及後終
  又夢山川中　　田野村城邑
  人眾悉充滿　　共營諸業務
  彼此互相見　　猶如世所為
  及從於睡覺　　一切皆非有
  復有多欲人　　夢瞻於女色
  姿容極姝麗　　服玩皆珍綺
  在夢極歡娛　　覺已即無見
  一切世間事　　當知悉如是
  王位及軍旅　　父母等宗親
  但誑於凡夫　　體性皆非實
  汝於如是定　　何故不勤修
  無量諸聲聞　　獨覺及菩薩
  在於空閑處　　山林恒寂靜
  或住於乳海　　及以摩羅延
  須彌與臏陀　　摩醯因陀羅
  雞羅婆利師　　乃至雪山等
  或在劫波樹　　波利耶多羅
  拘鞞羅樹下　　半柱婆羅上
  食閻浮果味　　及諸不死食
  具足諸神通　　而常修此觀
  過去未來世　　常坐於蓮花
  結跏身不動　　正定恒觀察
  諸根善調攝　　不散於眾境
  譬如象得鉤　　離欲而三昧
  世間若出世　　一切諸定中
  佛定淨無垢　　貪愛皆除遣
  遍處無色定　　無想等禪中
  見日月蓮花　　水火虛空相
  若離是分別　　其心不動搖
  即於三昧中　　見無量諸佛
  一時共舒手　　以水灌其頂
  如是入佛地　　一切皆明覺
  具足眾色身　　隨宜而普現
  力通諸自在　　三昧陀羅尼
  如是等功德　　莫不皆成就
  分析於諸色　　乃至觀微塵
  自性無所有　　譬如彪兔角
  無分無分者　　蘊有蘊亦然
  同於幻所作　　一切皆如是
  此中無業果　　亦無作業人
  無能作世間　　設有非能作
  能作待於作　　何名能作人
  此言成過失　　說者非清淨
  若謂云何有　　水輪與地輪
  及眾生世間　　次第而安布
  諸趣各差別　　彼此互往來
  誰復作諸根　　隨情取於境
  此等皆分別　　展轉而變異
  同於乳酪酥　　如是生住滅
  若業若非業　　於斯生妄計
  定者常觀此　　如夢與乾城
  眾生無始來　　戲論所熏習
  生起於分別　　種種眾過咎
  諸根猶如幻　　境界同於夢
  能作作及業　　定者不分別
  智慧微劣者　　妄生諸惡見
  計有於能作　　作一切世間
  或謂摩尼珠　　金銀等眾礦
  鳥獸色差別　　刺端纖以利
  此等誰所為　　當知無作者
  世間非勝性　　微塵等緣作
  亦非無有因　　自然而得有
  惑心妄計者　　不知其體性
  為業為非業　　如是而分別
  如毒入於乳　　隨變與相應
  諸法亦復然　　分別常俱起
  法性非是生　　亦非是滅壞
  惑者不能了　　種種異分別
  定者應觀察　　世間唯積聚
  若業若非業　　於此勿思惟
  諸趣互來往　　譬如於日月
  在空無所依　　隨風而運轉
  業性甚微隱　　密嚴者能見
  修行觀行人　　不為其所縛
  譬如火燒木　　須臾作灰燼
  智火焚業薪　　當知亦如是
  又如燈破闇　　一念盡無餘
  諸業之闇冥　　多劫所熏聚
  牟尼智燈照　　剎那悉除滅

    大乘密嚴經分別觀行品第五

爾時金剛藏菩薩摩訶薩復告大眾。諸仁者。譬如有人在空閑地。以泥瓦草木葺之成宇。既而諦觀一一物中無舍可得。又如多指共合成拳。離指求拳即無所有。軍徒車乘城邑山林。瓶衣等物一切皆是和合所成。智者觀之悉如夢事。凡夫身宅亦復如是。諸界積集。譬如高山危脆不安同於朽屋。不生不滅非自非他。如乾闥婆城。如影如雲如陽焰如繢像。雖可現睹性常清淨。遠離一切有無分別。如盲與跛相假而行無決定性。乃至分析至於微塵。但有空名都無實物。若諸定者作是思惟。即於色聲等法不生覺念。離覺念已心得休息。泰然解脫不受諸有。常樂修行甚深禪定。諸天仙等端正女人而來供養。如觀夢事不生染著。身雖在此。諸仙外道持咒之人。乃至梵天不能見頂。是人不久生摩尼寶藏宮殿之中。遊戲神通具諸功德。此觀行法是大心者所行境界。仁應速發廣大之心。大心之人疾得生於光明宮殿。離諸貪欲瞋恚愚癡。乃至當詣密嚴佛土。此土廣博微妙寂靜。無諸老死衰惱之患。遠離眾相非識所行。妄計之人所不能得。諸仁者。此土清淨觀行所居。若懷希仰當勤修習。斷貪瞋癡離我我所。何以故。貪等煩惱取諸境界。若取於境即三覺生。如有女人端正可喜。有多欲者見已生著欲心迷亂。若行若坐飲食睡眠。專想思惟更無餘念。彼女容相常現於心。此心即為境界淤泥之所濁亂。是故於境不應貪著。諸仁者。譬如有人見牛鹿山羊有角之獸。即於彪兔生無角解。若使不見牛等有角。於彪兔等決定不生無角之見。世間妄見悉亦如是。妄有所得起有分別。後求其體不可得故。便言諸法決定是無。乃至未離分別之心。常生如是不平等覺。諸仁者。應以智慧審諦觀察。心之所行一切境界。皆如妄計見牛兔等。若諸佛子作如是觀。隨其意樂或生人中為轉輪王。有大威力騰空來往。或生日月星宿之宮。四天王天三十三天。夜摩天兜率陀天。乃至自在天主摩尼藏殿。或生色界梵身等天。修行定者十梵之處。無煩無熱善見善現阿迦尼吒。空處識處無所有處非想非非想處。住於彼已漸除貪欲。從此而生清淨佛土。常遊妙定至真解脫。爾時金剛藏菩薩摩訶薩。復說偈言

  如因瓶破　　而成於瓦　　剎那各別
  恒是無常　　因種生芽　　芽生種壞
  又如陶匠　　以泥作瓶　　泥是奢摩
  瓶如其色　　若復兼用　　餘色泥作
  火燒熟已　　各雜色生　　箭竹生蔥
  角生於蒜　　不淨之處　　蠅生於蟲
  世間之中　　有果似因　　或有諸物
  不似因者　　皆因變壞　　而有果生
  微塵等因　　體不變壞　　不應妄作
  如是分別　　無能作我　　內我勝我
  亦無我意　　境界諸根　　和合為因
  而生於識　　智者方便　　善知眾境
  破煩惱等　　一切諸魔　　世有貪愛
  如淡得蜜　　貪愛若除　　眾縛悉解
  如蛇螫物　　瞋毒亦然　　生死趣中
  多所惱害　　諸仁若欲　　令彼除盡
  宜各勤心　　修於觀行

    大乘密嚴經阿賴耶建立品第六

爾時金剛藏菩薩摩訶薩復告眾言。諸仁者。我念昔曾蒙佛與力而得妙定。廓然明見十方國土修世定人。及佛菩薩所住之處。於如是處中密嚴佛土安樂第一。諸佛菩薩數如微塵處蓮華藏。我於爾時一心瞻仰。尋從定出即自見身。與諸菩薩在密嚴土。復於爾時見解脫藏住在宮中。其量大小如一指節。色相明潔如阿怛斯花。亦如空中清淨滿月。我時見已便生念言。此為是誰。而有如是不思議事。作是念時。即見我身在其身內。於中普見一切世間。爾時蓮花藏中無量菩薩。以佛神力亦如是見咸生是念。此為希有不可思議。時天中天所為事畢還攝神力。諸菩薩等悉復如故。我時見此希有事已。知諸菩薩種種變現。是佛境界不可思議諸仁者。如來昔為菩薩之時。從初歡喜至法雲地。得陀羅尼句義無盡。及首楞嚴等諸大三昧。意生之身八種自在。如應而現遊戲神通名稱光明。如是等一切功德悉已成就。轉復清淨逮成正覺。住密嚴土隨宜變化。佛及菩薩種種色像。自然周遍一切世間轉妙法輪。令諸眾生速滅癡闇修行善法。或有菩薩見佛身相尸利婆蹉等。具足莊嚴自然光明猶如盛火。與諸菩薩住如蓮華清淨之宮。常遊妙定以為安樂。或見大樹緊那羅王。現百千億種種變化。如月光明遍諸國土。或見無量佛子。智慧善巧眾相莊嚴。頂飾寶冠身佩瓔珞。住兜率陀等諸天之宮。或見普賢有大威力。得一切智無礙辯才。身相光明獨無倫比。所居宮殿如淨滿月。雖住密嚴正定之海。而現眾色像靡不周遍。一切賢聖所共稱譽。無量天仙乾闥婆等。國王王子并其眷屬圍繞侍衛。或復見有觀行之師。諸佛子眾所共圍繞。住禪寂靜猶如睡眠。而離惛沈懈怠等過。悉曾侍奉無量諸佛。或復有見為大導師。降神誕生出家苦行。一心正定乃至涅槃。於虛空中行住坐臥現諸神變。令閻浮提至色究竟。諸天人等莫不瞻仰。諸仁者。諸佛體性唯佛所知。佛之智慧最上無比。如釋迦牟尼人中師子之所已得。汝諸佛子咸當得之。是故仁等應生淨信。信為佛體必當解脫。斯人或作轉輪聖王及諸小王。乃至或生梵天等宮而為天主。是諸佛子轉復精進。於蓮花藏清淨佛土。與諸菩薩蓮花化生。入一乘道離貪等習。乃至降伏欲界天魔。夫精進者志無怯弱。光隆佛家王諸國土。諸仁者。若欲作佛當淨佛種性。淨種性已必為如來之所授記成無上覺。利益一切諸修行者。譬如大地與諸眾生而作所依。又如良醫善調眾藥。周行城邑普心救療。佛亦如是。平等教化心無分別。設有眾生割截肌膚心亦不動。諸仁者。內外境界心之所行。皆唯是識惑亂而見。此中無我亦無我所。能害所害害及害具。一切皆是意識境界。依阿賴耶如是分別。譬如有人置珠日中。或因鑽燧而生於火。此火非是珠燧所生亦非人作。心意識亦復如是。根境作意和合而生。此性非如陽焰夢幻迷惑所取。亦不同於龜蛙之毛及以兔角。如霹靂火。為從水生為從電生為雷生耶。無能定知此所從生。如見陶師造於瓶等。欲等心法與心共生。亦復如是。諸仁者。心之體性不可思議。密嚴中人善能知見。諸仁者。一切眾生阿賴耶識。本來而有圓滿清淨。出過於世同於涅槃。譬如明月現眾國土。世間之人見有虧盈。而月體性未嘗增減。藏識亦爾。普現一切眾生界中。性常圓潔不增不減。無智之人妄生計著。若有於此能正了知。即得無漏轉依差別。此差別法得者甚難。如月在雲中性恒明潔。藏識亦爾。於轉識境界習氣之中而常清淨。如河中有木隨流漂轉。而木與流體相各別。藏識亦爾。諸識習氣雖常餘俱不為所雜。諸仁者。阿賴耶識恒與一切染淨之法而作所依。是諸聖人現法樂住三昧之境人天等趣。諸佛國土悉以為因。常與諸乘而作種性。若能了悟即成佛道。諸仁者。一切眾生有具功德威力自在。乃至有生險難之處。阿賴耶識恒住其中作所依止。此是眾生無始時界。諸業習氣能自增長。亦能增長餘之七識。由是凡夫執為所作能作內我。諸仁者。意在身中如風速轉。業風吹動遍在諸根。七識同時如浪而起。外道所計勝性微塵自在時等。悉是清淨阿賴耶識。諸仁者。阿賴耶識由先業力及愛為因。成就世間若干品類。妄計之人執為作者。此識體相微細難知。未見真實心迷不了。於根境意而生愛著。爾時金剛藏菩薩摩訶薩。復說偈言

  汝等諸佛子　　云何不見聞
  藏識體清淨　　眾身所依止
  或具三十二　　佛相及輪王
  或為種種形　　世間皆悉見
  譬如淨空月　　眾星所環繞
  諸識阿賴耶　　如是身中住
  譬如欲天主　　侍衛遊寶宮
  江海等諸神　　水中而自在
  藏識處於世　　當知亦復然
  如地生眾物　　是心多所現
  譬如日天子　　赫奕乘寶宮
  旋繞須彌山　　周流照天下
  諸天世人等　　見之而禮敬
  藏識佛地中　　其相亦如是
  十地行眾行　　顯發大乘法
  普與眾生樂　　常讚於如來
  在於菩薩身　　是即名菩薩
  佛與諸菩薩　　皆是賴耶名
  佛及諸佛子　　已受當受記
  廣大阿賴耶　　而成於正覺
  密嚴諸定者　　與妙定相應
  能於阿賴耶　　明了而觀見
  佛及辟支佛　　聲聞諸異道
  見理無怯人　　所觀皆此識
  種種諸識境　　皆從心所變
  瓶衣等眾物　　如是性皆無
  悉依阿賴耶　　眾生迷惑見
  以諸習氣故　　所取能取轉
  此性非如幻　　陽焰及毛輪
  非生非不生　　非空亦非有
  譬如長短等　　離一即皆無
  智者觀幻事　　此皆唯幻術
  未曾有一物　　與幻而同起
  幻焰及毛輪　　和合而可見
  離一無和合　　過未亦非有
  幻事毛輪等　　在在諸物相
  此皆心變異　　無體亦無名
  世中迷惑人　　其心不自在
  妄說有能幻　　幻成種種物
  幻師甎瓦等　　所作眾物類
  動轉若去來　　此見皆非實
  如鐵因磁石　　所向而轉移
  藏識亦如是　　隨於分別轉
  一切諸世間　　無處不周遍
  如日摩尼寶　　無思及分別
  此識遍諸處　　見之謂流轉
  不死亦不生　　本非流轉法
  定者勤觀察　　生死猶如夢
  是時即轉依　　說名為解脫
  此即是諸佛　　最上之教理
  審量一切法　　如稱如明鏡
  又如大明燈　　亦如試金石
  遠離於斷滅　　正道之標相
  修行妙定者　　至解脫之因
  永離諸雜染　　轉依而顯現

大乘密嚴經卷中
大乘密嚴經卷下

        唐天竺三藏地婆訶羅奉　制譯

    目識境界品第七

爾時金剛藏菩薩摩訶薩。遍觀十方從髻珠中放大光明。其光普照一切國土及密嚴中諸菩薩眾。放斯光已即告如實見菩薩言。仁主。雪山之中有一惡獸名為能害。變詐百千以取諸獸殺之而食。若見牝鹿有子之者。便為子聲悲鳴相呼。若有牝鹿便現有角。與其相似而往親附。彼無驚懼殺而食之。見牛馬等種種諸獸。悉同彼形而肆其惡。仁主。一切外道。於阿賴耶所生我見。亦復如是。如彼惡獸變種種形。著我之人所執我相。各各差別乃至極小。猶如微塵。仁主。是諸我執於何而住。不住於餘但住自識。計我之人言。我與意根境和合。意等和合而有識生本無有我。如衣與花和合而有香氣。未和合時無香可得。是故當知。但唯有識心及心法。無別有我如盤中果。如籠中燈。如伊尸迦文闍之草而可得者。但以因緣心心法生。此中無我亦無有生。微妙一相本來寂靜。是諸佛菩薩觀行之人內證境界。諸外道等不了唯識生於我見。無知法智而強分別執著有無。若一若多我我所論。如彼惡獸多所傷殺。此亦如是。令諸眾生於生死中馳騖往來。不肯親近佛及菩薩諸善知識。展轉遠離無歸向時。違背聖道失於己利。於三乘中乃至不得一乘之法。為取所縛不見真諦。不得預於密嚴之土。乃至名字亦不得聞。仁主。諸觀行人咸於此識淨除我見。汝及諸菩薩摩訶薩亦應如是既自勤修。復為人說令具速入密嚴佛土

    大乘密嚴經阿賴耶微密品第八

爾時眾中有菩薩名曰寶手。白眾色最勝王言。王應請問金剛藏。住三昧者。一切世間所有眾法。離諸分別及以名字不相應名相應之名。彼法自性於何而住。此諸佛子專心願聞。時眾色最勝王。即隨其義而問之曰

  名想等境界　　一切世間法
  為唯是分別　　為離分別有
  如其所立名　　是名何所住
  金剛自在者　　願為我宣說

爾時金剛藏菩薩摩訶薩。以偈答曰

  世間種種法　　一切唯有名
  但想所安立　　離名無別義
  四蘊唯名字　　是故說為名
  如名摩納婆　　但名無有體
  佛及諸佛子　　說名唯在相
  離相而有名　　不作是分別
  是故依於相　　分別種種名
  譬如祑吐等　　此皆無有實
  凡夫所分別　　莫不皆依相
  是故世間法　　離相即皆無
  瓶衣車乘等　　名言所分別
  色相雖可說　　體性無所有
  世間眾色法　　但相無有餘
  唯依相立名　　是名無實事
  王應觀世法　　離名無所有
  但以分別心　　而生於取著
  若離於分別　　取著即不生
  無生即轉依　　證於無盡法
  是故大王等　　常應觀想事
  但是分別心　　離此即無有
  形相體增長　　散壞質與身
  如是等眾名　　皆唯色之想
  想名及分別　　體性本無異
  隨於世俗義　　建立而不同
  若捨離名字　　而求於物體
  過去及未來　　此皆無所得
  能知諸識起　　無有所知法
  所知唯是名　　世法悉如是
  以名分別法　　法不稱於名
  諸法性如是　　不住於分別
  以法唯名故　　想即無有體
  想無名亦無　　何處有分別
  若得無分別　　身心恒寂靜
  如木火燒已　　畢竟不復生
  譬如人負擔　　是人名擔者
  隨其擔有殊　　擔者相差別
  名如所擔物　　分別名擔者
  以名種種故　　分別各不同
  如見杌為人　　見人以為杌
  人杌二分別　　但有於名字
  諸大和合中　　分別以為色
  若離於諸大　　色性即無有
  如德依瓶處　　瓶依名亦然
  捨名而取瓶　　瓶終不可得
  瓶不住瓶體　　名豈住於名
  二合生分別　　名量亦非有
  住於如是定　　其心不動搖
  譬如金石等　　本來無水相
  與火共和合　　若水而流動
  藏識亦如是　　體非流轉法
  諸識共相應　　與法同流轉
  如鐵因磁石　　周迴而轉移
  二俱無有思　　狀若有思覺
  賴耶與七識　　當知亦復然
  習繩之所繫　　無人而若有
  普遍眾生身　　周行諸險趣
  如鐵與磁石　　展轉不相知
  或離於險道　　而得住諸地
  神通自在力　　如幻首楞嚴
  乃至陀羅尼　　莫不皆成滿
  讚佛實功德　　以之為供養
  或現無量身　　一身無量手
  肩頭口及舌　　展轉皆無量
  往詣十方國　　供養諸如來
  或雨眾妙花　　寶衣及瓔珞
  其積甚高廣　　如須彌等山
  供養於如來　　及以諸菩薩
  或作寶宮殿　　如雲備眾彩
  化現諸天女　　遊處於其中
  妓樂眾妙音　　供養於諸佛
  或與佛菩薩　　遊止常共俱
  一切眾魔怨　　自在而降伏
  得自證三昧　　已轉於所依
  闡揚五種法　　八識及無我
  相續無暫停　　一心而供養
  或現身為小　　其量如微塵
  復現為大身　　無邊不可測
  種種諸色相　　以供養如來
  或於自身中　　普納諸世界
  復以諸世界　　置之於芥子
  大海為牛迹　　牛迹海亦然
  是中諸眾生　　身心無所嬈
  一切所資用　　平等而饒益
  如日月如地　　如水及火風
  又如大寶洲　　亦如良妙藥
  諸法不生滅　　不斷亦不常
  一異及來出　　如是悉無有
  妄立種種名　　是為遍計性
  諸法猶如幻　　如夢與乾城
  陽焰水中月　　火輪雲電等
  此中妄所取　　是為遍計性
  種種諸名字　　說於種種法
  此皆無所有　　是為遍計性
  一切世間法　　不離於名色
  斯皆但有名　　離名無別義
  如是遍計性　　我說為世間
  眼色等為緣　　而起三和合
  聲依桴鼓發　　芽從地種生
  宮殿及瓶衣　　無非眾緣起
  眾生若諸法　　此悉依他性
  若法是無漏　　其義不可捨
  證智所從生　　此性名真實
  諸法相差別　　已說其自性
  若離自性門　　諸法不明了
  如人以眾物　　幻作種種形
  色相雖不同　　性皆無決定
  世事悉如是　　種種皆非實
  妄情之所執　　遍計無有餘
  譬如摩尼寶　　隨色而像現
  世間亦復然　　但隨分別有
  體用無所在　　是為遍計性
  如乾闥婆城　　非城而似城
  亦非無有因　　而能如是現
  世間種種物　　應知悉亦然
  日月及諸山　　屋宅煙雲等
  體相各差別　　未嘗有雜亂
  自他及與共　　體性皆不成
  但是所分別　　遍計之自性
  諸物非因生　　亦非無有因
  若有若非有　　此皆情所執
  名依於相起　　二從分別生
  正智及如如　　遠離於分別
  心如相顯現　　相為意所依
  意及五心生　　猶如海波浪
  習氣無有始　　境界亦復然
  心因習氣生　　境令心惑亂
  依止賴耶識　　一切諸種子
  心如境界現　　是說為世間
  七識阿賴耶　　展轉力相生
  如是八種識　　不常亦不斷
  一切諸世間　　似有而安布
  有計諸眾生　　我等三和合
  發生種種識　　了別於諸境
  或有妄計言　　作者業因故
  生於梵天等　　內外諸世間
  世間非作者　　業及微塵作
  但是阿賴耶　　變現似於境
  藏識非緣作　　藏亦不作緣
  諸識雖流轉　　無有三和合
  賴耶體常住　　眾識與之俱
  如輪與水精　　亦如星共月
  從此生習氣　　新新自增長
  復增長餘識　　餘識亦復然
  如是常輪轉　　悟者心方息
  譬如火燒木　　漸次而轉移
  此木既已燒　　復更燒餘木
  依止賴耶識　　無漏心亦然
  漸除諸有漏　　永息輪迴法
  此是現法樂　　三昧之境界
  眾聖由斯道　　普詣十方國
  如金在礦中　　無有能見金
  智者善陶鍊　　其金乃明顯
  藏識亦如是　　習氣之所纏
  三昧淨除已　　定者常明見
  如酪未攢搖　　酥終不可得
  是故諸智者　　攢酪而得酥
  藏識亦復然　　諸識所纏覆
  密嚴諸定者　　勤觀乃能得
  密嚴是大明　　妙智之殊稱
  佛子勤修習　　常生此國中
  色及無色界　　空識非非想
  於彼常勤修　　而來生此處
  此中諸佛子　　威光猶日月
  住於修行地　　演說相應旨
  如來所證法　　隨見而轉依
  一切佛世尊　　灌頂授其位
  雖住密嚴土　　應物隨所宜
  在空而變化　　若見或聞法

爾時金剛藏菩薩摩訶薩復告大眾。諸仁者。阿賴耶識。從無始來為戲論熏習諸業所繫輪迴不已。如海因風起諸識浪。恒生恒滅不斷不常。而諸眾生不自覺知。隨於自識現眾境界。若自了知如火焚薪。即皆息滅入無漏位名為聖人諸仁者。阿賴耶識變似眾境。彌於世間染意攀緣執我我所。諸識於境各各了別。諸仁者。心積集業意亦復然。意識了知種種諸法。五識分別現前境界。如翳目者見似毛輪。於似色心中非色計色。諸仁者。如摩尼寶體性清淨。若有置於日月光中。隨其所應各雨其物。阿賴耶識亦復如是。是諸如來清淨之藏。與習氣合變似眾色周於世間。若無漏相應即雨一切諸功德法。如乳變異而成於酪乃至酪漿。阿賴耶識亦復如是。變似一切世間眾色。如翳目者以翳病故見似毛輪。一切眾生亦復如是。以習氣翳住藏識眼生諸似色。此所見色譬如陽焰遠離有無。皆阿賴耶之所變現。諸仁者。依於眼色有似色識。如幻而生住於眼中。其相飄動如熱時焰。諸仁者。一切眾色皆阿賴耶。與色習相應變似其相非別有體。同於愚夫妄所分別。諸仁者。一切眾生若坐若臥若行若立。惛醉睡眠乃至狂走。莫不皆是阿賴耶識。譬如盛日舒光燭地氣蒸飄動。猶如水流渴獸迷惑向之奔走。阿賴耶識亦復如是。體性非色而似色現。分別之人妄生取著。如磁石力令鐵轉移。雖無有心似有心者。阿賴耶識亦復如是。為生死法之所攝持。往來諸趣非我似我。如水中有物。雖無思覺而隨於水流動不住。阿賴耶識亦復如是。雖無分別依身運行。如有二象捔力而鬥。若一被傷退而不復。阿賴耶識應知亦然。斷諸染分更不流轉。譬如蓮花出離淤泥。皎潔清淨離諸塵垢。諸天貴人見之珍敬。阿賴耶識亦復如是。出習氣泥而得明潔。為諸佛菩薩大人所重。如有妙寶世所希絕。在愚下人邊常被污賤。智者得已獻之於王。用飾寶冠為王所戴。阿賴耶識亦復如是。是諸如來清淨種性。於凡夫位恒被雜染。菩薩證已斷諸習氣。乃至成佛常所寶持。如美玉在水蛙衣所覆。阿賴耶識亦復如是。在生死海為諸惡習覆而不現。諸仁者。阿賴耶識有能取所取。二種相生如蛇有二頭。所樂同往此亦如是。與色相俱世間之人取之為色。或計我我所若有若無。能作世間於世自在。諸仁者。阿賴耶識雖種種變現而性甚深。無智之人不能覺了譬如幻師幻作諸獸。或行或走。相似眾生都無定實。阿賴耶識亦復如是。幻作種種世間眾生而無實事。凡愚不了妄生取著。起微塵勝性自在丈夫有無等見。諸仁者。意能分別一切世間。是分別見如畫中質如雲中形。如翳夢者所見之物。如因陀羅弓。如乾闥婆城。如谷響音。有陽焰水。如川影樹。如池像月。分別之人於阿賴耶如是妄取。若有於此能正觀察。知諸世間皆是自心。是分別見即皆轉滅。諸仁者。阿賴耶識是意等諸法習氣所依。為分別心之所擾濁。若離分別即成無漏。無漏即常猶如虛空。若諸菩薩於阿賴耶而得三昧。則生無漏禪定解脫方便力自在神通。如是等諸功德法。十究竟願意生之身。轉於所依識界常住。同虛空性。不壞不盡。諸仁者。如來普見一切世間無有增減。般涅槃者非是壞滅。亦無非眾生而今始生。十方國土同一法性。諸佛出世不出世間。一切諸法住於法性不常不斷。若解脫者眾生界滅即壞如來一切智性。去來今佛所知之法不得平等。又若涅槃眾生滅者誰離於苦。有餘無餘降魔等事皆是妄說。是故當知。諸觀行者證於解脫其身常住。離眾有蘊滅諸習氣。譬如熱鐵投之冷水。熱勢雖除而鐵不壞。此亦如是。諸仁者。阿賴耶海為戲論麤重所擊。五法三性諸識波浪相續而生。所有境界其相飄動。於無義處中似義而現。諸仁者。阿賴耶識行於諸蘊稠林之中意為先導。意識決了色等眾境。五識依根了現境界。所取之境莫不皆是阿賴耶識。諸仁者。阿賴耶識與壽命煖觸和合而住。意住於此識復住意。所餘五識亦住自根。諸仁者。心意及識住於諸蘊。為業所牽流轉不息。諸所有業因愛而起。以業受身身復造業。捨此身已更受餘身如步屈蟲行。心及心法生於諸趣。復更積集稠林之蘊。諸仁者。壽煖及識。若捨於身身無覺知同於木石。諸仁者。藏識是心執我名意。取諸境界說之為識。諸仁者。心能持身意著諸趣。意識遍了五現分別。諸仁者。藏識為因生於諸識。意及意識又從所緣無間而起。五識復待增上緣生。以同時自根為增上故。諸仁者。身如起屍亦如陽焰。隨於諸行因緣而轉。非是虛妄亦非真實。為愛所牽性空無我。諸仁者。意等諸識與心共生。五識復與意識同生。如是恒時大地俱轉。諸仁者。阿賴耶識為愛所熏而得增長。自增長已復增餘識如輪不絕。以諸識故眾趣得生。於諸趣中識復增長。識與世間更互為因。如河中流前後不斷。如芽與種相續而生。各各差別分明顯現。識行亦爾。三和合已復更和合。差別而生無有斷絕。內外眾法因茲而起。一切凡夫不了自心。汝諸佛子應勤觀察。爾時眾色最勝王等。復向金剛藏菩薩摩訶薩。而作是言

  金剛三昧藏　　得無所畏者
  善入於密嚴　　能演一切法
  佛及諸佛子　　三昧正思惟
  所見諸法相　　微妙最無比
  惟願大智者　　為我等宣說
  尊者恒安住　　摩尼月藏宮
  坐於師子座　　菩薩眾圍遶
  願為諸瑜祇　　說密嚴定法
  此是月幢佛　　為眾所開演
  彼眾當來此　　願說而無倦

爾時月幢世尊。無量分身在於欲色諸天宮殿。有無央數菩薩及諸天等圍遶供養。說密嚴中諸無畏者所修觀行實相之法。彼諸菩薩聞說是已。得內證智相應三昧。心不樂於正位之樂不住實際。即於定中互相觀察。心各念言其誰已見。證於實相觀行之首。云何而得見斯人乎。心生渴仰僉然而住。彼諸佛子復更思惟。何者是定。云何非定。於何所定孰是其定。所待之緣。作是念已。以三昧力見密嚴土中菩薩之王。首戴寶冠三十二相以為嚴飾。彼諸菩薩便從定起著上好衣。從他方無量佛國而來此會。一心瞻仰金剛藏尊。爾時金剛藏菩薩摩訶薩。周顧四方見諸大眾。便生覺念將欲說法。熙怡微笑發和雅音。而說偈言

  汝等諸佛子　　咸應一心聽
  定境難可思　　非分別所了
  定及於定者　　定緣亦復然
  離諸欲不善　　而有於覺觀
  寂靜生喜樂　　是謂入初禪
  如是漸次第　　四八至于十
  外道著我者　　常修此諸定
  一切聲聞眾　　辟支佛亦然
  了知於世間　　諸法之自相
  蘊處如空宅　　此中無有我
  無思無動作　　如機關起屍
  但有三和合　　本無能作者
  外道修定人　　起於定性見
  此人迷法相　　壞於一切法
  若有能修行　　如來微妙定
  善知蘊無我　　諸見悉除滅
  一切唯有識　　諸法相皆無
  無能相所相　　無界亦無蘊
  分析至微塵　　此皆無所住
  地水等眾物　　皆從分別生
  不知其性者　　取於如是相
  惡色與好色　　似色餘亦然
  譬如虛空中　　雲霓等眾彩
  思惟如骨璅　　遍滿於世間
  及遍處想觀　　觀於諸大等
  身有色無色　　定者常諦思
  若於緣一心　　即緣說清淨
  如其所分別　　即彼成所緣
  非定非定者　　妄計以為定
  定者在定中　　了世皆藏識
  法及諸法相　　一切皆除遣
  獲於勝定者　　善說於諸定
  破諸修定人　　妄智所知法
  若人生小智　　取法及於我
  自謂誠諦言　　善巧說諸法
  計著諸法相　　自壞亦壞他
  無能相所相　　妄生差別見
  甜性能除熱　　苦醋鹹止痰
  辛物變於冷　　鹹能已風疾
  身中有痰熱　　共生於瘧病
  或復但因風　　或三和合起
  以病各差別　　良醫說眾方
  石蜜并六分　　庾沙諸食等
  能除眾生身　　種種諸瘧疾
  若法有自性　　及以諸相者
  藥無除病能　　病者不應差
  云何世人見　　服藥病除愈
  定者觀世間　　但是賴耶識
  變異而流轉　　譬如眾幻獸
  無能相所相　　蘊與於蘊者
  亦無支分殊　　及以有支分
  世中無能作　　而作於世間
  亦非散十方　　微塵之所聚
  非初最微細　　漸次大如指
  二指或復三　　諸物轉和合
  求那各差別　　如是義皆無
  非時非勝性　　及三法所作
  亦非無有因　　自然而得有
  斯由業習氣　　擾濁於內心
  依心及眼根　　種種妄分別
  意與於意識　　及以阿賴耶
  普現於世間　　如幻作眾物
  瓶等眾境界　　悉以心為體
  非瓶似瓶現　　是故說為空
  世間所有色　　諸天宮殿等
  皆是阿賴耶　　變異而可見
  眾生身所有　　從頭至手足
  頓生或漸次　　無非阿賴耶
  習氣濁於心　　凡愚不能了
  此性非是有　　亦復非是空
  如人以諸物　　擊破於瓶等
  物體若是空　　即無能所破
  譬如須彌量　　我見未為惡
  憍慢而著空　　此惡過於彼
  空性隨應說　　不應演非處
  若演於非處　　甘露即為毒
  一切諸眾生　　生於種種見
  欲令斷諸見　　為說於空理
  聞空執為實　　不能斷諸見
  此見不可除　　如病醫所捨
  譬如火燒木　　木盡火不留
  見木若已燒　　空火亦應滅
  生於智慧火　　諸見得滅時
  普燒諸煩惱　　一切皆清淨
  牟尼以此智　　密嚴而解脫
  不見以兔角　　觸壞於大山
  曾無石女兒　　執箭射於物
  未聞欲鬥戰　　而求兔角弓
  誰復須宮室　　令石女兒造
  一切法空性　　與法常同體
  始於胎藏時　　色生便滅壞
  離空無有色　　離色無有空
  如月與光明　　始終恒不異
  諸法亦如是　　空性與之一
  展轉無差別　　所為皆得成
  是身如死屍　　本來無自性
  恒為愛繩縛　　境界所牽動
  佛說於空理　　為欲斷諸見
  汝等有智人　　宜應一心學
  譬如工幻者　　以諸咒術力
  草木等眾緣　　隨意之所作
  依於眼及愛　　作意色與明
  如是眼識生　　如幻亦如焰
  是識無來處　　去亦無處所
  諸識性如是　　不應著有無
  譬如石女兒　　兔角毛輪等
  本來無有體　　妄立於名字
  師子熊羆類　　此皆無有角
  何故不分別　　唯言兔角無
  善巧談論者　　豈不能宣說
  古先諸智人　　但說兔無角
  惑者妄分別　　如瘖及聾瞽
  斯人無現智　　不能自證法
  但隨他語轉　　何用分別為
  若離於分別　　當生密嚴土
  一心正定中　　普現十方國
  譬如天宮殿　　眾星及日月
  依止須彌山　　風力所持運
  七識亦如是　　依於阿賴耶
  習氣之所持　　處處恒流轉
  譬如依大地　　發生種種物
  一切諸含情　　乃至眾珍寶
  藏識亦如是　　眾識之所依
  譬如孔雀鳥　　毛羽多光色
  雄雌相愛樂　　鼓舞共歡遊
  定者觀賴耶　　應知亦如是
  種子及諸法　　展轉相依住
  譬如百川流　　日夜歸大海
  川流無有盡　　海亦不分別
  藏識亦如是　　甚深無有涯
  諸識之習氣　　日夜常歸往
  如地有眾寶　　及餘種種物
  給施諸眾生　　隨其所資用
  藏識亦如是　　與諸分別俱
  增長於生死　　轉依成正覺
  善行清淨行　　出過於十地
  入如來地中　　十力皆圓滿
  正住於真際　　常恒不壞滅
  如地無分別　　應化無有窮
  如春眾花發　　人鳥皆欣翫
  執持識亦然　　定者多迷取
  如是諸佛子　　無慧離真實
  於義不善知　　妄言生決定
  非法離間語　　誑惑於眾生
  諸法別異住　　而別起言說
  譬如工幻師　　善用於咒術
  於無花果處　　現種種花果
  如是佛菩薩　　善巧方便智
  世間別異住　　別異而安立
  說種種教門　　誘誨無終已
  決定真實法　　密嚴中顯現
  六界與十八　　十二處丈夫
  意繩之所牽　　眾生以流轉
  八識諸界處　　共起而和合
  從於意繩轉　　前身復後身
  佛說此丈夫　　隨世因流轉
  是一切身者　　續生無斷絕

爾時金剛藏菩薩摩訶薩說諸界處丈夫義已。摩尼寶藏清淨宮中已得無畏諸大菩薩皆前頂禮。又有無量佛菩薩眾。從諸國土來此會者。同聲讚曰。善哉善哉。眾中復有無量菩薩諸天及諸天女。皆從座起。合掌而立遞相瞻顧。而說偈言

  一切定者中　　唯仁為上首
  今為諸菩薩　　說微妙丈夫
  遠離於外道　　著我等之論
  如仁所宣示　　六界淨丈夫
  但是諸界合　　隨因以流轉
  譬如虛空中　　有鳥迹明現
  亦如離於木　　而火得熾然
  空中鳥迹現　　離木而有火
  我及諸世間　　未曾見是事
  鳥飛以羽翰　　空中無有迹
  仁者說丈夫　　與鳥迹相似
  云何於諸有　　得有輪迴義
  而說界丈夫　　常流轉生死
  受諸苦樂果　　所作業無失
  如農夫作業　　未嘗不得果
  此果成熟已　　後果當復生
  身者亦復然　　住身修善行
  前生後生處　　恒受人天樂
  或常修福德　　資糧為佛因
  解脫及諸度　　逮成於正覺
  生天自在果　　觀行見真義
  若離趣丈夫　　一切悉無有
  有丈夫流轉　　在於生死中
  下從阿鼻獄　　上至諸天處
  是業必生果　　所作不唐捐
  若內外世間　　互力而生起
  此法似於彼　　彼從於此生
  雖離趣丈夫　　得有輪迴者
  如言石女子　　威儀而進退
  兔角有銛利　　沙中能出油

爾時會中諸菩薩天及天女說是語已。皆共供養所應供者金剛藏尊并諸菩薩。供養畢已。復共同心。而說偈言

  法眼具無缺　　因喻皆莊嚴
  能伏他人論　　顯示自宗德
  是故大精進　　宜應速開演
  此會天人等　　一心皆願聞

爾時金剛藏菩薩摩訶薩。以偈答曰

  此法深難思　　分別不能及
  瑜伽清淨理　　因喻所開敷
  密嚴修定處　　於中我宣說
  汝等諸天人　　咸應一心聽

爾時金剛藏菩薩摩訶薩說是語已。復向大樹緊那羅王。而說偈言

  大樹緊那羅　　汝應知法性
  諸法云何住　　性空無所有
  如是見相應　　於定不迷惑
  如飯一粒熟　　餘粒即可知
  諸法亦復然　　知一即知彼
  譬如攢酪者　　嘗之以指端
  如是諸法性　　可以一觀察
  法性非是有　　亦復非是空
  藏識之所變　　藏以空為相

爾時大樹緊那羅王。以偈問曰

  云何心量中　　而有界丈夫
  云何生諸界　　堅濕及煖動

爾時金剛藏菩薩摩訶薩。聞是語已。偈答之言

  善哉大樹王　　汝今作是問
  欲令修行者　　其心詣真實
  我今為汝說　　琴師應善聽
  汝昔乘宮殿　　并諸眷屬俱
  鼓樂從空下　　而來詣佛所
  汝手所鳴琴　　琉璃以為飾
  撫奏聲和雅　　悅動於眾心
  無量諸聲聞　　在佛所觀聽
  不能持本志　　各自起而舞
  時天冠大士　　告迦葉等言
  汝等離欲人　　云何而舞戲
  是時大迦葉　　白彼天冠士
  菩薩有大力　　譬如旋嵐風
  聲聞無定智　　如黑山搖動
  雖離惑分別　　尚染習氣泥
  彼捨諸習氣　　心淨當成佛
  汝於微細境　　其心已通達
  種種世論中　　明了而決定
  善於諸地相　　及佛清淨法
  汝在宮殿中　　眷屬所圍遶
  清淨而嚴好　　譬如盛滿月
  能於修觀行　　自在之眾中
  問我界丈夫　　云何從心起
  汝及諸佛子　　咸應一心聽
  如其諸界內　　心名為丈夫
  諸界因此生　　是義我當說
  津潤生於水　　炎盛生於火
  動搖諸作業　　因斯起風界
  從於色分齊　　有地及虛空
  境界與諸習　　識生而會聚
  眼及於色等　　相狀各不同
  此為生廣門　　諸有恒相續

爾時摩尼寶藏自在宮中持進菩薩與無量菩薩俱。從座而起稽首作禮。持諸妙供而以供養金剛藏尊。復張寶網彌覆其上。同聲讚曰善哉善哉。而說頌言

  尊者住法雲　　善入於佛地
  能為諸菩薩　　開示如來境

爾時大樹緊那羅王并諸婇女。復持種種妙好供具。以為供養。供養畢已。偈讚之曰

  善哉金剛藏　　得無所畏者
  為我等開演　　如來微妙法
  今此摩尼殿　　清淨最吉祥

爾時聖者觀自在菩薩。慈氏菩薩。得大勢菩薩。文殊師利菩薩。寶髻菩薩。天冠菩薩。總持王菩薩。一切義成菩薩。如是等菩薩摩訶薩。及餘無量修觀行者皆是佛子有大威德。善能開示觀行之心。悉從座起互相觀察。向金剛藏菩薩摩訶薩。而說偈言

  惟願金剛尊　　顯示於法眼
  尊者善地相　　一切咸綜知
  如來常念持　　佛子所宗敬
  今此大力眾　　同心而勸請
  瑜伽自在者　　顯示於密嚴
  普令諸世間　　得所未曾有
  此法最清淨　　遠離於言說
  化佛諸菩薩　　經中未開演
  諸聖現法樂　　見真無漏界
  自覺智所行　　清淨最無比
  具足眾三昧　　及以陀羅尼
  諸自在解脫　　意生身十種
  嚴淨佛國土　　不可思議數
  佛及諸菩薩　　身量如微塵
  乃至如毛端　　百分中之一
  密嚴佛國土　　諸土中最勝
  如是觀行者　　來生於是間
  此皆何所因　　佛子願宣說

爾時金剛藏菩薩摩訶薩三十二相八十種好莊嚴其身。為欲宣示無分別離分別。先佛法眼如師子王。普觀眾會知其智力堪能聽受。即以梵聲迦陵伽聲廣長舌相清美之聲。其聲決定眾所悅可。無有麤獷調柔簡暢。鍵羅摩聲。烏拖多聲。悉利多聲。離沙婆聲。般遮摩聲。毘嵐弭儋度路等聲。皆悉具足無量功德而共相應。不令聽者其心迷著。善能了達音聲之相。一切天人乾闥婆等莫不欣樂。金剛藏菩薩摩訶薩口無言說。以本願力。於其身上眉額頂鼻乃至肩膝。猶如變化自然而出如是之音。為諸大眾演說法眼。譬如鵝王群鵝翼從在沙汀上素潔嚴好。金剛藏大精進者。住於自在清淨之宮。諸佛子眾所共圍繞嚴潔亦爾。如空中朗月光映眾星。金剛藏菩薩亦復如是。處師子座映蔽一切。諸修行者如月與光無有差別。佛與金剛藏菩薩。亦復如是等無有異。爾時如實見菩薩摩訶薩住修行地眾中上首。從座而起合掌恭敬觀諸菩薩。說是偈言

  嗚呼大乘法　　微妙不思議
  如來之境界　　佛子應頂禮
  無思離垢法　　希有甚難遇
  一切國土中　　諸佛所觀察
  大乘真實義　　清淨無等倫
  遠離諸分別　　轉依之妙道
  八種識境界　　諸自性不同
  五法及無我　　差別而開示
  五種習所纏　　生諸惡分別
  見此微妙法　　清淨如真金
  得於清淨者　　即住佛種性
  如來性微妙　　非外道聲聞
  一切國土中　　密嚴為最上
  種性成就已　　而來生此國
  尊者金剛藏　　已得何三昧
  所說清淨法　　是何三昧境

爾時會中有無量菩薩眾。稽首作禮而說偈言

  大智金剛藏　　願為我開演
  住何三昧中　　而能說是法
  此諸佛子等　　一切皆願聞

爾時金剛藏菩薩大無畏者。普觀眾會智慧之力。為任聽受不思議法為不任耶。諦觀察已。知諸佛子堪受斯法。即說偈言

  汝等諸佛子　　咸應一心聽
  我今為汝說　　轉依之妙道
  我所得三昧　　名大乘威德
  菩薩住是中　　能演清淨法
  亦見拘胝剎　　所有諸如來
  塵數那由他　　在前而讚歎
  善哉汝所說　　此是瑜伽道
  我等諸如來　　皆行此三昧
  於斯得自在　　清淨成正覺
  未曾有一佛　　非此三昧生
  是故此三昧　　思惟不能及
  若有諸菩薩　　住是三昧中
  即住不思議　　諸佛之境界
  證於自智境　　及見於諸佛
  變化百千億　　乃至如微塵
  內證之妙理　　諸佛所安住
  此法無諸相　　遠離於聲色
  名從於相生　　相從因緣起
  此二生分別　　諸法性如如
  於斯善觀察　　是名為正智
  名為遍計性　　相是依他起
  名相二俱遣　　是為第一義
  藏識住於身　　隨處而流轉
  習氣如山積　　染意之所纏
  末那有二門　　意識同時起
  五境現前轉　　諸識身和合
  猶如有我人　　住在於身內
  藏識瀑流水　　境界風所飄
  種種識浪生　　相續恒無斷
  佛及諸菩薩　　能知法無我
  已得成如來　　復為人宣說
  分析於諸蘊　　見人無我性
  不知無有法　　是說為聲聞
  菩薩善能觀　　人法二無我
  觀已即便捨　　不住於真際
  若住於真際　　便捨大悲心
  功業悉不成　　不得成正覺
  希有難思智　　普利諸群生
  如蓮出淤泥　　色相甚嚴潔
  諸天聖人等　　見之生愛敬
  如是佛菩薩　　出於生死泥
  成佛體清淨　　諸天所欣仰
  從初菩薩位　　或作轉輪王
  天主阿修羅　　乾闥婆王等
  了悟大乘者　　獲於如是身
  漸次而修行　　決定得成佛
  是故諸佛子　　宜應一心學
  世間諸眾生　　染淨等諸法
  皆依於藏識　　為因而得生
  此因勝無比　　證實者宣示
  非與於能作　　自在等相似
  世尊說此識　　為除諸習氣
  了知解脫已　　此亦無所得
  賴耶有可得　　解脫非是常
  如來清淨藏　　亦名無垢智
  常住無始終　　離四句言說
  佛說如來藏　　以為阿賴耶
  惡慧不能知　　藏即賴耶識
  如來清淨藏　　世間阿賴耶
  如金與指環　　展轉無差別
  譬如巧金師　　以淨好真金
  造作指嚴具　　欲以莊嚴指
  其相異眾物　　說名為指環
  現樂諸聖人　　證於自智境
  功德轉增勝　　自共無能說
  現法諸定者　　了境唯是識
  得第七地已　　轉滅不復生
  心識之所行　　一切諸境界
  所見雖差別　　但識無有境
  瓶衣等眾物　　境界悉皆無
  心變似境生　　謂能取所取
  譬如星月等　　依須彌運行
  諸識亦復然　　恒依賴耶轉
  當知賴耶識　　即名為密嚴
  譬如好真金　　光色常充滿
  自證清淨境　　非分別境界
  性與分別離　　不可得分別
  體實而是常　　定者能觀見
  意識所行境　　但縛於凡夫
  聖見悉清淨　　譬如陽焰等

爾時世尊說是經已。金剛藏等無量菩薩摩訶薩。及從他方來此會者無央數眾。聞佛所說皆大歡喜信受奉行

大乘密嚴經卷下


大乘舍黎娑担摩经

    No. 711 [Nos. 708-710, 712]

大乘舍黎娑担摩经

        西天译经三藏朝散大夫试鸿胪卿传法大师臣施护奉　诏译

如是我闻。一时世尊在王舍城鹫峰山中。与大苾刍众千二百五十人俱。复有菩萨摩诃萨众。慈氏菩萨而为上首

尔时世尊。观舍黎娑担摩已。告诸苾刍言。若有苾刍。于十二缘生而能见了。是名见法。见是法已。即名见佛。世尊作是说已默然而住

尔时舍利子。寻作是念。今我世尊说如是法。当云何义云何了知。即往诣慈氏菩萨所。到已相见。各用软语互相问讯即与慈氏菩萨坐大石下。时舍利子白慈氏言。今者世尊。为诸苾刍说舍黎娑担摩经言。诸苾刍若于十二缘生而能见者。是名见法。见是法已。即名见佛。菩萨。我今不解斯义。何等名十二缘生。云何名法。云何名佛。唯愿菩萨。略为解说

尔时慈氏菩萨告尊者舍利子言。如来法王具一切智。随宜所说甚深微妙。汝今问我。我今略说。舍利子。如世尊言若有苾刍于十二缘生而能见了。是名见法。若见是法。即名见佛。舍利子。十二缘生者。所谓。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是生者即一大苦蕴生。舍利子。彼无明灭即行灭。行灭即识灭。识灭即名色灭。名色灭即六入灭。六入灭即触灭。触灭即受灭。受灭即爱灭。爱灭即取灭。取灭即有灭。有灭即生灭。生灭即老死忧悲苦恼灭。如是灭即一大苦蕴灭。舍利子。世尊如是说为十二缘生。舍利子言。云何名法。菩萨告言。圣八正道。名之为法。所谓正见正思惟正语正业正命正勤正念正定。舍利子。是八正道果报涅盘。是故世尊略说名法。舍利子言。云何名佛。菩萨告言。若知一切法。名之为佛。如是得圣慧眼。见菩提分法乃证法身

复次云何。见十二缘如佛所说。若人恒见此十二缘。无生无灭无作无为无取无著。如实不颠倒寂静无怖。大圣无尽止息悉皆无性。若如是见是人见法。若能如是恒见无生无灭无作无为无取无著。如实不颠倒寂静无怖。大圣无尽止息见法无性。彼人是见无上法身。佛是得正法正智止息三昧

复次舍利子白言。以何故名为十二缘。菩萨告言。以有因有缘名十二缘。舍利子。是法亦非因非缘。亦非不因缘。又从缘有。子今略说其相。如来出生及不出生。是因缘法常住平等。如实非虚是真实法。离颠倒故。又舍利子。如是缘生分为二义。何等为二。一者从因。二者从缘。此二种义分为内外。外缘从因所生者。谓从种生芽。从芽生苗。从苗生茎。从茎生枝叶。从枝叶生华果。若无种子即不生苗。乃至华果亦无所有。若有种子即生苗茎。乃至华果无不有故。舍利子。彼种子不作念我能生芽。芽亦不作念我能生苗茎。如是乃至华亦不作念我能生果。果亦不作念我能从华生。如是外因缘从因生法可见。又舍利子。外因缘从缘生者。谓缘六界合集故。云何六界。所谓地界水界火界风界虚空界时界。彼地界能安立。水界能滋润。火界能温暖。风界能动摇。空界能无碍。时界能成就。如是六界各各缘合。种子得生芽苗华实。无不具足。如是六界一不合者。种即不生乃至华实亦不可得。然彼六界各无有我。彼地不言我能安立。水亦不言我能滋润。火亦不言我能温暖。风亦不言我能动摇。空亦不言我能无碍。时亦不言我能成就。然彼种子不言我能生芽。芽亦不言我从诸缘得生。彼芽等所生。非自作非他作。亦非自他合有。非自在天所化。亦非时化。亦非缘生。亦不一事生。亦非不因生。然彼地水火风虚空时分。及种子华实而彼从生。不即不离。无尽灭故。此外缘生复有五义。何者为五。谓不常不断虽灭不尽。少因多果互为所缘。云何不常。谓种子与芽名别异故。云何不断。谓从种有芽芽生枝叶故。云何虽灭不尽。虽灭者。谓种坏似灭。不尽者。谓传种生芽。云何少因多果。谓一子为因果实繁倍。云何互为所缘。谓因种有芽乃至华实。相似连镮复为种子故。复次云何内十二缘。此十二缘。复有二义。云何为二。谓一从因。二从缘。云何从因所为。因于无明乃生于行。乃至生老死忧悲苦恼。若无无明行亦不立。乃至无老死忧悲苦恼。而彼无明不作念我能生行。行亦不作念我从无明生。乃至生亦不作念我能生老死忧悲苦恼。老死等亦不作念我从生生。是谓从因所生之相。云何从缘所生。所谓缘于六界得和合故。何等为六。谓地水火风空识。此六界合时。是名从缘生故。云何名地界。谓身坚实此名地界。若身滋润此名水界。若身温暖此名火界。若出入息此名风界。若身无障碍此名空界。眼识乃至第八识此名识界。如是等六界缘和合故。乃生其身。然彼地界不作念我能坚实。水界亦不作念我能滋润。火界亦不作念我能温暖。风界亦不作念我能出入息。空界亦不作念我能无障碍。识亦不作念我能成就。身亦不作念我从众缘生。然非众缘身亦不立。而彼地界无我无人无众生无寿命。非男非女亦无自无他。乃至水火风空识界亦无我无人无众生无寿命。非男非女亦无自无他。又复若于如是六界。而作一想凡夫想常想实想久想乐想我想人想众生想寿命想蠕动想。由无智故作如是等种种之想。是故说名无明。由无明故。即生贪欲嗔恚无明缘行。行亦如是着于假名。生诸妄想名识。识生名色。名色生六入。六入生触。触故生受。受故生爱。爱故生取。取故生有。以有故能生后蕴名生。生已衰变为老。蕴败坏故为死。以愚痴故。即发生忧悲苦恼。又以众苦集聚逼切身心。处大黑闇名为无明。造作为行。分别为识。安立相为名色。六根门为六入。对尘名触。得苦乐名受。饥渴名爱。追求名取。复生业为有。后蕴生为生。蕴熟为老。彼坏为死。思惧为忧。惨切为悲。众苦为苦。劳扰为恼。又复翻真实为虚妄。以邪见为正见。以是无智故名无明。行有三种。谓福行非福行无相行。作福行得福行智。作非福行得非福行智。作无相行得无相行智。如是乃至老死忧悲苦恼。此十二缘各各有因有果。非常非断非有为不离有为。非心法非尽法非灭法。本来自有所生不断。譬如江河流注无绝

尔时慈氏菩萨复告舍利子言。彼十二缘复以四缘增长。所谓无明爱业识等。彼识种子。以自性为因。以业为地。以无明爱烦恼覆盖。识种发生。彼业与识为地。爱与识为滋润。无明覆盖识得成就。彼业不作念我能与识种子为地。爱亦不作念我能与识种子为滋润无明亦不作念我能与识种子为覆盖。以是缘故。识种成就。识亦不作念我从众缘生复次业为识地爱为滋润。无明覆盖种子乃生。处母胎中为名色芽。彼名色芽。非自生非他生。非自他合生。亦非自在天生。亦非时化生。亦不从本所生。亦非无因缘生是法实从父母众缘和合得生。然彼名色芽本无主。亦无取舍。自性因缘如虚空幻化

复次眼识所生。有五种因缘。何者为五。谓眼色明照虚空意念。以此五缘而生眼识。以眼为所住。以色为所著。以明得观照。以虚空得无碍。是故意念起诸为作。以是缘故眼识得生。若眼色明照虚空意念等。缘不和合眼识不生。然眼不作念我能为眼识所住。色亦不作念我能令识之所著。明亦不作念我能令识得观照。空亦不作念我能令识无障碍。意亦不作念我能令识起为作。识亦不作念我能从众缘生。然眼识实从众缘和合而生。如是诸根次第所生。皆亦如是

复次无有法从今世至后世。但以业果因缘妄想所生。又如明镜照面。面现镜中实无面入镜内。由妄想因缘而显现故。又如满月高处虚空。去地四万二千由旬。影现众水。非月没彼而生此水。亦由妄想因缘故现。又如取火得薪即燃薪尽即灭

复次舍利子。无有众生从此世至后世。亦非后世至此世。但以业结成识种子处处得生。托母胎藏生名色芽。此因缘法本来无主无我无取无舍。如虚空如幻化。无有实法。而善恶之业报应不亡

又十二缘复以五事说。何等为五。谓无常不断无灭少因多果相似。云何无常。谓此蕴灭彼蕴生。灭即非生生即非灭。生灭异故。故名无常。云何不断。谓如秤高下此灭彼生。故云不断。云何不灭。谓众生界所作因业皆不灭故。云何少因多果。谓凡所造因亦如事田。专心勤力故获果广多。云何相似。谓所造因业不获异报。故云相似复次舍利子。如佛所说。若有能观十二因缘者名为正观正智慧。云何正观五智慧。谓观过去未来现在三世所生。不作有无之想。来无所从去无所至。若沙门婆罗门及世间人。能观是法。不生不灭无作无为无取无舍不颠倒寂静止息无性。若能如是见法。寂静了知无病无疮。如眴息间我见即除。如断多罗树头不复更生。是得不生灭法。舍利子。是人获法忍。具足。如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。当为授阿耨多罗三藐三菩提记

尔时慈氏菩萨说是法已。尊者舍利子。及天人阿修罗乾闼婆等。欢喜信受顶礼而退大乘舍黎娑担摩经


大乘四法经

    No. 772

大乘四法经

        大唐天竺三藏地婆诃罗译

如是我闻。一时薄伽梵在室罗筏。住誓多林给孤独园。与大苾刍众千二百五十人俱。复有无量菩萨摩诃萨众。尔时世尊告诸苾刍。有四种法。菩萨摩诃萨。尽其寿量常应修行。乃至虽遇丧命因缘。亦不得舍。何者为四。诸苾刍菩萨尽寿。乃至逢遇丧命因缘。必定不得舍菩提心。诸苾刍菩萨尽寿。乃至逢遇丧命因缘。必定不得舍善知识。诸苾刍菩萨尽寿。乃至逢遇丧命因缘。不得弃舍堪忍爱乐。诸苾刍菩萨尽寿。乃至逢遇丧命因缘。必定不得舍阿练若。诸苾刍如是四法菩萨尽寿常应坚持。宁丧身命而不舍离。尔时世尊重演其义。说伽他曰

  世间明慧者　　应发菩提心
  常思一切智　　恒近善知识
  住堪忍爱乐　　依止阿练若
  犹如师子王　　远离诸惊怖

诸明慧者修行此法。速能超出众魔罗网。疾证无上正等菩提。时薄伽梵说此经已。诸苾刍等。欢喜奉行大乘四法经


大乘四法经b

    No. 774

大乘四法经

        于阗国三藏法师实叉难陀奉　制译

  归命大智海　　毗卢遮那佛

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众五百人。菩萨摩诃萨八千人俱。皆被坚固大弘誓甲。并欲色界诸天子等无量百千。恭敬如来听受法要

尔时文殊师利童子持一宝盖广十由旬覆如来上。时有兜率陀天名曰善胜。已于阿耨多罗三藐三菩提得不退转。与其眷属在此会中。白文殊师利言。尊者。供养如来犹未足耶。文殊师利言。于意云何。海纳众流有厌足不。天言不也。文殊师利言。天子。大海深广无有涯际。万流朝宗尝无盈息。菩萨摩诃萨求萨婆若供养如来。亦复如是未曾厌足。天复请言。供养佛时应何所为。文殊答言。应以四事。一为萨婆若。二为度一切众生。三为不断三宝种。四为摄诸佛刹功德庄严。是为菩萨以四事故供养如来。天复请言。善哉尊者。菩萨于法常应不吝。如昔所为尸弃梵王及其眷属演四法门菩萨之道。愿为我等一切众会重宣此义。文殊师利言。谛听谛听。善思念之。当为汝说。天子。菩萨摩诃萨应发四种增上意乐心。云何为四。谓摄一切众生心。成熟一切众生心。集一切善根心。觉悟一切佛法心。是为四。复次菩萨应发四种如山心。云何为四。谓于乞者无嗔嫌心。向恶道者生慈愍心。般若波罗蜜常不舍心。所修众行皆究竟心。是为四。复次菩萨应发四种转胜心。云何为四。谓持戒转胜。多闻转胜。大慈转胜。大悲转胜。是为四。复次菩萨应发四种如金刚不可坏心。云何为四。谓信乐不坏。依善知识不坏。修行不坏。求大乘不坏。是为四。复次菩萨应发四种无能染心。云何为四。谓烦恼不能染。名利不能染。下乘不能染。诸恶众生不能染。是为四。复次菩萨应发四种无上心。云何为四。谓所爱皆舍心。施已无悔心。不望果报心。回向菩提心。是为四。复次菩萨有四种能至顶法。云何为四。谓智慧。方便持正法。化众生。是为四。复次菩萨有四种助菩提道。云何为四。谓勤修诸度。顺四摄事。住四梵住。游戏神通。是为四。复次菩萨有四种第一胜法。云何为四。谓于诸众生无损恼心。恼害己者心无系念。在五欲境而不放逸。贫穷苦厄不舍法行。是为四。复次菩萨有四种安隐心。云何为四。若在家时自财知足。他财不贪。若出家时依四圣种。行头陀法。是为四。复次菩萨有四种施。云何为四。谓财施。法施。纸笔施。于法师所善心赞叹施。是为四。复次菩萨有四种坚胜法。云何为四。谓所闻能行。丰财能施。尊者能供养。寿命能种诸善根。是为四。复次菩萨有四种不舍。云何为四。谓不舍菩提心。不舍正法。不舍一切众生。不舍求诸善法。是为四。复次菩萨有四种园。云何为四。谓乐住阿兰若。乐独露坐。乐求善法。乐方便度诸众生。是为四。复次菩萨有四种宫。云何为四。乐依梵住。乐闻善法。乐观性空。乐同行者共止。是为四。复次菩萨有四种无尽财。云何为四。谓多闻财。说法财。摄诸贫乏财。回向菩提财。是为四。复次菩萨有四种伏藏。云何为四。谓陀罗尼藏。辩才藏。法藏。无尽财回向藏。是为四。复次菩萨有四种远离。云何为四。谓远离众话。远离五欲境。远离非圣心。远离三界。是为四。复次菩萨有四种乐。云何为四。谓离我我所无著乐。一切不顾恋远离乐。离一切境界寂静乐。不舍一切众生而无烦恼涅槃乐。是为四。复次菩萨有四种喜。云何为四。谓见佛喜。闻法喜。布施不悔喜。与一切众生安乐喜。是为四。复次菩萨有四种真实。云何为四。谓不舍菩提心。不舍弘誓愿。不舍有来归依者。不舍一切善护语。是为四。复次菩萨有四种善法。云何为四。谓乐修一切善法。不轻未学。于诸众生怨亲平等。为不请友饶益众生不思其报。是为四。复次菩萨有四种清净。云何为四。谓戒清净无我故。定清净无众生故。慧清净无寿者故。解脱清净无诸趣生故。是为四。复次菩萨有四种足。云何为四。谓义足。法足。行头陀功德足。集菩提资粮足。是为四。复次菩萨有四种手。云何为四。谓信手。戒手。闻手。慧手。是为四。复次菩萨有四种眼。云何为四。谓肉眼作善业故。天眼神通不退故。慧眼所闻不厌故。法眼谛观诸法得忍故。是为四。复次菩萨有四种无厌。云何为四。谓施无厌。住阿兰若无厌。听法无厌。修善无厌。是为四。复次菩萨有四种难行。云何为四。谓忍受一切卑贱陵辱虽自穷乏所有皆施。见有从乞头目身体心无违逆生善友想。观空无我而现受生。是为四。复次菩萨有四种无病。云何为四。谓无诸界不等病。无烦恼热病。无不利益众生病。无诸法疑惑病。是为四。复次菩萨有四种自分法。云何为四谓诸波罗蜜。菩提分法。真善知识。不作一切恶业。是为四。复次菩萨有四种不动。云何为四。谓菩提心。如愿而行。如言而作。勤修正行。是为四。复次菩萨有四种资粮。云何为四谓奢摩他。毗钵舍那。闻一切善根。是为四。复次菩萨有四种齐行。云何为四。谓发心起行。布施回向。大慈大悲。智慧方便。是为四。复次菩萨有四种法障梦。云何为四。谓梦月堕于平地井中。梦月现于浊泉池中。梦月在空大云所覆。梦月在空烟尘所翳。是为四。复次菩萨有四种业障梦。云何为四。谓梦堕大险处。梦高下道。梦磐曲道梦迷方惊怖。是为四。复次菩萨有四种烦恼障梦。云何为四。谓梦毒蛇扰乱。梦群兽恶声。梦落贼难处。梦身蒙尘垢。是为四。复次菩萨有四种得陀罗尼梦。云何为四。谓梦大伏藏诸宝充满。梦清池中众花齐敷。梦得双净白叠。梦诸天持盖覆上。是为四。复次菩萨有四种得三昧梦。云何为四。谓梦端正童女众宝庄严持花授与。梦白鹅行列回翔空中。梦如来手摩其顶。梦如来坐莲花座入于三昧。是为四。复次菩萨有四种见如来梦。云何为四。谓梦月出现。梦日出现。梦莲花开。梦大梵王威仪闲寂。是为四。复次菩萨有四种得大人相梦。云何为四。谓梦诸妙花果满娑罗树。梦大铜器众宝盈满。梦虚空中幢盖庄严。梦转轮王以法御世。是为四。复次菩萨有四种不退相梦。云何为四。谓梦白缯系顶。梦自设无碍施会。梦身处法座。梦佛坐道场为众说法。是为四。复次菩萨有四种降魔怨梦。云何为四。谓梦大力士摧小力士持胜幡去。梦大勇将战胜而去。梦受灌顶王位。梦坐菩提树降伏众魔。是为四。复次菩萨有四种坐菩提场梦。云何为四。谓梦吉祥瓶满。梦众右绕其身。梦所往之处树皆低枝。梦金光普照。是为四。文殊师利说此法时。善胜天子及其眷属。欢喜踊跃。以天曼陀罗花。波头摩花。拘物头花。分陀利花。供养文殊师利。及散一切众会。以佛神力所散之花上升虚空。成大莲花量如车轮。微妙香洁悦可众心。于花台上有诸菩萨。三十二相庄严其身。尔时善胜天子白文殊师利言。此诸菩萨从何方来。文殊答言。如花来处是所从来。天言。此花化生无所从来。文殊复言。彼诸菩萨当知亦尔

尔时世尊即便微笑。从其口中放种种光。青黄赤白颇梨等色。遍照十方无量刹土。上至梵世蔽日月光还从顶入。时善胜天子即从坐起。偏袒右肩右膝着地。合掌向佛以偈赞曰

  清净金色光　　妙相三十二
  具亿那由他　　无比胜功德
  能救世间者　　何故现微笑
  梵音深且远　　所言净微妙
  恒蕰七圣财　　放大智慧光
  迦陵伽声音　　愿说微笑义
  世雄大丈夫　　降魔及异道
  常为诸天人　　修罗等供养
  具足十力者　　何故现微笑
  一切贪恚痴　　尘恼智慧障
  永断无余习　　面如净满月
  普施安乐者　　愿说微笑义
  善逝天人师　　无量功德聚
  其心常平等　　具足行众善
  开解一切者　　何故现微笑
  常持大慧灯　　破黑闇稠林
  游步若牛王　　无畏如师子
  利益众生者　　愿说微笑义
  人中最尊胜　　难见难可测
  无我无谄曲　　超越诸有海
  智力自在者　　何故现微笑
  千辐网缦足　　三界无伦匹
  竭涸生死流　　断绝愚痴网
  善哉大智者　　愿说微笑义

尔时世尊告善胜天子言。汝见虚空莲花座上诸菩萨不。天子白言。唯然已见。佛言。此诸菩萨皆是文殊师利之所化度。为听如是四法门故从十方来。皆住一生补处。于十方刹当成阿耨多罗三藐三菩提。名号各异。天言。世尊。此诸菩萨颇有算计知其数不。尔时世尊告舍利弗。汝能知耶。舍利弗言。世尊。我能于一念顷。悉知三千大千世界一切星宿。不能百年算知此诸菩萨数量。佛告舍利弗。假使微尘满阎浮提尚可数知。此菩萨数莫知边际。舍利弗言。何处当有尔许佛刹容是菩萨成正觉耶。佛言。且止莫作是说。诸世界中空无佛者无量无边。舍利弗。假使如来恒河沙劫久住于世。日日当说恒河沙法。说一一法。皆授恒河沙菩萨阿耨多罗三藐三菩提记。过于东方恒河沙佛刹乃一菩萨于中成佛。如是东方无佛世界尚不能尽。何况十方一切刹土空无佛者。舍利弗。如是所有无量世界。皆是如来肉眼所见。其中所有一切众生。皆是如来心之所知。时诸大声闻及一切众会。心生希有作如是言。我等今者咸得善利。值遇是师成就广大福德智慧。时虚空中诸来菩萨。皆从空下顶礼如来及文殊师利。恭敬右绕各还本土

尔时善胜天子白文殊师利言。善哉尊者。作佛作事。乃能化是无量菩萨住大菩提。愿为我说成就此等住菩提法。文殊师利言。天子。成就菩萨住菩提法有三十五。所谓应常依时不失其节。应警策诸根。应摄心不动。应修诸波罗蜜。应随善方便。应发胜意乐。应建大慈。应起大悲。应不舍大乘。应远离小乘。应常谛实。应如实作。应护正法。应如闻行。应了众生性平等无二。应观破戒持戒皆福田相。应觉诸魔业。应成满大愿。应于生死不疲厌。应降伏众魔。应知恩报恩。应入灭因法。应于解脱门不惊怖。应供养诸佛。应随众生所须皆作。应不染世法。应乐阿兰若。应行少欲。应念知足。应未度令度。应未解令解。应未安令安。应未涅槃令涅槃。应不断三宝种。应摄诸佛净刹功德庄严。是为成就菩萨三十五种住菩提法。应如是学。又复天子。菩萨应离十种慢心。所谓我慢。多闻慢。辩才慢。利养名称慢。住阿兰若慢。头陀功德慢。富贵眷属慢。释梵护世承事慢。禅定神通慢。为于佛法僧得不坏信天龙夜叉犍闼婆阿修罗迦楼罗紧那罗摩睺罗伽等恭敬赞叹慢。菩萨能离此十种慢。即于阿耨多罗三藐三菩提不退转。不为一切外道魔怨之所损败。时善胜天子白文殊师利言。随于尊者所住之处。当知已是有此法门。即为如来于中出世转正法轮。佛言。如是如是。如汝所说。随何方土。文殊师利说此法门。即为法王于其中住。若有众生行此法者。是真佛子。有能信解受持此法。名实修行。斯人已为佛所调伏。不退转于阿耨多罗三藐三菩提

尔时世尊告弥勒菩萨迦叶阿难。善男子。我今以此法门付嘱汝等。当受持读诵如说修行为人广说。我涅槃后应以此法大作佛事。令一切众生皆获安乐。弥勒白言。唯然受教。世尊。当何名此经。云何受持。佛告弥勒。此经名说四法门。亦名成就菩萨道法。是故汝等应共受持。佛说此经已。弥勒菩萨摩诃萨。长老大迦叶。长老阿难。及一切世间。天人阿修罗等。闻佛所说欢喜奉行大乘四法经


大乘同性经

    No. 673 [No. 674]

大乘同性经卷上(亦名一切佛行入智毗卢遮那藏说经)

        周宇文氏天竺三藏阇那耶舍译

如是我闻。一时婆伽婆。住在大摩罗耶精妙山顶摩诃园林华池沼边大持咒神所居止处人不能行最得道者所居之处。共大比丘千二百五十人俱。一切皆是摩诃声闻所作已办。已过一切凡夫之地。其名曰尊者阿若憍陈如。尊者阿说示。尊者摩诃迦叶。尊者舍利弗。尊者摩诃目揵连。与如是等诸大声闻。复有菩萨摩诃萨众。皆大菩萨悉得一切菩萨三昧陀罗尼行。一切已住诸菩萨地。其名曰圣者弥勒菩萨摩诃萨。大意菩萨摩诃萨。益意菩萨摩诃萨。坚意菩萨摩诃萨。定意菩萨摩诃萨。无尽意菩萨摩诃萨。无边意菩萨摩诃萨。海意菩萨摩诃萨。正定意菩萨摩诃萨。净意菩萨摩诃萨。智意菩萨摩诃萨。如是等一切各各佛刹已得受记。为阿耨多罗三藐三菩提转法轮故。复有最上最胜天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。并持咒神及非人等。种种形容天冠衣服。执持器杖并诸幢盖。及诸鬼神仙人众等。皆来集坐为欲听法

尔时世尊。众如大海前后围绕。有所说法初中后善。其义深远其语巧妙。具足广说清净梵行。尔时楞伽大城之中。有罗刹王名毗毗沙那。治化于彼。时毗毗沙那楞伽王。闻佛今住大摩罗耶精妙山顶摩诃园林华池沼边大持咒神所居之处人不能行最得道处。与千二百五十比丘现说梵行。时毗毗沙那楞伽王。即生念言。如来名字世间希有如优昙华。于无数时乃一得闻。何况值佛。我于是中无量无数时不得闻法。犹如盲龟遇浮木孔。是中诸佛及以佛法。入佛境界证佛道者。如是之事倍复最难。我若赍持多诸珍宝。及真珠贯无量香华。末香涂香华冠衣服宝幢幡盖。并及缯束音乐歌赞。与我眷属往诣佛所。到佛所已以此种种供养之具。供养如来欲问正法报我一生

时毗毗沙那楞伽王。普皆宣告诸罗刹众。汝等可共同心和合。捉持丰足胜妙金银摩尼宝珠珂玉琉璃珊瑚马瑙真珠璎珞并赤真珠种种精妙无量香华。作诸音乐及以歌赞。须向佛所。如来法王三界最胜。无上福聚具足众相。一切知见无上福田。我等向彼持此供具以用供养。所以者何。于无数时值佛出世得见佛难。离八难难。闻三宝难。作此念已。尔时毗毗沙那楞伽王。于其众中说偈告言

  无量无数时　　佛乃现世间
  欲离于八难　　复经无量世
  百千亿劫中　　希逢于世尊
  譬如优昙华　　无数时乃出
  地狱与畜生　　最苦饿鬼道
  往来于六趣　　展转如车轮
  令此众生类　　离诸八难厄
  利益众生故　　故出世间灯
  智日光所照　　能破无明盲
  相随至彼处　　供养无上尊
  教天人世中　　供养获大果

尔时毗毗沙那楞伽王说此偈已。佛神力故于虚空中。放百千亿那由他大光明网。遍照楞伽大城。照已毗毗沙那及一切罗刹众。皆悉踊跃。尔时彼大光明焰中。演出甚深法相之偈

  诸法本寂空无我　　众生初中后叵得
  譬如虚幻梦泡焰　　雾电水沫旋火轮
  世谛缘法悉非真　　无明爱根世间现
  真观无爱及无明　　诸法如空净叵说

尔时毗毗沙那楞伽王。闻彼光明网中演出如是法相偈已。即得甚深无我法忍。彼罗刹众中或得忍者。或有发于菩提心者。或有发顺忍者。有实见者。时毗毗沙那楞伽王。于佛法中明了无疑。既着菩提坚钾铠已。复发此愿而说偈言

  天人及与阿修罗　　一切梵王上天众
  如此无上最妙法　　彼等未曾得觉见
  我应未来得斯法　　具足一切无碍智
  此世界中成佛道　　度脱无量亿众生
  演说诸佛微妙法　　最胜无漏八圣道
  令我所作无边智　　三十二相庄严身
  若有精勤行善行　　及佛功德行满足
  利益众生脱怖畏　　持诸功德灭有尘
  面如日月净光明　　于三界中得作佛

尔时毗毗沙那楞伽王。于阿耨多罗三藐三菩提得不退转。即随其意。应念出生种种精妙华香涂香末香华冠衣服宝幢幡盖摩尼缯束真珠璎珞。作诸伎乐击掌歌赞妙声遍满。赞叹如来功德相好。持如是等诸供养具。与其眷属于虚空中。如鹅王行来向佛所。至佛所已从空而下。时毗毗沙那楞伽王。与眷属俱向佛合掌。接世尊足顶礼百遍。礼拜讫已绕佛三匝乃至千匝。时毗毗沙那楞伽王。即于佛所五体投地如斫树倒。复说此言。南无无量功德庄严最上法身师子丈夫三界最胜世尊释迦牟尼至真等正觉。出此语已即起合掌。于世尊前说偈赞叹

  昔世亿生转精事　　难行苦行求菩提
  布施饮食及衣乘　　亿数七珍与乞者
  不思议劫无悔吝　　舍国聚落及臣民
  王宫庄严宝丰满　　亿劫难舍皆能舍
  昔名王子须大拏　　于山林中施妻子
  前舍自身救产虎　　割其身肉济穷鸽
  挑眼施盲婆罗门　　于彼生中无怨恨
  施头为求菩提因　　心于索者常欢喜
  为护戒品长清净　　不犯圣行顺无为
  不断生命盗他物　　常顺梵行世无妒
  离于饮酒不妄语　　护诸众生如己身
  昔不两舌诸恶言　　亦无嗔恚说绮语
  世尊离邪常调顺　　于前众生无恼触
  功德如意离邪见　　供养三宝无坏心
  出家无垢除五欲　　依顺佛戒解脱行
  前行忍辱受诸苦　　诽谤毁訾及困责
  往昔所受诸苦痛　　为众生故无恨心
  若在佛边起杀恼　　于彼慈心视如子
  佛生于世常修忍　　解脱亿数苦众生
  如来往昔求道时　　作大仙人名曰忍
  彼所生中被割截　　忍痛于王无害心
  为彼国王及夫人　　演说白法令欢喜
  不思亿劫常精进　　懈怠邪意狭劣除
  昔诸苦行皆能忍　　广大精进觉菩提
  经行不睡亦无乏　　尊重供养无量佛
  众生所须常随顺　　熏修成佛无上法
  昔行禅定为伏心　　已善四禅无色定
  三昧念五神通力　　往昔行满无漏禅
  如来智慧满无漏　　知法如幻悉虚假
  无我众生命及人　　烦恼网缠因业转
  欲界不净四种惑　　众生烦恼界本净
  既知实净众生本　　得具六种波罗蜜
  谁能说此智方便　　勤求无尽佛福聚
  发胜三业向如来　　来世得佛我顶礼

尔时毗毗沙那楞伽王说此偈已。复以无量种种最妙及以香华末香涂香华冠衣服宝幢幡盖。音乐歌咏赞叹如来。尊重恭敬具足承事。供养于佛并诸声闻大菩萨众。彼罗刹众亦复如是。如法发起供养如来称可佛意。尔时毗毗沙那楞伽王。供养讫已白佛言。世尊。我今有疑。欲问如来至真等正觉。唯愿世尊。为我开解。说此语已。佛告楞伽王言。楞伽王。吾常开汝问佛所疑。随汝意乐。当为解说令心欢喜。时楞伽王得开许已。白佛言。世尊。众生众生者世尊。以何义故名为众生。佛言。楞伽王。众生众生者。众缘和合名曰众生。所谓地水火风空识名色六入因缘生。又众生者。犹如束竹缘业故报缘业得果。我人众生寿命畜养众数。知者见者作者触者受者。是名众生。毗毗沙那楞伽王言。世尊。彼众生者。以何为本依何而住以何为因。佛言。楞伽王。此众生者。无明为本依爱而住以业为因。毗毗沙那楞伽王言。世尊。业有几种。佛言。业有三种。何等为三。身口意业。复有三相。净不净非净非不净。时毗毗沙那楞伽王。复白佛言。世尊。云何众生舍此寿命受彼寿命。舍此故身受彼新身。佛言。楞伽王。众生舍此身已。业风力吹移识将去。自所造业而受其果。若善及不善非善非不善。众生如此造业行者。即于彼处而受新身。或受卵生。或受湿生。或受胎生。或受化生。皆是一切业风所造。而业亦不自知所造各自受报。楞伽王。众生如是舍此身命受彼新身。楞伽王言。世尊。众生舍此身命未受彼身。于其中间识停何处。佛言。楞伽王。于汝意云何。田中种子至生牙时。为当子先灭已然后牙生。为当其牙先生然后子灭。为当唯子灭时其牙即生。毗毗沙那王言。不也世尊。佛言。楞伽王。是义云何。楞伽王言。世尊。其子若灭其牙即生。非先子灭然后牙生。非先生牙然后子灭。佛言。如是楞伽王。非识先灭后识方生。楞伽王。亦非先生前识后识力灭。楞伽王。唯后识灭前识即生。楞伽王。如步屈虫先安头足次后足随。其形屈伸间无断绝。如是如是。楞伽王。此之神识。见前有中生处了已。识即令移托就于彼。间无断绝。毗毗沙那楞伽王言。世尊。若如是者无中阴耶。佛言。楞伽王。一种众生卵生是也。舍此身已入于卵中。而是神识业风所捉。停住卵中昏钝不觉。及至覆成识方觉了。当知彼卵已为熟也。何以故。卵生众生法如是故。未成熟时不觉不了。所以者何。为业力故。楞伽王。复有众生福力纯厚。得于转轮王家作子。而彼在胎不为胎污。亦不与胎不净共住亦不污染。楞伽王。其转轮王所生子者多受化生。设受胎者。初入胎中结子已成。及生出后破膜出身。楞伽王。是因缘故说有中阴。时毗毗沙那楞伽王言。世尊。众生神识为当几大为作何色。佛言。楞伽王。众生神识无边大。无色无相不可见。无碍无形无定处不可说。毗毗沙那言。世尊。识相如此无有边大。无色无相不可见。无碍无形无定处不可说者。岂非断绝。佛言。楞伽王。吾今问汝随汝意答。当为汝说。楞伽王。譬如大王在宫殿中或高楼上。婇女围绕安乐坐时。着种种衣及诸璎珞。时大园林阿输歌树。种种杂华庄严精丽。其园在处有细软风或大駃风。吹彼园林阿输歌树。众华香气至王所者。王闻之不。毗毗沙那白言。世尊。我闻此香。佛言。楞伽王。汝闻此香分别知不。王言。世尊。我能得知。佛言。楞伽王。此华香气王言知者。见大小耶定作何色。楞伽王言。不也世尊。何以故。此香气相无色无现无碍无相无定处不可说。是故不见大小形色。佛言。楞伽王。于意云何。若不见彼香气大小非断绝相耶。毗毗沙那言。不也世尊。何以故。若此众香是断相者。无人得闻。佛言。如是如是。楞伽王。识相亦尔。应如是见。楞伽王。若识断相则无生死而可得知。如是楞伽王识相清净。唯是无明贪爱习气业等。诸客烦恼之所覆障。楞伽王。譬如清净虚空之界。唯有四种客尘污染。何等为四。所谓烟云尘雾。楞伽王。识相如是本清净故。无边不可捉无有色染。唯是诸客烦恼之所覆染。所以者何。楞伽王。若正观时不得众生。无我无众生。无寿命无畜养。无人无众生数。无知者无见者。无觉者无受者。无听者乃至无色受想行识等。楞伽王。若正观时无有分别而可得者。楞伽王。诸法和合无有实相。汝虽得是众生实相。亦莫舍此生有旷野。云何名得众生实相。所谓得彼大智同性。尔时世尊而说偈言

  众生业力自回转　　不得八圣最上道
  若离诸业证无漏　　行无上行利众生

时毗毗沙那言。世尊。有无量恒河沙等众生。于此三界稠林有海。到彼岸者复欲到者。有证声闻法者。有证缘觉法者。亦有若干已证无上大智同性者。于未来世亦有无量无边不可数阿僧祇过是数恒河沙等众生。乘此三乘各各别乘得入涅槃。而众生界无增无减。如是世尊。我知如是心生厌惓。佛言。楞伽王。汝莫于此生厌惓想。所以者何。诸众生界前后不可尽故。虚空界法界亦尔。是故楞伽王。诸众生界不可言说。以是得知不增不减。如是三界稠林有为海中。已得度者当欲度者。而众生界亦不增减。楞伽王。譬如虚空界不增不减。无前无后亦无中间。是故虚空不可得知。遍一切处无碍无忧无作无想。如是如是。楞伽王。非众生界有初中后求之可得。楞伽王。唯有已得圣法同性。是名尽于众生界耳。而有为道不尽不灭。楞伽王。亦不离彼有解脱道。何以故。是众生界法如此故。是故无初无中无后

毗毗沙那复问佛言。世尊。众生有为行海相貌何似。佛言。楞伽王。众生有为行海犹如大海。复问佛言。世尊。诸佛之法复似何等。佛言。楞伽王。诸佛之法犹如船舶。复问佛言。世尊。出家比丘受具戒法复似何等。佛言楞伽王。出家比丘受具戒法。似治生人乘于船舶。复问佛言。世尊。如世尊说。依佛戒法具足奉行。无毁破者复似何等。佛言。持戒精进受法知足。似治生人乘坚牢船成就具足。楞伽王。有能如佛所说戒法不破不犯具足行者。亦复如是。复问佛言。世尊。善知识者复似何等。佛言。楞伽王。善知识者犹如船师。复问佛言。世尊。勤行八圣道复似何等。佛言。楞伽王。勤行八圣道者。似正疾风吹于船舶。毗毗沙那复问佛言。世尊。禅定三昧及诸神通复似何等。佛言。楞伽王。神通三昧犹如宝国。毗毗沙那复问佛言。世尊。七菩提分复似何等。佛言。楞伽王。七菩提分犹如七种宝性。复问佛言。世尊。得七菩提分证大乘同性者复似何等。佛言。楞伽王。得七菩提分证大乘同性者。譬如值得七种宝性巨富货贿称意满足。善哉善出家者。于我法中证于无碍无上佛果。尔时世尊复说偈言

  观察诸有苦　　自苦众生苦
  亦舍诸有缚　　我法中出家
  即名为佛子　　众中最大德
  勤苦如法行　　当得为世尊

尔时毗毗沙那复问佛言。世尊。若有众生于佛法中。得出家已不能持戒。或有犯戒或有破戒犯欲行者。或有脱于法服舍戒还俗。世尊。如是痴人譬如何等。佛言。楞伽王。若有众生于我法中。得出家已受于戒法作诸毁犯。是痴人辈多堕恶道。如治生人在大海中船舶破坏没命于水。毗毗沙那言。世尊。若有破戒犯戒犯欲行者。复说我行精进梵行。复有捐弃法服舍戒还俗。彼一种人命终亡已。或生好处彼似何等。佛言。如治生人于大海中船舶破坏没溺水中。或有得船板者。或有得死尸者。或有自力浮者。楞伽王。是治生人得船板者。因风力吹得至洲岛。捉死尸者海波所推渐到彼岸。何以故。大海之法不宿死尸。若其自力能浮得度随意所至。此是海神慈悲济彼。如是如是。楞伽王。若我法中得出家者。不能依戒如法护持。若舍戒法着于俗服得生善处者。或因我边得正信者。或复内净或虽破戒恒有慈行或有精进。是故楞伽王。虽是破戒及还俗者。还因我法得生善处。尔时世尊而说偈言

  往昔已作多罪业　　无边千亿世生中
  发露忏悔更不造　　灭无增长故清净

时毗毗沙那复问佛言。世尊。凡有几种助菩提法。佛言。楞伽王。有三十七品助菩提法。何者名为三十七品。所谓四念处四正勤四如意足五根五力七觉分及八圣道。楞伽王。是名三十七品助菩提法。复问佛言。世尊。解脱门者为有几许。佛言。楞伽王。有三解脱门何者为三。所谓空无相无愿。复问佛言。世尊。须念何法。佛言。念厌灭入涅槃。复问佛言。世尊。诸对治法凡有几许。佛言。楞伽王。总而言之三种对治。何者为三。谓贪欲心者不净观。嗔恚心者慈悲观。愚痴心者因缘观。是名三种对治之法。复问佛言。世尊。几许巧能应须念持。佛言。楞伽王。须念持者巧知阴巧知界巧知入巧知方便。复问佛言。世尊。须作何观。佛言。楞伽王。须观甚深十二因缘及四圣谛因果证等。尔时毗毗沙那楞伽王。复更围绕世尊三匝。以诸杂色七宝之华散于佛上。散已右膝着地合掌向佛。惊叹如来而说偈言

  云何菩萨诸圣行　　生精进意利世间
  施戒忍辱及精进　　发最上意为菩提
  求彼无漏智慧时　　摄化多亿诸众生
  众宝庄严无浊垢　　精妙刹中得成佛

尔时世尊告毗毗沙那楞伽王言。善哉善哉。楞伽王。汝能咨问如来此事。谛听谛听善思念之。当为解说。楞伽王。菩萨摩诃萨常须行六波罗蜜。于一切众生边不生恶心。楞伽王。菩萨行如是法时不减不少。于诸佛法常得增长。亦不染着世间之法。摄受教化无量众生。亦能清净如来刹土。复能具得大智同性。于佛法中无障无碍。尔时毗毗沙那楞伽王白佛言。世尊。云何修行。云何得住阿耨多罗三藐三菩提。佛言。放舍憍慢贡高嫉妒。常行四种清净梵行。欢喜普为一切众生恒行正真。须舍杀盗妄言绮语两舌恶口饮酒淫劮。莫使暂忘菩提之心。意乐勤行六波罗蜜。所作恒为安乐众生。于有为中心常寂静。欲度有海多诸怖畏。汝当正观三界众生令得度脱

复次楞伽王。汝若欲求菩提之者须如是知。言菩提者。但有名字言语谓菩提耳。何以故。楞伽王。无有是菩提。无根是菩提。无住是菩提。无垢是菩提。无尘是菩提。无我是菩提。不可捉是菩提。无色是菩提。无形是菩提。无此是菩提。无彼是菩提。无忧是菩提。无恼是菩提。无著是菩提。无染是菩提。无边是菩提。无为是菩提。无浊是菩提。已过一切根是菩提。除一切忆想念是菩提。已过一切有行是菩提。无底是菩提。难知是菩提。甚深是菩提。无字是菩提。无相是菩提。寂静是菩提。清净是菩提。无上是菩提。无譬喻是菩提。无求是菩提。无断是菩提。不坏是菩提。无破是菩提。无思惟是菩提。无物是菩提。无为是菩提。无见是菩提。无害是菩提。无明是菩提。无流注是菩提。常住是菩提。虚空是菩提。无等等是菩提。不可说是菩提。楞伽王。欲求菩提者。若不求法是求菩提。何以故。楞伽王。若无有着。得证阿耨多罗三藐三菩提。又无我相众生相命相人相畜养相众数相作相受相知相见相。乃可得证阿耨多罗三藐三菩提。若不得世谛相者。不执着法。不执着阴界。乃至不执着诸佛菩萨。乃可得证阿耨多罗三藐三菩提。何以故。楞伽王。无所执着即是菩提。若不执着物。若不执着常。若不执着断者。于未来世证成菩提。所以者何。楞伽王。一切诸法后际灭故

时毗毗沙那楞伽王复白佛言。世尊。云何得知一切世谛法耶。佛言。楞伽王。知一切世谛法如幻如化如梦如焰如水中月如乾闼婆城。一切世谛法应如是知如是觉如是观。尔时毗毗沙那楞伽王。即得菩萨三昧名无等等法光明智相。得陀罗尼名一切巧音。得如是等无量无边诸三昧陀罗尼已。时毗毗沙那楞伽王即白佛言。世尊。我今得此三昧陀罗尼已。觉知一切世谛之法。佛言。楞伽王。云何觉知。毗毗沙那言。世尊。一切世谛之法。如梦如幻如响声等。如山水駃如水中月。如风吹空华。如秋云起。如珠光明。如灯焰火。如华上露。如揵闼婆城。如水上泡。如虹如焰。世尊。我已觉知世谛诸法现皆无常。尔时世尊。即放顶上百千亿那由他种种妙色光明。所谓青黄赤白红紫颇梨及金等色。普照无量无边阿僧祇诸佛刹土。既遍照已还入顶上。尔时尊者大目犍连。即从座起偏袒右肩右膝着地。合掌向佛。说偈问言

  佛上妙德非无因　　开放清净光明网
  今意精妙觉发谁　　放百光网愿佛说

佛告目犍连言。汝见此毗毗沙那楞伽王。在于我前合掌正立。以此广大供养之具。用供养我及声闻众诸菩萨众。因此功德发阿耨多罗三藐三菩提心不。目犍连言。世尊我见。世尊我见。佛言。目犍连。是毗毗沙那楞伽王。从我已去乃至当欲供养承事百千亿那由他诸佛。过是已后彼身功德本力具足。有世界名莲华城。彼有世尊号莲华功德相震声威王如来阿罗呵三藐三佛陀。现在彼住游行说法。彼佛如来寿命无量。世界清净。此毗毗沙那楞伽王化生彼刹。生彼中已。即得菩萨欢喜之地。如是乃至得菩萨十地。过无量劫数已。于后生此娑婆世界当得成佛。号曰善妙震声金威善净光明现功德宝盖庄严顶相毗卢遮那王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。是最后生彼世界者名电宝冠。除诸山阜坑坎崖阪土石粪秽。无有女身及恶道等。而彼佛刹清净胜彼现在阿弥陀如来佛刹。诸菩萨众充满彼国。劫名善观明。彼佛如来寿命无量。目犍连。是故如来至真等正觉微笑。时毗毗沙那楞伽王。得受阿耨多罗三藐三菩提记时。以为法故。欢喜踊跃遍体战栗。飞上虚空高七多罗树。于虚空中说此偈言

  一切诸法空如梦　　清净非有同虚空
  我及无我悉皆无　　我知如化如电光
  众生有中自生灭　　谛求一法不可得
  初中后等无所有　　畜养众生命亦然
  众生随业得果报　　有中展转不休息
  若行如此菩提行　　得知诸法体皆空

尔时毗毗沙那楞伽王。说是偈已从空中下。绕佛三匝。绕三匝已蒙佛威神却坐一面。时海众中或有天龙阿修罗等证法得果者。或有夜叉罗刹发菩提心者。或有紧那罗摩睺罗伽于诸佛法得无疑者。或有迦楼罗乾闼婆及咒神等得陀罗尼证法得果。于一切法得不退转者。即时大地震动自然光明遍满佛刹。乃至大小铁围山间普皆明照。一切恶道诸苦悉除。上虚空中雨诸天华。响击天鼓叫啸等声。并诸衣服空中舒卷自然显现。如是种种不思议事。时毗毗沙那楞伽王。观其自众如是告言。汝等一切相与和合来向世尊。生恭敬心发于阿耨多罗三藐三菩提心。时彼无量百千罗刹相与和合。向佛合掌白言。世尊。我等聚集相与和合。从今已去归依于佛及以法僧发菩提心。世尊。我等从今已去行大乘行如来证知。世尊。我等于未来世在此娑婆刹中得成正觉。定断恶业为无上尊。为一切众生作利益故。佛言。善哉善哉。汝等若能发菩提心者。汝等当行四种善法。凡善行者。行此四法得不忘彼菩提之心。何等为四。一者所有愿行不违不失。二者于诸众生常行慈心。三者一日三时供养三宝昼夜不绝。四者不愿声闻辟支佛果。此为汝等四法具足不忘失彼菩提之心

尔时海龙王从坐而起。偏袒右肩右膝着地。向佛合掌白佛。世尊。毗毗沙那楞伽王。往昔造何善根。乃能如是广供养具供养于佛及无数声闻菩萨众等。供养讫已发菩提心。发菩提心已证不退转。得受阿耨多罗三藐三菩提记。作是语已。佛告海龙王言。龙王。往昔过无量阿僧祇劫数时。彼有佛号大悲所生智相幢如来至真等正觉应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。而彼如来亦还生此娑婆世界五浊世中。而彼如来至真等正觉。于众生中演说分别三乘之法。龙王。时彼如来亦还住此摩罗耶山顶上。与五百比丘大声闻众无量天龙及非人等。众中说法。龙王。时有罗刹童子名毗毗沙歌。亦还住此楞伽大城。形貌雄猛大腷巨力。其性[革*卬]恶面目鄙丑。唯食肉血口牙可畏。龙王。时彼毗毗沙歌罗刹童子。闻佛世尊住摩罗耶山顶上。即作是念。我不欲此沙门及比丘众在摩罗耶山顶上居住。何以故。若彼沙门住在摩罗耶山顶上者。我不能摄大海杂类。亦无众生可杀害者。我今住此则恒饥饿。龙王。时彼毗毗沙歌罗刹童子。即告其众诸罗刹言。汝等有大力者宜可速来着坚牢甲。各执刀杵槌弩斧戟弓箭鉾楯并金刚杵斗轮槊等。严持如是种种器杖。何以故。我今应当驱彼沙门及沙门众去我境界令其舍离我所住处。龙王。时毗毗沙歌罗刹童子。带好坚甲及罗刹众。各持种种别色器杖。飞行虚空向彼大悲所生智相幢如来。往至彼已住在虚空。与其徒众语世尊言。去去沙门。我不用汝住此山顶。莫复令我杀汝沙门及汝众等。龙王。尔时大悲所生智相幢如来。即现神通现神通已。时毗毗沙歌罗刹童子及其徒众。各见自身被五系缚。又见十方铁网罗布。欲走无路[怡-台+禁]然定住。龙王。时毗毗沙歌罗刹童子及罗刹众。心惊惶怖即生是念。我等今者欲何处去。求归命谁向谁求救谁脱我等难。龙王。尔时彼佛众中有咒神王。名正定深满功德威。与彼毗毗沙歌罗刹童子宿作善友。在彼世尊众中集坐。龙王。尔时正定深满功德威持咒神王。语毗毗沙歌罗刹童子言。善友。诸佛世尊教化人天。所得无量诸功德法三界独尊。众生中宝有大悲行。汝善友及罗刹众。此可归依及以法僧。汝等归依三宝发菩提心。一切系缚即得解脱。说是语已。龙王。尔时正定深满功德威持咒神王。教化力故及佛神力。即时毗毗沙歌罗刹童子及罗刹众。俱共合掌出如是言。南无无边功德庄严身者。南无最上大悲觉者。我等与汝今日已去。归依于佛及以法僧。我等恒行归依三宝。发阿耨多罗三藐三菩提心。龙王。时毗毗沙歌罗刹童子及一切罗刹众。出此言已。一切系缚即得解脱。从虚空来向大悲所生智相幢王如来。至彼世尊三匝围绕。时毗毗沙歌罗刹童子及罗刹众。一切俱时顶礼佛足。于彼如来乞求忏悔。乞忏悔已各还本处。龙王。于汝意云何。汝今当知。是时世中毗毗沙歌罗刹童子者岂异人乎。今毗毗沙那楞伽王是也。时彼世中罗刹众者更非别众今毗毗沙那楞伽王罗刹众者是也。龙王。于汝意云何。时彼世中正定深满功德威持咒神王者亦非别人。即是海妙深持自在智通菩萨摩诃萨是也。作是语已。此三千大千世界即时震动。犹如船舶在大海中随波动摇。众生类中无见惊怖及以害者。唯得一切安隐快乐。一切众生持十善行。时此娑婆佛刹。除去高山须弥大海国土聚落山林海岛黑山龛窟稠林园池河泉陂泽丘陵坑坎崖陇石壁沙卤棘刺。泥粪臭秽可恶除。阎浮檀金大光普照此三千大千世界。所有一切大小铁围山中一切诸闇一切光明。及以日月所不照处彼明遍照隐蔽日月。况余光明一切诸影是时不现。灭除一切地狱畜生饿鬼等苦。即时此娑婆世界诸天人等。若有苦恼一切皆得安隐受乐。若有众生饥者得食。渴者得饮。裸者得衣。贫者得宝。盲者见色。聋者闻声。哑者能语。六根残缺悉得具足。闭在牢狱普皆解脱

大乘同性经卷上大乘同性经卷下

        周宇文氏天竺三藏阇那耶舍译

是时杂类众生。无有贪欲嗔恚愚痴悭妒等心。各各唯有善心慈心安乐之心。犹如父母兄弟姊妹。当于是时一切众生得如是等心行安乐欢喜踊跃遍满诸根。无复寒热及以忧愁。如是一切众生乐心具足。不闻高声及诸大声。复此大地平正如掌琉璃所成。化出种种深广妙池。七宝为砌金沙布底。八功德水清净盈满。彼诸池中自然化出无量莲华大如车轮。彼诸妙华有七宝色。开敷微妙其叶柔软。或复化出无量莲华广一由旬。杂色精妙香气柔软如迦陵伽衣。又复化出百千亿那由他多诸种种莲华庄严。或复化出无量莲华广二由旬。或三四五乃至一十二十三十四十五十及百由旬。或复化出无量莲华广千由旬。是时娑婆佛刹雨大香雨洒散于地。彼水香气柔软微妙能令众生欢喜踊跃。诸微妙风吹彼种种天妙华雨自然堕落。所谓曼陀罗华摩诃曼陀罗华。曼殊沙华摩诃曼殊沙华。月华大月华。意华大意华。雨如是等广大诸华。复有胜妙诸末香雨。复有沉水香多伽罗香黑沉水香牛头栴檀。此等香烟如是出现处处遍满。又复出生过无量百千亿那由他阿僧祇数大如意树。七宝所成纵广高下或一由旬乃至百由旬。最胜端严悉皆乐见。其诸宝树以种种宝衣服缯彩白拂垂眊铃网庄严。彼诸宝树雨于种种精妙七宝。所谓金银琉璃摩尼真珠车磲马瑙赤真珠贯如是等雨。又诸宝树雨种种柔软杂色衣服。所谓歌奢衣俱奢衣憍奢耶衣歌尸歌衣如是等雨。又诸宝树雨诸璎珞。以阎浮檀金所作成就。种种杂宝间错微妙。所谓镮钏耳珰天冠臂印珠绳宝璎金锁璎珞如是等雨。又彼诸宝如意树下。出生百千亿那由他师子之座。各以种种七宝所成。彼师子座高于七刃。菩萨坐上三十二相庄严其身。容貌端严众所喜见。其身内外自然明彻。彼一切诸菩萨前。出生百千亿那由他榻各七宝成。彼诸榻上各千天子而坐其上。奏五音乐并出歌叹。其声精妙能令闻者心意喜跃。其音声中出诸歌赞。说是偈言

  平等无等等　　我所悉皆无
  具功德庄严　　一切世希有
  精进诸苦行　　此法如是生
  微妙庄严事　　故现一切世
  能除地狱等　　此法如是生
  微妙事庄严　　故现一切世
  能除地狱等　　所有生道苦
  及诸有等苦　　是时皆得灭
  除彼尘垢秽　　诸人等痴垢
  善胜微妙事　　故现诸人中
  今者无边刹　　是时皆平广
  大山及诸河　　须弥海悉无
  以琉璃为地　　清净平如掌
  诸宝杂色树　　精妙普乐见
  刹中复有此　　严净焰光明
  金色诸精妙　　翳障于日月
  多种杂宝座　　有诸菩萨坐
  威光如百日　　众相庄严身
  无量诸池边　　周匝摩尼宝
  八分功德水　　清净盈满中
  百千种莲华　　庄严陂池里
  广大如车轮　　展转倍于前
  复有坚牢座　　一切宝所成
  百千亿千天　　天众悉端严
  奏诸微妙音　　赞叹及歌咏
  如来神力故　　出此众妙声

出如是等音乐歌咏事相偈法。有过无量无边阿僧祇法句。尔时世尊集会之中。所有诸天及以人等。有大乘行者乐大乘者信广大意者。因此无边光明力故。见彼一切佛刹如是功德庄严清净。其中天人有行声闻辟支佛行者。不见不知佛刹功德庄严清净。其诸菩萨摩诃萨等在此刹中。悉得无量无边阿僧祇三昧陀罗尼神通法句。复有诸大声闻得入一切寂灭三昧。尔时有师子座纵广正等高百亿由旬。自然而现。七宝所成天衣敷上。时有如来身大无边。现于坐上加趺而坐。其身相好端严无譬显现具足。有大莲花纵广正等高八万四千由旬。七宝所作出现佛前。有无量百千亿那由他莲花。庄严围绕开敷柔软精妙端严。复有过无量阿僧祇数幢幡悬盖。种种杂宝间错而成。于虚空中悬无量无边真珠等宝及诸缯彩。复悬无量无边宝铃罗网。有如是等功德庄严。于此佛刹自然显现。如是不可说无量无边阿僧祇未曾有事。于此娑婆佛刹中现。又不可说不可量不可数大庄严神通之力。昔所未见本未曾闻。于此娑婆世界中。现如是等最大最胜希有之法

尔时弥勒菩萨摩诃萨即发此念。何因何缘。此佛刹中显现希有不可思议大庄严事。神通之力令众踊跃。我当问佛至真等正觉破此疑心。尔时弥勒菩萨摩诃萨从座而起。偏袒右肩以其右膝置莲花上。向佛合掌而白佛言。世尊。我今有疑欲问如来愿开疑网。佛告弥勒。如来至真等正觉常开汝问。若有疑惑当为解说。尔时弥勒菩萨摩诃萨。蒙佛许已白佛言。世尊。是谁因缘有此事相。于此娑婆佛刹。显现如是希有奇特踊跃之法。所谓现神通力一切功德。庄严佛刹胜净严饰明彻无垢。一切恶心悉已除灭。乃至不可称说无有穷尽未曾闻见。世尊。此菩萨众见如是等神通为法。世间显现。一切疑惑。世尊。欲为何事。尔时弥勒菩萨摩诃萨说偈问佛

  世间希有今是何　　显现如是大世尊
  惊怪未曾有斯法　　今于此事生疑惑
  震动大地并巨海　　或有安住净世界
  开敷清净金光网　　除灭世间一切闇
  莲华百千无有边　　复有杂花妙宝树
  亿数幢盖及缯幡　　并真珠贯铃网等
  无量种福慧光明　　灭除一切恶道苦
  世尊何事现此相　　妙净娑婆佛刹中

说此语已。佛告弥勒菩萨摩诃萨言。汝可复坐吾当为汝分别解说。何因何缘大希有法世间现者。弥勒。东方过阿僧祇恒河沙等佛刹。彼有佛刹名清净光轮功德庄严宝缕界厕。彼佛刹有佛名开敷精妙具庄严神通法界轮一盖吼声毗卢遮那藏安自在王如来至真等正觉。现在游行演说法要。世界清净除灭悭贪嗔痴一切烦恼诸恶道等。彼佛刹中十住菩萨摩诃萨之所居住。彼佛刹中有菩萨摩诃萨。名海妙深持自在智通。得一切菩萨禅定三昧神通陀罗尼最为第一持一切宝庄严殿。与过无边数诸菩萨摩诃萨。从虚空中欲来至此娑婆佛刹。是善丈夫威神力故。于此世界作大庄严。神通自在先现是事

尔时世尊说此事已。海妙深持自在智通菩萨摩诃萨及其徒众。即时现大威德光轮庄严之中。有无量亿光明罗网。具足围绕虚空中行。作百千种音乐歌咏。部别各各雨众天花。复放百千亿那由他光明。来至于此娑婆佛刹。即以宝庄严殿安置欲色二界空中。既安置已与其徒众从空中下。至于佛所合掌向佛。接足顶礼围绕三匝。尔时海妙深持自在智通菩萨摩诃萨与其徒众。合掌恭敬白佛言。世尊。唯愿如来怜愍我等。纳受坐此宝庄严殿。世尊。于此宝庄严殿。为大菩萨众说无等等深妙之法。尔时世尊告海妙深持自在智通菩萨摩诃萨言。善哉善哉善丈夫。汝今以此宝庄严殿。奉施如来至真等正觉。善丈夫。汝于此贤劫中毗婆尸佛已来乃至贤劫千佛。以此一切宝庄严殿。过去亦施现在亦施未来亦施。善哉丈夫。乃能以此大宝庄严。严饰此中娑婆佛刹

尔时海龙王白佛言。世尊。宝庄严殿今在何处复若大小。尔时世尊告龙王言。龙王。彼宝庄严殿置在欲色二界空中。纵广三千大千世界。龙王彼宝庄严殿。一切诸佛菩萨神通三昧力故出彼宝殿。一切菩萨安乐之处。堪以供养奉献如来。龙王。得彼宝殿佛所居处。又是如来福力故生。能令菩萨心得清净。复能照明十方世界。使诸众生心意欢喜。隐翳一切诸天宫殿。不可说无边庄严之事成就具足。普告十方一切菩萨皆令觉知。龙王。彼宝庄严殿白琉璃为上。阎浮檀金为壁。功德藏宝以为女墙。马瑙藏宝以为却敌。摩尼宝藏以为栏楯。净光明宝以为栏柱。普光明宝以为其辇。一切众宝以为其座。一切杂宝如半月形。光明无边以覆殿上。八万四千亿那由他柱。杂色端严众宝所成。精妙具足最胜供养称可如来。龙王。其彼宝殿悬诸杂宝无量无边真珠缯彩金铃罗网。立正妙幢悬诸幡盖。牛头栴檀以涂其地。烧坚栴檀及以沉水最上妙香。以之为楯。龙珠宝华间错庄严。以种种华遍散其地。龙王。彼宝庄严殿。一切所有诸殿柱上。无数千亿诸天子坐作天五音。最妙歌赞出声踊跃。诸法明门从音乐出。龙王。彼宝庄严殿周匝轮回大风所持。有千亿七宝妙池金沙为底。八功德水清净盈满。一一池中无数百千亿那由他莲花开敷。七宝填饰妙色端正。是诸莲华大如车轮。龙王。彼宝庄严殿有宝树园。周匝围绕有如意树。种种杂宝花果庄严。悬诸铃网及真珠贯缯彩细叠以为庄饰。出微妙香令心踊跃。种种宝塔妙色端正以为庄严。龙王。一一树下各有七宝师子之座。天迦尸迦衣以为敷具。彼师子座高广微妙成就具足。称可一切诸佛菩萨。龙王。十方所有一切诸佛刹。所有璎珞庄严及诸花雨。一切现彼宝庄严殿。龙王。彼宝庄严殿如是等大及以安住。尔时世尊告菩萨众言。诸善丈夫。为满海妙深持自在智通菩萨摩诃萨愿故。汝等随我向于宝庄严殿彼处俱坐。尔时世尊从座而起。与不可数诸菩萨摩诃萨前后围绕。时海妙深持自在智通菩萨在于右边。弥勒菩萨在于左边。于虚空中安庠而去。向宝庄严殿至彼处已。尔时世尊与菩萨众。入彼宝庄严殿。殿中东面有师子座。高无数由旬纵广正等。是时世尊即坐其上。世尊坐于师子座时。彼宝庄严殿六种震动。出百千亿那由他无量种种大光明网。所谓青黄赤白红紫金色。彼诸天子作天音乐及以歌赞。雨大天花。然诸天香恒不断绝。尔时世尊告菩萨众言。诸善丈夫。汝等各各敷莲华座而坐其上。世尊敕已。彼菩萨众。各就莲华座上而坐。佛及菩萨摩诃萨众皆悉坐已。时海妙深持自在智通菩萨摩诃萨作是思惟。我于今者供养如来至真等正觉。兼复咨请问于佛地。时海妙深持自在智通菩萨摩诃萨即从坐起。随意所生种种无量无边阿僧祇花香涂香末香。花冠衣服幢幡宝盖音乐歌叹。供养世尊及菩萨众。恭敬尊重承事供养。生希有心供养讫已。又复出此胜供养具。所谓宝真珠贯牛头栴檀七宝为花。以大宝珠名师子无碍宝藏。清净明彻以手执持。供养世尊及菩萨众。为供养故散于如来遍覆其上。散已礼世尊足绕百千匝。向佛合掌以偈赞曰

  显现无量妙相身　　平正端严无阙少
  螺髻孔雀乌蜂色　　额平悦泽而广开
  毫相圆开如妙花　　双眉形似初生月
  鼻高隆直妙无譬　　眼如日照青莲色
  耳埵妙如芭蕉茎　　齿齐如白拘勿头
  舌广红色得胜味　　唇厚圆满赤朱色
  妙肩洪满现无阙　　垂臂如风吹婆罗
  爪甲长妙赤铜色　　手指缦网如鹅王
  足下千辐妙轮相　　皆由往昔大施主
  功德胜形师子臆　　体相庄严妙端正
  腰如弓弝金刚杵　　阴相不现如马藏
  髀胫圆满如象鼻　　脚腂端正而平满
  指掌轮相鹅王网　　进止徐庠师子步
  如来具此一切相　　是故顶礼功德王

尔时海妙深持自在智通菩萨摩诃萨赞叹讫已。复白佛言。世尊。我今有疑欲问如来至真等正觉。若佛世尊开我疑问乃敢请说。作是语已。佛告海妙深持自在智通菩萨摩诃萨言。善丈夫。今若有疑恣汝乐问。吾当为汝分别解说令心欢喜。尔时海妙深持自在智通菩萨摩诃萨白佛言。世尊。佛地有几。一切菩萨及声闻辟支佛所不能行。作是语已。佛告海妙深持自在智通菩萨摩诃萨言。善哉善哉。善丈夫。汝今欲令一切菩萨。能作明了利益安乐显现佛智。乃能问于如来此事。汝善丈夫。谛听谛受善思念之。吾当为汝分别解说。善丈夫。佛有十地。一切菩萨及声闻辟支佛等所不能行。何者为十。一名甚深难知广明智德地。二名清净身分威严不思议明德地。三名善明月幢宝相海藏地。四名精妙金光功德神通智德地。五名火轮威藏明德地。六名虚空内清净无垢焰光开相地。七名广胜法界藏明界地。八名最净普觉智藏能净无垢遍无碍智通地。九名无边亿庄严回向能照明地。十名毗卢遮那智海藏地。善丈夫。此地是如来十地名号。诸佛智慧不可具说。善丈夫。佛初地者一切微细习气除故。复一切法得自在故。第二地者转法轮故说深法故。第三地者说诸声闻戒故。又复显说三乘故。第四地者说八万四千法门故。又复降伏四种魔故。第五地者如法降伏诸外道故。又复降伏傲慢及众数故。第六地者教示无量众生六通中故。又复显现六种大神通故。谓现无边清净佛刹功德庄严。显现无边菩萨大众围绕。显现无边广大佛刹。显现无边佛刹自体。显现无边诸佛刹中从兜率天下托胎乃至法灭。示现无边种种神通。第七地者为诸菩萨如实说七菩提分无所有故。复无所著故。第八地者受一切菩萨阿耨多罗三藐三菩提四种记故。第九地者为诸菩萨现善方便故。第十地者为诸菩萨说一切诸法无所有故。复告令知一切诸法本来寂灭大涅槃故。世尊。说此如来十地名已。即时此娑婆佛刹乃至十方不可说诸佛刹等。一切现大十八种相。所谓地动中动大动。小摇中摇及以大摇。小震中震及以大震。小声中声及以大声。小吼中吼及以大吼。小踊中踊及以大踊。是诸佛刹。或东倾西起西倾东起。或南倾北起北倾南起。或中没边起边没中起。一切佛刹如是旋转现十二相。其中无一众生有恼害者。放大胜光照诸佛刹。灭除一切世间诸闇。普得光明。所有一切诸佛刹土。皆悉于此佛刹中现。或佛刹中有佛无佛若成若坏。亦皆于此佛刹中现。彼诸佛刹雨大天花。遍满十方不可说不可说诸佛刹中。所谓曼陀罗花摩诃曼陀罗花。曼殊沙花摩诃曼殊沙花。卢遮华摩诃卢遮花。月华大月华盖月花等。乃至一切刹中所有音乐不鼓自鸣。大希有事皆悉出现诸佛刹中。彼诸佛刹所有侍者。悉从坐起各问如来诸希有事。时彼诸如来为其广说解所疑问

尔时此宝庄严殿中。海妙深持自在智通菩萨摩诃萨及诸菩萨。集坐众等咸悉惊怪。奇哉奇异何因何缘。世尊说此佛深境界如来所行。甚深难知微密难见。一切菩萨非所行处。况诸声闻及辟支佛。何以故。我等未曾得闻如此如来十地不可思议诸佛境界。我等为此善事和合相随。请于如来至真等正觉广说佛地。诸菩萨摩诃萨各从坐起。合掌向佛说偈请言

  最胜无上尊　　此间无等说
  一切佛诸道　　向者已说名
  我等今惊怪　　未曾闻此法
  闻诸地名已　　心意俱踊跃
  如饥思美食　　渴者念甘泉
  如是我欲闻　　愿佛说诸地

说此语已。彼诸菩萨绕佛三匝礼世尊足。各各在于莲花座坐。尔时世尊如师子王。安庠顾视观察十方。观十方已。告海妙深持自在智通菩萨摩诃萨言。善丈夫。如来诸地甚深难知。不可得底难可觉了。出过一切文辞言说。何以故。善丈夫。声闻辟支佛等诸地尚不可说。何况菩萨诸地一切如来佛地名也。时海妙深持菩萨白佛言。世尊。声闻诸地为有几多。佛言。善丈夫。声闻之地凡有十种。何等为十。一者受三归地。二者信地。三者信法地。四者内凡夫地。五者学信戒地。六者八人地。七者须陀洹地。八者斯陀含地。九者阿那含地。十者阿罗汉地。善丈夫。是名十种声闻之地。海妙深持菩萨复问佛言。世尊。辟支佛地复有几许。佛言善丈夫。辟支佛地有其十种。何等为十。一者昔行具足地。二者自觉甚深十二因缘地。三者觉了四圣谛地。四者甚深利智地。五者八圣道地。六者觉了法界虚空界众生界地。七者证寂灭地。八者六通地。九者彻秘密地。十者习气渐薄地。善丈夫。是名十种辟支佛地。海妙深持菩萨复问佛言。世尊。诸菩萨地复有几种。佛言善丈夫菩萨诸地有其十种。何者为十。一者欢喜地。二者离垢地。三者明地。四者焰慧地。五者难胜地。六者现前地。七者远行地。八者不动地。九者善慧地。十者法云地。善丈夫。是名菩萨十种诸地。海妙深持菩萨复问佛言。世尊。一切自地从何处生。佛言。善丈夫。一切自地从佛地生。海妙深持菩萨复问佛言。世尊。解脱解脱彼此何异。佛言。善丈夫。河水海水彼此异不。海妙深持菩萨言。世尊。河水海水广狭有异佛言。如是如是。善丈夫。声闻辟支佛解脱如彼河水。如来解脱如大海水。海妙深持菩萨复问佛言。世尊。诸大小河流入海不。佛言。如是如是。善丈夫。如汝所说。何以故。所有声闻法辟支佛法。菩萨法诸佛法。如是一切诸法。皆悉流入毗卢遮那智藏大海。海妙深持菩萨复问言。世尊。唯愿世尊现初佛地住彼初地。显现一切如来境界。及诸声闻辟支佛等欢喜踊跃

尔时世尊现自佛刹。名无边阿僧祇功德诸宝具盖不思议庄严佛刹王。纵广百千亿那由他恒河沙数三千大千世界微尘等诸佛刹。是时诸佛刹。入无边阿僧祇功德诸宝具盖不思议庄严佛刹中。皆同一名。所有小须弥中须弥大须弥。一切黑山。及小河中河大河及诸大海。诸山林谷槃石峰崖粪秽沙卤险恶之处。悉皆除灭。无有地狱畜生饿鬼等道。及天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等亦悉除灭无有旧佛刹土功德庄严诸璎珞等。此佛刹中所有地际皆琉璃成。平整如掌大因陀罗绀色金刚为佛刹中。出最上微妙庄严宝花阿轮歌林名菩提树王。七宝所成有杂妙色此菩提树王高无边恒河沙佛刹微尘世界。纵广正等。彼菩提王种种妙宝以为花叶果实枝柯师子无碍摩尼杂宝以为庄严。毗琉璃赤真珠贯铃网缯彩。彼菩提树出电光焰不断不绝。或放金光或摩尼光或因陀罗绀光。或颇梨光或日宝光或月宝光。彼菩提树王出最妙香。所谓沉水香多伽罗香黑沉水香多摩罗跋香黑栴檀香龙栴檀香牛头栴檀等香。香气出时遍彼佛刹。其菩提树王出歌赞声或雨宝雨遍诸世界。彼菩提树下。于其东面出生大地。七宝所成清净无浊。名曰摩诃菩提池王。深无边恒河沙等三千大千微尘等世界。纵广正等。以阎浮檀金沙布底。八功德水具足盈满。池四方面各四阶道众宝所填。种种杂宝栏楯具足。彼池水中出大莲花。名善开敷菩提莲花相王。七宝所成。纵广无边恒河沙等三千大千微尘等世界七宝所作。复有百千亿那由他无量无边诸宝莲花周匝围绕。众妙七宝庄严为叶。柔软妙香令人爱乐。其莲花王台上出菩提辇王。名无边宝严饰。七宝所成。高阿僧祇恒河沙等三千大千微尘数等世界。纵广正等。彼宝严饰菩提辇王。所有服饰最胜最多上中之上。彼宝庄严殿中所有服饰所有庄严及神通力百分千分百千亿分不及其一。譬如萤火在日光前其明隐翳。如是如是。宝庄严殿。在无边宝严饰菩提辇王前时。全不复现如是。种种无量无边庄严璎珞。所有服饰神通庄严及以光明。能令一切日月光明悉不能照无有精光。一切帝释光。一切梵天光。一切首陀会天光。于彼无边宝严饰菩提辇王前。所有若明若光若精若照者无有此事。于彼辇中出摩诃菩提师子座王。名善照无碍师子庄严。七宝所成。光色无等众事具足。迦尸迦天衣以覆其上。高百亿恒河沙等微尘等世界。纵广正等。释迦牟尼即便坐彼师子座上。转名无垢威功德师子月光毗卢遮那藏琉璃幢圆通光相功德威聚日月智光王如来。大身正等如百亿恒河沙佛刹微尘敷三千大千世界等。一切身分皆悉具足。满三十二大人之相。八十种好庄严其身。顶背轮光庄严其头。不可见顶其身清净。譬如日月照镜中光。彼如来身亦复如是。无有肉血及以骨髓。非因父母歌罗逻时。其身化生清净如彼阎浮檀金及净琉璃因陀罗宝绀光等色。彼如来身清净如是。无有一切微细习气。彼佛世尊众相具足一切智师。诸法自在度于彼岸无上等觉最胜大慈是最大人。师子丈夫已得漏尽。坚金刚身百福德聚具足十力及四无畏十八不共法。正师子吼。寿命无量清净佛刹。成道自在光明自然。无量无边菩萨之众前后围绕。彼诸菩萨各各色身皆得具足。在宝树下。于彼池中莲华辇上。坐师子座其身相称。菩萨各各而自庄严。犹如如来庄严具足。如是佛刹功德严净。身清净众清净。劫名无边际庄严摩诃劫王。其劫清净若欲说此广大佛刹及佛行者。无有是处。若如是觉名为如来住佛初地

尔时世尊告海妙深持自在智通菩萨摩诃萨言。善丈夫。汝见如来神通智不。海妙深持自在智通菩萨答言。见也世尊。见也如来。佛言。善丈夫。此是佛之初地。名甚深难知广明智德。善丈夫。汝今当知。有正真愿庄严功德相一盖震声主威王如来。宝德明彻藏功德身相净如来。不动离难光明如来。有神通力莲花生功德威相胜璎珞摩尼王如来。在喜乐刹中天人尊重。复有阿弥陀如来。莲花开敷星王如来。龙主王如来。宝德如来。有如是等生净佛刹所得道者。彼诸如来得初佛地。如来在此地中作是神通。如我今日神通无异。海妙深持自在智通菩萨复问佛言。世尊。若有五浊刹中诸佛如来现得道者当成道者。而彼世尊现得当得如来地不。佛言。善丈夫。若诸佛菩萨能现善巧方便者得。所以者何。为诸众生起大慈心。见诸众生闭在三有稠林之中。是诸众生无明闇中爱网所覆。信其不净颠倒邪见。无量诸苦临三恶岸轮回六道。烦恼展转无有前际不知本际。彼诸众生不知诸佛及诸佛法诸菩萨法。亦不如实知诸解脱。善丈夫。诸佛菩萨如是知彼一切众生多受诸苦。善丈夫。尔时应佛出现五浊世界。或兜率下入胎生胎初生。及长宫中喜乐出家。苦行向于道场。降魔成佛转大法轮。与诸外道共论议时。依法降伏傲慢众数。乃至促寿现大涅槃。入涅槃已三昧力故。显现自身分布舍利大如芥子。天龙人非人等生其喜心。为供养故造作无量百千亿那由他诸舍利藏。或有于彼法中出家修持苦行。或为菩提而作种子。度于烦恼有海彼岸。善丈夫。一切诸佛有如此法。令无量无边诸众生等度于烦恼有海彼岸。善丈夫。汝今当知。若五浊世中如来所现神通之力。皆佛应化。或诸菩萨神通力故。善巧方便便化所出。海妙深持自在智通菩萨复问佛言。世尊。佛身几种。佛言。善丈夫。略说有三。何等为三。一者报。二者应。三者真身。海妙深持自在智通菩萨复问佛言。世尊。何者名为如来报身。佛言。善丈夫。若欲身彼佛报者。汝今当知。如汝今日见我现诸如来清净佛刹现得道者当得道者。如是一切即是报身。海妙深持自在智通菩萨复问佛言。世尊。何者名为如来应身。佛言。善丈夫。犹若今日踊步揵如来。魔恐怖如来。大慈意如来。有如是等一切彼如来。秽浊世中现成佛者当成佛者。如来显现从兜率下。乃至住持一切正法一切像法一切末法。善丈夫。汝今当知。如是化事皆是应身。海妙深持自在智通菩萨复问佛言。世尊。何者名为如来法身。佛言。善丈夫。如来真法身者。无色无现无著不可见。无言说无住处无相无报。无生无灭无譬喻。如是善丈夫。如来不可说身。法身智身。无等身。无等等身。毗卢遮那身。虚空身。不断身。不坏身。无边身。至真身。非虚假身。无譬喻身。是名真身。海妙深持自在智通菩萨复问佛言。世尊。若诸佛真体。无色无现乃至不可说。不可说者岂非断相也。佛言。善丈夫于汝意云何。虚空界者可有断绝及有相不。海妙深持自在智通菩萨答言。世尊。虚空界者不可断绝亦无有相。世尊。何以故。若虚空界有断绝者。彼虚空界不名无碍世尊。虚空界无有相处聚处边处色处及以物处。是故世尊。彼虚空界不可断绝非是有相世尊。是虚空界遍一切处。佛言。善哉善哉善丈夫。如是如是善丈夫。如来真实身无有断绝亦无有相。何以故。善丈夫。若如来真实身有断绝者。亦无佛出及现无边神通之力。若有相者。即有聚处及以处所可执可捉。一切凡夫悉皆一时即得成佛。不应依时而有次第。善丈夫。是故如来真实之身。非可断绝亦非有相。惟是普为一切众生作其佛事。海妙深持自在智通菩萨复问佛言。世尊。供养如来真身报身及以应身。所得福业何者最多。佛言。善丈夫。若供养一如来身。即是供养一切佛身。何以故。善丈夫。一切光明能破诸闇普使得明。而此光明不共闇住。如是如是。善丈夫。若有各各供养如来身者。所造福业能破一切是无明闇。开解脱明路。亦复不共诸闇障住。海妙深持自在智通菩萨复白佛言。世尊。唯愿显现第二佛地。佛言。善丈夫。汝能见不。海妙深持自在智通菩萨言。世尊。我于今者欲依相见。尔时世尊一毛孔中即放光明名无相照。乃至不可说不可说诸佛刹。所有诸色一切除灭。尔时世尊问彼一切菩萨众言。汝等今者有何所见。诸菩萨言。世尊。都无所有惟见光明。佛言。诸善丈夫。汝等见此光明何似。诸菩萨言。世尊。我惟遍见无量百千亿那由他恒河沙微尘等诸佛刹一大光明。尔时世尊还摄光明。佛刹如旧如是安住。是时世尊告一切诸菩萨众言。如来若说第二佛地。汝等一切尚难知闻。何况得见如来三地乃至十地。善丈夫。譬如日月光明与一切众生作大利益。彼日月力令众生知有一日半日一月半月乃至一年及以时分。众生不能分别见彼日月色身。汝等惟见光轮形相。如是如是。如来至真等正觉。一切众生作大利益。是如来力。令彼众生得知诸法若罪若福若世间若出世间若有漏若无漏。知诸法已彼如实证。得度一切诸有旷野。彼诸众生不能分别得见如来报身色相。惟观神通力用应化之形。是故汝等应如是知。如来诸地出过于一切音声语言。惟有名字而可说耳

尔时海妙深持自在智通菩萨摩诃萨白佛言。世尊。谁是回度一切恶道。佛言。善丈夫。若有于此一切佛智行入毗卢遮那藏。甚深如来十地大乘同性经典闻已生信。信已受持读诵书写。若教他书广为人说。乃至受持此经典名。善丈夫所有应堕诸恶道者。即皆得度。菩萨复问佛言。世尊。谁是发菩提心者。佛言。善丈夫。若能受持如此经典。乃至受持名字者是。菩萨复问佛言。世尊。谁是行菩萨行者。佛言。善丈夫。若有受持此经者是。菩萨复问佛言。世尊。谁是速满具足六波罗蜜者。佛言。善丈夫。若能受持此经典者是。菩萨复问讯言。世尊。谁是当得值如来者。佛言。善丈夫。若有能听此经典者是。菩萨复问佛言。世尊。谁是值佛得授记者。佛言。善丈夫。持此如来秘密者是。菩萨复问佛言。世尊。谁是为诸众生作大商主。佛言。善丈夫。若有持此如来奥藏者是。菩萨复问佛言。世尊。谁是佛子。佛言。善丈夫。有能信此经典者是。菩萨复问佛言。世尊。谁是当得一切菩萨地。佛言。善丈夫。有能听此经典者。是菩萨复问佛言。世尊。谁是得一切诸佛法者。佛言。善丈夫。有能供养此妙法明者是。菩萨复问佛言。世尊。谁是知声闻辟支佛法而不取彼涅槃。佛言。善丈夫。有能受此妙法藏者是。菩萨复问佛言。世尊。云何名此经。我等云何奉持。佛言。善丈夫。此经名为大乘同性。亦名说一切佛智行入毗卢遮那藏。如是受持。尔时世尊。而说偈言

  欲觉佛菩提　　无上胜精进
  欲转圣无漏　　难思智法轮
  若欲建法幢　　欲打于法鼓
  欲得然法灯　　欲得吹法蠡
  欲得智明照　　欲灭愚痴闇
  欲集诸众生　　安立菩提智
  欲降伏魔军　　供养一切佛
  欲照诸世间　　尊胜妙清净
  不染世诸法　　欲得无漏智
  行行利众生　　欲生清净刹
  教写听授持　　如是妙经宝
  为令通佛地　　读诵及宣扬

尔时世尊说此经已。海妙深持自在智通菩萨摩诃萨。并及一切诸菩萨众。闻佛所说欢喜奉行

大乘同性经卷下


大乘修行菩萨行门诸经要集

    No. 847

大乘修行菩萨行门诸经要集卷上

        大唐至相寺沙门释智严译

诸经要集四十二部

凡菩萨行门总六十六条具列如后

第一出象腋经(显说三条行)

  解六波罗蜜行　修行菩萨为众生故生于六趣受诸快乐　菩萨行空喻

第二出说妙法决定业障经(显说三条行)

  教菩萨行表善知识退菩提因　虽谤法法入耳故当成佛道　解二十四种大乘名号

第三出维摩诘所问经(显说二条行)

  解佛种性因发起修行菩萨行　解出家因缘功德

第四出方广如来智经(显说二条行)

  解非善知识不应同居　挍量声闻道行与修行菩萨行深浅

第五出胜义谛品经(显说二条行)

  修行菩萨起十种行愿速成佛道　解修行菩萨十种戒行成就六波罗蜜

第六出大般若波罗蜜多经(显说四条行)

  修行菩萨初修檀波罗蜜因无散乱发起菩提　解修行菩萨恐散乱菩提心故摄念六波罗蜜　解释烦恼因缘　解修行菩萨初发起菩提心专持六波罗蜜

第七出花严经善财童子经(显说一条行)

  初修行菩萨发起菩提挍量声闻道行譬喻

第八出宝髻所问经(显说一条行)

  解修行菩萨清净持戒行修六波罗蜜

第九出演法师品经(显说二条行)

  修行菩萨挍量声闻法教　又解于诸刹土修行菩萨行门

第十出决定毗尼经(显说二条行)

  解修行菩萨及声闻行人如何住持戒行　解三毒轻重因

第十一出遍清净毗尼经(显说二条行)

  挍量修行菩萨戒行　挍授声闻戒行调伏其心

    已上一十一部入上卷

第十二出海慧菩萨所问经(显说八条行)

  修行菩萨纵犯六波罗蜜善巧方便而能成就不犯　佛说般若波罗蜜深义引喻挍量声闻与菩萨轻重　修行菩萨初发菩提心实能忍辱不令邪魔退失菩提　解忍身口意三业不动成就六波罗蜜　解观行成就六波罗蜜念门　解八种功德与烦恼和杂喻　解四种善行　解修行菩萨所修道行有十二种邪魔障道央俱余钩

第十三出戏乐严经(显说一条行)

  解修行菩萨善巧方便五欲因缘然则劝令发起菩提因而度脱无量众生

第十四出善巧方便经(显说一条行)

  修行菩萨习学声闻行犯重障因

第十五出胜积品经(显说一条行)

  喻修行菩萨退入声闻行

第十六出如来藏经(显说一条行)

  观念如来忍辱因果

第十七出金光上胜毗尼经(显说一条行)

  金光胜童女发十种行愿放出家心开意解

第十八出降伏魔经(显说一条行)

  魔为菩萨说二十种魔障应当自觉不取

第十九出富娄那所问经(显说一条行)

  修行菩萨为恶知识故四种因缘退舍菩提入声闻解脱

第二十出宝童子天人所问经(显说一条行)

  修行菩萨与声闻挍量道行四种实语不妄诸行无厌

第二十一出宝积经(显说一条行)

  修行菩萨与声闻挍量法行　　右已上一十部入中卷

第二十二出虚空藏菩萨所问经(显说一条行)

  说修行菩萨有四十五种魔障若能觉悟兼能超度四魔

第二十三出如来境界经(显说一条行)

  有诸比丘于迦叶如来问法故于今不忘当生弥勒三会

第二十四出阿阇世品经(显说一条行)

  解三乘藏菩萨因又解上座因

第二十五出离垢菩萨所问经(显说一条行)

  空中有菩萨众下佛所是等现身是女人为发菩提心故转为男子

第二十六出文殊师利菩萨所问经(显说一条行)

  修行菩萨修习二种行获十种善根利益

第二十七出光明遍照品经(显说一条行)

  诸有比丘随佛在于逝多林中不见如来威神圣德喻诸菩萨福力殊胜于声闻

第二十八出出生菩提经(显说二条行)

  说三种佛地　又说三乘高下因缘

第二十九出宝聚经(显说一条行)

  初发菩提心人功德多于恒河沙数罗汉无能及可及

第三十出那罗延品经(显说一条行)

  说修行菩萨生于四种住地

第三十一出集一切功德品经(显说一条行)

  修行菩萨投刀请杀愿易生死救度众生不离三界

第三十二出密严经(显说一条行)

  挍量声闻与修行菩萨行业深浅

第三十三出梵刹经(显说一条行)

  修行菩萨每数发忍辱大行愿速进菩提

第三十四出一切诸佛所念经(显说一条行)

  修行菩萨忍辱身口意羞耻三业不复更犯

第三十五出法集经(显说二条行)

  修行菩萨修持十种戒行　复有十种戒行

第三十六出阿差耶末菩萨经(显说一条行)

  一切诸色行人戒力皆有尽时唯修行菩萨戒力无尽

第三十七出集会品经(显说一条行)

  显示三乘法教

第三十八出郁伽长者所问经(显说一条行)

  说在家菩萨应修四种行功德不出家因缘

第三十九出殊胜具戒品经(显说二条行)

  初修行菩萨初发起菩提心应共魔斗堪受无量衣食床卧无障　又释阿耨达龙王以四太河成

第四十出解深密经(显说一条行)

  修行菩萨修六波罗蜜住地行

第四十一出胜鬘经(显说一条行)

  胜鬘夫人以偈赞叹如来如来则现夫人受十大受行愿

第四十二出出生无边门经(显说三条行)

  说持是经陀罗尼者临命终时八十亿诸佛亲来迎接　又表如来三身　又说修行菩萨修四事四事无相行门速成佛道

    右二十一部入下卷

  若欲偏寻当条请依此次第披捡经文

    第一

出象腋经(显说三条行)

  解修行菩萨行六波罗蜜空行　菩萨生入六道救度众生故身受快乐　菩萨修行喻若虚空譬喻

尔时文殊师利童子白佛言。世尊。我有所疑。唯愿如来为众解说。佛告文殊师利童子言。恣汝所问。我当为汝解说其义令汝及众欢喜奉行

尔时文殊师利童子白佛言。世尊。修行菩萨如何住于胜上妙法。显现一切菩萨行门。而能成熟无量众生。喻如满月现于一切佛刹。尔时世尊叹文殊师利童子言。善哉善哉。文殊师利。汝以少问。我今为汝广解所疑。汝当谛听善思念之。时文殊师利童子言。唯然世尊。授教而听。佛言。修行菩萨有六种相应法。善住于一切甚深法趣。何者为六。所谓一者若修行菩萨乐施无吝不见悭心与身有异。身与悭心俱无所得。二者坚持戒行。不见身与非戒有异。身与非戒俱无所得。三者善住忍辱守护自心不见自身与嗔恚异。身与嗔恚俱无所得。四者精勤善行不见自身与慢有异。身与怠慢俱无所得。五者方便净住禅定三昧不见自身。离于诸行亦不和合。三昧定心一切法故俱无所得。六者正智于一切诸法无所得故。乃至不求涅槃不见自身与众生身而为有异。于六趣中见身无异故。文殊师利当知。修行菩萨以此六种法故。成就一切甚深法行。复次文殊师利。修行菩萨复有六种相应法行。善入一切甚深法行。何者为六。所谓一者修行菩萨若生地狱受天快乐。二者若生畜生则受人间上妙快乐。三者若生贫家则受转轮圣王快乐。四者若生六趣。各现本身端严殊胜无能过者。五者善巧方便游历十方诸佛刹土。无去无来安然不动。于一切佛刹示现其身。六者以随类音演说诸法。而不杂乱。文殊师利当知。修行菩萨以是六种法故。善得一切甚深法行

尔时文殊师利童子白佛言。世尊。如何修行菩萨生于地狱而得受天快乐。佛告文殊师利童子言。修行菩萨有三昧。名摩诃钵头摩。得此三昧已。为诸众生入于地狱受天快乐。是诸狱人。见其菩萨受地狱苦。菩萨以福力故。与诸罪人普为说法度脱无量百千众生。文殊师利当知。修行菩萨生于地狱而受诸天快乐

复次文殊师利童子白佛言。如何修行菩萨生于畜生而受人间上妙快乐。佛告文殊师利童子言。修行菩萨有三昧名遍寂静。得此三昧已。则生畜生。不失其念。仍受人间上妙快乐。以畜生身故。与诸畜生解说佛法。度脱无量百千众生。文殊师利当知。修行菩萨为众生故生于畜生而受上妙人间快乐

文殊师利童子复白佛言。世尊。如何修行菩萨生于贫里而受轮王快乐。佛告文殊师利童子言。修行菩萨有三昧。名离缘寂静。得此三昧已。而生贫家与诸贫里众生说法毁呰悭贪无戒赞扬布施持戒善因。度脱无量百千众生。身受转轮圣王快乐

文殊师利童子复白佛言。如何修行菩萨于六趣中为众生故。各随其类。现种种形受诸快乐。皆得殊胜。佛告文殊师利童子言。修行菩萨有三昧。名一切遍光明。得此三昧力故。遍生六趣。方便示现杂类身形。受诸快乐相貌殊胜

文殊师利童子复白佛言。世尊。如何修行菩萨善巧方便游于一切佛刹。无去无来安然不动。如水中月现于一切佛刹。尔时佛告文殊师利童子言。修行菩萨有三昧。名摄一切语言。得此三昧力故。分身现于十方诸佛刹土。而无去无来安然不动。现于佛刹。见诸如来皆闻法要。如是修行菩萨善巧方便遍历一切诸佛刹土。无去无来安然不动。如水中月现诸佛刹

文殊师利童子复白佛言。世尊。如何修行菩萨于一切异类众生随其类音而为说法。是诸言音而无杂乱。佛告文殊师利童子言。修行菩萨有陀罗尼。名阿难哆伐多。得此陀罗尼已。修行菩萨则能了知无量无边众生心。各解其言语而无杂乱。尔时文殊师利童子白佛言。世尊。修行菩萨善巧方便甚难了知。世尊。修行菩萨求于甚深法者。亲近何等法行可知可识。佛告文殊师利童子言。若有修行菩萨乐知是法义者。喻若虚空为对。文殊师利童子言。如何虚空为对。佛言。譬如虚空无贪嗔痴。文殊师利当知。色等诸法亦复如是。无贪嗔痴不异涅槃相故。复次譬如虚空。布施持戒忍辱精进禅定智慧皆无和合为无相故。一切色等诸法亦复如是。无所相应。施戒忍进定慧不异涅槃相故。涅槃亦无和合。复次譬如虚空无弃无别。文殊师利当知。色等诸法亦复如是。无弃无别。涅槃亦尔。无弃无别。复次譬如虚空无知无习。文殊师利当知。一切色等亦复如是。无知无习。涅槃亦尔。无知无习。复次譬如虚空无明无闇。色等诸法亦复如是。无明无闇。涅槃亦尔。无明无闇。复次譬如虚空于一切处无所执得。当知色等诸法亦复如是。不可执得。涅槃亦尔。无所执故。复次譬如虚空无道所得无非道所得。色等诸法亦复如是。无道所得无非道所得。涅槃亦尔。无道无非道故。复次譬如虚空不学声闻解脱缘觉解脱大乘解脱。色等诸法亦复如是。一切乘处无所学故。涅槃亦尔。无所学故。复次譬如虚空无攀无受。色等诸法亦复如是。无攀无受。涅槃亦尔。无攀无受。复次譬如虚空不取不舍。色等诸法亦复如是。不取不舍。涅槃亦尔。不取不舍。复次譬如虚空无有体性无有浊乱。是以一切众生。于涅槃体性。皆无浊乱。涅槃亦尔。无浊无乱。复次譬如虚空于一切处无著无动。文殊师利当知。修行菩萨亦复如是。当知一切众生于一切法无所著故。涅槃亦尔。无有所著。若能如是悟达正智。当知执想诸法则是涅槃知无常故。文殊师利。一切诸法既无实相。若愿见佛身者。不应如是。若非所见则达正位。达正位者于中执相。如是行施非大福田。亦非利他。如是施者不获多福。无所利益。若有所施。不求获多福利者。是名世间乞士。于中所施福利无价。既获无价福利。则得自无所得。福智成就。既获自无所得福智成就已。则能速得无生法忍

    第二

出说妙法决定业障经(显说三条行)

  解善知识不退菩提　解邪魔故闻法故闻法诽谤已闻法故后当成佛　解二十四种大乘名号

如是我闻。一时佛在法界藏殿诸佛所会无边道场。与大比丘众菩萨摩诃萨俱。时此道场有一夫人。名曰功德庄严开敷花。合掌向佛。退坐一面

尔时夫人白佛言。若有初修行菩萨。何等之人非善知识。不应共住。佛告夫人。若三界中。梵释四王沙门婆罗门。皆与修行菩萨为善知识。唯除声闻非善知识。恐声闻退修行菩萨大乘道行。何以故。声闻缘觉为己利故。劝引初修行菩萨。回入小乘。是以声闻乘人非善知识。夫人当知。初修行菩萨。不应与声闻比丘同居房舍不同坐床不同行路。若初修行菩萨。智慧弥广无二分别。悟大乘法而为方便劝引声闻。令入大乘方许同住。若声闻比丘。福智狭劣。则修行菩萨不应为说甚深大乘。恐其诽谤。复次修行菩萨不应数览小乘经论。何以故。为障佛道故。夫人当知。修行菩萨宁舍身命不弃菩提而入声闻求罗汉道。菩萨劝请一切众生已。尔时若舍菩提之心别起异道入于声闻罗汉道果因恼乱故。菩萨而退菩提二人俱堕无间地狱。佛告夫人。修行菩萨。宁犯杀等五种大罪。不学须陀洹果。不退菩提修行。菩萨宁于一劫百劫乃至千劫。受地狱苦。不学斯陀含果。不退菩提修行。菩萨宁堕畜生。不学阿那含果。不退菩提修行。菩萨宁杀害众生堕于地狱。不修阿罗汉果。不退菩提。罗汉独证私入涅槃。譬如小贼密入他舍。修行菩萨菩提心故。摄诸众生。宁同火坑。不住声闻寂灭涅槃。不退菩提。以是义故。为摄众生令入佛道故。如是修行菩萨一切世间天人阿修罗之所尊重。堪任供养。超越声闻则邪魔眷属无能娆恼

尔时夫人白佛言。何者邪魔眷属。佛告夫人。敷演大乘经典之处。若有众生闻说大乘。心不乐闻。调弄诽谤。当知则是邪魔眷属。诽谤大乘经典心故。死堕阿鼻受苦无量。复生饿鬼食火屎尿。无量劫中。受苦毕已。后生人中。盲聋喑哑病癞不具。此等众生命终之后。经无量生。方得值遇如来。亲承供养于诸佛所。还复得闻大乘经典。纯一无杂。尔时如来于诸毛孔。普出言音。一一毛孔。出无量亿百千法光。复生无量法音偈赞。时此会中若有声闻。则闻声闻乘法。若有缘觉乘人。则闻缘觉乘法。若有大乘行人则闻大乘妙法。鸟兽之类。各随其音。而闻佛法。于此会中。所有众生过去未曾耳闻佛法。皆见如来默然不语。其余众生。过去曾谤大乘经故。虽于多劫堕在地狱饿鬼受苦。由谤法时大乘入耳是故佛所亲闻大乘。心生欢喜而发无上菩提之心。究竟成就阿耨多罗三藐三菩提

尔时夫人白佛言。所说大乘何故名为大乘。何故说为大乘。佛告夫人善哉善哉。夫人深乐大乘以是义故善思念之。当为汝说大乘名号。所谓一者令人深乐。是名大乘。二者不动是名大乘。三者无过是名大乘。四者无量是名大乘。五者如四大海是名大乘。六者金翅及紧那罗摩睺罗伽杂类所敬。是名大乘。七者乾闼所赞。是名大乘。八者诸天恭敬。是名大乘。九者梵天归依。是名大乘。十者天帝所敬。是名大乘。十一者四王所摄。是名大乘。十二者龙王供养。是名大乘。十三者菩萨奉持。是名大乘。十四者成就佛性。是名大乘。十五者贤圣归依。是名大乘。十六者一切普堪所受。是名大乘。十七者如药树王。是名大乘。十八者断诸烦恼。是名大乘。十九者能转法轮。是名大乘。二十者无言无说。是名大乘。二十一者如虚空相。是名大乘。二十二者三宝种性无断。是名大乘。二十三者钝根众生不信。是名大乘。二十四者超过一切。是名大乘

尔时佛说大乘威力名号之时。此三千大千世界六种震动。百千乐器不鼓自鸣。则于空中。诸天雨花无量。百千天子皆发无上菩提之心。无量百千声闻皆发阿耨多罗三藐三菩提心。复有初戒菩萨未悟法者。皆已悟解。尔时阿难白佛言。世尊。此法何名如何奉持。佛言。是经名为大乘巨拏胜斯受持。又名说妙法决定业障受持。如来说此经已。阿难及功德庄严开敷花夫人。及诸天龙八部。皆大欢喜。持受奉行

    第三

出维摩诘所问经(显说二条行)

  解佛种性因缘发起菩提　解出家因缘功德

尔时维摩诘长者。白文殊师利菩萨言。汝善明解如来种性。于意云何。何等为种。文殊答言。善男子。是诸佛性。五阴种性。无明生死种性。贪嗔痴种性。四倒妄想种性。五盖种性。六入种性。七识烦恼种性。九恼灭坏身心种性。十恶不善种性。善男子。略要言之六十二见及一切烦恼。皆是如来种性。时维摩诘问言。汝何义故云一切烦恼是佛种性。文殊师利答言。善男子。若执见无为已住定灭。是人不应发得阿耨多罗三藐三菩提。若菩萨住于烦恼。住地见正位实相。是人堪任发得菩提。譬如陆地不生莲花。青淤泥中而生莲种。善男子亦复如是。若声闻缘觉。住于无为灭定。佛种花芽无复更生。烦恼淤泥池中能发菩提。因烦恼故。佛种芽生。善男子。譬如空中种子不生。粪壤之地乃能茂盛。善男子亦复如是。不应无为灭定而生菩提。若起我所非我所心等于须弥仍堪发生菩提。而生佛种无量智慧。善男子。譬如不入四大海水无由取得无价宝珠。善男子亦复如是。若不入烦恼大海。无由取得佛性宝珠。当知菩提种性本从烦恼中来

尔时长老摩诃迦叶。叹文殊师利菩萨言。诚如所说真实不虚。如是佛种皆是烦恼种性。何以故。我等声闻无复堪任发生菩提。我等为烧灭三界烦恼种子。我等宁以无间五逆不应断解世间烦恼。何以故。若人已造五逆恶罪受毕究竟。还复发生菩提之心。亲闻佛法显现佛事。若阿罗汉。烦恼已尽无复后有。无能发得阿耨多罗三藐三菩提。譬如有人五根总坏。是人识心不堪更起罗汉亦尔。烦恼总坏诸结已除。既无力故不堪扶持无上菩提。以是义故。凡夫亲近于佛。声闻辟支远离菩提何以故。凡夫数闻三宝威力无量种性。则发菩提。不断阿耨多罗三藐三菩提心。若声闻缘觉。虽曾闻说如来圣德十力无畏十八不共。亦不堪任发得菩提

佛告罗睺罗。汝诣维摩诘问疾。罗睺罗白佛言。世尊。我不堪任诣彼问疾。所以者何。我念昔时鞞舍离城。有诸族姓子来诣我所。稽首作礼而问我言。唯罗睺罗。汝佛之子。舍转轮王位。出家为道。其出家者有何等利。时我与诸族姓。如法为说出家功德因缘。说此法时。维摩诘而来我所。稽首我足。而谓我言。唯罗睺罗。汝今所说出家功德不应如是。所以者何。夫出家者。无利无功德。是为出家。有为法者。可说有利有功德。夫出家者。无为法故。无为法者。无利无功德。远离一切诸行处。于涅槃智趣所受圣所行处。降伏众魔。度五道。净五眼。定五根。施无畏不恼于他。不染杂恶。摧诸外道。超越假名。出离犯戒淤泥池中。我所无著无我所。无所受。亦无扰乱。调伏身心。摄护他众。随禅定离外过。一切处而无所取。若能如是出家名为善出。汝等于正法中宜共出家。善学律仪诸佛法教。所以者何。人身难得。佛世难逢。无上菩提甚难发起。尔时此等诸子。白维摩诘言。我等闻佛所说。若父母不听不得出家。尔时维摩诘长者告诸童子言。汝等但发阿耨多罗三藐三菩提心。常修梵行。是则出家功德

尔时此三十二族姓子。皆发阿耨多罗三藐三菩提心故。我无言可答。以是义故。我不堪任诣彼问疾

    第四

出方广如来智经(显说二条行)

  解善恶知识菩萨不应声闻同居　解修行菩萨与声闻校量道行深浅

尔时佛告摩诃目揵连。善男子。当知善知识故教道诸法菩萨而成阿耨多罗三藐三菩提。是以初修行菩萨。不应学声闻缘觉小乘教道。何以故。一切破戒邪行之人。是菩萨善知识。若声闻缘觉。障佛道故。则非善知识。何以故。犯戒之人不堪破于菩萨正行。是犯戒邪行之人法无力故。不能障于菩萨佛道。若声闻缘觉。以世谛无我复无烦恼。以是智故。能令初学菩萨入于声闻教道。当知声闻非是菩萨善知识也。修行菩萨宁与破戒邪行交通。不与声闻缘觉乘人受法。何以故。犯戒邪行。虽共交通身相远离。若声闻人。行坐不离。譬如家贼不离其侧。以是义故。菩萨不应与声闻人习学交往。譬如野干不堪师子同居。当知声闻与其菩萨亦复如是。何以故。声闻修学唯利己故。若修行菩萨专求佛道度脱众生。声闻唯见一身趣路。若菩萨善行正路导引众生。声闻唯净己心。若菩萨能净己心亦净众生。声闻唯自除烦恼。若菩萨自除烦恼。亦能除灭众生烦恼。声闻入邪疾路独避世间。菩萨自入正路导引众生。声闻唯除习气烦恼。菩萨成等正觉。习气都灭烦恼悉除。声闻异道入于涅槃。菩萨自证正道无余涅槃。声闻入于寂灭涅槃。其法亦灭。若菩萨成等正觉已入无余涅槃。法仍不灭。十力无畏十八不共四圣谛三十二相八十种好无量佛事神通不灭。当知声闻及辟支佛。皆无是德

    第五

出胜义谛品经(显说二条行)

  修行菩萨起十种行愿速成佛道　解修行菩萨十种戒行成就六波罗蜜

尔时普贤菩萨语普智菩萨言。佛子修行菩萨。为求阿耨多罗三藐三菩提故。应起十种行愿。何者为十。所谓一者愿度一切众生。二者令其远离一切烦恼。三者除灭相续习气。四者于一切佛法无所疑惑。五者除救众生一切苦聚。六者愿救众生三涂八难。七者归依亲侍一切诸佛。八者愿学菩萨一切戒行。九者升于空中示现毛端无量佛事。十者以大法鼓击动一切佛刹。众生闻者随机速入无余涅槃。当知初学菩萨如是修行。若住此地不久而起如来行愿

复次佛子修行菩萨。复有十种戒行。何者为十。所谓一者究竟不退菩提是其戒行。二者远离声闻辟支佛地。三者常为一切众生身心利故。四者令一切众生住于佛行。五者受持菩萨戒行无令缺犯。六者开悟一切诸法。七者所修功德回施十方愿成佛道。八者不应分别如来法体。九者一切世法无所贪着。十者防护六根无令染着。佛子是修行菩萨十种戒行。若菩萨能住此地不久圆满戒行六波罗蜜。成就无上菩提

复次修行菩萨。复有十种退道迷路。应当远离每自察心。何者为十。所谓一者不敬师僧和尚及善知识。是其迷路。二者怖畏世苦。是其迷路。三者所修戒行忽生悔心。是其迷路。四者不乐住于诸佛刹土。是其迷路。五者不乐三摩钵低。是其迷路。六者修少分功德便以为足。是其迷路。七者诽谤大乘。是其迷路。八者远离菩萨戒行。是其迷路。九者乐阿罗汉辟支佛道。是其迷路。十者若见修行菩萨心生憎嫉。是其迷路。佛子如是十种菩萨迷路。能远离不久当入解脱法门

复次修行菩萨。应有十种行愿。何者为十。所谓一者愿我为诸众生尽未来劫住于世间。如是愿者是普善愿。二者愿我最后亲侍供养一切诸佛。如是愿者是普善愿。三者愿我令一切众生住于普贤菩萨行愿。如是愿者是普善愿。四者愿我积集一切戒行功德。如是愿者是普善愿。五者愿我普修六波罗蜜。如是愿者是普善愿。六者愿我满足菩提戒行。如是愿者是普善愿。七者愿我庄严净一切佛刹。如是愿者是普善愿。八者愿我生于十方佛刹。如是愿者是普善愿。九者愿我深求一切佛法善自开解。如是愿者是普善愿。十者于诸佛刹成等正觉。如是愿者是普善愿。佛子当知。是修行菩萨十种大愿。以愿力故。速获菩萨具足行愿

复次修行菩萨。复有十种魔障。何者为十。所谓一者忽生退心我不成佛。是其魔障。二者正起勤修忽然弃舍。是其魔障。三者少分功德而生厌足。是其魔障。四者乐住隐僻善行俱舍。是其魔障。五者弃舍一切善愿。是其魔障。六者舍断烦恼乐修灭定。是其魔障。七者断割世法。是其魔障。八者退舍菩萨道行。是其魔障。九者不乐劝化众生。是其魔障。十者诽谤佛法。是其魔障。佛子当知。是修行菩萨十种魔障。若菩萨远离是等。不久速得如来十种记别地位

    第六

出摩诃般若波罗蜜经中(显说四条行)

  初修行菩萨初学檀波罗蜜发起菩提心

  无散乱已菩提心散乱故摄念六波罗蜜行

  解烦恼因缘

  菩萨初发菩提心持六波罗蜜行

尔时圣者舍利弗语圣者富娄那言。复次富娄那修行菩萨。应当初学檀波罗蜜。何以故。贪惜世业无始习气。若修行菩萨舍施之时。悭心则舍。因则能发菩提心。若发菩提则能渐渐增长成就。若渐增长成就。则渐远离二乘。若渐远离二乘。则复升进阿耨多罗三藐三菩提。譬如雨中安置瓦瓶。是瓶所入第一雨滴。及最后滴。非缘前后二滴水。瓶得满要其中间。雨滴渐入而得盈满。富娄那当知亦复如是。若修行菩萨不应以初发菩提心故而成佛道。亦不以最后菩提树下而成佛道。以是义故。初发菩提心故。乃至最后于其中间。菩萨渐证佛道。发起种种善行。三阿僧祇修行利益资助佛道。是以仁者富娄那。修行菩萨不应散乱心无所染

尔时圣者富娄那语圣者舍利弗言。修行菩萨如何摄心而无散乱。舍利弗言。菩萨助佛道故。若发邪行恶见将为善利。当知我今所发恶行。应是菩提利故。何以故。为我是邪见不断世间生死。是以我身变易世间。方便利益无量众生。以是义故。修行菩萨如是智慧心无散乱

尔时富娄那语舍利弗言。若菩萨菩提心乱。如何相貌而得知耶。舍利弗言。此心散乱。是声闻缘觉乘人障其道故。若求二乘道果。当知则是散乱心也。何以故。二乘道行不应菩提。若修行菩萨贪嗔痴见尚不散乱。何以故。为此三毒见助佛道故。转易生死利益菩提。以是见故生于世间。善巧方便圆满六波罗蜜。修行菩萨以资助烦恼故。得阿耨多罗三藐三菩提。富娄那。当知若修行菩萨摄念心故。而生障善。当知则是散乱。复有相应声闻辟支佛摄念菩萨。亦是散乱。若非此等摄念。不断生死资助道故。不应乱心。何以故。为摄念故。修行菩萨在于世间。以善巧方便。摄念相续。不断生于世间。生已则受檀波罗蜜持戒波罗蜜忍辱波罗蜜精进波罗蜜禅波罗蜜智慧波罗蜜。修学如是。摄念资助世间生死道故。修行菩萨应当如是授学。乃至成佛。而无有舍。富娄那。当知修行菩萨不应厌离烦恼。何以故。以智识别烦恼。作是思念。是等烦恼饶益我身。助我成佛。若此烦恼有相。可以上妙供养。何以故。为此烦恼故。修行菩萨常所护惜烦恼。以是义故。应当以智识烦恼因。何以故。为我善巧方便。不摄三界系缚。令我增长圆满六波罗蜜故。速得菩提。若六波罗蜜渐渐增长。我则解脱世间生死系缚而得宽慢。富娄那。当知譬如车载重物。以车重故车轴渐渐研磨载物才入到城。其轴事毕则断。当知因烦恼故。三界而有生死修行菩萨若烦恼故。续续生于世间。六波罗蜜则得增长圆满。若六波罗蜜渐得圆满。则生死烦恼渐得微薄。若生死烦恼渐薄。则能决定渐近佛位。若修行菩萨坐菩提树已。则起萨婆若智。前后烦恼当则断灭。无复更生。是诸烦恼所作已办。菩萨成正觉已。烦恼无复有缘。譬如车轴载重入城。事毕然乃始断。修行菩萨若成阿耨多罗三藐三菩提已亦复如是。烦恼事办无复有缘。是以当知为是利故。中间不断烦恼。修行菩萨纵被嗔骂。返从乞求所须。皆是助道善缘。发起菩提心故。若摄罗汉心智亦是。修行菩萨助佛道故。若无罗汉行门。如来从何制修罗汉道果。以制修故。而助佛道

尔时世尊于摩诃般若伽他所说。譬如世间若树木无芽则无树身。若无树身枝叶花果无由盛茂。当知众生若无菩提芽种。诸佛不现世间。若佛不出于世。声闻从何而起譬如明灯要赖炷心。而是炷心不因第一火焰而能烧尽。亦非不因初焰而尽。复非后焰烧灭而尽。亦非因后焰而尽。以是义故。前后中间焰焰相续故。炷心烧尽。菩提亦尔。非缘初心成佛。亦非后心。前后中间相续心故。而能成佛。何以故。刹那刹那菩提心故。而成佛道。若修行菩萨布施不着我相人相受者相。心无所求无悭吝心。如是布施。纵施少分等施无量。则是修行菩萨。具足檀波罗蜜行

复次修行菩萨若恒念如来圆满威神。显扬圣德。则是菩萨甚深戒行。若菩萨渐减佛说戒相则亏。若修行菩萨顺世法故。虽受五欲心念三归。是故愿我成等正觉救度众生。此则已住持戒波罗蜜行。修行菩萨如是智慧念心不犯不名犯戒。若修行菩萨于亿劫中。虽持十善戒行。若乐声闻阿罗汉果。当知则是增上缠犯亏于大乘。是为修行菩萨持戒波罗蜜行。复次若修行菩萨发广大心见诸众生。禁闭牢狱枷锁杻械栲楚鞭挞。斩其头项割截手足耳鼻身分。尔时菩萨念言。愿我代彼普受诸苦。令一切众生皆得安乐。若有恼我难忍能忍心无恶对。当知如是修行菩萨则是慈忍波罗蜜行

复次修行菩萨愿为众生乐住世间成熟众生。清净佛土苦行逼恼行而无疲倦。当知则是菩萨精进波罗蜜行

复次修行菩萨若色声香味触五欲所缠。不乐声闻罗汉道果专念菩提。当知是人恒在禅波罗蜜行

复次譬如商人欲入大海船舶不修。商人及财陷没当尽。若预修船宽广牢固。商人及财皆达彼岸。修行菩萨虽有道心。若无坚牢智慧。不久退失菩提。是以智慧波罗蜜。成就菩提无所缺陷。速成阿耨多罗三藐三菩提。刹那一念无上菩提。则是修行菩萨过于无量二乘功德。智慧波罗蜜行

    第七

出花严经入法界品(显说一条行)

  初修菩萨发起菩提心故喻类声闻无所能及

善男子。譬如师子兽王。为诸兽故哮吼大声。以其声故。师子初生子而得肥壮勇健跳梁。诸兽闻其大声悉皆逃窜。初修行菩萨。喻若师子初生子息。菩提发吼菩萨亦复如是。是以如来萨婆若智。为初修行菩萨故。吼赞佛性。皆以如来善教引故。菩萨而得智慧勇健。菩提增长。若诸众生贪着烦恼而自损减。譬如师子身筋造作筝弦其音若奏余弦悉断。如来以波罗蜜。成熟菩提起发心故。若有赞叹五情俱断二乘道行皆悉俱断。譬如以象牛杂乳盛满大池。若以师子真乳一滴入池。是诸杂乳悉皆流出不住同池。菩提心乳亦复如是。百千劫中积恶罪业。以师子菩提心故。罪障悉皆坏灭无余。二乘解脱与菩提种性不堪同居。善男子。譬如迦陵频伽。犹在卵中若发声音雪山大鸟声不能及。修行菩萨亦复如是。生死卵中发大菩提心故。所修功德大悲势力。若声闻缘觉无能及者。善男子。譬如金翅鸟王。其子初生目则明利飞则劲捷。一切诸鸟虽久成长无能及者。修行菩萨亦复如是。发菩提心为法王子。智慧清净大悲勇猛。一切二乘虽已历劫久修道行。皆不能及

    第八

出宝髻所问经(显说一条行)

  解修行菩萨一种持戒清净行波罗蜜

尔时佛告宝髻菩萨言。善男子何者是修行菩萨。持戒波罗蜜清净行。善男子。修行菩萨有一种持戒清净行。何者为一。所谓于无上菩提而舍心复有。是心若不相应事者而能相应。是心于三界中胜上为最。是心超越声闻缘觉。是心能救一切度达三界众生至于彼岸。是心能类无价宝珠而为等量。是心深重护念无舍使无暂忘。善男子当知。修行菩萨为十种尸波罗蜜清净行。何者为十。所谓三种身净行。四种口净行。三种意净行。是为十无尽清净戒

    第九

出演法师品经(显说二条行)

  修行菩萨挍量声闻法教　修行菩萨于诸刹土修学菩萨行门

尔时佛告舍利弗言。舍利弗。譬如有人自言我能入大海至海底坐。是人既见海已则于牛迹涡中动摇手脚自云我学拍浮。他人告言。汝自昔云我入大海取海底坐。何故今日不入海中。其人答言。我先于此牛迹水中习学。然后方入大海。舍利弗于意云何。是人所修邪正。以不所拟作者。善巧方便以不所执。我入海底。先于牛迹涡中习学。舍利弗言。不也世尊。若人愿入大海。必须入海习浮。佛告舍利弗。亦复如是。佛入涅槃后。世有法主比丘比丘尼优婆塞优婆夷。于是大乘经典信心供养。显扬如来智慧圣德恭敬尊重。既缘大乘深义。智慧狭劣不达其底不解其义。后时依止声闻。修习杂学阿含经论。以名闻利养故。与诸檀越交通。若有比丘。不习大乘经者。随顺递相谄曲心故。构引伴侣乐学声闻。牛迹水涡习学拍浮。舍利弗。以是义故。若修行菩萨所将大乘经典而求佛智者。是修行菩萨应学如来威仪集行。若如来在于无智众中。不共交通亦不所受。除施法外默然不语。修行菩萨亦复如是。如闻诸佛刹土诸大菩萨摩诃萨见在。住持百千善巧方便。于诸百千刹土。习学教授亿百千众生。令得神通大力而得善行功德。舍利弗。修行菩萨应当于诸刹土随诸菩萨习学法行。复应学彼威仪行业禅定解脱三昧三摩钵帝善巧方便威神五通解脱故。随其修学。然于空闲静处。心念十方刹土诸大菩萨随机方便。不应乐入声闻智慧受持习学

    第十

出决定毗尼经(显说二条行)

  解声闻及菩萨如何授教戒行律仪相应　又解三毒类定轻重

尔时圣者优波离。从禅定起。诣于佛所稽首顶礼退坐一面。而白佛言。世尊。我今向来宴坐入定而有所思。世尊。先为声闻缘觉乘人。及初修大乘行菩萨。为其制戒清净律仪。如来所说。宁舍身命不得犯戒。我于毗尼律藏。名为上首。今如来在世若复涅槃。我当云何教授戒律。若声闻缘觉乘人修持禁戒不令缺犯。复当云何。教授初修大乘行菩萨修持护戒。世尊。是以为我广说教迹。我今密于佛所听闻授记。我则以佛威神力故。敢当自制我若摄授禁断律仪。愿佛慈悲为我宣说。云何犯戒。云何无犯。世尊今此会中声闻菩萨无量众集。堪可表示

尔时优波离说此语已。佛告优波离言。汝为声闻应机别说清净戒行。复为初修大乘行菩萨故。善巧方便应机别说清净戒行。何以故。优波离。若声闻持戒当知戒行差别。与初修大乘菩萨戒相违背。则非菩萨净戒。若初修大乘菩萨持戒清净。则与声闻戒行违背不同。非是净戒。所以者何。若声闻志愿力故乃至刹那不求世间生死。亦无所乐亦无所愿。是其声闻清净戒行。若初修大乘行菩萨志愿力故。愿我无量劫时。于此苦海救度众生。心无疲倦。是其初修大乘行菩萨清净戒行。以是义故。优波离当知。各为随机当说禁戒。若为初修大乘行菩萨说戒顺于他心无恼众生。若为声闻说戒利己不顺他心。若为初修大乘菩萨说戒宽容方便。若为声闻说戒无所宽容禁戒严切。若为初修大乘菩萨说戒。可以长远无相所说。若为声闻说戒。可以严切。执见有相为其所说。优婆离。何故初修大乘行菩萨。兼顺他意而令修学。何以故。声闻不顺他意而令修学。优波离当知。初修大乘行菩萨。各各随机引化众生。顺他心故无所恼故修持戒行。若声闻则非他心故修持戒行。何故初修大乘行菩萨戒行宽容无犯。何故声闻禁戒笮狭严切。优波离当知。若初修大乘行菩萨晨朝有犯应当结罪至午。若菩提心无间断戒聚成就则非所犯。若当午时有犯至于黄昏。菩提心无间断戒积成就则非所犯。若黄昏有犯至于初夜。菩提心无间断戒积成就则非所犯。若初夜有犯至于中夜。菩提心无间断戒积成就则非所犯。若中夜有犯至于后夜。菩提心无间断戒积成就则非所犯。优波离当知。初修大乘行菩萨戒行宽缓。若有菩萨结罪有犯不应悔惧。复次若声闻犯戒戒相则灭无复更全。何以故。若声闻持戒除烦恼故。如救头然烧衣。心速为求寂灭涅槃。坚持戒行。云何初修大乘行菩萨。长远修行无相无著不离世间。云何声闻执相一生断灭现前修学。优波离。若初修大乘行菩萨喻若恒河沙劫虽受五欲快乐。菩提心无暂舍。当知是菩萨戒行无缺。何以故。为初修大乘行菩萨。后时成熟菩提心故。若在睡眠五欲尚无所染。况在觉悟。所以者何。若初修大乘行菩萨。不应一生总断烦恼。若菩提成熟烦恼自灭。若声闻修习道行。犹未成熟。是等其心刹那不愿更生世间。是以一生迅速修行。喻若救头。优波离当知。初修大乘行菩萨。长远心无厌倦随入修行应知。声闻一生暂时修学。以是义故。优波离。汝若为初修大乘行菩萨。教授说戒宽遮顺他意故。长远深邃教其修学。若为声闻。教授说戒不应顺他亦无宽缓。何以故。初修大乘行菩萨。为大因缘修法器故。而成阿耨多罗三藐三菩提。菩萨不应厌惧世间。愿我无量长远劫时。为众生故。受生死苦。是以如来不为修行菩萨。而说出离三界生死苦海悔过因缘。所以者何。如来为修行菩萨故喜悦欢心。为说甚深清净因缘。无过无缠无障空相如是与其言说。若菩萨闻是说已。乐住世间无有厌倦。乃至成就阿耨多罗三藐三菩提

尔时圣者优波离白佛言。世尊。说有三种三毒重罪。或缘贪欲相应。或缘嗔恚牵缠。或为愚痴。何者最重。何者最轻。愿为初修大乘行菩萨。说其轻重方便戒行

尔时佛告圣者优波离言。若初修大乘行菩萨。以恒河沙劫。常犯贪欲种类罪故。若信受大乘而生一念嗔心。结罪重于贪欲。何以故优波离。若嗔心发动则能舍弃众生。若舍嗔贪欲心发则摄众生。菩萨而无厄难。何以故。优波离。佛说若犯贪欲舍离稍慢。犯罪稍轻。若犯嗔恚解离稍速。获罪甚重。若犯愚痴解离则速得罪稍深。优波离当知。三毒轻重如是。修行菩萨应当守护善巧方便智慧心故。无令缺犯

    第十一

出遍清净毗尼经(显说二条行)

  解释菩萨行声闻行各各如何调伏其心　类于二乘轻重

尔时寂净天子白文殊师利童子言。初修行菩萨。云何调伏其心。若声闻比丘。云何调伏其心。文殊答言。厌离三界心惊动故。则是声闻调伏其心。若摄授世间无量法故。不断生死一切众生而施无畏利众生故。乐住世间。则是修行菩萨调伏其心。若厌离功德资粮。则是声闻调伏其心。若集智资粮功德无厌。则是修行菩萨调伏其心。若厌见一切烦恼则是声闻调伏其心。若摄一切众生烦恼。则是修行菩萨调伏其心。若不为众生故不念诸佛圣德。则是声闻调伏其心。若为一切众生故显现诸佛圣德。则是修行菩萨调伏其心。若所修行业诸天不证。则是声闻调伏其心。若复所修业行三千大千世界诸天普证知闻。则是修行菩萨调伏其心。若舍一切魔军。则是声闻调伏其心。若三千大千世界所有魔军令其发动。菩萨而能摧伏。则是修行菩萨调伏其心。若不明自身心量。则是声闻调伏其心。若明一切刹土诸佛如来圣德。则是修行菩萨调伏其心。若唯为自身。则是声闻调伏其心。若为众生故。修习摄念一切诸佛圣德。则是修行菩萨调伏其心。若为小乘解脱执速。则是声闻调伏其心。若以刹那智慧成熟菩提。则是修行菩萨调伏其心。若断灭三宝种性。是声闻调伏其心。若修学三宝种性。则是修行菩萨调伏其心。若喻瓦瓶坏破无复更全。则是声闻调伏其心。若喻金器破坏修持如旧。则是修行菩萨调伏其心。若以善巧方便不具。则是声闻调伏其心。若善巧方便相应。则是修行菩萨调伏其心。若十力四无所畏不具。则是声闻调伏其心。若以十力四无畏心相应。则是修行菩萨调伏其心。若避世间如避火坑。则是声闻调伏其心。若乐住世间如游园苑居住殿堂。则是修行菩萨调伏其心。若不具六波罗蜜并四摄事。则是声闻调伏其心。若修六波罗蜜并四摄事坚持摄念。则是修行菩萨调伏其心。若不断一切宿缘习气。则是声闻调伏其心。若除相续一切习气。则是修行菩萨调伏其心。略要言之。若心着数量亲近量法习学有量戒行三昧智慧解脱解脱知见。则是声闻调伏其心。若非量数以无量系亲近无量善巧方便所学戒行三昧智慧解脱复缘解脱所见。则是修行菩萨调伏其心

尔时如来告文殊师利菩萨言。善哉善哉。如汝所说。此是修行菩萨初入调心法行。以何义故。文殊师利。听我所说乃至解脱。此调伏义多应成就圆满故。文殊师利。譬如二人同居一处。一人赞叹四大海水。一人赞叹牛迹涡水。文殊师利于意云何。牛迹涡水堪赞多不。文殊师利言。是坑微浅况堪类于四大海水赞叹轻重。佛言若声闻调伏现相亦复如是。譬如牛迹涡水自少不济无所赞益。当知小乘轻重若是。其有一人所赞大海者。文殊师利于意云何。是人堪任赞大海不。文殊师利言。大海功德无量赞叹无量。佛言修行菩萨亦复如是。应现修行无量。譬如大海不知滴量。大乘功德亦复如是

尔时说此法已。一万二千天子。皆发阿耨多罗三藐三菩提心。各发是言。世尊我等。从今修行菩萨行处而能修学。愿引一切众生。令入此道

大乘修行菩萨行门诸经要集卷上大乘修行菩萨行门诸经要集卷中

        大唐至相寺沙门释智严译

    第十二

出海慧菩萨所说经(显说八条行)

  解菩萨犯戒而能成就六波罗蜜　解般若波罗蜜深义挍量声闻轻重　解初发菩提心宝忍辱邪魔不退菩提　解身口意三业成就六波罗蜜　解成就观行六波罗蜜念门　解八种功德与烦恼和杂喻　解四种善行门　解菩萨行门有十二种魔障钩

尔时有一天子。白文殊师利童子言。文殊师利。颇有初修行菩萨。心怀悭吝。而能成就檀波罗蜜不。文殊师利言。有是行人。天子白言。以何义故而有是人。文殊师利言。若修行菩萨成熟众生。不舍菩提故。以不舍故。则是悭吝以施成熟众生心故。则能成就檀波罗蜜

复次天子白文殊师利言。颇有修行菩萨。若当犯戒而得成就尸罗波罗蜜不。文殊师利言。有是行人。天子白言以何义故而有是人。文殊师利言。修行菩萨摄护成熟诸众生故。若不具戒而得成就尸罗波罗蜜

复次天子白文殊师利言。颇有修行菩萨。舍于忍辱而得成就羼提波罗蜜不。文殊师利答言。有是行人。天子白言。以何义故而有是人。文殊师利言。若修行菩萨舍外道行。专习无上菩提法忍。而得成就羼提波罗蜜

复次天子白文殊师利言。颇有修行菩萨。贡高我慢而得成就精进波罗蜜不。文殊师利言。有是行人。天子白言。以何义故而有是人。文殊师利言。若修行菩萨。不乐辟支阿罗汉果故。然为显扬萨婆若智故。乐于大乘。而无怠心。积集善念无上菩提。而得成就毗梨耶波罗蜜

复次天子白文殊师利言。颇有修行菩萨。以散乱心。而得成就禅波罗蜜不。文殊师利言。有是行人。天子白言。以何义故而有是人。文殊师利言。若修行菩萨乃至睡眠。不乐辟支阿罗汉果。专求无上菩提。而得成就禅波罗蜜

复次天子白文殊师利言。颇有修行菩萨。愚痴无智。而得成就般若波罗蜜不。文殊师利言。有是行人天子白言。以何义故而有是人。文殊师利言。若修行菩萨。智慧狭劣。见于世俗厌魅咒诅起尸扰动惊乱他心。而菩萨无有方便救护之智。然为菩提心故。摄念佛地。而得成就般若波罗蜜

尔时如来叹文殊师利菩萨言。善哉善哉。文殊师利。诚如所说汝能分别。初修行菩萨应作不作修习行业真实不虚。所以者何。汝今听我略说般若波罗蜜圆满解脱。文殊师利。譬如有人一日之中忍受饥饿。不尝毒食。修行菩萨亦复如是。宁守悭吝无持戒心嗔恚怠慢不摄念。心不乐声闻缘觉道行。若心爱乐修六波罗蜜行则不应尔。何以故。是中菩萨应当有厄。天子言世尊。修行菩萨不应怖畏烦恼。佛言修行菩萨。实怖烦恼。恐入声闻地位。天子。于意云何。譬如有人志存身命忽被加害。宁当截首宁截身耶天子言。世尊。若欲存命。宁割身肉不截其头。何以故。若存其首。尚得修集功德善踪。以善踪故生于天上。若截其首善踪俱灭。佛告天子言。修行菩萨亦复如是。宁舍威仪戒行不退菩提。宁与烦恼相应。不入声闻断烦恼门。天子言世尊。修行菩萨如是修行行业。世间稀有甚为难信。声闻缘觉精进行业。乃如修行菩萨犯戒。佛言。诚如所说。譬如贫人家常饭食。若转轮王暂少尝之如服毒药。若声闻除灭烦恼坚固精进。类于修行菩萨戒行亦复如是。复次譬如有人勤求生业庄饰一身。其人不堪富饶一国。况余世间。声闻亦尔。除己烦恼心故。虽行精进。不堪饶益阎浮众生。况余世间。复次譬如大富商主多诸眷属亲侍部从勤心。好施而能饶益无量众生。天子当知。修行菩萨亦复如是。修习慈悲悲心精进。是以饶益一切众生。胜义谛世俗谛。广施众生快乐

尔时长老摩诃迦叶。白佛言。世尊。若声闻修道证无为果。修行菩萨乃在有为。以何义故。修行菩萨。能过无为证果之人。佛言。迦叶当知。为汝说喻。智者以喻而速闻解。譬如于四大海满中成酥。而有人取一牛毛。分为百分。以一分毛端。取其一滴酥。迦叶于意云何。彼一分毛端一滴酥量。多彼四大海中酥不。迦叶言。不也世尊。佛言。迦叶于意云何。此二处酥。何者最上最尊最多最贵。迦叶言。若以一毛端酥。类大海酥。过亿百千。是酥实为最上最尊最多最贵。其一滴酥。不可为比。佛言。迦叶。譬如百分毛端所取得酥。若声闻于无为智慧类于佛智亦复如是。修行菩萨。修习有为功德。无为行愿普入佛智。迦叶当知。譬如蚊蚁之属。唯能取得一粒食味。若复有人三月广种田苗。迦叶于意云何。何者数多。迦叶言。三月所种。若至秋收其数无量饶益众生。其一粒食未能利己。况利众生。佛言。迦叶当知。譬如蚊蚁执一粒食。声闻亦尔。若三月广种收获甚多。修行菩萨于六波罗蜜并四摄事功德。亦复如是。若成熟已安立利益无量众生。胜义谛世俗谛普施快乐。乃得成就无上涅槃。佛告迦叶。譬如有琉璃珠百千驮乘般入城邑。复有一颗无价宝珠。置于大海舟船之内。若无障碍到阎浮提。是珠普富阎浮众生。饶益贫苦。迦叶于意云何。彼百千驮琉璃珠所有价直。颇能过此一宝珠不。迦叶言不也世尊。佛言。彼诸琉璃珠无所直故。声闻修入无为解脱。亦复如是。迦叶当知。譬如无价宝珠犹在海船。若无障碍得到阎浮。则能普富一切众生。若修行菩萨。三宝种性相续无断。而能发起无上菩提。喻得宝珠利益无量。尔时佛告海慧菩萨言。云何初发菩提心宝而能忍辱不退菩提。云何菩提心宝而有障碍。海慧当知。若修行菩萨已发菩提心故。逢恶知识或魔波旬。或魔眷属。或事邪魔。或住魔行。被其娆恼劫夺善心。修行菩萨心有疑惑。是等邪魔来恼菩萨。菩萨尔时心无退散。复不离隔无上菩提。亦不断绝众生解脱。以大悲故精进修集。亦不断绝三宝种性。亦不断绝一切佛行。亦不断绝如来三十二相八十种好。次第修行显集功德资粮。显现清净诸佛刹土。护持善法修习学故。乃舍身命成熟众生。不乐染着世间快乐。若修行菩萨。为众生故。大悲忍辱其心坚固。被他轻贱骂辱不可言说。苦楚打棒皆能忍受。众生重担而能荷负。不潜不缩。精勤不退。其心勇猛。至于彼岸。亦不疲倦修持精进起方便心专心坚固。他若恼者自不恼他。有人打骂自不嗔他。大乘义故世间殊别。是心正念筹量善路。为众生故顺三界行。我今勤求逆行。三界众生违顺我故。我应与其相应和合。是等众生嗔心勇猛。我求忍辱心怀随顺。世间众生递相诳惑。我今唯念智慧圆满。若有十方众生来集。各持兵器刀剑枪槊。随我而行各怀是心。此修行菩萨。若行若立若坐若卧。若发菩提心时。若发施心。若发持戒心。若发忍辱心。若发精进心。若发禅定心。若发智慧心。若发习学经典心。若发修持功德心。修行菩萨念此心时。我等则当斩断其首。细截身分大如枣叶。是等众生专怀忿怒志在杀人。尔时修行菩萨专心自念。我今于他无嫌怨心。我以忍辱而无仇恶。以何义故。我今是身从无始三界已来无边数量转易生死。无不经历经于地狱饿鬼畜生。受苦无量。或生人中。五欲贪故而无暂舍。或闻非法随顺他心。以是因缘抂失身命。被解支节百段分张。如是苦时彼此总无所益。今既截我身分断我命根。若能尽未来劫不休。我常不舍无上菩提。以何义故。我今所受割截。支体苦楚难忍。比于地狱苦过此百倍。愿我入于地狱不舍菩提。以大慈悲度众生故。何以故。如来所说少分心量能成大事。今世间众生。恶友甚多善友甚少。当知不应恶友为侣。所以者何。我与众生而无怨恶不生恨心。他有与人我有与他。他唯与人嗔嫉。我唯慈忍与他。我今应现不杀忍力不生嗔力。若能舍身命则速得菩提无碍。于身五欲贪爱所染。命断悉已自除嗔心。若起当舍觉除若能入是法门。当知如是修行菩萨。则能忍受一切众生恼乱。不共众生断绝。常能忍辱三种苦恼。何者为三。所谓一者身恼忍。二者口恼忍。三者意恼忍

复次何者恼乱身忍。若被割身而能忍受。唯心世法观念众生被割身者。若修行菩萨智慧方便正割体时观念六波罗蜜。如是观心。舍身命财。施身命故。不吝身故。则能成就檀波罗蜜行。若当被害悲心普遍。虽有楚痛。心无散乱。则能成就持戒波罗蜜行。若被割身分之时。愿度此人忍受无报。则能成就忍辱波罗蜜行。若以坚固精进。不舍菩提心故不厌世间修诸功德。则能成就精进波罗蜜行。若割身分之时。应当摄念。是身犹如草木瓦石影壁。如幻无常无我须臾坏灭。如是观已。则能成就智慧波罗蜜行。海慧当知。若修行菩萨。如是善巧方便。则能圆满六波罗蜜行不退菩提。则是菩萨成就身忍辱行

复次何者是修行菩萨口恼忍辱。若修行菩萨被骂不可言说。一切斗诤嗔忿嫌贱打棒邪直不可所言。闻他恶口。不起嗔怨。皆能忍受。则是菩萨成就口忍辱行

复次云何修行菩萨恼乱意忍。若修行菩萨。善巧方便智慧相应。被人毁呰骂辱嗔责不可言说。菩萨闻已意能忍辱。则是修行菩萨。成就意忍辱行

复次海慧。如何修行菩萨善巧方便智慧圆满。而能成就六波罗蜜观行念门。若修行菩萨。闻他被骂难闻难忍。恶口嗔责不可言说。菩萨应当观念。是人今骂我之人。应是过去悭吝嫉妒。不遇良缘不授习学。不曾供养三宝。今者骂我。我今应当除其烦恼嗔恚怒心。我今可舍怨恶嫉心。无所贪惜。求善知识修学善路。亲侍善人禁慎口过。则能成就檀波罗蜜

复次修行菩萨应作是念。是人犯戒不识罪咎。我已受戒不应嗔动。一心念佛观受罪报。则能成就持戒波罗蜜

复次修行菩萨应作是念。是人习性多嗔恶故。是以骂我。我今无怨。慈心相向。则能成就忍辱波罗蜜

复次修行菩萨应作是念。是人不具善行。是以骂我。我今自当策励身心。一心正念不忘菩提。此等恶人利益我故。结大因缘。未调伏者当令调伏。未念善者令其念善。未息恶者令其息恶。如是心念。则能成就禅波罗蜜

复次修行菩萨应作是念。是人自在无智。执见有相我相众生相贪受财相。是以骂我。我今如法自念。是中有谁骂者。是谁与受俱无。既无自他则能除灭一切法相邪行。无怨能忍则得成就般若波罗蜜

佛告海慧菩萨。若修行菩萨具智慧故。闻他恶口骂詈毁辱不堪闻说。菩萨乃能安忍受故。行愿圆满成就。波罗蜜定不离大乘。则能成就口恼忍辱

尔时海慧菩萨言。何者是修行菩萨被恼意忍。一切魔障。令其菩萨远离菩提。劝生退心。一切外道贪利养故。修习邪行。令其菩萨远离菩提。菩萨已悟正行。心无散乱不离菩提。纵为化现佛身。其心无所退动。复有大力邪魔。诃责菩萨令生邪念。语菩萨言。汝非有力。能集大乘终不成佛。速弃重担舍此精进。菩提难得。如来圣德亦复难求。世间无量难忍苦恼。已入涅槃者现受快乐。汝大丈夫宜亦速入涅槃。海慧当知。修行菩萨正被劝退菩提之时。菩萨不遂他心不舍正念。菩萨作是念言。我定当坐菩提树下。定当摧伏邪魔军众。定当成等正觉转大法轮。于三千大千世界敷演佛法。我已劝请一切众生令成正觉。普愿于我受净法施。若一切诸佛他心贤圣。知我诚心菩提行愿。我今以此菩提心故。于身忍辱不敢诳惑。诸佛贤圣及一切众生乃至自身。如是修行菩萨摄心忍受。不退大乘不断菩提心宝。海慧当知。如是发起菩提心宝。既能发起忍辱波罗蜜。复能不退精进波罗蜜。圆满二行。则是菩萨忍辱意恼

尔时海慧菩萨白佛言。世尊。何者是世间相续功德。与烦恼和杂而能成熟。我等众生以何义故。名为相续世间功德与烦恼和杂。佛言。有八种世间相续功德与烦恼和杂。何者为八。所谓一者修行菩萨功德资粮无厌。二者乐受世间生死。三者愿值诸佛如来。四者愿成就众生无惓。五者守护佛法修行习学。六者勤心摄授众生善行。七者深乐佛法不舍菩提。八者系着波罗蜜行而无舍心。海慧当知。世间相续功德和杂烦恼修行如是。而此修行菩萨。恶见烦恼。无所染着

尔时海慧菩萨白佛言。是诸功德云何烦恼和杂。佛言。当知所立三界皆因烦恼成就。其修行菩萨以善巧方便功德力故。愿住世间救度众生。恒在三界摄受烦恼。菩萨不为自身动乱深故。以是义故。功德和杂烦恼

尔时舍利弗白佛言。世尊。如是无量菩萨行愿。依佛如来不可思议智慧方便。甚希难有。世尊。又见初修行菩萨。如来智故随诸众生。修行无量种种行业。甚难甚难。不可闻说。若修行菩萨如是难行难忍。不惊不惧。其事更难。时舍利弗说是语已。佛告舍利弗言。舍利弗。于意云何。如师子儿闻父哮吼有惊怖耶。舍利弗言。不也世尊。佛言。舍利弗。当知。修行菩萨若闻菩提师子吼声不惊不惧。若闻众生种种异类无量行业。亦不惊不动。舍利弗。如微小火。不惧一切草木丛林。亦不作是念。我无力烧世间草木。修行菩萨亦复如是。以少慧火救诸众生。不惧一切烦恼。亦不作念。我不堪任除灭众生世间烦恼。何以故。若明识一切众生烦恼。而此烦恼则助慧炬。佛告舍利弗。譬如世间一切草木枝叶根茎。各相谓言。劫后七日。一切草木宜共火战各取为胜。尔时此诸草木积聚柴草。高如须弥。有告火言。柴草积集高若须弥。汝火何不集力。必被柴草所胜。火云。我不集众。何以故。草木是我朋友。若草木多我则有力。若草木少我当则灭。舍利弗。修行菩萨亦复如是。以众生无量烦恼故。而能炽然智慧火炬。修行菩萨渐渐力强。若明识烦恼义已。然持烦恼为智慧炬。若修行菩萨。不乐烦恼而有舍弃。便堕声闻缘觉之地。舍利弗。当知若修行菩萨。正念观察一切烦恼。修行菩萨渐则力强。闻是语已不惊不动。当知菩萨善巧方便智慧成就

复次修行菩萨有四种相应善行。何者为四。所谓一者精进修习六波罗蜜。二者以大悲心成熟众生。三者坚持功德成就圆满。四者无量劫时守护三界。亦无疲倦。积集一切功德资粮。若修行菩萨能成如是四种功德。则为决定菩萨行业

尔时佛告海慧菩萨言。善男子。汝识邪魔波旬央俱赊钩不。海慧菩萨言。世尊。我识知是邪魔障钩。佛言。汝今愿闻邪魔障钩解脱义不。海慧菩萨言。愿乐欲闻。佛言。若有菩萨。闻是义已。则得解脱邪魔障钩。而能摧伏一切魔军。速成阿耨多罗三藐三菩提。尔时海慧菩萨白佛言。我等今者以佛威神。欲说十二种邪魔央俱赊钩。初修行菩萨道故。何者十二。所谓一者若修行菩萨修檀波罗蜜。所爱之物而生吝心。不爱之物方能舍施。若有亲识意乐施与。若非亲识心无舍施。施者受者俱生分别。世尊。此是修行菩萨第一障布施魔钩

复次世尊。若修行菩萨。善行精进坚持戒行威仪具足。少分所犯则见闻其罪。身心清净平等习戒。若见精进比丘及婆罗门。而生供养共其习学。若见犯戒则生嗔心嫌恨恶贱。所修行业自赞毁他。世尊。此是修行菩萨第二障持戒魔钩

复次世尊。若修行菩萨。身忍口忍。意心不忍。返生嗔恚。若见倚世豪族。则为显扬其德。为其忍受。若见卑下庶类。则生嗔恨而无忍心。虽暂忍定心怀高慢嗔恚无舍。世尊。此是修行菩萨第三障忍辱魔钩

复次世尊。若修行菩萨。勤心习学而化众生。令入声闻缘觉乘中。不教大乘。而赞声闻辟支佛地。专习俗谛。舍弃胜义谛法门。掩覆大乘。专修世俗名利。幢幡音乐花香供养尊容以求声誉。不览大乘。不求佛法。世尊。此是修行菩萨第四障精进魔钩

复次世尊。若修行菩萨。起四禅定三摩钵低。宴坐寂然成就禅定。而被毁呰成熟众生处。毁呰说佛法处。毁呰众生同居处。毁呰善行有为功德处。不动无为法少分修习不求禅定。返见欲界及无色界乐无色天。以钝心故愿寿长远。若生无想天上。百千般佛成等正觉。是人无由值遇诸佛。不闻佛法不值僧徒。不能成就众生。亦不值受如来妙法。不值积集功德资粮。而无智慧愚痴怠慢。若无想天寿生毕已。下生之处少智尪弱。世尊。此是修行菩萨第五障禅定魔钩

复次世尊若修行菩萨。智慧弥广别识习性知因缘起所有不立不行不住。而乃毁呰有为功德。遂失善巧方便智慧。若布施持戒忍辱精进禅定。俱不修习。唯赞般若波罗蜜。自言。般若最胜。于五波罗蜜心生分别。以四摄事不摄众生。心常无相无为将为最妙。是人未熟智故却堕邪路。世尊。此是修行菩萨第六障般若魔钩

复次世尊。若修行菩萨。修阿兰若行乐住寂静。独处山林无所乐着。迥无储积不居道俗。少用功智不动安然。亦不习学深义。亦不成熟众生。亦不听闻佛法。亦不挍量趣路。若有讲深义处。亦不往就。听闻。亦不求问深教。亦不寻善知识。以其乐住阿兰若。志存烦恼不动。若不开剥烦恼种子乃至八圣道路。是修行菩萨。虽在独住不利他己。世尊。此是修行菩萨第七障阿兰若魔钩

复次世尊。若修行菩萨。说法深邃。美言悦豫威德摄众。若有众生堪与授法。不为授说。若见钝根愚痴不堪教授。则为显示佛法。世尊。此是修行菩萨第八障归依法海魔钩

复次世尊。若修行菩萨。习学世间外道疏论。舍弃大乘深义。赞扬外道所说。若见有人明闲外论。乐说听闻称美为德。是时会中有诸天众。心乐听闻大乘法故。来赴道场。既闻所说外道疏论。心生懊恼而还本宫。发如是言。此善男子今已灭法如来善教。如是修行菩萨于法栋梁。何故翻教世间外论。乐戏论故。弃舍大乘。何以故。诸佛如来为甚深法故。成等正觉。不因世俗外道戏论。成就菩提。世尊。是等修行菩萨。学说外道种种言论。而乃覆藏如来佛法。如是之人于佛法化成等正觉专行断灭。世尊。此是修行菩萨第九障覆盖甚深佛法赞扬外道戏论魔钩

复次世尊。若修行菩萨。逐恶伴侣为善知识共结朋友。而是恶友专令菩萨弃舍众生不令成熟。亦复不令扶护佛法。教住空寂少功力处。数为教授声闻法行。若有大乘相应深义。不为宣传。若修行菩萨习大乘故。住寂静处欲进菩提。恶友为障令其菩萨攀缘世间。而谓之言。修行菩萨合攀缘世间俗法。若应教习世法。他则令住寂静为现令悟入于他位。不为显示菩萨决定无上行门。世尊。何者是菩萨决定无上行门。有其十种。何者为十。所谓一者依住信根受善知识教故。二者精求妙法如救头然。三者于善法教乐住正念常勤修学。四者正勤精进已作法者其心不舍。五者不乐自乐唯愿成熟众生。六者为求法故不惜身命。七者三十二相八十种好净佛刹土修诸功德资粮无厌。八者总持威德圆满成就。九者一切凡俗世位心无染故修习摩诃般若波罗蜜行。十者过一切声闻缘觉位地善巧方便智慧超进。世尊是为十种决定无上菩萨行业。修行菩萨应当习学。是诸恶友。不为显示善事翻令障道。谓菩萨言。汝若勤苦修行然可成佛。不可怠慢心故得成佛道。汝若八劫乃至十劫不成菩提。更无可求阿耨多罗三藐三菩提。世尊。修行菩萨。苦行精进被他障道。令退入声闻果位。此是修行菩萨第十障非善知识魔钩

复次世尊。若修行菩萨。贡高我慢。以贡高故。心不下故。于诸师僧和尚威仪羯磨门徒檀越乃至父母。心无摧伏。若见修行菩萨。已超菩萨行门悟达善行。已得总持威仪圆满。不愿亲近不共习学善教。亦不寻求请问。若见曾修大乘行人。已被魔钩钩着其心。以是义故。是人翻修邪行。爱乐邪伴。专行邪路。退失菩提。如痴母羊无步前进。譬如有人于炕旱时。高原陆地种赡部树。复不溉灌。纵有流渠堰塞令断。是人虽种不溉不生。世尊。修行菩萨亦复如是。先发菩提。后生贡高我慢心故。退失善知识教不闻佛法。已闻受者更不修治。譬如海水波浪不动地势洼下水能深厚。所有江河泉源凑流就下。世尊修行菩萨亦复如是。于师僧父母。心为卑下用少功力获大深法随所记念法入心耳。若贡高我慢不伏师僧父母。当知是人已被魔钩之所钩着。世尊。此是修行菩萨第十一障贡高魔钩

复次世尊。若修行菩萨。形貌端严众所钦仰。富饶高族部从眷属仓库珍宝。其数无量。以其端严众所观美。富饶高族部从众多功德资粮贵敬遵崇。是菩萨不求集智资粮。以自威严富豪力故。醉心怠慢不见正路。若见出家初修菩萨戒人。已出尘劳精勤修习。集智资粮智慧力故。为法精诚宴坐风日。血肉干焦露骨羸瘦。晨昏修习如救头然。是贡高修行菩萨。若见如是行人而生嫌贱。不共为伴不随受教。其心愚昧闇钝无智。世尊。此是修行菩萨第十二障我心所醉魔钩

尔时菩萨言。世尊。是为修行菩萨十二种魔障央俱赊钩。令其修行菩萨障道。若修行菩萨。不觉不知不离不远。如是无明尚不堪习随逐菩萨幼童行业。况能得成阿耨多罗三藐三菩提。是以初修行菩萨。应当精勤摄心自觉超过邪魔十二障钩

    第十三

出戏乐严经(显说一条行)

  解善巧方便施五欲乐故劝化一切众生令发无上菩提

尔时长老须菩提。告夫人言。善女人。汝之夫婿今在何处。夫人答言。须菩提当知。我今非唯一夫。何以故。世间众生五欲所缠戏乐习故。皆是我夫。须菩提言。何者是善巧方便随意戏乐。夫人答言。须菩提当知。若有众生贪求五欲。我当则以资助奉施。然则劝化令发菩提。若有众生欲心炽盛。我当回施恣情戏乐。是以名为善巧方便随意戏乐。须菩提言。如来不许众生耽欲。夫人答言。如闻如来经中所说。若有比丘。受持袈裟锡杖卧具病缘杂药什物之属。不应多畜。是其童子及诸檀越。就于聚落所得上妙供具。供养师僧和尚同居僧徒随所乐受。若因此一物。恶行灭除而得长道。以是义故。如来许其比丘受畜是物。须菩提言。诚如所说真实不虚。夫人言。一切五欲耽着戏乐。如来以是方便。若有利故亦许不遮。须菩提言。善女人。几何众生。因是善巧方便受诸戏乐。成熟无上菩提。夫人答言。若三千大千世界。虚空所有星辰数量至于边际。尚知其数。若与我善巧方便受世戏乐。调伏劝化故。皆发无上菩提。是等众生。其数多于虚空星数。须菩提言。善女人。汝何能得令诸众生而获安乐。夫人答言。须菩提当知。有诸众生。乐事梵天。我以四禅喜乐随意奉施。然后劝令发菩提心。复有众生乐事帝释。我当奉以帝释快乐。然后劝令发菩提心。复有众生。乐于诸天龙王夜叉修罗乾闼及金翅鸟诸杂大蛇皆以戏乐。我当各随所乐施奉无阙。然后劝令发菩提心。复有众生。意乐转轮圣王游戏乃至大臣国邑聚落族姓之子及婆罗门中部下庶。如是众生各随意乐悉皆施与不令阙乏。然后劝令发菩提心。复有众生。乐于色声香味触法。复有众生意所贪着。花鬘璎珞涂香末香衣服缯彩以为严饰。复有众生。贪着钱财。金银珠玉颇梨马瑙鼓乐弦歌。如是众生意所乐者五欲戏乐皆当施与。然后劝令发菩提心。须菩提言。善女人当知。是诸五欲障八圣道涅槃趣路善无所得。是等五欲正受之时。亦有众生以是缘故。于善调伏劝入菩提。此义次第甚为难思。善女人。以大菩萨修行甚难之事。令是修行菩萨成就善事。当知甚难。何以故。如是等事。皆是众生障道一种之事。亦有诸类众生。还复因调伏而得入善

尔时精舍演法会中有二长者子。曾与夫人交游。善巧方便随意戏乐故。劝入无上菩提。是时此二长者子。白须菩提言。须菩提。勿以自智简择他智。须菩提。于意云何。若有少分油灯。堪以口吹手扇而能灭不。须菩提言。甚堪吹灭。长者子言。若声闻行善男子善女人。以少智慧明故。以一游戏智故而能则灭。亦复如是。须菩提当知。譬如劫末之时有七日现。以众日光。世间起大火焰。是火堪以恒河中水灭得以不。须菩提言。百千海水尚不能灭。况恒河水能使灭耶。长者子言。须菩提当知。菩萨如是无量无边智慧光明。无量无边功德光明。若修行菩萨于恒河沙数劫中。以五欲游戏娱乐受世快乐。是修行菩萨智慧光明功德光明。无能堪任而能得灭。譬如有一贫病之人求医疗病。以其贫故医处单方。于时贫人病愿除愈。药价贱者服之病除。何以故。是贫病人以无力故。声闻亦尔。十二头陀修摄心故。独住阿兰若乐弊恶衣。然后解脱世间烦恼。须菩提当知。如贫病人良医为其随机处药愿求病差。声闻解脱亦复如是。复次譬如刹利国王。已授灌顶。王若有病良医为王和合贵药。光泽香美唇口甘甜四支安泰。堪为王服。王服药已。奉献音乐花香娱乐将为欢乐。以是方便国王病差。须菩提当知。亦复如是。亦有修行菩萨。以善巧方便随意戏乐受诸五欲。以欢乐乘故。而成阿耨多罗三藐三菩提。须菩提当知。如王病服上妙药者。修行菩萨亦复如是。以善巧方便智慧力故。而得解脱

    第十四

出善巧方便经(显说一条行)

  为修行菩萨声闻行故犯重障因

尔时佛告无上慧菩萨言。善男子。若有比丘修菩萨行。而犯众重。以善巧方便而能灭除。以是义故。我今为说不犯因缘。尔时无上慧菩萨白佛言。世尊。修行菩萨如何所犯。佛言。善男子。若修行菩萨。修习声闻法行。纵使百千劫中。服诸药草根茎花果。及能忍诸众生善恶言气。以于声闻缘觉行中修习定故。此是修行菩萨重大所犯。善男子。譬如声闻犯四重。已。是五阴现身无复堪任入得涅槃。善男子。亦复如是。若修行菩萨。不舍声闻不忏其罪。于时修行菩萨。无复堪任成等正觉。无能入于佛地无余涅槃

    第十五

出胜积经(显说一条行)

  说修行菩萨退入声闻行中

复次善男子。譬如有人患眼。经过一月以药医疗。眼渐开见。然有仇人以毕茇末而扑眼中。是人眼光盲闇如旧。若修行菩萨。修大乘时退入声闻。其根闇钝。譬如无智之人。以白栴檀末和青淤泥涂于身体。是其白檀和恶气故。其檀本香无复更闻。修行菩萨亦复如是。以习声闻行故。污染功德资粮。难遭佛行无复更堪集诸菩萨会中清净位地

    第十六

出如来藏经(显说一条行)

  观念如来因果

尔时佛告摩诃迦叶言。譬如有人倒地。若还拓地而得起立。迦叶当知。亦复如是。若于佛法中。倾倒直堕无间地狱。若拓如来圣德。从地狱中还复得起。何者倚拓如来若能一心念佛圣德依教修行。尔时摩诃迦叶白佛言。纵无净心观察如来。尚能获大利益。况以净心观察如来其福无量。佛言。诚如所说。但种种意行观察如来。皆当为说趣涅槃路。尔时摩诃迦叶言。我今解如来所教。宁于佛法犯罪。不事外道恶行修学。以何义故。若于如来法中行非法罪。所起恶行皆因涅槃能灭。若事外道所起恶行。皆入地狱饿鬼畜生。受诸恶报。佛言。诚如所说。迦叶当知。譬如有人骂詈紫檀香木捶打而掷于地。毁呰不堪受用。迦叶。于意云何。此紫檀香气更能熏是骂人以不。迦叶言。其紫檀香气熏彼骂人。如本无异。佛言。迦叶当知。若有众生。专念如来若见如来。若闻佛名。是等众生。皆得资熏解脱法门。亦复如是

    第十七

出金光上胜毗尼经(显说一条行)

  为金光胜童女十种行愿请出家因缘

尔时文殊师利童子语金光胜童女言。汝如何应听佛法。童女言。乐闻法故听法如来所说修行。尔时此童女。以文殊师利菩萨威神。兼自善根智慧功德力故。于其会中相续说法。因其一万二千众生而发阿耨多罗三藐三菩提心。复有五百天人。先于菩萨藏中修集善根。于时是等菩萨发悟无生法门。又有三万二千天人。远离烦恼弃除尘垢。于法眼净。是时童女说法之际。以其喜悦心故。入随顺深悟解脱法门。既悟法已。则于文殊师利菩萨前。五体投地愿请出家。伏愿文殊师利。以大慈悲听闻法故。我愿是生得预缁服。文殊师利菩萨言。童女当知。若修行菩萨。自乐出家割截身发。不应如是出家。何以故。先为一切众生。割截烦恼令其精进。此则名为菩萨出家。若修行菩萨。自乐出家。以汤染色修造衣服袈裟卧具。不应如是出家。何以故。先除一切众生贪嗔痴色汤。令其精进。此则名为菩萨出家。若修行菩萨。自乐出家。受具足戒。不应如是出家。何以故。若见犯戒众生。令其摄行断恶修善。此则名为菩萨出家。若修行菩萨自乐出家。独住寂静。不应如是出家。何以故。菩萨先除五趣众生愚痴。令住智慧。此则名为菩萨出家。若修行菩萨。自乐出家。住威仪相。不应如是出家。何以故。先为众生发大慈大悲喜舍之心。此则名为菩萨出家。若修行菩萨。自乐出家。刚修精进善根功德。不应如是出家。何以故。劝化众生发起善根。令修功德。此则名为菩萨出家。若修行菩萨自乐出家。意求涅槃。不应如是出家。何以故。先为一切众生坚心为求涅槃趣路。此则名为菩萨出家。若修行菩萨自乐出家。除己烦恼。不应如是出家。何以故。先为一切众生。勤求精进除他烦恼。此则名为菩萨出家。若修行菩萨自乐出家。愿悟身心。不应如是出家。何以故。先用成熟诸众生故。令悟身心。此则名为菩萨出家。若修行菩萨。自乐出家解脱己厄。不应如是出家。何以故。先救众生厄难。令得解脱。此则名为菩萨出家。若修行菩萨自乐出家。厌离烦恼。不应如是出家。何以故。先为成熟一切众生乐住世间。此则名为菩萨出家。若修行菩萨自乐出家。愿入涅槃。不应如是出家。何以故。先为圆满如来一切善根功德。此则名为菩萨出家。复愿一切众生速得出家。是名出家。复能不见众生过失。是名出家。复舍一切过患除灭众罪。是名出家。夫出家者系心属他。若修行菩萨则非所属。童女言。何故出家名为属他。文殊师利菩萨言。凡出家者当属禁戒守护无犯。是名属他。凡出家者属禅定故。不应散乱。是名属他。凡出家者属智慧。不应愚痴。是名属他。复属解脱。是名属他。不应系缚。是名属他。童女言。文殊师利。如何修行菩萨则非属他。文殊师利菩萨言。若修行菩萨不受他行。则非属他。亦不随他颜色。亦不他智他语。菩萨自有萨婆若智。是以不应属他。时文殊师利菩萨。说是出家法已。有五百菩萨。各脱自身上妙袈裟。持奉文殊师利菩萨。挂其身上。而作是言。文殊师利所说出家因缘诚。实不虚。我等从今应当修学。尔时金光胜童女。得法本源渡达彼岸。得智慧光灭愚痴闇。见生死过烦恼缘起。则顶礼文殊师利童子。右绕三匝。升车而还本宫

    第十八

出降伏魔经(显说一条行)

  魔为修行菩萨说二十种魔障菩萨应觉不取

尔时善坚天子。在于会中。见魔波旬化现佛形坐在道场。天子问波旬言。向来文殊师利菩萨所说魔波旬。能障修行菩萨行业。当愿为说。何者是修行菩萨魔障。说是语已。是魔波旬苏失迷却化本形。而白天子言。修行菩萨凡有二十种魔障。所谓一者求于解脱怖畏世间。习瑜伽诸论供养修学。当知则是魔障。二者搜求空相远离众生。当知则是魔障。三者修无为法。不乐有为善根功德。当知则是魔障。四者所修禅定。不乐世间定门。当知则是魔障。五者所显法教不令发大慈心。当知则是魔障。六者寻求精进有德之徒。于破戒人而生嗔嫌。当知则是魔障。七者显扬声闻道行覆盖大乘。当知则是魔障。八者显扬世谛所说。若闻大乘空义无著无相。而能覆盖。当知则是魔障。九者已识趣菩萨道。更不求六波罗蜜。当知则是魔障。十者自赞精进。不劝怠慢众生。当知则是魔障。十一者修集功德。不念无上菩提。当知则是魔障。十二者修治鞞钵舍那正见。不见众生正见。当知则是魔障。十三者志求断烦恼。不愿处于三界。当知则是魔障。十四者虽以智慧观察慈悲而无习行。当知则是魔障。十五者所修善行。若非善巧方便。当知则是魔障。十六者不修大乘菩萨藏经。习学外道世论。当知则是魔障。十七者博达慧学护惜经法。恐他习解。当知则是魔障。十八者若缘俗事皆当尽心。若习妙法元无学意。当知则是魔障。十九者若修行菩萨见说大乘而不敬习。亦不供养。若见声闻缘觉乘人。随其习行相应和合。当知则是魔障。二十者若修行菩萨得大名闻无所乏少。若当亲见释梵四王帝主大臣长者。若不显说如来无量圣德。亦不供养。亦不敬承。当知则是魔障。天子当知。修行菩萨。有如是二十种最大魔障。应当摄心觉悟如教。修行菩萨则入大乘次位已。发菩提心。修禅波罗蜜定。若在睡眠。尚不乐入声闻位地

    第十九

出富娄那所问经(显说一条行)

  修行菩萨为恶知识故四种因缘退菩提入声闻解脱

尔时佛告圣者富娄那言。富娄那当知。修行菩萨有四种相应法退失菩提。回入声闻位地。何者为四。所谓一者若修行菩萨。伴恶知识。共习恶行。是等恶友。令其远离佛行舍弃众生。而谓菩萨言。汝可厌足如是行业。三界长远苦恼无穷。世间受生烦恼结集暂无停息。成佛甚难。在家弃俗。更复甚难。劳心长远更勿修习。汝亦未曾授记得成阿耨多罗三藐三菩提。汝今力微尪弱。不堪度五趣路。中途不应断绝。修行菩萨闻是语已。心生退缩潜隐萎垂。则于菩萨行中心无所乐。富娄那当知。是第一法故。修行菩萨而退菩提。翻入声闻解脱。二者若修行菩萨。不闻菩萨道行。不闻菩萨藏经。菩萨积集功德菩萨所说禁戒趣六波罗蜜路相应法证。皆不曾闻。既不曾闻。不能如法习学。不知以何行门修行。以何行门远离。如何法习业次。如何法不应习。何者声闻法行。何者菩萨法门。既未明闲。不知如何法则修学应修而不修行不应修而更修。如是修行菩萨。菩提渐渐损减。道心渐慢心意回惶。舍昔行愿退失菩提。富娄那当知。修行菩萨如是退舍菩提。而入声闻解脱。三者若修行菩萨。起异见行厌见己身。执邪正二边不离此行。若闻无上甚深法要。应得开悟。反生诽谤轻嫌不信。以谤法故。死堕无间地狱。无复见闻佛法。不复更修大乘。不遇善知识。以不值故。退失善行。入于恶行。隔断善友。和合恶人。忘失本念。弃菩萨乘位。不救三界众生。不习大乘行业。富娄那当知。此第三法相应故。退失菩提而入声闻解脱。四者若修行菩萨。听闻甚深法要。不为众生解说。怠慢潜缩心无乐说。少用力处而生修学。悭惜佛法不摄众生。以是罪故。所念渐灭。念行灭已。不应筹量法义。亦不堪任更受法分。舍是身命退失菩提。富娄那当知。此第四法相应故。退失菩提而入声闻解脱

    第二十

出宝童夫人所问经(显说一条行)

  修行菩萨四种实语不妄超越声闻诸行无厌

尔时佛告宝童夫人言。修行菩萨。有三种实语不妄。何者为三。所谓一者不诳诸佛如来。不诳一切众生。亦不诳自身。夫人当知。如何修行菩萨。不诳如来一切众生及以自身。若修行菩萨发菩提心已。然后发愿乐证声闻阿罗汉果。夫人当知。是菩萨则诳如来及诳众生并诳自身。何者名为不诳。若修行菩萨发菩提心已。纵值种种苦恼逼切乃至邪魔外道尼干。调弄骂辱以口言气状若刀剑枪槊刺心损其所受毁呰苦楚。若修行菩萨不惊不动不潜不缩不忧不悔皆能忍受。坚固不弃前言菩提心宝。不移不动。于其三界救度众生。归依无等无上菩提乃至刹那不念余乘。常念诸佛愿转法轮。摄受众生生大威力现大势力。善行坚固修治精进。不随他语无能摧伏。夫人当知。如是修行菩萨。不诳众生不诳自身。若有如是菩萨。则是最大无上实语。复有四种因缘。修行菩萨不诳如来。何者为四。所谓一者坚固心。二者威力心。三者势力无怠。四者持戒精进。复有四种因。不诳一切众生。何者为四。所谓一者坚牢修学。二者慈心与乐。三者悲心愍苦。四者摄受众生。复有四种因。不诳自身。何者为四。所谓一者坚固心。二者重复坚固心。三者无谄惑心。四者无诳心。夫人当知。修行菩萨则入第一实语位。不舍菩提。过去行愿不移不动。尔时宝童夫人白舍利弗言。汝能以女身为诸众生演说法不。舍利弗言。我今尚厌男子之身。况受女人身耶。夫人答言。舍利弗汝岂厌离是身耶。舍利弗言。实厌是身。夫人言。以是义故。修行菩萨超越一切众生。何以故。若声闻厌者菩萨殊无厌心。若声闻所嫌菩萨无厌。声闻厌离五阴六入。菩萨则无厌离。声闻厌摄身分。菩萨无厌。声闻厌摄三界菩萨无厌。声闻厌世间生死菩萨无厌。声闻厌离有为功德。菩萨集功德资粮无厌。声闻厌与众生结缘。菩萨成熟众生心故无厌结缘。声闻厌离聚落。菩萨无厌入于国邑聚落王宫。声闻厌自烦恼。菩萨能摄众生不厌烦恼。舍利弗当知。声闻所嫌厌离诸行。菩萨皆能摄受无厌。舍利弗言。如是修行菩萨。以何威力以何气势而无厌心。夫人答言。修行菩萨八种威力相应而无厌心。何者为八。所谓一者于诸众生慈力无恼。二者悲力成熟众生。三者善修行愿无作者。四者智慧力故为除烦恼。五者善巧方便力故无倦。六者功德力故无退。七者智慧力故愚痴已除。八者精进力故具足已入不弃往愿。舍利弗当知。修行菩萨有此八种行力相应。皆无厌心

    第二十一

出宝积经(显说一条行)

  修行菩萨校量声闻道行

尔时佛告摩诃迦叶言。如月与星。不可弃月先念诸星。智者亦尔。修行菩萨亦复如是。以习学故不应弃舍先念声闻。复次譬如诸天世人。共力磨治琉璃珠拟令光洁。无由变为颇梨宝珠。纵数揩磨还复如故。迦叶当知。声闻亦复如是。纵使持戒清净十二头陀一切禅定相应。仍不堪任坐于菩提树下成等正觉。迦叶譬如磨治颇梨宝珠。价直无量百千利益无数。迦叶当知。亦复如是。若修行菩萨道行清净已。尔时令无量百千声闻缘觉而入解脱法门

大乘修行菩萨行门诸经要集卷中大乘修行菩萨行门诸经要集卷下

        大唐至相寺沙门释智严译

    第二十二

出虚空藏菩萨所问经(显说一条行)

  修行菩萨以四十五种魔障觉故超度四魔

尔时佛告虚空藏菩萨言。善男子。如何修行菩萨能伏一切邪魔。而得超度四魔。若修行菩萨以智慧故。见一切诸法喻如幻化。则能超度阴魔。若闻甚深佛法依句披寻。则能超度蕴魔。若悟常乐我净则能超度死魔。若不离菩提心故则能超度天魔。然此修行菩萨能伏一切魔障。何者魔障菩萨而能摧伏。不令邪魔娆乱。善男子当知。凡有魔障四十五种。障其正行。所谓一者若修行菩萨心乐声闻。是为魔障。二者不念菩提。是为魔障。三者所施而有分别。是为魔障。四者求生高贵。是为魔障。五者愿生端正。是为魔障。六者勤求世事。是为魔障。七者[斬/食]尝禅定少分欣悦。是为魔障。八者以智轻嫌少分功德。是为魔障。九者不乐世间生死。是为魔障。十者所修功德而不回向无上菩提。是为魔障。十一者厌见烦恼。是为魔障。十二者覆藏所犯不能忏悔。是为魔障。十三者于修行菩萨起憎嫉心。是为魔障。十四者诽谤佛法。是为魔障。十五者诳惑众生。是为魔障。十六者不修六波罗蜜。是为魔障。十七者于诸佛法不乐听闻。是为魔障。十八者悭吝佛法。是为魔障。十九者为利养故宣说佛法。是为魔障。二十者不以方便设化众生。是为魔障。二十一者不摄受众生。是为魔障。二十二者于犯戒人憎嫌轻贱。是为魔障。二十三者于持戒精进无敬重心。是为魔障。二十四者修声闻行。是为魔障。二十五者顺独觉行。是为魔障。二十六者非时意修道业。是为魔障。二十七者舍大慈悲而求涅槃。是为魔障。二十八者乐修无为。是为魔障。二十九者嫌贱有为。是为魔障。三十者不助众生善行。是为魔障。三十一者我慢贡高。是为魔障。三十二者两舌斗乱。是为魔障。三十三者诳惑众生。妄说是非。是为魔障。三十四者谄曲妄语所爱非真。是为魔障。三十五者于诸众生无真直心。是为魔障。三十六者心变刚犷。是为魔障。三十七者心变粗猛。是为魔障。三十八者见造罪人不劝忏悔。是为魔障。三十九者谤法不信。是为魔障。四十者随自欲乐。是为魔障。四十一者乐行非理。是为魔障。四十二者爱乐非法。是为魔障。四十三者所有业障报障烦恼障缠绕积聚不令散灭。是为魔障。四十四者心垢不除。是为魔障。四十五者与诸俗缘。是为魔障

    第二十三

出如来境界经(显说一条行)

  诸比丘于迦叶佛所闻法故值遇释迦如来法化当来若有众生于佛法中闻说大乘者当生弥勒三会

尔时如来告须菩提言。是等比丘所说诚不虚言。须菩提当知。迦叶如来出现世时。是诸比丘于佛闻法皆悉随逐。文殊师利以随逐故。所闻深法无有忘失。善根智慧成就圆满。当来若有于我法中闻是深法闻已忆念。如是众生。皆于未来弥勒三会大数之中。次第皆入。何况修习大乘菩萨。若能修习大乘行已。是等通达甚深法忍

    第二十四

出阿阇世品经(显说一条行)

  解菩萨藏及声闻缘觉藏定上座

尔时宝日菩萨言。善男子。如来行业不可思议。若大乘法不可率尔调习悟入。若修行菩萨乃至睡眠。不乐声闻缘觉行业。将是如来实相示现众生不应吝惜。能作是念愿。一切众生习学大乘。此无等心而无损减。以是不吝法故。应当觉悟如来大乘义趣。善男子。譬如栽树根茎着地枝叶花果必当茂盛。修行菩萨亦复如是。已能坚持菩萨藏故。亦当解了一切诸乘。是名无量善根菩萨藏法器。善男子。何者是菩萨藏。何因名菩萨藏。譬如大海中水滴无量杂宝无数。诸龙夜叉乾闼婆阿修罗金翅鸟王紧那罗摩睺罗伽摩竭鱼等。无量杂类悉居其中。修行菩萨亦复如是。无量法宝印记布施持戒禅定智慧解脱解脱知见悉住其中。是以名为菩萨法藏。譬如大海所生杂类一切众生。是等不堪饮余河水。若修行菩萨修习菩萨藏已。亦不应餐余乘法味。是以名为菩萨法藏。善男子当知。凡有三藏。声闻藏缘觉藏大乘菩萨藏。何者是声闻藏。依他所说依他所闻而得道行。何者辟支佛藏。依自悟入常乐我净灭定门故。何者是菩萨法藏。悟达无量诸佛法故。发起无上菩提心故。善男子。当知声闻缘觉乘人。不应得有三藏名位。然但可得为三乘教。若闻师说三乘教者。各随所闻而般涅槃。由于三乘各禀承故。以此三乘号为三藏。然非明于大乘义趣。若修行菩萨说法之时。以三乘教化众生令入涅槃。是以菩萨名为三藏。善男子。有三种学。何者为三。所谓一声闻学。二辟支佛学。三者菩萨行学。何者是声闻学。分令悟自心故。何者辟支佛戒学。随中品行无悲心故。何者是修行菩萨学。随顺大悲自悟智故。精进善行。声闻缘觉不习菩萨行门。亦不知义。若菩萨则知二乘义理行门。然不染着。菩萨习学深心乐住。而能示现声闻辟支解脱趣路不入其位。善男子。若修行菩萨如是学故。是以名为菩萨乘藏。尔时文殊师利童子。着衣持钵。呼长老迦叶言。仁当先行我等随从。何以故。长老须菩提。如来先度出家已久。年夏俱尊。汝自往昔当发是愿。我今所度出家。依世间诸阿罗汉道。迦叶。仁但先行我等随从。时须菩提白文殊师利言。于佛法中。不应以老为上。生年为上。何以故。文殊当知。于佛法中智慧为上。智慧上故所学亦上威德亦上。此等甚深法教中为上。文殊师利。仁者智慧为上法教为上威德无碍。普观一切众生善恶根性。明了知见。是故当知。文殊师利最尊最上。仁但先行我等随从

    第二十五

出离垢菩萨所问经(显说一条行)

  诸菩萨从空中下往昔为女人以发菩提愿故现身转为男子

尔时佛告净光夫人言。夫人当知。若有女人以一行故。速得舍离女人之身。受丈夫身。何者一行。以坚固愿发起无上菩提之心。何以故。夫人当知。菩提心者是大丈夫。是大男子非容易心。故能远离阿罗汉行。摧伏一切诸魔外道。于三界中最为无上。断除一切烦恼习气。若有女人正念归佛。起菩提心。无复更受女人之身。清净心故。回此女身转成男子。如是善根回施一切女人。以此回施功德故。亦皆回向无上菩提。夫人当知。以一行愿故。速离女人转成男子。时于此会虚空之中。有诸菩萨来至佛所顶礼佛足。退坐一面。是诸菩萨往昔皆是女人。现身转为男子。于时会中是诸菩萨。见诸往昔夫婿蒙放出家者。各相慰言。汝等是我善知识故。速发无上菩提之心。诸佛出世难可值遇。修功德因会缘甚难。若于众生起大慈悲。发起无上菩提心者。则得成就圆满供养过去现在未来一切诸佛。时诸菩萨说是语已。是等比丘告诸菩萨言。善大丈夫。汝与我等为善知识。救度一切众生故。今劝我等发无上心。我等以汝劝故。善念归依一切诸佛。愿我等未来成等正觉。皆如世尊释迦牟尼。是时此大菩萨及诸修行菩萨白佛言。愿佛慈悲度我等出家。尔时佛告弥勒菩萨言。弥勒为度此等诸善男子出家。弥勒言。如佛所教。则以度讫

    第二十六

出文殊师利菩萨解义经(显说一条行)

  修行菩萨修二种行获十一种善根利益

尔时佛告舍利弗言。修行菩萨以二种行相应不退善愿。随愿往生诸佛刹土。无所障碍。何者为二。若修行菩萨。不乐声闻行业。亦不习学交通不说声闻和杂教迹。亦不劝化众生令入声闻缘觉法中。专为无上菩提劝化众生。修学成就如来圣德。若修行菩萨。劝诸众生。令入佛乘获十种利。何等为十。所谓一者远离声闻缘觉乃至成佛游诸刹土。二者值遇清净菩萨法集。三者成佛已来诸佛摄护。四者名闻十方诸佛会中称其名号。五者发起无等最妙上心。六者唯受帝释梵天之身。七者若生人中受转轮王位。八者常得值遇诸佛如来。九者天人所敬。十者积集无量善根功德。舍利弗。若三千大千世界众生悉令劝入阿罗汉辟支佛位。若复有人能劝一善男子善女人。令住佛位。是人功德甚多于彼。何以故。舍利弗当知。佛种不应声闻缘觉起故而能断绝。若如来不出于世。则声闻缘觉不有。若佛种不断佛出世故。声闻缘觉方得出现。修行菩萨。于佛地中安立他故。得此十种善利。以是二种功德相应故。不离行愿。于诸刹土随愿往生

    第二十七

出光明遍照品经(显说一条行)

  挍量菩萨声闻福力

尔时佛告毗卢遮那愿光明菩萨言。譬如恒河两岸有无量百千饿鬼。饥渴所逼裸形露体火焰为衣身肉焦然形枯风日。雕鸱乌鹫飞绕争餐。恶兽豺狼竞来搏撮。饿鬼罪故。不见恒河。设有所见其水枯涸。或见为灰。何以故。为罪障故受诸苦恼说不可尽。声闻弟子虽复同住逝多林中。不见如来广大神力。不闻佛说菩萨集会挍量法义。何以故。无明翳膜覆其眼故。不曾种植萨婆若地诸善根故。善男子。譬如有人于大会中。昏睡安寝。忽然梦见须弥山顶帝释所居善见大城宫殿园林种种严好天子天女百千万亿普散天花遍满其地。种种衣树出妙衣服。种种花树开敷妙花。诸音乐树奏天音乐。天诸婇女美音歌咏。无量诸天于中戏乐。其人自见着天衣服。普于其处住止周旋。时大会中一切诸人。虽同一处不知不见。何以故。此人梦见。非彼大众所能见故。一切菩萨世间诸王亦复如是。以久积集善根力故发一切智广大愿故。习学一切佛功德故。修行菩萨庄严道故。圆满一切智智法故。满足普贤诸行愿故。趣入一切菩萨智地故。游戏菩萨诸三昧故。已能观察一切菩萨智慧境界无障碍故。是故悉见如来不可思议自在圣德神变。一切声闻诸大弟子不能知见。以无菩萨清净眼故。譬如比丘得心自在入灭尽定。六根作业皆悉不行。一切语言不知不觉。定力持故。不般涅槃。以在定故。不觉世间诸法。一切声闻亦复如是。此等诸大比丘。同在逝多林中。六根具足。不见如来圣德神变。不见菩萨集会挍量法义。何以故。为诸佛如来及大菩萨甚深自在力故。希逢难遇过去善根功德清净无杂。若声闻缘觉无有分故。是以比丘。虽在逝多林中如来足下。不见如来圣德神变。亦不见菩萨集会挍量法义。以不相应住于无上菩提位故

    第二十八

出出生菩提经(显说二条行)

  说三种佛地　解释三乘高下

尔时迦叶敖怛婆罗门。白佛言。世尊。若有已发菩提心者。而有退失不。佛告婆罗门言。若发菩提心已则无退失。何以故。婆罗门当知。有三种菩提。一者声闻菩提。二者缘觉菩提。三者诸佛无上菩提。其中何者是声闻菩提。若有善男子善女人。于声闻行中。虽发菩提心者。亦不劝化安立众生令发菩提。亦不显示大乘深义。不敬大乘行人。不共习学。亦不供养。若见来者不迎不喜。以是行故。当独解脱。是名声闻菩提。复次婆罗门。何者是缘觉菩提。若有善男子善女人。在于缘觉行中。虽已自发菩提之心。不劝众生令发菩提。不习甚深大乘法教。亦不教授他人。不敬大乘行人。不共习学。亦不供养。若见来者不迎不喜。以是行故。当独解脱。是名缘觉菩提。复次婆罗门。何者是无上菩提。若有善男子善女人。自发菩提心已。劝诸众生发菩提心。调伏安立。习学大乘法义为他演说。若见大乘行人。欢喜迎送。婆罗门当知。是人解脱他已安立人天利益世间。是为大乘无上菩提。何故名为无上菩提。为于三界一切已办更无胜上所求。是以名为无上菩提

尔时迦叶敖怛婆罗门白佛言。世尊。解脱解脱有二义不。佛言。解脱解脱无有异义。复云道与道亦无二义。若三乘者而有分别。婆罗门当知。譬如衢路有三乘车。第一象驾。第二马驾。第三驴驾。此三次第驾驭同入城门。婆罗门。于意云何。是三乘车有高下不。婆罗门言。有高下也。佛言。若声闻乘缘觉乘无上佛乘。亦复如是。而有高下。若道与解脱而无高下。婆罗门。譬如三人同渡恒河至于彼岸。一人浮草得渡。一人浮囊得渡。一人造大船而渡。并与百千众生同乘达彼岸。复属长子监此渡船。语言。来者皆应运渡令至彼岸。其第三人自达彼岸。复能济渡一国众生。婆罗门。于意云何。三人所渡同益不耶。婆罗门言。不也世尊。佛言。婆罗门。于意云何。三乘利益有高下耶。婆罗门言。有高下也。佛言。婆罗门当知。声闻乘缘觉乘无上佛乘。有高下所益不同

    第二十九

出宝聚经(显说一条行)

  初发菩提心挍量声闻罗汉与修行菩萨数量轻重不同

尔时佛告长老舍利弗言。若此三千大千世界众生。皆得阿罗汉果。复有三千大千世界众生。皆得成佛。是诸佛前各置一罗汉。各各供养是诸如来。或经一劫百劫千劫。乃至经于恒河沙劫。舍利弗于意云何。况复供养无量无边诸佛如来。其福甚多说不可尽。佛言。若有如是无量阿罗汉。供养如是无量诸佛。复有初发菩提心者。是人功德多于是数罗汉。况以菩提无断故。供养诸佛及诸弟子师僧和尚善知识等。乃至畜生施其一团之食。此之功德。比阿罗汉供养功德百分千分。不如供养初修菩提心者

    第三十

出那罗延品经(显说一条行)

  修行菩萨住四种住地修四种行

尔时佛告那罗延菩萨言。那罗延当知。譬如吠琉璃宝。若置诸杂器中。其宝不失本光。那罗延当知修行菩萨亦复如是。所在三昧纵为俗服名为出家。不离法界道行。说是语已。那罗延菩萨白文殊师利菩萨言。菩萨住于何地而无损减。集诸三昧功德而得无尽智慧资粮。文殊师利菩萨。告那罗延菩萨言。菩萨有四种住地。何者为四。所谓一者若于身命无所吝惜。二者不乐名闻利养。三者不乐己所快乐。四者不愿受生诸天快乐。是为四种住地

    第三十一

出集一切功德经(显说一条行)

  菩萨为诸众生不离三界喻

尔时复有菩萨白佛言。世尊。譬如多人各犯刑名。临刀欲杀。而有一人解散得脱。是人却来就执刀者。谓是执刀杀我杀我。世尊。是三界地不异法人之处。凡夫愚钝亦如犯死之人。菩萨解脱世间却来成熟诸众生故。如人临刑得免却就死刑。菩萨亦复如是。不离三界。是以诸佛如来大慈大悲相应菩提心故。修行菩萨超度一切声闻缘觉。何以故。为声闻缘觉无是大悲心故。亦无善巧方便

    第三十二

出密严经(显说一条行)

  显示声闻菩萨挍量行门

若有菩萨。于法深解善巧方便法义。当得阿耨多罗三藐三菩提。若成等正觉已。显扬法教。若见五阴离。于自身观无人我诸法体性。亦无所动。此则声闻解脱。若修行菩萨一切法行。观于二边。远离边际。此等速得阿耨多罗三藐三菩提。若有直见边际快乐已。于诸众生无慈悲心舍离世缘。如是之人成佛甚难。快哉如来智慧。令诸众生至于安乐。譬如莲花虽淤泥垢生甚清净。虽生淤泥所。为诸佛贤圣供养故生。菩萨亦复如是。生于三界淤泥。若成佛已则得诸天叹美。若修行菩萨转生人间。当得王四天下转轮王位。若生天上。自为天主乾闼婆王。为不断相应大乘法故。所生之处恒受胜上高位。是故修行菩萨。应当摄护大乘。常受胜位究竟。成就阿耨多罗三藐三菩提

    第三十三

出梵刹经(显说一条行)

  修行菩萨发大忍辱行愿

尔时佛言。初修行菩萨。宜当数发无上菩提相应行愿。为诸众生苦恼枯涸。令为发大誓愿忍辱心故。成就众生

愿三千大千世界地为金刚。于其地上我身分散。譬如芦苇甘蔗。或如稻苗。如是多身。各受世法苦乐。依恒一切众生。变为那罗延力。以其力故。愿于我身生大嗔嫌。各执金刚锤杵。昼夜三时杵碎我身。如安善那眼药碎已复生。依前无舍。我于此等众生无嫌怨心。愿我代于一切众生。受此苦厄无有间断。普令远离诸烦恼苦。不退无上菩提。不入声闻缘觉道果。愿成等正觉。度脱一切众生

    第三十四

出一切诸佛所念经(显说一条行)

  忍辱慎三业行门

尔时善等观菩萨白佛言。世尊。修行菩萨。如何住于忍辱羞耻行门。佛言。若修行菩萨以身恶行自慎羞耻。以口恶行自慎羞耻。以意恶行自慎羞耻。以声闻缘觉谈论恶行自慎为耻。善男子。是修行菩萨羞耻之处。若能慎觉。则得至于无上菩提道位

    第三十五

出法集经(显说二条行)

  修行菩萨修十种戒行　复别有十种戒行

尔时佛告无所发菩萨摩诃萨言。善男子。于意云何。何者是修行菩萨实语。菩萨若发菩提心已。宁舍身命不舍菩提。于诸众生。不行非法是为不妄语。若修行菩萨发无上菩提心已。后违前志违言欺诳。则是修行菩萨退失菩提

复次修行菩萨。云何持戒念行。所谓一者若乐听闻佛法。是其为戒成就圆满而得四无量心。二者若志求佛法是其为戒成就圆满得卑下心。三者若供养善知识故。是其为戒成就圆满伎艺无缺。四者若修波罗蜜行。是其为戒成就圆满而得佛智。五者若闻经典转为他说。是其为戒成就圆满而能广说大乘经典。六者若常念佛法。是其为戒成就圆满明闲总持威力。七者若专修菩提。是其为戒成就圆满灭诸罪障。八者不嫉众生。是其为戒。是以不失菩提。九者不退菩提。是不失戒三宝现前。十者如如念戒观一切无缺。善男子。修行菩萨。应当恒以心念如是善戒

复次修行菩萨。复有十种菩提心戒。所谓一者为求一切众生利故。非独利己。二者所修道业回施众生。愿速成佛非专为己。三者以坚牢行利他世业。亦非为己。四者戒行清净增长菩提。历劫忍辱无有疲倦。五者布施为戒。乃至能舍头目髓脑利众生故。六者持戒为戒。菩萨不舍无戒众生。七者忍辱为戒。菩萨不惧一切魔军。八者精进为戒。为众生故。积集佛道无有疲倦。九者禅定为戒。菩萨为声闹乱定心不动。十者智慧为戒。菩萨见诸世法想同菩提空相为戒。菩萨不染世间慈悲为戒。不入涅槃是为法集

    第三十六

出阿差耶末所问经(显说一条行)

  修行菩萨戒行无尽诸行人戒力皆有尽时

尔时阿差耶末菩萨白舍利弗言。修行菩萨持戒无尽。舍利弗当知。相续无断见故。何故凡夫持戒上生善处戒力销尽。人间持戒十善受毕戒力销尽。若六欲天戒功德报毕戒力销尽。若色界天戒四禅灭故。戒力销尽。若无色界天戒四三摩钵帝灭故。戒力销尽。若五通仙人戒失于五通戒力销尽。若一切声闻戒入涅槃故。戒力销尽若辟支佛戒无大悲故。戒力销尽。舍利弗当知。若菩萨摩诃萨戒行无尽。何以故。一切净戒皆因菩萨戒摄现前故。譬如种子渐多利益无尽。舍利弗当知。菩提心者犹如种子。诸佛如来戒行无尽。是大丈夫名为无尽戒行。舍利弗是修行菩萨持戒故。戒行无尽

    第三十七

出集会品经(显说一条行)

  修行菩萨于三乘中普明善巧方便

何者是修行菩萨。于一切乘中善巧方便。凡有三乘法而得解脱。何者为三。一者声闻乘。二者缘觉乘。三者大乘。复有二乘。何者为二。天乘人乘。其中何者修行菩萨。于声闻乘中而有善巧方便。若佛不出于世。声闻乘亦无成就。何以故。为依他闻法故而现声闻。何者是闻法。持戒忍辱积集圆满故。若积集戒圆满。则得积集禅定圆满。若积集定圆满。则得积集智慧圆满。若积集慧圆满。则得积集解脱圆满。若得积集解脱圆满。则得积集解脱知见圆满。如是方便是为声闻善巧方便。声闻复有善巧方便福德不动诸法嫌故。于是三界而生厌离一切诸行无常。厌离烦恼一切诸法无我故。专求寂灭涅槃。乃至刹那不求世间生死。恒惧无常。五阴诸行无相故。五根喻若蟒蛇相故。十二因缘如空聚落。一切生死无心乐故。显是法已。修行菩萨。则知声闻乘中善巧方便

何者修行菩萨。于缘觉乘中。而有善巧方便。是何因缘。缘觉而得出世。修行菩萨应知。缘起何者。加行乐修精进禅定。不住积集功德资粮。不住积集持戒资粮。少分听法修习故。亦不亲近供养诸佛故。中分智故常为出家。下心故而修少用功力。不乐筹量法集。乐住空寂独居别处。速求难入大灌顶位。乐行乞食。数思常乐我净法。出离三界。披寻涅槃。故自智悟入定故。乐修三昧非他自悟以智明悟起一切诸行因缘边际。显是法已。修行菩萨。则知缘觉乘中善巧方便

何者修行菩萨。于大乘中善巧方便。若大乘行故方便无量无边。我今略说。此乘功力为一切众生。令入此乘。功德资粮积集善根。为诸众生。清净摄受诸波罗蜜。令入一切法故。以无间断常行佛道。此乘以无碍故。光明所照。若此大乘一切众生皆是乞士。超越一切无畏邪路。此乘如来圣德恒在目前。一切邪魔外道杂行皆能摧伏。复为如来资助善行。如树宝幢无有间断。此乘能除三界住灭二边妄想执持空相无常结使所持疑惑。皆能除断如来佛乘无障碍得故。此乘能于一切法集。亲近三宝。利益世人。皆当恃怙行。不诳路一切众生皆有分故。为过去大悲坚持力故。示现此处。以十力四无所畏十八不共法三十二相八十种好。身口意庄严具光明严饰。为一切处无嫌无过。是为修行菩萨大乘中善巧方便

    第三十八

出郁伽长者所问经(显说一条行)

  说在家菩萨应修四种行不出家因缘

尔时佛告郁伽长者言。在家修行菩萨。以四种行相应而得归依如来。何者为四。所谓一者菩提心无舍故。二者不破三摩禅业。三者大慈大悲无断故。四者不染杂乘。是为四种相应成就归依如来。复有四种行业相应而得归依法。何者为四。所谓一者供养法师故。二者尊重听法。三者听闻法已正直披寻。四者若闻法要而为众生显说。流传回施众生成等正觉。复有四种行相应而得归依僧。何者为四。所谓一者不乐声闻专求无上菩提。二者若有众生修余行业。劝令修学正真佛法。三者以菩提心无退。四者供养僧徒推寻声闻行业而不取声闻解脱。若修行菩萨。舍一切财物已智。而生施心作是念言。若有饥饿来乞饮食。皆当施与。纵施酒者复作是念。一切所求而成檀波罗蜜。如是在家修行菩萨摄护戒行

尔时佛告阿难。汝见郁伽长者供养如来修习于法所乐之物而能布施。阿难白佛言。世尊我见是事。佛言。阿难当知。郁伽长者此贤劫中。所有一千佛出世。皆以无量供具当遍供养摄护佛法。虽在俗服而修僧行广修佛道

尔时阿难问郁伽长者言。长者。以何义故。俗中犹如怨贼。所居俗服而能乐住。今值出家因缘何无乐心。长者答言。我不乐俗。何以故。修行菩萨相应大悲故。不求快乐。忍辱苦恼不舍众生故。佛言。阿难。当知此郁伽长者。虽在俗服已曾成就无量众生。诸余百千菩萨。无能如是成熟众生。何以故。彼百千菩萨。皆无如是善巧威力如郁伽长者一人

    第三十九

出殊胜具戒经(显说二条行)

  初发起修行菩萨堪受无量衣食床座供养其福无量　又表阿耨达多龙王神力

尔时佛告诸善男子言。汝善男子。应共魔斗寻求圣位。若修行菩萨。成熟众生之时。先共邪魔斗战。令其变化相应善行。不求余师。是为法行。诸善男子当知。若有人讥嫌声闻行者。汝等勿有讥嫌。若有乐修声闻行者。汝等勿乐。尔时诸菩萨白佛言。世尊。何者行声闻讥嫌。而菩萨无讥嫌。然声闻求者而菩萨不求佛言若声闻讥嫌生死。汝不应嫌。若声闻所愿乐涅槃。汝等不应愿乐。是为法行

尔时佛告舍利弗言。舍利弗。若修行大菩萨。满于世间于诸众生。每日授与袈裟衣服。于意云何。如是施者是善清净施。不但为初修行菩萨初心发起无上菩提心故。从此之后则成最上。修行菩萨而堪净受如是衣施。若初修行菩萨。每日于他受净脔食积如须弥。而堪净受。不为修行菩萨初心发起无上菩提心故。从此之后则成最上。修行菩萨而堪受如是净食。若初修行菩萨受用高座。广如四天下高若须弥。七宝所成金银颇梨真珠码瑙金刚杂宝而为厕钿。诸天上衣弥覆其上。其座每日于诸众生。清净受用而成净受。不为初修行菩萨初心发起无上菩提心故。从此之后为一切众生。当成施主而堪受如此高座。舍利弗当知。譬如阿耨达多龙王宫四面出生四大河水。何者为四。所谓一者恒河。二者斯涂。三者薄叉。四者新都。此四大河流入大海。令海盈满。此四大河。各有眷属。若恒大河与五百小河而为眷属。东方流入大海。若斯涂大河与五百小河而为眷属。南方流入大海。若薄叉大河与五百小河而为眷属。西方流入大海。若新都大河与五百小河而为眷属。北方流入大海。舍利弗于意云何。是等四河随方流出。满四大海。旷野遍流。而能利益世间众生。舍利弗言。世尊此四大河利益无量众生人非人等。如是大小诸河流注天下。润泽五谷粳粮菉豆杂麦油麻床[疊*毛]杂田皆以诸河溉灌田野。舍利弗。于意云何。是四大海如何得满。舍利弗言。以是四大河故。而得盈满。佛言舍利弗。于意云何。此四大河于大海中。而能利益几何众生。舍利弗言。世尊。利益无量众生。第一利益水陆众生鱼鳖鼋鼍鲛龙摩竭蟒蛇杂类万像海人蚌蛤珂虫诸龙母子修罗罗刹人与非人皆能利益。种种杂宝遍满海中。蚌蛤真珠放光动地颇梨玛瑙靺羯车磲琥魄珻瑰珊瑚杂宝遍满海中利益众生。舍利弗。于意云何。是四大海从何而有。舍利弗言。以阿耨达多龙王故而有。佛言舍利弗。是阿耨达多龙王不遭三难。何者三难。一者不惧金翅吞食其身。二者热沙不堕身上。三者若行欲时不变为蛇。诸余龙王皆有三难。唯阿耨达多龙王而无此难。阿耨达多龙王宫殿。恒止神通禅定之人。所有众生入其宫者。热沙不堕其身。尔时舍利弗白世尊言。世尊。阿耨达多龙王宫殿。如何得如是奇妙功德威力。何故诸余龙王昼夜六时。皆有厄难。唯此阿耨达多龙王及彼宫中无如是难。而有无量善根功德。流出四河利益无量众生产业。佛告舍利弗。诚如所言。阿耨达多龙王是大菩萨。是大修行菩萨。舍利弗。譬如阿耨达多龙王。于三种难而得解脱。修行菩萨亦复如是。亦得解脱三种厄难。何者为三。地狱难饿鬼难畜生难。譬如阿耨达多龙王池中四河潜润广遍田野。修行菩萨亦复如是。以四摄事摄诸众生。何者为四。一者布施摄。二者爱语摄。三者利行摄。四者同事摄。舍利弗。譬如四大海水。以阿耨达多龙王四大河故成就。初修行菩萨亦复如是。以发生菩提心故。而成阿耨多罗三藐三菩提。譬如四大海中无量无边亿百千众生快乐相应。舍利弗。当知三界众生于佛法中安立亦复如是。应见欲界色界无色界众生。若三千大千世界众生受乐。皆因菩萨应现功德

    第四十

出解深密经(显说一条行)

  修行菩萨修六波罗蜜住地行

尔时观世音菩萨白佛言。世尊。是诸修行菩萨凡有几种修学住地。菩萨应学能成无上菩提。佛告观世音菩萨言。善男子。当知修行菩萨学住地。略有六种。何者为六。所谓布施持戒忍辱精进禅定智慧

观世音菩萨白佛言。世尊。如是六种修学住地。几是戒学所摄。几是定学所摄。几是慧学所摄。佛告观世音菩萨言。善男子。当知初三种学第一布施持戒忍辱。此三者当知为戒学所摄。若禅定一种。但是增上心学所摄。若慧则是增上慧学所摄。若精进我说遍行一切。观世音菩萨复白佛言。世尊。如是六学住地。几是功德资粮。几是智慧资粮所摄。佛告观世音菩萨言。善男子。若因戒学所摄者。是名功德资粮所摄。若智慧修学所摄者。是名智慧资粮所摄。我说精进禅定遍行一切。亦入功德资粮。亦入智慧资粮所摄。观世音菩萨复白佛言。世尊。于此六种所学。一者最初于菩萨藏波罗蜜。相应微妙正法坚牢行愿。二者次于十种法行。精进修行。以闻思修妙智所成。三者护持菩提心故。四者亲近供养真善知识。无间勤修善品

观世音菩萨言。世尊。何故是六种学住地。六数各愿知所因

佛告观世音菩萨言。善男子二因缘故。一者饶益诸众生故。二者对治诸烦恼故。观世音。当知是六学中。前三种饶益众生。布施持戒忍辱。后三种对治一切烦恼因。精进禅定智慧。是中修行菩萨以前三种布施故。种种资具摄养众生。以持戒故。不行损害逼迫恼乱令离怨家。以忍辱故。他来欲害逼迫苦恼。堪能忍受摄护众生。观世音。当知此三所说。为众生摄施因。后复三种对治烦恼者。修行菩萨由修学精进故。令烦恼倾动。修学而能对治。勇猛修诸善品。由禅定学故。而能剥削心家烦恼。由智慧故永除烦恼。此后三种为对治烦恼因

    第四十一

出胜鬘师子吼一乘大方便方广经(显说一条行)

  发十大受愿赞叹如来如来则现

尔时波斯匿王及末利夫人。信法未久共相谓言。胜鬘夫人是我之女。聪慧利根通敏易悟。若见佛者必速解法心得无疑。宜时遣使发其道意。夫人白言。今正是时。王及夫人与胜鬘书。略赞如来无量功德。即遣内人名旃提罗。使人奉书至阿踰阇国。入其宫内敬授胜鬘。胜鬘得书欢喜顶受。读诵受持生希有心。向旃提罗而说偈言

  我闻佛音声　　世所未曾有
  所言真实者　　应当修供养
  仰惟佛世尊　　普为世间出
  亦应垂哀愍　　愿必令我见
  即生此念时　　佛于空中现
  普放净光明　　显视无比身
  胜鬘及眷属　　头面接足礼
  咸以清净心　　叹佛实功德
  如来妙色身　　世间无与等
  无比不思议　　是故今敬礼
  如来色无尽　　智慧亦复然
  一切法常住　　是故我归依
  降伏心过恶　　及与身四种
  已到难伏地　　是故礼法王
  如一切尔炎　　智慧身自在
  摄持一切法　　是故今敬礼
  敬礼过称量　　敬礼无譬类
  敬礼无边法　　敬礼难思议
  哀愍覆护我　　令法种增长
  此世及后生　　愿佛常摄受
  我久安立汝　　前世已开觉
  今复摄受法　　未来生亦然
  我已作功德　　现在及余世
  如是众善本　　唯愿见摄受

尔时胜鬘夫人。闻授记已恭敬而立。受十大受。世尊。我从今日乃至菩提。于所受戒不起犯心。世尊。我从今日乃至菩提。于诸尊长不起慢心。世尊。我从今日乃至菩提。于诸众生不起恚心。世尊。我从今日乃至菩提。于他身色及外众具不起嫉心。世尊。我从今日乃至菩提。于内外法不起悭心。世尊。我从今日乃至菩提。不自为己受畜财物。凡有所受悉为成熟贫苦众生。世尊。我从今日乃至菩提。不自为己行四摄法。为一切众生故。以不爱染心无厌足心无碍心。摄受众生。世尊。我从今日乃至菩提。若见孤独幽系疾病。种种厄难困苦众生。终不暂舍必欲安隐。以义饶益令脱众苦然后乃舍。世尊。我从今日乃至菩提。若见捕养众恶律仪及诸犯戒。终不弃舍。我得力时于彼彼处。见此众生。应折伏者而折伏之。应摄受者而摄受之。何以故。以折伏摄受故。令法久住。法久住者。天人充满恶道减少。于如来所转法轮而得随转。见是利故。救摄不舍。世尊我从今日乃至菩提。摄受正法终不忘失。何以故。忘失法者则忘大乘。忘大乘者则忘波罗蜜。忘波罗蜜者则不欲大乘菩萨。不决定大乘者则不能摄正法。欲随所乐入。永不堪任越凡夫地。我见如是无量大过。又见未来摄受生正法菩萨摩诃萨无量福利故受此大受法主。世尊。现为我证。唯佛世尊现前证知。而诸众生善根微薄。或越疑网以十大受极难度故。彼或长夜非义饶益不得安乐。为安彼故。今于佛前说诚实誓。我受此十大受。如说行者以此誓故。于大众中。当雨天花出天妙音。说是语时于虚空中。雨众天花出妙声言。如是如是。如汝所说真实无异。彼见花及闻音声。一切众会疑惑悉除喜踊无量。而发愿言。恒与胜鬘常共俱会同其所行。世尊悉记一切大众如其所愿。尔时胜鬘夫人复于佛前。发三大愿而作是言。以此实愿安慰无量无边众生。以此善根。于一切生得正法智。是名第一大愿。我得正法智已。以无厌心为众生说。是名第二大愿。我于摄受正法舍身命财护持正法。是名第三大愿

尔时世尊即记胜鬘三大誓愿。如一切色悉入空界。如是菩萨恒沙诸愿。皆悉入此三大愿中。此愿者真实广大

    第四十二

出出生无边门陀罗尼经(显说三条行)

  说持是经陀罗尼者临命终时八十亿诸佛亲迎接　又表如来三身　又说修行菩萨修四事四事无相行门速成佛道

尔时佛告舍利弗言。若诸修行菩萨。为求阿耨多罗三藐三菩提者。应当发广大心。无所染着无取无舍。受持诵念此陀罗尼

尔时世尊说陀罗尼曰

写陀(提耶反)体昙(一)阿拏么拏(二)阿溪么溪(三)娑蔓多目溪(四)娑低(低耶反)[口*邏](去)咩(五)扫咩(六)欲讫低(二合七)泥噜讫低(二合八)泥噜讫多钵鞞(九)翳黎咩黎醯梨(十)舸立箄(二合十一)舸立谤(二合)泥(十二)舸立跛(二合)栖(十三)娑(去)[口*(黍-禾+利)]娑(去)啰啝低(十四)醯罗醯犁(十五)醯礼犁(十六)醯逻醯礼犁(十七)战提(十八)遮啝低(十九)者[口*犁]遮啰拏(二十)遮逻遮啰拏(二十一)阿者黎(二十二)按低(二十三)按多低(二十四)舸啰拏(二十五)阿啰拏(二十六)阿散低(二十七)涅漫泥(二十八)涅靺怛泥(二十九)涅目讫低(二合三十)涅殿低(三十一)涅陀(提耶反)嚟(三十二)涅诃嚟(三十三)涅诃啰伏么黎(三十四)涅诃啰烧驮泥(三十五)烧驮泥(三十六)尸罗烧驮泥(三十七)钵吉低(二合)靺泥(三十八)钵吉低(二合)泥跛泥(三十九)婆(去)啝伏婆(去)啝泥(四十)阿僧倪(四十一)娜咩(四十二)縒咩(四十三)微晡罗钵鞞(四十四)桑葛屣拏(四十五)侄[口*梨](四十六)侄侄嚟(四十七)摩诃侄侄嚟(四十八)泥那泥(四十九)婆(去)啝伏婆(去)[口*梨]泥(五十)婆啝泥(五十一)摩诃婆啝泥(五十二)讫吒泥(五十三)摩诃讫吒泥(五十四)耶赊啝低(五十五)者黎(五十六)阿者黎(五十七)摩者黎(五十八)娑摩者黎(五十九)侄荼散泥(六十)速思体(二合)低(六十一)阿僧伽鞞诃嚟(六十二)阿僧伽泥诃嚟(六十三)娑蔓多目溪(六十四)涅诃嚟(六十五)涅诃啰欲讫低(六十六)泥诃啰伏么嚟(六十七)泥诃啰烧驮泥(六十八)侄荼散泥(六十九)速思体(二合)低(七十)扫咩宋摩啝低(七十一)思荡(二合)咩(七十二)思汤(二合)摩啝低(七十三)思贪(二合)婆啝低(七十四)侄荼思傥(二合)咩(七十五)思汤(二合)摩钵(去)卑低(二合七十六)摩诃钵鞞(七十七)娑蔓多钵鞞(七十八)鞞摩罗钵鞞(七十九)鞞摩罗湿咩(二合八十)娑蔓多目溪(八十一)萨婆怛逻(二合)女褐低(八十二)閜(乌可)那(去)扯陀(提耶反)钵啰(二合)低婆(去)泥(八十三)驮啰尼泥驮泥(八十四)驮啰尼目抗奴散泥(八十五)萨婆勃陀婆(去)瑟低(八十六)萨婆勃驮侄瑟耻(二合)低(八十七)泥驮那遨低黎(二合八十八)莎诃(八十九)

佛告舍利弗。若菩萨修此陀罗尼者。不应分别有为无为。亦不取不着不增不减不成不坏不合不散不生不灭。亦不念于过去未来现在诸法。亦不积集摄取诸法。但当思惟诸佛非色非无色非相非无相。菩萨不应同于二乘取佛色身。何以故声闻缘觉。取佛色身庄严之相。光明照曜父母生育饮食长养血肉筋骨四大合成无常变坏苦恼不净为佛色身。菩萨不尔。何以故。如来之身无生相故。普为众生于一切法。以非明照集智资粮。显现法身虚空相无生相。如来法身以无生相而为色蕴。复以无生相甚深之义是一切法体故。然诸菩萨不应非色取如来相。若以非色取如来相便同声闻。谓佛入于寂灭涅槃色身断灭无复更生。菩萨不尔。何以故。如来之身无尽相故。普为众生于一切法。以非明照显现色身。以法作相集福资粮。以如来色身无尽相故。是为无尽色蕴。是故诸法亦无尽相。若众生界度脱未尽。如来常现无尽色身。舍利弗。于此经中陀罗尼故。出生无量面门。修行菩萨若闻是经于无上菩提皆不退转。何以故。是中显示如来一切圣德神通。复因此经。增益众生戒行分段守护无所得法

尔时世尊而说颂言

  汝等勿乐着　　一切诸法空
  于诸佛菩提　　亦莫起分别
  于菩提涅槃　　亦不生疑惑
  若能修此行　　速得陀罗尼
  听此修多罗　　习智空无相
  无生亦无灭　　当速证菩提
  菩萨持是经　　深解无量法
  得生诸佛刹　　亲近最胜尊
  若得陀罗尼　　决定深义趣
  不生退惧心　　受持无尽法
  十方一切佛　　说法皆尽闻
  闻已悉受持　　顶戴而奉行
  若受持此经　　于文字名句
  及所说妙义　　终无有疑忘
  如日月光明　　所照无不遍
  了知此法门　　通达无量义
  诵持此经故　　即自能开解
  一切最胜法　　陀罗尼妙门
  假使一劫中　　一切诸众生
  所有深疑惑　　皆问持经者
  时持经菩萨　　咸皆为开演
  疑网悉已除　　菩萨智无尽
  爱乐此经故　　能速近菩提
  如是真佛子　　护持秘密藏
  持此陀罗尼　　众生咸敬念
  诸佛共称扬　　名闻十方界
  由持此经故　　临欲命终时
  见八十亿佛　　伸手俱携接
  咸作如是言　　汝当往我刹
  由诵持此经　　现受如斯福
  若百千亿劫　　造罪当应受
  诵此陀罗尼　　一月皆清净
  菩萨亿劫中　　勤习诸功德
  一月诵此经　　其福超于彼
  善念慧精进　　三昧陀罗尼
  经故常现前　　乃至如来地
  三界诸众生　　一时尽为魔
  诵持此经故　　悉无能障碍
  此经中解释　　一切诸法门
  而说一切智　　因是成正觉
  我因闻是经　　然灯授我记
  记言汝成佛　　解脱诸众生
  彼时见诸佛　　其数如恒沙
  闻诸佛说法　　皆悉能解了
  若欲得受持　　诸佛所说法
  勤修学此经　　速成如是力
  殊胜庄严刹　　大会诸圣众
  光相及妙族　　皆从此经得
  若人经七日　　谛思惟是经
  八十亿诸佛　　为说如斯法
  邪思慎莫思　　不应思勿思
  以智当正思　　速得此经典
  勤修此法门　　勿惧菩提远
  如人至宝洲　　随意采众宝
  若持陀罗尼　　莫言无善报
  具足人天乐　　近佛道非难
  若愿速成佛　　应持是经典
  毕竟定当得　　无上大菩提

佛告舍利弗。若菩萨成就四法。必定当得此陀罗尼。何等为四。一者不乐爱欲。二者不生嫉姤。三者于诸众生。能舍一切无有恚恼。四者昼夜欢悦深乐求法。舍利弗。菩萨成就如是四法。得此陀罗尼

复次舍利弗。若菩萨成就四法。得此陀罗尼。何等为四。一者住寂阿兰若行。二者悟入甚深法忍。三者不乐名闻利养。四者能舍所爱之物乃至身命。菩萨成就如是四法。得此陀罗尼

复次舍利弗。若菩萨成就四法。得此陀罗尼。何等为四。所谓入于八字之义。云何八字。一者跛字。是第一义。一切诸法无我入义。二者攞字。入于如来无生法身。以非明照集智资粮无所入相。以无生相而为色身。以无尽相而为色蕴入义。三者么字。智慧愚痴法作同类入义。四者舸字。分别业报。亦无业报入义。五者阇字。悟生老病死不生不灭入义。六者驮字。悟陀罗尼法体空无相。无愿寂如涅槃开解入义。七者赊(赊可反)字。奢摩他住寂定相。鞞钵舍那正见诸法相。如何而得住于寂定。宜当精勤昼夜无间观佛禅像不应取相。当念鞞钵舍那以慧正见。若行者见佛而现。将为真佛应作是念。此所见佛从何方来。东西南北四维上下方所来耶。若将此佛是人所造应作是念。此佛为是泥木作耶。为复金银铜铁所作。如是观已。知所见佛。但由我于精舍之中。观佛形像。昼夜忆念。是故佛形常现目前。由是当知。我常见闻一切诸法。将为实者。皆从自心忆念而起。即是修行菩萨。第一温习不住定乃至欢喜地位

云何观佛形像。亦住胜义谛门。当作是念。我今所见佛之形像。非佛所有种类之相。此但是我现在观察像因缘故。见佛形像。得入定中。类知一切诸法亦复如是。以是义故。见佛形像。不应总无。当知赊字与一切法无有差别。皆同法门入义。八者叉字。诸法皆空不生不灭。何以故。悟解诸法本来空寂自性涅槃入义。是八字义。如是受持。随何方所。有是经卷者。应当尊重恭敬供养。半月半月。读诵演说。若见诵习此经典者。称扬劝进。舍利弗。若有修行菩萨修此四法。得是陀罗尼

大乘修行菩萨行门诸经要集卷下


大方等如来藏经

    No. 666 [No. 667]

大方等如来藏经

        东晋天竺三藏佛陀跋陀罗译

如是我闻。一时佛在王舍城耆阇崛山中。宝月讲堂栴檀重阁。成佛十年与大比丘众百千人俱。菩萨摩诃萨六十恒河沙。皆悉成就大精进力。已曾供养百千亿那由他诸佛。皆悉能转不退法轮。若有众生闻其名者。于无上道终不退转。其名曰法慧菩萨。师子慧菩萨。金刚慧菩萨。调慧菩萨。妙慧菩萨。月光菩萨。宝月菩萨。满月菩萨。勇猛菩萨。无量勇菩萨。无边勇菩萨。超三界菩萨。观世音菩萨。大势至菩萨。香象菩萨。香上菩萨。香上首菩萨。首藏菩萨。日藏菩萨。幢相菩萨。大幢相菩萨。离垢幢菩萨。无边光菩萨。放光菩萨。离垢光菩萨。喜王菩萨。常喜菩萨。宝手菩萨。虚空藏菩萨。离憍慢菩萨。须弥山菩萨。光德王菩萨。总持自在王菩萨。总持菩萨。灭众病菩萨。疗一切众生病菩萨。欢喜念菩萨。餍意菩萨。常餍菩萨。普照菩萨。月明菩萨。宝慧菩萨。转女身菩萨。大雷音菩萨。导师菩萨。不虚见菩萨。一切法自在菩萨。弥勒菩萨。文殊师利菩萨。如是等六十恒河沙菩萨摩诃萨。从无量佛刹。与无央数天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽俱。悉皆来集尊重供养尔时世尊于栴檀重阁。正坐三昧而现神变。有千叶莲华大如车轮。其数无量色香具足而未开敷。一切花内皆有化佛。上升虚空弥覆世界犹如宝帐。一一莲花放无量光。一切莲花同时舒荣。佛神力故须臾之间皆悉萎变。其诸花内一切化佛结加趺坐。各放无数百千光明。于时此刹庄严殊特。一切大众欢喜踊跃。怪未曾有咸有疑念。今何因缘无数妙花忽然毁变。萎黑臭秽甚可恶餍。尔时世尊。知诸菩萨大众所疑。告金刚慧。善男子。于佛法中诸有所疑恣汝所问。时金刚慧菩萨知诸大众咸有疑念。而白佛言。世尊。以何因缘。无数莲花中皆有化佛。上升虚空弥覆世界。须臾之间皆悉萎变。一切化佛各放无数百千光明。众会悉见合掌恭敬。尔时金刚慧菩萨。以偈颂曰

  我昔未曾睹　　神变若今日
  见佛百千亿　　坐彼莲花藏
  各放无数光　　弥覆一切刹
  离垢诸导师　　庄严诸世界
  莲花忽萎变　　莫不生恶餍
  今以何因缘　　而现此神化
  我睹恒沙佛　　及无量神变
  未曾见如今　　愿为分别说

尔时世尊。告金刚慧及诸菩萨言。善男子。有大方等经名如来藏。将欲演说故现斯瑞。汝等谛听善思念之。咸言善哉愿乐欲闻。佛言善男子。如佛所化无数莲花忽然萎变。无量化佛在莲花内。相好庄严结加趺坐。放大光明众睹希有靡不恭敬。如是善男子。我以佛眼观一切众生。贪欲恚痴诸烦恼中。有如来智如来眼如来身。结加趺坐俨然不动。善男子。一切众生。虽在诸趣烦恼身中。有如来藏常无染污。德相备足如我无异。又善男子。譬如天眼之人。观未敷花见诸花内有如来身结加趺坐。除去萎花便得显现。如是善男子。佛见众生如来藏已。欲令开敷为说经法。除灭烦恼显现佛性。善男子。诸佛法尔。若佛出世若不出世。一切众生如来之藏常住不变。但彼众生烦恼覆故。如来出世广为说法。除灭尘劳净一切智。善男子。若有菩萨信乐此法。专心修学便得解脱。成等正觉普为世间施作佛事。尔时世尊以偈颂曰

  譬如萎变花　　其花未开敷
  天眼者观见　　如来身无染
  除去萎花已　　见无碍导师
  为断烦恼故　　最胜出世间
  佛观众生类　　悉有如来藏
  无量烦恼覆　　犹如秽花缠
  我为诸众生　　除灭烦恼故
  普为说正法　　令速成佛道
  我已佛眼见　　一切众生身
  佛藏安隐住　　说法令开现

复次善男子。譬如淳蜜在岩树中。无数群蜂围绕守护。时有一人巧智方便。先除彼蜂乃取其蜜。随意食用惠及远近。如是善男子。一切众生有如来藏。如彼淳蜜在于岩树。为诸烦恼之所覆蔽。亦如彼蜜群蜂守护。我以佛眼如实观之。以善方便随应说法。灭除烦恼开佛知见。普为世间施作佛事。尔时世尊以偈颂曰

  譬如岩树蜜　　无量蜂围绕
  巧方便取者　　先除彼群蜂
  众生如来藏　　犹如岩树蜜
  结使尘劳缠　　如群蜂守护
  我为诸众生　　方便说正法
  灭除烦恼蜂　　开发如来藏
  具足无碍辩　　演说甘露法
  普令成正觉　　大悲济群生

复次善男子。譬如粳粮未离皮糩。贫愚轻贱谓为可弃。除荡既精常为御用。如是善男子。我以佛眼观诸众生。烦恼糠糩覆蔽如来无量知见。故以方便如应说法。令除烦恼净一切智。于诸世间为最正觉。尔时世尊。以偈颂曰

  譬一切粳粮　　皮糩未除荡
  贫者犹贱之　　谓为可弃物
  外虽似无用　　内实不毁坏
  除去皮糩已　　乃为王者膳
  我见众生类　　烦恼隐佛藏
  为说除灭法　　令得一切智
  如我如来性　　众生亦复然
  开化令清净　　速成无上道

复次善男子。譬如真金堕不净处。隐没不现经历年载。真金不坏而莫能知。有天眼者语众人言。此不净中有真金宝。汝等出之随意受用。如是善男子。不净处者无量烦恼是。真金宝者如来藏是。有天眼者谓如来是。是故如来广为说法。令诸众生除灭烦恼。悉成正觉施作佛事。尔时世尊以偈颂曰

  如金在不净　　隐没莫能见
  天眼者乃见　　即以告众人
  汝等若出之　　洗涤令清净
  随意而受用　　亲属悉蒙庆
  善逝眼如是　　观诸众生类
  烦恼淤泥中　　如来性不坏
  随应而说法　　令办一切事
  佛性烦恼覆　　速除令清净

复次善男子。譬如贫家有珍宝藏。宝不能言我在于此。既不自知又无语者。不能开发此珍宝藏。一切众生亦复如是。如来知见力无所畏。大法宝藏在其身内。不闻不知耽惑五欲。轮转生死受苦无量。是故诸佛出兴于世。为开身内如来法藏。彼即信受净一切智。普为众生开如来藏。无碍辩才为大施主。如是善男子。我以佛眼观诸众生有如来藏。故为诸菩萨而说此法。尔时世尊以偈颂曰

  譬如贫人家　　内有珍宝藏
  主既不知见　　宝又不能言
  穷年抱愚冥　　无有示语者
  有宝而不知　　故常致贫苦
  佛眼观众生　　虽流转五道
  大宝在身内　　常在不变易
  如是观察已　　而为众生说
  令得智宝藏　　大富兼广利
  若信我所说　　一切有宝藏
  信勤方便行　　疾成无上道

复次善男子。譬如庵罗果内实不坏。种之于地成大树王。如是善男子。我以佛眼观诸众生。如来宝藏在无明壳。犹如果种在于核内。善男子。彼如来藏清凉无热。大智慧聚妙寂泥洹。名为如来应供等正觉。善男子。如来如是观众生已。为菩萨摩诃萨净佛智故显现此义。尔时世尊以偈颂曰

  譬如庵罗果　　内实不毁坏
  种之于大地　　必成大树王
  如来无漏眼　　观一切众生
  身内如来藏　　如花果中实
  无明覆佛藏　　汝等应信知
  三昧智具足　　一切无能坏
  是故我说法　　开彼如来藏
  疾成无上道　　如果成树王

复次善男子。譬如有人持真金像。行诣他国经由险路惧遭劫夺。裹以弊物令无识者。此人于道忽便命终。于是金像弃捐旷野。行人践蹈咸谓不净。得天眼者见弊物中有真金像。即为出之一切礼敬。如是善男子。我见众生种种烦恼。长夜流转生死无量。如来妙藏在其身内。俨然清净如我无异。是故佛为众生说法。断除烦恼净如来智。转复化导一切世间。尔时世尊以偈颂曰

  譬人持金像　　行诣于他国
  裹以弊秽物　　弃之在旷野
  天眼者见之　　即以告众人
  去秽现真像　　一切大欢喜
  我天眼亦然　　观彼众生类
  恶业烦恼缠　　生死备众苦
  又见彼众生　　无明尘垢中
  如来性不动　　无能毁坏者
  佛既见如是　　为诸菩萨说
  烦恼众恶业　　覆弊最胜身
  当勤净除断　　显出如来智
  天人龙鬼神　　一切所归仰

复次善男子。譬如女人贫贱丑陋。众人所恶而怀贵子。当为圣王王四天下。此人不知经历时节。常作下劣生贱子想。如是善男子。如来观察一切众生。轮转生死受诸苦毒。其身皆有如来宝藏。如彼女人而不觉知。是故如来普为说法。言善男子莫自轻鄙。汝等自身皆有佛性。若勤精进灭众过恶。则受菩萨及世尊号。化导济度无量众生。尔时世尊以偈颂曰

  譬如贫女人　　色貌甚庸陋
  而怀贵相子　　当为转轮王
  七宝备众德　　王有四天下
  而彼不能知　　常作下劣想
  我观诸众生　　婴苦亦如是
  身怀如来藏　　而不自觉知
  是故告菩萨　　慎勿自轻鄙
  汝身如来藏　　常有济世明
  若勤修精进　　不久坐道场
  成最正觉道　　度脱无量众

复次善男子。譬如铸师铸真金像。既铸成已倒置于地。外虽焦黑内像不变。开摸出像金色晃曜。如是善男子。如来观察一切众生。佛藏在身众相具足。如是观已广为显说。彼诸众生得息清凉。以金刚慧捶破烦恼。开净佛身如出金像。尔时世尊以偈颂曰

  譬如大冶铸　　无量真金像
  愚者自外观　　但见焦黑土
  铸师量已冷　　开摸令质现
  众秽既已除　　相好画然显
  我以佛眼观　　众生类如是
  烦恼淤泥中　　皆有如来性
  授以金刚慧　　捶破烦恼摸
  开发如来藏　　如真金显现
  如我所观察　　示语诸菩萨
  汝等善受持　　转化诸群生

尔时世尊告金刚慧菩萨摩诃萨。若出家若在家。善男子善女人。受持读诵书写供养。广为人说如来藏经。所获功德不可计量。金刚慧若有菩萨为佛道故。勤行精进修习神通。入诸三昧欲殖德本。供养过恒河沙现在诸佛。造过恒河沙七宝台阁。高十由旬纵广正等各一由旬。设七宝床敷以天缯。为一一佛日日造立过恒河沙七宝台阁。以用奉献一一如来及诸菩萨声闻大众。以如是事普为一切过恒河沙现在诸佛。如是次第乃至过五十恒沙众宝台阁。以用供养过五十恒沙现在诸佛及诸菩萨声闻大众。乃至无量百千万劫。金刚慧。不如有人乐喜菩提。于如来藏经受持读诵书写供养乃至一譬喻者。金刚慧。此善男子。于诸佛所种诸善根福虽无量。比善男子善女人所得功德。百分不及一千分不及一。乃至算数譬喻所不能及。尔时世尊重说偈言

  若人求菩提　　闻持此经者
  书写而供养　　乃至于一偈
  如来微妙藏　　须臾发随喜
  当听此正教　　功德无有量
  若人求菩提　　住大神通力
  欲供十方佛　　菩萨声闻众
  其数过恒沙　　亿载不思议
  为一一诸佛　　造立妙宝台
  台高十由旬　　纵广四十里
  中施七宝座　　严饰备众妙
  敷以天缯褥　　随座各殊异
  无量过恒沙　　献佛及大众
  悉以此奉献　　日夜不休息
  满百千万劫　　所获福如是
  慧者闻此经　　能持一譬喻
  而为人解说　　其福过于彼
  乃至于算数　　譬喻所不及
  众生之所依　　速成无上道
  菩萨谛思惟　　甚深如来藏
  知众生悉有　　疾成无上道

尔时世尊。复告金刚慧菩萨言。过去久远无量无边。不可思议阿僧祇劫。复过是数。尔时有佛。号常放光明王如来应供等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。金刚慧。何故名曰常放光明王。彼佛本行菩萨道时。降神母胎常放光明彻照十方千佛世界微尘等刹。若有众生见斯光者一切欢喜。烦恼悉灭色力具足念智成就得无碍辩。若地狱饿鬼畜生阎罗王阿修罗等见光明者。皆离恶道生天人中。若诸天人见光明者。于无上道得不退转具五神通。若不退转者皆得无生法忍五十功德旋陀罗尼。金刚慧。彼光明所照国土。皆悉严净如天琉璃。黄金为绳以界八道。种种宝树花果茂盛香气芬馨。微风吹动出微妙音。演畅三宝菩萨功德根力觉道禅定解脱。众生闻者皆得法喜。信乐坚固永离恶道。金刚慧。彼十方刹一切众生蒙光明故。昼夜六时合掌恭敬。金刚慧。彼菩萨处胎出生。乃至成佛无余泥洹常放光明。般泥洹后舍利塔庙亦常放光。以是因缘诸天世人。号曰常放光明王。金刚慧。常放光明王如来应供等正觉初成佛时。于其法中有一菩萨名无边光。与二十亿菩萨以为眷属。无边光菩萨摩诃萨于彼佛所。问如来藏经佛为演说。在于一坐经五十大劫。护念一切诸菩萨故。其音普告十佛世界微尘等百千佛刹。为诸菩萨无数因缘百千譬喻。说如来藏大乘经典。诸菩萨等闻说此经受持读诵如说修行。除四菩萨皆已成佛。金刚慧。汝莫异观。彼无边光菩萨岂异人乎。即我身是。彼四菩萨未成佛者。文殊师利。观世音。大势至。汝金刚慧是。金刚慧。如来藏经能大饶益。若有闻者皆成佛道。尔时世尊重说偈曰

  过去无数劫　　佛号光明王
  常放大光明　　普照无量土
  无边光菩萨　　于佛初成道
  而启问此经　　佛即为演说
  其有遇最胜　　而闻此经者
  皆已得成佛　　唯除四菩萨
  文殊观世音　　大势金刚慧
  此四菩萨等　　皆曾闻此法
  金刚慧为彼　　第一神通子
  时号无边光　　已曾闻此经
  我本求道时　　师子幢佛所
  亦曾受斯经　　如闻说修行
  我因此善根　　疾得成佛道
  是故诸菩萨　　应持说此经
  闻已如说行　　得佛如我今
  若持此经者　　当礼如世尊
  若得此经者　　是名佛法主
  则为世间护　　诸佛之所叹
  若有持是经　　是人名法王
  是为世间眼　　应赞如世尊

尔时世尊说此经已。金刚慧。及诸菩萨四众眷属。天人乾闼婆阿修罗等。闻佛所说欢喜奉行大方等如来藏经


大方广宝箧经

    No. 462 [No. 461]

大方广宝箧经卷上

        宋天竺三藏求那跋陀罗译

如是我闻。一时佛在舍卫国只陀林给孤穷精舍。与大比丘僧千二百五十人俱。菩萨五千。尔时世尊住迦利罗华园场上。菩萨声闻大众围绕而演说法。尔时文殊师利童子。与五百菩萨释梵护世恭敬围绕。往世尊所。至已顶礼佛足。绕七匝已。却坐一面。及菩萨眷属亦坐一面。尔时文殊师利童子白世尊言。今日如来为说何法。随次续说勿令断绝。时大德须菩提语文殊师利。世尊先为声闻说法。文殊师利。我今请汝说菩萨法。于时文殊师利童子语须菩提。大德今用菩萨法为。大德须菩提。一切声闻及与缘觉非菩萨法器。须菩提言。文殊师利唯愿演说。诸器众生自当听受。文殊师利童子报言。大德须菩提。汝今能知是佛法器及非器耶。须菩提言。文殊师利。我等声闻因他声解。岂能得知是佛法器及非器乎。文殊师利。我请汝说是佛法器非佛法器。文殊师利言。大德须菩提诸入正位皆是非器已为法界所系持故。若观法界而不舍放一切众生不堕正位不共结住。如是等人是佛法器。复次大德须菩提。若到学法无学法界为所缚者。舍一切众生焦然结缚。心生疲倦怖畏三界。乃至一念不乐住结。是等名为非佛法器。大德须菩提。若有能尽未来际劫。发大庄严不怖不畏。行三界行不为三垢之所染污。于生死中起园观想。欲乐诸有不集有行。如是等人名佛法器。复次大德须菩提。若无欲染示现染欲。非为嗔恼示现有嗔。不为痴覆示现有痴。除断结使现住三界。导引众生无有自高。荷担重任一切众生。能令无上三宝种性。具足不断住三昧门。如是等人名佛法器。大德须菩提语文殊师利。法性是一如一实际。云何分别说器非器。文殊师利言。大德须菩提。譬如陶家以一种泥造种种器。一火所熟或作油器苏器蜜器或盛不净。然是泥性无有差别。火然亦尔无有差别。如是如是。大德须菩提。于一法性一如一实际。随其业行器有差别。苏油器者喻声闻缘觉。彼蜜器者喻诸菩萨。不净器喻小凡夫。须菩提言。文殊师利。颇有是器说名非器非器为器。文殊师利言有须菩提言。何者是也。文殊师利言。大德须菩提。一切结使名为非器。一切结习名为非器。是名非器。是亦说名为佛法器。若断一切诸烦恼者。如是之器非佛法器。须菩提言。所言器者为何所盛。文殊师利言。无盛为盛。若所盛不漏知是完器。若所盛漏失知是破器。大德须菩提。犹如虚空是诸药木丛林之器。然非是器。如是大德须菩提。菩萨亦尔。是佛法器然非是器。大德须菩提。犹如从地出生诸树。以空器故得有增长。如是大德须菩提。菩萨从诸善心出生。为般若波罗蜜器之所增长。须菩提言。而是菩萨何所增长。文殊师利言。如虚空增长。菩萨增长亦复如是。而是菩萨无有增长亦无退减。何以故。不增结使不退佛法。须菩提言。文殊师利佛法结使有何差别。文殊师利言。大德须菩提。如须弥山王光所照处悉同一色。所谓金色。如是须菩提。般若光照一切结使悉同一色。谓佛法色。是故须菩提。佛法结使以般若慧观等无差别。是故大德须菩提。一切诸法皆是佛法。须菩提言。文殊师利。以何缘故一切诸法皆是佛法。文殊答言。如佛智所觉。又问。云何如佛智所觉。文殊答言。如汝初始后亦如是不离如故。是以说言如佛智所觉。又问。所言初后云何初后。文殊答言。初空后寂故名初后。须菩提言。空之与寂有何差别。文殊师利言。大德须菩提。于意云何。如生金与熟金有何差别。答言。以言说故而有差别。文殊师利言。如是大德须菩提。以言说故言空言寂。若有智者不著文字不执文字。须菩提言。文殊师利。凡夫智者有何别相。文殊师利言。大德须菩提。如佛所说以业相故名为凡夫。以业相故名为智者。须菩提言。文殊师利。业有何相。文殊师利言。因缘为相。随其所行有差别名。若无所行则无别名。凡夫有行有差别名。慧者无行无差别名。有无中间名为圣行。然此圣行于诸凡夫名为非行。又问。文殊师利。所言圣者为何谓也。文殊答言。同入无著无诤句故。又问。文殊师利。颇有诸法亦入无著无诤句不。文殊言有大德须菩提。须菩提言。何者是也。答言。须菩提。一切众流入大海已为一碱味。如是须菩提。一切诸法皆悉入于无著无诤同为一味。谓解脱味。须菩提言。解脱何事说名解脱。文殊师利言。大德须菩提。以何因缘故或有缚者或有无缚。须菩提言。无智故缚。文殊师利言。如是断无智故名为解脱。须菩提言。诸法平等云何说智及与无智。文殊师利言。如春热时名为热水。如冬降寒名为冷水。然其水性无有差别。如是须菩提。不正思惟烦恼所热名为无智。若正思惟名曰为智。然其此中无有士夫。名智无智。须菩提言。文殊师利。此义难觉。文殊师利言。大德须菩提。行二行故。须菩提言。是义难见。文殊师利言。无慧眼故。须菩提言。此义难入。文殊师利言。不得底故。须菩提言。此义难知。文殊师利言。增上慢故。须菩提言。此义难觉。文殊师利言。舍离觉故。须菩提言。此义难脱。文殊师利言。乐樔窟故。须菩提言。此义难思。文殊师利言。是中无相行故。须菩提言。此义难觉难观。文殊师利言。是中无言说故。须菩提言。此义叵得。文殊师利言。是中乃至无少义故。须菩提言。此义乃是智者所解。文殊师利言。解自心如故。文殊师利。如来所说谓利非利。何故世尊说如是句。文殊师利言。大德须菩提。所言利者名不可得。于是事中欲有所得。是利名非利。大德须菩提。又复利者名为寂静。是中若起身心之行。是利名非利。是故如来说利非利。须菩提言。如佛所说一切法非法。此何谓也。文殊师利言。大德须菩提。如佛所说能知我法如筏喻者。法尚应舍况复非法。若法应舍则不名法不名非法。须菩提言。文殊师利。如来佛法可非法耶。文殊师利言。大德须菩提。如来佛法无有决定。若无决定则不应说是法非法。是故佛说一切法非法。须菩提言。希有文殊师利。新行菩萨闻如是说而不惊怖。文殊师利言。汝意云何。师子王子闻师子吼有惊怖不。如雁王子行虚空中畏堕空不。须菩提言。不也文殊师利。文殊师利言。如是须菩提。若有如来种性菩萨。去至如中从如出生。闻一切法一切音声一切所说而不惊畏。大德须菩提。凡有畏者于何而畏。须菩提言。若以我见为实有者是则有畏。文殊师利言。菩萨解知了我见故。于一切法一切音声一切所说不生惊畏。须菩提言。文殊师利。若其菩萨知解我见。何不得果。文殊师利言。无有菩萨得证果者。菩萨之人唯观察知。为趣佛智不取果证。菩萨常于一切众生修行大悲。虽知我见不堕证果。须菩提言。而是菩萨善巧方便。虽知我见而不取果。文殊师利言。如是大德。若有菩萨为智方便界所摄者。而是菩萨虽知我见而不取果。大德须菩提。如大力士执持利刀斩娑罗树。虽断犹住不即堕落。如是须菩提。菩萨若于一切众生。有大慈悲大方便智。虽知我见而不证果大德须菩提。或时天降大润泽雨。是娑罗树即便还生。生叶华果利益众生。如是须菩提。菩萨若为大慈大悲之所润洽。菩萨智界还生三界。示现受于种姓生死。为诸众生作大利益。大德须菩提。设有大风吹是娑罗树。觚枝茎果便堕于地。如是大德须菩提。是诸菩萨为大智慧猛风吹。堕道场上毕竟永灭。尔时世尊赞文殊师利。善哉善哉。善说菩萨智方便界。大慈大悲相应说法。文殊师利听吾说。喻如大龙王生于是心。兴起大云遍是云中。雨热霹雳至处皆烧。复雨大雨为生长故。如是文殊师利。方便菩萨起大智慧及方便云。现行一切诸凡夫事教化凡夫。现行圣行调伏众生。文殊师利。如大香树根香。有异茎香叶香华香果香各各别异。如是文殊师利。菩萨所有智慧香身亦复如是。随诸众生所应闻解出相应法香。然大悲根而不移动。文殊师利。如毗楞伽摩尼宝珠在帝释颈。悉遍普照三十三天。以珠力故一切所有皆悉照现。然此宝珠无有忆想。如是文殊师利。净宝珠者喻菩萨智性现一切事。而是菩萨无一切想。文殊师利。如如意珠能满一切众生所愿。然是宝珠无有忆想。如是文殊师利。菩萨所有净意宝珠。能满一切众生所愿。于一切处无有忆想。文殊师利。如因虚空火得炽然因空下雨。而是虚空无有寒热。如是文殊师利。方便菩萨住在三界。行寂涅槃不为结热。在佛法中无所染着二俱利益。文殊师利。如因虚空出生毒树亦生药树。然是虚空不为毒害非药除净。如是文殊师利。若有智慧方便菩萨。五阴之身犹如毒树。信等五根如彼药树。非阴结染非根净结二俱有利。文殊师利。如漉水筒若暂一塞水则不漏。若复暂放其水便漏。如是文殊师利。若有智慧方便菩萨。住于三昧成就大通不着诸界。若暂起定现漏诸界。随其所应而演说法。文殊师利。如极好鸟善护氄者不自惜身。如是文殊师利。住大悲菩萨。善护众生不自惜身。文殊师利。如师子兽王无所畏惧。唯除猛火。如是文殊师利。方便菩萨不畏一切。唯除声闻缘觉解脱。文殊师利。如伊罗宁龙象是畜生道。能现一切诸庄严事。由是帝释福德力故。如是文殊师利。菩萨乃能作于畜生现法庄严。随所应度而化度之。文殊师利。如火燧出火宝珠出火二俱能烧。如是文殊师利。若有菩萨始初发心乃至道场最后之心。二俱能烧一切众生一切结使。文殊师利。犹如诸树有种种色种种香种种果。皆因四大而得生长。如是文殊师利。菩萨以种种门集诸善根。一切皆摄在菩提心。回向菩提以为增长。文殊师利。如转轮王轮宝若去四兵皆从。如是文殊师利。菩萨方便智波罗蜜。随所至处。所有一切助菩提法皆悉随从。文殊师利。犹如迦陵频伽鸟王卵中鸟子。其嘴未现便出迦陵频伽妙声。如是文殊师利。佛法卵中诸菩萨等。未坏我见未出三界。然能演出佛法妙音。谓空无想无作行音。文殊师利。如迦陵频伽。至孔雀群终不鸣呼。还至迦陵频伽鸟中乃复鸣呼。如是文殊师利。菩萨若至一切声闻缘觉众中。终不演说不可思议诸佛之法。至菩萨众尔乃演说。文殊师利。如旋岚大风。阎浮界内树木诸山无能当者。如是文殊师利。菩萨演说不可思议诸佛法时。学及无学声闻缘觉。除佛护持不能信解。若信解者是佛护持。文殊师利。犹如日宫所出光明。净秽等照无有增减无能呵者。如是文殊师利。方便菩萨放智光明。虽与一切凡夫共俱不为所坏。与声闻缘觉俱不为所染。无有能呵菩萨方便智慧光者。文殊师利。如波利质多拘毗陀罗树。若叶落时三十三天欢喜踊跃。作如是言。是树不久当生华果。如是文殊师利。若有菩萨能一切舍。是时诸佛皆大欢喜。而是。菩萨不久当与一切众生生法华法果。文殊师利。如调弱树随风动转不畏摧折。如是文殊师利。菩萨善能随顺众生。则不畏堕一切声闻缘觉地中。文殊师利。犹如水流顺下而去。如是文殊师利。无慢菩萨亦复如是。流趣顺向于一切智。文殊师利。犹如大海始初安时其处最卑。然后众流悉皆归之。如是文殊师利。菩萨除灭憍慢贡高。然后佛法悉流归之。文殊师利。如金刚珠能破一切诸余众宝。而此宝珠无能坏者。如是文殊师利。方便菩萨调伏。一切声闻缘觉而不堕中。文殊师利。如曼陀罗华无风之时香气普遍满一由旬。如是文殊师利。方便菩萨无圣慧根。慈香普遍一切众生。文殊师利。如曼陀罗华有嗅香者一切病愈无诸苦患。如是文殊师利。大慈大悲诸菩萨等若有随喜。一切结病悉皆除灭无有逼恼。文殊师利。如佛出世优昙钵华则便出现。如是文殊师利。有菩萨出世。诸佛法华皆悉出现。文殊师利。如阿那婆达多大龙王雨遍阎浮提。如是文殊师利。菩萨如是。以大法雨等心普润一切众生。文殊师利。如彼阿那婆达多池。流出四河满于大海。如是文殊师利。诸菩萨等。以四摄法流注充满一切智海。文殊师利。由有大海阎浮提人有诸珍宝。如是文殊师利。由菩萨故。令诸声闻缘觉充足解脱法宝。文殊师利。一切诸色皆依四大。如是文殊师利。菩萨所有一切诸法。为诸众生住解脱依。文殊师利。如山险处生大药树。不能利益诸多人众。如是文殊师利。若从声闻法调伏者。不能利益一切众生。文殊师利。如大城中生大药树利益多人。如是文殊师利。菩萨从于大慈大悲中出生已。不舍一切智宝之心。能多利益一切众生。文殊师利。如暴雨水势不久流。如是文殊师利。声闻说法势不久住。文殊师利。如春水流便得经久。如是文殊师利。菩萨说法得久住世。文殊师利。如雪山树虽复斫截不久还生。如是文殊师利。如来施作诸佛事已便入涅槃。三宝之种而不断绝。尔时大德须菩提白佛言。希有世尊。今乃演说菩萨所有无量无边诸法功德真实功德。世尊倍复希有。菩萨闻是真实功德无喜无高。佛言须菩提。诸菩萨根本自净故。闻诸功德不喜不高。须菩提言。世尊。云何菩萨根本自净。佛言须菩提。无我根净。无众生根净。无命根净。无丈夫根净。无人根净。无身见根净。无无明有爱根净。无我我所根净。须菩提言。世尊。何谓为净。佛言须菩提。无缚无解。是名为净。无生无灭无去无来。是名为净。无妄想无分别。无高无下。无作无不作。无闇无明。无恼无不恼。无缚无解。无生死无涅槃。是名为净。须菩提言。世尊。若无生死无涅槃者。云何名净。佛言须菩提。是净无忆想生死及与涅槃。亦无染着。须菩提。犹如有言净于虚空。实无所除令虚空净。如是须菩提。所言净者实无有法。名之为净。若有闻是而不惊怖。名之为净。须菩提。汝今净不。须菩提言。世尊。我净以无垢故。佛言须菩提。若无有垢为何所净。须菩提言。世尊。法性清净我已知之。佛言。须菩提。汝今能知法界性耶。须菩提言。世尊。若离法界有余法者可知法界。无有法界能知法界。佛语须菩提。无有一法离于法界谁知法界。时须菩提默然不答。尔时文殊师利语须菩提。大德。汝今何故不答如来。须菩提言。以我本不发阿耨多罗三藐三菩提心故。何以故。以我本不修习无尽无碍辩故。如是无尽无碍辩者是菩萨有。有碍有尽是声闻有。文殊师利语须菩提。是法界中有障有碍耶。须菩提言。是法界中无障无碍。无障无碍是法界相。文殊师利言。大德。若其法界无障无碍。汝今何故说时有碍。须菩提言。文殊师利。我已证断故辩有碍。若知法界而不证者则辩无碍。文殊师利言。大德须菩提。法界之中有可断耶。须菩提言。文殊师利。而是法界无能断者。一切法门悉法界故。文殊师利言。若一切法悉是法界。汝何故说我证于断。须菩提言。声闻境界有限齐故说时有断。佛之境界无限量故说无碍无滞。文殊师利言。法界有生耶。须菩提言。是法界者无有境界。灭诸境界是名法界。文殊师利言。大德须菩提。若无境界灭诸境界。汝今何故无境界中说法界也。何故说有种种境界。须菩提言。我先不言有碍有滞是声闻辩。无碍无滞是菩萨辩也。文殊师利言。大德须菩提。汝今不得无碍辩耶。如是文殊师利。我得是辩。文殊师利言。得无碍辩何故默然。须菩提言。不知一切众生根故辩有滞碍。知入一切诸众生根是菩萨辩。是故菩萨说时无碍。文殊师利言。大德须菩提。汝知法界得证辩时。是知境界有碍相耶。不也文殊师利。是智境界是无碍相非是碍相文殊师利言。若智境界无有碍相。汝何不说而默然乎。是时须菩提。语大德舍利弗。佛常称为智慧第一。汝今可问彼当答汝。舍利弗言。汝今可说。我欲从汝及文殊师利听闻于法。须菩提言。我今不说。何以故。我曾见是文殊师利游诸佛土。百千万亿佛前说法。令诸声闻悉皆默然。我今何能于文殊师利前敢有所说。大德舍利弗。东方有国名曰端严。彼中有佛。号曰光相如来应正遍觉。今现说法。有大声闻名曰智灯。智慧第一。时彼如来入于寂定。是智灯大声闻即至梵世。以大音声而演说法。声遍三千大千世界。我随文殊至彼世界。及无量菩萨百千天子侍从文殊。为听法故。时文殊师利。住光音天发大音声。遍闻三千大千世界。时彼智灯大声闻。闻如是大声不能堪忍。从上坠落其心惊怖身毛皆竖。即便往诣光相佛所。到已顶礼佛足绕三匝已。合掌向佛问于是事。世尊。谁作如是可畏音声。我闻是音不能堪忍。从上坠下如旋岚风吹于小鸟。时彼佛告智灯比丘。有不退菩萨。名文殊师利。现大神通来至此土。为欲见我供养恭敬尊重赞叹。住光音天发大音声。是声遍三千大千佛之世界。一切魔宫皆悉隐蔽。时智灯声闻白光相佛。愿欲见是文殊师利大善丈夫。于时彼佛光相如来。即为文殊师利现相。令文殊师利与菩萨众诸天眷属来至佛所。到已顶礼佛足右绕三匝。化作莲华师子座已却坐一面。时智灯大声闻。问文殊师利。汝为何利来至此土。尔时文殊师利童子。语大德智灯。我今为见光相如来礼敬亲近问讯请法故来至此。智灯问言。文殊师利。云何名为清净见佛。云何礼佛。云何亲近。云何问讯。云何请问。文殊师利言。大德智灯。若见法净名见佛净。若身若心不低不仰。若不低仰正直而住。不动不摇。其心寂静行寂静行。大德智灯。是名礼佛。若不自观亦不观他。不观佛不观法不观僧。不观难不观易。不观作不观不作。一体一身。一切佛身等入法身。见于自身同入法性。见如不见无近无远。大德智灯。是则名为亲近于佛。若如来所为修行问非不修行。不见有法不修行者。见自及法入于修行。所问心定无有散乱。问者问处及问讯法俱不可得。无所贪着。于三世中求不可得。如是三场清净问讯。大德智灯。是则名为问讯于佛。若往来问答不求觅过。随顺所问如来印可。大众欢喜不嫉他问。有所问时。令无量众生起庄严道乃至道场。大德智灯。是则名为请问于佛。时光相如来。赞文殊师利。善哉善哉。文殊师利。应当如是见于如来。应如是礼。如是亲近。如是问讯。如是请问。尔时文殊师利童子。问智灯比丘。大德智灯。云何见佛。云何礼佛。云何亲近。云何问讯。云何请问。智灯答云。文殊师利。如汝所问非我境界。我随音声从他而闻如是所说。文殊师利言。大德智灯。若不解是。汝云何得心解脱耶。智灯答言。因圣谛故心得解脱。文殊师利言。云何名圣谛。智灯答言。独修无侣名为圣谛。又复问言。若独修无侣名为圣谛。云何见平等心得圣解脱。答言文殊。我依世谛说非第一义。又问。是世谛者入第一义不。答言文殊。若不入中非第一义。又问智灯。汝云何言依世谛说非第一义。若其世谛入第一义即是一谛谓第一义。时智灯言。文殊师利。初行菩萨闻汝所说则生惊畏。文殊师利言。大德智灯。汝亦惊畏况复初行。智灯答言。都无有能惊畏我者。文殊师利言。大德。岂不怖畏生死心得解脱也。智灯言。文殊师利。怖畏厌患心得解脱。文殊师利言。是故我说。大德智灯。本亦怖畏况复初行。智灯问言。文殊师利。菩萨云何而得解脱。文殊答言。不畏不厌菩萨解脱。问言。文殊不畏不厌言得解脱。此义云何。文殊答言。菩萨不畏百千万亿魔诸军众。菩萨不厌为于一切生死众生。菩萨不畏集诸善根。菩萨不厌集智庄严。以是义故我作是说。不畏不厌心得解脱。尔时会中有诸天子。以种种华散供文殊师利童子。如是叹言。若有住处见文殊师利则为见佛。所说法处应起塔想。若有众生闻是法者。当知是人摄诸德已。时文殊师利。语智灯比丘。佛说大德智慧第一。是智慧者为是有为为是无为。若是有为是生灭三相。若是无为则无三相。智灯答言。修无为故佛说名圣。文殊问言。大德智灯。是无为者可修习不。不也文殊。文殊又言。云何大德。说修无为名之为圣。时智灯大声闻即便默然。尔时光相如来。告文殊师利。可说法门。令诸会众不退无上正真之道。文殊师利白言。世尊。一切诸法是寂静门。一切言说是寂静门。示寂静故。时有菩萨名曰法勇。在会而坐。问文殊师利。如来所说及贪嗔痴。是寂静门示寂静耶。文殊答言。善男子。是贪嗔痴从何所起。答言文殊。从妄想起。文殊又问。是妄想者为住何处。答言文殊。住于颠倒。文殊问言。是颠倒者复住何处。答言。文殊。住不正思念。文殊又问。不正思念为住何处。答言文殊。住我我所。文殊又问。我我所者为住何处。答言文殊。住于身见。文殊又问。是身见者为住何处。答言文殊。住于我见。文殊又问。是我见者为住何处。答言文殊。是我见者则无住处。无处是我见处。何以故。而是我者十方推求了不可得。况复有处。文殊又问。善男子。若法十方求不得者为是何门。答言文殊。都无有门。文殊又问。善男子。而是寂静颇有门不。答言文殊。是亦无门。善男子。以是义故。我说诸法是寂静门。一切言说是寂静门显示寂静。说是法时。八百菩萨逮得于忍。文殊师利广说法已。从坐而起。礼敬光相世尊足已。出众而去。是故舍利弗。当知无有声闻菩萨能尽文殊师利辩者。我今何敢与文殊师利有所论说。尔时大德须菩提。语舍利弗。大德复见文殊师利。何等神变游诸佛国。舍利弗言。大德须菩提。我昔曾与文殊师利。在于西方游诸佛土。见有佛土大火灾起。于彼火中作莲华网。文殊师利从中而过。复见佛土火灾充满。文殊师利从中而过。是火触人如以坚[革*卬]栴檀涂身卧迦尸衣。柔软和适甚为快乐。复有佛土空无所有。文殊师利化作梵宫。入于禅定从中而过。复有佛土极为迮狭。其中众生造诸恶业。文殊师利从中而过。皆令休止而不为恶成觉慧慈。我当得成无上正道。为断众生贪嗔痴故而演说法。令诸众生得慈三昧。是名菩萨成觉慧慈。大德须菩提。我于尔时曾见是事。我又独处曾作是念。文殊师利所有神通。与我神通等无有异。文殊师利知我心已。即便将我游诸佛国。至火灾土而语我言。汝以神力从是中过。我时尽以神通之力。灭是火已经七日夜。我及文殊乃过此界。过已复至第二三千大千火灾世界。倍复广大在中住已。文殊师利而语我言。用谁神力过此世界。我时答言。文殊师利。用汝神力过是世界

大方广宝箧经卷上大方广宝箧经卷中

        宋天竺三藏求那跋陀罗译

尔时文殊师利童子。系心在前。以菩萨神力。于一念顷。作莲华网遍覆火上。从中过已便语我言。大德舍利弗。于意云何。汝神力胜为我胜也。我即答言。文殊师利。金翅鸟王飞速疾耶。为小鸟疾耶。文殊师利。还问我言。汝意云何。而是二鸟何者为疾。我时即答。我之神力如彼小鸟。汝神力胜疾殊特过金翅鸟。文殊师利。即语我言。大德舍利弗。汝独处念。文殊神力我之神力等无有异。我复答言。不可为比。文殊问言。汝云何知。我即答言。声闻之人不断习气。是故我本以不等为等。文殊师利言。善哉善哉如汝所言。舍利弗。乃往过世于大海边有二仙住。一名欲法。二名梵与。是时欲法获得五通。是梵与仙以咒术力能游空行。时彼二人各以自力。度过大海还至住处时梵与仙作如是言。欲法神力我之神力等无有异。复更异时从海此岸至于彼岸到罗叉渚。时有罗叉出箫笛。音时梵与仙闻是声已。从空而堕失咒术力。时欲法仙愍梵与故。捉其右臂将至住处。大德舍利弗。于意云何。是梵与仙岂异人乎。勿作异观。即汝身是。我即是彼欲法仙人。舍利弗。汝于尔时亦以不等为等。今亦复以不等为等。何以故。以偏见故。尔时舍利弗。复语须菩提。我又复念与文殊师利。南方界分游过百千诸佛土已。有国名曰一切庄严。佛号宝大。我与文殊师利俱到彼国。文殊师利既至彼已。而语我言。汝今见此佛土不也。所经诸国皆悉见不。我言见已。复问我言。是诸国中。悉见何事。我时答言。或见满水。或见满火。或见空界。或见丰乐。文殊复言。汝云何见。我时答言。若见满水便言见水。若见满火便言见火。若见空界言见空界。若见丰乐言见丰乐。文殊师利言。汝之所见境界如是。我时问言。文殊师利。汝复云何见诸佛土。文殊答言。虚空世界是诸佛世界。何以故。汝幻惑故。见满水满火空界丰乐。舍利弗。汝之所见皆各不实。生灭相应。虚空世界不因缘有其性安住。如是舍利弗。客尘烦恼污染于心。然其心性终不可污。大德舍利弗。如恒沙劫火灾炽然终不烧空。如是舍利弗。一一众生恒河沙劫。造作逆罪不善之业。然其心性终不可污。舍利弗。若善男子善女人。能解知是法界性净。无覆盖缠无结垢行能恼心者。是名无有盖缠法门。若依此门一切诸法无能覆盖。解一切法体性清净。终无有法能覆心者。大德须菩提。文殊师利神通变化说法如是。我见其为诸神通事。菩萨不达况复声闻。尔时大德阿难。复语舍利弗。我亦曾见文殊师利神通变化。大德舍利弗。昔于一时。世尊在此舍卫国只陀林中给孤穷精舍与大比丘僧八百人俱。诸菩萨众万二千人。是时兴大非时云雨。经七日夜而不休止。诸大德声闻。若得禅定及解脱者。若入禅定七日不食。余凡夫人及诸学人。五日绝食饥困羸瘦。不能往觐见佛世尊礼敬供养。我时念言。是诸比丘甚为大苦。当往白佛。我时便往佛世尊所。顶礼佛足白言。世尊。诸比丘僧绝食五日极为羸瘦。不能从床而自起止。世尊告我。阿难。汝今可以是事往语文殊师利。彼当充足比丘僧食。我承佛敕往诣彼文殊师利所住室中。到已具说如是之事。时文殊师利。为释梵护世而演说法。即答我言。阿难。汝往敷座。若时已至便击楗槌。我从文殊师利闻是语已。即便敷座住在一处。看文殊师利何时出房。是文殊师利甫为释梵护世天王广演说法。名曰分别一切身三昧。不出于房。我作是念。文殊师利将不令诸比丘失食时。文殊师利化作己身。为诸释梵护世。说是分别一切身三昧。文殊师利亦即入此分别一切身三昧已。从房而出。入舍卫大城次第乞食。我时不见。魔王波旬作是念言。文殊师利师子吼已。入舍卫大城而行乞食。我今当蔽舍卫城中。诸婆罗门长者居士。无入出者不令施食尔时文殊师利童子。随所至处门户悉闭无往来者。文殊师利即时观知。是魔波旬隐蔽诸人。我今当作诚实言誓。尔时即作是志诚言。我之所集一毛孔中所有福慧。设恒河沙等诸佛世界。满中诸魔之所无有。我此语实魔蔽当去。令魔自身作居士像。于四衢道诸巷陌中。唱如是言。当施文殊当施文殊。若施是者获大果报。若施三千大千世界。其中所有一切众生。给诸乐具百千亿岁。不如施此文殊师利一爪端许所生福胜。文殊师利。须臾之间立此誓已。尔时诸天遍开城中一切门户。令诸人众皆趣文殊师利童子。时魔波旬作居士像。于诸四衢街巷陌中。唱如是言。当施文殊当施文殊。若施是者获大果报。若施三千大千世界。一切众生诸乐供具。经百千岁。不如施此文殊师利一爪端许所生福胜。时文殊师利。以神通力令所持钵受诸种种美妙饮食及饼果等。不相和杂如别器盛。八百比丘万二千菩萨。所食之食在一钵中。不见此钵若减若满。尔时文殊师利童子。于舍卫大城乞食已足。出舍卫城以钵置地语魔波旬。汝为净人可持此钵在前而去。时魔波旬。不能举钵生惭耻心。语文殊师利。我今不能举此地钵。文殊师利语波旬言。汝今成就大威神力。云何不能举地小钵。时魔波旬。尽其神力不能举钵如毛分许。怪未曾有。语文殊师利。我之神力举伊沙陀山。置之手掌掷虚空中。今不能举如此小钵一毛分许。文殊师利。语波旬言。若大众生大人大力彼所持钵。非汝波旬所能擎举。是时文殊师利童子。即以一指持举地钵着波旬手。语波旬言。汝为净人持钵前行。时魔波旬。尽力持钵在前而去。尔时自在天子与万二千天子。侍从围绕。来向文殊师利童子。顶礼其足。右绕已毕。语波旬言。汝非使人。何故持钵在他前行。魔言天子。我今不堪与有力者诤。天子语言。波旬汝亦成就大威神力。

尔时波旬。为文殊师利力所持故答言天子。愚痴之力是为魔力。慧明之力是菩萨力。憍慢之力是为魔力。大智慧力是菩萨力。诸邪见力是为魔力。空无相无作力是菩萨力。诸颠倒力是为魔力。正真谛力是菩萨力。我我所力是为魔力。大慈悲力是菩萨力。贪嗔痴力是为魔力。三解脱力是菩萨力。生死之力是为魔力。无生无灭无有诸行无生忍力是菩萨力。魔王波旬说是法时。于天众中。五百天子发阿耨多罗三藐三菩提心。千二百菩萨得无生法忍。时文殊师利。共魔波旬持此钵食。置迦利罗华园中已。俱出外去。我时不见文殊师利。乃至食时犹不出房。我作是念。文殊师利。将不令诸比丘僧众失于日时。当往佛所具白是事。即至佛所。顶礼佛足白言。世尊。日时已至。文殊师利犹不出房。佛告我言。阿难。汝不到此迦利罗园而看之耶。我白佛言。大德世尊。见一小钵其食满中。佛告我言。速打揵槌集比丘僧。我言世尊。比丘僧多是一钵食当与谁耶。佛语我言。汝勿虑是。设使三千大千世界所有一切诸众生等。于百千岁食此钵食犹不能尽。何以故。是文殊师利力所持钵。文殊师利有檀波罗蜜无量功德。我闻佛语。便打揵槌集比丘僧。时此钵食不相和杂。香美众味取不可尽。充饱大众钵食不减。时魔波旬。欲恼文殊师利童子。即便化作四千比丘。衣服弊坏威仪粗恶执持破钵。鼻眼角睐卷手脚跛。其形丑恶在下行坐。以此钵食复充足之。时魔波旬。令化比丘人人各食摩伽陀国十种之食。然此钵食犹满不减。令诸守园作使之人赋食疲顿。时文殊师利。以神力持令魔波旬所化比丘钵食不减。手口俱满而不能咽。气闭眼张悉皆躄地。文殊师利语波旬言。汝诸比丘何不更食。恶魔答言。文殊师利。是诸比丘在地垂死。汝将不以毒食与耶。文殊师利语波旬言。已尽毒人当有何毒。内有毒者则施人毒。内无毒者不施人毒。波旬。所谓毒者名贪嗔痴。善赞法中所调伏者。若与人毒无有是处。又魔波旬。所谓毒者无明有爱。见我我所。见无因缘。见于名色。见爱恚嗔。见我见众生。见诸盖缠。计着诸阴。起种性慢。执着诸入。常住三界系着所依守护取舍。若来若去爱着于身。坚着寿命。不净思念爱乐染心。多起诸过。违逆因缘。断见常见。谄曲憍慢。妄想分别。示现诈伪。执着樔窟。出没卷舒惊畏于空。于无想中生堕落想。于无作中生死畏想。于无著处生起畏想。于出生死生起缚想。于使流中不生度想。助菩提法生非法想。于邪见中生正见想。于恶知识生善知识想。违佛谤法轻慢众僧。不舍憍慢增长诤讼。实不实想不实实想。于欲乐中生功德想。于有为中心生狂惑。于生死行不见其过。于涅槃中生惊怖想。波旬。如是诸法于妙法中名之为毒。佛正法中无如是事。波旬。甘露法者是名佛法。安隐法者是名佛法。无戏论法是名佛法。无过恶法是名佛法。无结使法是名佛法。出要之法是名佛法。无怖畏法是名佛法。无分别法是名佛法。不执自他法是名佛法。无讥呵法是名佛法。作舍作依归依洲渚作守护法是名佛法。调伏寂法是名佛法。自净无垢照明之法是名佛法。正向正趣法是名佛法。无诸妄想善调伏法是名佛法。善教善导随宜之法是名佛法。自说说他法是名佛法。如法调伏诸外道法是名佛法。降诸魔法是名佛法。断生死流法是名佛法。正念之法是名佛法。住念处故。正断法是名佛法。断诸恶故。神足法是名佛法。观身心轻故。诸根法是名佛法。信为首故。诸力法是名佛法。无能降伏故。诸觉法是名佛法。次第觉故。正道法是名佛法。正流入故。三昧法是名佛法。究竟寂静故。智慧法是名佛法。贯穿诸圣解脱法故。真谛法是名佛法。无忿恚故。诸辩法是名佛法。法辞及义乐说无滞故。明了无常苦无我法是名佛法。呵毁一切诸有为故。空法是名佛法。降伏一切诸外道故。寂静法是名佛法。趣涅槃故。波罗蜜法是名佛法。至彼岸故。方便法是名佛法。善摄取故。慈法是名佛法。无过智故。悲法是名佛法。无逼故。喜法是名佛法。灭不喜故。舍法是名佛法。所作办故。禅法是名佛法。灭憍慢故。不断三宝法是名佛法。发菩提心故。一切安乐无苦恼法是名佛法。不来诸有故。说是法时。魔王所将五百天子。发阿耨多罗三藐三菩提心。而作是言。世尊。是所叹法。愿令我等住是法中。尔时世尊即便微笑。大德阿难前白佛言。大德世尊今何缘笑。佛告阿难。汝见波旬化比丘不。阿难白言。见已世尊。佛言阿难。后五百岁法欲灭时。当有如是恶形比丘。如是恶衣着不齐故。如是下贱如是无智。何以故。后世比丘重于结使。贪着利养多营众事。舍诸毗尼越解脱戒离白净法。其所去来重现法利。不重后世。盲聋跛蹇。老谬无智。着种种病。是等皆来于我法中出家受戒。以重眷属给使人故。不为重法。阿难。我所说法如是正直。如是可爱。当于尔时。不见不闻诸天忧戚。魔王波旬当大欢喜无复忧虑。我时问佛。何故魔王波旬欢喜而无忧虑。佛告阿难。以彼恶人作魔业故。魔王波旬无所营作。何以故。由彼比丘无正行故。若有比丘勤加精进如救头然。如是等人魔则求短。是故阿难应勤方便。未得令得未解令解未证令证。降伏魔党炽然佛法。护持正法作法供养莫作放逸。是我教法。说是法时五百比丘放舍身命白言。世尊。我等不欲见是恶世。踊处虚空以火焚身。百千诸天而供养之。二百比丘远离尘垢得法眼净。二百比丘永尽诸漏心得解脱。三万二千菩萨逮得法忍。释梵护世及诸眷属。礼佛足已作如是言。唯愿世尊。久寿住世勿使我等见是恶世。世尊。若有众生得闻此经。终不更作懈怠非法。亦更不作魔诸恶业。我时闻已闷绝躄地。大德舍利弗。我见文殊师利童子。成就如是不可思议神通之力。及所说法我自亲见。时大德迦叶语舍利弗。我亦曾见文殊师利希有神通。舍利弗。尔时世尊成佛未久。我久出家。是时文殊师利童子。始初至此娑婆世界。从宝王世界宝相佛所来。欲见佛释迦牟尼供养恭敬。尔时世尊在舍卫国只陀林中给孤穷精舍。夏坐三月。我时不见文殊师利。若如来前。若众僧中。若于食时。若说戒日。若僧行次。都不见之。过三月已。临自恣时乃见其面。我即问言。文殊师利。何处夏坐。即答我言。大德迦叶。我住在是舍卫大城波斯匿王后宫一月。复一月住童子学堂。复一月住诸淫女舍。我闻是已。心甚不悦。即作是念。云何当共是不净人而作自恣。我即出堂便击楗槌欲摈文殊师利童子。尔时世尊。即告文殊师利童子。汝往看是摩诃迦叶。今者何故打楗槌也。白言。世尊。我已见之。欲摈于我。佛语文殊师利童子。今可现汝自在神力神通境界。令彼声闻心得清净。勿于汝所生不净心。于时文殊师利童子即入三昧。其三昧名现一切佛土。文殊师利入三昧时。十方各如恒河沙等诸佛世界。其中皆有摩诃迦叶。头陀第一。悉打楗槌。于时世尊即问我言。摩诃迦叶。汝今何故打于楗槌。我言。世尊。文殊师利自说是言。夏三月中。住王后宫及淫女舍。为摈是故打于楗槌。尔时世尊身放光明遍照十方。而告我言。汝今遍观十方世界为见何事。我时遍观无量无边恒河沙数十方世界。其中皆有摩诃迦叶而打楗槌。欲摈文殊。是一切处亦有文殊在佛前坐。佛告我言。汝今欲摈何处文殊为此世界。为十方界。我时即礼佛世尊足作如是言。听我悔过。世尊。是文殊师利法王之子。成就菩萨如是不可思议功德。我从佛所成有量智。而欲度量无量智慧。以不知故而打楗槌。佛告我言。摩诃迦叶。汝之所见十方世界文殊师利。亦复夏三月。住王后宫及淫女舍。此间文殊师利童子。令是波斯匿王宫中五百女人。不退阿耨多罗三藐三菩提。亦令五百淫女五百童子。得不退转无上正道。复有百千众生以声闻法而调伏之。无量众生得生天上。我时白言。大德世尊。文殊师利为说何法。乃能如是教化众生。佛言。迦叶。汝今可问文殊师利。自当答汝。我时即问文殊师利。汝说何法教化调伏如是众生。彼答我言。非唯说法教导众生。大德迦叶。或有众生以娱乐乐而调伏之。或以护持。或以威伏。或以财摄。或以贪求。或现大庄严。或现神通。或现释身。或现梵身。或现护世身。或转轮王身。或随各各所事诸天而为现身。或以软语。或以粗语。或二俱用。或以讁罚。或以密益。或现作子。何以故。大德迦叶。众生有于杂种之行。以杂种法而调伏之。大德迦叶。我以方便化众生界。然后说法令其究竟毕竟调伏。我时问言。文殊师利。汝所调伏有几众生。即答我言。大德迦叶。我所调伏等如法界。我又问言。法界几许。文殊答言。如众生界。我又问言。众生界者复有几许。即答我言。如虚空界。如是迦叶。众生界法界虚空界。等无有二无有别异。我又问言。文殊师利。佛空出世无所调伏。文殊师利言。大德迦叶。如人热病。是人种种妄有所说。是中宁有天鬼持耶。有大明医饮彼人酥。热病即愈止不妄说。于意云何。是中颇有天鬼去不。我言。不也文殊师利。由饮苏故热病除差。大德迦叶。是良医者多利彼不。我言。如是。文殊师利。文殊师利言。大德迦叶。世间如是颠倒热病无我我想。住我想已流转生死。是故如来出现于世随彼形色应解法门。知解我想断于颠倒。为彼众生而演说法。既闻法已除一切想无所执着。知解想已越度诸流到于彼岸。名为涅槃。大德迦叶。于意云何。是中颇有我及众生寿命养育人及丈夫可涅槃者不。我时答言。无也文殊师利。文殊师利言。大德迦叶。为是利故如来出世。但为显示平等想故。不为生不为灭。但为解知烦恼不实。我时语言。文殊师利。菩萨所作甚为难有。所谓观知众生之性毕竟寂静。为欲利益一切众生。不舍庄严不没不出。众生之性毕竟涅槃。犹复能发大誓庄严文殊师利言。大德迦叶。菩萨庄严等同如如。我又问文殊师利。愿说菩萨发大庄严。文殊师利言。菩萨摩诃萨。发大庄严有三十二。何等三十二。菩萨摄取无量生死发大庄严。如梦空性故。菩萨灭度无量众生发大庄严。无我相故。菩萨供养给事无量诸佛世尊发大庄严。同法身相故。菩萨听受一切佛法发大庄严。如响声相故。菩萨守护一切佛法发大庄严。解达诸法平等相故。菩萨降伏一切诸魔发大庄严。一切结使性相净故。菩萨降伏一切外道发大庄严。令有无见者解因缘相故。菩萨所有一切悉舍发大庄严。一切悉舍无余相故。菩萨集戒头陀功德发大庄严。无行相故。菩萨忍力发大庄严。无伤相故。菩萨精进发大庄严。解知身心寂静相故。菩萨一切禅定解脱发大庄严。舍离一切所依相故。菩萨无碍般若波罗蜜发大庄严。净除无明痴见相故。菩萨方便发大庄严。示现一切所作相故。菩萨大慈发大庄严。如空相故。菩萨大悲发大庄严。解知五道虚空相故。菩萨大喜发大庄严。无忧恼相故。菩萨大舍发大庄严。离苦乐相故。菩萨修满大神通智发大庄严。犹如掌中观见解脱无疑相故。菩萨不念诸法无我发大庄严。不畏堕彼声闻缘觉地之相故。菩萨观阴犹如怨贼发大庄严。知幻相故。菩萨观四大犹如毒蛇发大庄严。同法界相故。菩萨观入犹如空聚发大庄严。知怨贼相故。菩萨不着三界发大庄严。无樔窟故。菩萨决定摄取诸有发大庄严。有非有相故。菩萨大悲发大庄严。不退相故。菩萨为大医王发大庄严。随诸众生所有疾患施法药相故。菩萨为大商主发大庄严。示导三乘出道相故。菩萨不断于三宝种发大庄严。知报一切佛恩相故。菩萨知诸法性无生发大庄严。得于无生法忍相故。菩萨为得不退转地发大庄严。舍于三界一切结使。及舍声闻缘觉地相故。菩萨庄严道场发大庄严。以一念相应慧如实了知诸法相故。如是迦叶。是名菩萨三十二种发大庄严。菩萨摩诃萨。以是庄严自庄严者。是四大体可易其性。而是菩萨于无上道终不退转。我即答言。发大庄严犹尚不退况三十二。文殊师利。声闻法中无有庄严。文殊师利言。大德迦叶。是故声闻无大庄严。如诸菩萨乃至名字。大德迦叶。于意云何。如大健夫以诸铠仗。善自庄严执持利刀。有怯弱人粗自庄严。是二庄严可相比不。我言。不也。文殊师利言。以是义故。大德迦叶。菩萨庄严。一切声闻及诸缘觉之所无有。说是菩萨大庄严时。万二千天子发于无上正真道心。是故舍利弗。我见文殊师利童子。不可思议神通智慧如是无量。尔时大德富楼那弥多罗尼子语舍利弗。我亦曾见文殊师利童子所为。昔于一时。佛在毗舍离庵罗树林。与大比丘五百人俱。是时萨遮尼乾陀子。住毗舍离大城之中。与六万眷属俱。供养恭敬。我入三昧观是尼干。我时见有百千尼干应当受化。我时即往而为说法。无有专听无善好心。反见轻笑出粗恶言。我时唐苦于三月中无一受化。过三月已我心不悦便舍而去。时文殊师利。即便化作五百异道自为师范。将五百弟子往诣萨遮尼干子所。顶礼其足。白萨遮言。我遥承闻大师名德故。远而来至毗舍离。汝是我师我为弟子。愿见纳受垂愍教诲。令我不见沙门瞿昙。令我不闻彼相违法。萨遮答言。善哉善哉。汝得纯净。不久当解我调伏法。尔时萨遮即便宣令己之徒众。此五百摩纳。自今以去和合同住互相咨问。彼若所说汝专心受。尔时文殊师利童子。及五百化弟子。听次第坐。受用尼揵戒法。威仪殊胜于彼。时时赞说三宝功德。亦复赞叹萨遮功德。令彼诸人心相亲附。复于异时知众已集。文殊师利便作是言。我等所行咒术经书毗提遮经。若读诵时。沙门瞿昙所有功德。有入我等经中来者。是沙门瞿昙有实法功德。何以故。是沙门瞿昙所生成就。父母清净转轮王种。以百福相庄严其身。又闻生时大地震动释梵扶侍。自行七步口出是言。我于一切世中最胜世中最大。我今当为灭诸生死。空中自然出生二水释梵洗浴。人天伎乐不鼓自鸣。放大光明遍照世界。灭诸恶道聋盲视听。当于是时一切众生不为结恼。安乐无为。婆罗门相。若不出家作转轮王。若其出家作佛法王。而彼瞿昙舍转轮王位出家修道。于道场上降伏百亿魔。成菩提道转妙法轮。沙门婆罗门。魔梵及世。若天若人。一切世间无能转者。所说真正初中后善。云何初善。谓身善行口意善行。云何中善。学行胜戒学胜定胜慧。云何后善。谓空三昧解脱法门。无相三昧解脱法门。无愿三昧解脱法门。复次初善者信欲不放逸。中善者定念一处。后善者善妙智慧。复次初善者信佛不坏。中善者信法不坏。后善者信于圣僧得果不坏。复次初善者从他闻法。中善者正念修行。后善者得圣正见。复次初善者知苦断集。中善者修行正道。后善者证于尽灭。是名声闻初中后善。云何菩萨初中后善。若不舍于菩提之心是名初善。不念下乘是名中善。回向一切智是名后善。复次初善者于诸众生慈心平等。中善者于诸众生起大悲心设何方便。后善者喜舍同等。复次初善者降伏悭贪舍离破戒远离嗔恚断除懈怠。不住乱心杀害无知。中善者施戒忍进禅定智慧。后善者以诸波罗蜜回向一切智。复次初善者谓四摄法教化众生。中善者不惜身命守护正法。后善者善巧方便不堕正位。复次初善者如地等持不舍一切菩萨行心。中善者以善方便知进知退住不退地。后善者于一生灌顶正位。是名菩萨初中后善

大方广宝箧经卷中大方广宝箧经卷下

        宋天竺三藏求那跋陀罗译

尔时文殊师利童子。外道众中渐次开示如是正法。令五百外道远离尘垢得法眼净。八千外道发于无上正真道心。尔时文殊师利童子。所可化作五百徒众。于文殊师利前。五体投地作如是言。南无佛陀。南无佛陀。余诸外道未信解者。见五百摩纳作如是语。亦皆效彼五体投地而作是言。南无佛陀。南无佛陀。尔时释提桓因。以曼陀罗华。各与诸人而作是言。汝可以此供养于佛。尔时文殊师利童子。与诸大众恭敬围绕诣世尊所。到已顶礼佛足却住一面。时诸大众亦皆礼佛却住一面。尔时尼干外道弟子。以曼陀罗华散供佛已。右绕三匝于一面住。文殊师利所化摩纳。以文殊师利力所持故白言。世尊。我等今来不为见佛。何以故。如来者名为法身。世尊。我等不为听法。何以故。不可听者名之为法。世尊。我等不为僧德。何以故。如来圣僧修无为故。世尊。我等不为功德。何以故。是法界中无有功德咸称赞故。世尊。我等不为修道。何以故。一切诸法究竟道故。世尊。我等不为得果。何以故。无叶华果名为解脱。世尊。我等不为知苦。何以故。离于二行名为解脱。世尊。我等不为断集。何以故。诸法究竟无和合故。世尊。我等不为证灭。何以故。一切诸法毕竟灭故。世尊。我等不为修道。何以故。离有无故。世尊。我等不修念处。何以故。一切诸法离处非处故。世尊。我等不为正断。何以故。一切诸法离善不善无记行故。世尊。我等不为神足。何以故。一切诸法无去来故。世尊。我等不为于根。何以故。一切诸根是离义故。世尊。我等不为于力。何以故。一切诸法无力非力故。世尊。我等不为于觉。何以故。第一义中无有觉故。世尊。我等不为正道。何以故。无有去尽世间边故。世尊。我等不为修定。何以故。常寂定中无娆动故。世尊。我等不为修慧。何以故。出世间慧无余杂故。世尊。我等不为三明。何以故。彼此明处毕竟无故。世尊。我等不为解脱。何以故。性法善系故。世尊。我等不为沙门。何以故。离结聚故名为沙门。世尊。我等不为婆罗门。何以故。断诸形色名婆罗门。世尊。我等不为比丘。何以故。法性无坏故。世尊。我等不为彼岸。何以故。六入常灭故。世尊。我等不为少欲。何以故。乃至无有少许欲故。世尊。我等不为知足。何以故。法无取故。世尊。我等不为寂静。何以故。身心无失故。世尊。我等不为知识。何以故。不与三界共住止故。世尊。我等不近亲友。何以故。不见有二故。世尊。我等不为阿练儿。何以故。三界诸行皆阿练儿故。世尊。我等不修无诤。何以故。独一无侣名为无诤。世尊。我等不为乞食。何以故。我等永断于食相故。世尊。我等不畏一切生死诸行。何以故。不见实故。世尊。我等不怖畏避贪嗔愚痴。何以故。无有妄想诸分别故。世尊。我等不勤断结。何以故。一切烦恼其性如如无染污故。世尊。我等不出我见。何以故。自身非身故。世尊。我等不净诸见。何以故。诸烦恼性如如相故。世尊。我等不断颠倒。何以故。常乐我净性解脱故。世尊。我等不度诸流。何以故。不见此岸及彼岸故。世尊。我等不断五盖。何以故。是盖解脱所贯穿故。世尊。我等不出诸缠。何以故。是真实际无缠相故。世尊。我等不为断悔。何以故。不悔真谛名为沙门。世尊。我等不舍离疑。何以故。常信清净解脱法故。世尊。我等不拔忧箭。何以故。为解脱信所贯穿故。世尊。我等不为涅槃。何以故。一切诸法究竟涅槃故。说是法时。二百比丘不起诸漏心得解脱。是时众中二百比丘。先得四禅住增上慢。谓最后身轻慢他人。从坐起去作如是言。是所说法与诸一切世间相违。我等本闻说随顺法。而今闻说非法非毗尼非导师说。富楼那言。我时即语文殊师利。是二百比丘从坐起去作如是言。是所说法与诸世间共相违反。文殊师利言。大德富楼那。有因缘故。是所说法与世相违。何以故。富楼那。世间住着阴界诸入。是诸人等。欲舍生死趣向涅槃。而不能知生死实性。永不可得即是涅槃。不知是中无生死行无至涅槃。忍是不知。言与生死世间相违。计有四谛者与是相违。第一义中无有是四。又无道无德。言相违者以住二故。若已住二便有相违。道平等故一切法等名为无二。若解无二则不相违。若计我者有增上慢。有增上慢者则有相违。若不作上亦不作下。是平等中不作上下无作无不作。若如是者名无增上慢。若无增上慢则无相违。如佛所说。我不与世诤世间与我诤。何以故。诤讼等事佛悉断故。何等是名为诤讼本。所谓是实是不实是正是邪。如佛说言。婆罗门所言实者。于汝意云何。为是虚妄非是实耶。正也邪也。若是俱无。汝以何事而得知也。尔时文殊师利。于二百比丘所去道前。化满大火令不能过。随所趣方皆见满火而不能过。即以神力欲乘空去。上见铁网而笼遮之。时是比丘。上见铁网下见大火。不知方所惊怖毛竖。唯见趣向只陀林道。以杂莲华而庄严之。及见多众趣向佛所欲听受法。即便回还至只陀林迦利罗华园向世尊所。到已顶礼佛足却住一面。富楼那言。我时即问彼诸比丘。汝至何处从何所来。诸比丘言。大德富楼那。我是罗汉诸漏已尽。成就四禅具诸神通。我从文殊师利童子。闻相违法弃舍而去。见此佛土满中大火而不能过。即以神力上升虚空。复见铁网笼遮于上下见大火我等今欲问佛漏尽阿罗汉地。时佛告我。富楼那。若有大火能避大火无有是处。富楼那。若堕见网能出铁网无有是处。富楼那。若堕爱水能过水界无有是处。何以故。富楼那。是诸比丘有贪嗔痴火未断灭。以是事故不能出火。富楼那。是诸比丘堕在见网。是故不能出于铁网。富楼那。是诸比丘堕在爱水。能过大水无有是处。富楼那。而是火界铁网水界无有来处去无所至。文殊师利力所持故见如是事。富楼那。贪欲嗔痴诸见有爱。如是诸法无有来处去无所至。从于颠倒妄想分别欲贪自他。由是故生死生无我无有所属。若无乱心起正修行。于一静处庄严修禅。若得禅已不起憍慢不住不着。定心所作观察诸法。何法是因何法是缘。如是观察如实而见。所谓无明缘行。乃至忧悲大苦聚集。是名堕邪。如是无明灭则行灭。乃至忧悲大苦聚灭。是名正见。是无为正位。无有过去无明可灭。无未来现在无明可灭。但不正思念便起无明。若无明灭不正思惟更不复起。若是不正思惟灭者无明亦灭。无明若灭名毕竟灭。是故无明灭则诸行灭。若正思惟如实观知。是四大身痴无所知。如草木瓦砾。如影如焰。如我所说。是身如是是心如是。是意如是是识如是。是心无形色不可抱持。犹之如幻不可言说。非外非内非两中间而可得之。若有比丘如是成就正思惟者。知一切法本来不生若法不生即第一义。说是法时。是二百比丘不受诸法。诸漏永尽心得解脱。尔时萨遮尼乾陀子。失诸徒众愁忧不悦来趣舍卫。至只陀林给孤穷精舍迦利罗园佛世尊所。共相问讯却住一面白言。瞿昙。我数数闻沙门瞿昙以幻术力夺他徒众。今乃亲见。令文殊师利。破我徒众将至佛所。受行邪法不来我所不受我教听用在意。是时有一出家外道。名曰胜志。在会而坐。是胜志外道。以亲厚意语萨遮言。止止尼干。勿于世尊及比丘僧文殊师利所生不敬心。莫长夜失利受苦。不乐堕在恶道。萨遮尼干听我说喻以明斯义。譬如有人愚痴无智欲求索酥。持瓶往趣恒河。取水至于异处。以钻钻之甚大疲苦了不见酥。如是尼干汝诸外道。欲修断结受戒炙身。威仪法用悉皆是邪无所能断。犹如彼取恒河水人。复于世尊调伏法中而起嗔恚当堕地狱畜生饿鬼。又言。尼干。复有一人生便聪慧。欲求苏时取纯好乳。盛着器中。以钻钻之。用功甚少大得生酥。从于生酥转得熟酥。复因熟酥转得醍醐如是尼干。佛正法中在家出家。具足净信多有解向。勤修胜进速得解脱。如彼智人为得酥故以乳置器。又复尼干。如有二人。其一人者。破彼一人百千瓦器。以好宝器而用偿之尼干于意云何。是人为损彼人不也。尼干答言。不也胜志。如是尼干。外道弟子如彼瓦器。破已便入如来法中。如得宝器增而无损。又复尼干。如有商主愚无方便。将诸人众至于非道。复有商主。有大智慧愍是诸人安置正路。如是尼干。汝等如彼自称为师。是不知道者。不善道者。不见道者。不能说道。是故汝等引导众生趣于非道。今者世尊为大商主。知导善道。见道说道。导诸外道安置正路尼干。汝之徒众悉在于此汝可将去。是时余有万二千人。还从萨遮服道而去。其余住者已逮得明。佛即告言。善来比丘皆成沙门。尔时佛告胜志外道。汝今见此万二千人随从萨遮去者不也。见已世尊。佛言。胜志。是等诸人悉当至彼弥勒佛所初会数中。何以故。是等由闻如是深法及供养我。而是萨遮亦弥勒佛所智慧第一。如今我所舍利弗也。何以故。我知是人于我信解。以我慢故不舍是见。尔时胜志语文殊师利。后末世中多有比丘起增上慢文殊师利言。善男子。后末世中法欲灭时。增上慢者甚为难得。何以故不能修行得四禅故。得四禅已起增上慢。后末世中法欲灭时。诸比丘等不能住心况得四禅。是故善男子。后末世时增上慢者甚为难得。又善男子。增上慢者凡有二种。何等二。一者信见。二者禅慢。起禅慢者。为于利养及名称故起增上慢是。信见者。起增上慢谤佛正法是。增上慢者当堕地狱畜生饿鬼。胜志问言。文殊师利。欲知他心是增上慢。当云何知。文殊师利言。凡夫人者欲得涅槃实非罗汉。若闻是说惊畏恐怖。当知此是凡夫之人增上慢也。非是如来实阿罗汉。若从他闻惊畏恐怖。当知是人即是凡夫是增上慢非是罗汉。是犹能净报所施恩然非罗汉。若无一切结使烦恼。彼无所依是世福田。若有一切结使烦恼。则有所依非世福田。若在是中。当知是人为增上慢。一切诸法摄入涅槃若于是中分别观察。当知是人为增上慢。一切诸法不应知不应断。不应证不应修。不知此实。当知是人名增上慢。胜志问言。文殊师利。无增上慢者有何印相。文殊师利言。不违无灭。是无增上慢之印相。何以故。无有音声。能令其人生惊怖畏如师子王。一切音声不能令其惊畏恐怖。无增上慢比丘亦尔。闻诸音声不生恐怖。何以故。彼知音声犹如响故。如彼响声无心意识而有音声。如是如实知心意识。一切音声皆从缘起无有真实。如是知已不知何法定名为声。若闻佛声而不贪爱。闻外道声复不呵毁。闻善净法心不贪爱。闻垢污法而不呵毁。善知一切所有音声前后际故。如是印相无增上慢。无高下印。如实印。正见道印。入一道印。入法界平等印。如不怀印。不违如印。住实际印。第一义空印。三世等印。初无生印。观正法性印。如是等印印一切法。如是比丘名为无诤。闻已无疑不惊不畏不恐不怖。不得于我不得于法一切平等。尔时胜志外道白言。世尊。我今从是善知识所。闻是真道大乘功德。世尊。我今从是文殊师利。闻说是法。发阿耨多罗三藐三菩提心。善哉世尊。唯愿如来如应说法。令我闻已速疾修集助菩提法。逮得无上正真之道。广为一切无量阿僧祇诸众生故。佛告胜志。菩萨有二法。速得明达具足大乘。何等二。所谓精进及不放逸。是中精进谓如法得财一切悉舍。不放逸者施不望报。皆以回向于一切智。又精进者正断一切恶不善法。成满具足一切善法。不放逸者谓坚持净戒不为后生。悉以回向于无上道。又精进者不惜身命修行忍辱。不放逸者于诸众生无侵害心。又精进者进诸善法无有厌惓。不放逸者进诸善根向无上道。又精进者于诸禅支心无疲惓。不放逸者于诸禅支不贪味着。又精进者进诸多闻无有厌足。不放逸者正念修行圣智圣慧。又精进者不舍四摄。不放逸者起化众生。又精进者身心坚住。不放逸者不得身心舍离着法。又精进者慈心等缘一切众生。不放逸者不得所缘众生慈法。又精进者教他众生发一切智心。不放逸者观一切法皆悉如幻。而不舍离一切智心。又精进者发起三昧。不放逸者将护不令堕于漏尽。又精进者如救头然修集圣谛。不放逸者不随证灭。又精进者为满诸相集善无惓。不放逸者观于法身。又精进者修净佛土。不放逸者净众生界。又精进者集三十七助菩提法。不放逸者安住寂静解脱之法。胜志当知。菩萨所有善方便业。皆由精进而得成办。菩萨所有一切智业。因不放逸而得成就。是故说言。菩萨成就智慧方便。不畏退转无上正道。说是法时。胜志外道得无生法忍。心净喜悦上升虚空高七多罗树。三千大千世界六种震动大光普照。诸天伎乐不鼓自鸣。天雨众华。尔时世尊知胜志心而便微笑。诸佛常法若微笑时。若干百千杂色光炎从面门出。普照无量无边世界。上过梵世障日月光隐蔽魔宫。还右绕身百千匝已。从顶上入。尔时大德阿难承佛神力。从坐而起正于衣服。偏袒右肩右膝着地。向佛合掌而说偈言

  智慧福力华　　圆光导世间
  三十二相华　　杂好以自严
  行如象师子　　精进力勇出
  世尊何故笑　　愿导师演说
  其言如雷音　　佛音师子吼
  迦陵频伽音　　柔软梵音声
  三千世界声　　诸天及与人
  欲比佛音声　　算数不能及
  声闻及缘觉　　并及诸菩萨
  智无与佛等　　不知一切智
  牟尼智力说　　为于何事笑
  人天龙修罗　　闻疾得菩提
  心得离二边　　亦不执于中
  一切无执着　　等同如虚空
  一切无能数　　过一切世上
  我问等空智　　以何因缘笑
  青绿金色光　　红紫赤白色
  从面门出炎　　如恒河沙等
  普照无量界　　广远如虚空
  灭恶道得乐　　导师光触故
  若放膝光明　　是授声闻记
  若手放光明　　是说辟支佛
  佛定记大乘　　一切智慧道
  光利众生已　　还入无垢顶
  善哉人中天　　三界所供仙
  愿如实敷演　　导师一向说
  断疑悦大众　　以何因缘笑
  千万亿众生　　闻已心欢悦

如是请已。佛告阿难。汝今见是胜志善男子不。上升虚空高七多罗树。得无生忍合掌礼我。百千诸天而供养之。阿难白言。见已世尊。佛言。阿难。是胜志善男子。曾于七十二亿佛所。种诸善根行菩萨道。修集无上正真之道。尔时常作大转轮王恭敬供养是诸如来尊重赞叹。常修梵行。悉皆护持。是诸佛法。阿难。是胜志善男子从今已往。当值无量无数诸佛。恭敬供养尊重赞叹。常修梵行。令无量阿僧祇众生住菩提道。过是无量阿僧祇劫。集菩提道已。当得无上正真之道成最正觉。号智光王如来应供正遍觉乃至佛世尊出现于世。国名嬉见。劫名一宝严。阿难。是嬉见土所受用物。犹如他化自在天中。彼国众生不漏色声香味触法无诸恶色。彼诸众生互相恭敬欢喜悦乐。是诸众生皆悉往见智光王佛。乃至梦中亦常见佛不离念佛。是故彼土名曰嬉见。于是劫中唯一如来施作佛事。佛及众生寿等一劫。是故彼劫名一宝严。阿难。是智光王佛。纯菩萨僧九十二亿。皆是初会得不退转。是智光王如来欲涅槃时。先当授彼师子进去菩萨记。当得作佛。号师子相如来应供正遍觉乃至佛世尊。寿十中劫然后涅槃。当有无量无边菩萨僧。佛涅槃时。以全身舍利起一宝塔。纵广六十由旬。高八十由旬众宝严饰。无量众生而供养之。尔时胜志菩萨从空来下。顶礼佛足右绕七匝。向佛叹说不坏法界偈

  色界及法界　　众生界同等
  是界等智界　　今授我记已
  受界烦恼界　　与空界同等
  诸法同是界　　今我同此来
  法界及欲界　　及与于三界
  等同如虚空　　我记同于是
  生死界涅槃　　等住如法界
  是界及水界　　地界风火界
  阴入及与界　　眼界眼识界
  意界及法界　　是境界同等
  不授我阴记　　不授界入记
  不授名色记　　不授内外记
  以音声故知　　导师受我记
  音声是寂静　　佛无有心意
  作心而授记　　我亦无有识
  得受于道记　　如我佛亦然
  如佛我亦然　　诸众生亦尔
  授记受记尔　　受记是真实
  如如悉舍离　　不坏于法界
  安住真实际　　我礼等正觉
  同入一切法　　如虚空无作
  学知方便故

尔时胜志菩萨。偈赞佛已顶礼佛足。右绕七匝却坐一面。尔时佛告阿难。汝受持是经读诵书写。于大众中广为人说。阿难白言。我已受持。世尊。此经何名当云何奉持之。佛告阿难。是经名为文殊师利神通所持。亦名灭除一切诸魔外道音声。亦名采宝。亦名宝箧。如是受持。说是经已。文殊师利童子。胜志菩萨等。及大声闻大德阿难。及诸大众天龙夜叉诸天及人乾闼婆等。闻佛所说皆大欢喜

大方广宝箧经卷下


大方广如来藏经

    No. 667 [No. 666]

大方广如来藏经

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

如是我闻。一时婆伽梵。住灵鹫山宝盖鹿母宅。于栴檀藏大楼阁中。成等正觉十年之后。当热时际。与大苾刍众千人俱有学无学声闻罗汉。诸漏已尽无复烦恼。皆得自在心善解脱。慧善解脱获得正智。犹如大龙所作已办。舍弃重担逮得已利。尽诸有结到于彼岸。所谓具寿大迦叶波具寿沤楼频蠡迦叶波。具寿那提迦叶波具寿伽耶迦叶波。具寿大迦旃延具寿俱郗罗。具寿薄俱罗具寿离波多。具寿须菩提具寿满慈子。具寿语自在具寿舍利子。具寿大目揵连具寿憍陈如。具寿乌陀夷具寿罗呼罗。具寿难陀具寿邬波难陀具寿阿难陀。与如是等上首苾刍一千人俱。复有六十殑伽河沙数菩萨摩诃萨俱。从种种佛刹而来集会。皆是一生补处。得大神通力无所畏。已曾承事无量俱胝那庾多百千诸佛。悉皆能转不退法轮。若有无量阿僧祇世界有情才称名者。皆于阿耨多罗三藐三菩提得不退转。所谓法慧菩萨师子慧菩萨。虎慧菩萨义慧菩萨。胜慧菩萨月光菩萨。宝月光菩萨满月光菩萨。大勇健菩萨无量勇健菩萨。无边勇健菩萨三世勇健菩萨。得大势菩萨观自在菩萨。香象菩萨香悦菩萨。香悦吉祥菩萨吉祥藏菩萨。计都菩萨大幢菩萨。无垢幢菩萨无上幢菩萨。极解宝刹菩萨无垢宝刹菩萨。欢喜王菩萨常欢喜菩萨。虚空库菩萨迷卢菩萨。大迷卢菩萨苏迷卢菩萨。功德宝光菩萨陀罗尼自在王菩萨。持地菩萨除一切有情病菩萨。欢喜意菩萨忧悲意菩萨。无忧菩萨光藏菩萨。栴檀菩萨于此无争菩萨。无量雷音菩萨起菩提行菩萨。不空见菩萨一切法自在菩萨。慈氏菩萨曼殊室利童真菩萨。如是等而为上首。有六十殑伽沙数菩萨摩诃萨俱

复有无量世界中。无量阿僧祇。天龙药叉揵达嚩阿苏罗孽噜茶紧那罗摩呼罗伽人非人等皆来集会。复有国王大臣寮佐。长者居士及诸人众皆来集会

尔时世尊。与百千众前后围绕恭敬供养。尔时世尊于栴檀藏大楼阁中。食时后入佛神力故。从栴檀藏忽然涌出俱胝那庾多百千莲花。一一莲花有俱胝那庾多百千叶。量如车轮色香具足。是诸莲花上升虚空。遍覆一切诸佛刹土共相合成。如宝宫殿安住虚空。彼一切俱胝那庾多百千莲花皆悉开敷。于一一花中皆有如来结跏趺坐。具三十二大丈夫相放百千光。是时以佛威神力故。诸莲花叶忽然痿瘁。形色臭秽而可厌恶皆不悦意。于花胎中诸如来等。各放无量百千光明。普现一切诸佛刹土皆悉端严

尔时一切菩萨及四部众皆悉惊愕。生奇特想怪未曾有。以佛世尊现作如是神通之事。大众见斯咸怀疑惑作是念言。何因缘现俱胝那庾多百千莲花。于须臾顷形色变坏。甚可厌恶无复悦意。于莲花中现如来相。结跏趺坐放百千光明。如是光明令人爱乐

尔时金刚慧菩萨摩诃萨。及诸大众皆悉云集于栴檀藏大楼阁中恭敬而坐

尔时世尊告金刚慧菩萨摩诃萨言。汝善男子今应可问如来应正等觉甚深法要

尔时金刚慧菩萨摩诃萨承佛圣旨。普为一切天人世间。菩萨摩诃萨及四部众怀疑惑故。白佛言世尊以何因缘。一切世界现于俱胝那庾多百千莲花。一切于花胎中皆有如来。结跏趺坐放百千光。是诸莲花忽然之间。形色可恶而令生厌。于彼花中俱胝那庾多百千如来。合掌而住俨然不动

尔时金刚慧菩萨摩诃萨以伽他问曰

  我曾不见如来相　　而作神通之变化
  现佛无量千俱胝　　住莲花胎寂不动
  放千光明而影现　　悉皆映蔽诸佛刹
  奇特于法而游戏　　彼诸佛等悉端严
  犹如妙宝而显现　　于恶色莲花中坐
  是莲花叶皆可恶　　云何作是大神通
  我曾见佛如恒沙　　见彼殊胜神通事
  我未曾见如是相　　如今游戏之显著
  唯愿天中尊说示　　何因何缘而显现
  唯愿世利作哀愍　　为除一切诸疑惑

尔时世尊告金刚慧等上首菩萨。及一切众菩萨言。诸善男子有大方广如来藏经甚深法要。如来欲说是故先现如是色相。汝等善听极善听作意思惟

尔时金刚慧菩萨等一切菩萨摩诃萨言。善哉世尊愿乐欲闻

佛言诸善男子。如此如来变化莲花忽然之间。成恶色相。臭秽可恶令不爱乐。如是花中而现佛形。结跏趺坐放百千光明。相好端严人所乐见。如是知已有多天龙药叉健达嚩阿苏罗[薩/子]路茶紧那罗摩呼罗伽人非人等。礼拜供养如是如是。善男子。如来应正等觉。以佛自己智慧光明。眼见一切有情欲嗔痴贪无明烦恼。彼善男子善女人。为于烦恼之所凌没。于胎藏中有俱胝百千诸佛悉皆如我。如来智眼观察彼等有佛法体。结跏趺坐寂不动摇。于一切烦恼染污之中。如来法藏本无摇动。诸有趣见所不能染。是故我今作如是言。彼等一切如来如我无异。善男子如是如来以佛智眼。见一切有情如来藏。善男子譬如以天妙眼。见于如是恶色恶香。诸莲花叶缠裹逼迫。是以天眼见彼花中。佛真实体结跏趺坐。既知是已欲见如来。应须除去臭秽恶业。为令显于佛形相故。如是如是。善男子如来以佛眼。观察一切有情如来藏。令彼有情欲嗔痴贪无明烦恼藏。悉除遣故而为说法。由闻法故则正修行。即得清净如来实礼。善男子如来出世若不出世。法性法界一切有情。如来藏常恒不变

复次善男子。若诸有情可厌烦恼藏缠。为彼除害烦恼藏故。净如来智故。如来应正等觉。为于菩萨而说法要。作如是事令彼胜解。既胜解已于法坚持。则于一切烦恼随烦恼而得解脱。当于是时如来应正等觉。于其世间而得其数。是能作于如来佛事。尔时世尊说伽他曰

  如彼莲花可厌恶　　并其胎叶及须蕊
  譬如天眼而观见　　是如来藏无所染
  若能除去萎花叶　　于中即见如来身
  复不被诸烦恼染　　则于世间成正觉
  今我悉见诸有情　　内有如来微妙体
  除彼千俱胝烦恼　　令厌恶如萎莲花
  我为彼等而除遣　　我智者常说妙法
  佛常思彼诸有情　　悉皆愿成如来体
  我以佛眼而观见　　一切有情住佛位
  是故我常说妙法　　令得三身具佛智

复次善男子譬如蜜房。悬于大树其状团圆。有百千蜂遮护其蜜。求蜜丈夫以巧方便。驱逐其蜂而取其蜜随蜜所用。如是如是善男子。一切有情犹如蜜房。为俱胝百千烦恼随烦恼之所藏护。以佛智见能知此已。则成正觉。善男子如是蜜房。智者丈夫既知其蜜。亦复了知于俱胝百千众烦恼蜂之所守护。如是一切有情。以如来智见知已成佛。于彼为俱胝百千烦恼随烦恼之所遮覆。善男子如来以巧方便力。为害蜂者教诸有情。驱逐欲嗔痴慢憍覆忿怒嫉悭烦恼随烦恼故。如是说法。令诸有情不为烦恼之所染污。无复逼恼亦不附近。善男子云何此等有情。我以如来智见为净。除故于诸世间而作佛。事善男子以清净眼。见诸有情如是清净。尔时世尊说伽陀曰

  犹如蜜房状团圆　　众蜂护而所隐覆
  求蜜丈夫而见已　　悉皆驱逐于众蜂
  我见有情在三有　　亦如蜜房无有异
  俱胝众生烦恼蜂　　彼烦恼中如来住
  我佛常为净除故　　害彼烦恼如逐蜂
  以巧方便为说法　　令害俱胝众烦恼
  云何成佛作佛事　　常于世间如蜜器
  犹如辩才说好蜜　　令证如来净法身

复次善男子。譬如稻麦粟豆。所有精实为糠所裹。若不去糠不堪食用。善男子求食之人。若男若女以其杵臼舂去其糠而充于食如是如是。善男子如来应供正遍知。以如来眼。观见一切有情具如来体。为烦恼皮之所苞裹。若能悟解则成正觉。坚固安住自然之智。善男子彼如来藏。处在一切烦恼之中。如来为彼有情除烦恼皮。令其清净而成于佛。为说于法。常作是念。何时有情[兌*皮]去一切烦恼。藏皮得成如来出现于世。尔时世尊说伽他曰

  譬如稻谷与粟床　　大小麦等及于豆
  彼等为糠之所裹　　是不堪任于所食
  若能舂杵去于糠　　于食种种而堪用
  精实处糠而不堪　　不怀有情为作利
  我常观见诸有情　　以烦恼裹如来智
  我为除糠说妙法　　愿令速悟证菩提
  与我等法诸有情　　住百烦恼而藏裹
  为令净除我说法　　何时速成诸佛身

复次善男子。譬如臭秽诸恶积聚。或有丈夫怀挟金砖于傍而过。忽然俣落坠于秽中。而是金宝沉没臭秽。或经十年或二十年。或五十年或百千年处于粪秽。是其本体不坏不染。亦不于人能作利益。善男子有天眼者。见彼金砖在于臭秽。告余人言丈夫汝往。于彼粪秽之中有金胜宝。其人闻已则便取之。得已净洗随金所用。善男子臭秽积聚者。是名种种烦恼及随烦恼。彼金砖者是名不坏法。有天眼者则是如来应正遍知。善男子。一切有情如来法性真实胜宝。没于烦恼臭秽之中。是故如来应正等觉。为于有情除诸烦恼臭秽不净。而说妙法当令成佛。出现世间而作佛事。尔时世尊说伽他曰

  譬如有人怀金砖　　忽然俣落于粪秽
  彼处秽中多岁年　　虽经久远而不坏
  有天眼者而观见　　告余人言此有金
  汝取应洗随意用　　如我所见诸有情
  没烦恼秽流长夜　　知彼烦恼为客尘
  自性清净方便说　　令证清净如来智

复次善男子譬如贫穷丈夫。宅内地中有大伏藏。纵广正等一俱卢舍。满中盛金。其金下深七丈大量。以地覆故。其大金藏曾不有言语。彼丈夫丈夫我在于此名大伏藏。彼贫丈夫心怀穷匮。愁忧苦恼日夜思惟。于上往来。都不知觉。不闻不见彼大伏藏在于地中。如是如是善男子一切有情住于执取作意舍中。而有如来智慧。力无所畏诸佛法藏。于色声香味触耽着受苦。由此不闻大法宝藏。况有所获。若灭彼五欲则得清净

复次善男子如来出兴于世。于菩萨大众之中。开示大法种种宝藏。彼胜解已则便穿掘。入菩萨住如来应供正遍知。为世间法藏。见一切有情未曾有因相。是故譬喻说大法藏为大施主。无碍辩才无量智慧。力无所畏不共佛法藏。如是善男子。如来以清净眼。见一切有情具如来藏。是以为于菩萨宣说妙法。尔时世尊说伽他曰

  譬如贫人家伏藏　　金宝充满在于中
  是彼不动不思惟　　亦不自言是某物
  彼人虽复为主宰　　受于贫乏而不知
  彼亦不说向余人　　而受贫穷住苦恼
  如是我以佛眼观　　一切有情处穷匮
  身中而有大伏藏　　住诸佛体不动摇
  见彼体为菩萨说　　汝等穿斯大智藏
  获得离贫作世尊　　能施无上之法财
  我皆所说而胜解　　一切有情有伏藏
  若能胜解而精勤　　速疾证于最胜觉

复次善男子譬如藤子多罗子。赡部果子阿摩罗果子。由其子芽展转相生成不坏法。若遇地缘种植于其。久后成大树王。如是如是善男子。如来以如来眼。见一切有情欲嗔痴贪无明烦恼乃至皮肤边际。彼欲嗔痴无明烦恼藏中有如来藏性。以此名为有性。若能止息名为清凉。则名涅槃。若能净除无明烦恼是有情界。是则名为大智聚体。彼之有情名大智聚。若佛出现于天世间说微妙法。若见此者则名如来。善男子若彼见如来应正等觉。令诸菩萨摩诃萨。咸皆悟解如来智慧令显现故。尔时世尊说伽他曰

  譬如藤子之中树　　藤芽一切而可得
  于根赡部咸皆有　　由其种植复得生
  如是我见悉无余　　一切有情喻藤子
  无漏最胜佛眼观　　是中备有如来体
  不坏是藏名有情　　于中有智而不异
  安住在定处寂静　　亦不动摇无所得
  为彼净故我说法　　云何此等成正觉
  犹如种子成大树　　当为世间之所依

复次善男子譬如贫人。以一切宝作如来像长可肘量。是贫丈夫欲将宝像经过险路。恐其盗却即取臭秽故破弊帛。以缠其像不令人测。善男子是贫丈夫在于旷野忽然命终。如来宝像在于臭秽弊恶帛中。弃掷于地流转旷野。行路之人往来过去践踏跳蓦。不知中有如来形像。由彼裹在臭秽帛中弃之在地。而皆厌恶岂生佛想。是时居住旷野诸天以天眼见。即告行路余人而言。汝等丈夫此秽帛中有如来像。应当速解一切世间宜应礼敬。如是如是善男子。如来以如来眼。见一切有情如彼臭秽故帛烦恼。长于生死险道旷野之所流转。受于无量傍生之身。彼一切有情烦恼臭秽故弊帛中。有如来体如我无异。如来为解烦恼秽帛所缠裹故。为诸菩萨而说妙法。云何得净如来智见去离烦恼。得一切世间之所礼故犹如于我。尔时世尊说伽他曰

  譬如秽帛令厌恶　　缠裹彼之如来体
  宝像秽帛之所缠　　弃于旷野险恶处
  诸天天眼而见已　　即告行路余人言
  宝像在彼臭帛中　　应当速解而恭敬
  我以天眼如是见　　我观一切诸有情
  被烦恼帛之所缠　　极受忧恼生死苦
  我见烦恼秽帛中　　结跏趺坐如来体
  安住寂然不倾动　　皆无所有解脱者
  为见彼已而惊悟　　汝等谛听住胜觉
  一切有情法如是　　于怖畏中常有佛
  即解彼已现佛身　　彼时一切烦恼静
  是故号名于如来　　人天欢喜而供养

复次善男子或有孤独女人。恶形臭秽容貌丑陋如毕舍支。人所见者厌恶恐怖。止于下劣弊恶之家。偶然交通腹中怀妊。决定是为转轮王胎。然彼女人虽复怀妊亦曾无有如是思念。唯怀贫匮下劣之心。由心羸劣常作是念。我形丑陋寄于下劣弊恶之家。而过时日。亦不足知是何人类生于我腹。如是如是善男子。一切有情无主无依。生三有中寄于下劣弊恶之舍。为生死苦之所逼迫。然一一有情有如来界具如来藏。是彼有情不觉不知。善男子如来不令一切有情而自欺诳。佛为说法。善男子汝等莫自欺诳。发大坚固精进之心。汝等身中皆有佛体。于其后时毕成正觉。汝今已入于菩萨数即非凡夫。久后亦堕于如来数即非菩萨。尔时世尊说伽他曰

  譬如妇人无依主　　形容丑恶令厌怖
  寄于弊恶下劣家　　或时而有王胎孕
  彼怀如是之胎孕　　决定是为转轮王
  其王威德七宝围　　统领四洲为主宰
  彼愚丑女曾不知　　于已腹中有如是
  在于贱贫弊恶舍　　怀贫穷苦心忧恼
  我见一切诸有情　　无主受于穷迫苦
  在于三界中耽乐　　身中法藏如胎藏
  如是见已告菩萨　　一切有情具法性
  胎中世利有光明　　应生恭敬勿欺诳
  发坚精进以修持　　不久自身成作佛
  不久当坐菩提场　　解脱无量俱胝众

复次善男子。譬如以蜡作模。或作马形象形男形女形。泥裹其上而用火炙。销炼真金铸于模内。候其冷已。是其工匠将归舍宅。其模外为黑泥覆弊。形状燋恶内有金像。或工匠及工匠弟子。知其模冷即坏其泥既净持已。于须臾顷是金宝像则便清净。如是如是善男子。如来以如来眠观见一切有情。如金像模外为烦恼泥所覆裹。于内虚冲满有佛法无漏知宝。善男子我今观见一切有情悉皆如是。在菩萨众而说妙法。若菩萨摩诃萨。若得寂静清凉。如来为彼有情。以金刚器仗净其法眼。除其烦恼及随烦恼。为净如来智宝藏故。善男子如来犹如持宝像者。善男子而破彼色及随烦恼。令得解脱是名如来。善男子如来应正等觉。见一切有情如来藏。为无边俱胝烦恼藏中之所沉没。为彼有情破烦恼藏。于佛智见安立无上正等菩提。尔时世尊说伽他曰

  譬如外色泥作模　　于内空虚无所有
  销炼真金满铸泻　　其数或百或一千
  工匠之人知冷已　　则破其泥现于像
  泥除则净其宝像　　匠意雕琢皆成就
  我见一切诸有情　　犹如金像在泥模
  烦恼于外而盖覆　　如来之智处于内
  若得寂净及清凉　　前际清净智菩萨
  以法器仗而捶击　　烦恼由斯悉摧坏
  所有如来之佛子　　犹如金像令可爱
  常得天世人供养　　圆满身相具十方
  我见一切诸有情　　如是清净成善逝
  成就善逝成佛眼　　满足无上萨婆若

佛告金刚慧菩萨言。善男子若在家出家善男子善女人。于此如来藏经典法要。受持读诵书写经卷。为他广说得福无量。或有善男子善女人或余菩萨。为于积集如来智故。精勤供养一切如来。于一一世界。成就如是色三摩地。由此色三摩地威力。过恒河沙诸佛世界。过恒沙数俱胝那庾多现在诸佛。于一一佛所供养承事。并及菩萨声闻僧众。如是乃至过五十恒河沙诸佛世尊。当于和畅安乐之时。各送百千珍妙楼阁。一一量高十踰缮那。纵广正等一踰缮那。如是一切以宝成天妙香器。散种种花成办种种受用之具。日日如是乃至千劫。金刚慧若苾刍苾刍尼邬波索迦邬波斯迦。发菩提心于此如来藏经。取其一喻。或在于身或在经卷。金刚慧以此福业与前福业。如来安立百分迦罗分千分百千分俱胝分。俱胝百分。俱胝千分俱胝百千分。俱胝那庾多百千分。不及于此迦罗一分。乃至算数譬喻所不能及。金刚慧若有善男子善女人。求无上菩提者。于彼诸佛世尊并及菩萨声闻大众。取曼陀罗花百千斛。日日供养复满千劫。金刚慧若余苾刍苾刍尼邬波索迦邬波斯迦。发菩提心闻此如来藏经法要。乃至合掌礼敬作随喜语。金刚慧以此胜福善根。与前善根献花功德。如来安立比前功德。百分迦罗分千分无数分。不如一分。尔时世尊说伽他曰

  或有乐求菩提者　　闻此经典而受持
  乃至书写于经卷　　若能恭敬于一偈
  应听彼福而无量　　发生无量福德藏
  得闻如来之藏经　　若能求胜菩提行
  以神通力住上乘　　供养恭敬人中尊
  并及十方声闻众　　乃至满足于千劫
  多千劫数如恒沙　　超于彼数不思议
  一一世间行无量　　纯以宝作妙楼阁
  其量高十踰缮那　　纵广有一踰缮那
  涂香烧香而供养　　于中七宝微妙座
  以妙缯彩敷其上　　及余妙座皆敷设
  其数犹如恒河沙　　一一供养于诸佛
  一一送彼如来所　　所有刹中诸如来
  其数犹如恒河沙　　悉皆供养而承事
  若有智者闻此经　　取于一喻而正行
  若能受持及读诵　　此福超过前福聚
  有情归依于此经　　疾证于彼无上觉
  此如来藏相应法　　若智菩萨能思惟
  一切有情胜法性　　速疾觉悟自然智

佛告金刚慧。以此得知如是法门。于诸菩萨摩诃萨成多利益。能引萨婆若智。金刚慧我念过去无量无数广大不思议无量不可说劫从此已后。当于是时有佛。名常放光明如来应正等觉明行圆满善逝世间解调御士无上丈夫天人师佛婆伽梵。金刚慧以何因缘彼佛世尊。名常放光明金刚慧彼佛世尊常放光明。如来应正等觉为菩萨时在母胎中。以身光明透彻干外。普照东方十佛刹土微尘等百千世界。如是照已。乃至南西北方四维上下。各十佛刹微尘等百千世界普皆照曜。金刚慧彼诸世界。由于菩萨在母胎中身光普照。而是光明令人适悦发生欢喜。金刚慧由彼菩萨身光照故。微尘数百千世界。是中有情为光照触。获大威德色相具足。具念具慧具行具智具于辩才。是彼诸世界中一切有情。堕于地狱傍生阎魔罗界阿苏罗趣者。由彼菩萨身光明照。光才触已。一切皆舍恶趣之身生于人天。是彼诸世界所有人天。由于菩萨身光照触。皆于无上菩提。得不退转获五神通。是彼诸世界所有不退转菩萨。以彼菩萨身光照触。光才触已悉皆成就无生法忍。各各获得名五百功德转陀罗尼。如是微尘百千世界。由彼菩萨身光明照成吠琉璃。黄金为绳以界八道。一切宝树八行布列。花果庄严色香殊异。是诸宝树香风摇击。从其树出和雅悦意微妙之声。所谓佛声法声僧声菩萨声。菩提声根力觉分解脱等持等至之声。由宝树声。彼微尘数百千界中一切有情。悉皆获得法喜禅悦。是诸世界中所有一切有情。远离地狱傍生阎魔罗界阿苏罗趣。是彼菩萨在母腹中。光明如月合掌而住。昼夜六时常放光明。乃至诞生。金刚慧是彼菩萨。亦初生已便成正觉。彼佛世尊既成佛已。而于身中常放光明。乃至般涅槃时常放光明。彼佛世尊般涅槃后。所有舍利置于塔中常放光明。金刚慧以是因缘。彼时人天号彼世尊。名为常放光明如来。复次金刚慧。彼佛世尊常放光明。如来住世之时。有一菩萨名无量光。与二十俱胝菩萨以为眷属。是时无量光菩萨。于彼常放光明如来应正等觉。已曾问此如来藏法门。金刚慧是彼常放光明如来应正遍知。于五百劫不起于座。广宣说此如来藏经。以种种句于法了别。无碍辩才百千譬喻。哀愍摄受彼菩萨故。是故广演此如来藏甚深法要。于彼十方各十佛刹微尘数俱胝百千世界中。菩萨以小功力而皆警觉。金刚慧彼中菩萨。闻此如来藏经。乃至得闻此经名号。一切渐次善根成熟。已成熟已。各于异国而成正觉。除四菩萨摩诃萨不取菩提。金刚慧勿生异念。当彼之时无量光菩萨。岂异人乎即汝身是。何以故。汝金刚慧于彼。往昔为菩萨时名无量光。金刚慧彼佛世时。其四菩萨不取菩提者。所谓曼殊室利菩萨得大势菩萨。观自在菩萨则汝金刚慧。是为第四。金刚慧如是大利益如来藏法要。菩萨摩诃萨。由闻此故佛智成就。尔时世尊说伽他曰

  昔常放光明世尊　　过去之世无量劫
  以身常放大光明　　照曜俱胝百千界
  初成无上正觉已　　彼时无量光菩萨
  问彼世尊此法王　　如是经典彼时说
  常彼佛时闻此经　　从于彼佛而闻已
  悉皆获得胜菩提　　唯除于此四菩萨
  得大势及观自在　　曼殊室利为第三
  第四即汝金刚慧　　当于是时闻此经
  昔时无量光菩萨　　即是于汝金刚慧
  当于彼时为佛子　　我曾于先行胜行
  闻此妙经之名号　　从师子憧如来所
  恭敬合掌闻此经　　我昔由此善根业
  速得最胜菩提位　　是故智者持此经

尔时世尊复告金刚慧菩萨言。若善男子善女人。被于业障之所缠缚。得闻此如来藏经。受持读诵为他敷演。由彼闻此经典读诵受持。讽诵敷演书写经卷。以小勤劳业障销灭佛法现前

尔时具寿庆喜白佛言。世尊若有善男子善女人缠缚业障。彼得几佛世尊。加持说法。获得多闻。得与如是法要相应。佛言庆喜。若善男子善女人。于百佛所得加持说法。或有二百或三四五百。或千或二千。或三四五六七八九。或十千佛所加持说法。或有二百千。或有俱胝那庾多百千佛所。得说法闻持。庆喜若有菩萨。得此如来藏法。书写经卷读诵受持。思惟其义为他广说。而彼菩萨应作是念。我今获得无上菩提。其人应受人天阿苏罗供养恭敬。佛说是已唯然欢喜。尔时世尊复说伽他曰

  菩萨闻此修多罗　　作是思惟获胜觉
  若有人手得此经　　人天礼拜应恭敬
  诸佛世尊大导师　　称赞彼人人中最
  亦名最胜之法王　　若经入干彼人手
  是人照曜如满月　　应受礼敬如世尊
  能持法炬为世雄　　由入此经于彼手

尔时世尊说是经已。金刚慧菩萨摩诃萨等。并诸菩萨诸大声闻众。人天阿苏罗等。闻佛所说欢喜奉行大方广如来藏经


大方广如来秘密藏经

    No. 821

大方广如来秘密藏经卷上

        失译人名附三秦录

如是我闻。一时佛住王舍城只阇崛山。与大比丘僧八千人俱。菩萨摩诃萨三万二千。众所知识。得陀罗尼无碍辩才。得无生法忍。降伏魔怨。一切法中快得自在。善能种种神通变化。善知一切禅定三昧入出自在。为诸众生作不请友。永离盖缠。善能了知诸众生根。善知依止于了义法。净修六度到于彼岸。游戏五通教化众生心无厌倦。无量无边百千万亿那由他劫久修诸行。已曾供养无量诸佛。善为诸佛之所护持。护正法城不断佛种。常以圣德悦乐一切。转妙法轮。善能往来无边佛土。奉觐诸佛。大师子吼。治大法船。击大法鼓。吹大法蠡。善集一切福德庄严。相好严身。念慧坚进。善知惭愧。法喜自娱。具足成就大慈大悲。隐蔽日月所有光明。利衰毁誉称讥苦乐。是世八法所不能污。不高不下。善断爱恚。常与方便智慧相应。随众生根善开化之。救无救者。有所为作善观察之。身口意业无诸过患。善能集于定慧庄严。其心调柔犹如大龙。如大师子降伏外道。善能进趣大丈夫行离诸怖畏。善能决断诸众生疑。善能劝请无量诸佛转于法轮。善住大愿永离二见。常勤度脱一切众生。善知垢净所起因缘。善修正念。不起声闻缘觉之念。不舍一切智宝之心。其心清净犹如虚空。其身柔软。心无染污志意无坏。随所至处心无染着。妙音和软。有所言说显露易解。其言清白说无染法句。常观他德。勇猛无侣。志欲道场。其名曰山刚菩萨。大山菩萨。持山岩菩萨。山积王菩萨。石山王菩萨。大进菩萨。信进菩萨。极进菩萨。喜手菩萨。宝印手菩萨。宝手菩萨。德手菩萨。灯手菩萨。常举手菩萨。常下手菩萨。常喜根菩萨。常思念菩萨。常勤菩萨。常观菩萨。法勇王菩萨。净宝光明威德王菩萨。摩尼光王菩萨。过诸盖菩萨。总持自在王菩萨。发心转法轮菩萨。法勇菩萨。净众生宝勇菩萨。道分味菩萨。捷辩菩萨。无碍辩菩萨。不动足进菩萨。金刚足进菩萨。金刚志菩萨。虚空藏菩萨。相好积严菩萨。坏魔网菩萨。胜志菩萨。导师菩萨。喜见菩萨。贤护等十六大士。弥勒等贤劫菩萨。兜率陀天曼陀罗华香等而为上首。他化自在天王等三万二千。如是天子。及余趣向于大乘者。三千大千世界之中。释梵护世。欲界色界净居诸天。一切来集。恭敬供养礼拜如来。尔时世尊为于无量百千大众恭敬围绕而演说法。是时东方去此佛土七十二亿刹。彼有佛土。名曰常出大法之音。其国有佛。号曰宝杖如来应供正遍知觉。今者现在。如是常出大法音国。一切江河池泉诸水。一切树林一切众华。一切诸叶一切华果。一切台观。常出法宝无上法音。彼土众生。常闻如是胜妙法音。是宝杖佛常出大法音国。有菩萨名无量志庄严王。是菩萨观宝杖佛已。犹如壮士屈伸臂顷。没是常出大法音国。一念之顷。而来至此娑婆世界。时无量志庄严王菩萨。化作八万四千宝台。妙宝所成。四方四柱纵广正等庄严极妙。一一宝台化作八万四千宝树。华果茂盛。一一树下皆悉化作宝师子座。众宝厕填。皆悉敷置百千妙衣。是诸座上皆见佛坐。形色相貌如释迦牟尼。是无量志庄严王菩萨。现是化已。化虚空中化作宝盖。纵广正等百千由旬。垂悬缯彩铃网庄饰。风吹铃网。出柔和微妙可爱软音。其音遍告三千大千佛之世界。时此三千大千世界。平坦如掌。生宝莲华供养如来。时无量志庄严王菩萨。以八万四千宝台。而自围绕来诣佛所。是时大众。见是化已得未曾有。而作是言。如今所见。此大士来庄严事相。必说大法。及此三千大千世界诸庄严事。又上空中垂悬宝盖于如来上。一切天宫悉皆隐蔽。是时大德摩诃迦叶。承佛神力。从座而起整衣服。偏袒右肩右膝着地。向佛合掌而说偈言

  无垢净光从空出　　隐蔽释梵诸光明
  及蔽日月珠火光　　唯愿人尊说此相
  此空中现妙宝盖　　遍覆百千由旬地
  幢幡铃网以庄严　　世尊今将雨法雨
  铃网所出妙声音　　其音遍告此佛界
  有闻音者烦恼息　　为何利益说此事
  三千世界平等掌　　百千莲华从地出
  华香适意悦身心　　是何威德之所为
  东方遍放金色光　　八万四千妙宝台
  台内宝树师子座　　见如导师释师子
  导师此是何利事　　见此事者何增益
  此是何种欲佛知　　现此无量诸神变

尔时佛告摩诃迦叶。东方去此七十二亿佛土。有国名常出大法音。彼中有佛号曰宝杖。今者现在。彼有菩萨。名无量志庄严王。来至此土。见我礼拜咨受听法。为诸菩萨。生大法欲。生大法力。集大法智。欲显常出大法音国所有功德及宝杖佛所有功德。以此缘故。是无量志庄严王菩萨。而来至此娑婆世界。一日一夜所利众生。多于汝等满此三千大千世界诸大声闻法利众生。假令汝等数如稻麻竹苇甘蔗丛林。寿命一劫所利众生。犹尚不等。大德迦叶白言。世尊。阎浮提人。若得闻是善丈夫名。尚得大利。况有信心复闻说法。时无量志庄严王菩萨及诸宝台。住如来前顶礼佛足。当礼佛时。令是三千大千世界六种震动。百千伎乐不鼓自鸣。一切大众礼如来足。尔时无量志庄严王菩萨。绕佛三匝。及与八万四千宝台亦绕三匝。绕三匝已。向佛合掌。以偈赞佛

  善能柔软微妙语　　无错无杂净无垢
  善名威德慧中胜　　我今稽首最胜仙
  多百千亿功德满　　施安隐乐灭百苦
  仁大悲喜等三界　　而演说法除尘垢
  十方诸佛叹仁德　　善逝恶时得菩提
  度恶众生无疲倦　　度一众生尚为难
  一切诸佛悉平等　　智慧通等号人尊
  成佛无等白净法　　示现卑劣调众生
  尊若悉示佛境界　　一切众生心迷乱
  大悲为利是等故　　修彼所行演说法
  人尊智胜众所乐　　常先和颜柔软语
  算数人天德无等　　是故欢喜顶礼尊
  一切智等诸众生　　尽诸法降降外道
  一切智见伏魔怨　　稽首百力降诸力
  常乐真实诚谛语　　善知如说如所行
  苦乐不动如山王　　我今稽首施世乐

尔时无量志庄严王菩萨。偈赞佛已。而白佛言。世尊。宝杖如来问讯世尊。少病少恼起居轻利安乐行不。世尊。我今欲少请问如来应供正遍觉。若佛听者。乃敢咨启。佛告无量志庄严王菩萨。善男子。如来常听。随所有疑。恣汝所问。吾当随汝所问演说悦可汝心。如是世尊愿乐欲闻。时无量志庄严王菩萨白言。世尊。我从先佛如来应供正遍觉闻。有法名如来秘密藏。若有菩萨住是秘藏。得无尽法。得无尽辩。见佛无尽。善能获得无尽神通。为诸众生作实依止。善哉世尊。愿为演说如来秘密藏法。尔时佛告无量志庄严王菩萨。善哉善哉。善男子。乃能问佛如是之法。善男子。汝已曾于恒河沙佛所。殖诸善根咨受请问。善男子。汝今谛听善思念之。吾当少说如来密藏法。无量志庄严王菩萨。即白佛言。如是世尊受教而听。佛言。善男子。如来密藏法。谓一切智心。发是心已坚固守护。不退不舍无有娆乱。善好忆念。炽然劝导。显示教诲。善根先首。喜乐守护。常恒坚造应作之业。为是布施。为是持戒。为是忍辱。为是精进。为是禅定。为是方便。是心为柱。不怯不弱。不羸不坏。无有懒惰。不背不舍。顺向是心而觉了之。善业为首。质直无曲。正住端直。无幻无伪。作已无疑。未作者作。如所应作勤修行之。舍不正行勤修正行。善男子。是名如来秘密藏法所入法门。所谓坚固一切智心。好坚守护不弃舍之。善男子。何等一切智心坚固。善男子。一切智心坚固有四。何等四。不念余乘。不礼余天。不发余心。志意无转。是为四。而说颂曰

  不生念余乘　　礼佛不礼天
  不生余欲心　　不礼外凡夫
  修行是法时　　一切智心坚
  非魔及外道　　得便如毛发

善男子。复有四法。护一切智心。何等四。不为色醉。及财封醉。非眷属醉。及自在醉。是为四。而说颂曰

  非色财封醉　　眷属及自在
  色财封自在　　眷属不放逸
  观诸有为法　　皆悉是无常
  不放逸离慢　　守护菩提心
  斯行法功德　　趣菩提不退

(初偈是行半)

善男子。复有四法。不退菩提心。何等四。集诸波罗蜜。亲近实菩萨。修集大悲心。以四摄法摄诸众生。是为四。而说颂曰

  常修六度无满足　　生闻闻已心柔软
  生于大欲离恶友　　亲近善友随所欲
  常修胜道近向者　　常修悲心住四摄
  常好坚住菩提心　　佛功德聚不难得

善男子。菩萨具足四法。不舍一切智心。何等四。信佛功德。修集佛智。见佛神通。不断佛种。是名为四。而说颂曰

  信解佛德已　　勤修集佛智
  见佛神通已　　勤守护佛种
  修行如是法　　不舍菩提心
  随所见诸佛　　倍生精进力

善男子。菩萨具足四法。终不娆乱菩提之心。何等四。给侍诸佛面前。从于如来闻法。常叹佛德。依止寂静缘念于佛。是为四。而说颂曰

  给侍于如来　　好尊重恭敬
  若有所闻法　　闻已如说行
  常赞叹如来　　信敬爱乐之
  面闻胜法已　　智者依于义
  常赞叹功德　　调御世所有
  彼常勤依止　　正念于诸佛
  数数赞佛德　　常勤观己行
  常乐独静处　　思念于如来
  善摄如是法　　修行心不乱
  斯人有三昧　　不忘菩提心

善男子。菩萨具足四法。忆菩提心。何等四。我要当为一切众生良福田。我当说道。我当随趣如来所趣。我当实知诸众生行。是为四。而说偈曰

  我当为世胜福田　　趣邪道者示正路
  善逝所趣我当趣　　我当常知众生行
  菩萨大士念此德　　常念菩提胜道心
  彼当速疾成法王　　得神通智世无等

善男子。菩萨具足四法。念一切智心。何等四。专志念意是诸法本。当念法本。发一切智心是世宝塔。当念宝塔。是为四。而说颂曰

  当专志念意　　极好专念意
  此是诸法本　　一切世间塔
  常念菩提心　　住意好善住
  此是十力本　　当为天世塔

善男子。菩萨具足四法。然一切智心。何等四。势力通集不失本行。满五根力。身心精进而无有我。勤行精进为利益他。是为四。而说颂曰

  所演说四法　　炽然菩提心
  若炽然智慧　　得止息烦恼
  势力及通达　　如是勤精进
  安住服是已　　庄严无懈怠
  斯不失本誓　　善安住根力
  身心无疲倦　　勤进求实身
  住如是炽然　　增长菩提心
  彼智慧如是　　犹日月增长

善男子。菩萨有四法。劝菩提心。何等四。在大众中称扬赞叹菩提之心。令其开解菩提之心。善受教诲随顺师长发清净心。一切烦恼不得自在。是为四。而说颂曰

  劝导唱道心　　先住此为本
  当有一切智　　是名知因者
  是一切智心　　清净常照明
  常住于是中　　世间所顶礼
  常出柔软语　　速疾受教诲
  咨问诸师长　　一切智胜心
  本性常清净　　守护菩提心
  白净离烦恼　　最胜不相违

善男子。菩萨有四法。显示菩提心。何等四。此是我住处。住是处已开示显说。知于是心有无量德。亦为他说如是之事。是为四。而说颂曰

  善住于所住　　菩萨住是已
  称扬如是法　　菩提之妙心
  道心德无量　　发及称扬等
  称扬已便行　　称扬者所得

善男子。菩萨有四法。教修菩提心。何等四。谓不粗穬。言说柔软。无有粗涩。颜色和悦。是为四。而说偈言

  柔软解说义　　常无有粗穬
  和颜住是法　　彼教菩提心

善男子。菩萨有四法。菩提之心善根为首。何等四。成满相好开门大施。修净佛土行种种施。净于智慧常伏憍慢。满足智慧修集多闻。是名为四。而说颂曰

  常开门大施　　彼到相好岸
  善好种种施　　斯当有净土
  常无有憍慢　　恒求集佛智
  集闻无满足　　斯有利智慧
  如是胜妙相　　方便起道根
  是巧心所转　　集先诸功德

善男子。菩萨有四法常喜乐。何等四。喜乐见佛。见余菩萨胜精进者生于喜乐。作如是言。我当何时满足受记。受于无上菩提道记。我当何时诸众生前作诸佛事。于佛智慧生喜乐心。是为四。而说颂曰

  我当何时现见佛　　彼生喜乐欲见佛
  见余菩萨胜进者　　生喜欲修是精进
  我当何时满德聚　　得授胜记证菩提
  胜智某方作法王　　菩萨常生是喜欲
  我何时世作佛事　　得神通智到彼岸
  名闻普遍十方供　　菩萨常生此喜欲

善男子。菩萨有四法不喜。何等四。不喜称誉不实功德得诸利养。不喜得诸释梵护世人天富乐。不喜一切声闻缘觉。不喜一切外道所得胜供养事。是为四法不喜。而说颂曰

  不喜名称大利养　　于身命财亦如是
  不喜释梵及护世　　是诸邪有悉无常
  不喜声闻及缘觉　　唯除起何胜乘心
  不喜世禅及外道　　不喜身见及边见

善男子。菩萨有四法。护一切智心。何等四。如说如住如作而说。于诸众生其心平等。生极欲心。谓于善法。是为四。而说颂曰

  如说如住如作说　　等心众生极欲道
  善住于是四胜法　　常护道心不忘失

善男子。菩萨有四法。是所应作。何等四。修集多闻。思念多闻。说于所闻。不退寂静。是为四。而说颂曰

  斯常勤集于未闻　　是常修念思多闻
  是常勤说于多闻　　是常勤修为得禅

善男子。菩萨有二法。定一切智心而行布施。何等二。专意念定。舍不望果报。是为二。而说颂曰

  以欢喜心而施与　　施已生喜不望报
  一切悉舍向菩提　　定心施已证菩提

善男子。菩萨有二法。一切智为首修持净戒。何等二。于诸众生无侵害心。毁戒者所生大悲心。是为二。而说颂曰

  不生毁害心　　等施上中下
  倍增生悲心　　于恶逆众生

善男子。菩萨有二法。一切智为首修行忍辱。何等二。自舍己乐。施与他乐。是为二。而说颂曰

  不求于自乐　　常为利乐他
  斯有如是忍　　佛菩提为道

善男子。菩萨有二法。一切智为首修行精进。何等二。菩提心为首。不舍诸众生。是为二。而说颂曰

  行一切白净　　上道心为首
  不见我众生　　精进无毁减

善男子。菩萨成就二法。一切智为首修行禅定。何等二。方便入禅。本愿力出。是为二。而说颂曰

  勇健者常起　　智者行禅定
  降伏诸结使　　恒常欲得禅
  本愿力持出　　当为世导师
  斯有如是德　　获得于禅定

善男子。菩萨成就二法。一切智为首有于智慧。何等二。自离诸见。为断一切众生见故修行智慧。是为二。而说颂曰

  彼离于诸见　　修利为众生
  有胜智现前　　智安隐行道

善男子。菩萨成就四法。有于方便。何等四。慈愍众生而为作救。大悲真实无有疲倦。喜乐于法生欢喜故。舍离烦恼无有怯弱。是为四。而说颂曰

  修慈无嗔恚　　起悲无疲倦
  以法生欢喜　　舍烦恼无难

善男子。菩萨有四法无厌。何等四。多闻无厌。集德无满。阿练儿处无满。回向无满足。是为四。而说颂曰

  求闻无满集福尔　　阿练儿处无满足
  福德回向无满足　　菩萨如是四无厌

善男子。菩萨有四法无足。何等四。是菩萨念过去佛作如是念。是诸佛等皆悉修集最胜菩提。我今云何而不修集。念未来佛我亦入在是等数中。念现在佛。念是佛时而作是念。此诸佛等现悉了知一切诸法。是诸念中无有怯弱。是为四。而说颂曰

  忆念过去佛　　无怯心增长
  彼佛得胜道　　我云何不得
  念未来善逝　　我在是数中
  无怯倍精进　　我定在是数
  念现在导师　　本行菩萨时
  我当除诸结　　证寂灭菩提
  解了一切法　　所住如所欲
  终不生怯心　　倍生好胜进

善男子。菩萨有四法。不退大乘。何等四。其心如地。其心如水。其心如火。其心如风。是为四。而说颂曰

  其心如地水　　心亦如风火
  作不作同等　　不得道不退

善男子。菩萨有四法。解知无我。何等四。而是菩萨作如是念。诸众生界我当悉知是等心行。诸众生界我当悉知是等诸根而为说法。诸众生界我当除断一切烦恼而为说法。无量佛智我等觉了。实非我身能觉此法。亦非我心。我诸善根能觉此法。无有我者名为菩萨。是为四。而说颂曰

  众生界诸心　　所行叵思议
  烦恼妄分别　　妄想生是非
  佛智亦如是　　无量叵思议
  非我之所能　　解了于佛智
  诸结使相违　　无色不可见
  我应悉除断　　显示解脱道

善男子。菩萨有四法。无有怯弱。何等四。愿诸善根。修方便慧。修信进念力。信无上道。是为四。而说颂曰

  善喜悦充润　　慧方便众香
  信精进念力　　斯有解脱道
  如是四慧法　　持法无有厌
  为厌倦者依　　亦为世作救

大方广如来秘密藏经卷上大方广如来秘密藏经卷下

        失译人名附三秦录

善男子。菩萨有四障法。应当觉知。何等四。毁谤正法。秘吝惜法。怀增上慢。修无色定。是为四。而说颂曰

  菩提心有四　　说示名障碍
  菩萨应觉知　　应数数远离
  毁诽于正法　　多闻怀吝惜
  增上慢贡高　　不善起禅定
  是故护正法　　闻已广流布
  舍慢无贡高　　远离不禅定

善男子。菩萨有四法。所造速疾。何等四。所作以智不以憍慢。所有善根回向菩提不趣下乘。一切诸趣不生染着。若生染着一向专为化于众生。昼夜三时常修三分。灭过恶业未来不造。是为四。而说颂曰

  所造以智不以慢　　回善上道非下众
  慧者不信于诸有　　发心为利诸众生
  昼日三时夜亦尔　　三分悔过灭先恶
  不造众恶集诸善　　慧者如是集善业

善男子。菩萨有四法极好。何等四。不自称举。不轻于他。远离诸恶。舍除诸慢。是为四。而说颂曰

  不自称举不轻他　　所造诸恶悔不作
  不生憍慢及慢慢　　其心端直修善行

善男子。菩萨有二法。端直速疾。何等二。若有所问如实而答。先所见事无所覆藏。是为二而说颂曰

  如问而演说　　不藏先所见
  宁舍于身命　　终不说妄语
  正直于是法　　是为贤善根
  彼得于质直　　疾觉胜菩提

善男子。菩萨有二法。无有谄伪。何等二。虽多获利不欲叹德。不得利养不自称举。是为二。而说颂曰

  虽多获利养　　不叹示己德
  大智所不欲　　是不谄者得
  设不得利养　　此是我本业
  不欲他有过　　勿令彼业熟

善男子。菩萨有二法。不望他报。何等二。我应当利一切众生。非诸众生而利于我。我当觉知而为菩提。是为二。而说颂曰

  我应利众生　　我荷担彼等
  我求无为道　　不观望他报
  我不求有为　　我求无为道
  我摄护世间　　不望报得道

善男子。菩萨有二法。作于不作。何等二。不知恩者而常供给。于知恩者作于重任。是为二。而说颂曰

  不知恩众生　　于彼不望报
  诸阴界入等　　皆为作菩提

善男子。菩萨有二法。是所应处。何等二。常值诸佛。亦常值遇菩萨乘者。是为二。而说颂曰

  二种所应处　　是处增名称
  得值诸如来　　菩萨所识知

善男子。菩萨有二法所不应修。何等二。不与愿行声闻乘者而共同止。不惊畏诸有独处宴默。是为二。而说颂曰

  不与修行者　　而共同止住
  不惊畏诸趣　　依止宴寂处

善男子。是名初入如来密藏根本句也。菩萨若入是初根本句。是菩萨能成就如来秘密藏法。世尊。说入如来密藏初句法时。六万众生及天与人。发于无上正真道心。十千菩萨得无生法忍。五百比丘不受诸法。永尽诸漏心得解脱。时此三千大千世界。六种震动大光普照。人天伎乐不鼓自鸣。人天阿修罗等。同声三唱作如是言。其有众生得闻于是如来密藏法快得善利。若有书写受持读诵如说修行。是等众生皆当不失如是如来秘密藏法

尔时无量志庄严王菩萨。闻是如来密藏法已。即作是念。我今当以何等供具。供养如来应供正遍觉。复作是念。外物易舍内事难舍。我今当以自身奉供如来世尊。即升虚空。而说偈言

  我今奉独觉　　以自身供养
  以此无上舍　　愿令如导师
  财供二足尊　　此事不为难
  云何为希有　　所谓身供养
  我今供无等　　自身奉遍眼
  为世人天供　　如大智师子

尔时无量志庄严王菩萨。即便放身投如来上。当于尔时。以佛神力。未曾有华异华异色。甚为鲜净极妙端严。散如来上。是菩萨身又不坠地亦不现空。此诸华等至佛身上。即复还踊住虚空中。成大华盖覆四天下。是华盖中垂悬华贯出大光明。是光明中现妙莲华。是莲华上有菩萨坐。如无量志庄严王。是菩萨等从华台起。顶礼佛足同声请言。唯愿世尊。说如来秘密藏法。无令断绝。及护如来密藏眷属

尔时大德摩诃迦叶。生希有心叹未曾有。白言。世尊。是无量志庄严王菩萨。以身庄严供养如来。以身供养于如来已。现是菩萨诸庄严事。世尊。愿令一切诸众生等得于如是庄严之身。愿使如来常寿住世。世尊。我等今者快得大利。乃得见是善大丈夫闻其说法。尔时佛告摩诃迦叶。汝今见是无量志庄严王菩萨不。已见世尊。迦叶。是善男子。于恒河沙等佛所。恒得咨请如是如来秘密藏法。贤劫诸佛所。亦当请问如是如来秘密藏法

尔时大德摩诃迦叶。复白佛言。善哉世尊。唯愿敷演。说是如来秘密藏法。如此菩萨所启请者。尔时世尊告大迦叶。汝今善听如来密藏少许法分。何以故。若于一劫演说此法。不可穷尽。迦叶白言。如是世尊。尔时迦叶及诸大众受教而听。佛言。迦叶。于意云何。汝谓我行菩萨道时。所舍手足头目耳鼻。皮肉骨髓血及妻子。略说乃至一切财物。处处遍恼于菩萨者。是诸众生不堕地狱畜生饿鬼及诸恶趣。何以故。本菩萨时志意净故。及大誓愿净戒聚故。于诸众生大悲纯至及坚忍故。以大慈故。大功德法故。牢强精进定向大乘故。自心净故。大愿丰饶故。不嬉自乐故。其有众生触娆菩萨毁骂之者。菩萨德故不堕恶道。迦叶。我今引喻以明斯义。迦叶。犹如病人良医授药。而是病人毁骂是药及与良医。先毁已后乃服此药。迦叶。汝意云何。药以骂故不为药耶。病不除耶。不也世尊。虽复毁骂不失药势而能除病。如是迦叶。菩萨如彼药及良医。虽不恭敬种种触恼。然是菩萨纯净志意无有缺减。迦叶。如大宝珠众德所成。其性纯净除诸瑕秽。若有人天毁骂是宝而不恭敬。迦叶。于意云何。是大宝珠畏毁骂故失宝力耶。不也世尊。佛言。迦叶。是净宝珠犹彼菩萨志意清净。一切众生虽不恭敬。所有功德无有折减。迦叶。如大油灯。假令人天而毁骂之。以毁骂故便闇冥耶。不也世尊

佛言。迦叶。菩萨志意纯净如是。虽复触恼不失其性。迦叶。以是事故当知众生虽有触娆于菩萨者不堕恶道。何以故。由是菩萨本愿净故所愿皆成。尔时大德摩诃迦叶白言。世尊。如我解佛所说义趣。若于如来起不善业。是众生等亦复不畏堕于恶道。佛言。如是迦叶。若有众生于大悲如来。生信敬心解入进趣。若佛现在。若灭度后。若有奉施如来及塔。若幢幡盖华鬘涂香及与末香。若宝若衣及诸饮食。随于种种所有诸物。若取若食。若自取若教取。迦叶。我说是人无有所犯。迦叶。贫为最苦。不恭敬故。作劫夺故。无畏惧故。不信敬故。不解业故。不虑报故。以贪求故。难调伏故。贪嗔痴故。无惭愧故。凶横恶故。不思如来有大慈悲。不信如来多利众生。取如来塔物乃至一线。若自取若使人取。我说是人不名少犯。我不说彼不堕恶道。迦叶。若有众生于如来物及佛塔物。若自取若教人取。如来今者悉知是人。悉见是人当堕恶趣。又以此缘当得断结。何以故。是人心行为佛护故。迦叶。若于如来若如来塔。生心缘念。乃至起于少许悔心。迦叶。是众生心自当改悔。以缘如来生悔心故。背弃生死一切之罪。结使微缓。迦叶。假有人天坠堕于地。堕大地已还依大地而得起住。如是迦叶。是众生等于如来所。生不善故堕在恶道。堕恶道已还缘如来速得出离。云何名为缘于如来。于如来所生殷重心。尔时大德迦叶。白言。世尊。是人以是恶贼之心。若能生心缘念如来。尚得大利。况净心者

佛言。迦叶。如汝所言。若有众生起念如来思忆如来观缘如来。是等一切悉皆当得涅槃果证。大德迦叶。白言。世尊。如我解知佛所说义。宁于如来起不善业。非于外道邪见者所施作供养。何以故。若如来所起不善业当有悔心。究竟必得至于涅槃。随外道见当堕地狱饿鬼畜生

佛言。迦叶。如汝所言。迦叶。设有人天骂赤栴檀。以手打捶速撩弃地。迦叶。于意云何。如是人者有何等香。迦叶白言。而是人者有栴檀香。如是迦叶。若有众生眼见耳闻及口宣说于如来者。当知是人有解脱香。迦叶。有人执把于粪污已。以诸伎乐一切众华而供养之。如是人者有何等香。迦叶白言。世尊。是人唯有粪秽臭恶。如是迦叶。其有亲近恭敬供养诸外道者。当知是人亦复如是。有诸见畏地狱畜生饿鬼等畏。迦叶。若善男子善女人。信于如来有大慈悲。殷重敬信除慢不憍。无有贪嗔及与愚痴。意志决定解知业报。质直无谄无有幻伪。于如来所得净信心。诸根无贪无有谄曲。志意不坏净信成就。信佛大悲多利众生。信佛本行信于如来。不舍一切诸众生等。有如是心有如是意。设乏于食病药所须。未得道果未入正位。若得所须能得道果入于正位。若其不得饥渴羸劣。不能修善不得道果。是人若取如来佛物衣服饮食病药所须自服食之。迦叶。我不说是有恶道果。迦叶。是名如来秘密藏法。应当密持善好守护。不应在彼见著者前开示演说。勿令是人重增所见

迦叶。云何为解。谓解如来说一切法。云何为缚。迦叶。所言缚者所谓贪着。云何为解。谓不贪着不分别二。迦叶。我今不说是无著者。名之为犯。何以故。迦叶。羸劣烦恼从虚妄生。迦叶。若其不实不以生故。名之为实。迦叶。我今引喻为示不实妄想事故。迦叶。犹如人天持芥子火吹令增长。渐烧诸物成大火聚。如是迦叶。愚小凡夫起少不正思惟妄念。坚着诸见随所妄想。随是诸处增长结使。迦叶。若有火聚如须弥山无有所依。迦叶。于意云何。而是火者。为当增长。为当渐灭。迦叶白言。是火当灭。更不增长。佛言。迦叶。不实妄想诸烦恼等。若更不起。若更不着。更不妄想。更不嬉乐。更不分别。此当渐灭而不增长。迦叶。以是事故。应当解知羸劣不实妄想烦恼是不真实。迦叶。犹如有人至毒家舍。竟不服毒自生惊怖。受大苦痛发声大呼。我今遇毒。我今遇毒。有善良医持不实药。令是病人除不实病得离众苦。迦叶。于意云何。若是良医持于实药与是人者。是人活不。不也世尊。是人实不服食于毒自生毒想。须不实药以疗治之。佛言。如是迦叶。诸小凡夫为于不实烦恼所恼。是故如来说不实法。尔时迦叶白言。世尊。如来说法不真实耶。佛言。迦叶。汝所解说。为是真实。为不真实。迦叶白言。我所解说无有真实。何以故。世尊。所有贪欲以不净对。嗔恚慈对。痴因缘对。世尊。若不净是实。则不能除不实贪欲。亦非贪欲生不净观。若愚痴是实。起愚痴已非因缘对。亦非因缘能除愚痴。是故世尊。一切结使及断结法。二俱不实无物无定无有成就。是故不实诸烦恼等。习近不实便得除去。世尊。结使无去。何以故。若有除去则为有去。若已有去则便有来。是故世尊。一切结使无去无来。是故知诸一切有为无来无去。名离烦恼。佛言。迦叶。此如来密藏。说一切法本性清净。尔时大德摩诃迦叶白言。世尊。是十恶道如佛所说。其性无垢本性净耶。佛言。如是如是。迦叶。何以故。无有自在而犯于杀。无可亲信而犯于盗。非无主无护而犯邪淫。非为护他而犯妄语。非为调伏而犯恶口。非为破坏外道邪增(恐慢)而犯两舌。无随应器而犯绮语。无粗恶教而犯嗔恚。无有希望增上善根名之为贪。无有将护自在者意少不正言而犯邪见。迦叶。是十恶道若不坚着。我不说彼名之有过。迦叶。是十恶道若不坚着。名为不犯。如是迦叶。一切烦恼若不坚着。我说无犯。迦叶。诸不著者。名曰离见。迦叶白言。世尊。十恶业道何者最重。佛言。迦叶。是十恶业道。杀及邪见。名为最重。迦叶。随在在处诸恶不善。若不坚住。若不坚执。若不坚着。一切我说名为不犯。迦叶。若少不善。若其坚住坚执坚着。一切我说名之为犯。迦叶。五无间罪。若不坚住坚执坚着生于见者。我不说彼名曰为犯。况复余小不善业道。迦叶。我不以不善法而得菩提。亦不以善法而得菩提。迦叶。若以不善得于菩提。诸小凡夫亦得菩提。若以善法得菩提者。一切被烧草木丛林应还生长。迦叶。我今问汝。如来云何得于菩提。迦叶白言。佛是法本。世尊是眼。世尊是依。如世尊说当共奉行。佛言。迦叶。解知烦恼从因缘生。名得菩提。迦叶。云何为解知从因缘所生烦恼。解知是无自性起法是无生法。如是解知名得菩提。迦叶。但假名字名得菩提。而是菩提不以文字言说而得。若无文字。无言无说。无得菩提。是第一义。迦叶。如汝所问。十恶业道何者为重。迦叶。如人有父得缘觉道。子断父命名杀中重。夺三宝物名盗中重。若复有人。其母出家得罗汉道。共为不净是淫中重。若以不实谤毁如来。是妄语中重。若两舌语坏贤圣僧。是两舌中重。若骂圣人是恶口中重。言说坏乱求法之人。是绮语中重。若五逆初业。是嗔恚中重。若欲劫夺持净戒人物。是贪中重。邪见中重。谓之边见。迦叶。此十恶道。是为最重。迦叶。如来知是十恶业是为最重。迦叶。若有一人具是十恶。迦叶。是恶众生。若解知如来说因缘法。是中无有众生寿命。无人无丈夫。无我无年少。无作业者。无受者起者。无知者见者。无福伽罗。无生无灭无行。是为尽法。无染无著。无善不善。本性清净。一切诸法本性常净解知信入。迦叶。我不说彼趣向恶道。无恶道果。何以故。迦叶。法无积聚。法无集无恼。迦叶。一切诸法生灭不住。因缘和合而得生起。起已还灭。迦叶。若心生灭一切结使亦生已灭。若如是解无犯犯处。迦叶。若犯有住无有是处。迦叶。如百千岁极大闇室不然灯明。是极闇室无门窗牖。乃至无有如针鼻孔。日月珠火所有光明无能得入。迦叶。若闇室中然火灯明。是闇颇能作如是说我百千岁住。今不应去。迦叶白言。不也世尊。当然灯时是闇已去

佛言。如是迦叶。百千万劫所造业障。信如来语解知缘法。修观察行修于定慧。观无我无命无人无丈夫等。我说是人名为无犯无处无集。迦叶。以是事故。当知羸劣诸烦恼等。智慧灯照势不能住

迦叶。是说如来密藏住处无上。大师子吼转净法轮。天人魔梵所不能转。迦叶。若有众生信是如来秘密藏法。如是受持如是观察。彼当如是大师子吼。是时大德阿难白言。世尊。是无量志庄严王菩萨。自以其身供养如来。当以何身觉菩提道。时华台中诸菩萨等。问阿难言。于意云何。可以身觉于菩提耶。阿难。勿作斯观。当以身心觉于菩提。阿难报言。诸善丈夫。若非身心觉于菩提。当用何等而觉菩提。诸菩萨言。大德阿难。身之实性是菩提实性。菩提实性是心实性。心之实性即是一切法之实性。觉是一切诸实性故。名觉菩提。时诸华台所有菩萨。顶礼佛足说如是言。世尊。我等若至此大地时。是无量志庄严王菩萨。乃当得成阿耨多罗三藐三菩提。是时阿难白言。世尊。是诸华台众菩萨等。几时当至于此大地

佛告阿难。是诸菩萨于下方界分恒河沙等诸佛如来所。咨受请问于是如来秘密藏法。闻已解义。阿难白言。世尊。是无量志庄严王菩萨。几时当成阿耨多罗三藐三菩提。佛告阿难。是贤劫中千佛已出当出。阿难。最后如来号名卢志。阿难。卢志如来应正遍觉。诸声闻众多先诸佛所有声闻僧。阿难。是卢志如来乃当授是无量志庄严王菩萨无上道记云。无量志庄严王菩萨。过九十八劫。当得成佛号庄严王。亦于是界得无上道。是庄严王如来。坐此地时。是华台中诸菩萨等尔乃至地。复当闻此如来密藏法。阿难。尔时是庄严王如来世界。名作无量功德庄严。阿难。一切欲界诸天宫殿等。彼庄严王佛国土中。一宝台耳。是娑婆界。尔时当名妙好色土。阿难。庄严王如来寿命百劫。佛灭度后正法住世满足十劫。纯菩萨僧。说是庄严王如来记已。佛土华盖便没不现。无量志庄严王菩萨现佛前住。是时阿难白言。世尊。护持此法令得久住。于阎浮提增广流布。令善丈夫能持如来密藏法者。成满功德手得是法。尔时世尊告阿难言。假令四大变易其性。终不令是善丈夫等。不闻是法而取命终。阿难。若有书写受持读诵。当知是人即是如来所持。阿难。若有人能右手执持恒沙佛界满中七宝。左手复持恒沙世界满中七宝。若昼三时夜三时持用布施。是人不懈经恒沙劫。阿难。是布施功德。若有书写受持读诵是经典者。所得功德复过于是。是故阿难。汝今受持读诵是经。令诸法器普得闻知。是诸人等则为受持如来秘密藏法。佛说此经已。无量志庄严王菩萨。大德阿难。大德迦叶。一切大众。天人阿修罗等。闻佛所说。皆大欢喜

大方广如来秘密藏经卷下


大方广师子吼经

    No. 836 [No. 835]

大方广师子吼经

        大唐天竺三藏地婆诃罗译

如是我闻。一时薄伽梵在日月宫中胜藏殿上。与大比丘众九十百千俱胝及无量菩萨摩诃萨俱

尔时佛告胜积菩萨。北方去此六十恒河沙佛土。俱胝那由他百千微尘等刹。有世界名曰欢乐。佛号法起如来应正等觉。现在说法。以立持安普利一切。今欲说大方广名师子吼。难遇难闻。汝可诣彼听受法要。尔时胜积菩萨受佛教已。即往欢乐世界见法起佛。顶礼双足右绕七匝却住一面。时法起佛见胜积菩萨。知而故问。作如是言。善男子汝从何来。时胜积菩萨居心而住默无言说。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。普大会众咸作是念。胜积菩萨三界尊问。如何默然不答居心而住。尔时佛以修广明朗青莲华目师子频申。普视十方知大众疑。便现微笑放大金光。其光间错无量百千种种异色。普照十方一切国土地大震动。是时十方诸菩萨众见此神变。种种形色种种仪服。来诣佛所顶礼佛足。各以己福庄严华藏坐莲华座。尔时。电鬘菩萨从座而起。偏袒右肩右膝着地合掌向佛。欢喜奇特得未曾有。白佛言。世尊。我昔曾见无量神变。未有光明地震如今所睹。善哉世尊愿说因缘。何故微笑。惟垂悲愍决此众疑。尔时电鬘菩萨以偈请曰

  大悲大导师　　微笑非无因
  愿佛利众生　　垂哀决定说

尔时法起如来端严赫奕。阎浮檀金晖焕照朗。散注无量百千俱胝那由他微妙光明如大金柱。电鬘菩萨白佛言。世尊。我见无量神通光明。未若今日昔所不睹。佛告电鬘。如是如是。此大光明神通如来希现。非大因缘不示此相。谛听谛听善思念之。当为汝说微笑因缘。汝勿惊怖勿余悕望。坚固汝心勿生疑惑。所以者何。诸佛境界不可思议。愿力神通不可思议。汝深思此慎无疑惑。电鬘。汝见胜积菩萨释迦牟尼佛使来者不。电鬘言见。善男子。此胜积菩萨。我问汝从何来。居心默然而不答我。我见此事故现微笑。如来问而不答。今此会众咸生疑怪。善男子。胜积菩萨作如是解。一切诸法无来无去。云何世尊而问我言汝从何来。彼知诸法无有言说处不可得。云何而得言所从来。善男子。此已略说诸法实相。善男子。胜积菩萨于一切法中。无字无说字性离故。诸法无出出性离故。诸法无趣趣正断故。诸法无现无所依故。超心意识离诸因缘。无名无言无作无示。过眼等路无所积聚。无生离想无有处所。离诸处所法惟一字。所谓无字。本无言说何所言说。善男子。当知无说是为真说。尔时净身菩萨承佛神力。白佛言。世尊。若无所说是真说者。哑默不言皆应说法。佛言。如是。善男子如汝所言。非惟哑默说法。不哑默者亦皆说法而不知法。净身菩萨白佛言。世尊。惟愿显说。云何一切众生说法而不知法。佛告净身菩萨。善男子。如生盲人处日光中。而不见日傍人为说。以他声故乃知有日。如是诸法悉入法界。法界无字离诸字性。非诸众生所能宣辩。以因缘故而有言说。如幽谷响谷空无声。以因缘故有响声起。如是善男子。因缘和合字声显现。而众生界空无有字。善男子。众生所有音声语言。当知皆入四无碍智。以言说者。斯入法无碍智。非言说者。斯入义无碍智。以言分剖。斯入辞无碍智。与事相应决了无滞。斯入善说无碍智。众生所有言说。当知皆悉入此四法句中真实义句本来不动。如彼生盲随他言执非真实见。是故善男子。欲求法者于自身求。欲求菩提以五蕴求。说此实义句时。三千大千世界普六震动大光遍照。佛出广长舌相遍覆三千大千世界。从其舌相放无量俱胝那由他百千光明。从大地狱上至有顶。一切世界光明遍照。还摄舌相普告大会。汝等当知。如来广长舌相由实语得。如来所说应当敬受起真实信。勿怀犹豫而生疑惑。尔时十地菩萨等众。并天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切大会俱从座起。合掌同声而白佛言。惟愿世尊说如实义。惟愿善逝说如实义。我等今者。惟悕如来所证之法不悕余法。我等大众咸无疑惑。尔时世尊再三观览一切大会。作如是言。我为悲愍一切世间。利益安乐多众生故。以法财利安诸天人。是以今说大师子吼。善男子。汝等当知。娑婆世界释迦牟尼如来应正等觉。现在说法以立持安度众生者。彼即是我法起如来。我于娑婆世界。作种种形饶益众生。随其所宜如应度脱。是时大会闻说此语咸生奇特。欢喜踊跃得未曾有。同声唱言。善哉善哉。世尊欲令一切众生吼师子吼。故为大会说师子吼真实之法。若得闻者。当知是人善根不少。况复受持读诵广宣流布。种种花鬘种种衣物。幢幡幰盖烧涂末香恭敬供养。斯人则为一切诸佛之所眷护。尔时佛赞诸菩萨言。善哉善哉。善男子。如汝所言。是善男子善女人等功德不少。此佛真实师子吼法。若闻净心乃至一称善哉者我皆摄护。亦为弥勒之所顾召。斯人两肩担我菩提。于五浊中信受此经。生生之处我当成熟。亦为弥勒之所摄护。此人当能干竭生死海。降伏众魔销诸烦恼击大法鼓。永离女身摧诸怨障息众结聚。若有善男子善女人。经十阿僧祇三千大千世界微尘等劫。以一切乐具供养供给一切如来。若闻此经真实神通怀疑不信。斯人则于佛所有过。不名真实供养诸佛。若有善男子。闻说如来此真实德净信称叹。比前功德过百千倍。斯人则为真实供养。善男子。汝等若于我所心净信者。当好书写受持此经。此经所在之处诸佛游止。尔时胜积菩萨。电鬘菩萨。常光菩萨。净眼菩萨。弥勒菩萨。作无畏菩萨。观自在菩萨。大势至菩萨。文殊师利菩萨。辩积菩萨。辩勇菩萨。除一切障菩萨。作光菩萨。普贤菩萨。如是上首八十四俱胝那由他百千菩萨摩诃萨俱白佛言。世尊。我等于后末时。当广流布如是经典。令诸众生悟大涅槃。世尊。若不久植善根。如是之经不入其耳。若有受持此经广流布者。叹其功德。于百千俱胝那由他劫不可穷尽

尔时世尊告诸菩萨言。善哉善哉。汝等应当如是尊重佛教。受持正法。佛说此经已。胜积菩萨并诸天人阿修罗乾闼婆等。普大会众欢喜奉行大方广师子吼经


大方广圆觉修多罗了义经

    No. 842

大方广圆觉修多罗了义经

        大唐罽宾三藏佛陀多罗译

如是我闻。一时婆伽婆。入于神通大光明藏。三昧正受。一切如来。光严住持。是诸众生清净觉地。身心寂灭。平等本际。圆满十方。不二随顺。于不二境。现诸净土。与大菩萨摩诃萨十万人俱。其名曰文殊师利菩萨。普贤菩萨。普眼菩萨。金刚藏菩萨。弥勒菩萨。清净慧菩萨。威德自在菩萨。辩音菩萨。净诸业障菩萨。普觉菩萨。圆觉菩萨。贤善首菩萨等。而为上首。与诸眷属。皆入三昧。同住如来平等法会。于是文殊师利菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。愿为此会诸来法众。说于如来本起清净因地法行。及说菩萨于大乘中发清净心。远离诸病。能使未来末世众生求大乘者不堕邪见。作是语已。五体投地。如是三请。终而复始

尔时世尊。告文殊师利菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨。咨询如来因地法行。及为末世一切众生求大乘者。得正住持不堕邪见。汝今谛听。当为汝说。时文殊师利菩萨。奉教欢喜。及诸大众。默然而听

善男子。无上法王有大陀罗尼门。名为圆觉。流出一切清净真如菩提涅槃及波罗密。教授菩萨。一切如来。本起因地。皆依圆照清净觉相。永断无明。方成佛道。云何无明。善男子。一切众生。从无始来。种种颠倒。犹如迷人四方易处。妄认四大为自身相。六尘缘影为自心相。譬彼病目见空中花及第二月。善男子。空实无花。病者妄执。由妄执故。非唯惑此虚空自性。亦复迷彼实花生处。由此妄有轮转生死。故名无明。善男子。此无明者。非实有体。如梦中人梦时。非无及至于醒了无所得。如众空花。灭于虚空。不可说言。有定灭处。何以故。无生处故。一切众生。于无生中。妄见生灭。是故说名轮转生死。善男子。如来因地。修圆觉者。知是空花。即无轮转。亦无身心受彼生死。非作故无。本性无故。彼知觉者。犹如虚空。知虚空者即空花相。亦不可说。无知觉性。有无俱遣。是则名为净觉随顺。何以故。虚空性故。常不动故。如来藏中。无起灭故。无知见故。如法界性。究竟圆满。遍十方故。是则名为因地法行菩萨因此于大乘中。发清净心。末世众生。依此修行。不堕邪见。尔时世尊。欲重宣此义。而说偈言

  文殊汝当知　　一切诸如来
  从于本因地　　皆以智慧觉
  了达于无明　　知彼如空花
  即能免流转　　又如梦中人
  醒时不可得　　觉者如虚空
  平等不动转　　觉遍十方界
  即得成佛道　　众幻灭无处
  成道亦无得　　本性圆满故
  菩萨于此中　　能发菩提心
  末世诸众生　　修此免邪见

于是普贤菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。愿为此会诸菩萨众。及为末世一切众生修大乘者。闻此圆觉清净境界。云何修行。世尊。若彼众生。知如幻者。身心亦幻。云何以幻还修于幻。若诸幻性。一切尽灭。则无有心。谁为修行。云何复说修行如幻。若诸众生。本不修行。于生死中。常居幻化。曾不了知如幻境界。令妄想心云何解脱。愿为末世一切众生。作何方便。渐次修习。令诸众生永离诸幻。作是语已。五体投地。如是三请。终而复始

尔时世尊。告普贤菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨。及末世众生。修习菩萨如幻三昧方便。渐次令诸众生得离诸幻。汝今谛听。当为汝说。时普贤菩萨。奉教欢喜。及诸大众。默然而听

善男子。一切众生。种种幻化。皆生如来圆觉妙心。犹如空花从空而有。幻花虽灭空性不坏。众生幻心。还依幻灭。诸幻尽灭。觉心不动。依幻说觉。亦名为幻。若说有觉。犹未离幻。说无觉者。亦复如是。是故。幻灭名为不动。善男子。一切菩萨及末世众生。应当远离一切幻化虚妄境界。由坚执持远离心故。心如幻者。亦复远离。远离为幻。亦复远离离远离幻亦复远离得无所离。即除诸幻。譬如钻火两木相因火出木尽灰飞烟灭。以幻修幻。亦复如是。诸幻虽尽。不入断灭。善男子。知幻即离。不作方便。离幻即觉。亦无渐次。一切菩萨及末世众生。依此修行。如是乃能永离诸幻。尔时世尊。欲重宣此义。而说偈言

  普贤汝当知　　一切诸众生
  无始幻无明　　皆从诸如来
  圆觉心建立　　犹如虚空花
  依空而有相　　空花若复灭
  虚空本不动　　幻从诸觉生
  幻灭觉圆满　　觉心不动故
  若彼诸菩萨　　及末世众生
  常应远离幻　　诸幻悉皆离
  如木中生火　　木尽火还灭
  觉则无渐次　　方便亦如是

于是普眼菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。愿为此会诸菩萨众及为末世一切众生。演说菩萨修行渐次。云何思惟。云何住持。众生未悟作何方便普令开悟。世尊。若彼众生。无正方便及正思惟。闻佛如来说此三昧。心生迷闷。则于圆觉。不能悟入。愿兴慈悲。为我等辈及末世众生假说方便。作是语已。五体投地。如是三请。终而复始

尔时世尊。告普眼菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来修行渐次思惟住持乃至假说种种方便。汝今谛听。当为汝说。时普眼菩萨。奉教欢喜。及诸大众默然而听

善男子。彼新学菩萨及末世众生。欲求如来净圆觉心。应当正念远离诸幻。先依如来奢摩他行。坚持禁戒。安处徒众。宴坐静室。恒作是念。我今此身四大和合。所谓发毛爪齿皮肉筋骨髓脑垢色皆归于地。唾涕脓血津液涎沫痰泪精气大小便利皆归于水。暖气归火。动转归风。四大各离。今者妄身。当在何处。即知此身毕竟无体。和合为相。实同幻化。四缘假合。妄有六根。六根四大。中外合成。妄有缘气。于中积聚似有缘相假名为心。善男子。此虚妄心若无六尘则不能有。四大分解无尘可得。于中缘尘各归散灭。毕竟无有缘心可见。善男子。彼之众生幻身灭故幻心亦灭。幻心灭故幻尘亦灭。幻尘灭故幻灭亦灭。幻灭灭故非幻不灭。譬如磨镜垢尽明现。善男子。当知身心皆为幻垢垢相永灭十方清净。善男子。譬如清净摩尼宝珠映于五色随方各现。诸愚痴者见彼摩尼实有五色。善男子。圆觉净性现于身心随类各应。彼愚痴者。说净圆觉实有如是身心。自相亦复如是。由此不能远于幻化是故我说身心幻垢对离幻垢说名菩萨垢尽对除即无对垢及说名者。善男子。此菩萨及末世众生。证得诸幻灭影像故。尔时便得无方清净。无边虚空觉所显发。觉圆明故显心清净。心清净故见尘清净。见清净故眼根清净。根清净故眼识清净。识清净故闻尘清净。闻清净故耳根清净。根清净故耳识清净。识清净故觉尘清净。如是乃至鼻舌身意亦复如是。善男子。根清净故色尘清净。色清净故声尘清净。香味触法亦复如是。善男子。六尘清净故。地大清净。地清净故水大清净。火大风大亦复如是。善男子。四大清净故。十二处十八界二十五有清净。彼清净故。十力四无所畏。四无碍智。佛十八不共法。三十七助道品清净。如是乃至八万四千陀罗尼门一切清净。善男子。一切实相性清净故一身清净。一身清净故多身清净。多身清净故如是乃至十方众生圆觉清净。善男子。一世界清净故多世界清净。多世界清净故如是乃至尽于虚空圆裹三世一切平等清净不动

善男子。虚空如是平等不动。当知觉性平等不动四大不动故。当知觉性平等不动。如是乃至八万四千陀罗尼门平等不动。当知觉性平等不动。善男子。觉性遍满清净不动。圆无际故。当知六根遍满法界。根遍满故当知六尘遍满法界。尘遍满故当知四大遍满法界。如是乃至陀罗尼门遍满法界。善男子。由彼妙觉性遍满故。根性尘性无坏无杂。根尘无坏故如是乃至陀罗尼门无坏无杂。如百千灯光照一室。其光遍满无坏无杂。善男子。觉成就故。当知菩萨。不与法缚。不求法脱。不厌生死不爱涅槃。不敬持戒。不憎毁禁。不重久习。不轻初学。何以故一切觉故。譬如眼光晓了前境。其光圆满得无憎爱。何以故光体无二无憎爱故。善男子。此菩萨及末世众生。修习此心。得成就者。于此无修亦无成就。圆觉普照寂灭无二。于中百千万亿不可说阿僧祇恒河沙诸佛世界。犹如空花乱起乱灭。不即不离无缚无脱。始知众生本来成佛生死涅槃犹如昨梦。善男子。如昨梦故当知生死及与涅槃无起无灭无来无去。其所证者无得无失无取无舍。其能证者无住无止无作无灭。于此证中无能无所毕竟无证亦无证者一切法性平等不坏。善男子。彼诸菩萨。如是修行。如是渐次。如是思惟。如是住持。如是方便。如是开悟。求如是法。亦不迷闷。尔时世尊欲重宣此义。而说偈言

  普眼汝当知　　一切诸众生
  身心皆如幻　　身相属四大
  心性归六尘　　四大体各离
  谁为和合者　　如是渐修行
  一切悉清净　　不动遍法界
  无作止任灭　　亦无能证者
  一切佛世界　　犹如虚空花
  三世悉平等　　毕竟无来去
  初发心菩萨　　及末世众生
  欲求入佛道　　应如是修习

于是金刚藏菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。善为一切诸菩萨众。宣扬如来圆觉清净大陀罗尼因地法行渐次方便。与诸众生开发蒙昧。在会法众。承佛慈诲。幻翳朗然。慧目清净。世尊若诸众生本来成佛。何故复有一切无明。若诸无明。众生本有。何因缘故。如来复说本来成佛。十方异生。本成佛道。后起无明。一切如来。何时复生一切烦恼唯愿不舍无遮大慈。为诸菩萨开秘密藏。及为末世一切众生。得闻如是修多罗教了义法门。永断疑悔。作是语已。五体投地。如是三请。终而复始

尔时世尊。告金刚藏菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来甚深秘密究竟方便。是诸菩萨最上教诲了义大乘。能使十方修学菩萨及诸末世一切众生。得决定信。永断疑悔。汝今谛听。当为汝说。时金刚藏菩萨奉教欢喜。及诸大众默然而听

善男子。一切世界始终生灭。前后有无。聚散起止。念念相续。循环往复。种种取舍。皆是轮回。未出轮回。而辨圆觉。彼圆觉性即同流转。若免轮回。无有是处。譬如动目能摇湛水。又如定眼。犹回转火。云驶月运舟行岸移亦复如是。善男子。诸旋未息。彼物先住。尚不可得。何况轮转生死垢心。曾未清净。观佛圆觉而不旋复。是故汝等便生三惑

善男子。譬如患翳妄见空花。患翳若除。不可说言。此翳已灭何时更起一切诸翳。何以故。翳花二法非相待故。亦如空花灭于空时。不可说言虚空何时更起空花。何以故。空本无花非起灭故生死涅槃同于起灭。妙觉圆照离于花翳。善男子。当知虚空非是暂有亦非暂无。况复如来圆觉随顺而为虚空平等本性

善男子。如销金矿金非销有既已成金不重为矿。经无穷时。金性不坏。不应说言本非成就。如来圆觉亦复如是。善男子一切如来妙圆觉心本无菩提及与涅槃。亦无成佛及不成佛。无妄轮回及非轮回

善男子。但诸声闻所圆境界身心语言皆悉断灭。终不能至彼之亲证所现涅槃。何况能以有思惟心测度如来圆觉境界。如取萤火烧须弥山。终不能着。以轮回心。生轮回见。入于如来大寂灭海。终不能至。是故我说一切菩萨及末世众生先断无始轮回根本。善男子。有作思惟从有心起。皆是六尘。妄想缘气。非实心体。已如空花。用此思惟辨于佛境。犹如空花复结空果。展转妄想。无有是处。善男子。虚妄浮心。多诸巧见。不能成就圆觉方便。如是分别。非为正问。尔时世尊。欲重宣此义。而说偈言

  金刚藏当知　　如来寂灭性
  未曾有终始　　若以轮回心
  思惟即旋复　　但至轮回际
  不能入佛海　　譬如销金矿
  金非销故有　　虽复本来金
  终以销成就　　一成真金体
  不复重为矿　　生死与涅槃
  凡夫及诸佛　　同为空花相
  思惟犹幻化　　何况诘虚妄
  若能了此心　　然后求圆觉

于是弥勒菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。广为菩萨开秘密藏。令诸大众深悟轮回分别邪正。能施末世一切众生无畏道眼。于大涅槃生决定信。无复重随轮转境界起循环见。世尊。若诸菩萨及末世众生。欲游如来大寂灭海。云何当断轮回根本。于诸轮回。有几种性。修佛菩提。几等差别。回入尘劳。当设几种教化方便度诸众生。唯愿不舍救世大悲。令诸修行一切菩萨及末世众生慧目肃清照曜心镜。圆悟如来无上知见。作是语已。五体投地。如是三请终而复始

尔时世尊。告弥勒菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生请问如来深奥秘密微妙之义。令诸菩萨洁清慧目。及令一切末世众生永断轮回心悟实相具无生忍。汝今谛听。当为汝说。时弥勒菩萨奉教欢喜。及诸大众默然而听

善男子。一切众生从无始际由有种种恩爱贪欲故有轮回。若诸世界一切种性。卵生胎生湿生化生。皆因淫欲而正性命。当知轮回爱为根本。由有诸欲。助发爱性。是故。能令生死相续。欲因爱生。命因欲有。众生爱命还依欲本。爱欲为因爱命为果。由于欲境起诸违顺。境背爱心而生憎嫉造种种业。是故。复生地狱饿鬼。知欲可厌爱厌业道。舍恶乐善。复现天人。又知诸爱可厌恶故。弃爱乐舍。还滋爱本。便现有为增上善果。皆轮回故不成圣道。是故。众生欲脱生死免诸轮回。先断贪欲及除爱渴。善男子。菩萨变化示现世间非爱为本。但以慈悲令彼舍爱。假诸贪欲而入生死。若诸末世一切众生能舍诸欲及除憎爱永断轮回。勤求如来圆觉境界。于清净心便得开悟

善男子。一切众生由本贪欲。发挥无明显出五性。差别不等。依二种障。而现深浅。云何二障。一者理障碍正知见。二者事障续诸生死。云何五性。善男子。若此二障未得断灭名未成佛。若诸众生永舍贪欲先除事障。未断理障但能悟入声闻缘觉。未能显住菩萨境界。善男子。若诸末世一切众生。欲泛如来大圆觉海。先当发愿勤断二障。二障已伏。即能悟入菩萨境界。若事理障已永断灭即入如来微妙圆觉。满足菩提及大涅槃。善男子。一切众生皆证圆觉。逢善知识依彼所作因地法行。尔时修习便有顿渐。若遇如来无上菩提正修行路。根无大小皆成佛果。若诸众生虽求善友遇邪见者未得正悟。是则名为外道种性邪师过谬非众生咎。是名众生五性差别

善男子。菩萨唯以大悲方便入诸世间开发未悟。乃至示现种种形相逆顺境界。与其同事化令成佛。皆依无始清净愿力。若诸末世一切众生于大圆觉起增上心。当发菩萨清净大愿。应作是言。愿我今者住佛圆觉求善知识莫值外道及与二乘。依愿修行渐断诸障障尽愿满。便登解脱清净法殿。证大圆觉妙庄严域。尔时世尊。欲重宣此义。而说偈言

  弥勒汝当知　　一切诸众生
  不得大解脱　　皆由贪欲故
  堕落于生死　　若能断憎爱
  及与贪嗔痴　　不因差别性
  皆得成佛道　　二障永销灭
  求师得正悟　　随顺菩提愿
  依止大涅槃　　十方诸菩萨
  皆以大悲愿　　示现入生死
  现在修行者　　及末世众生
  勤断诸爱见　　便归大圆觉

于是清净慧菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。为我等辈。广说如是不思议事。本所不见本所不闻。我等今者蒙佛善诱。身心泰然得大饶益。愿为一切诸来法众。重宣法王圆满觉性。一切众生及诸菩萨。如来世尊所证所得云何差别。令末世众生闻此圣教随顺开悟渐次能入。作是语已。五体投地。如是三请。终而复始

尔时世尊。告清净慧菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。请问如来渐次差别。汝今谛听。当为汝说。时清净慧菩萨。奉教欢喜。及诸大众默然而听

善男子。圆觉自性。非性性有。循诸性起。无取无证。于实相中实无菩萨及诸众生。何以故。菩萨众生皆是幻化。幻化灭故无取证者。譬如眼根不自见眼性。自平等无平等者。众生迷倒未能除灭一切幻化。于灭未灭妄。功用中便显差别。若得如来寂灭随顺实无寂灭及寂灭者。善男子。一切众生从无始来由妄想我及爱我者。曾不自知念念生灭。故起憎爱耽着五欲。若遇善友教令开悟净圆觉性。发明起灭即知此生性自劳虑。若复有人劳虑永断得法界净即彼净解为自障碍。故于圆觉而不自在。此名凡夫随顺觉性。善男子。一切菩萨见解为碍。虽断解碍犹住见觉。觉碍为碍而不自在。此名菩萨未入地者随顺觉性。善男子。有照有觉俱名障碍。是故菩萨常觉不住。照与照者同时寂灭。譬如有人自断其首。首已断故无能断者。则以碍心自灭诸碍。碍已断灭无灭碍者。修多罗教如标月指。若复见月了知所标毕竟非月。一切如来种种言说开示菩萨亦复如是。此名菩萨。已入地者随顺觉性

善男子。一切障碍即究竟觉。得念失念无非解脱。成法破法皆名涅槃。智慧愚痴通为般若。菩萨外道所成就法同是菩提。无明真如无异境界。诸戒定慧及淫怒痴俱是梵行。众生国土同一法性。地狱天宫皆为净土。有性无性齐成佛道。一切烦恼毕竟解脱。法界海慧照了诸相犹如虚空。此名如来随顺觉性。善男子。但诸菩萨及末世众生。居一切时。不起妄念。于诸妄心。亦不息灭。住妄想境。不加了知。于无了知。不辨真实。彼诸众生。闻是法门。信解受持。不生惊畏。是则名为随顺觉性。善男子。汝等当知。如是众生已曾供养百千万亿恒河沙诸佛及大菩萨。植众德本。佛说是人名为成就一切种智。尔时世尊。欲重宣此义。而说偈言

  清净慧当知　　圆满菩提性
  无取亦无证　　无菩萨众生
  觉与未觉时　　渐次有差别
  众生为解碍　　菩萨未离觉
  入地永寂灭　　不住一切相
  大觉悉圆满　　名为遍随顺
  末世诸众生　　心不生虚妄
  佛说如是人　　现世即菩萨
  供养恒沙佛　　功德已圆满
  虽有多方便　　皆名随顺智

于是威德自在菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。广为我等。分别如是随顺觉性。令诸菩萨觉心光明承佛圆音。不因修习而得善利。世尊。譬如大城外有四门。随方来者非止一路。一切菩萨庄严佛国及成菩提非一方便。唯愿世尊。广为我等。宣说一切方便渐次并修行人总有几种。令此会菩萨及末世众生求大乘者。速得开悟游戏如来大寂灭海。作是语已。五体投地。如是三请。终而复始。尔时世尊。告威德自在菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来如是方便。汝今谛听。当为汝说。时威德自在菩萨奉教欢喜。及诸大众默然而听。善男子。无上妙觉遍诸十方出生如来。与一切法同体平等。于诸修行实无有二。方便随顺其数无量。圆摄所归循性差别当有三种。善男子。若诸菩萨悟净圆觉。以净觉心。取静为行。由澄诸念。觉识烦动。静慧发生。身心客尘从此永灭。便能内发寂静轻安。由寂静故十方世界诸如来心于中显现。如镜中像。此方便者名奢摩他

善男子。若诸菩萨悟净圆觉。以净觉心。知觉心性及与根尘皆因幻化。即起诸幻。以除幻者。变化诸幻而开幻众。由起幻故便能内发大悲轻安。一切菩萨从此起行渐次增进。彼观幻者非同幻故。非同幻观皆是幻故幻相永离。是诸菩萨所圆妙行如土长苗。此方便者名三摩钵提

善男子。若诸菩萨悟净圆觉。以净觉心不取幻化及诸净相。了知身心皆为挂碍。无知觉明不依诸碍。永得超过碍无碍境。受用世界及与身心。相在尘域。如器中锽。声出于外。烦恼涅槃不相留碍。便能内发寂灭轻安妙觉随顺寂灭境界。自他身心所不能及。众生寿命皆为浮想。此方便者名为禅那

善男子。此三法门皆是圆觉。亲近随顺十方如来。因此成佛十方菩萨种种方便一切同异皆依如是三种事业。若得圆证即成圆觉。善男子。假使有人修于圣道。教化成就百千万亿阿罗汉辟支佛果。不如有人闻此圆觉无碍法门一刹那顷随顺修习。尔时世尊。欲重宣此义。而说偈言

  威德汝当知　　无上大觉心
  本际无二相　　随顺诸方便
  其数即无量　　如来总开示
  便有三种类　　寂静奢摩他
  如镜照诸像　　如幻三摩提
  如苗渐增长　　禅那唯寂灭
  如彼器中锽　　三种妙法门
  皆是觉随顺　　十方诸如来
  及诸大菩萨　　因此得成道
  三事圆证故　　名究竟涅槃

于是辩音菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。如是法门甚为希有。世尊。此诸方便一切菩萨于圆觉门有几修习。愿为大众及末世众生。方便开示令悟实相。作是语已。五体投地。如是三请。终而复始

尔时世尊。告辩音菩萨言。善哉善哉。善男子。汝等乃能为诸大众及末世众生。问于如来如是修习。汝今谛听。当为汝说。时辩音菩萨奉教欢喜。及诸大众默然而听

善男子。一切如来圆觉清净本无修习及修习者。一切菩萨及末世众生依于未觉幻力修习。尔时便有二十五种清净定轮

若诸菩萨唯取极静。由静力故永断烦恼究竟成就。不起于座便入涅槃。此菩萨者名单修奢摩他

若诸菩萨唯观如幻以佛力故。变化世界种种作用。备行菩萨清净妙行。于陀罗尼不失寂念及诸静慧。此菩萨者名单修三摩钵提

若诸菩萨唯灭诸幻不取作用独断烦恼。烦恼断尽便证实相。此菩萨者名单修禅那

若诸菩萨先取至静。以静慧心照诸幻者。便于是中起菩萨行。此菩萨者名先修奢摩他后修三摩钵提

若诸菩萨以静慧故证至静性。便断烦恼永出生死。此菩萨者名先修奢摩他后修禅那

若诸菩萨以寂静慧复现幻力种种变化度诸众生。后断烦恼而入寂灭。此菩萨者名先修奢摩他中修三摩钵提后修禅那

若诸菩萨以至静力断烦恼已后起菩萨清净妙行度诸众生。此菩萨者名先修奢摩他中修禅那后修三摩钵提

若诸菩萨以至静力心断烦恼后度众生建立世界。此菩萨者名先修奢摩他齐修三摩钵提及修禅那

若诸菩萨以至静力资发变化后断烦恼。此菩萨者名齐修奢摩他三摩钵提后修禅那

若诸菩萨以至静力用资寂灭。后起作用变化境界。此菩萨者名齐修奢摩他禅那后修三摩钵提

若诸菩萨以变化力种种随顺而取至静。此菩萨者名先修三摩钵提后修奢摩他

若诸菩萨以变化力种种境界而取寂灭。此菩萨者名先修三摩钵提后修禅那

若诸菩萨以变化力而作佛事安在寂静而断烦恼。此菩萨者名先修三摩钵提中修奢摩他后修禅那

若诸菩萨以变化力无碍作用。断烦恼故安住至静。此菩萨者名先修三摩钵提中修禅那后修奢摩他

若诸菩萨以变化力方便作用至静寂灭二俱随顺。此菩萨者名先修三摩钵提齐修奢摩他禅那

若诸菩萨以变化力种种起用资于至静后断烦恼此菩萨者名齐修三摩钵提奢摩他后修禅那

若诸菩萨以变化力资于寂灭后住清净无作静虑此菩萨者名齐修三摩钵提禅那后修奢摩他

若诸菩萨以寂灭力而起至静住于清净。此菩萨者名先修禅那后修奢摩他

若诸菩萨以寂灭力而起作用。于一切境寂用随顺。此菩萨者名先修禅那后修三摩钵提

若诸菩萨以寂灭力种种自性安于静虑而起变化。此菩萨者。名先修禅那中修奢摩他后修三摩钵提

若诸菩萨以寂灭力无作自性起于作用。清净境界归于静虑。此菩萨者。名先修禅那中修三摩钵提后修奢摩他

若诸菩萨以寂灭力种种清净而住静虑起于变化。此菩萨者。名先修禅那齐修奢摩他三摩钵提

若诸菩萨以寂灭力。资于至静而起变化。此菩萨者。名齐修禅那奢摩他后修三摩钵提

若诸菩萨以寂灭力资于变化。而起至静清明境慧。此菩萨者。名齐修禅那三摩钵提后修奢摩他

若诸菩萨以圆觉慧圆合一切。于诸性相无离觉性。此菩萨者。名为圆修三种自性清净随顺。善男子。是名菩萨二十五轮一切菩萨修行。如是若诸菩萨及末世众生依此轮者。当持梵行寂静思惟求哀忏悔。经三七日。于二十五轮。各安标记。至心求哀。随手结取。依结开示。便知顿渐。一念疑悔。即不成就。尔时世尊。欲重宣此义。而说偈言

  辩音汝当知　　一切诸菩萨
  无碍清净慧　　皆依禅定生
  所谓奢摩他　　三摩提禅那
  三法顿渐修　　有二十五种
  十方诸如来　　三世修行者
  无不因此法　　而得成菩提
  唯除顿觉人　　并法不随顺
  一切诸菩萨　　及末世众生
  常当持此轮　　随顺勤修习
  依佛大悲力　　不久证涅槃

于是净诸业障菩萨。在大众中。即从座起顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。为我等辈广说如是不思议事一切如来因地行相。令诸大众得未曾有。睹见调御历恒沙劫。勤苦境界一切功用犹如一念。我等菩萨深自庆慰。世尊。若此觉心本性清净。因何染污。使诸众生迷闷不入。唯愿如来广为我等开悟法性。令此大众及末世众生作将来眼。说是语已。五体投地。如是三请。终而复始。尔时世尊。告净诸业障菩萨言。善哉善哉。善男子。汝等乃能为诸大众及末世众生。咨问如来如是方便。汝今谛听。当为汝说。时净诸业障菩萨奉教欢喜。及诸大众默然而听。善男子。一切众生从无始来妄想执有我人众生及与寿命。认四颠倒为实我体。由此便生憎爱二境。于虚妄体重执虚妄。二妄相依生妄业道。有妄业故妄见流转。厌流转者妄见涅槃。由此不能入清净觉。非觉违拒诸能入者。有诸能入非觉入故。是故。动念及与息念皆归迷闷。何以故。由有无始本起无明为己主宰。一切众生生无慧目。身心等性。皆是无明。譬如有人不自断命。是故。当知。有爱我者我与随顺。非随顺者。便生憎怨。为憎爱心养无明故。相续求道皆不成就

善男子。云何我相。谓诸众生心所证者。善男子。譬如有人百骸调适忽忘我身四支弦缓摄养乖方微加针艾则知有我。是故证取方现我体。善男子。其心乃至证于如来毕竟了知清净涅槃皆是我相

善男子。云何人相。谓诸众生心悟证者。善男子。悟有我者不复认我。所悟非我悟亦如是。悟已超过一切证者悉为人相。善男子。其心乃至圆悟涅槃俱是我者。心存少悟备殚证理皆名人相

善男子。云何众生相。谓诸众生心自证悟所不及者。善男子。譬如有人作如是言我是众生。则知彼人说众生者非我非彼。云何非我我是众生则非是我。云何非彼我是众生非彼我故。善男子。但诸众生了证了悟皆为我人而我人相所不及者存有所了名众生相。善男子。云何寿命相。谓诸众生心照清净觉所了者。一切业智所不自见犹如命根。善男子。若心照见一切觉者皆为尘垢。觉所觉者不离尘故。如汤销冰无别有冰知冰销者。存我觉我亦复如是

善男子。末世众生不了四相。虽经多劫勤苦修道但名有为。终不能成一切圣果。是故名为正法末世。何以故。认一切我为涅槃故。有证有悟名成就故。譬如有人以贼为子其家财宝终不成就。何以故。有我爱者亦爱涅槃。伏我爱根为涅槃相。有憎我者亦憎生死。不知爱者真生死故。别憎生死名不解脱。云何当知法不解脱。善男子。彼末世众生习菩提者。以己微证为自清净犹未能尽我相根本。若复有人赞叹彼法即生欢喜便欲济度。若复诽谤彼所得者便生嗔恨。则知我相坚固执持潜伏藏识游戏诸根曾不间断。善男子。彼修道者不除我相。是故不能入清净觉。善男子。若知我空无毁我者有我说法我未断故。众生寿命亦复如是。善男子。末世众生说病为法。是故名为可怜愍者。虽勤精进增益诸病。是故不能入清净觉。善男子。末世众生不了四相。以如来解及所行处为自修行终不成就或有众生未得谓得未证谓证。见胜进者心生嫉妒。由彼众生未断我爱。是故不能入清净觉。善男子。末世众生希望成道无令求悟。唯益多闻增长我见。但当精勤降伏烦恼起大勇猛。未得令得未断令断。贪嗔爱慢谄曲嫉妒对境不生。彼我恩爱一切寂灭。佛说是人渐次成就。求善知识不堕邪见。若于所求别生憎爱则不能入清净觉海。尔时世尊欲重宣此义。而说偈言

  净业汝当知　　一切诸众生
  皆由执我爱　　无始妄流转
  未除四种相　　不得成菩提
  爱憎生于心　　谄曲存诸念
  是故多迷闷　　不能入觉城
  若能归悟刹　　先去贪嗔痴
  法爱不存心　　渐次可成就
  我身本不有　　憎爱何由生
  此人求善友　　终不堕邪见
  所求别生心　　究竟非成就

于是普觉菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。快说禅病。令诸大众得未曾有心意荡然获大安隐。世尊。末世众生去佛渐远。贤圣隐伏邪法增炽。使诸众生求何等人依何等法行何等行除去何病。云何发心令彼群盲不堕邪见。作是语已。五体投地。如是三请。终而复始

尔时世尊。告普觉菩萨言。善哉善哉。善男子。汝等乃能咨问如来如是修行。能施末世一切众生无畏道眼。令彼众生得成圣道。汝今谛听。当为汝说。时普觉菩萨奉教欢喜。及诸大众默然而听

善男子。末世众生将发大心。求善知识欲修行者。当求一切正知见人。心不住相。不着声闻缘觉境界。虽现尘劳心恒清净。示有诸过赞叹梵行。不令众生入不律仪。求如是人即得成就阿耨多罗三藐三菩提。末世众生见如是人应当供养不惜身命。彼善知识四威仪中常现清净。乃至示现种种过患心无憍慢。况复搏财妻子眷属。若善男子于彼善友不起恶念。即能究竟成就正觉。心花发明照十方刹

善男子。彼善知识所证妙法应离四病。云何四病。一者作病。若复有人作如是言。我于本心作种种行欲求圆觉。彼圆觉性非作得故说名为病。二者任病。若复有人作如是言。我等今者不断生死不求涅槃。涅槃生死无起灭念。任彼一切随诸法性欲求圆觉。彼圆觉性非任有故说名为病。三者止病。若复有人作如是言。我今自心永息诸念得一切性。寂然平等欲求圆觉。彼圆觉性非止合故说名为病。四者灭病。若复有人作如是言。我今永断一切烦恼身心毕竟空无所有。何况根尘虚妄境界一切永寂欲求圆觉。彼圆觉性非寂相故说名为病。离四病者。则知清净。作是观者名为正观。若他观者名为邪观

善男子。末世众生欲修行者。应当尽命供养善友事善知识。彼善知识欲来亲近应断憍慢。若复远离应断嗔恨。现逆顺境犹如虚空。了知身心毕竟平等。与诸众生同体无异如是修行方入圆觉。善男子。末世众生不得成道。由有无始自他憎爱一切种子故未解脱。若复有人。观彼怨家如己父母心无有二即除诸病。于诸法中自他憎爱亦复如是。善男子。末世众生欲求圆觉。应当发心作如是言。尽于虚空一切众生我皆令入究竟圆觉。于圆觉中无取觉者。除彼我人一切诸相。如是发心不堕邪见。尔时世尊欲重宣此义。而说偈言

  普觉汝当知　　末世诸众生
  欲求善知识　　应当求正觉
  心远二乘者　　法中除四病
  谓作止任灭　　亲近无憍慢
  远离无嗔恨　　见种种境界
  心当生希有　　还如佛出世
  不犯非律仪　　戒根永清净
  度一切众生　　究竟入圆觉
  无彼我人相　　常依止智慧
  便得超邪见　　证觉般涅槃

于是圆觉菩萨在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手。而白佛言。大悲世尊。为我等辈。广说净觉种种方便。令末世众生有大增益。世尊。我等今者已得开悟。若佛灭后末世众生未得悟者。云何安居修此圆觉清净境界。此圆觉中三种净观以何为首。唯愿大悲为诸大众及末世众生施大饶益作是语已。五体投地。如是三请。终而复始

尔时世尊。告圆觉菩萨言。善哉善哉。善男子。汝等乃能问于如来如是方便。以大饶益施诸众生。汝今谛听。当为汝说。时圆觉菩萨奉教欢喜。及诸大众默然而听

善男子。一切众生。若佛住世。若佛灭后若法末时。有诸众生具大乘性信佛秘密大圆觉心欲修行者。若在伽蓝安处徒众。有缘事故随分思察。如我已说。若复无有他事因缘。即建道场当立期限。若立长期百二十日。中期百日。下期八十日安置净居。若佛现在当正思惟。若佛灭后施设形像。心存目想生正忆念。还同如来常住之日。悬诸幡花。经三七日。稽首十方诸佛名字。求哀忏悔遇善境界得心轻安。过三七日一向摄念。若经夏首三月安居。当为清净菩萨止住。心离声闻不假徒众。至安居日即于佛前作如是言。我比丘比丘尼优婆塞优婆夷某甲。踞菩萨乘修寂灭行同入清净实相住持以大圆觉为我伽蓝身心安居。平等性智涅槃自性无系属故。今我敬请不依声闻。当与十方如来及大菩萨三月安居。为修菩萨无上妙觉大因缘故不系徒众。善男子。此名菩萨示现安居过三期日随往无碍。善男子。若彼末世修行众生求菩萨道入三期者。非彼所闻一切境界终不可取

善男子。若诸众生修奢摩他。先取至静不起思念静极便觉。如是初静从于一身至一世界觉亦如是。善男子。若觉遍满一世界者。一世界中有一众生起一念者皆悉能知。百千世界亦复如是。非彼所闻一切境界终不可取

善男子。若诸众生修三摩钵提。先当忆想十方如来十方世界一切菩萨。依种种门渐次修行勤苦三昧广发大愿自熏成种非彼所闻一切境界终不可取

善男子。若诸众生。修于禅那先取数门。心中了知生住灭念分齐头数。如是周遍四威仪中分别念数无不了知。渐次增进乃至得知百千世界一滴之雨。犹如目睹所受用物。非彼所闻一切境界终不可取。是名三观初首方便。若诸众生。遍修三种勤行精进即名如来出现于世。若后末世钝根众生心欲求道不得成就由昔业障。当勤忏悔常起希望先断憎爱嫉妒谄曲求胜上心。三种净观随学一事。此观不得复习彼观心不放舍渐次求证。尔时世尊欲重宣此义。而说偈言

  圆觉汝当知　　一切诸众生
  欲行无上道　　先当结三期
  忏悔无始业　　经于三七日
  然后正思惟　　非彼所闻境
  毕竟不可取　　奢摩他至静
  三摩正忆持　　禅那明数门
  是名三净观　　若能勤修习
  是名佛出世　　钝根未成者
  常当勤心忏　　无始一切罪
  诸障若锁灭　　佛境便现前

于是贤善首菩萨。在大众中。即从座起。顶礼佛足。右绕三匝。长跪叉手而白佛言大悲世尊。广为我等及末世众生。开悟如是不思议事。世尊。此大乘教名字何等。云何奉持。众生修习得何功德。云何使我护持经人。流布此教至于何地。作是语已。五体投地。如是三请。终而复始

尔时世尊。告贤善首菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来如是经教功德名字。汝今谛听。当为汝说。时贤善首菩萨奉教欢喜。及诸大众默然而听

善男子。是经百千万亿恒河沙诸佛所说。三世如来之所守护。十方菩萨之所归依。十二部经清净眼目。是经名大方广圆觉陀罗尼。亦名修多罗了义。亦名秘密王三昧。亦名如来决定境界。亦名如来藏自性差别。汝当奉持。善男子。是经唯显如来境界。唯佛如来能尽宣说。若诸菩萨及末世众生依此修行渐次增进至于佛地。善男子。是经名为顿教大乘。顿机众生从此开悟。亦摄渐修一切群品。譬如大海不让小流乃至蚊虻及阿修罗饮其水者皆得充满。善男子。假使有人纯以七宝积满三千大千世界以用布施。不如有人闻此经名及一句义。善男子。假使有人教百千恒河沙众生得阿罗汉果。不如有人宣说此经分别半偈。善男子。若复有人闻此经名信心不惑。当知是人。非于一佛二佛种诸福慧。如是乃至尽恒河沙一切佛所种诸善根闻此经教。汝善男子。当护末世是修行者。无令恶魔及诸外道恼其身心令生退屈。尔时会中。有火首金刚摧碎金刚尼蓝婆金刚等八万金刚并其眷属。即从座起。顶礼佛足。而白佛言。世尊。若后末世。一切众生。有能持此决定大乘。我当守护如护眼目。乃至道场所修行处。我等金刚自领徒众晨夕守护。令不退转。其家乃至永无灾障。疫病销灭。财宝丰足常不乏少

尔时大梵天王二十八天王并须弥山王护国天王等。即从座起。顶礼佛足。右绕三匝而白佛言。世尊。我亦守护是持经者。常令安隐心不退转

尔时有大力鬼王名吉槃茶。与十万鬼王。即从座起。顶礼佛足。右绕三匝。而白佛言。世尊。我亦守护是持经人。朝夕侍卫令不退屈。其人所居一由旬内。若有鬼神侵其境界。我当使其碎如微尘。佛说此经已。一切菩萨天龙鬼神八部眷属及诸天王梵王等一切大众。闻佛所说。皆大欢喜。信受奉行大方广圆觉修多罗了义经


大花严长者问佛那罗延力经

    No. 547

大花严长者问佛那罗延力经

        罽宾国三藏般若共利言译

如是我闻。一时薄伽梵。在室罗筏悉底国逝多林给孤独园。时大花严长者。从坐而起整理衣服。长跪合掌而白佛言。大德世尊。一切有情施饮食者。当得何报

尔时薄伽梵告长者言。若施食者。得如来力。时大长者复白佛言。世尊。其如来力。颇有譬喻而能宣说。令我闻不

佛告长者言。有善男子。不可以少因缘而能说之。复告长者。如十凡牛力。等一犎牛力十犎牛力等一犀牛力。十犀牛力等一凡象力。十凡象力等一设腊婆力(形如麚面似犀牛身有八脚四在背上四踞地行下足若困翻上憩令上足下履地而行力能负象)十设腊婆力等一斗战象力。十斗战象力等一醉象力。十醉象力等一野象力。十野象力等一羯嚟耨迦象力。十羯嚟耨迦象力。等一拘牟头花象力。十拘牟头花象力。等一嗢钵罗花象力。十嗢钵罗花象力。等一宁卢钵罗象力。十宁卢钵罗象力。等一大香象力。十大香象力。等一五色师子王力。十师子王力。等一人中力士力。十力士力。等一诺拘罗力。十诺拘罗力。等一遏主那力。十遏主那力。等一毗摩细那力。十毗摩细那力。等一那罗延力。六百六十三那罗延力。等佛世尊一毛孔力。八万四千毛孔之中。一一皆具如是那罗延力。八万四千毛孔之力。等薄伽梵一节之力

佛告长者。以是当知诸佛如来一一节中。皆具八万四千六百六十三种那罗延力

佛说此经已。大花严长者。闻佛所说欢喜奉行大花严长者问佛那罗延力经


大树紧那罗王所问经

    No. 625 [No. 624]

大树紧那罗王所问经卷第一

        姚秦龟兹三藏鸠摩罗什译

如是我闻。一时佛住王舍城只阇崛山。与大比丘众六万二千人俱。菩萨摩诃萨七万二千。众所知识。皆从十方世界来集。得陀罗尼无碍辩才。进入念慧惭愧具足。其志坚固犹如金刚。善修成就一切佛法。志意清净成就具足。自不忘失菩提之心。亦能令他而不忘失。善调柔施摄伏诸根。善能知舍所爱之物。以清净戒善自庄严。于诸众生其心平等。以柔和忍力而自庄严。于无量那由他阿僧祇劫勤修进力。于诸禅定解脱三昧。游戏神通自在无碍。善以智慧分别一切诸法句义。其心不动如大山王。于诸众生其心平等。如地水火风善离爱恚。常行慈心恒遣慈光。遍照众生安住大悲。常勤观察一切众生。住于大喜乐法具足。住于大舍得无二智。利衰毁誉称讥苦乐。皆以超过如是世法。慧光善伏自众他众。降伏众魔。世所难遇如优昙华。为诸众生中大师子吼。究竟涅槃悕乐甚深四无所畏。为如来印之所印之。所记无错如说而行。于深法藏义味相应。蔽诸日月。名称流闻遍十方界。若为诸佛之所护持。守护法藏常不断绝三宝种性。善能游过无边佛刹。善解了知。随宜给侍诸佛世尊。听闻受法。常勤精进教化众生。得到方便智慧彼岸。善随一切诸众生根如应说法。善知一切诸众生等意之行相。其心净妙善巧言说。为大医王善疗众病。已于无量阿僧祇佛所种诸善根。善集相好福德庄严。善能解了空无相愿。善解诸法如幻如焰。如水中月如梦镜像。解一切法如虚空相。善能解了一切众生音声言说。善分别法乐说无尽。善能观察出世之慧。成就大力近佛十力。得明肉眼天眼慧眼法眼佛眼。善度庄严助道法分。善解超度一切诸道。明了菩萨法藏所摄。善能转于不退法轮。得三昧印相。善能知到金刚场三昧。一切诸法自在三昧。常现在前。持大宝炬。其心谦下于诸众生。常观一切诸众生心。亦常观诸众生智慧。近佛智慧。令诸众生施作佛事。所作事办皆已聚集。一切功德尽未来劫。说其功德不可穷尽。其名曰宝住菩萨。宝有菩萨。宝手菩萨。宝花菩萨。宝王菩萨。喜见菩萨。爱意菩萨。爱眼见菩萨。持地菩萨。作喜菩萨。大势菩萨。大德菩萨。降魔菩萨。摩鸠提菩萨。儒天菩萨。曼陀罗香菩萨。实菩萨。等观菩萨。无高下菩萨。善御菩萨。一切众生不请友菩萨。弥勒菩萨。云音菩萨。持山严菩萨。山积菩萨。上友菩萨。勇友菩萨。光明菩萨。光德菩萨。灯王菩萨。观志菩萨。光庄严菩萨。杂彩冠菩萨。天冠菩萨。天王菩萨。天眼观菩萨。观世音菩萨。善臂菩萨。思志等菩萨。善住志菩萨。善住业菩萨。不动足集菩萨。金刚足进菩萨。越三界足菩萨。疾辩菩萨。速辩菩萨。无断辩菩萨。住辩菩萨。妙音菩萨。梵音菩萨。喜一切众生音菩萨。文殊师利法王子菩萨。如是等上首七万二千人。于此三千大千世界。释梵护世并余大威德。诸天龙夜叉乾闼婆。迦楼罗紧那罗摩睺罗伽人与非人。比丘比丘尼。优婆塞优婆夷。皆来集会为欲听法。尔时世尊。与无量百千大众。恭敬围绕而演说法。尔时天冠菩萨。即从座起正衣服。偏袒右肩右膝着地。合掌向佛以偈赞曰

  超世为世作灯明　　智慧利益于世间
  令结闇者得光明　　我今稽首离世间
  十方行施最殊胜　　善自调心到彼岸
  人天龙神所供养　　稽首敬礼烧结仁
  胜相多利益世间　　金色圆光普周遍
  持净妙戒大美音　　稽首三界最无比
  度诸众生到彼岸　　调伏诸论无能动
  善了知诸众生心　　稽首敬礼胜大悲
  断诸结使不生着　　以力降怨善住戒
  天中之天净结垢　　我稽首礼降诸怨
  众宝中最无瑕秽　　常乐智慧为先首
  除断贪嗔愚痴垢　　稽首心等如虚空
  演说四谛度四流　　说甘露法施净眼
  游行三界为利众　　我稽首礼持轮相
  常为人天所供养　　常化众生令度脱
  虚空人天所供养　　我稽首礼人中胜
  常乐集于正善法　　常以慈心等世间
  人尊调御住正道　　稽首摄持一切德
  净音所说胜妙善　　适意柔软梵音声
  善解众音到彼岸　　稽首美妙如实说
  趣空无相及无作　　能最甚深难见法
  善能进趣入解脱　　稽首善知解脱道
  世尊善解知因缘　　常能断离二边见
  实说因缘业果报　　我稽首礼见世间
  无有来者亦去者　　无慢善能观诸法
  如幻如焰水中像　　稽首敬礼善法眼
  生若无生都无生　　若生及灭亦无灭
  其所止处如法住　　调御善住如是处
  所有言说便真实　　善住如如叵倾动
  金刚山身无动摇　　我稽首礼叵倾动
  其身口意等无异　　名闻无量遍三界
  我今欲问胜丈夫　　愿尊勿虑为演说

尔时天冠菩萨。偈赞佛已白佛言。世尊。我今欲于如来应供正遍觉胜妙法中少有所问。若佛听许乃敢咨请。尔时佛告天冠菩萨。善男子。恣汝所问随汝所疑。如来当说悦可汝心。尔时天冠菩萨白佛言。世尊。云何菩萨得成杂种庄严之辩。世尊。云何菩萨得增胜智。善知分别甚深之法。世尊。云何菩萨善知诸根。世尊。云何菩萨善能解知如应说法。世尊。云何菩萨善知一切众生心行。世尊。云何菩萨知一切因行果报。亦知出过所行无失。世尊。云何菩萨庄严布施。世尊。云何菩萨庄严戒忍精进禅智。世尊。云何菩萨善能解知庄严梵道。世尊。云何菩萨不失神通。世尊。云何菩萨断诸结使。世尊。云何菩萨度到彼岸。世尊。云何菩萨能现一切声闻缘觉。及诸众生形色威仪无有别异。世尊。云何菩萨观于生死不住涅槃。世尊。云何菩萨观众生界不动法界。世尊。云何菩萨不退失利观现失利。世尊。云何菩萨有大财宝封邑无尽。以方便力现为贫穷。世尊。云何菩萨行于诸行。令有作门入无作门。世尊。云何菩萨善观诸法。世尊。云何菩萨决定分别一切诸法。世尊。云何菩萨行诸世法不为所污。世尊。云何菩萨于诸自在不观望他。世尊。云何菩萨不离见佛。世尊。云何菩萨善自调伏无诸恶法。世尊。云何菩萨善为师导而不吝法。世尊。云何菩萨为诸众生作实依止。世尊。云何菩萨能转一切诸佛法轮。世尊。云何菩萨于一切法得灌顶位。尔时世尊赞天冠菩萨。善哉善哉。善男子。汝今所问多所利益。安乐世间利安人天。摄取未来诸菩萨等。善男子。汝常曾于恒河沙等佛世尊所。咨请问难。今复当大利益安乐未来菩萨。令此大乘得久住世。善男子。汝之所问善心谛听。吾当演说。天冠菩萨白言。世尊。受教而听。善男子。菩萨成就四法。得于杂种庄严之辩。何等为四。是菩萨于一切众生无侵害心。舍诸一切所爱之物心无悔吝。有说法者不断其说。起随喜心欢喜踊跃。赞言善哉。劝请说法。若于昼夜。若在僧中。若在佛塔。以菩提心常为先道。起志欲心喜乐诸法。而是菩萨专心志欲。以法等施不期利养。善男子。是为菩萨成就四法。得成杂种庄严之辩。善男子。菩萨成就四法得增胜智。善知分别甚深之法。何等四。顺因缘法知我实性。知入一切众生实性。知生死行。无有来者无有去者。知一切法虚空印相。是为四。善男子。菩萨成就四法。善知诸根。何等四。善知法界门。观诸法门无有障碍。知诸神通。善调伏心无有二行。是为四。善男子。菩萨成就四法。善能解知如应说法。何等四。辩智。度众生智。分别法智。自净其心亦净一切众生之心。是为四。善男子。菩萨成就四法。善知一切众生心行。何等四。智慧超出智无有碍。入于方便。诸有所作终不中悔。能自觉了。是为四。善男子。菩萨成就四法。善知造因所得业报。亦知出过所行无失。何等四。不说断灭亦不说常因。于业报如实而知。如法而现诸法示相。是中无我无我所。知于所作不失果报。是为四。善男子。菩萨成就四法。庄严布施。何等四。庄严于相。庄严于好。无比喻色。无尽封邑及以宝手。是为四。善男子。菩萨成就四法。庄严持戒。何等四。作转轮王而善庄严菩提之心。作释提桓因而善庄严菩提之心。作大梵王而善庄严菩提之心。不堕恶道生人天善处。而善庄严菩提之心。是为四。善男子。菩萨成就四法。庄严忍辱。何等四。出梵音声迦陵频迦声。多人所爱心意悦乐。坚修善法。得金色肤。是为四。善男子。菩萨成就四法。庄严精进得不可坏。何等四。得一切众生无能坏者。为诸众生作不请友。有所为作专志不懈心无疲厌。乐集多闻。坚智庄严。是为四。善男子。菩萨无厌成就四法。庄严于禅何等四。无诸闹乱。无有放逸。无有悭慢。不舍调伏心。是为四。善男子。菩萨成就四法。庄严智慧。何等四。不说我人众生寿命。得无碍辩。善能分别一切句义。于一切法无有疑惑。是为四。善男子。菩萨成就四法。庄严梵道。何等四。在空净处生起慈心。为化众生起于悲心。守护正法起于喜心。生如来智起于舍心。是为四。善男子。菩萨成就四法。不失神通。何等四。入于四禅而不退失。入四空定知于方便。心得自在知一切法。神通游至无量佛刹。是为四。善男子。菩萨成就四法。断诸结使。何等四。内自寂静亦寂静外。善观诸法知如幻化。有大智力。非憍慢力。是为四。善男子。菩萨成就四法度到彼岸。何等四。知于欲流不证离欲。知于有流随意往生。知于见流不舍诸见知无明流不逆缘法。是为四。善男子。菩萨成就四法。能现一切声闻缘觉。及诸众生形色威仪无有别异。何等四。善起如幻三昧。如实而知一切法相。善观五通。自观己身知如幻化。是为四。善男子。菩萨成就四法。观于生死不住涅槃。何等四。诸佛护持。自大悲心。善巧方便。不舍本愿。是为四。善男子。菩萨成就四法。观众生界不动法界。何等四。观自实性解于法性。观众生性不疑智性。观诸众生同涅槃性。是为四。善男子。菩萨成就四法。不退失利观现失利。何等四。善男子。以专志心趣向涅槃。修入生死。专志欲于一切佛法。现为声闻缘觉调伏。是为四。善男子。菩萨成就四法。有大财宝封邑无尽。以方便力现为贫穷无诸财贿。何等四。或现作于转轮大王释梵天王。为化尊胜诸众生故。现作贫穷。为化贫穷诸众生故。见来求者尽舍一切所有财物见大富者。现无尽宝有自在力。是为四。善男子。菩萨成就四法。令有作门入无作门。何等四。说一切行无常。净于智行。得于觉知一切行无我。离于诸见得涅槃法寂智进行。是为四。善男子。菩萨成就四法。善观察诸法。何等四。善净慧眼。得明法眼。佛眼现前。于一切法得灌顶位。是为四。善男子。菩萨成就四法。决定分别一切诸法。何等四。辩智。无滞解了谛智。住四依智。不舍陀罗尼智。是为四。善男子。菩萨成就四法。行于世法不为所污。何等四。观知世法。超出过于世间众生。断除爱恚无所染污。毕竟明净。是为四。善男子。菩萨成就四法。于法自在不观望他。何等四。定得自在。智得自在。慧得自在。方便得自在。是为四。善男子。菩萨成就四法。不离见佛。何等四。自往见佛亦劝众生。自往听法亦劝众生。自发菩提心亦劝众生发菩提心。常不舍离念佛三昧。是为四。善男子。菩萨成就四法。善自调伏无诸恶法。何等四。出世明慧观察智见。显示解脱。善集法忍。断离一切不善法习。是为四。善男子。菩萨成就四法。善为师导而不吝法。何等四。专心利益一切众生。志意坚固无所慊恨。常行教化一切众生。自舍己乐修集智慧。常为一切众生作利成于己利。是为四。善男子。菩萨成就四法。为诸众生作实依止。何等四。舍于己利常求利他。自舍诸乐为诸众生求于法乐。如所闻法为人广说无有疲倦。以法养命不以衣食。是为四。善男子。菩萨成就四法。能转一切诸佛法轮。何等四。得陀罗尼。得无断辩知。入一切众生心行。不观种姓而为说法引入涅槃。是为四。善男子。菩萨成就四法。于一切法得灌顶位。何等四。出过诸行住菩萨行。得无生法忍示现生死。为不退转印之所印入如来印。住第十地善知诸地。是为菩萨成就四法。于一切法得灌顶位。佛说如是诸四法时。三千大千世界六种震动。大光普照。于上空中百千亿天。作天伎乐歌咏赞叹。雨天曼陀罗华。作是叹言如来世尊。无量阿僧祇劫。所集无上正真道法。皆悉于是诸四法中开示显说。若有众生得闻是经。受持读诵兼复书写。于大众中广分别说。当知是人不从小功德来。若有众生闻于如是诸四句法。闻已信解受持读诵。在大众中广为人说。不离菩提心。彼人不久当于人天诸大众中大师子吼。如今如来大师子吼。我等今者。快得善利。得闻如是诸四句法。复能信解演说如是诸四法。时八万四千人天。发阿耨多罗三藐三菩提心。万二千菩萨。得无生法忍。尔时天冠菩萨白言。世尊。菩萨成就几法。佛涅槃后得闻是经。受持读诵兼复书写。于大众中广说显示。佛告天冠菩萨。善男子。菩萨成就八法。佛涅槃后受持读诵书写此经。于大众中广分别说。何等八。志意成就专向菩提。究竟行慈于诸众生无侵害心。住于大悲化诸众生。常求法利乐法欲法求法集法。心无满足如海吞流。放舍身命守护正法。厚种善根集诸福德。发起大愿诸佛护持。降诸魔怨离大众畏。天冠。是为菩萨成就八法。佛涅槃后能得受持读诵书写如是经法。在大众中广为人说。当于演说如是法时。于此三千大千世界。亦复六种震动。坑坎堆埠诸山污秽。江河池流及诸大海。皆不复现。亦不恼触水性众生。尔时三千大千世界。悉平如掌微妙庄严。于此三千大千世界。百岁枯树皆生花叶。倾向于佛。诸生卉树花叶果茂亦倾向佛。此大地上生诸莲花。大如车轮杂色可爱。妙香适意大光普照。遍此三千大千世界。上虚空中有诸天子。不现其形鼓众伎乐。闻是乐音雪山王中香山王中。所有诸天倍出妙香。令此三千大千世界普悉大香。时雪山王香山王中。雨众妙花皆流趣佛。遍满三千大千世界。其余诸树亦悉雨花。于上空中有一宝盖覆万由旬。是大宝盖垂真珠贯铃网庄严。诸铃网中所出音声柔软悦意。有大妙音遍闻三千大千世界。尔时大德舍利弗见是变现。合掌向佛白言。世尊。是何光瑞。有是希有未曾之相。普此三千大千世界。皆悉庄严甚可爱乐。佛告舍利弗。是大树紧那罗王。从香山中与无量紧那罗。无量乾闼婆。无量诸天。无量摩睺罗伽。大众围绕。欲来见佛礼拜供养。是大树紧那罗王。欲来见佛先现此相。语言未久。大树紧那罗王。与无量紧那罗众。无量乾闼婆众。无量天众。无量摩睺罗众。大众围绕。作八万四千伎乐。以净妙歌善和众乐。复有无量百千众生皆悉随从。菩萨神通大力所持。上升虚空普雨众花。来诣佛所到已。及诸侍从顶礼佛足。右绕七匝住世尊前。尔时大树紧那罗王。以己所弹琉璃之琴。阎浮檀金花叶庄严。善净业报之所造作。在如来前善自调琴。及余八万四千伎乐。是大树紧那罗王当弹此琴。鼓众乐时。其音普皆闻此三千大千世界。是琴音声及妙歌声。隐蔽欲界诸天音乐。尔时欲界所有诸天。皆舍音乐来诣佛所。是大树紧那罗王当鼓琴时。三千大千世界所有丛林诸山。谓须弥山王。雪山。目真邻陀山。摩诃目真邻陀山。黑山。及众药草树木丛林。悉皆涌没。涌渐遍涌。等遍涌。动渐遍动。等遍动。震渐遍振。等遍震。犹如有人极为醉酒。前却颠倒不能自持。诸山须弥颇峨涌没亦复如是。大树紧那罗王当鼓琴时。佛大众中人王众等。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释梵护世若人非人。及离欲者。唯除菩萨不退转者。其余一切诸大众等。闻是琴声及诸乐音。各不自安从座起舞。时诸一切声闻大众。闻琴乐音不能堪耐。各从座起。放舍威仪诞貌逸乐。如小儿舞戏不能自持。尔时天冠菩萨。语是一切诸大声闻大迦叶等。汝诸大德已离烦恼。得八解脱见四圣谛。云何今者各舍威仪如彼小儿举身动舞。于时大德诸声闻等答言。善男子。我于是中不得自在。何以故。由是琴音。我等各各不安乐坐。其体动舞不能自持。所有心念不能令住。尔时天冠菩萨。语大德迦叶言。如何耆年少欲知足。修行头陀常乐空静。天人阿修罗敬汝如塔。大德云何不能持身犹小儿舞。云何不护是大众心。大迦叶言。善男子。如旋岚大风吹诸树木药草丛林。彼无有力能自安持。非彼本心之所欲乐。然彼鼓动。不能自持。善男子。今此大树紧那罗王。鼓作琴乐妙歌和顺。诸箫笛音鼓动我心。如旋岚风吹诸树身。不能自持。是善丈夫。誓愿威势福德神力。于诸声闻及诸缘觉。所有威德彼为殊胜。尔时天冠菩萨语大迦叶。汝今观是不退菩萨威德势力。彼琴乐音不能令其动摇惊扬。大德迦叶。谁见如是而当不发无上正真菩提道心。何以故。今有无量智所有威力不如琴声。令如是等大威德人。闻是琴声不能自持。其向大乘不退转者。不能令动。尔时大树紧那罗王。更易调琴。并及八万四千余乐。佛威神力。及大树紧那罗王。宿善根力之所持故。诸琴乐音。说是偈言

  一切诸法向寂静　　如是乃至上中下
  空静寂灭无恼患　　无垢最上今显现
  诸众生等无众生　　过去现在亦复尔
  以音声说令众闻　　是声同等如法界
  诸世界同无世界　　说事犹如虚空相
  无生无增亦无减　　显示虚妄如虚空
  善觉诸佛悉同等　　法界决定无毁坏
  解达施戒及智慧　　一相平等同无相
  诸结寂灭永无结　　妄想于彼生分别
  无内无外亦无中　　从于妄想颠倒有
  若法非法无妄想　　推求诸法无所有
  觉了名色如实性　　彼行于世无染着
  过去未来无边量　　所演说法亦如是
  本际寂灭无尽灭　　无有方所无住处
  以文字故说是法　　而此文字是尽相
  知是文字尽相已　　于一切法无妄想
  持心等持无所持　　彼此不违于法相
  心及数法无有生　　知一切法入平等
  际无际断无所断　　前后及中同叵得
  了知三世平等已　　彼智无边无有量
  世间贪着于名色　　有边无边皆寂静
  了知因缘法相已　　无我众生命妄想
  所起我见永无起　　一切诸法亦无起
  若所起者本无起　　彼常随顺顺法忍
  其性犹如云中电　　一切法如我实性
  我人众生性自空　　入此陀罗尼印相
  随所觉知三脱门　　一相无相等同相
  一切有法无边量　　法法自无有妄想
  以文字说分别法　　若上若中及与下
  文字亦无有妄想　　推求分别真实义
  义及文字共相应　　以音声说无二义
  若知本性常寂静　　彼本际性常自断
  若本际性常自断　　为利世故修诸行
  推求本际无本际　　彼大慈悲最清净
  若大慈悲最清净　　苦乐同等而修行
  亦复无高亦无下　　彼名知利大丈夫
  法眼寂静最寂静　　若见不见常寂静
  亦复无增亦无减　　彼性离作常寂静
  如空中声叵捉持　　虽可闻知不可说
  是演说者及听者　　悉皆不实得自在

当诸琴乐演出是偈法音之时。八千菩萨得无生忍。尔时天冠菩萨白佛言。世尊。如是妙偈从何而出。佛言。善男子。汝今自问大树紧那罗王。彼当答汝。尔时天冠菩萨。问于大树紧那罗王。紧那罗王。如是妙偈从何而出。答言。善男子。从诸众生音声中出。又问。诸众生音声从何而出。答言。善男子。众生音声从虚空出。天冠菩萨问言。紧那罗王。众生音声非口出耶。答言。善男子。是众生音为从身出。为从心出。天冠答言。不从身出。亦不从心。何以故。身痴无知如草木瓦石。心无形色。不可睹见。无有触碍。不可宣说。犹如幻化。大树紧那罗言。善男子。若离身心从何而出。天冠答言。从于思惟出生音声。又问。若无虚空声何由出。天冠答言。若无虚空声终不出。紧那罗言。善男子。是故当知一切音声从虚空出。当知是声即虚空性。闻已便灭。若其灭已同空性住。是故诸法若说不说同虚空性。是故应当不舍空际。如音声分诸法亦尔。若以音声有所说法。而是诸法于音声中求不可得。音声于法求亦叵得。善男子。是故说言。一切诸法不可言说。但以音声名为言说。当知言说为无所说。又以音声名为言说。然是音声本无住处。若无住处则无坚实。则名为实。若其是实则不可坏。若不可坏则无有起。若无有起则无有灭。若无有灭是名清净。若是清净是则白净。若是白净是则无垢。若是无垢是则光明。若是光明则是心性。若是心性。则是出过。若是出过则出过诸相。若出过诸相则是正位。若菩萨在正位。是则名得无生法忍。若得无生法忍一切能忍。亦忍于空亦忍于人。何以故。不离于人名之为空。人即是空忍于无相亦忍于相。何以故。是相实性即是无相。忍于无愿亦忍于愿。何以故。愿实性相即是无愿。一切法性及众生性。一切常灭亦如是忍。何以故。一切众生生死之性犹如幻梦。是名菩萨得无生法忍。不违一切法不逆一切法。若顺此忍则亦忍顺随诸法去。若无去则无来。若无去来知一切法。是常住性如法常住。众生亦尔。若得是处如法随顺如处修行。是名成就无生法忍。一切言说即是音声。为语他故起是音声。是无生法忍无有能说无有能听。何以故是义不可得故。而是法忍非声非说。善男子。如来世尊有大威德。同不可得义。不可得义说于有得

大树紧那罗王所问经卷第一大树紧那罗王所问经卷第二

        姚秦龟兹三藏鸠摩罗什译

尔时天冠菩萨白言。世尊。未曾有也。而是大树紧那罗王。成就如是不思议法。世尊。是紧那罗王。乃能成就如是胜妙神通之力。复能演说甚深法忍。世尊。紧那罗王。于几佛所种诸善根有如是辩。佛言。善男子。假使能数恒河沙等世界星宿。不能数是紧那罗王所事如来应正遍觉。善男子。是人已于尔许佛所修行梵行。集于无上正真之道。是故得有如是辩才。尔时天冠问紧那罗王。汝于尔许无量佛所。种殖无量无边善根。何故不成无上正道。尔时大树紧那罗王。语天冠菩萨。善男子。菩萨摩诃萨有十二无满足法。何等十二。谓供养给事诸佛世尊无有满足。集诸善根无有满足。听集法宝无有满足。修禅解脱无有满足。修观寂法无有满足。流通显法无有满足。教化众生无有满足。守护正法无有满足。不舍阿练若处无有满足。诸波罗蜜庄严佛土无有满足。修习福慧无有满足。集助菩提法无有满足。善男子。是名菩萨十二无满足法。是故菩萨求善根庄严无有满足。尔时大树紧那罗王白言。世尊。我闻菩萨所有三昧。名曰宝住。若有菩萨得是三昧。一切法宝诸功德法自然而得。善哉世尊。唯愿如来。演说于是宝住三昧。菩萨闻已于一切法。而得自在随增长法。尔时佛告大树紧那罗王。如是紧那罗王。有于三昧名曰宝住。汝今善听善思念之。吾今当说如是菩萨宝住三昧。善哉世尊。愿乐欲闻受教而听。佛告大树紧那罗王。若有菩萨欲令佛宝种性不断。法宝种性僧宝种性不断绝者。修集起生八十种宝。何等八十。不忘一切智宝之心。不舍离于志意宝心。不舍修诸善根宝心。不舍坚人寂定宝心。生起一切布施宝心。不悕望报清净宝心。回向菩提故。庄严身宝心。满三善故。庄严口宝心。离四过故。庄严意宝心。舍离无明爱恚见故。持戒不毁不穿不坏不缺宝心。不穿不坏不缺不污戒庄严故。无恼害宝心。于诸众生意平等故。柔忍宝心。能忍难事故。不忧身命清净宝心。净菩提故。无爱恚宝心。无高下故。坚固牢强庄严宝心。无忧虑故。一切所作成就宝心。无慢缓故。坚固念慧进入宝心。能善修集助菩提法故。起禅解脱三昧宝心。得心自在故。集法宝心。集自财故。闻正法已能持宝心。得无畏故。不吝法宝心。心无吝故。不期利养说法宝心。舍离恶欲不望报故。修正念宝心。正流趣故。如所闻法成满宝心。如闻行故。智观宝心。降伏智故。大慈宝心。化众生故。大悲宝心。观众生故。大喜宝心。爱乐法故。大舍宝心。诸法寂故。不厌生死宝心。集诸善根故。化众生宝心。不住自乐故。四摄宝心。为摄法故。起神通宝心。一切神通现变化故。善知识宝心。为闻法故。离恶知识宝心。集善根故。为一切众生正修宝心。如涅槃故。离诸一切结病宝心。入一切众生所志欲故。于一切法生药想宝心。寂诸病故。善修学习无慢宝心。知大人法故。灭憍慢宝心。于诸众生谦卑下故。无幻伪宝心。无谄诳故。和敬宝心。令法久住故。护法宝心。报去来现在诸佛恩故。知恩报恩宝心。亲友究竟故。不望报宝心。无所亲故。常出家宝心。不忘所作故。爱乐宝心。护白净故。圣种少欲知足宝心。集持戒故。庄严一切头陀功德宝心。于诸众生无有过故。少欲知足宝心。慧无足故。独处宝心。身意寂静故。求法无厌宝心。满相好故。庄严集智无厌宝心。断诸一切众生疑故。念佛宝心。不离见佛故。念法宝心。不离闻法故。念僧宝心。不退菩萨僧故。念戒宝心。不舍菩提心故。念舍宝心。舍结使故。念天宝心。系在一生补处菩萨地故。义辩宝心。觉一切义故。法辩宝心。不坏法界故。辞辩宝心。觉了一切诸音声故。乐说辩宝心。悦可一切诸众生故。得陀罗尼宝心。随所闻法不忘失故。依义宝心。知文字实性故。依智宝心。知识如幻故。依了义经宝心。于了义中无违诤故。依法宝心。觉了人实性故。观一切行无常宝心。不住一切三界中故。观一切法无我宝心。我及众生俱无我故。观于涅槃寂静宝心。究竟寂静故。观空无相无愿解脱门宝心。入甘露门故。观一切法无生宝心。得无生法忍故。见一切法如幻如梦如焰如影如响如水月宝心。不住诸见故。顺因缘法宝心。离断常见故。离诸边见垢秽宝心。离于二故。入无二法门宝心。觉一道故。离一切行宝心。至正位故。正观法位宝心。一切法平等故。集助一切菩提法宝心。觉了一切诸佛法故。如是紧那罗王。若有修集如是等法。善修好修正住获得如说修行。是名菩萨宝住三昧。若能如是则便得是宝住三昧。若有菩萨已逮得宝住三昧。无世间宝出世间宝而是菩萨不得自在。紧那罗王。云何世间宝云何出世间宝。紧那罗王。世间宝者。谓人天豪尊。若帝释豪尊。梵天豪尊。护世豪尊。转轮王豪尊。居士豪尊。婆罗门豪尊。长者豪尊。刹利豪尊。虽得如是人天豪尊而不放逸。以不放逸能集一切助菩提法。是名世间宝。何等名为出世间宝。所谓圣慧是出世间。何以故。智慧悉摄出世间法。是故说入般若慧门名出世间。紧那罗王。譬如大海为众流主。如须弥山为众山王。犹如众星月为其主。如诸药草火珠光明日为其最。一切禽兽师子为最。一切民庶王为其最。三十三天帝释为最。诸梵天中梵王为最。如是紧那罗王。所有一切出世间法智慧为首。是故说言般若为诸众经中主。能度诸流是安去道故。是名为炬照结闇故。是名勇健除众怨故。是名医王和众药故。是名为师知诸书故。是名为箭射结的故。是名为力究竟害缠故。是名大象拔结树故。是无违诤悉平等故。是无斗诤无讼诉故。是名不逆善随顺故。是名无嗔究竟尽故。是名善知四圣谛故。是名为念正念处故。是名为正能正断故。是名示现神足力故。是名为戒障诸根故。是名降伏有大力故。是名为觉善觉知故。是名开示示正道故。是名为寂寂静定故。是名为明作慧明故。是名作明离障翳故。是至正处作照明故。是名除断除结尘故。是无波浪度诸流故。是不可见过境界故。是无境界离内外故。是名为空离见岸故。是名无相离觉观故。是名无愿出三界相故。是名一相无有相故。是虚空相无相似故。是害爱慢离魔业故。施无妄想。不依于戒。不住忍辱。不起精进。不染着禅。无言说门。无一切门。方便自造。无我无众生。度到彼岸。集诸善根。无作无作者。过诸作道。紧那罗王。是则名为出世间宝。诸般若宝。是智慧宝。即是宝住三昧之体。若菩萨得宝住三昧。一切众宝皆悉来集。紧那罗王。喻如大海为众流主。集一切宝。一切众宝皆悉来归。于是海中出生诸宝。如是紧那罗王。菩萨得是宝住三昧。为诸一切众生之主集一切宝。一切法宝皆悉归趣。紧那罗王。宝住三昧能集一切诸法之宝。是中不断于三宝种。是宝住三昧。名为集聚诸法之宝

尔时天冠菩萨白言。世尊。是大树紧那罗王。已逮得是宝住三昧耶。佛言。善男子。汝今自问大树紧那罗王。当为汝说。时天冠菩萨。即问大树紧那罗王。紧那罗王。汝今已逮得是菩萨宝住三昧耶。答言。善男子。是三昧中无住无得。是三昧中无有得者。而是三昧非色受想行识。而是三昧。非色可见无声可闻。非是住相非是灭相。无有处相非无相非一相。所言相者。都无有相无能为作。三昧相者。自无有相亦非无相。是三昧相应如是修。善男子。是三昧者等一切法。若等诸法亦等于我。若等于我亦同等于一切众生。是故善男子。是三昧等一切众生。何以故。一切众生即是空相。空相是三昧相。一切众生即是无相相。无相相是三昧相。一切众生即是无愿相。无愿相是三昧相。一切众生及一切法是寂静相。寂静相是三昧相。一切众生是无我相。无我相是三昧相。三昧相者。无能以身触。无能以心触。凡可触法若等不等。一切皆为善调伏故。而演说之。时天冠菩萨即白佛言。希有世尊。是大树紧那罗王。处在如是放逸之中。乃能演说甚深妙法。佛言。善男子。菩萨从慧方便地中。出生示现一切所作。不为一切所作染污。善男子。是大树紧那罗王。以此琴乐诸箫笛音及妙歌音。调伏七十亿紧那罗众令住菩提。三十亿乾闼婆。于无上道而得调伏。其内眷属八万四千住一切智。彼有如是大方便智。善男子。我唱是言。是谓菩萨随所居住在于大处。随是诸处多利众生。善男子。犹如无薪火则不然。如是善男子。菩萨处寂亦复如是。不能炽然教导众生。善男子。如大薪聚火则炽然。善男子。菩萨亦尔。处在多众教导炽然。善男子。是故当知。菩萨住在最豪尊处。随所生处多利众生。天冠菩萨复白佛言。是大树紧那罗王。云何以琴及妙歌声。诸伎乐音教化众生。佛告天冠菩萨。善男子。紧那罗等。乾闼婆等。摩睺罗伽等。好乐音乐。是大树紧那罗王。善自调琴和众伎乐。是紧那罗众。乾闼婆众。摩睺罗众。起大爱乐信解增敬。得是爱乐信解增敬已。于是音中出于佛声法声僧声。不忘菩提心声。施声戒声。忍声进声。禅声慧声。慈声悲声。喜声舍声。念处声。正断声。神足声。根声力声。觉声道声。定声智慧声。禅定解脱三昧之声。无常声苦声。无我声寂声。空声无相声无愿声。无生声。无起声无行声。菩萨法藏所摄法声。陀罗尼金刚句三昧满声。不退转法轮声。一切决定法王声。大海庄严三昧声。一切法流入平等三昧声。等一切法自在三昧声。庄严智慧三昧声。宝住三昧声。宝有三昧声。宝降伏三昧声。宝炬三昧声。娱乐三昧声。莲花庄严三昧声。过莲花三昧声。遍一切处三昧声。一切法白莲花三昧声。增益三昧声。大奋迅三昧声。师子奋迅三昧声。日灯三昧声。无量旋三昧声。前进三昧声。金刚场三昧声。金刚幢三昧声。金刚不坏三昧声。地持三昧声。山灯三昧声。山幢三昧声。宝藏三昧声。宝华三昧声。宝心自在三昧声。观一切众生心三昧声。出增长一切行三昧声。修深坚三昧声。杂辩三昧声。无观三昧声。观一切众生三昧声。游戏三昧声。出一切神通境界三昧声。降魔界三昧声。现一切色三昧声。入一切三昧声。分一切身三昧声。住一切行三昧声。慧灯三昧声。手灯三昧声。观菩提三昧声。过乐辩三昧声。作入一切功德三昧声。善男子。是琴歌音诸伎乐中。出于如是三昧法声。令诸众生受化而去。菩萨摩诃萨。成就如是希有之法。说是大树紧那罗王诸功德行神力之时。以佛力故。有天曼陀罗花聚。令诸大众各散大树紧那罗王。大树紧那罗王。以神通力右手接持。无一花堕地而不在手。尔时大树紧那罗王。即以供散于如来上。当散花时佛神力故。令是众花成一宝盖覆千世界。是宝盖中垂悬无量千万亿数宝真珠贯。一一珠贯出于无量万亿光明。一一光明出宝莲花。杂色妙好妙香适意。诸花台中一切皆现释迦牟尼如来色像结加趺坐。如是诸佛皆赞大树紧那罗王。善哉善哉。紧那罗王。乃能教化无量众生。菩萨应当如是施作。既出世间还来世间教化众生。生死已尽还来受有。得涅槃位还游三界。于是中生教化众生。尔时大树紧那罗王。作如是念。我今当作一一宝盖。覆一一佛上。尔时是王即入三昧。名庄严宝盖。当其入是三昧之时。有妙宝盖一一各覆诸如来上。一切大众右手亦各执持宝盖。以为己用供养于佛。是时大树紧那罗王。复作是念。我今当请释迦如来。及诸菩萨并声闻僧一切大众。至香山中我宫殿。食令无量无边天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。集令听法。我身当供如来给使。令彼众生长夜利益安隐快乐。尔时大树紧那罗王。作是念已。顶礼佛足。合掌白言。唯愿世尊及菩萨众。并声闻僧哀愍我等。至香山王受请七夜。令无量众生增长善根。世尊。我今堪任能为走使。哀愍大树紧那罗王。及菩萨众诸声闻僧。当至香山七日之中怜愍我故。尔时紧那罗王。知佛可已。欢喜踊跃遍满其身。与其夫人男女眷属。作众伎乐供养于佛。礼世尊足右绕三匝。出众而去还至香山。是时大树紧那罗王。于香山中庄严自己所住园林。为供如来。庄严妙地纵广五百由旬。青琉璃地阎浮檀金以为间错。众宝杂色互相映发。是时场上敷百千妙座。以宝莲花而间错之。敷置百千万亿天衣。复于场上为佛如来敷师子座。高三十二由旬。众宝严饰众宝栏楯而围绕之。张施幢盖竖众宝幢。无量香[土*瓦]烧坚黑沉水。上张缯彩以承尘露。周遍垂悬幡盖缯彩散众天花。于座四面作大宝树杂色妙好。外多众来及自眷属皆悉已集。便为说偈而教授之

  佛出于世时乃值　　犹如优昙钵罗花
  人尊今已出现世　　善好恭敬供养之
  舍慢懈怠及诳伪　　亦离悭贪及幻惑
  皆当舍离诸戏笑　　善好恭敬于导师
  所有众妙适意花　　天中胜花香山花
  皆当聚集置一处　　当以供养于人仙
  所有众妙适意香　　坚黑沉水及栴檀
  当于此间香山中　　烧用供养胜众生
  所有伎乐妙歌音　　紧那罗等所爱乐
  各各善调诸音乐　　当以供养丈夫仙
  幢幡宝盖及妙衣　　柔软善染适天意
  张设以侍供如来　　难值难得无有比
  供养佛已至善处　　或为帝释四天王
  或作梵王自在王　　常作人天中尊王
  形色威德及名称　　眷属侍从及珍宝
  所有言教悉受用　　供养佛已得是利
  诸天欢乐及人乐　　欲于生死常欢乐
  欲得常乐及乐具　　当供养是胜众生
  欲得缘觉声闻乘　　及得最上胜妙乘
  又欲降伏于魔怨　　当作供养供法王

尔时大树紧那罗王。如是教令诸眷属已。即时集聚诸花香鬘。涂香末香。办百味食。已在香山王前。作众音乐。歌诸偈颂。白言时到

  佛能利益施安乐　　和颜喜笑柔软语
  妙华善听人天供　　时到善逝今可来
  十力降伏诸魔力　　降伏他众利益世
  断除诸垢无垢浊　　时到利益世尊来
  乐头陀行无染着　　胜集念慧坚固者
  胜人常出过世间　　欢喜心来作利益
  隐蔽日月珠光明　　释梵天有诸光明
  牟尼光明皆喜乐　　光明自在蔽诸光
  天龙紧那罗歌声　　是声增结不灭欲
  佛音柔软梵音声　　能灭诸结与安乐
  世医游行于十方　　不能治世烦恼病
  十力医王演妙音　　灭诸结使与安乐
  大名大威力无等　　无比无错无浊语
  伏怨寂怨离诸怨　　世尊利益愿时来
  施调施主慧甘露　　持戒行戒尊最胜
  善巧调忍熏修心　　念我故来可爱者
  善具进力相应法　　住于禅定具神通
  慧调伏意惭德备　　持百福相愿时来
  大慈悲心意平等　　离爱欲过无使患
  善知梵道住佛道　　世尊施乐愿时来

尔时世尊。知大树紧那罗王白言时到。告诸比丘。各持衣钵受七夜请差守房人。大树紧那罗王白言时到。是时天冠菩萨作是念言。我今当化作大宝台。令佛世尊及诸菩萨众。大声闻僧安处宝台。坐于莲花庄严座上置之右掌。乘空而往至香山中。天冠菩萨作是念已即入三昧。以三昧力作大宝台。纵广高下各十由旬。杂色好妙四方四柱庄严差别。时宝台中出于百千宝莲花座。复为世尊敷宝莲花师子之座。上高七仞。尔时天冠菩萨。化作宝台及花座已自言。世尊。愿就宝台坐师子座。及诸菩萨声闻大众怜愍我故。世尊。我今当以如是宝台置于右掌着香山中。尔时世尊愍天冠菩萨。即升宝台就师子座。诸菩萨众及声闻僧次第而坐。时天冠菩萨。即擎宝台置右掌中。上升虚空往赴香山。尔时欲界诸天。色界诸天。见天冠菩萨作是神变。欢喜踊跃生希有心。为供养佛及天冠菩萨故。持花香鬘涂香末香。作众伎乐来诣宝台。在虚空中供养于佛。乃至香山。尔时大树紧那罗王。遥见如来坐宝台中从空而来。见己与己眷属八万四千诸紧那罗等。持香花鬘末香涂香。作于八万四千伎乐。以清妙歌善和众乐往迎如来。到已及诸眷属顶礼佛足。以所赍持诸花香鬘涂香末香。供养佛已引前而去。尔时世尊知已至彼。与诸菩萨大声闻僧。释梵护世及诸大众。诣大树紧那罗王所。庄严道场坐所敷座。尔时大树紧那罗王。语释梵护世及诸天子诸大德等。可前就坐所。为如来施设饮食当共同甘。尔时紧那罗王。与诸妻子男女眷属。手自斟酌敬意奉食。种种甘美杂味具足。从于菩萨善根所生。供养如来菩萨声闻一切大众悉皆充足。既充足已。紧那罗王。知各洗钵澡手已毕。与己眷属于如来前。次第而坐欲得闻法。尔时世尊。为紧那罗王及诸大众。演说妙法示教利喜。尔时世尊。即为演说如是妙法。紧那罗王。菩萨有三十二法净檀波罗蜜。何等三十二。紧那罗王。菩萨不忘菩提之心。而为先导而行布施。不赞下乘而行布施。诸所为者无伤毁心而行布施。有来求者无侵害心而行布施。又所请者起福田想而行布施。诸所诣者起于师想起善知识想而行布施。舍内悭结而行布施。无所贪惜欢喜踊跃而行布施。申手正直善好放舍无所期为而行布施。生增上心不生下心而行布施。不生恶处而行布施。不望果报无所悕望而行布施。欲于佛法而行布施。心无恼热而行布施。以摄为首而行布施。我当教导化诸众生而行布施。我当护法而行布施。我当顺用如来言教而行布施。我应当作降魔伴党而行布施。我宜应当正觉菩提而行布施。我应当作善丈夫业而行布施。我应当离饿鬼恶道而行布施。我应当集修舍心因而行布施。我当获得大财封邑摄取他人而行布施。我应当行和敬之法而行布施。我当不离得善知识而行布施。我应当于一切众生无嗔害眼而行布施。我应当以布施善根向无上道而行布施。我应当学余菩萨舍而行布施。我宜应当庄严相好而行布施。我宜应当净佛国土而行布施。紧那罗王。是为菩萨三十二法净檀波罗蜜。紧那罗王。菩萨复有三十二法净尸波罗蜜。善自净身是名为戒净贪嗔痴故。善自净口是名为戒。不自欺诳佛及诸天是无虚相故。善自净心是名为戒离无明贪嗔邪见故。净十善业是名为戒生人天故。不忘菩提心是名为戒不贪余乘故。志意清净是名为戒舍幻伪故。称赞贤圣是名为戒勤摄非圣故。以慈为首是名为戒于诸众生心平等故。修大悲心是名为戒趣向教化诸众生故。善好等学是名为戒毕竟无缺故。惭愧所摄是名为戒怖畏恶道故。无有穿漏是名为戒不中舍故。无有瑕疵是名为戒究竟白法故。自己自在是名为戒至余佛土故。尊重豪贵是名为戒智者所赞故。能超出过是名为戒离恶道故。善安止住是名为戒一切安乐悉具足故。诸佛所赞是名为戒是佛戒故。不自慢缓是名为戒坚实救拔世间人故。不自高毁他是名为戒善弃舍故。修行弃舍是名为戒离诸烦恼故。自己修行是名为戒一切助道菩提法故。作于欢喜是名为戒离爱贪故。善摄取他是名为戒随如说故。调伏出家是名为戒舍离一切家系缚故。坚欲修行是名为戒欲乐法故。决定少欲及与知足是名为戒依圣种故。乐修头陀是名为戒欲舍一切诸恶法故。无著相应是名为戒观无众生故。随顺不违是名为戒顺缘法故。离一切见是名为戒离断常故。紧那罗王。是为菩萨三十二法净尸波罗蜜。紧那罗王。菩萨复有三十二法净忍波罗蜜。何等三十二。不坚着身是名知忍。不住寿命是名知忍。无侵害心是名知忍。堪耐恶言是名知忍。悲于下劣是名知忍。不轻未学是名知忍。有大势力能苦切他而不为之是名知忍。节节支解不起嗔恚是名知忍。无有粗涩是名知忍。不生嗔害是名知忍。无不与语是名知忍。有于志意是名知忍。其心无浊是名知忍。无娆乱心是名知忍。护他人心是名知忍。以财利益是名知忍。知觉大悲是名知忍。灭除憍慢是名知忍。谦下一切诸众生等是名知忍。不增炽然是名知忍。乐于寂静是名知忍。闲晏无为是名知忍。自观己过是名知忍。他人有缺不见其过是名知忍。如法财封是名知忍。有于信财是名知忍。心无热恼是名知忍。意念安乐是名知忍。先意问讯无有嗔面是名知忍。顺甚深法是名知忍。顺三脱门是名知忍。解无生无起是名知忍于无生法忍。紧那罗王。是为菩萨三十二法净忍波罗蜜。紧那罗王。复有三十二法净进波罗蜜。何等三十二。紧那罗王。菩萨不断佛种行进波罗蜜。不断僧种行进波罗蜜。受无量生死行进波罗蜜。集无量善根行进波罗蜜。供养给事无量诸佛行进波罗蜜。为欲摄持无量闻故行进波罗蜜。为欲教导无量诸众生故行进波罗蜜。欲以妙说悦可一切诸众生故行进波罗蜜。为令一切众生逆流故行进波罗蜜。为诸众生当设何宜行进波罗蜜。舍一切所有行进波罗蜜。护一切戒无有毁缺行进波罗蜜。一切柔和忍力无恚行进波罗蜜。出过一切所作事故行进波罗蜜。欲起一切禅定解脱诸三昧故行进波罗蜜。满无量智故行进波罗蜜。欲以一切诸佛国土所有庄严严己佛土故行进波罗蜜。大力坚固越到彼岸故行进波罗蜜。降伏一切诸魔场故行进波罗蜜。降伏一切外道论故行进波罗蜜。具佛十力无畏法故行进波罗蜜。庄严身口意故行进波罗蜜。能办众事无休息故行进波罗蜜。心无怯弱故行进波罗蜜。其心勇健故行进波罗蜜。不共一切烦恼结住故行进波罗蜜。摧伏一切诸烦恼故行进波罗蜜。灭一切结故行进波罗蜜。度诸流故行进波罗蜜。脱未脱者安未安者度未度者故行进波罗蜜。集百福德庄严相故行进波罗蜜。守护一切佛正法故行进波罗蜜。神通遍至一切佛刹。供养礼拜右绕恭敬于诸佛故行进波罗蜜。此诸精进从寂静生。身心寂静住。无出无入。无上无下。为于无生无起所摄。紧那罗王。是为菩萨有三十二法净进波罗蜜。紧那罗王。菩萨复有三十二法净禅波罗蜜。何等三十二法。所谓念净。慧净。进净。惭净。坚实净。心体性净。不忘菩提心净。功德根净。无所依净。我我所净。起神通净。身寂静净。修治心净。内寂静净。外威仪净。断诸见着净。观无我无众生无人无寿者无丈夫净。不住三界净。助菩提法现前净。悲观众生净。除智障净。智慧超出净。不违因果净。决定法忍净。修行无常苦空法净。转方便净。方便摄净。近道场净。不悕望声闻缘觉乘净。满足无漏净。心不散乱得佛定净。观众生心如应说净。紧那罗王。是为菩萨三十二法净禅波罗蜜。紧那罗王。菩萨复有三十二法净般若波罗蜜。何等三十二。求集多闻无有厌足。善巧思惟分别诸法。以己智慧觉了诸法。善分别阴善分别界趣法界故。善于诸入知分别故。善于缘法知因住故。善于诸谛知解灭故。知于正位不入正位故。观察无起起自心故。知诸法无生本际净故。知诸一切众生无我离倒见故。知一切法同是一法本际离欲故。知诸世界是一世界同虚空故。知一切佛同是一佛入不思议法界故。善知分别一切章句善文字故。知无碍辩广演说法悦可一切诸众生故。知陀罗尼无忘失故。知诸魔业教化诸魔向菩提故。观知诸法如幻住于分别有差别故。解知诸法如电水月梦影响法诸法究竟无成就故。觉知一切众生心性本自净故。善分别观生死涅槃善学方便故。善知解空无相无愿示解脱门故。知一切法本性寂静本无缚碍故。知一切法离障得明害无明闇故。善知于智施慧光明为欲解脱一切众生演说法故。知一切法无去来故。知所作业不相违故。知示众生示生死故。得成四辩解义法辞乐说辩故。所说无错法无不空。自己寂静调顺解真知于涅槃。智慧趣向诸佛智慧。守护法城持一切法。得受记地所作究竟。住不退转菩萨之地。紧那罗王。是为菩萨三十二法净般若波罗蜜。紧那罗王。菩萨复有三十二法净方便波罗蜜。何等三十二。观察众生自无众恶。有无量福而不休息。若有少福亦不休止。为化众生而行惠施不求福田。于诸众生起福田想不望果报。教化下劣现为下劣。教诸众生护持口业。现女人像化诸年少。现作童子化诸童女。现一切色不违众生。自无憍现现作憍恣。为化憍恣诸众生故示现狂乱。随众所解而为说法。百岁持戒为化一人放舍此戒所有一切娱乐之具。而共同之摄令入法。自住头陀。为不活畏诸众生故现不活畏。示现一切外道法中修出家行不呵佛法。现为淫女。若在王宫现妙女身。为化悭着淫欲众生。于大众中多人集处现众伎术。或现箫笛琴瑟鼓贝常为第一。于是众中歌舞戏笑。皆出法音现众伎术。随诸众生所喜乐者。为教化故而示现之。现神通力施众生财然后说法。失财众生为现宝藏然后说法。有诸众生忧箭所逼。随其所宜而为示现然后说法。若长者居士及诸小王。内宫妇女忧无子息。为欲化导令其欢喜现为其子。于大伴中作大伴主。将诸人众至空旷野。粮食乏尽求索无所。以神通力化作饮食令充足已。如应说法令不退转于无上道。若有众生从生而盲群相随逐。若一若二若三若四。乃至一十一百。若千二千乃至十千。于彼众前现为盲人现极贫穷。从外乞求给施诸盲。令其得眼睹见诸色。随应说法使不退转于无上道。若复有诸多千众生。造众过罪为王所系。菩萨为脱是诸众生牢狱系闭。现为罪人同入是中。以神通力。悉解杻械。施与衣裳充足饮食。若为说法令不退转于无上道。若有众生犯罪应死。为教化故化作化人。代彼罪人令其全命得无忧虑。慰喻令喜而为说法。毕定住于无上正道。若有众生诤诸财利。奴婢畜生舍宅田地。共相挝打斗诤讼诉。以方便力现大财宝。酬报是人令两和合。然后说法令住菩提行。方便菩萨现作聋盲喑哑形残丑陋之身。舍己妙形同作彼像。化众生故。或复现作外道导师。在远而去住赞叹三宝。冀望佛种故。方便菩萨舍诸禅定生于欲界化众生故。或复现为诸无学人。悕望得乐示现涅槃。倍勤精进修诸法行。方便菩萨示现修行。获得正位现入涅槃。而甫修行于胜妙行。方便菩萨为未得正位欲涅槃者。于是人前现如来像。为令其人住菩提故。紧那罗王。是为菩萨三十二法具方便波罗蜜。说是诸波罗蜜时。大树紧那罗王诸眷属中。九十万六千众生。发于无上正真道心。如来众中八千菩萨。得无生法忍。大树紧那罗王。得智灯三昧。是时大树紧那罗王。从佛闻法示教利喜已。欢喜踊跃得未曾有。以无价衣供上世尊。菩萨声闻各各施衣。以所住园林及中所有一切奉施供佛如来。尔时大树紧那罗王。有八千子。以众宝花庄严。八千微妙盖以奉供如来。当奉盖时佛神力故。令诸宝盖在虚空中。合为一盖覆百由旬时紧那罗王八千诸子。见佛神力欢喜踊跃。得未曾有专心志意。发阿耨多罗三藐三菩提心。坚不退转。各发心已白言。世尊。愿与我等助菩提法。我等闻已当修行之

大树紧那罗王所问经卷第二大树紧那罗王所问经卷第三

        姚秦龟兹三藏鸠摩罗什译

尔时世尊。知紧那罗王诸子之心所欲乐已。上升虚空高七多罗树。放大光明。是光遍照于此三千大千世界。欲界诸天所有伎乐。乾闼婆紧那罗等所有伎乐。不鼓自鸣出微妙音。香山王中所有树木。亦皆悉出微妙乐音。尔时世尊。复于身上诸毛孔中。各放无量万亿光明。一一光端各有莲花一一花中各有菩萨。三十二相而自庄严坐花台中。于时世尊以神通力。令诸伎乐演出智偈问诸所疑。令诸花台所有菩萨。以一一偈。答其所问

  云何而发起　　无上菩提心
  终不忘此心　　乃至觉菩提
  专至心成就　　为诸众生故
  起大悲庄严　　不忘菩提心
  彼志意云何　　彼当云何行
  所说大悲心　　云何生起是
  志意无谄伪　　所修行无诈
  住众生涅槃　　彼大悲如是
  云何行于施　　施已心无热
  亦不悕望报　　回向于菩提
  所施一切舍　　彼施已无悔
  趣向菩提道　　是不望果报
  云何住于戒　　不生于戒慢
  救于毁禁者　　大乘无有上
  戒是菩提心　　空无不起慢
  起于大慈心　　救诸毁禁者
  云何忍众生　　骂詈及呵咥
  心终不起嗔　　倍增生欢喜
  我为众生医　　疗治众病患
  若闻恶言已　　不起于嗔恚
  云何彼行进　　云何修集行
  云何心无倦　　修于菩提行
  精进护众生　　护法常勤进
  善根悉充足　　彼心无疲倦
  云何修正念　　勇健胜进行
  云何修禅定　　心无有驰散
  无有驰想念　　慧无有谄伪
  以方便行禅　　彼心无驰散
  云何得智慧　　云何见正直
  云何作决定　　云何分别法
  修闻增智慧　　本习正直心
  决定行法施　　随义而修行
  云何彼求闻　　云何得多闻
  云何闻如说　　大人云何去
  彼恭敬故听　　习近多闻者
  说不为财利　　大人如是去
  云何彼行慈　　云何行大悲
  喜舍悉成就　　云何住梵道
  慈心悉平等　　大悲无疲倦
  随喜名为喜　　是能至梵道
  云何得见佛　　见已生信心
  云何彼闻法　　云何除断疑
  修行念于佛　　得见世导师
  信心得具足　　闻法已无疑
  云何福庄严　　云何智庄严
  若定及与慧　　彼云何庄严
  庄严福无厌　　学问庄严智
  心寂名为定　　知法名为智
  云何彼行处　　居住止何相
  彼行处云何　　彼云何修行
  彼行法空处　　舍是彼岸句
  彼行住四禅　　修行脱众生
  云何是魔业　　佛正业云何
  造作何等业　　得于菩提护
  下乘为魔业　　大乘为胜道
  舍离一切恶　　得于菩提护
  云何近善友　　恶友何等相
  云何平等去　　舍离于邪见
  若赞菩提道　　善亲近彼人
  菩提心善净　　舍离恶知识
  知诸业行已　　修行正直见
  舍离邪相应　　此不失正见
  云何护正法　　及教化众生
  彼方便云何　　能得成菩提
  精进护正法　　方便能教化
  舍离二边流　　能得胜菩提
  云何作智业　　云何适意业
  云何速受教　　常恭敬右绕
  无诤是智业　　不起于诤讼
  口柔软善语　　恭敬而右绕
  道是何等相　　云何是非道
  云何能安彼　　叵思众住道
  六度为正道　　下乘为非道
  学方便智已　　令众生住道
  云何得大富　　云何获大利
  宝藏为何在　　云何满众生
  七财为大富　　寂静为大利
  陀罗尼宝藏　　辩说令充满
  彼父母是谁　　亲族何等相
  侍从有何相　　严饰智慧者
  慧母度彼岸　　助道法亲族
  诸善根侍从　　庄严于智者
  解法无我已　　慈心普遍世
  无我及与慈　　是义云何等
  若解知于空　　彼自了无我
  是为最上慈　　今世知于空
  未来无有来　　诸行性如是
  业报亦如是　　云何而有生
  第一义无是　　亦无有去者
  入于世谛道　　说业及业报
  若空与无相　　及无愿解脱
  一相同无相　　云何而生道
  空即是无相　　以无相故得
  一相同一义　　故说解脱门
  云何观于空　　云何观众生
  空及与众生　　云何而得生
  智慧观于空　　方便观众生
  大悲以教化　　趣向于涅槃
  无生无有起　　一切法如是
  云何生诸行　　应当解此义
  无生与无灭　　是智所行处
  从于誓愿生　　此方便所建
  云何得授记　　云何不退转
  云何忍所缘　　云何得决定
  住平等授记　　法界不退转
  无生是忍缘　　知法得决定
  道场何所场　　菩提何等相
  谁名为如来　　云何佛得明
  虚空名道场　　菩提虚空相
  不依于身心　　如如名如来

尔时大树紧那罗王诸子。闻说如是法已。得柔顺法忍。各各以自所著璎珞。供上如来而作是言。世尊。今我等为佛出世。我等今日乃得闻是甚深之法。希有世尊乃能令诸伎乐音中说偈问疑。令菩萨像答其所问。能断一切诸大众疑。我等闻已得大法明。世尊。是谁所持。时佛答言。诸贤士等当知皆是如来之力。佛力如是不可思议。尔时大树紧那罗王子白言。世尊。愿令一切诸众生等得如是力。尔时大树紧那罗王。夫人婇女八万四千。其手各各持真珠贯。往世尊所。到已头顶敬礼佛足。各以珠贯供散佛上。当其散时佛神力故。于虚空中化成八万四千真珠大台。四方四柱庄校分明。诸宝台中各有床座众宝璎珞百千天衣。是诸座上各有如来结加趺坐。三十二相八十种好而自庄严。尔时紧那罗王。八万四千诸夫人等。见佛神力欢喜踊跃得未曾有。皆以深心发阿耨多罗三藐三菩提心。得不退转。既发心已欢喜踊跃。皆共同声以偈歌咏赞叹如来

  最胜无上应供养　　其所利益叵思议
  善学利益调伏法　　我今顶礼于胜人
  离贪嗔痴及谄伪　　离烦恼习无畏声
  从大宝藏开示法　　稽首赞礼离欲尊
  五眼清净无结垢　　善能降伏诸怨敌
  不染三有如莲花　　得到彼岸我顶礼
  能与世间明慧眼　　能蔽日月诸光明
  出生转轮圣王种　　持于轮相我赞礼
  心常不染着诸色　　导师作归作救护
  无与尊等况有胜　　妙音演说我顶礼
  于利无利等无著　　悉知一切诸世法
  堕爱网者令解脱　　导师世尊我赞礼
  常调伏心住禅定　　烧诸结使住十方
  演说法施非食施　　无上福田我顶礼
  所说微妙具相好　　弃舍远离于左道
  语声柔软如雷音　　稽首超过于三界
  人尊已离燋热恼　　神通游至无量土
  造坚牢船度世间　　我稽首礼赞如来
  世尊演说信及进　　度脱世间诸结碍
  声闻所有六通行　　离于六道稽首赞
  我今稽首金山色　　稽首调伏寂定根
  我今稽首满月面　　稽首侍德人中上
  摧伏一切众生结　　超度四流难度河
  我等今者归命是　　调根世尊我敬礼
  尊本世时大布施　　施乞求者心欢喜
  最妙珍爱悉施他　　健施善断我顶礼
  见诸痴慢醉众生　　善知是等所造因
  得道最胜无有上　　尊善导引安是处
  阴界本性常空寂　　诸结无实虚伪有
  导师断世诸疑悔　　时语世尊我赞礼
  常住实法诸三昧　　于法自在到彼岸
  智慧调御最无上　　我稽首礼大商主
  离于幻伪诸欺诳　　大力降伏诸魔军
  明智善道人中上　　犹大猛风无碍着
  尽诸流底到彼岸　　人尊宝藏无穷尽
  如恒河沙诸如来　　尊本行时常供养
  得于世中不动摇　　离爱过患到彼岸
  亲近诸佛住善处　　是故敬礼人中上
  弃生老病死畏怖　　忆念千亿本生处
  极大爱网甚可畏　　慧日光照令枯干
  导师独觉悟诸法　　手足轮有吉祥相
  吉祥奉施柔软草　　吉祥世尊我顶礼
  自在超出陀罗尼　　常以法施非财施
  仁尊击于大法鼓　　法王世尊我赞礼
  从释王种中出生　　诸根常寂心亦寂
  三有导师常寂灭　　寂静心者我赞礼
  魔王执持利剑来　　及诸魔众树王下
  不能令尊一毛竖　　不动如山稽首赞
  人尊到彼精进岸　　为诸众生荷忍苦
  生死都尽不受有　　说忍世尊我赞礼
  得大势力无倾动　　善住无畏处非处
  安无量众住菩提　　世尊善住我赞礼
  知诸有为不坚牢　　舍离眷属行出家
  三有知最无有上　　智到彼岸我赞礼
  众生苦恼无救护　　以三宝法充足之
  安置住于无难道　　实救世尊我顶礼
  尊修智力知诸根　　破坏恶魔诸军众
  所说音声最尊妙　　善修诸根我赞礼
  听闻正法欲为根　　复以此欲欲菩提
  平等普阴不择亲　　实覆世者我赞礼
  善逝自觉了诸法　　自转无上圣法轮
  知诸行相犹如梦　　令诸众生识真实

尔时大树紧那罗王诸夫人等。偈赞佛已白言。世尊。我等皆发无上道心。终不以是女人之身成阿耨多罗三藐三菩提。善哉世尊。愿为我等如应说法。令我等辈转舍女身得男子身。疾成无上正真之道。尔时世尊。语紧那罗王诸夫人等。诸姊谛听善思念之。吾当演说转舍女身成男子身。疾得无上正真之道。善哉世尊。受教而听。佛言。诸姊。女人成就于一法行。舍女人形得男子身。疾得无上正真之道。何等为一。谓菩提心。一切智心同为一心。一切三界最胜之心。不忘一切善根庄严。诸姊。是为女人成就一法。转舍女身得男子身。疾成无上正真之道。复次诸姊。女人成就二法。转舍女身得男子身。疾成无上正真之道。何等二。谓亲近佛非事余天。离于邪见。是为二。转舍女身乃至疾成无上正真之道。复次诸姊。女人成就三法。转舍女身得成男子。何等三。所谓身戒口戒意戒。是为三。复次诸姊。女人成就四法。转女人身得成男子。何等四。谓无为心而行布施。不以诈伪修持于戒。以恭敬意趣向贤圣。听受正法。是为四。复次诸姊。女人成就五法。转女人身得成男子。何等五。谓爱法乐法。欲法听法。既闻法已正念观察。秽厌女身常喜欲得成男子身。是为五。复次诸姊。女人成就六法。转女人身得男子身。何等六。谓速疾柔软质直无伪无幻无诈正直之心。是为六。复次诸姊。女人成就七法。转女人身得成男子。何等七。所谓念佛欲得佛身故。常念正法欲得佛法故。常恒念僧自得僧故。常恒念戒誓愿净故。常恒念舍舍诸烦恼故。常恒念天明了菩提心故。观诸众生欢喜心故。是为七。复次诸姊。女人成就八法转女人身成男子身。何等八。不贪着食。不贪饮宴。不贪丈夫。不贪末香涂香。不贪游观园林。不贪戏笑。不贪歌音及诸伎乐。不贪舞戏。不贪交酒会乐。是为八。复次诸姊。女人成就九法。转女人身得男子身。何等九。不说有我不说有众生。不说有寿命及人丈夫。不说断见。不说常见。不著有见。不着无见。善解因缘法。是为九。复次诸姊。女人成就十法。转女人身得男子身。疾得阿耨多罗三藐三菩提。何等十。于诸众生修行慈心。于他财封不生贪爱。不思念他男子之人。失命因缘终不妄语。不作两舌。不粗恶语。不无义语。不起无明。不为嗔牵。有正直见依于业报。诸姊。是为女人成就十法转女人身得男子身。疾得阿耨多罗三藐三菩提。复次诸姊。女人应当观察深法。观色如水沫。不贪醉色。观受如泡。于乐受中不生贪着。于苦受中而不舍离。于不苦不乐受中不生痴结。观想如焰。是中不起男想女想。观行如芭蕉。解知诸行无有坚实。如是观已。不住诸法不起想着。观识如幻。解知心识如幻人来。如是知已。于一切法都无所染。观知此身地水火风四大和合。诸大所成假多为身。犹如草木墙壁瓦砾。是身如影。无我众生。无命无人。无有丈夫。因业所作而自回转。诸界妄想犹如空聚。如实观眼唯是肉段其性空寂。如是正观耳鼻舌身意性空寂。解身如镜像解知言说犹如响声。观心如幻。如是诸姊。女人观察如是诸法。速转女身成男子身。疾得阿耨多罗三藐三菩提。是时大树紧那罗王夫人婇女。闻佛说此转女身法。闻此法门欢喜踊跃得未曾有。顶礼佛足至心不起。是时世尊。知紧那罗王诸夫人等心所念已。即便微笑。佛之常法若微笑时。若干百千青黄赤白红紫等光从面门出。遍照无量无边世界。上至梵世蔽日月光。还来在于佛前而住。绕佛三匝从顶上入。尔时大德阿难。即从坐起正衣服。偏袒右肩右膝着地。合掌向佛而说偈言

  我问无垢喜见面　　我问无垢特威德
  我问善能断诸疑　　为何缘故而见笑
  我问持净最妙色　　我问能利益世间
  我问人天中最上　　为哀念谁而现笑
  我问乐施善调伏　　我问乐持清净戒
  我问乐忍得忍力　　何所利故而现笑
  我问住于精进力　　我问住禅具神通
  我问其智等虚空　　无等何缘而现笑
  我问善逝大慈心　　我问大悲哀世间
  我问乐喜及大舍　　以何因缘而现笑
  我问度到三垢边　　我问无垢净三眼
  我问常乐三脱门　　以何缘故而现笑
  我问能摧伏他众　　我问能说甘露法
  我问能闇蔽诸魔　　大悲愿说笑因缘
  我问能持胜十力　　我问犹如金山色
  我问得到功德顶　　为何利益而现笑

尔时佛告大德阿难。汝今见是大树紧那罗王诸夫人不。今于我所种善根已。志诚发于阿耨多罗三藐三菩提心。欲转女身取男子身顶礼我足。阿难白言。已见。世尊。佛告阿难。紧那罗王诸夫人等。以此志诚殖诸善根。于此命终舍女人身。得成男子生兜率天。与弥勒菩萨。共守护我无量阿僧祇劫。所集无上正真道法。弥勒成佛复当供养。如是次第贤劫千佛皆悉供养。渐次满足助菩提法。是大树紧那罗王得成佛时。是诸女等当生其国。彼佛如来当授其记。尔时大树紧那罗王白言。世尊。今佛世尊。已为我等大作佛事。除净恶道安住善道示菩提道。住于智慧大宝之藏。成办一切出世善根说助成就波罗蜜伴。示善方便劝菩提心闻法充足。得示教利喜爱乐深法。悉得安住不退转地。世尊。我等今者。当作知恩非不知恩。世尊。我等今者。若以肉血髓脑尚不报恩。况余珍宝。尔时会中有余菩萨。作如是念。是大树紧那罗王。几时当得阿耨多罗三藐三菩提。得成佛已号字何等。其佛国土庄严云何。诸菩萨众以何庄严。所受用物复何相类。尔时世尊。知是菩萨心之所念即便微笑。无量百千种种色光从面门出。普照十方恒河沙等诸佛世界。休息一切众生苦已。遍至天世还来绕佛。满千匝已从顶相入。尔时阿难。即从坐起顶礼佛足。右绕七匝在如来前。合掌住立而说偈言

  我礼善逝未曾见　　如是事相之微笑
  遍照无量亿世界　　十方犹如恒河沙
  帝释梵王及护世　　日月珠火星光明
  人尊光明普隐蔽　　愿说以何因缘笑
  寂灭三恶诸苦恼　　众生离结得欢悦
  人天得乐及余众　　清净众生何缘笑
  谁有人天住大乘　　谁当得证转法轮
  谁为得满上菩提　　勇健放斯净妙光
  法王愿为我断疑　　及余诸天得无疑
  大众欢喜愿欲闻　　为谁故现是微笑

尔时阿难偈问佛已。右绕三匝还复本座。尔时世尊犹如大龙。顾视十方告阿难言。阿难。汝今见是大树紧那罗王作广博供养如来不。阿难白言。已见世尊。佛告阿难。是大树紧那罗王。过六十八百千亿劫已。当得作佛号功德王光明如来应供正遍觉明行足善逝世间解无上土调御丈夫天人师佛世尊。国名无垢月。劫名有宝。阿难。是无垢月世界之地平等如掌。白琉璃为地。犹如月色极净无垢。无诸荆棘瓦砾沙石。有妙宝台住虚空中。诸菩萨等在地经行。时两边有功德王光明如来世尊像现。是诸菩萨见如来像即得是念。一切诸法亦皆如像。若有众生于法有疑即问佛像。问佛像已便能受持得无生忍。一切众生皆依虚空宝台而住。彼佛国土无女人名。其国众生皆悉化生。是国土中无饮食名纯法喜食。彼国土中无有余乘纯一大乘。一切众生决定大乘。彼诸众生无有毁禁及与威仪破正见者。一切众生决定佛法。彼国无魔及与魔天外道尼干诸异道等。不着诸见。乃至不住着于善见。一切众生皆为深行空印所印。彼诸众生人天无别。所受用物皆悉同等。是功德王光明如来寿十中劫。多所利益多所安乐利安天人。多有无量菩萨眷属皆不退转。是功德王光明如来欲涅槃时。授上精进菩萨记言。是上精进菩萨。次于我后当得作佛号大庄严如来乃至佛世尊。于是劫中佛宝法宝僧宝不断。是故此劫名曰有宝。尔时大树紧那罗王。自闻受记欢喜踊跃得未曾有。以大菩萨善根神力。欲令大众发欢喜心增善根故。上升虚空高七多罗树。以佛神力及己言辩。说是偈言

  实性普摄一切法　　其性如空无垢秽
  知于如是妙道已　　是一切佛最长子
  犹如梦中有所见　　无实可见悉虚妄
  知解诸法如梦已　　是于诸行无忧厌
  犹如幻化之所现　　象马车步等兵众
  第一义中无有实　　此阴如幻无坚实
  色之体性如水沫　　诸受犹如水泡现
  其想犹如热时焰　　诸行无实如芭蕉
  三有心意及与识　　如来说是如幻化
  知阴性空无所有　　于诸行中无疲厌
  四大诸界如法界　　诸入喻如空聚落
  如是解知诸法已　　能持诸佛空法藏
  善自调伏于财施　　以空净戒自调伏
  忍性常尽无有相　　精进胜妙常寂灭
  禅性寂静无戏论　　智亦空寂无戏论
  若有能入如是法　　是名为度到彼岸
  慈心无我无众生　　大悲清净如虚空
  大喜大舍悉空寂　　是道梵道常最胜
  是四所摄为最胜　　如来说是能普摄
  此摄所摄永解脱　　彼得摄法之彼岸
  众生无我无众生　　不得寿命及士夫
  六根常自寂静相　　能如是知名菩萨
  无有菩萨有众生　　亦复不生无我慢
  离二无著无戏论　　是名无著实菩萨
  诸法无实犹浮云　　无有来者无去者
  其体常住法界性　　善逝如如而觉了
  诸法非有亦非无　　以因缘故诸法有
  如电暂现寻复灭　　其心常乐如是观
  心行非色不可捉　　世间如是同叵捉
  若知心性本清净　　无有结使诸闇冥
  说身如木如墙壁　　痴无有主如瓦砾
  能如是知本性已　　更不作心依倚身
  口说清净犹如风　　犹如山谷中响声
  知说音声亦如是　　于诸音声不染欲
  住在空虚不堕落　　虚空无住亦无处
  知于诸法如空已　　如是众生住于如
  虚空本无生及烧　　千万亿劫而不烧
  知于诸法如虚空　　彼至百千界离烧
  须弥轮围及诸山　　大城村邑及草木
  能知是等如虚空　　神通远至千亿界
  地大水火及风大　　四大犹之如虚空
  能知此等皆平等　　勇健乘空千亿界
  三界所有诸音声　　胜妙增上及中下
  无量百千亿劫说　　不见本性知所在
  彼胜无有别异相　　虽知不能觉于心
  心意等同入寂静　　诸如来等同于法
  百千万劫修善根　　本为菩萨修行时
  知菩提同一切法　　彼得受记大名称
  诸法境界性自净　　如来境界无有量
  如是知于平等已　　持德如是得授记
  今我无有色受阴　　想思行阴亦如是
  解知菩提得授记　　不受阴记界入记
  其所得忍本空寂　　忍及与尽等无二
  是无量名无生忍　　如是则得于授记
  无有能尽于无尽　　尽问不起一切法
  通达忍已得授记　　无句入句无有相
  实无有数无二边　　无有异作当作实
  若如是者佛授记　　今我性等一切法
  己性无我等空性　　菩提之性犹虚空
  若能如是得授记　　是名邪行非正行
  若以心意而修行　　平等法中行胜行
  是等皆悉在地住　　我今在上空中住
  知住地者不同等　　不着三界智转增
  是故得授无上记

尔时大树紧那罗王。说此偈已从虚空下。顶礼佛足合掌向佛。如是白言。世尊。为我已作佛事。授我满足无上道记。世尊。我于过世所修诸行则为不空。我为不诳所作诸行。尔时大众中。有菩萨摩诃萨。作是念言。是大树紧那罗王。于何佛所初种善根。彼佛如来号字何等。是时天冠菩萨。知诸菩萨心之所念白言。世尊。是大树紧那罗王。于何佛所初种善根发菩提心。彼佛世尊号字何等。尔时佛告天冠菩萨。善男子。乃往过世无量无边阿僧祇劫。复过无量无边阿僧祇劫。彼时有佛。号曰宝聚如来应供正遍觉乃至佛世尊。是佛世界名净庄严。劫名净洁。是宝聚如来应正遍觉。其菩萨众有六十亿。一切皆是无量精进。得陀罗尼。不退无上正真之道。其佛寿命六十亿岁。彼国土中所受用物。皆悉具足琉璃所成。如兜率天饮食丰多。土无余乘纯一大乘。尔时有转轮大王。名尼泯陀罗。四域自在。有四万夫人千子具足。勇健妙色能伏他众。是时尼泯陀罗王。请宝聚如来及菩萨僧。满一亿岁施诸所安。衣服饮食床敷医药一切乐具。作于如是无量供养。供如来已成此善根。及四万夫人并诸千子。复有八万四千众生。同发无上正真道心。发道心已。复更满于一亿岁中。以诸乐具恒常供养宝聚如来。过是后已舍于王位。授最长子名曰净戒。自舍国位。彼佛法中剃除须发以信出家。如是千子。转相禅位各各出家。唯除最小王子名曰觉悲。正法治国不加兵仗。善得自在统领国土。善男子。尔时尼泯陀罗王。及其诸子既出家已。宝聚如来初中及后。所说诸法悉能受持。善男子。汝意云何。谓异人乎勿有疑也。彼转轮王尼泯陀罗。即今大树紧那罗王是。其王诸子。今皆修行于菩萨道善男子是。大树紧那罗王。于彼宝聚如来法中。初发无上菩提心。自是之后。不离见佛闻法供僧。教化众生。而不速疾取于无上正真之道。我今授是无上道记。当得作佛号功德王光明如来。时天冠菩萨白言。世尊。未曾有也。如来智慧不可思议。乃能知于如是久远。佛言如是。善男子。如汝所言。如来知见无量无边。何以故。善男子。过去无量一切众生。如来悉能知彼诸心。如是十方。如是处处。如是所作。若善不善及无记业。如是一切所有心转。如来悉知。若现在起心。若善不善若无记心。如是十方。如是处处。如是所作。如来悉知。如来应正遍觉。所有知见如是无碍。若未来世一切众生当起诸心。如来悉知。说是如来无碍智时三万二千众。生本未发心今始殷重。发阿耨多罗三藐三菩提心

尔时大树紧那罗王。请佛供养及诸菩萨声闻大众七夜已讫。复更以诸所须乐具及其宫殿园林场地悉以奉施。作如是言。愿佛世尊。屈意数来怜愍我故。当大安乐。当大利益。诸乾闼婆紧那罗摩睺罗伽。尔时大树紧那罗王子名无垢眼。以宝珠网奉上如来白言。世尊。我紧那罗耽醉华香。耽醉歌舞。耽醉欢喜。唯愿世尊。当为我等说所入法门。当令我等舍离狂醉。修集菩提助道之法

尔时世尊。告紧那罗王子无垢眼。贤士自尔已去。我当护汝令诸伎乐出六十四。护助菩提妙法之音。何等六十四。所谓演出布施之声。戒声。忍声。进声。禅声。智慧之声。慈声。悲声。喜声。舍声。四摄法声。不忘无上菩提心声。不厌生死声。集善根声。佛声。法声。比丘僧声。念处声。正断声。神足声。根声。力声。觉声。道声。定声。慧声。无常声。苦声。无我声。寂声。无行声。静声。无生声。无起声。如声。法性声。实际声。无我声。无众生声。无命声。无丈夫声无人声。无来声。无去声。无处声。无住声。空声。无相声。无愿声。离声。灭声。无所有声。因缘声。无物声。无聚声。无依声。护正法声。降魔声。善方便声。教化众生声。如幻如化如电水月梦响之声。法界破坏声。如说如作声。集诸善根而不忘失无放逸声。如是贤士当令汝等诸乐音中出如是等六十四种护助菩提道法之声当令汝等得不放逸满助菩提法

大树紧那罗王所问经卷第三大树紧那罗王所问经卷第四

        姚秦龟兹三藏鸠摩罗什译

尔时一切大众得未曾有。合掌礼佛作如是言。希有世尊。如来乃能善护念诸菩萨摩诃萨。以神通力而护持之。佛言。如是如是。如汝所言。如来护念于诸菩萨。何以故。护念诸菩萨。即是护念一切众生。汝诸正士。若佛如来护诸菩萨。即便为护一切众生。何以故。是菩萨为一切众生发大庄严。大庄严已。令无量众生离生死饿。拔出安置令住正道。诸正士。是故汝等我涅槃后。应当守护于诸菩萨。若护菩萨当知则护诸众生已。若菩萨施衣服饮食卧具病药。即是施与一切众生。若以乐具施与菩萨。便为己施诸众生已。何以故。是诸菩萨出息入息。常为一切诸众生故。尔时欲界诸天色界诸天。乾闼婆摩睺罗等。及诸大众。闻佛所说深心随喜。以诸妙花珍宝璎珞种种末香散如来上。尔时大树紧那罗王。作是念言。今者如来及诸菩萨大声闻众将欲还归。以我神力从此而往。作大宝车令佛菩萨声闻大众乘之而去。我及眷属当共牵车。则为具足供养如来。尔时大树紧那罗王作是念已。即以天宝造作宝车。高五由旬纵广正等亦五由旬。众宝间错无量宝树以为庄严。于此车上为佛如来作师子座。庄严校饰上高七刃。敷置无量天诸宝衣。一切菩萨及诸声闻各为设座。其诸天子释梵护世乾闼婆等。为听法者悉为设座。尔时紧那罗王作大宝车及敷诸座已。合掌白言。唯愿世尊及诸大众。就宝车坐怜愍我故。尔时世尊及诸菩萨。声闻大众一切余众。悉坐宝车所敷座上。尔时紧那罗王。以佛神力及己神力。以是宝车置右掌中。上升虚空高七多罗树。紧那罗王八千诸子。及无量乾闼婆紧那罗摩睺罗伽。各以金琐牵挽宝车游空而去。八万四千诸紧那罗。作于八万四千伎乐。在如来前引导而去。以诸偈颂并赞叹佛

  足满八万及四千　　是等紧那罗身形
  清妙歌音和众乐　　赞叹如来实功德
  最胜相好有威德　　最胜妙色众所爱
  常住清净实功德　　世尊有是大功德
  于上虚空侍左右　　无有能见如来顶
  犹如大山坚不动　　有如是身可乐德
  游空自在随所至　　导师有是大神力
  犹如虚空净无垢　　世尊善断脱结使
  阿修罗等及罗刹　　释梵天王及净居
  日月星宿珠火光　　毫相光明悉隐蔽
  智慧力能如大海　　发起众生诸心行
  三明普能照三界　　头顶敬礼世所敬
  摧伏四魔诸结使　　说四圣谛涅槃道
  四神足力无所畏　　如来行步最殊胜
  祥徐进趣无倾动　　常习调心住三昧
  所说微妙悦世间　　亦不依止是言说
  言说柔软善妙音　　远闻无量诸刹土
  若有众生闻是音　　一切安乐生欢喜
  三千世界诸海水　　一毛孔中悉容受
  终不恼触水众生　　其神通力无损减
  三千世界所有山　　悉皆安置一毛中
  往至无量千亿界　　然其身力无损减
  又于无量百千劫　　勤苦无量调伏施
  善修学戒护诸根　　忍辱精进禅慧力
  供养无量亿诸佛　　护持是诸佛所说
  其心终不生疲厌　　大慈大悲利益世
  于无为中不卑下　　于有为中不自高
  犹如大地无倾动　　住世法中如莲花
  谛观察了诸法空　　都无有相犹水月
  如幻如化如水沫　　亦如梦电热炎相
  实性无我无有人　　极净无烧无有主
  犹如虚空净无垢　　一切有物如实性
  一切诸因及与缘　　流转造法无有主
  是能觉了菩提道　　是故号之名为佛
  是诸众生获大利　　若见导师及闻者
  彼终不畏堕恶道　　是人常至于善道
  我等今得供上人　　一切皆供我亦供
  以此回向菩提心　　愿使一切如人尊
  假令能量于虚空　　能以毛滴尽海水
  日月星宿坠虚空　　无有能尽佛功德

尔时世尊乘于宝车。游空而去放金色光。是光遍照于此三千大千世界。王舍大城只阇崛山。光照倍明时王舍城阿阇世王。及其夫人眷属兵众。诸比丘比丘尼。优婆塞优婆斯。婆罗门居士。见光瑞已。持诸香花末香涂香幢幡宝盖及诸伎乐。出王舍城往迎如来。既出城已。诣只阇崛山。遥闻紧那罗所作乐音微妙歌声。遍满只阇崛山之中。尔时大树紧那罗王。以佛神力从于虚空下。大宝车安着只阇崛山之中。尔时世尊从宝车下。诣自住房敷座而坐。时诸菩萨大声闻众亦皆下车。礼如来足次第而坐。尔时阿阇世王。及夫人婇女内外眷属。比丘比丘尼。优婆塞优婆斯。婆罗门居士。各以所持诸供养具供养如来。胡跪合掌问讯。世尊。将无疲耶安善游耶。问讯已毕却坐一面。尔时天冠菩萨白言。世尊。是大树紧那罗王。及紧那罗众。牵如来车乘空来此得几所福。佛言。善男子。是大树紧那罗王。及余眷属发道心者。从今已往当得五通。乃至成佛。从一佛土至一佛土。不离见佛闻法供僧。世世所生常识宿命。得善好辩音声美妙。亦不舍离教化众生。世世所生勤护正法勤化众生。尔时阿阇世王语大树紧那罗王。紧那罗王。快得善利。如来今者叹汝功德。紧那罗王。汝之功德我亦冀望同有少分。时大树紧那罗王语阿阇世王。大王当知。我所有功德。悉施于汝及诸众生。何以故。大王。菩萨所有诸功德事。悉与一切众生共之。何以故。大王。菩萨之法无所悭吝。所有功德悉施众生。其心喜悦无热无恼。大王当知。菩萨以此功德回向于一切智。亦为育养一切众生。何以故。大王。菩萨护念诸众生故。修行菩提为众生依。大王。汝今亦得获大善利。得佛世尊。文殊师利。为善知识亲近听闻。不实无明黑闇翳障。逆罪疑心热恼除灭。得大法明得法明故。无有恼热安隐而住。是故大王。当自克厉成作法器。若闻于法乃至一句。不忘不失名护正法。尔时天冠菩萨白佛言。世尊。菩萨成就几法能为法器。是时佛告天冠菩萨。善男子。菩萨法器有三十二。何等三十二。佛所护持是菩提心器。专心质直是无伪器。增长志意是善根器。修行于道是菩提柱器。正意思念是多闻器。慧是出道器。进是集义器。施是大富器。戒是满愿器。忍是三十二丈夫相器。进是一切佛法之器。禅是练心器。慧是度障器。大慈是等诸众生器。大悲是救拔贫穷器。大喜是喜乐佛法器。大舍是舍离爱恚器。善知识是诸善根器。修进多闻是般若波罗蜜器。出家是离缚碍之器。阿练儿处是少事务无恼乱器。乐于寂静是诸禅定神通之器。四摄法是化众生器。护持诸法是照明器。陀罗尼是闻于一切未闻法器。辩才是断一切疑器。念佛是得见诸佛器。无恼害心是护一切善根之器。空法是断我见之器。因缘是舍诸所珍器。无生法忍是舍诸障碍授记器。缘不退地是无畏器。善男子。是为菩萨三十二法器。说是法时十千众生发阿耨多罗三藐三菩提心。而作是言。世尊。愿使众生得是法器。亦令我等成此法器。如佛所说。尔时世尊告大树紧那罗王。善男子。汝还所止。汝诸眷属或能忧悒。紧那罗王白言。世尊。若其菩萨有忧悒者。是则不名为菩萨也。何以故。世尊。能忍忧悒是名菩萨。世尊。云何菩萨有于忧悒。云何菩萨无有忧悒。佛告紧那罗王。菩萨成就四法则有忧悒应当觉知。何等四。闻有无量无边众生心生惊畏。闻受无量无边生死心生惊畏。闻佛如来无量智慧心生惊畏。闻集无量福德庄严满足相好心生惊畏。紧那罗王。菩萨成就是四法者则生忧悒。紧那罗王。菩萨成就四法心无忧悒。应当觉知。何等四。闻有无量无边众生。我当安置于涅槃道而无忧悒。闻无量生死而不惊畏。修诸善根心无忧悒。闻佛如来无量智已。我当成满如是大智而无忧悒。闻集无量福德庄严成满相好而无忧悒。是为四。紧那罗王。菩萨复成就四法有于忧悒应当觉知。何等四。时时欲证于声闻乘。时时欲证于缘觉乘。法欲灭时舍不护持。不劝他人令住菩提。是为四。紧那罗王。菩萨复成四法无有忧悒。应当觉知。何等四。有逼切苦不舍菩提心。不生声闻缘觉心。宁舍身命不舍正法。乃至百由旬外劝人令发菩提之心。是为四。紧那罗王。菩萨复成就四法则有忧悒。应当觉知。何等四。见来乞者生嗔呵咥。自乐安卧不修多闻。若已闻法不为众说。是为四。紧那罗王。菩萨复成四法无有忧悒。应当觉知。何等四。见乞者已生善知识想无侵害心。不乐自乐常欲乐人。修集多闻无有厌足。所闻持法于大众中广为人说不期利养。是为四。紧那罗王。菩萨复成四法则有忧悒。应当觉知。何等四。不集波罗蜜道。不修摄法。不勤精进教化众生。于少功德自生知足。不修菩萨无量功德。是为四。紧那罗王。菩萨复成四法则无忧悒。应当觉知。何等四。常勤精进修诸波罗蜜如救头然。常勤精进集四摄法。常勤精进教化众生。精进勤修满诸功德。修集菩萨无量功德。是为四。尔时世尊。说是四法已。遣大树紧那罗王。告阿阇世王。大王。汝今闻说菩萨如是四句无忧法不。阿阇世王即白佛言。闻已世尊。是故大王。若诸菩萨行菩提者。不应忧悒。阿阇世王白言。世尊。云何菩萨修菩提行。尔时世尊。为欲成满紧那罗乾闼婆摩睺罗伽等。诸乐音中所出法音。又欲报答阿阇世王所问菩萨修菩提行。而说偈颂以显其义

  若欲修行利益行　　闻于法已如说行
  修行菩提最胜行　　行彼修时无忧悒
  修安乐行为众生　　诸众生中等行慈
  修行菩提最胜行　　彼无若干杂种行
  为诸众生修坚行　　志意清净修行者
  修行菩提最胜行　　彼行终不堕恶道
  修于布施放舍行　　行于一切悉舍行
  修行菩提最胜行　　彼人无有悭吝行
  修行净戒寂静行　　身口清净无垢行
  修行菩提最胜行　　彼终无有毁梵行
  修行忍辱利益行　　离于嗔恚过咎行
  修行菩提最胜行　　彼无嗔恚毒过行
  修行精进力柱行　　于生死中无厌行
  修行菩提最胜行　　彼终无有懈怠行
  修于禅定三昧行　　身心独寂无闹行
  修行菩提最胜行　　彼终无有愦闹行
  修行智慧菩提行　　一切法行亦如是
  修行菩提最胜行　　彼终无有不知行
  修行慈心利益行　　于诸众生胜悲行
  修行菩提最胜行　　彼终无有害他行
  修行空行寂静行　　无相无愿清净行
  修行菩提最胜行　　彼终无有所愿行
  修行真行实谛行　　满一切智具足行
  修行菩提最胜行　　彼终无有障碍行
  修行信行欢喜行　　善念思惟无乱行
  修行菩提最胜行　　彼终无有不信行
  修行禅定解脱行　　获得五通之妙行
  修行菩提最胜行　　彼终无有挂碍行
  修于佛行及法行　　供给僧宝清净行
  修行菩提最胜行　　彼有最上胜实行
  修于法行及空行　　教化一切众生行
  修行菩提最胜行　　彼终无有止住行
  修于因行果报行　　断于一切有边行
  修行菩提最胜行　　彼终无有染着行
  修行净行无垢行　　解脱一切结使行
  修行菩提最胜行　　彼终无有恼热行
  修于安隐解脱行　　施诸众生无畏行
  修于菩提最胜行　　彼有一切满愿行
  修于日行及月行　　犹如莲花无污行
  修行菩提最胜行　　彼为人天所敬礼
  修行释行梵王行　　为满白法之妙行
  修行菩提最胜行　　彼令魔军怖畏行
  修行上行及胜行　　断于贪欲嗔恚行
  修行菩提最胜行　　彼终无有嗔痴行
  修行外道禁戒行　　慧眼清净之妙行
  修行菩提最胜行　　彼终无有妄想行
  修于调伏寂静行　　无有名色狂乱行
  修行菩提最胜行　　彼为人天所敬礼
  修于易行利益行　　断于左道胜妙行
  修行菩提最胜行　　彼人常有智慧利
  修行健行勤进行　　能怖魔军勇猛行
  修行菩提最胜行　　彼人道场无不知
  修显露行无屏行　　得于陀罗尼妙行
  修行菩提最胜行　　彼人不失果报行
  修于王行寂静行　　常一切时出家行
  修行菩提最胜行　　彼有如说修行行
  修于长者及胜行　　行于世间无胜行
  修于方便相应行　　舍于禅乐微妙行
  修行菩提最胜行　　彼终无有恼热行
  修于世行离世行　　欲界色界无色行
  修行菩提最胜行　　彼终无有恐怖行
  修于遍行一切行　　满足诸根善如行
  修行菩提最胜行　　彼智犹若如虚空

说是菩萨诸行法时。五百菩萨得无生法忍。阿阇世王及其眷属。王舍城中婆罗门居士。及紧那罗眷属之中八千众生。发阿耨多罗三藐三菩提心已白言。世尊。我等当于如上所说菩萨所行菩提诸行如说修行。尔时世尊语大树紧那罗王。汝今可去还其所止。尔时大树紧那罗王。及其夫人并诸子息一切眷属。顶礼佛足右绕三匝。悔过世尊。作诸伎乐天雨众华。放大光明地六种动。即便还往诣香山中。尔时释提桓因白言。世尊。是大树紧那罗王。乃能如是真实供佛。真实供法。佛言。憍尸迦。不但于汝名为真实。普胜三千大千世界所有释梵护世天王声闻缘觉。是紧那罗王真实殊胜。何以故。天主。菩萨发心已。胜一切声闻缘觉。憍尸迦。无有能胜于菩萨者。唯除如来。何以故。从于菩萨出生如来。从于如来出生一切声闻缘觉。尔时释提桓因。于如来所闻是语已。涕泣流泪作如是言。我今永为离于大乘。尔时瞿夷天子。语释提桓因。父王天主。如是如是。一切诸行一切诸法。无有覆障从妄想起。不能发生无上正真大道之心。不能悲念一切众生。不能修于大慈之心。父王天主今覆何言。已入正位烧败种子。于此大乘永非其器。瞿夷天子说是语时。三十三天中五百天子。皆发无上正真道心。尔时瞿夷天子白言。世尊。我欲亲见菩萨所行。百千万亿难行苦行。乃至然灯佛所得无生忍。愿佛少说。我等闻已如说修行当得是法

尔时世尊告瞿夷天子。无有菩萨不种善根得无生忍。菩萨多种无量善根。然后乃得无生法忍。瞿夷天子。菩萨成就是四法者得无生法忍。何等四。诸佛平等。诸法平等。世界平等。众生平等。瞿夷。是为菩萨成就四法得无生法忍。复成四法。何等四。玩乐四空。玩乐大悲三解脱门。玩乐方便六波罗蜜。玩乐禅定及五神通。是为四。复成四法。何等四。解知阴性即是菩提。知诸界性集于菩提。信菩提性即是界性。知诸入性集于菩提。以菩提性观于诸入。一切诸法集于菩提。菩提之性即诸法性定无有疑。是为四。复成四法。何等四。知一切法住于实际不动摇故。知一切法住于如中。信三世法等不坏性故。观诸法平等如虚空性故。瞿夷。是为菩萨成就四法得无生法忍。说是法时。五百菩萨得无生法忍。瞿夷天子得于顺忍。尔时世尊将封印此经法。告大德阿难。阿难。汝受持此经。名曰大树紧那罗王入作一切法门行经。大德阿难白言。世尊。我已受持未曾有也。世尊。是经极为甚深微妙。其义决定文辞庄严。世尊。无有余经能胜此经。今此经中无不开示者。世尊。我于目前得法光明不如此经。我今自觉于是经中获得百千万亿功德。世尊。我今以此有限量智入声闻位。闻此经已尚得如是大法光明。况复菩萨摩诃萨成就无量大海法器。无畏大智修集诸法。为诸众生作不请友。无量大智闻如是法得几法门。佛言。阿难。若是三千大千世界。一切所有日月光明。是菩萨等所得法明。一毛孔光悉能隐蔽是诸日月所有光明。阿难。若佛如来一切毛孔悉放光明。是诸光明悉有智慧。何以故。佛诸所有皆智慧故。阿难。如来有此智慧光明。如来以此智慧光明。能知一切众生心行。若有众生闻此经者。皆当得是大慧明照。若书写受持读诵通利。于大众中广为人说。正念思惟如说修行。是人终不离菩提心。教化众生大悲庄严。着大慈铠为除众魔。阿难当知。如是之人定趣道场。尔时阿难白言。世尊。以佛力故。我今已受持此经法。世尊。若有善男子善女人。受持此经读诵书写。于大众中广为人说得几功德。佛言。阿难。若有菩萨善男子善女人。于初日分以满三千大千世界所有七宝。施须陀洹斯陀含阿那含阿罗汉。及诸缘觉乃至诸佛。如是日中日没初中后夜。如上布施满于千岁。阿难。汝意云何。是善男子善女人。所得功德宁为多不。甚多世尊。甚多善逝。世尊。若于一日所得功德无量无边。况复千岁。佛言。阿难。我今唱令是善男子善女人。为得菩提。为化众生。为转法轮。受持是经读诵书写。于大众中广为显示其福为胜。何况复能如说修行。阿难。若于是经受持乃至一四句偈。在大众中广为人说其福为胜。何以故。如是之施名为法施诸施中最。如是之施即是法施。是为胜舍谓舍于法。是名上受谓受于法。是名上持谓持于法。何以故。阿难。施于法已能灭结使。财宝施已增长烦恼。是故菩萨为灭结使当行法施。佛所印可。如是法施则能摄取一切功德。阿难。菩萨法施有三十二功德名称。何等三十二。有正忆念。有于智慧。有于进趣。有离悭结。有少淫欲。有少嗔恚。有少愚痴。降伏自他所有结使。多人爱敬诸天赞叹。诸龙夜叉乾闼婆等常随守护。不空受用人之供养。衣服饮食卧具医药不求而得。名称远闻十方世界诸恶鬼等不得其便。诸佛世尊之所赞誉。守护正法持佛法藏。不堕一切诸恶道中。生于人天不以为难。不离见佛。不离闻法。不离供僧。得识宿命。生净佛土。生生之处诸根具足。得三十二相庄严之身最为上主。种陀罗尼根本种子。作无断辩智因。得智人眷属。集大智因速疾得法。不起不正忆念之心。舍离一切世间财施。得大法藏辩才无尽。阿难。菩萨法施。有是三十二功德名称。尔时释提桓因白佛言。世尊。我等亦当受持此经。世尊。如来涅槃后有法器众生。我要当令得闻此经。令其信解我当守护。何以故。世尊。我等欲得如上功德。尔时世尊。赞释提桓因。善哉善哉。天主。汝今乃能勤守护法作师子吼。天主。汝今以此护法善根随我法在。阿修罗众悉当降伏诸天得胜。何以故。憍尸迦。得见如是无畏法故。谓于诸法无所染着。天主。诸所有畏皆由住着于我见故。天主。若无所著是护正法。尔时娑婆世界主大梵天王白言。世尊。我亦当舍无量禅乐。诣诸城邑聚落郡县流通此法。我亦当往至彼听法。令说法者得坚念力。何以故。从是法中出生无量声闻缘觉释梵护世。尔时四天大王白佛言。世尊。我等四王。是佛声闻当坚守护。于是经法令得久住。我诸眷属若有不信佛此法者摧伏令信。于佛法中勤加精进亲附爱乐。世尊。若有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。有恶心者。若欲降伏当诵此咒。所谓

多罗卑(一)使卑(二)使那卑(三)婆罗卑(四)呼娄(五)摩呵呼娄(六)呼娄呼娄(七)使婆蜘(八)毗婆蜘(九)波囄车陀尼期那呢(十)波迦奢呢(十一)希持希持(十二)毗持(十三)阿车(十四)多车(十五)摩罗使[口*亟]呢伽睺(十六)萨婆[口*皮][口*皮]提(十七)萨婆弥利车[口*皮][口*虫*也]多那(十八)阿那忧多罗萨婆复多那佛陀瞂尼多(十九)四天大王所见咒句(二十)是咒神力诸欲求短悉能降伏(二十一)

尔时世尊告弥勒菩萨天冠菩萨诸善丈夫。我今以此无量千万阿僧祇劫所集难得阿耨多罗三藐三菩提法嘱付汝等。令得久住中无断灭。时弥勒菩萨天冠菩萨白言。世尊。我等于佛般涅槃后。当广流布于此经法。诸有厚种善根菩萨。诸众生等令至其手。使得自在降伏憍慢。能持是经令信欲解。佛涅槃后若有得闻是经法者。受持读诵书写解说。当知皆是弥勒菩萨天冠菩萨神力所持。尔时魔王波旬。来至会中白言。世尊。若为声闻所说诸法。我于是中无一毛竖。今者世尊。演说如是菩萨道法。菩萨印印如来护持一切众生之所归趣。说如是法。我今已为忧箭所中。我今自知便为生老。愿佛世尊执持我手。更莫演说如是极大功德力经。勿令我等重被忧箭。佛告波旬。汝勿愁苦。多有众生在汝境界不信是经。少有众生能信受者。波旬当知。如从大地抓取少土。信甚深法诸众生等如是甚小。如余大地其不信者如是多矣。波旬。其不信者尽是汝许。是故波旬应生欢喜。波旬。众生之界无量无边。说是法时。无量众生住于无上正真道心。九万二千菩萨得无生法忍。八万四千众生远离尘垢得法眼净。八千比丘尽于诸漏心得解脱。时此三千大千世界六种震动。大光普照天雨众花。百千伎乐不鼓自鸣。百千万亿那由他天。欢喜踊跃称赞歌叹我等今于阎浮提中。再见法轮转。世尊。昔在波罗捺国。转正法轮所利众生。今说是经所利众生。是为殊胜。其有众生持是经者。是人不久当转法轮。尔时弥勒菩萨天冠菩萨。大德阿难等白言。世尊。当何名此经。云何受持。佛言。善男子。是经名为大树紧那罗王所问。亦名宣说不思议法品。如是受持。佛说是经已。弥勒菩萨天冠菩萨大德阿难等。一切大众天龙夜叉乾闼婆。闻佛所说皆大欢喜

大树紧那罗王所问经卷第四


大唐新翻密严经

    No. 682 [No. 681]

    大唐新翻密严经序

朕闻西方有圣人焉。演不言之言垂无教之教。启迪权实发披聋瞽。迁其善者不疾而速。阶其益者即圣自凡。击蒙求以娑婆丘陵。示达观以密严世界。匪染净在我实是非游。而楚越生于念中。及缺顿于目下。彼鱼藏鸟逝。其若是乎。钦哉密严迹超三有。量周乎法界相离于极微。非声闻之所闻岂色见之能见。尝洁已主妙允恭付属。是欲泉静识浪。珠清意源穷赖耶能变之端。照自觉湛然之境。深诣心极其唯是经。夫翻译之来抑有由矣。虽方言有异而本质须存。此经梵书并是偈颂。先之译者多作散文。蛇化为龙何必变于鳞介。家成于国宁即改乎姓氏。矧讹异轻重或有异同。再而详悉可为尽善。大兴善寺三藏沙门不空。像教栋梁爱河舟楫。戒珠在握明镜入怀。雪涉云征穷鹿野之真谛。帆飞海宿究马鸣之奥音。声咏八转言善两方。之可窥鉴阙如抑扬了义。诏令集京城义学沙门飞锡等翰林学士柳抗等。详译斯文及护国经等。对执贝多翻诸简牍。凭其本夹依以颂言。大羹之味不遗。清月之魄恒满。岂不美欤岂不美欤。朕词乏清华文非道丽。志流衍于秘赜将布灌于无穷。聊课虚怀序之篇首云尔

大乘密严经卷上

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

    密严道场品第一

如是我闻。一时佛薄伽梵。住于超越欲色无色等想。于一切法自在无碍。神足力通之所游戏密严世界。而此世界非彼外道声闻缘觉所行之境。与诸修习胜瑜伽者。十亿佛刹微尘数等菩萨摩诃萨俱。其名曰摧一切外道异论菩萨摩诃萨。大慧菩萨摩诃萨。一切佛法如实见菩萨摩诃萨。圣观自在菩萨摩诃萨。得大势菩萨摩诃萨神通王菩萨摩诃萨。曼殊室利菩萨摩诃萨。金刚藏菩萨摩诃萨。解脱月菩萨摩诃萨。持进菩萨摩诃萨而为上首。皆超三界心意识境智成身。转于所依成就如幻。首楞严法云三摩地。无量诸佛手灌其顶。处离三有莲华宫

尔时如来应正遍知。从现法乐住自觉圣智甚深境界。微妙奋迅无量众色之所现显三摩地起。出帝雷光妙庄严殿。与诸菩萨入于无垢月藏殿中。升密严场师子之座。世尊坐已观察四方。从眉间珠髻光明庄严。出于无量百千净光。围绕交映成光明网。是光网流照之时。一切佛刹庄严之相分明显现。如一佛刹余诸佛土。严饰细妙同于微尘。密严世界超诸佛国。远离星宿及日月。如无为性不同微尘。此密严中佛及弟子。并余世界来此会者。当如涅槃及以虚空非择灭性

尔时世尊。现彼世界佛及菩萨。威神功德胜妙事已。复以佛眼遍视十方诸菩萨众。告一切佛法如实见菩萨摩诃萨言。如实见今此世界名曰密严。是中菩萨悉于欲色无色无想有情之处。以三摩地力生智慧火。焚烧色贪及以无明。转所依止得意成身。神足力通以为严饰。无窍隙无骨体。犹如日月摩尼电光。帝弓珊瑚纥利多罗。黄金瞻卜孔雀花月镜中之像。如是色身住于诸地修无漏因。由三摩地而得自在。十无尽愿及以回向。获殊胜身来密严刹

尔时一切佛法如实见菩萨摩诃萨。从座而起偏袒右肩。稽首佛足右膝着地。合掌白佛言世尊我于今者欲有所问。惟愿如来应正遍知哀许为说。佛告如实见言。善哉善哉恣汝所问。当为汝说令汝心喜

尔时一切佛法如实见菩萨摩诃萨承佛开许即白佛言。世尊。唯此佛刹超越欲色无色。及以无想有情界耶。佛言善男子。从此上方过百亿佛刹。有梵音佛土娑罗树王佛土星宿王佛土。过如是佛土复有无量百千佛刹。广博崇丽菩萨众会之所庄严。彼中诸佛咸为菩萨。说现法乐住自觉圣智。远离分别实际真如。大涅槃界究竟之法。是故当知此界外。有如是等无量佛刹。如实见匪唯汝今于佛国土菩萨众会。心生限量请问如来。有此菩萨摩诃萨名曰持进。曾于佛所生限量心。便以神通升于上方。过百千俱胝乃至殑伽沙等诸佛世界。不能一见如来之顷。心生希有知佛菩萨不可思议。还至娑诃世界名称大城。来于我所悔谢已过。赞佛功德无量无边。犹如虚空住自证境来密严刹。尔时会中金刚藏菩萨摩诃萨。善能演说诸地之相。微妙决定尽其源底。从座而起偏袒右肩。顶礼佛足右膝着地。合掌白佛言世尊我于如来应正遍知。欲少咨问唯愿哀愍为我宣说。佛言金刚藏汝于我所欲有问。如来应正等觉随汝所疑为汝开演

尔时金刚藏菩萨摩诃萨。承佛许已而白佛言。世尊佛者是何句义。所觉是何。唯愿世尊说胜义境示法性佛。令过去未来现在修菩萨行者。于诸色相积集之见。及余外道异论执着。行分别境起微尘胜。自在性时方虚空我意。根境和合如是诸见。复有计者无明爱业眼色与眼。是时复有触及作意。如是等法而为因缘。等无间缘增上缘所缘缘。和合生识执着行者。起有无等种种恶觉于我法中。复有诸人于蕴有情堕空性见。为断如是妄分别觉。唯愿世尊说离五种识所知相。能于诸法最自在者。佛大菩提所觉知义令得闻者。如其了悟所知五种而成正觉

尔时佛告金刚藏菩萨摩诃萨言。善哉善哉金刚藏。十地自在超分别境有大聪慧。能欲显是法性佛种最胜瑜只。匪唯汝今于佛菩提所觉之义。生希有念请问于我。有贤幻等无量佛子。咸于此义生希有心。种种思择而求佛体。如来者是何句义。为色是如来耶异色是如来耶。如是于蕴界处诸行之中。内外循求不见如来。皆是所作灭坏法故。蕴中无如来。乃至分析至于极微皆悉不见。所以者何以妙智慧定意谛观无所见故。蕴粗鄙故如来者常法身故。善哉佛子汝能善入甚深法界。谛听谛听善思念之当为汝说。金刚藏菩萨摩诃萨唯然受教

佛言善男子。三摩地胜自在金刚藏如来非蕴亦非异蕴。非依蕴非不依蕴。非生非灭。非智非所知。非根非境。何以故蕴处界诸根境等皆鄙陋故。不应内外而见如来。且色无觉知无有思虑生已必灭。同于草木瓦砾之类。微尘积成如来聚沫。受以二法和合而生。犹如水泡瓶衣等想。亦二和合因缘所生犹如阳焰。譬如盛热地气蒸涌。照已日光如水波浪。诸鸟兽等为渴所逼。远而望之生真水解。想亦如是无有体性虚妄不实分别智者。如有性见各别体相名字可得。定者审观犹如兔角。石女儿等但有假名。如梦中色唯想妄见觉悟非有。无明梦中见男女等种种之色。成于正觉即无所见。行如芭蕉中无坚实。离于身境即无体性。识如幻事虚伪不实。譬如幻师若幻师弟子。依草木瓦砾示现色像。幻作于人及诸象马。种种形相具足庄严。愚幻贪求非明智者。识亦如是依余而住。遍计分别能取所取二种执生。若自了知即皆转灭。是故无体同于幻士。金刚藏如来常住恒不变易。是修念佛观行之境名如来藏。犹如虚空不可坏灭。名涅槃界亦名法界。过现未来诸佛世尊。皆随顺此而宣说故。若如来出世若不出世。此性常住名法住性法界性法尼夜摩性。金刚藏以何义故名尼夜摩。远离后有一切过故。又此三摩地能决定除后有诸恶。以如是故名尼夜摩。若有住此三摩地者。于诸有情心无顾恋。证于实际及以涅槃。犹如热铁投诸冷水弃于有情故诸菩萨舍而不证。所以者何舍大精进大悲诸度。断于佛种趣声闻乘。行于外道邪见之迳。犹如老象溺在淤泥。为三摩地泥所沉没。味定境界亦复如是。退转一切诸佛法门不得入于究竟之慧。是故菩萨舍而不证近住而已。以究竟慧入佛法身。觉悟如来广大威德。当成正觉转妙法轮。智境众色而为资用。入如来定游涅槃境。一切如来令从定起。渐次加行超第八地。善巧决择乃至法云。受用如来广大威德。入于诸佛内证之地。与无功用道三摩地相应。遍游十方不动本处。而恒依止密严佛刹。金刚自在具大变化。示现佛土而成自在。转于所依智三摩地。及意成身力通具足。行步威德犹如鹅王。譬如明月影遍众水。佛亦如是随诸有情普现色相。于诸众会所益不空。复令当诣密严佛刹。如其性欲而渐开诱。为说一切欲界天王自在菩萨。清净摩尼宝藏宫殿诸安乐处。乃至诸地次第。从一佛刹至一佛刹。示现富乐功德庄严。尽于未来随机应现。犹如成就持明仙等。及诸灵仙宫殿之神。与人行止而不可见。如来变化所为事毕。住于真身隐而不现亦复如是

尔时世尊而说偈言

  根蕴如蛇聚　　境界缘所触
  无明爱业生　　熏习缚难解
  心心所恶觉　　缠绕如蟠龙
  怒毒因之与　　[火*孛]如炎盛火
  诸修观行者　　常应如是观
  舍诸蕴法故　　一心而不懈
  如于虚空中　　无树而有影
  风衢及马迹　　此见悉为难
  于能造所造　　色及非色中
  欲求见如来　　其难亦如是
  真如实际等　　及诸佛体性
  内证之所行　　非诸语言境
  涅槃名为佛　　佛亦名涅槃
  离能所分别　　云何而可见
  碎末于金矿　　矿中不见金
  智者巧融炼　　真金方乃显
  分剖于诸色　　乃至为极微
  及析求诸蕴　　若一若异性
  佛体不可见　　亦非无有佛
  定者观如来　　胜相三十二
  苦乐等众事　　施作皆明显
  是故不应说　　如来定是无
  有三摩地佛　　善根善巧佛
  一切世胜佛　　及正等觉佛
  如是五种佛　　所余皆变化
  如来藏具有　　三十二胜相
  是故佛非无　　定者能观见
  超越于三界　　无量诸佛国
  如来微妙刹　　净佛子充满
  定慧互相资　　以成坚固性
  游于密严刹　　思惟佛威德
  密严中之人　　一切同佛相
  超越刹那坏　　常游三摩地
  世尊定中胜　　众相以庄严
  得于如梦观　　显现于诸法
  众谓佛化身　　从于兜率降
  佛当密严住　　像现从其国
  住真而正受　　随缘众像生
  如月在虚空　　影监于诸水
  如摩尼众影　　色合而明现
  如来住正定　　现影亦复然
  譬如形与像　　非一亦非异
  如是胜丈夫　　成于诸事业
  非极微胜性　　非时非自在
  亦非余缘等　　而作于世间
  如来以因缘　　庄严其果体
  随世之所应　　种种皆明现
  游戏三摩地　　内外无不为
  山川及林野　　朋友诸眷属
  众星与日月　　皎镜而垂像
  如是诸世间　　身中尽苞纳
  复置于掌内　　散掷如芥子
  佛于定自在　　牟尼最胜尊
  无能作世间　　惟佛之所化
  愚翳无智者　　恶觉惑所缚
  着于有无论　　见我及非我
  或言坏一切　　或言于少分
  如是诸人等　　常自害其身
  佛是遍三有　　观行之大师
  观世如干城　　所作众事业
  亦如梦中色　　渴鹿见阳焰
  屈伸等作业　　风绳而进退
  佛于方便智　　自在而知见
  譬如工巧匠　　善守于机发
  亦如海船师　　执柁而摇动
  无边最寂妙　　具足胜丈夫
  利根者能证　　钝根者远离
  是修行定者　　妙定之所依
  一切定慧人　　明了心中住
  佛体最清净　　非有亦非无
  远于能所觉　　及离于根量
  妙智相应心　　殊胜之境界
  诸相妄所境　　离相是如来
  能断诸烦恼　　于定无所染
  无动及所动　　住于无染路
  微妙诸天俱　　乾闼修罗等
  众仙及外道　　赞叹常供养
  于彼不惊喜　　心无所动摇
  由瑜伽本净　　是故超彼岸
  以化佛现迹　　为天人亦业
  佛非彼此现　　犹如于日月
  住于圆应智　　离欲现人间
  异类诸外道　　随宜悉调伏
  种种众智法　　王论四吠陀
  悉是诸如来　　定力而持说
  现国王朝会　　及诸国法令
  山林修道处　　悉皆佛示化
  十方众宝藏　　出生清净宝
  悉是天中天　　自在威神故
  三界善巧慧　　种种诸才智
  所作方便业　　因佛而成就
  持鬘为群品　　业行者示因
  戏笑众善巧　　常说歌咏论
  或现降兜率　　天女业围绕
  歌舞交欢娱　　日夜常游集
  或现如魔王　　宝冠以严首
  执世之所绳　　与夺而招放
  虽放一切众　　现为明智者
  常在密严中　　寂然无动作
  此大牟尼境　　凡愚妄分别
  如人患翳目　　如鹿见阳焰
  如世观于幻　　梦中诸所取
  天中天境界　　佛子悉具真
  由见殊胜故　　如从于梦觉
  那罗伊舍梵　　珊那单妙喜
  童子劫比罗　　首迦等亦想
  或乱彼境界　　不见正瑜伽
  当来苦行仙　　过去及现在
  习气覆心故　　悉亦不能了
  善哉金刚藏　　普行诸地中
  复以佛威神　　而居密严土
  此之金刚藏　　示现入等持
  正定者境界　　由此相应故
  或有妄分别　　胜性与微尘
  如工匠制物　　种种相差别
  生唯是法生　　灭亦唯法灭
  妄计一切物　　细尘能造作
  譬如灯显物　　因能了于果
  初无所得相　　后坏亦复然
  非于过去中　　有体而可得
  未来亦如是　　离缘无有性
  一一诸缘内　　遍求无有体
  亦见有无性　　亦无无有见
  分别微细我　　有情瓶衣等
  邪宗坏正道　　三百有六十
  往来生死中　　无有涅槃法

    大乘密严经入密严微妙身生品第二

尔时一切佛法如实见菩萨摩诃萨。无量威力世中自在宝璎珞庄严其身。从座而起右膝着地。白金刚藏而作是言。尊者善能通达三乘世间。心得无违现法乐住内证之智。为大定师于定自在能随顺说诸地之相。常在一切佛国土中。为诸上首演深妙法。是故我今劝请佛子。说诸圣者不随他行。现法乐住内证之境。今我及诸菩萨摩诃萨众得见斯法。安乐修行趣于佛地。获意成身及言说身。自在力通皆得具足。转所依止不住实际。犹如众色真多摩尼。现诸色像能于诸趣天王宫殿。及一切佛密严国中说密严行。尔时金刚藏菩萨摩诃萨以偈答曰

  善哉天人主　　菩萨中殊胜
  请说入密严　　无我之法性
  应觉分别境　　心之所取相
  若舍于分别　　即见世分别
  了于世所缘　　即得三摩地
  我今为开演　　仁主应谛听
  热时见阳焰　　世间相亦然
  能相所相因　　而无妄分别
  能觉生所觉　　所觉依能现
  离彼则无此　　如光影相随
  无心亦无境　　能所量俱无
  但依于一心　　如是而分别
  能知所知法　　唯心量所有
  所知心既无　　能知不可得
  心为法自性　　有性所扰浊
  八地得清净　　九地获静虑
  觉慧为十地　　灌顶证如来
  法身得无尽　　是佛之境界
  究竟如虚空　　心识亦如是
  无尽无所坏　　众德已庄严
  恒在不思议　　诸佛密严土
  譬如瓶破已　　瓦体而显现
  瓦破微尘显　　析尘成极微
  如是因有为　　而成无漏法
  如火烧薪尽　　复于余处然
  证如得转依　　远离于分别
  住于不动智　　密严中显现
  无生现众色　　不住诸世间
  能断一切见　　归依此无我
  相续流注断　　无坏亦无生
  能尽一切见　　归依此无我
  诸惑皆已灭　　寂静不思议
  能净一切见　　归依此无我
  世间种种法　　本来无我性
  非由击坏无　　乃喻之所显
  如火烧薪已　　于中自息灭
  观察于三有　　无我智亦然
  是名现法乐　　内证之境界
  依此入诸地　　净除无始恶
  舍离世所依　　出世而安住
  其心转清净　　恒居密严土

尔时如实见菩萨摩诃萨及诸王等。向金刚藏咸作是言。我等今者皆欲归依。唯愿示我归依之处。于是金刚藏菩萨摩诃萨以偈答曰

  佛体非有无　　已焚烧蕴树
  超胜魔王众　　而住密严国
  所觉净无垢　　仁主可归依
  远离于觉量　　证于无所有
  密严诸定者　　仁主可归依
  净胜密严刹　　众圣所依处
  观行者充满　　应归于密严
  当观于世间　　如尽有高下
  梦中见美色　　石女急诞生
  亦如乾闼城　　火轮空中发
  如种种幻形　　人马花果树
  幻归所变化　　一切悉非真
  如奔电浮云　　皆为而非实
  如匠作瓶等　　由分别所成
  仁主应谛听　　世间诸有情
  习气常覆心　　生种种戏论
  末那与意识　　并余识相续
  五法及三性　　二种之无我
  恒共而相应　　如风击暴水
  转起诸识浪　　浪生流不停
  赖耶亦如是　　无始诸习气
  犹如彼暴水　　为境风所动
  而起诸识浪　　恒无断绝时
  八种流注心　　虽无若干体
  或随缘顿起　　或时而渐生
  取境亦复然　　渐顿而差别
  心转于舍宅　　日月与星宿
  树枝叶花果　　山林及军众
  于如是等处　　皆能渐顿生
  多分能顿现　　或渐起差别
  若时于梦中　　见昔所更境
  及想念初生　　乃至于老死
  算数与众物　　寻思于句义
  观于异文彩　　受诸好饮食
  于如是境界　　渐次能了知
  或有时顿生　　而能取之者
  心性本清净　　不可得思议
  是如来妙藏　　如金处于矿
  意生从藏识　　余六亦复然
  识六种或多　　差别于三界
  赖耶与能熏　　及余心法等
  染净诸种子　　虽同住无染
  佛种性亦然　　定非定常净
  如海水常住　　波潮而转移
  赖耶亦复然　　随诸地差别
  修有下中上　　舍染而明显
  金刚藏复言　　如实见菩萨
  见闻觉悟者　　自性如实慧
  十方一切国　　诸王众会中
  汝已从我闻　　随应广为说
  若人闻法已　　渐净阿赖耶
  或作人中王　　转轮四天下
  或复为帝释　　兜率苏焰等
  乃至化乐宫　　欲界自在主
  或王色界处　　或生无色天
  无想有情中　　静虑受安乐
  证真而不住　　犹如师子吼
  于诸定自在　　法喜以相应
  一心求密严　　不染着三界
  至于密严已　　渐次而开觉
  转依获安乐　　寂静常安住
  无量诸佛子　　围绕以庄严
  为法自在王　　众中之最上
  非如外道说　　坏灭为涅槃
  坏应同有为　　无有复生过
  十业上中下　　三乘以出生
  最上生密严　　地地转升进
  得解脱智慧　　如来微妙身
  云何说涅槃　　是灭坏之法
  涅槃若灭坏　　有情有终尽
  有情若有终　　是亦有初际
  应有非生法　　而始作有情
  无有非有情　　而生有情界
  有情界既尽　　佛无所知法
  是则无能觉　　亦无有涅槃
  妄计解脱者　　而说于解脱
  如灯灭薪尽　　亦如芭蕉种
  彼证解脱性　　是坏有成无
  于解脱妙乐　　远离不能说
  遍处及静虑　　无色无想定
  逆顺而入出　　力通皆自在
  于彼不退还　　亦不恒沉没
  了达于法相　　诸地得善巧
  如是而庄严　　当来密严刹
  若言解脱性　　坏有以成无
  斯人住诸有　　毕竟不能出
  既坏三和合　　因等四种缘
  眼色内外缘　　和合所生识
  世间内外法　　互力以相生
  如是等众义　　一切皆违反
  若知唯识现　　离于心所得
  分别不现前　　亦不住其性
  尔时所缘离　　寂然心正受
  舍于世间中　　所取能取见
  转依离粗重　　智慧不思议
  十种意成身　　众妙为严好
  作三界之王　　而生于密严
  色心及心所　　所相应无为
  于内外世间　　谛观无别异
  如是诸智者　　来于密严国
  名相与分别　　正智及如如
  牟尼三摩地　　体性皆平等
  应当往密严　　佛所称赞土
  若坏三和合　　及以四种缘
  不固于自宗　　同诸妄分别
  恶习分别者　　彼之五种论
  譬喻不成立　　诸义皆相违
  彼五悉成过　　惑乱觉智眼
  着喻及似喻　　颠倒不颠倒
  如是虚妄执　　一切于此坏
  舍离于自宗　　依止他宗法
  初际等诸见　　皆从灭坏生
  大王应当知　　有情在三界
  如轮而运转　　初际不可得
  如来以悲愿　　普应诸有缘
  如净月光明　　无处不周遍
  随彼先业类　　应机而说法
  若坏于涅槃　　佛有何功利
  增上有三种　　解脱亦复然
  四谛及神足　　念处无碍解
  四缘无色住　　根力及神通
  觉支诸地等　　有为无为法
  乃至众圣人　　皆依识而有
  苦法忍法智　　苦类忍类智
  集智四亦然　　灭道亦如是
  如是十六种　　名之为现观
  学人数有十　　第八七返有
  家家一往来　　一间而灭度
  中槃与生般　　有行及无行
  上流于处处　　然后般涅槃
  如是一切种　　诸智之品位
  修行观行者　　下中上不同
  菩萨增上修　　功德最殊胜
  十一与十二　　及以于十六
  此诸修定者　　复渐灭于心
  所尽非是心　　亦非心共住
  未来心未至　　未至故非有
  心缘不和合　　非此非彼生
  第四禅无心　　有因不能害
  有因谓诸识　　意识及五种
  妄想不觉知　　流转如波浪
  定者观赖耶　　离能所分别
  微妙无所有　　转依而不坏
  住密严佛刹　　显现如月轮
  密严诸智者　　与佛常共俱
  恒游定境中　　一味无差别
  难思观行境　　定力之所生
  王应常修习　　相应微妙定
  欲界有六天　　梵摩复十二
  无色及无想　　一切诸地中
  若生密严国　　于彼为天主
  欲求密严土　　应修十种智
  法智及类智　　他心世俗智
  苦集灭道智　　尽智无生智
  仁主汝所生　　舍军恒罗族
  月王与甘蔗　　种姓而平等
  虽于彼族中　　汝族最殊胜
  当求密严国　　勿怀疑退心
  如羊被牵拽　　喘惧而前却
  末那在身中　　似幻鹿而住
  亦如幻树影　　河中之苇荻
  如王戏园苑　　运动身支分
  意及于意识　　心心法共俱
  此法无自性　　犹云聚非实
  藏识一切种　　习气所缠覆
  如彼摩尼珠　　随缘现众色
  虽住有情身　　如鹅王无垢
  是决定种性　　亦为大涅槃
  名从于相生　　相从因缘起
  以诸形相故　　而起于分别
  分别由二因　　外想心习气
  第七末那识　　应知亦复然
  诸根意缘会　　发生于五识
  与心所相应　　住身如宫室
  王智常观察　　一切诸世间
  从于如是因　　而生彼诸果
  真如非异此　　诸法互相生
  与理相应心　　明了能观见
  此即是诸法　　究竟圆成性
  亦为妄所计　　一切法不生
  诸法性常空　　非无亦非有
  如幻亦如梦　　及乾闼婆城
  阳焰与毛轮　　烟云等众物
  种种诸形相　　名句及文身
  如是执着生　　成于遍计性
  根境意和合　　熏习成于种
  与心无别异　　诸识由此生
  资于互因力　　是谓依他起
  善证自觉智　　现于法乐住
  是即说圆成　　众圣之境界
  佛及诸佛子　　证此名圣人
  若人证斯法　　即见于实际
  唱言我生尽　　梵行亦已立
  所作无不成　　不受于后有
  解脱一切苦　　断灭于动摇
  熏习皆已焚　　劫尽犹不转
  生法二无我　　照见悉皆无
  无始来积集　　种种诸戏论
  无边众过患　　一切皆已除
  譬如热铁团　　热去铁无损
  如是解脱者　　惑尽得清凉
  入于无漏界　　密严之妙国
  此土最微妙　　非余者所及
  唯佛与菩萨　　清净之所居
  三摩地现前　　以此而为食
  欲生斯刹者　　善习胜瑜伽
  复为诸有缘　　分别广开示
  名本从相生　　相复从缘起
  从相生分别　　不契圆成性
  根境瓶衣等　　假法共和合
  分别从此生　　了知而别异
  若动若非动　　一切诸世间
  皆因痴暗生　　愚冥以为体
  短长等诸色　　音声与香界
  甘苦坚滑等　　意识因所缘
  所有诸善恶　　有为无为法
  乃至于涅槃　　斯为智之境
  念念常迁转　　皆因识以生
  末那缘藏识　　如磁石吸铁
  如蛇有二头　　各别为其业
  染意亦如是　　执取阿赖耶
  能为我事业　　增长于我所
  复与意识俱　　为因而转谢
  于身生暖触　　运动作诸业
  饮食与衣裳　　随物而受用
  腾跃或歌舞　　种种自嬉游
  持诸有情身　　皆由意功力
  如火轮垂发　　乾闼婆之城
  不了唯自心　　妄起诸分别
  身相器世间　　如动秋千势
  无力不坚固　　分别亦复然
  分别无所依　　但行于自境
  譬如镜中像　　识种动而见
  愚夫此迷惑　　非诸明智者
  仁主应当知　　此三皆识现
  于斯远离处　　是即圆成实
  持进等菩萨　　及圣目干连
  寻声与遍观　　百千万亿刹
  种种宝严饰　　绮丽无等双
  于彼微妙境　　密严最殊胜
  极乐妙喜刹　　下方俱胝国
  一切诸世尊　　皆赞如斯土
  谓无有终始　　威德化自然
  本昔佛所居　　超出于三界
  丰乐非执受　　寂静自无为
  自利及利他　　功业悉成满
  不于欲界中　　成佛作佛事
  要往密严土　　证于无上觉
  俱胝诸世尊　　欲中施佛事
  先从于此国　　化为无量亿
  正定常相应　　神通以游戏
  遍于诸国土　　如月无不见
  随诸众生类　　所应而化益
  十地花严等　　大树与神通
  胜鬘及余经　　皆从此经出
  如是密严经　　一切经中胜
  仁主及诸王　　宜应尽恭敬
  欲色无色界　　无想等天宫
  如来迥已超　　而依密严住
  此土诸宫殿　　如莲被众饰
  是一切如来　　净智之妙相
  佛及诸菩萨　　常在于其中
  世尊恒住禅　　寂静最无上
  依自难思定　　现于众妙色
  色相无有边　　非余所能见
  极乐庄严国　　世尊无量寿
  诸修观行者　　色相皆亦然
  或见天中天　　赫奕含众彩
  瞻卜雌黄色　　真金明月光
  孔雀颈如莲　　相思子之聚
  虹电珊瑚色　　或现清羸身
  或着刍摩衣　　或寝草茅等
  或处莲华上　　犹如千日光
  或见诸菩萨　　顶饰盘龙髻
  金刚帝青宝　　庄严为宝冠
  或见轮幢文　　鱼商佉等相
  或见光丽色　　如霓而拖空
  或以须弥山　　置之于掌内
  或持大海水　　安于牛迹中
  或现作人王　　冕服当轩宇
  辅佐皆恭敬　　共宣于国化
  或现密严场　　寂静修定者
  说于自证境　　光佛所知法
  或说得转依　　心慧皆解脱
  自在三摩地　　如幻无碍身
  或现境不染　　断诸取着业
  以智烧见薪　　不受于诸有
  譬如膏炷尽　　灯灭而涅槃
  或示修诸度　　大会施无遮
  持戒苦行等　　种种诸仪则
  极乐庄严国　　人非胎藏生
  微妙金色身　　光明净圆满
  彼众之境界　　皆悉具瑜伽
  若比于密严　　百分不及一
  极乐界中人　　自然随念食
  牟尼胜自在　　定为甘露味
  种种宝树林　　游憩于其下
  金沙布其地　　显现殊胜刹
  净妙之宝莲　　开敷功德水
  如是殊胜境　　不可得为喻
  彼皆莲华生　　恭敬无量寿
  善修三摩地　　爱乐佛功德
  专精回向者　　悉皆生彼国
  众相以庄严　　皎镜无尘垢
  金刚藏说已　　自现于己身
  或如于指节　　或复如芥子
  或细如毫端　　百分之一分
  或现善逝身　　声闻与缘觉
  众色及余类　　乃至种种形
  各随其所宜　　而说于诸法
  或说于菩萨　　入诸地了知
  五法三自性　　八识二无我
  得于如幻定　　随意所成身
  自在诸神通　　十方四无畏
  住于不退转　　得净之所依
  入于佛地中　　无漏之蕴界
  永离余变易　　寂然而常住
  或说于菩萨　　善妙而游履
  犹梦像水月　　瑜只所行道
  得首楞严定　　十种如幻身
  十无尽愿圆　　证成等正觉
  据妙莲华座　　相好甚端严
  无量诸佛子　　恭敬而围绕
  或说诸菩萨　　愿力现众形
  遍游于十方　　历事恒沙佛
  是诸菩萨等　　其身甚微妙
  出入常自在　　不住有无中
  譬如天神仙　　及诸健达缚
  依彼妙高住　　或处于虚空
  地行诸有情　　对之而不见
  如是诸菩萨　　现形亦复然
  非修观行人　　无能睹之者
  或说诸菩萨　　得于胜静虑
  处处现受生　　示入无余界
  或说诸菩萨　　能以于定力
  自在转所依　　不住真实际
  无量有情处　　随现差别身
  身虽种种殊　　其心一平等
  犹如于地水　　亦如于日月
  或说诸菩萨　　常以大悲心
  怜愍诸有情　　轮回处生死
  跉跰受穷独　　贪病众苦煎
  下贱与形残　　安之不忧恼
  如蜂处舶上　　飘然大海中
  沿溯而往来　　须臾数万里
  为说非我法　　生死速无常
  令其知灭坏　　刹那暂不住
  或说于诸佛　　及以诸菩萨
  明见众有情　　醉在于渴爱
  为分别苦逼　　于无于法中
  妄取种种相　　计着能所取
  心恒被缧绁　　不能得解脱
  溺生死海中　　驰荡无休息
  贫贱而孤露　　往来无所依
  譬如大海中　　蛛蝥网难住
  诸佛及菩萨　　如彼住船者
  普怜诸有情　　运出生死难
  随其若干类　　为现差别身
  说施戒等门　　种种诸胜行

大乘密严经卷上大乘密严经卷中

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

    入密严微妙身生品之余

尔时大会中。有普贤众色大威德菩萨摩诃萨。与其同类持世菩萨摩诃萨。持进菩萨摩诃萨。曼殊室利菩萨摩诃萨。神通王菩萨摩诃萨。得大势菩萨摩诃萨。解脱月菩萨摩诃萨。金刚脐菩萨摩诃萨。大树紧那罗王菩萨摩诃萨。虚空藏菩萨摩诃萨等。乃至摩尼大宝藏殿无量诸天。复有密严土中诸瑜只众。与彼无量俱胝佛刹来听法者。闻便密严甚深功德。于法恭敬定得转依。恒居此土不生余处。咸共悲愍未来世中一切有情。普欲等慈为作饶益。各共瞻仰金刚藏菩萨摩诃萨。一心同声以偈问曰

  尊者具辩才　　唯愿见开示
  世间诸色像　　其谁之所作
  为如工造瓶　　泥轮以埏埴
  为如奏乐者　　击动所成音
  为如一物体　　有三种自性
  谓已成未成　　咸在于一物
  云何种种色　　一物而建立
  为兜率所作　　夜摩所作耶
  他化自在作　　大树紧那罗
  善见天所作　　色究竟天耶
  螺髻梵王作　　无色天作耶
  一切天主作　　自然所作耶
  变化之所作　　诸佛所作耶
  为余世界中　　佛子之所作
  是诸作众色　　惑乱而建立
  所起于惑乱　　如鹿见阳焰
  譬如于瓶处　　为德之所依
  一切诸世间　　能住于处者
  非德者属德　　非德依德者
  展转和合故　　众德所集成
  诸色唯惑乱　　为亦有住耶
  为梵王所作　　那罗延作耶
  雄猛及胜论　　数论自作耶
  胜性之所作　　自在自然耶
  时无明所生　　爱业所作耶
  天仙及世定　　皆悉怀疑惑
  为先无有体　　犹如于幻梦
  亦如热时焰　　及乾闼婆城
  无始妄分别　　随彼彼相续
  起能耶所耶　　如蛇有二头
  亦如起尸行　　木人机所转
  空中见垂发　　及旋火轮耶

尔时金刚藏菩萨摩诃萨。告普贤众色大威德菩萨摩诃萨。及余大众。而说偈言

  世间众色像　　不从作者生
  亦如劫比罗　　因陀罗等作
  亦非祠祭果　　亦非围陀教
  彼有多因种　　修行常不住
  亦复非无有　　能持世间因
  谓第八丈夫　　是名为藏识
  由此成众色　　如转轮众瓶
  如油遍在麻　　盐中有碱味
  如无常遍色　　丈夫识亦然
  如香在沉麝　　及光居日月
  远离能所作　　及以有无宗
  亦离于一异　　一切外道过
  非智所寻求　　不可得分别
  定心解脱者　　自觉之所证
  若离阿赖耶　　即无有余识
  譬如海波浪　　与海虽不异
  海静波去来　　亦不可言一
  譬如修定者　　内定清净心
  神通自在人　　所有诸通慧
  观行者能见　　非余之所了
  如是流转识　　依彼藏识住
  佛及诸佛子　　定者常观见
  藏识持于世　　如以线贯珠
  如轮与车合　　业风之所转
  陶师运轮杖　　器成随所用
  藏识与诸界　　共力无不成
  内外识世间　　弥给悉周遍
  譬如众星象　　布列在虚空
  风力之所持　　运行常不息
  如空中鸟迹　　求之莫能见
  若离于虚空　　飞翔不可得
  藏识亦如是　　不离自他身
  如海起波涛　　如空含万像
  丈夫识亦尔　　蕴藏诸习气
  譬如水中月　　及以诸莲华
  与水不相杂　　不为水所著
  藏识亦如是　　习气莫能染
  如目有童子　　眼终不自见
  赖耶住于身　　摄藏诸种子
  遍持寿暖识　　如云覆世间
  业用曾不停　　有情莫能见
  身者众色成　　又能作诸色
  如陶师不依　　以泥成众器
  世间妄分别　　见牛等有角
  不了角非有　　因言兔角无
  分析至极微　　求角无所有
  要待于有法　　而起于无见
  有法本自无　　无见何所待
  若有若无法　　展转互相因
  有无二法中　　不应起分别
  若离于所觉　　能觉即不生
  譬如旋火轮　　翳幻干城等
  皆因少所见　　而生是诸觉
  若离于所因　　此觉即无有
  名相互相系　　习气无有边
  一切诸分别　　与意而俱起
  有情流转故　　圆成则不证
  无始时积集　　沉迷诸妄境
  戏论而熏习　　生于种种心
  能取及所取　　有情心自性
  瓶衣等诸相　　见实不可闻
  一切唯有觉　　所觉义皆无
  能觉所觉性　　自然如是转
  愚夫不除断　　习气心迷惑
  赖耶及七识　　有时而顿生
  犹如海波浪　　风缘之所动
  洄澓而腾转　　无有断绝时
  识浪亦如是　　境界风所击
  种种诸分别　　自内而执取
  如地无分别　　庶物依以生
  藏识亦复然　　众境之依处
  如人以己手　　还自扪其身
  亦如象以鼻　　取水自沾洒
  复似诸婴孩　　以口含其指
  是知识分别　　现境还自缘
  是心之境界　　普遍于三有
  久修观行者　　而能善通达
  内外诸世间　　一切唯心现
  尔时金刚藏　　说是妙法已
  默然而止住　　思惟于法界
  微妙普遍定　　则入诸佛境
  见无量佛子　　当修住密严
  即从禅定起　　放光而普照
  欲色与无色　　及无想天宫
  如是光明中　　复现诸佛刹
  悉见无量佛　　相好妙端严
  种种微妙色　　皆从佛身出
  随其所爱乐　　世间作利益
  皆使彼佛子　　称赞密严名
  欣然相顾视　　复作如是说
  密严妙无垢　　能除一切罪
  观行者胜处　　其土最姝妙
  我等闻名字　　心生大喜悦
  各从其所住　　俱来诣密严
  色尽螺髻梵　　及与净居天
  希慕此密严　　佛子所生处
  同心而共聚　　咸请梵王言
  我等今云何　　得至密严土
  天王若往彼　　我等当营从
  尔时螺髻梵　　闻诸天众言
  遽即与同行　　中路迷所适
  梵王先觉悟　　以慧审观察
  彼胜观行境　　何阶而可至
  欲色自在者　　非彼所能诣
  非空处识处　　及与非非想
  并余外道宗　　邪定者能往
  云何作善巧　　得至于密严
  或以天中天　　威神力加护
  能令至亟行　　得会密严宫
  螺髻梵发声　　即时尽归命
  见佛满空界　　威光而炽然
  告彼梵王言　　汝当还本殿
  如来密严刹　　是观行之境
  非想尚难阶　　色者何能往
  梵王从诸佛　　闻如是告已
  退还于本处　　寻至梵天宫
  时净居诸天　　各各相共议
  螺髻梵天主　　威神不能往
  当知密严土　　胜妙难思议
  自非如幻定　　谁能诣斯刹
  此会闻天众　　称赞功德声
  生于奇特心　　乃白金刚藏
  我等皆乐闻　　唯垂演深法
  尔时金刚藏　　即告大众言
  如来所说法　　谁能尽敷演
  自觉之圣智　　境界不思议
  非深观行人　　云何可开示
  时持进夜摩　　自在诸佛子
  异口同音言　　唯愿速宣说
  神通与曼殊　　慈氏紧那王
  及余修定者　　咸皆作是请
  诸天持明仙　　空中奏众乐
  同心而劝请　　唯垂为宣说
  如是劝请已　　各坐于胜座
  梵王承佛力　　还来此会中
  复白金刚藏　　作于如是问
  今此诸大会　　严饰未曾有
  悉是尊弟子　　聪慧无等伦
  皆于尊者处　　渴仰而求法
  我今犹未知　　所问为何等
  憍腊与胜堕　　及顶生轮王
  为是少年马　　为是古仙传
  甘蔗种之子　　千弓持国王
  欲色无色中　　人天等之法
  为是菩萨行　　独觉及声闻
  乃至修罗明　　星象等众论
  唯愿如是事　　次第而演说
  我等及天人　　一心咸听受
  尔时解脱月　　持世虚空藏
  大势观自在　　总持自在王
  宝髻与天冠　　金刚手寂慧
  及宝手大士　　并诸最胜子
  皆从俱胝刹　　来坐莲花宫
  咸请金刚藏　　唯愿大慧说
  过去及未来　　牟尼清净智
  仁于佛亲受　　明了心不疑
  此众皆乐闻　　愿尊时演说
  定王金刚藏　　普告大众言
  如来所说法　　非我具能演
  唯除佛菩萨　　威神之所护
  我今至心礼　　自在清净宫
  摩尼宝藏殿　　佛及诸佛子
  我以敬心说　　如来清净智
  能令绍佛种　　汝等应谛听
  此非诸王论　　及轮王轨仪
  但示于密严　　如来之种性
  正定者境界　　诸佛之胜事
  如来微妙智　　离于能所觉
  是故非我力　　能演此甚深
  但以佛威神　　从佛而听受
  此智甚微妙　　是三摩地花
  佛在密严中　　正受而开演
  远离诸言说　　及以一切见
  若有若无等　　如是四种边
  是名最清净　　中道之妙理
  密严诸定者　　于此能观察
  离着而转依　　速入如来地
  时诸佛子众　　从尊闻是语
  头面礼双足　　恭敬而白言
  我等受乐法　　如渴人思饮
  如游蜂念蜜　　瑜伽自在尊
  唯愿正宣说　　令诸菩萨众
  于定得自在　　智慧大威德
  及诸刹土王　　深解观行者
  咸欲闻如来　　所说甚深法
  皆愿听尊者　　微妙梵帝声
  如来所悦可　　深远善巧声
  演说殊胜义　　悉令得明了
  金刚藏告言　　如来所说义
  真实甚希有　　离相难可见
  如空中无物　　见影为希有
  如来所说义　　希有亦复然
  空中风鸟迹　　其形不可见
  牟尼演妙理　　难见亦复然
  世间之事喻　　智者能明了
  诸佛所宣说　　譬喻不能知
  令我之所见　　如梦干城等
  此会有观行　　具大智慧者
  通达真实义　　无不皆明了
  云何为是人　　说佛难思境
  然今所开演　　凭佛威神力
  一切最胜子　　至心应谛听
  如来妙言说　　句义皆相应
  超越心境界　　远离于譬喻
  犹如蜂采花　　先者取精粹
  是诸后至者　　皆悉味其余
  胜牟尼亦然　　先得妙法味
  我则饮其余　　今为众宣说
  天中天境界　　增悦诸明智
  实非意测量　　言象可能表
  示同人形色　　相好以严身
  现于胜妙宫　　宝冠以为饰
  圆光及轮辐　　种种皆成就
  照曜于宫殿　　能除外道憍
  诸佛四时中　　恒依密严住
  而于一切处　　现生及涅槃
  纯善少减时　　恶生及浊乱
  随彼之意乐　　利益诸有情
  业用无暂停　　常住密严刹
  此之清净处　　瑜只安乐宫
  浊乱少减时　　显示如来相
  譬如净满月　　影遍于众水
  佛以一切身　　随宜而应化
  如来净智境　　观行者皆见
  或现大自在　　或现那罗延
  成现迦毗罗　　住空而说法
  或现围陀者　　常行及妙喜
  童天及尸弃　　罗护都牟卢
  或现紧那罗　　甘蔗月种姓
  及诸国王等　　一切所瞻奉
  或作大医王　　示现于众人
  金刚等众宝　　铜铁及诸矿
  明珠与铅锡　　红碧二颇梨
  随彼诸有情　　爱乐而显现
  由佛加持力　　令彼悉安乐
  天女及龙女　　乾闼婆之女
  欲界自在者　　不能动其心
  超胜欲境界　　及胜色界色
  空处及识处　　无所有之处
  非想非非想　　于彼不迷惑
  无想诸定者　　未离于惑缠
  非安非清净　　流转于诸有
  有身者所生　　非如密严国
  密严微妙土　　清净福为严
  解脱知见人　　最胜之依处
  具十种自在　　六通三摩地
  皆以成意身　　如佛于彼现
  修行于十地　　檀等波罗蜜
  一切相好花　　常以为严饰
  远离于分别　　亦非无觉了
  无有我意根　　惠根常悦乐
  施等诸功德　　净业悉圆满
  得佛胜所依　　密严之净国
  此土最微妙　　不假日月明
  佛及诸菩萨　　清净光恒照
  密严中众圣　　其光逾聚日
  无有昼夜时　　亦无老死患
  殊胜密严宫　　诸天所希慕
  最上瑜伽者　　地地而进修
  了知一切法　　皆以心为性
  善说阿赖耶　　三性法无我
  其身转清净　　而生密严国

    大乘密严经胎藏生品第三

  尔时金刚藏　　菩萨摩诃萨
  复告螺髻梵　　天主应当知
  一切有情身　　九物以为性
  有为相迁动　　能造所造俱
  精血共和合　　增长于不净
  为无量诸业　　之所常覆缠
  如毒树所生　　扶疏而蓊郁
  贪嗔等烦恼　　增长亦如是
  九月或十月　　生于满足时
  既从胎藏出　　颠危受诸苦
  天主应当知　　此诸有情类
  皆由业力故　　驱驰运动生
  或自人中来　　或以傍生趣
  非天与罗刹　　龙及于诸鬼
  或以持明族　　天趣之胜身
  或于瑜只中　　退失三摩地
  轮王之贵族　　而来生此中
  如是既生已　　诸根遂增长
  随亲近宿习　　复造于诸业
  由斯业大故　　轮回诸趣中
  若有诸智者　　闻法得觉悟
  离文字分别　　入三解脱门
  得证真实理　　清净之殊胜
  上上最清净　　即往于密严
  能遍俱胝刹　　随宜而应现
  天主如是生　　永脱诸险趣
  是名为丈夫　　亦名为智者
  亦名天中天　　佛子众围绕
  天主应当知　　胎藏身虚伪
  非从自性生　　非从痴爱业
  以皆因相有　　了达灭无余
  亦离于分别　　及以于文字
  能如斯观者　　即往密严场
  若诸修定人　　住定攀缘境
  即便为声色　　诳惑生取着
  不能得坚固　　亦名散动心
  以斯邪定缚　　流转生三界
  若有胜瑜只　　善住三摩地
  远离能所取　　寂然心不生
  是名真实修　　无相观行者
  欲生密严土　　常应如是观

    大乘密严经自作境界品第四

  尔时金刚藏　　菩萨摩诃萨
  复告螺髻梵　　天主应当知
  八种九种心　　常与无明转
  能生诸世间　　皆心心法现
  由彼流转故　　诸识与诸根
  无明所变异　　本心坚不动
  世间及根境　　皆从十二支
  能生及所生　　刹那而灭坏
  梵世至非想　　亦从于因缘
  唯有天中天　　能离作所作
  有情及无情　　动与不动法
  皆如于瓶等　　灭坏以为性
  天主应当知　　诸识甚微细
  迁流而速疾　　是佛之境界
  诸仙及外道　　假称是牟尼
  以言互相缚　　而贪种种色
  于此生灭识　　悉皆不能知
  假使一千岁　　思唯四吠陀
  行施得梵天　　还当有退落
  或四月苦行　　祠祭所获果
  或修异类坛　　事火所求福
  或修三趣法　　宰羊以祈祷
  得果还有退　　梵王何不悟
  三德果系属　　不坚如芭蕉
  唯以智解脱　　得生密严土
  定者证斯境　　方能往彼宫
  是故大梵天　　应当善修习
  密严中之人　　无生死眷属
  一切有情识　　不断亦不坏
  诸业无染着　　亦无染熏习
  如莲不着水　　犹空不染尘
  日月无云翳　　瑜伽者亦尔
  速修是观行　　如来所摄持
  沐之净戒流　　饮以智慧液
  由修胜戒智　　生死得解脱
  天主应当知　　有情蕴处界
  众法所合成　　悉皆无所有
  眼色等因缘　　而得生于识
  犹火因薪炽　　识起亦复然
  境转随妄心　　犹铁逐磁石
  如干城阳焰　　愚渴之所取
  中无能造物　　但随心变异
  复如干城人　　往来皆不实
  众生身亦尔　　进止悉非真
  亦如梦中见　　寤后即非有
  妄见蕴等法　　觉已本寂然
  四大微尘众　　离心无所得
  世间可特物　　执非四大成
  譬如风疾缘　　或现见诸境
  起尸无作者　　世间法亦然
  汝等诸佛子　　应当善观察
  世间诸动植　　犹如水聚沫
  瓶衣等妄想　　不实如阳焰
  苦乐等诸受　　方之水上泡
  众行如芭蕉　　中无有坚实
  是识如幻事　　虚伪悉非真
  于彼三界中　　动与不动法
  皆同于梦境　　迷心之所现
  亦如幻化事　　及乾闼婆城
  但诳于愚夫　　初无有真实
  佛子觉此法　　其心无所畏
  慧火焚诸患　　即生密严国
  世间皆无相　　相为所系缚
  无相为吉祥　　相及心境界
  心境界非真　　真为慧境界
  远离于众相　　慈悲之所行
  无相遍一切　　三界皆清净
  色声等众相　　名为三界法
  一切诸根境　　有情之缚因
  由慧得解脱　　安乐而自在
  时宝髻菩萨　　坐殊妙之座
  向于金刚藏　　而作如是言
  遍诸俱胝刹　　尊者为上首
  成就最妙智　　了达所知法
  于无量悉檀　　皆已得明见
  今在修行众　　能净于彼疑
  觉察有情身　　一切之本起
  以妙音演畅　　穷劫不能尽
  应当为众会　　说离诸逆顺
  似非似等因　　及以真实法
  令此诸智者　　心净无有疑
  舍于诸蕴因　　不久得解脱
  蕴因法非法　　生此身后身
  智则能脱苦　　受则为坚缚
  有情心所起　　由色及以明
  作意等众缘　　驰散于诸境
  迅疾其奔电　　难可得觉知
  无明及爱业　　以之而浊乱
  诸法意先导　　意速意殊胜
  法与意相应　　皆以意为性
  譬如摩尼宝　　显现于众彩
  如是之妙义　　佛子何不说
  如众色摩尼　　随色而显现
  仁者瑜只中　　照耀亦如是
  具足如来像　　恒住自在宫
  佛子众围绕　　随宜应为说
  尔时金刚藏　　菩萨摩诃萨
  于法自在者　　复告大众言
  密严微妙土　　是最胜寂静
  亦是大涅槃　　解脱净法界
  亦是妙智境　　及以大神通
  修诸观行者　　所依之妙刹
  不断亦不境　　常住无变易
  水亦不能濡　　风亦不能燥
  非如瓶等体　　勤勇成而坏
  非似不似因　　二种所成立
  立宗及诸分　　皆是不定法
  以宗及以因　　各执差别故
  密严微妙刹　　体是转依识
  超于分别心　　非妄情境界
  如来密严刹　　无终亦无始
  非微尘自性　　非由于乐欲
  非大自在作　　非无明爱业
  但由无功用　　妙智之所生
  出欲色无色　　超无想暗网
  密严微妙土　　是阿若悉檀
  非诸因明者　　所量之境界
  非由于胜性　　自在与声论
  及吠陀等宗　　之所能开显
  乃至资粮位　　智慧不能了
  唯是于如来　　及十地智境
  仁者今谛听　　愚夫迷世间
  为业及非业　　我今演此义
  令修胜定者　　获得于安乐
  内外一切物　　所见唯自心
  有情心二性　　能取及所取
  心体有二门　　即心见众物
  凡夫性迷惑　　于自不能了
  如瓶现色相　　无体唯自心
  羸定及诸仙　　于此义惑乱
  舍于真实理　　而行分别路
  是心有二性　　如镜像月影
  如目而有翳　　妄见于毛轮
  空中无毛轮　　应无珠璎珞
  但从病翳眼　　若斯而显现
  虚妄计著者　　不觉恒执取
  广现诸严饰　　种种梵等相
  一切诸有情　　及与瓶衣等
  内外种种事　　皆悉从心起
  此密严妙定　　非余之所有
  若有修行者　　生于众福地
  或生欲自在　　或于色界天
  乃至无相宫　　色究竟天处
  空识无所有　　非想非非想
  种种诸宫殿　　渐次除贪欲
  不久得生彼　　密严观行宫
  众佛子围绕　　自在而游戏
  汝应修此定　　如何着亲属
  亲属常系缚　　轮回生死因
  男女意惑乱　　精血共和合
  如虫生自泥　　此中生亦尔
  九月或十月　　彼体渐增长
  时至出胎已　　譬如虫蠕动
  从此而长大　　乃正心了知
  我观诸有情　　生生悉如此
  父母无有数　　妻子亦复然
  于诸世间中　　无处不周遍
  譬如彼石女　　梦已忽生子
  生已方欢乐　　寻又见其亡
  悲哀不自胜　　忽然从睡觉
  不见有其子　　初生及后终
  又梦游山川　　城邑与园苑
  一切诸境界　　世间共受用
  彼此互相见　　驰鹜而往来
  运转与屈伸　　无量之境界
  及从于睡觉　　一切皆非有
  亦如多欲者　　梦见于女人
  颜貌甚端严　　服玩皆珍绮
  种种恣欢乐　　觉已悉皆无
  一切诸世间　　当知亦如是
  王位及营从　　父母等宗姻
  但诳于愚夫　　体性皆非实
  汝于三摩地　　何故不勤修
  无量诸声闻　　独觉及菩萨
  住山间树下　　寂静修禅处
  摩罗耶乳海　　频陀婆利师
  摩醯因陀罗　　鸡罗雪山等
  或止圆生树　　或住娇微那
  处须弥半腹　　或憩如意树
  绊住剑摩罗　　于中而宴默
  或食赡部果　　及饮甘露味
  具足诸神通　　而常修此观
  过去未来世　　坐于莲华台
  结加住等引　　如是常观察
  善摄诸根故　　不散一切境
  如以钩制象　　住定亦复然
  世间若出世　　一切诸余定
  佛定净无垢　　贪爱皆遣除
  遍爱无色定　　无想等禅中
  见彼日月形　　莲花与深险
  如空火众色　　耶定非究竟
  拂除如是相　　得净无分别
  则见俱胝刹　　诸佛住等引
  同时共舒手　　以水灌其顶
  即入于佛地　　示现众色形
  既得种种身　　则具萨婆若
  力通及自在　　正定陀罗尼
  如是等功德　　莫不皆成就
  分析于诸色　　乃至观极微
  自性无所有　　仇如于兔角
  无分无分别　　蕴有蕴亦然
  同于幻所作　　一切皆如是
  此中无业果　　亦无作业人
  无能作世间　　设有作能作
  能作待于作　　何名能作人
  此言成过患　　说作者清净
  我者成诸境　　地轮依水轮
  及有情世间　　次第而安布
  诸趣各差别　　彼此互往来
  于事起诸根　　而能取于境
  此等非由我　　皆是于分别
  展转而变异　　同于乳酪酥
  如是生住灭　　计业与非业
  定者常观此　　如干城与梦
  无始来戏论　　熏习于有情
  种种之过咎　　而生分别业
  诸根犹如幻　　境界同于梦
  能作所作业　　定者能远离
  恶觉微劣者　　迷惑生妄计
  分别于能作　　一切诸世间
  或谓摩尼珠　　金银等众矿
  鸟兽色差别　　刺端铦以利
  此等皆不同　　应知无作者
  世间相差别　　皆从分别生
  非胜性微尘　　无因自然等
  恶觉者妄计　　不知其体性
  为业为非业　　如是起分别
  如毒在于乳　　随变与相应
  一切处分别　　诸法亦如是
  是性亦不生　　是性亦不灭
  惑者不能了　　种种异分别
  世间唯积集　　定者乃能观
  汝等应勤修　　无思业非业
  有情互来往　　如日月超回
  在空无所依　　随风而运转
  业性甚微隐　　密严者能见
  修诸胜观行　　不为甚所羁
  如火燎长焚　　须臾作灰烬
  智火焚业薪　　当知亦如是
  又如灯破闇　　一念尽无余
  诸业习暗冥　　无始之熏聚
  牟尼智灯起　　刹那顿皆灭

    大乘密严经辩观行品第五

  尔时金刚藏　　菩萨摩诃萨
  复告于大众　　诸仁应谛听
  譬如空闲地　　欲造立宫室
  匠人资土木　　然后方得成
  谛观诸物中　　二皆无舍宅
  亦如于众指　　和合以成拳
  离指而推求　　拳体不可得
  军师及车乘　　城邑与园林
  云物须山川　　瓶衣等诸相
  皆是假和合　　智者了如梦
  如是身舍宅　　诸界所集成
  蕴积犹崇山　　攲危如朽屋
  不生亦不灭　　非自亦非他
  如乾闼婆城　　如云亦如影
  复如热时焰　　亦如观绘事
  相自于妄现　　性净离有无
  亦如盲与跛　　相假而得行
  自性无能持　　凡愚身亦尔
  分析至极微　　空名无实物
  极微不可得　　诸法亦如是
  瑜伽净慧者　　作是思惟时
  便于色声等　　远离于觉念
  一切意息已　　泰然得解脱
  不爱于有情　　常乐于等持
  设有诸天仙　　姝丽女人等
  而来供养者　　如观梦无染
  身虽住于此　　外道不能见
  持明与梵天　　亦不睹其顶
  当生摩尼宫　　自在而游戏
  与诸明妃众　　离欲常欢娱
  此之观行法　　萨埵之境界
  仁应速修习　　发于勇猛心
  当生光明宫　　利益于三有
  则断贪欲分　　及离嗔恚痴
  能诣大密严　　寂静殊胜处
  彼无死境界　　亦非识所行
  远离于诸相　　非分别所得
  为此微妙处　　瑜伽者相应
  是故修观行　　希求于彼土
  既胜于贪恚　　无我亦无人
  胜定汝应修　　勿生于三毒
  若执于境界　　则有二觉生
  犹如美女人　　曼脸而缜发
  多欲者见已　　爱着而思惟
  迷惑生染觉　　专想无余念
  行来及坐起　　饮食与眠睡
  彼女之容姿　　常现于心想
  如此之恶慧　　皆由妄境生
  溺在境淤泥　　是故不应着
  或如诸世间　　邪慧妄分别
  于牛及山羊　　设婆与麋鹿
  见彼有角故　　执之以为实
  而于彪兔等　　便生无角解
  若非见牛角　　于兔宁执无
  世间亦复然　　妄见有所得
  后求体非实　　便言法定无
  未舍分别来　　常生是邪觉
  仁应审观察　　心行诸境界
  皆如妄所得　　角与无角等
  若诸修行者　　能作如是观
  随其所意乐　　或作转轮王
  升空而往还　　具有大威力
  或生日月殿　　及诸星宿宫
  四王忉利天　　焰摩及兜率
  化乐与他化　　摩尼宝殿中
  色界梵众身　　并十梵天处
  无烦及无热　　善见与善现
  阿迦尼吒宫　　自在而游戏
  空识无所有　　非想非非想
  住彼渐除欲　　乃至诸佛刹
  常游微妙定　　解脱之境界
  譬如因破瓶　　而乃成于瓦
  坏性刹那现　　于常见无常
  种子生于芽　　芽生种已坏
  又如彼陶匠　　以泥而作瓶
  泥若是奢摩　　瓶亦如其色
  或时彼匠者　　兼用杂色泥
  比至烧已成　　各随其泥色
  从箭竹生葱　　从角生于蒜
  秽蝇与败蜜　　各得生于虫
  当知世间果　　似因不似因
  皆因变坏故　　乃得生于果
  众尘成所作　　体性不变坏
  皆是世愚夫　　而生妄分别
  能作我内我　　胜我不可得
  亦无于意我　　亦无积集因
  及以亲生因　　不从识缘有
  智者之境界　　善巧力所生
  拔除烦恼刺　　降魔并眷属
  世间贪爱尽　　如蜜能消瘦
  诸仙由有贪　　流转生诸趣
  多时所熏习　　譬如嗔恚蛇
  烦恼火烧然　　流转险恶趣
  离贪即解脱　　常勤修观行

    大乘密严经趣入阿赖耶品第六

  尔时金刚藏　　菩萨摩诃萨
  复告诸大众　　仁等应当知
  我昔蒙佛力　　加持得妙定
  明见俱胝刹　　修行世定者
  诸佛与佛子　　清净所住处
  于中唯密严　　安乐最第一
  诸佛坐莲花　　有如殊妙殿
  我等从定起　　一心以瞻仰
  自见住密严　　佛子众围绕
  复见解脱藏　　住在于宫中
  身量如指节　　色相甚明朗
  如空净满月　　如阿恒思花
  我即心自念　　是谁难思事
  即便见已身　　在于彼腹内
  亦于中普见　　一切诸世间
  莲花藏佛子　　以佛神力故
  亦皆如是见　　咸叹不思议
  天中天作已　　即摄威神力
  大众悉如故　　希有妙难思
  瑜只种种色　　是佛之境界
  诸仁应当知　　佛昔为菩萨
  从彼欢喜地　　得至于离垢
  发光及焰慧　　难胜与现前
  远行及不动　　善慧法云地
  获得陀罗尼　　生无尽句义
  首楞严等定　　及以意成身
  细性与轻性　　大性及意乐
  尊贵欲寿等　　获斯八自在
  如应而显现　　游戏于密严
  名称妙光明　　功德皆成就
  转复得清净　　现成等正觉
  化为佛菩萨　　种种妙色像
  自然遍一切　　而转妙法轮
  速令诸众生　　以智断诸惑
  利乐诸趣已　　还住密严中
  或有诸大士　　见佛现身色
  庄严吉祥相　　光明自然发
  炽盛如化聚　　住于莲花宫
  与诸观行人　　嬉游安乐定
  三摩地自在　　处所最殊胜
  或见于大树　　紧那罗王身
  现于百千亿　　种种之变化
  光明皎如月　　遍照诸国王
  或见兜率天　　无量诸佛子
  身如帝青色　　功德相庄严
  首饰摩尼冠　　坐于殊胜殿
  光明普照耀　　一切智通达
  或见于普贤　　具有大威力
  得于一切智　　四无碍辩才
  身相现光明　　独胜无伦匹
  住于满月殿　　密严之定海
  遍现众色像　　贤圣所称叹
  无量诸天众　　及乾闼婆等
  明仙及国王　　眷属众围绕
  或见最胜子　　并诸观行师
  寂静而住禅　　俨如在睡眠
  远离于沈怠　　顺行诸佛教
  勤苦而清羸　　示同于外道
  六欲及梵天　　有顶至赡部
  于中而现化　　多种之光明
  神通调御者　　赫奕而炽盛
  或见为导师　　降胎并诞育
  出家修静虑　　乃至般涅槃
  佛智不思议　　一切皆圆满
  得自在无畏　　人天等归依
  仁者应当知　　诸佛之体性
  智慧最无比　　唯佛所能知
  如释迦已获　　人中胜师子
  汝等咸当得　　生信勿怀疑
  信即为佛体　　必当得解脱
  或为彼天主　　及以诸粟散
  乃至生梵宫　　而作转轮王
  转生莲花藏　　在彼佛会中
  莲花而化生　　获大精进力
  由此降魔众　　及欲熏习因
  志意无怯弱　　证成一道法
  绍继于佛事　　得王诸国土
  若欲得作佛　　当净佛性道
  种姓既净已　　诸佛即授记
  瑜只转觉悟　　不久当成佛
  一切修行者　　而为作依怙
  譬如彼大地　　亦为众所依
  如于妙行者　　能疗一切病
  觉者亦如是　　能除虚妄疾
  得无分别心　　支解不倾动
  内外之境界　　了达皆唯识
  能远离于我　　亦离于我所
  无能害所害　　及以于害具
  一切悉皆是　　意识之境界
  皆依阿赖耶　　如是妄分别
  如珠合日光　　相感而生火
  此火非珠出　　亦非从日生
  心意识亦尔　　根境意和合
  能生于诸心　　如海起波浪
  此性非阳焰　　亦非于梦幻
  非同如是等　　迷惑之所取
  非同龟蛙毛　　及与于兔角
  又如雷电合　　震发而生火
  此火为从水　　为从雷电生
  竟无有定知　　此火从生处
  如火为从水　　造作于瓶等
  欲等诸心法　　与心而共生
  和合无定性　　当知亦如是
  心境不思议　　密严者知见
  有情之藏护　　无始妙俱生
  如涅槃虚空　　择灭无为性
  远离于三世　　清净常圆满
  如月有亏盈　　显现诸国土
  循环体是一　　其性无增减
  愚夫所分别　　见月有增减
  往来于四洲　　而实无盈缺
  如是之藏识　　普现有情界
  其体无增减　　圆洁常光明
  愚夫妄分别　　恒于赖耶识
  计著有增减　　应知亦如是
  若有于此识　　能正而了知
  即便得无漏　　转依位差别
  如是差别法　　得者甚为难
  藏识亦如是　　与七识俱转
  熏习以相应　　体性而无染
  犹如河中木　　随水以漂流
  而木与于流　　体相各差别
  藏识亦如是　　诸识习气俱
  而恒性清净　　不为其所业
  清净与杂染　　皆依阿赖耶
  圣者现法乐　　等引之境界
  人天等诸趣　　一切佛刹土
  如是染净法　　如来藏为因
  由彼悟成佛　　为诸乘种性
  一切诸众生　　有具于威力
  自在诸功德　　殊胜诸吉祥
  乃至险恶处　　上中下差别
  赖耶恒住中　　遍为作依止
  悉是诸有情　　无始时来果
  以诸业习气　　而能自增长
  亦复而增长　　所余之七识
  由是之愚夫　　执以为内我
  能作所依我　　轮回于生死
  意识在身中　　迅疾如风转
  业风所吹动　　遍住于诸根
  常与七识俱　　流转如波浪
  微尘与胜性　　自在及时方
  悉是净赖耶　　于中妄分别
  赖耶由业力　　及爱以为因
  成就诸世间　　种种之品类
  愚夫恒不了　　执之为作者
  此识之体相　　微细甚难知
  未见于真实　　心迷不能觉
  常于根境意　　而生于爱着
  金刚藏复言　　无畏诸佛子
  如是赖耶体　　云何不见闻
  众身之所依　　性净恒无染
  具足三十二　　佛相及轮王
  遍于三界中　　而现种种色
  犹如净空月　　众星所环绕
  藏识与诸识　　住身亦如是
  亦如欲天主　　天女众围绕
  显于宝宫殿　　藏识亦如是
  如江海诸神　　水中而自在
  藏识处于世　　当知亦如是
  如龙依水天　　如百川归海
  如树王依地　　现心亦如是
  如日在宫殿　　旋绕妙高山
  诸天皆敬礼　　佛地心亦尔
  十种诸地中　　修行一切行
  在于菩萨身　　显现于大海
  遍利与安乐　　如来常称赞
  地地皆清净　　故号为佛子
  在于菩萨身　　是即名菩萨
  佛与诸菩萨　　皆是赖耶名
  佛及最胜子　　已授当授记
  广大阿赖耶　　当成等正觉
  即此赖耶体　　密严者能见
  由最胜瑜伽　　妙定相应故
  诸佛与缘觉　　声闻及外道
  证理无畏人　　所观皆此识
  种种诸识境　　皆从心所变
  瓶衣等众物　　如是性皆无
  悉依阿赖耶　　所见皆迷惑
  谓以诸熏习　　妄生能所取
  体非如幻化　　非阳焰毛轮
  非生非不生　　空性空远离
  有无皆无性　　长短等亦然
  智者观幻事　　此皆唯幻术
  未曾有一物　　与幻而同起
  有情所分别　　如幻而可见
  阳焰毛轮相　　二俱不可得
  离一亦无二　　无过世当世
  此皆识变异　　无幻无幻名
  诸性无所得　　是幻幻所作
  世间有迷惑　　其心不自在
  妄说有能幻　　幻成种种物
  动摇及往来　　虽见皆非实
  如铁因磁石　　所向而转移
  藏识亦如是　　随于分别种
  一切诸世间　　无处不周遍
  如日摩尼宝　　无思及分别
  此识遍诸处　　见之谓流转
  不死亦不生　　本非流转法
  如梦见生死　　觉悟即解脱
  佛子若转依　　即名解脱者
  此即是诸佛　　最胜之教理
  审量一切法　　如称如明镜
  照曜如明灯　　试验如金石
  正道之标相　　远离于断灭
  修习胜定者　　皆由清净因
  令离诸杂染　　转依而显现

大乘密严经卷中大乘密严经卷下

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

    我识境界品第七

尔时金刚藏菩萨摩诃萨。遍观十方。从髻珠中出大光明。照诸世界及他化自在天宫。并密严中诸佛子众。放斯光已。即告一切佛法如实见菩萨言。仁主雪山之中有一恶兽名为能害。百千变诈以取诸兽。应可食者杀而食之。若见壮兽名能之者。即须便为呼子之声害而食之。若时或见有角之兽。便现有角与其相似而往亲附。无令所畏杀而食之。见牛羊等种种诸兽。悉同彼形而肆其害。仁主如彼能害现种种形以杀诸兽。一切外道亦复如是。于阿赖耶所生我见执着我相。犹如恶兽变种种形。亦如彼彼自类计我各各差别。乃至极小犹如微尘

仁主是诸我执依何而住。不住于余但自住识。计我之人言我与意根境和合而有识生。本无有我如花与衣合即有香气。若未和合衣即无香。是故当知但唯有识心及心法。若离于识心心所法则无有我。如器中果如灯照瓶。如伊尸迦文阇之草。而可得者但以因缘心心法生。此中无我亦无有生。微妙一相本来寂静。此是觉悟胜观行者自证境界。如彼恶兽多所伤杀。然诸外道亦复如是。养育增长世间恶见无知法智。而强分别执有执无。若一若多我我所论。所以者何由不觉悟唯识性故。思渴耶慧往来驰鹜生杀轮转。远离诸佛菩萨善友。违背解脱动摇正慧。不能修治八支圣道。于彼三乘乃至一乘都无所证。由起执着不见圣谛。于密严名号尚不得闻。何况其土而能得入

仁主诸深定者咸于此识净除我见。汝及诸菩萨摩诃萨亦应如是。既自勤修复为人说。令其速入密严佛土

    大乘密严经阿赖耶即密严品第八

  尔时金刚藏　　为明此藏识
  即密严之义　　告如实见言
  如磁石吸铁　　常能自转动
  如蕴车性定　　转动由习气
  草木土竹等　　及绳以成舍
  和合而可见　　身蕴亦如是
  起尸磁石铁　　转动如有情
  一切皆亦然　　如是蕴无我
  时宝手菩萨　　白众色王言
  王今应请问　　金刚藏定者
  一切诸世间　　所有于众汝
  无觉离于觉　　远离诸言诠
  相应不相应　　二种之名字
  彼世间所有　　自性云何住
  此会诸佛子　　专心咸愿闻
  众色最胜王　　即随义而问
  名相等境界　　一切世间法
  为唯是分别　　为离分别有
  如其所立名　　是名依何住
  金刚藏闻已　　即告色王言
  一切唯有名　　亦唯想安立
  从能诠异故　　所诠不可得
  四蕴唯名字　　是故说为名
  如名摩纳婆　　但名无有体
  诸佛及佛子　　说名唯在相
  离相而有名　　不可得分别
  是故依诸相　　分别有诸名
  如匿兔未勿　　假名不可得
  于相无所有　　愚夫妄分别
  世间亦如是　　离相无有名
  瓶衣车乘等　　名言所分别
  名相虽可说　　体性无所有
  世间众色法　　但相无有余
  唯依相立名　　是名无实事
  王应观世法　　离名无所有
  但以分别心　　而生于取着
  若离于分别　　取着即不生
  无生即转依　　证于无尽法
  是故大王等　　常应观想事
  但是分别心　　离此即无有
  形相体增长　　散坏资与身
  如是等众名　　皆唯色之想
  想名及分别　　体性本无异
  随于世俗仪　　建立名不同
  若舍离名字　　而求于物体
  过去及未来　　此皆不可得
  但诸识转变　　无有所知法
  所知唯是名　　世间悉如是
  以名分别法　　法不称于名
  诸法性如是　　不住于分别
  以法唯名故　　相即无有体
  相无名亦无　　何处有分别
  若得无分别　　身心恒寂静
  如木火烧已　　毕竟不复生
  譬如人负担　　是人名负者
  随其担有殊　　担者相差别
  名如所担物　　分别名担者
  以名种种故　　分别各不同
  如见杌为人　　见人以为杌
  人杌二分别　　但有于名字
  诸大和合中　　分别以为色
  若离于诸大　　体终不可得
  如德依瓶处　　瓶依名亦然
  舍者而取瓶　　瓶终不可得
  瓶不住瓶体　　名岂住于名
  二合分别生　　名量亦非有
  住于如是定　　其心不动摇
  譬如金石等　　本来无水相
  与火共和合　　若水而流动
  藏识亦如是　　体非流转法
  诸识共相应　　与法同流转
  如铁因磁石　　周回而转移
  二俱无有思　　状若有思觉
  赖耶与七识　　当知亦复然
  习气绳所牵　　无人而若有
  遍满有情身　　周流于险趣
  如铁与磁石　　展转不相知
  或离于险趣　　而得住于地
  神通自在力　　如幻首楞严
  乃至陀罗尼　　莫不皆成满
  赞佛实功德　　以之为供养
  或现无量身　　一身无量手
  肩头口及舌　　展转皆无量
  往诣十方国　　供养诸如来
  雨花及衣服　　头冠与璎珞
  种种宝庄严　　积如须弥等
  供养萨婆若　　佛及诸佛子
  或作宝宫殿　　如云备众彩
  化现诸天女　　游处于其中
  妓乐众妙音　　供养于诸佛
  或与佛菩萨　　游止常共俱
  一切诸魔怨　　自在而降伏
  得自觉圣智　　正定以庄严
  已转于所依　　即见法无我
  五法三自性　　及与八种识
  能成就诸明　　住定常供养
  或现身广大　　或现如微尘
  种种诸色身　　供养于诸佛
  或身纳诸刹　　刹入芥子中
  大海为牛迹　　牛迹或为海
  其中诸有情　　无有所逼恼
  平等施资用　　如地及日月
  如水与火风　　如宝洲妙药
  普能作饶益　　长养诸有情
  诸法不生灭　　不断亦不常
  不一亦不异　　不来亦不去
  妄立种种名　　是为遍计性
  诸法犹如幻　　如梦与干城
  阳焰水中月　　火轮云雷等
  此中妄所取　　是为遍计性
  由彼彼名诠　　以名彼彼法
  于彼不可得　　是为遍计性
  一切世间法　　不离于名色
  若离于能诠　　所诠不可得
  如是遍计性　　我说为世间
  眼色等为缘　　因三和合起
  声依桴鼓发　　芽从地种生
  宫殿与瓶衣　　无依众缘起
  有情及诸法　　此悉依他性
  若法是无漏　　其义不可舍
  自觉圣智境　　此性名具实
  诸法相差别　　已说其自性
  若离自性门　　诸法不明了
  如众物和合　　现作幻化形
  众色虽不同　　性皆无决定
  世事悉如是　　种种皆非实
  妄情之所执　　遍计无有余
  譬如摩尼宝　　随色而像现
  世间亦复然　　但随分别有
  体用无所在　　是为遍计性
  如乾闼婆城　　非城而见似
  亦非无有因　　而能如是见
  世间种种物　　应知亦复然
  日月等宫殿　　诸山及宝山
  烟云相击触　　未尝有杂乱
  无共无自性　　体性皆非有
  但是所分别　　遍计之自性
  诸物非因生　　亦非无有因
  若有若非有　　此皆情所执
  名依于相起　　二从分别生
  正智及如如　　远离于分别
  心如相显现　　相为意所依
  意与五心生　　犹如海波浪
  习气无有始　　境界亦复然
  心因习气生　　境令心惑乱
  依止赖耶识　　一切诸种子
  心如境界现　　是说为世间
  七识阿赖耶　　展转互相生
  如是八种识　　不常亦不断
  一切诸世间　　似有而安布
  有计诸众生　　我等三和合
  发生种种识　　了别于诸境
  或有妄计言　　作者业因故
  生于梵天等　　内外诸世间
  世间非作者　　业及微尘作
  但是阿赖耶　　变现似于境
  藏识非缘作　　藏亦不非缘
  诸识虽流转　　无有三和合
  赖耶体常住　　众识与之俱
  如轮与水精　　亦如星共月
  从此生习气　　新新自增长
  复增长余载　　余识亦复然
  如是生死转　　悟者心无转
  譬如火烧木　　渐次而转移
  此木既已烧　　复更烧余木
  依止赖耶识　　无漏心亦然
  渐除诸有漏　　永息轮回法
  此是现法乐　　成就三摩地
  众圣由是生　　从刹至于刹
  譬如微妙金　　在矿不能见
  智者巧陶炼　　其金乃明显
  藏识亦如是　　习气之所缠
  三摩地净除　　觉者常明见
  如酪未攒摇　　酥终不可得
  是故诸智者　　攒酪而得酥
  藏识亦复然　　诸识所缠覆
  密严诸定者　　勤观乃能得
  密严是大明　　妙智之殊称
  佛子勤修习　　生于此刹中
  色及无色界　　空识非非想
  于彼常勤修　　而来生是处
  此中诸佛子　　威光犹日月
  修行得正定　　演说相应道
  诸佛与灌顶　　咸皆授其位
  如来所证法　　随见而转依
  虽处密严场　　应物而变化
  随彼爱乐法　　住空而演说
  是时金刚藏　　复告大众言
  赖耶无始来　　为戏论薰习
  诸业所系缚　　轮转无有穷
  亦如于大海　　因风起波浪
  恒生亦恒灭　　不断亦不常
  由不悟自心　　随识境界现
  若了于自心　　如火焚薪尽
  通达于无漏　　则名为圣人
  藏识变众境　　弥纶于世间
  意执我我所　　思量恒流转
  诸识类差别　　各各了自境
  积集业为心　　遍积集名意
  了别名为识　　五识取现境
  如翳见毛轮　　随见而迷惑
  于似色心中　　非色计于色
  譬如摩尼珠　　日月光所照
  随其所应现　　各雨自类物
  阿赖耶亦尔　　如来清净藏
  和合于习气　　变现周世间
  与无漏相应　　雨诸功德法
  譬如乳变异　　成酪至酪浆
  藏识亦如是　　变似于众色
  如翳见毛轮　　有情亦复尔
  以恶习气翳　　住藏识眼中
  于诸非色处　　此所见诸色
  犹如于阳焰　　远离于有无
  习赖耶所现　　仁者依眼色
  而生似色识　　如幻住眼中
  飘动犹热焰　　色皆是藏识
  与色习相应　　变似体非有
  愚夫妄分别　　诸昏醉放逸
  坐卧及狂走　　顿起诸事业
  皆是赖耶识　　犹如盛赫日
  舒光照于地　　蒸气如水流
  渴兽望之走　　赖耶亦复尔
  体性实非色　　而似于色现
  恶觉妄生者　　如磁石吸铁
  迅速而转移　　虽无于情识
  似情识而动　　如是赖耶识
  为生死所摄　　往来于诸趣
  非我而似我　　如海中漂物
  无思随水流　　赖耶无分别
  依身而运动

  譬如二象斗　　被伤者永退
  赖耶亦如是　　断染无流转
  譬如净莲华　　离泥而皎洁
  人天皆受用　　莫不咸珍敬
  如是赖耶识　　出于习气泥
  转依得清净　　佛菩萨所重
  譬如殊胜宝　　野人所轻贱
  若用饰冕旒　　则为王顶戴
  如是赖耶识　　是清净佛性
  凡位恒杂染　　佛果常宝持
  如美玉在水　　苔衣所缠覆
  赖耶处生死　　习气萦不现
  于此赖耶识　　有二取相生
  如蛇有二头　　随乐而同往
  赖耶亦如是　　与诸色相具
  一切诸世间　　取之以为色
  恶觉者迷惑　　计为我我所
  若有若非有　　自在作世间
  赖耶虽变现　　体性恒甚深
  于诸无知人　　悉不能觉了
  譬如于幻师　　幻作种种兽
  或行而或走　　似有情非实
  赖耶亦如是　　幻作于世间
  一切诸有情　　体性无真实
  凡愚不能了　　妄生于取着
  起微尘胜性　　有无异分别
  及与于梵天　　丈夫等诸见
  分别皆是意　　分别于世间
  此之分别见　　本来无有实
  譬如画中质　　亦如虹霓像
  及以云中物　　翳眼见毛轮
  女人窥镜容　　如梦观众色
  如帝弓谷响　　树影与干城
  热时阳焰水　　池中明月像
  如是诸计度　　于赖耶妄取
  观察是等时　　谛了唯藏识
  即达世间相　　所依一切法
  是诸分别见　　即皆而转灭
  赖耶是意等　　诸法习气依
  常为于分别　　心之所扰浊
  若离于分别　　即成无漏道
  常恒而不变　　犹若于虚空
  若于阿赖耶　　获得三摩地
  则生无漏法　　如意定解脱
  及以四无畏　　十力并善巧
  自在与神通　　如是诸功德
  起十究竟愿　　意成微妙身
  永转于所依　　识界常安住
  体同虚空性　　不坏亦不尽
  如来悉明见　　世间无增减
  有情复不生　　涅槃者非灭
  此刹及余刹　　同于一法性
  诸佛出于世　　或不出于世
  法性本常住　　不常亦不断
  又若解脱者　　而有情界灭
  即坏于如来　　一切之智性
  三世诸佛境　　不得于平等
  又若般涅槃　　有情界灭者
  是谁离于苦　　得有余无余
  降魔伏邪见　　皆应是妄说
  是故应当知　　诸胜观行者
  若证于解脱　　其身则常住
  永离于取蕴　　灭除诸习气
  譬如以热铁　　投之于冷水
  热势虽已除　　其铁体无坏
  诸仁应当知　　阿赖耶如海
  常为於戏论　　粗重风所击
  五法三自性　　诸识浪相续
  所有于境界　　其相而飘动
  于无义处中　　似义实无体
  若悟则皆空　　转依恒无尽
  住密严如月　　影现于十方
  应知赖耶识　　行于蕴稠林
  末那为先导　　意识能决了
  色等一切境　　及以五识身
  与根境和合　　了于现境界
  自境之所取　　皆是阿赖耶
  藏识与寿暖　　及触和合性
  末那依此识　　识复住于意
  所余五种识　　亦住于自根
  心意及诸识　　而安住于蕴
  为业习系缚　　流转无有穷
  如是所有业　　皆由于贪爱
  既以业受身　　复以身造业
  舍于此身已　　更受于余身
  前后以依因　　徐行如水蛭
  心及诸心所　　相续生诸趣
  更展转积集　　住诸蕴稠林
  寿暖及与识　　若舍离于身
  身则无觉知　　犹如于木石
  藏识是为心　　执我名为意
  能取诸境界　　以是说为识
  采集业为心　　意为遍采集
  意识能遍了　　五识现分别
  心能持于身　　末那着诸趣
  意识能遍了　　五识缘自境
  藏识以为因　　从是生余识
  意意识所缘　　无间而流转
  五识复更待　　增上缘而生
  同事自根事　　是为增上故
  是身如起尸　　亦如热时焰
  随行因缘转　　非妄亦非实
  为受之所牵　　性空无有我
  意等诸转识　　与心而共生
  五识复更依　　意识而因起
  如是一切时　　大地而俱转
  赖耶为于爱　　所熏而增长
  既自增长已　　复增于余识
  展转不断绝　　犹如于井轮
  以有诸识故　　众趣而生起
  于是诸趣中　　识复得增长
  识与世间法　　更互以为因
  譬如河水流　　前后而不断
  亦如芽与种　　相续而转生
  各各相差别　　分明而显现
  行识亦如是　　既三和合已
  而复更和合　　差别相而生
  如是而流转　　常无有断绝
  内外一切法　　皆因此而起
  愚不了唯心　　汝等勤观察
  时众色王等　　复向金刚藏
  而作如是言　　金刚藏无畏
  善入于密严　　能演一切法
  佛及诸佛子　　正定而思惟
  无比甚奇特　　显明于法相
  金刚藏无畏　　垂见为宣说
  尊处摩尼宫　　居师子胜座
  最胜子围绕　　往于密严定
  愿为诸佛子　　说瑜伽胜法
  此是月幢佛　　为众所开演
  彼众当来此　　愿说而无倦
  此月幢如来　　亦现多神变
  于欲界宫殿　　及于色界中
  与佛子围绕　　诸天皆侍卫
  所说胜理趣　　密严无畏法
  彼诸瑜伽者　　闻说如是已
  得自觉圣智　　内证之境界
  怖于尼夜摩　　及正位之乐
  不住于实际　　定中互观察
  而皆各念言　　谁已证实相
  观行之上首　　愿得见斯人
  此众咸一心　　复更重思惟
  何者是于定　　云何为非定
  复于何所定　　又复以何法
  为定所待缘　　彼诸佛子等
  复于何所定　　以三摩地力
  见密严土中　　清净最胜子
  菩萨众之王　　首戴于宝冠
  具三十二相　　及以随形好
  而作于严饰　　彼诸佛子等
  悉皆从定起　　挂微妙宝璎
  从无量佛土　　而来于此会
  同共以一心　　瞻仰金刚藏
  大力瑜伽尊　　彼等皆思惟
  得法乐而请

  金刚藏见已　　周顾于四方
  发于和雅音　　微笑而告曰
  汝等诸佛子　　一心咸谛听
  瑜只定境界　　甚深不思议
  非分别所知　　定及缘亦尔
  远离欲不善　　及以诸散动
  有寻伺喜乐　　寂静入初禅
  如是渐次第　　四八至于十
  着我诸外道　　常修习此定
  声闻辟支佛　　亦复皆如是
  各知于世间　　诸法之自相
  蕴处如空聚　　一切皆无我
  无思无动作　　但三和合生
  如机关起尸　　本无能作者
  外道修是定　　起于空性见
  此人迷法相　　坏于一切法
  若修佛妙定　　善知蕴无我
  即发胜福聚　　灭除诸恶见
  一切皆唯心　　无能相所相
  无界亦无蕴　　一切皆无相
  分析至微尘　　此皆无所住
  愚夫妄分别　　彼地水等性
  不知其性者　　取于如是相
  妙色及恶色　　似色余亦然
  如空中虹霓　　云霞等众彩
  思惟如骨琐　　遍满于世间
  及遍处想观　　观于诸大等
  身有色无色　　定者常谛思
  若于缘一心　　即缘说清净
  如其所分别　　即彼成所缘
  非定非定者　　妄计以为定
  定者在定中　　了世皆藏识
  法及诸法相　　一切皆除遣
  获于胜定者　　善说于诸定
  破诸修定人　　妄智所知法
  若人生劣慧　　取法及于我
  自谓诚谛言　　善巧说诸法
  计着诸法相　　自坏亦坏他
  无能相所相　　妄生差别见
  甜味能除热　　苦酸碱上淡
  辛味除于冷　　碱能已风疾
  黄痰变畏故　　共生于疟病
  或时但因风　　或因三和合
  疾既有差别　　古仙设众方
  石蜜等六分　　沙糖及诸味
  能除有情身　　种种诸疟病
  若法有自性　　及以诸相者
  药无除病能　　病者不应差
  云何世咸见　　服药病消除
  定者了世间　　但是赖耶识
  变异而相续　　譬如众幻兽
  无能相所相　　无蕴及蕴者
  亦无支分德　　及以有支分
  世间无能作　　亦无有所作
  无尘积世间　　无方处往者
  无初最微细　　渐次如一指
  乃至三指量　　宝物转和合
  求那各差别　　如是义皆无
  非胜性作世　　亦非时能生
  亦非爱乐性　　乃三法所作
  亦非无有因　　自然而得有
  由斯业习气　　扰浊于内心
  依心及眼根　　种种妄分别
  意及于意识　　有情阿赖耶
  普现于世间　　如幻师造物
  若能入唯识　　是则证转依
  若说于空性　　则知相唯识
  瓶等本无境　　体相皆心作
  非瓶似瓶现　　是故说为空
  世间所有色　　诸天等宫殿
  变异而可见　　皆是阿赖耶
  有情身所有　　从头至手足
  顿生或渐次　　无非阿赖耶
  习气浊于心　　凡愚不能了
  此性非是有　　亦复非是空
  如人以诸物　　系破于瓶等
  物体若是空　　即无能所破
  我如妙高山　　此见未为碍
  憍慢而着空　　此恶过于彼
  自处为相应　　不应非处说
  若演于非处　　甘露即为毒
  一切诸有情　　生于种种见
  欲令断诸见　　是故说空理
  闻空执为实　　不能断诸见
  此见不可除　　如病翳所舍
  譬如火烧木　　木尽火不留
  见木若已烧　　空火亦应灭
  诸见得灭时　　生于智慧火
  普烧烦恼薪　　一切皆清净
  牟尼由此智　　密严而解脱
  不见以兔角　　触坏于大山
  曾无石女儿　　执箭射于物
  未闻欲斗战　　而求兔角弓
  何有石女儿　　能造于宫室
  一切法空性　　与法常同体
  始于胎脏时　　色生便坏灭
  离空无有灭　　离色无有空
  如月与光明　　始终恒不异
  诸法亦如是　　空性与之一
  展转无差别　　所为皆得成
  是身如死尸　　本来无自性
  贪爱绳系缚　　境界所牵动
  说微妙空理　　为净于诸见
  其有智慧人　　应当一心学
  譬如工幻师　　以诸咒术力
  草木等众数　　随意之所作
  依于根及爱　　色明与作意
  发生于明识　　无实如幻焰
  是识无来处　　亦不去余方
  诸识性皆尔　　有无不变着
  如毛轮兔角　　及以石女儿
  本来无有体　　妄立于名字
  师子虎熊罴　　马驴馲驼类
  [央/龜]龟与玳瑁　　彼等皆无角
  何故不分别　　唯言兔角无
  最胜谈论人　　云何不成立
  为慧者显示　　但彼妄分别
  外道众迷惑　　如喑及聋瞽
  彼无超度智　　亦无内证法
  但随他语转　　何用分别为
  若妄起分别　　不生于密严
  定者获等至　　及能生此国
  譬如天宫殿　　日月及众星
  环绕妙高山　　皆由风力转
  七识亦如是　　依于阿赖耶
  习气之所持　　处处恒流转
  譬如依大地　　能生卉木类
  一切诸有情　　乃至众珍宝
  如是赖耶识　　众识之所依
  譬如孔雀乌　　毛羽多光色
  雄雌相爱乐　　鼓舞共欢游
  如是阿赖耶　　种子及诸法
  展转相依住　　定者能观见
  譬如百川注　　日夜归大海
  众流无断绝　　海亦不分别
  如是赖耶识　　甚深无涯底
  诸识之习气　　日夜常归往
  如地有众宝　　种种色相殊
  诸有情受用　　随福而招感
  如是赖耶识　　与诸分别俱
  增长于生死　　转依成正觉
  善修清净行　　出过于十地
  入于佛地中　　十力皆圆满
  正住于实际　　常恒不坏灭
  现种种变化　　如地无分别
  如春众花色　　人鸟皆欣玩
  执持识亦然　　定者多迷取
  如是诸佛子　　无慧离真实
  于义不善知　　妄言生决定
  非法离间语　　诳惑于有情
  诸法别异住　　而别起言说
  譬如工幻师　　善用于咒术
  亦现种种花　　花果实无有
  如是佛菩萨　　善巧智方便
  世间别异住　　别异而变现
  说种种教门　　诱诲无穷已
  决定真实法　　密严中显现
  六界与十八　　十二处丈夫
  意绳之所牵　　有情以流转
  八识诸界处　　共起而和合
  从于意绳转　　前身复后身
  此流转丈夫　　随世因示现
  是一切身者　　续生无断绝
  六界与丈夫　　及以十二处
  十八界意行　　说为自在者
  尔时金刚藏　　菩萨摩诃萨
  说于诸界处　　丈夫之义已
  他化清净宫　　摩尼宝藏殿
  诸无畏佛子　　悉皆稽首礼
  他方佛菩萨　　来居此会者
  悉皆共同声　　而赞言善哉
  复有诸菩萨　　诸天及天女
  皆从本座起

  合掌一心敬　　递共相瞻顾
  而作如是言　　定中上首尊
  善为诸菩萨　　说妙丈夫义
  远离外道论　　最胜子宣示
  六界净丈夫　　但是诸界合
  随因以流转

  譬如众飞鸟　　空中现其迹
  又如离于木　　而火得炽然
  空中见鸟迹　　离木而有火
  我及诸世间　　未曾睹是事
  鸟飞以羽翰　　空中无有迹
  仁者说丈夫　　与鸟迹相似
  云何于诸有　　得有轮回义
  而说界丈夫　　常流转生死
  受诸苦乐果　　所作业无失
  如农夫作业　　功必不唐捐
  此果成熟已　　能生于后果
  身者于身中　　而修于善行
  前生后生处　　恒受人天乐
  或常修福德　　资粮为佛因
  解脱及诸度　　成于无上觉
  生天自在果　　观行见真我
  若离趣丈夫　　一切悉无有
  于业业果报　　所作无虚弃
  下从阿鼻狱　　上至于诸天
  谓有趣丈夫　　流转于生死
  内外诸世间　　种现牙生果
  此法似于彼　　彼从于此生
  若离趣丈夫　　得有轮回者
  如言石女子　　威仪而进退
  兔角有铦利　　从沙而出油
  会中诸菩萨　　诸天及天女
  说如是语已　　供养应供者
  即金刚藏尊　　及诸菩萨众
  供养事毕已　　同作如是言
  法眼具无缺　　因喻皆庄严
  能摧诸异论　　外道诸宗过
  既降伏他已　　显示于自宗
  是故大勇猛　　宜为速开演
  我等咸愿闻　　大慧者应说
  尔时金刚藏　　菩萨摩诃萨
  问诸天殷请　　即时而告言
  汝等诸天人　　一心应谛听
  此法深难思　　分别不能及
  瑜伽清净理　　因喻所开敷
  我现于密严　　今为汝宣说
  密严甚微妙　　定者殊胜处
  尔时金刚藏　　说如是语已
  复告于大树　　紧那罗王言
  大树紧那王　　汝应当观察
  云何诸法性　　性空无所有
  如是见相应　　于定不迷惑
  如饭一粒熟　　余粒即可知
  诸法亦复然　　知一即知彼
  譬如攒酪者　　尝之以指端
  如是诸法性　　可以一观察
  法性非是有　　亦复非是空
  藏识之所变　　藏以空为相
  大树紧那王　　即时而问曰
  云何心量中　　而有界丈夫
  云何生诸界　　坚湿及暖动
  尔时金刚藏　　菩萨摩诃萨
  闻其所说已　　而告如是言
  善哉大树王　　能发甚深问
  愿令修定者　　得诣于真实
  我今为汝说　　琴师应谛听
  汝昔自他化　　与诸眷属俱
  鼓乐从空来　　乘于宝宫殿
  如是诸天侣　　而同诣佛会
  抚奏妙宝琴　　其声甚和雅
  声闻在会者　　各递相谓言
  我乐见树王　　紧那众游戏
  及所乘宫殿　　妙宝以庄严
  汝奏琉璃琴　　众心皆悦动
  迦叶声闻等　　不觉起而舞
  由妙音和乐　　不能持本心
  时天冠菩萨　　告迦叶等言
  汝等离欲人　　云何而舞戏
  是时大迦叶　　白彼天冠士
  佛子有大力　　譬如毗岚风
  声闻无定智　　如黑山摇动
  虽离惑分别　　尚染习气泥
  分证于实际　　未断于诸习
  若舍诸粗重　　必当得菩提
  汝于微细境　　巧慧具诸论
  帝释世间明　　于彼法通达
  及紧那罗论　　如来清净理
  善于诸地相　　明了而决定
  端居宝殿中　　眷属共围绕
  光明净严好　　犹如盛满月
  观行得自在　　处众能问答
  问我界丈夫　　云何从心起
  汝及诸佛子　　咸应一心听
  如其诸界内　　心名为丈夫
  诸界因此生　　是义我当说
  津润生于水　　炎盛生于火
  动摇诸作业　　因斯起风界
  从于色分齐　　有虚空及地
  识与诸境界　　习气能生身
  眼及诸色等　　相状各不同
  此无门作门　　诸有恒相续
  时摩尼宝藏　　自在之宫殿
  持进大菩萨　　与诸最胜子
  俱是从座起　　稽首而作礼
  各持妙供具　　供养金刚藏
  覆以宝罗网　　同声而赞佛
  圣者善安住　　菩萨法云地
  悟入如来境　　应现实难量
  能为诸大士　　开示佛知见
  时紧那罗王　　并诸婇女等
  供养而赞叹　　金刚藏无畏
  摩尼宝宫殿　　严净胜道场
  为我等开演　　如来微妙法

尔时圣者观自在菩萨摩诃萨。慈氏菩萨摩诃萨。得大势菩萨摩诃萨。曼殊室利法王子菩萨摩诃萨。神通王菩萨摩诃萨。宝髻菩萨摩诃萨。天冠菩萨摩诃萨。总持王菩萨摩诃萨。一切义成就菩萨摩诃萨。如是等菩萨摩诃萨。及余无量修胜定者。皆是佛子。威德自在。决定无畏。善能开示观行之心。俱从座起。互相观察。问金刚藏菩萨摩诃萨而说偈言

  金刚自在尊　　能示于法眼
  诸佛所加护　　菩萨皆宗仰
  善达于地相　　巧能而建立
  佛子大力众　　同心皆劝请
  定王愿哀愍　　显示于密严
  佛及佛子等　　甚深奇特事
  此法最清净　　远离于言说
  化佛诸菩萨　　昔所未开敷
  自觉智所行　　见真无漏界
  微妙现法乐　　清净最无比
  具众三摩地　　无量陀罗尼
  诸自在解脱　　意成身十种
  殊胜色清净　　照明于法界
  善逝不思议　　严刹亦如是
  佛及诸菩萨　　身量如极微
  乃至如毛端　　百分中之一
  密严殊妙刹　　诸土中严胜
  如是观行者　　咸来生此中
  是皆何所因　　佛子愿宣说
  尔时金刚藏　　菩萨摩诃萨
  身如师子臆　　具三十二相
  以随好庄严　　将欲广开示
  观察彼大会　　犹如师子王
  知众堪听闻　　古先佛秘旨
  我今演法眼　　离于能所觉
  金刚藏即发　　清净梵音声
  迦陵频伽声　　广长舌相声
  巧妙无粗犷　　世间称叹声
  广略美畅声　　克谐钟律声
  高韵朗彻声　　干驮罗中声
  雄声与直声　　罽尸迦哀声
  歌咏相应声　　急声及缓声
  深远和畅声　　一切皆具足
  众德以相应　　闻之而离着
  心无有厌倦　　一切皆欣乐
  悉能尽通达　　所有音声相
  自然而普应　　无作无功用
  金刚藏菩萨　　口未曾言说
  所有诸音声　　但由本愿力
  从眉额及顶　　鼻端肩与膝
  犹如于变化　　自然出妙音
  普为诸大众　　开示于法眼
  勇猛金刚藏　　住于自在宫
  最胜子围绕　　清净而严洁
  如鹅王在地　　群鹅而翼从
  大定金刚藏　　处于师子座
  映蔽于一切　　所有修行人
  犹如月在空　　光映于列宿
  如月与光明　　而无有差别
  金刚藏威德　　与佛亦复然
  尔时如实见　　菩萨之大力
  修行中最胜　　住于瑜伽道
  即从座而起　　观察大众言
  奇哉大乘法　　如来微妙境
  一切佛国中　　佛子应顶礼
  无思离垢法　　诸佛所观察
  希有甚微密　　大乘清净理
  非恶觉境界　　转依之妙道
  八种识差别　　三自性不同
  五法二无我　　各各而开示
  五种习所缘　　生诸妄分别
  见此微妙法　　清净如真金
  得于真性者　　则住佛种性
  如来性微妙　　离声闻外道
  密严诸刹胜　　证者乃能往
  尊者金刚藏　　已得何等持
  所说净法眼　　是何等持境
  时无量菩萨　　复礼金刚藏
  大智金刚尊　　愿为我开演
  住何三摩地　　而能说是法
  此诸佛子等　　一切皆乐闻
  尔时金刚藏　　处自在宫殿
  观察于大会　　自心而念言
  此法不思议　　十力微妙境
  由慧之所持　　离当堪听受
  已见堪住者　　皆诸佛之子
  即时而告言　　汝等当谛听
  我今为汝说　　转依之妙道
  我为诸佛子　　他化自在众
  以得三摩地　　名大乘成德
  住于此定中　　演清净法眼
  亦见亿尘刹　　所有诸善逝
  那庾多尘亿　　在前而赞叹
  善哉汝所说　　此是瑜伽道
  我等悉皆行　　如是三摩地
  于斯得自在　　清净成正觉
  十方一切佛　　皆从此定生
  当知最殊胜　　非思量所及
  若有诸菩萨　　得住此定中
  即住不思议　　诸佛之境界
  证于自智境　　见三摩地佛
  变化百千亿　　乃至如微尘
  自觉圣智境　　诸佛所安立
  此法无诸相　　远离于声色
  名从于相生　　相从因缘起
  此二生分别　　诸法性如如
  于斯善观察　　是名为正智
  名为遍计性　　相是依他起
  远离于名相　　是名第一义
  藏识住于身　　随处而流转
  习气如山积　　深意之所缠
  求那有二门　　意识同时起
  五境现前转　　诸识身和合
  犹如有我人　　住在于身内
  藏识暴流水　　境界风所飘
  种种识浪生　　相续恒无断
  佛及诸佛子　　能知法无我
  已得成如来　　复为人宣说
  分析于说蕴　　见人无我性
  不知法无我　　是说为声闻
  菩萨所修行　　善达二无我
  观已即便舍　　不住于实际
  若住于实际　　便舍大悲心
  功业悉不成　　不得成正觉
  希有难思智　　普利诸有情
  如莲出淤泥　　色相甚严洁
  诸天圣人等　　见之生爱敬
  如是佛菩萨　　出于生死泥
  成佛体清净　　诸天所欣仰
  从初菩萨位　　或作转轮王
  或主乾闼婆　　阿修罗王等
  了悟大乘法　　获于如是身
  渐次而修行　　决定得成佛
  是故诸佛子　　宜应一心学
  所有杂染法　　及与清净法
  恒于生死中　　皆因赖耶转
  此因胜无比　　证实者宣示
  非与于能作　　自在等相似
  世尊说此识　　为除诸习气
  了达于清净　　赖耶不可得
  赖耶若可得　　清净非是常
  如来清净藏　　亦名无垢智
  常住无终始　　离四句言说
  佛说如来藏　　以为阿赖耶
  恶慧不能知　　藏即赖耶识
  如来清净藏　　世间阿赖耶
  如金与指环　　展转无差别
  譬如巧金师　　以净好真金
  造作指严具　　欲以庄严指
  其相异众物　　说名为指环
  现法乐圣人　　证自觉智境
  功德转增胜　　自共无能说
  现法诸定者　　了达境唯心
  得于第七地　　悉皆而转灭
  心识之所缘　　一切外境界
  见种种差别　　无境但唯心
  瓶依等众幻　　一切皆无有
  心变似彼现　　有能取所取
  譬如星月等　　依须弥运行
  诸识亦复然　　恒依赖耶转
  赖耶即密严　　妙体本清净
  无心亦无觉　　光洁如真金
  不可得分别　　性与分别离
  体实是圆成　　瑜伽者当见
  意识缘于境　　但缚于愚夫
  圣见悉清净　　犹如阳焰等

尔时世尊说是经已。金刚藏等无量菩萨摩诃萨。及从他方来此会者微尘数众。闻佛所说皆大欢喜信受奉行

大乘密严经卷下


大威灯光仙人问疑经

    No. 834 [No. 833]

大威灯光仙人问疑经

        隋天竺三藏阇那崛多等译

如是我闻。一时婆伽婆在伽耶城。成道未久。与诸比丘一切众俱。其中或有得于一果。及以二果三四果者。随其得果所有功德皆悉明净。复有九十九亿诸菩萨众。及二十八亿诸天众等。复有比丘比丘尼优婆塞优婆夷无量众数。及六万力士。十二亿等诸尼干子。复有八万四千五通仙人。复有五百诸外道等。皆悉以灰涂于身体。露现胸臆。肉尽脂消。唯余皮骨。伛偻曲背结发自里。披树皮衣手执瓶罐。处处寻求语言论义

尔时世尊如须弥山处黑山内。光明照耀威德绝伦。如来世尊亦复如是。于诸仙中为最第一。又如六牙清净白象。独自在于白羊群内。如月夜朗映蔽众萤。如曼陀花生芦苇町。如金翅鸟处在乌群。世尊于彼诸仙众中。亦复如是。威德照明倍复殊胜。尔时世尊即便入于宝舍三昧。现无量神通。普放净光遍身明耀。于身左右。迭相交绕。又于自身。出无量亿诸化佛身。一一化身复出无量亿诸化佛。复自身中。出无量亿诸菩萨身。无量帝释身。无量梵王身。无量四天王身。无量百千阿罗汉身。无量百千比丘比丘尼优婆塞优婆夷身。无量大转轮王身。无量小转轮王身。无量粟散诸小王身。无量东海洲中边地人身。无量南天竺等。所有诸地一切人身。无量刹利大姓。诸婆罗门等。大富长者。一切人身。如是等种种形类。种种服饰。种种言说。所有一切诸天界分。一切皆从如来身出。尔时一切大众。各怀疑心。迭共相观。时诸菩萨皆大欢喜。雨诸珍宝供养之具。乃至璎珞供养如是。尔时世尊现是瑞已。还从宝舍三昧起。从三昧起已。如师子王频申顾视。普观十方观十方已。即时见彼十方世界。一切所有诸佛刹土。及此娑婆大千世界。以佛眼观。分明显现犹如掌中。如此释迦如来。放大神通种种变现。十方一切诸佛。亦复如是现化佛身。从化佛身示化佛身。彼诸如来所有化佛。皆来云集。世尊大会。复有无量恒河沙等诸菩萨众比丘比丘尼优婆塞优婆夷。过诸譬喻。各执种种供养之具。随其所应堪供养者。来诣佛所。复有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众。随其住处皆见如来神通力已。从彼而来赴此海会。尔时十方诸来菩萨各以无上供养之具。供养如来。设供养已。各以六波罗蜜之所成就师子高座。随其身量称座而坐。乃至人非人等。各称身座。复座而坐。释迦如来所教化者。上至阿迦尼吒天。下至阿鼻地狱。所有化类皆悉而还还已。当于是时以佛力故。皆见十方诸佛世界。犹如一会。所有十方一切诸佛所教化者。一切皆从释迦如来诸毛孔入。释迦如来所教化者。皆从彼佛身诸毛孔入。现如是已。当尔之时。于彼众中有一菩萨名曰胜分。从坐而起进止庠序。容貌端严偏袒右肩。右膝着地合掌向佛。而说偈言

  佛世甚希有　　为众故显现
  此事未曾有　　覆蔽一切魔
  迭共相观面　　唱言希有事
  我等何故来　　出言我破坏
  我等辈可怜　　唯首骸骨消
  我等既羸瘦　　枯老复失乐
  无言字神通　　覆翳我道刺
  大神通佛子　　今自显佛法
  此众生疑心　　复生大欢喜
  此会皆出言　　我等愿作佛
  文殊在众中　　佛子众围绕
  文殊侍多佛　　来显说神通
  为何法现相　　今佛说何法
  咸生是疑心　　愿为我众说

尔时彼众中以魔力故。有一仙人名威灯光。即白胜分菩萨言。童子汝且默然。我今发问。若是沙门能决于我心所疑者。乃可得名为萨婆若。若不能决我疑心者。云何得名一切智也。如是神变若幻作者。摩醯首罗。那罗延等所说咒咀。凡世间人用是法故。亦能成就诸如是等无量之事。岂足为奇。作是语时如来世尊。熙怡微笑既微笑已。普观诸仙一切大众。观察众已。即告威灯光大仙人言。汝威灯光。今正是时恣汝所问。如我智力为汝解说。尔时威灯光大仙人即问佛言。瞿昙沙门先与我说众生体者。从何处生。几粗几细。众生内体性者。为一搩耶。一尺耶。一指耶。乃至若大麦小麦。大豆小豆等分耶。乃至芥子许众生内体性耶。作是问已。尔时世尊即赞威灯光大仙人言。善哉善哉。汝威灯光。快问是义。如六万劫寿命者。尔时世尊作是语时。诸仙人等皆大惊怪。作是念言。我等与彼大仙。久居共在一处。犹尚未知大威灯光寿命算数。今是瞿昙。云何速得如是觉知。尔时世尊即复告于彼威灯光大仙人言汝大仙人。谛听谛受。善思念之。吾当为汝具足善说。汝问我言众生体者从何处生。大仙当知。实无言说。无有字句可说。众生有所从来。但以无明行等诸因缘故。起彼众生乃至生老病死等。诸因缘故起彼众生。大仙。复有因缘能起众生。所谓以母为因以父为缘。得生众生。复次父母和合以之为因。邪念妄想起诸业风。吹识种子置胎藏中。即是彼缘。复次苦圣谛集灭道圣谛。是众生也。复次五阴分十八界和合故。是众生也。复次大仙。不离众生有业。不离业有众生。众生是业。业是众生汝当知之众生界者不增不减。大仙人言。瞿昙。若众生界不增不减者。何故众生舍垢身已。得自在身。佛言。汝大仙人如汝所言。是大不可。何以故。若自在得自在者。应不堕落。常在自在中。若自在身不得自在者。云何名得自在也。大仙人。譬如萤火虫作是心念。我光明焰悉能遍照于阎浮提。假使萤火虫实能放光遍照阎浮提者。终亦不能使无伏心者。得名真自在。复次大仙。若自在得自在者。应尽诸烦恼垢。不自在故。应长诸烦恼。若诸烦恼垢。与自在等共有者。是故众生界。无有增减而可见也。时大仙人复言。瞿昙。汝可不作尽诸烦恼耶。佛言。汝大仙人。我亦不作尽诸烦恼。亦复不增诸烦恼。大仙人言。今汝瞿昙。若如是者。亦不应言我得自在。佛言。大仙。如是如是。大仙当知。我亦不言我得自在。何以故。我无实故亦不自在。大仙人言。汝瞿昙且置是语。瞿昙。如汝前言父母和合得众生。生者何故多人共和合。少有众生而得生耶。此义云何。佛言。大仙。我今为汝所引譬喻。随汝所能为我解说。汝大仙人。如有一子中多有树生。复一树中有无边枝。一一枝中复无量花。是一一花应各结果。何故有结有不结者。若已结者皆应成熟中作种子。何故复有熟不熟者。此义云何。大仙人言。瞿昙。由风吹故有结不结。若已结者堕落不熟。不任为种。佛告大仙人。以业风自转吹业众生。果堕落故。少有众生而得生耶。大仙人汝当知之。若在胎中或为虫食。或为业风转为碎失。汝当知之。树灾堕落少不足言。所有众生。为灾堕落多不可说。复次大仙人。以邪心故起众生界。若诸众生能有几许心想转者。还复尔数受后有生。是故我言邪心故起众生界。尔时大仙人言。瞿昙。如是如是。如我所问。汝已答我此义。得成瞿昙。更复为我解说。何以故有劫烧尽也。佛言。大仙人。汝当知之。无作故名为法界。若劫尽时大地不烧者。法界便有二种。少有分是无常。少有分是常。若如是者。是诸如来。则亦不成为实语者。若一切无常。无为法中不可思量者。是故如来得名一切智。尔时大仙人闻是语已。回首顾语自诸弟子言。汝知之不。此瞿昙者。真成是于一切智也。尔时世尊复更重告大仙人言。若劫尽时一切大地不被烧者。不得分别此是初时此是末时。亦复不知好丑业果善恶等报。汝当知之。此劫烧时焚荡尽者。是诸如来大方便力之所为也。所有众生若能闻信。劫当烧尽洞皆燃者。尔数众生。诸如来边受诸摄受汝当知之。如大蟒蛇身分所有眼耳口鼻。以毒力故。悉能摄受一切飞走杂类众生。应知如来亦复如是。以布施爱语利行同事。法毒力故。悉能摄受调伏一切诸众生也。大仙人。又如有人以其金铤置在火中。不以嗔恨置于火中。以不熟故欲令成熟。为欲成就真宝物故。为令价大得多财故。置金火中连椎交打柔软清净。如是一切诸众生辈。莫不皆因诸佛如来。放劫尽烧而得调伏。如是劫尽大地烧时。实无众生受苦恼者。大仙人言。世尊希有。可得劫尽火焚烧然。大地坏时。无一众生受苦恼者。佛言。不也。大仙人。诸佛如来。不令一众生受逼切恼。何以故。大仙人。譬如十方微细雨渧。彼诸雨渧宁为多不。大仙人言。甚多世尊。佛言。大仙人。诸佛如来十地菩萨倍多于彼。当尔劫尽大地烧时。于上虚空中。以慈悲智慧身手。解救众生。不令有苦而触身也。所以者何。以彼诸佛如来。一切菩萨妙身。广大相好端严。众生见者无不欢喜生正信心。唱如是言。我等愿于未来世中。皆得成就如是除拔。还得成就如是形色如是相好端严之身。当于是时。又有心解脱已。得阿罗汉果者。或有厌离心生。得须陀洹果。斯陀含阿那含果证者。或复有得无生法忍者。有得不退转地者。有得生于四天王天上者。有得生于忉利天上。夜摩天上。兜率天上。化乐天上。他化自在天上者。略说乃至有得生于阿迦腻吒天上者。当于是时。所有一切大转轮圣王小转轮王及诸方域粟散小王。大仙人等。乃至刹利大家。大婆罗门。大富长者。如是次第。以见如来妙色之身。复见己身。于大恐怖生死海中。得解脱故。生大踊跃欢喜之心。于如来边起知恩心。起报恩心。于如来边听受法已。各各皆于十业道中。作不放逸行。以是方便力因缘故。于十恶道中速得舍离。当于是时。所得十地大菩萨者。以此菩萨眼道所及。照了之处大地微尘。彼等微尘虽复甚多。而彼时节诸众生界。乃至知于烦恼体性污染不净。从于无为涅槃道中。入彼无余涅槃道者。倍多于彼。汝今当知诸佛如来。为如是等大利益故。方便显示劫烧尽也。尔时一切大仙人等。闻是语已生惊怪心。呜呼奇哉甚大希有。大德释子向者唤我。为大仙人发我寿命。我时虽闻如是之事。犹谓非真一切智也。今以世间难中之难。具足施已。我今始知释子真是一切智也。我于今者以于真实名号称之。尔时一切大仙人等即发是言。大功德聚者。无边大智者。知一切智者。我见众生持业星流各各别异。何处得成真实聚集。唯愿世尊。为我解说令得开悟。尔时世尊即告大仙人言。汝大仙人。当知无有时方。亦无处所。令得众生真聚集也。大仙人。惟平等中众生得聚集。一乘道中众生得聚集。菩萨地中众生得聚集。无余涅槃界中众生得聚集。汝今当知。如有众流河泉渠渎一切川源皆归大海。入大海已得一味住。谓一碱味无差别也。大仙。汝今当知。所有众生界若得漏尽者一切彼处于解脱味中会一味住。汝今当知。我虽说言烦恼平等中众生得聚集者。亦非聚集也。所以者何。譬如大风施起。吹诸蚊虫一切聚集。若风定已各各星散。如是诸类一切众生。各各皆为业风缚故。或堕地狱中彼辈得聚集。业风缚故。或时饿鬼中彼辈得聚集。或在畜生中。彼辈得聚集如是等。仙人复言。一切识一切智者。愿为我说。若有如是。如是等辈已于先世。俱人中生共同聚集。今日现在云何可知。乃至一切。若在畜生。若在饿鬼。已于先世曾聚集者。云何可知。愿为解说。佛言。大仙人。所有众生若先世时。共地狱中曾聚集者。于现在世若相见时。心不欢喜生嗔结恨。或时头痛。或复失禁大小便利。当知是辈已于先世。地狱之中曾聚集相。若有如此相貌现时。应当觉知。彼与我身决定已曾于地狱中一处居来。时大仙人。复白佛言。一切能人证大寂者。一切智者。更为我说。若先世中曾在畜生。共千万身一处来者。云何可知。佛告大仙人。若彼等辈生人中者。各相见时结成嗔怨。常觅其便。我当何处觅得其便。是名相貌在畜生中。一处同居多身之相。应知决定我已共彼。在畜生中一处居来。若饿鬼中一处居来者。常乐臭秽复多贪食息。设欲与他心不去离。生悭贪着。或复见彼富贵势力心生嫉妒。常复欲得彼人财物。见是相时。决定知彼与我同在饿鬼之中一处居来。若有先世同在人中共一处者。于现世中若相见时。更生欲心。尔时威灯光大仙人复白佛言。若先世时。共在天中同一处者。今世人中若相见时。云何可知。佛言。大仙人。若有先世共天中生。现在人中若相见时。各以眼道远相摄取。共相眷爱。若有是相。决定天中共聚集来。若以如是相观察者。得知众生聚集相也。尔时大仙人。闻是语已。欢喜踊跃。生希有心。即白佛言。世尊。我今始知彼众生辈。成实可言大虚诳也。云何迷没不求修学萨婆若也

尔时世尊。更复重告大仙人言。汝向问我内众生体有几微细者。大仙人。若有众生体可得者。彼众生体可得作分微细长短。汝今当知。譬如有人从生盲瞽。复有一人问彼人言。人者白色为似何者。于汝意云何。彼既不见可得说言。此色如是如是色也。仙人答言。彼人既不明了见色。何敢如此决定判也。佛言。如是如是。大仙人。是诸凡夫人如似生盲者。不见众生体不可言道。如是众生微细内体长短粗涩。复次大仙人。眼非众生。耳鼻舌身意等亦非众生。有为阴分亦非众生。十八界十二因缘亦非众生。众生名字亦不可得。亦非内空外空内外空得名众生也。所以者何。大仙当知。眼即假名。暂时不相合故。耳鼻舌身意等假名。暂时不相合。五阴法假名。暂时不相合。三十六种不净之物。一切假名。暂时不相合。如是等无有众生而可得也。亦非色等诸尘共相和合故。有众生色等诸尘。各各别异。分张离散。彼等诸法亦非众生。非命非养育。无主无人。亦无有我。皆不可得。复次大仙人。若有众生者。是诸如来。则不应说四种四谛法。以实无有众生性故。是故一切诸佛如来。得是诸法。如是随顺。如是修行。得如来身。尔时威灯光大仙人。为欲求得一切智故。发大弘誓。作如是言。世尊。设我今者有大火坑。尽其劫际应处其中。复有大山犹如须弥。其山岩峻高远峙立。乃至上到阿迦尼吒天。于彼时中。我身在上自坠而下。复有大火其聚犹如劫尽时火。如是等火猛焰炽然。五热炙身其日长远。一日时分等于一劫。如此劫时。以三十日持作一月。满十二月以为一年。如是时节尽彼劫际。修此苦行欢喜甘受。终不因是暂舍精进。而不求于一切智也。尔时威灯光大仙人作是语时。于大会中。所有一切五通仙人。皆悉从坐恭敬而起。合掌向佛。作如是言。世尊。我等诸仙从今已去。皆各勇猛勤力精进所欲求于阿耨多罗三藐三菩提。是诸仙辈作此言已。尔时世尊。即从眉间放诸光明。其光名曰无能降伏者。十方一切诸佛世尊。眉间白毫放诸光明。亦复如是。当于是时。以佛光明力因缘故。是诸大地六种震动。所谓动遍动。等遍动。踊遍踊。等遍踊。觉遍觉。等遍觉。起遍起。等遍起。震遍震。等遍震。吼遍吼。等遍吼。东踊西没。西踊东没。南踊东没。北踊南没。中踊边没。边踊中没。乃至上下踊没亦复如是。尔时十方诸佛世尊于虚空中。在于释迦如来佛上。雨种种华。种种妙香。种种天乐。随心所爱令众见闻。复有乾闼婆王。并及无量诸天众等。皆悉作于五种音乐。以乐如来。复于一切诸乐音中。出于种种赞叹之声。歌咏如来。是诸天香。又有微风徐徐而动。吹是香气叆叇垂布。于如来前遍覆虚空。复有十方诸来菩萨摩诃萨等。一切大众踊跃欢喜。各于佛上雨种种花。种种璎珞。种种珍宝。种种杂香。种种花鬘。种种涂香。种种末香。种种衣服。种种幡盖。诸如是等无量无边供养之具供养如来。复有余方无量无边诸天众等皆大欢喜。亦于空中。雨天上妙曼陀罗花。及于摩诃曼陀罗花。诸如是等供养之具。以供如来时诸大众生希有心。复以自己所著种种殊胜衣服普散佛上供养如来。尔时无能降伏大光明焰。上至阿迦尼吒天。下至阿鼻地狱。遍照十方。一切诸佛大会之众。围绕一切彼诸如来。作围绕已。是大光明从彼而来。还至世尊顶上而入。尔时长老须菩提即从坐起。前至佛所顶礼佛足。礼佛足已右膝着地。长跪合掌以偈颂曰

  无有不因今释迦　　放妙光明遍诸刹
  愿佛怜愍我等故　　大众因说除疑心
  以睹世尊现威容　　或更怀疑或欢喜
  是中或复举一手　　踊跃赞叹佛世尊
  帝释梵众四天王　　充遍虚空叹佛德
  雨天香花璎珞具　　乐器不鼓出妙声

尔时世尊即告长老须菩提言。汝今见是此威灯光大仙人不。须菩提言。唯然世尊。我已见之。真正行者。我已见之。尔时世尊复更重告须菩提言。须菩提。汝今当知。是威灯光大仙人者。于未来世。过是贤劫千佛世已。复更有劫还名为贤。刹名月主。于彼界中当得作佛。号毗婆尸如来应供正遍知。十号具足。须菩提。汝当知之。彼毗婆尸如来出现于世之时。其有得闻是佛名者。无不获利。犹如意珠随心愿满。复次须菩提。汝当知之。今此会中八万四千诸仙人辈闻是法本已。悉皆获得不退转地。当于弥勒下生之时。一切满足十地愿行。过三千劫已。当得作佛。号曰威灯如来至真等正觉。今此大会之中。复有无量亿诸菩萨众。闻是法本已。皆得首楞严三昧。上上智威三昧。如来受位三昧。如幻化三昧。四大难降伏三昧。意王三昧。海藏三昧。调伏庄严三昧。真心藏三昧。清净三昧。如是等复有亿恒河沙等诸天之众。皆得住于无生法忍。无量百千比丘比丘尼。优婆塞优婆夷。皆悉得于阿罗汉果。恒河沙数天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。未发心者。皆得发于阿耨多罗三藐三菩提心。须菩提。汝今当知。我见是等大利益故。放是光明

尔时世尊。复出舌相遍覆面门。彼舌相中出种种色。种种光明。所谓青黄赤白。紫绀琉璃。红缥金色。颇梨色等。是光明曜遍到十方无量无边诸世界已。还从如来足下而入。尔时无尽意菩萨从坐而起。偏袒右肩右膝着地。长跪合掌而白佛言。世尊。如来无有无因缘故现于舌相。惟愿世尊。为我等说。何因何缘出现舌相放是光明。佛告无尽意菩萨言。善男子。我为无信诸众生等出是舌相。如来世尊。终不以此舌根相故作妄语也。尔时无尽意菩萨复白佛言。世尊。若未来世诸善男子。及善女人。于此经中若以一句若以一偈为他显说。其福几何。惟愿说之。佛言善男子。所有十方诸佛刹中。诸佛世尊眼所见者。彼等一切资生乐具。悉以供养十方一切诸佛世尊。乃至入于大般涅槃。般涅槃后。复以一切种种宝物起舍利塔。若复有人。于此真如法本之中。乃至一句及以一偈。分别为他而显说者。所得福德乃多于彼。复次善男子。若有说是法本之时。能于是中。赞言善哉快哉之者。当知彼人。一切诸佛皆共赞叹。若有供养是经典者。当知彼人。即是供养于我身也。尔时世尊普观大众。观大众已即告之言。诸善男子。若此经典所在之处。如是地分一切诸佛皆共忆念。诸善男子。当知是经于未来世阎浮提内诸众生边为大良药。若人能于是经典中。若自转读。若教人读。一遍二遍及三遍者。当知是人。自请如来转妙法轮。若有善男子。于是经典若自抄写。若教人抄。当知彼人即是受持一切诸佛甚深法藏。常得欢喜速获安乐。于未来世当得作佛。若有善男子善女人。应堕地狱者。终不闻是微妙经典。诸善男子及善女人。若得闻是妙经典者。舍是身已。必得生于清净国土。复次善男子善女人等。得闻是经。闻已欢喜。信乐受持。广为他人读诵解说。当知彼人速得菩提。毕定不久。六根具足。五眼清净。临命终时不忘正念。复当得彼无量无边百千三昧陀罗尼门。所谓入于一切诸佛三昧。普照奋迅三昧。总持藏三昧。髻珠印三昧。灌顶位三昧。观印三昧。复得无字惬陀罗尼。一切法无能降伏陀罗尼。决疑陀罗尼。真如决义陀罗尼。如是等无量无边百千陀罗尼。复得五神通。于生死处正念不乱。尔时世尊即告文殊尸利菩萨摩诃萨言。善男子。汝已供养无量无边百千诸佛故。我以此法付嘱于汝。汝当来世广为他说如是法本。文殊尸利。于汝意云何。汝已过去于诸佛所。种种供养。种种恭敬。种种奉迎。是诸福德可得边际可得思量不。文殊尸利言。不也世尊。佛言文殊尸利。若汝于未来世于此娑婆世界。五浊世中。广宣流布如是法本。所得福德倍多于彼。文殊尸利。汝于过去诸世尊所。虽复以于种种衣服四事供养常令丰足。而汝未曾于是法本为他人故方便显说。以如是故。于彼佛边犹多过咎。若汝于彼过去佛边。乃至一佛未曾供养。但能于是深妙法本为他广说。当知即是于一切佛诸世尊所。具足供养无有过咎。佛说是经时。文殊尸利诸菩萨等。及威灯光一切仙人。并余眷属天龙八部诸鬼神等。一切大众。闻佛所说欢喜奉行大威灯光仙人问疑经


大庄严法门经

    No. 818 [No. 817]

大庄严法门经卷上(亦名文殊师利神通力经亦名胜金色光明德女经)

        隋天竺三藏那连提耶舍译

如是我闻。一时佛在王舍城耆阇崛山。与大比丘众五百人。大菩萨众八千人俱。尔时王舍城中。有淫女。女名胜金色光明德。彼女宿世善根因缘。形貌端正众相具足。身真金色光明照曜。容仪媚丽世所希有。神慧聪敏辩才无碍。音辞清妙深邃柔软。言常含笑语无粗犷。顾眄进止容豫安详。随所在处。或行或住或坐或卧。地皆金色。光明照曜。所著衣服青黄赤白亦皆金色。时王舍城一切人众。或是王子或大臣子。或长者子或豪富子。见者贪染系心爱着。情无舍离。是金色女。或在聚落或在街巷。或在市肆或在河岸。或在园林所游之处。若男若女童男童女。皆悉随从观无厌足。复于异日。有长者子名上威德。为欲乐故多与财宝。共相要契乘驷马车。其车纯以金银琉璃摩尼真珠上妙众宝。严饰庄校。建立宝幢微妙幡盖。宝座华鬘涂香末香。如是种种和合胜香以用涂薰。以瞻卜华而为璎珞。庄严其身同载宝车。于宝车前。种种伎乐歌舞作倡。于其车后。复持种种甘美饮食衣服卧具。次第随从往诣园林。尔时大众。若男若女童男童女。皆悉随逐左右观看

尔时文殊师利童子从禅定起。于一切众生起大悲心。而作是念。何等众生。于大乘中堪受教化。何等众生。应以神通而受教化。何等众生。应以过去业缘而受教化。何等众生。应闻正法而受教化。作是念已。见金色女与长者子。同载宝车欲诣园林。见已即观根性差别。差别观已作是念言。此女过去善业因缘堪受教化。若闻我法即能信受。尔时文殊师利以神通力身放光明。映蔽日光悉不复现。何况余光。时文殊师利所著衣服。面各光照满一由旬。令彼多众皆悉睹见。复以种种众宝璎珞天冠臂印。庄严其身。欲令见者心生贪乐。作是事已。往诣女所当路而住。光照女身及长者子。驷马宝车所有光明皆悉闇蔽。犹如聚墨比于真金无有光明。彼金色女。见文殊师利众宝庄严衣服清洁光明远照。谓是天童自于己身及长者子。而生鄙恶不复爱乐。于文殊身及以衣服起贪着心。默自念言。我当就彼共为嬉戏。从心欲乐求索彼衣。作是念时。文殊师利威神力故。毗沙门王化为人像。从空而下立于女前而语之言。汝今不应于彼人所生贪欲心。何以故。彼人清净无贪欲故。金色女言。此是何人。毗沙门言。此是文殊师利童子菩萨。金色女言。云何名菩萨愿善说之。为是天耶。为是夜叉。为乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽为是帝释。为是梵天。为是四天王天耶。毗沙门言。非天。非夜叉。非乾闼婆。非阿修罗。非迦楼罗。非紧那罗。非摩睺罗伽。亦非帝释。亦非梵天。亦非四天王天。如是等辈悉非菩萨。言菩萨者。一切众生随所愿求悉能满足不生悭吝。是名菩萨。时胜金色女即作是念。如所说者。我今乞衣必定应得。即便下车向文殊师利所。到已白言。文殊师利。愿能施我所著衣裳文殊师利言。妹汝若能发阿耨多罗三藐三菩提心者。当与汝衣。女言。文殊师利。何者名为菩提心耶。文殊师利言。汝身即是菩提。女言。云何我身即是菩提。愿重广说令我得解。于是女人说偈乞衣

  文殊久发菩提愿　　今可施我身上衣
  若不能施非菩萨　　犹如枯河而无水

尔时文殊师利。说偈答言

  汝若能发菩提心　　我当随愿施汝衣
  若有坚固菩提者　　一切天人皆供养

尔时胜金色女。复以偈问

  菩提有何义　　菩提从谁得
  菩提谁能与　　菩提何行成

尔时文殊师利。语金色女言。于今现在有佛。号释迦牟尼多他阿伽度阿罗诃三藐三佛陀。彼佛所说。身及菩提皆悉平等。于意云何。汝身有五阴十二入十八界不。是女过去善根因缘闻此语已。即得法光。得法光已白文殊言。如是如是。我今此身有五阴十二入十八界。文殊师利言。于汝意云何。色可觉可知不。女言。不也。不可觉不可知。文殊师利言。菩提亦如是。不可觉不可知。如是色平等故。菩提亦平等。是故我说汝身即是菩提

文殊师利言。于汝意云何受想行识可觉可知不。女言。不也。不可觉不可知。文殊师利言。菩提亦如是。不可觉知。如是受想行识平等故。菩提亦平等。是故我说汝身即是菩提。文殊师利言。于汝意云何。此色可说在此在彼在内在外在中间不。可说青黄赤白颇梨杂色不。女言不也。文殊师利言。菩提亦如是不可得说。如是色平等故菩提亦平等。是故我说汝身即是菩提

文殊师利言。受想行识可说在此在彼在内在外在中间不。可说青黄赤白颇梨杂色不。女言。不也。如色不可说。乃至受想行识亦不可说。文殊师利言。菩提亦如是不可说。如是受想行识平等故菩提平等。是故我说汝身即是菩提

复次五阴如幻体性不实。颠倒故生。菩提亦如幻体性不实。以颠倒故。世俗说生如是。幻平等故五阴平等。幻平等故菩提平等。是故我说汝身即是菩提

复次五阴如梦体性不生。菩提亦如是体性不生如是梦平等故五阴平等。梦平等故菩提平等。是故我说汝身即是菩提

复次五阴如阳炎以业缘故生。菩提亦如阳焰无业无报。如是阳炎平等故五阴平等。阳炎平等故菩提平等。是故我说汝身即是菩提

复次五阴如镜中像。体性空无不去不来。菩提亦如是无去无来。如是镜像平等故五阴平等。镜像平等故菩提平等。是故我说汝身即是菩提

复次五阴但是假名。菩提亦如是但是假名。如是五阴平等故菩提平等。是故我说汝身即是菩提

复次五阴无有作者。离作者义。是菩提五阴无体性离体性义。是菩提五阴不生离生义。是菩提五阴无常离常义。是菩提五阴无乐离乐义。是菩提五阴无清净离清净义。是菩提五阴无我离我义。是菩提五阴不清净离清净义。是菩提五阴无取离取义。是菩提五阴无家离家义。是菩提五阴无去来无去来义。是菩提五阴圣人法论。菩提亦圣人法论。如是论非论法五阴体性。如来一切觉故。是名菩提。如是五阴体性即是菩提体性。菩提体性即是一切诸佛体性。如汝身中。五阴体性即是一切诸佛体性。诸佛体性即是一切众生五阴体性。是故我说汝身即是菩提

复次觉五阴者。名觉菩提。何以故。非离五阴佛得菩提。非离菩提佛觉五阴。此方便知。一切众生悉同菩提。菩提亦同一切众生。是故我说汝身即是菩提

复次四大法生。所谓地界水界火界风界。而此地界非我。非众生。非寿命。非晡沙。非富伽罗。地界平等是菩提过去无取故。水界平等是菩提。体性不生故。火界平等是菩提。体性不可觉故。风界平等是菩提。体性不可见故。地界体性如来觉故得菩提。如是水界火界风界如来觉故得菩提。觉地性者是名菩提。如是能觉水火风等是名菩提。是故我说汝身即是菩提。复次地界不知水。水界不知火。火界不知风。如是诸界无名不可说者是名菩提。是故我说汝身即是菩提

复次汝身眼法生不。如是耳鼻舌身意生不。妹此中眼空眼空体性即是菩提。如是耳鼻舌身意空。意空体性即是菩提

复次若眼体性空色不可说。色空体性即是菩提。如是耳鼻舌身意体性空。一切法不可说法空体性即是菩提。复次眼不取色菩提亦如眼不取色。如是耳鼻舌身意不取声香味触法。菩提亦如是不取一切法。如是眼识界色界中不住。眼识色界菩提中亦不住。耳识界鼻识界舌识界身识界意识界法界中不住。如是意识法界菩提中不住。眼识界菩提界无二无别。乃至意识界菩提界无二无别。是故我说汝身即是菩提

复次觉眼者是名菩提。如是觉耳鼻舌身意者是名菩提。眼体性空。能觉如是体性空者即是菩提。耳鼻舌身意体性空。能觉知者即是菩提。复次眼体性不贪不嗔不痴。离贪嗔痴即是菩提。如是耳鼻舌身意体性不贪不嗔不痴。离贪嗔痴即是菩提。眼无主者无取者。菩提亦无主者无取者。如是耳鼻舌身意亦无主者无取者。菩提亦无主者无取者。眼中无男法女法亦非男非女。如是菩提中无男法女法亦非男非女。耳鼻舌身意中无男法女法。耳鼻舌身意亦非男非女。如是菩提中无男法女法。菩提亦非男非女。复次眼色如如来。觉此如故名为菩提。如是意法如如来。觉此如故名为菩提。是故我说汝身即是菩提

复次汝身无我。无众生。无寿命。无晡沙。无富伽罗。无人。无摩那摩。无作者。无受者。无见者。无闻者。无嗅者。无味者。无触者。无知者。彼菩提亦无我。无众生。无寿命。无晡沙。无富伽罗。无人。无摩那摩。无作者。无受者。无见者。无闻者。无嗅者。无味者。无触者。无知者。是故说一切法不可知即是菩提

复次此身无知无觉无作。犹如草木石壁。若内地界若外地界名地体性。此地界性。如来般若智力觉已。是故我说汝身即是菩提

复次妹如汝心意和合思量分别。而此心意思量分别无觉无知。不在皮肤。不在筋血。不在骨髓。不在发毛。不在指爪。不在内外。不在眼耳鼻舌身意。非住非不住。不定住非不定住。非此住非彼住。非色不可见不可捉。无障碍无分别。不可执不和合。非家离家。清净最清净。光明照曜彼心意思量分别。不与烦恼和合亦非清净。何以故。体性净故不与烦恼和合。不和合故清净光明。又彼光明无身。无身故不与烦恼和合亦非清净。如是阴界入体性即是菩提。菩提体性即是阴界入。是故汝身阴界入性是名菩提。何以故。非离彼故名为菩提。离阴界入事中菩提不可得。觉阴界入即是菩提。是故我说一切法平等觉此名菩提

尔时文殊师利童子说此法已。时虚空中五百诸天发阿耨多罗三藐三菩提心。复有随从胜金色光明德女。若男若女童男童女二百人。发阿耨多罗三藐三菩提心。六十天人于诸法中得法眼净。时胜金色女踊跃欢喜心得清净。五体投地礼文殊师利足。作如是言。归依佛归依法归依僧。归三宝已。受梵行五戒。受戒法已。至心发阿耨多罗三藐三菩提心。既发心已白文殊言。我今得闻如是法教。为一切众生得安隐故起慈悲心。为不断佛种故至心发阿耨多罗三藐三菩提心。如文殊师利为我说此菩提之法。我当顺行。亦当广为一切众生说如是法文殊师利。如是佛法寂灭大寂灭。我不知故随恶觉观起颠倒心执于身见。自贪着身复令他贪。我今至心清净忏悔一切罪业。如文殊师利所说贪寂灭法一切和合法亦如是寂灭。若有众生不知此法起贪著者。我能令彼远离贪着。安住阿耨多罗三藐三菩提。何以故。一切烦恼犹如死人。但以颠倒妄想故生。若无颠倒诸妄想者烦恼则灭。我今得闻文殊师利所说法要。知一切烦恼犹如云雾体性不实。烦恼如电。一念不住。烦恼如风。体性不生。烦恼如空中画。不可见故。烦恼如画水。随画随灭故。烦恼如夜叉鬼。生恶觉故。烦恼如热病。狂妄语故。烦恼体性无。恶觉生故。烦恼难舍。我我所执故。无物妄取客尘。烦恼妄生故。烦恼随想现。恶觉观取故。烦恼如眼。见种种境起故。烦恼体无尽。犹心浊生故。烦恼体性无。和合缘生故。烦恼如团聚。阴入界合故。烦恼不可识。无名色故。烦恼不可知。无善觉故。烦恼如种子。能生菩提故。何以故要因烦恼能满菩提故

文殊师利。菩提者如金刚撅。众生烦恼不能动故。又菩提者如金刚迹一切烦恼不能破故。何以故。法界方便不可坏故。文殊师利。见烦恼者名为菩提。何以故。一切境界顺菩提故。如是菩提无有住处。一切烦恼亦无住处。何以故。生即灭故。文殊师利如心体性不可说示。亦不可说在此在彼。贪嗔痴体性亦复如是。菩萨如是知烦恼故。于多贪众生多嗔众生多痴众生。善能教化然不为彼众生恼乱。乃至教化等分众生亦不恼乱。文殊师利。如我贪嗔痴。一切众生贪嗔痴亦复如是。如我烦恼当知一切众生烦恼亦复如是

复次文殊师利。譬如猛火于一切草木不生恐怖。如是智慧行菩萨。于诸烦恼不生恐怖。譬如日轮不与闇住。如是智慧行菩萨不与惑住。譬如大风诸山树木无能障碍。如是智慧行菩萨。一切世间烦恼境界无能障碍。譬如虚空劫火不烧。如是智慧行菩萨。诸烦恼火亦不能烧。譬如有宝名曰铁爱。不住不净随所止处一切清净。如是智慧行菩萨。于一切烦恼亦复不住。譬如虚空不与地合。如是智慧行菩萨。不与烦恼诸结和合。如铁围山风不能动。如是智慧行菩萨。一切烦恼所不能动。譬如仓鹄水乳和合惟啑于乳而不取水。如是智慧行菩萨。虽与一切烦恼和合。而但取智不取烦恼。如郁单越国男女和合。悉诣树下若非亲者树枝垂下阴覆其身。菩萨如是。于根未熟众生智不垂化

复次文殊师利。我今于此一切烦恼不生惊怖。何以故。以知一切烦恼性故。善披菩萨无畏铠故。譬如健人临阵不怖。若生恐惧则非健人。菩萨亦尔。于诸烦恼而生恐怖则非菩萨。又如有人入阵相击。不能胜他反为他害不名健儿。若诸菩萨而为烦恼之所害者。不名菩萨文殊师利。如净水珠投之浊水。水则清净而不为彼浊水所污。菩萨虽与烦恼和合。不为烦恼之所染污

尔时胜金色女说是语已。问文殊师利言。云何菩萨能离烦恼。文殊答言。若有菩萨知烦恼生知烦恼灭。是则不名离烦恼者。譬如明灯能灭诸闇。若与闇俱不名为灯。如是菩萨见烦恼生见烦恼灭。则不得名离烦恼菩萨。复次离烦恼菩萨。不见烦恼不见清净。非见非不见。离心意识者名离烦恼。于彼彼处心有分别。乃至念涅槃者。是名不离烦恼。何以故。或心或心数生攀缘罪福故。此攀缘者名一切作行。若作行已是为流转若流转法名实流转。一切流转名为烦恼

复次和合者名为烦恼。何者和合。眼与色和合。耳与声和合。鼻与香和合。舌与味和合。身与触和合。意与法和合。三昧与烦恼和合。何以故。见得三昧出没相者名为烦恼。离恶觉者名离烦恼。离心行者名离烦恼。无功用者名离烦恼。离数量者名离烦恼。若有菩萨。自离烦恼复令他离。为解一切众生缚故勤行精进。如来说此名离烦恼精进菩萨。时胜金色女问文殊师利言。何者名为最胜精进菩萨。文殊师利言。若有菩萨不证空法。于身见众生悲心不舍不证无相。于恶见众生悲心不舍不证无愿。于愿行众生悲心不舍不证无作法。于作行众生悲心不舍不证无生法。于生老死众生悲心不舍不证无出法。于生灭众生悲心不舍。不证声闻辟支佛果住菩萨位。于一切众生悲心不舍。是名最胜精进菩萨。譬如大海易入难出。何以故无善方便故。如是声闻缘觉入空无相无作法中。无方便故不能自出。最胜精进菩萨有方便故能入能出。譬如有人入阵斗战身无伤损而能免出。是最为难。如是菩萨入空无相无愿三解脱门。有方便故则能免出。是则名为菩萨方便

胜金色女问文殊师利言。云何名为菩萨方便。文殊师利言。方便有二种。一者不舍生死。二者不住涅槃。复有二种。一者空门。二者恶见门。复有二种。一者无相门。二者相觉观门。复有二种。一者无愿门。二者愿生门。复有二种。一者无作门。二者种善根行门。复有二种。一者无生门。二者示生门。复有二种。一者无出门。二者阴入界门。复有二种。一者寂灭门。二者出生门。复有二种。一者定门。二者教化门。复有二种。一者法界门。二者护正法门。复有二种。一者声闻门。二者深心菩提行门。复有二种。一者辟支佛门。二者四无碍门。若有菩萨于如是等二种法门。为他示现无所执着。于一切法门亦复如是。是名方便。复有二种门。一者贪门。二者离贪门。复有二种。一者嗔门。二者离嗔门。复有二门。一者痴门。二者离痴门。复有二门。一者烦恼门。二者离烦恼门。复有二种。一者一切生门。二者离生门。此名菩萨方便门。复有二种。一者一切凡夫行门。二者一切学无学声闻辟支佛菩萨如来门。若能知此二种门者。是名菩萨最胜方便

大庄严法门经卷上大庄严法门经卷下(亦名文殊师利神通力经亦名胜金色光明德女经)

        隋天竺三藏那连提耶舍译

尔时世尊。与侍者阿难。在耆阇崛山顶大经行处。遥赞文殊师利言。善哉善哉文殊师利。善说菩萨最胜精进方便法门。如汝所说。赞此语时其声遍满三千大千世界。一切大地六种震动。是时无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。帝释天王大梵天王四天大王。皆悉寻声同诣佛所。恭敬礼足却住一面。俱白佛言。世尊。向闻如来赞善哉声遍大千界地皆震动。未审。如来赞叹谁耶。尔时世尊告诸大众。我向赞叹文殊师利。是时大众复白佛言。世尊。文殊师利今在何处。佛言。在王舍城东门路上。共金色女为诸大众敷演妙法。汝等若欲乐闻法者宜可往彼。是时一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。帝释天王大梵天王四天大王闻佛教已。俱诣文殊师利所。各现自身殊胜光明。雨天妙华遍王舍城及诸大众。尔时一切人天大众。皆得相见无有障碍。时王舍城一切人民。见诸天众及见妙华。皆共相随往文殊师利所。尔时阿阇世王。以大威德庄严四兵及后宫婇女。亦皆往诣文殊师利所。是时城中一切王子。大臣长者居士子等。见金色女心住寂灭。皆舍染心五根清净。具诸惭愧无复烦恼。时文殊师利。见此大众于金色女无染心已。问金色女言。汝今烦恼置在何处。令诸王子乃至居士子等不生染心。金色女言。一切烦恼及众生烦恼。皆住智慧解脱之岸。如如法界平等法中。彼诸烦恼非有生非有灭亦不安置。我如是知如是正见烦恼体性。文殊师利语金色女言。何者是烦恼体性。金色女言。诸恶觉观是烦恼体性。不净攀缘故烦恼则生。清净觉观故烦恼如客。是故烦恼不与空智和合。不与无相无愿和合。如大毒蛇眼视人时人便消灭。若有智人持阿伽陀药往彼蛇所蛇闻药气即便失毒。乃至童子种种触恼不能为害。文殊师利。我于昔时恶觉观故颠倒心生。为烦恼火之所焚烧。爱着自身不知此身如沫如炎如幻如化如于梦中。受五欲乐如蜜涂刀。愚者贪味不觉伤舌。又如草露见日便消。不知诸行无常迅速。不知五阴一向常苦。不知自身性不清净。不知一切法离我我所种种差别。不知自无所见令他闇蔽。不知自缚复令他缚。我未闻法于此诸法不得解脱。我今闻法得智慧已。于诸烦恼而得解脱。是故一切众生于我身所不生贪心。文殊师利。譬如光明不与闇住。如是离贪心者烦恼不住。尔时金色女对文殊师利说是法已。白文殊师利言。一切天人大众云集。唯愿慈悲具说法力。开示人天令知一切烦恼体性。知体性已。于诸众生起怜愍心。为诸众生得安隐故。发阿耨多罗三藐三菩提心。时文殊师利复作是言。此烦恼体性难信难解。何以故。此烦恼性即是菩提故。譬如火未出时不能烧薪。如是不生烦恼于流转中不受生死。如火出已即能烧薪。恶觉生者流转生死。譬如火烧大[卄/積]草木火势难灭。如是恶见毒心与烦恼合。于三界中炽然常烧无有休息。譬如无薪火不得然。如是远离恶见烦恼不生三界。譬如火然设百千岁无有利益亦不增多。烦恼炽火亦复如是。至百千年无所利益亦不增多。譬如火灭不至方所。如是智慧灭诸烦恼。亦复如是不至方所。譬如猛火无能入者。如是自性清净客尘烦恼生而不能染。尔时文殊师利问金色女言。云何见身。金色女言。如见水中月。又问云何见五阴。女言。如见佛所化人。又问。云何见十八界。女言。如见劫火烧诸世界。又问。云何见十二入。女言。如不作业行。又问。云何见四众。女言。如见上虚空。又问。云何观自身。金色女言。知从父母和合而生。又问。云何见我身。女言。如盲人见色。又问。汝今听此法耶。金色女言。如幻人听法。又问。汝发阿耨多罗三藐三菩提心耶。金色女言。我已发心不复更发。又问。汝行檀那波罗蜜耶。女言。烦恼中不行亦不舍。又问。汝满尸波罗蜜耶。女言。满如虚空满。又问。汝修羼提波罗蜜耶。女言。已修如一切众生不生不出。又问。汝发毗梨耶波罗蜜耶。女言。已发如一切法不可得。又问。汝住禅波罗蜜耶。女言。已住如法界中住。又问。汝满般若波罗蜜耶。女言。已满云何满。不增不减方便智故。又问。汝修慈耶。女言。已修如一切众生不生。又问。菩萨大悲当于何求。女言。于一切众生烦恼中求。何以故。若众生无烦恼者。菩萨不发阿耨多罗三藐三菩提心。文殊师利言。喜心当于何求。女言。于最胜信清净菩提喜心中求。文殊师利言。菩萨舍心云何满。女言。舍离一切众生斗诤是名为满。远离一切诸法诤论是故名满。文殊师利言。云何名诤论。女言。若菩萨自言我当舍离一切烦恼度脱一切众生。是名诤论。文殊师利又言。与谁诤论。女言。一切外道。又问。谁是外道。女言。于他邪说随顺忍受是名外道。复次菩萨忍心从何而生。女言。从一切众生恼乱中生。何以故。若不恼乱忍心不生故。若菩萨受诸众生呵骂打辱。其心如地不起怨恨。是名为忍。文殊师利言。云何嗔恨。女言。嗔恨者能灭百劫所作善业。是名嗔恨。又问云何非嗔恨。女言。若于一切烦恼境中无所障碍。名无嗔恨。文殊师利言。菩萨于诤论中云何能胜。女言。菩萨于一切法无所分别亦无所得。是名为胜。文殊复言。云何菩萨远离魔怨。女言。菩萨虽现行魔业无所染着。是则名为远离魔怨。何以故。菩萨虽现五阴烦恼。不与五阴烦恼和合。体性无染故。菩萨虽示生死教化众生。知一切法无去来故。虽为众生说天魔道。于一切智中自身远离我我所故。文殊问言。菩萨云何教化众生。女言。当修方便般若波罗蜜能教化故。文殊又言。菩萨云何安住一切众生。女言。如菩萨自住智中。一切众生亦如是住。文殊师利言。女子。一切大众闻汝说法心生爱乐恭敬于汝。女言。文殊师利。不应如是恭敬供养。如是供养者不名供养。何以故。若见自身他身及见有法。而可说者不名供养。若不见自身他身及有法者。是名供养。如是无闻无著是名听法。亦名供养。文殊师利言。云何法供养。女言。若观身如梦。说者如幻。所闻法如响。如是信已不作二种解脱。是名法供养。文殊问言。云何听法。女言。如说修行是名听法。是金色女以文殊师利童子神通力故。又以自身过去善根智慧力故。于彼众中如法说法。尔时金色女说此法时。众中有亿千人。发阿耨多罗三藐三菩提心。复有过去深种善根诸天人众。其数五百得无生法忍。三万三千天人。远尘离垢得法眼净。胜金色女净心欢喜得顺法忍。得顺忍已。礼文殊师利足。自于己身深生惭愧。作如是言。我于正法犹如死人。唯愿慈愍听我出家。文殊师利言。菩萨出家者。非以自身剃发名为出家。何以故。若能发大精进为除一切众生烦恼。是名菩萨出家。非以自身披着染衣名为出家。勤断众生三毒染心是名出家。非自持戒行名为出家。能令毁禁安住净戒是名出家。非以阿兰若处独坐思惟名为出家。能于女色生死流转。以慧方便化令解脱是名出家。非以自身守护律仪名为出家。若能广起四无量心。安置众生是名出家。非以自身修行善法名为出家。能令众生增益善根是名出家。非以自身得入涅槃名为出家。为欲安置一切众生。入大涅槃是为出家。非以自身除烦恼故名为出家。勤断一切众生烦恼名为出家。非以自能将护身心名为出家。将护一切众生名为出家。非以自解身心缚故名为出家。为解一切众生身心缚故名为出家。非以自身于生死怖畏得解脱故名为出家。能除一切众生生死怖畏。令得脱者名为出家。非以自乐涅槃名为出家。勤行精进为令众生满足一切佛法故名为出家。文殊师利言。女子。夫出家者。于一切众生起慈悲心名为出家。出家者。不见一切众生恶。亦不取相名为出家。出家者。不举他罪有惭愧者教令忏悔是名出家。女子。出家者难名为属他。菩萨不尔。身心自在无系属故。女言。云何出家名为属他。文殊师利言。属戒者名为出家。破戒者不名出家。属三昧者名为出家。乱心者不名出家。属智慧者名为出家。愚痴者不名出家。属解脱者名为出家。离解脱者不名出家。女子言。文殊师利。云何菩萨名不属他。文殊师利言。菩萨内自证法不从他学名不属他。何以故。菩萨于一切智即自开解故。尔时文殊师利。说此出家法已。五百菩萨心生欢喜。即脱身上衣服璎珞奉文殊师利赞言。善哉善哉快说此法。我当修行。尔时文殊师利语金色女言。汝可上车教化威德长者子。若能教化此长者子即名出家。尔时文殊师利说此语时。一切大众咸生疑怪。各作是念。今此女人已离贪欲。何故乃遣共贪者俱。尔时金色女知诸大众心生疑已。语大众言。离贪菩萨虽复常与贪者共俱。以教化故远离恶名。菩萨自离嗔痴。虽与共俱以教化故亦无恶名。菩萨自离烦恼。虽与烦恼者俱。以教化故远离恶名。譬如母子共俱常无贪染。离贪菩萨亦复如是与贪者俱常无贪染。譬如黄门与女人俱亦无贪染。如是菩萨远离三界。虽行欲界而无欲心。时金色女。谛知生死烦恼恶法住离欲际。得离欲光明除欲闇冥。礼文殊师利足礼足已。右绕三匝。临欲上车而说偈言

  我今上车离三毒　　体性清净无贪染
  远离嗔恚有慈心　　无复愚痴得智慧
  我贪觉观已清净　　今当上车诣林去
  我昔有贪心迷醉　　耽着财色不觉知
  犹如大云覆大地　　日光不出不照曜
  彼光不去亦不来　　大云覆故隐不现
  如是众生烦恼覆　　清净大智不光明
  彼智不来亦不去　　知烦恼已智光出
  亦复非从余处来　　恶觉观故烦恼生
  净觉观故烦恼灭　　名色不取亦不舍
  亦复不生亦不灭　　亦不与他他不取
  如是法味甚清净　　犹如灯然灭除闇
  彼闇不去亦不来　　如是智慧离烦恼
  烦恼不去亦不来　　亦复不生亦不灭
  犹如良医疗众病　　但除客病病不生
  而不治彼地水风　　如是文殊胜医王
  治诸众生烦恼病　　智慧因缘无烦恼
  烦恼不去法不失　　而我此身有五阴
  亦复具有诸界入　　我于前者杂烦恼
  今皆远离得清净

时文殊师利。于大众中说法教化已。大众欢喜。文殊师利赞言。善哉善哉至心听法。既赞叹已。于大众中作如是言。我今日要至如来所。汝等大众若欲听法当往佛所。说此语已。文殊师利及诸大众各还所止。尔时胜金色女。与八十从女前后围绕。共长者子同载宝车往诣园林既到林所。种种庄严宝幢幡盖香华璎珞百宝香炉遍林树间为欲乐故。作倡伎乐歌舞戏笑。又设种种甘美饮食。尔时胜金色女。以头枕彼上威德长者子膝上而睡。即以神力于其卧处现为死相。膖胀臭烂难可附近。须臾腹破肝肠剖裂。五藏露现臭秽可恶。大小便道流溢不净。眼耳鼻中及诸身分。一切毛孔脓血交横口出恶气。膖秽臭处薰遍林间。髑髅骨破脑出流散支节涂漫。青蝇唼食蛆虫蠢动。种种秽恶不可称说。时长者子。见此死尸生大恐怖身毛皆竖。而作是念。我今于此无救无依。遍观四方无归依处。倍增怖畏发大怖声。彼长者子二因缘故生大怖畏。一者昔所未见如是怖事是故生怖。二者大众知我与彼同来在此。而今忽死谓我故杀。恐阿阇世王不鉴。此理横见加戮。是故怖畏。时长者子。独于此林不见一人。复作是念我今怖畏。诸沙门婆罗门。天龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。谁能救者。彼长者子过去善根虽熟。以不闻见文殊师利共金色女所说法故。文殊师利。即以神力令诸树林悉说偈言

  一切法体性　　如长者所见
  三界悉虚妄　　如幻皆不实
  皮覆恶不净　　凡夫无羞耻
  恶觉因缘故　　妄想生贪着
  譬如满瓶粪　　外假画庄严
  愚痴不知故　　取瓶头戴行
  堕地即便破　　不净皆充满
  种种臭难近　　心悔求舍离
  如是诸凡夫　　横分别女色
  见长短赤白　　恶觉故爱染
  若见身实性　　汝身亦如是
  谁有实见人　　于臭尸生着
  汝今不应怖　　此法体性空
  一切非真实　　汝先所贪着
  云何今怖畏　　导师释迦文
  能施汝安乐　　说法中最胜
  说诸欲无常　　譬如云雾电
  五欲诳不实　　智者谁贪着
  犹如风鼓水　　能令起泡沫
  彼中无实作　　因缘合故生
  如是名色法　　亦无有实作
  业力故不失　　诸法和合生
  本所见妙色　　于今何处去
  此恶色何来　　而生大怖畏
  是法不住方　　亦不余处来
  不去至未来　　集起故可见
  彼中无作者　　亦无实受者
  离于作受法　　如幻空无实
  汝于他人身　　不应生怖畏
  若能自观察　　汝身亦如是
  如梦中欲乐　　踊跃大欢喜
  寤人着欲乐　　如梦等无异
  汝怖无能除　　亦无安慰者
  汝今应速往　　如来大师所
  汝之大怖畏　　非父母眷属
  知识能救者　　唯有佛世尊
  能拔其根本　　能施畏无畏
  及护无护者　　汝宜归依佛
  亦归胜法僧　　若有天龙等
  归依于彼者　　怖畏皆解脱
  速得天人身

尔时长者子上威德。闻此偈已心大欢喜。踊跃无量深自庆幸。舍弃死尸从林而出。尔时佛在耆阇崛山顶。知长者子善根成熟堪受教化。放大光明。其光遍照摩伽陀国。时长者子于光明中。遥见佛身犹如日出。大众围绕而为说法。见是事已一心念佛。忽然复见七宝阶道周匝栏楯至于佛所。又见妙华遍布街道。时长者子寻路欲往。始发足时。释提桓因即遮前路当道而立。作如是言。汝长者子。欲往见佛获大善利佛亦愍汝。我当与汝俱诣佛所。时长者子即共帝释往至佛所到佛所已。时天帝释即以衣裓曼陀罗华。与长者子教令散佛。时长者子受天华已。发欢喜心以散佛上。头面作礼右绕三匝。于一面立而白佛言。我今至心归依佛归依法归依僧。三归依已作如是言。以此善根种种功德。愿于来世得成阿耨多罗三藐三菩提。而白佛言。世尊。此金色女众所知识。我为欲乐与彼财宝。将向林所共相娱乐。至彼林中枕我膝卧。奄忽而死卒便烂坏臭秽可畏。所将眷属悉舍我去无有见者。恐阿阇世王知此女死。谓我杀害横加刑戮。是故我今生大怖畏。尔时佛告长者子言。汝莫忧怖。我当施汝一切无畏。汝长者子。归依佛者于一切处无所怖畏。又复告言。汝当放舍怖畏因缘。时长者子白佛言。一切怖畏从何而生。佛言。贪嗔痴因缘故怖畏生。身见因缘故怖畏生。恶见因缘故怖畏生。渴爱因缘故怖畏生。我我所因缘故怖畏生。执着因缘故怖畏生。斗诤因缘故怖畏生。自身爱缚因缘故怖畏生。于无常中生常想故怖畏生。于苦法中生乐想故怖畏生。于不净中生净想故怖畏生。于无我中生我想故怖畏生。执着五阴因缘故怖畏生。不观十二入故怖畏生。不观十八界故怖畏生。不见未来恶故怖畏生。不观内外身因缘故怖畏生。爱寿命因缘故怖畏生。长者子。如是等因缘故一切怖畏生。如是等事汝当放舍。又复告言。汝见此女身种种恶事不。长者子言。唯然世尊。我今已见。佛言。如是一切诸法无常败坏苦空不实。但是虚诳。愚痴不知业缘生故。如幻不实离色相故。如梦喜乐无实乐故。如热时炎非水水想故。亦如水光影发照壁水动则动无来去故。如镜中像业力生故。如水中月水静则现无来去故。如响从声生不可说实故。如影不可作故。如幻体性空故。如风性不可捉故。如是一切法虚假不实不增不减故。如是长者子。当知一切法无主无作无有执者。汝先欲觉今何所在。长者子言。此中所见长短好色。恶觉因缘凡夫贪着。于圣法中无如是事。圣人法中但是不净。如实见故。离恶觉故。贪嗔痴尽故。佛言。善哉善哉长者子。见贪性故离恶觉观。离恶觉故贪嗔痴尽。是故汝当生清净心修方便行。于一切境起智慧业。离自身见及他身见。长者子言。菩萨云何生清净心行智慧行。佛言。长者子。菩萨当于贪体性中求于菩提。如是嗔痴体性中求于菩提。亦于一切烦恼体性中求于菩提。如是贪嗔痴等一切烦恼性空无物。菩萨则于一切法中智慧行生。是故长者子。彼贪嗔痴性无有根本。亦无住处。亦无主者。亦无作者。内外清净空无所有。无我无众生无寿命。离富伽罗无相。离恶觉观故无愿。离渴爱取故。如是贪嗔痴体性无生故。菩萨于一切法中智慧行生。复次长者子。清净攀缘方便行。菩萨于一切生心法中悉有菩提。何以故。若彼心无色离色离分别。体性如幻彼此内外不相续者。是名菩提。复次长者子。菩萨不应觉于余事。但觉自心。何以故。觉自心者。即觉一切众生心故。若自心清净。即是一切众生心清净故。如自心体性即是一切众生心体性。如自心离垢。即是一切众生心离垢。如自心离贪。即是一切众生心离贪。如自心离嗔。即是一切众生心离嗔。如自心离痴。即是一切众生心离痴。如自心离烦恼。即是一切众生心离烦恼。作此觉者名一切智智觉。如是清净攀缘方便行。菩萨能知烦恼体性染一切众生心。若有说言客尘烦恼相续染心者。菩萨见法方便于彼众生。善能教化无所恼乱。若彼众生觉客尘烦恼。客尘烦恼亦不能染。佛说此法已。长者子得顺法忍。时胜金色女。知长者子受教化已。庄严五百马车前后围绕。种种音乐皆悉作唱。来诣佛所到已下车。头面三礼右绕三匝却住一面

尔时文殊师利童子。问长者子言。汝识此妹不。长者子言。我今实识。文殊师利言。汝云何识。时长者子。即向文殊而说偈言

  见色如水沫　　诸受悉如泡
  观想同阳炎　　如是我识彼
  见行如芭蕉　　知识犹如幻
  女名假施设　　如是我识彼
  身无觉如木　　亦如草瓦砾
  心则不可见　　如是我识彼
  非我非众生　　非寿富伽罗
  十八界相续　　如是我识彼
  彼中非贪嗔　　亦复非愚痴
  非染非清净　　如是我识彼
  诸凡夫如醉　　颠倒生恶觉
  智者所不染　　如是我识彼
  如彼林中尸　　臭烂恶不净
  身体性如是　　如是我识彼
  过去本不灭　　未来亦不生
  现在不暂住　　如是我识彼
  文殊当善听　　彼恩难可报
  我本多贪欲　　见不净解脱
  彼身实不死　　为化我现死
  愍众故示现　　谁见不发心
  如是贪嗔痴　　及一切烦恼
  如是体性法　　善哉甚微妙

尔时如来即便微笑。从其面门出五色光。遍照三千大千世界。照已还从顶入。尔时阿难见斯光已。即从坐起偏袒右肩。顶礼佛足右膝着地合掌向佛。赞言。善哉世尊。以何因缘示现微笑。诸佛如来多他阿伽度阿罗呵三藐三佛陀。非无因缘而现微笑。佛告阿难。汝见是金色女不。阿难白言。唯然已见。佛告阿难。此金色女。文殊师利已于过去教化令发阿耨多罗三藐三菩提心。今复更于文殊师利所。闻说正法得顺法忍。佛告阿难。汝见此上威德长者子不。阿难白言。唯然已见。佛言。阿难。此长者子。我于过去已曾教化令发阿耨多罗三藐三菩提心。今于我所闻说正法得顺法忍。阿难。此胜金色女。于当来世过九十百千劫。当得作佛号曰宝光多他阿伽度阿罗呵三藐三佛陀。寿命无量。其佛世界名宝德刹。劫名乐生。彼女当来得成佛时。其国众生衣服饮食寿命身色。悉如忉利诸天王等。等无有异。彼佛世界无有声闻及辟支佛。纯一大乘诸菩萨宝。彼宝光如来成佛之时。此长者子得菩萨身。名曰德光。持佛法藏。宝光如来所说法藏皆悉受持。宝光如来临涅槃时。与德光菩萨授菩提记。告诸大众。我灭度后我法灭已。此德光菩萨当得作佛。号曰宝炎如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。尔时如来授二人记已。是时三千大千世界六种震动。放大光明遍满十方一切世界说此授记法时。八千人等。发阿耨多罗三藐三菩提心。尔时长老阿难白佛言。世尊。当何名此经。佛言。此经名大庄严法门。如是受持。亦名文殊师利神通奋迅力经。亦名胜金色光明德女教化经。说此经已。长老阿难。胜金色女。及长者子。文殊师利。天人阿修罗等。一切大众欢喜奉行

大庄严法门经卷下


道地经

    No. 607 [Nos. 606, 608]

道地经一卷

        天竺须赖拏国三藏僧伽罗刹汉言众护造后汉安息国三藏安世高译

    散种章第一

从明胜日出像。亦颜色行德多。中多贵姓尊行德守。本从是种有。世间亦天上皆叉手礼佛。是故持头面为礼佛。为无上天下无有等精进者。鬼龙天人亦在三界中。随近持微妙。不度者便度。死者不复死。老者不复老。皆从行得佛法。亦行者是三无有行亦德守听说谛法自意作。行者得味譬如笮甘蔗。常怖观见积百余。若不得[仁-二+樂]乐穷老死。故在世间没。譬如无有力象堕陷不能自出。世间人亦尔。从若干种经取安。譬如若干种华积在。欲所作着行道地听从若欲度世说。行者便听当说行道地。生老病死忧戚若不可意愁恼。行者若家中行。若弃家行。欲坏苦本者。欲往得道。无有余近无有余归。无有余能解住。当一切舍。如是行者。但当一切舍。使行道地从后来。说生老病死着意忧。便身生苦已欲度世者。便行道地莫厌在身。已有老病死。从是若着意恼生。欲随受佛戒者。便行从致无为。何等为不可行。何等为可行。何等为行者。何等为地者。不可行者。名为念欲念嗔恚念侵念国不念死。随恶知识。不持戒不受慧。不摄意不受教行不问。自斯身念色想念常乐想净。自计身不慧。郡县居羸人并居。念色瞢瞢不离贪。多欲多恚多痴多因缘多食。舍行贪身欲睡眠忘意疑过。精进失精进。畏怖不摄根。多事多说多业多作事。久倒教倒意计。是亦如是。今世法从道或离道。是名为不可行。是何以不可行。离无为故。从后缚束说。嗔恚欲杀常身乐净受想不慧不随从若干恶。佛说是不可行。何等为可行。念出不念嗔恚不念杀。近明知识。持戒净不多食事。问自身不斯念非念不好。念苦念不净。不念身好。不郡县居。不羸人共居。不瞢瞢。自守少恼少事少食。不舍方便。伏身舍睡眠。意在行正。守意无有疑。精进在行。离惊怖摄根门。少说在谛行受谛教修谛意。喜在空泽中行如有观。未得好法便致法。已致便护。多喜欲闻经所身故用足。但不足法行知当死。不乐世间德厌食可无为。亦如是辈行法从应致无为。是名为可行。何以为是可行。从是致无为。从后缚束说戒净堕信不念身敛受法事。听者谛见不侵若干。是应无为得道者。佛说法念若干种意。定无有苦无有疲。已说功德聚。摄根伏身应可行。行者为何等意近事如应行。行者为习。行者近习。是为行习。是行者三辈未得道者。学者不学者。何等为道地。行者所行是为行者地。未得行道者。为何等本起次行居前说是行。如是说竟。学者不学者亦已说。道行地名为止观。何用是止观。但未得四德故。欲致是四德。何用欲致是四德。从是欲致无为故。何因缘致无为。不欲有余为故。何以不欲有余为。但欲除一切苦故。是故行者欲除一切苦。当常莫离莫犯莫穿立止观。若行者穿便不得止亦不得观。空亡苦行。譬如人求火。便钻木上钻着下木便钻。时时中止时时钻止。如是未曾得火。但自劳倦。道譬如是。从后现说。设观法行者中得疲意厌。行者除行莫穿莫疲。倦者从行便失行。譬如夜极冥人冥中闭目行。何时当见明。若行者行不穿慧者如是。日出开目行。便稍稍慧人得无为种。通经者若干。更经通者观经教。便说止观。余经散说。是为道地散种章品

    道地经知五阴慧章第二

从若干经得明坚不老不死甘露。声名闻以行如明月。事者净者慧明者。若守度者更明。并家中行亦尔。恶意不可蒦不可牵如意。是故施得道者。礼得道者。稽首从得甘露故。贪为种。多故为生。菰爱欢喜为忧支。佛说五阴。譬如箜篌。听说从多经牵比行道者。当知身体本为五种所成。色种痛痒种思想种行种识种。如若干户东方郡字。如若干户南方郡字。如若干户西方郡字。如若干户北方郡字。亦非一舍名为郡。是譬色。亦非一色为色种。若干色为色种。痛痒思想行识亦如是。色在十入文亦从法。受入是为色种。百八痛是痛种。百八思想为思想种。百八行为行种。百八识为识种。如是当知五种从后现。譬说不相连着。但本痴故。不闻佛言。或习痴故。譬如树叶着枝。痴恶行着五种成聚五种意计。是身道地行知五阴慧章品

    道地经随应相具章第三

性河开流满度器满。破六足经。蜜突如莲花开慧日。出服胜莲花奉事佛。清净淡泊其相然。至尊世绝福祐人视。其精固将道者敷演如经。已开化行道者。亦当知五种各应相种相。色视相亦色手篌把。亦色更痛为痛相。乐苦亦不乐亦不苦。更痛是为痛相识相为思想。若女人若男子亦余是为思想。所作是为行。若好行若恶行。若不好行若不恶行。是为行相。识相为识。好不好亦非不好亦非好识。是为识相。如是五种各自有相从后说。说是色于乐亦多恶。佛说在经中如应出说。如应五阴种相若干相份。道地随应相具章

    道地经五阴分别现止章第四

所然持甘露种浇五盛阴。为五阴薪从慧明却坏恶火。从三界礼我施礼。为持甘露灭三毒者。从五阴钻所生随应。持智慧意灭恶火意。三界中尊敬者。我亦尊敬意叉手。自从慧智力慧者自得。如自得知佛便教弟子所说应行。听说从是意定五阴分别见。为从慧力所守者。知清净自佛从所意知便现事者。是佛所说应行见行可知。听说意从是定分别五阴行道者。当知分别五阴。行者当那分别知五阴。譬如四衢中堕一贯真珠裹。一人当见已见。便喜爱意喜欲得珠。人见意在珠。是为色阴种。所喜可意是为痛痒种。若上头如是名为贯珠。是为思想种。若意生欲取贯珠。是为行种。从是知为识种。如是五种意在一贯珠俱行。便若干作行亦自行。如是在一贯珠一时俱行。五阴更如是。眼所见色并俱行五行。更耳闻声。鼻闻香。口更味。身更粗细。身中四阴无有色种生。如是五阴种各自分别知。后有说道德者。分别说如是已。得是经说。未得道者受着心。心如是行说我亦现。是说道行五阴分别现止章

    道地经五种成败章第五

已知要得佛。要中竟要作要并得要已竟并要已。更无当要。当礼应无所著。名闻无有量。所语言说譬如明月明为弟子得明知畏脑罪从生能坏干已知五种阴得明成败如有当稽首听。佛言。行道者当知。五阴出入成败。譬如人命欲尽在呼吸欲死。便四百四病中前后次第稍发。便见想生恐畏怖。梦中见蜂啄木乌鸦啄顶脑。一柱楼上自乐见。着衣青黄赤白自身着。见骑马人牧[馬*毛]有声。持[竺-二+奇]作枕聚土中卧。死人亦担死人。亦除溷人共一器中食。亦见是人共载车行麻油污泥污足亦涂身。亦见是时时饮。亦见堕网中猎家牵去。或见自身嘻喜观喜啕。或见道积蟆子自过上。或见敛卤盐。钱。或见被发胆裸女人自身相牵。或有灰傅身亦食。或见狗亦猕猴相逐恐。或见自身灭欲娶嫁。或时见人家中神坏。或时见马来狧须发。或时见齿堕地。或时见担死人衣自着身。或时自身胆裸为涂腻。或见聚土自身转。或时见革及旃着衣行。或时自见家中门弊坏车来到多载油花香。亦见昆弟近自身。严先祖人现粗恐颜色。欲来取是取共行。或时冢间行遽舍花婴颈或时见自身倒堕河水中。或时见堕五湖九江不得底。或时见入菅茅中裸身相割自敷转。或时上树无有蓏无有华无有华戏。或时在坛上舞。或时树间行独乐大美。亦持若干干树破聚薪。或时入舍闇冥不得门出。或时上山崭岩悲大哭。或时鸟棁吞足亦蹈。或时尘坌头。或时虎遮断。亦狗猴亦驴。南方行入冢间。见聚炭发毛分骨捣碎干华。自身见入盐。王见盐王使问。从后现说世间已得多乐根堕。或身堕畏命欲去不得自在。病追促病已促。意便动命尽忧近。便见梦令入大怖。人便意中计。我命欲尽。如是梦身所见便意怖便身残。譬如鸟蹋棁。己身近极苦相着。便欲自归医。己亲属昆弟见病剧。便遣使到医舍。呼使者行。便有是相。不洁恶衣长爪乱须发载坏弊车着穿弊履。颜色黑眼青。车中驾白牛马。自手摩抆须发。呼医已急驾车使上从后缚束。但坐恶乐意不计好乐。不念医病。已坏身便堕罪器。即遣呼医便念病痛不得复活。何以故。趣使得相有如是像跓被服语言车盖须发衣。亦如是讳日来呼若四若六若九若十二若十四来至到复触忌讳日人所不喜医复何血忌上相四激反支来唤是亦不必日时漏刻星宿须臾疑人取相。何以故。或时是恶日时漏刻。有是人行方便。能治病痛病痛有时不能得治。是故不必在时日漏刻故。慧人不亦喜用历日。仙人常劝当为求方便治至死。若病痛横有病可能得活。若命尽但说去计。如是可至病痛舍。从后束结。说俱入海水。或到或中坏。病亦比海。或愈或死。医便行至病痛家。闻声不可意。亡烧断破刺拨刮刷。出杀去发灭蚀烧断破刺拨刮刷出杀去发灭蚀不可治。已死视南方。复见乌鸱巢有声。复见小儿俱相坌土。复胆裸相挽头发。破瓶盆瓦瓯。亦见空器舍不着意。行至病者舍。入见病着人。病更恼。从彼舍来说。医便视病相遽。惊怖惊坐起。着病无有力不得自在。见如是便念。如是经中说死相。见颜色不如皮皱。行身如土色。舌延出。或语言忘。见身重骨节不随。鼻头曲戾皮黑咤干。喉舌如骨色。不复知味。口燥毛孔赤筋脉不了了。被发发竖牵发不复觉直视背卧惊怖颜色转面皱发竖熟视。或语若干说。如经说。余命不足道。譬如树间失火。亦如六相无说所闻见。若有沐身未浴身时。譬栴檀香。或时如蜜香。或时多核香。或时那替香。或时根香。或时皮香。或时华香。或时蓏香。或时霍香。或时宿命从行相。筋香发香骨香肌肉盟血香大便香。或时鸱香。或时乌香。或时蚖香。或时猪香。或时狗香。或时狖香。或时鼠香。或时蛇香。或时譬如有人。或时啄木声。或时瓦声。或时涩声。或时恶声。或时雁声。或时孔雀声。或时鼓声。或时马声。或时虎声。亦有说熟死相中。譬如人死时有死相为口不知味。耳中不闻声。一切卷缩脉投血肉[浿*昜]颊车张上头掉影无有明。臀肉竖眼黑色黑。大小便不通。节根解口中上臛青双哕计。如是病痛相不可治。设鶣鹊亦一切良医并祠祀尽会。亦不能愈是。便医意念。是病痛命求绝。应当避已。便告家中人言。是病所未所思欲。当随意与莫制禁。我家中有小事。事竟当远。屏语病者家人言。不可复治。告已便去。病痛家已闻医语。便弃药所事方便便止。亲属知识比邻共会。还绕病困者悲哀哭视。譬如牛为屠家所杀。余牛见死牛恐自及。跳场惊怖走入山树间叫唤。复譬如猪为屠家所杀。余猪见惊怖畏效死。便耸耳直视。复如鱼为捕鱼堕网者。余鱼见惊怖沈走入沙石间[疑/木]藻中藏。复譬如飞鸟聚行。一鸟为鹰鹞所得。余鸟惊分散分走。如是昆弟亲属知识邻里。见哀离别视命欲断。地狱使者已到将入狱。在斯便转死。箭已射已。生死索行罪便牵往过世。亲属已还收发草[糸*絜]。若忼忾声满口不止。出悲语见爱念。若干种胞颐[泳-永+羨]洟出。呼当奈何。病者不复久。内见风起名刀风。令病者散节。复一风起名遽风。令病者断结。复一风起名针风。令病者筋缓。复一风起名破骨风。令病者骨髓伤。复一风起名藏风。令病者眼耳鼻孔皆青。发毛出入一切。是孔令坏断拔舍。复一风起名复上风。令病者内身膝胁肩背胸腹脐小腹大肠小肠肝肺心脾肾亦余藏令断截。复一风起名成风。令病者青血肪膏大小便生熟热寒涩令干从处却。复一风起名节间居风。令病者骨骼直掣振。或时举手足。或把空。或起或坐。或呻号或哭或嗔。已散节。已断结。已筋缓。已骨髓伤。已精明等去。裁身有余在。心已冷如木已弃五行。并心中羸羸裁有余微。譬如灯灭有余明。裁心有余但有微意。识是人本所行好丑罪福心便见。今世若有好行意便喜。若恶即时惭。得好处者意喜。堕恶处者意即愁惭。譬如人照净镜尽见面像。发白皮皱生体垢尘。或齿堕或尘齿见身从老。屡如是即自惭。闭目放镜不欲见。以放镜忧愁。我已壮去老到颜色丑乐已去。如是素行恶。在意从恶行。便忧愁悔受苦恼不可意自责。今我堕恶处为无有疑。若如行者行三好。若干守行愿。最好行者多好。即时喜多喜意可自喜。我今上天亦好处。譬如贾客。从涩道得脱出。得多利归家到门喜。亦譬如田家愿获五谷着舍中。亦如病痛得愈安隐。亦如负债已偿。素行好亦如是合好行。譬如蜜蜂便意生我已到好处。即时身精识灭中便有阴。譬如称一上一下。如是舍死受生种。譬如种禾根生双。如是中时灭识即时中生五阴具足不少。死阴亦不中得五阴往。亦不离死五阴为有中五阴。有但死五阴故中五阴生譬如人持印印好埿。埿中便有印。像印亦不往至埿。埿亦不离印像。譬如种生根。种亦非根根亦不离种。人神亦如是小大如法。从生往至中。从是本会有。好行者中得好五阴。恶行者得恶中。得阴者为天眼行。中止者为三食。乐念识。中止者或住一日或住七日止。到父母会亦所堕处从中止。当到所堕即死时已生中阴。便生千思或见念便痴生。最恶行者便自然大火边。亦若干百千乌鸦鹰鹞共会。亦见人恶爪面齿被服然头为手中行若干种毒。身自见远丛树。便意生入中。便中阴灭生所堕处。即时不久便见刀叶树堕中。是名为地狱。五阴生入罪。咸所恶行。便见猛烟尘火风雨来着身。复见象师子虎蚖自恐身。亦见丘井亦合后。亦止绝崖岸。生意入中便舍中阴身已。意生便灭中阴堕处生。即时不久到畜生。后现行极痴无有礼。持恶意向父母。常喜可粗言嗔恚缚捶行恶。是人不与取便堕畜生。罪轻减便生热风。命饥恼身刀矛钻绕。还人亦见大坑。意生当入。是即意生便灭中阴。受所堕处阴。便即时堕饿鬼。如是堕名为饿鬼。从有说行两贱贼人共语。亦谗失诫诬妄论议。一切食不避恶不净。从善还不行法语。便堕盟血唾涌泥。是名为堕饿鬼处。行最好者得最善乐。亦得香风吹若干种华见自散身。若干种伎乐声相随。若干种树在园中。意生即入时。意已生便中阴灭。所应堕阴受生。便即时受上天身。如是堕天上。有福行者堕应上天。已有不离法是为堕天种。若堕人中从本行受殃福。父母亦聚会。夙行应男从生福亦止等。同时父母收精胞门不坚。从风热寒。亦不染亦不邪曲。亦不屡亦不涩。亦不汁思饭不起不慢不杀胞门。亦不像栗不像轮。亦不像狸亦不像麦。中央亦不像自刚铁中央亦不像锡中央。一切门无有恶精。亦不薄亦不厚。不亦腐亦不黑亦不赤亦不黄。乘色亦不散。亦不风血寒热杂。亦不小便合精。神已止精。神念往意生欲。却男自身代共乐羸人。羸人便恶父喜母。已喜不喜增意生。当却是男欲独与羸人共乐。已即跓胞门意生已却男。我已羸行礼。父母即时堕精。神便到意生为是我精。即可意喜生。已喜生中迹灭便在精血生。识在精中复生爱中爱识不堕精。但从本复生爱识。精是儿身。所爱在精生。是为痛痒种。已知为精。为精者为思想种所本。行念为生死种。已知精为识种。是为五种要。即时得两根身根心根精已。七日不减二七日精生。薄如酪上酥肥。三七日精凝。如久酪在器中。四七日精稍坚如酪成。五七日精变化如酪酥。六七日如酪酥变化聚坚。七七日变化聚坚藏。譬如熟乌麮。八七日变化灭乌麮。譬如磨石子。九七日在磨石子上生五腄。两肩相两膑相一头相。十七日亦在磨石子上生四肘。两手相两足相。十一七日亦在磨石子上生二十四肘。十在手指相十在足指相。四在耳目鼻口止处相。十二七日是肘为正。十三七日为起腹相。十四七日心脾肾肝心生。十五七日大肠生。十六七日小肠生。十七七日胃生。十八七日生处肺处熟处。十九七日髀膝足臂掌节手足趺约。二十七日阴脐乳颈项形。二十一七日为骨髓应分生。九骨着头两骨着颊。三十二骨着口七骨着咽。两骨着肩两骨着臂。四十骨着腕十二骨着膝。十六骨着胁十八骨着脊。二骨着喉二骨着臗。四骨着胫十四骨着足。百八微骨生肌中。如是三百节从微着身譬如瓠。二十二七日骨稍坚譬如龟甲。二十三七日精复坚譬如厚皮胡桃。是为三百节连相着足骨连腨肠腨肠连臗骨臗骨连背脊腰骨。连肩肩连颈脰颈脰连头颐头颐连齿。如是是骨聚磈礧骨城筋缠血浇肉涂革覆福从是受靡不知痛痒随意随风作俳掣。二十四七日为七千筋缠身。二十五七日生七千脉尚未具成。二十六七日诸脉悉彻具足成就如莲花根孔。二十七七日三百六十节具。二十八七日肉栽生。二十九七日肉稍坚满。三十七日皮膜成腊。三十一七日皮膜稍坚。三十二七日脽[月*里]肌生。三十三七日耳鼻腹脾脂节约诊现。三十四七日身中皮外生九十九万孔。三十五七日九十九万孔稍稍成现。三十六七日爪甲生。三十七七日母腹中若干风起。或风起令目鼻口开已开入。或复风尘起。令发毛爪生端正亦不端正。或复风起盛肌色。或白或黑或黄或赤好不好。是七日中脑。血肪膏髓热寒涕大小便道开。三十八七日母腹中风起。令得如宿命行好恶。若好行者便香风起。可身意令端正可人。恶行者令臭风起。使身意不安不可人。骨节不端正。或[月*(卄/(ㄇ@儿)/戍)][月*戾]或偻或[身*宛]或魋人见可是。三十八七日为九月不满四日骨节皆具足。儿生宿行有二分。一分从父一分从母。或时毛发舌咽脐心肝脾眼尻血从母。或爪甲骨大小便。脉精若余骨节从父。宿行从母受生。熟在下生在上。儿在左胁背向前腹向后。女在右胁腹向前背向后。止处臭恶露一切骨节。卷缩在革囊在腹内血着身在外处大便肥长。九月余有四日一日二日中。若宿行好便意生。我在园中意计若在天上。若恶行者意生。我在狱止二日意在三日中。即腹中乐三日意在四日中。一日一夜母腹中上下风起。儿从是风倒头向下。足在上堕母胞门中。宿行好。于母胞门中意生堕池水池水中戏。复意生在高床上若香华中。宿命行恶者意生从山堕树上。堕岸上。堕坑中。堕溷中。堕蒺[卄/梨]中。堕网中堕茅中。堕刀矛栏中。从行忧恼匆匆。亦从喜从乐名闻好恶行。自缚身。在所到。自更得便出。既为胞门。所缠裹。产户急笮堕地中。风复为人温汤所洗手粗身遍痛如疮。从是便忘宿行腹中所更。已生从血臭故。便聚为邪鬼魑飞尸各[魅-未+屬]魃蛊魅魖行。父亦如是。譬如四街有一脔肉。为鸱鸢乌鹊众鸟所争各自欲得耶。环绕娆人如是。有宿行好耶。不能得着宿行恶耶。能得着生未久母便养乳。稍稍大便饮食。已能饮食。八十种虫生身中。二种发根生。三种着头。一种着脑。二种着中脑。三种在额。二种着眼根二种着耳。二种着耳根。二种着鼻根。二种着口门。二种在齿。二种在齿根。一种在舌。一种着舌根。一种着口中上齶。一种在咽。二种在膝下。二种着臂根。二种在手。一种着肘。二种着脾。一种着心。一种着乳根。一种着脊根。二种着胁。二种着背。一种着脐根。一种着皮。二种着肉。四种着骨。五种着髓。二种着大肠。二种着小肠。一种在热处。一种在寒处。一种在大便道。三种在大肠根。二种着臗根。五种着阴根。一种着指节约。一种在胫。一种在膝头。一种在足[跳-兆+尃]。如是八十种虫着身中。日夜食身。身便生寒热风病各百一。杂余病复有百一。如是并四百四病在身中。譬如木中出火还烧木。病亦从身生。如是但坏身无有异。如是从内坏病亦中勿复问从外恼常坏恼今世。现在身常着衰。世间人不闻者意计身[仁-二+樂]。但不至诚见故。发毛爪齿心肉肌骨清血热恼生熟涕唾屎尿从身流。非常亦不净。痴人计为净。都卢儿拨肌合裁如一酸枣为裹着身。从如是酸枣肌。痴不闻者世间人得调身自坏堕恼。譬如鱼但见饵不见钩不见网。复譬如小儿舐利刀蜜但嗜甜不见刀刃。复譬如金错涂铜卖欺人痴人不觉以为钝金故买为自侵。如是世间人。或见如酸枣肌裹身。从受若干恼不觉。如是。酸枣肌发去。但有肉骨血在。人足践蹋常恶不敢视。谁敢抱持者。素行殃福已尽。或时横命尽。如陶家作器。或时在拘。或从[革*(罩-卓+瓦)]或从行轮。或已行。或在干流时。入窖火烧时。或已熟出时。或给用时。要会当坏。人身亦如是。或从堕腹中。或不成根去。或不具根去。或临生时去。或适生去在学业时去。或时从十六至三十八十百岁。或不啻久久。要会当死。阴如是定不久。有生辄灭。举足灭下足灭。世间人不闻者自计小时身壮时身老时身。为是我身。与行道者意异。行道者从是有是从无有是无有是。何等为从是有是从罪。行有死中。从中识堕业薄从薄凝。从凝稍坚六根。从六根便生。从生儿身。从儿身壮长。从壮长得老病死身。如是常随。如是世间轮不断无所属。空如幻逐不止。譬如火起城中火风吹舍舍相燃。第一舍火非第二舍火。亦不啻但为上舍已燃。次舍复燃。如是转延生死亦如是。是因缘无有是亦无有是。是灭是亦灭。何等为无有是亦无有。是素行殃福无有死中亦无有。已无有中当那得往。已不得往当那得生。已不得生当那得老病死。生死如流水。不行生死业便止。行道者当知是五阴本从生灭。道地五种名为成坏章也

    道地经神足行章第六

慧清入心如水。破恶从树离种花。度世乐功德聚。凉风可乐无有过自归一心何在在不中止观意如称摄钩牵闻经中止观世间明。叉手持头面从三界皆作礼彼。或时行者居前止便得观。或时行者当得止观居前得止。若行者止意已得应从观得解。若行者观已足当应从止得解止观相云何。若意在使一因缘止止不动不或念余是应止相。若在止处偏分别偏去如相观思惟如有受是应观相。譬如买金家见金不观试。如是应止。若持金试知。是金某国某处杂铜不真。知石色好丑长短圆方濡亦余病。观譬如是。譬如人刈刍。左手把刍右手持镰便断刍。彼譬如把刍是应止。如断刍是应观。譬如行者见髑髅熟谛视。若如开目见。闭目亦见亦尔无有异。是应止。若分别观头骨异颔骨异齿骨异颈骨异臂手胁胭膝足骨。如是观。如是见骨连。从四因缘致有。何等为四。食礼行合骨见非常苦空非身从不净生无所有。是应观。要听止观相不分别。是为止。分别是为观止意。行者持何等行得止意报。若干因行止意。听说要止意二因缘方便行得止意。一者念恶露。二者念安般守意。恶露行云何。是间行者等意念一切人令安隐。便行至父树便行至观死尸一日者。至七日者膖胀者。青色者。如盟者。半坏者。肉尽者。血洗者。骨骨连者。筋缠者。若白若解散四面。无有数手破。譬如鸽色。彼行者自在取一敷意令知。不久意着止。令意在敷处熟谛观。若自知如今是敷处。是间在又处自见。远在所见亦如是。是空处一处便正坐便见。如敷因缘在地所见随亦如是。便行无有声处。无有说处。人空处一处便正坐。便见如上久处。令意见念无有异。若行者从敷因缘失不受念意不生。便复往至父树。令意受敷因缘相令意坐。亦引不离念常在。前若行者意敷因缘。出入远行常在意止不远离。已昼夜在心。令半月一月一岁。复不啻令行不失行。令行时止时。坐独坐时。多众中共坐时。病疲时。有力时。连随常念敷意因缘在前住。令敷因缘念如是非常。若空非身不净无所有。令如本因缘敷意行念无有异。若己意在敷处得自在。便持响自身观。若见死尸亦自身等无有异。便若见男子。若见羸人。若见老若壮若少年。若不端正若胆裸若着衣若庄严。若彼亦尔。如敷念处若意念所在。所在一切无有异。便已应从念恶露得止意。是时意随行念不离。行增满譬如河入海

    道地经五十五观章第七

行道者当为五十五因缘自观身。是身为譬如沫不能捉。是身为譬如大海不厌不足五乐。是身为譬如大河日愿至死海。是身为譬如大便慧人不欲故。是身为譬如沙城疾坏散去。是身为譬如会坏城多怨家。是身为譬如化城不自有亦不可取。是身为譬如骨关肉血涂。是身为譬如弊坏车筋缠故。是身为譬如家猫贪恚痴聚。是身为譬如荒泽中常痴失亡。是身为譬如忘善意常忘失。是身为譬如榆百八爱行。是身为譬如破瓶常漏。是身为譬如画瓶内杂最恶满。是身为譬如清溷九门故。是身为譬如軯血人所恶故。是身为譬如幻痴计谛。是身为譬如疥。是身为譬如意着苦故。是身为譬如腐谷舍饮食坏故。是身为譬如大窟多虫多虫止。是身为譬如骨嚾罪如满狐猴不失。是身为譬如不熟器疾坏故。是身为譬如一囊两口净入不净出。是身为譬如干垢裳衣干。是身为譬如车常行至葬地。是身为譬如露雾不久止。是身为譬如疮上漏。是身为譬如盲不知谛。是身为譬如处四百四病。是身为譬如坑一切不净聚。是身为譬如地孔虺止会。是身为譬如空把为痴人所欺。是身为譬如冢间常可畏可怖。是身为譬如虎师子共居嗔恚忽然。是身为譬如颠疾盛八十八结行故。是身为譬如恒常涂畏死。是身为譬如铜涂金肌覆故。是身为譬如空聚常中细六衰。是身为譬如饿鬼常求食饮。是身为譬如畏处常老病死。是身为譬如腐髑髅为常衣洫。是身为譬如怨家常成事逢恶因缘。是身为譬如迦陀树皮皮中央无所有。痴人意是为最重。是身为譬如度载多胎小。是身为譬如腐囊腥臭。是身为譬如深冥六十二疑不自守。是身为譬如喜妒不可不得不受。是身为譬如腐垣壁从恶念因缘。是身为譬如结垢内有恶。是身为譬如不意常着外衰。是身为譬如无所依如无所依舍爱不爱碜一切。是身为譬如不可近近常破碎。是身为譬如无有能护时时为病碜一切。是身为譬如无有自归死来时不得离故道地经一卷


得道梯橙锡杖经

    No. 785

得道梯橙锡杖经

        失译人名今附东晋录

尔时世尊告诸比丘。汝等皆应受持锡杖。所以者何。过去诸佛执持锡杖。未来诸佛执持锡杖。现在诸佛亦执是杖。如我今日成佛世尊亦执如是应持之杖。过去未来现在诸佛。教诸弟子。亦执锡杖。是以我今成佛世尊。如诸佛法。以教于汝。汝等今当受持锡杖。所以者何。是锡杖者。名为智杖。亦名德杖。彰显圣智故。名智杖。行功德本故曰德杖。如是杖者。圣人之表式。贤士之明记。趣道法之正幢。建念义之志。是故汝等咸持如法。尔时尊者迦叶从坐而起。整衣服偏袒右肩。合掌胡跪。而白佛言。世尊。云何名锡杖。云何而受持。唯然世尊。愿敷演说。我等奉行。佛告迦叶。谛听善思当为汝说。所言锡杖者。锡者轻也。依倚是杖。得除烦恼。出于三界。故曰轻也。锡者明也。持杖之人。得智慧明。故曰明也。锡言不回。持是杖者。能出三有。不复染着。故曰不回。锡言惺也。持是杖者。惺[宋-木+悟]苦空三界结使。明了四谛十二缘起。故曰惺也。锡言不慢。持是杖者。除断慢业。故曰不慢。锡者言疏。持此杖者。与五欲疏。断贪爱结。散坏诸阴。远离五盖。志趣涅槃。疏有为业。故曰疏也。锡言采取。持是杖者。采取诸佛戒定慧宝。获得解脱。故曰采取。锡者成也。持是杖者。成就诸佛法藏。如说修行。不令缺减。悉具成就。故曰成也。佛告迦叶。如是锡字。其义广多。不可具陈。汝今且当如是受持。迦叶白佛言。世尊。是锡杖者。其义如是。云何智杖。乃至建念义之志。唯然世尊。愿为敷演。佛言。是锡杖者。为修智士。广修多闻。解世出世。分别善恶。有为无为。有漏无漏。了智无碍。智慧成就。故曰智杖。为持禁戒忍辱禅定。一心不乱。常修福业。无时懈怠。如救头然。故曰德杖。摄持是杖。如斯之人。内具十六行。谓四谛。苦集灭道。四等慈悲喜舍。四禅初禅二禅三禅四禅。四无色定。空处识处不用处非想非非想处。复具三十七行。谓三十七助道法。于是法中。了了分别。自身作证。不随音声。于是法中。而自遨戏。入空无相无愿解脱门。自在无难。名之为圣。内有是德。外执锡杖。表式此人。必有圣德。戒定忍慧。三明六通。及八解脱。皆悉具有。以记此人。望表生敬。故曰圣人之表式也。贤士之明记者。内有智性。故曰贤士明记。此人内有智性。习功德本。于法增进。善心成办。故曰贤士明记。此人不久之间。智慧成就。入无为处。寂然宴静。涅槃安乐。第一义道。故曰趣道之法幢。建念义之志者。是杖有三鬲。见三鬲重。则念三涂苦恼。则修戒定慧。念三灾老病死。则除三毒贪嗔痴。念三界之无常。则信重于三宝。除三恶。断三漏。净三业。欲具三明。入三解脱得三念处。通三达智。故立三鬲。以相重也。复有四鉆者。用断四生。念四谛。修四等。入四禅。净四空。明四念处。坚四正勤。得四神足。故立四楞。通中鬲五。用断五道苦恼轮回。修五根。具五力。除五盖。散五阴。得五分法身。故立五也。十二环者。用念十二因缘。通达无碍。修行十二门禅令心无患。三重四楞合数成七。以念如来七觉意法。成就七圣财。通鬲钻八用念八正道。得八解脱。除灭八难。故用八也。略说锡杖其义如是。汝当善持。迦叶白佛。如是世尊。如圣法教

尔时迦叶复白佛言。世尊。三世诸佛法同是也。佛言。有杖是同。若用不同。或有四钴。或有二钴。环数无别。但我今日四钴十二环用是之教。二钴者迦叶如来之所制立。令诸众生记念二谛。世谛第一义谛。以立其义。尔时世尊。说此法已。尊者迦叶。千二百众。及诸大会。皆悉欢喜。顶戴奉行

凡体法。上台法天。下台法地。四支法四天王。十二环法十二因缘。包含天地人天上下。无不斯尽。凡发慈。广生万行物不准此。已起善本。持此杖法。赍天挟地。着左胁下。以小指句之。使两头平正。不令高下。鸣则常鸣。不令声绝。其声均细调和。恒使若初。若初无声讫。一行处不令有声。若初有声讫。一行处常令有声。亦使粗细一等不得。或粗或细。僧置左足。尼置右足。不得着地。若檀越不出。近至三家。远满七家。若不得更不容多过。若过非行者法。若限内得食。持杖悬之树上。勿令着地。若无树着地。就地平处一不令倾侧。眠时安杖与身相顺。置之床后。正与身齐。不令前却。持行路止息时。头常向日。勿令倒逆违背。持此杖即持佛身。万行尽在其中。谓持天挟地。并观十二因缘。为护身。一切如其倾侧。一切万物皆亦倾侧。如其平正。一切含生。皆令安隐无为。若下台着地之时。令三涂众生苦剧踰增。若不着地。令三涂众生因之得拔。如其颠倒。则逆世界。亦令行者其心迷乱。若能顺持。彼此俱利若如是持。具现得威仪出入护助。后得获果。速成正觉。

持锡杖威仪法。有二十五事。持锡杖十事法。一者为地有虫故。二者为年朽老故。三者为分越故。四者不得手持而前却。五者不得担杖着肩上。六者不得横着肩上手垂两头。七者出入见佛像不听有声。八者杖不得入众。九者不得妄持至舍后。十者杖过中不出。复有五事。一者远请行宿过中得出。二者至病瘦家过中得出。三者送过世者过中得出。四者外道请者过中得出。五者不得将杖指人画地作字。复有五事。一者三师俱出不得持杖自随。二者四人共行除上座不得普持。三者到檀越门好正威仪。四者入檀越门三抖擞三反不出从至余家。五者檀越出应持杖着左肘中央

复有五事。一者杖恒在己房中不得离身。二者不听下头着地。三者不听杖许生衣。四者日日须好磨拭。五者杖欲出时当从沙弥边受。若无沙弥白衣亦得

  锡杖四钴应四谛　　环应十二因缘
  中召明中道义　　上头应须弥顶
  第二应须弥山　　中央木应于空
  下错应须弥根

沙门之法。解空得道。执此惺窹。世间一切众生。诸比丘等至心奉行得道梯橙锡杖经

    又持锡杖法(依天竺藏经重出使后人看阅知其源流也)

锡杖有二十五事威仪。持锡杖有二十五事者。一者为蛇虫故。二者为年老故。三者为分卫故。四者为出入见佛像不得使头有声。五者不得持杖入众。六者中后不得复杖出。七者不得担着肩上以手悬两头。八者不得横着膝上以悬两头。九者不得手掉前后。十者不得持至舍后。十一者不得复持在三师前后。已杖出不得复杖随。十二者若四人俱行。一人已持。不得复持随。十三者若至檀越家。不得舍杖离身。十四者至人门户时。当三抖擞不出应当更至余家。十五者主人出应当杖着左肘挟之。十六者若至室中。不得使着地。十七者当持自近卧床。十八者当数取拭之。十九者不使头有生。二十者欲行当从沙弥若白衣受。二十一者至病人家宿应得暮杖。二十二者欲远送过去者应得暮杖。二十三者远请行宿应得暮杖。二十四者远迎来者应得暮杖。二十五者常当自近不得指人若画地作字

持锡杖法


灯指因缘经

    No. 703

灯指因缘经

        后秦龟兹国三藏鸠摩罗什译

若种少善于胜福田。人天受乐。后得涅槃。是以智者。应当勤心修集善业。言福田者。即是佛也。佛身光明。如融金聚。功德智慧。以自庄严。得圆足眼。善能观察众生诸根。世间黑闇。为作灯明。众生愚痴。为作亲善。众善悉备。名称普闻。牟尼世尊。众所归依。是故人天。至心修福。无不获报

昔王舍城。五山围绕。于五摩伽陀。最处其里。此王城内里巷。相当[這-言+(序-予+手)]园广博。台观严丽。堂室绮妙。高轩敞朗。周匝栏楯。有好林池。甚可爱乐。其水清净。温凉调适。通渠回流。转相交注。林树萧森。枝条蓊郁。华实繁茂。映蔽日月。风吹花林。出微妙香。其香苾馚。芳馨四塞。遍王舍城。诸胜智人。修梵行者。咸以此地。庄严殊特。心生喜乐。自远而至。云集其中

时此城主。阿阇世王。道化光被遐迩所归。正法治国。修善者众。国实民殷安隐快乐。尔时城中。有一长者。其家巨富。库藏盈溢。如毗沙门。然无子胤。祷祀神祇。求乞有子。其妇不久。便觉有身。满足十月。生一男儿。是儿先世宿殖福因。初生之日。其手一指。出大光明。明照十里。父母欢喜。即集亲族及诸相师。施设大会。为儿立字。因其指光。字曰灯指。诸集会者。睹其异相。叹未曾有。时此会中。有婆罗门。名曰婆修。诵四围陀典。博闻多知。事无不晓。见儿姿貌。奇相非常。含笑而言。今此儿者。或是那罗延天。释提桓因。日之天子。诸大德天。来现生也。时儿父母。闻是语已。倍增欢喜。设大檀会。七日七夜。布施作福。如是展转。举国闻知。皆云长者产一福子。称美之音。上彻于王。时王闻已。即敕将来。长者受教。寻即抱儿诣王宫门。值王宴会。作众伎乐。无人通启。不得辄前。其儿指光。彻照宫[這-言+(序-予+手)]赫然大明。照于王身及以宫观。一切杂物。斯皆金色。其光遍照于王宫内。譬如大水湛然盈满。王即怪问。此光何来。忽照吾宫。将非世尊欲化众生至我门耶。又非大德诸天释提桓因日天子等下降来耶。王寻遣人。往门外看。使人见已。还入白王。向者大王。所唤小儿。今在门外。此儿手在乳母肩上。其指出光明来彻照。故有此光。王敕使言。速将儿来。王既见之。深异此儿。自捉儿手。观其儿相。谛瞻睹已。而作是言。外道六师。称无因果。真伪诳惑。若无因果。云何此儿。从生已来。容貌超绝。指光炳着以此观之。诸外道辈。陷诸众生。颠坠恶趣。定知此儿非自在天之所化生。亦非神祇。自然而有必因宿福。获斯善报始知佛语诚谛不虚。佛说种种业缘。庄严世间。一切众生。眼见报应。而不修福。一何怪哉。王复言曰。今犹未审。此指光曜。或因于日。而有此明。必欲验者。须待夜半。既至日暮。即以小儿。置于象上。在前而行。王将群臣。共入园中。而此小儿。指光所照。幽闇大明。观视园中。鸟兽华果。与昼无异。王观此已。喟然叹曰。佛之所说。何其真妙。我于今日。于因于果。生大坚信。深鄙六师。愚迷之甚。是故于佛。倍生宗仰。于时耆域。即白王言。佛于修多罗中说。若不见业。故有悭贪。以见业故。悭贪永息。今见灯指。有此福报。假令穷困。尚应罄竭。而修善业。况复富饶。而不作福。如是语顷。天已平晓。还将灯指。入于王宫。王甚欢喜。大赐珍宝放令还家。灯指渐渐。遂便长大。其父长者。为求婚所。选择高门与己等者。娉以为妇。长者既富。礼教光备。闺门雍穆。资产转盛。夫盛有衰。合会有离。长者夫妻。俱时丧亡。譬如日到没处晖光潜翳。如日既出月光不现。如火为灰炽炎永灭。强健好色。为病所坏。少壮之年。为老所侵。所爱之命。为死所夺。父母既终。生计渐损。而此灯指。少长富逸。不闲家业。恶伴交游。恣心放意。耽惑酒色。用钱无度。仓库储积。无人料理。如月盈则阙转就损减。时彼国法。岁一大会。集般周山。于时灯指。服饰奢靡。将从伎乐。皆悉严丽。拟于王者。诣彼会所。彼会大众。见其如是。无不敬美。尔时众人。共相酣饮。欢娱适意。钟鼓竞陈。弦歌普作。欢舞平场。嬉戏原野。娱乐之音。动山盖谷。时后群贼。知灯指诣会未还之间。伺其空便往到其家。劫掠钱财。一切尽取。灯指暮归。见己舍内。为贼劫掠。唯有木石塼瓦等在。见此事已。闷绝躄地。傍人水洒。方得醒寤。忧愁啼哭。而作是念。我父昔来。广作方宜。修治家业。劬劳积聚仓库财宝。是父所为。生育我身。觊有委付。如何至我。不绍父业。浮游懒惰。为人欺陵。父之余财。一旦丧失。仓库空虚。畜产迸散。顾瞻舍宅。唯我子然。着身璎珞。及以服乘。当用贸食以济交急。用之既尽。当如之何。当于尔时。指光亦灭。其妻厌贱舍弃而走。僮仆逃失。亲里断绝。素与情昵极亲厚者。反如怨仇。见其贫穷。恐从乞索。逆生嗔怒。妇尚舍弃。况于余人。当知贫穷。比于地狱。贫穷苟生。与死无别。先惯富乐。卒罹穷困。失所依凭。栖寄无处。忧心火炽。愁毒燋然。华色既衰。悴容转彰。身体尪羸。饥渴消削。眼目押陷。诸节骨立。薄皮缠綶。筋脉露现。头发蓬乱。手足锐细。其色艾白。举体皴裂。又无衣裳。至粪秽中。拾掇粗弊。连缀相着。才遮人根。赤露四体。倚卧粪堆。复无席荐。诸亲旧等。见而不识。历巷乞食。犹如饿乌。至知友边。欲从乞食。守门之人。遮而不听。伺便辄入。复为排辱。舍主既出。欲加鞭打。俯偻曲躬。再拜谢罪。舍主轻蔑。都不回顾。设得入舍。轻贱之故。既不与语。又不敷座。与少饮食。撩掷盂器。不使充饱。时彼国内。取妇生子剃发法皆设会。往到会中望乞残食。以轻贱故。不唤令坐。驱其走使。益索所须。得少余残。与奴共器。便自思惟。怪哉怪哉。我今云何。贫贱伶俜。忽至如此。私自念言。如我今日。精神昏迷。心智失识。不知今者为是本形。更受身耶。辛苦荼毒。世所无偶。譬如林树无花众蜂远离。被霜之草叶自燋卷。枯涸之池鸿雁不游。被烧之林糜鹿不趣。田苗刈尽无人捃拾。今日贫困。说往富乐。但谓虚谈。谁肯信之。世人甚众。无知我者。由我贫穷。所向无路。譬如旷野为火所焚。人不喜乐。如枯树无荫。无依投者。如苗被雹霜。捐弃不收。如毒蛇室。人皆远离。如杂毒食。无有尝者。如空冢间。无人趣向。如恶厕溷。臭秽盈集。如魁脍者。人所恶贱。如常偷贼。人所猜疑。我亦如是。所向之处。动作讥嫌。所可谈说。发言生过。虽说好语。他以为非。若造善业。他以为鄙。所为机捷。复嫌轻躁。若复舒缓。又言重直。设复赞叹。人谓谄誉。若不加誉。复生诽谤。言此贫人。常无好语。若复教授。复言诈伪。耆旧强有所知。若广言说。人谓多舌。若默无言。人谓藏情。若正直说。复云粗犷。若求人意。复言谄曲。若数亲附。复言幻惑。若不亲附。复言骄诞。若顺他所说。复言诈取他意。若不随顺。复言自专若屈意承望。骂言寒贱。若不屈意。言是贫人犹故自我。若小自宽放。言其愚痴。无有拘忌。若自摄捡。言其空粗。诈自端礭。若复欢逸。言其诪张。状似狂人。若复忧惨。言其舍毒。初无欢心。若闻他语。有所不尽。为其判释。言其命趣以愚代智耐着之甚。若复默然。复言顽嚚。不识道理。若小戏论。言不信罪福。若有所索。言其苟得不知廉耻。若无所索。言今虽不求后望大得。若言引经书。复云诈作聪明。若言语朴素。复嫌疏钝。若公论事实。复言强说。若私屏正语。复言谗佞。若着新衣。复言假借严饰。若着弊衣复言儜劣寒悴。若多饮食。复言饥饿饕餐。若少饮食。言腹中实饥诈作清廉。若说经论。言显己所知。彰我闇短。若不说经论。言愚痴无识。可使放牛。若自道昔事业。言夸业自誉。若自杜默。言门资浅薄。诸贫穷者。行来进止言说俯仰。尽是[億-音+(夫*夫)]过。富贵之人。作诸非法都无过患。举措云为。斯皆得所。贫穷之人。如起尸鬼。一切怖畏。如遇死病。难可疗治。如旷野崄处绝无水草。如堕大海没溺洪流。如人捺咽。不得出气。如眼上翳。不知所至。如厚垢秽。难可洗去。亦如怨家。虽同衣食。不舍恶心。如夏暴井入中断气。如入深泥滞不可出。如山暴水駃流吹漂树木摧折。贫亦如是。多诸艰难。贫穷又能毁坏。壮年好色。气力名闻。种族门户。智慧持戒。布施惭愧。仁义信行勇武意志。悉能坏之。又复能生。饥寒怨憎。轻躁褊狭。忧愁惨毒。嫌责罪负。如是众苦。从贫穷生。譬如伏藏。多有杂物。贫伏藏中。多有种种身心苦恼。夫富贵者。有好威德。姿貌从容。意度宽广。礼义竞兴。能生智勇。增长家业。眷属和让。善名远闻。灯指思惟。我今贫厄。世间少比。正欲舍身。不能自殒。当作何方。以自存济。复作是念。世人所鄙。不过担尸。此事虽恶交。无后世受苦之业。若当余作。或值杀生。作诸不善。以此而言。我请为之。尔时有人。闻其此语。即雇担尸。灯指取直。寻从其言。担负死人。到于冢间。意欲掷弃。于时死人。急抱灯指。譬如小儿抱其父母。急捉不放。尽力[打-丁+勉]却不能得去。死人着脊。犹如胡胶。不可得脱。排推不离。甚大怖畏。作是念言。我于今日。担此死人。欲何处活。即诣旃陀罗村语言。谁能却我背上死尸。当重相雇。诸旃陀罗。详共尽力。共挽却之。亦不肯去。余见之者。骂灯指言。狂人何为。担负死尸。入人村落。竞以杖石。而打掷之。身体伤破。痛惧并至。有人怜愍。将其诣城。遂到城门。既到门下。守门之人。逆遮打之。不得近门。此何痴人。担负死尸。欲来入城。自见己身。被诸杖木。身体皆破。甚怀懊恼。发声大哭。而作是言。我正为食。作此鄙事。今日忽然。遭此大苦。由我贫困。不择作处。为斯贱业。冀得价直。以自存活。如何一旦。复值苦毒。宁作余死。不负尸生。且哭且言。时守门者深生怜愍。放令还家。到自空室。先同乞索诸贫人等。共住之者。遥见死尸在其背上。悉皆舍去。既到舍已。尸自堕地。灯指于时踰增惶怖。闷绝躄地。久乃得稣。寻见死尸。手指纯是黄金。虽复怖畏。见是好金。即前视之以刀试割。实是真金。既得金已。心生欢喜。复剪头项手足。如是剪已。寻复还生。须臾之顷。金头手足。其积过人。譬如王者失国还复本位。如盲得眼视瞻明了。如久思他女得与交欢。如学禅者忽得道证。灯指欢喜。亦复如是。库藏珍宝。倍胜于前。威德名誉。有过先日。亲里朋友。妻子僮仆。一切还来。灯指叹曰。呜呼怪哉。富有大力。能使世人来归极疾。呜呼怪哉。贫有大力。能使所亲舍我极速。我先贫时。素所亲昵。交游道绝。总无一人与我语者。今日一切颙颙承事。合掌恭敬。假使生处如帝释。勇力如罗摩知见如天师。若无钱财都无所直。富者不问愚智。皆称好人。实无所知。人以为智亦得勇健。诸善名闻。虽复丑陋老弊。少壮妇女。乐至其边。阿阇世王。闻其还富。寻即遣人。来取其宝。其所取者。尽是死人。还掷屋中。见是真金。灯指知王欲得此宝。即以金头手足。以用上王。王既得已赍之还宫。于后灯指作是思惟。而说偈言

  五欲极轻动　　如电毒蛇虫
  荣乐不久停　　即生厌患心

寻以珍宝。施与众人。于佛法中。出家求道。精勤修习。得阿罗汉。虽获道果。而此尸宝。常随逐之

比丘问佛。灯指比丘。以何因缘。从生以来。有是指光。以何因缘。受此贫困。复何因缘。有此尸宝。常随逐之。佛告比丘至心谛听。吾当为汝说其宿缘。灯指比丘。乃往古世。生波罗奈国大长者家。为小儿时。乘车在外。游戏晚来。门户已闭。大唤开门。无人来应。良久母来。与儿开门。嗔骂母言。举家担。死人去耶。贼来劫耶。何以无人与我开门。以是业缘。死堕地狱。地狱余报。还生人中。受斯贫困。光指因缘。尸宝因缘。为汝更说。过去九十一劫有佛。名毗婆尸。彼佛入涅槃后。佛法住世。灯指尔时。为大长者。其家大富。往至塔寺。恭敬礼拜。见有泥像。一指破落。寻治此指。以金薄补之。修治已讫。寻发愿言。我以香华伎乐供养。治像功德因缘。持此功德愿生天上人间。常得尊豪富贵。假令漏失寻还得之。使我于佛法中出家得道。以治佛指故。得是指光及死尸宝聚。以恶口故。从地狱出。得贫穷果报。佛说是灯指因缘经时。诸天人民。散众天华。作天伎乐。供养已讫。便还天宫。以是因缘。少种福业。于形像所得是福报。乃至涅槃形像尚尔。况复如来法身者乎。能于佛法。如说修行如此功德。不可限量若欲生天人中受诸快乐。应当至心听法。以恶口因缘。受大苦报。应畏众苦。远离恶口诸不善业。以此观之。一切世人。富贵荣华。不足贪着。于诸人天。尊贵不应喜乐。当知贫穷是大苦聚。欲断贫穷不应悭贪。是以经中。言贫穷者。甚为大苦灯指因缘经


弟子死复生经

    No. 826

弟子死复生经

        宋居士沮渠京声译

闻如是。一时佛在祇树给孤独园。与千二百五十比丘俱。菩萨万二千人。神足弟子五百人俱。尔时有贤者优婆塞。本奉外九十六种道。厌苦祷祠委舍入法。奉戒不犯精进一心。勤于诵经好喜布施。笮意忍辱常有慈心。暴得疾病遂便命过。临当死时。嘱其亲属及其父母言。我病若不讳之日。莫殡敛七日。若念我者不违我言。遂奄忽如死。父母亲属诸家如其所言。停尸七日。到八日亲属诸家言。死人已八日。眠眠无所复知。当急殡敛。父母言。虽已日久亦不膖胀。亦不臭处。小复留之。以到十日。语言未竟。死人便即开眼。诸家父母大小踊跃欢喜。未能动摇诸家共守之。至十日便能起坐善能语言。众人问所从来。尽见何等。言有吏兵来将我去。往到一大城中有大狱狱。正黑。四面悉以铁作城。城门悉烧铁正赤。狱中系人身皆在大火中坐。上下火烧。炙之青烟出。或有人以刀割其肉啖食之。狱中有王问我言。若何等人犯坐。何等乃来到是中。是中治五逆。不孝父母。不忠信事其君。治诸恶人处。若罪何重乃尔。答言。我少小为人以来为恶人所惑。奉事外道。少为世间愚痴。杀生祠祀天地饮酒。又于市里采取财利。升斗尺寸欲以自饶。会后与善师相得相教作善。牵我入佛道中。得见沙门道人。授我五戒奉行十善。自尔以来至于今日不复犯恶。恩由明王哀我不及。我便叩头

王即起叉手谓我言。止止。清信之人不应当尔。便与我座便坐。王便呼吏问之。此乃无上正真弟子。汝曹等辈。皆当从是人得度。以其人寿命自尽时乃当死耳。魂神自追随行往受。若生天上。天神自当来迎之。若生人中。人中自当来迎之。何得将此尊人来入是五逆之处。吏答王言。世间多有是人。不畏王法不畏四时五行不拘。鬼神天地无所取录。不可一二不问耶。是人横行天下无所拘制。有法师名之为沙门。髡剔头发被服疏陋。以法自大多将弟子。东西南北无所取录。移徙葬埋嫁女取妇。不畏四时毁败改易。不拘王相。是曹辈人应当治之。王言。止止。卿为了不解是法耶。法服之人无所贵敬。他所畏难。诸释梵日月中王。下及帝王臣民皆所尊奉。尊奉是人得福无量。使人得道。不得轻慢是人。轻慢是人者自求罪苦。急案名录寿命应尽未。吏白王言。以命录理之未应死耶。尚有余算二十。以其先小时所犯罪恶。后乃欲作善是以取之。使其党辈小复自下。王言。人居世间少作恶至于百岁。是辈人罪当复云何。吏言。是人但可以生不可以死。死便更连延当受罪苦痛。千劫万劫无得解脱。时王曰。其佛弟子有戒精进不懈怠。为天神所贵敬。所以尔者。佛以大慈大悲护心投心。以是四等心忧念十方。天下一切人民万物蜎飞蠕动之类。佛皆哀伤之。功德流演十方天下。是故佛子天神地祇鬼龙皆敬贵之。岂当拘王相四时五行耶。佛恩如四海不可得限量。百亿恒水边流沙。尚可升量尽知其升数。佛恩不可得量耶。吏白王言。大王。为奉佛净戒耶。王曰。坐我不奉佛故。追罪来作此狱王。卿见此狱中。今现有数寿终不受。亦不敢当前。皆当叉手起往奉迎之。使案其所行善福。福神自来迎取之。未应死者自有护速得除愈。若有人已入正法。后悔乃复还为外道。杀生祠祀。邪道恶鬼法见之得便。此则自无护。虽有千岁寿命。当逢九横无病自死。所以尔者。救护神不祐之。如是者终不得解脱。若持戒比丘及诸弟子。当勤行六事。何等为六。一者檀波罗蜜。当好布施无得悭惜。二者尸罗波罗蜜。当护诫慎莫犯。三者羼提波罗蜜。当忍辱笮意心口莫嗔恚。四者毗梨耶波罗蜜。当勤力精进莫懈怠。五者禅波罗蜜。当一心定意莫放逸。六者般若波罗蜜。当勤作经上口讽诵。当晓沤和拘舍罗。是为六事菩萨求道之本。复有六事。一者眼。二者耳。三者鼻。四者口。五者身。六者意。人欲求道蒙福。当护是六事。护眼莫着色。护耳莫着声。护鼻莫着香。护口莫着味。护身莫着细滑。护意莫着爱欲。是为护六事。当复灭三事。何等为三。一者淫泆。二者嗔恚。三者愚痴。是为三毒。当复灭五事。何等为五。一者痛痒。二者思想。三者生死。四者识。五者爱欲。是为五阴复有六衰。何等为六衰。一者眼为色衰。二者耳为声衰。三者鼻为香衰。四者口为味衰。五者身为细滑衰。六者意为法衰。是为六衰。五阴六情三毒合为身中二十事。常在人身中。道人行道常当断绝是二十事。不能禁绝是二十事。当堕人着罪中。六情不绝当堕十八泥梨中。五阴不绝当展转五道中。三毒不绝当入三恶道中。若善男子善女人。禁制持戒身中二十事。如镜之去垢清净无秽内外照明者。天下千百亿万人。有一人是佛弟子不。吏言。实自无有。王曰。以是观之。知佛功德大巍巍渊泓堂堂乎。如巨海不可当耶。吏白王言。诚如大王所言。小吏罪之所致不别真伪。请得遣之还。王曰善。吏便辞谢人使自还去。人便如从高堕下。[火*霍]然而稣便得生活。父母便以车载诣祇洹以白佛。佛便呼人问之。其以所见所言答。佛便笑五色光从顶上出。绕身三匝还从脐入。阿难便整衣服以膝着地。叉手白佛言。佛不妄笑。笑当有意。愿佛广说其义。佛言。阿难。谛听受。众会阿难受教而听。佛言。是间阎浮利天下为五逆恶世。子不孝父。臣不忠君。夫妻相欺。欺上罔下人民佷戾。少有义理轻慢无节。以强陵弱富富相从。贫困守穷贪利悭惜。无有慈心但欲胜人。四王相守鬼恶神司。取其便犯者则死。魂神展转随行往受。当作饿鬼畜生地狱。楚毒痛掠笞斫汤镬烧煮。若有余微之福得上生天。当在第六魔天。薄福短寿不受法教。虽得作人当作下贱奴婢。或作牛马畜生骡驴骆驼象虎师子鸟兽虫蛾。困苦巨言。百劫千劫万劫无得解脱。时适生便病。或时即死。若得为人六情不具。癃残聋盲喑痾如是困苦无极。今是世上有一人知世间有佛。闻经法得见比丘僧。有善心好意恭敬慈心。捐九十六种道来入正法。自惟自克奉受五戒。修行十善以灭十恶。尔时有一人皆是维卫佛时得道人功德同是人。其有百劫千劫万劫之罪。皆悉灭尽。其人寿终已后。不复更见三恶道中。假有所犯。当追罪轻重诣地狱。王见之衣毛当竖敬仰其人。帝王人民一切莫不尊奉。虽未得道功德隆赫。天人龙鬼莫不称叹

佛语阿难。我般泥洹后世人多不敬法。喜自贡高自大轻蔑于人。薄贱正法毁诸比丘。不与分卫。骂詈瓦石击之无所拘畏。是曹辈人。皆从魔界中来生为人故。复恶如是。其信乐佛法。则是上古先世时。佛上足弟子。能知真伪随奉正法。受持经戒。复灭二十事。皆悉诸菩萨摩诃萨非凡人耶。人生当有死。无有不死者。持戒善人不惜身命。但念大慈大悲拯济一切。为众人作唱导。菩萨不惧生死之变。入生死度生死。入地狱说经戒。止恶为善。入饿鬼为说布施。入畜生为说淫泆。亡人身上天生为教诸天。人中为作法恶为善。人作地狱行则有地狱想。人作畜生行则有畜生想。人作天行则有天想。人作饿鬼行则有饿鬼想。人作人行则有人想。一切万物皆无所有。但依所作名便有思想。今是贤者。眼所见其证分明。于世生已得为人有福德奉正法。何不努力可自致得佛尊贵。何为作勤苦之业。身当自往受之。悔有何益

佛语阿难。法之欲兴世生善人。法之欲衰恶人众多。善相告语。各勤加精进经戒。为忧一切无常。无常力大佛不常住。于世努力勤之。既以自度复能救度一切人非人。诸比丘。汝曹当及我在世当努力。莫言佛常在。今不努力后悔何益。今以死人者名见谛。见谛闻佛说经。父母诸家皆得阿罗汉道谛。即得阿惟越致。坚住不复动转。诸比丘及诸菩萨大弟子。天龙鬼神。闻经莫不欢喜。皆前为佛作礼而去弟子死复生经


第一义法胜

    No. 833 [No. 834]

    第一义法胜经翻译之记

夫爱法者必深善根。涅槃经云。供佛二恒。魏尚书令仪同高公。重法心成。生上财想。博采梵文。广崇翻译。且第一义法胜经者。诸法门中。此其髓也。公意殷诚。感之题额。沙门昙林。瞿昙流支。兴和四年岁次壬戌。九月一日甲子换文。始末四功。质义乃定。五千五百七十六字

第一义法胜经

        元魏婆罗门瞿昙般若流支译

如是我闻。一时婆伽婆住伽耶城。成道未久。与胜中胜诸比丘俱。九十九亿诸菩萨众。复有二十八亿诸天。八万六千比丘比丘尼。优婆塞优婆夷。六万力士。有十二亿尼乾陀众。八万四千五通仙人。五热炙身羸瘦肉尽。唯有皮骨。腹皮着脊。头发成毡。伛身曲体。着鹿皮衣。若树皮衣。手执澡罐俱至佛所为欲诤斗

尔时世尊光明胜出端严殊特超过诸仙。如黑山中须弥山王。如羊群中六牙象王。如萤火虫显于日月。如芳华中曼陀罗华。如鸟群中迦楼罗王两重端严。佛于诸仙亦复如是。尔时世尊。入舍宝三昧。示现无量无数神通。左右皆放无量光明。出无量亿如来之身。出无量亿菩萨之身。出无量亿帝释天王大梵天王世界尊主。复出无量百千罗汉。复出无量多千比丘诸比丘尼诸优婆塞诸优婆夷。复出无量转轮圣王。力转轮王。小转轮王。汉不邻那。及陀毗罗。南国土人。得咒仙人。边地处人。刹利大姓。及婆罗门。长者居士。人非人等。种种异异诸色庄严。如是一切有名字者。乃至天众。一切皆从如来身出

尔时大众皆生疑心。云何迭相瞻视。彼大众中一切菩萨皆生欢喜。雨种种宝。乃至普雨一切庄严

尔时世尊起舍宝三昧。师子奋迅观察十方。即观察时周遍十方。乃至佛眼所见境界。一切十方诸佛世界诸佛世尊。彼一切佛观察娑婆如观手掌。彼一切佛皆现神通。如此世尊释迦牟尼所现无异。彼诸如来身所化出。乃至一切皆悉如是。来到世尊释迦牟尼众会之所。既到此已。皆入世尊大众会中

尔时此会无量菩萨与恒河沙多诸比丘诸比丘尼诸优婆塞优婆夷俱以不可说诸供养具供养世尊。既供养已近如来住

如是天龙及诸夜叉。诸乾闼婆。诸阿修罗。诸迦楼罗。诸紧那罗摩睺罗伽人非人等。既见世尊神通事已。皆至佛所

尔时十方诸来菩萨。无上供养供养世尊。既供养已。六波罗蜜究竟所作座上而坐。如是乃至人非人等。随自相似座上而坐

世尊所化。上去乃至阿迦尼吒诸天宫殿。下去乃至阿鼻地狱。又到阿鼻地狱处已。彼十方佛身所化出。一切皆入释迦牟尼一切毛根。此处世尊释迦牟尼身所化出。一切皆入十方佛身

尔时会中。有一菩萨摩诃萨名曰胜阴。从座而起。整服一厢。右膝着地。合掌向佛。以偈赞言

  人主甚希有　　速示诸世间
  本未曾有此　　魔军隐不现
  迭相瞻说言　　此事甚希有
  我何因来此　　为令破坏故
  我仙今非仙　　身瘦唯有皮
  老干无有乐　　不得此神通
  现神通不说　　除佛法棘刺
  佛弟子朝喜　　尊作佛法主
  众生希有想　　心清净欢喜
  诸天众皆言　　愿得佛人主
  此众会中住　　文殊师利向
  无量佛弟子　　相随在此会
  此文殊师利　　已多佛供养
  佛于此大众　　现种种神通
  此是何法相　　牟尼欲何为
  此众有疑心　　愿愍众生说

尔时如来以威神力。令众会中一大仙人名光明炬。语彼胜阴大菩萨言。童子默然。童子默然。我今难问。若能解释自清净者。如一切智相应得名。若那罗延。摩醯首罗所作幻化陀毗罗咒。如是作者此非奇特。如是幻化凡人能成。不必是佛

尔时世尊。怡然微笑。观仙众已。即告大仙光明炬言。慧命大仙。汝当难问。随汝力分。我能清净

尔时大仙光明炬言。我问瞿昙。瞿昙为我一一解说。一切众生从何处生。何者众生。何因缘故劫尽炽燃。众生过去。何处和合而生人中。何相得知众生身中微细内。我为一肘量。为二肘量。为二指量。为一指量。为如大麦。为如小麦。为当如豆。为如胡麻。为如芥子

尔时世尊赞光明炬大仙人言。善哉大仙。善哉善哉。汝大仙人。六十劫寿恒常修行。今者如是相以问难。诸仙众中复有大仙。如是思惟。我常林行不觉不知此光明炬大仙命量。未有人说。沙门瞿昙云何得知

尔时世尊告光明炬大仙人言。大仙谛听善思念之。今为汝说。如汝所问。一切众生何处生者。如是之义无字无说。无明因缘。次第乃至生老死等。而生众生。又复大仙。从于因缘而生众生。所谓父母因缘而生。又复大仙。父母和合是众生因谓迳劫起业风所吹堕女根中。此是因缘。又复大仙。谓苦圣谛苦集苦灭。及苦灭道圣谛所摄。名为众生。又五取阴十八界等。名为众生。大仙当知。彼谛阴界即是众生。不异于业。如是业者不异众生。大仙当知。众生不减。众生不增

时大仙人问言。瞿昙。若诸众生不减不增。众生何故。人天自在后时作狗。复作人天得自在耶。佛言大仙。如汝所言是义不然。若有自在则不属他。如是大仙。若身自在。云何后时得不自在。大仙当知。如萤火虫起如是意。我此光明能悉普遍照阎浮提。彼萤火虫所有光明无有因缘能悉普遍照阎浮提。如是一切不调御心无实自在。又复大仙。若自在者烦恼减少狗。烦恼多狗则自在则不自在。亦为自在。是则自在亦不自在。若狗自在烦恼平等。是则众生不减不增

大仙人言。瞿昙岂不断烦恼耶。佛言大仙。烦恼不了。我了烦恼非断烦恼。大仙人言。若如是者汝则自在。佛言大仙。如是如是。以不实故我则自在。大仙人言。瞿昙此言且止且住。若瞿昙子向者说言。父母和合生众生者。多有众生多相和合。多受欲乐少生众生。是义云何。佛言大仙。我今当以譬喻问汝。如一种子则生一树。一子一树生无量果。彼无量果。有任种子。有不任者。此复云何。答言瞿昙。风势因缘散失树子。佛言大仙。诸众生果亦复如是。业风所散。大仙当知。有在藏中为虫啮食。有为业风之所散坏。大仙当知。树等少障。众生多碍。又复大仙。诸众生界从分别起。大仙当知。诸众生界心心数法。处处转行皆有攀缘。此义已说。如是大仙。诸众生界从分别起

大仙闻已。作如是言。如是如是。瞿昙已净此一难问。又复瞿昙。应当更说何义劫烧。佛言大仙。以无常故。我如是说法界劫烧。大仙当知。若地劫烧法界则二。如是有常亦有无常。若如是者。一切如来不实语说。又复大仙。若一切法皆悉无常变异不住。如来得名一切智人。大仙闻已。为摩那婆如是说言。此名乃是如实相应一切智名

佛言大仙。若使如来不放劫烧。一切众生不知时节。不识劫名。不识斗时。不识善时。大仙当知。若使如来不放劫烧。若善不善业果报异。皆无知者。又复大仙。应知此是如来方便放劫尽烧。大仙当知。诸众生等信劫尽烧。畏当烧故。皆摄福德信于如来

又复大仙。譬如有蟒名曰涎呼。彼涎呼蟒。眼亦能呼。耳亦能呼。鼻亦能呼。口亦能呼。如是大仙。如来亦尔。以布施摄。爱语利益同事等摄

又复大仙。譬如有人置金火中。非嗔金故置之在火。为令善熟宝相应故。若宝相应则为贵价。大仙当知。以是因缘打熟明净。如是大仙。诸佛如来。非无因缘放劫尽烧。非有众生劫火所烧

尔时大仙光明炬言。希有世尊。放劫烧火。无一众生劫火所烧。佛言大仙。无一众生为如来烧。又复大仙。譬如十方雨微细雨。如来之数复多于是。十地菩萨亦复如是在上而住。如是住已。皆以自手救诸众生。令使解脱。大仙当知。如是众生见诸如来及诸菩萨身色端严。如是见已复见劫尽。大火烧已见自脱已。心生欢喜清净心生。如是愿言。我亦如是度诸众生。我亦如是身色端严。我亦如是身作金色。众生既起如是心已。有心解脱即时证得阿罗汉者。有见劫火心生厌离。或有证得须陀洹者。或有证得斯陀含者。或有证得阿那含者。或有证得阿罗汉者。或有证得缘觉道者。或有证得无生法忍。或有得上不退地者。或有得生四天王处。或有得生三十三天。或有得生夜摩天者。或有得生兜率陀天者。或有得生化乐天者。有生他化自在天者。有生梵天梵辅梵众。如是次第乃至有生阿迦尼吒。如是有得转轮圣王。力转轮王。天竺小王。如是大仙。乃至刹利。若婆罗门。若长者等。大仙当知。以此方便。令见如来色身相已。自见己身生大怖畏。得解脱已。知如来恩。报如来恩。亲近如来听闻正法。既闻法已如法修学不放逸行。以此方便。令诸众生不入恶道。又复大仙。乃至几许十地菩萨。彼眼境界所有地界。复过于此诸众生界。彼诸众生见生死过。一切无余涅槃界入。大仙当知。以此因缘放劫尽烧

尔时大仙名光明炬。心即思惟。此释迦子。六波罗蜜具足大人第一胜人。不唤我字称言大仙。我自试看是一切智非一切智。我今实知是一切智。我今应当称其实名

尔时大仙名光明炬。既思惟已。即白佛言。大功德聚无量智者。一切智者。更为我说彼诸众生何处和合。佛言大仙。当知众生无处和合。当知众生平等和合。是名和合。当知众生一乘和合。是名和合。一切皆是菩萨和合。谓在无余涅槃界处。大仙当知。众生如是无处和合

大仙当知。譬如种种小河大河。入大海已皆同一味。如是大仙。诸众生界诸漏尽已皆解脱味。一切平等菩萨和合

又复大仙。若诸众生。生死海中而和合者。我说彼合非是和合。又复大仙。譬如飞蛾风吹和合。离风则散。如是大仙。诸众生界。迭互业缚行地狱行生地狱中地狱和合。大仙当知。众生如是迭互业缚行饿鬼行生饿鬼中饿鬼和合。行畜生行生畜生中畜生和合。行人天行生人天中人天和合

大仙复言。一切自在一切智者世间应供。更为我说。云何得知此人中生某甲众生。何处和合而来生此。佛言大仙。若有众生。于地狱中和合而来。生人中者迭互相见则生恶心。彼此相憎迭互相见。或有头痛。或放大便。或失小便。大仙当知。此是地狱和合众生。人中生相。人中若有如是相者。于地狱中和合而来。应如是知

大仙复言。世界光明一切智者。更为我说。云何得知于畜生中彼此和合来生人中。复有何相。佛言大仙。若人前身于畜生中。和合而来生人中者。迭互相见则生嗔心。更求过短常相伺便欲为恼乱。大仙当知。此是畜生和合众生人中生相。人中若有如是相者。于畜生中和合而来。应如是知。又复大仙。若人前身于饿鬼中和合而来生人中者。爱乐臭气。性贪饮食。悭惜不施。于饿鬼中同处来者。见其富乐则生嫉心。悕望他物。大仙当知。此是饿鬼和合众生人中生相。人中若有如是相者。于饿鬼中和合而来。应如是知

又复大仙。若人前身于人道中异处和合复为人者。彼人相见则生染心。人中若有如是相者。本于人中和合而来。应如是知

彼大仙人问言。世尊。若天和合退生人中。彼有何相。复云何知。佛言大仙。若人前身天中和合来生人者。迭互相见乐看不舍。人中若有如是相者。本于天中和合而来。应如是知。大仙当知。众生如是和合因相

尔时大仙名光明炬。闻佛说已。心生欢喜。而白佛言。世尊。若有不求一切智者。如是众生。一切所作空无所获。尔时世尊告光明炬大仙人言。如汝所问众生身内微细我者。大仙当听。若有分别得众生者。彼则分别众生细我。大仙当知。譬如有人生盲无眼。有人问言。何者白色。于意云何。彼生盲人不曾见色。能说如是一种色不。大仙答言。不能说也。佛言。如是如是。大仙。彼生盲人眼不曾见。故不能说。我亦如是。不见众生微细内我。是故不说

又复大仙。眼非众生。如是非耳非鼻非舌非身非意得众生名。又复大仙。非五取阴得众生名。非十八界。非十二分十二因缘得众生名。又复大仙。亦非内空得众生名。亦非外空非内外空得众生名

大仙当知。眼念不住变异不停。如是耳鼻舌身意等。皆念不住变异不停。如是大仙。五阴亦尔。一念不住变异不停。如是大仙。三十六种不净之物。皆念不住变异不停。如是等中无众生名

又复大仙。色物和合数名众生。若人思量分分观察。彼不得命。不得养育富特伽耶。亦不得人摩那婆等

大仙当知。若有众生。如来不说四圣谛法。若无众生则是如来。若不知法如和集取。如心取得

尔时大仙光明炬言。世尊。我光明炬。自从今日求一切智。世尊。若一大劫为一日夜。数如是日三十为月。数如是月十二为岁。数如是岁以成一劫。世尊。我宁如是无边劫中常住火坑须弥楼山。高大乃至阿迦尼吒。我宁如是无边劫中在彼山上。念念自堕投身在地。如劫火烧五处炽然。我宁如是无边劫中。常以如是五火自炙。世尊。我宁忍受如是等苦。而终不能舍一切智。求一切智因缘精进我不休息

尔时五通诸仙人等。皆近世尊。复从座起。白世尊言。我从今日求阿耨多罗三藐三菩提。如力所堪发勤精进。尔时世尊即于仙人如是语已。眉间放光。其光名曰毗尼婆帝。此光出已普照十方。彼十方处一切诸佛眉间亦放如是光明。毗尼婆帝光明势力。令此大地六种震动。谓震等震。动平等动。起平等起。西高东下。南高北下。十方一切诸佛如来在上雨华散此佛会。天鼓妙声甚可爱乐。乾闼婆王作五分乐。供养如来赞叹世尊。风吹天香以熏如来。菩萨欢喜。以诸璎珞。掷置空中在如来上。华香烧香。妙鬘涂香。散种种香。种种妙衣。幢盖缯幡供养如来。诸天欢喜。于虚空中。雨曼陀罗大曼陀罗。一切大众心生欢喜。以己所著妙好衣服。用奉如来

尔时此处释迦如来毗尼婆帝光明。上去乃至遍到阿迦尼吒诸天宫殿。下去乃至阿鼻地狱如是照已。围绕十方诸佛世尊。然后还来入世尊顶。尔时慧命须菩提。以妙伽陀。请如来曰

  朝日释迦子　　放光照十方
  此非无因缘　　唯愿为我说
  见人主奋迅　　此众皆生疑
  亦有欢喜意　　清净心悕望
  或有人合掌　　或有言善哉
  唯愿如来说　　除断众生疑
  空中帝释王　　梵王世界主
  心皆生欢喜　　赞叹实功德
  诸天虚空中　　雨种种妙华
  多有诸音乐　　不击自然鸣

尔时世尊即告慧命须菩提言。汝须菩提。见光明炬大仙人不。须菩提。是人未来月光世界。当得成佛。号毗婆尸如来应正遍知。此贤劫中一千如来。最后如来同时出世。须菩提。若有众生。闻毗婆尸如来名者。皆蒙威力。如如意珠须者皆得。须菩提。八万四千诸大仙人。闻此法门得不退地。须菩提是等一切弥勒世尊。佛法之中当得十地复三百劫。生自灯明如来应正遍知佛之世界

须菩提。无量菩萨闻此法门。即时皆得首楞严三昧。音声智三昧。受胜位三昧。如幻三昧。界胜三昧。慧王三昧。海藏三昧。地藏三昧。虚空藏三昧。得光明三昧。须菩提。有恒河沙亿数诸天。一切皆得无生法忍。无量比丘比丘尼优婆塞优婆夷。证阿罗汉。须菩提。恒河沙数天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。发阿耨多罗三藐三菩提心。须菩提。见是因缘。如来放此毗尼婆帝光明普照

尔时世尊怡然微笑。出自舌根遍覆己面。彼舌根中出无量色。出种种色。所谓青黄赤白等色。紫颇梨色。遍至无量无边世界。然后还来入世尊足。尔时无尽意菩萨从座而起。整服一厢。右膝着地。合掌向佛白言。世尊。若无因缘如来不笑。今者世尊。何因缘笑。尔时世尊告无尽意菩萨言。善男子。我为饶益不信众生出舌而笑。非妄语人有如是舌

尔时无尽意菩萨白佛言。世尊。若善男子若善女人。此法门中。能为他人演说一偈。得几许福。佛言。善男子。十方世界。尽佛所见。佛眼境界所有诸佛一切供养。一切乐具皆以供养。乃至诸佛入涅槃已。为作宝塔。所有功德。若复有能为他说此。说实义句法门一偈。得福甚多胜前福德

善男子。若于说此胜法门者。生清净心赞言善哉。如是之人。则为赞叹一切诸佛。若复有能供养之者。与供养我等无有异

尔时世尊。普遍观察一切众会。既观察已。说如是言。我今实语。善男子。当有地处。随于何处有此法门。住彼地处。为一切佛之所观察。善男子。此法门者。于当来世阎浮提中。众生如药。若有能于如是法门。三种修行。若读若诵。若为他说。彼人则与佛在世时请转法轮。无有差别

善男子。若能书写如是法门。彼人易得阿耨多罗三藐三菩提。则为不难。一切佛藏皆能住持。善男子。行恶道者。如是法门不迳其耳。善男子。若有众生。如是法门一迳耳者。舍人身已。则生清净佛之世界。善男子。若有供养一千诸佛种诸善根。如是法门乃迳其耳。善男子。若善男子。若善女人。闻此法门。闻已生信。受持读诵。能为他说。我说彼人菩提在手。我说彼人必得五眼。自是已后诸根不劣。临命尽时不失正念。彼人当得一切诸佛和集三昧。毗卢遮那奋迅三昧。陀罗尼藏三昧。珠印髻三昧。授记三昧。观世印三昧。无字箧三昧。得一切法胜陀罗尼。断疑陀罗尼。得第一义决定陀罗尼。得如是等无量百千陀罗尼门。当得五通随心忆念退生自在

尔时世尊告文殊师利法王子言。文殊师利。汝已供养多佛世尊。则能护念如是法门。复能处处广为他说。文殊师利。汝所供养恭敬给侍。几许诸佛。尊重赞叹所有善根。文殊师利。于意云何。如是善根为有边际。为无边际可数量不。文殊师利答言。世尊。不可数量。佛言。文殊师利。若能于此娑婆世界五浊乱时。为他广说如是法门。其福过彼。文殊师利。若汝唯以衣服饮食。床敷卧具。病药所须。供养尔许诸佛如来。不为他说如是法门。汝于彼佛则为得罪。文殊师利。若汝不曾供养一佛。为他广说如是法门。汝则供养一切如来。世尊说已。文殊师利法王之子。光明炬等诸大仙人。一切众会并诸天人。及阿修罗乾闼婆等。闻佛所说欢喜赞叹第一义法胜经


饿鬼报应经

    No. 746

饿鬼报应经

        失译附东晋录

尊者大目揵连。从佛在耆阇崛山中。游行恒水边。见诸饿鬼甚多。受罪不同。见尊者目连。皆起敬心。来问因缘。一鬼问言。我常苦头痛。不知何罪所致。目连答言。汝本为人时。不能修忍。以杖打众生头。今受花报果在地狱。一鬼问言。我常疮痛。何罪所致。答言。汝为人时。无有慈心。焚烧山野。残害众生。今受花报果在地狱。一鬼问言。我举身疮烂。不可堪忍。何罪所致。答言。汝为人时。喜燂猪羊。今受花报果在地狱。一鬼问言。我食无足。初不得饱。何罪所致。答言。汝为人时。虽饭众生。恒令不足。今受花报果在地狱。一鬼问言。我常苦头痛。治之叵差。何罪所致。答言。汝为人时。不敬道德。加以骂辱。今受花报果在地狱。一鬼问言。我生男女。尽皆端正可爱。而皆早死。念无断绝。何罪所致。答言。汝为人时。见儿杀生。助喜啖肉。杀故促命。喜故痛毒。今受花报果在地狱。一鬼问言。我有一夫。而畜多妇。我应直宿。而不见纳。何罪所致。答言。汝为人时。不敬夫主。邪淫无礼。今受花报果在地狱。一鬼问言。我常头痛。而男根疮烂。何罪所致。答言。汝为人时。于塔庙清净之处行淫。今受花报果在地狱。一鬼问言。我得此身。粗涩不净。何罪所致。答言。汝为人时。不尊有德。轻贱善人。而以沙土。掷坌沙门。今受花报果在地狱。一鬼问言。我食不啻一斛。而常不足。何罪所致。答言。汝为人时。本作比丘。为僧求物。而以自食。今受花报果在地狱。一鬼问言。我受此形。脚肿项瘿。何罪所致。答言。汝为人时。使人及诸畜生。负重无道。今受花报果在地狱。一鬼问言。我受此身。常患热渴。何罪所致。答言。汝为人时。喜好渔猎。以所得鱼。投之沙土。令其苦死。今受花报果在地狱。一鬼问言。我受此身。狂痴无智。何罪所致。答言。汝为人时。以酒施人。今受花报果在地狱。一鬼问言。我所生子。皆反啖我。何罪所致。答言。汝为人时。不修孝养。今受花报果在地狱。一鬼问言。我食常吐。何罪所致。答言。汝为人时。有人中后索食。汝嗔骂而与。今受花报果在地狱。一鬼问言。我今一生资财无乏。而乐着弊衣。何罪所致。答言。汝为人时。虽好布施。施后寻悔。今受花报果在地狱。一鬼问言。我受一形。恒倚巷陌。宿无常处。何罪所致。答言。汝为人时。客来投止。而不安隐。见他容止。而复嗔骂。今受华报果在地狱。一鬼问言。我得此形。非男非女。何罪所致。答言。汝为人时。而无慈心。好犍六畜。今受花报果在地狱。一鬼问言。我得此身。躄不能行。何罪所致。答言。汝为人时好行无道。拘系人兽。令不得行今受花报果在地狱。一鬼问言。我此一身常患热渴。行见恒河。清凉美好。入中洗浴。冀得凉乐。以除热苦。方入其中。举身烂坏。渴欲饮之。一口入咽。五藏焦烂。饥肉离骨。何罪所致。答言。汝为人时。好为相师。相人吉凶。少实多虚。或毁或誉。自称有德。以动人心。以求利养。又于父母兄弟宗亲。谄伪不实。今受花报果在地狱。受苦亿倍。说不可尽。一鬼问言。我受身以来常有恶狗。体大牙利。两目赫赤昼夜常来而啖我身。命未尽顷肉寻复生。复受此苦。痛不可忍。何罪所致。答言。汝为人时。作天祠主。于天祠中。取牛羊血。以祀于天。自食其肉。语众人言。汝等祀天。大得吉利。作诸恶邪。以惑百姓。今受花报果在地狱。一鬼问言。我受此身。常在不净中。举身涂漫。有所啖食。皆是不净。恒受此苦。不能得离。臭恼缠身。忧患叵计。何罪所致。答言。汝为人时。作婆罗门。不信佛法。不乐供养沙门道人。若来乞求。恒不欲见。时有一道人来从汝乞。汝作是念。当作方便令不复来。即取钵盛屎着下。以饭覆上。将与道人。道人得已。还至本处。持着一面。净洗手讫。坐而执钵。手取欲食。钵中不净。臭不可近。以是因缘。受此臭恼。今受花报果在地狱。常吞热铁丸。身体烂坏。苦不可言。一鬼问言。我受此身。处处舌出。有自然斧。而斩截之。如是无数。何罪所致。答言。汝为人时。作小道人。为僧所差。取冷净水。作石蜜浆。分与众僧。石蜜坚大。打取少许。盗食一口。盗僧物故。今受华报果在地狱。吞注洋铜。苦不可言。一鬼问言。我受此身。常苦饥饿。往至厕上。欲取屎食。厕上有大力鬼。以杖打我。初不得近。何罪所致。答言。汝为人时。曾作道人。为佛图主。吝护僧物。不以好食供养众僧。常以粗恶与之。或时时欲作好食。客比丘来。便止不作。待去乃设。恶心悭惜。今受花报果在地狱。一鬼问言。我受此身。腹大如瓮。余身分皆小。咽如细针孔。不得下食。何罪所致。答言。汝为人时。作聚落主。自恃豪强。欺人民。常以无道。索人饮食。以苦百姓。今受花报果在地狱。一鬼问言。我受此身。肩上有铜瓶。满中洋铜。手捉一杓。以酌取之。自灌其头。举身焦烂。如是无数。苦痛无量。何罪所致。答言。汝为人时。出家修道。知僧饮食。以一酥瓶。藏着余处。客道人来而不与之。客去出酥行与旧僧。此酥是招提僧物。一切有分。隐匿僧物。与不平等。以是因缘。得如是苦。今受花报果在地狱。受苦难计。一鬼问言。我受此身。常有人来。持诸刀锯。割剥我身。又破其腹。出其五藏。肉尽筋断。痛不可忍。须臾之间。肉生平复。寻复来割。何罪所致。答言。汝为人时。作婆罗门。不信正法。常生邪见。奉事天神。恒以牛羊祷祠。以是罪故。今受花报果在地狱。一鬼问言。我受此身。常有人来。持诸刀锯。割剥我身。又破其腹。出其五藏。肉尽筋断。苦切叵忍。须臾之间。肉生平复。寻复来割。何罪所致。答言。汝为人时。常作魁脍主。知杀人无有慈心。叹喜行之。有如是罪。故得此恶。今受花报果在地狱。一鬼问言。我受此身。两腋下恒有热铁轮转。大热逼身两腋焦烂。何罪所致。答言。汝为人时。出家学道。与僧作种种饼。僧未下食。汝时贪心盗取僧饼。藏着腋下屏处食之。以是因缘得如是苦。今受花报果在地狱。受苦难量。一鬼问言。我受此身。常有自然赤铁丸。从空中下。入口至腹。或从左出右入。或从右出左入。举身焦烂。痛切无量。何罪所致。答言。汝为人时。出家为沙弥。为僧煮庵罗果。僧中行之。至和上前。辄长与七枚。以是因缘。得如是恶。今受华报果在地狱。一鬼问言。我受此身。意欲行来。发动回还。犹如旋风。初不得前。愁恼闷苦。不可称计。何罪所致。答言。汝为人时。作卜问师。诡诳他人。令心罔惑。或喜或怖。皆不真实。由此因缘。得如是恶。今受花报果在地狱。一鬼问言。我受此身。内常有热。犹怀汤火。复来烧煮。苦痛万端。何罪所致。答言。汝为人时。作国王第一夫人。时王贵敬小夫人。汝常生嫉心。作恶方便。求欲杀之。伺其卧时。煮酥令热。注着腹上。其人得此苦痛无量。遂便命终。由是因缘。得如是苦。今受花报果在地狱。一鬼问言。言我受此身。性多恐怖。常畏人来。收闭系缚。枷锁楚毒。初无欢心。何罪所致。答言。汝为人时。好行邪淫。犯人妇女。常畏发觉。心不自宁。今受花报果在地狱。或卧铁床或抱铜柱。如是之苦。不可称计。一鬼问言。我受此身。自然热铁。而有笼网。缠络我身。烧热焦烂。痛毒叵言。何罪所致。答言。汝为人时。常持罝网。杀诸鱼兽。笼取飞鸟。以是因缘。得如是苦切。今受花报果在地狱。一鬼问言。我受此身。无有手足。如一叚肉。在于旷野。狐狼虎豹。雕鹫众鸟。竞来搏撮。争共食之。苦痛叵言。何罪所致。答言。汝为人时。作恶方便。若己若他。妊身之时。即便与药。令胎消化。由是因缘。得如是苦。今受花报果在地狱。又三鬼一时来问言。我受此身。常有铁钉。从空中下。钉我身上。入肌破骨。痛毒彻髓。何罪所致。答言。汝为人时。一人作马师。一人作牛师。一人作象师。苟贪他财。针刺无道。使受痛苦。而不除痛。由是因缘。得如是苦。今受花报果在地狱。一鬼问言。我受此身。无有头首。眼耳鼻口。尽在胸前。何罪所致。答言。汝为人时。若见杀人。与之捉头。欢喜而挽。无有慈心。由是因缘。得如是身。今受花报果在地狱。目连答诸鬼已。皆生敬心。走前忏悔。目连见其欢喜。更为说法。诸鬼闻已。皆大欢喜饿鬼报应经


法观经

    No. 611

法观经

        西晋月氏国三藏竺法护译

佛言。第一何以故数息。用息轻易知故。以世间人皆贪身。未能舍身守意。又身中事难分别。皆不信本无意不止。何以有故说空意。颠倒习息见有无故先说息。稍稍解人意上头为数已得行为第一禅

佛言。坐禅当三定。何等为三定。一者身定。二者口定。三者意定。痛痒止为身定。声止为口定。意念止为意定。念止者。为受行常念道。声止者。断四恶。痛痒止者。为不堕贪意在止已。身定口定意定。当立戒身意持。持者为一切无所犯。又身意持名为治。治者意持意行三十七品经故。经言所不识所不能止为息中不识意去时不能止意去。如是当精进行出力守政坐叉手低头持意。内着心中堕自生灭。当识意去时已识当能止便不堕盖。盖在戏疑听六根如是为不可。佛言。数息意今息数不互。何意念意为互行

佛言。已三定戒应律为道法爱行道。故经言贪道法行道。已坐行道上夜后夜惊意守食。时至禺中日西至夕名为四守。当精不离是为勤力。夜半日出日中晡时是名为四正。读经经行旋塔内外。自观身体内视五灭。外从头至足从足至头。一一观视斯何等有。皆当臭败节节解堕本无所有。来作去亦灭尽无所有。反覆回念用数心意复不解。眼见死人谛念从头至足。若坐若起若饭食。常念着心中用坚其心是为数念。出息入息念灭时已觉息灭尽时无所有。校计思惟知人物皆当复尽。意止已定便知空。故经言一者勤力二者数念三者思惟

佛言。自观身。有时当观他人身。当观身者为校计。当观他人身者。为自观身意着。当观他人身死败。有时可自观身。亦可观他人身。可自观者为自观身意不着。可观他人身。亦为观他人身意不着。有时不可自观身。亦不可观他人身。不可自观身者。为自见身肥白好。不可观他人身。亦为见他人身肥白好端正腻眉赤絮。见肥当念膖胀。见白念死人骨。见腻眉念死人欲坏时色转青黑。见赤絮念血。皆当坏败。何等可贪

是意自观身有三十二物者。计发毛爪齿骨皮肉五藏十一事属地。泪涕唾脓血肪髓汗小便七事属水。温热主消食二事属火。风有十二事。是三十二物皆从地水火风出。何等为地。人生从谷精气。谷为地意为种。精气为水雨便合生身故。求一衣一食是为养气护主。人身为本无故灭尽无常。得道便知身非身。念身不久要当死败。意为人种便守意一心。痴人不守意护魂神但养四柯。为色味所欺。谓身是我计不知恶一切从身起。饭食贪味便堕苦。往来生死不脱卒逢恶对。魂神空去趣善恶之道。身死堕地日夜消腐亦本无所有但意行故化成身。死皆归土。万物亦尔。皆当过去。是为非常

人不自计多念万端。皆不为一以是为苦。身死索弃万物亦尔。灭是为已复生生复苦。便作善恶行种栽。未知所趣是为非身。道人行道当为断。人不知四非常。终不得道以自计身。视诸死败知人物皆无所有。意便守止得行欢喜。已得行心便安不离五者其心一是道

佛言。念身观头发脑。念发本无所有。来作为化成皆当腐落。脑如凝米粥皆当臭败。眼但有窌水皆汁出空塪。耳但有肉垢皆穿漏。鼻口涕唾皆流弃消坏。舌咽喉肺肝心。心中恶血肝胆膈脾着胃肾着脊胃中有未消食。大肠有屎小肠泡有尿。发便腹少增减身。死气尽皆当膖胀坏烂。肠胃屎尿相浇灒臭处可恶。下有尻肉两胫两足。肌肉稍尽筋脉坏败。骨锁节节解堕。胫脡确政白髀骨如车辐。尻骨与脊骨相连。脊与肋骨相连。肩骨与肘臂手相连。皮革消腐节节解堕。颈骨与触髅相连。肉血消尽磨磨但有骨。气出不报为死人。身侹正直不复摇。风去身冷。火去黄汁从九孔流出。水去死不复食。地去三四日色转正青。脓血从口鼻耳目中出正赤。肌肉坏败骨正白。久久转黑作灰土。视郭外臭死人死人骨如是。自身亦如是。皆当灭尽是为空。出息尽时便知空。知空便知身空。何以故。知命近在息空故

佛言。是意当先观思惟。灭念待自意便守意。意不出身为道人。待在外为万物。念在内为思。识欲灭念待当念物非常败皆非我所我亦非物主。意念死时持何等去。持善持一必持经多作多乐故。佛言。是汝物持去。其余一切皆非我所。意当识念何等恩爱会当别离各自消腐。念之但乱人意堕人罪。要当还身守净趣泥洹道

佛从一心至九道念四色皆当消灭。谓人死四五日欲臭坏色转正青。五日六日脓血从口鼻耳目中出正赤。后肌肉坏败肠胃生虫还自食皮革消腐。骨颜正白久久转黑作灰土。明地水火风空皆非我所。意汝从无数世以来亦为人作妻子奴婢。亦作畜生牛马虫象勤苦重负。亦为人所屠剥脍炙。今为人复所人作妻子奴婢。亦取畜生屠剥脍刺斫自在。身死皆当复受。行道人汝宁见死人不气绝便无所知。身挺正直便臭坏可恶。谛念便畏不欲见。何以故不怖一心。一心令人上天得泥洹道。佛知九道皆空无所有故。还就一心行道人急灭念待无所他知。便至拘深国行拘深俱在所见用不在故不见

佛言。意欲贪念非常败淫当念对。嗔恚念等心愚痴念本一切行非常无为安隐。人不知非常终不去贪。亦不离薜荔道。世间所有如梦耳。梦饭食见好寤便不见。世间所有如是。生便死。适成便坏。要皆归空。当何等可贪。人有妻子财产亦尔。何以故。人治生得钱利时。若家室合会喜乐。譬如飞鸟聚会亦皆无常。一旦别离亦便不见。正使有忧恐万苦意。在生死中为日积罪。黠人自约少欲趣求一衣一食。从定意行不求地止。常还身守净断求念空

问曰行道守意根本从何起。佛言。天地成后人从十五天上来下。寿无有夭逝生死五道从六衰起。人生心意本自善。无有贪爱痛痒思想生死识。为耳目鼻口所欺。目光视色耳声音鼻知香口知味身知寒温粗细。心为作十事成五阴。意为识合为六衰。因作善恶行种栽。从是便有老病死生五道。求道欲断生死故。自守意止目色止耳声止鼻香止口味止身如断六衰。行观怀心念坐禅灭意识。得道者五阴悉灭知本无。便念空想空径向泥洹。问所以守意者。意为识主行故。恶六衰为祸行种五道根本。道人精思自守四意欲止无邪念识思想走。何道人欲灭念识思想。当一切行非常断身十事。身口意三者从五阴六衰乃至。三定者口无所知为口定。身无所知为身定。意无所复念为意定

佛言。道有四要。界持启封乃得出。何等为四。一为识苦不复向万物。是为得出三恶道启。二者知身非身便坏身不复爱。是为从人得出门第。六天上启。三者知非常意不复向。是为得出十八天启。四者知空灭空。是为得出二十八天启。空灭乃为堕道故。经言行道觉者得出。谓觉苦空非身非常得出者谓得出四要界。得第一禅上七天无有身景。何以故。行道坏身故法观经


分别业报略经

    No. 723

分别业报略经

        大勇菩萨撰

        宋天竺三藏僧伽跋摩译

  最胜无上尊　　知见悉具足
  是故稽首礼　　及法应真僧
  我今撰安住　　知见具足说
  五趣所缘起　　由净不净业
  普为诸世间　　开示契经义
  随智力所及　　分别业果报
  佛以法自觉　　诸天咸劝请
  即至波罗奈　　演畅真谛义
  谓苦及苦因　　苦集究竟灭
  八正悉具足　　尽苦清净道
  无上人中尊　　说苦业果报
  从是转相生　　烦恼及诸业
  种种相烦恼　　无量诸业行
  次第略分别　　随顺大仙说
  契经所显示　　不违诸法相
  真实决定义　　慧者当受持
  非自在所作　　果报非无因
  亦非自性起　　亦不从时生
  自在天无因　　自性及与时
  以果有胜劣　　当知彼非因
  无知生烦恼　　从是起诸业
  因业开众趣　　今当说差别
  造诸不善业　　随业入恶道
  彼诸罪众生　　阎王慈哀说
  生老病死苦　　王法所拘执
  汝见彼天使　　何不生胜觉
  惠施清净戒　　能调身口意
  汝为何所求　　而不发上愿
  不幸遇恶友　　唯闻非法事
  增我贪恚痴　　何由起净业
  汝曾不修善　　但作诸恶行
  不觉罪报至　　今来入地狱
  尔时诸狱卒　　即执罪众生
  驱向地狱门　　恐怖身毛竖
  等活若黑绳　　众合二叫呼
  无择大地狱　　烧热及大热
  土海及粪池　　锋利剑叶林
  刀道剑枝树　　灰河铁镬狱
  造诸恶业者　　生此泥黎中
  今当说彼业　　苦报差别相
  等活死复生　　经历亿千劫
  今闻结怨憎　　互相伤害故
  陷人以非道　　两舌离亲友
  谗谤及妄语　　死堕黑绳狱
  屠捕及余杀　　死入众合狱
  诸山所磨切　　身碎血髓流
  为政无慈恻　　峻法多因缘
  广设诸方便　　种种加楚毒
  亦入众合狱　　随业受苦报
  轮转崩山芒　　铁石所磨捣
  随贪恚痴怖　　听讼违抂直
  亦入众合狱　　铁轮断其身
  自恃强力势　　崄暴陵孤弱
  亦入众合狱　　黑象竞来践
  逼迫多人众　　令彼大呼泣
  死堕叫呼狱　　举身常洞燃
  斗秤欺诳人　　心恶而口善
  言行无诚实　　入大叫呼狱
  呼哉大呼狱　　见者身毛竖
  于中受剧苦　　寄付不还故
  非法言是法　　见法言非法
  邪见无因果　　悔傲谤贤圣
  如是诸人等　　死入无择狱
  父母贤善人　　沙门婆罗门
  犯忤令忧恼　　死入热地狱
  父母贤善人　　沙门婆罗门
  恶心加苦痛　　死入大热狱
  出家修净行　　亏犯律仪戒
  展转相形毁　　死入热土狱
  越禁舍正命　　邪谄营秽生
  死入热粪池　　毒虫贯骨髓
  田猎焚林泽　　烧害陆众生
  死入火剑狱　　烧剥断支节
  诱取诸众生　　诈亲害其命
  乌鸱群饿狗　　竞来食其肉
  毁坏正法桥　　导人非法行
  死经利刀道　　截足断肌骨
  长身百足虫　　貌像端正女
  缠身唼髓脑　　由彼邪淫故
  于他妇女身　　摩触深染着
  驱上剑枝树　　往还贯身体
  种种设方便　　杀诸水虫类
  死入沸灰河　　举身悉糜烂
  吞食热铁丸　　融铜灌其口
  铁钉钉其身　　盗窃他财故
  增上十不善　　神逝入地狱
  次罪堕畜生　　余则入饿鬼
  恚憎不善行　　心常乐恶法
  见他苦随喜　　死作阎罗卒
  已说诸业行　　重者入地狱
  今当说畜生　　饿鬼业果报
  身三口四过　　及意三不善
  此业若非增　　死堕畜生趣
  多欲生鹅鸽　　孔雀鸳鸯鸟
  愚痴业所生　　蛆蚁飞蛾等
  无智好打缚　　报生象马中
  或复作牛羊　　獐鹿诸野兽
  嗔恨作蚖蛇　　蜂蝎毒虫类
  憍慢自矜高　　恶心密怀害
  报生合罗婆(八脚兽)
  及作虎师子　　虚傲疏崄报
  猪狗驴狐狼　　悭吝不惠施
  疾忌多憎恶　　轻躁心不住
  死堕猿猴中　　强颜少羞耻
  无节多言说　　随业获果报
  后受乌鸟身　　邪贪无厌足
  两舌离亲友　　后受猫狸身
  或作熊罴身　　修行大布施
  急性多嗔怒　　不依正忆念
  后作大力龙　　能修大布施
  高心陵蔑人　　由斯业行生
  大力金翅鸟　　劫盗贤善人
  饮食诸肴膳　　堕富单那鬼
  食粪及死尸　　欺怖愚尪劣
  疾病诸贫乞　　后作富提鬼
  常食诸胎网　　颦蹙鄙陋行
  悭惜多贪求　　死作贱饿鬼
  形体甚黑瘦　　悭贪不布施
  或施还自毁　　死堕食吐鬼
  唯膳脓涕唾　　自不修福慧
  毁他行布施　　悭惜甘粗涩
  乐习鄙秽行　　居伏窦下流
  恒食诸不净　　常希他人物
  有财不食用　　宁弃不行施
  死堕嗔饿鬼　　好发他阴私
  害人取财物　　余罪堕饿鬼
  常食人精气　　粗言触恼人
  好发他阴私　　刚强难调伏
  生焰口饿鬼　　炽然他斗讼
  积财常恐尽　　无慈性刚强
  后作食虫鬼　　常啖诸蛾蚁
  举身皆火然　　抑止他人施
  有财不肯舍　　生作巨身鬼
  腹大咽如针　　不施不自食
  积聚为子孙　　以此业缘故
  后生轻饿鬼　　子孙为修福
  因是得信食　　若为聚落主
  逼取他财施　　死作鸠槃茶
  饮食常随意　　若多杀众生
  以肉为施惠　　余罪作罗刹
  常得众美食　　微恚少忧戚
  常作修布施　　香华自严身
  好作诸伎乐　　后作乾闼婆
  为天执乐神　　为利而行施
  多嗔好两舌　　后作毗舍阇
  其身甚丑陋　　髼发而赤眼
  利爪长牙齿　　逼他取财物
  而以广行施　　性乐心轻躁
  生为负多鬼　　多嗔性难满
  好乐修布施　　嗜酒喜歌舞
  后生作地神　　舆乘献父母
  给施亲善人　　禀性多悭吝
  生作游空神　　宅舍乘饮食
  以此修惠施　　生作虚空神
  常与宫殿俱　　我已略分别
  畜生饿鬼趣　　今当次第说
  善道人天果　　修种种净行
  后生善趣中　　随业受果报
  今当如实说　　天人阿修罗
  欲求长寿者　　不害生为本
  慧者应当知　　慈愍不害生
  乐修诸功德　　坚固不倾动
  所生离诸难　　于诸群生类
  不捶打系缚　　由斯不恼业
  所生常无病　　未曾修布施
  亦不盗他财　　所生常短乏
  多求而少获　　能广行布施
  而复夺他物　　所生常得财
  随得寻复失　　常不盗他物
  时复行少施　　方便获财利
  所得恒不失　　常不盗他物
  兼复广行施　　所生辄大富
  得财常不失　　决定修斋戒
  所生遇正法　　众见悉爱乐
  名闻普流布　　身心常安乐
  易满知止足　　夷泰无忧恼
  质直修正行　　欲报所生恩
  信心修福业　　随其所生处
  常得父余财　　若以饮食施
  长寿好色力　　辩慧多财宝
  无病心安乐　　施衣得惭愧
  神仪高胜尊　　人相悉具足
  睹者莫不欣　　其身常安隐
  心适恒喜欢
  施屋得舍宅　　宫殿极严丽
  宝藏悉盈满　　众具随所欲
  若施井浴池　　及与净水浆
  生生无渴乏　　所欲常随意
  桥船济未渡　　履屣施徒跣
  常得象马车　　是则人中天
  若以园林施　　常获胜妙果
  一切所依荫　　心安无热恼
  众人所爱乐　　眷属悉具足
  若人施医药　　后生得无病
  长寿常安乐　　具足色力财
  无量百千世　　不经疫疾劫
  终遇法医王　　永拔生死根
  造厕除众秽　　后无便利患
  身心常清净　　见者莫不欢
  缘是离诸垢　　究竟获大安
  若为生天上　　或复求名闻
  酬恩及望报　　恐怖故行施
  获果不清净　　所受多粗涩
  祖先建立施　　子孙续不绝
  所生蒙遗庆　　无量余财宝
  常叹施功德　　有财而不舍
  所生恒贫匮　　欲施无财物
  常叹布施德　　愍念常周恤
  所生得大富　　不乐修福业
  常乐修智慧　　而不行布施
  所生常聪哲　　贫窭无财产
  唯乐行布施　　而不修智慧
  所生得大财　　愚闇无知见
  施慧二俱修　　所生具财智
  二俱不修者　　长夜处贫闇
  布施无正信　　后得饶财物
  所受悉粗涩　　其心常乐着
  深信行施惠　　生得上财宝
  所受皆庄严　　其心常爱乐
  善知良福田　　恭敬欢喜施
  所生眷属和　　俱受安乐报
  心常轻布施　　慢意供福田
  后生多财物　　虽得不能用
  凡品无异闻　　众所不敬慕
  心不轻布施　　恭敬修福慧
  生得殊胜财　　亲族悉宗敬
  随所应惠施　　其心常欢喜
  生得如意财　　以道而受用
  乘理获财物　　智慧修布施
  财宝自然至　　所得皆不失
  时施无留难　　明解修福惠
  少求多所获　　常得应时物
  若人修净行　　远离他所爱
  生得贤良妻　　容德悉具足
  慧者常远离　　非处非时行
  心安身无过　　具足丈夫法
  清净修梵行　　贤圣所称赞
  受身常鲜洁　　令闻远流布
  众人所瞻仰　　诸天咸供养
  若人于此世　　远酒离迷乱
  强志不忘误　　义辩得无异
  若人不妄语　　至诚不虚欺
  受身悉具足　　不染恶名称
  若人不两舌　　方便善和诤
  生为人中尊　　眷属常不坏
  若人不恶口　　美言悦众听
  恒闻清净音　　宣扬胜妙法
  若人于此世　　远离无义语
  诚实及应时　　知量饶益说
  后生言常正　　闻者乐信行
  若不贪他物　　未曾起求想
  所生心安乐　　常得天胜财
  若不起嗔恚　　打缚恼逼心
  常好修慈忍　　后生升梵天
  若人于今世　　深信具正见
  有无真实说　　习近善知识
  后生天中天　　慧光踰日月
  如上所宣说　　无量清净业
  随行各受生　　世间种种报
  若欲求大利　　名称生天乐
  无常求坚固　　当勤修德本
  作净不净业　　庄严种种果
  若生人道中　　杂受黑白报
  童子及盛壮　　中年衰老时
  斯各随本缘　　迭受苦乐报
  诸业作已增　　是则次第受
  虽作不增长　　久乃获果报
  若人施不恒　　中间致贫匮
  若常修惠施　　富乐无穷已
  若人多嗔恚　　后生恒丑陋
  慈忍无忿怒　　受身常端正
  若人不修慧　　所生痴闇冥
  好智习多闻　　明哲遇贤圣
  若能伏憍慢　　转身生胜族
  愚惑自矜高　　常生卑贱中
  谄谀致身曲　　讹言形矬陋
  见圣心不喜
  所生常愚憃　　喑哑不能言
  目盲无所见　　尊长师善友
  慈心安慰说　　厌舍不听受
  所生当聋聩　　洗浴诸有德
  供养妙香花　　斯人所受生
  身相悉端严　　肌体极柔软
  净如炼真金　　污所不应污
  邪行犯非处　　害形毁众生
  由斯受阉身　　若人于今世
  爱欲心炽然　　身口及诸根
  尽习妇人法　　后常受女身
  多欲不聪慧　　若人施灯烛
  演说清净道　　迷者示正路
  等爱视众生　　后得清净眼
  明彻无障碍　　子爱视众生
  哀愍诸贫病　　所生多子孙
  如月在众星　　慈母乳婴儿
  奉斋修净行　　怀妊他所爱
  一切悉不犯　　由斯净业故
  生得多婇女　　围绕自娱乐
  犹如天帝释　　爱敬礼父母
  恭肃诸所尊　　后生常高贵
  身体极柔软　　若人于今世
  坚固持律行　　后得不动财
  犹如雪山王　　若人于今世
  常不越仪法　　若彼求不求
  等施令满足　　后生得妙相
  师子方颊车　　具足无尽财
  如海珍宝渚　　身口意清净
  兼复行布施　　于他无嫉心
  己财不守护　　由斯业行报
  后生郁单越
  若人慕名闻　　及求生天乐
  依凭善师学　　身口意清净
  所有诸财物　　爱乐加守护
  由斯业缘故　　后生四王家
  若人于今世　　志强不随人
  所行多幻伪　　亦修诸善法
  乐观他斗讼　　兼行好布施
  由斯业缘故　　后作阿修罗
  孝顺净供养　　父母诸尊长
  忍辱少嗔恨　　不乐观斗讼
  由斯业缘故　　后生忉利天
  若人自不斗　　亦不观他诤
  精勤修善法　　得作夜摩天
  于身善观察　　好学集多闻
  专精思惟义　　乐修净功德
  由斯业缘故　　后生兜率天
  修习胜布施　　乐诵诸经典
  方便行善法　　自力不由他
  殷勤精进故　　后生化乐天
  修行胜布施　　善摄护诸根
  精勤不退转　　欣乐他功德
  由斯业缘故　　后生他化天
  舍离炽然欲　　修习四梵行
  离生欣乐俱　　转身生梵宫
  又离觉观心　　亦度离生喜
  定生喜乐俱　　上生光音天
  离定生喜乐　　一向与乐俱
  舍念三摩提　　生彼遍净天
  悉已度苦乐　　不苦不乐俱
  舍及清净念　　得生广果天
  觉知离想过　　及厌五种有
  深爱着无想　　生彼无想天
  世俗及无漏　　修习诸熏禅
  熏禅正受力　　生五净居天
  修习软中品　　无烦无热天
  修习上三品　　次生三净天
  如是次第上　　乃至色究竟
  依色无常想　　超修无量空
  次观无量识　　舍至无所有
  又离无所有　　乃至非非想
  我已说生死　　有有果报等
  于彼业果报　　慧者当观察
  应修清净业　　离苦疾受乐
  已说诸生死　　种种业差别
  非自在天生　　亦非自然有
  非时非无因　　唯从烦恼起
  观彼有无常　　慧者不染着
  出离诸系缚　　永到安隐处　分别业报略经


分别缘起初胜法门经

    No. 717 [No. 716]

分别缘起初胜法门经卷上

        大唐三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。在室罗筏住誓多林给孤独园。时有众多大苾刍众。在安适堂同集会坐。作如是类往复谈论。言诸大德。世尊曾以无量异门。说十二分甚深缘起。于彼最初宣说无明。以为缘性。何因缘故。一切烦恼诸行缘中。唯说无明以为缘性。于此无明见何殊胜。由是因缘便兴诤论。于时世尊。游于天住。以超过人清净天耳。闻如是事。于日晚时从宴坐起。诣安适堂在大众前。敷如常座结加趺坐。以清美音告诸大众。汝等何故集此堂中。而兴诤论。汝等今者。为何所论于此集会。时诸大众白言。世尊。我等集此。作如是类往复谈论。言诸大德。世尊曾以无量异门。说十二分甚深缘起。于彼最初。宣说无明以为缘性。何因缘故。一切烦恼诸行缘中。唯说无明以为缘性。于此无明见何殊胜。世尊。我等由是因缘便兴诤论。我等今者为论是事于此集会。作是语已

尔时世尊告彼大众。我有如是分别缘起初胜法门。汝应谛听极善作意。当为汝说。云何名为分别缘起初胜法门谓十一种殊胜事故。于缘起初。宣说无明以为缘性。何等十一。谓所缘殊胜。行相殊胜。因缘殊胜。等起殊胜。转异殊胜。邪行殊胜。相状殊胜。作业殊胜。障碍殊胜。随缚殊胜。对治殊胜

尔时众中有一苾刍。从座而起偏袒右肩。合掌礼佛。白言世尊。云何无明所缘殊胜。世尊告曰。无明所缘。即是一切若因若果。有众过患诸杂染品。及以一切若因若果。有众功德诸清净品。是名无明所缘殊胜

复言世尊。云何无明行相殊胜。世尊告曰。如是无明隐覆真实显现虚妄。以为行相。是名无明行相殊胜

复言世尊。云何无明因缘殊胜。世尊告曰。如是无明。普于一切烦恼杂染诸业杂染诸生杂染。能作因缘根本依处。云何一切烦恼杂染。谓略有三烦恼品类。普摄一切烦恼杂染。谓无知烦恼。犹预烦恼。颠倒烦恼。云何一切诸业杂染。谓略有三自相差别身语意业及三障碍对治差别。谓福非福及不动业。普摄一切诸业杂染。云何一切诸生杂染。谓略有三依止三受。谓乐及苦不苦不乐。所起三苦。坏苦苦苦及以行苦。普摄一切诸生杂染。云何无明普于一切烦恼杂染诸业杂染诸生杂染。能作因缘根本依处。谓于诸谛有二种愚。能令一切烦恼杂染。未生而生生已增广。及令一切诸业杂染。未生而生生已积集。亦令一切诸生杂染。未生而生生已不转。是故我说如是无明。普于一切烦恼杂染诸业杂染诸生杂染。能作因缘根本依处。是名无明因缘殊胜

复言世尊。云何无明等起殊胜。世尊告曰。谓此无明。或愚当来苦谛所摄后有自体。或愚现法苦谛所摄已得自体。如是愚者。或有能引所引缘起。或有能生所生缘起。此二缘起。即以愚于当来现法。自体无明作等起缘。复言世尊。云何能引所引缘起。世尊告曰。第一无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。是名能引所引缘起

复言世尊。云何能生所生缘起。世尊告曰。第二无明缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。是明能生所生缘起

复言世尊。云何名为第一无明与其能引所引缘起作等起缘。世尊告曰。谓有一类。愚于当来后有自体。即便发起后有希求。由愚所生后有希求。便于后有见胜功德。若于现法。执着可爱不可爱境。邪分别故。造非福行。彼于资具生贪着故。或于怨憎生嗔恚故。及彼相应不能决了。功德过患放逸愚故。造斯恶行。即于后世所有过失。不能思惟。不能解了。行相无明。能作如是非福行缘。若于后有见胜功德。或见出离便造福行或不动行。彼依教法或依诲法。发起思择及修习故。能造斯行。应知如是思择修习。虽在善心。然不如理作意思惟。故是后有愚痴所引。谓于后有见胜功德。痴覆藏故。及见出离。痴覆藏故。如是非福福不动行。障碍对治。与六识身俱生俱灭。能于现在已得生灭。异熟识中安置诸行。三种习气由此方便。摄受后有新生种子。摄受后有新种子故。于当生中所起后有。所摄名色。六处触受次第而生。此名色等。于现已得异熟识中。但起因性未有果性。是故但名所引缘起。如是名为第一无明与其能引所引缘起作等起缘

复言世尊。云何名为第二无明与其能生所生缘起作等起缘。世尊告曰。谓有一类。愚于现在已得自体。于六触处。为缘生受。便起味着。由味着故。希求当来。如是类受由希求故。于追求时便起于取。乐受所起爱为缘故。发生欲取。言欲取者。谓于诸欲妄分别贪。此为上首。此为前行。便有欲界一切烦恼。若复以其苦受为缘。生无有爱。厌离俱行非理所引。厌离相应。依止此爱。不正方便。求无有时即便发起出离恶见定期恶见。及此二种所依恶见由此义故。名爱缘取。若即以此取为所依。不离欲贪而命终者。由此诸见及与欲界一切烦恼。名有欲界爱为缘取。若离欲贪。或离色贪。彼色界爱或无色爱。便得生处。彼于色界或无色界。烦恼转时。发起色界无色界取。由此诸色无色烦恼及彼诸见。名有色界爱为缘取。及无色界爱为缘取。彼由如是爱为缘取。先得种种行所熏习异熟果识。名为有取。彼由如是取所摄受。先所积集行等种子。若彼彼处诸爱未断。即彼彼处功能现前。能生后有。由彼行等能有当生。能令生有将入现在。故说名有。由彼取力行等成有以是为缘。从此命终。先所引发渐次生起。由此义故。名有缘生。生既生已。先起时分变异名老。于最后边命尽名死。由是故名生缘老死。如是名为第二无明与其能生所生缘起为等起缘。复言世尊。何缘不说爱取二种能生缘起与行为缘

世尊告曰。爱取二种自界所行有分齐故。所以者何。欲界爱取。与彼色界或无色界诸不动行。为等起缘不应道理。非境界故。如说欲界爱取二种。于不动行如是色界爱取二种。于无色界诸不动行。若无色界爱取二种于欲界行或色界行。及以色界爱取二种于欲界行当知亦尔

复言世尊。何缘欲界爱取二种。不与非福福行为缘。世尊告曰。诸有现前爱非爱境增上力故。发生欲爱起不善根造非福行。一切皆由于因于果。非福行中不知过患。彼由意乐有过失故。或由加行有过失故。起非福行。如是意乐加行过失。唯用无明以为胜缘。非境界爱及不善根。若由欲爱造诸福行。彼信为依乃造斯行。于死于生起定信故。此爱及取。由信摄伏我施设为有覆无记。若法欲界有覆无记。于发诸行无胜功能。以于因果及福行中不知出离。求可爱生造斯福行故。此福行亦唯无明以为胜缘。复言世尊。何缘色界爱取二种不作色界不动行缘。世尊告曰。诸有未离欲界贪者。色界爱等未得生处若无生处则无堪能故非色界不动行缘。如说色界爱取二种。于其色界诸不动行。如是无色爱取二种。于无色界诸不动行。应知亦尔。彼于色界或无色界。有过患身。起有功德作意想见。或依教法或依诲法。发起如是非理作意能为彼界不动行缘。如是所起非理作意无明所引。如是无明由此所起非理作意及果为伴。能为彼界不动行缘。是故应知彼不动行亦唯无明以为胜缘。复有一类依无有爱。造诸福行或不动行。彼由如是无有爱故。既于诸有见多过患。岂更悕求当来诸有。然于无有不如实知。由无知故。不得诸有真对治道。又无知故。于非对治起对治想。造诸福行或不动行。由是道理。如是诸行应知唯用无明为缘。非爱及取为诸行缘

复言世尊诸所有行。与六识身相应俱有。同生同灭。何缘故说行是识缘。世尊告曰。以六识身与福非福及不动行相应俱有。同生同灭。异熟识中安置诸行。熏习种子引发余生新异熟识。由此道理。是故宣说行是识缘。复言世尊。何缘名色六处触受诸分种子。异熟识中同时引发。而复说有先后次第。世尊告曰。彼于当来。先后次第而生起故。如是而说。复言世尊。何缘名色六处触受。说为当来生身之相。世尊告曰。由彼是因受用依止。及是其因受用体故

复言世尊。若唯名生都无其色。斯有何过。世尊告曰。若一生中唯有其名不依色住。相续生起不应道理

复言世尊。若唯色生都无其名。斯有何过。世尊告曰。若唯有色无名执受即应散坏不得增长

复言世尊。若但说言识缘六处。斯有何过。世尊告曰。初受生时六处未满。唯有身根及意根转。应不可得由此两根为体。名色最初有故。次第增长。与后圆满六处为缘故。说名色是六处缘

复言世尊。若六处满生身究竟。何缘复说触受二种。世尊告曰。若于生身六处已满。虽是受用所依究竟。而未得名受用究竟。由因及受。方得说名受用究竟。是故应知。要须受用所依究竟。及与受用因体究竟。方得说名生身究竟

复言世尊。如说无明为缘生爱。又复说言受是爱缘。若唯无明是其爱缘不缘于受。斯有何过。世尊告曰。爱有三种。应于一时三种俱起。由爱观待受为缘故。非一时起。由此道理。非唯无明与爱为缘

复言世尊。若尔此爱唯受为缘。斯有何过。世尊告曰。应一切受皆是爱缘。然复有受非是爱缘。彼能为缘断灭诸爱。是故非唯受为爱缘

复言世尊。若唯说爱与有作缘。不缘于取。斯有何过。世尊告曰。悕求名爱。于崄恶趣无有悕求。然由所作非福行故。虽求善趣相违果生。彼果生时岂缘于爱。唯应用彼取为其缘。又如所说无有爱者。悕求无有。求无有时。由造福行不动行故。相违果生。此果生时岂缘于爱。唯应说彼取为其缘。由此道理。非唯用爱与有为缘

复言世尊。若取缘有。有缘生者。何缘不说取之与有以为集谛。世尊告曰。爱能造作四种业故。一者此爱于其自体境界受中。能作贪味系缚业故。二者此爱能作发起诸取业故。三者此爱能作令先所引行等成有业故。四者此爱能作死后续生业故。由是因缘。唯说此爱以为集谛

复言世尊。若生老死。名色六处触受为相。于此生身何缘显示生老死名。世尊告曰。为显如是生身之相。有三种苦成苦性故

复言世尊。生显何苦。世尊告曰。生显行苦。复言世尊。老显何苦。世尊告曰。老显坏苦。复言世尊。死显何苦。世尊告曰。死显苦苦。复言世尊。如是四种生身之相。由生老死有何差别。世尊告曰。即此四种生身之相。若次第生。若属彼生。若如是生。应知是名生身生相。复言世尊。云何次第生身生相。世尊告曰。于其最初有下种生。从此无间有渐增生。从此无间有出胎生。从此无间有渐长生。既成长已。受用言说能得等生。如是品类名次第生。复言世尊。此属谁生。世尊告曰。蕴界处生都无有我。所以者何。以诸蕴等渐增长故。其性无常。即无常法有此生相。复言世尊。云何而生。世尊告曰。由命根力有暂时住。分限法故。其性无常。即无常法如是而生。即此四种生身之相。时分变异。应知能作五种衰损。说名为老。复言世尊。云何名为五种衰损。世尊告曰。一者须发衰损。以彼须发色衰坏故。二者身相衰损。形色肤力皆衰损故。三者作业衰损。发言气上喘息逾急。身战掉故。住便偻曲。以其腰脊皆无力故。坐即低屈身羸弱故。行必按杖。身虚劣故。凡所思惟智识愚钝。念惛乱故。四者受用衰损。于现资具。受用劣故。於戏乐具。一切不能现受用故。于诸色根所行境界。不能速疾明利而行。或不行故。五者命根衰损。寿量将尽。邻近死故。遇少死缘。不堪忍故。即于此四生身相中。复有六种死差别相。一者究竟死。二者不究竟死。三者自相死。四者不究竟死分差别相。五者究竟死分差别相。六者时非时死。应知此中自相死者。谓识离身。色相灭没差别之相。如是名为生身相中名色等相由生老死而有差别。复言世尊。于缘起中说三种爱。一切皆是生身之缘。何缘处处多分唯说欲界生身。世尊告曰。欲界生身相最粗故。易显了故。非永解脱退还道故。复言世尊。如先所说诸引缘起。诸生缘起有十二分。于诸分中。几是能引。几是所引。几是能生。几是所生。世尊告曰。应知于此十二分中。无明与行及识一分。名为能引。复有一分识及名色六处触受。名为所引。复有一分受爱取有。名为能生。生及老死名为所生。应知一分名色六处及与触受。亦名所生。复言世尊。如是诸分。若引若生。为一时起。为次第起。世尊告曰。一时而起。次第宣说。复言世尊。如是诸分。若一时起。何因缘故。先说其引后说其生。世尊告曰。要由有引后有方生。非无引故

复言世尊。无明亦缘非理作意。何故唯说无明为缘。世尊告曰。无明亦引非理作意。与行为缘。又从无明所生触受为缘生爱。是故偏说

复言世尊。略由几相应知缘起世尊告曰。略由三相应知缘起。一者由无动作知缘起相。二者由性无常知缘起相。三者由有堪能知缘起相

分别缘起初胜法门经卷上分别缘起初胜法门经卷下

        大唐三藏法师玄奘奉　诏译

复次世尊。如余处说。缘有四种。所谓因缘。等无间缘。及所缘缘。并增上缘。世尊。今者依何缘说无明缘行。依何缘说次第乃至生缘老死。世尊告曰。我依诸行总相宣说。有四种缘。今此义中。我惟依一增上缘说无明缘行。次第乃至生缘老死。此增上缘复有二种。一远二近。复言世尊。此增上缘云何为远。云何为近。世尊告曰。非理作意若未生时。无明随眠能为诸行远增上缘。生已便作近增上缘非理作意所引诸行。与六识身相应俱有同生同灭。若未生时。彼能为识远增上缘。彼若生已。便能为识近增上缘。未死没时。识为名色远增上缘。既死没已。识为名色近增上缘。如以其识望彼名色。如是以其所引名色。望彼所生名色亦尔。如以名色望彼名色。如是六处望彼六处。触望于触。受望于受亦复如是。如以无明望彼诸行。无明望爱。爱望于取。取望于有。亦复如是。如以其识望彼名色。以名色等望名色等。如是以有望生亦尔。若在胎藏。婴孩童子少年时。生能为老死远增上缘。诸根成熟命将尽时。应知能作近增上缘。复言世尊。如彼有因有缘有由。法门经说爱是业因。有何密意。世尊告曰。有所摄业用爱为因。是为此中所说密意

复言世尊。此因缘由三种别义。云何应知。世尊告曰。诸能引发后生种子。是其因义。若兴此生作依作持令得生起。是其缘义。既命终已。导引近生令得生起。是其由义。如是应知三义差别

复言世尊。言缘起者。是何句义。世尊告曰。如是诸分。各由自缘和合无阙。相续而起。如是名为缘起句义

复言世尊。惟有此生相续缘起。为更别有所余缘起。世尊告曰。我说缘起。略有八门。一者说有受用世俗境界缘起。谓缘眼色生于眼识。三事和合便有其触。触为缘受。如是广说。二者说有任持缘起。谓缘四食诸根大种安住增长。三者说有食因缘起谓求诸谷田种水缘发生牙等。四者说有一切生身相续缘起。谓由能引能生。诸分别生一切所引所生。五者说有一切生身依持缘起。谓诸世界由诸因缘施设成坏。六者说有一切生身差别缘起。谓由不善善有漏业。施设三恶人天趣别。七者说有清净缘起。谓依他音。及依自内如理作意。发生正见能灭无明。无明灭故诸行随灭。广说乃至。由生灭故老死随灭

复言世尊。如无明等次第为缘。能生行等。为即如是次第灭耶。佛言不尔。复言世尊。何缘次第而说彼灭。世尊告曰。为欲显示由先诸分不生功能。令后诸分得不生法。故次第说。然非不为生相灭法有次第转。八者说有自在缘起。谓善修治静虑为缘。诸修定者随所愿乐。如是皆成终无别异。如是名为我所略说八门缘起

复言世尊。如佛所说。因业故生。因爱故转。依何密意作如是说。世尊告曰。无明为缘。先于诸有。造作增长种种福行。或非福行。或不动行。引发摄受种种生身种子差别。于此有中若爱未断。由此爱故能令行等转成其有。有起后有自体功能。如是功能不离于爱。依此密意故说是言。因业故生。因爱故转

复言世尊。若世尊说爱是转因。何缘但说取为有缘。非爱缘有。世尊告曰。若离于取。有爱不能为缘转变非福行等。令成有支生诸恶趣。又若离取。诸无有爱。不能为缘转变福行不动行等。令成有支于不定地及于定地生诸善趣。是故非唯爱为有缘。然彼有支定缘于取

复言世尊。如大因缘法门经说。汝阿难陀。若于彼彼有情类中。无有生者应无如是如是类生。若一切生都无有者。应不施设生缘老死。依何密意作如是说。世尊告曰。依所引生及所生生。二种密意。作如是说。又依老死远增上缘。及依老死近增上缘。二种密意。作如是说

复言世尊。先为略说缘起句义。其缘起义犹未为说。云何应知。世尊告曰。诸缘起义。略有十一。如是应知。谓无作者义是缘起义。有因生义是缘起义。离有情义是缘起义。依他起义是缘起义。无动作义是缘起义。性无常义是缘起义。刹那灭义是缘起义。因果相续无间绝义是缘起义。种种因果品类别义是缘起义。因果更互相符顺义是缘起义。因果决定无杂乱义是缘起义。如是应知缘起略义

复言世尊。如余经说。缘起甚深。云何应知如是缘起甚深之相。世尊告曰。即依十一缘起略义。应知缘起五甚深相。何等为五。一因甚深。二相甚深。三生甚深。四差别甚深。五流转甚深。应知缘起甚深之相。复有五种。何等为五。谓相甚深。引发因果诸分甚深。生起因果诸分甚深。差别甚深。对治甚深。应知缘起复有五种甚深之相。何等为五。谓摄甚深。顺次甚深。逆次甚深。执取甚深。所行甚深。是名无明等起殊胜

复言世尊。云何无明转异殊胜。世尊告曰。略有四种转异无明。何等为四。一者随眠转异无明。二者缠缚转异无明。三者相应转异无明。四者不共转异无明。复言世尊。谁有何等转异无明。而说无明为缘生行。世尊告曰。外法异生非理作意所引四种转异无明。由此为缘。生福非福及不动行。如是所说外法异生所有福行及不动行相应善心。一切皆是非理作意所引等流。内法异生若放逸者。彼除一种不共无明。所余无明引发放逸。为缘生行内法异生。若不放逸勤修学者。及圣有学三种无明。引发妄念为非福缘。然此非福。不能为缘招三恶趣。故此非福。我不说为无明缘行。如是所说不共无明。内法异生虽不放逸。而修学者亦未能断。诸圣有学应知永断。又不放逸内法异生。若造福行及不动行。彼是正法如理作意。相应善心之所引发。解脱为依回向解脱。而引发故。虽于善趣感殊胜生。而非无明起增上缘。然能作彼四种无明。断增上缘诸圣有学。不共无明已永断故。不造新业。所有故业由随眠力未永断灭。暂触还吐。如是所有无明缘行。生生渐灭不复增长。由此道理。应知内法诸有学者。不缘无明更造诸行。是故惟依外法异生。我说顺次杂染缘起。最极圆满。非住内法。是名无明转异殊胜

复言世尊。云何无明邪行殊胜。世尊告曰。彼四无明。于诸谛中。皆能发起增益损减二种邪行。复言世尊。如何名为增益损减二种邪行。世尊告曰。由四颠倒。谓于非法见为是法。或于是法见为非法。或于生天解脱道中。非方便者见是方便。是方便者见非方便。如是名为增益邪行。诸有诽谤一切邪见。如是名为损减邪行。是名无明邪行殊胜

复言世尊。云何无明相状殊胜。世尊告曰。应知无明有二种相。一者微细自相殊胜。二者遍于可爱非爱俱非境界共相殊胜。所以者何。缠缚无明。尚为微细难知难了。况彼所有随眠无明。相应无明。尚为微细难知难了。况彼所有不共无明。遍于一切可爱非爱。俱非境界。覆真实相显虚妄相。共相而转非余烦恼有如是相。是故殊胜。余身见等共相烦恼。亦用无明为依而转。是名无明相状殊胜

复言世尊。云何无明作业殊胜。世尊告曰。应知无明略有二种所作事业。一者无明普能造作一切流转所依事业。二者无明普能造作一切寂止能障事业。复言世尊。何等名为一切流转。世尊告曰。若是处转。若是事转。若如是转。我总说为一切流转。复言世尊。是何处转。世尊告曰。于三世处由我分别。复言世尊。是何事转。世尊告曰。内外六处由我取执。复言世尊。云何而转。世尊告曰。诸业异熟相续流转。由我分别由邪分别。复言世尊。云何名为一切寂止。世尊告曰。一切寂止略有四种。一者寂止所依。二者寂止所缘。三者寂止作意。四者寂止果成。是名无明作业殊胜

复言世尊。云何无明障碍殊胜。世尊告曰。应知无明障碍胜法。障碍广法。复言世尊。如何无明障碍胜法。世尊告曰。言胜法者。能摄五根令其和合。所谓慧根障碍。此者即是无明。是故说名障碍胜法。复言世尊。如何无明障碍广法。世尊告曰。言广法者。闻所成智。思所成智。修所成智。障碍此者即是无明。是故说名障碍广法。复言世尊。如说无智名为无明。此唯智无名无明耶。世尊告曰。非唯智无名为无明。复言世尊。若唯智无名为无明。斯有何过。世尊告曰。若尔无明应不可立决定体相。所以者何。闻所成智体上。无有思所成智。思所成智体上。无有修所成智。一切世间修所成智体上。无有一切出世修所成智。出世有学智上。无有诸无学智。无学声闻智上。无有如来等智。若如是者。应即是智即是无智。如是无明应不可立决定体相。又我于彼三善根中。说有无痴。应但痴无说名无痴。然非痴无说名无痴。故非明无说名无明。而别有一心所有法。不知真实说名无明。如别有一心所有法。了知真实说名为智。又唯明无名无明者。应无如是一切无明十一殊胜。是故应知。非唯明无说名无明。是名无明障碍殊胜

复言世尊。云何无明随缚殊胜。世尊告曰。乃至有顶三界有情。于诸谛中所有无智随眠随缚未缺未减。由彼有情说名具缚。又此无智。善趣恶趣因果差别。无色有情有其下品。色界有情有其中品。欲界有情有其上品。如是成就三品无明。诸有情类当来可生。一一法尔三品随缚。此说异生。若诸圣者渐次永断。若具上中定有中下。或有中下而无上中。又阿罗汉。虽尽诸漏脱烦恼障。应知尚有所知障。摄无明随缚。如是无明。应知极远随逐有情。唯除诸佛余皆随缚。是名无明随缚殊胜。复言世尊。云何无明对治殊胜。世尊告曰。有二妙智对治无明。何等为二。一依他音。或不依止少分有量法界妙智。二依他音全分无量法界妙智

复言世尊。少分有量法界妙智。为何所缘。有何行相。作何事业。世尊告曰。少分有量法界妙智。缘四圣谛十六行相。作无明等烦恼业。生一切杂染离系事业

复言世尊。云何应知生苦之相。世尊告曰。是内缘苦所依性故。是外缘苦所依性故。是俱缘苦所依性故。复言世尊。内缘苦者其相云何。世尊告曰。所谓病苦老苦死苦。复言世尊。外缘苦者其相云何。世尊告曰。非爱和合。所爱别离。求不得苦。复言世尊。俱缘苦者其相云何。世尊告曰。所谓略说五取蕴苦

复言世尊。云何名爱。世尊告曰。谓于现在自体贪着。复言世尊。后有爱者其相云何。世尊告曰。谓于未来自体希求。复言世尊。云何喜贪俱行爱耶。世尊告曰。谓于已得摄受资财现前境界。深生味着。复言世尊。云何名为彼彼喜爱。世尊告曰。谓于未得摄受资财非现境界。种种追求

复言世尊。云何此爱永断无余。世尊告曰。见修所断烦恼断故。下分上分诸结断故。毕竟断故。未来苦果诸爱断故。现在苦果诸爱断故。是名此爱无余永断。复言世尊。云何弃舍。世尊告曰。诸见所断烦恼断故。复言世尊。云何变吐。世尊告曰。诸修所断烦恼断故。复言世尊。云何永尽。世尊告曰。诸下分结已永断故。复言世尊。云何远离。世尊告曰。诸上分结已永断故。复言世尊。云何永灭。世尊告曰。毕竟断故。复言世尊。云何寂静。世尊告曰。未来苦果爱永断故。复言世尊。云何隐没。世尊告曰。现在苦果爱永断故

复言世尊。云何正见。世尊告曰。所谓现观前方便慧。正现观慧。及与现观后所得慧。超越所知方便圣教诸邪解行。复言世尊。云何正思。世尊告曰。谓于三宝已得证净。为所依止。于彼功德随念思惟。超越归依外道师等。复言世尊。云何正语。世尊告曰。谓圣所爱无漏戒摄。无漏作意同时而转。于四语业能正远离。超越一切诸险恶趣。复言世尊。云何正业。世尊告曰。谓圣所爱无漏戒摄。无漏作意同时而转。于三身业能正远离。超越一切诸险恶趣。复言世尊。云何正命。世尊告曰。谓圣所爱无漏戒摄。无漏作意同时而转。于邪命趣身语二业能正远离。超越一切诸险恶趣。复言世尊。云何正勤。世尊告曰。于上解脱欲乐为依。发勤精进远离障碍。圆满对治。复言世尊。云何正念。世尊告曰。勤修止观。诸瑜伽师依止三相。时时于彼三种相中及不放逸。俱行境界心现明记。超越远离修道加行。复言世尊。云何正定。世尊告曰。谓由如是七种定具。资助莹饰心一境性。乃至能作如是七支胜进依止。及与引发殊胜功德。作所依止。复言世尊。所有一切四念住等菩提分法。皆圣道摄。何缘唯说八圣道支以为道谛。世尊告曰。如是所言八圣道支。普摄一切菩提分法。复言世尊。于苦谛中有四行相。云何初名无常行相。谓于苦谛生灭法性。正观行相。云何第二名苦行相。谓于苦谛即以生灭法性为依。于三种苦随逐法性正观行相。云何第三名空行相。谓于苦谛离实我性。正观行相。云何第四无我行相。谓于苦谛非我相性。正观行相

复言世尊。于集谛中有四行相。云何第一名因行相。谓于能植众苦种子因缘爱中。正观行相。云何第二名集行相。谓于续起因缘爱中。正观行相。云何第三名生行相。谓于五趣差别生起因缘爱中。正观行相。云何第四名缘行相。谓于能作余缘引发因缘爱中。正观行相

复言世尊。于灭谛中有四行相。云何第一名灭行相。谓于永断烦恼灭中。正观行相。云何第二名静行相。谓于永断众苦静中。正观行相。云何第三名妙行相。谓于永断无罪清净安乐性中。正观行相。云何第四名离行相。谓于永断常住性中。正观行相

复言世尊。于道谛中有四行相。云何第一名道行相。谓于圣道与境相应无颠倒性。正观行相。云何第二名如行相。谓于圣道永出世间离诸漏性。正观行相。云何第三名行行相。谓于圣道先圣后圣同所游履。正观行相。云何第四名出行相。谓于圣道无上性中。正观行相

复言世尊。何缘圣谛唯有四种。世尊告曰。如是四谛。普摄一切染净因果差别性故

复言世尊。何缘四谛如是先后次第说耶。世尊告曰。由是世间诸病病因病灭良药相似法故

复言世尊。入见道时。于此四谛为顿现观为渐现观。世尊告曰。有别道理名顿现观。有别道理名渐现观。何别道理名顿现观。谓自内证真谛圣智。于真智境非安立义。总相缘故名顿现观。何别道理名渐现观。谓初业智及后得智。观察自相及因果相。由作行相别相缘故。名渐现观

复言世尊。若有如是四圣谛者。何缘世尊复说二谛。谓世俗谛及胜义谛。世尊告曰。即于如是四圣谛中。若法住智所行境界。是世俗谛。若自内证最胜义智所行境界。非安立智所行境界。名胜义谛

复言世尊。如是四谛。于圣非圣皆悉是谛。何缘如来唯说圣谛。世尊告曰。如是四谛。于非圣者。唯由法尔说名为谛。不由正智决定信故说名为谛。于诸圣者。亦由法尔说名为谛。亦由正智决定信故。说名为谛。是故如来唯说四种名为圣谛

复言世尊。全分无量法界妙智。为何所缘。有何行相。作何事业。世尊告曰。此智亦以如是四谛。为其所缘。除谛相想清净行相。入一切种诸谛行相。于作有情一切义利。趣向行相。少分有量法界妙智。若诸声闻。于作有情一切义利。无有弃背趣向行相。若诸独觉。于作有情一切义利。弃背行相全分无量法界妙智。能作一切烦恼所知二障离系所依事业。又作证得一切种智极净法界所依事业。又作救济一切有情一切灾患所依事业。是名无明对治殊胜。时薄伽梵说是经已。诸苾刍众默然领悟。深心随喜叹未曾有。闻佛所说皆大欢喜。信受奉行

分别缘起初胜法门经卷下


佛藏经

    No. 653

佛藏经卷上(奉入龙华经一名选择诸法)

        姚秦龟兹三藏鸠摩罗什译

    诸法实相品第一

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘僧俱。皆是众所知识。及无边大菩萨摩诃萨众。无量无数。尔时舍利弗从三昧起行诣佛所。偏袒右肩头面作礼白佛言。希有世尊。如来所说一切诸法无生无灭无相无为。令人信解。佛告舍利弗。汝见何利叹言希有。如来所说一切诸法无生无灭无相无为。令人信解。舍利弗白佛言。世尊。我在静处每作是念。世尊。乃于无名相法以名相说。无语言法以语言说。思惟是事生希有心。佛告舍利弗。如是如是。是事希有第一希有。谓是诸佛阿耨多罗三藐三菩提。舍利弗。譬如巧画师。画于虚空现种种色相。于意云何。是画师者为希有不。希有世尊。舍利弗。如来所得阿耨多罗三藐三菩提。说一切法无生无灭无相无为。令人信解倍为希有。所以者何。无名相法。无念无得。亦无有修。不可思议非心所依无有戏论。非是戏论所可依止。无觉无观无有所摄。不在于心非得所得。无此无彼无有分别。无动无性本来自空。不可念不可出。一切世间所不能信。如是无名相法以名相说。如是舍利弗。一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如有人嚼咽须弥能令消尽。飞行虚空不以为患。于意云何。为希有不。希有世尊。舍利弗。诸佛所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如火城纵广深浅各一由旬。四门出焰人负干草于中而过。猛风吹焰烧爆其身。是人能令火不烧草及不烧身。于中得出如本无异。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如有人以石为筏。从海此岸度至彼岸。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如有人负四天下及诸须弥山河草木以蚊脚为梯登至梵天。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如藕丝悬须弥山在于虚空。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如劫尽大火烧时。人以一唾能灭此火。又以一吹还成世界及诸天宫。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。恒河广大为无量不。如是世尊。舍利弗。四天下中普雨大雨渧如恒河。有人以手承此雨渧无所遗落。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。须弥山王为高大不。高大世尊。舍利弗。四天下中普雨大石皆如须弥。有人以手承接此石。无有遗落如芥子者。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。譬如有人以一切众生置左手中。右手接举三千世界山河草木。皆能令是一切众生同心喜乐其意不异。于意云何。为希有不。希有世尊。舍利弗。如来所说一切诸法无生无灭无相无为。令人信解倍为希有。舍利弗。如来所说诸法无性空无所有。一切世间所难信解。何以故。舍利弗。是法无想离诸想。无念离诸念。无取无舍无戏论无恼热。非此岸非彼岸非陆地。非痴非明。以无量智乃可得解。非以思量所能得知。无行无相无有恼热。无念过诸念。无心过诸心。无向无背无缚无解。无妄无妄法。无痴无痴法。无有痴网无名无言。无说无不说。无尽无不尽。无行无行相。无道无道果。无离过诸离。无思惟无杂糅。不取不舍。无得不可得。除诸滞着除贪恚痴。非实非虚妄。非常非无常。非明非不明。非闇非照不在心。无有性性本空。能降伏魔。降伏烦恼。降伏五阴。降伏十二入。降伏十八界。降伏说有五阴者。降伏说有十二入者。降伏说有十八界者。降伏说有众生者。说有人者。说有寿者。说有命者。说有有者。说有无者。降伏一切诸邪行者。舍利弗。我此圣法。皆能降伏一切贪着乃至说有法者。不信乐诸法如实相者。逆佛法者。所以者何。舍利弗。若有众生说我者。说人者。说众生者。说断灭者。说常者。说有者。说无者。说诸法者。说假名者。说边者。皆违逆佛。与佛共诤。舍利弗。乃至于法少许得者。皆与佛诤。与佛诤者皆入邪道。非我弟子。若非我弟子。即与涅槃共诤。与佛共诤。与法共诤。与僧共诤。舍利弗。如是见人。我则不听出家受戒。舍利弗。如是见人。我则不听受一饮水以自供养。舍利弗。若人除舍如是不善贪着事者。于我法中出家求道。不念涅槃。不以涅槃为念。不贪涅槃。于毕竟空法。不惊不畏。是人尚为断诸法故勤行精进。何况如是不善贪着。谓着我着众生着人着法。是人为断诸贪着故。但勤修习无相三昧。于无相三昧亦不取相。是人通达一切诸法相皆是一相。所谓无相。舍利弗。是则名为于圣法中柔顺法忍。得是柔顺法忍。乃名是我弟子。能消供养不空受身。所以者何。舍利弗。我是真实相法。不可入不可取。不可舍不可贪。不可说断语言道。无欢无喜断贪喜心。非众缘合离众因缘。无道断道至于无道。断诸语言论议音声。无形无色无取无著无用。无实无妄无闇无明。无坏无诤无合无散。无动无念无有分别。不可得示。非垢非净非名非相。非心数法非心所解。我此法中无男无女无天无龙无夜叉无乾闼婆无鸠槃荼无毗舍阇。无断无常。无我无众生无人。无来无去无出无入。无戒无犯无净无垢。无有三昧无定无定根。无禅无禅根。无知无见无贪无诤。无道无道果。无慧无慧根。无明无非明。无解脱无非解脱。无果无得果。无无力非力。无所畏无无所畏。无念无念根。无坐无行无有威仪。无此无彼无忆想分别。无菩提无菩提分。无智无非智。无地无水无火无风。无罪无福。无法无非法无苦无乐。拔诸一切戏论根本。一切永离冷而无烟。舍利弗。举要言之。我法悉破一切诸念一切诸见一切诸结诸增上慢。不念一切诸所忆念。除断一切种种语言。我是法中无常无无常。无苦无乐。无垢无净。无断无常。无我无众生。无人无寿者。无命者无生无灭。何以故。舍利弗。如来于法都无所得有所灭。故名为涅槃。亦不见有得涅槃者。舍利弗。佛亦不念涅槃。不以涅槃为念。亦不贪着涅槃。是故当知。是为第一奇特希有。所谓如来说一切法无生无灭无相无为。令人信解倍为希有

    念佛品第二

尔时舍利弗白佛言。世尊。于此法中云何为恶知识。云何为善知识。佛告舍利弗。若有比丘教余比丘。比丘。汝当念佛念法念僧念戒念施念天。比丘。汝当观身取是身相。所谓不净。当观一切诸有为法皆悉无常。观一切法空无有我。比丘。汝当取所缘相系心缘中。专念空相。当乐善法。当取不善法相。取不善法相已。为令断故观念修习。谓为断贪欲观不净相。为断嗔恚观慈心相。为断愚痴观因缘法。常念净戒深取空相。勤行精进为得四禅。专心求道观不善法皆是衰恼。观于善法最是安隐。一心修道分别谛观。善不善法谛取相已。唯观涅槃安隐寂灭。唯爱涅槃毕竟清净。如是教者名为邪教。谓是正教而是邪教。舍利弗。如是教者名恶知识。是人名为诽谤于我助于外道。亦为他人说邪道法。舍利弗。如是恶人我乃不听受一饮水以自供养。我说教者不说受者。舍利弗。于我法中多有如是增上慢教。舍利弗。若受教者受戒五岁。不能悉舍如是所教。于是教中勤心精进。自有得无所有。比丘不往咨问。我说此人虽有五岁犹名邪见。杂外道法顺行魔教。舍利弗。若有比丘受是教已。闻空无所得法即自觉知。我先受者皆是邪见。于空无所得法无疑无悔。深入通达不依一切我见人见。舍利弗。我说此人名为得清净梵行。舍利弗。若有比丘。成就如是无所得忍。虽现未得无余涅槃。我记是人。弥勒佛时当在初会。时弥勒佛欢喜三唱。是人能于释迦牟尼佛法中。成就无所得忍。舍利弗。若在家出家成就此忍。我记是人必得涅槃。舍利弗。若有人受如是教已。闻空无所得法即时惊畏。是人可愍。无有救者无有依者。直趣地狱。何以故。舍利弗。于佛教中惊疑畏者。是人则为具足恶道。所以者何。我常自说。有所得者是恶道分。何以故。舍利弗。佛所得法无有差别。是与非是若可差别是有所得。舍利弗。人宁成就五逆重恶。不成就我见众生见人见寿见命见阴入界见。贪着持戒着持戒见。贪着三昧着三昧见。依于佛想得于法想。于僧断事成就身见。何以故。于佛法中成就身见不在僧数。舍利弗。佛弟子众心无分别。舍利弗。佛弟子众无不善者。无破戒者。无破见者。无破威仪者。舍利弗。何等为恶不善。于佛众中不在僧数名恶不善。谓心心数法与诸缘合。无真实事但作分别。以分别故计有所得。是人乃至所有言说心心相续。乃至善不善法。于圣法中名恶不善。何以故。舍利弗。所有乐处中必有苦。如来法者灭是苦乐。舍利弗。如来所得。是中无欲亦无非欲。无乐无苦无思无想无修。乃至亦无空想。何以故。舍利弗。若计空想即是我想众生想者。是常想者。是断想者。何以故。舍利弗。随所有想则生诸想。是皆堕邪。舍利弗。空名无念是名为空。空念亦空是名为空。舍利弗。空中无善无恶。乃至亦无空想。是故名空。舍利弗。诸有为法可知可解。空非可知亦非可解。非可思量。是故名空。舍利弗。空非念得。何以故。空无想故。是故名空。舍利弗。何故说行空行。不念一切诸想。乃至空想亦复不念。是名空行。舍利弗。想名乃至心有所念。即名为想。无所念者乃名无想。离诸想故名为无想。随所取想皆是邪见。何以故。舍利弗。于圣法中计得寂灭皆堕邪见。何况言说何况说者。如是空法以何可说。舍利弗。诸佛何故说诸语言皆名为邪。不能通达一切法者。是则皆为言说所覆。是故如来知诸语言皆为是邪。乃至少有言语不得其实。舍利弗。诸佛阿耨多罗三藐三菩提皆是无想无念。何以故。如来于法不得体性亦不得念。舍利弗。如来何故说有念处。舍利弗。经说若人得四念处。是人能得诸法体性。能得自身得我得人。无有是处。示法别相空故说四念处。四念处性无性无处。无念无说无有贪着。念性尚无何况念处。是故如来说名念处。舍利弗。诸法若有决定体性。如析毛发百分一者。是则诸佛不出于世。亦终不说诸法性空。舍利弗。诸法实空无性一相。所谓无相。如来悉见。如来以是说有念处。舍利弗。念处名为无处无非处。无念无念业。无想无分别。无意无意业。无思无思业。无法无法相。皆无合散。是故贤圣名为无分别者。是名念处。如来以是说有念处。随顺无所有故。名为念处。随顺念佛名为念处。舍利弗。云何名为念佛。见无所有名为念佛舍利弗。诸佛无量不可思议不可称量。以是义故。见无所有名为念佛。实名无分别。诸佛无分别。以是故言。念无分别即是念佛。复次见诸法实相名为见佛。何等名为诸法实相。所谓诸法毕竟空无所有。以是毕竟空无所有法念佛。复次如是法中。乃至小念尚不可得。是名念佛。舍利弗。是念佛法断语言道过出诸念。不可得念是名念佛。舍利弗。一切诸念皆寂灭相。随顺是法。此则名为修习念佛。不可以色念佛。何以故。念色取相贪味为识。无形无色无缘无性。是名念佛。是故当知。无有分别无取无舍。是真念佛

    念法品第三

尔时舍利弗白佛言。世尊。云何为人亦说是法。为恶知识。世尊。云何为人亦说是法为善知识。佛告舍利弗。若有比丘教他比丘。比丘汝今当知念佛事空念。所缘处是不应念。汝所念空念亦复空。是无性空能断色想能断取想。是人尔时不得无想何况于念。是人尔时都无所有寂灭无性。不集诸想灭一切法。是则名为修习念佛。念佛名为破善不善一切觉观。无觉无观寂然无想。名为念佛。何以故。不应以觉观忆念诸佛。无觉无观名为清净念佛。于此念中乃无微细心心念业。况身口业。又念佛者离诸想。诸想不在心。无分别无名字无障碍。无欲无得不起觉观。何以故。舍利弗。随所念起一切诸想皆是邪见。舍利弗。随无所有无觉无观无生无灭。通达是者名为念佛。如是念中无贪无著。无逆无顺无名无想。舍利弗。无想无语乃名念佛。是中乃无微细小念。何况粗身口意业。无身口意业处无取无舍。无诤无讼无念无分别。空寂无性灭诸觉观。是名念佛。舍利弗。若人成就如是念者。欲转四天下地随意能转。亦能降伏百千亿魔。况弊无明从虚诳缘起无决定相。是法如是无想无戏论。无生无灭不可说。不可分别无闇无明。魔若魔民所不能测。但以世俗言说有所教化。而作是言。汝念佛时莫取小想。莫生戏论。莫有分别。何以故。是法皆空无有体性。不可念一相。所谓无相。是名真实念佛。所谓无生无灭无相无为。何以故。如来不名为色。不名为想。不名为念。不名分别。不逆不顺不取不舍。非定非慧。非明非无明。如来不可说不可思议无相。汝今莫乐取相。莫乐戏论。佛于诸法无执无量。不见有法可执可量。是人于佛犹尚不得。何况于念。舍利弗。如是教者名善知识。第一义中无有决定。是善知识是恶知识。复次舍利弗。若有比丘教余比丘。比丘汝当分别观察诸法。亦复莫念法相。是比丘如是修习心无系着。则能通达诸法一相。所谓无相。是人犹尚不生法想。况我人想。舍利弗。于意云何。念法想者。是人能灭一切法不。不也世尊。舍利弗。如树无根能有枝叶华果实不。不也世尊。如是舍利弗。若人不得诸法根本。是人能生诸法想不。不也世尊。舍利弗。若人不得不念法想。是人能灭一切法不。不也世尊。是人不得于法不得法相。不得于灭。亦不分别无生无灭。是人尔时不生不灭。不名得涅槃者。亦复不名无得涅槃。舍利弗。如是教者名善知识。第一义中无善知识无恶知识。舍利弗。若人成就如是相者。世间希有。得不颠倒真实见故。是为正见。复次舍利弗。正见者。名为正作正行正道正解。无有颠倒如实而见。是故如来说名正见。舍利弗。若有众生无有颠倒如实观者。则有正见。若生我想人想众生想者。当知是人皆是邪行。舍利弗。佛及弟子。不说有我。不说有人。不说众生。不说寿命。不说断常。是故佛及弟子。名为正见。何以故。正观不颠倒故。舍利弗。一切凡夫于此事中无能入者。何以故。一切凡夫都无正见。但有随顺正见得柔顺忍。不能如实。舍利弗。是名正见邪见差别。如实见故名为正见。见世乐因增长财利是世间正见。是皆欺诳不免生死。舍利弗。佛说世间正见。是说懈怠下劣者法。贤圣不作是念。此是正见此是邪见。所以者何。一切诸见皆从虚妄缘起。舍利弗。若作是念此是正见。是人即是邪见。舍利弗。于圣法中拔断一切诸见根本。悉断一切诸语言道。如虚空中手无触阂。诸沙门法皆应如是

    念僧品第四

舍利弗白佛言。世尊。何等为圣众。舍利弗。若有人能信解通达一切诸法无生无灭无起无相。成就如是忍尚不得我。况得须陀洹斯陀含阿那含。况得阿罗汉况复得法。况得男女何况得道。况得如是等事。是名圣众。是亦不得。复次舍利弗。众生少能信解无生无灭无相法者。若能信解无生无灭无相法者。心无颠倒共相知解。以法和合不受后有。知诸世间但从虚妄缘起。是人则更不住是身。以是因缘说名圣众。是人于是语言亦复不得谓诸名相。但集无相无戏论事。是名僧宝应受供养。得无颠倒真实义故。是人以是方便念僧是事亦空。舍利弗。如是教者名善知识。舍利弗。断一切语言道。名为圣众。何以故。于圣法中所因语言说真实义。如是语言亦不可得。是故当知断诸语言。名为圣众。舍利弗。或有人言。若于此中无有言说无有定者。何名为僧。舍利弗。我于此中有如是答。众僧名为示如实事。此事决定亦不可得。俱同一学一忍一味。是事亦以世俗语故说。非第一义。第一义中无有定实名为僧法常不坏者。圣人若说言有是法。是即为污。所以者何。若人作是分别。是男是女。是天是龙是夜叉是乾闼婆是鸠槃茶。是法是非法。作是分别已得种种事。得种种事故作是言。是坐是卧是行是住。圣人得诸法实相故。亦不分别是男是女。是天是龙乃至是法是非法。不分别故不得种种法。不得种种法者。能作是说是坐是卧是行是住不。不也世尊。舍利弗。若人言是男是女。是天是龙乃至是法是非法。是人所说非虚妄耶。虚妄世尊。舍利弗若不入是虚妄者。名为圣众。不颠倒故名为圣众。舍利弗。所有不善所有可知所有可得。如是一切诸不善法。皆以名相为本。此贤圣法中断诸名相。又不念名相不得名相。云何当言是圣是众。断诸名相名为圣众。若有法处可破可断。贤圣法中无名无相无有语言。断诸语言无有合散。若言无僧则破圣众是亦不得所谓名相虚妄想故。着种种邪见。因是邪见更受后身。贪着诸见则五阴生。舍利弗。五阴皆是虚妄贪着。是名恶道是名邪见。贤圣众者无有此事。但知虚妄缘故起于三界。知是事故名为圣众。舍利弗。凡所有见于圣众中皆不可得。谓我见众生见寿命见。人见男见女见。天见地狱见畜生见饿鬼见。阴入界见。贝声见鼓声见。地声见水火风声见。持戒声见毁戒声见。正道声见邪道声见。垢声净声。禅定三昧八圣道声。须陀洹果斯陀含果阿那含果阿罗汉果声见。解脱声见得果声见。佛声见法声见僧声见。灭声见涅槃声见。舍利弗。是名虚妄音声等见。贤圣众者。于第一义不得是见。通达种种音声一相。所谓无相。无违无诤成就不颠倒法忍故。名为圣众。舍利弗。是不颠倒法忍即是无相。无相故无取无舍无逆无顺无生无灭。是中自然归灭无修无坏无起无得。不分别此彼故心常舍离。所以者何。于是忍中无此岸无彼岸。无分别无非分别。通达无相成就是忍。名为圣众破和合故名为圣众。舍利弗。我余经说。若人见法是为见我。如来非法亦非非法。何以故。调达愚人及诸外道。皆以色身见佛。舍利弗。如来不应以色身见。亦复不应以音声见。舍利弗。若人以色身见佛。是去佛远。所以者何。佛不名见色名为见佛。舍利弗。若人能见诸法无相。无名无触无忆无念无生无灭。无有戏论不念一切法。不念涅槃不以涅槃为念不贪涅槃。信解诸法皆是一相。所谓无相。舍利弗。是名真见。佛谓一切法无求无戏论无生。于此事中亦不念不分别。是名见佛。若有人于此法中无忆想分别。无取无舍无贪无违。无想无想业。不贪言说。知法假名。皆无所有。断语言道。无有差别亦无戏论。是名无生无想行者。于世间中名为圣众。舍利弗。见何法故名为见佛。所谓无想。无分别无戏论。不受一切法。若以空门若寂灭门若离门。不念见不得见。是事亦不得。所谓名字。是处亦不得。所谓涅槃。何以故。舍利弗。我尚不念涅槃。云何当说汝等当念涅槃当得涅槃。舍利弗。若人得涅槃者。是人不随如来出家。随六师出家。舍利弗。当知是人为是法贼入我法中。当知是人污辱我法。当知是人为是大贼。如大城邑中有大贼。所以者何。如是痴人尚不得涅槃。何况我人。舍利弗。如是痴人我以手遮。非我弟子。不入众数。我非彼师。舍利弗。若知诸法无生无灭无念无想。得是法忍者尚不得涅槃。何况我人。舍利弗。佛说如是名为见法。能见是事名为见佛。舍利弗。云何名为佛。一切法如不异不坏。是名如来。若人于是法中无有疑悔。是名圣众。舍利弗。过去世中有一痴人不识猕猴。入一大林见猕猴群丛聚一处。是人曾闻有忉利天。便谓为是忉利诸天。即出树林还本聚落。多人众中作如是言。汝等曾见忉利天不。众人答言。未曾见也。即时语言。我已得见。汝欲见不。皆言欲见。即将大众诣彼林中示猕猴群。汝等观此忉利诸天。众人皆言非忉利天。此是猕猴乐住林中。汝痴倒故不识猕猴。又亦不识忉利诸天。舍利弗。是人空将大众诣彼林中。如是舍利弗。于未来世当有比丘至白衣家作是言。汝欲见佛圣众听佛法不。中有白衣信佛法者。皆言欲见听受佛法。舍利弗。中有白衣贪乐语言入于塔寺。有诸比丘好于言说能通诸经。依止语言乐于文饰。是诸沙门随顺为说。谓是真道。但充众数如放牛人。但乐读经不入真际。但悦人意贵于名利。善巧世事不净说法。但能巧语行世间道。无有威德破涅槃因。舍圣默然不乐禅定。昼夜常好谈论诤讼。卧厚被褥尚无一念随顺禅定。何况能得成沙门果。是人睡眠常与俗心相应。初夜后夜不修顺忍乐于下法。是人亦多得供养衣服饮食。何以故。是人常为恶魔所摄乐浅近语。于第一义不能勤学。不能诵持第一深经。闻则惊畏舍于淳浓而取糟粕。有诸凡夫见得利养。生贪着心作是念言。我等亦当习是言论。舍利弗。是人舍于无上法宝堕在邪见。是沙门旃陀罗。有诸白衣往诣其所。如此恶人而为说法。以利养故称赞于佛及法与僧。但求活命为财奴仆。贪重衣食赞己所乐。若行布施得生天上。于佛法中施为下法。赞以为最而作是言。大施因缘得生天上。不知语言不解义趣。但知初入浅近下法。贪着我人舍第一义。舍利弗。如是说法。或时有人生信出家。与诸恶人而共和合。不能勤求第一深义。有所得者说有我人寿者命者。忆想分别无所有法。于阿毗昙修妒路中自为议论。或说断常或说有作或说无作。舍利弗。我法尔时多外道法。令诸众生正见心坏。如是舍利弗。我清净法以是因缘渐渐灭尽。舍利弗。我久在生死受诸苦恼所成菩提。是诸恶人尔时毁坏。舍利弗。若有比丘。不能舍是有所得见我见人见。不解如来随宜所说。而言决定有我人法。如是之人。我则不听受一饮水。或时是人得闻空法。信心清净而不惊疑。即便还应导引众人入实相义。便应出家受具足戒。何以故舍利弗。若人不舍如是见者。是名外道。舍利弗。我以世俗因缘假说有我。非第一义。若有人言。我亦复以世俗因缘而说有我。是人若能通达无生无灭无相之法。与我所说不相违者。是我弟子。舍利弗。若有人言。如来何故随世因缘。于无我法而说有人。如来不应为世间故作不实语。又诸经中多说有人。佛所说者不应虚也。舍利弗。应答是人。佛说诸法皆空无主无性。但是虚妄非第一义。如来不以第一义故。说有我人。圣人言说无所贪着。无智慧人无与佛等亦无过者。舍利弗。如来智慧不可思议。以是智慧知众生心。宁当有人与佛等者。佛为大龙大法之王。不应难言。佛说有人一切世间常共我诤。我常不与世间共诤。舍利弗。说有我者甚可哀愍。此中无法亦无有我。多有众生不解如来随宜所说。违逆法宝多堕恶趣。舍利弗。我知邪见而不为邪见。能知邪见者即是正见。舍利弗。邪见终不变作正见。见不知见。舍利弗。诸佛如来阿耨多罗三藐三菩提。一切世间所难得信。我于诸天一切世间。是最可信非不可信。舍利弗。我所说法为至彼岸。是中亦无至彼岸者。我所说法为尽诸行。是中亦无尽诸行者。我所说法为寂灭故。是中亦无有寂灭者。我所说法为灭度故。是中亦无有灭度者。我所说法为解脱故。是中亦无有解脱者。我所说法为诸智故。是中亦无有诸智者。我所说法为净垢故。是中亦无有净垢者。舍利弗。如来为天说法亦无有天。为人说法亦无有人。为众生说法亦无有众生。舍利弗。如来说明及与解脱。是中无明及与解脱。我说念佛佛不可念。我说空行空不可行。亦不可念。舍利弗。是名如来所说经法章句。是中无有说者。诸恶人等得此章句为他人说。亦复以我为师。无有如来圣众功德。而自为僧数。舍利弗。譬如猕猴群不似忉利天。如是众恶人。不似我圣众。舍利弗。是诸恶人。但以音声语言。自谓沙门。似如痴人见猕猴群谓忉利天。舍利弗。中有出家人喜乐问难。得值善师为说名色寂灭语言道断。无起无失。通达无相。得闻如是无生无灭无相之法。不惊畏者。当知是人已曾供养无量诸佛。能知我法可名圣众

    净戒品第五之一

佛告舍利弗。破戒比丘有十忧恼箭。难可堪忍。比丘成就十忧恼箭。则于佛法不可滋味。憎说法者不乐亲近。何等为十。舍利弗。破戒比丘见僧和合不生喜心。何以故。和合布萨必驱我出。是恶比丘自知有过常怀忧恼。于持戒者嗔恨不喜。舍利弗。是名破戒比丘初忧恼箭。必堕恶道。复次舍利弗。破戒比丘众所憎恶不欲亲近。如恶牛利角人所舍远。是恶比丘自知有过常怀忧恼。舍利弗。是名破戒比丘二忧恼箭。必堕恶道。复次舍利弗。破戒比丘逢见比丘众。自知不同恶心舍离。怀愧耻故不能入众。舍利弗。是名破戒比丘三忧恼箭。必堕恶道。复次舍利弗。破戒比丘毒恶心盛不可化喻。犹尚无有外道戒法。况于净戒。以其破戒因缘人不亲近。舍利弗。是名破戒比丘四忧恼箭。必堕恶道。复次舍利弗。破戒比丘以他财物自养其身。我说此人为重担者。所以者何。行者得者应受供养。破戒比丘非是行者非是得者。是故舍利弗。破戒比丘当于百千亿万劫数。割截身肉以偿施主。若生畜生身常负重。所以者何。如析一发为千亿分。破戒比丘尚不能消一分供养。咒能消他衣服饮食卧具医药。舍利弗。破戒比丘着圣法服。犹尚不应入寺一步。何况得受一饮之水。乃至床榻。何以故。舍利弗。如是恶人于天人中是为大贼。一切世间皆应远离。舍利弗。是败坏人即是怨家。如来悉听一切世间皆至我所。破戒之人如来手遮。非我弟子。何况一日住我法中。舍利弗。譬如死人死蛇死狗最为臭秽。清净诸天欲游戏时。不应得见若见则远。如是舍利弗。破戒比丘如彼三尸臭秽不净。智者远离不与同事布萨自恣。舍利弗。破戒比丘于我法中为是不吉。持戒比丘见此破戒即时远离。何以故。若破戒比丘手所触物及所受物。于持戒者则为毒恶。舍利弗。正使三尸臭秽满地。我能于中行四威仪。不能与此破戒比丘须臾共住。何以故。舍利弗。是为沙门中卑陋下贱。为沙门中朽坏弊恶。为沙门中秕糠。为沙门中垢。为沙门中浊。为沙门中污。为沙门中曲。为沙门中粗。为沙门中失圣道者。如是人等。于我法中出家求道而得重罪。舍利弗。如是之人于我法中。为是逆贼。为是法贼。为是欺诳诈伪之人。但求活命贪重衣食。是则名为世乐奴仆。舍利弗。譬如黄门非男非女。破戒比丘亦复如是。不名在家不名出家命终之后直入地狱。舍利弗。譬如蝙蝠欲捕鸟时则入穴为鼠。欲捕鼠时则飞空为鸟。而实无有大鸟之用。其身臭秽但乐闇冥。舍利弗。破戒比丘亦复如是。既不入于布萨自恣。亦复不入王者使役。不名白衣不名出家。如烧尸残木不复中用。如是比丘。无有戒品定品慧品解脱品解脱知见品。但有具足破净戒品。不能出大微妙音声。戒声定声慧声解脱声解脱知见声。但出毁戒弊恶音声。与诸同恶俱出恶声。但论衣服饮食床卧。受取布施树木华果。为贵人使。及论国土吉凶安危戏笑众事诸不善语。常于日夜伺求尘染。比丘如是。身业不净口业不净意业不净当堕地狱。舍利弗。是破戒比丘乐于闇冥。如彼蝙蝠。闻说正经以为忧恼。所以者何。如实说故。世间之人不喜实说但乐顺意。如是比丘于说法者心不清净。重更为罪增益地狱。舍利弗。是名破戒比丘五忧恼箭。必堕地狱。复次舍利弗。破戒比丘无有羞耻。诸根散乱成就不净。身口意业不净威仪。所著衣服皆不如法。好喜妄语不能护口。心常驰骋染于垢秽。舍利弗。如新瓦器盛以屎尿臭烂脓血。后去不净着栴檀香。复去栴檀如是瓦器有何等气。世尊。是新瓦器先盛屎尿臭气坚着。唯有臭气无栴檀香。舍利弗。人以清净信等诸根出家学道。遇恶知识而随其教。舍利弗。何等为恶知识。恶知识者。常好调戏轻躁无羞。言语散乱不摄诸根。心不专一痴如白羊。亲近如是恶知识者。失须陀洹果斯陀含果阿那含果阿罗汉果。乃至失于生天之乐。况涅槃道。但能修集破法罪业。与破法者而共从事。是人成就不净身业不净口业不净意业不净持戒。身死之后入于恶趣。云何恶趣。恶趣名为地狱畜生饿鬼阿修罗道。复有恶道如阿由勒虫。婆伽罗目呿虫。浮弥修遮迦虫。修脂目迦虫。是人多生此诸虫中。舍利弗。是人随恶知识。若生人中父母生离死亡丧失。亲里衰恼国土破坏。生八难中舍八乐处。多欲怒痴常好戏调。轻躁无羞言语散乱。不能摄心痴如白羊。为贪欲嗔恚愚痴所坏。聋哑盲瞎手脚挛躄。共恶知识生无佛处。若值佛世目不喜见。不喜闻法不与佛众而共和合。起是恶业。恶人共生乐下劣法。于正见中生邪见想。于邪见中生正见想。是名下欲下忍下慧。舍利弗。下慧之人。终不能为厌离灭道涅槃生心。舍利弗。遇恶知识而得如是诸衰恼患。有是相貌。是人闻是诸深经法。惊疑怖畏如堕深坑。则堕大罪深坑堑中。何以故。舍利弗。如经中说。破戒比丘有大重罪。何因缘故名为破戒。破所受戒难可教语。行无常准多所违逆。常行贪着多杂糅行。贪嗔痴行乐诸杂语。名为破戒。复有乐多事务。乐多讽诵。乐多睡眠。所言不顺无有次第。说不清净贪着我人寿者命者。是故名为弊恶比丘。不知节量。不知沙门法。不知婆罗门法。乐行医术贩卖求利。乐为国使污染诸家。乐与白衣给使作务。以诸树叶华果奉上好为白衣说外道法。心常舍离出世间法。未满二十受具足戒。受戒事中有诸不具。形体缺少不应于法。受生米谷钱帛金银。不顺教诲拒逆师命。不自知身不知他人。不能分别贵贱差品。好喜妄语贪着戒取。行事散乱心不专一。面有嗔相悭贪不信。不识恩义多怀贪欲。睡眠戏调疑悔嗔恨。覆藏罪恶。好自专执。嫉妒谄曲无所惭愧。自大放逸憍慢我慢大慢邪慢。好行欺诳赞美其身。多作方便开利养门。陵践白衣伪现亲厚。因势得财以夸众人。毁破戒品定慧解脱品。解脱知见品。于佛法众心不定信。不信业报贵于现利。谓无后世多诸疑悔。志性浅弱常好惊怖。舍利弗。是名弊恶比丘。如是痴人于我法中。便是屎尿臭秽不净。是人成就身口意业命不清净故。命终之后堕在恶道入大地狱。如是比丘。诸佛如来及弟子众。常所远离。余好道者求灭度者。亦皆不近。舍利弗。譬如栴檀置不净器同于不净。不复任用。如是舍利弗。若在家出家亲近是人习效所行。亦破戒品不久同恶。颜色毁悴破失威仪。命终之后生地狱中。舍利弗。如是恶人诸佛如来及弟子众。并余求道好灭度者。皆所远离。舍利弗。譬如栴檀置不净器。不复任用。如是舍利弗。若在家出家虽以涂身犹杂不净。舍利弗。此恶比丘亦复如是。虽坐众中着圣法服。然是比丘恶相犹现。梵行比丘见此不净远而不近。见他远离心则嗔恨。以是因缘死入地狱。舍利弗。是名破戒比丘六忧恼箭。必堕地狱

佛藏经卷上佛藏经卷中

        姚秦龟兹三藏鸠摩罗什译

    净戒品之余

复次舍利弗。破戒比丘闻佛所说如是等经。心不清净欢喜信乐。自知有过便疑此经。为我等说不为余人。何以故。如我等比丘在此事故。舍利弗。如是上妙无比之法。破戒比丘乃生嗔恨。于说法者心多不信。得闻如是佛所说经。违逆不受。而作是言。此非佛说教语余人。何以故。破戒比丘不乐修道。修道比丘不逆佛语。此皆破戒愚痴恶法。谓心不信违逆佛语。如是比丘自知有过。但生嗔恨憍慢佷戾。恶邪慢心谤佛法僧。舍利弗。随此比丘闻是诸经违逆不信。心不通达无上菩提。教语诸人非佛所说。舍利弗。佛说是人则为谤法。以谤法故为非沙门非释种子。应当灭摈是等比丘。若百千万亿诸佛三轮示现。不能令悟使得道果。何以故。舍利弗。如是恶人于此法中自作障道。无复生分无有信心。但好衣食贪乐世利。我说此人必堕地狱。舍利弗。我今明了告汝。若人违逆如是法宝。于好生处永无有分。但生恶处常盲无目。舍利弗。是诸比丘憍慢炽盛不能定说。破我正法。其余众人不能自活。为利养故随破我法。舍利弗。如是法宝尔时坏灭。何以故。如是法宝一切诸佛皆共恭敬诸辟支佛阿罗汉等亦皆恭敬。破戒比丘增上慢者不定说法。诸比丘等。尔时皆共轻慢我法而共远离。多怀悭贪专求生业。贵于财利嫉妒所缚。常好诤讼互生怨隙。不相敬顺无有威仪。志性轻躁犹如猕猴。转易威仪行诸恶业。退沙门法远离贤圣。舍利弗。如是恶人覆藏瑕疵。多欲多求以财自活。恶魔知心为作方便。令其乖异各共散坏。一味僧宝分为五部。既有五部则生诤讼。互相是非论说过失。舍利弗。如今比丘。互相教化互相恭敬。同心共行随顺佛语。尔时比丘。不相教化不相恭敬。见作恶者畏而舍去。不能以法共相教诲。或时虽有多闻深智。犹怀憍慢轻贱余人。各以所是自立其轮。不喜相见况能受教。舍利弗。如来在世三宝一味。我灭度后分为五部。舍利弗。恶魔于今犹尚隐身。佐助调达破我法僧。如来大智现在世故。弊魔不能成其大恶。当来之世恶魔变身。作沙门形入于僧中种种邪说。令多众生入于邪见为说邪法。谓弥楼陀罗迦楼。斗事五分。事念念灭。事一切有。事有我事。有所得事。尔时恶魔说如是等邪贪着事。如是事者。非诸佛及佛弟子所说。尔时恶人为魔所迷。各执所见我是彼非舍利弗。如来豫见未来世中。有如是等破法事故。说是深经悉断恶魔诸所执着。舍利弗。当尔之时阎浮提内。多是增上慢人。作小善顺便谓得道。命终之后当堕恶趣。何以故。是人长夜自谓得道。亦复称说他人得道。冒受圣人所供养事。是人于诸天人世间为大恶贼。如是痴人闻说第一实义。惊疑怖畏如堕深坑。舍利弗。有诸比丘乐此事者。相与共集破坏诸佛无上菩提。尔时增上慢人偏执者多。恶魔又复迷惑在家出家者心。令执非法。说正法者少于援助。则便散坏不复得立。舍利弗。尔时世间年少比丘多有利根。所以者何。诸出家者有余烦恼。还生人中即复出家。是诸比丘喜乐难问推求佛法第一实义。舍利弗。尔时增上慢者。魔所迷惑但求活命。实是凡夫自称罗汉。谓诸年少比丘等言。善身口意此是佛法第一实义。善护净戒读诵经法勤修多闻。是名顺忍因缘。所谓净心信佛。又有第一实义。汝当系心缘中。专念涅槃灭三种苦。则能厌离五阴十二入十八界。汝等当于静处观此阴界入法悉皆无常自观其身种种不净。汝等能如是观当得须陀洹果。又能于是五阴等法。深观无常苦空无我无有坚牢。则得斯陀含转复深观得阿那含得阿罗汉。是为第一实义是中年少比丘复问。于佛法中阿罗汉果。便是第一义耶。我等亦知是事。得阿罗汉是第一义。今此五阴。为忆念者生。为不忆念者生。答言。是五阴者忆念者生。不忆念者不生。复问。忆念与五阴为异不答言。如五阴忆念亦尔。复问。若如五阴忆念亦尔者。谁是念五阴者。答言。若无念五阴者。则无涅槃。实有念五阴者。是故有修八直圣道。入涅槃者。舍利弗。未来世中多有比丘成就此忍。舍利弗。尔时会中多诸天众。欲闻佛法第一实义。闻是增上慢者所说。心生疑悔如堕深坑。咸作是言咄哉。释迦牟尼佛法今将速灭。舍利弗。中有成就善根比丘。谓是比丘痴人空老增上慢者。若有五阴相十二入十八界相者。不受此语不喜不悦从座起去。舍利弗。尔时诸天心大欢喜四方唱言。释迦牟尼佛犹有好弟子在。是诸人等善根不少。不喜闻是不净所说。谓我见人见。诸天闻此皆大欢喜。称扬赞叹是利根者。喜乐问难必皆成就无生法忍。如是人等合集一处共为徒侣。人众既少势力亦弱。舍利弗。尔时我诸真子。于父种族尚无爱语。况得供养住止塔寺。舍利弗。汝且观之。尔时如来便为轻微。我灭度后我诸子等。成就善寂无所得忍时亦为轻贱。我以是故。于无数劫摧诸怨敌。化诸一切天王人王令心清净。所以尔者。令我诸子得安父位。舍利弗。如来今以一切世间天人为证。如来如法得阿耨多罗三藐三菩提转无上法轮。沙门婆罗门若天魔梵所不能转。舍利弗。如是现事。如来灭后我此阿耨多罗三藐三菩提。我诸弟子等欲广流布。是诸恶人不能证明。亦复不能施与无畏。舍利弗。譬如蜜瓶置四衢道。而作是言。若人能食一毛头者。常不老死。尔时诸天世人各以刀杖卫护是瓶。时卫护者各作是言。若或有人食一毛头者。我等当杀。舍利弗。中有一人窃作是念。是瓶中蜜食一毛头。则不老死。我今何为惜死不啖。若得啖已。则便不畏诸卫护者。亦可常得无老病死。如是定心不惜寿命直诣瓶所。诸卫护者各持刀杖竞欲杀之。舍利弗。是人若能刀杖未。及食一渧者。则免衰患无复老死。如是舍利弗。多有恶人魔及魔民欲灭我法。如来灭后若有人能随顺空法通达无疑。则于诸法心无所得成就上忍。尔时虽为恶人所轻沮坏其道。是人若能不惜身命勤行精进。通达诸法无生无作。则得度脱生老病死。舍利弗。蜜瓶是佛第一义法。诸天世人卫护瓶者。则是恶人乐行魔事。自失大利。亦遮他人行实相者。失于大利。舍利弗。增上慢者皆是魔党助成魔事。咸共讥诃无生灭法。又舍利弗。不净说者。我见人见众生见。五阴十二入十八界见。未得谓得心计得道计得涅槃。咸亦讥诃如是正法。何以故。是人贪着空故。亦是魔众魔所迷惑。以我正法而作魔事。舍利弗。若在家出家闻是无我无人无众生毕竟空法惊疑畏者。当知是人受魔教化。是像比丘为是盗法恶威仪者。舍利弗。是人则是我见众生见有见无见常见断见。皆是魔民非佛弟子。何以故。我经中说。一切世间皆空。无我无我所。无人无众生。无常无定无不坏法。如是恶人亦复皆共读诵是经为他人说。而心贪着我见人见。如是痴人名为造作苦因。名为反覆两端。各为斗乱破僧。名为污染道法。名为沙门中浊。名为丑陋秽恶。名为但有言说。名为假伪沙门。名为沙门中贫。名为担重担者。名为欺诳诸佛。名为得逆罪者。舍利弗。是人名为大恶逆贼。名为恶知识。名为破戒。名为邪见。名为外道。名为无实行。名为恶伴。名为杀鬼。名为癞疮。名为臭秽。名为烧热。名为谄曲。名为堕在黑闇。名为入稠榛林。名为堕生死流。名为互出恶者。名为地狱。名为畜生。名为饿鬼。名为阿修罗。名为不入道者。名为欺诳人者。名为自赞己者。名为行占相者。名为大声唤呼。名为因利求利。名为污染他家。名为常调戏者。名为散乱心者。名为贪所害者。名为嗔所害者。名为痴所害者。名为好面欺者。名为衰恼处者。名为无解脱者。名为忧恼缚者。名为非沙门。形像沙门。沙门旋陀罗。沙门臭秽。沙门糟粕。名为难满。名为难养。名为坏威仪者。名为无羞耻者。名为截断头者。名为身体坏者。名为袈裟系颈。名为自入闇冥者。名为多贪欲者。名为多嗔恚者。名为多愚痴者。名为五盖缠覆。名为没者。名为虚者空者。名为痴者。舍利弗。云何名空。退失诸佛赞善人相。故名为空。退失一切沙门功德沙门事法。故名为空。云何为虚。在圣法外故名为虚远离空无相无愿法故名为虚。舍利弗。如是恶人能令魔喜。贪着坚执虚妄法故。同于凡夫备足具有罪恶人相。不似得法忍者。沙门事法沙门功德。百千万分尚无其一。舍利弗。是故名为空者虚者。但深贪着世间利乐。非是沙门自称沙门。不应供养而受供养。名为常贼立幢相贼。名为自在杀害人贼。是人所食一口皆不清净。唯有向道得道果者能消供养。是人无此。是故名为不净食者。舍利弗。是故名为空者虚者。于意云何。若人杀生偷盗邪淫妄语两舌恶口绮语贪嫉嗔恚邪见。是人为是常杀生不常夺命不。不也世尊。在家杀生不常夺命。杀生时少不杀时多。舍利弗。于意云何。若人偷盗。偷盗时多不盗时多。世尊。不盗时多。舍利弗。于意云何。若人邪淫。邪淫时多不邪淫时多。世尊。不邪淫时多。妄语恶口两舌绮语贪嫉嗔恚时多。不嗔恚时多。世尊。不嗔恚时多。舍利弗。是十不善道中何者罪重。世尊。十不善中邪见罪重。何以故。世尊。邪见者垢常着心。心不清净。舍利弗。我今语汝。若人一日杀百千万亿众生。一日偷盗百千万亿金银宝物。邪淫者昼夜不息。妄语者常欺诳人。口业不净无一实语。两舌者常破和合亦助破者。恶口者口常恶逆。乃至不说柔软一语。绮语者无有根本人问此事。以余无量语言干乱。贪嫉者于他物中生非法心。嗔恚者无有因缘横起嗔恚怀恨满心。邪见者乐行非道。舍利弗。于意云何。若人成就如是不善法者罪为多不。甚多世尊。舍利弗。我今语汝。若人百岁成就如是十不善罪。破戒比丘一日一夜受他供养罪多于彼。何以故。是杀生者。多人所知多人所识人所恶贱。人皆知是杀夺命者。罪人秽浊是污染者。不善无德人所离者。又舍利弗。杀生之人多夺他命。或生厌心自知不是当得罪报。人皆知恶无戒秽浊。于此人所不望功德。乃至析毛百分之一。况谓福田而供养之。又舍利弗。是杀生之人其家妻子。人皆知悉不共恭敬。尚不令坐何况供养。杀生之人以财自活养育妻子。或时供养沙门婆罗门。以此业报得遇贤圣。比丘比丘尼为说道法。教离杀生舍其杀业。于佛法中而得出家无有障碍。得出家已近善知识得沙门果。是人现世轻受罪报。不障圣道得免三涂。舍利弗。于我法中有诸比丘。非是沙门自言沙门。非是梵行自言梵行。断诸善根障入涅槃迷惑失道。破道因缘破诸善法。行外道事入于恶道多诸恶贼。空生受命犹如死人。形色毁悴失正威仪。于我法中名为污染。名为法贼。名为逆人。名为魔使。犹如行厕亦如死狗。如像沙门同沙门服无沙门事。舍利弗。譬如野干在师子群。亦如黄门在于转轮圣王众中。亦如猕猴在于诸天。亦复如驴在象王众。亦如盲人在天眼众。亦如蝙蝠在金翅鸟众。舍利弗。破戒比丘在我众中。百千万亿诸天大众。见此比丘在众而坐。皆大忧恼而作是言。如是恶人何用布萨。是魔党类。欲闻无上佛道向白衣说。复有信乐佛法诸龙鬼神等。高声大唤是恶比丘。何故于此隐藏其身。似如恶马在调善马。中如是痴。人自谓无有见知我。恶自藏于此欺诳天。人为是一切天人中。贼众共见已皆更大笑。舍利弗。如是罪恶比丘。为是诸天所知恶贼。白衣无异而受供养。迎送礼拜合掌恭敬。弊人愚痴犹如死尸。所著衣服皆是偷得。钵中所食皆是盗取。无人与者。乃至少水亦是盗得。舍利弗。破戒比丘所至之方。若至东方南西北方。皆是偷地而行。何以故是人所有威仪行法。皆是偷盗假窃所作。行立坐卧来去视瞻。屈申俯仰着衣持钵。今但略说身口意业。有所施作皆是偷贼。若有剃是人发为剃贼发。举要言之。破戒比丘有所施作皆是贼作。舍利弗。弊恶比丘。乃至大小便利澡手皆是贼法。何以故。舍利弗阎浮提内皆是国王及诸大臣。人民所有及属非人。是恶比丘于中为贼。舍利弗。若王大臣。于恶贼所不望功德。不言等我不言胜我。破戒比丘着圣法服于是人所望得功德。是故听使止住国土。若知其恶。乃至唾地亦复不听。是故舍利弗。弊恶比丘。动身所作皆是贼作。名为常贼大贼立幢相贼。打害一切世间人者。何以故。无恶不作故。是故舍利弗。是恶比丘于诸一切天人世间。为是大贼。舍利弗。若人是一切天人世间大贼。是人能消一饮水不。不也世尊。舍利弗。于意云何。是人非是大恶人耶。如是世尊。舍利弗。破戒比丘于诸一切天人世间有大恶罪。以是义故我说此偈

  宁啖烧石　　吞饮洋铜　　不以无戒
  食人信施

舍利弗。是破戒比丘。无色无德无复志愿。身心热毒喜见恶梦不乐独处。或时独处或时独行身则战惧。见净戒者僻藏避回。心怯自愧不喜欲见。受供养时惊疑怖畏。心常驰骋多诸想念。深贪财利爱乐美食。如是比丘。命终之后必入地狱。舍利弗。是名破戒比丘七忧恼箭必入地狱。复次舍利弗。破戒比丘乐在众闹。散乱多语性好嫉妒。与破戒者以为亲友。常乐论说破戒恶事。以为喜乐不知羞耻。违逆深经心疑不信。或时闻说如是等经。疑逆诤竞不乐听受。东西顾望心不专一。以手掩口仰视虚空。从坐而起谤佛法教怀嗔恨心骂说法者。以如是等过恶因缘。命终之后深入地狱。舍利弗。是名破戒比丘八忧恼箭。必堕地狱。复次舍利弗。破戒比丘。但乐尊重和上阿阇梨赞其功德。以求名利称持戒者。因以自活执事便附。随宜善巧无有羞耻犹如黑乌。为僧因缘多求衣服。饮食恣口身力肥盛。不知惭愧言无次第。手脚粗燥颜色毁悴。乐视妇女不附男子。如是恶人众所轻贱。天龙鬼神所不称赞。乃至诸佛亦不叹说心性急促常好嗔恚。众僧断事侠为势力。舍利弗。如是破戒比丘。多于僧中求有威势。未问而答常求他过。见净戒者谓是欺诳。勤求道者不同其法。喜乐别异诤者助喜。舍利弗。是名破戒比丘九忧恼箭必堕地狱

复次舍利弗。破戒比丘。好乐他事任持其理。有斗诤者以为喜乐。衣服严身学他威仪。求好卧具利养安身乐人称赞。护惜檀越及吝住处。恐好比丘来见我过。憎持戒者亲附破戒。常赞布施。不赞持戒忍辱精进禅定智慧不赞寂灭远离独处。常好讥论持戒者过。亦不称赞行头陀者。或指说其事。或恶口横加。或忆想妄说。依怙种姓数问亲族。以少因缘为贪说法。常以曲心而怀惊疑。众所憎恶久而益贱。于持戒者常好讥说。苦切实语者不欲亲近。意不喜闻如是等经好持读诵如是经者。闻说是经心欢喜者亦不喜见。又不喜闻赞持戒法。说是等经不来听受。设来听受不久即还。多与白衣而作知识。常乐论说持戒比丘。以得自在轻行暴恶。舍利弗。是名破戒比丘十忧恼箭必堕恶道。舍利弗。我灭度后如是等人满阎浮提。专行求利以自生活

    佛藏经净法品第六

佛告舍利弗。昔迦叶佛豫记我言。释迦牟尼佛多受供养故。法当疾灭。舍利弗。我法实以多供养故。后当疾灭。舍利弗。譬如贫人得大宝藏心则大乐。如是舍利弗。未来世中多有比丘。亲近白衣受其供养。渐相狎习而与执事。心便欢喜以为悦乐。犹如贫人得大宝藏。如是痴人贵于世利世乐奴仆。若见比丘多人供养。心便谓之得阿罗汉。见少知识便谓恶人。如是比丘。为利养故舍上佛道。随所乐者即成其事。舍利弗。如来于今为是痴人说如是等经。何以故。破戒比丘闻说是经则生悔心当还持戒。不作大贼受他供养。舍利弗。若有比丘得闻是经。心不清净不喜不乐。是则名为弊恶比丘。何以故。舍利弗。净戒比丘无法不乐。若说布施。若说持戒。若说忍辱。若说精进。若说禅定。若说智慧。若说如是厌畏经法心皆喜乐。舍利弗。有三种人。闻说是经心则忧恼。何等为三。一者破戒比丘。二者增上慢人。三者不净说法。复有三种人闻如是经心则忧恼。何等为三。一者人见。二者命见。三者我见。舍利弗。我今明了告汝。如好善知识。以慈愍心为人求利求乐求安隐。汝等一心听受我语。常求善利心勿放逸。舍利弗。不净说法者。有五过失。何等为五。一者自言尽知佛法。二者说佛经时。出诸经中相违过失。三者于诸法中心疑不信。四者自以所知非他经法。五者以利养故为人说法。舍利弗。如是说者。我说此人当堕地狱不至涅槃。复次舍利弗。说法比丘处在大众。信乐法者为敷高座。舍佛正法而说外道严饰文辞。我久勤苦求是法宝。而此恶人舍置不说。但以经中相违语义。互相是非不顺正法。于圣法中高心自大。随意而说为求利养。舍利弗。若比丘说法杂外道义。有善比丘勤求道者。应从坐去。何以故。舍利弗。有信白衣敷置高座。不应演说外道语义。若不去者非善比丘。亦复不名随佛教者。舍利弗。说法甚难。如是说者。我说此人名为外道。尼犍弟子非佛弟子。是说法者命终之后。当生尼犍子道。何等是尼犍子道。邪见是尼犍子道。何等为邪见。谓是地狱畜生饿鬼。何以故。舍利弗。身未证法而在高座。身自不知而教人者。必堕地狱。舍利弗。如是因缘如来悉知。我诸弟子。以种种门种种因缘种种诸见。灭我正法。舍利弗。若有众生。闻如是经第一义空无所有法。心欢喜者。当知是人真我弟子。舍利弗。过去世有五百盲人行于道路。到一大城饥渴乏极。令一盲人在外守物。余者入城乞索饮食。未久之间有一诳人。至守物者所语言。咄人何以独住。答言。我有多伴入城乞食。诳人语言。汝为知不。彼间大施衣食璎珞花香杂物。随意可得。汝若须者将汝诣彼。答言。可尔。诳人将盲小离本处尽夺其物。诸盲乞食得已而还。诳人复语诸盲人言。汝等得值大会施不。答言。不值。诳人语言。汝等所得可置于此。我将汝等诣大施会。诸盲尽共留物一处。随诳人去。诳人尽将五百盲人。临大深坑而语之言。此地平好有大施会。汝等各可回面东行受他施物。即便一时堕坑而死。舍利弗。当来比丘好读外经。当说法时庄校文辞令众欢乐。恶魔尔时助惑众人障碍善法。若有贪着音声语言巧饰文辞。若复有人好读外道经者。魔皆迷惑令心安隐。若有比丘修佛法者令生疑惑。咸使众人不复供养。或有比丘若二若三已读佛经。便使令求外道经法。先自看者赞言善好。是诸人等。为魔所惑覆障慧眼。深贪利养看诸外书。犹如群盲为诳所欺。皆使令堕深坑而死。舍利弗。诸生盲人即是比丘。舍佛无上道求外道经书。诳人是恶魔。深坑是邪道。舍利弗。如群盲人舍所得物。欲诣大施而堕深坑。我诸弟子亦复如是。舍粗衣食而逐大施求好供养。以世利故失大智慧。而堕深坑阿鼻地狱。复次舍利弗。不净说法者。不知如来随宜意趣。自不善解而为人说。是人现世得五过失。余人不知。唯得天眼比丘。及诸天所知。何等为五。一说法时心怀怖畏恐人难我。二内怀忧怖而外为他说。三是凡夫无有真智。四所说不净但有言辞。五言无次第处处抄撮。是故在众心怀恐怖。如是凡夫无有智慧心无决定。但以憍慢微小因缘求于名闻。疑悔在心而为人说。是人长夜自受贪欲嗔恚愚痴毒箭。何以故。舍利弗。是人不能定知诸法。而为他说。心不喜乐若乐速失。舍利弗。我知不净说法有此过咎不得正道。是事一切比丘不知。诸天不知。唯我乃知。复有不净说法。比丘不解如来随宜所说。而为他人说。诸经中无我无人无众生无寿命。而是人自以论辞说言。有我有人有众生有寿命。即为谤佛谤法谤僧。谤三宝罪诸天世人所不能知。唯佛乃知。舍利弗。是人亦名不净说法。我知其过。诸神通者及诸天众皆不能知。唯佛乃知。舍利弗。我今为汝譬喻解说。若人不知佛道义相。而为他人不净说法。此人成就几不善事。舍利弗。于意云何。阎浮提众生宁为多不。甚多世尊。舍利弗。若有恶人尽夺其命。是人得罪宁为多不。甚多世尊。如是痴人不知佛道。而为他人不净说法。罪多于此。何以故。是人不净说法破无上佛道。亦谤过去未来今佛。何以故。舍利弗。若有过去诸佛。说一切法皆毕竟空。无我无人无众生无寿者无命者。舍利弗。未来诸佛说一切法亦毕竟空。无我无人无众生无寿者无命者。舍利弗。今现在十方恒河沙世界诸佛。说一切法亦毕竟空。无我无人无众生无寿者无命者。舍利弗。是名诸佛无上之法。谓一切法无有体性无所得空。本性寂灭无生无灭。无有性相自相皆空。如来但为断诸忆想分别故说。而诸佛菩提无有分别。舍利弗。何等为分别。谓分别者。我见人见众生见寿见命见断见常见。凡夫成就是诸分别。若人无有如是分别。能悉了知一切法空。无我无人无众生无寿者无命者。如是念时心得欢喜。闻第一义空不惊不畏。是人则知五阴虚妄无有真实。知十二入十八界虚妄无有真实。是人亦不分别涅槃不念涅槃。不言我能念涅槃。以法得寂灭而不分别。是法所寂灭处。亦不分别亦复不得。舍利弗。是名顺忍。是人于是顺忍第一义中。亦不得自相。舍利弗。何等是顺忍相。所谓无相是顺忍相。舍利弗。于意云何。若人于此顺忍尚不得相。是人若得我相人相众生相寿相命相者。无有是处。若人成就如是智慧。应受供养是名佛子。是名入不住定。舍利弗。是名佛法第一义门。谓无忆想分别无此无彼。而是痴人在大众中说于邪见。自以忆想分别教人。此是佛法此是圣道。如是痴人。则为诽谤过去未来现在诸佛。如是痴人。名恶知识不名善知识。舍利弗。怨虽夺命但失一身。如是痴人不净说法。千万亿劫为诸众生作大衰恼。是人痴冥覆佛菩提本心。贪着还复炽盛相续不断。以贪着故往来五道。无善迳路生死不断。是故舍利弗。不净说法者得罪极多。亦为众生作恶知识。亦谤过去未来今佛。舍利弗。置此阎浮提众生。若人悉夺三千大千世界众生命。不净说法罪多于此。何以故。是人皆破诸佛阿耨多罗三藐三菩提为助魔事。亦使众生于百千万世受诸衰恼。但能作缚不能令解。当知是人于诸众生为恶知识。为是妄语于大众中谤毁诸佛。以是因缘堕大地狱。教多众生以邪见事。是故名为恶邪见者。舍利弗。我见人见众生见者多堕邪见。断灭见者多疾得道。何以故。是易舍故。是故当知。是人宁自以利刀割舌。不应众中不净说法

    佛藏经往古品第七

佛告舍利弗过去久远无量无边不可思议阿僧祇劫。尔时有佛号大庄严如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛寿命六十八百万亿岁。有六十八百万亿大弟子众。其佛灭后舍利流布。如我灭后无有异也。正法住世亦五百岁。如我灭后无有异也。其佛灭后大弟子众。于中一日有百比丘入涅槃者。二百三百四百五百入涅槃者。一日之中或有十万亿比丘入涅槃者。如是展转。其佛所有多知多识大神通众。三月之中皆入涅槃。舍利弗。大庄严佛正法流布。多诸天人所共供养。舍利弗。大庄严佛及大弟子灭度之后。渐多有人知沙门法安隐快乐出家学道而不能知佛所演说甚深诸经无等空义。多为恶魔之所迷惑。时说法者心不决定说不清净。说有我人众生寿命。不说一切诸法空寂。其佛灭度百岁之后。诸弟子众分为五部。一名普事。二名苦岸。三名萨和多。四名将去。五名跋难陀。舍利弗。此普事比丘。苦岸比丘。萨和多比丘。将去比丘。跋难陀比丘。是五比丘为大众师。其普事者知佛所说真实空义无所得法。余四比丘皆随邪道。多说有我多说有人。舍利弗。普事比丘。为四部所轻无有势力多人恶贱。四恶比丘多教人众以邪见道。于佛法中不相恭敬。相违逆故以灭佛法。舍利弗。若有人知普事比丘所说空法信受不逆。我知此人曾于先世供养五千佛。有六十八亿那由他人已入涅槃。何以故。舍利弗。此人于过去世诸佛所种诸善根。修习无所得空法应入涅槃。舍利弗。是苦岸比丘。一切有比丘。将去比丘。跋难陀比丘。皆计有所得。说有我人众生寿命徒众炽盛。是四恶人多令在家出家住于邪见。舍第一义无所有毕竟空法。贪乐外道尼揵子论。舍利弗。是四恶人。所有在家出家弟子。常相随逐乃至法尽。舍利弗。是中有人知非法事。受以为法勤心行之。犹尚不得顺忍。况得须陀洹果。是人犹尚不作消供养事。何况能生顺忍。舍利弗。尔时在家出家弟子。多堕恶道不至善道。是诸恶人灭佛正法。亦与多人大衰恼事。又是恶人命终之后。堕阿鼻地狱。仰卧九百万亿岁。伏卧九百万亿岁。左胁卧九百万亿岁。右胁卧九百万亿岁于热铁上烧然燋烂是中退死更生。炙地狱大炙地狱。活地狱黑绳地狱。皆如上岁数受诸苦恼。于黑绳地狱死还生阿鼻大地狱中。舍利弗。以是因缘若在家出家亲近此人。及善知识并诸檀越。凡有六百四万亿人。与此四师俱生俱死。在大地狱受诸烧煮。如是舍利弗。是人所有善知识家。诸檀越家。弟子诸师随顺行者。凡在其数皆生地狱。舍利弗。汝等不能知其多少。唯有如来乃能知之。与此恶人堕大地狱俱生俱死。凡有六百四万亿人。如是展转一劫受苦。大劫将烧故在地狱。何以故。舍利弗。破诸如来阿耨多罗三藐三菩提。其罪甚重不为轻也。大劫若烧。是四恶人及六百四万亿人从此阿鼻大地狱中。转生他方在大地狱。何以故。舍利弗。重罪具足其报不少。在于他方无数百千万亿那由他岁受大苦恼。世界还生。是四罪人及六百四万亿人。并及余人罪未毕者。于彼命终还生此间大地狱中。舍利弗。是四罪人及六百四万亿众生。久久虽免地狱苦恼得生人中。于五百世从生而盲。然后得值一切明佛如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。舍利弗。一切明佛声闻弟子一亿那由他。尔时人民身长三百九十六肘。佛身一倍常光圆照十万亿由旬。舍利弗。是人于一切明佛法中出家。十万亿岁勤行精进。如救头然不得顺忍。况得道果。何以故。舍利弗。起破阿耨多罗三藐三菩提罪业因缘法应当尔。命终之后还生阿鼻大地狱中。以先起重不善业因缘。舍利弗。是诸人等如是展转。乃至我今于其中间。得值九十九亿佛。于诸佛所不得顺忍。何以故。佛说深经是人不信。破坏违逆谤毁贤圣持戒比丘。出其过恶起破法业因缘。法应当尔。舍利弗。汝且观之。诽谤圣人不信圣语。受是无量无边苦恼不得解脱。舍利弗。有诸众生起破法罪业违逆不信者。其数无量。于九十九亿佛所阿僧祇劫乃无一人入涅槃者。舍利弗。谁能破诸佛教不信违逆。但凡夫愚痴及增上慢诸恶比丘。并诸不净说法比丘。何以故。舍利弗。是三种人不名行者不名得者。是人不信如来法故。毁谤违逆。舍利弗。若汝谓何者是苦岸比丘不净说法者。即调达痴人是。汝谓何者是一切有比丘不净说法者。即拘迦离比丘是。舍利弗。汝谓何者是将去比丘不净说法者。即迦罗比丘是。汝谓何者是跋难陀比丘不净说法者。即裸形沙门。波利摩陀是。舍利弗。汝谓尔时清净如实说诸佛菩提。利益无量众生者。即是富楼那弥多罗尼子所说清净。诸随学者得值五千佛。有六十八亿那由他人。皆已灭度。舍利弗。若人实语何者为是。最上法师决了法义清净说者。当说富楼那是。舍利弗。富楼那。定心决了所说无难。无有所疑而生论议。舍利弗。若人实说何者是一切因缘法师。当说富楼那是。舍利弗。富楼那世世所生。常为众生而作佛事。于九十亿诸佛法中。常作法师清净说法。皆于诸佛所尽其形寿。常修梵行清净说法。舍利弗。富楼那亦于六佛法中而作法师。亦于我法作大法师。成阿罗汉心得解脱。若人实说何人世世供养诸佛种诸善根。当说富楼那是。舍利弗。富楼那于九十亿诸佛法中。勤心求学决定议论。有深智慧。是故如来于诸法师说为第一。舍利弗。若我一日一夜称说富楼那功德不尽。若过一日一夜亦复不尽。何以故。富楼那法施无俗因缘不贪利养。富楼那法师得四无碍智。唯除如来。诸世间中言辞义理无能胜者。舍利弗。我今告汝。若人欲得阿耨多罗三藐三菩提为人说法。则得无量无边福德。亦能利益无量众生。舍利弗。若人破坏违逆不信是法者。则起无量重罪因缘。何以故。舍利弗。恶有恶报善有善报。我以此故。今以是经嘱累于汝。当为四众广说分别。舍利弗。若闻是经心信欢喜。即得无量无边福德。若闻不信心不喜乐。即得无量无边重罪。舍利弗。当知是人名为破戒比丘。若增上慢不净说法者。舍利弗。若人违逆如是教者。世世所生常盲无目。舍利弗。我今明了告汝。我今所说非如陶师爱护坏器。我今分明广为四众。说第一义毕竟空法。坚固者在。不坚固者破。何以故。舍利弗。佛得阿耨多罗三藐三菩提不为邪见恶人说法。不为我见人见众生见寿命见者说法。何以故。是诸贪着皆名邪见。舍利弗。如是我见人见不得顺忍。况得道果。舍利弗。若我见人见众生见寿命见断见常见者。能得顺忍。能得道果。无有是处。是故舍利弗。若人成就如是见者。于我法中我则不听受诸供养。是非行者。亦非得者。但于我法求自活命。舍利弗。我说外道欲入佛法。应试四月。何以故。诸外道人。多有我见人见众生见寿命见断见常见。舍利弗。我诸弟子。无有我见人见众生见寿命见断见常见。我诸弟子。但说空无相无愿无所得忍。说识无所住。舍利弗。若有成就如是忍者。我听是人出家受戒。得受供养衣服饮食卧具医药。若人无是忍者。应先试之。先教令住诸法无我。舍利弗。若于此忍心不欢喜。闻说第一义空惊疑讥诃。闻说我见心则欢喜。当知是人为魔所使。若先外道。舍利弗。智者于此不应生忧。但于此人应生悲心。何以故。舍利弗。若人成就如是恶者。所获恶报说不可尽。当于此人生利益心。教以诸法无我。诸法空寂。诸法无作。无有受者。是人若爱佛法。得闻是事心喜乐者。其余空行比丘无所得者。皆应示教利喜安慰其心。为说诸法无所有空。若闻惊畏应于众中语其和上阿阇梨。如经中说行空行者。又能了知诸法别相我与为师。不与我见人见颠倒邪见贪着持戒者为师。如来听许具正见者而共布萨。不听破戒邪见之人破威仪者而共布萨。长老弟子闻说空寂无所有法。心不信乐志在外道。佛不听与外道布萨。是人若当不舍是见。不应听使得入僧事。亦不受其欲。如是作已犹故不舍。当知是人不得在道便是永弃。应语其和上阿阇梨。不应复畜。舍利弗。若僧如是则供养我。亦为善破外道邪见。是名清净说戒布萨。舍利弗。我今明了告汝。若人受是我见人见众生见有无见。是人不名供养于我。不名随我出家受戒。是名随逐六师出家。以六师为师。舍利弗。若人于是清净。实法不能得忍。而受供养。是人所得则为邪受。舍利弗。是人虽于我法中出家护持净戒。而于第一义空无所得法。心不信解惊怖疑悔。当知是人但贵持戒多闻禅定。舍利弗。是人不名供养恭敬尊重于我。何以故。舍利弗。无始世来无有众生不得四禅。若但知得四禅。谓为沙门利者。是人何名供养于我。是故舍利弗。我今明了告汝。当来世人。于我法中种种贪着。种种邪见毁坏我法。舍利弗。若人但贵持戒多闻禅定。当知是人不能净行沙门诸法。我则不说此人名为沙门婆罗门。舍利弗。若人于一切法无我。如实知无我。一切法本来无所有空。能如实知无所有空。是则不以持戒为上多闻为上禅定为上。何以故。舍利弗。诸法实相无生无起。于中无法可为上者。舍利弗。是诸法如实中。无持戒者无破戒者。何况贪着而以为上。舍利弗。是名诸佛阿耨多罗三藐三菩提。谓一切法无相自相空。无我无人。若有是忍。是名行者。是名得者。是人名为以信出家。应受供养清净布萨。是人则为人中之天。舍利弗。诸佛阿耨多罗三藐三菩提唯是一义。所谓离也。何等为离。离诸欲诸见。欲者即是无明。见者即是忆念。何以故。一切诸法忆念为本。所有念想。即为是见见即是邪。舍利弗。善法中见。我亦说之名为邪见。何以故。舍利弗。离欲寂灭中无法无非法。无善无恶。是事皆空。远离诸结一切忆念。是故名离。舍利弗。无上道中诸欲永息。何等诸欲。谓邪不善念。若我若我所。作相事相。是名阿耨多罗三藐三菩提中诸欲永息

佛藏经卷中佛藏经卷下

        姚秦龟兹三藏鸠摩罗什译

    净见品第八

佛告舍利弗。我念过世求阿耨多罗三藐三菩提。值三十亿佛。皆号释迦牟尼。我时皆作转轮圣王尽形供养。及诸弟子衣服饮食卧具医药。为求阿耨多罗三藐三菩提。而是诸佛不记我言。汝于来世当得作佛。何以故。以我有所得故。舍利弗。我念过世得值八千佛。皆号定光。我时皆作转轮圣王尽形供养。及诸弟子衣服饮食卧具医药。为求阿耨多罗三藐三菩提。而是诸佛皆不记我。汝于来世当得作佛。何以故。以我有所得故。舍利弗。我念过世值六万佛。皆号光明。我时皆作转轮圣王尽形供养。及诸弟子衣服饮食卧具医药。为求阿耨多罗三藐三菩提。而是诸佛亦不记我。汝于来世当得作佛。何以故。以我有所得故。舍利弗。我念过世值三亿佛。皆号弗沙。我时皆作转轮圣王四事供养。皆不记我。以有所得故。舍利弗。我念过世得值万八千佛。皆号山王。劫名上八。我皆于此万八千佛所剃发着法衣。修习阿耨多罗三藐三菩提。皆不记我。以有所得故。舍利弗。我念过世得值五百佛。皆号华上。我时皆作转轮圣王。悉以一切供养诸佛及诸弟子。皆不记我。以有所得故。舍利弗。我念过世得值五百佛。皆号威德。我悉供养皆不记我。以有所得故。舍利弗。我念过世得值二千佛。皆号憍陈如。我时皆作转轮圣王。悉以一切供具供养诸佛。皆不记我。以有所得故。舍利弗。我念过世值九千佛。皆号迦叶。我以四事供养诸佛及弟子众。皆不记我。以有所得故。舍利弗。我念过去于万劫中无有佛出。尔时初五百劫。有九万辟支佛。我尽形寿。悉皆供养衣服饮食卧具医药。尊重赞叹。次五百劫。复以四事供养八万四千亿诸辟支佛。尊重赞叹。舍利弗。过是千劫已无复辟支佛。我时阎浮提死。生梵世中作大梵王。如是展转五百劫中。常生梵世作大梵王。不生阎浮提。过是五百劫已。下生阎浮提。治化阎浮提。命终生四天王天。于中命终生忉利天。作释提桓因。如是展转满五百劫。生阎浮提满五百劫。生于梵世作大梵王。舍利弗。我于九千劫中。但一生阎浮提。九千劫中但生天上。劫尽烧时生光音天。世界成已还生梵世。九千劫中都不生人中。舍利弗。是九千劫无有诸佛辟支佛。多诸众生堕在恶道。舍利弗。是万劫过已。有佛出世。号曰普守如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。我于尔时梵世命终。生阎浮提作转轮圣王。号曰共天。人寿九万岁。我尽形寿以一切乐具。供养彼佛及九十亿比丘。于九万岁为求阿耨多罗三藐三菩提。是普守佛亦不说我。汝于来世当得作佛。何以故。我于尔时不能通达诸法实相。贪着计我有所得见。舍利弗。于是劫中有百佛出名号各异。我时皆作转轮圣王。尽形供养及诸弟子。为求阿耨多罗三藐三菩提。而是诸佛亦不记我。汝于来世当得作佛。以有所得故。舍利弗。我念过世第七百阿僧祇劫中。得值千佛。皆号阎浮檀。我尽形寿四事供养。亦无记我。以有所得故。舍利弗。我念过世。亦于第七百阿僧祇劫中。得值六百二十万诸佛。皆号见一切义。我时皆作转轮圣王。以一切乐具尽形供养及诸弟子。亦不记我。以有所得故。舍利弗。我念过世亦于第七百阿僧祇劫中。得值八十四佛。皆号帝相。我时皆作转轮圣王。以一切乐具尽形供养及诸弟子。亦不记我。以有所得故。舍利弗。我念过世亦于第七百阿僧祇劫中。得值六十五佛。皆号日明。我时皆作转轮圣王。以一切乐具尽形供养及诸弟子。亦不记我。以有所得故。舍利弗。我念过世亦于第七百阿僧祇劫中。得值六十二佛。皆号善寂。我时皆作转轮圣王。以一切乐具尽形供养。亦不记我。以有所得故。如是展转乃至见定光佛乃得无生忍。即记我言。汝于来世过阿僧祇劫。当得作佛号释迦牟尼如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。舍利弗。我念过世有十二亿转轮圣王。皆字顶生。又舍利弗。过世有三十亿转轮圣王。皆名摩诃那摩陀那。舍利弗。我念过世四十亿转轮圣王。皆字摩诃提婆。舍利弗。我念过世有一亿转轮圣王。皆字亿螺(律妫反)。舍利弗。我念过世有一亿转轮圣王。皆字称尾(觅视反)。舍利弗。我念过世有一万转轮圣王。皆字照明。舍利弗。我念过世有二万转轮圣王名字各异。舍利弗。我念过世有十六亿转轮圣王名字各异。是诸王等。我于余处为阿难说。舍利弗。于意云何。汝谓是诸王者。岂异人乎。即我身是。舍利弗。我念过去时世。有佛号曰善明。弥勒菩萨时作转轮圣王。字曰照明。初发阿耨多罗三藐三菩提心。于时众生寿八万四千岁。其善明佛三会说法。初会九十六亿人一时得道。第二大会九十四亿人一时得道。第三大会九十二亿人一时得道。时王见佛三会说法度人无量。心大欢喜。即于万岁一切供养佛及弟子。发心求阿耨多罗三藐三菩提。于未来世众生易度。我当成佛寿命限量。比丘僧数围绕如是。舍利弗。我知是事过此无量。舍利弗。弥勒发心四十劫已。我乃发心无胜佛所初种善根。我于千岁一切乐具供养是佛。五百张叠而以奉上。是佛灭后起七宝塔。高一由旬。纵广半由旬。皆以金银琉璃颇梨车磲马瑙赤真珠所成。心常发愿。众生苦恼无救度者。遭值恶法多堕恶趣。我于尔时当成佛道。舍利弗。汝且观之。阿耨多罗三藐三菩提甚难修习。舍利弗。我修习阿耨多罗三藐三菩提。无央数世受诸苦恼。我若说者汝闻愁闷。我诸所受勤苦忧恼。皆为求得阿耨多罗三藐三菩提。舍利弗。汝观萨和檀菩萨。求善法菩萨。常悲菩萨。不放逸菩萨。常精进菩萨。供养若干诸佛受诸苦恼。犹尚难得阿耨多罗三藐三菩提。何况是诸痴人。乃无一念为求涅槃。舍利弗。如是行者犹尚甚难。况不行者。是故舍利弗。我今明了告汝。以下法者不得上法。用上法者乃得上法。何等下法。谓身恶业口恶业意恶业。下法名为不能勤心修习善法。下法名为懈怠懒堕破所受戒。舍利弗。是名下中下者。又下中下者。于我法中出家。生有所得见我见人见众生见。何以故。舍利弗。如来于此了了现知。有所得者。乃无顺忍。况得道果。舍利弗。若有所得者。百千万亿诸佛以三轮示现是人。若当不舍是见。尚不消人一口饮食。况得道果。舍利弗。我见人见得涅槃者。一切凡夫皆应灭度。何以故。我见人见皆是邪见。诸凡夫人。多贪着我我所见人见众生见。是故一切凡夫应得涅槃。舍利弗。若人作念有我有人。是人若当不舍是见得入涅槃。一切凡夫应得圣道。何以故。一切凡夫皆是我见人见。是故我见人见入涅槃者。一切凡夫皆入圣道。于圣道中则无所少。舍利弗。若人作念有我见者则有涅槃。是人得是圣道不须余念。何以故。一切凡夫我见人见无所少故。如是痴人有是过失。谓诸凡夫皆入圣道。圣道无系。是人修时应当杀生。受诸五欲起五逆罪。是故痴人于圣道中有五逆罪。何以故。一切凡夫皆说有我有众生故。若人作如是言。成就五逆罪者不入涅槃。说我人者得入涅槃。即是妄语亦是谤佛。于我法中又不能得清净出家。舍利弗。我今明了告汝。有所得者无有涅槃。有所得者若有涅槃。是则诸佛不出于世。一切凡夫皆入涅槃。何以故。一切凡夫皆有我见人见。皆有所得皆是邪见。舍利弗。汝且观我。几时成就有所得见非贤圣行。诸佛不与我授记言。汝于来世当得作佛。舍利弗。我如是行。犹不得记。况是痴人但以持戒多闻禅定等。生我见人见众生见。舍利弗。我说此人不名行者不名得者。何以故。舍利弗。长夜贪着如是邪见不得灭度故。如是痴人不作是念。我等何不试行修习无我人法。我等或得断众苦聚。舍利弗。譬如从生盲人走避恶狗堕深火坑。舍利弗。我谓痴人。如是修习我见人见有所得见。以是诸见欲望清净。是人随所贪着。即以是事欲得涅槃。我说是人当堕恶道。舍利弗。譬如盲人于深火坑生安隐心。如是痴人于我人见有所得见生安隐心。是人长夜随所著者。为之欺诳还着是事。于我法中而受供养。如是痴人长夜衰恼堕恶道中。舍利弗。譬如大灌顶王。自于所治国中威势自在。是人应夺是人应驱。若诸民众不顺王意。说王过恶沮坏人心。不能护城谋欲反叛。王知是人为是大贼。于大众中打恶声鼓。苦治其罪驱摈令出。以其不能尽忠护城。得是苦恼。舍利弗。佛亦如是。于无量劫修习阿耨多罗三藐三菩提为大法王。于法国土有大威力。诸弟子中有知法味。乃至失命不毁我教。诸天世人无能坏者。所受教中自不恶逆亦不教他。我于众中有大威力。自在立教为护法城。不使恶贼毁坏得入。窃受如来所说密法。向诸怨贼邪见者说

舍利弗。如来现在善护法城。四大弟子智慧深远。今我法城不惧破坏。若与法城作障碍者。为是大贼毁坏法城。盗我密法向外道说。是人常来至于我所。我与共语示其教法不说密要。是人为求所示教法出家受戒。我知此人后应得道。听使出家四月中试。何以故。为护法城故。又使未来世贼不更起故。如是如来善护法城使不得便。所谓令受佛教舍本恶邪。诸比丘众皆应欢喜。听使出家得受戒已。天人世间不能动转。舍利弗。何等是可试者。谓外道人及乐外道法者。舍利弗。何等是乐外道法。所谓有所得者。我见者人见者。众生见者贪者邪者。于自相空法心生疑者。受行种种邪虚妄法。不能入于第一义空。行诸邪道。是人名为乐外道法。舍利弗。不可试以种种色衣。若白衣人若着袈裟。有如是不善有所得见。皆名外道。于我法中出家受戒是人应试。何以故。有所得者。于我法中即是邪见。是名大贼。一切世间天人中贼。是名一切世间怨家诸佛大贼。舍利弗。是邪见人。我则不听出家受戒。舍利弗。一切法无我。若人于中不能生忍。一切法空无我无人无众生无寿命不能信解。于我法中所受供养。名为不净。是人则是不供养佛。不供养法。不供养僧。强入我法。形是沙门。心是外道。为盗法人。舍利弗。于未来世当有比丘不修身不修戒不修心不修慧。是人轻笑如来所说如来所行。如来常于第一义空。恭敬供养常乐是行。是诸比丘。轻笑如来所行真际毕竟空法。舍利弗。尔时若有苦行比丘。亦共轻笑。今我弟子有行空者。我赞其善安慰其心。尔时是人轻蔑空行但求不坚牢事。以有我及有诸法如是等事令众心喜。若说一切诸法空者亦轻是人。何以故。舍利弗。法应尔也。众生善根欲断本相。则现真实妙法。在于世间无有受者。譬如痴人以栴檀香同于猥木。舍利弗。迦叶佛说。未来世中释迦牟尼佛诸弟子众。以利养故。为诸白衣说第一义空。尔时多有在家出家。愚痴不受违逆不信。而反诽谤失于大利。以是因缘当堕恶道。舍利弗。尔时多有相违诤论。我论人论众生论寿者论命者论善法欲少但乐利养。实是愚痴自谓有智。互相违逆常共诤讼。乐有断事生怨嫉心。是人舍沙门法但求利养。多乐事务所营非一。常乐伺求他人长短。自隐其过称说功德。如今比丘覆藏功德自出过恶。当尔之时。咸共不能护持重戒无所晓故。破于仪则而言。诸法空自相空何所能作。如那罗戏人种种变现。无所知者见之大笑。何以故。不知戏法其术隐故。生希有心惊怪大笑。如是舍利弗。尔时真实比丘说空寂法。求活命者咸共嗤笑。何以故。是人不知佛法义故。闻说空法惊疑怖畏。舍利弗。汝观此人。于安隐处生衰恼心。于衰恼处生安隐心。是人颠倒逆行善法顺行恶法。舍利弗。如是痴人。多怀悭贪嗔恚愚痴。具行三不善根。舍利弗。我为利益持戒比丘故。说二百五十戒经。如是痴人。乃以世间小因缘故。向在家者说。乃至书写以示白衣。舍利弗。如是痴人说言。诸法空自相空。何所能作。何以故。如是痴人。尚不能除悭贪烦恼。何况能断无明。舍利弗。尔时持律比丘不能善学。诸说法者亦不善学。读诵修妒路者亦不善学。舍利弗。云何名为持律比丘。不能善学如来经中说有三学。善戒学。善心学。善慧学。是人于三学中不能善学。但以多闻因缘轻慢他人。是人则为障碍善法。如是痴人。犹尚不能如法答问。况于毕竟空无所有中能发精进。舍利弗。尔时破戒比丘。乐为白衣执事。宣通使命疗治病法。以自生活。舍利弗。汝今观此恶人。于我法中出家受戒得受供养。而反以我为怨。舍利弗。尔时四天王释提桓因大梵天王。乃至百千万亿诸天。见我法中如是毁坏。皆大忧愁啼泣涕零。舍利弗。是实不应依止于我。而为白衣营执事务。何以故。释迦牟尼佛弟子。乃至诸天龙神。犹尚不应为作给使。诸天龙神于我弟子与作给使。如是痴人所亲近白衣。若能修习通达诸法第一义空。无有是处。舍利弗。尔时破戒比丘。乃至为得一杯酒故。与诸白衣演说佛法。于意云何。多贪恚痴多乐读经。贪外经利行不清净。是人能得信解无所有毕竟空法。能得具足沙门果不。不也世尊。舍利弗。若有比丘趣得衣服饮食卧具医药。持戒清净不乐众闹散乱言语。不贪外义昼夜精勤如救头然。一心勤行八直圣道。是人于空无所得法尚难通达。况是痴人。无有深欲无有信解。舍利弗。汝观是人。不知如来无上义故破我正法。自为己身及为他人作大衰恼。如是大贼世间怨家。此经中说应当远离。是人于佛尚不知恩。自念我等所为出家。于此法中不应行处则不应行。是故舍利弗。如来欲使未来世中止此恶故说如是经。若有比丘破所受戒。毁破威仪及破正见。得闻是经怖畏反戒。何以故。破戒之人。不应于弹指顷住圣人相在袈裟中。若闻是经心欢喜者。是人名为供养诸佛守护佛道。何以故。舍利弗。是名佛道真际。若善男子善女人欲得沙门法者。为听是经应过百千万亿由旬。何以故。诸佛如来久乃出世。虽出于世时乃说之

    佛藏经了戒品第九

佛告舍利弗。有三种人。闻说是经心不喜乐。何等三。一者破戒比丘。二者增上慢人。三者不净说法及贪着我者。是人远离于此随顺实相深经。具足充满生盲部党。是故舍利弗。我以是经重嘱累汝。所以者何。是经于如来灭后。能令清净持戒比丘心生喜乐。如是深经。清净戒者常所摄持。毁破戒者常所远离。所以者何。痴人闻说真实正语。则以为苦。舍利弗。破戒比丘所成相貌。如来于此已具广说。舍利弗。破戒比丘法。应不乐持戒律仪。愚痴之人不喜智慧。悭人不欲闻说布施。增上慢者。不欲闻此无憍慢法。若闻惊畏如堕深坑。好世利者贪着美味。闻诃訾食心则忧恼。若人好读外经书者。则于其中生坚实想。贪着语者乐说散乱。乐严饰辞巧美说者。于佛第一义则无净心。又于此法不敬不信。舍利弗。譬如不男之人无男子用。至男子中生不男想。而作是念。是诸人等如我无异。如是好着外经书者。常乐严饰巧美文辞。于佛第一义心不恭敬。舍利弗。其中有人说清净经。于此人所亦不恭敬。轻慢清净持戒比丘。何以故。舍利弗。外道经书无真实语。法应憍慢贡高自大。何以故。是事不为厌离。不为寂灭。不为得道。不为涅槃。是人毁坏信等善根故。于一切处不信有功德。如不男人于诸人中皆谓如己。舍利弗。如生盲人不见诸色。所谓黑色白色。不见黑白色者。不见好色不见丑色。不见青黄赤白红紫缥色。不见长短粗细深浅等色。不见日月星宿。不见日月星宿者。如是盲人便作是念。无黑白色。无见黑白色者。无好丑色。无青黄紫缥。长短粗细深浅。日月星宿色。无见日月星宿者。余人皆亦如是。盲人心倒。于一切处皆谓黑闇。舍利弗。破戒比丘。增上慢人。堕外道论比丘。亦复如是。于深佛法心不信乐不能通达。闻诸法空无所有。不信不乐不能通达。舍利弗。如是诸人。畏于汝等入邪际中不得正法。以是正法名为真实沙门。汝所得法是人不信。犹如盲人谓无白黑等色。舍利弗。是人如是入于邪际。求外道论乐众闹语。增长烦恼恶性恶法。是人不能信诸法空。何况通达。舍利弗。于意云何。野干作师子。为能已吼今吼当吼。作师子行今行当行已行不。不也世尊。何以故。野干色力音声不及师子。野干但能作野干声。若欲作声。但有野干声出。非师子声。如是舍利弗。破戒比丘。增上慢比丘。自以此事为上。不净说法者受尼犍子论。若执一事坚持不舍。贪贵世利乐读经书。不能通达诸法实相。若能信受无相法者。无有是处。舍利弗。若有比丘耆年有德。比丘中龙有深智慧。是人能信无所有自相空法。无我无人法。何以故。是人不乐众闹杂语。不乐读经睡眠多事。不为白衣营执事务。不为使命持送文书。不行医术。不读医方。不为贩卖。不乐论说世间语言。但乐欲说出世间语。是人能信一切法空。于一切法不起不坏。是人则能证真实际。则能如实正师子吼。非野干吼。舍利弗。若有比丘着外经义。是人为舍微妙佛法。诵持外道语言为大众说。但作野干吼。舍利弗。如是恶人名为朽坏沙门。何以故。是外道义非佛法故。舍利弗。着外道法比丘。不应自称是佛弟子。何以故。沙门释子不说尼犍子语。于大众中但说佛语。舍利弗。若人着不净语。欲作师子吼。但作野干鸣。是人不能解佛法第一义。舍利弗。我今明了告汝。若人具足持戒禅定智慧。不悭不贪不染恚痴。不怀谄曲有厌恶心。言必真实。常乐独处不乐睡眠。乐空无相无愿无生无灭行。生离欲心求解佛法第一义。不好世语乐出世语尽持诸戒。一切恶事及恶知识悉皆远离。住如是法则能解空无所有法。何以故。舍利弗。是行名为大人所行。非是贪乐利养所行。非是愚痴常人所行。非是败坏沙门所行。非是糟糠沙门所行。非是假名沙门所行。舍利弗。诸法实相毕竟空寂。即是佛道。好世财利贪说不净法者。所不能及。舍利弗。是地名为大智者地。非是贪乐外道者地。非说我见人见者地。舍利弗。若实有我有人者。说我人者。应有实相。如实应问。若有我者。为是何色。青黄赤白。为在身中。为在身外。为遍在身如油在麻。舍利弗。麻中有油可出可示。若我在内说有我者。应说应示。如从麻中出油示油。第一义中求我不可得。是故当知。若说有我人者。是人犹尚无沙门戒。况沙门地。舍利弗。当知如是邪贪著者。所谓着我着众生着寿命者。则为堕顶。是人如是邪贪着故。尚不能除贪利养心。况细烦恼。舍利弗。通达空者。若为贪欲嗔恚愚痴利养所覆。无有是处。亦不堕顶。舍利弗。计我心者谓有寿命。寿命因缘故。则为利养所牵障碍于道。舍利弗。我见者人见者。虽于我法出家为道。如是痴人于清净中则非出家。何以故。尼犍子出家。皆计我心有所得故。舍利弗。有所得者。从无始世常有此见。若得出家犹有不绝。是名因外道出家。不名因圣法出家。何以故。弊人不能信乐大法。于清净大法无真实想。舍利弗。如是破法重罪因缘余殃未尽。不能信解诸法实相。起不善业。或谤八直圣道。或于净戒比丘而生恶心。妄出其过。或言破戒破见破命破威仪。或不见他过妄生是非。或以浊恚嫉心说他恶名。或不能知佛经义理。谓非佛法。如是恶人成就破法恶业。于佛第一义中。心不通达不入不喜。如是重罪余报因缘。虽勤精进。犹尚不能取所缘相。何况系心能得道果。又深依止我见人见。如是见者。乃至诸佛。犹亦不能拔其根本。何况声闻。舍利弗。若人有如是贪着不善邪见。谓我见人见众生见寿者见命者见。又于第一义空惊疑畏者。当知是人先世成就破法罪缘。舍利弗。若人如是贪着恶邪不善。谓贪我贪人贪寿命者。是人百千亿诸佛以三轮示现。不能令悟使得道果。舍利弗。宁以利刀割舌。不应不见他事妄说其过。破戒破见破命破威仪。舍利弗。于未来世。当有比丘善护二百五十戒。是人我慢心生而作是念。我是持戒余人不尔。轻于他人心无恭敬。我是多闻彼非多闻。舍利弗。尔时多有比丘。但贵持戒多行阿兰若行。能善护戒品随所说行。勤心读经求通佛法。如是人等。生多闻慢阿练若慢。而好嗔恚心常垢浊。深怀悭贪嗔恚毒心顽钝无知。以小因缘而起大事。是人嗔恚覆心互相出过。谓破戒破见破命破威仪。舍利弗。如是僧中有好比丘。心无偏党处在中间。而亦同之在彼恶中。互相讥论诤讼不息。不得安隐坐禅读经。在家出家皆亦娆动。如是舍利弗。尔时多有比丘。一岁二岁三岁乃至九岁。轻慢上座无有恭敬。是人出家受戒多不如法。习效和上阿阇梨亦无恭敬。舍利弗。尔时年少比丘及先出家无有依止。共相轻慢十岁比丘所畜徒众。其诸徒众皆无恭敬威仪法则。亦不如法。舍利弗。时诸恶人。具足贪欲嗔恚愚痴。互相轻慢无有恭敬。相违逆故我法则灭。舍利弗。时诸痴人多起破法罪业。起此罪已当堕恶道。舍利弗。我今明了告汝。求自利己善比丘。当尔之时不应入众。乃至一宿。唯除阿罗汉烦恼已断。及病比丘于中有缘。何以故。舍利弗。当尔时人贪欲嗔恚愚痴毒盛。不活怖畏常所逼切。求利善人常应自处山林空静。乃至毕命如野兽死。舍利弗。我今明了告汝。我此真法不久住世。何以故。众生福德善根已尽浊世在近。求自利善比丘。应生如是厌心。我当云何见法破乱。见此沙门恶世难时。我当勤心精进早得道果。舍利弗。我法无诸难事。不念衣食卧具医药。汝等但当勤行佛道。莫贵世间财利供养。舍利弗。汝今善听。我当语汝。若有一心行道比丘。千亿天神皆共同心。以诸乐具欲共供养。舍利弗。诸人供养坐禅比丘。不及天神。是故舍利弗。汝勿忧念不得自供。佛真教化当随顺行。莫以第一义空出。人过恶。何以故。舍利弗。大崄难者所谓得空。或有比丘。因以我法出家受戒。于此法中勤行精进。虽诸天神诸人不念。但能一心勤行道者。终亦不念衣食所须。所以者何。如来福藏无量难尽。舍利弗。如来灭后。白毫相中百千亿分。其中一分供养舍利及诸弟子。舍利弗。设使一切世间人。皆共出家随顺法行。于白毫相百千亿分不尽其一。舍利弗。如来如是无量福德。若诸比丘所得饮食。及所须物趣得皆足。舍利弗。是诸比丘应如是念。不应于所须物行诸邪命恶法。舍利弗。若纳衣比丘。于粪扫中拾取弊故。应生是心。以此障寒及修圣道。我今以此弊故。缝作僧伽梨着。勤行精进。若以凡夫乃至一夜不应着此。是比丘净浣缝着。若此比丘。于此纳衣生贪着心即应舍之。我不听着。何况余衣。何以故。舍利弗。是比丘于此衣中。生非比丘法。是比丘不复应着。何况余物。舍利弗。是时比丘宁以赤热铁鍱自缠其身。不应着此纳衣。何以故。于此衣中染爱心故。舍利弗。纳衣比丘应作是念。着此纳衣。以遮寒热以助修道。我今不复更着余衣。当得须陀洹果斯陀含果阿那含果阿罗汉果。舍利弗。如是纳衣比丘专求道者。我则听着。舍利弗。乞食比丘。应诸法中无所分别。常摄其心不令散乱而入聚落。以诸禅定而自庄严。乞食得已心不染污。持所得食从聚落出。在净水边可修道处。置食一面洗脚而坐。以食着前。应生厌离想不净想屎尿想臭烂想变吐想涂疮想厌恶想子肉想臭果想沉重想。又于身中应生死想青想脓想烂坏想。舍利弗。比丘应生如是想。以无贪着心然后乃食。但以支身除饥渴病。令得修道。应作是念。我食此食破先苦恼不生后苦。心得快乐调适无患。身体轻便行步安隐。又念食此食已。我应当得须陀洹果斯陀含果阿那含果阿罗汉果无生法忍。舍利弗。比丘如是食者。我听乞食。舍利弗。若乞食比丘。于所得食生贪味心。以为甘美而作是念。我食此食当得好色气力充盛。不作是念。我食此食勤行圣道。如是比丘我乃不听受一饮水。何况饭食。舍利弗。若于食中不见过恶。不见出道而便食者。宁自以手割股肉啖。何以故。我听行者得者受他供养。不听余人。舍利弗。云何名为行者。若有比丘决定发心。我于今世断诸结使。当入无余涅槃。修习圣道如救头然。又当除断不善恶法。是名行者。又能一心信解空无相无愿。为得须陀洹果斯陀含果阿那含果阿罗汉果断诸烦恼。名为行者。求诸善法常行咨问。名为行者。又能发心度脱一切。名为行者。勤心修习诸助道法。于诸经中如说而行。及有一心求佛道者。舍利弗。于佛法中是名行者。何谓得者。谓得须陀洹脱三恶道。名为得者。斯陀含阿那含阿罗汉。断诸烦恼求道已息。所作已办善学三学。是名得者。我听是人得受供养。是人若受供养。是名善受供养。舍利弗。清净持戒者。开化檀越者。及修多闻读诵经者。谓读诵修妒路岐夜授记经伽陀忧陀那尼陀那。如是诸经本生经方广经。未曾有经。阿波陀那论议经。是人又能清净持戒无有瑕疵。不垢不浊自在不着。智者所赞能自具足。随顺禅定时时乐坐禅。如是比丘我亦听受供养。舍利弗。身证法者无有疑悔。我听是人高座说法。虽是凡夫清净持戒。心不贪着外道经义。一心勤求沙门上果。不贪利养善巧定说。多闻广喻犹如大海。乃至失命犹不妄语。不乐诤讼自利利他。唯说清净第一实义。所说如是亦如是行。舍利弗。如是说者我听说法。如来所说能使诸法不相违逆。谓说戒定慧解脱解脱知见。舍利弗。求利比丘。为佛出家而破戒品。何用说法。何以故。舍利弗。我经中说。若人自不善寂自不能护。能令他人善寂自护。无有是处。如人自没污泥欲出他人。无有是处。若人能自善寂。能出污泥欲出他人。则有是处。是故舍利弗。我今明了告汝。诽谤如来其罪不轻。实语比丘应听说法。非妄语者持戒比丘。则能法施。舍利弗。高座说法决定断疑。最是上事。若持戒不净着外道义。我则不听。及妄语者。贵世乐者。求利养者。乐诤讼者。我亦不听。我听净持戒者。质直心者。通达诸法实相者。高座说法。舍利弗。破戒比丘宁当舍戒。不着圣人相袈裟覆藏罪垢。密作众恶受人信施。舍利弗。以小因缘。而于久远受地狱身

    佛藏经嘱累品第十

尔时阿难白佛言。世尊。当尔世时诸比丘等。于善法中云何精进。佛告阿难。且置莫问。所以者何。佛无量智所说经典。尔时比丘尚不能信。况能勤行。阿难。如来于有为法中所有智慧。一切辟支佛阿罗汉等不能解知。阿难。如来所知法。若为汝说汝则迷闷。何况是人当能信之。如来于今说如是经。尔时痴人犹尚不信。何况能信所说罪报。阿难。法应当尔。自身是恶谓余亦恶。如今第一懈怠比丘。尔时第一精进比丘所不能及。若所持戒威仪智慧。不得相比。如来若说此人所行。一切过恶转身所受。是人不信更起重罪。汝等若闻亦得忧怖。不能量其所受罪恶。阿难。如来深法受者难有。于意云何。好床茵褥豚子乐不。不也世尊。阿难。我阿耨多罗三藐三菩提。此法深妙智者所乐。是人不能信解通达。得出家已自称沙门。不能堪受如实教化。于此法中不能修心。不得滋味振手而去堕在恶道。犹如豚子舍好床褥。何以故。阿难。是我阿耨多罗三藐三菩提甚深清净。非难化者所能信解。难降伏者。无智慧者。难满者。难养者。破戒者。难与语者。住邪法者。行邪行者。贵财利者。以衣食为上者。破威仪者。破戒德者。堕顶者。弊恶者。懈怠者。小欲者。小精进者。无羞者。耐羞者。匆匆营事业者。沙门中旃陀罗。沙门中白衣。沙门中败坏。沙门中行邪道者。非沙门自言是沙门者。魔所吞者。与外道义合者。不如说行者。乐众闹者。乐散乱语者。具有魔事者。魔所衰恼者。烦恼炽盛者。我见者。人见者。众生见者。颠倒者。于我此法若能信解通达。无有是处。何以故。阿难。我阿耨多罗三藐三菩提清净快大。与此恶人不相称可。阿难。譬如百千亿三千大千世界中间旷远。此弊恶人远沙门法。犹尚如是。况得顺忍。况得涅槃。阿难。如此事者说不可尽。当来沙门弊恶鄙贱。深怀悭贪。深怀嗔恚。深怀不信。三毒炽盛心行粗犷。难可制御。阿难。譬如良田善熟以火自烧。甘膳美食而自着毒。舍宅所有以火自梵。为应尔不。不也世尊。阿难。如是未来世痴人。因以我法得受供养。而不信解如来功德。又不能信如是等经。不能堪忍如实说过。自知疮疣而逆我语。如是痴人依佛自活。而逆是法。阿难。尔时阎浮提内。如是痴人充满其中。阿难。且置。何用求此愚痴恶人。徒生徒老所行恶事。尔时阿难白佛言。世尊。当何名此经。云何奉持。佛告阿难此经名为佛藏。亦名发起精进。亦名降伏破戒。亦名选择诸法。当奉持之。阿难若人诵持是经。所得功德无量无边所以者何。破戒比丘。尚不能信读诵教人。况于是中得欢喜心。何以故。阿难。譬如恶贼于王大臣。不敢自现盗他物者。不自言贼。如是阿难。破戒比丘成就非沙门法。尚不自言是恶。况能向余人说。自言罪人。阿难。如是经者。破戒比丘。随得闻时能自降伏则有惭愧。持戒比丘得自增长。说是经时。无数诸天于诸法中得法眼净。恶魔及诸眷属皆大忧恼。如堕十六种大坑。大啼哭言。瞿昙沙门知我觉我。我常长夜。愿佛灭后破持戒者助破戒者。欲令诸恶比丘不知佛法。但知读诵我欲于佛法中破安隐心。语言此非佛法无有义趣。瞿昙于今在诸天人大众之中。守护是法遮我所愿。魔说此已。怀忧愁恼忽然不现。尔时世尊欲明了此事。而说偈言

  我所说诸法　　随顺第一义
  有为不坚牢　　如梦之所见
  我今说此法　　呵责未来事
  随顺第一义　　防制诸恶人
  尔时恶世中　　比丘心娆动
  诤讼生是非　　不能得涅槃
  沙门及白衣　　所说无有异
  尔时我此法　　与俗法无别
  为诸在家说　　汝知我希有
  我得于佛法　　初道第一果
  更有比丘言　　我说不异是
  此人与我同　　我真见法者
  见法不见者　　为致白衣故
  各于自法中　　而生其议论
  有言一切有　　有言一切空
  不住于正道　　性恶毁我法
  汝勿近是人　　可来亲附我
  为汝说真法　　如我疾得道
  如是诸音声　　流布于远近
  同心相党助　　破我所教法
  譬如诸恶贼　　同恶共为侣
  反逆破国土　　城邑及聚落
  尔时诸比丘　　难可得开化
  钝根深贪着　　少智依我人
  不解于如来　　随宜所说法
  说有漏增上　　自言是得道
  在于大会中　　多有诸比丘
  皆言有智慧　　求智无一人
  若是大会中　　或有一比丘
  如实有智慧　　皆呵言无智
  诸天神等见　　法王道散坏
  咸皆怀忧恼　　相对而啼泣
  中有诸树神　　从树而堕地
  咸言释师子　　妙法今悉坏
  佛宝法僧宝　　在世犹未久
  如何于今日　　悉皆当散坏
  我等不复闻　　如来所说法
  痴冥无所知　　上道今将灭
  尔时诸地神　　皆出大音声
  如来大法炬　　于今当灭尽
  诸天诸神等　　后莫有所悔
  而言不见闻　　佛道今已灭
  如来无量劫　　自利亦利人
  忍受诸苦恼　　发愿得成佛
  释师子大圣　　度诸众生者
  清净微妙法　　今将欲灭尽
  痴恶诸贼等　　于今当得力
  无有慈愍心　　互相谤毁恼
  魔使及魔民　　钝根难开化
  谄曲懈怠心　　嗔恚坏佛法
  但于空林中　　坐禅满三月
  自言是罗汉　　无禅况得道
  不得言得道　　死言入涅槃
  众人信起塔　　而自入地狱
  如是痴空者　　互共相轻恚
  我于无量劫　　所得今尽坏
  尔时虚空神　　共见释师子
  妙法毁坏败　　发声皆啼泣
  四天王闻此　　皆共怀忧恼
  时与诸天神　　佥皆共来下
  阿罗迦槃城　　夜叉神众来
  佥皆大啼哭　　出可畏音声
  有诸七宝城　　严饰极微妙
  失色皆如土　　诸天不乐住
  悲号大啼哭　　处处皆来集
  各共怀忧恼　　相见不能言
  宛转卧在地　　发如是音声
  共行阎浮提　　见是大怖畏
  佛子共斗诤　　破法而分散
  皆从天上来　　共诣我生处
  天神诸宝城　　七日无光色
  各共坐啼泣　　满七日不起
  如何大精进　　勇猛世间尊
  我等见住此　　今当不复见
  咸共诣祇洹　　相对而啼泣
  佛此说四谛　　我等此中闻
  世间将盲冥　　互相轻恚慢
  但起诸恶业　　还堕于恶道
  诸天妙宫殿　　可惜今将空
  我等诸天神　　无复救度者
  尔时阎浮提　　毁坏无威色
  经行处树下　　山窟无善人
  一切诸世间　　悉皆大娆动
  诸天及大神　　音声可怖畏
  尔时忉利天　　举手大悲哭
  各于宫殿中　　发声而号哭
  诸天宫殿中　　皆称说我言
  永离大圣王　　为我说法者
  忉利天六月　　不食修陀食
  不听伎乐音　　忧愁如丧子
  诸阿修罗众　　闻有如此事
  皆共相命集　　欲攻忉利天
  时诸阎浮王　　皆共相征罚
  诸天阿修罗　　亦皆共战斗
  尔时诸比丘　　及诸比丘尼
  多堕恶道中　　少有得免者
  破戒诸白衣　　随顺恶比丘
  以是因缘故　　皆趣于恶道
  诸恶优婆夷　　随顺恶师故
  亦复入恶道　　世间皆娆动
  有入城聚落　　有至山林中
  东西怀忧恼　　以损其寿命
  尔时多恶贼　　多有诸崄道
  种五谷不生　　若生虫所食
  尔时世人民　　饥馑多饿死
  死堕饿鬼中　　久受诸苦恼
  时人施佛物　　塔及四方僧
  辄皆共分食　　我后僧如是
  阿难汝等当　　勉力勤精进
  莫见后末世　　如是众恶事
  一切诸凡夫　　愚痴无有智
  起诸凡夫业　　疾堕恶道中
  汝等勤读诵　　是名智慧因
  若为智慧故　　疾得至胜处
  我学世正见　　汝亦如我学
  断世障碍事　　疾得至胜处
  勤行八圣道　　当疾得涅槃
  思量求自利　　我所说如是
  是劫过去后　　六十劫无佛
  尚无佛音声　　况有得道者
  时世诸人民　　饥饿所逼切
  无有孝慈心　　食母食儿肉
  时诸家生子　　常护恐他食
  谁闻是恶事　　复起生死业
  诸苦痴为本　　五阴贪为本
  若不乐五欲　　当断诸贪着
  受福果报时　　深生贪着心
  贪着因缘故　　起恶堕恶道
  无漏法空寂　　世间无牢坚
  若知如是者　　汝等应疾行
  无心生心想　　而自大惊畏
  我为作不作　　是事为云何
  如是诸凡夫　　思惟而筹量
  我当云何作　　如是常啼泣
  无阴生阴想　　无我生我想
  闻自相空法　　如是亦迷闷
  不知佛如实　　所说诸阴义
  闻则以为定　　畏处无畏想
  我说去来今　　诸阴皆空寂
  三世悉平等　　犹若如虚空
  所有过去佛　　亦说自相空
  未来世诸佛　　亦说自相空
  我今出于世　　亦说一切法
  自性自相空　　三世无有异
  当来人不知　　佛所说实义
  贪着我众生　　常堕于恶道
  当来世如是　　大恶甚可畏
  汝等勤精进　　莫见是恶世

佛说此经已。长老舍利弗及诸比丘。一切世间天人大众。闻佛所说。皆大欢喜。信受佛语

佛藏经卷下


佛升忉利天为母说法经

    No. 815 [No. 816]

佛升忉利天为母说法经卷上

        西晋月氏三藏竺法护译

闻如是。一时。佛游于忉利天上昼度树下无垢白石。愍哀其母度脱之故。正夏三月与大比丘众俱。比丘八千皆阿罗汉。诸漏已尽得大神足。威曜无极生死悉断。无复尘垢弃捐重担。所作已办。逮得己利。心即从计致平等忍。心已得解度于智慧。普则正士。于世福地多所祐安。唯除一人贤者阿难。菩萨七万二千人一切大圣神通已达。逮得总持辩才无碍。各从他方异佛世界皆来集会。尔时世尊。与无央数百千之众眷属围绕而为说经。时于众会有二天子。名曰月氏月上。月氏天子即从坐起。更整衣服偏袒右肩。叉手长跪而白佛言。吾欲咨问如来至真等正觉。假使听者乃敢自陈。佛告天子。欲问如来何所义乎。月氏天子以偈颂曰

  其于众生类　　兴发愍哀心
  逮求于佛道　　志无垢甘露
  自伤己身行　　及慈哀群黎
  余以斯等故　　咨问释师子
  于亿劫积行　　悉能忍勤苦
  一切而布施　　志寂然无念
  等心于群生　　疗化已平均
  我问此胜义　　导利黎庶者
  假使见正道　　妙相自庄严
  无垢三十二　　英特之福田
  逮斯功德者　　奉敬乎巨海
  今予问大圣　　欲了斯义归
  假使无异心　　则无有别念
  常志求妙慧　　人中巍巍尊
  而无声闻意　　不慕缘觉事
  今余问此义　　坚固无过者
  有利若无利　　等心于毁誉
  有名若无名　　苦乐不以移
  虽处于俗法　　则不以动转
  今我问此义　　远离恐惧者
  以爱己身事　　等念于黎庶
  未曾有若干　　咸化于三处
  而以修慈心　　有谄无厌秽
  今余问此义　　贤将持土地
  心恒行精勤　　布施戒离邪
  其身逮寂然　　戒品不永灭
  身口意常正　　将御顺拥护
  今问最胜义　　处垢而无尘
  其忍辱调柔　　达已加遵修
  能修任苦患　　愦扰放逸众
  游救于一切　　而不生嗔恚
  因此故问义　　欲决诸狐疑
  各常力精进　　恭顺不违义
  悉愍伤世间　　不为己身施
  行道无厌足　　如海受众流
  是故问最胜　　其德如大海
  虽存于三处　　不退从诸想
  以贤圣之慧　　伏除诸垢尘
  承禅定妙通　　神足自娱乐
  今故问此义　　普往开化众
  智慧度彼岸　　圣达无有际
  弃捐众思想　　出家除根株
  憺怕得自在　　晓了斯法慧
  是故今启问　　无极大圣人
  所分别神足　　解了随顺行
  游亿垓佛土　　无有国土想
  供养亿垓佛　　无有诸佛想
  是故问此义　　睹者普受欣
  其离欲尘魔　　忽化阴身魔
  弃舍于死魔　　降伏诸天魔
  蠲除一切魔　　则逮成佛道
  是故问斯义　　永弃于众冥
  乃震动天地　　树木及山岩
  觉了成佛道　　无量最胜慧
  假使已一心　　习于寂定明
  是故问此义　　咨启如斯像
  晓了一切慧　　威耀甚巍巍
  假住于佛教　　善建立法行
  导利于众圣　　靡所不开化
  今故问斯义　　济游三处者

月氏天子。又问世尊。唯然大圣。何谓菩萨得大圣通殊特之行度于彼岸。何谓菩萨至不可思议善权方便备劝助慧何谓菩萨一切诸法以为一议。入于一味所趣同均。入于一慧平等之说。何谓菩萨奉深禁戒行无放逸。逮成无上正真之道为最正觉

佛言。善哉善哉。月氏天子。多所哀念多所安隐。愍伤诸天及十方人。乃能发意启问如来如此之义。诸菩萨行佛道正真慧。被大铠者建立大乘。度大欲御大船转大法轮。施无极法恢弘慧典。欲放大雨欲演普光。慕击大鼓志大雷震。乐立巨幢愿吹大珂。执大法英揽大法典。演无极明欲照世间。务令大乘永存不断。愿大祀祠究竟足满。以此比类无极之德愍伤群庶。故问如来。谛听谛听。善思念之。吾当为汝分别说之。如诸菩萨大士之行。致大圣通具足深戒。至于无上正真之道为最正觉。唯然世尊。愿乐欲闻。月氏天子与诸大众受教而听。佛告天子。菩萨有四法行。得大圣通殊特之行度于彼岸。何谓为四。菩萨大士晓了诸法而应真谛。于一切法无所倚着。等念诸法而无有尽。逮于圣慧而造明证。游一切法亲近众典。虽在诸法无有脱者不见异法。何谓诸法而应真谛。如过去空。当来现在亦自然空。天子。欲以晓了是空平等三世空无所想。彼诸有慧分别处所。建立开化解畅道品。便通正业达其义理。是谓晓了而应真谛。何谓于一切法无所倚着。一切诸法住于我所。现有所住于我非我。则谓菩萨晓了诸法而无吾我不依倚身。是则名曰无所倚着。假使菩萨于斯诸法。身无所著无所著已。不住异法。其于诸法不生不住。尔能于彼无所倚着已无所倚。供养诸法则于诸法而无所倚。二何谓菩萨晓了一切犹如虚空。其三界者心之所为。不计斯心无有色像。亦不可睹无有处所。无有教令犹如幻化。因其心本而求诸法则不可得。若以于心不求于心则无所获心不可逮。以不得心一切诸法亦不可得。诸法则无有法。无形类想。亦无有影而无所有。及与实谛亦无所睹。无所睹者于一切法心无所入。知一切法无所成就亦无所生。譬如虚空。犹如天子。欲察虚空永无有生无所成就。了一切法亦复如是。犹如虚空名曰虚无。彼则憺怕。一切诸法亦复如是。但假字耳彼则寂寞。三何谓菩萨于一切法而亲近典也菩萨大士。观察思惟一切诸法。于斯无知亦无所见。眼不知耳亦无所见。耳不知眼亦无所见。鼻不知舌亦无所见。舌不知鼻亦无所见。身不知意亦无所见。意不知身亦无所见。一切诸法虽有痴騃快眇凶暴。见于法界慧常平等所行具足。其六情界有所照来则有所在。计于本者无有内法。教于外者如无外法。教内法者所见如是。睹若斯者则无有法无有起者。亦无有法有所作为。若有住者睹无所见。佛语天子。是为法界法无所起亦无所灭。而亦不住则无所有。假使有念诸法。不住不生不起无有处所。如是观者真谛慧备。无有诸法及与法界。不见解脱。斯一切法亲近诸典。是为四法。菩萨大士。得大圣通殊特之行度于彼岸。四何谓圣通。所云通者于一切法不信他慧而有咨受。所以言慧于一切法不造二事。所谓无二彼则无名法不可知。设使天子。具足斯慧。其菩萨者速逮圣通。以成就愿具足所晓。菩萨晓了如是慧者则净道眼。超天世人。便睹十方无量无限亿百千垓诸佛国土。佛天中天所有圣众。悉闻诸佛所说经法。彼佛国土群萌之类。其心所念善恶好丑悉识知之。人民伴党行来如是。逮及若斯。自知往古所周旋处。以慧明证解己本际。他人众生始无所由。所居止处悉证明之从缘说是。佛告天子。菩萨大士。虽未得至一切通慧。圣明之智巍巍如是。为诸众生兴立佛事。速疾具足一切佛法。逮得无上正真之道为最正觉。于是世尊即说颂曰

  以善权慧方便道明　　则具足成于大圣通
  而常遵修深妙禁戒　　寻用一义解一切法
  分别真谛一切经典　　其明目者无所倚着
  常观诸法犹若虚无　　以有所察宣扬悉空
  习近诸法彼假号法　　不见诸法有解脱者
  其不见者靡所不观　　已得圣通所见若斯
  假使过去法已空者　　当来诸法亦如是空
  分别现在则亦若兹　　是乃谓为真谛之见
  一切诸法三界常空　　斯明知者无念不念
  已无有应应不应者　　其无所畏为睹真谛
  若慧如是无著方便　　讲说经法无有法想
  意无所念则无所著　　无所著者则不动摇
  一切诸法自然而兴　　其自然者本净无我
  晓了诸法而无吾我　　尔乃不起无他异法
  其不生者不有不来　　察计于彼则无所倚
  而反讲说诸法处所　　虽演佛道不念有我
  一切三界心之所由　　彼心则亦不可常睹
  无色无人犹如幻化　　当以斯法务求于心
  彼以此法求于心已　　则知无心亦无心法
  假使已心求心处所　　则便不睹心之本净
  已于诸法无所著者　　虽在黎庶不随众想
  一切诸法无意无成　　常分别知犹如虚空
  如观虚空不生不有　　分别诸法亦复如是
  假号虚空谛无有实　　说有言辞彼法虚空
  其眼未曾观见于耳　　其耳亦不观见于眼
  舌不属鼻鼻不属舌　　斯等展转而不相见
  其身未曾察见于意　　意亦不察身之形类
  各各如是不能相知　　以是之故斯常憺怕
  计着众恶谀谄痴騃　　诸法之界常等均平
  其内事者不知于外　　若外事者亦不知内
  以是之故晓法所趣　　成就智慧常不可限
  观见十方亿垓诸佛　　及诸声闻无有罪衅
  又彼诸佛所说经典　　无量圣达清净之义
  悉得逮闻所演美辞　　则能受持普修平等
  便能了知众生心念　　具足飞到亿万佛土
  识念往古无数世事　　亿百千劫如恒河沙
  逮成于此妙五圣通　　则得亲近安住之慧
  彼以佛故有所显发　　无放逸道兴造利义
  假使闻斯如是空法　　生欣踊心乐微妙乐
  魔不能得彼之瑕短　　则能疾成觉了上道

佛告天子。菩萨大士有四事法。至不可议善权方便。何谓为四。菩萨晓了往返度流之法犹如己身。若干种痛苦毒之患睹所游起。亦欲蠲除他人之苦修行精进。劝诸众生趣于圣路。令一切法留存道心。为诸群黎积累德品三世亦然。而已劝助一切诸佛。集三世行劝助德品。所作善本加施众生。放舍弘施有所开化亦不生心其不劝进一切智者心不离脱亦不见道。心不离道道不离心。如道之相身相若斯。以慧平等于心于道亦无所倚。顺权方便长益德本。不见法界有所增益。彼于诸法无所思议积功累德未曾厌倦。不以心业求晓了心。彼若布施则无望想。奉修禁戒亦无所失。遵行忍辱亦无所住。所行精进亦无憺怕。一心禅定无所依倚。奉行智慧亦无所习。劝化众生亦无所著。以愍哀故严净佛土。求于圣达无所起慕。讲说经法亦无所入。如是天子。菩萨所行所造德本虽为薄少。善权方便不可限量乃至大道。何谓菩萨所造德本虽为薄少。善权方便得至无量乃致大道。菩萨大士。于一切法念发无量。观察诸法无有计限得边际者。所以者何。天子。欲知一切诸法。则空无想亦无有愿。其以空者则亦无量。假使畅达无量心者。讲法虽少善权方便广大无际。所以者何佛道无量劝心无限。至无际法则为诸佛世尊之道。复次天子。菩萨大士善权方便。劝勉众生令入正行。忧群萌类所乐法者而劝立之。若施有所救济为说经法。复次天子。菩萨大士。不以布施而为审谛言是我所。持戒忍辱精进一心智慧。亦复如是。不名我所又有所施。若持戒者亦无所念常顺禁戒。具足忍辱见人所作。是非悉忍。奉行精进修清白行一心禅思。晓了方便观察智慧。复次天子。菩萨大士分别晓了。善权方便与声闻俱。而开化之不乐所行。所修坚固与缘觉俱。不乐所行坚固其志。是为四法。菩萨大士。致不可议善权方便。于是世尊即说颂曰

  晓了于二事　　己身及他人
  当除吾苦患　　疗尽众恼热
  愍念于众生　　劝使在道心
  思惟一切法　　演令入一义
  一切群生庆　　合集于三世
  普于诸佛德　　悉当劝化之
  而悉晓了斯　　皆以施众生
  真心而惠施　　犹以佛慧故
  一切所发心　　悉劝助佛道
  不失于道心　　见诸法悉脱
  察心及于道　　不见有二事
  其相有所存　　了心相同等
  法等故平等　　不二无所有
  明知权方便　　长益清白法
  其种无为益　　法界不可议
  志求于佛道　　常以不厌倦
  不以心念心　　吾长清白议
  不忘失道心　　所作而劝助
  布施不望报　　护戒无所念
  常修行忍辱　　不立计有人
  恒奉行精进　　身口心寂然
  禅定无所倚　　智慧度无极
  开化解众生　　不处于颠倒
  严净诸佛土　　志性无刚强
  常志于佛道　　于法无所舍
  咨受一切典　　故慧不可议
  为众生说法　　不着于文字
  造行如是者　　速成佛无难
  心不想于空　　不慢无所念
  无想无所愿　　不可称限量
  知群黎所行　　随之因开化
  自在而布施　　说法给所乏
  有施众生　　不言我获　　不高于戒
  不忽忍辱　　不慢精进　　不着禅定
  而于智慧　　无所吝惜　　常喜布施
  讲论众戒　　遵修谦下　　恒行勇猛
  虽奉禅思　　永无所著　　兴发智慧
  而以布施　　在于缘觉　　声闻之中
  菩萨大士　　游于此党　　假使处中
  有所造业　　明眼达士　　不乐彼行
  以能建立　　如斯法者　　是则名曰
  菩萨之行　　晓了善权　　不可思议
  所为惠施　　至无限量

佛告天子。菩萨有四事法。一切诸法以为一议入于一味所趣同等。入于一慧平等之说。何谓为四。菩萨大士。晓了法界无所破坏。解诸法空而普游至。于诸法议无所同像。平等吾我及于他人。晓了诸法悉为憺怕。是为四。晓了是慧所睹若此。于世俗法及度世法。靡不通达不造二观。若罪若福有碍无碍。若闻不闻有为无为。于此诸法不造不观。不见诸法有所受者。无凡夫法无罗汉法无若干观。其凡夫法不为清净也。不察罗汉法独解明。不举不下分别一议。趣憺怕门演畅讲说。散一切法而于诸法不见散坏。修行一忍永无有二。以入一议普入诸法。所谓入者无所从生。是为天子菩萨大士。得近无上正真之道成最正觉。亦不念言我近若远。所以者何。不处一议见异群黎。亦观睹人与道别异。又思惟之人不可得尔乃是道。于是世尊即说颂曰

  而于法界　　无所破坏　　又彼法界
  无能散者　　计如法界　　诸人若斯
  但假有字　　无有若干　　了诸法空
  则致响忍　　其内若外　　有为无为
  观察斯法　　悉无所有　　分别一议
  皆知为空　　诸所现法　　无所同像
  不着己身　　及与他人　　若不计念
  有吾我人　　其行未曾　　有若干想
  修于寂然　　志在憺怕　　普观一切
  诸法所存　　于一切法　　靖默无念
  游于憺怕　　而无所著　　讲说现在
  及度世事　　彼则不兴　　造尽灭尽
  若福若罪　　若闻不闻　　不念于法
  不取音声　　不在有为　　亦不无为
  常等一观　　不喜二事　　不睹诸法
  有所受者　　不得凡夫　　及阿罗汉
  不说凡夫　　痴秽不净　　此则名曰
  阿罗汉法　　亦无所举　　不有所下
  分别一议　　而悉寂然　　晓了诸法
  皆无所坏　　亦不毁散　　一切法界
  不谓忍别　　与空异耶　　普知诸法
  一切悉空　　不着于空　　无倚了忍
  以入一议　　悉了一切　　此无所起
  其本清净　　如是行者　　疾成佛道
  速得亲近　　无量正觉　　不计有身
  不念道心　　一切诸法　　吾我及彼
  悉无所著　　得平等觉

佛告天子。菩萨有四事法。奉深禁戒行无放逸。何谓为四。菩萨大士而自念言何谓禁戒。则顺观察思惟其议。若身行善。口言至诚。心念柔顺。是为禁戒。又复念言。何谓身善。何谓言诚。何谓心柔不犯身事而不杀生盗窃淫劮。是身行善。口不说非妄语两舌恶口谗言。是口言诚。心不念非念余嗔恚邪见之事。是心念柔。彼谛观察而自念言。假使不犯身口心者不可分别其处。所在青黄赤白紫红之色。计于眼者不分别识。耳鼻口心亦复如是不分别识。所以者何。彼亦不生亦无生者。亦无起者亦无不起。设不有生无所生者。亦不有起。无所起者。则不堪任分别识法。又更念言。尔时察之则无所有。亦无有戒则无所行。已无所行则不可知。已不可知不当于彼有所倚着。造此行已则无所见。当尔之时不见有戒。已不见戒劝彼戒者亦无所见。是为天子菩萨大士奉深禁戒。复次天子。若有菩萨晓不贪身。不处见身亦不睹见。修于持戒亦不犯禁亦无所著。复次天子。菩萨大士入深法藏在所护禁。威仪礼节行步进止。安详顺教是曰为戒。不自见己之所兴行。不见他人之过咎。是故名曰深妙之戒。复次天子。菩萨不犯于戒亦不毁戒又不弄戒。其反己者则以反戒。若不反己则不反戒。以不反戒则无所犯。已不犯戒则不弄戒便无所度。所以不弄不度戒者。了一切法悉度脱故。以度脱者则无有我亦不无我。既无有人何所度者。是为四。于是世尊即说颂曰

  其身清净　　言无误失　　心念鲜明
  行无瑕秽　　而常自护　　谨慎于行
  彼菩萨者　　乃谓奉戒　　将顺奉行
  于斯十善　　聪明菩萨　　若能护此
  则身口意　　无所犯负　　斯能名曰
  奉明达戒　　其无所造　　不起无生
  彼无形色　　无有处所　　已无像貌
  则无所住　　便不可得　　何所归趣
  戒不有造　　常如无为　　则不可以
  眼观察之　　耳无所闻　　无鼻无舌
  身不可别　　及心所念　　设不分别
  于六根者　　则达诸趣　　无所依倚
  设如是观　　乃清净戒　　未曾逮戒
  有所立处　　彼无有戒　　无意无正
  护于禁戒　　无吾我想　　将养于禁
  亦无戒想　　修深要戒　　志得自在
  以能分别　　所见身者　　即不堕落
  六十二疑　　其无所见　　不睹处所
  虽奉禁戒　　不自憍恣　　则能顺入
  深妙法藏　　所行礼节　　为不妄想
  善修安详　　将顺谨慎　　其禁戒者
  无有异着　　不倚吾我　　亦不依戒
  已无吾我　　则无禁戒　　不念己身
  及与禁戒　　如是乃谓　　为法器耳
  无吾我者　　不依倚戒　　不计身者
  不想念法　　无身见者　　无有戒心
  不犯戒者　　无有脱禁　　亦不建立
  于禁戒中　　不计有身　　则无戒想
  深妙之戒　　谓无所犯　　假使勇猛
  奉戒如是　　彼则未曾　　有所毁犯
  如是戒者　　圣贤所叹　　于一切法
  而无所著　　愚騃之夫　　住吾我想
  将护禁戒　　言我畏慎　　则失戒宝
  永无有余　　便不度脱　　三界之患
  假使有人　　除诸见网　　则不见彼
  违失禁戒　　其人心计　　无有吾我
  顺奉禁戒　　不堕疑见　　便不恐惧
  堕于恶趣　　若使分别　　禁戒如是
  则不睹见　　犯禁戒者　　不察吾我
  不见三世　　况当观察　　犯戒毁禁

月氏天子白佛言。得未曾有。天中天。诸佛世尊道法微妙。无上正真甚深难及。菩萨所作第一巍巍。乃能奉修如此之法。而无所住亦无所修。除去一切诸所妄想离吾我念。行无数劫而不堕落声闻缘觉。而不中道违失道意。具足佛法入不缺漏。云何菩萨奉行何法修微妙典。于真本际而不取证。世尊告曰。天子听之。菩萨有四事行深妙法。于真本际而不取证。何谓为四。菩萨大士坚固志愿。建立要行具一切智。奉修精进而不怯弱。不住立者不舍众生。于大哀不断教。善权方便劝众德本。是为四行深妙法于真本际而不取证。于是世尊即说颂曰

  其明智者　　志愿坚强　　未曾违失
  往古所晓　　为一切智　　精进殷勤
  终不处于　　兴废异乘　　奉行精进
  常无放逸　　敢所遵修　　心不怯弱
  亦不捐舍　　一切众生　　而普等心
  群萌之类　　常加愍哀　　普世群黎
  能忍勤苦　　意不转移　　志不欲令
  道教断绝　　犹如有人　　积无数宝
  而善觉了　　善权方便　　劝一切德
  行无厌足　　游趣最要　　怀于愍哀
  不于中间　　灭尽诸漏　　其有禀授
  于此经典　　其菩萨者　　名曰勇猛
  而常奉修　　深妙之法　　彼则未曾
  倚着本际

月氏天子复白佛言。何谓菩萨奉行深要。佛告天子。于是菩萨未曾破坏凡夫之法。而普成就于佛道议。亦不谤毁凡夫之法。亦不睹见佛法长益。亦不远离于凡夫法。亦不求慕。欲得佛道不兴斯行。凡夫法异佛道异乎。亦不念言。凡夫之法瑕秽卑贱。佛之道法为微妙乎。不作斯行凡夫之法则为斯漏。佛之道法无穿漏乎。又复念言。凡夫之法及与佛法。二者俱法虚无寂寞但假号耳。思想致秽。凡夫之法亦无成就。诸佛之法亦无具足。凡夫之法而无有实亦无自然。诸佛之法悉无有实亦无自然。若欲理者凡夫之法。而无所知亦不无知不生无生。若观察者推其本末。若以空慧无相之慧无愿之慧。智慧明省是为佛法。不可别知佛法所处。观此本末彼悉则空。空不见空亦无所知亦无所观。悉为本净无明故起。是以天子。法者无法诸法自然住立诸法憺怕。其憺怕法则无有二。其无二者则无凡夫。亦无声闻亦无缘觉平等佛道。亦无所教深妙之行为菩萨行。菩萨深修分别正教。无有一法非佛法也。所以者何。其言法者习俗为法。无习俗言有所言者则无所得。其无所得则无所兴。以无所兴则无形教。一切诸法悉无形像。假使诸法无有限数不离佛法。是故天子。当作斯观。一切诸法悉为佛法无有想行。其念想行寻即兴废二事之识。是等之类以识为行佛法无漏。亦复于彼而不想求。于彼生起声闻之行。其解了者法界无尘亦无寂然。假使于法而不受法则无有法。其尘劳法及寂然法。岂可获到尘劳寂然乎。欲作斯求终不可得。如是天子。假使菩萨晓了如是则为名曰深妙之行。其于诸法及与佛法无所见者。以无所见则为离见。其所见者为无所见。假使菩萨如是观者。魔及官属不能得便。莫能胜也

佛升忉利天为母说法经卷上佛升忉利天为母说法经卷中

        西晋月氏三藏竺法护译

月氏天子便白佛言。唯然世尊。至未曾有。菩萨大士所行难及。如是像类观察诸法。志于所趣终始没生。坐起语言亦无想念。佛言譬如天子幻师所化来往周旋。坐起经行而出言教彼无想念。如是天子。其有晓了诸法如幻。普现五趣不有所生彼则无想。其菩萨者不念于生亦无所起。用本愿故有所建立现有所生。天子复问。如尊所教而言。菩萨不念所生亦不往生。云何大圣如来至真。愍哀垂念所生之亲上忉利天。一时三月如来不为从王后摩耶而由生乎。佛告天子。菩萨不从王后摩耶所生常应如法。天子又问。如来至真云何生乎。佛言。天子。如来则从智慧度无极生。设人观察推其本末。过去当来现在诸佛谁为母者。则当了之。智慧度无极是其母也。所以者何。天子。其三十二大人相。非从摩耶而所生。学大智慧真谛之谊乃能致此。自然成就如来之身。其十力者不从王后摩耶而生。本时奉行。智度无极。得十种力四无所畏十八不共诸佛之法。亦复不从王后摩耶而生。大慈大悲无见顶及不虚见。佛眼佛慧佛之辩才。知人心念所从来生。神足善权如是比类不可限量。皆因智慧所度无极。所以如来名曰为佛。斯诸功德悉为不从王后摩耶而生。天子当知。悉从大智度无极行学此道品。如来因斯致如是像无量佛法如来弘德。缘是之故名曰如来。是故天子。当作斯观。如来则从智慧度无极生。不因王后摩耶所生。天子又问。唯然世尊。智度无极法无有母。亦无所生亦无所灭。云何世尊。智度无极而生如来。佛言天子。因其法故号曰如来。其彼法者则无有生。亦无有终不生不灭。其无有生无终没者不起不灭。斯无色法则为智度无极所生。以故名曰智度无极生于如来。其所生者都无所生。亦不终没。亦无所起。佛言。天子。其不生不没不起不灭是则名曰智度无极之处所也。智度无极者如有所生如有所行。而智度无极者未曾有生亦无所行。天子又问。唯然世尊。智慧有想有分别。而依智慧。如有所生如有所行。佛言。天子。智慧无想亦无分别。假使智慧而有所想有分别者。则为不行智慧之事。所以者何。有所想念有所见者。则不应行也。设于智慧无所思想无所分别。彼能名曰奉行智慧。又问世尊。何谓依行。答曰。天子。其依行者无所言取何所依乎。佛语天子。无言取者则以放舍三界所生。其取言者则便不离三界所生。是故天子。演此教耳。其无言取何所依行。而生三界令有所依。天子又问。云何世尊。为诸声闻讲说经法度三界乎。佛告天子。吾为声闻欲界因缘而说经法。又如来身不得欲界。于色无色界为诸声闻而演经典。如来不得色无色界之所处。亦无所度而声闻众度于欲界。佛亦不得色无色界。而声闻众超度过出色无色界。又复天子不得三界不倚三界。计于空无柔顺之法不顺欲界。于三界中而无所慕。生于三界亦无所生不知所趣。天子。欲知何谓度者。贤圣之教但假言耳。推于正义无有度者无往无反。所以者何。观一切法无有度者。譬如虚空究竟自然。无有生者亦无所著。无有作者亦无所有亦无不有。观一切法亦当如斯。于是世尊说是语时。彼诸天众七万二千天。远尘离垢诸法法眼生。万六千天子宿殖德本。悉发无上正真道意。千菩萨德本普具得不起法忍。佛之威神令其裓上自然有华。自昔未有。各取此华供养如来。应时彼华普悉遍布忉利天上

尔时天帝前白佛言。吾未会见如此辈华族姓子等奉如来者。月氏天子报天帝释。拘翼且听。今所散华如来上者。众人未曾见斯圣尊。所以者何。所因心见如来者。彼心忽然已过去灭而不可见。是故拘翼。有所见者一切诸法。皆为本空本所不见。拘翼又问。天子。今为见如来乎。答曰。见矣。拘翼察之。假使如来有色有为乃当见耳。设使如来有痛痒思想生死识者吾当见之。如来无色痛想行识。亦无合会亦无所有。五阴法想则无有想不可色观。又复向者拘翼所云。若见如来乎。如令如来见于我身。吾睹如来亦复如是。又问。天子。云何如来见尔身乎。天子答曰。如来在前便可启问。时天帝释前白佛言。云何世尊。见于天子。世尊告曰。不以色见。不以痛痒思想生死识见。不见过去当来现在。亦不以见凡夫之法。亦复不离凡夫之法。不见所学及与不学。亦不学成究竟诸法。不见罗汉法。不见声闻。亦不以见缘觉之地。无缘觉地。佛之所见为如此也。其作斯观则为正观。其正观者则无所见。其无所见则平等观不为邪观。拘翼。欲知如来所观如斯无异。如是观者普见一切。名曰一切审观。是故如来名曰为佛。如来所兴不坏法界。于意云何。如来所见如是法者为见何等。答曰。世尊。如是如来不见名号亦无有色。于此所察则无法数无所兴造。又复问曰。唯然世尊。如佛所见。月氏天子见如是乎。答曰。拘翼。其有逮得不起法忍菩萨行者。于诸法界随顺住者。法不见法则无所有为自然法。又问。世尊。月氏天子得法忍乎。佛告拘翼。汝以自问月氏天子。当为发遣。于是天帝问月氏曰。仁者。为得不起法忍乎。天子答曰。于拘翼意无所从生有发起乎。答曰。不也。报曰。设无从生不有发起。云何逮得不起法忍。一切法界悉无所起此之谓也。其法界者不起不灭亦无所得。时天帝释心自念言。如今天子有所讲说。以为逮得不起法忍。以为亲近无上正真之道。月氏天子即知帝释心之所念。报天帝曰。拘翼。欲得法忍者不为亲近无上正真道。其不有起法忍。乃能亲近无上正真之道。又问。天子。何故说此。答曰。有所得者则堕颠倒亦无所得。其道心者无有成觉不起忍者。是曰无所从生。其无所起乃成正觉。又问。天子。道当何求。答曰。拘翼。其道心者当于己身自然求之。又问。其己身自然之者当于何求。答曰。其法不生。亦无生者亦无所生。当于彼求。当造斯求求如求意。不求名称而无所求。则无所求则无所住。时天帝释前白佛言。至未曾有。天中之天。月氏天子深入智慧巍巍难限。于何终没而来生此。于斯没已当于何生。月氏天子答天帝曰。假使幻士有所变化为男为女。为于何没而来生此。于是没已当复所趣。答曰。化者无所至趣。又其化者无有没生。所以者何。化者无想。答曰。拘翼。设使无想云何如是。斯幻化人往至于彼没来生斯。于此没已当生某处。设有斯念则非明智人所蚩笑。答曰。如是天子。诚如所云。今者拘翼所发问者亦复如是。一切诸法悉为如幻。而问如来。今此天子。于何所没而来生此。没斯何趣。于意云何。如幻所化宁有去来。岂可得见没所生乎。答曰。不也。所因化者欲有所兴有所造乎。答曰。无有所作。报曰。如是。其晓了一切诸法皆如幻化。则能示现去来没生。彼虽现此亦无想念亦无所作。于意云何。其于梦中睹色。若闻声者。鼻所嗅香。口所嗜味。身遭细滑。心所识法。宁可谓之实有所有。答曰。不也。天子报曰。如是拘翼。其有晓了诸法如梦如自然者。有所见闻心于诸法无所染污。亦不离尘。亦无所求。亦不忧戚。如所闻法悉分别之为他人说。于诸言声亦无所著。时天帝释前白佛言。唯然世尊。月氏天子不得所生不没不生。当以何义开化众生。群黎有生而有终没。于声闻之地不生不没。不生不没非菩萨地。云何菩萨之行当在生死游无央数亿百千劫

佛告天帝。其有菩萨逮得成就不起法忍。不念于生亦无终没。犹如罗汉灭度已来积于百年。所以者何。观察菩萨亦复如是。菩萨者无吾我想。无他人想。菩萨所行又复过彼。不念于生无终没想。无有吾我他人之想。皆悉灭度。一切诸法无有本末。假使不了于是法者则无所觉。大悲菩萨设无数劫亿百千垓。游于终始不以懈倦。譬如男子于四徼道烧大屋宅无所复慕。行大慈者亦复如是。不惜身命在于五乐弃捐之。去于所乐欲如远大火。在于火中悉能忍之其身不烧。于意云何。其人所作为难不乎。答曰。甚难。天中之天。佛言。拘翼。菩萨所行复过于此。度脱一切诸欲尘垢。而现于生教化群黎。是故当观。菩萨大士超越一切声闻缘觉。逮得无上正真之道为最正觉

尔时佛告天帝。向者仁问。于何所没而得生此。听佛所说。东方去斯九十二亿百千佛土。而有世界名曰积宝。其国有无央数众宝树木枝叶华实。各各别异经行游观。棚阁讲堂悉用七宝。彼国土地悉绀琉璃。以无央数百千众宝合成。积宝世界佛号宝场威神超王如来至真等正觉。现在说法。其佛国土无有二乘声闻缘觉之所教业。纯诸菩萨具足弘普周满佛土。其佛说法一会时。三十六亿菩萨逮得不起法忍。众适得忍寻则踊身在于虚空。四丈九尺动于三千大千世界。则无央数七宝百千莲华。自然布地无不周接。即从虚空诣他佛土。奉觐异国如来正觉。稽首归命咨问经法听所说谊。其佛兴来以十二劫。昼夜各三讲说经法。以故拘翼。当作斯观。其佛之界。诸菩萨众不可计亿。无有损耗众宝积聚。佛之国土无异聚名。无有山林溪谷诸渊。无谈语者无有众患。罗汉缘觉无食饮者。所以者何。斯诸菩萨昔以乐法悦豫为食。今此天子从积宝世界没来诣此处忉利天。故来见佛稽首归命咨问经典。为无数人演斯经法广解其谊。又复欲令诸余菩萨具足兴发于斯法忍。佛言。天帝。月氏天子佛欲释命当护正法受持奉行。如来灭度之后。最于末世法欲尽时。当住此阎浮提。于彼世时当授人民如是比像深妙之法。优奥无量精进将养。化不可计亿百千人住斯法忍。法没尽后人间终没。生兜术天弥勒菩萨所。启受于此诸佛世尊微妙之道化。于无量百千天子立无从生。或发无上正真道意。弥勒菩萨成正觉时。住阎浮提十岁供养。弥勒如来及诸弟子与二万人俱。舍家之地离家为道。行作沙门启受经法。尽其形寿常持正法。佛灭度后。而以此法将济群生。悉当复值于斯贤劫千佛兴者。次第供养九百九十六佛世尊。悉于大圣净修梵行。过七十五江河沙劫。寻得无上正真之道为最正觉。号曰日曜如来至真等正觉。其佛土名一切具足

于是月上天子。谓月氏曰。于斯世尊授仁者决。当成无上正真之道。而今如来独与欢豫。偏见愍念而授决乎。月氏天子答月上曰。如来至真永无所欲。亦无所难。亦无疑结。假使授决无所悕望。若有菩萨学开士行。以故如来而授决耳。何因如来独当欢豫。偏见愍念而授决乎。又问。天子。当何以欢豫之信当于信求。又曰。假使于心而想心者计于彼人。无欢信者无所受取。无受取者第一欢豫。计于彼信其无瑕秽。无欢豫者乃为信乐。若于言辞无所言者。乃为信乐。彼则未曾无欢豫信也。亦无结恨。是故天子。假使有人求欢豫信。便当修行无言辞法。所精进行如无所行。亦无不行无忧无喜。所以者何。其法界者亦无有行。亦不不行不进不怠。月上天子谓月氏曰。所可名曰菩萨学者为何谓乎。月氏答曰。所谓菩萨学者。则无有身亦不护体。又无有舌亦不护口。又无有心亦不护意。是为菩萨第一之学也。所谓学者其无所受亦无所行。若无所起亦无不起。是为菩萨学也。又复问曰。仁者。学斯如来授决乎。答曰。天子。吾不学此而见授决。所以者何。学如此者不得吾我及我所耶。其不念知有所学斯名曰学也。天上世间不能得短亦无有失。若有念言我有所学。则不为趣于正业也。不逮平等。用自谓言我所学故。又问曰。以何等事谓逮平等也。答曰。天子。假使行者不上不下不处中间。不着所行不有所作。有所行者而无所造是菩萨行。其作斯念是为尊法此卑贱法于斯诸法。晓了平等不为二念。如是行者谓逮平等。又问曰。于今仁者。逮何等法乃为如来所见授决。月氏答曰。亦不蠲除凡夫之法。亦不逮成诸佛之法。如来以此授吾之决。吾于是法无所断除。又于诸法亦无所得故见授决。又问曰。计如是者愚冥凡夫悉当得决。所以者何。亦不蠲除凡夫之法。斯则名曰为凡夫矣焉致佛法。又重问曰。何故解凡夫法乎。月氏答曰。吾以空义为诸法界解佛法耳。其本际者实无有本也。谓空法界可灭乎。答曰。不能也。本际无本岂可获乎。答曰。不也。是故天子。吾说此言。亦不灭除凡夫之法。亦不逮成诸佛之法。如来以此授于吾决。又复问曰。空与法界本际无本有言辞乎。答曰。无也。假使空与法界本际无本。无有言辞道无言说。于今云何授仁者决。答曰。天子。今授吾决犹如空义。诸法之界本际无本。是为诸法之所归谊。如法无法受决。亦如授别亦如。授别竟者亦复如是。等觉亦如。逮成无上正真之道。亦复如是。于是月上天子前白佛言。唯然世尊。月氏天子入深智慧巍巍难及。佛告天子。菩萨以逮成法忍者。其法如是有所分别。若发道谊演经典者。解脱一切法界之事。又其法界所可讲说。亦无言辞宣畅示众。所以者何。理于法界无有言辞亦无所说。计如法界人界亦如。如众生界佛界亦如。佛界法界亦如。假使菩萨入此谊者。则能独立不从他受

佛升忉利天为母说法经卷中佛升忉利天为母说法经卷下

        西晋月氏三藏竺法护译

于是贤者大目揵连。咸请劝发于无央数亿百千垓诸天子众。欲行天人。色行天人。各各疾取华香捣香杂香缯幡。各往诣佛供养世尊。前礼足下却住一面。时目揵连还诣大圣。稽首于地迁住佛前。佛告目连。汝听。如来所现神足正觉变化。有经名曰如来感动威变。善思念之。目连应曰。受教而听。佛告目连。斯三千大千世界。百亿日月。百亿四大海。百亿须弥山王。百亿四天下。是则名曰三千大千世界一佛国土。于意云何。佛为独在一阎浮提成正觉乎。莫作斯观。所以者何。吾普悉遍诸四方面佛之世界顺如所应。为众生类讲说经法。或以成佛。或复自现从在胞胎。或复示现在兜术天。或复现身已灭度矣

佛告目连。于此三千大千世界。在于东方。去此万二千四大天下四大之域。则有世界名曰无垢。其佛号曰离垢意如来至真等正。觉现在说法。斯四大域佛之世界。所与众生淫怒痴薄易可开化。少菩萨学及辟支佛乘。多诸声闻。又目揵连。离垢意如来。一一集会说经法时。导九十九亿诸声闻等。其土所化不别四证。如此国土不说须陀洹斯陀含阿那含。其彼世界一坐听经。证六神通至八脱门。逮获神足踊在虚空四丈九尺。身中出火还耶维已而般泥洹。忽即[火*霍]灭无有烟炭。其土如来常说经法未曾休废。救济群生亦无懈息。诸声闻等日日灭度。亦不贩卖估作治产。欲得饮食从意应至。不传口教衣食屋宅悉为化生。如忉利天皆自然生不由胞胎。紫金为地。离垢意如来寿五百岁。其土人民亦复如是。亦有中夭。目连。欲知彼界如来讲说法者。岂异人乎。勿造斯观。所以者何。则吾身是也。佛之神足威变所为。则非一切声闻缘觉之所能及也

佛告目连。于斯三千大千世界。南方去此十八四大域。其四大域名曰宝成。而以三宝金银琉璃为地为树。有佛号曰宝体品如来至真等正觉。现在说法。但演宣示缘觉之法少声闻乘。诸菩萨学亦复薄鲜。及缘觉乘若使彼国土忽终没者。则生他方空佛境界成缘觉道。于目连心所忆云何。宝体品如来讲说经者。岂异人乎。莫造斯观。所以者何。则吾身是。如来于彼现威神变讲说经法。则非一切声闻缘觉之所及知也

佛告目连。于斯三千大千世界。西方去此二十二四大域。其四域界名宝锦。悉以七宝金银琉璃水精珊瑚琥珀车磲玛瑙合成土地。其境树木众宝化成。经行棚阁栏楯苑囿皆以七宝。其浴池中满八味水清澄且美。犹如兜术天上。诸天宫殿饮食被服。彼界人民亦复如是等无差特。又其土地无女人名。亦复不从女人生矣人民之类不兴秽浊。化生莲华结加趺坐。其土众生无淫怒痴。无贪欲想。无嗔恚想。无危害想。亦无胞胎。彼佛号曰宝成如来至真等正觉。现在说法。其佛所说不讲异义。但演菩萨法典之藏。总持金刚分别三场。奉修六度为极之行。彼无央数不可思议众生之类。皆发无上正真道意。不可计人得不起法忍。授无量人无上正真道慧其界无有二乘之名声闻缘觉之言行。纯有大乘无诸情欲。一切鲜洁而无秽浊。诸菩萨众充满世界。其佛寿命八万四千载。世人终后不趣地狱饿鬼畜生。不堕八难。斯诸菩萨若迁神命。即便往生清净佛土现在佛所。天龙鬼神阿须轮揵陀罗迦留罗真陀罗摩睺勒。心皆同一志一切智诸通之慧。不乐异义唯乐佛法。天龙鬼神形体被服。举动进止不可分别。唯名异耳。天龙鬼神及世人民。皆同一源无有异流。于目连心意之云何。宝成如来岂异人乎。于彼境界讲说经道。开发教化一切群黎。勿造斯观也。所以者何。则吾身是。斯即如来神足变化。则非声闻缘觉之所及知也。佛告目连。于此三千大千世界。北方去。是计三十六四大诸域。其四大域名无恐惧。黄金白银交成其界。彼土无有地狱饿鬼畜生之患难也。亦无八处之恐惧也。人民所行无犯禁戒及与邪见。志性礼节调顺无卒暴者。亦无外道众邪异学之名声也。佛号无畏如来至真等正觉。现在说法。其佛始往诣树下时。须摩提等七十二垓诸魔往欲与佛战。又彼如来为菩萨时。行无放逸成诸通慧。魔便遮往。应时如来随诸魔数化诸佛树。化诸菩萨其数亦尔。各各别坐于佛树下。时诸魔怪未曾有。何所为审菩萨身者。吾等当往妨废所兴坏其道意。诸化菩萨告众魔曰。一切诸法皆如幻化。于今仁者欲何所乱。假使卿等能分别了。发于无上正真之道福德庆者。若复劝助使发道意遮发道意。又来坏乱之罪衅者。卿等未曾乃复怀害。诸魔又问。发无上正真道意及劝化人。发大道者其福云何。菩萨答曰。正使江河沙等诸佛世界。满中七宝以用布施。发道意者福德超彼。又复正使江河沙等诸佛国土。所有众生悉共供养一切施安奉众学者恣其所欲。设复有人劝发道意德超于彼。又复问曰。假使有人乱坏道意其罪如何。诸菩萨曰。设复有人普取众生挑其瞳子罪宁多不。答曰。甚多。报曰。坏道意者罪过于彼。时无数亿诸魔之众。闻此言说睹大变化。皆发无上正真道意。皆以天华天香杂香散华烧香。奉诸菩萨。鼓诸音乐百千之数。各叹颂曰。愿令圣众疾得无上正真之道。时彼菩萨成最正觉寻有异天而举声曰。斯诸魔众皆脱恶趣乃发道意。如来为施无恐惧义。以是之故。如来名曰为无所畏。无所畏如来岂异人乎。莫造斯观。所以者何。则吾身是也。佛言。目连。佛变斯名于彼世界示现说法。是为如来威神之感。则非一切声闻缘觉之所能及

佛告目连。于此三千大千世界。东南去斯八万四千诸四大域。其域名曰普锦彩色。佛号众华如来至真等正觉。现在说法。彼四大域种种妙好八品珍宝以成为地交露宝幔。其地柔软如上妙衣。以珍为草自然四寸遍布于地。足蹈其上则便陷偃举足还复。其地平正犹若如掌。普锦世界有大城郭名曰上贤。人民炽盛安隐无患。米谷平贱快乐。不伦人民繁滋其城东西长千二百八十里。南北广六百四十里。上贤大城人民所居众多难计。复多于此安迦摩竭拘娄沙国。众华如来常游在于上贤大城。若一说法化三垓人得罗汉证。有三垓人至阿那含。有三垓人至斯陀含寂寞之行。有三垓人得道迹证。有三垓人化缘觉乘。又两倍人皆发无上正真道意。有无数人皆殖众德本。彼四大域其境界中。而有一树名蜜合成。常有华实其味甚美如百味馔。男子女人若取华实当食之者。昼夜七日饱不饥渴。颜容姝好色中改变。精气充满势力强盛形体轻便。食是已后亦不大行亦不小便无有涕唾。土不耕种贾贩求利。服是华实自然安隐。亦无贫富饮食居宅等无差特。又彼如来诸声闻等。六十四亿百千诸垓诸菩萨众复倍此数。而彼如来所游观园名曰普华。佛所食处。佛与声闻诸菩萨众。适坐饭顷寻时诸树曲躬作礼。有此华实自然来入比丘钵中。饭食已竟。有诸树木复重作礼复住如故。佛言。目连。彼之世界功德巍巍乃如是矣。众华如来则吾身是。今续现在。以此名号讲说经义。则非一切声闻缘觉之所能知也

佛告目连。斯三千大千世界。西南方去此七大四域。有四方界名曰选择。一一方域有八万四千国。一一国有八万四千王。一一王有八万四千城。其州域大邦郡国县邑村落。人民之众亿百千垓具足备满斯一切王弃去非法。一一王者有八万四千夫人婇女。一切婇女国中第一为真玉女。一一国王有五百子。或有千二百子者。一一诸王以正治国。不加鞕杖刀刃不设。各各教化不令而从。佛名释宝光明如来至真等正觉。现在说法。彼佛所游厥四方域精舍。香座高四丈九尺。一一座床香气流布。于四天下而雨天华。散于释宝光明如来上。百千伎乐自然和鸣。天地忽然为大震动音声如梵。积累功德不可称计。百千之福为转法轮。断诸尘劳泥洹无垢名曰将护。诸菩萨容如来说法为四大。八万四千王住在宫中。及诸婇女男女大小。闻了道义悉得远尘离垢诸法法眼生。诸王妻子中宫眷属悉发无上正真道意。皆同一音各自宣言。志愿出家。如来劝赞悉使一时同作沙门。若游郡国县邑丘聚村落。造行亦不种作自然生粳米。诸天悉来供养之。其佛第一讲法。诸声闻众皆得立于须陀洹果。诸菩萨乘皆逮信忍。第二说法得斯陀含果。诸菩萨乘皆悉逮得柔顺法忍。第三法会讲说经典住阿那含。诸菩萨学获致五通。第四说法立于罗汉。诸菩萨学得不起法忍。诸王中宫女子官属。皆转女身得为男子。斯诸如来悉授其决。皆当逮得无上正真之道。于意云何。彼界如来名释宝光明。岂异人乎。莫造斯观。所以者何。则吾身是也。以此名号于彼世界示现说法如来变动。则非一切声闻缘觉之所能知也。佛告目连。于是三千大千世界。西北方去此。五十五四大方域。有四方域号名香土。以上妙好栴檀杂香为阎浮提土地。有树名曰普香。一一树者香闻四十里。自然莲华大如车轮。有无数叶香气普流极柔软。好绝细彩衣色不可计。光耀炜炜生高二丈。一一莲华其香之气。遍四天下香周无量。香为重阁。香为经行。池生莲华。无有郡县国邑丘聚村落。惟有高台无央数千满其境界。犹如第六无憍乐天。自然之物人民之安。饮食游居等无差特。彼土如来说经法时。惟演清净诸大人教。舍于声闻缘觉之事。神通菩萨周遍四方。不可思议诸菩萨众。逮得法忍。诸菩萨中有菩萨名曰变众法王。志愿高妙获威成三。忍明神通辩才巍巍。供养稽首归命无央数亿百千诸佛。变众法王菩萨大士劝请世尊演说经典。佛即听之宣扬道义。即于佛前从座而兴高四百里。因从毛孔悉放光明普照世界。自然化生微妙莲华。其色像貌生无央数亿百千叶。遍布境界积四丈九尺。诸天伎乐不鼓自鸣。出八部音法印之声。一一法印总八十四亿经典之训。一一经典摄二万二千香气之敏言。从虚空中自然而建。九十六百千亿人立不退转。当成无上正真之道。皆逮得至不起法忍。诸菩萨众如是比像周遍彼土。其境人民无有盲聋亦无跛蹇。亦无恶色瑕秽之难。无贫匮者。斯众菩萨三十二相庄严其身。无有异乐以法为乐。亦不食饮服志禅定以为供养。彼无八处及与恶趣。假使寿终无有别趣惟归佛道。佛言。目连。于意云何。释贤光明如来则吾身是也。如来于彼变化感动。则非一切声闻缘觉之所能知也

佛告目连。于是三千大千世界。东北方去此四十二四方大域。有别大界名曰志危。其土人民淫怒痴盛。弊恶悭贪手执刀杖。无信嫉妒犯戒嗔恚。多为徙倚懈怠慢突。放心恣意而不安详。计有吾我贪人寿命。复无智慧不知时节。不晓羞惭志性卒暴而无恭敬。彼土众生颜貌变恶下劣卑贱。相求长短欲相危害。喜相骂詈诽谤相言。风雨不时邪辞相教。其地坚鞕粗恶之瑕。荆棘污秽周布土境。斯诸人民形体颜貌似冰麻油草木蓝色。衣服丑陋。饮食粗恶贫穷困厄。土石七凶人民憍念。是天宫殿人民之党。若得财宝悉没王藏。彼土人民遭众罚厄。加之杖痛一类无差也。佛言。目连。彼土人民。勤苦之患现在如是。假使命过终没之后悉堕地狱饿鬼畜生。其佛名曰心念愍哀如来至真等正觉。讲说经法现十八变而演典籍。七百岁中无有一人受法教者。其佛世尊不以懈厌。兴发大哀益加演经。其佛若入郡国县邑邦域村落。人民见之皆共骂詈诽谤。毁辱唾贱瓦石打之。彼如来尊欲开化故亦不退止。时佛复于七百岁中说经。八十四垓人皆得罗汉。得阿那含斯陀含须陀洹。各各亦复八十四垓。悉于一日出作沙门受成就戒。一切学者及不学者。于三月竟不乐余谈。一日之中皆般泥洹。又其如来续存处世。复有五人学菩萨乘。宿有余衅生彼佛土。遭勤苦恼佛为说经。目连白佛言。其土菩萨以何罪殃生彼土弊恶之处耶。佛告目连。菩萨以四事法。生于恶处受于恼患也。何等四。假使菩萨慕供养利。不学道法即生恶处。复次目连。菩萨又喜诽谤正法既自不学。又止他人令不受持。复次目连。菩萨呵折他人断不得共行诽谤之。复次目连。菩萨不护身口意者。以是四法生于恶趣而受恼患。佛言。在彼世界讲说经者则吾身是也。如来现变感动威神。则非一切声闻缘觉之所能知。目连白佛。如来至真。惟于此三千大千世界现作佛事。复于余国异佛土乎。佛告目连。今尔所见世尊示现与声闻俱。吾又复于斯三千大千世界百亿四大域。随人所乐察其本志各为说法。又佛于斯三千世界四方大域。以梵天色像说法。或如来像而现教化。或现白衣不着袈裟。或如帝释示现说法。或如四王转轮圣王。如是一切行权方便为说经典。如来于斯三千大千世界。各各随心之所喜乐。所应度者众生之类。而为说法开化之也。及在他方无量佛土。一切声闻缘觉之乘所不能知也。如日月宫而不动移。普悉现于郡国县邑村落丘聚州域大邦。如来若斯自于佛土而不动摇。则便皆现于无央数诸佛国土。随从群黎本志所应为说经典

目连白佛言。今所现佛。何所审实。忉利天上阎浮提者。诸天宫中三千大千域者。在他方异佛世界说法者乎。惟天中天当何因知审真佛者。施何所佛福祐大巨不可称限。佛告目连。吾今问尔从意报之。卿意云何。犹如幻师化造化人。为男为女何所审实。目连答曰。无有实者。天中天所以者何。幻祝术力化有所变。悉无所有不可别知。又问。目连。所可故化宁有所辩不乎。曰辩之。天中之天。佛言。如是一切诸法亦如幻化。不可别知等无差特。亦不作犹如幻师。任力祝术多所化变。所可化者等无差特。佛亦如是。以智慧圣而普示现诸佛国土。所造平等而无差特悉为佛事。其有供养斯诸佛者。建立福祐德量一等。诸佛世尊无有差别。是一切法悉无所生亦无有实犹如幻化。法异亦无差别。佛言。目连。如来发意之顷。以一毛孔现江河沙等如来至真三十二相。具足微妙自然颜貌。随形而化普为说法。而口宣示以六十音。一切如来晓了众生心之所行。众生群黎心之所好悉知根源。顺诸群黎而为说法。有所演说众生悉受则除苦患。斯诸如来皆以三品。感动变化说众经法。悉以四辩分别之慧皆现佛德。于目连。意所趣云何。何所如来为第一尊形像威容初最胜耶。化佛者乎。佛所化如来耶。目连答曰。无有尊卑。天中之天。所以者何。有所变动等无差别故也。是故无异。颜貌威容辩才圣达。神足说法有所度脱。不可分别言有差特也。佛言。是故目连。当造斯观。其有自然化现法者。无有差特不可别知。佛言。目连。设了诸法自然化者。则不分别言凡夫有异。况佛法乎。所以者何。目连。一切诸法悉本清净诸法皆空。人迷惑者反住众想为应不应。从其所喜而为驰骋其法界者亦无所起亦无所灭。法界平等如来善解。其有解斯。悉于阎浮提众生之类前。化现诸佛形像相好及诸比丘。而令人民无觉知者。置是目连。阎浮提人也。正使四方大须弥方域。诸天人民及余所生群萌伴党。如来现入一毛孔。于诸人中变化示现。及与圣众诸人各各不能相见。不知所入。置是。目连。假使三千大千世界众生之类。复令稍渐悉得人身。一切群生比丘圣众人民之党。如来普现于一毛孔。不能相知为何所入也。置是。目连。正所东方江河沙等诸佛国土。及于十方诸佛世界众生之类。无量世界一切悉变逮得人身。如来遍令一切人民及与圣众入一毛孔不使众生知为所入也。置是十方江河沙等诸佛国土群萌之类。佛言。目连。今佛现在无挂碍眼见诸佛国。能以具足圣达佛眼。引若干变而为譬喻。于百千劫说诸佛土不能究竟。诸佛国土不可眼量。又斯一切群萌之党。悉令得道犹如缘觉。不能计数称量知限。何况声闻。惟有如来。能知多少国土所有广狭。大小远近深浅毫毛分寸分了微尘。正使无量无限不可计会。江河沙等三千大千世界满其中尘。佛眼无极以无挂碍圣达。皆见。此诸佛国复过于彼。斯诸佛土所有群萌不可限量。人界若斯众生甚多多于地土。斯诸众生稍稍渐得为人身。一切悉为转轮圣王。一一圣王如彼众生眷属之数亦复如斯。一切圣王及与官属。如来悉能各各现入于一毛孔。及与圣众各不觉知不知所入也。各见如来一切毛孔普现佛身及与圣众。如来所现威神之变终不损耗。正使一劫不可计劫无量无限劫中现变。如来威圣道德之光不可称尽。巍巍神妙乃如是也。于意云何。诸转轮王及与七宝。所获功德宁增多不乎。答曰。甚多甚多。天中天。无量安住。佛言。目连。今吾告汝。如彼一切众生之类。皆为转轮圣王。与七宝福悉合集之。不及如来所造成满一毛之福。德善之庆超出于彼。无以为喻也

尔时贤者目连白佛言。惟然世尊。我得善利慧及余福。佛为法师圣尊。无限神妙乃尔。威豪无极明达。浩浩堂堂光辉无边不可穷底。又天中天。有所兴造无所损耗。于一切法靡不畅达。我以违失如是之像无碍之慧。其有众生得闻若斯佛之所为威圣之变。一心能闻一句义者。则得善利无极之庆。何况信持讽诵读者。便当具足如斯神足。发兴无上正真之道。如是等人。当为归命天中之天。无有恐畏不当复疑有向恶趣。尔时诸天龙神释梵四天王。从世尊闻佛所示现感动变化。异口同音而咨嗟曰。南无诸佛。归命世尊。假使有人能发斯心清净意者。吾亦归命为之作礼。兴隆大道亦当逮获。若兹变化犹若如来之所感动也。吾等不疑无犹豫结。时天龙神揵陀罗释梵四王五体投地归命斯经则以恭敬秽首礼佛。百千伎乐自然为鸣。散天青莲芙蓉茎华遍忉利天。佛说经时七十二垓天人。昔者以来未起道心。今皆发无上正真道意。各自说言。吾于来世于天上世间人民之前。当畅宣显大师子吼。亦如今日如来所为。兴发师子大吼之导

于斯月氏天白佛言。若有族姓子族姓女。受斯经典持讽诵读。广为人说得何福祐。佛言。假令族姓子族姓女。受斯经典持讽诵读为他人说。当值三宝而不断绝。所以者何。其闻经者不发声闻缘觉之心。惟志无上正真道意。所以者何。有学是经。其人则好微妙之义。诸根明达靡不信乐。是故天子。当造斯观。能受奉持讽诵读其经典者。为护三宝令不断绝。于天子意所察云何。其护三宝使不断者。设令千佛各寿一劫。宁能叹尽其功德乎。答曰。不能。天中之天。佛言。以故天子。当了知之。若有受持斯经典者德不可量也。于斯慈氏菩萨白佛言。是经名曰何等。何因持名。佛告弥勒。是经名曰忉利天品佛现感动威神之变。奉持之。佛言。慈氏。殷勤受持讽诵说者。若为他人分别解义多所成就。于众人民若斯像经。流布天下甚难得值。佛说如是。月氏天子。月上天子。慈氏菩萨。贤者目连。诸天龙神阿须轮。世间人民莫不欢喜。作礼而退

佛升忉利天为母说法经卷下


佛说阿阇世王经

    No. 626 [Nos. 627-629]

佛说阿阇世王经卷上

        后汉月氏三藏支娄迦谶译

闻如是。一时佛在罗阅只耆阇崛山中。万二千比丘俱。菩萨八万四千。一一尊复尊。诸菩萨摩诃萨。悉得诸总持。悉得无所挂阂欲。悉得无所从生法。而得如是三昧慧。悉得知一切人心之所行。如所欲以法教令各得其所。诸四天王及天帝释。释天及诸天子。龙．阅叉．揵陀罗．阿须轮．迦留罗．真陀罗．摩休勒．人．非人悉来会。时文殊师利在山一面异处。与二十五上人俱。何谓二十五人者。悉是菩萨各各有名。名曰若那师利。那罗达师利。三波师利。劫波头师利。波头师利。劫阇因陀楼陀罗尼陀楼罗陀波尼罗陀牟诃多私诃末师诃惟迦阇俱罗加那迦阇沙诃质兜波沈摩遮迦波栝镇遮萨。和波陀波坻盘拘利沙竭末摩诃。麑楼耆非陀遮阿难陀譬叉波贸耆罗耶阿难陀阿蓝惟诃罗摩抵吒沙牟迦抵陀阿喻达萨和頞悉。是为二十五上人名。四兜术天子来到文殊师利所。欲闻法故。其天子名沙摩陀鸠速摩罗。无拘速摩。漫那罗揵陀沙诃。沤术昙惟诃。是为四天子。复有异天子少少。来到文殊师利所。欲听法故。上人诸天子悉坐。各各说佛智慧甚尊。无有极不可议。不可度不可量。不可以凡而应僧那。皆言当何作法证方便而至无极智慧。乃至佛一切智不可议。慧首菩萨言。于功德无有厌。于诸功德无所悕望。作是者可至无极慧。惠施菩萨言。等心如寂。其心悦怿柔软。自随其教。便持萨芸若心。而坚固于僧那僧涅。作是者可至无极慧。具足平等菩萨言。不计校劫数。其当来劫无央数。不可以为计。是为僧那。于僧那不自贡高。作是者可至无极慧。具足行菩萨言。不自念安。可至无极慧。所以者何。欲令一切皆安故。作是念者。不求复悉安一切。作是者可至无极慧。莲华具足菩萨言。其不自伏意者。亦不能伏他人意。其能自伏意者。乃能伏他人意。作是者可至无极慧。莲华具行劫菩萨言。其有随欲者不可度欲。不随欲者是乃度欲。其菩萨者得利不得利。其心无有异。若苦若乐若谤若叹若恶若善。于是无所著。所以者何。亦不忧亦不喜。作是者可至无极慧。制持诸根菩萨言。不念他人作功德我可得。作是者不入无极慧。当念独而无有伴。所以者何。念于一切故。诸不办者我当办之。须臾精进不以懈怠。欲教一切。作是者可至无极慧。持行如地菩萨言。譬若如地一切草木药舍宅城郭。无不因地而住者。地亦无所置。一切仰而得活。亦不以为烦荷。菩萨者亦当如是持心。当若地亦不喜怒持心。当令一切各各得其所。亦不念还复。其作是者可至无极慧。宝愿菩萨言。当持心如尊不自卑。于梦中亦无二心。所以者何。无罗汉辟支佛意。其所作者。譬若如宝不离菩萨。若不失一切人心。于珍宝心无所贪惜。其从索者皆开导为摩诃衍。所以者何。无心与心等者。无心慧与是心慧等者。亦无所增无所减。其心无所贪惜。作是者可至无极慧。宝印手菩萨言。视五道生死人。譬如堕海。菩萨若心而愍念之。当以手授之。所以者何。为无黠者作黠首。其贪者为作无所惜首。其不持戒者为作戒首。其嗔怒者为作忍辱首。其懈怠者为作精进首。其乱意者为作一心首。其无慧者为作智慧首。其无功德者为作功德首。以功德首印三法宝。何谓三。令一切具足佛智慧教化而造作。自解其身珍宝功德。念一切诸法譬如空。是故为法宝之首。是为三。其作是者可至无极慧。师子意菩萨言。其身作是僧那者。无所恐惧亦不畏。亦不却亦不解衣。毛不复起。所以者何。于生死无有恶故。亦不作于泥洹。等住于苦乐不作二心。作是者可至无极慧。师子步过无惧菩萨言。其弱劣者不能逮此。是者大士之所作。所以者何。以舍众恶以不谀谄以应质朴。则不贡高无嗔恚之心。所作不从非法。所以者何。用忠政故则无淫嫉以无恶心。其愚痴若冥以无此者。其身口意以平等。所语如语不失其意。甚尊所作欲成。所以者何。用至诚故。俱以法自娱乐。以如法者不贪惜寿命。所以者何。不贪躯命不舍一切故。所施与无所贪惜。欲令人得其所故。所入者正则非邪道。其贫者为作珍宝藏。其有病者则为作医。其恐惧者则为作护。其劣者则为作道地。其入邪者则为作政导。其无智者则为作智。一切诸顺何所恨起意。大士以度脱此中忍。所受法本如住。作是者乃至无极慧。紫磨金色菩萨言。所念譬如空。所以者何。无所不遍。以大哀无所不覆。其心常喜面颊而悦。诸所欲乐者。其心不在其中。所施与譬如天无所不蔽。其戒忍辱精进一心智慧亦复如是。作是者可至无极慧。发意即转法轮菩萨言。其有新发意者。不当令魔得其便。不失诸佛天神意。作心住者以应法轮转。所以者何。用发好心故。所以者何。一切诸法无所生。其作是者可至无极慧。诸语自然普无不入菩萨言。当持心无所不入。所以者何。诸法自然其本悉空。一切所语皆空。譬若虚空无所不入。菩萨者当复如是。其心无所不入。有所作如语。其智无所不晓。其作是者可至无极慧。乐不动菩萨言。诸所有音无有音。诸所有声而不可得。以知是者亦不以喜。亦不以忧亦不懈怠。所以者何。譬若泰山而得风亦无所动。诸好音恶音。菩萨心亦不以喜欢。亦不以忧戚。所以者何。无所著。无所著谓佛语。若异道语俱空无所有。视诸欲有所作者皆有尽。以知尽而不贡高。作是法者疾成至佛。海意菩萨言。其心当如海所受。慧而无极。譬如海受于众流合为一味。菩萨以诸所有合为一法。所以者何。用微妙故。不与十二因缘有所变。念法身亦不增亦不减。为一切作功德。所作功德欲令一切皆得。是为不可尽功德。当护不着不断。以意力制身。诸所有所作皆等无有异。作是故发意慧者。具足可至无极慧。大光明菩萨言。当持心。其智慧其光明如佛。非俗人之所作。其意习光明无所不照。所以者何。欲令世间知以为法。则其意习施与光明无所不照。习戒光明无所不照。忍辱精进一心智慧悉习其光明无所不照。作是者可至无极慧。焰明菩萨言。以功德慧心为眼。清净所视色无有恶。声香味细滑法亦复如是。以净于六事。何谓六。眼耳鼻口身意。诸所可者不那中作乐。用心净故。所视人欲令悉入佛法。其不正者以法率化。所有好物人来索之无所爱惜。既与不从后悔。作是者可至无极慧。可意王菩萨言。其有骂詈挝捶者亦不嗔恚。但念其法。以何念法。何所骂者。何所嗔者。其挝捶亦尔。以内空无所得。于外空无所疑。身于身无所见。亦不见于他人。所以者何。其索手脚者欢喜与之。其欲取头者其心倍悦。若索城及珍宝。其有索者无所贪惜。其求妻子即持施与无有异心。若讽诵起是经得一章欢喜。不乐为金轮王欢乐。为一切人说法而不作释。愿乐造一人发心为菩萨。不作梵天。愿乐见佛。不贪三千大千刹土之珍宝。作是者常无懈怠。如是欢喜可至无极慧。所视无底菩萨言。视一切诸所有。不念是我所。悉清净刹土。不念有与无。见诸佛不想色求。所以者何。用法身故。视一切人心。不求一切人之所有。所以者何。其德眼逮得清净。便有道眼神足备具。以得慧眼便知所有无所可贪。便得佛眼。十八法悉具。以得法眼者具足十种力。其作如僧那僧涅者便至无极慧。作无底行菩萨言。一切所作如萨芸若所作。何以故。无所住故。以无所住但念诸法。菩萨作是者不以诸顺。何为堕。亦不以罪堕。亦不以魔事堕。所以者何。不舍法故。不犯非法以故致是。以度罪所作魔事。以应是者可至无极慧。说息爱意菩萨言。一切所有者。亦不从人受。以所作便唵嗒诸魔。以自知者无所有。亦无所复作。以知无所复作便制五阴。以知五阴者无有魔事。以度魔界者所作中道无所覆蔽。已度无所覆蔽。菩萨摩诃萨作是者可至无极慧。所起即悔菩萨言。诸所作非法意而悔之。所作如法其心无异。所以者何。常当专心作善。其身有所作。不欲令人不可。若口若意所作。不欲令人有不可。其有愁忧者以法宽大令不愁忧。作是者是为菩萨摩诃萨可至无极慧。得一切愿菩萨言。其有如净戒者所愿必得。以如净戒者不复犯俗。不犯俗者以应三十七品根林。如萨芸若。其以如净戒者不犯三十七品。是为菩萨摩诃萨所作以至无极慧。普等华天子言。譬若树有华。其见莫不欢喜。所作功德一切莫不蒙者。譬若忉利天上拘耆树。而有华炽盛。诸天莫不爱乐。菩萨以法为一切作眼。譬若华。若天上摩尼之宝而无瑕秽。菩萨清净其心如是。其作是者可至无极慧

光明华天子言。譬若如日出众冥索尽所有诸色悉见。菩萨以智慧无所不照。其诸愚痴冥尽索为开辟。所以者何。终不而当明故。其在冥者。见明便得道径。菩萨以住道径者。其忘失道径者。指示道路。以如是者可至无极慧。天香华天子言。譬如漫陀罗华。其香闻纵广上下四维各四十里。菩萨以所闻净戒三昧。持智慧以为香。三千大千无不闻者。是香愈无央数人病。其以所闻净戒三昧智慧。菩萨以住是者便至无极慧。信法行得天子言。当住法当所作者。以如菩萨法者常不复懈怠。无所复懈无复念。便当得十事。习六波罗蜜以四等心五句四事。总三脱忍辱利。令人发意。其身不离。以沤和拘舍罗教。悉持诸法要。所信无有异。是为十事。其作是者可至无极慧。文殊师利谓诸上人及诸天子。菩萨住无所住。何谓住无所住。于三界不以三界作习。不习者是为内。亦不求习者是为外。虽外不堕弟子无所习。复不堕辟支佛地。习谓生死。所学习谓无所知。习者是为名。所学习是为色。习者是因缘。所学习谓有所见。习者谓爱。所学习谓有所根。习者谓我。所学习谓非我。习者贪。所学习所施与无有异。习者谓犯戒。所学习谓不于戒自贡高。习者谓嗔怒。所学习忍辱而不贡高。习者无精进。所学习精进而不自贡高。习者谓乱意。所学习为一心而不自贡高。习者谓无知。所学习智慧不贡高。习者谓无功德。所学习谓作功德而不贡高。习者谓俗法。所学习谓道法不自贡高。习者谓无脱。所学习谓得脱而具足不贡高。习者谓有罪。所学习无有罪亦不贡高。习者谓有余。所学习无有余尽亦不贡高。菩萨习无所习。一切护亦不着亦不断。作是者便至无极慧。诸法一切无所得。所以者何。无所入亦无所不入故。是一切智便至一切智。无所得者一切智。得一切智不可以色计。痛痒思想生死识亦尔。不从法数亦不从非法数。亦不一切智施与为数。所以者何。施与者亦不离一切智。戒忍辱精进一心智慧亦不为数。何以故。一切智从智慧。一切智者无所不入。亦不过去当来。亦不入现在。所以者何。以过三世故。一切智者不以眼而视之。耳鼻舌身意亦尔。所以者何。以过诸界故。若男子女人欲求一切智者。当如一切智住。当云何住。于诸法一切无所住。是为一切智住。不自念法是我所。作是者为一切智。一切人法佛法等。如是无有异。是为一切智。其求欲得一切智者。会从四大得。所以者何。为身不作身计。所以者何。不以作因缘故。其有功德法无有功德法。其所有是为我所者皆非我所。我者无所生。无所生者无有计。其计者是为不生。其示若见者。是皆无有生。以知无生无所生慧。作是等者是为萨芸若。文殊师利说是事时。二千天子悉得无所从生法忍。万二千人悉发无上平等道意。乐不动菩萨谓文殊师利。共到佛所问菩萨当云何住。应时文殊师利。化作如来。在众会中而坐。其形状被服如释迦文佛。文殊师利谓波坻槃拘利菩萨言。属之所问。今佛在是。可问菩萨住。波坻槃拘利菩萨。不知是为化佛。前长跪问。怛萨阿竭。菩萨当云何有所住。化佛言。如我所作。菩萨当如是住。复问。云何如佛。其佛言。亦不从施与。亦不从戒忍辱精进一心智慧。亦不从欲。亦不从色。亦不从无色。亦不从身行。亦不从口行。亦不从意行。诸所行无所著故。其佛问波坻槃拘利。化者而有所从行不。则答言。无所从行。其佛言。如化无所从行。菩萨当作是行。波坻槃拘利菩萨复问。文殊师利是佛当无化佛乎。文殊师利答言。若自知诸法如化不。则答言。诸法实如化。文殊师利言。以知诸法化。何为复问如来化。文殊师利言。仁者。谓以诸佛悉化。则复问文殊师利言。佛者从何所化。文殊师利言。所作本清净。何以故而有化。文殊师利言。故佛无有吾。无有我无有人。无有寿无有命。亦不依佛住。亦不依凡人住。波坻盘拘利菩萨复问化佛。本何所学自致得佛。其佛言。无所学是菩萨学。何以故。亦不自念。我欲求是亦不求是。亦不忧亦不喜。亦不缘亦不所化。亦无所见亦无处所。亦无有想亦无有字。亦无有色。一切无所希望。是菩萨学。作是学者以为等学。作是学者无所著无所缚。作是学者无有欲无有怒无有痴。作是学者无所爱无所憎。其学是者不自念我作是学。是为学作是学。作是学者不堕恶道。其佛言。若有求阿耨多罗三藐三菩提心欲成至佛者。当作如我学。复问。何所是佛学。其佛言。亦不作罪亦不堕罪亦不所与。亦无所持亦无所不持。亦不持戒亦无有戒。亦不忍辱亦不恶意。亦不精进亦无懈怠。亦不禅亦不乱意。亦不智慧亦无所知。亦无所学亦不有所学。亦不所成亦无有所成。亦不菩萨亦不佛法。亦不自念有身。亦不念他人有身。其所见者无有想。亦不法想亦不无法想不想无想。其佛言。晓了是者。菩萨当作是学。所以者何。诸法一切如幻是为相。诸法一切皆合。所以者何。虽无央数事。念之皆空无所有合则为空。诸法不可见。所以者何。诸法等而无差特。诸法悉默。所以者何。不语不言。是故无有处所。何以故。诸法无所生。其信是者。亦不念所行。亦不念得脱。亦不菩萨自贡高。其佛言。若闻是学者。不恐不怖不畏。是故名为菩萨。譬若空不畏火。不畏风不畏雨。不畏烟不畏云。亦不畏雷亦不畏电。所以者何。是空法故。菩萨者当如是一切无所畏惧。菩萨心以如空者。乃伏众魔。便能为佛。能为一切作护。其化佛说是语竟便不复现。波坻槃拘利菩萨问文殊师利。今怛萨阿竭所凑。则答言。所从来处而所凑。所凑处从是来。波坻槃拘利谓文殊师利。其化者无所从来无所从去。何谓从来。文殊师利答言。譬若如化。来无道径去无道径。诸法亦尔。无所从来无所从去。波坻槃拘利复问。何所是诸法之处。则答言。自然住是之处。复问。一切何所处是其处。如所作是其处。复问。诸法无所作无有罪。文殊师利言。如是者诸法无所作无有罪。其法去亦无有作者。无有作罪者。诸所有悉入法身。则复问文殊师利。无有作无有罪。何以言人随其所作。文殊师利言。审如所问人亦无所作亦无有罪。所以者何。是人之法法身故。亦无有作。亦无有罪。如所作如所得。是三者等。波坻槃拘利菩萨复问。是三事等乎。文殊师利言。怛萨阿竭等。故三事适等。复问怛萨阿竭者。无作无罪无得。是三事何缘与等。文殊师利言。怛萨阿竭无作无罪无得。其作其罪其得。如所为以故等。其罪以过了不见罪。已过当来亦不离。怛萨阿竭故说。是时如在释迦文佛所。尊者舍利弗阿难及诸尊比丘。悉承佛威神。皆闻文殊师利所说。舍利弗言。善哉善哉。上人之所作。以法无所不感动。不离法身。其有智者闻是莫不发意。佛言。审如所语。菩萨者学无所学。所语平等无有异。如所种得其实。其菩萨者所学者慧。如是所说如慧。佛语舍利弗。汝若所学自致是慧。顶中光明菩萨白佛。何所声闻所学。何所菩萨所学。佛言。有限有着故为弟子学。无有限无有碍是为菩萨学。如声闻者其学小其智少。菩萨者学广大。其所知无有极。所说无所挂碍。光智菩萨白佛。唯怛萨阿竭作感应。令文殊师利众会悉来到是。所以者何。其在是会。皆令得无所亡失。所以者何。文殊师利所说甚深微妙。其欲闻者。随其所欲各令得所。佛即感动。文殊师利应时。与二十五上人及诸天子。俱到佛所。前作礼而住。光智菩萨问文殊师利。佛在是间。而若何缘得在异处而说法。文殊师利言。所以不在是间者。佛甚尊不可当。或所语可怛萨阿竭意。或不可意。故在一面。其菩萨复问。说何所法而可怛萨阿竭者。文殊师利答言。佛自知之。复言。虽尔会说其意。文殊师利则言。如我所知少当说。则言。何言是。文殊师利言。如所说所说法而不异。如怛萨阿竭。如本际而不可说。如法住如法说。为怛萨阿竭意。无所止无所断。亦不缘亦无所缘。亦无所增亦无所减。作是说而不失怛萨阿竭意。亦于身无所失。亦不令他人有所失。亦不亡法。亦不亡生死。亦不亡泥洹。作是说者亦不失怛萨阿竭意。佛言。善哉善哉。如文殊师利所说。以可怛萨阿竭意。所以者何。亦不过亦不减。适在中无所想。所以者何。文殊师利。俗三昧说事如故。不见诸法有所增者有所减者。如文殊师利所说。不失怛萨阿竭意。说是语时。八百天子。皆得无所从生法忍。尔时众会中。复有二百天子。皆前以发菩萨意。而未坚固皆欲堕落。各各有念佛法无有极难得至佛。我等不在菩萨学中。不如取罗汉辟支佛而般泥洹。佛悉知是人可成为菩萨。而中欲意转。佛便化作一迦罗越。持百味饭满钵赍。到佛所前而作礼。以钵上佛。惟加哀受之。佛即受钵。文殊师利便从坐起。叉手白佛。虽食当念故恩。舍利弗心念。佛本从何等。而文殊师利言当念故恩乎。则问佛。文殊师利本有何功德。而置怛萨阿竭。佛言。且忍。今为汝决狐疑。即以钵舍地。其钵便下没过诸佛刹直下过七十二恒边沙等刹土。刹土名曰沤呵沙(沤呵沙者天竺语汉言名曰明开辟)。其佛号荼毗罗耶(汉曰光明王)。今现在。其钵在彼佛刹住止空中。亦无持者。钵所过诸佛刹。其佛侍者皆问佛。是钵从何所来。诸佛言。上方有刹名曰沙呵。佛号字释迦文。钵从彼来。所以者何。救护堕落菩萨意故。以变化感动。佛语舍利弗。行求钵来。舍利弗即承佛威神。自以慧力入万三昧。过万佛刹亦不见亦不得。从三昧还白佛。求之不见不得。佛言。且舍。佛复谓大目揵连。行求索钵。则承佛威神。自蒙神足力入八千三昧。过八千佛刹。无所见无所得。则从三昧还白佛。求之不见不能得。佛语须菩提。行求钵来。则入万二千三昧。过万二千佛刹亦不见亦不得。即从三昧还白佛。求之不见不能得。则五百尊比丘。各各以神足行求索钵。亦不能见亦不能得。须菩提从座起白弥勒菩萨。仁者高才一生补处。现当来佛。吾等行求钵不能得。惟行求之。弥勒则答言。如若所说实一生补处。今者不及文殊师利。所作三昧及其名字。听我所言。我作佛时如恒边沙等悉为文殊师利。复不能知我行步举足下足之事。如今者实不逮及。不如报文殊师利而行求之。则须菩提白佛。唯怛萨阿竭。当令文殊师利而行求钵。佛即谓文殊师利。行求钵来。文殊师利即默声。以受教即自思念。而不起坐不离佛不舍众会。于是便能致钵。即时三昧为无所不遍入。即于众会以手指地。其手而下行。所过佛刹悉为诸佛接其足。下方莫不闻其声道。释迦文佛致问。其臂者一一毛放百亿千光明。一一明者有亿百千莲华。一一莲华上者皆有菩萨。其菩萨者皆各各叹释迦文佛。是所过刹土皆为六反震动。其刹土皆严庄幢幡而起。所过处悉皆见文殊师利以右手悉接诸佛足。皆言释迦文佛之所致问。过七十二恒边沙等刹。到明开辟刹土。乃至荼毗罗耶佛所。前作礼。为释迦文佛致问。其臂上毛一一毛有亿百千光明亿百千莲华。一一莲华上各有坐菩萨。悉叹释迦文佛功德。其菩萨光明彼佛光明。如不相错。各各自见光明王佛边有侍者。而尊菩萨名曰光尊。自问其佛。是谁手臂姝好乃尔。其毛光明莲华。菩萨之所歌叹彼佛功德。其佛言。上方过七十二恒边沙等刹土。名曰沙呵。其佛号字释迦文佛。今现在前。有菩萨名文殊师利。不可思议僧涅。其智无所不度。以续在彼佛前。坐用钵故而投手乃到是间。其菩萨悉作是念。皆白其佛。譬如渴人欲得饮。愿欲得见释迦文佛。文殊师利及其刹土。其佛即以两眉中央相而放光明。彻照过七十二恒边沙刹。乃至沙呵刹悉为开辟。其有人见其光明者皆得安隐。其身譬如遮迦越罗。其有凡比丘者。得须陀洹。其过三道上者。皆有人惟务禅。应时得罗汉。其菩萨身得是光明者。皆逮得日明三昧。荼毗罗耶佛刹诸菩萨。从彼间悉见是间。及诸声闻诸菩萨。以见是间刹土则而泪出。便言。若琉璃清净及其摩尼。堕其污泥诚可惜之。所以者何。沙呵刹土诸菩萨。诚可惜之。而生彼间。荼毗罗耶佛。谓波羁头菩萨。汝不晓是勿得说之。所以者何。我刹土千劫行禅。不如彼佛刹人行慈从日出至食。其所功德过倍是间。彼之菩萨虽有宿命。行法如弹指顷者。其罪尽索。是间菩萨悉问佛。是光明从何所来。今身皆安隐。佛则言。下方过七十二恒边沙等佛刹土。名沤呵沙。何佛者号字荼毗罗耶。放两眉中央相光明。菩萨悉白佛。愿闻欲见沤呵沙刹土及怛萨阿竭荼毗罗耶。应时释迦文。放足下光明。照下方过七十二恒边沙等刹。沤呵沙刹土及荼毗罗耶佛。尽为开辟。彼刹菩萨。见其光明入其身。悉得摩仳低三昧具足(三昧者天竺语汉解之名须弥光明)。是间菩萨尽见彼佛及刹。譬如在地住者。莫不见日月星宿。下方见是间。亦如是间见下方荼毗罗耶沤呵沙刹土。文殊师利以右手取其钵。与无央数拘利那术百千菩萨俱而来上。所过诸刹土。其莲华一一毛光明稍稍而尽。其钵便在手中。是间文殊师利。则从坐起为佛作礼。以钵授佛佛则受之。其菩萨从下上者悉作礼。各各自以佛名。谢释迦文佛。怛萨阿竭即时各令就坐。悉皆受教各各而坐。佛谓舍利弗。向之所问。用文殊师利所问故。今为汝说之。已过去无央数不可计阿僧祇劫。尔时有佛号字勇莫能胜。其刹名无常。尔时诸声闻八万四千人。菩萨万二千人俱悉会。其佛为三道家如说法。佛言。时怛萨阿竭勇莫能胜。于五恶世而作佛。有比丘名慧王。明于经法。持钵入惟致国中而行分卫。得百味饭若干种食。尔时有尊者子。名离垢王。为乳母所抱持。在城门外而住。其儿遥见明经比丘。欲从抱下。得下便取之求其食。比丘即以蜜饼授与之。其儿则食之。知味甘美。随比丘而行。不顾念乳母。便随至勇莫能胜佛所。则为佛作礼而坐一面。若那罗耶比丘。以所持钵得食。而与是儿令上其佛。儿则受之以上怛萨阿竭。其佛受食钵则为满。其儿所持钵食续如故。复以是食遍八万四千比丘。及菩萨万二千人。各各悉饱满。其儿所持食续复如故。佛以威神令儿欢喜。并蒙本之功德即为尽信。便前而住。即叹其佛。所持钵食而奉上。以应时满。其所持者亦不缺减。遍比丘及诸菩萨。其食续在。乃知佛尊亦不尽索。而复增益。其供养佛者。功德可重而增。佛语舍利弗。是儿以一钵食。乃至七日其食不减。满则如故。其佛阿波罗耆陀陀。教导其儿。自归佛及法比丘僧。授与五戒。教令悔过。劝助功德。乃发阿耨多罗三耶三菩心。其儿父母求索子无所不遍。乃至怛萨阿竭所。前为佛作礼而住。其子见父母。前为作礼而誉言。我今入菩萨法。用一切故愿复发意。所以者何。难值佛故。语其父母视佛相及其种好。其慧无所不遍。其道以度。愿欲我身令得作沙门。所以者何。难与怛萨阿竭会故。父母即言。善哉善哉。随子之所欲欢乐子之所求。悉如子之愿。吾等亦复发心。当从汝为法。则今悉放其舍宅。亦复效汝而为沙门。佛语舍利弗。是儿之所言。父母及五百人。悉发阿耨多罗三耶三菩心。悉于阿波罗耆陀陀佛所。皆作沙门。佛语舍利弗。汝之所疑者。即若那罗耶比丘者。文殊师利是。其时儿尊者子惟摩罗和耶者。则是我身。文殊师利以食与我。作其功德而令发心。是则本之初发阿耨多罗三耶三菩心恩师。佛语舍利弗。汝欲知其今佛十种力四事无所畏。其智慧不可议。悉文殊师利之所发动。所以者何。心则是根本。佛复语舍利弗。如我身等不可数阿僧祇刹土诸佛。悉为文殊师利之所发动。号悉字释迦文佛。如是佛数。复有号为提式沸佛。复有号式佛。复有号提和竭佛。复有号惟卫佛。佛语舍利弗。悉说是诸佛字。从劫至劫未有竟时。皆悉文殊师利之所发动。今现在悉转法轮中。有般泥洹者。中有行菩萨道者。中有在兜术天上者。中有在母腹者。中有生者。中有舍家求佛者。中有坐佛树下者。中有成佛者。犹不可尽。佛谓舍利弗。文殊师利者。是菩萨之父母。是则为迦罗蜜。属所问者。何缘而置怛萨阿竭。而我之所得。悉蒙文殊师利恩。以为是恩故。其二百天子即时自念。诸法学者乃可有所成。吾等尚可。所以者何。今是释迦文佛。为文殊师利所发意自致成佛。我等何为懈怠。用是念故其心则坚。悉得尽信阿耨多罗三耶三菩心。文殊师利。以手变化而得钵。无所不感动。是谓本之学习。从是刹土乃到下方。过不可数人。皆悉发阿耨多罗三耶三菩心。十方今现在诸佛。皆以珍宝华盖。用供养法故。悉覆三千大千之刹土。从其华盖尽闻其音。如释迦文佛之所言。皆文殊师利之所感动

佛语舍利弗。若男子女人欲疾般泥洹者。当发阿耨多罗三耶三菩心。所以者何。有人畏生死而不能发心。为阿耨多罗三耶三菩心。欲求声闻作阿罗汉早取般泥洹。其作是言者。我续见在于生死中。有菩萨而精进者。已成至佛。所以者何。以过去无央数不可计阿僧祇劫。尔时有佛号字一切度。寿一万岁。有百亿弟子。有尊比丘。名莫能胜。其智慧甚巍巍。后有尊比丘名得大愿。其神足甚亦巍巍

尔时怛萨阿竭。整衣服持钵。与比丘俱入常名闻国分卫。其尊比丘智慧备足者。在佛之右。其神足比丘在佛之左。有尊比丘名悔智。随佛后而侍之。八千菩萨而在前导。中有如释者。中有如天子被服者。中有如天者。中有如四天王者。皆悉令人治道。用怛萨阿竭故。佛语舍利弗。时佛以入彼城。道径而过于市。有三尊者子。各各尚小。庄严被服甚姝好。而共坐戏。是一儿遥见佛且来。及诸比丘菩萨光明甚巍巍。其小儿谓二儿。以手遥指示之。乃见怛萨阿竭来。光明与相随者不甚好乃尔。其二儿则言。以见之。是一儿便言。此者一切之中。极尊而无与等者。吾等当供养。所以者何。其福无量。其二儿则答言。亦无华香。当何以供之。其一儿则脱着身白珠着手中。便报谓二儿。是犹可以供佛智者。见怛萨阿竭。不当作贪。则其二儿。效解取着头上白珠着其手中。即各叹言行至佛所。譬若度水。所以者何。以其心净而等住故。是一儿复问二儿。持是功德以何求索。其一儿言。愿如佛右面尊比丘。其一儿言。愿如左面神足比丘。是二儿各各有是愿已。复共问一儿。若愿何等。即报言。我欲如佛其光明无辈。如师子独步。常有众而随我。是儿作是说时。虚空中八千天子皆言。善哉善哉。如若之所言。天上天下一切蒙若恩。是三儿相将来至佛前。其怛萨阿竭。呼侍者沙竭。汝乃见是三儿而持白珠来者不。其中央行小儿。悦心精进来行。举其一足时。却其罪百劫。如下一足。后事事当更百遮迦越罗。如是数当复更释亦如是。其梵天亦等如是。其一举足之功德中百见佛。语适竟。是三儿已到。前为怛萨阿竭作礼。各各以其白珠散佛上。其二儿发声闻意者。所散珠各在佛上肩升。其一儿发阿耨多罗三耶三菩心者。而散白珠在佛头上。而在虚空化为珠华交露之帐。正等而四方。中有床。怛萨阿竭而坐之。其佛则时笑。沙竭勃问佛。怛萨阿竭所笑。会当有意。愿闻其说。佛言。见二儿发声闻意者不。所以者何。皆畏生死之惧故。是以不发菩萨心。所以者何。欲疾般泥洹故。其侍者问。其一儿当云何。佛复谓言。是中央儿以后自致成佛是二儿乃为作声闻。其一者智慧甚当尊。一者神足亦复尔释迦文佛问舍利弗。汝乃知是中央儿不。舍利弗言不及。佛言。则我身是。乃知右面之儿不。舍利弗言不及。尔时之儿。则舍利弗是。其左面之儿。则大目揵连是。佛谓舍利弗。汝等本畏生死故。不发菩萨心。而欲疾般泥洹。观其一儿发阿耨多罗三耶三菩心者。今我自致成佛。如汝等不离吾法。而作声闻乃得解脱。佛复谓舍利弗。其欲疾般泥洹者。当发意求佛如我。向之所说其疾者。无过萨芸若。所以者何。无所挂碍故。用持尊故。用无尽故。用阿耨多罗三耶三菩心故。莫能有及等故。持有好故。以过诸声闻辟支佛故。其欲作者。便得萨芸若意。亦复如是。说摩诃衍品时。万人悉发阿耨多罗三耶三菩心。其一一尊比丘。舍利弗摩诃目揵连阿难舍比摩诃迦叶蠡越难头耶和致难离分耨头陀须菩提等。悉以头面着佛足。皆誉言。若男子女人欲求道者。当发尊意。所以者何。如佛百千以法为吾等说。不能复发作菩萨心。皆而有悔为罗汉故。不如本作五逆恶。其罪犹有解脱。可发心为阿耨多罗三耶三菩心。今者以无所益。所以者何。惟烧佛种故。其器者以不堪菩萨心。所以者何。譬若死人无益于生者。今吾等以得脱无益。于天上天下有两足若四足者。皆依地而得活。其有发心为阿耨多罗三耶三菩心者。诸天及人皆蒙其恩

尔时阿阇世王。乘四马车与群臣俱出。而到佛所前为作礼而住。白佛言。一切人从何因缘而作罪。佛语阿阇世。以住吾我人者便作罪。贪身故而有身用。是故不离其中。阿阇世王复问。助贪爱者根为在何所。佛言无黠是。则复问。谁是无黠根。佛言。所作与念异。是故根。复问。何所与念异者。佛言。其本异所作谓是。复问。本异者何谓是。佛言。如幻所化无所有是故异。复问谁化者。佛言。无有造者是故化。复问。无所生无所有。当云何计。佛言。用无有生无所有故不可计。复问。所疑从何因缘起。佛言。无所据故。何谓无所据。佛言。如所说闻之则疑。是谓不据。复问。何所是道何所为信。佛言。脱于淫怒痴是为道。何所是信。佛言。不得诸法根本。其心不异是故为信。阿阇世王即言。善哉善哉。如怛萨阿竭所说。一切人所以不信者何。自作故。今我用恶人之言。敕令臣下自杀其父。用贪利国故。用贪财宝故。用贪利宰民故用贪利尊贵故。今我使臣下而害其父。贪身狐疑不能自解。若饮若食在戏乐。若在正殿听省国事。若在中宫五乐之欲。若独与众俱。昼夜而不忘。饮食则不能消。亦无其卧。颜色亦无和悦。时其心常怖据。知不离于泥犁。则复陈言。若盲者承佛所得眼目。若为水所溺者依佛而得脱。其有苦痛者佛而令得安。其有恐懅者佛而为作护。其有贫穷者佛能为作珍宝。其有失道径者能示于道路。佛以加大哀不以为勤剧。等心于一切坚固而作厚。常忍于苦乐不舍于一切人。今我身而怖懅。惟佛当加护。令危者而得安。身无有能救者。唯愿而得济。无所归者唯愿受其归命。譬若无眼目唯得而视瞻。如人之欲躄惟令而得往。今当入阿鼻乃至大泥犁。愿令得不入。惟怛萨阿竭今当为我解说吾之狐疑。令心而得开至死无余疑。令重罪而得微轻。佛念阿阇世王。其所说甚深而微妙。是病莫能疗之者。独佛文殊师利而有感应。舍利弗承佛威神。谓阿阇世。欲决狐疑者明旦作食。请文殊师利等。令到其宫受之者。其若之官属皆当得其福。并罗阅国诸民。皆因是功德可而为本。阿阇世王则白文殊师利。惟加大恩。明旦屈德就宫而食则文殊师利答言。以足可为供养已。文殊师利复言。佛法非以衣食故。阿阇世即白。当何以施之。则答言。若深入微妙。其事审谛无所污亦无所著。亦无所疑无所难。无所畏无所一惧。如是者以为得哀。文殊师利复语阿阇世。念诸法。亦不念有亦不念无。是者以为得哀。不当念过去意。亦不当念当来意。亦不当念现在意。作是者以得加哀。汝不当念一切之所可见者。亦不诚作是者以得加哀。阿阇世王复白文殊师利。如所言。悉法之所载无有异。惟以身故当加哀受其请。文殊师利复言。且止。其道者非以是故。若饮若食。若王不念有吾有我寿命人。以念是者以得加哀。若心无所持亦无所缘。亦不四大亦不五阴。亦不六衰亦不持三界。亦不于功德亦不念无有功德。亦不于俗亦不于道。亦不于罪亦不于无罪。亦不于余亦不于无余。亦不于脱亦不于无脱。亦不于生死亦不于泥洹。作如是者以得加哀。阿阇世王复白文殊师利。闻如是法倍复踊跃。以是故欲请之。令我缘是而得安隐。文殊师利答言。汝希望有所缘欲得安隐。是以不缘则无安隐。所以者何。因其法无所缘无有安。不念是亦不贡高。一切无所念。是故缘是故安。于是中无恶意。后复无灾变者。后有灾变者是则不安。从本至竟无有异。是乃为安。阿阇世复问。说何所法而无异可得安。文殊师利言若空无作者。无有能作者。无有想。无有愿。无有作。亦无有作者。其有念我有所作无所作。是故为异。亦不求无所缘。身口意是为作。所以者何。无生死想。是故诸法若有所缘。当知悉无所缘。阿阇世复问。何谓生死无生死。则言。不念过去以尽。亦不念当来未至。亦不念今现在而无常。于诸法不念有所增有所减。作者是生死则无生死。阿阇世复问。未脱者当云何与道合。文殊师利言。汝知日明与冥合不。阿阇世言不合。所以者何。日出众冥晦灭。文殊师利言。王宁知冥何所去处乎。答言。不见可处而在何所处。文殊师利言。所谓道智来时。譬若日出不可知众冥所在。如是时亦不知未脱所在。文殊师利复言。道与未脱等。未脱与道等。何以故俱空故。未脱与道等故。诸法平等。其知是者未脱则为作道。何以故。求不脱不知处。是故曰道。其求不脱处而不可见。是则道。阿阇世复问。云何不脱而为道。文殊师利言。于不脱是为道。不作是者为道。阿阇世复问。其道者当云何学。则答言。如学诸法。阿阇世复问。以学诸法宁有处所不。文殊师利言。作是学道不可至。阿阇世复问。其学者当至泥洹不。文殊师利言。乃有法从泥洹来。言我从泥洹来。阿阇世即言。亦无往者亦无来者。文殊师利谓阿阇世。其学道知无处所。是故道。阿阇世复问。当何所住道而学作是。则答言。无所住是为学道。阿阇世复问。其学道者不作净戒三昧智慧住。即答言。其道若不缘戒不求三昧。不贡高于智慧住。文殊师利谓阿阇世。乃可缘戒求三昧贡高于智慧。作如是则有住处不。阿阇世言无。文殊师利言。故当如道无所住。阿阇世复问。若男子女人。当云何自前于道。文殊师利言。其欲学道者。不见法有常无常。不见法有脱无有脱。亦不见法安若苦者。亦不见法是我若一切人。亦不见法在生死至泥洹者。作是学道者为以前。阿阇世王即言。善哉善哉。如文殊师利菩萨之所言。惟愿受其请。所以者何用狐疑故。熟自思念。如诸法无吾无我无寿无命。而我有狐疑。文殊师利言。如无者不可令有。以无者亦不脱。亦无所脱。其说我者而有脱者。以无有脱者亦不脱。亦无所脱。所以者何。诸法悉脱故。佛谓文殊师利。受阿阇世王请。用无央数人故。文殊师利则言。惟受怛萨阿竭教。所以者何。不违教故。阿阇世则踊跃欢喜。便从座起。为佛诸比丘及文殊师利。作礼而去。阿阇世行。且问舍利弗。文殊师利等辈者几人。舍利弗言。五百人悉令于宫食。便从道归于城。即敕大宫令作百味之食。即日治其殿上。施其幢幡帷帐华盖。以华布其地。悉持名香而熏之。设五百高床。皆布名珠琬[王*延]其色若干。合宫之内悉皆治严。以华香遍之。敕令城郭诸街市里。皆而扫除以华香从之。道边者皆施帷帐幢幡而起除之。其里之门皆施双结华。令诸人民明旦皆当道迎供养。文殊师利即初夜。文殊自念。我与少少俱出至请。亦无他感动。乃可到他方刹土请诸菩萨。往到彼所令就请。复悉听其所说法。作是念时。应时如伸臂之顷。便从是不现。到东方过八万二千佛刹。其刹名常名闻。其佛号字惟净首。今现在有众菩萨无异道。其刹土常转阿惟越致法轮。其土诸树悉皆众宝。其叶花实无央数色。风一起时吹其诸树。但闻佛音但闻法音及阿惟越致僧音。用是常闻三宝声。故其刹土名曰沙陀惟瞿吒。文殊师利已在彼所。为佛作礼。白其怛萨阿竭。愿用我故。尽令菩萨到沙呵刹土。至阿阇世所而就食。佛则谓之。其欲行者便可往

佛说阿阇世王经卷上佛说阿阇世王经卷下

        后汉月氏三藏支娄迦谶译

应时二万二千菩萨。同共发声。我等欲与文殊师利俱行。即时如其数菩萨。与文殊师利俱行。忽以在沙阿刹土其处而坐。其处者谓室中。所以能容者。是菩萨威神故。悉共坐已。文殊师利说其法。其法名曰陀邻尼。文殊师利谓诸菩萨。乃知何所法名陀邻尼者。而言解一切诸法故。其意无所望故。所作无有异。所念应时足。所知如智慧。其法者悉知其本。所语如谛。自护不堕。用转上故。悉入诸法行。陀邻尼者则道之元。不断佛元。持法之元。总持僧之元。于诸法无有殆在人之所问。即能知报答。见众而不却。所以者何。无所畏故。欲教化诸天。随天之所欲而悉教之。令各各得解。及龙．阅叉．阿须伦．迦留罗．真陀罗．摩休勒．人．非人及释梵。下至一切诸虫兽鸟兽。各各知其意随其所欲。而悉教化令得其所。悉晓了有功德无功德者。尽知一切人之行住其心譬如地。于世不以八事。中有顺何所作功德。不离于道教照于人随其所乐。令一切皆蒙其恩。所作戒令一切悉在中。其慧无所不遍入。为一切之所重。而不以为勤苦。其心无有异其法者知而本所教化。承其教。常以法而施与不以为厌。所说法不望当得。其复不断菩萨善根本。所以者何。以精进而养成其根故。所施与不以为厌足。用萨芸若故。以戒不以为厌足。所以者何。恭敬一切人故。忍辱不以为厌足。便逮得佛身故。以精进不以厌足。合会诸功德故。以禅不以为厌足。无所悕望故。以慧无厌足。所以者何。无所不念故。以法为奉禄。而自依为得活。一切无所豫。其如是者是故为陀邻尼。陀邻尼者。悉总持诸法故。云何持。空无想无愿。无欲无所著无所见故。以是持无所生无所造。为作是持法。亦不来亦不去。亦不住亦不乱。亦不趣亦不坏。亦无所持亦无所掌。于脱不想脱。亦无所住亦不当住。亦无吾亦无我。亦无寿亦无人。亦无所执亦无放。亦不诚亦不虚。亦无所闻亦无所见。亦如虚空无所称举。亦无所触亦无所觉。持一切诸法。故曰陀邻尼。复有陀邻尼者。持诸法如幻。譬若如梦若野马。譬若水中聚沫如水泡。譬若化。悉持诸法。故曰陀邻尼。复有陀邻尼。以无常持诸法。若所见无我而寂。诸法根本悉脱其中。于法无所诤。亦不堕亦无期。以是持一切诸法。故曰陀邻尼。譬若如地无所不持。不以为勤剧。菩萨以逮得陀邻尼者。为一切作本。阿僧祇劫诸所作功德。悉能合会发萨芸若。心无所不持。亦不放亦不以为烦。所以者何。若地为一切之所载仰。菩萨以逮得陀邻尼者。饶益于一切。若树木万物因地而生。菩萨以逮得陀邻尼者。悉生诸功德法。譬若如地。亦不动亦不摇。亦无所适亦无所憎。譬若如地受一切雨亦无厌极。菩萨以逮得陀邻尼者。一切诸佛菩萨声闻辟支佛所问法。亦无厌足。为一切说法。亦无厌极。譬若如地含果诸种皆得时出。菩萨以逮得陀邻尼者。悉含果诸功德法种。亦不失时。辄如时具足诸法。乃坐佛树不离萨芸若。菩萨以得陀邻尼者。勇猛如将。兵中之率无所不伏。菩萨以逮得陀邻尼者。坐于佛树降伏众魔。故曰陀邻尼。复有陀邻尼。于诸法无所持。何以故。于有常无常故。亦无乐亦无苦。有身无有身。无有人无有常。一切诸法无所持。所以者何。无有二心故。譬若如地不持空。陀邻尼。一切诸法无所持。譬若空不持有所有。陀邻尼者。于诸法亦无所持。譬若水不持诸垢浊。陀邻尼者。于诸法亦无所持。譬若有所至无处所故。陀邻尼无所持故。陀邻尼者。不可尽无有尽。不可度故无所不入。无所不入故是为空界。陀邻尼与空等。说陀邻尼时。五百菩萨。悉得陀邻尼法。文殊师利。于二夜说菩萨藏。诸法莫不从是。若功德法若无功德法。若俗若道。若有罪若无罪。若有余若无余。若脱若不脱。一切尽入是藏。何以故。用诸法故。无所不得故。譬若三千大千刹土。含受百亿国土。百亿日月。百亿须弥山。百亿大海。尽入三千大千。亦不凡法亦不道法尽入其中。声闻辟支佛法若菩萨法尽入其中。何以故。悉总持诸行故。持声闻持辟支佛持菩萨。若如树其根坚住者。本茎枝叶华实皆而成好。菩萨藏者无所不持。无所不成。一切持诸功德法。悉持萨芸若心。其菩萨藏者。若器名曰受不可数。譬若海含受众水受持珍宝。龙阅叉揵陀罗真陀罗摩休勒无不苞裹。为一切作其处。其藏者因缘不可数亦如是。受无数戒。其间三昧智慧所见。其器无所不受而见。故曰菩萨藏。譬若如海。其往生者不饮余水。所以者何皆因海故。其在是藏者。皆因是法不在外道。所以者何。尽受萨芸若法味故。故曰为菩萨藏。是为三藏。何谓三藏。声闻藏辟支佛藏菩萨藏。声闻藏者从他人闻故。所以者何。闻其音故。辟支佛藏者。缘十二因缘故。以因缘尽而致是。菩萨藏者。入无央数法。而自然逮成佛。其声闻若辟支佛。其三藏者。非声闻辟支佛所有也。说是法时。其三藏者各得如所行。所以者何。说是法时。其声闻辟支佛菩萨各得其行。故曰三藏。其逮得菩萨法者便有三藏。所以者何声闻辟支佛不离佛法故。复有三藏学。何谓三藏。有声闻学有辟支佛学有菩萨学。声闻学者用有度故。但自明故。辟支佛学者是谓中学。无有大哀。菩萨法不可度入法身故。用大哀故。声闻者不学辟支佛事。亦不了辟支佛事。辟支佛不学菩萨事。亦不了菩萨事。菩萨者知声闻所学不以为乐。不于是中有所悕望。亦不于是中而求脱。亦知辟支佛所学不以为乐。不于是中而求脱。而知菩萨所学。乐于所学而自欢乐。当因于中得脱故。教声闻而示现。以其行教化之。其辟支佛亦尔。是菩萨作。故名曰菩萨藏。譬若以器受其琉璃。用琉璃故。其器亦作琉璃之色。菩萨以逮入藏者。以诸法所见不离佛。菩萨以逮藏者。诸所见法悉见于佛法。菩萨悉无所不学诸法。所以者何。无有异所见。诸法悉如佛证。其菩萨藏者。无央数字而教不可度处。所以者何无增减故。不可议光明悉照于冥。所作者有慧利无有极。入萨芸若无所不入。其学是学乃为学。悉入藏故便入摩诃若那。摩诃若那者无极慧。以入者其未入者而入之。尔时文殊师利。为诸菩萨说其藏事已。复于三处说阿惟越致轮金刚行。说是时其闻者悉逮得是事。其轮者亦无所转。阿惟越致轮者。无所悕望。于一切其心无有异。所以者何。不念善恶。以等心学法。见诸佛刹亦复等视。不着其好丑。以诸佛等无有异。其轮者无所不遍入。所以者何。不坏法身故。以是故为阿惟越致法轮。其轮者无断绝处。所以者何无二心故。其轮者如所见。何以故。以法轮致佛故。是名曰阿惟越致法轮。其从阿惟越致轮者。悉以脱诸想故。其信是者悉当得如佛。不以二事故。从一事脱所说。如怛萨阿竭所因。脱其脱者无想无想。是故诸法其有想无有脱。何以故。其脱无有二。所以者何。无身口意故。所以者何。其脱者亦不从身口意故曰脱。作是者以为自从不从他人。故曰阿惟越致轮。其轮者不转色。所以者何。其色自然故。痛痒思想生死识亦不转。所以者何。识自然故。一切法亦不转。所以者何。法身无法转故。是曰阿惟越致轮。其轮者所入无有际。何以故。无有断绝故。其轮亦无所著。亦无有断。何以故。其轮无有门故。所以者何。不二心故。其谛亦无转者。所以者何。不可说故。其轮亦无有能解者。所以者何。亦不有其音。何得见其形。故其谛以空可致其脱者。莫能有逮。譬若如空无所不入。何以故。无所不入。用脱于本故。其轮者亦能行亦能步。何谓行何谓步。如金刚钻穿众宝。云何可以钻穿其法。譬若以空钻穿一切。所以故是名曰法。为无所想。是故金刚。所以者何。钻穿一切诸所求故。无愿者若钻金刚穿。诸所未脱令而得脱。法身者若金刚。诸所乱者而空理之。怛萨阿竭者如金刚。悉穿无所有。其脱如金刚过于诸不脱者。泥洹者见诸自然法。文殊师利为诸菩萨。说是阿惟越致法轮时。菩萨悉得罗毗拘速三昧(汉言者名曰日光明花)。得是三昧已。其菩萨身一毛者。放亿百千光明。其一光明者。见坐亿百千佛。一一佛者到他方。其求佛道而往教化

明日旦阿阇世王。遣使者到文殊师利所。唯哀用时与等人自屈。摩诃迦叶时与五百比丘。俱欲入城而分卫。以行道半念尚早而旋。还与比丘俱过候文殊师利。以到所习住于门外。文殊师利问摩诃迦叶。今早欲到何所。则言欲行分卫故。文殊师利复谓摩诃迦叶。我今与汝分卫。摩诃迦叶则言。已具足为供已。所以者何。以法到是不以食故。文殊师利谓摩诃迦叶与诸比丘。俱就是当用法故。亦当用食故。所以者何。今亦不失其法。亦令不失其食故。合两以作一。摩诃迦叶则答言。吾等常当忍不食当听其法。何以故。二诸深法常从是闻。摩诃迦叶则复问。今日与诸摩诃萨俱而食。文殊师利言。今所食处其人亦不离生死。亦不入泥洹。亦不过欲事。亦不以道证。所食处其食亦无所增无所减。亦于诸法无所持亦无所舍。摩诃迦叶言。其作是施与者。是为无极施与。则言诺受所请。文殊师利则自念。今当入城。所作当如佛之感动。作是念时。便得无所不感动三昧。则时沙河刹土平等如镜。诸丘墟山陵一切不现。其光明无所不接。其在泥犁勤苦。其痛则除悉得安隐。是刹诸人。用是时悉无淫怒痴。亦无妒心。亦无贡高。亦无起意。尔时诸人皆有慈心。展转相视若父若母。应时地为六反震动。诸欲天子诸色天子。以百种伎乐而供养文殊师利。并雨天华而散其上。从文殊师利所止。乃到城门尽索治严。以众华结为交路侠道两边。以名殊华悉布其地。已众绝宝而为帐幔覆盖其上。其道广六丈三尺。两边悉有栏楯。以众宝化而作树。间间行列侠道两边。则以宝作绳。縺缚诸树展转相连。其一树者香四面闻四十里。两树间化有水池。周匝其边悉有众宝以为拥障。以琉璃为饰。其水之沙沙者悉金。其水有八味。众华悉生其中。凫雁鸳鸯而走戏其间。一一树下当其根上。而有众宝之垛。其垛上者皆以珍宝而为香炉皆烧名香。一一垛者其女百人。各以莲华擎持栴檀名香。文殊师利作是三时。其威神无所不变化。文殊师利从座起着衣服。谓摩诃迦叶。便而前行我今从后。何以故。其年尊老故。复先佛作沙门。以是故当在前。摩诃迦叶则时答言。其法者亦无前后。不计年岁而有尊幼。文殊师利言。当行谓为尊老。摩诃迦叶答言。智慧是尊。学问甚多。是则为尊。在所作为。是则为尊。索知一切人之所行。是则为尊。摩诃迦叶复言。文殊师利亦有智慧其问具足。在所作为。晓了一切人之所行。以是当为尊。摩诃迦叶复言。今若其年亦复为大。亦复为尊。故当在前。愿乐在后。今欲说譬喻。唯愿听之。若师子之子。其胆势气力不如于大。虽小蒙大者之香。诸禽兽闻其臭者莫不恐怖。譬若大象而有六牙。其岁六十。若人以革而为绳缚系其象。师子之子于革绳之所。大象闻之嗅便犇走入山。虽菩萨发意未成力势。非声闻辟支佛之所而当。众魔莫不惊动缩腰而怖。其师子之子见大者而鸣呼。有所作为。其心不恐亦不畏懅。所以者何倍复欢喜。今如是菩萨见佛。有所作为。其心不恐亦不怖懅。所以者何倍复欢喜。今我敢亦当如是。舍利弗言。欲计其尊者。若声闻若辟支佛。其发菩萨心者。是则为尊。所以者何。其有所求皆从菩萨心而起。摩诃迦叶言。故文殊师利。以是为尊。仍当在前。吾等承后。文殊师利便在前。诸菩萨在后。声闻悉从亦在后。便向道。天则雨华。地为六反震动。诸天于上以伎乐而娱乐。应时光明一切莫不明者。便至罗阅只。未入城门。王阿阇世闻文殊师利旦到。从菩萨二万二千五百人。其比丘者五百人俱。王自念。吾作五百人具。今当云何供。当坐何所。应时天王名曰休息心。与尊阅叉名曰金鈚。与俱而来。与阿阇世王相见则言。勿恐勿懅。勿以为难。则答当云何。而不以为难。则报言。文殊师利者作沤和拘舍罗无极智慧。以功德光明具足而来。神足功德。其以一饭与文殊师利。若有三千大千一切人索饭食者。悉能饱之。其食不尽索。是二万三千人何足可忧。是故勿以为难。所以者何。今皆可而悉足。文殊师利者其功德甚尊。而不可尽。阿阇世王应时而欢喜。其心无异踊跃倍喜。而设所作便将伎乐。擎其华香而自出。迎文殊师利等而俱入宫。时于菩萨中有一菩萨。名曰普视悉见。则文殊师利敕三摩陀阿楼者陀。令严治其处可容来者。其菩萨受教。应时四面而视占。则时悉以办。于众会中复有菩萨。名曰法来则得敕令而具床座。应时受教掸指顷有二万三千床座。其綩綖若干种色。名珠好绣绮异色物悉布在上。文殊师利及诸菩萨声闻。一切皆悉就坐。阿阇世王前白文殊师利。所作供具甚少。愿忍须臾。今更欲办其具。则答言。所作已可自足。勿复劳意。天王。惟沙门与家室仆从悉来而谒。皆恭事左右。释提桓因自与大夫人名曰首耶。及与天女。皆持名香供养。散文殊师利及诸菩萨比丘僧上。其诸菩萨亦不以天女。亦不以伎乐。亦不以华香有所转动。梵天而自化作年少婆罗门。甚姝端正。持扇住文殊师利之右。侍而扇之。诸梵天子悉复供侍。诸菩萨比丘僧。住于之右持扇而事。阿耨达龙王其在众会虚空之上。而无见者。持把贯珠垂若幡。从其贯珠其水流下。水有八味。若欲所作当悉取是水。文殊师利及诸菩萨比丘僧。人人前有垂珠。水从中出悉给所当得。阿阇世王复念。诸来会者而不持钵。今当以何器而食之。文殊师利知王之所念。则言。菩萨者不赍钵行而所食处。念钵便从其刹土钵自而来在其手中。阿阇世复问文殊师利。是诸菩萨悉从何刹土而来到。是其佛号字文殊师利。则言。其刹土名沙陀惟瞿吒。其佛号字惟首陀尸利。从彼间而来到是食于仁。所以者何。故来欲闻法听仁之所狐疑。诸菩萨念钵。应时钵而飞来。行伍而到阿耨达。皆自净洒盛满其水。诸龙婇女皆擎持二万三千钵。而来授与瞿吒刹土菩萨。人人着其手中。阿阇世住侍文殊师利。文殊师利则谓阿阇世。可分布饭食。应时受教分布而遍。其食不减如故。阿阇世复白。其食悉遍无所缺减则复如故。文殊师利言。今为尽不。则答言。不尽。所以未尽者以若疑故。诸菩萨饭已。持钵跳掷虚空。行列而住。亦不堕地。亦不转摇。阿阇世复问。是钵云何住而依何等。文殊师利答言。是钵所住如若狐疑所住。阿阇世复言。是钵亦无所住处。亦不在地。亦不所依。亦无有处所。文殊师利则言。如若狐疑。亦无所住。诸法亦复如钵。无所住无所堕。饭事既讫。阿阇世则取一机坐文殊师利。前自白言。愿解我狐疑。文殊师利则言。若恒边沙等。佛不能为若说是狐疑。阿阇世应时惊怖。从机而堕。若大树躄地。摩诃迦叶谓阿阇世。勿恐无惧。所以者何。文殊师利入沤和拘舍罗甚深。以是故说是。徐可而问。阿阇世则问言。属所说何所恒边沙等佛。不能说我之所狐疑。文殊师利言。仁者谓已从心因缘而可见佛。王即答言。不用心心生故。为可见佛。王言不。用有心故为可见佛。王言不。生死与脱是二事。持是作佛。王言不。而有法言从蒙是法。王言不。其作如是法者。能可为决说。王言不。以是故吾说若之狐疑。恒边沙等佛而不能说。所以者何。若人言我能以尘污于虚空。乃能为不。王言不。若有人言我能却虚空之垢。能却不。王言不能。文殊师利言。佛知诸法一切悉若虚空。所以者何脱于本故。亦不见诸法有本若有脱者。以故我言。若王之狐疑。非恒边沙等佛之所能说。文殊师利复言。怛萨阿竭者。不得内外心。何所当作狐疑。所以者何。一切诸法本悉脱。何以故。复有狐疑。文殊师利复言。其脱本者已不复着空。本无所有诸法故曰脱。亦不自然不有所成无所可见。诸法有所有无所有。诸法无所见故无所可见。诸法谓默然。是谓想不可知。诸法无想。已过自然故以过度。诸法者谓生死断故。诸法无处所。谓无有愿故。诸法无有愿。谓无有生死故。等诸法无所著。谓清净故。诸法悉清净。谓本中外悉净。诸法无有双者。谓无有侣。诸法无有侣。谓一心故。诸法一心。谓脱故。诸法无有极。谓无所断故。诸法无有边幅。谓无有度故。诸法不可见其度者。谓所作异故。诸法谓所作异者求慧。谓不能得安。诸法无常。谓无二心故。诸法悉安。谓过净故。诸法悉决。谓无所求故。无自然法。谓不可得身故。诸法无狐疑。谓内寂故。奇哉诸法。谓无谛故。诸法寂者。谓坦然故。诸法无吾。谓无是我所。诸法无余。谓脱故。诸法无所转会上。谓无有念故。诸法尽信。无所著断故。诸法一味。谓脱故。诸法安隐。谓无有想故。诸法无有想。谓无所坏故。诸法悉空。度诸求故。诸法无有愿。谓三界故。诸法以断三界。谓不着过去当来今现在。一切诸法若泥洹。谓以生未生者。文殊师利谓阿阇世。无所生。无所生者乃可令净。王言不。文殊师利言。佛知诸法如泥洹。故不可脱其所狐疑。所以者何。当直住视诸法。视诸法已。亦无所取无所舍。亦不于诸法有所止处。已无所止诸法是故安。已安者便无有疑。已无有疑便无所有作。无所有作者谓无有主。于是中当作是忍。何以故。不自念我用诸法故。忍诸法不可作。谓可为是不可为。诸法无有作。无有作无所作是故泥洹。其信是者以为等脱。亦无所增亦无所减。诸法本无故无有作。而能作者悉本无。其本无者亦非是亦不非是。故本无无有异。已信无有异者。诸狐疑已索尽。其眼者亦无垢亦无净。眼之自然是故本无。本无自然故曰眼。耳鼻舌身意。亦无有垢亦无有净。其意者自然是故本无。本无自然故曰意。色亦本无。本无自然。色痛痒思想生死识。亦无有垢亦无有净。识者自然本无。本无自然故曰识。诸法一切无有垢无有净。诸法自然本无。本无自然故曰诸法。其心亦不可见。色亦不可得持。何以故。譬若幻不可言用内故。亦不可言用外故。所以者何本净故。以是无有垢。其心本者亦不以受。亦不以增。亦不以烦。亦不以忧。亦不以愁。闻是法者无所疑。本异而念异故而有垢。当知本异而念异。其无是者不可以令有。王不当念有是。譬若人言我能令空有垢。以烟若尘。作是而可令空有垢不。王言不。文殊师利言。其心本以清净者。淫怒痴无来何复言。譬若空现于五事。一者灰。二者尘。三者烟。四者雾五者云尽索可见不可言为坐作垢。如人言是我所作非我所作。便有淫怒痴。于心本而不作垢亦不作狐疑。所以者何。心本有所作。亦不能防后心。后心有所作。不寻于前心。今现在心亦无处所。其智者已晓是所作。而不有悕望。无所悕望是故清净相。一切诸法无有垢无所不明。无所生无有处所。无有处所是佛生地。生地者谓为诸法。诸法者是故生地。故不可说。其智慧者诸法无有脱。以法为脱诸疑。以无所有无有法度者。故狐疑属法身。故曰法身无所不入诸法。亦不见法身有所入。何以故。诸法是法身。如诸法等。故法身亦等。故曰法身所入。说是时阿阇世王。得所喜信忍。则欢喜踊跃。则言。善哉善哉解我狐疑。文殊师利则答。是为大狐疑。向所说法者无有本。何从得狐疑。当从何所闻狐疑。阿阇世王则言。蒙大恩而得小差。今我命尽者不忧不至泥洹。文殊师利言。如王之所悕望者。是无有本。所以者何。诸法本泥洹故无所生。阿阇世王则从座起。取名好奇叠。其价直亿百千。持绕文殊师利身。应时文殊师利身不现。其叠仍在处于虚空。但闻其声不见其形。则闻其音说。如见文殊师利身。王自见狐疑。不以见狐疑者为以见诸法。如所见是为。复从空中闻其声。谓王有所见便以叠而与之。次文殊师利坐处有菩萨。名得上愿。阿阇世复欲持是叠而奉上之。其菩萨言。其求脱泥洹者。我不从是有所受。亦不受凡人有所有。何以故。凡人者谓有俗间事故而不受。亦不从求罗汉辟支佛有所受。亦不从怛萨阿竭法有所受。其有不近是法不离是法。而我受是物。其与者亦无二心。其受者亦无二心。故曰所受过于脱。王则欲以衣着菩萨上。忽然不现不知处。但闻其音不现形。说言其所现身以衣与之。而是菩萨坐次复有菩萨。名曰见诸幻。阿阇世王复以是衣而奉上之。其菩萨言。若有计他人有我者。我不受是物。亦不从有所沾污。亦不从以得脱从是而受物。亦不从定意者。亦不从乱意者而受是物。亦不从智慧者。亦不从无智慧者而受是物。阿阇世便以衣掷床上。其菩萨即不现。复闻其音不见其形。说言。其有现者以衣与之。而是菩萨坐处有菩萨。名曰不见幻至泥洹。阿阇世以手擎衣而往。趣之上坐已去仁者。可受其菩萨言。若有自着他人者。我不受是物。其不着五阴四大六衰。亦不着佛。亦不着法。亦不着僧。何以故。诸法无所著故。王阿阇世便持衣。欲着菩萨上。应时而不现。但闻其音而不现形。说言。其有现者以衣与之。而是坐次有菩萨。名曰私呵末。阿阇世则以衣奉上。其菩萨言。其无瞻者我不受物。今汝发菩萨意。持心如菩萨。其心等诸法。亦等于诸佛法。亦无所取无所舍。于诸法亦无疑亦无有疑。亦不念诸法有我。不念诸法有所脱。有是意者乃受是物。王阿阇世则而以衣着菩萨上。应时不现形但闻音。说言。其有现者以衣与之。而是菩萨坐次有菩萨。名三昧拘速摩。阿阇世持衣欲奉上。其菩萨言。若有如是三昧无所疑。乃受其物。本三昧悉知诸法无所脱。我乃受是物。王阿阇世便持衣着其上。应时不现但闻其音。言其有现者以衣与之。而是坐次有菩萨。名量精进。言一切诸音字声而不可得。其作是者我乃受是物。王阿阇世复以衣起着其上。则时不现形但闻其音。言其有现者以衣与之。而是坐次有菩萨。名离所作垢。阿阇世欲以衣上之。是菩萨言。其不自念我身与之。亦不念有人从我取。亦不念当有利。其无是者我乃受是物。王复以衣着其上。应时不现其形但闻其音。言其有现者以衣与之。而是坐次有菩萨。名昙摩惟惧和那罗耶。阿阇世复以衣奉上之。其菩萨言。若于声闻示现而不般泥洹。于辟支佛示现而不般泥洹。亦不住于生死。亦不至泥洹。我乃受其物。王阿阇世便以衣着其上。忽然而不现但闻其音。言其有现者以衣与之。如是一一以衣与之。应时不见。其床机座处悉亦不现。复闻其音言其所现者以衣与之。阿阇世语摩诃迦叶。我从佛闻仁特尊。今以衣奉上唯当受之。摩诃迦叶而不肯受。所以者何。我淫怒痴未尽索。故不可受。亦不离无黠。亦不离恶亦不离苦知。亦不习亦不尽。亦不导亦不以尽为证。亦不有道念。亦不见怛萨阿竭。亦不闻法亦不属比丘僧。亦不慧生亦不眼净。亦不以识有所住而作。其与我物者。其德不能大亦不能得尊脱。摩诃迦叶言。如仁作意如我者我乃受之。王阿阇世便以衣着其上。应时而不见但闻其音。言其有现者以衣与之。便复以衣次第与诸比丘。一一不见。尽索五百人。悉亦不现但闻其音。言其有现者以衣与之。王阿阇世熟自思念。诸菩萨比丘僧悉亡。当以衣与谁。还自与中宫极夫人。又其夫人亦不现。应时阿阇世王便以得三昧。不见诸色。亦不见母人。亦不见男子。亦不见男儿。亦不见女儿。亦不见垣墙。亦不见树木。亦不见室宅。亦不见城郭。尚有余念。谓有我身诸色识悉止。复闻其音。如一切有所见。当自见其狐疑。如所见狐疑。见一切诸法亦复如是。所见当作是视无所视。当作是视无所视法。是为视法。其有所见者便以与之。王了无所复见。便取其衣还欲自着。亦复不见其身。心意识诸所想已无。是名曰脱于想脱于狐疑。则从三昧还。见众菩萨比丘僧。诸官属所有一切如故。阿阇世复白文殊师利。属诸众会所而我不见。文殊师利言。如仁之狐疑处。属众会在彼闻。文殊师利复言。乃见众会不。阿阇世则言见。云何见。如我所见狐疑。见众会如是。文殊师利复问。乃见众会不。阿阇世则言见。云何如我所见狐疑。见众会如是。文殊师利复问。云何见狐疑。如我属不见众会者。是狐疑于内外亦无所见。文殊师利言。乃闻佛所言其作逆恶当入大泥犁不。王言闻。文殊师利复谓。王汝自知当入泥犁不。阿阇世复问。其佛得佛时乃有法上天入泥犁者不。乃有安隐当至泥洹者不。文殊师利则言无。王言。我知诸法悉空故。所以者何。泥犁亦复已空。上天安亦空。诸法无所可坏败。是故入法身。法身者亦无天上。亦无人间。亦无泥犁禽兽薜荔。其逆者亦不离法身。其所作逆者身悉法身之所又。诸逆之本悉诸法之本。已去当来无去来者。诸法亦无去来。已知是者。亦不入泥犁。亦不上天。亦不泥洹。文殊师利复问。佛说有逆。如何今说无有。王则答言。我不违佛所语。云何。王言。无我是佛之说。谛其以无我。是则无人。亦不作罪者。亦无受罪者。文殊师利复问。王已脱于狐疑不。则答言。从本已脱以来亦脱。文殊师利言。其疑以尽未。王言。已从久远尽。文殊师利复问。云何众会而知王有逆无逆脱是中。王言。以尊法持我故知无逆。譬若菩萨已得忍辱。悉持诸恶。菩萨若惠好愿。那羁头梁耶谓阿阇世。诸逆以净以得是忍。王言。一切诸法悉净无所沾污故。是法亦不可污。所以者何。其道无有瑕秽故。以入大逆道者。不去生死不见泥洹。所以者何。其道无已可往者而可近者。说是语时。阿阇世王便得疾信忍。则时三十二人。于文殊师利前皆发阿耨多罗三耶三菩心。五百臣下悉得须陀洹道。其罗阅国民塞满宫门。欲见文殊师利说法。文殊师利则时以足大指指地。宫壁及地悉为琉璃。一切在外皆见宫中诸菩萨比丘僧。若人照境自见其形。尔时所视悉亦了了。皆听文殊师利所说法。八万四千人。悉得须陀洹道。复有五百人。悉发阿耨多罗三耶三菩心。文殊师利为王及宫中臣下诸人说法已。各令安隐。便从坐起。与诸菩萨比丘僧俱而出宫门。王阿阇世及宫中官属。俱而送之出于城门之外。见树下有人。而大呼我自杀其母。是人当得脱者。文殊师利化作一人。与父母俱行。父母言。是故正道。可从是行。其子言。非是正道。如是至再三。与父母共诤。便起意还杀父母。前呼杀母者。见是人而杀父母。便于边举声。而与其化人杀父母者便自陈说。我所作为非法所载怨杀父母。其一人则念。我独杀母耳。是人杀父母其罪甚重。如子所受我尚轻微。化人则语一人。我不如往到佛所。佛者无所归者而受其归。而无护者而为作护。如佛所语。我当承教不敢违失。其教化人便向道。其一人即随其后。如是人所受法。我亦如是。虽尔我尚嗟之。俱共啼哭而行。已到佛所前作礼而住。便自白。我作非法而妄杀父母。佛言。善哉善哉。如子之所言至诚无异。所以者何。不覆藏作罪故。乃至怛萨阿竭前。所说事如佛则言。勿恐莫懅随我所言。其化人言。如佛所教惟哀加护。佛言。还自观心之法。视持过去当来今现在心。持何等心而杀父母。佛则复言。已过去心已灭已尽。亦不可见处。亦不可见所在。当来心不可说。所以者何。未生未有故。无有故。无有想无有念。今现在心亦无所住止。若心起意则灭。亦不合聚。亦不可知去至何所。从何所来。亦不可知青。亦不知赤白黄黑。心者不可见。亦无有形。亦复不可得持。亦无有伴。譬如幻。于身亦不可见在内。亦不见在外。亦不见中间。佛言。心者亦不可从爱可见。亦不可从嗔怒可见。若卧出于梦可见其心。若作若无所作。心亦无所与无所得。心者本净故。亦无有沾污。亦无有而净者。佛复言。其心亦非是间。亦非彼间。譬若如幻不可得持。所以者何无伴侣故。其知如是者。不作是想。亦不念有我无我。亦不念有所见。亦不念有所住。诸法寂寞而有作者。其信是者不复受恶道。所以者何。无所沾污故。其心法者亦无所生。亦无所著。其化人则言。善哉善哉。如怛萨阿竭。以法身而自成佛。今知如佛所说。以信不疑无作者无受罪者。无生者无所灭者。如诸法愿乐得为沙门。佛言。如子之愿。应时其化人便如沙门。即白佛。我所犯罪杀父母。已脱而得阿罗汉。今欲般泥洹。佛言。从意如所欲。是化比丘飞去地二十丈。在于虚空便般泥洹。从身火出还自烧身。其杀母者见是人已般泥洹。具足闻怛萨阿竭所语。则自念言。其人所作甚逆。今作沙门而得度脱般泥洹。我罪尚可行。何为不自归佛。亦可到是。便前为佛作礼自白。我所作非法自杀我母。今以身自归。佛言。善哉善哉。所语至诚无有异。所说如言。见怛萨阿竭说所作罪而不覆藏。且观心法。念以过去以当来今现在心。何所心杀其母者。过去心以灭尽。亦不外亦不内。亦无处所。当来心不可说。亦未生亦未有。亦无有想亦尔有所想。今现在心亦无所住止。心有所生则破坏亦无所聚。亦不见有所至处。亦不可见有所从来处。其心者亦不青赤黄白黑。其心者无有形不可见。不可得持。亦不可听闻。所以者何无有声故。亦不可得获。亦无有伴。譬若幻。亦不于外见身。于内亦无所得。于中间无有处。其心者亦无沾污。亦无有恶。亦无有疑。其心无所作。亦不有所作。亦无所与。亦无所得。心者本净故。亦无沾污。亦复无净。其心亦不在是是不是。其心若空。亦不可得获。亦无有伴。其智者不念是想。亦不作缚。亦不作净。不作有所见。亦不作处亦不有所止处。亦不有。而着心脱者。是故无所碍。亦不生恶处。何以故。其心法亦无所著。亦无所至凑。亦不在生死之所止。其杀母者。应时身诸毛孔一一孔。泥犁之火从其孔出。痛不可言。则自陈说。今自归怛萨阿竭。惟哀加护令得安隐。佛则时以金手。着其人头上。应时火灭苦痛则除。便前长跪愿欲作沙门。佛言。如所欲则时以为沙门。怛萨阿竭以四谛法而说之。应时得法眼。深入其事则得阿罗汉。便白佛言。今我欲般泥洹。佛言。如所欲飞在虚空。去地百四十丈。便于是上其身火出还自烧身。诸天亿百千人。悉飞而来供养。舍利弗白佛。怛萨阿竭实尊。所以者何。而作恶令得解脱。谁而解者独佛。若文殊师利及诸菩萨。深入僧那僧涅者而知是事。非罗汉辟支佛之所而堪知其中事。若一切人之所行。悉不而及逮。佛语舍利弗。其怛萨阿竭土者。是菩萨之所忍。非罗汉辟支佛地。及非一切人之所行。所以者何。若有一人所作异而当得异。如是若曹见作罪者。知当入泥犁。我而令不入泥犁可至泥洹如若曹所知当有般泥洹者。我知当入泥犁。何以故。若曹而不及知一切人之所行。佛语舍利弗。若见其杀母人而般泥洹者不。则答言见。佛言。是人以供养五百佛尽索。从一一佛闻心法本净。何以故。今复闻是法而般泥洹。其有知深法入其微妙。欢喜踊跃其心无惧。若为恶师所误。若其心不足者。而所犯罪会当解脱。其以信心法本净。是人不堕恶道。所以者何无所碍故。文殊师利即与诸菩萨摩诃迦叶比丘僧。王阿阇世及群臣官属来到佛所。舍利弗问阿阇世。今以闻狐疑解不。则答言。以闻知。云何闻。其说法时无所得。亦无所不得。亦无所持亦无所舍。闻是时从今以去无有沾污。时舍利弗问佛。阿阇世余罪有几所。佛言。所闻法譬若一芥子。能尽须弥山之罪。舍利弗问佛。王阿阇世当入泥犁不。譬若忉利天子。被服名众好宝。来下到是则还处所。阿阇世者亦以衣服珍宝庄严。譬若是天子从上来下虽入泥犁。泥犁名宾头。入中无有苦痛。则为苦天子上归本处。舍利弗白佛甚善。阿阇世所作罪而得微轻。佛谓舍利弗。汝乃知是王不。则言不知。是阿阇世王以供养七十三亿佛。各从诸佛常闻深法。其心不离阿耨多罗三耶三菩心。佛复问舍利弗。乃见文殊师利不。则言见。是本发阿阇世。而令为阿耨多罗三耶三菩心。尔时久远过去时。有佛号字安隐觉劫名无尘垢。用是劫中而有三亿亿人。皆文殊师利之所劝而转法轮。佛语舍利弗。譬若如恒边沙等佛。为阿阇世说法。而不解其狐疑。所以者何。是文殊师利之所发意故。当从是解。世世常从文殊师利闻甚深法。佛言。菩萨本有所造作。其人必当因本所发意而得解。今阿阇世虽入泥犁。还上生天。上方去是五百四十五刹土。号字名惟位惟位(汉言为严净)。其佛号字罗陀那羁头(汉言宝好)。亦于彼当与文殊师利相得。从其刹欲会闻所说法。则当得无所从生法忍。弥勒于是作佛。阿阇世从彼刹来生是间。尔时当名阿伽佉鈚菩萨。弥勒佛从是因缘。以法教诸菩萨。所说法亦不过亦不短适平等。尔时当说阿伽佉鈚者。以过去释迦文佛时。有王名阿阇世。用恶人言而杀其父。从文殊师利闻诸法。闻已则欢喜信忍。所作罪应时尽索。弥勒佛说是时。八千菩萨悉得无所从生法忍。却后八阿僧祇劫。阿伽佉鈚当行菩萨道。而教化人亦当净刹土。其有人从其闻法者。若作声闻若作辟支佛若菩萨法者。皆当无瑕秽。一切无所碍。诸人悉当明于智慧无所狐疑。其王阿阇世过如所说八阿僧祇劫以后。当得为佛。其劫当名唾曰鈚陀遍(汉言者欢喜见)。其刹土名阿迦昙(汉言者为药王)。其病者莫不愈。其怛萨阿竭。当号字惟首陀惟沙耶(汉言者净其所部)。尔时寿四小劫。当有七十万声闻。悉已从惠得解。皆当知八惟务禅。尔时当有十二亿菩萨。一切皆入诸慧晓了沤和拘舍。佛般泥洹以后。其法住乃至亿万岁已后乃尽。其刹土一切人至死无狐疑者。寿终已后不生八恶处。所以者何。用从佛闻深法故诸垢浊不复着。佛语舍利弗。人而不可轻。所以者何。而从轻得其罪。佛言。我知人而所作。而余无知者。而所趣向。其佛者乃知之。舍利弗从其众会言。是事微妙快乃知是。则言。从今已去不敢复说。是者罪人是者福人。所以者何。一切人之所行不可议故。如佛属所说。阿阇世而得决。尔时万二千天子。皆发阿耨多罗三耶三菩心。各各同愿惟首陀净所部惟沙耶作佛时。我生其刹土。佛悉与决。其作佛时。而当往生后刹土。王阿阇世有子年八岁。名曰栴檀师利。应时取身上珍宝解散佛上。则言以是发阿耨多罗三耶三菩心。若惟首陀惟沙耶而作佛时。我愿为遮迦越罗。其佛般泥洹以后。我愿承其后作佛。所散宝物悉化作七宝交露纵广正等。中有床坐具足若干之宝。其綩綖幨亦复如是。佛坐其床上。应时佛笑。无央数色光明。而从口出遍于十方。还绕身三匝从顶上而入。阿难从坐起白佛。怛萨阿竭不妄笑。当有意。阿难叹佛其智慧甚尊。无所挂碍。悉知一切人心之所行随其所欲。教照令各得所。天上天下而独特尊。所因缘笑故唯愿欲闻。若十方一切人悉在前住。一一人问亿百千那术事。悉则发遣而无留难。属之所笑唯闻其说。已过去当来今现在。佛悉而具足。无所挂碍。属之所笑惟决其疑。其光明悉逾于日月。过于释梵。坏诸遮迦和山。令一切悉见其光明。见其光明者。人则无所复着。所以者何。佛以无瑕秽故。属之所笑惟愿发遣

佛告阿难。是栴檀师利者。已供养我。而发阿耨多罗三耶三菩心。稍稍而至。惟首陀惟沙耶作佛时。而生彼刹。当作遮迦越罗。举家室仆从。当供养其佛比丘僧。至竟无有已。其佛般泥洹已是儿当习其后。便于遮迦越罗寿尽。当至兜术天上。从上竟寿而下。当生彼佛刹而自成佛。号字栴檀羁尊。所有一切如前佛无异。其寿适等。诸声闻菩萨亦复适等。其从阿阇世所诸余菩萨悉皆言。若文殊师利在所方面。亦复如佛无有空时。所以者何。有所作为与佛无异。其有菩萨。为文殊师利所教者。无所复异。何以故。无复生于恶处者。不畏众魔。亦不畏罪。不有所沾污。若城郭郡国县邑丘聚。若有学其法者。若有持是经讽诵读者。若书者。见是辈人。当如见佛无有异。在所方面而闻法。则当念则是佛处。佛谓诸菩萨。审如若之所言。所以者何。已过去无央数阿僧祇劫。有佛号字提和竭。则与我决当为阿耨多罗三耶三菩心。而成为佛。我以发布地。令怛萨阿竭而蹈之。正于是处而得决言。汝过阿僧祇劫后。而当为佛。号字释迦文。时提和竭佛谓诸比丘僧。是所受决处。不当以足蹈其地。所以者何。是则极尊神处。诸天人民一切当共事是处。谁有于是而起塔者。应时八十亿天皆念言。我而起之。有迦罗越。名颰陀调。则白言。我欲于是起塔。则时便作七宝塔。严庄甚好。事已讫竟。至提和竭所白言。所作塔以成。闻怛萨阿竭其福如何。提和竭言。若菩萨在所处得法忍。圆如车轮。而起作塔。下行尽地际。诸天鬼神一切当已其土供养。当如舍利无异。如是菩萨所授决得法忍处。圆如车轮。满中七宝。上至三十三天。持施与佛。有作是塔者。其福出是上。其佛言。如我授摩纳决。而后当作释迦文佛。汝作是塔。因是功德。当从释迦文佛授决。却后阿僧祇劫亦当成佛。佛语众会者。乃知时迦罗越颰陀调不。诸会者不及。佛即言。今在会中迦罗越子。名曰作罗一耶阇。是应时怛萨阿竭。而与决言。汝当作佛号字须陀扇(汉言者名曰决见)。佛复言。若比丘比丘尼。优婆塞优婆夷。而书是经若讽诵读。为一切人说解其法处。圆如车轮。尘等下尽地际。上至三十三天。其智者取中一尘而供养之。所以者何。菩萨从是法而得忍故。佛言。若男子女人。以七宝满三千大千佛刹土。日三反持是施与。但专念是。其所复作。如是百劫千劫。若复至百千劫。其有讽诵读阿阇世品者。若恭若事若讽诵。为一切说。而解其中慧。其心信向无有异。是福出彼所作施与功德上。若男子女人。于百劫而持净戒。卒闻是法信乐喜之。其福出彼净戒功德上。虽为人所挝捶骂詈百劫亦不起意。是为忍辱。其闻是法信向于中作忍。出彼忍辱上。于百劫而精进。恭事一切人。亦不以为勤苦。不惜身命。其闻是法信。而为一切人解其中事。其福出彼精进上。其身于百劫守禅。不如以是法而教一切人。其功德出彼守禅上。若有百劫而行智慧。闻是法解心本清净。其功德出彼上。诸菩萨皆白佛。吾等悉当奉行。所至到诸佛刹。当以法而化人佛语诸菩萨。汝所至奉行法教。一切所作如佛无异。所以者何。是法悉解佛事故。一切诸会菩萨悉以花供养。散怛萨阿竭上。遍三千大千刹土。诸菩萨各自说。是法实尊。其释迦文佛之所说。当久在阎浮利地而与明。文殊师利者常当久住。所以者何。常当从闻深沙之法。诸菩萨言。推身未而报其恩。佛言。若男子女人从人闻是法。亦不以身报其恩。欲见怛萨阿竭者。视其男子女人所闻法处。当供养如佛。其有信于是法者。视其人当如见佛。诸菩萨从座起。为释迦文佛作礼。于是恍惚而不见。各各还其刹土。以是法自于处所。为一切具足解说是慧。其闻是法者无央数人。悉发阿耨多罗三耶三菩心。佛语弥勒菩萨。持是法当讽诵读。当为一切广说其事。当加哀天上天下及一切。弥勒菩萨白佛。我以从过去诸佛所。已闻是法。持讽诵读已。今复还闻是法。今亦当广为一切说法。虽怛萨阿竭般泥洹已后。我在兜术天上。若男子女人欲学是法我劝助护之。后末世法一切欲尽时。其有闻其处所有是经。当知我之所护。若有魔中道而欲坏败。我当护之令不得其便。佛语释提桓因。当持是法讽诵读决诸狐疑。若阿须伦兴师起兵。欲觉击天帝。当念是经。应时得胜其兵即却。佛复言。若有郡国县邑丘聚其奉事是经皆当往护。其遭县官者。若入县官者。当念是经。行贼中当念是经。若为贼所拘击当念是经。若在旷野当念是经。若见怨家若与怨家相得当念是经。其有至心于是法者。无而得其便。佛语阿难。持是法讽诵读。当为一切说解其法。若有男子女人。从若闻是法便无狐疑。诸狐疑索尽则不复为罪所覆。亦不为生死之所覆。亦不中道离法之所覆。一切其有作邪道者则为不行。终不与魔事而相当值。所以者何。用闻是法故。其已作逆恶者闻是法信乐喜则已无逆恶。亦不受逆之罪。摩诃迦叶白佛。我证知是法属文殊师利。于阿阇世所食时说是法。解作逆恶之事。应时得欢喜信忍。悉为解狐疑。我今说之。其有犯逆者。从是法忍悉得解脱。亦当如阿阇世。应时摩诃迦叶复言。一切人本悉净。而自作反是我所非我所。亦不而自知其本净。悉以晓了本净者。所作罪则解脱无有而知如阿阇世者。是以一切愚人。所作反还自杀身。便因是而得勤苦便入泥犁。摩诃迦叶言。其奉事信乐是法。吾等证之不复堕恶道。佛言。如汝之所说。一切诸佛菩萨心无瑕秽。阿难复白佛。惟怛萨阿竭。令后世人见是法。怛萨阿竭应时从身之相放光明。照无央数佛刹。诸垣墙树木皆有音声。其法当尔。所以者何。若劫尽火起。其当闻者会是法。若当闻是法。虽在于海中会还得闻是法。佛语阿难。如垣墙树木之所闻声。审如其言。其已作功德者。已作摩诃衍者。后世皆还得闻是法。说是经时。诸天及人九万六千悉得须陀洹道。七万八千人悉发阿耨多罗三耶三菩心。二千菩萨得无所从生法乐忍。八千人皆得阿罗汉道。是三千大千刹六反震动。众冥悉开辟而悉明。诸欲天子诸色天子。以若干伎乐而供养之。皆以天华天香共散之言。所谓法轮。闻是法者已为逮法轮转。诸外道者闻是法即而自知。是故因为伏是者则菩萨印。其得是印者乃到佛树下。佛说是经。王阿阇世诸菩萨。文殊师利是为本。诸声闻舍利弗摩诃目揵连阿难等是其本。诸天揵陀罗一切人。闻佛所说。前已头面作礼而去

佛说阿阇世王经卷下


佛说阿鸠留经

    No. 529

佛说阿鸠留经

        僧祐录云安公古典经今附汉录

闻如是。一时佛在舍卫国祇树给孤独园。佛告诸比丘言。昔者有贾客。名阿鸠留。居处甚富。金银珍宝。奴婢众多。阿鸠留。不信有后世生。作善不得善。作恶不得恶。阿鸠留言。人死后身。地外地身。水外水身。火外火身。风外风身。皆共和合。人死后终不复生也。人所作善恶。心所念。口所言。身所行。皆当弃捐。后不复生。时阿鸠留。持财货数千万。与贾客五百人俱行。阿鸠留最尊豪相随行贾客。当经剧道无水草处。所持粮食。水草皆已尽。行一日二日。不见水草。行三日四日。不见水草。贾客皆恐怖言。今我皆悉当于此荒泽中饿死耶。各自啼哭。呼父母妻子。阿鸠留。遣骑四布。行求水草。阿鸠留。自行遥见一树。树叶青青。果蓏繁炽。自念此树下犹当有水。便前趣树。见一男子。端正无比。遥见阿鸠留骑马来前。迎趣之言。多贺来到。在所求索。阿鸠留。见树下人。答之即大喜。如得更生。树下人言。从何所来。欲所之到。阿鸠留言。索救我命及五百人畜生命。树下人言。欲何求索。言我欲得水。树下人便举右手。水从五指端出如流泉。甚香味。语阿鸠留言。自极饮。饮已复从索饭。树下人便举右手。美食从指端出。阿鸠留。得饱食已。便举声大啼哭。树下人因问。仁者啼哭为。阿鸠留言。我等伴五百人及畜生。从三四日以来。皆不得饮食。饥饿甚极。命在须臾。是故我啼哭耳。树下人语阿鸠留。若行将五百人及畜生来。我悉为若饱之。阿鸠留。即驰行。呼伴人语之言。勿复忧也。已得饮食处。随我去来。伴人大喜。便随去到树下。皆叉手。为树下人作礼。树下人问言。欲何得。人皆言。大饥渴。树下人即复举右手五指端。即复大水出。水如流泉。人马畜生皆饮。复从索饭。树下人复举右手五指端。出名美饮食与之。五百人及畜生皆饱满。树下人因问。五百人等。卿皆欲至到。何等求索。贾人言。我皆欲到大海。求索珍宝。树下人因问。卿皆欲索珍宝者。便可从我手中出。树下人便举右手。从五指端。出金银水精琉璃珊瑚虎魄白珠。人便敛取。取各自重如去。树下人语阿鸠留。持此金银。归乡里。用布施贫穷者。欲得饭者饭之。欲得金银钱财衣被者。极与之。令道人皆咒愿我。令我得其福。令我手中出琦物。又多使我早脱此荒泽中。阿鸠留。闻此语。大惊怖。便以头面着地。问仁者为何等人乎。是天耶龙耶鬼神耶是人耶。树下人言。我亦非天。亦非龙。亦非鬼。亦非人。我是豪薜荔也。我前世时。于国中大贫穷。常在城门下坐。虽贫穷心净洁。爱乐沙门道人。我贫穷不能施人。见他人布施。代其喜。时迦叶佛。般泥洹去。诸比丘来从我乞丐食。我应比丘言。我无所有。但遥指示城中。某家善可得饭。某家不善不可得饭。比丘乞来出。我见有所得。即欢喜。又迦叶佛。般泥洹去。其国王名为基立。为迦叶佛。起七宝塔。我辄持手着其上言。令我得其福。王上好物于佛塔。我辄持手着之言。使我得其福。但用贫故。未曾斋。饭食无时。又饮酒。是故死后。以作豪薜荔耳。但用我前世见人作善。代其欢喜。手着其物上。是故令我五指端在所出。但用生时未曾斋。故使我作是间薜荔。阿鸠留自念言。我前不信有后世生。作善不得善。作恶不得恶。今我眼见。是为审有后世。复生审有作善得善作恶得恶。从今日以去。归乡里。快当作善。布施与人。恣所求索人有欲得金银珍宝饮食衣被者。皆与之。不逆人也。阿鸠留。归到乡里。语一国中人。谁有欲得金银珍宝衣被饮食者。恣所求索。皆来取之。如是布施无央数。日日饭八万四千道人。但澜汗流出门。人用擿船而行。阿鸠留。作善极意。死后便上第二忉利天上。作天人。去离天帝座。四百八十里。其国中有乞丐女人。名曰[女*參]。以善心持一杅米粥。与沙门摩诃迦叶。女人死后。亦生忉利天上。作天人。在天帝释边第三座。复胜余天五事。何谓五事。一者长寿。二者端正。三者安乐。四者智慧。五者威神。胜于余天。后佛母忽故生忉利天。时佛天上。为母说经。说经已。佛母及诸天无央数。皆得须陀洹道。佛因见阿鸠留。布施与人。远在天帝释边。四百八十里坐。复见乞丐女人。持米粥与沙门摩诃迦叶。在天帝释边第三座。又胜余天五事。佛见悉皆识知。即遥呼阿鸠留言。布施善人来相见。阿鸠留。即来前持头面着地。为佛作礼。白佛言。我布施大众。多但得凡人耳。不得须陀洹。斯陀含。阿那含。阿罗汉。辟支佛。佛道也。今见乞丐女人。持米粥与沙门摩诃迦叶。今世在帝释边第三坐。又胜余天五事。人持小物与摩诃迦叶。得福乃尔。是故身自致豪贵如此。天便为佛作礼而去佛说阿鸠留经


佛说阿难分别经

    No. 495

佛说阿难分别经

        乞伏秦沙门释法坚译

阿难白佛言。有人事佛得富贵谐利者。有衰耗不偶者。云何不等耶。愿天中天。普为说之。佛告阿难。有人奉佛。从明师受戒。专信不犯精进奉行。不失所受。形像鲜明。朝暮礼拜。恭敬然灯。净施所安。不违道禁。斋戒不厌。中心欣欣。常为诸天善神拥护。所向谐偶。百事增倍。为天龙鬼神众人所敬。后必得佛。是为善男子善女人真佛弟子也。有人事佛。不值善师。不见经教。受戒而已。示有戒名。愦塞不信。违犯戒律。乍信不信。心意犹豫。亦无经像。既不日日烧香作礼。恒怀嗔恚。恶口骂詈。又不六斋。杀生趣手。不敬佛经持着衣被弊箧之中。或着妻子床上。或以挂壁。无有座席供养之心。与世间凡书无异。若疾病者。狐疑不信。便呼巫师。卜问解奏。祠祀邪神。天神远离不得善护。妖魅日进。恶鬼屯门。令之衰耗。所向不谐。现世罪人。非佛弟子死当入泥犁中。被考治掠。由其罪故。现自衰耗。后复受殃。死魂神痛。酷不可言。愚人盲盲。不思宿命先世因缘。精神所之。根本从来谓言事佛致是衰耗。不惭前世宿行不功。责圣咎天。世人迷谬。不达乃尔。不达之人。狐疑犹豫。信不坚固。心怀不定。进退失理。违负佛恩。而无反复。遂为三涂所见缀缚。自作祸福。罪识之缘。种之得本。不可不顺。十恶怨家。十善厚友。安神得道。皆从善生。善为大铠。不畏刀兵。有能守信。室内和安。福付自然。非神授与也。今复不信者。后生转复剧矣。佛言阿难。善恶追人。如影逐形。不可得离。罪福之事。亦皆如是。勿作狐疑自堕恶道。谛信不迷。所在常安。佛语至诚。终不欺人。佛复告阿难。佛无二言。经法难闻。汝宿有福。今得侍佛。当念报恩。班宣法教。示现人民。为作福田。信者得值。后生无忧。阿难受教奉行普闻。阿难复白佛言。人不自手杀。教人杀者。不自手杀。为无罪耶。佛言阿难。杀人杀者。重于自杀。何以故。或是奴婢愚小下人。不知罪法。或为县官。逼为所使。不自意出。虽获其罪。事意不同。轻重有差。教人杀者。知而故犯。阴怀逆害。愚恶趣手。无有慈心。欺罔三尊。亦复自然犯五逆罪。害生杌命。其罪莫大。怨对相报。世世受殃。展转相偿。无有断绝。现世不安。数逢灾凶。死入地狱。出离人形。当堕畜生中。为人屠截。三涂八难。巨亿万劫。以肉供人。未有竟时。令身困苦。啖草饮泉。今世现有是辈畜兽。皆由前世得为人时。暴逆无道。阴害伤生。不信致此世世为怨。还相报偿神同形异。罪深如是

阿难复白佛言。世间人及佛弟子。恶意向师及道德之人。其罪云何。佛语阿难。夫为人者当爱乐人善。以善为友。不可嫉之。人有恶意向有德之人。及善师者。是恶意向佛无异也。宁持万石弩。还自射身。佛语阿难言。自射身为痛不。阿难言。甚痛甚痛世尊。佛言。人持恶意。向道德人及其师者。痛剧弩射身也为人弟子。不可轻慢其师。恶意向道德人。当视之如佛。不可嫉其善也。人有戒德者。感动诸天。天龙鬼神莫不敬尊。宁投身火中。利刀割肉。慎莫嫉妒人之善也。其罪不小。慎之慎之。阿难言。师者为可灼然非弟子。不以小罪成大。可无罪不。佛言不可。亦甚深甚深。师弟之义。义感自然。当相许后。视彼如己。己所不欲。勿施于人。弘崇礼律。不使怨讼。弟子亦尔。二义真诚。师当如师。弟子当如弟子。勿相诽谤。慎莫含毒。小怨成大。还自烧身。我观末世。诸恶人辈。魔世比丘。但念他恶。不自止恶。嫉贤妒善。不念行道。既不能为。复坏毁人。断绝道意。令不得行。贪务俗业。积财自丧。死堕恶罪大泥犁中。未当如是。于世何求。念付佛恩。相率以道。道不可不学。济神离苦。超出生死。见贤勿慢。见善勿谤。勿以小过证人大罪。违法失理。其罪莫大。罪福有证。可不慎耶

阿难复白佛言。末世弟子理家因缘。随事便宜。当云何。佛言。受佛禁戒。信而奉行。不念诳妄。奉孝畏慎。敬归三尊。养亲尽忠可得为世间事。不可得为世意也。阿难言。世间事。世间意。云何耶。天中天。佛言。为佛弟子可得贩利业。平斗直尺。不惘人民。施行合理。不违自然。葬送移徙。姻娶之事。是为世间事也。世间意。为佛弟子。不得卜问请祟符咒厌怪祠祀解奏。亦不得择良时良日。受佛五戒者福德人也。有所施作。当启三尊。道护为强。设使诸天。天龙鬼神无不敬伏。戒贵则尊。无往不吉。岂有忌讳不善者耶。不达之人。自作骂詈。善恶之事自由心作。祸福由人。如影追形响之应声。戒行之德应之自然。诸天所护。愿不意违感动十方。与天参德。功勋巍巍众圣咨嗟难可称量。智士达命。没身不邪。善如佛教。可得度世之道。阿难闻佛所说。更整袈裟。头脑顿地。唯然世尊。我等有福。得值如来。普恩慈大。愍念一切。为作福田。令得脱苦。佛言。至真而信者少。是世多恶。众生相诅甚可痛哉。若有信者。如一若两。奈何世恶。乃弊如是。佛灭度后。经法稍替渐衰灭矣。呜呼痛哉。将何恃怙。阿难堕泪。因事说曰

  佛为三界护　　恩广大慈普
  世弊不见佛　　值法者亦难
  痛矣不识者　　盲盲不别真
  痛矣乃如斯　　罪使令如是
  宿福值法者　　若一若有两
  经教稍稍没　　当复何恃怙
  佛恩非不大　　罪由众生故
  法鼓震三千　　如何不得闻
  世浊多恶人　　倒见堕颠倒
  谀謟啤訿圣　　邪媚相毁坏
  不信世有佛　　言佛非大道
  是人是非人　　自作众罪本
  命尽往无择　　刀剑解身形
  饿鬼好伐杀　　镬汤涌其中
  淫逸抱铜柱　　大火相烧然
  抂谤清高士　　铁钩拔其舌
  乱酒无礼节　　迷惑失人道
  死入地狱中　　洋铜沃其口
  遭逢众危难　　毒痛不可言
  若生还为人　　下贱贫穷中
  不杀得长寿　　无病常康强
  不盗后大富　　钱财恒自饶
  不淫香清净　　身体鲜苾芬
  光影常赫奕　　上则为天王
  至诚不欺诈　　为众所奉承
  不解后明了　　德慧所尊敬
  五福超法出　　天人同俦类
  所生亿万倍　　真谛甚分明
  末世诸恶人　　不信多狐疑
  痴愚不别道　　罪深便逮冥
  蔽圣毁正觉　　死入大铁城
  识神处其中　　头上戴铁轮
  求死不得死　　须臾已变形
  矛戟相贯刺　　躯体恒残截
  奈何世如是　　背正信鬼神
  解奏好卜问　　祭祀伤不仁
  死坠十八狱　　经历黑绳狱
  八难为界首　　得复人身难
  若时得为人　　蛮狄无义理
  痴騃为孔窍　　跛躄哑不语
  朦胧不达事　　恶恶相牵拘
  展转众徒聚　　禽兽六畜形
  为人所割屠　　剥皮视其喉
  归偿宿怨对　　以肉给还人
  无道堕恶道　　求脱甚为难
  人身既难得　　佛经难得闻
  世尊为众祐　　三界之特尊
  敷遗甘露法　　令人普奉行
  哀哉已得慧　　愍念群萌故
  开语示道真　　黠者即度苦
  福人在向向　　见谛学受成
  自归大护田　　殖种不死地
  恩慈莫过是　　世祐转法轮
  愿使一切人　　得服甘露浆
  慧船到彼岸　　法磬引大千
  彼我无有二　　愿发无上真

阿难说如是诸会大众。信解僧那大铠甘露之音。香熏三千。从是得度。开现道地。为作桥梁国王臣民。天龙鬼神。闻经所记。阿难所说。且悲且喜。稽首佛足。及礼阿难。受教而去佛说阿难分别经


佛说阿难四事经

    No. 493

佛说阿难四事经

        吴月支国居士支谦译

闻如是。一时佛在拘夷那竭国。欲灭度时。阿难白佛言。我念天龙鬼神。帝王人民与佛相见。闻佛教诫。无不欢喜。在志所愿。或作沙门。得应真者。或有居家。奉行五戒。死得上天者。今佛去世。天龙鬼神。帝王人民。及四辈弟子。当何恃赖得福得度。将当复从谁得之乎。佛言。善哉善哉。阿难。慈心多愍天人杂类。无不由汝得度脱者。吾去之后。世名五浊。人心愦愦。秽垢自乱。世多颠倒。贱善尊恶。此实可忧。世虽然者。吾有经籍恳恻之戒。尽心遵行。福自归身汝莫忧也。吾虽去世。典籍续存。六度大法不持之去。行者得度非神授与。汝等不解吾之所言耶。阿难即白。愿重说之

佛言。大法有四。可从得福。亦可得道。与得佛身。其福正等。阿难又言。愿佛为我解释四事。世尊曰。当以慈心育养幼弱。见禽兽虫蛾下贱仰人活者。常当愍念。随其所食。令得稣息。莫得加刀杖伤绝其命。恻怆慈心。当如慈母天龙鬼神。帝王人民。有行此慈者。其得大福。与侍佛身功德正等。此谓一事也。世有灾异。水旱不调。五谷不丰。人民饥馑。不安本土。志欲叛亡。王及臣民。富有仓谷。当惟无常。身命难保。勿爱宝谷。知爱人命。当起悲心。出谷廪假。赒诸穷乏。以济其命。安居本土。若意悭贪。不欲布施。当谛计念。人初来生。魂神空来。依因二亲情欲之气。以成己体。在母腹中。十月乃生。得亲喜悦。可得全命。愁忿之日。即切绝之。困极乃终。魂神不灭。复更求身。豪贵贫贱。皆由宿行。官爵俸禄。国土珍宝。无为迷惑。以乱高德。至其寿终。身及珍宝。故留世间。不随己去。常当慈心练行经道。以佛明教。观视人物。如幻如化。如梦如响。一切皆空。不可久保。观世皆尔。此为真谛。世人愚惑。心存颠倒。自欺自误。犹以金价。买鋀铜也。身死神去。当堕三涂。谛思如此。急当布施。与身命竞。贫穷乞丐。羸老疾病。随所当与。莫令命绝。执心如此。十方诸佛。开士大人。天龙鬼神。无不愍之。至于寿终。魂神所生。辄受豪贵。身意俱安。灾害不生。具获上愿。如佛在时。供养佛身。正等无异。此谓二事也。国中多有盗贼。水火灾异。变生毒气。流布疾病纵横。悉是海中龙神鬼王之所为也。故得此毒重病忧恼。此诸鬼神龙者。皆是世人所为。射猎屠杀鱼网。中毒死者。其魂神或堕海中为龙。或为有力太神化生之类。皆知宿命。忿怒宿怨。因作雾露吐恶毒气。雨其国中。其时人民。或中毒死者。或但得病者。有相涂污者。皆由世人所作。不仁残杀物命。展转相怨。手自杀者。中毒即死。助其喜者。皆更困病。或相涂污不相涂污者。皆由食肉。有相分者。不相分者。听聪之士。觉知杀罪追人不置。以己度彼。正等无异。如此奉行。佛之弘道。行四等心。慈悲喜护。福自归身。若彼杀家。以肉与己。慎莫食之。不食之者。虽处恶世。盗贼灾变。毒气之时。虽处其中。不相涂染其帝王人民。富有盈谷。孤独鳏寡。衣食不充。疾病困笃。无以自济。当给医药。糜粥消息。令其得愈。命不横尽。当明此人宿命行恶。不信三尊。背真向伪。悭贪所致。罪福分明。慎莫为恶。亦当慈心。以佛经法。教训愚痴。令持经道。若活一人。使病得愈。示之善道。令持五戒。终身清洁。与侍佛身。其福正等。是谓三事也

世有高节。清洁无欲。沙门梵志。怀抱经典。言辄法律。帝王臣民。心当恭肃。诣禀律行。此曹高士。口之所陈。皆是诸佛之遗典也。令人去恶就善。恩倍于亲。百有余分。使人寿终不堕三涂。常当慈心恭肃向之。宁洋铜灌口。利刀截舌。慎莫谤毁此清洁之人。宁自断手。莫加之痛。宁自剖腹。出心烧之。无怒此人。设使愚者见佛经道。明知去就。由远顽闇之群。驰就贤者之众。讲受圣典。以成高德。沙门梵志。无以贸买求利为身秽垢。心清行净。犹明月珠。护持应器。劳身乞食。供口即止。不畜遗余。或居寺舍。或处山泽树下冢间。皆知宿命。分别真伪制作经籍。为世桥梁。慈心多愍。坐起咒愿。帝王臣民。令国平夷。如此高士德训。诸天龙鬼。恻心不务世俗故。不为情欲之失所见叹述耳。国王臣民。若有智者。当寻求之。供所当得衣食床卧疾病医药。使其安隐。得讲经戒。敷演训导。坐禅念定。或从得道。或死得上天。衣食一国秽浊之人。不如尽心供养清净道士一人。其福弘大。如佛在时供养佛身。正等无异。此谓四事也。帝王臣民。视此辈人。天龙鬼神。无不拥护。助之欢喜者也

佛告阿难。吾前世时。行此四事。展转受福。自致得佛。吾以是故。重说四事。阿难。汝当广为诸天帝王臣民说之。所作善行。自得其福。终不唐捐。吾将灭度。四事累汝。阿难。闻经。且悲且喜。前以头面。为佛作礼佛说阿难四事经


佛说阿难问事佛吉凶经

    No. 492

佛说阿难问事佛吉凶经

        后汉安息国三藏安世高译

阿难说。闻如是。阿难白佛言。有人事佛得富贵谐偶者。有衰耗不得谐偶者。云何不等耶。愿佛天中天普为说之。佛告阿难。有人奉佛从明师。受戒不失。精进奉行所受。朝暮礼拜恭敬燃灯斋戒不厌。心常欢欣善神拥护所向谐偶百事增倍。为天龙鬼神众人所敬。后必得道。是善男子善女人真佛弟子也。有人事佛不值善师。不见经教信意不坚。亦有戒名违犯正律。既无形像亦不烧香然明作礼。恒怀嗔恚恶口骂詈。六斋不持杀生趣手。不敬佛经持着杂物弊箧之中。或着妻子床上不净之处。或持挂壁无有床坐棚阁。与世书无异。若有疾病了不念佛。便呼巫师卜问祠祀。请乞邪神。天神离远不得善护。妖魅日进恶鬼屯门。令之衰耗所向不谐。现世罪人非佛弟子。死入泥犁百毒掠治。魂神痛酷不可得言。愚人[夢-夕+登]瞢不能自思。先行无功还怨天地。责圣咎天迷谬乃尔。甚为愚痴遂为三涂所见缀缚。夫人得道皆从善生。经戒自御心身口。善为大铠不畏刀兵。善为大船得渡河渊。有能守信室内和安。现世有庆福追自然。行之得报非神授与。若人不信不持经戒。后生转剧。善恶逐人如影追形。勿作狐疑。自堕恶道。求脱良难。谛信不犯。所在常安。佛语至诚终不欺人。佛世难值人身难获。汝今侍佛宿福之大。当念报恩班宣法教。广为福田行之得度。所适无忧。阿难复白佛言。人不自手杀教人杀者。其罪云何。为无罪耶。佛言。阿难。教人杀者重于自杀。何以故。或是奴婢下贱之人作无杀意。或为王者县官所见逼促。不自意出为之所使。教人杀者而知故犯。阴谋残害复罪他人。欺罔三尊还负自然。其罪莫大怨对相报。世世受殃未有断绝。现世不安死入地狱。受毒痛裂。从地狱出为畜生。屠割皮骨以肉偿人。皆由前世残杀暴逆克贼众生阴谋怀害。无有慈心。见人杀者代其欢喜。以用快意过于自杀。罪深如是

阿难复白佛言。世间人及佛弟子。轻易其师恶意向师并道德人者。其罪云何。佛言。阿难。夫为人者当爱乐人德。欣乐人善不可嫉之。恶意向师道德人者。是恶意向佛无异也。宁持万石弩还自射身。为痛不。阿难言。甚痛甚痛世尊。佛言。人持恶意向道德人与其师者。痛剧弩射身也。为人弟子不可轻慢其师恶意向道德之人。道德之人当视之如佛。不可嫉谤。人有戒德者。感动诸天龙鬼神。莫不敬尊。宁身投火中利刀割肉。慎勿得嫉谤是善之人其罪不小。慎之慎之

阿难复白佛言。师者为可得呵喝弟子。以小罪成大。得无罪耶。佛言。不可不可。师弟之义义感自然。当相信厚视彼若己。己所不行勿施于人。弘崇礼律训之以道。和顺忠节不相怨讼。弟子与师二义真诚。师当如师。弟子当如弟子。勿相诽谤慎莫含毒。小怨成大还自烧身。观世恶人魔比丘辈。师不如师。弟子非如弟子。但共为恶不念行道。沮坏善者贪慕俗业。不计无常积财自丧。死堕恶趣饿鬼畜生。未尝有是相视若牛。于世何求念报佛恩。当持经戒相率以道。道不可不学。经不可不读。善不可不行。行善布德济神离苦。超出生死。见贤勿慢见善勿谤。不以小过证人大罪。违法失理其罪莫大。罪福有证可畏可畏。阿难复白佛言。末世弟子生是魔界。多有因缘。有居家之求身口之累。云何行之。佛言。为佛弟子。虽有因缘持戒勿犯。诚信畏慎敬归三尊。孝事二亲内外谨善。不念诳[佞-二+〦]心口相应。善权方便进退知时。可得作世间事。不得为世间意。阿难白佛。何谓世间事。何谓世间意。佛言。为佛弟子。可得估贩利业平斗秤尺施行以理。不得阿枉巧欺以侵于人。葬送移徙婚姻嫁娶。是为世间事也。世间意者。为佛弟子。不得卜问请符咒魇怪祠祀。解奏畏忌不吉。受佛五戒者。是福德之人无所畏避。有所施行当启三尊。无往不吉。戒德之人道护为强。诸天龙鬼神无不敬伏。戒贵则尊所往常安不达之者自作鄣碍。善恶由心祸福由人。如影追形如响随声。天无不覆地无不载。戒行之德福应自然。天神拥护感动十方。与天参德功勋巍巍。众圣嗟叹难可称量。智士达命没身不邪。善知佛教可得度世之道。阿难闻佛所说。便整袈裟头脑着地。唯然世尊。我等有福。得近如来耳餐法味。普恩慈大愍念一切。为兴福田令得脱苦。佛语至诚而信者少。是世多恶众生相诅。多信鬼神背正向邪。天堂皆空地狱塞满。甚可痛哉。若有信者或一若两。奈何世凋乃当如此。佛灭度后经法独存。少有行者人民转伪。渐销沦替将衰灭矣。呜呼痛哉复何恃怙。唯愿世尊。为诸晚学。留神显化未可般泥洹。阿难因进颂曰

  佛为三界护　　恩广普慈大
  愿为晚学类　　未可取泥洹
  痛矣未达者　　瞢瞢不别真
  法鼓震三千　　云何不得闻
  世浊诸恶人　　自还堕颠倒
  不信世有佛　　自作众罪本
  命尽往地狱　　刀剑解其身
  祠祀好杀生　　镬汤涌其中
  淫泆抱铜柱　　大火相烧然
  诽谤清高士　　铁钩拔其舌
  乱酒无礼节　　洋铜沃其口
  若生还作人　　痴騃无义方
  不杀得长寿　　无病常康强
  不盗后大富　　钱财恒自饶
  不淫香净洁　　身体鲜苾芬
  至诚不欺诈　　为人所信承
  不醉得聪明　　众人所尊敬
  五福超法出　　天人同俦类
  所生亿万倍　　真谛甚分明
  痴愚不别道　　蔽圣毁正觉
  死入无择狱　　头上戴铁轮
  求死不得死　　须臾已变形
  矛戟相贯刺　　躯体相残截
  曚曚不达事　　恶恶相牵拘
  展转众徒趣　　禽兽六畜形
  为人所屠割　　以肉偿宿怨
  无道堕恶道　　求脱甚为难
  人身既难得　　佛法难得闻
  世尊为众祐　　安住之特尊
  敷遗甘露法　　晚学普奉行
  哀我现深慧　　愍念群生故
  开悟示道地　　行者得度脱
  福人在向向　　见谛乐不生
  自归安仁圣　　殖种不死路
  恩慈无过佛　　神妙现威光
  愿使一切人　　得服甘露浆
  慧船到彼岸　　法磬倡三千
  彼我无我想　　众祐转法轮
  我等蒙嘉庆　　得舍十二缘
  欢喜稽首拜　　自归最无上

阿难稽首颂已。诸会大众得不回还。心意开解。僧那大铠志无上道。甘露之音香熏十方。示现道地为作桥梁。国王臣民天龙鬼神。闻佛所说。阿难所颂。且悲且感。且叹且喜。稽首佛足及礼阿难。受教而去佛说阿难问事佛吉凶经


佛说八部佛名经

    No. 429 [Nos. 427, 428, 430, 431]

佛说八部佛名经

        元魏天竺婆罗门瞿昙般若流支译

闻如是。一时佛游维耶离奈女树园。与大比丘众俱。比丘千二百五十诸菩萨无央数。尔时有长者子。名曰善作。从城中出诣奈女园。到世尊所稽首足下。右绕三匝却住一面叉手白佛。欲有所问。大圣见听乃敢自陈。佛告善作。恣所欲问。如来当具分别解说。善作见听便白佛言。唯天中天。宁有诸佛修行本愿自致正觉今现世讲说经道。大圣愿宣诸佛之名。闻之执持戴着顶上咨受所说。稽首归命颁宣功勋。无复众难不趣三涂。闻诸佛名。人若非人不得其便。若在县官说诸佛名。无能撗枉夺其所有。而性坚强不怀怯弱安隐得胜。又入战斗刀不伤身。箭射不入。阅叉诸鬼诸天龙神无敢娆者。师子虎狼野兽弊虫无能害者。佛告善作。谛听善思念之。当为汝说。拥护除难无恐获安。于是善作受教而听。佛言。东方去此有佛号奉至诚如来至真等正觉。今现在说经法。世界曰名闻迹

复次东方有佛号固进度思吉义如来至真等正觉。今现在说经法。世界曰莫能当

复次东方去此佛土。有佛号观明功勋如来至真等正觉。今现在说经法。世界名吉安

复次东方去此佛土。有佛号慈英寂首如来至真等正觉。今现在说经法。世界曰无恚恨

复次东方去此佛土。有佛号真性上首如来至真等正觉。今现在说经法。世界名曰去杖

复次东方去此佛土。有佛号念众生称上首如来至真等正觉。今现在说经法。世界曰炽盛首

复次东方有佛号踊首高超须弥如来至真等正觉。今现在说经法。世界曰曜赫热首

复次东方去此佛土。有佛号胜耻称上首如来至真等正觉。今现在说经法。世界曰爱乐。假使有人遥闻东方诸如来号。受此诸佛世尊之名。谛奉善思抱在心怀持讽诵读。纵使诸佛戒德智慧道本平等。又诸刹土庄严清净殊异之德卓然无侣。无有尘垢。无有女人污秽之难。亦无五浊勤苦之患三涂之厄。无沙砾石荆棘沟坑。佛言善作。若有能持奉是诸佛世尊之名颁宣远近。上夜觉寤而起经行。叹咏诵说此诸佛名。中夜后夜起一心住。舍此无益念所增修。如是行者德行日进终无损耗也。佛告善作。汝当乐此八佛名经。佛以斯法教族姓子。怀抱在心勿得忘舍。寻时精修便当逮见八千诸佛。善作于是闻圣教诏。则以宝华价直八千两金。供散世尊稽首佛足。右绕三匝却行而坐。时天帝释在于彼会。前白佛言。唯然大圣。我已受此八佛之名。以讽诵读抱在心怀。唯天中天。吾身当勤精进奉行是八部场诸佛尊名。思惟专念不离食息。贵重恭敬为无上宝。佛告天帝。以是之故。天阿须伦共战斗时。若有恐惧拘翼当念可无所畏。所以者何。假使有人赞叹称誉诸如来名八部经典。则为颁告无所畏业。宣诸如来经典名者。不遇恼热众患之难。若能显传诸如来名经典之要。则宣太平丰熟之世。能传诸佛经典名者。则宣安隐除去大患。能传诸佛经典名者。则为宣布寂然燕坐。若传诸佛经典名者。则离一切无数恐惧。若能传此诸佛名经。梦安觉欢不畏县官。水火盗贼怨家债主自然避去。鬼神罗刹妖魅魍魉。薜荔厌鬼皆不敢当。若入山陵溪谷圹路。抄贼劫掠自然不现。师子虎狼态罢蛇虺悉自缩藏。所以者何。诸佛至尊德过须弥。智超江海慧踰虚空。独步三界无能及者。十方一切莫不蒙度。佛说如是。长者善作及天帝释诸比丘僧一切会者。诸天龙神阿须伦世间人。闻经欢喜作礼而退佛说八部佛名经


佛说八大菩萨经

    No. 490

佛说八大菩萨经

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。与大苾刍众千二百五十人俱。复有八大菩萨摩诃萨。其名曰

妙吉祥菩萨摩诃萨。圣观自在菩萨摩诃萨。慈氏菩萨摩诃萨。虚空藏菩萨摩诃萨。普贤菩萨摩诃萨。金刚手菩萨摩诃萨。除盖障菩萨摩诃萨。地藏菩萨摩诃萨。以为上首。复有诸大菩萨摩诃萨。其名曰

无能胜菩萨摩诃萨。龙相菩萨摩诃萨。喜意菩萨摩诃萨。无垢藏菩萨摩诃萨。无垢称菩萨摩诃萨。智王菩萨摩诃萨。无边军菩萨摩诃萨。智光菩萨摩诃萨。慧光菩萨摩诃萨。慧灯菩萨摩诃萨。智灯菩萨摩诃萨。梵授菩萨摩诃萨。天冠菩萨摩诃萨。如是等诸大菩萨。皆来会坐

尔时世尊。告舍利弗。汝今谛听。过东方恒河沙数世界。有一佛刹名无能胜。彼土有佛。名善精进吉祥如来应正等觉。现为众生说微妙法

复次舍利弗。又过东方十恒河沙世界。有一佛刹名曰无我。彼土有佛。号普照如来应供正等觉。现为众生说微妙法

复次舍利弗。又过东方三恒河沙数世界。有一佛刹名曰善爱。彼土有佛。号吉祥如来应供正等觉。现为众生说微妙法

复次舍利弗。又过东方三十四恒河沙世界。有一佛刹名寂静藏。彼土有佛。号印捺啰计睹特嚩惹王如来应供正等觉。现为众生说微妙法

复次舍利弗。又过东方五恒河沙世界。有一佛刹名曰离尘。彼土有佛。号喜功德光自在王如来应供正等觉。现为众生说微妙法

佛告舍利弗。若有善男子善女人等。于此经中闻是诸佛如来名号。一心谛听或自忆念。或书写读诵为他解说。彼人命终不堕恶趣。不生边地邪见诸恶律仪下贱族中。亦不生于长寿天中。亦不生于五浊恶世。饥馑疾病刀兵劫中。亦无王难水难火难贼盗虎狼等难。常生佛刹及天上人间。身相端严诸根具足。眷属圆满得宿命智。具六波罗蜜。行四无量法。通达一切甚深法藏。成最上道。佛说此经已。诸大菩萨。舍利弗及诸苾刍。天人阿修罗等。闻佛所说皆大欢喜。信受奉行

佛说八大菩萨经


佛说八大人觉经

    No. 779

佛说八大人觉经

        后汉安息国三藏安世高译

为佛弟子常于昼夜至心诵念八大人觉

第一觉悟世间无常。国土危脆四大苦空。五阴无我生灭变异虚伪无主。心是恶源形为罪薮。如是观察渐离生死

第二觉知多欲为苦。生死疲劳从贪欲起。少欲无为身心自在

第三觉知心无厌足。唯得多求增长罪恶。菩萨不尔常念知足。安贫守道。唯慧是业

第四觉知懈怠坠落。常行精进破烦恼恶。摧伏四魔出阴界狱

第五觉悟愚痴生死。菩萨常念广学多闻。增长智慧成就辩才。教化一切悉以大乐

第六觉知贫苦多怨横结恶缘。菩萨布施等念冤亲。不念旧恶不憎恶人

第七觉悟五欲过患。虽为俗人。不染世乐。常念三衣。瓦钵法器。志愿出家守道清白。梵行高远慈悲一切

第八觉知生死炽然苦恼无量。发大乘心普济一切。愿代众生受无量苦。令诸众生毕竟大乐

如此八事。乃是诸佛菩萨大人之所觉悟。精进行道慈悲修慧。乘法身船至涅槃岸。复还生死度脱众生。以前八事。开导一切。令诸众生觉生死苦舍离五欲修心圣道。若佛弟子诵此八事。于念念中灭无量罪。进趣菩提。速登正觉。永断生死。常住快乐佛说八大人觉经


佛说八吉祥神咒经

    No. 427 [Nos. 428-431]

佛说八吉祥神咒经

        吴月氏优婆塞支谦译

闻如是。一时佛在罗阅只耆阇崛山中。与千二百五十比丘俱。菩萨千人皆弥勒等。佛告贤者舍利弗及诸比丘。皆一心听。佛告贤者舍利弗。东方去是一恒沙。有佛名安隐嘱累满具足王如来至真无所著最正觉。今现在说法。其世界名曰满所愿聚。去是二恒沙。有佛名绀琉璃具足王如来无所著最正觉。今现在说法。其世界名曰慈哀光明。去是三恒沙。有佛名劝助众善具足王如来无所著最正觉。今现在说法。其世界名曰欢喜快乐。去是四恒沙。有佛名曰无忧德具足王如来无所著最正觉。今现在说法。其世界名曰一切乐入。去是五恒沙。有佛名药师具足王如来无所著最正觉。今现在说法。其世界名曰满一切珍宝法。去是六恒沙。有佛名曰莲华具足王如来无所著最正觉。今现在说法。其世界名曰满香名闻。去是七恒沙。有佛名算择合会具足王如来无所著最正觉。今现在说法。其世界名曰一切解说音声远闻。去是八恒沙。有佛名解散一切缚具足王如来无所著最正觉。今现在说法。其世界名曰一切解脱

佛告贤者舍利弗。此诸佛如来无所著过四道不受最正觉。其国土清净无五浊。无爱欲无意垢。若有善男子善女人。闻此八佛及国土名。受持奉行讽诵。广为他人解说其义者终不愚痴。口之所言无有失误。相好具足无所缺减。无央数年不为乏少。是人终不堕太山地狱饿鬼畜生中也。是人终不望取罗汉辟支佛道而般泥洹。必当逮得无上平等之道。常遇陀邻尼。常行菩萨道得功德无量。第一四天王常拥护之。不为县官所拘录。不为盗贼所中伤。不为天龙鬼神所触娆。阅叉鬼神蛊道鬼神若人若非人。皆不能害杀得其便也。除其宿命不请。若有疾病水火乌鸣恶梦诸魔所娆。恐怖衣毛竖时。常当读是八吉祥神咒经咒之。即得除愈。是时佛说偈言

  若有持是经　　八佛国土名
  不堕三恶处　　疾得无上道
  自觉发道意　　见佛即开解
  中外常欢喜　　供养心恭敬
  亿劫阿僧祇　　行恶悉消除
  持是八吉祥　　速得明解教
  供事是经者　　千叶华中生
  珍宝为其出　　色像好无上
  人闻是尊经　　尊敬信乐者
  奉持讽诵读　　清净无放逸
  女人信是经　　敬慎无谀谄
  弃女为男子　　聪明常黠慧
  奉持八佛名　　出入贼不害
  刀兵水火毒　　诸邪不能干
  爱乐奉是经　　诸魔不得便
  鬼神诸官属　　无能娆乱者
  飞行到诸刹　　所在大丰乐
  心意正无邪　　见佛大欢喜
  所生常遇佛　　等心奉事之
  一切众恶除　　疾得泥洹道
  精进无懈怠　　去离诸缘着
  为人朴直儒　　奉持八佛名
  勇猛降众魔　　其力如金刚
  端正相好具　　一切莫能当
  布施无悭贪　　巨亿万家生
  盗贼及怨家　　自然皆消除
  疾病县官事　　乌鸣诸恶梦
  持是八佛名　　咒之即除愈
  奉持是经者　　弥勒菩萨等
  第一四天王　　常共拥护之
  所愿皆可得　　踊跃大欢喜
  一心信乐者　　福德亦如是

尔时诸菩萨颰陀和菩萨。罗怜那竭菩萨桥日兜菩萨。那罗达菩萨。须深弥菩萨。摩诃须和萨和菩萨。因只达菩萨。和轮调菩萨。是八人求道已来无央数劫。于今未取佛。愿言使十方天下人民皆得佛道。若有急疾。皆当呼我八人名字。即得解脱。寿命欲终时。我八人便当飞往迎逆之。诸菩萨弥勒等第一四天王。皆白佛言。吾当拥护持八吉祥神咒经者。与我并力令诸疾病皆得除愈。佛说经已。舍利弗弥勒菩萨。及诸比丘天龙鬼神阿须伦王。皆大欢喜乐闻

佛说八吉祥神咒经


佛说八师经

    No. 581

佛说八师经

        吴月支国居士支谦译

闻如是。一时佛在舍卫国祇树给孤独园。时有梵志。名曰耶句。来诣佛所。阿难白佛言。有异学梵志。今来在外。欲咨所疑。天尊曰现之。梵志乃进。稽首佛足。天尊曰就座。梵志就座。须臾退坐曰。吾闻佛道厥义弘深。汪洋无涯。靡不成就。靡不度生。巍巍堂堂。犹星中月。神智妙达。众圣中王。诸天所不逮。黎民所不闻。愿开盲冥。释其愚痴。所事何师。以致斯尊。天尊叹曰。快哉斯问。开发大行。吾前世师。其名难数。吾今自然神耀得道。非有师也。然有八师。从明得之刑戮。或为王法。所见诛治。灭及门族。死入地狱。烧煮搒掠万毒皆更。求死不得。罪竟乃出。或为饿鬼。或为畜生。屠割剥裂。死辄更刃。魂神展转。更相残贼。吾见杀者。其罪如此。不敢复杀。是吾一师。佛时颂曰

  杀者心不仁　　强弱相伤残
  杀生当过生　　结积累劫怨
  受罪短命死　　惊怖遭暴患
  吾用畏是故　　慈心伏魔宫

佛言。二谓盗窃。强劫人财。或为财主。刀杖加刑。应时瓦解。或为王法。收系着狱。拷掠榜笞。五毒并至。戮之都市。宗门灰灭。死入地狱。以手捧火。洋铜沃口。求死不得。罪竟乃出。当为饿鬼。意欲饮水。水化为脓。所欲食物。物化成炭。身常负重。众恼自随。或为畜生。死辄更刃。以肉供人。偿其宿债。吾见盗者。其罪如此。不敢复盗。是吾二师。佛时颂曰

  盗者不与取　　劫窃人财宝
  亡者无多少　　忿恚怀忧恼
  死受六畜身　　偿其宿债负
  吾用畏是故　　弃家行学道

佛言。三谓邪淫。犯人妇女。或为夫主。边人所知。临时得殃。刀杖加刑。或为王法。收系着狱。酷毒掠治。戮之都市。死入地狱。卧之铁床。或抱铜柱。狱鬼然火。以烧其身。地狱罪毕。当更畜生。若复为人。闺门淫乱。违佛远法。不亲贤众。常怀恐怖。多危少安。吾见是故。不敢邪淫。是吾三师。佛时颂曰

  淫为不净行　　迷惑失正道
  精神魂魄驰　　伤命而早夭
  受罪顽痴荒　　死复堕恶道
  吾用畏是故　　弃家乐林薮

佛言。四谓恶口两舌妄言绮语。谮入无罪。谤毁三尊。舌致捶杖。亦致灭门。死入地狱。狱中鬼神。拔出其舌。以牛犁之。洋铜灌口。求死不得。罪毕乃出。当为畜生。恒食草棘。若后为人。言不见信。口中恒臭。多逢谮谤。骂詈之声。卧辄恶梦。有口不能得含佛经之至味。吾见是故。不敢恶口。是吾四师。佛时颂曰

  欺者有四过　　谗佞伤良贞
  受罪痴聋盲　　蹇吃口臭腥
  痴狂不能言　　死入拔舌囹
  吾修四净口　　自致八音声

佛言。五谓嗜酒。酒为毒气。主成诸恶。王道毁仁泽灭。臣慢上忠。敬朽父。失礼母。失慈子。凶逆孝道。败夫失信。妇奢淫。九族诤财产耗。亡国危身。无不由之。酒之乱道三十有六。吾见是故。绝酒不饮。是吾五师。佛时颂曰

  醉者为不孝　　怨祸从内生
  迷惑清高士　　乱德败淑贞
  吾故不饮酒　　慈心济群生
  净慧度八难　　自致觉道成

佛言。六谓年老。夫老之为苦。头白齿落。目视[梳-木+目][梳-木+目]。耳听不聪。盛去衰至。皮缓面皱。百节痛疼。行步苦极。坐起呻吟。忧悲恼苦。识神转灭。便旋即忘。命日促尽。言之流涕。吾见无常。灾变如斯。故行求道。不欲更之。是吾六师。佛时颂曰

  吾念世无常　　人生要当老
  盛去日衰羸　　形枯而白首
  忧劳百病生　　坐起愁痛恼
  吾用畏是故　　弃家行学道

佛言。七谓病瘦。肉尽骨立。百节皆痛。犹被杖楚。四大进退。手足不任。气力虚竭。坐卧须人。口燥唇燋。筋断鼻坼。目不见色。耳不闻音。不净流出。身卧其上。心怀苦恼。言辄悲哀。今睹世人。年盛力壮。华邑暐晔。福尽罪至。无常百变。吾睹斯患。故行求道。不欲更之。是吾七师。佛时颂曰

  念人衰老时　　百病同时生
  水消而火灭　　刀风解其形
  骨离筋脉绝　　大命要当倾
  吾用畏是故　　求道愿不生

佛言。八谓人死。四百四病。同时俱作。四大欲散。魂神不安。风去息绝。火灭身冷。风先火次。魂灵去矣。身体挺直。无所复知。旬日之间。肉坏血流。膖胀烂臭。无一可取。身中有虫。还食其肉。筋脉烂尽。骨节解散。髑髅异处。脊胁肩臂。[月*坒]胫足指。各自异处。飞鸟走兽。竞来食之。天龙鬼神。帝王人民。贫富贵贱。无免此患。吾见斯变。故行求道。不欲更之。是吾八师。佛时颂曰

  我惟老病死　　三界之大患
  福尽而命终　　气绝于黄泉
  身烂还为土　　魂魄随因缘
  吾用畏是故　　学道升泥洹

于是梵志闻佛所说。心开意解。即得道迹。前受五戒。为清信士。不杀不盗不淫不欺。奉孝不醉。欢喜而去佛说八师经


佛说八无暇有暇经

    No. 756

佛说八无暇有暇经

        大唐三藏法师义净奉　制译

如是我闻。一时薄伽梵。在室罗伐城逝多林给孤独园。与大苾刍众及人天等俱。尔时世尊告诸苾刍曰。汝等当知。于此世间。寡闻无识。凡夫之类。常说无暇有暇之言。然不了知。云何无暇。云何有暇。吾今为汝分别开示。汝等谛听。善思念之。若诸有情。欲住圣行。修善法时。有其八事。无暇修习。云何为八。汝等当知。于此世间。大师出现。所谓如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人堕在地狱之中受大苦恼。是名最初欲住圣行无暇修习。复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人堕在饿鬼之中受大苦恼。是名第二欲住圣行无暇修习

复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人堕在傍生之中受诸苦恼。是名第三欲住圣行无暇修习

复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人生在长寿天中。无所知晓。是名第四欲住圣行无暇修习

复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人生在边地下贱蔑戾车中。不识善恶。于我四众。不闻不见。是名第五欲住圣行无暇修习

复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人虽复生在中国。然受恶报。聋盲喑哑。以手代言。于善于恶。不能分别。是名第六欲住圣行无暇修习

复次诸苾刍于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人虽复生在中国。其身虽不聋盲喑哑以手代言。于善于恶。悉能晓了。然而信邪倒见。作如是说。无施无受。亦无祠祀。无善恶业缘。无异熟果报。无今世后世。无父母眷属。无化生有情。于此世间。无阿罗汉正趣正行。此世他世。于现法中。得自觉悟。正证圆满。皆悉了知。我生已尽。梵行已立。不受后有。此事皆无。生极邪见。是谓第七欲住圣行无暇修习

复次诸苾刍。于此世间。无大师现。无十号名。不闻诸佛所证妙法。不除烦恼。不趣菩提。不至涅槃。无苦边际。有人虽复生在中国。不聋盲喑哑。不以手代言。于善于恶。悉能晓了。不生邪见。作如是说。有施有受。亦有祠祀。有善恶业缘。有异熟果报。有今世后世。有父母眷属。有化生有情。于此世间。有阿罗汉。正趣正行。此世他世。于现法中。得自觉悟。正证圆满。皆悉了知。我生已尽。梵行已立。不受后有。此等皆有。生极正见。然无将导开出离门。是名第八欲住圣行无暇修习

复次诸苾刍。于此世间。大师出现。十号具足。宣说诸佛所证妙法。善除烦恼。能趣菩提。究竟涅槃。尽诸苦际。说是法时。有人生在中国。而所受身。诸根具足。了善恶言。乃至生极正见。汝等苾刍当知。是人有暇修习。汝等苾刍。此有暇事。汝等已得生居中国。逢我出世。得闻圣教。诸根具足。当生勇猛常勤策励修诸善品。于善法律如说修行。展转相教展转忏悔。常净三业恒行十善。勿为无益致招后悔。尔时世尊欲重宣此义。说伽他曰

  我已为说八无暇　　皆愿当生有暇中
  若生难处不闻经　　汝等至心应善听
  铜柱铁山众苦逼　　煻煨粪屎刺刀林
  于地狱中受斯苦　　此处岂能闻正法
  饥渴针咽苦逼身　　雨注河流成猛火
  于饿鬼中受斯苦　　此处岂能闻正法
  更互恒怀怖害心　　常欲展转相食啖
  于傍生中受斯苦　　此处岂能闻正法
  若在天中有顶处　　由先福力生于彼
  长寿觉慧不分明　　此处岂能闻正法
  生在边方鄙恶处　　耳不曾闻说法声
  无识恒居蔑戾车　　此处岂能闻正法
  由彼先身造恶业　　聋盲喑哑缺诸根
  痴钝即是人身牛　　此人岂能闻正法
  若人不信于三宝　　说无因果无尊亲
  如是邪见坏其心　　此人岂能闻正法
  诸佛大师不出现　　亦无妙法流世间
  若人生居闇世中　　此时岂能闻正法
  若人生于有暇处　　八种无暇过皆除
  犹如病者遇良医　　应可至心闻正法
  汝已获人身　　复得闻正法
  不得圣果者　　多生无暇中
  我说八无暇　　是众生难处
  得住有暇者　　斯人世希有
  汝已获人身　　复得闻正法
  爱护自身者　　当除烦恼慢
  若有闻正法　　不能如说行
  轮回八难中　　备受诸辛苦
  已舍无暇处　　常求闻正法
  于生老死中　　不久当出离
  若已获人身　　闻法行放逸
  后当生恼悔　　如商人失财
  若人闻我说　　识暇及无暇
  是故应勤心　　正修于梵行
  我说明眼人　　善护于诸恶
  正念能防守　　不随诸有漏
  一切随眠断　　降伏大魔怨
  永超生死流　　得升于彼岸

尔时世尊说是经已。时诸苾刍人天大众。闻佛所说。欢喜顶戴。信受奉行佛说八无暇有暇经


佛说八阳神咒经

    No. 428 [Nos. 427, 429-431]

佛说八阳神咒经

        西晋月氏三藏竺法护译

闻如是。一时佛在王舍城灵鸟山中。时与大比丘众千二百五十人菩萨千人俱。皆如弥勒菩萨等。佛告舍利弗。东方去是过一恒沙有佛刹。佛号快乐如来无所著等正觉。今现在说法。国土名不可胜

舍利弗。东方去是过二恒沙有佛刹。佛号月英幢王如来无所著等正觉。今现在说法。国土名欢乐

舍利弗。东方去是过三恒沙有佛刹。佛号等遍明如来无所著等正觉。今现在说法。国土名喜爱

舍利弗。东方去是过四恒沙有佛刹。佛号分别过出清净如来无所著等正觉。今现在说法。国土名内哙

舍利弗。东方去是过五恒沙有佛刹。佛号等功德明首如来无所著等正觉。今现在说法。国土名无狐疑

舍利弗。东方去是过六恒沙有佛刹。佛号本草树首如来无所著等正觉。今现在说法。国土名无毒螫

舍利弗。东方去是过七恒沙有佛刹。佛号过宝莲华如来无所著等正觉。今现在说法。国土名莲华香

舍利弗。东方去是过八恒沙有佛刹。佛号宝乐莲华快住树王如来无所著等正觉。今现在说法。国土名甘音声称说

复次舍利弗。诸佛如来清净国土。彼方无五浊无爱欲无女人无意垢无咒诅无相择

复次舍利弗。诸佛如来。若有善男子善女人闻是八佛名者。受持讽诵读奉行者。终不堕三恶道。除五不中止罪

复次舍利弗。是善男子善女人。若有持是八佛名及国土名者。受持讽读奉行之者。以是功德若发菩萨心。所生处常遇陀邻尼。常遇相好常遇相音。常遇右转福。是善男子善女人。奉行是八佛教令如其正行者。女人所生处转为男子

复次舍利弗。诸佛如来。是善男子善女人。以平旦净澡漱正衣服。昼夜各三时奉读是经。得功德无量。第一四天王常拥护是善男子善女人。若在县官中当读是经。若在怨家中当读是经。若在盗贼中当读是经。若在水火中当读是经。若在海水中逢风浪恐怖当读是经。若在军兵对斗中当读是经。若为蛊毒所中当读是经。若闻恶鸟鸣若恶梦当读是经。若为龙神所中当读是经。若为诸魔所中恐怖毛起者当读是经。若有急恐病疫疾痛者。持是八阳咒经咒之立得除愈。是时佛说要偈

  是土无如来　　持是国土名
  一切众恶除　　疾得登正道
  所生常遇佛　　见觉大欢喜
  照是世上尊　　等心供事之
  百劫以无数　　着常当离之
  疾逮泥洹道　　奉是诸佛名
  今现诸如来　　奉行明教名
  为人朴直软　　在在见所生
  端正相好具　　巨亿万家生
  勇猛好布施　　为人不悭贪
  女人闻是要　　踊跃大欢喜
  去离女人身　　所生为男子
  诸兵不敢害　　蛊道亦不幸
  县官及盗贼　　终不害是人
  五魔不能娆　　将帅及官属
  奉行是经者　　不能中得便

尔时第一四天王弥勒菩萨等白佛言。我曹当共拥护持是八阳咒经一切学者。我曹当并力拥护病者令愈。佛说如是。第一四天王。弥勒菩萨等比丘众。及诸天龙鬼神人民阿须伦。闻经欢喜为佛作礼而去

八菩萨名

第一名颰陀和菩萨。第二名罗那邻竭菩萨。第三名憍日兜菩萨。第四名那罗达菩萨。第五名须深菩萨。第六名因抵达菩萨。第七名摩诃须和萨和菩萨。第八名和轮调菩萨。是八人求道以来其劫无数。今未取佛。是八人本俱学道时。俱愿八方上下人民皆共使得佛。若有急者当使呼我八人名字。即自得解除。若寿欲尽时。我八人便当飞行往迎之。愿持此一字之功德。愿一切人皆如八菩萨快也

佛说八阳神咒经


佛说百佛名经

    No. 444

佛说百佛名经

        隋天竺三藏那连提耶舍译

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘比丘尼优婆塞优婆夷。大菩萨众。及大诸天。帝释天王。大梵天王。四天大王。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。无量百千大众。前后围绕。恭敬供养尊重赞叹。尔时世尊。为诸大众宣说妙法。时尊者舍利弗。即从坐起整理衣服。右膝着地合十指掌。而白佛言。唯愿世尊。演说十方现在世界诸佛名号。所以者何。若有善男子善女人。闻是现在诸佛名者。生大功德。发阿耨多罗三藐三菩提心。得不退转。亦当速成阿耨多罗三藐三菩提

尔时佛告舍利弗。善哉善哉。汝今为欲利益安乐诸大众故。覆护怜愍诸众生故。令诸众生所求满故。欲令一切生欢喜故。亦为未来诸菩萨等增善根故。善哉善哉。生善觉观作如是问。如是问者皆是如来威神之力。舍利弗。汝今谛听。若有善男子善女人。闻是现在诸佛名号。能受持者。一切魔众于是人所不得其便。一切恶人亦不得便。获得无量无边甚深功德。随所生处具菩萨行。得宿命通颜容端正众相具足。常得亲近供养诸佛。乃至速成阿耨多罗三藐三菩提。何以故。舍利弗。若有闻是诸佛名号。受持读诵恭敬礼拜书写供养展转教他。所得功德无量无边。尔时世尊。即说偈言

  若能持此佛名者　　此人不为刀所伤
  毒不能害火不烧　　亦不堕于八难中
  得见大智金色光　　三十二相诸法王
  既得见于诸佛已　　无量供养彼诸佛
  其目不盲不赤黄　　身不伛曲不一眼
  得那罗延大力身　　受持佛名报如是
  常得天龙及夜叉　　乾闼婆等所供养
  怨家恶人不能害　　受持佛名报如是
  汝今谛听舍利弗　　如我所说微妙语
  若有闻此佛名者　　则得近于菩提道
  是故汝今至心听　　十方世界大法王
  能拔众生烦恼刺　　譬如药树除众病
  愚痴盲瞑凡夫等　　施与菩萨智慧眼
  又如行施胜菩萨　　无量千亿恒沙界
  于中悉满阎浮金　　昼夜六时无休息
  施与大悲大导师　　又以栴檀满百刹
  幡盖衣服如恒沙　　无量千万亿劫中
  一心而以用布施　　复于一佛国土中
  满中建立诸佛塔　　于十劫中而供养
  如恒河沙等诸佛　　又造高塔如须弥
  其塔悉以七宝成　　如是遍满十千刹
  其数三十有六亿　　以赤栴檀及真珠
  造作伞盖供养具　　一一伞盖能遍覆
  百佛世界等诸国　　真珠旒苏齐佛刹
  其数犹如恒河沙　　于空复造金伞盖
  其数亦如恒河沙　　色如紫磨真金像
  各各遍照三千界　　一一塔中设供养
  无量无边无数劫　　如上所作诸功德
  不及能发菩提心　　如是能发菩提心
  住不放逸清净戒　　不及能持此佛名
  如是能持此佛名　　又能怜愍诸众生
  所在诸方广流布　　教令受持佛名者
  彼于一切众生中　　为作福田犹如来

尔时佛告舍利弗。若有一心受持读诵忆念不忘此佛名者。所生贪欲嗔恚愚痴诸怖畏等即得除灭。未生贪欲嗔恚愚痴诸怖畏者能令不生。尔时世尊。即说佛名

南无月光佛　南无阿閦佛　南无大庄严佛　南无多伽罗香佛　南无常照曜佛　南无栴檀德佛　南无最上佛　南无莲花幢佛　南无莲华生佛　南无宝聚佛　南无阿伽楼香佛　南无大精进佛　南无栴檀德佛　南无海佛　南无巨海佛　南无幢德佛　南无梵德佛　南无大香佛　南无大生佛　南无宝辋佛　南无阿弥陀佛　南无大施德佛　南无大金柱佛　南无大念佛　南无言无尽佛　南无常散花佛　南无大爱佛　南无师子香胜佛　南无养德佛　南无帝释火炎佛　南无常乐德佛　南无师子华德佛　南无寂灭幢佛　南无戒王佛　南无普德佛　南无普德像佛　南无无忧德佛　南无优波罗香佛　南无大地佛　南无大龙德佛　南无清净王佛　南无广念佛　南无莲花德佛　南无舍花佛　南无龙德佛　南无花聚佛　南无香象佛　南无常观佛　南无正作佛　南无善住佛　南无尼瞿嚧陀王佛　南无无上王佛　南无月德佛　南无栴檀林佛　南无日藏佛　南无德藏佛　南无须弥力佛　南无摩尼藏佛　南无金刚王佛　南无威德佛　南无无坏佛　南无善见佛　南无精进德佛　南无大海佛　南无覆娑罗树佛　南无跋瑳德佛　南无佛天佛　南无师子幢佛　南无毗头德佛　南无无边德佛　南无德智佛　南无厚德佛　南无花幢佛　南无象德佛　南无精进德佛　南无龙德佛　南无德生佛　南无宝聚佛　南无德婆瑳子佛　南无论义佛　南无普见佛　南无宝多罗佛　南无普舍佛　南无大供养德佛　南无大网佛　南无断一切众生疑王佛　南无宝德佛　南无普盖佛　南无大盖佛　南无胜德佛　南无千供养佛　南无宝莲花奋迅佛　南无厚德佛　南无智幢佛　南无宝月德佛　南无尼瞿嚧陀婆瑳王佛　南无常德佛　南无普莲花佛　南无平等德佛　南无龙护救济佛

  此诸佛名等　　能救护世间
  初夜诵一遍　　思念佛而眠
  中夜诵一遍　　后夜亦复然
  如是昼三时　　于初中后分
  一时诵一遍　　精勤不放逸
  诵此佛名故　　常得见好梦
  恶鬼及恶人　　不能得其便
  是故此佛名　　能救护世间
  一切天乐神　　夜叉鸠槃茶
  罗刹诸鬼神　　不能起障碍
  于此百佛名　　常能念持者
  一切诸魔事　　不能得其便
  尔时天帝释　　三十三天王
  整理身衣服　　胡跪而合掌
  白佛言世尊　　我等常卫护
  受持佛名者　　及四天大王
  亦常护于彼　　受持佛名者
  唯除必定业　　不可得救护
  一切天人中　　无能加恶者
  尔时一切智　　出大微妙声
  八种和雅音　　善美众乐闻
  普告诸大众　　速受此佛名
  于十方世界　　所在广流布
  而作大法施　　断除众生疑
  大圣释迦文　　演说此法时
  三百诸比丘　　悉得诸漏尽
  复有比丘尼　　其数有四十
  一切漏法尽　　逮得阿罗汉
  复有优婆塞　　其数满五千
  住胜欢喜心　　获果须陀洹
  复有优婆夷　　其数千一百
  皆远离尘垢　　而得法眼净
  复有大天王　　无量千万众
  于法王法中　　得清净法眼
  如彼恒河沙　　分之为三分
  菩萨如一分　　悉获无生忍
  三千大千刹　　是时六震动
  诸山及高峰　　大地皆震吼
  于上虚空中　　雨诸天妙花
  天龙非人等　　喜声悉遍满
  尔时帝释天　　目连离波多
  蛇奴劫宾那　　摩诃迦旃延
  及摩诃迦叶　　沤楼频迦叶
  乃至那迦叶　　富楼弥多罗
  善吉不见空　　阿难陀跋提
  沓婆摩罗子　　如是等大众
  二万五千人　　同声白佛言
  释师子法王　　我尽精进力
  皆悉无有余　　以诸神通力
  于无量世界　　化作无量身
  过无量佛刹　　常说此佛名
  亦如佛所说　　尔时佛世尊
  为令众见故　　示现大神通
  现无量亿刹　　以佛神通力
  见释师子王　　处处而遍满
  说此修多罗　　亦如过去佛
  所说无差别　　佛告诸大众
  我于无量劫　　久善修神通
  于无上佛法　　决定莫生疑
  安隐众生故　　速说此佛名
  令诸众生等　　永离生死苦

尔时佛告慧命舍利弗。若有善男子善女人闻佛名已。深信清净发菩提心。爱乐受持昼夜精勤。读诵书写广为他说。得无量无边广大功德。得不退转乃至速成阿耨多罗三藐三菩提。一切众魔不能娆乱。佛说是经已。慧命舍利弗。释梵四王。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗等。一切大众闻此法已。皆大欢喜佛说百佛名经


佛说宝如来三昧经

    No. 637 [No. 636]

佛说宝如来三昧经卷上

        东晋天竺三藏只多蜜译

闻如是。一时佛在罗阅只竹园中。时与千二百五十比丘僧。菩萨有九十亿人。悉皆如文殊师利。是时罗阅国及竹园四面广纵。上到三十六天。下到无极佛刹地。悉生文陀般华。悉有九十万亿种种色。各各异非世之明。一华有百万叶。叶上悉有一怛萨阿竭。悉有交络万宝之盖。一盖之上各各有万种之音乐声相娱乐。一佛前各各有一菩萨。如文殊师利菩萨等问事。是时竹园地悉平等。如三弥佛刹。是三千日月诸佛境界。光明悉蔽隐无有明。一时诸佛境界诸大泥犁。毒痛勤苦悉为不行皆得安隐。百日悉得见十方佛。当是时禽兽飞鸟。悉百日不饭食。但听法味耳。不自知是众生亦复见佛。尔时罗阅国中人民。悉百日无复食五味者。悉以法作味。皆发阿耨多罗三耶三菩提心。三千大千佛境界树木自有音乐。自复相娱乐。是时竹园化作水池。池中有十万种莲华大如小山。一华有四十万叶。叶上悉有交露师子座。一座上各各有一菩萨。如文殊师利。一座前各各有天侍菩萨。交露帐间各各有万种音乐相娱乐。千岁枯死树悉为生华。三千大千佛刹诸树。悉为屈枝四面相向。是时竹园佛教导处。女人悉化为男子。无有爱欲悉得法眼。佛尔时为广大现宝如来三昧。即动九亿万佛刹土。尔时三昧都无所舍。有东方无极佛刹土。遣无数菩萨悉如如来等。各各自持无形之华。十万种异色之华。来到竹园。为正觉作礼。以华散正觉上却就坐。复有南方无极佛国土。复遣无数菩萨悉如如来。各各持二十万种华。来到竹园中。为正觉作礼。以华散正觉上却坐。复有西方无极佛。复各各遣无数菩萨。悉如如来等。各各复持三十万种异色华。来到竹园。为正觉作礼。以华散众会上却坐。复有北方无极佛刹。亦复遣无数菩萨。悉如如来等。各各复持异色四十万种之华来到竹园。为正觉作礼。以华散众会上却坐。复有东角佛刹。复遣无数菩萨。悉如如来等。各各持无形华。来到竹园。为正觉作礼。以华散佛及众会上却坐。复有南角佛刹。亦复遣无数菩萨。悉如如来等。各各持无想欲之华。来到竹园。为正觉作礼。以华散正觉及大会却坐。复有西角无数佛刹。复遣无数菩萨。悉如如来等。各各持无响之华。来到竹园。为正觉作礼。以华散佛及大会却坐。复有北角无极佛刹。遣无数菩萨。悉如如来等。各各持文尼之华。来到竹园。为佛作礼。以华散佛上及众会却坐。复有上方无极佛刹。各各复遣无数菩萨悉如如来等。各各持乱色之华。来到竹园。为正觉作礼。以华散正觉及大会却坐。下方无数佛刹。各各遣无数菩萨。悉如如来等。各各持诸妙华。来到竹园。为正觉作礼以花散正觉及大会却坐。上方诸天宿命。功德甚尊。遇佛大会旷大宝如来三昧。各各自庄严。天上诸天子。皆令初发意。梵天将无数天。各各持天香天华。梵多会天复将无数天。各各持天上杂华香。遍净天持非世间名华。诸尊天尽持天上伎乐。在虚空中立乐之。三千大千悉以法音。昼夜百日如是受之。来到竹园为佛作礼。爱欲天子复将无数天子。各各持天伎乐。来到竹园为佛作礼。于虚空中娱乐诸天。迦翼天上诸天持千万种杂香。以散佛上及诸菩萨上。为佛作礼。尽天上诸天。悉来会竹园中。上到三十六天。中间无缺。悉诸天子诸大龙王。各各复将无数官属。持世间人所不能得华以雨竹园。诸阿须伦王各各复将无数官属。各各持杂华。以雨佛上及诸菩萨上。诸迦楼罗。各各复将无数官属。来到竹园。诸真陀罗。各各复将无数官属。来到竹园。诸摩睺勒。复将官属来到竹园。佛尔时现宝如来三昧。即动九亿万佛刹。舍利弗见地大动。舍利弗白佛言。今诸远方菩萨诸天人民悉会。上到三十六天地为大动。是何等应。佛告舍利弗。无应之应是其应。舍利弗复白天中天言。无应之应是何应是何等。佛告舍利弗。若疑不断若往到宝如来菩萨所。舍利弗正衣服礼如来若干过。叉手白如来言。今日诸十方。上到三十六天。百千亿佛刹菩萨悉会。何等之应。愿如来说之。如来谓舍利弗言。若阿罗汉本疑大重故来解耶。如来菩萨言。舍利弗。若常有想。想者非尽之作。无想无作。是故宝法如来告舍利弗。我初发意时。与三十六亿人求菩萨道。正觉时亦在其中。一切悉起我不作。诸悉作我不念空。法悉无我无求生死。生死无道无有断者。虚空无主。我非所有现法。譬若野马无相起作。持是作法灭行求愿。想欲得是为怀重者。罪之明。自言得道起想罪想。坏灭诸慧求得三尊。从是作想取泥洹。疑尽灭身。然生死不断。言得泥洹罗汉。譬如命尽之人其身在床。一时得闻须臾休息。命尽犹不离于身。罗汉辟支佛自得禅。是非大积疑耶。如来谓舍利弗。佛所问乃尔。如来谓舍利弗言。若当见龙欲作雨起云时不。舍利弗言见之。四面不知云所从来。何况菩萨从第九以下。悉得逮六万三昧。何道菩萨所从来处。舍利弗白如来言。解慧如是心意疑结。今悉破坏都无复有疑根。但学本不得。善知识相得。今故断灭我意。令我不脱法轮。令我疑根不绝耳。今我闻尊法无所益。譬如为百鸟作音乐会无有听受知者。如是但当为坐中新发意诸摩诃萨故。令大会诸天及人。得闻是尊三昧。何一巍巍乃尔。但当亲近尊。但我前世不与善知识相得故。令我不得见是三昧如来慧。如是心意所疑今散解。譬如冥处须臾以火明之。火灭冥复在处。今我闻之如是。舍利弗叉手白如来言。今乞得作八千里大火。上到三十六天。持我身置其中亿万劫。后出复入三恶道。为天下人所啖食数千亿劫。后生作人如奴事大夫。求善知识相得。求我心中所愿可得不。实如来言。大火上至三十六天。尚可浇灭。若本发意微薄功德无厚觉本。不得萨云若。不得沤和拘舍罗。不得善知识。故不致是耳。舍利弗问事竟还坐。如来正衣服。为正觉作礼。愿欲有所问。佛言。善哉善哉。当问如来。白佛言。诸法无主。谁为成萨云若者。谁为成正觉者。谁为成阿罗汉辟支佛者。愿怛萨阿竭。当为坐中诸摩诃萨分别其决。佛言。善哉善哉。如来乃欲决断十方大生死根。若有善男子善女人。欲使发阿耨多罗三耶三菩提心。当行九法宝。何等为九法宝。一者见诸天无有处但有名耳。二宝者世间人民但有字耳。三宝者五道勤苦但有苦习耳。四宝者水火风地但有戏耳。五者当来过去现在如芭蕉无想。六者现生死无本际也。七者观诸三昧寂然无有往来者也。八者当观三千大千日月诸佛刹土。见之了无得三昧者。九者见三千大千日月中人民蠕动。悉欲度之令与佛等。佛告如来。得是无作之想者。即可决断十方之大想。如来复白正觉言。诸法不以想见知之。当作何等住得无所住法。佛言。诸法无住是即为想无起之念。是亦复为想非想非道。亦复为想断求之作。如来白天中天言。当作何缘度众欲。佛言。善哉善哉。如来所问乃尔故。非罗汉辟支佛所及者。众欲无垢。众欲无过度。众欲无主。众欲无往来者。众欲如虚空无有能蔽隐者。与泥洹等与无名等。如来问事竟为天中天作礼却坐。般施白佛言。今日大会菩萨欲于佛树。欲得无所从生处立。欲得庄严千亿佛刹土。欲得教授十方。悉使十方诸佛刹土。各如今日会竹园中时。佛言。善哉善哉。般施菩萨所问甚深甚深。佛语般施菩萨言。欲得使十方大会欲坐于佛树。欲得无所从生处立。欲得庄严诸佛刹土。欲得教受十方。悉使诸佛刹土。各自会如今日会竹园中时者。当行八直。一者直无名之响。二者直无名之声。三者直观十方佛刹土无有二。四者见三千大千刹土。直之法皆同无相离者。五者直观十方一切欲令与佛等。六者直于法无作形。见一切不生死者。七者所见直悉入诸三昧。藏于无住相报之想。八者直见十方佛。泥洹不泥洹亦复悉等。是为八直。法行菩萨从是疾得无所从生法。从是得教授诸佛刹土。从是疾得大会竹园如今日会时。如来复白正觉言。今日远方悉来会竹园。悉得见佛如其处是。欢喜不食若干日。各各自是诸菩萨诸天及人民皆得见佛。皆见诸三昧。是其本愿所致耶。佛当为新发意摩诃萨解说如是

佛言。善哉善哉。如来所问甚深。悉欲为诸来会菩萨。新发意诸天人民。作桥梁如是。佛语如来。是今日诸菩萨摩诃萨。诸天人民大龙王诸鬼神王。悉来会竹园者。皆闻见诸三昧。亦非本愿。亦不离于本愿。所行常精进不失诸三昧不失善知识世世远众事寂然不数会。但愿是三昧。今故以宝精泥洹珠。以雨大会耳。如来白正觉言。今会有新发意摩诃萨。欲行是三昧。当何以致之。佛言如来。所问甚快。若新发意摩诃萨欲行是三昧。当行八法宝。何等为八法宝。一者即于佛前是三昧。是为一法宝。二法宝者供养十方诸罗汉。从其相随亿亿万劫。一时闻是即解亲近尊。三昧不远。是为二法宝。三者供养舍利从上至三十六天。中无空缺无益一时也。转意作行即向慧问。是为三法宝。四法宝者得四无所畏。不与十方于生死无所远离。是为四法宝。五法宝者菩萨见五道勤苦。心意欲悉止度之。以其身救之命。不用作勤剧趣令得佛耳。是为五法宝。六法宝者菩萨事十方天下人。常如奴事大夫。不用作苦贵度之。所以者何。知本求无故本无所起故。是六法宝。七法宝者菩萨观见九十六种外道。于其中觉知之。欲起想取法住。是为七法宝。八法宝者奉行六波罗蜜。供养比丘僧。供养亿万劫。不如一时闻是宝如来三昧。十方当作佛者用何为证。闻是宝如来三昧者。即十方人得佛证。若新发意向是三昧。欢喜解是三昧者。即是为以解万万三昧。为已得如来三昧。是为八法宝。令行是三昧即可得陀罗尼门。如来问事。竟还坐。佛便笑。文殊师利正衣服头面着地。叉手为佛作礼。白佛言。佛不妄笑。既笑当有意。愿佛说之。佛语文殊师利言。宝如来所从来佛刹。过是九亿万佛国土。其刹名曰诸法自然无厌敢有。善男子善女人。往者无有胞生者。无有苦痛生者。无恩爱生者。悉于百亿万杂华香中生即立住。悉有乱音乐声朝暮相娱乐。但以无作法。但以寂然法为唱乐。若善男子善女人。闻是三昧。即却六百四十劫。罪尽绝命。即得往生。往生者但以诸三昧为乐。宝如来刹。无有日月光明。虽有为不现。若有善男子善女人往生者。日月光明星宿明即为现。应是三昧当往生者。星宿日月光明悉为见。十方佛言。今日复往生宝如来刹。十方诸菩萨问十方佛。何以为证。十方佛言。以星宿日月明见作证。罗汉辟支佛其数如是。非诸罗汉辟支佛所及知。以往生其国中。善男子善女人。菩萨自知之耳。我故笑也。须菩提及舍利弗二第一贤者。起头面着地。为正觉作礼。愿佛加大恩。广大哀我等。以佛威神神足与我。我等欲到宝如来刹土诸法自然国。观须臾复还。佛言。善哉善哉。舍利弗尊。罗汉须菩提乘佛威神须臾即到宝如来菩萨刹。便复见宝如来国中。亦复罗阅竹园如释迦文佛会时也。见东方遣无央数菩萨。见南方无数菩萨。十方上至三十六天会如是。舍利弗问须菩提。怛萨阿竭随我人来到是刹也。须菩提舍利弗须臾便还。到竹园众会如故。佛问舍利弗。向观宝如来国土人民何类教授几人。须菩提舍利弗白佛言。观彼国悉如今日会竹园中时也。舍利弗为佛作礼。佛功德甚尊。今大会诸天人民。得见明乃如是。三弥菩萨从坐起。正衣服。头面着地。为佛作礼。愿欲所问。佛言。善哉善哉当问。三弥菩萨白佛言。无生之法有想无。未起之想有识无。泥洹寂然有无。泥曰不起有形无形者。在彼间教。生死立处。谁是主者。以空造空是为主。三弥闻佛解说是事如是。即时诸天及人八万六千人。即得无所从生法忍。即住虚空中去地百六十丈。来下为佛作礼。是时三千大千日月即复大动。弥勒菩萨从坐起。为佛作礼。问佛言。向者地大动。是何之应。佛语弥勒菩萨言。所以地大动者。非但刹动。十方诸佛刹悉复动。亦复各各八万六千诸天及人。得无所从生法住。即住虚空中。如是以故地大动耳。弥勒白佛言。何从致若有发意常当六法。何等为六。一法者知三十六天。当得佛者。未得莂者。我当往莂之。不与十方天下人共知之。二法者三千大千日月中。善男子善女人当得佛。我悉当往莂之。不与十方天下人共知之。三法者百千泥犁中人。当得佛者。我悉往莂之。不与十方天下人共知之。四法者十方人绝命当所生处我悉知之。不与十方天下人共知之。五法者十方天下人命尽我悉知之。不与十方天下人共知之。六法者十方诸佛当取泥洹不取泥洹者。不与十方天下人共知之也是为六法住。从是疾得无所从生法忍。弥勒菩萨复白佛言。是三昧甚尊甚尊。今我欲使来会者悉得是三昧。当行何等法。佛言。当行九法。何等为九。一法者视诸法悉清净无边。二法者视天悉清净。三法者视诸生死亦清净无边。四法者视五道悉清净。五法者于欲无所求悉清净。六法者视三界色悉清净无有边。七法者见诸泥犁悉清净无边。八法者观视泥洹悉无边。九法者十方无有举名者。是为九法。作是行者疾得是三昧。弥勒白佛言。说是如来时。即得六万三昧。三昧乃有边幅无如得六万三昧。是为有边幅耶。佛言。虽得六万三昧但有名耳。不可极尽三昧悉具足。佛言。三昧非但一辈。有无念三昧。有离欲三昧。有坐听十方佛三昧。有庄严诸佛国土华香三昧。有所说法一切人悉还本三昧。有出诸欲无还想三昧。有说经时化为百种音乐声三昧。有说法亿千万佛国华香自然来三昧。有伏诸魔三昧。有发师子意独行独步三昧。有所向处莫不发阿耨多罗三耶三菩提三昧。有所在处莫不供养者三昧。有乱风一起时如佛说经声三昧。有所向门莫不开三昧。有所处悉师子座为现三昧。有飞到十方三昧。有所向门十方菩萨往来无极三昧。有所知十方人意三昧。有坏灭诸想三昧。有坏灭诸识三昧。有合十方诸刹土合为一刹三昧。有发意不尽三昧。有视三界中了不有一人三昧。有从一佛国到一佛国三昧。有所在处令法不断绝三昧。有所在处常与佛相遇三昧。有坐观十方大兵大火大水大风于其中不恐怖悉住教导之二昧。有所在处但以法作器三昧。有善男子善女人闻是三昧。即得住无还之想三昧。是三昧大多不可极尽故。住大会说之。有无名三昧。有住诸法三昧。有名诸慧三昧。有教法三昧。有灭坏罗汉辟支佛三昧。有法宝三昧。有总持无名法三昧。有知人意三昧。有断诸烦荷三昧。有制力欲觉三昧。有十种力三昧。有智慧三昧。有光明所行处三昧。有不可计三昧。有见法时如水中影三昧。有不可尽净慧三昧。有人空众恶无有无愿想三昧。有住禅乃到泥洹三昧。有譬若金刚无秽三昧。有无极明三昧有度诸烦荷已尽三昧。有广大水法三昧。有庄严大船三昧。有入无名三昧。有不可尽喜意三昧。有总持无忘三昧。有在冥悉令明三昧。有所乐悉乐三昧。有慈行三昧。有净大哀三昧。有入等心三昧。有出等心三昧。有名已脱未脱三昧。有光明所从来处三昧。有晓无所不晓三昧。有脱慧脱教三昧。有金色莲华为现三昧。有无离无常三昧。有尊智慧无生三昧。有勇猛无所不伏三昧。有开辟诸刹三昧。有清净于无形三昧。有无名珍宝三昧。有如海无所不受三昧。有神足广大三昧。有弹指顷无所不及三昧。昙摩竭菩萨语舍利弗言。所问慧住故曰不可极。应时闻所闻如意不自贡高。所作不妄常敬意如所教。习慧用意无所受故不失礼节。所作法不妄不乱。意如珍宝除诸老病。以意为法器也。是为乐忍辱。所思但想。诸所乐但法意。慧不有足时。所施无所惜。与无适莫。所问谛意观。欢喜无所得。其意已悦身体悉为轻。意不在外道。但欲闻法味及毗罗经。但欲闻沤和拘舍罗。但欲闻四平等心。但欲闻无底法如意无异念。欲意受沤和拘舍罗。欲闻无所从生法不贪观。但欲慈度之。欲知无常声。欲知寂然之意。欲知空复空。欲知无想生死及布施。一切不欲闻。但欲闻音乐。随乐十方中。忠信以作。正降伏诸欲根。昙摩竭菩萨从坐起。正衣服白佛言。菩萨已得宝如来三昧。自在所为众慧已具。便得三宝。何等为三宝。一者譬如水中影。影亦不在水中。亦不在水外。菩萨于是间坐。其身悉在十方。其身亦不在十方。二者菩萨于是间坐。分身悉现十方佛前坐。其身亦不在十方佛前坐。三者譬如山中呼响音声还报。音响亦不在中。亦不在外。菩萨于是坐。悉遥说十方诸菩萨事。十方诸菩萨亦无来到彼者。彼亦无往者如是。佛语昙摩竭菩萨。已得陀邻尼门。譬如持弓弩布矢。在所欲射无所不到。菩萨持一慧入万慧。靡所不至如是。佛言昙摩竭菩萨。若乃见阿须伦欲兴兵时。弹指顷兵便到二十八天。中间无空缺。菩萨以次第九。以下说法时如是

如来菩萨语舍利弗言。净者贪欲消伏。其意无贪欲者是不可尽。其诸恶意者不能复乱。其意护于恶意。是故不可尽。其意嗔恚有形欲贪高。诸所不可索可作者。菩萨常欲护是意。知不可尽去。无瞻诸垢。当知是意不可尽。护者不令懈怠。当知其意不可尽。其狂乱者轻已法护之。当知是意不可极。无智慧者欲护之。当知其意不可极。一切以法施与以法脱之。当知其意不可尽。欲教一切人皆令为功德。当知其意不可尽极。如来语舍利弗言。菩萨有四法。何等为四。一者意作陀邻尼行不可尽。二者陀邻尼行不可尽。三者教一切人是不可尽。四者不厌学问故陀邻尼不可尽。如来菩萨复语舍利弗。复有四事不可极。一者上脱中脱不可尽。二者四马之路不可极。三者可意之王不可极。四者十二因缘无有主不可尽极。如是为不可极。如来菩萨语舍利弗。复有八法不可尽。何等为八。一者无我之语不可极。二者无作之极想不可极。三者寂寞泥洹之语不可极。四者菩萨所度不可极。五者大海流水无有懈惓不可极。六者众恶无垢不可极。七者苦痛之声不可极。八者去来之想不可极。是为八法所度无主不可极。如来菩萨语舍利弗复有九法不可极。何等为九法。一者诸佛刹土不可极。二者诸菩萨所从来处不可极。三者发阿耨多罗三耶三菩提者不可极。四者失愿取罗汉辟支佛不可极。五者十方菩萨从一佛刹土。飞到一佛刹土不可极。六者六波罗蜜不可极。七者三昧不可极。八者过于泥洹亦如化视之无极。九者三界不可极。是为九法不可极

如来语舍利弗言。菩萨有三十二宝。何谓三十二宝。一者其心不着爱欲。是忍辱不可极。是即为宝。二者不起是我非我亦无所造。是故忍辱不可极。是即为宝。三者不念一切善恶。是为忍辱不可极。是即为宝。四者不恒心意于一切。是为忍辱不可极。是即为宝。五者不嗔怒向于一切人。是为忍辱不可极。是即为宝。六者不怀念他人乱恶。是为忍辱不可极。是即为宝。七者亦不妄娆人有所击。是为忍辱不可极。是即为宝。八者不调戏于大会中。是为忍辱不可极。是即为宝。九者自护护他人身。是为忍辱不可极。是即为宝。十者若贫穷者给护之后不从有所悕望。是为忍辱不可极。是即为宝。十一者自护不随恶知识不随众会。是为忍辱不可极。是即为宝。十二者无爱欲意于身于他人身。是为忍辱不可极。是即为宝。十三者不起诸想无念于菩萨如弹指顷。是为忍辱不可极。是即为宝。十四者护功德庄严身相。是为忍辱不可极。是即为宝。十五者信作善不离于三昧。是为忍辱不可极。是即为宝。十六者口不妄语。是为忍辱不可极。是即为宝。十七者心净。是为忍辱不可极。是即为宝。十八者坚住善知识世世与相随不舍。不于他处说其过失。不说之恶。是为忍辱不可极。是即为宝。十九者自挍计他人有恶者我亦有恶。是为忍辱不可极。是即为宝。二十者所念无有邪即觉。是为忍辱不可极。是即为宝。二十一者软心和意。是为忍辱不可极。是即为宝。二十二者护恶人令心不起。是为忍辱不可极。是即为宝。二十三者生于诸天教导诸天。是为忍辱不可极。是即为宝。二十四者生天上世间教两道中不更三恶道。是为忍辱不可极。是即为宝。二十五者具足诸种好。是为忍辱不可极。是即为宝。二十六者得音如梵天声。是为忍辱不可极。是即为宝。二十七者脱淫怒痴。是为忍辱不可极。是即为宝。二十八者不于诸色与名。是为忍辱不可极。是即为宝。二十九者所作功德不着但欲起众法耳。是为忍辱不可极。是即为宝。三十者降伏诸外道。是为忍辱不可极。是即为宝。三十一者已出于众侯中。是为忍辱不可极。是即为宝。三十二者具足诸佛法使不伤毁。是为忍辱不可极。是即为宝。如来菩萨语舍利弗。菩萨有三十二事。为宝如所入。何谓三十二事。一者欲入响欲入观无所观。是即为宝。二者欲入心离心于心无主。是即宝。三者欲入身求脱本无脱者。是即宝。四者不入十二因缘无有住者。是即宝。五者欲入断离于不断。是即宝。六者欲入无常视之无形。是即宝。七者欲入无名主离于无名。是即宝。八者欲入寂不离于起。是即宝。九者欲入三界不离三界。是即宝。十者欲入受无所受。是即宝。十一者欲入当来过去亦出当来过去。是即宝。十二者欲入功德观本末无主。是即宝。十三者欲入空空中空。是即宝。十四者欲入无想不起无想。是即宝。十五者欲入愿不起愿。是即宝。十六者欲入空离想空。是即宝。十七者欲入三昧无有合者。所以者何法无二法。是即宝。十八者不以三昧有所愿生处。是即宝。十九者三昧不为一切诸法作证。是即宝。二十者欲入无生之道有度者。是即宝。二十一者欲入无生处。是即宝。二十二者欲入不动摇处。是即宝。二十三者欲入一切无我不离无我。是即宝。二十四者欲与生死初无相知者。是即宝。二十五者欲与三昧初无所识者。是即宝。二十六者相欲切相知者。是即宝。二十七者欲厌欲意。是即宝。二十八者欲入不念无有。是即宝。二十九者欲入诸陀邻尼门无所不总。是即宝。三十者欲入诸所作恶欲不为恶。是即宝。三十一者欲入沤和拘舍罗以意作法器。是即宝。三十二者欲与万事相应不相远。是即宝。

佛语如来。譬如若欲入城会从其门。欲知因缘无所诤。欲知诤者不如自守。欲知不欲语言者。不如莫那中居不动者勿得转欲。无悕望者无所想。是故等不欲危者。当正位谓至故。欲有不与者。当自守其家。能自守者不称说。不自高不自下者。其人已具足故。不欲咸者。无而谴之者。欲有所使者。所作无所失。得道亦如是无痴。无痴者知本无故耳。知本无者无所失故。三世等无异。三世无增减者不住色。已不住色。为不住众法也。眼见色者。但是眼眼精住是色也。耳闻声声识无所住。鼻闻香香识无所住。口所识味味亦无所住。身知细滑识亦无所住。意不知识。识不知意无所住。如本行无有想。慧行谛谛如我。无有我是我所。非识法见我。但见无我名者慧不知诸所有亦不知慧。欲不知习。习不知慧。慧不知身。身不知慧。菩萨其心不离其心是非耶。昙摩竭菩萨白佛言。天中天。道不与想合。为有合者无。佛语菩萨。诸法不以为证。但以音响为法。譬若人吹长笛。音声悲快与歌相入。知歌气笛气合同一音出。菩萨诸三昧亦如是。诸法无生坏者。亦离于坏灭。诸化亦如是。诸念亦如是。诸觉亦如是。诸生无名离于无名。诸念无名离于无名。诸化无名离于无名。觉无诸名离于无名。无处我不想之。但无作之想为离。但已无作之作。已为作想。想行寂然。都无所著。法非欲一切皆然

如来正衣服白正觉言。诸法不起。今复欲问如来。昙摩竭菩萨向者所问。欲决断大疑。各还本处。佛语如来。诸法若生处无有处。若化处无有处。诸法若觉处无觉处。诸法若念处无念处。如来菩萨白天中天言。生生处有生处无。化化处有化无。无念处有念无。无觉处有觉无。如来言。生生复生泥洹生。是为合。怛萨阿竭意非合。生生复生不生泥洹生是不合。怛萨阿竭意是合。化化复化泥洹化是为合。怛萨阿竭意非合。化化复化不化泥洹化。是为不合。怛萨阿竭意是合。念念复念泥洹念。是为合。怛萨阿竭意非合。念念不念泥洹念。是不合。怛萨阿竭意是合。觉觉复觉泥洹觉。是为合。怛萨阿竭意不合。觉觉复觉不觉泥洹觉。是为不合。怛萨阿竭意是合。文殊菩萨说偈言

  法者无有生　　合为一刹耳
  生生不复生　　泥洹皆如是
  化者从本无　　化化无脱者
  化与泥洹等　　寂然无处所
  念者本无识　　发念因空耳
  泥洹与念等　　所念谛如是
  觉觉平等等　　所觉无所到
  所觉无常住　　是故怛萨竭
  化处无有处　　所觉无所到
  若化无处所　　诸法皆如是
  生处有本无　　无生是其处
  化处无名处　　一切为三昧
  念处有念无　　从空到是处
  非本无所谛　　其慧已如是
  觉不行相连　　觉不离其处
  行从觉见谛　　离觉无有脱
  所生法不绝　　所在常如是
  三千日月中　　所明无有上
  法有非思想　　可得还行者
  于欲不起垢　　非空亦非想
  如来意常净　　亦不处法名
  所脱非常住　　一切如本处
  华香自然来　　所出无处所
  清净意无处　　所有皆悉尔
  千岁枯树生　　皆从发意起
  皆见大光明　　世间最无有
  虚空为音乐　　昼夜光明现
  是时及大会　　悉发菩萨意
  人民大欢欣　　皆得闻是经
  即动三千刹　　得受不动身
  寂然法为现　　无名是其应
  何况世所有　　一切皆如是
  清净不为定　　痴慧本无现
  清痴合用本　　慧本无脱者
  三昧无所造　　一切皆如是
  菩萨住道地　　在意所从生
  五事不可亲　　今堕五道中
  远离如是行　　得佛达十方
  百日法为时　　奉行是三昧
  皆从诸刹来　　飞到怛萨前
  诸天及国王　　悉得见佛身
  志意大欢喜　　身体为悉轻
  不当以色想　　观法有三千
  般若毗罗法　　所处无三千
  如来本发意　　愿不离十方
  常作大法国　　所处无三千
  三界及已上　　乃到忉利天
  悉阿陀那佛　　其号天中天
  发意到其国　　须臾复来还
  摩提那菩萨　　飞到竹园中

舍利弗白如来言。愿复有所问。如来所从来处刹土。何类厚薄。何如本愿。何如无极国土。如来语舍利弗言。本愿无极。无极国中悉菩萨。无阿罗汉之名。无女人之声。宫殿皆水精。黄金为树。白银为叶。珊瑚马瑙为实。铫铫鐄鐄非世所明。诸菩萨皆生莲华中。如来语舍利弗言。舍利弗。我发愿已来所度不还。无愿不极所愿也。珍宝金银树木。我欲皆不欲耶。法者无起之处起。愿珍宝是非思想耶。百千亿佛刹土有起愿者。今复还是无极之想愿也。舍利弗白如来言。宝如来时持亿万种华来。各各异色。岂非想耶。如来语舍利弗。是无形之华。但已华作法器授之耳。诸菩萨以花所竹园中者。悉已法授之。不于中愿生。持华为主。不于华中生也。如来语舍利弗。若初见佛形像不。舍利弗言见之。人悉为佛像作礼。其佛威神无有不归之者。其中有道威神无。舍利弗言。威神在何所。如来言。亦不在像中。亦不离于像。但有想者言有威神耳。观之了无威神愿者。譬如忉利天上有树名拘者。而华炽盛。诸天莫不爱乐者。菩萨已法为一切识可意王。作眼目耳。道者俱无。但以意作器耳。舍利弗言。意者独有主耶。如来言。意者与诸法合。诸法与意合。道者无主。但以无起作主耳。是故为法器。如来语舍利弗。若见化未。舍利弗言见之。如来言。化道径在何所去。来到何许。从何所来。有道路无。舍利弗言。化无有道径。何知为化。舍利弗言。但见化成时了不见本末。故呼之为化耳。如来化无所有。舍利弗言。见者不见到见耶。舍利弗白如来言。无所见。何等为见者。如来答言。诸想如化是为见。未起法如化是为见。未来法无有名是为见。无造法是为见。未作法是为见。无有造化者是故见。但作无名之想是为见。但作无造之化是为见。舍利弗言。云何于是见中为有往来无。如来答言。故无往来者已故为是见。设使有往来者。是不为是见。是为到见耳。如来见事

宝如来三昧经卷上佛说宝如来三昧经卷下

        东晋天竺三藏只多蜜译

舍利弗问如来言。乃有断法轮者无。如来答舍利弗言。菩萨若已见无形之门。是为已断轮门已空可缺。其脱无脱者可致于空。譬若空无所不入。何以故睹无有处用。是故无所不入用脱于本故。其轮不转故。昙摩竭菩萨白如来菩萨言。诸新学者摩诃萨。我欲令得是法定。如来答昙摩竭菩萨言。欲得是三昧者。当行九法。何等九法。一者当定十方天下人悉令作菩萨。二者见诸恶意令心了不起。是为定。三者视五道勤苦悉欲得脱之。是为定。四者痴涂于其中不起吾我。是为定意。五者视诸冥悉令明。是为定意。六者所作功德悉令不失。是为定。七者视十方天下人皆令为等。是为定意。八者观当来过去诸可意王。勿令复使有作之识。是为定。九法者悉使千亿佛刹土人悉不动转者。是为定意。菩萨从是疾得三昧。弥勒菩萨问如来言。今日敢来在会者。何所菩萨不发阿耨多罗三耶三菩心。佛语弥勒。往昔沙楼陀佛时。我初发意学悉为众垢所盖。不得大慧。但闻菩萨谓发意。当至其处起想识空。不得善知识。不逮沤和拘舍罗。远离善知识。为欲王所欺。可意王断。如是令我失波罗蜜失意。没六十二劫后。与法自然佛会。断我诸可便得还本。即得乐于空中住。断诸可根即见慧门。便得无动之形。从是转行便断法轮。是时从正觉。受是三昧。虽六十二劫发意。于法无益。后与自然法佛会。便得大树更初发意。我发意时。有九十亿人善男子善女人。亦初发意。如是为阿耨多罗三耶三菩心。弥勒自谓。如来发意有几事。如来言。有九法。何等为九。一者远离众会寂然。二者得善知识从受法不失。三者远恶知识。四者当远离五事。一者恶沙门。二者婆罗门。三者黄门。四者恶牛恶马恶蛇多毒。不当与从事。未得道顷令人入泥犁中。当远离之。五者初发意求罗汉辟支佛心者当远之。五者当觉众魔事。不当与共事也。六者但当于梦见说深法。七者但为法发意不在饭。八者不当数聚会有所悕望人饭食。九者当等心于十方。当等心于三昧。于佛坐不恐怖。是为菩萨九法发意。佛现宝如来三昧时。有六万诸爱欲天子。皆得是三昧。是时空中飞天悉共善之。快哉。爱欲天子得闻是三昧。弥勒白佛言。是诸天子得是三昧。巍巍尊自是其主。发意持佛威神耶。佛言。是诸天子前后供养舍利。大须弥山无益于泥洹。今得是三昧前功德悉灭坏。所以者何。三昧无名处。三昧无想处。三昧无念处。三昧无形处。三昧无识处。三昧无威神处。三昧无有结行求脱处。三昧清净处。三昧是不到彼彼至是处。三昧无有是相非想处。三昧无有造作处。三昧于化无形处。三昧无生死不断无处但有名耳。三昧但有响耳。三昧但有音耳。三昧但有开慧之处慧无所生处。三昧无作器处。是故三昧不可坏灭。如是处三昧无出入治处。三昧亦无作识处。三昧无有起行处。三昧不受众味受处。三昧无形处。三昧无出入欲处。三昧不定诸法处。三昧无生处。三昧无应处。三昧寂然处。三昧无动处。三昧无边幅处。是三昧不可坏败。若有坏败三昧。是大痴根生之门也。故不坏败。如来语舍利弗言。有五不直不当与从事。何等为五。一者不当处法有二。二者不当于所起。三者不当视诸法是作非作无有名之者。四者不当于当来过去有所见。五者诸法不可断。是为五法。菩萨摩诃萨得无去来之作者。疾可发阿耨多罗三耶三菩心。须菩提白佛言。若有于苦于乐者。不言离苦乐。是即为二法。不字为菩萨。菩萨者不中离。不止离不脱离。中无所离于所作。远无作之为作。所起如幻耳。以幻说幻之中无名。如是亦不从法得度者亦不离法。得度脱者于脱中复脱。是为无有主者。但有住名耳。于字无知名者。是为法轮断。舍利弗法轮自本清无所有。谁有断法轮者。如来语舍利弗言。不知轮有处者。是即为断。佛语如来言。贪可法者是生死根。灭法者亦为无结之作也。无作之作是为不离作。离贪诸可即为无有断有。无贪不起是即道。无可无不可。是即道。无生不生。是即道。无识不识。是即道。无死不死。是即道。无断不断是即道。无远不远。是即道。诸可不可。是即道。所住无想离于无想。是即道。所念无念。是即道。所说无所说。是即道。泥洹无灭离于无灭。是即道。泥洹无形离于无形。是即道。泥曰灭尽无所尽。是即道。法自寂然离于寂然。诸法无可不有所失。是即道。于慧离本。是即道。非名非想。是即道。所明无所明。是即道。于明冥无想知者。是即道。痴慧无想入者。是即道。于道无有得道者。即是道。若苦若乐无想识者。是即道。所起无所想想。是即道。于清无难易。是即道。所度无有主。是即道所至无想者。是即道。诸法非名离于非名。是即道。菩萨所度如流水。是即道。于名无转者。是即道。佛已三昧成度如人意。以万物自庄严。但庄严无形耳。但庄严到见耳。但庄严诸可意王。但庄严是想非想耳。如来问事竟。文殊师利菩萨白佛言。三十六天人悉会者。乃有几人持受是三昧。佛语文殊师利菩萨言。诸会者非但天人敢来会者悉得是三昧悉当作佛。悉当受十方。悉当断五道勤苦如今日会。时诸菩萨闻佛授与莂。八十亿诸天及人。悉得无所从生法。住虚空中去地三百丈。观身上万千亿香华。下为正觉作礼。阿楼菩萨。阿提菩萨。从坐起白佛。是诸受莂菩萨。即住虚空中去地三百丈。观身上华好妙。是华从何所来。佛言菩萨。譬青本青本自白。以杂色着之。随青黄赤黑悉见其色。如是所以诸色悉现者。但用帛本净故。但用青黄赤黑。本亦复净故现于色。亦不入帛。帛亦不入色。但用本俱净故现之色耳。诸得莂菩萨观身上杂种华者亦如是。菩萨亦不在华。华亦不在菩萨许。但诸天及人。得断无念法慧作明净故。便有华现耳。用华净故便现耳。如是无住者而成诸功德。有住想行者开生死之门。阿罗汉辟支佛所已由远五道者。但有十见。何等十见。一者见诸功德悉言脱者。是为倒见。二者见五道勤苦欲取泥洹。是为倒见。三者见厌万物无主欲疾离之。是为倒见。四者求安本自无本。是为倒见。五者欲出无间入无处世自无出求之不止。是为倒见。六者罗汉取泥洹时。身中火自出火无处起想。出身中火自烧煮。故知生死不断。是为倒见。七者未自无尽。是故为倒见。八者但欲时欲于泥洹尽之成。恶亦无主反欲灭之。是故倒见。九者所施与不发十方人意。但欲法不断。是故倒见。十者于苦于乐不等净行言有二法。是故倒见。十事倒见。佛语阿惟阿楼菩萨摩提菩萨。今诸天及人。皆是阿诃耨佛时人也。今我悉莂之者。亦于六万佛所受是三昧。今故复于我记莂之耳。却后若干亿万岁。我法断绝。是今日会发意。当有四十万人。持住于法转不退轮。令法不断绝。当护持法至使各得佛故。法不断如今日会时。是诸发意者若干千岁。我弟子当共坏我法。若恶沙门。若男子女人。须菩提白正觉言。何所菩萨以何等行护法令不断绝。佛语贤者须菩提。诸四十万菩萨。悉住第八已下。于法无烦荷之想。是即为已护持法令十方不断。须菩提白佛言。何等为坏法者。愿天中天解之。佛言。须菩提。若有诸罗汉辟支佛。若有沙门诸天及人起烦荷想。于慧求名坏灭本末增减尊法。[王*支][王*夜]经言。但好饭食为是道。遂不知空何所是空。但欲庄严刹土。非尊法者。闻佛可得求佛。亦不知法言有二法。是为坏败我法。天上尊天。阿须夷天。潘那天。子楼尼天。拘属提天。施天。那利天诸天。白天中天言。乞持形寿归是持法法者。千万劫亿万劫无有休息时。但令我等得是三昧。佛言。奉行是三昧如其未者便是。佛语如来言。后有发意行是三昧者。得是三昧者。譬如精泥洹。天上有宝诸宝中王。天上天下宝中最尊。有佛在世时乃现耳。名精泥洹珠。有得是一宝珠。持是珠着竹上。若着手中见之。四面空中在欲得几日雨珍宝。向莫不得如其愿者。有得精泥洹珠者。不当贪有亦持雨三界各令得宝如是。行是三昧亦如是。罗阅国王从诸群臣到佛所。为佛作礼。白佛言。是天上之大尊。傥加大恩已度脱十方。傥持天上精泥洹珠宝。傥已雨于罗阅。令我国中人民悉得是宝。佛便笑。阿难正衣服。为佛作礼。白佛言。佛不妄笑。既笑当有意。佛语阿难。罗阅国王从诸群臣。欲乞得泥洹天上珠宝清泥洹珠。欲使雨之于罗阅国。国中亦乐是宝。不知如来时悉已得是宝。佛语罗阅王言。见人民悉百日不食五味。但以法为味。女人悉化为男子。王见之不。王言见之。悉得是三昧。王大欢喜。悉以身上珠宝。以散佛上及诸菩萨上。珠宝悉化成香华。虚空中住皆成行。其间悉有百千种音乐相娱乐。王见衣服如是。王便欢喜。王若干百日复不食。王白佛言。是诸华乃从无处出生。佛答。从无处出。复问。无处从何出生。佛言。从无所起来。王复问。无所起从何所来。佛言。从无所生来。王复问。无所生从何所来。从不动来。王复问。不动从何所来。从无造来。王复问。无造从何所来。佛言。从无名来。无名从何所来。从无生来。无生从何所来。从无音来。王复问。无音从何所来。从无二来。王复问。无二从何所来。从无形来。王复问。无形从何所来。佛言。从自然来。王复问。自然从何所来。从化来。王复问。化从何来。佛言。离于不化来。王复问。离于不化从何来。佛言。离于不化从无相知处来。王复问。无相知处从何来。佛言。已故为诸法。王问佛事大欢喜。昼夜百日但乐是三昧。王为佛作礼而还坐。白佛言。如来菩萨及远方诸菩萨尊贤者皆从远来。今恐与佛相见但去。我今愿乞请文殊如来菩萨等到舍饭食。愿如来许之。佛默然无应者即可意。王为佛作礼还宫。即敕臣下。疾使国中庄严。侠道华香皆结好名华。侠道悉华为帐。王宫中扫除。世间极好华香悉作百种坐。皆琉璃金银。皆使宫中扫除。诸夫人婇女悉斋戒。文殊师利如来等。悉诣罗阅国入城。未到宫门。王出迎诸菩萨。是时菩萨如来文殊师利等六十亿万人。如来让使在前入宫。诸尊菩萨不于前入宫。如来言。诸尊菩萨何以故不于前入宫。诸尊菩萨致尊当于前入。如来言。我不于前入宫。诸尊菩萨当入。诸菩萨言。何所为尊者。于慧无处是即尊。于意无形是故尊。于念不想是故尊。于法无所施是故尊。所作不离于道是故尊。已断法轮是故尊。无念法不想是故尊。于法无有多少是故尊。欲沤和拘舍罗甚多是故尊。于萨芸若无相知者是故尊。已被法铠是故尊。于三昧无有多少是故尊。如是者如来故当于前入宫也。如来语菩萨。故尊何等为尊。年故尊故。诸菩萨言。今我年虽长尊者。譬如万岁之枯死树。根本以永尽。无复有华实可荫覆盖世者。今如来虽年少者。入慧甚深。譬如宝树间人得之华实。莫不得度者。已故当于前入宫。如来于前入。诸尊天持万种音乐随如乐之。文殊师利及如来等各坐。王使夫人利修诸菩萨所食金器悉有八种味。出宫中烧万种杂香饭食竟。王白文殊师利及如来言。我今欲得见十方佛大会时。当以何致之。如来言。欲得见十方佛会者。悉欲见众慧者。但行九法。何等为九。一者当视十方佛与是无异。二者当视我所道无有道径。三者当观一切人无有脱者。四者当视饭食如化所见。五者当知五阴无有识想。六者当知六情观之如幻耳。七者当知观但是倒见。八者当于法中大施与。九者当知所施非施。王闻如来解之欢喜却坐。佛尔时便在彼笑言。快哉快哉。如来为说偈言

  常当显是功　　所生常遇尊
  从受大智慧　　常除爱欲根
  不贪亦不嫉　　恶意不复生
  乃从无数佛　　得闻是三昧
  乃于三千刹　　常行尊三昧
  不于一切人　　所有诸珍宝
  法不从五阴　　亦不离是处
  从观得脱名　　一切皆如是
  从观得欢喜　　发意无所生
  其处已如是　　故为天中天
  若在三界中　　不生亦不死
  泥洹及泥曰　　一切无有是
  意不当邪念　　所行作非法
  若在三界中　　持心令不起
  音响有还答　　内外悉相应
  不起悉寂然　　诸法亦如是
  三千诸佛刹　　名字悉如是
  无闻亦无见　　非法所当议
  三昧不挍计　　已数持作多
  慧者解是言　　得佛无常海
  法者悉清净　　广大无有双
  常作无边水　　所载蔽三千
  意愿陀邻尼　　发慧无有前
  法者已如是　　一切当奉行
  我念求意时　　从来若干劫
  志意常弃家　　于欲无所求
  常依善知识　　得立正法住
  是时于大会　　得闻尊三昧
  志意大欢喜　　即住虚空中
  去地百卌丈　　叉手在佛边
  今坐诸菩萨　　受别亦如是
  其意增欢喜　　得闻诸三昧
  便从一佛刹　　飞到诸佛前
  不动亦不摇　　惊动诸刹中
  花香自然来　　乱风自然生
  百种诸音乐　　悉住于座中
  龙王大欢喜　　即雨万种香
  化为诸小池　　上到三千中

如来谓文殊师利菩萨言。今自然华香从三千刹土来到是会。音乐悉具足。是为佛威神如来之神足。文殊师利菩萨语如来言。卿欲知佛之威神及诸菩萨威神者不可见知。是乐者所处无名之乐。有所在处法者无名处。若苦若乐。是乐处。所有如化耳。是其乐。法无二法。是其乐。于罗汉辟支佛悉欲度之。是其乐。所见五道悉欲令得佛。是其乐。诸所度无有生。是其乐。一切无处。无所起。是其乐。于三昧无烦荷。是其乐。一切处无有名。是其乐。诸所有皆如化。是其乐。非音处无所生处。是其乐。法所施无所施无所有。是其乐。三千中无常处。是其乐。一切人令得信无所得。是其乐。当来过去现在三处尽无有尽。是其乐。令还本无所见。是其乐。见法轮是为无所见。是其乐。三千刹一切等。是其乐。十方三千树法之藏。是其乐。十方诸刹但有名。是其乐。色欲合。是其乐。于名字无有主。是其乐。无边幅一切寂。是其乐。一切明与冥合。是其乐。诸所行不失戒。是其乐。诸所念不离三昧。是其乐。虚空实度无极。是其乐。诸慧觉无有处。是其乐。诸所可。是其乐。一切决无受者。是其乐。三界中无与等。是其乐。贪于法不惜命。是其乐。一切明合复明。是其乐。诸所有但倒见。是其乐。若布施无所望。是其乐。意无极作大船师。是其乐。无边园脱无极。是其乐。意寂。是其乐。无所定。是其乐。诸三昧门无到者。是其乐。亦无听亦无闻。是其乐。诸所念非正道。是其乐。一切人无极者。是其乐。诸所度譬如幻。是其乐。初发意三昧具。是其乐。诸菩萨所从来无有处。是其乐。诸菩萨在意生到十方。是其乐。非青黄及白黑无道径。是其乐。文殊师利菩萨谓如来。欲知佛及诸菩萨威神及所乐。其诸所乐如是。文殊师利答如来菩萨所问乐五事。如来便说偈言

  文殊师利意　　慧尊无有前
  所施蔽三千　　其智莫不尊
  威神所施行　　悉除三千中
  诸乐无所欲　　但为不夺施
  乐法为最大　　于化无度者
  所施乐法与　　若空无恶者
  法与乐俱行　　无有过是宝
  所乐不有主　　若空无处所
  深入诸微妙　　晓了一切人
  使之得大法　　断灭勤苦根
  一切世间人　　悉有意不解
  以法为觉意　　以慧救一切

佛是时说偈言

  离空非想　　是想非空　　于法不起
  即为是起　　常当软意　　净无所有
  色欲同合　　无相入者　　所说无形
  不离形有　　因法如梦　　所欲无底
  是寂离寂　　无离不造　　众法无主
  所可如化　　都无所受　　法无所舍
  所作倒见　　一切皆然　　非色离色
  是色所离　　其法如色　　其处如是
  非音是响　　无闻不见　　不听不观
  所有如是　　于礼无名　　自言为是
  法无是计　　所度如是　　于幻无见
  所见离见　　离贪着欲　　非法所议
  于欲无垢　　不着无离　　如是谛见
  无有见者

如来菩萨知佛笑。便于宫中说偈言

  疑本不解　　谓法自然　　本无常住
  疑慧无是　　于想无劳　　识念无苦
  举名住字　　非求法者　　于本不尔
  不还不退　　所可无可　　远离无可
  于生无灭　　是即为灭　　于义无想
  是为非灭　　于法无生　　亦非相灭
  所以者何　　众法皆空　　亦不求言
  我离泥洹　　所以者何　　本末净故
  不尽十方　　举之为证　　有言是我
  是即是证　　不当远念　　念于十方
  真法不烦　　是受无名　　法非思念
  可当还者　　起行如是　　不见尊法
  要当解慧　　于眇不恐　　漫行不至
  可谓慧门

如来问文殊师利菩萨言。今日来会新发意者。我欲使得无极法。何以致之。文殊师利语如来言。于念无作即可得无极法。如来复问。何等为念无作者。文殊师利答如来。当建九法宝。何等为九法宝。一者意无处所。是即宝。二者观法无主。是即宝。三者不见有当来过去。是即宝。四者于法无有造作者。是即宝。五者所施但施法音。是即宝。六者见五道勤苦于中意不转。是即宝。七者所觉不远沤和拘舍罗。是即宝。八者直见诸法不处有二法。是即宝。九者到于泥洹亦如化是即宝。如来语舍利弗言。是为九法宝。文殊师利菩萨说偈言

  于可无所笑　　所作无常名
  若空无有垢　　佛笑无不可
  笑空不离末　　如本无所笑
  已住诸法名　　一切皆如笑
  本末皆自然　　无有往来者
  笑者有还报　　不还亦不笑
  法者皆是一　　已笑便有二
  于二无名字　　是故为是尊
  所笑无所可　　但为众法施
  所动无所动　　是故无上尊

文殊师利报如来偈

  笑者无还报　　一切无有主
  其笑不离本　　是故天中天
  笑者无所趣　　但为倒见耳
  于法悉寂然　　寂然本无是
  笑者不离化　　以化大施与
  于化无举名　　是故乃为法
  于法无有是　　但为不脱施
  已脱不为脱　　佛者皆如是
  故于大会中　　议度无度者
  于法作施与　　无有与比者
  是寂离寂　　无离不造
  众法无主　　所向如化

舍利弗复问如来言。欲使十方发意陀邻尼行者。当行何等法。当行三十二法宝。何等为三十二法宝。文殊师利言。一法宝者。欲使十方未发意皆度之如化。二法宝者。未发阿耨多罗三耶三菩提者皆令住正法。三法宝者。欲使三千大千日月视之一切等。四法宝者。若在住意者皆令远离众欲。在慧门无动无摇至于泥洹。五法宝者。人说有天无天志不动还。六法宝者。意不动还。七法宝者。一切无来受生者视当来过去无有二。八法宝者。观诸三昧禅寂然无处所。九法宝者。诸所度无有主一切从空引空。十法宝者。三千日月诸佛者我从得决。十一法宝者。十方诸佛三千日月。敢有来听经者悉得佛莂。即住虚空中亦如是。十二法宝者。诸佛刹土华香自然来。缯盖来者亦不喜。不来者亦不求。十三法宝者。皆使敢有发意使得法住如其处。十四法宝者。当来过去无增减。所以者何。知本无二故。十五法宝者。悉欲使十方蜎飞蠕动持佛经戒令不毁伤。十六法宝者。无有邪念。在于十方转意还本则向慧门。十七法宝者。常行忍辱。十八法宝者。从观至观无有度者。十九法宝者。本住无常住处。如是无常住处。二十法宝者。所度无有主名空。为众欲施于欲无常处是故为道。二十一法宝者。施慧作施与无有举名者。于欲无所可但为脱耳。二十二法宝者。所说不离对因作施与故。曰大法故获度无脱者。二十三法宝者。常于无数佛刹飞到一佛前。二十四法宝者。十方诸刹等无得脱者。二十五法宝者。净痴同合本净无异。二十六法宝者。住于三千住作桥梁故。是进学如冥见光明。二十七法宝者。常于无边水广作大船师所度无有极。二十八法宝者。常作无边盖闭塞三千垢。二十九法宝者。常作无极慧不离十方。三十法宝者。常作大慈动于十方。未度悉度之。未脱悉脱之。故无字为天中天。三十一法宝者。等行无有双于无有及与人。字为无上尊发意平等是故为佛。三十二法宝者。如来为是尊所说不离法。遍闻三千刹中虚空为自然王。故立华香中。菩萨三十二法宝如是

  十方都大化　　一切名无常
  真法不烦荷　　即说度十方
  有想不离想　　一切诸宝空
  若华及于叶　　其色不可当
  一切众欲所　　立之可意王
  诸宝无上尊　　号为天中天
  故于大会中　　议度无脱者
  其本无常住　　故字十方尊
  一切为倒见　　世间乐之具
  所可若如化　　能脱十方中
  虚空无常处　　佛藏悉在中
  已脱无脱者　　故教十方中
  十方诸佛刹　　合之为一国
  自然众大会　　悉满十方中
  佛者一切觉　　笑不离其容
  不离黄金色　　已示未脱人
  十方为作道　　意不离法王
  所施无所施　　华布施十方
  金色大莲华　　周遍满刹中
  起想起作行　　不住诸天中
  文殊师利意　　旷大无有双
  譬如初得莂　　住在虚空中
  如来慧意尊　　光明遍宫中
  可意诸天人　　悉得到法门
  十方诸菩萨　　惊动诸刹中
  今会诸天人　　得闻是尊经
  彻见诸一切　　乃到可意宫
  化为交露坐　　万种天华香
  听受诸三昧　　坐观大众中
  诸来宿功德　　发意供养尊
  道者不具见　　所有皆如是
  诸脱无有数　　三界不可极

文殊师利菩萨。问如来菩萨言。众音如化所作于法无想。亦不可尽极。故有自然当以何脱之。如来菩萨语文殊师利菩萨言。复有九法宝。何等为九法宝。一法宝者。自然无处亦如化。二法宝者。诸法无处亦如化。三法宝者。当来无处亦如化。四法宝者。诸所有皆世直处亦如化作。五法宝者。观过去处亦如化。六法宝者。观见诸法如幻耳。亦无有处亦如化。七法宝者。所可无处亦如化。八法宝者。得道无脱处亦如化。九法宝者。得于泥洹本无住处亦如化。文殊师利复问。如来。过于泥洹皆自然。谁为是化本者。谁是化主者。化为有本无化为所起。处无非道无处。如来菩萨谓文殊师利。复有九法。一者化无处化者非道无处。是即化。二者非处无想。是即化。三法宝者。非处化为作处。是即化。四法宝者。非常名所有无尽时。是即化。五法宝者。化处无处。是即化。六法宝者。于道无想。是即化。七法宝者。于起无起。是即化。八法宝者。于诸欲无诸欲处。是即化。九法宝者。于所度无所度。是即化。文殊师利菩萨。说偈答如来

  十方无化者　　化化无有形
  一切无常宝　　是故为化生
  道者不化得　　亦不离其处
  所说无常形　　自然在其处
  诸法从化得　　本离从无有
  其本因化生　　是故人中尊
  欲者从化起　　法本无有是
  化而住五道　　无有见化主
  死生及五道　　与化不相连
  以世贪不断　　故现正觉者
  如来及化主　　十方尊无极
  持化大施世　　世间无知者
  法轮无色转　　于世无转者
  系色有思想　　深法无转者
  想色化十方　　莫不受法者
  所施大智慧　　世间无听者
  诸欲及罗汉　　不还与是宝
  故于众会中　　度脱无上宝
  智慧不可极　　光明最无有
  十方作桥梁　　所说无有二
  十方诸佛刹　　悉令为平等
  亦不使其人　　发意有异心
  十方诸法园　　一切住脱垢
  亦不从世间　　于法无夺者
  于慧无有脱　　不见往来者
  于寂复见寂　　明中复见明
  法者非慧得　　自然无本是
  慧冥俱同合　　都无相识者
  痴慧不同合　　其慧众冥明
  所施但为法　　若华在高山
  诸恶不可极　　色欲不可尽
  泥洹及生死　　一切皆如是
  十方诸佛慧　　无知无觉者
  所以见净法　　故言世无有

昙摩竭菩萨复问如来菩萨言。于化无起离于谁成主者。泥洹不生灭不远五道。当使来发意转住法轮无诸垢。令悉不生。谁为度者。如来言。昙摩竭所问。欲决断十方生死根。乃如是当行九法宝。何等为九法宝。一者于无主。是即宝。二法宝者。于泥洹与生死初无相知者。是即宝。三法宝者。于死生于灭无灭。是即宝。四法宝者。上到三十六天使不还生死生处。是即宝。五法宝者。当起意未起意如处住。是即宝。六法宝者。三千大千佛刹观了无得度者。是即宝。七法宝者。于念无起处。是即宝。八法宝者。悉使三千佛刹悉取泥洹意亦不喜。不取泥洹者意亦不怒。所以者何。诸法无处故。是即宝。九法宝者。随愿取罗汉。我悉令发意求愿者不令复还是愿。是即为宝。不起诸生无有还愿。是即为菩萨法宝

如来答昙摩竭菩萨。说偈言

  于可无所可　　于欲无所欲
  所度无见者　　法轮无常处
  慧者无所说　　因度无往者
  故见大正法　　世之最无有
  道者无常名　　故为十方宝
  已得无得者　　生死无有道
  四马不可尽　　可意无有足
  世间悉乐者　　不舍不得道
  畏生无有脱　　不畏无脱者
  生死当举名　　立之为五道
  有报无答者　　可谓为是法
  法者本无二　　所有谛已觉
  无边亦无幅　　无极不可计
  本际如影响　　无有往来者
  于起无所起　　法无诸欲者
  生死本无处　　生死化如是
  于净无有净　　于垢无有垢
  悉为十方人　　断绝诸五道
  净意若如水　　一切无瑕垢
  青黄及白黑　　悉得见其形
  诸法不可荷　　即得无上宝
  吾我及与人　　世间无得者
  不住无住谛　　所有谛如是
  所觉无所见　　世间谛如是
  无度无不度　　世时谁不有
  十方立正觉　　悉得无上宝

昙摩竭菩萨问如来言。欲使十方自然诸天人民。皆令得如其处。当行六法宝。何等六法宝。一者闻知是会时。是即宝。二法宝者。诸来会者得闻是经。是即宝。三法宝者。非今功德。是即宝。四法宝者。敢问是经法已得六万三昧。但欲使十方人发无上意。是即宝。五法宝者。皆使十方会于佛树下。是即宝。六法宝者。佛所说经法使十方人悉令得之。是即宝。说是三昧时会中有九十亿万菩萨诸天人民。有六十七亿万人。皆得无所从生法处。当是时九亿万菩萨皆得是三昧。三千大千佛刹土。复即九反大动。三十六天诸天王。在虚空中乱风音乐乐佛。诸大龙王诸阿须伦。皆得见是法。阿难正衣服头面着地。叉手为佛作礼白佛言。是经名为何等经。我当云何奉行之。佛言阿难。是名为诸刹无极园自然华香自然。号为会无极宝。说是经时。无数诸天人民阿须伦人非人。闻经皆大欢喜。各前为佛作礼而去

佛说宝如来三昧经卷下


佛说宝网经

    No. 433

佛说宝网经

        西晋月氏三藏竺法护译

闻如是。一时佛游维耶离猕猴水边交路精舍。与大比丘众俱。比丘六万皆阿罗汉。菩萨三十亿悉一生补处。慈氏菩萨等二生补处三生补处。四生五生十生补处。十八生二十生三十生四十生补处。五十生百生补处。举要言之。上至千生而补佛处。有九十亿诸天之众。欲行天人。色行天子。四天王天。帝释梵天王。须深天子。月光天子。日光天子。胜英天子。作乐天子。此诸天子及余天人九十九亿。无劳龙王。沙竭龙王。和伦龙王。摩奈斯龙王。难头和难只龙王。文邻龙王。大悦龙王。燕居阿须伦王。与诸阿须伦民皆来集会。稽首佛足分部而坐

尔时维耶离大城中。师子将军。有子号无量力。时无量力有童子仁贤。号曰宝网。曾已供养不可称计百千诸佛。为无量世之大庭燎执持法教。厥年八岁。时适寝寐。于梦中见兜率天人从天宫下宣扬其香音。而叹颂曰

  佛身现在导众生　　其光照曜三千界
  颜容殊妙旷无厌　　体色紫金百福会
  若干月光加亿数　　不比精明圣智容
  其殿现光巨垓数　　令斯月宫遍东方
  南方如是西亦然　　造宫北方为若兹
  如是诸殿照巨亿　　其数各如江河沙
  无比世护诸毛孔　　所演光明曜巍巍
  能仁一一诸相好　　所出晖曜照无量
  一一导师所奋威　　以用开化诸众生
  犹复越于江河数　　普能现说三十六

于是童子宝网。于夜梦觉启白其父。夜诸天人下兜术宫。以偈相语而歌颂曰。赞佛功德今欲求索。缘见自归如来至真。童子宝网因时以颂而赞叹曰

  开寤众生善导师　　无念世父志广大
  大人当知供养佛　　导师兴世甚希有
  如灵瑞花难可遇　　其色煌煌软微妙
  香气流布无耗损　　如是尊花难得值
  我身今日　　启于大人　　愿以相施
  欢喜之心　　其从世护　　光明之教
  常当奉敬　　现真谛慧　　其无量力
  怀欢悦心　　寻时即告　　犁车童子
  师子将军　　供养大圣　　童子我往
  惟从命耳　　若种六亿　　修精进业
  供养导师　　于释师子　　殷勤自归
  最上尊势　　皆随天帝　　其眼有千
  又梵天王　　尊位自在　　其导师者
  天魔之子　　与诸天子　　那术亿数
  一切皆乐　　游维耶离　　床榻具足
  满亿千数　　紫磨金色　　像明月珠
  七宝挍成　　亦甚巍巍　　一一分部
  其数亿千　　床悉如是　　布在右面
  跱立幡幢　　常为欢乐　　一一床座
  具足微妙　　其幢超绝　　有亿殊胜
  诸幢幡者　　各在左右　　于阁如是
  众好最胜　　明月珠宝　　卓然周遍
  一一宝珠　　其价亿数　　而以垂挍
  于诸幢幡　　跱竖立之　　上法甚高
  其幡丁尾　　紫金交络　　其幡如是
  不离黄金　　诸树皆悉　　满亿众千
  众座安然　　罗在后面　　其此诸座
  坚固殊胜　　所设安定　　犹如门阃
  其床榻上　　宝盖光晃　　紫磨金色
  周匝垂幡　　白银琉璃　　水精亦然
  车磲之胎　　及与马瑙　　阿文珍藏
  并及真珠　　其赤栴檀　　若干种宝
  一一在前　　具足百千　　交路周匝
  庄饰宝盖　　其于地上　　亦设微帐
  以上妙金　　而合成之　　水精琉璃
  白银如珍　　成就车磲　　及以马瑙
  在于地上　　一一施设　　一一宝瓶
  究竟百千　　烧香满中　　以为供养
  奉上导师　　名称远闻　　于维耶离
  上虚空中　　以紫磨金　　而为宝绳
  一一宝绳　　甚微妙好　　连诸宝幢
  其数亿千　　计彼宝璎　　亿垓无数
  一一紫金　　以为绳连　　若来观者
  甚以为好　　诸国中民　　维耶离城
  从下上去　　四丈九尺　　维耶离城
  皆布衣服　　赤栴檀香　　而用熏之
  各遣其衣　　珠玑璎珞　　紫金杂厕
  有七万亿　　其铃千种　　皆在左右
  罗诸香炉　　有七万亿　　以用供养
  佛释师子　　其大庄严　　所作如此
  童子宝网　　国中所设　　以欣然心
  启于父母　　我往诣佛　　欲请至圣
  寻即时出　　于彼城门　　行到最胜
  大圣人所　　稽首足下　　自归德海
  童子即退　　却住一面

于是童子宝网。出维耶离大城行诣佛所。恭肃敬意稽首足下还坐一面。佛知其意则随时宜。所应当解而为说法。欣然大悦。童子宝网见佛劝助开化说法益以踊跃。即从坐起偏出右肩右膝着地。和颜悦色前白佛言。唯愿世尊。垂愍明日受请及与圣众。佛已受请默然不应许可。童子。于时佛愍哀宝网。宝网见佛默然。便从坐起绕佛三匝作礼而去。童子宝网与天帝释梵迹天王须深天子。入维耶离城。施百味馔奉若干品种种美食。即于夜时办诸座具。庄严校饰维耶离城。悬诸幢幡散花烧香。所设已办往诣佛所。稽首足下却住一面。叉手白佛。大圣见愍。时至食办从尊所宜。时佛明旦着衣持钵。与无央百千圣众。上虚空中去地四丈九尺。神足经行欲得前入维耶离城。适欲入城。如来应时六反震动三千大千诸佛世界显现十八无数亿垓百千众变。到维耶离。时无央数亿百千垓诸天悉来。雨诸天花。青莲诸红黄白众花诸天意花。蜜花香末香杂香持。其明月珠杂紫磨金众珍琦异七宝天华。奉散佛上同音歌颂。鼓无央数亿百千垓伎乐乐佛。空中雷音彻闻十方。雨天栴檀众宝璎珞校饰上下。盲者得目。聋者得听。哑者能言。病者得愈。跛者能行。狂者得正。乱者得定。偻者得申。其被毒者毒皆消歇。箜篌乐器不鼓自鸣。妇女珠环相掁玲玲。飞鸟禽兽相和悲鸣。众人集观莫不喜惊。于时世尊适已入城。诸天于上下诸宝盖执在虚空。佛即往到童子宝网家前坐其舍。与四部众比丘比丘尼清信士女。悉在其中次第而坐。童子宝网见佛弟子所坐已定。手自斟酌百种饮食若干种味殊异肴馔。供养世尊及与圣众四部弟子。等无差特。饭食毕讫行澡水竟。取三法衣其价无数亿百千垓。贡上大圣比丘比丘尼。亦复俱得三品法衣。其价施佛等无差特。各各赐遗清信士女。一具体衣。所以者何。皆是世尊圣恩所化故使其然。童子宝网供养佛竟。别自歇饥安身已讫。更取独座于佛前。却坐一面白佛言。欲有所问若见听者乃敢自陈。佛告宝网。在所欲问诸有疑者。如来至真当解结网令心坦然。童子问佛。唯然大圣。岂有诸佛往世修行所愿合成现在者乎。学菩萨道诸族姓子族姓女。学菩萨乘。得闻其名心中开解而不怀疑。成不退转当得无上正真道也。姿体端正颜色无比。财富无穷戒不缺漏。智慧具足心识宿命。不怀贪嫉无所妄想。所在之处常以和安。与诸菩萨以为眷属。离于一切诸声闻众。便得启受所说功德。不可称计亿百千垓。诸佛正觉之所钦爱。饱满众生久远饥虚。惊动诸魔咸来自归。修治严净诸佛国土。雪除众生心性翳垢。而为颁宣清白之法。诸天神明悉共拥护。菩萨大士咸俱念之。如来至真之所建立未曾违远诸佛世尊。而皆备悉诸菩萨行。而皆具足八万四千诸种事业。众究竟音其声如梵普彻佛界。莫不闻焉咸受其命

于时佛告童子宝网。善哉善哉。所问辩才甚为微妙。多所忧念多所安隐。愍伤诸天及十方人能质如来如斯义乎。童子谛听善思念之。当为汝说分别其义。童子宝网与诸大众受教而听。佛言童子。当知东方去此有佛世界名曰解君。犹族姓子。江河沙等其中沙数若干佛土。从下水基转至上界三十三天。有诸埃尘周遍其中。时有一士夫自然出彼。一一皆数诸世界尘。过越若干亿百千垓诸佛刹土乃着一尘。佛言童子。是比类次如前数诸佛刹土复着一尘。长远久迥无限无量不可称计。虚空不容此诸尘数。稍稍举移悉令使尽。于童子意所志云何。宁能有人思惟计数称量下算。于彼士夫所移尘数所著处乎远近多少。答曰无能知者。天中之天。假使有人欲分别识。说此譬喻晓了其义。尚不能达。识其譬喻安知数乎。佛语童子。彼时士夫所移诸尘。一一着处是诸佛界。下至水际上至上界三十三天。满其中尘国土若干。于时复有第二人。出取彼一尘。过如前人所计尘数。而越若干不可称载亿百千垓诸佛刹土乃着一尘。佛言族姓子。以是比类。所过东方长远无际。复取一尘过如前数复着一尘。以是比像。其人所越天所不覆地不能载。不可计量亿百千垓诸佛刹土。尔乃得至解君世界。彼有佛名宝光月殿。号妙尊音王如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。于今现在。族姓子及族姓女学菩萨乘。闻彼佛名不怀犹豫。信佛道眼斯可闻名。所生之处作转轮王。若佛兴世常与相见。睹无央数诸佛至真咸供养之。净修梵行获致神通。进退独步总持自在。得观如来睹江河沙等平等正觉。弃舍生死超若干亿。劫亦如江河沙。心常安静未曾忽忘。恒志无上正真之道。无有尘埃不近众尘。由得自在身如钩锁。住在一处具足四事。体如紫金以三十二大人相庄严其身。逮八部音声喻梵天。弃捐八难常得闲静。于时世尊观此义已。则说颂曰

  其闻世吼名　　心不怀狐疑
  笃信佛法明　　则为真众祐
  常为转轮王　　辄值见诸佛
  适遇寻供养　　无量不可议
  恒遵修梵行　　神通而独步
  执转诸总持　　致睹诸佛路
  常得觐诸佛　　犹如江河沙
  超越诸生死　　亿劫亦若干
  以志佛道故　　心未曾忽忘
  其宣世吼名　　为众请宣传
  成转轮圣王　　立一处自由
  致体紫金色　　其相三十二
  若有闻佛号　　声音喻梵天
  弃捐八难处　　五体归礼敬
  不障塞佛道　　未曾怀嗔恨
  其闻佛名者　　不怀犹豫故
  若奉最胜号　　夙夜具七日
  彼眼致清净　　逮见无量佛
  未舍于肉眼　　而普见清净
  睹无数诸佛　　犹如江河沙

佛告童子。若有菩萨闻彼佛名。及与凡夫殷勤精思。而遥自归咸能供养。悉闻十方诸佛所说。目皆睹见佥信乐之。前世宿命曾所供养无央数佛。适能得闻诸如来名。辄皆识念本所游历。为说往世本末名号志所誓愿见他众生根原所从来。究竟佛道心怀悦豫。亘如日出永无尘翳所睹极旷。弃除八难斗诤之事。其心和雅常怀闲静。若有笃信于佛道者。和合离别未曾述惕。正使往世犯诸罪衅。应在恶趣烧炙劫数。小遇头痛众殃消除。火不能灾风不能中。国主王者不能加害。闻如来名未曾生盲。目不痛瞎不聋不哑。闻佛名故不偻不跛。诸龙鬼神及阿须伦饿鬼[袖-由+厭]鬼人与非人不能犯触。诸魅暴鬼神龙地祇莫不爱乐。假使执持诸佛名者。功德如是不可称计。佛于是而作颂曰

  目皆见诸佛　　咸能供养之
  闻所说趣受　　其人佥信乐
  宿命所更历　　供养无数佛
  适闻彼佛名　　一切悉识念
  其本之名号　　为众人说之
  复睹他众生　　能究竟佛道
  兴发欢喜心　　弃捐诸八难
  刈去诸诤讼　　所生常闲静
  假使信名者　　世护正真主
  其心不怀结　　雪弃愦闹事
  设犯无择罪　　受殃若干劫
  一时遇头痛　　诸衅永毕除
  不为火所灾　　在风不见中
  彼闻如来名　　王不能加害
  未曾为生盲　　不聋亦不哑
  其奉最胜号　　手脚不缺减
  鬼神揵沓和　　饿鬼厌恶神
  若闻如来称　　人毒咒不行
  诸魅若罗刹　　诸天若干龙
  奉此最胜名　　皆共爱敬之

佛复告童子。假使有闻彼佛名者。疾逮三昧决诸狐疑不着音响。志无所生劳勋亿千。所以然者闻佛名故。若值佛名坦然无疑则能奉持越无数劫。其于末世信乐此法功德如是。若闻导师灭度后名。善宣法训执持讲说。若能诵怀于人中尊所演经典。修净致尊备诸佛行。临寿终时其心不乱。寻能睹见亿垓诸佛。闻所说法皆能受持。已自修立开化众生。闻不求短而悉化之令住佛道。其人设奉诸佛名者。为应供养诸佛大圣。并信吾身从佛之教常自归命。永得解脱不趣地狱其信佛慧则归吾身。其诽谤者是魔官属。斯在五趣所游众生世尊悉济。令立一乘以一毛孔。如来至真则能演出江河沙光明度脱众生。佛于是作颂

  不疑音声句　　疾逮得三昧
  兴畅亿功勋　　闻佛名所致
  于后末世时　　奉持此经道
  闻诸世吼名　　其心不犹豫
  灭度诸正觉　　若颁宣法教
  闻众导师名　　奉持能分别
  则为具奉行　　诸佛所演法
  能致尊严净　　众圣所应宜
  临欲寿终时　　寻见亿垓佛
  趣能皆启受　　诸佛所说法
  已能逮立行　　并化亿众生
  所闻不虚耗　　普建诸佛道
  则为悉奉持　　一切诸佛教
  信吾真圣目　　亦供养诸佛
  归命诸最胜　　永度诸恶趣
  其信佛慧者　　此人从吾教
  若好佛道法　　为随大圣教
  设诽谤正法　　皆是魔官属
  如五趣众生　　所有体毛孔
  济危如是数　　入之一乘道

佛告童子。如来至真以一毛孔用演江河沙等光明威神。若有信此于一世中睹见亿数诸佛世尊。若复闻此法王所说不怀结网。亦当成佛如我今也。若复随顺讲斯经典。于最后世希有信者。如江河沙数士夫世界。如此悉遍照佛土如是无思议。设能计是一切诸数。满中珍宝施于如来。加闻佛名心怀欣豫。当逮此慧不可思议。数数思念诸导师尊。其功德福不可称计。又佛光明照于十方。其身巍巍如宝合成。加闻佛名不怀狐疑。寻时逮得无所从生。口气馥芬名香远闻。宣持佛名其功德如是不可称量。佛于是而作颂曰

  从一毛孔中　　世吼圣威神
  演出其光明　　犹如江河沙
  假使有信此　　诸佛无量光
  一世所觉了　　逮见亿载佛
  若闻斯经者　　法王所叹咏
  省之不怀疑　　当逮如我今
  其有如应时　　闻说斯经者
  然后末世时　　为人分别说
  犹如江河沙　　赞士夫所由
  以一光明曜　　照若干佛土
  一切皆共计　　佛土无思议
  满中紫磨金　　亲自奉世护
  若闻诸佛名　　心中怀坦然
  不如叹佛名　　是福最无限
  常能数数念　　至真等正觉
  无能叹究畅　　计数其功德
  其身所演光　　如宝甚煌煌
  设闻诸佛名　　不造立沉吟
  逮成于法忍　　口气香馥芬
  如天栴檀香　　悉由宣佛名

佛告童子宝网。假使人闻佛身毛孔所演光明。其晖远照开导众生心中悦豫。在所生处得侍诸佛不离在侧。亦如阿难今来侍佛。犹如子孙亲里骨肉。奉行佛道以见世明。欢喜无量所致恭恪不可称限。见诸佛已具足奉事获福如是。孰闻佛名而不敬承。惟魔官属迷惑外道能不信耳。童子。适见佛寻自归命是经法者。末世归之。执在身手心思口诵。曾见过佛说是尊经义。能殷勤供养者。斯经卷归彼人自然在手。法王所咏所建立誓愿至诚后世必获。若以一心奉无数佛。不如信此经典之要。福不可量胜供诸佛。容貌端正勇猛无畏。功德殊异财富无数志意坚强。三十二相庄严吉祥莫不宣畅。佛于是而作颂曰

  佛身诸毛孔　　若有人闻者
  佛名及明曜　　能导化众生
  世世所生处　　常为佛侍者
  如阿难侍吾　　闻法辄受持
  为子若亲属　　奉修菩萨道
  当见世光明　　欢喜无有量
  得见最胜味　　爱敬不可称
  具足承事之　　常致妙道慧
  谁闻导师名　　而不敬承者
  惟有魔官属　　外道不笃信
  长者子宝网　　睹佛寻奉养
  然后末世时　　经法归彼掌
  本闻佛讲说　　分别此尊经
  若供养自归　　自然归彼手
  法王之所说　　当受斯妙卷
  建立斯正愿　　后世自然获
  若一心供事　　不可计诸佛
  其有信是经　　功德过于彼
  颜貌常端正　　功勋无所畏
  财富意坚强　　相好自庄严

佛告童子。若族姓子及族姓女。今闻此经于后末世得值此法。持讽诵读为人演说者。见百千佛所转法轮咸悉供养。然后末世不疑道目。前世所奉无数诸佛。闻佛名笃信明目。护于正法顺诸佛教。闻其名号造佛形像。愚痴闇塞人闻世尊名怀毒诽谤。亿百千劫盲冥无目。于无数劫斗乱众生诽谤此经。其罪过彼以故说是。后世值者无得怀疑不信佛慧。香华杂香勤心供养奉上衣服。从闻经者恭恪如是安隐庠序。宝网童子衣食奉上如来至真心不离之。灭度之后诸天神灵。住于虚空而雨天花。供养闻此经好喜爱乐者。一心无犹豫。佛于是而作颂曰

  若于后末世　　得闻此经典
  受持而讽诵　　为他人说者
  供养百千佛　　诸转法轮者
  然其后末世　　不疑佛教故
  往古无数劫　　奉养诸护世
  假使复有人　　闻此诸佛名
  信乐顺正法　　从诸佛教化
  闻斯经法者　　当作佛形像
  愚痴怀闇塞　　诽谤是佛名
  盲冥无眼目　　亿劫获此殃
  若住无数劫　　斗乱别离人
  设诽谤此经　　其罪过于彼
  然后将来世　　以故说斯义
  无得怀犹豫　　疑佛无上慧
  名香种种花　　杂香好衣服
  闻如是经卷　　当勤勤供养
  安和诸饮食　　其童子宝网
  柔软妙供具　　数奉上如来
  尔时诸天人　　謦扬大音声
  诸天雨众花　　遥散闻此经

佛告童子宝网。此经典者多所安隐。犹如困疾值得良医疗治其病风寒热气无不除愈。菩萨如是。闻彼佛名殷勤精进。淫怒痴病皆得消尽。时无央数诸天人众。来集空中雨栴檀香。梵天亿数及与童子。闻此经名并如来号。欢喜踊跃善心生焉。口所宣说咨嗟无上。我等末世当为比丘。志强无畏当以此经在于郡国城郭县邑颁宣斯经当随佛教。假使远在亿百千里。当往启受不以迥邈而为患难。常请诸天人龙神阿须伦健沓和加留罗真陀罗摩睺勒人非人等。为说经义饱满道法。诸天悦豫空中散花其堕如雨。各赞叹言。法王一音普告佛土。为显无为愍伤众生。周遍佛土如江河沙。十方亦然。童子宝网覆诸佛国。若见大雄无有懈惓。世尊顾眄为分别说。莫疑佛法如来无量。佛眼无限普施安隐。佛慧无际达知三世。无所不通诸法中王。轮世五阴无有坚要。四大亦然。勿着音响色痛痒阴想生死阴。晓了是者知无有要也。其有思惟如来所说。疾得总持志不迷荒。诸法本净空无吾我。无所悕望无有畴疋。如来如是。于是而作颂曰

  诸天无央数　　亿千住虚空
  而雨栴檀香　　亿载梵亦散
  闻此宝网经　　赞劝助如来
  心欢喜欣然　　口宣无上义
  我于后末世　　为勇猛比丘
  诣城郭县邑　　当为说此经
  当谛顺佛教　　平等觉吉祥
  故到亿喻旬　　颁宣是言教
  请会诸天人　　诸龙真陀罗
  诸人及非人　　饱满以法施
  诸天人欢喜　　其心和悦安
  于彼雨众花　　同音俱咨嗟
  普遍诸佛土　　法王之境界
  释师子人尊　　一毛光所照
  导人兴愍哀　　世尊一出舌
  蒙覆亿佛土　　亦如江河沙
  十方亦如兹　　各照亿佛土
  大雄即告曰　　于童子宝网
  缘犁车国人　　及六十等侣
  于彼侍世尊　　顾眄而告言
  无得疑佛法　　如来不可量
  无能限佛眼　　施安一切和
  佛慧无央数　　普流于三世
  世尊靡不达　　皆解诸经典
  五阴无坚固　　人中导所说
  四大之所变　　无得着音响
  当解于色阴　　痛痒诸想念
  生死猗众识　　无有真要者
  别五阴如是　　顺如如来命
  速得逮总持　　心未曾忽忘
  诸法皆本净　　虚无无吾我
  无诤无所念　　此从如来教

佛告童子。南方去此如前譬喻。过倍此数一切诸尘。更复越彼七十二亿百千垓不可计会诸佛刹土计倍。复有世界名杂种宝锦。彼有佛名树根花王现在说法。若族姓子及族姓女。闻彼佛名为如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。所演经法初中竟善。若族姓子及族姓女。闻彼佛名不怀疑结信吾道眼。则于现世至德具足逮受五法。何谓为五。一曰尽除吾我所生之处常值佛世。二曰获极尊势转轮圣王。三曰逮总持法执御经典诚信百千。四曰成三十二大人之相。至得佛道众行备悉。五曰逮得五通无所蔽碍。是为五。复有五事逮得神通。何谓为五。一曰彻视见于十方粗细大小。学无学声闻缘觉。上至世尊与众超越。二曰耳能彻听。闻万亿地狱饿鬼烧炙饥渴畜生之恼。天上世间安隐苦乐。或恶或好。十方诸佛所说经典。皆悉闻之。三曰身能飞行遍诸佛国。如日现水。虽现往来而无周旋。四曰能知一切众生心念善恶好丑。有志无志有漏无漏。有心无心慕俗乐道。而悉知之。五曰自知宿命。并见众生无数劫事古世所生。过去当来今现在事。靡所不通悉识念之。佛于是颂曰

  其有赞叹　　人中大圣　　闻不怀疑
  常能晓了　　此则疾获　　逮致五通
  敬是尊经　　佛所说者　　颜容端正
  体如紫金　　当为尊主　　转轮圣王
  身如钩锁　　则为功德　　建立威仪
  而得自在　　其福兴盛　　具足千子
  勇猛英雄　　游步无胜　　面貌殊妙
  相好饰姿　　彼功德勋　　如天帝王
  若为国王　　婇女满千　　身如天金
  心性第一　　本所游居　　及当来处
  见此王者　　观之无厌　　所可造行
  不以为患　　诸有臣下　　一切尊豪
  来就见者　　不以懈惓　　如是成就
  第一大德　　诸天来归　　所愿难胜
  世间人民　　及诸龙王　　咸为众生
  善立国界　　悉能更立　　于佛道处
  其国最安　　丰熟平等　　当为世间
  自然之佛　　佥至其所　　奉敬第一
  从始至终　　道无放逸　　何所知者
  闻佛之名　　岂怀狐疑　　爱敬所知
  于法第一　　布其威曜　　咨是尊经
  佛之所说　　惟本前世　　从佛受法
  疾致寂灭　　遵修正行　　但有诸佛
  开导众生　　所行见敬　　众义备足
  其信乐者　　谓是童子　　清净尊豪
  是王财业　　童子谦卑　　承事于佛
  闻斯名者　　第一无疑

佛告童子。西方去此过于前喻三倍尘数。复越彼刹十二阿僧祇百千亿垓佛土。有世界名胜月明。其佛号造王神通[火*僉]花如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。现在说法。若族姓子及族姓女学菩萨乘。闻彼佛名不怀狐疑。笃信于道自所宣说。所生之处致演光明三昧正定。寻复随逮十阿僧祇亿百千垓诸三昧门入于六十不可计会亿百千垓诸总持门。如海总持宝藏总持。然后不失诸定意法。临寿终时目见十方各十亿垓诸佛正觉。十方诸佛所说法者。皆能启受不失道教。至成佛道越五百劫生死之难。住于斯学如是不久。寻即成无上正真之道为最正觉。佛于是颂曰

  闻人中尊名　　为世护圣明
  弃捐诸生死　　具足五百劫
  临其寿终时　　各见百亿佛
  辄稽首归命　　咨受所闻法
  其所听经者　　亿劫未曾忘
  奉修尊妙行　　悉闻如来名
  所生百千世　　服宝三昧定
  兴发亿功勋　　用闻佛名故
  逮六十亿定　　载数不可计
  因奉导师号　　奉事供养故
  是故诸勇猛　　遵修佛道行
  化无数千人　　建立尊上道
  其晓了佛法　　未曾习尘欲
  喻众生所行　　为造其名号
  其闻此名者　　为一切广说
  未曾堕八难　　易遇诸闲静
  以除诸危厄　　佛今所可说
  其人常自在　　值微妙佛世
  童子设识解　　如如来所明
  闻其名号者　　悉照此众生
  即当以此经　　为他人宣畅
  世正觉若斯　　世护多所救
  其闻斯名者　　调和而启受
  旋为他人说　　彼则护佛法
  其护佛法者　　善宣正道因
  以闻此经典　　为人剖判故

佛复告童子。北方去此如前譬喻复加三分。越彼佛土六十无限亿百千垓诸佛境土。其世界名曰决了宝网。其佛号月殿清净如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。现在说法。若族姓子及族姓女学菩萨乘。闻彼佛名信乐不疑。敬喜道眼之所颁宣。所生之处常当逮致宝幢三昧。观见十方各十江沙诸佛国土。亦越若干百千亿垓生死之难。立在初学疾逮无上正真之道为最正觉。若有女人闻彼佛名。不怀狐疑有信吾言。所生之处转女人身得男子形。劝化无数百千众生。令致无上正真之道。解其音响得不退转疾成正觉。当为一切讲说经典。令致三乘声闻缘觉菩萨大道。佛于是颂曰

  假使得闻两足名　　其心悦豫不沉吟
  则能弃捐非法忧　　正行亿数如江河
  得见诸佛其亦然　　奉事供养不可计
  于一世中无崖底　　所可供养极美具
  其能奉修尊佛道　　其人如是有殊特
  若有咨嗟众圣明　　闻之未曾怀犹豫
  若有女人得闻此　　诸佛名号不踌躇
  则能疾转女人身　　得为男子光普照
  其明遍曜靡不周　　往诣无量诸佛土
  皆见世间众所行　　然后成佛常无忧
  若能得闻诸佛名　　其神足力超如是
  如来圣众如大龙　　何况发意求佛道
  奉敬正觉离垢尘　　若闻其号速宣传
  其明所照喻日光　　致三昧定善宣畅
  若能遵行尊佛道　　其德殊异为若此
  众生无量不可议　　诸圣所劝尊佛道
  犹如月殿妙巍巍　　住在虚空演众曜
  其能奉持如来号　　威德众好亦如是
  何所知者说佛名　　而怀狐疑犹豫者
  若能至诚行此法　　殷勤遵修最尊道
  常能勤行无上义　　其人不致诤讼事
  以无极行奉圣尊　　适闻其名寻归命

佛告童子。下方去此过于前喻九十九倍复越于彼。如九十九不可计会亿百千垓诸佛刹土。有世界名尊幢君。其佛号善寂月音王如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。所说经典上中下善。独步三界救济三世。令志大道无上正真。若族姓子及族姓女学菩萨乘。闻彼佛名心不怀疑。信我道眼之所解说。所生之处得普光三昧。临寿终时。具足逮见亿百千垓佛现住其前。十方各然。十方诸佛为说经典。闻则受持抱在心怀未曾忽忘。至成佛道。不可计会十倍功勋亿百千垓。致不可计无崖底载诸三昧定。不中失定。至成佛道无所蔽碍。十方诸佛皆共建立。在于新学。越九十九亿百千劫生死之难。菩萨疾近无上正真之道。不以劫数生死为碍。如自晃出天下大明。于是世尊观此义已。即说颂曰

  闻游世间尊上号　　为大神仙亿无极
  得见诸佛亿百千　　当自奉事斯殊胜
  以能供养诸如来　　为善导师广开化
  普能照曜于三世　　然后成佛无忧患
  于一世中所承事　　如江河沙无数尊
  寻致三昧光遍照　　然后成佛无忧念
  以致觉意广无厌　　遇诸法王转法轮
  建立众生无三恶　　灭生死火如水浇
  天人之尊为福田　　人中法导德殊胜
  人民见之怀喜悦　　弃捐于斯诸八难
  明智逮值独闲静　　逮得人身常聪圣
  游无量世乃遇佛　　若有颁宣安住名
  造立誓愿若百千　　而得闻此世明导
  以安和成大觉眼　　亦当获致柔顺忍
  如我锭光所得决　　见佛以花散其上
  智者得忍亦如斯　　说超异愿亿佛名
  其演光明临寿终　　闻其名号无不宣
  唯有外道虚伪术　　以坐其人翳道教
  假使有闻说斯经　　亲自所睹如来宣
  斯党后世能受持　　复为他人分别说

佛告童子。上方去是过如前喻倍恒边沙。有世界名善分别。其佛号无数精进愿首如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。现在说法。颁宣道教开化十方。六通六度皆使蒙恩。唯学菩萨不断佛种。若善男子及善女人学菩萨乘。闻彼佛名不怀结网信吾道眼。世世所生未曾懈怠。不习贪欲不恋父母。不着妻子兄弟姊妹。不慕亲属中外种姓。不贪亲友交识所知。世世所在身未曾离。三十二相庄严其体。少淫怒痴身无疾病。不多忧虑安隐无量。至成佛已。常逮得不可称计亿百千垓功勋之德。佛于是颂曰

  未曾见忧戚　　父母及亲属
  其闻诸佛名　　不怀疑结故
  其世光明曜　　今现在上方
  威神照三界　　为众说经法
  若能闻名号　　为他人说者
  以三十二相　　而常庄严身
  智慧无损耗　　修行菩萨道
  奉敬归诸佛　　用宣名所致
  所在常奉敬　　不可议亿佛
  其行佛道者　　未曾有所著
  所获功勋德　　称扬不可尽
  以闻是名故　　能为他人说
  然后将来世　　若得值此号
  无得怀狐疑　　佛慧无上盖
  其见平等觉　　供养无央数
  然后将来世　　是经归身手
  宝网得见佛　　菩萨无所畏
  适闻此经已　　未曾怀犹豫
  无得疑佛道　　如来不可限
  前世已曾行　　修无数亿劫
  施以身手足　　耳鼻及头目
  妻子国邑城　　惠与不怀恨
  然后将来世　　得闻此经者
  能为他人说　　则成最众祐
  其欲解了义　　诸佛之所行
  无得怀沉吟　　世护所教诲
  是故闻此经　　调心习止足
  讽诵学斯典　　数数当经行
  常讲具精进　　满足备三月
  转得总持决　　善执念诸法

于是童子宝网。闻佛所宣真谛之义心怀悦豫。以金缕织成衣其价无数奉上如来。如来应时即如其像三昧正受。佛身一切诸有毛孔悉演光明。照于东方不可称计无际世界。其在东方一切佛土。皆悉遥见此佛国土。其彼众会集在道场。亦复皆睹于此佛刹。当尔之时九十九亿百千兆载诸四部众。皆各各见诸佛世尊。佛告童子宝网。仁今乃见东方去此不可思议无能称计无际世界诸佛世尊。浩浩甚多无以为喻。童子白曰。已见世尊。佛告童子。譬如三千大千世界诸天人名一一身号。建立精进不可计会。其诸佛名复过于彼不可称载。或名吉祥。善寂亦然。或名月响。月殿亦然。或名清净。花光亦然。或有名号过神通王。如一名号。其若干名亦各如是。对曰已见。天中之天。东西南北四维上下亦复如是。如仁今者所见佛数。仁者。更转轮王若干反数。时童子宝网。欢喜踊跃善心生焉。时地大动一切众生皆得安隐。其大光明无所不照。劝发德本。无央数亿百千兆垓诸天之众住虚空中。散花烧香供养如来。释梵诸天各各侍从。无数兆载诸天营从。雨赤栴檀青莲芙蓉黄白莲花。或有诸天垂散无数诸宝璎珞。不可称计数亿百千垓世间人民。自来投身归佛足下。悲喜交集泪流于面。承佛威神识念无数亿百千垓宿世所更。遥睹无底兆载神足变化。于是天人叹颂曰

  其无央数亿　　诸天普周遍
  柔软妙花香　　下散世光明
  亿载天帝释　　佥住虚空中
  紫磨金色花　　以奉两足尊
  亿百千梵天　　手执赤栴檀
  以散光明曜　　举声而嗟叹
  无数诸天乐　　在上而自鸣
  所演辞尊妙　　显离垢光明
  诸天莲花有百千　　住在虚空赞导师
  诸华若干天香盖　　为人中尊亿幢幡
  各拥百千宝璎珞　　散明月珠奉叹佛
  其心欢悦供最尊　　胜无等伦威无量
  人民具足百千亿　　自归最胜不可量
  头面着地而自归　　识亿垓宿无以喻
  于时世光明　　则为扣法鼓
  应时告于彼　　名闻巨亿土
  无限不可量　　亿数人民会
  佛则建立之　　尊慧人中上
  上妙坚固宝　　栴檀无能胜
  自然彼床座　　童子怀踊跃
  巍巍微妙宝　　宝网即受持
  化是无数千　　以奉两足尊
  一心所思惟　　其价直千界
  光明亿百千　　所出明月珠
  一心悉如是　　宝网演威曜
  其明所可照　　遍其维耶离
  以此奉供养　　世护圣明主
  宝盖三万六　　用上两足尊
  若干种宝盖　　诸佛身形现
  紫磨金色成　　团如尼拘类
  所贡上宝盖　　周匝垂真珠
  一一其宝盖　　二万有五千
  如是献世尊　　须臾间悉辨
  以黄金衣服　　赐遗诸菩萨
  庄严于佛道　　具足普周遍
  二万五千人　　诸亿百千众
  众菩萨亿党　　无能计数者
  无央数亿垓　　其载数如是
  悉从东方来　　南方西亦然
  北方上下方　　四隅亦如是
  一切诸世界　　目悉遥睹之
  世护诸圣主　　其色紫磨金
  世尊住于彼　　晃晃奋光明
  诸菩萨等类　　各从本土来
  童子宝网者　　供养此学士
  当尔集会时　　所敬不可议
  世尊劝安将　　人上世师子
  于诸天龙神　　人民高位者
  如今住佛前　　一心而奉敬
  往世亦如是　　供如江河沙
  其闻此佛经　　童子宝网行
  其三昧正定　　不退转至佛
  所得功德报　　不可称限量
  持斯经典者　　福无以为喻
  十方诸佛土　　尚可知其数
  水火及风种　　地可尽极知
  若持此经者　　嗟叹说其限
  不能尽究福　　功德之多少
  比丘比丘尼　　及清信士女
  诸天摩睺勒　　闻是经典者
  众生悉集会　　不能称其德
  血脉不损耗　　入火火为冷
  七日专惟是　　奉修佛道行
  亦供养菩萨　　奉经当如是
  其欲一毛厘　　执持千世界
  擎之以手掌　　亿劫不舍置
  若于后末世　　以如是像经
  广为他人说　　疾成尊觉道
  能为他人说　　是为未曾有
  佛道不可限　　譬喻难遍数
  然于后末世　　外道异学人
  闻佛师子吼　　必当共诤讼
  其有奉敬佛　　世护演光明
  于后将来世　　闻经甚谦恭

佛告童子。若有佛刹中三品众生。共和同心志于佛慧。设复有人供养此等。无央数劫如江河沙。以贡上佛一心无二。造立精舍极令广大如大千界。以天栴檀而合成之。一精舍里兴造讲堂计有亿数。一一讲堂施亿千榻。一一床上重布好衣柔软。百亿紫磨金宝以为床榻。使大神圣住在世间。以此床榻而供养之。竟恒沙劫灭度之后。为一一佛各起塔庙。亦如江河沙不可计亿。为一一佛所起塔庙七宝合成。大如三千大千世界。极高巍巍极于上界三十三天。一一塔庙所供养盖。数如江河沙。亿百千垓诸真珠贯垂着四面。亿千缯幡跱立诸幢。亦如江河沙。众宝校饰鼓诸伎乐。一塔庙竖天上柱。诸柱罗列亿百千垓。而见供养所设如是。一佛世界所兴塔庙幢盖香花。如是奉事江河沙劫。若闻是经一偈之颂。不怀犹豫颁宣咨嗟。一安住名号福过于彼。并供养吾为天中天。能持奉行不毁禁戒。若有明者闻三昧名。得见诸佛如江河沙。亦能恭敬消息承事。诸两足圣威神无极。讲说经典常无放逸。无数亿劫未曾忘失。其有曾见过去世吼为说尊经殊异道王。是等末世闻之乃悦。宿从世尊更已启受。弃捐结网瑕秽之垢。除诸恶行如粪不净出于贪欲。名曰有目。习乐闲居常无驰骋。其人本在维耶离城。以曾闻佛说是经时。自归如来及见宝网。于后末世乃持是经。如我所教为弟子说。其行尊妙功德茂盛。愍伤众生开度诸流。于后末世乃持是经。供养诸佛不可称计。是等之类于后末世乃持佛法。若亿千劫净修梵行在于世间。行不可计积累功德。于后末世闻此经者。福超于彼无能限量。启受经典精思无底。游诸佛土不可计会。见诸正觉讲无限法。见阿弥陀阿閦如来。其欲睹此诸人中导离垢光[火*僉]师子月英。然后末世当持此经。若复欲见弥勒如来无垢大圣师子英如来。如光明尊亦复如是。然后末世当持佛法。顺如是比尊妙经典。今者如来为宝网说。自于后世当奉行之。无得住立放逸之地。不毁禁戒常无放逸。于后世时当奉行之。仁寿终时当速往生上方世界无量光明最胜佛土。世界名曰为宝君主。彼寿终已当久逮寻见弥勒正觉。佛说如是。童子宝网。四万亿菩萨弥勒菩萨等。六十亿阿罗汉。九十亿诸天世人阿须伦。闻佛所说莫不欢喜。作礼而退佛说宝网经


佛说宝雨经

    No. 660

佛说宝雨经卷第一(显[禾*(ㄆ/用)]不退转菩萨记)

        唐天竺三藏达摩流支译

如是我闻。一时薄伽梵。住伽耶城伽耶山顶。与大苾刍众七万二千人俱。皆是阿罗汉诸漏已尽。无复烦恼得真自在。心善解脱慧善解脱。如调慧马亦如大象。已作所作已办所办。弃诸重担逮得己利。尽诸有结明了正法。心得自在到胜彼岸。通达法界为法王子。于诸利养心无所著。善得出家成具足戒。意解圆满住涅槃路。唯除一人。谓长老阿难陀。犹居学地

菩萨摩诃萨八万四千人皆是一生补处。于一切智现前能入随顺尊重。得无所著陀罗尼门。住首楞严三昧。游戏神通证无功用。离一切障起大慈悲。遍满十方一切世界。善摄无边诸佛刹土。空性所行安住无相。心如虚空如甚深海。如妙高山八风不动。亦如莲花无所染着。如明净宝如炼真金。为欲利益诸有情故。起无边智入佛境界。其名曰宝炽菩萨。宝手菩萨。宝印手菩萨。宝冠菩萨。宝髻菩萨。宝积菩萨。宝性菩萨。宝顶菩萨。宝幢菩萨。金刚藏菩萨。金藏菩萨。宝藏菩萨。德藏菩萨。离垢菩萨。如来藏菩萨。智藏菩萨。日藏菩萨。定藏菩萨。莲花藏菩萨。解脱月菩萨。普月菩萨。净月菩萨。观自在菩萨。大势至菩萨。普贤菩萨。普眼菩萨。莲花眼菩萨。普威仪菩萨。端严菩萨。普慧行菩萨。法慧菩萨。胜慧菩萨。上慧菩萨。金刚慧菩萨。师子游戏菩萨。大音声王菩萨。师子吼菩萨。甚深音声菩萨。无染着菩萨。离一切垢菩萨。月光菩萨。日光菩萨。智光菩萨。智德菩萨。贤德菩萨。月德菩萨。莲花德菩萨。宝德菩萨。曼殊室利法王子菩萨摩诃萨等

复有十六善大丈夫。贤护菩萨而为上首

复有贤劫菩萨。慈氏菩萨而为上首

复有四大王众天。四大天王而为上首

复有三十三天众。帝释天王而为上首

复有时分天众。时分天王而为上首

复有知足天众。知足天王而为上首

复有乐变化天众。乐变化天王而为上首

复有他化自在天众。他化自在天王而为上首

复有白分魔王众。商主罗摩而为上首

复有梵天王众。大梵天王而为上首

复有净居天众。摩醯首罗天王而为上首

复有无量百千阿素罗众。毗摩质多罗阿素罗王。睒末罗阿素罗王。婆稚阿素罗王。罗怙罗阿素罗王等而为上首

复有无量百千诸龙王众。阿那婆达多龙王。摩那斯龙王。娑揭罗龙王。和修吉龙王等而为上首

复有无量百千诸龙王子。威光而为上首

复有无量百千诸龙王婇女。及余无量天龙。药叉健达缚。阿素罗。揭路荼。紧奈罗。莫呼罗伽。人非人等。皆来集会。时伽耶山顶周四踰缮那地及虚空。无微尘许众不充满。为欲供养佛世尊故敷师子座。其师子座高一踰缮那。以无量百千绮妙缯彩宝铃宝网宝盖庄严。复有百千缯带垂下。其师子座及地方处皆以金刚所成。坚固难坏。平坦如掌洒扫清净散众天花甚可爱乐。于其地上出生无量百千叶金色莲花。琉璃为茎帝青为台。香气芬馥悦可众心。其座四边生四宝树。高半踰缮那枝条荫映三俱卢舍

尔时如来于大众中坐师子座。以清净智转妙法轮。降伏魔怨世法不染。无有惊怖如师子王。如清净池。亦如大海。如妙高山。如日光耀。如月清凉。如大龙王普雨法雨。如梵天王超诸法众。以无量无边诸弟子等。及百千帝释梵王护世四天王等。一切大众前后围绕。瞻仰尊颜目不暂舍

尔时世尊从于顶上放大光明蔽于众会。其所放光名曰普耀。有无量光明而为眷属。遍满十方一切世界。还于佛所右绕三匝摄入面门。然佛面门无有异相。譬如月光遍于虚空无有异相。如是光明入佛面门无有异相亦复如是。又如灌水及苏油等入于沙聚。然彼沙等无有异相。光入面门亦复如是

尔时东方有一天子名日月光。乘五身云来诣佛所。右绕三匝顶礼佛足退坐一面

佛告天曰。汝之光明甚为希有。天子。汝于过去无量佛所。曾以种种香花珍宝严身之物衣服卧具饮食汤药。恭敬供养种诸善根。天子。由汝曾种无量善根因缘。今得如是光明照耀。天子。以是缘故。我涅槃后最后时分。第四五百年中法欲灭时。汝于此赡部洲东北方摩诃支那国。位居阿鞞跋致。实是菩萨故现女身为自在主。经于多岁正法治化。养育众生犹如赤子。令修十善能于我法广大住持建立塔寺。又以衣服饮食卧具汤药供养沙门。于一切时常修梵行。名曰月净光。天子。然一切女人身有五障。何等为五。一者不得作转轮圣王。二者帝释。三者大梵天王。四者阿[跳-兆+卑]跋致菩萨。五者如来。天子。然汝于五位之中当得二位。所谓阿鞞跋致及轮王位。天子。此为最初瑞相。汝于是时受王位已。彼国土中有山涌出五色云现。当彼之时。于此伽耶山北亦有山现。天子。汝复有无量百千异瑞。我今略说。而彼国土安隐丰乐人民炽盛甚可爱乐。汝应正念施诸无畏。天子。汝于彼时住寿无量。后当往诣睹史多天宫。供养承事慈氏菩萨。乃至慈氏成佛之时。复当与汝授阿耨多罗三藐三菩提记

尔时月光天子。从佛世尊闻授记已。踊跃欢喜身心泰然。从座而起绕佛七匝顶礼佛足。即舍宝衣严身之具。奉上于佛作如是言。世尊。我于今者亲在佛前得闻如是本末因缘。授阿耨多罗三藐三菩提记已获大善利。作是语已绕佛三匝退坐一面

尔时东方过殑伽沙世界。有世界名莲花。其佛号曰莲花眼如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。为诸菩萨开示正法。其所演说唯是一乘。彼佛刹中无有声闻辟支佛名。一切有情皆是阿鞞跋致。回向阿耨多罗三藐三菩提。而彼世界诸菩萨等。皆以禅定法喜为食无段食等。彼佛光明清净遍满。不假日月星宿之光。地平如掌无诸草木墙壁瓦砾及以山川清净严饰

尔时释迦牟尼佛所放光明既遍其国。而彼大众倍增欢喜。彼有菩萨名止一切盖。何故菩萨而受此名。若诸有情闻其名者。即能断除诸障结缚名止一切盖。尔时止盖菩萨。乘佛光明诣彼佛所从莲花下。偏袒右肩右膝着地。合掌恭敬而白佛言。世尊。如是种种清净光明。悦乐身心从何而至

尔时莲花眼如来告止盖菩萨言。善男子。西方去此佛刹过殑伽沙世界。有佛国土名曰索诃。其中有佛号释迦牟尼如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。若诸有情闻彼佛名。于阿耨多罗三藐三菩提得不退转。如是种种清净光明。从彼如来之所现耳。其有众生遇斯光者身心悦乐。尔时止盖菩萨白佛言。世尊。以何因缘闻彼佛名。即于阿耨多罗三藐三菩提得不退转

佛告止盖菩萨。善男子。由彼如来往昔修菩萨行时发是誓愿。若我得成佛已。一切有情闻我名者。皆于阿耨多罗三藐三菩提得不退转。止盖菩萨白其佛言。世尊。若如是者彼世界中诸有情等。但闻佛名皆于菩提不退转耶。佛言不也。止盖菩萨言。世尊。彼诸众生既已预闻彼佛名号。云何于中有退不退。佛言。善男子。但使得闻如来名号。皆与彼作不退因缘。是故亦名阿鞞跋致

善男子。譬如植种未经腐败。至彼后时水土和合。于意云何。如是种子名为生不。止盖菩萨白其佛言。世尊。如是种子无有损坏。若遇因缘而定得生。佛言。善男子。如是如是。彼诸众生由闻佛名。必定当成阿鞞跋致。得授阿耨多罗三藐三菩提记

尔时止盖菩萨白佛言。世尊。我今欲往索诃世界。礼拜释迦牟尼如来应正等觉。承事供养尊重赞叹。愿见听许。尔时世尊告止盖菩萨言。善男子。汝欲往彼今正是时。其诸菩萨又白佛言。世尊。我亦欲往索诃世界。礼拜亲觐恭敬供养释迦牟尼佛

尔时世尊告彼诸菩萨言。善男子。汝若欲往今正是时。汝等于彼国土。莫生轻贱放逸之心。所以者何。彼国有情多诸贪欲嗔恚愚痴。不敬沙门婆罗门造作非法粗恶犷悷矫诈轻险。贡高我慢爱着悭吝嫉妒懈怠。毁破禁戒行诸不善。无量烦恼之所系缚。而彼如来能于恶世教化有情。彼诸菩萨白其佛言。世尊。释迦牟尼如来。甚为希有能为难事

佛告诸菩萨。如是如是。如汝所说。于恶世中若诸有情。一弹指顷能生净信。或持禁戒或离悭贪或起大悲。发阿耨多罗三藐三菩提心。过于清净国土百千劫行

尔时止盖菩萨及诸菩萨。承佛教已顶礼佛足。彼本住处将欲往诣索诃世界。为欲供养释迦牟尼佛故。即以种种神通变化。示现宝树花树果树劫波树等。皆以真金琉璃颇胝迦宝而严饰之。高广微妙枝条扶疏。或复示现种种衣服严身之具。妙香宝盖诸天音乐如云而下。现如是等无量变化。谓众菩萨言。诸仁者。彼索诃世界多诸苦恼。汝等各现神变。令彼有情获最胜乐。时诸菩萨皆曰唯然

尔时止盖菩萨及诸菩萨。身出种种清净光明。其光遍满三千大千世界。其中所有地狱傍生琰魔鬼界蒙光触身。皆得离苦悉获安乐。慈心相向远离贪嗔。如父母想。又于世界暗冥之中日月光明所不能及。而皆大明各得相见。威光照耀充满世界。所有诸山。铁围山。大铁围山。目真邻陀山。摩诃目真邻陀山。并余黑山。上至梵世。下至阿鼻地狱。靡不周遍。威光至处一切有情。求食得食求衣得衣。求乘得乘求财得财。盲者得视聋者得闻。狂者正念苦者得乐。怀孕之者自然平安

尔时止盖菩萨与诸菩萨。到索诃世界已诣伽耶山。以诸菩萨威神力故。三千大千世界宝网弥覆庄严显现。于虚空中遍布大云。雨天妙莲花杂花妙果。或雨天花鬘好香末香袈裟衣服珠盖幢幡。现如是等种种供具之时。索诃世界一切有情。皆得最上无量快乐。尔时伽耶山顶及诸方国。所有株杌一切丛林。由菩萨威神力故悉不复现。又复显示一切宝树花树果树栴檀沉水劫波树等。枝叶花果次第庄严甚可爱乐。于虚空中奏天伎乐供养赞叹

尔时止盖菩萨摩诃萨。即从坐起偏袒右肩右膝着地。向佛合掌恭敬而白佛言。世尊。我欲少问如来应正等觉。唯愿听许。佛告止盖菩萨言。善男子。随汝所问当为汝说。一切如来皆同许可。今汝应当善自摄心。止盖菩萨闻佛许已白佛言。世尊。云何菩萨得施圆满。云何净戒圆满。云何住忍圆满。云何精进圆满。云何静虑圆满。云何般若圆满。云何方便善巧圆满。云何大愿圆满。云何胜力圆满。云何得智圆满。世尊。诸菩萨云何等于地。云何等于水。云何等于火。云何等于风。云何等于空。云何得如月。云何得如日。云何如师子。云何善调伏。云何性寂静。云何如莲花。云何广大心。云何清净心。云何无犹豫心。云何而得智慧如海。云何而得微妙智善巧。云何成就应理辩才。云何而得解脱辩才。云何而得清净辩才。云何能令一切众生欢喜满足。云何言说令他信受。云何名为能说法者。云何而得随顺法行。云何而得诸法善巧。云何而得法界善巧。云何行于空。云何行无相。云何行无愿。云何得慈自性。云何得悲自性。云何得喜行。云何得舍行。云何能得游戏神通。云何能得离八无暇。云何住菩提心而不退转。云何而得宿住智通。云何而得近善知识。云何而得远离恶知识。云何证得如来法身。云何修得金刚之身。云何而得为大商主。云何于道而得善巧。云何演说得不颠倒。云何常得诸三摩呬多。云何菩萨受粪扫衣。云何而得受用三衣。云何而得不随他行。云何常乞食。云何得一坐。云何得一食。云何得阿兰若。云何得树下坐。云何露地坐。云何冢间住。云何得常坐。云何随敷坐。云何修瑜伽者。云何能持素怛缆藏。云何能持毗奈耶藏。云何而得轨则所行境界具足威仪。云何得离悭吝嫉妒。云何于一切有情得平等心。云何得善巧供养如来。云何降伏我慢。云何多净信。云何于世俗而得善巧。云何于胜义而得善巧。云何深入缘起善巧。云何自了知。云何能知于世。云何得生清净佛土。云何得处胎尘垢无染。云何乐出家。云何得净命。云何无疲倦。云何奉顺如来教敕常不违越。云何和颜微笑永无颦蹙。云何具足多闻总持。云何善巧摄受正法。云何为法王子。云何而得释梵护世之所随从。云何了他意乐随眠。云何成熟有情善巧。云何得随顺住。云何共安隐住。云何而得摄事善巧。云何成就相好端严。云何而得依止所作。云何而得如药树王。云何精勤修福德业。云何修证变化善巧。云何速证无上菩提

尔时世尊告止盖菩萨言。善男子。善哉善哉。汝为利益无量有情故。为安乐无量有情故。为哀愍一切世间故。问如是义。谛听谛听善思念之。当为汝说。尔时止盖菩萨闻是语已白佛言。唯然世尊。愿乐欲闻。佛言。善男子。有十种法。诸菩萨摩诃萨若能成就。即得施波罗蜜多。何等为十。一者成就法施。二者成就无畏施。三者成就财施。四者成就无悕望施。五者成就慈愍施。六者成就不轻慢施。七者成就恭敬施。八者成就供养施。九者成就无所依施。十者成就清净施。善男子。云何菩萨成就法施。所谓摄受正法。受持读诵。无所悕求。不为利养恭敬故。不为名闻胜他故。唯为一切苦恼有情令罪销灭。演说妙法无所悕望。如为王王子及旃陀罗子演说妙法心尚无二。况为一切大众说法心不平等。虽复行施而不恃此心生我慢。善男子。是名菩萨成就法施。善男子。云何菩萨成就无畏施。所谓菩萨自舍离科罚及一切器仗。亦教他学舍离科罚及一切器仗。又复观察一切有情。如父母想。如男女想。如亲属想。何故菩萨作如是念。如佛所说。一切众生未有不曾为我父母男女眷属。于微细虫犹割身肉而布施之。何况广大有情而令惊怖。是名菩萨成就无畏施。善男子。云何菩萨成就财施。所谓菩萨观见一切有情。造极恶业施财摄取。令彼远离所作恶业安置善处。复起思惟。佛说布施是菩萨菩提。由布施故得断三种不善之法。所谓悭吝嫉妒恶思。是故我应学于如来随所有财常行布施。虽复施与不起慢心。是名菩萨成就财施。善男子。云何菩萨成就不悕望施。所谓布施终不为自身故。不为财物故。不为眷属故。不为利养故。然诸菩萨行布施时其心清净。由是因缘远离一切希望报恩而行布施。是名菩萨成就不希望施。善男子。云何菩萨成就慈愍施。所谓菩萨见诸有情受于苦恼饥渴贫露衣服垢弊。孤独无怙无所依止。远离福业无所趣向。由此菩萨作是思惟起慈愍心。我为利益彼有情故。发阿耨多罗三藐三菩提心。此诸有情受于苦恼。无归无怙无所依处流转生死。我当何时为诸有情。为归为怙为所依处。由是菩萨慈愍缠心。于常常时于恒恒时。随所有物施彼有情。虽有饶益众生善根。终不恃此起于高慢。是名菩萨成就慈愍施。善男子。云何菩萨成就不轻慢施。所谓施时终不弃掷轻欺而与。曾无嗔嫌要颉之意。不恃富贵自在骜慢。非求多闻名称憍逸。所施与时欢喜恭敬尊重赞叹自手授与。是名菩萨成就不轻慢施。善男子。云何菩萨成就恭敬施。所谓菩萨见阿遮利耶邬波驮耶。及修梵行所有尊者。恭敬顶礼问讯起居。但是所作种种善根。愿我同作所作成就是名菩萨成就恭敬施。善男子。云何菩萨成就供养施。所谓菩萨供养三宝。云何供养佛。谓于如来制多之中。若花若香若散若烧及涂扫地。若制多破坏应当修理。是名菩萨善供养佛。云何供养法。谓诸菩萨听闻正法。若书写受持读诵通利思惟修习。不颠倒思惟不颠倒修习。是名菩萨善供养法。云何供养僧。谓供给衣服饮食卧具汤药。下至水器众具皆足。是名菩萨善供养僧。如是供养佛法僧时。是名菩萨成就供养施。善男子。云何菩萨成就无所依施。所谓菩萨行布施时。终不为求天王位果及生余天。亦不求人王及小王等。是名菩萨成就无所依施。善男子。云何菩萨成就清净施。所谓菩萨行施之时。观察施物及能所施皆非实有。离诸障碍贪染过患。是名菩萨成就清净施。善男子。若能成就此十种法。是名菩萨成就施波罗蜜多

复次善男子。菩萨成就十种法。即能圆满戒波罗蜜多。何等为十。一者守护波罗提木叉律仪。二者守护菩萨净戒律仪。三者远离一切热恼。四者远离不如理思惟。五者惊怖所作诸业。六者惊怖所作违犯。七者怖见他物。八者要期坚固。九者得净尸罗而无所依。十者尸罗三轮清净。善男子。云何菩萨守护波罗提木叉律仪。所谓菩萨善学如来所说素怛缆毗奈耶法。善受学处。菩萨修学及以学处。不着种族故。不执异见故。不着徒众故。不见补特伽罗过患生尊重心故。是诸菩萨所修学处。是名菩萨守护波罗提木叉律仪。云何守护菩萨净戒律仪。所谓菩萨如是思惟。若但学波罗提木叉。终不令我得阿耨多罗三藐三菩提。由是菩萨于诸如来素怛缆中所说菩萨学处及菩萨律仪戒。我应修学。何者是菩萨学处。何者是菩萨律仪戒。谓诸菩萨不住非处。顺时而语知时知方。菩萨若不如是即令有情不生敬信。由是菩萨随顺一切诸有情故。令至菩提及为己身菩提资粮速圆满故。成就具足威仪行法。音声柔软辩才简要无所执着。恒修寂静颜貌熙怡。是诸菩萨于如来所说素怛缆中。成就学处修律仪戒。是名守护菩萨净戒律仪。云何菩萨远离一切缠障热恼。所谓菩萨不为贪嗔痴等毒火所烧。亦复不为阙缘众具热恼所烧。以诸菩萨修习贪欲能对除法。及远离能起贪欲缘故。何者是贪欲对除。何者是起贪爱缘。谓修不净观是贪对除。世间妙色是贪起缘。云何修习观不净法。谓诸菩萨观察自身发毛爪齿皮肤血脉筋肉骨髓脾肾心肺肝胆肠胃生熟二藏肪膏脑膜洟唾涎泪脓汗脂痰疮。及尘垢大小便利流溢种种臭秽不净。如是观察不净体性。深生厌离不起贪心。设有顽嚚痴迷狂乱幼无了解。见是事时尚不起贪。何况智者。由是菩萨修不净观。云何远离起贪爱缘。谓诸菩萨见于世间端严妙相可爱色像。便生染着适悦身心。即自思惟。如世尊说爱欲境界犹如幻梦悟已即无。云何智者于幻梦境而起贪心。是名菩萨修习对除贪欲自性及彼起缘。云何菩萨修嗔对除。云何远离能起嗔缘。所谓菩萨于诸有情多修习慈。由是因缘对除嗔恚。若起嗔恚于因于缘有执着时。彼诸菩萨由是伏灭嗔恚随眠。是名菩萨修习对除嗔及起嗔缘。云何菩萨修痴对除。云何远离能起痴缘。由彼菩萨如是观察便得离痴。由离痴故无诸热恼。远离乐欲及众资具。是名菩萨修习对除痴及起痴缘。云何菩萨而得远离不如理思惟。谓诸菩萨静处独坐终不思惟。云我居静处不杂乱住。我顺如来毗奈耶法。其余沙门婆罗门等。皆杂乱住多所执着。不顺如来毗奈耶法。是名菩萨远离不如理思惟。云何菩萨怖畏所作诸不善业。谓诸菩萨起正思惟修诸善法。以如来说诸苾刍等应当恭敬守护净戒。专修定业习学般若。何以故。以恭敬心作福德业。能招端正可爱果报殊胜果报。菩萨如是远离一切诸不善业。是名菩萨而能怖畏所作诸业。云何菩萨惊怖违犯。所谓菩萨见违犯中如微尘量深生怖畏。下至少罪心怀大惧。况多违犯而生随喜。何以故。由知如来说苾刍当知。多服毒药能令人死。少服毒药亦令人死。苾刍当知。若多犯罪即生恶趣。若少犯罪亦生恶趣。菩萨如是正思惟时惊怖违犯。是名菩萨惊怖违犯。云何菩萨怖见他物。谓此菩萨与城邑聚落诸婆罗门刹帝利等。心相体信彼。婆罗门刹帝利等。或以金银末尼真珠珂贝珊瑚璧玉吠琉璃宝及资身具而寄菩萨。菩萨受时独一无二虽无忌惮。菩萨于彼终无恶思而辄受用。又复菩萨执知众事。若窣堵波物。若四方僧物及僧祇等物。于诸物中亦不受用。何以故。由世尊说。若他饮食资生之具一切物等。他不与时皆不应用。菩萨如是起思惟已。宁自割身肉而自食之。然于他物终无侵犯。是名菩萨怖见他物。云何菩萨誓愿坚固。所谓菩萨若为恶魔及魔天众。以诸妙欲来娆菩萨令起贪爱。菩萨于彼心无惑着而不生退。是名菩萨誓愿坚固。云何菩萨于净尸罗心无所著。谓诸菩萨善护禁戒终不起心。以此尸罗令我生天及王等家。是名菩萨于净尸罗心无所著。云何菩萨三轮清净。谓诸菩萨于身口意皆得清净。云何身得清净谓身所有一切恶行皆得永离。何者是身恶行。所谓杀生及不与取欲邪行业。常远离故。是名身得清净。云何菩萨语得清净。谓语恶行皆得永离。何者是语恶行。谓虚诳离间粗恶杂秽等语。常远离故。是名语得清净。云何菩萨意得清净。谓意所有一切恶行皆得永离。何者是意恶行。谓贪染嗔恚邪见。皆远离故。是名意得清净。是名菩萨三轮戒净。善男子。菩萨摩诃萨成就此十种法。得尸罗圆满

佛说宝雨经卷第一佛说宝雨经卷第二

        唐天竺三藏达摩流支译

复次善男子。菩萨摩诃萨成就十种法得忍圆满。何等为十。一者内忍圆满。二者外忍圆满。三者法忍圆满。四者随佛教忍圆满。五者无分限忍圆满。六者无分别忍圆满。七者不待事忍圆满。八者无恚忍圆满。九者悲忍圆满。十者誓愿忍圆满。云何菩萨内忍圆满。善男子。谓诸菩萨于内所有忧悲苦恼。能安忍住心无逼迫。是名菩萨内忍圆满。云何菩萨外忍圆满。善男子。谓诸菩萨闻他粗言骂詈毁呰父母亲属阿遮利耶邬波驮耶。及闻诽谤佛法僧宝。菩萨闻已不起嗔恨反报毁呰。亦不为彼嗔恚随眠之所随逐。堪忍彼恼能安隐住。是名菩萨外忍圆满。云何菩萨法忍圆满。谓诸菩萨于佛所说素怛缆中一切甚深微妙法义。无来无去自性寂静。离分别取自性涅槃。菩萨闻已不惊不怖。作是思惟。我若不了诸深妙法。终不能得阿耨多罗三藐三菩提。由是因缘摄取诸法。思惟修习心生信解是名菩萨法忍圆满。云何菩萨随佛教忍圆满。谓诸菩萨若起嗔恚为损害时。菩萨自应如是思惟。而此嗔恚从何而起从何而灭。是谁所起云何而起有所缘耶。菩萨如是思惟。彼能起之因了不可得。能灭之因亦不可得。能起既无所起非有。乃至所缘皆不可得。由是菩萨安忍而住嗔无缘起。是名菩萨随佛教忍圆满。云何菩萨无分限忍圆满。谓诸菩萨非昼分忍夜分不忍。非夜分忍昼分不忍。非自国忍他国不忍。非他国忍自国不忍。非于名闻者忍无名闻者不忍。非于无名闻者忍有名闻者不忍。由是菩萨于一切时及一切国名闻有无皆悉能忍。是名菩萨无分限忍圆满。云何菩萨无分别忍圆满。谓诸菩萨非惟父母妻子亲属于是处忍余所不忍。是故菩萨下至旃荼罗等亦能行忍。是名菩萨无分别忍圆满。云何菩萨不待事忍圆满。谓诸菩萨修忍辱时。不为财物。不为惊怖。不为行恩。不为顺世及羞耻故。如是菩萨自性常忍。是名菩萨不待事忍圆满。云何菩萨得无恚忍圆满。谓诸菩萨设未遇彼嗔恚因缘。及未遇他嗔心常安忍。若遇因缘及遇他嗔。或复轻欺拳打手搏刀杖损害粗言毁责。菩萨遇已作是思惟。被轻毁业是我所造我今应受。定非父母亲属所造。是故我今欢喜忍受。亦非内外地界所受。水火风界亦复如是。菩萨由是无倒观察。遇因缘时于嗔不嗔二俱能忍。是名菩萨得无恚忍圆满。云何菩萨悲忍圆满。谓诸菩萨。于彼贫苦一切有情。为作君主若王小王。有大财宝多诸资具。若为一切贫苦有情。骂詈呵责恼乱之时。终无恚恨损害之心。亦不自高现主威势。但起思惟。此诸有情是我所摄。我应养育而守护之。由是菩萨不生损害。以是因缘起大悲心忍受安住。是名菩萨悲忍圆满。云何菩萨誓愿忍圆满。谓诸菩萨如是思惟。我曾于彼一切如来应正等觉所。作师子吼誓修菩提。成正觉已于生死海烦恼泥中。济拔一切诸有情等。菩萨由是不生嗔恼。是故我应精勤修习。为拔济故。为成熟故。为欲调伏安乐有情。若自起嗔及损害彼即不含容。云何而能生于悲忍拔济有情。善男子。如有良医善能针疗见有众生患目翳者。作是思惟。我应愍彼为除眼翳令无暗障。尔时良医起思惟已自患眼暗。善男子。汝意云何。而此医师堪能疗彼有情眼翳除暗障不。止盖菩萨白佛言不也世尊。佛告止盖菩萨言。善男子。菩萨亦尔作是思惟。我今不应以般若针断世间翳。由自心有无明暗障。如何能灭他无明惑。由是因缘。终不损害修忍安住。是名菩萨得誓愿忍圆满。善男子。菩萨成就此十种法得忍圆满

复次善男子。菩萨成就十种法得精进圆满。何等为十。一者如金刚精进。二者得无逮精进。三者离二边精进。四者广大精进。五者炽盛精进。六者性常精进。七者清净精进。八者不共精进。九者不轻贱精进。十者不倨傲精进。善男子。云何如金刚精进。谓诸菩萨发起精进。勤修而住诸有情界。未涅槃者令证涅槃。未得度者令其得度。未解脱者令得解脱。未安隐者令得安隐。未现等觉者令现等觉。菩萨如是勤修而住。尔时天魔伺求其短将欲破坏。至菩萨所作如是言。善男子。汝勿作此勤苦精进。何以故。我曾如是发起精进。勤修而住诸有情界。未涅槃者令证涅槃。未得度者皆令得度。未解脱者令得解脱。未安隐者令得安隐。未现等觉者令现等觉。如此精进诳惑愚夫。皆为虚妄非真实法。善男子。如是勤修起精进者。我未曾见一有情能于阿耨多罗三藐三菩提而现等觉。善男子。我知无量俱胝有情。皆能证入二乘涅槃。善男子。汝徒精进求虚妄法。速舍是心离诸苦恼。尔时菩萨作是思惟。决定是魔恼坏于我。菩萨悟已知是魔说而告之言。汝恶思惟欲破坏我。汝但自忧勿忧我事。世尊已说。魔罗波旬一切世间各随逐业。若自若共而感生处。魔罗汝今亦随逐业。亦自亦共而感生处。汝应如是随业而往。莫恼乱我无义利故。又于长夜自受苦恼。尔时魔罗情智狭劣。自生惭耻即舍恶自隐没不现。由是菩萨。若一切魔王及诸魔众来恼乱时。欲求其短故相破坏。而菩萨心终不倾动。无下勇捍坚固不退。是名菩萨如金刚精进。善男子。云何菩萨得无逮精进。谓诸菩萨发起如是种种精进。诸余菩萨虽复久远积集净业安住真性终不及此发起种种精进菩萨。数分不及。迦罗等分乃至计喻及邬波尼杀昙分亦不能及。何况一切声闻缘觉。是中菩萨发心精进力。能摄取一切佛法。复能舍离一切罪业诸不善法。是名菩萨得无逮精进。云何菩萨离二边精进。谓诸菩萨常起精进不增不减。何以故。以极增上生倨傲故。以极下劣生懈怠故。是故精进常不增减。是名菩萨离二边精进。云何菩萨广大精进。谓诸菩萨发起精进。愿我如是当得如来妙色端严。诸佛所有无见顶相。圆光随好微妙具足。又复发起如是精进。愿我当得无量无碍诸佛大智。及大威德胜义性等。是名菩萨广大精进。善男子。云何菩萨炽盛精进。谓诸菩萨发起精进。永离一切尘垢过患。如末尼珠及紫金等。远离一切尘垢过患。光明炫曜殊妙赫奕。菩萨精进如是炽盛。永离一切尘垢过患。何者名为精进尘垢。何者名为精进过患。所谓惰怠懒惰。不节饮食。不自知量。非理作意。起恶思惟。如是说名精进尘垢。亦名过患。菩萨精进永能舍离。是故精进清净无垢鲜白炽盛无复过患。是名菩萨炽盛精进。云何菩萨性恒精进。谓诸菩萨于诸威仪能常发起种种精进。性恒勤勇无休废时。若身若心曾无懈倦。是名菩萨性恒精进。云何菩萨清净精进。谓诸菩萨发起如是恒常精进。所有众罪诸不善法无利益事。障碍于道乃至微细极小不善一念恶心亦不发起。况复广大诸不善法。是故菩萨皆悉除断顺涅槃理。圣道资粮趣菩提分。如是善法菩萨修习令增长广大圆满菩提。是名菩萨清净精进。云何菩萨不共精进。谓诸菩萨如是思惟。设使十方殑伽沙界。火聚遍满如阿鼻狱过彼世界。有一众生受诸苦恼。无归无依及无怙恃。菩萨哀愍彼一有情。度猛火聚往彼教化尚不辞劳。况多有恼而不救济。菩萨如是大悲精进。外道二乘所不能及。是名菩萨不共精进。云何菩萨不轻贱精进。谓诸菩萨终不起心。以我精进微弱下劣及懈怠故。修习菩提自谓难得。又复不作如是思惟。我亦不能荷担。如是于无量劫及千万劫积集苦行。如救头然方证菩提。不作如是退屈之心。由是菩萨发如是心。所有过去如来应正等觉。现在如来应正等觉。未来如来应正等觉。彼诸如来于无量劫精进修行皆现等觉。由是诸佛非不多时修行精进。得有如是现正等觉。我亦如是理应多劫修种种行。当得阿耨多罗三藐三菩提。以三世如来同行精进已成佛故。又我宁为一切有情。精勤修习而处地狱。终不为己修行精进而证涅槃。是名菩萨不轻贱精进。云何菩萨不倨傲精进。谓此菩萨起精进时。终不味着自倨轻他。谁有智者希他恩念而行精进。是名菩萨不倨傲精进。善男子。菩萨摩诃萨。能成就此十种法故得精进圆满

复次善男子。菩萨成就十种法得静虑圆满。何等为十。一者积集福德。二者能多厌离。三者勤修精进。四者具足多闻。五者得不颠倒勤修领受。六者法随法行。七者成利根性。八者得心善巧。九者得奢摩他毗钵舍那善巧。十者得不执着。云何菩萨积集福德。谓诸菩萨爱乐大乘。复能积集一切善根。所生之处摄善知识。而能修习种种妙行。又常愿生大婆罗门家。刹帝利家。大居士家。所生之处恒得正信。由是因缘增长无量广大善根。为常不离善知识故。善知识者。所谓诸佛一切菩萨。由是菩萨。串习善根增长炽盛。观察世间苦恼逼迫。众病所集愚暗所蔽无所安住。何以故。以欲因缘故。云何菩萨能多厌离。谓诸菩萨由前因缘。我今不应于此世间行于贪欲。以彼贪欲但由妄情分别生故。诸佛广说一切贪欲种种过患。所谓欲如尖摽如镩如剑亦如利刀。又如毒蛇。如水聚沫。如肉腐败臭秽可恶。由是菩萨起厌离心。剃除须发而披法服出家正信趣于非家。云何菩萨勤修精进。谓此菩萨既出家已发大精进。未得令得。未解令解。未证令证。云何菩萨具足多闻。谓此菩萨由前因缘多闻领受。于世俗谛及胜义谛深妙理中善能宣说。云何菩萨得不颠倒勤修领受。谓此菩萨于诸谛理领纳于心。精勤修习无倒善巧。云何菩萨法随法行。谓此菩萨得善巧已法随法行。所谓正语正业正命正思惟正精进正念正定正见。是为菩萨修习道支。云何菩萨而得利根。谓此菩萨习道支已。利根明悟能正了知。菩萨由此安住寂静。远离执着一切愦闹不乐多言。复能舍离欲寻恚寻害寻及不死寻。远离眷属名称利养。云何菩萨得心善巧。谓此菩萨由前因缘。得心善巧身常寂静。观察其心于善不善及与无记。自念我今心住何性。若住胜善清净心生信乐欢喜。云何胜善。谓三十七菩提分法。若住不善应当厌离。发起精进便能永断诸不善法。云何名为诸不善法。谓贪嗔痴。贪有三种。谓上中下。云何上贪。谓此贪欲遍满身心。随顺下劣心常染着。于一切时无有惭愧。云何无惭。谓贪欲者恒起思惟寻求欲境。心生爱重耽着赞美。是名无惭。云何无愧。谓贪欲者为欲因缘。能于父母及余尊者起于诤论。轻欺损害重彼贪欲。是名无愧。谓贪欲者由是因缘生于恶处。是故说名增上贪欲。云何中贪。谓贪欲者。行贪欲已即生厌离。起变悔心不复随顺。是名中贪。云何下贪。谓贪欲者起贪欲时。或摩触身才共语言。或时见已欲心便息。是名下贪。所有一切活命资具。心若执着总说名贪。云何名嗔。是嗔应知亦有三种。谓上中下。云何上嗔。谓嗔恚者起种种嗔。于五无间随造一业。或谤正法。谤正法者。其罪过彼五无间业。数分不及。迦罗分不及。乃至计喻邬波尼杀昙分亦所不及。由是因缘生捺洛迦。若生人中形貌惨黑眼目恒赤。为人暴恶常行损害。由是因缘生捺洛迦。是名上嗔。云何中嗔。谓嗔恚者造罪业已。速能改悔即起对除。是名中嗔。云何下嗔。谓嗔恚者由起嗔故出粗恶言轻调讥嫌集不善业。经一刹那及一腊缚一牟呼栗多。即能改悔修习对除。是名下嗔。是痴应知亦有三种。谓上中下。云何上痴。谓愚痴者恒住贪嗔曾无忧悔。是名上痴。云何中痴。谓愚痴者起少不善。即能于彼梵行者前发露忏悔。不见恶业可受重故。是名中痴。云何下痴。谓愚痴者于佛所制非性戒中少有毁犯。或一二三便能舍离。是名下痴。菩萨于彼贪嗔痴法。皆能遮止由心善巧。得善巧已终无喜乐于彼染着。何以故。得心善巧故。若住无记即勤观察惟起正念。云何无记。谓起心时心不在内亦不在外。非住于善非住不善。不住毗钵舍那亦复不住于奢摩他。而心下劣引起睡眠。令心昧略。犹如士夫极重睡眠初觉之时根识惛昧不能明了。住无记心亦复如是。以无记心不明了故。菩萨于中心精勇锐安住欢喜。是名菩萨得心善巧。云何菩萨得奢摩他毗钵舍那善巧。谓此菩萨心善巧已。观察诸法如幻如梦。思惟诸法此是善法。此非善法。此出离法。此不出离法。谓诸菩萨观一切法皆依于心。心为自性。心为上首。能摄受心。善调伏心。善了知心。故能摄此一切诸法。既善调伏又善了知。由此因缘便能修习奢摩他法。如是系心如是止心及安住心。勤修如是奢摩他故。便能安住心一境性。菩萨住心一境性已。入定观察得离生喜乐。心得喜已。远离欲界恶不善法及有寻有伺。是名修行住初静虑。又离寻伺不味喜乐。观无常已出初静虑。住内等净得定生喜乐。是名菩萨入第二静虑。次厌离喜及观苦已。住舍正念正知及乐心安正受。佛说成就住舍念乐入第三静虑修行而住。作空解已入第四静虑。便舍我执。舍我执故。苦乐亦断。忧喜灭故。住不苦乐舍念清净。是名修习第四静虑。又菩萨观身与虚空等。既信解已。舍诸色想。灭有对想。离种种想。舍色想故。灭有对想。离异想故。入无边空。是谓修习空无边处。超过一切空无边已。有识等生入无边识。是谓修住识无边处。超过一切识无边已。入无所有。是谓修住无所有处。超无所有修习而住非想非非想处。又诸菩萨远离能缘想受心故。名住灭定。虽入彼定终不乐着。出彼定已与慈心俱。舍怨憎心远损害想。广大无量平等无二极善修习。于一方面意解遍满入定而住。诸余三方四维上下周遍世间与悲心俱。舍怨憎心离损害意。广大无量平等无二极善修习。于一方面无边世界。意解遍满入定而住。诸余三方四维上下周遍世间。菩萨与喜心俱。舍怨憎心离损害意。广大无量平等无二极善修习。于一方面意解周遍入定而住。诸余三方四维上下周遍世间。菩萨与舍心俱。离怨憎心舍损害意。广大无量平等无二极善修习。于一方面意解周遍入定而住。诸余三方四维上下周遍世间。云何菩萨得不执着。谓此菩萨得五神通亦不执着。常能希求菩提资粮诸法圆满。善男子。菩萨摩诃萨。成就此十种法故。得静虑圆满

复次善男子。菩萨成就十种法得般若圆满。何等为十。一者无我善巧。二者业果善巧。三者有为善巧。四者生死流转善巧。五者舍离生死善巧。六者得二乘善巧。七者大乘善巧。八者舍离魔业善巧。九者得不颠倒般若。十者得无等般若。善男子。云何菩萨得无我善巧。谓诸菩萨。学般若故能正观色受想行识。观察色时生不可得。集不可得。灭不可得。如是观察受想行识生集灭法俱不可得。以胜义中不可得故非于世俗。胜义世俗诸法自性。但有言说实无可得。由是因缘菩萨长时不舍精进。为欲利益诸有情故如救头然。由是菩萨得无我善巧。云何菩萨得业果善巧。谓诸菩萨如是思惟。一切世间自性皆空。如戏场处健达缚城。一切有情虽非实有然执着我。由是不能通达圣道。是诸有情如是思惟。若无有我。及无有情命者生者意生士夫。若补特伽罗摩纳缚迦。若养育者。即无善恶业异熟果体性可得。以正般若如实了知。是名菩萨得业果善巧。云何菩萨得有为善巧。谓诸菩萨以正般若了知一切诸有为法。如是思惟。诸有为法念念迁谢无久住相。犹如危露譬若瀑流。云何如是法中。而生贪着即怀忧恼。若起执着易坏诸法。何名智者。由是因缘于灭坏法不乐执着起厌离心。是名菩萨得有为善巧。云何菩萨得生死流转善巧。谓诸菩萨如是思惟。一切世间无明所覆。常处生死为爱罥缚。由爱为因而生于取。由取为因生善恶业。由生业故令有相续。由有为因而起于生。由生为因故有老死忧悲苦恼。众苦集故如是展转相续不断。如汲灌轮上下回转。生死相续亦复如是。由此菩萨以正般若如实了知。是名菩萨得生死流转善巧。云何菩萨得舍离生死善巧。谓诸菩萨如是思惟。离无明故不着诸行。舍诸行故则无有爱。远离爱故则无有取。能离取故有不相续。舍彼有故则无有生。能离生故永断老死忧悲苦恼。由是菩萨以正般若如实了知。是名菩萨得舍离生死善巧。云何菩萨得二乘善巧。谓诸菩萨如是思惟。此法得能预流一来及不还果阿罗汉故。永尽诸漏断诸结习无复相续。生死流转游履涅槃。思惟此法得辟支佛。如犀角喻。独一而行。一切菩萨以正般若了知此法。终不取证。何以故。若诸菩萨如是思惟。我为利益诸有情界。作师子吼。我当拔济住于生死诸有情类。发大誓愿终不独一出离生死。是名菩萨得二乘善巧。云何菩萨得大乘善巧。谓诸菩萨于学戒中。观学者不可得。所学亦不可得。戒所得果亦不可得。然不执空堕于断见。是名菩萨大乘善巧。云何菩萨而得舍离魔业善巧。谓诸菩萨远离一切不善丈夫。亦不住彼恶国之中。又能远离随世俗见修习咒术。而求利养及尊重供养。复能远离障菩提法诸烦恼等。而能修习诸对除道。是名舍离魔业善巧。云何菩萨得不颠倒般若。谓诸菩萨修习般若。于诸世间经书咒术工巧处中。常为教化诸有情故。终不为已求知解故。亦不为身得名闻故。又复不为得利养故。为开演圣教大威德故。终不欲为显己德故。专起思惟殊胜正教。于如来制毗奈耶中。示现功德终不堕于异道诸见。是名菩萨得不颠倒善巧。云何菩萨得无等般若谓诸菩萨所学般若。超过二乘。一切世间天魔梵世及诸外道婆罗门等八部诸众一切有情。而无等于菩萨般若。惟除如来应正等觉。是名菩萨无等般若。善男子。菩萨能成就此十种法。得般若圆满

佛说宝雨经卷第二

(大周长寿二年岁次癸巳九月丁亥三月己丑佛授记寺译)

(大白马寺大德沙门怀义监译)

(南印度沙门摩流支宣释梵本)

(中印度王使沙门梵摩兼宣梵本)

(京济法寺沙门战陀译语)

(佛授记寺沙门慧智证译语)

(佛授记寺沙门道昌证梵文)

(天宫寺沙门摩难陀证梵文)

(大周东寺都维那清源县开国公沙门处一笔受)

(佛授记寺都维那昌平县开国公沙门德感笔受)

(佛授记寺沙门思玄缀文)

(长寿寺主沙门智[澰*殳]缀文)

(佛授记寺都维那赞皇县开国公沙门知静证议)

(佛授记寺主渤海县开国公沙门行感证议)

(大周东寺都维预章县开国公沙门惠俨证议)

(天宫寺上座沙门知道证议)

(大周东寺上座江陵县开国公沙门法明证议)

(长寿寺上座沙门知机证议)

(大奉光寺上座当阳县开国公沙门惠棱证议)

(佛授记寺沙门神英证议)

(京西明寺沙门圆测证议)

(波罗门僧般若证译)

(波罗门僧臣度破具写梵本)

(鸿州度山县人臣叱干智藏写梵本)

(婆罗门臣迦叶乌担写梵本)

(婆罗门臣刹利乌台写梵本)

(尚方监匠臣李审[暴-日]装)

(麟台揩书令史臣杜大宾写)

(专当典并写麟台揩书令史臣徐元处)

(专当使文林郎守左术翊二府兵曹参军事臣傅守真)

(敕捡挍翻经使典司宾寺府史赵思泰)

(敕捡挍翻经使司宾寺录事摄然孙承辟)佛说宝雨经卷第三

        唐天竺三藏达摩流支译

复次善男子。菩萨成就十种法得方便善巧圆满何等为十。一者得回向方便善巧。二者令诸外道归向方便善巧。三者转舍境界方便善巧。四者除遣恶作方便善巧。五者救护有情方便善巧。六者施与有情活命方便善巧。七者得受取方便善巧。八者舍离非处住于是处方便善巧。九者示现教导劝励庆喜方便善巧。十者供养承事方便善巧。云何菩萨得回向方便善巧。谓诸菩萨以非他摄所有花果。昼夜六时奉献诸佛及诸菩萨。以此善根回向阿耨多罗三藐三菩提。菩萨以非他摄所有香树。若诸宝树。若劫波树。于昼夜六时供养诸佛及众菩萨。以此善根回向阿耨多罗三藐三菩提。菩萨又于素怛缆中所有广大承事供养。闻已起于净信乐心回此。供养一切诸佛及诸菩萨。又复菩萨能于十方诸菩萨所。及余有情所造善业。令菩提资粮皆得圆满。发净意乐深心庆喜。以此善根回向阿耨多罗三藐三菩提。菩萨若以香花奉献如来制多及佛形像以此回向。令诸有情离破戒垢得佛戒香。菩萨又常洒扫涂地持此回向。令诸有情离恶威仪修善法式齐整圆满。又诸菩萨奉献花盖以此回向。令诸有情舍离热恼。又彼菩萨入僧伽蓝发如是心。令有情等入涅槃城。出伽蓝时。愿令有情出生死狱。若开房门。愿令有情开诸善趣出世智门。若闭房门。愿令有情闭恶趣门。菩萨坐时。愿令有情皆得坐于妙菩提树。右胁卧时。愿令有情安住涅槃。从卧起时。愿令有情离缠障起。若往便利。愿令有情向大觉路。正便利时。愿令有情拔诸毒箭。若洗净时。愿令有情洗烦恼垢一切过患。若洗手时愿令有情离秽浊业。若洗足时。愿令有情离障尘垢。嚼杨枝时。愿令有情舍离垢秽。菩萨自身所作诸业。持此回向。利益安乐一切有情。菩萨礼拜如来制多。愿令有情常得诸天及世间礼。是名菩萨回向方便善巧。云何菩萨令诸外道归向方便善巧。谓此菩萨于彼彼类外道众中。能变化作诸外道形。谓遮洛迦波利缚罗社迦昵健陀弗多罗。于彼法中受持读诵。菩萨为欲成熟有情如是思惟。我若先作阿遮利耶。则不能令傲慢有情随顺调伏。由是我往外道法中。示现出家为作弟子。既出家已勇猛精进。随彼修习。种种诸行。博学多闻究尽彼法。乞粗秽食所作皆胜彼诸外道威仪行法。由是菩萨为诸外道尊重师范。所有言说悉皆信受随顺调伏。菩萨了知此诸有情归向我已。说彼外道邪见过失。所学之法复非正教。以不能说厌离贪欲令断灭故。由是外道受菩萨化。舍离邪道入正法中。菩萨又于一切外道修习五通梵行之中。勤行精进证五神通。又复修习成就静虑。诸三摩地三摩钵底。胜诸外道所得五通。聪慧超彼为作师范。菩萨了知所化外道皆成熟已。说彼静虑诸三摩地三摩钵底种种过失。所学之法复非正教。以彼不说厌离贪欲对除道故。由是外道受菩萨化。舍离邪道入佛法中。是名菩萨令诸外道归向方便善巧。云何菩萨转舍境界方便善巧。谓此菩萨观见一切多贪有情方便调伏。化作女身端严殊妙胜余女身。有情见者心生染着。菩萨见彼如是染着。即便于彼寝卧之处示现命终。于一刹那一牟呼栗多。现膖烂相臭秽可恶。有情见已起大惊怖生苦恼心情深厌舍。谁能令我离于如是秽恶之处

尔时菩萨即于彼前。随机演说如是诸法。于三种菩提定随证一。是名菩萨得转舍方便善巧。云何菩萨除遣恶作方便善巧。谓此菩萨见诸有情造无间罪。及起一切诸不善业失心忧悔。菩萨往彼作如是言。善男子。云何失心忧悔而住。彼有情言。大士。我造无间诸不善业。恐于长夜受诸苦恼。无利益故。不安乐故。以是因缘失心忧悔。是时菩萨为彼有情广说正法。令深悔过受菩萨戒。若此有情未能悔过。是时菩萨欲令彼人心生信伏。为现神通广说彼人思惟之事。有情由是于菩萨所生信伏心欢喜信乐。生信乐已根性成熟。菩萨为彼广说妙法。彼人即能随顺领受。菩萨又复于彼人前化作父母说如是言。汝可观之我即是汝同伴丈夫。汝莫悔过此所造业。毕竟不堕捺洛迦中。亦不退失利益安乐。如是说已。即便杀害所现父母。菩萨于彼有情之前示现神变。彼人思惟。有智之者尚杀父母不失神通。况我无智而造此业。堕捺洛迦退于利乐。尔时菩萨为彼有情演说妙法。令其恶业渐得轻微犹如蚊翼。是名菩萨除遣恶作方便善巧。云何菩萨救护有情方便善巧。谓此菩萨观见有情。根器成熟堪为说法。彼之有情造作一切极不善业。菩萨为欲利益彼人。方便调伏化作种种诸有情类。应以大王身得调伏者。即现大王身而为说法。应以小王身得调伏者。即现小王身而为说法。应以婆罗门刹帝利身得调伏者。即现婆罗门刹帝利身而为说法。应以天身得调伏者。即现天身而为说法。应以执金刚身得调伏者。即现执金刚身而为说法。应以怖畏得调伏者。现作怖畏而为说法。应以系缚杀害打骂得调伏者。即为示现如是等事而为说法。应以爱语得调伏者。即现爱语而为说法。若有情类欲造彼彼无间罪时。于菩萨身兴损害意。其得神通菩萨。即为示现种种方便。或时遮止。或复禁制。或移向他方。于彼人前。又复示现似彼所造无间业事。或复示现捺洛迦相。制彼所造无间罪业令不现前。其有未得神通菩萨。善能观察彼诸有情寿命长短。见彼有情欲造无间作是思惟。此诸有情将起重罪。而发大悲心生忧恼。菩萨观彼犹如掌中置庵罗果作是思惟。我为利益一有情故。能于阿鼻受大苦恼。即此有情。乃至未住无余涅槃。常能如是无别方便而能遮止。此诸有情造恶业已。将欲生彼捺洛迦中。由我未得神通自在。无有方便移彼不信寿命短促诸恶有情置于他方。恐彼有情由不善业生阿鼻狱。菩萨以是发起悲心。思惟有情各随自业。无异方便而能救济。但起慈心平等教诫示为科罚。是名菩萨救护有情方便善巧。云何菩萨施与有情活命方便善巧。谓诸菩萨观见有情不堪受法。但求衣食以为自足。不能了知圣法调伏。菩萨教示此诸有情算数伎术文字注记如是事业。为成于善不成恶法。是名菩萨施与有情活命方便善巧。云何菩萨得受取方便善巧。谓此菩萨得珍宝聚如妙高山而不受取。若能下劣资生杂物而即受之。何以故。谓此菩萨如是思惟。此诸有情悭吝嫉妒。贪爱所蔽惜自他物。不令自他而得受用。由此因缘处生死海常被漂没。菩萨欲令彼有情等。于长夜中得具足利益及安乐故。而便为受。虽受彼物不起贪爱。无属己心但为供养诸佛法僧。令诸有情同获胜利。及为饶益贫苦有情。施主由是欢喜踊跃。是名菩萨得受取方便善巧。云何菩萨舍离非处住于是处方便善巧。谓诸菩萨观见有情堪能受法。于阿耨多罗三藐三菩提应现等觉。然彼有情。为得声闻辟支佛乘。发起方便常勤修习。菩萨说法令彼有情舍离二乘。引导回向大乘法中。是名菩萨舍离非处住于是处方便善巧。云何菩萨示现教导赞励庆喜方便善巧。谓诸菩萨能令有情未发菩提心者。令发菩提心。已发菩提心者虽复持戒心易知足。若少精进而多懈怠。菩萨教令常修精进。若诸有情虽少持戒多有毁犯。由是因缘信不清净常无喜乐。为破戒垢覆心而住。菩萨为彼有情演说种种妙法。令彼有情心生净信欢喜悦乐。是名菩萨示现教导赞励庆喜方便善巧。云何菩萨得承事供养方便善巧。谓诸菩萨既得出家。于诸利养知量知足。所受利养无非法者。又诸菩萨独处闲静入定而住。随顺诸佛及菩萨行。如是思惟。我欲承事供养如来。谓此菩萨随顺思惟已。而作种种承事供养一切如来。得六殊胜波罗蜜多修行圆满。云何修六波罗蜜多诸行圆满。谓于承事供养等中严办资具。此是菩萨施波罗蜜多。谓于承事供养等中。发心饶益一切有情。此是菩萨戒波罗蜜多。谓于承事供养等中。心能安住欢喜悦乐。此是菩萨忍波罗蜜多。谓于承事供养等中。心无厌倦。此是菩萨勤波罗蜜多。谓于承事供养等中一心思惟。此是菩萨静虑波罗蜜多。谓于承事供养等中。心能种种差别观察。此是菩萨般若波罗蜜多。是名菩萨承事供养方便善巧。善男子。菩萨成就此十种法。得方便善巧圆满

复次善男子。菩萨成就十种法故得愿圆满。何等为十。一者无下劣愿。二者无怯弱愿。三者为欲利益一切有情勤修行愿。四者为诸佛如来赞叹发愿。五者善能摧伏一切魔愿。六者成就不由他愿。七者得无边愿。八者不惊怖愿。九者不疲厌愿。十者得圆满愿。云何菩萨无下劣愿。谓此菩萨不乐诸有而发于愿。是名菩萨无下劣愿。云何菩萨无怯弱愿。谓此菩萨不厌三界求离贪欲住于寂灭而发于愿。是名菩萨无怯弱愿。云何菩萨为欲利益一切有情勤修行愿。谓诸菩萨发如是愿。诸有情界乃至尽证无余涅槃。我方于后证大圆寂。是名菩萨为欲利益一切有情勤修行愿。云何菩萨为诸佛如来赞所发愿。谓此菩萨发如是愿。诸有情界乃至未发菩提心者皆愿发心。愿发心已次第修行菩提分行。次修行已坐菩提树。于彼已得坐道场者。我当承事恭敬供养请转法轮。若般涅槃我当劝请久住世间。为欲利益诸有情故。是名菩萨为诸佛如来赞所发愿。云何菩萨善能摧伏一切魔愿。谓此菩萨发如是愿。若我当来现等觉时。于佛土中永无一切天魔之众。亦复不闻诸魔名字。是名菩萨善能摧伏一切魔愿。云何成就不由他愿。谓此菩萨不由他故。于阿耨多罗三藐三菩提而方发愿。然以般若观有情界受于苦恼。既观见已为欲救护。发阿耨多罗三藐三菩提心。是名菩萨而能成就不由他愿。云何菩萨得无边愿。谓此菩萨不为菩提少分资粮而发于愿。然此菩萨为发大愿。偏覆左肩右膝着地起净信心。观十方界现住诸佛一切菩萨。或有菩萨住于苦行。或坐道场。或见诸佛。或现等觉。或转法轮。观见彼已发净意乐。于彼十方诸佛菩萨。或住苦行。或现等觉及转法轮。菩萨于彼一一信解深心庆喜。回向阿耨多罗三藐三菩提。是名菩萨得无边愿。云何菩萨得不惊怖愿。谓诸菩萨有新发心。闻甚深法。闻于诸佛广大威德。闻诸菩萨游戏神通。闻于甚深方便善巧。菩萨闻已不惊不怖作是思惟。谓诸如来所证菩提所住境界。成熟有情皆无边量。于彼法中我不能知。诸佛证知我应当知。是名菩萨得不惊怖愿。云何菩萨不疲厌愿。谓诸菩萨虽见有情志性顽愚又难调伏。于此有情终不疲厌。或有菩萨见诸有情志性顽愚难调伏者而生疲厌。由疲厌故弃舍有情发如是愿。我求生于清净世界。终不用闻如是诸恶有情之名。虽复愿生清净世界终不得生。以弃舍有情不成熟故。于此义中又聪慧菩萨发如是心。于诸世界诸有情中。精进下劣有懈怠者。顽嚚聋瞽如彼哑羊。如是有情为一切佛及诸菩萨观察简择及遍有情界中。无般涅槃法者并皆弃舍。我今欲令如此有情悉当集会我佛刹中。又我欲令此诸有情坐于道场。成阿耨多罗三藐三菩提。而此菩萨发如是心思惟之时。念念之中诸魔宫殿悉皆震动。又为一切诸佛如来之所称叹。如是菩萨必定得生清净佛土。又能速疾于阿耨多罗三藐三菩提而现等觉。是名菩萨得不疲厌愿。云何菩萨得圆满愿。谓此菩萨坐道场已摧破魔军。于阿耨多罗三藐三菩提道而现等觉。愿既圆满无复更发。善男子。譬如苏油于其钵中。平满盛已更不容受。如极微量一滴苏油。是故说名得圆满愿。菩萨如彼盛苏油钵。能于菩提现等觉已。愿既满足无复更发一切妙愿。是名菩萨得圆满愿。善男子。菩萨成就此十种法得大愿圆满

复次善男子。菩萨成就十种法修力圆满。何等为十。一者他不映蔽修力圆满。二者不被摧伏神力圆满。三者于福德力修习圆满。四者于般若力修行圆满。五者于眷属力同得圆满。六者于神通力修得圆满。七者于自在力修得圆满。八者于总持力而得圆满。九者无能改易神变力圆满。十者他不违越教力圆满。善男子。云何菩萨他不映蔽修力圆满。谓此菩萨一切外道诸异论者不能映蔽。是名他不映蔽修力圆满。云何菩萨不被摧伏神力圆满。谓此菩萨诸有情中。终无有能摧菩萨力。是名不被摧伏神力圆满。云何菩萨于福德力修习圆满。谓此菩萨修习一切世出世间所有福德。菩提资粮悉皆积集。无有少分不圆满者。是名菩萨于福德力修习圆满。云何菩萨于般若力修行圆满。谓此菩萨于诸佛法。以正般若而观见之。唯除如来一切种智。非不已证非不了知。是名菩萨于般若力修习圆满。云何菩萨于眷属力同得圆满。谓此菩萨所有眷属。于戒及见威仪净命皆悉圆满。所有眷属一切皆同菩萨所行。是名菩萨于眷属力同得圆满。云何菩萨于神通力修得圆满。谓此菩萨神通胜力。超诸世间及彼二乘神通境界。菩萨乐欲于一毛端安赡部洲乃至四洲。若千世界。二千三千大千世界。又复菩萨乐欲于一微尘量中安处无量殑伽沙界。如是世界若二若三若四若五。或十二十三四五十。乃至不可说不可说不可说殑伽沙界。安置于一极微尘中。其微尘量不增不减。彼诸世界于一微尘中。各各安处不相障碍。其中有情亦无娆乱迫迮之相。是名菩萨于神通力修得圆满。云何菩萨于自在力修得圆满。谓此菩萨意所乐欲。七宝充满大千世界饶益有情。乃至乐欲种种诸宝。于不可说不可说界皆得充满。是名菩萨于自在力修得圆满。云何菩萨于总持力而得圆满。谓此菩萨乃至闻于所不可说不可说数诸佛土中一切如来演说正法。义句有异名理不同。菩萨能于一刹那中。若一腊缚一牟呼栗多。于义句名理领受了知并能修习。是名菩萨于总持力而得圆满。云何菩萨无能改易神变威力圆满。谓此菩萨所有神变。唯除如来应正等觉。一切有情终无有能改易菩萨。是名菩萨得无改易神变威力圆满。云何菩萨得不违越教力圆满。谓此菩萨所有教敕言无有二。有情信顺无违越者。唯除方便善巧利乐。是名菩萨得不违越教力圆满。善男子。菩萨成就此十种法修力圆满

复次善男子。菩萨成就十种法得智圆满。何等为十。一者于补特伽罗无我智得圆满。二者于法无我智得圆满。三者于无限量智得圆满。四者于三摩地所行境界智得圆满。五者修神变智而得圆满。六者不摄取智修得圆满。七者观有情所行智得圆满。八者于无功用智得圆满。九者诸法相智修得圆满。十者于出世智修得圆满。云何菩萨于补特伽罗无我智圆满。谓此菩萨随诸蕴相观见生起。又于诸蕴观见灭坏。菩萨正观诸蕴生时性不坚固。无实所作即是空性。及正观察诸蕴灭时体性破坏。菩萨如是思惟诸蕴毕竟无我。亦无有情。无有命者。无养育者。无补特伽罗。愚夫异生执着于我。如是思惟。蕴即非我。我即非蕴。然诸蕴中妄执有我。不能了知真实法故。生死流转犹如旋轮。菩萨如实了知诸法。是名菩萨于补特伽罗无我智得圆满。云何菩萨于法无我智得圆满。谓此菩萨如实了知增益损减诸法体性。菩萨又复如是思惟。法之与名更互为客。但由虚妄分别安立法及名字。俱无自性依想心量。及随世俗法及名字。更互为客。非无有体及以作用。此依他缘说有法性。待他众缘而得起故。菩萨如实了知一切待缘而起缘尽而灭。是名菩萨于法无我智得圆满。云何菩萨于无限量智得圆满。谓此菩萨无限量智。非初刹那起后刹那不起。非此方起余方不起。以无碍智于一切刹那一切方所。而常相续恒遍起故。是名菩萨于无限量智得圆满。云何菩萨于三摩地所行境界智得圆满。谓此菩萨能悉了知二乘所得诸三摩地。能悉了知菩萨所得诸三摩地。及能了知一切如来诸三摩地。又此菩萨亦能了知二乘修习住三摩地。及三摩地所行境界。亦能了知一切菩萨住三摩地。及三摩地所行境界。亦能了知如来所住诸三摩地。及三摩地所行境界。以如来力加持菩萨故能了知佛三摩地。菩萨若以自所成就异熟果智。即不能知佛三摩地。以自成就异熟果智。能悉了知余三摩地。是名菩萨于三摩地所行境界智得圆满。云何菩萨修神变智而得圆满。谓此菩萨能正了知声闻神变。能正了知缘觉神变。能正了知菩萨神变。何况一切有情所有神变而不能知。是名菩萨修神变智而得圆满。云何菩萨不摄取智修习圆满。谓此菩萨所成就智。一切外道及诸恶魔。声闻缘觉不能摄取。是名菩萨不摄取智修习圆满。云何菩萨观有情所行智得圆满。谓此菩萨以清净智观有情界。见有情中或未发菩提心。或已发菩提心。或未得菩提心。或已得菩提心。或住初地乃至十地。或已现等觉。或正现等觉转法轮时。或于所化一切已办入般涅槃。或有声闻乘般涅槃时。或有辟支佛乘般涅槃时。或生善趣。或生恶趣菩萨悉见。是名菩萨观有情所行智得圆满。云何菩萨于无功用智得圆满。谓此菩萨行住去来若动若寂。任运常起无功用智。如人睡眠出息入息而无功用。应知菩萨无功用智亦复如是。于一切境智起无碍。是名菩萨于无功用智得圆满。云何菩萨诸法相智修得圆满。谓此菩萨了知诸法皆同一相。谓能了知一相无相。及诸幻相妄分别相。是名菩萨诸法相智修得圆满。云何菩萨出世间智修习圆满。谓此菩萨得无漏智。超过一切世间诸智。是名菩萨出世间智修习圆满。善男子。菩萨成就此十种法得智圆满

复次善男子。菩萨成就十种法得如大地何等为十。一者广大无量。二者一切有情之所受用。三者舍离恩怨。四者普能承受大法云雨。五者为诸有情之所依止。六者诸善种子之所依处。七者如大宝器。八者如大药器。九者得不倾动。十者得不惊怖。善男子。云何菩萨广大无量。犹如大地周遍广大无有边量。菩萨如是周遍广大。福智资粮无有限量。是名菩萨得广大无量。云何菩萨为一切有情之所受用。譬如大地为种种资具一切有情之所受用。菩萨如是摄取彼彼布施持戒忍辱精进静虑般若波罗蜜等。种种资粮为诸有情之所受用。是名菩萨为一切有情之所受用。云何菩萨舍离恩怨。善男子。譬如大地平等载育。无恩无怨无嗔无喜种种之想。菩萨如是于有情中无有恩怨不生嗔喜。是名菩萨舍离恩怨。云何菩萨普能承受大法云雨。譬如大地普能承受广大云雨悉皆含容。菩萨如是承受如来发起广大善法云雨能忍能持。是名菩萨普能承受大法云雨。云何菩萨为诸有情之所依止。善男子。譬如大地为诸有情来去所依。菩萨如是平等普为一切有情往于善趣及向涅槃之所依故。是名菩萨为诸有情之所依止。云何菩萨为诸善种之所依处。善男子。譬如大地能为一切种子依处。菩萨如是能为有情一切善法种子依处。是名菩萨诸善种子之所依处。云何菩萨如大宝器。善男子。譬如大地为诸宝器。能现种种诸珍宝故。菩萨如是能现种种诸功德宝。是名菩萨如大宝器。云何菩萨如大药器。善男子。譬如大地一切诸药依之出现。能除世间一切诸病。菩萨如是诸大法药依之而出。所现法药能灭世间烦恼诸病。是名菩萨如大药器。云何菩萨得不倾动。善男子。譬如大地非蚊蚋等力所亏损。世间诸风不能摇动。菩萨如是不为一切有情内外苦恼之所倾动。是名菩萨得不倾动。云何菩萨得不惊怖。善男子。譬如大地若有诸龙及诸兽王。哮吼音声无有惊怖。菩萨如是闻彼诸魔一切外道哮吼音声不生怖畏。是名菩萨得不惊怖。善男子。菩萨成就此十种法得如大地

佛说宝雨经卷第三佛说宝雨经卷第四

        唐天竺三藏达摩流支译

复次善男子。菩萨成就十种法得如于水。何等为十。一者随顺善法。二者常能生长一切白法。三者欢喜净信悦乐滋润。四者令一切烦恼相续朽败。五者自性澄清无浊洁净。六者息灭一切烦恼烧然。七者舍离一切诸欲爱渴。八者甚深难度。九者于等不等地方充满。十者息灭一切诸烦恼尘。云何菩萨随顺善法。譬如大水若行若流若出。皆能随顺滋润草木。菩萨如是于诸善法。随顺修行随顺流布随顺出离。是名菩萨随顺善法。云何菩萨能生一切白善之法。善男子。譬如水性能生一切草木丛林生已增长。菩萨如是。以三摩地水。能生一切菩提分法生已增长。乃至能成萨筏若树。以得一切佛果智树。所有种种诸白善法。令诸有情之所受用。是名菩萨能生一切诸白善法。云何菩萨得欢喜净信悦乐滋润。善男子。譬如于水自性流润。及能令他一切滋润。菩萨如是常怀净信。欢喜悦乐自性滋润及能令他一切有情欢喜净信悦乐滋润。云何欢喜。谓常悕求出世间法。云何净信。谓能归依于佛法僧。云何悦乐。谓彼所有清净之心而常悦乐。是名菩萨欢喜净信悦乐滋润。云何菩萨令一切烦恼相续根栽皆悉朽败。善男子。譬如于水能令一切若树若草其根腐败。菩萨如是以修行所依三摩地水。能令一切烦恼根栽相续腐败。既腐败已烦恼相续体不可得。烦恼臭秽无有余习。是名菩萨令一切烦恼相续根栽皆悉腐败。云何菩萨自性澄清无浊洁净。善男子。犹如于水自性澄清无浊洁净。云何自性澄清。谓能远离缠及随眠。云何无浊。谓能远离贪嗔痴故。云何洁净。能令诸根得洁净故。是名菩萨自性澄清无浊洁净。云何菩萨息灭一切烦恼烧然。善男子。犹如水性于有情热恼及热时热处悉令息灭。菩萨如是。能以法水息灭有情诸烦恼热。是名菩萨息灭一切烦恼烧然。云何菩萨舍离一切诸欲爱渴。善男子。犹如有情为渴所逼。若得于水即便止渴。菩萨如是。一切有情为彼欲境渴所逼故生诸苦恼。菩萨即为雨大法雨。有情由此离境界渴。是名菩萨舍离一切诸爱欲渴。云何菩萨甚深难度。善男子。如大深水甚为难度菩萨如是。成就般若圆满甚深。不为诸魔一切外道之所能度。是名菩萨甚深难度。云何菩萨于等不等地方充满。善男子。如水瀑流。于等不等诸地方所皆悉遍满。菩萨如是法水瀑流。于等不等诸有情界遍能充满。由菩萨哀愍诸有情故。发起瀑流广大法水而不逼迫。诸有情界不同于水。是名菩萨于等不等地方充满云何菩萨息灭一切诸烦恼尘。善男子。譬如于水能令一切坚硬地方普皆柔软。及诸尘坌皆能止息。菩萨如是以般若所依三摩地水。令诸有情坚硬染心悉皆柔软。及能息灭烦恼尘坌。是名菩萨息灭一切诸烦恼尘。善男子。菩萨成就此十种法。等之于水

复次善男子。菩萨成就十种法。等之于火。何等为十。一者能烧诸烦恼聚。二者能成熟佛法。三者能干诸烦恼泥。四者如大火聚。五者如火光明。六者能令惊怖。七者能令安隐。八者能令一切有情共得。九者能令供养。十者得不轻欺。云何能烧诸烦恼聚。善男子。譬如大火能烧一切草木丛林诸秽恶聚。菩萨如是以智慧火。能烧一切缠及随眠贪嗔痴等烦恼恶聚。是名菩萨能烧一切诸烦恼聚。云何菩萨能成熟佛法。善男子。譬如火性成熟一切种种饮食诸药等物。菩萨如是以内证般若。成熟佛法而不退失。是名菩萨成熟佛法。云何菩萨能干诸烦恼泥。善男子。譬如大火能干于泥。菩萨如是悉能干竭诸烦恼泥。是名菩萨能干一切诸烦恼泥。云何菩萨如大火聚。善男子。譬如有人为极寒苦之所逼迫。然大火聚得离寒苦。菩萨如是。若诸有情为烦恼寒苦之所逼迫。以般若火令得销灭。是名菩萨如大火聚。云何菩萨如火光明。善男子。譬如有人于雪山顶玟陀罗山顶然大火聚。赫奕炽盛光耀周遍一踰缮那。或二踰缮那。或三踰缮那。菩萨如是以智慧明。光耀周遍百踰缮那。或千踰缮那。或百千踰缮那。乃至无量阿僧企耶。诸世界中一切有情。皆蒙智光明耀周遍。有情遇此智光明故。破坏一切无明黑闇。是名菩萨如火光明。云何菩萨能令惊怖。善男子。譬如兽王及诸恶兽。见大火聚即生怖畏。既惊怖已舍离于此远至他方。一切魔王及诸魔众亦复如是。若见菩萨心生怖畏。由彼自念威光下劣。舍离菩萨远至余处。尚不欲闻菩萨之名何况近见。是名菩萨能令惊怖。云何菩萨能令安隐。善男子。譬如有人在于旷野。饥渴困乏险难艰辛迷失方所。见大火聚即往趣之。或遇村落或牧牛处。彼人见已。远离一切所有怖畏心得安隐。有情亦尔。在于生死旷野。险难饥渴困乏迷失正路。见菩萨已远离一切烦恼惊怖心得安隐。是名菩萨能令安隐。云何菩萨能令一切有情共得。善男子。譬如火聚温暖势力。一切有情之所共得。若王王等及旃荼罗子皆共得之。菩萨亦尔。所有恩力一切有情。若王王等及旃荼罗子。皆共得之。是名菩萨能令一切有情共得。云何菩萨能令供养。善男子。譬如火聚能令人间城邑聚落事火婆罗门刹帝利等之所供养。菩萨亦尔。应为世间天人阿素洛等。犹如佛想而皆供养。是名菩萨能令供养。云何菩萨得不轻欺。善男子。如微小火不可轻欺以性能烧故。菩萨亦尔。住解行位初学大乘。虽未能有广大威力。一切世间天人阿素洛等终不轻慢。何以故。世间天龙药叉健达缚阿素洛等。了知菩萨不久坐于菩提道场。当成阿耨多罗三藐三菩提。是名菩萨得不轻欺。善男子。菩萨成就此十种法。得如于火

复次善男子。菩萨成就十种法。等如于风何等为十。一者等于风行无有处所。二者等风所行究竟不尽。三者能得摧破有情我慢山峰。四者能得起于大法云雨。五者能得除灭一切有情烦惑热恼。六者能普施与一切有情等流净法。出息入息活命善巧。七者能持无量大法云雨。八者能得安立最胜大法。一切宫殿种种庄严。九者能于众会决定演说种种妙法。犹如风吹诸劫波树。适意之花如雨而下。十者于阿僧祇劫。积集无量清净法轮。及三摩地解脱总持。于彼大海苏迷卢山。轮围山等之所围绕众会之处。若有众生堪应调伏可成熟者。发智风轮转灭所依一切无余。善男子。云何等于风行无有处所。善男子。譬如风行于一切处无有住着亦无处所。无所依止亦无色相能作自事。谓令一切宫室苏迷卢山及诸海等有所动摇。皆得成办能令他见。菩萨亦复如是。行一切处得无所著。何者是一切处。谓蕴界处。一切法中蕴。谓色蕴受蕴想蕴行蕴识蕴。界谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。处谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。菩萨又于世出世法。一切天人富贵炽盛。转轮圣王。释梵护世大自在天。及声闻缘觉诸地菩萨。乃至一切智中于此诸处得无所著。又能远离非有非无。非一性。非异性。非真实性。非虚妄性等。无量分别之所分别。以无有所缘故。然菩萨所行解脱无碍。复能示现普遍十方无量无边诸世界中。现作释梵护世等身。为欲饶益一切有情行一切处。经于多劫终不可见由离边际故。以法性身远离分别所分别故。善男子。是名菩萨等于风行无有处所。善男子。云何菩萨等风所行究竟不尽。善男子。如风顺行无量世界。能吹诸物速疾回转各有所作。菩萨亦尔。如风触物速疾行于一切方所究竟不尽。谓能行于一切如来道场众会。及诸菩萨道场众会。又于一切世间所有宫室之中。普遍安立宣畅演说。周遍观察世俗胜义无量诸法。是名菩萨等风所行究竟不尽。善男子。云何菩萨能得摧破一切有情我慢山峰。善男子。譬如风吹能令曼陀罗山峰林。低屈摧折堕落菩萨亦尔。如彼风吹能令有情我慢憍醉纵逸峰林摧折堕落。何者名为我慢山峰。谓诸有情。恃己所有色力等相。受用自在长寿无病能得活命。工巧多闻聪明智慧。有胜眷属言辞辩了令众乐闻。由是憍醉自赞。已能菩萨为欲摧破有情我慢山峰故。能示现色力之相受用等事。最胜自在过于彼人。为说正法摧破有情我慢高山。悉能安置清净善处。是名菩萨能得摧破我慢山峰。善男子。云何菩萨能得起于大法云雨。善男子。譬如风力周遍四方发起大云。其云如轮有种种色。雷音远震如海中声。美妙明朗甚深柔软。又出种种音乐歌声能令悦意。电光为鬘庄严晃耀。昼夜恒常而雨大雨。又雨种种诸宝之雨。流霔周遍弥覆百千俱胝那庾多界。令诸有情欢喜悦乐。又令世间一切草木丛林苗稼皆得生长。菩萨亦尔。以大悲为风。发起十方无边世界。种种身相以之为云。所出光明晃耀殊胜色相显现。如彼电鬘光饰严净。为诸有情之所爱乐。出大音声说真实法。犹如雷震美声深远。言辞差别有六万种。以此音声为尽虚空周遍法界一切有情雨大法雨。覆护一切世界有情在于恶趣。及诸无暇受苦之者皆令离苦。复能加持此诸有情。安置一切严净世界。然皆令得最胜喜悦。生安乐心富贵炽盛。令得种种相好圆光。其光清净分明晃耀。又于一切诸法会中。以法雨水灌人天顶。令得最胜欢喜悦乐。成就圆满一切世间。及出世间诸白净法。皆令生长如彼云雨。能令药草丛林苗稼皆得生长。是名菩萨能广发起大法云雨。善男子。云何菩萨能得除灭一切有情烦惑热恼。善男子。如风吹击诸云藏时。周遍流注清净香雨能作清凉。除灭有情一切热恼。菩萨亦尔。大悲为风以正法为水。清净戒香及不空愿香饶益有情。谓亲近菩萨同居之时。若闻说法若见若触皆蒙获益。是名菩萨不空愿香。以此无上和合香水。能令恶趣一切有情贪嗔痴等。邪见恶行贫穷困苦。于其境界所爱乖离非爱和合。起非法贪能生众病。如是热恼皆得销灭。又能置于无忧恼地。是名菩萨能得销灭一切世间烦恼炎热。云何菩萨能普施与一切有情等流净法。出息入息活命善巧。善男子。如因风力有出入息。能令一切有情活命。菩萨亦尔。如彼风力能施一切白净之法。能与种种富贵满足。能令有情各得欢喜

复次善男子。譬如风力广能安立一切世界种种庄严。谓风能持金刚轮等。七宝洲海。轮围山。大轮围山。四大洲渚。苏迷卢山。大苏迷卢山。及余宝山香山雪山。帝释宫殿。赡部洲等。及小千中千大千世界。菩萨亦尔。大悲为风。谓能施与周遍十方一切有情诸福德聚。悉令生长安立成就。如因风力成就雪山。菩萨施与世间福田。应知亦尔。如风成就四大洲渚苏迷卢山等。菩萨成就声闻。应知亦尔。如风能持小千世界。菩萨能成辟支佛果。应知亦尔。如风成立中千世界。如是成立菩萨乘果。当知亦尔。如风成立大千世界。菩萨如是成如来身百福之相。出过一切世间一切世界。甚深清净究竟圆满遍虚空界。闻佛名称一切供养。于一切时安立三摩呬多常住现前。应知亦尔。如风能成诸大海水。菩萨能成三摩地海。应知亦尔。如风成立小中大洲及诸山等。菩萨成就诸陀罗尼。以方便成熟诸弟子众及一切有情。应知亦尔。如风成立帝释宫殿。菩萨能成清净佛刹功德庄严。应知亦尔。如风能成劫波树林。菩萨成就诸地波罗蜜多及三摩地。神通自在诸陀罗尼。三明智光现正等觉力。及无畏不共大悲。于一切法最胜自在。应知亦尔。善男子。何者名为诸佛世尊百福之相。善男子。譬如十方一一方面。如阿僧企耶殑伽河沙世界。其中所有一切有情。一一成就十三千大千世界中所有轮王福德之聚。彼诸有情成就如是福德之聚。总为一聚成一大转轮王福德之量。于其东方过前所说世界数量。复有世界数量如前。其世界中所有众生。一一成就如前所说一大轮王福德之量。如是次第。南西北方四维上下亦复如是。乃至尽彼虚空界中一切世界。所有众生一一成就如前所说一大轮王福德之量。善男子。假使十方一一方面。如阿僧企耶殑伽河沙世界。其中所有一切有情。一一成就十三千大千世界中所有帝释福德之聚。彼诸有情所成如是帝释福德之聚。以此福聚合成一大帝释福德之量。于其东方过前所说世界数量。复有世界数量如前。其世界中所有众生。一一成就如前所说一大帝释福德之量。如是次第南西北方四维上下亦复如是。乃至尽彼虚空界中一切世界所有众生。一一成就如前所说福德之量。善男子。譬如十方一一方面。如阿僧企耶殑伽河沙世界。其中所有一切有情。一一成就十三千大千世界中所有梵王福德之聚。彼诸有情所成如是梵王福德之量总为一聚。以是福聚合成一大梵王福德之量。于其东方过前所说世界数量。复有世界数量如前。其世界中所有众生。一一成就如前所说一大梵王福德之量。如是次第南西北方四维上下。亦复如是。乃至尽彼虚空界中所有众生。一一成就如前所说一大梵王福德之量。善男子。以如是算数世界所有众生成就声闻及辟支佛。证得十地大智光明法云灌顶。成十自在诸大菩萨福聚之量。亦复如是。善男子。总以如是十方三世尽虚空际一切世界所有众生微尘数等。以彼如是一切种类若干有情福德之聚。如是积数满于百倍。成就如来一毛孔中福德之聚。以彼如来一切毛孔福德之聚。如是积数满十阿僧企耶。百千倍数。成就八十随好之中一随好福德之量。以彼一切随好福德。如是积数满十不可说不可说倍。成就如来二十九相。如是积数满十不可说不可说俱胝倍。成就如来眉间白毫之相。其白毫相光明严净。过于圆满清净月轮其量千倍。如是积数满十不可说不可说千俱胝倍。成就如来无观顶相。其无观顶相乌瑟腻沙之所庄严。出过世间所有积数满十不可说不可说俱胝那庾多数百千倍。成就如来梵音声相。其佛所出梵音声相有六万分。任运自在能种种说。词韵和雅一切世间无不等闻。复令众生欢喜满足。善男子。是名诸佛百福之相。善男子。如来以是无尽福智资粮。普遍之所庄严。令一切有情而得受用。善男子。若于十方遍于法界尽虚空性。诸世界中所有众生。悉住第十法云之地。皆得种种殊胜三业之所庄严。于十自在中能得自在。以赡部洲金而为诸器。种种诸宝之所庄严量如虚空。其数等于殑伽河沙。以此宝器盛取如来一毛孔中福德之聚。于一刹那盛取而去。尽未来际盛而复往。如来一毛孔中福德之聚不增不减。善男子。一切如来百福体相不可思议。何者诸地有十二种。一未发菩提心地。二极喜地。三离垢地。四发光地。五焰慧地。六极难胜地。七现前地。八远行地。九不动地。十善慧地。十一法云地。十二普光明佛地。何者是初未发菩提心地。谓此菩萨出过一切愚夫所行灭坏之法。胜于一切三界人天释梵护世声闻缘觉。超过一切世间所得殊胜。三业种种庄严之所庄严。圆光晃耀十方无边一切世界。由精进力一刹那中。于阿僧企耶诸世界中。来而复往无有障碍。于一切世界四大洲中。普现莲花为大光明。宝网庄严以承其足。于千世界中。庄严宝座无量无边。精勤修行毗钵舍那。善能了知一切诸法。于所缘境无有障碍。意所喜乐能现十种广大瑞相。乃至示现阿僧企耶极大瑞相。得不退转来往诸方而无障碍。放不思议大光明网。而能庄严无量佛刹。善巧神变。于不可说诸世界中。示现能作无量无边世界之主。似佛影身为主。自在承受灌顶为大施主。能于一切世出世间。雨于无量法宝光明作大祠曾。如云普遍周匝施与。终无限碍广大庄严。能令见者之所爱乐。随顺一切世间有情意乐满足。又能震动阿僧企耶一切世界往返游行。哀愍无边诸恶趣等一切有情。复能供养无边诸佛。于一切法门悉能受持。又于阿僧企耶诸三摩地。总持解脱神通智明。常能游戏爱乐无边诸法苑乐无所悕望。于无边数俱胝大劫。得无功用离分别喜及增上光明。经于无量俱胝那庾多百千莲花数劫。入于大乘种种修习利他之行。摄取出离福智资粮。由昔行因有无量种。今得增长百千数倍。以此增上最极增上信解法性。于无间时得初地位。此是菩萨未发证性菩提心地。善男子。譬如转轮圣王。已得超过人中色相。而未能得过于诸天净妙色相。菩萨如是。已得超过一切世间声闻辟支佛地。未得胜义菩萨之地

复次普光明佛地者。证离中边无复余垢。于一切法而得自在。一刹那中普遍观察一切有情。获得一切义利之相

复次云何名为诸三摩地。谓诸菩萨证三摩地。有其十种。一涌出宝三摩地。二善住三摩地。三不动三摩地。四不退三摩地。五宝积三摩地。六日光三摩地。七一切义成三摩地。八智炬三摩地。九现在佛前住三摩地。十健行三摩地。是诸菩萨证三摩地。无量无边。以如是等而为上首

复次菩萨。陀罗尼有十二种。一灌顶陀罗尼。二有智者陀罗尼。三音声清净陀罗尼。四无尽箧陀罗尼。五无边旋陀罗尼。六海印陀罗尼。七辩峰陀罗尼。八莲花庄严陀罗尼。九入无著门陀罗尼。十决定入无碍解陀罗尼。十一诸佛庄严神变陀罗尼。十二成就佛身无边色相出现于世陀罗尼。是诸菩萨证陀罗尼。无量无边。以如是等而为上首。云何菩萨六种神通。一天眼智通。二天耳智通。三他心智通。四宿住随念智通。五神境智通。六漏尽智通。云何菩萨十种自在。一命自在。由此寿命经于无量阿僧企耶能持令住。二心自在。由心自在调伏方便。入不可说诸三摩地。能得自在三财自在。由此示现一切世间庄严妙饰。四业自在。能随诸业及于异熟而示现之。五生自在。能于一切世界示现受生。六胜解自在。谓能示现诸佛身相。于诸世界充满令见。七愿自在。谓随于彼非时非刹能现等觉。八神通自在。于一切世界示现无边种种神变。九法自在。谓能于彼离中边法门明了显现。十智自在。谓于一刹那中。遍能了知三世如来。十力无畏无碍解脱。佛不共法诸相随好。复能示现无上等觉。又于一刹那中。能遍了知三世诸佛。一切刹土极微尘数。又能示现起一切智现正等觉。成就种种具足最胜。此是菩萨十种自在。云何菩萨十力。一意乐力。二增上意乐力。三加行力。四般若力。五愿力。六修行力。七乘力。八神通力。九菩提力。十能转法轮力。云何菩萨四无所畏。一闻陀罗尼受持读诵。演说其义得无所畏。二由证无我。不恼乱他及不现恶相。俱生无过守护威仪。三业清净得无所畏。三以般若而为方便。善能通达所受持法常不忘失。又能示现不为放逸。令诸有情出离清净无有障碍得无所畏。四不于余乘而求出离。终不忘失一切智心。能得圆满种种自在。方便利益一切有情得无所畏。是名菩萨四无所畏。云何菩萨十八不共法。一诸菩萨行施不随他教。二持戒不随他教。三修忍不随他教。四精进不随他教。五静虑不随他教。六般若不随他教。七行于摄事能摄一切有情。八能解回向。九方便善巧为主自在。令一切有情有所修行。复能示现于最上乘而得出离。十不退大乘。十一善能示现。于生死涅槃而得安乐。言音善巧能随世俗文同义异。十二智为前导。虽现前起种种受生。而无所作离诸过失。十三具足十善身语意业。十四为摄诸有情恒不舍离。常能忍受一切苦蕴。十五能为示现一切世间之所爱乐。十六虽于众多苦恼愚夫及声闻中住。而不忘失一切智心。如宝坚固清净庄严。十七若受一切法王位时。以缯及水系灌其顶。十八能不舍离诸佛正法示现悕求。是名菩萨十八不共之法

佛说宝雨经卷第四佛说宝雨经卷第五

        唐天竺三藏达摩流支译

善男子。云何名为如来十力。一处非处智力。二去来现在异熟业因要期智力。三种种胜解智力。四种种界智力。五根胜劣智力。六遍趣行智力。七一切静虑解脱三摩地三摩钵底出离杂染清净智力。八宿住随念智力。九生死智力。十漏尽智力。是名如来十种智力。云何如来四无所畏。一诸法现等觉无畏。二一切漏尽智无畏。三障法不虚决定授记无畏。四具足修行证于出离无畏。是名如来四无所畏。云何十八佛不共法。一如来无有误失。二无卒暴音三无忘失念。四无不定心。五无种种想。六无不择舍。七欲无减。八精进无减。九念无减。十定无减。十一慧无减。十二解脱无减。十三于过去世智见无著无碍。十四于未来世智见无著无碍。十五于现在世智见无著无碍。十六一切身业智为前导随智而转。十七一切语业智为前导随智而转。十八一切意业智为前导随智而转。是名十八佛不共法

善男子。云何如来大悲。善男子。如来成就大悲有三十二种。能于十方无量无边一切世界诸有情中。起于种种大悲不可思议。云何。三十二种大悲。一者一切诸法皆无有我。有情不信诸法无我。是故如来为彼有情而起大悲。二者。一切诸法无实有情。众生自谓有实有情。是故如来为诸有情起于大悲。三者一切诸法无实命者。有情谓言有实命者。是故如来为诸有情而起大悲。四者一切诸法无补特伽罗。有情执有补特伽罗。是故如来为诸有情而起大悲。五者一切诸法无实体性。有情执法实有体性。是故如来为诸有情而起大悲。六者一切诸法无实处所。有情执著有实处所。是故如来为诸有情起于大悲。七者一切诸法无实执藏。有情妄执有实执藏。是故如来为诸有情起于大悲。八者一切诸法无我我所。有情执有实我我所。是故如来为彼有情起于大悲。九者一切诸法无实主宰。有情妄执有实主宰。是故如来为诸有情而起大悲。十者一切诸法无实事物。有情妄执有实事物。是故如来为彼有情起于大悲。十一诸法无生。有情妄执诸法有生。是故如来为诸有情而起大悲。十二一切诸法无起无灭。有情妄执有起有灭。是故如来为诸有情而起大悲。十三一切诸法无有杂染。有情妄执实有杂染。是故如来为诸有情而起大悲。十四诸法无贪。有情起贪。是故如来为诸有情而起大悲。十五诸法离嗔有情起嗔。是故如来为诸有情而起大悲。十六诸法离痴。有情起痴。是故如来为诸有情而起大悲。十七一切诸法皆因缘生。自性寂静自性清净。有情妄执有实可得。是故如来为诸有情而起大悲。十八一切诸法无来。而诸有情妄执有来。是故如来为彼有情起于大悲。十九一切诸法无去。而诸有情妄执有去。是故如来为彼有情起于大悲。二十一切诸法无实造作。有情妄执有实造作。是故如来为诸有情而起大悲。二十一一切诸法无有戏论。有情爱乐执有戏论。是故如来为彼有情而起大悲。二十二诸法体空。众生执有。是故如来为诸有情而起大悲。二十三诸法无相。有情妄执而行有相。是故如来为彼有情而起大悲。二十四诸法无愿。有情妄执诸法有愿。是故如来为彼有情而起大悲。二十五此界有情安住世间。由各执着互相诤论起贪嗔痴。观见如是诸有情故。我今当为有情说法。令彼永断贪嗔痴故。是以如来为诸有情起于大悲。二十六谓诸有情安住世间。具足颠倒坠险恶路堕于非处。我应令彼诸有情等入真实路。由是如来为诸有情起于大悲。二十七此界有情恋着世间贪爱所蔽。侵夺他财心无厌足。我应令彼诸有情类得圣法财。谓施戒闻等。是故如来为彼有情而起大悲。二十八一切有情为贪爱驱役耽染舍宅妻子财物诸谷麦等。经求守护。与诸财物而作奴仆。我应为彼演说妙法。观舍宅等毕竟无常不坚之法。是诸有情妄作坚想。是故如来为诸有情起于大悲。二十九此界有情互为欺诳。更相侵夺以恶活命。我为说法令诸有情得清净活命。是故如来为诸有情而起大悲。三十此界有情亲近恶友。得诸供养及赞叹等之所饶益。自谓是我真实知识。我应为彼一切有情真善知识。我应为作毕竟善友。令彼有情众苦息灭。而得究竟安乐涅槃。是故如来为诸有情而起大悲。三十一三界有情在于居家。一向烦劳众苦器中。于一切时爱乐恋着。我应为彼说如是法。令诸有情于三界中而得出离。是故如来为彼有情而起大悲。三十二解脱圣者作如是说。一切诸法由因而生。众缘长养果相滋茂。若诸有情起于懈怠。即为舍离增上殊胜无染正智及最上涅槃。此诸有情虽复希求下劣声闻辟支佛乘。我应为彼说如是法。令诸有情乐广大慧希求佛智。是故如来为诸有情而起大悲。善男子。此是如来所成大悲。有三十二种于有情中起。应知即是菩萨摩诃萨真实福田。威光炽盛具不退者。复能利益一切有情。善男子。一切如来及诸菩萨得自在者。所有功德无量无边阿僧企耶。此百福相而为上首。若诸如来经无量劫。演说如是无量无边诸功德相终不可尽。我今略说。为令有情生喜乐故。是名菩萨摄取有情。清净等流一切诸法。出息入息活命善巧。善男子。云何菩萨能持无量大法云雨。善男子。譬如风轮广大无边。普遍世界坚固不动。于成坏时能持云雨。海及大洲。牟真邻陀山。摩诃牟真邻陀山。轮围山。大轮围山。诸香山等。河林宫室。以彼风轮为所依持。菩萨摩诃萨亦复如是。以无量无边诸陀罗尼而为风轮。发起一切正等觉云。如成劫时安立世界。苏迷卢山。轮围山。大轮围山。香山雪山。海及大洲。河林宫殿。又复流澍大法云雨。能持世间及出世间。无边法蕴百福之相。诸地波罗蜜多。一切三摩地。诸陀罗尼。神通自在力无畏等。及无碍解不共大悲。成就一切佛及菩萨。是名菩萨能持无量大法云雨。善男子。云何菩萨能得安立最胜宫殿种种庄严。善男子。譬如风力周遍安立一切宫殿种种庄严。令诸草木萌牙增长。根茎枝叶花果茂盛。又复能令一切有情支分差别。菩萨如是以无边智。无著智。无碍解智。辩才智。如风布列一切世间及出世间种种具足。复能了知示现施与种种差别。今当略说。谓此诸法能生恶趣及生善趣所生为主。谓此诸法生捺洛迦及以傍生。谓此诸法生琰魔界。或生人天或生释梵护世诸天。谓此诸法所生之处。色相端严人所喜见。聪明智慧及好眷属。又菩萨善巧了知此法。是诸明处种种伎能种种工巧一切色类及诸异论。又能显示有声闻种姓故起声闻乘。有辟支佛种姓故起辟支佛乘。有大乘种姓故起菩萨乘。今当略说。发起种种自利利他殊胜功德。得普贤地及一切智。复能了知此是诸地。此是波罗蜜多。此是诸三摩地。此是诸陀罗尼。此是神通。此是诸明。此是自在。此是解脱。此是诸力。此是无畏。此是无碍解。此是诸佛不共之法。善男子。菩萨以莲花等数。总持善巧。建立如是无量诸法种种庄严。善男子。是名菩萨能得安立最胜大法一切宫殿种种庄严。善男子。云何菩萨能于众会决定演说种种妙法。犹如风吹诸劫波树。于常常时雨适意花如雨而下。善男子。如风吹动诸劫波树。适意之花如雨而下。及诸珍宝庄严之具。衣服饮食种种具足。微风吹动展转出现。遍于天人。众生得已无复忧恼。心生庆悦获增上喜。身心安乐欢娱游戏受法苑乐。于一切时色相端严威力速疾。受诸胜乐而无退减。菩萨亦尔。犹如彼风。于清净世界。请诸如来及诸菩萨。于众会中决定演说相应妙法。雨法宝花如雨而下。谓契经。应颂。记别。讽诵自说缘起。譬喻本事本生。方广希法论议。或上或下。若顺若逆。种种演说。复能示现一切世俗所有言说。于其所缘无我法性寂静清净。演说解释离诸染相。复能显现一切诸法平等法门令有情入。复能示现不可思议如幻诸法。令如幻智之所趣向。复令有情于一切法种种增长。游戏神通欢喜悦乐。但有问答能令知足。离于中边。发起广大善巧神通。由彼常能爱乐法苑。身无疲厌语及意业终不违犯。一切人天威德广大。具足受用一切诸法恒不退减。常起般若明耀观察。趣向增上殊胜之法。是名菩萨能于众会决定演说种种妙法如劫波树于常常时雨适意花如雨而下。善男子。云何菩萨于阿僧祇劫积集无量清净法轮。及三摩地。解脱总持。于彼大海及迷卢山轮围山等之所围绕众会之处。若有众生堪应调伏成熟者中。发智风轮转灭所依一切无余。善男子。譬如劫尽坏世界时。以无碍风力速疾吹坏三千大千世界。百千那庾多。苏迷卢山。轮围山等。及诸大海破坏离散。犹若虚空都无所有。菩萨亦尔。于多劫中积集种种福智资粮之所庄严。能于一切众会之中发智风轮。以速疾神力示现神变。发大音声说诸法蕴无碍法轮。令一切有情所起我慢如山峰者皆得销灭。复能证得胜法光明。毗钵舍那常现在前。如理思惟。一切诸行内心正住三摩呬多诸三摩地皆得具足。破坏离散诸蕴界处。一切诸行不坚之身。了知一切虚妄分别。即能超出一切世间。无有色相不可思议。增长出世福德圆满。复能示现一切色相了知。转得清净所依。尽未来际一切时住。是名菩萨于阿僧祇劫积集无量清净法轮。及三摩地解脱总持。于彼大海及迷卢山轮围山等之所围绕众会之处。若有众生堪应调伏成熟者中。发智风轮转灭所依一切无余。善男子。菩萨成就此十种法等之于风

尔时止盖菩萨白佛言。世尊。说此十种法门。种种具足甚为希有。一切有情悉皆喜足。世尊。若有天人于此法中。能起净信胜解修行。如佛所说。当证具足今世后世。能得释梵所有安乐一向利他

佛告止盖菩萨。善男子。如是如是观彼有情。当得出过一切世间。若有能于是诸法中而修行者。永断一切诸不善法。成就一切清净善法。为诸世间之所归依。若诽谤者是名愚人。堕于恶处受诸苦恼。又为一切世间天人阿素洛等之所轻贱

复次善男子。菩萨成就十种法故等于虚空。何等为十。一者得离于垢。二者得无所著。三者能证寂静。四者证无边般若。五者得无边智。六者于平等法界能随顺行。七者得净胜解信一切法犹若虚空。八者得无所住。九者超过所行。十者超过计度。善男子。菩萨成就此十种法故等于虚空

复次善男子。菩萨成就十种法等于虚空。何等为十。一者于可爱不可爱色中不贪不嗔。二者于爱不爱声中不贪不嗔。三者于爱不爱香中不贪不嗔。四者于爱不爱味中不贪不嗔。五者于爱不爱触中不贪不嗔。六者于爱不爱法中不贪不嗔。七者于利衰中不贪不嗔。八者于毁誉中不贪不嗔。九者于称讥中不贪不嗔。十者于苦乐中不贪不嗔。善男子。菩萨成就此十种法等于虚空

复次善男子。菩萨成就十种法等之于月。何者为十。一者能令一切有情身得悦乐。二者得喜乐见。三者增长白净诸法。四者能断黑闇之法。五者能令称赞。六者得身清净。七者得最上乘。八者常得庄严。九者得爱乐法。十者得大威神及大威德。善男子。云何菩萨令一切有情身得悦乐。善男子。如月出现能作清凉性可爱乐。令诸有情身得悦乐。菩萨亦尔。出现于世能除有情一切热恼性可爱乐。令一切有情身得悦乐。云何菩萨得喜乐见。善男子。如月出现光色鲜洁。令诸有情欢喜乐见。菩萨出现亦复如是。诸根寂静威仪功德清净具足。为一切有情欢喜乐见。云何菩萨能得增长白净诸法。善男子。譬如白月日日增长。乃至圆满种种光色皆得具足。菩萨亦尔。初发心时乃至坐于菩提道场。诸白净法渐渐增长。乃至圆满一切种智。云何菩萨能断一切黑闇之法。善男子。譬如黑月所有光色日日减少。至十五日诸光色相皆不可得。菩萨如是证出世智。诸不善法渐渐除灭。乃至坐于菩提道场一切无有。云何菩萨能令称赞。善男子。如月出现。能使人间城邑聚落诸刹帝利婆罗门等。若男若女悉皆称赞。菩萨如是如月出现。为一切世间天人阿素洛健达缚等悉皆称赞。云何菩萨身得清净。善男子。如月天子业果成就得清净身光色明朗。菩萨如是出现于世。证于法性从法化生。不依父母羯逻蓝等不净所生故。身得清净光色明朗。云何菩萨得最上乘。善男子。如月天子乘最上乘光耀四洲。菩萨如是乘最上乘。智慧光耀无量无边一切世界。云何菩萨常得庄严。善男子。如月天子威德庄严。其庄严具常不萎歇。菩萨如是以功德法常自庄严。云何菩萨得爱乐法。善男子。如月天子于一切时爱乐欲乐。菩萨如月于一切时。爱法苑乐不爱欲乐。云何菩萨得大威神及大威德。善男子。如月天子有大神通及大威德。菩萨亦尔。有大神通及大威德。谓大福性及大智性。善男子。菩萨成就此十种法故等于月

复次善男子。菩萨成就十种法等之于日。何等为十。一者能破一切无明黑闇。二者能调伏有情令得觉悟。三者能光耀十方。四者能出现善法。五者诸漏灭尽。六者能作光明。七者能映蔽一切外道邪论。八者能示现高下。九者起所作业。所谓一切白净善法。十者得善人爱乐。云何菩萨能破一切无明黑闇。善男子。如日出现破诸黑闇。菩萨日出亦复如是。能破一切无明黑闇。云何菩萨调伏有情令得觉悟。善男子。如日出现能令一切莲花开敷。菩萨日出调伏有情令得觉悟。云何菩萨能光耀十方。如日出现光耀十方。菩萨日现以般若威力。光明朗耀于十方界。而不娆乱诸有情等。云何菩萨能出现善法。善男子。如日天子出现之时。于赡部洲光明可得。菩萨出世以智光明现诸善法。云何菩萨诸漏已尽。如日没时于赡部洲名日光隐没。菩萨烦恼得灭尽时。说名永断一切诸漏。云何菩萨能作光明。善男子。如日出现。为赡部洲一切有情作种种光明。菩萨出现。为一切有情放智慧光明。能破愚痴一切闇障。云何菩萨能映蔽一切外道邪论。如日出现能尽映蔽。彼日不念我能映蔽一切无明。然法性如是。菩萨日出能现威光。映蔽外道诸邪异论。菩萨不作如是思惟。我能映蔽诸邪异论。然法性如是。云何菩萨能示高下。善男子。如日出现于赡部洲。高下有情悉能显示。菩萨日现。以智慧光。于等不等有情悉见。谓入诸圣道。说名为等。处于非道。说名不等。云何菩萨起所作业。善男子。如日出现。令一切农夫起所作业。菩萨日现。发起一切善法之业。云何菩萨得善人爱乐。善男子。如日出现。为诸善人之所爱乐。诸恶人类所共憎嫉。菩萨日现聪慧善人之所爱乐。愚夫种类无智恶人。向诸邪道背于涅槃。乐生死者所共憎嫉。善男子。菩萨成就此十种法等之于日

复次善男子。菩萨成就十种法犹如师子。何等为十。一者得不惊怖。二者得无怯惧。三者得不退道。四者如师子吼。五者得无所畏。六者游行园林。七者依止岩窟。八者得无所取。九者势力勇猛能破他军。十者守护一切善法苗稼。云何菩萨得不惊怖。善男子。譬如师子所游行处终无惊怖。自见己身无有等者。菩萨如是所行之处无有惊怖。自见己身无与等者。云何菩萨得无怯惧。善男子。犹如师子闻彼野干诸恶兽声终无怯惧。菩萨如是。能于一切他诤论时终无怯惧。不自沉没亦无倨傲。云何菩萨不退于道。善男子。譬如师子唤使前来。其心终无退避于道。菩萨如是能于一切诤论之处。唤菩萨来心无退屈。云何菩萨如师子吼。善男子。譬如师子哮吼之时。恶兽野干各于方处惊骇驰走。菩萨如是说无上乘如师子吼。能令一切外道野干执我我所诸恶兽等。于诸方所驰走而去。菩萨虽作是师子吼。终不恼乱一切有情。但欲令彼执我我所诸有情类皆令调伏永舍离故。云何菩萨得无所畏。善男子。譬如师子普观诸处得无所畏。菩萨如是。普能观察诸有情界。威仪清净得无所畏。云何菩萨游行园林。譬如师子自性无畏能现威势游诸园林。菩萨如是。自性寂静常能游戏无碍法林。云何菩萨依止岩窟。善男子。譬如师子依据山窟。菩萨如是常能安住智慧岩窟。云何菩萨得无所取。善男子。譬如师子弃舍藏积得无所取。菩萨如是弃舍一切烦恼重担永无所取。云何菩萨如彼师子。性能勇猛有大势力。独一无二能破他军。善男子。菩萨坐于菩提道场。独一无二力能摧破诸魔军众。云何菩萨守护一切善法苗稼。善男子。譬如师子所游行处近于村邑。一切恶兽无能损坏近彼苗稼。菩萨如是所近人间及游行处。一切外道诸恶禽兽。无能损坏善法苗稼。善男子。菩萨成就此十种法得如师子

复次善男子。菩萨成就十种法能善调伏。何等为十。一者菩提心坚固。二者所作能净菩提之心。三者密护诸根。四者能趣向正道。五者能荷重担。六者终无厌倦。七者得于正命利益有情。八者舍离一切矫诈言论。九者永离谄诳。十者自性质直。善男子。菩萨成就此十种法能善调伏

复次善男子。菩萨成就十种法得自性寂静。何等为十。一者得瑜伽师。二者多习空性。三者开发圣道离一切缠无有障碍。四者顺如来教修行无违。五者随顺诸法平等理趣。通达实相游止世间。心常下劣如旃荼罗子。六者于一切时常能起于乞丐之想。远离我慢憍醉放逸。七者于佛法中无有疑惑。于佛正智现前能证。八者于一切法无有犹豫。以自内证知法性故。九者不由他悟自见道故。十者为世福田向菩提故。善男子。菩萨成就此十种法得自性寂静

复次善男子。菩萨成就十种法得如莲花。何等为十。一者无所染着。二者不为少分罪垢所染。三者得妙戒香。四者常得清净。五者面门微笑。六者得不粗犷。七者能现吉祥。八者开发觉悟。九者成熟觉悟。十者为他摄取。云何菩萨无所染着。善男子。譬如莲花从水出现无所染着。何以故。由彼莲花性清净故。菩萨如是虽从生死水中出现既出现已无所染着。何以故。菩萨能证方便般若法自性故。由菩萨善巧处生死中。不为生死过患染着。以方便般若能摄彼故。云何菩萨不为少分罪垢所染。善男子。譬如莲花不为少分水所染污。菩萨如是不为小分罪垢所染。云何菩萨得妙戒香。善男子。如地方所若有能生莲花之处。其香普遍彼彼地方。菩萨如是游行一切人间地方。戒香遍满彼游行处。云何菩萨常得清净。善男子如地方所生莲花处。即为一切世间聚落诸婆罗门刹帝利等。悉皆以彼为清净处。菩萨如是所生之处寂静清净故。常为诸佛护持忆念。及诸菩萨之所称叹。又为天龙药叉健达缚阿素洛紧捺洛莫呼洛伽人非人等皆往趣之。云何菩萨面门微笑。善男子。譬如莲花周遍开敷。一切有情若有见者心皆悦乐。菩萨如是于一切时。和颜微笑。离于颦蹙诸根清净。何菩萨得不粗犷。善男子。譬如莲花。其性柔软而不粗犷。菩萨如是性恒柔软。语无粗犷又无矫诈。云何菩萨能现吉祥。善男子。譬如有人若觉若梦。乃至于一牟呼栗多。若见莲花以为吉祥瑞应之相称扬赞叹。菩萨如是于一切时。若有见者为善吉祥。称扬赞叹为大利益。乃至能得一切智故。云何菩萨开发觉悟。善男子。譬如莲花敷荣之时名为开发。菩萨如是若得般若菩提分花开敷之时说名觉悟。云何菩萨成熟觉悟。善男子。譬如莲花成熟之时。若有见者能令眼根增上悦乐。若有嗅者能令鼻根增上悦乐。若有触者能令身根增上悦乐。若欢喜者能令意根增上悦乐。菩萨如是若得般若光明成就。能令见者眼根清净。能令闻者耳根清净。能令触时及供养者身根清净。能令称扬赞叹功德思惟之者意根清净。云何菩萨为他摄取。善男子。譬如莲花开敷之时。能令一切人及非人之所摄取。菩萨如是所生之处。为一切佛及诸菩萨释梵护世之所摄取。善男子。菩萨成就此十种法得如莲花

佛说宝雨经卷第五佛说宝雨经卷第六

        唐天竺三藏达摩流支译

复次善男子。菩萨成就十种法得广大心。何等为十。一者我当积集一切平等诸波罗蜜多。是名发起广大之心。二者我当圆满一切佛法。是名发起广大之心。三者我当调伏一切有情。是名发起广大之心。四者我当坐于菩提道场于阿耨多罗三藐三菩提而现等觉。是名发起广大之心。五者现等觉已转于法轮。若诸沙门婆罗门。及天魔梵世间人等。一切无能同我转者。是名发起广大之心。六者我为利益一切有情。往于无量无边诸世界中。为彼彼有情作利益事。是名发起广大之心。七者我当积集般若以为船筏。度生死海中一切有情令至彼岸。是名发起广大之心。八者见诸有情无主无归无救无护无有处所。我当为彼而作眷属与彼有情为救护等。是名发起广大之心。九者于一切佛最胜事业。我当示现能作诸佛最胜事业。佛师子吼我当能作大师子吼。佛所游戏我当游戏。大龙观察我当观察。我所得者令诸天魔梵世沙门婆罗门。一切世间天人阿素洛等皆当得之。是名发起广大之心。十者佛大威德调伏有情。我当调伏。不为粗恶行。不为无利苦行。不为下劣行是名发起广大之心。善男子。菩萨成就此十种法得广大心

复次善男子。菩萨成就十种法得清净心。何等为十。一者得圆满意乐。以此意乐性不动故。常安住故。为虚伪故。二者远离不如理作意。谓我当作佛师子吼。终不发起声闻作意。亦不发起缘觉作意。亦不发起少分作意。三者永离一切尘垢。谓能除去诸烦恼尘。四者永离身现矫诈。谓能远离一切矫诈威仪异相。五者永离语言矫诈。终不示现不真实语。六者永离心业矫诈。谓身无所著故。语言知足故。心无悕求故。七者报恩。于少分恩常不忘失。况有多恩而不念报。八者知恩。于有恩者必无隐讳亦不轻贱。见彼有德踊跃欢喜称扬赞叹。除彼世间无惭愧者。九者如言而作。谓诸菩萨示现美言称心相应。心常寂静不怀怨结。尊重于他不生轻慢。实言而说无有矫诈。不为悭吝嫉妒谄诳之所随逐。菩萨终不令他斗战。亦非展转破坏于他。说真实义随利益事而皆与之。十者于如来教中永离诽谤。谓此菩萨发阿耨多罗三藐三菩提心已。剃除须发覆袈裟衣。于如来教中正信出家。非因王力逼令出家。不为盗贼抑令出家。不为负债方便出家。不为惊怖而求出家。非怖不活邪命出家。希求正法以信出家。菩萨常为求善知识亲近承事听闻正法闻已修行。又复菩萨不为我慢之所掩蔽离我慢故。又不颠倒取。以无颠倒领受性故。证通达道得通达故。证于法性得法性故。证法性已决定能得阿耨多罗三藐三菩提。是名菩萨于佛教中离诸诽谤。善男子。菩萨成就此十种法得清净心

复次善男子。菩萨成就十种法得无犹豫心。何等为十。一者深信如来身业秘密。二者深信如来语业秘密。三者深信如来意业秘密。四者深信菩萨积集。五者深信菩提。六者能信如来出现。七者能信演说一乘实相。八者能信宣说种种实相。九者能信如来言音深远。十者深信如来知有情意乐而调伏之。云何菩萨深信如来身业秘密。善男子。谓诸菩萨若闻如来法身之性寂静身性。无等身性。无量身性。不共身性。金刚身性作是思惟此为真实。非是虚诳。谓此菩萨于彼法中心无犹豫。是名菩萨深信如来身业秘密。云何菩萨深信如来语业秘密。谓诸菩萨闻于如来为诸有情现前授记不现前授记。秘密记已。菩萨如是思惟。如来言音。终无虚诳得无误失。由此因缘语得真实。何以故。由如来永断一切遇患故。永断一切诸尘垢故。永断一切诸热恼故。永无一切诸烦恼故。能得自在皎洁澄清无诸秽浊。若如来之言有虚诳误犯无容是处。惟此真实非为虚诳。菩萨于此法中得无犹豫。是名菩萨深信如来语业秘密。云何菩萨深信如来意业秘密。若诸菩萨闻于如来意之秘密。谓如来所有意乐法义。依止于心依心而住。一切菩萨声闻缘觉。及诸有情无能知者。惟除如来之所加持何以故。如来甚深难可度量。超过计度及计度所行。广大无量犹若虚空。超越一切虚妄计者所有境界。菩萨如是正思惟。此是真实非为虚诳。于彼法中得无犹豫。是名菩萨深信如来意业秘密。云何深信菩萨积集。谓闻诸菩萨现前利益一切有情。是诸有情所作之事。皆能作之终无疲倦亦不惊怖。复能荷负大愿重担。有大势力勇猛坚固。遍能积集诸波罗蜜多。次第积集一切佛法得无碍智。无边智性。无等智性。不共智性。精进坚固。被甲坚固。誓愿坚固誓愿不动誓愿不共。以为无上菩提因缘。是诸菩萨次第修习。令生增长圆满广大。菩萨如是思惟。此为真实非是虚诳。菩萨于彼诸法之中得无犹豫。是名菩萨能得深信积集。云何菩萨深信菩提及如来出现。谓诸菩萨如是思惟。闻诸菩萨坐菩提道场已。无著无碍无障。得天眼智通。天耳智通。他心智通。宿住随念智通。神境智通。漏尽智通。成就胜智。一一刹那了达三世。无著无碍无障。由是因缘能遍观察诸有情界。此类有情成就身恶行。成就语恶行。成就意恶行。受诸邪法。起于邪见诽谤圣者。由是因缘身坏命终。堕诸恶趣生捺落迦中。复能观察如是有情。成就身善行。成就语善行。成就意善行。领受正法。起于正见。不谤圣者。以是因缘命终之后。生诸善趣得生天中。菩萨如是能实观察诸有情界善不善业已作是思惟。我于往昔行菩萨行有如是愿。若自觉悟令他觉悟。我愿既满意乐亦足。惟此真实非是虚妄。菩萨能于彼法之中得无犹豫。由是菩萨能证菩提名为正觉。善男子。是名菩萨深信菩提及如来出现。云何菩萨深信演说一乘实相。谓诸菩萨如是思惟。闻于如来一乘法已。唯此真实非是虚妄。恒不变易。何以故。由从一乘出诸乘故。善男子。譬如赡部洲中有诸小洲。虽各异名然彼同依于赡部洲。由是说名一赡部洲。所说一乘亦复如是。由如来乘出现诸乘。而诸乘等虽有异名。然同依止如来乘故说名一乘。菩萨能于彼正法中得无犹豫。是名菩萨深信演说一乘实相。云何菩萨能深信演说种种实相。谓诸菩萨如是思惟。闻于如来素怛缆中宣说如是种种实相已。唯此真实非为虚诳。何以故。由诸如来能调伏故。随诸有情种种胜解演说妙法。菩萨于此正法之中能无犹豫。是名菩萨能深信演说种种实相。云何菩萨得深信如来言音深远。谓诸菩萨如是思惟。闻于如来言音深远已。唯此真实非为虚诳。何以故。以诸天子少福善根。尚得深远美妙音声。何况如来以于无量百千数劫积集妙行。由是菩萨于彼法中得无犹豫。是名菩萨深信如来言音深远。云何菩萨得深信如来知有情意乐而调伏之。谓诸菩萨如是思惟。闻于如来能知一切有情意乐。种种随眠种种胜解。一音说法皆令调伏。各随意解断除疑惑成熟有情。一一有情如是思惟。各谓如来独为我故演说妙法。如来于此实无分别。我为能说有情为所化。惟此真实非为虚妄。菩萨能于彼法之中得无犹豫。是名菩萨深信如来知有情意乐而调伏之。善男子。菩萨成就此十种法心无犹豫

复次善男子。菩萨成就十种法得智如海。何等为十。一者得如宝所。二者甚深难度。三者广大无量。四者随顺渐深。五者不与烦恼死尸同住。六者皆同一味。七者容受驶流。八者潮不过时。九者与大有情为所依止。十者无有穷尽。云何菩萨得如宝所。善男子。譬如大海有诸宝所。赡部洲人皆来取宝终无穷尽。菩萨如是有功德宝所。一切有情取功德宝亦无穷尽。云何菩萨甚深难度。善男子。譬如大海甚深难度。菩萨如是成就智慧甚深大海。一切有情无能越度。云何菩萨广大无量。善男子。譬如大海周遍广大。菩萨如是智慧之海广大无边。云何菩萨随顺渐深。善男子。譬如大海随顺向下渐低渐深。菩萨如是一切智海随顺法性渐低渐深。云何菩萨不与烦恼死尸同住。善男子。譬如大海不宿死尸。何以故。以海性法尔故。菩萨如是不与烦恼死尸丈夫同处而住。何以故。以菩萨法如是故。云何菩萨皆同一味。善男子。譬如大海诸瀑流水澍入之者。一切皆同一碱味性。菩萨如是积集无量白净之法。至一切智皆得同于一切智味。云何菩萨容受驶流。善男子。譬如大海容受无量诸驶流水而无增减。菩萨如是容受无量法雨驶流无增无减。云何菩萨潮不失时。善男子。譬如大海潮不失时。菩萨如是教化有情随其根性不失于时。云何菩萨与大有情为所依止。譬如大海与大有情为所依止。菩萨如是为一切有情诸白净法之所依止。云何菩萨得无穷尽。善男子。譬如大海为一切有情汲引其水无有穷尽。菩萨如是为诸有情种种说法无有穷尽。善男子。菩萨成就此十种法得智如海

复次善男子。菩萨成就十种法得微妙智善巧。何等为十。一者得希求出离善巧。二者得通达一切法善巧。三者得悟入一切法平等善巧。四者得悟入一切法幻相善巧。五者得遍知一切法善巧。六者得缘起甚深难度善巧。七者得业不思议善巧。八者得了知随所说义善巧。九者得证知如实义善巧。十者得真实善巧。善男子。云何菩萨得希求出离善巧。乃至云何得真实善巧。谓此菩萨观察如是一切有情处于世间。常为贪欲之所烧然。嗔恚之所昏绕。愚痴黑暗之所盲冥。菩萨作是思惟。此诸有情云何能得出离善巧。菩萨为彼希求通达诸法。以通达故悟入一切诸法平等。以悟入故了知虚幻之相。以了知故如实遍知一切诸法。以遍知故随顺思惟甚深缘起。以思惟故随顺观业不思议性。菩萨作如是观。一切法中都无有实。而业有种种异。由是菩萨即能悟入微妙智慧。而于诸佛及菩萨所。闻说法要即了其义。以了义故得见真实。见真实故于生死海中度脱有情。善男子。是名菩萨得希求出离善巧。乃至得真实善巧。善男子。菩萨成就此十种法得微妙智

复次善男子。菩萨成就十种法得应辩才。何等为十。一者于诸法中施设无我。二者无有情。三者无命者。四者无养育者。五者无补特伽罗。六者远离作者受者。七者远离知者见者。八者空无所有无主。九者虚妄分别空。十者一切诸法施设缘生。善男子。以一切诸法无我无有情无命者无养育者无补特伽罗远离作者受者。远离知见者空无所有无主。虚妄分别从缘所生。如是此应随顺法性。善男子。所有应随顺法性。不相违法性。相应法性。悟入法性。明了法性。如是法性菩萨摩诃萨皆应遍知。是名应辩。善男子。菩萨成就此十种法得应辩才

复次善男子。菩萨成就十种法得解脱辩。何等为十。一者得无著辩。二者得无尽辩。三者得觉悟辩。四者得不怯弱辩。五者得谦卑辩。六者得无畏辩。七者得不共辩。八者得无蔽辩。九者得无边辩。十者得无碍辩。善男子。菩萨摩诃萨成就此十种法得解脱辩才

复次善男子。菩萨成就十种法得清净辩才。何等为十。一者得无[斯/瓦]嗄辩。二者得不杂乱辩。三者得不下劣辩。四者得不倨傲辩。五者得义不退失辩。六者得文字不下劣辩。七者得方便不下劣辩。八者得时不下劣辩。九者得不粗犷辩。十者得明了辩。善男子。菩萨摩诃萨于众会中远离怖畏故。得无[斯/瓦]嗄辩才。安住智慧故得不杂乱辩才。菩萨于众会中无所畏故。如师子王不惊不怖。得不下劣辩才。无烦恼故得不倨傲辩才。善男子。有烦恼者即有倨傲。非无烦恼有倨傲也。证法性故得于义不退失辩才。善男子。未证法者于义有失。非已得者有退失也。于一切言论无所畏故。得文字不下劣辩才。善男子。知少分论者而于文字即有退失。非知一切论者名下劣也。积集诸方便故得方便不下劣辩才。无善巧者而于方便即有退失。有善巧者无下劣也。善男子。菩萨摩诃萨。知长时。知应时。知初中后时。非先说后。非后说先。应时而说故得时不下劣辩才。永离语言戏论故得无粗犷辩才。善男子。以有戏论名为粗犷。无戏论者非粗犷也。善男子。菩萨摩诃萨诸根聪利故得明了辩才。诸根钝者即不明了。非根利者不明了也。善男子。菩萨成就此十种法得清净辩才

复次善男子。菩萨成就十种法得一切众生欢喜满足。何等为十。一者得可爱语。二者面门微笑远离颦蹙。三者能演说义。四者能演说法。五者能平等说。六者无有贡高。七者远离轻贱。八者无染。九者不嗔。十者得种种辩才。善男子。云何得爱语。菩萨言辞能令有情心喜悦故。云何面门微笑。菩萨和颜安慰能令有情得安隐故。云何能演说义。菩萨言辞应量说故。云何能演说法。菩萨凡所演说饶益有情故。云何平等说。菩萨恒以等心授有情法故。云何无有贡高。菩萨远离我慢憍逸同类性故。云何远离轻贱。菩萨说法尊重法故。云何无染。菩萨尸罗极清净故。云何不嗔。菩萨性能行忍辱故。云何得种种辩才。菩萨言辞美妙悦众生故。善男子。菩萨成就此十种法。能令有情欢喜满足

复次善男子。菩萨成就十种法。能令有情领受所说。何等为十。一不为非器者说法。二不为嗔害者说法。三不为增上慢者说法。四不为外道说法。五不为不生尊重者说法。六不为无净信者说法。七不为谄诳者说法。八不为爱乐活命者说法。九不为规求利养得他尊重嫉妒悭吝所缠者说法。十不为顽钝喑哑者说法。何以故。菩萨摩诃萨不以悭吝法故。而不为说亦不为师。奉秘而不说。亦不为有情轻于我故。亦不为弃舍法故。但以非法器故而不为说。止盖菩萨白佛言。世尊。何等有情诸佛菩萨为之说法。佛言。善男子。若诸有情具足信根。成熟法器承事诸佛。心无谄曲亦无虚诳。威仪无诈不贪利养。意乐具足为善丈夫。闻法觉悟善能开晓。聪慧利根随所说义即能了知。为得法故勤修精进。顺如来法依教修行。善男子。如是种类诸有情等。佛及菩萨为之演说。善男子。菩萨成就此十种法。即能领受所说之法

复次善男子。菩萨成就十种法能为说法之师。何等为十。一者为积集佛法故能演说法。然佛法不可得。积集亦不可得。二者为积集诸波罗蜜多故演说法。波罗蜜多不可得。积集亦不可得。三者为积集菩提故演说法。然菩提不可得。积集亦不可得。四者为断烦恼故演说法。然烦恼不可得。断亦不可得。五者为厌贪离贪灭贪故演说法。然厌离灭及贪俱不可得。六者为得预流一来不还向果故演说法。然预流一来不还向果俱不可得。七者为得阿罗汉向果故演说法。然阿罗汉向果俱不可得。八者为得缘觉向缘觉果故演说法。然缘觉向果俱不可得。九者为永断执着我故演说法。然我与执着俱不可得。十者为显示业及异熟故演说法。而业及异熟俱不可得。何以故。彼诸菩萨作是思惟。由彼名字故说有法。其所说法本不可得。所以者何。法非文字文字非法。但于俗谛法中顺世俗故。于无名法中施设其名。胜义谛中无有名字。但是虚妄施设假立作其名字。诱引愚夫故作是说。善男子。菩萨成就此十种法故能为说法师

复次善男子。菩萨成就十种法。得随法性行。何等为十。一者菩萨随法性行不离于色亦不离受想行识。二者随法性行不离欲界。三者随法性行不离色界。四者随法性行不离无色界。五者随法性行不舍于法。六者随法性行不执着于法。七者随法性行而不舍于有情。八者随法性行而不行于断见。九者随法性行而不行于常见。十者随法性行而不舍于正道。所以者何。菩萨成就般若方便善巧故。虽随顺法性然于色等不舍不着亦不行。善男子。菩萨成就此十种法得随法性行

复次善男子。菩萨成就十种法。得法界善巧。何等为十。一者有智慧。二者摄取善知识。三者勤行精进。四者离一切障。五者极清净。六者尊重教诫。七者多修空性。八者离诸慢见。九者向于道。十者见真实义。善男子。菩萨摩诃萨。有智慧者求善知识。见善知识故得欢喜悦乐。于善知识生如佛想依止彼住。依止彼故得勤行精进。永断一切不善法。圆满一切善法。以勤修精进故。灭除一切障得无障碍。开示正道远离身口意粗重。由离障故得最极清净。既清净已得尊重教诫。得教诫已能多修行空性。修行空已即得远离骜慢之见。远离骜慢见已得向正道。菩萨得住道已见于真义。止盖菩萨白佛言。世尊。云何名真义。佛言。善男子。真义者即是实义增语。止盖菩萨白佛言。世尊。云何名实义。佛言。善男子。所谓不虚妄是实义。止盖菩萨白佛言。世尊。云何名不虚妄。佛言。善男子。所谓真如是不虚妄无别异也。止盖菩萨白佛言。世尊。何谓真如。佛言。善男子。此法自内所证。非有文字能施设之。何以故。此法超过一切文字言说及戏论故。离诸入出无有计度。非计所行无相离相。非诸愚夫所行之处。远离一切诸魔境界。及以一切烦恼境界。非识所行住无所住自性寂静。超过众圣智之所入。由是因缘自内所证无垢无染。清净微妙最上无比。恒常不动性不灭坏。若诸如来出现于世若不出世如是法界自性常住。善男子。为利益故是诸菩萨勇猛修行无量苦行证此法性。得法性已安置有情住如是法。善男子。如是名为真如。亦名实际。名一切智。亦名一切种智。名不思议界。亦名不二界。止盖菩萨白佛言。世尊。云何于此法中现证。云何自内所证。佛言。善男子。应以出世间般若自内所证。止盖菩萨白佛言。世尊。若如是者。般若现证即是自内证耶。佛言。不也。善男子。般若如实观见法身为内证也。止盖菩萨白佛言。世尊。若以闻所成慧思所成慧。如是证法为内证乎。佛言。不也。终不但以闻所成慧思所成慧为内证也。善男子。以是因缘我当为汝说于譬喻。譬若有人热际之余在于旷野。从东方来将诣西方。复有一人从西方来往于东方。其人热乏为渴所逼。语东方人言。我今热乏为渴所逼请示我路。何处应有泉林池沼清净冷水。我若得之热恼渴乏皆得止息。从东来人语西来者作如是言。我谙道路知有水处我经尝饮。从是东行去此不远便有二道。应舍左路趣于右道。若见青山彼有林泉清净冷水能解渴乏。汝可往彼必得舍除热渴之患。善男子。于意云何。彼热渴人唯闻水名但思水事。即得除其热渴患不。止盖菩萨白佛言。世尊。彼热渴人。要当内证清凉之水。然后除其热渴之患。善男子。如是如是。非但闻思即能证得。自内所证真如之法。善男子。言旷野者即是生死。言热渴者即是一切有情于境界中。为烦恼热之所渴乏。示道路者即是诸佛菩萨善知识也。经自尝饮者即是善巧。能知一切智道自内所证胜法性也

复次善男子。我今更说譬喻晓悟于汝。假使如来住世一劫。为赡部洲人赞叹诸天所食。甘露色香美味清净微妙。若触彼时受其安乐。于意云何。然彼有情闻是语已。即得如是自内所证甘露味不。止盖菩萨白佛言。不也世尊。彼人虽闻佛说甘露终不能得甘露之味。佛言。善男子。汝于此喻应如是知。非唯闻思即能得彼自内所证。善男子。譬如有人食美果已。于未食人前赞叹其果香味具足。于意云何。彼未食人能得内证知其味不。不也世尊。佛言。善男子。彼亦如是。汝于此喻应如是知。非唯闻思即能证得自内所证。如是说已。止盖菩萨白佛言。世尊。甚为希有。如来今者善能为我说斯法要。若有得闻如是法门应当证得。何以故。世尊。彼善男子。得此法因决定当得此法性故。佛言。如是如是。既知因已当得此法善男子。菩萨成就此十种法。得法界善巧

佛说宝雨经卷第六佛说宝雨经卷第七

        唐天竺三藏达摩流支译

复次善男子。菩萨成就十种法而得空性。何等为十。一者能知力空性。二者能知无畏空性。三者能知不共法空性。四者能知戒蕴空性。五者能知三摩地空性。六者能知般若空性。七者能知解脱蕴空性。八者能知解脱智见蕴空性。九者能知空空性。十者能知胜义空性菩萨虽行于空而不为断。复不执空。亦不见空性。亦不依空性。亦不入于无所有性。善男子。菩萨成就此十种法而行于空

复次善男子。菩萨成就十种法得无相行。何等为十。一者远离外相。二者远离内相。三者远离戏论相。四者远离分别相。五者远离有所得相。六者远离所作事相。七者远离所行相。八者远离所缘相。九者能知识不可得相。十者所知事物不可得相。善男子。菩萨成就此十种法得无相行

尔时止盖菩萨白佛言。世尊。如是十种法菩萨应学。云何当学。佛言。善男子。佛所行处不可思量。以彼远离思量境界性故。善男子。若诸有情思惟如来法性境界。心即迷闷终不能睹法性。此岸彼岸但生劬劳。何以故。如来境界不可思议甚深难测。超过一切虚妄计度所有境界。超过一切有所得者所有境界。以是义故非彼虚妄计者思惟度量。止盖菩萨白佛言。世尊。我今欲有少问。惟愿如来哀许我请为我解说。佛言。善男子。一切诸佛皆许疑问。随汝所欲当为解说。止盖菩萨白佛言。世尊。夫自赞者非正士法。云何如来自赞所行之境超过一切。佛言。善哉善哉。善男子。谛听谛听当为汝说。善男子。如来不为我慢贡高贪着利养。承事给侍名闻识知。恐他映蔽而自赞叹。善男子。如来无矫无诈言不谀谄。唯除利益一切有情。获安乐故。证法性故。于如来所发净信心。欢喜悦乐当成法器。复能演说饶益有情。止盖菩萨白佛言。世尊。一切有情可不能知如来功德威力。今者如来须自赞耶。佛言。善男子。此土众生信根薄少智力下劣。而不能知如来功德及以威力。是故如来自赞令知。譬如医师善知方药能疗众病。医所住处多有病疾。更无余医能疗治者。尔时医师作是念言。此诸人等病苦所逼。而于良药既不能知。亦不知我能除其病。是时医师于病者前而自赞言。我能识病亦善知药。尔时病人既已识知。彼是良医深生敬信。依之将养所有病苦皆得除愈。善男子。于意云何。如彼医师亦得名为自赞以不。止盖菩萨言。不也世尊。佛言。善男子。如是如是。诸佛如来为无有上为大医王。善知有情烦恼病因能与法药。然诸有情不能了知。诸佛如来善除其病。尔时诸佛便自赞叹功德威力。众生闻已深起敬信。依止如来除烦恼病。如来尔时为大医王施大法药。令烦恼病皆得除愈。何等名为大法药也。大法药者所谓不净观慈缘起等。善男子。由是因缘如来遍观而自赞叹

复次善男子。菩萨成就十种法。远离一切依止愿。何等为十。一者不依布施有所悕求。二者不依持戒有所悕求。三者不依忍辱有所悕求。四者不依精进有所悕求。五者不依静虑有所悕求。六者不依般若有所悕求。七者不依三界有所悕求。八者不依菩提有所悕求。九者不依正道有所悕求。十者不依涅槃有所悕求。何以故。以诸菩萨远离一切依止相故。善男子。菩萨摩诃萨无所依止故而能游行一切世间。善男子。菩萨成就此十种法。即能远离一切依止愿

复次善男子。菩萨成就十种法而行于慈。何等为十。一者无方所慈。二者无差别慈。三者得诸法慈。四者得决定思惟一缘之慈。五者无滞碍慈。六者恒利益慈。七者于一切有情心平等慈。八者无损害慈。九者遍一切慈。十者出世间慈。善男子。菩萨成就此十种法。是名修慈自性

复次善男子。菩萨成就十种法而行于悲。何等为十。一者见诸有情无归无护受苦恼者。即起哀愍发菩提心。二者发菩提心已勇猛精进速入法性。三者入法性已饶益有情。四者为悭吝有情令其布施。五者为毁禁有情令其持戒。六者为嗔害有情令其忍辱。七者为懈怠有情令其精进。八者为散乱有情令其静虑。九者为恶慧有情令其智慧。十者虽为有情受诸苦恼志必拔济无有疲厌。于大菩提终不退转。善男子。菩萨成就此十种法。是名修悲自性

复次善男子。菩萨成就十种法而行于喜。何等为十。一者我得出离诸有牢狱猛火炽然。如是生喜。二者我能断除久远相续生死之缚。如是生喜。三者我已能度种种寻伺邪执杂乱生死大海。如是生喜。四者我能倾折憍慢久远之幢。如是生喜。五者我能以金刚智破烦恼山。乃至无有如微尘许。如是生喜。六者我今自既安隐。亦复能令他得安隐。如是生喜。七者我于长夜睡眠之中而得觉寤。亦能令他于长夜中为爱绳所缚痴盖所覆盲冥有情。皆令觉寤。如是生喜。八者我于一切恶趣既得解脱。亦能令他而得解脱。如是生喜。九者我于长夜生死旷远。困乏饥渴独行无伴流转无穷。不识正道不知方所。既能识道复能示道。如是生喜。十者我今能向一切智城。如是生喜。善男子。菩萨成就此十种法是名修喜

复次善男子。菩萨成就十种法而能行舍。何等为十。一者于眼所见色中得舍行故。二者于耳所闻声中得舍行故。三者于鼻所嗅香中得舍行故。四者于舌所尝味中得舍行故。五者于身所受触中得舍行故。六者于意所知法中得舍行故。作是行时于色等境不恼坏不损害不灭尽。七者于苦苦中得舍行故。八者于坏苦中得舍行故。九者于行苦中得舍行故。作是行时于苦苦坏苦行苦性中。不恼坏不损害不灭尽。十者于所作已办有情中得舍行故。发欢喜净信悦乐之心。作是思惟。彼诸有情虽已自度。我当令彼而得度脱行于舍心。善男子。菩萨成就此十种法。是名修舍

复次善男子。菩萨成就十种法。得游戏神通。何等为十。一者示现隐没。二者示现受生。三者示现少年游戏后宫。四者示现出家。五者示现苦行。六者示现往于菩提道场。七者示现降伏众魔。八者示现成等正觉。九者示现转正法轮。十者示现大般涅槃

尔时止盖菩萨白佛言。世尊。何因缘故诸大菩萨。于睹史多天宫示现灭没。乃至示现入大涅槃。佛言。善男子。菩萨于睹史多天最尊最胜。超过一切世间诸欲境界而无染着。为有情故示现隐没。有情见已舍离常想起无常想。以彼无常为依止故得不放逸善男子。彼诸有情未离放逸。虽于菩萨生净信心。然由耽嗜诸欲境界。未能承事供养菩萨。作是思惟。菩萨与我长时在世。我等于后往菩萨所。承事供养而不晚也。为令如是有情起恋慕心舍于放逸现隐没耳。而彼有情观无常已不复放逸。当得阿耨多罗三藐三菩提。善男子。若有众生应处母胎而调伏者。菩萨即处母胎中。现其功德威神希有之事。为说种种微妙之法。众生闻已当得阿耨多罗三藐三菩提。善男子。若诸有情应见菩萨为童子时。后宫游戏而调伏者。菩萨令彼有情得成熟故。亦为守护下劣有情少信根者。现为童子宫中游戏。善男子。若诸有情应见菩萨出家而成熟者。菩萨为欲令其得成熟故示现出家。善男子。若天龙药又健闼缚应以苦行得调伏者。菩萨为化彼故。及为降伏诸外道故示现苦行。善男子。若诸有情长夜悕求发如是愿。菩萨若诣菩提道场。我当往彼勤修供养。菩萨为如是等诸有情故。示现往诣菩提道场。为令有情随顺供养。决定当得阿耨多罗三藐三菩提。善男子。若诸有情我慢贡高憍奢纵逸。为欲令彼舍离如是烦恼事故。降诸魔故。而能示现坐于道场。若诸有情乐寂静者。菩萨为令毕竟证得最胜最高殊胜法故。示坐道场成等正觉。是故菩萨现正觉已。三千大千世界。悉皆寂静无复众声。彼诸有情见斯事已。咸作是言。愿我未来证菩提时。亦如菩萨坐于道场成等正觉。善男子。若诸有情以彼邪师。为一切智受于邪法。此世他世不能出离成等正觉。菩萨为欲降伏彼故。及为善根成熟故。复有众生堪为法器堪示道故。菩萨即现成等正觉。往彼波罗痆斯城。示现三转十二行法轮。善男子。若诸有情宜闻涅槃而调伏者。菩萨即现大般涅槃而调伏之。善男子。以是因缘菩萨于睹史多天最胜宫中。示现隐没乃至示现大般涅槃。善男子。菩萨成就此十种法得游戏神通

复次善男子。菩萨成就十种法能离八无暇。何等为十。一者舍离不善法。二者于如来所说学处终不违越。三者远离悭贪。四者已曾供养诸佛如来。五者勤修福业。六者智慧圆满。七者得方便善巧。八者本愿具足。九者厌离世法。十者勤行精进。善男子。菩萨以离众恶业故不堕地狱。诸有情等生地狱中者。为无量苦之所逼恼生嗔恚心。菩萨不尔。十善业道性成就故。终不生于地狱之中。善男子。菩萨于如来学处不违越故。不堕畜生趣中。生其中者极受炽盛无量苦恼。善男子。菩萨不悭贪故不生饿鬼之中。生其中者极受炽盛饥饿苦恼。善男子。菩萨已曾承事供养诸佛如来故。而不生于邪见之家。若生其中诸缘不具。与善知识不得和合。是故菩萨不生其中。遇善知识修行善法。由是得生正见之家诸缘具足。增长广大殊胜善根善男子。菩萨诸根终无缺减。若缺减者于佛法中即非法器。然菩萨以积集福业故。于佛法僧及制多所承事供养故。得诸根具足堪为法器善男子。菩萨不生边地。何以故。边地之人顽嚚愚憃犹如哑羊。如是等类于善恶言义不能了知。不孝父母不敬沙门婆罗门。是故菩萨常生中国。利根智慧聪悟明达。于佛法中堪为法器。善男子。菩萨不于长寿天生。若生其中不得值遇无量诸佛出现于世不得道果无能利益。是故菩萨生于欲界遇佛出现。承事供养成熟众生。所以者何。以能得彼巧方便故。善男子。菩萨不生无佛世界。其中无佛法僧而应供养。常生具足三宝佛土之中。所以者何。以诸菩萨具本愿故。善男子。菩萨闻是无暇之处深生厌离。随如是类得厌离已。勤修精进获诸善法。永断一切诸不善法。善男子。菩萨成就此十种法远离八无暇

复次善男子。菩萨成就十种法。得不退转菩提之心。何等为十。一者远离虚诳谄曲。二者质直清净离诸疑惑。三者远离师奉。四者远离法悭。五者不作灭法因缘。六者如说而行终不虚诳。七者摄取大乘。八者于大乘人常生尊重同法想故。九者得趣向大乘随顺悟入。十者于说法师作善知识想。善男子。菩萨成就此十种法。即得不退菩提心

复次善男子。菩萨成就十种法。得宿住随念智。何等为十。一者承事诸佛。二者摄受正法。三者持戒清净。四者无有恶作。五者得无障碍。六者欢喜无量。七者得多修行。八者得三摩呬多。九者得化生。十者得识无愚痴。善男子。菩萨承事无量诸佛故得尊重正法。于诸正法受持读诵为他广说。不顾身命勤修正法故得尸罗。所谓身语意戒皆得清净。由戒清净故得无恶作。无恶作故得无障碍。由无障碍故得欢喜无量。欢喜无量故得多修行。多修行故得三摩地。得三摩地故能趣清净。趣清净故恒得化生。得化生故识无愚痴。识无愚痴故得忆念生智。由是能随忆念多生。一生二生乃至无量百千生善男子。菩萨成就此十种法。得宿住随念智

复次善男子。菩萨成就十种法。不离善知识。何等为十。一者见佛闻佛念佛。二者听闻正法。三者承事众僧。四者不离诸佛菩萨问讯起居。五者常近多闻说法之师。六者常得听闻诸波罗蜜。七者恒闻菩提分法。八者恒闻三解脱门。九者恒闻四梵行。十者恒闻一切智性。善男子。菩萨成就此十种法亲近善知识

复次善男子。菩萨成就十种法远离恶知识。何等为十。一者远离毁禁补特伽罗。二者远离破见补特伽罗。三者远离坏威仪补特伽罗。四者远离邪命补特伽罗。五者远离习近愦闹补特伽罗。六者远离懈怠补特伽罗。七者远离耽着生死补特伽罗。八者远离违背正觉补特伽罗。九者远离爱着家业补特伽罗。十者远离一切烦恼。善男子。菩萨虽复远离如是诸恶知识。然于彼处不起损害轻贱之心。菩萨应发如是之心。由佛说言。若与杂乱众生而相染习。便即为彼之所破坏。是故我应远离如是诸杂乱处。善男子。菩萨成就此十种法远离恶知识

复次善男子。菩萨成就十种法得法性身。何等为十。一者得平等身。二者得清净身。三者得无尽身。四者得积集身。五者得法身。六者得甚深难测不可计度身。七者得不可思议身。八者得寂静身。九者得等虚空身。十者得智身。善男子。菩萨成就此十种法得如来法性身。止盖菩萨言。世尊。诸菩萨等于何位中。得证如来法性之身。佛言。善男子。初地菩萨得平等身。何以故。以永离一切不平等故悟入一切菩萨平等法性故。二地菩萨得清净身。以尸罗清净故。三地菩萨得无尽身。以永离一切嗔害故。四地菩萨得善积集身。以积集佛法故。五地菩萨证得法身。以能通达一切法故。六地菩萨得不可计度甚深难测身。以积集不可计度甚深难测法故。七地菩萨得不可思议身。以积集不思议佛法。及能积集方便善巧故。八地菩萨得寂静身。以远离一切戏论及烦恼故。九地菩萨得等虚空身。以无边身充满故。十地菩萨证得智身。以积集一切智故。止盖菩萨言。世尊。如来法身与菩萨法身有何差别。佛言。善男子。二种法身性无差别。功德威力而有差别。止盖菩萨白佛言。世尊。云何性无差别而有差别。佛言。善男子。佛与菩萨法性无差别。何以故。此二种身同一性故。但功德威力有差别耳。止盖菩萨白佛言。世尊。佛与菩萨功德威力云何应知有其差别。佛言。善男子。我今为汝广说譬喻以明斯义。善男子。如末尼珠有莹拭者有未莹者。虽同是宝。而已莹者光明具足人所爱乐。未已莹者所有光明犹不具足。善男子。如来珠宝与菩萨珠宝。体性虽同然亦有异。何以故。如来珠宝已清净故。离一切垢故。菩萨身中法性珠宝。未能普照一切世界。何以故。以有余故。犹有垢故。如末尼珠未已莹者。是故如来法身与菩萨法身如是差别。善男子。如白分月。从初一日至十五日。光明照耀渐渐圆满。虽同是月光明不等。而菩萨法身如来法身虽同一性相。然功德威力如是差别

复次善男子。菩萨成就十种法得金刚坚固之身。何等为十。一者贪嗔痴等不能沮坏。二者忿恚结妒我慢贡高颠倒之见不能沮坏。三者世间八法不能沮坏。四者恶趣苦恼不能沮坏。五者一切诸苦不能沮坏。六者生老病死不能沮坏。七者外道诸论不能沮坏。八者魔及魔众不能沮坏。九者声闻辟支佛不能沮坏。十者诸欲境界不能沮坏。善男子。菩萨成就此十种法得金刚坚固之身

复次善男子。菩萨成就十种法为大商主。何等为十。一者得平等意乐。二者应受供养。三者能作出离。四者能为所依。五者能作饶益。六者善能积集道路资粮。七者得好财宝。八者心无止足。九者常为导师。十者善巧随顺往一切智城。善男子。云何菩萨得平等意乐。乃至云何得善巧随顺往一切智性大城。善男子。譬如商主得诸国王及国王子等之所爱乐。菩萨亦尔。为法商主得诸如来及声闻等之所爱乐。善男子。譬如商主应得聚落婆罗门及刹帝利等之所供养。菩萨亦尔。为法商主应得有学无学及余天龙等之所供养。善男子。譬如商主经于旷野饥馑之处。导引众商令得安乐无有疲厌。菩萨亦尔。为法商主经于生死旷野之中。能令众生免离逼迫皆获安乐。善男子。譬如商主能与一切贫苦众生作大依止。令得出离旷野饥馑。菩萨亦尔。为法商主能与外道遮落迦波离婆罗社迦。令得出离生死全其躯命。善男子。譬如商主能得饶益王臣及诸人民。菩萨亦尔。为法商主能得饶益爱着生死诸众生等。善男子。譬如商主将多商人往于诸方。经过旷野饥馑之处。善能积集众多资粮。越于险难得至大城而获安乐。菩萨亦尔。为法商主善能积集福智资粮。导引众生超过生死旷野之中。得至诸佛一切智城。善男子。譬如商主养育众人。欲往他方积集珍宝。所谓金银末尼真珠吠琉璃螺贝璧玉珊瑚等宝。菩萨亦尔。为法商主养育众生。欲往一切智慧大城。善能积集佛法珍宝。善男子。譬如商主悕求一切财物终无厌足。菩萨亦尔。为法商主悕求一切正法财宝无有厌足。善男子。譬如商主于众商中而为上首。积集资财能为主故。最尊胜故。能令众商信受语故。菩萨亦尔。为法商主于一切众生中最尊胜故。能为主故。积集功德言不虚妄故。善男子。譬如商主能以善巧超过险路至彼大城。菩萨亦尔。将诸众生超过生死到智慧城。善男子。是名菩萨得等意乐乃至善巧到一切种智慧大城

复次善男子。菩萨成就十种法。而能于道善巧。何等为十。一者能知平等道。二者能知不平等道。三者能知安隐道。四者能知善巧道。五者能知有水草道。六者能知诸方道。七者能知相道。八者能知正道。九者能知邪道。十者能知出离道。善男子。菩萨成就此十种法即能于道善巧

复次善男子。菩萨成就十种法得不颠倒道。何等为十。一者若诸有情应以大乘而调伏者。为说菩萨道而调伏之不为说声闻道。二者若诸有情应以声闻乘而调伏者。为说声闻道而调伏之不为说菩萨道。三者若诸有情应以一切智而调伏者。为说一切智道而调伏之不为说缘觉道。四者若诸有情应以缘觉乘而调伏者。为说缘觉道不为说一切智道。五者若诸有情执着我法。为说无我及以空法。不说我与有情命者养育者补特伽罗。六者若诸有情执着二边为说离二边道。不说依止二边。七者若诸有情心散乱者。为说奢摩他毗钵舍那。不说散乱道。八者若诸有情着戏论者为说真如。不说愚夫耽着戏论。九者若诸有情耽着生死。为说涅槃不说生死。十者若诸有情着于邪道。为说无结无棘刺道。不说普遍烦恼棘刺道。善男子。菩萨成就此十种法即能成就不颠倒道

复次善男子。菩萨成就十种法。而能善行于三摩呬多心。何等为十。一者善行身念处。二者善行受念处。三者善行心念处。四者善行法念处。五者善行境界念处。六者善行阿兰若念处。七者善行村邑国土王都聚落念处。八者善行利养尊重名闻念处。九者善行如来施设学处念处。十者善行烦恼及随烦恼杂染念处。云何菩萨行身念处。善男子。菩萨以正般若简择诸法。与身俱者能舍恶法。观察是身从头至足无我我所。性不久停终当坏灭。筋脉缠缚臭秽不净。菩萨如是观察之时。而不于中乐欲贪着。以是义故。身中所有诸可恶法。唯除菩萨自在能舍。非诸有情。是名善行于身念处。云何菩萨行受念处。善男子。菩萨作是思惟。所有诸受悉皆是苦。愚夫颠倒为之为乐。一切智者知乐即苦。是故勇猛修行断苦。令他有情亦如是学。菩萨摩诃萨观察受时。终不染着亦不嗔恚。是名菩萨善行受念处。云何行心念处。善男子。菩萨作是思惟。心实无常执着为常。实是其苦执着为乐。本无有我执着为我。本来不净执着为净。其心轻动无时暂停。以不停故。于诸杂染能为根本。坏灭善道开恶趣门生长三毒。与随烦恼等作其因缘。为主为导。又能积集净不净业。迅速流转如旋火轮。亦如奔马。如火焚烧。如水增长。遍知诸境如世彩画。菩萨如是观察心时。便得自在。得自在已于诸法中亦无挂碍。是名菩萨善行心念处。云何菩萨行法念处。善男子。菩萨如实了知诸不善法贪嗔痴等。及依止此所起余法。及能修习烦恼对治。令诸恶法皆悉永断。既能了知一切善法。于中安住要期发愿。复能安立一切有情。如是修学。是名菩萨善行法念处。云何菩萨行境界念处。善男子。菩萨于可意不可意色声香味触法中无染无著。亦不发起嗔恚之心。菩萨作是思惟。我不应于都无法中而生贪染。我若生染即是愚夫及愚痴性。为不了性。为不善性。如世尊言。若为贪爱所染即便顽钝。不能了知善不善法。由此因缘堕于恶趣。菩萨作是思惟。我不应于空法中发起嗔恚。我若起嗔。即不能忍是嗔恚缠。为诸圣人之所诃责。及梵行者之所讥嫌。菩萨观察境界之时。不为境缚亦无执着。复教化人如是修学。是名菩萨善行境界念处

佛说宝雨经卷第七佛说宝雨经卷第八

        唐天竺三藏达摩流支译

云何菩萨善行阿兰若念处。善男子。菩萨作是思惟。住无诤行及住寂静行。若有天龙药叉健达缚等他心神通。能知我心心所有法。是故我应如理作意。远离不如理作意。于如理法中增广修习。是名菩萨善行阿兰若念处。云何菩萨善行村邑聚落国土王都念处。善男子。菩萨若有非法之处当须舍离。所谓酒肆淫里王家。博弈醉徒聚戏歌舞。非是出家之所行处皆应远离。是名菩萨善行人间念处。云何菩萨善行利养承事尊重赞叹念处。善男子。菩萨能于利养等中发如是心。为诸施者作福田故。分散施故。终不耽着生于爱染。亦不为己执我我所。所受之物与一切有情共之。回施一切苦恼之者。由此因缘菩萨所得利养等事。终不倚恃而生我慢贡高之心。作是思惟。所得名闻利养等事。体性空寂都不可得。终当磨灭败坏之法。不可信也。谁有智者于无常法中而生爱着。复起憍逸我慢贡高。是名菩萨善行利养等念处。云何菩萨善行如来施设学处念处。善男子。菩萨作是思惟。过去诸佛习是学处。既能修习已现等觉入般涅槃。未来诸佛如是修习。当现等觉入般涅槃现在诸佛既修习已。今现等觉入般涅槃。菩萨摩诃萨。能于如是所学之处。发起信心尊重勇猛。依之修习。是名菩萨善行如来施设学处念处。云何菩萨善行一切烦恼及随烦恼杂染念处。善男子。菩萨于烦恼及随烦恼杂染法中善能念之。从何因起何缘所生。如是缘起。如是缘生。悉皆舍离。是名菩萨善行烦恼及随烦恼念处。善男子。菩萨成就此十种法。恒常证得三摩呬多心

复次善男子。菩萨成就十种法受粪扫衣。何等为十。一者誓愿坚固。二者谦下自卑。三者无厌弃。四者无所著。五者离过患。六者见功德。七者不自赞。八者不毁他。九者戒具足。十者诸天之所亲近。善男子。云何菩萨誓愿坚固乃至诸天之所亲近。善男子。菩萨得信及意乐具足。于诸佛所深起信心。设因护命不毁誓愿亦无转动。由誓愿坚牢故得谦下心。心谦下故得无我慢。人所弃舍粪扫之服。尽皆收用洗濯缝缀。乃无疲倦亦不弃舍。由是义故无所执着。虽云此衣粗弊烂坏复生污垢多诸蚤虱不以为患。见其功德粪扫衣仙人服用。如来所赞佛说吉祥。远离悭贪随顺圣种。以是因缘得不自赞。亦不毁他得戒具足。戒具足故诸天来下而亲近之。恒为诸佛之所称叹。诸大菩萨而训诲之。复得人非人等之所拥护。若聚落城邑刹帝利婆罗门等顶戴尊重。同梵行者常所咨嗟。善男子。菩萨成就此十种法受粪扫衣。止盖菩萨白佛言。世尊。诸菩萨等其心广大。何因缘故行下劣行

佛言。善男子。诸菩萨等有大势力。方能行此下劣之行。无势力者则不能行。何以故。大力菩萨为护世间。而能对治未起烦恼。非无力者行下劣也。善男子。于意云何。如来行解为广大耶为下劣乎。止盖菩萨白佛言。世尊。我今于此不堪詶对。何以故。如来无所证无行解。以不见法故不可测量。我今何能辩如来所行优劣。佛言。善男子。于汝意云何。如来于四洲中一切有情天龙药叉健达缚等。示现如是下劣之行。复为如是众生赞叹杜多功德。止盖菩萨白佛言。世尊。如来为调伏初发趣大乘。对治一切有情未起烦恼故。示现下劣苦行。佛言。善男子。如是如是。有大势力诸菩萨等。为欲调伏诸有情故。着粪扫衣而无下劣亦复如是。善男子。是名菩萨受粪扫衣

复次善男子。诸菩萨成就十法受用三衣。何等为十。一者知足。二者少欲。三者远离希求。四者无积聚。五者离损失。六者离积聚损失苦恼。七者离忧恼。八者离愁叹。九者无所取。十者勤修习故尽诸有漏。善男子。菩萨于下劣衣而得知足。以知足故而能少欲。以少欲故无所希求。不希求故曾无积聚。无所聚故无损失。以不损失故即无苦恼。无苦恼故无有愁叹。无愁叹故亦无所受。无所受故能勤修习尽诸有漏。善男子。是名菩萨成就十法得受用三衣

复次善男子。菩萨成就十种法得不随他行。何等为十。一者不随贪爱行。二者不随嗔怒行。三者不随愚痴行。四者不随损害行。五者不随悭吝嫉妒行。六者不随我慢行。七者不随令他了知名称行。八者不随尊重利养行。九者不随恭敬天魔行。十者不随贡高行。善男子。菩萨成就此十种法。是故说名不随他行

复次善男子。菩萨成就十种法名为乞食。一者为摄受诸有情故而行乞食。二者为次第故而行乞食。三者为不疲厌故而行乞食。四者为知足故而行乞食。五者为分布故而行乞食。六者为不耽嗜故而行乞食。七者为知量故而行乞食。八者为善品现前故而行乞食。九者为善根圆满故而行乞食。十者为离我执想而行乞食。善男子。云何菩萨摄受有情乃至为离我执想。善男子。菩萨见一切有情受诸苦恼。虽复成就微少善根。而此善根暂时非久。为欲摄益如是有情故。而行乞食。菩萨入于城邑聚落之时。住于正念具足威仪。诸根寂然亦不高举不令放逸。得次第故终不舍彼贫穷之家入富贵家。所谓婆罗门若刹帝利。居士大家次第乞时。从一家诣一家。乃至事毕终无违越。唯除恶处不应乞食。所谓恶狗家新产犊家恶种类家。若男子若女人若童男若童女起烦恼处。及讥嫌处。诸外道处。如是之处皆应舍置。菩萨次第乞食之时。不生厌离亦不疲倦。于彼有情无所憎爱。由不疲厌而生知足。于好于恶随应受取。若得食已至于住处。收钵多罗及以衣服。于如来像前。或制多前。或窣堵波前。供养恭敬尊重赞叹。以所得食分为四分。一分施与同梵行者。一分施与贫穷之人。一分施与恶趣有情。一分自食。菩萨虽食而于食事无贪无染亦无爱着。唯为活命而受于食。不使身羸亦不令重。所以者何。身若极羸废修善品。身若极重增长睡眠。菩萨食已能令善品增长现前。由勤修故无有懈怠亦无懒堕。而得圆满菩提资粮。由彼善能成熟菩提分法远离我执。得无我故能舍身肉施与有情。善男子。菩萨成就此十种法能行乞食

复次善男子。菩萨成就十种法得于一坐。何等为十。一者坐菩提道场。诸魔惊怖而独不动。二者证出世静虑。诸魔惊怖而独不动。三者得出世般若。诸魔惊怖而独不动。四者得出世智。诸魔惊怖而独不动。五者证其空性。诸魔惊怖而独不动。六者证诸法如实。诸魔惊怖而独不动。七者证正觉道。诸魔惊怖而独不动。八者证于实际。诸魔惊怖而独不动。九者证于真如。诸魔惊怖而独不动。十者得一切智。诸魔惊怖而独不动。言一坐者。所谓一切智坐。亦名法座。善男子。菩萨成就此十种法能得一坐

复次善男子。菩萨成就十种法得一食。何等为十。一者不恣贪食。二者无染着食。谓得食已于时非时。不应更受。若苏油石蜜等种种滋味。三者若见他人受苏等时不起嗔恼。四者若他人受苏等时不生嫉妒。五者菩萨行一食时。若遇重病应受苏等。六者菩萨行一食时。必有命难应食苏等而便受之。七者菩萨行一食时。若有废修善法之难。应食苏等而便受之。八者菩萨行一食时。若有如上三难。食苏等已而不追悔。九者菩萨行一食时。若有三难。应食苏等而不疑惑。十者菩萨行一食时。若有三难。须食苏等当作药想。善男子。菩萨成就此十种法故得一食

复次善男子。菩萨成就十种法得阿兰若。何等为十。一者久住梵行。二者于毗奈耶而得善巧。三者诸根圆满。四者具足多闻。五者善说法要。六者离我所执。七者犹如野兽。八者得身远住。九者得居寂静。十者不厌离无盖覆。善男子。云何菩萨久住梵行乃至不厌离阿兰若。善男子。菩萨舍家出家。于毗奈耶中三业清净具足尸罗。性多善巧乐习威仪。于佛所说长幼法中。不假他缘自能解悟。及于教义能得善巧。又能了知持犯之处。见持戒者能生恭敬。见毁戒者便能舍离。又复多时数数悔过。于所作罪追悔恶作终不覆藏。复能了知所犯之罪有上中下。又能了知所造恶业。招异熟果时分长短。菩萨修行清净故得诸根圆满眼根不减。耳根无缺。身分具足。方堪住彼阿兰若处。独静无人不为恼乱。乞食易得非远非近。多诸林木花果枝叶皆悉茂盛。清净美水取不为劳。龛室安隐无有恶兽。山路幽静去住无难。如是之处乃可依止。菩萨依止如是处已。随先所诵及以所闻。昼夜三时恒常修习。诵经之声不粗不细。善摄诸根不令变异。所受用物皆悉清净。了知诸法差别之相。舍离惛沉思惟教理。其心不动亦不外缘。若有王王子及刹帝利婆罗门等至菩萨所。菩萨见已恭敬问讯赞言。善来大王。如所敷设请王就坐。王若坐时菩萨亦坐。王若不坐菩萨亦立。详观王等诸根躁动。菩萨即应赞言。大王善能利益王之国内。多有持戒福德多闻智慧沙门。若婆罗门之所居住。无有盗贼及官人等之所侵欺。复观王等诸根寂然安隐调伏。菩萨尔时当为演说种种诸法。王若不乐说种种法。菩萨即当随顺说厌离法。王若不欲乐闻厌离之法。即应为说如来甚深广大之法及大威德。如是及余人间聚落婆罗门刹帝利诸有来者。随宜为说亦复如是。菩萨以多闻故即能说法。令听闻者心皆欢喜。于菩萨所生净信心。以能说法修习善品对除烦恼。又以多闻力故得离我执。复能远离我执怖畏故。于阿兰若处不惊不惧得无所畏。菩萨住阿兰若处。现前观察无所住着。非如野兽无所观察。菩萨住阿兰若处。无有怖畏无有过患。非如野兽恒畏中伤。菩萨住阿兰若处。为聚落中若男若女若童男若童女散乱心故。为摄受正法故。为无所住着故。非如野兽为护命故。远避人间。菩萨由远住故得现前寂静。见阿兰若有大功德。复见寂静无厌离无覆盖。修习诸法住阿兰若。是名菩萨久住梵行乃至不厌离不覆盖。善男子。菩萨成就此十种法得阿兰若处住

复次善男子。菩萨成就十种法能树下坐。何等为十。一者不得依止极近聚落树下而坐。二者不得依止极远聚落树下而坐。三者不得依止棘刺稠林树下而坐。四者不得依止葛蒙密蔓及猕猴处树下而坐。五者不得依止枯叶树下而坐。六者不得依止猿猴住处树下而坐。七者不得依止多有鸟处树下而坐。八者不得依止恶兽住处树下而坐。九者不得依止近道路处树下而坐。十者不得依止粗恶人处树下而坐。菩萨应当依止无障难处树下而坐。身得轻安心常悦乐。善男子。菩萨成就此十种法得树下坐

复次善男子。菩萨成就十种法能露地坐。何等为十。一者于春夏秋冬不应依止墙壁处坐。二者不应依止林树下坐。三者不得依止穰[麥*戈]草[卄/積]处坐。四者不得依止山腹岩坎处坐。五者不得依止河岸坎中而坐。六者不得以物遮寒而坐。七者不得以物障风而坐。八者不得以物障雨而坐。九者不得以物障热而坐。十者不得以物承露而坐。若诸菩萨在露地坐。身遇诸病又复无力。应入寺中作如是念。如来为欲对除烦恼。处处广说杜多功德。我今虽复在于寺中。心不爱乐又不耽着。勤修正法对除烦恼。作是思惟我住寺中。但为摄受诸施主故。不为长养于自身故作露地想。善男子。菩萨成就此十种法得露地坐

复次善男子。菩萨成就十种法得冢间坐。何等为十。一者谓诸菩萨于好住处极生厌离。二者诸菩萨等于一切时恒起死想。三者诸菩萨等恒常能起余残之想。四者诸菩萨等常观于身分起赤想。五者诸菩萨等常观于身分起青想。六者诸菩萨等常观于身分起脓想。七者诸菩萨等常观于身起膖胀想。八者诸菩萨等常观于身起干焦想。九者诸菩萨等常观于身起离散想。十者诸菩萨等常观于身起骨锁想。善男子。菩萨于冢间坐为利益哀愍诸有情故住于慈心。亦为持净戒故。成就轨则故。不起食肉之心。何以故。善男子。冢间周遍多有非人之所依住。若见菩萨食啖于肉。生不净信起烦恼心。由是菩萨不应食肉。善男子。菩萨住于冢间若入伽蓝。先当礼拜如来制多。次应礼拜长老苾刍。后复问讯少年苾刍。不坐僧家床席等物恭敬而立。何以故。善男子。菩萨为欲随顺世间将护有情故。不坐僧家床席等物。冢间菩萨顺圣者故。若违逆世间非圣者故。若一苾刍将自坐物。请菩萨坐冢间。菩萨应审观察彼苾刍意乐后无追悔。及余众僧不起嗔嫌。然自应起下劣之心。如旃荼罗童子方坐此座。善男子。菩萨成就此十种法得冢间坐

复次善男子。菩萨成就十种法能得常坐。何等为十。一者常坐为不恼身故。二者常坐为不恼心故。三者常坐为不惛睡故。四者常坐为不疲厌故。五者常坐为欲圆满菩提资粮故。六者常坐为心一境性故。七者常坐为证现前道故。八者常坐为趣菩提道场故。九者常坐为利益一切有情故。十者常坐为欲永断诸烦恼故。善男子。菩萨成就此十种法能得常坐

复次善男子。菩萨成就十种法得随敷坐。何等为十。一者于其敷具无所耽嗜。二者终不自为施设敷具。三者不遣他人施设敷具。四者不现于相令他施设敷具。五者随彼所有若草若叶便即应坐。六者诸地方处若多毒蛇蚊虻孔穴。即应舍离并不应坐。七者菩萨欲卧身向右边累足而卧。以法衣覆身。正念正知起明了想。八者右胁而卧不着睡眠。九者但为长养诸大种故。乃至为活命故。十者菩萨于恒恒时及常常时令善品现前。善男子。菩萨成就此十种法得随敷坐

复次善男子。菩萨成就十种法得修习瑜伽者。何等为十。一者能常修不净。二者能常修慈悲。三者能常修缘起。四者于诸过患常修善巧。五者能常修空性。六者能常修无相。七者能常修瑜伽。八者能常勤修。九者得不悔过。十者能具足戒。善男子。云何菩萨能修不净。善男子。菩萨独处宴坐。端身舒缓结加趺坐。现前观察心极厌离。安住正念心不外缘。作是思惟。人中所有一切饮食。若净若秽若好若恶有味无味。若食啖已身火所触。皆成不净烂坏可恶。而不随顺一切世间诸愚夫等耽嗜染着。我等圣者依毗奈耶法。能以正智观察自身。不起染着亦不耽嗜。然复我心亦不生于厌离。是故菩萨能修不净。云何菩萨能修慈悲。善男子。谓诸菩萨于闲静处独处宴坐。端身舒缓结加趺坐。现前观察心极厌离。安住正念心不外缘。作是思惟。诸有情辈多起嗔害作不善业。复常亲近不善丈夫。无状于我起怨仇想。或于过去。或于未来。或于现在。起如是业。我意令彼一切有情所起嗔害皆得断除。令彼坐于菩提道场。如是之事不唯言说。实是菩萨甚深意乐随顺思惟。是名菩萨能修慈悲。云何菩萨能修缘起。谓诸菩萨若起贪爱及嗔恚心。作是思惟。由我起于贪嗔等法。能起之我既从缘生。所起贪嗔及贪等境亦从缘起。谁有智者于众缘生虚妄法中起我执着。是名菩萨能修缘起。云何菩萨于诸过患能修善巧。谓诸菩萨为欲断除自身过患故常修习。若他相续有诸过患。堪为说者令彼断除。不堪为者菩萨即应舍离而去。云何过患。谓于佛法僧。于戒于圣于梵行者。及于世间尊卑长幼性不恭敬。此是过患。自恃己身常起我慢。轻贱于他染着现前种种境界。背于涅槃起我见有情见命者见补特伽罗见断见空见执常无常。性不承事一切圣者。亲近愚夫。远离持戒供养破戒舍善丈夫近不善丈夫。诽谤甚深素怛缆藏。于此藏门常怀惊怖。懈怠懒惰轻贱己身。性无辩才威光下劣。所不应悔而乃悔之。所应悔者而不能悔。恒为盖缠之所系缚。幻惑诳谄之所随逐。惛沉睡眠之所覆蔽。性常爱乐恭敬利养。贪着种姓爱恋眷属。乐国土众会。舍所受持法性乐。亲近顺世间咒。而常厌离出世正法。串习不善不修诸善。赞出家人恶。若于女人及诸丈夫童男童女诸外道等皆悉赞叹。不乐住于阿练若处。食不知量。于其尊者不乐亲近。诵习之时自为分限。非所行处不见过恶。性不恭敬微细尸罗。于小罪中心不惊怖。见愚痴者诸根暗昧叹为寂静。见智慧者诸根明利拨为嚣举。行于倨傲颠倒执着。性乐粗言。于爱不爱诸色之中随顺执着。见起嗔者不生慈心。见受苦者不起悲愍。见有病者无厌离心。见彼死者无有惊怖。不求出离焚烧之处。不观察身不观察戒。于已作当作现作之法性不观察。不应思惟而起思惟。不应计度而生计度。不应悕求而有悕求。于非出离作出离想。于彼非道而作道想。未得谓得。应作不作。耽着恶法舍离善品。恶说大乘赞叹小乘。毁呰深信大乘补特伽罗。赞叹深信小乘补特伽罗。常为诤论恒起斗讼。性怀粗犷好为恶语。倨傲多言严切暴恶。贪婪矫诈性多虚妄。语无伦次爱乐戏论。此是过患。菩萨能于如是过患。得善巧已勤修空性。为欲舍离诸戏论故。菩萨虽复勤修空性然心流散。于彼彼处而心乐住。菩萨遍求于彼彼境。自性皆空求不可得。所取之境体既是空。能取之心性亦非有。所观心境了知是空。能观察智体实非有。菩萨观察空性之时修无相性。菩萨虽复勤修无相。犹有彼彼诸相现前。菩萨又观现前诸相体性皆空。如是诸相既不可得。观内身相亦不可得。于身念住亦不可得。心不执着外诸相中。念住体性亦不可得。菩萨舍离如是诸相。常能发起修习意乐。菩萨修习诸三摩地。于其境界无间而住。谓心一境性是奢摩他。如实观察是毗钵舍那。菩萨修习三摩呬多。心得无悔又复欢喜。何以故。戒清净故。以诸菩萨戒清净故得于瑜伽。具足戒者增长瑜伽修习瑜伽。是故说名得瑜伽者。善男子。菩萨成就此十种法能修习瑜伽者

复次善男子。菩萨成就十种法能持素怛缆藏。何等为十。一者听闻领受。为守护正法故。不为资财故。二者听闻领受。为守护住持故。不为利养故。三者听闻领受。为三宝种不断故。不求供养故。四者听闻领受。为正摄受发趣大乘诸有情故。不为名称赞叹故。五者听闻领受。为欲利益无依无怙诸有情故。六者听闻领受。安乐苦恼诸有情故。七者听闻领受。为诸有情无慧眼者得慧眼故。八者听闻领受。为发趣声闻乘诸有情等。演说声闻乘道故。九者听闻领受。为发趣大乘道故。十者听闻领受。为自身证无上智故。不为希求下劣乘故。善男子。菩萨成就此十种法能持素怛缆藏

复次善男子。菩萨成就十种法能持毗奈耶藏。何等为十。一者能了知毗奈耶。二者能了知毗奈耶义。三者能了知毗奈耶甚深理趣。四者能了知毗奈耶微细。五者能了知应作不应作。六者能了知自性违犯。七者能了知施设违犯。八者能了知所学波罗提木叉缘起。九者能了知声闻毗奈耶。十者能了知菩萨毗奈耶。善男子。菩萨成就此十种法能持毗奈耶藏

复次善男子。菩萨成就十种法能善轨则所行境界具足威仪。何等为十。一者善学声闻一切学处。二者善学缘觉一切学处。三者善学菩萨一切学处。四者于诸学处得善学已。能善轨则所行具足。五者轨则所行皆具足已。便能舍离非沙门行。六者以是因缘菩萨不行非处非时。七者菩萨能于沙门所行威仪轨则皆具足已。若沙门若婆罗门。皆无有能非理讥毁。八者由此菩萨亦能令他善学如是一切学处。九者菩萨所行轨则圆满已。得端严寂静具足威仪。十者成就威仪而无矫诈。善男子。菩萨成就此十种法能善轨则所行境界威仪具足

佛说宝雨经卷第八佛说宝雨经卷第九

        唐天竺三藏达摩流支译

复次善男子。菩萨成就十种法离悭吝嫉妒。何等为十。一者得自为施主。二者能劝他布施。三者能赞叹布施。四者庆慰他施。五者赞余施主令得欢喜。六者见施他时终不起念。但施于我勿施余人。如是之物唯我应有。七者菩萨发心令一切有情皆得利益。谓能济彼活命资具。八者菩萨发心令诸有情皆得安乐。所谓成就世出世间所有安乐。九者我当勤修为欲利益诸有情故。十者我应发起舍离悭吝嫉妒之心。善男子。菩萨成就此十种法便能永离悭吝嫉妒

复次善男子。菩萨成就十种法能于一切有情得平等心。何等为十。一者于一切有情得平等方便。二者于一切有情得心无障碍。三者于一切有情得无恼坏心。四者修行布施。五者修习持戒。六者修习安忍。七者修习正勤。八者修习静虑。九者修习般若。为欲利益诸有情故。十者积集一切智因。菩萨积集终不依止二种之心。平等普为一切有情而积集故。菩萨若能如是积集。速证法性能出一切生死热恼。亦能令他出离生死。菩萨平等于诸有情心不贪爱亦无憎嫉。善男子。譬如长者有其六子。皆悉端严称可父意。长者怜愍心无偏念平等养育。然彼诸子幼小愚痴未有善巧。长者舍宅忽然失火。是时诸子各各别处。善男子。于汝意云何。是时长者颇作是念。我令诸子前后出不。止盖菩萨言。不也世尊。何以故。由彼长者心平等故。于其诸子随得随出。佛言。如是如是。菩萨亦尔。一切有情在于生死热恼宅中。愚痴无智复无善巧。如是有情。于六道中各各别住。菩萨以方便故皆令得出。复能置于寂静之界。善男子。菩萨成就此十种法。于一切有情得平等心

复次善男子。菩萨成就十种法。得善巧供养一切如来。何等为十。一者以法供养。即供养一切如来。非财供养。二者如说修行。即为供养一切如来。非财供养。三者为利益安乐诸有情故。即为供养一切如来。非财供养。四者为摄诸有情故。即为供养一切如来。非财供养。五者随所作事皆为利益诸有情故。即为供养一切如来。非财供养。六者不舍离誓愿。即为供养一切如来。非财供养。七者不舍菩萨所作事业。即为供养一切如来。非财供养。八者如理思惟故。即为供养一切如来。非财供养。九者心无厌倦故。即为供养一切如来。非财供养。十者不舍离菩提心故。即为供养一切如来。非财供养。云何为法供养。善男子。以法身即是诸如来故。法供养已即为供养一切如来。云何如说修行。谓如说修行成如来故。云何为利益安乐一切有情。谓如来出现为利益安乐一切有情故。云何为摄受诸有情。谓如来出现摄受一切诸有情故。云何为利益诸有情。以所作事业皆为利益诸有情故。云何不舍誓愿。以舍离誓愿不能利益诸有情故。云何不舍菩萨所作事业。若违背菩萨所作事业。即不能供养一切如来。云何如理思惟。谓不如理思惟。不能供养诸如来故。云何心不疲厌。谓心若疲厌。即不能供养一切如来。云何不舍菩提心。以舍离菩提心。即不能供养一切如来。何以故。善男子。以诸菩萨为利益有情。当得阿耨多罗三藐三菩提。若无有情则诸菩萨不现等觉。是故以法供养。即得供养一切如来。非财供养。善男子。菩萨成就此十种法即得善巧。承事供养一切如来

复次善男子。菩萨成就十种法能降伏我慢。何等为十。一者菩萨舍家出家所有亲属。皆舍离我犹如死尸。以是因缘能降伏我慢。二者我毁形好。着坏色衣身貌异俗。由是因缘能伏我慢。三者我剃除须发。手执应器巡家乞食。以是因缘能降伏我慢。四者巡家乞食。如旃荼罗子起下劣心。以是故能降伏我慢。五者从他乞食我命因他。应念己身如乞求者。由是故能降伏我慢。六者我所得食虽为他人之所轻贱。为乞食故而无厌倦。由是故能降伏我慢。七者供养尊者阿遮利耶作福田想。由是故能降伏我慢。八者我具威仪轨则所行。为欲令他同梵行者见皆欢喜。以是故能降伏我慢。九者未得佛法愿我当得。以是故能降伏我慢。十者我能于彼忿怒损害诸有情中常起忍辱。以是故能降伏我慢。善男子。菩萨成就此十种法能降伏我慢

复次善男子。菩萨成就十种法能得净信。何等为十。一者以宿植善根具足因缘故出生福德。二者不由师教而得正见。三者舍离虚诳谄曲之行得意乐具足。四者无邪曲性得质直心。五者由利根故。得智慧具足。六者以清净心流注相续故。能舍离睡眠障碍。七者舍离恶知识。依止善知识。八者希求善法不起我慢。九者演说正法。无颠倒取。十者以广大信。能知如来广大威德。善男子。菩萨成就此十种法得清信心

止盖菩萨白佛言。世尊。我于如来广大威德。愿乐欲闻少分之义。佛言。善男子。汝应谛听善思念之。我今为汝宣说如来广大威德少分之义。止盖白佛言。善哉世尊。愿乐欲闻。善男子。如来成就大慈平等普为一切有情。如来于一有情起于大慈。与一切有情而无有异。如来大慈。虽遍有情界尽虚空界。然大慈边际实不可得。善男子。如来成就大悲不与一切声闻缘觉诸菩萨共。如来于一有情起大悲时。与一切有情而无有异。善男子。如来成就说法无尽。于无量劫无量阿僧企耶。名言各别道理不同。为一切有情能顿演说。然佛所说法无穷尽。善男子。如来成就无量问难。能答能释。善男子。假使一切有情。乃至入于有情数者。同时问佛。名句文身各各有异。如来于一刹那或一腊缚一牟呼栗多。能答能释而无穷尽。善男子。如来成就静虑所行境界得无障碍。善男子。假令一切有情。皆住十地诸菩萨位。如是菩萨。一时皆入无量百千诸三摩地。如是入时经于无量百千诸劫。所入静虑各各不同。实不能知佛三摩地。及所行境界边际可得。善男子。如来成就无量色身。若诸有情应以如来色身而教化者。如来即能于一刹那或一腊缚一牟呼栗多。各各于彼有情之所。示现如来色身之相。若诸有情应见种种别类有情色身之相。如来即能于一刹那或一腊缚或一牟呼栗多。各各于彼有情之前。示现种种别类有情色身之相。善男子。如来眼所取境有无量种。诸有情等。天眼所见。肉眼不见者。如是种类有情。满于超过算数思量世界之中。世尊如实观见尔所有情。犹如掌中阿摩罗果。善男子。如来耳所取境有无量种。如前所说无量无边诸世界中。有情充满。然彼世界一切有情。于一刹那一腊缚时一牟呼栗多顷同时出声。然彼诸声音韵屈曲。言词大小宣说有异。如来闻彼音声。各各差别皆能了知。善男子。如来成就圣智无尽无量犹若虚空。善男子。尽有情界所有众生。各各构画别别思惟作种种业。如来于一刹那于一腊缚一牟呼栗多。悉能了知。此诸有情如是构画如是思惟如是造业得如是果。如来以无碍智。悉能了知彼诸有情三世业果。何以故。如来常在三摩呬多故。何以故。如来念无失故。诸根不散故。心不驰流故。何以故。善男子。如来住寂静故。甚寂静极寂静故。能断一切诸烦恼故。善男子。若彼众生。有诸烦恼心则驰散。不能得彼诸三摩地。如来无彼烦恼尘垢起无漏智。证得一切诸法自在平等理性。通达一切诸三摩地三摩钵底所行境界。善男子。如来所有四种威仪。一一皆住于三摩地。乃至如来入于涅槃。经尔所时住三摩地。何况少时而不在定。善男子。如来于无量劫积集资粮。由是如来常住三摩呬多。善男子。如来不可测量。不可思惟。不可计度。止盖菩萨白佛言。不也世尊。以如来于三阿僧企耶积集资粮。而证得故。佛言。善男子。我于无量劫积集资粮。证得如来不思议境。非唯于彼三僧祇劫而证得故。然由菩萨悟解平等诸法性已。方得入彼三僧祇数。非初发心

止盖菩萨言。若诸有情得闻如来大威德者。能起净信欢喜悦乐。世尊。彼诸有情。当知即是有福德者。作诸善者。断业障者。若起信解则亲近菩提。何况闻已受持读诵究竟通利为他广说。世尊。如是有情不久堪成如来威德。佛言。如是如是。善男子。此诸有情。当为无量诸佛摄受。当得承事无量诸佛种诸善根。若善男子。善女人。得闻如来广大威德。终不应起犹豫疑惑。于如来威德。能意乐思惟心净胜解。着新净衣如法供养。能于七日七夜。专念思惟心不散乱。满七日七夜已。即于其夜得见如来。若所作法不具足者。是人临命终时心不散乱。当得如来现前而住

止盖菩萨白佛言。世尊。若诸有情。闻说如来大威德时生不信不。佛言有。善男子。若诸有情。闻说如来大威德时。意乐猛利粗恶楚毒起损害心。于说法师起恶知识想。由是因缘。身坏之后生奈洛迦。善男子。若诸有情。闻说如来广大威德心生净信。于说法师起善知识想及导师想。善男子。决定应知。此诸有情生生之处。曾闻如来广大威德。或此诸有情作如是思惟。我应往昔于诸佛会中曾闻此法门。由斯我等闻于如来广大威德。心生净信如世尊说。今闻如来广大威德。生净信者以昔曾闻故

尔时世尊即现舌相覆于面轮。次覆于身及师子座并诸菩萨声闻之众释梵护世。乃至覆于一切大会。尔时世尊还摄舌相告大众言。善男子。如是舌相。由如来得不妄语故。汝等应当深生净信。能于长夜利益安乐。说此法时。八万四千菩萨得无生法忍。无量百千有情。远尘离垢得法眼净。其余无量有情。曾未能发菩提心者皆得发心

尔时薄伽梵告止盖菩萨言。善男子。菩萨成就十种法。于世俗中而得善巧。何等为十。一者于世俗谛施设有色。胜义谛中色不可得亦无执着。于世俗中施设受想行识。胜义谛中乃至于识皆不可得亦无执着。二者于世俗中施设地界。于胜义中地不可得亦无执着。虽于世俗施设水火风界及空识界。于胜义中乃至识界俱不可得亦无执着。三者虽于世俗施设眼处。于胜义中眼处不可得亦无执着。虽于世俗施设耳处乃至意处。于胜义中乃至意处皆不可得亦无执着。四者虽于世俗施设有我。于胜义中我不可得亦无执着。五者虽于世俗施设有情。于胜义中有情不可得亦无执着。六者虽于世俗施设命者养育意生补特迦罗摩纳缚迦。于胜义中皆不可得亦无执着。七者虽于世俗施设世间。于胜义中世间不可得亦无执着。八者虽于世俗施设有世间法。于胜义中世间法不可得亦无执着。九者虽于世俗施设佛法。于胜义中佛法不可得亦无执着。十者虽于世俗施设菩提。于胜义中所证菩提及能觉者。俱不可得亦无执着。善男子。因想施设所有言说。是名世俗。虽胜义中世俗不可得。离于世俗则无胜义。善男子。若菩萨于世俗中能得善巧非胜义谛。是故说名世俗善巧。善男子。菩萨成就此十种法。得世俗善巧

复次善男子。菩萨成就十种法。得胜义善巧。何等为十。一者证得无生法性。二者证得不灭法性。三者证得不坏法性。四者证得不入不出法性。五者证得超过言语所行法性。六者证得无言说法性。七者证得离戏论法性。八者证得不可说法性。九者证得寂静法性。十者证得圣者法性。何以故。善男子。以胜义谛不生不灭不坏无入无出超过言路。非文字取故。非戏论证故。不可言说湛然寂静。为诸圣者自内所证。善男子。以诸如来。若有出现若不出现。其胜义理常住不坏。为是义故。菩萨剃除须发。身服袈裟心生正信。远离于家趣于非家。是名出家。得出家已精勤修习。如头系缯彩为火所烧。无暇救火专求胜义。若无胜义则梵行唐捐。诸佛出世亦无义利。善男子。由有胜义故。诸菩萨于此法中能得善巧。善男子。菩萨成就此十种法。得胜义善巧

复次善男子。菩萨成就十种法得缘起善巧。何等为十。一者能知空性。二者能知无所有性。三者能知不坚固性。四者能知如影性。五者能知如像性。六者能知如响性。七者能知如幻性。八者能知无住性。九者能知摇动性。十者能知缘起性。菩萨作是思惟。诸法如是空。如是无所有。如是不坚固。如是喻影。如是喻像。如是喻响。如是喻幻。如是无住。如是摇动。如是缘起。复作思惟。于此诸法能了知生能了知灭。菩萨又复思念。一切诸法何因故生何因故灭。由无明为缘能生诸法。无明是首。无明为依。依无明已诸行得生。依诸行已诸识得生。依识生已名色得生。依名色已六处得生。依六处已诸触得生。诸触生已施设于受。以有受故施设于爱。愚夫为爱所逼迫故施设于取。取谓受取。以取生故有相续生。依止有故而得于生。依止生故而得有老。以有老故补特伽罗皆有其死。以有死故即能生于忧悲苦恼。诸法积集为大苦聚。是故智者应当精勤坏灭无明拔其根本。无明灭故而诸法灭。善男子。譬如命根灭已余根皆灭。如是无明灭故即无所依。以无依故烦恼不起。以生死因灭故诸趣果灭。由是菩萨能证涅槃。善男子。菩萨成就此十种法得缘起善巧

复次善男子。菩萨成就十种法故能自了知。何等为十。一者菩萨观察自身是谁种姓。于婆罗门刹帝利种。若居士家富贵贫贱。诸种姓中何种姓生。菩萨虽能于诸富贵种姓中生。终不恃此而起憍慢。若于贫贱种姓中生。作是思惟。我昔曾作诸杂业故。由是令我生此种姓。以是因缘厌离诸有。以厌离故而求出家。二者得出家已应作是念。为何义利而求出家。作是思惟。我今出家为欲自度令他得度。自得解脱令他解脱。是故菩萨常应远离懈怠懒惰。三者菩萨应念。我今出家于诸罪障不善之法皆应除灭。所以者何。若有诸罪已能断除。应自心生欢喜悦乐。若未除断为令断故应勤修习。四者菩萨应当如是观察。我既出家一切善法皆得增长。所以者何。若诸善法已得增长心生喜乐。若未增长为令增长殷勤修习。五者菩萨又应如是观察。若增长善法除灭罪障。我当依止如是尊者。由是因缘。菩萨应随邬波驮耶。持戒破戒。少闻多闻。若有名称。若无名称。起导师想犹如世尊。生于净信欢喜悦乐。六者菩萨当于阿遮利耶。应常尊重恭敬供养。作是思惟。我今依止阿遮利耶故。于菩提分法未圆满者愿得圆满。于烦恼法未得除断愿得除断。菩萨奉事阿遮利耶。如邬波驮耶想。若有善法随顺摄受。若不善法了知不作。由此心生欢喜悦乐。七者菩萨应起思惟谁是我师。复作是念。一切智者是我之师。云何一切智者。谓了知诸法哀愍世间。能起大悲为大福田。与一切世间天人阿素洛等为大轨范是我导师。菩萨由此欢喜悦乐得大利益。复作思惟。诸佛世尊是我之师。佛所演说圣道学处我当修习。乃至命终亦无违犯。我应如是尊重诸佛。恭敬供养心常随顺。八者菩萨作是思惟。我从谁乞而得于食。菩萨复念。我应从彼城邑聚落诸婆罗门刹帝利等而乞于食。我令如是诸有情等。以施食故获大果报。获大义利获大威德。故从乞食。九者菩萨作是思惟。城邑聚落诸婆罗门刹帝利等。应作何想而与我食。菩萨复念。彼应于我。作沙门想。作苾刍想。作福田想。而与我食。我应思念但是沙门及福田者。所有功德我皆修习。十者菩萨作是思惟。无始生死我今出离。云何出离。菩萨思念。我得出家成苾刍法。是第一出离。我今成就沙门功德。是第二出离。我常精进离于懈怠。证于法性故能出离无始生死。是第三出离。我当于阿耨多罗三藐三菩提而现等觉。是第四出离。菩萨由作如是观察能自了知。善男子。菩萨成就此十种法得自了知

复次善男子。菩萨成就十种法能知于世。何等为十。一于倨傲者能自卑下。二于憍慢者能离憍慢。三于邪曲者能为质直。四于虚诳者能真实言。五于恶语者能为爱语。六于坚强者能柔软语。七于暴恶者常能忍辱。八于嗔怒者能修于慈。九于苦恼者能修于悲。十于悭吝者能修于施。善男子。菩萨成就此十种法能知于世

复次善男子。菩萨成就十种法生清净佛刹。何等为十。一者成就于戒无缺无杂。戒无点污。戒得清净。二者为一切有情心得平等。三者以能成就广大善根。四者于利养名称恭敬赞叹。心常舍离无所染着。五者得清净信心无疑惑。六者常修精进离懈怠心。七者能入寂定无散乱心。八者能得多闻而无恶慧。九者成就利智非钝根性。十者有慈悲性无损害心。止盖菩萨白佛言。世尊。于此十法。为要具足方始得生。若有阙者能得生不。佛言。善男子。若有菩萨。成就一法得无缺减。无少违犯鲜白清净。彼诸菩萨即得具足成就十法。善男子。菩萨成就此十种法生清净佛刹

复次善男子。菩萨成就十种法。得处胎藏尘垢不染。何等为十。一者造如来像。二者修理破坏诸佛制多。三者以诸妙香涂佛制多而为供养。四者以诸香水洗如来像而为供养。五者于佛制多中扫洒涂地而为供养。六者亲能承事供养父母。七者亲能供养阿遮利耶邬波驮耶。八者亲能供养修梵行者。而菩萨心无有悕望。九者菩萨愿以善根回施有情。由我善根。令不染着胎垢而生。十者菩萨如是回向。意乐殷重猛利甚深。善男子。菩萨成就此十种法。得处胎藏尘垢无染

复次善男子。菩萨成就十种法。得舍家出家。何等为十。一者得无所取。二者不杂乱住。三者得厌背境界。四者离境界爱着。五者不起染着境界过患。六者于佛施设所有学处恭敬尊重。能善修习勇猛精进。七者于饮食衣服资具医药。随所受物心常知足。八者于钵多罗及袈裟资具。善能舍离一切积集。九者于境界中心常怖畏起于厌离。十者常勤修习。能于现前寂静而住。善男子。菩萨成就此十种法。得舍家出家

复次善男子。菩萨成就十种法。能得净命。何等为十。一者能善舍离为利养故矫诈谄曲。二者能善舍离为利养故而现其相。三者善能舍离为利养故虚言鼓动。四者善能舍离恶求利养。五者善能舍离非法利养。六者善能舍离不净利养。七者不耽着利养。八者得不染着利养。九者得性不热恼。十者于如法利养善能知足。善男子。云何善能舍离为利养故矫诈谄曲。谓此菩萨不为利养因缘故身语心业而为矫诈。云何身不矫诈。谓此菩萨若见施主及助施者。不现威仪。云何不现威仪。谓此菩萨若举足时不诈徐步。若下足时不前视一寻现思惟相。亦不诈伪不顾直视。云何语不矫诈。谓此菩萨不为利养故安徐细语柔软爱语及随顺语。云何心不矫诈。若有施主及助施者请唤之时。菩萨不为利养语现少欲心广贪求内怀热恼。是名菩萨不为利养故矫诈谄曲。云何善能舍离为利养故而现其相。菩萨若见施主及助施者终不现相。自言我之衣钵病缘医药。而彼施主及助施者。虽不惠施菩萨终不从彼乞求。是名菩萨善能舍离为利养故而现其相。云何菩萨善能舍离为利养故虚言鼓动。菩萨若见施主及助施者。终不诈言。某甲施主持某事物而惠施我。我以某物而报彼恩。又言某甲以我持戒多闻少欲。持彼彼物而施与我。我起悲心。怜愍彼故而摄受之。是名菩萨善能舍离为利养故虚言鼓动

佛说宝雨经卷第九佛说宝雨经卷第十

        唐天竺三藏达摩流支译

云何菩萨善能舍离恶求利养。善男子。菩萨不为利养故身心行恶。身行恶者。为利养故驰走来往而犯尸罗。心行恶者悕求利养。若见余人所得利养及同梵行者。兴心损坏。是名菩萨舍离恶求利养。云何菩萨舍离非法利养。谓此菩萨不行矫诈取于利养。不以斗秤而行欺诳。他所委信。终不侵损不行矫诈。是名菩萨舍离非法利养。云何菩萨舍离不净利养。谓此菩萨所得利养。若窣堵波。若法若僧共有之物。或他不与亦不许可。虽得彼物必不受之。是名菩萨舍离不净利养。云何菩萨不耽着利养。谓此菩萨得利养时。不摄为己物。不自称富者。亦无积聚。时时施与沙门婆罗门等。若施与父母及辅翼左右亲友眷属。时时自用。虽自受用亦无染着。菩萨不得利养之时。心不生苦亦无热恼。若彼施主及助施者。虽不惠施。菩萨于彼不起嗔心。若得如法利养及随僧次。一切如来皆同许可。诸菩萨等无有呵责。诸天赞叹。同梵行者无有讥嫌。于此利益常能知足。善男子。菩萨成就此十种法能得净命

复次善男子。菩萨成就十种法得心无厌倦。何等为十。一者为诸有情故虽久住生死而无厌倦。二者为诸有情故于生死苦而无厌倦。三者于利益有情中而无厌倦。四者诸所作事常为有情而无厌倦。五者能令有情作善事业而无厌倦。六者为声闻乘补特伽罗宣说道法而无厌倦。七者不于声闻乘补特伽罗前现不信彼声闻乘法。八者摄受菩提分法而无厌倦。九者圆满菩提资粮而无厌倦。十者于涅槃界不求现证。亦无趣向涅槃意乐。由此菩萨能随顺大菩提故。趣向大菩提故。亲近大菩提故。善男子。菩萨成就此十种法得心无厌倦

复次善男子。菩萨成就十种法。能行一切如来教敕。何等为十。一者修不放逸。舍诸放逸故。二者得身善律仪。身不行恶故。三者得语善律仪。语不行恶故。四者得意善律仪。意不行恶故。五者怖畏他世。能尽舍离诸不善法。六者能说正理离诸非理。七者能善说法诃责非法。八者能得舍离讥嫌之业。于清净业随顺修行。九者于如来教中不说过患。能尽舍离诸烦恼毒。十者于如来法性能随顺守护。防御一切恶不善法。善男子。菩萨成就此十种法。能行一切如来教敕

复次善男子。菩萨成就十种法。得面门微笑永离颦蹙。何等为十。一者得诸根明净。二者得诸根遍净。三者得诸根不缺。四者得诸根离垢。五者得诸根白净。六者得永离损害。七者得永离睡眠。八者得永离缠缚。九者得永离结恨。十者得永离忿怒。善男子。菩萨成就此十种法。得面门微笑永离颦蹙

止盖菩萨白佛言。世尊。如我解佛所说义趣。由诸根清净故诸菩萨得面门微笑。复由永离诸烦恼故得无颦蹙。佛言。善男子。如是如是如汝所说

复次善男子。菩萨成就十种法能得多闻。何等为十。一者如实了知如是贪火炽然生灭。二者如实了知如是嗔火炽然增盛。三者如实了知如是痴火惛乱增长。四者如实了知有为之法悉皆无常。五者如实了知如是诸行一切皆苦。六者如实了知如是世间并皆是空。七者如实了知如是一切诸行无我。八者如实了知如是爱着皆名戏论。九者如实了知一切诸法因缘所生。十者如实了知涅槃寂静。如是之义非但言说。要以闻思修所成慧。方于此义如实了知。如是知已悲心坚固。为诸有情发起精进。善男子。菩萨成就此十种法能得多闻

复次善男子。菩萨成就十种法摄受正法。何等为十。一者于后时后分后五十岁正法将灭时分转减。诸有情类不能修持住非道中。智灯已灭无能说者。此时若有能于广大素怛缆中。有大利益。有大威德。生诸善法如有情母。受持读诵。种种承事恭敬供养。二者展转为他宣说开示。三者能于修学如是广大经典补特伽罗所。生于净信。欢喜踊跃摄受于彼。四者听闻正法无所悕望。五者于此法师起导师想。六者能于正法起甘露想。七者能于正法起仙药想。八者于其正法起良药想。九者专求正法不顾身命。十者悕求正法起修行想。善男子。菩萨成就此十种法能摄受正法

复次善男子。有十种法菩萨成就为法王子。何等为十。一者具诸相庄严。二者身得随好。三者诸根具足皆悉圆满。四者于一切如来所行之处随顺修行。五者于一切如来所得圣道随顺得之。六者于一切如来所有觉悟随顺悟之。七者能得除灭世间苦恼。八者善学一切圣者所行。九者得善修习梵行。十者能住一切智城。是诸如来所住之处。善男子。菩萨成就此十种法为法王子

复次善男子。菩萨成就十种法。得释梵护世之所承奉。何等为十。一者能于菩提而不退转。二者一切诸魔所不能动。三者于佛法中而无退失。四者随顺能入诸真实相。五者随顺通达一切诸法悉皆平等。六者能于一切佛法之中。不藉他缘而能信解。七者得善证智。八者成就不共一切声闻辟支佛法。九者能超过彼一切世间。十者证无生法忍。善男子。菩萨成就此十种法。得释梵护世之所承奉

复次善男子。菩萨成就十种法。能知有情意乐随眠。何等为十。一者如实了知一切有情贪心意乐。二者如实了知一切有情嗔心意乐。三者如实了知一切有情痴心意乐。四者如实了知一切有情上品意乐。五者如实了知一切有情中品意乐。六者如实了知一切有情下品意乐。七者如实了知一切有情诸善意乐。八者如实了知一切有情坚固意乐。九者如实了知一切有情常起随眠。十者如实了知一切有情暴恶随眠。善男子。菩萨成就此十种法。能知有情意乐随眠

复次善男子。菩萨成就十种法。能得成熟有情善巧。何等为十。一者若诸有情。应以如来色相而得度者。即现如来色相。二者应以菩萨色相而得度者。即现菩萨色相。三者应以缘觉色相而得度者。即现缘觉色相。四者应以声闻色相而得度者。即现声闻色相。五者应以帝释色相而得度者。即现帝释色相。六者应以魔王色相而得度者。即现魔王色相。七者应以梵天色相而得度者。即现梵天色相。八者应以婆罗门色相而得度者。即现婆罗门色相。九者应以刹帝利色相而得度者。即现刹帝利色相。十者应以居士色相而得度者。即现居士色相。善男子。若诸有情应以如是色相方便得调伏者。菩萨为彼示现种种色相方便而调伏之。善男子。菩萨成就此十种法。能得成熟有情善巧

复次善男子。菩萨成就十种法得随顺住。何等为十。一者质直心。二者柔软心。三者不邪曲心。四者无损害心。五者无垢心。六者清净心。七者无坚鞕心。八者无粗恶言。九者能常忍辱。十者具足随顺善男子。菩萨成就此十种法得随顺住

复次善男子。菩萨成就十种法得安乐住。何等为十。一者能得正见具足清净。二者得戒具足。三者轨则清净。四者得顺所行境。五者无所染着。六者成就悲愍。七者能常忧念。八者能得同类。九者能发起一乘。十者不事余师。善男子。菩萨成就此十种法得安乐住

复次善男子。菩萨成就十种法得摄事善巧。何等为十。一者为摄有情修利益施。二者为摄有情修安乐施。三者为摄有情修无尽施。四者为摄有情言说利益。五者为摄有情修言说义。六者为摄有情修言说法。七者为摄有情示言说理。八者为摄有情以善利益。九者为摄有情同饮食等饶益彼故。十者为摄有情同于活命资具等事饶益彼故。善男子。法利益者所谓法施。安乐施者。所谓财施。无尽施者。谓常宣说道路示人。言说利益者。谓说善根。言说义者。谓说真实。言说法者。谓顺如来教演说之法。言说理者。谓不坏实义。善利益者。谓令众生除灭不善置于善处。同饮食等饶益彼者。谓同受用种种饮食衣服等事。同于活命资具等事饶益彼者。谓同受用金银末尼真珠璧玉吠琉璃宝螺贝珊瑚象马车乘如是等事。善男子。菩萨成就此十种法得摄事善巧

复次善男子。菩萨成就十种法能得端严。何等为十。一能得寂静威仪。二能得无矫诈威仪。三能得清净威仪。四能令见者之所爱乐。五能令见者诸恶止息心意寂静。六能令见者无有厌足。七能令见者心意悦乐。八能令见者心无挂碍。九能令见者所愿满足。十能令见者心生净信。善男子。菩萨成就此十种法能得端严

复次善男子。菩萨成就十种法为所依止。何等为十。一者能守护他。以诸有情怖烦恼故。二者能得出离。以生死旷野多饥渴故。三者善能拔济。谓令有情出生死海故。四者能作眷属。以诸有情多茕独故。五者为大医师。以能对除烦恼病故。六者能作依怙。以诸有情无依恃故。七者能作依止。以诸有情无依处故。八者能作归依。以诸有情无依托故。九者能为智灯。以诸有情住无明故。十者能作归趣。以诸有情无趣向故。善男子。菩萨成就此十种法得为所依

复次善男子。菩萨成就十种法如大药树。何等为十。善男子。如大药树能令有情皆得受用。一者受用其根。二者受用其茎。三者受用其枝。四者受用其叶。五者受用其花。六者受用其果。七者见时受用其色。八者嗅时受用其香。九者尝时受用其味。十者摩时受用其触。善男子。菩萨如是从初发心乃至成佛。能施彼彼一切有情诸烦恼病种种法药令得受用。或受用菩萨施波罗蜜多。或受用菩萨戒波罗蜜多。或受用菩萨忍波罗蜜多。或受用菩萨精进波罗蜜多。或受用菩萨静虑波罗蜜多。或受用菩萨般若波罗蜜多。或见菩萨身而得胜利。或闻菩萨名而得胜利。或味菩萨功德而得胜利。或复供养菩萨而得胜利。善男子。菩萨成就此十种法如大药树

复次善男子。菩萨成就十种法能勤修福德。何等为十。一者于三宝中随力供养。二者于诸有情病患之者能施医药。三者于一切有情饥渴逼者能施饮食。四者于一切有情为寒热等所侵逼者能施衣服。五者于阿遮利耶邬波驮耶。心常尊重恭敬供养。六者于同梵行者问讯起居。合掌礼拜恭敬供养。七者建立伽蓝树林园苑。八者于时时间能以资财谷麦等物库藏所有而行惠施。九者于其奴婢及佣力者。平等怜愍而养育之。十者于时时间。能尊重供养持净戒者及诸沙门婆罗门等。善男子。菩萨成就此十种法能勤修福德

复次善男子。菩萨成就十种法得变化善巧。何等为十。一者于一佛刹身相不动。能于无量佛刹诸如来所闻甚深义。二者于一佛刹身相不动。能于无量佛刹诸如来所听闻正法。三者于一佛刹身相不动。能于无量佛刹诸如来所恭敬供养。四者于一佛刹身相不动。能于无量佛刹土中。修集菩提资粮圆满。五者于一佛刹身相不动。能于无量佛刹土中。见诸菩萨现正等觉。恭敬供养尊重赞叹。六者于一佛刹身相不动。能于无量佛刹土中示诣道场。七者于一佛刹身相不动。能于无量佛刹土中。自现等觉令他皆见。八者于一佛刹身相不动。能于无量佛刹土中转正法轮。九者于一佛刹身相不动。能于无量佛刹土中示般涅槃。十者于一佛刹身相不动。能于无量佛刹土中。从初发心乃至成佛。经尔所时观诸有情应调伏者。即能现作种种变化而调伏之。菩萨虽现如是变化。而不分别我能变化。于所变境亦不分别。如是之事我所化作。止盖菩萨白佛言。世尊。菩萨能作种种变化。云何于此能化之者及所化事得无分别。佛言。善男子。我今为汝当说譬喻。汝应谛听。善男子。譬如日月光耀四洲。广能利益诸有情等。而彼日月。虽能利益一切有情。而不分别我为能耀。亦不分别彼有情等以为所耀。然日月天子。由其往昔异熟业成。能作如是利有情事。善男子。诸菩萨等亦复如是。虽种种变化而无功用。于能化所化不起分别。我是能化有情为所化。何以故。如是种种变化之事。一一皆是菩萨善业得成熟故。由昔修行发如是愿作如是事。以此故得于能化所化离于分别。善男子。菩萨成就此十种法得变化善巧

复次善男子。菩萨成就十种法。速疾能于无上菩提而现等觉。何等为十。一者得具足施。以善积集成就施故。二者得具足戒。成就净戒无有缺漏亦无杂染。超过一切声闻缘觉。三者具足安忍。四者具足正勤。五者具足静虑。六者具足般若。七者具足方便。八者具足胜愿。九者具足诸力。十者具足正智。菩萨以能成就智故。起过一切声闻辟支佛地。由能成就不共智故。又能超过菩萨初地。乃至能超于第九地。由菩萨得智具足故。善男子。菩萨成就此十种法故。能速疾于无上菩提而现等觉。世尊。说此法门之时。此三千大千世界六种震动。又此世界所有苏迷卢山。及牟真邻陀山。摩诃牟真邻陀山。轮围山。大轮围山。及宝山等一切诸山。为供养佛故。峰岫低屈向伽耶山。又此世界所有一切花果树等。悉皆低屈向伽耶山。供养于佛及供养法。复有无量百千俱胝那庾多菩萨。以种种衣服诸庄严具。其积量如苏迷卢山供养佛法。复有无量百千俱胝释梵护世。合掌向佛恭敬礼拜。以曼陀罗花摩诃曼陀罗花散于佛上。复有无量百千天子。于虚空中各执天衣。举手旋转作百千种声。以诸天花散于佛上而作是言。过去诸佛已出世间转正法轮。世尊。今者又复出现转妙法轮。若诸有情曾于过去供养诸佛。修行福业积集善根。如是有情。今时方得闻此法门。何况闻已深生净信。复有无量百千莫呼洛伽。亦为供养此法门故出大音声。犹如雷震其声普遍。复变化作种种香云雨诸香水。其雨遍此三千大千世界。及伽耶山顶。亦不娆乱诸有情类。复有无量百千诸龙婇女。于世尊前作种种音乐赞叹供养。复有无量百千健达缚紧捺洛。右绕三千大千世界及伽耶山。出美妙音赞叹供养。复有无量百千俱胝药叉。雨众莲花而为供养。复有无量百千诸婆罗门及刹帝利。以诸花鬘烧香和香涂香末香衣服花盖及诸幢幡而供养佛。复有无量世界之中所有诸佛。为供养释迦牟尼佛及供养法故。各放眉间光明。其光明中现种种色种种形种种光。谓青黄赤白及红颇胝迦。所放光明其光右绕此大千界。而能破彼一切闇障。光复右绕伽耶山顶及如来身。然从世尊顶上而入。复有妙风所吹之处。触者安乐。世尊。说此法门之时。于众会中有七十二那庾多菩萨得无生法忍。无量百千俱胝那庾多有情。远尘离垢得法眼净。无量百千俱胝有情未发心者发菩提心。时伽耶山有一天女名曰长寿。久住此山。率其兵众将诸眷属来诣佛所。于众会中从坐而起。为供养佛。往自宫殿取供养具。还至佛所恭敬供养。而白佛言。我知世尊于过去世无量生中。常住在此伽耶之山。曾有七万二千诸佛。皆为世尊说此法门文句义理。今者世尊还住此山。而为我等说此法门所有文句。佛言。天女。汝今得闻如是法宝为大义利。尔时复有诸天子众作是思惟。此长寿天女经尔所时承事如来闻此法门。云何不能转此女身

尔时止盖菩萨知诸天子心所思惟。而白佛言。世尊。有何因缘。此长寿天女。经尔所时供养如来。复闻此法门大威神力。而今不能转此女身。佛言。善男子。此长寿天女。住不可思议解脱法门。为利益一切有情因缘故。善男子。我知此天女于往昔时。以能劝请超过算数诸佛如来发菩提心乃至涅槃故。此天女有大威德。于贤劫中供养诸佛。于此佛刹当现等觉。号长寿如来应正等觉。时薄伽梵。告天女言。天女。汝应示现自身佛刹。尔时天女。当即现入一切色身三摩地。入此定已时。此三千大千世界平坦如掌。吠琉璃宝以成此界。除去诸恶山石草木。处处示现诸劫波树流泉浴地八功德水充满池中。于其水上众花弥覆。复能除彼下劣有情。乃至不闻女人之名。处处示现种种莲花大如车轮。于莲花中有诸菩萨结加趺坐。亦复示现薄伽梵身。谓长寿如来应正等觉。为诸菩萨敷演妙法。无量百千俱胝那庾多释梵护世诸大菩萨。前后围绕说此法门。尔时长寿天女从定而起。于世尊前右绕三匝。大众之中隐没不现

止盖菩萨白佛言。世尊。若有善男子善女人。闻此法门若能受持若读若诵。若复思惟为他广说。如是之人生几所福。佛言。善男子。若有人能布施三千大千世界一切有情。如是布施相续不断。经于无量百千诸劫。若善男子及善女人。有能书写如此法门。善详校已能施与他生净信者。是人功德胜前福德。何以故。善男子。以彼财施是下劣之法有灭坏故。法施殊胜有大威力。何以故。善男子。以诸有情染着财产。经无量时生死流转。乐世间法终不能受广大法味。善男子。若有能以三千大千世界中所有众生。皆能安置于十善道。复有能于此殊胜法门听闻读诵思惟修习为他演说。是人功德胜前福德。何以故。善男子。十善业道因此法门而出生故。善男子。若复有人教化三千大千世界一切有情。皆得声闻辟支佛果。若有闻此法门受持读诵思惟修习为他广说。是人功德胜前福德。何以故。善男子。依此法门得诸声闻辟支佛果。又依此法门得诸菩萨及出世间诸佛之果。善男子。若能听闻受持读诵此法门者。此人即是已于一切素怛缆中受持读诵。何以故。以此法门是诸法母。善男子。非不得此法性而能证得广大法性。尔时诸大声闻承佛威神。从坐而起偏袒右肩右膝着地。恭敬合掌。而白佛言。世尊。我等闻此法门。必定能出广大生死。佛言。诸苾刍。如是如是如汝所说

尔时薄伽梵告大众言。善男子。若于如是诸地方处说此法门。当知其地是菩提道场转法轮处。又应思惟。其地即是大制多处。亦是我等一切导师在中而住。何以故。善男子。以法性即是大菩提故。亦是转法轮故。又法身即是诸如来故。若供养法即是供养一切如来。若说法师所在地方。当于此处起制多想。于法师处起尊重想。起善知识想。起于演说正道路想。若见法师。应当欢喜。净信悦乐。邀请上座恭敬供养赞叹善哉。善男子。我若赞说法师功德。乃至劫尽亦不能说少分功德。何以故。若有善男子善女人爱乐法者。于说法师所行之处。以自身血洒其道路。亦不能报彼说法师少分恩德。何以故。以说法师即能住持如来法眼甚希有故。善男子。诸说法师。若欲说此法门之时。若正说若已说应现无畏不应沉没。不现忧恼无损害心。着新净衣应生净信。他赞叹时。不应倨傲。不起我慢。不自赞毁他。无所悕望。应常恭敬演说此法

尔时释提桓因白佛言。世尊。若诸地方有能说此法门之处。我当将诸兵众。及与眷属往诣其处。为欲听闻此法门故。及能守护彼说法师。佛言。憍尸迦。善哉善哉。汝今正应作如是事。汝当守护如来法性

尔时止盖菩萨白佛言。世尊。当何名此法门。我等云何受持。佛言。善男子。此名宝雨法门。亦名宝积功德。亦名智灯。亦名止一切盖菩萨所问法门。汝当受持。时薄伽梵。说此经已欢喜无量。止一切盖及诸菩萨。一切声闻释梵护世。及大自在净居诸天。无量百千天子。及诸天龙药叉健达缚阿素洛揭路荼紧捺洛莫呼洛伽。闻佛所说欢喜奉行

佛说宝雨经卷第十


佛说报恩奉盆经(亦云报像功德经)

    No. 686 [No. 685]

佛说报恩奉盆经(亦云报像功德经)

        阙译附东晋录

闻如是。一时佛在舍卫国祇树给孤独园。大目揵连始得六通。欲度父母报乳哺之恩。即以道眼观视世界。见其亡母生饿鬼中。不见饮食皮骨相连柱。目连悲哀即钵盛饭往饷其母。母得钵饭。便以左手障饭右手搏食。食未入口化成火炭遂不得食。目连驰还白佛。具陈如此。佛告目连。汝母罪根深结。非汝一人力所奈何。当须众僧威神之力。乃得解脱。吾今当说救济之法。令一切难皆离忧苦

佛告目连。七月十五日当为七世父母在厄难中者。具糗饭五果汲灌盆器。香油庭烛床榻卧具。尽世甘美以供养众僧。当此之日。一切圣众或在山间禅定。或得四道果。或树下经行。或得六通飞行。教化声闻缘觉。菩萨大人权示比丘在大众中。皆共同心受钵和罗。具清净戒圣众之道其德汪洋。其有供养此等之众。七世父母五种亲属。得出三涂应时解脱衣食自然。佛敕众僧。当为施主家七世父母。行禅定意然后食此供。目连比丘及一切众欢喜奉行佛说报恩奉盆经


佛说孛经

    No. 790

佛说孛经抄

        吴月支国居士支谦译

闻如是。一时佛在舍卫国。大子名只。有园田八十顷。去城不远。其地平正。多众果树。处处皆有流泉浴池。其池清净。无有蚑蜂蚊虻蝇蚤。居士须达。身奉事佛。受持五戒。不杀不盗不淫不欺不饮酒。见谛沟港。常好布施。赈救贫穷。人呼为给孤独氏。须达欲为佛起精舍。周遍行地。唯祇园好。因从请买。太子只言。能以黄金布地。令间无空者。便持相与。须达曰诺。听随买数。只曰我戏言耳。讼之纷纷。国老谏曰。已许价决。不宜复悔。遂听与之。须达默念何藏金足。只谓其悔嫌贵自止。曰不贵也。自念当出何藏金耳。即时使人象负金出。随集布地。须臾满四十顷。只感念佛必有大道故使斯人轻宝乃尔。教齐是止。勿复出金。园地属卿。我自欲以树木献佛。因相可这便立精舍已。各上佛。佛与千二百五十沙门。俱止其中。是故名祇树给孤独园也

其王名卑先匿。举宫中及人民。皆共事佛。奉诸沙门。衣食床卧疾药所宜。世无佛时诸道皆兴。譬如昏夜炬烛为明。天下有佛。众邪皆歇。喻若日出火无复光。国中本共。事五百异道人。异道众邪。是时皆废。诸异道人。乃共嫉妒。谋欲毁佛以望敬事。其女弟子名酸陀利曰。师莫愁也。我能令人不复敬佛。事师如故。便从今始。欲日日庄严往来佛边诸沙门所。至一月后。可默杀我埋祇树间。佯行求索。众人当言。数见此女往来精舍。即诣王告。乞吏搜索。啼哭出尸。道其淫乱无戒行意。国人闻是。必当舍佛来事诸师。诸师曰善。女如其言。往来一月。师使四人共杀埋之。分布求已。诣阙告言。生亡一女。众人悉见。日日往来诸沙门所。乞吏搜求。王即敕外部吏。与行诸师。乃佯徘徊再三过。出尸舆载。遍行啼哭曰。沙门之法。戒当清净。反淫人妇。恐事发觉。杀而藏之。有何道哉。国人闻此。多有信者。惟得道之人。知谄伪耳

佛于是乃敕诸沙门。且勿入城。七日之后。事情当露。至八日旦。佛使阿难。巷至说曰。妄语谗人。天令口臭。诈诬清白。死入地狱。痴虐自怨。长夜受苦。国人闻是语。皆相谓曰。沙门必清净。故佛说此语耳。王使人微密伺之。见异道家。窃相劳贺。共赐四人。异道人法。知经多者得分多。一人顽闇。得分独少。怒曰当反汝事自共杀人。而诈诬佛。反与我少。伺人得之。牵将上闻。到以实对。即收谋者。王与群臣。俱出诣佛。给孤独氏。诸清信士。及国人民无数。皆行诣佛。到已作礼毕。各一面坐。王叉手白佛言间闻此谤。莫不罔然。唯佛至真。清净无量。不识其故。何缘有此。佛告王曰。诽谤之生。皆由贪嫉。而此久有。非这今也。王曰愿欲闻之。佛言我宿命无数世时。我为菩萨道。常行慈心。欲度脱万姓。时有蒱邻奈国。广博严好。人民炽盛。中有梵志。姓瞿昙氏。才明高远。国中第一。有三子。其小子者。端正无比。父甚奇之。为设大会。请诸道人。中外亲戚。抱儿示之。众师相曰。是儿好道。有圣人相。必为国师。因名为孛。孛幼好学。才艺过人。悉通众经。及天下道术九十六种。死生所趣。山崩地动。灾异祸福。医方镇厌。无所不知。能却淫心。消伏蛊道。武略备有。而性慈仁。瞿昙没后。二兄嫉之。数求分异曰。孛幼好学。事师消费。与分当少。母怜念之。数晓二子。二子不止。孛见兄意盛。自念人生。皆为贪苦。我若不去者。兄终不息。因自报母。求行学道。母便听之。孛即去近。明师作沙门。于山中自得四意止。一慈众生。如母爱子。二悲世间。欲令解脱。三解道意。心常欢喜。四为能护一切不犯。复得四意。诸佛所誉。一制贪淫二除恚。怒三去痴念。四得乐不喜逢苦不忧。又绝五欲。目不贪色。耳不贪声。鼻不贪香。舌不贪味。身不贪细滑能以智慧方便之道。顺化天下。使行十善。孝顺父母。敬事师长。诸疑惑者。令信道德。知死有生。作善获福。为恶受殃。行道得道。见忧厄者为解免之。疾病者为施医药。服孛教者。死皆生天。其有郡国水旱灾异。孛至即平。毒害悉除

时有大国。安乐饶人。王名蓝达。所任四臣。专行邪谄。淫盗奸欺。侵夺无厌。民被其毒。王不觉知。孛愍伤之。往到城外。从道人沙陀。寄止七日。乃入城欲乞食。王于观上。见孛年少。仪容端政。行步有异。心甚爱敬。即出问讯。王曰。愿道人留意。我有精舍近在城外。可于中止。当给所须。孛曰诺。王喜曰。意欲相屈。明日已去。日日于宫食。孛曰善。王还向夫人说。孛非恒人。汝明日当见之。夫人心喜。床下有犬。犬名宾只。闻之亦喜。明旦孛来入宫。王与夫人迎为作礼。与施金床。[毯-炎+瞿]毹毾[毯-炎+登]。孛欲就坐。犬前舐足。王自起行澡水。敬意奉食。已而俱出。到外精舍。孛为王说治国政法。王大喜欢因请孛留。令与四臣共治国事。四臣愚怯。不习战阵。自知贪浊。常恐王闻。一臣曰人死神灭。不复更生。一臣曰贫富苦乐。皆天所为。一臣曰作善无福为恶无殃。一臣自恃知占星宿。然皆佞谄。不为忠政。孛性聪明。高才勇健。仁义恭敬。信顺寡言。言常含笑。不伤人意。清净无欲。节色少事。其政不烦。豫知灾异。能役使鬼神。却起死人。爱民如子。教之以道。不得讻醟。游猎畋渔。弹射鸟兽。杀盗淫欺。谗骂佞嫉。诤怒妖疑。皆化使善。其为政后。国界安宁。风雨时节。五谷丰熟。众官承法。不复扰民。索体无为。独贵奉佛。沙门四道。朝暮诵习。及其姊子。亦贤有志。常师仰孛。国好学者。多依附之。王无复忧。一以委孛。四臣畏忌。不得纵撗兴嫉妒意。谋欲治孛。共合财宝人一亿数。伺王出时。以上夫人。而自陈曰。臣等至意奉家所有。及身妻子。当为奴婢。欲白一事。愿蒙听省。夫人贪得受其好宝。答谢四臣曰。便说之。四臣对曰。王所奉孛。被服粗陋。似乞人耳。见住过重。不念国恩。日导夫人恶教。王远房室。窃念夫人。宜及少壮。当有立子。念若失时。则绝国嗣。愿熟思惟。不除孛者。恐后有悔。夫人恚曰。王信此人。不知其恶。各且还归。今自忧之。比令明日使不见孛也。夫人遣四臣出。即以栀子黄面乱头却卧。须臾王还。内妓白王。夫人不乐。王素重之。入问再三。夫人不应。王即怒曰。何人有罪。应诛戮者。汝欲使我罪谁那尔。夫人垂泣曰。王会不用我言耳。王曰便说。不违汝也。夫人即白。王旦这出。孛来谓我。今王老耄。不能听政。国中吏民。皆伏从我。可以图之共此乐也。今反为此乞人所谋。故我愁耳。王闻是语。譬若人噎。既不能咽。亦不得吐。不用恐悔。用之恐乱。念孛助我。已十二年。常以忠政。忧国除患。远近赖之。此国之宝。不可治也。王曰今治孛者。后必大乱。为万民故。且共忍之。夫人便自掷床下。举声哭曰。不治孛者。我当自刺。自投楼下。不能见也。王复晓曰。汝亦知法。此非小事。起共议之。夫人还坐。王曰。道人之法。不可以刀杖加之。当以渐遣。稍减其养。明日来者。勿复作礼。擎卷而已与施木床于殿下坐。炊恶厮米。盛以瓦器。如是惭愧。极自当去。王说此时。宾只不悦。夫人明旦。即以王教。具敕内厨。孛来入宫。宾只于床下。啀喍吠之。孛见狗吠。夫人擎卷。及所施设。即知有谋。自念我欲无害于人。人反害我。如是当避入深山耳。小怨成大。不可轻也。彼以阴谋我宜慎之。凡人身羸行正为强。今我自有食钵水瓶革蓰伞盖漉水之囊。斯足用矣。孛食已摄物欲去。王惊起曰。是何疾也。顾谓夫人。乃使我失圣人之意。即前牵孛。问欲何之。孛答曰。为王治国。十二年矣。未曾见宾只啀喍如今也。是必有谋。故欲去耳。王曰实有。今见孛意。觉微甚明。愿自敕厉。当诛恶人。不须去也。孛曰。王前意厚。而今已薄。及我无过。宜以时去。夫盛有衰。合会有离。善恶无常。祸福自追。结友不固。不可与亲。亲而不节。久必泄渎。如取泉水。掘深则浊。近贤成智。习愚益惑。数见生慢。疏则成怨。善友接者。往来以时。亲如有敬。久而益厚。不善友者。假求不副。巧言利辞。苟合无信。接我以礼。当以敬报。待我以慢。当即远避。有相亲爱。回相憎者。爱时可附。憎不可近。敬以亲善。戒以远恶。善恶无别。非安之道。人无过失。不可妄侵。恶人事已不可纳。前人欲疏已不可强亲。恩爱已离。不可追思。鸟宿枝折。知更求栖。去就有宜。何必守常。朽枝不可攀。乱意不可犯。人欲相恶。相见不欢。唱而不和。可知为薄。人欲相善。缓急相赴。言以忠告。可知为厚。善者不亲。恶者不疏。先敬后慢。贤愚不别。不去何须。夫人初拜。今但擎卷。若我不去。将见骂逐。初施金座。今设木床。初盛宝器。今用瓦瓯。初饭粳粮。今恶厮米。我不去者。且饭委地。知识相遇。主人视之。一宿如金。再宿如银。三宿如铜。证现如此。不去何待。王曰。国丰民宁。孛之力也。今弃去者。后将荒坏。孛曰。天下有四自坏。树繁花果。还折其枝。虺蛇含毒。反贼其躯。辅相不贤害及国家。人为不善。死入地狱。是为四自坏。经曰

  恶从心生　　反以自贼　　如铁生垢
  消毁其形

王曰。国无良辅。实须恃孛。若欲相委。是必危殆。孛曰。凡人有四自危。保任他家。为人证佐。媒嫁人妻。听用邪言。是为四自危。经曰

  愚人作行　　为身招患　　快心放意
  后致重殃

王曰。我师友孛。常在不轻。当原不及。莫相捐去。孛曰。友有四品。不可不知。有友如花。有友如称。有友如山。有友如地。何谓如花。好时插头。萎时捐之。见富贵附。贫贱则弃。是花友也。何谓如称。物重头低。物轻则仰。有与则敬。无与则慢。是称友也。何谓如山。譬如金山。鸟兽集之。毛羽蒙光。贵能荣人。富乐同欢。是山友也。何谓如地。百谷财宝。一切仰之。施给养护。恩厚不薄。是地友也。王曰。今我自知。志思浅薄。听用邪言。使孛去也。孛曰。明者有四不用邪伪之友。佞谄之臣。妖[薛/女]之妻。不孝之子。是为四不用。经曰

  邪友坏人　　佞臣乱朝　　[薛/女]妇破家
  恶子危亲

王曰。相与爱厚。宜念旧好。不可孤弃也。孛曰有十事知爱厚。远别不忘。相见喜欢。美味相呼。过言忍之。闻善加欢。见恶忠谏。难为能为。不相传私。急事为解。贫贱不弃。是为十爱厚。经曰

  化恶从善　　切磋以法　　忠正诲励
  义合友道

王曰。四臣之恶。乃使孛恚。不复喜我。孛曰。有八事知不相喜。相见色变。眄睐邪视。与语不应。说是言非。闻衰快之。闻盛不喜。毁人之善。成人之恶。是为八事。经曰

  平斗杀人　　尚有可原　　怀毒阴谋
  是意难亲

王曰。是我顽弊。不别明闇。恶人所误。遂失圣意。孛曰。有十事知人为明别贤愚。识贵贱。知贫富。适难易。明废立。审所任。入国知俗。穷知所归。博闻多识。达于宿命。是为十事。经曰

  缓急别友　　战斗见勇　　论议知明
  谷贵识仁

王曰。自我得孛。中外怗安。今日相舍。永无所恃。孛曰。有八事可以怗安。得父财。有善业。所学成。友贤善。妇贞良。子孝慈。奴婢顺。能远恶。是为八事。经曰

  生而有财　　得友贤快　　诸恶无犯
  有福祐快

王曰。圣人之言。诚无不快。孛曰有八事快。与贤从事。得咨圣人。性体仁和。事业日新。忿能自禁。虑能防患。道法相亲。友不相欺。是为八事。经曰

  有佛兴快　　演经道快　　众聚和快
  和则常安

王曰。孛常易谏。今何难留。孛曰。有十不谏悭贪。好色。朦笼。急暴。抵突。疲极。憍恣。喜斗专愚。小人。是为十。经曰

  法语专愚　　如与聋谈　　难化之人
  不可谏晓

王曰。如我憍恣。不能远色。孛得无为。不复与我语乎。孛曰。人不与语有十事。骜慢。鲁钝。忧怖。喜预。羞惭。吃[口*刃]。仇恨。冻饿。事务。禅思。是为十事。经曰

  能行说之可　　不能勿空语
  虚伪无诚信　　明哲所不顾

王曰。恶妇美姿。巧于辞令。如有外劮。卒何用知孛曰。有十事可卒知。头乱髻倾。色变流汗。高声言笑。视瞻不端。受彼宝饰。窥看垣墙。坐不安所。数至邻里。好出野游。喜通淫女。是为十事。经曰

  妇女难信　　利口惑人　　是以高士
  远而不亲

王曰。人情所近。亲信妇人。不知其恶。孛曰。人有十事不可亲信。主君所厚。妇人所亲。怙身强健。恃有财产。大水渍处。故屋危墙。蛟龙所居。辜较县官。宿恶之人。毒害之虫。是为十。经曰

  谓酒不醉　　谓醉不乱　　君厚妇爱
  皆难保信

王曰。如孛所语。爱习生恶。是可嫉也。孛曰。可嫉有五。粗口伤人。谗贼喜斗。焦哓不媚。嫉妒咒诅。两舌面欺。是为五。经曰

  施劳于人　　而欲蒙祐　　殃及其躯
  自遘广怨

王曰。何所施行人所爱敬。孛曰。爱敬有五。柔和能忍。谨而有信。敏而少口。言行相副。交久益厚。是为五。经曰

  知爱身者　　慎护所守　　志尚高远
  学正不昧

王曰。何者为人所慢孛曰。见慢有五。鬓长而慢。衣服不净。空无志思。淫态无礼。调戏不节。是为五。经曰

  摄意从正　　如马调御　　无憍慢习
  天人所敬

王曰。愿孛留意。共还精舍。孛曰有十。不延于堂恶师邪友。蔑圣反论。淫劮嗜酒。急弊长者。无反复子。妇女不节。婢妾庄饰。是为十。经曰

  远避恶人　　淫荒勿友　　从事贤者
  以成明德

王曰。孛在我乐四方无事。今日去者。国中必嗟。孛曰。有八事可以安乐。顺事师长。率民以孝。谦虚下下。仁和其性。救危赴急。恕己爱人。薄赋节用。赦恨念旧。是为八事。经曰

  修诸德本　　虑而后行　　唯济人命
  终身安乐

王曰。吾常念孛。岂有忘时。孛曰智者。有十二。念鸡鸣。念悔过作福早起。念拜亲礼尊临事。念当备豫所止。念避危害言语。念当至诚见过。念以忠告贫者。念哀给护有财。念行布施饮食。念以时节食人。念以平均御众。念用恩赐军具。念时缮治。是为十二。经曰

  修治所务　　虑其备豫　　事业日新
  终不失时

王曰。安得大贤。使留孛乎。孛曰。大贤有十行学闻高远。不犯经戒。敬佛三宝。受善不忘。制欲怒痴。习四等心。好行恩德。不扰众生。能化不义。善恶不乱。是为十行。经曰

  明人难值　　而不比有　　其所生处
  族亲蒙庆

王曰。我过重矣。畜养恶人。使孛恚去。孛曰大恶。有十五。好杀。劫盗。淫劮。诈欺。谄谀。虚饰。佞谗。诬善。贪浊。放恣。酗醟。妒贤。毁道。害圣。不计殃罪。是为十五。经曰

  奸虐饕餮　　怨谮良人　　行已不正
  死堕恶道

王曰。晓孛不止。使我惭愧。孛曰。有十可愧。君不晓政。臣子无礼。受恩不报。过不能改。两夫一妻。未嫁怀妊。习不成就。如人杖兵仗不能战斗。悭人观布施。奴婢不能使。是为十。经曰

  世傥有人　　能知惭愧　　是易诱进
  如策良马

王曰。吾始念曰。知有道者。为难屈也。孛曰。有十二难。任使专愚难。怯弱御勇难。仇恨共会难。寡闻论议难。贫穷负债难。军无师将难。事君终身难。学道不信难。恶望生天难。生值佛时难。得闻佛法难。受行成就难。是为十二。经曰

  人命难得　　值佛时难　　法难得闻
  闻能行难

王曰。今与孛谈。益我有智。孛曰。略说其要。人所当知有四十五事。修其室宅。和其家内。亲于九族。信于朋友。学从明师。事必成好。才高智远。宜守以善。富贵行恩。治产宜慎。有财当广方业。子幼勿付财。相善与交。苟合莫信。财在县官。当早忧出。卖买交易。以诚勿欺。凡所投止。必先行视。所往当知贵贱。入国当亲善人。客宜依豪。无与强诤。故富可求复。素贫勿大望。宝物莫示人。匿事莫语妇。为君当敬贤。厚勇取忠信。清者可治国。趣事能立功。教化之纪。孝顺为本。师徒之义。贵和以敬。欲多弟子。当务义诲。为医当有效验。术浅不宜施用。病瘦当随医教。饮食取节。便身知识美食当共。博戏莫财。命抵所施。假贷当手自付证佐。从正勿枉。无过谏怒。以顺避恶。以忍人无贵贱。性和为好。道以守戒。清净为上。天下大道。无过泥洹。泥洹道者。无生老病死。饥渴寒热。不畏水火。怨家盗贼。亦无恩爱。贪欲众恶。忧患悉灭。故曰灭度。王当自爱。我今欲退

王曰。孛欲去者。宁复有异诫乎。孛曰。譬如大水所荡突处。虽百岁后。不当于中立城郭也。其水必复顺故而来。宿恶之人。虽欲行善。故不当信。本心未灭。或复为非。不可不戒。人所欲为。譬如穿池。凿之不止。必得泉水。事皆有渐。智者见微。能济其命。如人健泅截流度也

王曰。前后所说。我皆贯心。举国士女靡不欢喜。旧恶低伏无敢言者。愿闻其言。傥遭异人。何知其明。孛曰。明者问对。种种别异。言无不善。师法本正。以此知之。明人之性。仁柔谨懿。温雅智博。众善所仰。无有疑也。观其言行。心口相应。省其坐起。动静不妄。察其出处。被服施为。可足知之。与明智谈。宜得其意。得其意难。如把刃持。毒不可不慎也。王曰。欲事明者。不失其意。为之奈何。孛曰。敬而勿轻。闻受必行。明者识真。体道无为。知来今往古。一归空无。人物如化。少壮有老。强健则衰。生者必死。富贵无常。是故安当念危。盛存无常。善者加爱。不善黜远。虽有仇恨。不为施恶。柔而难犯。弱而难胜。明人如是。不可慢也

王曰。尽心爱敬。以事明智。宁有福乎。孛曰。智者法圣以行其仁。乐开愚朦。成人之智。治国则以惠施为善。修道则以导人为正。国家急难则能分解。进退知时无所怨尤。恩广施大不望其报。事之得福终身无患。王其勿疑。治政之法。不可失道。劝民学善。益国最厚。王曰。谁能留孛。我心愁惨。忽忽如狂。垂泣向孛忏悔解过。孛曰。如人不能泅。不当入深水。欲报仇者。不当豫娆。亲厚中诤。后更相谢。虽知和解。善不如本无诤也。善不能赏。反听谗言。我如飞鸟。止无常处。道贵清虚。不宜人间如野火行。傍树为焦。激水破船。毒虫害人。与智从事。不当扰也。草木殊性。鸟兽类分。白鹤自白。鸬鹚自黑。我与彼异。无欲于世。如田家翁生习山薮。与之好衣为无益也。天下有树。其名反戾。主自种之。不得食实。他人窃取果则为出。今王如是。善安国者而见驱逐。佞伪败政反留食禄。宾客久留。主人厌之。我宜退矣。王曰。人命至重愿垂忆念。今欲自力事孛胜前。孛曰。王虽言之。犹不得施夫人意恶。我不宜留。天下家家。皆有炊食。沙门所以持钵乞者自乐除贪。全戒无为。远罪咎也。王曰。今孛既去。莫便断绝。愿时一来。使我不恨。孛曰。如俱健者。犹复相见。且欲入山。以修其志。夫近而相念恶。不如远而相念善。智者以譬喻自解。请说一事。譬如有人以蜜涂刀。狗得舐之。以伤其舌。坐贪小甜。不知疮痛。四臣如是。但美其口。心如利刀。王甚戒之。自今以后若有惊恐。常念孛者。众畏必除。孛复言曰鸱枭乐冢。群鼠粪居百鸟栖树。鹤处污池。物各有性。志欲不同。我好无为。如王乐国。器虽粗弊。不可便弃各有所贮。愚贱不肖。亦不可弃。各有所用。王当识此。我犹知人言意所趣。如鸟集树先后下枝。间关趣上。见宾只吠。以知中外有谋。意欲厌故更受新也。孛曰请退。即起出城。王与夫人。啼泣送之。人民大小。莫不号怨。王行具问孛。谁可信者。孛曰。我姊子贤善。可与咨议。时时共出。巡行国中。观民谣俗可知消息。王曰受教。即与傍臣人民。为孛作礼。于是别去孛去之后。四臣纵横于外。以佞辩为政。夫人于内。以妖蛊事王。王意迷惑。不复忧国。奢淫好乐。昼夜耽荒。众官群寮。发调受取。无有道理。正平市买。不复雇直。强者陵弱。转相抄夺。至相杀伤。不畏法禁。良民之子。掠为奴婢。六亲相失。迸窜苟活。灾异相属。王不能知。风雨不时。所种不收。国虚民穷。饥饿满道。歌咏怨声。感动鬼神。人民愁怖。亡去略尽。号泣而行莫不思孛。孛如鸧鹰。临众鸟上。压伏奸人。慈育民物。如天帝释

孛姊子道人。后适他郡。见国荒乱。聚落毁坏。人民单索。还为王说。大臣不政。放纵劫盗。掠杀无辜。残虐无道。人怨神怒。天屡降灾。远近皆知。而王不觉。今不早图。且无复民。王乃惊曰。果如孛戒。我所任者。如狼在羊中。知民当散。如犇车逸马。道人既告。何以教之。道人曰。孛去国乱。皆由奸臣。王宜更计。国尚可复。愿一循行。目见耳闻。当知其实。王即与道人私出。案行国界。见数十童女。年皆五六十。衣服弊坏。呼嗟而行。道人问曰。诸女年大。何以不嫁。答曰。当使王家穷困。如我快也。道人曰。汝言非也。王者位尊。何能忧汝。女曰不然。王治不政。使国饥荒。夜则困于盗贼。昼则穷于胥吏。衣食不供。谁当嫁娶我也。王复前行。见诸老母。衣不盖形。身羸目瞑啼哭而行。道人问曰。皆有何忧。答曰。当使国王穷盲。如我快耶。道人曰。是言非也。老自目瞑。王有何过。诸母曰。我夜为盗所劫。昼为吏所夺。穷行采薪。触犯毒螫。使我如此。非王恶耶。王复前行。见一女人跪构牛乳。为牛所踏。躄地骂曰。当踏王妇。如我快也。道人问曰。牛自踏汝。王家何过。答曰。王治不政。使国荒乱。盗贼不禁。令我善牛见夺。为弊牛所踏。非王恶耶。道人言。汝自无德不能构牛。女曰。不然。若王家善。孛自当留。国不乱也。王复前行。见乌啄虾蟆。虾蟆骂曰。当使恶王见啖。如我快也。道人曰。汝自为乌所啖。王当护汝耶。答曰。不望护也。王无恩泽。政治不平。祭祀废绝。天旱水竭。故使我身乌见啖耳。虾蟆唤曰。知为政者。弃一恶人。以成一家。弃一恶家。以成一乡。不知政者。民物失所。天下怨讼。道人曰。百姓无罪。呼嗟感天。神使虾蟆降语如此。王自具见。宜退恶人。改往修来。与民更始。如种善地。雨泽以时何忧不熟。王曰。今当任谁。道人言宜急请孛。孛仁圣知时。反国必安。王还即遣使者。入山请孛言。若孛不还者。当向叩头道。我自知怨负万民。忧不能食。须待孛到。孛素慈仁。忧念十方。知我国荒。想必来也。使者受命。往到孛所。稽首白言。大王殷勤致敬无量。自知罪过深重。违失圣意。使国荒乱。百姓穷困。涕泣思孛。不能饮食。愿垂愍念。一来相见也。孛哀人民故。随使者还。道见死猕猴。故剥取其皮。欲以生语。国人闻孛来。皆出界迎。孛到城外。止故精舍。王出相见。作礼问讯毕一面坐。叉手谢孛言。空顽不及虐负万民。请自悔励幸遂原之。孛曰甚善。四臣过耳语。孛曰。卿等无过。何不公谈。四臣恚曰。凡为沙门。欲望天福。人皆称善。不当杀猕猴取其皮也。孛曰。卿等自迷惑。不别真伪耳。是非好恶。天悉知之。苦乐有本。不可强力。为恶罪追。虽久不解。作善福随。终不败亡。祸福在己。愚谓之远。以我剥皮。而杀猕猴。难此似是。卿曹默默。为奸不止相教事耶。言命在天。谓善无益。为恶无殃祸福之报。自然如响。响应随声。非从天堕。卿等作恶。岂不自识。虽欲诬之自然不听。此非谏我。为自中耳。卿一人言。人死神灭。不复生者。是圣语耶。从意出乎。自欲为恶。反言作善无福。为恶无殃。夫天之明象。日月星辰。列现于上。谁为之者。四臣默然。孛复曰。天地之间。一由罪福。人作善恶。如影随形。死者弃身。其行不亡。譬如种谷。种败于下。根生茎叶。实出于上。作行不断。譬如灯烛展转然之。故炷虽消火续不灭。行有罪福。如人夜书火灭字存。魂神随行。转生不断。卿曹意志。自以为高。如人杀亲可无罪乎。四臣答言。夫荫其枝者不摘其叶。何况杀亲而当无罪。孛曰。然卿难我似是。吾取死皮。而尚讯之。卿曹所为法当云何。卿一人言。人死神灭不复生。一人言。苦乐在天。一人言。作善无福。为恶无殃。一人自怙。知占星宿。外阳为善。内阴为奸。譬如伪金其中纯铜。貌饰美辞。心行谗贼。如狼在羊中。主不能觉天下恶人。亦称为道。被发卧地。道说经戒。专行谄欺。贪利欲。得愚人信伏。如雨掩尘。群妖相厌。如水流溢。不时入海。多所伤败。惟有圣人。能济天下。化恶授善。莫不蒙祐。若善无福。恶无殃者。古圣何故。造制经典。授王利剑。夫行有报。其法自然。善者受福。恶者受殃。天之所疾。祸无久迟。阴德虽隐。后无不障。故国立王。王政法天。任贤使能。赏善伐奸。各随其行。如响应声。人死神去。随行往生。如车轮转。不得离地。信哉罪福。不可诬也。人行至诚。鬼神助之。恶虽不觉。终必受殃。故当戒慎。远恶知惭。若皆为善。禀气当同。不善者多。或有不平。或寿不寿。多病少病。丑陋端正。贫富贵贱。贤愚不均。至有盲聋喑哑跛蹇隆残。百病皆由宿命行恶所致。其受百福。人所乐者。则是故世行善使然。积德忠政。故有日月星辰。有天有人。帝王豪贵。是明证也。何可言无。宜熟思之。勿谓不然。孛说是时。王与臣民。无不解悦。孛复曰。古昔有王。名为狗猎。池中生甜鱼。甘而少骨。王使一人监护。令日献八鱼。其监亦日窃食八鱼。王觉鱼减。更立八监。使共守护。八监。又各日窃八鱼。守之者多。鱼为之尽。今王如是。所任不少。为乱益甚。譬如人摘生果既亡其种食之无味。王欲为治。不用贤人。既失其民。后又无福。治国不正。则使天下有诤夺之心。如人治产。不勤用心。则财日耗。国有勇武习战阵者。不足其意则弱其国。为王不敬道德。不事高明。生则贤者不归。死则神不生天。掠杀无辜。使天下怨讼。则天降灾。身失令名。治国以法。为政得忠。敬长爱少。孝顺奉善。现世安吉。死得生天譬如牛行其道直正余牛皆从。尊贵有道。率下以正。远近伏化。则致太平。为君当明探古达今。动静知时。刚柔得理。惠下利民。有施平均。如是则世世豪贵。后可得泥洹之道。众坐皆喜。称善无量。王即避坐。稽首白言。今孛所语。譬如疾风吹却云雨。幸卒慈念。垂化如前。孛即起行。随王入宫。四臣愚痴。于是见废。孛复治国。恩润滂流。风雨时节。五谷丰熟。人民欢喜。四方云集。上下和乐。遂致太平。佛言。时孛者。今我身是也。姊子道人。则阿难是。时王蓝达。今卑先匿是。时夫人。则好首是。时犬宾只者。车匿是。时四大臣。则今四道人杀好首者。是时语虾蟆者。今得罗汉沤陀耶是。我为菩萨。世世行善。勤苦积德。无央数劫。为万民故。今自致得佛。所愿皆得。诸值我时闻经法者。宜各精进为善勿懈。佛说是已。有三亿人。得践道迹。皆受五戒。欢喜奉行佛说孛经抄


佛说不思议功德诸佛所护念经

    No. 445

佛说不思议功德诸佛所护念经卷上

        曹魏代失译人名

东方去是百千万亿江河沙诸佛土解君世界宝光月殿妙尊音王如来　东方去是百八万亿江河沙诸佛土净光庄严世界净华宿王智如来　东方去是百亿江河沙诸佛土超立愿世界普照常明德海王如来　东方喜信净世界光英如来　东方解脱华世界师子响作如来　东方普光世界天王如来　东方多乐世界虚空等如来　东方宝积世界宝扬威神超王如来　东方常名闻世界离闻首如来　东方宝严世界喻日光王如来　东方莲华浮世界净教如来　东方寂寞世界一亿诸佛普集如来　东方清净世界日月光如来　东方拔众尘劳世界等行如来　东方阿毗罗提世界大目如来　东方须弥幡世界须弥灯王如来　东方不眴世界普贤如来　东方思惟世界无念如来　东方甘音声称说世界过宝莲华快住树王如来　东方莲华香世界过宝莲华如来　东方无诸毒螫世界本草树首如来　东方除狐疑世界等功德明首如来　东方内快世界分别过出净如来　东方爱喜世界等遍明如来　东方爱乐世界月英幢王如来　东方不可胜说世界快乐如来　东方解脱世界解散一切缚具足王如来　东方满香名闻世界莲华具足王如来　东方满一切珍宝世界药师具足王如来　东方乐入世界无忧德首具足王如来　东方欢喜世界劝助众善具足王如来　东方慈哀光明世界绀琉璃发勇猛具足王如来　东方满所愿聚世界安隐嘱累满具足王如来　东方不退音世界最选光明莲华开敷如来　东方清净世界精明堂如来　东方无量德净世界净王如来　东方多宝世界宝积如来　东方无垢世界离垢意如来　东方香林世界入精进如来　东方离垢世界无垢光如来　东方欢喜世界阿閦如来　东方甚乐世界仙刚如来　东方坏调世界思夷华如来　东方莫能胜世界固进度思吉义如来　东方闻迹世界奉至诚如来　东方吉安世界观明功勋如来　东方无恚恨世界慈英寂首如来　东方五杖世界真性上首如来　东方炽上首世界念众生称上首如来　东方曜赫热首世界勇首超高须弥如来　东方爱喜世界称耻胜上首如来　东方天神世界宝海如来　东方宝集世界宝英如来　东方宝最世界宝成如来　东方光明世界宝光明如来　东方幢幡世界宝幢幡如来　东方众德光明世界宝光明如来　东方无量世界大光明如来　东方众华世界无量音如来　东方无尘垢世界无量音如来　东方莫能胜世界大名称如来　东方光明世界宝光明如来　东方名光世界德大光隐如来　东方华尼光世界火光明如来　东方正直世界正音声如来　东方光明尊世界无限净如来　东方音响世界月音王如来　东方安隐世界无限名称如来　东方日世界月光明如来　东方清净世界无垢光如来　东方琉璃光世界净光如来　东方大丰世界日光如来　东方正觉世界无量宝如来　东方莲华光世界莲华最尊如来　东方普度众难世界身尊如来　东方坚固世界金光如来　东方无际世界梵自在如来　东方月世界紫金香如来　东方火光世界金海如来　东方正觉世界龙自在王如来　东方喻月世界一切华香自在王如来　东方星王世界树王如来　东方勇猛执持器杖弃舍战斗如来　东方丰饶世界内丰珠光如来　东方香熏世界无量香光明如来　东方龙珠观世界师子响如来　东方修行世界大精进勇力如来　东方坚住世界过出坚住如来　东方光明世界鼓音王如来　东方众德吉世界日月英如来　东方栴檀地世界超出众华如来　东方善住世界世灯明如来　东方光明世界休多易宁如来　东方围绕世界宝轮如来　东方善觉世界常灭度如来　东方须弥胁世界净觉如来　东方名称世界无量宝花光明如来　东方妙濡世界须弥步如来　东方丰养世界宝莲华如来　东方莲华勇出世界一切众宝普集如来　东方金光世界树王丰长如来　东方清净世界转不退转法轮众宝普集丰盈如来　东方净住世界围绕特尊德净如来　东方杂相世界上众如来　东方流布世界佛华生德如来　东方金刚住世界佛华出王如来　东方栴檀世界宝像如来　东方药世界不虚称如来　东方药生世界无边功德精进严如来　东方上华光世界明德王如来　东方妙庄严世界德王明如来　东方无边德严世界度功德边如来　东方流布世界然灯如来　东方上善世界无畏如来　东方莲华世界华德如来　东方优钵罗世界智华德如来　东方宝生世界宝积如来　东方妙月世界无边愿如来　东方住林世界宝肩如来　东方众香世界娑罗王如来　东方华德世界宝明如来　东方一聚世界宝聚如来　东方离忧世界无边德严如来　东方诸功德处世界观世音如来　东方宝明世界须弥明如来　东方庄严世界无边自在力如来　东方无尘垢世界宝华德如来　东方云阴世界无量神通自在如来　东方普香世界无量华如来　东方华世界宝自在如来　东方杂宝相世界月出德如来　东方金刚世界拘陵王如来　东方乐世界日灯如来　东方安隐世界上宝如来　东方娑婆世界智生德如来　东方纯乐世界安立功德王如来　东方宿开世界无碍明如来　东方月出世界智聚如来　东方清净世界无相严如来　东方普明世界明德聚如来　东方欢喜世界那罗延如来　东方离垢世界离垢相如来　东方无边德世界善思严如来　东方安隐世界优钵罗德如来　东方常照明世界香弥楼如来　东方常庄严世界杂华如来　东方阿竭流香世界上香德如来　东方普香世界香弥楼如来　东方无相世界无相音如来　东方名华世界无碍音声如来　东方月世界纯宝藏如来　东方坚固世界无动力如来　东方坚固世界迦叶如来　东方众月世界善生德如来　东方离忧世界名称如来　东方离尘垢世界智德如来　东方杂华世界宿王如来　东方极广世界无量相如来　东方恐怖世界栴檀香如来　东方众网世界网明如来　东方无畏世界梵音如来　东方可归世界无量性德如来　东方离垢世界智出光如来　东方青莲华覆世界华上如来　东方无忧世界善德如来　东方无胜世界德胜如来　东方随喜世界普明如来　东方普贤世界胜敌如来　东方善净世界王幢相如来　东方离垢世界无量功德明如来　东方不诳世界药王无碍如来　东方金集世界宝游行如来　东方美音世界宝华如来　东方一盖世界一宝严如来　东方宝聚世界无边宝力如来　东方相德聚世界无相音如来　东方大名闻世界须弥肩如来　东方上意世界空性如来　东方沙陀罗尼世界名闻力王如来　东方月光世界放光如来　东方袈裟相世界离垢如来　东方莲华世界杂华生德如来　东方一盖世界离怖畏如来　东方清净世界智聚如来　东方香聚世界栴檀香如来　东方阿竭流香世界大声眼如来　东方无边聚世界宝积如来　东方众香世界香象如来　东方离相世界弥楼肩如来　东方华盖世界一宝盖如来　东方普明世界无碍眼如来　东方名善世界栴檀窟如来　东方善意世界妙肩如来　东方宝德世界网明如来　东方德乐世界宝华德如来　东方赞叹世界智华宝明德如来　东方众善世界善出光如来　东方安隐世界灭诸怖畏如来　东方弥楼相世界弥楼肩如来　东方度忧恼世界安王如来　东方善法世界法积如来　东方安立世界增十光如来　东方千明世界增千光如来　东方多伽楼香世界智光如来　东方妙香世界宝出光如来　东方明严德世界无边光如来　东方善德世界无碍如来　东方法世界网光如来　东方众华世界宝意如来　东方上清净世界无边际如来　东方优钵罗世界无边自在如来　东方觉处世界优钵罗德如来　东方莲华处世界智住如来　东方智力世界释迦牟尼如来　东方流布世界智流布如来　东方无边世界娑罗王如来　东方月世界宝娑罗王如来　东方离忧世界善德王如来　东方寂灭世界流布王如来　东方不虚见世界不虚力如来　东方妙香世界香明如来　东方梵音声世界无碍音如来　东方月光世界名闻力如来　东方普明世界须弥顶王如来　东方宝严世界宝生德如来　东方法世界华上如来　东方华住世界宝高王如来　东方妙陀罗尼世界香明如来　东方金明世界方流布严如来　东方高智世界普守增上云音王如来　东方常明世界无边明如来　东方[火*定]光世界无边慧成如来　东方然灯世界无边功德智明如来　东方赤莲华覆世界方生如来　东方华覆世界华生德如来　东方天世界众坚固如来　东方妙明世界智明如来　东方乐德世界智众如来　东方众乐世界离垢如来　东方无漏世界医王如来　东方普赞世界无边智赞如来　东方众坚世界栴檀香德如来　东方具威德世界具佛华生如来　东方众宝世界婆罗王安立如来　东方方主世界月出光如来　东方安住世界须弥肩如来　东方无怖畏世界施名闻如来　东方诸功德住世界名亲如来　东方福住世界坚固如来　东方无忧世界离忧如来　东方名闻世界华生德王如来　东方华布世界演华相如来　东方宝明世界宝照如来　东方常熏香世界火然如来　东方善吉世界三界自在力如来　东方无畏世界明轮如来　东方常悬世界空性自在如来　东方安王世界尽自在力如来　东方普离世界鼓音王如来　东方安隐世界普自在如来　东方陀罗尼世界山王如来　东方妙等世界安立王如来　东方妙严世界佛自在严如来　东方倚息世界积诸功德如来　东方爱世界佛宝德成就如来　东方列宿世界智生德如来　东方列宿严世界智生德聚如来　东方莲华世界华生王如来　东方众华世界上法自在如来　东方白莲华覆世界月光明如来　东方广世界香象如来　东方上妙世界无量明如来　东方众香世界莲华聚如来　东方薝卜众世界栴檀德如来　东方宝藏世界宝聚如来　东方明慧世界上明慧如来　东方善住世界无边德生如来　东方众多世界明相如来　东方爱香世界无边德积如来　东方爱惜世界众德生如来　东方可爱世界一切功德生如来　东方众莲华世界华生德如来　东方金网覆世界持炬如来　东方宝网覆世界宝生如来　东方离畏世界极高王如来　东方一盖世界宿王如来　东方众杂世界无边弥楼如来　东方妙喜世界虚净王如来　东方可迎世界无量音如来　东方妙音香世界无量明如来　东方上清净世界宝弥楼如来　东方照明世界杂宝华严如来　东方宝华世界离垢严如来　东方金刚世界金华如来　东方金光世界宝窟如来　东方众坚固世界杂华生如来　东方众华世界华盖如来　东方众莲华世界不虚严如来　东方梵德世界梵音如来　东方住处世界无碍眼如来　东方妙禅世界无相音如来　东方德住世界无边功德成就如来　东方宝住世界宝生德如来　东方喜世界莲华生德如来　东方莲华生世界宝上如来　东方妙明世界无边明如来　东方觉世界宝弥楼如来　东方月灯世界灯高德如来　东方星宿德世界智生德如来　东方炬世界炬灯如来　东方智积世界无上光如来　东方出生世界德王明如来　东方一盖世界无边眼如来　东方积德世界佛华生德如来　东方娑罗世界娑罗王如来　东方善住世界师子如来　东方劝助世界宝弥楼如来　东方莲华世界频婆尸如来　东方摄处世界医王如来　东方善德世界上善德如来　东方妙香世界上香德如来　东方香德世界香相如来　东方栴檀世界栴檀窟如来　东方宝网覆世界无边明如来　东方金网覆世界增十光佛华出如来　东方莲华网覆世界无边自在力如来　东方众华世界威华生高王如来　东方照明世界宝网如来　东方月灯世界安立王如来　东方栴檀香世界上香王如来　东方楼阁世界施一切乐如来　东方离窟世界见一切缘如来　东方离相世界不虚称如来　东方可敬世界坏诸惊畏如来　东方金明世界宝明如来　东方众乐世界无边空严德如来　东方一华盖世界盖严如来　东方无垢世界空相如来　东方广大世界威华生德如来　东方善积世界善德如来　东方妙华世界净眼如来　东方无边世界最高德弥楼如来　东方善生世界无胜相如来　东方阿竭流香世界无边香弥楼如来　东方多伽流香世界月闻王如来　东方上妙世界上弥楼如来　东方名喜世界宝生德如来　东方明世界名闻弥楼如来　东方软美世界美德如来　东方善香世界梵德如来　东方帝相世界无碍眼如来　东方善处世界无边德积如来　东方不思议德世界威德王如来　东方集相世界善思愿威如来　东方星宿王世界净王如来　东方智香世界智聚如来　东方德处世界娑诃王如来　东方善爱世界调御如来　东方莲华出世界最高德如来　东方无边德生世界示众生深心如来　东方欢喜世界无边德宝如来　东方倚息世界灭诸受自在如来　东方名乐世界无碍光如来　东方善成世界无碍光佛华生德如来　东方普德成就世界一切缘中自在现佛相如来　东方众相世界乐无相如来　东方无相世界妙化音如来　东方无相海世界华上如来　东方杂相世界宝德如来　东方宝生世界海弥楼如来　东方广大世界无垢意如来　东方名华世界智华生如来　东方虚空净世界极高德聚如来　东方无相世界寂灭如来　东方妙乐世界离欲自在如来　东方德积世界不思议德生如来　东方大安世界喜生德如来　东方散赤莲华世界流香如来　东方阿竭流光世界无碍香光如来　东方众归世界云鼓王如来　东方功德积世界功德生德如来　东方纯乐世界无边行自在如来　东方妙音世界须弥肩如来　东方香相世界上香弥楼如来　东方助香世界无边光如来　东方调御世界普观如来　东方月世界日月灯如来　东方照明世界明灯如来　东方善明世界振威德如来　东方众香世界善众如来　东方金刚世界金刚生如来　东方音声世界智自在王如来　东方阿楼那世界德明王如来　东方阿楼那积世界妙明如来　东方柔软世界娑罗王如来　东方善立世界须弥王如来　东方清净世界虚弥楼如来　东方威德生世界宝威德如来　东方善相世界上善德如来　东方梵德世界梵音声如来　东方华德世界宝华如来　东方莲华德世界莲华生德如来　东方栴檀世界栴檀香如来　东方名华世界如须弥如来　东方金华世界上严如来　东方宝明世界宝盖如来　东方香弥楼世界香象如来　东方杂相世界无边自在力如来　东方清净世界不虚称如来　东方功德处世界不思议功德王如来　东方有德世界杂华如来　东方安隐世界安王如来　东方最高世界华最高德如来　东方动世界常悲如来　东方常动世界药王如来　东方普虚空世界无边自在力如来　东方琉璃明世界无边光如来　东方金明世界无边明如来　东方无相世界言音自在如来　东方莲华盖世界无边虚空自在如来　东方盖行列世界宿王如来　东方宝网覆世界上香如来　东方真金世界虚空德如来　东方清净世界极高德如来　东方无忧世界作方如来　东方星宿世界极高弥楼如来　东方杂相世界无碍眼如来　东方香流世界娑伽罗如来　东方众香世界持炬如来　东方栴檀香世界火相如来　东方善喜世界善净德光如来　东方喜生世界智聚如来　东方流布世界流布力王如来　东方大德世界功德王明如来　东方坚固世界现智如来　东方不退世界华高生德如来　东方善分别世界宝火如来　东方优钵罗世界赤莲华德如来　东方疑盖世界坏一切疑如来　东方妙世界善众如来　东方众德世界拘留孙如来　东方妙善世界相王如来　东方妙香世界莲华德生如来　东方善相世界放光如来　东方云阴世界弥勒如来　东方光明世界莲华光明如来　东方名称世界上法王相如来　东方帝释世界无边力如来　东方莲华世界称山海如来　东方喜世界释迦文如来　东方常严世界不虚见如来　东方流布世界无碍音声如来　东方常言世界无量名明德如来　东方白相世界无分别严如来　东方栴檀香世界无边光如来　东方袈裟相世界妙眼如来　东方坚固宝世界寿无尽幢如来　东方因陀罗世界不变动月如来

佛说不思议功德诸佛所护念经卷上佛说不思议功德诸佛所护念经卷下

        曹魏代失译人名

南方去是百千万亿江河沙诸佛土杂种宝锦世界树根华王如来　南方去是无数百千诸佛土诸好庄饰世界德宝尊如来　南方去是百千万亿诸佛土消冥等世界初发心离恐畏超首如来　南方去是十八亿江河沙诸佛土严净世界离垢净如来　南方去是五十万诸佛土宝积世界宝积示现如来　南方欢喜世界栴檀德如来　南方庄严世界严净如来　南方离忧世界无忧德如来　南方诸欲净世界无垢称如来　南方宝城世界宝体品如来　南方乐林世界不舍乐精进如来　南方华迹世界普华如来　南方佛辩世界无量亿宝辩如来　南方宝净世界宝焰如来　南方真珠世界日月灯明如来　南方戒光世界须弥如来　南方音响世界大须弥如来　南方紫磨金世界超出须弥如来　南方色像见世界喻如须弥如来　南方珠光世界香像如来　南方得勇力世界围绕香熏如来　南方无垢光世界净光如来　南方法界世界法最如来　南方星自在王世界香自在王如来　南方正直世界大集如来　南方广博世界香光明如来　南方广远世界火光如来　南方无际世界无量光明如来　南方坚固世界开光如来　南方马瑙世界月灯光如来　南方妙香世界月光如来　南方日光世界日月光明如来　南方金珠光明世界火光如来　南方众色像世界集音如来　南方众聚世界最威仪如来　南方胜战超度无极世界光明尊如来　南方音响世界莲华军如来　南方月光世界莲华响如来　南方天自在世界多宝如来　南方莲华世界师子吼如来　南方明星世界师子音如来　南方无忧世界精进军如来　南方金刚聚世界金刚踊跃如来　南方明珠世界度一切禅绝众疑如来　南方香华熏世界宝大侍从如来　南方名喜世界无忧如来　南方哀色世界地力持踊如来　南方一大世界最踊跃如来　南方栴檀光世界自在王如来　南方一切伎乐振动世界无量音如来　南方光明世界锭光如来　南方一切香世界宝光如来　南方虚空住如来　南方常灭度如来　南方一切德严如来　南方炬照天师如来　南方宝树光明如来　南方呼那僧如来　南方莲华提如来　南方阿儿三耶三佛驮如来　南方日月镫如来　南方名闻光如来　南方大焰肩如来　南方须弥镫如来　南方无量精进如来　南方金刚藏如来　南方纯宝藏如来　南方释迦文如来　南方坚固乐世界风幢如来　南方莲华世界无尽月如来　西方去是百千万亿江河沙诸佛土胜月明世界造王神通焰华如来　西方去是百亿江河沙诸佛土水精世界净尊如来　西方去是无量佛土普乐世界离垢三世无碍严如来　西方去是九十九亿江河沙诸佛土光明幡世界光明王如来　西方乐围世界妙乐如来　西方净复净世界越净如来　西方璎珞世界无碍如来　西方善选择世界金刚步积如来　西方灭恶世界宝山如来　西方消诸毒螫世界普度空如来　西方宝锦世界宝成如来　西方华林世界习精进如来　西方极乐世界阿弥陀如来　西方思夷像世界华严神通如来　西方照曜世界普明如来　西方庄严世界见若灯之明王如来　西方无忧世界离忧如来　西方寂定世界吉祥如来　西方破一切尘世界殊胜如来　西方伏一切魔世界集音如来　西方度一切世间苦恼如来　西方泥洹华如来　西方诸宝般如来　西方阿弥陀如来　西方无量相如来　西方无量幢如来　西方大光如来　西方大明如来　西方宝相如来　西方净光如来　西方无量明如来　西方无量华如来　西方无量光如来　西方无量光明如来　西方无量自在力如来　西方无量力如来　西方一盖如来　西方盖行如来　西方宝盖如来　西方宿王如来　西方善宿如来　西方明轮如来　西方明王如来　西方高广德如来　西方无边光如来　西方自在王如来　西方自在力如来　西方无碍音声如来　西方大云光如来　西方网聚如来　西方觉华光如来　西方莲华自在如来　西方山王如来　西方月众增上如来　西方放光如来　西方妙肩如来　西方不虚见如来　西方顶生王如来　西方莲华生如来　西方释迦文如来　西方阿弥陀如来　西方坚固宝王世界清白如来　西方众宝世界不动月如来　北方去是百千万亿江河沙诸佛土决了宝网世界月殿清净如来　北方去是七十二亿江河沙诸佛土坚要世界梵慧如来　北方去是六十六亿江河沙诸佛土华迹世界觉积如来　北方不动转世界照意如来　北方住清净世界正意如来　北方觉辩世界宝智首如来　北方化成世界无染如来　北方普光世界勇辩如来　北方瞻倍世界灭意根如来　北方名胜世界胜王如来　北方无恐惧世界无畏如来　北方道林世界行精进如来　北方日转世界蔽日月光如来　北方众宝锦世界无量德宝光如来　北方善行列世界不虚称如来　北方云自在如来　北方云自在王如来　北方钩锁如来　北方迦禅那如来　北方阿迦头华如来　北方诸欲无脱那如来　北方焰肩如来　北方最胜音如来　北方难胜如来　北方日生如来　北方网明如来　北方金刚藏如来　北方坚固世界金刚坚强消伏坏散如来　北方摩尼光世界宝火如来　北方阿竭流香世界宝月如来　北方欢喜世界贤最如来　北方现入世界宝莲华出如来　北方丰严世界德内丰严王如来　北方不虚力如来　北方不虚自在力如来　北方不虚光如来　北方无边精进如来　北方娑罗王如来　北方宝娑罗王如来　北方一盖严如来　北方宝肩如来　北方栴檀窟如来　北方栴檀香如来　北方无边明如来　北方明轮如来　北方弥楼严如来　北方无碍眼如来　北方无边眼如来　北方宝生如来　北方诸德如来　北方觉华生德如来　北方善住意如来　北方无边力如来　北方不虚德如来　北方宝力如来　北方无边严如来　北方无边德严如来　北方虚空光如来　北方无相音如来　北方药王如来　北方无惊如来　北方离怖畏如来　北方德明王如来　北方观觉华生如来　北方虚空性如来　北方虚空音如来　北方虚空严生如来　北方释迦文如来　北方坚固世界威仪幢如来　北方优钵罗世界香风月如来　东北方去是九十九亿江河沙诸佛土净观世界法观如来　东北方去是十一江河沙诸佛土忍慧世界香尽如来　东北方去是八江河沙佛土无垢世界等行如来　东北方拔所念世界坏魔罗网独步如来　东北方一切住世界建大音普至如来　东北方青华世界悲精进如来　东北方焰气世界固受如来　东北方乐白交露世界宝盖起光如来　东北方净住世界空域离垢心如来　东北方照耀世界普世如来　东北方爱见世界尊自在如来　东北方丰盛世界吉祥义如来　东北方无垢世界离垢如来　东北方众归世界灭一切忧如来　东北方离一切忧世界离忧如来　东北方喜乐世界喜生德如来　东北方安隐世界安王如来　东北方金网覆世界上弥楼如来　东北方香明世界妙香如来　东北方实聚世界憍陈若如来　东北方坚固世界势德如来　东北方青莲华世界赤莲华德如来　东北方白莲华世界白莲华生如来　东北方大音世界大音眼如来　东北方香严世界上众如来　东北方众明世界无边明如来　东北方栴檀香世界月出光如来　东北方明世界名流十方如来　东北方月世界星宿王如来　东北方普明德世界无边光明如来　东北方香明世界上香弥楼如来　东北方无畏世界离怖畏如来　东北方上安隐世界生德如来　东北方无边明世界无边功德月如来　东北方庄严世界一切功德严如来　东北方莲华散世界华王如来　东北方离相世界不坏相如来　东北方坚固世界宗守光如来　东北方乐戏世界大威德莲生王如来　东北方乐世界无异生行如来　东北方喜世界一切智上如来　东北方乐德世界虚空净王如来　东北方喜乐世界无相音声如来　东北方娑婆世界宝最高德如来　东北方梵众世界梵德如来　东北方众香世界无碍香像如来　东北方众华世界弥楼明如来　东北方然灯世界大灯如来　东北方作名闻世界华上光如来　东北方多乐世界作名闻如来　东北方安立世界名慈如来　东北方娑罗世界娑罗王如来　东北方照明世界无边光如来　东北方坏一切世间怖畏如来　东北方师子吼如来　东北方金刚藏如来　东北方阿閦如来　东北方坚固青莲华如来　东北方梵天如来　东北方世界自在幢如来　东北方相德如来　东北方释迦牟尼如来　东北方星宿世界星宿月如来　东南方去是十四江河沙诸佛土梵音世界梵德如来　东南方去是七十七亿江河沙诸佛土仁贤世界善眼如来　东南方去是三亿诸佛土积宝世界善积如来　东南方贤圣普集世界观世苦如来　东南方极妙世界微妙如来　东南方常照耀世界初发心不退转轮成首如来　东南方多所造作世界多所念如来　东南方普锦彩色世界众华如来　东南方金林世界尽精进如来　东南方德王世界德明王如来　东南方无忧世界除众戚冥如来　东南方无悦世界首寂如来　东南方宝首莫能当甚光明如来　东南方佛华生世界一切缘中现佛相如来　东南方师子相如来　东南方师子音如来　东南方无忧首如来　东南方兴光明如来　东南方法种尊如来　东南方慧王如来　东南方莲华敷力如来　东南方无边缘中现佛相如来　东南方网明如来　东南方无边明如来　东南方上华如来　东南方宝娑罗如来　东南方发心即转法轮如来　东南方金刚藏如来　东南方华聚如来　东南方增千光如来　东南方无上光如来　东南方不动力如来　东南方无边光力如来　东南方无边愿如来　东南方无量愿如来　东南方无边自在力如来　东　南方无定愿如来　东南方转胎如来　东　南方转诸难如来　东南方一切缘修行如来　东南方无缘庄严如来　东南方佛虚空如来　东南方有德如来　东南方释迦牟尼如来　东南方坚固摩尼世界明相幢如来　东　南方妙行世界自在天月如来　西南方去是十三亿诸佛土广胜世界妙积如来　西南方去是十一江河沙佛土一切世界等慧如来　西南方去是八江河沙佛土无量藏世界忍慧如来　西南方覆白交露世界宝盖照空如来　西南方去是如江河沙佛土遍净一切世界无极身如来　西南方善选择世界释宝光如来　西南方去是无极宝林世界上精进如来　西南方乐成世界宝林如来　西南方善观世界大哀观众生如来　西南方乐御世界智首如来　西南方尊调世界离臂如来　西南方普明世界无垢如来　西南方阴雨世界雨王如来　西南方大尊王如来　西南方梵相如来　西南方谛相如来　西南方师子如来　西南方妙宝如来　西南方阿弥陀如来　西南方善吉世界吉利如来　西南方吉利严如来　西南方尸弃如来　西南方常精进如来　西南方善住如来　西南方无边严如来　西南方无相严如来　西南方普严如来　西南方灯明如来　西南方藏聚如来　西南方无边像如来　西南方无边精进如来　西　南方网光如来　西南方大神通如来　西南方明轮如来　西南方观智如来　西南方不虚胜如来　西南方坏诸怖畏如来　西南方无边德明王如来　西南方离怖畏如来　西　南方坏诸怨贼如来　西南方过诸魔界如来　西南方无量华如来　西南方持无量德如来　西南方无量音声如来　西南方光聚如来　西南方明德如来　西南方离二边如来　西　南方无量觉华光如来　西南方无量声如来　西南方明弥楼如来　西南方娑罗王如来　西南方日面如来　西南方妙眼如来　西南方上德如来　西南方宝华如来　西南方宝生如来　西南方日华如来　西南方一切众生严如来　西南方转一切生死如来　西　南方无边辩才如来　西南方释迦牟尼如来　西南方金刚藏如来　西南方坚固金刚世界帝幢如来　西南方无诤怖如来　西南方善行世界清净月如来　西南方缘一辩才如来　西北方去是百千万江河沙诸佛土师子口世界法成就如来　西北方去是二百亿江河沙佛土尽度世界清净观如来　西北方去是七十七亿江河沙佛土不动转世界众相如来　西北方释迦牟尼如来　西北方住清净世界众德如来　西北方兴显世界广耀如来　西北方青琉璃世界身相如来　西北方无尽世界彻听如来　西北方毛孔光世界法观如来　西北方雷吼世界如意如来　西北方清泰世界无动如来　西北方众智自在世界慧造如来　西北方贤善世界贤勇如来　西北方住清净世界开化菩萨如来　西北方贪众净意世界善变无形如来　西北方雨氏世界雨香王如来　西北方金刚世界一乘度如来　西北方除众闇冥世界光净王如来　西北方栴檀香世界普香光如来　西北方多摩罗跋栴檀香神通如来　西北方须弥相如来　西北方见无恐惧如来　西北方香明如来　西北方香弥楼如来　西北方香象如来　西北方香自在如来　西北方香窟如来　西北方明轮如来　西北方光王如来　西北方莲华生王如来　西北方佛法自在如来　西北方无边法自在如来　西北方乐爱德如来　西北方散华如来　西北方华盖行列如来　西北方华窟如来　西北方金华如来　西北方香华如来　西北方弥楼王如来　西北方善导师如来　西北方一切众生最胜严如来　西北方转诸难如来　西北方善行严如来　西北方妙华如来　西北方无边香如来　西北方普放光如来　西北方普放香如来　西北方普光如来　西北方散华生德如来　西北方宝网手如来　西北方极高王如来　西北方普照一佛土如来　西北方宿王如来　西北方妙见如来　西北方安立王如来　西北方香琉如来　西北方无边智自在如来　西北方不虚严如来　西北方不虚见如来　西北方无量眼如来　西北方不动如来　西北方初发意如来　西北方无边眼如来　西北方灯上如来　西北方普照明如来　西北方光照如来　西北方一切众生不断辩才如来　西北方无垢力如来　西北方无积行如来　西北方金刚藏如来　西北方欢喜莲华世界上幢如来　西北方欢喜世界无上月如来　下方去是百千万亿江河沙诸佛土尊幢若君世界善寂月音王如来　下方去是七十二亿江河沙诸佛土众宝普现世界一宝盖如来　下方去是三十二亿江河沙佛土坚固世界不舍弘誓如来　下方照耀世界光明王如来　下方明开辟世界赖毗罗耶如来　下方地氏世界持地如来下方念无倒世界念断疑拔欲除冥如来　下方无量华世界灯尊王如来　下方无减世界普愿如来　下方极深世界宝聚如来　下方锦幢世界师子鹰像顶吼如来　下方名善世界善德如来　下方载诸净世界金刚刹如来　下方水精世界梵精进如来　下方沙陀惟惧咤世界唯首陀失利如来　下方照明世界染青莲首如来　下方普明世界普现如来　下方起得度世界导龙如来　下方光刹世界普观如来　下方照明世界月辩如来　下方导御世界坚要如来　下方虚空净世界大目如来　下方无垢称王如来　下方师子如来　下方名闻如来　下方名光如来　下方达磨如来　下方法幢如来　下方法持如来　下方名称远闻如来　下方法名号如来　下方法幢如来　下方奉法如来　下方意无恐惧衣毛不竖如来　下方上德如来　下方大德如来　下方莲华德如来　下方有德如来　下方师子德如来　下方成利如来　下方师子护如来　下方师子嚬如来　下方安立王如来　下方梵弥楼如来　下方净眼如来　下方不虚步如来　下方香像如来　下方香德如来　下方香弥楼如来　下方无量眼如来　下方香聚如来　下方宝窟如来　下方宝弥楼如来　下方安住如来　下方善住王如来　下方梵弥楼如来　下方娑罗王如来　下方明轮如来　下方明灯如来　下方不虚精进如来　下方善思严如来　下方师子喜如来　下方众真实如来　下方妙善住王如来　下方释迦文如来　下方金刚藏如来　下方坚固栴檀世界梵憧如来　下方无厌慈世界不衰变月如来　上方去是百千万亿江河沙诸佛土善分别世界无数精进愿首如来　上方去是百亿江河沙佛土莲华严世界莲华上如来　上方去是六十二亿江河沙佛刹一土世界一切德所见明王如来　上方离诸恐惧无处所世界消冥等超王如来　上方释迦牟尼如来　上方回转世界音响如来　上方普慈世界弘等如来　上方众香世界香积如来　上方吉祥世界行真如来　上方安寂世界妙识如来上方尼遮揵陀波勿世界犍陀罗耶如来　上方庄严世界宝好如来　上方庄严世界宝英如来　上方名喜世界喜德如来　上方过度众妙世界信色清虚如来　上方欲林世界至精进如来　上方虚空世界无限眼王如来　上方庄严世界名称如来　上方宝君主世界无量光明最胜如来　上方宝月世界金宝光明如来　上方象步楼世界无量尊丰如来　上方天王女世界无量离垢王如来　上方须弥幡世界德首如来　上方尊聚妙意世界无数精进兴丰如来　上方无受世界无言胜如来　上方净观庄严世界无愚丰如来　上方日光世界月英丰如来　上方说法世界无异光丰如来　上方宝丰首尽世界逆空光明如来　上方好集世界最清净无量幡如来　上方殊胜世界好谛住准王如来　上方主精进世界成就一切诸刹丰如来　上方愿力世界净慧德丰如来　上方好乐世界净论幡如来　上方栴檀香世界琉璃光最胜如来　上方星宿世界宝德步如来　上方无量德丰世界最清净德宝住如来　上方声所至世界度宝光明塔如来　上方无际眼世界无量惭愧金最丰如来　上方莲华庄严世界莲华尊丰如来　上方宝镫世界净宝兴丰如来　上方电光世界电镫幡王如来　上方虚空致世界法空镫如来　上方审谛世界一切众德成如来　上方月英世界贤幢幡如来　上方宝种世界一切众宝致色持如来　上方栴檀香明世界无边高力王如来　上方所度无足如来　上方处法形如来　上方所行香华如来　上方梵声如来　上方宿王如来　上方香上如来　上方香光如来　上方火焰肩如来　上方杂色宝庄严如来　上方金刚藏如来　上方萨罗树王如来　上方宝华德如来　上方见一切义如来　上方如须弥山如来　上方精进最高王如来　上方破疑如来　上方善宿王如来　上方然灯如来　上方作明如来　上方明弥楼如来　上方明轮如来　上方净明如来　上方白盖如来　上方香盖如来　上方宝盖如来　上方栴檀窟如来　上方栴檀德如来　上方须弥肩如来　上方宝明如来　上方娑罗王如来　上方梵德如来　上方净眼如来　上方无惊怖如来　上方离怖畏如来　上方妙肩如来　上方上宝如来　上方山王如来　上方转女相严如来　上方无边严如来　上方无上光如来　上方网明相如来　上方因王如来　上方坚固香世界宁泰幢如来　上方虚空世界无量自在月如来　过去十方雷明音王如来　过去雨音王如来　过去寂趣音王如来　过去总水雷音肃华慧王如来　过去无量勋宝绵净王如来　过去离垢日月光首如来　过去梵首天王如来　过去日月镫明王如来　过去世饶王如来　过去药王如来　过去超空如来　过去首寂如来　过去宝月如来　过去息意如来　过去灯光如来　过去栴檀香如来　过去大通智胜如来　过去多宝如来　过去光远如来　过去定光如来　过去月教如来　过去无著如来　过去龙天如来　过去安明顶如来　过去惟卫如来　过去式弃如来　过去随叶如来　过去拘留秦如来　过去拘那鋡牟尼如来　过去迦叶如来　过去释迦牟尼如来　未来十方忍世界弥勒如来　未来离垢心世界普现如来　未来阿弥陀如来　未来慧见如来　未来师子威如来　未来金刚步积如来　未来光无垢称王如来　未来时大光明如来　未来莲华光如来　未来海持觉娱乐神通如来　未来度七宝华界如来　未来力严净王如来　未来普明变动光王如来　未来严净法王如来　未来称英如来　未来普光如来　未来散华如来　未来金华如来　未来阿耨达如来　未来强行精进如来　未来贤劫千佛如来　未来留油如来(出华手等诸经)

佛说不思议功德诸佛所护念经卷下


佛说不增不减经

    No. 668

佛说不增不减经

        元魏北印度三藏菩提流支译

如是我闻。一时婆伽婆住王舍城耆阇崛山中。与大比丘众千二百五十人俱。诸菩萨摩诃萨无量无边不可称计

尔时慧命舍利弗。于大众中即从坐起。前至佛所到已顶礼佛足。退坐一面合掌白佛言。世尊。一切众生从无始世来。周旋六道往来三界。于四生中轮回生死受苦无穷。世尊。此众生聚众生海。为有增减为无增减。此义深隐我未能解。若人问我当云何答。尔时世尊。告舍利弗。善哉善哉。舍利弗。汝为安隐一切众生。安乐一切众生。怜愍一切众生。利益一切众生。饶益安乐一切众生。诸天人故。乃能问我是甚深义。舍利弗。汝若不问如来应供正遍知如是义者有多过咎。所以者何。于现在世及未来世。诸天人等一切众生。长受衰恼损害之事。永失一切利益安乐。舍利弗。大邪见者。所谓见众生界增。见众生界减。舍利弗此大邪见诸众生等。以是见故生盲无目。是故长夜妄行邪道。以是因缘于现在世堕诸恶趣。舍利弗。大险难者。所谓取众生界增坚着妄执。取众生界减坚着妄执。舍利弗。此诸众生坚着妄执。是故长夜妄行邪道。以是因缘。于未来世堕诸恶趣

舍利弗。一切愚痴凡夫不如实知一法界故。不如实见一法界故起邪见心。谓众生界增众生界减。舍利弗。如来在世我诸弟子不起此见。若我灭后过五百岁。多有众生愚无智慧。于佛法中虽除须发。服三法衣现沙门像。然其内无沙门德行。如是等辈实非沙门自谓沙门。非佛弟子谓佛弟子。而自说言。我是沙门真佛弟子。如是等人起增减见。何以故。此诸众生以依如来不了义经。无慧眼故。远离如实空见故。不如实知如来所证初发心故。不如实知修集无量菩提功德行故。不如实知如来所得无量法故。不如实知如来无量力故。不如实知如来无量境界故。不信如来无量行处故。不如实知如来不思议无量法自在故。不如实知如来不思议无量方便故。不能如实分别如来无量差别境界故。不能善入如来不可思议大悲故。不如实知如来大涅槃故。舍利弗。愚痴凡夫无闻慧故闻如来涅槃起断见灭见。以起断想及灭想故。谓众生界减。成大邪见极重恶业。复次舍利弗。此诸众生依于减见复起三见。此三种见与彼减见。不相舍离犹如罗网。何谓三见。一者断见。谓毕竟尽。二者灭见。谓即涅槃。三者无涅槃见。谓此涅槃毕竟空寂。舍利弗。此三种见如是缚如是执如是触。以是三见力因缘故。展转复生二种邪见。此二种见与彼三见。不相舍离犹如罗网。何谓二见。一者无欲见。二者毕竟无涅槃见。舍利弗。依无欲见复起二见。此二种见与无欲见。不相舍离犹如罗网。何谓二见。一者戒取见。二者于不净中起净颠倒见

舍利弗。依毕竟无涅槃见复起六种见。此六种见与无涅槃见。不相舍离犹如罗网。何谓六见。一者世间有始见。二者世间有终见。三者众生幻化所作见。四者无苦无乐见。五者无众生事见。六者无圣谛见

复次舍利弗。此诸众生依于增见复起二见。此二种见与彼增见。不相舍离犹如罗网。何谓二见。一者涅槃始生见。二者无因无缘忽然而有见。舍利弗。此二种见令诸众生。于善法中无愿欲心勤精进心。舍利弗。是诸众生以起如是二种见故。正使七佛如来应正遍知。次第出世为其说法。于善法中若生欲心。勤精进心无有是处

舍利弗。此二种见乃是无明诸惑根本。所谓涅槃始生见。无因无缘忽然而有见

舍利弗。此二种见乃是极恶根本大患之法。舍利弗。依此二见起一切见。此一切见与彼二见不相舍离犹如罗网。一切见者。所谓若内若外。若粗若细若中种种诸见。所谓增见减见。舍利弗。此二种见依止一界。同一界合一界。一切愚痴凡夫。不如实知彼一界故。不如实见彼一界故。起于极恶大邪见心。谓众生界增。谓众生界减

尔时慧命舍利弗白佛言。世尊。何者是一界而言。一切愚痴凡夫。不如实知彼一界故。不如实见彼一界故。起于极恶大邪见心。谓众生界增。谓众生界减。舍利弗言。善哉世尊。此义甚深我未能解。唯愿如来为我解说令得解了

尔时世尊。告慧命舍利弗。此甚深义乃是如来智慧境界。亦是如来心所行处。舍利弗。如是深义一切声闻缘觉智慧所不能知。所不能见。不能观察。何况一切愚痴凡夫而能测量。唯有诸佛如来智慧。乃能观察知见此义。舍利弗。一切声闻缘觉所有智慧。于此义中唯可仰信。不能如实知见观察。舍利弗。甚深义者即是第一义谛。第一义谛者即是众生界。众生界者即是如来藏。如来藏者即是法身。舍利弗。如我所说法身义者。过于恒沙不离不脱不断不异。不思议佛法如来功德智慧

舍利弗。如世间灯所有明色及触不离不脱。又如摩尼宝珠所有明色形相不离不脱。舍利弗。如来所说法身之义亦复如是。过于恒沙不离不脱不断不异。不思议佛法如来功德智慧

舍利弗。此法身者是不生不灭法。非过去际。非未来际。离二边故。舍利弗。非过去际者离生时故。非未来际者。离灭时故。舍利弗。如来法身常。以不异法故。以不尽法故。舍利弗。如来法身恒。以常可归依故。以未来际平等故。舍利弗。如来法身清凉。以不二法故。以无分别法故。舍利弗。如来法身不变。以非灭法故以非作法故

舍利弗。即此法身过于恒沙。无边烦恼所缠从无始世来随顺世间。波浪漂流往来生死名为众生。舍利弗。即此法身厌离世间生死苦恼。弃舍一切诸有欲求。行十波罗蜜。摄八万四千法门。修菩提行名为菩萨

复次舍利弗。即此法身离一切世间烦恼使缠过一切苦。离一切烦恼垢。得净得清净。住于彼岸清净法中。到一切众生所愿之地。于一切境界中究竟通达更无胜者。离一切障离一切碍。于一切法中得自在力。名为如来应正遍知。是故舍利弗。不离众生界有法身。不离法身有众生界。众生界即法身。法身即众生界。舍利弗。此二法者义一名异

复次舍利弗。如我上说。众生界中亦三种法。皆真实如不异不差。何谓三法。一者如来藏本际相应体及清净法。二者如来藏本际不相应体及烦恼缠不清净法。三者如来藏未来际平等恒及有法

舍利弗当知。如来藏本际相应体及清净法者。此法如实不虚妄不离不脱。智慧清净真如法界不思议法。无始本际来。有此清净相应法体。舍利弗。我依此清净真如法界。为众生故说为不可思议法自性清净心

舍利弗当知。如来藏本际不相应体。及烦恼缠不清净法者。此本际来离脱不相应烦恼所缠不清净法。唯有如来菩提智之所能断。舍利弗。我依此烦恼所缠不相应不思议法界。为众生故说为客尘烦恼所染。自性清净心不可思议法

舍利弗当知。如来藏未来际平等恒及有法者。即是一切诸法根本。备一切法具一切法于世法中不离不脱真实一切法。住持一切法摄一切法。舍利弗。我依此不生不灭常恒清凉不变归依。不可思议清净法界说名众生。所以者何。言众生者即是不生不灭常恒清凉不变归依。不可思议清净法界等异名。以是义故。我依彼法说名众生。舍利弗。此三种法皆真实如不异不差。于此真实如不异不差法中。毕竟不起极恶不善二种邪见。何以故。以如实见故。所谓减见增见。舍利弗。此二邪见诸佛如来毕竟远离。诸佛如来之所呵责

舍利弗。若有比丘比丘尼优婆塞优婆夷若起一见。若起二见。诸佛如来非彼世尊。如是等人非我弟子。舍利弗。此人以起二见因缘故。从冥入冥从闇入闇。我说是等名一阐提。是故舍利弗。汝今应学此法。化彼众生令离二见住正道中。舍利弗。如是等法。汝亦应学。离彼二见住正道中

佛说此经已。慧命舍利弗。比丘比丘尼优婆塞优婆夷。菩萨摩诃萨。及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众。皆大欢喜信受奉行佛说不增不减经


佛说布施经

    No. 705

佛说布施经

        西天译经三藏朝散大夫试鸿胪少卿明教大师臣法贤奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。与大苾刍众说布施法。有三十七种。一以信重心而行布施。当得离众嫉妒人所崇敬。二依时施。得三业清净四时安隐。三常行施。得身心适悦无散乱失。四亲手施。得手指纤长身相端正。五为他施。复得他人行大舍施。六依教施。心离取相得无为福。七以妙色具施。得身色端严众所爱乐。八以上妙香具施。恒得旃檀之香受用供养。九以上味施。得味中上味充益肢体。十如法尊重施。得安隐快乐众人喜见。十一以广大心施。得无量广大之福。十二以美食施。得离饥馑仓库盈溢。十三以浆饮施。得所往之处无诸饥渴。十四以衣服施。得上妙衣庄严身相。十五以住处施。得田宅宽广楼阁庄严。十六以卧具施。得生贵族资具光洁十七以象马车辇施。得四神足无拥妙用十八以汤药施。得安隐快乐无诸疾病。十九以经法施。得宿命等通。二十以花果施。得七觉支花。二十一以花鬘施。得脱贪嗔痴垢。二十二以香施。得离烦恼臭秽。二十三以伞盖施。得法自在。二十四以铃铎施。得言音美妙。二十五以音乐施。得梵音深妙。二十六以然灯施。得天眼清净。二十七以缯彩疋帛施。得解脱衣服。二十八以香水洒如来塔庙。二十九以香水浴如来身。三十以香油涂饰佛像。共得三十二相八十种好。三十一以香水施浴众僧。得富贵家生少病安乐。三十二以慈心施。得颜貌和悦无诸嗔恨。三十三以悲心施。得离杀害。三十四以喜心施。得无所畏远离忧恼。三十五以舍心施。得离挂碍证寂灭乐。三十六以种种施。得种种福。三十七以无住无相心施。得无上正等正觉。佛告诸苾刍。如是三十七种。智者所行微妙施行。汝今受持

尔时舍卫国王白佛言。世尊。我等云何而行布施。佛言。大王。若求胜妙福报而行施时。慈心不杀离诸嫉妒。正见相应远于不善。坚持禁戒亲近善友。闭恶趣门开生天路。自利利他其心平等。若如是施。是真布施。是大福田。复次行施。随自心愿获其报应。或以妙色名香珍味软触。亲手布施。得众人尊重眷属圆满富贵安乐之报或以饮食布施。而得大力。或以酥油之灯布施。而得天眼。或以音乐布施。而得天耳。或以汤药布施。而得长寿。或以住处布施。而得楼阁田园。或以法说布施。而得甘露。佛言。大王。若以十善行施。复得十种报应。十善者。不杀生。不偷盗。不淫欲。不妄语。不绮语。不恶口。不两舌。不贪。不嗔。不痴而得命不中夭。财无散失。眷属清洁。所言诚谛。离诸嫉妒。人所喜见。亲友和睦。不堕贫贱。颜貌端正。智慧相应。获报如是。佛言。大王。若以上妙饮食供养三宝。得五种利益。身相端严。气力增盛。寿命延长。快乐安隐。成就辩才。如是南赡部洲一切众生。父母妻子男女眷属。如上布施随愿所求无不圆满。说此法已。皆大欢喜。作礼而退佛说布施经


佛说禅行三十七品经

    No. 604

佛说禅行三十七品经

        后汉安息国三藏安世高译

闻如是。一时佛游于舍卫国祇树给孤独园。佛言诸比丘。若能弹指间。惟行自身身止观。外身身止观。内外身身止观。分别念解世间痴恼。是为精进。为如佛教。非是愚痴食人施。何况能多行者。撮取其要。若弹指间。止观痛若止观意及止观法。内外分别念解世间痴恼。皆如上说。何况多行者。是故可念行四意止

佛言诸比丘。若弹指间。惟行未生恶法不令生。劝意治行精进摄意。是为精进行禅。为如佛教。不是愚痴食人施。何况多行者。摄取其要。若弹指间。惟行已生恶法即得断。若惟行未生善法便发生。及已生善法立不忘增行得满。劝意治行精进摄意。皆如上说。何况多行者。是故可念行四意断

佛言诸比丘。若弹指间。惟行欲定断生死。惟神足是为最精进行禅。为如佛教。不是愚痴食人施。何况多行者。摄取其要。若弹指间。惟行精进定。若惟行意定及戒定断生死惟神足。皆如上说。何况多行者。是故可念行四神足。佛言诸比丘。若弹指间。惟行信根。以见四喜之事。不离佛亦法与众及戒。是为精进行禅。为如佛教。不是愚痴食人施。何况多行者。撮取其要。若弹指间。惟行精进根。以见四意断。若惟行念根。以见四意止。若惟行定根。以见四禅。若惟行慧根。以见四谛。皆如上说。何况多行者。是故可念行五根。佛言诸比丘。若弹指间。惟行信力。从得四喜之事。令无能坏。是为精进行禅。为如佛教。非是愚痴食人施。何况多行者。若弹指间。惟行精进力。若念力。若定力。若慧力。皆如上说。何况多行者。是故可念行五力

佛言诸比丘。若弹指间。惟行念觉意。以念所当念。以爱念。以正念。为善法念。得志不忘。是为精进行禅。为如佛教。不是愚痴食人施。何况多行者。撮取其要。若弹指间。惟行法解觉意。其意经经分别解随顺解。若惟行精进觉意。其身精进。意亦精进。若惟行爱觉意。知所当爱令意得喜。若惟行止觉意。令身休止。意亦休止。若惟行定觉意。令意住念亦住。志不乱不邪念。若惟行护觉意。为护行知所念知安身。令见道护。恶念安隐行事事。皆如上说。何况多行者。是故可念行七觉意。佛言诸比丘。若弹指间。惟行正见。以知古知始知终。知内知外。知苦知习。知尽知道。知佛知法。知比丘众。知学行事。如六合所习所取欢喜变失及其归趣。知不贪之德。是为正见。为精进行禅。为如佛教。不是愚痴食人施。何况多行者。撮取其要。若弹指间。惟行正思。为思出家思不诤思不杀。若惟行正语不妄语不两舌不恶口不形笑。若惟行正命。不以贪生活。不恚生活。不以痴生活。若惟行正业。不杀不盗窃不邪淫。若惟行正治。以修治四意断之事。若惟行正念。以受行四意止。亦惟行正定。以思念四禅事事。皆同如上说。其弹指间。功德如是。何况多行者。是故可念行八正道。佛说是已。皆欢喜受佛说禅行三十七品经


佛说长者法志妻经

    No. 572

佛说长者法志妻经

        失译人名今附凉录

闻如是。一时佛在舍卫国祇树给孤独园。与大比丘千二百五十菩萨万人俱。佛时清旦着衣持钵入城分卫。比丘菩萨皆悉侍从。诸天龙神。及香音神。无善之神凤凰神。山神执乐神王。皆散华烧香。鼓诸音乐歌叹佛德。而说颂曰

  从无数亿劫　　积行难可量
  慈愍于众生　　使发大道行
  三界犹如化　　一切悉空无
  能晓了此慧　　度脱诸十方
  三十二相明　　姿好八十种
  口出万亿音　　功德自严容
  虽处现三界　　开示三道场
  三垢今已灭　　除于三界殃
  心如明月珠　　处欲无所著
  等行离爱憎　　一切无适莫

于是人民闻歌。颂佛德一国集会。观佛行来举动进止法则安徐。威容之颜犹星中月如日初出。普照天下无所挂碍。譬如梵王处诸天中。如天帝释处忉利宫诸天中尊。犹须弥山现于大海。四域之中安不可动。欢喜踊跃叉手归命。佛至长者法志门外进到中合。放大光明皆照十方。时长者妻严庄床座。文饰身形众宝璎珞。服栴檀香面彩颜貌。五色焜煌谓可保常。奴客婢使小有过失。挝捶苦毒不问曲直。遥见佛明超于日光。心自念言。此之显耀非类日月释梵诸天凡俗之光。其明清凉安隐无量。我身蒙之一切无患。不饥不渴自然饱满。云何行杖加于仆从。速趣向合睹见世尊。相好威耀难可为喻。诸根寂定无有衰入。犹七宝山晃晃巍巍。惭惧悲喜稽首佛足。悔过殃衅所犯无状。既为女人不能自责。嗔喜由己。今首罪舋不敢藏匿。佛言。善哉善哉。汝获善利离一切衰。见身殃咎改往修来。人身难得佛经难值。亿世时有所以堕女人身中者何。淫欲姿态在于其中。不能修身放心姿意。嫉妒多口贪于形貌而自恃怙。世间无常豪富威势须臾间耳。当视诸下犹如赤子。豪富贫贱如月进退。若日出没水火风起不久则衰。一切道俗皆从心兴。上天人间地狱饿鬼畜生之类皆由己耳。佛天中天缘觉声闻。亦复如是。今我斯身三十二相八十种好。彻睹十方悉从解达。女闻佛言欢喜无量。重自归命责己朦冥。唯受不及开化未闻无上之诲。佛言。施行十善义。身不杀盗淫。口不妄言两舌绮语恶口。意不嫉恚痴。当奉六度。布施持戒忍辱精进一心智慧。遵四等心慈悲喜护。普弘大哀自致得三十二相八十种好。乃为奴客婢使。教以辛苦生死罪福示语三涂之患难也。诫以道禁义理之事胜于挝杖。庄严璎珞有四事。何等为四。一曰笃信。二曰戒禁。三曰三昧。四曰智慧。是为四事。菩萨自庄严心计大乘。无男无女犹如幻化。画师所作随意辄成。晓了空慧一切本净。得无名身四无所畏。四事不护独步三界度脱一切。女闻佛教心开踊跃。即发无上正真道意。立不退转地。时天帝释来在佛后。谓女言曰。佛道难得。不如求转女为男日月天帝转轮圣王。于是女以偈颂曰

  天帝日月王　　转轮四域主
  威势无几间　　不可久恃怙
  在豪如朝露　　梦中有所睹
  觉以忽灭尽　　不知所凑处
  五阴如幻化　　三界由己作
  三世以平等　　道心无等侣
  谛解作是了　　谁男何所女
  天帝闻斯言　　默然无所语

佛言。善哉善哉。诚如所云。三处如幻化影响野马水月芭蕉。俗人不解计有吾我。便倚三界不能自济。女心即解变为男子。踊在虚空下礼佛足。佛告女曰。汝于后世恒沙来劫当得作佛。号无垢王如来至真等正觉明行成为善逝世间解无上士道法御天人师佛号天中天。世曰光净。时来会者诸天人民无央数千。见此变应皆发无上正真道意。时长者妻一切下使。前白佛言。尊者卑者本宁异乎

佛言。一切本无随心所存。虽为下使发心为道可得成佛。既为尊豪恣心憍慢。不离恶趣地狱饿鬼畜生之中。犹月增减如树盛衰。一切非常无一可赖。唯道深慧乃可保常。犹如虚空无进无退。时诸下使踊跃欣豫发大道意。变为男子得不起忍。佛告阿难。五阴无处六情无根。十二因缘而无端绪。四大寄因何所是人。佛说如是。莫不欢喜佛说长者法志妻经


佛说长者女庵提遮师子吼了义经

    No. 580

佛说长者女庵提遮师子吼了义经

        失译人名今附梁录

如是我闻。一时佛住舍卫国祇树给孤独园。与无量比丘比丘尼优婆塞优婆夷。菩萨摩诃萨众俱尔时去舍卫城西二十余里。有一村名曰长提。有一婆罗门。名婆私腻迦。在其中住。其人学问广博。深信内典敬承佛教。时婆罗门欲设大会。至祇洹所请佛及僧。佛则受其请。婆罗门还家。又克其时。佛与大众往诣彼村。至婆罗门舍。尔时长者。见佛欢喜踊跃。不能自胜。即率诸眷属来至佛所。各各礼佛恭敬而住。其婆罗门有一长女。名庵提遮。先[女*適]与人暂来还家。侍省父母。其女容貌端正。其度高远。用心柔下。其怀豁然。能和夫妻。侍养亲族。事夫如禁。其仪无比。出于群类。父母眷属皆出见佛。唯有此女独在室内。其女自以生来。父母莫测其所由。故名之庵提遮。尔时如来。即知长者有一女。在室内未出。知其不出所由。若其出者利益无量大众。及诸天人。佛即告长者言。汝之眷属出来尽耶。其婆罗门。束手长跪佛前。以此女不出之状。将之为耻。默然未答。佛则知其意。仍告之言。中时向至可设供耶。时婆罗门。即承佛教起设供养。大众及其长者。眷属中食已讫。唯有此女。未及得食。时如来钵中故留残食。遣一化女将此余食。与彼室内女庵提遮。时化女人。以偈告曰

  此是如来余　　无上胜尊赐
  我当承佛教　　愿仁清净受

其女庵提遮。即以偈叹曰

  呜呼大慈悲　　知我在室已
  今赐一味食　　寻仰睹圣旨

复以偈答彼化女曰

  我常念所思　　大圣之所行
  未曾与汝异　　何事不清净

其化女闻庵提遮说偈已。即没不现。其女庵提遮。以心念诵偈言

  我夫今何在　　愿出见胜尊
  愿知我心净　　速来得同闻

尔时庵提遮。净心力故。其夫随念即至其所。是女庵提遮见其夫已。心生欢喜。以偈叹曰

  呜呼大胜尊　　今随济我愿
  不辞破小戒　　恐当不同闻

其夫见庵提遮说偈言已。即还以偈责曰

  呜呼汝大痴　　不知善自宜
  劳圣赐余食　　守戒竟何为

时女庵提遮。即随其夫往诣佛所。各自礼佛及诸大众。恭敬而立。时女庵提遮。以偈叹曰

  我念大慈悲　　救护十方尊
  欲设秘密藏　　赐我净余食
  大圣甚难会　　世心有所疑
  谁可问法者　　发众菩提基

尔时舍利弗。即白佛言。世尊。此是何女人。忽尔来至此。复说如是法偈言得余食。佛告舍利弗言。此是长者女。复问曰。从何而来。何因至此。佛告舍利弗。此女人不从远来。只在此室。虽有父母眷属。其夫不在。以自诫敬顺夫因缘故。不从父母轻尔出游现于大众。时舍利弗白佛言。是女以何善因故。生此长者家。其容若此。复以何因缘故。得如是士夫禁约。若此不能自由见佛及僧。佛即告舍利弗。汝自问之。时舍利弗。问其女曰。汝以何因缘。生此长者家。复以何因缘。得如是人为夫禁戒。若此不能自由见佛及僧。其女庵提遮。以偈答曰

  我以不恶生　　生此长者家
  又不执女相　　得是清净夫
  我在内室中　　以为自在竟
  是分未曾越　　圣知赐我余
  呜呼今大德　　不知真实由
  丝毫不负越　　故名大自在
  我虽内室中　　尊如目前现
  仁称阿罗汉　　常随不能见
  大圣非是色　　亦不离色身
  声闻见波旬　　谓是大力人
  呜呼今大德　　随圣少方便
  不知本元由　　于我生倒见

尔时舍利弗。默然而止。私自念言。此是何女人。其辩若此。我所不及。佛即知其意。而告之曰。勿退于问答生于异心。是女人已经值无量诸佛所说。是法药勿疑之也

尔时文殊师利。问庵提遮曰。汝今知生死义耶。答曰。以佛力故知。又问曰。若知者生以何为义。答曰。生以不生生为义。又问曰。云何不生生为义耶。答曰。若能明知地水火风四缘。毕竟未曾自得有所和合。而能随其所宜。有所说者。以为生义。又问曰。若知地水火风。毕竟不自得有所和合为生义者。即应无有生相。将何为义。答曰。虽在生处而无生者。是为正生。故说有义。文殊又问曰。死以何为义耶。答曰。死以不死死为义。又问曰。云何以不死死为死义耶。答曰。若能明知地水火风。毕竟不自得有所散。而能随其所宜。有所说者。是为死义。又问曰。若知地水火风。毕竟不自得散者。即无死相。将何为义。答曰。虽在死处其心不亡者。是为正死。故说有义。文殊师利又问曰。常以何为义。答曰。若能明知诸法毕竟。生灭变易无定如幻相。而能随其所宜。有所说者。是为常义。又问。若知诸法毕竟。生灭无定如幻相者。即是无常义。云何将为常义耶。答曰。诸法生而不自得生。灭而不自得灭。乃至变易亦复如是。以不自得故。说为常义。又问曰。无常以何为义。答曰。若知诸法毕竟不生不灭。随如是相。而能随其所宜。有所说者。是为无常义。又问曰。若知诸法毕竟不生不灭者。即是常义。云何说为无常义耶。答曰。但以诸法自在变易无定相。不自得随。如是知者。故说有无常义耶。又问曰。空以何为义。答曰。若能知诸法相。未曾自空。不坏今有。而能不空空。不有有者故说有空义。又问曰。若不空空。不有有者。即无有事。将何为空义耶。其女庵提遮。则以偈答曰

  呜呼真大德　　不知真空义
  色无有自相　　岂非如空也
  空若自有空　　则不能容色
  空不自空故　　众色从是生

尔时文殊师利又问曰。颇有明知生而不生相。为生所留者不。答曰有。虽自明见其力未充。而为生所留者是也。又问颇有无知不识生性。而毕竟不为生所留者不。答曰无。所以者何。若不见生性。虽因调伏少得安处。其不安之相常为对治。若能见生性者。虽在不安处。而吉相常为现前。若不如是知者。虽有种种胜辩谈说甚深典籍。而即是生灭心。说彼实相密要之言。如盲辩色。因他语故。说得青黄赤白黑。而不能自见色之正相。今不能见诸法者。亦复如是。但今为生。所生为死。所死者于其人。即无生死之义耶。若为常无常所系者。亦复如是。当知大德。空者亦不自得空。故说有空义耶

尔时佛告文殊师利。如是如是。如庵提遮所说。真实无异。日可令冷。月可令热。是庵提遮所说。不可移易。时舍利弗。复问其女曰。汝之智慧辩才若此。佛所称叹。我等声闻之所不及。云何不能离是女身色相。其女答曰。我欲问大德。即随意答我。大德。今现是男不。舍利弗言。我虽色是男。而心非男也。其女言。大德。我亦如是。如大德所言。虽在女相。其心即非女也。舍利弗言。汝今现为夫所拘执。何能如此。其女答曰。大德。能自信己之所言不。舍利弗言。我之自言。云何不自信。其女答曰。若自信者。大德。前言说我色是男而心非男者。即心与色有所二用也。若大德自信此言者。于我所不生有夫之恶见。大德自男。故生我女相。以我女色故。坏大德心也。而自男见彼女者。则不能于法生实信也。舍利弗言。我于汝所。不敢生于恶见。其女答曰。但以对世尊故。不敢是实言也。若实不生恶见者。云何说我言汝今现为夫所拘执耶。是言从何而来。舍利弗言。我以久离习故。有此之言非实心也。其女问曰。大德。我今问者随意答我。大德既言久离男女相者。大德。色久离心久离。时舍利弗。默然不答。尔时庵提遮以偈颂曰

  若心得久离　　毕竟不生见
  谁为作女人　　于色起不净
  若论色久离　　法本不自有
  毕竟不曾污　　将何为作恶
  呜呼今大德　　徒学不能知
  自男生我女　　岂非妄想非
  悔过于大众　　于法勿生疑
  我上所言说　　是佛神力持

时庵提遮说是偈已。其比丘比丘尼。优婆塞优婆夷。天及人一千余人。得阿耨多罗三藐三菩提心。有五千众。于中得无生法忍者。得法眼者。又得心解脱者。其无量声闻众。而于佛法自生惭耻者无量

尔时佛告舍利弗。是女人非是凡也。已值无量诸佛。常能说如是师子吼了义经。利益无量众生。我亦自与是女人同事无量诸佛已。是女人不久当成正觉。是诸众中。于是女人所说法要。即能生实信者。皆已久闻是女人所说法故。今则能生正信。是故应当谛受是师子吼了义经勿疑。佛告阿难言。汝当受持此长者女庵提遮。以师子吼了义问答经章句。次第付嘱于汝。汝当谛受。阿难白佛言。唯然世尊。今悉受已。尔时大众闻女庵提遮说法已。心大欢喜。踊悦无量。各自如说修行佛说长者女庵提遮师子吼了义经


佛说长者音悦经

    No. 531

佛说长者音悦经

        吴月支优婆塞支谦译

闻如是。一时佛在罗阅只耆阇崛山中。与尊弟子千二百五十人俱。及诸菩萨。清信士女。一切普会。围绕说法。佛告大众。彼有长者。名曰音悦。财富无数。年老无子。以为愁戚。虽其然者宿福所追。其报有四。一者夫人产男。端正无比。二者五百白马。同时生驹。三者国王遣使者。拜授金印。四者五百宝船。同时俱至。阿难白佛。何等宝船而俱至乎。佛告阿难。长者音悦。群族殊多。先此之时。遣五百人。乘船入海。既获众宝。安隐还家。是故如来。说此四福。同时普集。长者欢喜。心自念言。天降福祚。集我之庭。当作甘馔。室族相庆。即如所言。兴作大厨。娱乐尽欢鼓乐弦歌。声闻于天。是时四大天王。释梵天王。诸龙鬼王。阿须伦王。一切神王。各与眷属。侧塞虚空。看此长者。福德无量。如来神达。知此长者。欢喜踊跃。因其欢悦。欲往称叹。若其开解。可殖福栽。如来应时歌颂吉祥八种之音。往于门外。而说颂曰

  长者今日　　吉祥集至　　一切福应
  室族吉利　　昔所殖福　　其报有四
  大小欢悦　　世间无比　　诸天龙神
  咸为降伏　　快哉长者　　猥获吉福
  如春种禾　　秋则成熟　　先作后受
  影报随逐

尔时长者。闻佛德音。五情逸豫。欢喜而出。见佛恭肃。即便启言。瞿昙沙门。实为神妙。知我室族。吉祥无量。枉屈尊神。来相赞叹。即以好白[疊*毛]直金千万两。奉上如来。佛即受之。而为达嚫。佛告长者。财有五危。世人不知。悭吝贪惜。不能减割。以周穷乏。寿终神逝。弃财世间。汝今能尔。必获影报。所生之处。福自归身。长者白佛。何等五危。佛即报言。一者大火烧之不觉。二者大水漂没无常。三者县官夺取无道。四者恶子用度无限。五者盗贼所见劫夺。五事一至。不可抑制。譬如有人违犯王法。闭在牢狱。应当诛戮。财物没入其官。岂复能却之乎。又复譬如阿难邠坻。财宝无数。国王夺取。主不能制。亦非神龙所能止之。所以者何。以其前世布施七悔。是以今世。七富七贫。长者闻说。益增踊跃。于是如来。忽然还到耆阇崛山

尔时国内。有尼揵异道人。名曰不兰迦叶。听闻如来。诣长者家。歌颂一偈。猥得长者千万两金。心怀悁嫉。心即念言。瞿昙沙门。尚能得金。况我往乞当不得乎。又自念言。我当往求。瞿昙沙门。所可说偈。然后往乞。必得珍宝。嗟叹之宜当胜瞿昙。不兰迦叶。怀此愚痴妒嫉之意。而往稽首。问讯如来。长跪白佛。薄德无福。衣食不充。传闻瞿昙。诣长者家。歌颂一偈。大得珍宝。宁可哀矜。赐所说偈。令吾讽诵。当往咨嗟。冀望得宝。如来三达知。此长者却后一时。财宝当散。不兰迦叶。不知时宜遭厄之家。而说吉祥。必得长者无量杖痛。如来告言。不惜此偈。所以者何。汝不知时。卿说此偈。必得楚痛。是故如来。违卿所求。若更欲得应时之说绝妙之句。吾当与汝。既使长者得闻真言。又可免于捶毒之痛。不兰迦叶。心自念言。瞿昙沙门。不欲令我往乞珍宝。是故吝惜。不肯与我。即便重启。其于与我焉知余事。如来慈愍。谏之满三。终不信解。佛亦豫知。不兰迦叶。前世因缘。应受此痛。如来又云。罪不可债。佛即为说吉祥之偈。尼干讽诵。一岁乃闇。然后长者失火烧舍。珍奇了尽。五百马驹。同时烧死。所生妙子。一旦终亡。王遣使者。录夺金印。后复乘船。入海采宝。安隐来还。泊岸数日。五百宝船。一旦漂没。室族大小无不愁毒。譬如有人而被诛戮。未死之顷。愁怖难言。其日不兰迦叶。往到其门。歌颂如来吉祥之偈

  长者今日　　吉祥集至　　一切福应
  室族吉利　　昔所殖福　　其报有四
  大小欢悦　　世间无比　　诸天龙神
  咸为降伏　　快哉长者　　猥获吉福
  如春种禾　　秋则成熟　　先作后受
  影报随逐

于是不兰迦叶说此偈时。长者闻之。举门忿恚。天下凶殃。无过于我。云何此人裸形无耻。在此妖蛊。说我吉祥。益我忧烦。即出捶打。从头至足。无不被患。举身大痛。匍匐还家。六师宗等。逆问其意。答言。此变正由瞿昙。内不自克。反怨世尊。尔时世尊在罗阅只竹园之中。与诸大众围绕说法。佛告众会。不兰迦叶前从如来。求索一偈。欲诣长者歌颂求宝。如来谏之。其于不信。今已在彼。遭痛毒患。阿难白佛。不兰迦叶与此长者。有何因缘而被此患。佛告阿难。乃昔久远不可计数阿僧祇劫。时有国王。亦名音悦。复有一鸟。名曰鹦鹉。在王宫上。鸣声和好。王时昼寝。闻鸟鸣声。惊觉问其左右。此为何鸟。鸣声妙好。侍者白言。有一奇鸟五色焜煌。适在宫上。鸣已便去。王即遣大众。步骑络绎。逐而求之。推寻殊久。捕得与王。王得欢喜。爱乐无厌。即以珠玑水精琉璃真珠珊瑚。璎珞其身。头颈羽翮。无不周遍。常着左右。昼夜看视。不去须臾

后复有鸟。名曰秃枭。来在宫上。看见鹦鹉独得优宠。即问鹦鹉。何缘致此。鹦鹉答言。我来宫上。悲鸣殊好。国王爱敬于我。取我常着左右。五色珠玑。璎珞我身。秃枭闻之。心怀嫉妒。心即念言。我亦当鸣令殊于卿。国王亦当爱宠我身。王时出卧。秃枭即鸣。王即惊觉。[嗇*欠]然毛竖。如畏怖状。王问左右。此为何声。惊动怖我。侍者白言。有恶声鸟。名曰秃枭。王即恚曰。促遣大众。分布推索。即得与王王令左右。生拔毛羽。举身大痛。步行而去。到其野田。众鸟问言。何缘致此。秃枭嗔恚。不责己身。答众鸟言。正坐鹦鹉。故得此患。佛言。善声招福。恶声致祸。罪报由己。反怒鹦鹉

佛告阿难。昔国王者。今长者音悦是。鹦鹉者。我身是。秃枭者。今不兰迦叶是。昔嫉鹦鹉。即被毒患。今嫉如来。获痛难言。贪嫉烧身。何况苦难。所以者何。不兰迦叶诽谤如来。前后六事。何等为六。一者在于难国。兴贪嫉心。诽谤如来。二者于罗阅只。以竹园故。诽谤如来。三者在罗阅只。诣长者音悦家。贪其金宝。诽谤如来。四者于摩竭提界。贪于供养。诽谤如来。五者在维耶离国。贪名利养。诽谤如来。六者在舍卫国。贪于利养。及惜名称。诽谤如来。于时国王。驱逐出国。不兰迦叶六师徒等。同心说言。瞿昙实神。莫不敬重。吾等术浅。名称崩颓。处处见忽当用活为。即时以沙。而着瓶中。自沉于水。于是寿命终。即入地狱。考治一切。苦痛无量。佛重告言。当未来世。多有贪嫉弊恶之人。诽谤贡高。相求长短。是则自烧痛哉。阿难。是故汝当广宣斯经。以护将来如斯之党。阿难白佛长者音悦。昔殖何德。获此四福。何所罪行。而复失之。佛告阿难。音悦前世。为年少时。钦戴佛法及与圣众。供养尽忠。而愿豪富。纳妻之后。专迷着色。违慢三宝。又无慈心仁接长幼。是故报应。适毕便散。汝开导宣告令知其要。佛说此已。四部弟子。天龙鬼神。国王臣民。一切众会。闻经欢喜。莫不作礼佛说长者音悦经


佛说长者子懊恼三处经

    No. 525

佛说长者子懊恼三处经

        后汉安息国三藏安世高译

闻如是。一时佛在舍卫国祇树给孤独精舍。与大比丘众千二百五十人俱。尔时舍卫城。有大长者。财富无数。田宅牛马。不可称计。家无亲子。其国俗法。若无子者。寿终之后。财没入官。长者夫妇。祷祠诸天日月星辰。求索子息。竖立门户。亦不能得。时长者妇。归命三宝奉受五戒。晨夜精进。不敢懈怠。便得怀躯。妇人黠者有五事应知。一者知夫婿意。二者知夫婿念不念。三者知所因怀躯。四者别知男女。五者别善恶。是长者妇。报长者言。我已怀躯。长者欢喜。日日供养衣被饮食。极使精细。十月已满。便生得男。五乳母共供养子。乳哺者。洗浴者。衣被者。抱持者。儿即长大。年十五六。长者夫妇。为子索妇。得长者女。端正姝好。于城外园馆。大请人客。饮食娱乐。肴膳精细。四方来者。无所拒逆。如是宾从。至于七日。时儿夫妇。游行园中。有树名曰无忧。其上有花。色甚鲜好。如弱绯色。妇语夫言。欲得此华。夫便上树。为取此华。树枝细劣。即时摧折。儿便堕地。断绝而死。父母闻之。知堕树死。便走奔趣。母抱其头。父抱两脚。摩挲瞻视。永绝不稣。父母悲哀。五内摧伤。众客见之。亦代哀痛。死何急疾。众客饮食。娱乐未毕。而反堕树死亡无常。时佛世尊与阿难俱。着衣持钵。入城分卫。见长者夫妇。独有一子而堕树死。啼哭悲伤。甚不可言。佛见此儿所从来生。从忉利天。寿命终尽。过生于长者家。死即生龙中。金翅鸟王。复取食之。三处悲哀。悉共发丧

佛告阿难。诣长者所。解喻其意。为除其患。设不尔者。恐愁忧死。阿难言唯然。即从佛行到长者所。长者闻佛来到其所。心即欢喜。稽首佛足。佛问长者。何为愁忧。乃如是乎。长者白佛。我身无相。由有一子。为其娶妇。请客饮食娱乐未毕。上树取华。堕地便死。我身如石。心如刚铁适得一子。而舍我死。佛告长者。人生有死。物成有败。对至命尽。不可避藏。捐去忧念。勿复忧戚。时佛出光明。遍照十方。使长者见天上龙中父母啼哭。佛语长者。此儿本从忉利天上寿尽命终。来生卿家寿尽。便生龙中。金翅鸟王。即取啖之。三处一时共啼哭。为是谁子。佛即说偈言

  天上诸天子　　为是卿子乎
  为在诸龙中　　龙神之子耶
  时佛自解言　　非是诸天子
  亦非为卿子　　复非诸龙子
  生死诸因缘　　无常譬如幻
  一切不久立　　譬若如过客

佛语长者。死不可得离。去事不追。长者白佛言。此儿宿命罪福云何。生豪富家。其命早夭。此为何应。佛言。此儿前世。好喜布施。尊敬于人。缘此福德。生豪富家。喜射猎戏。伤害群生。用是之故。令身命短。罪福随人。如影随形。长者踊跃。逮得法忍。佛说如是。长者夫妇。一切众会。皆欢喜受佛说长者子懊恼三处经


佛说长者子制经

    No. 526 [Nos. 527, 528]

佛说长者子制经

        后汉安息三藏安世高译

闻如是。一时佛在罗阅只耆阇崛山中。时与五百沙门俱。皆阿罗汉。平旦皆被袈裟持钵入城丐食。时城中有四姓豪贵家。国中第一所居高燥。舍宅楼观甚好。垣墙周匝七重门。四姓豪家字檀尼迦柰。有一子字制年十六。父檀尼迦柰殁。故制独与母居。佛时到其家丐食。时制在内第三门住。遥见佛来制即念言。是人何壹端正绝好乃尔。好如明月珠。光明如日月。其色如黄金。如月十五日盛满。时佛住于门外。制便走入语母言。我见一人来。大端正绝妙天下无有辈。我生以来未曾见人如是。今在门住欲乞丐。制语母当丐之。其母大悭贪不肯丐与。制言。母当哀用我故丐与是人。与是人者如病者得良医。制复言。与是人者名字达于天上天下。是人今续在外住。其母复不肯丐。制数数语母不止。母便恚语制言。汝娆我不止者。汝令我烦乱。母言。是人不用是乞丐故来。但欲欺调汝耳。今汝小痴儿当何等知。汝所索不止者。会得我捶杖乃止耳。佛预知其母悭贪。佛便放威神彻照七重门内。制见佛光明心大欢喜。制即复到母所启语言。愚人不知布施。譬如盲人堕火中。其人但坐无目故。世间人但坐悭贪。不信布施后当得其祸。人心念恶口言恶身行恶。愚痴不信佛不信经不信比丘僧。死后皆堕地狱中饿鬼畜生中。人不悭贪信布施后得其福。身行善口言善心念善。自得其福其人家常当与。智者相随令人有智。制言。母不肯丐与者。自持我今日饭分来。我宁一日不食。哀我疾持来。我欲与是人。恐是人弃我去。是人弃我去是人难值。其母复不肯与。制便自往取饭分。复取所著好衣。持去至佛所。前以头面着佛足。却住叉手白佛言。持我所有衣被饭愿上佛。佛默然不应。制复白言。今佛是天上天下人师。当哀度脱我曹。愿为我受之。当令我得福。如是者三。佛便受之。制即大欢喜。佛语制言。今诸悭贪者汝皆伏之。今日汝施与佛衣被饭食。使汝心中诸欲愿者亦皆得之。制大欢喜。复白佛言。我所可愿者。亦不求作第二忉利天王释。亦不求作第七天王梵。亦不求世世豪贵。愿使我智慧光明如佛。佛言大善。诸所愿者皆令得之。第二天王释闻制语。即在佛后叉手住。天王释便于佛前语谓制言。汝今日持小饭食衣被与佛。便欲求作佛者不能得也。十劫百劫千劫万劫亿劫。汝尚未能得作佛。制报天王释言。我亦不用一饭食故欲得作佛。我常当持善心精进不懈。求佛不止会当作佛。天王释报制言。汝持四宝须弥山。汝慈心念天下人民。千万劫亿万劫。汝尚未能得佛也。制复报天王释言。譬如匠师持斧入山索树木。会当择取好直者。会当可意乃取耳。我不用一饭食衣被故求作佛也。天王释复语制言。汝欲求佛者剧苦。汝不如求作第七梵。若第二忉利天王释。汝欲求作佛难得也。制复报天王释言。汝宁见阎浮利内不。天王释言。见之。制言。满其中大火上至天。持身投其中。我会当求作佛终不止。天王释言。汝满阎浮利地内其中火。是中有人民畜生及蠕动之类。汝不当杀之。汝口言恶心念恶。死当入地狱中。汝当那得作佛。制报天王释。世间人民及蠕动。我持慈心皆付弥勒佛。弥勒佛自当度脱之。我求佛道会不止。制复报天王释言。第七梵众第二天王释。所居止处会当衰败。皆当归死无有脱不死者。天王释便叉手报制言。卿持心坚乃如是。念欲求佛不止者。卿会得作佛。制复报天王释言。汝莫持汝天上意自贡高也。复有胜汝者。我持善心精进不懈。求佛不止会当得作佛。天王释便默然无所复语。佛便语制。汝前后所承事凡六万佛。汝常当愿求作佛。汝常持心精进承事诸佛。却后二百亿万劫。汝不复更地狱饿鬼畜生中。却后二百亿万劫竟。汝当作遮迦越王。当有十亿小国皆属汝。汝当领四天下当飞行。汝所行当正。寿尽当上生第七梵天。第四兜术天。天上寿尽当复下生作遮迦越王。寿尽当复上生第七梵天。如是上下百亿万劫竟。汝当作佛字须弥迦罗。当度脱天上天下人民。汝生下地当照万二千亿天地。上至二十八天上。天地皆为大动。夜明如日出。人民皆寿七千亿岁。汝身当长二百丈。当有万一千城。城皆四百八十里。城皆板着之。皆刻镂金银琉璃水精珊瑚车渠马瑙七宝。汝作佛时当再会说经。一会时有六千亿沙门皆得阿罗汉。第二会说经时。有四千亿沙门皆得阿罗汉。当尔时人民无有偷盗者。男子女人皆同一心无有恶者。亦无山林溪谷地皆平正。人民无有疾病忧苦皆安乐。所居皆自守。天日三雨裁淹尘土。人欲议语皆大聚会。夏月则不暑冬月则不寒皆得中适。汝教授精舍名为难提陀。若有男子女人。持戒布施与佛辟支佛阿罗汉。求作佛者皆可得佛道。不可不求。八方上下无有能穷极者。佛智慧如是。天下人不知生所从来。亦不知死趣何道。佛说经已。制及诸比丘僧。皆前以头面着佛足。作礼而去佛说长者子制经


佛说超日明三昧经

    No. 638

佛说超日明三昧经卷上

        西晋清信士聂承远译

闻如是。一时佛游于维耶离奈氏树园。与大比丘众俱。比丘万八千。菩萨八万。一切大圣神通已达。悉得总持揽十力慧。住无所住超三脱门。善权方便莫不从化。三达之智无所挂碍。游步三世独尊无侣。见生死原本末所起。应病授药令各得所。守护法城救济群生。行四等心慈悲喜护。四恩随时开建桥梁。布施持戒忍辱精进一心智慧以度无极。解空无相无愿之法得不起法忍。现入众生都无所起。诲诸退转令不回还。八不思议拔度八难。与法身合示现菩萨。或为如来声闻缘觉。犹如日光无所不照。往来十方亦无周旋。观一切法如化幻梦野马影响悉无所有。利衰毁誉苦乐善恶永已灭除。皆过世间诸所有法。至于道场等无增减。其名曰普明菩萨。普达菩萨。普智菩萨。普慧菩萨。普至菩萨。光明菩萨。光[火*僉]菩萨。光等菩萨。光英菩萨。光造菩萨。慈光菩萨。慈施菩萨。慈戒菩萨。慈忍菩萨。慈进菩萨。慈寂菩萨。慈智菩萨。慈救菩萨。慈护菩萨。慈雨菩萨。慈明菩萨。慈普菩萨。如是等上首八万德皆如是。尔时世尊。与无央数百千之众眷属围绕。而为说法。讲大乘业无极之慧。于是城中有大长者。名曰善实。与千人俱各各手执七宝之华。来诣佛所稽首佛足。以其宝华共散佛上。而各誓愿。愿使十方众生之类。心软如华意净若空。如来威神令诸宝华皆在空中。于世尊上合成华盖。华盖之光普照十方诸佛国土菩萨。诸天人民靡不睹焉。诸佛世界各有无数亿百千菩萨。来诣佛所稽首毕一面坐。于是慈普八万大士。与百亿天帝释梵王。与三十亿梵诸天神妙天。与十亿眷属净居天。与二十亿侍从魔子导师。与五千亿妓傥相随俱来诣佛所。稽首足下退住一面

阿阇世王与八万人。波斯匿王与五万人。维耶离王与诸尊者八万四千人。郁蝉王与二万人。输头檀王与九万人。拘夷那竭王与六万人。如是诸王。各将官属不可复计。俱来诣佛所。稽首于地迁坐一面

诸比丘比丘尼清信士清信女。诸天龙神阿须轮迦留罗真陀罗摩休勒人与非人。无央数亿不可譬喻。来诣佛所稽首于地。各各分部。或坐或住。佛在众中威神特尊。如日初出若星中月。犹须弥山峙干大海周照四域。世尊放身光明巍巍圣慧无边。普照一切靡不蒙度。四品瞻仰犹冥睹明。于是会中有菩萨。名曰普明。从坐起整衣服。长跪叉手以偈赞佛

  大慈哀愍群黎　　为阴盖盲冥者
  开无目使视瞻　　化未闻以道明
  处世间如虚空　　若莲花不着水
  心清净超于彼　　稽首礼无上圣
  观法本无所有　　如野马水月形
  影响幻化芭蕉　　晓三界亦如是
  从无量难计劫　　积功德不可数
  慈心等定广化　　众生类皆被荷
  了三界其若梦　　觉悉灭无适莫
  生死吾之本末　　斯恍惚无所有
  佛光明靡不照　　威相好难计量
  道巍巍无等伦　　故稽首礼十方
  本发意为十方　　拯厄难济群庶
  已获愿过于空　　一切人莫不蒙
  坐佛树力降魔　　逮无量觉道成
  解诸法本自然　　于异术无所求
  众上佛七宝华　　在虚空成华盖
  光普照十方国　　群黎集受法诲
  圣尊德喻须弥　　智慧光超日月
  所敷演不可喻　　故稽首大圣雄

尔时普明说此偈赞佛已。长跪叉手。问曰。唯然世尊。斯诸会者有发菩萨意。或未发者。有得不退转。或未得者。有得不起法忍一生补处道德成者。或在五道生死缚者。如来加哀深为演现无极宝藏。令未解达心得[火*霍]然。愚冥睹明得不退转。宁有三昧名普照。深浅消散二法。疾至无上正真道乎。佛言。善哉普明。多所哀念多所安隐。愍伤诸天及十方人各令得所。谛听谛听善思念之。唯然世尊愿乐欲闻。佛言。有三昧名超日明。菩萨逮得是者无所不入。譬如日光所在而现无所蔽碍。化终始者使畅三处心意所为其未发意兴菩萨心。已发道心至不退转。立不回还至一生补处。已得补处究竟无上正真之道。等如虚空无往无来。不出不入无所不行。行八十事乃谛逮得斯定。何等八十。解眼空。除耳声。无鼻嗅。拔言着。济于识。息贪淫。休恚恨。释愚痴。了色沫。痛若泡。想野马。行芭蕉。识犹幻。心本净。意喻梦。念同像。不见身。不计人。不有寿。不保命。四大空。五阴无根。六衰无原。七识无主。行慈心。哀一切。志和悦。护诸根。无憎爱。离众对。不散行。无合会。无施不悭。无戒不犯。无忍不怒。无进不怠。无寂不乱。无智不愚。不废俗。不专道。讲说法。不为身。为一切。无所著。亦不断。亦无缚。无所解。行平等。却睡眠。无诸盖。不受入。不随对。心自解。顺佛教。不违法。不轻众。愍十方人。如父严教。若母抚育。譬子顺亲。恩如己身。不自为形。不为他人。亦不为法。行菩萨道。弘雅志。不为邪想。无声闻念。无缘觉意。不求望想。弃彼此行。一切无倚。不见三世。了三界本。不心意识。解道若空。离去来今。深入大慧。一切本无。行大善权是为八十。佛语普明。是八十行。若遵修者。则疾得至超日明三昧。譬如日出一时遍照。百谷草木仰天之类莫不成熟。逮斯定者等入一切上中下行无所不现而皆度之。如月盛满消夜窈冥。以大定明进却三垢想蔽用除而睹上道如大医王。选采百药以疗众病各各得愈。以无极慧随众本行而为说法。屏色痛想行识求使获神通。又如船工御牢坚船。度人往还而无停滞。示现泥洹济无量人。开化止处解三界空。顺至终始救摄群萌。如雄师子隐乎林薮诸兽摄伏。获斯定者开士独步周旋三世。六十二见九十六径诸堕邪者皆为降弃。从受道教三品得所。如转轮王典领四域天下戴仰。斯定四等以四意行。分别四大度脱众生生老病死我人寿命使知本无。得至大道。犹若巨海悉受众流。苞含诸宝奇妙异珍。一切法门总持辩才诸定意门悉而归之。光演深邃无上慧义。兴隆三宝洗濯愚冥。超至日明三昧尊定。佛时颂曰

  譬如日出时　　其光悉遍照
  百谷仰成熟　　大定超于彼
  等至于一切　　杂行群萌类
  普现无不周　　莫不得过度
  医王疗众病　　随时而授药
  斯定应所宜　　淫怒痴消除
  船师度往还　　从此到彼岸
  菩萨亦如是　　所济无穷极
  譬如雄师子　　独步无所畏
  六十二疑见　　斯定皆降化
  若转轮圣王　　绥恤四天下
  菩萨犹如斯　　四等度群黎
  巨海受万川　　瑰琦异珍宝
  斯定苞诸法　　施以七大财
  假使有发意　　欲至无上慧
  当尊斯定义　　疾获正真觉

佛语普明。菩萨有四事。疾获斯定。何等四。愍伤群黎如己骨髓。殖众德本不望其报。观四大空犹若如梦。计五阴本则野马也。是为四事。佛时颂曰

  欲获定意者　　愍哀众生类
  犹如己骨髓　　立德不想报
  观身四大空　　恍惚其若梦
  计五阴本无　　譬若如野马
  设使解慧者　　则不计吾我
  缕练一切原　　速逮斯定意

佛告普明。菩萨有四事。疾得斯定。何等为四。苞育众生爱若赤子。常行大慈无有彼此。劝诲愚痴示以道明。昼夜精进志道无求。是为四。佛时颂曰

  养护哀众生　　如父母爱子
  大慈不劳望　　等心无适莫
  劝化诱愚憃　　使睹大道明
  夙夜乐正法　　乃能逮斯定

佛告普明。菩萨有六事。疾得斯定。何等六。布施平等奉持禁戒一切无犯忍辱之力。被大乘铠精进勤修未曾懈废一心摄意使无众想。智慧明了不着三界。是为六。佛时颂曰

  布施无所望　　护戒如山地
  忍辱立大力　　则被大乘铠
  善修大精进　　未曾有懈休
  一心禅三昧　　智慧无挂碍
  不自睹缘变　　所从兴造立
  三处忽现没　　一心无所住

佛告普明。菩萨有十事。疾得斯定。何等十。施安于人。除诸秽害。消化尘劳。和合别离。释理邪见六十二疑。晓无吾我。常崇十德。欲济一切三趣之难。不为细术所见迷网。从本无教无合不散。是为十事。佛时颂曰

  施安悦众生　　离诸秽害想
  消化于尘劳　　和合乱别离
  释六十二见　　晓了无吾我
  常遵崇十德　　欲济拔三趣
  矜愍诸八难　　往来周旋者
  犹如盲无目　　不自觉没冥
  以故兴大悲　　救脱众危厄
  分别深远慧　　疾得斯定意

佛告普明。菩萨有七事。疾得斯定。何等为七。心专志。道不为他念。于法自在分别英妙。悦颜一切瞻察众生。信知诸法无有根原。常力精进不废于道。建立大意志存永安。将顺护法至获大定。是为七事。佛时颂曰

  策心专志道　　未曾兴他念
  分别于本空　　和颜向一切
  晓了三脱门　　解诸法无根
  常修于精进　　不废于道教
  建立大弘意　　将养到永安
  救护悟迷惑　　得超日明定

佛告普明。菩萨有十事法。疾得斯定。何等为十。无我无人。无寿无命。无声闻。无缘觉。不处二法。不着菩萨。不想见佛。不在生死。不处泥洹。是为十。佛时颂曰

  不见吾我人　　不计身寿命
  无有声闻心　　蠲除缘觉想
  不处法有二　　无著于菩萨
  不想睹佛身　　不住有无际
  [火*霍]然不自见　　乃睹一切空
  因缘不复起　　乃得成定意

佛告普明。菩萨有八事法。疾得斯定。何等为八。等观邪正无有二心。常念三宝令不断绝。讲深法义未曾谈话。业以大乘不乐弟子。所造顺法不舍佛道。平正方便除诸起灭。因缘之想永已灭尽。意止至寂不为愦乱。一心定意睹见十方。是为八。佛时颂曰

  等观诸邪正　　二俱无所处
  常念于三宝　　令慧不断绝
  说演深义要　　未曾生他想
  业以供大乘　　不慕于小乘
  所造常顺法　　不释佛正道
  方便行平等　　除诸起灭缘
  意止至寂寞　　未尝兴愦乱
  一心存定意　　明睹十方佛

佛告普明。菩萨有七事。疾得斯定。何等为七。解色本空声如呼响。香若风等。味若缘合。细滑何乐。晓识如幻。诸法喻梦。是为七。佛时颂曰

  解色之本空　　耳声犹呼响
  鼻香风气等　　细滑更则过
  了诸识幻化　　一切法则梦
  能分别如是　　得超日明定

佛告普明。菩萨有五事。疾得斯定。何等五。等心十方人与非人。于供养利不以适莫。若有讲经后不宣阙。不望他人财色之宝。深入微妙难喻之法。是为五。佛时颂曰

  等心于十方　　人非人无异
  若获于供养　　其志无适莫
  假使讲经者　　没命不讼阙
  不望他财利　　深入乃逮定

佛告普明。菩萨有五事。疾得斯定。何等五。过空无相不愿诸法。晓三达智辩才无碍。行大智慧度于无极。善权方便无所不入。是为五。佛时颂曰

  过空无相愿　　晓了三达智
  辩才不可量　　所说如大海
  修行大智慧　　所度于无极
  善权皆周普　　日明定如是

佛说是时。三十亿菩萨皆得不起法忍。八万四千人发无上正真道意。三万人远尘离垢诸法眼净。八千比丘漏尽意解。三千世界六反震动。天雨华香。箜篌乐器不鼓自鸣。飞鸟禽兽皆来集听。十方菩萨自然飞来。各擎诸华如须弥山用散佛上。若干种衣被服珍宝供养世尊。大圣难值如优昙钵花时时可得。斯法希有难以遭焉。佛大神通从无数劫。积累功德恢弘大哀。布施持戒忍辱精进一心智慧善权方便皆为黎庶。自然获之功不唐捐。吾为善利得见如来。闻深妙法超日明定。快哉快哉何乃侥幸至如斯乎。佛告诸菩萨。审如所云实无一异。信于深法能遵修者。则当逮得超日明定十慧之德。何等十。具足四等。四恩无厌。遵崇大慧。普畅大定。神通则达。成就六度不起法忍善权方便。见十方佛。能领国土。一生补处。已逮道场三达之智。是为十。说是语时。无数菩萨得不起法忍。不可计人发无上正真道意。尔时有菩萨。名离垢目。白佛言。何谓菩萨学。何谓声闻学。何谓缘觉学。佛言。无限无碍其心泰然是菩萨学。有限有碍其心偏局是声闻学。庶慕大乘进退无慧心存中跱是缘觉学。离垢目又问。何谓无限。何谓无碍。何谓泰然。佛言。发无上正真道意。慈哀一切。欲度蚑行喘息人物之类。布施持戒忍辱精进一心智慧善权方便。但为一切不念己身。遵四等心慈悲喜护。加以四恩惠施仁爱。利人等利一切救济危厄穷匮化之为道而为慧学菩萨之道。自省己过不察彼阙。敬如父母如子如身等无有异。以身敬德等一切人。以爱子事愍一切人。仇怨亲友心无殊特。解知身空众生无处。吾我自然诸法自然。道法自然佛法自然。一切本无无形无貌。是为无限。于生死元求索泥洹不见泥洹。于泥洹元求索生死亦无所睹。不恶生死不住泥洹住无所住。犹如日光遍照悉至。亦无往来光无想念。菩萨如是普入一切亦无所入。亦无往返周旋之想。譬如大海中有七宝明月之珠。龙神鲛蛇鼋龟鱼鳖悉含受之无增无减。其水一味亦无能秽。菩萨如是。现于生死三趣之难。若至泥洹无为之界。未曾增减心如明珠。若喻净水终不秽浊。普济群生入诸通慧平等之味。以示众生犹如空中生药毒树。其毒树者不害虚空。其药树者无所疗治。菩萨如是。若在生死三毒之中无所沾秽。假在泥洹清净之处亦无所净。俱度黎庶无所不济。虽曰有入亦无出入往来周旋也。是谓无碍。道心无限不有处所无人无心亦不可得度众生心如一切法如其趣此者则趣平等其趣平等则正等觉无三界也。无声闻地无缘觉处无菩萨住。不处有为不处无为。无有无无。亦无过去当来现在之处。度无所度生无所生。道迹本无往来本无。不还本无无著本无。缘觉本无三界本无。众生本无佛道本无。无此本无乃真本无无所适莫。是谓其心泰然

离垢目又问。何谓为限何谓为碍。何谓其心偏局。佛言。畏恶生死三界之患言泥洹第一不了自然厌身之苦。惮无数劫周旋尘劳。布施持戒忍辱一心精进学智不倦。头目耳鼻髓脑肌肉支体所在惠与不可称限。乃到于佛豫怀是心。便却不学菩萨法欲求灭身。是谓为限。已得罗汉欲有所度三昧禅息乃见人心不能豫睹一切根本不应病授药适欲久住。观察恶露不净之躯。不以为乐视如仇贼。如虺如毒早证泥洹。是谓为碍。住于泥洹好明恶冥。不了诸法都无根本。而求处所不知空慧。是谓其心偏局

离垢目又问佛言。何谓中跱。佛言。发菩萨意。布施持戒忍辱精进一心智慧皆为妄想。欲得世尊三十二相八十种好。威神圣德与众卓异。不解本无如来之化。示现身命反求谓有。又谓有人欲度吾我不知本空行四等心四恩着行至空无见无为因止不知进退不知空慧欲度众生无善权方便法身之明可以济之。是谓缘觉学。说是语时。无数天人皆发无上正真道意

于是长者子名曰净教。与五千群从。来诣佛所稽首佛足。退坐一面。叉手白佛言。此诸群从好乐佛法。诸发道意。积何等行得至道慧。施行何法得摄佛土。佛言。有一法行而应道意。何谓一。心性调柔等向一切。是为一。佛时颂曰

  心性常调柔　　志意不粗犷
  平等摄一切　　乃应菩萨行

复次又有二法为菩萨行。何谓二。寂然心净离诸着观。睹于无见唯志大道。是为二。佛时颂曰

  心净常寂然　　离见诸着观
  释六十二疑　　唯念大道行

又有三法为菩萨行。何谓为三。晓空不着。无相不缚。无愿不脱。是为三。佛时颂曰

  心常晓了空　　无相不复缚
  无愿无所脱　　乃解三界结

又有四法为菩萨行。何谓四。常遵慈心无有害意。长养道化常修慈悲。愍伤众生生死勤苦为之雨泪。常奉喜意和颜悦色。向于群萌无憎爱心。常行护心劝教众生使发道意已发道意至不退转已不退转。至于道场无上正真。道是为四。佛时颂曰

  常遵四等心　　和颜意志悦
  愍哀众生类　　矜伤为雨泪
  心欲度众生　　等心无憎爱
  救护以道法　　乃应菩萨行

又有五法为菩萨行。何谓五。奉于禁戒而无所犯。定意摄志令心惔怕。智慧解空而无所起。脱于五阴使无处所。示现三界睹无所有。是为五。佛时颂曰

  持戒无所犯　　三昧意不乱
  智慧分别空　　济脱五阴聚
  睹见三世厄　　示现在其中
  随时而开化　　各令得其所

又有六法为菩萨行。何谓六。目睹皆空。耳听无声。鼻嗅无香。口语无言。身不存细滑。心无思想。是为六。佛时颂曰

  目所睹皆空　　耳听无有声
  鼻香无所著　　舌味何所有
  计身但四大　　心了本空事
  如是晓无形　　乃应菩萨行

又有七法为菩萨行。何谓七。摄身口意寂定无乱无所复违。是为七。佛时颂曰

  常摄己身口　　其心静不乱
  寂寞定三昧　　神通无不达

又有八法为菩萨行。何谓八。施度无极。戒度无极。忍度无极。进度无极。寂定度无极。智度无极。权度无极。成名慧行。是为八。佛时颂曰

  布施度无极　　戒忍精进禅
  智慧自然达　　道明为最尊

又有九法为菩萨行。何谓九。除五阴。去六衰。灭三垢。蠲八难。不着三界。不慕三世。离罗汉心。远缘觉意。常志大道。是为九。佛时颂曰

  除五阴六衰　　无三垢八难
  不着于三界　　三世无所处
  以离罗汉心　　无缘觉之念
  常慕求大道　　斯谓菩萨行

又有十法为菩萨行。何谓十。法宝三昧。善住三昧。无动三昧。度无转三昧。宝积华三昧。日光耀三昧。诸利义三昧。现在三昧。慧光耀三昧。勇猛伏三昧。超日明三昧。是为十。佛时颂曰

  以法宝三昧　　善住无所动
  竖立不可震　　宝积花三昧
  光耀诸利义　　现在慧光明
  勇猛伏三昧　　乃获超日明

复次难垢目。菩萨布施天人乐从。开化悭者令无所惜。菩萨遵戒。天人乐从。化放恣者令无殃衅。菩萨忍辱天人乐顺。化忿狷者令无纤介。菩萨精进天人乐从。化懈废者令建勤力。菩萨一心天人乐习。化愦扰者令志安寂。菩萨智慧天人乐顺。化蔽碍者令通圣范。菩萨行慈天人乐之。化不仁者令等惋恋。菩萨行悲天人乐之。化愚迷者悼愍众生。菩萨喜悦天人乐从。化愁戚者法鼓自娱。菩萨行护天人乐之。救化无援将养一切。菩萨讲法天人乐听。化志俗者令慕圣典。菩萨谦苦天人乐恭。化贡高者奉敬三宝。菩萨利人天人乐惠。化无义者令普施恩。菩萨行等天人乐豫。化不恢泰令接未达。菩萨行权摄诸众生。化之为善成平等觉悉生彼国。菩萨行三十七品以摄众生。意止意断根力觉道。摄取众生使令寂然。若成佛时悉生彼国。菩萨在于大会讲深妙法。欲使蠕动悉蒙超度。若成佛时皆生彼国。菩萨行十德以摄众生。悉开化之护身口意。菩萨说经蠲除八难。以摄众生行八正道。若成佛时皆生彼国。菩萨自省不求彼阙。以摄众生离诸邪见六十二网。若成佛时皆生彼国。菩萨说法以摄众生。脱于八缚得至八解。若成佛时皆生彼国。菩萨说法除八思议。至不思议法门之海。若成佛时悉生彼国。菩萨说法假使逮得无所从生法忍。成具佛事示现泥洹。度无量人皆使得道。如是离垢目。菩萨所行本末若斯。以应此行号字自然。成立国土度脱群黎。佛说是时。离垢目长者子五千营从。皆发无上正真道意。寻时逮得不起法忍。于是居士名曰见正。前白佛言。我常闻佛思一奉觐。罪盖之故不能自到。今日乃果欣踊难量。视尊无厌听法不倦。唯加大恩使我世世值遇天尊。佛言。善哉善哉。有四事常不离佛。何谓四。常念如来立佛形像。闻经深义则信奉行。虽不见佛晓了本无。知十方佛则一法身。是为四事不离诸佛。又有四事虽面睹佛则不见之。如来现在不往听经。不采其义。不能奉行。宣示于人。是为四虽面见佛则为不见。又有见佛。自计吾我。不解非常苦空非身堕四颠倒。听经着音不能分别呼声之响。于其人身则灭度也。佛以灭度不现世间。其人闻经欣然心开。如冥睹明晓知如来随俗现化。奉行道禁不违经典。离外邪法六十二见。行四等心无僧无爱。佛虽灭度志达如是常为相见。复问曰。何谓见佛。何谓闻法。何因供养。佛言。见如来身。观知何行得至于佛。本因六度无极。愍伤一切如父如母如子如身不贪四大是为见佛。闻说经法不着音声。但取其法不取于人。取要不声取慧不形取正不说。是为闻经。若见道迹往来不还无著缘觉世尊菩萨。等心供养谦逊卑顺不以憍慢。为见圣众。又问曰。何谓魔事。佛言。魔有四事。何谓为四。一曰身魔。身犯众恶五阴六衰不顺佛法。二曰欲尘魔。爱欲情态无有休息。三日死魔。生诸想着不兴法念。四曰天魔。及与官属来试乞求无有厌足。意止意断魔则降伏。譬如两木相揩则自生火还烧其木。火不从水出不从风出不从地出。其四魔者亦复如是。皆由心生不从外来。譬如画师画作形像随手大小。虽因缘合有彩有板有笔。画师不画不能成像。四魔如是心已坚固便无所起则无四魔。所以者何。五阴无处四大本无。十二因缘无有端绪。晓了如是则无魔事。计我人有寿命堕魔见缚。分别无身乃降伏魔。离垢目白佛。何谓法宝三昧。佛言。不断三宝佛法圣众。何谓不断。发无上正真道意。成诸德本如须弥山。信乐大乘心不动移。先睹嘉瑞三千佛土。亿百千藏皆满具足。逮成殊胜难当总持。而成就达施度无极。初发心时舍身之安。常忧一切诸乐。所乐不以为乐。弃俗所慕以法为乐。何谓俗乐。吾我人寿五阴六衰十二因缘伎乐饮食官爵奉禄财物富贵妻子奴婢眷属营从田宅牛马车乘是俗所乐。何谓法乐晓知无我无人无寿无命。五通六达十二部经。讲读讽诵菩萨道法。于七法财不以为厌。四恩之行。行四等心慈悲喜护。六度无极众善之行。无毁害心蚑行喘息人物之类。以为国土不自称誉不毁其余。其心慺慺常志一切。天神龙鬼人民大小睹斯人者。莫不兴意而为善德。是谓法乐。又行十事。何谓十。信根第一。定根为本。大慈为元。大哀为尊。志性调柔。诸通慧正。建立众生。四恩为首。道品则最。志护佛法以为徒隶。是为十复次不犯十行。何谓十。身不杀盗淫。口不妄言两舌恶口绮语。意不恚嫉狐疑邪见。是为十。愍念十方如母念子。于色痛想行识不乱。不为俗人所惑。不为荣华所侮。不从贪人不从嗔恚不从愚痴。不谤三宝不怀谲诡。兴六念行佛法众施信慧。出入行步不尚矜高。初发意者如月始生会当成满。天龙鬼神所见拥护。不为邪恶所见中害。心存三法以道为宝以世为无常。是为法宝三昧也。离垢目又问曰。何谓善住三昧。佛言。譬若如地。善恶美苦臭香不净之物悉受不污。菩萨如是受一切法而自修立。先睹嘉瑞三千佛土平等如掌。众宝莲华以为庄严。逮成殊胜难喻总持。则具超越戒度无极。又行十事蠲八难态。建立佛德度于声闻。缘觉之乘。净身口意诸事所由皆从佛法。严庄志性度三趣厄。具满诸愿检御人心。是为十。身常行慈不窃不淫。讲议经典不为浮华。至诚和诤言软不粗未曾绮饰。舍贪念施为人安调。离于邪见而乐正法。常观非常苦空非身。以世为秽以法为计。心自修立常患不及。视身无益五阴则损欲拔五欲。佛道为尊不怀悔恨。察天无常观人如梦。三涂最苦怜愍伤之。以何方便自济生死五阴之难并化他人。计十方人则为我所。所以者何。欲度脱之。见来侵者不念其恶。若光益者不偏念善。见骂詈者默而不报。若挝捶者受而不挍。若嗔恚者慈心向之。若轻毁者哀而不害。又自羞耻从无数劫在生死中。五阴所盖不能自拔。心迷意惑流于五江四惧之患不能自觉。有物能施知财非常身非我有。求于善友远离恶友。发意向佛恒求尊经。不慕世名行常恭敬。志于信戒闻施慧道。不为疑惑犯禁懈怠悭贪愚痴舍道义也。常思念法如饥求食。稍入于道如泉远流稍入于海。如母生子乳哺养育。治生救命不居畜积。供给父母弟兄妻子奴客婢使皆念愍哀欲令得度。不堕三涂使越三界。归命三尊佛法圣众。获三达智无碍之慧。不为三垢之所沾污。其行是者则善住三昧也

离垢目白佛言。何谓无动三昧。佛言。譬如师子诸鹿之王。鹿兽畏威靡不慑伏。先睹嘉瑞三千佛土自现执持五兵勇猛逮成善住总持。则具超越忍度无极。又有十事何谓十。忍辱为本。信悦为力。训一切人深妙法忍。散割诸结。除所欲碍。不慕身原。不惜寿命。以诸通慧。超三脱门。观法平等。是为十。护身口意常以诸法而兴因缘。何谓法乐。乐于佛法不好俗法。乐闻经典不思世谈。乐供养众不为俗党。但乐三宝不志三垢。乐度三处不为沾污乐观四大为地水火风不计我许。乐安人物不为危害。乐施所有不为悭吝。乐奉禁戒不毁所遵。乐忍于辱不失德本。乐精进力不为罪根。乐禅一心不为乱意。乐深智慧不为愚惑。乐化尘劳不为垢浊。乐佛国净不厌开化。乐严道法不为非法。乐三脱门离空相愿。乐无为法不乐俗为。乐入深法不为失节。志乐欣喜离怒不谛。乐自然法亦不舍人。乐习善友远世亲厚。乐常志道不造迷惑。乐讲正议不为俗典。乐慕菩萨不为声闻。乐求正觉不为缘觉。乐向大道不为细术。乐存八等不为八邪。乐六十二慧不为身堕六十二见。乐无上法不为下劣。乐大乘业弃罗汉法。是为法乐。又有十事。疾得定觉。何谓十事。慈心哀人不为危害。常行十善。远离恶行。专心修道。善念佛法。如饥求食如渴求饮。普尊深义。不偏他念。慈念十方。欲度一切不自念己。是为十。所以名曰无动三昧之法。超越第一第二三昧之故。不为欲法之所迷惑。奉行菩萨慈心之法。布施持戒忍辱精进一心智慧以救众生三趣之难。稍习大慈欲济三界。视一切人如己无异。不为他念常念法念。以法为本以俗为罪。常哀群萌悉使至道。是为无动三昧。离垢目白佛言。何谓度无动三昧。佛言。譬如自然钩销力士勇猛力强多。所开辟独步雄杰。雄杰无侣除诸秽害尘劳仇怨。先睹嘉瑞三千佛土。四方四隅有大风来。若干种华普遍佛土。分别逮成难当总持。则具超越进度无极。又有十事。何谓十。等精进根进力为本。平等方便意止为首。令一切人不贪乐身。而以心口顺化众生。所住不回而无所处。精进最上降伏怨胁勤修成就诸通妙慧。是为十。念四大身犹若蚖蛇。畏老病死不舍终始不为惑事。慈悲喜护蚑行喘息人物之类。如父如母如子如身等无差特。常思道义无贪怒痴念。为布施不为悭想。奉持禁戒无犯恶想。为忍辱念无嗔恚想。常修精进无懈怠想。精专一心无乱意想。智慧行正无闇蔽想。常求方便至心善权无放逸想。念劝化人如度己身。一切所有非我之有。念堕地狱者毒痛之患如身自遭。常省己过彼罪代受不以为怨。念饿鬼趣饥渴穷乏。为之悲泣战栗寒心。欲令度脱自然安隐。使服法食除五阴六衰之渴。诵习经典以为饭食。分别经义以为饮浆。修六法行以为贤良。出入行步精进安详。念堕兽者常怀恻怆。欲令安隐毕其前债。了故世罪无令造新。奉行诸善不为众恶。自观察已世世不了。坐计吾我不信道法。思犯罪者如没深渊。奉法信戒心如虚空。不解法者展转五道犹如车轮。父母相忧兄弟相念。夫妻相恋持心不坚。若为父母反为子女。本为子女反为父母。或为夫妻更为怨家。颠倒上下无常根本。此菩萨意常慈念之。开化使信入佛正道。信解非常苦空非身。是为度无动三昧

离垢目白佛言。何谓宝积华三昧。佛言。譬如忉利天上昼度树。以诸本行度于五根。超越众生心净如空。先睹嘉瑞三千佛土。众音伎乐杂交璎珞庄饰其身。以思夷华光耀其体。雨解脱华及青莲华侍在其上。以是之故诸德总持。便为受应禅度无极。又有十事。何谓十。调伏诸根以为德本。一心为力。平等方便。定意不乱。禁戒为原。脱门为上。趣于定要。而无所有。消殪尘劳。具惟诸定。是为十。愍哀五道攻除五阴。成立五根蠲化五色。而已积德具足五品戒定慧解度知见品。慕志五通十力当蒙。不与诸殃罪衅相遇。在在生处常修佛法。名德远着愍哀三界。不为愚迷了善恶趣。譬如万川归向四海流驶水之渎。此菩萨行奉法如是。精进不休遂向大道。譬如若月十日之时光明转盛照于众生。菩萨如是功德威耀日日增益。度诸危厄哀愍群黎之患。又有五事行。何等为五。五戒清净譬如明镜无所沾污。十善不犯以为具足不失道意。不为邪想。不自贪身。是为五。复有五。除嗔恚色。无怯弱心。弃悭贪意。蠲谀谄志。分别解空。不但口说常修一心不为乱行。知豪贵势富乐如化。观色如泡。痛痒如沫。想如芭蕉。生死如影。识若如幻。不为色使。不为痛痒惑。不为想还。不为邪行。不为识退解五阴空。是为五。复有五。何等五。贪淫嗔恚睡眠调戏狐疑。除斯五盖。彻视洞听轻举能飞。知人心所念。自知所从来生死之处。以五神通而自娱乐。不以五阴而为放逸。身修德行不为非法。开化说法多所安隐。不为多恶危害之事以道为业。习法为食解义为饮。不慕豪贵以法为豪了空为贵。是为宝积华三昧

离垢目白佛言。何谓日光曜三昧。佛言。先睹嘉瑞见三千佛土。众宝浴池八味之水湛满且清。植以青莲红黄白华。周匝栏楯皆用七宝。与瑞华俱。底布金沙。自身娱乐游戏其中。逮成慧定证明总持。则具超越智度无极。又有十事。何谓十。慧为根原。智力为上。正见为最。等意为胜。修身诸德。尽入诸种圣谛之相。为平等相。慧无阴盖。除诸往见。不起法忍。是为十事。观于六情本无处所。无所从来无所从去。本自然空缘对而兴。譬如天雨不从龙出不从水出不从地出不从龙心出。皆因缘合会乃致此雨。六情诸入亦复如斯。犹因缘成不得独立。生死如是。譬如画师画作人像屋室舍宅象马车乘。未画作时不见处所工治。壁板素笔彩绘具众缘合具会乃成之。善恶如是因缘合成。若复行道因十善行六度。无极布施持戒忍辱精进一心智慧善权方便。乃合成耳。不着佛身不离佛身。心意无想自然如空。稍入大慈又修大悲喜护等行。不自为身常为一切亦不有求。身行谨敕口言谦顺心念柔和。无有谀谄质朴无邪。又有六事。疾得无上正真之道。何等六。常依佛住。入于正真心不回还。于内意行而自晓了。得善朋友因而委付。志愿弘绰不以厌足。心非不协不乏智慧。是为六菩萨行道不倚于色痛想行识不倚内外。随本法教不违菩萨深妙之行。不废大慈不失大悲。随世所乏而救济之。修道正化不为邪教。一心向慧不为愚蔽。分别六衰犹如化幻影响野马水中之月梦中所见忽不知处。是为日光曜三昧。多所感动柔顺法忍

离垢目白佛言。何谓为逮成诸利义三昧。佛言。先睹嘉瑞见三千佛土。众宝浴池察其左右。度地狱厄游于旷野。逮成奇特聚落总持。则具超越权度无极。又有十事。何谓十。入诸志行。建立众生。无极大慈普哀为本。心性调柔未曾厌倦。舍于弟子缘觉之乘。所观审谛。导御道心。以诸通慧。立不退转。觉了弘智。是为十事。常以正慧。远离邪见。自然修道不为俗惑。深入微妙无极之法普入道俗。于俗不俗于道无倚。思及圣教开化众生。老病死者常护身事。攘却六情不堕六衰。不从七邪常摄七觉。心了不邪精进不废。顺法不违好喜不恨。信根不迷安隐不危志定不乱。信财信智本无戒财。不坠小乘惭愧财。愧于三界未得度也。羞耻财耻不弘慧。博闻财闻无等伦。至深远智布施财施。以大道智慧财。入于智慧广度一切。有十事至不退转。何谓十。闻有度无极心不动回。有佛无佛心不动回。有法无法心不动回。有圣众无圣众心不动回。有道无道心不动回。有菩萨无菩萨心不动回。有法身无法身心不动回。有俗无俗心不动回。有人无人心不动回。有命无命心不动回。有寿无寿心不动回。是为十。飞到十方教化诸天及诸群萌。以法为本以道为原不计吾我。或入地狱救济苦痛。或入禽兽开化愚冥。或入饿鬼慰满饥毒。随俗训化各得其所。不为俗法之所染污。净如日光明若月盛。菩萨得不退转能行权变。有所开济辄多保度。诸苦恼者皆获大安。诸无智者悉弘智谋。是为逮成诸利义三昧

离垢目白佛言。何谓为现在诸佛目前立三昧。佛言譬如月盛具足满时众冥皆除。喻诸所作精修清净所愿者成。具立佛土训化众生。先睹嘉瑞三千佛土。师子鹿王首戴缯帛。其身高大威御杂兽。逮成无极诸总持门八万四千。则具超越以慧成就。又有十事。一心定意三月。无想念。专志向佛。众想皆断。不为诸求。解法悉空。不畏三界。不乐无为。不计有为。解知法身。是为十。其所向方闻现在佛常念彼方睹佛众会四部弟子为说经法。察四大空。地如聚沫。水如朝露。火如红电。风如摇扇。分别四大因缘合成本无所有。自观身貌察一切根本无形貌。自观痛痒知本无痛痒。自观思想察一切思想。知本无思想。自观其意知本无意。以观已空见一切无。愍哀八难释世八事盛衰毁誉有名无名勤苦安乐。舍于八邪不住八正。等处有无亦无所住。行四等心慈悲喜护。四恩济众惠施仁爱饶益等利。一心向佛无诸想念。五阴则断六衰无处心则得定。不见四大不见人民。不睹天地人物永无所见。久久乃睹十方诸佛。譬如水浊不见其底。停久不动详而清澈。菩萨如是。适定无想观无所见。五阴六衰[火*霍]如云除。日月光显睹十方佛。以复观之我至佛所佛为来耶。心则自惟佛亦不来我亦不往。譬如明镜清水净油。观形睹影不入不出。菩萨如是。睹十方佛亦无往还。譬如梦中归本乡里。自见父母兄弟妻子。寤则不见。菩萨如是。睹十方佛从三昧寤都无所见。所以者何。解知本无三十二相八十种好但化现耳。无形无处譬如虚空不可别知。何者是空法身如斯无有处所。乃能睹达一切之原。坐睹十方不往不来。是为现在诸佛立目前三昧

离垢目白佛言。何谓为慧光耀三昧。佛言。先睹嘉瑞三千佛土。转轮圣王造法王教。无量君子臣辅百千眷属营从。于虚空中执诸宝华以覆其身。逮成无尽行总持门。六十万垓诸总持慧。则具超越教化众生。譬如明月神珠令诸穷匮周满所侥。具足诸法训诲群萌。随一切人而应施与无尽德藏。又有十事。何谓十。以法布施。戒摄不顺。忍摄强暴。进摄慢怠。一心摄乱。慧摄邪智。善权随时化以大乘阐弘大道。游于八难脱八邪行。等心一切无偏颇行。是为十。住八不思议不舍菩萨。观于三界若如幻化不以为实。自忖何来去至何所。不见去来而随行住各各自成。譬如野马夏行旷野无人之处。遥见大河流水。其傍生树若干种果而甚茂盛。其人饥渴既热。疲劳不可复言。欲往趣之看之如近。走有里数都不见水。乃解野马无有水也。达者频睹则知无水。不走趣求。众生不了三界如幻化者。计吾我有寿命。闻佛说经一切无常。乃思觉之不复为惑。菩萨解如一切处三界者。如化如幻如影野马如梦水月。悉知本无。无著无缚无脱一切无求。犹如燕母养活诸子。菩萨如是。开化一切亦无所置。譬如导师多将贾人归本乡里。不逢恶贼安隐到家。菩萨如是。以慧光耀三昧之定。携接一切去淫怒痴三毒之冥。开示三乘大乘为本各令得所。譬如医王见众人疾应病授药。诸被病者莫不消除。菩萨如是。以慧光耀三昧。普见群萌五道之患三毒酷苦。以大慈悲而开化之。令奉正训无极之慧。发未发者。坚进回向者。升一生补处。至无上正真之道。是为慧光耀三昧之定也

离垢目白佛言。何谓勇猛伏三昧。佛言。譬如转轮圣王功祚无量威德巍巍而得自在。于一切法得无尽慧。方之虚空无垢清净。先睹嘉瑞三千佛土。如来形容紫磨金颜。其光方圆与无数梵德亿百那术而为说经。逮成无量行总持门。恒沙百千垓总持行。则具超越圣智多所成就。又有十事。何谓十。志一切智无所适莫。不住有为不住无为。行普慈心等于众生。行大悲心等若虚空。无弟子念无菩萨想。亦无俗志亦无道意。常以大慧顺化群黎。入一切生亦无所生。现诸佛土不舍法身。等心吾我及与泥洹。是为十事。不以身口有所言行。心常安定不增不减。现于欲界度诸欲尘。于欲自然亦无所著一切无求。譬如莲华不着尘水。现于色界于色自然无所求望。譬如麻油不与水合。观色无色自察本无亦无所察。现无色界无色自然无后无前。譬如火焰不烧虚空。亦无增损不来不去无去来处。独步三界以越三处。譬如飞鸟飞行虚空无所挂碍。济脱三界各随本志。使疾开解得至大乘。譬如医王持若干药。各以应病而令服食。风寒热病即使瘳愈。菩萨如是。以佛法药。疗治淫怒痴病。使无有余。其心清净无形无名。犹如猛健大军之主攻讨恶逆。菩萨如是。以大慈悲开化众生。诸周旋者闇昧之人。六十二见诸邪狐疑堕罗网者。及六十二诸非正法。皆令发意。自遵六度大慈大悲众行之要。使至大乘。譬如船师御坚牢船。通度往还一切黎庶。各随彼此。菩萨如是。以勇猛伏三昧之定。度脱无量生死之恼。于声闻现随心开化。于缘觉现从本诲授。示现佛身开三道教。或现大法无极之慧大乘深法。无三恶道亦无三乘。譬如幻师于大众中自现身死火烧兽食。众皆恐怖各各求哀。大馈遗之欲令复身。知得宝多便从地起亦复如故。亦无有死亦无起活。菩萨如是。开化众生生死五道。或发菩萨或为声闻或为缘觉或生天上忽现泥洹。众人啼哭谓之灭尽。悉现他方缘觉声闻亦复如是。谓已灭度。无所复有如火烧灭。亦无处所则归火本。菩萨虽现泥洹与法身合。亦无往来还复示现随众化度。菩萨大士乃达之耳。解知法身。譬如日照现于水中及郡国县邑丘聚村落。日殿不下亦不转移。在于人间而明悉至不去不来。菩萨如是。现于三界亦无往返周旋也。度脱一切亦无所度。是为勇猛伏三昧也

佛说超日明三昧经卷上佛说超日明三昧经卷下

        西晋清信士聂承远译

离垢目复白佛言。何谓超日明三昧。佛言。其明无量不可譬喻过于日光。所以者何。日之光明照现在事。人物蠕动百谷药木诸天龙神。皆因日成普得茂活。日不能照二铁围间。亦不能照人心之本令开达也。但照有形不照无形。超日明三昧所以胜者何。殊照十方无边无际三界五道靡不彻畅。菩萨大乘照于声闻缘觉之乘。九十六径六十二见邪疑结冥。使心霍然皆发道意。业三乘者各得成就。或得生天或得人身无不普蒙。如忉利天处须弥顶。天帝释宫紫绀宝殿炳然在上。中四天王下四方域。诸天人民饿鬼厌鬼诸神阅叉。超日明三昧亦复如是。心坚不动如须弥山王。化五道天王帝释。化生老病死踰四天王。疗诸不孝淫怒痴垢使发道意。释小乘志大乘。发意受决得忍受决未发意受决。行六度无极。悉无妄想不觉受决。超日明三昧甚深甚深。不可称量无有崖底。譬如虚空。假使有人欲量虚空。升合斗斛多少之限。空尚可量尽知其斛数。超日明定慧不可量也。譬如人度空。十里百里千里万里亿里亿万里。无央数亿百那术里。空尚可尽究其边际。超日明定慧殊于彼。无数亿亿倍而复倍无能限量。造譬喻者所比道明无远无近无广无狭

离垢目问世尊曰。大圣嗟叹当言极广甚大长远。何谓无远无近无广无狭。佛言。有狭之故因日有广。有近之故因日言远。无远无近无广无狭无可比方。假喻譬之。欲使人解无有边际如空无际。超出其外微尘无色。开入其里。无复计挍。引喻了义至大道慧无有譬也。过诸声闻缘觉菩萨乃至无上正真之道。为上为尊为无畴匹为无等伦。自然之法无有作者亦无不造。无来无去虚无自然。晓了一切本无。晓了一切本末。已了诸本。亦无所倚亦无所不倚。自然之慧皆别了之三界自然。三界自然人物自然。人物自然生死自然。生死自然本无自然。本无自然佛道自然。解分别斯一切自然。乃能逮得超日明定。普济三世至无极慧。是为超日明三昧。于是有长者女名曰慧施。与五百女人俱来诣佛所。前稽首足下却坐一面。闻佛说斯超日明定。喜踊无量。前白佛言。我今女身。愿发无上正真道意。欲转女像疾成正觉度脱十方。有一比丘名曰上度。谓慧施曰。不可女身得成佛道也。所以者何。女有三事隔五事碍。何谓三。少制父母。出嫁制夫。不得自由。长大难子。是谓三。何谓五碍。一曰女人不得作帝释。所以者何。勇猛少欲乃得为男。杂恶多态故。为女人不得作天帝释。二曰不得作梵天。所以者何。奉清净行无有垢秽。修四等心若遵四禅乃升梵天。淫恣无节故。为女人不得作梵天。三曰不得作魔天。所以者何。十善具足尊敬三宝。孝事二亲谦顺长老。乃得魔天。轻慢不顺毁疾正教故。为女人不得作魔天。四曰不得作转轮圣王。所以者何。行菩萨道慈愍群萌。奉养三尊先圣师父。乃得转轮王主四天下。教化人民普行十善。遵崇道德为法王教。匿态有八十四无有清净行故。为女人不得作圣帝。五曰女人不得作佛。所以者何。行菩萨心愍念一切。大慈大悲被大乘铠。消五阴化六衰广六度。了深慧行空无相愿。越三脱门。解无我人无寿无命。晓了本无不起法忍。分别一切如幻如化。如梦如影芭蕉聚沫。野马电[火*僉]水中之月。五处本无无三趣想。乃得成佛。而着色欲淖情匿态身口意异故。为女人不得作佛得。此五事者皆有本末。时慧施女报上度曰。各殖诸本用获果实。本有男女及报应耶。本有五处释梵魔王转轮圣帝大道小道乎。上度答曰无也。慧施问曰。设使本无何因而有。答曰。因行而成。慧施报曰。譬如画师治壁。板素和合彩具因摸。作像分赋彩色。从意则成。五道如是本无处所随行而成。譬如幻师化作日月帝释梵天转轮圣王天龙鬼神人民禽兽。随意则现。恍惚之间则不知处。生死如是。本无所有从心所行各自得之至于本无。无幻无化无合无散亦无处所乃成佛耳。所以者何。五戒为人十善生天。悭堕饿鬼抵突畜生恶堕地狱。行四等心不解空行生于梵天。倚空求度散心着空生无想天。六度无极之想不离三界畏苦厌身。恶生死难志存泥洹。故堕罗汉。发菩萨意欲度一切。不解本无著佛身相。欲疾得佛不得善师不了善权。便中道止得缘觉道。斯之所行有合有散。则不得成无上正真道也。一切无相何有男女。上度又问。以何等行而成正觉。慧施报曰。不生色行不观不空行不灭色行。不舍执行亦无造行。不生识行不观不空行不灭识行。不色生行不识生行。亦无归行无来无去。永无处所无所住行不倚三界。不舍五阴不受五阴。不舍俗行不想道行。是为道行得至正觉。不倚四等。不想六度无极之行。不于三脱有所倚行。达空无相无愿之法。乃为菩萨。应顺法行不违正觉平等之行。如是上度。行斯法者。宁有方面处所三界男女乎。答曰无也。尚无造者何所成立。以是之故吾取佛者有何难也。取无所取成无所成。觉无所觉无取无舍。乃号为佛。亦无名号假为字耳

佛言。善哉善哉慧施。诚如所云。一切无处随行而成。不合不散不兴不衰。无见无闻无念无知无言无说。乃成正觉。于是慧施。则转女像化成男子踊在空中。从上来下稽首佛足。得不起法忍。时五百女忻然踊跃以偈颂曰

  本每自观察　　谓男有常种
  强弱各有品　　女固不得移
  今日蒙佛恩　　乃知无坚固
  五道如幻化　　随行而各成
  三界为心迷　　不了本无谛
  自计有吾我　　缚着堕污泥
  譬如捕鱼工　　以钩钓取鱼
  非是己所有　　自谓我应获
  三界如寄居　　四大非我所
  解诸法如梦　　则无有取舍
  惟佛见加哀　　恩慈垂覆盖
  令转女人身　　值超日明定
  得佛成国土　　教化诸天人
  众生皆度脱　　疾获无上真

佛告五百女。当如所愿疾获尔志。诸女欣然即成男子。于是佛授慧施及五百女决。却后十劫皆当为佛。名曰慧见如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰除冥。劫曰光明。佛住百亿万岁说法。恒沙菩萨得不起法忍。一生补处亦复如是。诸阿罗汉不可称计。尔时人民被服饮食。当如第二忉利天上。时诸众会闻佛授决满百千人发无上正真道意。无数菩萨得不起法忍。八万比丘漏尽意解。十万天人远尘离垢诸法法眼生。地即大动。空中散花其堕如雨。箜篌乐器不鼓自鸣。亿百诸天于空中皆叹颂曰

  甚哉深法　　难值难闻　　幸哉吾等
  宿有余福　　今乃得闻　　何其快哉

佛复告慧施。人在世间生死之缚。但用不解深法计吾我人。犹如猩猩诱诳以酒。知不能释为人所获。世人若兹。绸缪五阴六衰之患。恒计吾我。不知苦空无我非身。犯则有殃不自抑制。而为三毒五盖所缚。不得解脱返真谛道。如木生火不觉自烧。不了空行计吾我人亦复如是。自误堕冥入三恶道。譬如剧贼劫抄寇害。自谓健快。俗人着色痛想行识。没溺垢秽罪蔽阴盖。不解大法殊妙深义。有痴恩爱则生为人。十二结缚六十二见疑网尘罗迷惑诸邪九十六径。研精诸法分别空无。如幻如化如梦芭蕉野马水月呼声之响。不计吾我。知色自然痛想自然。痛想自然行识自然。行识自然四大自然。四大自然三界自然。三界自然泥洹自然。泥洹自然乃能逮得无所从生法忍。不在生死不处灭度。则应大乘深妙之慧。譬如有人体得重疾欲自疗治。当服顺药反饮毒药。谓攻身病害腹伤藏。不即更服除毒之散。寻能杀人悔无所及。学道之士亦复如是。本发道意为菩萨行。奉四等心慈悲喜护。遵行六度而皆有想有所希望。便堕声闻缘觉之乘。假使适成不乐因出。得至大乘踌躇不了。便住中者即堕小乘。譬如庶人之食。如是转轮圣王食之为毒药也。譬如甘露上味。具药多所疗治众人之病。菩萨如是以大乘法。多所疗治于一切人生老病死淫怒痴厄众想之患也。佛说是时。千天人发无上正真道意。五百天子得不起法忍

于是有菩萨。名曰慧英。问文殊师利。何谓菩萨博闻多知。文殊师利答曰。从无央数恒沙等劫。积累功德不以为厌。闻四等心亦不厌足。修四恩法亦不厌足。行六度无极亦不厌足。空无相无愿亦不厌足。大慈大悲亦不厌足。进五神通亦不厌足。教化众生亦不厌足。为大乘教亦不厌足。现声闻缘觉普化一切亦不厌足。示现泥洹住泥洹中还生死界亦不厌足。不去不来无所不至。譬如虚空无所不至不出不入无所不达无所不遍。是者名曰博闻多知。不以过去为计数。不以当来有限碍。不以现在有处所。无去来今三世之限。于三涂等无三界想无泥洹念。无道无俗不附不舍。是者乃谓博闻多知。于所闻者亦无所闻。于所见者亦无所见。于所言亦无所言。于所度亦无所度。是者乃谓博闻多智。慧英又问。何谓行者何谓成就。答曰。发菩萨意行四等心。大慈大悲无极之慧。布施摄人。戒忍精进一心智慧以救众生。行稍渐进。是谓行者。行过于空无相无愿之法。不见吾我不见三世。不见泥洹及与生死是谓成就

大英菩萨又问佛言。人生从何所来去至何所。老病死何所从来去至何所。色痛想行识从何所来去至何所。地水火风空眼耳鼻口身心从何所来去至何所。佛言。皆无所从来去亦无所至。缘合则有缘离则灭。如幻如化如画如鼓。如雨如电皆从因缘。有缘有生无缘无对。生死如是等无有异也。大英又问。何谓无所从来无所从去因缘合成。佛言。作人行者则得为人。作天行者则得为天。作地狱行则入地狱。作畜生行则受畜生作饿鬼行则为饿鬼。无五行则无五道。无五道则无出入。名曰人本。无有三界欲界色界无色界。无心意识故无三界。名之人本。未有人物有色无见。何谓有色无见。地色水色火色风色。定者谓地。清者谓水。明者谓火。摄者谓风。天地未然未有三界。是四色者而常自然。无有作者自然动起。唯道能名及至补处能名斯者无像之色亦曰心色。阿惟越致见心心色。阿惟颜见四色心。如来见未有四色心之本也。于三界中而不然者是为心色名心本故曰非不然于菩萨法故曰为然无心色志三界自然。自然如空乃名曰道。于是诸法无合无散。所以者何。假使合者则人本也。假使散者则生死也。见生死病泥洹之乐则名声闻。处在中间无益一切名曰缘觉。无合无散不处行洹不恶生死乃名之曰法身。法身无形普入一切。亦无所入无所不入。说是经时。五千天人得无所从生法忍。无央数人皆发无上正真道意

于是阿难问世尊曰。欲发道意为菩萨者当以何为本。佛言。精进不懈分别空慧。欲度一切不见吾我及与寿命。是则为本。又问曰。宁有迟疾。佛言。亦有亦无。又问。何谓为有。何谓为无。佛言。有者从精进而不懈怠积殖功德。布施戒忍精进一心智慧善权方便慈悲喜护四恩空行。得无上正真之道。不从懈怠得。斯谓有也。无者道无处所无形无名譬如虚空。不从造作而可获也。无所造作无心意识。无内无外亦无中间。无取无舍乃应入道。斯谓无也。所以者何。乃往历劫其数难计会。有转轮王名曰自在。王有千子勇猛杰异。国土七宝主四天下。治以正法不加刑罚。尔时有佛。号曰宝妙如来至真等正觉明行成为善逝世间解无上士道法御天人师。号佛世尊。时佛说法。初语亦善中语亦善竟语亦善。分别其义微妙具足。净修梵行演法弘普。时会菩萨无数亿众。声闻缘觉不可称限。时转轮王供养侍佛积有年岁。千子宝臣大众翼从。俱诣佛所。稽首足下却一面坐。佛为广说菩萨之行。多所安隐多所救护。于一切人为第一尊。王及诸子宝臣翼从之众。皆发无上正真道意。夙夜精进不敢倦息。供养如来一切所安。于是千子悉于佛前自试功德。各各探策谁前作佛。得上策者余降不如次第作佛。懈怠薄德最当在后。寻如所言各各探策。有一太子最后得策。穷久下第乃得作佛。则时愁戚不能自胜。便自投身如大山崩。吾身云何最后作佛

佛告之曰勿得忧感。道无有限亦无远近。能分别解空无之慧便在前耳。于时太子闻佛所说即时踊跃。即发无上正真道意。得不起法忍。行大慈悲。解一切法如幻影响如野马如梦芭蕉水中之月。千人之中第四得佛。号曰释迦文如来至真等正觉。其余诸子次第得佛。最后当得作佛者名曰楼由。佛语阿难。欲知尔时转轮圣王者。定光如来是也。失策太子。便解空无精进不懈。先得佛者则吾身是也。其余诸子贤劫中千佛兴者是也。当知斯义。道无远近解空别妙知自然法乃得佛疾。尔时诸会莫不欣然。普发道意为菩萨行。五千菩萨逮得法忍。万人得柔顺法忍。于是日天王与无央数百千天人。来诣佛所稽首足下却住一面。前白佛言。以何等行为日天王行照四天下。何缘为月照夜除冥。佛告日王。有四事法得为日王。何谓为四。常喜布施修身慎行奉戒不犯。又志然灯于佛寺庙。若于父母沙门道人殖光明德。是为四。佛时颂曰

  常乐兴布施　　奉戒不犯禁
  然灯于佛寺　　若于父母前
  好喜佛正典　　不诽谤经法
  敬沙门道士　　因斯得为日
  身出千光明　　普照四天下
  诸窈冥之处　　莫不蒙晖曜

佛告日王。又有十事。为日天王。何谓十。身不杀盗淫。口不两舌恶骂妄言绮语。意不恚嫉痴。是为十。佛时颂曰

  恭己自摄护　　而不杀盗淫
  不两舌恶口　　妄言及绮语
  心不怀嫉妒　　无嗔恚诸毒
  离六十二见　　日光照四方

佛告日王。又有四事。得为月王。何谓为四。布施贫匮。奉持五戒。遵敬三宝冥设锭光。君父师寺。是为四。佛时颂曰

  布施诸贫匮　　常奉持五戒
  然灯于佛寺　　恭敬侍三宝
  心存念诸善　　蠲却世众恶
  自护身口意　　得月光照冥

于时日王白佛言。唯愿大圣。枉屈尊神到宫小食。令诸导御虚空神天皆蒙大恩。闻深妙法悉发道意所度无量。时佛默然已受其请。日王见佛已许就请。绕佛三匝忽然还宫。办百种食若干甘美。床榻坐具挍饰鲜洁。为佛敷座高四千里。于是日王立于宫殿。遥重请佛倾侧竦息。以偈赞曰

  布施于一切　　所有无所吝
  亦不望相报　　得佛度十方
  智慧如虚空　　所化无挂碍
  一切皆蒙恩　　时到惟屈尊
  慈心加众生　　未曾有危害
  悲哀未度者　　施诲以法宝
  威神照群黎　　救脱贫匮者
  惠以七大财　　时到唯屈尊
  睹众生迷惑　　五道之勤苦
  常以加大恩　　慰勉诸恐惧
  开化以法教　　示导诸不及
  种至空无慧　　时到惟屈尊
  其光踰日月　　威德超须弥
  智慧越虚空　　双比不可喻
  日月照众冥　　但能成万物
  佛照五道人　　悉令获五眼
  虚空尚可度　　海水知几渧
  须弥十方地　　亦可知斤两
  如来智慧圣　　功祚弘巍巍
  无限普超彼　　时到惟屈尊

尔时世尊告大众会。时到悉严就日王请。则皆受教。佛与大众踊在虚空。至日王宫坐师子之床。众会坐毕。王后太子诸天眷属稽首于地。即以至心供养世尊。手自斟酌百种之鐥。饭讫澡毕更取卑床。自坐佛前恭肃听法。佛告日王。一切三界所受形貌皆从心意。心意无形而有所造随行立身。豪贵贫贱皆归无常。如泡起顷寻复坏灭。一切世间所有如是。当信道德正真可怙余不可恃。弃捐众行奉行法行。何谓法行。无生之行除诸所生。真谛之行所存殊胜。入道之行无所忘失。布施之行无所吝冀。持戒之行普得诸愿。忍辱之行不乱众人。精进之行未曾动转。一心之行意行常达。智慧之行。以圣眼睹。慈心之行忍一切苦。悲心之行等意众生。喜心之行以法开化。护心之行安慰一切。神通之行六通以达。惟空之行无恚害心。消灭之行度诸群黎。四恩之行合聚救人。博闻之行从受成道。不起之行而观自然。道品之行不获有为。本无之行无罪福报。缘起之行了知无明明不可尽。众劳之行解人物自然。诸法之行了空见慧得平等觉。伏魔之行无能倾动。三界之场虽处不堕。师子之行善胜无畏。力无惧行所向无畏。三达之行无有挂碍一心觉场大智普具。教一切行无所不周。化六十二见行济众罗网。九十六径诲入一道。如是日王。菩萨以应斯行则顺道行已顺道行则应大慈。已顺大慈则应大悲。已顺大悲则应大铠。已顺大铠则师子吼。已师子吼则应化幻。已顺化幻则入五道。已顺五道则随时入。已随时入无所不变。已在所变无去无来。度无所度净无所净。明无所明觉无所觉。乃为正觉

佛告日王。欲达去来今现在事十方诸佛法身平等。常当信乐分别此义。欲知生死十二因缘所从兴发三趣之患五盖之覆。当解此义信奉行之。欲了十二部经典之要。开三达教越于三脱至三达智。当解斯义。犹郡国县邑丘聚村落百谷草木药果之树。皆因地生。菩萨入斯慧无所不化皆成立之。至于无上正真之道。声闻缘觉皆依因之。佛说是时。日天王王后太子眷属诸天。其心自然皆得不起法忍。十亿天人发无上正真道意。于时世尊即从座起而立空中。与无央数百千之众眷属围绕。以偈颂曰

  天人不解了　　从来难计量
  迷惑于五趣　　如鱼着钩饵
  三界犹如幻　　恍惚不见处
  生者不自觉　　为意识所使
  堕于四颠倒　　甚可愍哀怜
  自计身有常　　不信于道真
  一切从空生　　反恶闻空慧
  如人从亲生　　更不孝父母
  貙者化为虎　　不觉为人时
  寻还害家中　　不别其亲疏
  人本从空生　　憎无亦如是
  迷乱于阴入　　犹醉者裸驰
  貙者变为人　　乃识家亲属
  已分别本无　　乃解一切空
  空者不念空　　空亦不见空
  已达无所生　　乃能解自然
  欲求菩萨行　　度脱众生类
  当了一切法　　自然如幻化
  分别斯慧已　　周旋不以离
  则深入微妙　　权慧开度人

佛说是时。无数亿天虚空诸神。皆发无上正真道意。不可称计菩萨得不起法忍。佛还维耶离奈氏树园

尔时城中有大长者。名曰解法度。供养先佛无数百千。殖众德本不可称限。稽首诸佛礼敬难量。咨受法言。于无上正真道意志不退转。不起法忍出于智慧。所度无极善权所济不可计议。与眷属俱来诣佛所。稽首毕一面坐。叉手白佛。供养世尊得何功德。佛告长者。奉华散佛生生端正衣饭自然。烧香芬熏身体香洁名德远闻。其然灯者天眼明慧不处窈冥。幢幡施者所在富乐财宝无限。上缯盖者致得屋宅覆盖不露。音乐倡伎乐佛塔寺及乐一切得天耳彻听。履屣车乘施者得轻举能飞。一心向佛得知宿命。慈察众生知一切心。以法施与得诸漏尽。以食施与常值法会。以衣施与得三十二相八十种好。我灭度后其有供养形像舍利。德皆如是稍稍顺法。因斯得度无为之道

解法长者复白佛言。宁有供养殊过于斯华香幡盖伎乐履屣车乘饭食衣服者乎。佛言有。又问何所是。佛言。发菩萨意哀念一切终始之患欲令济度。大慈大悲不厌生死。求诸总持三藏之奥。优奥难量无极之慧。平灭三涂导以三宝。分别于空无相无愿。超三脱门得三达智。睹人根本本无处所因缘而生。观一切法亦无去来。六情自然如水上沫。四谛无谛譬如野马。了本无已乃为正谛。慈悲喜护布施以法。仁爱众生劝益群黎等利一切。六度无极善权方便。随顺而化不恶生死。又如飞鸟飞行空中乐于终始。譬如华果苑园流泉戏庐。不违大圣真妙之海。不畏四魔。降伏众邪六十二见。化发九十六种诸径之惑。舍声闻缘觉之行。知无我无人无寿无命。遵修正真无上大道。斯供最胜。自观己身如幻化耳。十二因缘了无端绪。所以者何。本无有痴缘对而兴。从痴致行。从行致识。从识致名色。从名色致六入。从六入致习。从习致痛。从痛致爱。从爱致取。从取致有。从有致生。从生致死。从死致忧。从忧戚悲感不可意恼。了知本无尚无有痴。何有行识名色六入习痛爱取有生老死忧悲之患。永无有也。诸缘悉除不住三界不乐泥洹。无大道念无小道想。游生老死譬如日月不出不入。于世间人有出有入。菩萨如是。开化一切现生三界。说三乘教便现灭度。于一切人见诸生灭。于菩萨法无有生灭。是供养者。最为殊胜为尊为上。无极无底之供养也。佛说是时。十万天人皆发无上正真道意。解法长者及诸眷属。皆立不退转不起法忍

于是调意菩萨白佛言。何谓为调何谓为宝。佛言。若有骂詈挝捶咒诅心无有异。毁辱轻慢陵侮唾贱心无有异。若称誉恭顺宣扬功德心无有异。若稽首归命跪拜尊敬心无有异。设以天福转轮豪圣爱欲之乐以劝示之心无有异。假以地狱饿鬼畜生灾怪恐逼心无有异。知命非常苦空非身示以勋之心无有异。若以声闻缘觉之法用诱进之心无有异。假以菩萨空无之慧大乘化之心无有异。是则谓调。何谓为宝。佛言。发菩萨心欲度一切斯则宝也。尊敬于佛不随外道斯则宝也。解经顺教不逆大化斯则宝也。谦敬众僧及于圣众斯则宝也。布施一切无所悕望斯则宝也。奉戒顺禁发菩萨愿斯则宝也。忍辱之力伏意不乱斯则宝也。精进恪勤修道务本斯则宝也。一心行定正不邪迷斯则宝也。智慧幽微不堕六衰斯则宝也。善权方便各得其所斯则宝也。慈心弘普志不孅介斯则宝也。常怀悲愍矜哀危厄斯则宝也。安和喜悦不忻不戚斯则宝也。拥护一切无不救度斯则宝也。以法施与不道不俗斯则宝也。抚育众生无所爱恶斯则宝也。务存长益无所损耗斯则宝也。等利一切无偏邪意斯则宝也。常执谦冲未尝慢恣斯则宝也。若有骂詈而不结恨斯则宝也。假使挝捶计若无身斯则宝也。设使怒害以仁恻报斯则宝也。如令轻易不念其恶斯则宝也。解知非身不计吾我斯则宝也。了一切苦不乐放逸斯则宝也。物非我有无色眩惑斯则宝也。舍声闻行不为缘觉斯则宝也。尚修神化于五至六斯则宝也。释六十二不堕邪见斯则宝也。不安泥洹不危生死斯则宝也。常以大法开化未闻斯则宝也。为一切人示现法桥救摄诸厄斯则宝也。解三界空一切自然斯则宝也。莲花净菩萨白佛言。何为菩萨得至净行。世尊曰。不为爱欲所点污斯则清净。心常光洁不协恚毒斯则清净。于三界尘无所染碍斯则清净。不侥灭度不忍生死斯则清净。不计终始出入无为斯则清净。常行大慈不舍大哀斯则清净。无大道想无小道求斯则清净。光英菩萨白佛言。何因菩萨光耀普照。佛言。然灯庙寺学问智慧博综无厌。显授道明令达真伪。遵习圣典十二部经。度诸有海二六牵连。常志大乘消众人患至微妙慧。斯则菩萨光耀普照

解缚菩萨白佛言。何缘菩萨解一切缚。佛言。了三处空于去来今无所想着三垢则除。分别色空痛想行识亦复如是。一切本无不着不断。一无所求亦无所舍。是为菩萨解一切缚

宝事菩萨白佛言。以何为宝以何为石。世尊曰。归佛法众不为非法。弃舍诸径九十六种。不愿声闻缘觉常志大道。大慈大悲救济众生五道之惑。是则为宝。十二因缘所见迷谬。不识大法空无之慧。是则为石

恩施菩萨白佛言。何谓菩萨施恩众生。佛言。其未发意者皆令发之。其退转者使不退转。于诸所生使无所起。其未具足至一生补处。是为菩萨施恩于一切

帝天菩萨白佛言。何谓菩萨能化诸天。佛言。在于欲界现欲无常。譬如人梦示清净行。在于色界为现大慈菩萨之行。在无色界为现深妙之法。无所依猗。不猗欲界。不猗色界。不猗无色界。不猗小乘。不猗大道。是为菩萨能化诸天

水天菩萨白佛言。何谓菩萨解知本净。世尊告曰。菩萨了知一切诸法如幻如化一切本无。譬如水原本初清净无有垢浊。所以者何。水适定住则清如故。以了本无便逮法身

大导师菩萨白佛言。何谓菩萨为一切导。世尊告曰。见悭贪者导令布施。放逸者导令护戒。恚怒者导令忍辱。懈怠者导令精进。乱意者导令一心。愚冥者导令智慧。其无道心导之大乘。是为菩萨为一切导

龙施菩萨白佛言。何谓菩萨不惜身命。世尊告曰。菩萨观世所有非常苦空非身。我不有身身非我有。一切如影因形而现。生死如是从心而成。了一切空皆无所求吾我自然。吾我自然生死自然。生死自然泥洹自然。泥洹自然大道自然。是为菩萨不惜身命

尔时梵天白佛言。甚哉法之大也。诚难值遇。从无数劫积行累德。乃仿佛闻音。幸遭大圣得闻斯法。供养菩萨正典要妙之化深邃之义。已奉屡听解达是法故。使彼人依行六号。其闻斯经为已见佛耳聆妙慧供奉圣众。济天路拔三趣。使发无上正真道意。体解三脱不废三达。虽未至道其德渐增如月初生。如师子子无所畏难自在由己。诸天龙神悉卫护之。众魔邪恶自然为伏。所在州城郡国县邑莫不敬重。出入应节十方诸佛威神化祐。于时四天王白佛言。快哉甚善。大圣洪恩现神浊世。令我之等得觐安住遇斯妙化。菩萨纯慧如天中天。有人发行入于大海获如意珠为一切愿。其人欣豫岂可訾量。我等如是。诣斯大会瞻戴慈泽听受甘露。菩萨景则犹入大海得兹宝珠当以宣布显示同志为菩萨行。未曾信乐诸天之众。依福徒类。当令亘然如开心受学。其信乐者倍令坚进而不回转

佛言。善哉四王。诚如所云。斯大法者难可见闻。若一蹉跌与法永违。于亿千劫未卒值遇。犹如一针堕深大海。反覆求索宁易致乎。四王白佛。甚难甚难天中天。佛言。闻斯要典菩萨深法。而不信乐失不讽诵。累劫徼错不可再遭。是故诸仁欲得自致所在见佛闻深妙法疾至无上正真道者。当勤执玩读诵奉持。散示未闻敷演其义。使蒙洪典令人日修。展转相化其福难测。正使三千大千世界如来充满。若族姓子族姓女。供养奉事于百千劫一切施安。佛灭度后。各各兴塔七宝跱立。上至二十四天。供养幡盖伎乐歌颂亦百千劫。福宁多不。四王白佛。甚多无极天中天。不可譬喻。佛言。其有受斯三昧十法超日明定六度无极善权方便。福越于彼。所以者何。虽供侍佛。不如受斯佛之遗典从大圣命。诸行菩萨一切学者。皆由深经自致得佛

于时慧施菩萨白佛言。斯法甚深甚深。若有信乐而不诽谤。知为佛之所护。闻不悦欣。狐疑讥讪不写讽诵。既不自诵并止余人使不遵学。罪难计量。世世自误堕坠三趣。自服毒药复饮他人。自危身命投陷盲冥又危众人。斯大法者众明之元。毁巨就细殃衅难限。生远三宝甘在八处。何谓八处。一曰边地。二曰外道。三曰贫匮。四曰下贱。五曰短命。六曰丑陋。七曰人所憎恶。八曰夷人。不解法者其有诽谤。不信不乐大乘之业。归于八恶悔之无及。佛言善哉。诚如所云。所云无异。忆念往古无数劫时。发菩萨意。始学之初出家离欲。得为比丘名曰法乐。好尚杂句严饰之文。不志大乘深妙之化。谓为虚伪非佛正典。乃以四阿含怀来果证以为雅诲。时有大学信大乘者。名智度无极。讲空无慧深奥无际。久修梵行悉共讽诵。敷陈旨要宣布流美四辈洽闻法乐比丘所在坐上闻诵慧品辄诽谤之云非佛教。自共撰合慎勿修行。用因此罪堕大地狱。十八囹圄受殃酷痛弥历年劫。阿难白佛言。如令佛国劫尽烧坏。水灾荡溢痛宁息不。佛言。不得休废。所以者何。若国坏尽徙至他方佛界囹圄。所以者何。斯大尊法三涂所由。去来今佛之父母也。假使诽谤殃衅不朽。佛告阿难。欲知尔时法乐比丘不。答曰不及。佛言。则吾身是。用是之故护身口意勿妄谤讪。已堕恶道考掠剧者悔当何及。佛告阿难。后末世人。睹有学法为佛弟子。聪达智慧演宣大乘散结狐疑。嫉供养者谤谓无智。用憎人故并毁深经云不足宣。假喻言之。如一父母有十余子。兄弟相憎并谤二亲。如是阿难。当来世人。憎嫉同学诽谤正法。其人受罪不可计尽无以尽喻。阿难白佛言。假使自觉则悔过者。当云何乎。佛言。其人殃咎转当微轻。虽后获衅速得解脱。故当自省改变心口。无轻妄语也

佛告阿难。受斯经典持讽诵读。广为人说颁宣周遍福祚难量。诸天龙神揵沓和阿须伦迦留罗真陀罗摩休勒。悉共拥护学斯经者。诸佛世尊悉共拥护。若猛师子虎狼熊罴无敢娆者。行步出入常得自在。未曾恶梦。梦中但见佛塔。寂志四辈道士说经。天龙鬼神皆欲见之。诸佛世尊亦复如是。四大天王帝释梵王。皆欲见之悉共拥护。用乐深法菩萨箧藏超日明尊定故。佛时颂曰

  学斯经典者　　诸天悉拥护
  龙神阿须伦　　真陀摩休勒
  迦留罗一切　　无敢犯娆者
  十方佛威神　　皆共授导之
  天帝释梵王　　诸大神妙天
  虚空持世者　　钦渴悉欲见
  卧起常安详　　未曾有卒暴
  梦中见塔寺　　不睹恶因缘
  体解深经典　　常务分别说
  闻者则畅达　　不疑于大乘
  无知少福者　　不信毁正经
  谓虚自合作　　非佛之所说
  以嫉妒学者　　并谤弘雅训
  如兄弟相憎　　并讪及二亲

尔时有菩萨。名曰大光。白佛言。何谓为光。何谓为明。世尊告曰。解了慧明心如虚空。睹见十方去来现在三世之事无所挂碍。逮得权智神通已达。坐睹一切众生根原。无有去来因缘之想。不碍四大。不碍铁围大铁围宝山。于地水火风出入无间。所以者何。地皆空故。入不解地。地不空者。我不得前。水不得入。以空之故。转相开通。如人体中毛孔九十九万。已神通者不见有身。察之虚空无所挂碍。是谓为光。睹一切心已生未生有志无志道心俗心痛心尽心无漏之心。悉晓了之而为讲义。各令得所。是谓为明。说是语时。无数菩萨皆得神通。光明无量普照十方

佛告阿难。受斯经典。宣示未闻令得流布。众生蒙度以致正真。阿难白佛言。惟当受持要者。何名此经。佛言。名超日明三昧。又名十定。佛之决教多所成就。譬如日明遍照四域。百谷草木万物变化皆因成熟。斯定若兹。一切十方五道生死莫能自济。声闻缘觉菩萨大道。皆由斯定而得成济。若千万劫奉行六度而有望想。不如达斯超日明定。以大慧光照于十方德喻于彼。佛所说如是。贤者阿难大菩萨众诸天龙神阿须伦等莫不欢喜。作礼而去

佛说超日明三昧经卷下


佛说称扬诸佛功德经

    No. 434

佛说称扬诸佛功德经卷上

        元魏天竺三藏吉迦夜译

闻如是。一时佛在罗阅只灵鹫山中。与大比丘众千二百五十人俱。尔时耆年舍利弗。便从座起偏袒右肩。更整法服在佛右面。右膝着地长跪叉手。前白佛言。唯天中天。今日现在诸佛世尊进止康常。今说法者其数几何。时舍利弗发是问已。尔时世尊告舍利弗。所问甚快多所饶益普利一切。谛听谛听善着心中。吾当为汝具分别说。于是舍利弗。闻佛许可欢喜踊跃。叉手白言。诺当善听。愿乐欲闻。佛告舍利弗。东方去此千万亿诸佛刹土。有世界名曰天神。其国有佛名曰宝海如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。若族姓子族姓女。其有得闻宝海如来名号者。执持讽诵欢喜信乐。其人当得七觉意宝。皆当得立不退转地。疾成无上正真之道。却六十劫生死之罪

复次舍利弗。东方有世界名曰宝集。其国有佛。号曰宝英如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝英如来名号者。执持讽诵欢喜信乐。五体投地而为作礼。若使三千大千佛刹满中七宝。持用布施满百岁中。所得功德宁多不乎。舍利弗言。甚多甚多。天中天。佛言。不如有人得闻宝英如来名号。持讽诵者作礼之德。十方亿倍过出布施功德者上

复次舍利弗。东方去此宝集世界。度八百佛刹。有世界名曰宝最。其国有佛。号曰宝成如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝成如来名号者。执持讽诵以清净心欢喜信乐。却五百劫生死之罪

复次舍利弗。东方去此宝最世界度千佛刹。有世界名曰光明。其国有佛。号宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝光明如来名号。执持讽诵欢喜信乐。于三涂中悉得解脱

复次舍利弗。东方去此光明世界。度千五百佛刹。有世界名曰幢幡。其国有佛。号曰宝幢幡如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝幢幡如来名号者。持讽诵念欢喜信乐。其人则为成法珍宝

复次舍利弗。东方去此幢幡世界。度二千佛刹。有世界名曰一切众德光明。其国有佛。号宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝光明如来名者。持讽诵读欢喜信乐。五体投地而为作礼。却二十万劫生死之罪

复次舍利弗。东方去此众德世界度千佛刹。有世界名曰妙乐。其国有佛。号曰阿閦如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻阿閦如来名号者。捉持讽诵叹说其德。复劝他人令学讽诵。尔时波旬将四种兵。来诣佛所而作是语。宁使捉持余千佛名。亦劝他人令使学之。不使捉持阿閦佛名。其有捉持阿閦如来名号者。我终不能毁坏其人无上道心。我亦当能毁坏斯等无上道心。佛告魔言。汝能毁坏谁之道心。魔言。其求大乘捉持阿閦如来名者。我心则生愁忧热恼。如我今日复得热恼。用闻阿閦如来名故。魔言。亦复有众生其数甚多捉持余佛名号者。我或当能毁坏其人正觉道心。佛告魔言。汝莫愁忧怀于恼结。汝终不能毁坏此等无上道心。魔波旬言。有何因缘。佛告魔言。汝为隐蔽归命诸佛功德之行。所以者何。阿閦如来自当观视拥护其人。时舍利弗即白佛言。波旬今日于如来前。云何欲作师子之吼。欲破众生正觉道心。其有众生捉持阿閦如来名者。及余一切诸佛名号。魔审当能毁坏其人正觉心乎。佛告舍利弗。我今观睹诸众生。其有捉持诸佛名者。若有呵骂诽谤之者。斯人则为造大恶行。致无量罪入阿鼻狱具受众苦。舍利弗言。有诽谤经者其数几许。佛言。十方诸佛为诸众生广说法时。皆先赞叹阿閦如来名号功德。众生听闻其功德者终无厌足。若有众生得见如来闻其功德。未曾有能谤此经者。诸佛如来不于五浊弊恶之时兴出于世。如我今者。于此忍界下劣丛残诸众生中而作佛也。阿閦佛国严净最好终不尔也。当知舍利弗。斯尊法轮随次分布丘聚国邑。若族姓子。若族姓女。一心信行当广宣传此诸经法。当知舍利弗。闻此经者。诽谤轻毁所受之报。汝今谛听。舍利弗言。诺当善听。佛言。犍陀梨国谤此经者满百千人。造斯恶行当堕阿鼻大泥犁中。次复北方国名罽宾。其国经法兴盛久住。而此国中五百千人谤此经法。此众生辈死堕阿鼻大泥犁中。舍利弗。于众聚中当有共谤此经者。有八万人堕阿鼻大泥犁中。东方少有信斯经者。多造阿鼻泥犁行。有百千人死入阿鼻大泥犁中。南方二百千人。当谤此经死入阿鼻大泥犁中。西方有百万人。当谤斯经死堕阿鼻大泥犁中。当知舍利弗。缘觉智慧不能度量如来之智。况诸声闻及诸众生未成道果。为生死水所漂流者。欲度如来智慧功德。未之有也。夫黠慧者当自思惟。诸佛功德不可限量。诸佛智慧不可思议。诸佛已成一切种智三达无阂。而我痴冥无有是智。诸佛已成一切智者。自当知之我所不了。若我不了。不当谤毁四句一偈。何况谤毁斯大尊经。造斯大罪众恶行聚。无央数劫。当在阿鼻大泥犁中于彼止宿。是故舍利弗。若族姓子族姓女。当作是意。我今乃闻此大尊经而不诽谤。乃却阿鼻一劫之罪。我等今当自庆欢喜兴大踊跃。缘此之故无央数劫常当与此大法共俱

复次舍利弗。东方去此妙乐世界度万佛刹。有世界名曰无量。其国有佛。号大光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大光明如来名者。执持讽诵欢喜信乐。其人所生未曾不值诸佛世尊。住不退转必得成就最上正觉

复次舍利弗。东方去此无量世界。度六万佛刹。有世界名曰众华。其国有佛。号无量音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量音如来名者。净心信乐三反称言。我今一心礼无量音如来。其人当得无量音声。及得如来净光之音

复次舍利弗。东方去此众华世界。度万四千佛刹。有世界名无尘垢。其国有佛。号无量音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量音如来名者。欢喜信乐持讽诵念。却十二劫生死之罪

复次舍利弗。东方去此无尘垢世界。度二万佛刹。有世界名莫能胜。其国有佛。号大名称如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大名称如来名者。净心信乐讽诵不忘。长跪叉手而作是言。我今礼大名称如来。作七宝阜如须弥山。持用布施满百岁中。所得功德宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人持大名称如来名号作礼之者。得其功德巨亿万倍。过出布施功德者上。不得为比

复次舍利弗。东方去此莫能胜世界。度三千佛刹。有世界名光明。其国有佛。号宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝光明如来名者。尽心信乐持讽诵者。当却十劫生死之罪。住不退转必成无上正真之道。其有诽谤其不信者。当在阿鼻大泥犁中寿命一劫

复次舍利弗。东方去此光明世界。度万五千佛刹。有世界名曰多光。其国有佛。号得大安隐如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大安隐如来名者。欢喜信乐讽诵不忘。当作是念。持此功德普使一切无量众生而得安隐。其人则受无量功德。便能安隐一切众生

复次舍利弗。东方去此多光世界。度七千佛刹。有世界名摩尼光。其国有佛。号大光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大光明如来名号者。欢喜信乐持讽诵读。其人当得如来十力

复次舍利弗。东方去此珠光世界。度八千佛刹。有世界名曰正直。其国有佛。号正音声如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻正音声如来名号者。净心信乐持讽诵读。其人当得如来四谛平等之法

复次舍利弗。东方去此正直世界。度二万佛刹。有世界名光明尊。其国有佛。号无限净如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无限净如来名者。欢喜信乐持讽诵者。大千世界满中七宝持用布施。所得功德宁多不乎。舍利弗言。甚多甚多。天中天。佛言。不如捉持无限净如来名者。所得功德百千万倍。过出布施功德者上。无以为比。少功德人不得闻此如来名号。于千佛所造立德本。尔乃得闻此尊佛名。却生死罪四十八劫

复次舍利弗。东方去此光明尊世界。度九千佛刹。有世界名曰音响。其国有佛。号月音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻月音如来名号者。尽心信乐持讽诵念。其人所得清净功德。成具毕满如月盛明。立不退转。当成无上正真之道

复次舍利弗。东方去此音响世界。度万二千佛刹。有世界名曰安隐。其国有佛。号无限名称如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无限名称如来名者。一心信乐而讽诵者。长跪叉手自作是言。今我礼无限名称如来至真等正觉。计于其人所得功德。若积七宝如须弥山。持用布施满百岁中。所得功德宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如得闻无限名称如来名者。持其名号欢喜作礼。其福甚多。比于布施过出百倍无以为比

复次舍利弗。东方去此安隐世界。度千五百佛刹。有世界名曰为日。其国有佛。号日月光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻日月光如来名号者。欢喜敬心。两膝着地。长跪叉手。自作是言。我今礼日月光如来至真等正觉。其人疾得成就无上正真之道

复次舍利弗。东方去此日世界。度三十佛刹。有世界名曰清净。其国有佛。号无垢光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无垢光如来名者。若天若人龙及阅叉若诸非人。欢喜信乐一心敬礼。斯等皆得立不退转。成无上最正觉道。终不畏堕三涂之中

复次舍利弗。东方去此清净世界。度半大千佛刹。有世界名曰琉璃光。其国有佛。号曰净光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻净光如来名号者。诵其名号欢喜作礼。若天若龙阅叉及与非人。此等寿终当生天上及与人中。未曾失于天人之路。常当得值法之盈利。贪心嗔恚愚痴之意。疾得清净。若有谤毁而不信者。六万岁中在于卢猎泥犁受罪

复次舍利弗。东方去此琉璃光世界。度三百佛刹。有世界名得大丰。其国有佛。号日光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻斯佛名者。欢喜信乐念其如来。斯等之类譬若日轮。皆悉具满白净之法。降伏众魔及诸外道。却四十劫生死之罪

复次舍利弗。东方去此大丰世界。度万佛刹。有世界名曰得立正觉侍从。其国有佛。号无量宝如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量宝如来名号。欢心信乐持讽诵者。斯辈皆当得七觉宝。能立众生于最宝中。众德之聚日日增长

复次舍利弗。东方去此立正觉世界。度五千佛刹。有世界名莲花光。其国有佛。号莲花最尊如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻莲花最尊如来名号。欢喜信乐持讽诵者。犹若妙花在尊法室。功德智慧日日增长。譬如莲花从水涌出。却五十劫生死之罪

复次舍利弗。东方去此莲花光世界。度十万亿佛刹。有世界名普度众难。其国有佛。号曰身尊如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻身尊如来名号者。尽心信乐持讽诵者。其人疾度生死之海。能除众生诸欲饥渴。当作快士为于世间而作福田能受三界一切供养。其有目见此如来者。欢喜信乐。当为世间作大法师。得金刚力立不退转。当成无上正真之道。其有女人闻此身尊如来名者。尽心净意欢喜信乐无谀谄者。厌污女身。从是以后更止不受女人之身。却六十劫生死之罪

如是舍利弗。其有得闻身尊如来名号者。斯等为获无极之德。是故当求正觉之道。普救一切令离众苦

复次舍利弗。东方去此度众难世界。度二十佛刹。有世界名曰坚固。其国有佛。号曰金光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻金光如来名号者。欢喜信乐持讽诵念。斯等皆当为佛光明之所护持。成佛之时于诸如来。光明广远而得自在。悉得如来一切众德。是故至心普当信乐诸佛尊号。悉得无碍辩才之慧。终不咨受下劣之法。诸愿之行当疾成满。其有闻此诸如来名。当自劝发起于尊意。发金刚志求无上道。此等皆当却十二劫生死之罪

复次舍利弗。东方去此坚固世界。度十佛刹。有世界名曰无际。其国有佛。号梵自在王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻梵自在王如来名者。欢喜信乐持讽诵念。叉手作礼。其人必当得见其佛。作转轮王立不退转。当成无上正真之道

复次舍利弗。东方去此无际世界。度二千佛刹。有世界名曰为月。其国有佛。号金光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻金光明如来名者。欢喜信乐持讽诵念。此等后生常为众生广说经法。虽为分别一切如梦如水中月幻化之法。用寤众生。从是以往终不复堕恶道之中。当与大德众聚共会。而常欢喜。能使众生而得快乐。后作佛时以大乘法。兴显于世无有二道

复次舍利弗。东方去此月世界。度千佛刹。有世界名曰火光。其国有佛。号曰金海如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻金海如来名号者。尽心信乐持讽诵者。得不退转必成正觉。所以者何。其佛如来本行菩萨道时。作是誓愿。若使有人生我国者。及在他方诸佛国土。闻我名号。斯等当住不退转地成最正觉。我当尽为满具如来无上之愿

复次舍利弗。东方去此火光世界。度十八佛刹。有世界名曰正觉。其国有佛。号龙自在王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻龙自在王如来名者。尽心信乐持讽诵者。若使郡县村落之中雨雹霜时。以右膝着地叉手作礼。而作是言。龙自在王如来本行菩萨道时。无数诸龙于厄难中悉度脱之。由此功德自致成佛。作是誓言。若我刹中及诸佛土。若我在世般泥洹后。若有诸龙雷电雹霜恐怖众生。以龙自在王如来威神功德智力。至诚誓愿口作是言。头面作礼疾得度脱。当知舍利弗。如是厄难疾得解脱。唯除宿罪不能得免。一切诸龙若在厄难闻此佛名。于众厄中疾得解脱。其有执持斯佛名者。复劝他人令使诵持增益功德。必当得往生此佛国。求最正觉。立不退转。疾成不久

复次舍利弗。东方去此正觉世界。度十亿佛刹。有世界名曰喻月。其国有佛。号一切花香自在王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻一切花香自在王如来名者。净心信乐持讽诵者。斯其人等所生之处。当得恒沙戒香具足。一切妙香香气遍熏。诸佛刹土众戒具满。常能奉持未曾缺犯。舍利弗言。本何因缘乃能如是。佛言。其佛本行菩萨道时作是誓愿。我若在世般泥洹后。若有众生持我名字一心信乐。皆悉当得如是戒香。是故舍利弗。常当兴立大敬信心于诸如来。如是诸佛拥护其人。使得功德不可计量。若有持此诸佛名者。从其所愿得之。皆悉当得诸佛智慧而令备满得不退转长跪叉手自作是言。我今礼此一切花香自在王如来。常念不忘。却十四劫生死之罪

复次舍利弗。东方去此喻月世界。度二千一亿佛刹。有世界名曰星王。其国有佛。号曰树王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻树王如来名号者。欢喜信乐持讽诵者。斯辈皆当得诸法乐。坏诸魔兵裂破罗网。若闻此经轻慢诽谤用相调戏。满六万岁于僧迦泥犁受其罪报。若有言我不信此经。于七万岁常在饿鬼。不闻饮食水谷之名

复次舍利弗。东方去此星王世界。度五十五佛刹有世界。其国有佛。号曰勇猛执持牢杖弃舍斗战如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻勇猛执持牢杖弃舍斗战如来名者。欢喜信乐持讽诵者乃至梦中。此等众生。譬如金刚伏众魔兵。以诸智慧消伏诸欲。其有得闻此佛名号一心信者。审谛自知我等前世。以为曾见此佛世尊游于菩萨径路之时而不疑也。我等当发弘誓之愿。莫从大乘而得退转。但当自庆欢喜踊踊进大法路。得闻如来种姓名号。诸佛普利益于一切。不舍一人而取灭度。诸佛大慈普愍众生雨于法雨。其有得持此如来名者欢喜信乐。所得功德。我当为汝取少譬喻。如恒边沙诸佛国土。满中七宝持用布施。所得功德宁多不乎。舍利弗言。甚多甚多。不可思议。佛言。分大海水一渧为一分。布施功德犹若一渧。持佛名者所得功德。如大海水不可为喻。少功德人不能堪任听斯经典。若使有人久殖德本。得闻斯法信而不疑。若使地狱畜生饿鬼及长寿天闻此经者尚得大福。况复有人已种德本。闻斯经法所得功德宁可喻乎

复次舍利弗。东方去此佛土。度二十佛刹。有世界名曰丰饶。其国有佛。号内丰珠光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻内丰珠光如来名者。一心信乐持讽诵念。斯等皆当获大功德。终不畏堕三涂之难。所发弘誓如意得满大乘之愿。若今现在般泥洹后。其有得闻内丰珠光如来名者信乐诵念。斯等皆当得大乘法乐而以自娱。及受天上人中快乐。常当得生清净佛土。于诸佛国具满众愿。从意所欲于三乘法而得灭度。于其中间从此佛所。获功德聚甚大弘广。恒沙劫中所作众罪。悉当弃舍不受。唯除逆罪起嗔恚意向诸快士。此等之类于久长世。地狱之中受斯罪毕。因得闻此佛名功德所致。其后如愿于三乘中而取灭度。当知舍利弗。众恶之行慎莫造作。如我于此经中上章所说。不可起恚向于焦柱。何况怀恶向于众生。已立信心向成道者。况起嗔恚怀于诽谤。向诸如来无量慧等。如此之人于无数劫在地狱中。具受无量苦恼之罪。尔乃得出。我为斯等求于大乘信解者故。而说斯法。其有毁坏大乘法者。实当具受无量大苦。信乐之者自果当立不退转地必成正觉

复次舍利弗。东方去此丰饶世界。度八十佛刹。有世界名最香熏。其国有佛。号无量香光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量香光明如来名者。持讽诵念一心信乐最后念之。斯等皆当得不退转地成最正觉。成正觉已诸毛孔中出众妙香。遍至十方犹若云起。非是下劣少智之士学浅法者而解斯经。吾亦道眼观睹斯等诸众生类。其有信乐斯经法者。过去世间无数劫中。于诸佛所集诸慧法造众德本。今乃得闻此尊妙法。最后末世闻斯典教信而奉持。未曾生意而怀诽谤。初未曾有不解法时。却四十劫生死之罪。其人功德如月欲满。为于世间而作快士。应当得受一切恭敬。而为众生作良福田

复次舍利弗。东方去此香熏世界。度五十佛刹。有世界名龙珠观。其国有佛。号师子响如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻师子响如来名者。持讽诵读一心信乐念于戒行。斯等皆当立不退转。成最正觉作众德轮。入白净法于中旋转过出于世。却二十劫生死之罪。若族姓子族姓女。若人非人。其诸厄难疾得解脱。现在于世有得闻斯佛名者。于诸世间犹若尊塔

复次舍利弗。东方去此龙珠观世界。度三十佛刹。有世界名曰修行。其国有佛。号大强精进勇力如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大强精进勇力如来名者。尽心信乐持讽诵念。右膝着地叉手作礼。自作是言。我今礼大强精进勇力如来至真等正觉。斯其人等游生死中多所饶益。得大战力退却众魔伏诸外道。却二十五劫生死之罪

复次舍利弗。东方去此修行世界。度四十佛刹。有世界名曰坚住。其国有佛。号过出坚住如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻过出坚住如来名者。净心信乐持讽诵念。此等皆当坚住大乘。于诸尊法得坚固财。加得大福昼夜日日增益功德

复次舍利弗。东方去此坚住世界。度三十六佛刹。有世界名曰光明。其国有佛。号鼓音王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻鼓音王如来名者。尽心信乐持讽诵念。长跪叉手自作是言。我今礼鼓音王如来至真等正觉。所得功德三千大千一切世界。满中珍宝持用布施。得其功德宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人持此佛名功德甚多。过出施上百千万倍

复次舍利弗。东方去此光明世界。度百五十佛刹。有世界名众德室。其国有佛。号曰月英如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻月英如来名者尽心信乐若天若人龙及非人。闻此佛名持讽诵念。斯等皆当得入清净。犹若莲花不着尘水。于众恶中悉无所犯。若有女人得闻月英如来名者。净心信乐无有谀谄。从是以后更止不受女人之身。若有不信轻慢谤毁。当二十劫在于阿鼻大泥犁中具受众苦。若使有人尽心信乐怀大恭敬。却二十一劫生死之罪

复次舍利弗。东方去此众德世界度十万亿佛刹。有世界名住栴檀地。其国有佛。号超出众花如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。佛告舍利弗。其佛本行菩萨道时。自作是言。我成正觉兴出世时。其刹土中无有八难。用是誓愿自净佛国。若有得闻超出众花如来名者。尽心信乐持讽诵念。斯等大士于诸世间。多所利益如大药王

复次舍利弗。东方去此栴檀世界。度二十亿佛刹。有世界名曰善住。其国有佛。号世灯明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻世灯明如来名者。尽心信乐持讽诵念。斯等皆当脱三涂厄。唯除逆罪起嗔恚向诸快士。其有持此如来名者。为得此尊妙法之宝。却二十劫生死之罪

复次舍利弗。东方去此善住世界。度八十亿佛刹。有世界名曰光明。其国有佛。号休多易宁如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。所以世界名光明者。其国佛土地平如掌。以众莲花布满世界。其土如来光明晃晃。犹若大火昼夜常照。其佛国土光明巍巍最尊第一。常于大众转尊法轮。若使有人三千世界以金布地。复以妙衣庄饰其地。悉令弥满三千世界持用布施。得其功德宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人闻休多易宁如来名者。尽心信乐持讽诵念。其人得福过出布施功德者上数百千倍。斯等众生自恣发愿如意得之。却六十劫生死之罪。后成无上正真道时。其佛国土严净快乐尊贵无比

复次舍利弗。东方去此光明世界。复有刹土名围绕月。其国有佛。号曰宝轮如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次舍利弗。东方去此围绕世界。有刹土名曰度觉。其国有佛。号常灭度如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。而今现在转不退转无上法轮

复次舍利弗。东方去此度觉世界。有刹土名须弥胁。其国有佛。号曰净觉如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。而今现在广说经法

复次舍利弗。东方去此过须弥胁世界。有刹土名曰名称。其国有佛。号无量宝花光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。而今现在广说妙法

复次舍利弗。东方过此名称世界有刹土。名曰妙软。其国有佛。号须弥步如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。而今现在于大众中广说经法

复次舍利弗。东方过此妙软世界。有刹土名曰丰养。其国有佛。号宝莲花如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。现在大众广说经法

复次舍利弗。东方过此丰养世界。有刹土名莲花踊出。其国有佛。号一切众宝普集如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。现在说法

复次舍利弗。东方去此莲花踊出世界。有刹土名曰金光。其国有佛。号树王丰长如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。现在说法

复次舍利弗。东方过此金光世界。有刹土名曰清净。其国有佛。号转不退转法轮众宝普集丰盈如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。与诸菩萨无央数众前后围绕。转不退转无上法轮

复次舍利弗。东方过此清净世界。有世界名曰净住。其国有佛。号围绕特尊得净如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。斯诸如来至真等正觉现在东方。其有宣扬诸如来名。广分别说令人受持。复有余者不可计数。今悉现在说无上法。其有得闻斯诸佛名尽心信乐。以膝着地长跪叉手。普为东方诸佛作礼。持诸佛名三作是言。我今普礼东方一切诸佛世尊。其人得福不可限量

佛说称扬诸佛功德经卷上佛说称扬诸佛功德经卷中

        元魏天竺三藏吉迦夜译

复次舍利弗。南方去此度十万亿佛刹。有世界名曰真珠。其国有佛。号日月灯明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻日月灯明如来名者。持讽诵念欢喜踊跃。至心信乐而无有疑。如来言教实为快善。无数千人净心敬信。悲喜情踊为之雨泪。此众生辈自当忆知。吾等往昔为曾值见此诸佛已。若有女人其有得闻日月灯明如来名者。欢喜信乐。从是已后所生之处。止更不受女人之身。十方世界其有得闻斯佛名者。皆当得立不退转地必成正觉。于诸欲中意常清净。不为欲垢之所缠缚。此佛刹人及与他方诸众生类。闻此如来名号者。计其功德不可限量。不以言辞所可称说能尽其德。魔王官属终不堪任毁坏其人无上道心。佛语舍利弗。魔王常欲索此经便。欲断绝之。所以者何。为诸欲聚之所缠缚。虽尔舍利弗。斯之伴党最为后世时。会当信乐斯尊经法而不谤毁其信乐者。斯之正士如优昙花。在于世间宜受一切三界供养。舍利弗言。惟天中天。最后末世凶愚暴恶。几所众生有能信持日月灯明如来名者。及诸世尊如来名号欢喜信者。佛言。我今现在谛观察之。比丘僧中终不见有。被白衣者最后末世亦复如是。信乐斯经讽诵之者。亦复少有。百万之中若一若两。舍利弗言。设有听受信斯经者。所得功德为几许。佛言。诸如来于无数劫游于五道。拔济众生三涂之厄。满具一切弘誓之愿兴出于世。广为众生敷陈妙法。实为难值。用说正法故多所利益。一切众生其有闻者欢喜信乐。斯等皆当疾能解了。我之智慧却生死罪百劫在后。其闻此法不信乐者。斯之等辈我悉见之。舍利弗言。惟天中天。有几所人谤毁斯经。所得罪报受几时苦。佛言。斯众生辈六十亿岁。于地狱中具受众罪。为以谤毁诸如来等正觉法故。舍利弗。斯法兴盛几时之间。在所之处愚痴之人。于中造立地狱之行。用谤诸佛如来之故。是故舍利弗。夫黠慧者。若族姓子族姓女。最后末世闻此妙法信不诽谤。宜当自庆欢喜踊跃。作是思惟。我等不谤如来之法。身之所受恶行苦报吾已得脱。佛告舍利弗。最后世时大千世界满中七宝持用布施犹尚易得。闻有赞叹斯众功德实难得值。值此法者皆为如来之所护持

复次舍利弗。南方去此真珠世界。度万佛刹。有世界名裁光。其国有佛。号曰须弥如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻须弥如来名号者。持讽诵念欢喜信乐。长跪叉手当为作礼。当得无比功德之报。魔王不能毁坏其人无上道心。犹须弥山坚住不动。功德甚多日日增益不可限量(裁光世界丹本戒光)

复次舍利弗。南方去此裁光世界。度万四千佛刹。有世界名曰音响。其国有佛。号大须弥如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大须弥如来名。尽心信乐持讽诵念。若至梦中。斯等之人终不更起恚乱之意向诸快士。得不退转当成正觉。斯诸正士当解妙慧。了一切法犹若如梦。却八十劫生死之罪

复次舍利弗。南方去此音响世界。度五千佛刹。有世界名紫磨金。其国有佛。号阿提弥留(晋言超出)须弥如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻阿提弥留如来名者。尽心信乐持讽诵念。所得功德。设使有人持阎浮檀金。布于三千大千世界。悉令弥满持用布施。其人得福宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人持讽诵念阿提弥留如来名者。净心信乐所得功德。过出施上百倍有余无以为比。若有常念此如来名。却生死罪十劫在后

复次舍利弗。南方去此紫磨金界。度二万佛刹。有世界名色像光。其国有佛。号喻如须弥如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻喻如须弥如来名者。净心信乐持讽诵念。以膝着地长跪叉手。而为作礼。如斯人等当得智慧犹若大海。悉能奉持诸佛之法。疾得成就正觉之道

复次舍利弗。南方去此色像光世界。度万八千佛刹。有世界名过珠光。其国有佛。号曰香像如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻香像如来名号者。弹指之顷恭敬净意。念斯如来所得功德。假令有人持阎浮檀金。布三千大千世界。悉令弥满持用布施。其人得福宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人口中讽诵香像如来名号者。如弹指顷功德殊特。过出施上百倍有余。所以者何。一反唱声称斯佛名获大盈利。何况目睹如来色像作礼恭敬。及泥曰后入于庙寺。瞻觐形像礼拜虔恭。所得功德宁可称乎

复次舍利弗。南方去此珠光世界。度无数千佛刹。有世界名曰得勇力。其国有佛。号三曼陀揵提(晋言围绕)香熏如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。舍利弗。其佛如来本求大乘。为菩萨时作是誓愿。我设先世供养诸佛。及复供养弥嘉揵尼如来正觉。烧名好香丸如芥子。自誓愿言。愿我今日持此功德。成作佛时。身诸毛孔悉出妙香。熏遍十方恒沙世界。犹若云起。皆令弥满他方佛国无量世界。一切众生得具戒香闻我名者。斯等一切成作佛时。我诸毛孔亦出斯香遍无量国。三曼陀揵提如来。亦自满具一切诸愿。若使有人赞叹广说如来名德。若族姓子族姓女。七日之中饥不获食。故当往听叹说如来功德之法。所以者何。闻斯佛名所得功德不可限量。舍利弗言。如是世尊。其有得闻三曼陀揵提如来名。所得功德不可称量甚多乃尔。最后世时。若族姓子族姓女。闻斯功德欢喜踊跃。及复得闻诸佛名号功德法者。魔王不能毁坏其人无上道心。所以者何。诸佛世尊。皆共拥护此等众生。是故魔王不能得坏其人道心。佛言。设我赞叹斯佛功德。众生闻者。或能惑乱。所以尔者。此等之类福德浅薄无黠所致。不能信持。若有信者。舍利弗。皆当欢喜踊跃自庆。此等必当成最正觉。而于此中所得功德。我当为汝引少譬喻。诸佛大慈皆欲使人入其法中。十方世界满中七宝持用布施。所得功德宁为多不。舍利弗言。甚多甚多。天中天。佛言。不如有人得闻三曼陀揵提如来名者。得福甚多过出施上百倍有余。加复作礼五体投地。得其福德不可思议。却生死罪百劫在后

复次舍利弗。南方去此得勇力界。度十亿佛刹。有世界名曰云厚无垢光。其国有佛。号曰净光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻净光如来名号者。欢喜信乐持讽诵念。弹指之顷发大慈心其人至心慕乐斯佛已。自作是言。今我得闻斯佛名号。弹指之顷发大慈心。持此功德。愿使十方一切众生得解如来微妙之慧。当知舍利弗。斯等众生发弘誓愿。于中所得功德之福。如恒边沙诸佛国土。满中七宝持用布施。其所得福宁为多不。舍利弗言。甚多甚多。世尊。不可称量。佛言。不如有人诵持净光如来名者。欢喜踊跃。弹指之顷发大慈心。兴弘誓愿所得功德。比于布施过上百倍。诸正士等欲布施时当作法施。斯之功德疾得成就正觉之道。却八十劫生死之罪

复次舍利弗。南方去此云厚无垢光界。度万佛刹。有世界名曰法界。其国有佛。号曰法最如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻法最如来名号者。欢喜信乐持讽诵念。长跪叉手头面作礼。斯等皆当而能护持诸佛之法。于佛法中所得大利目见如是。以是之故皆当信乐持斯佛名。加广宣传阐扬佛德发尊觉意。不当起心作轻慢行。向于如来敬信之者。悉能灭除三涂之苦皆由斯德。诸佛世尊无数劫中。聚众德本具如来行实为谦苦。久远难量乃得成就如来法身畅达正觉。一切之智实为甚难。以是之故不当生慢。皆当兴立敬信之心向于如来。一切世界设满中水。水上有板而板有孔。有一盲龟。于百岁中乃一举头。欲值于孔。斯亦甚难。求索人身甚难甚难。于此欲得除去八难之患。若有得闻斯经法者。众难恶道皆悉永绝。以是之故。当发大愿求解最尊无比之法。若一发意于如来者。喜心信乐。斯等疾近正觉之道。却二十劫生死之罪

复次舍利弗。南方去此法界。度五万五千佛刹。有世界名曰星自在王。其国有佛。号香自在王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻香自在王如来名者。欢喜信乐持讽诵念。长跪叉手自作是言。我今礼香自在王如来至真等正觉。当发大慈持功德聚。使诸如来及诸弟子长受天乐亦受法乐。一切众生皆亦如是。若使有人不慕泥洹。斯等皆当住不退转疾成正觉。三千世界满中七宝持用布施满千岁中。所得功德宁为多不。舍利弗言。甚多世尊。佛言。不如有人持斯佛名发大慈心得福甚多。比于施德过上百倍。却三十劫生死之罪

复次舍利弗。南方去此星自在王世界。度万佛刹。有世界名曰正真。其国有佛。号大集如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻大集如来名号者。欢喜信乐持讽诵念。如此人等与诸佛法常共合偶。亦不起意乐入泥洹

复次舍利弗。南方去此正真世界。度八千佛刹。有世界名曰广博。其国有佛。号光香明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻香光明如来名号者。欢喜信乐持讽诵念。斯等皆当得不退转成最正觉。所以者何。香光明如来本游菩萨径路之时。作是誓愿。我作佛时。一切众生闻我名者。得不退转疾成正觉。在于三涂恐怖之中疾得解脱

复次舍利弗。南方去此广博世界。度二万佛刹。有世界名曰广远。其国有佛。号曰火光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻火光如来名号者。欢喜信乐持讽诵者。斯等皆得无限之福。其有谤毁而不信者获无量罪

复次舍利弗。南方去此广远世界。度万五千佛刹。有世界名曰无崖际。其国有佛。号无量光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量光如来名者。尽心净意欢喜信乐。斯等众生。为此如来光明威神之所护持。却生死罪十劫在后。其有谤毁而不信者。当二十劫在波多畔泥犁中

复次舍利弗。南方去此无崖际界。度二万佛刹。有世界名曰坚固。其国有佛。号曰开光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻开光如来名号者。欢喜信乐持讽诵者。魔王众兵不能毁坏其人道心。

复次舍利弗。南方去此坚固世界。度二千五百佛刹。有世界名曰马瑙。其国有佛。号月灯光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻斯佛名者。持讽诵念。斯等皆当为世作导。应当得受世之供养。斯其人等为持天上之牢杖也。当知舍利弗。此诸佛名在于郡县丘聚村落诸国邑则神塔也。所以者何。舍利弗。最后末世斯诸快士。正觉之名。甚难得值。其有闻者皆当欢喜一心信乐

复次舍利弗。南方去此马瑙世界。度八千佛刹。有世界名曰妙香。其国有佛。号日月光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻月光如来名号者。欢喜信乐持讽诵念。若于梦中若闻若说展转相语。此辈皆当欢喜踊跃。当得无量功德之报。道心坚固如须弥山不可倾动。一切魔王不能毁坏

复次舍利弗。南方去此妙香世界。度万佛刹。有世界名曰为日。其国有佛。号日月光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其佛国土无有四路。何等为四。无有地狱饿鬼畜生贫穷下贱。其佛世尊本求道时。作是誓愿。设我成佛若泥洹后。其有众生闻我名者。皆当得住不退转地。疾成无上正真之道。亦使此等成立国土无上道田所愿具足。亦当如我众愿悉满。舍利弗。若有得闻月光明如来名者。欢喜信乐持讽诵念。此等众生亦当具满无上道愿如此世尊

复次舍利弗。南方去此日世界。度万八千佛刹。有世界名曰金珠光明。其国有佛。号曰火光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻火光如来名号者。信乐欢喜持

诵念。斯等已持智慧之炬。越度一切生死之海。当各精进一心信行。昼夜常念莫得疑懈当广宣化设于法施。一切魔王不能毁坏其人道心。况于外道能毁呰耶

复次舍利弗。南方去此金珠光明世界。度万六千佛刹。有世界名曰众色像逆镜。其国有佛。号曰集音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有众生生彼佛刹。甫当生者。现已生者。此等正士过逾一切人天像貌。众相严容端正姝妙光明巍巍。非天世人所受之体。其有得闻集音如来名号者。欢喜信乐持讽诵念。后生之处常得端政颜容妙好。心常欢喜信乐诸佛

复次舍利弗。南方去此众色像界。度万三千佛刹。有世界名曰众聚。其国有佛。号最威仪如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻最威仪如来名者。欢喜信乐持讽诵念。其人为得世间最尊天龙鬼神之所敬仰。却二十劫生死之罪

复次舍利弗。南方去此众聚世界。度十万佛刹。有世界名曰胜战超度无极。其国有佛。号光明尊如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻光明尊如来名者。欢喜信乐持讽诵念。若天若人阅叉鬼神斯众生。因此功德。会得成就正觉之道。却三十劫生死之罪。若有轻谤而不信者。满八万岁在于大泥犁具受众苦

复次舍利弗。南方去此胜战超度无极世界。度五千佛刹。有世界名一切音响。其国有佛。号莲花军如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻莲花军如来名者。欢喜信乐持讽诵念。若使有人大千刹土。满中珍宝持用布施。其人得福宁为多不。舍利弗言。甚多甚多。世尊。不可称量。佛言。不如有人持讽诵念莲花军如来名者。所得功德过于布施功德者上。常与诸佛世尊共会。卿舍利弗。汝曹不能都尽堪任听此功德。斯佛世尊从久已来。于诸禅中具诸德本。其有信持此佛名者。其人皆当超过三界。犹若莲花从水踊出

复次舍利弗。南方去此音响世界。度二万佛刹。有世界名曰月光。其国有佛。号莲花响如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。舍利弗。此如来尊。何故名曰号莲花响。初升道场坐莲花上成最正觉。无数诸天在虚空中。异口同音共唱声言。莲花响佛今出于世。其音遍闻大千刹土。以是之故号莲花响。其有得闻斯佛名者。欢喜信乐长跪叉手。自作是言。我今礼莲花响如来至真等正觉。斯等终不堕于恶道。游诸恐难疾得解脱。惟除五逆恶罪行者

复次舍利弗南方去此月光世界。度三万佛刹。有世界名天自在。其国有佛。号曰多宝如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。舍利弗。其佛世尊何故名曰为多宝乎。本游菩萨径路之时。有不可计声闻之众。悉来从其启受经法。异口同音共作是言。斯之正士乃能有此深妙法宝。因号名曰为多宝也。若族姓子族姓女。其有得闻斯佛名者。欢喜信乐长跪叉手。三反称言。我今礼多宝如来至真等正觉。其人所生在诸佛刹。心常解了一切诸法。所以者何。斯佛世尊为菩萨时发是誓愿。如此人者自成法宝。以宝为徒从

复次舍利弗。南方去此天自在界。度二万佛刹。有世界名曰莲花。其国有佛。号师子吼如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻师子吼如来名者。欢喜信乐长跪叉手。三举声言。我今礼此师子吼如来至真等正觉。斯其人等所生之处。皆当悉能作师子吼。声扬法音遍于三千。化度无量众生之类。却五十劫生死之罪

复次舍利弗。南方去此莲花世界。度万佛刹。有世界名曰明星。其国有佛。号师子音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻师子音如来名者。欢喜信乐持讽诵念。斯其人等后生之处。得无量音。及得如来净光之音。所以者何。若散花香于虚空中。称南无佛得福无量。况睹灵庙如来形像。至心礼敬散花香者。斯等在世犹若好花。莫不鲜泽

复次舍利弗。南方去此明星世界。度万五千佛刹。有世界名曰无忧。其国有佛。号精进军如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻精进军如来名者。欢喜信乐持讽诵念。一心奉信无忧刹土。以清净心尽诚敬信于此如来。斯等皆当成等正觉。能为众生广转法轮。所以者何。其如来尊本求道时兴此誓愿。吾成正觉。一切众生闻我名者。其人皆当生我刹土。悉当具满如来之慧。舍利弗。若有谤毁轻慢不信更相调戏持用作笑。此辈亿岁在地狱中具受罪报

复次舍利弗。南方去此无忧世界。度万佛刹。有世界名金刚聚。其国有佛。号金刚踊跃如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻金刚踊跃如来名者。一心信乐持讽诵念。若于梦中闻斯佛名。其人皆能破坏三毒消散诸欲。得不退转于诸佛法

复次舍利弗。南方去此金刚聚世界。度千亿佛刹。有世界名曰恐明珠其国有佛。号度一切禅绝众疑如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻度一切禅绝众疑如来名者。欢喜信乐至心讽诵念其如来。若复有人说斯佛名。其有听者当以质直无谀谄意。宣传之者真正说之。斯等皆能坏众魔兵。及诸外道倒见之徒。悉能决散一切疑结。必得成就正觉之道

复次舍利弗。南方去此恐明珠世界。度千八百佛刹。有世界名曰花香。其国有佛。号宝大侍从如来至真等正觉明行。成为善逝世间解无上士道法御天人师号曰众祐度人无量。舍利弗。若有得闻宝大侍从如来名者。欢喜踊跃一心信乐持讽诵念。斯其人等能为世间作大珍宝。当转无上正法之轮。如是舍利弗。闻斯佛名信乐之者。得大利益功德乃尔。其有畏恶生死之难。倾其心意着在声闻缘觉之道。此等徒类小誓浅智志存下劣。不能堪任尊妙之道。放舍如来广大之慧。斯之等辈不能信解此深妙义。其有众生求广妙慧。倾于众德着最特妙乘。于此法中。但当求索无尽之藏。除去悭心褊狭局意。发无盖哀。但欲充满众生之愿。作是施与。于如来田得无尽报。会当解了正觉之慧。能以财宝施与众生。令使一切各得快乐。愿此众德着于无上正真道中。舍利弗。其有得闻斯佛名者。及诸如来功德名号。加广宣传称扬说时。若有不信谤毁之者。四十亿岁在加罗秀领泥犁之中具受众苦

复次舍利弗。南方去此花香世界。度六千佛刹。有世界名曰喜起。其国有佛。号曰无忧如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无忧如来名号者。发欢喜心信乐讽诵。斯诸人等于众欲中无所污染。不为诸欲之所拘碍。心如莲花不着尘水。得不退转。悉能安隐一切众生。后成正觉。若有众生闻其名号。至心讽诵欢喜信乐。若存在世。若泥曰后。斯等亦得最特妙乘。为世导师。皆当逮得无量功德所生之处。其人未曾不值佛时

复次舍利弗。南方去此喜起世界。度二万佛刹。有世界名曰哀色。其国有佛号地力持踊如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻地力持踊如来名者。净心欢喜持讽诵念。五体投地而为作礼。念其如来一日一夜。斯人当得立不退转难动如地。一切众魔不能毁坏其人道心。得无量慧犹若大海。断生死路却二十劫生死之罪

复次舍利弗。南方去此哀色世界。度十四佛刹。有世界名曰为天。其国有佛。号最踊跃如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻最踊跃如来名者。欢喜踊跃持讽诵念。长跪叉手而为作礼。当作是言。我今礼最踊跃如来至真等正觉。此等众生当为最特殊妙大乘之所捉持。亦能饶益一切众生。三涂八难悉为永除

复次舍利弗。南方去此天世界。度八千佛刹。有世界名栴檀光。其国有佛。号曰自在王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻自在王如来名者。益加信乐。若更相劝持此佛名。斯皆当得无量之福。舍利弗。若有说此如来名时。若天若人龙及阅叉一切非人。其有闻此如来名者。此等皆当得不退转于正真道

复次舍利弗。南方去此栴檀光世界。度二十亿佛刹。有世界名一切伎乐震动。其国有佛。号无量音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻无量音如来名者。欢喜信乐如来功德当发此愿。以此功德使我解了如来智慧。斯皆当住不退转地。必成无上正真之道。所以者何。此如来尊为菩萨时兴大弘誓。立此愿故。若有不信诽谤之者。于地狱中长受众苦。罪毕得出所生之处。常不遇值诸佛之世。舍利弗。其佛世界何故名曰伎乐震动。无量音佛本从兜术降神之时。始发一切伎乐之音声。普震动扬其乐音声。天上世间乃至非人一切伎乐所不能及。其佛住寿在世之时。说法教化至于泥曰。其佛国土伎乐之音声续美畅。震于十方二十佛刹。以是之故号无量音

复次舍利弗。南方去此一切伎乐震动世界。度三百亿佛刹。有世界名集光明。其国有佛。号曰锭光如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。舍利弗。其如来尊停住光明照他佛国。十万亿刹常以大明。以是之故名曰锭光。其有得闻斯佛名者。一心信乐欢喜踊跃无谀谄意。斯等当为如来光明之所护持

复次舍利弗。南方去此集光明世界。度八万佛刹。有世界名一切香。其国有佛。号宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝光明如来名者。欢喜信乐持讽诵念。斯等皆当为于世间作大珍宝。住不退转于正真道。所生之处常值佛世。初不曾生无佛之处。游于菩萨径路之时。却五十劫生死之罪。是故舍利弗。不当起于嗔恚忿乱向诸菩萨及诸弟子。惟当兴立大慈之心而奉敬之。当求如来广妙之慧。发弘誓愿趣至大乘。舍利弗。如是其人疾近无上正真之道。广演如来深妙之法。若使有人未入泥洹。在菩萨之境界者。不信佛法。亦不信有行菩萨道。言佛道难得。如是之人。满于千岁在地狱中具受众罪。是故舍利弗。不当起嗔恚之意向于虫蠡。况持恶意向诸快士。痴盖所覆无惭愧者。于中谤毁益牢地狱诸罪之行。舍利弗。诸佛兴世甚难甚难。百亿之数发意求道。至时得者若一若两。当知舍利弗。如来兴世如优昙花。时时乃有不可见也。其求大乘发弘誓愿。已有发者。甫当发者。今现发者。起勇猛意不沉疑者。当如所愿疾成不久。广施法食具正觉道。如是南方诸佛之等不可称计。今现康常广说经法。其有闻者广演兴显叹扬如来无量功德。当向南方五体投地念诸如来称其名号而为作礼。其人得福不可计量

佛说称扬诸佛功德经卷中佛说称扬诸佛功德经卷下

        元魏天竺三藏吉迦夜译

复次舍利弗。西方去此度十万亿佛刹。有世界名曰安乐。其国有佛号阿弥陀如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。若有得闻无量寿如来名者。一心信乐持讽诵念。当起广远无量欢喜安立其意。令使真谛十万亿信心念斯如来。其人当得无量之福。永当远离三涂之厄。命终之后皆当往生彼佛刹土。命欲终时一心信乐。念不忘舍阿弥陀佛。将诸众僧住其人前。魔终不能毁坏斯等正觉之心。所以者何。其佛世尊兴立大悲。誓度一切无量众生。亦复护持十方世界一切众生。其有得生安乐世界。当于其中具满如来正觉之慧。舍利弗。其佛世尊本求誓愿。其有求于第一之乘。于其世界具满如来诸佛之法。具正觉分。求声闻乘于彼佛刹得阿罗汉。其有往生彼佛刹者。从其所愿大小之乘于彼毕满。其有最后闻阿弥陀如来名号。赞说之者信不狐疑。当起敬心至意念之如念父母。作如是意。斯等普当于彼佛国具满众愿。其有不信赞叹称扬阿弥陀佛名号功德而谤毁者。五劫之中当堕地狱具受众苦

复次舍利弗。西方去此十万佛刹。有世界名破一切魔。其国有佛。号曰殊胜如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻殊胜如来名号者。欢喜信乐持讽诵念。此等皆能降伏众魔。裂坏罗网。却六十劫生死之罪

复次舍利弗。西方去此十万佛刹。有世界名曰伏一切魔。其国有佛。号曰集音如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻集音如来名号者。欢喜信乐持讽诵念。其人当得一切如来诸佛音声。于大众中广说法处。于中特尊。退却众魔降之以德。却八十劫生死之罪

于是阿逸菩萨。长跪叉手前白佛言。宁有一事菩萨摩诃萨。于此事中具大乘愿住不退转。疾成无上正真道不。佛言有。阿逸。北方有世界名曰丰严。其国有佛。号德内丰严王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻斯佛名者。欢喜信乐持讽诵念而为作礼。其人皆当得不退转。疾成无上正真之道。却一亿劫生死之罪。其有供养五千佛者。此辈阿逸。尔乃得闻德内丰严王如来名号。其闻名者。从是以后所生之处。常得天眼未曾不得天眼之时。常能彻听未曾不得天耳之时。常能飞行无有不得神足之时。乃至泥曰常得端政。未曾受于丑恶之形。乃至泥曰常当尊贵。未曾生于下劣之处。乃至泥曰悉能除坏众欲之缚。其人六情眼耳鼻口及于身意终无有疾。乃至泥曰初未曾生无佛之处。听大尊法未曾有碍。不得听时未曾有碍。不见僧时亦复不生八难之处。戒常具足无有缺时。识心清净无有忿乱时。当知阿逸。其有得闻此佛名者。净心信乐于最正觉。如渴欲饮。发信敬心向如来者。此等阿逸。悉能捉持诸佛世界最特之利。其人皆当获于殊妙奇特功德。是故阿逸。并当专精持此佛名。若族姓子族姓女。欲得殊特妙净刹者。当急听此诸尊佛名称其名号。当为作礼自作是言。我今礼于德内丰严王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。阿逸白佛言。惟天中天。其佛刹土为在何所去此远近。成佛以来为几时也。佛告阿逸。设使纵广百由延中一大埠沙。取一沙着一佛刹。如是悉着诸佛刹中悉令沙尽。如是沙数诸佛刹土悉满中沙。复取诸佛刹土中沙。复以一沙着一佛刹。如是诸国刹中沙。悉使令尽取此沙数。诸佛刹土悉破为尘。复取一尘着一佛刹悉令尘尽。是诸佛国尘数刹土犹尚未至。余未到者过此百倍。其佛刹土去此极远不可称量。其佛世尊在彼丰严刹土之中。而今现在与无央数诸开士等不可称计诸比丘众。前后围绕而为说法。我于此坐遥用肉眼。见其如来于大众中广说经法。彼佛世尊于彼刹土在高座上。亦用肉眼观此世界。亦复见我在于座上于大众中而说经法。阿逸当知。若有众生信诸如来肉眼所见。而欢喜者。此必成就正觉之道。斯等皆诸佛如来之所护持。令使信乐而不狐疑。斯等皆当捉持如来深妙之慧。得不退转于最正觉。是故阿逸。其有欲求此大福者。若使三千大千世界满其中火。故当入中听斯佛名智慧之法。阿逸菩萨复白佛言。宁有一法得不退转。疾成无上正真道不。佛言有。阿逸。北方去此不可计数诸佛刹土。有世界名曰金刚坚固。其国有佛。号金刚坚强消伏坏散如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻金刚坚强消伏坏散如来名者。欢喜信乐持讽诵念尽心供养。斯等皆当住不退转。疾成无上正真之道。却于十万亿那术劫生死之罪。超然在后。其佛如来功德无量弘誓乃尔。我自过去无数劫前。锭光如来兴出于世。于彼佛所而得闻此金刚坚强消伏坏散如来名号。得超十万亿那术劫生死之罪。阿逸当知。若我不从锭光闻斯佛名者。我今故未得成正觉。其佛何故名曰金刚坚强消伏坏散。譬如金刚所在堕处。若山若崖瓦石土垒墙壁树木。若遥拟向所堕之处。莫不消灭破碎坏散。如是阿逸。其有得闻此佛名者。持讽诵念一切诸欲皆疾消散。一切声闻辟支佛心。褊狭之意皆悉消灭。疾得成就正觉之道。是故号曰金刚坚强消伏坏散如来。其佛世尊一切众愿具满如是

复次阿逸。北方去此度十万亿诸佛刹土。有世界名摩尼光。其国有佛。号曰宝火如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻宝火如来名号者。欢喜信乐持讽诵念。其有未入泥洹界者。斯等一切皆当得立不退转地。疾成无上正真之道。其佛刹土一切人民。供养宝火如来者。悉一大乘而得度脱。无有声闻缘觉之名

佛告长老大迦叶。当知诸佛如来之德不可思议。北方去此五十万佛刹。有世界名阿竭流香。其国有佛。号宝月光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。迦叶。若族姓子族姓女。其有得闻宝月光明如来名者。欢喜信乐持讽诵念。此等后世所生之处。得不中止三昧正定。若三昧时自见诸佛转尊法轮。悉能总持诸佛之法。在所生处。常为众生阐扬大法。辩才清妙于众特尊。诸所欲求从愿悉得。所以者何。其佛世尊本求道时。兴此誓愿。吾成正觉闻我名者。令使得此三昧定意。从初发意至于成道。于其中间常得此定未曾中失。于是世尊。而叹颂曰

  度五十万诸佛刹　　有世界名阿竭流
  其国有佛号宝月　　方明晃昱甚巍巍
  其有得闻此尊名　　便为已得所依仰
  后生之处则得禅　　精进智慧无中止
  名声普达光围绕　　其人见佛在刹土
  为诸众生广兴演　　诸佛导师所说法
  一切诸事无坚固　　观诸法中无所起
  普当慈哀于一切　　于诸禅中得自在
  已能发行如是意　　都了三涂无恚忿
  审谛解了无吾我　　无所有者非无有
  谛了诸事无所得　　于此中间所兴法
  如是法者无所住　　求了表识无表识
  此二俱空亦无性　　兴显如是无我法
  无表识者是空义　　当审谛说此妙法
  表识可了不可了　　此二俱转于痴慧
  谛观此二俱清净　　亦不复见诸法垢
  所说法者无所猗　　都了无依波罗蜜
  譬如月行于空中　　其所说法无所猗
  如此妙法兴是间　　于三界中无所著
  菩萨法中无所依　　解如是者一切智
  解了此法为人说　　若能解达无猗法
  审谛分别如是者　　其人则为近大智
  慧者得闻无依句　　终无复有狐疑计
  其人解了如是者　　于世独达无所咨
  畅达如是大智慧　　号曰特尊无上士

复次迦叶。北方去此六万佛刹。有世界名长欢乐。其国有佛。号曰贤最如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻贤最如来名号之者。欢喜信乐持讽诵念。所生之处当为一切之所敬爱。哀见信用。其所言教莫不承奉。其人皆当获斯功德。得无碍辩。所说经法众生闻者。欢喜信解莫不履行。于是世尊。而叹颂曰

  度于六万诸佛刹　　有界名曰长欢乐
  慈哀度法贤最尊　　其大导师在世界
  最尊无比无与等　　世世济度诸众生
  其闻名者作法师　　言奉信用莫不欢
  此一切智大法王　　无量黎庶斯依仰
  若有女人闻其名　　疾得舍离女人形
  秽恶甚深无崖际　　非离世者不能入
  其无所有所可入　　是为审谛谛不谛
  了此二事俱无性　　其已寂灭无有性
  其有尽者以为灭　　甫当兴者亦无性

复次迦叶。北方去此八千佛刹。有世界名曰现入。其国有佛。号宝莲华步如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。若族姓子族姓女。其有得闻宝莲花步如来名者。欢喜信乐持讽诵念。后生之处颜貌端正殊妙无比众共敬爱。自识宿命无数劫中事。皆悉了知生所从来所作善恶。悉皆识知其所生处。所说言教一切信奉。莫不承用。迦叶。若族姓子族姓女。得闻斯等诸如来尊正觉名号功德之行。若有爱乐女人身者。如是女人在于女中未得解脱。若厌女人身不贪乐者。持讽诵念诸佛名者。尽可得斯等德。迦叶白佛。当复云何得此功德。佛言。绝诸名色尽诸欲垢。斯等疾逮无量功德。当疾远离女人之身。当得具受男子之形。求为女者所生之处续受女人之身。都悉污秽一切世界。是故当弃女人之身。当得无比诸善知识。功德日生。亦自受福。复利他人多所饶益。一切男女于众苦中疾得拔济。譬若毒树所在之处蔓莚生长多所伤害。若能断截诸毒树者。尔使一切普得快乐。女人之身譬若毒树。增长诸欲毒害精神。广诸恶行受无量苦皆由女人。若能断弃女人身者。则为断绝众生无量诸苦。坏众恶行闭绝三涂开泥洹门。普使一切而得快乐。斯等疾入诸佛径路。迦叶白佛。云何得除女人之身。佛言。当自观身观他人身。解此二事俱不可得。不可得中无有径路。若于男子及女人中。观其处所。男女相貌亦不可得。若了二事亦不可得无处所者。当于其中愿得清净。若以清净则无取舍。以无取舍便无识心。谛推觅之亦不可得无有处所。意自思惟。无处所中为求男子成女人乎。谛求索之意不可得。若解意性了无男女不可见者。尔乃得近如来之道。其欲发心疾欲除去女人之身。谛观男子女人之身。了无异同增减之二。当受女人作女人形。如其所说以理推之。六性分中亦不可得有男有女。其如是者则为求索如来之道。其欲求解如此事者。复有谛了知此法者。是二辈人过去佛时。曾得闻此诸佛名号。当知其人过去世时。于诸佛所造大功德。今乃闻此诸佛名号。世所依仰为自在者。其奉持此诸尊号者获无量福。其有闻者若有学者。我普见之有欲急求。得此经者斯等已为见我无异。若有轻慢其人说言此非佛语。作是言者此等便为谤佛毁经。谤斯经已为造大恶。缘此恶行当入地狱。受众苦报无央数劫。地狱罪毕所生之处。常当聋哑不能言语。诸情闭塞常不完具。常当愚痴而有癫狂。其有娆固诸菩萨者。薄德丑陋言无威势。常生下贱常生恶道。所生之处常不闻法。如来正觉所说经法。终不能解说深妙义。愚痴之人与经共诤广受罪报。增益其意毁斯经法。此众生辈生常愚痴。诸佛正觉常为世间而作大明。我重殷勤诫嘱汝等。诸比丘及比丘尼清信士清信女。其有谤毁骂经法者实受重罪。诸佛世尊现在十方。无量世界为作法师。所说经法实难得闻。如来慈愍重诫汝等。若有信乐诸佛名号功德法者。于诸善法自然合偶。其有学持讽诵念者。其人疾得见诸如来。智慧转增得无碍慧。其有劝人读诸佛名。所生之处。游四方域。独言只步而无所畏。其有好乐尽心敬奉此诸佛名。当知其人去正觉道终不复远。其有好喜诸佛功德。加益劝人学斯佛名。其人所在于诸如来所游行处。于诸欲中无所畏难。当知迦叶。若有比丘具四事法。乃能信此诸佛尊名。何等为四。过去世时于诸佛所。得闻深法喜乐静寞清净之处。世世值遇诸善知识。不于法中作危难行。当知迦叶。是为四事。若有比丘以能具此。于诸如来正觉法中而无疑难。其人得闻如来功德。尔乃一心能信乐之。于是世尊。而叹颂曰

  过去供养诸佛尊　　缘此功德其闻名
  最后恶世其闻者　　普用是号增众德
  其有过去见诸佛　　得闻如来深妙义
  往世净德不诤法　　斯辈乃能信奉行
  若使得闻深妙法　　说诸若干微妙义
  斯辈终不起狐疑　　佛之深法无能毁
  安住所说诸法义　　以思集意信普智
  坚固其意听我说　　念莫忘失此尊法
  终不复更与法诤　　闻诸佛名能奉行
  有念无念不相豫　　于其法中无差特
  不可思议极广大　　终无犹豫于大智
  其求此法深慧者　　解达深义无咨启
  无疑勤求诸深法　　此等不喜下劣业
  当知此人无所求　　极大勇猛于法中
  佛所说法莫不信　　其有众生于先世
  合偶众善受福报　　无所违诤乃得闻
  显诸如来大智德　　皆为赞叹十方佛
  其有讽持诸名者　　诸佛遥赞其人德
  于大众中叹其名　　常当得闻诸佛声
  疾能解了大智法　　极大清净无生业
  放大光明超日月　　广为众生演妙法
  后会当成最正觉　　普悉照耀诸佛刹

复次迦叶。上方有世界名曰宝月。其国有佛。号金宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有世界名象步楼。其国有佛。号无量尊丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名天玉女。其国有佛。号无量尊离垢王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名须弥幡。其国有佛。号曰德手如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名尊聚鲜意。其国有佛。号无数精进兴丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰无受。其国有佛。号无言胜如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名净观庄严。其国有佛。号无愚丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐。度人无量。今现在说法

复次迦叶。上方有刹名曰日光。其国有佛。号月英丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰说法。其国有佛。号无量光丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法。

复次迦叶。上方有刹名宝丰首尽。其国有佛。号逆空光明如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰好集。其国有佛。号最清净无量幡如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰殊胜。其国有佛。号好谛住唯王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名生精进。其国有佛。号成就一切诸利丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰愿力。其国有佛。号净慧德丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名娱乐入。其国有佛。号净轮幡如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名栴檀香。其国有佛。号琉璃光最丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名曰星宿。其国有佛。号宝德步如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名无量德丰。其国有佛。号最清净德宝住如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹。名曰声所不至。其国有佛。号度宝光明塔如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法

复次迦叶。上方有刹名无际眼。其国有佛。号无量惭愧金最丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。今现在说法。于是世尊。而叹颂曰

  德如月满其如来　　诸天最上为尊雄
  此诸大尊德中王　　能为众生除诸殃
  持诸佛名功德成　　能净诸刹为肃清
  其难得值此尊经　　少有众生闻其名
  若有信行而供养　　得大智慧勇力强
  解了诸法无有量　　当成一切正觉王
  正觉之法甚深微　　不当于中起狐疑
  当善信奉诸导师　　欢喜敬礼慎莫疑

复次迦叶。上方有刹名宝莲花庄严。其国有佛号莲花尊丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻莲花尊丰如来名者。三恶之道为已闭塞。为已得成如来之花。于诸正觉一切法中。便为得成无上道花。却生死罪三十六劫。于是世尊。而叹颂曰

  上方有刹宝庄严　　众花茂盛普大千
  光色晃昱甚可观　　譬如天上难檀桓
  莲花尊佛在其刹　　说法无比慧通达
  光普照耀大千界　　众相端严圣中最
  若有女人闻其名　　断绝恶道遭诸圣
  却三十劫生死罪　　必成正觉不退转
  不见身哃道清净　　世世智慧功德成
  缘念诸佛得善友　　怨家消灭除罪苦
  当普礼此是诸佛　　今悉现在于异刹
  其人快当受供养　　用礼诸佛大法王
  此等不当疑我言　　必当成佛德无边
  常当共诸妙法会　　后成正觉慧独达

复次迦叶。上方有刹名曰宝镫。其国有佛。号净宝兴丰如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻净宝兴丰如来名者。欢喜信乐持讽诵念。其人得七觉意宝。却三十劫生死之罪。于是世尊。而叹颂曰

  上方有界号宝明　　净宝最尊在其刹
  其有得闻名号者　　斯等当得七觉禅
  三十大劫生死苦　　超越过去无因缘
  得无比力住不动　　常当遭值诸天尊

复次迦叶。上方有刹名曰电光。其国有佛。号电镫幡王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻电镫幡王如来名者。欢喜信乐持讽诵念。斯其人等悉当远离八难之处。终不复生下劣之家。于是世尊。而叹颂曰

  上方有界名电光　　大尊号曰电镫王
  其有闻此快士名　　八难永断不复生
  智慧解了生死根　　种种功德随次成
  兴隆道化度众生　　智慧独达无比圣

复次迦叶。上方有刹名虚空致。其国有佛。号法空镫如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻法空镫如来名者。欢喜信乐持讽诵念。却六十劫生死之罪。得不退转于最正觉。常得与诸佛共会。现世得见其佛世尊。亦于梦中见此如来。当知迦叶。其人今世五体投地一心恭敬向于如来。其人则种无量功德。诸善根栽悉得具满。常当得值诸善知识。常与诸人共相敬爱。如是迦叶。是为现世获诸善报。其佛如来一切功德普集如是。于是世尊。而叹颂曰

  有虚空致大世界　　其佛号曰法空镫
  名称普达其世尊　　光明极大踰虚空
  其有得闻此尊名　　超六十劫生死罪
  必当遭值见诸佛　　于如来前讲妙法
  精进现世见诸佛　　当五体礼其如来
  梦中得见其世尊　　其佛导师光围绕
  念其如来致斯德　　常当得见诸大哀
  生常得值诸法王　　其人现世见诸佛
  其佛导师德无量　　智慧普达为法王
  其有勤求众德者　　尽心敬意礼其佛

复次迦叶。上方有刹名审谛分。其国有佛。号一切众德成如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。何故此界名审谛分。当知迦叶。其彼世界皆为八分。众花分。栴檀树分。金多罗树宝致分。其佛刹土出众名香遍其世界。于彼刹土在虚空中。成为香盖普覆佛刹。其佛如来趣于法座庄严大会。其有得闻一切众德成如来名者。六情端政常得清净。解了诸佛妙法之分。却八十劫生死之罪。于是世尊。而叹颂曰

  审谛世界有八种　　多罗宝树香庄严
  出妙名香遍其刹　　普覆虚空香云盖
  大智正觉在其刹　　名声普达号众德
  色像端严妙甚姝　　法王独步无畏惧
  其有得闻此尊名　　端正奇妙功德成
  节解圆满而方正　　视之无厌莫不敬
  功德极尊无与等　　欢喜踊跃游诸刹
  精进勇猛甚超越　　却八十劫生死罪
  于正觉道终不转　　广能演说佛尊法
  逮得一切诸快乐　　后生之处常尊贵
  逮得清净无差特　　思念如来众功德
  思惟智慧诸法义　　增进功德成诸智

复次迦叶。上方有刹名日月英。其国有佛。号贤幡幢王如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其有得闻贤幡幢王如来名者。欢喜信乐持讽诵念。其人当得立不退转成最正觉。却五十劫生死之罪。于是世尊。而叹颂曰

  上方界名日月英　　其佛号曰贤幢王
  法王大仙在其刹　　相好盛明如满月
  其有得闻此尊名　　游生死路诸根明
  于诸法中常增长　　审谛得住如来种
  至心念佛而敬礼　　却五十劫生死罪

复次迦叶。上方有刹名曰宝种。其国有佛。号一切宝致色持如来至真等正觉明行成为善逝世间解无上士道法御天人师号曰众祐度人无量。其刹何故名曰宝种。当知迦叶。其佛世界一切众生。悉求无上正真之道。其国菩萨神足勇猛。无数菩萨俱共同时如弹指顷。以神足力飞到十方。供养无量恒沙诸佛。悉皆周遍悉能成就一切众生。说是诸佛功德处时。若有闻者则为到此诸佛国已。谁能发起大精进行。有菩萨摩诃萨。其有捉持此名号者其名曰师子戏菩萨。师子奋迅菩萨。师子幡菩萨。师子作菩萨。坚勇精进菩萨。击金刚慧菩萨。其有得闻一切宝致色持如来名号及诸菩萨大士名者。皆悉当得如来十力十八不共特异之法。常能转于不退法轮。却六百劫生死之罪。于是世尊。而叹颂曰

  我今已说诸法王　　今悉现在康常者
  无师自觉大导师　　得泥洹乐为最尊
  如来名号性清净　　诸法威仪行清净
  其有最后闻诸名　　兴大欢喜怀恭敬
  不当狐疑于如来　　至诚奉信莫言无
  汝当知是舍利弗　　斯等先世已供我
  若有供养于诸佛　　其人最后恐怖世
  得闻此等诸尊经　　一心信乐无疑生
  诸佛大智所游路　　无此最上慧通达
  于是法中多所成　　云何于中疑此经
  若值妙珠无疑宝　　愚者不识嫌不好
  贫者犹豫意未了　　既无重价致此宝
  是法出生等正觉　　此皆大士之所闻
  智慧浅者无慧眼　　斯等何从而能信
  其有富者积众宝　　闻如意珠大欢喜
  叹誉甚多益众宝　　我当买取自庄严
  其有福慧合聚者　　闻诸佛名大欢喜
  郑重赞叹欲得闻　　得正觉珠自庄严
  行恶之法求恶者　　其有谀谄及反戾
  福德智慧薄少者　　终不堪任闻此法
  短促倒覆及愚痴　　悭吝甚多成秽意
  贪淫嗔恚惑乱者　　此辈不任闻此法
  学鲜懈慢憍自轻　　弊恶亲友意未成
  真卷自举外如清　　斯众不任闻此经
  无数天人时唱言　　巍巍正觉无上尊
  快哉妙法甚难闻　　当听无比道之珍
  闻诸如来名号中　　所得盈利叵数陈
  诸天在上虚空中　　而散花香鼓乐音
  诸天妙香而遍熏　　大千世界结香云
  光明普照诸十方　　一切刹土六反震

尔时世尊。说诸如来名号之时。诸在会者悉于座上。遥见此等诸佛世尊。各在其国大众之中而说经法。悉从坐起礼诸世尊。莫不欢喜踊跃无量。于时会中无数千人已有得道未得道者悉发无上正真道意。十方世界诸菩萨等各如恒沙。皆来诣此礼释迦文。于其会中一亿比丘得阿罗汉。比丘比丘尼复有十万人得法眼净。复有十万人悉得法忍。五百优婆塞。四百优婆夷。同时从坐起整衣服供养如来。尽发无上正真道意。于是舍利弗长跪叉手前白佛言。此名何经。云何奉持。佛言此经名曰称扬诸佛功德法品。亦复名曰集诸佛花。当奉行之

尔时世尊说此经竟。舍利弗及诸比丘。诸天人民龙阿须伦。一切大会皆大欢喜。前为佛作礼而去

佛说称扬诸佛功德经卷下

  巍巍十方佛　　国土甚清明
  七宝为庄严　　妙香栴檀馨
  悉纯诸菩萨　　无有二乘名
  惟说不退转　　般若道之英

  巍巍十方佛　　三世道之珍
  其闻信乐者　　疾成无上真
  游于菩萨道　　坚住不退还
  所生常见佛　　遭值诸天尊

  巍巍十方佛　　三界之导师
  至心怀恭敬　　信乐无狐疑
  所生常端正　　颜容甚花晖
  辩才慧独达　　愿礼天人师

麟嘉六年六月二十日。于龟兹国金华祠。演出此经。译梵音为晋言。昙摩跋檀者。通阿毗昙。畅诸经义。又加究尽摩诃衍事。辩说深法。于龟兹国博解第一。林即请命出此经。檀手自执梵本。衍为龟兹语经。当如是时。道俗欢喜。叹未曾有。竞共讽诵。美其功德。沙门慧海者。通龟兹语。善解晋音。林复命使译龟兹语为晋音。林自笔受。章句鄙拙。为辞不雅。贵存本而已。其闻此经。欢喜信乐。一心恭敬。受持讽诵诸佛名字。兴显赞扬如来功德。广加宜传。得不退转。疾成无上正真之道。无数天魔。不能毁坏无上道心。所生之处。严净佛刹。常得值遇诸佛世尊。端正殊妙。颜容光泽。常能解了无量智慧。得无碍辩。常为众生。阐扬大法。于大众中。最为上首。后成佛时。刹土清净。于诸佛国。最尊第一。愿使十方无量众生。普令讽持。解了如来无碍之慧。功德巍巍。亦当如此诸佛世尊

称扬诸佛功德经卷下


佛说成具光明定意经

    No. 630

佛说成具光明定意经

        后汉天竺三藏支曜译

闻如是。一时佛在迦维罗卫国精舍中止。晨朝整服呼语阿难。汝请诸明士除恶众及无著履迹等来。今日当有上问异要。于是阿难受敕。应时遍宣如来教于四辈人。时有除恶无著履迹众。凡五千万人诣如来所。稽首于地毕而避住。复有贤女弃恶众及国中凡女人随诸贤女人。十四万众诣如来所。稽首于地退座而坐。复有明士八十亿万二千人诣如来所。稽首于地俨然恭住。复有文士居家修戒者。四万人相随来至。稽首于地毕各却住。佛以威神感动十方诸佛国。明士及上诸天应当成者及当发者。凡八百亿万人皆飞来至佛所。稽首于地列住空中。复有十二天神将军。将诸官属四十万人来诣佛所。稽首于地毕各分部住。佛左右立侍所当是日会时如一食顷悉至佛所佛即令坐。其有肉体未得四神足者。应皆就榻。十方诸来明士及诸天神身轻。或已得神足者皆踊在空中坐自然座。各各有化花盖。行列奇好。皆佛威变之所兴化也。诸来明士在会坐者率皆妙行。心清口净身服众戒。三秽六患五蔽已索。众烦热恼。杂垢沷若。疑网闭结。倒见之谬。不知之本。十二牵连皆已绝弃。净如月花。各随世习俗。依行立字

有明士名无秽王。次复名光景尊。次复名智如山弘。次复名大花净。次复名转根香。次复名月精曜。次复名光之英。次复名整不法。次复名善中善。次复名昆仑光。次复名日光精。次复名师子威。次复名意杂宝。次复名炎炽妙。次复名德普洽。次复名普调敏。次复名敬端行。次复名慈仁署。次复名慧作。次复名散结。次复名严仪具足。次复名高远行。次复名光德王。次复名护世。次复名导世。次复名大力。次复名正净。次复名天师。次复名善观。次复名观音。如是众名各各别异

于时有贵姓子。名曰善明。从同辈五百。人人各有侍者。执盖相随来诣佛所。稽首如来足下。起住观众四面甚盛。仰视空中率皆上人。天尊在座端严直立。兴心念言。今日大福遇此众会。欲设饮食以供一日。计身所有不能供办。施不等接则非施也。我将如何。于是佛知善明所念。则劳之曰。少年善来。宁闻法劝之说乎。曰未达也。起时则起可谓智矣。不计少多有所希望。可谓施矣。向所念者如来在此何患不办。如来能使不办者办。不足者足。一切常足所作常办。是谓如来。如来办者。不用衣食欲乐之物。乃以具戒。不听六患五蔽之惑。不惟家乐。不有四食之想。亦无衣容冠帻之饰。处计常之中而知无常之谛。居惑乐之地则觉必苦之对。贪有之室照空无之本。于受有之体明非身之真。无我无作无缘无著。斯如来之办也。于是善明闻天尊说。心悦结解身轻踊跃曰。我本无黠连缚十二。心起就冥堕俗三流。今日所闻未曾有法。愿身受持如天尊教咸乐妙法。因而叹曰

  天人之尊　　如来为上　　慈哀劝救
  等施三界　　劣漏贫行　　摄以法财
  令一切惑　　解释无疑　　身尊具贵
  相好无双　　出意为人　　演法无穷
  睿慧众流　　注如山洋　　法泽三界
  流衍十方　　大人相满　　宝慧具足
  在在现法　　将导不逮　　慧照愚冥
  牵致净处　　愿身自归　　得到彼岸

于是善明叹毕。更前长跪启天尊曰。愿卒本意。今日设馔。唯乞加哀抂屈临眄。天尊默然自如常法。善明恭立谓未见听。于是阿难开语之曰。天尊默然为己相许。善明闻之心则逸豫。稽首而出住于门外。遣人入白言。今自计所有。可供二千人饭。愿启天尊令知如此。阿难即白佛具宣善明所言。佛告阿难。汝语善明。使还供设尽汝所有。佛当与大众一切皆往。勿嫌不办。阿难即出具语善明如佛教言。阿难又曰。贤者便还。莫起二意畏有不足。佛神所至无有不具。善明即前礼阿难而还。还舍敕其妻子室内大小言。今所请者号曰天尊。神妙通达为一切智。其以一物施是人者。世世受福而无穷极。又能度人解于索结。汝等恭肃净施饭食。具设众味当令绝美。眷属从使各尽心极意。天尊难遇亿劫时有。其所当为善令清净。于时座中有明士。名力办众有。佛告令行。共佐善明供此大众。于时十二天神王。及四天王大势龙王。承佛告教。皆从力办众有明士往而佐之。到则劳徕语善明曰。贤者勤心。佛使我等来相营助。善明则前礼明士及诸天王。敬意辞谢言。劳屈上人。今已办二千人具。大众当来惧是小舍。其将奈何。于是力办众有明士。及诸天神王。答言莫忧。因各左右顾视。屋室自然长广高大像天之殿。于屋下。便有千亿万座。皆是众宝变地之形。绀琉璃色。室中床座亦复如是。如弹指顷。即有百千亿万人饭具。而皆足毕。烧众名香悬诸缯幡。其所行道即便广平。色如水精。树木行伍。自然音乐。雅声相和甚悲。说法之音释梵八种。于时力办众有明士。诸天神王。即还佛所。善明见此大变。惊喜踊跃来诣天尊白言。受佛大慈。所设已具。唯愿举众抂屈尊神。佛即令无秽王明士等六百万人在于前导。或行虚空。佛处中央其余从后。如来出门地则肃震。诸天散花烧众名香。乃作上乐歌颂而从。到皆就座。诸天神王即助施饭。佛口咒愿食已。饱足饭不消[歹*斯]。众器饭具满则如故。善明心独而言。天尊威变弘广乃尔。食讫行盥当问此意。水盥已毕。如伸臂顷。佛与大众恍惚而还在精舍坐。于是善明因复叹曰

  天尊实神妙　　世所希见闻
  变改卓荦异　　睹者莫不欣
  谛观甚奇雅　　现变难等双
  不作而自具　　不劳饱满众
  不语自然使　　不教令自行
  不为而遇为　　是德以可将
  本行何术法　　生而有此荣
  积何德之本　　致斯巍巍尊
  愿哀贫道者　　开饶以法财
  决心之结网　　放令无余疑

善明叹已。更避坐叉手启言。我所居止去是不远。聚名福安。佛向所哀顾处是也。我在其聚常好学问。学世威仪古王之制。及学神仙圣人之法。始闻天尊近在此国。兴意想像梦辄仿佛。天尊弟子名舍利弗。常到我舍为我说法。法甚深妙我所希闻。心虽欣叹犹怀瞢瞢。今日轻来礼佛天尊并观道法。所当则行至见。心悦如冥睹光。意欲设饭因获异问。所有劣少未敢发言。天尊神通迎知我心。道力助我。床座食馔忽然而办。食毕器具满则如故。此何变化神妙乃尔。又观天尊三十二相。相相有好视之无厌。行则庠序不迟不疾。坐则中坐不前不却。语声八种不缓不急。言成法律明诫如日。令一切众咸受恩福。本作何行生而有此。又见天尊足不履地。相轮昺列端严如画。身空体轻在所变现。此皆何行于世有是。愿垂解了令知本末。于是佛言。善哉善哉。如尔所问。如来当具演之。整心整意咸受莫忘。善明则曰受教。佛言。我本先行六德之行。世世不废。是以至于得佛。恣意变化在所作为。为一切智无物不达也。则曰。何谓六德之行。曰广施。广戒。广忍。广精进。广一心。广智慧。善明白佛。何谓广施。佛言。为道者。先当知身非常真物四大所成。骨肉不净皆当弃捐。还归其本不得常住。身不我有财物非我许。心无有形了无常名。为缘缘行缚。所以有身行。身无有常。亦当空朽。以计如此则立四信。内身外身天地万物皆无常住。当归坏败弃散消融。此信已立则观体非体。观物非物。便能恣施饱满于人。又而法施牵化愚曚。故曰广施。何谓广戒。曰广戒者。谓能摄身之三殃。守口之四过。捡意之三恶。身行者。若见一切众生蚑行蠕动。愍而哀伤纵而活之。随其水陆还而安之。若见众宝珍琦柔软细滑可意之物。虽身贫苦。内伏其心。不令贪取。及见细色脂粉之饰。则内观朽烂脓血之臭。斯身之三戒。口行者。谓彼若以四过加己。则而觉知口之失也。报以善言和语。至诚不饰。答而化之。使反从己。斯口之四戒矣。意行者。则心习智慧思惟生死。常住慧处不惑流淟。又深人道品空无之要。别了真喭而无疑难。见善则劝成则代喜。斯意之三戒。故行道之始。先于十戒既能自为。又化他人勤而不懈。行而不休。都无懈惓之想。故曰广戒也。何谓广忍。曰广忍者。若人骂我。计从声出音来。到此观了无形本音所来。出于心意。观于心意亦复无形。察心所猗猗于四大。四大还本则亦无名。亦非彼我亦非男女。亦非老少。计了无主。惭辱所在无形立字。于两无之中又亦无形。计此三者空无所有。智者散意观虑。如此则嗔恚不生。以空忍空。又于众恶忍而不为。对来不起。捡心伏意。身自能尔。又诲他人。此谓广忍也。何谓广精进。减于多食不味于味。除于睡卧惊意晨夜。远俗近道行于众戒。坐起之法。不失其仪。无犯之行。当习于心道品之要。汲汲乐诵。昼则勤受夜则经行。语则应律。身口意并从猗忆法不离经文。坐而广说意不以烦。开教愚顽不以懈劳。违心反意自逮专精。身既自能又诲他人。斯谓广精进。何谓广一心。孝事父母则一其心。尊敬师友而一其心。断爱远俗而一其心。入三十七品而一其心。空闲寂寞而一其心。在众烦乱而一其心。多欲多诤多作多恼。于是之处而一其心。褒讪利失善恶之事。于是不摇而一其心。数息入禅舍六就净而一其心。身自能行复教他人。此谓广一心也。何谓广智慧。曰明士随于受身。则有三痛六患五蔽之垢。六十二沉吟之想。八十八难解之缚。千八百锋疮之痛。若此之事。则以智慧一一开了。观其所起察其所灭。视其所病选以何药。既总其要令身不毁戒。意不入俗处众爱之中心在道品之藏。寄六患之舍心在六净之堂。住五蔽之室心在断灭之户。猗不固之屋心思方便之护。坐蛇蚖之地心念舍远之径。乘坏船之崄心图自济之路。近盛火之林心推灌灭之安。是以明士。行智慧之便拔出生死之难。绝三界之想就灭度之地。既自身行又教他人。此谓广智慧六德之行义也。向所问如来神变相好无量之德。所以致之。行此六法及诸慧定三十七品总持无边底之行故。得佛号天尊。无所不能为也。于是善明及众会。闻天尊说。则皆举言。愿发无上独尊平等之意。皆言今日得大福。令一切人疾逮此行。善明。时则得四净法。一为眼净。二为身净。三为口净。四为意净。欣然低头默思法义。于是善明。避坐长跪启如来曰。天尊所说广度无极。法禁微妙捡摄意态。伏心就净殃垢消灭。其闻此者功德已大。况乃履行德难称量。天尊又说。前世非但行此六事而已。又行定意之法及总持无底边三十七品。乃成具佛事四无所畏十种力十八神妙特异之法。变化自在所说无难。而面见诸佛。飞到十方。而授一切诸未度者。率化度之。而坏邪藏将导曲邪。而生受苦之中。不着不断。以不着不断。作因缘行。教诸惑者如此之妙德无央数事。行何等定意。致得之乎。唯愿天尊。为今现在及未来者。演其深义。令获解脱。佛言。善哉善哉。所欲问者。今为分别具敷大要。整意善听。则曰受教。佛言。有定意法。名成具光明。其有人闻之者。若能履行一日至七日。其功德福不可譬喻。其闻是法者。先世已供养百千亿佛已。于其坐具闻不疑。今生乃复值遇是成具光明定意法。今得修行行之。如弹指顷。长离三恶道。功德渐满疾逮至佛。向所问诸事悉能成具。善明曰。当行几事而得此尊定。佛言。当净行百三十五事。乃得入此定耳

远身行。离口过。除意念。尽三秽。却六患。遏五蔽。十二因缘已捐尽解结束明六十二沉吟行。愈众疮。悦众恼。舍诸大。弃骨血。避亲属。绝诸习。断于爱。无诸可。无不可。刬贪垢。刈欲根。不惑流。能制疾。不我计。无不我。立四信。住四止。就四断。插五根。习五力。晓七智。履八正。入八念。八常勤为已无。勤可行。离不可行。学上智。自尊意。不贡高。而濡软。雨法雨。如一法不两计。不三想。不为无益想。无有际想。不空想。不想想。想无处。不住无处想。善惟佛。知佛净。已知净。而善学。心正住。不邪还。等善恶。如明冥。于明冥知俱空。不疑法。不以有净无。观有无本为一。已知一而除一。不于一而起想。勤受教。善习行。因习行。入无际。习胜意。不听心。善防识不乱转。往来三而不着。察诸性了无根。知无根不可满。以不满而自整。缕观法为同无。常住无绝无想。常无常以过上。不念人。不宥世。不着物。罢舍求。法合离了无见。身生殁皆由化。上中下知法等。于是世往后世。观二因如虚空。心无欲而常仁。行清白善诱人。知人向为反浊。于反浊而清澄。心远爱筋入火。以净火烧众垢。已尽垢寂然净。不念善。不念恶。不惟好。不惟丑。不念苦。不念乐。于毁誉。无欢怒。心调净所在入。开大藏。入大法。以道律护满法。苦习审勤承行。以尽道为光曜。视一切性识起。流结冥意思止。勤求止以入道。剪三爱。除四失。增四城。离五覆。绝六慢。修六敬。具六法证。行七慧。强八力。拔九结。习九灭。十弘净为已能。十力慧已备足。十直法不复学。慧法种而常存。于三宝已能备。以法施无极尽。于诸专能备行。入无所著。入空无懈。却无吾念。无我想。无人计。无筹算。寂如灭度

是为百三十五事成具光明定意戒法之行。佛说是成具光明定意戒法品时。三十万明士。得是定意功德成具。立于第十之地。善明。则得无所从生法忍。五百同辈人。心欣意悦。皆发无上独尊平等觉意。四十万明士。皆立不回还行。除恶众五万人。皆得无所著道。持五戒贤士贤女二千人。皆得履迹之行。诸天在虚空中。而作音乐。叹曰快哉世人乃获上闻之要。其在愚曚埃浊者。今日[火*霍]然除尽。如净水洗浴垢。今闻大法心垢为消。愿令法轮常转。使一切疾逮妙慧。我等常遇天尊所生不离。疾得是成具光明定意。当广宣法恩。还照流冥。如今日大会。兴立无数道本。善明白佛言。今闻天尊是定意。净心自思观。我无黠慧心了不知处。于外于内俱亦如是。佛告善明。譬犹冥室执炬而入。则莫知冥之所在。是定意法其能履行道品成具。则不知无黠十二牵连之所失也。善明。非但是而已。则不见十方生死起灭之处也。至履迹无著因缘觉佛乃至如来皆无见有所想见非见也。无所想。一切清净想。止清净想。亦不止清净想。是为空见无所见

善明白天尊。云何不止清净想是为空见。当是时。心在何许。所见何等。佛言。善明。于是时心不在内不处外。不于道不于俗。不于有不于无。不于起不于灭。不于动摇处也。是心无根际无音响。本末了索。当如是见。是见为见。为空为灭。为都无所有定意之法。以此为见。明士当作是计念。除念就净。作是计念者。为应成具光明定意之教法也。是法无所有法故。强为其名。明士闻是。莫怪莫疑。谛而思惟其法。不退不懈。斯为已得定意威神之护力也。善明。其欲学此者。当行四事。稍入无见处。曰何谓四也。一不有身。二不有居三不有世。四不有物。以能如此者。则得入四要。曰何谓四要。曰一为佛要。二为法要。三为空要。四为灭要。此谓四要也。佛时叹曰

  无彼无我想　　亦不无黠计
  十二因不着　　是应成具足
  是定法本无　　非有住立处
  哀世现其名　　空行亦合仪
  人心并意识　　此三为起法
  行是成具足　　无起无所灭
  空为成具地　　生死苦断离
  一切无余迹　　是合定意行
  世人转相猗　　邪见著名法
  贪有利常想　　缠缚无数世
  积行常缀碍　　忧恼着意戚
  四变如随影　　往来无休息
  行定无所猗　　正观不著名
  贪尽想得灭　　解缚清净安
  净行不挂惑　　惑恼意了无
  生老病已绝　　无复往来忧
  慧眼明已大　　智本无边底
  黠使度无极　　行定乃致此
  世火星月明　　日曜昆仑光
  释梵殿所照　　是定明过上

佛告善明。乃往昔无数劫时。有佛名尊伏欲王。时佛住世寿十万岁。不在是南天竺止。自于今北方净耀天归佛所住处是也。彼国去是。三亿万佛土乃得之。尊伏欲王佛时。人寿二万岁。常可自从弟子六十万人。明士众不可计。国民炽盛丰饶宁静。率皆贤行戒德相嵯。欲贪三垢薄而[歹*斯]。时佛大会十方明士。普受持说是成具光明定意。便而成具佛事。在于四署之一数。是时有长者子名敏见。年五百岁。时国人以为少年。敏见。闻佛大会则启二亲。乞行诣佛观其所作。父母听行即往见佛。稽首于地礼竟正住。喜心兴盛。便脱身珍琦杂宝璎珞。散于佛上。以佛神威。应时所散化成花盖。到覆大众。人人各别佛令就坐。为说是成具光明定意法。心又增欣。则时愿言。令我所生常遇是成具光明定意。疾能履行无亏减于戒德。是时少年。以一切宝施与。发一言之至愿。以是故。所生世辄得受。善明。宁知彼时少年不乎。则尔身是也。今我出世。汝复遇值定意。于今以后必得不久。得慧之后。二百劫当具成佛。号导世王天上天下之独尊。当化导愚冥如我今也。善明。闻佛授其封拜之名。则心净体轻。譬如琉璃水精中外洁净一切无秽。以所置处处并后净其心。若斯则时得十憺然法。一者憺然不以所见为动。二者于诸烦劳之事。憺然常足。三者于众想憺然不想。四者流俗所乐汲汲之事。憺然而饱舍。五者于德不德憺然不念求。不念否。六者善法恶法。憺然不着。七者谦者贤者。憺然不望荣。八者敬养舍弃。憺然无欢怒。九者一切如法失法。憺然同其原。十者以入净寂若处不净。能以法化。憺然无著别。无厌舍之念。心以如此。因白言。天尊。今授封拜之要于我。当报恩宣开一切。令未闻者闻。未知者知。未度者度之。我生死常多。虽多虽久不以为劳。已不着。已觉。已能整。已为不惑。已能入其被服。随因缘而示见之。我不已生死为生死也。我受佛威神已悉俱了我有等率五百人。愿天尊加四等之大慈。勉引入法。令疾解是成具光明定意。于是佛笑。皆见光从口出。五色炜晔明接十方。其在痛者一时得安。还从顶入自如常辉。侍者阿难。整服避坐。叉手启曰。佛未尝虚欣笑。笑必有故。唯愿敷演散告未闻。于是阿难。则而叹曰

  面部人雄颜　　眼鼻口正端
  金体极软细　　今笑何盛欣
  方口含白齿　　唇像朱火明
  姿美八十种　　今笑必有因
  镜齿牙四十　　广舌颊车方
  语则香气发　　今笑为谁成
  眉髭绀青色　　眼睑双部当
  白毫天中立　　今笑唯愿闻
  天眼已了朗　　道眼已备通
  法眼与慧眼　　此四已具成
  笑必有感应　　启化于未成
  或当受拜决　　故笑发金颜

佛语阿难。佛真不妄笑也。今善明所从五百贤士。前世已供养二百亿佛。已于其坐。闻是成具光明慧中百三十五行。自从初闻历世踰多。然常刚猛适在小善之数。未能伏心受持清净最妙定行。虽尔以闻之功德。所生不在三恶处。常遇值是尊定之法。今日来会净心听受。稍稍解释开入正谛。后慈仁佛立。当于彼时得是成具光明定意。却后三十六万亿劫。皆成为佛。当复以是法教化。所领国土各各有号有名。幢节布耀王。次名大光遍显。次名大势伏恶。次名猛盛威德。次名流水净音。次名高德普接。次名景现除结。次名化幻自在。名各各如此。于是五百贤士闻所受决。欣悦踊跃。则得五无转心。一者祠祀求福心不转为。二者一切五味可否。皆是众生之神命。终不转为害生可口。三者正立于无上独尊之行。终不转动舍就小道。四者知是法尊无有与等者。勤心修行。虽有他法杂异之虚而己。法心观别终不转为。五者正使世有佛无佛法兴法衰有终有绝。心在定意。不以无此三宝故转为邪业。是为五无转心。已得是心法义。皆前长跪白天尊曰。佛哀我等。告其封拜成佛之名。我等当报恩。后若所生弊恶之世。当勤修正行。奉宣尊法。开化未知乱者正之。懈者勤之。却者勉之。倾者扶之。缺惧者补完之。冥者照之。结者解之。杀者为说夭逝之殃。盗者为说贫乞之苦。淫者为说身之祸。谗佞欺者为说灭性之患。醉乱者为说危身之变。我等今日并于佛前。誓立五愿。作明士行乃至成佛。行之无休已愿佛哀于我等。听我等所言。第一之愿者。我作明士行。疾令身而变化周流十方。若世无佛。四辈弟子或有知法者。言信实有佛但灭度耳。俗人邪见疑网生。不见佛有不知法。便言无佛但虚妄耳。若审有佛。何不见其威神乎。两诤如此。当于诤时。我便当往化。现佛身相好照明。又化威神。于是两诤人前令见知谛有佛。并谓曰汝莫疑也。是疑人即当惊喜。因为说法教度脱之已便化去。如是无极。第二之愿者。佛有大妙极深无量法门十二部要。佛灭度后。弟子各学一经。偏见一卷不能遍洽。未解四说方便之等。便转相难。或言虚惑言有。言是义当尔是不当尔。真知法义者言辞相貌。不晓义者。贪于名字。饰相貌状。如解达便于众会。两诤兴恚舍善就恶。当是诤时。我当往现身变化。有踰于众。令众肃然。便为断说。是别正者。牵经开语。令俱欢喜已便化去。如是无极。第三之愿者。佛灭度后。俗人外智之士。入佛弟子大众中。弟子论说法义言及众道分邪别正差品高下。便言是道九十六种之中佛为尊耶。有四神足飞行变化。天上天下无如佛智者。俗智之士生不睹佛。习于邪见信小毁大。便语佛弟子言。汝莫妄说云佛神足飞行变化。先古以来人之品类无有此也。诚不实言。当此之时我便化作佛身相。示诸种好。现于神足。经行空中。身出火水。令诸俗人外智之士肃然而惊。乃知威神之化。以为说法。授以正戒毕乃化去。如是无极。第四之愿者。若人读诵佛经。独在野室若在山间。或于大国尊姓长者及与人民无有师法。或师不明顽无所问心用疑网。我化作道人。被服往到其所。句句为解本末分了疑意权开。令入微妙而无疑难已便化去。如是无极。第五之愿者。所生国处常遇见佛。佛灭度后弟子立庙图像佛形。并设讲堂论义经法。若俗之人。开学小慧缚在四倒。闻佛弟子说度世法生死之要。便往难却。不谅真正。谤讪啤呰。贪名求胜。或加悁恚。欲往坏败。陵訾毁蔑卑易弱之。弊于正道令不得行。当尔之时。我便当化现佛身。更为说绝妙之法。现其生死殃福之应。将诣天上令观福舍。牵到泥梨使视罪报。法威以震之。智力以伏之。令即降伏信就大道已便化去。如是无极。我作明士乃至成佛。常当行此五愿无有休息。愿天尊以大恩之福。覆祐我等令得所志。于是佛言。善哉愿也。斯成明士所当志念。从今已往必得不失。但当常护其行莫令毁漏。勤率一切疾获尔志。佛时叹曰

  意大兴愿首　　化惑以此五
  当成无央数　　疑者得入道
  此德无有量　　为众行之英
  若人闻是愿　　疑网永除亡
  五愿为佛地　　所伏合道化
  大慧无过是　　此愿人中上
  五百诸贤士　　启愿少等双
  后生得不失　　一切受福庆

佛谓诸贤士。一切在坐者。是法真谛宜善奉行。当以成具为本。不以虚言绮语为应法也。当忍而不为恶。若在空闲及于大众尊卑之处。内制其心令如戒法。不以闲宴而犯漏。行。不于众会而自大。不用尊显而骄贵。不以卑弱而转随。不惭善不惭恶。不种无益之事。心如正法无有摇却。不作增减之念也。如此明士。善根五愿必获尔志。疾成至佛。是时无秽王明士。避坐长跪。启天尊曰。愿佛今日现是成具光明定意威神。令此众会见之悦也。喜乐皆当发意立此德本。未成者成未度者度。于时坐中有明士。名大力普平。佛赞大力普平。现是成具光明定意威神。即时受教。便于其坐而不起动。因入慧定神静之意。如弹指顷。三千大千之国。诸小山大山。大障山小障山。悉灭不现。一切普平绀琉璃色。复令十方他佛国土。皆通相见相去如一寻所也。观十方诸佛坐处。譬如仰观星宿不可计算。复以右手举十方诸佛三千大千国土。已着一指。上之下之如举一尘。其中人民蠕动之类。无有知之者而有惊怖之念也。于是复以一切十方诸佛之国。以内方圆一尺之器中而不逼迮。现变毕竟耀如常故。其在坐者皆见如斯。悉而惊欣踊喜发于大愿。其心皆在无上独尊之地。八百万明士。及诸尊天。得安乐慧定。复六十万人。悉入通解法门。复六万八千人。得是成具光明定意。十方诸来明士莫不欢喜。佛语善明。一切人所以不学是成具光明定意者。为住于惑故也。计有以有便着染黑冥。以在着染譬犹冥夜复闭目行便无所见。无所见者。谓今所受身善恶目前之所造也

以不觉见故便吁嗟啼泣。谓今为善反受恶罪。或先为恶反受善福。不晓思惟此本。便结在疑网。已在疑网。于可学便不欲学。可进不欲进。可入不欲入。是故忘失是定。在于哭悲惶恋累劫无终已来往无休息。名曰劳苦行也。哀哉善明。此章可像故。佛出世正为愚迷人故。其有人学是正定者。彼所感念生死之烦皆疾得除。复能训导一切诸著有者。善明。常当思惟空法。莫住惑误处也。善明白佛言。若有贤士。生于种姓之家。统领县官位率国政。心多烦乱不得专一。欲学是定。当奈何乎。佛言。贤士生有县官之因缘。或在不安隐处。欲学是定。不得巡心者。当书是经卷供养。设坐阁烧香敬礼。朝中人定不失三时。头面为礼恳恻至心。又当加行十五事。一者不杀。二者活生。三者不妄取。四者而恩施人。五者不淫。六者远色声。七者不欺不调。八者而忠言善谏。九者不醉。十者不以酒为惠施。十一者拥护羸劣不令抂撗。十二者其所临生加以仁心。各使得所。十三者宽弘大受包化不肖示以正教。十四者其来归于己有所陈诉必而正平。应于法律令无枉愠。十五者以善劝上。悉施于民。终始无懈。行是十五戒莫得休废。此亦应定意之教法。必得不失。后长解脱也

善明白佛言。若有凡人。为宿罪所牵。在不安隐处。拘逼制碍。有志于是成具光明定法。而不得从心意。欲学是尊定。当奈何乎。佛言。善明。凡人至心欲学者。亦如上说。善书是经卷。为设坐阁烧香敬礼。不失三时。当复加行十事。一者修奉五戒无有缺犯。二者当以闲暇。稍稍诵行定意法文。三者虽执事作。内心诵习使不忘误。四者在勤劳屈苦之地。当知是宿行所为而无愠恚。五者若居地无佛形像。无离恶众。心常存忆。向四方作礼。如对佛无异。六者谨敕柔软。调和心意。下于一切。七者所作尽节而无虚饰。八者饶作等侣。不爱筋力。九者若见老羸疾病瘦耄。伤念扶护至心不饰。十者当归命三尊。而不怠忘是谓十事。凡人虽在勤苦拘碍之处。当行此十事。莫毁莫懈。亦应定意教法世世不失。后长解脱也。善明白佛言。若有贤女人。姻种姓之家。或有居事之业因缘。不得舍离。欲学是成具光明定意。当奈何乎。佛言。善明。女人有居事因缘。志欲学是正定者。亦如上说。善书是经。设立棚阁。供施幡花。烧香敬礼。头脑着地。鸡鸣日中人定三时。为礼不失。至心恳恻。常愿离于女人身。心绝爱欲如是无懈。又当加行二十事。一者持上贤士十五戒。中士十戒而不毁缺。二者捐于妒心。三者减于镮钏之好。四者于除脂粉之饰。五者无有恣态。六者衣服真纯而不奢丽。七者育养室内。以慈心相向。八者软教奴婢不加楚痛。九者摄护孤独。衣食平等。十者孝事其上。仁接下小。十一者下声下意。当自克责。十二者谦卑诫顺。常知惭愧。十三者所作为者。手执其事。清净香洁。施于公姑父母。供养三尊及与师友。十四者亲疏善恶。慈而等之。无此四念差别之相。十五者若在私室空闲无人。心不念欲。十六者端殷精一。心常在法。十七者所欲施作报于所尊。然后乃行。十八者无自专之心。常以卑顺敕诫其身。令如正法。十九者终不于墙垣窥看有邪辟之念。二十者坐起言语终不调戏。常应法律而无轻失。是为贤女人居家行正定之法。如此莫漏。功德渐满。后长解脱也。善明白佛言。若有小姓凡女人。性乐贤行者。家贫困厄。执事劳苦。忧在衣食。不得自在。内厌殃罪。欲疾解脱。闻是成具光明尊定清净之法。至于欲行。当云何乎。佛言。善明如此凡女人辈。在于贫困。欲学是定。虽不能得具行诫法者。且当修奉十事。莫作违舍。一者亲就贤友从受五戒。行不毁缺。二者虽饥虽寒。忍不杀盗。以自饱暖。三者虽独居处。忍不邪淫。数谏心意。四者虽贫。忍不欺怠以求财贿。五者于酒食倡伎。忍不观戏。六者尊行定法者。视之知佛。七者常行五善心。一为念施心。二为恭敬心。三为礼节心。四为下于一切心。五为制伏众态心。八者虽在事作心诵法文而无懈怠。九者六斋入塔礼拜三尊。十者虽无钱财以用布施。常身自扫洒塔地。以净水浆给与众僧。澡手洗浴以力为施勤而不厌。是为凡女人在于贫困而行是十事不有懈怠。此则巍巍。生则值佛。常遇定法。后长解脱。佛言。善明。我所说贤女凡人。贵姓贤女。凡姓女人。好贤行者。四品之行诫法了了。其身履行无毁漏者。是之福祐难譬喻也。善明。譬人以七宝满是十方。上至二十八天。以用布施。百千劫不休不息。如彼四辈人。行成具光明定意四品法功德。出于彼布施福上巨亿万倍。所以者何。夫福者有尽有苦。有往来有烦劳。有食饮。行是成具光明定意。则无此五也。寂然洁净一切尽灭。是曰最尊故喻胜也善明。当布露是戒。令一切闻受持行之。此明士所当勤劝率也。佛告善明。我灭度后。若有人行是成具光明定意。及书持经卷供养作礼者。当有十二大天神拥护之。令不抂撗所在安隐。不为恶所中伤。今为汝说此诸神名字。其在厄难水火盗贼兵革。善诵行是经文。不以怨厄故而废置者。是十二天神即当往护之。终不使横殃。佛无二言也。当广宣告一切人令诵习之

  有神名大护　　复次神名福救
  复次神名祐众　　复次神名不厄
  复次神名善将　　复次神名光明
  复次神名道戒　　复次神名拔苦
  复次神名大度　　复次神名度厄
  复次神名安隐　　复次神名普济

佛告善明。是十二神又有愿。于佛当防护是持法者。行是成具光明定意法诫处。当令有五清净。一者为经所在高座当令清净。二者烧香扫地令清净。三者衣服常清净。四者心口意常清净。五者读是经时。先施清净水。盥手漱口常令清净。是为五也。于是佛告阿难。以成具光明定意法嘱汝。善书经文慎莫增减。勤教一切人疾令受解。阿难。是经难遇。所以者何。其要先从六度无极起。乃入正定。是百三十五行。此中有教诫。有谦诫。有忍诫。有礼节诫。有众善法诫。有空法诫。乃至灭度处。无不具有也。佛身所有相好慧力。悉从此法出。为尊上为断生死。所谓无比之法也。重嘱累汝。谛以授之。当以了了。佛之出世难可常见。法诫之兴亦难值遇也。汝莫怠远。阿难言。受天尊教。佛说经竟。十方诸来明士。及诸天神。礼佛欢喜。忽各还本所。忍国诸明士除恶众。天龙鬼王及四辈人。闻经欣悦。各以头面着地。礼佛而去佛说成具光明定意经


佛说出家功德经

    No. 707

佛说出家功德经

        失译人今附东晋录

如是我闻。一时佛在毗舍离国。食时到入城乞食。时毗舍离城中。有一梨车。名鞞罗羡那(秦言勇军)。譬如天与诸天女共相娱乐。时此王子。与诸婇女。在阁上共相娱乐。耽于色欲亦复如是。尔时世尊。以一切智。闻彼乐音。告阿难言。我知此人。贪五欲乐者。不久命终。却后七日。当舍如是眷属快乐。决定当死。阿难如此人。若当不舍欲乐不出家者。命终或能堕于地狱。尔时阿难。顶奉佛教。欲利益此王子故。次至其舍。尔时王子。闻阿难在外。即出奉见。以敬念故。请阿难入坐。坐已未久。尔时王子。起恭敬心。白阿难言。善哉好亲友来。今正是时。我今见汝。踊跃欢喜。汝字欢喜。汝今当教告我佛所教法。令我欢喜。尔时王子。如是三请。阿难为欲作大利益。默然无言。王子又言。鞞陀呵牟尼大仙。利益一切众生。有何嫌恨。默然无所说。不见少告时第三师。持佛法藏。利世间者。惨然告言。汝今善听。却后七日。汝当命终。汝若于此五欲乐中。不能觉悟。不出家者。命终或当堕地狱中。佛一切智人。正语正说。记汝如是。譬火烧物。终不虚发。汝谛思惟。时彼王子。闻此语已。甚大忧怖。愁愦不乐。受阿难教。我当出家。定且听更六日受乐。第七日中。我辞家眷属。定必出家。阿难可之。第七日畏生死故。求佛出家。佛即听之。一日一夜。修持净戒。即便命终。烧香毕已。尊者阿难。与其眷属。往白佛言。世尊此鞞罗羡那比丘。今已命终。神生何处。时佛世尊。天人之师。一切智人。以大梵音。胜出雷鼓迦陵频伽众妙音声。以八种音。告阿难言。此鞞罗羡那比丘。畏于生死地狱苦故。舍欲出家。一日一夜。持净戒故。舍此世已。生四天王天。为北方天王毗沙门子。恣心受于五欲快乐。贪受五欲。与诸婇女。共相娱乐。寿五百岁。五百岁已。命终转生三十三天。为帝释子。具受五欲。极天之乐。天妙婇女。恣意千岁。寿尽生焰天。为焰天王子。自恣受天色声香味触。快心欲乐。受天二千岁已。命终生于兜率天王子。恣心受于五欲快乐。目视相欲。心自厌足。常谈法语解脱智慧。寿天中寿。满四千岁已。命终往生自在天上。为天王子。受种种五欲妙乐。于婇女中。化应恣意八千岁。八千岁已。命终生他化自在天。为天王子。此第六天。其中欲乐。下五天中。所不能及。生此中已。受最妙乐众乐之藏。受此乐时。心极迷醉。具足受于诸妙胜乐。万六千岁。如是受乐。于六欲天。往来七反。此毗罗羡那。以一日一夜出家故。满二十劫。不堕地狱饥鬼畜生。常生天人。受福自然。最后人中。生富乐家。财富珍宝具足。壮年已过。诸根熟时。畏恶生老病死患故。厌世出家。剃除须发故。身披法服。勤修精进。持四威仪。常行正念。观于五阴苦空无我。解法因缘。成辟支佛。名毗流帝。于是时。放大光明。多有人天。生于善根。令诸群生种于三乘解脱因缘。尔时阿难。叉手白佛言。世尊。若当有人放人出家。若有出家者。任其所须。得几所福。若复有人。毁破他人出家因缘。受何罪报。唯愿世尊。具尽告示。佛告阿难。汝若具满于百岁中。问我此事。我以无尽智慧。除饮食时。满百岁中。广为汝说。此人功德。犹不能尽。是人恒生天上人中。常为国王。受天人乐。若有于此沙门法中使人出家。若复营佐出家因缘。于生死中。常受快乐。我满百岁。说其福德。不可穷尽。是故阿难。汝满百岁。尽寿问我。我至涅槃。说此功德。亦不能尽。佛告阿难。若复有人。破坏他人出家因缘。即为劫夺无尽善财福藏。坏三十七助菩提法涅槃之因。设有欲坏出家因缘者。应善观察如是之事。何以故。缘此罪业。堕地狱中。常盲无目。受极处苦。若作畜生。亦常生盲。若生饿鬼中。亦常生盲。在三恶苦。久乃得脱。若生为人。在母腹中。受胎便盲。汝于百岁。常问是义。我百岁以无尽智说是罪报。亦不可尽。于四道中。生而常盲。我终不记。此人当有得脱时。所以者何。皆由毁出家故。或成就无边功德。以破如是善因缘故。受无量罪。由障出家故。于此清净智慧镜中。为于解脱诸善法故。若见出家修持净戒趣解脱处。破他出家。为作留难。以是因缘故。生便常盲。不见涅槃。由毁出家故。常观痴等十二因缘。应得解脱。以毁破他智慧眼故破出家缘。覆慧眼故。从生至生。常盲无目。不见三界。缘障出家故。出家应见五阴二十我见人趣正道。破出家因坏正见故。所生常盲。不见正道。出家应见一切法聚善法住处。应观诸佛清净法身。以破出家善因缘故。所生常盲。不能睹见佛法身。以因出家应具沙门形貌及与持戒清净福田种佛道因破出家故于善法中断一切望。由是罪缘。生生常盲由毁出家故。出家应善观察一切身心。皆苦无常无我不净破他出家。为作留难。则破此眼。破此眼故。不见四道四念处四正勤四如意足五根五力七觉分八正道趣涅槃城。是罪缘故。所生常盲。乃至不见空无相无作清净善法向涅槃城。是以智慧之人。知出家者。应当成就如是善法不应破坏善法因缘。获如是罪。谁毁破他人如是出家沙门正见因缘者。终不能得见涅槃城。所生常盲。若复有人满百劫中余方出家修持净戒。若复有人。于此阎浮提。出家持戒。一日一夜。乃至须臾。清净出家。于十六分。彼百劫出家持戒。十六分中不及其一。若有颠倒淫姊妹女。不应淫处强生悭嫉。此中罪报。不可计限。若有一人。能正思惟有出家心。欲舍诸恶。若复有人。破坏此人出家因缘。不令愿满。是罪因缘增长于前。复倍百劫。尔时阿难。复白佛言。世尊。此毗罗羡那。所种善根。生尊贵处。当受福乐。为过去世亦有善行。为但齐今一日一夜出家功德受尔许福。佛告阿难。汝不应观过去因缘。于此一日一夜。清净出家故。此善根。六欲天中。七反受福。二十劫中常受生死。世间之乐最后人中。生福乐家。壮年已过。诸根熟时。畏于生老病死苦故。出家持戒。成辟支佛

佛告阿难。我今说喻。汝当善听。譬四天下。东弗婆提。南阎浮提。西瞿耶尼。北郁单越。满中阿罗汉。若稻麻丛林。若有一人。满百岁中。尽心供养。此诸罗汉。衣服饮食。病瘦医药。房舍卧具乃至涅槃。后若起塔庙。种种珍宝花香璎珞。幡盖伎乐。悬诸宝铃。扫洒香水。以诸偈颂。赞叹供养。所得功德。若有人为涅槃故出家受戒。乃至一日一夜所作功德。比前功德。十六分中不及其一。以是因缘。善男子当应出家修持净戒。诸善男子。诸须功德者。求善法者。自受法者。不应留难出家因缘。应勤方便劝作令成。时诸大众。闻佛所说。莫不厌世。出家持戒。有得须陀洹。乃至阿罗汉者。有种辟支佛善根者。有发无上菩提心者。皆大欢喜。顶戴奉行佛说出家功德经


佛说出家缘经

    No. 791

佛说出家缘经

        后汉安息国三藏安世高译

如是我闻。一时婆伽婆在王舍城耆阇崛山。与大比丘僧俱千二百五十。是时难提优婆塞。与五百优婆塞。出王舍城上耆阇崛山。往诣佛所头面礼足。长跪叉手问佛。大德。愿闻优婆塞五戒。毁犯正戒有何恶事。佛答难提优婆塞。楚害生命有十恶事。何等十现世常怀害心。后世毒心隆赫。恒被痛害怨怨不息。人不喜见。思虑多恶见者怖惧。眠不安寐。梦则惶怖觉则惊悸。死时狂勃种短命栽。身坏命终生地狱中。设得为人多病少命。是为十恶事。偷劫他财。有十恶事。何等十。贪餮深重。恒为众疑。能兴重恶。行则非时。动则非法。亲友恶逆。贤良疏远。败戒果敢。常惧王伺。须财市命。种遗宝物贫弊之业。身坏命终生地狱中。设得为人饥寒困苦。致财良难。虽获少财五事共之。王贼水火及恶妻子。今乃藏埋。会亦当失。是为十恶事。邪淫有十恶事。何等十。常为其夫伺捕楚毒。室家不和善法消竭。不善法增。危败躯身。不检其妻。不守财贿。常为人疑。宗亲不信。种业如是。门不贞洁。身坏命终生地狱中。设得为女非独一主。设得为男驰骋邪淫。自失其妻。是十恶事。妄语中有十恶事。何等十。口常臭烂。善神背叛。凶鬼易陵。实言流世众所不信。俗为重事。不在言议。未有实事恶名远闻。为人轻毁不起恭肃。虽言有实人不奉用。多怀愁怖种诽谤业。身死命终生地狱中。设得为人常被诽谤。是十恶事。饮酒有三十五恶。何等三十五。散尽财贿。致众苦患。怨诤增重。裸露形躯。恶名遐迩。慧明日减。应得不得。已得便失。显扬恶事。要务顿发忧戚之本。恍惚变没。颜貌鄙恶。轻慢尊长。不知供养沙门婆罗门。自于室家不辨尊卑。不宗敬佛。不崇大法。不敬事僧。返亲恶人。远离明能。崩坠邪道。无惭愧心。不护根门。惛荒淫欲。众所不爱。人不喜见。德士宿旧咸来咎责。集造众恶。要用之势。不豫识任。智德隐避。像类不别。去泥洹远。种狂惑业。身死命终生地狱中。设得为人愚痴顽瞆。是时难提优婆塞。及五百清信士诸天世人。四辈之众。闻佛所说毕命受持。头面绕竟。踊悦而去佛说出家缘经


佛说出生菩提心经

    No. 837 [No. 838]

佛说出生菩提心经一卷

        大隋北印度三藏阇那崛多译

如是我闻。一时婆伽婆在王舍城迦兰陀竹园。与大比丘众百千人俱。复与无量阿僧祇不可说大菩萨众。所谓十方来集

尔时王舍大城有婆罗门姓大迦叶。于睡眠中。梦见阎浮提内。有大莲华其华千叶。光明遍照三千大千世界。微妙最胜七宝所成。于莲华内见有月轮。彼月轮内又见丈夫放大光明普照一切。此四天下所有众生见斯光者。生大欢喜踊跃无量皆受快乐。尔时迦叶婆罗门睡觉已。念所梦事心喜生疑。此何因缘竟有何事。于先现此未曾有相。昔所未闻如我梦见。作是念已生大欢喜未曾见有。复作如是念。此有沙门瞿昙。我从他闻六年苦行。降伏魔众证大菩提。转妙法轮摧诸外道。为诸智人之所赞叹。聪明善巧知诸事相。我今应往诣彼沙门瞿昙问此梦相

尔时迦叶婆罗门。夜既过已。从王舍城往诣迦兰陀竹园往到佛所。到已顶礼佛足却住一面。住一面已。如梦所见而向佛说。时婆罗门具说梦已。尔时世尊告迦叶婆罗门言。汝善男子。有四种善梦得于胜法。何等为四。所谓于睡眠中梦见莲华。或见伞盖。或见月轮。及见佛形。如是见已。应自庆幸我遇胜法。尔时世尊欲重宣此义。而说偈言

  若有睡梦见莲华　　及以梦见于伞盖
  或复梦里见月轮　　应当获得大利益
  若有梦见佛形像　　诸相具足庄严身
  众生见者应欢喜　　念当必作调御人

尔时迦叶婆罗门闻此偈已。复白佛言。世尊。何者是大利诸众生等。若为能得此利益求菩提道。尔时佛告迦叶婆罗门言。大利者所谓一切智者是其利也。时迦叶婆罗门复白佛言。世尊。所言一切智利者。有何因缘而可得也。尔时世尊为迦叶婆罗门。而说偈言

  我今说大利　　婆罗门善听
  若有利和合　　当作两足尊
  若作转轮王　　自在四天下
  众生欲作者　　须发菩提心
  若作梵天王　　于众得自在
  众生欲作者　　须发菩提心
  欲界及色界　　无色及上界
  众生欲作者　　须发菩提心
  若有众生等　　若欲作商主
  为商主导师　　须发菩提心
  若有众生等　　欲作大光明
  破灭诸黑暗　　须发菩提心
  若有众生等　　欲灭诸颠倒
  及以三有等　　须发菩提心
  若有众生等　　欲灭诸盖障
  及诸恶法者　　须发菩提心
  若有众生等　　欲灭于无明
  及断贪爱网　　须发菩提心
  若有众生等　　欲灭有及爱
  及灭垢无垢　　须发菩提心
  若有众生等　　欲灭于我慢
  及色使我慢　　须发菩提心
  若有众生等　　欲离于贡高
  无病命我慢　　须发菩提心
  若有众生等　　欲灭老我慢
  无常常住慢　　须发菩提心
  若有众生等　　欲灭多闻慢
  及以持戒慢　　须发菩提心
  若有众生等　　欲灭兰若慢
  乞食等诸慢　　须发菩提心
  若有众生等　　欲灭知识慢
  爱粪扫衣慢　　须发菩提心
  若有众生等　　欲灭神通慢
  一食以为净　　须发菩提心
  若有众生等　　欲灭一切慢
  所有有为慢　　须发菩提心
  若有众生等　　当欲供养佛
  于先灭度者　　须发菩提心
  若有众生等　　当欲供养佛
  所有诸如来　　须发菩提心
  若有众生等　　欲得转法轮
  世间无能转　　须发菩提心
  若有众生等　　欲灭应当灭
  当思所多思　　须发菩提心
  若有众生等　　当欲行梵行
  初中后最上　　须发菩提心
  若有众生等　　欲摄诸精进
  往来诸有中　　须发菩提心
  若有众生等　　欲说诸行苦
  见众生受苦　　须发菩提心
  若有众生等　　诸法无有我
  欲为众生说　　须发菩提心
  若有众生等　　欲转于法轮
  欲触上菩提　　须发菩提心
  若有众生等　　欲说寂涅槃
  当证胜菩提　　须发菩提心
  如是等功德　　发心者能得
  梵志当闻已　　应行菩提道

尔时迦叶婆罗门闻此偈已。复白佛言。世尊。发菩提心者应摄几许福聚。尔时世尊即以偈颂向迦叶婆罗门。说如是言

  若此佛刹诸众生　　令住信心及持戒
  如彼最上大福聚　　不及道心十六分
  若此佛刹诸众生　　令住信心于法行
  如彼最上大福聚　　不及道心十六分
  若诸佛刹恒河沙　　皆悉造寺求福故
  复造诸塔如须弥　　不及道心十六分
  若有佛刹如恒沙　　皆悉遍施诸七宝
  如彼最上大福聚　　不及道心十六分
  如铁围山高广大　　造塔无量为诸佛
  如是求福众生等　　不及道心十六分
  若诸众生具满劫　　若头若髆常担戴
  如彼最胜福德聚　　不及道心十六分
  如是人等得胜法　　若求菩提利众生
  彼等众生最胜者　　此无比类况有上
  是故得闻此诸法　　智者常生乐法心
  当得无边大福聚　　速得证于无上道

尔时迦叶婆罗门复白佛言。世尊。如是发菩提心者有退转不。是时佛告迦叶婆罗门言。如是发菩提心者。于解脱中无有退也。但就事别有三种菩提。何等为三。所谓声闻菩提。辟支佛菩提。阿耨多罗三藐三菩提大婆罗门。何者是声闻菩提。若善男子善女人发阿耨多罗三藐三菩提。而不教他发菩提心不令他住。亦不为说如是经典。不自受持亦不为人广说其义。亦有亲近是富伽罗。而不承事供养所须。若有来者及不来者亦不恭敬。而于彼所不生随喜。以此因缘心得解脱。婆罗门。是则名为声闻菩提。复次何者是辟支佛菩提。若善男子善女人自发菩提心。而不教他发菩提心不令他住。亦不为说如是经典。不自受持亦不广为他人解说。亦不亲近如是富伽罗。而不承事供养所须。若有来者及不来者。亦不恭敬亦不随喜。以此因缘心证辟支菩提。是故名为辟支佛道。复次何者是阿耨多罗三藐三菩提。若善男子善女人自发阿耨多罗三藐三菩提心。亦复教他发阿耨多罗三藐三菩提心。既令彼住。复为人说如是经典悉令受持。亲近如是富伽罗等承事供养。若有来者及不来者。亦悉恭敬亦生随喜。如此解脱自利利他。为多人利益故。为多人安乐故。怜愍世间利益安乐诸天人等故。名阿耨多罗三藐三菩提也。以何义故。名阿耨多罗三藐三菩提。于上更无有胜可求。是故名为阿耨多罗三藐三菩提。尔时世尊欲重宣此义。以偈颂曰

  自发菩提心　　不教他受持
  因自心力故　　于后般涅槃
  为自利勤劬　　不教他受持
  是故名沙门　　佛子最胜师
  彼发菩提心　　教化生欢喜
  是故自得道　　果报如是知
  自成不成他　　诸仙中福田
  得名为缘觉　　婆罗门当知
  自发菩提心　　复脱多众生
  为世作利益　　故名佛导师
  成就自利益　　复令他解脱
  此彼无差别　　故名不思议

尔时迦叶婆罗门白佛言。世尊。解脱解脱有差别不。佛言。婆罗门。解脱于解脱无有差别。道于道无有差别。乘于乘而有差别。譬如王路有象舆者。有马舆者。有驴舆者。彼等次第行于彼路同至一城。婆罗门。于汝意云何。如是等乘有差别不。婆罗门言。大德世尊。然彼诸乘实有差别。佛言。如是如是。婆罗门。声闻乘。辟支佛乘。阿耨多罗三藐三菩提乘有差别。道与解脱无有差别。婆罗门。譬如恒河有三种人。有从此岸至于彼岸。其初人者。以草为筏倚之而度。第二人者若以皮囊若以皮船倚之而度。第三人者。造作大船乘之入河。于此船中载百千人。其第三人。复敕长子安置守护如此船舫。所有众生来者。汝从此岸度至彼岸。为多人等作利益故。婆罗门。于意云何。夫彼岸者有差别不。婆罗门言。不也世尊。佛复问言。婆罗门。于汝意云何。彼乘之乘有差别不。婆罗门言。所乘之乘实有差别。佛言。如是如是。婆罗门。然声闻乘辟支佛乘阿耨多罗三藐三菩提乘实有差别。婆罗门。如第一人。依倚草筏从于此岸至于彼岸。独一无二。声闻菩提应如是知。第二人者。若倚皮囊及以皮船。从于此岸度至彼岸。辟支佛菩提应如是知。婆罗门。如第三人。成就大船共多人众。从于此岸至于彼岸。如来菩提应如是知。尔时世尊欲重宣此义。而说偈言

  路及解脱无有上　　诸乘皆悉有差别
  智者如是应挍量　　当取最胜最上乘
  诸法教如是　　正觉说此言
  简择诸法已　　胜者应当学

尔时迦叶婆罗门复白佛言。世尊。菩萨摩诃萨当云何行云何念住。得至摩诃衍。尔时佛告迦叶婆罗门作如是言。婆罗门汝听是义。若诸菩萨摩诃萨。如念修行至摩诃衍。婆罗门。若善男子善女人。自发菩提心。亦教他人发菩提心。自乐修行劝他令修亦令他住。复为解释如是修多罗义。如是等富伽罗人。不来亲近承受接事。当以四摄而摄取之。何等为四。所谓布施爱语利益同事。尔时世尊欲重宣此义。而说偈言

  种种大布施　　一切所有物
  欲摄受他故　　菩萨无畏者
  示现引接道　　众生不依来
  能以妙善语　　数数当安慰
  为自他安乐　　彼所生善处
  昼夜常随顺　　如是众生等
  不信教令信　　破戒令住戒
  悭吝令布施　　一切巧利益
  教人行菩提　　牢固常精进
  同于利益事　　智者如教行
  如此智慧者　　菩萨之导师
  智慧所行者　　常乐大乘法
  勇猛是最胜　　智者应当学
  以彼胜法故　　最胜到彼岸

尔时迦叶婆罗门。复以偈颂而白佛言

  大德示彼行　　菩萨诸导师
  当学彼所行　　得至两足尊
  为我说彼行　　及行行所依
  菩提深广大　　慈愍愿为说

尔时世尊告迦叶婆罗门言。善哉婆罗门。诸菩萨有三种行。何等为三。所谓天行梵行圣行。婆罗门。于中何者名为天行。若有善男子善女人。以慈身业。以慈意业。以慈口业。遍满东方无量世界慈行充满。行此遍已。复能善入南西北方四维上下。皆以慈身业慈意业慈口业普遍充满。是名天行。于中何者名为梵行。所谓四无量。何等为四。慈悲喜舍。是名梵行。婆罗门。于中何者名为圣行。所谓三解脱门。何者为三。空无相无愿。是名圣行。尔时世尊欲重宣此义。而说偈言

  勇猛行精进　　菩萨之导师
  若有具天行　　是人乐菩提
  圣行及梵行　　是行圣所说
  若有修行者　　是人得不动

尔时迦叶婆罗门。复以此偈。而白佛言

  我乐深菩提　　今问大导师
  此等当来世　　如何集诸行
  为后众生等　　故我问世尊
  于佛菩提中　　我意无分别
  令我发道心　　利益众生故

尔时世尊。复以偈颂报彼迦叶婆罗门言

  说此修多罗　　令发大菩提
  梵志佛菩提　　未曾有分别
  说此修多罗　　令发大菩提
  能断一切疑　　随顺众生问
  说此修多罗　　令发大菩提
  能断一切疑　　称彼众生欲
  得闻此经者　　彼于未来世
  能行大布施　　至于檀彼岸
  得闻此经者　　彼于未来世
  护持戒无缺　　至于戒彼岸
  得闻此经者　　彼于未来世
  行忍为众生　　至于忍彼岸
  得闻此经者　　彼于未来世
  精进为众生　　至于精进岸
  得闻此经者　　彼于未来世
  常入诸禅定　　至于禅彼岸
  得闻此经者　　彼于未来世
  为众求胜智　　至于智彼岸
  已曾作供养　　怜愍众生者
  得闻此经典　　后世到其手
  比丘住兰若　　意欲佛菩提
  得闻此经者　　于后最先得
  过去数亿佛　　已持此经典
  为利诸菩萨　　发起意欲故
  若有婆罗门　　欲乐佛菩提
  彼时得信已　　是经至其手
  我见彼众生　　悉知彼所行
  亦知彼名字　　我见悉无碍
  一切颇具说　　恐迷未来人
  惧彼起诸过　　是故少分说

尔时迦叶婆罗门。复以此偈而白佛言

  大德此善持　　令生广大意
  此世大丈夫　　不久我当作
  过去及未来　　导师之所说
  为彼生善利　　故住于菩提

尔时世尊。复以偈报婆罗门言

  彼等住此智　　为谁之所说
  已知彼心行　　我今当记彼
  所闻此经者　　今现在我前
  彼等于后世　　此经当现前
  若有诸女人　　抄写此经典
  此经当在手　　能生大菩提
  我于先已说　　比丘乐兰若
  手得此经典　　于后当现前
  比丘闻此经　　悲泣而雨泪
  我先作何业　　今世得此利
  我于如是经　　未曾善思惟
  我已得受记　　何业获此果
  我昔婆罗门　　依于比丘活
  时比丘放逸　　说此修多罗
  梵志于彼闻　　时至而乞食
  泣泪已行出　　是时心作愿
  我于修多罗　　钞义及文字
  后世作证明　　亦复作拥护
  以彼善业果　　于后后末世
  得此修多罗　　执持在其手
  彼时有比丘　　悲泣泪满目
  当时作忏悔　　后得此经法
  于先业灭尽　　彼时有相现
  于其睡梦中　　得此修多罗
  生死诸流转　　欺诳大恐怖
  斯由阿弥陀　　愿力如是果
  破戒诸比丘　　为他所轻贱
  如是多诸过　　流转大恐怖
  如是多诸恶　　由得闻此经
  当至彼边际　　于后常显曜

尔时迦叶婆罗门。复以此偈而白佛言

  此大修多罗　　令发大道心
  为我及未来　　分别广宣说

尔时世尊。复以偈告迦叶种姓婆罗门言

  未来诸音声　　乃至我所说
  此是广经典　　是故汝当知
  说此大经典　　此当作阿含
  当作秘密藏　　声闻所修学
  此处之所说　　及余得道者
  此是诸经母　　梵志如此知
  彼时诸比丘　　于我灭度后
  杂及长阿含　　复名中阿含
  彼时有阿含　　具数名增一
  复说杂经典　　箧藏声闻说
  复当作毗尼　　亦作阿毗昙
  或于三箧藏　　得名诸比丘
  八万有四千　　法聚我已说
  一切从此出　　名为最胜经
  于此说声闻　　及说独一觉
  诸智之根本　　不思议经典
  世间之所有　　三界未现者
  诸福之根本　　由发菩提心
  施戒等功德　　忍辱精进行
  禅定胜功德　　此经中善说
  智慧胜功德　　解脱忍寂灭
  一切皆示现　　此经中善说
  苦集及以道　　寂灭于此现
  诸法皆佛法　　此经之所说
  说诸苦无常　　亦说无我法
  说寂静涅槃　　在此修多罗
  此处说声闻　　所住诸因缘
  大乘此经典　　摄受一切法
  诸法甚广大　　在于菩提心
  此为最胜典　　普说修多罗
  现前见诸佛　　及为彼说法
  当时现前闻　　斯由此经典
  三界诸众生　　少有闻此经
  闻已生爱乐　　为求佛乘故

尔时迦叶婆罗门复白佛言。希有世尊。若诸众生无有智慧。若闻如是无上无边。乃至如是等众生当无有智慧。若如是等无边无上修多罗。闻已不能于此法中不生坚固乐欲。大德世尊有何因缘既有如是妙法。然彼众生而当虚过也

尔时佛告彼婆罗门言。此三千大千世界。有百俱致(凡言俱致者隋数千万)诸魔宫殿。彼一一魔有俱致数魔众眷属。围绕彼诸魔辈。常勤方便欲灭此经作种种因缘。因彼因缘随所在处作诸障碍。所以者何。若以三千大千世界所有众生。皆悉得于阿罗汉果。若有善男子善女人。闻此修多罗已。当发阿耨多罗三藐三菩提心。婆罗门。以是因缘。令俱致数诸魔。勤求方便欲灭此经。所以者何。婆罗门。此修多罗。是一切诸法种性根本。以是义故。俱致诸魔勤求方便欲灭此经。尔时佛告婆罗门。今有修多罗。名曰破魔众会。汝等受持读诵。即得破彼魔天众会。婆罗门。譬如日轮既出现时。能灭一切幽冥黑暗如是如是。婆罗门说破魔众会修多罗时。一切诸魔隐没不现。婆罗门。何者名为破魔众会修多罗。尔时世尊。即说陀罗尼曰

多(上)致他(一)阿[少/兔]谟大那(上二)菩提三摩陀波那多(三)伏哆(四)纡伏哆(五)怛怛罗伏哆(六)尼兴(蜎蝇反)伽魔(七)波罗破(八)多罗破(九)哆嘘(十)哆隆(洛中反)伽磨伽魔那(十一)毗唎磨(十二)磨素磨(十三)系(上声)履婆伽磨(十四)毗达啰魔(十五)大啰麴磨(十六)阿逻弥逻(十七)伊迦叉逻那喻(十八)

婆罗门。此陀罗尼。是过去未来现在诸佛世尊。同说此破魔众会修多罗。婆罗门。说此破魔众会修多罗时。一切魔宫皆悉震动。大动摇大摇。一切诸魔各各从彼本座颠倒堕落不能语言。所以者何。彼等常为多人作不利益。常为多人作苦恼事令失利益。以是事故。现得如是恐怖果报。如佛世尊常与一切众生乐故。乃至慈悲喜舍。是故令彼诸波旬等皆生恐怖。婆罗门。若复有人。当能转此发菩提修多罗者。于彼人所无有障碍。若诸天龙夜叉。若人非人。若魔魔子。若魔眷属。若水火刀杖。若恶行者。若诸恶兽。若身所恼。若意所苦。而有受者无有是处。何以故。彼善男子善女人。常为多人作利益事安乐故。常为多人作怜愍故。为诸天人等作覆护故。彼等诸善男子善女人慈行力故。应如是知。婆罗门。彼善男子善女人。不作身恶行。不作口恶行。不作意恶行故。彼等诸苦事。不逼其身亦不逼心。婆罗门。此因缘故能灭一切苦。尔时世尊重宣此义。而说偈言

  魔勤于此经　　当欲坏灭之
  是故此经典　　调御今为说
  令魔悉迷乱　　丛聚坐战栗
  相视不能言　　此恶行果报
  恐怖众生故　　常怀作恶心
  颠倒而堕落　　是故得现报
  慈悲和合者　　喜心有所说
  平等说法时　　恶心意悉散
  降伏诸魔王　　及散魔军众
  夜叉诸鬼等　　自然皆堕落
  彼力杖不害　　水火不漂然
  言说咒诅毒　　不能有伤害
  逼身及逼心　　彼等不曾有
  常当所作誓　　身口如是住
  闭塞诸恶道　　远离一切难
  诸魔悉摧灭　　为说此经故
  一切法巧智　　若欲度彼岸
  须闻此经典　　闻已即能学
  若能学此经　　无畏诸菩萨
  最上觉菩提　　是向菩提句

佛说此经时。迦叶婆罗门及诸大会众。乾闼婆天人阿修罗等。闻佛所说欢喜奉行出生菩提心经


佛说初分说经

    No. 498

佛说初分说经卷上

        西天译经三藏传法大师赐紫臣施护奉　诏译

尔时世尊。往诣优楼频螺耆年迦叶所。到彼处已。时彼迦叶见佛世尊自远而来。即白佛言。善来大沙门。诸有所须衣服饮食。我悉供给。是时世尊即谓迦叶言。我今于汝此舍之中。止息一夜。迦叶白言。此舍非我所止之处。是我事火之舍。有一大龙。见止其中。彼龙具大神通。有大威力。汝今若止其中。恐彼侵害。于是世尊第二第三。谓迦叶言。但令我今于此会中。止息一夜。时彼迦叶亦复再三。而白佛言。大龙居中。恐彼侵害。汝今宜应信受我语

尔时世尊即作是念。我今不应多与其言。起悲愍心。决定转故。作是念已。即入火舍。以僧伽梨衣四叠。安置净草之处。然后世尊加跌而坐。是时彼龙心生嗔恚。乃吐烟焰。充塞其舍。世尊即入火界三昧。亦出烟焰。周匝其舍。都成一聚大火炽焰。彼龙复出青黄赤白种种色相大恶火焰。世尊亦出青黄赤白种种色焰

尔时优楼频螺耆年迦叶。与自眷属。于其火舍。周匝旋转已。作如是言。此大沙门。最上色相。先不听我言。必为龙所害。是时世尊以神通力。于须臾间。彼龙威光。自然收摄。时彼迦叶知佛世尊亦得神通。尽其夜分。随其所应。佛现神通。时即往观察。乃见其龙。威光渐少。世尊光明。转复炽盛

尔时世尊于明旦时。摄伏彼龙。入其钵中。持示迦叶言。此是火舍中龙。我已摄伏。迦叶。此龙有大威力。若诸凡夫。即不能入其舍。时彼迦叶即生叹异。乃发净信。我出家心。岂可止耶

复次优楼频螺耆年迦叶。欲于日初分时作事火法。即作是念。此大沙门。有大威力。具大神通。乃至大威力。龙亦能摄伏。我今但于日初分时。作事火法。彼大沙门。于日后分时。应作神通事。是时世尊知彼迦叶信佛神通。世尊即为摄神通力而彼迦叶。于日初分。得作大事已。即生叹异。乃发净信。我出家心。岂可止耶

又复迦叶欲于日后分时作事火法。即作是念。此大沙门。有大威力。具大神通。乃至大威力。龙亦能摄伏。我今但于日后分时。作事火法。彼大沙门。于日初分时。应作神通事。是时世尊知彼迦叶信佛神通。世尊即为摄神通力而彼迦叶。于日后分时。得作大事已。即生叹异。乃发净信。我出家心。岂可止耶

又复迦叶别作然火法种种施作。皆不能然。复以干木。投掷其中。及以干草干瞿摩夷苏油等物。所应用者。悉掷其内。复作不善相。出是咒言

伊梨萨哥多梨萨哥一切能烧此何不然

作是咒已。火亦不然。时彼迦叶即作是念。此大沙门。具大神通。有大威力。乃至大威力。龙亦能摄伏。我以何物。当为供养。是时世尊知彼迦叶信佛神通。世尊即为起神通力。其火乃然。时彼迦叶即生叹异。乃发净信。我出家心。岂可止耶

又复迦叶既作法已。欲灭其火。种种施作。不能息灭。乃取净土。倾掷其中。复投以灰。乃洒以水。亦作不善相。出是咒言

伊梨萨哥多梨萨哥一切烧已此何不灭

作是咒已。火亦不灭。时彼迦叶。即作是念。此大沙门。具大神通。有大威力。乃至大威力。龙亦能摄伏。我以何物。当为供养。是时世尊。知彼迦叶信佛神通。世尊即为摄神通力。其火乃灭。时彼迦叶。即生叹异。乃发净信。我出家心。岂可止耶

复次迦叶于昼日分。而暂睡眠。世尊即化五百耆年。众状如迦叶。俱诣其所。化众到已高出其声。互相戏笑。迦叶由戏笑声。乃从睡觉。作是思惟。我今何故耽着睡眠。同梵行者。来亦不知。时彼化众咸赞是言。善哉善哉。是时迦叶普遍观察。各各见其色相。乃作是念。岂非大沙门神力所化邪。彼大沙门。具大神通。有大威力。乃至大威力。龙亦能摄伏。我以何物。当为供养是时世尊知彼迦叶信佛神通。世尊即为摄神通力。彼诸化众忽然不见。时彼迦叶即生叹异。乃发净信。我出家心。岂可止耶

尔时世尊离彼迦叶住处。往诣泥连河岸珂那聚落中阿惹播罗树下。世尊行时。体具威仪。容相可观。既到彼已。而暂止息。是时迦叶即作是念。我等今时。亦往泥连河岸。作洁净事水法。而大沙门亦复在彼。作是念已。即与眷属。诣泥连河岸。到已忽见其水逆流。复作是念。此水逆流。岂非大沙门神通所作邪。而此大沙门。具大神通。有大威力。乃至大威力。龙亦能摄伏。我以何物。当为供养。是时世尊知彼迦叶信佛神通。世尊乃为摄神通力。水即顺流。时彼迦叶即生叹异。乃发净信。我出家心。岂可止耶

又复世尊渐次欲渡泥连河。往缚象聚落中。是时大云忽起。暴雨澍流。河声泛涨。如角贝响。世尊尔时于急流中。徐缓而进。水分两派。步步尘生。时彼迦叶乃作是念。此大沙门。方涉中流。河水迅急。将非漂没。作是念时。乃见世尊。于急流中。水分两派。步步尘生。渐至其岸。即生叹异。希有难得。此大沙门名。我于诸世间。曾所未闻。迦叶尔时乃发净信。我出家心。岂可止耶。迦叶见佛如是等神通事已。转发最上清净信心。深生爱乐。乃发是言。佛大沙门。能作如是神通事业。我以何物。当为供养

尔时世尊既至彼岸于缚象聚落中。而乃止息。即于是夜。东方持国天王。来诣佛所。恭敬礼足。彼身光明。广大照耀。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故东方光来。广大照耀。世尊告言。夜中所现东方光者。是彼持国天王。来礼我足。彼身光明。照耀如是。迦叶尔时即作是念。彼之名字。我等虽闻。而不能见。况复能来礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶。第二夜中。南方增长天王。来诣佛所。恭敬礼足。彼身光明。广大照耀。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故南方光来。广大照耀。世尊告言。夜中所现南方光者。是彼增长天王。来礼我足。彼身光明。照耀如是。迦叶尔时即作是念。彼之名字。我等虽闻。而不能见。况复能来礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶。第三夜中。西方广目天王。来诣佛所。恭敬礼足。彼身光明。广大照耀。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故西方光来。广大照耀。世尊告言。夜中所现西方光者。是彼广目天王。来礼我足。彼身光明。照耀如是。迦叶尔时即作是念。彼之名字。我等虽闻。而不能见。况复能来礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶。第四夜中。北方多闻天王。来诣佛所。恭敬礼足。彼身光明。广大照耀。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故北方光来。广大照耀。世尊告言。夜中所现北方光者。是彼多闻天王。来礼我足。彼身光明。照耀如是。迦叶尔时即作是念。彼之名字。我等虽闻。而不能见。况复能来礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶。第五夜中。上方帝释天王。来诣佛所。恭敬礼足。彼身光明。广大照耀。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故上方光来。广大照耀。世尊告言。夜中所现上方光者。是彼帝释天主。来礼我足。彼身光明。照耀如是。迦叶尔时即作是念。彼之名字。我等虽闻。而不能见。况复能来礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶。第六夜中。四方四大天王。上方帝释天主。俱诣佛所。恭敬礼足。四王身光。四方互照。帝释身光。上方照耀。然彼诸光。悉于世尊三摩地光中之所收摄。迦叶是夜睹斯光已。至明旦时。往诣佛所。到已白言。大沙门。夜中何故四方光来。及彼上方光来照耀。世尊告言。夜中所现四方光者。是彼四方天王。上方光者。是帝释天主。俱来礼足。彼诸身光。照耀如是。迦叶尔时即作是念。五方俱来。礼沙门足。我观是事。希有难得。乃发净信。我出家心。岂可止耶

复次世尊谓迦叶言。汝今为我。于庵摩勒林中。取彼果来。迦叶以佛威神力故。如言即取持以奉佛。世尊又言。汝于呵梨勒林中。取彼药来。迦叶如言取以奉佛。世尊又言。汝于赡部树。先取其果。次复可取随应知者种种果来。迦叶如言取以奉佛。世尊又言。汝于北俱卢洲。取彼饭来。迦叶如言取以奉佛。世尊又言。汝于三十三天中。取彼曼陀罗华来。迦叶如言取以奉佛。尔时迦叶知佛世尊有如是等种种神通。转复发起最上净信。世尊知彼心已。于迦叶前。复以神力。以虚空中。别见身相。起三威仪。谓住威仪。行步威仪。加趺坐威仪。如是所现诸威仪相。皆悉迅疾。如履急流。是相亦然。又于空中。化现众宝。所成楼阁。又复普现。黄金色相。世尊现如是等诸神通已。还摄神力。本相如故

尔时迦叶。常于年中。而择一日。于自住处。作祀天会。所有摩伽陀国。王舍大城。频婆娑罗王。及其国中。一切人民。咸来赴会。而彼迦叶。知设会时至。还本住处。乃作是念。我常所设祀天施会。今正是时。王及人民。咸悉来集。彼大沙门。面相平满。远离颦蹙。无复恚怒。出善语言。见者欢喜。此最上善人。若来我舍。我祀天会。何能施作。尔时世尊。知彼心念已。即现神力。往北俱卢洲。如常乞食。还诣雪山边。安坐而食。食已于彼作草庵舍。止息一夜。时彼迦叶。祀天既毕。设会亦周。饮食所须。而尚丰溢。迦叶见已。即作是念。彼大沙门。今时若来。我当授食。世尊知其念已。从虚空中来现其前。迦叶见已。作如是言。善来大沙门。我昨设会。汝何不来。世尊答言。知汝起念。故我不来。世尊即为如念而说。迦叶复言。汝于今日。何故乃来。世尊答言。亦知汝念。欲授我食。故我斯来。是时迦叶即作是念。希有难得。此大沙门。知我心意。此必同我。亦得阿罗汉。世尊知其所念。即时谓言。迦叶。汝非阿罗汉。不知阿罗汉法。迦叶闻已。复作是念。希有希有。此大沙门。若心若意。若寻若伺。皆悉能知。作是念已。头面着地。前礼佛足白言。世尊。我今归佛。出家受具足戒。惟愿善逝。哀愍摄受。佛言。迦叶。汝今不应投佛出家。所以者何。摩伽陀国王及人民。皆悉宗敬。供养于汝。汝于亲属知识众中。是最善人。宜应今时审自思忖。迦叶白佛言。莫作是说。莫作是说。我于世尊所。生极喜心。发胜爱乐。岂复审思。我今决定归佛出家。何以故。世尊。我出家已。于沙门婆罗门外道众中。摧伏一切讥毁过失者。执持胜幢。于王舍大城中。次第经行。表示我优楼频螺耆年迦叶。能于世尊清净法中。而得解脱。是故我今决定归佛出家。惟愿世尊。哀愍摄受。佛言。迦叶。汝能决定归佛出家者。斯为甚善。然汝今时。亦应与自眷属而共评议。尔时迦叶如佛教敕。即与眷属。而相议言。汝等当知。佛大沙门。具大神通。有大威力。一切见者。咸生欢喜。我于佛所。深发最上清净信心。我今决定归佛出家。诸眷属言。我师圣者尚能如是。发轻利心。我等诸人。岂不出家。是故今时。亦各乐欲。归佛出家

佛说初分说经卷上佛说初分说经卷下

        西天译经三藏传法大师赐紫臣施护奉　诏译

尔时优楼频螺耆年迦叶。与五百眷属。还诣佛所。到已偏袒右肩。右膝着地。合掌顶礼。而白佛言。世尊。我今归佛出家奉持戒律。愿佛摄受。佛言善来。汝今于我法中。修持梵行。时彼迦叶。须发自落。袈裟被身。执持应器。成苾刍相

尔时尊者优楼频螺迦叶。即以其发。奉上世尊。作如是言。世尊。此我之发。用拭佛足。愿佛慈悲。受我所献。如是迦叶。既出家已。彼诸眷属。亦各出家。复次迦叶即时取彼先事火具。所谓净草虎皮牛皮果树皮三杖净水瓶珂哩哥洁净器等。而悉弃掷泥连河中

尔时那提迦叶。在于彼河下流之侧。与三百眷属俱。见所弃掷事火之具流至彼已。乃作是念。我兄优楼频螺耆年迦叶。岂非为彼人或非人所恼害邪。若不然者。何故弃掷所用之物。作是念已。即与眷属。往诣其所。到已乃见兄及五百眷属。俱在佛边。而为苾刍。修持梵行。即作是言。我兄优楼频螺。此摩伽陀国王及人民。尊重恭敬。供养于汝。汝于今时。何所见闻。乃于大沙门边。而能出家。修持梵行。我观是事。甚为希有。优楼频螺迦叶言。佛世尊者。具大神通。有大威力。能作种种神变等事。我见是相。乃发净信。于佛法中。出家修道。汝今宜应亦发净信。归佛出家。是时那提迦叶闻其语已。发出家心。即与眷属。前诣佛所。偏袒右肩。右膝着地。合掌顶礼。而白佛言。世尊。我等归佛出家。奉持戒律。愿佛摄受。佛言善来。汝今于我法中。修持梵行。时彼那提迦叶。须发自落。袈裟被身。执持应器成苾刍相。彼诸眷属。亦各出家

复次那提迦叶即时取彼先事火具。所谓净草虎皮牛皮果树皮三杖净水瓶珂哩哥洁净器等。而悉弃掷泥连河中

尔时伽耶迦叶。亦在彼河下流之侧。与二百眷属俱。见所弃掷事火之具流至彼已。乃作是念。我兄优楼频螺迦叶。那提迦叶。岂非为彼人。或非人所恼害耶。若不然者。何故弃掷所用之物。作是念已。即与眷属。渐次前诣。询问其故。乃见二兄并诸眷属。俱在佛边。而为苾刍。修持梵行。即作是言。我兄优楼频螺。此摩伽陀国王及人民。尊重恭敬。供养于汝。汝于今时。何所见闻。乃于大沙门边。而能出家。修持梵行。我观是事。甚为希有。优楼频螺迦叶言。佛世尊者。具大神通。有大威力。能作种种神变等事。我见是相。乃发净信。于佛法中。出家修道。汝今宜应亦发净信。归佛出家

是时伽耶迦叶。闻其语已。发出家心。即与眷属。前诣佛所。偏袒右肩。右膝着地。合掌顶礼。而白佛言。世尊。我等归佛出家。奉持戒律。愿佛摄受。佛言善来。汝今于我法中。修持梵行。时彼伽耶迦叶。须发自落。袈裟被身。执持应器。成苾刍相。彼诸眷属。亦各出家。复次伽耶迦叶。即时取彼先事火具。所谓净草虎皮牛皮果树皮三杖净水瓶珂哩歌洁净器等。而悉弃掷泥连河中

如是三迦叶。并诸眷属。俱出家已。时尊者优楼频螺迦叶于眷属众中。即谓一人言。汝往频婆娑罗王所。如我词曰。优楼频螺迦叶告白王言。我今并弟眷属俱。已随佛出家修道。我先受王诸有信施。今日已还。愿王止息。使人受命。即往白王

尔时世尊化三迦叶已。与如是等苾刍众俱。往诣象头山。到已安止。即作是念。迦叶眷属。虽复耆旧先事火天宗信火法。而不能知诸法无常。我今为说。世尊作是念已。即时踊身。于虚空中。现大火焰。光明炽盛如是现已。还复本座。告诸苾刍言。汝等当知。眼根无常。色境无常。眼识无常。眼触无常。眼触为缘所生。苦乐舍受。皆悉无常。耳鼻舌身意根无常。声香味触法境无常。耳鼻舌身意识无常。耳鼻舌身意触无常。耳鼻舌身意触为缘所生诸受。皆悉无常。诸苾刍。贪火无常。嗔火无常。痴火无常。生老死忧悲苦恼。皆悉无常。诸苾刍。是故汝等应如是知诸法无常

复次诸苾刍。汝等当知。眼根不受。色境不受。眼识不受。眼触不受。眼触为缘所生诸受。皆悉不受。耳鼻舌身意根不受。声香味触法境不受。耳鼻舌身意识不受。耳鼻舌身意触不受。耳鼻舌身意触为缘所。生诸受。皆悉不受。诸苾刍。由如是故。一切法不受。以不受故。即远离尘垢。而得解脱。我生已尽。梵行已立。所作已办。不受后有。佛说是法时。会中有六十苾刍。不受诸法。得心解脱。余诸苾刍。亦悉知法。尔时世尊说是法已。与苾刍众。往诣杖林山。到已安止。世尊乃为诸苾刍。现三种神通。所谓神境通。说法通。教诫通。以如是神通。而示利喜。佛言。诸苾刍。汝等应当如是作意。如是伺察。如是了知。当如是行。即获利乐。时诸苾刍于是三种神通等事。而悉见闻。示利喜已。会中有得心解脱者。说是伽陀曰

  象头山与杖林山　　世尊说法现神变
  摄伏外道归正真　　使彼邪心皆解脱

尔时世尊谓苾刍众言。我今欲入王舍大城。时频婆娑罗王。初闻有如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。十号具足。出兴于世。于诸天人梵魔沙门婆罗门大众中。以自智力。而成正觉。宣说诸法。初善中善后善。文义深远。纯一无杂。圆满清白。梵行之相。彼佛会中。有优楼频螺迦叶。那提迦叶。伽耶迦叶。并诸眷属。归佛出家。修持梵行。是佛世尊今日欲入王舍大城。其王即敕修治王城内外。街巷道陌。悉令清净。烧众名香。散诸妙华。张设珠璎。树立幢盖。如是普遍处处严丽。乃至城中。一切人民。发欢喜声。互相得闻。时频婆娑罗王。被新妙衣。着众宝履。严整四兵。与无数眷属。前后导从。出王舍城。迎候世尊。其王与诸眷属。出城向远。渐近世尊。王乃下车。徒步而进

尔时世尊。与诸苾刍。前后围绕。诸王舍城。王及眷属。见佛远至。肃恭前迎。从佛入城。佛入城时。城中人民。异口同音。说伽陀曰

  世尊入此王舍城　　出现师子光明相
  解脱耆年清净众　　彼彼恭敬而围绕

尔时频婆娑罗王前导。世尊往迦兰陀竹林园中。到已世尊周遍观察。王乃为佛敷设其座。佛处座已诸苾刍众。各居佛后。是时王及眷属众中。有礼佛足者。有但合掌顶礼者。有发欢喜心者。有随发欢喜心即生爱乐者。如是各各伸敬已。退坐一面。王乃复从座起偏袒右肩。右手执持上妙金瓶。出妙香水。灌世尊手。灌已白言。我此园林。奉上世尊并四方僧。安止受用此。是最初园林布施。惟愿世尊。为我纳受。佛即为受。王礼佛足已。向尊者优楼频螺迦叶前。欢喜合掌。作如是言。迦叶此摩伽陀国中。一切人民。宗敬于汝。我亦常所尊重供养。汝今何所见闻。归佛出家。修持梵行。迦叶答言。大王当知。今佛世尊。具大神通。有大威力。能作种种神变等事。以是缘故。我发净信。归佛出家。时众会中。有生疑念。此优楼频螺迦叶。今在大沙门边。修持梵行。何所求耶。此能归心。佛能摄受。互见何相。致如是耶。又复众中。有作是言。此优楼频螺迦叶。今在大沙门边。修持梵行。不复能得频婆娑罗王恭敬供养

尔时世尊知众疑已。即告尊者优楼频螺迦叶言。迦叶。汝今知时。宜现神通。是时迦叶受佛敕已。随其所应。即入三摩地。犹如鹅王。起现空中。以神通力。身上出火。身下出水。身下出火。身上出水。右边出火。左边出水。左边出火。右边出水。于其四方。现行坐卧相。现是神通已。从空而下。还住佛前。偏袒右肩。右膝着地。合掌恭敬。顶礼世尊。作是白言。佛是我师。我是声闻弟子。若我所知。若我不知。佛悉能知。如佛所了知。是为最上知。佛言。迦叶。汝先所作事火之法。汝见何义。为于其中得寂静耶。能作染耶。如汝所作。皆不解脱。今问此义。汝随应答。迦叶白佛言。我无智故。先所不知。世尊大龙。善为救度。令我今时见无上句。世尊。我先所作。以饮食供设。然火祀天。实不解脱。而饮食者。设使美味种种具足。终不能离三欲之数。今蒙佛开导。我如是见。佛言。迦叶。又如汝所作事火等法。于天人世间。不可爱乐。迦叶白佛言。我今于佛正法。见最上句。住寂静意。毕竟不复堕于欲有。别异教中更不修习。是故弃舍事火等法。尔时尊者那提迦叶白尊者优楼频螺迦叶言。佛世尊者。证涅槃法。离过无染。最上清净。出世说法。广大利益。而汝迦叶。亦能善说

尔时尊者伽耶迦叶为频婆娑罗王说伽陀曰

  善来大王听我说　　我大居止伽耶山
  正等正觉出世间　　说涅槃句我得利
  佛最胜者大象龙　　无上调伏最上尊
  无畏善御诸众生　　三摩呬多心寂静
  我昔长夜心染污　　起诸邪见不解脱
  佛今破我邪见心　　一切缠结皆消散

是时众会疑念皆息。乃知尊者优楼频螺迦叶。并诸眷属。归佛出家。修持梵行。甚为希有

尔时世尊知彼众会已息疑心。乃为频婆娑罗王等。宣说法要。如先佛世尊所说法式。谓施论戒论生天之论。欲为染污。生诸过失。爱若不生心即离障。时王并诸眷属。闻是法已。咸发净信。归依佛法僧。受持学句。即于世尊。起安乐心。柔软心。最上心。离障心。无著心。善顺心。是时世尊知王及众心开意解。如先佛世尊所说法式。以无数方便。复为宣说苦集灭道四谛法门。时王并众不起于座。悉能了知苦集灭道四圣谛理。见法知法。得白净法。平等法。坚固法。安住法。无恚法。无坏法。无堕法。犹如白衣易受染色。王等获利。亦复如是。时王并诸眷属。蒙佛宣说法要。示利喜已。从座而起。顶礼佛足。是时有守空神。守种子神。守国界神。守事业神。守草神。守木神。守畜类神。守树林神。守道路神。如是诸神。咸作人言。互相谓曰。世尊具大神通。有大威力。能作种种神变等事。即说伽陀曰

  今日频婆娑罗王　　并诸眷属归依佛
  闻法获利竹林中　　我等诸神亦归佛

尔时频婆娑罗王。并诸眷属。右绕世尊。出离众会。复次王舍城有一外道。名删阇夜。与自眷属。居止其中。而删阇夜。后亡殁已。彼二弟子。一名舍利子。一名大目干连。是二弟子。弃舍彼众已。互相谓言。我等二人。若先有所证。必相告语。后于一时。有尊者乌波西那。食时着衣持钵。入王舍城。次第乞食。时舍利子。见彼尊者自远而来。诸根调寂。威仪整肃。即作是念。今此尊者威仪进止。希有最上。念已前诣问言。尊者汝师何人。复说何法。乌波西那答言。我师是大沙门。于大众中。决定宣说无屈伏力广大法门。舍利子言。汝今可能于彼法门。若少若多。为我宣说。乌波西那言。我师所说。缘生之法。缘生法者。谓一切法从因缘生从因缘灭。复以是义。说伽陀曰

  若法因缘生　　法亦因缘灭
  是生灭因缘　　佛大沙门说

时舍利子闻是法已。远尘离垢。得法眼净。即说伽陀曰

  如是缘生妙章句　　尊者为我善开示
  我于那庾多劫中　　不见不闻令得遇

说是伽陀已。又言。尊者世尊今在何处。乌波西那答言。世尊今在迦兰陀竹林精舍。又言。我今得诣世尊处不。彼答言。汝当随意。时舍利子忆念大目干连先所言约。今应往告。念已即往。时大目干连见舍利子进止威仪胜彼先时。知必证法。乃谓舍利子言。汝有所证耶。舍利子言。世尊所说缘生之法。乌波西那为我略说。我已证悟。如彼所说伽陀曰

  若法因缘生　　法亦因缘灭
  是生灭因缘　　佛大沙门说

大目干连闻是法已。远尘离垢。得法眼净

佛说此经已。迦叶等诸大声闻。及一切世间天人阿修罗乾闼婆等。闻佛所说。欢喜信受

佛说初分说经卷下


佛说除盖障菩萨所问经

    No. 489

佛说除盖障菩萨所问经卷第一

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

如是我闻。一时佛在象头山中。与大苾刍众七万二千人俱。皆是阿罗汉。诸漏已尽无复烦恼。心善解脱慧善解脱。如大龙王。诸有所作悉已成办。释诸重担逮得己利。尽诸有结。正智妙心俱得解脱。诸心自在到胜彼岸。善入法界建立法幢。心能弃舍一切利养。正善出家极善具圆。满足诸愿住涅槃道。唯一补特伽罗现居学地。所谓尊者阿难。诸菩萨摩诃萨八万四千人。皆是一生补处。获诸总持得一切智。现前趣向一切智。渐入一切智。增广一切智。得无碍总持诸三摩地。复能安住首楞严王妙三摩地。具大神通游戏自在。履轻安道。离诸所起一切障累。大慈大悲广遍十方一切世界。超越无边一切佛刹。通达空行及无相行诸愿离着。勤劬发起一切有情利益胜行。善入一切佛之境界。心如虚空具无边智。心如大海深无涯底。心如须弥山王坚固不动。心如莲华离诸染着。心如妙宝极善清净。心如真金精炼莹洁。其名曰宝星菩萨摩诃萨。宝手菩萨摩诃萨。宝印手菩萨摩诃萨。宝冠菩萨摩诃萨。宝髻菩萨摩诃萨。宝峰菩萨摩诃萨。宝积菩萨摩诃萨。宝顶菩萨摩诃萨。宝幢菩萨摩诃萨。金刚藏菩萨摩诃萨。金藏菩萨摩诃萨。宝藏菩萨摩诃萨。吉祥藏菩萨摩诃萨。净藏菩萨摩诃萨。净无垢藏菩萨摩诃萨。如来藏菩萨摩诃萨。智藏菩萨摩诃萨。日藏菩萨摩诃萨。等持藏菩萨摩诃萨。莲华藏菩萨摩诃萨。解脱月菩萨摩诃萨。普月菩萨摩诃萨。普贤菩萨摩诃萨。观自在菩萨摩诃萨。得大势菩萨摩诃萨。普光菩萨摩诃萨。普眼菩萨摩诃萨。莲华眼菩萨摩诃萨。广眼菩萨摩诃萨。普威仪道菩萨摩诃萨。普严相菩萨摩诃萨。普戒慧菩萨摩诃萨。智慧菩萨摩诃萨。法慧菩萨摩诃萨。胜慧菩萨摩诃萨。上慧菩萨摩诃萨。金刚慧菩萨摩诃萨。最胜慧菩萨摩诃萨。师子慧菩萨摩诃萨。师子游戏菩萨摩诃萨。大音声王菩萨摩诃萨。师子吼声菩萨摩诃萨。震吼深妙音声菩萨摩诃萨。无染着菩萨摩诃萨。离诸垢菩萨摩诃萨。月光菩萨摩诃萨。日光菩萨摩诃萨。智光菩萨摩诃萨。智吉祥菩萨摩诃萨。贤吉祥菩萨摩诃萨。月吉祥菩萨摩诃萨。莲华吉祥菩萨摩诃萨。宝吉祥菩萨摩诃萨。妙吉祥童真菩萨摩诃萨。如是等诸菩萨众而为上首

复有贤护等十六大士。慈氏等贤劫中一切菩萨摩诃萨众

四大王天主等。四大王天诸天子众。帝释天主等。忉利天中诸天子众。须夜摩天主等。夜摩天中诸天子众。兜率陀天主等。兜率陀天诸天子众。善变化天主等。化乐天中诸天子陀化自在天主等。陀化自在天中诸天子众。导师等。善分魔王子众。大梵天主等。梵众天中诸天子众。大自在天主等。五净居天诸天子众。毗摩质多罗阿修罗王。大力阿修罗王。罗睺阿修罗王等。无数百千阿修罗众。阿那婆达多大龙王。摩那斯大龙王。娑伽罗大龙王。阿难多大龙王。嚩苏枳大龙王等。无数百千龙王之众。吉祥威光龙王子等。无数百千龙王之子并诸龙女。及余无数百千天．龙．夜叉．乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人．非人．等大众集会。时象头山。遍四方面四由旬内。天人大众充满虚空。乃至无有一毛端量极微尘量之所空缺。于如是等天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等众会中间。敷佛所坐妙师子座。其座高一由旬。纵广正等各半由旬。严设无数百千天妙宝衣。宝铃宝网张设幰盖弥覆其上。复有无数百千天妙缯帛。周匝垂挂。散真珠华及诸妙华。又师子座周匝地方皆是金刚所成。严饰殊妙地平如掌。柔软清净妙香芬馥。无数百千天妙宝华散布其地。复有莲华大若车轮。无数百千黄金为叶。琉璃为茎。帝青为台。马脑为须。妙香可爱适悦快乐。如是庄严佛所受用。又复师子之座。于其四隅不近不远。有四宝树而极耸拔。高半由旬。周广盘郁三俱卢舍

尔时世尊在大众中处师子座。以极净慧转妙法轮。摧伏魔军不染世法。作师子吼明焕无畏。犹如大池清净无杂。又如大海广积妙宝深无涯底。如须弥山王高出众山。如日光明威耀赫奕。如满月轮人所爱乐。如大龙王能雨法雨。如大梵王世间最上。而佛世尊与无数百千俱胝那庾多梵王护世等无边善调伏者弟子众俱。是时大众一心诚谛瞻仰世尊

尔时世尊。先以常光照诸大众。于常光中复从顶上放大光明其名普照。是光复有无数百千光明眷属。其光即于十方一切世界普照耀已。旋环佛所右绕三匝。复从世尊口门而入。而佛世尊口门之相悉无动静。譬如日月光明悉从虚空界入。而虚空界亦无动静。佛之光明口门入时无动静相亦复如是。又如积以干沙投之酥油。或投以水。彼等入时悉无动静。佛之光明口门入时无动静相亦复如是

尔时东方去此佛刹过殑伽沙数等世界。有世界名大莲华。其中有佛号莲华眼如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。为诸菩萨宣说法要。彼所说法唯以一乘发起利益。彼佛刹中无有声闻缘觉名字。况复声闻缘觉乘法。又彼世界有情。皆修菩萨行法。得不退转于阿耨多罗三藐三菩提。又彼世界。不以饮食而为资养。彼诸菩萨。悉以等持静虑法喜为食。又彼世界。不以日月星宿而为照明。皆彼如来身光普照而悉清净。又复其土。无诸草木沙砾土石山等。地平如掌。彼有菩萨摩诃萨名除盖障。独止一处。若诸有情闻是菩萨名者。一切障累悉得蠲除

是时除盖障菩萨摩诃萨蒙佛光明之所照触。离自所止诣彼佛所。到已头面礼佛双足退住一面。并余菩萨各各蒙光所照触已悉离所止。咸来诣彼世尊莲华眼如来所。到已头面各礼佛足退住一面

尔时除盖障菩萨摩诃萨。即从座起偏袒右肩。右膝着于莲华台上。合掌顶礼白其佛言。世尊。何故有是光明。极善无垢清净悦意。使诸有情蒙光照者身心调畅

尔时莲华眼如来。告除盖障菩萨摩诃萨言。善男子。西方去此佛刹过殑伽沙数等世界。有世界名娑婆。其中有佛。号释迦牟尼如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。若诸有情闻彼如来名字之者。悉得不退转于阿耨多罗三藐三菩提。是彼如来所现此光明。即时除盖障菩萨摩诃萨复白佛言。世尊。何因何缘而诸有情闻彼如来名字之者。悉得不退转于阿耨多罗三藐三菩提。莲华眼如来。告除盖障菩萨摩诃萨言。善男子。彼佛如来往昔修行菩萨道时。发是愿言。愿我当来成正觉已。一切有情闻我名者。悉得不退转于阿耨多罗三藐三菩提。除盖障菩萨言。云何世尊。彼世界中一切有情悉得不退转邪。佛言。不也善男子。除盖障菩萨言。云何世尊。若然者亦有有情不闻彼佛名邪。佛言。善男子。一切皆闻。除盖障菩萨言。若皆闻者何故乃有不得不退转者。佛言。善男子。所言一切不退转。亦非一切不退转。除盖障菩萨言。如佛所说一切不退转亦非一切不退转。其义云何。佛言。善男子。若有有情得闻如来名字。生起不退转种子者。我说斯等有情得不退转。非是得闻如来名字。俱时皆得不退转地。善男子。我今复说譬喻以成斯义。譬如有树初植种子。而其种子离诸过失。后以诸缘得生牙茎。乃至滋长果实成结。善男子。彼树何故但说种子。除盖障菩萨言。世尊。由其种子离诸过失。乃至果实成办故说种子。佛言。善男子。得不退转有情亦复如是。由彼才闻如来名字之时。不退转种子生起具足。而其有情即于阿耨多罗三藐三菩提得不退转

尔时除盖障菩萨摩诃萨白莲华眼如来言。世尊。我今欲往娑婆世界。瞻睹世尊释迦牟尼如来应供正等正觉。礼奉亲近尊重供养。于是莲华眼如来告除盖障菩萨言。善男子。汝当可往今正是时。余诸菩萨俱白莲华眼如来言。世尊。我等亦欲往诣娑婆世界。瞻睹世尊释迦牟尼如来应供正等正觉。礼奉亲近尊重供养。时彼世尊。告诸菩萨言。善男子。汝等可往今正是时。然汝往彼世界勿生放逸。何以故。彼世界中诸有情类极贪嗔痴。无沙门婆罗门父母之想。非法欲行。暴恶粗犷。口出恶言。高倨轻慢。染着懈怠。破戒造恶。悭嫉增盛。如是多种烦恼随烦恼等。彼佛世尊。于如是等恶有情中而为说法。彼诸菩萨白其佛言。世尊。彼佛如来难行能行。于如是等恶有情中能为说法。佛言。诸善男子。如是如是。彼佛如来难行能行。恶有情中能为说法。又善男子。彼诸有情亦复如是。难行能行于彼杂染世界之中。能起一善心者斯为极难。何以故。若清净世界中。清净有情发起善心岂为希有。杂染世界之中能起善行者极为希有。能于一弹指顷发净信心。一弹指顷能归依佛及法僧宝。一弹指顷修持净戒。一弹指顷离贪着心。一弹指顷起悲愍意。发阿耨多罗三藐三菩提心极为希有。诸菩萨言。希有世界。希有善逝

尔时除盖障菩萨摩诃萨等诸菩萨众。咸叹善哉。于彼佛所如其行相。闻佛所言顺佛教敕。各各头面礼佛足已。从佛会出。俱时往诣娑婆世界。于世尊释迦牟尼佛所。作供养事。或有化现诸宝树者。枝干佣圆色相荣茂。华果具足。或现琉璃宝树。或现颇胝迦树。或现劫树。或真金树。或众华树。或众果树。或现妙宝衣云。或庄严云。或涂香云。或宝鬘云。或妙盖云。或末香云。或鼓乐云。如其所应各化现已。咸悉萃集前导。除盖障菩萨摩诃萨等诸菩萨众。来诣娑婆世界

尔时除盖障菩萨摩诃萨告诸菩萨言。仁者。彼娑婆世界诸有情等苦之深重。仁等宜应随其神力善化而往。使彼有情得胜妙乐。时诸菩萨闻是语已如教而行

尔时除盖障菩萨摩诃萨如其色相。以自神力作诸化事。即从身中放大光明。善妙无垢清净适悦。使诸有情蒙光照者身心调畅。是光普遍广照于此三千大千世界。而此三千大千世界之中。所有地狱饿鬼畜生等趣。诸有情类蒙光照触。皆得离苦息恚害心。互相皆起父母之想。又此三千大千世界之中幽隐暗暝。日月光明所不照处是光普照。所有日月具大神力。有大威德自在照耀。为此光明映蔽不现。悉无焰赫光耀之用。又此三千大千世界光明普照。其中所生诸有情类互得相见。又此三千大千世界。诸铁围山。大铁围山。目真邻陀山。摩诃目真邻陀山。宝山黑山及诸山等。其光普照。上至梵世下至阿鼻大地狱。于其中间一切方分而无光明所不照处

尔时诸菩萨众。随彼色相如其所应。亦以神力作诸化事。令诸有情须食者得食。须饮者得饮。须衣者得衣。须辈舆者得辇舆。须财者得财。盲者能视。聋者能听。裸者得覆。迷乱之者还得正念。苦者得乐。诸怀妊者产生无难

佛说除盖障菩萨所问经卷第一佛说除盖障菩萨所问经卷第二

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

尔时除盖障菩萨摩诃萨等菩萨众。来诣于此象头之山去山不远。彼诸大士。俱时化现殊妙宝网。遍覆三千大千世界。又于空中雨众天华。及天果云。天宝鬘云。天涂香云。天衣服云。天末香云。及天上服宝盖幢幡诸供具云。广大化现随所现已。而诸有情皆得瞻睹。悉能获得最上快乐。彼象头山所有树林。即时自然离其地方。别现种种微妙宝树。劫树华树果树。栴檀香树。沉水香树。彼等皆是神力所化。又于空中。自然出妙天鼓音声。于鼓音中说伽陀曰

  龙弥尼园最胜生　　不以烦恼种等比
  稽首无等如虚空　　故我来此最胜山
  坐胜道树成菩提　　警觉摧伏魔力军
  稽首持胜无垢光　　故我来此最胜山
  如幻如焰如水月　　此等理法悉觉了
  稽首最上大福树　　故我来此最胜山
  觉了世法如戏剧　　巧现众法如帝弓
  稽首无动胜福藏　　故我来此最胜山
  久远历于多百劫　　为欲圆满悲心故
  稽首无垢月面尊　　故我来此最胜山
  多百俱胝菩萨众　　诸天供养亦复然
  稽首已离痴暗瞑　　故我来此最胜山
  已得最上圣法藏　　悲所成身弃世财
  稽首无等作大利　　故我来此最胜山
  住寂静心常慈意　　如莲在水离诸染
  稽首胜上持功德　　故我来此最胜山
  妙相开华清净身　　随形众好世资养
  稽首宝树无边枝　　来此供养愿摄受

其鼓音中说是伽陀已。尊者大目干连即从座起。偏袒右肩右膝着地。合掌向佛而白佛言。世尊。何故今时现是瑞相。昔所未闻。昔所未见。佛告尊者大目干连言。东方去此佛刹过殑伽沙数等世界。有世界名大莲华。彼佛世尊号莲华眼如来应供正等正觉。现住说法教化利益。彼佛刹中有菩萨摩诃萨名除盖障。与彼无数俱胝那庾多百千菩萨大士。同来诣此娑婆世界。彼众将至故先现瑞。说是语已。除盖障菩萨摩诃萨。与无数俱胝那庾多百千菩萨之所围绕。各以广大神通威力。来诣佛所。到已头面各礼佛足。时除盖障菩萨摩诃萨说伽陀曰

  具大名称大胜慧　　得大无畏大牟尼
  已度生死险难中　　稽首出过烦恼岸
  汝为普遍炽焰光　　汝为普遍大灯炬
  汝得一切解脱门　　稽首归命无等等
  坚固不动如山王　　深广无底如大海
  一切邪外不能破　　稽首称赞大法王
  本来寂静法无生　　自性如是常寂灭
  我法圣尊善开明　　稽首转大法轮者
  或有宣说诸正道　　或说趣入真实理
  或说涅槃正妙门　　或说授记成觉果
  有情心意汝悉知　　是中无少不知者
  有情观汝法行圆　　是故随奉汝教敕
  所有贪嗔痴三毒　　及余种种垢染等
  坐道树成正觉尊　　以大智火悉焚爇
  汝自得度度有情　　汝自解脱利世间
  汝于世间善所求　　永破生死诸险难
  无智久沈于睡眠　　有情流转生死轮
  善为开觉汝圣尊　　稽首等视如亲爱
  汝观此诸大士众　　一切安住菩提道
  皆欲听闻妙法门　　唯愿世尊随为说

尔时除盖障菩萨摩诃萨说是伽陀赞叹佛已。时佛敕令处莲华台一面而坐。余诸菩萨大众。佛亦敕令随其所应处莲华台一面而坐

尔时除盖障菩萨摩诃萨。从座而起偏袒右肩。右膝着于莲华台上。合掌向佛而白佛言。世尊。我今欲问如来应供正等正觉。若佛世尊垂见听者。我当发问愿为宣说

佛告除盖障菩萨摩诃萨言。大士。恣汝所问斯为常事。诸佛如来亦悉听许随其所疑。如来为汝一一宣说

尔时除盖障菩萨摩诃萨。承佛圣旨即白佛言。世尊。诸菩萨摩诃萨。云何修行即得布施具足。复云何得持戒具足。云何得忍辱具足。云何得精进具足。云何得禅定具足。云何得慧具足。云何得方便具足。云何得愿具足。云何得力具足。云何得智具足。云何得菩萨如地。云何得如水。云何得如火。云何得如风。云何得如虚空。云何得如月。云何得如日。云何得如师子。云何调伏。云何了知。云何得如莲华。云何得广大心。云何得清净心。云何得无疑惑心。云何得如海智。云何得微妙智。云何得智辩才。云何得解脱辩才。云何得清净辩才。云何得一切有情欢喜辩才。云何得信顺语。云何得正法语。云何得随法行。云何善入法界。云何住空境界。云何得无相行。云何得诸愿离着。云何得慈身。云何得悲身。云何得喜行。云何得舍行。云何得神通游戏。云何得离八难。云何得不忘失菩提心。云何得宿命智。云何得不舍善知识。云何得常离恶知识。云何获得如来法性之身。云何获得金刚真实之身。云何得大导师。云何得善知诸道。云何善说无颠倒道。云何得常安住妙等引心。云何着粪扫衣。云何持三衣。云何常坐不卧。云何常乞食。云何一坐食。云何食后不饮浆。云何受阿兰若法。云何树下坐。云何空地坐。云何死尸间住。云何节量食。云何随敷座。云何得相应行。云何持经。云何持律。云何持论。云何于轨范所行及威仪道而得具足。云何得离悭嫉二法。云何于一切有情起平等心。云何于佛如来善作供养承事。云何能摧伏诸慢。云何能广多净信。云何善知世俗。云何善了胜义。云何善知诸缘生法。云何知自。云何知他。云何能于清净佛土中生。云何能离胎藏垢染中生云何能得舍家出家。云何能得净命自资。云何能得心无懈倦。云何得受诸佛教敕。云何获得熙怡面相。云何得离颦蹙之相。云何得多闻。云何得正法摄受。云何得法王子。云何能得胜出梵王帝释护世天等。云何能知有情心意。云何能知成熟有情诸有法式。云何能成智者。云何能得常处妙乐。云何善知四摄之法。云何获得妙相具足。云何得为他所依止。云何得如大妙药树。云何乃能勤修福行。云何善了诸变化事。云何速能证得阿耨多罗三藐三菩提果

尔时世尊。赞除盖障菩萨摩诃萨言。善哉善哉。善男子。如汝所问斯为极善。悲愍世间能令天人大众获善利乐。能问如来如是等义。汝今谛听极善作意。当为汝说。于是除盖障菩萨摩诃萨受教而听。佛言。善男子。菩萨若行十种施法。即得布施具足。何等为十。一者法施。二者无畏施。三者财施。四者不求饶益果施。五者悲愍施。六者不轻慢施。七者恭敬施。八者供养承事施。九者无所著施。十者清净施。善男子。云何法施。谓若菩萨。不以财利心。自所受法即于他人随应教授。不以希欲利养恭敬因故。不望他人所知识故。不求名称故。不以余事因故。但自思惟。何等有情受诸苦恼。我为蠲除即以是法。亦复不怀希求之心。无二平等为他宣说。若复为王及与王臣之所宣说。或为旃陀罗及旃陀罗子说法亦然。何况余诸人众。而菩萨行是法施时不起高心。善男子。如是名为菩萨法施。云何是无畏施。谓若菩萨自所嫌弃刀杖等器。亦复教示他人令弃。于彼一切有情。起如父想如母想如子想。如眷属想及余亲爱知友之想。何以故。菩萨作是思惟。如佛所说。彼彼生中一切转易。于诸有情聚中。未曾有不是父母及子并余亲爱知友。乃至于彼微细情命之中。皆为发起利益。设自身肉尚亦与之。何况余诸大有情类。善男子。如是名为菩萨无畏施。云何是财施。谓若菩萨。或见有情造极不善业。即时以财摄彼有情由财摄已。是故令其于不善业而悉除断。于诸善业使彼安住。菩萨作是思惟。如佛所说。布施是菩萨菩提。菩萨所行布施。除断三种不善之法。一嫉二悭三贪。是故我于如来所受布施之法。彼所布施而无高心。善男子。如是名为菩萨财施云何是不求饶益果施。谓若菩萨所行布施。不以希欲为因。不以财利为因。不以眷属为因。不以世间近事为因。菩萨修持布施法尔如是。彼因彼缘所行布施。远离一切饶益果报。善男子。如是名为菩萨不求饶益果施。云何是悲愍施。谓若菩萨见诸有情受诸苦恼。或饥渴者。或裸露者。或秽污残缺之者。无主无救无归无依之者。无福者等。菩萨见已生悲愍心。我为此等有情故。发阿耨多罗三藐三菩提心。念此无主无救无依归等诸有情类流转生死。而我今当以何方便为此有情为主为救与作依归。作是念时。菩萨由此悲心所逼。即以方便随为摄受。菩萨摄受彼等有情。俱时所起善根而无高心。善男子。如是名为菩萨悲愍施。云何是不轻慢施。谓若菩萨行布施时。不以轻重分别故施。不以慢心故施。不以毁谤故施。亦不令他劳力故施。不恃豪富骄恣故施。不希名称故施。不恃多闻倨慢故施。菩萨若行施时。心必恭敬尊重。专注供养亲奉施之。善男子。如是名为菩萨不轻慢施。云何是恭敬施。谓若菩萨于轨范师亲教师及余所应尊重之者修梵行者。身极恭顺心极尊重。由恭顺尊重故发言慰安。合掌顶礼稽首承迎于其有情。即以彼彼善相应事而普及之。善男子。如是名为菩萨恭敬施。云何是供养承事施。谓若菩萨或作佛事或法僧事。若于如来塔像之所。或扫去尘秽。或严饰清净。或以妙香华及涂香等而为供养。又或修治如来故坏塔庙。是为佛事。何名作法事。所谓随闻何等法门。即当受持书写读诵思惟修习。及为他解说。或以无颠倒相应修学。是为法事。何名作僧事。谓以衣服饮食坐卧之具病缘医药奉施众僧。乃至但以少分清冷之水而为供施。是为僧事。善男子。如是名为菩萨供养承事施。云何是无所著施。谓若菩萨行布施时起如是心。我今所行布施。不求天报或天之余。不求王报或王之余。善男子。如是名为菩萨无所著施。云何是清净施。谓若菩萨随其所说布施之法。即起伺察。如其彼彼起伺察时。于布施法伺察得无过失。无垢染无障难邪。善男子。如是名为菩萨清净施。菩萨若能修此十法者。即得布施具足。又善男子。菩萨若修十种戒法者。当得持戒具足。何等为十。一者别解脱戒行。二者菩萨摄律仪戒行。三者离诸烦恼烧然戒行。四者离不深固作意戒行。五者怖业戒行。六者怖罪戒行。七者怖非所取戒行。八者坚固志意戒行。九者无依着戒行。十者三轮清净戒行。善男子。云何是别解脱戒行。谓若菩萨。于诸如来所有经中。或戒律中及余学句所宣示处。如善作意尊重大师所说。于一一法中如理修学。不爱着氏族不爱着所见。不爱着众会。无我人过失。于彼学句中而生尊重。善男子。如是名为菩萨别解脱戒行。云何是摄律仪戒行。谓若菩萨作是伺察。我于别解脱戒中。不能取证阿耨多罗三藐三菩提果。谓若如来于一一经中。宣示菩萨所行及菩萨学句。我当于彼如理修学。何等是菩萨所行。所谓菩萨。无非处非方非时。所行无非时。所说无不知时。无不知方。无不知量。何以故。或有有情。于如来所生不信心。为令彼等生信解故。及彼有情随为摄护故。菩萨自能圆满菩提胜行。善具威仪。柔软容缓。不杂阓闹。趣寂止门极清净门。此是菩萨所行。何等是菩萨学句。谓若如来于一一经中宣示菩萨所学之法。菩萨于中而生信顺不生障难。此是菩萨学句。善男子。如是名为菩萨摄律仪戒行

佛说除盖障菩萨所问经卷第二佛说除盖障菩萨所问经卷第三

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。云何是离诸烦恼烧然戒行。谓若菩萨或贪火烧然。或嗔火烧然。或痴火烧然。或余烦恼之火烧然。或余诸受用侵害火烧然。若欲不烧然者。当起贪之对治。及应远离贪所起缘。何谓贪之对治。即不净观是贪对治。不净观者。谓自身中诸不净物。发毛爪齿涎泪涕唾。淡荫垢汗大小便利。皮肤血肉骨髓肪膏。脑膜筋脉脾肾心肺。肝胆肠胃胞及肚胘。凡如是等诸不净物。菩萨应当作此观想起是思惟。世间所有彼愚痴者。不明解者。造不善者。尚能了知诸如是等不净物已。不处贪心。况智者乎。此为菩萨多种不净之观是贪对治。何者是贪所起缘。谓着诸欲染。或见女人端严妙色。起可爱心而生希取。尔时见已当作是观。如佛所说梦境无实。何故智者。于此如梦境界之中而起贪心。是名菩萨远离贪所起缘。何谓菩萨嗔之对治。及远离彼嗔所起缘。所谓菩萨。于诸有情所多起慈心。以此慈心及此因缘。而彼忿恚嗔怒有情心意皆能摄伏。嗔恚因缘悉得远离。是名菩萨嗔之对治。及远离彼嗔所起缘。当作如是观察之时即离痴法。离痴由故彼诸所欲及诸受用。不为侵害之火烧然。此等是为菩萨离诸烦恼烧然戒行。云何是离不深固作意戒行。谓若菩萨独处一方寂静而住。不起是心。我不杂乱所行。我寂静住。我复能行如来法律。余诸沙门或婆罗门。彼等皆是杂乱所行多诸阓闹。而悉坠失如来法律。若能不起如是心者。是为菩萨离不深固作意戒行。云何是菩萨摄善法戒行。谓若菩萨作是伺察。如佛所说。诸苾刍应当尊敬修福尊敬护戒尊敬修慧。何以故。尊敬福者。福是现受可爱精光悦意果报。如是信者而能远离诸不善业。是为菩萨摄善法戒行。云何是怖罪戒行。谓若菩萨或有如微尘罪。见悉生怖不顺所作。乃至少罪亦不生轻。作是思惟。如佛所说。诸苾刍。譬如有人中于少毒亦趣命终。若中多毒亦趣命终。诸有罪者。若少若多皆堕恶趣。若作如是伺察之时。菩萨于罪乃生恐怖。是为菩萨怖罪戒行。云何是怖非所取戒行。谓若菩萨或有具信沙门婆罗门及余人众。信菩萨故。或以金银摩尼真珠珊瑚琉璃螺贝珍宝财物及余受用之具。于菩萨所嘱累寄托。虽或单己而菩萨心。不起贪着辄生希取。又复于诸塔寺之物。及众僧物设使有人劝令掌执。菩萨于中亦不希取为自资养。作是思惟。如佛所说。菩萨宁自割其身肉而啖食之。终不以他不与不许若饮若食。及余物等而怀希取。是为菩萨怖非所取戒行。云何是坚固志意戒行。谓若菩萨或为魔王或诸魔众及余天等。或现女相。或以余缘来作魔事之所娆恼欲破坏时。而菩萨不动不摇亦无减失。是为菩萨坚固志意戒行。云何是无依着戒行。谓若菩萨持戒行时。不起是念。我所持戒为求天报或天之余。为求王报或王之余。是为菩萨无依着戒行。云何是三轮清净戒行。谓若菩萨身业清净。语业清净。意业清净。身业清净者。谓远离身三不善业。一杀生二偷盗二邪染。如是名为身不善业。语业清净者。谓远离语四不善业。一妄言二两舌。三恶口四绮语。是名语不善业。意业清净者。谓远离意三不善业。一贪二嗔三邪见。是名意不善业。由能远离诸不善业。是故即得三轮清净。是为菩萨三轮清净戒行。善男子。菩萨若行如是十法。即得戒行具足。善男子。菩萨若修十种法者。即得忍辱具足。何等为十。一者安受苦忍。二者外忍。三者谛察法忍。四者佛许可忍。五者无定方忍。六者无差别忍。七者不以事因故忍。八者耐怨害忍。九者悲心忍。十者愿力救拔忍。善男子。云何是安受苦忍。谓若菩萨或自心有忧悲苦恼。随生起时。菩萨安然悉能忍受不起嗔心。是为菩萨安受苦忍。云何是外忍。谓若菩萨亲闻他人所出恶言。或展转闻。因其毁谤父母师长亲友知识。或有恶言谤佛法僧。菩萨闻已不生嗔恨。是中安然悉能忍受。是为菩萨外忍。云何是谛察法忍。谓若菩萨若闻如来所说最极甚深经中。有法能断轮回种子。脱诸结缚坏相续者。谓一切法本来寂静。及一切法自性涅槃。菩萨得闻如是法已。不生惊怖作是思惟。若不了知此法。及不得此法者。岂能证得阿耨多罗三藐三菩提果邪。由此因缘故。应于如是甚深法中。受持思惟修习伺察及生胜解。是为菩萨谛察法忍。云何是佛许可忍。谓若菩萨设起忿恚嗔害心已。即当伺察此恚害心。从何所起复何处灭。何因故生生复何住。作是观时都不见有恚害之法。若生若灭二法可得。随生即灭。若因若缘亦不可得。以是缘故。菩萨于中安然忍受。无复生起佛所许可。是为菩萨佛许可忍。云何是无定方忍。谓若菩萨非于昼分能忍。夜不能忍。或夜能忍。昼不能忍。自国能忍。他国不能忍。或他国能忍。自国不能忍。惯习者能忍。不惯习者不能忍。菩萨不然。于一切国一切处一切时一切种皆悉能忍。是为菩萨无定方忍。云何是无差别忍。谓若菩萨不于己之父母师长眷属亲友知识等处能忍。余诸人所而不能忍。何以故。菩萨乃至于旃陀罗眷属等处。有所侵恼而悉能忍。是为菩萨无差别忍。云何是不以事因故忍。谓若菩萨所起忍行。不以财利因故。不以怖畏故。不为资养故。不以世间近事故。不为隐覆惭耻等故忍。何以故。菩萨常行忍辱心故。是为菩萨不以事因故忍。云何是耐怨害忍。谓若菩萨或无他缘来加其恶。菩萨尔时即无所忍。或时怨对若执刀杖。若复持拳起嗔怒心而来打击。或复期克恶语骂詈。菩萨见如是等他怨对来打击骂詈之时。坚固其心深自伏忍。作是思惟。此等怨对皆是我之自业所感。业成熟已来相逼恼。诚非父母眷属亲友所造。皆是自业造作所成熟故。而亦非外地界水界火界风界之所成熟。又亦非内四大成熟。菩萨作是思惟时。由此因缘故。于有怨害及无怨害。平等其心皆悉能忍受。是为菩萨耐怨害忍。云何是悲心忍。谓若菩萨设得王位。或为臣佐。大富自在威德特尊。见诸有情多苦恼者。而彼有情。于其王所生忿恚心。而来毁骂及诸娆乱。其王尔时不生嗔恚。不恃尊豪而行凌逼。作是思惟。此诸有情我之向化。我应为彼作其救护。是故我今不恃王之威相。但为彼等作其卫护使不破坏。以是因缘。悲心起故安然忍受。是为菩萨悲心忍。云何是愿力救拔忍。谓若菩萨作是思惟。我于如来应供正等正觉所。作师子吼发是愿言。愿我得成阿耨多罗三藐三菩提果已。普为救拔一切有情出生死海。我所勤行救拔一切有情不取其相。但为令诸有情悉得解脱。令诸有情其心调伏住奢摩他。菩萨尔时若自心生嗔恚。不能忍者如佛所说。善男子。譬若有人善疗眼疾。能除患者昏翳暗障。时医眼师。作是思惟。我欲普令除去患者所有昏翳。医师忽然自丧其目。善男子。于汝意云何。而彼医师能疗眼不。答言不也。佛言。善男子。菩萨亦复如是。欲以慧眼开导世间一切有情愚痴暗瞑。而菩萨若自为彼痴暗所覆。即不能与一切有情除去暗瞑。是故菩萨于诸损恼。不生嗔恚安然忍受。是为菩萨愿力救拔忍。善男子。菩萨若修如是十种法者。即得忍辱具足。又善男子。菩萨若修十种法者。即得精进具足。何等为十。一者被甲精进。二者无能胜精进。三者离二边精进。四者利乐精进。五者加行精进。六者相续精进。七者清净精进。八者不共精进。九者不随他教精进。十者无高心精进。善男子。云何是被甲精进。谓若菩萨发大精进。普为一切有情。未得涅槃者令得涅槃。未得度者悉令得度。未解脱者普令解脱。未安隐者而令安隐。未成正觉者当使成正觉。菩萨发行是精进时。或有魔来欲令断坏菩萨胜行及生娆恼。魔作是言。善男子。汝今宜应止此精进。何以故。我亦曾发此之精进。普为一切有情。未得涅槃者令得涅槃。未得度者悉令得度。未解脱者普令解脱。未安隐者而令安隐。未成正觉着当使成正觉。此等皆是不实妄失之法。愚人诤论之语。善男子。我不曾见有人发如是精进。能令一有情得阿耨多罗三藐三菩提者。我但知彼无数俱胝有情。趣证声闻缘觉涅槃。善男子。以是缘故。应须退转于阿耨多罗三藐三菩提心。若不然者。汝所发精进。徒增烦恼唐捐其功。魔作是言已。菩萨乃自思惟。此诸恶魔伺求其便欲来娆我。菩萨知是事已乃谓魔言。汝今勿应逼迫于我。汝于世间但勿有虑。如佛所说。世间一切从自业种子所生长故。自所造作彼彼之业。是所归趣。今汝亦然。自业种子所生长故。自所造业是所归趣。汝今速应从所来道还归本处勿复娆我。娆乱我故使汝长夜于诸有情苦恼逼迫作不饶益。时彼恶魔潜伏退屈。即于是处隐而不现。菩萨于是诸恶魔众或魔天等来娆乱时。而菩菩心不惊不怖亦不怯弱。是为菩萨被甲精进。云何是无能胜精进。谓若菩萨随其诸相发起精进。如所起时而为最胜。正使余诸久修道行菩萨。比此菩萨精进胜行。数分算分乃至乌波尼杀昙分皆不及一。何况声闻缘觉。何以故。菩萨随起一念精进之心。具诸胜力即能普摄一切佛法。断诸恶法故。是为菩萨无能胜精进。云何是离二边精进。谓若菩萨所起精进。不应增剧不应沉下。何以故。若增剧时其心高倨。若沉下时即生掉举。离此二者。乃名菩萨精进胜行。是为菩萨离二边精进。云何是利乐精进。谓若菩萨发是精进。愿我此身得与佛身而相等比。愿我得佛无见顶相。及佛圆光相好具足。及无能胜无边胜智。佛大威德。佛胜自在。菩萨为是等故发起精进。是为菩萨利乐精进。云何是加行精进。此加行者。譬如有人取摩尼宝。或真金等。磨莹治炼去诸瑕垢。悉使其宝明净精洁光色赫奕。尔时方见摩尼真金焕然有异。菩萨亦复如是。于诸精进中加行修治。使去垢染即离过失。精进垢者。所谓懈怠是精进垢。沉下是精进垢。饮食不知节量是精进垢。妄执主宰是精进垢。不依正法是精进垢。不深固作意是精进垢。诸精进中有是垢染乃名过失。是故菩萨若离此者。即得洁白清净自性明亮。是为菩萨加行精进。云何是相续精进。谓若菩萨于诸威仪道中所起精进。随所起时若身若心而不懈倦相续无间。是为菩萨相续精进。云何是清净精进。谓若菩萨即彼所起相续精进行中。所有诸不善业。及于障碍菩提道法。无利义事常当除断。若诸善法。谓随顺涅槃顺正道行。趣向菩提菩提分法。使诸善法悉令广大而复增长。乃至于一念间尚不起于极微不善之法。何况粗重等诸过失。是为菩萨清净精进。云何是不共精进。谓若菩萨作是思惟。假使普遍十方殑伽沙数等世界。从于阿鼻大地狱中出大火聚。充满是等世界都为一聚。过是世界之外。若一有情受极苦恼。无主无救无依归者。我宁忍受其苦履践。是等世界越其火聚。至彼有情所而为救度。何况微小之苦不能忍受。菩萨所发如是精进。不与一切声闻缘觉邪外等辈之所共有。是为菩萨不共精进。云何是不随他教精进。谓若菩萨不同声闻之人起如是心。凡夫位中求佛菩提极为难得。我所发精进而甚微少懈怠劣弱。我若为求菩提。假使顶上然火经多百千俱胝劫数。如是勤行亦不能成。故我不能堪忍其苦。亦复不能荷斯重檐。菩萨应起是心。所有过去诸佛已成正觉者。现在诸佛现成正觉者。未来诸佛当成正觉者。诸佛世尊皆为求菩提故勤行精进。彼彼如是修诸胜行。而诸佛如来。亦不但为己故求成正觉。今我亦然。勤行精进成诸胜行。亦不但为己故。所有善根普与一切有情共之。为有情故发起情进。我所求成阿耨多罗三藐三菩提果。普为利乐一切有情。亦不自利取证涅槃。为有情故我宁常处大地狱中。乃为胜上。是为菩萨不随他教精进。云何是不高心精进。谓若菩萨所发精进时。亦不于中而生味着。不毁谤他不自称赞。菩萨作是思惟。若不勤行自事警策于他何名智者。是故菩萨所起胜行而不高心。是为菩萨无高心精进。善男子。菩萨若修如是十种法者。即得精进具足。

佛说除盖障菩萨所问经卷第三佛说除盖障菩萨所问经卷第四

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

复次善男子。菩萨若修十种法者。即得禅定具足何等为十。一者广集福德。二者多生厌患。三者发起精进。四者具于多闻五者无颠倒教授勤行修习。六者随正法行。七者根性明利。八者具纯善心。九者善了止观。十者不着禅相。云何是广集福德。谓若菩萨于大乘法中久积善根。彼彼生中善修戒行。为善知识之所摄受。随所生处常生婆罗门大族姓家。或刹帝利大族。或长者大族。皆具正信。于彼生中以其因缘。转复广大增长善根。而常不离于善知识。何者是善知识所。谓佛及菩萨。而能增长宿世善根。由惯习力故。作是思惟。世间大苦世间灾患。世无暂停久受萦缠痴暗所覆。彼等皆由贪欲为因贪欲为缘。了此因缘是为菩萨广集福德。云何是多生厌患。谓若菩萨以是缘故乃起思惟。我今不应于此世间合曾相中。染着亲近诸欲境界。而诸欲者虚妄分别。如世尊言。常以多种因缘毁呰贪欲。所谓欲如利叉。欲如利戟。欲如剑锋。欲如刀锋。欲如毒蛇。欲如聚沫。欲如痈疽。欲极臭秽。如是欲境心生厌恶。乃剃除须发被袈裟衣。发正信心舍家出家。是为菩萨多生厌患。云何是发起精进。谓若菩萨由出家故发起精进。未得法者皆令得法。未悟者令悟。未证者令证。是为菩萨发起精进。云何是具于多闻。谓若菩萨由此因缘。能听能受诸有所说。世俗谛法及胜义谛法。是为菩萨具于多闻。云何是无颠倒教授勤行修习。谓若菩萨。于其世俗胜义二种法中。能正教授勤行修习。无颠倒法。是为菩萨无颠倒教授勤行修习。云何是随正法行。谓若菩萨于正见正思惟正语正业正命正勤正念正定此等正法中。菩萨如是行即觉了正道。是为菩萨随正法行。云何是根性明利。谓若菩萨由行正法故。辩慧明了利根转胜。是为菩萨根性明利。云何具纯善心。谓若菩萨利根胜故多生厌患。远离大众一切愦闹。及世杂语欲觉嗔觉害灭等觉皆悉远离。亦复不着知识亲爱名闻利养所欲等事。身心寂静得纯善心。由善心故作是观察。今我此心于何法中行。若善若不善若无记邪。若行善法即得欢喜清净心生。何者是善法所谓三十七菩提分法。若行不善法者。当起厌患多种观察。勤行断除不善之法。何者是为不善之法谓贪嗔痴。贪有三种上中下品。上品贪者。若身若心极其分位。而生染着无离贪心。由染着故于一切处不生惭愧。何者是无惭。谓独止一处作是思惟。而起寻求诸所欲事。称赞欲境自现有德。是为无惭。何者是无愧。由彼贪欲因缘。于父母等前违背很戾及生恼害。于余师尊之所亦无耻忸。自现有德是为无愧。以是因缘。命终之后堕恶趣中。此名上品贪。中品贪者。谓若亲近诸欲境时。自初至末虽复暂有所成。旋起离贪之心即生变悔。此名中品贪。下品贪者。谓若亲近诸欲境时。或身相触或共语言或瞻视间。旋起即灭。此名下品贪。总要而言。一切济命受用资具。有所欲者皆名下品贪。嗔有三种上中下品。上品嗔者。随于所起诸嗔境中。生极嗔恚而复暴恶。遍造五无间罪。或随造一无间罪。或谤正法。凡如是等总聚五无间罪。算分数分及譬喻分。乃至乌波尼杀昙分。皆不能及。由此因缘。身坏命终堕大地狱。若或暂得生于人间。身相黑色其目赤恶。性多恚暴。此因缘故。还堕地狱。此名上品嗔。中品嗔者。随于诸嗔境中若暂起已。或微分造不善罪业即速变悔。旋起对治而令止息。此名中品嗔。下品嗔者。谓于亲爱和合境中。随以嗔缘辄生轻谤。虽复暂起于刹那间即生变悔。旋起对治而令息灭此名下品嗔。痴有三种上中下品。上品痴者。谓一切处若行若止。悉无善作亦无忧戚。不生变悔此名上品痴。中品痴者。若起少分不善之业。虽有所成即速变悔。于同梵行人所。忏谢其罪不现己德。此名中品痴。下品痴者。谓于如来所制戒中不越性罪。违犯初篇戒学之罪。此名下品痴。菩萨离是染法即得心善寂静。由是善故能离欲爱欲贪诸欲染着。何以故。随心善故。若行无记法者。谓即想念勤行伺察。何等是无记。若心不缘外。亦不缘内。不缘善不缘不善。不住止法。不行观法。其心沉下着于睡眠。如人睡觉目视不明。若无记心现前。心不明利亦复如是。是故菩萨若行善心。即得心生欢喜其心安住。是为菩萨具纯善心。云何是善了止观。谓若菩萨由具如是纯善心故能观诸法。此法如幻此法如梦。此法不善此法是善。此法出离此法非出离。菩萨作是思惟。彼一切法。心为依止心为先导。应当善摄其心。善调伏心。善觉了心。由此即能善摄诸法。亦善调伏及善觉了。如是即能正观诸法。此因缘故得心寂止。以心系心。以心止心。以心住心。如是策勤心寂止故。即得心一境性。心一境故。即成三摩地。三摩呬多。由是现前得离生喜乐。由喜乐心故即能远离罪不善法。乃能成就有寻有伺离生喜乐初禅定法。次复于诸寻伺悉无对碍。于其喜乐不生味着。作无常观已。还从初禅定心渐次而起。远离寻伺有所著心。即能成就无寻无伺定生喜乐二禅定法。次复于乐观苦作苦观已。即得舍行舍念行成。如圣所观。能正觉了妙乐现前。即能成就离喜妙乐三禅定法。次复于三禅定中。作空观已引四禅心。彼四禅中除去我执。我执离故苦乐悉断。苦乐断故如先所起。悦意恼意亦悉舍离。即能成就舍念清净四禅定法。次复于自身相与虚空相等作一解脱。观如是解脱故。于一切处一切种类。过诸色想及离障碍。由过色想离障碍故。彼种种想悉无作意缘。无边虚空而为行相。即能成就空无边处定法。次复于空无边处。俱时观彼识无边处而为行相。即能成就识无边处定法。次复过彼识无边处。缘无所有处而为行相。即能成就无所有处定法。次复过彼无所有处。缘非想非非想处。而为行相。即能成就非想非非想处定法。次于上心无复行相。灭诸想受离诸发悟名灭尽定。如是等法。是为菩萨善了止观。云何是不着禅相。谓若菩萨虽入灭定。亦不乐着寂灭。即能俱时发起慈心。悉离怨亲违顺等境运心广大。先于一方起慈无量行。普遍观察作解脱已。南西北方四维上下亦复如是。慈心起已悲喜舍心亦悉如前。远离怨亲违顺等境运心广大。周遍十方起悲喜舍无量之行。普遍观察悉作解脱。菩萨如是即能起五神通。亦不以自足不着禅相。而复进求上法圆满菩提胜行。是为菩萨不着禅相。善男子。菩萨若修如是十种法者。即得禅定具足。又善男子。菩萨若修十种法者。即得胜慧具足。何等为十。一者善解无我。二者善知业报。三者善了有为之法。四者善知轮回流转。五者善解轮回出要之法。六者善解声闻缘觉乘法。七者善解大乘之法。八者善能遮止魔业。九者具无颠倒慧。十者具无等慧。善男子。云何是善解无我。谓若菩萨以正慧观察色受想行识。观彼色时色生不可得。集亦不可得。灭亦不可得。受想行识生不可得。集不可得。灭不可得。彼胜义谛不离世俗谛。若胜义谛若世俗谛。彼二自性但有言说。假名而无实体。菩萨虽如是观。亦不以此缘弃舍诸行发勤精进。为诸有情成利益事。如救头然及如烧衣。是为菩萨善解无我。云何是善知业报。谓若菩萨作是伺察。今此世间合会之相。犹如幻化及如乾闼婆城自性皆空。若于情非情中着于我执。彼等有情由是不能觉了正道。而彼有情作如是念。若无我无有情无寿命蠕动养者。士夫补特伽罗。意生摩拏嚩迦等。即无善不善业而可表示。谁为受者。无实有情业报可得。菩萨虽复如实了知无实有情。而亦显彰善恶业报。菩萨以其正慧如实了者。是为菩萨善知业报。云何是善了有为法。谓若菩萨于有为法中。以其正慧能善觉已。乃作是念。此有为法。而无暂停念念流动。犹如露滴及如涧水迅流不住。岂有智者。于此等法中。而生取着及起爱乐。若乐境谢时或生忧戚。由此因缘。是故深生厌离乐求寂灭。是为菩萨善了有为法。云何是善知轮回流转。谓若菩萨作是伺察。今此世间合会之相。无明暗蔽轮回相续。皆由爱绳所系缚故。爱故生取由取因故善不善业诸行造作。以彼善不善业行起作故。有有相续。有故有生生故老死。由死法故忧悲苦恼随起缠缚。如是即一大苦蕴集。而生死轮相续流转。犹汲水轮宛转上下。菩萨以其正慧于此等法如实了知。是为菩萨善知轮回流转。云何是善解轮回出要之法。谓若菩萨作是伺察。若无无明即无行。无行即无识。无识即无名色六处触受爱取有生。无生即老死忧悲苦恼等法。皆悉断灭。菩萨以其正慧。于此等法如实觉了。是为菩萨善解轮回出要之法。云何是善解声闻缘觉乘法。谓若菩萨作是伺察。此法得须陀洹果。此法得斯陀含果。此法得阿那含果此法尽漏断诸有结。不受后有究竟涅槃。得阿罗汉果。此法得缘觉果如犀一角。菩萨于如是等果。以其正慧如实了已。然亦不于彼法之中而为取证。何以故。菩萨作是思惟。我摄受一切有情作师子吼。我应为彼一切有情。于生死旷野险难之中与作救拔。我今不应独出生死。菩萨起是行愿坚固。是为菩萨善解声闻缘觉乘法。云何是善解大乘。谓若菩萨于诸学门能善修学。然于学时而不可得。于所学道亦不可得。菩萨虽于彼相不可得故。亦不以彼因缘堕于断见。是为菩萨善解大乘。云何是善能遮止魔业。谓若菩萨于一切处。常离恶知识亦不至恶国。复不亲近修习外道典籍。于一切处而常远离世间利养供给等事。及余烦恼等障菩提道者而悉除遣。即起对治破坏之法。是为菩萨善能遮止魔业。云何是具无颠倒慧。谓若菩萨于世间一切文论典章诸事业中。悉以胜慧引入修学。菩萨学者。但为成熟诸有情故。不为知识名称所欲等事。不显己德。谓以如来法律。是为最上最胜言说具大威德。由显如是胜功德故。精勤修学终不堕于外道邪见。是为菩萨具无颠倒慧。云何是具无等慧。谓若菩萨于世间天人魔梵沙门婆罗门诸有情中。无与菩萨智慧等者。而菩萨慧中唯除如来应供正等正觉智慧最胜。世间天人魔梵众中无复过上。是为菩萨具无等慧。善男子。菩萨若修如是十种法者。即得胜慧具足。又善男子。菩萨若修十种法者。即得方便具足。何等为十。一者善解回向方便。二者善回外道诸见方便。三者善回五尘境界方便。四者善除疑悔方便。五者善知救度有情方便。六者善解有情济命方便。七者善知受施方便。八者善回二乘趣入大乘方便。九者善知示教利喜方便。十者善知供养承事如来方便。善男子。云何是善解回向方便。谓若菩萨于其一切非己所有无摄属者。若华若果若众香树。若妙香树。若诸宝树。若[疊*毛]树。若华树。若果树。非己所有无摄属者。常当昼三时中夜三时中。想作供养诸佛菩萨。以彼善根回向阿耨多罗三藐三菩提。又于佛说广大甚深经中。诸供养法听已深心而生信乐。以此善根回向诸佛菩萨。又于十方世界一切菩萨。及诸有情所作一切善业圆满菩提行者。菩萨深心而悉随喜。以此善根回向阿耨多罗三藐三菩提。又于如来塔庙。或于如来像前。以华香涂香布施供养。当愿一切有情蠲除破戒秽恶之香。普愿一切有情获得戒香清净。又若扫塔涂地之时。当愿一切有情离诸恶相。获得相好端严具善威仪又以华盖供养佛时。当愿一切有情离诸烦恼烧然。又若入塔寺时即起是念。当愿一切有情入涅槃城。出塔寺时即起是念。当愿一切有情出离生死。又于所止若开户时即起是念。当愿开诸善趣出世智门。若闭户时即起是念。当愿扃闭诸恶趣门。若随坐时即起是念。当愿一切有情坐菩提场。若右胁卧时即起是念。当愿一切有情悉作如是右胁涅槃。若或起时即作是念。当愿一切有情超出烦恼淤泥。若动止时即作是念。当愿一切有情获得大人所行所止。若安住时即起是念。当愿一切有情离诸忧恼。若大小便利时即起是念。当愿一切有情涤除烦恼垢染过失。若盥手时即起是念。当愿一切有情蠲除烦恼秽气。若濯足时即起是念。当愿一切有情除去种种烦恼尘坌。若嚼齿木时即起是念。当愿一切有情离诸垢染。乃至身诸分位。若运用时皆愿一切有情悉得利益安乐。若于如来塔庙作礼奉时即起是念。当愿一切有情悉得天人尊重礼奉。是为菩萨善解回向方便

佛说除盖障菩萨所问经卷第四佛说除盖障菩萨所问经卷第五

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

复次善男子。云何是善回外道诸见方便。谓若菩萨于左啰迦波哩没罗惹迦尼乾陀等诸外道处。作诸化事。使其调伏为欲成熟。彼因缘故。菩萨作是思惟。此等外道我慢贡高。我今不应先行师教。要先恭事现为弟子。然后使其调伏。于彼法中而求出家。如其所行策勤修学。随诸外道种种法式。多闻苦行咸悉究尽而复过胜。彼众推许有所言说悉皆听受。如奉师尊不相违戾。由得亲近诸外道故。乃呵毁言。诸仁者。汝此所修非出离道。亦非离欲。又非寂灭。由是渐能使彼调伏。而令安住如来法中。文复于彼具五神通诸外道所学修梵行。随其所修而复勤行。令得彼法随能成办。外道所修禅定之法。即能胜过彼诸外道。勤勇进修难行之行。于外道中智者共许。菩萨知其根成熟时。于其所修禅定之法。乃呵毁言。诸仁者。汝修定法非出离道。亦非离欲。又非寂灭由是渐次使令安住如来法中。是为菩萨善回外道诸见方便。云何是善回五尘境界方便。谓若菩萨或见有人极多贪爱。菩萨不以别异方便。但随所乐而为调伏。乃以神力化现女身。端正殊妙胜诸女人。是人见已极生贪着。时化女身于刹那间。变成死尸烂坏臭秽。彼贪爱人见即惊怖。乃生厌患逼恼其心。作如是言。云何速能离此臭秽。尔时菩萨即住其前如应说法。彼贪染人随得离欲。是为菩萨善回五尘境界方便。云何是善除疑悔方便。谓若菩萨或见有人造五无间业。或诸不善业。即诣其所而语之言。汝今何故愁不悦意。是人答言。善男子。我造五无间业。以是缘故愁不悦意。将非我于长夜之中。无有利乐极大苦恼。菩萨乃为其人说戒忏悔。又复如应说甚深法。是人未能舍疑悔心。菩萨即现神通适其心念使令生信。是人即时于菩萨所。乃起信心清净欢喜。由喜心故堪任受法。菩萨引之令入正道。于其人前。化现父母而加杀害。谓其人言。我今与汝同造斯罪勿生疑悔。作是语已复现神通。是人念言。菩萨具有神通智慧犹害父母。况复我邪。尔时乃为是人说种种法。使其罪业而得轻微犹如蚊翅。是为菩萨善除疑悔方便。云何是善知救度有情方便。谓若菩萨或见有人堪任受法。然以是人造极恶业。菩萨为欲度斯等故随应化现。若以王身得度者。即现王身。若以宰官身得度者。即现宰官身。若以刹帝利婆罗门庶民等身得度者。即现刹帝利婆罗门庶民等身。若以天身得度者。即现天身。若以金刚力士身得度者。即现金刚力士身。若以柔善可爱之身得度者。即现彼身。若以恐畏絷缚鞭打等身得度者。即皆现之。若复有人。欲造五无间业。或有人欲于菩萨所生触娆者。菩萨乃以种种方便悉令禁止。或置之异方使其不造无间业等。后于其前作诸化现。乃至或现地狱等相。又复诸有未得神通菩萨寿量色相。菩萨悉知。又诸有情欲成欲坏。菩萨起大悲心悉能思念。此有情欲坏。此有情已坏。菩萨一心如实了知。如观掌中庵摩勒果。菩萨起厌离心作是思惟。若一有情造恶业已。将堕阿鼻大地狱中。彼之定业。我复无异方便能为救拔。我宁代受地狱之苦。乃至彼一有情安住无余依涅槃界中。是为菩萨善知救度有情方便。云何是善知有情济命方便。谓若菩萨或见有情无所堪任。复无力能不识正法。但贪饮食衣服而无余求。菩萨乃为斯等。显示书算伎术种种事业。如是善者悉令学习随有所得使其济命。是为菩萨善知有情济命方便。云何是善受供养方便。谓若菩萨或得宝聚如须弥山菩萨亦受。或得诸余微毫之物菩萨亦受。何以故。菩萨作是思惟。世间有情悭贪谄曲。以是缘故如水中鱼。而常出没生死大海。菩萨深愍斯等有情。使令长夜利益安乐。是故受已不摄于己不起贪心。周给于余一切有情。而复施作佛法僧事。诸贫苦者遍行拯济令诸施主心生欢喜。是为菩萨善受供养方便。云何是善回二乘令入大乘方便。谓若菩萨或见二乘之人堪任阿耨多罗三藐三菩提器者。菩萨乃于声闻缘觉乘中。以其方便回转彼心令住大乘。乃至彼之徒众亦令转舍二乘之心。是为菩萨善回二乘令入大乘方便。云何是善知示教利喜方便。谓若菩萨未发菩提心者。使令发心。若虽已发心而懈怠懒惰。以少戒行为喜足者。当为策勤进修诸行。若于戒学有少缺坏。以是缘故生障碍心。不起清净欢喜心者。菩萨如应为说法要。以善方便使令发起清净之心。是为菩萨善知示教利喜方便。云何是善知供养承事如来方便。谓若出家菩萨。得少财利而生喜足。唯求法利独止一处寂静而住。作是思惟。我今何故不起想念供养如来。即时运心想以种种供养诸佛。随想念时便能圆满六波罗蜜多。云何观想能具六波罗蜜多。谓若想作供养事时。即具布施波罗蜜多。若于供养法中。令一切有情起所缘善心。即具持戒波罗蜜多。若于供养法中。发生欢喜爱乐之心。即具忍辱波罗蜜多。若于供养法中心不懈退。即具精进波罗蜜多。若于供养法中寂住其心。即具禅定波罗蜜多。若于供养法中庄严众行。即具般若波罗蜜多。是为菩萨善知供养承事如来方便。善男子。菩萨若修如是十种法者。即得方便具足。又善男子。菩萨若修十种法者。即得诸愿具足。何等为十。一者不卑下发愿。二者不畏生死发愿。三者出过一切有情发愿。四者诸佛称赞发愿。五者善降诸魔发愿。六者不以他缘故发愿。七者无边发愿。八者不恐怖发愿。九者不懈退发愿。十者善具圆满发愿。云何是不卑下发愿。谓若菩萨不于三有中欲受乐故。而乃发愿。是为菩萨不卑下发愿。云何是不畏生死发愿。谓若菩萨。不厌患三界。不求离欲。不趣寂灭故发愿。是为菩萨不畏生死发愿。云何是出过一切有情发愿。谓若菩萨发如是愿。乃至普尽诸有情界。愿彼一切得大涅槃已。然后我当亦入涅槃。是为菩萨出过一切有情发愿。云何是诸佛称赞发愿。谓若菩萨发如是愿。普尽有情界中。未发菩提心者。普愿一切发菩提心。已发心者。次第修行菩萨行已坐菩提场。我皆一一恭敬供养。然后劝请转妙法轮。若欲入涅槃时。亦悉劝请令久住世利益有情。是为菩萨诸佛称赞发愿。云何是善降诸魔发愿。谓若菩萨发如是愿。如我所行。我及一切有情当成正觉时。其佛刹中不闻魔声。况复魔众。是为菩萨善降诸魔发愿。云何是不以他缘故发愿。谓若菩萨。不由他缘故发阿耨多罗三藐三菩提愿。何以故。菩萨以自胜慧。观察有情界中种种苦恼为救度故。乃发阿耨多罗三藐三菩提愿。是为菩萨不以他缘故发愿。云何是无边发愿。谓若菩萨所发愿者无限方分。何以故。谓菩提行广大无量无有边际。菩萨当发愿时。偏袒一肩右膝着地。于诸世间心生厌患。发是愿言。普观十方一切世界。诸菩萨众现修苦行者。现坐菩提场成等正觉转法轮者。愿诸菩萨观照我心乃至说法度脱。得度脱已我悉随喜。以是随喜善根。回向阿耨多罗三藐三菩提。是为菩萨无边发愿。云何是不恐怖发愿。谓若菩萨从初发心闻甚深法。或闻诸佛有大甚深威德之力。或闻菩萨游戏神通甚深法门。或闻诸佛善巧方便甚深之法。闻已皆悉不惊不怖。菩萨作是思惟。佛菩提无边。佛境界无边。诸佛世尊成熟有情亦悉无边。我之智力而不能知。唯佛与佛乃能究尽。是为菩萨不恐怖发愿。云何是不懈退发愿。谓若菩萨或见有情[怡-台+龍]戾难调。以斯等故。生弃舍心欲生净土。我不愿闻此等有情诸恶名字。菩萨虽以此缘。不应弃舍利有情事。何以故。菩萨具悲智故。起如是心遍有情界中。诸有少智起劣精进。痴盲喑哑无涅槃分者。悉为诸佛菩萨呵毁弃舍。斯等有情普愿于我刹中。悉令发起阿耨多罗三藐三菩提心。乃至坐菩提场成等正觉。菩萨发是心时。一切魔宫皆悉震动。诸佛赞叹严净佛土。速证阿耨多罗三藐三菩提果。是为菩萨不懈退发愿。云何是善具圆满发愿。谓若菩萨誓愿坐于大菩提场。降伏魔军证阿耨多罗三藐三菩提果。此上无复更求余愿。善男子。譬如钵器盛酥或油。若平满已无复更受一尘之滴。菩萨亦复如是。成正觉已无复减少一尘之愿。是为菩萨善具圆满发愿。善男子。菩萨若修如是十种法者。即得诸愿具足。又善男子。菩萨若修十种法者。即得诸力具足。何等为十。一者无能胜力。二者无屈伏力。三者福力。四者慧力。五者徒众力。六者神通力。七者自在力。八者陀罗尼力。九者不动加持力。十者不越教敕力。云何是无能胜力。谓若菩萨力无能胜。一切外道二乘。无与菩萨力齐等者。是为菩萨无能胜力。云何是无屈伏力。谓若菩萨具胜力故。于有情聚中。无能屈伏菩萨力者。是为菩萨无屈伏力。云何是福力。谓若菩萨世出世间诸有福行无不积集。是为菩萨福力。云何是慧力。谓若菩萨于佛法中正慧悉知。无有少法不见不证不觉了者。是为菩萨慧力。云何是徒众力。谓若菩萨。所有徒众。不缺戒行。不坏正见。不越法式。不染净命。何以故。菩萨徒众。同其菩萨正直行故。是为菩萨徒众力。云何是神通力。谓若菩萨所有世间神通之力。尚能超胜一切声闻缘觉神通境界。而此菩萨胜上神力。于一微尘中。而能容受阎浮提世界。及四大洲。小千世界。中千世界。大千世界。或一殑伽沙数世界。乃至不可说不可说殑伽沙数。是等世界。于一微尘中悉容受已。而微尘不增世界不减。其中有情不相触碍。是为菩萨神通力。云何是自在力。谓若菩萨力自在故。欲使三千大千世界。七宝充满随其所欲。乃至不可说不可说世界。悉能充满种种珍宝。是为菩萨自在力。云何是陀罗尼力。谓若菩萨于不可说不可说佛刹中。诸佛世尊所说之法。诸名句文种种义理。于刹那间悉能受持解了修习。是为菩萨陀罗尼力。云何是不动加持力。谓若菩萨胜加持力所加持故。诸有情中无能亏动菩萨力者。唯除如来应供正等正觉。是为菩萨不动加持力。云何是不越教敕力。谓若菩萨于有情中。而不见有敢违菩萨教敕之者。唯除善巧方便利益等事。是为菩萨不越教敕力。善男子。菩萨若修如是十种法者。即得诸力具足

佛说除盖障菩萨所问经卷第五佛说除盖障菩萨所问经卷第六

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

复次善男子。菩萨若修十种法者。即得诸智具足。何等为十。一者人无我智。二者法无我智。三者无方分智。四者知定境界智。五者加持智。六者不坏智。七者善观一切有情诸行智。八者无发悟智。九者善解一切法相智。十者出世间智。云何是人无我智。谓若菩萨观诸蕴生及诸蕴灭。若蕴生时。观法无实虚妄不坚。若蕴灭时。观法离散亦无所至。菩萨作是思惟。此诸蕴中。无我人有情寿者养者。而愚夫异生执着于我乃起是念。蕴中有我邪。我中有蕴邪。我不是蕴邪。蕴不是我邪。由是计执不了真实。由不了故如旋火轮展转生死。菩萨于如是法悉如实知。是为菩萨人无我智。云何是法无我智。谓若菩萨若诸法成若诸法坏悉如实知。菩萨作是思惟。此于假法之中分别建立。而彼诸法无实自性。乃至文字亦无自性。但唯忆想分别。世俗所行不应于彼而生取着。然其世俗假借诸法而亦非无。谓以诸法藉缘而有。法从缘生法从缘灭。如是等法菩萨悉知。是为菩萨法无我智。云何是无方分智。所谓菩萨之智无局方分。非但一刹那中智能随转。第二刹那智不随转。何以故。菩萨之智于刹那中。普遍一切随转随现。是为菩萨无方分智。云何是知定境界智。谓若菩萨能知声闻所修之定。知缘觉定。知菩萨定。知如来定。若声闻所修禅定境界菩萨随知。若缘觉所修禅定境界菩萨随知。若菩萨所修禅定境界菩萨随知。若如来所行禅定境界菩萨亦知。然非宿报所成己之智力而能了知。但以如来威神力故乃能知之。余诸定法以自智力悉可了知。是为菩萨知定境界智。云何是加持之智。谓若菩萨于声闻所有加持之法如说能知。缘觉加持如说能知。菩萨加持如说能知。况复于余诸有情邪。是为菩萨加持之智。云何是不坏智。谓若菩萨得不坏智已。诸魔外道及一切声闻缘觉无能沮坏。是为菩萨不坏智。云何是能观一切有情诸行智。谓若菩萨以其无著无断清净之智。普观一切有情界中而悉能见。或有有情发菩提心者。或有不发菩提心者。或有满足菩提行者。或有不满足菩提行者。或有住初地者。或有乃至住十地者。或有现成正觉者。或有成正觉已转法轮者。或有广作一切化利事已入大涅槃者。或有入声闻乘涅槃者。或有入缘觉乘涅槃者。或有生于善趣之者。或有生于恶趣之者。此如是等。菩萨之智悉能观察。是为菩萨观一切有情诸行智。云何是无发悟智。所谓菩萨于行住坐卧四威仪中悉无发悟。而菩萨之智自然常转。譬如人睡俱无动作。而出入息自然常转。菩萨之智亦复如是。于一切处无碍而转。是为菩萨无发悟智。云何是知一切法智。谓若菩萨善知一切法平等之相。一相。种种相。如幻相。虚妄分别等相。悉如实知。是为菩萨知一切法相智。云何是出世间智。谓若菩萨具无漏智。出过一切世间之智。是为菩萨出世间智。善男子。菩萨若修如是十种法者。即得诸智具足。又善男子。菩萨若修十种法者。即得胜行如地。何等为十。一者如地广大无量。二者存济一切有情。三者远离损恼饶益等育有情。四者普能容受大法云雨。五者为诸有情共所依止。六者能生善法种子。七者为大宝器。八者为大妙药。九者不可倾动。十者不生惊怖。善男子。云何是如地广大无量。譬如大地周遍广大无其限量。菩萨亦复如是。福智胜行周遍广大无其限量。是为菩萨如地广大无量。云何是存济一切有情。譬如大地周给一切有情彼彼所须受用之物。菩萨亦复如是。以施戒忍精进禅慧等法。及无数种菩提行法。随其所应普能摄受化度有情。是为菩萨存济一切有情。云何是远离损恼饶益等育有情。譬如大地损恼无戚饶益无忻无此二想。菩萨亦复如是。于诸有情损恼无戚饶益无忻平等利乐。于一切处不生忻戚。是为菩萨远离损恼饶益等育有情。云何是普能容受大法云雨。譬如大地大云含润一切悉能容受任持。菩萨亦复如是。如来兴大密云注大法雨。如其所说悉能容受亦悉任持。是为菩萨普能容受大法云雨。云何是为诸有情共所依止。譬如大地一切有情若行若止悉依于地。菩萨亦复如是。一切有情依止菩萨故。生于善趣向涅槃道。是为菩萨为诸有情共所依止。云何是能生善法种子。譬如大地一切种子依地而植依地而生。菩萨亦复如是。一切有情善法种子。悉依菩萨种植生长。是为菩萨能生善法种子。云何是为大宝器。譬如大地种种珍宝由地而生。是故地者即大宝器。菩萨亦复如是。种种功德智宝皆由菩萨所现。是故菩萨即大宝器。是为菩萨为大宝器。云何是为大妙药。譬如大地世间所有一切药草。悉依地生而能治疗种种病苦。菩萨亦复如是。现大法药普疗世间一切有情诸烦恼病。是为菩萨为大法药。云何是不倾动。譬如大地一切蚊蚋虻虫湿生等类。及彼大风不能倾动。菩萨亦复如是。一切有情所起内外诸缘苦恼等事悉不能动。是为菩萨不可倾动。云何是不生惊怖。譬如大地一切龙王鹿王哮吼震响。闻已皆悉不生惊怖。菩萨亦复如是。闻诸魔外道声已不生惊怖。是为菩萨不生惊怖。善男子。菩萨若修如是十种法者即得如地。又善男子。菩萨若修十种法者即得如水。何等为十。一者善法如水流润赴下。二者种植诸善法种。三者信乐欢喜。四者渍坏诸烦恼根。五者自体无杂清净。六者息除烦恼炎炽。七者能止诸欲渴爱。八者深广无涯。九者高下充满。十者息诸烦恼尘坌。云何是善法流润赴下。譬如大水奔流赴下润泽滋长。菩萨亦复如是。所修善法流润赴下滋长有情。是为菩萨善法如水流润赴下。云何是种植诸善法种。譬如大地种植一切树林药草由水滋溉增长成结。菩萨亦复如是。广植一切菩提分法种子。定水滋溉数数增长。乃至得成一切智树。以其一切智树获成立故。种种佛法果实繁茂。普为一切有情存济慧命。是为菩萨种植诸善法种。云何是信乐欢喜。譬如大水自性流润复润于他。菩萨亦复如是。自性爱乐净信欢喜。复能令他一切有情爱乐净信欢喜。爱乐者。所谓乐求出世间法。净信者。信佛法僧。欢喜者。心得清净。是为菩萨信乐欢喜。云何是渍坏诸烦恼根。譬如大地树林草木为水浸渍而悉溃坏。菩萨亦复如是。以其所修禅定之水。浸渍一切有情烦恼根种。以溃坏故烦恼根种不相续生。秽恶习气亦悉除灭。是为菩萨渍坏诸烦恼根。云何是自体无杂清净。譬如大水自体无杂而复清净。菩萨亦复如是。自体无杂本性清净。自体者。为离所起随烦恼等。无杂者。不杂贪嗔痴法。清净者。守护诸根极善清净。是为菩萨自体无杂清净。云何是息除烦恼炎炽。譬如夏月地极炎炽人亦烦热。水能除解悉得清凉。菩萨亦复如是。以其法水息除一切有情界中烦恼炎炽逼迫之苦。是为菩萨息除烦恼炎炽。云何是能止诸欲渴爱。如世间人渴爱所逼水能解除。菩萨亦复如是。一切有情为诸尘境渴爱所逼。菩萨雨大法雨。悉为解除离诸渴爱。是为菩萨能止诸欲渴爱。云何是深广无涯。譬如大水众流合会深广无涯。菩萨亦复如是。胜智积集深广无涯。诸魔外道。而悉不能得其涯涘。是为菩萨深广无涯。云何是高下充满。譬如大水无碍流注一切地方而悉充满。虽复满已亦不损恼一切有情。菩萨亦复如是。注大法雨普润一切有情界中高下充满。虽复满已亦不损恼一切有情。何以故。菩萨大悲心故。是为菩萨法雨流注高下充满。云何是息诸尘坌。譬如大水流润一切尘坌所覆涩恶地方。悉使润泽息诸尘坌。菩萨亦复如是。普为一切粗恶心者。悉令发起柔软之心。乃以胜慧所依定爱之水。流润一切有情息诸尘坌。是为菩萨息诸烦恼尘坌。善男子。菩萨若修如是十种法者即得如水。又善男子。菩萨若修十种法者即得如火。何等为十。一者能烧烦恼之薪。二者成熟佛法。三者能干一切烦恼淤泥。四者如大火聚。五者作光明照。六者能使惊怖。七者能作安慰。八者随所得利与诸有情共之。九者人所供养。十者人不轻慢。善男子。云何是能烧烦恼之薪。譬如大火能烧大地药草丛林杂类等物。菩萨亦复如是。以智慧火能烧所起贪嗔痴等及随烦恼。是为菩萨能烧烦恼之薪。云何是成熟佛法。譬如大火依地所生一切种子及诸药等悉能成熟。菩萨亦复如是。以智慧火内能成熟一切佛法。如所成熟随得不坏。是为菩萨成熟佛法。云何是能干一切烦恼淤泥。譬如大火能干一切湿物及淤泥等。菩萨亦复如是。以智慧火能干一切有漏淤泥。是为菩萨能干一切烦恼淤泥。云何是如大火聚。譬如寒苦诸有情类得大火聚而能温暖。菩萨亦复如是。以智慧火悉能温暖烦恼寒病所逼有情。是为菩萨如大火聚。云何是作光明照。譬如有人于雪山顶或民陀山顶燃大火聚其火光明周一由旬或二三由旬普遍照耀。菩萨亦复如是。以智光明周遍照耀。广一由旬或百或千。乃至无量无数世界。智光普照一切有情。智光照故。而诸有情无智暗冥悉得破散。是为菩萨作光明照。云何是能使惊怖。譬如大火所有恶兽或恶兽王。见彼火聚而悉惊怖四散驰走离其窟穴。菩萨大智威德亦复如是。若魔若天见菩萨已悉生惊怖。弃自所有劣弱威光。离彼地方远远而去。永不得闻菩萨名字。况复见身。是为菩萨能使惊怖。云何是能作安慰。譬如有人或于旷野险难之中迷失方所若见火聚知有聚落或牧放处。即诣其所心得安慰离诸惊怖菩萨亦复如是。一切有情。处于生死旷野险难之中。见菩萨已心得安慰。悉离一切烦恼恐怖。是为菩萨能作安慰。云何是随所得利与一切有情共之。譬如大火一切有情共所受用。若王若旃陀罗童子等无有差。菩萨亦复如是。随得利养受用资具。悉与一切有情共之。若王若旃陀罗童子等无有差。是为菩萨随所得利悉与一切有情共之。云何是人所供养。如世间火诸婆罗门刹帝利或民庶等皆悉奉事而为供养。菩萨亦复如是。世间一切天人阿修罗等皆悉奉事。作诸供养如诸佛想。是为菩萨人所供养。云何是人不轻慢。如微小火人不敢轻。何以故。以能烧故。菩萨亦复如是。若信解行住。菩萨于大乘中。初始发心虽未具力。能世间天人阿修罗等不敢轻慢。何以故。是诸天人阿修罗等。知彼菩萨不久当坐道场证阿耨多罗三藐三菩提果。是为菩萨人不轻慢。善男子。菩萨若修如是十种法者即得如火。又善男子。菩萨若修十种法者即得如风。何等为十。一者如风无碍行故。二者所行境界无边际故。三者如风破散坠堕有情高慢山故。四者吹布广大法云雨故。五者息除一切世间烦恼炎炽故。六者不动一切有情善法济命长养故。七者无量法云含润任持大法雨故。八者大法种种庄严楼阁布饰妙好故。九者一切众会劫树庄严决定常出正妙法音雨华悦意故。十者阿僧祇劫。洁白圣会建立积集三摩地解脱总持门海布妙高山日月光明法教丛林。善妙宫殿轮围山等。及一切有情成熟调伏庄严。善住无上无身依止。随转智风曼拏罗解脱因故

佛说除盖障菩萨所问经卷第六佛说除盖障菩萨所问经卷第七

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。云何是菩萨如风无碍而行。善男子。如世间风于一切处无依无著亦无色相。而能于彼一切宫殿楼阁。及须弥山大海等处。如所作事而悉能作。菩萨智风亦复如是。于一切处亦无所著。而能施设蕴处界等彼一切法。蕴者所谓色受想行识。界谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。处谓眼处色处。耳处声处。鼻处香处。舌处味处。身处触处。意处法处。乃至世间法出世间法。及天人转轮圣王。梵王帝释护世诸天。大自在天。声闻缘觉。诸菩萨地一切智等。虽有所作悉无住着。彼一切处无住着故。若有性若无性。若一性若异性。真如性等。虽无数心意而无种异。及无造作复无所缘。悉是无障解脱境界。是故梵王帝释护世天等。如理而作十方无边际诸世界中。一切有情及有情事悉令获得。于一切处皆成办已。乃至最后边际劫中隐而不现。而法身者。不可分别非不可分别。是为菩萨如风无碍而行。云何是菩萨所行境界而无边际。如世间风能于十方无量世界。开发成办一切种子。菩萨智风亦复如是。于普遍无边世俗胜义一切法中。广大显现开觉安布。及广宣说如来众会。菩萨众会。世间一切众会。随思随行以无碍心。于诸方处一切通达而无边际。是为菩萨所行境界而无边际。云何是菩萨如风破散坠堕有情高慢山峰。如世间风一切山石丛林宫殿。悉能吹击破散坠堕及隐覆等。菩萨智风亦复如是。所有憍慢耽迷执有身见高倨。有情恃于色相盛年豪贵。身力长寿无病轻安。及伎艺多闻聪利眷属富有辩才。以是等事恃着憍醉。此诸有情。由是缘故起我相心违背正道。菩萨能为宣示胜法破彼慢心。使令善得离染清净。是为菩萨如风破散坠堕有情高慢山峰。云何是菩萨吹布大法云雨。如世间风吹发大云从四方起。众色云轮震吼甚深软美音声。海潮之声。及其种种歌咏之声。响亮无间清妙悦意。电鬘庄严普遍弥覆。俱胝那庾多百千世界。悉能吹发。一切世间所可爱乐。苗稼种子及诸林树。而常降澍种种宝雨。菩萨智风亦复如是。出现种种妙身相云。光明遍照十方世界。一切有情所可爱乐。最上色相光明电鬘而为庄严。出如实法音及六十千胜妙音声。菩萨大悲之风。普高法界普摄一切世间。广覆一切世界。拯拔一切恶趣难处诸有情类。现一切相好光明轮。清净光明加持照耀。一切有情悉成正行坏灭邪行。雨大法雨众庄严具而为庄严。建立一切世界最上喜悦。令诸天人悉置最上喜乐之处。所有一切世出世间。善法种子药草丛林而悉种殖。一切吉祥时分授法灌顶。是为菩萨吹布大法云雨。云何是菩萨息除一切世间烦恼炎炽。如世间风扬激善妙清凉之水。普息有情炎热之苦。使诸有情清凉适悦。菩萨智风亦复如是。一切有情贪嗔痴等。恶趣恶见恶作邪行。极恶贫穷耽爱境界。冤憎会苦。爱别离苦。众病逼恼及法爱等。此诸炎炽皆能息灭。法水灌注得最上清凉。以不空愿力。若见若觉悉无障碍。是为菩萨息除一切世间烦恼炎炽置诸有情处无忧地。云何是菩萨不动一切有情善法而能济命长养。如世间人出息入息风力持故而得活命。菩萨亦复如是。以其智风成办有情一切善法。使诸有情悉得具足皆生欢喜。复次善男子。如世间风悉能成立一切世界。种种庄严殊妙可爱。所谓金刚轮围。小铁围山大铁围山及四大洲。金轮所持大海诸宝。须弥山大须弥山及余宝山。乃至雪山香醉山等。诸宫殿楼阁。阎浮提四大洲。小千世界中千世界。三千大千世界。菩萨智风亦复如是。悉能发起成办一切有情广大福蕴。次第安布如成雪山。应作是见即是所成世间福蕴。如成四大洲须弥山。应知即是所成声闻。如成小千世界。应知即是所成缘觉。如成中千世界。应知即是所成菩萨广大之相。如成三千大千世界。应知即是所成如来百福身相。高出一切世间。普尽虚空一切世界。极妙清净最上称赞。布设一切最胜供养所缘事相。如是一切现前成已。常住三摩呬多如成大海应知即是所成三摩地海。如成大洲中洲及余山石四大洲等。应知即是诸陀罗尼。化度有情诸学众等。如成宫殿楼阁及诸丛林。应知即是清净佛刹功德庄严。如成劫树种种变化。应知即是十地十波罗蜜多十三摩地诸陀罗尼。六通三明诸智光明十自在等。菩萨及佛力无畏不共法大悲等。最上自在广大之法。善男子。此中何等是诸佛世尊百福之相。善男子。譬如满一劫中积集十方。而一一方各有阿僧祇殑伽沙数等世界。是诸世界中所有有情。一切皆具十三千大千世界之数小转轮王所有福蕴。以如是等具小转轮王福蕴之者。诸有情类彼彼福蕴总聚较计。与一大转轮王福蕴相等。又过东方一切世界。是等世界中所有有情。各各皆具一大转轮王福蕴如前所说。乃至十方尽虚空界一切世界中一切有情。各各皆具大转轮王所有福蕴。以此之数较计。如是有情福蕴。与一帝释福蕴相等。又若十方。彼一一方各有阿僧祇殑伽沙数等世界。一一世界有情皆具帝释福蕴。是诸帝释。总而聚之为一帝释。即以如是之数。尽虚空遍法界一切世界有情。皆具如上帝释福蕴。以此之数较计。如是有情福蕴。与一大梵天王福蕴相等。又若十方。彼一一方各有阿僧祇殑伽沙数等世界。彼彼世界有情。皆具大梵天王福蕴。是诸大梵天王。总而聚之为一大梵天王。即以如是之数。尽虚空遍法界一切世界有情。皆具如上大梵天王福蕴。以此之数较计。如是有情福蕴。即同声闻缘觉菩萨所证。大地大光明云授法灌顶。得十自在所有功德。善男子。即以是事。所有一切有情。于十方无边际世界尽虚空界。积集三世所有福蕴。以彼三世福蕴。尽虚空界一切世界极微尘量。百倍倍之即成如来一一毛孔。而彼一一毛孔之中所入福蕴。以十阿僧祇百千倍数倍之。即成如来八十种好。而彼一一随形好中所入一切福蕴。以十不可说倍数倍之。即成如来三十种相。而彼一一所成之相。以十不可说倍数倍之。即成如来眉间圆满无垢月轮胜余千光殊妙最上白毫之相。即如是相。以十不可说不可说千俱胝倍数倍之。即成如来一切世间高显不可睹见乌瑟腻沙庄严顶相。即如是相。以十不可说不可说俱胝那庾多百千倍数倍之。即成如来六十千种一切所缘无边音声。流出殊妙无所发悟。普令有情生大欢喜。开示一切世界清净语言佛大辩才。善男子。此说是为诸佛世尊百福之相。如来以是无尽福智胜行普遍庄严。广为一切有情长养济命。善男子。正使十方尽虚空遍法界。一切世界中所有有情。满一劫中悉住第十法云地菩萨之位具诸胜相。谓身语意所庄严。具诸陀罗尼及十自在。是等菩萨。以阎浮檀金所成之器。量等虚空如殑伽沙数。而一一器盛种种宝。经尔所时乃至最后边际圆满劫中。刹那刹那来而复往。各各持入如来一毛孔中。而佛世尊一毛孔中。所有福蕴不增不减。善男子。此是如来不可思议百福之相。复次何等是十二地。所谓未发菩提心地。欢喜地。离垢地。发光地。焰慧地。难胜地。现前地。远行地。不动地。善慧地。法云地。普遍光明佛地。是为十二地。此中何等是未发菩提心地。谓此菩萨。超越一切愚夫所行邪行。及一切三世梵王帝释护世诸天声闻缘觉。最胜出过一切世间一切行相吉祥。身语意业而为庄严。于十方无边世界。普遍照耀具大光明轮。得无障碍力。行陀罗尼于阿僧祇世界。一一相中纵任无方。于四大洲世界。出现普遍香光明网广大庄严。莲华承足。处大千世界边际之量妙庄严座。得一切法善调顺。善观察成就无碍可意。所缘事相。现十种大相及阿僧祇相。显示不退转法。于无边际一切方所。随所行时放不可思议大光明网。无量刹土种种庄严现身影像。于不可说无量世界中。能为诸世界主。劝受灌顶增上加持。能于一切世出世间。常雨无量大法宝雨。妙光明门悉无遮碍。周广普遍而作最上大施福行。随顺一切世间。普能圆满一切有情不空意愿。见者咸生善妙可爱清净之心。普振一切世界。随所思念诸恶趣等无边有情悉为救度。普能摄受无边诸佛供养法门。游戏一切阿僧祇数三摩地陀罗尼解脱通明等法嬉乐无边胜妙法园而无爱着。得无边俱胝劫数无发悟无疑惑喜行光明。无数俱胝那庾多百千劫。于清净大乘分位中修习圆满。种种利他所行事业成办。福智胜行多百千种。广大先行究竟圆满。若具最极信解行法故。乃得初地。今以次第分位故。而此菩萨。是未发菩提心地。善男子。譬如转轮圣王。虽已超越人之色相。然未获得天之色相。而此菩萨亦复如是。虽已超越一切世间声闻缘觉之地。然未获得最上菩萨地故。复次普遍光明佛地者。无中无边无复遗余一切清净。于一切法自在。普能善观无数种相。普令一切有情获得利乐。何等是诸菩萨所行十种三摩地。所谓一者宝高。二者善住。三者无动。四者不退转。五者宝积。六者日光焰。七者一切义成。八者智光明。九者安住现在佛前。十者首楞严。如是等无边菩萨所行三摩地。复次十二种陀罗尼。何等十二。所谓一者灌顶。二者大智。三者清净音声。四者无尽藏。五者无边转。六者海印。七者莲华庄严。八者趣无碍门。九者决定出生诸无碍解。十者住佛庄严。十一者无边色相。十二者佛身色相成办圆满。是为十二种陀罗尼。复次六通。何等为六。一者天眼通。二者天耳通。三者他心智通。四者宿住随念智通。五者神境智通。六者漏尽智通。是为六通。复次诸菩萨十种自在。何等为十。一者无量阿僧祇劫具寿量力故。即寿自在。二者不可说不可说三摩地门。相续趣入胜相应故。即心自在。三者一切世界无数庄严具。庄严加持显示相应。即受用自在。四者随其时分诸业报力悉显示故。即业自在。五者于一切世界示现受生故。即生自在。六者于一切世界见佛圆满示现故。即信解自在。七者随乐欲时于诸刹中现成菩提。即愿自在。八者于一切世界。出现无边神通事故。即神通自在。九者无边无中法门光明常显发故。即法自在。十者于如来十力四无所畏。四无碍解十八不共法。三十二相八十种好。及现证最上菩提。充满三世一切佛刹。微尘阿僧祇等数中。了知一相具诸胜相。乃至现证一切智悉能显示故。即智自在。是为菩萨十种自在。复次何等是菩萨十力。所谓一者意乐力。二者深固力。三者方便力。四者慧力。五者愿力。六者行力。七者乘力。八者神变力。九者菩提力。十者转法轮力。是为菩萨十力。何等是菩萨四无所畏。所谓一者于诸陀罗尼。随闻能受宣说义理无畏。二者了无我法不娆于他。积集无相本习威仪而无缺失。三业清净成就广大护持无畏。三者常持正法而不忘失。毕竟安住智慧方便。救度有情无放逸心。开示善法得离障难无畏。四者不忘失一切智心。亦于余乘诸出离道圆满自在。得一切种一切事成就无畏。是为菩萨四无所畏。何等是菩萨十八不共法。所谓一者菩萨无著布施。二者无著持戒。三者无著忍辱。四者无著精进。五者无著禅定。六者无著智慧。七者以四摄法摄诸有情。八者善了诸回向法。九者善巧方便成诸有情增上所行。十者开示上乘出离之道。十一者于大乘法而不退转。十二者表示生死及涅槃门。十三者于诸典章不减文句。十四者所作行中智为先导。十五者于诸生中离众过失。十六者于身口意具十善业。十七者堪忍诸苦不舍一切有情。十八者一切世间所可爱乐皆悉显示。普遍一切世间愚夫及声闻缘觉。善以众宝及劫树庄严坚固。一切智心永不忘失。得一切法依法灌顶。常所乐求见佛法僧。是为菩萨十八不共法。云何是如来十力。所谓一者处非处智力。二者教示过去未来现在业因果报智力。三者种种信解智力。四者种种界智力。五者了别自他根智力。六者至处道智力。七者发起一切禅定解脱三摩地三摩钵底染净等智力。八者宿住随念智力。九者生死智力。十者漏尽智力。是为如来十力。云何是如来四无所畏。所谓一者一切法现证智无畏。二者一切漏尽智无畏。三者决定说障道无畏。四者出尽苦道无畏。是为如来四无所畏

佛说除盖障菩萨所问经卷第七佛说除盖障菩萨所问经卷第八

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次何等是为如来十八不共法。所谓一者如来身无懈倦。二者语无卒暴。三者无失念。四者无不定心。五者无种种想。六者无不知舍心。七者欲无减。八者精进无减。九者念无减。十者定无减。十一者慧无减。十二者解脱解脱知见无减。十三者于过去世无著无碍知见随转。十四者于未来世无著无碍知见随转。十五者于现在世无著无碍知见随转。十六者于诸身业智为先导随智而转。十七者于诸语业智为先导随智而转。十八者于诸意业智为先导随智而转。此等是为如来十八不共法。何等是如来大悲。善男子。勤行三十二种相故。乃起如来大悲之心。于十方无边世界。广现不思议相。皆从如来大悲心转。何等三十二相。所谓一者一切法无我。而诸有情于无我理不能信解。是故如来为诸有情发起大悲。二者一切法无有情。而诸有情执以为有。是故如来发起大悲。三者一切法无寿者。而诸有情执以为有。是故如来发起大悲。四者一切法无补特伽罗。而诸有情生其取着。是故如来发起大悲。五者一切法无性。而诸有情起有性见。是故如来发起大悲。六者一切法无碍。而诸有情着于所碍。是故如来发起大悲。七者一切法无含藏。而诸有情生其乐着。是故如来发起大悲。八者一切法无主宰。而诸有情着于我相。是故如来发起大悲。九者一切法无摄属。而诸有情起于执取。是故如来发起大悲。十者一切法无物像。而诸有情着于境物。是故如来发起大悲。十一者一切法无种姓。而诸有情生其取着。是故如来发起大悲。十二者一切法无生无灭。而诸有情着于生灭。是故如来发起大悲。十三者一切法无染污。而诸有情自生染污。是故如来发起大悲。十四者一切法离贪。而诸有情生其贪爱。是故如来发起大悲。十五者一切法离嗔。而诸有情生其嗔恚。是故如来发起大悲。十六者一切法离痴。而诸有情起于愚痴。是故如来发起大悲。十七者一切法无来。而诸有情取着诸趣。是故如来发起大悲。十八者一切法无去。而诸有情着于有生。是故如来发起大悲。十九者一切法无行。而诸有情诸行中行。是故如来发起大悲。二十者一切法无戏论。而诸有情乐着戏论。是故如来发起大悲。二十一者一切法空。而诸有情起于有见。是故如来发起大悲。二十二者一切法无相。而诸有情着境界相。是故如来发起大悲。二十三者一切法无愿。而诸有情运行诸愿。是故如来发起大悲。二十四者世间有情所共集会。互相诤讼起贪嗔等一切过失。如来观已。为说法要。使令断除彼贪嗔等一切过失。是故如来发起大悲。二十五者世间有情所共集会。勤行颠倒履险恶道居邪异处。为令彼等入如实道。是故如来发起大悲。二十六者世间有情所共集会。悭贪增盛侵取他财而无厌足。为令彼等具戒闻舍慧诸圣法财。是故如来发起大悲。二十七者世间有情于诸舍宅。财物妻子生贪爱故。卑贱其身犹如仆使。于不真实中计真实想。佛为彼等宣说法要。令知毕竟无常之法。是故如来发起大悲。二十八者世间有情以其艰苦求活命故互相欺诳。佛为彼等宣说法要。咸使有情净命自资。是故如来发起大悲。二十九者世间有情于名闻利养。固起追求不生厌足。为令彼等如实了知而生厌足。究竟息苦获涅槃乐。是故如来发起大悲。三十者世间有情常生贪爱。居苦器中一向染污。佛为彼等宣说法要。令其出离超越三界。是故如来发起大悲。三十一者以一切法离因缘故。世间有情生懈怠心。乃于圣法解脱门中而起障碍。佛为彼等宣说解脱真实之法。令诸有情行于精进。是故如来发起大悲。三十二者世间有情。弃舍最上无著妙智殊胜涅槃。乐求声闻缘觉下乘涅槃。为令彼等爱乐广大趣求佛智。是故如来发起大悲。善男子。勤行如是三十二种相故。如来乃起大悲之心。如是所说如来大悲之行。若有菩萨。勤行如是三十二种之相。发起大悲心者。而此菩萨摩诃萨。于福功德刹中。而能圆满广大威光。利乐有情相应事业得不退转。是故当知如是等无量无数自在之法所有分位。若诸如来若诸菩萨乃至住后边际劫中广宣说者。而悉不能得其边际。今此所说而极少分。但为令诸有情发生最上净信欢喜。是为菩萨不动一切有情善法济命长养。善男子。云何是菩萨无量法云含润任持广大法雨。如世间风无其边际。而彼风轮广大安固。普遍任持一切世界。若成时若坏时。及其水云。并于大海与四大洲。须弥山。目真邻陀山。摩诃目真邻陀山。雪山铁围山大铁围山。香醉山。树林宫殿诸楼阁等。菩萨摩诃萨。无边陀罗尼风轮亦复如是。悉能任持一切正等正觉之云。流注广大无碍法雨。于一切世界悉能成办佛功德法。如其所说须弥山等世间差别之相。即是百福胜相。十地十波罗蜜多。十三摩地。十二陀罗尼。六通十自在。十力四无所畏。四无碍解十八不共法。大悲心等一切佛菩萨法。悉能任持具足。又复常持一切世出世间百千法蕴而悉成就。是为菩萨无量法云含润任持广大法雨。善男子。云何是菩萨大法种种庄严楼阁布饰妙好。如世间风悉能普遍吹布一切庄严楼阁。种种安置殊妙可爱。及一切树林枝叶牙茎华果蕊等。及一切有情身诸分位。悉由风力常所吹布。菩萨之风亦复如是。以无边无碍无著解力辩才之智。悉能施设一切世出世间种种法门。行列具足照明开示。最胜殊妙种种法者。所谓此相是恶趣所成之法。此是善趣所成之法。此是增上所成之法。此是地狱。此是饿鬼。此是畜生。此是人此是天。此是转轮圣王。此是帝释梵王护世诸天。此是色相眷属聪利福力。此是明慧善计。此是艺能。此是善解种种诸教典籍。此是声闻乘法。成声闻果。此是缘觉乘法。成缘觉果。此是大乘之法。具诸胜相。自利利他事业圆满。成就普贤一切胜智。乃至此是十地十波罗蜜多。十三摩地。十二陀罗尼。六通三明。十自在。八解脱十力四无所畏四无碍解十八不共法。善男子。菩萨善能施设此如是等无量种法。莲华庄严等陀罗尼门。为法庄严妙巧安布。是为菩萨大法种种庄严楼阁布饰妙好。善男子。云何是菩萨一切众会劫树庄严决定常出正妙法音雨华悦意。如劫树林为风吹击。常雨种种香华妙宝衣服鼓乐等庄严具而悉具足。是诸严具相续流出。令诸天人咸生最上适悦欢喜无忧自在。嬉戏娱乐常具色相。力势勤勇悦乐无减。菩萨智风亦复如是。菩萨常于如来清净世界大法会中。为诸有情宣说契经应颂记别讽颂譬喻缘起自说本事本生方广希法论义十二分教。常雨如是正法宝华。为诸有情。于其顺违惯习事中。从初次第宣说教授。及一切世间诸所缘事引发示诲。无我寂灭清净法性。开示普遍一切法门。总摄法性引示令入不可思议如幻法中。显发大智如幻法门。复令有情增长游戏一切法乐。诸有问答无中无边。能善起发普使欢喜。常令于其正法园林以无过身语意业。适悦戏乐不生懈退。令诸天人受用具足。善法无减慧光明照。常住最胜清净法中。是为菩萨一切众会劫树庄严决定常出正妙法音雨华悦意。善男子。云何是菩萨阿僧祇劫洁白圣会建立积集三摩地解脱总持门海布妙高山日月光明法教丛林善妙宫殿轮围山等。及一切有情成熟调伏。庄严善住无上无身。依止随转智风曼拏罗解脱因故。譬如劫风。世界坏时其风无碍。力势迅猛普遍吹击三千大千世界俱胝那庾多百千诸铁围山须弥山大海等。皆悉破散磨灭无余同太虚空。菩萨之风亦复如是。于多百千劫中。积集种种福智庄严。菩萨以广大力势。能现种种神通变化。善转无碍清净法轮。出妙音声。普遍调伏一切众会。由如是故。从智风轮出诸法蕴。彼所调伏观察最上妙法光明无著诸行。胜力具足深固作意。内心正住成三摩地。想蕴处界。及三有身所作诸行。而悉破散无身所作。了知皆是虚妄分别。超越一切世间。然后乃现不可思议。无相出世胜福圆满。依止随转获胜清净。住后边际离诸忧恼。是为菩萨阿僧祇劫洁白圣会建立积集三摩地解脱总持门海布妙高山日月光明法教丛林善妙宫殿轮围山等。及一切有情成熟调伏庄严善住无上无身。依止随转智风曼拏罗解脱因故。善男子。菩萨若修如是十种法者。即得如风

尔时除盖障菩萨摩诃萨前白佛言。希有世尊。希有善逝。善说如是广大之法。乃至具足一切胜相。而能令诸菩萨大士咸生欢喜。世尊。若天及人。能于如是法中信解修行者。如佛所说。是人即得一切具足受胜妙乐。适悦自在乃同梵王帝释护世天等。所有此世他生。得一切圆满利他胜行。今此不说。佛言。善男子。如是如是。如汝所说。彼之有情出过一切世间。普为多人所共瞻仰。断诸恶法具诸善法。一切世间之所归向。善男子。若诸有情。于此法中能修行者。或复有人返生轻谤。我说彼人是愚痴者。当堕黑暗大地狱中受诸苦恼。世间天人阿修罗等所共悲愍。又善男子。菩萨若修十种法者即如虚空。何等为十。所谓一者无垢。二者无碍。三者寂静。四者无相。五者无边智。六者平等随知一切法。七者了一切法如虚空自性解脱。八者无住。九者出过诸境界相。十者出过寻伺。菩萨若修如是十种法者。即如虚空。善男子。复有十法。菩萨若修即如虚空。何等为十。所谓一者于可意不可意一切色中不爱不恶。二者于可意不可意一切声中不爱不恶。三者于可意不可意一切香中不爱不恶。四者于可意不可意一切味中不爱不恶。五者于可意不可意一切触中不爱不恶。六者于可意不可意一切法中不爱不恶。七者于利衰法中不爱不恶。八者于乐苦法中不爱不恶。九者于称讥法中不爱不恶。十者于誉毁法中不爱不恶。菩萨若修如是十种法者即如虚空。又善男子。菩萨若修十种法者即得如月。何等为十。所谓一者令诸有情皆生欢喜。二者众所乐见。三者善法增长。四者恶法损减。五者咸皆称赞。六者体相清净。七者乘最上乘。八者常自庄严。九者游戏法乐。十者具大神通威德。善男子。云何是菩萨令诸有情皆生欢喜。如月初出。一切有情皆得清凉。及悦意故咸生欢喜。菩萨之月亦复如是。当初出时。一切有情悉得远离烦恼炎炽生喜乐故。是为菩萨令诸有情皆生欢喜。云何是菩萨众所乐见。如月初出。一切有情悉乐瞻睹。所谓善妙洁白令诸有情心生喜故。菩萨之月亦复如是。当初出时。一切有情爱乐悦意。所谓诸根清净种子洁白。于诸所行威仪具足。是为菩萨众所乐见。云何是菩萨善法增长。如白分月从初出已。日日渐增。至十五日其月盛满诸相圆具。菩萨之月亦复如是。从初发心乃至坐于道场。日日善法渐渐增长。至坐道场已一切胜相皆悉圆满。是为菩萨善法增长。云何是菩萨恶法损减。如至黑分月时。其月轮相光明渐减。如其所减。至月尽日一切不现。菩萨之月亦复如是。至具出世智时恶法渐减。如其所减。乃至坐于道场。一切灭尽无复遗余。是为菩萨恶法损减。云何是菩萨咸皆称赞。如月初出时。诸婆罗门。刹帝利。男女大小。一切人民咸悉称赞。菩萨之月亦复如是。当初出时。一切世间天人阿修罗乾闼婆等咸悉称赞。是为菩萨咸皆称赞。云何是菩萨体相清净。如月天子体相清净洁白无染。谓胜业报之所成故。菩萨体相亦复如是。本来无染洁白所成清净化生。非从父母羯逻蓝。等不净所生。是为菩萨体相清净。云何是菩萨乘最上乘。如月天子乘清净乘照四天下。菩萨之月亦复如是。乘于最上菩萨之乘。广照无边一切世界。是为菩萨乘最上乘。云何是菩萨常自庄严。如月天子本相清净常自庄严不以澡沐所庄严故。菩萨之月亦复如是。诸胜功德常自庄严。是为菩萨常自庄严。云何是菩萨游戏法乐。如月天子常受天乐。菩萨之月亦复如是。常所游戏胜妙法乐。不染世间诸欲境界。是为菩萨游戏法乐。云何是菩萨具大神通威德。如月天子具大神通有大威德广照一切。菩萨之月亦复如是。具大福智胜功德故。是为菩萨具大神通威德。善男子。菩萨若修如是十种法者。即得如月

佛说除盖障菩萨所问经卷第八佛说除盖障菩萨所问经卷第九

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。即得如日。何等为十。一者破无明暗。二者开敷一切。三者普遍十方咸得和暖。四者起诸善法。五者有漏灭没。六者作光明照。七者制诸邪异。八者高下开显。九者成诸事业。十者善人乐欲。善男子。云何是菩萨破无明暗。如日初出。悉能除去一切昏暗。菩萨之日亦复如是。当初出时。能破一切无明黑暗。是为菩萨破无明暗。云何是菩萨开敷一切。如日出时。悉能开敷净莲华等一切华卉。菩萨之日亦复如是。所应受化诸有情等而悉开觉。是为菩萨开敷一切。云何是菩萨普遍十方咸得和暖。如日出时。普遍十方咸得和暖。菩萨之日亦复如是。当初出时。智光普照十方一切咸悉和暖。而亦不娆世间有情。是为菩萨普遍十方咸得和暖。云何是菩萨起诸善法。如日将出。阎浮提内先现明相则知日出。菩萨之日亦复如是。将欲出时先现智光明相。有情则知菩萨出现。是为菩萨起诸善法。云何是菩萨有漏灭没。如阎浮提日光隐时则知日入。菩萨亦复如是。诸染烦恼隐不现时。则知菩萨诸漏已尽。是为菩萨有漏灭没。云何是菩萨作光明照。如日初出。阎浮提内诸有情类蒙光普照。菩萨之日亦复如是。当初出时。智光普照一切有情。除去一切痴冥暗蔽。是为菩萨作光明照。云何是菩萨制诸邪异。如日光现翳诸小明。而日不作是念。我能翳彼诸小光明。何以故。日光出时法尔如是故。菩萨之日亦复如是。智光出时一切邪异外道小明皆悉映蔽。而此菩萨亦不作是念。我能映蔽邪异诸小光明。何以故。而诸小明法尔如是映不现故。是为菩萨制诸邪异。云何是菩萨高下开显。如日出时。阎浮提内一切丘墟及平坦处。一切人众悉能显视。菩萨之日亦复如是。智光普照令诸有情显观一切丘墟平坦。平坦者谓八正道。丘墟者谓八邪道。是为菩萨高下开显。云何是菩萨成诸事业。如日初出。一切农者耕稼事业而悉兴作。菩萨日出亦复如是。有情一切善法事业而悉成办。是为菩萨成诸事业。云何是菩萨善人乐欲。如日初出。善人爱乐恶人嫌恶。菩萨日出亦复如是。其智慧者悉生爱乐。趣向邪道奸恶之类。愚蒙无智乐着生死背涅槃者悉生嫌恶。是为菩萨善人乐欲。善男子。菩萨若修如是十种法者即得如日。又善男子。菩萨若修十种法者即如师子。何等为十。一者自无恐怖。二者不畏于他。三者直进不还。四者能师子吼。五者无畏观察。六者常行林中。七者乐居山岩。八者无所结缚。九者自具勇力摧伏他军。十者善作守护。善男子。云何是菩萨自无恐怖。譬如师子安详行步无惊无怖。何以故。不见有能与己等故。菩萨亦复如是。周遍往复无惊无怖。何以故。不见有能与己等故。是为菩萨自无恐怖。云何是菩萨不畏于他。如彼师子不畏于他一切邪恶呼叫之音。菩萨亦复如是。若与一切他宗外道论义之时。心无怯弱亦不卑下。是为菩萨不畏于他。云何是菩萨直进不还。如彼师子直往不退。菩萨亦复如是。本性直进。不复退还邪异宗教。而复菩萨辩才无尽。是为菩萨直进不还。云何是菩萨能师子吼。譬如师子震吼之时。一切獐鹿野干之类。而悉惊怖奔走十方。菩萨亦复如是。若作无我师子吼时。所有一切着我执者。邪异外道。而悉惊怖驰走十方。菩萨亦不娆恼于彼。但为破于着我见者。震发无我师子吼故。亦复为余有情作调伏故。是为菩萨能师子吼。云何是菩萨无畏观察。如彼师子作无畏相普遍观视。菩萨亦复如是。志行清净作无畏相普遍观察。是为菩萨无畏观察。云何是菩萨常行林中。如彼师子本性乐行林野之中。菩萨亦复如是。自性寂静远离愦闹乐行林中。是为菩萨常行林中。云何是菩萨乐居山岩。如彼师子乐居山岩。菩萨亦复如是。乐居智慧禅定山岩。是为菩萨乐居山岩。云何是菩萨无所结缚。如彼师子无所结缚。菩萨亦复如是。去除一切烦恼重担离诸结缚。是为菩萨无所结缚。云何是菩萨自具力能摧伏他军。如彼师子独无伴侣能摧他众。菩萨亦复如是。独无伴侣坐道场时。以自力能摧伏魔军。是为菩萨自具力能摧伏他军。云何是菩萨善作守护。如彼师子若或近于聚落而住诸有獐鹿等类不损苗稼。菩萨亦复如是。所向国邑及诸方处。而彼一切邪异外道獐鹿等类。不损有情善法种子。是为菩萨善作守护。善男子。菩萨若修如是十种法者即如师子。又善男子。菩萨若修十种法者即能调伏。何等为十。一者坚固菩提心。二者修治菩提行。三者守护诸根。四者趣向正道。五者能荷重担。六者为有情故不生懈退。七者正命自活。八者离诸谄曲。九者不起诳惑。十者身心正直。是为十法。善男子。菩萨若修如是十种法者。即能调伏。又善男子。菩萨若修十种法者即能善乘。何等为十。一者虽修定行而常观空。二者虽尽诸障而常修善行。三者虽离诸起作而善顺佛教无所违背。四者平等了知一切诸法而解法界理。五者能于世间自卑其身如旃陀罗谦下其意。六者远离憍慢常于他人起智者想。七者以现量智了知佛法离诸疑惑。八者虽知诸法差别得决定相。九者自取正道不随他教。十者善顺世间为世福田。善男子。菩萨若修如是十种法者。即能善乘。又善男子。菩萨若修十种法者。即如莲华。何等为十。一者离诸染污。二者不与少恶而俱。三者戒香充满。四者本体清净。五者面相熙怡。六者柔软不涩。七者见者皆吉。八者开敷具足。九者成熟清净。十者生已有想。善男子。云何是菩萨离诸染污。譬如莲华出于水中而水不染。何以故。法尔如是故。菩萨亦复如是。虽处生死流中而不染着。何以故。由慧方便法尔如是故。菩萨以其善巧方便。处生死中不为生死过失所染。以方便慧所摄受故。是为菩萨离诸染污。云何是菩萨不与少恶而俱。譬如莲华而不停留水之微滴。菩萨亦复如是。不与少恶而俱。是为菩萨不与少恶而俱。云何是菩萨戒香充满。譬如莲华生时随处妙香广布。菩萨亦复如是。所向国邑及诸方处。戒香芬馥广布一切。是为菩萨戒香充满。云何是菩萨本体清净。譬如莲华生时自然洁白清净随其方所婆罗门刹帝利一切人民共所称赞。菩萨亦复如是。随诸方邑所生之处洁白清净。何以故。戒清净故。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等咸共称赞。诸佛菩萨之所摄受。是为菩萨本体清净。云何是菩萨面相熙怡。譬如莲华当开敷时令诸见者心意快然生适悦故。菩萨亦复如是。面相熙怡离诸颦蹙。诸根清净见者欢喜。是为菩萨面相熙怡。云何是菩萨柔软不涩。譬如莲华体性柔软。菩萨亦复如是。自体清净柔软细妙。是为菩萨柔软不涩。云何是菩萨见者皆吉。譬如莲华乃至梦中于须臾顷见亦善吉。何以故。一切义成故。菩萨亦复如是。若于一切分位之中。见者咸得最上吉祥。是为菩萨见者皆吉。云何是菩萨开敷具足。譬如莲华若开敷已即名具足。菩萨亦复如是。若慧觉华开敷之时即名具足。是为菩萨开敷具足。云何是成热清净。譬如莲华若成熟已。眼所观时眼根清净。鼻所嗅时鼻根清净。身觉触时身根清净。心欢喜时意根清净。菩萨亦复如是。果成熟时。慧光明相。一切有情。若眼见时眼根清净。若耳闻时耳根清净。菩萨戒功德香。若鼻嗅时鼻根清净。身供养时身根清净。思惟称赞菩萨胜功德时意根清净。是为菩萨成熟清净。云何是菩萨生已有想。譬如莲华所生之时若人非人生已有想。菩萨亦复如是。当初生时佛及菩萨。并余帝释梵王护世天等。咸乐护持生已有想。是为菩萨生已有想。善男子。菩萨若修如是十种法者即如莲华。又善男子。菩萨若修十种法者得广大心。何等为十。一者为令有情圆满诸波罗蜜多故起广大心。二者为令圆满一切佛法故。三者为令化度诸有情故。四者安坐道场成就阿耨多罗三藐三菩提故。五者成正觉已。为诸沙门婆罗门天人魔梵一切世间。转妙法轮故。六者为令有情作利乐事周行无量无边世界。施设化行故。七者谓以智慧之船渡诸有情。越生死岸故。八者世间一切无依无救无归无趣无亲属者。为作依归亲属故。九者为令显示佛大牛王妙师子吼。游戏诸佛神通法门。如大龙王审谛瞻视。普遍观察沙门婆罗门天人魔梵一切世间。普令同获佛功德故。十者为令化度有情。具佛威德无粗涩行。无难行行。无劣弱行。无卑下行。故发广大心善男子。菩萨若修如是十种法者。即得广大之心。又善男子。菩萨若修十种法者得清净心。何等为十。一者深心具足。深心不动。深心安住。深心质直。二者离不深固作意。不深固作意者。所谓发起声闻之行。缘觉之行。及起诸小缘。三者离诸垢染。诸垢染者谓烦恼垢。四者离身过失。身过失者谓离虚假诸威仪道。五者离语过失。语过失者谓不如实开示正义。六者离心过失。心过失者谓于身语心中复有所离。知身不和合故。常出少欲知足语故。心无求故。七者知恩念报。受少恩惠尚不忘失况复广多。八者施恩于人。不现已德不讥彼短。乃至少恩亦不望报。欢喜教示称赞彼德。九者如说能行。而菩萨者不外发柔软之语心生恚害。菩萨亦不外发称赞之语内心思惟损恼方便。菩萨不外发爱语内固冤结。菩萨不外现善相内起恶意。菩萨不外现恭敬之相内起轻慢之心。菩萨无不真实亦无虚妄。复无悭嫉及无谄诳。不起斗诤不破和合。何以故。菩萨于一切时。身起恭敬语宣实义。心念成办一切善法。十者于如来教中远离毁谤。而菩萨者毕竟不于如来教中而生毁谤。何故菩萨于如来教中不毁谤邪。谓诸菩萨发阿耨多罗三藐三菩提心已。剃除须发被袈裟衣。于如来教中清净出家。不为王难故出家。不为贼难故出家。不为负债逼迫故出家。不为怖不活故出家。但以正信求出家已寻求善法。近善知识亲事恭敬。于其善知识所听受正法。听已修行不起我慢贡高之心。由离慢故除颠倒执。无颠倒故得觉了正道。觉正道故得入法性。得入法性故决定当得阿耨多罗三藐三菩提。是故菩萨于如来教中不生毁谤。善男子。菩萨若修如是十种法者。得清净心。又善男子。菩萨若修十种法者。即得深信无疑惑心。何等为十。一者信如来身密。二者信如来语密。三者信如来意密。四者信诸菩萨所行。五者信如来出生。六者信菩提法。七者信如来唯说一乘。八者信如来说种种教。九者信如来深远音声。十者信如来随其所应化度有情。善男子。云何是菩萨信如来身密。谓若菩萨起如是念。我闻如来法身。寂静身。无等身。无等等身。无限量身。不共身。金刚身。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信如来身密。云何是菩萨信如来语密。菩萨作是念。我闻如来语密。为诸有情现前授记。或为有情隐密授记。我知如来身无误失语无卒暴。以是缘故。妄言过失无所从来。何以故。如来已断诸过失故。离一切垢远一切尘。息诸炎炽离诸烦恼。洁白自在清净无染。若言如来身有过失语有卒暴诸过失者。无有是处。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信如来语密。云何是菩萨信如来意密。菩萨作是念。我闻如来意密者。如来诸有意乐悉与智慧心俱。依其心故。一切声闻缘觉一切菩萨。及余有情所不能知。唯除如来神力所加。何以故。如来智慧甚深无底不可伺察。过诸寻伺境界。无量广大等虚空界。亦复超出世间一切度量境界。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信如来意密。云何是菩萨信诸菩萨所行。菩萨作是念。我闻诸菩萨为有情故。现前施作诸利益事。不生懈倦不起怖畏。荷负重担。坚固志行。坚固精进。满足诸波罗蜜多。次第成办一切佛法。以无碍慧。无边慧。无等慧。不共慧等。彼坚固铠。坚固精进。坚固誓愿。不动誓愿。不共誓愿。所谓菩提因。菩提相。菩提缘等。如是次第圆满广大神通事业。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信诸菩萨所行。云何是菩萨信如来出生。菩萨作是念。我闻诸菩萨坐道场已。得无著无碍离障天眼智通。天耳智通。他心智通。宿住随念智通。神境智通。漏尽智通。得如是等无著无碍离诸所缘三世同一相平等之智。能如实观诸有情界。此类有情造身语意诸恶行业。毁谤贤圣起于邪见具邪见业。由此因缘。身坏命终。堕在恶趣受地狱报。又复见此一类有情造身语意诸善行业。不谤贤圣。起于正见具正见业。由此因缘。身坏命终。生于善趣受天胜报。菩萨如是如实观见诸有情界。如实能知善不善业。菩萨又作是念。如我往昔所修菩萨行时。发大誓愿。如是诸行自觉了已。令诸有情而悉觉了。如是我当得愿圆满。我望亦足。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信如来出生。云何是菩萨信菩提法。谓若菩萨。于佛菩提而能觉了。以自智力成正觉果。我于是处信无疑惑。是为菩萨信菩提法。云何是菩萨信如来唯说一乘之法。菩萨作是念。我闻一乘法者谓如来乘。如是真实无有虚妄。诚实无异谛无不实。何以故。谓从如来之乘出生诸乘。譬如阎浮提内所有各各诸小洲渚。皆阎浮提之所摄属。而悉依止于阎浮提。是故同名阎浮提数。如来之乘亦复如是。诸乘悉于如来乘摄。从如来乘之所出生。而悉依止于如来乘。是故一乘即如来乘。我于是处信无疑惑。是为菩萨信如来唯说一乘之法。云何是菩萨信如来说种种教。菩萨作是念。我闻如来说种种教种种经典。如是真实无有虚妄。何以故。如来观诸有情所应度者。随彼信解为说法要。我于是处信无疑惑。是为菩萨信如来说种种之教。云何是菩萨信如来具深远音声。菩萨作是念。我闻如来具足深远清净音声。如是真实无有虚妄。何以故。彼诸天子。以修少分善根力故。尚得清净深妙音声。况复如来无量无数百千劫中积修胜行。我于是处信无疑惑。是为菩萨信如来深远音声。云何是菩萨信如来随其所应化度有情。菩萨作是念。我闻如来随有情心。如其有情所应信解。以种种方便而为化度。佛以一音断诸疑惑。是诸有情根性成熟。所应度者。皆谓如来为我说法。而各解了。而佛如来无所分别。非无分别。如是真实无有虚妄。我于是处信无疑惑。是为菩萨信如来随其所应化度有情。善男子。菩萨若修如是十种法者。即得无疑惑心

佛说除盖障菩萨所问经卷第九佛说除盖障菩萨所问经卷第十

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次善男子。菩萨若修十种法者即如大海。何等为十。一者为大宝聚。二者深难彻底。三者广大无量。四者次第渐深。五者不宿死尸。六者皆同一味。七者容受众流。八者潮不失时。九者水族所依。十者无有边际。善男子。云何是菩萨为大宝聚。譬如大海广积众宝。阎浮提中一切人众。咸取其宝无有穷尽。菩萨亦复如是。广积一切智功德宝。一切有情皆取是宝亦无穷尽。是即菩萨为大宝聚。又善男子。譬如大海深难彻底。菩萨亦复如是。一切有情于菩萨法莫测其际。又善男子。譬如大海广大无量。菩萨亦复如是。功德智慧广大无量。又善男子。譬如大海次第渐深。菩萨亦复如是。一切智深一切智渐深一切智极深。又善男子。譬如大海不宿死尸。何以故。大海法尔如是故。菩萨亦复如是。不与烦恼结漏及不善知识而所共止。何以故。菩萨法尔如是故。又善男子。譬如大海众流入中皆同一味。所谓碱味。菩萨亦复如是。积集一切善法皆同一味。所谓一切智味。又善男子。譬如大海容受众流而其海水不增不减。菩萨亦复如是。容受无量一切法水。而菩萨智慧不增不减。又善男子。譬如大海潮不失时。菩萨亦复如是。所应成熟化度有情亦不过时。又善男子。譬如大海为诸水族依止窟宅。菩萨亦复如是。为一切有情一切善法之所依止。又善男子。譬如大海一切有情悉取其水而无边际。菩萨亦复如是。广为一切有情宣说法要。亦无边际。善男子。菩萨若修如是十种法者即如大海。复次善男子。菩萨若修十种法者得微妙智。何等为十。一者善求出离。二者善知诸出离法。三者善知诸法平等。四者善知诸法如幻。五者善知一切法相。六者善解甚深难测缘生之法。七者善知业不思议。八者善知诸所说义。九者善了如实义。十者善观真实智。善男子。云何是菩萨善求出离乃至善观真实智谓若菩萨作是思惟。我应观察诸世间相。观见世间贪火炽然嗔烟蓬[火*孛]。痴暗覆蔽瞑然无托。菩萨乃起是念。此诸有情云何能得出离。菩萨即为勤求出离及出离法。由得出离法故。即能随知诸法平等。由知诸法平等故。即能如实知诸法如幻。由知诸法如幻故。即如实知一切法相。由知法相故。即能思察甚深难测缘生之法。由能思察缘生法故。即能解了业不思议。是故菩萨虽知世间诸法无实。而亦显示种种业报。由是之故得微妙智。能于诸佛菩萨所说义中而悉了知。由了知故即能开解如实之义。解如实义故。即能观真实智。见真实故。能度有情出离生死。善男子。菩萨若修如是十种法者即得微妙智。复次善男子。菩萨若修十种法者得随应辩才。何等为十。一者开示诸法无我。二者无有情。三者无寿命。四者无养育。五者无补特伽罗。六者无作者。七者无受者。八者无知者。九者无见者。十者显示一切法空都无主宰。皆是虚妄不实分别诸法但从缘生故有。善男子。若得一切法无我相应。彼即随顺法性。由是之故。于一切法无有情无寿命无养育无补特伽罗无作者无受者无知者无见者等。如理相应即能随顺法性。由是之故。了知一切法空都无主宰。皆是虚妄不实分别。诸法但从缘生故有。如理相应即能随顺法性。善男子。若随顺法性故。即于法性不相违背。不违背故乃能正说诸法。正说法故善入法性。入法性故乃能开示彼一切法。开示法故彼之辩才乃名随应。善男子。菩萨若修如是十种法者。即得随应辩才。复次善男子。菩萨若修十种法者得乐说辩才。何等为十。一者辩才无著。二者无尽。三者相续四者不畏大众。五者不卑下。六者无恐怖。七者不共。八者不轻慢。九者无边。十者无碍解。善男子。菩萨若修如是十种法者即得乐说辩才。复次善男子。菩萨若修十种法者。得清净辩才。何等为十。一者无有謇吃。二者词无杂乱。三者远离卑劣。四者语不高戾。五者义无减失。六者文无缺漏。七者声无短阙。八者无不知时。九者言无粗犷。十者无不明了。善男子。诸菩萨者。所有辩才无有謇吃。何以故。菩萨于大众中无怯弱故。又菩萨者。所有辩才而无杂乱。何以故。菩萨智慧安然无畏。又菩萨者。所有辩才而无卑劣。何以故。菩萨处大众中。犹如师子离诸恐惧。又菩萨者。所有辩才语不高戾。何以故。已离烦恼故。若有烦恼语即高戾。无即不尔。又菩萨者。所有辩才义无减失。何以故。已得法故。若不得法即于义中有所减失。得即不尔。又菩萨者。所有辩才文无缺漏。何以故。广解诸论故。若解论鲜少即文有缺漏。广解即不尔。又菩萨者。所有辩才声无短阙。何以故。菩萨妙解一切音声故。若不解者即于音声有所短阙。解即不尔又菩萨者。所有辩才无不知时。所应前说而不后说。若应后说亦不前说。何以故。菩萨善知诸时分故。又菩萨者。所有辩才言无粗犷。无不悦意无不乐听。何以故已能远离语过失故。若有语过失者言即粗犷。无即不尔。又菩萨者。所有辩才无不明了。何以故。菩萨根性利故。若钝根者即不明了。利即不尔善男子。菩萨若修如是十种法者。即得清净辩才。复次善男子。菩萨若修十种法者。得一切有情欢喜辩才。何等为十。一者爱语。二者熙怡面相远离颦蹙。三者如义语。四者如法语。五者平等语。六者不自高。七者不轻他。八者无染着。九者无触恼。十者具种种辩才。善男子。菩萨能以爱语令诸有情咸生欢喜。又菩萨者。常现熙怡善相远虽颦蹙。令诸有情咸生欢喜。又菩萨者。常出如义语及美妙语。令诸有情咸生欢喜。又菩萨者。常出法语及利益语。令诸有情咸生欢喜。又菩萨者。常为有情平等说法。令诸有情咸生欢喜。又菩萨者。而不自高。远离骄慢高举之咎。令诸有情咸生欢喜。又菩萨者。不轻于他。常为有情恭敬说法。令诸有情咸生欢喜。又菩萨者。离诸染着具净尸罗。令诸有情咸生欢喜。又菩萨者。离诸触恼具多忍力。令诸有情咸生欢喜。又菩萨者。具种种辩才常出悦意之语。令诸有情咸生欢喜。善男子。菩萨若修如是十种法者。即得一切有情欢喜辩才。复次善男子。菩萨若修十种法者得信顺说法。何等为十。一者非法器有情菩萨不为说法。二者有障碍者不为说法。三者有所得见者不为说法。四者邪异外道不为说法。五者不起乐欲心者不为说法。六者不发清净心者不为说法。七者谄曲心者不为说法。八者求活命者不为说法。九者贪着利养悭嫉所缠者不为说法。十者盲聋喑哑者不为说法。何以故。善男子。菩萨不作法悭亦不秘法。于诸有情无不怜愍。为利有情而不弃背。所以者何。若有有情非法器者。菩萨乃起是念。此等有情。而于如来法律之中起于舍行。除盖障菩萨白佛言。世尊。若然者。诸佛菩萨当为何等有情说法。佛言。善男子。具信有情。诸佛菩萨当为说法。又若善根已成熟者。是法器者。于先佛所植众德本者。无谄诳者。不诈现威仪者。不耽着利养者。深心具足者。为善知识所摄受者。具足善相人所乐见者。根性明利于所闻法中解其义者。随所得法勤行精进者。如佛所说能修行者。此等有情。诸佛菩萨乃为说法。善男子。菩萨若修如是十种法者。即得信顺说法。复次善男子。菩萨若修十种法者为说法师。何等为十。一者修集佛法故说法。不见有佛法可得。亦复不见有所修集。二者修集波罗蜜多故说法。不见波罗蜜多可得。亦复不见有所修集。三者修集菩萨法故说法。不见有菩萨法可得。亦复不见有所修集。四者断烦恼故说法。不见有烦恼可得。亦不见断。五者厌离离贪寂灭故说法。不见有厌离离贪寂灭可得。六者为得须陀洹斯陀含阿那含果故说法。不见有须陀洹斯陀含阿那含可得。亦不见果。七者为得阿罗汉果故说法。不见有阿罗汉可得。亦不见果。八者为得缘觉果故说法。不见有缘觉可得。亦不见果。九者断我执取着故说法。不见有我可得。亦不见执着。十者显示业报故说法。不见有业可得。亦不见报。何以故。如是等一切法皆无实体。但以假名宣说。名亦无所有。所以者何。文字无自性。法离文字故。但以世俗虚假施设于无名中。是故建立诸法名字。由彼名空本虚假故。胜义谛中无虚假名。无假名故。于胜义中无虚妄法。彼虚妄法者诳惑愚人故。善男子。菩萨若修如是十种法者即为说法师。复次善男子。菩萨若修十种法者。能顺观法性。何等为十。一者菩萨虽顺观法性而不坏色相。虽顺观法性不坏受想行识相。二者虽顺观法性不坏欲界相。三者虽顺观法性不坏色界相。四者虽顺观法性不坏无色界相。五者虽顺观法性不坏诸法相。六者虽顺观法性不见诸法随顺相。七者虽顺观法性不见有情相。八者虽顺观法性亦不堕断见。九者虽顺观法性而不失正道。十者虽顺观法性亦不离智慧方便。善男子。菩萨若修如是十种法者。即能顺观法性

复次善男子。菩萨若修十种法者。善解法界理。何等为十。一者有慧。二者为善知识摄受。三者发起精进。四者离诸障染。五者善修净行。六者尊重赞法。七者善修空观。八者离有所得见。九者趣向正道。十者见真实法。善男子。菩萨具智慧故。而能勤求诸善知识。见善知识已心生欢喜。如师尊想亲近依止。由能依止善知识故。即发起精进。断除一切不善之法。圆满一切清净善法。勤行远离一切障染。离障染故获得轻安。善修净行离身语心一切过失。由清净故于所得法尊重称赞。由重法故多习空观。习空观故不起有所得见。离有所得见故顺行正道。入正道故能观真实

除盖障菩萨白佛言。世尊。何名真实。佛言。善男子。如实之义乃名真实。除盖障菩萨白佛言。何名如实。佛言。不虚妄故名为如实。除盖障菩萨白佛言。何名不虚妄。佛言。所谓真如。无不真如无异真如。除盖障菩萨白佛言。何名真如。佛言。善男子。此法唯内所证。非文字语言而能表示。何以故。此法出过诸文字故。离诸言说故。超越一切语言境界。出于言道离诸戏论。离作非作无动无静。离诸寻伺。是不思议境界。无相非无相而悉远离出诸相境。超诸凡境。出凡夫行。过诸魔境。超越一切烦恼境界。离诸识境。安处无住最上寂静圣智境界。是故此法唯内所证。是即无垢无染洁白清净。最上最胜第一无比。常住坚固究竟无坏之法。如来出世若不出世。是法常住。善男子。菩萨为求此法。历百千种难行苦行故得是法。得是法已。令诸有情悉住此法。善男子。故说此法名为真如。说名实际。说名一切智。说名一切种智。说名不思议界。说名不二界

佛说除盖障菩萨所问经卷第十佛说除盖障菩萨所问经卷第十一

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

尔时除盖障菩萨白佛言。世尊。此法云何能证。云何能解。佛言。善男子。出世间慧乃能证入内自明解。除盖障菩萨言。岂非慧证即是自心内解入邪。佛言。不也善男子。何以故。慧但如实能观诸法。由身作证故。除盖障菩萨言。若诸善男子。岂非以彼闻思修慧能证法时。便能内自得解入邪。佛言。不也善男子。非彼闻思修慧才得闻时便能内自解入。我今当以譬喻略明斯义。善男子。譬如大旷野中夏盛热时。或有一人自东而西。复有一人自西而东。当其炎毒渴乏所逼时。西至人谓东来者。我今极热为渴所逼。汝所从来善履途道。何处当有流泉池沼清冷之水。愿为我说令我饮之除其渴恼。其东来者。善知东方所有道路。亦复悉知有水之处。其味甘美及深浅等。即告之云。汝今前去当观一处有二道路。出于左者不应当诣。由于右者汝可往之。彼有园林苍翠滋茂。中有池沼。清流甘美衍漾弥满。善男子。于汝意云何。彼渴乏人才闻说示有妙池沼起思念时。便能除去渴恼之患。即能内自得清凉邪。除盖障菩萨言。不也世尊。而炎渴人。若亲诣彼有水之处。于其池中饮其水已。是人乃能除去炎渴内自清凉。佛言。善男子。闻思修慧非才得闻便能内自解入法性。亦复如是。汝今当知。大旷野者是生死境。夏盛热时受炎渴人。即是一切诸有情类。极炎炽者。即是烦恼六尘爱境。善知路人。即诸菩萨。善能知于一切智道。其饮水者即是内自入证解者。得法胜味轻清甘美。第一义谛诸法实性。善男子。汝今当听。复说譬喻。假使如来住寿一劫。于阎浮提一切人前。称赞天苏陀妙色妙香。最上清净精美之味。其所饮者得妙乐触。善男子。阎浮提人闻如是说。于色香等内了知邪。除盖障菩萨言。不也世尊。佛言。善男子。由是之故。当知闻思修慧非才闻时便能内自解入法性。汝今复听。譬若有人于果实中知一果名。自先食已。与未食人说其果味及色香等。善男子。于汝意云何。彼未食人而能了知其果味邪。除盖障菩萨言。不也世尊。佛言。善男子。由是之故。当知闻思修慧非才闻时便能内自解入法性

尔时除盖障菩萨前白佛言。善说世尊。善说善逝。如是内证理法。若有善男子。能一历耳当知是人即能具足闻思修法。何以故。是人已具不颠倒因。故得此法。佛言。如是如是。善男子。菩萨若修如是十种法者。即得善解法界之理。复次善男子。菩萨若修十种法者。善知空境界。何等为十。一者知力空。二者知无畏空。三者知不共佛法空。四者知戒蕴空。五者知定蕴空。六者智慧蕴空。七者知解脱蕴空。八者知解脱知见蕴空。九者知空空。十者知胜义空。虽知是空亦不以其空因缘故而于彼空有所得相。亦不执空。不起空见。不依止空。复不以其空因缘故堕于断见。善男子。菩萨若修如是十种法者。即善知空境界。复次善男子。菩萨若修十种法者。即能善修无相之。行何等为十。一者离外相。二者离内相。三者离戏论相。四者离一切遍计相。五者离一切有所得相。六者离一切举动相。七者离一切虚假相。八者离一切所缘相。九者离识有得相。十者离识所知境相。善男子。菩萨若修如是十种法者。即能善修无相之行

尔时除盖障菩萨白佛言。世尊。如是行相是菩萨修无相之行。云何复见如来所修。佛言。善男子。当知此是不思议处。何以故。离心境界故。一切有情若谓如来有所思者。彼即狂乱。所有如来。若此岸事。若彼岸事。乃至疲极终不可见。亦不可得。所以者何。如来之法不可思议。甚深难测。莫究其际。与虚空等。超出一切寻伺境界。超出一切有所得相。非诸惟忖较计度量之所能及。除盖障菩萨白佛言。世尊。我有少疑欲伸请问。若如来应供正等正觉。见听我问。愿为略说。佛言。除盖障。汝今当问斯为常事。除盖障菩萨白佛言。世尊。诸有自高之者乃非正士。如何世尊为大法王。今自赞说得非自高邪。佛言。善哉善哉。善男子。而汝心志深固能发是问。汝应谛听。极善作意。今为汝说。时除盖障菩萨受教而听。佛言。善男子。如来无我慢心亦不自高。不为利养名称所欲生于我慢。亦不为求人所知故。亦不起于谄诳心故生于我慢。但以己所得法。广为利益安乐一切有情。何以故。欲令有情于如来所发生清净欢喜之心。堪任法器者令彼获得一切善法。使其长夜得大利乐。除盖障菩萨白佛言。世尊。云何有情而不能知如来胜德。佛言。善男子。彼实不知。何以故。此佛刹中诸有情类。信解狭劣志着粗弊。少慧少信善根微鲜。而不能知如来胜德。是故如来乃自赞说所有功德。意欲令诸有情发生净信。能成如来诸胜功德。善男子。譬如有人为大医师善疗众病国中第一无有伦比。然其国中不知是人。明善方药具医胜得。时彼医师。见有疾苦所逼恼者即起是念。是人疾苦不善方药。我今应当为其治疗。是时医师诣病人所语其人言。我是医师明练方术。善知众病及病所因。汝之病恼善为治疗。时彼病人闻是言已。即于医师起信重心而作依仗。医师即时为其治疗病得除愈。善男子。于汝意云何。而彼医师于病人前。说已能解为自赞邪。除盖障菩萨白佛言。不也世尊。佛言。善男子。如来亦复如是。为大医王善疗有情诸烦恼病。知病所因施大法药。而诸有情为无明等诸烦恼病之所逼迫。如来见已即诣其前。称说如来具胜功德。令诸有情为其病苦所逼恼者。闻说如来胜功德已。能生清净信重之心。以佛如来而为依仗。是故如来胜大医王。为彼病者施大法药。使诸有情烦恼重病咸得销灭。善男子。何等是大法药。所谓多贪有情作不净观。多嗔有情作慈悲观。愚痴有情作缘生观。以是缘故。乃见如来自赞胜得。复次善男子。菩萨若修十种法者。得诸愿离着。何等为十。一者虽行布施而有愿求。亦不着于布施。二者虽持禁戒。亦不着于持戒。三者虽行忍辱。亦不着于忍辱。四者虽起精进。亦不着于精进。五者虽习禅定。亦不着于禅定。六者虽修智慧。亦不着于智慧。七者虽依三界。亦不着于三界。八者虽求菩提。亦不着于菩提。九者虽行正道。亦不着于正道。十者虽入涅槃。亦不着于涅槃。何以故。菩萨离诸所著虽于世间一切所行而悉无著。善男子。菩萨若修如是十种法者。即得诸愿离着。复次善男子。菩萨若修十种法者。得慈身具足。何等为十。一者无方分慈。二者无种类慈。三者法慈。四者定慈。五者不害慈。六者利益慈。七者于一切有情平等心慈。八者等心无嗔恚慈。九者周遍十方广大慈。十者出世间慈。善男子。菩萨若修如是十种法者。即得慈身具足。复次善男子。菩萨若修十种法者得悲身具足。何等为十。一者见诸苦恼无救无依无归趣者。菩萨见已发起菩提心。二者发菩提心已求所得法。三者历苦勤求得法成已。普为有情作大利益。四者悭贪有情令行布施。五者毁戒有情令持净戒。六者嗔心有情令修忍行。七者懈怠有情令发精进。八者散乱有情令住定心。九者无智有情令修智慧。十者菩萨为利有情故。不以艰苦坏失退转菩提胜行。善男子。菩萨若修如是十种法者。即得悲身具足。复次善男子。菩萨若修十种法者。善修喜行。何等为十。一者菩萨自得出离三有炽然。故生欢喜。二者为断长时轮回往来系缚之索。故生欢喜。三者菩萨远离种种寻求。自已得渡生死海中诸恶杂类。故生欢喜。四者菩萨自已摧折久远以来高慢之幢。故生欢喜。五者菩萨以智金刚。自已摧碎烦恼高峰细无尘末。故生欢喜。六者菩萨自得安隐。亦复令他悉得安隐故生欢喜。七者菩萨于其世间。贪爱执缚暗瞑所覆不得自在。长眠境中自能醒然睡眼明已。亦复令他悉能开觉。故生欢喜。八者菩萨自能解脱出离恶趣。亦复令他悉得解脱出离恶趣。故生欢喜。九者有情久处生死旷野险难之中。独行无侣周旋往返。不知其道不识方所。菩萨自能超出远离。而悉为他指导开示。故生欢喜。十者菩萨得近一切智城。故生欢喜。善男子。菩萨若修如是十种法者。即善修喜行。复次善男子。菩萨若修十种法者。即善修舍行。何等为十。一者眼虽观色而行舍行。亦不见眼识色境。若增若减若成若坏。二者耳虽听声。三者鼻虽嗅香。四者舌虽了味。五者身虽觉触。六者意虽知法而行舍行。亦复不见耳声鼻香舌味身触意法诸尘。若增若减若成若坏。七者虽观行苦而行舍行。亦不见行苦。若增若减若成若坏。八者虽观苦苦而行舍行。亦不见苦苦。若增若减若成若坏。九者虽观坏苦而行舍行。亦不见坏苦。若增若减若成若坏。十者观所作已办有情。菩萨于彼生欢喜心。乃起是念。我欲度彼。彼已自度。故修舍行。善男子。菩萨若修如是十种法者。即善修舍行。复次善男子。菩萨若修十种法者。即得神通游戏。何等为十。一者示现舍寿。二者入胎受生。三者现童子相宫中游戏。四者出家。五者苦行。六者诣菩提场。七者成等正觉降伏魔军。八者现寂静相。九者转妙法轮。十者入大涅槃

尔时除盖障菩萨前白佛言。世尊。何因缘故。菩萨示现兜率陀天舍寿。乃至示现入大涅槃。佛言。善男子。兜率陀天。诸有情等多生常想。而彼有情见菩萨于一切世间最上最胜。而复高显观者无厌。不为五欲境界所染。能起舍寿。而彼有情见已。转于常想生无常想。由依止无常故。即起不放逸行。又复有情起放逸心者。于菩萨所。虽有爱乐信重之心。然于诸境生爱着故。于菩萨所。不来亲近恭敬承事。而彼有情乃起是念。菩萨久住于此我亦久住。生放逸心。菩萨为欲令彼有情起于厌离得不放逸。由能不起放逸心故。即得不退转于阿耨多罗三藐三菩提。菩萨以是缘故。于兜率陀天示现舍寿。善男子。若有有情应以入胎受生而可度者。菩萨即现入胎受生之相。令其见已生希有心。菩萨处母胎中。为彼彼有情如应说法。令得不退转于阿耨多罗三藐三菩提。菩萨以是缘故。示现受生。善男子。若有有情应以童子宫中游戏之相而可度者。又以下劣信解诸有情类。菩萨为成熟故为护持故。乃现童子宫中游戏之相。善男子。若有有情应以出家之相而可度者。菩萨为成熟故。乃现出家之相。善男子。若有志着粗弊天龙夜叉乾闼婆阿修罗等。应以苦行之相而可度者。菩萨为欲成熟彼故。及为降伏诸外道故。乃现苦行之相。善男子。若有有情于长时中。念求菩萨。当于何时诣菩提场。我当随应作供养事。菩萨为欲成熟彼有情故。即为示现诣菩提场。至菩提场已。令诸有情随应供养。作供养已。而彼有情即得不退转于阿耨多罗三藐三菩提。善男子。若有有情自恃我慢贡高。菩萨为欲令彼转于我慢心故。现坐道场成等正觉降伏魔军。复为有情乐寂静者。便谓获得胜上所证。菩萨乃为示现成等正觉。菩萨成正觉时。三千大千世界种种音声皆悉寂然。而彼乐寂有情。见是三千大千世界皆寂然已。俱发愿言。愿我亦复如是。得成阿耨多罗三藐三菩提果。善男子。若有有情乐为师尊专志愿求。然不能知出离之法。亦复不知后世因果。菩萨为彼有情成熟善根。令其堪任法器。乃为开示正道故。成正觉已。诣迦尸国。三转十二行相圣妙法轮。善男子。若有有情应以入涅槃相而可度者。菩萨乃为示现入大涅槃。善男子。菩萨以是因缘。示现兜率陀天舍寿乃至入大涅槃。善男子。菩萨若修如是十种法者。即得神通游戏

佛说除盖障菩萨所问经卷第十一佛说除盖障菩萨所问经卷第十二

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

复次善男子。菩萨若修十种法者。能离八难。何等为十。一者离不善业。二者如来所立禁戒而不违越。三者远离悭吝。四者于先佛所植众德本。五者勤修福行。六者智慧具足。七者善解方便。八者胜愿具足。九者多起厌患。十者发勤精进。善男子。菩萨不造不善业故不堕地狱。设或示现生地狱中。亦不受彼地狱极苦。复不久处地狱之中。又不于彼有情生嗔恼心。何以故。谓以菩萨本性具修十善业故。以是因缘。菩萨不堕地狱。又善男子。菩萨于如来禁戒不违越故。不堕畜生之趣。设或示现生彼趣中。而亦不受畜生之苦。又善男子。菩萨不起悭吝。不以悭因缘故堕饿鬼趣。设或示现生彼趣中。而亦不受饿鬼之苦。又善男子。菩萨不生邪见之家。设生于彼亦不坏净信。而菩萨者。常得善知识共相会遇。何以故。菩萨久修善法。于先佛所植众德本。而常于彼正见家生。于彼生已净信具足。亦复广大增长净信。又善男子。菩萨诸根亦不缺坏。若复诸根有所缺坏。即于佛法中不能堪任法器。何以故。菩萨广集福德勤修福行。常尊重供养如来塔庙若法若僧。常所亲近作诸胜行。由胜行广修于己。乃得诸根圆具。以圆具故。于佛法中即大法器。又善男子。菩萨不生边国。其中有情愚騃聋哑。色力不具无所堪任。善言恶言不晓其义。于佛法中非其法器。不识父母沙门婆罗门。是故菩萨常生中国。其中有情根性明利。多有智者。复为智者所许。是所堪任具有力能。善言恶言悉晓其义。于佛法中是大法器。深信沙门婆罗门。何以故。先所修习智慧力故。又善男子。菩萨不生长寿天。若生其中。虽有无数诸佛出世。亦不值遇。利有情事不能成办。是故菩萨生于欲界。此中有情值佛出世。爱乐亲近而可化度。何以故。菩萨善具方便故。又善男子。菩萨不生无佛世界。若生其中。即不见佛不闻法不供僧。是故菩萨生于三宝具足佛刹之中。何以故。由昔所修胜愿具故。又善男子。菩萨若闻诸可厌事。无有不生厌恶心者。何以故。菩萨才闻是事。即起厌患之心。生厌患已发勤精进。修诸善法断诸恶法。善男子。菩萨若修如是十种法者。即能远离八难。复次善男子。菩萨若修十种法者。得不忘失菩提心。何等为十。一者远离谄诳。二者正而无曲清净洁白。远离追求犹豫分别。三者受持佛法。四者于法而不秘惜。五者远离法悭。六者不作障法因缘。七者无不实语。八者摄受大乘之法如说能行。于彼受持大乘人所起尊重心。九者于彼受持大乘人所。为渐入大乘故起亲近想。十者深入大乘故。于说法人起师尊想。善男子。菩萨若修如是十种法者。即得不忘失菩提心。复次善男子。菩萨若修十种法者。得宿命通。何等为十。一者供养诸佛。二者摄持正法。三者修持净戒。四者除疑离障。五者多生欢喜。六者多作观想。七者常住定心。八者生处清净。九者常受化生。十者得明利识。善男子。菩萨由广供养佛故。即能尊重正法。以重法故。乃于持法人所。以彼因缘。能于正法受持读诵。以所得法广为他说。由是不惜身命。勤行修习受持正法。复能修持净戒。戒有三种谓身语心。由其三业戒清净故。即能除疑离诸障染。何以故。先由戒行清净。即能除疑离障。离疑障故多生欢喜。以心喜故多作观想。由观想故常住定心。心住定故生处清净。处清净故常受化生。以化生故得明利识。识明利故能知一生二生三四五生。若十二十乃至百千无数生中宿命通事。善男子。菩萨若修如是十种法者。得宿命通。复次善男子。菩萨若修十种法者。得不离善知识。何等为十。一者不离见佛或闻或念。二者不离闻法。三者不离供僧。四者不离于诸佛菩萨。赞叹礼拜合掌恭敬或复顶礼。五者不离于多闻人所听受说法。六者不离听受波罗蜜多法。七者不离听受菩提分法。八者不离听受三解脱法。九者不离听受四梵行法。十者不离听受一切智法。善男子。菩萨若修如是十种法者。即得不离善知识。复次善男子。菩萨若修十种法者。得远离恶知识。何等为十。一者远离破戒人故。即能离恶知识。二者远离坏正见人。三者远离坏轨范人。四者远离坏正命人。五者远离耽湎之人。六者远离懈怠之人。七者远离沉没生死之人。八者远离背菩提人。九者远离习近白衣之人。十者远离诸烦恼故。能离恶知识。善男子。菩萨虽于如是等处皆悉远离。而亦不于彼等人所生恚恶心生恼害心生轻慢心。菩萨但起是心。如佛所说。一切有情诸界缘成。性欲相染习相近故即有所坏。是故我今离所习性。善男子。菩萨若修如是十种法者。即能远离恶知识。复次善男子。菩萨若修十种法者。得如来法身。何等为十。一者得平等身。二者得清净身。三者得无尽身。四者得积集善身。五者得法身。六者得不可计度难测之身。七者得不思议身。八者得寂静身。九者得等虚空身。十者得妙智身。善男子。菩萨若修如是十种法者。即得如来法身。除盖障菩萨白佛言。世尊。何等分位菩萨得如来法身。佛言。善男子。初地菩萨得平等身。何以故。而此菩萨。能离一切险恶之身。遍知一切菩萨地法。二地菩萨得清净身。善具净戒故。三地菩萨得无尽身。已离一切嗔恚故。四地菩萨得积集善身。积集诸佛法故。五地菩萨得法身。了知一切法故。六地菩萨得不可计度难测之身。积集一切不可计度甚深法故。七地菩萨得不思议身。积集善巧方便故。八地菩萨得寂静身。远离一切戏论及离诸烦恼故。九地菩萨得等虚空身。能现无量广大身故。十地菩萨得妙智身。积集一切所知法故。除盖障菩萨白佛言。世尊。如来法身与菩萨法身有别异不。佛言。善男子。身无有别。其功德相而各有异。除盖障菩萨白佛言。世尊。云何身无有别功德相异。佛言。善男子。身实无异。何以故。身者积集所成同一相故。然功德相而各有异。除盖障菩萨白佛言。世尊。功德相异者。其事云何。佛言。善男子。我今说喻以明斯义。譬如摩尼之宝若不磨治与磨治者。二宝俱名摩尼之数。而彼已磨治者。摩尼之宝。光明焕耀莹洁可爱。与不磨治不可伦比。菩萨身摩尼宝。如来身摩尼宝。亦复如是。如实皆同。然菩萨身摩尼之宝。对如来身摩尼宝前。说其清净。光明之相不可伦比。何以故。以如来身摩尼之宝广大无量。满有情界及虚空界。光明显焕照耀而住。所以者何。如来身摩尼宝者。磨治清净离一切垢。不可以菩萨身摩尼之宝而为伦比。何以故。菩萨有余垢故。又善男子。如白分中初二夜月与彼望夕。圆明相远体无殊异。法有差渐故。如来之身菩萨之身。亦复如是。俱名为身。然菩萨身光明照耀。对如来前不可伦比。其犹初二与十五月。善男子。是故当知。说如来身与菩萨身。虽同一相而功德异。复次善男子。菩萨若修十种法者。得金刚不坏身。何等为十。一者不为贪嗔痴所坏。二者不为忿恼疲倦骄慢颠倒见等所坏。三者不为世间八法所坏。四者不为恶趣之苦所坏。五者不为一切苦所坏。六者不为生老死苦所坏。七者不为一切外道他论所坏。八者不为诸魔及魔眷属所坏。九者不为声闻缘觉所坏。十者不为一切欲境所坏。善男子。菩萨若修如是十种法者。即得金刚不坏之身。复次善男子。菩萨若修十种法者。为大导师。何等为十。一者得他信许。二者为他所敬。三者善作指引。四者为他依止。五者能为济命。六者善备资粮。七者富有财宝。八者无其止足。九者为作先导。十者善到一切智城。云何是得他信许。乃至善到一切智城。善男子。如海导师若王若王臣皆悉信许。菩萨大导师亦复如是。若诸佛若佛之声闻弟子皆悉信许。又善男子。如海导师得婆罗门刹帝利等一切人民恭敬供养。菩萨大导师亦复如是。得一切学无学众。及余天龙夜叉乾闼婆等恭敬供养。又善男子。如海导师能于旷野险难之中为作指引。令其安隐不生疲倦。菩萨大导师亦复如是。能于生死旷野险难之中。为诸有情指引其道。令知烦恼恶贼之处。使获安隐不生疲倦。又善男子。如海导师为诸孤露困苦之者作其依止。使令得出旷野险路。菩萨大导师亦复如是。能为诸外道等而作依止。使令得出生死旷野大险恶道。又善男子。如海导师能为王官及余人众。设以所须作其济命。菩萨大导师亦复如是。能为耽着生死诸有情类。设以方便作其济命。又善男子。如海导师随诸方处若行若住。与诸商众同涉旷野险恶道路期至城邑。是时导师善备资粮令诸商众同出旷野险恶之道。乃至安隐得到城邑。菩萨大导师亦复如是。随欲往诣亲近佛所。欲为摄受广多有情。过大生死险恶道中。欲令有情悉到一切智大城之所。是故菩萨善备福智诸行资粮。又善男子。如海导师欲止诸方富有财宝资生缘具。所谓金银琉璃摩尼珊瑚车渠等宝。菩萨大导师亦复如是。欲止一切智大城故。广集一切佛法胜行。又善男子。如海导师于其财宝希取无足。菩萨大导师亦复如是。于圣法财积集无足。又善男子。如海导师与诸商众善为先导。何以故。为主宰故。善增益故。所作胜上故。能以爱语而摄受故。菩萨大导师亦复如是。能为一切有情而作先导。何以故。于功德法善增益故。分位胜上故。为胜主宰故。出实语故。又善男子。如海导师具力能故得到城邑。菩萨大导师亦复如是。具胜力能得到一切智大城。善男子。此等是为菩萨得他信许乃至善到一切智城。善男子。菩萨若修如是十种法者。为大导师。复次善男子。菩萨若修十种法者。善知正道。何等为十。一者善知道路平坦。二者善知道路险恶。三者善知道路安隐。四者知其道善。五者善知道路流润枯涸。六者善知道路处所。七者善知道路之相。八者善知道路正直。九者善知道路诘曲。十者善知道路出要。善男子。菩萨若修如是十种法者。善知正道。复次善男子。菩萨若修十种法者。善能说示无颠倒道。何等为十。一者应以大乘所度有情。即为宣说菩萨道法。不说声闻道法。二者应以声闻乘所度有情。即为宣说声闻道法。不说菩萨道法。三者应以一切智道所度有情。即为宣说一切智法。不说缘觉道法。四者应以缘觉乘法所度有情。即为宣说缘觉道法。不说一切智道。五者着于我执法执诸有情类。如应为说空无我法。不说我及有情寿者养育补特伽罗道法。六者依着二边有情。即为宣说离二边法。不说着二边法。七者散乱有情。即为宣说止观道法。不说散乱之法。八者爱着戏论有情。即为宣说真如道法。不说愚夫爱着戏论之法。九者乐着生死有情。为说涅槃道法。不说生死之法。十者住邪道有情。为说离其过失荆棘之法。不说烦恼荆棘之法。善男子。菩萨若修如是十种法者即能说示无颠倒道

佛说除盖障菩萨所问经卷第十二佛说除盖障菩萨所问经卷第十三

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。即得常住妙等引心。何等为十。一者善行身念处。二者善行受念处。三者善行心念处。四者善行法念处。五者善行境界念处。六者善行阿兰若念处。七者善行王都国城聚落念处。八者善行名闻利养等事念处。九者善行如来施设学门念处。十者善断烦恼及随烦恼杂染念处。善男子。云何是菩萨善行身念处。谓若菩萨。所有身中从我所起罪不善法。以其胜慧审细思择。皆悉远离。又复观察身诸过失。下从足心上至顶门。筋脉缠缚。遍观其身。而悉无我。不得暂停败坏之法。是身不净。诸不成熟臭秽可恶。众恶色相共所积集。菩萨作是观时。若身中身贪爱诸欲。身计我想身所执着。是等诸法悉不可得。以是缘故。与身俱者诸不善法不得自在。余与身俱一切善法而得自在。如是名为善行身念处。云何是菩萨善行受念处。谓若菩萨作是思惟。所有诸受皆悉是苦。云何愚人。于中颠倒计以为乐。诸愚痴者不识苦乐。唯诸圣人悉知是苦。菩萨自能勤行断苦受已。复教他人亦悉同己如是修学。菩萨作是观时。又于彼受不生染爱。不起嗔恚。自勤行已。复令他人亦如是学。如是名为善行受念处。云何是菩萨善行心念处。谓若菩萨作是思惟心实无常计执为常。以苦为乐。无我谓我。不净谓净。是心动摇不得暂停。如风轻转。而为烦恼最初根本。亦复为诸随烦恼缘。开恶趣门破坏善趣。又复为缘生贪嗔痴。与一切法为胜主宰。一切法中心为先导。若心有知。即一切法亦有所知。心如画师画诸物像。心不见心。心能积集善不善业。是心循环如旋火轮。是心迅转其犹奔马。心如野火炽焰烧然。心如大水滋长众物。菩萨作是观时。而实其心不得自在。诸菩萨者自能调伏。心若调伏。即一切法悉得调伏。如是名为善行心念处。云何是菩萨善行法念处。谓若菩萨。于不善法如实了知所谓贪嗔痴等及所依止。贪之对治余不善法。嗔痴对治诸不善法。菩萨于是不善法中。勤断除已。即能了知一切善法。于善法中。起心爱乐住正念处。而于彼法求所成办。自能行已。复教他人如是修学。如是名为善行法念处。云何是菩萨善行境界念处。谓若菩萨。于诸可意及不可意色声香味触诸境界中。不生贪着不起恚心。菩萨作是思惟。我今不应于此无体相法中而生贪着。若生贪者即是愚人。具愚痴性是不明了性。是不善性。如佛所说。若生贪者。即起染着愚痴计执。不能分别善不善法。以是缘故堕恶趣中。菩萨又作是念。我今不应于此空法之中而起恚心。起恚心者。即不能忍发生嗔恚。为诸圣人之所讥毁。同梵行者而共厌弃。菩萨作是观时。不为境坏不着所得。菩萨自能行已。复教他人亦如是学。如是名为善行境界念处。云何是菩萨善行阿兰若念处。谓若菩萨作是思惟。修无诤行及寂静行。是即名为住阿兰若处。有诸天龙夜叉乾闼婆等他心通者。能知我心及心所法。是故我今应当远离不如理作意及异思惟。于一切处亦复常离不如理作意。于如理法中。起心爱乐增广修习。如是名为善行阿兰若念处。云何是菩萨善行王都国城聚落念处。谓若菩萨。入于王都国城聚落之时。当起菩萨所行之行。于诸非处皆悉舍离。非出家人所应行处。亦悉舍离。何等是非出家人所应行处。所谓王官之舍。博弈之会。酒肆欢宴歌舞倡伎所住之处。及余一切非出家人所应行处。当远离之而悉不往。如是名为善行王都国城聚落念处。云何是菩萨善行名闻利养等事念处。谓若菩萨。于诸名闻利养等事。但为施主作福田故。随所起心而乃受之。然其所受。不起贪爱。不生取着。复不计执。不作己有之想。不起我所之相。随其所得即与一切有情共之。诸苦恼者济其资养。以是缘故。乃于名闻利养等事。不生高举。不起我慢。不恣骄逸。菩萨作是思惟。诸有名闻利养等事。若自若他。暂时所起而不久停以暂起故。于一切时及一切处悉无所得。谁诸智者。于此无常不久不坚不安隐法。中生染爱心及生高举我慢骄逸。如是名为善行名闻利养等事念处。云何是菩萨善行如来施设学门念处。谓若菩萨作是思惟。所有过去一切如来皆如是学。如是学故已成正觉入大涅槃。未来世中一切如来皆如是学。如是学故当成正觉入大涅槃。及现在世一切如来亦如是学。如是学故现成正觉入大涅槃。以是缘故。于此学门起清净心。而生尊敬勤勇修习。如是名为善行如来施设学门念处。云何是菩萨善断烦恼及随烦恼杂染念处。谓若菩萨。以正念故。善能了知一切烦恼。及随烦恼。杂染等法。何因所起何缘所生。菩萨悉知如是因起如是缘生以了知故而悉远离。如是名为善断烦恼及随烦恼杂染念处。善男子。菩萨若修如是十种法者。常住妙等引心。又善男子。菩萨若修十种法者。常着粪扫衣。何等为十。一者坚固誓愿。二者谦下其心。三者不生疲倦。四者离诸有着。五者不观过失。六者唯观功德。七者不自赞誉。八者不毁谤他。九者戒行具足。十者圣贤亲近。善男子。云何是菩萨誓愿坚固。乃至圣贤亲近。谓若菩萨。自有净信志意具足。为诸如来之所信许。设或遇于护命因缘。亦不破毁所发誓愿。能于誓愿无所改转。由能坚固彼誓愿故。即能谦下其心不生我慢。心谦下故。能以一切人所嫌弃粪扫之物而悉取之。取已洗涤治染缝缀。不生厌恶而不疲倦。不疲倦故。随所作已离诸有着。乃至胜业修进得成。而能于此粪扫之衣不观过失。虽云此衣坏烂故弊复多蚤虱。若被于身而生垢污。菩萨终不观其过失。何故此衣唯观功德。谓此粪扫衣者仙人所服。离欲圣者亦悉随顺。顺圣种故。佛赞吉祥。佛所称叹。以是缘故。不自赞誉不毁谤他。由离自赞不谤他故。即得戒行具足。清净戒具足故。一切圣贤之所亲近。诸佛称赞。及诸菩萨之所守护。人非人等而共佑助。诸婆罗门及刹帝利。一切人民咸来礼敬。同梵行者而悉咨嗟。善男子。菩萨若修如是十种法者。常着粪扫衣

尔时除盖障菩萨前白佛言世尊。诸菩萨者具广大心何故行斯粗劣行耶。佛言。善男子。菩萨为护世间随顺转故。乃行斯行。善男子。菩萨有具大势力者。有不具者。为彼不具大势力者。令起对治未生烦恼。故行斯行。又善男子。于汝意云何。汝谓如来行解为广大邪。为浅劣邪。除盖障菩萨白佛言。世尊。我无此辩不堪酬对。所以者何。无能测度如来行解之者。以如来无法可证。无法可见。是故如来无有少法可为行解。佛言。善男子。于汝意云何。汝谓如来以何缘故。于四大洲中诸人非人。及余劣信解者。天龙夜叉乾闼婆等众中。现斯粗劣之行。及于彼前称赞头陀功德。除盖障菩萨白佛言。世尊。如来为欲化度诸有情故。及为初住大乘菩萨。令起对治未生诸烦恼故。乃行斯行。佛言。善男子。如是如是。诸有大力菩萨。为欲成就化度有情故着粪扫衣。斯亦非为下劣粗行。以是缘故。菩萨常着粪扫之衣。又善男子。菩萨若修十种法者。但受三衣。何等为十。一者喜足。二者少欲。三者远离希求。四者离所积聚。五者离积聚故无所坏失。六者无坏失故离诸苦恼。七者离不悦意。八者远离愁叹。九者无所受。十者勤修习故而得漏尽。善男子。云何是菩萨喜足。乃至勤修习故而得漏尽。谓若菩萨。随所得衣便生喜足。由喜足故而能少欲。以少欲故。无所希求离诸积聚。无积聚故而无坏失。无坏失故。即离坏失所生苦恼。离苦恼故无不悦意。离不悦意故乃无愁叹。无愁叹故而无所受。无所受故勤行修习。乃得漏尽。善男子。菩萨若修如是十种法者。但受三衣。又善男子。菩萨若修十种法者。不随他行。何等为十。一者不随贪行。二者不随嗔行。三者不随痴行。四者不随恚害行。五者不随悭嫉行。六者不随我慢行。七者不随求他知识名称事行。八者不随希取利养事行。九者不随恭敬天魔而行。十者不随高举染爱而行。如是名为不随他行。善男子。菩萨若修如是十种法者。即不随他行。又善男子。菩萨若修十种法者。常行乞食。何等为十。一者为欲摄受有情故行乞食。二者次第而行乞食。三者不生疲倦而行乞食。四者喜足而行乞食。五者为欲分布而行乞食。六者不耽着故而行乞食。七者善知量故而行乞食。八者为令善品得现前故而行乞食。九者令得圆满诸善根故而行乞食。十者离身想故而行乞食。善男子。云何是菩萨摄受有情。乃至离身想故而行乞食。谓若菩萨。见诸有情受苦恼者善根微少。为欲摄受令其具足诸善根故而行乞食。菩萨若入城邑聚落行乞食时。当住正念端直其身。进止可观威仪有则。诸根寂静如理瞻视系念善法。所行乞食依其次第。终不弃舍贫窭之舍而从富乞。谓于婆罗门刹帝利长者居士诸大族舍。从一至一次第行乞。所获饮食知量止足。唯除异处而悉不往。谓异处者。恶犬畜家及有新生犊子之舍。破坏净戒堕畜生中能起娆乱之者。若男若女童男童女共所嫌弃。如是等处皆悉远离。由其次第行乞食故。不生疲倦亦无讥毁。于彼有情不生染爱不起嗔恚。亦不厌弃。所得之食。随应而受便生喜足。受已还复所居僧坊。收其衣钵盥手濯足。于如来像前或如来塔前。尊重恭敬作供养已。入自舍中以所乞食而为四分。一分授彼同梵行者。一分施于贫苦有情。一分当施堕恶趣者。一分自食。菩萨虽受其食不生染爱。不起骄逸亦不取着。其所受食但为资养身故。亦不令其身极羸瘦亦不沉重。何以故。若极羸瘦妨修善法。若极沉重增长睡眠。菩萨为令善品得现前故。随受食已发起精进离诸懈怠。渐当修进菩提分法令得圆满。以其修进菩提分法得圆满故不起我执。无我执故。乃至能以身肉施诸有情。善男子。菩萨若修如是十种法者。即常行乞食

佛说除盖障菩萨所问经卷第十三佛说除盖障菩萨所问经卷第十四

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。得一坐法何等为十。一者一坐菩提场中。诸魔惊怖而永不动。二者证出世定而永不动。三者具出世慧而永不动。四者得出世智而永不动。五者证悟空性而永不动。六者如实觉了诸法而永不动。七者得圣道法而永不动。八者住于实际而永不动。九者证真如性而永不动。十者成一切智智而永不动。善男子。此一坐者是谓一切智座。亦名法座。是故菩萨一登其座而永不动。是即名为一坐之法。善男子。菩萨若修如是十种法者得一坐法。又善男子。菩萨若修十种法者常受一食。何等为十。一者不生贪恣。二者不起染着。所谓一受食已。若时非时余诸所有资身之食。不应受者不复受之。谓苏油石蜜根茎华果。种种美味而悉不受。三者若见他人受苏油等诸美味时。不生恚害之心。四者不生嫉妒之心。五者菩萨若于非时婴缠重病。所应食者为疗治故而当受之。六者菩萨若命有难。所应食者而当受之。七者菩萨若于善法有障难时。所应食者而当受之。八者菩萨受已不悔。九者菩萨受已不疑。十者菩萨随所受时当作药想。善男子。菩萨若修如是十种法者。即常受一食。又善男子。菩萨若修十种法者。善住阿兰若处。何等为十。一者久修梵行。二者善解律仪。三者诸根圆满。四者具于多闻。五者有大力能。六者离于我执。七者犹如野兽。八者身得远住。九者寂静现前。十者无所厌离亦无爱着。善男子。云何是菩萨久修梵行。乃至无所厌离亦无爱着。谓若菩萨。于佛最上法律之中。舍家出家三轮清净。戒行具足体性善巧妙解律仪进止轨范。于佛所说上中下法诸有修学。不假他缘善自解了。谓即教义及出离法。又知诸罪及罪所有出要之法。于如是处所应远离。于如是处所应恭敬而悉能知。又于其罪可讥毁者。广陈忏悔亦不覆藏。又知是处有罪是处无罪。若轻若重上中下罪而悉能知。又知世间所造业因感异熟果。如实成办悉了知故。如是菩萨。诸根不减身分圆满。身圆满故即能栖止阿兰若处。依彼住故是处寂静无诸娆恼。非近非远乞食易得。甘泉清洁取不为劳是处可乐。树林青翠华果茂盛而悉具足。离诸虫兽龛岩安隐虽高而平。快乐调适閴然无侣。菩萨依止如是寂静阿兰若处。得安住已。以所习诵及先所闻诸有典教。昼夜持诵六时无间。音韵调畅不高不低。容止寂然心不外缘。而悉清净息诸境界。思惟教义离于睡眠。若时住彼阿兰若处。或有国王及诸王臣。并余沙门婆罗门等。诸刹帝利一切人众来菩萨所。即时应起恭敬前迎。作如是言。善来大王今可就坐。乃为随宜敷设其座。若王坐时已即当坐。若王不坐随所应立。又复观王。若见诸根有所动乱。即时赞言。快哉大王。王得善利统大国界。王之境内多有持戒具大德者。复有多闻沙门婆罗门等而共栖止。亦无盗贼王官等事而为娆乱。又复观王诸根善寂举止安详堪所授法。即为宣说种种之法。王若不乐种种法时。即当为说诸可厌离随顺之法。若复不乐厌离法时。即当为说如来其有广大威德殊胜之法。或余婆罗门刹帝利等。一切人众诸有来者。随其所应皆悉如是。菩萨由此具多闻故。有大势力能善说法。令其闻者生大欢喜。发起清净爱乐之心。菩萨由是具势力故即能发起。为诸有情对治烦恼。获得多闻及大势力。是故即能离于我执。离我执故住阿兰若。自在无畏不生惊怖。乃于是处现前寂静。离于愦闹犹如野兽。然其菩萨不同野兽常生惊怖及有过失。何以故。而诸野兽远离于人及人所居。避走远去以护命故。菩萨远离愦闹之处。但为不杂一切世间。若男若女童男童女。愦闹等事虑其散乱。于誓愿心有所障难。以是缘故。修止息行已得现前寂静。由寂静故。即能见于阿兰若处有胜功德。由见功德住寂静故。即无厌离亦无染着。是故能成无所厌离无染着法。是为菩萨久修梵行乃至无所厌离亦无染着。善男子。菩萨若修如是十种法者。即得善住阿兰若处。又善男子。菩萨若修十种法者。常树下坐。何等为十。一者不得极近聚落依树下坐。二者不得极远聚落依树下坐。三者不于棘刺丛林树下而坐。四者不于藤蔓缠缚树下而坐。五者不于枯叶树下而坐。六者不于有猕猴处树下而坐。七者不于有飞鸟处树下而坐。八者不于恶犬住处树下而坐。九者不于近道路处树下而坐。十者不于恶人住处树下而坐。何以故。菩萨若能离如是处依树下坐。即身得轻安心生适悦。善男子。菩萨若修如是十种法者。常树下坐。又善男子。菩萨若修十种法者。常露地坐。何等为十。一者于春夏秋冬不依墙壁而坐。二者不依树林下坐。三者不依草积处坐。四者不依山腹间坐。五者不依河岸坎侧处坐。六者不置御寒之具。七者不置障风之具。八者不置却雨之具。九者不置辟热之具。十者不置承露之具。善男子。菩萨虽常露地而坐。或时身为重病所婴胑体羸弱。应当于彼僧坊中住。菩萨尔时乃作是念。如佛所说。为令对治烦恼不起及离取着故。佛赞说头陀功德。我今亦然。虽处僧坊但为断除烦恼离爱着故。复为摄受诸施主故。又虽处僧坊而常起彼露地之想。善男子。菩萨若修如是十种法者。常露地坐。又善男子。菩萨若修十种法者。能冢间住。何等为十。一者菩萨随于处处得好住止皆生厌离。二者于一切时常起死想。三者常起残余之想。四者遍观赤色之想。五者遍观青瘀之想。六者遍观脓血之想。七者遍观膖胀之想。八者观于干燋之想。九者观于离散之想。十者常观骨锁之想。善男子。冢间住者。诸菩萨等常起慈心。广利益心。悲愍一切有情之心。戒行清净修持具足而不食肉。何以故。而诸冢间周匝多有非人鬼神依止而住。或见菩萨若食肉时。不起清净爱乐之心返生娆恼。又善男子。冢间菩萨若入僧坊。先当诣于如来塔前恭敬礼拜。次当礼奉耆年尊者。后应问讯少年苾刍。不坐众僧床敷坐具。何以故。菩萨为护世间相故。又复住于冢间菩萨随顺圣者。违背世间诸愚夫等。若有苾刍独居之者。以己床座而来。奉彼冢间菩萨请就于座。菩萨尔时坚辞不坐。然复审察斯苾刍意后无变悔。乃至观于余苾刍众。不生毁谤而可就坐。即时亦当卑下其心。与旃陀罗童子等无有异。善男子。菩萨若修如是十种法者。能冢间住。又善男子。菩萨若修十种法者。即能常坐。何等为十。一者不为逼恼身故常坐。二者不为逼恼心故常坐。三者不为离睡眠故常坐。四者不为身疲倦故常坐。五者菩萨为欲圆满菩提行故常坐。六者为住心一境性故常坐。七者为令圣道得现前故常坐。八者为登菩提场故常坐。九者为利诸有情故常坐。十者为断诸烦恼故常坐。善男子。菩萨若修如是十种法者。即能常坐。又善男子。菩萨若修十种法者。即随宜敷座。何等为十。一者不耽着床座。二者不自敷设床座。三者不令他人敷设床座。四者不作相故敷设床座。五者或于他处若草若叶随得便坐。六者于诸方处。若有毒虫蚊虻等类所居窟穴。当远避之不应敷座。七者菩萨卧时右胁着床。累足而卧以衣覆身。正念正知专作明想专念起想。八者不着睡眠乐味。九者右卧疲倦不左回转。而更求于睡眠之乐。但为资养诸大种故。十者常念诸善品法而得现前。善男子。菩萨若修如是十种法者。即随宜敷座。又善男子。菩萨若修十种法者。成瑜伽行。何等为十。一者多修不净观行。二者多修慈心观行。三者多修缘生观行。四者于诸过患善能除断。五者多修空观。六者多修无相观行。七者多修瑜伽观行。八者常能勤加修习。九者心不变悔。十者戒行具足。善男子。云何是菩萨修不净观行。谓若菩萨独居异处。现前寂静端身详缓。起明了意加趺而坐。安住正念心不外缘。作是思惟。人间所有一切饮食。若清净味若最上味。妙香具足或粗粝味。是诸饮食身火所触。皆成不净臭秽可恶。世间愚夫执见违背。于其味中耽染爱着。我等圣者依正法律。宜以正慧如实伺察。于斯等身不应爱染而生耽着。以是缘故常当发起厌离之心。是为菩萨修不净观。云何是菩萨修慈心观。谓若菩萨。独居异处端身详缓。起明了意加趺而坐。安住正念心不外缘。作是思惟。若诸有情多生恚害造不善业。于我无状而起怨害。若过去若未来若现在。三世之中一切有情。于我所起一切恚害皆令断灭。使彼悉当坐菩提场。此是菩萨甚深意乐常所思惟。非但语说皆悉如实。是为菩萨修慈心观。云何是菩萨修缘生观。谓若菩萨于已生贪。及已生嗔已生害心。此等法中作是思惟。若法有生皆从缘起。即此缘法亦从缘生。能生之缘既属缘法。岂诸智者于此缘生空法之中计有我想。是为菩萨修缘生观

佛说除盖障菩萨所问经卷第十四佛说除盖障菩萨所问经卷第十五

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。云何是菩萨于诸过患善能除断。谓若菩萨于自身中所有过患勤行除断。若他身中诸有过患教令断灭。不堪任者即当舍离。何等是过患。所谓于佛法僧不生尊重。及于戒学并诸圣人。同梵行者上中下位。于是等处不生尊重。自生我慢轻易于他。顺诸爱境逆背涅槃。起于我见有情寿者士夫养者补特伽罗等见。执空断见执常无常。不乐诸圣亲附愚人。远离清净持戒之者。尊重供养破戒之者。随逐恶友弃舍善友。毁谤如来甚深经典。复于深经而生惊怖。懒堕懈怠轻贱己身。志性下劣无有威光。亦无辩才非处造恶。不应疑处乃生疑惑。所应疑处而不能疑。盖障缠缚谄诳随逐。惛沉睡眠之所覆蔽。乐着利养贪爱种族眷属国土。起诸爱见贪爱众会。复常习近外道典籍。厌离正法破毁誓愿。惯习修作不善之法。于诸善法而不惯习。亲洽于彼非出家人。又复亲洽男子女人童男童女及诸外道。不乐阿兰若处。食不知量。而不亲附师尊长宿。凡所习诵亦不知时。又复不知所行方处。微细戒学亦不尊敬。观其小罪不生怖畏。于其痴暗根性之者计为寂静。于其高胜利根之者。倨傲而行起诸邪执常出恶言。于诸可爱及不可爱色相之中随顺执着。见嗔恚者不起慈心。见苦恼者不生悲愍。见疾病者不起厌离。见彼死者不怀惊怖。于火宅中不求出离。不能审细伺察其身。不观戒行。何者已作。何者当作。何者现作。而悉不能审细伺察。不应思惟而起思惟。不应计度而起计度。不应追求而起追求。非出离中计出离想。非道之中计正道想。未得所证计已得想。世俗所作专一其心。非所作中而生勤勇。广大善法常所远离。毁谤大乘之法。称赞声闻乘法。毁谤深信大乘之人。称赞修行声闻道人。常与他人而共言讼。常兴斗诤恶口粗言。为性高倨自恃胸臆。碜毒暴恶恣其贪婪。语无诚信轻毁他人。非说而说言多虚妄。爱乐计着诸有戏论。此等是为种种过患。菩萨善断如是过患已。离诸戏论勤修空观。菩萨虽复多修空观。然于处处其心流散有所乐住。菩萨即时于诸境处遍求自性。皆悉是空了不可得。由境空故。观察彼心亦悉是空。心境空故能观察智而亦是空了不可得。菩萨又复勤行观察诸相皆空。菩萨虽观无相。犹有彼彼诸相现前而为对碍。是故乃观无有内相。无内相故身不可得。及身念住亦不可得。亦不系心。于身亦无外相可得。亦无外相念住可得。心不系着外相离故身相亦离。由内诸相得断灭已。勤行发起修习意乐由多修习诸观行故。能常勤修于奢摩他毗钵舍那。所修之行中无间断。所谓心一境性是奢摩他。如实观察诸法自性。是毗钵舍那。由心一境性住奢摩他故。即于三摩呬多心欢喜无悔。何以故。若戒清净及戒具足。是即菩萨瑜伽之行。以戒具足故增长瑜伽。戒具足故修习瑜伽。此说名为修瑜伽行。善男子。菩萨若修如是十种法者。善修瑜伽之行。又善男子。菩萨若修十种法者。能持如来修多罗教。何等为十。一者为护正法故听闻受持不为资财。二者为守护教故听闻受持不为利养。三者令三宝种得不断故听闻受持不为求他恭敬。四者为欲摄受安住大乘诸有情故听闻受持不为名称。五者为利益无依无救诸有情故听闻受持。六者为令苦恼有情得安乐故听闻受持。七者为令无慧眼者得慧眼故听闻受持。八者为彼住声闻乘者说示声闻道故听闻受持。九者为彼住大乘者说示大乘法故听闻受持。十者为自取证无上智故听闻受持。不为求彼下劣乘故。善男子。菩萨若修如是十种法者。能持如来修多罗教。又善男子。菩萨若修十种法者。能持律教。何等为十。一者善知于律。二者善知律之仪范。三者善知律甚深义。四者善知律微细相。五者善知应作不应作。六者善知自性违犯。七者善知施设违犯。八者善知波罗提木叉所起因缘。九者善知声闻律法。十者善知菩萨律法。善男子。菩萨若修如是十种法者。善持律教。又善男子。菩萨若修十种法者。善解轨则所行境界威仪具足。何等为十。一者善学声闻学处。二者善学缘觉学处。三者善学菩萨学处。四者于彼一切学处修习具足。五者于所行轨则得具足已。而能远离非沙门行。六者以是因缘故。菩萨不于非处非方非时所行。七者于其沙门轨则所行得具足已。不为诸沙门或婆罗门非理讥毁。八者令他亦如是学。九者所行轨则得具足故。容相端严威仪寂静。十者具足威仪而无诈异。善男子。菩萨若修如是十种法者。善解轨则所行境界威仪具足。又善男子。菩萨若修十种法者。能离悭嫉。何等为十。一者自为施主。二者教他行施。三者赞叹布施。四者见他施时心生随喜。五者令余施主庆快利喜。六者见施他时不应生念此应施我勿施于他。我族应得他族非得。七者菩萨发如是心。令诸有情一切皆得济命资具悉获安乐。八者令诸有情悉能成就胜出世间最上安乐。九者菩萨作如是念。我常勤修利有情事。十者菩萨作如是念。我终不起悭嫉之心。善男子。菩萨若修如是十种法者。能离悭嫉。又善男子。菩萨若修十种法者。能于一切有情住平等心。何等为十。一者于一切有情起平等方便。二者于一切有情起无障碍心。三者于一切有情起无嗔恼心。四者为一切有情广行布施。五者守护戒行。六者修持忍辱。七者发勤精进。八者安住禅定。九者修习胜慧。十者积集彼一切智。菩萨如是依无二心之所积集。何以故。菩萨于一切有情平等积集故。以一切有情为所缘境而积集故。如是速能普令一切证得法性。菩萨自能出离大火宅已。复令他人亦悉出离。以其安住平等心故心无高下。善男子。譬如长者有其六子。而一一子称可父意。慈爱怜惜而悉同等。是等诸子幼无所识复不明了。其父同以方便训育。一时父舍欻然火起。而彼诸子各各异处。善男子。于汝意云何。时彼长者可作是念。此诸子等令同出邪。前后出邪。除盖障菩萨白佛言。不也世尊。何以故。而彼长者以平等心怜爱无异。是时诸子虽各异处。以等爱心俱时令出。佛言。善男子。菩萨亦复如是。一切有情悉是愚夫而非圣者。久处生死大火宅中。愚痴无识复不明了。各各散在诸趣之中。菩萨为救度故。随以方便俱时令出彼大火宅。出火宅已普令安住寂静界中。善男子。菩萨若修如是十种法者。能于一切有情住平等心。又善男子。菩萨若修十种法者。善能承事供养如来。何等为十。一者以法供养是为承事供养如来非财供养。二者如说修行。是为供养。三者为诸有情作利乐事。是为供养。四者摄受有情。是为供养。五者为诸有情随顺所行。是为供养。六者不舍誓愿。是为供养。七者不舍菩萨事业。是为供养。八者如说能行。是为供养。九者诸有所作不生懈倦。是为供养。十者不舍菩提心。是为承事供养如来非财供养。何以故。善男子。法身即是如来。是故以法供养即为供养如来。又积集如来所说。是即如说修行。发起诸利乐事。是即利乐有情。施作有情事业。是即摄受有情。善男子。若不能作利有情事。誓愿微劣弃舍菩萨事业之者。即不能顺有情行增长誓愿坚固菩萨事业。又若起虚妄语志意缺减。即不能如说能行。又若生其懈倦。即不能于诸所作不生懈倦又若于菩提心有所退失而无所证。即不能不舍菩提之心。何以故。善男子。菩萨于阿耨多罗三藐三菩提。本无所得亦无所证。是故汝今应如是知。以法供养。是为承事供养如来非财供养。善男子。菩萨若修如是十种法者。善能承事供养如来。又善男子。菩萨若修十种法者。能摧伏我慢。何等为十。一者菩萨舍家出家离诸亲友眷属知识犹如死故。摧伏我慢。二者毁己形好被服坏色随顺正法故摧我慢。三者剃除须发执持应器。巡家行乞故摧我慢。四者为乞食因缘卑下其心。与旃陀罗童子而无有异故摧我慢。五者常作是念。我从他乞我之身命系属于他故摧我慢。六者我所受食以清净故诸佛所许故摧我慢。七者为欲亲近阿阇梨师长圣众故摧我慢。八者我具威仪轨则所行如法。欲令同梵行者见皆欢喜故摧我慢。九者于诸未具佛法之者愿当得具故摧我慢。十者于彼忿恚恼害诸有情中。我当常行忍辱之行故摧我慢。善男子。菩萨若修如是十种法者。能摧我慢。又善男子。菩萨若修十种法者。能生净信。何等为十。一者福行成辨。二者具正因故得宿世善根圆满。三者不起邪信故而具正见。四者不依邪师故得意乐具足。五者离谄诳故得正行无曲。六者根性利故而得胜慧。七者相续清净故得离诸障。八者远离恶知识故常得亲近诸善知识。九者常求诸善说故而能除彼增上慢心。十者于佛所说法中具大信故而能离诸邪执。了知如来广大威德善男子。菩萨若修如是十种法者。能生净信。

佛说除盖障菩萨所问经卷第十五佛说除盖障菩萨所问经卷第十六

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时除盖障菩萨白佛言。世尊。所有如来广大威德。愿佛世尊为说少分佛言。善男子。汝当谛听。我今为汝。略说如来广大威德。除盖障菩萨白佛言。善哉世尊。愿乐欲闻。于是除盖障菩萨受教而听

佛言。善男子。如来成就大慈无量平等。普及一切有情。如来于一有情行其慈已。于余一切尽有情界。普遍行慈亦复如是。乃至等虚空界所行亦然。而实不能得知如来大慈边际

又善男子。如来成就大悲功德。不与一切声闻菩萨同等。如来于一有情行大悲已。于余普遍尽有情界所行亦然。为彼有情广作利益

又善男子。如来成就说法无尽。如所成就。若或一劫百劫千劫。乃至无量无数劫中。尔所有情若干种类。名言各异理趣不同。如来同时能为说法。然实不能得知如来说法边际

又善男子。如来成就无量问答。若诸有情乃至在于有情数者。同时各以种种差别名句文义。问佛世尊。如来于一刹那一腊缚一牟呼栗多中皆悉能答。然实不能得知如来应答辩才究尽之相

又善男子。如来成就禅定无碍境界。正使一切有情悉住十地。彼等有情。同时俱入无数百千三摩地门。如是入时经于无数亿百千劫。所入三摩地各各别异。然亦不能得知如来所有三摩地门及三摩地境界

又善男子。如来成就无量色身化门。若诸有情。应以如来色相而得度者。如来于一刹那一腊缚一牟呼栗多中。各各能于彼彼之前现如来身。若诸有情应以别异色相而得度者。如来于刹那中。悉现种种别异之身

又善男子。如来成就无量天眼境界。若有有情具天眼光明非肉眼者尽有情界。彼如是等诸有情类。超过算数思惟较计。是等世界。如来悉能一一观见。如观掌中庵摩勤果

又善男子。如来成就无量天耳境界若无边世界充满其中。如前所说一切有情。彼如是等诸有情类。同于一刹那中。俱时发声音韵诘曲各各差别。如来悉能同时闻彼一一音声各各解了

又善男子。如来成就无量胜智。假使无量无边尽有情界等虚空界诸有情类。各各思惟各各计度。随其种种思惟计度。各各造业差别不同。如来于一刹那一腊缚一牟呼栗多中。悉能了知此类有情如是思惟。此类有情如是计度。此类有情造如是业得如是果。如来以其三世无碍清净智力而悉能知。善男子。如来常住三摩呬多。不离三摩呬多。何以故。如来无失念故。诸根不散乱故。无异思惟故。已断一切烦恼故。如来寂静极寂静故。善男子。若有烦恼心即散乱。心散乱故。不能积集一切善法。是故如来已断烦恼。离诸尘染得诸漏尽。获一切法平等自在。成办三摩地三摩钵底境界胜行善男子。如来于一一威仪道。一一三摩地常所修行。乃至入涅槃时所行无失。况复一三摩呬多。善男子。如来如是于无数劫积集功德。是故如来所有功德。不可量不可称。不可思不可计

尔时除盖障菩萨。白佛言。世尊。岂非如来于三阿僧祇劫积集功德耶。佛言。不也善男子。如来境界不思议故。若住不可思议菩萨。方能积集。非三阿僧祇劫所能积集。何以故。若菩萨得入一切法平等者。方入劫数。非初发心者之所能入

除盖障菩萨复白佛言。世尊。如是所说如来广大威德。若人闻已。能生净信欢喜适悦。当知是人具大福德者。作诸善业者。断诸业障者。广多信解者。是人得近菩提。况复有能于是法中。闻已受持读诵通利。复能广为他人说者。必知是人不久应当得如是等如来广大威德出生。佛言。如是如是。善男子。如汝所说。彼人当得诸佛摄护深种善根。于多佛所尊重恭敬。是故若善男子善女人。闻说如来大威德已。勿生疑惑勿起犹豫。若彼善男子善女人。能于七昼夜中。专注系念心不散乱。思惟如来广大威德。随所思惟。深固作意深固信解。随其悟入过七昼夜已。应当严洁敷设种种供养之具。着新净衣起清净心现前谛想。即于是夜得见如来。若复不能依其法式或有所减。但能专注一心者。是人临命终时。亦得如来为现其前

除盖障菩萨复白佛言。世尊。或有人闻宣说如来大威德时。生不信不。佛言。善男子。亦有有情闻说如来大威德已。起粗恶意极损害心。于其说法师所起恶友想。以是缘故。身坏命终堕地狱中。善男子。若复有人闻说如来大威德时生净信心。于彼说法师所起善知识想。起师尊想。如是之人。决定于先世中。曾闻如来如是广大威德之法。世世已来至于今生。而此众会之中。亦复得闻如来功德。善男子。如佛所说若人得闻此正法者。是人先世已曾闻故

尔时世尊。即乃舒其清净舌相遍覆面轮。覆面轮已次覆顶轮。覆顶轮已旋覆身轮。覆身轮已周匝覆于师子之座。次第覆于菩萨众会及声闻众。乃至帝释梵王护世天等一切大会。如是次第周广遍覆。摄其舌相旋复如故。普告众会而作是言。诸善男子。汝观如来如是舌相。表佛如来言无虚妄。汝等应当各起增上清净信心。当令汝等于长夜中得大利乐

说是法时。会中八万四千菩萨。得无生法忍。无数百千有情。远尘离垢得法眼净。复有无数有情。先未曾发菩提心者。皆发阿耨多罗三藐三菩提心。

尔时世尊。复告除盖障菩萨言。善男子。菩萨若修十种法者。善知世俗。何等为十。一者虽复施设色蕴。于胜义谛中。色蕴不可得亦无取着。虽复施设受想行识等蕴。于胜义谛中识蕴不可得亦无取着。二者虽复施设地界。于胜义谛中地界不可得亦无取着。虽复施设水火风空识界。于胜义谛中识界不可得亦无取着。三者虽复施设眼处。于胜义谛中。眼处不可得亦无取着。虽复施设耳鼻舌身意处。于胜义谛中。意处不可得亦无取着。四者虽复施设于我。而胜义谛中。我不可得亦无取着。五者虽复施设有情。于胜义谛中。有情不可得亦无取着。六者虽复施设寿者养者士夫补特伽罗摩拏嚩迦。于胜义谛中。皆不可得亦无取着。七者虽复施设世间。于胜义谛中。世间不可得亦无取着。八者虽复施设世间法。于胜义谛中。世间法不可得亦无取着。九者虽复施设佛法。于胜义谛中。佛法不可得亦无取着。十者虽复施设菩提。于胜义谛中。菩提不可得亦无取着。复无得菩提者。善男子。名相施设此说是为世俗之法。而胜义谛亦不离世俗法有。若无世俗之法。即不能得从胜义谛。若菩萨于如是处了知世俗。是即名为善解世俗之法。善男子。菩萨若修如是十种法者。善知世俗

佛说除盖障菩萨所问经卷第十六佛说除盖障菩萨所问经卷第十七

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。善知胜义谛。何等为十。一者成就不生法故。二者成就不灭法故。三者成就不坏法故。四者成就不出不入法故。五者成就超言境界故。六者成就无言诠法故。七者成就无戏论法故。八者成就不可说法故。九者成就寂静法故。十者成就圣者法故。何以故。善男子。胜义谛理本无坏故。若佛出世若不出世本自如是。不生不灭。不出不入。非文字所说。非文字诠表。离诸戏论取证。善男子。此胜义谛。湛然寂静不可言说。唯诸圣者自内所证。又善男子。此胜义谛。若佛出世若不出世。本无所坏以是义故。有善男子。发正信心清净出家剃除须发被服袈裟。既出家已发勤精进修诸善行。如头覆缯帛救其火然。求法亦尔。善男子。若不得胜义谛法。即所修梵行虚无果利。如来出世亦无果利。是故善男子。若有胜义谛可说。名为菩萨了知胜义。善男子。菩萨若修如是十种法者。即善知胜义

又善男子。菩萨若修十种法者。善知缘生。何等为十。一者知诸法空。二者知法无所有。三者知法不真实。四者知法如像。五者知法如影。六者知法如响。七者知法如幻。八者知法不久停。九者知法动摇。十者知法皆从缘生。菩萨作是思惟。此法如是空。如是无所有。如是不真实。如是如像如影如响如幻。如是不久停。如是动摇。如是缘生。虽复了知诸有生法。决定不住速趣破坏。而亦建立生法灭法及彼住法。又复惟忖如是诸法。从何缘生从何缘灭。作是思惟已。乃知是法从无明生。因无明有。以其无明而为先导依止无明。依无明已诸行乃生。依诸行已而有诸识。由有识故乃立名色。立名色故乃有六处。六处有故诸触随生。以有触故乃起于受。由其受因愚夫生爱。爱逼迫故而起于取。以有取故缠缚于有。由有故生。生故有老。有老法故补特伽罗士夫皆死。依死法故而起忧悲苦恼愁叹。如是乃得一大苦蕴集。是故智者应当勤力断除无明。破坏无明。拔无明根灭无明法。由无明灭故。即能除灭无智之者所依止法。譬如命根灭已除根皆灭。无明灭已。无智所依诸法皆灭。亦复如是。何以故。无无智故乃无积集。一切烦恼不转诸趣。以无烦恼转诸趣故。即能断灭生死之因近于涅槃。善男子。菩萨若修如是十种法者。善知缘生

又善男子。菩萨若修十种法者。能自了知。何等为十。一者菩萨善自观察。今我此身何族中生。婆罗门族邪。刹帝利族邪。长者族邪。而或高尚富贵族邪。其或卑贱下种族邪。若在高尚富贵族生。我当不恃此缘而生憍倨。记使于其卑贱族生。当起是念。由我宿昔造杂业故生如是族即以此缘厌离于世。生厌离故而求出家。二者菩萨既出家已。即当观察。我今为何义故而求出家。乃自思忖。我今出家。自得度已令他亦度。自解脱已亦令他人悉得解脱。以是缘故终不生于懒堕懈怠。三者菩萨如是观察。我今出家。应断一切罪不善法灭尽无余。我若已断诸不善法。生大欢喜适悦庆快。我若未断诸不善法。应当策勤速令除断。四者菩萨如是观察。我今出家宜应广大增长修习一切善法。我若已能广大增长一切善法。心生欢喜适悦庆快。我若曾未增修善法。应当策勤速令增长。五者菩萨如是观察。我若依止于师尊已。即能增长一切善法。坏灭一切不善之法。由此因缘。于其亲教师所。不以鲜闻多闻有智无智持戒毁戒。应当悉起佛大师想。于彼师尊之所。爱乐信重恭敬承事。亦于轨范师所。同彼亲教之师尊重恭敬。六者菩萨如是观察。我若依止轨范师已。当于菩提分法。未圆满者而能圆满。诸有未断一切烦恼而悉能断。是故于彼轨范师所。恭敬承事如亲教师想心大欢喜。而彼师尊。能以正道一切善法摄受于我。不以邪道不善之法而为摄受。七者菩萨如是观察。谁是我师乃审思惟。一切智者是我大师。彼一切明了悲愍世间。起大悲心作大福田。能为天人阿修罗世间等师。以是缘故。生大欢喜适悦庆快。又复思惟。若佛世尊为我大师。我实得大善利。如佛世尊施设学道。我当尽其寿命奉教修学。如闻随转终不违越。八者菩萨作是思惟。我当从谁而行乞食。遍伺察已。我应于彼婆罗门刹帝利庶民之家周行求乞。令彼施食获大果报。成大义利具大威德。我以此缘。令彼得果故从乞食。九者菩萨作是思惟。彼婆罗门刹帝利等。为起何想而施我食。如是审察彼婆罗门刹帝利等。必应于我起沙门想起苾刍想起福田想故施我食。我今宜应积集修行沙门功德苾刍功德福田功德。十者菩萨作是思惟。我当云何而能出离无始生死。如是审察。一者我得成苾刍相。斯为第一出离生死。二者我得成就苾刍所有功德。斯为第二出离生死。三者我能发起精进舍离懈怠。修诸善行证得法性。斯为第三出离生死。四者遍修诸行。乃至成佛化度有情。斯为第四出离生死。菩萨若能如是审谛常所观察。是即名为善自了知。善男子。菩萨若修如是十种法者。善自了知

又善男子。菩萨若修十种法者。善知世间。何等为十。一者见高倨人能自卑下。二者见我慢人能离憍慢。三者见谄曲人能立正直。四者见妄语人为说实语。五者见恶语人为说爱语。六者见粗猛人起柔软相。七者见恚恶人能多忍辱。八者见毒害人为起慈心。九者见苦恼人为生悲愍。十者见悭吝人为行布施。善男子。菩萨若修如是十种法者。善知世间

又善男子。菩萨若修十种法者。得生清净诸佛刹土。何等为十。一者具戒净净不断不杂。复无染污戒行成就。二者行平等心。为一切有情设平等方便。三者成就广大善根非鲜少故。四者远离世间名闻利养等事复不染着。五者具于净信无疑惑心。六者发勤精进舍离懈怠。七者具修禅定无散乱心。八者修习多闻而无恶慧。九者利根利慧无暗钝性。十者广行慈行无损害心。善男子。菩萨若修如是十种法者。即生清净诸佛刹土

尔时除盖障菩萨白佛言。云何世尊。为具修十法乃得生邪。为随修一法无所缺坏亦得生邪。佛言。善男子。若随修一法不断不坏。无杂无染清净洁白。即能成就余诸法行。善男子。此中意者。若能具修诸法无所缺减。生净佛刹决定无疑

又善男子。菩萨若修十种法者。不染胎藏垢秽而生。何等为十。一者修治如来形像。二者严饰破故塔庙。三者妙香涂治如来宝塔。四者以妙香水洗沐佛像。五者泥饰涂补扫除溅洒如来塔地。六者恭事父母。七者恭事轨范之师及亲教师同梵行等。八者虽复如是无所悕望。九者即以如是所有善根而用回向。愿以此善普令一切有情不染胎藏垢秽而生。十者深心志固。善男子。菩萨若修如是十种法者。得不染胎藏垢秽而生

又善男子。菩萨若修十种法者。即能在家出家。何等为十。一者得无所取。二者不杂乱住。三者弃背诸境。四者远离诸境一切爱着。五者不染诸境所有过失。六者能于如来所设学门恭敬修习。加复勤力而无厌足。七者虽复少分得其饮食衣服卧具病缘医药心常喜足。八者随得应器衣服离诸取着。九者厌离诸境常生怖畏。十者常勤修习现前寂静。善男子。菩萨若修如是十种法者。即能在家出家

佛说除盖障菩萨所问经卷第十七佛说除盖障菩萨所问经卷第十八

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。即得净命。何等为十。一者远离谄求利养。二者远离为利养故矫现其相。三者远离为利养故虚言激诱。四者远离恶求利养。五者远离非法利养。六者远离不净利养。七者不耽着利养。八者不染爱利养。九者不为利养故心生热恼。十者得如法利养而生喜足。善男子。云何是菩萨善能远离谄求利养。谓若菩萨不以利养因缘故而身语心行于谄曲。身不行谄者。菩萨若见施主及助施者。而不故意策发威仪。徐缓安详举足进步端审前视。或复起于厌恶而视。或作寂住无发悟视。此即名为身不行谄。语不行谄者。菩萨不以利养因缘故发徐缓语。及柔软语。爱乐之语。或随顺语。此即名为语不行谄。心不行谄者。菩萨若见施主及助施者。以其利养召命之时。而不语现少欲心起贪爱内怀热恼。此即名为心不行谄。如是等名为菩萨善能远离谄求利养。云何是善能远离为利养故矫现其相。谓若菩萨虽为衣服应器病缘医药。及余资具之所逼迫。以虚矫故。终不发言求彼施主及助施者。是为菩萨善能远离为利养故矫现其相。云何是善能远离为利养故虚言激诱。谓若菩萨或见施主及助施者不发是言。某甲施主持如是物惠施于我。而彼以我持戒多闻少欲知足。是故以种种物而特见施我。亦为其起悲愍心作饶益事。摄受于彼而乃受之。是为菩萨善能远离为利养故虚言激诱。云何是善能远离恶求利养。谓若菩萨不为求利养故身心行恶。身行恶者。所谓往来驰走奔竞。历诸艰苦破毁净戒。心行恶者。为利养故见余同梵行者得利养已。而于彼所生损害心。是为菩萨善能远离恶求利养。云何是善能远离非法利养。谓若菩萨不以斗秤而行欺诳。他所委信亦不侵取。复无奸恶积蓄财利。是为菩萨善能远离非法利养。云何是善能远离不净利养。谓若菩萨于利养中。若窣睹波物若法若僧所有诸物不与不许。菩萨知已悉不受之。是为菩萨善能远离不净利养。云何是不耽着利养。谓若菩萨虽得利养。不为自己之所摄属。亦不自谓我所富足。复无积聚。时能普施诸余沙门婆罗门等。及父母亲属朋友知识。或复以时己所受用。是为菩萨不耽着利养。云何是不染爱利养。谓若菩萨虽所受用不生种种染爱之心。是为菩萨不染爱利养。云何是不为利养故心生热恼。谓若菩萨或于不得利养之时心不生苦亦无热恼。而复于彼施主及助施者。不起嫌恶弃舍之心。是为菩萨不为利养故心生热恼。云何是得如法利养而生喜足。谓若菩萨或随僧次得其如法利养之时。如来许可。诸菩萨众复不呵责。圣贤称赞。同梵行者亦不讥毁。如是受已生喜足心。是为菩萨得如法利养而生喜足。善男子。菩萨若修如是十种法者。即得净命。又善男子。菩萨若修十种法者。心无懈倦。何等为十。一者为利诸有情故。久处生死而无懈倦。二者为利诸有情故受生死苦而无懈倦。三者为诸有情作利益故而无懈倦。四者施作有情诸善事业而无懈倦。五者为于有情诸所作事而无懈倦。六者为求声闻乘人。说彼道法而无懈倦。七者不于声闻人前言不信彼法。八者成办菩提分法而无懈倦。九者圆满菩提资粮而无懈倦。十者不取证涅槃不起趣向涅槃意乐。菩萨以是缘故。即能趣向菩提。渐近菩提取证菩提。善男子。菩萨若修如是十种法者。心无懈倦。又善男子。菩萨若修十种法者。能行一切如来教敕。何等为十。一者勤修不放逸行。离诸放逸故。二者具善律仪。身不行恶故。三者具善律仪。语不行恶故。四者具善律仪。意不行恶故。五者恐畏他世。尽断诸恶故。六者说如理语。离非理语故。七者宣正法语。离非法语故。八者离不善业。修善业故。九者常于如来教中不说过恶。离诸烦恼秽恶毒故。十者随顺守护如来正法。防御一切不善法故。善男子。菩萨若修如是十种法者。能行一切如来教敕。又善男子。菩萨若修十种法者。得面相熙怡离诸颦躄。何等为十。一者诸根胜妙。二者诸根清净。三者诸根无缺。四者诸根无垢。五者诸根洁白。六者远离嗔恚。七者远离随眠。八者远离缠缚。九者远离结恨十者远离忿怒。善男子。菩萨若修如是十种法者。得面相熙怡离诸颦躄

尔时除盖障菩萨白佛言。世尊如我解佛所说之义。由诸根清净故。菩萨即得面相熙怡。由断诸烦恼故。得离颦躄。佛言。如是如是。善男子。由诸根清净故。菩萨即得面相熙怡。由断诸烦恼故得离颦躄。又善男子。菩萨若修十种法者即得多闻。何等为十。一者如实了知于生死中贪火炽然。二者如实了知嗔火增盛。三者如实了知痴火昏乱。四者如实了知有为之法皆悉无常。五者如实了知诸行是苦。六者如实了知世间悉空。七者如实了知诸法无我。八者能离世间戏论。九者如实了知彼一切法皆从缘生。十者如实了知涅槃寂静。此等诸法要以闻思修所成慧方能证悟。不可但以音声言说而能解入。菩萨如是知已。即起坚固悲愍之心发勤精进。为诸有情作利益事。善男子。菩萨若修如是十种法者。即得多闻。又善男子。菩萨若修十种法者。即能摄受正法。何等为十。一者于后时后分后五百岁正法减没时分转易。诸有情等于佛教中安立邪道智灯隐灭。当如是时有能宣演如来所说广大经典。作大利益具大威德。如诸法母能受持读诵恭敬承事者。即能摄受正法。二者为他宣说。令彼听受开晓其义。三者于彼修行正法人所。爱乐信重欢喜适悦。为彼摄受。四者为他宣说正法无所希望。五者于说法师所起师尊想。六者于其正法如甘露想。七者如圣药想。八者如良药想。九者为求正法不惜身命。十者求得法已修行圆满。善男子。菩萨若修如是十种法者。即能摄受正法。又善男子。菩萨若修十种法者。为法王子。何等为十。一者具足诸相庄严。二者身得诸随形好。三者众相具足诸根圆满。四者于佛如来所亲近处随顺亲近。五者于佛如来所行正道随顺而行。六者于佛如来所觉悟法随觉悟之。七者救度世间一切苦恼。八者善能修学一切圣行。九者善能修习成诸梵行。十者善住如来所住一切智城。善男子。菩萨若修如是十种法者。为法王子。又善男子。菩萨若修十种法者。即能超胜帝释梵王护世天等。何等为十。一者于佛菩提得不退转。二者不为诸魔所动。三者不离一切佛法。四者随能解入诸法正理。五者通达诸法平等。六者不起他信。七者于佛法中得善觉智。八者不共一切声闻缘觉同等。九者出过一切世间。十者证得无生法忍。善男子。菩萨若修如是十种法者。即能超胜。帝释梵王护世天等。又善男子。菩萨若修十种法者。能知有情意乐随眠何等为十。一者如实了知一切有情贪欲意乐。二者了知嗔恚意乐。三者了知愚痴意乐。四者了知上品意乐。五者了知中品意乐。六者了知下品意乐。七者了知诸善意乐。八者了知坚固意乐。九者了知常起随眠。十者了知暴恶随眠。如是等法。于一有情如实知已。乃至尽于诸有情界所知亦然。善男子。菩萨若修如是十种法者。能知有情意乐随眠。又善男子。菩萨若修十种法者。善知成熟有情之法。何等为十。一者应以诸佛色相而调伏者。即现佛相。二者应以菩萨色相而调伏者。即现菩萨之相。三者应以缘觉色相而调伏者。即现缘觉之相。四者应以声闻色相而调伏者。即现声闻之相。五者应以帝释色相而调伏者。即现帝释之相。六者应以魔王色相而调伏者。即现魔王之相。七者应以梵王色相而调伏者。即现梵王之相。八者应以婆罗门色相而调伏者。即现婆罗门之相。九者应以刹帝利色相而调伏者。即现刹帝利之相。十者应以长者色相而调伏者。即现长者之相。善男子。诸有情等应以如是种种色相而调伏者。菩萨即能随所应现别异之相。善男子。菩萨若修如是十种法者。善知成熟有情之法。又善男子。菩萨若修十种法者。得胜乐住。何等为十。一者正直。二者柔软。三者无谄曲心。四者无嗔恚心。五者无染污心。六者具清净心。七者无粗犷语。八者断秽恶语。九者常行忍辱。十者具善爱乐善男子。菩萨若修如是十种法者。得胜乐住。又善男子。菩萨若修十种法者。得安乐住。何等为十。一者正见具足。二者具见清净戒行圆满。三者仪范清净。四者随顺所行境界。五者不杂诸烦恼住。六者得无过失。七者具修梵行。八者得其同类。九者住一乘道。十者不事余师。善男子。菩萨若修如是十种法者。得安乐住

佛说除盖障菩萨所问经卷第十八佛说除盖障菩萨所问经卷第十九

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次善男子。菩萨若修十种法者。即能善知四摄法行。何等为十。一者行利益施摄化有情。二者行安乐施三者行无尽施。四者利益语。五者如义语六者如法语。七者如理语。八者利益行。九者同财而行利益。十者同其济命受用等事。而行利益摄化有情。善男子。利益施者。是谓法施安乐施者。是谓财施。无尽施者。谓与他人宣示正道利益语者。所谓宣说诸善品法。如义语者。所谓宣说真实之理。如法语者。所谓随顺如来正教宣说诸法。如理语者。所谓不坏真实之义。利益行者。谓令有情不善不起善法安立。同财利益者。谓同饮食财物平等受用同其济命受用等事行利益者。所谓金银摩尼真珠琉璃。螺贝壁玉象马车乘等。同其受用而行利益。善男子。菩萨若修如是十种法者。即能善知四摄法行。又善男子。菩萨若修十种法者。得妙相具足。何等为十。一者常修寂静威仪。二者常修无矫诈威仪。三者常修清净威仪。四者见者皆生爱乐。五者见者皆生善相。六者见者无厌。七者见者悦意。八者一切有情见者无碍。九者一切有情见者皆生欢喜之心。十者一切有情见者皆生清净之心。善男子。菩萨若修如是十种法者。即得妙相具足。又善男子。菩萨若修十种法者。为他所依。何等为十。一者有情久处生死怖畏中者。为作守护。二者有情久在生死旷野险难者。为作善导。三者有情没溺生死大海中者。而为济渡。四者有情无亲属者。为作主宰。五者有情久婴烦恼重病苦者。为作医师。六者有情无救护者。为作救护。七者有情无栖托者。为作舍宅。八者有情无归投者。为作归投。九者有情无安止者。为作洲渚。十者有情无趣向者。为作趣向。善男子。菩萨若修如是十种法者。即能为他所依。又善男子。菩萨若修十种法者。如大药树。善男子。譬如世间有大药树。其名善见若彼有情婴缠一切病苦之者。随取受用悉愈其疾。何等为十。一者受用其根。二者受用其茎。三者受用其枝。四者受用其叶。五者受用其花。六者受用其果。七者见时受用其色。八者嗅时受用其香。九者当时受用其味。十者举动受用其触。善男子。菩萨亦复如是从初发心已来。善能治疗一切有情诸烦恼病。而诸有情随所修作悉愈其疾。一者受用菩萨布施波罗蜜多。二者受用菩萨持戒波罗蜜多。三者受用菩萨忍辱波罗蜜多。四者受用菩萨精进波罗蜜多。五者受用菩萨禅定波罗蜜多。六者受用菩萨般若波罗蜜多。七者见菩萨身受用其色。八者闻菩萨名受用其声。九者尝于菩萨清净功德法味。十者亲近菩萨恭敬供养。善男子。菩萨若修如是十种法者。即得如大药树。又善男子。菩萨若修十种法者。而能勤修福行。何等为十。一者随力供养三宝。二者病苦有情为施妙药。三者饥渴有情为施饮食。四者诸有情类若为寒热所逼恼者。施其覆护。五者常当尊重恭敬轨范之师及亲教师。六者见诸同梵行人。应起承迎合掌恭敬礼拜问讯。七者修治园林精舍。八者于时时中出诸库藏财谷等物而行给施。九者于诸奴婢及佣作人。平等养育而为护持。十者于时时中常行供养持戒沙门及婆罗门。善男子。菩萨若修如是十种法者。即能勤修福行。又善男子。菩萨若修十种法者。善能施作诸变化事。何等为十。一者于一佛刹不动身相。能于无数佛刹诸如来所请问深义。二者于一佛刹不动身相。能于无数佛刹诸如来所听受深法。三者于一佛刹不动身相。能于无数佛刹诸如来所承事供养。四者于一佛刹不动身相。能于无数佛刹之中。而悉圆满菩提资粮。五者于一佛刹不动身相。能于无数佛刹之中。有诸菩萨成正觉时。悉皆尊重作供养事。六者于一佛刹不动身相。能于无数佛刹之中。自身示现成等正觉。七者于一佛刹不动身相。能于无数佛刹之中。示现往诣菩提道场。八者于一佛刹不动身相。能于无数佛刹之中转妙法轮。九者于一佛刹不动身相。能于无数佛刹之中示现涅槃。十者于一佛刹不动身相。能于无数佛刹之中。乃至有情所可化者。随其所应而悉为作诸变化事。菩萨虽复作诸化事。而不分别能化所化

尔时除盖障菩萨白佛言。世尊。云何菩萨作诸化事而不分别能化所化。佛言。善男子。我今喻说。汝应谛听。譬如日月照四大洲。随摄世间一切有情普遍照曜。而彼日月亦不分别。我为能照一切有情是为所照。何以故彼之日月。皆由往昔所修业报故能照曜。善男子。菩萨亦复如是。虽复作诸化事。亦不分别能化所化。都无发悟亦无造作。何以故。谓由菩萨往昔胜善业报所成。菩萨往昔修菩萨行时。随其愿力随其行业。故能今时作诸化事无所分别。善男子。菩萨若修如是十种法者。善能施作诸变化事。又善男子。菩萨若修十种法者。即能速证阿耨多罗三藐三菩提果。何等为十。一者能善具足。及善积集布施之行。二者善具足戒。善积集戒。无缺漏戒。不杂染戒。出过一切声闻缘觉。清净洁白戒蕴具足。三者善具忍辱。四者善具精进。五者善具禅定。六者善具胜慧。七者善具方便。八者善具诸愿。九者善具诸力。十者善具正智善积集智。以菩萨成就不共智故。而能出过一切声闻缘觉之智。超越菩萨初地。乃至超越菩萨九地之智。善男子。菩萨若修如是十种法者。即能速证阿耨多罗三藐三菩提果

世尊宣说如是诸正法时。即此三千大千世界六种震动

又此三千大千世界所有须弥山王。目真邻陀山摩诃目真邻陀山。小铁围山。大铁围山。及余宝山黑山诸小山等峰岫。自然皆悉低屈向象头山。而伸供养佛及正法

又此三千大千世界。一切花树一切果树。皆悉低垂向象头山。供养世尊及其正法

是时复有无数百千俱胝那庾多菩萨。化现种种衣服庄严。其积量如须弥山王。供养世尊及其正法

复有无数百千帝释梵王护世天等。皆悉合掌顶礼世尊。雨天曼陀罗花。摩诃曼陀罗花。散于佛上

复有无数百千诸天子众各持天衣。住虚空中举身旋转。作百千种清妙之声而伸供养。复以天花散于佛上咸作是言。我等今日见佛世尊。于第二时出现世间。于第二时转正法轮。世尊。若诸有情。具大福德修诸善业。于先佛所植众德本者。是人方得闻此正法。何况有能闻已发生清净心者

复有无数百千摩睺罗伽。咸悉震发大云雷音。又复化现种种大云。遍覆于此三千大千世界。及象头山。雨众香水皆悉充满是中有情亦不娆恼。如是施作而伸供养

复有无数百千龙女。于世尊前出歌咏声而伸供养

复有无数百千乾闼婆众紧那罗众右绕。于此三千大千世界及象头山。出美妙声歌咏供养

佛说除盖障菩萨所问经卷第十九佛说除盖障菩萨所问经卷第二十

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

尔时复有无数百千夜叉之众。雨诸莲华而伸供养。又复吹击和风触者安乐

复有无数诸佛刹中。彼彼如来。为供养世尊释迦牟尼佛及正法故。各从眉间放大光明。其光具有青黄赤白红颇胝迦及翡翠等种种之色及种种相。种种光明右绕于此三千大千世界普遍照耀。而悉除破一切暗冥。光复旋还绕象头山。后从世尊顶门而入

复有无数百千婆罗门刹帝利士庶人民。各持香花涂香末香。众妙花鬘衣服幢幡及诸宝盖。置于佛前以伸供养

当佛宣说如是正法及诸天龙神献供养时。有七十二那庾多菩萨。得无生法忍。无数百千俱胝那庾多有情。远尘离垢得法眼净。无数百千俱胝那庾多有情。先未曾发菩提心者。皆发无上大菩提心。

尔时有一天女名曰长寿。久住于此象头山中。与自眷属先在佛会。即从座起。为供养佛故往自宫中。取诸供养还来诣佛。到佛所已尊重恭敬。专谛一心献诸供养。如是至诚作供养已。前白佛言。世尊。我知过去久久生中。有七万二千诸佛如来悉曾于此象头山中。说此正法亦如是义亦如是理亦如是文。佛言。长寿天女。汝快得善利。值遇如是法宝出世。一一亲闻

尔时会中有诸天子咸作是念。今此天女。久已曾闻如是正法。复曾亲近多佛如来。何故不能转此女身。时除盖障菩萨知诸天子心所念已。白佛言。世尊。何因何缘。此长寿天女具大威德。久已曾闻如是正法。复曾亲近多佛如来。何故不转此女人身。佛言。善男子。不转女身者。广为利乐一切有情大因缘故。所以者何。善男子。今此天女。已住不可思议解脱菩萨之位。我知此长寿天女。曾于超过算数诸如来所。劝请发菩提心。乃至入大涅槃。以是缘故。而此天女。获是广大神通威德善男子。此长寿天女。即于贤劫中供养诸佛已。此佛刹中当得成佛。号曰长寿如来应供正等正觉

尔时世尊复告长寿天女言。汝今应现自佛国土庄严之事。时长寿天女。即入现一切色相三摩地于是三摩地中。现此三千大千世界地平如掌。除去黑山土石山等。及余一切本有树木。清净可爱琉璃所成。处处皆有妙劫波树。处处皆有清净严好泉源池沼。八功德水充满其中。除去一切凡常人类。亦复不闻女人之声。处处皆现广大莲花。其一一花量如车轮。诸莲花中有菩萨像加趺而坐。复现世尊长寿如来应供正等正觉。与诸菩萨共会说法。有无数百千俱胝那庾多帝释梵王护世天等之所围绕。又有无数百千俱胝那庾多菩萨之众围绕听法。所谓亦说如是法门

尔时长寿天女如是现已。即从三摩地起。于世尊前。右绕三匝隐而不现

尔时除盖障菩萨前白佛言。世尊。若有善男子善女人。于此正法。听闻受持读诵记念解释其义。复为他人广大说者。是人得几所福。佛言。善男子。正使三千大千世界。满中有情悉行布施。经无量时相续不断。若有善男子善女人。于此正法发清净心。如法书写复善详校。又以净心转施于他。是人所获福德倍胜于前何以故善男子。夫财施者不出生死。而法施者最上最胜。所以者何。一切有情在生死中。贪受种种财利事故。不能受彼最上法味出于世间。又善男子。正使有人。以此三千大千世界满中有情。悉令安住十善业道。若复有人。于此正法。听闻受持读诵记念解释其义。复为他人广大说者。是人所获福德倍胜于前。何以故。善男子。十善业道从是正法所出生故。又善男子。正使三千大千世界满中有情。悉令证得须陀洹果斯陀含果阿那含果阿罗汉果。若复有人于此正法。听闻受持读诵记念解释其义。复为他人广大说者。是人所获福德倍胜于前。何以故。善男子。当知一切声闻缘觉。皆悉从是法性中来。诸菩萨者。亦悉从是法性中来。如来亦得是法性故出现世间。又善男子。若人能于如是正法。受持读诵解其义者。是人即同于诸经中受持读诵解释义趣。何以故。此法性者是诸法母。善男子。而诸菩萨。若不得此正法性者。即不能得广大法性

尔时会中诸大声闻。各从座起偏袒右肩。右膝着地俱白佛言。世尊。我等获得此法性已。而能普尽广大生死邪。佛言。诸苾刍如是如是

尔时世尊。普告在会诸大众言。善男子。若诸地方有能宣说如是正法之处。而彼地方当知即是大菩提场。即是转法轮处。即是大灵塔处。当起是念。是我大师所游止处。何以故。善男子。法性即是菩提。即是转法轮。法轮即是如来。善男子。若供养法者。是即供养诸佛如来。若诸地方有说法师所游止处。当于彼地起灵塔想。于说法师起大师想。又复当起善知识想。又应当起善导师想。由如是故。若时见彼说法师已。当起净信欢喜之心。尊重恭敬承迎于前。称扬赞叹白言善哉。复次善男子。我若赞说尊重恭敬法师功德。及说报其法师大恩。如是等事。若经一劫若过一劫。我亦不能说其少分。善男子。若有爱乐法者。诸善男子及善女人。于说法师所履道中。以自身血散洒其地。亦不能报彼说法师少分恩德。何以故。说法师者。以能任持如来法眼极难行故。善男子。是故诸说法师。当说如是正法之时。应现无畏。不应沉下生障碍心。着新净衣起清净心。当说法时。若人赞叹不起高心。不现我相不生慢执。不自称誉不凌毁他。亦复不生染着之心。应当恭敬尊重说法

尔时帝释天主前白佛言。世尊。若诸地方有说如是正法之处。我当率诸宫属往诣彼所。听受如是甚深正法。及为护助彼说法师。佛言。善哉善哉。憍尸迦。汝善守护如来正法。如汝所作今正是时

尔时除盖障菩萨白佛言。世尊。此经何名。我等云何奉持。佛言。善男子是经名曰除盖障菩萨所问。亦名宝云。亦名宝积功德。亦名智灯。如是名字汝当受持

佛说此经已。除盖障菩萨等。彼诸菩萨摩诃萨众。并在会菩萨声闻之众。帝释梵王护世诸天大自在天子等。无数百千诸天子众。及余无数百千。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等一切大众。闻佛所说欢喜信受

佛说除盖障菩萨所问经卷第二十


佛说除恐灾患经

    No. 744

佛说除恐灾患经

        乞伏秦沙门释圣坚译

闻如是。一时佛游王舍城竹林精舍。与四部弟子大众俱会。说上妙法。尔时维耶离国。厉气疫疾。威猛赫赫。犹如炽火死亡无数。无所归趣。无方疗救。国王大臣。长者居士。婆罗门。集会博议。国遭灾患。非邪所摧。疫火所烧。死亡无数。当以何义。设何方便。以除灾害。婆罗门议言。当于诸城门。设祠祀坛。或有议言。当于城中四衢路头。立大祠祀。禳却害气。或有议言。当用白马白驼白牛白羊白鸡白狗种种百头。而以祠祀镇厌解除。以禳却之。时众会中。有一长者。名曰弹尼(晋言才明)。奉佛五戒。修行十善。为清信士。谛证道迹。时发议曰。唯听所言。国遭灾患。死亡无数。如仁等议。害生救命。岂得然乎。以先世时所行不善。今遭斯厄。当设方便。以善禳恶。永无苦别。如何反倒。行害求安。长夜受苦。无有出期。时诸大会。问才明曰。当设何议。才明对曰。世有大怙。三千世界。天人之师。一切覆护。慈愍众生。号名为佛。独步三界。若能降致。光临国者。灾害可除。大众闻之。皆然其议。莫不称善。才明又曰。佛无数劫。修治六度。布施无限。国城财宝。象马车乘。头目髓脑。肌体妻子。戒忍精进。一心智慧。每生自克。不可计量。以求佛道。不为己身。但为众生。救济危厄。消除众患。生老病死。地狱鬼神畜生之苦。今成佛道。顺其本誓。周行济救。授甘露药。消除众生。今世后世。苦毒之患。永令获安。众会咸曰。如仁所言。甚诚大快。佛在王舍。阿阇世王。与吾国嫌。岂当听佛来至此耶。或复有言。傥听佛来。时才明曰。佛兴出世。救众生苦。犹如虚空。无所挂碍。谁能制止。犹如日光。万物萌生。莫不蒙育。佛怜国厄。必来无疑。但遣重使。贡遗琦珍。温辞雅谢。诣阿阇世。又别归佛。委命酸切。心虽怀嫌。信使贤重。贡遗妙宝。辞理柔软。事无不泰。自古已来。邻国不协。还相侵叛。皆由明使。名宝重贡。软辞逊顺。而得和协。展转相谓。思谁任使。尔时大众。国王大臣。长者居士。皆同意言。唯清信士。长者才明。是佛弟子。可以为使。往行请佛。所以者何。先众开建请佛之议。便告才明。唯仁可往。诣王舍国。与王相问。求请佛来。尔时才明。受使欲往。于时大众。皆起退坐。向佛方面。叉手长跪。五体投地。以顶礼佛。跪告才明。佛天中天。慈悲喜护。加于群生。唯怜鄙国遭遇大患。疾病死亡。犹猛野火焚烧草木。普遭困厄。幸佛世尊。犹冥求晓。寒愿朝阳。渴暑阴饮。病追良医。迷者求导。唯愿世尊。垂降救济。授甘露法。令得稣息。于是才明。受命为使。诣罗阅只。涉路径达。到王舍城。诣门求通书命贡遗。时王听见才明启言。奉使诣国。前虽不和。无他重隙。故先致虔。除前不协。俱绥万民。佛兴于世大慈普覆。国有重患。因命请佛。唯愿大王。劝佛回光。顾临鄙国。救济灾患。冀蒙神祐。王默思惟。适欲留佛。令不出国。无理得尔。非力所制。佛以大慈。普许十方。等视憎爱。救济为务。以是之故。不可留之。便告才明。可诣佛所。宣贵国命。于是才明。辞诣竹林。行到精舍。见佛世尊。尽虔礼敬。五体投地。右绕三匝。长跪叉手。而白佛言。维耶离国。诸王大臣。长者居士。遥礼佛足。唯天中天。普慈众生。莫不蒙济。鄙国遭厄。唯愿世尊。垂恩降光。怜愍苦厄。令得稣息。时佛默然。许其所请。才明见佛受请许往。欢喜无量。时王舍国。境内神祇。天龙鬼神。知佛受请。当诣他国。莫不躁动。惨然不悦。便现感应。语其国王阿阇世曰。大王如何。安然无忧。于今不久。当违离佛。犹如婴儿失其二亲。喻行旷路断失水浆。譬如猛寒亡失衣裳。今佛当行。国失恃怙。其喻如是。王闻神祇降应说是。情即怆然。甚怀愁苦。默然思惟。众生顽愚。志性钝浊。今离世尊。安从复得智慧之砺磨莹钝心。谁当济其尘劳重愆。宿世重责。谁当诲除。一切众生。重罪令轻。吾等久在生死牢狱。重关所闭。谁当复以正法之钥开生死狱重关牢闭。吾等普为劳垢。盛阳暑热所炙。安从复得佛清凉教月精明珠。消除炎热。王即敕严驾。出诣佛所。稽首佛足。右绕三匝。却坐常位。时佛为王。说正法化。初中竟善。净身口意。清净微妙。王心欢喜。叉手白佛。顷维耶离。使请世尊。承已许往。心甚怀惨。无方留尊。唯垂矜愍。特受鄙请。住宫三月。佛告王言。众生可伤。若住三月。何时当周众苦厄者。吾无数劫。苦身求道。为众生故。愿欲成佛。以甘露药。施于众生。今愿已成。犹如有人合和神药。欲救众患值遇病者。违其本誓。而不授与。则非良医。若在江侧。见漂流人。不往救度。非贤士宜。若于旷野。见失路者。不示正道。是则非仁。吾以大慈。普愍众生。故游诸国。县邑村落。救济众苦。赋甘露药。无恃者恃。无归者归。王重白佛。唯垂慈恩。许受二月。佛故不许。王重殷勤。长跪叉手。垂泣白言。命难可保。犹露然灯。遇无常风。奄忽便灭。今与佛别。何时当复更睹尊颜。幸受二月。佛重不许。王便投身于佛足下。唯愿世尊。特加大慈。与弟子众。许住一月。世尊不忍。即便许受。王便还起。心悦怀敬。绕佛三匝。礼辞还宫。敕厨馔具百味之饭。极令精好。鲜甘香洁。宫里张施。缯彩幡盖。杂宝床机。綩綖坐具。扫除缮治。香汁洒地。众事办毕。明日时至。王于正路。遥向世尊。烧香长跪。佛天中天。圣达知时。愿与圣众回降神光。到宫蔬食。于时世尊。敕诸弟子。法服执器。行诣王请。佛与圣众。俱到王宫。王即尽虔。花香伎乐。宫门迎佛。入各就坐。王自行水。周遍圣众。手自斟酌。百味饭食。鲜洁香甘。一切平等。日日供养饭食卧具疾药所须。令敕外宫。治填道路。种植街树。七行街路。乃至江水。顿息帐幔。及床座具。严饰幡盖。犹如天街。更新造作五百七宝盖。维耶离国。闻佛当至。亦复平治七行阶路。种植行树。帐幔床座。国王大臣。长者居士。各从大众。出国迎佛。一月期满。佛与圣众。出宫临路。王从大众。以花散佛。周遍覆地。大众来集。犹秋水长投于大海。白明月珠。校七宝盖。王以恭敬。手执奉上。以覆世尊。佛与大众。寻路而行。至江水侧。时王上佛五百七宝盖。大海龙王。亦复敬奉五百七宝盖。恒水诸龙。亦俱上佛五百七宝盖。时天帝释。将诸天众。亦复献佛五百七宝盖。时维耶离大众迎者。服饰严丽。青马青车青盖青幡。服饰皆青。赤马赤车。服饰皆赤。黄马黄车。服饰皆黄。白马白车。服饰皆白。黑马黑车。服饰皆黑。色色部别。将从无数。佛遥见之。告诸弟子。欲知天帝出游观时威仪如是。维耶离国。奉迎上佛五百七宝盖。各以其盖前至佛所。各白佛言。佛天中天。普世覆盖。愿受盖施。佛受其施。余留一盖。时诸大众。心各怀疑不审。为是宿世积德行善之报。海龙恒龙。忉利天帝。维耶离国。罗阅只王。各各奉上七宝妙盖。同时俱会。又疑何故。不受一盖。于是阿难。知众怀疑。长跪叉手。前白佛言。惟天中天。大众普疑。今日何缘。有是二千五百七宝宝盖。同时俱至。奉上世尊。为是前世善本报乎。今现福耶。唯愿世尊。决一切疑。佛告阿难。一心专听。今当决除汝等所疑。乃往过去无央数劫时。有转轮圣王。名曰摩调(晋言大天)。典主四域。王有千子。七宝导从。王末少子。见其父王七宝御盖。还问母曰。我当何时得服此盖以自光饰。母言惟子。王千子中。汝最末小。若无大王。太子承嗣。若太子崩。以次承继。展转千子。汝骨朽腐。未央得盖。重问母曰。无盖望耶。因闻有死。形骸当朽。宿福追逮。悚然心恐。惟人生世。必当有死。因报母曰。唯愿见听。舍家学道。母甚愍伤。不违其愿。母告之曰。听汝舍家。若卿道成。要还见吾。尔乃相听。对曰如敕。道成当还。即诣林薮。除剃须发。被着法服。静处勤修。精进不懈。竭尽尘劳。成缘觉道。游行诸国。县邑村落。福度众生。所种善本。忽忆母要。便上升空。犹如雁王。还本国宫。与母相见。阖宫大小。见道士神通。莫不欢喜。王诸婇女八万四千。共请令住。道士慈仁。不逆一切。便受其请。诸婇女辈。于宫后园。为设庐窟。止宿其中。举宫供养衣食床卧疾药所须。朝暮礼事。一切世间。壮者皆老。强健必病。生者皆死。时辟支佛。于其宫园。便舍寿命。举宫婇女。薪油花香。供养以礼。敛骨起塔。朝暮礼拜。烧香然灯。时王大天。巡四域还。临幸后园。见有此塔。顾问侍臣。何故有是。婇女对曰。此是圣王最下少子。离家学道。于此寿终。为立是塔。因重发问。是谁之子。何缘舍家。便召其母。而问之曰。是卿子耶。对曰唯尔。又复问曰。何缘学道。其母白王。是儿往昔见王出游。即还见问。王七宝盖。不审何时在我上旋。妾便告言。太子应继。承嗣圣王。展转千子。汝骨朽败。永无盖望。子闻妾言。惨然畏死。求行学道。妾辄听之。勤学道成。妾等请住供养尽寿。建立此塔。王复问曰。子以盖故。行学道耶。对曰如是。王愍其子不得盖故。学道尽寿。生不得盖。今便以盖。覆其塔上。王因发愿。今以此盖。奉得道塔。缘是福报。愿成佛道。济度众生生老病死。王心悚然。知世非常。无免死者。因立太子。承嗣圣位。王舍四域。七宝千子。八万四千。后宫婇女。除剃须发。行作沙门。静处学道。修四净行。慈悲喜护。毕其形寿。上生梵天。佛告大众。于卿等意。所志云何。王大天者。岂异人乎。莫造斯观。则吾是也。时以一盖。上缘觉塔。缘是福报。于此地上。为转轮王。不可称数。上为天王。天上世间。受福无限。一盖余福。吾应于世二千五百返为转轮王。主四天下。阿难又问。世尊何故。不受一盖。佛言。是吾一世转轮王福。所以舍置而不受者。以此福报。施后末世受吾法化为弟子者。学士学女。欲令此等不乏衣食床卧疾药。过去诸佛。法没尽时。其有学道。或因恐怖。或因饥穷。不得行道。正法没尽。其有末世。于吾法化。舍家学道。被服法衣。称佛为师。畜妻养子。此等皆尚得人供养。何况精勤修奉禁戒。守净行者。至吾法尽。不得供养耶。罗阅只王。敕其部界。令于江上更造新桥。佛与圣众。得乘度江。维耶离国。亦复造桥。欲使佛过。恒水诸龙。还相交编结龙为桥。请佛乘度。时佛思惟。若乘罗阅只所造桥度。恐维耶离国。及诸龙王。心怀微恨。乘维耶离所造桥度。恐阿阇世及龙怀恨。欲乘龙桥。恐二王有恨。佛又思惟。今当分身。令于三桥皆有佛过。佛垂临桥。王阿阇世。与其将从数亿众生。香花杂宝伎乐。供养佛法圣众。王与群臣一切大众。数亿千人。五体投地。自归悔过。垂泣送佛。佛现神化。于二王桥及诸龙桥。皆现有佛。与圣众俱。天龙鬼神。乘桥度江。王舍国王。维耶离王。恒水诸龙。各自见其所作桥上。佛将大众。乘桥度江。各不知见。更有佛在余桥上独自见桥。佛登度江。佛适度江已竟。见八万四千饿鬼。身出烟火。其中未得道者。见此火皆恐怖。是何大火。譬如烧其大山。见此大火。或来近水。或远于水。阿难悉知一切人意。长跪叉手。白佛言。佛天中天。佛至尊至重。天上天下最尊。一切众生。见此火者。无不恐怖。此何等火。愿佛为一切众生。说此何等之火。佛语阿难。此今饿鬼。先世不逢佛。亦不闻法。亦不见比丘僧。亦不知世间有罪福。生为饿鬼。如今见佛。奔趣归向。皆为头面着地。长跪叉手。白佛言。佛天中天。至尊至重。天上天下。怜愍一切众生蠉飞蠕动有形之类。佛为一切众生之父母。使我堕饿鬼佛度我。我亦如一切众生之类。佛亦知饿鬼先世所种。佛为一切众生故。问饿鬼前。世所种行今为饿鬼。饿鬼曰。先身虽见佛。不知有佛。虽见法不知有法。虽见比丘僧不知有比丘僧。我亦不作福。教他人亦不作福。作福有何等福。不作福有何种罪。见人作福。言恒笑之。见人作罪。意常欢喜。佛问饿鬼。生此饿鬼之中以来。至今更历几百年岁。饿鬼报言。我生中七万岁。佛问饿鬼。生中七万岁。食饮何种。为得何食。饿鬼报言。我先世种行至恶。遇值小水。即化不见。至于大水。便为鬼神龙罗刹所逐。言汝先世种恶。今何以来近此江海。虽值大龙普天放雨。谓呼得雨渍其身。方便砾石热沙。或值炭火以堕其身。佛问饿鬼。生中七万岁。由来饮食何等。饿鬼报佛言。或有世间父母亲里。称其名字。为作追福者。便小得食。不作福者。不得饮食。诸饿鬼叉手白佛言。从来饥渴。佛天中天。慈愍一切众生。今赐饿鬼小饮食。佛语阿难。捉钵取水。用布施饿鬼。阿难便捉钵取水。与饿鬼。饿鬼白佛言。今此一钵水。不饱一人。况乃八万四千。佛语诸饿鬼。八万四千。捉此钵水。至心布施佛及诸弟子。诸八万四千饿鬼。捉此钵水。长跪布施。以我先世不布施。今生饿鬼中。如今无所有。持此钵水。布施佛及诸弟子。使诸饿鬼缘此功德远离三恶道。后所生得师如佛无异。饿鬼过水与阿难。阿难捉水与佛尝一口。过与千二百五十弟子。各尝一口。佛语诸饿鬼。入大江饮水。并可洗浴。江海龙鬼神。遮不得洗浴饮水。佛语海龙王及诸鬼神。无极之水何以爱惜。诸龙鬼神言。不惜此水。以饿鬼不净故。佛语海龙王鬼神。卿身自从无数劫以来。亦作此身。爱惜无极之水。卿后还作此身。以悭贪故。生为饿鬼。诸海龙王鬼神。闻佛言尽还入海。听诸饿鬼。尽得饮水饱满洗浴。还出绕佛三匝。为佛作礼。叉手白佛言。佛天中天。知当来过去何时。当脱此饿鬼之身。佛言以一钵水故。后当弥勒佛出世人寿八万四千岁。现诸饿鬼尽得人身。皆得阿罗汉道。其诸众会。闻此布施功德者。皆得正真道意。诸一切饿鬼。绕佛三匝。作礼而去。维耶离国。诸王大臣。长者居士。国人无数。五体作礼。自投佛足。归命三宝。香花伎乐。缯盖幢幡。奉迎世尊华遍覆地。寻路供养。日日不绝。至于国城。佛与圣众天龙鬼神。往于城门。以金色臂德相之手。触城门阃。以梵清净八种之声。而说偈言

  诸有众生类　　在土界中者
  行住于地上　　及虚空中者
  慈爱于众生　　令各安休息
  昼夜勤专精　　奉行众善法

说此偈已。地即为之六返大动。佛便入城。空中鬼神。升空退散。地行鬼神。争门竞出。城门不容。各各奔突。崩城而出。于时城中。诸有不净。厕秽臭恶。下沉入地。高卑相从。沟坑皆平。盲视聋听。哑语躄行。狂者得正。病者除愈。象马牛畜。悲呜相和。箜篌乐器。不鼓自鸣。宫商调和。妇女珠环。相[敲-高+亭]妙响。器物[土*瓦]罂。自然有声。柔软和畅。妙法之音。地中伏藏。自然发出。一切众生。如遭热渴得清凉水服饮澡浴泰然稣息。举城众病。除愈解脱。亦复如是。佛与大众。便还出城。垂大慈哀。欲为众生施大拥护。绕城周匝。门门咒愿。敷演妙法。除凶致祥。普国疾患。灾疫悉除。国界尽安。于是才明。前礼佛足。长跪叉手。白世尊言。前许垂愍。唯愿明日。与诸大众。愍众生故。回光顾临至舍蔬食。佛默听许。欢喜踊跃。右绕三匝。礼佛而退。归家供办百味饭食。清净香洁。色鲜味甘。严饰家裹悬缯幡盖。床坐綩綖。香汁洒地。散花烧香。供设备办。遥于门中。长跪烧香。遥白佛言。幸时降神。尔时世尊。敕诸弟子。着衣持钵。行诣长者才明受请。即到其门。才明肃恭。花香伎乐。请佛入舍。佛与圣众。以次就位。于时才明。执持金瓶。躬行澡水。手自斟酌。上下平等。饭食毕讫。重行澡水。长跪叉手。前白佛言。唯愿世尊。垂四等心。更受三日如今之请。佛默便许。于是才明。供佛圣众。种种香洁。如其初日。四日已竟。以金色叠价直十万。次到上座。九万价叠。以次转下。末下坐者万钱价叠。以为哒嚫。其妻即起。长跪叉手。白世尊曰。惟天中天。慈加人物。愿留神光。受贱妾请。更住四日。佛默然许。其妻供养。初日后日。至于四日。饭食香洁。等无差异。四日已竟。又以金色十万价叠。奉上世尊。次九万叠。最下万钱。时才明子。起至佛前。长跪叉手。白世尊言。惟天中天。已受父母各四日食。幸垂慈哀怜愍。受我四日以请。佛亦默许。其子恭勤。四日供养。饭食甘美。亦如父母。即以金色十万价叠。奉献世尊。次坐九万。末下万钱。子妇又起长跪。白佛世尊。弘慈已受公姑及夫供养。幸如前比。复受四日。佛又默受。所设肴膳。如前无异。亦至四日。亦以金色十万价叠。次坐九万。下坐万钱。以为哒嚫。居家大小。于佛前坐。奉受训诲。佛为颁宣。敷演四谛苦集尽道。八贤圣路。断除劳意二十二结。证谛沟港。维耶离国。诸王大臣。长者居士。合国人民。皆生心念。佛来至国。为独以一才明故乎。意皆怀嫌。象马车步。皆共来集。向才明家。欲坏其舍得见世尊。大众震动。响响有声。佛悉预睹。故问阿难外有何声。阿难白佛维耶离王。大臣长者。国人巨细。皆怀怨心。世尊入国。才明请归。独固在家。至十六日。余不得见。以此为嫌。故集会来。欲见世尊。佛告阿难。出慰诸人。莫赍恨意。欲见佛者。便听使入。阿难宣命。谓诸大众以启听入。国王大臣。及一切人。闻佛教告。怒心霍除。无余微恨。如雨淹尘。便入见佛。五体投地。稽首佛足。大众浩浩。其舍不容。在外者众。佛悉慈愍。化才明舍令为琉璃。表里清彻。悉通相见。于是才明。为设床座。氍毹毾[登*毛]。种种食具。水精琉璃。金银杂宝。以为器物。大众食讫。于是才明。前白世尊及诸贵宾。居俭蔬食。枉屈顾临。愿以食器及床座具。以相贡遗。时会大众。莫不愕然。皆共叹咤。长者才明。立名不妄。与德相副。兴设大施。贡遗宝器。莫不周遍。家中财宝。岂可訾计四部弟子及与大众。心皆怀疑。长者才明。有何功德。请佛大众。至十六日。及王臣民。供养贡遗。周遍一国。得服甘露。前世福耶。今世德乎。阿难即知众会心疑。长跪叉手。前白佛言。大会怀疑。长者才明。于何福田。广植德本。遭何明师。受其教诲。今逮影报。财富无限。心明行净。先服甘露。惟愿世尊。现说本行。决一切疑。佛告阿难及诸大会。一心善听。今当解畅心之所疑。往世有城。名波罗奈。去城不远。山名仙居。山中池水。林树花果。快乐无比。世有佛时。与诸弟子。游处其中。若世无佛。缘觉居中。若无缘觉。外学神仙。则居其中。初无断绝。以是之故。斯名仙居。时有缘觉。在山中止。早起澡漱。法服持钵。出山求食。未至聚落。遇暴风雨。去道不远。有官果园。中有园监。见有烟出。道士往诣。报语主人。行遇风雨。幸听入舍。向火曝衣。即请令入。取薪然火。为曝衣裳。衣干体暖。风雨小歇。着衣欲出。园监问曰。惟圣道士。欲何所至。答曰贤者。一切有形。衣食为命。吾舍家学乞食自存。若不得食。身命不济。诸根不定。不能思道。园监对曰。贫家蔬食。色粗味酸。若垂甘受。幸住勿行。缘觉答曰。学道求食。不着色味。充躯而已。若相许食。便住不行。于是园监。便归取饭。至家问妇。饭食办未。对曰已办。其国食法。分饭别食。夫语妇曰。取吾分来。偶有要客。欲以食之。妻即念言。夫为男子。当执劳役。涉冒寒暑。假令不食。不能执劳。妾为女人。在家闲处。可持妾分。以[仁-二+俟]此客。其子又言。父母年老。便可自食。以我分与。其子妇曰。公姑及夫。以许食客。妾年幼壮。堪忍饥渴。乞以妾分。持用食客。大人便言。汝等各各。善心欲施。可共减取众人之分。足以食客。即便各减己之饭分。园监又念。道士衣裳。裂坏形露。因问其妇。家中少有衣裳调无。其妻对曰。家中惟有一领叠衣。会宾应门。更共衣之。余无所有。夫答妇言。以前世时无所惠施。今守贫贱。不及逮人。今者不施。贫穷下贱。何时当竟。富贵豪尊。衣食自然者。皆是前世惠施之福。今续惠施。无有厌足。我亦不用。会客应门。改易服饰。取叠并饭。家属皆往。到道士所。澡手奉食。道士食讫。澡漱涤钵。四人奉叠。供授缘觉。即便衣之。缘觉不以说法教化。现通神足悦寤众生。令发道意。告主人曰。以能惠施供养道士。坚强汝志。发弘誓愿。语竟升空。结交趺坐。住立经行。变现缘觉。充满虚空。各各现化。身出水出火。水不灭火。火不侵水。若干变化。乘空飞行。还仙居山。园监眷属。欢喜踊跃。叉手作礼。叩头求哀。便发誓愿。以今日惠施圣明神圣道士。缘是福报。离三恶道地狱饿鬼畜生之趣。所生之处。常共聚会。天上世间。饶富安隐。觉慧道力。服甘露味。如圣明师。若遭明师。神德殊胜。佛告大众。时园监者。则才明是。妻息子妇皆是本人。尔时同心。施尊缘觉。自是以来九十一劫。不更三涂。受弘福报。天上世间。室家聚会。不相远离。尔时发愿。愿服甘露。觉道得解。遭殊胜师。缘是之故。今遭值我。得遇胜觉。无限无喻。今服甘露。如其先师。尔时大会。闻佛颁宣。功德报应。莫不欢喜。心悦意清。自归三宝。佛法圣众。崄结除解。或受五戒。或舍家学。于是会中。有四千人。皆得道迹。往来不还。无著之果。无央数人。发大乘意。心不退转。于是世尊。起出其舍。一切大众。稽首各退。佛与大众。游至柰女林树精舍。柰女闻佛从大圣众至其树园。心喜无量。即便严驾。与其仆从。诣园见佛。到下宝车。如云降电。趋翔入园。如吉利天。服饰姿容殊天玉女。园树诸天。莫不回目。佛见其然。是魔使来。坏败净戒定慧解脱度知见品。即以梵音告诸沙门。柰女来至。各捡汝意。各自执持精进刀弓。皆自严办智慧之矢。被定意铠。乘禁戒车。与尘劳战。汝等当计女人所有欺诳。一切如金涂钱皮薄。如蝇翅以覆恶秽。筋骨连缀。血肉之聚。目眵洟唾。身体汗垢。若不洗拭。作是计念。观女人身。以制迷惑色欲之意。谛观骨舍。束缚以筋。涂以血肉。覆以衣服。饰以华彩。犹如画师立墙以堑埿涂恶露画。以彩色女人之身。亦复如是。当谛计知。除灭淫心。夫欲学道。先调其心。后可获安。不先调心。后悔无及。邪行迷旋。譬如枥马。临其寿终。愿与意违。终不解脱。其有视色。心随惑者。无常计常。苦有乐想。无我计我。不净净想。慧觉无常苦空不净。达如是者。即离长途生死患难。佛以是教。告诸弟子。皆共受持。一心奉行。柰女见佛。如日出云。金光照耀。发清净意。五体投地。稽首佛足。却坐一面。佛告柰女。女人情逸惑着五欲。汝能御心。回屈诣佛所。乐妙法化。是汝最利男子安重尘劳垢薄。乐受法化。此不为奇。女人缠绵。尘劳罗网。盘旋周障。不识出要。一切世间。苦空无常。不可怙恃。强疾侵壮。老失颜色。死劫寿命。危侵安隐。欲离是患。专精受法。勤修奉行。乃免斯苦。女人怨憎。相遇甚恶。亦甚恋慕。恩爱之别。凡为女人。每不远离于此二事。是故女人。当勤奉法。可离怨会恩爱离别。不复遭遇生老病死。众苦都灭。柰女闻佛若干妙化女人之秽。心怀惭愧。即起长跪。叉手白佛。愿垂慈哀。与圣众俱。至舍受食。佛即默受。于是柰女。稽首而退。还归办具百味之食。甘脆精美。张施幡盖。床座綩綖。香汁洒地。烧香散花。长跪请佛。日时已到。愿与圣众垂回临覆。佛与弟子。着衣持钵。至柰女家。花香伎乐。请佛入舍。各就坐位。手自斟酌。行水奉食。食讫澡漱。佛为广说布施福报戒慎之果。天人快乐。不得长久。危亡别离。不可恃怙。唯四圣谛。八贤圣路。以获大安。永无忧患。心皆欢喜。疑除结解。得须陀洹。众坐怀疑。柰女前世。有何功德。从树花生。端正姝好。贤者阿难。知众怀疑。长跪叉手。前白佛言。众坐悉疑。柰女前世。于何福田。植何德本。今遇世尊。服甘露药。佛告阿难。乃前过世。迦叶佛时。人寿二万岁。佛事终竟。复舍寿命。尔时有王。名曰善颈。供养舍利。起七宝塔。高一由延。一切众生。然灯烧香。花盖缯彩。供养礼事。时有众女。欲供养塔。便共相率。扫除塔地。时有狗粪。污秽塔地。有一女人。手撮除弃。复有一女。见其以手除地狗粪。便唾笑之曰。汝手以污不可复近。彼女逆骂。汝弊淫物。水洗我手。便可得净。佛天人师。敬意无已。手除不净。已便澡手。绕塔求愿。今扫塔地。污秽得除。令我来世劳垢消灭清净无秽。时诸女人。扫塔地者。今此会中。诸女人是。尔时扫地。愿灭尘劳。服甘露味。尔时以手。除狗粪女。今柰女是。尔时发愿。不与污秽会。所生清净。以是福报。不因胞胎臭秽之处。每因花生。以其尔时。发一恶声。骂言淫女。故今受是淫女之名。佛为广说善恶报应。天上世间。荣乐欢娱。三恶道苦。更相吞啖。愁毒号哭。尔时众会。闻佛所说。归命三尊。佛法圣众。除身口意。奉行十善。无央数人。各于三乘。建立道意。一切欢喜。绕佛三匝。作礼而去。于是世尊。还至精舍佛说除恐灾患经


佛说处处经

    No. 730

佛说处处经

        后汉安息国三藏安世高译

佛言。道人行道。若嗔恚意起时。即当制己。制便念善。是为道人行。若布施财利。得之便计无常。不随身犯。谓不犯杀盗淫。是为不随身犯。出嗔恚者口亦不言。意亦不念。是为出嗔恚意中大深声者。譬如人作盗。说言。汝所作大无状。是为意中大深声

佛言。味味次第者。所食物外合之内。分别其味令不错误。是为味味次第。菩萨所以得知者。前世所食啖。皆先上父母道人。然后自食。是故得是三十二相八十种好

佛言。菩萨用四事。得四无畏。一者自身所知。亦欲使人悉知二者教人无厌极。三者等心无所藏匿。四者为人说经从后不悔。是为四事。佛亦用四事。得四无所畏。一者如法说。二者不受他人物。三者等心。四者戒具。佛言。复有四无所畏。一者如事说。二者无所爱惜。三者神足。四者不与人共诤。佛得顶中光明者。有三因缘。一者然灯施佛寺。二者爱乐明经。三者解人疑结。佛举右手。有四因缘。一者用恶人无反复故。二者以善人有反复故。三者现教。四者语人无作恶。佛举右手复有四因缘。一者欲令十方人皆来学道随行意。二者为欲示人我所行福。今得是相。三者劝人皆令持戒。四者威仪自尔。亦为不欲见人恶态。是故举一切右手

佛不着履。有三因缘。一者使行者少欲。二者现足下轮。三者令人见之欢喜。佛行足去地四寸。有三因缘。一者见地有虫蚁故。二者地有生草故。三者现神足故。亦欲令人意止佛行。佛行地高下皆平。有三因缘。一者本行四等心。欲令一切安隐。地在水上水中有神。虫蚁一切值佛足下。皆安隐同心立意。是故卑者为高。高者为卑。二者诸天鬼神行福。为佛除地故。高下为平。三者佛为菩萨时。通利道迳。桥梁度人故。从是得福故。高下正平。欲令人意亦尔

佛不飞行。有四因缘。一者劝弟子欲令精进。二者欲令弟子听经。三者报宿命恩。四者现相。是故不飞行

佛在世时。诸天鬼神龙人民。皆到佛所听经。数千百重。行坐前后皆见佛面。所以者何。佛前世时。言语无前后。是故无不见佛面者。人卧皆随佛所首。用佛尊故

佛初得道不食七日。有四因缘。一者念道忘食。二者一心不饥。三者欢喜不渴。四者不念痛痒思想生死识。是为四。欲使人听经亦尔。佛袈裟里。尘水不着。外垢不着。有二因缘。一者不念一切人恶故。二者见一切人有欲。欲令灭之。佛复浣袈裟者。外垢不着里。著有身故有垢。所以者何。外行已尽。是故垢不着外。内行未尽是故垢着。用有身故为内未尽。以有身为罪用。是故不惜身命。所以者何。复惜命用命得道故

佛说八十亿万因缘经。都治人三病。一者贪淫。二者嗔恚。三者愚痴。是三事分为六。故应六衰治三病。经所以多者。譬如人服药病不愈。当更服余药。佛言。人意多端。疾转故多经。随意疗之欲使疾解故

佛已得道。复有三病六忧。六忧者谓忧六入。三病者谓心意识虞受故。佛已得道有是忧病。何况余人。殃罪不毕不得度世。佛业未竟不得度世。佛弃余寿二十年。有三因缘。一者用世间人贪身故。二者所教已尽。三者恐恶人诽谤之得罪重故。便取般泥洹。佛度世去。亦不持身去。亦不持意去。但为苦灭耳。地水火风空。常在世间无有断时

佛度世烧身。有三因缘。一者腐烂故。二者虫蛾生故。三者人以香华持资来得福故

佛笑口有五色光出者。有五因缘。一者欲令人有所问。因所问有益故。二者恐人言佛不知笑故。三者现口中光。四者笑诸不至诚。五者笑阿罗汉守空不得菩萨道。光还从顶上入者。当示后人大明故

佛欲度世去。诸比丘白佛言。诸在世间人。皆当从佛得福。今佛度世去。诸世间人民。当复从谁得福。佛言比丘。我虽度世去。经法当在。复有四因缘。可从得福。一者畜生无所食。饲之令得命。二者见人得疾病无瞻视者。当给与供养令得安隐。三者贫穷孤独当护视。四者人独一身行禅念道无所衣食当给视之。是为四事布施持善意与之。其得福与佛等无有异。尔时身皆痛。便欲度世去。佛谓舍利弗令说经者。有三因缘。一者恐佛去后人不信余比丘语故。二者劝弟子意令解。佛尚令比丘说经。何况余人。三者现舍利弗功德。恐余比丘各自贡高。欲得说经故。是故佛使舍利弗说经。佛度世去后。诸阿罗汉。共责数阿难。佛在世时欲得水。何以故不与。十方一切皆当从佛解脱。汝何以不留佛莫令般泥洹。佛欲行四神足。止住一劫。亦可百劫。亦可千劫。汝何不劝佛行四神足。阿难言。如卿语。佛为不得自在耶。当须我言。设使止住一劫在世间。弥勒当那得来下作佛。佛本行共学道者。有八十亿万人。皆求菩萨道。唯有两人得道耳。一有释迦文。二者弥勒。其余人有得阿罗汉辟支佛者。佛忍辱过于地。心软过于水。意坚过于须弥山。功德过于海水。智慧过于虚空。以是故前得佛耳

佛言。弥勒不来下。有四因缘。一者有时福应彼间。二者是间人粗无能受经者。三者功德未满。四者世间有能说经者。故弥勒不下。当来下。余有五亿七千六十万岁。弥勒时人眼皆见四千里。弥勒时人眼见四千里者。本行十因缘得。一者不掩人眼明。二者不舍人眼。三者不覆蔽人眼。四者不藏人善。五者不视杀。六者不视盗。七者不视淫。八者不视阴私及人短。九者诸恶事不视。十者然灯于佛寺。是为十事

佛辟支佛阿罗汉。是三人法同行异。佛者为觉意。辟支佛为见因缘知。阿罗汉坐禅乃知。辟支佛为因缘见生死相。自守不敢离行。从见因缘得道。故为辟支佛。佛者为通行欲度脱人故。故求辟支佛。辟支佛自割身活五百人。以木自刺其颈见因缘计挍。如割土见血。是水见万物皆非常便取道。有辟支佛。先世为菩萨五百劫。身已有三十相。无二相不及佛。不及佛者。无善权方便故

佛说生死勤苦三恶道事。有黠人意解。便取阿罗汉。虽作阿罗汉于中最尊。所以者何。用前世行菩萨道五百劫。有慈心欲度十方人故。虽得阿罗汉智慧。能晓方俗语。初为阿罗汉时。不能自觉前世为菩萨。佛便说佛功德。复为说阿罗汉功德。尔乃知佛功德大。便自悔欲转意取佛。佛言。已得阿罗汉道。不可复得转。便自悔言。我何愚痴正取阿罗汉道。佛便为解意。汝智胜余阿罗汉智慧不及佛。阿罗汉自断苦不断他人苦。佛本行自断苦亦断他人苦。是故不相及

佛言。舍利弗。有三语。悉以知人意。一者粗语。二者深语。三者牵语。得是三语。有善意即见。有恶意亦见。有忍意亦见。欲意从是三语悉知人意。舍利弗白佛言。弹指之间。人意有六十生死。佛言。有九百六十生死复不多。要有三意。有善意。有恶意。有欲意。善意有三百二十。恶意有三百二十。欲意有三百二十。弹指之间。三意并行。合为九百六十生死。除善意三百二十。余有六百四十生死意。佛与舍利弗。同行三十七品经。智慧不等者。譬如喘息。同从诸毛孔。出入能觉。便但知鼻息气出入。佛所知悉知诸毛孔。舍利弗所知如鼻孔。取舍利弗知分为十六分。满一佛界三千大千日月天下黠人所知。不及舍利弗所知一分。取佛智分为十六分。满一佛界中。舍利弗所知。不及佛知一分。三十七品行有三辈。有大三十七品。有中三十七品。有小三十七品。意大得大意。意中得中意。意小得小意。深妙具行三十七品便洞达。何以故。正分分为十六分。人本十六意。故佛分别。是故不同

舍利弗知一切法语用时语护语守语佛便谓舍利弗去非时语用。不可寄人故。舍利弗本字优波替。舍利弗。先佛度世去有三因缘。一为宿命尽。二为不欲见佛度世去。三为无所复度脱。舍利弗行受人饭已。还精舍中。言当偿债。谓当坐禅念道为偿债。不念道为负债行受人施。譬如负债未毕复更取前罪未竟今复造罪。佛言。食人施不可不念道。亦自得复益一切用。是故当偿债

佛言。舍利弗黠第一目揵连神足第一。阿难闻第一。罗云戒第一。阿那律彻视第一。佛使目揵连请舍利弗。舍利弗言。举我带。恐不能胜目揵连。便牵带。三千大千日月天地悉动。不能令带起。舍利弗便生意。当先往到佛所。目揵连从后行先。舍利弗至。佛知二人各第一。十方天下比丘。无有如罗云持戒者。罗云持戒有四因缘。一者自念言我为佛子。二者谓命持多。三者常自念我为沙门。四者持戒常欲胜余比丘。舍利弗。复持一盂水着海。水中挠捞之。明旦往取故水去。舍利弗尚能如此。何况佛。目揵连为人所挝。不飞去。不能得神足故。何以不能得神足用。罪未毕故

佛言。沸迦沙王。行至十二门。复还不知其身中六分。秉意能为道。不知身生意意生身。不能分别是。佛知可度故。便往从宿。王不知是佛。佛问。王行何法好何道。而衣毛为竖。佛为解身中事空于是便得道不悉断不得阿罗汉。佛言。诸行者当知。意能得道

佛言。昔者末利满台。学经二十四年。得五言解垢下弃离。亦不复忧。何以故。本宿命更见五百佛。悉通知众经。但闭藏经道不肯教人。后被病二十四日。临死时乃悔呼人教之。有是一福故知五言。何况乃具足教人。得福德不可计(知利满台他本作朱利盘特)。佛言。昔有栴那比丘得病。佛使舍利弗往与分卫。舍利弗因问之。汝眼宁有所识不。旃那对言曰。眼无所识但见色。识生身生病。对至故有病身亦不知死。设身死者。地水火风空皆当灭。但为意识移生耳。佛遣舍利弗行分卫过淫女家。女便闭门作治道。谓舍利弗言。汝不与我共淫者。当入是大火中。舍利弗报言。宁入是火中不与汝共淫。淫使人堕恶道无有出时。天便来下救之。佛言。人但不能守戒。若能守者。终不忧为邪道所中

佛言。昔有一比丘。坐禅行道。佛第难陀饮酒醉。数往来到其边歌戏。比丘白佛言。我欲避之去。佛言。不须是难陀于今当得道迹。佛即遣阿难往到其家。摩诃迦叶随其后。舍利弗为说经。目揵连现神足。难陀便欢喜。即得道迹。佛说比丘行道当但坚心者何忧不得道。比丘闻佛说此语。欢喜意解便得阿罗汉

佛姑子名须那察多。随侍佛八年便生念。与我兄弟俱行。而独端正有三十二相。便恶意生。随佛后扫佛迹。不令人见佛相。复于人中说佛无道。但言语中人意耳。舍利弗阿难闻之。便愁忧不乐。佛言。须那察多不为说我恶。为称誉佛功德耳。言语中人意者人意多病故。佛语舍利弗。须那察多不挍计但嗔耳。何以故不计。佛有三十二相光明神足。但降伏邪道故。佛数教诫须那察多。正真之言。是邪待之祷是故嗔耳

佛有姑姊。年老手自作缕织。成袈裟持上佛。佛不受。如是复言。佛当哀怜我故。当受之令我得福。阿难白佛言。可为我受之。佛语阿难。令持与诸比丘僧。我亦是比丘僧。不如与众人。后世当为因缘。今世相见欢喜者。皆是前世亲里善知识。何以故知之。相见意解故。佛言。世间人相待。但苦薄不苦厚

佛言。本侍佛者。字弥喜。次字须那察多。次字阿难。佛告诸比丘。我年老欲得一人侍我。舍利弗。摩诃迦叶。目揵连等。各自愿侍佛。佛言不得。摩诃迦叶。目揵连。因禅思惟知。佛欲得阿难。便呼阿难言。卿当侍佛。阿难言。我不敢侍佛。我不能侍佛。目揵连言。不得不侍佛。阿难言。当听我四事。一者佛余衣我不欲受。二者佛余饭我不用。三者若有人请佛。诸比丘不行。我亦不行。四者佛坐禅思道时。我当出入得自在。佛言大善。听汝所愿。于是阿难因侍佛。是故阿难独能问佛

佛弟子阿那律。难提。金毗罗。三人共坐自思惟七事。一者少欲得道。多欲不得道。二者知足得道。不知足不得道。三者精进得道。不精进不得道。四者守六衰使不起得道。不守六衰。放使起者不得道。五者自护得道。不自护不得道。六者守意得道。不守意不得道。七者智慧得道。不智慧不得道。共思惟七事。时去佛六十里。佛时坐禅。即知三人所念。便移意往坐三人前言。善哉善哉。我复语汝一事。不念家欲得道。念家欲不得道。于是三人欢喜即得菩萨

佛语阿难。人眼所见。四十二万由旬。何以知之。日月去地。四十二万由旬。人眼见日月。以是知眼所见者。十方广远之处。日月亿亿万倍。譬如大海中沙。亿亿万倍。不能计知人所作善恶殃福。即前后所作殃福。亿万不可复计。一切善恶要在命尽时。作恶逢恶处。作善得善处。殃福皆豫。有处皆豫。有父母兄弟妻子。得道便止。不得道不断绝也

佛言。调达但教人作福。不教人行道。佛教人作福持戒守意。得道乃止。调达自意生念。我当现神足。于国王阿阇世所。王随我。余人亦皆当随。我便化作一白象。独出入宫中。复化作一小儿。端正无比。便上王膝上。王大爱之。王见调达所作如是。王意呼调达胜佛。王便随调达所语。王吏民及未得道沙门。悉随王至调达所问事。调达便至佛所言。佛年老。可不须复教诸弟子。调达便呼舍利弗去。及诸沙门去。调达痴贪有是恶意。因亡神足。佛言。痴人所作颠倒非诸佛法。调达自意念言。我当飞去。人见我飞悉当随事。我因欲飞去。便不能复飞。调达不能自觉亡神足时。即有婆罗门行等心便从第一天上来下语舍利弗。调达以亡神足。佛语舍利弗。调达欲呼汝重令得罪。佛语天言。调达未得神足。我知当亡之。何况至今。佛言。人不当贪。调达但坐贪故。亡失神足

佛言。罗汉有两辈。一名舍沫。自忧身得道。即欲度世去。二辈随卫皆得度脱。佛与罗汉俱。行三十七品经。譬如灯火。佛计挍知有几事。知其本末守而灭之。阿罗汉不计本末。直而灭之。佛譬如顺树从本至末。分别知之。阿罗汉行。譬如从末至本。从本至末者。计本空从不知空者不得道

佛言。阿罗汉有盛阴无五阴。所有皆现但不着耳有色痛痒思想识无生死佛言。阿罗汉有为默以得阿罗汉有三相。一者不复犯身口意二者三毒灭。三者衣食不用作好。但灭饥寒意。有是三因缘。便能变化自在意。不着衰故不得自在。佛言。意但当分别六衰。不当着着便不得道

佛言。阿罗汉飞行有二因缘。故令人不见。一者恐人见便多供养。二者恐恶人嫉妒之。佛言。现神足复有两福。一者人见飞行。便精进念道。二者从人受施令得大福用。是故现神足。意喜故便得大福

佛言。有罗汉。名憍梵钵。已得阿罗汉道。反作牛饲。弟子问佛。何以故。佛言。是比丘前世宿命时。七百世作牛。今世得道。余习未尽故。佛语比丘。当念身无常。有一比丘。即报佛言。我念非常。人在世间极可五十岁。佛言。莫说是语。复有一比丘言。可三十岁。佛复言。莫说是语。复有一比丘言。可十岁。佛言。莫说是语。复有一比丘言。可一岁。佛复言。莫说是语。复有一比丘言。可一月。佛复言。莫说是语。复有一比丘言。可一日。佛复言。莫说是语。复有一比丘言。可一时。佛复言。莫说是语。复有一比丘言。可呼吸间。佛言是也。佛言。出息不还则属后世。人命在呼吸之间耳。佛语诸比丘。当会坐一切。但当说法语。不能者急闭目声。守意善听。可从得道诸比丘。闻佛说此语。欢喜意解。即得阿罗汉道

佛言。比丘入人舍中。当如手在空中无所挂碍。意亦无所著。耳闻可意是为着。闻不可意是为着。有一比丘白佛。可以不可皆着。当云何得道。佛言。比丘意解。空都无所著。是应菩萨行。诸比丘闻此语。皆欢喜踊跃。即得无所从生法忍

佛言。有一比丘。于山中坐叹息。有一人问比丘。卿为道。何以叹息。比丘报言。我在地狱中时。五毒极痛。今得作人。复得见佛经戒而复不得道。畏死复入是恶道中。是故叹息耳。为比丘亦忧俗人亦忧经戒亦自忧身。善意不可得常。或有因缘来时。便念妻子钱财。是为堕恶道

佛言。有一比丘到优婆夷家。分卫因为说经。优婆夷便长跪泪出。比丘说经至夜半。优婆夷长跪不起。比丘言。我行说经。未曾见人精进乃尔。优婆夷报言。我家有一驴。鸣至夜半便死。是故泪出耳。佛言。人说经不在为多。但问解慧。不也。有一比丘。闻佛说是事。便往问佛言。为我说一要法。令我得道。佛言。非汝物莫取。是汝物便取。于是比丘即自思念。天下万物皆非我许。独善是家物。于是比丘因白佛言。我已解。佛言。解是便为道耳。时有一比丘。闻佛说此语。便往问佛。舍利弗。为得是未。佛言。舍利弗悉得。比丘言舍利弗。何以骂我持袈裟拂我面。佛言。呼舍利弗来问之。舍利弗言。我无恶意。所以骂者欲令忍辱。所以持袈裟拂面者。欲令眼耳鼻口净故。佛语比丘。是舍利弗善权方便所作。于是比丘欢喜。即得阿罗汉道

佛言。昔一人往难。比丘言。人死识念思想所知皆灭。行道得定意所知亦灭。有何等异。比丘报言。俱灭。人死命尽神不灭。随行所生但微不可便见所得不同。为善升天为恶入渊。以是为异

佛言。有一比丘。到优婆夷家分卫。见端正好比丘。便生邪念因起。优婆夷即取饭具与之。比丘便舍去。我不应受人施。优婆夷便报之言。已有悔意可受施耳。优婆夷复报。比丘便受。佛言。譬如人有恶即觉罪灭。比丘受施无有罪。佛告诸弟子。能计空制意。如弹指顷。即可得道

佛言。有一比丘。坐得定意。有一优婆塞。见坐处不平。牵起示其安处。优婆塞后得五百劫不得安隐。何以故。断道念故。佛告诸弟子。有说经慎莫其中断。断经罪重不可计

佛言。有比丘行道得一禅。自言我得道迹第一禅福。上生第七天上寿一劫。得二禅自计得斯陀含。第三禅福。上生十五天寿八劫。得四禅自计我得阿罗汉。今我何故不得生第十九天上寿十六劫。作是言已。便言。佛为两舌耳。即时从天堕地狱中。不觉失天上寿便受地狱罪。譬如世间人得珍宝。一日为火起尽烧之。人生恶意为横烧善意(斯陀含下诸本并脱生天寿劫及得三禅等文)。佛言。人善恶相随无有解以。唯得道乃离俗耳。佛言。日中后不食有五福。一者少淫。二者少卧。三者得一心。四者无有下风。五者身安隐亦不作病。是故沙门道士知福不食。澡漱有三因缘。一者为恐爪下垢故。二者爬痒随可意。三者杀蚤蚊故。亦欲使意净无欲。复不污经此者。适可除外垢。心念恶不能除。为学人第一当净心为本心为法本。心正则行方行方则应道

佛言。昔有沙弥与师共行。见地有金便默取之。语师言。疾行是间。无人甚可畏。师言。但坐有金故令汝恐耳。弃金去便不复恐。弟子便为师作礼言。我愚痴无所知故。今已弃便不复懅。于是佛告诸弟子。学人贪道如沙弥贪金。何忧不得道

佛言。有比丘学道。从师受经不精进。师教取牛马粪数升烧之。至冥不尽。师取大石持地狱中。火烧之即作灰。弟子大恐长跪问师。是何等火。师言。汝不读经行道。死后当入地狱。狱中火烧汝不复移时。于是比丘惶怖便更精进。日闻一阿含便得罗汉道。佛言。善权方便度人如是

佛言。阿那含有三结。一者痴结。二者世间爱结。三者见未谛未尽结。阿那含。譬如火上焰烟起不能有所烧。须陀洹。除八十八结。斯陀含除七结。阿那含除三结。阿罗汉无有结。须陀洹得道迹。斯陀含为往来得道。阿那含为不还世间。阿罗汉为不复着。何等为得道迹。谓识苦。世间人皆不识苦。须陀洹为识苦。斯陀含为弃习。阿那含为知尽。阿罗汉为行道已竟。得须陀洹。别百劫乃得阿罗汉。何以故。乃百劫须陀洹。余有十结不断。不得阿罗汉。须陀洹但自忧身畏罪。不敢豫世间事。余有十疑结不解。不解故便止住。须陀洹所弃常有五下结。一者贪欲结。二者嗔恚结。三者见行结。四者戒贪福结。五者疑意结。亦谓从六天以下。以至世间贪欲嗔恚。贪身愿疑为下结。须陀洹见因缘者。谓不犯五戒时当死。死不犯。余人见急悉犯五因缘。须陀洹断故。受新阿罗汉。新故悉断。菩萨毕故罪。罪毕得道。乃知非常苦空。非身非道。道人行道不当有所著。行须陀洹得须陀洹。行斯陀含得斯陀含。行阿那含得阿那含。行阿罗汉得阿罗汉。行辟支佛得辟支佛。行菩萨得菩萨。佛言。学者随意所作。便得其报。如影响相随

佛言。钵有四名。一名为不供食。二名为戒。三名为受。四名为从。是得福无有瑕秽。便应受福持钵便立戒。意中无恶念

佛言。阿罗汉不食肉者。计畜生从头至足。各自有字无有肉名。辟支佛计本精所作不净故不食肉。佛计一切天下皆空无所有有便灭灭复生要归空故。为无所有。诸弟子闻经欢喜。为佛作礼而去佛说处处经


佛说大安般守意经

    No. 602

    佛说大安般守意经卷上

        康僧会序

夫安般者。诸佛之大乘。以济众生之漂流也。其事有六以治六情。情有内外。眼耳鼻舌身心谓之内矣。色声香味细滑邪念谓之外也。经曰诸海十二事。谓内外六情之受邪行。犹海受流。饿夫梦饭盖无满足也。心之溢荡无微不浃。恍惚仿佛出入无间。视之无形听之无声。逆之无前寻之无后。深微细妙形无丝发。梵释仙圣所不能照明默种于此化生乎。彼非凡所睹。谓之阴也。犹以晦曀种夫深芬闿手覆种。孳有万亿。旁人不睹其形。种家不知其数也。一朽乎下万生乎上。弹指之间心九百六十转。一日一夕十三亿意。意有一身心不自知。犹彼种夫也。是以行寂。系意着息数一至十。十数不误意定在之。小定三日。大定七日。寂无他念怕然若死。谓之一禅。禅弃也。弃十三亿秽念之意。已获数定转念着随蠲除其八。正有二意。意定在随。由在数矣。垢浊消灭心稍清净。谓之二禅也。又除其一注意鼻头。谓之止也。得止之行。三毒四走五阴六冥诸秽灭矣。煚然心明踰明月珠。淫邪污心。犹镜处泥秽垢污焉。偃以照天覆以临土。聪睿圣达万土临照。虽有天地之大靡一夫而能睹。所以然者由其垢浊。众垢污心有踰彼镜矣。若得良师刬刮莹磨。薄尘微曀荡使无余。举之以照。毛发面理无微不察。垢退明存使其然矣。情溢意散念万不识一矣。犹若于市驰心放听广采众音。退宴在思不识一夫之言。心逸意散浊翳其聪也。若自闲处。心思寂寞。志无邪欲。侧耳靖听。万句不失。片言斯着。心靖意清之所由也。行寂止意悬之鼻头。谓之三禅也。还观其身。自头至足反覆微察内体污露。森楚毛竖犹睹脓涕。于斯具照天地人物。其盛若衰无存不亡。信佛三宝。众冥皆明。谓之四禅也。摄心还念诸阴皆灭。谓之还也。秽欲寂尽其心无想。谓之净也。得安般行者厥心即明。举明所观无幽不睹。往无数劫方来之事。人物所更现在诸刹。其中所有世尊法化弟子诵习。无遐不见无声不闻。恍惚仿佛存亡自由。大弥八极细贯毛厘。制天地住寿命。猛神德坏天兵。动三千移诸刹。八不思议非梵所测。神德无限六行之由也。世尊初欲说斯经时。大于震动人天易色。三日安般无能质者。于是世尊化为两身。一曰何等。一尊主。演于斯义出矣。大士上人六双十二辈靡不执行。有菩萨名安清字世高。安息王嫡后之子。让国与叔驰避本土。翔而后集遂处京师。其为人也。博学多识。贯综神摸。七正盈缩。风气吉凶。山崩地动。针[血*永]诸术。睹色知病。鸟兽鸣啼无音不照。怀二仪之弘。仁愍黎庶之顽闇。先挑其耳却启其目。欲之视明听聪也。徐乃陈演正真之六度。译安般之秘奥。学者尘兴靡不去秽浊之操就。清白之德者也。余生末踪始能负薪。考妣殂落三师凋丧。仰瞻云日悲无质受。眷言顾之潜然出涕。宿祚未没会见南阳韩林颖川皮业会稽陈慧。此三贤者。信道笃密执德弘正。烝烝进进志道不倦。余从之请问。规同矩合义无乖异。陈慧注义余助斟酌。非师所传不敢自由也。言多鄙拙不究佛意。明哲众贤愿共临察。义有疣腨加圣删定共显神融矣

佛说大安般守意经卷上(此经多随字除数息相随之随余皆他本作堕)

        后汉安息三藏安世高译

佛在越只国舍羁瘦国。亦说一名遮匿迦罗国。时佛坐行安般守意九十日。佛复独坐九十日者。思惟校计。欲度脱十方人及蜎飞蠕动之类。复言。我行安般守意九十日者。安般守意得自在慈念意。还行安般守意已。复收意行念也。安为身。般为息。守意为道。守者为禁亦谓不犯戒。禁者亦为护。护者遍护一切无所犯。意者息意亦为道也。安为生。般为灭。意为因缘。守者为道也。安为数。般为相随。守意为止也。安为念道。般为解结。守意为不堕罪也。安为避罪。般为不入罪。守意为道也。安为定。般为莫使动摇。守意莫乱意也。安般守意名为御意至得无为也。安为有。般为无。意念有不得道。意念无不得道。亦不念有亦不念无。是应空定意随道行。有者谓万物。无者谓疑。亦为空也。安为本因缘。般为无处所。道人知本无所从来。亦知灭无处所。是为守意也

安为清。般为净。守为无。意名为。是清净无为也。无者谓活。为者谓生。不复得苦故为活也。安为未。般为起。已未起便为守意。若已意起便为守意。若已起意便走为不守当为还。故佛说安般守意也。安为受五阴。般为除五阴。守意为觉因缘。不随身口意也。守意者。无所著为守意。有所著不为守意。何以故。意起复灭故。意不复起为道。是为守意。守意莫令意生。生因有死为不守意。莫令意死。有死因有生意亦不死。是为道也。安般守意有十黠。谓数息相随止观还净四谛。是为十黠成。谓合三十七品经为行成也。守意譬如灯火有两因缘。一者坏冥。二者见明。守意一者坏痴。二者见黠也。守意意从因缘生。当缘因缘莫着。是为守意也。守意有三辈。一者守令不得生。二者已生当疾灭。三者事已行当从后悔计亿万劫不复作也。守与意各自异。护十方一切觉对不犯是为守。觉彼无为是为意。是守意也。守意中有四乐。一者知要乐。二者知法乐。三者为知止乐。四者为知可乐。是为四乐。法为行。得为道。守意六事为有内外。数随止是为外。观还净是为内。随道也。何以故。念息相随止观还净欲习意近道故。离是六事便随世间也。数息为遮意。相随为[僉*殳]意。止为定意。观为离意。还为一意。净为守意。用人不能制意故行此六事耳。何以故数息。用意乱故。何以故不得。用不识故。何以故不得禅。用不弃习尽证行道故也。数息为地。相随为犁。止为轭。观为种。还为雨净为行。如是六事乃随道也。数息断外。相随断内。止为止罪。行观却意。不受世间为还。念断为净也。意乱当数息。意定当相随。意断当行止。得道意当观。不向五阴当还。无所有当为净也。多事当数息。少事当相随。家中意尽当行止。畏世间当观。不欲世间为还。念断为净也。何以故数息。不欲随五阴故。何以故相随。欲知五阴故。何以故止。欲观五阴故。何以故观阴。欲知身本故。何以故知身本。欲弃苦故。何以故为还。厌生死故。何以故为净。分别五阴不受故。便随黠慧八种道得别为得所愿也。行息时为随数。相随时为随念。止时为随定。观时为随净。还时为随意。净时为随道亦为随行也

数息为四意止。相随为四意断。止为四神足念。观为五根五力还为七觉意。净为八行也。得息不相随不为守意。得相随不止不为守意。得止不观不为守意。得观不还不为守意。得还不净不为守意。得净复净乃为守意也。已念息恶不生。复数者为共遮意。不随六衰故。行相随为欲离六衰行。止为欲却六衰行。观为欲断六衰行。还为欲不受六衰行。净为欲灭六衰。已灭尽便随道也

数息欲遮意。息中有长短。当复遮是长短意也。何以故守意。欲止恶故。恶亦可守亦不可守。何以故。恶已尽不当复守也

数息有三事。一者当坐行。二者见色当念非常不净。三者当晓嗔恚疑嫉念过去也。数息乱者当识因缘所从起。当知是内意。一息乱者是外意过。息从外入故。二息乱者是内意过。息从中出故。三五七九属外意。四六八十属内意。嫉嗔恚疑是三意在内。杀盗淫两舌恶口妄言绮语。是七意及余事属外也。得息为外。不得息为内。息从意生。念息合为一数。息至尽数为一亦非一。意在外息未尽故。譬如数钱。意在五数为一也。数息所以先数入者。外有七恶。内有三恶。用少不能胜多故先数入也。数息不得者失其本意故。本意谓非常苦空非身。失是意堕颠倒故。亦为失师。师者初坐时。第一入息得身安便次第行。为失其本意故不得息也。数息意常当念非常苦空非身。计息出亦灭入亦灭。已知是得道疾当持非常恐意。得是意即得息也。入息出息所以异者。出息为生死阴。入息为思想阴。有时出息为痛痒阴。入息为识阴。用是为异。道人当分别是意也。入息者为不受罪。出息者为除罪。守意者为离罪。入息者为受因缘。出息者为到因缘。守意者为不离因缘也。数息不得有三因缘。一者罪到。二者行不互。三者不精进也。入息短出息长。无所从念为道意。有所念为罪。罪恶在外不在内也数息时。有离意为喘息长。得息为喘息短。不安行息为长定为短。念万物为长息无所念为短息。未至十息。坏复更数为长息。得十息为短息。得息为短。何以故。止不复数故。得息亦为长。何以故。息不休故为长也。喘息长自知。喘息短自知。谓意所在为自知长短。意觉长短为自知。意不觉长短为不自知也。道人行安般守意欲止意。当何因缘得止意。听说安般守意。何等为安。何等为般。安名为入息。般名为出息。念息不离是名为安般。守意者欲得止意。在行者新学者。有四种安般守意行。除两恶十六胜。即时自知乃安般守意行令得止意。何等为四种。一为数。二为相随。三为止。四为观。何等为两恶。莫过十息。莫减十数。何等为十六胜。即时自知喘息长。即自知喘息短。即自知喘息动身。即自知喘息微。即自知喘息快。即自知喘息不快。即自知喘息止。即自知喘息不止。即自知喘息欢心。即自知喘息不欢心。即自知内心念万物已去不可复得喘息自知。内无所复思喘息自知。弃捐所思喘息自知。不弃捐所思喘息自知放弃躯命。喘息自知。不放弃躯命喘息自知。是为十六即时自知也。问何等为莫过十数莫减十数。报息已尽未数是为过。息未尽便数是为减。失数亦恶不及亦恶。是为两恶。至二息乱为短息。至九息乱为长息。得十息为快息。相随为微。意在长便转意。我何以故念长。意在短即时觉不得令意止。止为着。放弃躯命者谓行息。得道意便放弃躯命。未得道意。常爱身故不放弃躯命也。息细微为道。长为生死。短息动为生死。长于道为短。何以故。不得道意无知见故为短也。数息为单。相随为复。止为一意。观为知意。还为行道。净为入道也。数时为念至十息为持是为外禅。念身不净随空是为内禅也。禅法恶来不受是名为弃。闭口数息随气出入。知气发何所灭何所。意有所念不得数息。有迟疾大小亦不得数。耳闻声乱亦不得数也。数息意在息数为不工。行意在意乃为止。数息意但在息是为不工。当知意所从起气所灭。是乃应数因缘尽便得定意也。守意者念出入息。已念息不生恶故为守意。息见因缘生无因缘灭因缘断息止也。数息为至诚。息不乱为忍辱。数息气微不复觉出入。如是当守一念止也。息在身亦在外。得因缘息生。罪未尽故有息。断因缘息不复生也

数息以为随第二禅。何以故。用不待念故为随第二禅也。数息为不守意。念息乃为守意。息从外入息未尽息在入意在尽识在数也。十息有十意为十绊。相随有二意为二绊。止为一意为一绊。不得息数为恶意不可绊。恶意止乃得数。是为和调可意绊也。已得息弃息。已得相随弃相随。已得止弃止。已得观弃观莫复还莫复还者。莫复数息亦使意意亦使息也有。所念为息使意。无所念为意使息也。息有四事。一为风。二为气。三为息。四为喘。有声为风。无声为气。出入为息。气出入不尽为喘也。数息断外。相随断内。数从外入为断外亦欲离外因缘。数从中出为欲离内因缘。外为身离。内为意离。身离意离是为相随。出入息是为二事也。数息为欲断内外因缘。何等为内外。谓眼耳鼻口身意为内。色声香味细滑念为外也。行息为使意向空。但欲止余意。何以为向空。息中无所为故也。数息意走不。即时觉者。罪重意轻罪。引意去疾故不觉也。行道已得息自厌息意欲转不复欲数如是为得息。相随止观亦尔也。知出入息灭。灭为得息相知生死。不复用为得生死相已得四禅。但念空为种道栽

行息已得定不复觉气出入便可观。一当观五十五事。二当观身中十二因缘也。问息出入宁有处不报息入时。是其处出息时。是其处数息身坐痛痒思想生死识止不行。是为坐也。念息得道复校计者。用息无所知故。问念息得道何以为无所知。报意知息息不知意是为无所知。人不能得校计意。便令数息。欲令意定。虽数息。但不生恶。无有黠智。当何等行得黠慧。从一至十。分别定乱。识对行药。已得定意。便随黠慧。得校计为堕观也。问何等为数。报数者谓事。譬如人有事更求是为数罪。道人数福。何以故正为十。一意起为一。二意起为二。数终于十。至十为竟。故言十数为福。复有罪者用不能坏息故为罪。亦谓意生死不灭堕世间已不断世间事为罪也。六情为六事痛痒思想生死识。合为十事。应内十息。杀盗淫两舌恶口妄言绮语嫉妒嗔恚痴。应外十息。谓止不行也

问何等为十六事。报十事者。谓数至十六者。谓数相随止观还净。是为十六事为行不离为随道也。问数息念风为随色何以应道。报行意在数不念色气尽便灭。堕非常知非常为道也。道人欲得道。要当知坐行二事。一者为坐。二者为行。问坐与行。为同不同报。有时同有时不同。数息相随止观还净。此六事。有时为坐。有时为行。何以故。数息意定。是为坐。意随法。是为行。已起意不离为行。亦为坐也。坐禅法。一不数。二二不数一一数二者谓数一息未竟便言二是为一数二如是为过精进二数一者谓息已入二甫言一是为二数一如是为不及精进。从三至四五至六七至八九至十。各自有分部。当分别所属。在一数一。在二数二。是为法行便堕精进也。有三坐堕道。一为数息坐。二为诵经坐。三为闻经喜坐。是为三也。坐有三品。一为味合坐。二为净坐。三为无有结坐。何等为味合坐。谓意着行不离。是为味合坐。何谓为净坐。谓不念为净坐。何等为无有结坐。谓结已尽为无有结坐也。息有三辈。一为杂息。二为净息。三为道息。不行道。是为杂息。数至十息不乱。是为净息。已得道。是为道息也。息有三辈。有大息。有中息有微息。口有所语。谓大息止念道。中息止得四禅。微息止也

问佛何以教人数息守意报。有四因缘。一者用不欲痛故。二者用避乱意故。三者用闭因缘。不欲与生死会故。四者用欲得泥洹道故也。譬喻说日无光明者有四因缘。一者用有云故。二者用有尘故。三者用有大风故。四者用有烟故。数息不得亦有四因缘。一者用念生死校计故。二者用饮食多故。三者用疲极故。四者用坐不得更罪地故。此四事来皆有相。坐数息忽念他事失息意。是为念校计相。骨节尽痛。不能久坐。是为食多相。身重意瞪瞢。但欲睡眠。是为疲极相。四面坐不得一息。是为罪地相。以知罪当经行。若读经文坐。意不习罪。亦祸消也。道人行道当念本。何等为本。谓心意识是为本。是三事皆不见。已生便灭。本意不复生。得是意为道。意本意已灭无为痛更因缘生便断也。定意日胜。日胜为定意。有时从息得定意。有时从相随得定意。有时从止得定意。有时从观得定意。随得定因缘直行也。行息亦堕贪。何以故。意以定便喜故。便当计出息入息念灭时。息生身生息灭身灭。尚未脱生死苦。何以故。喜已计如是便贪止也。数息欲疾。相随欲迟。有时数息当安徐。相随时当为疾。何以故。数息意不乱当安徐。数乱当为疾。相随亦同如是也。第一数亦相随所念异。虽数息当知气出入意着在数也。数息复行相随。止观者。谓不得息前世有习。在相随止观。虽得相随。止观当还从数息起也。数息意不离是为法离。为非法数息意不随罪。意在世间便堕罪也。数息为不欲乱意故。意以不乱复行相随者。证上次意知为止。止与观同。还与净同也。行道得微意当倒意者。谓当更数息。若读经已。乃复行禅微意者。谓不数息及行相随也

佛有六洁意。谓数息相随止观还净。是六事能制无形也。息亦是意亦非意。何以故。数时意在息为是。不数时意息各自行。是为非意。从息生意已。止无有意也。人不使意意使人。使意者。谓数息相随止观还净。念三十七品经。是为使意。人不行道贪求随欲。是为意使人也。息有垢息垢不去不得息。何等为息垢。谓三冥中最剧者。是为息垢。何等为三冥。谓三毒起时身中正冥故言三冥。三毒者。一为贪淫。二为嗔恚。三为愚痴。人皆坐是三事死故言毒也。数息时意在数息未数时有三意。有善意有恶意有不善不恶意。欲知人得息相者。当观万物及诸好色。意不复着是为得息。相意复着。是为未得当更精进。行家中意欲尽者。谓六情为意家贪爱万物。皆为意家也相随者。谓行善法从是得脱。当与相随。亦谓不随五阴六入。息与意相随也

问第三止。何以故。止在鼻头。报用数息相随止观还净。皆从鼻出入。意习故处亦为易识。以是故着鼻头也。恶意来者断为禅。有时在鼻头止。有时在心中止。在所著为止。邪来乱人意。直观一事。诸恶来心不当动。心为不畏之哉也。止有四。一为数止。二为相随止。三为鼻头止。四为息心止。止者谓五乐六入当制止之也

入息至尽鼻头止。谓恶不复入至鼻头止。出息至尽着鼻头。谓意不复离身行向恶故着鼻头。亦谓息初入时。便一念向不复转。息出入亦不复觉。是为止也。止者如如出息入息觉知前意出。不觉后意出。觉前意为意相观。便察出入息见败。便受相畏生死便却意。便随道意相也。莫为相随者。但念着鼻头。五阴因缘不复念。罪断意灭亦不喘息。是为止也。莫为相随者。谓莫复意念出入。随五阴因缘。不复喘息也

第四观者。观息败时与观身体异息。见因缘生无因缘灭也。心意受相者。谓意欲有所得。心计因缘会当复灭。便断所欲不复向。是为心意受相也。以识因缘为俱相观者。谓识知五阴因缘。出息亦观入息亦观。观者谓观五阴。是为俱观。亦应意意相观。为两因缘。在内断恶念道也。观出息异入息异者。谓出息为生死阴。入息为思想阴。有时出息为痛痒阴。入息为识阴。随因缘起便受阴。意所向无有常用。是故为异。道人当分别知是。亦谓出息灭入息生。入息灭出息生也。无有故者。谓人意及万物意起已灭。物生复死。是为无有故也。非出息是入息。非入息是出息。非谓出息时意不念入息。入息时意不念出息。所念异故言非也。中信者。谓入道中见道因缘信道。是为中信也

第五还弃结者。谓弃身七恶。第六净弃结者为弃意三恶。是名为还。还者为意不复起恶。恶者是为不还也。还身者。谓还恶得第五还尚有身亦无身。何以故。有意有身无意无身。意为人种。是名为还。还者谓意不复起恶。起恶者是为不还。亦谓前助身后助意。不杀盗淫两舌恶口妄言绮语。是为助身。不嫉嗔恚痴。是为助意也。还五阴者。譬如买金得石便弃捐地不用。人皆贪爱五阴得苦痛。便不欲是为还五阴也。何等为便见灭尽处。谓无所有是为灭处。问已无所有。何以故。为处者无所有处有四处。一者飞鸟以空中为处。二者罗汉以泥洹为处。三者道以无有为处。四者法在观处也。出息入息受五阴相者。谓意邪念疾转还正以生觉断。为受五阴相。言受者。谓受不受相也。以受五阴相。知起何所灭何所。灭者为受十二因缘人。从十二因缘生。亦从十二因缘死。不念者为不念五阴也。知起何所灭何所。谓善恶因缘起便复灭。亦谓身亦谓气生灭。念便生不念便死。意与身同等。是为断生死道。在是生死间。一切恶事皆从意来也。今不为前前不为今者。谓前所念已灭。今念非前念。亦谓前世所作今世所作各自得福。亦谓今所行善非前所行恶。亦谓今息非前息。前息非今息也。为生死分别者。为意念生即生念灭即灭。故言生死。当分别万物及身。过去未来福为索尽。何以故。尽以生便灭灭便尽。已知尽当尽力求也。视上头无所从来者。谓人无所从来意起为人。亦谓人不自作来者。为有所从来。人自作自得是为无所从来也。生死当分别者。谓知分别五阴。亦谓知分别意生死人意为常。知无有常亦为分别也。后视无处所者。为今现在。不见罪人在生死会。当得无有脱于罪故。言后视无有处所。未得道迹。不得中命尽。谓已得十五意不得中死。要当得十五意便堕道。亦转上至阿罗汉也。中得道亦不得中命尽。为息意身凡三事。谓善恶意要当得道迹亦复中坏。息死复生。善意起复灭。身亦不得中死也。何等为净。谓诸所贪欲为不净。除去贪欲是为净。何等为五阴相。譬喻火为阴薪为相也。从息至净是皆为观。谓观身相随止观还净本为无有。内意数息外意断恶因缘。是为二意也。问何以故。不先内外观身体。反先数息相随止观还净。报用意不净故。不见身意已净。便悉见身内外道。行有十九。行用人有十九病故。亦有十九药。观身念恶露。是为止贪淫药。念四等心。是为止嗔恚药。自计本何因缘有。是为止愚痴药。安般守意。是为多念药也。内外自观身体。何等为身。何等为体。骨肉为身。六情合为体也。何等为六情。谓眼合色耳受声鼻向香口欲味细滑为身衰意为种栽为痴。为有生物也。内外身体所以重出者何。谓人贪求有大小有前后。谓所欲得当分别观。观者见为念。念因见观者为知也。身体止者。坐念起起念意不离。在所行意所著为识。是为身观止也。出息入息念灭时。何等为念灭时。谓念出入气尽时。意息灭出息入息念灭时。譬如画空中无有。处生死意道意俱尔也。出息入息念灭时。亦不说息意息说。灭时出息入息念灭时。物从因缘生。断本为灭时也。内外痛痒见观者。为见痛痒所从起。便观是为见观也。内外痛痒者。谓外好物为外痒。外恶物为外痛。内可意为内痒内不可意为内痛。在内为内法。在外因缘为外法。亦谓目为内色为外。耳为内声为外。鼻为内香为外。口为内味为外。心为内念为外。见好细滑意欲得是为痒。见粗恶意不用是为痛。俱堕罪也。痛痒观止者。若人臂痛意不作痛。反念他一切身痛如是。以意不在痛为止痛。亦可念亦不可念。念痛无所著。自爱身当观他人身。意爱他人身当自观身亦为止也

内外痛痒所以重出者何。谓人见色爱有薄厚。其意不等观。多与少异故。重分别观道。当内观有痴。当外观以自证也。身心痛痒各自异。得寒热刀杖痛极。是为身痛。得美饭载车好衣身诸所便。是为身痒。心痛者。身自忧复忧他人及万事。是为心痛。心得所好及诸欢喜。是为心痒也。意相观者有两因缘。在内断恶念道。一者谓五乐六衰当制断之。观者自观身。身不知粗细。以得乃觉是为意意相观。意意相观息亦是意。数亦是意。数时观息为意意相观也。意观止者。欲淫制不为欲嗔恚制不怒欲痴制不作欲贪制不求诸恶事一切不向。是为观止。亦谓以知三十七品经。常念不离为止也。出息入息尽定便观者。尽谓罪尽。定谓息止意。定观者谓观止还净也。尽止者谓我能说是晓是遍更是。是为尽止也。所起息若布施作福一切善法。已起便灭更意念耶。向习罪行亦无数。古世今世意不如是相随。他人亦尔。已知觉当断已断。为内外意意观止也。内外法法者。内法谓身。外法谓他人。有持戒法有不持戒法。是为内外法法也。内法谓行黠不离三十七品经。一切余事意不堕中。行道得道。是为内法。外法谓堕生死谓生死行。便得生死不脱一切当断已断。为内外法观止也。法观止者。一切人皆自身为身。谛校计非我身。何以故。有眼有色。眼亦非身色亦非身。何以故。人已死有眼无所见。亦有色无所应。身如是但有识亦非身。何以故。识无有形。亦无所轻止。如是计眼耳鼻舌身意亦尔。得是计为法观止。亦谓不念恶为止。念恶为不止。何以故。意行故也

佛说大安般守意经卷上佛说大安般守意经卷下

        后汉安息三藏安世高译

出息入息自觉。出息入息自知。当时为觉。以后为知。觉者谓觉息长短。知者谓知息生灭粗细迟疾也。出息入息觉尽止者。谓觉出入息欲报时为尽。亦计万物身生复灭。心者谓意止也。见观空者。行道得观不复见身。便堕空无所有者。谓意无所著意有所著因。为有断六入便得贤明。贤谓身。明谓道也。知出何所灭何所者。譬如念石出石入木石便灭。五阴亦尔。出色入痛痒。出痛痒入思想。出思想入生死。出生死入识。已分别是。乃堕三十七品经也

问何等为思惟无为道。报思为校计惟为听无谓不念万物。为者如说行道为得故。言思惟无为道也。思为念惟为分别白黑。黑为生死白为道。道无所有已分别无所有。便无所为。故言思惟无为道。若计有所为所著。为非思惟。思亦为物惟为解意。解意便知十二因缘事。亦谓思为念惟为计也。断生死得神足。谓意有所念为生。无所念为死。得神足者能飞行故。言生死当断也

得神足有五意。一者喜。二者信。三者精进。四者定。五者通也。四神足念不尽力得五通。尽力自在向六通。为道人四神足。得五通尽意可得六通尽意。谓万物意不欲也。一信二精进三意四定五黠。是五事为四神足。念为力者凡六事也。从信为属四神足念。从喜从念精进从定从黠。是为属五根也。从喜定谓信道。从力定谓精进。从意定谓意念定。从施定谓行道也。为种故有根。有为之事。皆为恶。便生想不能得胜。谓得禅是因为力。亦谓恶不能胜善意。灭复起故为力。力定者恶意欲来不能坏。善意故为力定也

道人行道未得观。当校计得观。在所观意不复转为得观止恶一法为坐禅观二法。有时观身有时观意有时观喘息有时观有有时观无。在所因缘当分别观也。止恶一法观二法恶已尽。止观者为观道。恶未尽不见道。恶已尽乃得观道也。止恶一法为知恶。一切能制不着意为止。亦为得息想随止。得息想随止是为止恶一法。恶已止便得观故。为观二法。为得四谛为行净。当复作净者。识苦弃习。知尽行道。如日出时。净转出十二门故。经言从道得脱也。去冥见明如日出时。譬如日出多所见为弃诸冥。冥为苦。何以知为苦。多所挂碍故知为苦。何等为弃习。谓不作事。何等为尽证。谓无所有。道者明识苦断习尽证念道。识从苦生。不得苦亦无有识。是为苦也。尽证者。谓知人尽当老病死证者知万物皆当灭。是为尽证也。譬如日出作四事。一坏冥。谓慧能坏痴。二见明。谓痴除独慧在。三见色万物。为见身诸所有恶露。四成熟万物。设无日月万物不熟。人无有慧痴意亦不熟也。上头行俱行者。所行事已行不分别说。谓行五直声。身心并得行也。从谛念法意着法中。从谛念法意着所念。是便生是求生死。得生死求道。得道内外随所起意。是为念法意着法中者。从四谛自知意生。是当得是不生是不得。是便却意畏不敢犯。所行所念常在道。是为意着法中也。是名为法正从谛本起本着意。法正者谓道法。从谛谓四谛。本起着意者谓所向生死万事。皆本从意起。便着意便有五阴所起意当断。断本五阴便断。有时自断不念。意自起为罪。复不定在道为罪。未尽故也。意着法中者。谛意念万物为堕外法。中意不念万物为堕道法中。五阴为生死法。三十七品经为道法。意着法中者。谓制五阴不犯。亦谓常念道不离。是为意着法中也。所本正者所在。外为物本为福所在。内总为三十七品经。行道非一时端故。言所本者。谓行三十七品经法。如次第随行意不入邪为正故。名为所本。正所本正各自异行。以无为对本。以不求为对正。以无为为对无为。以不常为对道。以无有为对亦无有所。亦无有本。亦无有正。为无所有也。定觉受身。如是法道说谓法定。道说者谓说所从因缘得道。见阴受者为受五阴。有入者为入五阴中。因有生死阴者为受正。正者道自正。但当为自正心耳。人行安般守意。得数得相随得止便欢喜。是四种譬如钻火见烟不能熟物。得何等喜用未得出要故也

安般守意有十八恼。令人不随道。一为爱欲。二为嗔恚。三为痴。四为戏乐。五为慢。六为疑。七为不受行相。八为受他人相。九为不念。十为他念。十一为不满念。十二为过精进。十三为不及精进。十四为惊怖。十五为强制意。十六为忧。十七为匆匆。十八为不度意行爱。是为十八恼。不护是十八因缘不得道。以护便得道也。不受行相者。谓不观三十二物。不念三十七品经。是为不受行相。受他人相者。谓未得十息便行相随。是为受他人相。他念者。入息时念出息。出息时念入息。是为他念。不满念者。谓未得一禅便念二禅。是为不满念。强制意者。谓坐乱意不得息。当经行读经以乱不起。是为强制意也。精进为黠。走是六事中。谓数息相随止观还净。是为六也。何等为喘。何等为息。何等为气。何等为力。何等为风。制者为意息。为命守。为气。为视听风。为能言语从道屈伸力。为能举重嗔恚也。要从守意得道。何缘得守意。从数转得息。息转得相随。止观还净亦尔也。行道欲得止意。当知三事。一者先观念身本何从来。但从五阴行有。断五阴不复生。譬如寄托须臾耳。意不解念九道以自证。二者自当内视心中随息出入。三者出息入息念灭时息出小轻。念灭时何等为知无所有。意定便知空。知空便知无所有。何以故。息不报便死。知身但气所作。气灭为空。觉空堕道也。故行道有三事。一者观身。二者念一心。三者念出入息。复有三事。一者止身痛痒。二者止口声。三者止意念行。是六事疾得息也。要经言一念谓一心。近念谓计身。多念谓一心。不离念谓不离念。身行是四事。便疾得息也。坐禅数息即时定意。是为今福。遂安隐不乱。是为未来福。益久续复安定。是为过去福也。坐禅数息不得定意。是为今罪。遂不安隐乱意起。是为当来罪。坐禅益久遂不安定。是为过去罪也。亦有身过意过。身直数息不得。是为意过。身曲数息不得。是为身过也。坐禅自觉得定意。意喜为乱意。不喜为道意。坐禅念息已止便观。观止复行息。人行道当以是为常法也

佛说有五信。一者信有佛有经。二者去家下头发求道。三者坐行道。四者得息。五者定意所念不念为空难不念为空。何以故念息。报曰。息中无五色贪淫嗔恚愚痴爱欲。是亦为空也。可守身中意者。谓意在身观。是为身中意。人不能制意故令数息。以黠能制意。不复数息也。问何等为自知。何等为自证报谓。能分别五阴是为自知。不疑道是为自证也。问曰。何等为无为。报无为有二辈。有外无为有内无为。眼不观色。耳不听声。鼻不受香。口不味味。身不贪细滑。意不志念。是为外无为。数息相随止观还净。是为内无为也。问现有所念何以为无为。报身口为戒。意向道行。虽有所念本趣无为也。问何等为无。何等名为。报无者谓不念万物。为者随经行指事称名。故言无为也

问设使宿命对来到。当何以却。报行数息相随止观还净。念三十七品经能却难。宿命对不可却。数息行三十七品经。何以故能却。报用念道故消恶。设使数息相随止观还净不能灭恶。世间人皆不得道。用消恶故得道。数息相随止观还净。行三十七品经尚得作佛。何况罪对。在十方积如山。精进行道不与罪会。问曰。经言作是何以故不会。报用作是故也。数息为堕十二品。何谓十二品。数息时堕四意止。息不乱时为堕四意念断。得十息有时为堕四神足。是为堕十二品也

问何等为念三十七品经。报谓。数息相堕止观还净行。是六事是为念三十七品经也。行数息亦为行三十七品经。问何以故为行三十七品经。报数息为堕四意止。何以故。为四意止。亦堕四意断。用不待念故为四意断。亦堕四神足。用从信故为神足也。数息为堕信根。用信佛意喜故生信根。亦堕能根。用坐行根为堕能根。亦堕识根。用知谛故为识根。亦堕定根。用意安故为定根。亦堕黠根。用离痴意解结故为黠根也。数息亦堕信力。用不疑故为信力。亦堕进力。用精进故为进力。亦堕念力。用余意不能攘故为念力。亦堕定力。用一心故为定力。亦堕黠力。用前分别四意止断神足故为黠力也。数息亦堕觉意。用识苦故为觉意。亦堕法识觉意。用知道因缘故为法觉意。亦堕力觉意。用弃恶故为力觉意。亦堕爱觉意。用贪乐道故为爱觉意。亦堕息意觉。用意止故为息意觉。亦堕定觉意。用不念故为定觉意。亦堕守觉意。用行不离故为守觉意也。数息亦堕八行。用意正故入八行。定意慈心念净法。是为直身。至诚语软语直语不还语。是为直语。黠在意信在意忍辱在意。是为直心。所谓以声息。是为十善堕道行也。数息亦堕直见。用谛观故为直见。亦堕直行。用向道故为直行。亦堕直治。用行三十七品经故为直治。亦堕直意。用念谛故为直意。亦堕直定。用意白净坏魔兵故为直定。是为八行。何等为魔兵。谓色声香味细滑。是为魔兵。不受是为坏魔兵。三十七品应敛。设自观身观他人身止淫。不乱意止余意。自观痛痒观他人痛痒止嗔恚。自观意观他人意止痴。自观法观他人法得道。是名为四意止也。避身为避色。避痛痒为避五乐。避意为避念避法。不堕愿业治生。是名为四意念断也。识苦者本为苦。为苦者为有身。从苦为因缘。起者所见万物。苦习者本为苦。从苦为因缘生。尽者万物皆当败坏。为增苦习。复当为堕八道中。道人当念是八道。是名为四为四收苦。得四神足念也。信佛意喜。是名为信根。为自守行法。从谛身意受。是名能根为精进。从谛念遂谛。是名识根为守意。从谛一意。从谛一意止。是名定根为正意。从谛观谛。是名黠根为道意。是名为五根也

从谛信不复疑。是名信力。弃贪行道从谛自精进。恶意不能败精进。是名进力。恶意欲起当即时灭。从谛是意无有能坏意。是名念力。内外观从谛以定。恶意不能坏善意。是名定力。念四禅从谛得黠。恶意不能坏黠意。是名黠力。念出入尽复生。是名为五力也。从谛念谛是名为觉意得道意。从谛观谛是名法名法识觉意。得生死意。从谛身意持是名力觉意。持道不失为力。从谛足喜谛是名爱觉意。贪道法行道行道法。从谛意得休息。是名息意觉已息安隐。从谛一念意。是名定觉意。自知意以安定从谛自在意在所行从观。是名守意觉。从四谛观意。是名为七觉意也。从谛守谛。是名直信道。从谛直从行谛。是为直从行念道。从谛身意持。是名直治法。不欲堕四恶者。谓四颠倒。从谛念谛。是名直意不乱意。从谛一心意。是名直定。为一心上头。为三法意行。俱行以声身心。如是佛弟子八行。是名四禅。为四意断也。第一行为直念属心常念道。第二行为直语属口断四意。第三行为直观属身观身内外。第四行为直见信道。第五行为直。行不随四恶。谓四颠倒。第六行为直治断余意。第七行为直不堕贪欲。第八行为直定正心。是为八行。佛辟支佛阿罗汉所不行也。第一行为直念。何等为直念。谓不念万物意不堕是中。是为直念。念万物意堕中为不直念也。四意止者。一意止为身念息。二意止为念痛痒。三意止为念意息出入。四意止为念法因缘。是为四意止也

道人当念是四意止。一者为我前世爱身故不得脱。二者今有剧怨家。何以故。所欲者爱生。当断已断。为外身观止也。四意止者。意止者意不在身为止意。不在痛痒为止意。不在意为止意。不在法为止意。随色诚便生。是为不止也。问人何以故。不堕四意止。报用不念苦空非身不净故。不堕四意止。若人意常念苦空非身不净行道者。常念是四事不离。便疾得四意止也。问何等为身意止。谓念老病死是为身意止。何等为痛痒意止。谓所不可意是为痛痒意止。何等为意意止。谓已念复念是为意意止。何等为法意止。谓往时为行还报为法。亦谓作是得是。是为法意止也。四意止有四辈。一者念非常意止。二者念苦身意止。三者念空有意止。四者念不净乐意止。是为四意止。一切天下事皆堕身痛痒。堕法都卢不过是四事也。四意止者。一者但念息不邪念。二者但念善不念恶。三者自念身非我所万物皆非我所。便不复向。四者眼不视色意在法中。是名为四意止也。道人当行四意止。一者眼色。当校计身中恶露。二者意欢喜念乐。当念痛痒苦。三者我意嗔他人意亦嗔。我意转他人意亦转。便不复转意。四意者我意嫉他人意亦嫉。我念他人恶他人亦念我恶。便不复念是为法也。身意止者自观身观他人身。何等为身。欲言痛痒是身。痛无有数。欲言意是身。复非身有过去意未来意。欲言法是身复非身有过去未来法。欲言行是身。行无有形知为非身。得是计为四意止也。意不堕色念识亦不生。耳鼻口身亦尔。意不在身为心意不在痛痒。意不在念意不在法为心也。问谁主知身意痛痒者。报有身身意知。痛痒痛痒意知。意意意意知有饥饥意知。有渴渴意知。有寒寒意知。有热热意知。以是分别知也。身意起身意。痛痒意起痛痒意。意意起意意。法意起法意。四意止谓意念恶制使不起。是为止也。四意止亦随四禅。亦随四意止。随四意止为近道。不着恶便善意生。四禅为四意定为止意也。行道有四因缘。一止身。二止痛痒。三止意。四止法。止身者。谓见色念不净。止痛痒者。谓不自贡高。止意者。谓止不嗔恚。止法者。谓不疑道人行四意止。意起念生即时识对行药。得一意止。便得四意止也。四意定。一者自观身亦复观他人身。二者自观痛痒亦复观他人痛痒。三者自观心亦复观他人心。四者自观法因缘亦复观他人法因缘。如是身一切观内外因缘成败之事。当念我身。亦当成败。如是是为四意定也。人欲止四意弃为外摄为内。已摄意为外弃为内也。观他人身。谓自观身不离他。便为观他人身苦。观他人身为非痛痒意法亦尔也。自贪身当观他人身。念他人身。便自观身。如是为意止。问意见行何以为止。报意以自观身贪。便使观他人身。为意从贪转故应止。若意贪他人身。当还自观身也

有时自身观。不观他人身。有时当观他人身。不当自观身。有时可自观身。亦可观他人身。有时不可自观身。亦不可观他人身。自观身者为校计观他人身。意不止须自念身为着便转着他人身。观他人身为见色肥白黛眉赤唇。见肥当念死人胀。见白当念死人骨。见眉黑当念死人正黑。见朱唇当念血正赤。校计身诸所有。以得是意便转。不复爱身也。观有内外。嫉恚疑当内观。贪淫当外观。贪当念非常败。淫当念对所有恶露。如自观身淫当念四断意也。观有两辈。一者观外。二者观内。观身有三十六物。一切有对皆属外观无所有为道。是为内观也。观有三事。一者观身四色。谓黑青赤白。二者观生死。三者观九道。观白见黑为不净。当前闻以学。后得道未得道为闻得别为证得为知也。观有四一者身观。二者意观。三者行观。四者道观。是为四观。譬如人守物盗来便舍物。视盗人已得观。便舍身观物也

观有二事。一者观外诸所有色。二者观内谓无所有。观空已得四禅。观空无所有。有意无意无所有。是为空。亦谓四弃得四禅也。欲断世间事当行四意止。欲除四意止当行四意断。人堕贪贪故。行四神足飞。但有五根无有五力不能制。但有五力无有五根不生得四神足。尚转五力。能制上次十二品四意断。不作现在罪但毕故罪。是为四意断也。毕故不受新为四意止。故毕新止为四意断。故竟新断为四神足。知足不复求守意。意为毕。生为新老为故。死为身体坏败为尽也。四意断。谓常念道。善念生便恶念断故。为断息道。善念止便恶念生故。为不断也。四意断者。意自不欲向恶是为断。亦谓不念罪断也。四神足。一者身神足。二者口神足。三者意神足。四者道神足。念飞念不欲灭不随道也。四伊提钵。四为数伊提为止钵为神足。欲飞便飞。有时精进坐七日便得。或七日或七岁也。得神足可久在世间。不死有药。一者意不转。二者信。三者念。四者有谛。五者有黠。是为神足药也。得四神足不久在世间有三因缘。一者自厌其身臭恶故去。二者无有人能从受经道故去。三者恐怨恶人诽谤得罪故去也。神足九辈。谓乘车马步疾走亦为神足。外戒坚亦为神足。至诚亦为神足。忍辱亦为神足也。行神足当飞意。问何为飞意。报有四因缘。一者信。二者精进。三者定。四者不转意。何等为信。信飞行。何等为精进。飞行。何等定。飞行。何等为不转意。谓着飞行不转意也。身不欲行道。意欲行便行。神足如是意欲飞即能飞也。五根譬如种物坚乃生根不坚无有根。信为水雨。不转意为力。所见万物为根。制意为力也。信根中有三阴。一为痛痒。二为思想。三为识阴。定根中有一阴。谓识阴也

五根五力七觉意。中有一阴者。中有二阴者。中有三阴者。有四阴者。皆有阴。问是道行何缘有阴。报以泥洹无阴。余皆有阴也。七觉意上三觉属口。中三觉属身。下一觉属意。何等为觉。念念为觉。念念为得。觉得是意便随道也。外七觉意为堕生死内。七觉意为随道。内七觉意者。谓三十七品经。外七觉意者。谓万物也。觉者为识事。便随觉意也。有觉意便随道。觉有觉意堕罪觉。三十七品经便正意是为随道。觉善恶是为堕罪也。问何等为从谛身意持。报谓。身持七戒意持三戒。是为身意持也。从谛意得休息。从四谛意因缘休。休者为止息为思。得道为受思也。贪乐道法当行道为爱觉意。持道不失为力觉意。已得十息身安隐为息觉意。自知已安为定觉意。身意持意不走为持。从谛自在意在所行。谓得四谛。亦可念四意止。亦可四意断。亦可四神足。亦可五根五力七觉意八行。是为自在意。在所行从谛观者。为三十七品经要。是为守意觉者。谓谛不复受罪也。八行有内外。身为杀盗淫。声为两舌恶口妄言绮语。意为嫉妒痴。是上头三法。为十事在外五道在内也。从谛守谛从为神守。为护谓法不犯罪。谛为道。知非常苦空非身不净为直见。非常人计为常。思苦为乐。空计为有。非身用作身。不净计为净。是为不直见也。何等为直见。信本因缘知从宿命有。是名为直见。何等为直治。分别思惟能到善意。是为直治。何等为直语。守善言不犯法如应受言。是名为直语也。何等为直业。身应行不犯行。是名为直业也。何等为直治。随得道者教戒行。是名为直治也。何等为直精进。行行无为昼夜不中止不舍方便。是名为直精进方便也。何等为直念。常向经戒。是名为直念。何等为直定。意不惑亦不舍行。是名为直定。如是行令贤者八业行具已行具足便行道也。八直有治有行行八直。乃得出要身不犯戒。是为直治。慧信忍辱是为行身。意持是名为直治。谓无所念为直。有所念为不直也。十二部经都皆堕三十七品经中。譬如万川四流皆归大海。三十七品经为外。思惟为内。思惟生道故为内。道人行道分别三十七品经。是为拜佛也。三十七品经亦堕世间亦堕道。讽经口说是为世间。意念是为应道。持戒为制身。禅为散意。行从愿愿亦从行。行道所向意不离。意至佛意不还也。亦有从次第行得道。亦有不从次行得道。谓行四意止断神足五根五力七觉意八行。是为从次第。畏世间恶身便一念从是得道。是为不从次第。道人能得三十七品行意。可不顺从数息相随止也。身口七事心意识各有十事。故为三十七品。四意止断神足属外。五根五力属内。七觉意八行得道也。泥洹有四十辈。谓三十七品经并三向。凡四十事皆为泥洹。问数息为泥洹非。报数息相随鼻头止意。有所著不为泥洹。泥洹为有不。报泥洹为无有。但为苦灭。一名意尽难泥洹为灭报但善恶灭耳。知行者。有时可行四意止。有时可行四意断。有时可行四神足。有时可行五根五力七觉意八行。谛者为知定乱。定为知行。乱为不知行也。问何以故。正有五根五力七觉意八行。报人有五根道有五根。人有五力道有五力。人有七使道有七觉意。行有八直应道八种。随病说药因缘相应。眼受色耳闻声鼻向香口欲味身贪细滑。是为五根。何以故名为根。已受当复生故名为根。不受色声香味细滑是为力。不堕七使为觉意。已八直为应道行。五根坚意。五力为不转意。七觉为正意。八行为直意也。问何等为善意。何等为道意。报谓。四意止断神足五根五力。是为善意。七觉意八行。是为道意。有道善有世间善。从四意止至五根五力。是为道善。不淫两舌恶口妄言绮语贪嗔痴。是为世间善。谛见者。知万物皆当灭。是为谛见。万物坏败身当死。以不用为忧。是为谛观。意横意走便责对得制。是为除罪。诸来恶不受为禅。一心内意十二事智慧。七为数。八为相随。九为止。十为观。十一为还。十二为净。是为内十二事。外复十二事。一为目。二为色。三为耳。四为声。五为鼻。六为香。七为口。八为味。九为身。十为细滑。十一为意。十二为受欲。是为外十二事也。术阇者为智。凡有三智。一者知无数世父母兄弟妻子。二者知无数世白黑长短。知他人心中所念。三者毒以断。是为三也。沙罗惰怠者为六通智。一为神足。二为彻听。三为知他人意。四为知本所从来。五为知往生何所。六为知索漏尽。是为六也

佛说大安般守意经卷下

此经按经首序及见经文。似是书者之错经注不分而连书者也。义当节而注之。然往往多有不可分处。故不敢擅节。以遗后贤焉


佛说大乘不思议神通境界经

    No. 843

佛说大乘不思议神通境界经卷上

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

如是我闻。一时世尊住法界光明菩萨宫。与大苾刍众五十万人俱。皆阿罗汉。诸漏已尽无余烦恼。安住寂静心善解脱慧善解脱。如大龙王所作已辨。舍诸重担得大善利。诸有结缚皆悉已尽。正智无碍诸心善寂神通具足。复有菩萨摩诃萨众。皆得不退转地一生补处。当得成就阿耨多罗三藐三菩提者。而悉安住无边如来神通变化。菩提加持无著妙行。一切众生广大爱乐。住正念慧入普遍智。具平等行。成就无量众功德聚。现证如来平等法门。转妙法轮。能善教授无边学众。已获一切白法功德。善知一切众生心意。了别众生诸根利钝。已到彼岸最上自在。成就圆满一切善法。诸佛事业皆悉成办。从他方界来集此会。其名曰普贤菩萨摩诃萨。普幢菩萨摩诃萨。普步菩萨摩诃萨。普信菩萨摩诃萨。普眼菩萨摩诃萨。普寤菩萨摩诃萨。普光菩萨摩诃萨。普香菩萨摩诃萨。普意音菩萨摩诃萨。普照菩萨摩诃萨。普念菩萨摩诃萨。普智幢菩萨摩诃萨。普缘观菩萨摩诃萨。法界普光菩萨摩诃萨。如是等万二千人俱。复有诸天子众。所谓智幢天子。普华幢天子。普光天子。珠髻天子。宝积摩尼峰天子。如是等一万天子众俱。是诸天子。皆悉已于过去佛所。种诸善根者。来习此会

尔时世尊即入普遍光明三摩地。从是三摩地出已。即放广大光明。普照三千大千世界。乃至十方一切佛刹普皆照曜。是时此诸世界所有一切众生。蒙光照者皆发阿耨多罗三藐三菩提心。已发心者皆悉安住不退转地

尔时十方世界一切佛刹。彼彼刹中诸佛世尊。所有近侍诸菩萨众。见此光已。各各白其佛言。世尊。今此光明普照世界。有何因缘是何神力。即时彼彼佛言。诸善男子。汝等当知。有世界名娑婆。佛号释迦牟尼如来应供正等正觉。与诸大菩萨众。而共集会。欲说不思议境界正法。以是因缘光明普照。尔时彼诸近侍佛者。各各白其佛言。世尊。我等今者。乐欲往彼娑婆世界。瞻礼恭敬释迦牟尼如来。随喜听受不思议境界正法。及欲见彼诸菩萨众。时彼如来。即各告诸近侍者言。汝等可往今正是时。随其所欲

尔时十方诸佛刹中。所有一切近侍佛者。即各以其菩萨通神。现诸变化。各与无数天龙夜叉乾闼婆等恭敬围绕。来诣释迦牟尼佛所。是诸菩萨到佛会已。头面殷勤礼世尊足。咸作是言。世尊释迦牟尼如来。我等闻其不思议境界正法名字。乐欲随喜听受宣说。及欲见佛世尊瞻礼恭敬。并见此诸菩萨大众。以是因缘。我等到此娑婆世界

尔时东方大宝世界。宝幢佛刹中。所住妙吉祥菩萨摩诃萨。即起是念。今彼西方娑婆世界。释迦牟尼佛刹中。有十方世界如殑伽沙数诸大菩萨摩诃萨众。皆悉集会。听彼佛说不思议境界正法。我今亦宜往彼会中。礼近世尊释迦牟尼如来。随喜听受彼正法门。及见彼诸菩萨大士。何以故。十方一切诸佛刹中。随其所有集会利益。我皆往彼无不往者。又复我常所见诸佛菩萨集会说法无如今日。彼佛刹中有如是等无量无边菩萨大士广大集会。我观是相甚为难有。若见若闻转复甚难。是故我今亦宜往彼。尔时妙吉祥菩萨作是念已。即谓慈氏菩萨摩诃萨言。慈氏当知。今世尊释迦牟尼佛刹中。有无数百千俱胝那庾多菩萨摩诃萨众广大集会。听受宣说不思议境界正法。我等今者宜共往彼瞻礼世尊。并见彼诸菩萨大士。何以故。十方世界诸大菩萨。普集一处甚为难事

尔时慈氏菩萨摩诃萨。告妙吉祥菩萨言。汝今自诣彼佛会中。非我所往。何以故。此甚难故。彼佛会中诸大菩萨。皆悉已得陀罗尼门。住无著智具诸善法。虽彼集会若见若闻。诸有相者我皆不能。妙吉祥。汝今当知。若以如来色身。有所见者实无可见。是故我今所不能见。若以如来法身有所见者。法身即是法性。于法性中无见无闻。无所供养无所瞻礼无所了知。妙吉祥菩萨言。汝今随顺往彼供养如来。慈氏菩萨言。不也妙吉祥。非我所供养如来。何以故。无有如来能供养者。如来即是真如法。真如法中无有二相。真如法者即是如来。妙吉祥菩萨问言。即此无二相。汝当云何说。慈氏答言。妙吉祥。烦恼一性及种种性。此说为二。若了一性即种种是无二法。若起分别此是烦恼此出世间。作是见者即为二相。又若分别此是持戒此非持戒。此声闻法此缘觉法。此是布施此非布施。此是正道此是邪道。此是须陀洹斯陀含阿那含阿罗汉。此是缘觉此是菩萨。此是如来应供正等正觉。此法断灭此法有想。此法决定此不决定。此法是智所知。此法为识所识。此证觉道此涅盘道。作如是等有分别者。皆为二相。于二相中随识所转。若能不起如是等相。是无二法。妙吉祥。若我以劫或以劫尽。说是无二法。假使辩才智慧说不能尽。亦复不能知其边际。何以故。彼一切法离种种性。若中若边皆不可见亦不可得。妙吉祥菩萨言。大哉慈氏。汝已证得无生法忍。故作是说。如是如是。假使若我以劫或以劫尽。说是无二法。亦非辩才智慧说所能尽。慈氏菩萨言。妙吉祥。莫于文字而生有想。彼一切法离诸文字。是无生相亦无所动

尔时妙吉祥菩萨。普告彼佛刹中诸菩萨言。善男子。汝等今者宜共往彼世尊释迦牟尼佛刹中瞻礼彼佛。及见百千俱胝那庾多诸菩萨众。随喜听受不思议境界正法

尔时有菩萨名辩积幢王。白妙吉祥菩萨言。如来无有可能见者。何故今言令我等往见佛如来。何等如来是可见者复以何义说名如来。何以故。如来非过去未来现在可得。彼一切法亦非三世皆悉空故。于空法中无能见者。如妙吉祥菩萨所言。如来有所见者。今云何见彼佛如来。为以何眼可观察耶。若以肉眼而能观者。肉眼即空。于空性中而无所见。若以天眼观如来者。天眼亦复是有得想。若非眼所观何名为见。是故我等今不能往。妙吉祥菩萨言。善男子。汝今若住不平等法。作是说者。于佛如来。即不能见亦非供养。汝今若住无所著相如实说者。于佛如来即有所见。亦有所往亦可供养。不着一切文字相故。亦复不离诸文字相。彼自性空。是故我于平等法中。作如是说。诸佛如来本清净故。如来亦复无所动转。汝等今者若住忍意应当往彼。若住非忍意亦当往彼。是时妙吉祥菩萨如是重复为诸菩萨方便宣说。彼菩萨众。以佛威神力故。即于诸法得无所住

尔时妙吉祥菩萨。复作是念。我今不应而独往彼娑婆世界。何以故。彼世界中。所有众生造不善业。少见少闻不生净信。我今当现种种色相及希有事而可往彼。令诸众生见已生信得未曾有。使其获得广大善利。即时妙吉祥菩萨作是念已。入于无垢普光三摩地。于是三摩地中。见无数百千菩萨摩诃萨而共围绕。所有大梵天王帝释天主。各执宝拂侍立左右。是时妙吉祥菩萨于一一毛孔中。出天莲华大如车轮。一一华中。有佛世尊结加趺坐。一一世尊执宝莲华。是时三千大千世界。所有众生得大快乐。妙吉祥菩萨即时普见一切众生。彼诸众生亦同得见妙吉祥菩萨。皆悉不退转于阿耨多罗三藐三菩提心

尔时妙吉祥菩萨见是相已出三摩地。从彼东方大宝佛刹。来此娑婆世界。随所经历诸佛刹土。悉现如是神通变化。普令一切获大利益。于其种种佛刹。皆见如来执宝莲华。各各为彼众生说法。或见佛刹。地狱众生现受苦者。佛为救度皆得离苦。及彼畜生饿鬼等趣互相食啖。极苦恼者亦皆离苦。乃至阎魔界中。现受一切苦恼众生。见佛各为如应说法。是诸众生。一一皆得远离苦恼。各各发趣阿耨多罗三藐三菩提心。有佛刹中。或见如来广为一切阿修罗众如应说法。各各得转阿修罗身。有佛刹中。或见如来住妙吉祥神通境界。为诸刹帝利大族婆罗门大族长者大族。如应说法各获利益。或为四大王天诸天子众如应说法。谓诸天子言。汝等当知。彼一切行皆悉无常。勿起意念谓究竟法。闻是法者皆获利益。有佛刹中。或见如来住妙吉祥神通境界。为三十三天帝释天主等诸天子众如应说法。亦复谓言。诸行无常非究竟法。诸有智者当如实知。不应于中作究竟想。闻是法者皆获利益。有佛刹中。或见如来住妙吉祥神通境界。为夜摩天诸天子众。知足天中诸天子众。化乐天中诸天子众。他化自在天中诸天子众。梵众天中诸天子众。梵辅天中诸天子众。大梵王天诸天子众。如是乃至色究竟天诸天子众。各各如应为其说法。闻所说法皆获利益。或见如来住妙吉祥神通境界。为诸初地菩萨摩诃萨众如应说法。或为二地。或为三地。或为四地。或为五地。或为六地。或为七地。或为八地。或为九地。或为十地诸大菩萨摩诃萨众。或为一生补处。当得成就阿耨多罗三藐三菩提者。各各如应说法。要使令增进住不退转。乃至普令圆满安住大涅盘界

尔时妙吉祥菩萨现如是等种种神变。随所经历诸佛刹土。一切众生见是相者。皆悉发于阿耨多罗三藐三菩提心。五百苾刍得诸漏尽心善解脱。八千菩萨得无生法忍。十千天子远离尘垢得法眼净。即时所得利益诸菩萨等。异口同音说伽陀曰

  见是神通变化事　　一切具足未曾有
  妙吉祥尊境界中　　一切众生得利益

尔时十方诸佛刹中。已来集会诸菩萨众。各各以神通力。见如是等大希有事。俱白世尊释迦牟尼佛言。今此三千大千世界光明普照。及希有事。是何神力所变化故。愿佛世尊为我等说

佛告诸菩萨摩诃萨言。善男子。汝等当知。有菩萨大士名妙吉祥。住不退转已得灌顶。从东方来欲入此会。是彼神通现斯瑞应。又善男子。若人得闻彼妙吉祥名字者。皆悉住于不退转心。况复得见甚为难事。是时世尊释迦牟尼佛为诸菩萨摩诃萨作是说时。彼妙吉祥菩萨即以神通来入佛会。到佛会已头面着地。礼世尊足。前前白佛。世尊释迦牟尼佛。少病少恼轻利调适得快乐不。我从东方大宝世界宝幢佛刹来此会中。礼近世尊听说正法

尔时普华幢天子在大会中。从座而起前白佛言。世尊。诸菩萨摩诃萨当修何法即得成就如妙吉祥神通事业最胜甚深辩才智慧

佛告普华幢天子言。若菩萨摩诃萨乐欲成就如是神通胜事业者。应当具足四种法门。何等为四。一者于甚深法随喜听受。二者广为他人说甚深法。三者随所闻法请问其义。四者闻已信解如理修行。是为四种。复有四法。应当具足。何等为四。一者于佛如来所说经法总持决定。二者于诸经法爱乐修习。三者于诸经法记念不忘。四者于诸经法广说流通。是为四种。复有四法。应当具足。何等为四。一者于正法门谛实听受。二者于说法师生尊重想。三者于持法人恭敬承事不生懈退。四者于说法师常所称赞长时无倦。是为四种。复有四法。应当具足。何等为四。所谓四心常当发起。一者平等心。二者柔软心。三者无懈心。四者无毒心。是为四种。若菩萨摩诃萨于如是等四种法门。随所修习。即得如是神通变化最胜事业。复能成就智慧辩才

尔时世尊说是四种法门时。五千菩萨得无生法忍。四千天子远离尘垢得法眼净。是诸菩萨及天子众得所利已。咸作是言。普愿众生。皆得安住诸佛境界。于正法门深生信解。所闻正法记念受持。于未来世得大神通如妙吉祥。于诸佛刹变化自在

尔时普华幢天子。白妙吉祥菩萨言。菩萨从何所来至此佛会。所住佛刹其名何等。化主如来复何名字。时妙吉祥菩萨。告普华幢天子言。莫作是说。有所从来。何以故。天子当知。法界无来亦无所去。复无所行而无所住。一切无著。彼法界性。无所疑惑离诸戏论。天子。若言有来有去有所住者。是戏论法

尔时普华幢天子。及诸大众。闻妙吉祥菩萨说是法已。即时各各叹未曾有。异口同音说伽陀曰

  最上希有妙吉祥　　从佛世尊所出生
  具足神通诸法门　　闻者见者得利益
  大士今现此诸相　　宣说甚深微妙法
  我皆随喜得见闻　　咸于今日获大利
  我等昔闻大名士　　今见神通妙色相
  菩萨是大法光明　　出现一切诸佛法
  已能圆满一切行　　惭愧上服所庄严
  自利利他妙吉祥　　最胜功德难思议
  菩萨犹如世间父　　普摄一切为所归
  开示涅盘方便门　　咸令众生到彼岸
  菩萨犹如大师子　　一音能破诸外论
  正法功德悉已圆　　一切染法皆清净
  菩萨犹如世间地　　普能出生诸善法
  复为最上大医王　　能救众生诸病苦
  菩萨如月大清凉　　令诸热恼皆清净
  复如日光大炽盛　　广照一切三摩地
  菩萨大利大导师　　引示众生菩提道
  常生广大慈愍心　　救度恶趣众生苦
  菩萨常为所依怙　　了别一切众生心
  一切智智妙法门　　普施众生令解脱

尔时世尊告普华幢天子及诸大众言。如是如是如汝所言。妙吉祥菩萨有是功德

佛说大乘不思议神通境界经卷上佛说大乘不思议神通境界经卷中

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

尔时普华幢天子复白佛言。世尊。今此妙吉祥菩萨摩诃萨发菩提心为久近耶。佛言天子。此妙吉祥菩萨过于无量无边殑伽沙数劫。已发菩提心。天子。我今为汝及诸大众。略说其一。是时普华幢天子白佛言。世尊。愿为我等一切众会。如理宣说。佛言天子。过去度如微尘数劫。尔时此娑婆世界。有佛名普观清净音王如来应供正等正觉。出现于世。彼佛法中。有一苾刍名清净音。于彼法中出家修道得五神通。时彼苾刍。于四万二千岁中。以种种香华灯涂及众妙具。供养彼佛。种是善根。发于阿耨多罗三藐三菩提心。天子。于汝意云何。彼时清净音苾刍岂异人乎。即今妙吉祥菩萨摩诃萨是。汝等当知。此妙吉祥菩萨已于无量无边殑伽沙数佛世尊所。发菩提心。已度殑伽沙数众生。令住须陀洹斯陀含阿那含阿罗汉果。已度殑伽沙数众生。令住缘觉果。已度殑伽沙数众生。令住初地。乃至已度殑伽沙数众生。令住十地。妙吉祥菩萨如是广大种诸善根成就善法

复次天子。假使有人。满三千大千世界七宝布施如来。是人所获功德其数甚多。若复有人。闻此妙吉祥菩萨名字。恭敬受持乃至随喜称念者。当知是人福多于彼。又复天子。若三千大千世界所有众生。一一皆得须陀洹乃至阿罗汉果。是人得福甚多。若复有人。闻此妙吉祥菩萨名字。能受持者福多于彼。又若三千大千世界所有众生。一一皆悉得缘觉果。是人得福甚多。若复有人。闻此妙吉祥菩萨名字。能受持者福多于彼。何以故。若有人称赞受持诸佛名字。若复有人。称赞受持妙吉祥菩萨名字。如是二人所获功德等无有异

尔时普华幢天子。闻佛世尊作是说已。即与四万天子。合掌恭敬作如是言。善哉妙吉祥菩萨。甚善甚善。我等志诚归命顶礼。彼诸天子发是言时。其声普遍三千大千世界。皆悉遥闻

尔时尊者大目干连闻是声已。来诣佛所前白佛言世尊。今此三千大千世界。皆得普闻赞叹音声。是何神力。现此希有不思议事

佛告大目干连言。汝今当知。是妙吉祥菩萨摩诃萨已住不退转。被大铠甲。最胜大士在此会中。诸天子等称赞彼名。是故音声普闻三千大千世界。大目干连。若有人随其方处。称赞受持此妙吉祥菩萨名字者。即时三千大千世界普皆震动

是时尊者大目干连复白佛言。希有世尊。此菩萨摩诃萨成就如是不思议事。被大铠甲勇猛精进。成熟有情具诸佛法。世尊。若人以少善根。不能如是圆满具足大菩萨法

尔时世尊为大目干连说是法时。忽然出现大宝莲华。遍满娑婆世界。一一莲华大如车轮。其华各有种种色香。诸妙宝网以为庄严。于其华中有一莲华。而最出现高显妙好。一切众会皆悉睹见

尔时尊者阿难见其莲华殊妙庄严忽然出现。即白佛言世尊。云何此会先有是相。佛言阿难。汝今当观。不久即有六万菩萨摩诃萨众。从普遍光明世界吉祥德王佛刹中。而来此会。各各处其宝莲华上。结加趺坐。彼一莲华最高显者。当有菩萨名遍照藏。处其华上加趺而坐。是诸菩萨欲现空中故。先示此宝莲华相

尔时会中诸菩萨等。一切大众。咸共称赞得未曾有。各各合掌向空顶礼。是时于虚空中有梵王帝释。执宝莲华。围绕遍照藏菩萨摩诃萨。而此菩萨与诸大士。即时各各踊身虚空。高七多罗树。一切众会皆悉睹见。时诸菩萨于其空中雨众宝华。种种色香殊妙第一。以供养佛。华供养已。于虚空中出如是声。世尊。吉祥德王如来应供正等正觉。问讯世尊释迦牟尼如来。少病少恼轻利调适。得大快乐气力安不。吉祥德王如来如是置问。今遍照藏菩萨摩诃萨等。六万菩萨同来至此。礼近世尊。随喜听受不思议境界正法。尔时空中出是声已。遍照藏菩萨摩诃萨。及诸菩萨。即时各各从空而下。头面着地礼佛足已。住立佛前

尔时世尊知是事已。故复问言。遍照藏菩萨摩诃萨等。诸善男子。汝等今者何故至此。遍照藏菩萨白佛言。世尊。我等于普遍光明世界吉祥德王佛刹中。闻此娑婆世界世尊释迦牟尼如来。与诸菩萨大士而共集会。宣说不思议境界正法。我等欲见世尊及闻正法。以是因缘故来至此

尔时尊者大迦叶在大会中前白佛言。世尊。普遍光明世界。吉祥德王佛刹。去此佛刹而不远耶。何故。此诸大士。于少时间速能至此。遍照藏菩萨。谓大迦叶言。尊者。汝若以自神通定力。往彼世界。至寿量尽。亦未能到。是故当知。彼佛世界如是远近

尔时佛告大迦叶言。去此世界。度如六十殑伽沙数佛刹。即到普遍光明世界。此诸菩萨以其最胜大神通力。速能至此。是时尊者大迦叶白佛言。世尊。我今乐欲往彼世界。遍照藏菩萨。即问尊者大迦叶言。尊者云何。于来去想有所动转。迦叶。汝于何法见有来去。汝谓色法有来去耶。受想行识有来去耶。大迦叶答言。善男子。色无来去。受想行识亦无来去。于定心中示来去相。若住定心即诸色不见。色无见故即不能得彼来去相。善男子。若住定心即得胜义法门

复次善男子。汝诸菩萨来此久耶。遍照藏答言。我来久近。如汝尊者所得漏尽证心解脱。大迦叶言。希有大士。得大神通。遍照藏言。即汝尊者。得心解脱亦云何久。大迦叶言。解脱已久。遍照藏言。如汝尊者得心解脱。当以何义说名为心。大迦叶言。汝善男子。亦云何说。遍照藏言。心有所缚何名解脱。大迦叶言。若如是者。汝善男子。有缚于心不名解脱。亦复不名解脱知见。遍照藏言。尊者大迦叶。心本无缚其何解脱。大迦叶言。若于无缚如实了知是即解脱。遍照藏言。尊者大迦叶。为用何心而了知耶。过去耶未来耶现在耶。若过去心彼已灭尽。若未来心当亦未至。若现在心今即无住。离此三世。复以何心而了知耶。大迦叶言。善男子。心法灭处非彼心分。遍照藏言。尊者大迦叶。即此心灭处而可了知耶。大迦叶言。若心灭处即不能知。遍照藏言。彼一切法皆如心灭。是故不能有所了知。大迦叶言。汝善男子。得大辩才随问能答。我今不能有是辩才。遍照藏言。尊者大迦叶。于汝意云何。所有辩才。若见若闻为有得耶。大迦叶言。无得无闻。何以故。缘生性故。遍照藏言。岂非一切法皆同如是耶。大迦叶言。善男子。诸法亦如是。遍照藏言。尊者大迦叶。于汝意云何。若见若闻。于其辩才能无断耶。大迦叶言。不坏亦不断。遍照藏言。尊者大迦叶。如是如是。菩萨辩才。随有所问而不断坏。迦叶当知。诸菩萨摩诃萨纵经劫数随问能答。所有辩才亦不断坏

尔时遍照藏菩萨。及尊者大迦叶。说是法时。五十万众生。皆发阿耨多罗三藐三菩提心。二百菩萨。得无生法忍

尔时尊者大迦叶白佛言。世尊。劝请世尊。为妙吉祥菩萨及大会众。如应说法。使其长夜得大利乐。而能决定证诸法性

尔时有菩萨名曰辩积。在大会中从座而起。白妙吉祥菩萨言。妙吉祥云何。尊者大迦叶。于法精进能善宣说。妙吉祥言。此大迦叶。于声闻法中已得无畏。辩积菩萨言。此大迦叶。云何不住大乘法中。妙吉祥言。善男子。此大迦叶。亦非不能住大乘法。为于声闻法中得解脱故。辩积菩萨言。妙吉祥。云何名为声闻法。妙吉祥言。世尊释迦牟尼如来。于此娑婆世界。为诸众生说三乘法。何等为三。所谓声闻乘。缘觉乘。大乘。是名三乘。何以故。有诸众生。起劣精进而求解脱故。佛方便开示三乘。辩积菩萨言。妙吉祥。云何如来广说无量空解脱门。无相解脱门。无愿解脱门。妙吉祥言。善男子。如来以善方便。宣说无量空无相无愿解脱法门。令诸众生如理修行

尔时妙吉祥菩萨。为辩积菩萨。说是法时。会中所有天龙夜叉乾闼婆等。即时各各合掌恭敬。异口同音说伽陀曰

  所有一切供养具　　宝衣宝器众庄严
  妙吉祥尊所严身　　我今称赞功德聚

尔时普华幢天子复白佛言。世尊。此妙吉祥菩萨摩诃萨。最初于何佛世尊所。发菩提心。佛告普华幢天子言。汝今当知。过去度如殑伽沙数劫前。彼时有世界。名金焰光明。有佛出世。号无垢日焰光明如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。十号具足。天子。彼佛寿量九百九十万俱胝那庾多数。为诸众生说三乘法。所谓声闻乘。缘觉乘。菩萨乘。时彼如来。初会说法。有八百四十万俱胝那庾多众生。住声闻乘得阿罗汉。诸漏已尽舍诸重担得大善利。诸有结缚皆悉已尽。正智无碍心善解脱。第二会说法时。有七十万俱胝那庾多苾刍。得阿罗汉。第三会说法时。有六百五十万俱胝那庾多苾刍。得阿罗汉。彼佛法中。二分苾刍苾刍尼优婆塞优婆夷众。二分菩萨摩诃萨众。彼诸菩萨一切皆是不退转者。皆悉证得无生法忍。普入无边三摩地门。圆满善法。复得无边陀罗尼门。如来为说不退转法轮。况复彼诸初发大乘心者。其数无量。是中亦有无量众生住缘觉者。天子。彼无垢日焰光明如来。以其无量无数相应行法。普摄众生。时彼金焰光明世界。多以黄金而用庄严。诸有楼阁殿堂众宝为柱。一切树林皆宝严饰。于其树间出妙音声。称赞甚深不思议法。所谓空声无相声无愿声。无性声无著声。无生声无起声。出如是等赞诸法声。其所出声一切众生闻者爱乐。彼佛灭后。正法住世满一千岁。天子。时彼金焰光明世界中。有转轮王名最胜辩才。为四洲主。是时彼王。于无垢日焰光明佛刹中。以其饮食衣服卧具幢幡宝盖诸妙供具。供养彼佛。及其佛刹所有一切声闻缘觉大菩萨众。如是供养满一俱胝岁。于彼佛所深种善根。彼转轮王种是善根时。即有八万四千众生。及王宫中有三百二十万后妃眷属。同发阿耨多罗三藐三菩提心。天子。彼最胜辩才转轮圣王。有其千子。先于声闻法中发生信解。后复发于阿耨多罗三藐三菩提心。证得无生法忍。尔时彼王有女。名曰大慧。具大辩才甚深信解。是时大慧。与七千二百宫女眷属。恭敬围绕。诣彼无垢日焰光明佛所。到佛所已。与诸眷属头面着地。礼彼佛足。时大慧女。以善根故。即发阿耨多罗三藐三菩提心。既发心已前白佛言。世尊。我欲趣求阿耨多罗三藐三菩提果。然我今者不能以此女人色相而取证彼阿耨多罗三藐三菩提。唯愿世尊。为我开示。有何法门如理修行。令我当得转女人身成男子相。速能取证阿耨多罗三藐三菩提果

尔时无垢日焰光明如来。即告大慧女言。汝善女人。当有一法。能具足者。即得转女人身成男子相。何等为一。所谓发起大菩提心。无等等心。一切三界最胜上心。乃至一切声闻缘觉起随顺心。复有一法。若具足者。即得转女人身成男子相。何等为一。所谓于诸如来。常所作意而不远离。听受正法无所厌倦。大慧。复有十法。若具足者。即得转女人身成男子相。何等为十。所谓十善业道。应当圆满。即得慈行成就。又复长时。受学无懈。听法无懈。亲近法师亦复无懈。若能圆满如是等法。即得转女人身成男子相

尔时彼佛说是法时。其大慧女。即于同来诸眷属前。转彼女身得成男子。即时大慧童子合掌恭敬前白佛言。世尊。我今已转女身。于佛法中乐欲出家。持苾刍戒。愿佛摄受。尔时彼佛。即告大慧童子言。善来苾刍。是时大慧。于刹那间须发自落。袈裟被身成苾刍相。威仪庠序如百腊者。即于会中。证得无生法忍。是时彼王所有诸子知是事已。生希有心。来入佛会皆求出家。佛即摄受。各各如应为说法要。尔时大慧苾刍。告诸王子言。我于今者得最上利。永不复起声闻之见。决定趣求阿耨多罗三藐三菩提果。修大悲行利益众生。汝等有发声闻心者。亦应如我发趣最上大菩提心。当于正中正道起修行想。时大慧苾刍。为诸王子如应说法。皆得不退转于阿耨多罗三藐三菩提

尔时世尊释迦牟尼佛。告普华幢天子言。彼无垢日焰光明佛刹中。最胜辩才转轮圣王。大慧童女者岂异人乎。即今妙吉祥菩萨摩诃萨是。彼王所有千童子众。今已成就阿耨多罗三藐三菩提果。现住说法教化众生。即千佛是。所谓

东方超过行如来。无边光明如来。普光如来。吉祥主如来。实相如来。宝上如来。宝明如来。宝幢如来。宝照明如来

南方最极高如来。大光明如来。无量寿如来。无量声如来。大名称如来。无边名称如来。宝光如来。清净无边寿如来。月相如来。月光如来。

西方无垢明如来。清净光如来。日明如来。无边宝最上如来。梵高如来。金色光明如来。梵自在王如来。龙自在王如来。一切宝华自在王如来。娑罗树王如来

北方坚固勇猛如来。离尘如来。吉祥藏光如来。无量香光如来。师子音王如来。大势力精进出生如来。妙高步如来。大宝聚如来。不退转轮如来。宝句义吉祥如来。普遍大日如来。胜得如来。如是等诸佛如来。种种名字。现在十方世界。说法教化众生

佛告普华幢天子言。如汝所问。此妙吉祥菩萨摩诃萨。于彼金焰光明世界无垢日焰光明佛所。最初发于阿耨多罗三藐三菩提心

佛说大乘不思议神通境界经卷中佛说大乘不思议神通境界经卷下

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

佛告天子。此妙吉祥菩萨从是已后。复于七十二殑伽沙数佛世尊所发菩提心。最初有佛。名尸邻捺啰王如来应供正等正觉。出现世间。于彼佛所发菩提心。其后有佛。名宝光行吉祥。出现世间。其后有佛。名莲华上变化吉祥。出现世间。其后有佛。名清净宝吉祥。出现世间。其后有佛。名无边宝吉祥。出现世间。其后有佛。名大宝吉祥。出现世间。其后有佛。名虚空灯。出现世间。其后有佛。名大法王。出现世间。其后有佛。名众宝聚持妙色相。出现世间。其后有佛。名能仁主出现世间。其后有佛。名功德光明庄严吉祥。出现世间。其后有佛。名大光吉祥。出现世间。其后有佛。名无量光广大庄严。出现世间。其后有佛。名作变化云千音声王。出现世间。其后有佛。名最上日光吉祥。出现世间。其后有佛。名最上意。出现世间。其后有佛。名多种光明吉祥王。出现世间。如是等七十二殑伽沙数佛世尊所。发菩提心已。复于九十一劫中。值遇诸佛发菩提心。又复于火顶如来。众尊如来。作庄严如来。饮光如来。是诸如来所。皆发菩提心种诸善根。天子。此妙吉祥菩萨。能于如是无量无数佛世尊所。发菩提心。广大方便。种诸善根已。乃至最后于我现在如来应供正等正觉所。以神通变化作诸佛事

尔时普华幢天子前白佛言。世尊。一切众生欲种善根。若能于此广大正法。发信解心。听受读诵记念思惟。为人演说。当知是人。善得人身。善见诸佛。善闻正法。于其世间有所利益不空受食。世尊。而诸众生。云何当能于此正法发生信解

佛告普华幢天子言。汝今宜应以如是事问妙吉祥菩萨。彼当为汝如理宣说。是时普华幢天子。即白妙吉祥菩萨言。云何当得一切众生。于此正法能生信解。妙吉祥菩萨言。天子。无有法可生信解。彼一切法自性空故。无所生故。若法自性空无所生。当复于何而生信解

普华幢天子。复白妙吉祥菩萨言。愿为我等略说菩萨行法。妙吉祥言。天子当知。无行是菩萨行。又复一切法是菩萨行。普华幢天子言。云何一切法是菩萨行。妙吉祥菩萨言。天子当知。所言一切法者。谓四念处八正道五根五力七觉支。略说此等为菩萨行。若广说者其数无量。诸菩萨摩诃萨若得此法。是即名为真菩萨行。普华幢天子。白妙吉祥菩萨言。云何名为四念处。妙吉祥言。天子。若菩萨观身如虚空。不得身相。住平等法。如是名为身中身念处。若菩萨观诸受法内外中间俱不可得。皆悉空故。如是名为观受念处。若菩萨如实观心。于其名中无色可见。即不可得所观心相。如是名为心中心念处。若菩萨如实了知彼一切法。若善不善自性皆空。如是名为法中法念处。天子。此等名为四念处法

复次普华幢天子。白妙吉祥菩萨言。云何名为八正道法。妙吉祥菩萨言。若菩萨观一切法。非境界相。无二无分别。无少法可取。是名正见。若菩萨观一切法。离诸分别及诸疑惑。与无所观正行相应。是名正思惟。若菩萨观一切法自性真实。非有边非无边。皆悉平等。如实宣说。是名正语。若菩萨观一切法。离所作性而不可得。若如所作若非所作。皆悉平等。住如实义。是名正业。若菩萨知一切法本不相续。即于诸法无嗔无喜。亦无所著。安住真实平等法中。是名正命。若菩萨了一切法。无诸起作离种种相。于精进行如实相应。是名正精进。若菩萨于一切法不起诸念。了知诸业自性清净。住无所念。是名正念。若菩萨入一切法自性平等。于所缘相皆悉远离。毕竟观察了不可得。是名正定。天子。此等名为八正道法

复次普华幢天子。白妙吉祥菩萨言。云何名为五根。妙吉祥言。若菩萨了一切法本无所生。自性真实无进无退。平等法中如实信解。是名信根。若菩萨。于一切法心无爱乐。离远近想住真实性。是名精进根。若菩萨。于一切法非所作意。以所缘相离种种性。由性离故诸念不生。是名念根。若菩萨。于一切法。无所念无所得。正定相应。是名定根。若菩萨。于一切法。离所生相及不生相。谛观诸法自性皆空。是名慧根。天子。此等名为五根

复次普华幢天子。白妙吉祥菩萨言。云何名为五力。妙吉祥言。若菩萨于一切法不起种种虚妄分别。是名信力。若菩萨于一切法而能请问如实胜义。名精进力。若菩萨于一切法离诸失念正念相应。是名念力。若菩萨于出世法心无懈倦。是名定力。若菩萨于诸业报净信不坏。是名慧力。天子。此等名为五力

复次普华幢天子白妙吉祥菩萨言。云何名为七觉支。妙吉祥言。若菩萨了一切行本无所生。于喜乐法观真实性。是名喜觉支。若菩萨于一切法无爱着心。于所缘相观不可得。是名轻安觉支。若菩萨见一切法自性无念无所作意。是名念觉支。若菩萨若一切法求种种相了不可得。记诸善法如实出生。是名择法觉支。若菩萨观三界性不取三界相。是名精进觉支。若菩萨观心无所得。即于一切法亦无所觉了。是名定觉支。若菩萨知一切法本无所依即无所住。复无所生亦无所觉。是故一切法无所观不可得住平等舍。是名舍觉支。天子。此等名为七觉支法

如是略说。四念处八正道五根五力七觉支法。此诸法门。若菩萨所修为菩萨行。声闻所修为声闻行。假使若有净行诸婆罗门能修习者。即得解诸怨结除灭棘刺息诸烦恼。远离病苦不生怖畏。顺向佛道住佛种姓。若诸沙门多闻佛子修此法者。即得超越轮回到于彼岸。离诸尘垢得无相身。去除重担到无畏处获大快乐。若诸菩萨于此法门。如实观想如理修行得具足已。是诸菩萨于天上人间。应受广大信施供养。天子。是故诸菩萨于其世间随诸方处。不空受食有大利益。又复若欲出度轮回。破诸魔众摧伏外道。吹大法螺击大法鼓。转大法轮立大法幢。解脱众苦得大涅槃。当于如是胜妙法门如理修行。天子。如前所问菩萨行者。此一切法是菩萨行

尔时妙吉祥菩萨摩诃萨。为普华幢天子说是法时。会中有三万二千天子。闻已信解住法平等。即时雨天曼陀罗华。摩诃曼陀罗花。及众妙花。住虚空中。供养世尊及妙吉祥菩萨。花供养已。作如是言。我等今者于佛法中。暂得闻此菩萨行法。尚获如是最胜利益。况复有人于此正法能一心听。生净信解如理修行。当知是人顺向佛道。如妙吉祥神通具足

尔时普华幢天子复白佛言。世尊。今此正法于后末世。欲使广大宣通流布。唯愿世尊。以威神力加持护念。佛告普华幢天子言。如是如是。诸佛如来而自知时

尔时世尊普遍观察诸众会已。作如是言。诸善男子。汝等众中。谁当能于无数百千俱胝那庾多劫。持佛菩提护助正法

尔时会中有三十二俱胝大菩萨众。异口同音俱白佛言。世尊。我等于佛住世及涅槃后。以佛神力而能持佛菩提护助正法

复次会中有梵天子。名胜思惟。从座而起。前白佛言。世尊。诸菩萨摩诃萨。于何福蕴修习具足。当能于此甚深正法。受持读诵为人演说广大流布。佛告胜思惟梵天子言。若菩萨摩诃萨。于佛如来所有十力。修习具足勇猛坚固证得无生法忍者。当知是人即能持佛菩提护助正法

尔时胜思惟梵天子复白佛言。世尊。如我解佛所说义。今此不思议境界正法。若有人闻不能发生清净信解者。我知是人非为大士。于正法门而不相应。是故世尊不为授记

佛言。梵天子。如汝所说如是如是

尔时慈氏菩萨摩诃萨。从他方界还来佛会。与妙吉祥菩萨摩诃萨俱白佛言。世尊。今此正法。于后五百岁中。唯愿世尊。以威神力加持护念。使令正法广大流布。于其世间利益安乐一切众生。而诸魔众欲生破坏不得其便

尔时世尊当欲加持护念此正法故。于其左右重复观察一切众会。即时十方如殑伽沙数。所有佛刹六种震动。而彼十方如殑伽沙数。现住说法诸佛世尊。知是事已亦各以其神力。加持护念此正法门

尔时帝释天主前白佛言。希有世尊。今此甚深不可思议境界正法。诸佛如来神通威力所加持故。世尊。于后末世城邑聚落所在方处。若有善男子。广为他人说此正法者。我当与诸眷属往诣彼法师所。密加护之使其精进。处师子座勇猛无畏。不令诸魔伺得其便。我今复以秘密大明当为作护。即说大明曰

怛[寧*也](切身)他(引一句)嗢契(二)目契(三)苏目契(四)钵啰(二合)摩哩那(二合)偁(五)畔惹(仁左切下同)偁(六)三畔惹偁(七)嚩哩沙(二合)砌(引)那偁(八)味怛啰(二合)嚩帝末没提(二合引九)世尊。若诸方处有说法师。我当于其左右密诵此明结金刚持印而为加护。使得正法广大流通

尔时三十三天中有一天子。名虞钵迦。生天未久来此佛会处虚空中。得闻正法见希有事。即时雨天曼陀罗华。摩诃曼陀罗花等。种种妙花。及诸广大殊妙珍宝。供养世尊并妙吉祥菩萨及所说法。作如是等诸供养已。从空而下绕佛三匝头面着地礼世尊足。持真珠鬘五百肘量。其鬘复以一切妙宝而为庄严。奉上世尊作如是言。希有世尊。今此广大甚深正法。于后末世。能与众生多所饶益。若有善男子等。于城邑聚落及诸方处受持此法者。当知是人从佛所生。持佛菩提转大法轮

尔时佛告虞钵迦天子言。如汝所说如是如是。若后末世有善男子。能于城邑聚落及诸方处。持此法者。我说是人从佛所生。持佛菩提转大法轮。尔时世尊告妙吉祥菩萨摩诃萨言。汝当受持此不思议境界正法。又复告言。汝当受持此不思议境界正法。于后末世广大流布不令断绝。使诸众生得大利乐

妙吉祥菩萨白佛言。世尊。如佛教旨我当奉持。如佛教旨我当奉持。若佛住世及涅槃后。正法所住五百岁中。乃至最后法欲灭时。以佛如来所加持力。我当护助宣通流布。若有善男子等为人演说此正法时。我当往彼人所。隐我身相而不出现。听受彼人所说正法。如是随喜展转称赞

尔时世尊告尊者阿难言。汝当受持此正法门。广大为人宣布演说。阿难。若诸众生。受持读诵此正法门一四句偈者。当知是人决定成就阿耨多罗三藐三菩提果。常为诸佛共所观察阿难。正使有人以十方一切诸佛刹土满中珍宝。供养诸佛所获福蕴。不如有人于此正法。发生净信听受读诵。而此福蕴无量无边。尔时尊者阿难白佛言。世尊。此经何名。我当云何奉持。佛告阿难。是经名为不思议境界正法。亦名普华幢天子所问。亦名妙吉祥菩萨游戏神通。亦名如来秘密法印。亦名不退转法门。如是受持。佛说此经已。妙吉祥等诸大菩萨。及普华幢天子。乃至世间天人阿修罗乾闼婆等一切大众。闻佛所说皆大欢喜。信受奉行

佛说大乘不思议神通境界经卷下


佛说大乘大方广佛冠经

    No. 438

佛说大乘大方广佛冠经卷上

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

如是我闻。一时世尊在王舍城鹫峰山中。与大苾刍众千二百五十人俱。皆是阿罗汉诸漏已尽

复有诸大菩萨之众。慈氏菩萨妙吉祥菩萨而为上首。并余无数天龙夜叉乾闼婆。及持明仙天女众等

尔时世尊告尊者大迦叶言。迦叶。我今为令诸初发心菩萨成熟一切善根故。有所宣说。汝等谛听极善作意。时大迦叶白佛言。善哉世尊。受教而听。佛言。迦叶。东方去此佛刹。过一殑伽沙数等世界。有世界名曰定严。其土有佛。号定手最上吉祥如来应供正等正觉。今现住彼教化利益。其佛刹中有菩萨摩诃萨。名离尘步。次补彼佛。当成阿耨多罗三藐三菩提果。号常定手最上吉祥如来应供正等正觉。出现世间

迦叶。若有住菩萨乘诸善男子及善女人。闻是定手最上吉祥如来名号及离尘步菩萨摩诃萨名号。能称念受持者是人转生得宿命智。百劫之中背于生死。而能摄集无量福蕴。近证阿耨多罗三藐三菩提果

复次迦叶。东方去此佛刹。过二殑伽沙数等世界。有世界名大菩提场庄严妙爱。其土有佛。号莲华最上吉祥如来应供正等正觉。今现住彼教化利益。其佛刹中有菩萨摩诃萨。名莲华手。次补彼佛。当成阿耨多罗三藐三菩提果。号莲华上王如来应供正等正觉。出现世间

迦叶。若有住菩萨乘诸善男子及善女人。闻是莲华最上吉祥如来应供正等正觉名号及莲华手菩萨摩诃萨名号。能称念受持者。是人转生得宿命智。乃生常得莲华化生。于诸世间而无染着。超越一切不善之法。犹如莲华不着于水。当得不退转于阿耨多罗三藐三菩提。三十千劫中背于生死。而能摄集无量福蕴。近证阿耨多罗三藐三菩提果

复次迦叶。东方去此佛刹。过三殑伽沙数等世界。有世界名离尘藏。其土有佛。号日轮光明最胜吉祥如来应供正等正觉。今现住彼教化利益。其佛刹中有菩萨摩诃萨。名日光明。次补彼佛。当成阿耨多罗三藐三菩提果。名诸圣吉祥圆满最上众相严身如来应供正等正觉。出现世间

迦叶。若有住菩萨乘诸善男子及善女人。闻是日轮光明最胜吉祥如来应供正等正觉名号及日光明菩萨摩诃萨名号。能称念受持者。是人转生得宿命智。乘日轮光照诸善法。不复更生堕三恶趣疑惑怖畏。当得不退转于阿耨多罗三藐三菩提。千劫之中背于生死。近证阿耨多罗三藐三菩提果

复次迦叶。东方去此佛刹。过四殑伽沙数等世界。有世界名得自在。其土有佛。号一宝盖最上如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻是一宝盖最上如来应供正等正觉名号。能称念受持者。是人转生得宿命智。不于下劣族姓中生。不于贫窭族姓中生。在在所生而悉于彼王宫中生。所生之处无母障难无父障难。无富贵难无疾病难。当得不退转于阿耨多罗三藐三菩提。三十千劫中背于生死。近证阿耨多罗三藐三菩提果

复次迦叶。东方去此佛刹。过五殑伽沙数等世界。有世界名清净藏。其土有佛号定最上吉祥如来应供正等正觉。今现住彼教化利益

迦叶。彼定最上吉祥如来应供正等正觉。往昔修行菩萨道时发大誓愿。愿我当来得成佛时。若有住菩萨乘诸善男子及善女人。闻我名号能称念受持者。是人世世生生常得出家。得出家已而悉获于千三摩地。一一三摩地中。复证百千俱胝那庾多三摩地门。彼之所得诸三摩地永不散失。能于过去已入涅槃十千佛所。瞻礼听法。所有现在未来世中见佛听法。亦复如是。当得不退转于阿耨多罗三藐三菩提。世世所生千劫之中背于生死。近证阿耨多罗三藐三菩提果

迦叶。若有住菩萨乘诸善男子及善女人。闻是定最上吉祥如来应供正等正觉名号。能称念受持者。是人于彼如是行相所求皆得

复次迦叶。东方去此佛刹。过六殑伽沙数等世界。有世界名宝庄严。其土有佛。号宝轮光明高胜吉祥王如来应供正等正觉。今现在彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻是宝轮光明高胜吉祥王如来应供正等正觉名号。能称念受持者。是人转生得宿命智。有念有慧诸相圆满。当得成就信顺之语获得无断语言辩才。迦叶。是人能于天人世间一切辩才之中。不为他所退怯间断。常得语言辩才无断。又善男子及善女人。若能称念彼佛名者。是人听法之时。得佛圣相为现其前。若于诸法昔所未闻随所受学。即时获得无边俱胝那庾多百千随转陀罗尼。又此阎浮提中。一切有情随所乐求而悉能知。然后如其信解善为说法。当得不退转于阿耨多罗三藐三菩提。阿僧祇俱胝那庾多百千劫中背于生死。而能摄集无量福蕴

佛说大乘大方广佛冠经卷上佛说大乘大方广佛冠经卷下

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

复次迦叶。南方去此佛刹。过三十千世界。有世界名悦意声。彼土有佛。号无边步迹如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻彼无边步迹如来应供正等正觉名号。能称念受持者。是人转生得宿命智。获得月轮清净菩萨三摩地。住是三摩地已。所有东方殑伽沙数等诸佛世尊亲得瞻睹。如是南西北方四维上下普遍十方。彼一一方所有殑伽沙数等诸佛世尊悉得瞻睹。而于彼彼佛世尊所。听受说法皆能解了。常得值遇诸佛出世。于一切时不暂舍离诸佛世尊。乃至证成菩提毕竟边际。永得不退转于阿耨多罗三藐三菩提。三十五千劫中背于生死。而能摄集无量福蕴

复次迦叶。南方去此佛刹。过三十五世界。有世界名妙香最上香。彼土有佛。号无边香最上王如来应供正等正觉。今现住彼教化利益

迦叶。彼无边香最上王如来。往昔修行菩萨道时。发大誓愿。愿我当来得成佛时。若有住菩萨乘诸善男子及善女人闻我名号能称念受持者。是人获彼多种功德。所谓于一切处在在所生得宿命智。梵行圆满具三十二大丈夫相庄严其身。又复余佛刹中蒙光照触者。皆悉来集。我为彼等圆满一切菩提胜行。又复若此。大地大火充满普遍烧然。火烧然已。大地出现种种珍宝。诸来求者而周给之。然彼一切亦无少分差动之相。当得不退转于阿耨多罗三藐三菩提。三十千劫中背于生死。而能摄集无量福蕴

复次迦叶。南方去此佛刹。过一殑伽沙数等世界(此下合有世界之名梵本元阙)。彼土有佛。号宝上如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻彼宝上如来应供正等正觉名号。能称念受持者。是人转生得宿命智。又复当生在母胎中即得见佛。彼佛劝赞作如是言。善男子。汝当成熟阿耨多罗三藐三菩提故速出母胎。千劫之中背于生死。而能摄集无量福蕴

复次迦叶。西方去此佛刹。过三殑伽沙数等世界。有世界名不知遍知。彼土有佛。号大光明照如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻彼大光明照如来应供正等正觉名号。能称念受持者。是人转生得宿命智。获得日轮光明最上三摩地。住是三摩地已。得见殑伽沙数等诸佛世尊。如无能胜等诸大菩萨所有功德。亦同称赞是人功德

迦叶。又若女人在母胎中得闻彼如来名者。是人后生不复成彼女人之相。此报终已当成男子。何以故。为由得闻如是大神通大威德如来名号能受持故

尔时世尊即说颂曰

  若有女人处母胎　　闻佛大仙胜名号
  是人转此女身已　　当成有智之男子
  证成无上大菩提　　利益一切众生类
  能于天上及人间　　普为众生作趣向

复次迦叶。若有住菩萨乘诸善男子及善女人。闻彼如来名号能称念受持者。是人阿僧祇劫中背于生死。而能摄集无量福蕴。近证阿耨多罗三藐三菩提果

复次迦叶。北方去此佛刹。过四十千世界。有世界名有宝。彼土有佛。号宝开花普耀吉祥如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻彼宝开花普耀吉祥如来应供正等正觉名号。能称念受持者。是人转生得宿命智。获得宝月菩萨三摩地。住是三摩地已。能解一切众生语言音声。得佛加持无碍语言辩才成就。若有众生乐求见彼。住虚空中宣说诸法。是人即时随意能现。又此阎浮提中一切众生。随有乐求所出音声。是人各各悉能了知。又若此三千大千世界一切众生。随有乐求所出音声诸言说等。是人悉知。如其信解各为说法。当得不退转于阿耨多罗三藐三菩提。六十千劫中背于生死。复次迦叶。东方去此佛刹。过六十千世界。有世界名众宝。彼土有佛。号曰宝藏如来应供正等正觉。今现住彼教化利益

迦叶。若有住菩萨乘诸善男子及善女人。闻彼宝藏如来应供正等正觉名号。能称念受持者。是人转生得宿命智。当得成就七觉支法

复次迦叶。东方去此佛刹。过阿僧祇世界。有世界名宝耀。彼土有佛。号曰宝胜如来应供正等正觉。今现住彼说法教化

迦叶。若有住菩萨乘诸善男子及善女人。闻彼宝胜如来应供正等正觉名号。能称念受持者。是人能生多种福蕴

迦叶。正使住菩萨乘诸善男子及善女人。广集珍宝其积量如须弥山王。以如是相行于布施。广大奉献诸佛世尊。如是行施经俱胝那庾多百千岁中。曾无间断。又若有人闻彼宝胜如来应供正等正觉名号。能称念受持者。前之布施无量功德。比是功德百分不及一。千分不及一。百千分不及一。阿僧祇分不及一。算分喻分皆不及一

尔时世尊说伽陀曰

  所有东方诸佛刹　　南方西方及北方
  诸方现住诸世尊　　光照众生作利益
  若时非时悉应知　　昼夜常起尊重想
  合掌虔恭发志诚　　信礼最上人中胜
  何能知名而表了　　意想礼奉人中尊
  所谓于其千劫中　　极难得值佛出世
  若欲恭敬于诸佛　　为求无上菩提者
  闻佛所说诸佛名　　应当于彼常归命
  我今无复诸所求　　唯求佛智中出生
  于彼所得众善根　　回向佛智不思议
  若人欲供于诸佛　　佛不思议常作意
  彼诸佛名得闻已　　当为他人广宣说
  欲令俱胝众生类　　出离二有得解脱
  彼诸佛名得闻已　　受持不复生人间
  欲令俱胝诸佛刹　　能以足指而震动
  彼诸佛名得闻已　　受持广为多人说
  若曾供养于诸佛　　彼闻佛名得受持
  非一非十二十生　　此即多生种善本
  若闻佛名能受持　　若以河沙金宝施
  较量受持佛名人　　福蕴百分不及一
  若闻佛名受持者　　当得最上人身相
  妙色端严处世间　　出家堪受人天供

佛说此经已。彼诸苾刍诸大菩萨摩诃萨众。尊者大迦叶。并诸世间天人阿修罗乾闼婆等。闻佛所说皆大欢喜信受奉行

佛说大乘大方广佛冠经卷下


佛说大乘稻芉经

    No. 712 [Nos. 708-711]

佛说大乘稻芉经

如是我闻。一时。薄伽梵。住王舍城耆阇崛山。与大比丘众千二百五十人。及诸菩萨摩诃萨俱。尔时具寿舍利子。往弥勒菩萨摩诃萨经行之处到已。共相慰问。俱坐盘陀石上。是时具寿舍利子。向弥勒菩萨摩诃萨。作如是言。弥勒。今日世尊观见稻芋。告诸比丘。作如是说。诸比丘。若见因缘。彼即见法。若见于法。即能见佛。作是语已。默然无言。弥勒。善逝何故作如是说。其事云何。何者因缘。何者是法。何者是佛。云何见因缘即能见法。云何见法即能见佛。作是语已。弥勒菩萨摩诃萨。答具寿舍利子言。今佛法王正遍知告诸比丘。若见因缘即能见法。若见于法即能见佛者。此中何者是因缘。言因缘者。此有故彼有。此生故彼生。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死愁叹苦忧恼而得生起。如是唯生纯极大苦之聚。此中无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死愁叹苦忧恼得灭。如是唯灭纯极大苦之聚。此是世尊所说因缘之法。何者是法。所谓八圣道支。正见．正思惟．正语．正业．正命．正精进．正念．正定．此是八圣道。果．及涅槃。世尊所说。名之为法。何者是佛。所谓知一切法者。名之为佛。以彼慧眼及法身。能见作菩提．学．无学法故。云何见因缘。如佛所说。若能见因缘之法。常．无寿．离寿．如实性．无错谬性．无生．无起．无作．无为．无障碍．无境界．寂静．无畏．无侵夺．不寂静相者。是也。若能如是。于法亦见常．无寿．离寿．如实性．无错谬性．无生．无起．无作．无为．无障碍．无境界．寂静．无畏．无侵夺．不寂静相者。得正智故。能悟胜法。以无上法身而见于佛。问曰。何故名因缘。答曰。有因有缘。名为因缘。非无因无缘故。是故名为因缘之法。世尊略说因缘之相。彼缘生果。如来出现若不出现。法性常住。乃至法性．法住性．法定性．与因缘相应性．真如性．无错谬性．无变异性．真实性．实际性．不虚妄性．不颠倒性等。作如是说。此因缘法。以其二种而得生起。云何为二。所谓因相应。缘相应。彼复有二。谓外及内。此中何者是外因缘法因相应。所谓从种生芽。从芽生叶。从叶生茎。从茎生节。从节生穗。从穗生花。从花生实。若无有种。芽即不生。乃至若无有花。实亦不生。有种芽生。如是有花实亦得生。彼种亦不作是念。我能生芽。芽亦不作是念。我从种生。乃至花亦不作是念。我能生实。实亦不作是念。我从花生。虽然。有种故而芽得生。如是有花故。实即而能成就。应如是观外因缘法因相应义。应云何观外因缘法缘相应义。谓六界和合故。以何六界和合。所谓地水火风空时界等和合。外因缘法而得生起。应如是观外因缘法缘相应义。地界者。能持于种。水界者。润渍于种。火界者。能暖于种。风界者。动摇于种。空界者。不障于种。时则能变种子。若无此众缘。种则不能而生于芽。若外地界无不具足。如是乃至水火风空时等。无不具足。一切和合。种子灭时而芽得生。此中地界不作是念。我能任持种子。如是水界亦不作是念。我能润渍于种。火界亦不作是念。我能暖于种子。风界亦不作是念。我能动摇于种。空界亦不作是念。我能不障于种。时亦不作是念。我能变于种子。种子亦不作是念。我能生芽。芽亦不作是念。我今从此众缘而生。虽然。有此众缘。而种灭时。芽即得生。如是有花之时。实即得生。彼芽亦非自作。亦非他作。非自他俱作。非自在作。亦非时变。非自性生。亦非无因而生。虽然。地水火风空时界等和合。种灭之时而芽得生。是故应如是观外因缘法缘相应义。应以五种观彼外因缘法。何等为五。不常。不断。不移。从于小因而生大果。与彼相似。云何不常。为芽与种。各别异故。彼芽非种。非种坏时而芽得生。亦非不灭而得生起。种坏之时而芽得生。是故不常。云何不断。非过去种坏而生于芽。亦非不灭而得生起。种子亦坏。当尔之时。如秤高下而芽得生。是故不断。云何不移。芽与种别。芽非种故。是故不移。云何小因而生大果。从小种子而生大果。是故从于小因而生大果。云何与彼相似。如所植种。生彼果故。是故与彼相似。是以五种观外因缘之法。如是内因缘法。亦以二种而得生起。云何为二。所谓因相应。缘相应。何者是内因缘法因相应义。所谓始从无明缘行。乃至生缘老死。若无明不生。行亦不有。乃至若无有生。老死非有。如是有无明故。行乃得生。乃至有生故。老死得有。无明亦不作是念。我能生行。行亦不作是念。我从无明而生。乃至生亦不作是念。我能生于老死。老死亦不作是念。我从生有。虽然。有无明故。行乃得生。如是有生故。老死得有。是故应如是观内因缘法因相应义。应云何观内因缘法缘相应事。为六界和合故。以何六界和合。所谓地水火风空识界等和合故。应如是观内因缘法缘相应事。何者是内因缘法地界之相。为此身中作坚硬者。名为地界。为令此身而聚集者。名为水界。能消身所食饮嚼啖者。名为火界。为此身中作内外出入息者。名为风界。为此身中作虚通者。名为空界。五识身相应。及有漏意识。犹如束芦。能成就此身名色芽者。名为识界。若无此众缘。身则不生。若内地界。无不具足。如是乃至水火风空识界等。无不具足。一切和合。身即得生。彼地界亦不作是念。我能而作身中坚硬之事。水界亦不作是念。我能为身而作聚集。火界亦不作念。我能而消身所食饮嚼啖之事。风界亦不作念。我能作内外出入息。空界亦不作念。我能而作身中虚通之事。识界亦不作念。我能成就此身名色之芽。身亦不作是念。我从此众缘而生。虽然。有此众缘之时。身即得生。彼地界。亦非是我。非是众生。非命者。非生者。非儒童。非作者。非男。非女。非黄门。非自在。非我所。亦非余等。如是乃至水界火界风界空界识界。亦非是我。非是众生。非命者。非生者。非儒童。非作者。非男。非女。非黄门。非自在。非我所。亦非余等。何者是无明。于此六界。起于一想．一合想．常想．坚牢想．不坏想．安乐想．众生．命．生者．养育．士夫．人．儒童．作者．我．我所想等。及余种种无知。此是无明。有无明故。于诸境界起贪嗔痴。于诸境界起贪嗔痴者。此是无明缘行。而于诸事能了别者。名之为识。与识俱生四取蕴者。此是名色。依名色诸根。名为六入。三法和合。名之为触。觉受触者。名之为受。于受贪着。名之为爱。增长爱者。名之为取。从取而生。能生业者。名之为有。而从彼因所生之蕴。名之为生。生已。蕴成熟者。名之为老。老已。蕴灭坏者。名之为死。临终之时。内具贪着及热恼者。名之为愁。从愁而生诸言辞者。名之为叹。五识身受苦者。名之为苦。作意意识受诸苦者。名之为忧。具如是等及随烦恼者。名之为恼。大黑闇故。故名无明。造作故名诸行。了别故名识。相依故。名名色。为生门故名六入。触故。名触。受故。名受。渴故。名爱。取故。名取。生后有故名有。生蕴故。名生。蕴熟故。名老。蕴坏故。名死。愁故。名愁。叹故名叹。恼身故。名苦。恼心故。名忧。烦恼故。名恼。复次。不了真性。颠倒无知。名为无明。如是有无明故。能成三行。所谓福行．罪行．不动行。从于福行而生福行识者。此是无明缘行。从于罪行而生罪行识者。此则名为行缘识。从于不动行而生不动行识者。此则名为识缘名色。名色增长故。从六入门中能成事者。此是名色缘六入。从于六入而生六聚触者。此是六入缘触。从于所触而生彼受者。此则名为触缘受。了别受已。而生染爱耽著者。此则名为受缘爱。知已。而生染爱耽着故。不欲远离好色及于安乐。而生愿乐者。此是爱缘取。生愿乐已。从身口意。造后有业者。此是取缘有。从于彼业所生蕴者。此是有缘生。生已。诸蕴成熟及灭坏者。此则名为生缘老死。是故彼因缘十二支法。互相为因。互相为缘。非常．非无常．非有为．非无为．非无因．非无缘．非有受．非尽法．非坏法．非灭法。从无始已来。如暴流水而无断绝。虽然。此因缘十二支法。互相为因．互相为缘。非常．非无常．非有为．非无为．非无因．非无缘．非有受．非尽法．非坏法．非灭法。从无始已来。如暴流水而无断绝。有其四支。能摄十二因缘之法。云何为四。所谓无明．爱．业．识。识者。以种子性为因。业者。以田性为因。无明及爱。以烦恼性为因。此中业及烦恼。能生种子之识。业则能作种子识田。爱则能润种子之识。无明能殖种子之识。若无此众缘。种子之识而不能成。彼业亦不作念。我今能作种子识田。爱亦不作念。我今能润于种子之识。无明亦不作念。我今能殖种子之识。彼种子识亦不作念。我今从此众缘而生。虽然。种子之识。依彼业田。及爱所润。无明粪壤所生之处。入于母胎。能生名色之芽。彼名色芽。亦非自作。亦非他作。非自他俱作。非自在化。亦非时变。非自性生。非假作者。亦非无因而生。虽然。父母和合时。及余缘和合之时。无我之法。无我我所。犹如虚空。彼诸幻法。因及众缘无不具足故。依彼生处。入于母胎。则能成就执受种子之识。名色之芽。如眼识生时。若具五缘而则得生。云何为五。所谓依眼．色．明空依作意故。眼识得生。此中眼则能作眼识所依。色则能作眼识之境。明则能为显现之事。空则能为不障之事。作意能为思想之事。若无此众缘。眼识不生。若内入眼。无不具足。如是乃至色明空作意。无不具足。一切和合之时。眼识得生。彼眼亦不作是念。我今能为眼识所依。色亦不念。我今能作眼识之境。明亦不作念。我今能作眼识显现之事。空亦不作念。我今能为眼识不障之事。作意亦不作念。我今能为眼识所思。彼眼识亦不作念。我是从此众缘而有。虽然。有此众缘。眼识得生。乃至诸余根等。随类知之。如是无有少法而从此世移至他世。虽然。因及众缘无不具足故。业果亦现。譬如明镜之中。现其面像。虽彼面像。不移镜中。因及众缘无不具足故。面像亦现。如是无有少许从于此灭。生其余处。因及众缘无不具足故。业果亦现。譬如月轮。从此四万二千由旬而行。彼月轮形像。现其有水小器中者。彼月轮亦不从彼移至于有水之器。虽然。因及众缘无不具足故。月轮亦现。如是无有少许从于此灭而生余处。因及众缘无不具足故。业果亦现。譬如其火。因及众缘若不具足。而不能燃。因及众缘具足之时。乃可得燃。如是无我之法。无我我所。犹如虚空。依彼幻法。因及众缘无不具足故。所生之处入于母胎。则能成就种子之识。业及烦恼所生名色之芽。是故应如是观内因缘法缘相应事。应以五种观内因缘之法。云何为五。不常。不断。不移。从于小因而生大果。与彼相似。云何不常。所谓彼后灭蕴。与彼生分各异。为后灭蕴非生分故。彼后灭蕴亦灭。生分亦得现故。是故不常。云何不断。非依后灭蕴灭坏之时。生分得有。亦非不灭。彼后灭蕴亦灭。当尔之时。生分之蕴。如秤高下而得生故。是故不断。云何不移。为诸有情。从非众同分处。能生众同分处故。是故不移。云何从于小因而生大果。作于小业。感大异熟。是故从于小因而生大果。如所作因。感彼果故。与彼相似。是故应以五种观因缘之法。尊者舍利子。若复有人。能以正智。常观如来所说因缘之法。无寿．离寿．如实性．无错谬性．无生．无起．无作．无为．无障碍．无境界．寂静．无畏．无侵夺．无尽．不寂静相．不有．虚．诳．无坚实．如病．如痈．如箭．过失．无常．苦．空．无我者。我于过去而有生耶。而无生耶。而不分别过去之际。于未来世。生于何处。亦不分别未来之际。此是何耶。此复云何。而作何物。此诸有情。从何而来。从于此灭而生何处。亦不分别现在之有。复能灭于世间沙门婆罗门不同诸见。所谓我见．众生见．寿者见．人见．希有见．吉祥见．开合之见。善了知故。如多罗树。明了断除诸根栽已。于未来世。证得无生无灭之法。尊者舍利子。若复有人。具足如是无生法忍。善能了别此因缘法者。如来．应供．正遍知．明行足．善逝．世间解．无上士．调御丈夫．天人师．佛．世尊。即与授阿耨多罗三藐三菩提记。尔时弥勒菩萨摩诃萨说是语已。舍利子及一切世间。天．人．阿修罗．犍闼婆等。闻弥勒菩萨摩诃萨所说之法。信受奉行佛说大乘稻芉经


佛说大乘流转诸有经

    No. 577 [Nos. 575, 576]

佛说大乘流转诸有经

        大唐三藏法师义净奉　制译

如是我闻。一时薄伽梵。在王舍城羯阑铎迦池竹林园中。与大苾刍众千二百五十人俱。并大菩萨摩诃萨。无量百千人天大众。一心恭敬围绕而住。尔时世尊为说自证微妙之法。所谓初中后善。文义巧妙。纯一圆满清净鲜白梵行之相。尔时摩揭陀主影胜大王。往竹林中礼世尊足。右绕三匝在一面坐。时影胜王白佛言。世尊。云何有情先所造业。久已灭坏。临命终时皆悉现前。又复诸法体悉空无。所造业报而不散失。唯愿世尊。哀愍为我分别解说

尔时世尊。告影胜王曰。大王当知。譬如男子于眠梦中。见与人间端正美女。共为稠密。既睡觉已。忆彼梦中所见美女。大王于意云何。于眠梦中人间美女。是实有不。王言。非有。世尊告曰。大王于意云何。此之男子。于彼梦中所见美女。心生忆念恋慕不舍。可说此人是大博识明智者不。王言。不尔。此是愚人非明智者。何以故。由彼梦中人间美女。毕竟体空。不可得故。岂能与彼而行稠密。令此男子情怀爱恋生忆念耶

佛言。大王。如是愚痴无识凡人。眼见色时心生喜乐。便起执着。起执着已随生顾恋。生顾恋已情怀染爱。起染爱故随贪嗔痴。发身语意造作诸业。然此诸业作已灭坏。此灭坏时曾不依止东方而住。亦不依止南西北方四维上下。至命终时意识将灭。所作之业皆悉现前。譬如男子从睡觉已。忆彼梦中所见美女影像皆现如是。大王。前识灭已后识生时。或生人中。或生天上。或堕傍生饿鬼地狱。大王。后识生时无间生起。彼同类心相续流转。分明领受所感异熟。大王。曾无有法。能从此世转至后世。然有死生业果可得。大王当知。前识灭时名之为死。后识支起号之为生。大王。前识灭时无有去处。后识支起无所从来。所以者何。本性空故。大王。前识前识性空。死死性空。业业性空。后识后识性空。生生性空。而彼业果曾不散失。大王。如是应知。一切有情皆由愚惑不知非有。妄起顾恋轮回生死。尔时世尊欲重宣此义。说伽他曰

  诸法唯假名　　但依名字立
  离于能诠语　　所诠不可得
  皆以别别名　　诠彼种种法
  于名法非有　　是诸法自性
  由名名性空　　于名名不有
  诸法名本无　　妄以名诠名
  诸法皆虚妄　　但从分别生
  此分别亦空　　于空妄分别
  我说诸世间　　以眼见于色
  皆由邪计想　　是名为俗谛
  我说一切法　　皆是藉缘生
  是名近胜义　　智者当观察
  眼不见于色　　意亦不知法
  是名胜义谛　　愚者不能知

尔时世尊说此法已。摩揭陀主影胜大王。深心顶受。时诸苾刍。及大菩萨人天等众。皆大欢喜。信受奉行佛说大乘流转诸有经


佛说大乘善见变化文殊师利问法经

    No. 472

佛说大乘善见变化文殊师利问法经

        西天中印度惹烂驮啰国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

如是我闻。一时世尊在王舍城鹫峰山中。与大比丘众并大菩萨文殊师利等大众围绕。尔时佛告文殊师利童子言。佛子。我今为诸众生于四圣谛心生颠倒。恒处轮回不能免离。说此真实四圣谛法。文殊师利白佛言。世尊。如来应正等觉。云何因缘。而诸众生不能远离如是虚妄轮回之中不觉不知。佛言。文殊师利。我见众生受如是虚妄轮回。何以故。善男子。皆因无始已来妄生计执分别彼我。文殊师利。以是因缘。受此愚痴业报虚妄轮回。何以故。是诸愚痴众生。不闻不知最上一切寂静法故。不自思惟警悟三业。恣身口意造众烦恼。我贪我嗔我痴等。我今于彼如来法中。得此出家受清净戒修持净行远离轮回。得涅盘道解脱苦轮。复自思惟。此烦恼性即善法故。即有漏法故。即无漏法故。即轮回法故。即世间即出世间。即智即蠲除法。即决定法。即观法圆满智。即观苦集灭决定道。乃至决定法界故。又复思惟。一切行虚假故。一切行苦恼故。一切行即无相故。我若得此。即能远离一切虚假得随意生。若观我见不离道谛。即得彼法所作随意。复于彼法忆念无惑。于一切法心无差别。能如是知。即得远离不信疑惑毁谤赞叹。得此解脱一切我苦。我于是时无有少分而难作者。若阿罗汉能知此我。彼临命终时自见所生。弃舍本心得佛菩提。随意所乐自在而往。即得至于无为界故。彼得此苦智法智。若了知我集一切法生不信心疑惑诽谤种种怖畏。若不信此法尽此集故。彼作是思惟。决定灭谛。彼复思惟。此法应如是作。得灭谛故。是法若作此决定灭作是决定彼意心生疑惑。命终之后堕大地狱中。云何名如实思惟。生一切法故

尔时文殊师利童子白佛言。世尊。云何见四圣谛心。佛告文殊师利若见一切法即不生故即见苦谛。若见出生一切法消除故即是集谛。若见最上涅盘一切寂静法相即是灭谛。若见究竟一切法性即是道谛。文殊师利。若彼见此四圣谛非实非虚。是善法是不善法。是有漏是无漏。是世间是出世间。是有为智是无为智。是无变异法。是观苦集了别智法。即决定灭谛。乃至决定法界道谛不可改变。何故一切愚迷众生耽着欲乐。于此实相法中而生迷惑。彼诸众生于寂灭法不谛思惟。乃至一切法寂静自性不得现前。不知此法非取非舍非离取舍。在彼贪界显现涅盘。嗔界痴界乃至轮回界悉能现彼涅盘寂静界故。若于一切法能现如是自性平等。当得一切法中自在无碍。云何不知彼真实法。若于不生不灭法心同虚空。即佛平等不可得故。法平等不可得故。僧平等不可得故。乃至涅盘寂静平等亦不可得故。如是于一切未曾有法不生疑惑。即得离疑。不生不出。至一切最胜涅盘寂静界故。文殊师利。如是真谛一切法不可见。是故须菩提而不往诣礼如来足。如须菩提尚得无我。况复如来云何而见。勿作是解。文殊师利。如是一切不生法中。有所见故。即非见四圣谛

尔时文殊师利法王子白佛言。世尊。云何见四念处。佛告文殊师利。彼须菩提当得观身不净见身念处。观受是苦见受念处。观心无常见心念处。观法无我见法念处。文殊师利复白佛言。世尊。如是实相云何而说。复云何见真实四念处。佛告文殊师利。止此真实谛如来所说难解难知。文殊师利言。唯愿说之广演分别。彼真实四念处故。佛言。文殊师利。汝若见等虚空身。即见此身中身念处。又文殊师利。若于受中内外中间。有所得故即见受念处。又文殊师利。若见此心智有方圆大小。即见此心中心念处。又文殊师利。若于善不善有漏无漏乃至烦恼世出世间法中。有所得故。即非见此法中法念处。文殊师利。此真实四念处应如是解。文殊师利白世尊言。云何见四正勤。佛告文殊师利。若观十二缘生究竟空寂乃至无性。一切法彼不可得当起精进心称法。灭除所生不善一切业故。为未生不善法令不起故。未生善法起精进心令出生故。所生善法令得久住不废忘故。当起圆满精进心故。如一切法离取离舍非离取舍。若得如是正忆念故。彼不复起心。即得此三摩地行。彼云何思惟。得神足故。云何住平等一切法。文殊师利。应当如是见四正勤

文殊师利又复白言。世尊。云何见五根。佛言。文殊师利。若见究竟一切法不生。即解信根。何以故。文殊师利。此究竟不生信根。于一切法中心不可得故。本离此名。又文殊师利。若于一切法离忆念故。无有趣求不住方所是为精进根。文殊师利。若于一切法。离现前明了故。远离差别心不起故。是为念根。又文殊师利。若于诸法。能离生灭能觉所觉性空性非空性故。是为定根。文殊师利。若性孰有孰无。一切法中不可得故。是为慧根。文殊师利。应如是解。了知五根故

文殊师利言。世尊。云何见五力。佛言。文殊师利。若能见此离性离相一切广大心法。是为信力。文殊师利。若于菩提进求功德。能离取舍非离取舍。是为进力。文殊师利。若于一切法离诸忆念无有计执。是为念力。文殊师利。若至一切法无相故。是为定力。文殊师利。若能远离一切所见乃至涅盘。是为慧力。文殊师利。应如是解。了知五力故

文殊师利言。世尊。云何见七觉分。佛言。文殊师利。若见一切无自性法。不忆念故。是为念觉分。文殊师利。若于一切法心不可测度。说善不善及得受记。是为择法觉分。文殊师利。若于一切法能离取舍非离取舍。又于诸法舍离思虑。是为精进觉分。文殊师利。若于一切法不生爱着。解一切法即无生故。是为喜觉分。文殊师利。若于一切法心生信乐。解一切法不可得故。是为轻安觉分。文殊师利。若于一切法心无掉举。是为定觉分。文殊师利。若于一切法无住无著不可觉知。于一切法不生贪着。若得此舍是为舍觉分。文殊师利。七菩提分。应如是解而能了知

文殊师利言。世尊。云何见八正道。佛告文殊师利。若不见正。乃至不见一切无性。法无二相心无挂碍。是为正见。文殊师利。若见一切法离诸挂碍。非离挂碍。心无所著。是为正思惟。文殊师利。若见一切法无有边际。称无边际平等善说。是为正语。文殊师利。若见一切法无有动作。离悲[(每*殳)/心]心。本不生故。是为正业。文殊师利。若于一切法无喜无嗔诸法不生。是为正命。文殊师利。若于一切法无有起灭无有力用。是为正精进。文殊师利。若于一切法念念不生。无有知觉离诸思惟。是为正念。文殊师利。若于一切法自性非性。而能远离无有所著。是为正定。文殊师利。此八正道。应如是解即能了知

文殊师利。若有见如是四圣谛心。即得见于四念处四正勤四神足五根五力七菩提分八圣道分。真实心故。是求彼岸。至实际地得大安乐。悉舍重担远尘离垢。观身无相至无生忍。阿罗汉沙门婆罗门。至净彼岸名曰多闻。是真佛子是能仁子。能敌冤家弃掷烦恼。得大坚固无老无怖。无有疑惑亦无戏论。无彼无此。名此比丘为圣法幢。文殊师利。若得如是法忍得大善利。应得一切世间天人阿修罗而为供养。文殊师利。是故得一切国土无空过者。悉受清净饮食供养。为离轮回得涅盘岸脱诸苦轮。乃至一切正遍知正等菩提。起此心法所求皆得

尔时世尊说是法时。三万二千天子皆得此法。彼诸天众于如来世尊应正等觉并文殊师利菩萨摩诃萨。散曼陀罗花摩诃曼陀罗花。而以供养。作如是言。彼等于如来佛法中。当得出家受清净戒。若说此法。一心听受得菩提道。复有八千一百比丘众。心得漏尽无生解脱。复有四万二千菩萨。得无生法忍。于时三千大千世界。一切魔王宫殿山林旷野大地六种振动。于虚空中雨众天花。赞言善哉善哉。善说此法甚为希有。出是音声十方普闻。佛说此经已。文殊师利法王子。及大菩萨诸比丘众。一切世间诸天人民阿修罗干达婆等。闻佛所说。各各欢喜礼佛而退佛说文殊师利问法经


佛说大乘随转宣说诸法经

    No. 652 [Nos. 650, 651]

佛说大乘随转宣说诸法经卷上

        宋明教辩才法师充译经三藏沙门绍德等奉　诏译

如是我闻。一时佛在王舍城鹫峰山中。与大比丘众千二百五十人俱。诸大菩萨摩诃萨众二千人俱。其名曰庄严菩萨。师子游戏菩萨。不动光菩萨。欢喜无垢光菩萨。日光焰菩萨。甚深离垢菩萨。莲华相菩萨。师子智菩萨。金色相菩萨。梵天音菩萨。师子慧王菩萨。无垢金光菩萨。微妙色身菩萨。放光坏魔菩萨。寂静诸根菩萨。陀罗尼王菩萨。吉祥清净相菩萨。妙吉祥摧伏坏魔菩萨等。而为上首。尔时师子游戏菩萨。在大众中。睹佛身色金光晃耀。心生爱乐。即从座起绕佛三匝。右膝着地合掌恭敬。而说伽陀曰

  如来真金色　　相好端严身
  于尘沙劫中　　积集诸功德
  福智悉圆满　　证于无上道
  兴运大悲心　　应现娑婆界
  人天八部众　　瞻仰无厌足
  从于自性中　　演出微妙法
  甚深难可测　　唯佛乃能知
  众生性昏懵　　闻说不能解
  如来大导师　　方便能善巧
  诱彼诸群迷　　渐次得开悟
  众生妙明心　　本来常湛寂
  清净无垢染　　具足诸功德
  体性如虚空　　无有诸挂碍
  不生亦不灭　　无去亦无来
  安住于法性　　不动如须弥
  一切悉平等　　真实不思议
  众生无始劫　　贪着于诸欲
  堕入苦海中　　不能求出离
  如来甚深法　　微妙极难思
  于上中下机　　随顺而演说
  如天一味雨　　遍洒于十方
  草木及丛林　　根茎随大小
  而于大地中　　无不蒙滋益
  如来所说法　　悉亦复如是
  以一微妙音　　演说无量义
  根器有差殊　　闻之各得解
  故于一会中　　咸皆入佛慧
  是佛神通力　　名为不思议
  我于往昔劫　　常随佛所化
  而今此会中　　亦预佛座下
  如来所说法　　我悉能总持
  见在及未来　　愿佛为宣说

尔时佛告师子游戏菩萨摩诃萨言。善哉善哉。善男子。世间一切众生妙明元心。本来清净无诸垢染。圆满十方湛然寂静。犹如虚空本无尘翳寂然清净。众生眼病空华发生。华生华灭病眼所见。眼翳既消空华亦灭。清净虚空本来不动。妙明元心亦复如是。本来清净无诸垢染。众生颠倒背觉合尘。于诸尘境分别心生。眼见于色。耳闻于声。鼻嗅诸香。舌尝于味。身受诸触。意了法尘。此六根识各各自偶诸尘境界。于诸尘境妄想执着。便生爱染造种种业。业成受报堕诸苦海。生死轮回受大苦恼。如旋火轮无有休息。如来大慈怜愍一切。设诸方便说奢摩他三摩钵提禅那止观法门令彼摄心渐渐熏修。证于佛果免斯恶道。善男子。诸阿阇梨。与诸世间一切众生欲求菩提。用真实心直行正道。若心行染欲谄曲不实。是行邪道希求菩提。无有是处。善男子。若诸众生心行善行除彼妄想。无诸分别了法空寂。无空见无愿见。不起妄见。无性见无相见。无佛见无菩提见。常行正见种诸善根菩提愿足。如是之人身如无价珍。乃至过去未来现在。三世诸佛尽行此道。而得菩提名为解脱。断尽疑惑无分别心。清净语业说真实法。得一切智显现自然相。显现无文字无非文字。真实相说。菩提心相说。布施说平等无贪故。持戒说无诸染欲故。忍辱说心无嗔恨故。精进说无诸懈怠故。禅定说安住寂静故。智慧说善能拣择故。如是各各开说奢摩他三摩钵提禅那门。百千俱胝那庾多门。甚深无比旁生地狱诸有情等。闻说法音悉离诸恶趣。了知空无相无愿解脱。如是恭敬供养三业清净。尊重功德得心安乐犹如平地。一切声闻缘觉菩萨摩诃萨。昼夜恭敬甚深解脱最上第一。世尊如是说已。师子游戏菩萨摩诃萨。赞叹欢喜深生领解。尔时世尊。而说偈言

  汝与世间　　一切众生　　心无有二
  了诸法空　　而得菩提　　离贪嗔痴
  无令更作　　自性清净　　虚妄不生
  平等一心　　无有散乱　　求法有情
  当如是会　　观想幻梦　　了知不实
  趣佛菩提　　定知不远　　得如是道
  得而无得　　明而无明　　惟契如来
  智慧明了　　如是而知　　世间第一
  名大丈夫　　人皆敬仰　　始自回心
  亲近善友　　瞻仰承事　　无有懈怠
  渐渐增进　　了法性空　　勤修诸行
  更无退转　　生于胜处　　获得菩提
  禅定现前　　湛然不动　　亦不持戒
  亦不分别　　有戒无戒　　体性一故
  得菩提已　　心入佛乘　　安住法性
  体如虚空　　无有挂碍　　演说正法
  度诸有情　　平等一心　　与佛无异
  复有比丘　　贪着放逸　　不学圣道
  身心散乱　　一如狂人　　又似巫神
  昼夜常作　　三毒重罪　　愚夫凶恶
  性难调伏　　至极痴人　　终无利益
  亲近恶友　　耽恋五欲　　迷惑女人
  未曾暂舍　　彼人一心　　造破戒罪
  愚痴不觉　　毁尽尸罗　　破戒人中
  斯为第一　　于诸善道　　无毫发许
  力行阐提　　忿恨憍傲　　造罪毕已
  当受苦报　　于诸善法　　心不好乐
  闻音乐声　　欢喜踊跃　　心恋不舍
  朋习恶人　　身语不善　　随顺贪嗔
  共相娱乐　　渐渐游行　　至一聚落
  彼聚落中　　人多修善　　闻诵佛声
  不生敬仰　　唯寻恶友　　共造欲乐
  堕恶趣中　　失菩提路　　若阿阇梨
  比丘知识　　作诸功德　　求大乘行
  闻小法音　　不乐亲近　　常行忍辱
  无憍慢心　　远访法师　　精求妙法
  持陀罗尼　　秘密章句　　书写经卷
  无数百千　　智慧发明　　欢喜踊跃
  如是之人　　得佛功德　　与佛无异
  经俱胝劫　　更无退转　　安住佛道
  湛然不动

尔时师子游戏菩萨摩诃萨白佛言。世尊。我等今者。闻佛所说甚深妙法。得未曾有心生欢喜。瞻睹威光遵仰慈诲。誓勤熏习无敢懈怠。有乐法者随为开说。是时复有天龙夜叉乾闼婆阿苏罗迦楼那紧那罗摩睺罗伽。与其眷属及世间众生皆来亲近供养恭敬。尊重礼拜咸来解脱。复有八千天子。与其眷属舍天快乐来诣佛所。听闻妙法而求解脱。复有二千药叉。与其眷属舍除暴恶。皆发阿耨多罗三藐三菩提心。复有三千大龙。亦与眷属发菩提心。来诣佛所希求出离。复有五百比丘尼众。皆来亲近恭敬礼拜。尊重赞叹欢喜踊跃。听受教法求菩提道。复有二千俱胝菩萨摩诃萨众。闻佛说法除障解脱。尔时世尊。告师子游戏菩萨言。善男子。我昔与汝。于然灯如来应供正等正觉所。闻说法要修忍辱行。安受苦忍无有缺犯。诸恶不生具足圆满。复闻演说六波罗蜜。所谓布施波罗蜜。持戒波罗蜜。忍辱波罗蜜。精进波罗蜜。禅定波罗蜜。智慧波罗蜜。因是得闻最上妙法。增长善根得不退转。由于彼时闻佛教法。勤行精进证于道果。获大人相尊重佛法。常当供养十方诸佛及大菩萨。事善知识了法性空。得正念现前。善男子。汝又于过去无数阿僧祇劫。有佛出世。号须弥王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛寿命无量百千俱胝那庾多岁。世界名曰琉璃金光。其佛国土地平如砥。金银琉璃[王*車]璖码瑙。众宝合成而严饰之。无诸秽恶瓦砾荆棘。善男子。尔时彼佛会中有八十百千俱胝那庾多比丘。皆是阿罗汉。一切漏尽无诸结使心得解脱。复有无数百千比丘尼众。复有无数百千优婆塞众无数百千优婆夷众。俱来会集。善男子。时彼世尊。说法教化三乘众生。为诸声闻说四谛法。为诸缘觉说十二因缘法。为诸菩萨说六波罗蜜法甚深微妙诸善法要。令诸大众安住法中各得解脱。善男子。时彼琉璃金光世界宝地平正。多诸宝树行列道侧。金绳界道宝网交络。微风吹动互相掁触。出微妙音声。其声演说诸法无常苦空无我。诸妙法音。所谓空声无相声无愿声。不生声不灭声。无色声无性声。其中众生闻是种种微妙音声。心生欢喜各得解脱。善男子。汝于彼须弥王如来应供正等正觉清净法中。而作比丘名曰劝慧。爱乐正法求佛种智。无诸贪欲戒根清净。心常欢喜赞叹大乘。昼夜勤修恭敬供养。有来求法随为演说不生悭吝。种种开说令其解脱。心无希求安住平等。具足善根满菩提愿。善男子。时彼比丘为求法故。乐诵经典增长智慧。归命大乘无量功德。复事阇梨知识。尽劫供养曾无懈倦。多诸方便安乐一切。善男子。彼劝慧比丘。为利众生舍离旧止游诸聚落。次第循门而行乞食。其中众生清信男女。有来亲近。生敬重心种种供养。劝慧比丘为说法要。忍辱禅定功德难量。令其信解坚固道意。彼聚落中。复有一类下劣众生。见僧恐怖意不乐见避走远去。以其过去恶业因缘。譬诸禽畜无有异也。时劝慧比丘。见彼恶人心生慈愍。不惮辛勤渐次亲近。开诱示导为说法要。各各省己悔过归命三宝。善男子。时劝慧比丘旧住精舍。善友知识各相谓言。彼劝慧比丘。宿植善本深达法要。于其众中而为上首。今以何缘舍离精舍。远游聚落极受勤苦。教化众生而行乞食。我等比丘心生忆念。相率远去迎请归还。到于彼处遥见劝慧。咸生欢喜各各问讯。起居轻利善住安隐。我等今者远来寻访。愿还旧居。依时供养精妙饮食香华灯果长时无缺。唯愿慈悲同归旧止。是时劝慧比丘。不受其请乐居寂静。复舍聚落远行前去。遇一兰若屏弃诸缘。寂然安住精修苦行。积集功德种智增明。劝慧比丘。复于一时不乐兰若。又入深山人所不到。叹羡此境堪可安居。精持结夏修习禅观遵佛禁制。然于此中多诸走兽。虎狼师子野干飞禽皆来亲近。衔华献果种种供养。时彼劝慧心生欢喜。转更精勤无诸退转。善男子。往昔世中一类比丘。于佛教法不生爱乐。不修梵行。不护尸罗。毁谤大乘。虚食信施。无有惭愧。远善知识。常党恶人。上品贪毒人皆避见。愚痴恶作失袈裟服。堕在地狱九十俱胝百千劫受大苦恼。毕是罪已。复受六十百千俱胝劫苦中极苦。不可比喻。后遇劝慧比丘。种种开示。说有如来应供正等正觉。清净教乘令生信解。善男子。劝慧比丘。又复阿閦如来应供正等正觉。于彼法中亦作比丘。欣乐正法求佛智慧。用真实心供养恭敬。尊重佛法书写经典作诸功德。心无懈怠近善知识。多诸方便发欢喜心。劝化有情令皆出离。时诸众生欢喜敬仰。善男子。时彼如来复为劝慧比丘。说诸法要令增种智。苦恼不生贪嗔不作。不随恶友堕诸恶趣。防护自身无诸过咎。一心供养讲说正法。昼夜常持清净法宝。渐次增进无有退转。善男子。当尔之时三千大千世界众生。闻佛所说行十善业安住法中。一切菩萨行六波罗蜜。具足功德安乐一切。尔时佛告师子游戏菩萨言。彼时劝慧比丘者。今汝身是也。

佛说大乘随转宣说诸法经卷上佛说大乘随转宣说诸法经卷中

        宋明教辩才法师充译经三藏沙门绍德等奉　诏译

尔时文殊师利童真菩萨白佛言。世尊。云何离除业障得清净心。佛告文殊师利。要离恶业当学一切法了知诸法。分别心生虚妄不实。空智现前业障自除心得清净。复次文殊师利。一切众生。从无始劫来妄想颠倒。贪嗔痴三为因。造杀盗淫业无量无边。堕落诸趣轮回生死。受大苦恼无有休息。业障炽盛恶魔娆恼。故心不得清净。复次文殊师利。汝今欲知一切众生离诸业障心得清净。当学如来一切法。于身口意三业清净。昼夜精勤修持梵行远离苦恼。分别不生希求菩提。恭敬供养佛法僧宝。长时诵习大乘经典秘密陀罗尼。身心坚固无有退转。观想了知生住异灭。念念无常刹那生灭。一切虚妄无有真实。安住禅定渐渐增进心无散乱。一切恶魔不得其便。自然快乐意地发明。积诸功德滋长慧命。证佛菩提无上道果。是名出家。是真佛子。乃知如来甚深法藏广大如海。饶益有情无有穷尽。得无上法宝。复修禅定观想法空。无诸苦恼获功德力。行平等行心常护持。昼夜恭敬尊重赞仰。一切解脱身心快乐。了知生灭一切皆是幻梦。安住法中生于胜处。具足圆满更无退失。如是而修恶业自除心得清净。尔时文殊师利童真菩萨白佛言。世尊。云何四圣谛。佛告文殊师利。四圣谛。谓苦集灭道。是名四圣谛。文殊师利白佛言。世尊。当云何学。佛言。当学一切法得彼法智现前。于此分别不生。善与不善。观想自性清净。了知一切悉皆虚妄。文殊师利白佛言。一切众生云何不学。佛言。愚夫异生为毁谤教法。不生善心。不修梵行。不读诵经典。不受教诲。于佛教法不肯少学。常作恶行流浪三界而生欢喜。即不知一切法如幻如梦如阳焰虚妄不实。若诸众生学一切善法。修习奢摩他定。观想自性清净。了知贪嗔痴悉皆虚妄。安住法中得彼定力身心快乐。愚夫不学善法。不知有佛法僧宝。普遍虚空微妙难见。文殊师利白佛言。云何此法微妙众生难见。佛告文殊师利。此法如风生浪起。只见浪起不见风生。唯汝文殊须菩提能知。余皆不解。尔时文殊师利白佛言。世尊。云何四念处。佛言。文殊师利。四念处。谓观身不净。观受是苦。观心无常。观法无我。是名四念处。文殊师利言。当云何学。佛言。一切众生。当观想自身五种不净。观受有苦受乐受舍受三悉皆是苦。观心无常念念无常刹那生灭。观法无我四大五阴无实我体。是名四念处。一切众生当如是学。文殊师利白佛言。世尊。云何五根。谓信进念定慧。是名五根。文殊师利白佛言。当云何学。佛言。学法众生于一切法中观想此法深远。能生信故名信根。了知此法勤行精进。除障解脱名精进根。然于此法一心想念不忘名念根。了知一切法定知心生名定根。以慧拣择一切法空名慧根。是名五根。文殊师利白佛言。世尊。云何七觉支。佛告文殊师利。念觉支。择觉支。精进觉支。喜觉支。轻安觉支。定觉支。舍觉支。是名七觉支。文殊师利白佛言。世尊。当云何学。佛告文殊师利。学法众生于自性中。了知一切善不善法。弃舍世缘勤念正法。名念觉支。择谓以自性智于三界能拣择。故名择觉支。精进谓了知一切法勤行不舍。名精进觉支。喜谓于一切诸行发生昼夜喜行妙性快乐欢喜。故名喜觉支。轻安谓安住一切法中不为魔娆心得自在。故谓轻安觉支。定谓了一切法本无自性修三摩地。名定觉支。舍谓心安住一切法不住智不住佛舍离诸缘。名舍觉支。是名七觉支。文殊师利白佛言。世尊。云何八正道。佛告文殊师利。八正道。谓正见正思惟。正语正业。正命正精进。正念正定。是名八正道。文殊师利白佛言。世尊。当云何学。佛告文殊师利。彼一切众生。了知一切法三业恭敬。是名正见。彼于一切法。分别不分别喜不喜。名正思惟。彼了知一切法真实言说。名正语。彼于一切法了知唯造善业。名正业。彼于一切法安住平等真心。名正命。彼于一切法勤修大乘。名正精进。彼于一切法不生恶业。名正念。彼于一切法不散不乱。名正定。是名八正道。彼学法众生一心了知四圣谛四念处五根七觉支八正道。如是等法一一修学已得到彼岸生诸佛国。无有恐怖得金刚坚固心。一切罗汉声闻沙门婆罗门。及小婆罗门等。闻佛说此微妙最上法门有大神力。能除热恼获得心地清凉。诸比丘若能展转勤行心无退转与我无异。而诸天人昼夜作诸音乐。持众名香种种奇华。珍妙饮食堪受供养。文殊师利。彼诸比丘若不断嗔。入王城持钵循行乞食。为魔所恼染着诸欲。非佛弟子与俗无异。复有比丘心无嗔故。了知大乘微妙法行法义言句。于真实正行而得解脱。尔时三千二百天子。持天曼陀罗华种种名香上妙饮食。恭敬供养心大欢喜。互相赞叹出家功德。与如来佛国而无有异。尔时文殊师利白佛言。世尊。我闻佛说秘密陀罗尼章句云何。佛告文殊师利。我为汝说秘密句橛句金刚句慧句。是名陀罗尼章句法门。此法门菩萨得一切法句发生。刹那刹那得忍辱法。文殊师利言。云何名秘密句法门。佛言。我为汝说秘密句真实章句。于一切法中心爱乐秘密句为第一。如汝文殊师利。于一切菩萨中而得第一。秘密句亦复如是。复次文殊师利。秘密句如虚空。我身遍满虚空。一切法亦如是遍满虚空。一切菩萨现前不现前。都是一如。名真实秘密句。文殊师利白佛言。世尊。云何橛句。佛告文殊师利。我为汝说橛句。不动贪法界。住一切法动。我不动大乘。不作种种世事。是名橛句。文殊师利白佛言。世尊。云何金刚句。佛言。我为汝说金刚句。嗔众生长时有嗔。金刚能断一切法。是名金刚句。文殊师利白佛言。世尊云何慧句。佛言。我为汝说慧句。痴是学佛智。一切众生非学佛智不到彼岸。若诸众生学佛智一切慧具足。有慧无慧悉能了知。此是甚深。文殊师利。悉能了知众生无智但乐诸恶于一切法不能远离。是名秘密句。文殊师利白佛言。世尊。云何秘密句识。佛告文殊师利。识如幻化妄生一切法。空无自性无自相。如是五蕴如五指。不实如虚空。悉是假名。众生惛懵不能晓了。是名秘密句。文殊师利白佛言。世尊。云何秘密句色。佛告文殊师利。色一切法。众生心痴眼痴。毁谤正法不好勤学。爱乐于色不知虚妄。文殊师利。汝于色尘悉能了知。是名秘密句。文殊师利白佛言。世尊。云何秘密句声。佛告文殊师利。声空发生不可得见。种种语言音响之声。耳识听受。是名秘密句。文殊师利白佛言。世尊。云何秘密句香。佛告文殊师利。香发诸尘不可得见。但识所闻识亦无故皆是虚妄。是名秘密句。文殊师利白佛言。世尊。云何秘密句味。佛告文殊师利。味无自性妄生于舌。众生分别爱乐贪着。是名秘密句。文殊师利白佛言。世尊。云何秘密句触。佛告文殊师利。触本无故。观想一切法如虚空。众生愚迷于境于身。种种贪着以为妙触。是名秘密句。文殊师利白佛言。世尊。云何秘密句地。佛告文殊师利。地性质实于法思惟。无自体性亦无自相。众生颠倒妄执为有种种恋着。是名秘密句。文殊师利白佛言。世尊。云何秘密句水。佛告文殊师利。观诸水性犹如阳焰。虚妄不实故。是名秘密句。文殊师利白佛言。世尊。云何秘密句火。佛告文殊师利。火性猛烈苦恼众生。此法灭故自性寂静。分别不生最上极乐。是名秘密句。文殊师利白佛言。世尊。云何秘密句风。佛告文殊师利。风一切法不可得见。众生贪着动作往来风力所转。是名秘密句。文殊师利白佛言。世尊。云何秘密句佛亦如是。佛告文殊师利。一切不善法十方诸佛。各各开说教诏众生。是名秘密句。文殊师利白佛言。世尊。云何秘密句法亦如是。佛告文殊师利。一切法不可取不可舍。观想无我。无自相无自性。心不散乱。是名秘密句。文殊师利白佛言。世尊。云何秘密句僧亦如是。佛告文殊师利。彼无数妙住法界。于三摩地平等持戒。修平等慧平等解脱。于平等法中善安住故。余无所学。是名秘密句。文殊师利白佛言。世尊。云何橛句虚空境界。佛告文殊师利。一切法虚空境界。不思议境界。于诸境界不可取不可舍。不可住无有住处。是名橛句。文殊师利白佛言。世尊。云何橛句一切法住虚空。佛告文殊师利。一切法不离虚空。住不生烦恼。住寂静故。是名橛句。文殊师利白佛言。世尊。云何橛句一切法无分别心。佛告文殊师利。一切法不学不问。不作不亲近。不发愿不生爱乐。寂静如虚空。是名橛句。文殊师利白佛言。世尊。云何橛句一切法微妙。佛告文殊师利。一切法离垢安住清净。光自在妙圆满清净。虚空圆满清净。发生微妙身安住于法。是名橛句。文殊师利白佛言。世尊。云何橛句一切法安住虚空。佛告文殊师利。一切法安住虚空不可见。一切法离垢安住亦不可见。是名橛句。文殊师利白佛言。世尊。云何橛句一切法教诏学。佛告文殊师利。一切法教诏众生。不来勤学。不学观想。不作意。昼夜六时不学。又不问邻座不会解释。不能宣说无有智慧。不能分别亦不爱乐。不亲善友我慢贡高。远离教诏不得解脱。是名橛句。文殊师利白佛言。世尊。云何橛句一切法最上远离。佛告文殊师利。一切众生于诸善法而不肯学。唯造罪恶不亲贤善无有智慧。是名橛句。文殊师利白佛言。世尊。云何橛句众生难教诏。佛告文殊师利。若诸众生心不散乱。唯勤学法亲近供养。自然往诣教诏求法福慧乃生。若众生不学一切法。唯造恶业欲求福慧无有。是名橛句。文殊师利白佛言。世尊。云何橛句众生得一切智。佛告文殊师利。一切众生勤求学法得一切智。发欢喜心生大乘行。明了自性得一切智。是名橛句。文殊师利白佛言。世尊。云何橛句众生得一切智智具足。佛告文殊师利。一切众生自性。自性中于如来平等一切智慧。悉皆晓解一体性相。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生菩提道场。佛告文殊师利。菩提道场唯求佛法。一切法寂静道场。一切法性道场。一切法求道场。文殊师利。言菩提道场我一心。求法不求余相。一切众生一切人民。常乐往彼求此菩提道场。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生得此忍辱。佛告文殊师利。学法众生。息念观想净慧发生。于诸名相不生分别。得忍辱平等。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生善友说法。佛告文殊师利。一切众生与十方天人诸小天人。各各说法希求菩提。心生欢喜供养恭敬。除障平等于无体相安住。是名橛句。文殊师利。白佛言。世尊。云何橛句一切众生得此陀罗尼。佛告文殊师利。一切众生学观想色声香味触。任持甚深圆满分别圆满不分别。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生慈心具足。佛告文殊师利。一切众生乐修慈心。了知一切法得平等慈。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生悲心具足。佛告文殊师利。一切众生勤学如来平等大悲心。大悲体具足。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生不得三摩地。佛告文殊师利。一切众生不修禅不乐不喜。妄语颠倒性恶刚暴。多诸障碍非有智慧。无刹那顷爱乐禅定。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生贪具足。佛告文殊师利。一切众生贪爱具足。烦恼多生无欢喜心。不乐寂静不行平等。而于贪性无有觉悟不得菩提。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生嗔具足。佛告文殊师利。一切众生嗔具足安住。嗔体性安住。悉皆具足。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生痴具足。佛告文殊师利。一切众生不求佛法。一切慢一切行非梵行。痴平等住痴体性住。不学菩提。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生痴身具足。佛告文殊师利。一切众生身住痴一切法。不诵经典不信不读。性恶憎嫌不乐大乘。安住最上不善。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生邪见具足。佛告文殊师利。一切众生邪见。归依十身佛。不真实归依。常作十恶行十邪见。不悟邪见体性爱乐。安住五欲中。安住贪嗔痴中。安住障不得菩提。是名橛句。文殊师利白佛言。世尊。云何橛句一切众生住处听法。佛告文殊师利。一切众生。一心恭敬听受。当为汝说。一切众生真实求法。一心不动不生怕怖。佛福广大愚夫不知。我有真实言教。不生恭敬。不安住听受。贪平等住。嗔平等住。痴平等住。五欲中平等住。障难平等住。爱乐平等住。不赞叹佛。有如是无上正等正觉。如是贪体性安住。嗔体性安住。痴体性安住。五欲中体性安住。障难体性安住。爱乐体性安住。不赞叹佛。有如是无上正等正觉解脱。佛告文殊师利。汝若不问不为汝说。汝今问我当为汝说。一切善法当学。如来正等正觉一切善法平等具足。如是师僧善友欢喜。学大乘教。行大乘行。有大势力。舍离于此更无余事。专心发愿求法最上。精勤专心观想五智如来境界。如来境界无别境界。一切境界平等。昼夜如是学法一心供养。文殊师利。若诸众生作如是求法。得佛菩提了知善法。一切善法具足如是。若不学佛法。与诸禽畜实无有异

佛说大乘随转宣说诸法经卷中佛说大乘随转宣说诸法经卷下

        宋明教辩才法师充译经三藏沙门诏德等奉　诏译

尔时莲华游戏天子与十千天子。皆来供养世尊及文殊师利菩萨。各持上妙名华。优昙钵罗华。青色莲华。白色莲华。曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。发恭敬心。种种语言欢喜赞叹世尊文殊师利。不好世乐超出三界。心无烦恼亦无诸恶。语言真实甚深真实。法界吉祥。真实吉祥。微妙吉祥。无数最上第一吉祥。天子。如是赞叹世尊文殊师利。尔时佛告莲华游戏天子。诸天子中汝得第一。天子于身内外心无分别。得最上第一法。众中最上第一。微妙第一。极妙第一。真实心处大众中。能最上供养而得第一佛言。天子。汝无贪嗔痴。不生烦恼。若有如是与愚夫不异。若天子。不得学斗战失菩提路。若爱乐一切法菩提萨埵佛法。乐修十地行。如是天子。宿种善根恭敬供养诸佛菩萨。远离诸恶心放光明。勤学佛法。于十地行妙安住故示现光明。学佛教法勇猛爱乐。若不如是好乐佛法多诸诤讼。不生供养心智慧鲜薄。如是天子。心高我慢。不爱乐一切法。不亲近善友。此天子。为众所嫌。于菩提而不和合。无恭敬心轻慢三宝。不学教法愚夫无异。菩提道场甚深恭敬。求一切智具足。得天子行于善众安住。彼诸天子。不住贪。不住嗔。不住痴。不恋资生。不行邪见。恭敬问讯世尊文殊师利。礼拜供养。于贪嗔痴悉皆远离。世尊如义而说。天子爱乐如义而住。是时世尊赞叹文殊师利。安住大乘不行邪行。亦无邪见。诸天子闻佛说已往诣文殊师利所。称赞供养学一切法。圆满无分别无有邪行。尔时十千天子。闻佛于大众中说无生忍辱法安住。于此皆修文殊行得最上妙法。于金刚句。秘密句。橛句。了色本空。体性不邪。无有诤讼。得菩提解脱法已。恭敬供养修习禅定。任持读诵宣说书写。如是熏习五法。人皆欢喜三业清净。于一切法一切佛法。圆满宣说得安乐行。尔时佛告莲华游戏天子言。如是声色。今世后世无智菩萨。不乐佛法贪恋外声外色。不怕不怖。于一切声爱着迷惑无有福德。世尊如是说。莲华游戏天子赞叹。于虚空中往来。种种变化诸妙音声。宿世善根福业所作。得佛菩提生上种姓。礼貌具足圆满福业。了悟色声一切具足。世尊记言。汝当生天子。菩萨摩诃萨真实殑伽沙劫。尊重法师恭敬供养。一切安乐衣食卧具饮食汤药。如是种种上妙香华灯涂。昼夜不绝一切具足。安住法中决定求得上妙福报无诸忿怒。如是天子。了悟色声速得往诣。菩萨殑伽沙劫一切安乐。彼天子。于殑伽沙劫不生烦恼心无轻慢。圆满言说法味真实。如是天子。生决定心闻佛法音。了悟声色无诸苦恼亦无毁谤。欢喜赞叹得一切最上安乐。佛言。天子。今一切人不求佛法。贪恋资生不怕不怖。不似娑罗王世人善根成熟。世尊如是说已。莲华游戏天子闻是法音。了色体性深入佛慧。若诸众生。不学佛法不修禅定。于一切法不好不问非菩萨行。常作恶想不学正智。闻女人声爱乐贪着不怖罪业。世尊说已。莲华游戏天子言。诸菩萨天子。身心散乱不受世尊教学。三业不善毁谤听法。贪声住。嗔声住。痴声住。不近善友不学佛法。贪着女人无有厌足。不学欢喜声。爱乐欲乐声。喜听恶人声。不学好人声。不学书写声。不学佛声。贪着女色常如醉人。不学安乐声。不学出家声。爱乐无佛慧声。喜闻外道声。恋女人声。不学佛法布施声。不学佛法持戒声。不学佛法忍辱声。不学佛法精进声。不学佛法禅定声。不学佛法智慧声。恋女人声。远寻放逸亲近恶友不学善人声。恋世间声。昼夜不舍不得涅槃。恋着女人不学佛法不得解脱。转寻乡村聚落从生恋着。常与女人共相娱乐。不亲善友。不行大乘行。不行比丘行。不行在家正行。唯行邪道。只于女人路行。听女人声心生欢喜。闻佛音声不生敬仰。不修梵行安住烦恼。娆乱众人修外道行。无福果报。不学持戒行。恋破戒行。体性下劣。恋下劣体性。不亲善友不学佛法。恋着贪不学佛法。恋着嗔不学佛法。恋着痴不学佛法。愚昧不会不受教诲。其心壅塞不能领解。不学诸佛行。不学菩萨行。不学声闻行。于佛菩萨法不问不学。业障深重远离而去造不善业。贪恋女色心迷自作烦恼憔悴。不信真实菩提。展转远离。一切人嫌。如是之人贪着女色不得安乐。亦不寂静。不礼拜不恭敬。自不觉知不得菩提。若菩萨天子。勤修十善真实圆满。积集善根心中欢喜。此菩萨天子。往诣博学多闻菩萨天子所。修一切善根圆满具足。离除业障心得清净。除业障已。身心轻安远离诸欲。昼夜更无女人想。安住法性。尔时文殊师利童真菩萨白佛言。世尊。诸佛法海无有边际。不可观见微妙色相。不可听闻微妙音声。欢喜微妙音声。极喜微妙音声。一心专住修微妙佛性。远离障染。到于彼岸安住于法。不住涅槃不住聚落。不去不来。无布施持戒忍辱精进禅定智慧。无有忿怒无贪嗔痴。悉皆平等。世尊。如义而说真实微妙法门。佛言。莲华游戏具大智慧天子。文殊师利童真菩萨。是二大士宿种善根。于过去无量无数阿僧祇劫诸佛国土。听受教法修大乘行。断诸业障宿福深厚。积集功德无量无边。过去因缘获斯福报。今此会中实无有对。如是莲华游戏天子。远离色声用真实心。以上妙种种香华灯烛珍妙饮食供养。人皆不及。亲近佛声。听文殊师利演说甚深平等真实法门。尔时佛告文殊师利童真菩萨言。汝往昔劫于我法中。了如是色声最上色相。一切业障悉皆远离。安住福业万德圆备。余皆不及。乃至过去菩萨亦皆不及。文殊师利言。如是色业障嗔业障。一切恶业障我已了知。悉当远离决定守护。亲近世尊如是说离一切染法。得清净福业心无烦恼。是我宿生于无量无边阿僧祇劫。发广大心修作福业。思惟圆满善行具足。乃过去修习今时受报。得值师子鼓音自在王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛寿命无量百千那庾多岁。三界众生了知圆满。世界名曰大光。其佛国土多诸宝树。金绳界道宝树行列。香风吹动枝叶掁触出妙音声。其声演说空声无相声无愿声。不生声不灭声。无色声无自性声。如是音声众生闻已皆得解脱。时彼如来有二十七俱胝声闻众。皆来听法。大比丘众断诸烦恼去除重担。得慧解脱心解脱。是比丘心不散乱。往来听法求佛菩提。彼如来复有二十七俱胝众及大比丘众皆来听受荷担如来尊重教法。得慧解脱心解脱。如是他方菩萨皆来听法。各各得一切忍辱法具足安乐。如是十方诸佛国土。无数百千俱胝佛皆来听法。闻阿难多目佉陀罗尼三摩地。无数百千那庾多众生。得寂静安乐心生欢喜共相论议。乃至宿世今生无有他求。决定安住菩萨摩诃萨。是时如来于彼国土宣说妙法。一切毕已。正法住世六十百千岁。时彼如来复为寂静诸根菩萨。说一切菩萨法。人所赞叹心无外缘。此菩萨往昔劫中。修菩萨法净道行住。不乐世间一切法。诸根不乱甚深解脱。真实最上妙法了知。色相言说欢喜踊跃。专心书写。与善知识共相论议。非人不言恐生诽谤。然彼众生。贪体性一切法住着。嗔体性一切法住着。痴体性一切法住着。此菩萨唯爱乐一切佛法。不乐世间一切法。非众生方便爱乐。唯乐菩提行。种种善行。无分别心。常行忍辱。无贪无嗔。无是无非。安住如来甚深法界。尔时复有比丘。名曰胜意。爱乐菩提。是时世尊。为说一切妙法。得四禅定四无色定。十二头陀功德。常行是行。尔时佛告胜意比丘。寂静诸根菩萨。了知一切最上行。胜意比丘闻佛所说。合掌听受。远离远处寂静安住。修一切最上行。尔时寂静诸根菩萨。发广大无边心。王城持钵引导众生循门教化。乞食诣长者居士善友门化。有智慧人心生欢喜供养赞叹。或有居士善友恶言毁谤。不生恶念少语知足真实言行。心不嗔人和颜悦色。彼居士善友赞叹。时寂静诸根菩萨说诸色法。诸比丘僧多不了知。入诸邪见僻居小处。贪慢障安住。嗔慢障安住。痴慢障安住。一切法爱乐障。不听真实言行。寂静诸根菩萨。复劝在家居士善友。不得贪烦恼。不得造诸恶业。居士善友。不能行得忍辱行。自往诣贪处。自往诣多贪处。往诣东西南北方四维上下方。生五种毁谤。云何谓爱乐贪嗔痴。心多烦恼故。时寂静诸根菩萨。于王城中游行教化。与居士善友言。赞叹胜意比丘。是真实僧人皆供养。今不住王城归寂静处安住。及不乐寺院香华供养。诸比丘僧多不喜见。此胜意比丘真善知识。诸比丘僧深入邪见。贪心障嗔心障痴心障。不能远离诸恶业障。复次寂静诸根菩萨言。诸比丘僧不学善法。不习一切观想。不学甚深妙法。不求菩提。尔时寂静诸根菩萨。为比丘僧。而说伽陀曰

  若有贪嗔痴　　不修菩提行
  菩提无贪性　　一切当远离
  愚夫不觉知　　耽着诸欲乐
  非寂静禅那　　不能趣佛国
  高傲于放逸　　功德无少分
  诸佛清净戒　　而生疑惑心
  贪恋造诸恶　　无佛法僧宝
  设若学文字　　心中多巧妙
  于真实菩提　　云何得解脱
  丈夫学菩提　　无烦恼分别
  亲近佛观想　　得正见具足
  于法不能解　　众生堕邪见
  远离佛教法　　安住贪嗔痴
  不恭敬礼拜　　不亲近法师
  苦恼生分别　　无有忍辱心
  迷惑不自知　　愚痴作诸恶
  去佛道甚远　　不受人劝化
  疾速得菩提　　若人有忍辱
  平等解脱界　　超出世间眼
  一切悉智见　　观想忍辱法
  而得佛菩提　　于此安住故
  决定无魔事　　禅定力现前
  如是解脱已　　趣佛涅槃界
  众生勤学法　　实不可称量
  得不生不灭　　无贪嗔痴故
  历游诸聚落　　亦无分别心
  若有人毁谤　　不生嗔恨故
  或遇人赞叹　　亦无欢喜故
  安住佛菩提　　一切悉平等
  佛法如虚空　　不可称量故
  无上佛菩提　　愚夫不了悟
  不修寂静观　　于此不解脱
  众生贪放逸　　无心学圣道
  驰骋诸欲乐　　与狂人无异
  愚痴不寂静　　不肯学菩提
  云何离业障　　众生若了知
  远离诸欲乐　　专心习禅那
  众中为上首　　晓解一切法
  而行于正道　　常念佛菩提
  更无分别想　　真实心爱乐
  最上菩提道　　龙天皆欢喜
  安住佛功德　　于微妙法中
  不生诸恶想　　唯求佛菩提
  更不学余事　　故于此会中
  德行为上首　　我闻佛所说
  种种学外道　　营务作事业
  不如佛法中　　熏习诸善本
  彼爱乐眷属　　及贪恋资生
  不求佛菩提　　好世间荣贵
  无有刹那顷　　学如来正法
  多生分别心　　安住诸欲乐
  欲性本虚妄　　如阳焰空谷
  愚痴都不觉　　心常生我慢
  不赞佛菩提　　实无有知见
  不了法空义　　坚固执为有
  有为及无为　　一切悉平等
  众生若晓了　　勤修大乘行
  趣佛菩提道　　此非是凡夫
  安住于法中　　得诸佛心印
  圆满功德业　　与佛无有异
  一念贪心起　　犯波罗夷罪
  贪心若不断　　为之所缠缚
  不肯护尸罗　　无禅定观想
  见佛不欢喜　　长夜造诸恶
  堕入地狱中　　受俱胝劫罪
  由是破戒故　　少法亦不解
  云何得菩提　　与愚夫无异
  说若修福业　　其心不淳净
  不修大乘行　　无禅定观想
  此人如何得　　无上法王印

尔时寂静诸根菩萨。为比丘僧说此偈已。三千二百天人得忍辱法。八万比丘闻法各得解脱。彼胜意比丘。得三业清净离除业障。尔时文殊师利白佛言。世尊。如来宣说甚深法义。昼夜思惟。如来一切法十号功德愚夫难可称量。如来无生忍辱法亦难可称量。如来所说法义不可思议。与我心法义都是一说。尔时文殊师利菩萨。慈氏菩萨摩诃萨白佛言。世尊。如来真实法义。后五百岁人多不信不怕不怖。乃至诸天亦复如是。我决定亲近供养如来法义。以身命布施如殑伽沙数。赞叹咏歌三时供养。于殑伽沙世界法义安住复说。如殑伽沙众生声闻得忍辱法安住法义。尔时尊者阿难。闻佛一切法义。信受任持誓愿展转为人宣说。时文殊师利菩萨。慈氏菩萨。师子游戏菩萨。莲华游戏菩萨。真实大菩萨众。与无数比丘僧尊者阿难。一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜作礼而退

佛说大乘随转宣说诸法经卷下


佛说大乘造像功德经

    No. 694

佛说大乘造像功德经卷上

        大唐于阗三藏提云般若奉　制译

如是我闻。一时佛在三十三天波利质多罗树下。与无量大比丘众及无量大菩萨众俱。弥勒菩萨摩诃萨而为上首

尔时世尊在彼天上。三月安居为母说法。于诸天众多所利益。令无量诸天离苦解脱。无量诸天皆蒙法利获大福果。时彼众中有一天子。寿将欲尽五衰相现。以闻法力命终之后还生此天永离恶道

尔时阎浮提中无有如来。譬如暗夜星中无月。如国无君如家无主。欢娱戏乐一切都息。是时众生孤独无依。皆于如来心怀恋慕生大忧恼。如丧父母如箭入心。共往世尊曾所住处。园林庭宇悉空无佛。倍加悲恋不能自止

尔时优陀延王住在宫中。常怀悲感渴仰于佛。夫人婇女诸欢乐事皆不涉心。作是念言。我今忧悲不久当死。云何令我未舍命间得见于佛。寻复思惟。譬若有人心有所爱而不得见。见其住处及相似人或除忧恼。复更思惟。我今若诣佛先住处不见于佛。哀号感切或致于死。我观世间无有一人能与如来色相福德智慧等者。云何令我得见是人除其忧恼。作是念已。即更思惟。我今应当造佛形像礼拜供养。复生是念。若我造像不似于佛。恐当令我获无量罪。复作念言。假使世间有智之人。咸共称扬如来功德犹不能尽。若有一人随分赞美获福无量。我今亦然当随分造。即时告敕国内所有工巧之人并令来集。人既集已而语之言。谁能为我造佛形像。当以珍宝重相酬偿。诸工巧人共白王言。王今所敕甚为难事。如来相好世间无匹。我今何能造佛形像。假使毗首羯磨天而有所作。亦不能得似于如来。我若受命造佛形像。但可摸拟螺髻玉毫少分之相。诸余相好光明威德谁能作耶。世尊会当从天来下。所造形像若有亏误。我等名称并皆退失。窃共筹量无能敢作。其王尔时复告之曰。我心决定勿有所辞。如人患渴欲饮河水。岂以饮不能尽而不饮耶。是时诸人闻王此语。皆前拜跪共白王言。当依所敕。然请大王垂许我等。今夜思审明晨就作。复白王言。王今造像应用纯紫栴檀之木文理体质坚密之者。但其形相为坐为立高下若何。王以此语问诸臣众。有一智臣前白王言。大王当作如来坐像。何以故。一切诸佛得大菩提。转正法轮。现大神通。降伏外道。作大佛事。皆悉坐故。是以应作坐师子座结加之像

尔时毗首羯磨天遥见其事。审知王意欲造佛像。于其夜中作是思惟。我身所解最为巧妙。世间之中无如我者。我若为作应少似佛。即变其身而为匠者。持诸利器至明清旦住王门侧。令守门人具白王言。我今欲为大王造像。我之工巧世中无匹。唯愿大王莫使余人。王闻此语心大欣庆。命之令入观其容止知是巧匠。便生念言。世间之中何有此人。将非毗首羯磨天。或其弟子而来此耶。王于尔时即脱身上所著璎珞。手自捧持以挂其颈。仍更许以种种无量诸珍宝物。时王即与主藏大臣。于内藏中选择香木。肩自荷负持与天匠。而谓之言。善哉仁者。当用此木为我造像。令与如来形相相似。尔时天匠即白王言。我之工巧虽云第一。然造佛形相终不能尽。譬如有人以炭画日言相似者无有是处。设以真金而作佛像亦复如是。有外道言。梵王能作一切世间。然亦不能造佛形像尽诸相好。但我工巧世中为上。是故我今为王作耳。今晨即是月初八日。弗沙宿合毗婆诃底出现之时。佛初诞生还有此应。此日祥庆宜应起作。发是语已操斧斫木。其声上彻三十三天至佛会所。以佛神力声所及处。众生闻者罪垢烦恼皆得销除。尔时如来即便微笑。种种叹美其王功德。乃至遥授阿耨多罗三藐三菩提记

尔时三十三天主白佛言。世尊。今在人间颇亦有人。曾于曩生作佛像不。佛言。天主。诸有曾经作佛像者。皆于过去先已解脱。在天众中尚复无有。况于余处。唯有北方毗沙门子那履沙婆。曾于往昔造菩萨像。以斯福故后得为王。名频婆娑罗。复因见我今得生天。有大势力永离恶道。优楼频螺迦叶。伽耶迦叶。那提迦叶。并曾于往世修故佛堂。由此因缘永得解脱。憍梵波提昔作牛身追求水草。右绕精舍食诸草竹。因见尊容发欢喜心。乘兹福故今得解脱。尸毗罗曾持宝盖供养佛像。阿[少/兔]楼[馬*犬]然一支灯亦以供养。输鞞那曾扫佛堂。阿婆摩那于佛像前燃灯施明。难陀比丘爱重尊仪香水洗沐。有如是等无量诸阿罗汉。皆悉曾于佛像之所薄申供养。乃至极下如那伽波罗。于像座前以少许黄丹画一像身而为供养。由此福故皆永离苦而得解脱。天主。若复有人能于我法未灭。尽来造佛像者。于弥勒初会皆得解脱。若有众生非但为已而求出离。乃为欲得无上菩提造佛像者。当知此则为三十二相之因。能令其人速致成佛

尔时优陀延王心自思惟。云何令我所造之像速得成就。作是念已语彼匠言。汝可勤心令功速毕。使我早得瞻仰礼敬。是时天匠运其工巧。专精匪懈不日而成。其像加趺坐高七尺。面及手足皆紫金色。时优陀延王见像得成相好端严。心生净信获柔顺忍。既得忍已益加欣庆。所有业障及诸忧恼并得销除。譬如日出雾露皆尽。唯除一业现身受者。以曾于圣人起恶语故。其王尔时即以种种殊珍异物赏彼天匠。是时天匠敬白王言。王今造像我心随喜。愿与大王同修此福。今王所赐非我敢受。若要相与待余吉日。作是语已即于其夜还升本天

尔时诸大国王阿阇世等。并先于佛心怀渴慕。闻王造像功已获成。皆生喜庆共至王所。各以无量花香音乐供养佛像。复以种种诸珍宝物赠奉于王。咸作是言。大王所作甚为希有。能拔我等愁忧毒箭

尔时如来在彼天中为母说法。及诸天众咸得利喜。所应作事皆已作讫。复告众言。诸天子。诸佛世尊是常住身。若诸众生有可度者。即为出现教化说法。若所作事毕。更无有能受法化者。如来于此即便不现。无智之人谓佛实灭。如来身者法身常身实不灭度。诸天子。一切诸佛法皆如是。为化众生有现不现

尔时如来复作是言。汝等当知。此诸天众所应度者皆已度讫。吾今将欲下阎浮提。汝等诸天若念我者。当勤精进勿复放逸。所以者何。放逸过失故。令汝等不得阿耨多罗三藐三菩提。然汝等以于往昔曾种善根。今得在此受天快乐。便着放逸不修福行。此诸快乐无常所随。一从陨坠长沦恶道。又汝等诸天烦恼尤重。见有胜己便生嫉妒。曾不念言彼天胜乐由多福业之所感致。我若勤修必亦当得。又今汝等身色光泽如日初辉。若怀嫉妒心黯如死炭。复当令堕大黑闇中。乃至不能自见手掌。后复当作食吐之鬼。又汝等诸天受众福报。身相严洁威势勇猛。由嫉妒故当受女身。永失丈夫威猛之力诸天子。我念昔者有无量诸王。皆为汝等嫉妒之心非理所害。诸天子。昔有阿修罗王名曰邬罗。修行苦行戒品清洁。而汝诸天等遣一天女名邬婆尸。惑彼王心令亏净行。其王染着威德损减。被那罗延天之所杀害。并无量阿修罗众同时败灭。其那罗延天既杀此王又诛其众。困即收取邬婆尸女而往天宫。复有一王名曰那诃受。汝等诸天诳惑之语。助诸天众伐阿修罗。修罗破已。汝等诸天反加其害。又汝等诸天以舍支夫人故心生忿妒构行谗毁。令阿伽娑仙人无故被嫌而兴恶愿。又汝等诸天曾为诳惑。谓曀荼王曰。仙人之处多有真金。王信此言。逼之令出。仙人由是心生愤恚。即时猛火烧杀其王。昔复有王名曰提婆。尝设大会。以为供养。以斯福业威力自在。上此天中受天快乐。汝诸天等心怀嫉妒。令从忉利退堕阎浮。所有威势并皆丧失。如月无光。如河无水。诸天子。世中有人威德自在。或得诸定。或得神通。或有成就四神足等。若起一念嫉妒之心。如是功德一时退失。如提婆达多愚痴厚重。乃于我所生嫉妒意。即时自失五种神通

尔时天帝释白佛言。世尊。我今有疑欲有所问。言嫉妒者云何是耶。复作是言。世尊。若有众生见他胜己生如是念。云何令我获彼所得。如是之心。是嫉妒不。佛言不也。此是贪心非为嫉妒。天主其嫉妒者。自求名利不欲他有。于有之人而生憎恚是为嫉妒。尔时诸天众皆从座起。右膝着地合掌向佛而作是言。如佛所诲我诸天众皆当奉行。如来世尊为父为主。为尊重者为最胜者。能于我等起大慈悲而来至此。令诸天众皆得利益。我等所愿犹为未满。欲于如来重请一事。世尊。世间之人于我等诸天多生轻慢。何以故。以诸佛如来人中生故。复于人中成正觉故。人中多有诸阿罗汉而得果故。诸大威德辟支佛。复于人间而出现故。如来今者。若不住此下阎浮提。世间之人谓我等诸天。不知如来有大威德。应受诸天如法供养。复谓我等不能供养诸佛世尊。唯愿如来少住于此受我微供。令彼人间知我等诸天供养于佛。于时世尊默然许可

尔时佛告大目揵连。汝可先往阎浮提。问讯四众作如是言。一切众生忆念我者。咸应集会僧伽尸国。却后七日皆当见我

尔时大目揵连顶礼佛足。礼佛足已。如一瞬顷到阎浮提。以佛所敕告诸四众。时优陀延王等及一切众生。闻佛此言若身若心欢喜踊跃。皆除忧恼普得清凉

尔时四众比丘比丘尼优婆塞优婆夷。欲共往诣僧伽尸国。并先来集王舍城中。互相谓言如来世尊下阎浮提。谁能先得恭敬礼拜。法未尽来恒为上首。尔时摩诃迦旃延闻此语已。心怀不悦恐比丘尼得为上首。何以故。彼众之中。有优波难陀莲花色二比丘尼。善能通达诸佛法藏。所得神通唯除目连更无等故。作是念已。种种诃责比丘尼众。时莲花色比丘尼告诸尼言。我等女人在于俗间常被尊贵。纵使种族卑贱之者。仍得丈夫恭敬礼重承事供养。又佛法中诸比丘尼。父母眷属多是王种。精进持戒不犯威仪具诸德业。仍令礼敬初戒比丘。又尊者迦旃延。今复作此种种呵责。我为汝等设诸方便。令比丘尼出过于彼。作是语已。与诸四众即时往赴僧伽尸城

尔时波斯匿王阿阇世王。及毗舍离国严炽王等。各将四兵前后导从。有大势力所乘象马。皆以种种宝物庄严。幡盖香花并众妓乐。威容肃穆状若诸天。皆亦往诣僧伽城所

尔时优陀延王严整四兵以为侍从。乘大白象珍宝绮饰。躬自荷戴所造之像。花幡音乐随逐供养。从其本国向僧伽尸城

尔时毗首羯磨天并诸天众。知佛将欲下阎浮提。作三道宝阶。从僧伽尸城至忉利天。其阶中道琉璃所成。两边阶道悉用黄金。足所践处布以白银。诸天七宝而为间饰

尔时帝释遣使往诣夜摩天。兜率陀天。化乐天。他化自在天。及于梵世而告之曰。如来不久下阎浮提。欲有供养愿来至此。复遣使往四天王天。大海龙王揵闼婆紧那罗夜叉等众。而谓之言。世尊今欲下阎浮提。可持所有来此供养。时彼诸天及龙神等闻此语已。靡不云集忉利天中

尔时世尊在须弥山顶。与诸天众将欲下时。一切诸天前后翼从。威德炽盛光明赫奕。如满月在空众星共绕。如旭日初出彩霞纷映。时佛众会其状如是

尔时阎浮提中。以佛威神有五种希有之事。一者令彼诸天不见人间不净之物。二者令诸女人见彼天男而无欲想。三者亦令丈夫见诸天女不生染意。四者令于人间遥见诸天种种供养。五者诸天之身光洁细妙非人所睹。以佛神力显然明着皆可得见。尔时世尊从天初下足蹈宝阶。梵王在右手执白盖。帝释在左手持白拂。其余诸天皆乘虚空随佛而下。一时同奏种种音乐。各自捧持幢幡宝盖散花供养。净居天众侧塞虚空。无量百千诸天婇女。持宝珠璎珞歌赞佛德。复有诸天。于虚空中雨种种香及种种花。诸龙雨于微细香雨。于时空中净无云曀。雷声美妙闻者喜悦。揵闼婆神。紧那罗神。奏提婆那伽微妙之曲。歌赞如来本生之事。于时阎浮提内。王及臣人并四众等。周匝遍满僧伽尸城。或散香花或持幡盖。吹螺击鼓种种音乐向空供养。举手合掌瞻仰于佛。人天名花上下交散。缤纷而下积至于膝。诸外道众见斯事者。咸亦发心归依礼敬

尔时世尊足蹈宝阶。次第而下至于半路。四天王天即于其所广设供养。此供殊妙劫初已来未曾有也

尔时如来受天供毕。复与大众巡阶而下。至最下级欲践地时。其莲花色比丘尼。即变其身作转轮王。领四种兵七宝前导。从空来下疾至佛所。诸国王等各兴是念。此转轮王从何所来。干时尊者须菩提在自房中见佛下来。即整衣服遥申礼敬。时莲花色比丘尼。舍轮王身还复本形。遽即顶礼佛世尊足。尔时世尊种种呵责彼比丘尼。而谓之曰。汝今知不。须菩提已先礼我。汝得谁教变作轮王。汝得预出家受具足戒已过其分。汝智慧微少谄诈无边。慈悲报恩如露一滴。岂能于我法中而为上首。时莲花色比丘尼。闻佛教诲深生愧耻。即白佛言。世尊。我今自知为过不少。从今以往不敢复更变现神通

尔时阎浮提内国王大臣并四部众。皆以所持种种供具供养于佛。时优陀延王顶戴佛像并诸上供珍异之物。至如来所而以奉献。佛身相好具足端严。在诸天中殊特明显。譬如满月离众云曀。所造之像而对于佛。犹如堆阜比须弥山不可为喻。但有螺髻及以玉毫少似于佛。而令四众知是佛像

尔时优陀延王白佛言。世尊。如来过去于生死中为求菩提。行无量无边难行苦行。获是最上微妙之身无与等者。我所造像不似于佛。窃自思惟深为过咎

尔时世尊告彼王言。非为过咎。汝今已作无量利益。更无有人与汝等者。汝今于我佛法之中初为轨则。以是因缘故。令无量众生得大信利。汝今已获无量福德广大善根。时天帝释复告王言。王今于此勿怀忧惧。如来先在天上及此人间。皆称赞于王造像功德。凡诸天众悉亦随喜。未来世中有信之人。皆因王故造佛形像而获胜福。王今宜应欢喜自庆

佛说大乘造像功德经卷上佛说大乘造像功德经卷下

        大唐于阗三藏提云般若奉　制译

尔时世尊于僧伽尸道场坐师子座。时诸四众心各念言。我等愿闻如来演说造像功德。若有众生作佛形像。设不相似得几所福。尔时弥勒菩萨摩诃萨知其念。即从座起偏袒右肩。长跪合掌白佛言。世尊。今优陀延王造佛形像。若佛在世若已涅槃。其有信心能随造者所获功德。唯愿世尊广说其相

佛告弥勒菩萨言。弥勒。谛听谛听。善思念之。当为汝说。若有净信善男子善女人。于佛功德专精系念。常观如来威德自在。具足十力。四无所畏。十八不共法。大慈大悲。一切智智。三十二种大人之相。八十随形好。一一毛孔皆有无量异色光明。百千亿种殊胜福德庄严成就。无量智慧明了通达。无量三昧。无量法忍。无量陀罗尼。无量神通。如是等一切功德皆无有量。离众过失无与等者。此人如是谛念思惟深生信乐。依诸相好而作佛像。功德广大无量无边不可称数。弥勒。若有人以众杂彩而为缋饰。或复镕铸金银铜铁铅锡等物。或有雕刻栴檀香等。或复杂以真珠螺具绵绣织成。丹土白灰若泥若木如是等物。随其力分而作佛像。乃至极小如一指大。能令见者知是尊容。其人福报我今当说。弥勒。如是之人于生死中虽复流转。终不生在贫穷之家。亦不生于边小国土下劣种姓孤独之家。又亦不生迷戾车等。商估贩赁屠脍等家。乃至不生卑贱伎巧不净种族。外道苦行邪见等家。除因愿力并不生彼。是人常生转轮圣王。有大势力种姓之家。或生净行婆罗门。富贵自在无过失家。所生之处常遇诸佛承事供养。或得为王。能持正法以法教化不行非道或作转轮圣王。七宝成就千子具足。腾空而行化四天下。尽其寿命自在丰乐。或作帝释。夜摩天王。兜率天王。化乐天王。他化自在天王。人天快乐靡不皆受。如是福报相续不绝。所生之处常作丈夫不受女身。亦复不受黄门二形卑贱之身。所受之身无诸丑恶。目不盲眇。耳不聋聩。鼻不曲戾。口不喎斜。唇不下垂。亦不皱涩。齿不疏缺。不黑不黄。舌不短急。项无瘤瘿。形不伛偻。色不斑驳。臂不短促。足不癵跛。不甚瘦。不甚肥。亦不太长。亦不太短。如是一切不可喜相悉皆无有。其身端正面貌圆满。发绀青色软泽光净。唇如丹果。目若青莲。舌相广长。齿白齐密。发言巧妙能令闻者无不喜悦。臂肘佣长。掌平坦厚腰髀充实胸臆广大。手足柔软如兜罗绵。诸相具足无所缺减。如那罗延天有大筋力。弥勒。譬如有人堕圊厕中从彼得出。刮除粪秽净水洗沐。以香涂身着新洁衣。如是此人比在厕中犹未得出。净秽香臭相去几何。此事悬隔无有等倍。弥勒。若有人于生死中。能发信心造佛形像。比未造时相去悬隔。亦复如是。当知此人在在所生净除业障。种种伎术无师自解。虽生人趣得天六根。若生天中超越众天。所生之处无诸疾苦。无疥癞。无痈疽不为鬼魅之所染着。无有癫狂干痟等病癀疟症瘕恶疮隐疾。吐痢无度饮食不消。举体酸疼半身痿躄。如是等病四百四种皆悉无有。亦复不为毒药兵仗虎狼师子水火怨贼如是横缘之所伤害。常得无畏不犯诸罪。弥勒若有众生宿造恶业。当受种种诸苦恼事。所谓枷锁杻械。打骂烧炙。剥皮拔发。反系高悬。乃至或被分解支节。若发信心造佛形像。如是苦报皆悉不受。若寇贼侵扰城邑破坏。恶星变怪饥馑疾疫。如是之处不生其中。若言生者斯则妄说

尔时弥勒菩萨摩诃萨复白佛言。世尊。如来常说善不善业皆不失坏。若有众生作诸重罪。当生卑贱种姓之家。贫穷疾苦寿命夭促。后发信心造佛形像。此众罪报为更当受为不受耶。佛告弥勒菩萨言。弥勒。汝今谛听当为汝说。若彼众生作诸罪已。发心造像求哀忏悔。决定自断誓不重犯。先时所作皆得销灭。我今为汝广明此事。弥勒。譬若有人宿行悭吝。以是缘故。受贫穷苦无诸财宝资用匮乏。忽遇比丘先入灭定从定初起。即以饮食恭敬奉施。此人施已永舍贫穷。凡有所须悉如其意。弥勒。彼贫穷人先世恶业。及所得报今何在耶。弥勒菩萨言。世尊。由施食故。先世恶业皆悉灭尽。永离贫穷大富充足。佛言弥勒。如汝所言。当知此人亦复如是。由造像故。彼诸恶业永尽无余。所应受报皆不复受。弥勒。业有三种。一者现受。二者生受。三者后受。此三种业中一一皆有定与不定。若人信心造佛形像。唯现定业少分容受余皆不受

尔时弥勒菩萨摩诃萨复白佛言。世尊。如来常说有五种业最为深重。决定堕于无间地狱。所谓杀父害母杀阿罗汉。以恶逆心出佛身血。破和合僧。若有众生先作此罪。后于佛所生净信心造佛形像。此人为更堕于地狱为不堕耶

佛告弥勒菩萨言。弥勒。我今为汝重说譬喻。如或有人手执强弓。于树林间向上射叶。其箭彻往曾无所碍。若有众生犯斯逆罪。后作佛像诚心忏悔得无根信。我想微薄。虽堕地狱还即出离。如箭不停。此亦如是。又如比丘得神足通。从海此岸到于彼岸。周旋四洲无能碍者。此人亦尔。由先所犯暂堕地狱。非彼宿业所能为碍

尔时弥勒菩萨摩诃萨复白佛言。世尊。诸佛如来是法性身非色相身。若以色相为佛身者。难陀比丘与转轮圣王皆应是佛。以悉具有诸相好故。或有众生坏佛法身。法说非法非法说法。后发信心而造佛像。此之重罪为亦销灭为不得灭

佛告弥勒菩萨言。弥勒。若彼众生法说非法非法说法。唯以口言而不坏见。后生信乐造佛形像。此先恶业但于现身。而受轻报不堕恶道。然于生死未即解脱

尔时弥勒菩萨摩诃萨复白佛言。世尊。若有人盗佛塔物。盗僧祇物。四方僧物现前僧物。自用与人如己物想。世尊。常说用佛塔物及僧物者其罪甚重。然彼众生作是罪已深自悔责。起净信心而造佛像。如是等罪为灭不耶

佛告弥勒菩萨言。弥勒。若彼众生曾用此物。后自省察深怀愧悔。依数酬倍誓更不犯。我今为汝说一譬喻。如有贫人先多负债。忽遇伏藏得无量宝。还其债已长有余财。当知此人亦复如是酬倍彼物。又造佛像免诸苦患永得安乐

尔时弥勒菩萨摩诃萨复白佛言。世尊。如佛所说于佛法中。犯波罗夷不名为生。或复有人作斯罪已。发心忆念诸佛功德而造佛像。于佛法中得再生不。又于今生第二第三第四生中获证法不

佛告弥勒菩萨言。弥勒。譬如有人身被五缚。若得解脱如鸟出网至无碍处。此人亦尔。若发信心念佛功德而造佛像。一切业障皆得销除。于生死中速出无碍。弥勒当知。乘有三种。所谓声闻乘独觉乘及以佛乘。此人随于何乘而起愿乐。即于此乘而得解脱。若但为成佛不求余报。虽有重障而得速灭。虽在生死而无苦难。乃至当证无上菩提。获清净土具诸相好。所得寿命常无有尽

尔时会中有未发大乘心者。皆生疑念。如来过去为造佛像为不作耶。设若作者云何寿命而有限极有病有苦。所居国土多诸秽浊不得清净。时波斯匿王承佛威神。即从座起长跪合掌白佛言。世尊。我见如来诸根相好。及以种族皆悉第一。其心决定无有所疑。然佛世尊曾于一时。被佉陀罗木刺伤其足。又于一时遇提婆达多推山迸石伤足出血。昔复一时唱言有病。命遣耆婆调下利药。又一时中曾患背病。令摩诃迦叶诵七菩提分所苦得除。复于一时曾有所患。使阿难陀往婆罗门家。乞求牛乳。往复一时于娑罗村中。三月安居唯食马麦。复曾一时乞食不得空钵而还。如世尊言。若有人作佛像者。所有业障皆得除灭。离众苦恼无诸疾病。世尊往昔为曾作像。为不曾作。若于昔时作佛像者。何因而有如是等事

佛告波斯匿王言。谛听谛听。善思念之。当为大王分别解说。大王。我于往世为求菩提。以众宝栴檀彩画等事而作佛像。过此会中人天之数。以斯福故虽在生死未尽诸惑。然所受身坚如金刚不可损坏。大王。我念过去于无量劫生死之中。造佛形像。尔时尚有贪嗔等无量烦恼而共想应。然未曾于一念之间以罪业故有四大不调及恶鬼神诸少病苦。所须之物莫不充备。况我于今已得阿耨多罗三藐三菩提。而有如是不如意事。大王。若我昔时曾作佛像。今有残业受斯报者。我复云何作无畏说。言造佛像决定能尽诸恶业耶。大王。我于过去给施无量饮食财宝。云何今时乞求不得。而食马麦。傥今此事而有实者。云何我于无量经中。种种赞叹檀波罗蜜。说其福业终不虚也。大王。我是真实语者。不诳语者。我若欺诳况余人乎。大王。我已久断一切恶业。能舍难舍。能行难行。所舍身命过百千亿。已造无量诸佛形像。已悔无量诸罪恶业。岂得有斯毁伤病苦食啖马麦饥渴等事。若曾得胜果今还退失。何假劝修此众福善。大王。诸佛如来常身法身。为度众生故现斯事非为实也。伤足患背乞乳服药。乃至涅槃。以其舍利分布起塔。皆是如来方便善巧。令诸众生见如是相。大王。我于世间现于如是众患事者。欲示众生业报不失令生怖畏。断一切罪修诸善行。然后了知常身法身。寿命无限国土清净。大王。诸佛如来无有虚妄。纯一大悲智慧善巧。故能如是种种示现。是时波斯匿王闻此说已。欢喜踊跃与无量百千众生。皆发阿耨多罗三藐三菩提心

尔时弥勒菩萨摩诃萨复白佛言。世尊。有诸女人志意狭小。多怀嫉恚轻薄谄曲。有恨不舍知恩不报。设求菩提莫能坚守。常欲诳惑一切众生。亦复为他之所诳惑。世尊。若此女人造佛形像。如是诸业得除灭不。当来得作勇健丈夫求佛果不。得作知恩报恩人不。得具智慧大慈悲不。于生死法能厌离不。除因愿力得更不受女人之身。如瞿昙弥及佛母摩耶夫人不。佛告弥勒菩萨言。弥勒。若有女人能造佛像。永不复受女人之身。设受其身则为女宝尊胜第一。然诸女人有五种德。此女所得出过诸女。何等为五。一者生孕子息。二者种族尊贵。三者禀性贞良。四者质相殊绝。五者姿容美正。弥勒。一切女人有八种因缘恒受女身。云何为八。一者爱好女身。二者贪着女欲。三者口常赞美女人容质。四者心不正直覆藏所作。五者厌薄自夫。六者念重他人。七者知人有恩而已背逆。八者邪伪庄饰欲他迷恋。若能永断如是八事而造佛像。乃至成佛常作丈夫。更受女身无有是处。弥勒。有四种因缘。令诸男子受女人身。何等为四。一者以女人声。轻笑唤佛及诸菩萨一切圣人。二者于净持戒人。以诽谤心说言犯戒。三者好行谄媚诳惑于人。四者见他胜己心生嫉妒。若有丈夫行此四事。命终之后必受女身。复经无量诸恶道苦。若深发信心悔先所作。而造佛像则其罪皆灭。必更不受女人之报。弥勒。有四种因缘。令诸男子受黄门身。何等为四。一者残害他形乃至畜生。二者于持戒沙门嗔笑谤毁。三者情多贪欲故心犯戒。四者亲犯戒人复劝他犯。若有男子先行此事。后起信心造佛形像。乃至成佛不受斯报。常作丈夫诸根具足。弥勒。有四种业。能令丈夫受二形身。一切人中最为其下。何等为四。一者于尊敬所而有烝秽。二者于男子身非处染着。三者即于自己而行欲事。四者詃卖女色而与他人。若有众生曾行此事。深自咎责悔先所犯。起净信心造佛形像。乃至成佛不受此身。弥勒。复有四缘令诸男子其心。常生女人爱欲。乐他于己行丈夫事。何等为四。一者或嫌或戏谤毁于人。二者乐作女人衣服庄饰。三者于亲族女行淫秽事。四者实无胜德妄受其礼。以此因缘令诸丈夫起于如是别异烦恼。若悔先犯更不造新。心生信乐作佛形像。其罪既灭此心亦息。弥勒。有五种悭能坏众生。何等为五。一者悭惜所住邻邑。由此当于旷野中生。二者悭惜所居宅宇。当作蛊身恒居粪秽。三者悭惜端正好色。当感丑恶不如意形。四者悭惜所有资财。当受贫穷衣食乏少。五者悭惜所知之法。当有顽钝畜生等报。若悔己先业造佛尊仪。则永离悭心无前所受。弥勒。复有五缘。令诸众生生边夷之处及无佛法时。何者为五。一者于三宝良田不生净信。二者背实亏理妄行教诫。三者不如理实而有教授。四者破和合僧令成二部。五者极少乃至破二比丘令不和合。若永断斯业造佛形像。则常遇佛兴恒闻法要。弥勒。众生复有五种因缘。常被于人之所厌逐。乃至至亲亦不喜见。云何为五。一者两舌。二者恶口。三者多诤。四者多嗔。五者巧说相似之言以行诽谤。后若发心造佛形像。悔先恶业誓不重作。其所作罪并得除灭。为一切人之所爱敬。何以故。诸佛有无量无边胜福德故。无量无边大智慧故。无量无边三昧解脱等。种种希有功德法故。善男子。假使有人以三千大千国土末为微尘。复碎彼尘。一一尘分等彼三千大千国土微尘之数。有如是等碎微尘数三千大千国土。设复有人取一碎尘。以神通力往于东方。一刹那顷过彼所碎微尘数三千大千国土第二第三。后后刹那皆亦如是。乃至终彼碎尘数劫。彼诸劫中所有刹那一一刹那各为一劫。经尔许劫刹那刹那。皆度如前碎微尘数三千大千国土。如是毕已乃下此尘。是人还来更取一尘。复往东方过前一倍下尘而返。至第三尘倍于第二。如是次第转倍于前。乃至尽此碎微尘数。如说东方南西北方皆亦如是。是人四方所经之处。一切国土尽末为尘。此诸微尘。一切众生共挍计筹量容可知数。于如来身一毛孔分所有功德不可知也。何以故。诸佛如来所有功德。无有限量不思议故。善男子。假使如前微尘等数。舍利弗等。所有智慧不及如来一念之智。何以故。如来于念念中常能出现过前尘数三昧解脱陀罗尼等种种无量胜功德故。诸佛功德一切声闻辟支佛。于其名字亦不能知。是故若有净信之心造佛形像。一切业障莫不除灭。所获功德无量无边乃至当成阿耨多罗三藐三菩提。永拔众生一切苦恼。佛说此经已。弥勒菩萨及三十三天。优陀延王一切世间天人阿修罗乾闼婆等。闻佛所说。皆大欢喜信受奉行

佛说大乘造像功德经卷下


佛说大乘智印经

    No. 634 [Nos. 632, 633]

佛说大乘智印经卷第一

        西天三藏宝法大师赐紫沙门智吉祥等奉　诏译

如是我闻。一时世尊。入王舍大城。次第乞食受施充足。还迦兰陀林。食时食已结跏趺坐。与大比丘众及诸菩萨百万人俱。欢喜围绕。是诸大众。皆得陀罗尼平等无碍。心悟总持得三摩地。安住空性无相无愿解脱法门。具足无量殊胜功德。言议思惟皆不可及。为众所知为众所识。寂静安住如是法门。于诸分别悉皆平等。不随世间众所好乐。了知众生差别识性。于一切时所知善恶。离诸憎爱一味平等。尔时世尊忽于眉间放大光明。是诸众会咸皆悚栗。肃恭合掌瞻仰如来目不暂舍。世尊告言。汝等应当系心思惟。安住如来所知境界。于我我所好恶分别悉皆远离。若于自身毁誉等观。苦乐一切审知众生。由染污缘受差别相。游处好乐昼夜不舍。以方便力悉使断除。观诸众生种种造作诸不善业。随顺他教竞共驰逐。与诸同分安处动作无义利业。斯由有情识心愚昧。于真实境无所了知。失胜善心逐恶朋友。不解思惟深远胜法。真实义谛起诸分别谓为真实。无拣择慧阙定信心。于佛言教及众妙行不生好乐。设复修善无应正理。著有着空互为究竟。我以如来智印三摩地力悉能了知。汝等应当于是有情深心怜愍。是诸大众闻如是说。赞叹如来胜定功力。悉能了知如是差别。尔时世尊作是语已。乃入如来智印三摩地。是诸大众睹佛如来入是胜定。于佛身相及种种相。一切众会忽皆不见不能了知。如来所著法衣及近身衣。亦复不见不能了知。如来所有四威仪相。乃至一切动转之相。皆不可见不能了知。如来所有音声差别。不能听闻不能了知。所以者何。以是安住如是智印三摩地胜功德力。心无动转不可测量故。复次如来由胜定力。于诸外境种种庄严。一切众会皆不可见不能了知。于诸所住清净国土。皆不得见不能了知。所以者何。以是安住如来智印三摩地胜功德力。心无动转不可测量故。尔时大众于佛形相既无所见。各各称赞胜定功德承佛威力。深心所求离诸怖畏。尔时如来复于定中放大光明。遍照三千大千世界。其间所有日月星辰电火药珠。种种光明悉皆掩蔽。复于定中发生异香。其香微妙不与世间栴檀沉水诸香为比。是时色无色天梵王帝释。及诸天人四众八部。大铁围山小铁围山。及须弥山众山之王。水陆空界幽暗之处。一切有情咸睹光明叹未曾有。各寻是光至迦兰陀林。各随所有香华衣服宝冠璎珞以为供养。见是会中诸大菩萨及声闻众。如大池中莲华开敷。异香芬馥集在众会。时诸人天闻是香已。各各皆得智慧明了。复于空中有宝璎珞上妙衣服。处处垂下严饰供养。时诸大众咸皆欢喜。恭敬礼拜退坐一面。尔时东方如一酤胝殑伽沙数。一一沙数为一酤胝。尔所国土一切如来。皆是释迦分身化利。如是如来各集众会。菩萨摩诃萨阿僧祇数不可称量。是诸菩萨悟证平等。当得阿耨多罗三藐三菩提。诸身色相微妙具足。人天众会皆无与等。尔时一切分身如来。各各告语诸菩萨言。善男子。娑婆世界有佛世尊。号释迦牟尼应正等觉。出现于世。化诸有情离众罪垢。经无量时演说正法。示佛知见甚深难解。有陀罗尼门。名如来智印三摩地三摩钵提。我今为汝略而赞说。诸善男子汝等谛听。诸菩萨摩诃萨于百千劫具足修行六到彼岸。具大智慧福德无量。悟证修习常无懈废。永离罪垢舍众恶缘。住三摩地得佛智慧心无动转。以无动心了悟诸法。若诸有情亲近如来及大菩萨。熏修智慧三业恭敬。以胜法财修诸供养经无量时。不如于此一刹那顷安住如是胜三摩地。所获功德不可较量。常生胜处诸佛国土。尔时诸佛作是语已安住禅定。以神通力摄诸菩萨。诣娑婆世界。示同一身入王舍城次第乞食受施充足。至迦兰陀林。乃与众会分食妙供。是诸众会无不沾足。饭食已讫摄敛衣钵跏趺而坐。一切国土所来诸佛。及诸菩萨亦复如是。无二无别。复次南方如一酤胝殑伽沙数。一一沙数为一酤胝。尔所国土一切诸佛。摄诸菩萨从彼国来集会亦尔。如东方南方西方北方四维上下。一切诸佛诸大菩萨。皆来集会亦复如是。尔时释迦牟尼应正等觉。见所分身一切诸佛。皆来集会心相怡悦。唯佛与佛乃得相见。时诸如来。同入如是智印三摩地三摩钵提。静意廓如动乱止息。以不动心明照诸法。无二无别。诸佛身相亦复不现。尔时此会人天大众。见是十方无数诸佛皆来集会。以胜定力身相不现。咸皆惊喜整衣合掌右绕三匝。以宝莲华。及众妙华诸色具足持以供养。是时集会无量世界诸大菩萨。得清净心具正法眼。于一切时心相澄寂。各各当得阿耨多罗三藐三菩提者。见释迦牟尼如来应正等觉与诸如来安住如是智印三摩地三摩钵提。由胜定力隐诸色相。志愿希求深心欢喜。以精意力不起于坐。觉智现前入佛境界。得陀罗尼门。时诸菩萨告此娑婆世界诸大众言。善男子。汝等应当于佛功德眷恋希求。于诸有情系心怜愍。知诸菩萨摩诃萨于百千劫行六波罗蜜。具大智慧福德无量。于一切法悉皆了知。离诸戏论处深禅定。不忘不愚达诸性相。于是胜法应当愿求。尔时三千大千世界声闻缘觉。具大智慧得大神通。舍生死岸离烦恼缚。于自涅槃修证圆满。大苾刍众及诸宰官婆罗门。邬婆索迦邬婆斯迦。如是等众咸来至此王舍大城迦兰陀林。释迦如来应正等觉及分身佛会。绕百千匝恭敬礼拜。各以上妙杂色莲华。其华千叶七宝间错。过无量数以为供养。复有八十酤胝那庾多数诸大菩萨摩诃萨众。是诸菩萨皆是他方国土中。诸佛如来之所遣使。有大勇猛不怖生死。有大慈悲不乐涅槃。各以神力入大禅定现诸威仪。从彼彼土如弹指顷。到王舍城迦兰陀林。释迦牟尼应正等觉及分身佛会三业恭敬。以清净妙音尊重赞叹。见诸佛身隐晦不现。渴仰世尊围绕众会。头面作礼退处一面。各各皆于宝莲华上结跏趺坐。复有三亿诸比丘众。乐修己利求解脱者。承于如来智印三摩地力。而来集会。是时他方三千大千世界。帝释梵王。大自在天。净居天子。日月星辰。及诸一切天龙乐叉。乾闼婆。阿苏啰。紧那啰。摩虎啰伽。及比丘比丘尼。优婆塞优婆夷。人非人等各并眷属。睹佛光明皆来集会。如是等众。譬如有人发密修长。将一一发剪如微尘。如一人发。至千万人发亦复如是。以一发尘为一众生。是赴会众复过是数。尔时尊者大目干连。摩诃俱絺罗。摩诃迦栴延摩诃迦叶波。摩诃富楼那弥多罗尼子。摩诃须菩提等。知诸大众虽在会中。而不睹见如来身色及与住处。于时尊者舍利弗从座而起。至妙吉祥童真菩萨前。白言仁者。今此世尊。入是如来智印三摩地。而我等辈。云何不能见如来身及与住处。时妙吉祥童真菩萨。告舍利弗言。汝诸声闻。具大智慧得诸解脱。常修梵行离诸怖畏。一切人天悉皆恭敬。汝等应当各各依自所得三摩地门。以智慧力观察如来身色住处。时舍利弗等。即时各各入自所得三摩地门。以智慧力观察推求。如来色身及与住处。遍于三千大千世界微尘刹土。穷尽神力皆不能见。时舍利弗白妙吉祥童真菩萨言。我等依自所得三摩地门。以智慧力观察推求如来色身及与住处。了不可见。惟愿仁者。为我等辈。分别指示咸令得见。时妙吉祥童真菩萨告舍利弗言。汝诸声闻。虽具智慧及与神通。而于如来智印三摩地门。不能思惟。故于佛身及所住处不能得见。所以者何。汝诸声闻以差别心。观视如来色身住处。由此分别自为障碍。是如来身非分别心所能观见。若以汝身即如来身。汝等所住即如来住。乃至一切有情之身即如来身。一切有情之所住处即如来住。空有一相自他无二。不舍有为而证无为。不离无为而悟有为。以如是心。观如来身及与住处。尔乃可见。汝等既用有分别心。欲见如来无相境界。设经无量尘沙劫数莫复能得。于是众会悲感懊恼。离分别心安住正念。身心内外犹如虚空寂静而住。尔时世尊从禅定起。其心广大如海汪洋。澄清映彻如净琉璃。普观众生若身若土。与诸如来平等不二。身相廓然众会皆睹。是时三千大千世界皆大振动。一切诸天心大欢喜离诸怖畏。于虚空中雨天宝华。其华微妙缤纷而下。又于空中作天妓乐。种种歌咏上妙音声。琴瑟箜篌琵琶笙箫。是诸乐器不鼓自鸣。于是会中以为供养。于时舍利弗从座而起。至世尊前曲躬合掌。而白佛言。大悲世尊。如来所入智印三昧。而我等辈无所觉知。各以神通。入自所得三摩地门。以智慧力周遍推求如来身色及与住处。杳不可得不能了知。是我等辈。先自所得三摩地门及智慧力狭劣短促。未得如来无相正智自在法门。惟愿世尊。大慈悲力深加怜愍。与我等辈而为开导。于佛知见定慧法门使令悟入。于无相境任运现前。尔时佛告舍利弗。我入如是智印三摩地。非汝声闻及诸缘觉所得智慧之所了解及能推求。唯佛与佛乃能知之。何以故。如来色身由无动心离诸希求。舍分别缘绝自他相凝然湛寂。胜智功力之所任持。大定如如为一体相。若汝声闻及诸缘觉。唯求自利不乐利他。所证法门及智慧境未解融通。自他隔阂空有互违。于佛如来法空无相智印三昧。难解难入。是故汝等于佛身相及与住处。不可得见亦不了知

佛说大乘智印经卷第一佛说大乘智印经卷第二

        西天三藏宝法大师赐紫沙门智吉祥等奉　诏译

尔时佛告舍利弗。诸佛如来若身若心所获功德。难修难证亦难悟入。何以故。舍利弗诸佛如来眼观诸色。是识不以色境而动。耳听诸声。是识不以声境而动。鼻嗅诸香。是识不以香境而动。舌尝诸味。是识不以味境而动。身取诸触。是识不以触境而动。所以者何。识智自在。不于外境妄计好丑起爱憎故。舍利弗。诸佛如来意缘诸法。胜智相应了知所观。无生非无生。是得最上无生。寂静非寂静。是得最上寂静。禅定非禅定。是得最上禅定。律仪非律仪。是得最上律仪。戏论非戏论。是离最上戏论。分别非分别。是离最上分别。断灭非断灭。是得最上断灭。舍利弗。诸佛如来凡有所说。离诸虚妄无不真实。义味充饶止息诤论。心相平等离诸异相不平等法。能令闻者除去恶欲。不生邪见离邪思惟。舍利弗。诸佛如来若于所证无去无来。不常不断。非空非有。离见离闻。无大小形。无方圆相。舍利弗。诸佛如来于能证道相性圆满智慧光明。远离异相及非异相。无诸拣择及非拣择。体若金刚无破坏故。用如虚空无取舍故。于胜善法无所爱着。于广大行亦无怖畏。心相空寂离论闻见。舍利弗。诸佛如来于所安住边际胜定。清净圆满。不厌阓闹不乐空寂。于一切时而常游戏。于法非法情器差别悉能了悟。无不如境定力坚固。纵遇恶缘不可破坏。舍利弗。诸佛如来。于诸世间尊贵富饶一切乐境。如梦如幻。如弃遗迹。不依辅相宰官大婆罗门而有所求。是故不为名闻利养之所系缚。舍利弗。诸佛如来或有所闻情非情声。不缘此故而生差别。无差别心亦复远离。舍利弗。诸佛如来于诸所缘决定境相不生胜解。非胜解心亦复远离。舍利弗。诸佛如来于诸时分。不计延促有尽无尽成坏差别。非差别心亦复远离。了知诸法无言无说离去来今。于心心所无有相应无不相应。思惟计念悉皆不生。无有此岸无有彼岸。于诸情器无上中下。深心坚固不可破坏。舍利弗。诸佛如来所有身相。无所动作离诸事业。怨憎违戾信向亲厚。以平等慈隐显不二。由昔因中离无边障修无边行。于诸众生施大悲智真实观察随其所宜具能饶益。令诸有情应自所求欢喜满足。故于所得身相智慧。唯自证知余无所解。于自身色无有齐限与虚空等。无有隐显周遍一切。胜功德力之所庄严。相好圆满无有缺减。于蕴处界中无在无不在。于诸有情所习事业。悉能弃舍。除方便智示现修作。内心清净外色清净。舍利弗。如上所说。皆是如来若身若心。胜善功德庄严之相。周遍平等。若以汝等分别之心。欲见如来胜定任持所有身相。是如来身不可得见。尔时舍利弗重白佛言。世尊。云何如来色身圆满得名无相。云何智印三摩地周遍平等。尔时世尊欲重宣此义。而说偈言

  如来身心相　　由定智所生
  不假外境牵　　识相分别动
  意缘一切法　　与身无有异
  离是非差别　　所得为最上
  若以小智力　　欲见善逝身
  如月印晴空　　妄谓水中现
  身相本微妙　　复由胜定持
  离长短方圆　　无去来住立
  内心寂不动　　澄静若虚空
  息泯身心相　　自然无所有
  以无所有心　　不着香味触
  离诸蕴处界　　以此观如来
  如见水中月　　虽不得真实
  既离分别心　　是亦名为见
  如来智印门　　非我独能证
  若大心众生　　希求无厌倦
  得最上等持　　依此胜定力
  于佛智印门　　亦当无所得
  此经所生福　　无尽如虚空
  我以方便智　　少略而赞说
  十方诸佛土　　百千酤胝刹
  满中诸珍宝　　若人持供养
  时经无量劫　　不如闻是经
  书写或受持　　是人所得福
  比前行施者　　复倍河沙数
  若人行慈心　　饶益诸有情
  不如依此经　　悟佛三摩地
  若于众生界　　心常行忍辱
  不如弹指顷　　修习殊胜定
  其所生功德　　犹如须弥山
  将以对微尘　　大小莫为比
  若人行精进　　勇猛为诸善
  不如闻此经　　依教悟其理
  所获诸功德　　百千万亿分
  若以共较量　　比况不及一
  若人修禅定　　安住无量劫
  坐卧若经行　　周遍诸佛刹
  不如一时中　　闻此经功德
  若于尘沙劫　　能修习智慧
  断除烦恼缠　　名闻普周遍
  不如刹那时　　赞佛智印海
  如以大海水　　比较于一滴
  若欲观佛者　　须离诸名相
  了知诸法性　　非空亦非有
  若但了知空　　设如苏部底
  于佛智印门　　亦无所悟入

尔时世尊说是偈已。告舍利弗。如我所说。如来智印三摩地法。若诸菩萨能于十方诸佛世界。为欲圆满无碍智慧。应当修学是三昧地。昼夜精进身心安住。而不散乱亦不懈废。舍利弗。如是菩萨摩诃萨。若欲愿见十方世界诸佛国土。一切如来悉皆能见。舍利弗。此三摩地。是菩萨摩诃萨。无量无边最胜法门甚深法眼。而于诸法得无障碍通达了知。无所忘失。是名如来最胜总持陀罗尼门。若诸菩萨心欲圆满一切说相。为欲成就无上菩提微妙体性。应当志心精勤修学。是三摩地智印法门。若诸菩萨随欲远离诸恶业行无诸障碍。成就最上清净之法。以智慧力摧伏怨魔。远离不善诸相平等。如如来智无诸染秽。诸业障尽清净无垢。安住如来究竟智地。能使诸恶一切魔怨。咸皆止息无所退动。觉智明了知彼一切诸众生等。种种分别爱乐境相。善不善业因果差别。了知一切诸众生等。意地微细烦恼结缚。善能知彼解诸有情一切缚法。应当修学如来所说方便最上胜三摩地智印法门。若诸菩萨欲令众生志乐坚固。心欲思惟求无上法。应当精勤修习如是三摩地门。自然成就无上胜法。若诸菩萨意欲宣说诸佛如来应诸有情种种根病对治等法。应当精勤修习如是三摩地门。自然于法分别演说无有障碍。若诸菩萨心欲于彼三乘圣法。分别晓悟真俗谛相甚深法义。应当精勤修习如是三摩地门。自然于法智慧明了不生闇钝。若诸菩萨欲于酤胝百千劫数。了悟生灭幻化不坚。能证诸法真实自性清净解脱。应当精勤修习如是胜三摩地。若诸菩萨欲于生灭十二因缘。无明为始发生业行招集苦报。贪染执着爱欲增盛。假有聚成生死病相。变易无常流转诸趣。于生灭因而自觉悟。应当精勤修习如是胜三摩地。若诸菩萨欲了一切杂类有情。起见造业报相差别。心识明昧正念颠倒异分有情。如实了知根性利钝。方便教示渐令悟入。真实正法住信行地。应当精勤修习如是胜三摩地。若诸菩萨意乐成就诸佛国土。清净业因纯善境界。身心寂静眷属调顺。远离嫉妒憍慢过失亲近恭敬。平等爱乐无怨憎想。应当精勤修习如是胜三摩地。若诸菩萨意欲发萌自身智慧胜妙光明。照曜自他生死黑暗愚痴重障。断三界惑灭诸苦报自在解脱。应当精勤修习如是胜三摩地。若诸菩萨欲知十方所有世界一切有情死此生彼寿命延促。所经长劫及以刹那生灭分限定由先业。招引势力所感如是。自类果报如实了知。前后决定寿命根本。应当精勤修习如是胜三摩地。若诸菩萨欲知声闻及辟支迦菩萨如来。从自因地所行妙行。于四圣谛断灭修证。十二因缘逆顺观察。寂然自觉微妙甚深。十到彼岸清净因行。各各获得究竟果报。应当精勤修习如是胜三摩地。若诸菩萨欲于一切语言音声角论辩捷应时詶对不疏不谬。方便善巧于诸世俗及以胜义。显示明了令人易解。不生疑惑印证决定。应当精勤修习如是胜三摩地。若诸菩萨意欲了知佛法正因。三乘善行方便随顺。根本差别有上中下。称性悟入菩萨因地。渐以熏修植诸善本得如来智。应当精勤修习如是胜三摩地。若诸菩萨意欲成就诸佛如来圆满觉智。不起分别现种种身。以平等慈任运摄受一切有情。令各生起欢喜爱乐。修学菩萨心地行愿。应当精勤修习如是胜三摩地。舍利弗。如我所说三摩地法。是为最胜。如摩尼珠。一切有情凡所乐欲。悉得如意无不满足。舍利弗。若诸菩萨摩诃萨等。得此如来三摩地法。一切所须诸法圣财及微妙行。悉得如意行愿圆满。是故应当精勤修学。尔时世尊欲重宣此义。而说偈言

  如来所有智　　最上更无等
  随性相差别　　一切皆能证
  平等智光明　　普照诸缚着
  能入智慧门　　得无量自在
  智相及智性　　能印证诸法
  分别诸善恶　　及世俗胜义
  晓了如是法　　智慧无有尽
  譬如大明日　　光照于三界
  普于诸幽暗　　一切皆破坏
  成就平等法　　是真实圣智
  一切三摩地　　皆从智印出
  名为诸佛种　　亦名大摩尼
  利益诸有情　　亦如世间人
  有最胜珍宝　　财富无有尽
  济诸贫乏者　　皆令得充足
  法财施众生　　亦复无有尽
  神通及智慧　　最胜妙法门
  皆从三摩地　　智印宝所生
  譬如诸国土　　有大摩尼珠
  诸王皆爱乐　　臣佐普护持
  如是摩尼宝　　诸宝无有上
  我说智印宝　　殊胜最第一
  总持智光明　　破坏于诸见
  境界悉明了　　远离诸冥暗
  安住寂静心　　不分别好丑
  修清净智慧　　财法无穷尽
  贪染无所著　　无六十二见
  正念悉平等　　入甘露法门
  速得如来智　　成就相好身
  具足三十二　　得最胜菩提
  等一切佛觉　　妙智已圆明
  到菩提彼岸　　证涅槃自性
  具自他圆满　　功德悉成就
  无量无边际　　甚深微妙法
  总持陀罗尼　　解脱常寂静
  能具足十力　　又以大愿海
  布施波罗蜜　　持戒及忍辱
  精进与禅定　　智慧常坚固
  安住六度中　　长时无间断
  无有诸怖畏　　离烦恼苦业
  魔罗与眷属　　不能得其便
  能引导众生　　不舍于正法
  渐入如来家　　得游智印门
  能于贤劫中　　及十方世界
  一切诸佛会　　亲近皆随喜
  是名真佛子　　无有能破坏
  若有信解人　　能书写此经
  或读诵受持　　爱乐广流布
  长时无懈倦　　于义味明了
  当知如是经　　三世诸佛母
  出生智印宝　　如来功德藏

佛说大乘智印经卷第二佛说大乘智印经卷第三

        西天三藏宝法大师赐紫沙门智吉祥等奉　诏译

尔时会中复有殑伽沙那庾多数一切菩萨。闻佛如来说是三摩地。离诸障碍心得解脱。于陀罗尼秘密深法。随意悟入印证明了决定住持。复有六十八那庾多菩萨。于百千劫已修习禅定解脱。离诸妄想生死怖畏。常乐熏修微妙胜行。闻此最上三摩地法心怀踊跃。于阿耨多罗三藐三菩提得不退转。证陀罗尼音声辩才得无碍解。复有六十亿诸天及人。闻佛所说智印法门。欢喜无量恭敬赞叹礼拜供养。而于阿耨多罗三藐三菩提。心生爱乐。于三摩地甚深胜法。无有疑惑咸生信解。于菩提心坚固不舍。于智印门勇猛精进。由大愿力修诸善本。根性成熟便得住于阿惟越致。信受如来所行行愿。心意决定无诸退屈。于时世尊。知彼善根因缘纯熟欲授其记。告诸菩萨言。善哉善哉。汝等从此过三十亿劫。各各于诸佛国土。具足修习六波罗蜜。所有难行最胜行愿。一切皆能圆满成就。种习俱尽得大菩提。皆当作佛。悉同一号。名无畏如来。汝天人众诸善男子。已于过去无量佛所。植众善本信乐大乘。今于此会得闻如是微妙甚深希有之法欣乐受持。诸善男子。汝等从此过亿千劫。同得作佛。皆同智印如来。尔时世尊为此菩萨及天人众授佛记已。普观众会以柔软音。语妙吉祥童真菩萨言。我观此会菩萨天人。虽各于彼最上菩提发坚固心勇猛不退。未能于彼末世邪见道中建立正法。唯汝能于三千世界五浊恶时。利益安乐一切众生。方便守护分别演说。于一切处广令流布。使离虚妄及诸爱染。不为名誉之所缚着。尔时妙吉祥童真菩萨。从座而起端容整服。右膝着地胡跪合掌顶礼世尊。持种种华以为供养。瞻仰赞叹得未曾有。而白佛言。善哉世尊。如我观察一切诸法。皆不可得。而我愿乐守护无上正等菩提。及愿乐心亦不可取。世尊。此菩提道性离分别。非在内外中间。无见无闻非取非舍。圆满寂静不可相求。离戏论故。是时会中。复有三百酤胝菩萨。从座而起头面作礼恭敬赞叹。而白佛言。我等亦当守护世尊无量阿僧祇那庾多酤胝数劫所得阿耨多罗三藐三菩提秘密甚深难解之法。于未来世方便为人。受持读诵敷绎妙义。书写恭敬供养。于时一切菩萨作是语已。各各脱身所著上衣而用供养。发是愿竟退坐一面。尔时世尊告弥勒菩萨摩诃萨言。汝能具足广大慈悲。于后末世若诸众生不乐正法。于如是时护持此法。令诸众生不生邪见。尔时弥勒菩萨摩诃萨。于世尊前头面作礼。而白佛言。我当愿于五浊恶世。方便守护是三摩地令不断绝。使诸邪见散乱众生。渐次悟入摩诃衍曩最胜妙法。世尊复告弥勒菩萨言。今此会中三百八千酤胝菩萨。安住是法信解受持心生愿乐。精进修学誓不退舍。复有菩萨心未坚固。而于是法不能受持亦不爱乐。于后末世五浊劫中。不能护持如来无量阿僧祇劫庾多酤胝劫数。所修阿耨多罗三藐三菩提法。于是法中转生诤讼及诸烦恼。不能任持爱乐修学。弥勒菩萨复白佛言。世尊。云何菩萨而不爱乐最上胜法。若有菩萨意欲修习如是法行。发几种心而能成就。尔时世尊告弥勒菩萨言。谛听谛听。善男子。由诸菩萨俱生我法。愚痴闇钝以为障碍。虽有智慧而不明了。故于菩提无决定心。数数退舍多不爱乐。若有菩萨欲于如是胜三摩地智印上乘坚固趣求意乐证入。应于菩提发七种心。云何七种。一者如佛世尊往昔因地。访善知识不惜身命。为求佛道发菩提心。二者于诸微妙一切胜法。爱乐修学专心守护。为如是等发菩提心。三者现诸有情有种种苦。昼夜忧恼无解脱时。起大悲心普欲救拔。为如是等发菩提心。四者普欲利益一切众生无怨亲想。皆得快乐自在解脱。为如是等发菩提心。五者普于一切诸众生等。欢喜布施方便摄受。令离怖畏于如来法不生怯弱。为如是等发菩提心。六者见诸菩萨发菩提心。而生欣乐亲近修学。同诸菩萨发菩提心。七者为闻如来身相殊胜功德圆满第一清净。为求出世无垢圣果发菩提心。善男子。如是菩萨。发此七种最胜妙心。能于无上正等正觉渐次成就。不舍众生守护正法。是名七种发菩提心。善男子。若诸菩萨。善能修习四无量心。学佛如来甚深法藏。复能成就五种胜法。是诸菩萨具足名曰阿惟越致。弥勒菩萨复白佛言。世尊。云何五法得不退转。善男子。一者于诸众生起平等心。于自眷属不生亲昵。于他有情亦不厌舍。二者见诸有情而得利养。深生欢喜善言赞美。不生憎嫉烦恼之心。三者于佛如来微妙胜法。意愿听闻及欲宣说。为欲护持如是法藏不惜身命。广布流通相续不断。四者所有资生种种财宝无有悭吝。悉能惠施一切有情。及以上妙饮食汤药。平等普济皆令充足。五者于诸如来所得最上胜功德法广大智慧秘密总持。欢喜爱乐精勤修学。是为菩萨五种胜法。应当于此决定趣求心不退转。佛告弥勒菩萨摩诃萨。复有五法其性刚强。能障菩提不得解脱。云何五法。一者于三乘法不能解了。二者贪求利养而无厌足。三者常怀悭惜不能惠舍。四者谄曲不实无时间断。五者口但谈空不了诸相。弥勒菩萨。如是五法。惯习刚强覆障菩提。不能成就无上圣果。复有五法。若诸菩萨而能具足。即于如来所说胜法。开导演说坚固修习入圣性地。如是菩萨名为阿惟越致。云何五法。一者无我远离相缚不执自他。二者无法远离封着世俗胜义轨持自性。三者智性智相平等不二。无诸憎爱。寂静湛然。四者不着菩提及与众生不愚善恶因果渐次。五者了知如来功德色身神通变化成道入灭差别之相。善男子。如是五法具足了知名阿惟越致。能成无上正等正觉。尔时世尊。而说偈言

  无智众生类　　妄说法非法
  论世俗语言　　研求于好丑
  自身口意业　　而不能守护
  专意修习者　　爱乐于寂静
  行持戒忍辱　　言语常柔软
  能护持菩提　　如犀乐独处
  舍离于阓闹　　常乐居空寂
  如鹿在深山　　悉无诸怖畏
  如是修行者　　如风无所著
  为护持深法　　能舍于身命
  其心无所欲　　动静与施为
  咸皆为饶益　　智慧常明敏
  不愚诸境相　　后五浊恶世
  无信诸有情　　不能受是法
  触处生疑惑　　无所能觉了
  妄行于邪行　　狂乱心颠倒
  如是愚痴人　　于此菩提法
  而不能守护　　亦不乐修习
  我念过去世　　于灯明佛所
  闻是三摩地　　而发意修习
  复过于百千　　酤胝劫数已
  复有佛出世　　号名曰髻幢
  为无量众生　　说此三摩地
  第一会说法　　而有八十亿
  那庾多菩萨　　心得不退转
  第二会众数　　七十那庾多
  第三会说法　　复有七十三
  那庾多菩萨　　皆住不退地
  其佛寿长远　　身所出光明
  广六十由旬　　复有比丘僧
  九百千酤胝　　远离诸苦缚
  皆得阿罗汉　　时有转轮王
  号名曰福上　　统领阎浮提
  地里计其数　　七百千由旬
  王者四天下　　嫔妃及婇女
  其数六酤胝　　而有千王子
  诸相悉具足　　其土号光慧
  人民皆快乐　　有八百酤胝
  诸城及园苑　　上妙众华果
  种种皆严好　　摩尼宝庄严
  如诸天境相　　尔时转轮王
  而于睡梦中　　间有佛出世
  其名曰髻幢　　于是梦觉已
  寻将所领众　　臣佐及人民
  百六十酤胝　　而来至佛所
  为闻三摩地　　时王闻是经
  甚深真实法　　心生大欢喜
  即以诸国土　　咸皆施于佛
  而以为供养　　于一切国土
  用上妙栴檀　　各起诸精舍
  园林皆具足　　金银诸珍宝
  种种而严饰　　如是供养佛
  经于八万岁　　安住佛法中
  能远离诸恶　　于情及非情
  常兴修胜善　　弃舍诸爱乐
  深心无所欲　　唯以真实语
  化利诸眷属　　而于一日中
  所伸诸供养　　其数无有边
  如是供养佛　　为求三摩地
  得名生佛家　　是最上真实
  甚深微妙法　　非住相能求
  非妄心所得　　而此三摩地
  名如来智印　　时王闻是法
  弃国而出家　　经于八万岁
  常习三摩地　　而于昼夜中
  未曾有懈废　　佛于长时中
  说法广开悟　　是髻幢如来
  后入般涅槃　　王造窣睹波
  六十四酟胝　　一一窣睹波
  各五百伞盖　　七宝以庄严
  及诸众妓乐　　然百千香灯
  光明普照曜　　种种供养具
  皆悉广严备　　积累计其数
  七万三千岁　　复为诸众生
  说是三摩地　　无相殊胜法
  其心无所住　　若为人恭敬
  供养赞叹者　　心亦不生喜
  远离诸有相　　及以诸咒术
  常护持正法　　经八千酤胝
  七十那庾多　　安住如来法
  寂然常快乐　　于一切学处
  而无不具足　　成就菩提法
  三业悉清净　　于诸已受学
  系心无间断　　于所未学法
  精进勤修习　　以大智慧力
  及胜解印持　　思惟常忆念
  而无有忘失　　远离诸戏论
  及以诸异想　　非如恶世中
  妄行菩提行　　虽教化有情
  贪求于名誉　　为利养说法
  安住诸有相　　言一切皆空
  实不了空性　　是即名为着
  悟心与说异　　邪命不清净
  及行于非法　　口但能谈空
  心为相所缚　　若修如是行
  究竟无所得　　时福上轮王
  即今安乐国　　无量寿佛是
  尔时王千子　　今此贤劫中
  千佛世尊是　　今此大会中
  我前听法者　　时同王出家
  为比丘者是　　忆念于往昔
  酤胝那庾多　　一切佛法中
  出家闻正法　　闻悉能解了
  由是无量劫　　行种种方便
  供养于诸法　　不着菩提相
  安住实际中　　得见灯明佛
  福智皆平等　　如为我授记
  未来世成佛　　号名曰释迦

佛说大乘智印经卷第三佛说大乘智印经卷第四(第五同卷)

        西天三藏宝法大师赐紫沙门智吉祥等奉　诏译

尔时会中有频婆娑王。其王夫人名贤吉祥。亦名酤胝金光。阿阇世王是彼所生。从座而起五体投地礼如来足。如是礼已。双膝踞地长跪合掌色相怡悦。以妙音声赞叹佛德。复以百千无价众宝微妙衣服奉上世尊以为供养。复以五百七宝之华散虚空中。成华云盖遍覆众会。时贤吉祥作是种种诸供养已。而白佛言。世尊。我念未来浊恶世中。诸有情类信根薄劣烦恼增多。我愿于彼信解受持此三摩地最胜法门。若见有人书写受持。听闻读诵。为人演说开示导化。展转流通使不断绝。普令见闻而生信解精进修习。如是之人名为法器。我当于彼受持之者。欢喜赞叹亲近承事。供给所须饮食衣服卧具医药。诸供养具令无歉乏。复以大乘甚深之法更令悟入。令彼所住大乘种性。速得成熟于阿耨多罗三藐三菩提法。不妄分别是空不空了知诸法离言执故。随悟随学不生戏论。为护正法于诸身命无所吝惜。况复世间资生之物。增益烦恼生死之具。唯当修学如是殊胜三摩地法。作是语已退坐一面。时频婆娑王后宫八千婇女。闻如是说。各各发起阿耨多罗三藐三菩提心。而皆愿乐无上大乘。欲学安住如是殊胜三摩地门。各从座起合掌恭敬头面作礼而白佛言。世尊。我等咸当于后未来末世之中。受持如是甚深圆满微妙之法。及愿守护供养受持之者。时摩竭国乌波索迦乌波斯迦。六十万众。见是事已咸皆欢喜。亦各发起阿耨多罗三藐三菩提心。于此智印三摩地法深心随喜。作是愿言。我等亦愿于后未来浊恶世中。于是妙法圆满护持。尔时世尊知彼摩竭陀国乌波索迦乌波斯迦。并贤吉祥酤胝金光夫人。与后宫婇女八千人等。心口所愿信解受持如是妙法。长时修习无间无断。知诸佛果从此法生示现欢喜忻然微笑。缘是笑故。有百千种微妙色光从佛口出。所谓青黄赤白及颇胝迦。种种色相普遍世界。其中众生睹此光明离诸惊怖。摧伏一切烦恼魔怨。其光上照至有顶天。日月光明所不照处悉皆通彻。下至一切诸大地狱。及诸恶趣苦恼休息秽恶悉除皆得清净。其光回旋还至佛所右绕千匝。覆世尊顶隐而不现。尔时贤吉祥酤胝金光夫人。见是光已。不知如来放光义利。复从座起整肃衣容。恭敬合掌双膝长跪。顶礼世尊精勤三业。赞叹佛德而说偈言

  佛德差别无边际　　三界最胜无与等
  如华开敷正芬芳　　似月印空已圆满
  佛心平等离忧喜　　云何今者现微笑
  我今仰测笑因缘　　应当演说微妙法
  具足安乐十力尊　　处众犹如星中月
  所说言辞义味丰　　为诸世界众生眼
  法如一雨无差别　　随诸根性令生解
  梵音清彻福无边　　凡在听闻皆欢喜
  由是闻法胜因缘　　得未曾有诸快乐
  愿佛为作师子吼　　蠲除种种诸报业
  众生闻法皆悦可　　随喜平等诸义味
  自他见闻及受持　　应根应时能解了
  由兹开发菩提心　　悉于所闻生尊重
  八种圆满无漏音　　普应无边诸性欲
  一切说法功德中　　相应诸数无违背
  令诸受化诸有情　　悟入闻持心坚固
  不为烦恼娆其心　　使于所得无退转
  受持禁戒众律仪　　纵遇违缘悉能忍
  远离尘劳无众苦　　身心安住寂灭乐
  于此菩提胜行中　　思惟修作常精进
  佛身犹如妙金山　　亦如宝塔光明聚
  莲华出水正开敷　　凡是见闻悉瞻仰
  如师子王游戏时　　吼大音声伏众兽
  惟愿演是笑因缘　　令我众会除疑惑
  佛于诸法得自在　　契合无相真实理
  令差别性诸有情　　各各三业净无垢
  不舍众生常护持　　令转善因获胜果
  十方世界诸众生　　闻已思惟正修作
  摧伏一切烦恼热　　如饮甘露心清凉
  如来所有说法声　　世间众音莫能比
  琵琶笙笛及角贝　　箜篌鼓瑟妙歌唱
  桴击犍椎及铙钹　　如是诸乐共振作
  命命频伽及鹦鹉　　如是众鸟皆和鸣
  佛发微妙柔软音　　众音相共莫能比
  此十方众来集会　　毁持好恶心差别
  惟愿方便随宜说　　调伏彼中[怡-台+龍]悷者
  咸使悛革不善心　　普圆无边胜善愿
  彼从酤胝刹土来　　为闻世尊说法故
  愿今领悟正法音　　离诸怖畏获安乐
  惟愿世尊雨法雨　　慈悲演说无上法
  冀能圆满无漏音　　究竟得成菩提果

尔时世尊闻是贤吉祥酤胝金光夫人说是偈已。复于众会而说偈言

  我于无量世　　殑伽沙劫中
  时有大法王　　名无相福光
  佛寿极长远　　七十六酤胝
  化诸四天下　　彼土声闻众
  其数无有量　　以智印法门
  引导众生类　　时有转轮王
  号名曰胜慧　　王有二夫人
  一名曰帝幢　　其次号日光
  闻是智印门　　昼夜常精进
  勤修诸善业　　于一酤胝年
  护持正法眼　　经六十酤胝
  为师导众类　　已于三十亿
  无量诸佛所　　积集诸功德
  无量世界中　　法眼常救护
  三十殑伽沙　　未来世诸佛
  于彼彼世间　　平等普护持
  如是正法眼　　皆令不断绝
  时彼胜慧王　　今阿閦佛是
  彼会清净众　　夫人与眷属
  各各同俱生　　如是佛国土
  护法心不怠　　复于后后时
  转彼女人身　　得成于男子
  即生于无量　　安乐佛世界
  如今末世中　　唯汝贤吉祥
  能护如来法　　任持不破坏
  应以菩提心　　普遍诸佛刹
  正法欲尽时　　一切皆救护
  使彼觉法人　　同生安乐国
  坐千叶莲华　　得诸佛相好
  庄严皆具足　　既生彼土已
  复供养诸佛　　末后当次第
  于彼庄严劫　　得成无上道
  以阿耨菩提　　转授诸人天
  令发无上心　　同守护正法
  彼土离魔怨　　及以三毒业
  不生诸罪戾　　诸恶悉无有
  不处于胎脏　　清净而化生
  与无数菩萨　　皆集于此会
  无有诸声闻　　亦不闻名字
  远离诸恶缘　　常修菩提行
  舍名闻利养　　不恋着亲昵
  捐弃身命财　　饶益有情类
  方便为说法　　普令生信解
  若有能修习　　佛无上菩提
  安住此法中　　不求世间乐
  如说而修行　　普遍诸佛土
  常生恭敬心　　护持诸佛法
  有怀嫉妒者　　应当密护持
  以大怜悯心　　教诫诸有情
  令如是修学　　咸离诸苦厄
  如我往昔时　　为求菩提故
  于酤胝劫中　　舍头目髓脑
  珍宝及妻儿　　一切无爱恋
  若于我法中　　不能生谛信
  虽剃发染衣　　愚忘真实相
  贪求名誉财　　为利养说法
  亲近不律仪　　废受持读诵
  虽欲学沙门　　有失沙门行
  佛说是语时　　是会人天众
  有八十酤胝　　咸生悲悯心
  念彼如是人　　当沉沦恶趣
  同作如是言　　我愿于未来
  以菩提心力　　平等普护持
  作如是语已　　三千大千界
  悉皆大震动　　诸天雨众华
  于是国土中　　荆棘及便秽
  以此胜因缘　　一切皆除灭
  无异于诸天　　周遍悉清净
  于未来世中　　有人闻如是
  摩诃衍曩者　　得最胜慧命
  十方天人众　　欢喜咸恭敬
  赞叹大乘经　　种种诸妙义
  一切诸龙王　　夜叉罗刹众
  舍除毒恶心　　皆恭敬供养
  若末世有情　　得闻此最上
  甚深智印经　　而能信解者
  其人所得福　　今略为譬喻
  如似殑伽沙　　为佛国土数
  满中盛珍宝　　悉施供养佛
  修如是胜行　　过殑伽沙劫
  其所得功德　　不如闻于此
  无上智印门　　开导复演说
  所获过于彼　　无量无边数
  是福无形相　　非有为心知
  若因闻佛说　　微妙智印法
  发生菩提心　　与诸法相应
  依佛所宣说　　如说而修行
  又于末世中　　勤观察护念
  乐于空寂处　　一心求解脱
  积集无数量　　胜善诸功德
  常以三种戒　　教授诸有情
  爱护怜悯心　　如母念其子
  欢喜柔软音　　教令离怨贼
  于佛正法中　　不生颠倒想
  自他皆饶益　　速令至正觉
  若于三摩地　　广大智印门
  能书写受持　　读诵正开演
  展转授众生　　自他得开解
  亦令俱获得　　胜善诸果报
  言议与思惟　　皆悉不能及
  是人咸得生　　诸佛安乐国
  世尊见彼已　　而生亲善想
  怜悯心护持　　欢喜而摄受

尔时弥勒菩萨摩诃萨白佛言。世尊。有几乘性人。而能受持此三摩地智印法门。于彼未来世之中护持正法。于是正法而生爱乐。能于如来秘密甚深智印法门。而生信解好乐修行。于时世尊。语弥勒菩萨摩诃萨言彼五浊时恶世众生。诸苦逼恼不可称数。唯有菩萨。于此恶世荷负正法而生信解。如是之人甚为希有。而彼末世诸众生等。常闻斗诤妄言绮语。或坏善根。于此智印最胜法门所有言说不能解了。唯有菩萨。于是五浊恶世之中法欲灭时。于苦众生慈念怜悯。以诸方便饶益摄受。如是诸人苦恼所逼。若无菩萨接化引导。即于深法不能信解受持读诵。于是弥勒菩萨摩诃萨白佛言。善哉世尊。意为怜悯安乐有情。宣说如是甘露妙法。令彼未来一切众生。得是义利。生悲感心爱乐修习。若彼菩萨得是法门。随顺如来最上胜行坚固趣求。无有破坏无上道心。速能证得阿耨多罗三藐三菩提。契佛道中相应胜行而不退舍。尔时世尊复语弥勒菩萨摩诃萨言。若有菩萨。已于往昔百世尊所。亲近恭敬承事供养发菩提心。种种善根植众德本。于彼未来浊恶世中。于此广大无上菩提甚深妙义未能信解。于此广大智印法门不能悟入。复次弥勒。若有菩萨于往昔中千世尊所。发菩提心亲近恭敬。种种善根植种德本。如是菩萨。于彼未来五浊世中。虽遇善友发菩提心。而于广大智印法门微妙义理未能悟解。数起疑惑不生爱乐。不能受持读诵书写流通。亦复不能为人演说令生信解。复次弥勒。复有菩萨于往昔中经百千佛。发菩提心。种诸善根植众德本。于彼未来浊恶世中。虽遇善友发菩提心。于此广大甚深最上智印法门信解微劣。于深远义未能悟入。亦复不能受持读诵。为人称赞及与讲说。如是无上广大菩提甚深义利。复次弥勒。若有菩萨乃至往昔于一酤胝佛所发菩提心。种诸善根植众德本。彼于未来末世之中。虽遇善友发菩提心。于此广大微妙最胜智印法门。虽复听闻书写读诵好乐受持。于甚深义未能解了。不能为人分别解说。于第一义大菩提心未能印定。于此智印三摩地门无所了悟。复次弥勒。若有菩萨于彼往昔三十酤胝诸世尊所发菩提心。种诸善根植众德本。彼于未来末世之中。虽遇善友发菩提心。闻此广大智印法门。亦能听闻读诵受持书写流通为人演说。然于智印三摩地法。无决定心任持印可。不能成就真实义利。复次弥勒。若有菩萨于八十酤胝诸世尊所。闻此最上三摩地法如说修行复能化利诸有情类悉令信受。于是佛所发菩提心。种诸善根植众德本。于彼未来末世之中。菩提心力闻是广大甚深智印无上法门而能解了。受持读诵书写流通为人解说。深心爱乐堪任护持令速圆满。于是微妙三摩地门正解了已。于一切法悉皆通达。复于无上菩提广大法中离诸分别。摧伏一切诸恶魔怨。破坏一切不善业障。无量劫中随有所造诸苦因行。于未来世当受报者皆得解脱。又于往昔造不善因。至后恶世法欲灭时。善心微劣破坏正法。乐着外道世俗言教。增长戏论行非法行。出无义言不择高下。多所贪求诸恶有情。见不恭敬轻慢凌辱。于自所须一切乏少。如是苦因由此一生。证悟胜法大功德力皆得除灭。复由往昔亲近供养。如上所说一切诸佛所集善根。于彼未来末世之中。发菩提心而能任持。是三摩地最胜法门。离诸苦缚得不退转。三业坚固不生散乱。精进趣求菩提圣果。复次弥勒。若诸菩萨于往昔中。造不善业应堕恶道。于彼未来末世之中法欲灭时。闻是法门好乐受持。以是因缘。或以病苦怖畏交煎。先世罪业即得除灭。诸根不具受诸苦恼。生邪见家颛愚聚会生下贱家为人所使。生贫穷家衣食歉乏。生悭贪家不能拯济。若有所说人不信受。王法所加怨敌会遇。亲知厌弃心多忧恼。慈悲法会而多障阻。纵欲说法人不乐闻。所欲资生饮食衣服卧具医药。及看视人不逢惠施。贫穷亲附豪富弃捐。或被恶人来相娆乱憎嫉残害。所修善法不能增长。或于梦中见诸恶相。以是轻微诸苦逼迫。先世罪业即得消灭。业障灭已。设遇苦缘及诸怨贼不能为害。与魔相随虽不远离。而能了知诸魔境界。于诸名闻及与利养心不爱乐。为人亲近及以恭敬尊重赞叹不以为喜。修诸善行惠施有情。不生悭吝而求解脱。守护尸罗无所毁坏。修忍辱行饶益有情拔苦与乐。修精进行策励三业。勤求众善离诸恶欲。修习禅定散乱不生。以大智慧悟诸法性。方便愿力利乐有情。闻无量法心无忘失。修种种善为利有情。于世乐果不生希望。令诸众生速登彼岸。复次弥勒。彼诸菩萨曾于往昔百世尊所。发菩提心。真实平等种种善根。植众德本离诸苦缚。由为末世诸恶众生而来恼害。不能于此信解修习。何况末世诸恶众生。不种善根迷惑散乱而能觉悟。是故末世诸不善人。于此最胜甚深之法。不能信受如理修学。复次弥勒。若诸菩萨能于是法深生信解。志意坚固被忍辱铠。降伏诸魔长时修行。保护任持不生退屈。广大智慧无量善法从此法生。一心希求无上菩提。念念相应坚固不舍。复于未来。敷演妙义精进不倦。究竟护持是三摩地最上法门。了达一切善恶事业。安住法中勤修众行

佛说大乘智印经卷第四佛说大乘智印经卷第五

        西天宝轮大师赐紫沙门金总持等奉　诏译

尔时欢喜王菩萨弥勒菩萨妙吉祥菩萨。并六十不可思议菩萨摩诃萨等。在大众中而为上首。合掌恭敬咸白佛言大悲世尊。我等今者得闻如是微妙胜法。于彼未来坚固守护。教诸众生发无上慧。于此胜法如说而行。远离诸恶不生憍慢亦不贡高。无有谄曲爱憎之心。于彼自他怨亲之境悉皆平等。于诸如来无数酤胝百千万亿那庾多劫。所得无上大法总持智印法要。爱乐受持书写读诵。乃至展转相续流通而无间断。于时世尊。闻是欢喜王菩萨。弥勒菩萨。妙吉祥菩萨。并六十不可思议菩萨摩诃萨等。发生无上护正法心。安乐众生利益语已。于大众中以清净音而说偈言

  种诸善根离谄慢　　寂静安住无诸恶
  深忍坚固不动摇　　常正忆念于胜慧
  如是安住具大力　　而能守护法财聚
  离诸恶行无过患　　不为名闻与利养
  无有诤讼离染着　　普皆平等如虚空
  如是之人能守护　　渐次得成此三昧
  深忍坚固乐菩提　　昼夜精进无懈废
  守护威仪离诸恶　　于甚深法而增长
  世间一切诸财宝　　眷属亲姻无所爱
  悉皆厌舍离诸着　　无怨亲想心平等
  如是之人得成就　　无上大宝三摩地
  于昼夜中勤精进　　能于是法生觉悟
  尊重恭敬于善友　　欢喜称赞是三昧
  能解世间无尽法　　故于染境无所著
  印忍诸法心清净　　如百酤胝日光照
  智慧光明破诸暗　　能入如是深法义
  是人智解离诸着　　犹如日月处虚空
  与大雪山等坚厚　　镇压大地能庄严
  亦如释梵转轮王　　有大威仪人恭敬
  亦名无上大医王　　能除种种诸病苦
  尽诸业障心清净　　摧破魔罗诸眷属
  渐次成就他心智　　了别种种差别心
  忆念过去那庾劫　　灭除烦恼炽盛火
  此人善逝所称赞　　证悟菩提真空理
  能入如来智印门　　获诸无边诸宝藏
  了达名相无自性　　不着空有处中道
  观察五蕴如尘幻　　印证四大体非真
  一切有为皆生灭　　妄心造作成轮回
  胜智三昧性寂静　　离诸分别难思议
  湛然三世本自如　　无去无来无所动
  若见末世邪见人　　于佛正法着空有
  又复于此无所证　　自言我得法性空
  是各增长众生见　　世世远离菩提心
  复见有人随顺学　　涕泪悲泣身毛举
  又复末世诸释种　　具诸衰损无威仪
  为求菩提而出家　　于彼菩提不安住
  破戒破见毁威仪　　昼夜亲近不善人
  为贪利养及资生　　所得还将利亲族
  如渡大海失浮囊　　是必遥观彼岸远
  其有上乘真释子　　弃舍如是诸世间
  犹如莲华出淤泥　　本性清净无所染
  我今教汝欢喜王　　应当正念常守护
  摧伏妄想生真智　　于此希求具众德
  精进修学无懈怠　　是即名为诸佛子
  譬如世间谷麦种　　数如河沙那庾多
  以此种子致良田　　展转相生无量劫
  所得子实莫可量　　算数譬喻尚不及
  如是展转尽东方　　河沙数种亦如是
  乃至十方佛国土　　所种子实无差别
  如是一种为一佛　　一佛设复有百头
  一头而现于百舌　　共赞如来三摩地
  于彼殑伽沙劫中　　亦复宣说不能尽
  如将芥子等须弥　　又如纤草敌空界
  或以毛头一滴水　　用对无涯四大海
  如是功德共较量　　譬如算数不能及
  应当于此甚深经　　长时精进而修学

尔时欢喜王菩萨。弥勒菩萨。妙吉祥菩萨。并六十不可思议菩萨摩诃萨等。闻佛世尊说是偈已。发起坚固大菩提心。踊跃精进。复白佛言。大悲世尊。所有第一义谛。最胜涅槃甚深法义。我等众会虽生信心未能深解。惟愿世尊。为我等辈分别解说。于时世尊以一圆音。语欢喜王菩萨。弥勒菩萨。妙吉祥菩萨。并六十不可思议菩萨摩诃萨等言。善男子。如是胜法本来寂静。离诸分别绝诸戏论。假有名言显示宣说。诸菩萨言。大悲世尊。云何此法离诸分别绝诸戏论。假有言说方便显示。佛告善男子。如是胜法虽有言说。体不可得故无分别。云何此法体不可得。以是胜法无修无作。故不可得。云何此法无修无作。以是胜法本无生灭。故非修作。云何此法无有生灭。以是胜法性离所取亦非能取。故无生灭。云何此法无能所取。以是胜法无住无处。云何此法而无住处。以是胜法无变易相。故无住处。云何此法无变易相。以是胜法无彼无此。故无变易。云何此法无彼无此。以是胜法非有为亦非无为故。云何此法非有为亦非无为。以是胜法非虚非实故。云何此法非虚非实。以是胜法非心亦非非心故。云何此法非心亦非非心。以是胜法不可了别故。云何此法不可了别。以是胜法无有识变故。云何此法无有识变。以是胜法非相应非不相应故。云何此法非相应非不相应。以是胜法自性平等故。云何此法自性平等。以是胜法不可相求故。云何此法不可相求。以是胜法无安住相故。云何此法无安住相。以是胜法无有自相故。云何此法无有自相。以是胜法本性空寂故。云何此法本性空寂。以是胜法无染着故。云何此法无染着。以是胜法离彼言说清净故。善男子。由是胜法离诸分别无修无作。乃至离彼言说性清净故。名为涅槃。尔时欢喜王菩萨。弥勒菩萨。妙吉祥菩萨。并六十不可思议菩萨摩诃萨等。而白佛言。世尊。如是胜法人所难解。世尊。一切诸法入法界性了无所得。如是法性。令我等辈云何守护。佛告欢喜王菩萨。妙吉祥菩萨。并六十不可思议菩萨摩诃萨言。善男子等。如是胜法不可思议。离诸分别及以戏论。若于是法起分别想。及以戏论则法有二。若法有二则堕生灭。何以故。此无上法第一义谛。亦无有生亦无有灭。如是了知是名守护。尔时世尊。为诸菩萨复说偈言

  无作胜法非空有　　离诸言说及分别
  若有得法着二边　　是名分别诸戏论
  而于是法不相应　　但能增长于染慧
  此法无相无憎爱　　离诸推求无所得
  若自说言我忍空　　自生分别诸戏论
  彼诸空性不可得　　以分别心难思量
  若于诸法无疑谤　　是即名为不退转
  离烦恼缚得解脱　　于此胜法心印忍
  若人妄了生分别　　寻求推度失正解
  筹量诸法著有空　　以性以相本无二
  用智求智不可得　　智外更无余智慧
  演说轮回有为相　　是智非智迷真空
  若言少分是实有　　虚妄想故成生灭
  若证真实即能知　　一切诸法本常住
  愚人妄想成流转　　厌生死故求涅槃
  增长我见有差别　　智者了知法无二
  明与无明本同体　　由不信故怀惊怖
  是人坚固执边见　　增长言说诸戏论
  说有为法名涅槃　　是于正法生破坏
  心与非心无自性　　而彼自性亦非心
  一切诸法本无相　　无言无说湛然空
  法从缘起非真实　　诸法灭尽亦非谛
  八谛四谛明真俗　　亦名如来方便智
  如来实智不可得　　所说诸法亦复然
  譬如医师治诸病　　随病处方无执着
  若能如是生觉悟　　是则名为善逝子
  涅槃本性皆平等　　廓如太虚无边际
  三乘圣智同涅槃　　无灭无增无戏论
  法界实无一众生　　亦无一字可言说
  有情执自分别心　　谓是涅槃无所住
  无明妄念结轮回　　惑业生苦常相续
  一真实谛离开见　　或言四种亦随宜
  有苦报故说集因　　由灭理故明道谛
  末世众生多妄想　　不为净行而出家
  以名利故破威仪　　积烦恼故兴斗讼
  修习功德诸比丘　　于此胜法能成就
  远离名闻及资生　　乐居兰若无求取
  譬如麟角独居山　　思惟如是三摩地
  八十酤胝两足尊　　慈心加被修习者
  诸天见已咸欢喜　　潜形昼夜常守护
  智慧破暗如日光　　出生胜法同甘露
  其有受者智印门　　梦中常与诸佛会
  汝等皆怀勇猛心　　坚固修习无退舍

尔时世尊复告妙吉祥童真菩萨言。妙吉祥。若诸菩萨及末世众生。为欲成就无上菩提。于是三摩地智印深法。相应修学。为欲成就如来八十种好。于是三摩地智印深法。相应修学。为欲成就如来十八不共胜法。于是三摩地智印深法。相应修学。为欲成就如来十力。四无所畏。四无量心。大慈大悲大喜大舍。于是三摩地智印深法。相应修学。为欲成就诸佛五眼。于是三摩地智印深法。相应修学。欲得诸佛广大寿命。种种庄严胜妙国土威德自在。于此三摩地智印深法相应修学。为欲成就诸大菩萨利根声闻。欲得如来智慧色身。广大总持胜妙法门。及解一切众生言音差别心行根性。具足神通辩才无碍晓了诸法。于是三摩地相应修学。所以者何。菩萨摩诃萨若于是三摩地而得相应。所获如是种种功德普遍具足。成就菩提无上大法。诸法所依名无上道。智出世间号正遍知。自性寂静名为如来。如说修行而无有等。非等等故无起无灭。出世究竟离诸言说。名第一谛真实义谛。无所破坏坚固调伏。是名如来不可思议最胜之法。妙吉祥。我由往昔修习安住是三摩地智印深法。见然灯佛。得无生忍授菩提记。时妙吉祥菩萨而白佛言。世尊。如来于然灯佛所。悟无生忍得菩提记。于无量劫在生死中。云何修诸难行苦行得成菩提。佛告妙吉祥菩萨摩诃萨言。我于往昔为求佛道。成熟一切诸众生等清净善根。以大愿力经无量时。勤修苦行化利有情。随其根性有上中下。各令悟入三乘法义。渐次修行而有所证。妙吉祥。我于尔时因是愿行。而得菩提及与涅槃。尔时世尊而说偈言

  若欲是法而相应　　获得如来无量慧
  十方百亿诸世尊　　皆悉来护修习者
  若于甘露甚深法　　能解一切诸妙义
  是名总持陀罗尼　　修习之者皆获得
  解了言音灭诸罪　　能破执着解诸缚
  涅槃无生亦无灭　　无去无来无住处
  庄严十力诸相好　　成就一切佛功德
  圆满清净解脱音　　普应无量诸含识
  所出音声能解了　　一切闻者皆欢喜
  远离邪见无分别　　最胜清净尽无垢
  能于是经相应学　　究竟能得菩提道
  若人于彼三七日　　一心思惟如是法
  不生懈怠舍亲缘　　昼夜修习得增长
  慈悲远离于嫉妒　　守护尸罗绝诤讼
  获得平等正遍知　　深心欢喜常解脱
  远离造作诸缘起　　譬如莲华不染着
  坚固不起诸贪爱　　亦如飞禽离系缚
  得此最胜法门时　　三千世界皆震动
  诸天竞奏妙音乐　　散施末香及沉水
  百千幢幡及天衣　　清净华鬘及璎珞
  摩尼珠冠及宝盖　　金铃间错悉庄严
  一切诸天作歌舞　　诸龙金翅修罗王
  比丘僧与优婆塞　　比丘尼及乌婆夷
  各各脱身上妙衣　　以用散佛为供养
  恭敬赞叹意思惟　　誓求于此无上道
  我说如是甚深法　　发生菩提心不退
  此会河沙信解人　　究竟皆得无生忍
  诸余刹土未来众　　展转闻法心欢喜

尔时世尊说是偈已。阿僧祇数诸众生等。各踊跃发菩提心。复有八十那庾多数诸大菩萨。得闻是法。于无上道得不退转。复有六万三酤胝菩萨摩诃萨。得无生法忍。复有六十三酤胝菩萨摩诃萨。而得三摩地。无数众生而得圣果。十方所来诸大菩萨。得悟如是智印三昧。佛说此经已。六十不可思议菩萨。欢喜王菩萨。弥勒菩萨。妙吉祥菩萨摩诃萨等。而为上首。与贤劫中诸大菩萨。并贤吉祥金光夫人诸大声闻。一切世间天人四众。乾闼婆王阿修罗等。闻佛所说皆大欢喜信受奉行

佛说大乘智印经卷第五


佛说大方等顶王经

    No. 477 [Nos. 478, 479]

佛说大方等顶王经(一名维摩诘子问)

        西晋月氏三藏竺法护译

闻如是一时佛游于维耶离奈氏树园。与大比丘众俱。比丘八百菩萨一万。一切大圣神通以达。悉得总持辩才无碍。摄三世慧至三达智。空无相愿不中取证。行于大慈奉无盖哀。不计吾我以度彼岸。通于三世无去来今。晓一切法如幻化梦影向野马芭蕉水泡聚沫。解于三处本无所有。从缘对生有利无利。若誉若谤得名失誉。若苦若乐以过世间之所有法。因权方便周旋三涂。以超欲界色界无色界。解畅道义救度一切。诸天来侍咨受深法。开发愚心悉入道明

尔时世尊明旦着衣持钵。入维耶离城分卫。至维摩诘舍。时维摩诘有子名曰善思。明旦沐浴以香涂身。体着新衣手执莲华。与妻室俱上楼阁观作妓相娱。宿命德本之所感应。遥见佛来与圣众俱入城分卫。现大瑞变以偈语妻。所说雅颂歌佛功德

  闻斯和雅音　　同时今俱作
  众妓在其处　　速彻楼阁上
  大雄来不疑　　护世演光辉
  必以足右指　　蹈于城门阃
  百鸟诸禽兽　　发哀悲和声
  从古未曾闻　　如是诸妙向
  大雄来不疑　　欲导利众生
  今举右足指　　以安着门阃
  我今日睹佛　　犹宝璎珞身
  众妓不鼓鸣　　微妙可悦心
  三千圣无疑　　威德净庄严
  必以右足指　　蹈于城门阃
  譬如有大钵　　着池河水至
  则闻调和音　　周遍其土地
  人中天无疑　　大圣演尊光
  佛开导世间　　定来入城门
  神通化众生　　犹树华茂盛
  若干色芬葩　　流布极美香
  大龙无所疑　　誓愿建立本
  今以右足指　　安于城门阃
  普照于虚空　　周遍于天地
  日明为以蔽　　永不复现光
  一切尊无疑　　现威大晃耀
  今以右足指　　安于城门阃
  犹如诸天人　　住于虚空中
  众庶佛后从　　如天侍梵王
  愍伤世无疑　　尊人圣导师
  今以右足指　　安于城门阃
  今日观城人　　各慈向不恨
  展转相示谈　　如父母子孙
  德光无沉吟　　福威自庄严
  今以右足指　　安于城门阃
  察男女大小　　各执若干花
  叉手而自归　　欢悦遥散花
  大导无犹豫　　德花严饰身
  今以右足指　　安于城门阃
  诸天人间华　　遍布于虚空
  散华而烧香　　其香可意悦
  大勇无疑结　　欲入维耶离
  因化悦大众　　最胜故到此

尔时善思妻室。闻说是言心中抱恐。衣毛为竖身内和凉。住于兰边心自念言。是何等神。为天龙鬼魅反足手。真陀罗摩休勒人非人耶。口宣人语在其处所。不动不摇不敢移转。时佛往诣善思童子所居里中。在于舍边立在门前。善思童子见佛世尊。即欲下楼阁往自奉迎。心中喜悦不能自胜。已投楼下承佛圣旨。住于虚空以偈叹佛

  圣慧尊且住　　人中雄愍待
  用哀众生故　　唯受斯水浆

于是世尊。为善思说偈言

  以住真本际　　世俗所不达
  彼际无所有　　是为本际相

善思童子。以偈问佛

  云何住本际　　真本际化导
  无明之猗际　　何谓立虚无

时佛复以偈。告善思曰

  其际真本际　　是际则如来
  如审住本际　　了了住如是
  如际真本际　　斯则如来际
  犹了真本际　　童子住亦然

善思童子。复以偈白佛言

  无际际何际　　何所是际相
  以何权方便　　名曰为本际

于是世尊。睹见善思心欲畅了解道无处。告于善思童子。以偈报曰

  无际不可待　　乃曰真本际
  其际相虚空　　虚空亦无相

善思为佛。说偈问言

  甚哉真正处　　其处玄无上
  使一切众生　　住如今导师

时善思童子前白佛言。世尊。垂愍受斯莲华。佛便受之。善思童子口身发言。以是功德致无上正真之道。成最正觉。为诸众生班宣经典。令不得至凡夫之法不至道法。尔时贤者舍利弗。亦在会中谓善思童子。于善思心所趣云何。所成正觉法何所像。欲为众生而班宣之。善思以诵答说偈言

  佛志无所得　　诸声闻亦然
  当成斯正觉　　为众生班宣
  彼无所向说　　亦复无所致
  大智当解斯　　本净明如是
  过去诸正觉　　护世无上尊
  亦不得诸法　　导世因灭度
  计求无法界　　亦无众生界
  是则为本际　　世俗所不畅
  假号曰世界　　人猗相名号
  亦无诸所想　　更无有异业

尔时邠耨文陀尼子。为善思童子说是偈言

  童子卿云何　　而欲学斯法
  是处深难逮　　明者所迷惑
  仁生来久如　　智慧独勇猛
  与声闻谈语　　卒对慧无畏
  处处能分别　　所住像紫金
  立王路巍巍　　犹虚空月盛

时善思童子。以偈答言

  唯仁问所生　　所生无所生
  诸法无所起　　谁当复生者
  其法无所生　　自然无所有
  是曰本清净　　无法无所得
  诸法本清净　　未曾能得是
  以斯无明慢　　佛故说是法
  在于仙人野　　第一转此轮
  多存声闻业　　系志在虚空
  宣畅法音向　　为众多辩才
  以权来圣慧　　宣说如审谛
  有生乃终没　　斯愚之行无
  处在颠倒业　　如邠耨所说
  以生有老死　　是为方俗言
  其法无言辞　　托假造言教

尔时贤者邠耨文陀尼子前白佛言。至未曾有。世尊。今是善思童子。深入智慧巍巍乃尔。所宣独步众所不逮。佛言。如是如是。如邠耨言而无有异也。时佛告菩萨善思童子。卿何以故。欲逮无上正真之道为最正觉乎。善思答曰。圣尊所明故复相问。用最大圣故被弘誓。大圣至仁因宣是语。我身寂然不有所为。以被弘誓悉无挂碍。无所开化尔乃名曰斯深上句。众生无人亦然。其不或斯是等能度。至贤详序深妙上句。晓了斯本真际本末。其以无数无有若干。解达深妙无上章句。以用法故化此众生。其行各异诲无众生。设无众生彼一切空。无智智慧众生本净。以达本净无有各异。以解斯义是世明智。唯然圣尊。我蒙解斯。自成正觉为众说法

贤者阿难前白佛言。至未曾有是善思童子。辩才乃深入如是乎。乃能宣斯应顺妙章无所著句。天上世间凡庶众人阿须轮闻必当恐怖不肯受学。谁当信乐此深妙法。往昔宿世曾闻学是深远之行。尔乃信受。于时阿难以偈叹曰

  犹如须弥顶　　远现微妙好
  今此善思德　　在众妙如是
  若如众山王　　坚住于大海
  今处斯众中　　快宣此妙句
  善思所咨嗟　　说名不有无
  亦光于本际　　世俗所不观
  其辞无所畏　　莫不敬叹者
  唯善思说之　　云何知本末

善思以偈报曰

  吾以弃身命　　被无挂碍铠
  志不贪正觉　　尔乃曰博闻
  猗欲故堕落　　合集极殃祸
  谁不堕灾者　　唯见世导师
  是诸佛境界　　护世所持济
  其身无所厄　　住于佛尊道
  虚空及人身　　二俱不可得
  如法不可得　　法怀无所畏
  晓虚空佛身　　真实无处所
  若成是忍辱　　永悉无所畏
  其虚空至地　　自然无所有
  是自然善思　　达悉无处所
  其虚空至地　　善思不可得
  无生无自然　　虚寂无所有
  虚空无有高　　亦复无有下
  以解了是法　　彼悉无所畏

尔时佛告善思童子。仁者。体性无所畏乎。白佛不也。世尊佛复重问。卿审不畏乎。白曰不也。佛言。善哉善哉。仁乃无畏不怀恐惧。时佛颂曰

  从有而生畏　　假现无所有
  若能解是忍　　尔乃近佛道
  因人想有畏　　众生本永无
  若能解如是　　于斯无所住
  其不得正觉　　无觉亦如斯
  若余无所获　　此傥无所畏
  若能晓了斯　　不住有无际
  善思解如是　　是为由佛道

佛告善思。若有菩萨疾欲永安逮无上正真之道。为最正觉者。便当消除有常想安想苦想众生之想人寿命想。分别解了无所著行悉无所猗。作是慕业逮成无上正真之道也。佛往宿世行菩萨业时。作是行道以便怀来慧。无能得法乃曰佛道。时佛颂曰

  解常想犹幻　　计常致生死
  常无常虚无　　求业无所有
  众生有安想　　了不安自然
  是想为颠倒　　用想有人故
  若解了法者　　无有各各异
  则不怀望想　　无命无有人
  道明不得由　　无道亦复然
  是乃曰本净　　法无所有故
  若有明达者　　晓有悉本净
  善思当解斯　　是为道正道
  不行于道乘　　佛乘所救济
  若有人诤斯　　便不畅道法
  不行于慧业　　不为道所护
  用不顺此行　　佛法深难解
  诸法无所法　　本悉无形貌
  所有亦虚无　　三界永不安
  计诸乐众苦　　犹如行虚空
  若能思是行　　斯乃心解脱
  有身云吾我　　彼法亦虚无
  其不有吾我　　所知无所有
  斯等不想命　　不得究本末
  虚无想真实　　少明为迷惑
  吾我及寿命　　本净无所有
  愚冥之所行　　计本净而有
  佛道无思议　　不念是所有
  若闻深妙法　　不能受奉持
  未曾有班宣　　如是经法者
  法不可逮得　　所说亦无获
  坐于佛树下　　因是成道慧
  若不致道慧　　则亦无所知
  佛道及慧场　　亦无有言说
  凡夫怀望想　　慕佛所演法
  斯则真实教　　佛所宣深妙
  其意觉甚深　　是为魔所行
  若有得闻是　　佛所说经典
  不解经义味　　诸法所救护
  菩萨甚勤苦　　不求道安隐
  于斯无道觉　　是二事无像
  意当倚慕斯　　有是佛所说
  是何此云何　　着于颠倒业
  若有过苦恼　　甚着于深妙
  各称举大音　　快佛无思议

佛复告善思。学是法者当习深典。勿得志存杂句多辞无益之义。不成正真无极大慧深远之法。乃曰优奥。是乃应法斯曰无得。众生堕邪不能行斯。不用三昧可解利义。慧无境界无慧亦然。当了斯际非智所行。佛往宿世闻是深法。以解寂净心无所著。若闻斯典得悦豫喜。曾于无数佛所造行立功勋德。受着心怀讽诵奉行。以化他人宣布十方

佛复告善思童子。菩萨当修如是弘誓。世人所在常抱恐畏。勤学至真不当怀惧也。畏难退却当作是解。宣布奉行乃入道慧。善思前白佛言。唯然信乐也。世俗所不信独笃无穷。志旷如空永无所慕。佛复语善思。若菩萨大士志深妙法。斯诸正士以是方便顺如佛教。则于道法无所诤讼。以不诤讼一切诸法则无恐怖。皆不可断。一切诸法了之本无。志无所慕便入道慧。若有闻说一切法有不以为怖。若说言无不以为懅。于有无法不以增损。闻诸法应诸法不应。诸法精进诸法懈怠。解是一切十方诸法。慧所归趣若无所趣。若复不解诸法有念诸法无念不以恐怖。诸法有为诸法无为。诸法有界诸法无界。诸法忻喜诸法无喜不以恐怖。一切诸法亦不有为亦不无为。一切诸法本有所有本无所有。诸法寂然诸法愦乱不以恐怖。诸法颠倒无有颠倒。诸法虚无真实无为不以恐怖。诸法一切有戒无戒。有明无明有名无名。有兴无兴有畏无畏。有生无生有死无死不以恐怖。诸法有道诸法无道。诸法有度若不灭度。诸法是非不以恐怖。所以者何。诸法皆空虚无不真。犹如幻化泡沫芭蕉影向野马。梦中所见本无从来去无所至。犹如虚空忽现云雾尘烟灰等。托现虚空不能为垢。忽然便灭虚空自然亦无所净。有道无道世俗慧明。普解自然乃无所著了无所了。乃应道慧无上正真。无所恐畏心不怀懅。佛于是颂曰

  诸法无所有　　自然虚不真
  其自然虚无　　是相便灭度
  诸法无所诤　　斯亦无所有
  以了诸法无　　达不有自然
  所诤讼诸法　　是亦无所有
  以晓法虚无　　则解不诤讼
  诸法无所有　　本净永无形
  本净不可得　　亦无所忘失
  断一切诸法　　故曰为明智
  斯谓永毁坏　　亦现无所坏
  诸法无所灭　　计亦无起立
  亦多无所坏　　法亦不可得
  诸法本虚无　　亦不可得见
  设使无所得　　方便现所有
  诸法无所有　　因缘从对生
  所有无所有　　班宣于经典
  诸法能相应　　示现无所诤
  不诤为自然　　究竟无有形
  诸法无所应　　无作不灭度
  如是不可得　　常离于诸数
  诸法不可得　　亦无有过去
  甚哉永无实　　乃曰本真际
  诸法皆悦豫　　亦不可悦喜
  若法不可得　　彼亦无言说
  诸法无放逸　　二俱无所有
  自然无可取　　是为深妙相
  诸法不可知　　无我而自然
  以解无志求　　至于自然号
  无为无所乐　　彼亦无所有
  用有无明业　　因号曰无为
  若念于诸法　　究竟不可见
  此则真实言　　故名曰意念
  不念于诸法　　无住无所归
  了斯无众生　　是号法中法
  一切法犹幻　　其幻无所有
  以法无明故　　因宣说生死
  诸法无形貌　　是其自然义
  若无有诸法　　解脱无解脱
  假号曰境界　　自然无境界
  愚冥所倚着　　故名曰部界

佛复告善思。色痛想行识空本无所有。眼耳鼻口身心空本无所有地水火风空本亦无形。因缘合成犹如五事成其屋宅。何谓为五。一曰材木。二曰瓦草。三曰土堑。四曰人功。五曰泥水。以是五事乃成为屋。本各别时都无屋名。因缘合成身亦如是。五阴缘对便有四大。因名曰身地水火风各缘来合。犹屋四柱四壁皆因缘会。合成散坏皆无处所。犹如梦中见屋宅城郭树木华实。流水田地犁牛诸种下其五谷各随时生。人主用意获之自给。心神无明不达一切三界皆空。因倚望求便生意识。十二牵连往来周旋。轮转无际劳于神识。沉迷五趣无懈息时。不解本空如梦所见。觉不知处何所归趣。至成正觉乃了五趣。本无处所独步无畏。佛于是颂曰

  色痛想识空　　眼耳鼻口意
  本寂无所有　　地水风火异
  了界得自在　　班宣无部章
  所言上佛土　　其境灭度想
  诸法各有形　　本亦无合会
  不晓知空寂　　其本无有身
  无得不可逮　　从缘对合成
  无获不可致　　又现望得生
  在彼不修戒　　亦复不犯禁
  无行无有戒　　是为诸法相
  诸法无所有　　因无明而生
  以有无明法　　便造明达智
  诸法假有名　　是名无所有
  假号无有法　　乃名曰灭度
  所起无所生　　因现有五阴
  其阴无所见　　因号有所现
  所有无处所　　因变示有法
  法离生死业　　长无生死难
  如幻师化形　　愚冥谓有人
  所有无所有　　明者不为迷
  法生无所生　　慧者无是计
  诸法皆悉空　　愚者不解此
  法适有所生　　便当有终没
  其生及病死　　舍是无所畏
  诸法一切空　　法亦无所归
  善思当了斯　　是佛所演法
  正觉无所作　　则为不可逮
  若不得道处　　乃见三界事
  若望想佛道　　则不求正觉
  若行志存道　　永不造无想
  诸生死自然　　不观自然法
  自然无所有　　是为无为想
  究竟无所生　　所说不可得
  以行无明业　　因示无为法
  以怀来众义　　诸法则自然
  彼悉无所生　　便无诤讼事
  彼无不奉行　　所宣深妙法
  用一切起生　　菩萨行愍哀

尔时善思以偈答世尊曰

  佛兴出现世　　皆用愍我等
  身以为疑网　　宣布是法义
  佛出无思议　　为具足兴变
  以坏魔罗网　　说除六十二
  以绝生死元　　因坐佛树下
  永无有沉吟　　宣消众想着
  解畅虚伪业　　能仁灭诸见
  勇猛为世俗　　断我众狐疑

尔时世尊告善思童子。菩萨所行未曾虚妄。多所救护以恩加济无有诤讼。除去众瑕一切无秽。愍伤众生行深远义不怀望想。世无坚固消去贪欲。以无贪欲蠲弃众结。常行等心加于众生志不虚妄。大慈之行法不可得。修大义吼不舍精进。心行至真不失勤业。无有娆害奉行忍辱而不诤讼。无所睹见夙夜尊行。善思一心弃于懈怠成就道行。定意正受其心寂静。修于善慧一切诸法永无所得。行无所畏心不怯羸。显发道心行无挂碍。成就如来十种之力。当以何行至殊特业。尊其至慧奉无等伦。游于十方诸佛世界。行无挂碍度脱一切。时佛颂曰

  行无虚妄业　　是诸菩萨辞
  以奉于脱门　　不畏诸碍行
  无行谓正行　　是菩萨之业
  若能解是行　　则无所贪求
  以法救摄之　　诸菩萨所宣
  其无所得义　　是行为无上
  言吾行道法　　则住于颠倒
  以住颠倒业　　便得有所畏
  假使有诤讼　　不见诤所在
  明者作是达　　行于无上乘
  是乘无所畏　　大乘最无极
  畏与无所畏　　是亦无放逸
  一切无所有　　众行中最胜
  设了悉虚静　　彼行无上道
  斯行甚微妙　　救护一切法
  所济亦深远　　消除众望想
  所行邈玄妙　　二俱无处所
  若能知本际　　不倚念于法
  法永无众垢　　亦不离垢去
  是法本清净　　反宣舍于欲
  而示现邪逆　　爱欲不坚固
  不转文字业　　斯句为无上
  不着犹如幻　　此则无言教
  以弃反倒行　　便无诤讼意
  一切众生行　　是实不可得
  若能晓了斯　　此行乃善教
  众生以无明　　故曰名黎庶
  众生法亦尔　　是道则无上
  其念及众生　　是永不可得
  此为第一慈　　叹慈乃无极
  是曰世大施　　斯乃为大士
  常慕乐放舍　　乃曰慧道心
  正使不得法　　诸法虚无实
  示菩萨明达　　是曰好布施
  解法不可得　　便无所恐畏
  无尊是之法　　乃曰为布施
  法貌不可获　　佛法不可思
  是戒无所犯　　诸法无所著
  佛土不可议　　此不见诸界
  于戒不望想　　诸菩萨所叹
  能忍诸众生　　一切不可得
  佛所教训诲　　是法第一忍

佛复告善思。色空不可得。痛想行识空亦不可得。所谓空者色则为空无复异空。痛想行识空无复异空。四大五阴十八诸种三界本空。十二因缘无则为空无复异空。现世度世有为无为。四大皆空无复异空。色如聚沫痛痒如泡。思想如芭蕉。生死如梦。识如幻。三界犹化。五趣如影所以如影从缘对生。三界本末欲界色界及无色界心意所为。犹如画师治素壁板。因缘合成犹如飞鸟飞行空中。菩萨如是行无望想旋到十方。犹日宫殿行于虚空不污众冥。菩萨如是独步三界心无所著。去淫怒痴三毒窈冥。犹如莲华生于泥中不与其合。菩萨如是在于生死成最正觉。心净如空永无所著度脱一切。佛时颂曰

  其心不可得　　则无有诤讼
  若不得众生　　是为第一忍
  菩萨离懈怠　　其志无所行
  永无所勤修　　乃曰最精进
  其身及心意　　所遣直无邪
  菩萨无所说　　是第一精进
  若有懈怠者　　菩萨化立之
  无心无所行　　住第一精进
  其心不可得　　内外无所著
  若心不可逮　　是则为定意
  心常自勤修　　自然无所有
  无思无正受　　乃曰逮三昧
  所以言定意　　以能作是行
  安住名自然　　是第一定意
  不知慧所在　　何所自然法
  自然及与慧　　二俱无所有
  是法不可得　　斯识行正法
  不以识知法　　自然无所有
  若有了此行　　菩萨意坚强
  行第一之义　　世所无所趣
  众会无等伦　　为众而宣法
  斯等虽游居　　无众生望想

佛复告善思。一切诸法犹如幻化。幻化本空悉无所有。迷惑愚俗自计己身及与他人。悉有所有故沈五趣。敢能晓了是悉无所畏。诸法本末无有内外。以了如是心不怯弱。不难三界三界悉空。若有菩萨晓是本无。独步三世而无所难。达于生死犹如虚空无形本亦无名。一切诸法亦复如是无形无名。用无明故驰逸三界转轮无际。犹如五事住于虚空不能为垢。自然之故心本清净。权未即解便有三毒五阴六衰客尘所蔽。虽有是非不污本净心亘开达。畅三世空便入大道。佛时颂曰

  众生犹如幻　　其幻无所有
  所宣如是者　　永无所复畏
  己身与他人　　二俱虚无寂
  以能晓了是　　则永无所畏
  其内及外法　　不计有所在
  无以怯弱心　　不难于世俗
  诸法无所碍　　犹如旋虚空
  所至如虚空　　是法为自然
  若能晓了斯　　菩萨无所畏
  分别一切法　　解了众生行
  彼不得众生　　其法皆如是
  以剖判诸界　　其界无所有
  是曰入道行　　斯曰无上道
  以致此至业　　知众生心行
  诸界及众生　　二俱无所有
  以念彼如是　　皆了一切法
  其内及外事　　无合会望想
  以为不除法　　乃曰真本际
  斯法无思议　　乃曰为佛法
  此悉无所有　　悉亦无所成
  所行能如是　　计数无有人
  以无为之慧　　乃曰为佛慧
  是乘为大众　　普安于一切
  永不畏此世　　世亦无所有
  其在于世界　　普世一切界
  菩萨无所行　　求于无上慧
  是法为深远　　佛法不可思
  若法无可获　　是则近佛道
  其佛及经法　　此一切悉无
  若行如是者　　则得近佛道
  以行如是者　　俗人无与侣
  其心无所著　　彼乃近佛道

佛复告善思。若有菩萨大士闻是深经。若读持讽诵心不恐怖。善被弘誓心如金刚。疾近佛树坐于道场。近佛境界得亲至真无碍脱门。观于无为无合会处。到于十方诸佛世界。建习大慈无盖道哀。成十八不共诸佛之法。三世最尊慧喻日月。德无等侣慧过虚空。道明巍巍不可为喻。逮无边圣无见顶相。若有闻是无限雅典。以斯深卷为人班宣而信乐者。往过去世曾见诸佛亦不可计。又不轻慢戏笑之者。佛以豫见观其人本早信此经如来久睹。若不信乐习斯经典。闻之调戏则外异学诸魔官属放逸之人也。信是法者是佛弟子佛则是师为亲成就下其须发而作沙门。其不信者则外邪业。九十六种反逆道法。佛时颂曰

  见佛坐树下　　行于真道场
  其不信佛道　　是慧不可得
  其无挂碍法　　究竟不可得
  了法无处所　　是曰为解脱
  意入于圣慧　　一切法之王
  诸法及道慧　　非佛之所宣
  有为及无为　　愚所发望想
  诸菩萨无想　　诸佛大圣明
  普观于斯世　　世悉不可得
  所用晓了世　　是亦无处所
  佛圣及众生　　于是无望想
  其无思想者　　善哉慈无上
  假使众生界　　法界亦复然
  是乃名之曰　　菩萨无所著
  以睹于悲哀　　其哀无形貌
  其哀以无貌　　非愚所了行
  五事在虚空　　不有无处所
  一切俗如是　　是乃无上哀
  其无上正法　　乃曰为佛法
  此无所贪世　　是为自然法
  护世之所照　　其色无所有
  以是无色法　　乃曰无见顶
  虚空无有边　　普平不可获
  是为佛正法　　名曰无能观
  其慧不可逮　　是无上大道
  慧以不可得　　斯无有坚固
  此际及彼岸　　所见若不见
  深解不行斯　　是非妄想求
  念是智慧法　　斯法则平等
  违此佛教法　　则非善亲友
  无勤若勤度　　乃曰到虚妄
  其不行平等　　则非善亲友
  以发兴斯法　　若复灭斯法
  此等诸比丘　　不善思佛教
  以能断众苦　　本净无所有
  如是说法者　　则班宣佛教

佛复告善思。若说诸行皆从习致。用三界习故修道习。有计吾我故行大慈修无盖哀。倚于三界行三脱门。慕四大故行无常苦空非身。以生老病死求四无畏。用十二因缘了十二部经。以十八种行十八不共诸佛之法。用十方众犯十恶故。行十善求十种力。用三弊故致三达智。着六情故行六度无极六通独步。应病与药使济危厄。佛犹良医经法如药。用疾病故而有医药。无病则无药一切本空。无形无名亦无假号。心等如空无比无侣。忽然无际尔乃应道。佛时颂曰

  其无所住法　　于中习所行
  班宣修消除　　去佛法大远
  若于斯寂法　　造虚妄思想
  以虚妄之法　　不亲近灭度
  其宣于诤讼　　斯为之灭度
  善思当了是　　斯无正见行
  若有修行道　　宣布反逆事
  朋友乱颠倒　　是为学者业
  佛所演讲说　　菩萨大名称
  当来诸就学　　故劝化行道
  若有奉持是　　佛所化深妙
  用一切众生　　以为供养佛
  若有明智者　　受持是真法
  斯等将来世　　用正法存立
  其不行是法　　心立存思想
  自谓则应慧　　不用余致道

佛说是经时。善思童子。寻时逮得无所从生法忍。忻然大悦涌在虚空。去地四丈九尺。时佛忻笑。五色光明巍巍甚妙。青黄赤白红紫之色从佛口出。照于十方无量佛土。还绕佛三匝从顶上入。六反振动是三千大千世界。上虚空中天雨细捣栴檀香。木蜜众香。雨天好华晃耀人目。箜篌乐器不鼓自鸣。庄严虚空周匝十方靡不校饰。此三千大千世界。罗列诸宝交露[王*屈]琦妙帐。高阁树木流水浴池。五音俱发和雅悲哀。闻见此变莫不悦豫得未曾有。贤者阿难即从坐起。偏露右臂更整衣服。长跪叉手前白佛言。以何缘笑。既笑当有意。以偈叹佛

  圣尊未曾妄　　大明不虚忻
  慈愍世雄说　　何缘而忻笑
  天处虚空中　　供养人中上
  各口而歌咏　　快哉宣经典
  如高灯电光　　若干色微妙
  斯耀亦如斯　　光光照远近
  如诸佛之法　　授与正道决
  还绕身三匝　　忽没于顶上
  圣尊笑辉耀　　若干种光色
  出佛口入顶　　唯说此瑞意

尔时世尊。为贤者阿难。说颂曰

  善思族姓子　　造立德无量
  当成如来觉　　逮致天人尊

佛语阿难。是善思童子。当值不可计会亿垓兆佛。世世随侍未曾远之。常用至心供养诸佛。衣被饭食床榻卧具病瘦医药。佛灭度后供养舍利。兴众宝塔高四万里。以持舍利着众宝塔奉事供养。以好名香众华衣服众妙若干种宝伎乐幢幡栴檀杂香。以解脱华及众缯彩。以用供事诸如来至真等正觉。最后末世当得佛道。号无垢光如来至真等正觉明行成为善逝世间解无上士道法御天人师佛世尊。尔时大圣。即说颂曰

  若以众杂宝　　充满十方界
  以用施诸佛　　护世众如来
  若闻是经典　　德多过彼施
  住力讲说法　　护世照三界

尔时舍利弗闻佛所说。欢喜心悦得未曾有。念佛至圣德踰须弥慧超三世。道不可比如空无侣。探古知今所睹无限。智明旷然无以为喻。救厄通明犹空无际一切蒙慈。时舍利弗。念佛恩德恭恪说偈。而叹颂曰

  是经甚微妙　　护世之所宣
  不说其名号　　云何知其称
  古来未曾闻　　班宣于斯法
  彼不得住处　　甚哉说法快
  假使有漏法　　及与无漏法
  计亦无所得　　甚哉快说法
  若令有为界　　及与无为界
  斯二无所积　　是经归如斯
  护世宣妙法　　道行正真教
  睹不得处所　　此经义如是
  所说诸佛法　　于斯无所叹
  吾我不可得　　甚哉快说经
  设使十方世　　自然无所有
  护世之所宣　　未及此经趣
  唯愍世宣之　　人中最愿演
  班宣是经名　　今所未称号

佛告舍利弗。是经名顶王当共传号。大智。当了所以名顶王。如须弥顶皆见四天下。解是经慧得四无畏无上大道。无生老病死度三界厄。若世人好喜是法。十方靡不蒙济。故名顶王。常奉持斯。若有持此佛所宣经。当为世护诸天人民百万亿众。兴无数德无上正真。不为缘觉及与声闻。若宣是法必得成就无极世护。以得闻法深难究畅处处演义。解了是法深奥无上当得成佛。以能奉持于一切法无复狐疑。若受斯经所宣至化所喻顶王。不但当得第一法忍。第二第三具三忍法。其法不可得道无处所。无所光显乃布大道。于一切法此人无欲现在无求。若持是经佛所班宣顶王言辞。讽诵化人福不可量。若有女人受持斯经。以行智慧疾得殊胜。舍女恶态知一切一。以知众一便持是法。班宣斯经入诸行业。明了一切诸所归趣。以入此法说多所照。知若干品所行精进。无数众人悉受道教。本空无法所可班宣。皆无处所悉不可得。所以者何。本末空故。从古以来义不可逮一切法然。奉持是门法无可得。则不有无是本净法乃名执持。其慕斯光无量普明。当以随时讲是顶王。广求法界志斯光目。不得境界乃曰执持。诸法甚深法不可得。若不可得则不有无。辩才具足志存佛道。觉亦若斯以畅经义。无卷无形如龙化生。先兴其云然后乃雨。心无从来因缘合成。斯慧无形是无思议。若欲宣布无央数法当学斯经。解一切空无所著法。思惟经典不知从来。所说甚善。斯法无生如经所传。其光玄照犹如日明。光无从来去无所至。经典如是。照诸所有令无所有。若有比丘执持辩才清净无断。当以至心学是顶王。因法光明所耀无量谛广布法。疾得逮入无碍辩才。以学顶王饶益世俗。其不学此不知法味。无玄妙典顶王无上。若不奉是远佛法教

诸比丘众若比丘尼。若不从是法典训诲不归义趣。其不求是不至正真。若有比丘比丘尼求归是法。为一切世而作法因。一切诸法悉不可喻。犹如有人住忉利天处天宫殿悉见天下。学斯经者。普超众生济度一切。若住须弥顶在于其上观察天下。斯经如是。解畅诸法睹一切无。开导众生。犹如有人执大炬火入于冥室消除窈冥。斯经如是。以法光明普照诸法。习持是典未曾遭冥。犹如日光出照天下靡不周遍。斯经如是。以道法明咸耀三界。一切众生示以道慧。犹如月殿游行虚空而不休废。斯经如是。照十方界一切蒙荷。是则法印印一切法。建立此印为诸菩萨。又计其印。犹如虚空悉无所有不可令有。虚空及印是二无望。佛与正法亦复如是。班宣是经亦无所说。犹如国王所爱敬子。欲立太子任以国财

王告大臣。以是洪业付其太子。又斯圣财天下国土。一切万民委任系后诸臣奉命。今斯经法亦复如是。善思童子。从佛启受当以授与无数菩萨使入上法。佛以建立是经法要诸菩萨故也。炽盛德本若以手执福不可量。其持是经所宣顶王。不当疑是不成正觉。欲逮辩才于一切法而无所著。当学斯经所宣顶王。所云世法是则正道。所以者何。俗人信道若入此经或复不信。用闻经恩会久成道。若受是经广为人说皆谓至贤。普世诸人莫能虚欺。解诸佛法饶益众生世护无上。若说是经诸天亿千住于虚空。而嗟叹言善哉正觉所宣。甚哉难及难及。乃说妙典是举道英慧英。所益不可思议。若四句诵为人讲说。若复精学无央数经。以是深法不可思议。广为人说。其人蒙慈。为与佛谈爱乐圣典。以为宣传斯顶王法。训诲经典无上道要。是乃名曰不可思议

佛告阿难。若有奉受如是像法纯淑经卷持讽诵读。若有比丘比丘尼清信士清信女。能从启受持讽诵读。其德无量功不可限。莫能称载得崖底者。犹如虚空不可得际。如是阿难。若受是经虽不能多。受四句颂讽诵宣布为他人说。福不可计德无崖底。无边无际不可为喻。佛尔时颂曰

  虚空尚可度　　众想可穷说
  斯功德福祐　　不可竟尽极
  奉十方世界　　诸无上护世
  若有受持是　　为供斯诸佛
  若睹诸神通　　举十方世界
  不如闻此经　　普奉是诸佛
  其于十方世　　弃捐第十业
  以斯奉事佛　　闻不如供养
  若供诸灭度　　及当来正觉
  于今十方土　　现在天人尊
  一切有为业　　归大仁师子
  若持是经卷　　正觉所宣说
  若以衣食养　　斯非精智慧
  其有持是业　　此慧供无上
  一切十方世　　满中众珍宝
  以施诸正觉　　是福不殊特
  其有学是经　　顶王所班宣
  斯供养诸佛　　是所宣第一
  我所宣经典　　不着诸佛道
  其心倚于是　　欲供养如来
  其不倚世俗　　是第一奉事
  都无举无下　　是乃曰供养
  其佛正觉法　　一切不可得
  如来所班宣　　是第一礼敬
  其定光诸佛　　所供养奉事
  见诸菩萨法　　是第一供养
  是供养第一　　如奉佛世尊
  从其授决已　　当得致正觉
  欲住于佛道　　正觉众生尊
  习是清净法　　则供养导师
  以如是供养　　得道无所至
  愍众生奉法　　皆趣一切慧
  十方诸佛法　　护世所敷演
  是皆归趣正　　是第一供养
  已得入佛界　　佛慧不可议
  便能师子吼　　亦如我今日
  因其师子吼　　在诸法勇猛
  济脱亿载众　　灭度无有漏

佛复告善思。受斯经典宣布十方。一切受持奉行正法。无极大慧开示同学。令得习行六度无极救于三界。若族姓子及族姓女。受是经典为他人说德不可量。犹如虚空不可限度。佛说如是。善思童子一切圣众。诸天龙神诸阿须伦世间人民。闻佛所说莫不欢喜。作礼而去佛说大方等顶王经


佛说大方等修多罗王经

    No. 575 [Nos. 576, 577]

佛说大方等修多罗王经

        后魏天竺三藏菩提流支译

如是我闻。一时婆伽婆。在王舍城迦兰陀竹园。与大比丘僧千二百五十人俱。及大菩萨摩诃萨众。尔时摩伽陀国频婆娑罗王。出王舍城。诣迦兰陀竹园精舍。至世尊所。头面礼足。绕佛三匝。退坐一面

尔时世尊即告频婆娑罗王言。大王。如人梦中见于众人。与诸婇女共相娱乐。此人觉已。忆念梦中众人婇女。大王。于意云何。如是梦中众人婇女。为有实不。频婆娑罗王答言。不也世尊。佛告大王。于意云何。是人梦中见婇女。与诸人等共相娱乐。觉已忆念。如是之人宁有智不。大王答言。不也世尊。何以故。世尊。梦中毕竟。无有众人及众婇女。众人婇女尚不可得。何况当有共相娱乐。佛告大王。凡夫之人亦复如是。眼见美色便生爱着。既生爱着便起欲心。既起欲心起嗔痴业。或作身业。或作口业或作意业。彼所作业作已而灭。灭已不依东方而住。亦复不依南方而住。亦复不依西方而住。亦复不依北方而住。四维上下亦复如是。至临终时行识将灭。其意现前。大王。如是行识。自作之业必尽受之。大王。如人梦觉。不见婇女及诸人众。行识灭已初识次生。或生天中。或生人中。或生地狱。或生畜生。或生饿鬼。大王。以初识不断自心相续。应受报处而生其中。大王。观诸生灭颇有一法。从于今世至未来世。大王。如是行识终时。名之为灭。初识起时。名之为生。大王。行识灭时。去无所至。初识生时。无所从来。何以故。识性离故。大王。行识行识空。灭时灭业空。初识初识空。生时生业空。观诸业果亦不失坏。大王当知。以初识心相续不断而受果报。尔时善逝。说此语已。而说颂曰

  一切唯名字　　唯住想分别
  名字分别说　　而说无所有
  以种种名字　　说于种种法
  法中无如是　　此法诸法相
  名字名字空　　名字离名字
  诸法无名字　　以名字而说
  此法非实有　　以分别而生
  彼分别亦无　　空以分别说
  一切凡夫说　　眼能见于色
  世间妄分别　　取之以为实
  佛之所说法　　众缘集故见
  此是行次第　　为说第一义
  非眼见于色　　意不觉诸法
  此是第一谛　　非世间所觉

尔时世尊说此经已。摩伽陀国频婆娑罗王。一切世间天人阿修罗揵闼婆等。闻佛所说。皆大欢喜佛说大方等修多罗王经


佛说大方广未曾有经善巧方便品

    No. 844

佛说大方广未曾有经善巧方便品

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

尔时有菩萨摩诃萨。其名大意。于众会中即从座起。严整衣服合掌恭敬。顶礼佛足前白佛言。世尊。诸修菩萨行者。于五欲境作何方便取而不着。虽复常行无所障碍

尔时佛告大意菩萨言。善哉善哉。大意。汝名最上。见最上义。能于众中问如是事。诸修菩萨行者。未来世中于诸佛所。深种善根。如是名为善巧方便。即得诸佛共所建立

是时大意菩萨复白佛言。世尊。诸修菩萨行者。未来世中云何于诸佛所。深种善根。唯愿世尊。利乐一切众生广为宣说

佛言。善男子。汝今谛听。当为汝说。若有人行少分施能起增上。广为一切众生最胜善心。所获功德回向一切众生。如是善利无有穷尽。譬如天雨降霔大海。一一水滴数不可知。相续流注无有穷尽。行布施者。善巧回向一切众生所有功德。亦复如是。资诸善法展转增胜。亦复无尽。乃至成佛众善圆满

复次大意。若复有人见有曼拏罗处。施以一香。作是施时当起是意。普愿一切众生得最上戒香。具足一切乐具皆得如意。若施一华。普愿一切众生当于天上人间。平等受大供养。若施一灯。普愿一切众生开诸盲目消除瞑暗。得大明照如日月光。若施涂香而用涂饰。普愿一切众生。当得真金色相天香涂饰。若施衣服。普愿一切众生惭愧具足离诸过失。若施抟食。普愿一切众生得天甘露定复得最上法甘露味快乐具足。若施铃铎。普愿一切众生。皆得最上清妙梵音闻者适悦。若施伞盖。普愿一切众生离风雨难。得大清凉普覆一切。若施幢幡。普愿一切众生身如朗月。清净洁白光明普照。尽诸世间人所爱乐。若施宝拂。普愿一切众生离诸尘垢身得清净。有大名称最上吉祥所应具足。若施诸庄严具。普愿一切众生当得一切佛功德宝圣庄严具。若施歌乐。普愿一切众生得胜耳根。常闻诸佛妙好音声。若施船舫骑乘。普愿一切众生得最上乘。又复随诸众生有所爱乐而悉施与。得童子相柔软妙好受天快乐。诸所施作适悦自在。若施旃檀香。普愿一切众生。得三十二大丈夫相具足庄严。乃至无见顶相常出妙香。若施座具。普愿一切众生受天富乐。一一当处最上最胜大金刚座。若施卧具。普愿一切众生当得最上欢喜适悦。若施僧坊舍宇。普愿一切众生住天悦意妙宝楼阁。四种神足悉得圆具。若施空地。普愿一切众生。当得安住胜妙十地。速至最上圆满佛地。若施眷属。普愿一切众生。当得世间天人阿修罗等。常所侍卫坚固不坏。最上最胜诸所施作而无等比。若施医药。普愿一切众生。离诸病苦如大药树。当得金刚不破坏身。一切庄严常得最上适悦快乐。若施明镜。普愿一切众生。如月光明普照一切。若施瓶器。普愿一切众生得大贤瓶。灌注法水普润一切。若施园林树木。普愿一切众生身如劫树。若施酥酪。普愿一切众生得最上乐味。若施甘美等物。普愿一切众生。得最上可爱轻安乐味

又复诸修菩萨行者。若见一切男女奴婢当起是意。普愿一切众生。悉当远离恩爱缠缚忧恼等苦。一一皆获自在快乐。若见苦境当起是意。普愿一切众生。得离诸苦解脱自在与诸佛等。若于一切众生。作父母师长阿阇梨想。恭敬尊重。于当生中天上人间若沙门婆罗门等。诸所生处诸根调伏离一切苦。若处五欲乐时当起是意。普愿一切众生。如所乐欲悉得如意。一切皆具菩萨胜行。若澡沐时当起是意。普愿一切众生。离诸尘垢清净无染与诸佛等。若入园林寺舍及诸方处当起是意。普愿一切众生。得入最上解脱法门。若出一切方处当起是意。普愿一切众生。出轮回际住安乐法。若饮食时当起是意。普愿一切众生。离诸恶趣断饮食想。若处眷属中当起是意。普愿一切众生。远离斗诤互相爱敬。为善知识慈和平等。若开户时当起是意。普愿一切众生。开解脱门咸得趣入。若闭户时。普愿一切众生。闭恶趣门不复趣进。若履道路时当起是意。普愿一切众生。如理修行顺趣正道。若乘船舫骑乘。当起是意。普愿一切众生。乘最上乘登正觉道。若有所过度时当起是意。普愿一切众生。出过地狱等苦不复趣入。若有一切。常语论时当起是意。普愿一切众生正念现前诸法圆满。若见有人。起忿怒时即生欢喜。作如是意。普愿一切众生。当息一切毒害忿怒远离魔娆。若有宣说善法语言。当起是意。普愿一切众生。得诸佛智辩才无碍。若处戏笑歌乐赞咏。当起是意。普愿一切众生。常大欢喜受诸富乐自在适悦。若睡眠时当起是意。普愿一切众生。起最上心。出离无智尘暗淤泥。诸有所作得佛建立住圆满智。若经行时当起是意。普愿一切众生。常得履诸圣道

尔时大意菩萨闻说是法生大欢喜。复白佛言。善哉世尊。善说此法。能令一切修菩萨行者。所有身语意业如善所作。常得诸佛共所摄受。所有恶趣一切众生得佛救度。世尊。于后末世修菩萨行者。如佛所说善巧方便。应如是行。是即名为修菩萨行

佛言大意。如是如是。诸修菩萨行者。若如是学即得信心坚固不复退转。种子具足出生现行。大意当知。此即名为菩萨胜相。复为最上善巧方便。汝等于此正法。当勤修习为人演说。尔时大意菩萨摩诃萨。闻佛说是法已。欢喜称赞。礼世尊足。退住一面佛说大方广未曾有经善巧方便品


佛说大迦叶本经

    No. 496

佛说大迦叶本经

        西晋三藏竺法护译

闻如是。一时佛游王舍城灵鹫山。尔时城中有势富梵志。名曰尼拘类(晋曰无恚)财富无数。金银七宝。田宅牛马。不可称计。梵志有子。名曰毕拨学志。舍六十佉梨金宝好物及千具犁牛。捐仁贤妻天下第一光颜微妙面色为最。心自念言。当趣世间阿罗汉学净修梵行。诣多子神祠药树之下。啖食其果。于是世尊。转大法轮。转法轮竟与比丘众退。至多子神祠。止其精舍

于时毕拨学志。夜欲向明。住立遥见世尊在丛树间。光明远照。威曜普达。志即念言。今此丛树。天已向明。威神普照。光明无量。殊妙巍巍。于此树间。必有鹿王。大雄师子。若有天神及大神通神足大变。必尔不疑。我当往观。时毕拨学志。即从坐起。往诣丛树。遥见世尊。光明百千。足底相文。众好具足。即时叹曰。吾等先古神仙所遗经典说。有瑞应三十二大人之相。分别具足。当趣二处。设在家者为转轮圣王。主四天下。选择要教。治以正法。刀杖兵甲。制而不施。假使出家。乘国捐王。当为如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。宁可亲觐。毕拨学志。往诣佛所。睹世尊在于树间端严而坐。犹大形象。七宝合成威德巍巍。诸根寂定。道心静然。逮最憺怕。忽然清净。度于彼岸。犹若金山。若须弥王。犹如夜分坐于幽冥然大炬火。譬龙在深渊其水清凉。相三十二庄严其身。如大山王顶有大火然。如日出山冈光曜普照。如月盛满众星独明。如转轮王眷属围绕。八十种好遍布其体。犹若干华。各各开摆亿百千光。从圣体出。毕拨学志。见佛如是。心怀欣然。如冥见光。寻趣世尊。揖让谈语。自达姓名。却坐一面。佛为说经。解若干义。分别其慧论。佛世尊有诲悦辞布施持戒。爱欲之病。挑尘劳心。出家为上。愦扰诸品。应病授药。尊见其心。应时柔心。狐疑盖心。悦信之心。罪福之心。若平等心。应心与合。而为说法。如诸佛法。察其根源。而分别说苦习尽道。即于坐上。远尘离垢。诸法眼生。现在获度。睹见法源。分别经典。拔于狐疑。得立果证。受教诲慧。致勇猛法。即从座起。更整衣服。右膝着地。稽首佛足。我初来时。观尊足心。自说名字。观佛相好。心怀踊跃。而失礼敬。尔时世尊告大迦叶。是故贤者。从今以往。若族姓子。有所至到。心念犹月。如月光照种姓光明威曜。如是族姓子。开目而行。如是迦叶。从今日始。若族姓子。制心修行。如月盛满游行空时。是故迦叶从今日始。族姓子所游至处。制心修行。犹如日光照于天下。其族姓子。未曾闭目。制心修行。犹如日光。亦当如是。佛告迦叶。从今日始。制心修行。犹如蜜蜂。所至到处。多所发起。犹如蜜蜂采诸花味不萎色香。若族姓子。制心修行。从今日始。造行如是。佛告迦叶。从今已往。制心修行。当如地水火风。得净不喜。得诸不净屎尿脓血死蛇死人污露。不以愁忧。若得华香金银七宝五种彩色。不以喜悦。无增无减族姓子。制心修行。亦当如是。嗟叹称誉。安乐欢豫。不以为悦。若遇诽谤众苦恼患不以愁忧

佛告迦叶。从今日始。族姓子。制心修行。当如拂净物。亦拂不净。亦拂屎尿涕唾脓血死狗死蛇死人污露。不以净悦。不净不忧。若族姓子。制心修行。亦当如是。佛告迦叶。从今以往。制心修行。子如扫帚。净亦扫不净亦扫。佛告迦叶。从今以往。族姓子。制心修行。当如凶祝子。常低头行。在所至到。常内其手。若裸形人。羞身不蔽。在于世间。趣欲活命。不说本姓。若可不可。不以自宣。若族姓子。制心修行。亦当如是。佛告迦叶。从今以往。族姓子。制心修行。如截角牛。如牛截角。贤善柔顺。不贪四事。诣于四衢。于四衢道。无有门户。而危其命。若族姓子。制心修行。亦当如是。佛告迦叶。从今以往。制心修行。当如铁釜。又如诸灯。如釜灯穿多有孔漏满中油脂。如明眼人从一边观釜灯诸孔脂油漏出。各各堕地。若族姓子。察身非常。四大合成。九孔穿漏。皆出不净。不贪乐身。不以为奇

于是大迦叶。从佛世尊。闻月喻行即受讽诵观八脱门。佛告迦叶。诣光曜树。迦叶应曰。唯然世尊。即从坐起。在佛后住。时佛与大迦叶。出其丛树。诣异丛树。寻复出去。坐异树下。告大迦叶。于此树下。为如来敷座。吾身疲弊。其背甚痛。迦叶受教。促疾促疾。为佛敷座。令其方正。敷座已竟。前白大圣。敷座已讫。唯愿就席。佛寻坐竟。告迦叶曰。是地柔软。细滑妙好。迦叶曰。唯然世尊。彼地此地。今者人身。曾归此地。唯然世尊。归于尽灭。持心忍辱。当如是地。今我法衣。亦犹柔好。愿佛愍伤。加哀受之

佛告迦叶。假使我受柔软绛衣。汝服何等。迦叶白佛。往古诸世尊赞誉。若族姓子。着冢间死人弊衣及五纳衣。为安诸天及世间人。佛言。善哉善哉迦叶。多所哀愍。多所安隐。着弊纳衣。往古诸佛。所称叹者。迦叶汝起促取水来。吾甚饥渴。意欲饮水。唯然世尊。即受教起。稽首足下。绕佛三匝。促疾促疾。欲行取水。诸比丘见寻时问之。仁为耆年。不以贡高。亦不忧戚。寂除凶欲入无所处。何因为沙门欲受具戒。今所至。迦叶报曰。汝等诣佛。以持此事。自问大圣。悉当为汝分别说之。于时贤者大迦叶。即取水来。往奉上佛。佛寻受之。饮水竟。便残水持与。迦叶即受。以着一面。长跪叉手。右膝着地。更整衣服。白世尊曰。我行取水。见诸弟子及诸比丘。问我曰。仁为耆年。不以贡高。不以忧戚。亦不痴妄。寂诸四事众欲之凶。我自舍六十佉犁金妙珍宝犁牛千具。弃妻玉女天下第一。其有世间能成罗汉。吾当从受。今者弟子。诸比丘众。悉来问吾。我时前在多子神祠。在药树下。啖其果蓏。于是世尊。未受具戒。尔时世尊。游于王舍城。我时在竹树间迦兰园。明旦着衣。持钵入城分卫。见日大殿有千光出。时佛世尊。在王舍城迦兰竹树间。时见世尊。吾自忆念。谓日更出。若大天神。夜忽如昼。时佛哺时从宴坐起。如月宫殿振大光明。则以覆蔽诸日月光。譬如大炬照于闇冥。佛在弟子众中。威神光明。亦复如是。为诸比丘。讲说经法。如转轮王。与诸子眷属俱。与无央数众比丘俱。吾尔时观死不睹见诸比丘众。无能受者。无能为师。唯独如来。将出世间。兴隆道化。而取灭度。今诸比丘。故来问我。尔时世尊。告迦叶曰。多有比丘。不了善恶。觉与不觉。不解福田。诸法之处多有义理。是说第一。迦叶最尊。不以贡高。平等无忧。寂诸四事诸欲之凶。第一成就。受具足戒。佛说如是。贤者迦叶。及诸比丘莫不欢喜佛说大迦叶本经


佛说大净法门经

    No. 817 [No. 818]

佛说大净法门经

        西晋月支三藏竺法护译

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。比丘五百。菩萨八千。一切大圣悉得总持辩才无量。其所建立分别圣慧解三脱门。于三世慧无所挂碍。得三昧定不可转移。十力无畏一切具足。尔时王舍大城有逸女人。名曰上金光首。端正殊妙见莫不悦。色像清净威耀如华。往古所修德本之报。形体自然紫磨金色。所可游居卧寐住立坐起经行。其地变现亦如身像设着彩帛其服自然转为金色。无央数人莫不敬重。见此女者视之无厌。言辞不粗柔和美丽。颜貌光泽无有憔悴。其于王舍大城之中。国王太子大臣长者居士诸子。兴贪爱心。志欲得见随其所游。园观河侧里巷树间。便就从之。男女大小无央数人。悉追其后欲观察之。尔时上金光首在于异日。与畏间长者子俱。市买好物而相贡上。供办美食至游观园。驾驷马车幢盖珍宝。明月之珠紫金校饰。布好座具赍持杂香思夷之华。从诸妓人至游观园而相娱乐。音声唱和鼓乐前导。供养之具载从其后。不可计人逐而观之。文殊师利者(晋名溥首童真)。于时从燕室出常发大哀愍伤群生。何所人者。可以劝化令发大乘。以三品法兴隆道慧神足变化。说法变化。教授变化。导利入律。时文殊师利。见上金光首与畏间长者子俱侣。共载乘行诣游观园。知女往昔本行根源宿世有德。吾应化之。当为说法必令解达文殊师利寻时变身化为少年。端正绝妙颜貌踰天。见者喜悦莫不欣戴。姿容威曜蔽日月光。被服像类现于人间。其所被服照四十里。自现其身如有所好。文殊师利被服严讫。观察逸女所游之路。寻在彼路而于前立。适在前立。其长者子所乘及上金光首车马被服。寻则覆蔽遏不复现。光曜灭尽犹如聚墨在明珠边。上金光首游逸之女。时见文殊师利颜貌英妙。犹如天子身体之明炜炜难及。肌色悦泽被服有异。光曜灼灼从其身出。适见此已。则自察己不以为奇。贪其被服心自念言。今欲舍此长者之子下车弃去。当与斯人共相娱乐。又愿吾身得是衣服形貌光像。适念此已。文殊师利建立威神令息意天王化作男子。谓彼女曰。且止且止。用为发是游逸之心。所以者何。如斯人者不志色欲。女曰何故。息意天王报言。是者名为文殊师利菩萨也。女又问曰。何因作字正谓菩萨。为是天子乎。为龙鬼神犍沓和迦留罗真陀罗摩休勒。释梵四天王耶。息意报曰。女欲知之非天龙神。亦非释梵。斯者名曰为菩萨矣。又能充足一切人愿。见众生心有所求索。不逆人意故谓菩萨也。女心念言。如今所闻必当施我妙好之服。即下车往白言。仁者。愿以此衣而见惠施。文殊师利答曰。大姊。若能发无上正真道意。吾身尔乃以衣相惠。女言唯然。何谓为道。答曰。欲知汝则为道。女言。云何文殊师利。设不广演分别谊者。吾不解也。何谓我身则为道者。尔时上金光首即说颂曰

  软首愿以　　衣服相施　　乃知仁者
  志弘佛道　　如天不雨　　久远之旱
  若贪惜者　　非真菩萨

尔时文殊师利。以偈颂曰

  假使女能　　发道意者　　吾乃当以
  衣相惠施　　若有坚心　　住于道意
  天上世间　　悉为作礼

上金光首。以偈重问

  所谓道者　　为何句谊　　孰为说者
  谁得道者　　志趣经业　　当何所习
  得成佛道　　开化未悟

文殊师利答曰。大姊。欲知有如来至真等正觉。名释迦文。今现在说法。演身平等等奉行道。于姊心中所念云何。岂不从己而生阴种诸入事乎。女闻此言。蒙宿德本所积善行。逮法光明寻即启言。如是如是诚如所云。因吾我身致阴种诸入耳。姊意云何。色有所念有所知乎。女答不也。文殊师利报曰。姊亦当知。道无所念无所分别。以是之故。色则平等道亦平等。吾故说此汝则为道。姊意云何。痛想行识。为有所念有所别乎。女答不也。文殊师利报曰。道亦无念亦无所分别。痛想行识则亦平等道亦平等。故说此言汝则为道。姊意云何。岂可见色处内若外及中间耶。岂青赤黄白黑紫红。为在某处某方面乎。女答不也。文殊师利报曰。道亦无见无内无外。亦无中间紫红之貌。亦无某处方面之土。色已平等道则平等。故说此言汝则为道。姊意云何。痛想行识。岂可见处内外中间。五色之貌某方面乎。女答不也。文殊师利报曰。道亦如是。不处内外中间五色。无彼无此亦无方面也。痛想行识则亦平等道亦平等。故说此言汝则为道。五阴若幻。虚伪颠倒因从斯生。道亦如幻假音声耳。幻为平等五阴平等。幻已平等道亦平等。故说此言汝则为道。五阴如梦无有本末。道亦如梦本无处所。梦以平等道亦平等。故说此言汝则为道。计于五阴犹如野马。迷惑之业从虚伪兴。道如野马自然之数。亦无有造亦无报应。是故野马五阴平等。野马已等道亦平等。故说此言汝则为道。五阴镜像像无所有。道如镜像亦无所有。以是镜像五阴平等。镜像平等道亦平等。故说此言汝则为道。五阴假名而为行耳。道亦假名而为道耳。五阴平等道亦平等。故说此言汝则是道

文殊师利谓言。更听。五阴无造道亦无造。阴无自然道无自然。阴无所有道无所生。五阴无常道晓无常。五阴无安道解苦义。五阴空无道晓了空。五阴无我。了无我义则为道矣。诸阴寂然了澹泊者。则为道也。诸阴无受。无所受义则为道矣。诸阴无住亦无所著。无住无著则为道矣。诸阴无来亦无有往。无来无往则为道矣。有五阴者计于圣法。为假音声言曰贤圣。而于道法言为友矣。其所言辞而无言辞。五阴悉无本皆清净。如来如是悉了本净得成正觉。故名曰道。是故五阴本净道亦本净。道以清净诸法本净。如今大姊诸阴本净。诸佛世尊道亦本净。一切本净亦复自然。众生五阴本净亦然。故说此言汝则为道。已了五阴则便解道为诸佛道。又诸佛者不离五阴乃成佛道。道不离阴觉了五阴。乃号为佛。是故大姊。当作此观。一切众生皆处在道。道亦处在一切众生。道无缘辞。故说此言汝则为道。彼从吾我而生四种。何谓四种。地水火风也。其地种者。无我无人无寿无命。等于地种道则平等。本无所受故谓平等。水种亦等道亦究竟本末自然。火种平等道为究竟本末无瑕。风种平等道之本末而无所见。大姊欲知如地种者。则以此种如来成道。水火风种如来种者。亦复如是。以此得道晓了地种水火风种则成为佛。故说此谊汝则为道。地水火风诸种无想。于此四大能无思想。故曰为道。以是之故说汝是道

彼因吾我便则有眼。耳鼻口身意亦复如是。其眼则空了眼自然。分别空者则为道矣。耳鼻口身意亦复如是。意则为空。解自然空则为道矣。眼以空者不知求色。色自然空则为道矣。耳鼻口身意亦复如是。意以空者则不识求。诸法无著。法自然空则为道矣。眼不受色。道亦如是。眼无有色。六情亦尔悉无所受。又计道者则无心法。如是大姊。其眼识界。彼于色界则无所住。眼识色界道无所住。耳之识界。鼻之识界。口之识界。身之识界。意之识界。不住法界道亦不住。心法识界道无所受。犹是之故。道与眼识界无有二。耳鼻口身意识界。道与意识无有二界。故说此言汝则为道

复次大姊。分别了眼则为道矣。眼本空净。若能解了自然空者则为道矣。耳鼻口身意亦复如是。本自然空。觉了分别本净自然空者则为道矣。眼自然空。则无所染亦无结恨。不见侵欺除淫怒痴。则为道矣。耳鼻口身意亦复如是。意则自然。其自然者则无所染亦无结恨。不见侵欺除淫怒痴。则为道矣。眼则无主则无吾我亦无所受。道亦无主则无吾我亦无所受。耳鼻口身意亦复如是。则无有主亦无吾我亦无所受。道亦无主则无吾我亦无所受。又计眼者。无男子法无女人法。已解了道。无男女法。无男无女则为道矣。耳鼻口身意。亦无男法亦无女法。道亦如是无男无女。如来觉了眼色无本。了无本者则为道矣。耳鼻口身意亦复如是。如来觉了意则无本。觉了如是则为道矣。故说此言汝则为道。复次大姊。其己身者则无吾我。无我无人无寿无命无形无意无作无受无见无闻无取无放无得无知。道亦无我无人无寿无命无男无女无身无造亦无所见。亦复无有色声香味细滑之识。制一切法乃为道耳。今姊身者。愚朴无智身为现在。犹如草木墙壁瓦石。其内地种及外地种。如来则以圣达之慧。了是地种逮致正觉。故说此言汝则为道。复次大姊。其心意识诸思想念。心使意者而有此法。无去无来身无所至。教无所到。亦无津流亦无筋脉。亦无骨节发毛。亦不住脑亦不住髓。亦不住内。亦不住外。亦不住中亦无内外。眼亦不住。耳鼻口身意亦复不住。亦无所住亦非不住。亦不建立亦不离立。亦无处所。亦无土地。亦无方面。无色无见无授无受。无使无教无余无著。清净鲜洁则为显耀。其心意识亦无欲着亦无净者。无有尘倚本际清净。以是之故。亦无欲着无有净者。则为显耀便无有身。以是之故。亦无欲着无有净者。如是大姊。阴种诸入自然为道。道亦自然晓了分别阴种诸入。设于己身能除阴种诸入事者。则为道矣。所以者何。道无忧戚无所危害。心了此者即便是道。觉了诸法一切平等。则为道矣。文殊师利于游观园说此语时。虚空中五百天子。皆发无上正真道意。男女大小随逐上金光首者。于彼众中有二百人。发大道意。六十天与人。远尘离垢诸法眼净。尔时上金光首。欢喜悦豫五体投地。稽首文殊师利足下。归命佛法及与圣众。净修梵行奉持五戒。其心质直乃发无上正真道意。口宣斯言。从仁之教。文殊师利愍伤一切众生之类不断佛教。其有人发大道意者。亦当如是。道所建立兴设法施开化黎庶。又说经法当为洗除恶秽罪业使得清净。一切诸法乃能寂然而悉澹泊。随顺思惟本悉无异。自依贪身为颠倒事。不了平等而习淫色。欲从身出。众生因欲便有尘劳。文殊师利犹如今者。诸法非法一切本净。迷惑致令从因缘会而有贪欲。我则能成合集诸法。立于无上正真之道。所以者何。一切尘欲从其思想因虚伪起。已能晓了知虚伪者。则能蠲除虚伪之事。又闻文殊师利说谊分别所趣尘欲之事。犹如云雾自然无实。欲如[火*僉]电。即寻消化。欲者如风。察于本末而无所倚。欲如虚空度一切界。欲如水泡不得久立。欲如鬼变于其中间不正之念。欲如热病恍惚妄语。欲而无实从缘想兴。欲如系缚计吾我故。欲无有形计着身故。欲如客来不从本起。欲炫因想随众念故。欲如晓观从若干种而发生故。欲无所生从贪羡起。欲无所知从彼我生。欲之所生为因诸阴。欲界如鍜因意境兴。欲如诸阴用诸入故。欲如若影假名色耳。欲不觉了违正念故。又复文殊师利。计于欲者。若能觉了疲懈之句。则能知道。所以者何。道无动转众生尘劳。欲如破坏分别道故。欲者为心心觉了故。欲如琴瑟晓了之故。所以者何。有道之谊不坏欲尘以能不坏便顺道也。若睹欲者则为道矣所以者何。欲入诸界靡所不至。假使佛乘无所有者。而无有形。尘劳之欲亦复如是无有形像。欲于诸有而无所有。住无所住。这发起已寻则便灭。心则自然尘劳亦然。所以者何。心不可察。谁言能令心结染痴。假使彼心不可睹者。尘欲如是亦不可见。无积聚处无有方面也。菩萨大士。若能晓了尘劳之法。为贪欲人开化说法不以为厌。若教愚恚及等分人。诱导说法不以懈惓。设使文殊师利。如我身欲诸贪欲者亦复如是。如我嗔恚及与愚痴。一切嗔恚愚痴之事亦复如是。如我尘劳。众生尘劳亦复如是。譬如大火悉烧草木贤圣慧火烧除尘劳。譬如日光照明众冥不与冥合。圣慧如是蠲除尘劳不与俱合。譬如风行不着一切山与树木。行智菩萨亦复如是。不着一切尘劳之欲。譬如劫尽烧诸有形不烧虚空。行慧菩萨亦复如是。烧诸爱欲不与一切尘劳俱合。譬如净水不与秽合。菩萨如是不与尘俱。譬如虚空受持于地。智慧如是不与欲杂。譬如大风坏铁围山。菩萨如是。以智慧事吹散诸欲。譬如有象名究焰气。乳与水合则为一类。菩萨如是。以圣智慧游除尘劳。化令明哲合为一慧。譬如须弥北方天下与诸亲里不为放逸在于树下而自分别。菩萨如是。智慧之明见众人根而为分别。文殊师利。吾身如今不畏欲尘亦无所难。所以者何。我晓欲尘本悉净故。又被菩萨大德之铠。勇猛精进无所[怡-台+惡]难。譬如怯人求于救者。如此之类不为勇猛。开士大士亦复如是。离于欲者不为菩萨。譬如有人为贼所坏不为猛将。开士如是。坏爱欲者不为菩萨。譬如人以清水明珠着浊河中寻时即清。不为垢浊之所染污。菩萨如是。在于爱欲尘劳之中。不为瑕秽之所染污。尔时上金光首叹说此已。复问文殊师利。何谓菩萨无有尘劳。答曰。假使菩萨见于起意若见灭意。不当谓之为菩萨也。譬如有限睹总持者。不当谓之获于无量。如是菩萨若睹尘劳意有起灭。非是菩萨无尘之谓。无尘欲者。不见有尘。不见结恨。无见不见。远离想念。乃谓无尘。设使行者其心意识而得自在。一切所有无泥洹想。所以者何。心无欲尘想念之缘。便得自恣也。于诸善恶亦复如是。所行无行。有为无为。有形无形。一切知之。生死尘劳有余之垢。目察于色。耳听音声。鼻香。舌味。身更。心法。若得定意志在澹泊。于爱欲尘则无垢秽。尔乃名曰无有放逸。号曰无业。而无所习斯之谓也。无尘劳者。离于有为及无为哉。乃无瘕疵。复次大姊。假使菩萨身无尘劳。则能度脱他人欲垢。如来说此为无尘劳。救济他人尘劳之欲。遵修菩萨乃为精进。女又问言。何谓菩萨现在目前精进者乎。文殊师利答曰。观于空无而不退转。众生邪见则兴大哀。观于无相而不退转。众生有相则以愍济。观于无愿而不退转。众生贪愿则以愍济。观无所行而不退转。众生着行则以愍济。观无所生而不退转。众生生死则以愍济。观无所起而不退转。众生起灭则以愍济。观声闻乘获声闻果使不退转。观缘觉乘获缘觉果使不退转。观菩萨乘则以愍哀一切群生。是为菩萨习平等行精进之事。譬如丈夫行入巨海。超进极远乃致众宝。如是大姊。正谛观察空无相愿及无所行。不生不起。声闻之乘。缘觉之乘。令难进者至不退转。乃离因缘。又如有人入大战中。使难进者将护忿诤。令无所害致为难也。如是大姊。其谛观察三脱门者。不失善权其难亦尔

女复问言。何谓菩萨为权方便。文殊师利答曰。权方便者。知其时节不舍恐畏生死分部泥洹伴党。权方便者。示恐惧门。谓生死门。泥洹之门。空无之门。所见之门。无相之门。无愿之门。彼所想门。无所行门。精进本德遵行之门。无所出门。现世之门。无所立门。阴种诸入无所起门。无所灭门典所行门。澹泊之门。开化众生导示之门。法界之门。护正法门。声闻之门。缘觉之门。说佛道门。度佛道门。若使菩萨见恐惧门者。于一切门而无所著。是则名曰善权方便。取要言之贪欲门哉离诸爱故。嗔怒门哉离于结恨。愚痴门哉离于不明。尘劳门哉离于秽浊。诸趣门哉无往来故。是为菩萨善权方便。至于一切愚夫行门。所学无学缘觉菩萨如来之门。其能晓了此诸门者。是则名为善权方便

尔时世尊在灵鹫山。游泉水边而以经行。贤者阿难侍从俱焉。于是世尊。则以遥赞。善哉善哉文殊师利。是为菩萨奉习平等现在目前善权方便精进之行。如仁所云等无差特也。于时以此善哉之音。即得普告三千世界。其声悉周六反震动。则无央数天龙鬼神犍沓和阿须伦迦留罗真陀罗摩休勒。人与非人。释梵四王闻善哉音皆受告敕。往诣佛所稽首足下退住一面。各白佛言。向者大圣为何所赞。乃告三千悉见蒙敕。大千世界六反震动。世尊答曰。天子欲知。叹文殊师利有所劝化也。又问。今者所游。佛言。于王舍城东门之下在中街路。为上金光首。广说经法谈论所趣。天子汝等往求法谊。时天龙神犍沓和阿须伦迦留罗真陀罗摩休勒人与非人。释梵四王。一切佥然共诣文殊师利谈所。自现半身而雨天花。悉皆周遍王舍大城。于彼世时诸天见人人见诸天。各自安隐无诤讼者。又王舍城无数千人。各取诸天所散之花。赍诣文殊师利。时阿阇世王与四部兵后宫婇女大臣百官。从诸小王俱共往诣文殊师利。又诸尊者及长者子太子群臣。见上金光首威仪耀赫诸根澹怕。破坏尘劳离于颠倒。殊妙之德而自庄严。见已如是不复兴发贪欲之想

尔时文殊师利。告上金光首。今者众人普来集会。以何等故无复染着。前所欲尘今为安在。女白文殊师利。一切众生尘劳之欲。则建立志慧脱本际。住于法界无本之处。无本如此而无差特。无生无灭亦无所处。又彼尘欲则为本净。分别平等。又问女曰。何谓尘欲而为本净。答曰。无想不想。无应不应。以此尘欲则为本净。尘从顺行而无所起。则为本净。当知尘欲因客。游来。晓了空慧与道同居。无相之慧。无愿之慧。本净之明。而俱同居。察此一切悉无所有。譬如蛇虺含毒害人。若有人来而赍良药能消恚毒。蛇这见药毒即灭除。男女大小知毒歇尽。悉共戏弄着械膝上。无所伤害亦不螫人。如是人者。本未曾闻法律之时。念于不顺所见颠倒。处于尘欲为之所烧。己身贪欲自着颜色。已能观了色如聚沫。则知身法犹如幻化。分别戏乐若如于梦。已解爱欲若如水泡。命如朝露万物无常。晓了诸阴皆同恼患。知身不净悉为空无。观一切法皆无吾我。正谛思惟本末悉虚。不毁他人不自称誉。亦不自缚不缚他余。今我从仁闻所说法。寻即信乐便得解脱。是故眼视无所染着。所以者何。省仁之说应其所作而处尘劳。如是计尘亦无欲垢谁能见者

尔时上金光首白。文殊师利。一切大会诸天人民将无恐惧。唯为分别如应说法。令诸天人晓了尘欲。本悉清净愍哀一切。使发无上正真道意。文殊师利答曰。欲尘本净信乐者希。所以者何用不觉故。觉尘清净则成道矣。譬如无生之火不能烧人。如是当知无想之念不行吾我也。如所兴火还自烧己。如是当知思想之念。尘劳贪欲造生死身。如木生火其焰遂盛。如是当知邪见颠倒兴起尘劳三界然炽。如火灭后无复焰光。如是当知倒见已止尘则不起。即于三界不兴劳垢。如百千岁火灭不然。人不疑恐畏于冷灰。如是当知虽若干劫习欲尘秽。已解观之无所积聚。如火灭尽不可施用。慧明澹怕尘劳不兴。如身中火温热虽盛则无所烧。如是计之。其心本净显耀之明。客尘欲起终不染污心之源际也。于是文殊师利复问其女。又当云何观于色身。答曰。犹如水中之月影也。又问。云何观五阴体。答曰。犹如无化如来之化也。又问。诸种当云何观。答曰。犹如水火二界也。又问。云何观诸入事乎。答曰。犹如无施因缘罪福所行也。又问。云何观此诸会。答曰。而悉照曜会者心性。又问。云何还观尔身。答曰。犹如吾之父母。平等定者而无有二也。又问。云何以观吾身。答曰。犹如生盲不见诸色。又问。云何曾听此法乎。答曰。已闻是法如幻师化化人所听也。又问。云何汝岂为发无上正真道乎。答曰。吾则是道无所志求。又问。云何为奉行于施度无极乎。答曰。修一切度舍诸尘劳也。又问。为具足戒度无极乎。答曰。所具足者周满如空也。又问。为奉行于忍辱乎。答曰。所可遵修一切诸法无起无生。又问。为殷勤精进行乎。答曰。修行诸法无所至凑也。又问。以为建立寂度无极乎。答曰。建于法界住无所住也。又问。为已具足智度无极乎。答曰。志无憍慢心不自大也。又问。为行慈乎。答曰。以为晓了一切众生悉无所有。又问。当于何求大哀菩萨乎。答曰。当于众生尘劳中求。所以者何。大哀菩萨欲得制御众生尘劳。则发无上正真道意也。又问。行喜菩萨当复何求。答曰。己心真实志性清净。化诸忧戚是菩萨喜也。又问。菩萨行护云何具足乎。答曰。众生所诤变斗之事。具足化之使至安和。又问。何谓为诤。答曰。蠲除无实虚伪尘劳。志建佛道者也。又问。与谁共诤。答曰。与外众邪异学心不同者也。又问。众邪异学为何所是。答曰。见他所兴不能忍辱而自随者也。又问。菩萨忍辱何所志趣。答曰。开化一切众生之故也。所以者何。若不开导。何谓忍辱化众生者。无嗔结恨亦不忧戚。则为忍辱。又问。何谓危害。答曰。积累德本为忧恼事。是为危害。又问。何谓无害乎。答曰。诸界不忧则为守仁。此谓无害也。又问。何谓菩萨选择战斗。答曰。选择诸法无所获故。又问。云何菩萨降伏众魔。答曰。无所著故不灭尘劳。所以者何。菩萨降伏五阴不与尘俱。以此胜魔菩萨降尘不污本净。究竟本末晓了诸法。开化众生除老死患。告诸天子。文殊师利菩萨者。则为已离一切之智诸通慧想也。又问。女言。云何菩萨开化众生。答曰。专秉善权修行智慧。又问。云何菩萨建立群生。答曰。建立己心之慧圣达菩萨。乃能开化一切群生。又问。今女说法此之众会悉善听受也。答曰。此不为善听受者也。所以者何。有彼我想而反劝耳。立于识故也。又问。云何闻法为善听者。答曰。设能信己如梦。其说经法如幻师化了听假音。不着其声不造解脱。有二事者。是乃名为善听受法也。又问。云何听承法理。答曰。文殊师利归命法者也

尔时上金光首。承文殊师利童真建立威神。亦已本德所修智慧。于众会中如应说法。万二千人。皆发无上正真道意。五百天子。宿殖德本志菩萨乘者。得不起法忍。三万二千天与人。远尘离垢诸法得法眼净。女说法已心怀欣豫。则自逮得柔顺法忍。即便投身文殊师利足下自归。唯愿至圣。听我之身得为沙门。加哀济脱不顺之念。众人所行皆非贤观也。时文殊师利言。菩萨不以除己发者为是出家也。所以者何其能断灭众生欲尘。使修精进。乃是菩萨之出家矣。菩萨不以自被袈裟为是出家也袈裟名者晋曰去秽当去众生淫怒痴垢令无瑕玼。常行精进乃是菩萨之出家矣。菩萨不以自奉禁戒为是出家。谓化众生令守谨慎。乃是菩萨之出家矣。菩萨不以自处闲居为是出家也。假使五趣随诸群类。悉能建之立慧闲居。乃是菩萨之出家矣。菩萨不以颜貌形容威仪礼节为是出家也。化诸黎庶劝立慈哀。乃是菩萨之出家矣。菩萨不以兴己功德为是出家也。劝显滋茂一切众生殖德本者。乃是菩萨之出家矣。菩萨不以济己志于灭度为是出家也。解脱一切众生心性令致灭度。乃是菩萨之出家矣。菩萨不以除己尘劳为是出家也。灭去一切众生尘劳。乃是菩萨之出家矣。菩萨不以偏护己身独守其心为是出家也。将护一切群萌心志。乃是菩萨之出家矣。菩萨不以自脱己者为是出家也。度脱一切群萌往反。乃是菩萨之出家矣。菩萨不以济己生死之患为是出家也。度脱一切生死之患。乃是菩萨之出家矣。菩萨不以志乐泥洹为是出家也。具足一切诸佛之法。乃是菩萨之出家矣。加以大哀愍济众生。不见他短不说其阙赞叙彼人笃信之德。开示信行以施一切。此之谓也。其出家者依倚他人为菩萨者。无所依倚。女问文殊师利。何谓出家依倚他人。则答女曰。其出家者。依倚禁戒不以缘戒为出家也。女欲知之。志于禅定意不放逸。出家依慧不随恶友。遵修脱门是为出家。心未解脱不为出家。又问。何谓菩萨不依他人。答曰。不信异人则为无倚。亦不消息察他颜色。有何智慧从其受明。彼等之人有何异德。当从获致诸通大慧。亦于己身无所悕求。此即名曰不倚他人。文殊师利说此出家品时。五百菩萨各脱身衣珍宝璎珞。悉共奉上文殊师利。皆说此言。闻尊所论出家善教。吾等亦当从此正义。寻如是行具足出家

于是文殊师利。谓上金光首。若当还复上驷马车。与畏间长者子俱为开化说此。则是汝出家之行也。时大众人各心念言。岂离欲者与有欲人而俱处乎。女寻则知众人心念。便答大众为分别说。离欲菩萨与有欲人众生之类而俱出生。欲以开化令清白故。诸人欲知。菩萨离于嗔恚愚痴。便与嗔恚愚痴群黎而俱游生。欲以开化施慈与明。设使菩萨已离尘劳。便与贪欲群萌俱生。开化一切游逸之类。喻如人者母子共处无所染污。菩萨如是。常与一切众生俱会无所染污。譬鼓琴人及神咒师。虽习所欲则无有欲。菩萨如是。处于三界想念之中。如神咒术无所染着。于时上金光首。逮得时节获致法谊。至于光明离诸窈冥。睹见尘劳开示真谛。则前稽首文殊师利足下。绕之三匝还复上车。则说颂曰

  本性为清净　　贪欲不能污
  则无有嗔恚　　常遵修慈心
  亦不有愚冥　　起智慧光明
  至德以如是　　然后乃上车
  前随畏间子　　而习为放逸
  吾本贪欲意　　今者为所凑
  诸恐畏难者　　财利之贪欲
  上车以离此　　故举声歌颂
  譬如纯厚阴　　降雨润于地
  则蔽日宫殿　　使人眼不见
  其耀不为冥　　亦无夺明者
  客云之所为　　令光不显现
  愚者心本净　　客尘亦如是
  由想不觉了　　覆蔽智慧光
  计彼明达者　　不为有处所
  已蠲除尘劳　　则号为智慧
  智慧不憍慢　　心净无损减
  推之无从来　　去亦无所到
  从念不顺正　　则有尘劳欲
  已应如法念　　便趣无所至
  名无有处所　　而无有受者
  则亦无所生　　亦无有灭者
  不施无所断　　亦不依他人
  快哉此正法　　微妙甚清净
  譬如油然灯　　照入诸窈冥
  计彼闇昧者　　不知所归趣
  智慧亦如是　　灭除众愚冥
  不睹尘劳处　　顺念成所来
  犹如有良医　　疗治于众病
  不令身增减　　亦无所忘失
  病则是游客　　其疾已灭除
  亦无有异习　　不知疹去处
  溥首亦如是　　上软之音声
  睹众生厄疾　　若干以疗治
  除垢令清净　　趣之智慧门
  有所造变者　　非法不为论
  今此五阴者　　及与诸种大
  衰入已显现　　本无有差特
  是辈这前时　　有毒嗔恚俱
  今则无伤害　　亦无若干变

于是上金光首。在于车上与长者子畏间俱。如是比像诣于清净游观之园。文殊师利而说经典。一切众会欢喜踊跃。其心开解亘然明达。咸悉言曰。当共俱往奉诣如来听所说法。舍游观处至佛精舍

尔时上金光首与长者子畏间俱。在游观园散花烧香。庄严宝盖办饮食馔。作倡妓乐而相娱乐。杂和捣香以自芬薰。于时彼女。观长者子及来会人意以满足。神通之力自化其身。应时终亡颜色变恶。犹如死人。眼耳鼻口脓血流出。身体[病-丙+逢]烂不可复视。口中臭气浡浡腥秽。一切毛孔恶露皆出。其腹溃坏肠胃肝肺脾肾五脏。屎尿髓脑悉为流溢。青蝇飞集周匝共食。时长者子。见此女身变状如是怖懅不安。欲求自归济脱是患。今遭难难无极之恐。当从何所免大忧烦。各怀二难。凡夫之士见众瑕秽。己之罪咎将无帝王。阿阇世知危害我命。一切眷属及诸会人。悉共惊怖志怀战栗。各各谊言当于何求。天龙鬼神。若犍沓和。沙门梵志救脱大厄。其长者子德本不纯。已闻文殊师利说经。当所施行而不晓了。于时文殊师利童真威神所立。令园树木自然声出。赞说颂曰

  如今年少见　　诸法自然数
  三界虚无实　　如幻师现化
  愚戆所迷惑　　朽肉之涂覆
  思想彼虚伪　　愚者生染污
  譬之如画瓶　　中满盛不净
  而人不分别　　戴着头上行
  已知中所有　　破坏则悉现
  不净自流出　　无奇乃迸走
  无智亦如是　　志染着女色
  睹见像颜貌　　思想以自污
  年少今当观　　开化自然身
  明者岂着此　　瑕秽之臭恶
  年少莫恐惧　　无得畏虚伪
  仁者前所集　　诸法自然尔
  世尊之兴出　　施恐使无畏
  号谓释师子　　讲说上妙法
  爱欲非常久　　犹如电忽现
  虽睹无有实　　慧者无所著
  譬如流河水　　欲取上聚沫
  彼无有作者　　亦不成报应
  名色亦如是　　而无有造作
  因有罪福缘　　便生报应果
  少童今自见　　颜貌为所凑
  不净何从来　　令人怀恐惧
  此法无处所　　去亦无方面
  无往亦无来　　自然而化现
  彼无有作者　　亦复无受者
  造法无所受　　如幻无有形
  放逸于他身　　年幼因生畏
  当自观己体　　亦是其比类
  犹如梦中戏　　欢喜而踊跃
  一切诸所乐　　如梦已便觉
  年少便可往　　诣于释师子
  世尊大圣人　　挽拔恐惧根
  计于父母者　　亲属及知友
  不能为仁者　　蠲除此患难
  唯有诸世尊　　能加施无畏
  当至归命佛　　及法与圣众
  诸天犍沓和　　人民悉稽首
  则离一切难　　便获大利安

尔时长者子闻斯颂已。欢喜踊跃善意生矣。则以衣裓盛女死尸。弃丛树间而舍之去

于是世尊。欲以开化彼长者子。从身放光。其明普照摩竭国界。尔时年少遥见如来与比丘众围绕说法。如日出时。道路自然现若干变微妙巍巍。宝为栏楯而散众花。其天帝释则在前立。宣叹之曰。年少善利为获福庆。乃能发心而怀欢豫。欲见如来具足佛身。如是比类归诚谛路。欲睹如来之光颜乎。故发行也。时彼年少闻此劝赞。即与天帝俱诣佛所。帝释复以大意之花用与年少言。取此花散如来上。则便取花供散世尊。稽首佛足右绕三匝。前住白言。今自归佛及法圣众。以是德本劝助无上正真之道。唯然大圣。有放逸女上金光首。国王所识郡县州城尊者见知。实与戏乐诣游观园。则于今日。颜貌变恶即时寿终。舍诸一切宗室眷属。发大恐惧。将无国王推理问之。佛言。且止。尔以贪欲而怀恐惧。吾当施汝至无畏难。归命佛者不当复惧。所由致恐当断其根。又问。恐惧何因致之。世尊答曰。因淫怒痴而致恐惧。用是我身憍高自大。而睹颠倒与恩爱会。计于吾我倚于所有。眩爱悭贪招致斗诤。自见其身为缚着故。无常常想。苦为乐想。无身身想。空见实想。受于五阴以为业故。观四种大。求诸衰入悉处所故。不察身瑕乐寿命故。以是致恐。当蠲此意也。汝见彼女身坏烂乎。对曰。已见。佛言。年少。一切诸法皆当别离。为勤苦患无有常者。愚痴贪之亦不久固。如是成就便复散坏。罪福报应多危少安。色如幻化亦复如梦。如野马现渴者为惑。色犹如影行照忽过。譬之镜像。因缘所合罪福报应。便复灭没。若水中月。因成寻败。如响无言。缘对致之。行若阴影须臾便消。犹如卷手屈即舒散。悉以本净自恣而兴。譬若如风不可护持。虚伪无实亦无所著愰惚为虚。因意造名而共相成。一切诸法如是无主。则当于彼莫乐贪着也。于年少意所趣云何。贪欲之习思想所凑。白世尊曰。愚人凡夫。思想端正净妙恣颜。便起贪欲。于贤圣律法教经谊。观之瑕秽无所贪羡。若不思惟正谛真实。则习贪欲追逐放逸。佛言。善哉。如年少言。贪欲之习志性若此。当弃邪想心思如顺。遵修其业莫复为也。已离我见。观彼平等。又问。世尊。何谓菩萨心思诸法常如应顺。佛言。年少。若能思惟分别贪欲嗔怒愚痴及诸尘劳。本悉清净。是则菩萨求佛道也。譬如年少有形之物为淫怒痴。菩萨如是。晓了一切分别诸法自在所游。其三毒者。则无有本亦无所住。如无主屋其屋内外澹泊虚空。以离吾我我人寿命。便应无相。所著念者便蠲除矣。以去所著即为无愿。志所喜乐恩爱悉除。无有诸行亦无所造。淫怒痴性本皆清净。菩萨如是。能悉晓了一切诸法而得自在。假使菩萨习如应顺遵修法者。诸所发意则为道矣。所以者何。设了己心则了如心。觉了分别解一切法。则无有色亦无有影。则无教令自然如幻。其于内外而相依倚。亦为道矣。为菩萨者无有异道。当所施行自晓了心。所以者何。若能晓了觉己心者。则能解知一切众生心之所存。己心寂寞。众生之心则为澹泊。己心本净。众生之心亦复清净。己心鲜洁。众生之心亦复鲜洁。己心离欲。众生之心则亦离欲。己心无怒。众生之心则无恚恨。己心无痴。众生之心则明无痴。己心无尘。众生之心则无劳秽。若有晓了如此事者。是为觉知诸通之慧一切智矣。如是应顺遵修行者。为菩萨也。近于本净。则知一切众生心念。假使复为有所好乐。客想尘劳依心为垢。则不当厌修行法观。设使有人晓了是者。客尘劳想则无尘劳。佛说是已。应时长者子畏间逮得柔顺法忍。上金光首见长者子以蒙开化顺从律教。则与五百玉女眷属。鼓天琴瑟而作伎乐。往诣佛所稽首足下。右绕三匝退住佛前。尔时文殊师利谓畏间长者子。为识此姊不。答曰。已知之矣。又问。云何知乎。于是畏间长者子报文殊师利。而说颂曰

  色者如聚沫　　痛痒泡起顷
  了想如野马　　吾晓知如是
  行虚犹芭蕉　　识者譬如幻
  名号假客来　　吾晓知如是
  身騃无可贪　　等如草墙壁
  其心不可见　　吾晓知如是
  彼无吾我人　　无寿无有命
  诸种合为身　　吾晓知如是
  无有此淫怒　　愚痴则无处
  清净无尘劳　　吾晓知如是
  愚者作迷惑　　逆念为颠倒
  明达无所染　　吾晓知如是
  犹如丛树间　　女身之臭秽
  彼色为自然　　吾晓知如是
  本无当来生　　终没与现在
  兴起无所有　　吾晓知如是
  软首当听之　　诚谛解脱者
  则免济瑕秽　　乃为颇进退
  不始亦不终　　而现于生死
  开化立众生　　谁不发道意
  如吾贪淫恚　　不正诸尘劳
  一切法无本　　善哉经之要

于是世尊应时而笑。口中则出五色之光。照于无量诸佛国土。还绕三匝从顶上入。贤者阿难即从座起。更整衣服。右膝着地叉手白佛。何因缘笑。诸如来至真等正觉。未曾虚笑必当有意。佛言。阿难。汝为岂见上金光首乎。对曰。已见天中天。佛告阿难。文殊师利乃往古世。劝化此女使发道意。今于其所而还闻法。寻则获致柔顺法忍。汝复见此长者子不。对曰。唯然。佛告阿难。吾本前世而劝化之使发道意。今复从佛而还闻法。寻即便致柔顺法忍。佛告阿难。上金光首。过九十二百千劫已。当得作佛号宝光明如来至真等正觉明行成为善逝世间解无上士道法御天人师。世界曰宝盖。劫名宝成。尔时国中饮食衣服所居屋宅。犹如第二忉利天上。其佛国土无复异宝而出生者。则以菩萨为珍宝矣。又彼如来寿命无量。得佛道已。其时畏间长者之子。当为菩萨名德光曜。奉持世尊所演法教。其宝光明如来未灭度时。授德光耀菩萨之决。乃般泥洹。是德光曜菩萨开士。吾去之后。当得作佛号曰持焰如来至真等正觉。其佛国土等无差特。寻适授此族姓子决。应时三千大千世界六反震动。其大光明普照世间。于是具足授诸决时。则八千人因发无上正真道意。贤者阿难前白佛言。唯然大圣。斯经典者名为何等云何奉持。世尊告曰。名为大净法门品文殊师利劝助戏变。又名上金光首本之化。应当奉持之宣示一切。佛说如是。贤者阿难。年少男子及与女人。文殊师利童真诸天龙神阿须伦。闻经莫不欢喜佛说大净法门经


佛说大自在天子因地经

    No. 594

佛说大自在天子因地经

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。尔时尊者大目干连于其食时着衣持钵。以精进力运大神通放无数光。其光金色遍照虚空。复以神力变化其身。或大或小或一或多。如火光炎。往昆仑山山峰如雪。其山顶内以金银琉璃真珠码瑙珊瑚摩尼种种诸宝庄严其地。有诸宫殿。一切珍宝殊妙庄严。于其中间有大自在宫。广二由旬高五由旬。光明照曜。有六十大神恒常守护。百千天女围绕四边作七种妓乐。于宫四方而有七殿广一俱卢舍。各以七宝而用严饰。复于四边各有浴池甘露之水清净弥满。于其池中生白莲华俱母奈花如天白月。金银摩尼庄严其上。彼大自在天子与乌摩天后于师子座上同座而坐。彼诸天众恒来围绕恭敬供养。其天忽闻琴乐之声音韵微妙。闻已爱著令心迷乱。尔时尊者大目干连虽闻其乐以无畏善根调伏其心无所爱着。如妙高山出于大海安住不动。行精进妙行。受一切世间众所供养。身相端严威仪具足手持钵器。乌摩天后忽然见已心生疑惑。告天子言。此是何人。身被法服端严寂静。调伏诸根威仪具足。圆光照曜如日初出。安然不动如妙高山。天闻言已观察尊者而复告言。天后。汝知识耶。天后答言。我昔未见今亦不知。大自在天白言。此是大福德离欲佛弟子。能破诸过教化众生与作安乐。因为乞食而来至此。乌摩天后闻是语已而白天曰。彼师云何。具何色相。有何道德威力及未曾有法。我愿乐闻。自在天曰。彼人之师于三无数劫。求大菩提广修福力。于其世间难作能作。行檀波罗蜜。施于饮食衣服卧具医药金银珍宝奴婢车乘城邑聚落及大宝藏国王之位。亦曾施诸婆罗门妻子男女。于彼心中无其毫尘之许贪惜烦恼。亦无贪爱之名。又为悲愍众生故。舍头目髓脑鼻舌身肉而无毫尘之许痛苦之想。亦无虚假之名。行真实施。为求菩提大威力果。具足檀波罗蜜。又于三无数劫为对种种境界相故。行戒波罗蜜。坚守禁戒。以持戒威德常得天人供养。复为冤亲不等违顺情差。行忍辱波罗蜜。以八正道调伏其心。欢喜忍辱令心平等。复为上中下三品众生。愍念饶益利乐彼故。行精进波罗蜜。于昼夜中策勤修进。复恐心意散乱妄缘退故。行禅波罗蜜。令心决定寂静轻安。复为出生智慧读诵分别微妙经典。行般若波罗蜜。如是三无数劫。行六波罗蜜求一切智智。今得佛位圆满。降伏一切魔王。证寂灭理色心微妙。具三十二相八十种好金色庄严圆光如日。三界无等。出轮回难安乐解脱。时大自在天说是语已。乌摩天后闻复欢喜。布施等行所得大果今闻可解。复问。于汝天自前。因修何行业。愿赐欢喜为我略说。时大自在天而复白言。汝今谛听而为汝说。天后。我于过去无数俱胝劫。于大牟尼佛所。布施供养修福持戒薰习智慧。过是已来获自在报。于八生身中得八种自在。我曾生生布施持戒苦行。求主宰自在。欲乐解脱。乃至究竟寂灭安乐亦然。是故布施智慧观察。一心守护修行不断。说是语已。大自在天于其宫内。以其金钵满盛百味殊妙香饭。诣目连前志心奉上。目连尊者即受钵饭腾空欲回。大自在天具宿命智。告目连曰。尊者大目干连。汝今暂住谛听我言。极久远时佛乃方出。我念过去生中。于此大地为其主宰。能生灭世间为三界师。无人等我。汝听此言。一心往彼香醉山中。时大目干连。运神通力腾空而往香醉山中。彼山一面有圣迹池名曰天水。于此池中即便洗浴既洗浴已。坐香醉山上开其金钵。其饭殊妙色香具足变成天食。目连食已忽有天女奉上净水目连受已。于身五分而皆结净。坐彼山上系意专心入定。作观思惟。自在天言。极久远时佛乃方出。经于千生不能得知。百千生中亦不能知。经俱胝百千生中亦不能知从禅定起往摩呬印捺啰山。入定思惟亦不能知。复入摩呬印捺啰山王窟。入定思惟亦不能知。从此遍历七十诸山禅观思惟亦莫能知。又往三十二洲。寂坐思惟亦不能知。目连曰。彼大自在天。智慧所生言意诸小。声闻辟支佛亦非能知而乃一心。告长老舍利弗。尊者谛听。我于昆仑山顶见大自在天。而白我言。极久远时佛乃出世。我于此意终不能知。汝今尊者具大智慧深鉴精微。其天降雨经三年三月知其点数。四大海水知其滴数。四大洲人知其心行。如是大智。佛子于此言意应可了知。唯愿慈悲略为显示。时长老舍利弗闻是语已。即入禅定经百千俱胝生。思惟此事而不能知

尔时长老大迦叶白舍利弗曰。大自在天所言之法。其意甚深微妙难测。若汝得其佛力方乃了知。若以自力思惟如持寸草量须弥山。时大迦叶而自思惟。若电影之间刹那之顷。观过去久远之事如在掌中。唯佛大智乃能知之。于是大迦叶发无垢清净之声。告大目连曰。若大自在天自行仪。则人间天上无人了知。唯三界无等一切智智即可证知。何以故。谓佛世尊于百千俱胝恒河沙数世界所有过去现在一切众生上中下品根宜心行。皆悉了知如观掌内。如是名为一切智智。是时长老大目干连舍利弗大迦叶同诣佛所。旋绕世尊五体投地。一心敬礼退坐一面

尔时世尊知彼心念顾示微笑。时大目干连赞佛功德。佛面端严如金莲开。慈颜适悦福相深厚。牙齿齐密身体殊妙。放大光明青黄赤白。普照世间山川幽谷无不朗然。设使百千俱胝日月团聚光明亦不能及。宣清凉法味三界普沾。一切众生无不蒙益。如是赞已恭敬作礼白言。世尊。我于一时。持其钵器往大自在宫。于彼乞食。时大自在天见我持钵如法施食。而告我言。极久远时佛乃方出。我于此言终不通达。佛具一切智。世间所有那臾多俱胝恒河沙世界众生心行差别。皆悉了知如视掌内。其舌广长上覆面轮。唯愿牟尼为决疑意。尔时世尊以微妙梵音告大目干连。汝今谛听善思念之。吾当为汝分别解说。彼于过去八万四千劫前。彼时有佛正等正觉出现世间名功德海。有一大城亦名功德海。彼有婆罗门名曰寂静。有其二子一名商迦。二名鲁支。渐次成长聪明多智。俱厌生死作礼父母而白父言。我欲入山于彼修道。父母不从汝不得去。复白父言。须去修道。如是三白。即离父母入于山谷。于其山间草庵而住。去庵十一步外有老婆罗门。修仙人之法复有一人亦相邻近而自修行。忽因节日四人聚会。而复相问。各自爱乐所求之事。鲁支问老婆罗门曰。汝修何行求何果报。老婆罗门曰。我所修者求梵天身天上千岁。问邻近修行者。汝修何行求何果报。彼自答云。我求三界之主天上千岁。商迦大仙而自告言。我求天上千岁世间爱敬。鲁支仙人具大智慧而白彼言。汝等三人所求成就得世间果报。我今所求为彼世间有色无色。二足四足多足无足上中下等轮回众生皆令解脱。如是后时。佛从天上与无数百千俱胝那臾多释梵人天凡圣之众随从围绕。其佛安处金莲之座。身着红衣面如满月。放吉祥光青黄赤白。降临大地照诸有情令心清净。彼前四人修行之者来诣佛所。时老婆罗门以白吉祥草花。供养于佛作礼旋绕而发愿言。以我此善为梵世主。五面端严与无数众生施愿圆满。次一仙人以一铁片用供养佛。复用香油涂佛足上而发愿言。以我此善。得那罗延天身为三界主宰。次商迦仙人然灯三盏。施三条针志心供养而发愿言。献此三灯三针。愿具三眼得三股叉。于生生中恒行施愿。为世间主宰得八自在。成就欲乐心识聪利。尔时鲁支头髻殊妙发长赤色。遂解头髻布于道路。告世尊言。愿佛慈悲踏我发过。佛之两足于三界中得未曾有。千幅网鞔。有幢印幡印金刚杵印。如是印相纹同绮画妙善庄严。佛遂踏过而发愿言。以我此善。当得成佛救诸轮回一切众生。如是四人各发愿后。其老婆罗门所修众善。获梵王身具五头面为三界主。用吉祥花布施感手持天拂。若次修行者。所修善根得无边福。获那罗延天身。施铁供养感手持轮宝。名曰妙现。能破一切修罗。第三商迦仙人。若施三灯感面生三目。施于三针感得三股叉。若旋绕世尊。得世间爱敬八种自在。为其主宰能生灭世间。第四鲁支者。布发供养以愿力故。当得离欲出过三界。成一切智智号天中天。尔时世尊。欲重宣此义。而说颂曰

  最上吉祥花　　施已复旋绕
  当得梵王身　　称为索诃主
  五面相庄严　　手持于天拂
  施铁获功德　　得那罗延天
  手持妙现轮　　能破于修罗
  燃彼三盏灯　　三针同供养
  面感三目生　　手执三股叉
  鲁支大仙人　　布发而供养
  以此妙善因　　当得成佛果
  自在天忆念　　过去无数劫
  彼等修行因　　其后当作佛
  出现于世间　　声闻不能知
  唯佛无上觉　　晓了能分别

尔时世尊告目连曰。彼大自在天所生此身甚为希有。彼从梵天下降人间。时寒林中有饿女鬼。名曰幻化。彼与鬼交鬼即有娠。彼即托生在鬼腹内。后乃生身。面有三目。身有光明。其母见已怕怖而走。以彼福故光照寒林。一切鬼众是时鬼众见光如日。心生疑惧而即问曰。汝是何人。彼即答云。我是大自在天名曰自生。鬼众闻已恭敬礼拜。而乃赞言。胜力精进色相殊妙。复有天人及彼梵天。俱来瞻仰。天人之众见彼梵天。具其五头内一丑恶。众怀惊恐心生热恼。告大自在天。可能为我截去彼头。大自在天告天众曰。若截彼头令我获得杀梵天罪。天众复言。如有过罪我等分受。时大自在天许之言得。寻即自变为大鹰身。以其手爪摘去一头。是故大自在天。于其手中持梵天头。一切天人婆罗门众普遍皆知。佛说是语。时长老大目干连等。一心听受。皆大欢喜佛说大自在天因地经


佛说道神足无极变化经

    No. 816 [No. 815]

佛说道神足无极变化经卷第一

        西晋安息三藏安法钦译

闻如是。一时佛游于忉利天上。在巴质树下绀琉璃石。佛坐其上为母说法尽夏三月。与大比丘僧众俱。比丘八千皆得罗汉。诸垢已尽神足备具能在所作。为菩萨七万二千人。神通已达皆得陀邻尼。悉知一切人心之所行所欲。自在遍至诸无央数佛刹。时佛与无央数之众眷属围绕而为说法。尔时诸天众中。有二天子。一名曰月天子。二名曰月星天子。在众会中坐。于是月天子从座起。更整衣服前下右膝。叉手长跪白佛言。愿欲说者今欲所问。佛言。恣所欲问。于是月天子踊跃。即说偈问佛言

  为一切大悲　　纯厚而得利
  立之得至道　　甚净施甘露
  既已得自安　　灭除诸垢秽
  复能安一切　　是故愿欲问
  于无数劫中　　所行甚勤苦
  悉舍诸所有　　布施无厌足
  为一切等心　　等忧于众人
  今愿用是故　　欲问人中尊
  其有见佛身　　众好自庄严
  皆发踊跃意　　所得因福田
  广长无边际　　无量过大海
  是故今欲问　　其德无过者
  亦无有异意　　复无有异心
  三界将中雄　　了知一切念
  其身所当行　　未曾随他人
  是故今欲问　　于世之大智
  若有德无德　　叹誉及毁谤
  有名若无名　　若苦及与乐
  皆知世八事　　分别而具了
  是故愿欲问　　已离于诸畏
  复护一切人　　自身守无异
  于是无增减　　三界皆悉尔
  有慈于他人　　不疑无嗔恨
  是故愿欲问　　持行譬如地
  布施与持戒　　其心甚清净
  宁自没身命　　终不犯于戒
  如身口所行　　意亦复如是
  是故愿欲问　　过度于世者
  忍辱调其意　　坚立而自损
  是皆智所造　　悉见勤苦处
  诸好恶嗔恚　　一切皆能忍
  是故愿欲问　　所为皆办讫
  精进力甚强　　超越于诸议
  为世作勤苦　　未曾自为身
  昼夜常仍求　　如駃流入海
  是故愿欲问　　其德知与天
  于是诸欲事　　三界不复为
  一切诸恩爱　　皆悉能降伏
  禅旬皆已具　　神足亦复然
  是故愿欲问　　人中之猛雄
  于是大智慧　　已度无所乐
  劫劫诸恶事　　皆悉为舍离
  若在于空闲　　自在知诸法
  是故愿欲问　　别于俗而作
  神足功德智　　灭诸不可行
  从是到他刹　　不誉慈心想
  供养于诸佛　　于佛亦无想
  是故愿欲问　　爱世人示现
  是时魔皆来　　悉共大聚会
  即以道法力　　众魔皆自坏
  于是降魔已　　自致道乃成
  是故愿欲问　　其功为最胜
  一切住于地　　金座地踊出
  即时逮觉道　　佛智不可量
  便起到他处　　皆悉解诸议
  是故愿欲问　　人中之最上
  一切智功德　　为尊中复尊
  已得如佛意　　如法说经行
  合会为已度　　导师为一切
  以故问其议　　三界皆蒙恩

于是月天子说偈赞佛已。白佛言。世尊。云何菩萨摩诃萨逮大神通智之持得最度无极。云何菩萨得不可思议善权方便。得知他人心之所议。云何菩萨得知一切法。为一行为一味为一入为一教说云何得智自恣为他人说。云何菩萨得甚深戒。不有放逸行。自致无上正真道而不离佛。所问如是。世尊。愿为解说之

佛告月天子。善哉善哉。天子。欲习如来业。欲被大僧那僧涅。欲入大战中作大导师。欲度一切。欲作大船。欲转大法轮。欲作大布施。欲作大法身。欲作大法雨。欲然大法火。欲击大法鼓。欲举大法幡。欲说大法界。欲放大法声。欲治大法英。欲现大法智。欲断邪见祀祠。欲建立满大祠。乃欲作如是状貌不可计数事。乃为一切故。持是议以问如来。佛语天子。谛听谛听善思念之。吾当为汝说之。菩萨摩诃萨得大智至甚深微戒。自致无上正真之道成最正觉。如是天子。听佛世尊所说。于是月天子。与诸大众叉手受教而听。佛语天子。菩萨有四事法。逮得第一差别大通之持。何等为四。一者得知一切法状貌无所增减。二者求索一切法。三者一切法无有尽。得定安隐得学之证。四者不见一切诸法离于法性者。不于余法界有所悕望而想视。是为四事。云何天子知法之状貌。知过去亦空当来亦空。今现在亦空。诸所有亦皆空如空。如是天子。长坐三昧索空各不知处。是名为悉了知。如是天子。知是处名为分别晓了。晓了诸决便持转相教授。是处知处造立处分别处。如是处。解议处展转相传是名曰功德。如是天子。云何得一切法。法亦不想我我亦不想法。法起则起法住则住。天子。一切法如是。是我所非我所悉已无。菩萨如是者为转前。为转前者便不复乐起灭处。所以者何。诸所有无所有故。于无所有于余法而思惟。虽思惟不于余法有所学。亦不有所说亦不有所住。虽于余法作大明。于法亦不为亦不学。如是天子。云何菩萨得知诸法等如虚空心。天子。造作三界。如是天子。心无有形。亦不可见无住止处。亦不可知如幻。是心心法。求心亦不可得。如是心心法。求心了不可得。是心复不可知。如是心一切法。亦不可得复不可得。持法了无所有视诸所有审如化如影。如是知一切法已为过。已过者一切诸不学而自知。如是知诸法等如虚空。如是天子。如虚空不可见。亦无有生亦无有长者。知一切诸法亦复如是。如是虚空亦如。虚空寂而净。如是诸法亦寂而清净。如是天子。云何菩萨得知一切诸法法性。如是天子。菩萨作是学。诸法亦不见。亦不可得。眼亦不见耳。耳亦不知耳。耳亦不见眼。眼亦不知眼。鼻亦不见舌。舌亦不知舌。舌亦不见鼻。鼻亦不知鼻。鼻亦不见身。身亦不知身。身亦不见意。意亦不知意。一切诸法若行若住。法当云何而等知法性为在所。如是眼见知分别于法。不言是不是亦不随。以是故得知常住处。亦不于法作衰。所以者何。外亦不入内亦不受。于衰不衰当作如是知如是见。亦不于法有所生有所住。如是住为悉见。如是天子。是为法性。如是法性亦不起亦不灭。于是处无所有。然复现诸法。以住无所生无所起。是止处如是审谛。如当眼所见智亦尔。亦不于法性亦无所脱。而兴隆而住止。彼诸法法性以毕足。如是天子。是为四事法。菩萨得大神通智之持得最度无极。如是天子。云何为神通。云何为智。天子。神通者。于一切诸法要义悉知。彼一一之智皆悉了。是故天子。名为神通。于一切诸法而自知我我名。天子。我者而不佷是为法黠。如是天子。菩萨用是故疾得大神通之持。智于所愿而无厌。所以者何。欲满所愿故。如是智。天子。过于人眼逮得天眼净。悉见十方不可计无央数亿千万诸佛刹中。于诸刹中见诸佛世尊及诸弟子众。持天耳悉闻诸佛世尊所说法皆悉闻知。诸佛刹土中一切人民学不学上中下事皆悉了知。能持神足遍游到诸佛刹。悉知前世无央数劫中所更。索知一切人意中所念。所从来生本末皆悉逮知。持是智以自证。便能为一切说法。如是智。天子。菩萨摩诃萨逮得一切智。佛所作者皆得住。疾逮得诸佛法。成无上正真之道最正觉。佛尔时便说偈言

  于是大神通　　悉为已满足
  善权之所施　　见则功德相
  如是皆从一　　悉了知诸法
  甚深净戒德　　亦皆由是致
  以如是之故　　皆悉知诸法
  终不于是行　　念有踰过者
  一切无所有　　其法亦如是
  譬之如虚空　　法义无差特
  于是审谛法　　尔乃得见法
  不疑于法界　　用是晓了知
  不以服法故　　而悉具足知
  分别而晓了　　自致得神通
  其诸过去法　　皆悉为虚空
  诸有当来法　　亦复无所有
  今诸现在法　　亦等悉如空
  如是所见者　　一切皆同等
  是三世诸法　　皆悉如虚空
  亦非是我所　　亦不非是我
  以自知一生　　一切亦复尔
  如是诸所见　　便为得转信
  于彼如是知　　功德不复同
  为一切说法　　亦不想于法
  亦无有恚恨　　不言是与非
  亦不有所疑　　亦复无所觉
  其已如是者　　便为立诸法
  于是诸所习　　为皆无有余
  于是无余法　　诸法皆悉尔
  亦不于异法　　而复有所见
  如是亦不生　　亦不为复有
  于是无所入　　亦复无所得
  便为逮得德　　为一切说法
  普演于法义　　于道无所念
  其心于三界　　为已甚佳快
  心已如是者　　为都不可见
  无色若如影　　其像亦如是
  于法有所求　　其心为已止
  若有于是法　　欲求索其心
  法亦不见心　　心亦不见法
  其于如是心　　心而复求心
  心已如是者　　悉已见诸习
  诸法亦如是　　无能黠法者
  诸所有思想　　不能作妨碍
  一切未成法　　我当悉办之
  其法如虚空　　常住无增减
  譬若如虚空　　所生无所有
  其已如是者　　为见一切法
  亦不于虚空　　而有所作为
  如是名为好　　诸法亦如是
  眼亦不见耳　　耳亦不见眼
  舌亦不见鼻　　鼻亦不见舌
  身亦不见意　　意亦不见身
  各各在其处　　处处不相见
  若从他人闻　　或自从己知
  如是而悉能　　为人说法界
  法界如是者　　乃为悉平等
  六衰不知我　　我亦不知衰
  如是皆悉知　　所学诸法事
  学已如是者　　其慧无有量
  为悉见十方　　无数亿千佛
  乃与弟子众　　尊说法悉闻
  其有于是法　　广普为人说
  于是无量慧　　为已甚清净
  善说戒之德　　而具足得闻
  晓了于诸议　　分别为皆满
  皆悉知一切　　其心之所念
  便以神足力　　游于亿刹土
  巨亿千万劫　　无数恒边沙
  前世之所行　　皆悉见了知
  而便于是行　　为已逮五通
  便因是前近　　安隐无上觉
  佛之所住者　　皆为已得住
  其未逮道者　　当道求其议
  于是视诸法　　皆空无所见
  便发踊跃意　　欢喜无过者
  一切诸魔众　　无能动其毛
  疾逮得正觉　　无上之最尊

天子。复有四事法。菩萨摩诃萨逮得不可思议善权方便之功德。何等为四。一者逮前世智慧功德。二者其有无所依者。寒冻者苦者。苦痛者愁忧者。若见是辈众苦毒者。便发意踊跃欲救之。皆教令求佛道。三者以诸法持佛意系于一切。持前世久远功德福祐劝助。复持一切过去诸佛福祐功德劝助。皆令解脱忧苦放赦去离。都持是功德奉上诸勤苦厄难者。四者未曾发意不满一切愿。亦未曾发意漏脱。使人不至道。亦未曾令一切不至道。如我心欲至道道亦迎我心。如是智便迎于心。心便逮道智持沤和拘舍罗。于功德而增益不于法界有所坏。于所可思议法所学无有厌足。于诸功德亦不厌足。如是作诸功德倍复无厌足。不于心法有所亡。心于功德亦无所亡。常奉行于布施心清净无所悕望。常奉持禁戒而不缺减。于忍辱力而不动转。加于精进而不懈怠。于禅三昧而不乱。于智慧而不愚。常供养于一切而无所贪。以慈报恩而无所忧。思惟所生逮无所生。忧其所说法忧欲令皆度脱。天子。菩萨行如是。其有知小福者以沤和拘舍罗所作无央数不可量。如是天子。菩萨于是一切法。逮得不可计智。于诸法无所不知无所不了。何以故。天子。一切法空无想不愿。如是空不可计。心逮得不可计。作小功德。持沤和拘舍罗所作无央数不可量。何以故。如是道不可量心亦如是。如是行不可量。无边际不可量法。随无边际不可量法。如是诸佛世尊道法。亦复无边际不可量。复次天子。菩萨以沤和拘舍罗。于一切行皆悉过上。过上已随一切人所喜乐。布施者。所求者。说法者。以法而度脱之。复次天子。菩萨已如是者。逮得无央数不可计所行法。则于布施持戒忍辱精进一心智慧皆悉具足。于勤苦人无有轻易之心。于戒无缺减以戒有所长益为一切人忍辱。若骂詈轻易者皆悉忍之。于精进合会诸善德。于禅逮得诸定于智慧无所挂碍。复次天子。菩萨以沤和拘舍罗。于弟子而现行。随其法教化之。自于内无所悕望。于辟支佛而现行。以其法教化之。于其内无所悕望。如是天子。菩萨以是四事法。得不可思议善权慧。佛尔时说偈言

  其苦凡有二　　谓我及他人
  自灭于我苦　　并复能灭彼
  忧念一切人　　令心了道事
  于法心亦尔　　皆使解一议
  用福一切人　　三世勤苦行
  诸佛所行福　　一切皆劝助
  以是功德福　　奉上施一切
  于诸心所愿　　疾逮得佛慧
  令一切发意　　皆学正真道
  心不于余道　　而复有所求
  心不悕望道　　视亦不可见
  道相心如是　　心相亦俱然
  法等如是等　　于我亦无我
  自知见功德　　增益净功德
  于身无所增　　法界难思议
  常住于道处　　是乃为求佛
  其心未曾念　　豪尊以自益
  心恒存于道　　精进而不懈
  布施而无厌　　常坚护于戒
  忍辱亦如是　　不造立人根
  日日行精进　　常自念身空
  于禅而寂静　　慧能度一切
  养育于一切　　所作如莲花
  施与持清净　　不望于他人
  常愿求佛慧　　诸法具了知
  晓习一切法　　其慧难思议
  为一切说法　　而无有诸碍
  若有应此行　　是则为菩萨
  皆悉解了空　　施少报无量
  不想有与无　　心未曾放恣
  悉知一切行　　如所愿度脱
  布施随所欲　　说法种隆化
  既施而无悔　　于戒不亏缺
  忍辱及精进　　禅慧不自大
  布施与持戒　　忍辱及精进
  于禅定三昧　　慧施而降调
  其于声闻行　　及与辟支佛
  随所乐度脱　　于内而不随
  坚住于是法　　菩萨无所著
  权慧难思议　　疾逮降一切

复次天子。菩萨有四事法。一切法为一味为一入为一说。其智皆解达于众议。何等为四。如是天子。菩萨于法界得一切智功德。而无所破坏。信一切诸法皆空。亦不于法界言是我作非我作。何以故。是我作亦非。不是我作皆非。所以者何。坏诸不可习便逮得皆知一切法智。天子。是为四事法。菩萨得知一切法为一味为一入为一说。如是智为悉解达众智议。如是知如是视。若于俗若于道。便以慈转法教。若有行者行之。若有恩者恩之。若有住立者立之。便以法住立之。以法大悲而转之。不于众法言念是尊者是为卑。亦不于入法亦不于行法。亦不于若干法而有所见。习知凡人法便复行凡人法。于凡人法亦无所举亦无所下。于是一事坏习法亦尔。便广说一切法。于诸法界不见有所坏。何以故。为得一忍为忍于空。于忍空而不疑。如一入诸法入亦尔。如无所生入。天子。如是菩萨为亲近佛世尊无上正真之道。亦不想念近佛不近佛。何以故。亦不见坏一事。所以者何。亦不见一切人异。亦不见道异。亦不见一切人。亦复不见于道。佛尔时说偈言

  不于法界言是非　　不于法界无所坏
  法界如是一切如　　若不思惟不了义
  已信于法一切空　　六衰久长与空会
  一切法寂得自在　　若一处空余皆尔
  于法无见无能视　　亦复无我不可获
  若我学得如是者　　如为审谛晓道意
  行应寂静逮空藏　　止与相随诸法处
  皆知诸法为寂然　　于是寂净无不可
  世最世间法皆知　　于是不疑不转还
  不断于愿愿来愿　　闻法常念不懈慢
  于无央数不可计　　其身所作不自见
  展转五道不见法　　凡人罗汉乃能知
  凡人所习常念说　　如是之事罗汉法
  亦复不举亦不下　　寂静不受尔乃知
  一切法数皆悉知　　不于法界有所坏
  忍辱虚空等无异　　诸法虚空皆如是
  忍辱如空无所念　　一切诸法入一智
  如无从生不生习　　如是所行道不难
  如是亲近无量道　　于是心念无懈倦
  若我他人法如是　　所求无得则觉道

天子。菩萨复有四事法。于甚深戒行不放逸。何等为四。如是天子。菩萨自思惟。何等名为戒。如是自视身所行。皆知身所行善口所言善心所念善。是名曰为戒。云何身所行口所言心所念。不犯身事。不杀不盗不淫。是名为身行善。云何口所言善。不恶口不两舌不妄言不绮语。是为口所言善。云何意所念善。不嫉不恚不邪见。是名为意所念善。如是为自视悉见。用是故。皆具得如身口意所行。不作是事无有能普说其德者。亦不青黄赤白红不离色。亦不眼识而可识。如是亦不意识分别而可识。何以故。于是不生无所生。于起无所起。如是不生无所生不起无所起。于是便逮得无能说普演之德。是时心安住而不摇。如是不相逢无能普演。如是无有能普演说。亦不自言我能作是说作是行者。心亦不可见。如是说心。戒亦复不可见迹。如是天子。菩萨逮得甚深戒之德

复次天子。菩萨逮知离所见身功德。知于所见无所起。若戒若恶戒等无所作。复次天子。菩萨逮得住入甚深法要。作如是祠。诸所学事深远之行皆悉行。于一切诸乘行皆悉行。是名曰为戒。如是行为不自欺亦不欺他人。如是者名曰甚深戒。复次天子。菩萨得不犯戒不亏戒不亡戒。云何菩萨不犯于戒不亏于戒不亡于戒。天子。能自护者便能护于戒。天子。自知者便能知戒不轻易于戒。于所学无所缺。于戒而不亡。用是故不亡于戒。一切他人法皆悉知。何所是他人。我为在何所。亦不佷他人亦尔。天子。用是故能度脱一切人。天子。是为四法菩萨得甚深戒而不放逸。佛尔时便说偈言

  身口意所行　　法洁净复净
  其行胜珍宝　　是戒应菩萨
  是十无过上　　黠持护菩萨
  身口意不亏　　是戒为最黠
  不作亦不生　　于生而无生
  无种无处住　　无智云何得
  不会不作戒　　眼视不可见
  亦非耳鼻口　　非身意所识
  不造六情根　　所住亦无处
  是戒甚清净　　戒亦无所住
  守戒不放逸　　于戒无我想
  护戒无戒想　　以是得深戒
  于是见身行　　离于诸所见
  不随望见处　　于戒无想念
  如律入深法　　诸行皆办毕
  灭有便能护　　于戒无异想
  有我便有戒　　无我亦无戒
  是说为恐畏　　知我则有戒
  空寂戒无念　　寂静戒无著
  空寂戒无时　　寂戒不思惟
  不亏戒无上　　于戒不贡高
  戒亦无我想　　是则甚深戒
  于戒甚勇悍　　不为不善哉
  一戒具众行　　一切法叵得
  戒有想为痴　　无戒言守戒
  是为灭戒果　　不脱于五道
  远离诸所见　　我所皆不见
  戒亦无所见　　不畏于五道
  视不见为见　　不增不善戒
  于我而无病　　习戒皆悉见

佛说道神足无极变化经卷第一佛说道神足无极变化经卷第二

        西晋安息三藏安法钦译

于是月天子白佛言。世尊。甚可怪如来深微乃如是。是佛世尊无上正真。甚可怪。菩萨所施行。如是名为眼见诸法行。不起自好益身败道之行。从久远已断离身想之行。于无央数劫行。而不堕声闻辟支佛地。而不堕落究竟于道。满足佛法有几法行。世尊。菩萨于深法行。不于亿百千万佛而作证。佛语天子。菩萨有四事。逮深法行。不于亿百千万佛所而作证。何等为四。如是天子。菩萨坚住于诸要持一切智出家大吼逮精进而不弱。为一切故舍诸所有。坚住于施与便逮大悲事。如佛所说所问皆报答。逮得善权方便。于一切功德已成。复成于余德。天子。是为四事菩萨于深法行。不于无央数亿百千佛所而求证。佛于是说偈言

  坚住于所作　　其智亦如是
  前世所作智　　亦终不放舍
  以一切智故　　所为而不忧
  一切像色貌　　皆悉具了知
  所行常精进　　终不为放逸
  心亦不懈惓　　所行亦如是
  其诸所作为　　皆悉忧一切
  如是于众生　　常而有等心
  常兴大悲意　　忧念一切人
  愍伤诸勤苦　　皆欲令安隐
  愿疾得作佛　　断绝诸苦恼
  逮得众珍宝　　其处不可尽
  常以善权慧　　教学诸方便
  勤力作功德　　行是无厌足
  所造有究竟　　其行常如应
  安之于道次　　不悉念居处
  以如是法者　　悉皆坚持之
  菩萨行是者　　诸行皆悉了
  于是甚深法　　所行皆备具
  于亿百千佛　　所作不懈倦

尔时月天子问佛言。云何菩萨得甚深之行。佛告天子。菩萨亦不于凡人法有所望。亦不于佛法有所求。亦不于凡人法有所疑。于佛法凡人法等无有异。不于凡人法有所求。于佛法亦无所得亦无所亡。于凡人亦无异。于佛法亦无异。亦不作是念。不言凡人法不尊佛法为尊。于凡人法亦无所断。于佛法亦无所断。如是生生复生。是名曰凡人法。如是佛法。是二法为空为寂为定。如是为知无处。亦不于凡人法有所求。亦不于佛法有所求。不于凡人法处有所有。亦不于佛法处有所有。如是二者。亦不见凡人亦不见不凡人。如是知为如眼见。所见者皆空皆无相皆亦无愿。如是智慧如眼所见。如是智为佛法。亦不于佛有与无亦不念于是有所安有所苦亦不念是好是丑。是皆空亦如空空。亦不于空而见空。亦不知亦不求。何以故。已是习有老有起故。如是天子。法法乎法名法住法灭法寂。于是亦不自见亦无所见。亦不自知亦无所知。所以者何。若凡人若弟子。若辟支佛若三耶三佛。若受决若深行。天子。菩萨不于诸法空佛法空。何以故。如是天子。法乎法音声。彼善音是善音。于是不可得。如是不可得。于是为无我。如是为无我。于是不说有住不住而去。天子。诸法如是不可数佛法亦不别。天子。其譬如是。当作是视。诸法佛法常念作是行。复念如是行。于是起无识念。行于无识念。于佛法亦无所惟。如此者为以应从思惟为以起。不复作是智。不于法界有所增。亦不在亦不不在。复次习法智。无能于法有所增减。所以者何。若有爱欲法无爱欲法皆觉知。何所是欲何所为无欲。已了知于是不复随。是故天子。菩萨得甚深之行。终不见于法亦终不于佛法如是视。如是见如是观。为不见作是视。天子。菩萨众魔若魔天。不能坏如是说。天子。佛说如是

天子白佛言。世尊。菩萨摩诃萨所作甚奇特。具足知是诸慧事。乃如是了知于生死乃作是求道而不懈倦。如是起灭上下可尽。佛言。天子。譬如幻如化。若来若去若坐若所求若所说亦皆无所有。天子。譬如幻化。欲知一切诸法悉如是。一切诸所起灭。过去当来今现在其劫数亦如是。菩萨亦不念起。亦不念前世所行。天子复问。云何世尊。菩萨若不念有起生处。佛何以得来上忉利天。到所生母所尽夏三月。世尊。不从摩耶生耶。佛报天子言。如来所生不用生死法住如如住。如者不来不去。佛生如是。佛复言。天子。佛从般若波罗蜜生。诸佛世尊皆从般若波罗蜜生。何以故。三十二大人相不从摩耶生。天子。般若波罗蜜如是学。般若波罗蜜佛母身。三十二大人相皆从学般若波罗蜜。月天子白佛言。我熟思惟般若波罗蜜。无所生无所灭。云何世尊。言般若波罗蜜是诸佛之母乎。佛报言。如天子所言。菩萨当学菩萨所学。逮般若波罗蜜。便得佛身相三十二大人之相。归之十种力四无所畏佛十八法大慈大悲三昧独行游步。佛慧知他人意皆来归之。此皆不从摩耶生。是故天子。当知佛慧从般若波罗蜜生。有无央数诸慧之事不可计。今粗举其事皆悉如是。天子复问。诸佛世尊法皆悉具足。如是如如来如者随如得成。如是天子所见事如是。视佛从般若波罗蜜生。亦不从生般若波罗蜜。不于法有想根。亦无起根亦无争除。云何世尊。般若波罗蜜所生。答言天子。如法如来如如者随所作法。于是法不生不起不灭。如是天子。不生不起不灭。如是如是异为智慧。慧从般若波罗蜜生。名曰怛萨阿竭。从般若波罗蜜所生。如是生为不复生不起不灭如是天子。不生不起不灭。菩萨学疾近般若波罗蜜。天子。般若波罗蜜智不可尽。复不可尽般若波罗蜜。复言世尊。是智慧云何思惟。云何当知是般若波罗蜜不可尽智。复言天子。不于智慧思惟而有智。如是天子。于智慧有思惟有智。是不为智慧不可尽慧。何以故。天子。心知有劳终不能得不可尽知。当令如是不为智慧。天子。智慧无思惟智。若智慧有尽不为智慧天子复问。云何世尊不可尽。从何所问从何所知。答言天子。是不可尽不从放恣而等求。复问世尊。是不放恣为何等类。答言天子。诸恶行于三界而不舍。亦不离三界中诸恶。已复舍三界诸恶行。如是天子。各随所为不放恣。其报云何。于三界不起不灭是其报。复问世尊。颇有弟子从是间游过三界为人说法者不。佛言天子。于欲界能为弟子说弟子法。不能于欲界有所益。于色界无色界能为弟子说弟子法都无所益。以三昧游三界而说法。不能了佛世尊之所说。亦不见以三昧力游于欲界有所说。而无色天子。虽游欲界复不能有所脱。以三昧力游于色界无色界。无色界所说而无益于色界。无色界都不能有所脱。虽游三界但能自脱身不能益他人。如是天子。虽知三界不恋于三界坐守空法。亦不习于欲界。不能于色界。亦复不能于无色界。如是不能于三界。亦不生于三界亦生于三界。所去亦不知处。如是天子。是辈捐身于是处无能知。亦不见往亦不见还。何以故。一切诸法于三界不相逢。天子。譬如虚空不生不可见。无有作者不复会以过去。如是天子。三界一切诸法皆如是。说是法时。天诸天众中。七万二千天子远尘离垢诸法法眼净。万六千天子前世已作功德。今复闻说是法。皆发阿耨多罗三耶三菩心。八千菩萨得不起法忍

尔时众会者皆承佛威神。皆自见未曾所见华在其裓上悉以散佛。应时佛威神令是华遍满忉利天上。是时释提桓因前白佛言。甚可怪世尊。是诸族姓子所散华本所不见。尔时月天子谓释提桓因言。拘翼。世尊亦是未曾可见者。华亦如是。何以故。拘翼。持是心见世尊者。是心为灭尽不可得见。如是拘翼。其有可见之事皆前所未曾见。释提桓因问天子。仁者云何见佛。天子报。如是世尊见我我见世尊亦复如是。释提桓因又问。云何见。答言拘翼。如来如如色如如痛想行识如。我作是见如来。拘翼。我不以色观如来。亦不以痛想观如来。亦不以行识见如来。所以者何。色自然不起不灭。痛想行识亦尔。是五阴法之相。是相不相皆如普照。拘翼。如来如是不可见。拘翼。复有欲见如来当如佛见我。我见佛亦尔。复问天子。云何如佛见仁。天子答言。今佛在此自可问佛

于是释提桓因前白佛言。云何世尊。如来见月天子。佛言。不以色见。亦不痛痒思想生死识见。亦不以前世见。亦不持当来见。亦不现在见。亦不凡人见。亦不于凡人解脱见。亦不于学见。亦不于不学法事见。亦不阿罗诃见。亦不阿罗诃法事见。亦不于弟子法见。亦不于辟支佛地见。亦不于佛地见。所见如是。拘翼。如是为见佛。如是见佛为无所见。如是无所见是为等见。如是示现是名为一切示现审谛示现。如是观。拘翼。是名为如来。如来于法界无所缺减。拘翼。于拘翼意云何。如来如是见如是观为见何等。答言。是名为见佛。世尊。如来是名为得不于色。如是如来于此无有能得计数者。复问世尊。如是为见佛耶。答言。如是拘翼。菩萨为逮得无所从生忍。于一切诸法界皆为等住。亦不离是法而见法。释提桓因复白佛言。是月天子为得无所从生法忍。佛答释提桓因言。持是事自以问月天子当为汝发遣

于是释提桓因问月天子。仁者。今为得是无所从生法忍耶。月天子答言。拘翼。颇有无所生而起不。释提桓因言不。天子复言拘翼。设无所生不起者。云何复问得无所从生法忍。天子复言拘翼。法界无所生。其譬正如此。是故法界亦不起亦不灭都不可知。尔时释提桓因便发是念言。如月天子所说。为已得无所从生法忍。为逮近佛。为逮三耶三菩。尔时月天子知释提桓因心所念。语释提桓因言。拘翼。无所得忍者。得三耶三菩座不难。有不得忍者。去三耶三菩座大远。释提桓因复言天子。云何作是说。天子报言。拘翼。已得忍者能作是说。其不得是者不能近三耶三菩阿惟三佛座。得无所从生忍故。能说无所从生如无所生。如是者道。释提桓因复问天子。道从何所求。天子答言。拘翼。道于三界而无我作是求道。释提桓因复问。三界无我云何求。天子答言。如法者不生。不生复不生当道作是求。作是求已。如是求不求于求。是者为无所起

是时释提桓因白佛言。甚可怪世尊。月天子所说甚深乃尔。从何所没而来生此。于是没当复生何所。时月天子语释提桓因言。拘翼。如幻师化作男子若女人。从何所没来生于此。于是没复生何所。释提桓因复报天子。了幻与化无起无灭。不可见不可知。是无所有。天子语拘翼言。如是说幻化从无合会来生。灭亦至无合会所。如是幻化。黠慧者所不用亦不不近。释提桓因言。如是天子。如所说。天子报释提桓因言。拘翼。如卿所问。我所答亦尔。如卿诸法如幻化。念欲持是事以问佛。是天子从何所没而来生此。于是没当生何所。天子语释提桓因言。于拘翼意云何。如如来化所化如。若去来上下可见知不。释提桓因答言。天子。如是不可得见。天子复言。是化宁可有所作为不。释提桓因言。能有所作。天子复言。如是拘翼。化一切诸法等如此。若去来上下作是观。拘翼。于是无能有所作。于拘翼意云何。不于是见色声香味细滑法亦尔。是化人宁能见闻知如是事不。释提桓因言。天子。不可得见闻知。天子言。如是拘翼。如是一切分数知诸法亦如是。若见若闻若心念法。亦不染亦不污。亦不于是止。亦不近亦不离。于见于闻于念。如是所语如是法。为一切说。为众所说而无有异

于是释提桓因白佛言。世尊。是月天子。说无处所不生不起不灭。是天子。不在弟子地。不在菩萨地。见菩萨云何当忆念无央数劫生死之事。育养众生云何都不可得知。佛语释提桓因言。拘翼。其有菩萨得不起法忍者。亦不念生亦不念起亦不念灭。欲睹是辈菩萨。当如观百岁般泥洹阿罗汉。不可得知。何以如是。亦无他人想。亦无我想。复无无他人想。复无无我想。复如是。拘翼。精进乐勤苦行菩萨所作。亦不念生亦不念灭。亦无他人想亦无我想。诸法体性本皆泥洹。如是拘翼。一切亦不缚亦不解。不了知是法是菩萨。为是故为解为示现。思念故为起大悲。是菩萨不疲厌。于无央数拘利百千劫而不懈怠。譬如拘翼有人堕火坑中。有大悲男子。不爱躯体不惜寿命。舍五所欲及诸所乐。入火坑中抱是人出。亦自出复出彼人。于拘翼意云何。是人所作为难不。释提桓因言。世尊。是人所作甚难甚难。佛言。如是拘翼。是何足为难。菩萨所作又难于此。以脱诸欲发意欲持诸供养之具。以其所有将护给与一切。如是拘翼。复有过于是者。以是光明之德照示一切。如是皆过一切弟子及辟支佛上。菩萨摩诃萨自致阿耨多罗三耶三菩阿惟三佛

复次拘翼。如是说从何所没来生于此。听者拘翼。东方于是国分。从是佛刹度九十二那术百千佛国。名罗他那萨遮(晋言珍宝审谛奥藏)。世界中以众宝为树。其枝叶华实无央数色。其经行处以无央数宝而校成。其国中所有皆众宝以为校庄无空缺处。其地皆绀琉璃。无央数宝以相杂厕。复次拘翼。有世界名罗陀那光只(晋言珍宝积聚)。是世界。拘翼。佛名罗陀那文陀罗帝耶阿丹竭罗油(晋言珍宝豪场出过上聚)如来无所著等正觉。今现在说法。其佛国中无有母人。亦不闻母人。亦无弟子缘一觉道。纯是菩萨满佛刹中

复次拘翼。是珍宝豪场出过上聚如来无所著等正觉。其世尊一一说法。七十二拘利菩萨皆得不起法忍。菩萨得是忍已。意念若豪名(丹本多)珍宝上天世大性一切皆以断用。是故一切诸佛刹皆悉为之动。即时三千大千刹中。若干无央数珍宝莲华杂华色甚鲜好。悉满其中以散佛上。皆于佛上化成华盖遍覆佛刹已。是菩萨便踊于虚空。飞到他方佛前而供养礼事。欲绕问讯欲闻法

复次拘翼。得法忍菩萨不乐住一处。便能遍到诸佛刹。不得法忍菩萨不能到他方。复次拘翼。彼佛世尊出来十二劫。彼佛所止处夜常三说法说法已。七十二拘利菩萨得不起法忍。如是拘翼。不得不起法忍菩萨不能到他方刹。得不起法忍者乃能到他方佛刹。如是菩萨乃于彼间没而生他方刹土。如是拘翼。以是比类当作是视。如是不可计亿佛刹诸菩萨皆悉尔。拘翼。是彼珍宝积聚刹土中。所有一切皆无有忧入三恶道。亦无苦智亦无乐智。亦无所问亦无所说。亦无勤苦亦无食饮。何以故。诸菩萨以法欢喜为食饮。彼土中无罗汉辟支佛名如是拘翼。珍宝积聚国土中。是刹中世尊珍宝豪场出过上聚如来至真等正觉。是月天子。从彼佛刹没来生此忉利天。故来欲见佛礼我绕我问讯我。欲有所问故来。因是所问会无央数千人广有所知。又会余菩萨。于不起法忍皆使满具。拘翼。是月天子。故来见佛欲护一切法欲持于法。佛般泥洹已后最后法欲尽时。当于是间得道生于人中。持是所说甚深甚深法广有所照。普以教授满百千人。于是不起法忍皆乐欲学。久远最后法欲尽时。于是尽终生第四兜术天会。于弥勒菩萨所讲说诸佛世尊道事。不可计数百千天子。前世初未曾起道意。今闻是说皆发阿耨多罗三耶三菩心。弥勒来下得正觉时。是菩萨承事弥勒佛万岁。居家常供养弥勒及众僧。乃后时与四千人俱。以家之信出家为道便作沙门。作沙门已。于弥勒如来至真等正觉所。尽形寿常持法。弥勒般泥洹后至于法住常持法。于是贤劫中千佛中少。四佛。皆当供养承事尔所佛。于是诸佛世尊所说经。当修梵清净之行。最后过七恒沙等劫。当于是世作佛。号字月光曜如来无所著等正觉。所愿皆满

于是月星天子语是天子言。善哉今为佛之所授决。当得阿耨多罗三耶三佛。卿本有何等恩有何等供养。作何等爱敬喜乐欢喜事施于佛。乃使如来独授卿决。是时月天子语月星天子言。如来者亦不以善与人决。亦不有所畏故与人决。亦不言是人可与是不可与。菩萨者自学菩萨法世尊便记其决。卿云何作是问。我仁有何等恩于佛所。使佛作是敬作是爱作是念作是欢喜作是赐遗。月星天子问月天子言。是欢喜当从何所见。月天子答月星天子言。欢喜从心求。月星天子复言。心不想心。谁作是踊跃者。报言。踊跃不可持亦不可获。是上踊跃。如不可获踊跃之最也。月天子语月星天子。如是踊跃。于是踊跃有所不可者不为踊跃。是踊跃于放逸事而不为。于是踊跃中而常踊跃。不复生废退意。如是月星天子。当于是法求用是故得踊跃。于法所作而不放逸于是求于是。不求亦不离求。何以故。不于法界求。亦不于所求。如是月星天子

佛说道神足无极变化经卷第二佛说道神足无极变化经卷第三

        西晋安息三藏安法钦译

于是月星天子语月天子言。如是菩萨学名为学菩萨。复问何所是菩萨学。报言天子。菩萨学于菩萨。于是无身无身行。无口无口行。无意无意行。是为菩萨学菩萨。于身无所学亦无所获。亦无所失亦无所亡。如是天子。菩萨学。复言天子。如是学为如来所授决耶。月天子语月星天子言。不作是学者世尊不与决。何以故。不念于是学。不念有所说。亦不念我。亦不念有所求。亦不念我有所学。是名为学。语分部于世不合会其有言。我作是学。为不谛为非说。不念言有我。亦不言是谛。亦不言我是菩萨学。复问若有几事。天子。得审谛报住。答言。于所愿常高举而不下亦不中间。于愿常在心未曾休懈。虽有是而不作。是法为最是法不如。于是法审谛觉知是名为住为审谛住。复问言。天子。持何所法得如来授决。报言。不于凡人法有所舍。亦不于佛法有所得。用是故如来授决。天子。如是法无所舍。于是法无所得。我以是故为如来所授决。复问。如是凡人为皆授决。何以故。如者不舍凡人亦不舍凡人法。于佛法亦无所得。复言天子。何因缘为凡人法。复言法空法界亦空。复言天子。何因缘为佛法如者拘利佛亦如。报言天子。能于虚空界于法界能有所舍不。报言天子。不于如如者于拘利佛为可有所得。报言。不久天子。如是天子。次第说。于凡人法无所舍。于佛法无所得。用是为如来所授决。复言。云何于空界法界于如于拘利佛从是得决耶。报言。天子不尔。复问言。云何天子。于空界于法界于如于拘利佛。于是不得决。余诸佛复从何所得决。报言。怛萨如受决如空界法界怛萨拘利佛。如是天子。法乎法如此。法乎法也如是授决是为受决为得决已不离阿耨多罗三耶三菩。不离阿惟三佛。于是月星天子前白佛言。世尊。是月天子逮得深慧所说乃尔。佛言。如是说法。天子。菩萨为逮得忍。若求索若发遣。若于一切诸法界。若说若有所说。不能于法界有所见。不能有所语。亦不能有所传。何以故。于法界无所语亦无所说。如是法界如是人界。如是人界是为佛力处。如是佛力处一切诸法如是如是。天子。如是菩萨为如法住。如是住不复信余事亦不随余事。如是者当复因何等令佛有所说。尔时贤者大目揵连于释提桓因宫紫绀殿上。为诸天子众说法。尔时大目揵连从座起便彷佯心念言。如来无所著等正觉。在此阎浮提为已空。阎浮提有无央数人。饥虚欲作功德。不见佛不闻法。于所作为转减。于是大目揵连作是念已。持天眼遍视阎浮提。便见佛如来无所著等正觉在萍沙宫中食。与大比丘众千二百五十人俱。是时大目揵连复自见在佛左而坐。自见身形被服坐在佛边无有增减。复自思惟。得无世尊还阎浮提。复更视巴质树下。见佛世尊与无央数诸天众围绕而为说法。见舍利弗坐佛之右。自见目连与诸比丘坐佛之左。复与大比丘俱。于是贤者大目揵连见甚大可怪。诸佛世尊所作为不可思议。诸佛世尊为威神为大。为能为大。分于阎浮提说法如故而不断绝。于第二忉利天上为诸天说法。尔时大目揵连复大疑怪。复更谛视。见佛在舍卫祇洹给孤独园与无央数众围绕而为说法。复自见在于会中如其像貌。舍利弗摩诃迦旃延分耨须菩提离越贤者子劫频奴一切诸大弟子众。皆悉见如在舍卫。如在罗阅只。如在忉利天。于是大目揵连复重思惟。阎浮提复见迦维罗卫大国尼拘类。见佛从尼拘类园出入迦维罗卫大国而行分卫。复见比丘形像如目连。于是复见佛在维耶离大国与大比丘众俱至离垢月童子家饮食。目连复自见色像貌与大比丘众俱。于是大目揵连见佛在波罗柰大国从分卫还。自见色像貌亦在其中。复思惟遍视阎浮提。所在处皆见有佛。若树下若岩石间。及阎浮提地上佛悉遍满。皆见佛比丘僧俱围绕。若干百千所在聚落皆悉遍见。于是目连重复甚大疑怪。更思惟已持天眼视郁单曰。见佛与比丘僧俱受食。亦自见身在其中。亦见余弟子。复视弗于逮。亦见佛在大身众人中而为说法。于拘耶尼地亦复如是。见佛世尊坐禅无央数千众皆见为佛作礼。诸弟子众亦各各随其色像貌而坐三昧三摩越。亦自见身在其中。于是目连倍复疑怪。复坐思惟。地上诸神。于是复见佛与诸弟子众。亦复自见在其中及众弟子。如是虚空中诸神亦见佛在其中。为虚空中诸无央数百千诸天而为说法。亦自见身与众弟子在其中。如是第一四王天上炎天兜术天尼摩罗提天波罗尼蜜和耶拔致天乃至梵天遍视。复见佛在梵天与无央数百千梵天围绕而为说法。亦自见身色像貌及一切众会者。皆悉如大目揵连。神足变化在所作为皆悉尔。自见在中为一切而说法皆如目连。复变诸会者。皆如舍利弗比丘。智慧光明于大众中为师子吼。如是比各各自以慧力。为说大弟子法。于是大目揵连惊怖衣毛为竖甚可怪。踊跃欢喜则生善心。三反自称誉言。乃尔乃尔。诸佛世尊甚大可怪。无挂碍行所作亦甚可怪。大踊所成欢喜踊跃五体投地。赞叹言。南无佛。尔时闻大音声响忉利天皆为震动。于是无央数百千天聚会俱到佛所白佛言唯。世尊。何因缘有是大音声感动是地乃尔。所问如是如来。佛言。如是天子。大目揵连于佛大地踊跃自归。五体投地感动使尔。佛言。如是天子。是比丘目连。当自来问。于是比丘目连起住疾疾往到佛所。前以头面着佛足。绕佛三匝已住佛前。叉十指为佛作礼。是时目连于佛前。说偈言

  持力不可称　　佛为已逮得
  如佛之所行　　世雄难思议
  垢垢已离三　　心意皆已调
  天人之中尊　　一切所供养
  虽有百千日　　满于虚空中
  盲者无所见　　盲者不蒙光
  十力放光明　　弟子因所见
  一切诸弟子　　不能及佛明
  从胎盲无见　　弟子行亦尔
  不能知佛慧　　亦复不能持
  虽有信受是　　如来之法教
  于是无能知　　不及尊所行
  譬若如大海　　欲比牛迹水
  其德如须弥　　喻之于芥子
  如日之光明　　宁与萤火等
  佛世尊之德　　弟子不能及
  不可以须弥　　方之譬芥子
  日月之光明　　比之于萤火
  比之牛迹水　　不可以大海
  比之于弟子　　不可以菩萨
  譬若如盲人　　以比有目者
  若复有乞人　　以比遮迦越
  譬如月光明　　比之以星宿
  如佛世尊德　　弟子不能当
  在于人间行　　复现须弥顶
  所现譬如幻　　一切蒙福祐
  不知佛在彼　　我忆天下空
  不复得见佛　　及与比丘僧
  我于此宫舍　　常止坐其中
  为诸天婇女　　教诫说法事
  便自以天眼　　观视阎浮利
  即见诸百国　　谓之无福地
  思惟是天下　　便即见世尊
  在于罗阅只　　与弟子共食
  在萍沙王家　　处于大宫中
  与诸众会俱　　眷属而围绕
  在于是见佛　　譬视冰山雪
  自见目连身　　住止在佛左
  又见舍利弗　　侍在佛之右
  并复及于余　　一切诸弟子
  我自忆呼佛　　下在阎浮利
  还在忉利天　　佛故在其处
  于是熟自视　　止在忉利天
  谛复自思惟　　处在阎浮利
  又复见世尊　　在于舍卫国
  坐于大众中　　一切广说法
  亦复自见身　　在于大会中
  亦见舍利弗　　及与诸弟子
  复现于释种　　现行而分卫
  见在维耶离　　而行受人食
  现住波罗柰　　行步而出入
  诸有所在处　　皆自见其身
  现到郁单曰　　与诸弟子众
  共行而分卫　　见到阿耨达
  亦现在于彼　　与其弟子众
  皆坐而共食　　又复见世尊
  现至拘耶尼　　复在弗于逮
  为无数拘利　　而为说其义
  皆自见目连　　在彼作变化
  自现神足力　　示人本所行
  于是诸地神　　见其所居处
  虚空诸神天　　为之理法事
  皆悉具示之　　今睹无上法
  在于四王天　　皆为说正法
  于炎天所见　　亦复悉如是
  见在兜术天　　亦复见魔天
  现于尼摩罗　　波耶尼蜜天
  悉见诸弟子　　并及与世尊
  在于梵天上　　所见亦如是
  为诸拘利梵　　皆为其说法
  于是自见身　　遍在诸梵中
  一切余弟子　　其众皆如是
  前诸过去佛　　所行皆如是
  经行及与树　　若龛及卧处
  于是皆悉见　　无数诸法王
  其如是比类　　皆如释师子
  我自在是间　　所见甚可怪
  其所见法事　　雄特无过是
  诸佛之世尊　　可怪放光明
  乃作是变化　　神足中最尊
  在于忉利天　　说法不往来
  悉遍阎浮提　　处处皆悉见
  国邑与郡县　　聚落及余处
  常等赞叹之　　为其而说法
  如我之所睹　　为皆见世尊
  并见诸弟子　　为皆得寂定
  大拘路拘路　　复及与离越
  迦旃延分耨　　及与大迦叶
  我皆为已见　　诸佛世尊迹
  无数所赞叹　　闻之若如海
  于是悉自见　　其身皆在中
  无央数之德　　其场聚如是
  如是大音声　　为在须弥顶
  以是礼世尊　　其德难思议
  恐怖求自归　　衣毛为之竖
  今愿持五体　　头面自归礼
  如是大音声　　普周无不闻
  诸是三千界　　皆为大震动
  在于须弥顶　　广放大光明
  我亦于是住　　皆悉而遍见
  我于是惊怖　　疾疾到佛所
  时即便往诣　　前见人中尊
  而问于是法　　恐惧心所怪
  皆施行何等　　能作是变应
  何所是佛事　　惟愿为说之
  如是阎浮利　　天上亦如此
  于东西南北　　四面俱皆是
  若在于梵天　　虚空亦复尔
  我自呼有德　　施祐谓为益
  自恃得道时　　神足为无比
  我求甚使疾　　焦烧道根本
  违失如来行　　远离于佛慧
  于是自思念　　是心无解脱
  本造当如是　　发心求佛道
  今悔无所益　　于行为了尽
  诸情悉已断　　于佛法无益
  譬如人入海　　行采求众宝
  舍摩尼不取　　而更求污泥
  自察如我智　　并复及余人
  弃于世尊行　　而反求弟子
  若疑有懈怠　　是行不得佛
  精进发道意　　合会诸善德
  如是勤苦行　　可得过三界
  其能作是行　　佛慧可疾得
  惟愿稽首礼　　归命诸世尊
  其有逮得是　　持最尊佛慧
  能现无极变　　独有释师子
  诸有见闻者　　疑惑为永除

尔时佛赞贤者大目揵连如汝境界能视能见。复次目连。如诸佛世尊境界不可思惟。令一切人及蜎飞蠕动。皆得辟支佛都合会是智。共消息不能知不能见。何况汝一弟子而欲计量知。是一处之所作尚不能知。况佛境界而欲得知耶。如是目连。复次当来辈皆共聚会。是辈聚会已共坐一处视道变化。如是如来等正觉。变化现道神足。名为道变化神足变化无极变化法言所说。目连则言。如是世尊。贤者大目揵连。闻佛所说已。自见身在莲华上。放身光明而在梵天。自于其处所语四天下皆闻。于是目连说偈言

  佛出于世间　　甚为难得值
  无数亿百千　　难计拘利劫
  譬如优昙钵　　其华甚难值
  如是佛难见　　世尊过于是
  譬之若尊王　　飞行遮迦越
  常而有神足　　福德力亦尔
  其子有千人　　七宝皆悉具
  往到于佛所　　听受上法言
  梵天与帝释　　所欲得自在
  若欲乐天上　　复乐于人间
  五乐以自娱　　恣心欢喜乐
  往到法王所　　一切可得愿
  若能有弃离　　一切诸爱欲
  到于泥洹寂　　如服甘露味
  其欲逮无极　　得最神足力
  当诣世雄所　　听受上法言
  若有辟支佛　　及与诸弟子
  于是两足中　　佛为最尊上
  降伏于魔王　　并及诸官属
  当往到如来　　见于法之主

于是大目揵连。发起无央数那术亿百千天子欲界色界。疾疾各以所有天华天香天傅饰华天泽香。皆持欲往到佛所。各持是华供养散于佛上。以头面稽首礼佛足却住一面。于是目揵连。以神足力聚会诸天众共在一处已。便往到佛所前以头面着佛足。皆却住一面。佛尔时语目连言。目连。听我所说道神足变化无极法言。于是目连受教而听。复次目连。三千大千刹土。百亿日月。百亿大海。百亿须弥山。百亿四天下。是名三千大千世界为一佛刹。于目连意云何。呼一阎浮利谓我于是中得道。目连。莫作是视。何以故。目连。于一切四天下。随其所愿上中下而为说法。知谁当得阿惟三佛。谁在母腹中。谁在兜术天。谁复般泥洹皆悉知

复次目揵连。于是三千大千刹土东方。去是四天下万二千四天下。其四天下世界名无尘。有佛号字比罗耶摩提(晋言如镜明无垢)。今现在说法。复次目连。彼四天下世界人民无淫怒痴。常亲近道法乐听受奉行。彼有求菩萨道者。少求辟支佛道者。求弟子行者甚众多。复次目连。彼佛如镜明无垢一一所说法。九十九亿人解弟子乘。于彼不说沙门之四德。不如是闻说沙门之四德。何等四德。须陀洹。斯陀含。阿那含。阿罗汉。复次目连。彼世界人在一坐。皆得六通之证。逮八惟务禅皆自念知。为脱于生死欢喜踊在虚空中。去地七仞坐于虚空便般泥洹。身中出火还自烧身。亦无有骨亦不见灰都无所有。如是目连。彼佛现在说法。寂然度人寂然般泥洹。彼世界无取无与。若饥渴所念。饮食皆自然在前。衣被服饰譬如忉利天上。若起若灭若生。不因母人胞胎生。无有女人因福自然而生。其地皆作黄金色。复次目连。彼佛如来国土人民寿五百岁有长有短。于目连意云何。能知彼佛如镜明无垢如来不。目连则言不知。彼土如来则我身是。我于彼间以法而教导。如是目连。如是比名为道神足无极变化也。一切弟子辟支佛皆悉过其上

复次目连。于是三千大千刹土南方。去是万八千四天下。世界名罗陀那三披(晋言宝等有世界)。其世界有三宝。黄金白银水精。彼世界佛号罗陀那揵头(晋言宝品)如来至真等正觉。今现在而说法。如是目连。复次彼佛如来。为辟支佛行者说法。彼佛世界少菩萨。弟子行者于彼刹没生于空无佛处。于彼处皆当得辟支佛。于目连意云何。知彼佛宝品如来无所著等正觉不。目连言。不知。天中天。佛言。则我身是。我于彼间说法以教导人。如是名为道神足无极之变化也。一切弟子及辟支佛去佛甚远

复次目连。于是三千大千刹土西方。去是四天下二万二千四天下。其世界名罗陀那质多(晋言名宝意)。其世界有七宝。黄金白银琉璃水精玛瑙赤真珠车渠是为七宝。如是目连。彼世界以宝为树。其经行处皆宝。以宝为交露帐以宝为栏楯。皆以杂宝而挍庄之。以宝为浴池中有八味之水。食饮皆自然念便自然至。譬如兜术天上诸天被服饮食。彼土人民亦如是。彼国土不闻母人亦不见母人。亦无有母苦生者。亦无男子母人合会者。亦无淫泆于欲。亦不淫泆于财。亦不淫泆于懈慢。亦不从胞胎生。彼世界一切人。生皆从莲华藏化生于彼。目连。复次宝意世界。佛号宝等有如来无所著等正觉。于彼说法。彼佛如来不说余事。纯以菩萨箧藏。令一切发三菩心。令不可复计阿僧祇人。皆得无所从生法忍。复不可计阿僧祇人皆受决。当为阿耨多罗三耶三菩。彼佛世界无有弟子缘一觉行者。皆悉菩萨。亦无有恩爱。心亦不念。满彼四天下。彼国如来。寿八万四千岁。其土人民寿亦如是有长有短。彼国人寿尽不堕三恶道不生边地。彼国菩萨若于是寿尽。倍复生清净刹土。面见诸佛世尊。于彼天若天龙揵沓和。其心不念一等无异。皆有萨芸若意。诸天龙揵沓和。虽有是名悉愿同一。虽若干智等以无上智。若诸天龙揵沓和若人常服于智。如是于目连意云何。彼宝等有如来现在说法。汝知不。目连言不及天中天。佛言。彼佛则我身是。我于彼间以法而教导。如是比名为道神足无极之变化也。非是罗汉辟支佛所能及知

复次目连。于是三千大千刹土北方。去是四天下世界。三万六千四天下。名无恐惧世界。其世界有两宝。黄金白银。彼佛世界。无泥犁身。无畜生身。无饿鬼。不畏生边地。于彼无有亏戒者。于所见亦不毁。亦不亏种姓。亦不于余道及尼揵波和而有所信知。彼目连。无恐惧四天下世界。佛号无畏与如来无所著等正觉于彼说法。其佛如来便往到佛树下。到佛树下已。七十二亿那术魔往到其所。是诸魔是时如来。现如菩萨求道未逮萨芸若。是时魔便化作七十二亿那术树。是时菩萨亦化作七十二亿那术菩萨。各坐一一所作树下。是时魔恐怖而大惊怪。自念言。何所为审是菩萨者。欲于是座牵出之。是时诸化菩萨语魔化幻。如汝诸魔众。一切诸法皆亦如是。云何言何所审是菩萨者而欲牵出之。我于是间禅念思惟。如我前后所作福。常发阿耨多罗三耶三菩心。以劝人令发意求菩萨道。汝云何无劝助意。反欲牵出。菩萨禅定思惟。若我所作恶事不劝人。令求菩萨者自然灭去。何须乃欲相牵耶。以是故非汝所能牵。莫于是而作自侵。于是魔复问菩萨言。汝作几所福而发阿耨多罗三耶三菩心。复能劝人令索菩萨道。报言众魔。譬如恒边沙。一沙为一佛刹。满其中珍宝持是施与。持是发道意其所作功德复过于是如是。复次众魔。如恒边沙等世界一切人皆满其中。施以所安恭敬承事至千劫中。如是功德福祐持用求道。魔复问言。卿所作功德乃尔。其有索菩萨夺处者。其罪云何。菩萨报言。如所说。尔所恒边沙一切人。若有索凿是人眼皆出之。则作罪如是为多不。魔报甚多。菩萨报魔言。若牵菩萨者其罪甚倍多于是。为牵阿耨多罗三耶三菩。尔时魔众七十二亿那术。以是方便见是变化。皆发阿耨多罗三耶三菩心。是时诸发意菩萨。天华天香天不饰华天泽香。皆举持散菩萨上。天上千种诸伎乐持用供养娱乐菩萨。如是音乐声皆说如是。疾疾令三界之导师疾成阿耨多罗三耶三菩阿惟三佛。作是赞叹已。便见菩萨坐于树下已。得阿耨多罗三耶三菩阿惟三佛。于是更有异百千天子。心念如是诸魔众今来到是。不复入三恶道亦当得脱。便当为阿耨多罗三耶三菩心。于是无恐惧施言。今得佛是故名无恐惧如来。何以故。名为无恐惧施。无恐惧与审如是说是名时。诸世界皆闻知佛为得道。佛言。如是目连。彼世无恐惧施如来则我身是。我于彼世界以法而教导。如是目连。如来名为道神足无极之变化也。一切弟子缘一觉所不能持

佛说道神足无极变化经卷第三佛说道神足无极变化经卷第四

        西晋安息三藏安法钦译

复次目连。于是三千大千刹土东南方。去是刹八万四千四天下国土。名三幔陀质(晋言遍等)。其佛名质多拘冲怛萨阿竭阿罗诃三耶三佛(晋言幻华如来无所著等正觉)。现在说法。彼四天下世界尽甚好。东西南北十八街巷珍宝满地。柔软譬如天衣。地生柔软之草高四寸。其地所有各各异种众色。如是皆悉遍行步。若下足蹈地草皆柔软可意。足举则生如故。其地皆平如掌。目连。是遍等世界皆如此。有城名颰陀郁沈(晋言善尊)。其城中人安隐丰饶炽盛大乐。东西长三十二俞旬。南北广十二俞旬。如是目连。彼善尊城人皆共居其中。其国人民繁裔。多于鸯迦摩竭拘留诸人民数。如是目连。其幻华如来世尊。于善尊城中游行止顿其中。一会说法为师子吼。令三十那术人皆得阿罗汉。复有三十那术人得阿那含。复有三十那术人得斯陀含。复有三十那术人得须陀洹。复有三十那术人发辟支佛行。复倍不可计数发阿耨多罗三耶三菩提心复异不可计数人皆悉作功德。目连。是彼。四天下世界。有树名末头三被(晋言此树)。譬如蜜其华果实常有不乏。其华果实味譬如百味饮食。彼若男子母人。欲得一华一果得以食之。安隐饱满七日不饥不羸。色貌不减身体康强轻便有气力。食是已讫如服甘露。亦无小便亦不大行亦无涕唾。彼无田种殖者。无举贾偿债者。其国中皆共食是华果。彼国初不知有贫富俱等无异。彼世界如来。目连。有九十六亿那术百千弟子众。其菩萨众复倍于弟之。有园名三曼陀拘冲(晋言法园)。有杂果诸弟子众食饮。常在是园中坐。其弟子众菩萨众皆坐树下。若欲食时树自然动摇华果落堕皆在钵中。食饮饱讫树不动摇。华果不堕还如本故。如是目连。彼世界所有事物。过倍于是不可计。目连。彼世界如来则我身是。我于彼世界以法而教导。如是目连。名为如来道神足无极之变化也。一切诸弟子缘一觉所不及知

复次目连。于是三千大千刹土西南方。去是四天下世界七万四天下世界。其世界名比实颰填(晋言容受)。有八万国王。一一天下有八万城。城外有八万聚落。八万王所治处。八万城八万四千小城。一一处城聚落处城小城拘利百千皆满其中彼诸王皆奉行法。非法之事皆悉除。尽是诸王各有八万四千夫人婇女。尔时婇女端正世之最上。一一诸王各有五百太子。一一诸王各有万二千女。是万二千女皆端正于世最上。是诸王法无鞕杖亦无兵器。是诸王各各自治在其国。目连。彼容受世界佛号波勿多罗陀那赖比怛萨阿竭阿罗诃三耶三佛(晋言宝放光明如来无所著等正觉)。现在说法。彼如来。目连。得阿耨多罗三耶三菩时。于彼四天下踊在虚空中。去地七刃结加趺坐。一加趺坐放大光明。彼时四天下世界皆悉相见。雨于天华诸音乐器不鼓自鸣。一一乐器出百千音声。地为六反震动。诸伎乐音譬如梵音声。不可计百千所作功德所致。转于法轮一切诸欲垢皆悉尽。无余泥洹。持菩萨所知为众说法。彼如来说法。以是四天下世界。八万诸王及夫人婇女。诸子诸女见佛变化已。乃皆发阿耨多罗三耶三菩心。彼国中一切人民男子女人男儿女儿。皆远尘离垢诸法法眼生。是诸王及夫人婇女诸儿诸女。从佛求作沙门。是时如来皆悉听为沙门。为沙门已在在所处。在所处及城郭县邑聚落。其所至到处。皆步行不乘车马。卧起饮食常于寺舍。不复田作种殖皆食自然。天人来下而悉供养。是时如来再会说法时。一切诸弟子行者皆得斯陀含。菩萨行者皆得欢喜忍。三会说法时。一切人皆得阿那含。菩萨行者皆逮得五通。四会说法时。一切皆得阿罗汉。菩萨行者皆得不起法忍。夫人婇女男女皆得不起法忍。尔时夫人婇女及诸女皆转女人身。悉得男子不复见女像。时彼如来。皆授决为阿耨多罗三耶三菩。于目连意云何。乃知彼土宝放光明如来无所著等正觉不。目连言不及天中天。佛言。则我身是。名为如来道神足无极之变化也。是故目连。一切弟子缘一觉所不能及知也

复次目连。于是三千大千刹土西北方。去是五万五千四天下世界。其世界名揵沓提(晋言香气)。世界纯以污勒迦莏罗栴檀。其栴檀大如一钱者价。当是世彼世界有树。三曼陀揵陀(晋言其香普熏)。彼世界一一树其香四百里。其土皆生莲华大如车轮。一华者有不可计百千叶无央数色。其华柔软如天綩綖华生高二丈。华其香遍四天下香甚香。彼世界四天下栴檀为交露。经行处亦皆栴檀波昙华来在两边。彼世界无城郭县邑聚落。但有交露帐。覆盖其上。其世界人民食饮。譬如第五尼曼罗天上。复次彼放香普熏世界。佛号揵陀勿赖比(晋言香气放光明)如来无所著等正觉。现在说法。彼如来世界纯是菩萨行。无有弟子缘一觉行者。其彼世界四天下悉遍满皆得神足。其菩萨皆得不可思议忍。彼菩萨辈中。有菩萨名萨和昙无惟屈罗游(晋言一切法无极积聚)。得不可思议愿事。已得三忍神通为达。其所报答皆悉过上。供养甚多不可计诸佛。复次目连。彼一切法无极积聚菩萨。自念今欲问佛。傥肯说者而欲问之。作是念已便从坐起。放身一一毛之光明照四百里。放身光明遍境界。若干百千种华无央数色色甚鲜好。是华在于虚空去地七刃。心念欲持是供养。应时虚空中。闻柔软音乐之声。譬如天乐。是音乐声皆出八种法印之声。一一法印之声。出八万四千拘利经卷。出七万二千偈。是时菩萨。便踊在虚空中结加趺坐。会九十六拘利那术百千人。皆住阿惟越致地。皆得无所从生法忍。当为阿耨多罗三耶三菩。如是像色貌菩萨。目连。满彼世界。一切人无有盲者亦无哑者。亦无跛者亦无聋者。无贫者无丑恶者。彼一切人民皆是菩萨。有三十二大人相。其世界无有他余异杂行。彼国中亦无饮食者。但以禅欢喜为饮食。其国中无有羌虏夷狄杂类之人。亦无三恶道亦无边地。亦不于彼间没而致他方国土生。若有没灭者便逮得如来。佛言。如是目连。彼世界如来则我身是。我于彼土以法而教导。是名道神足无极之变化也。一切弟子缘一觉所不能及知

复次目连。于是三千大千刹土东北。去是四万二千四天下世界。其世界名榆末陀那(晋言应时)。彼世界人民淫欲甚多。贪淫嗔恚愚痴悭贪。闹愦强额诸根习邪。无信嫉妒犯恶多疑。弊恶急性懒惰懈怠。喜忘憨。无所畏。有吾我人寿命无黠智。譬如野禽畜兽不知惭羞。无有礼节心意痴狂。彼世界丑恶面目无色无所省录。其处土地。但有污泥及诸不净。生活勤苦衣食不充。喜斗更相骂詈。六月一雨一岁再雨。五谷不丰恶行所致。其世界地坚如铁石[山/族]岳不平。譬如蒺蔾蹈伤人脚。毒恶止上及地但生荆棘。彼世界所出水人民饮之。浊恶碱苦臭秽不净。衣被皆用草刍。贫穷困厄更相看视转相作使。彼世界国王急性常喜嗔恚。其中人民役使作务甚大勤苦。治生田作谷粟钱财王皆夺取。鞕杖暴疟无不被殃。如是目连。其国界中现世受殃甚剧乃尔。如是比类彼复倍过此。其世界中人命尽。皆堕地狱饿鬼畜生三恶道中。复次目连。彼四天下世界。如来名振波迦论真陀摩那迦楼(晋言伤悲怜念)如来无所著等正觉。而为说法。彼佛如来。目连。现十八大变化而为说法七百岁。说法竟七百岁。无有一人解法者。是时世尊亦不厌惓。说法如故。常持大悲而为解说。如是目连。彼佛世尊。若至聚落郡国县邑。若散居恒游行无一处。所到其国人民骂詈轻易。挽灭唾言持怒作等。其世尊悉忍诱恤养护。欲使度脱得至泥洹。目连。是时如来。于尔所岁中说法常养护之。说法时有八万四千那术人皆得阿罗汉。复八万四千那术人得阿那含。复八万四千那术人得斯陀含。复八万四千那术人得须陀洹。诸大众一日之中皆除须发作沙门悉受大戒。是时学者不学者。于三月中前所诸恶。从佛受诲皆得离之。一时俱般泥洹。彼佛恒常在。复养护缘一觉及菩萨行者。其所作罪恶故而生彼国。彼受苦痛乃尔一时皆得毕离。于是目连。复白佛言。惟世尊。是辈菩萨作何等罪。生于彼国土。佛告目连。菩萨有四事法往生彼国。何等为四。一者倚菩萨名而求供养。不学菩萨事。二者目连。于菩萨事不能行而懈怠。虽见亦复不能持。三者目连。菩萨见余菩萨得供养。便妒嫉之言何以供养。是断截他人功德而轻易之。四者目连。菩萨不能护身口意。以是故得是。用是事。目连。得生彼国。佛言目连。彼佛则我身是。我于彼国以法教导人。名为如来权道神足无极之变化也。弟子缘一觉所不能及知。其如是。目连。如来于是三千大千世界作佛事如是。目连。如汝辈不尽悉现所以者何。弟子不能及持。以是故不能悉现

复次目连。于是三千大千世界百拘利四天下世界。彼如来随一切意而为说法。复次有四天下世界。如梵天形像被服而为说法。彼世界如来不出家除须发。复次有如释提桓因形体被服而为说法。或如日天王形体被服而为说法。或复如遮迦越王形体被服而为说法。如是比。目连。于是三千大千世界中。如一切人之所愿而为说法。如是比无央数。复有异无央数不可计数佛刹土。所为一切弟子缘一觉所不能及知。譬如目连。月宫殿日宫殿日月天各坐其殿。亦复不出亦复不入。坐照见天下。如是目连。佛世尊亦不从是起。亦不到彼坐。悉见不可计佛刹悉皆示现。随一切人上中下之所愿。皆养护之而为说法。是贤者大目揵连。白佛言。何所审是佛世尊者。若忉利天。若阎浮利。若天宫。若三千世界。此彼四天下世界。复异世界说法。乃尔所世界何所审是佛者。我曹当云何知无极大嚫之议大界之服。云何得知。目连所问如是。世尊。佛告大目揵连言。如汝所问能受持不。今为汝说之。目连。譬如幻师化作人。若男子若女人。何所审是男女者。目连白佛言。无有审是者。何以故。是幻咒术力之所成于是无有持。佛语目连。是幻谁之所化。是幻能所作耶。目连白佛言。可作世尊。佛语目连。如是一切诸法如幻化而无持在所作为。如是目连。幻师所化术力所成化幻多有所作为。是幻皆等无有持。如是目连。如来以智慧。一切诸刹而等示现。如是皆悉无持。为一切所作而常等如是为佛事。以是故为大无极达嚫。如是等所为之大报。如目连诸佛世尊皆一等无若干。如是比。目连。诸法常等住。如诸法等住成道亦尔。法界而无持亦不若干。目连。汝熟思惟。如来于广远谛寻迹求佛。能化作恒边沙如来三十二相一等无异。亦能令说法六十众事所说同声。是诸如来悉皆知一切人心之所行。是诸如来皆悉知一切人当得解脱者。如解脱印印六情根而为说法。令稍稍得满智。是诸如来为一切现说法。以一切闻之皆奉行。等知诸苦皆尽。是诸如来有三事变化说法为四面等说法。是诸如来悉现诸佛事。于目连意云何。乃尔所诸佛何所审是最持者。如来幻幻如来何者为持。目连白佛言。于是中如来无有能得知持者。何以故。如怛萨。如怛萨所作而无增减。于怛萨无若干作。若色若像若报答若慧。若神足若说法。若脱一切人。如是如来。于是众事不能若干说。如是目连。所作如是。作如是见。如化幻分诸法亦尔。是故诸法无有持无若干。如此目连。化幻分知诸法亦尔。凡人于此不能作若干。乃况诸佛世尊。何以故。目连。一切诸法习于空故念厌不用欲不欲若有若无即住其中。能所作如所得。于法界亦不起亦不灭。目连。如法界。如来皆见皆知皆觉。如是目连。如令阎浮利地人满其中。如来示现示现变化。若作如来若作比丘僧。其人展转不自知为如来若比丘僧。置是阎浮利中人。目连。满是四天下若天若人及蜎蜚蠕动之类。诸可所生者。目连。尔所人皆住佛前。乃尔久远前世是一切皆住于佛前。皆现如来若比丘展转不相知。复置是四天下。目连。于是三千大千刹土中。一切蜎蜚蠕动之类满其中皆令得人身。得人身已皆令一等。如是目连。得人身。得人身已皆一种类。皆现如来比丘僧展转不相知。目连。复置是三千大千刹土人民。如是目连。东方恒边沙刹土。东方南方西方北方四维上方下方。如是十方一切诸世界。是为甚多不可计界。都普一切皆令得作人身。得作人身已。如是人辈。目连。如来一种类。一一皆使如如来。皆复作比丘僧。如是辈展转复不能自知。复置。目连。十方十恒边沙佛刹中。目连。如如来今坐。于是持佛眼。视诸佛刹中。持佛所知。譬如是数于百千劫说不能究竟。如是不可计佛刹。于是间坐见。乃尔所佛刹如怛萨阿竭慧譬喻所说。令一切皆如辟支佛。索不能知。不能数。不能称。不能视。辟支佛常皆不能知。何况弟子。以是故。如来皆见知。如是百。如是千。如是百千。如是拘利百千。如是恒迦罗。如是频颰。如是阿寿。如是阿僧祇。如是不可计数。如是恒边沙。如是三千大千不可计数国皆悉遍满中。如是目连。佛言。如是数无所挂碍眼所见。直一而视而不睥睨视。亦不延颈视。持佛眼一而视。遍悉见十方不可计无央数难思议无边无际刹土中。如是比论佛刹土。其中人民及蜎蜚蠕动之类。如是如是比。一切萨和萨之界。多于地土之分。如是萨和萨前世初未曾有行。皆令得人身已。皆使作遮加越王。一一遮加越王。各各坐有官属。一遮加越王者。其官属都卢皆如尔所遮加越王。展转如是。如是目连。都卢尔所遮加越王官属。为一遮加越王官属。如此数如是比。皆为如来其像色貌皆一种类。如是因缘一切皆住前。一一遮加越王及其官属在前。皆各自见有如来诸比丘僧。诸遮迦越王各自呼。独有如来谓其余皆无。各各皆悉各各自见一如来。谓余为无各各皆悉尔。如是诸遮迦越王及其官属身一一诸毛皆各一如来。一如来皆各有比丘僧。如是非是如来道神足无极之变化。其闻是者。不敢微意言非是如来无极示现之变化也。若有起念。是真为如来无极示现变化之所为。如是为不可计慧所为事。目连。如是于目连意云何。如我令乃尔所人。皆立之于遮迦越王处如是品福分。如是品福分。皆使得作遮迦越王七宝皆具。如是福分宁多不。目连白佛言。甚多甚多天中天。使一人得者其福无能计量。乃尔所人不可计不可限其多安过之安。佛言目连。如是所说当受持熟思惟之。如是诸萨和萨作遮迦越王所福分。如是福分甚多。不如如来一毛之福。出过是上无央数

于是目连白佛言。如是为是如来之德。是为如来为大神足为大分为大能。如是世界我悔无所及。何以故。于诸法神通达而自损。目连复白佛言。彼诸一切。闻是如来道神足无极之大变化皆逮得大德。其有闻已。发一心念其中事。欲求解脱。欲学逮满。欲得是道神足无极之变化者。为发阿耨多罗三耶三菩心。世尊。如此辈人当头面礼之。所以者何。如是人得不久。是辈终不复畏堕三恶道。亦不复疑。如是如是议。亦不愿天龙鬼神揵沓和。亦不愿作梵天。如是世尊。目连。于是闻道神足无极变化。起住叉手发声言。南无佛世尊。当为闻是辈人作礼。令是人疾逮所愿。欲发者已发者。皆令是辈人逮得无极如佛无极。令心于是不复转不犹豫不复疑信。尔时诸天龙阅叉揵沓和释梵护持世者。供养于佛。以及于法言皆悉愿乐。是时百千种诸音乐器不鼓而自鸣。天优钵罗波昙拘文芬陀利华。满于忉利天上。闻是法言品所说时。七万二千那术诸天。从本来作功德。皆发阿耨多罗三耶三菩心。皆说是言。我曹于后当来世。当在诸天及世间人前作大师子吼。如今日佛世尊师子之吼

尔时月天子月星天子。前白佛言世尊。是族姓子。族姓女。于是法言品所说。若受若持若念若说。于大众中普广说之。当得几所福祐功德。佛语天子。于是三宝。若族姓子族姓女。不断不忘求逮。以于是法言若自持为他人说。何以故。如天子闻是法。亦不于弟子心有所求。亦不于辟支佛心有所求。心常在阿耨多罗三耶三菩。何以故。持净解脱天子。得利诸根。于是法言。为逮为起道起欢喜心。于解脱而不疑。天子。当持是法言而广说之。不断三宝而得住。于是法言。若持若讽诵若为人说。于天子意云何。不断三宝而常住。若有于是法若持若说。于天子云何。不断于三宝而住。供养于千佛衣被饮食床卧具病瘦医药所当得于百千劫中。宁有能计是人所得功德者不。无有能知者。世尊。佛言。如是天子。于是所说法言。有智黠者。知是福不可计无有限量。若有于是法言若持。于众中说其福。过是无能计者。于是弥勒白佛言。世尊。是法言名为何等。当云何持奉行。佛语弥勒。卿弥勒。是法言名为于忉利天所说持。一名为道神足无极变化持。是属累以相寄。卿弥勒当审谛持。于大会中审谛具足说之。弥勒如是像经。于阎浮利天下甚难得闻。如是弥勒。如我所说。佛说已皆欢喜。月天子月星天子。弥勒菩萨贤者大目揵连。诸天龙阅叉揵陀罗阿须伦阿须伦民。莫不乐闻欢喜。前为佛作礼

佛说道神通足无极变化经卷第四


佛说稻芋经

    No. 709 [Nos. 708, 710-712]

佛说稻芋经

        阙译附东普录

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众千二百五十人俱。及大菩萨摩诃萨众

尔时尊者舍利弗往至弥勒经行处。弥勒舍利弗俱坐石上。尔时尊者舍利弗问弥勒言。今日世尊睹见稻芋而作是说。汝等比丘。见十二因缘。即是见法。即是见佛。尔时世尊作是说已默然而住。弥勒。世尊何故说是修多罗。复以何义说见十二因缘。即是见法。见法即是见佛。皆以何义作如是说。云何是十二因缘。云何见因缘即是见法。云何见法即是见佛

尔时弥勒语舍利弗言。佛世尊常说。见十二因缘即是见法。见法即是见佛。十二因缘者。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。众苦聚集为大苦阴作因。是故佛说十二因缘。云何是法入正道分及涅槃果。如来略说是法。云何是佛。能觉一切法。故名为佛。若以慧眼见真法身。能成菩提所学之法。云何见十二因缘即是见法。见法即是见佛。佛作是说。十二因缘常相续起无生如实见不颠倒。无生无作。非有为无住无为。非心境界寂灭无相。以是故。见十二因缘即是见法。常相续起无生。如实见不颠倒。无生无作。非有为无住无为。非心境界寂灭无相。以是故。见十二因缘。即是见无上道具足法身

尊者舍利弗问弥勒言。云何名十二因缘。弥勒答言。有因有缘是名因缘法。此是佛略说因缘相。以此因能生是果。如来出世因缘生法。如来不出世亦因缘生法。性相常住无诸烦恼。究竟如实非不如实。是真实法离颠倒法。复次十二因缘法从二种生。云何为二。一者因。二者果。因缘生法复有二种。有内因缘。有外因缘。外因缘法从何而生。如似种能生牙。从牙生叶。从叶生节。从节生茎。从茎生穗。从穗生华。从华生实。无种故无牙。乃至无有华实。有种故牙生。乃至有华故果生。而种不作念我能生牙。牙亦不作念我从种生。乃至华亦不作念我能生实。实亦不作念我从华生。而实种能生牙。如是名为外因生法。云何名外缘生法。所谓地水火风空时。地种坚持。水种湿润。火种成熟。风种发起。空种不作障碍。又假于时节气和变。如是六缘具足便生。若六缘不具物则不生。地水火风空时。六缘调和不增减故。物则得生。地亦不言我能持。水亦不言我能润。火亦不言我能成熟。风亦不言我能发起。空亦不言我能不作障碍。时亦不言我能令生。种亦不言我从六缘而得牙。牙亦不言我从数缘生。虽不作念从尔数缘生。而实从众缘和合得生牙。亦不从自生。亦不从他生。亦不从自他合生。亦不从自在天生亦不从时方生。亦不从本性生。亦不从无因生。是名生法次第。如是外缘生法以五事故。当知不断亦非常亦不从此至彼。如牙种少果则众多。相似相续不生异物。云何不断。从种牙根茎次第相续故不断。云何非常。牙茎华果各自别故非常。亦不种灭而后牙生。亦非不灭而牙便生。而因缘法牙起种谢。次第生故非常。种牙名相各异故。不从此至彼。种少果多故当知不一。是名种少果多。如种子不生异果故。名相似相续。以此五种外缘诸法得生

内因缘法从二种生。云何为因。从无明乃至老死。无明灭即行灭。乃至生灭故则老死灭。因无明故有行。乃至因有生故则有老死。无明不言我能生行。行亦不言我从无明生。乃至老病死亦不言我从生生。而实有无明则有行。有生则有老死。是名内因次第生法。云何名内缘生法。所谓六界。地界水界火界风界空界识界。何谓为地。能坚持者名为地界。何谓为水。能润渍者名为水界。何谓为火。能成熟者名为火界。何谓为风。能出入息者名为风界。何谓为空。能无障碍者名为空界。何谓为识。四阴五识亦言为名亦名为识。如是众法和合名为身。有漏心名为识。如是四阴为五情根名为色。如是等六缘名为身。若六缘具足无损减者则便成身。是缘若减身则不成。地亦不念我能坚持。水亦不念我能湿润。火亦不念我能成熟。风亦不念我能出入息。空亦不念我能无障碍。识亦不念我能生长。身亦不念我从数缘生。若无此六缘身亦不生。地亦无我无人无众生无寿命非男非女亦非非男非非女非此非彼。水火风乃至识等亦皆无我无众生无寿命。乃至亦非此非彼

云何名无明。无明者。于六界中生一想。聚想常想不动想不坏想内生乐想众生想寿命想人想我想我所想。生如是种种众多想。是名无明。如是五情中生贪欲嗔恚。想行亦如是。随着一切假名法名为识。四阴为名。色阴为色。是名名色。名色增长生六入。六入增长生触。触增长生受。受增长生爱。爱增长生取。取增长生有。有增长故能生后阴为生。生增长变名为老。受阴败坏故名为死。能生嫉热故名忧悲苦恼。五情违害名为身苦。意不和适名为心苦。如是等众苦聚集常在闇冥名为无明。造集诸业名为行。分别诸法名为识。有所建立名为名色。六根开张名为六入。对缘取尘故名为触。受觉苦乐故名为受。如渴求饮故名为爱。能有所取故名为取。起造诸业故名为有。后阴始起故名为生。住世衰变故名为老。最后败坏故名为死。追感往事言声哀戚名为忧苦。事来逼身是名苦恼。追思相续故名为悲。烦恼缠缚故名为恼。邪见妄解名为无明。以此邪解起于三业故名为行善恶等业能受果报故名为识。从污秽无记业生污秽无记识。不动业生不动识。从识生名色。从名色生六入。从六入生触。从触生受。从受生爱。从爱生取。从取生有。从有生生。从生有老死忧悲苦恼。弥勒语尊者舍利弗。十二因缘各各有果。非常非断。非有为不离有为。非尽法。非离欲法。非灭法。有佛无佛相续不断。如河駃流间无绝时

尔时弥勒重语尊者舍利弗。十二因缘各各有因。各各有缘。非常非断。非有为不离有为。非尽法。非离欲法。非灭法。有佛无佛相续不断。如河駃流间则无绝。能以四缘增长十二缘。何等为四。无明爱业识。识为种体。业为田体。无明爱是烦恼体。能生长识。业为识田。爱为润渍。无明覆植识种子。业不作念我能生识种。爱亦不作念我能润渍。无明亦不作念我能覆植识种。识亦不作念我从尔所因缘。复次业为识田。无明为粪。爱水为润。便生名色等牙。而名色牙亦不从自生。亦不从他生。亦不从自他合生。亦不从自在天生。亦不从时方生。亦不从体生亦不无因缘生。复次欲乐父母精气众缘和合故生色牙。无主无我无造无寿者。犹如虚空如幻。从众因缘和合而生。复次尊者舍利弗。眼识从五因缘生。云何为五。眼色明空作意。识便得生。眼识依眼根以色为境界。缘明以为照虚空不作障碍。作意起发故。生眼识。如是众缘若不和合眼识则不生。而眼识亦不作念我能作体想。色亦不作念我能作境界。明亦不作念我能照了。空亦不作念我能无碍。作意亦不作念我能发起眼识。眼识亦不作念我从数缘生。如此眼识实假。众缘和合而生。如是次第诸根生识。亦如是说

复次舍利弗。无有法从此世至他世。但业果庄严众缘和合便生。又复舍利弗。譬如明镜能现面像。镜面各在异所。而无往来物见同处。又复舍利弗。如月丽天去地四万二千由旬。水流在下月曜于上。玄象虽一影现众水。月体不降水质不升。如是舍利弗。众生不从此世至于后世。不从后世复至于此。然有业果因缘报应。不可损减。复次尊者舍利弗。如火得薪便然薪尽则止。如是业结生识周遍诸趣。能起名色果。无我无主亦无受者。如虚空。如热时炎。如幻如梦无有实法。而其善恶因缘果报随业不亡。又复尊者舍利弗。十二因缘亦从五因缘生。非常非断不来不去因少果多。亦相似相续次第而生。云何非常。一阴灭一阴生。灭非即生生非即灭。故名非常。云何不断。如秤高下此灭彼生。故名不断。如实知见。云何不来不去无有子去而至于牙。亦无牙来而趣子所。以是缘故。无有从此至彼。然实以少种能生多果。云何相似而生。如不善因生不善果。如善因生善果。以是故名相似相续而生。又复舍利弗。如佛所说。能观十二因缘。是名正见。若正观十二因缘者。于过去身中不生有想。于未来身中亦不生无想。众生为从何来去何所至。若沙门婆罗门及世间人。成就诸见我见众生见命见丈夫见吉不吉见。如是十二因缘。如多罗树剪灭其首更不得生。我见则除。若人正见十二因缘。若得如是思心。尊者舍利弗。若有众生能忍是法。此多陀阿伽度阿罗呵三藐三佛陀善逝世间解调御丈夫天人师佛世尊。必为授阿耨多罗三藐三菩提记。尊者舍利弗闻弥勒作是说已。欢喜而去。天龙夜叉乾闼婆阿修罗及诸大众。顶礼弥勒。欢喜奉行佛说稻芋经


佛说德护长者经

    No. 545

佛说德护长者经卷上

        隋天竺三藏那连提耶舍译

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众千二百五十人。大菩萨众五百人俱。各从佛刹而来集会。得无所有无作行神通。得幻生神通。得清净离尘信心成就。得无障碍闻生。得深入一切相如幻。得如影身遍现一切佛刹。得如响声能持法轮。得如梦智随顺见一切世界。得能随顺阿僧祇如来行处。得无障无碍大智境界

其名曰清净辩才菩萨。放光焰菩萨。端严藏菩萨。无量光菩萨。杂藏菩萨。不定住佛刹菩萨。说佛法丈夫月菩萨。陀罗尼善根成住菩萨。毗卢遮那差别藏菩萨。如是等五百大菩萨俱。一一菩萨。各有阿僧祇菩萨以为眷属。尔时天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。比丘比丘尼优婆塞优婆夷。国王大臣沙门婆罗门。刹利长者居士及诸小王。种种外道。信心清净。尊重恭敬赞叹如来。多以上妙衣服饮食卧具汤药种种供养。供养如来。佛以慈心为欲利益诸众生故。受彼供养非为贪故。何以故。一切福田中佛田最胜。如来具足无量定。无量慧。无量解脱。无量解脱知见。如虚空无边法界无边。五分法身亦复无边。能舍施者增大功德。成就不可思议果报。又是一切世间导师。善能教导一切众生令不舍佛法。乐福德者为作无尽福田。于一切众生行平等慈。于一切智得解脱自在。时诸外道遮罗迦。波利婆阇迦等一切外道。远离信心但生贪欲。又以不得恭敬供养尊重赞叹衣服饮食卧具汤药而生嫉妒。见佛相好端严多有徒众眷属。诸外道等无如是事而生嫉妒。见佛具四辩才能说诸法。自无辩才而生嫉妒。见佛大得利养。自不得故诽谤于佛作大恶名。见佛威德尊重。见者悚惧如大国王。自无威德故生诽谤。见佛具足内外功德。三十二相一切种智。众生爱乐。自无此事而生诽谤。见佛具足神通智慧。隐显自在变现无碍。一身为多多身为一。身力自在乃至梵世。善知过去未来一切业报差别之相。善知现在众生心行如应说法。贪欲多者为说不净观法。嗔恚多者为说慈悲观法。愚痴多者为说因缘观法。众生信受远离贪欲嗔恚愚痴。诸外道等无如是事。而生嫉妒为作恶名。见佛具足四无所畏。大师子吼决定能说。若如是者得沙门果。不如是者无沙门果。诸外道等无实知见。颠倒谬说故生诽谤。见佛具足大慈大悲怜愍一切。于诸众生而得自在。如观掌中庵摩勒果。自无此事而生诽谤。见佛多得供养尊重赞叹天人钦仰。不得如是具足供养。心生嫉妒为作恶名。见佛如是种种功德具不可坏。自不具故而生嫉妒诽谤如来。彼诸外道。过去福尽新福不生。入于恶见旷野稠林。譬如有人入大旷野。迷失正道不能得出。彼诸外道亦复如是。离于智慧于诸恶见不能得出。不信正法不供养僧。失于善根生种种恶见。有所言说悉皆颠倒。不信业报不知十二因缘等法。行恶见稠林非真实道。于诸法中如生盲人。时诸外道六师眷属。及裸形外道等悉皆聚集。诣论议堂而共议言。瞿昙沙门昔未出时。未见大沙门时。此阎浮提一切人民悉归属我。信伏我法。随我所欲。瞿昙出世。一切人民舍我等法。不复供给衣服饮食卧具汤药。亦不恭敬尊重赞叹。不受我语。我等今者当设何计。复更议言。瞿昙沙门。虽复具足福德智慧。能化央伽摩陀罗国。一切人民悉令归化。而不能化彼之德护长者一人。此王舍城。惟彼长者不信瞿昙。独受我法供养恭敬尊重赞叹。布施我等衣服饮食。惟属我等尼揵陀若提子。末伽利拘舍梨子。般浮多迦旃延。删阇耶毗罗坻子。阿支罗翅舍甘婆罗。富兰那迦叶等大众之师。诸余沙门及婆罗门。初亦未曾得至彼门。我等徒众若至其家。彼人能以诚心种种供养。彼人今日信根成就。于我等所生胜信心深彻骨髓。王舍城中国王大臣。刹利婆罗门及诸余人。无有如是坚固信心。沙门瞿昙及一切婆罗门诸余外道等。亦无能坏彼人信心。我等于彼而得自在。闻有所说必定信受。今者宜应往至其家。具以上事向其人说。复当教彼于七重门下各作火坑。其一一坑深没七人。满中安置佉他罗炭无烟之火。以铜为梁草土覆上。瞿昙将至。当以水洒并散诸华。瞿昙若踏必当陷死。若不死者。复以毒药置饮食中与之令食。作是事已遣请瞿昙就家饭食。瞿昙若是一切智者。必不受请不为火毒之所烧害。若其非者受请无疑。时诸外道作是计已。即共发往至王舍城。到于德护大长者家。至其家已便一向立。是时长者见诸外道。心大欢喜踊跃无量就彼作礼。既顶礼已广为处处。安置床铺劝令就坐。既就坐已合掌曲躬作如是言。我常思念今忽逢遇。善哉善哉。天念我故令诸导师诸大德等悉来集会为作福田。尔时长者见诸外道悉皆坐已。次第行水安置器皿。设种种食食已洗竟。是时长者于大外道床前。别安小座而坐。时诸外道卢竭多蜜多尼延咃等一切外道。既见长者安坐已定。作如是言。大长者。我等本于大议论堂聚集之时。先有如是筹量。瞿昙沙门未出之时。未见大沙门时。一切阎浮提十六大国央伽摩陀罗等悉皆属我。随意自在信受我语。恭敬供养尊重赞叹。供给衣食卧具汤药。自彼出来惟信彼法。弃舍我等不复尊重恭敬供养。亦不供给衣食卧具汤药。十六大国央伽摩陀罗等。悉为瞿昙之所统领。惟汝一人是我檀越信受我语。瞿昙沙门种种方便。不能破坏令汝信受。央伽摩陀罗等十六大国。无有及汝信我语者。一切国人及大王等亦信汝语。是故我等生如是计共汝评章。汝今信我我亦信汝。所有言论义无有二莫令漏泄使外人知。大长者。汝今决定大须信用我等计挍。可于汝家七重门下。一一门内作大火坑各没七人。着佉陀罗炭无烟之火。以铜为梁遍敷[竺-二+處]篨薄以土覆。瞿昙将至以水洒上复散好华。瞿昙若过必当陷死。若烧不死复以毒药安着食中。作是事已遣请瞿昙。彼若定是一切智者必不受请。非一切智受请无疑。尔时长者闻六师教心大欢喜。叹言善哉。此计甚善快适我愿。我今堪能种种备办。惟愿大师莫为忧虑。六师答言。若如是者今可速办长者答言。善哉如教事事顺从。便当造作火坑毒食躬请瞿昙。我若不杀亦更无有能杀之者。此计甚要必果所愿。说此语已欢喜踊跃。覆自思惟我师所说甚善甚善。时诸外道教长者已各自庆幸。昔来所说今悉不违。作是赞言。我今教其舍离善事造作恶业。舍离无贪无嗔无痴。安置不忍贪嗔痴道。非理之教尚能随顺。善哉长者大信我语。发大喜声或歌或啸。各各辞退还其本处。尔时德护长者子名曰月光。年至十六形貌端正人相第一。身有二十八种大丈夫相。众生见者观无厌足。已曾供养过去诸佛殖诸德本。于多佛所听受正法。于八亿佛所净修梵行。聪慧利根勇猛坚固。具足辩才质直无伪。心口相应得念佛三昧。于诸佛所常得喜心。于正法中常得欢喜悦乐之心。心无怯弱得四辩才得不坏信。于诸法中心无疑网。能以上妙衣服饮食卧具汤药供养众僧。善能说法得陀罗尼。得不退转地阿耨多罗三藐三菩提。于菩提中得不可思议身心。于一切众生中得大慈不坏心。常勤教化一切众生。不退一切智愿。能坏一切魔怨摧伏一切外道。得智慧方便得深智慧。能舍如云。持戒清净。忍辱如地。精进坚固。于一切法中心不动乱。能行智慧如实而见一切诸法。一切法中得法津泽。以最胜信心供养诸佛。于佛种种功德悉生信乐悲心清净。于一切众生生怜愍心。信念坚固如金刚山不可倾动。得不忘念差别智慧。能受一切法彻到彼岸。智慧了知一切佛法方便之行。福德善力不可沮坏。住四辩才心无怯弱。于父母所知恩报恩。于一切佛法得最胜心。常为众生说佛功德。若见若闻诸佛神通心无厌足。善能摄取诸智慧者。能说一切诸佛境界。一切佛法悉能讲说。是长者子成就如是等功德。如是等无量法器。广说无量叹不可尽。是月光童子。知父长者信受外道欲害如来。即至母所白其母言。母今知不。父心颠倒受外道教失于本心。于外道所得欢喜心深生敬信。是诸外道自造三恶道业。亦令父作三恶道业。母今莫受父邪见语诽谤于佛。何以故。佛出世难久远劫来不可值遇。或一劫十劫千劫万劫。乃至不可说劫。诸佛名字尚不可闻何况得见。佛能清净诸众生心。具足神通智慧了达无有障碍。善能教化一切众生所行无碍。于三解脱佛最第一。于一念顷知一切法。如来善住一切法中。如来能知一切众生所生之处。佛真实语为诸众生而作证明。能除众生身心苦恼种种怨敌。于诸境界无所取着。母当信佛莫信六师虚诳之语。我敬母故为报母恩奉上此语。何以故。母怀我身满足十月受大苦恼。生我身时半死半生绝而复苏。我念此恩未曾遗忘。设于无量百千万劫亦不可报。我心常愿共母往见百万亿那由他佛。常愿共母听诸佛法。常愿共母往见一切菩萨行处。常愿共母往见一切菩萨净佛法处。常愿共母往见一切不坏清净信处。常愿共母往见一切作佛事处。常愿共母往见一切香华衣服卧具汤药供养佛法僧处。常愿共母往见一切圣人行法之处。常愿共母往见一切信根成就。无有颠倒至涅槃处

尔时其母月云。告月光言。善哉善哉。得闻汝说。汝实大悲。于父母所深生怜愍。开导善事如大导师。汝亦如是所说法者今悉信受。我今为自清净心故。亦愿安隐诸众生故。发菩提心广心上心无量心欢喜心生清净心。于诸法中得无疑心不颠倒心具足信心。众僧之中具有解脱解脱知见。能破一切烦恼诸结。应当于彼生清净信供养恭敬。佛德无量佛行无量佛境界无量。所说妙法亦复无量。利益众生亦复无量。如汝所说佛德无边。我今无智说佛功德。月光。我常信佛不生恶心。汝不能具尽真是我大善知识。能为我说佛无量德。于无量千万阿僧祇劫。说佛功德无有厌足不得边际。尔时月云为子说偈

  无量百千万亿劫　　佛名难闻况得见
  汝能于佛生胜信　　如是信心实难得
  我今信佛无量德　　不可得闻况眼见
  汝今来生在我家　　我今见汝如导师
  能使我心清净信　　不可思议诸佛法
  汝今犹如我父母　　亦如诸佛生我家
  譬如父母将子去　　得至诸佛无漏处
  我等无量千万劫　　不能报汝今日恩
  汝真是我善知识　　世世常为清净导
  令我安住最胜念　　决定信佛无有疑
  永得出于三恶趣　　常得安住人天道
  非惟是我善知识　　亦是众生善知识
  尚欲度脱他众生　　况复眷属亲父母
  能令合家诸眷属　　破坏一切诸怨结
  亦复远离三恶趣　　超出住于天人道
  佛出世间甚为难　　经于无量百千劫
  汝今能来生我家　　希有难值亦如是
  汝今真是大丈夫　　善能巧说微妙法
  汝今真是诸佛子　　于佛常生欢喜信
  谁今与我难得儿　　今乃来生在我家
  我子月光甚希有　　常能赞叹一切佛

尔时德护长者家内眷属一千婇女。闻月云夫人及月光童子说是偈已。皆大欢喜踊跃无量。同声赞言。善哉善哉。不可思议不可思议。月光福伽罗数生我家。此丈夫者尚难得闻。何况得见。是人随所生处。或阎浮提城邑聚落。若有见闻亲近供养。共坐共语永离恶道。何况生在家中而不利益。父母亲属令离恶道

尔时德护长者送外道已。便出王舍城诣耆阇崛山。躬往请佛。遥见世尊相好庄严不可思议六根寂静。得最胜陀摩他奢摩他。得最胜第一陀摩他奢摩他。守护诸根如调大龙。如大池水清净不浊。放无量百千亿那由他光焰。威德严仪难可睹觐见者欢喜。德护长者既至佛所。种种软语共相劳问。白佛言。愿佛及僧。怜愍受我明日供养。佛知长者受化时至默然受请。长者知已心生欢喜。稽首辞退下耆阇崛山。入王舍城至六师家。到已作如是言。沙门瞿昙及诸徒众已受我请。以是得知非一切智。诸外道等闻是语已。心生欢喜倍增踊跃。庆赖无量喜满身心。语长者言。今可还家速办所设火坑毒食。如上所说令遂所志

尔时长者即便还家。敕语家人营办斯事。时子月光。见父兴心造作恶事。心生忧悴而谏父言。此事不吉莫于佛所起不善业。何以故。诸佛难坏故。一切天人龙及鬼神。若于如来起恶逆者无能破坏。一切刀剑不能伤毁。一切猛火不能烧害。设地狱火烧之不暖况人火耶。如劫尽时七日并现。三千大千世界满中盛火。烧至梵天及铁围山。尚不能烧佛之一衣。况欲以此微小火坑烧害如来。无有是处。设霹雳火如须弥山。尚不能至如来行迹四威仪处。况此火坑而能烧害。一切世间所有大毒。如大海水佛能消灭。况以小毒杂置食中而能害佛。设使毒药高如雪山。佛眼视之自然消灭。况此毒食能有所害。愿父莫如小人造诸恶业作远佛因缘。一切有福德者方得亲近。愿父莫于佛所而生恶逆嗔害之心。一切众生心性清净。莫起烦恼染浊污心。莫与外道共为一手。勿以小芥比须弥山。牛迹之水同于大海。莫以蜘蛛小网欲遍虚空。莫以一尘之力欲动须弥。莫以斫迦罗山内一毛孔。莫以一沙欲令充满三千世界。何以故。佛智无量无障碍故。出过一切世间碍法故。佛具十力余力不能坏故。如来那罗延力。一切众生作恶不能加害故如来坚固不可沮坏。如来常住住真实际。如来无取一切法中离于取着。如来于三世中无所依止。如来寂灭无有处所。如来最寂离诸恼热。如来寂灭于一切众得最第一。如来无比过诸譬喻。如来三业随智慧行。如来清净离尘法行。如来勇健破坏一切诸魔外道。如来辩才具无尽力。如来善调能令未调得调伏故。如来善寂能令未寂得寂灭故。如来智水能洒众生诸烦恼故。能令多烦恼者无烦恼故。如来于一切众生中尊得一切智冠故。如来大云能雨一切法雨不可尽故。如来能满足一切众生心行故。如来得不诳智。能知众生心行如应说法故。如来能开一切众生过去善根行故。如来能灭一切众生烦恼流故。见如来者观无厌足故。佛于一切菩萨中无等等故。如来能尽一切烦恼故。如来能断一切烦恼瀑河故。如来于一切众生大悲满足能覆护故。众生见者皆得安隐不空故。如来善逝犹师子王。于诸世间无所畏故。如来于一切世间最上。三世众生不能染故。一切世间势力自在不能坏故。如来上上穷尽一切法界法故。如来寂灭离戏论故。如来一切知一切见。能知过去未来现在法故。未得菩提。先已预知成菩提时。王舍城中有大长者名为德护。以浊恶心欲作火坑毒食杀害如来。亦知因此恶心因缘。能得最上清净胜信舍离浊心。如来于作恶作善众生。皆能教化令作无上菩提因缘。愿父放舍一切恶念毒害罪心。何以故。譬如有人供养大地。复有一人烧斫大地。于此二人等与利益无所分别。佛亦如是。于供养者于打骂者。以本愿故皆悉为作得道因缘。是故如来。为一切众生种善根本。于一切福田最上第一。若有供养佛者。于三界中必定能出。佛是一切众生大善知识。父今于佛生恶心者。为失自身为烧自身。趣向地狱受诸苦恼。然如来身不可毁坏。一切外道及诸众生亦不能坏。何以故。如来已离三毒猛火。于无明中已得解脱。得三世智能知众生过去现在。离一切罪得一切福。成就一切诸善根本。是故父应深生信乐。莫于如来起怨家想。莫受外道愚痴所说远离于佛。莫于佛所生恶逆心。莫生怨心。莫于如来善知识所生恶害心。堕落三涂后当悔恨。尔时德护长者告月光言。若如汝所说佛有无量功德。是一切智知他心者。我以恶心作火坑毒食。何故不知而受我请

尔时月光白其父言。佛实一切知实一切见。悉见悉知父所有恶心。亦知因此恶心而得调伏。佛智慧最大智慧自在觉知具足。为欲除灭父恶心故。今受父请非为食故。父当念佛大庄严念佛大神通。佛大慈悲为欲令父恶心浊心得解脱故而来至此。欲令恶攀缘者作善根故。为欲令身作解脱故。得调伏故。欲令闇心作明心故。欲令黑心作白心故。欲令浊心作净心故。以父信受外道恶浊令大清净故。一切三界苦聚欲除去故。父若不信佛具种种大神变者明当自知。尔时德护长者过此夜已至明清旦遣使迎佛。告言。汝如我语白大沙门。供具已办当知是时。尔时使人出王舍城诣耆阇崛山。到佛所已白佛言。世尊。德护长者供食已办愿佛知时。尔时佛告诸比丘着衣持钵。往于德护大长者家受彼请食。时诸比丘白佛言。唯然受教。便各还房着衣持钵。至如来所各一面立。尔时如来如大师子王奋迅。从其四牙一一牙放百千亿种种色光。一一齿亦复如是。两手两臂两肩及顶肉髻。各放百千亿种种色光。眉间白毫复放百千万那由他种种色光。举身亦放无量百千万那由他种种色光。于胸德字复放无量千万那由他种种色光。从其脐轮复放光明名破一切闇。百千万那由他种种光明而为眷属。复以神力出无量光。其光遍照东方尽一切佛刹。如是南西北方四维上下尽一切佛刹。光明遍照亦复如是

尔时东方过三千大千世界微尘等佛国。有世界名阎浮幢光。彼土有佛名曰仁自在王多他阿伽度阿罗呵三藐三佛陀现在说法。彼有菩萨名须弥光。与阿僧祇眷属围绕。复有一万菩萨同号须弥光。皆共发引向娑婆世界。所经诸国兴大宝云。雨种种宝。到耆阇崛山。至于佛所头面礼佛。为见佛故。为恭敬供养故。为见月光童子故。为怜愍王舍城中德护长者故来至佛所

尔时南方过三千大千世界微尘等佛刹。有佛国名火味。佛号善住宝幢王多陀阿伽度阿罗诃三藐三佛陀。现在说法。彼佛刹中有菩萨名普德光焰王。复有一万菩萨。同号普德光焰王。一一菩萨各与阿僧祇眷属恭敬围绕。皆共发引向娑婆世界。所经诸国放无量阿僧祇光明充满世界。为见佛故。为恭敬供养故。为见月光童子故。为怜愍德护长者故来至佛所。尔时西方过三千大千世界微尘等佛刹。有佛世界。名一切庄严。佛号一切普光多陀阿伽度阿罗诃三藐三佛陀。今现在说法。彼佛刹中有菩萨名普焰云王。复有一万菩萨同号普焰云王。一一菩萨各与阿僧祇菩萨以为眷属。恭敬围绕向娑婆世界。所经诸国兴杂宝华云。雨杂宝华。出过一切天人供养。为见佛故。为恭敬供养故。为见月光童子故。为怜愍德护长者故。来至佛所(尸利崛多者隋言德护)

佛说德护长者经卷上佛说德护长者经卷下

        隋天竺三藏那连提耶舍译

尔时北方过三千大千世界微尘等佛刹。有佛国土名曰炎光。佛号德藏峰奋迅王如来多陀阿伽度阿罗诃三藐三佛陀。现在说法。彼佛世界有菩萨名卢舍那放大光明。复有一万菩萨。同号卢舍那放大光明。一一菩萨各与阿僧祇菩萨以为眷属恭敬围绕向娑婆世界。所经诸国放诸沉水清净香炎。其香普熏各过十方诸佛世界十阿僧祇倍遍满世界。出过一切天人庄严。为见佛故。为供养故。为见月光童子故。为愍德护长者故来至佛所(德护梵云尸利崛多)。尔时东北方过三千大千世界微尘等佛刹。有佛世界名一切宝庄严。佛号法自在王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。现在说法。彼有菩萨名离障碍神通。复有一万菩萨同号离障碍。各与阿僧祇菩萨以为眷属。恭敬围绕向娑婆世界。所经诸国以十千万劫清净善根所成就声。赞叹一切诸佛。兴大法云雨众法雨至于佛所。为见佛故。为供养故。为见月光童子故。为愍德护长者故来至佛所

尔时东南方过三千大千世界微尘等国土。有世界名普庄严。彼刹有佛号离障碍光炎如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。现在说法。彼有菩萨名普光清净月。复有一万菩萨同号普光清净月。一一菩萨各与百千万菩萨以为眷属。前后围绕向娑婆世界。所经诸国放杂宝光明庄严色。以金宝铃网弥覆充满一切虚空。其声微妙如百佛声。为见佛故。为供养故。为见月光童子故。为愍德护长者故来至佛所。尔时西南方过三千大千世界微尘等国土。有世界名金网覆。彼世界有佛。号胜行王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。彼有菩萨名软声自在。复有一万菩萨同号软声自在。各与阿僧祇菩萨以为眷属。往娑婆世界。所经诸国兴宝伞盖云。充满虚空。一一菩萨各将伞盖。一一宝盖以真珠为垂露。清净分明如佛光明。为见佛故。为供养故。为见月光童子故。为愍德护长者故。来至佛所。尔时西北方过三千大千世界微尘等佛刹。有世界名曰普入。佛号无碍月如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。彼有菩萨名无量音乐声。复有一万菩萨同号无量音乐声。与无量阿僧祇菩萨以为眷属。恭敬围绕向娑婆世界。所经诸国一一菩萨。于一一毛孔出阿僧祇音乐之声。歌颂一切佛法。为见佛故。为供养故。为见月光童子故。为愍德护长者故。来至佛所

尔时下方过三千大千世界微尘等佛刹。有佛世界名宝莲华善住。佛号一切众生世灯如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼有菩萨名普云德。复有一万菩萨同号普云德。一一菩萨各与阿僧祇菩萨以为眷属。恭敬围绕向娑婆世界。所经诸国兴宝莲华云。雨种种无边色华。庄严阿僧祇佛刹。为见佛故。为供养故。为见月光童子故。为愍德护长者故来至佛所。尔时上方过三千大千世界微尘等佛刹。有佛世界名杂华幢。彼佛号曰杂宝奋迅王如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。今现在说法。彼有菩萨名见者不空。复有一万菩萨皆同一号。一一菩萨各与阿僧祇菩萨以为眷属。恭敬围绕向娑婆世界。所经诸国兴栴檀味香云。雨杂味香。充满阿僧祇佛刹。为见佛故。为供养故。为见月光童子故。为愍德护长者故。来至佛所

如是一切方及非方无量胜身菩萨。各从国土佛刹中来。现大威德光明色像而来集会。从耆阇崛山上至有顶。及三千大千世界悉皆照曜。是诸菩萨庄严成就菩萨行。清净光明照曜心无所住。于不可思议阿僧祇佛刹。能过于诸佛所净修梵行。增长愿智方便智。不可思议三昧常不退转。若有见闻此诸菩萨及亲近者皆悉不空

尔时世尊见十方诸大菩萨与阿僧祇菩萨眷属各从佛刹来集此已。即解加趺坐。为欲往到德护大长者家故。应时三千大千世界六种十八相动。动遍动等遍动。踊遍踊等遍踊。吼遍吼等遍吼。觉遍觉等遍觉。震遍震等遍震。起遍起等遍起。是时有阿僧祇莲华。从地踊出。阿僧祇香。阿僧祇光。阿僧祇炎。阿僧祇宝华鬘。阿僧祇摩尼杂宝华茎。阿僧祇摩尼杂宝华台。阿僧祇毗卢遮那藏。阿僧祇德色不可尽

尔时世尊蹋宝华上整理衣服。以神通力化作百千万亿莲华叶。从地踊出种种杂色。青琉璃德藏为茎。甘露味宝为须。正摩尼藏宝为华台。龙坚栴檀那香光出百千炎。如是莲华次第行列。从耆阇崛山至于德护大长者家。宝华遍覆悉皆充满。复以神力一切身分普放光明。遍照东方一切佛刹。如是南西北方四维上下一切佛刹。光明照曜亦复如是。此王舍城一切宫殿一切屋舍城壁内外街陌垣墙。乃至床下悉皆照曜。一切人民所未曾见。尔时如来与大菩萨众大阿罗汉等。前后围绕恭敬侍立。遍满虚空蹋宝莲华。从耆阇崛山下入王舍城。至德护大长者家。当佛下时。阿耨达多龙王与无量种色龙子其数五百及无量百千龙王。放无量香云雨无量香雨。侍从如来

尔时四天大王侍引世尊。复雨无量宝云雨洒散道间。于路两边皆作七宝栏楯。种种庄严悉皆充满。如是等一切天王。一切龙王。一切夜叉王。一切揵闼婆王。阿修罗王。迦楼罗王。摩睺罗伽王。紧那罗王。梵天大梵天不坏梵天。无量千万那由他眷属。恭敬围绕歌颂赞叹。实赞叹。最实赞叹。不颠倒赞叹。无二赞叹。胜赞叹。最胜赞叹。欢喜赞叹。如佛法赞叹。作如是等赞叹遍满虚空。复以如是等恭敬供养。胜供养。最胜供养。阿僧祇供养。出阿僧祇供养。飞腾虚空随侍如来。入王舍城。至长者门。四大天王阿修罗王夜叉王等。亦从王舍大城步路立侍。至尸利崛多大长者门。尔时月光童子见佛光明及大神通。乃至大地十八相动。生大欢喜心意怡悦。诸根快乐遍身满足。生欢喜已登七重楼上。合十指掌而向父所。即说偈言

  佛舍加趺坐　　引发欲来时
  无畏如师子　　今来已至此
  此来那罗延　　难坏两足尊
  破魔及眷属　　起彼菩提树
  此来如金刚　　一切不能坏
  而能坏一切　　邪见诸外道
  譬如大力士　　能坏诸怨敌
  贡高诸烦恼　　慈悲能散灭
  此来难破坏　　摧彼自超胜
  智慧大导师　　能救济一切
  此来不可杀　　诸火所不烧
  如来已离死　　众毒不能害
  此来大丈夫　　能教大导师
  三界最胜身　　一切无能及
  圆肩聪睿者　　及慈悲圣众
  一切众生类　　最胜无能及
  众色相具足　　八十种庄严
  身光悉照曜　　调伏净无漏
  此乘虚空来　　离罪无取着
  不住杂觉观　　常住真实道
  此从无尽来　　能广说诸法
  不思议法轮　　种种差别知
  此来一切智　　能觉一切法
  十力大悲等　　安住四辩才
  此来见不空　　能与众安隐
  无量亿万劫　　难闻况得见
  此来调伏龙　　丈夫人师子
  愍众不思议　　行成无量劫
  此来自在者　　众生无能遮
  大慈悲导师　　能满求者愿
  此来善知识　　住法界最胜
  无边如虚空　　一念觉诸法
  此来离二者　　到诸法彼岸
  于无相地中　　最上胜觉来
  此来能净施　　财及法二种
  宿世舍身命　　怜愍众生故
  此来导师者　　与一切安隐
  无量劫修行　　为求菩提故
  平等大智心　　法中常胜修
  怨亲等无二　　心净无分别
  如师子奋迅　　神力度众生
  于诸无量刹　　光明悉遍照
  积劫常赞叹　　如来之功德
  一毛不可尽　　何况一切身

尔时月光童子妹月上。形容端正。闻月光童子说偈赞佛身心欢喜。又见如来光明晃曜。大神通力大地震动心欢喜故。合十指掌向其父前。复说偈言

  如兄月光赞　　如来诸功德
  一切世间无　　愿父当信受
  莫信外道语　　心常怀嗔妒
  于十力生恶　　恶觉失善心
  不知佛法故　　闻说不信受
  为恶失善道　　对佛不能说
  受彼邪见言　　当堕诸恶道
  嫉妒痴浊故　　则失于善心
  恶见三毒缘　　如是贪增长
  颠倒痴心故　　远离诸佛法
  无量千万劫　　难得闻佛名
  父应于佛所　　深生清净信
  若能称佛名　　此人尚难见
  何况见佛身　　是故父应信
  如所说导师　　现无量神通
  放无量光炎　　此人今已来
  如上之所说　　那由他刹动
  无量诸佛子　　愍众故来此
  彼彼十方来　　难坏如师子
  诸天人龙等　　欢喜雨众花

尔时长者女德生。见地大动及大神通大光明炎杂色分明。见已欢喜踊跃无量。以其衣裓盛满杂华。疾至父所合十指掌。以大信心大欢喜心。向父说偈

  父今信外道　　此心最大恶
  堕在邪恶中　　常不信佛法
  推人入恶趣　　遮闭人善道
  此常不调伏　　失佛功德利
  佛如优昙花　　设行百千劫
  常难得闻名　　何况能得见
  父今信外道　　起二心请佛
  今已得闻见　　不应起恶念
  亦莫生浊心　　及以杀害想
  常生清净信　　于佛生欢喜
  佛神力难思　　普覆十方界
  佛子月形面　　龙神夜叉等
  一切咸恭敬　　信心礼敬佛
  以曼陀罗华　　散佛及大众
  佛弟子心喜　　邪众心迷浊
  佛日照外道　　如日蔽萤光
  此胜愿大人　　礼拜难见佛
  见无量眷属　　围绕释迦尊
  胜智清净智　　外道不能坏
  盖云栴檀云　　种种杂庄严

尔时月光弟智坚童子。已曾过去供养诸佛种诸善根。于诸佛所净修梵行。时彼童子梦中见佛大神通力。从耆阇崛山下欲入王舍城。大地震动即便觉寤。着衣整服疾至门下。生大欢喜还诣父所。而说偈言

  我梦中见佛　　于此一念间
  从于耆阇崛　　最大山岗下
  不思议大力　　菩萨众围绕
  各从诸刹来　　法界差别知
  一一菩萨众　　无量众围绕
  各各地中住　　彼名不可闻
  大智大菩萨　　名曰离垢光
  为诸佛导师　　持七宝伞盖
  彼出妙音声　　闻者皆爱乐
  亦复能遍覆　　十方无量刹
  我见彼世尊　　能破诸斗诤
  从梦觉寤已　　即便至父所
  父今当信佛　　弃舍痴外道
  彼令人心恶　　应当速远离
  设有世界火　　充满十方界
  不能烧佛衣　　何况如来身
  设有诸毒药　　充满百千刹
  不害佛弟子　　何况于如来
  佛于一切毒　　远离中第一
  不念毒自消　　何况念不灭
  一切智善调　　今来王舍城
  不思议菩萨　　俱到于彼岸
  于一切三世　　或闻或见形
  悉能施安隐　　是故父当信
  此来见不空　　父应当供养
  佛放无量光　　能除此邪闇
  此光照天人　　修罗龙夜叉
  及其诸眷属　　见者皆不空
  一切热地狱　　悉皆得清凉
  地狱中众生　　除热心欢喜
  梵天及天主　　身皆放香云
  犹如杂彩盖　　庄严在虚空
  此来心无碍　　如龙胜导师
  能兴舍施云　　雨种种杂宝
  微妙宝璎珞　　旃檀及伞盖
  遍覆于虚空　　及十方世界
  此来能分别　　神通到彼岸
  种种差别知　　能赞叹诸佛
  无量僧祇天　　及此城胜人
  闻佛大名号　　悉来至佛所
  象出欢喜声　　师子亦如是
  放荡诸牛王　　出声亦复然
  畜生闻佛名　　皆发欢喜心
  父是人为胜　　云何而不信
  千万那由他　　无量诸音乐
  及宝璎珞器　　不鼓而自鸣
  无量种畜生　　于无等十方
  舍离恶毒心　　生欢喜净信
  能坏斗诤魔　　调伏大寂灭
  忍辱到彼岸　　慈心广怜愍
  悲心到彼岸　　能救诸众生
  舍种种布施　　能发菩提心
  父当信释迦　　超过世间岸
  能放十方光　　众生离八难
  具彼多神力　　三世不可量
  游行如师子　　智慧到彼岸
  智住如须弥　　常放于宝光
  佛子诸众等　　前后而围绕
  示现诸神通　　来至王舍城
  种种杂妙宝　　装挍而庄严
  天龙夜叉众　　修罗百千亿
  合掌恭敬礼　　释迦牟尼尊
  调伏今在门　　足蹈门阃时
  盲者得见色　　聋者得闻声
  苦者得安乐　　病者得除愈
  妊身产苦者　　安隐得免难
  宝藏悉皆得　　贫者获富饶
  清净佛神通　　一切皆欢喜
  城中一切地　　众宝悉遍满
  可爱宝庄严　　其色甚威曜
  调伏巷中行　　父当起迎接
  庑廊重楼阁　　男女皆充满
  以衣盛香花　　及诸宝璎珞
  清净欢喜心　　以散释迦牟
  国王名先尼　　从六万婇女
  各执诸杂宝　　供养于如来
  衣盛宝璎珞　　及诸妙香花
  亦起欢喜心　　以散于佛上
  智慧人满巷　　信乐求功德
  踊跃心欢喜　　顶礼佛世尊
  佛从巷而来　　百千亿众生
  合掌心欢喜　　一切皆礼拜
  下遍一切世　　上至于有顶
  十方一切刹　　天人杂众满
  种种杂类人　　供养于如来
  一切皆欢喜　　清净心礼佛
  外道胜论师　　顶礼世尊足
  以上欢喜心　　最胜净信心
  合掌赞叹佛　　善哉佛出世
  大智一切智　　已到于彼岸
  父应生欢喜　　共往如来所
  取上宝衣服　　供养于如来
  除于疑惑心　　嫉妒诸恶见
  信佛世中胜　　礼拜牟尼王
  父今应当知　　调伏众生者
  能覆护众生　　一切罪恶心
  皆悉能除灭　　如是大导师
  以怜愍父故　　今来在门外
  火坑当自灭　　出种种莲花
  优钵拘物头　　波头分陀利
  诸天及世人　　龙神等眷属
  散种种花香　　充满遍于地
  此导师智幢　　威光难睹见
  一切智知见　　达到于彼岸
  知三世心业　　上中下差别
  父当欢喜信　　难见难闻者
  无量僧祇劫　　为众修苦行
  具足诸功德　　永除一切罪
  欲修福业者　　此福田最胜
  怜愍众生故　　应现处于世
  不为求衣食　　及显己智慧
  但以大慈悲　　怜愍父故来
  知父生恶心　　为彼恶见覆
  欲令得解脱　　舍离杀害业
  佛于诸众生　　一切皆平等
  无有简择念　　亦无怨亲想
  如来真智慧　　永离诸谄曲
  父应生信心　　尊重而礼敬
  佛宝世中胜　　悉吐诸恶见
  父能欢喜信　　疑网毕竟除
  以信如来故　　不堕诸恶道
  佛能净五根　　应当速礼敬
  三世大导师　　佛子众围绕
  种种地中住　　无障碍智行
  此一切智子　　绕如来照曜
  如日蔽众星　　是故应敬礼
  父见佛神力　　火坑水盈满
  种种莲华出　　心生大欢喜
  见是诸变已　　顾看子月光
  汝是我导师　　怜愍我来生
  我信外道故　　心常怀毒害
  我今敬信佛　　悉舍诸恶见
  此儿我知识　　难可得值遇
  劝我敬信佛　　转生大欢喜
  尔时天帝释　　及大自在天
  此二大天王　　为佛庄严座
  八十千亿天　　以衣覆宝座
  令一切智坐　　显发而照曜
  梵天王礼已　　为佛持宝盖
  阎浮檀真金　　杂宝而庄严
  及余诸天等　　合掌礼于佛
  散百种杂华　　及赤旃檀末
  长者见佛已　　其心大欢喜
  八千诸女人　　得清净诸慧
  有五百童子　　及五百童女
  见佛神通力　　皆发菩提心
  无量百千亿　　那由他天子
  见佛神通力　　得清净智慧
  长者怀忧恼　　心生大惭愧
  即便礼佛足　　向佛而忏悔
  此食杂毒药　　今欲更办供
  惟愿佛世尊　　留神小停住
  如来妙梵声　　告德护长者
  如来一切智　　能却一切毒
  贪嗔痴三种　　及世间毒药
  如来真实说　　我已久远离
  贪嗔痴三种　　及世间毒药
  离毒清净法　　实语皆远离
  贪嗔痴三种　　及世间毒药
  离毒清净僧　　实语皆远离

佛说此语时。无量诸天出大声言。清净大智。已离众毒火坑皆灭。家内清净如本无异。皆是法王威神力故。时德护长者即于佛所生大信心。以上妙衣价直百千万亿覆佛身上。覆已白佛言。世尊。我本愚痴受六师教。今于佛前至心忏悔。由父昔世敬信外道。我顺父故作如是罪。今因月光令我信佛。我今殷勤至心忏悔。更不作罪。愿佛救我

尔时色界诸天复出大声。散天优钵罗花。波头摩华。拘物头华。分陀利华。曼陀罗华。摩诃曼陀罗华。遍满其地积至于膝。长者白佛言。世尊。我子月光于千万亿劫难可值遇。怜愍我故来生我家。善为我说诸佛功德。于千万劫恩难可报。复以无价真珠璎珞而散佛上

尔时世尊为德护长者深生信故。以神通力。出百千万杂宝色云。彼时卢纥多输(译云赤马是神名)毗桎逻莎(亦是神名)以种种杂色宝花光明照曜散于佛上。阿僧祇菩萨作无量神通。到于佛前。为欲教化百千万亿诸众生故。时德护长者及月光童子并德生童子等。心生欢喜礼敬佛足。至心忏悔作如是言。呜呼奇哉释迦如来神通变化不可思议。于百千万劫难可得见。况生净信。无量亿劫佛世难值。此儿月光有大智慧。曾见十方无量亿佛。游于一切诸佛世界稽首归命礼拜于佛。如释迦如来见十方佛。月光童子亦复如是。能见十方诸佛接足敬礼。于诸佛所闻法不忘

尔时如来见德护长者家内眷属男女大小及月光童子。于三宝所已生正信礼拜赞叹。广种善根增益心行。即便微笑如诸佛法。从其面门出无量千万种杂色光炎。口四十齿及以四牙。一一皆放无量千万亿光明。青黄赤白紫颇梨色。其光普照东方一切佛刹。如是南西北方四维上下。光明遍照亦复如是。光照已绕身三匝还从顶入

尔时离攀缘德菩萨。从坐而起。偏袒右肩右膝着地。合掌向佛白言。世尊。如来以何因缘作是微笑。诸佛不以无因缘而笑

尔时世尊告离攀缘德菩萨言。善哉善哉。善男子。汝能问佛如是因缘。汝已曾于过去无量千万亿劫常问此义。汝今承佛威神力故能问此义。善男子。汝今至心谛听。当为汝说。善男子。汝今见此德护长者大儿月光童子不。唯然已见。佛言。此童子者。能令未信众生令生净信。未调伏者能令调伏。未成熟者能令成熟。于其父所作善知识。何以故。能以导师法教化其父。安置无量千万那由他阿僧祇众生。于佛法中令生信心。必定阿耨多罗三藐三菩提又此童子。我涅槃后。于未来世护持我法。供养如来受持佛法。安置佛法赞叹佛法。于当来世佛法末时。于阎浮提大隋国内。作大国王名曰大行。能令大隋国内一切众生。信于佛法种诸善根。时大行王。以大信心大威德力供养我钵。于尔数年我钵当至沙勒国。从尔次第至大隋国。其大行王于佛钵所大设供养。复能受持一切佛法。亦大书写大乘方广经典。无量百千亿数。处处安置诸佛法藏。名曰法塔。造作无量百千佛像。及造无量百千佛塔。令无量众生于佛法中得不退转得不退信。其王以是供养因缘。于不可称不可量无边际不可说诸佛所常得共生。于一切佛刹常作转轮圣王。常值诸佛。于一切佛法僧供养恭敬尊重赞叹。造立塔寺。一切乐具悉以奉施。经半寿已。弃舍五欲。舍家出家净修梵行行法供养。阎浮提内一切男女见王出家。亦随出家净修梵行。此大行王。无量菩萨胜愿成就。大神通成就。于不可数劫行菩萨行。一一劫中所化众生不可称数。不可说不可量。悉皆安住于佛法中。如一劫中所化众生。一切劫中亦复如是。此菩萨如是安住。无量无边不可说众生。住佛法已于最后身当得作佛。号离垢月不动无障碍大庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。出现于世。世界名曰无障碍。其佛身广大。无量光明。无量光炎。无量神通力。无量说法。无量徒众。无量转法轮。无量身相。教化无量众生。彼佛欲入涅槃时。授德护长者记当得作佛。号无等身如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。德护长者家内眷属。见我神变发菩提心者。皆于彼劫各各名号次第作佛。天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。见我于德护长者家现神变时发菩提心者。皆于阿耨多罗三藐三菩提不退转。于十方界各各刹土各各名号皆得成佛。如是。善男子。此月光童子。已于过去无量阿僧祇劫。教化德护长者。此童子及德护长者。于当来世常生有佛世界。教化无量众生。说此月光童子及德护长者授记因缘时。无量世界地六种动。大光普照。雨众天华雨众天宝。雨天璎珞。雨天宝盖。雨众天衣。雨天旃檀末香。雨天沉水香。雨天多伽罗香。雨天优钵罗华。雨天波头摩华。诸天音乐出微妙声。及以诸天歌咏等声。如此一切皆是佛神通力。亦是月光宿世善根力。为化德护长者及眷属故。亦化天龙夜叉犍闼婆阿修罗迦楼罗紧那罗摩睺罗伽等故

尔时德护最大长者家人名德。见佛种种神力。亦见天龙八部兴大供养。向佛说偈赞叹佛曰

  南无大智佛　　释师子如来
  若能生信心　　而得大利益
  先信于外道　　而造诸恶业
  今信于世尊　　得如是大利
  见斯不思议　　其谁不信佛
  如是重罪人　　佛力故生信
  一心恭敬信　　出世胜导师
  无量百千劫　　不堕诸恶道
  长者造大罪　　今得净信心
  以信心因缘　　如来与授记
  长者自知罪　　心生大愁恼
  今得信心已　　得无量福德
  心中除恶见　　一切罪皆忏
  于佛世尊所　　而作清净心
  一心信佛故　　以是信因缘
  来世当作佛　　不思议法王
  初于佛生恶　　而今深生信
  布施因缘故　　得清净业藏
  于佛生信者　　一切信此人
  彼人福德聚　　不可得称量

尔时长者德护。头面礼佛及一切阿罗汉。一切菩萨众已。次第行百味饮食。尔时世尊说此法已。离攀缘德菩萨月光童子并长者德护。一切内外眷属大菩萨众。及天龙夜叉犍闼婆等一切大众。皆大欢喜作礼奉行

佛说德护长者经卷下


佛说犊子经

    No. 808 [No. 809]

佛说犊子经

        吴月氏优婆塞支谦译

闻如是。一时佛在舍卫国祇洹阿那邠迟阿蓝精舍。尔时佛遇风患当须牛乳。时有婆罗门大富去城不远。时佛遣阿难言。汝往到婆罗门家从乞牛乳。阿难受教而往。便至婆罗门家。婆罗门问阿难言。来何所求。阿难言。如来向者少遇风患。故遣我乞牛乳耳。婆罗门言。牛在彼间自[穀-禾+牛]取之。阿难即往到牛群所。有一牸牛。性常弊恶无人能近。阿难即自思惟。我法不应自[穀-禾+牛]取牛乳

尔时帝释知阿难所念。即来化作婆罗门像在牛边立。阿难往倩言。婆罗门为我[穀-禾+牛]取牛乳。语牛言。如来遇小风患。汝与乳湩令如来服之。差者汝得福无量不可称计。如来者是天上天下之大师也。当以慈心忧念一切蠕动之类。欲令度脱一切苦恼。牛言。此手扪摸我乳。一何快耶。前两乳取去。置后两乳用遗我子。我子朝来未有所食

尔时犊子在边立住。闻有佛名即语母言。持我乳分尽用与佛。佛者天上天下之大师也。甚难得值。我自食草饮水足得活耳。何以故。我先身以来常饮乳食。今当生牛身亦复饮乳。世间愚痴者甚多无量。我先世时坐随恶知识教不信佛经。使我作牛作马经十六劫。而今乃得闻有佛名。持我所食分尽用与佛满器而去。令我后世智慧聪明得道如佛。阿难持乳还至佛所

佛问阿难。彼牛母子有何言说。阿难言。大可怪也。牛先甚大弊恶不可得近。有一婆罗门为我[穀-禾+牛]乳。牛即调善。母子共说。佛言。此牛子母。先世时不信佛经故。堕牛马中经十六劫。今乃得悟闻有佛名。便有慈心以乳施佛。彼牛母子。后世当为弥勒佛沙门弟子得大罗汉。犊子死后当为我悬缯幡盖。散华烧香受持经戒。过二十劫后当作佛。名乳光如来度脱一切。佛言。牛以好善心意与佛乳故。度诸苦难。后得无量福报。以是因缘。佛不可不信。经不可不读。道不可不学。普告天上天下皆悉令知佛说犊子经


佛说伅真陀罗所问如来三昧经

    No. 624 [No. 625]

佛说伅真陀罗所问如来三昧经卷上

        后汉月氏三藏支娄迦谶译

闻如是。一时佛在罗阅只耆阇崛山中。与六万比丘俱。菩萨七万三千人。一一尊复各从十方佛刹。来到是间。悉得陀邻尼法。其欲无所挂碍。其心所念羞惭。多所忍而行。从是而得成。其心如金刚无能断截者。诸佛法一切习。诸佛法欲具足。其意所作而欲甚尊。其意不离菩萨心令他人亦尔施与伏意而不乱所爱而无所惜其净戒庄严饰身口意。其忍辱柔软是则为力。是则僧那阿僧祇劫。忆那术百千所作。精进而不懈怠。禅惟务三昧三摩越。其心知他人意。以是自娱乐。其慧功德无所不解。其心譬若须弥。无能譬者。其心如地水火风。亦无所爱。亦无所憎。常有慈心。其身光明无所挂碍。其哀是行。为一切人而作伤心。已法等心已是为乐。其护者不堕一道。有利无利。若誉若谤。若有名无名。若苦若乐。过世间之所有法。一切诸会不已为会。却诸外道。降伏众魔。是者难值。若优昙钵花。时时可得。一切人而无倩者而为作倩。故名曰厚。其厚者乃致至泥洹。已无极上僧那僧涅已深法。猛若如师子。已怛萨阿竭印而印之。所受决而无所碍。其作如所言。已谛法而审。其光明照于日月。十方莫不闻名者。一切诸佛无不救护。不令离法。悉皆守名深法灭。不断三宝。其心功德。通无央数刹土。其心净洁。习其处而往还。到佛所无所失。常教道一切人。已入般若波罗蜜沤和拘舍罗。则是头随人心所喜。以法教照。各令得所索。知诸人相。所行随所乐喜。不失其意。而作医王之德。疗于老病死已。供养过去无央数佛。其功德而致相诸种好已。过空无相无愿之法。诸法无所有。如幻野马如梦。如水中影山中之响。悉知一切之音声。通入诸法各各能答。已成持诸所欲。以智慧晓了道事。已稍近尊十种力。肉眼慧眼道眼法眼佛眼。过度众冥。尽入诸功德行。晓知菩萨之藏。其闻是法不复转移。便得相印三昧。金刚行三昧。其法在所作三昧。宝明持三昧。不舍一切人三昧。悉知一切心三昧已。得佛智慧。如佛所作为一切作。本已具足诸好。有菩萨名曰乐作(一)。复有菩萨名曰乐等有(二)。复有菩萨名曰宝手(三)。复有菩萨名曰明华(四)。复有菩萨名曰宝炎(五)。复有菩萨名曰喜见(六)。复有菩萨名曰意喜(七)。复有菩萨名曰喜以眼见(八)。复有菩萨名曰持地(九)。复有菩萨名曰欢喜作(十)。复有菩萨名曰大处废(一)。复有菩萨名曰大利(二)。复有菩萨名曰辟魔(三)。复有菩萨名曰意乐香(四)。复有菩萨名曰人中之天(五)。复有菩萨名曰谛愿(六)。复有菩萨名曰等视(七)。复有菩萨名曰尽见等不等(八)。复有菩萨名曰执御(九)。复有菩萨名曰一切无倩而作倩之厚(二十)。复有菩萨名曰弥勒(一)。复有菩萨名曰雨音(二)。复有菩萨名曰两若山半(三)。复有菩萨名曰两山鼎(四)。复有菩萨名曰慈行(五)。复有菩萨名曰光英(六)。复有菩萨名曰光声阳(七)。复有菩萨名曰镫明王(八)。复有菩萨名曰如当眼所见(九)。复有菩萨名曰光等知(三十)。复有菩萨名曰尊官(一)。复有菩萨名曰天官(二)。复有菩萨名曰天眼(三)。复有菩萨名曰视处悉吉(四)。复有菩萨名曰快臂(五)。复有菩萨名曰谛议意(六)。复有菩萨名曰安处意(七)。复有菩萨名曰安处度(八)。复有菩萨名曰无所动而度(九)。复有菩萨名曰金刚行度(四十)。复有菩萨名曰三世行度(一)。复有菩萨名曰谛如事不异(二)。复有菩萨名曰持严欲好(三)。复有菩萨名曰不尽欲(四)。复有菩萨名曰不稽留欲(五)。复有菩萨名曰意音(六)。复有菩萨名曰净音(七)。复有菩萨名曰饱满一切音(八)。复有菩萨名曰文殊尸利(四十九)

如是等菩萨会者。七万三千人于三千大千刹土。释梵护持世者。一一豪尊。诸天龙阅叉犍陀罗阿须伦迦留罗真陀罗摩睺勒人非人。尽来会。悉欲闻佛所说经。提无离菩萨。从坐起整衣服。叉手长跪而赞叹佛说。俗者不及道之明。为世间而作本。已过度于众冥。今自归度于世者。以布施总持十种力。已自伏意并化余人。是则为度一切莫不供事者。今自归于三界无能与等者(一)。以相无所不饶益其光(二)。赤色若于金。其音中和色甚殊好。无能与等者。今自归莫不供事者(三)。以度而度以降伏众外道。其智甚尊在于众黠之上。莫能有转动者。尽知一切之行。其功德甚尊。今自归无极之大哀(四)。诸所欲于欲无所得。众魔已索莫能当者。其净戒无所不安。于诸天一切则为天中天。其意无所复着。今自归莫能当者(五)。其闻德莫不欢喜。形像若宝。其见者无不爱乐。于施与已离淫怒痴。今自归其德。若天无所不覆(六)。以四谛过于四窦。以无眼者悉得视占。所说法无涯底。于三世行为一切作本。今自归其足而有轮(七)。其身者为诸天一切人之所供事。无男无女皆得而依。众魔而不敢当。则是天上天下之所特尊(八)。以众谛政法持于一切。其心等慈无所不遍。为一切作导。其法而等住。今已自归其德无及者(九)。其音柔软清净。其闻者莫不悦心。其声如梵无所不至。一切诸音皆悉具足。今自归于尊谛(十)。已度空无相无愿。其智甚深不可得根。已入众脱是为功德。今自归已得脱者(十一)。悉知因缘而所生。有之功德。其见无内无外用等故。其知所说别于如作。今已自归过度诸所可见(十二)。亦无所从来。无所从去。视诸法悉脱。若幻野马。今自归于法功德(十三)。所生无所生俱无生。其有已灭无有尽时。所住如法如怛萨所入(十四)。审如所说。若法如怛萨无所动转。其德若大山。身者若金刚。今自归安则若山(十五)。身心意而适等。其名流于三世莫不闻者。一切所问皆能报答。惟不以烦而肯说者。愿欲所问(十六)。赞叹佛已。傥肯说者而欲问之。佛言。在所问。提无离言。何谓菩萨以法自在说而庄饰身(一)。何谓菩萨快深法无所不入(二)。何谓菩萨知一切人心(三)。何谓菩萨随所喜而化(四)。何谓菩萨心行而入(五)。何谓菩萨知因缘有所作(六)。何谓菩萨而施与。为庄严持戒忍辱精进一心智慧(七)。何谓菩萨得在梵天(八)。何谓菩萨其智甚尊(九)。何谓菩萨而常得胜(十)。何谓菩萨从是得度(十一)。何谓菩萨于声闻辟支佛一切人。而示现法不入其中(十二)。何谓菩萨离于生死而不泥洹(十三)。何谓菩萨知一切人界不离法身(十四)。何谓菩萨不离本。于离本而示现(十五)。何谓菩萨而得尊贵。其福若帑藏(十六)。何谓菩萨随欲而得入道(十七)。何谓菩萨尽知诸法(十八)。何谓菩萨所作常安谛(十九)。何谓菩萨于世间而行无所著(二十)。何谓菩萨而自在法端正莫能当者(一)。何谓菩萨常不离佛(二)。何谓菩萨安谛而学(三)。何谓菩萨意与法无所取无所舍(四)。何谓菩萨而护一切(五)。何谓菩萨至法轮转(六)。何谓菩萨乃至阿惟颜(七)。佛言。善哉善哉。提无离。菩萨所问乃尔令一切得所。其在会者。若当来悉为作导。是摩诃衍而得久住。佛言。谛听谛听今我所说。则言。愿乐欲闻。佛言。菩萨用四事而自在。何谓四。其光明为一切无所挂碍(一)。所有名宝其有索者不为爱惜(二)。若明经者说法而不中断于边劝助(三)。若有倩令说法而不以难。承怛萨阿竭不可议踊跃而说之。于菩萨事无所悕望以法而施与(四)。是名曰四事。复有四事深入诸法。其慧所作不离功德。何谓四。于十二因缘而真知之(一)。如自惜身亦惜于人与身无异(二)。于生死亦不念有所从来有所从去(三)。一切诸法以空现空(四)。是为四事。复有四事。悉知一切人心其功德增减。何谓四事。以入法身而无瑕秽(一)。诸种好悉以现(二)。以四事而观(三)。其心无破坏便得三昧(四)。是为四事。复有四事。随一切所行而教化之。何谓四事。其慧而等(一)。悉化一切人(二)。观知诸法(三)。其心已净洁悉净一切人心(四)。是为四事。复有四事。知一切人心化之所行。何谓四事。其智无所不入(一)。其慧无所挂碍(二)。其心无有二(三)。睡卧诸盖已不复着(四)。是为四事。复有四事。所作罪福不忘。何谓四事。一切无所断(一)。亦无所著(二)。而知因缘所作随其示现以法持法(三)。亦不念有我。亦不念有人。随是教者不失道法(四)。是为四事。复有四事。以布施而庄严。何谓四事。以相庄严(一)。随人所喜。示现其好(二)。其色甚尊好(三)。所作而不可尽(四)。是为四事。复有四事。用净戒而为庄严。便为遮迦越罗不忘菩萨心(一)。得作释提桓因以菩萨心而自庄严(二)。而作梵天其心以菩萨而为庄严(三)。离一切恶道但生天上世间作人。以菩萨心而为庄严(四)。是为四事。复有四事。忍辱庄严。何谓四事。其音如梵声闻者各得所(一)。其声软好譬如迦陵(二)。一切莫不爱乐(三)。常于功德而坚固(四)。是为四事。复有四事。以精进庄严。何谓四事。其身若金刚诸邪不能得其便(一)。为一切而作厚(二)。所作事具足办而不中悔。学问无厌极(三)。其心所求而悉具足(四)。是为四事。复有四事。以禅自庄严。何谓四事。所作不抵突(一)。而不调戏(二)。不为弊恶(三)。自知而无异意(四)。是为四事。复有四事。以智慧而庄严。何谓四事。不自念有我。亦不念有人。亦不念有寿。亦不念有命。亦不着亦不断(一)。所作甚尊(二)。一切所有无所不入(三)。一切诸法无所复畏(四)。是为四事。复有四事。其慧自致梵天。何谓四事。以空慈念一切(一)。教一切人而以加哀(二)。总揽诸法而已护故(三)。等于一切亦不舍佛(四)。是为四事。复有四事。不离于智。何谓四事。以四禅而住不动转于菩萨(一)。以四事三昧三摩越。用沤和拘舍罗故不生无色中(二)。自在心所说不离法(三)。遍至十方尽见诸佛(四)。是为四事。复有四事而自在。何谓四事。于内而自灭于外亦自灭(一)。悉晓了诸法如幻(二)。以慧为力(三)。不自贡高而得度(四)。是为四事。复有四事。深入慧。何谓四事。知欲而不断欲。不中道取证(一)。知生死以沤和拘舍罗而在中(二)。所见悉知其政道非政道。亦不舍所见(三)。知无黠而亲近十二因缘(四)。是为四事。复有四事。于罗汉辟支佛一切人。以法而示现不于中有所悕望。何谓四事。视诸三昧知若如幻(一)。晓了诸法而严饰(二)。以旬自娱乐所作审谛(三)。其心自知譬若如幻(四)。是为四事。复有四事离生死亦不般泥洹。何谓四事。念诸佛故(一)。其心而等哀(二)。用沤和拘舍罗故(三)。不忘本发心之愿(四)。是为四事。复有四事。而知一切人不离于法身。何谓四事。视一切人皆自然。诸人入法身亦自然(一)。知一切人而自然(二)。人自然慧自然而不疑(三)。人自然泥洹自然而得忍(四)。是为四事。复有四事。亦不离本。于无本而见。何谓四事。常念泥洹欲具足佛法。其意而遍知(一)。以身现遮迦越罗梵释。于其中现功德。令会者因是法(二)。以身现不肖。令劣者得作功德(三)。其有所求者则施与以身。于尊贵现于极豪而往率化(四)。是为四事。复有四事。持想入无想。何谓四事。生死无常其心净(一)。从本已苦今已慧得(二)。视一切诸法无我(三)。泥洹寂(四)。是为四事。复有四事。离诸见法。何谓四事。清净(一)。于慧眼无所不见(二)。佛眼者悉在前立(三)。已度诸法印阿惟颜(四)。是为四事。复有四事。自在决诸疑。何谓四事。所欲无覆蔽(一)。入诸谛慧(二)。无所不覆(三)。不离诸陀邻尼(四)。是为四事。复有四事。而随习俗无所著。何谓四事。尽知世事(一)。便能度一切人(二)。已离憎爱(三)。以净于本无所沾污(四)。是为四事。复有四事而住法。何谓四事。其心自在(一)。其慧亦自在(二)。其智亦自在(三)。沤和拘舍罗而自在(四)。是为四事。复有四事。何谓四事。不离怛萨阿竭(一)。为一切赞叹佛形容(二)。教照人令发心为菩萨(三)。常念于佛(四)。是为四事。复有四事。寂而知诸法。何谓四事。以道尽知俗事(一)。一切晓了诸慧(二)。于所闻无有疑而得法忍(三)。不念有是无是。不随俗人有所作为(四)。是为四事。复有四事。而为师无所贪。何谓四事。为一切人作因缘(一)。其心质朴而无谀谄(二)。舍身之安而忧他人(三)。所求慧不用身故但为一切(四)。是为四事。复有四事。为一切作护。何谓四事。自舍身而忧他人(一)。悉舍诸乐以法自乐(二)。所闻不以为解(三)。以法而自长养(四)。是为四事。复有四事。当成轮转。何谓四事。逮得陀邻尼。逮得自恣所欲(一)。而无尽灭(二)。自入其心于内晓了诸法(三)。尽解他人(四)。是为四事。复有四事。乃至阿惟颜。何谓四事。已度于生死。不离于菩萨(一)。便得无所从生法乐忍故。受生死用不离法故(二)。已得阿惟致印(三)。已今得怛萨阿竭印(四)。今到十道地。以到十道地。从次第悉晓了。是为四事。佛说菩萨四事经时。三千大千刹土六反震动。其光明无所不明。诸天飞在其上。以亿百千种妓乐。而娱乐供养佛。雨于天华。皆言。善哉善哉。佛从无数劫所行。今皆闻之。其在会者其闻是法。从本已作功德。闻已便讽诵持。复为一切人广说。其心未曾忘。菩萨如是辈人所作。亦当如佛。吾等已得是利。所以者何。逮闻是法。尔时诸天及人八万四千。皆发阿耨多罗三耶三菩提心。万二千菩萨。皆得无所从生法乐忍。提无离菩萨问佛。从怛萨阿竭般泥洹已后。其有闻是经者。讽诵赞供事。当得几法功德。佛言。当得八法功德。其信无有异于菩萨而坚住(一)。其身施人于功德。而令增益于一切人。其心无所恨(二)。住于无极大哀教照一切(三)。以法故学问不厌足。若海不厌众流(四)。欲护诸法(五)。以法功德而自长养。虽身而死后还倍好(六)。入诸福功德具足本愿。为诸佛所拥护(七)。降伏众魔以离恐惧(八)。菩萨以是八事。佛般泥洹已后。便逮得功德法。尔时三千大千刹土。地为六反震动。悉平如掌。诸山陵海水陂渠沟坑。悉见如地其在水中。谓为如故。以百岁枯木诸树。皆生若干种叶。其叶者在佛方面。皆倾枝向之。其余好树亦复如是。地为生莲华大如车轮。其色无数。其光明悉开辟三千大千之刹土。从下视上。了无所见。但闻妓乐其音甚好。尔时从冰山香山。其香到是无所不遍。其华从是山出。乃来雨佛上。遍其地没人踝。佛所坐树其树亦出华。亦闻妓乐音若如天乐。其佛上便有三十万里珍宝华盖。而覆盖座盖间而有珍宝铃。周匝其边。悉皆垂珠。从其垂珠间。其音声悉遍三千大千之刹土。舍利弗前长跪问佛。是何本之瑞应乃有是现。佛谓舍利弗。有王名曰伅真陀罗。从名香山。与诸伅真陀罗无央数千。与犍陀罗无央数千。与诸天无央数千。而俱来说是瑞应。言适未竟便见伅真陀罗与八万四千伎人俱来。及无央数人。其华从上堕。譬若天雨从上悉下。与诸俱来者。头面着地为佛作礼。绕佛三匝皆在前住。伅真陀罗王。便以手持琉璃之琴。所以者何。是本之愿。面面各四万二千伎乐。伅真陀罗在其中央。同时鼓琴。其声悉遍三千大千之刹土。诸欲天子所有伎乐。应时其音不与是声而等。所以者何。其音悉覆即令不如诸欲天子诸色天子。皆悉到佛所。鼓是音时三千大千之刹土。应时诸树。名大山冰山王摩诃目邻。皆悉[(尸@言)*令][(尸@言)*令]摇。譬若如舞一切低昂皆向佛。譬若如人之作礼。比丘比丘尼。优婆塞优婆夷。诸一一尊。比丘及新发意菩萨。其在会者。诸天龙鬼神一切。自于坐皆踊跃。陂峨其身而欲起舞。提无离菩萨问。尊声闻已离诸欲。悉得八惟务禅。尽见四谛。何缘复舞。诸尊声闻答言。吾等不得自在用是琴声。于坐不能忍其音。亦不能制其心令坚住。提无离菩萨问摩诃迦叶言。仁者年尊而知厌足。自守如戒。为诸天及人之所敬爱。云何不能自制身舞。若如小儿。摩诃迦叶言。譬若随蓝风一起时。诸树名大树而不能自制。所以者何。其身不堪伅真陀罗王琴声。譬若如随蓝风起时。以是故吾等而不能自制。今乃知上人之所作。其功德不可当。诸声闻之所有。今悉为是音而覆蔽。提无离菩萨复谓摩诃迦叶。观诸阿惟越致所作为。闻是琴声而无动者。其有智人。闻是奈何。而不发阿耨多罗三藐三菩提心。诸声闻之所有威神之力。皆悉为琴声而所覆蔽。是音不能动摇诸摩诃衍。伅真陀罗王。所有伎乐八万四千音声。皆悉佛威神之所接。亦伅真陀罗。本愿福之所致。诸所音乐声。莫不闻其声。皆言。诸法等而悉脱。下中上悉净。而亦空无有异。一切诸人计。无有人已。过去当来今现在亦尔。但闻其音了无所有。其法者一切人声亦复如是。一切刹等刹。所已故等而无刹故(二)。其明无所有。等而称其刹者。无有生者。亦无长大者。是故空无有识而自然。诸所有无所有是自然(三)。亦不可得外行。亦不可得内行。其慧而本异法。而字法亦无所有。其名亦尔(四)。其知名色无所有。其行无著已。过去安无有极(五)。已从闻法本。尽坏无所有。亦无所至。亦无所住(六)。其所计但有字。但字尽知。字法而等不校别(七)。心所持等持故无所有。其本转而不相知。心所思亦无所生。其知是慧便入法(八)。其根根已等断前与后法这等其知等于三世。其慧便入无央数(九)。凡人为色名之所系。是者凡之所作。从本至本。从生至老无有已。已知因缘不复灭。其言有我有人。是与本而反(十)。我所住等无所住。诸法亦无所住。其知住无所住。是为欢喜闻信(十一)。譬若雨而有电。是上之自然。一切诸法我故曰自然(二)。我与人自然空。已知是者便入陀邻尼印。诸所脱门户而悉知。相等相故(三)。无有相法者。无有空故。无悕望用字故。故与法别。便有上中下(四)。其字者不自知而别用。不可见故。其心已本来故。而有本者续故。已知诸法无所有。已为断本际故(五)。已断本际。为一切而有行。已知本际等。是则为慈哀(六)。已净于慈。便等于苦乐。亦不喜亦不忧。所已者是为上人。已入本故。法学者寂而寂。若说若不说。无所增减法者。所以故寂而无悕望(七)。空中之声而不可获。但可闻无所说。若所说若所闻皆不诚。闻是音时。八千菩萨。悉得无所从生法乐忍。提无离菩萨问佛。是叹声从所出。佛语若问伅真陀罗王悉自为。若说之应时受言。便问伅真陀罗是叹声所从出。则答言。从一切人声从彼出。复问。一切人声。从所出从空出。提无离菩萨则言。伅真陀罗。一切人声不从意出。伅真陀罗复问提无离菩萨。是声当从身出为从心出。提无离言。亦不从身出。亦不从心出。何以故。其身不常住故。譬若草不常生。若墙壁不常而住。会有僻时其心无有形。亦不可见。亦不可闻。亦不可听。譬若如幻。伅真陀罗复问提无离。若无有身无心。是声何从得出。则答言。一切从念自然而有声。如仁说。声从念便有。今我叹声因空而出。所已故诸声不离空故。伅真陀罗则言。如仁欲知声者。皆因空自然有声。但闻音而不可见。即时灭。其灭者亦空。故曰自然。诸法所以等者。如空等故。其有所说。无所说亦等。所以者空等故。一切诸法。但可闻不可见。其所闻法。于闻不见其法。如法声不见。是声亦于法不现。诸法不可觉。所以闻者。已沤和拘舍罗故而可闻。则亦无所闻。已沤和拘舍罗知。便于法无所悕望。无所悕望者。是固要是固力。不复羸便坚强。无有能断。无有能断者无有生。无有生者无所属。无所属者便已轻。已轻者便净洁。已净者便无垢。已无法甚明甚朗。甚明者是心本。心本者为过。其过者知过已。已过者便无有想。已过诸想其处转上。转上者是菩萨忍。已得忍者无所不忍。亦忍空亦忍人。何以故。空亦不离人。何所是空人则空。忍于无想忍于有想。所以故想者自然而无想。亦忍无愿。亦忍有愿。所以故其愿想自然。无有愿本。诸法泥洹。亦复忍于生死。所以故生死者譬若如梦。菩萨得忍者不疑有无。持一计而尽知一切人。用得忍故。知一切诸法。亦无所至。亦无所来。知诸法悉住。已住于法者。知一切人亦住。已入是法者。是为无所从生法乐忍。但有音声。其法忍者。亦无所语无可说。其本者亦复不可说。佛者甚尊。不可说法。而令人得了。提无离菩萨白佛。快哉伅真陀罗所说微妙。晓了知深法而得忍。能有一一尊。所有所入忍而甚深问佛。是王所作功德。已更几佛。其所欲自恣乃尔。佛语提无离菩萨。可知洹河边沙。一沙为一佛土。尽索满中星宿。是数可知。伅真陀罗所供事佛。其数不可计。提无离菩萨问伅真陀罗。所供事佛甚多乃尔。合会功德甚大巍巍。何缘不疾成佛。伅真陀罗则言。菩萨用十事无有厌足。何谓为十。供事怛萨阿竭而无厌足(一)。所作功德亦无厌足(二)。学问法亦不厌足(三)。四禅五旬知亦不厌足(四)。视诸法亦不厌足(五)。欲广说法亦不厌足(六)。欲教一切人亦不厌足(七)。常欲护法亦不厌足(八)。欲具足诸波罗蜜亦不厌足(九)。欲感动化道劝助亦不厌足(十)。是菩萨十不厌足。伅真陀罗问佛。闻菩萨摩诃萨有三昧。名曰宝如来。其得是三昧者。悉具足诸宝。其问者所说法而自在。佛言。谛听所说。伅真陀罗言。受教惟愿闻之。佛言。菩萨不尽佛及法比丘僧用。是三事发心。便有八十法宝。何谓八十。其心不忘萨芸若。是则为宝(一)。其心不舍信。是则为宝(二)。其心习诸功德不懈。是则为宝(三)。其心坚其愿不舍。是则为宝(四)。其心所有施与无所爱惜而复增益。是则为宝(五)。其心所作但念菩萨。是则为宝(六)。其心庄严身。不犯身三事。是则为宝(七)。其心净者其语无恶。是则为宝(八)。其心庄严心不念恶。是则为宝(九)。其心已戒庄严加身。不欲不念人恶。是则为宝(十)。其心无所挂碍等一切人。是则为宝(一)。其心已忍辱为庄严。忍一切诸恶。是则为宝(二)。其心不爱惜身寿命用菩萨故。是则为宝(三)。其心无所憎爱亦不摇动。是则为宝(四)。其心坚固精进而不懈怠。是则为宝(五)。其心所作皆欲成。是则为宝(六)。其心所念意行直所作不忘。欲具足菩萨事。是则为宝(七)。其心禅三昧三摩越。已发是所作便自在。是则为宝(八)。其心求法欲合会诸智。是则为宝(九)。其心所闻法而习诵便有精进。是则为宝(二十)。其心所说法无所悕望。度诸求故。是则为宝(一)。其心于法无有虚饰。是则为宝(二)。其心念正道所作如事。是则为宝(三)。其心所闻所作如所闻用审故。是则为宝(四)。其心具足智慧已。不随他人教。是则为宝(五)。其心已无极慈而自护。是则为宝(六)。其心为无极哀。谓等一切故。是则为宝(七)。其心无极护已法自娱乐。是则为宝(八)。其心已无极等观视诸法。是则为宝(九)。其心于生死不以为勤苦。已入功德故。是则为宝(三十)。其心欲教一切人。多念于人不自念。是则为宝(一)。其心不乏已法分与人令得而学。是则为宝(二)。其心以大智无所不晓。有神足无所不感动。是则为宝(三)。其心而亲近迦罗蜜。无所闻而学问。是则为宝(四)。其心远离恶师而习功德。是则为宝(五)。其心等一切因是习无有二心。是则为宝(六)。其心知生死是则为病。便入一切人意。是则为宝(七)。其心为一切作药而愈诸病。是则为宝(八)。其心不轻易无智者。用法尊故。是则为宝(九)。其心不自贡高而忍一切。是则为宝(四十)。其心不谀谄。是则为宝(一)。其心所闻法不忘。于法住故。是则为宝(二)。其心尽护诸法。用念报诸佛恩故。是则为宝(三)。其心欲报恩。用坚固厚故。是则为宝(四)。其心若有侵者而不念报。是则为宝(五)。其心乐于山间。欲守法净故。是则为宝(六)。其心常欲舍家。欲作沙门。至于正道故。是则为宝(七)。其心于道而自趣足。自制而护恶。是则为宝(八)。其心知足。令人各欢喜。是则为宝(九)。其心于世事知足者。是为不厌足于法。是则为宝(五十)。其心自护不与众闹从事。是则为宝(一)。其心不厌足诸功德。用诸相具诸种好。是则为宝(二)。其心不厌足于智慧。欲决一切人疑故。是则为宝(三)。其心常念佛。不离佛故。是则为宝(四)。其心常念法。所说不离法故。是则为宝(五)。其心常念僧。便至阿惟越致僧故。是则为宝(六)。其心常念戒不动离菩萨。是则为宝(七)。其心常念施。不贪身故。是则为宝(八)。其心常念天上。便入一生补处。是则为宝(九)。其心尽知本。索晓诸所有。是则为宝(六十)。其心知法。不坏法身故。是则为宝(一)。其心所作知如事。尽知一切人之所语。是则为宝(二)。其心知自在。饱满一切人。是则为宝(三)。其心得陀邻尼。所闻法无所忘。是则为宝(四)。其心知本法。诸所有自然悉晓了。是则为宝(五)。其心护慧。知其识如幻。是则为宝(六)。其心学审谛。从是而得脱。不坏所作。是则为宝(七)。其心护法。欲知人自然。是则为宝(八)。其心知无常苦生死。于三界无所著。是则为宝(九)。其心视诸法无有我。用无人故。是则为宝(七十)。其心入泥洹。从本本寂复寂。是则为宝(一)。其心知空无相无愿。已度于脱近泥洹门。是则为宝(二)。其心无有生。无有生无所坏无所灭。其脱是者得忍。是则为宝(三)。其心知若幻如梦如野马如山中响如水中影已。坚固无所悕望。是则为宝(四)。其心喜知十二因缘已。去着断之事。是则为宝(五)。其心所见悉晓而不求不堕二。是则为宝(六)。其心不入二事。以一事悉知法。是则为宝(七)。其心具足诸行而不转还。度于诸色名。是则为宝(八)。其心稍近。已具法故。是则为宝(九)。其心合聚三十七品。用度诸法故。是则为宝(八十)。佛语伅真陀罗。已习是八十事而具足。便得宝如来三昧。已逮是三昧者。于道宝于欲宝无所住。何谓欲宝。何谓道宝。欲宝者。诸天及人人中之尊。释梵四天王遮迦越罗。若尊者诸侯。其一一豪姓者。于天上天下各自有尊。已得者则不如骄。自于是中悦心为菩萨而欲得之。是名曰欲宝。道宝者。以法度俗。何所法而度俗者则道法。何以故。欲之所作皆因慧。慧者则象道之法。譬如众流皆归于大海。须弥者诸山中尊。月者众星中大明。日者明于众冥。若师子诸兽中之猛。如王于众而为上。如释于忉利而为尊。梵者于众梵而独高。以是慧尊于诸法。故曰智慧王。所以其欲度者。因是而得度。用安隐道故。若冥持炬火而得明。其作甚猛降伏众魔。作医王调和诸药。作师晓知诸事。若持弓弭箭在所射。其箭无所不入。若力士持兵有所击。应时无有全命者。持是智慧击于愚冥无有不尽者。所以者何。用去垢故。其心而等无有异。亦不与人有所诤。亦无有能害者。与人无有恨。所作有究竟故。其慧而忠质故。能有所成作至诚。是为止意。一切平等是为断因缘。是神足合会诸功德。是则为根。所作在后。是则为力。于无智而为智。是则为觉。视人道径者。是则为道。已寂而寂。向观而观。于冥欲作明。冥去是则为明。是明之自然故。无有垢故。能净余脱于欲故。能脱余欲。不可见已度诸界故。无有诸界。内已寂已过诸空。用入空故。已离诸所见。是则无想。无所求寂。是则无愿想。已度三界。已相无有相是为相。其相与空等故。所以者何。以无求故。是则为布施。已度是我所非我所无希望。是则为戒。我无所住。是则为忍。无所持无所舍。是则为精进。无所增减是则为禅。不可知处所。是则为慧。其所入一切皆慧之所入。与沤和拘舍罗而相得故。譬若如梦。已无我为庄严。所作皆功德。已离无所住。佛语伅真陀罗。是则慧宝。菩萨已具足是者。便逮宝如来三昧。譬若大海悉含受众流及宝。其名宝悉从中生。若菩萨得是三昧者。便含受一切人。是为合集诸法故。是者众宝之明。是者众宝之本。以是故三宝众不知尽。提无离菩萨问佛。伅真陀罗王。已逮得是三昧不。佛言。自从伅真陀罗而问。为而发遣。提无离则问。仁者已得是三昧。伅真陀罗报言。是三昧不作是住念。当得我者不得我者。是三昧无有能得者。是三昧亦无有色。而不可知。痛痒思想生死识。亦不可知。是三昧不可已色见。亦不可听闻。亦无所生相。亦无所尽相。亦无所有相。而可相相相。亦不可观亦不可视。其言我能视我能观。不为三昧。何以故。有因缘想故。三昧者无有因缘想。三昧者等诸法故。已等诸法。我亦如是。一切人等人。何以故。等一切空故。三昧者空相。一切人无有想。无有想是三昧相。一切人无有愿。无有愿是三昧相。一切人悉净。悉净是三昧相。一切人无有我。无有我是三昧相。亦不可得身。亦不可得细滑。亦不可得心。其有说我知法我见法。是皆不可得。所以故不可从悕望得。提无离菩萨白佛。见伅真陀罗所被服从婇女及妓乐。谓已媱劮。不知所入法甚深微妙。所说自恣如法。佛言。菩萨已入深慧。晓了沤和拘舍罗。其道地如是无所不作。伅真陀罗。所持琴而鼓之。其音莫不而闻。故七十亿真陀罗。三十亿犍陀罗。自随者八万四千夫人。悉发阿耨多罗三藐三菩提心。菩萨以是慧沤和拘舍罗。便致名及美。人而在尊位。用不可数人。故为作本。如人作火不益薪。知令灭不久。菩萨而独住者。不能为人作本。以与人共乃能益人。其欲作大火者。当益其薪。故能大明。菩萨以人为薪。乃能成大之光明。佛言。菩萨所受人多各各得本。提无离问佛。伅真陀罗。何以故能持伎乐音。而令人发阿耨多罗三藐三菩提心。佛言。伅真陀罗犍陀罗者。悉乐于伎乐。便以伎乐而乐之。各得欢喜。知得欢喜。便令闻佛音闻法音闻僧音。赞叹菩萨快。其德极尊。当以心习萨芸若。但闻布施持戒忍辱精进一心智慧音。慈哀护等。意止意断神足根力觉道。向观禅惟务三昧三摩越。皆闻是音。无常苦无我寂。亦复闻是音。空无想不愿。无生无所生无生死。亦闻是音。复闻菩萨藏陀邻尼。金刚行三昧。净水诸法王印海印三昧。入一切诸法自恣诸法三昧。庄严三昧。宝如来三昧。宝自然三昧。知禅三昧。欢喜三昧。令地悉作莲华三昧。莲华尊三昧。无所不遍。入三昧。法池三昧。其意差特三昧。大电明三昧。师子明三昧。日明三昧。无央数因三昧。已入本三昧。金刚署三昧。金刚幢幡三昧。若金刚三昧。金刚济三昧。如地三昧。若须弥三昧。若须弥住三昧。明华三昧。其心自恣三昧。知一切入三昧。一切所行其地因是三昧。甚深全三昧。无央数说法三昧。开冥三昧。知一切人心行三昧。所乐三昧。生旬三昧。降伏魔三昧。现诸色三昧。各入其音三昧。悉知一切人身三昧。法行三昧。慧地首三昧。地首三昧。见谛所有三昧。解诸缚三昧。悉入诸因缘三昧

佛说伅真陀罗经卷上佛说伅真陀罗所问如来三昧经卷中

        后汉月氏三藏支娄迦谶译

佛言。其伅真陀罗。妓乐音声如是。用是音故。令人发菩萨心。是者其德甚厚。佛说伅真陀罗功德。尔时其在会者。衣裓上皆化自有华。皆起持是华。散伅真陀罗上。则时伅真陀罗。以右肩悉受华。其华不堕地。便持是华供养散佛上。其华于佛上。便化作珍宝华盖。覆蔽千佛刹。其华盖者。一一处悬亿百千珠宝。其一珠光明出亿百光明。一一明者有一莲华。其色若干其香甚香。其一一莲华上有坐佛。如释迦文。皆言。善哉善哉。仁者伅真陀罗。所化人甚多。皆发阿耨多罗三藐三菩提心。是菩萨之所作已度界。己界亦现过于生死。复见如故。住于泥洹三界而行。用一切人故。伅真陀罗念诸坐佛。欲持宝华盖遍覆其上。应时坐三昧。其三昧名严盖。则时诸坐佛上皆有华盖。及诸菩萨比丘僧。其会者各各有华盖。以手拥盖抵。诸菩萨比丘僧会者。皆持华盖供养上诸佛。伅真陀罗。复念欲请佛及诸化佛及菩萨比丘僧到香山。自是其所居处欲令宫室。及诸天鬼神一切。闻说法时皆得安隐。令悉见供养佛。可已为本。因是便可得福。伅真陀罗。便从坐起已。头面着地。为佛作礼。白佛。惟怛萨阿竭及菩萨诸比丘僧到香山。就其请处欲以饭食供养七日。令一切人得增益功德。佛即时默声。已受请故。伅真陀罗。则时欢喜。使已所从中宫。八万四千人。皆鼓琴作伎乐供养佛。作礼而去还归香山。庄严宫舍纵广三万里。令受佛及俱来者。其地墙壁绀琉璃色。以天金分布其间。无央数宝以杂厕其中。悉具诸床座。其足者悉名宝。以天缯为綩綖。为佛作座而高二千三百里。相持珍宝而庄严之。周匝栏楯皆以众宝。皆悬缯幡盖。烧名殊香。上有帐幔悉覆其上。以天华散遍其地。近佛座处而有四树皆宝。伅真陀罗。自呼官属及中宫。便言。佛者难值。譬若华优昙钵。今已得之当好供养。各弃谀谄嫉妒及贪。其乱者当正心。当至心供事。皆当具华名殊绝好。当以奉上名香及栴檀。于香山而熏之。今所当事是一切之尊。所作妓乐调和其音。当令悲好。其伅真陀罗所乐者。当作是供。人中之人。华盖缯幡。及天衣殊好软者。其色无数。当用是而奉上。佛者难值。其供事佛者。后生天上作四天释梵。其作是者便至此得。其色端正命则长寿。所生甚尊便得自在。其貌无辈所闻则得。其供佛者便得此德。若天上世间。常得安隐。其欲得是身常得休息。是皆供佛所致。其欲得辟支佛声闻菩萨道。为作是者便能降伏众魔。伅真陀罗。为诸官属中宫说是。受其教。具诸华香。调作百味之食。便住香山之南。与诸妓乐俱。皆令而作鼓诸琴瑟。所作已办。愿及用时其音皆雅悦心。一切欲令安隐莫不欢喜。其貌常净笑对一切。其尊无盖。诸天阿须伦莫不供事。惟愿用时屈神到是(一)。总持十种力。其力常胜莫能当者。降伏外道益于一切。其意已净弃于众垢。惟愿用时劳于尊神(二)。其身不受一切之尘。其功德不可胜数。其意甚尊无有极。所生甚豪。行步莫能与及逮之者。三道之恶已永无有所行。无行已悉舍行。其有见者莫不欢乐(三)。其明过于日月星辰。及释梵之明而不敢当。其明过于三界之上。其明见者。若在冥中见于灯火。莫不欢喜。诸所有明皆悉为蔽。其明无所不明。诸天龙所有妓乐不从其乐。而可得脱日益垢浊。其闻佛音莫不得脱其垢便除。十方诸医不能除人心之垢。佛则是医。所语闻者心垢则除便得安隐。佛者实尊尊中之尊。莫能与等者所语悉净无有异诸。所有恶莫不为伏。惟愿用时劳其尊神。本已布施而行。今已住于布施。当以法而施与。本已行净戒。自致得安隐。伏意而忍辱得成。惟愿用时劳于尊神。住于精进。已禅旬而自娱乐。其心意已住。以智慧光明而见。心常而欢悦。惟愿用时劳屈尊神。其心慈哀等于一切。已受过诸限。其功德过于梵。已佛故而得住。惟愿用时劳屈尊神。则时佛告诸比丘僧。各令护钵。当就其请。尽七日及护寺者。提无离菩萨自念。欲作交露车纵广四百里。其中悉有莲华。欲令佛及诸菩萨比丘僧。各各坐一一莲华之上到香山。则时三昧。应时便有如所念。白佛今有交露车愿就之。佛便坐莲华上。其座高四丈九尺。诸菩萨及比丘僧。各各坐莲华之上。如所言。所以者何。惟加哀我各坐已竟。则时以右手。自以神足而擎举之。诸欲天子。诸色天子。见提无离菩萨所作威神变化乃尔。各以其妓乐华香。而供养随到香山。伅真陀罗。遥见佛在交露中坐。来见已便令八万四千真陀罗揵陀罗。皆持华香而鼓琴瑟。作其唱乐而趣前迎佛。便相将入宫。到其处所佛就其座。诸菩萨比丘僧各各悉坐。伅真陀罗。语释梵四天王。今具已办各各布之。中宫一切各持饮食而悉供养。饮食已竟。行澡水讫。伅真陀罗。以机坐佛前听佛说经

佛语提无离菩萨。菩萨奉行檀波罗蜜。凡有三十二事。清净行之。何谓三十二事。一者菩萨布施欲求佛。发心为本。二者菩萨布施。当离罗汉辟支佛道。三者菩萨布施。念欲度脱十方人民。四者菩萨布施与人心不悔。五者菩萨布施与人。视之如佛。六者菩萨布施与人。心无悭贪。七者菩萨布施与人。心不乱欢喜与之。八者菩萨布施与人。手自斟酌。九者菩萨布施与人。意广不殆。十者菩萨布施与人。不求欲有所生。十一者菩萨布施与人。不从中有所悕望。十二者菩萨布施与人。不有所置随佛经教。十三者菩萨布施与人。乐佛经故。十四者菩萨布施与人。欲求佛道故。十五者菩萨布施与人。不自贡高。十六者菩萨布施与人。欲劝勉教人故。十七者菩萨布施与人。欲度脱人民。十八者菩萨布施与人。欲持经法教人民故。十九者菩萨布施与人。随佛教故。二十者菩萨布施与人。欲降伏魔官属故。二十一者菩萨布施与人。欲求成就得佛故。二十二者菩萨布施与人。欲求为人中雄猛故。二十三者菩萨布施与人。欲闭塞饿鬼道故。二十四者菩萨布施与人。欲使后世习布施故。二十五者菩萨布施与人。后世欲得豪贵富乐故。二十六者菩萨布施与人。世世得菩萨道故。二十七者菩萨布施与人。常欲与善师相随故。二十八者菩萨布施与人。欲使世世和颜向十方人故。二十九者菩萨布施与人。欲成佛道之本故。三十者菩萨布施与人。欲反成就菩萨故。三十一者菩萨布施与人。欲得三十二相八十种好故。三十二者菩萨布施与人。欲成境界庄严。欲向佛入诸经法故。是为菩萨清净布施三十二事。菩萨行檀波罗蜜如是

菩萨清净行尸波罗蜜。凡有三十二事。何谓三十二。一者菩萨身所行常清净。是为持戒。二者菩萨离悭贪嗔恚愚痴。口所言净洁。是为持戒。三者菩萨心作明慧不欺于佛。是为持戒。四者菩萨不随外道奉行十事。是为持戒。五者菩萨生天上世间。常不离佛道。是为持戒。六者菩萨离罗汉辟支佛。心去调戏。是为持戒。七者菩萨远离谀谄。入佛智慧。是为持戒。八者菩萨多学智慧心为第一。是为持戒。九者菩萨极大慈哀向于十方。是为持戒。十者菩萨遍护十方人悉具足。是为持戒。十一者菩萨未尝犯禁。离于惭愧。是为持戒。十二者菩萨不毁缺所行身常畏慎。是为持戒。十三者。菩萨不中道犯行违戾本心。是为持戒。十四者菩萨自守不犯众恶。是为持戒。十五者菩萨随明人之教度脱恶道。是为持戒。十六者菩萨持戒生天之本。是为持戒。十七者菩萨悉欲具足随佛智慧。是为持戒。十八者菩萨常坚持戒不犯佛教。是为持戒。十九者菩萨不自贡高轻侮他人常自制止。是为持戒(少十九一法诸藏并阙)。二十者菩萨能自制心不随爱欲。是为持戒。二十一者菩萨持戒不失得佛诸经。是为持戒。二十二者菩萨持戒有信。劝助乐不欺。是为持戒。二十三者菩萨不犯悭贪。是为持戒。二十四者菩萨持戒坚住随法教化。是为持戒。二十五者菩萨弃捐财富。常欲作沙门是为持戒。二十六者菩萨习乐于空闲之处。乐于经法。是为持戒。二十七者菩萨不贪饮食衣被。欲入道故。是为持戒。二十八者菩萨断截诸恶成诸功德。是为持戒。二十九者菩萨暴露专精。远离姓族守功行德。是为持戒。三十者菩萨入深法行无所附着。是为持戒。三十一者菩萨随次第法行十二因缘。是为持戒。三十二者菩萨不随诸外道。远离四颠倒。是为持戒。是为菩萨清净持戒三十二事。菩萨行尸波罗蜜如是

菩萨清净行羼提波罗蜜。凡有三十二事。何谓三十二事。一者菩萨不贪身。是为忍辱。二者菩萨不惜寿命。是为忍辱。三者菩萨不持嗔恚意向人。是为忍辱。四者菩萨人有骂詈毁辱悉受。是为忍辱。五者菩萨若见疲病羸劣。当哀伤之。是为忍辱。六者菩萨不轻易无教之人。是为忍辱。七者菩萨虽自豪尊为人所易。是为忍辱。八者菩萨为人所剥割不嗔不怨。是为忍辱。九者菩萨无嗔恚恨意于人。是为忍辱。十者菩萨为人所败令就小道。心不回转。是为忍辱。十一者菩萨乐信佛道其心不懈。是为忍辱。十二者菩萨心不动乱。清净而住。是为忍辱。十三者菩萨未尝持嗔恚向人。是为忍辱十四者菩萨护他人心令不得起。是为忍辱。十五者菩萨常以柔软之心向人。是为忍辱。十六者菩萨常持慈哀之心向人。是为忍辱。十七者菩萨不恃自贡高之心向人。是为忍辱。十八者菩萨为十方天下人下屈。是为忍辱。十九者菩萨不持忿行向人。是为忍辱。二十者菩萨自守无所犯负。是为忍辱。二十一者菩萨常自制心令意不起。是为忍辱。二十二者菩萨自有过失能自悔责。是为忍辱。二十三者菩萨不持他人长短。是为忍辱。二十四者菩萨常乐念佛道是为忍辱。二十五者菩萨常乐解于经法。是为忍辱。二十六者菩萨常爱乐十方人民。是为忍辱。二十七者菩萨常欲施与十方人民。是为忍辱。二十八者菩萨常持和心向人。是为忍辱。二十九者菩萨常喜劳来于人。是为忍辱。三十者菩萨常随经法不中断绝。是为忍辱。三十一者菩萨闻有三治不恐不怖。是为忍辱。三十二者菩萨无所从生乐喜智慧。是为忍辱。是为菩萨清净忍辱三十二事。菩萨行羼提波罗蜜如是

菩萨清净行精进波罗蜜。凡有三十二事。何谓三十二事。一者不断佛道。是为精进。二者不断经法。是为精进。三者不断比丘僧。是为精进。四者度不可计人。是为精进。五者受不可复计死生心不殆。是为精进。六者当供养无央数佛无厌极。是为精进。七者当作不可复计功德。是为精进。八者当学不可复计经卷。是为精进。九者悉当教十方天下人。是为精进。十者成就十方天下人皆使得佛道。是为精进。十一者当为十方天下人。给所当得悉当从与之。是为精进。十二者自身所有好物持施与人。是为精进。十三者诸禁戒悉当护持。是为精进。十四者忍辱之力悉当柔弱。是为精进。十五者诸禅三昧悉当具足。是为精进。十六者诸智慧悉令具足。是为精进。十七者诸佛境界所行功德。自庄严作佛时境界。是为精进。十八者欲求极大力。是为精进。十九者悉降诸魔及官属。是为精进。二十者持佛经法。悉降伏余外道。是为精进。二十一者十种力四无所畏。诸佛经法悉欲得具足。是为精进。二十二者庄严身口心。是为精进。二十三者未尝懈怠休倦。是为精进。二十四者所作为事悉当究竟。是为精进。二十五者心常当猛健。是为精进。二十六者悉弃捐诸爱欲。是为精进。二十七者诸未度者悉当度之。诸未闻经者悉当使闻之。诸未般泥洹者皆令当得般泥洹。是为精进。二十八者一一相者辄有百福功德悉当具足。是为精进。二十九者诸佛经法悉当护之。是为精进。三十者不可复计诸佛境界我悉当知。是为精进。三十一者世世常当见无央数佛。是为精进。三十二者远离从精进出生。远离身心无形。亦无所住。亦无所出。亦无所入。亦无所生。是为无所生乐住。是为菩萨清净行精进波罗蜜如是

菩萨清净行禅波罗蜜。凡有三十二事。何谓三十二事。一者所念无所犯。是为净。二者所持不缺。是为净。三者所分别不忘。是为净。四者去离调戏。是为净。五者自守知足。是为净。六者心不邪念。是为净。七者劝人作功德持用索佛。是为净。八者不犯六事。是为净。九者适无所著。是为净。十者自观内外。是为净。十一者悉具五旬。是为净。十二者心常柔软。是为净。十三者不着于身。是为净。十四者内行定。是为净。十五者向入佛道。是为净。十六者远离于恶人。是为净。十七者智慧明所入。是为净。十八者悉入所因功德。是为净。十九者悉令经法本乐。是为净。二十者随次第入行。是为净。二十一者智慧恩不转。是为净。二十二者沤和拘舍罗所成就。是为净。二十三者悉欲具足佛事。是为净。二十四者悉哀苦人。是为净。二十五者不与罗汉辟支佛从事。是为净。二十六者稍稍乐入深智慧具足。是为净。二十七者所作功德不厌。是为净。二十八者一切人本无有人信是事。是为净。二十九者悉得佛三昧不乱。是为净。三十者悉入十方天下人所念事悉见。是为净。三十一者悉知十方天人身事。是为净。三十二者譬如医王悉愈人病。菩萨持经法。悉愈十方天下人生死老病。是为净。菩萨行禅波罗蜜清净如是

菩萨行般若波罗蜜。凡有三十二事。何谓三十二事。一者欲得佛诸经法无厌时。是为高明。二者随次念诸经法。是为高明。三者智慧解黠。是为高明。四者所因法不灭智慧。是为高明。五者入黠守解五阴。是为高明。六者以黠慧承经法解于本端。是为高明。七者阿伊檀拘舍罗持智慧解。是为高明。八者十二因缘拘舍罗稍稍觉知。是为高明。九者四谛拘舍罗悉知是灭。是为高明。十者稍稍入慧拘舍罗制不随泥洹。是为高明。十一者内观皆悉晓知。是为高明。十二者故受化生死。当悉晓知。是为高明。十三者诸经法无所从生悉当晓知。是为高明。十四者一切人本端无形本自净。随世间习俗而入度十方人。是为高明。十五者一切法为一法耳。本端者泥洹也。是为高明。十六者一切境界为一境界耳。何以故。本自空故。是为高明。十七者一切佛为一佛耳。何以故。法身所入不可计故。是为高明。十八者一切事不悉见说。何以故。各各有字拘舍罗悉当知。是为高明。十九者无所挂碍护智慧。不可计十方天下人来问悉能报。是为高明。二十者悉得诸经法未尝有忘。用得陀邻尼故。是为高明。二十一者悉觉诸魔事。觉者当即远离。是为高明。二十二者一切法如幻。譬如人假着。笼躯须臾脱去。一切无所有亦如是。是为高明。二十三者如梦中所见。及水中影深山音响。一切法皆如是。是为高明。二十四者一切法皆空。本无所从来故。是为高明。二十五者十方天下人心所念。智慧悉至悉知其本。是为高明。二十六者持沤和拘舍罗威神之力入泥洹。后复来出现生死。是为高明。二十七者空无想无愿。一切法随教悉见度脱。是为高明。二十八者本端定无定无所见。一切法悉了其本。何以故。一切法无所持无所著。是为高明。二十九者悉得明无有痴冥。悉得智慧光焰。为十方天下人。说经法悉度脱。是为高明。三十者一切生死本无所从来。去亦无所至。悉晓知随习俗入。而为十方人说法。更生更死示现如是。是为高明。三十一者四事不护智慧悉至遍皆悉知。是为高明。三十二者为十方人说经法。从次第随人所喜乐为说之。当自制心自护智慧。悉具足成就。诸佛悉遥见是高才。为菩萨持佛威神。为悉拥护。是般若波罗蜜三十二事清净如是

菩萨沤和拘舍罗所行。有三十二事。何谓三十二事。一者教十方天下人自护身。二者福多者亦不于中住。福少者亦不于中住。三者教十方天下人民索菩萨道者。当教不索菩萨道者。不教悉视如师无异。四者常欲多珍宝财物施与众人。五者常乐求罗耶多教于人。六者示现母人身欲多教母人。七者示现年少教化小儿。八者示现若干种人。用哀世间人故。九者世间有狂乱者。亦现狂身安隐度之。十者若有乱心烦愦。随其烦愦为说经道。十一者随十方人所喜持法往度之。十二者持禁戒百岁若千岁。若有人所欲喜舍戒往教度之。十三者随人所好喜被服诸音伎乐。持施与之人得莫不欢喜。因持经法往教之。十四者头陀沙门各异志行。随其法行往教之。十五者尼揵波和及余外道。随其种类而入教之。引着佛道中。十六者于诸淫女人中。示现端正化淫女人。独尊悉教诸淫女人令不淫。及复化作男子。稍稍内佛道中。十七者若大会作诸音乐。时有观者听音乐之声。一切人大欢喜。持诸音乐声说经法。其有闻者莫不得度。十八者世间工师伎道化身。悉入其中教化令为佛道。十九者示现般遮旬世间有贫穷羸劣者。指示地中伏藏财物。施与贫穷人。竟为说经法皆令发意。二十者世间有死丧号哭愁毒者。亦复化现威神。亦复愁毒化教愁毒人令为经道。二十一者世间亡财物。菩萨化示伏藏财物教令为道。二十二者若有侯王。若有傍臣。若有迦罗越。傥有无子愁毒者。便化入腹中作子。各为父母家室。说经令得度脱。二十三者于贾人中最尊贵。中道资粮乏绝。便现威神。给与伴人浆水饮食令饱满。以为说经道。二十四者若有人堕地生盲。若百人若千人若万人。亦复持威神现盲人。悉复给示。与衣被饮食所当得。悉使盲人得眼视。莫不欢喜。如是稍稍为说经法。皆使发意求佛道。二十五者于大城中。若有见囚徒拘系牢狱。亦复化现作囚徒。亦复各各在其中持威神之力。悉使系者得洗沐衣被饮食。悉为说经皆令发意索佛。二十六者若有死罪将诣城外。菩萨便持威神之力。随其人数。以化人补其处将人持去。其人得脱大欢大喜。便饮食令饱与衣被。为说经道。其人得脱喜乐。皆发意求佛道。二十七者若有斗诤变讼。若诤钱财。若诤田宅。菩萨于中央两分和解。若有不足持钱财。义为和解给足与却。后为说经道。令发意索佛道。二十八者沤和拘舍罗。菩萨常端正示现于人作丑恶。二十九者现身作可怜沙门教人。转复作白衣行教人。三十者菩萨行沤和拘舍罗。远离在外余道。随其被服言语于其众中。诽谤佛。诽谤法。诽谤比丘僧。稍稍持经法。教化引着佛道中。三十一者稍稍教人。般泥洹亦复随之。般泥洹即复化出异方现。三十二者行沤和拘舍罗菩萨。自在所喜而化现。若化出作罗汉。若复化出作辟支佛。若复现作菩萨。若复化现作佛。是为沤和拘舍罗三十二事清净如是。佛说般若波罗蜜时。伅真陀罗及眷属。及诸天龙阅叉犍陀罗九万三千人。悉发阿耨多罗三藐三菩提心。与佛俱来者八千菩萨。悉得无所从生法乐忍。伅真陀罗王。得明慧三昧。闻佛所说欢喜踊跃。则以天缯贡上于佛。是间不能平其价数。则时伅真陀罗宫室八千人。以千叶华盖以贡上佛。佛以威神。令华盖悉在虚空。置佛头上合为一华盖。纵广四千里。伅真陀罗子及诸夫人。见是威神变化。悉发阿耨多罗三藐三菩提心。皆对佛惟。怛萨阿竭教照吾等。令成阿耨多罗三藐三菩提。作是言时。佛则离地百四十丈坐于虚空。从身放光明照三千大千之刹土。伅真陀罗摩休勒。诸所有眷属。及诸欲天子。诸色天子。所有唱伎乐不鼓而自鸣。于香华之山。诸华果树悉作琴声。其音甚好。佛举身毛。一一毛皆放光明。有莲华。一一莲华有菩萨坐。皆有三十二相。用佛威神故。诸伎乐声但闻说经。皆作难经之音。如人所疑。诸莲华上坐菩萨。皆发遣难经之问。决诸狐疑

诸音而作声。云何发菩萨心行而不忘。自致坐于佛树(一)。菩萨报言。其心欢。于一切便有无极大慈。以是之故不忘(二)。其音复作问。其意云何。所因云何云何。已无极大慈而生(三)。菩萨报言。其意。不谄所因如慧。无极大慈者致于泥洹(四)。其音复问。所施与云何已与。云何从而不悔所作。云何不求有所生。云何作菩萨愿(五)。菩萨报言。所有物而不爱惜。既与便无有悔意。常念菩萨道故。不求有所生处(六)。其音复问所作净戒。云何于戒而不自贡高。云何教失戒者。何从自致至摩诃衍(七)。菩萨报言。其有善心便有净戒。知一切法空故不贡高。作无极大慈故能教失戒者(八)。其音复问。若有骂詈挝捶欲杀者当云何有忍辱。其意云何不起而有悦(九)。菩萨报言。当念我作佛时。为一切人作医王。其病者我当愈之。以是故能忍辱。其有骂詈挝捶欲杀者。其意不起而有悦(十)。其音复问。精进云何而有究。云何不殆成菩萨行(十一)。菩萨报言。精进者用法故。欲护一切故而有究。晓了空事故不殆(十二)。诸音复问。其意当云何而令备足。其心如深入。云何于禅而自知无所希望(十三)。菩萨报言。其心不迷故能备足。其心不谄故如深入。用沤和拘舍罗故能禅。以是故无所希望(十四)。诸音复问。云何得智慧。所见而直行。云何具法慧业。当云何而决疑(十五)。菩萨报言。喜学问者增于智慧。晓知十二因缘故能直行。喜以法施与。故决诸疑晓知其本(十六)。诸音复问。云何而多智。能自致是以闻。云何而教人而自致得尊(十七)。菩萨报言。常谦损故多智。所闻如作乃能致。是以法施无所悕望。故能至尊(十八)。诸音复问。其慈者而云何。乃至无极之大哀。云何具护等。云何得至梵天(十九)。菩萨报言。其等心是则慈。不厌极是则护。因是其心欢喜悦。故能至梵天(二十)。诸音复问。云何菩萨能见佛。见已云何而欢喜。云何闻法而不疑(二十一)。菩萨报言。其心常念佛故。能致得见闻法。其心而净洁故能无疑(二十二)。诸音复问。云何功德而可集。云何其慧而可合。云何向观而可知。如是之事云何求(二十三)。菩萨报言。于功德无厌足。是故集学问无有厌故能致其慧。其心不乱无所念。是故为向观(二十四)。诸音复问。臧者云何其处。云何其行。云何所缘(二十五)。菩萨报言。臧者空无所有。其处者波罗蜜四禅是其行。所缘度一切(二十六)。诸音复问。何谓魔事。何谓佛事。云何所作至菩萨(二十七)。菩萨报言。无有胆而怯弱。是故为魔事。随摩诃衍心。是故佛事。悉舍众恶故致菩萨(二十八)。诸音复问。云何当亲近于迦罗蜜(汉云善友)。云何离于恶师。云何而等住。云何而舍(二十九)。菩萨报言。其教导菩萨道。是则为迦罗蜜。令离菩萨心。是则为恶师。所作而自知。是故为等住。舍外道诸邪。是则为政(三十)。诸音复问。云何可护诸法。云何可教一切人。云何为沤和拘舍罗。令成菩萨道(三十一)。菩萨报言。精进故能护法。沤和拘舍罗故。能教人随人有无。若道若俗而为开导故。成至菩萨道(三十二)。诸音复问。云何所作而用慧。云何是魔事。云何而谨敕不失时(三十三)。菩萨报言。所作令无罪是故慧所作而非法。是为魔事。常随其教。是则为谨敕常有谦损为人之所敬(三十四)。诸音复问。其道者云何。非道者云何。云何造人令入道(三十五)。菩萨报言。六波罗蜜是故道。其急者是声闻辟支佛事。是故非菩萨道。晓了般若波罗蜜沤和拘舍罗故。能造人令入道(三十六)。诸音复问。何谓为利。云何是镇。云何能令勤苦人。而令得欢喜(三十七)。菩萨报言。其得者七觉意。其法者是则利。其镇者是则陀邻尼。所教已法无饥渴。是则为欢喜(三十八)。其音复问。何所是菩萨父母。何所是亲属。何所是眷属。何所而有好(三十九)。菩萨报言。慧则为母。法则为父。三十七品是亲属。其功德是则为眷属(四十)。故能于一切而有好(四十一)。诸音复问。何从可知无我。何从可知慈而念一切。无我与慈。云何等令如称(四十二)。菩萨报言。晓了空事乃知无我。是则为大慈。知一切人皆空故(四十三)。一切生死无有生死法令然。其知是者亦复生死(四十四)。其谛者亦无有往。无有还者亦无有住。其作是者便能至道(四十五)。空无有相无有愿。已去求则为一相。已知者晓了五阴空。故无有想。无有想故无愿。一相而无数(四十六)。事五阴则空。已知观故。五阴亦知观一切人悉空。亦不有亦不无(四十七)。智慧则为护空。沤和拘舍罗护一切人。已无极大慈而教人。已故可至泥洹(四十八)。诸音复问。无有生故无所有。一切诸法如是(四十九)。何所生知微妙而生死(五十)。菩萨报言。无所生故无所有。是故慧之灭。用沤和拘舍罗微妙。故有生死(五十一)。诸音复问。何谓而得决。何谓不复还。云何而得忍。云何而无疑(五十二)。菩萨报言。等住而得决。已入法身不复还。已得无所从生法乐忍便无疑(五十三)。诸音复问。何谓佛树。何谓菩萨相。何缘佛名为佛。何谓名为怛萨阿竭(五十四)。菩萨报言。佛树者。普若天无所不覆。习诸法是菩萨相。是故名曰佛。以智故于心无所希望。其身亦尔。故名怛萨阿竭(五十五)。

佛说伅真陀罗所问如来三昧经卷中佛说伅真陀罗所问如来三昧经卷下

        后汉月氏三藏支娄迦谶译

伅真陀罗诸子。闻是法得欢喜信忍。各各解身上珍宝。以供养上佛。各各说言。今用吾等故。以是所有上佛。今还得闻诸法。各各白佛。甚可奇。是伎乐之音。乃作是问。诸坐化菩萨悉决其难。其在会者皆无狐疑。为我等开无央数冥。而令得明。是者谁之所致。令诸伎乐音。乃作是难问。诸坐化菩萨。而皆发遣。悉为解之。佛言。皆怛萨阿竭之所致。若我欲令空而作音声常可致。何况伎乐及诸树。以是故怛萨阿竭所作不可计。伅真陀罗诸子皆言。令一切人皆如怛萨阿竭。及伅真陀罗八万四千夫人。各各持天珠而奉上佛。则时散佛头上。便化作八万四千交露帐。其中悉有床具足皆珍宝。皆布天缯以为綩綖。诸交露帐中悉有坐佛。其佛皆三十二相诸种好悉具。八万四千夫人。见是变化莫不欢喜。皆发阿耨多罗三耶三菩提心。皆踊跃合作一音。而叹怛萨阿竭已。自净复净他人。悉去无垢。无所著无所污。其明甚好。其眼如优钵华。今自归明若如月(一)。其欢者莫若如见佛。佛为一切莫不断其罪。所语其闻者莫不欢悦。常爱乐于庐野。以众宝而合成。悉览持法宝藏。今自归无所不度者(二)。若度水以到岸。却外道伏诸邪。其净于莲华。以空率化。以谛教道。今自归欢喜者(三)。度四窦已四谛而率人。于世间行与人眼。足下轮有千好。今自归音安好(四)。其身过于人。为一切而说之。其有力无与佛等。今自归十种力(五)。而断欲有所得而不喜。无所得不已忧。于世间开盲者。如冥中然灯火(六)。已伏心致十种力而施与。自娱乐身已伏寂而度。今自归而无何(七)。其相者而甚尊。在于一切为之上。为一切示现。莫不得其本。其忍及慈已自娱乐。今自归为尊所敬(八)。若船师无所不度。佛者是即尊。烧三毒坏绝众冥。一切愚闇皆蒙其恩莫不来供。今自归寂诸恶已尽(九)。光而七尺色若如金。其音甚大声而清净。于人之上是则为尊。今自归为一切而作本者(十)。贡高诸冥已悉除去。度于一切自守如道。为众作导。所语悉谛而无有异。今自归于冥而作明(十一)。其祠祀而甚大故名字。而悉闻其法说如所言。其所闻莫不遍。今自归欢喜(十二)。大已住其处。降伏贡高自用者于一切而无所著。故知而极尊。今自归脱人之欲者(十三)。其声甚好音闻梵天。悉知罪福。去人之垢。晓知五阴。所作得重莫能等者。今自归去诸秽垢(十四)。其心悉等将护一切已率其意。其知无所不晓。已住于道所作悉正。所教皆谛莫不得脱。今自归所知而时(十五)。为人示导其德软好。其闻音者莫不解释。众魔甚多莫不而伏。一切悉过。自用诸所贡高。今自归已去众恶(十六)。诸有附者莫不随教。皆而来敬莫不供者。其佛难值所入微妙。其来问者莫不喜悦。今自归其德无辈(十七)。其意己力无所不晓。于好于丑其心适等。已坚住其处莫能动者。今自归已总诸力(十八)。其手足而有网。足下有轮。脱诸生老死。常胜一切。今自归其德如天无所不盖(十九)。则时伅真陀罗夫人。赞叹已竟各各复问。虽发阿耨多罗三藐三菩提心。难以母人。自致阿耨多罗三耶三菩提(二十)。佛言。以一事离于母人。疾得男子。至阿耨多罗三耶三菩提。何谓一事。以发萨芸若。作无央数功德而不忘。是为一事。复有二事。母人疾得男子。自致阿耨多罗。何谓二事。所作如所语不事诸天。但归于佛。所作如正不信于邪。是为二事。复有三事。母人疾得男子。自致阿耨多罗。何谓三事。护身三事而净。护口四事。护意三事。是为三事。复有四事。母人疾得男子。自致阿耨多罗。何谓四事。所施与不谀谄。于戒而不谀谄。常自守护亦不谀谄。听闻其法亦不谀谄。是为四事。复有五事。母人疾得男子。自致阿耨多罗。何谓五事。用法故。所作如法。闻法而直住。不乐于母人。常念作男子。是为五事。复有六事。母人疾得男子。自致阿耨多罗。何谓六事。不懈怠。所作不忘。其心柔软。质朴而不谀谄。亦无恣态。所作至诚。是为六事。复有七事。母人疾得男子。自致阿耨多罗。何谓七事。常念佛得法身。常念法得佛慧。常念僧欲令来属。常念戒欲净之所求。常念施与去诸垢。常念天上欲令如菩萨心。常念人欲度生死故。是为七事。复有八事。母人疾得男子。自致阿耨多罗。何谓八事。不以饮食而自乐。亦不华。亦不香。亦不众好杂色。亦不至戏观之庐。亦不倡伎而为乐。亦不歌舞。是为八事。复有九事。母人疾得男子。自致阿耨多罗。何谓为九。亦无所断。亦无所著。亦不念有我。亦不念有人。亦不念有寿。亦不念有命。亦不念有所生。亦不念无所生。而信因缘。是为九事。复有十事。母人疾得男子。自致阿耨多罗。何谓为十。为一切而有慈不贪利。一切物亦不念他。男子身命尽而不欺众。不两舌而喜骂。亦不妄语。其有作倡伎乐。其心不以为乐。亦不起意。亦无所恨而正住。不以邪罪福事而索知。是为十事。母人可得为男子。疾得阿耨多罗三藐三菩提。母人有施心有法心。视诸色若水中之聚沫。自于色不贡高。于安于苦。视若雨中之泡。若得安不以为爱。若得痛而不怒。于安隐亦不喜。于痛亦不忧。视而知思想。若野马。其心亦不在男。亦不在女。生死譬如芭蕉。知生死无有可于生死。亦不念有。亦不念无。其识譬如幻。视其心意。若幻无有异。于诸法无有着。以四大地水火风而知一切。若舍以三事而得成。有草有土有木。人者亦无吾无我无命所作。如所为无崖阂。是则本眼已自然而有所视。眼者如水中泡。但怙以肉而里空本空而净。耳鼻口身意亦尔。视其身若如影。其声者譬若向。知其心如幻。其作是者。疾离母人而得男子。自致阿耨多罗三藐三菩提。佛说是时。诸夫人皆欢喜已。头面着佛足。应时佛笑。无央数色光明。而从口出遍十方。还绕身三匝还从顶入。阿难从坐起正衣服。长跪已赞叹而问。面明如月其光甚尊。其色如火中之金。今笑愿闻其缘。今欲所问(一)。总持尊慧。为一切悉作本。其因地之者莫不供事。属之所笑会有欢者。今欲而问(二)。已法施自乐。已清净之戒忍辱之力。属之所笑是谁之本。今欲所问(三)。精进而根得成之力。以禅惟务以自娱乐。其慧若天无所不遍。属之所笑而为论本。今欲所问(四)。常若有慈。加之于哀护。寿适平而无奇特。属之所笑谁当得本。今欲所问(五)。已断三毒而有三眼。所语法譬若甘露。属之所笑谁当值本。今欲所问(六)。降伏众魔却于外道。已四谛而教。属之所笑谁当致本。今欲所问(七)。尊于十力决断众疑。其德无数。属之所笑谁当得本。今欲所问(八)。佛语阿难。乃见伅真陀罗诸夫人眷属为我作礼者不。阿难白言。已见佛谓阿难。诸夫人因是欢喜。为我作礼而自发心合会功德。寿终已后离于母人。当得男子便生兜术天上。当与弥勒相见讲议菩萨之事。弥勒佛时皆当供养。是波罗劫其当作佛者。皆悉来而供养。稍稍于是劫中。当成菩萨行。伅真陀罗自致至成佛。是诸夫人。皆当生彼佛刹悉作菩萨道

伅真陀罗白佛。今吾等所作。已若如佛。生死已尽。但住于天及人。已住于佛道。今已具法藏。已住其慧地。已治于功德。已现于谛道。已说沤和拘舍罗。已造菩萨心。开决众法说。所说而得依欢喜。而闻法时。众会及诸菩萨各各有念。伅真陀罗能至久如。而成佛号字云何。及其刹土有众菩萨。及其所有佛。应时悉知诸菩萨所念。便呼阿难谓。伅真陀罗王。却后七万四千八百劫。当为佛号字群那罗耶波披沙(汉曰德王明)。其刹土名栴陀惟摩罗(汉言日月明)。其劫名罗陀那三披(汉言宝等有)。其地平等悉白琉璃。其地之明譬若如日。其地甚净无有尘垢。在于虚空而有交露之帐。皆悉众宝诸菩萨悉坐其中。所行径处。诸菩萨各见佛。见已便念。我之所见若如是。化诸菩萨所疑。所见佛则当开解其疑。皆当得无所从生法乐忍。尔时刹土无有城郭丘聚县邑。王者之土。一切人皆在交露帐中。不见母人。亦不闻母人。其往生者。皆悉而化在莲华师子之座。众菩萨以禅为乐。以法欢喜为食。亦无异道。不闻异道一切。但有众菩萨。悉摩诃衍。无有邪道不信佛者亦无众魔。亦无魔民。亦无求者。亦无苦者。以好之藏。以空印而封。彼闻诸天及人等无异。但有名字。其佛寿十小劫。当以无央数众菩萨以为僧。悉当得不可议惟务。是佛欲般泥洹时。先当授菩萨决。其菩萨名曰沤多惟授。后当作佛号字摩诃惟授(汉言大严)。是劫罗陀罗三披。于佛于法于僧无有尽时。故名曰罗陀那三披。伅真陀罗。于佛前受决。即时欢喜踊跃。飞上去地百四十丈而住。欲令一切在会者而欢喜。自用功德。因佛威神而说叹。诸法本净。若空自然无有。自然故无垢。其知是者。则佛之上子(一)。若梦之所见不可得。故不可持。若如虚空。其知诸法如梦。不以死生为勤苦(二)。如幻师有所现。于其中无所得其五阴若如幻(三)。其色本若水中之沫。痛痒者若水中之泡而自然。思想者若野马如芭蕉无所得。生死无所得(四)。心意所知但有字。佛言。若如幻知五阴本如空。于生死不已等。已四大等如称所。已等如毒故(五)。六衰者如空野。已如法持佛威神(六)。自伏者乃施与。为是者即之安。其已净是则戒。想已尽则忍辱。能自制而寂为精进(七)。所作而无异。是则之为禅。如所缘无所碍故慧。持是学则波罗蜜(八)。无我无人则善慈。清净者是为哀。其寂者若护等。作是行上梵天(九)。以四事杂施与受佛忍以不怒贪。已无过所有(十)。无我寿命亦尔。六衰空而悉寂。其知者则菩萨(十一)。菩萨者不希望。不想有人无人。亦不想有我无我。其心不二故无所著(十二)。法无所有。而无所依。去无所至。来无所从。住法身无所阂。怛萨者与佛等(十三)。亦不有亦不无。因法缘所因便有。若电现则灭。心者亦尔(十四)。于生死而有行。其心不可见。心者如风无所著。其心者为本净。已知心本净。于生死无所沾污(十五)。若垣壁墙因土草木而得成。其身无知。譬若石本之净。身者无所希望(十六)。若风不可得。其声亦尔。若山中有妓乐之响。其知是声之亦净。于是响亦不作欲(十七)。若虚空而不堕。无所住无有处。尽知诸法。若虚空无所住无所止。如是知者已为等住(十八)。若有大火不能焦烧其虚空。其知诸法净若空。若异方刹土而有大火。往到彼间。其火亦不能害。已知是法。不已须弥遮迦和山之为碍。其知是者。能遍诸刹土。其四大地水火风悉平等。用空故。其知是者。能到亿亿刹土(十九)。于三界而有声上中下。于百亿劫而有声。无有竟。本自然故(二十)。佛色心等如称而微妙。用净故。诸佛平等若称(二十一)。菩萨行已。合会无央数之功德。已知善心诸法悉平等。后能便受其决(二十二)。菩萨者自己界于法身而甚净。其知是者后乃受决(二十三)。于色不想。于想亦不想。于痛痒思想生死识亦不想。以法故而受决。受决者不以阴四大。故空者尽平若称。已知是者为无所从生。后乃受决(二十四)。尽者不能自知。不尽者不能知尽。已向尽者。诸法忍后乃受决。无想者若直之道。有想者若入邪道。于诸法无所著。已过三世。其知是者乃得决(二十五)。自知我而自然。诸法悉自然。无我而自然。用空故而自然。空者自然无所有。其知三盖心等而空。是故曰自然。其知受决者。不当作是知。为有希望故。其知不心不意。受决者是则为受决(二十六)。伅真陀罗谓。诸会者若等悉住在地。而我在虚空。其知在地。于虚空心适等。遍于三世而无所著(二十七)。伅真陀罗赞叹说是。从虚空来下。前到佛所而白曰。今佛者用我故于世而有。佛尽为我说。吾之愿已从无央数阿僧祇劫而行菩萨道。不忘功德今悉得闻。时会诸菩萨各有是念。伅真陀罗。已从本何过去佛而发心。佛则知诸菩萨所念。欲决其疑故唤提无离菩萨言。过去不可胜数阿僧祇劫

尔时有佛。号字罗陀那吱头(汉言为宝英)。其刹土名曰首呵(首呵者汉言曰为净貌)。其劫名波罗林(波罗林者清净貌)。尔时怛萨阿竭。有十二亿菩萨。皆精进悉得忍。皆阿惟越致。其佛寿六十亿岁。其刹土庄严无所不办。其地悉琉璃。无种诸谷者。其有饥渴名美饮食尽悉在前。其土者无有异道。皆悉摩诃衍。尔时之世有遮迦越罗。名曰尼弥陀罗。而主四方。是遮迦越罗。供养佛六十亿菩萨至千亿万岁。所作功德而无央数。及夫人八万四千。及子千人。及官属八万四千人。与俱发阿耨多罗三耶三菩提心。发心复供事佛至亿万岁。却后以太子。名曰和陀波利林代而立为王。弃国行作沙门。其太子立为王者。亦供养佛。如前数已。复立其子而为王。便弃国行作沙门。如是展转相传如前法。乃至尽于佛寿。其佛般泥洹已。最后末王而制持法。佛语提无离菩萨。汝乃知时遮迦越罗尼弥陀罗不。今现伅真陀罗是。提无离则言。善哉善哉。佛之智以不可计尽久远。悉知而说之。佛言。是智不足言。所以故能知一切人已过去当来今现在心所行。有所因无所因。有功德无功德。是故怛萨阿竭智无所挂碍。佛说无所挂碍时。八万四千人。悉发阿耨多罗三耶三菩提心。伅真陀罗与宫室眷属。供养佛七日已。便持所有国土悉奉上佛。是者皆怛萨阿竭所有。时时抂尊来到是间。当用哀一切故。伅真陀罗太子。名曰遗摩罗涅。以摩尼珠交露以奉上佛。白言。今吾伅真陀罗者。于伎乐而有大欲。唯愿佛以法教照吾等。令于伎乐而无欲心。佛言。从今已去我为若心作护。有伎乐之音时。令若闻六十四法声当所向。何谓六十四法。但闻无常声。苦声。空声。无我声。寂声。清净声。无生死声。本净声。无所从生声。如其本声。本际声本无声。法身声。怛萨阿竭声。无人声。无寿声。无命声。无来声。无当来声。无过去声。无现在声。无处所声。无所得声。无所上声。布施声。净戒声。忍辱声。精进声。一心声。智慧声。慈声。哀声。护声。等声。佛声。法声。僧声。不忘菩萨声。意止声。意断声。神足声。根声。力声。觉意声。道所入声。响声。观声。沤和拘舍罗声。四事杂布施声。教一切声。护法声。降伏魔声。幻声。梦所见声。若日明声。若响声。若水中影声。不坏法身声。十种力声。四无所畏声。十八法不共声。阿耨多罗三耶三菩提声。阿惟越致声。庄严国土声。是为六十四事。诸所伎乐以佛威神但闻法声。已入是者便得三十七品。时会者莫不欢喜。皆以头面着地。各各悉言。菩萨甚尊。已住法者。皆为佛所护。佛语。诸会者如若之言。菩萨已住法者。皆为佛所护。所以者何。以护菩萨者。为护一切人。所以者何。菩萨发心用一切故。所以为僧那。将护愚冥脱于生死皆至泥洹。佛言。其知护菩萨者。是人已为护一切人。以其有以钵震越衣被。所当得者而与菩萨已。为施与一切已所以者何。菩萨出息入息而得生活。譬若如人有出息入息。因是而得住足。欲饶益一切故。一切众会。诸欲天子。诸色天子。清净天子。真陀罗揵陀罗摩休勒。皆赞叹劝助佛之所言。皆持众华而散佛上。伅真陀罗自念。诸比丘菩萨上至佛。皆当还去。欲令因伅真陀罗神足。而还便化作交露车。纵广三百里皆悉众宝。无央数宝以为诸树。为怛萨阿竭作师子座。高四丈九尺。以天缯无央数色。有綩綖布其诸座。令诸比丘菩萨各各就坐。为诸帝释四梵天王。作座如天座。则已成办。白佛。已加哀当就之。佛与比丘僧诸菩萨。悉就伅真陀罗车。则时因伅真陀罗神足。去地百四十丈。其车行于虚空。八千天子。其诸伅真陀罗揵陀罗皆共随从。伅真陀罗以金为绳。与眷属俱挽交露车适当向道。佛放光明悉照三千大千刹土。王阿阇世及诸群臣。比丘比丘尼。优婆塞优婆夷。见光明知佛当来。悉持缯盖幡花香。出罗阅城。皆出而行迎。伅真陀罗八万四千伎乐。皆作倡伎鼓琴瑟而行。其音先闻。伅真陀罗与子及眷属。挽车送佛。至耆阇崛山中已到。佛从车已下自就其座。诸比丘菩萨皆在前而住。阿阇贳王。比丘比丘尼。优婆塞优婆夷。诸一一尊者。及散王属阿阇贳者。皆持缯盖华香。悉以供养佛作礼。各各问言。怛萨阿竭。提无离菩萨问佛。伅真陀罗与诸眷属。以车送佛到是。当得何功德。佛言。伅真陀罗及眷属。其发阿耨多罗三耶三菩心者。因是功德皆当得五旬。乃至成佛而不忘。从一刹到一刹供养诸佛。闻其法亦供。视诸比丘僧。皆当知宿命。悉当成无极之大哀。常当护法。常当教化一切人。王阿阇贳语伅真陀罗。善哉仁者。为佛所誉。阿阇贳复报语伅真陀罗仁所作功德。愿分我少所令我得其功德。伅真陀罗则答言。若可意者持是功德。而相与及一切人。何以故。菩萨诸所作功德。皆为一切故。不于中有所贪。诸所作功德。不念独是我所作。一切人许菩萨有所作。为一切当蒙其福祐。何以故。菩萨者。是一切之因缘。稍而自习故能益于人。伅真陀罗谓阿阇贳。善哉仁者。而得二加罗蜜。一者是佛。二者是文殊尸利。蒙是恩所作非法其狐疑悉得解除。阿阇贳王言。菩萨所作甚善。已意作法器。诸所闻法其心不疑。亦不念亦不忘。提无离菩萨问佛。何谓菩萨能作法器。佛言。以三十二事为法器。何谓三十二事。菩萨坚住为佛所护。是为法器(一)。其意不谄所语无异。于功德有信。是为法器(二)。以习菩萨事。是为法器(三)。所闻用意。是为法器(四)。已入意稍欲至道。是为法器(五)。入知诸本。是为法器(六)。布施得尊。是为法器(七)。净戒具足所愿。是为法器(八)。忍辱者致三十二相。是为法器(九)。精进者一切诸佛法。是为法器(十)。一心者疗治其病。是为法器(十一)。智慧者无所挂碍。是为法器(十二)。慈者为一切人而等。是为法器(十三)。其哀者护一切贫穷。是为法器(十四)。其护者为哀一切人。是为法器(十五)。等心者为一切其心无有异。是为法器(十六)。为人作迦罗蜜。是为一切功德之法器(十七)。所闻不厌足。是为般若波罗蜜法器(十八)。作沙门虽离父母亲属。其心不已为勤苦。是为法器(十九)。乐在山间而自独处其心专一。是为法器(二十)。能忍空闲可得禅旬。是为法器(二十一)。其无者己所有而与之便教道入。是为法器(二十二)。护诸法使盲冥而得明。是则为法器(二十三)。知陀邻尼。晓了其事能开导人。是为法器(二十四)。在所欲为一切人能决其疑。是为法器(二十五)。其念佛者疾得见佛。是为法器(二十六)。(二十七二十八两法诸本并皆阙)。其无嗔怒其心不恨。其功德不知尽。是为法器。已知空事不慕所有。是为法器。晓了十二因缘过着断上而去。是为法器(二十九)。已得法忍者。是为法器(三十)。今受决不久。是为法器(三十一)。于阿惟越致。前其力故不动转。是为法器(三十二)。是为三十二事菩萨法器。说是时万人皆发阿耨多罗三耶三菩心。皆举言。令一切悉得是法器。令吾等逮得如佛所说法器。佛谓伅真陀罗。可还处所勿令人勤劳。伅真陀罗言。其心念劳者。是非菩萨。其不念劳者是为菩萨。伅真陀罗复问佛。何所菩萨念劳。何所菩萨而不念劳。佛言。菩萨以四事可知有劳。何谓四事可知有劳。闻无央数人其心恐怖。是为一劳。闻不可度生死其心恐怖。是为二劳。闻不可限诸佛智其心恐怖。是为三劳。闻无央数功德而成一相其心恐怖。是为四事。知而有劳。菩萨以四事知而不劳。何谓四事。欲度一切人皆令至泥洹。是为一事不以为劳。欲自护无央数生死。盖欲作功德其心不恐。是则不为劳。闻无央数佛智。欲悉具足其心不恐。是则不难。闻无央数功德而成一相其心不恐。续作功德不以为难。是为四事知菩萨而不为勤劳。复有四事。知而计勤劳。何谓四事。中间中间。爱乐声闻之事而往附觐。中间中间。乐辟支佛法而往亲近。诸法欲尽时而不用意。亦无有护。亦不教人发菩萨心。是为四事。知菩萨而计勤劳。复有四事不可计有劳。何谓四事。不于罗汉辟支佛法而自娱乐。听亡身命不离其法。若闻有好人可发菩萨心。故往教不避大远。是为四事知菩萨而不为劳。复有四事。可知有劳。何谓四事。若沙门婆罗门贫穷乞丐者。如有所求辄嗔怒向之。但忧食饮卧起得安。而不念余人。不念学问。我当多知时时所闻慧急去而不欲教人向。是为四事。知菩萨而计有劳。复有四事。知而不计劳。何谓四事。其乞丐者有所求则而施与。视之如迦罗蜜。其心柔软好颜向一切。不自念身安但欲安他人。于学不以厌足。如所闻教化一切人无所希望。是为四事。知菩萨不计有劳。复有四事。菩萨计而有劳。何谓四事。不求波罗蜜道。不以四事而有所施。于一切人不精进而欲教其趣。可所闻念已为足。不念菩萨道。是为四事知计有劳。复有四事。可知菩萨不计有劳。何谓四事。若身被火不已为剧。求诸波罗蜜亦如是不以懈怠。以四事施与常以备足不逆求者。以精进欲于人欢喜。欲具诸功德知而不厌。是为四事。菩萨知不计劳。佛谓阿阇贳。闻菩萨而不计劳则。答言已闻。佛言。已闻者从今已去。其有行菩萨者。所作勿厌极而计劳。王阿阇贳问佛。何谓菩萨行。佛则于伅真陀罗揵陀罗诸会中而言。各各得所。其阿阇贳闻佛所说菩萨行。如所行闻法则作行。于菩萨不计勤苦而行。于一切等心行。坚固行。谛行。其意所作而净行。于菩萨法而不谄行。布施行。与行。所有无所惜行。其作菩萨行不作有。所依净戒行。寂行。身口意净行。菩萨已心常念而行忍辱行。弃舍众恨而行。其作菩萨行者。不起其意精进行。有所致行。于生死不以勤剧而行。其作菩萨行其心不怯弱。禅行。知行。安身心而行。其作菩萨行心而不乱。菩萨者以智慧行当如法行。其行菩萨不计有所得。慈行。柔心行。常作哀行。菩萨所作行。无有恚行。空行。以意行。无有想清净行。其菩萨行无所愿。菩萨行是当行。具足意智慧行。菩萨所行。无所碍信行。精进行。用意安三昧行。其菩萨行无所断神足行。惟务行。以五旬行。菩萨所作而不罪行。平实行。乘法行。欲教一切而行。其如菩萨行。所作而不藉因缘行。如作行。断绝众冥行。于菩萨所作而不错净行。清净行。脱众垢行。菩萨其作是行。无有悔安行。护一切令无畏行。菩萨其作是行。为悉具足所欲。如日行。如月行。如莲花不污行。菩萨作是行。为诸天一切之所敬。如释行。如梵行。具足道行。菩萨其作是行。众魔悉恐。持行。尊行。尽淫怒痴行。菩萨作是行者。无央数诸天皆赞叹之。所行。久长行。智慧眼清净行。菩萨作是行者。无所希望。寂行。肃行。于名色无所著行。菩萨其作是行。无有罪。菩萨所作如是行。为诸天所叹。所语柔软行。如平等行。舍邪道行。菩萨之所行以慧为本行。勇猛行。动众魔行。会当坐佛树无有异行。得陀邻尼行者。菩萨在所作而不厌行。山间行。能忍行。常爱乐欲作沙门行菩萨所行如所因。欲脱行而心行。于一切而尊行。菩萨所缘所而不失。辩行。沤和拘舍罗行。于禅旬而不希望行。其作菩萨无所法行。于俗行。非俗行。欲色无色行。菩萨作是行。无所畏。一切无所不行。尽知一切人行。菩萨所行。譬若如天无所不覆(三十二)。佛说菩萨行时。五百菩萨皆得无所从生。法乐忍。于众会八千人。皆发阿耨多罗三耶三菩心。悉对佛言。吾等悉当奉行菩萨行如所行。佛作瑞应。欲令伅真陀罗还归其处。时伅真陀罗宫室眷属。绕佛三匝。前长跪而辞。放身光明皆作伎乐鼓于琴瑟。地六反为震动。而雨天华。便还处所归其宫室。释提桓因白佛言。今伅真陀罗。供养佛及法比丘僧诸菩萨。其功德已出我上。佛语释提桓因。不独过若上。其德已过三千大千刹土诸释梵四天王诸声闻辟支佛上。所以过者何。菩萨一发心。过诸声闻辟支佛一切人。当因其法得度脱故。菩萨胜于一切。莫能有胜于佛者。故知无能胜菩萨者。所以者何。佛因菩萨心。而自致成诸声闻。悉因佛法而得成。佛说是语。释提桓因则自泣泪出。白佛。令我有损本。不发菩萨心。时座中有天子。名曰惧或。谓释提桓因。佛法而普天。莫不发菩萨心。今若之悔。当复何益。所以者何。焦烧菩萨种故。已不在菩萨法器。惧或说是语时。五百忉利天子。皆发阿耨多罗三耶三菩心。惧或天子白佛。我见佛从本行。菩萨从提和竭佛受决。得无所从生法忍。时今怛萨阿竭。如所得法乐忍。惟愿说之。今吾等闻佛。佛言。无功德菩萨。不能得闻无所从生法乐忍。佛语惧或。菩萨以四事。得无所从生法忍。何谓四事。等知诸佛以过去当来今现在无有(一)。于诸法等无有异(二)。等诸刹土(三)。等一切人(四)。是为四事。复有四事。何谓四事。乐空而知四禅(一)。以无极哀乐于三活(二)。以沤和拘舍罗乐六波罗蜜(三)。以智慧乐于五旬(四)。是为四事。复有四事。何谓四事。于五阴求菩萨道。菩萨知五阴而自然(一)。于四大求菩萨以自然(二)。信四大于六衰求菩萨。视六衰而自然(三)。于诸法求菩萨。于诸法自然而不疑(四)。是为四事。复有四事。何谓四事。以住于本际而知诸法(一)。已住怛萨阿竭。于法无所不入。于三世而等(二)。入于法身悉知诸法。其相若空不可坏(三)。视诸法悉等无有异(四)。是为四事。菩萨得无所从生法乐忍。说是时。五百菩萨悉得无所从生法乐。惧或天子。得法忍不疑。说是欲竟时。佛呼阿难。若悉得伅真陀罗所问不。阿难白言。悉得甚善。是法快哉无比。甚深微妙如本所说。以是而知本晓了诸法。阿难白佛。如本所闻法。今闻是者可悉晓了。今我声闻。闻是悉晓了是法。何况菩萨其智无极。其心若海无所不受。其智甚广无所不苞。于诸法无所不总。于众宝而为大器。于一切无倩者而为作倩。若视厚其慧不可度。阿难复问佛。其后闻是者。当得向法明。佛言。今怛萨阿竭一毛光明。悉覆三千大千日月之明。如怛萨阿竭举身毛光明。不如得是法明。其决无所不过。所以者何。诸明者皆因智慧而得。法明者而知一切人。故尊而无盖者一其后闻是者。皆得慧明便持讽诵读。教人为其法智。不离菩萨。用一切故。于无极哀以为摩呵僧那僧涅。以慈而为铠以降伏众魔。稍近佛树下。阿难白言。今我承佛威神而持是法。其讽诵读。为一切人广说。其福云何。佛言。若有人以七宝满三千大千刹土。施与须陀洹斯陀含阿那含阿罗汉辟支佛上至佛。所作功德至千岁。佛问阿难。其德甚多不。阿难白言。甚多甚多。天中天。佛言。不如男子女人奉行菩萨事。而昼夜各三讽诵读。若为人说是法中事。其德出彼上。何况说如是法者。何以故。菩萨以经中四事。为人说解中义是故为法施。众施中之尊。于是为极上之恩。法施者是为极上之护。何以故。其法施者。闻听心垢则除便得脱。其所有物而施与。但长养于生死。其欲度于生死者。当以法而施与。是为随佛教法施者。一切人因是中而得德。菩萨法施时。得三十二事。何谓三十二事。用意安(一)。所作安(二)。于行安(三)。于爱欲少(四)。于怒鲜(五)。痴亦尔(六)。自就脱。复脱人。度生死(七)。为人所爱(八)。为诸天所叹(九)。为龙阅叉犍陀罗所护(十)。因所作而分越(十一)。便得衣钵震越床卧具病瘦医药(十二)。名声远近莫不闻者。终不为邪之所得(十三)。为诸佛之所赞便能行护法(十四)。因是而得法身。不畏于恶道(十五)。于诸天及人不以为难(十六)。所生不离诸佛法(十七)。所生便知宿命(十八)。所生爱(十九)。身而不缺减(二十)。便逮得三十二相(二十一)。得陀邻尼所破坏欲(二十二)。而知诸因缘以禅自养(二十三)。以大慧治道路(二十四)。于冥疾明(二十五)。其心不邪念(二十六)。俗事之所施与而过上(二十七)。于法藏不可尽在所欲(二十八少二十九至三十二四法诸本皆阙)。是为三十二。释提桓因白佛。我奉行持是法。若佛般泥洹以后。其有人应法器者。我当拥护令得闻是法。所以者何。如是经中所说功德。用功德欢喜故。佛言。善哉善哉。释提桓因于我前而勇猛若师子说。后当护是法。用是功德故。若阿须伦欲以兵而来不敢当若。所以者何。是法要无能得者。而若欲护之。其有所畏者。所见不邪故。于法无所希望。是故为护。梵天白佛。其有郡国县邑聚落其说是法。吾等自当舍其处所当往拥护。所以故声闻辟支佛释梵。因是法而得自成致。四天王白佛。吾等是佛弟子。皆当奉行是法。当拥护之令得久住。其吾等所部主。不信佛法者。若龙阅叉犍陀罗真陀罗摩休勒。其有不信者。我当令信。则皆言。随其习俗。说咒曰

多錍唵錍阿猎錍婆少猎錍休晏摩休晏伊晏牵晏阿和[口*鞮]惟越[口*鞮]波利眄陀那尼蚊眄波袈散那吚和吚和惟利頞眄妲眄妲摩罗伊陀

悉当令信向佛法其有邪意者皆令正心。其有阅叉自用者。皆不自贡高。皆当令赞叹佛而拥护法。是要佛之所说。四天王咒是言。其有求人短者皆得不胜。佛语弥勒。提无离菩萨。我从阿僧祇劫。而行菩萨道。今以法而相属累令得久住。弥勒菩萨谓提无离菩萨。佛般泥洹已后。吾等当护是法。当教告人广说其事。后世若有菩萨有功德者。当逮得是经卷。我等当劝助而拥护之。若后世其逮得是经者。有书讽诵读皆得安隐。当知弥勒。提无离菩萨之所拥护。时于会中。魔来而白佛。佛为声闻说法时。我不恐惧。亦无所忧。佛今所说菩萨印。住怛萨阿竭稍近菩萨道。为一切作护。我今闻是愁忧。譬若如老今以羸极。若欲躄地。惟怛萨阿竭加哀而哀。所以者何。闻是甚愁甚忧。从今已去莫复说是。佛谓。魔莫复啼哭。亦勿致愁。今若伴者亦甚众多。其有不闻是法者。悉是其伴。信乐者少少耳。佛以取土著爪甲上。其有信向是法。其数若爪上之土。其有不信者之数。譬若地之土。如地土之数不信者。悉若之侣也。用是故且自欢喜。无央数一切人界。说是法时悉发阿耨多罗三耶三菩提心。九万二千菩萨皆得无所从生法忍。八万四千人皆得须陀洹道。八千比丘皆得阿罗汉。尔时三千大千刹土而为六反震动。其光明无所不照。普雨于天华。其琴瑟倡伎乐不鼓而自鸣。诸天无央数辈。在虚空中皆言。善哉善哉。吾等于阎浮利。再见法轮而转。如怛萨阿竭。于波罗那界转于法轮。多得安隐。不如今之所说复增加转倍。其有持讽诵读是经者。所说以为助法轮转。弥勒提无离菩萨及阿难问佛。是法为何等。当云何行。佛言。是名伅真陀罗。所问诸波罗蜜解诸法宝品。佛说是经。弥勒提无离菩萨。比丘僧诸天人。犍陀罗鬼神龙。莫不欢喜。前为佛作礼而去

佛说伅真陀罗经卷下


佛说頞多和多耆经

    No. 740

佛说頞多和多耆经

        失译人今附西晋录

闻如是。一时佛在为耶国时有多树木处。与众比丘僧俱。比丘有五百人。月十五日盛满时。夜半寂然安静。比丘僧自相难问。时栴檀调弗天人。持天形状威神光耀来。直前趣佛。前以后悉脱身上珍宝着一面。但披一领衣。前以头面着佛足礼毕。问佛言。诸可过去佛正觉弟子有经。经名頞多和多耆。佛弟子今亦复说是頞多和多耆经。愿佛为我说是经。当使弟子奉持。佛默然不应。栴檀调弗。稽首而却坐。佛即为比丘僧说经言。我为若说頞多和多耆经。皆听着心中。念之勿得忘。比丘言。愿佛说。我皆当受经戒。佛言。布施有八事。何谓为八。愚痴人布施。但布施不知其恩善所在。既布施不达世间无有常。痴人持作常世间苦无极。愚人持作乐世间。所有愚人言。是我所有可常得。世间人皆颠倒不净臭处恶露。愚人用作好。不知作善得善。作恶得恶。愚人施与人。不知其人德深浅。持善心施与得道者。福不可量

佛告诸比丘。何以知愚人不知。布施有十因缘。何等为十。愚人布施不知为尊自用所与者得善。愚人不至心施与人也。愚人既施与人与时不敬重。不自手与。传教人与施。人不欲望其福。不即得其福者。自用忘其福。愚人施与佛辟支佛阿罗汉。不能自知其福大。愚人施与。不信佛辟支佛阿罗汉阿那含斯陀含须陀洹。皆用为弃损。无有后生。愚人施与。欲但得名字。欲使人称誉。是为愚人布施。佛说经已。栴檀调弗。及诸比丘。皆欢喜。前为佛作礼佛说頞多和多耆经


佛说发菩提心破诸魔经

    No. 838 [No. 837]

佛说发菩提心破诸魔经卷上

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

如是我闻。一时佛在王舍城迦兰陀竹林精舍。与大苾刍众千二百五十人俱。并诸菩萨摩诃萨众而共集会。是时王舍大城有迦叶氏大婆罗门住在彼城。而忽一时于夜梦中见此阎浮提世界。有其千叶广大莲华。七宝庄严清净可爱。而彼华中有大月轮。洁白圆满周匝光明炽盛照耀。彼婆罗门。于其梦中得见是相。心大欢喜适悦庆快。从梦觉已作是思惟。我闻沙门瞿昙是大智者。诸有智人无能过上。善巧方便大慧具足。我宜往彼请问其相。时婆罗门作是念已。过于夜分至明旦时。诣迦兰陀竹林精舍佛世尊所。到已头面礼世尊足合掌恭敬。如梦所见具以白佛

尔时世尊告婆罗门言。如汝所梦是吉祥相。婆罗门。汝今当知。若人梦中见四种相者。皆是最上吉祥胜相。何等为四。一者白莲华。二者白伞盖。三者月轮。四者佛像。若见如是四种相者。当知必得最上大利。尔时世尊欲重宣此义。而说偈曰

  梦中若见莲华相　　及白伞盖皆吉祥
  或见清净大月轮　　梦者当获最上利
  又复若见佛形像　　是相最上中最胜
  斯人一切所爱敬　　当能成就诸功德

尔时婆罗门复白佛言。世尊。何等名为最上大利。佛以何缘作如是说

尔时世尊。即以伽陀答婆罗门曰

  我今为说彼大利　　汝婆罗门当谛听
  若人能发菩提心　　成二足尊名大利
  转轮圣王位尊胜　　统四大洲而自在
  若有众生乐成就　　应当发起菩提心
  帝释天主胜福报　　三十三天中自在
  若有众生乐成就　　应当发起菩提心
  欲色无色三界中　　彼彼福报皆增胜
  若有众生乐成就　　应当发起菩提心
  所有众生界无边　　如其所应善化度
  若有广为利乐者　　应当发起菩提心
  世间所有大医王　　普能疗治一切病
  若有众生乐成就　　应当发起菩提心
  作大光明现世间　　一切暗冥皆照耀
  若有众生乐成就　　应当发起菩提心
  虽复生于三界中　　断除一切颠倒行
  若有众生乐出离　　应当发起菩提心
  所有烦恼等诸障　　及余一切不善法
  若有众生乐除断　　应当发起菩提心
  所有三界诸结使　　随所造作为魔摄
  若有众生乐除断　　应当发起菩提心
  若能调伏于无明　　一切爱网悉能断
  若有众生乐出离　　应当发起菩提心
  彼贪爱法若断除　　一切垢染皆清净
  若有众生乐出离　　应当发起菩提心
  所生族氏及色力　　愚人持彼生憍倨
  若有众生乐除断　　应当发起菩提心
  愚执我见寿者见　　于自善利生憍倨
  若有众生乐除断　　应当发起菩提心
  于诸色法生憍倨　　从染爱生过失大
  若有众生乐除断　　应当发起菩提心
  多闻持戒及修行　　愚人恃以生憍倨
  若有众生乐除断　　应当发起菩提心
  住阿兰若行乞食　　于如是事生憍倨
  若有众生乐除断　　应当发起菩提心
  应供自在具神通　　恃己尊胜生憍倨
  若有众生乐除断　　应当发起菩提心
  愚痴执着我人相　　恃彼我相生憍倨
  若有众生乐除断　　应当发起菩提心
  现在未来佛世尊　　尊重恭敬而获福
  若有众生乐斯利　　应当发起菩提心
  诸佛出兴于世间　　转大法轮普化度
  若有众生乐听受　　应当发起菩提心
  一切恶法断所断　　一切善法修所修
  若有众生乐成就　　应当发起菩提心
  诸修道者修梵行　　由是得证无漏道
  若有众生乐成就　　应当发起菩提心
  我所宣说无常法　　各各于身自观察
  若有众生乐了知　　应当发起菩提心
  我说有漏行皆苦　　智者见苦而生厌
  若有众生乐出离　　应当发起菩提心
  我为有情广宣说　　当知一切法无我
  若有众生乐通达　　应当发起菩提心
  宣说涅盘寂灭法　　证悟无上大菩提
  若有众生乐成就　　应当发起菩提心
  我所称赞菩提心　　汝婆罗门恭敬闻
  如闻深信能发心　　乃名修行菩提者

尔时婆罗门闻佛宣说是伽陀已。即白佛言世尊。若有人发菩提心者是人当得几数福蕴。尔时世尊复以伽陀答婆罗门曰

  正使一切众生类　　普集此佛世界中
  一一修持净戒行　　悉能安住戒学地
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  一一发生净信心　　悉能安住信行地
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  一一修习妙法门　　悉能安住法行地
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  广修须陀洹行法　　悉住须陀洹果位
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  广修斯陀含行法　　悉住斯陀含果位
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  广修阿那含行法　　悉住阿那含果位
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  正使一切众生类　　普集此佛世界中
  广修阿罗汉行法　　悉住阿罗汉果位
  而彼福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  若人于此佛世界　　广集上妙旃檀香
  造佛塔寺胜庄严　　高广等彼须弥量
  如是福蕴亦无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  又若造立诸佛塔　　如是分量所应作
  随所作已广庄严　　是诸众生胜果报
  而彼福利广无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  又若一切众生类　　假使住寿满一劫
  以诸乐具施众生　　随众生意使圆满
  如是福蕴量无边　　于诸福中为最上
  若人能发菩提心　　十六分中不及一
  我所宣说如是等　　一一皆为最上法
  若有众生忻乐者　　当求菩提寂静果
  住是果者得大利　　无比无等最尊胜
  是故若人闻此法　　应当尊重正慧行
  广修如是福蕴者　　速证无上大菩提

尔时婆罗门闻佛世尊如是称赞菩提心已。即白佛言。世尊。我于菩提心中无少法可转。佛告婆罗门言。如是如是。婆罗门。若人发菩提心者。实无法可转。何以故。婆罗门。当知菩提有其三种。何等为三。所谓声闻菩提。缘觉菩提。无上菩提。此中何名声闻菩提。婆罗门。谓若有人虽发菩提心。但乐自利不乐利他。于利他心不能发起不能修持。不能趣入不能安住。于此经法不乐听受。亦复不能为他宣说。于后生中而不受身断去来想。亦不能得平等正智。于现生中乐求解脱。婆罗门。以是义故名为声闻菩提。又复何名缘觉菩提。谓若有人虽发菩提心。于大乘法不乐修习而不记念。亦复自利趣求果证不乐利他。于利他心不能修持。不能趣入不能安住。于此经法不乐听受。亦不为他宣说教示。不能安住平等正智。但起心念观诸缘法。随所观察而得解脱。婆罗门。以是义故名为缘觉菩提。又复何名无上菩提。谓若有人。自能发生阿耨多罗三藐三菩提心已。复劝他人发如是心。于此经法自所听受修习记念。复为他人广说其义。于轮回身不生厌倦。乐欲利乐一切众生。住平等智自解脱已。欲令一切众生皆得解脱。自利利他得安隐乐。以己善利普施一切天人大众。婆罗门。以是义故。名为无上菩提。修是行者名为菩萨乘人。婆罗门。汝今当知。佛语。谛诚无有虚妄。如我所说阿耨多罗三藐三菩提心是最上义。若离此大菩提心。而发声闻缘觉心者。不能利他终不得至大涅盘界。何以故。而彼声闻缘觉。自所利己不复生起利他胜行。以是缘故。不能具足诸佛法分。虽发菩提心而自谓解脱。彼菩提心亦不能得利他果报。婆罗门。若人能发阿耨多罗三藐三菩提心者。于自于他皆悉平等。以自所利欢喜布施。即以此心普摄世间一切众生。乃为世间最上大利。亦名世间善调御者。如是即能住平等智。最上最胜不可思议。婆罗门。此即名为大菩提心。汝当如是如实了知

尔时婆罗门白佛言。世尊。佛说解脱云何有其种种相耶。佛言。婆罗门。声闻缘觉如来解脱无种种相。婆罗门。譬如有人乘三种兽欲诣宝所。虽所履道随有差别。彼所向处而无有异。其三兽者谓驴马象。彼驴乘者力势羸劣。由此因缘。是人虽至宝所。不能以其珍宝广施众生。但乐自利取证涅盘。彼马乘者轻利快捷。由彼力故。是人虽至宝所。亦复不能以其珍宝广施众生。但与众生作净福田。彼象乘者行步平正勇健多力。由彼力故。是人得至一切宝聚广大城中。至彼城已即作是念。三乘珍宝皆于此出。我当以此无量珍宝。普施无边一切众生。广为众生作大利乐。婆罗门。三乘行人修三乘法。亦复如是。彼驴乘者即声闻乘。彼马乘者即缘觉乘。彼象乘者即是大乘。汝今当知。彼三乘道虽种种相。所证涅盘所得解脱。无种种相亦无差别。婆罗门。又如世间有三士夫。俱欲过渡一深大河。彼第一人依一小叶浮水而渡。彼第二人而胜于前。依其板木浮水而渡。彼第三人又复胜前。乘以大船与多人众。安隐而渡得至彼岸。此复犹如世间长子。使其父母无所防护。于一切处离诸忧恼。婆罗门。彼第一人依叶而渡者。当知即是声闻乘人。彼第二人依其板木而得渡者。当知即是缘觉乘人。彼第三人乘船得渡者。当知即是菩萨乘人。自所得度复度他人。婆罗门。是故当知。彼三乘人所修行法虽种种相。而声闻缘觉及彼如来所证涅盘无种种相

尔时世尊欲重宣此义。而说偈曰

  三乘证涅盘　　同一涅盘法
  证道虽差别　　涅盘无二相
  三世一切佛　　得最上解脱
  如是等法眼　　正觉尊所说
  是最上法智　　出生诸方便
  诸有修行者　　应当如是学

佛说发菩提心破诸魔经卷上佛说发菩提心破诸魔经卷下

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

尔时大婆罗门白佛言。世尊。诸修大乘法者当行何行。佛告婆罗门言。如我今说当如是行。婆罗门。汝今当知。若有修大乘法者。自发阿耨多罗三藐三菩提心已。复劝他人发如是心。于此经法广为他人宣说教示。如是等人应当亲近尊重恭敬。是人以四摄法普摄众生。何等为四。所谓布施爱语利行同事。此中何名布施。所谓于财施中若少若多。随其自力起广大心。以此所施摄彼悭贪。如是名为修大乘者布施所摄。何名爱语。所谓于一切处见诸众生。应当面目熙怡语言柔顺。以诸方便安慰善来。以此爱语摄彼粗恶。如是名为修大乘者爱语所摄。何名利行。所谓见诸善法昼夜勤作。于诸众生起慈愍心。以生净信摄诸无信。以持净戒摄诸毁禁。于一切处常乐利益。如是名为修大乘者利行所摄。何名同事。所谓于一切处先同其事。复以方便教令精进坚固菩提。诸有智者于如是法当如是行。如是行者是为菩萨所修正行。若如是勇猛乃名最胜。得到彼岸悉能通达最上法门。如是名为修大乘者同事所摄

尔时婆罗门白佛言。世尊。诸菩萨摩诃萨依何而住。乃能得成二足尊果。住有几种。愿佛世尊广为宣说所有住法。如是说者。即同宣说菩提法门最上希有

佛告婆罗门言。汝今当知住有三种。所谓天住梵住圣住。此中何名天住所谓但修慈行。若人先于东方。身业行慈语业行慈意业行慈广大炽盛。南西北方四维上下亦复如是。身业行慈语业行慈意业行慈广大炽盛。此说名为天住。何名梵住。所谓修四无量行。何等为四。谓慈悲喜舍。此说名为梵住。何名圣住。所谓修三解脱门。何等为三。所谓空无相无愿。此说名为圣住。菩萨摩诃萨当依如是圣住中住

尔时世尊欲重宣此义。说[阿-可+加]陀曰

  我所说三住　　是勇猛胜法
  为诸菩萨众　　随所应宣说
  若于一切时　　如说而能行
  我当称赞彼　　是求菩提者
  天住及梵住　　圣住亦复然
  于此三住中　　随应而安住
  若如是住者　　当得无灭句

尔时婆罗门白佛言。世尊。菩提法门其义云何。未来世中若有众生问我此义。我无智慧。所有佛法不能通达。我于尔时当云何答。愿佛世尊广为我说

尔时世尊为婆罗门。说伽陀曰

  婆罗门当知　　我所为汝说
  此广大正法　　劝发菩提心
  诸无智慧者　　由此而获得
  若了此法门　　是即菩提义
  此所说正法　　劝发菩提心
  随众生所问　　一一能开示
  此所说正法　　劝发菩提心
  邪见诸疑惑　　一切皆能断
  于后末世中　　若有人得此
  正法堕手者　　是人若布施
  谓广大财等　　即圆满施行
  由施成就故　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　是人若持戒
  清净而无缺　　即圆满戒行
  由戒成就故　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　是人若忍辱
  安受诸娆恼　　即圆满忍行
  由忍成就故　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　是人若精进
  勇猛而发起　　即精进行圆
  由精进成就　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　是人若修定
  住三摩呬多　　即圆满定行
  由定成就故　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　是人若修慧
  解了最胜法　　即圆满胜慧
  由慧成就故　　得到于彼岸
  又复末世中　　若有人得此
  正法堕手者　　能尊重供养
  当知如是人　　名求菩提者
  得近佛菩提　　决定当成就
  八十俱胝佛　　加持此正法
  若得堕手者　　获最上法聚
  若现在佛前　　闻此正法者
  当知如是人　　了知菩萨义
  爱乐佛菩提　　我知如是人
  我见如是人　　我念彼名字
  我及一切佛　　亦共所称赞
  若人闻此法　　不转为他说
  彼生我慢心　　造广大过失
  当知彼等人　　不尊重正法

尔时婆罗门白佛言。善哉世尊。善说此法门。即是菩提义。若人于现世中。爱乐了知如是义者。是人不久于此世间得大勇猛。未来世中善说胜法安住菩提。广为多人作大利益。佛言。婆罗门。汝今已能得正智慧。能说如是利益语言。婆罗门。若有人今于我前闻是法已。我涅盘后于末世中。若能于此正法书持读诵者。当知是人爱乐圣道发菩提心。婆罗门。我于往昔求菩提时。于一阿兰若处遇一苾刍宣说此法。我当暂得闻是法时。涕泪悲泣即自思惟。我宿世中以何业障。于此正法先不得闻。作是念已。即取抟食施彼苾刍。后复白言。如所闻法我不能知。我今乐闻愿为广说。时彼苾刍。如其所应为我宣说。婆罗门。我于尔时闻是法已即发愿言。愿我当来以此正法。于末世中加持护念。广为众生宣布演说。婆罗门。我时又念。今此正法我于何时能为众生如应宣说。后末世中诸众生类。少能于此爱乐修习。后彼彼时此法在世佛不现前。我于是事深生悲愍。婆罗门。我当作是念时。有佛名无量光。发如是言。以愿力故果报成就。婆罗门。以是义故。我所悲愍一切众生。积集痴暗受轮回怖。后末世中有诸苾刍。于此正法起厌离心。毁坏禁戒作不律仪。以是缘故。不能宣通如是正法。是故婆罗门。我为利益诸众生故广说此经。汝应当知。今此正法是广大法门。总摄四种阿含。何等为四。所谓杂阿含长阿含中阿含增一阿含。如是等总摄一切声闻藏法。诸声闻人若于是中修学者即为声闻藏。而能出生声闻乘果。亦摄声闻菩提分法。又此经中摄彼一切最上所说菩萨藏法。是故得名诸法之母。所有毗奈耶藏阿毗达磨藏亦于此经摄。乃至八万四千法蕴一一皆从此经中出。又此经法是即一切智智最上根本。而复出生声闻缘觉之智。广大甚深不可思议。是大光明普照三有。此即从一切智根本出生诸佛菩提所有布施功德。持戒忍辱精进禅定智慧及彼最胜解脱。如是等众功德藏。悉于此经如理宣说。又复苦集灭道四圣谛法。而亦于此经中演说。以要言之。此经总说诸行无常诸法无我涅盘寂静。以是义故。若声闻乘若缘觉乘若大乘法。随其所应是中广说。又此经者于诸法中。广大称赞彼菩提心。是故此经最上最胜。婆罗门。若有人现见诸佛亲闻是法者。当知是人已从先佛闻宝严经。于彼经中已闻此法。是故当知今此经法。于三世中曾无断绝。彼彼众生随应得闻

尔时婆罗门白佛言。希有世尊。佛所说法最上甚深。若诸无智众生。得闻如是无量功德藏最上正法。不能深生爱乐心者。是人于阿耨多罗三藐三菩提。当以何缘而能成就。又复世尊。何因缘故多有众生。于此大乘最上法中。心生疑惑。佛言。婆罗门。汝今当知。此三千大千世界中。有百俱胝天魔宫殿百俱胝魔王。一一各有百俱胝天魔眷属。常时于此最上法门。伺求其便起诸难事。不令众生书持读诵。何以故。此三千大千世界中。多有众生取证阿罗汉果。今得闻此大乘法门。有善男子善女人。发阿耨多罗三藐三菩提心者。彼前功德称量较计。而不及此发菩提心。是故天魔伺求难事。魔为难故。多有众生以此因缘心生疑惑。婆罗门。又复此经为诸法中王。以是缘故多诸难事

尔时婆罗门白佛言。世尊。以何方便能令诸魔而自调伏。佛言。婆罗门。我有秘密总持法门名曰破魔。我若说此法门时。所有一切魔及魔众皆悉破坏。婆罗门。譬如日轮光明出照世间。一切暗冥皆悉隐没。破魔法门亦复如是。我若说时。一切魔众皆悉破坏。时婆罗门白佛言。世尊。何等是秘密总持破魔法门。愿佛为说

佛告婆罗门言。汝当谛听破魔法门。其名如是

那谟(引)阿帝(引)多阿那(引)誐多钵啰(二合)怛喻(二合)怛半(二合)泥(引)毗药(二合一句)萨哩嚩(二合)没提(引)毗喻(二合引二)婆誐嚩讷毗药(三合三)怛[寧*也](切身)他(引四)嗢哩没(二合)那(五)娑摩哩没(二合)那(六)嗢没那没那(十)壹贺没那(八)且怛啰(二合)没那(九)儞誐摩(十)多逻呬(引)腊没驮(二合十一)怛怛啰(二合)没(十二)怛噜贺誐多(十三)誐摩那致(十四)摩呬(引)耨娑摩(十五)讷讷(十六)摩嚩啰苏珂(十七)阿罗弥(引)多(引)伊迦啰叉(引十八)

世尊说是秘密总持破魔法门时一切魔宫皆大震动。一切魔王及诸魔众。皆悉惊怖战掉。心生苦恼不能安坐。咸作是念。世尊为一切众生。悲愍利益令得安隐。以慈悲喜舍饶益众生。何故今时。我等诸魔不为饶益。受斯苦恼不能安坐

复次婆罗门。我今以是秘密总持章句。而加持此发菩提心大乘经典。后末世中于一切处说此经时不为一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等伺得其便。宣通流布无诸难事。若有人书持读诵此正法者。是人远离王难贼难水火虫兽一切难事。何以故。今此正法最上秘密。我为悲愍利乐一切众生故。如是宣说。婆罗门。佛常不离慈悲喜舍饶益众生。若善男子善女人。如所宣说如理修习者。是人当得三业善行灭除诸罪。于一切时离诸苦恼。婆罗门。以是因缘。汝应当知。今此正法能除一切苦。能灭一切罪。能破一切魔。成就一切法

尔时世尊欲重宣此义。说伽陀曰

  魔于修善者　　常伺求其便
  欲起诸难事　　破坏彼善法
  若闻说此经　　一句或一偈
  彼诸恶魔众　　而悉自调伏
  大惊怖战掉　　苦恼不安坐
  由彼罪业因　　获果报如是
  于一切众生　　常起恼害心
  障诸善法故　　彼因果无失
  若人于此法　　书持读诵者
  是人当远离　　王难及贼难
  水火虫兽等　　诸难不能侵
  乃至人非人　　伺不得其便
  身语心善行　　断除一切罪
  于一切时中　　不生诸苦恼
  远离诸魔事　　不见诸魔相
  及离诸烦恼　　由持此经故
  若闻此经已　　如闻而善学
  善解一切法　　进趣于彼岸
  若修此法者　　通达菩提行
  从菩提道来　　成就正等觉

佛说此经已。迦叶氏大婆罗门。及诸菩萨声闻。世间天人阿修罗乾闼婆等。一切大众闻佛所说。皆大欢喜信受奉行

佛说发菩提心破诸魔经卷下


佛说法常住经

    No. 819

佛说法常住经

        僧祐录云安公失译经人名今附西晋录

闻如是。一时佛游舍卫国祇树给孤独之园。佛告诸比丘。法者常在。有佛无佛法住如故。如来至真出现世间。因为宣解分别深义敷演至慧。志在小乘。为说四谛苦习尽道。生苦老苦。病苦死苦。求不得苦。举要言之有阴身苦。设无有身当有何患。是曰苦谛。目贪于色。耳鼻身口意亦复如是。由此因缘成其六衰。从来劫数甚大久矣。既谛见斯已。知为恶习悉无益身。因守身行。护其心口十恶。以拔十二因缘根本则灭。灭除三毒。空无相愿由成罗汉。缘十二因知其牵连断其根源辄成缘觉。解身本空。奉六度无极四等四恩。道品之法三十有七。空无相愿无此三事。不为取证。六通善权常济危厄。等心一切无所适莫。故曰菩萨。逮不退转。当成无上正真之道。为最正觉度脱十方。故号为佛道法。常存行者。与合无彼无此。犹如众流未到海时各有本名。以合于海无有异号。道德若兹。去来今佛合一法身行与道合。因为众生分别演说。阴衰诸入十二牵连皆为病疾。诸度无极四等四恩为大法药。疗众生病。净如虚空。明踰日光。德超须弥。神圣巍巍莫能讥谤。众罪消灭无复诸苦。以大慈悲度脱十方。佛说是时。诸比丘众漏尽意解。无数菩萨寻时逮得无所从生法忍。佛说如是。诸比丘及诸菩萨诸天龙神。闻佛所说欢喜奉行佛说法常住经


佛说法乘义决定经

    No. 763 [No. 762]

佛说法乘义决定经卷上

        西天三藏明因妙善普济法师金总持等奉　诏译

如是我闻。一时薄伽梵。在舍卫国祇园精舍。与大比丘众千二百五十人俱。时有一比丘。名曰甚深勇猛。美妙音声。善问法要。初中后善。利益自他。能修梵行。清净圆满。敬礼合掌。前白佛言。世尊。如来往昔鹿野苑中。所说法乘决定之义。是事云何唯愿世尊。敷演分明。开示众生。皆令悟入。世尊叹言。善哉比丘。汝如是问甚深法要。最胜利益不可思议。汝应谛听。善思念之。吾当为汝分别解说。我于尔时。说四谛法。义无穷尽。所谓五蕴五取蕴。十二处。十八界。十二缘生支。四圣谛法。二十二根。五三摩地。四禅天定。四无色定。四三摩地。四念处。四正勤。五根。五力。七觉支。八圣道。十六心念。声闻四果。如来十力。四无所畏。四无碍辩。十八不共法。三十二大丈夫相。八十种随形相好。佛言。比丘如上所说。是名法乘决定之义。比丘复白佛言。世尊。云何五蕴。世尊答言。所谓色蕴受蕴想蕴行蕴识蕴。比丘是名五蕴。云何五取蕴。佛言。所谓色取蕴受取蕴想取蕴行取蕴识取蕴。比丘。是名五取蕴。云何十二处。佛言。所谓眼为内处。色为外处。耳为内处。声为外处。鼻为内处。香为外处。舌为内处。味为外处。身为内处。触为外处。意为内处。法为外处。比丘。是名十二处。云何十八界。佛言。所谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。比丘。是名十八界。云何十二缘生支。佛言。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老尽忧悲苦恼。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老尽忧悲苦恼灭。比丘。是名十二缘生支。比丘复白佛言。世尊。云何名无明。世尊答言。所谓痴惑暗蔽。无他明慧故。前际无智。后际无智。现在际无智。内无智外无智内外无智。业无智果无智业果无智。善作业无智。恶作业无智。因无智果无智因果法无智。缘无智缘生无智缘生法无智。无佛智无法智无僧智。苦无智集无智灭无智道无智。有耻无智无耻无智有耻无耻无智。有耻无耻法无智。乃至爱支有耻无耻法无智。世无智出世无智世出世法无智。依止无智非依止无智依止非依止法无智。有为无智无为无智有为无为法无智。过去无智现在无智未来无智过去现在未来法无智。比丘是名无明。云何无明缘行。佛言。所谓身行语行意行。是名无明缘行。云何身行。动转所作。身为济渡。任持诸法。为依止处。是名身行。云何语行。能诠能显。分别校量诸法实性。是名语行。云何意行。心所爱乐。心所思惟。心所摄受。心所依止。是名意行。云何行缘识。佛言。所谓眼识耳识鼻识舌识身识意识。比丘。是名行缘识。云何识缘名色。佛言。名谓非色四蕴受想行识。色谓形质。体即四大。是名识缘名色。云何四大。佛言。所谓地大水大火大风大。云何四大体相差别。所谓地以坚硬为性。水以湿润为性。火以温热为性。风以轻动为性。比丘。是名四大体相差别。云何名色缘六入。佛言。所谓眼入处耳入处鼻入处舌入处身入处意入处。比丘。是名名色缘六入。云何六入缘触。佛言。所谓眼触耳触鼻触舌触身触意触。比丘。是名六入缘触。云何触缘受。佛言。所谓眼触生受。谓生苦受乐受非苦非乐受。耳鼻舌身意生受。亦复如是。比丘。是名触缘受。比丘复白佛言。世尊。云何受缘爱。佛言。所谓色爱声爱香爱味爱触爱法爱。云何色爱。所谓一切有色。可爱可乐。深心恋着。无有厌离。是名色爱。声香味触法爱。亦复如是。比丘。是名受缘爱。云何爱缘取。佛言。所谓欲取见取戒禁取我语取。比丘。是名爱缘取。云何取缘有。佛言。所谓欲有色有无色有。云何欲有。谓欲界五趣。及四王天。忉利天。焰摩天。兜率天。化乐天。他化自在天。是名欲有。云何色有。佛言。所谓梵众天。梵辅天。大梵天。少光天。无量光天。极光天。少净天。无量净天。极遍净天。无云天。福生天。广果天。无烦天。无热天。善现天。善见天。色究竟天。比丘。是名色有。云何无色有。佛言。所谓空无边处。识无边处。无所有处。非想非非想处。是名无色有。比丘。如是三种。是谓取缘有。云何有缘生。佛言。所谓一切众生。以爱取为缘。润生五蕴。住世动作。随顺流转。种种差别所与及取。皆从蕴起。身之所生。以命为本。比丘。是名有缘生。云何生缘老尽。佛言。所谓四大迁变。诸根衰朽。身体羸弱。动辄疲苶。博识多知。智已昧劣一切众生。身识欲离。诸根欲灭。性境冥昧。无所觉知。比丘。是名生缘老尽。比丘复白佛言。世尊。云何四圣谛法。佛言。所谓苦圣谛法。集圣谛法。真圣谛法。道圣谛法。云何苦圣谛法。所谓生苦老苦病苦坏苦。爱别离苦。冤憎会苦。求不得见。五盛阴苦。比丘。是名苦圣谛法。云何苦集谛法。佛言。所谓众生爱着世间一切有及有具随顺贪欲。比丘。是名苦集谛法。云何苦真谛法。佛言。所谓以智慧刀。断除爱着世间一切有及有具随顺贪欲。永尽无余。入胜义谛。证寂灭理。是名苦真谛法。云何苦道谛法。佛言。所谓八圣道支。正见正思惟正语正业正命正念正定正精进。是名苦道谛法。云何二十二根。佛言。所谓眼等五根。谓眼耳鼻舌身。信等五根。谓信进念定慧。五受根。谓苦乐忧喜舍。三无漏根。谓未知当知根。已知根。具知根。及意命男女。比丘。是名二十二根。云何五三摩地。佛言。所谓身支五体。可喜可乐。无毁无损。深生恋着。于一切身。皆生爱乐。由如是心。随顺染欲。种种爱着。不了虚幻。妄执为实。是故应当如实观察。如是五体。皆从四大缘会而生。一心思惟。安住悟入妙三摩地。名身定智。譬如山上散水。于下流布四方。如是散已。不见其水。地复干涸。时有天人。空中告言。汝若须水。我有天水大泉。自然涌出。洁净清凉。甚可爱乐。济渡润益。无有穷尽。身生定智。利益无穷。亦复如是。复告比丘。当审思惟观察筹量。此身不实。勿应爱着。譬如优昙钵罗华。钵头摩华。俱勿陀华。奔茶利迦华。如是青黄赤白。四种莲华。众色殊好。甚可爱乐。皆生于水而坏于水。此身变异。虚幻不实。亦复如是。复告比丘。身语意业。圆满清净。获得胜解。如实安住三摩地门。以清净心。观一切身。皆非坚固。譬如长者及长者子。以众珍宝新净妙衣。严饰其身。色相虽好。体非坚固。能以清净身语意业。而为庄严。是名坚固。复告比丘。如是观察。善思念之。此身五体。有为无常。应行住坐卧四威仪中。系念思惟。清净定智。坚固摄受。比丘。是名五三摩地。比丘复白佛言。世尊。云何四禅定地。佛言。所谓离生喜乐地。离诸欲染一切烦恼故。定生喜乐地。已离寻伺降伏障染故。离喜妙乐地。安住方便作利乐行故。舍念清净地。苦乐已离。善恶心伏。非苦非乐念已离故。方便修习圆满清净。比丘。是名四禅定地。云何四无色定。佛言。所谓空无边处定。一切色想俱已远离。平等持心。如实安住故。识无边处定。内识无边。如实安住故。无所有处定。于一切法。皆无所有故。非想非非想处定。粗想非有。细想非无故。比丘。是名四无色定。尔时比丘复白佛言。世尊。云何名为四无量心。佛言所谓慈无量心。悲无量心。喜无量心。舍无量心。云何名为慈无量心。谓一切时处。慈心随顺。利益众生。不损害他。离诸冤结。以广大心等示众生。愍念救护犹如赤子。于冤亲所而无差别。令断缠盖皆得解脱。如是名为慈无量心。悲心随顺。喜心随顺。舍心随顺。亦复如是。比丘。如是名为四无量心。复有四种苦乐。皆应了知。所谓了知众苦。了知有苦。了知众乐。了知有乐。云何名为了知众苦。谓观一种补特伽罗所著者。贪所著者。嗔所著者。痴于贪不怖因贪故生。苦忧悲随顺。于嗔不怖因嗔故生。苦忧悲随顺。于痴不怖因痴故生。苦忧悲随顺。皆悉了知。于出世间五种善根。精勤修习。所谓信根进根念根定根慧根。次第获得三摩地门。名曰漏尽比丘。此则名为了知众苦。云何名为了知有苦。谓观一种补特伽罗。少贪少嗔少痴。虽少分贪不惧贪过故生。苦忧悲随顺。虽少分嗔不惧嗔过故生。苦忧悲随顺。虽少分痴不惧痴过故生。苦忧悲随顺。皆悉了知。于出世间五种善根。精勤修习。次第获得三摩地门。名曰漏尽比丘。此则名为了知有苦。云何名为了知众乐。所谓一种补特伽罗。皆悉了达此贪嗔痴三不善根。为生苦本。能永除断。于出世间信等五种无漏善根。精勤修习。次第获得三摩地门。名曰漏尽比丘。此则名为了知众乐。了知有乐。精勤修习。次第获得三摩地门。亦如上说。比丘如是四种苦乐。皆应了知。比丘复白佛言。世尊。云何名为四三摩地。佛言。所谓信解受持。如法修行。能断贪欲故。信解受持。如法修行。通达一切诸妙法门故。信解受持。如法修行。获得一切甚深智见故。信解受持。如法修行。获得一切清净妙慧故。云何能断贪欲。佛言比丘。汝等应当于显露处。或林间或树下或空寂处。常坐不卧。安住禅定。应观此身。三十六物和合而成。体非清净。虚幻不实。不应妄生爱念恋着。如是思惟。深生厌离。比丘。如是名为能断贪欲。云何三十六物。佛言。所谓外相十二。发毛爪齿眵泪耵矃涕唾垢汗大小便溺。中相十二。皮肤血肉筋脉骨髓肪膏脑膜。内相十二。脾肾心肺肝胆脏胃。赤白二痰。生熟二脏。比丘。是名三十六物。复告比丘。又诸世间。地中所生。百谷苗稼。须假耕种。亦非清净自然而生。是故汝应于显露处。或林树下。一心安住。如实观察。此身不净。虚假浮脆。眼耳等处。常行垢浊。而不坚固。极可厌离如是安住三摩地门。信解受持。如法修行。永断贪欲。云何通达一切诸妙法门。佛言比丘。汝等应当于显露处。或林树下。或空寂处。常坐不卧。修习禅定。护念怜愍一切众生。而为引导。皆令了悟。一切有为。虚幻不实。譬如优昙钵罗华。颜色殊好。既开敷已。非能坚固。此身非坚。亦复如是。是故汝应于显露处。或林树下。寂静之处。安住禅定。观一切身。有为不实。如梦如幻。方便开示。引导众生。皆令信受爱乐禅定。比丘。是名于三摩地信解受持如法修行通达一切诸妙法门。云何获得一切甚深智见。佛言比丘。安住禅定悟此甚深微妙法已。深心爱乐。决定坚固。昼夜系念。精进无懈。智光遍照。无明暗蔽。永尽无余。譬如虚空密云暗蔽于日中时。云忽退散得见日光。普照一切无有障碍。三摩地门一切智光。除其烦恼无明暗蔽。亦复如是。是故汝应善思念之。如实安住。昼夜无懈。于一切智。坚固摄受。比丘。是名于三摩地门信解受持如法修行。获得一切甚深智见。云何获得一切清净妙慧。佛言比丘。汝等应当于显露处。或林树下。或空寂处。常坐不卧。正念安住。三摩地门。苦受乐受忧受喜受及与舍受。皆已离故胜定熏修。圆满清净。则为安住四三摩地。悉能了知四种信解摄受通达作大导师。若摄受者。若通达者。则为安住善平等地。观察度量。一切智智。如是如是。复告比丘。汝应于显露处。或林树下。或空寂处。苦已离故。乐已离故。忧已离故。喜已离故。舍已离故。胜定解脱。圆满清净。如实安住四三摩地。比丘。是名于三摩地门信解受持如法修行。获得一切清净妙慧。比丘。如是名为四三摩地

佛说法乘义决定经卷上佛说法乘义决定经卷中

        西天三藏明因妙善普济法师金总持等奉　诏译

尔时勇猛甚深比丘。复白佛言。世尊。云何名为住四念处。佛言。比丘。所谓应观内身外身内外身。住有色不净。一切世间。忧悲苦恼。正念了知。观内受外受内外受。住种种诸苦。一切世间。受悲苦恼。正念了知观内心外心内外心。住虚幻无常。一切世间。忧悲苦恼正念了知。观内法外法内外法。住悟无我理。一切世间。忧悲苦恼。正念了知。比丘。是名住四念处。比丘复白佛言。世尊。云何四正断。佛言。所谓未生不善法。以精进力。摄伏断除。令永不生故。已生不善法。以精进力。摄伏断除。令永断灭故。未生善法。以精进力。正念摄受。令生起故。已生善法。以精进力。坚固安住。正念摄受。令增长故。是名四正断。比丘复白佛言。世尊。云何四神足。佛言。所谓欲定断行具神足力。自欲获得思惟依止离欲依止寂灭依止。于此摄受伏除诤论。勤定断行具神足力。自勤获得思惟依止离欲依止寂灭依止。于此摄受伏除诤论。心定断行具神足力。自心获得思惟依止离欲依止寂灭依止。于此摄受伏除诤论。观定断行具神足力。自观获得思惟依止离欲依止寂灭依止。于此摄受伏除诤论。佛言。比丘。是谓四神足。比丘复白佛言。世尊。云何五根。佛言。所谓信根进根念根定根慧根。云何信根。谓于因果而生信乐。轮回世间信行正见业报差别。若作诸业。或善或恶。彼彼业果。如如招报。于自信根。如实了知。是名信根。云何进根。谓于妙法而生信乐。勤加精进。如法修行。是名进根。云何念根。以精进力。积集善行。念念修习。而无退转。是名念根。云何定根。谓于法念。专心一境。而无散动。是名定根。云何慧根。谓于定中。观照一切。通达无碍。是名慧根。比丘复白佛言。世尊。云何五力。佛言。所谓信力进力念力定力慧力。云何信力。谓诸有情。受如来法。信为根本。善能安住。而无流转。若沙门婆罗门。若天魔梵。若世间法。皆能信解。随顺摄受。是名信力。云何进力。谓能勇猛。精进坚固。安住善法。无有疲懈。虽被众苦。而能堪忍。不舍善轭。行大精进。是名进力。云何念力。谓于念中。安住分位。坚固忆持。常无散动。亦无忘失。是名念力。云何定力。谓能摧伏欲染业果诸不善法。乃至安住四禅三昧。是名定力。云何慧力。谓住世间。发起正慧。于圣道行。具足修行。择不善法。离诸苦际。是名慧力。比丘复白佛言。世尊。云何七觉支。佛言。所谓择法觉支。念觉支。定觉支。精进觉支。轻安觉支。舍觉支。喜觉支。云何择法觉支。谓于诸法。而能拣择。思惟依止离欲依止寂灭依止。摄伏诤论故。云何念觉支。谓于诸法。正念修习。思惟依止离欲依止寂灭依止。摄伏诤论故。云何定觉支。谓能发起清净妙慧。思惟依止离欲依止寂灭依止。摄伏诤论故。云何精进觉支。谓于善行。精进无懈。思惟依止离欲依止寂灭依止。摄伏诤论故。云何轻安觉支。谓于诸法。远离粗重。调畅身心。思惟依止离欲依止寂灭依止。摄伏诤论故。云何舍觉支。谓于诸法。远离放逸。令心寂静。思惟依止离欲依止寂灭依止。摄伏诤论故。云何喜觉支。谓于诸法。而生喜受。思惟依止离欲依止寂灭依止。摄伏诤论故。佛告比丘。是名七觉支。比丘复白佛言。世尊。云何八圣道。佛言。所谓正见。正思惟正语正业正命正勤正念正定。云何正见。于所见境。有取有与。有善恶行。有善恶行所招之果。有世出世间一切众生所作之业。乃至须陀洹果。斯陀含果。阿那含果。阿罗汉果。此世他世。微妙善行。皆以正见。通达明了。净修梵行。永断惑障。所作已办。到于彼岸。是名正见。云何正思惟。谓以智慧。分别拣择。令身语意三业无失。离诸过咎。是名正思惟。云何正语。谓能永断妄言绮语恶骂两舌。是名正语。云何正业。谓诸有情永离杀生偷盗染欲。是名正业。云何正命。谓受世间衣服卧具饮食医药。而为资养。非邪命故。是名正命。云何正精进。谓能勇猛。破烦恼魔。常修善行。无有懈怠。是名正精进。云何正念。谓忆过去所修善法。念念摄持。而无错谬。是名正念。云何正定。谓心能安住于奢摩他毗钵舍那。寂然不动。是名正定。佛告比丘。是名八圣道。尔时勇猛甚深比丘复白佛言。世尊。云何十六心念。佛言。所谓念心和合故。和合平等。如实了知。念心相应故。相应平等。如实了知。念法自性和合故。和合平等。如实了知。念法自性相应故。相应平等。如实了知。念法增长和合故。和合平等。如实了知。念法增长相应故。相应平等。如实了知。念身正知和合故。和合平等。如实了知念身正知相应故。相应平等。如实了知。念身行正知和合故。和合平等。如实了知。念身行正知相应故。相应平等。如实了知。念一切身正知和合故。和合平等。如实了知。念一切身正知相应故。相应平等。如实了知。念一切身行正知和合故。和合平等。如实了知。念一切身行正知相应故。相应平等。如实了知。念轻安身行和合故。和合平等。如实了知。念轻安身行相应故。相应平等如实了知。念喜正知和合故。和合平等。如实了知。念喜正知相应故。相应平等。如实了知。念乐正知和合故。和合平等。如实了知。念乐正知相应故。相应平等。如实了知。念心正知和合故。和合平等。如实了知。念心正知相应故。相应平等。如实了知。念心行正知和合故。和合平等。如实了知。念心行正知相应故。相应平等。如实了知。念轻安心行和合故。和合平等。如实了知。念轻安心行相应故。相应平等。如实了知。念喜乐心和合故。和合平等。如实了知。念喜乐心相应故。相应平等。如实了知。念胜解心和合故。和合平等如实了知。念胜解心相应故。相应平等。如实了知。念等引心和合故。和合平等。如实了知。念等引心相应故。相应平等。如实了知。如是乃至无常观。离欲观。寂灭观。出离观。和合平等。如实了知。相应平等。如实了知。佛言比丘。如是名为十六心念。比丘复白佛言。世尊。云何声闻四果。佛言。所谓须陀洹果。斯陀含果。阿那含果。阿罗汉果。如是四果。诸声闻众。皆能信解。如来十号。功德圆满。了知正法。清净流布。无有穷尽。了知僧伽。具足众善。功德圆满。于无我理。皆悉了达。如是信解。净修梵行。具戒定慧。无碍解脱。解脱知见。出世功德。转正法轮。证须陀洹果。功德具足。证斯陀含果。功德具足。证阿那含果。功德具足。证阿罗汉果功德具足。净戒圆满。圣智现前。自在安隐。离诸热恼。清净无染。尽未来际。无有间断。亦无退转。以方便智。观察一切。通达无碍。佛言。比丘。如是名为声闻四果。比丘复白佛言。云何如来十力。佛言。所谓处非处智力。因果相应及不相应。如实了知故。自业智力。三世三业。如实了知故。静虑解脱等持等至智力。皆能了知故。根胜劣智力。信等五根。或软中上。皆能了知故。种种胜解智力。观一切法。胜解明了。皆能通达故。种种界智力。无量世界。种种界性。皆能了知故。遍趣行智力。诸趣遍行。种种差别。皆能了知故。宿住随念智力。过去世境。宿住随念。皆能了知故。生灭智力。诸有情类。生灭因缘。皆能了知故。漏尽智力。根随诸惑。净尽无余故。佛告比丘。如是名为如来十力。比丘复白佛言。云何四无所畏。佛言。所谓正等觉无畏。佛于正觉。诸法等觉。诸法皆悉了知。心无所畏故。诸天魔梵。沙门婆罗门。天人阿修罗等。皆悉恭敬。漏尽智无畏。如来诸漏欲染烦恼。皆已尽故。住安隐地。无有惊怖。于大众中。作师子吼。梵释诸天转轮圣王。尊重赞叹。出障道无畏。如来通达三乘圣道。于一切法。无有障碍故。心无所畏。诸天魔梵。沙门婆罗门等。皆悉恭敬。出苦道无畏。如来于无数劫。修习善法。乃能决定出离苦道。诸天魔梵。沙门婆罗门等。皆悉恭敬佛告比丘。如是名为四无所畏。比丘复白佛言。云何四无碍辩。佛言。所谓法无碍辩。义无碍辩。词无碍辩。辩才无碍辩。法无碍辩于无漏法智无退转故。义无碍辩。于所诠理。智无退转故。词无碍辩随诸众生所有问难。一音解释。普令欢喜故。辩才无碍辩。世出世间。一切诸法。皆悉通达。智无退转故。佛告比丘。如是名为四无碍辩。比丘复白佛言。云何如来十八不共法。佛言。所谓如来无误失。无卒暴语。无种种想。无不定心。无忘失念。无不择舍欲。无减念。无减精进。无减定。无减慧。无减解脱。无减身业随智慧行。语业随智慧行。意业随智慧行。知过去世无著无碍。知未来世无著无碍。知现在世无著无碍。佛告比丘。如是名为十八不共法。比丘复白佛言。云何如来三十二相。佛言。所谓足下平满高下等触相。足下千辐轮文网毂圆满相。手足柔软如睹罗绵相。手足指间咸有网鞔金色交络相。手足诸指纤长圆满相。足跟广长与趺相称相。足趺修高充满柔软与跟相称相。双腨纤圆如翳泥耶鹿王腨相。双臂修圆如象王鼻平立过膝相密处深隐如龙象王相。身诸毛孔一一毛生柔软绀青右旋宛转相。发毛上靡柔软绀青螺文右旋相。身真金色光洁晃曜众宝庄严相。皮肤薄润尘垢不住相。手足掌中颈及双肩七处平满相。肩项之间妙好充满相。膊腋清净悉皆充实相。容仪圆满端严殊妙相。身相修广端直相称相。体相纵广量等周匝圆满如诺瞿陀相。其身上半如师子王威容广大相。身常放光面各一寻相。具四十齿齐平净密相。四牙锋利白逾珂雪相。于诸味中得最上味相。舌相广薄遍覆面轮相。梵音洪雅随众等闻相。眼睫齐整犹若牛王相。其目绀青鲜白红环间饰皎洁相。面如满月双眉皎净如天帝弓相。眉间白毫右旋宛转如睹罗绵鲜白光净相。其顶上现乌瑟腻沙高显周圆如天盖相。佛告比丘。如是名为三十二相

佛说法乘义决定经卷中佛说法乘义决定经卷下

        西天三藏明因妙善普济法师金总持等奉　诏译

尔时世尊复告勇猛甚深比丘言。如来所现三十二相金色之身。皆由过去修种种行之所感得。亦为汝等。分别解说。时比丘众唯然谛听。佛言。所谓诸佛世尊。经无量劫。修菩萨行。于戒禁忍及惠舍中善能安住。坚固平等故。感得足下平满之相。有情苦恼。方便救护。孝顺父母。严饰布施。未尝退转故。感得足下千幅轮文相。给侍尊长。涂身按摩。沐浴衣服。庄严之具。未尝退转故。由是感得手足柔软相。以四摄法。饶益有情。平等护念。无有差别。由是感得手足指间金色网挽相。于诸尊长。恭敬和顺。于他有情。远离损害及不与取。能以妙法。密护众生。由是感得手足诸指纤长圆满相。以方便智。劝导覆护一切有情。令修善行。未尝退转故。由是感得足跟广门与趺相称相。足趺修高充满柔软与跟相称相。自于正法。如实摄受。皆能了解。广为人说及正为他善作给使。是故感得双腨纤圆如翳泥耶鹿王腨相。修习善行。无有懈惓。令诸善法展转增长。是故感得双臂修圆平立过膝相于被他摈无依有情。能以正法。慈悲摄受。令知惭愧。是故感得密处深隐如龙象王相。自善观察明智贤善乐欲亲近唯一住故。依一支故。入微义故。又能蠲除客尘垢故。是故感得身诸毛孔一一毛生柔软绀青右旋宛转相。发毛上靡柔软绀青螺文右旋相。能施悦意法喜饮食骑乘衣服严饰之具。资身什物。永离嗔恚。由此感得身真金色皮肤薄润尘垢不住相。广以上妙肴馔饮食。普施众生。皆令充足。由此感得其身七处皆悉平满相。于诸有情。随所生起。如法所作。能为上首。而作助伴。离于我慢心无犷悷。能为有情兴利益事。由是感得其身上半如师子王于一切事禀性勇决。又复感得肩项圆满膊腋充实容仪端严身相修广。能自防护身语意业。见疾病人给施良药。于不平等事业。皆不摄受。于界互违能令随顺由此感得身相圆满如诺瞿陀常光一寻。远离一切破坏亲友离间语言设已乖离能以善言方便和合。由是感得具四十齿齐平净密。修广大慈思惟法义。由是感得四牙锋利白逾珂雪。愍念众生犹如一子。方便救护。给施医药。由是感得于诸味中得最上味。远离杀害。修慈心故。于广大法。能正行故。由是感得其顶上现乌瑟腻沙。舌相广薄。遍覆面轮。常修谛语爱语法语及悦意语。由是因缘。得大梵音。言词辩雅。能悦众意。于诸世间。行大慈悲。怜愍饶益一切有情。由是感得目绀青色睫如牛王。见有德者。如实赞叹。称扬其美。由是感得面如满月。眉若帝弓眉间白毫。有旋宛转。鲜白光洁。如睹罗绵。佛告比丘。如是诸佛三十二相。往昔因缘。应如是知。比丘复白佛言。云何世尊八十种好。佛言。所谓世尊指爪狭长薄润光洁。世尊诸指纤圆佣直。世尊手足各等指间充密。世尊骨节深隐不现。世尊手足如意柔软。世尊筋脉盘结深隐。世尊两踝俱隐不现。世尊行步庠序如龙象王。世尊进止仪雅犹如鹅王。世尊右旋回顾举身随转如龙象王。世尊肢节佣圆妙善安布。世尊容貌敦萧无有所畏。世尊身支安定无有掉动。世尊骨节交络无隙犹如龙蟠。世尊膝轮圆满殊妙。世尊密处清净无垢。世尊肢节稠密坚固。世尊身相周匝端严。世尊身光常自照曜。世尊脐深圆妙殊异。世尊脐厚不窊不凸。世尊身体光洁离垢。世尊皮肤无疣赘等。世尊手掌平满润泽。世尊腹间方正柔软。世尊手纹深长明直不断。世尊唇色丹辉如频婆果。世尊面如满月端严称量。世尊舌相广长遍覆面轮。世尊梵音圆满犹如天鼓。世尊鼻高修直其窍不现。世尊诸齿方整齐密。世尊四牙锋利鲜白。世尊目净绀青青白分明。世尊眼相修广如青莲华叶。世尊上下眼睫齐整稠密。世尊双眉不白长致细软世尊身分上半威严最上如师子王。世尊额广圆满平正殊妙。世尊耳厚修长轮埵圆满。世尊两耳绮丽齐平离诸过失。世尊仪容能令见者无舍无染皆生恭敬。世尊双眉绮靡顺次其色绀青。世尊双眉高显光润犹如初月。世尊首发绀青修长稠密不白。世尊首发香洁细软润泽旋转。世尊首发齐整光净。世尊首发坚固不落。世尊首发尘垢不着。世尊身分充实坚固。世尊身相修长端直。世尊诸窍清净妙好。世尊身相势力殊胜无与等者。世尊身相众乐瞻仰无有厌足。世尊面轮修广相称皎洁光净如秋满月。世尊颜貌舒泰光显含笑先言唯向不背。世尊面貌光泽熙怡远离颦蹙无青赤色。世尊肢体清净无垢亦无臭秽。世尊所有身毛孔中常出如意微妙之香世尊面门常出最上殊胜之香。世尊首相周圆妙好犹如天盖世尊身毛光净绀青如孔雀项红辉绮错。世尊法音随众等闻应理无差世尊顶相无能见者。世尊手足指节分明庄严妙好。世尊行时其足去地如四指量而现印纹。世尊自持不待他卫身无倾动亦不逶迤。世尊威德远震一切嗔心见喜恐怖见安。世尊音声不高不下随众生意和悦与言。世尊能观诸有情类言音意乐而为说法。世尊一音演说诸法随有情类各令得解。世尊说法咸依次第必有因缘言无不善。世尊等观诸有情类赞善毁恶而无爱憎。世尊所为先观后作轨范具足令识善净。世尊相好一切有情不能观尽。世尊顶骨坚实圆满。世尊颜容无衰老相。世尊手足及胸臆前皆有吉祥喜旋德相。佛告比丘。如是名为八十种好。尔时世尊说是经已。复告勇猛甚深比丘言。吾今所说法乘妙理决定之义。所诠法要。初中后善。利益安乐。汝善诵持敷演分别。引导众生。令修梵行。一食如法。三衣具足。住显露处。或住冢间。或林树下。或空寂处。修头陀行。常勤精进。无有懈怠。永离惑染。究竟解脱。时勇猛甚深比丘与俱来会中诸大比丘等。及天人阿修罗等。一切大众。闻佛所说。欢喜作礼。信受奉行

佛说法乘义决定经卷下


佛说法集经

    No. 761

佛说法集经卷第一

        元魏天竺三藏菩提流支译

如是我闻。一时婆伽婆在虚空界法界差别住处。普皆严洁清净无垢。诸佛如来福智庄严如意所化。超于三界有为数行。过一切譬喻不可思议。诸佛如来果报所生。于最胜楼阁妙宝台上。与大比丘众千二百五十人俱。皆是阿罗汉。具四无碍得俱解脱。与菩萨摩诃萨众皆悉清净。得常无常三昧境界。观一切智智行处。得无中无边法界彼岸。满足一切菩萨所愿。具足一切菩萨自在。得十无尽无量功德以自庄严。具足一切菩萨陀罗尼三昧四无碍智。与大威德天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释提桓因梵天四天王其数百千万。及眷属亦百千万。尔时婆伽婆所说经。名入一切修行次第法门。所谓见诸贤圣能生信心。得信心者成就欲心。得善法欲心者成就不断心。得不断心者成就义心。得义心者成就增上心。修行檀波罗蜜者成就大富故。修行尸波罗蜜者成就人天果报故。修行羼提波罗蜜者成就一切庄严故。修行毗梨耶波罗蜜者成就一切佛法故。修行禅波罗蜜者成就调柔心故。修行般若波罗蜜者成就过一切世间智故。修行方便波罗蜜者成就一切无障碍故。修行愿波罗蜜者自然成就一切事故。修行力波罗蜜者成就不可破坏故。修行智波罗蜜者成就一切世间归依处故。出家者为成圣道故。着染衣者远离一切世间事故。乞食者为破一切憍慢心故。住阿兰若处者成就无怖畏故。处宴坐者成就神通无量等故。闻法受持者成就四无碍故。修念方便者成就陀罗尼故。修意方便者成就差别法智故。修坚固行者成就无大众畏故。修乐说方便者成就记说不错谬故。修阴方便者成就般若差别故。修界方便者成就微细般若差别故。修入方便者成就远离内外迷心故。修谛方便者成就不诳一切众生故。修念处方便者成就随顺一切佛意故。修舍摩他方便者成就寂静心故。修毗婆舍那方便者成就调伏心故。修不高心者成就一切智智满足故。修不憍慢者成就敬信心故。修不诳一切众生者成就乃至能令一人信故。修行坚固般若者成就一切天人行故。修如说修行者成就满足善知识法故。修行内思惟者成就自然觉故。修行降伏心者成就法王义故。修行不吝身者成就佛身故。修行恭敬三宝不坏心者成就是处非处智力故。修行善巧所作者成就业报智力故。修行不毁他智者成就诸根利钝智力故。修行入微细因缘集智者成就种种性智力故。修行三宝中教化众生者成就信欲智力故。修行一切处不坏威仪为诸众生平等说法者成就一切至处道智力故。修行禅法中教化众生者成就禅定三昧三摩跋提垢净起智力故。修行正道为失正道众生示正道者成就天眼智力故。修行与一切众生正念者成就宿命智力故。修行与一切众生白净法者成就漏尽智力故。修行多闻教化众生者成就无大众威德畏故。如是世尊说此名入一切修行次第法门时。彼大众中有二菩萨。一名无所发。二名奋迅慧。与诸眷属。于别楼阁宝堂上坐。此二菩萨于彼处坐起如是心。有诸菩萨摩诃萨广大法集我等应说。作是语已奋迅慧菩萨。语无所发菩萨摩诃萨言。善男子。云何菩萨摩诃萨知诸佛如来应供正遍知生。云何菩萨摩诃萨知诸佛如来真实身。云何知诸佛如来为他因缘故成。云何知诸佛如来真实常住。云何菩萨知诸佛如来大般涅槃。云何菩萨知诸佛如来行。云何菩萨知譬喻相应。云何菩萨知几种佛。云何菩萨知诸佛如来唯依言辞说法。云何菩萨知空义。云何菩萨知空所对法。云何菩萨知说空者。云何菩萨知法师义。云何菩萨知与法师相应譬喻。云何诸菩萨知不共住法。云何诸菩萨知应化事。云何菩萨知诸善根胜妙果报。善男子。云何菩萨知诸无漏善根得胜妙果报

尔时无所发菩萨摩诃萨。语奋迅慧菩萨言。善男子。汝善能问此甚深法集。善男子。此是胜妙广大法集法门。善男子。汝今谛听。我当承佛威神如来加力而为汝说。何者是广大法集法门

善男子。菩萨入十种法行。能知如来应供正遍知生。何者为十。所谓远离一切所作分别心故而生。转离一切心意意识身故而行寂静。一切生灭故而示现生灭行。依过去行起故而行一切果报行。得无障碍法界所作集故而集一切作业。以十大愿为首满足百千万阿僧祇愿庄严故而为庄严。得一切诸佛如来所加加故名诸佛加。随教化一切众生善根所作故而为一切作业集起。大慈大悲故而方便教化众生。随时住持众生善根吹心故而得深心。随众生心行差别故而现种种生。善男子。是名菩萨摩诃萨入十种法行。能知如来应供正遍知生

又善男子。菩萨摩诃萨。入十种法行能知如来真实身。何者为十。所谓真实为体。以清净无垢故。法界为体。以无差别故。实际为体。以遍至故。空无相无愿为体。以真实寂静故。幻化焰响水中月乾闼婆城旋火轮为体。以为化因缘而有故。不生不灭为体。以无物故。一切法自性为体。以自性鲜白故。过去不来。以无间故。未来不去。以无形故。现在不住。以过去未来无故。善男子。是名菩萨摩诃萨入十种法行。能知如来应供正遍知真实身。又善男子。菩萨摩诃萨入十种法行。知如来为他因缘故成。何者为十。所谓以不放逸行为种子故而成善法果以智慧方便生故而无过失。以尸波罗蜜行为足故而能善去。以菩提心为命根故而不死灭。以舍摩他毗婆舍那为手故而能善巧作业。以信业果报为眼故而现见智慧。成就修行一切诸波罗蜜故而善住无上处。依四摄行住故而修行坚固。修空慧为首故而无所分别。修行不疲惓不惊不怖不畏故而不舍一切众生所作事业。善男子。是名菩萨入十种法行。能知诸佛如来应供正遍知为他因缘故成

善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知真实常住。何者为十。所谓远离一切嗔恨过故不取我我所事。常为一切众生作善法依止故犹如良医。过去善愿满足故所得不退。依彼众生起大慈故善作诸业。唯为他事起心故能利益一切众生。舍自利益故代他受苦。远离分别涅槃心故以世间涅槃为一味相。不疲惓行故一切所作自然成就。远离一切所求事故无骨肉身。无障碍相故于一切处示现涅槃。善男子。是名菩萨入十种法行。能知诸佛如来应供正遍知真实常住

善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知大般涅槃。何等为十。所谓毕竟离一切烦恼障智障故。遍知我空法空无我故。得具足转离意生法身故。于一切众生作佛事自然不休息得具足智故。得一切诸佛无差别法身故。远离世间涅槃二心故。清净一切法根本故。得修行一切法不生不灭智故。得真如法性实际平等智故。得一切法自性涅槃性平等智故。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知大般涅槃。复次善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知得大般涅槃。何者为十。所谓一切烦恼求为根本因求而起。诸佛无有彼求则离烦恼。离烦恼故得大涅槃。以不求故名为如来不取一法。不取者不行不住。以不取故名得涅槃。云何如来不行不住。离彼二法法身不灭。不灭不生是故如来名得涅槃。云何如来不生不灭。彼佛如来无能说者。不可说故。是名如来得大涅槃。无我无众生唯是生灭法。离彼依止法。是故如来名得涅槃。一切烦恼随烦恼等唯是客尘。法性寂静不来不去。是故法性非客非主法性平等。是故如来得大涅槃。真如为实体。非真如法即是虚妄。实体即真如真如即如来。是故如来名得涅槃。实际不戏论余法即戏论。诸佛如来究竟实际。是故如来名得涅槃。不生为实。余生灭法即是颠倒虚诳妄语。佛不妄语离于虚妄真实为体。是故如来名得涅槃。不实法可作实法不可作。如来即实法身身即无为。是故如来名得涅槃。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知大般涅槃。复次善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知。大般涅槃。何者为十。所谓布施及布施果报无我无我所。如来善知布施及布施果报远离分别心无有颠倒。是故如来名得涅槃。持戒及持戒果报无我无我所。如来善知持戒及持戒果报。远离分别心无有颠倒。是故如来名得涅槃。忍辱及忍辱果报无我无我所。如来善知忍辱及忍辱果报。远离分别心无有颠倒。是故如来名得涅槃。精进及精进果报无我无我所。如来善知精进及精进果报。远离分别心无有颠倒。是故如来名得涅槃。禅定及禅定果报无我无我所。如来善知禅定及禅定果报。远离分别心无有颠倒。是故如来名得涅槃。般若及般若果报无我无我所。如来善知般若及般若果报。远离分别心无有颠倒。是故如来。名得涅槃。一切众生非众生。一切法无我。如来远离一切颠倒相。远离一切颠倒法相。是故如来名得涅槃。有我相者则有所求。以有求故有烦恼染。离我相者无一切求。以无求故离烦恼染。以离烦恼染。是故如来名得涅槃。有为法可量无为法不可量。如来远离有为无为法故。唯有无为法身不可限量。是故如来名得涅槃。如来若离于空。不见众生亦不见法。空者即是法。法者即是法身。法身者即是如来。是故如来名得涅槃。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知大般涅槃。又善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知行。何者为十。所谓法持为持善清净法故。众生持为持自愿满足故。自利利他无有二相以同事行故。如清净摩尼无有分别以不分别法界清净故得安隐处。灭除一切众苦刺故得无畏处。永断一切烦恼怨故得无大众威德畏。远离一切法中疑故降伏一切诸魔怨敌。得一切众生平等心故能为无量百千万亿应化等身。得善清净神通力故善巧示现一切色像无所障碍。得如虚空善清净故。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知行。复次善男子。菩萨摩诃萨。入十种法行。知诸佛如来应供正遍知行。何者为十。所谓如来不起是心。世间之法多诸过失。涅槃寂静无量功德。如来于世间涅槃得平等心。不住世间不住涅槃。而不弃舍利益一切诸众生故。善男子。诸佛如来不起是心。是诸众生颠倒智慧。种种烦恼随烦恼染。我能度脱如是众生。而诸如来依过去愿行。随诸众生根性信等。彼彼行中无所分别自然成故。善男子。诸佛如来不起是心。我说如是修多罗。如是祇夜。如是和伽罗那。如是伽陀。如是优陀那。如是尼陀那。如是伊谛越多伽。如是阇陀伽。如是毗佛略。善男子。诸佛如来不起是心。我说阿浮陀达摩。而诸如来无所分别。彼彼众生随所闻法自然成故。善男子。诸佛如来不起是心。我为乞食入某国土大小城邑及诸聚落。我至如是刹利婆罗门毗舍首陀国王王子大臣人民诸众生所。而诸如来智慧为首。身口意业自然成故。善男子。诸佛如来无有饥渴大小便利。身无羸损疲乏病苦。为众生故现行乞食。然诸众生谓如来食。而诸如来实不食也。示现教化诸众生事。于一切事无所分别自然成故。善男子诸佛如来不起是心。此诸众生下中上根。我为此等下中上根诸众生类。随顺宣说下中上法。而诸如来无分别心。所说之法自然而成。不增不减随器受故。善男子。诸佛如来不起是心。若诸众生不供养我不恭敬我毁骂于我。如是众生我不教化。复有众生供养恭敬尊重赞叹给侍于我。如是众生我应教化。而诸如来寂静三昧。慈悲普覆于彼众生。自然住于平等法故。善男子。如来无高心无下心无憍慢心。无爱心无贪心无嗔心无随贪心。无著心无碍心无障心无杂心。无烦恼心无随烦恼心。无嗔心无痴心。无随嗔心无随痴心。善男子。而诸如来。自然寂静寂静境界。住于赞叹寂静境界故。善男子。如来无有一法不知不解不觉。于一切境界毕竟满足现前悉知。而诸如来见彼彼事彼彼众生所作诸业自然成故。善男子。如来见诸众生修行成就不以为喜。见诸众生不修行者亦不生忧。而诸如来。于修正行众生无障大慈常现在前。于邪行众生无障大悲常现在前。善男子。是名菩萨摩诃萨入十种法行。能知如来应供正遍知行。善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知譬喻相应。何者为十。善男子。譬如日出于上中下。诸众生等若信不信若恭敬不恭敬。平等出现平等普照。善男子。如来应供正遍知亦复如是。于上中下诸众生等。若信不信若恭敬不恭敬。平等出现平等智慧光明普照。善男子。譬如虚空于一切众生无有障碍。而彼虚空为诸烟云尘雾等事之所曀障。善男子。诸佛如来亦复如是。于一切众生无有障碍。而为烟云尘雾我见烦恼客尘所障不见如来。不受如来功德利益。善男子。譬如树木虽有火性以无因缘而不现用。善男子。诸佛如来亦复如是。虽有无量神力自在。以诸众生远离精进信等因缘。不出于世不作佛事。善男子。譬如种种熏色置一器中熏种种衣。复以众杂染色置一器中染所熏衣。随其所熏受色不同。而彼诸色不生分别差别之心。善男子。诸佛如来亦复如是。种种善根功德庄严。随诸众生信等熏异。见佛如来所受功德差别不同。而佛如来不生分别差别之想。善男子。譬如诸河流水盈满。若人赞毁悉皆顺流。若逆流者无有是处。善男子。诸佛如来亦复如是。若人赞毁悉皆常随智慧而行。若随憍慢无有是处。善男子。譬如甘蔗若人割截若不割截不失甘味。善男子。诸佛如来亦复如是。若人亲近供养恭敬。及不亲近供养恭敬。终不舍于解脱甘味。善男子。譬如大地其性安固。于诸众生无所分别。有人欲得求其果实。若能耕种随时随时耘除草秽。彼人至时收获果实。若不耕种耘除草秽。是人终不得其果实。善男子。诸佛如来亦复如是。如彼大地寂然常住。于诸众生无所分别。若有众生求佛功德。能生信心供养恭敬。彼人成就功德果实。若不生信供养恭敬。则不能得功德果实。善男子。譬如有人若于栴檀龙恼等香。嗔谤毁骂然后涂身。而彼栴檀龙恼等香。终不为是而不出香。善男子。诸佛如来亦复如是。若人嗔谤毁骂而复亲近供养恭敬如说修行。然诸如来常与众生具足功德。善男子。譬如桥梁平坦王道。于诸众生上中下性。有往来者平等而住。与无障碍游行之乐。善男子。诸佛如来亦复如是。于诸众生上中下性。有修行者平等而住无有高下。与无障碍修行之乐。善男子。譬如雪山有药树王名曰善见。彼药树王其有见者即得远离一切病苦。善男子。诸佛如来亦复如是。众生见者远离一切烦恼病苦。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知譬喻相应

善男子。菩萨摩诃萨入十种法行。能知诸佛。何者为十。所谓习气佛。果报佛。三昧佛。愿佛。心佛。实佛。同佛。化佛。供养佛。形像佛。善男子。云何习气佛。习气佛者。诸波罗蜜所得果报。诸波罗蜜能成彼法。彼依诸波罗蜜而生。是名习气佛。善男子。云何果报佛。果报佛者。依彼习气果报佛所生。以彼果报成色身报佛。依众生住持依法力住持。是名果报佛。善男子。云何三昧佛。三昧佛者。随如来入何等三昧。以彼所入三昧之力。自然不复作心。能现百千万佛。依彼三昧住持力故而能示现。是名三昧佛。善男子。云何愿佛。愿佛者。诸菩萨等作如是愿。随何等何等众生。以何等因何等法。示现种种色身度彼众生。彼彼众生如是如是。示现形色状貌威仪去来。随彼众生应以佛身得度者。而现佛身化彼众生。是名愿佛。善男子。云何心佛。心佛者。诸菩萨等得心自在。是诸菩萨依心自在。于种种法随心成就。此诸菩萨随彼众生。应见佛身而可化者。即自在心即成佛身。是名心佛。又善男子。复有异义诸众生等。自心清净能见于佛。知佛信佛是名心佛。善男子。云何实佛。实佛者。远离一切诸烦恼染。不可思议无垢清净。种种形色三十二相八十种好大丈夫相毕竟成就。佛微妙色而可现见。是名实佛。善男子。云何同佛。同佛者。与一切众生。共其资业受用饮食行住去来威仪进止。是名同佛。善男子。云何化佛。化佛者。诸佛如来及诸菩萨。得示现一切色身三昧。彼诸佛菩萨成就自在。大慈大悲皆能示现。化佛色身度诸众生。是名化佛。善男子。云何供养佛。供养佛者。有人若师若和上。如佛世尊。当如是见。彼人于师和上如佛世尊。应如是见供养供给。依彼受法满足佛法成就佛法。是名供养佛。善男子。云何形像佛。形像佛者。有人若他作佛像。若自作佛像。以一切供养恭敬等事。而供养恭敬尊重赞叹亲近给侍。此人如是依彼形像。满足佛法成就佛法。是名形像佛。善男子。是名菩萨摩诃萨入十种法行。能知十种佛

善男子。菩萨摩诃萨入十种法行。知诸佛如来应供正遍知唯依言辞说法。何者为十。所谓说阴唯是言辞说界说入。说众生说业。说生说老说死。说死已更生。为离彼事故。说涅槃亦是言辞。善男子。云何说阴唯是言辞。善男子。第一义中无彼色阴。若第一义中有色阴者。舍彼色阴即是断灭。舍彼法者即是解脱。若如是者。第一义中则为有色及以解脱去住之处。而义则不然。是故说色阴唯是言辞。善男子。受想行识亦复如是。善男子。第一义中无彼识阴。若第一义中有识阴者。舍彼识法即是断灭。舍彼法者即是解脱。若如是者。第一义中则为有识及以解脱去住之处。而义则不然。是故说识唯是言辞。善男子。界入之义亦复如是。善男子。云何说众生唯是言辞。善男子。唯是有为无有众生。若众生实有者。不应同阴尽灭。若同阴尽灭应如虚空。若不尔者应同五阴。俱是有为而义则不然。是故说众生唯是言辞。善男子。云何说业唯是言辞。善男子。作业者非有非无。若作业是有者。作业之者无。彼作者犹如虚空。又如阴是有为。作者亦复如是。以是义故。无彼作者亦无作业。犹如虚空。云何得有作者。是故无有作业者。离彼作者云何有业。是故说业唯是言辞。善男子。云何说生唯是言辞。善男子。第一义中无生。若第一义中有生者。生即是常。若如是者生则非生。又复生能生生者。生能恼者竟为是谁。是故说生唯是言辞。善男子。云何说老唯是言辞。善男子。第一义中无老。若第一义中有老老者。则无一人而有老者。又复若有老者。即是少时老。若少时老非老时老。以少者无老。是故少时无老。若离于老云何名老。如是老不能老。若言老能老者。即是少时老。是故说老唯是言辞。善男子。说死唯是言辞。善男子。第一义中无死。若第一义中有死者。即是死法可得。若可得者。唯应一人得。余不应死而更有死者。是故第一义中无有死法。又复死者无所从来去无所至。而是死法体性空寂。是故说死唯是言辞。善男子。云何说死已更生唯是言辞。善男子。第一义中死更不生若第一义中死更生者。死即是生生即是死。若如是者死生即是一法。又复应是二身。一者能托生。二者已受生。若有受生者。必有五阴受生。何以故。以离五阴无彼识生。以依色受想行等法识心得生。以依止诸阴识缘彼住。若离依止则彼识心一念不住。如彼法住如是受生如种生芽。是故说死已更生唯是言辞。善男子。云何为离彼事说般涅槃唯是言辞。善男子。第一义中无彼涅槃。涅槃者知世间寂灭名为涅槃。而非即世间名为涅槃。亦不离世间而有涅槃。世间者如梦如幻。非有非无亦非有无。而是有法。如是非有非无亦非有无如是名生。如是非有非无亦非有无如是名灭。而寂灭一切世间相名为涅槃。如是想如阳焰受如泡沫。如彼阳焰泡沫生灭不实。世间涅槃亦复如是。是故说世间涅槃唯是言辞。善男子。是名菩萨摩诃萨入十种法行。能知诸佛如来应供正遍知唯依言辞说法

善男子。菩萨摩诃萨入十种法行。善能知空义。何等为十。所谓知无我空无众生。无命无寿者。无造者。无生无灭。无作无教者。无增上者。善男子。云何菩萨摩诃萨知无我空。善男子。空者非有非无。善男子。若空是有者。空即有为。如其实有应即是常。善男子。若空非无者。空即非空。是故彼空非有非无。如是名为知无我空。善男子。云何知无众生空。善男子。众生非空非不空。若众生空者。杀生之业应无有罪。若众生不空者。即应是常。是故如来说众生非常非不常。非有为非不有为。如是名为知众生空。善男子。云何知无命空。善男子。空者不生不死。何以故。善男子。眼空离我我所。云何眼空离我我所。彼法不生不灭故。如是耳鼻舌身空离我我所。云何耳鼻等空离我我所。彼法不生不灭故。如是名为知无命空

善男子。云何知无寿者空。善男子。空者不名寿者之数。彼阴界入皆悉是空。依彼阴界入等而有假名寿者。以假名故彼有无相不可得说。如是名为知无寿者空。善男子。云何菩萨知无造者空。善男子。若离于空。无有一法名为造者。又若空能有造者。无有是处。如是名为知无造者空。善男子。云何知不生空。善男子。空法不生。若空可生即非是空。如是空即非空。若本无空则无空法。又空始生者此即非空。如是名为知无生空。善男子。云何知无灭空。若法生者则有其灭。空法不生云何有灭。如是名为知无灭空。善男子。云何知无作空。善男子。空非他作亦非自作。阴界入等皆悉是空。依阴界入而有空法。如是名为知无作空。善男子。云何知无教者空。善男子。无有一人教于空者。造作如是种种等事。如是名为知无教者空。善男子。云何知无增上者空。善男子。空无境界离于境界。远离心意意识。如是名为知无增上者空。善男子。是名菩萨摩诃萨入十种法行。善能知空义。善男子。菩萨摩诃萨入十种法行。能知空所对法。何等为十。所谓无明法爱法业法识法取法见法疑法邪取法慢法掉法。善男子。是名十种空所对法。善男子。无明有二种能四种因。何者二能。一者烦恼障。二者是智障。何者是四因。所谓。贪欲界因。贪色界因。贪无色界因。贪无有因。善男子。爱有二种因四种求。何者二种因。一者有支根本。二者资生根本。何者是四种求。一者欲爱。二者色爱。三者无色爱。四者无有爱。善男子。业有一种起因三种相三种果报。善男子。何者一种起因。所谓为心。何者三种相。所谓身口意业。善男子。何者三种果报。所谓黑黑果报。白白果报。黑白黑白果报。善男子。何者是识。所谓六种。眼耳鼻舌身意等识。是名六种识。此识复有三种。何者是三。一颠倒念。二不颠倒念。三者无念。善男子。何者是颠倒念。所谓念欲界。念色界。念无色界。何者是不颠倒念。谓念小乘涅槃。何者是无念。所谓离彼二念名为无念。云何离彼二念。谓念无上诸佛法故。善男子。取因有四种。所谓欲取。见取。戒取。我取。善男子。何者是见取。见取有二种。所谓邪智见智。邪智者。谓邪见智故。见智者。谓阿罗汉妄见涅槃妄求涅槃。是名见智。如是见智诸佛所诃。善男子。何者是疑。疑有二种。一者障于大乘。二者障于正位。善男子。云何名为障大乘疑。谓声闻等其心狭劣。悕求速证小乘菩提。何以故。彼作是念。佛道长远无量诸行难可得成。是故我当求声闻乘速离诸苦。以是义故退于大乘。是名障大乘疑。何者障正位疑。以彼疑故不证正位。不得菩萨大乘智地。是名障正位疑。善男子。何者是邪取。邪取者。所谓檀等诸行求有果报。起如是心。我修如是布施持戒等行。取彼天人胜乐果报。如是等一切邪求。是名邪取。善男子。何者是慢。起高下心名之为慢。彼下于我我高于彼。如是高下胜负等心。是名为慢。善男子。何者是掉。掉有二种。一者能生烦恼。二者动乱生烦恼者。妄想分别见色为净。以是因缘身口意业皆悉颠倒。是故为诸圣人所诃。何者是动乱。动乱者。彼于出世道中。其心不住故。是名为掉。善男子。是名菩萨摩诃萨入十种法行。能知空所对法。善男子。菩萨摩诃萨。入十种法行。知能说空者。何等为十。所谓不破坏者。不扰动者。不贪不厌者。不修行非不修行者。不诤不竞者。不增不减者。闻说一切有为诸行自性寂灭能忍辱者。闻诸凡夫不生一法诸佛如来不灭一法不惊不怖者。闻世间性涅槃性是二平等不生疑者。闻诸佛如来常乐妙身无尽法身正信正入者。善男子。云何名不破坏能说空者。善男子。能说空者。世间之法所不能坏。何以故。心不依止世八法故。何者为八。而不依止于利衰等事。不生忧喜称讥之音。而无欣戚毁誉二法。心不高下。于诸苦乐不贪不厌。如是世法不能破坏。是故名为不破坏能说空者。善男子。是名菩萨不破坏能说空者。善男子。云何知不扰动能说空者。善男子。能说空者。不取于法不舍于法。于何等法而不取舍。即知是法空。即见是法空。若能如是不取不舍。名为心不扰动能说空者。善男子。云何名不贪不厌能说空者。善男子。能说空者。无法可贪无法可厌。于何等法而不贪厌。即知是法空。即见是法空。若于诸法生贪厌者。如是菩萨。不名知空不名见空。若能于法心无贪厌。名不贪不厌能说空者。善男子。云何名不修行非不修行能说空者。善男子。能说空者。不修行法非不修行法。能说空者。于何等法不修行非不修行。即知是法空。即见是法空。非不修行助菩提法。若能如是知空见空。是名菩萨不修行非不修行能说空者。善男子。云何不诤不竞能说空者。善男子。其说空者。若与众生有所诤竞。则不知空不见于空以是菩萨。于诤竞者知见空故无所诤竞。如是名为不诤不竞能说空者。善男子。云何知不增不减能说空者。善男子。能说空者。不知一法增不知一法减。不见一法增不见一法减。若于诸法见增减者。如是菩萨则不知空不见于空。若能知空见空。即于诸法不见增减。是名不增不减能说空者。善男子。云何闻说一切有为诸行自性寂灭其心安忍能说空者。善男子。能说空者。不见一法生不见一法灭。是名闻说一切有为诸行自性寂灭其心安忍能说空者。善男子。云何闻诸凡夫不生一法诸佛如来不灭一法不惊不怖能说空者。善男子。能说空者不生是心。此是凡夫此是诸佛。知佛如来及诸凡夫其相平等。若见凡法是下佛法为胜。如是菩萨不知见空。若闻凡夫不生一法即是凡夫空。若闻诸佛不灭一法即诸佛空。如是闻说凡夫不生一法诸佛如来不灭一法不惊不怖是名不见一法生不见一法灭能说空者。善男子。云何知世间性涅槃性是二平等不生于疑知能说空者。善男子。若见离世间性有涅槃性。如是菩萨不知见空。若见世间真如性涅槃真如性。此二法性唯是一相。所谓无为之性。若见世间真如性涅槃真如性其相平等无有高下。不生于疑不惊不怖。是名知世间性涅槃性二法平等能说空者。善男子。云何闻说诸佛如来常乐妙身无尽法身正信正入能说空者。善男子。若生是心。诸佛如来是尽灭身。如是菩萨不知见空。何以故。诸佛如来身是真如空身。非客尘烦恼随烦恼身。如是名为闻说如来常乐妙身无尽法身能说空者。善男子。是名菩萨知闻说诸佛如来常乐妙身无尽法身正信正入能说空者。善男子。是名菩萨摩诃萨入十种法行知能说空者

佛说法集经卷第一佛说法集经卷第二

        元魏天竺三藏菩提流支译

善男子。菩萨摩诃萨入十种法行。能知法师义。何等为十。所谓成就多闻。成就总持。成就闻慧海聚集闻慧藏。而于此闻慧不生高心。具足义无碍法无碍辞无碍乐说无碍。而不休息希求精进。知世知时知节知法知众生。而不舍于修敬长德所修行。知论知义知可化众生。而不舍于咨问之事。成就少欲知足等行。而不舍于供给尊者之业。成就妙静寂静柔软心不怯弱。而不舍于惭愧正行。成就甚深不可称量具足功德。而能示现世间垢行不得解脱。为随顺众生故。成就自性直心软心安乐心。而能现同一切破戒等行。成就布施持戒忍辱精进禅定智慧。而于一切处不生着心不分别境界。远离一切贪等随烦恼刺。而不舍为一切众生断烦恼精进之行。善男子。是名菩萨摩诃萨入十种法行能知法师义。复次善男子。菩萨摩诃萨。入十种法行。能知法师义。何等为十。所谓菩萨摩诃萨。远离一切诸求而不舍一切菩萨摩诃萨功德精进。善知一切诸法寂灭不证菩提而不舍一切布施精进。现知诸法毕竟无尽而不舍于忍辱安乐之行。常在三昧甚深境界而能不舍一切众生善根所作之事。具足妙静寂静而常不舍乱心颠倒心教化众生之行。成就陀罗尼及四无碍而常不舍求于多闻智慧精进。成就诸法秘藏而能不舍为于一偈迳百千由旬求法精进。知一切法不由于他而常不舍亲近师尊敬重精进。知一切法不生不灭而常不舍护法精进。不见众生及众生名而常不舍化一切众生得大菩提精进。善男子。是名菩萨摩诃萨入十种法行能知法师义。复次善男子。菩萨摩诃萨。入十种法行。能知法师义。何等为十。所谓成就摄受语故能行布施爱语利益同事之行。成就柔软语故能起大慈悲心。成就随顺语故则能随顺寂静随顺离烦恼随顺解脱。成就随顺语故则能随顺奢摩他随顺毗婆舍那随顺真如道。成就善巧语故则能具足显了语无讥嫌语无能夺语。成就字义语故。则能离于恶语具足义语。成就远离谄曲语故则能破众生无明欺诳。成就无疑语故则能现见一切法相。成就远离一切烦恼使语故则能灭诸烦恼随烦恼因。成就不起根本语以无垢无所发故。善男子。是名菩萨摩诃萨入十种法行能知法师义。复次善男子。菩萨摩诃萨入十种法行。能知法师义。何等为十。所谓菩萨摩诃萨。诸所说法皆依妙法所持而说。不依供养恭敬所持而说。依一切诸佛所持说法。不依自心所持而说。依大慈大悲根本说法。不依烦恼随烦恼根本而说。依断随顺凡夫使流说法。不依断绝随顺佛法僧宝如法修行而说。依大慈悲利他说法。不依受乐自利而说。夫说法者依彼甚深法说。以空无相无愿毕竟故。说法者依彼胜人而说。以能随顺转大法轮故。说法者降伏一切魔怨而说。以能降伏阴魔死魔烦恼魔天魔故。说法者随顺道场而说。以一切世间所应供养故。说法者随顺一切智智而说。以毕竟得十力四无所畏十八不共法故。善男子。是名菩萨摩诃萨入十种法行。能知法师义。复次善男子。菩萨摩诃萨入十种法行。能知法师义。何等为十。所谓乐于梵行资生之业。不乐世间资生之具。乐于圣人所行之法。而能不舍教化众生凡夫所作可诃之事。菩萨常乐法食不贪世味。常乐阿兰若处不着城邑聚落。常乐佛菩提不求声闻辟支佛菩提。常乐断智障不乐断烦恼障。常乐三十二相八十种好成就色身不乐唯证法身。常乐成就十力四无所畏十八不共法。不乐唯证四谛之法。常乐成就随一切众生善根。不乐唯集自身善根。常乐断除一切烦恼及烦恼习气。非唯乐断烦恼障法。善男子。是名菩萨摩诃萨入十种法行能知法师义。善男子。菩萨摩诃萨。入十种法行。能知法师相应譬喻。何等为十。所谓善男子。譬如大地其性平等。广能荷负一切众生。而于众生不求报恩。善男子。菩萨法师如彼大地。其心平等普能荷负一切众生。而于众生不求报恩。善男子。譬如大水其性普洽泽润一切皆令滋茂。而于彼物不求报恩。菩萨法师亦复如是。以己功德利润众生悉令安隐。而于众生不求报恩。善男子。譬如火性力能成熟一切果实。而于彼事无所悕望。菩萨法师亦复如是。以己功德智慧。成熟一切众生善根果实。而于众生不求恩惠。善男子。譬如风性力能生长一切药草诸种。而于彼物不生分别无所悕望。菩萨法师亦复如是。力能增长一切众生生身法身。而于众生不求报恩。善男子。譬如空界无量无边体无障碍容受一切。而于彼物无所分别无所贪着。菩萨法师亦复如是。成就无量无边诸善功德体无障碍。利益一切众生。而于众生无所分别无所贪着。善男子。譬如明月显处虚空清净圆满。众生见者无不爱乐。光照世间一切群像。而不为彼昏翳所污。菩萨法师亦复如是。出现于世功德具足。在在处处一切见者皆悉爱乐。救度世间而不为彼世法所染。善男子。譬如日出光明普照破诸闇冥无有翳障。一切众生所作事业皆悉成就。而彼日性于诸众生无有分别悕报恩心。菩萨法师亦复如是。出现于世破诸众生无明黑闇。以智慧光普照众生。种种善根皆令增长。而彼菩萨于诸众生无有分别求少报恩。善男子。譬如船舫坚厚善缚不破不坏。能于大海渡诸众生。而于众生不求价直。菩萨法师亦复如是。以智慧为厚。诸波罗蜜为坚。大慈悲为善缚。能于生死大海渡诸众生。而于众生不求价直。善男子。譬如暴河漂流迅急崄难可畏。中有桥梁于诸众生平等悉与济渡之乐。而无分别济渡之想。菩萨法师亦复如是。于烦恼暴河驶流难渡崄难可畏驶流恶道。能于其中作大桥梁。于诸众生平等施与解脱之乐。而无分别度脱之心。善男子。譬如闇室然大灯明。于下中上一切众生平等普照而彼灯明无我我所照了之想。菩萨法师亦复如是。于无明闇室然智慧灯。于下中上一切众生平等普照。而彼菩萨无我我所能照之心。善男子。是名菩萨摩诃萨入十种法行。能知法师相应譬喻

善男子。菩萨摩诃萨入十种法行。知不共住法。何等为十。所谓小心少求狭劣众生皆不共住。不起广心不起大行懈怠众生亦不共住。依止慢心增上慢我慢犹如高幢如是众生亦不共住。悭嫉破戒嗔恨懈怠乱心愚痴众生皆不共住。贪欲嗔恚恼害觉观等心亦不共住。一切分别差异分别种种分别亦不共住。一切盖障随烦恼使亦不共住。一切声闻辟支佛及世间念亦不共住。一切悕求恭敬赞叹礼拜之念亦不共住。一切我我所心亦不共住。善男子。是名菩萨摩诃萨入十种法行能知不共住法。复次善男子。菩萨摩诃萨于十种舍心皆不共住。何等为十。所谓舍于摄受妙法之心亦不共住。舍于听闻妙法之心亦不共住。舍于教化众生之心亦不共住。舍于法施众生之心亦不共住。舍于一切尊重恭敬供养之心亦不共住。舍于降伏魔等之心亦不共住。舍于摧灭外道之心亦不共住。舍于护持妙法之心亦不共住。舍于诸波罗蜜修行之心亦不共住。舍于三聚回向之心亦不共住。善男子。是名菩萨摩诃萨于十种舍心皆不共住。善男子。菩萨摩诃萨入十种法行。知应化事。何等为十。所谓转轮王化。帝释王化。梵王化。声闻化。辟支佛化。菩萨化。诸佛化。佛国土化。道场化。大众化。善男子。此诸应化。菩萨摩诃萨。皆依众生诸根性欲。又善男子。若诸众生其心尊重。转轮圣王持戒修行十善威仪。彼时菩萨摩诃萨。即现转轮圣王庄严之事利益众生。又善男子。转轮圣王轮宝庄严者。千辐具足纯是阎浮檀金。过于人天非人所为。自愿如意功德所生。观者无厌。余凡轮王所不能有。象宝者。其身姝大鲜白充洁。六牙具足众相圆满。见者无厌。乘空而行其去迅疾。犹如堙罗婆那金翅鸟等。殊胜善根福力所生。余凡轮王所不能有。马宝者。其色绀青厥性良善。犹若婆罗呵马王。飞空而行骏疾如风。其犹如意宝珠随王所念无不称意。余凡轮王所不能有。摩尼宝者。楞相成就非工所造自然而有。具足光明其色照曜。能蔽日月星宿诸火明等。随其所须一切称意。余凡轮王所不能有。女宝者。肤艳鲜洁妙相奇挺。黑白长短肥瘦得所。威仪动静靡不具瞻。世间技术五明论等无不通达。言音和雅柔软微妙。辞韵善巧辩才成就。如如意宝具足一切胜妙之事。心常安乐诸善法行。余凡轮王所不能有。主藏臣宝者。其身广大志性坚固。犹如金刚力士毗沙门王。色貌端严言辞流泽。其见闻者无不欣乐。成就肉眼具足慈悲。如如意宝所念皆得。此藏臣宝同彼轮王善根所生。余凡轮王所不能有。主兵臣宝者。一切功德善根所生。如摩尼宝镜像义故。王所未念先已成办。见相即知一切诸事。所依殊胜无可讥嫌。飞空而行自在无碍。随王所念导前而去。其所至处靡不摧伏。余凡轮王所不能有。如是一切轮王七宝庄严化事。皆是菩萨摩诃萨得心自在神力所为。欲与一切众生安隐乐事。此人王宝及作业者。一切殊胜无可讥嫌。能以实心深心柔软心随顺法心。转大法轮受持十善。具足三十二相教化众生。是名菩萨摩诃萨转轮圣王庄严大化。善男子。若诸众生其心尊重忉利天王。菩萨尔时化作帝释身。有百眼处三十三天。说一切诸法皆悉无常。汝等应当远离放逸。善男子。若诸众生其心尊重大梵王。菩萨尔时化作梵王。威仪殊胜为诸梵众说四禅等。善男子。若诸众生应以声闻身得度者。不以辟支佛身。不以佛身而可度者。菩萨尔时化作声闻身。为彼众生说尽诸苦得无为乐

善男子。若诸众生应以辟支佛身得度者。不以声闻身不以佛身而可度者。菩萨尔时化作辟支佛身。为说辟支佛道。明一切诸法皆悉无常。乐于空闲寂静之处。说诸禅定解脱三昧三摩拔提四如意足。说辟支佛为大福田。说微妙法教化众生令其正信。善男子。若诸众生应以菩萨身得度者。菩萨尔时以己微妙清净色身。说六波罗蜜四种寂法大慈大悲。及诸自在诸忍诸地。化彼众生。善男子。若诸众生具上根性。应以佛身而得度者。菩萨尔时化作佛身。为说十力四无所畏十八不共法。示现诸佛殊胜神通。化彼众生。善男子。若诸众生应以胜妙庄严清净佛土而得度者。菩萨尔时即变三千大千世界。平坦如掌无有高下。其地柔软如迦邻陀草。其有触者无不受乐。或如琉璃颇梨等色。或出优罗伽栴檀之香。无诸恶趣亦无女人黄门之身。或作种种庄严七宝之山。种种奇异华果香树。无诸黑山坑坎堆阜沙砾荆棘杂秽草木。现此胜事化彼众生。善男子。若诸众生应见胜妙庄严道场而得度者。菩萨尔时示现庄严道场之树。其形高广十二由旬。根盘幽固不可倾动。以阎浮檀金为茎。金银琉璃颇梨马瑙种种诸宝以为枝叶。又现无量天女之身。化彼众生。善男子。若诸众生应见胜众而得度者。菩萨尔时即现大威德天诸龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。释提桓因梵天王四天王。或为声闻得四无碍及俱解脱。或为菩萨住第十地得首楞严三昧。化彼众生。善男子。是名菩萨摩诃萨。入十种法行能知应化事。善男子。菩萨摩诃萨。入十种法行。知诸善根胜妙果报。何等为十。所谓善男子。譬如因彼虚空月形。即见水中种种月像。而虚空月不至水中。善男子。如是诸善根业行因缘。而有种种胜妙果报。随心所乐一切成就。如虚空月不至水中。如是所作诸善因缘不至于果。虽不至果。而依彼诸善根因缘。有胜妙果报差别不同。善男子。譬如业行因缘于彼孔雀一毛轮中见种种色。如是菩萨摩诃萨。依诸善根业行因缘。而有无量果报差别。如彼业行不至毛轮。虽复不至而依彼业因缘力故。于毛轮中有种种色。如是所作诸善根业不至于果。虽不至果。而依彼诸善根因缘。有胜果报差别不同。善男子。譬如依彼胜妙善根。于虚空中雨种种华。如是诸华具足妙好色香味触。而彼善根不至华中。以诸善根与虚空华相各异故。如是所作善根业行不至于果。虽不至果。而依彼善业因缘。有胜果报差别不同。善男子。譬如依彼胜妙善行。于虚空中自然而作种种伎乐微妙音声欢娱之事以为供养。然彼善行。不至伎乐音声等中。以此善行与诸伎乐相各异故。其相虽异而依彼业有虚空中种种伎乐。如是依诸善根业行因缘有胜果报。然彼善行不至于果。虽不至果。而依彼善根因缘。有胜果报差别不同。善男子。譬如虚空杂色虹起。依彼四大增上因缘。而彼四大不至虹中。虽不至虹。以彼四大因缘力故。生诸虹色种种不同。地大因缘而生黄色。水大因缘生于青色。火大因缘生于赤色及诸绮色。风大因缘生虹轮相。如是依诸善根增上因缘。而有胜妙果报具足。善男子。譬如轮王受持十善业道因缘。得七宝具足及自然粳粮不假种殖。而彼受持十善业道因缘。不至七宝亦复不至自然粳粮。以依受持十善业道因缘。而有轮王胜妙果报。如是善发胜心善起诸行。善能受持善根力故。有彼轮王胜妙果报。然彼业因不至果中故。说因果不相似。善男子。譬如诸天胜善因缘。自然而有曼陀罗华诸妙天宫百味甘膳。而彼善根不至果中。非不依彼善根因缘。而有诸天胜妙果报。善男子。譬如殊胜如意神通因缘力故。于彼石壁无所障碍。而彼神通因缘不至无障碍中。而依彼神通因有无障碍。如是不放逸善根因缘。有彼胜妙果报。善男子。譬如依风生火离彼不生。火既生已力能成熟光色明照。而彼火性不从风来以彼明色热触风中无故。如是一切善根果报从因缘生。应知善男子。譬如法行比丘得无漏善根功德。自在随念即成虚空处一切入地水火风青黄赤白。自在成就无有障碍。而彼无障碍心不至虚空。无障碍等虽不至彼。而即念能成无障碍事。是故不离彼心能成地等无障碍事。如是一切无漏善根因缘。而有果报胜事。善男子。是名菩萨摩诃萨入十种法行能知诸善根胜妙果报

善男子。菩萨摩诃萨入十种法行。能知得无漏善根胜妙果报。何等为十。所谓六通三明八解脱八胜处十一切入十自在十谛九次第定三摩拔提十力十智

善男子。何者是六通。所谓天眼天耳他心智宿命智如意通智漏尽智。是名六通。善男子。菩萨摩诃萨天眼者。具足一切善根功德。无碍无著无量无障无住无行无错无谬。能如是见无可讥嫌。不与一切世间声闻辟支佛共。远离一切烦恼及一切烦恼习气。不谬见不谬记。菩萨摩诃萨天眼。见诸众生若生若死若好若丑若粗若妙。随彼众生业行所造。称其因果能如实知。菩萨摩诃萨天眼。毕竟能得佛智。毕竟成就佛智。是名菩萨摩诃萨天眼

善男子。菩萨摩诃萨天耳者。无有障碍。具足一切善根功德过一切凡夫释提桓因四天王天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽声闻辟支佛。以此胜妙无所障碍清净天耳。闻一切声天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽声。乃至蚊虻蝇蚁等声。圣人非圣人声。皆悉得闻。而于圣人声不起乐心。于非圣人声不起厌心。闻凡夫声不生下想。闻声闻辟支佛声不生胜想。闻非圣人声听不生厌。闻圣人声听不生乐。于一切声不生美恶之想。虽闻一切声悉如响空离我我所寂静空故。不着耳入不着声入。是名菩萨摩诃萨天耳

善男子。菩萨摩诃萨他心智者。菩萨摩诃萨。如实知自心。以如实知自心故。如实知一切众生心。所谓如实知贪心离贪心。菩萨摩诃萨。如实知贪心而不生嗔。知离贪心而不生喜。唯于贪心众生生于大悲。于离贪心众生生于大慈。如是如实知嗔心离嗔心。痴心离痴心。爱心离爱心。取心离取心。染心离染心。思量心不思量心。三昧心离三昧心。如实知解脱心不解脱心。菩萨摩诃萨。如是如实知众生心。于未得解脱众生不生嗔心。得解脱众生不生喜心。唯于未得解脱众生生大悲心。得解脱众生生大慈心。如实知一切法唯是一心。而于彼心此心不生贪着。菩萨摩诃萨。彼知他心智。如实知一切众生心。彼诸众生。若菩萨不与念力。则不能知菩萨心。乃至天眼亦不能知。一切声闻辟支佛亦不能知。何况无智凡夫而能得知。是名菩萨摩诃萨他心智

善男子。菩萨摩诃萨宿命智者。一切善根具足故。能知自身过去无量宿命。及一切众生过去无量宿命。能知一生二生百生千生百千万生。乃至无量阿僧祇生。无量百千亿那由他生。善知劫成善知劫坏。乃至善知无量阿僧祇劫成劫坏。乃至善知无量无边百千亿那由他劫数成坏。善知大劫成善知大劫坏。善知大劫百劫。善知大劫千劫。善知大劫百千劫。百千万劫。乃至善知大劫无量百千万劫。菩萨摩诃萨。彼宿命智。唯除诸佛如来及住地菩萨。一切世间天人声闻辟支佛之所迷闷。菩萨如是知我于彼处如是生如是姓。如是色如是名。如是饮食如是命如是住。如是长短如是阔狭。如是好丑如是苦乐。我于彼死生于某处。于彼处死于此处生。如是生如是姓。如是色如是名。如是饮食如是命如是住。如是长短如是阔狭。如是好丑如是苦乐。如知己身。知一切众生身亦如是知。乃至蚊虻蝇蚁等亦如是知。菩萨摩诃萨彼宿命无碍无著无住无障无滞。不失时与大慈大悲相应。甚深不可思量。远离使烦恼及习气烦恼。一切清净功德智慧以为庄严。是名菩萨摩诃萨宿命智

善男子。何者是菩萨摩诃萨如意通智。所谓一切福德智慧。成就无障碍。自然无分别。无量阿僧祇百千万亿那由他劫。修行布施持戒忍辱精进禅定三昧三摩拔提。智慧增上自身力故。如来净天增上缘故。是菩萨。彼如意现前自然无障碍。胜一切世间。而作利益众生。是菩萨。如是随心欲住。能如是住。随心欲示现如是境界。能如是示现。是菩萨。一切处自在如意通示现无障碍。是菩萨。应以一众生形相现一切众生形相而可化者。是菩萨。为彼现一众生形色。示现为一切众生形色。随彼众生应受道器。现诸化身。作种种事种种言语种种威仪而现在前。是菩萨。心念一切众生色像。欲作一切佛像。即时能现一切众生色像。成一切佛像。是菩萨。心念一切佛色像。欲作一切众生色像。即时能成一切佛色像。成一切众生色像。是菩萨。念欲令成劫坏。即示成劫坏。彼诸众生即见成劫作坏劫。是菩萨。欲令坏劫作成劫。即能示现坏劫作成劫。彼诸众生即见坏劫作成劫。如是一切成坏而示现成坏。是菩萨。如是念欲令一劫示现一日初分即能示现。彼诸众生即见一劫为日初分。是菩萨。以日初分示现一劫。彼即如是成。彼诸众生亦如是见。是名菩萨摩诃萨变化如意通。菩萨摩诃萨现前如意通者。是菩萨。依不可思议功德智慧增上自然无心现前。成就一切事不坏而能现前。是名菩萨摩诃萨现前如意通。善男子。何者是菩萨摩诃萨自然如意通。若诸众生。应如是信如是见种种形色种种威仪。是菩萨。不思量不分别自然而现色。是名菩萨摩诃萨自然如意通。是菩萨。若干世界众生。应见诸佛出世而可度者。即时示现尔所世界佛出于世。从兜率天退。入胎出胎出家苦行。诣道场降伏魔成正觉转法轮现大涅槃。如是教化彼诸众生。善男子。菩萨摩诃萨。如是如意通无量境界。是名菩萨摩诃萨如意神通智。善男子。何者是菩萨摩诃萨漏尽智通。善男子。菩萨远离四漏。所谓欲漏有漏见漏无明漏。菩萨摩诃萨。远离如是等漏。不复受生。是菩萨。更不受生而能随顺可化众生。示现一切处生。是名菩萨自然不休息行于菩萨道。是名菩萨摩诃萨六通

善男子。何者是菩萨摩诃萨三明。所谓天眼智明宿命智明漏尽智明

善男子。何者名为智有天眼智天眼明。云何为天。彼清净天胜妙上天等天眼智。菩萨摩诃萨。毕竟得彼天眼智。清净天者。谓声闻辟支佛菩萨诸佛如来。胜妙上天者。谓诸佛如来。于声闻辟支佛天等为上。是菩萨摩诃萨。得彼诸佛如来天眼。是名初明

善男子。何者是菩萨摩诃萨宿命智明。善男子。诸佛如来过去未来现在无有境界不知不见不觉。菩萨摩诃萨。得彼境界彼宿命智明。此明不同一切声闻辟支佛。是名第二明。善男子。何者是菩萨摩诃萨漏尽智明。菩萨摩诃萨。远离四漏及烦恼习气。所谓欲漏有漏见漏无明漏。菩萨摩诃萨。证见道时。即得远离如是等烦恼及烦恼习气。非但证断烦恼障法。亦复不同声闻辟支佛等。得漏尽已。于一切生处及教化一切众生而无障碍。是名菩萨漏尽智明。是名菩萨摩诃萨三明

善男子。何者是菩萨摩诃萨八解脱。所谓有色见色是名初解脱。内有色相见外色是名第二解脱。信净是名第三解脱。是菩萨。过一切色相。灭一切有对相。不念一切异相。知无边虚空。即入无边虚空行。是名第四解脱。是菩萨。过一切虚空无边相。知无边识。即入无边识行。是名第五解脱。是菩萨。过一切无边识相。知无所有。即入无所有处行。是名第六解脱。是菩萨。过一切无所有处。知非有想非无想安隐即入非有想非无想处行。是名第七解脱。是菩萨。过一切非有想非无想行。灭一切受想。入灭尽定行。是名第八解脱

善男子。云何有色见色。有色者。皆是因缘而生。见空无寿者。能如是见得脱于缚。是名解脱。云何内有色相见外色。见空无寿者皆是因缘生。能如是见得脱于缚。名为解脱。云何信净。净者。若分别净不净相名为邪见。以信净故得脱于缚。名为解脱。过一切色相。灭一切有对相。不念别异相。知无边虚空。即入无边虚空行。无量虚空虚空空。能如是知得脱于缚。名为解脱。过一切虚空。知无边识。即入无边识行。无量识无边识。此无边识即是空。能如是知得脱于缚。名为解脱。过无边识知无所有少即入无所有行。所有者。名为贪嗔痴烦恼。入无所有行者。灭彼烦恼。能如是知得脱于缚。名为解脱。过无所有者。知非有想非无想。安隐即入非有想非无想行。非有想者。性空寂静。非无想者。以依因缘而有。能如是见得脱于缚。名为解脱。过一切非有想非无想。灭一切受想。入灭尽定行。是菩萨。如是见想如阳焰受如泡。想即是受受即是想。无知者无寿者。能如是见得脱于缚。名为解脱。善男子。何者是菩萨摩诃萨八胜处。所谓有色见色。彼色中得自在而知。彼色中得自在而见。是名初胜处。内身有色想。见外色若好若丑。彼色中得自在而知。彼色中得自在而见。是名第二胜处。内身有色相见外色无量若好若丑。彼色中得自在而知。彼色中得自在而见。是名第三胜处。内身有色相见外色少若好若丑。彼色中得自在而知。彼色中得自在而见。是名第四胜处。内身有色相见外色青见青色青色青光。譬如优摩歌华青见青色青色青光。菩萨亦复如是。内有色相见外色青见青色青色青光。彼色中得自在而知。彼色中得自在而见。是名第五胜处。内身有色相见外色黄见黄色黄色黄光。譬如伽尼歌罗华黄见黄色黄色黄光。菩萨摩诃萨亦如是。内身有色相见外色黄见黄色黄色黄光。彼色中得自在而知。彼色中得自在而见。是名第六胜处。内身有色相见外色赤见赤色赤色赤光。譬如槃头视婆华赤见赤色赤色赤光。菩萨摩诃萨亦如是。内身有色相见外色赤见赤色赤色赤光。彼色中得自在而知。彼色中得自在而见。是名第七胜处。内身有色相见外色白见白色白色白光。譬如优沙私多罗白见白色白色白光。菩萨摩诃萨亦如是。内身有色相见外色白见白色白色白光。彼色中得自在而知。彼色中得自在而见。是名第八胜处。是名菩萨摩诃萨八胜处

佛说法集经卷第二佛说法集经卷第三

        元魏天竺三藏菩提流支译

善男子。何者是菩萨摩诃萨十一切入。所谓地一切入。水一切入。火一切入。风一切入。虚空一切入。青一切入。黄一切入。赤一切入。白一切入。识一切入。是名十一切入。是菩萨。若欲以一切界入一界者。即一切界入一界。所谓入地界。若欲以一切界入一界者。即一切界入一界。所谓入水界。若欲以一切界入一界者。即一切界入一界。所谓入火界。若欲以一切界入一界者。即入一界。所谓入风界。若欲以一切界入一界者。即入一界。所谓入虚空界。若欲以一切入入一入。即入一入。所谓青入。若欲以一切入入一入。即入一入。所谓黄入。若欲以一切入入一入。即入一入。所谓赤入。若欲以一切入入一入。即入一入。所谓白入。若欲以一切入入一入。即入一入。所谓识入。若欲以一切地水火风空青黄赤白识入一入。即入一入。是故名为一切入入一。一入即成一切入。是故名为一切入。是名菩萨摩诃萨十一切入

善男子。何者是菩萨摩诃萨十自在。所谓命自在。心自在。物自在。业自在。生自在如意自在。信自在。愿自在。智自在。法自在。是名菩萨摩诃萨十自在。善男子。得上甘露名为命自在。能知一切唯是一心名为心自在。于其掌中出诸珍宝亦以虚空而为库藏名为物自在。远离一切烦恼烦恼习气及无明使名为业自在。于禅定解脱三昧三摩跋提随意回转名为生自在。于一切行自然而行名为如意自在。于一切入中得自在观名为信自在。即生心时。现前成就一切诸事。名为愿自在。一切身口意业以智为本名为智自在。现得平等真如法界实际无垢智慧名为法自在。复次善男子。得命自在故。对治一切世间死怖畏。得心自在故。对治一切世间烦恼怖畏。得物自在故。对治一切世间贫穷怖畏。得业自在故。对治一切世间恶行怖畏。得生自在故。对治一切世间恶道怖畏。得如意自在故。对治一切世间追求怖畏。得信自在故。对治一切世间谤法罪怖畏。得愿自在故。对治一切世间心念缚怖畏。得智自在故。对治一切世间云何疑刺怖畏。得法自在故。对治一切世间大众怖畏。复次善男子。远离杀生之罪。与一切众生无嗔害心。是命自在因。于受乐众生无障碍大慈。于受苦众生无障碍大悲。是心自在因平等心舍一切事。及回向大菩提。是物自在因入一切所作业。所谓清净身口意业。是业自在因以菩提心为本。摄取一切善根十善业道。是生自在因以一切供养恭敬礼拜赞叹象马车乘舍与众生。是如意自在因于三宝中教化一切众生。是信自在因与一切众生清净身口意业。是愿自在因远离供养恭敬饮食贪心。能施一切众生法食。是智自在因平等教化一切众生。说一切众生平等法界。说一切众生诸佛如来。以为法身非饮食身。是法自在。因是名诸菩萨摩诃萨得十自在

善男子。何者是菩萨摩诃萨十谛。所谓世谛。第一义谛。相谛。差别谛。观谛。事谛。生谛。尽无生智谛。入道智谛。集如来智谛。是名十谛。善男子。世谛者。所谓有限齐名数为他人说狭劣不广。是名世谛。第一义谛者。所谓甚深空相应法。无有限齐不断绝处。非他因缘平等一相无有高下。不乱不静相。一切法真如相。是名第一义谛。相谛者。所谓逼恼者苦相。生者集相。净者灭相。乘者道相。是名相谛。复次善男子。知一切法自性无我相证道相作证相。是名相谛。如是知一切法自性净相。知自性远离相。知自性空相。知自性不生不灭相。证道相作证道相。是名相谛。差别谛者一切法皆是一相。依他因缘而差别说。一相者。所谓空相。彼空依他差别而说。又复一切法。无相无愿无行不生不灭。彼一切差别皆是空相。皆悉是空不相违相。是名差别谛。何者是观谛。观者彻观故。数见思惟知见觉证。智于彼境不相违背。是名观谛。事谛者。所谓事智。事者谓阴界入。知彼阴界入唯是因缘生无事无寿者。能如是知而证于道。是名事谛。何者是生谛。所谓依彼知断烦恼。依彼行断烦恼。依彼道断烦恼。而得十力四无畏十八不共法。复证一切法。得一切如来胜自在法。是名生谛。尽无生智谛者。说一切有为法尽。彼有为法尽不尽以尽无尽。若尽有尽者即有尽尽。是故尽不尽。是故尽不生不灭。是名尽无生智谛。何者是入道智谛。以何等智以何等道。以何等功德聚集。以何等智聚集。知一切法不生不灭。依彼法自入令他入。是名入道智谛。何者是集如来智谛。谓法云地如来地中间。集如来智谛。得彼自然道证如来智。是名集如来智谛。是名菩萨摩诃萨十谛

善男子。何者是诸菩萨摩诃萨九次第入三摩拔提。菩萨摩诃萨。离诸欲诸恶不善法。有觉有观离生喜乐入初禅行。善男子。离诸欲者。谓初禅所对爱染法。远离彼法名离诸欲。离诸恶不善法者。谓因贪嗔痴。起杀生偷盗邪淫妄语两舌恶口绮语贪嗔邪见。是名诸恶不善法。远离彼法是名初禅。有觉者谓共觉故。何者是觉。依何境界随顺初禅。是觉有种种异名。谓知觉思惟观集定等。是名为觉。何者是观。即彼随顺初禅觉行。思惟观受欲定知觉。是名为观。依于厌行共彼有觉有观而成初禅。依于厌行共彼有喜有乐而成初禅。是名有喜有乐入初禅行。行者所谓。受持护念喜乐知等是名为行。菩萨摩诃萨。住初禅中。得无生法忍增上欲心。是故入禅求无生法忍。是菩萨摩诃萨。为得转胜无生法忍欲求心故。于彼初禅中生不坚固心。是故菩萨。舍彼初禅求第二禅。是菩萨离彼初禅有觉观心。灭于彼心离于彼心。净于彼心寂静彼心。为入第二禅。为成就第二禅思惟行。是菩萨离彼觉观。内净心一处无觉无观定生喜乐入第二禅行。内净者。谓对治障。彼第二禅法。菩萨寂静彼法清净无浊。是名内净。心一处者。谓灭彼初禅一切觉观。寂静一味犹如大海。善男子。譬如一切诸水入于大海。皆同一味所谓碱味。如是菩萨摩诃萨。入第二禅。灭彼初禅一切觉观。寂静一味无觉无观。是名得无觉无观三昧。是菩萨。依彼三昧生喜。谓于佛法僧中生于喜心。依彼喜心。诸善功德自然满足。是菩萨。为彼无生法忍增胜光明转转光明转转胜妙转转柔软得上欲心。是菩萨。依彼无生法忍上欲心故。于彼第二禅中不住不乐。更求胜上第三禅行。是菩萨生如是心。知彼喜心障第三禅及障无生法忍。是故菩萨。离喜行舍忆念安慧身受乐。是乐圣人亦说亦舍。远离喜乐入三禅行。是菩萨得三昧乐厌于彼喜。生如是心。此无喜乐。是无常乐。是尽灭法。非常非恒。非真实乐。非究竟乐。是菩萨知如是已。转转复得彼无生法忍增上欲心。是菩萨。依彼无生法忍增上欲心。不乐苦乐。是菩萨远离苦乐先灭忧喜。不苦不乐舍念清净入四禅行。是菩萨得第四禅三摩拔提柔软心自在心寂静心光明心正直心。以彼一切乐事。舍与一切众生。是菩萨与一切众生现前安隐乐时。即得无生法忍光明现前。是菩萨得彼无生法忍光明现前故。令行速疾。是菩萨于彼第四禅胜妙乐中。不生乐心。远离彼乐舍念清净。唯见虚空现前。是菩萨过一切色相。灭一切有对相。不念种种相。知无边虚空。即入无边虚空行。是菩萨如是观色。略有二种。一者四大。二者依四大。四大者。谓地水火风。依四大者。谓色香味触。如是广有八种色。离彼一切色相无彼色相。灭彼色相故。言过一切色相。随何等法有其色相。彼法必有碍相。是故过一切色相。灭一切有对相。不念不行种种异相。以过种种异相。以不念种种异相故。唯见虚空相。是故菩萨知无量虚空。即入无边虚空行。是菩萨入无边虚空处三昧。生如是心。虚空无边虚空无际虚空无崖。随何等法以无边等故。彼法无有前际中际后际。如是观一切法。无前中后际。是菩萨入如是三昧。即于一切众生起大慈心。即于一切法得平等智而现在前。是菩萨尔时于无生法忍中。始得胜进光明现前。是菩萨过一切无边虚空相。现前知无边识相。入无边识处行。是菩萨生如是心。是无边虚空相。唯是识想分别。是菩萨得如是心。知一切唯是识相。是识无量无边。是菩萨入如是三昧。得无生法忍。非究竟成就无生法忍。是菩萨过一切无边识相处。现前知无所有处。入无所有无少处行。无所有者无彼所有。何者是所有。谓贪嗔痴分别种种分别虚妄分别。一切有为法皆从虚妄分别心生。无彼所有故言无所有。无少者如向所说。法中少相细相微相等名为少相。无彼少相故言无少。过彼一切粗细相故。言无所有无少。是菩萨住如是三昧。得转胜无生法忍光明现前。是菩萨为得彼无生法忍。不乐彼无所有无少三昧。是菩萨更求增上三昧生胜欲心。是菩萨转求增上三昧胜行生如是心。是无所有无少行相亦是细相。虚妄分别故。次观非相非非相。何等法是非相非非相。非相者是空。非非相者从因缘生。菩萨尔时得非相非非相三昧现前。是菩萨过一切无所有处少相。入非想非非想处三昧行。菩萨住于彼处生如是心。彼非想非非想处无所可乐。是菩萨远离彼处。是菩萨远离彼处。即时一切法不生不灭现前。是菩萨知一切法不生不灭。见一切法自性寂灭。是菩萨不行不住。菩萨尔时得胜上清净无生法忍。是菩萨自此以上得自然不休息菩萨道。是名菩萨摩诃萨九种次第入三摩拔提

善男子。何者是菩萨摩诃萨十力。所谓信力。内力。修行力。忍辱力。智力。离力。闻慧力。乐说力。功德力。如实修行力。善男子。何者是信方。信力者。菩萨摩诃萨。信何等何等法。彼彼法中。随心即成决定信力。是菩萨于信力中。一切世间天人诸魔不能扰动。是名菩萨摩诃萨信力

善男子。何者是菩萨摩诃萨内力。菩萨起贪心时。修不净观即灭贪心。起嗔心时。修行大慈即灭嗔心。起痴心时。修因缘行即灭痴心。是菩萨若为他人呵骂打缚。生如是心。此声如响呵骂等如梦。菩萨尔时得平等智。信知打骂系闭等唯是自业。能如是见即时消灭。是菩萨知此身中有何等事。所谓逼恼割截等事。如水中月。菩萨尔时得平等智。能如是知即时消灭。举要言之。菩萨能知诸烦恼门皆是清净门。是名菩萨摩诃萨内力

善男子。何者是菩萨摩诃萨修行力。谓信行地力。见道地力所有对治障法。而彼障法所不能障是菩萨彼信行地中。见道地中。一切世间天人魔梵不能扰动。是名菩萨摩诃萨修行力

善男子。何者是菩萨摩诃萨忍辱力。若菩萨为他所骂而不加报。以得如响平等智力故。若菩萨为他人所打而不加报。以得镜像平等智力故。若菩萨为他所恼而不加报。以得如幻平等智力故。若菩萨为他所嗔而不加报。以得内清净平等智力故。世间八法所不能染。以得世法清净平等智力故。一切烦恼不能染不能胜。以得集因缘平等智力故。举要言之。是菩萨见一切染法门皆是清净门。是名菩萨摩诃萨忍辱力

善男子。何者是菩萨摩诃萨智力。谓菩萨摩诃萨。知阴界入空不生不灭。以何等智能集大菩提。于彼智中。一切诸魔外道邪见现作佛形所不能动。亦不扰乱不能令疑。是名菩萨摩诃萨智力

善男子。何者是菩萨摩诃萨离力。若菩萨身住一处。一切众生到菩萨所。恶口毁骂诽谤菩萨。亦复毁骂佛法僧宝。或捉菩萨若割若截。菩萨尔时于彼众生不生恼害及以嗔心。亦复不起烦恼使心及习气烦恼心。若有众生来化菩萨令起诸恶。菩萨尔时化令从己。于三宝中得坚固心。是名菩萨摩诃萨离力。善男子。何者是菩萨摩诃萨闻慧力。善男子。菩萨摩诃萨。多闻闻持闻慧海藏闻慧聚集。是菩萨成就如是多闻慧力。若三千大千世界众生。怀种种疑诣菩萨所。一时发问各异不同。菩萨尔时其心不动。以一音答断一切疑。如是百千万劫种种疑问。菩萨一时一音而答。是名菩萨摩诃萨闻慧力

善男子。何者是菩萨摩诃萨乐说力。菩萨在于百千万那由他大众中说法。彼菩萨不思惟不分别何等何等众生乐何等何等法。菩萨随彼众生而为说法。菩萨说法不失字义亦不重说不迟疾说。不恶声说不多少说。是名菩萨摩诃萨乐说力

善男子。何者是菩萨摩诃萨功德力。菩萨若于树下若在自舍若在空处。一切诸魔及其眷属诣彼菩萨。为作破坏为欲扰乱。然彼诸魔及其眷属。不能坏乱彼菩萨行。彼诸魔众而自惊怖破坏离散。自见摧灭无有救者。彼诸魔众所持器仗刀剑鉾槊长钩钺斧斗轮罥索弓箭戈戟。如是等事犹如云雨。以彼菩萨摩诃萨功德力故。即时变成种种诸华。所谓曼陀罗华。摩诃曼陀罗华。卢遮华摩诃卢遮华。陀罗华摩诃陀罗华。瞻婆华。修摩那华。优波罗华。钵头摩华。如是等种种诸华。如云雨下供养菩萨。彼诸魔众所有种种粗矿言语。闻者惊怖。如是等声以是菩萨功德力故。即时变成种种赞叹微妙音声。是时菩萨于彼诸魔种种粗恶六尘境界。以是菩萨功德力故。彼恶境界即灭不现。是时菩萨即随心念而虚空中。一切妙境即时现前。是菩萨依自功德增上因缘。以彼虚空而为库藏。于自掌中成就一切殊胜财宝而现在前。悉令一切众生受用。是菩萨掌中胜妙珍宝。皆由自力功德而成。善男子。若以劫寿说是菩萨功德之力。不可得尽。是名菩萨摩诃萨功德力。善男子。何者是菩萨摩诃萨如实修行力。善男子。菩萨摩诃萨有十种如实修行力。何者为十。所谓。布施修行力。持戒修行力。忍辱修行力。精进修行力。禅定修行力。般若修行力。方便修行力。愿修行力。力修行力。智修行力。是名菩萨摩诃萨波罗蜜相应十种如实修行力。善男子。诸菩萨摩诃萨。其余一切无量如实修行力。皆悉摄在十种如实修行力。善男子。何者是菩萨摩诃萨布施修行力。善男子。菩萨摩诃萨。无有一物吝而不舍。唯除恼害诸众生事。菩萨随何等心能行施者。而彼施心唯除诸佛如来及得忍菩萨。余一切众生不能得信。何况能知。是名菩萨布施修行力

善男子。何者是菩萨持戒修行力。善男子。菩萨持戒修行力有十种。何者为十。所谓声闻持戒修行。辟支佛持戒修行。菩萨持戒修行。摄受一切善法持戒修行。求善知识不舍持戒修行。护摄受妙法持戒修行。常为利益他持戒修行。回向大菩提持戒修行。常寂静入三昧持戒修行。断烦恼及烦恼习气持戒修行。善男子。诸菩萨等。善能分别微密持戒。以是义故。彼诸菩萨所修持戒。非一切种智人不能得知。是名菩萨摩诃萨持戒修行力。善男子。何者是菩萨忍辱修行力。菩萨摩诃萨。有三种忍辱。所谓诸苦忍辱。他所加恶不报忍辱。知诸法无生忍辱。善男子。诸苦忍辱者。以知自作业故。不报恶忍辱者。以于一切众生得一子心故。诸法忍辱者。以于一切法得无生智故。是名菩萨三种忍辱。善男子。是名菩萨摩诃萨忍辱修行力

善男子。何者是菩萨摩诃萨精进修行力。善男子。菩萨随何等处随何等行。为成就彼善法修行力故。彼彼法中生如是心。我成就此善法。为令一切众生同得故。是名菩萨摩诃萨精进修行力

善男子。何者是菩萨摩诃萨禅定修行力。善男子。菩萨不见一法而非寂静。见一切法自性寂静。灭一切诸觉。远离心意意识。不生不灭不动不乱。是菩萨不见自心定他心乱。不见离自身。不见离他身。更有三昧而能修习一切功德精进不息。是名菩萨摩诃萨禅定修行力

善男子。何者是菩萨摩诃萨般若修行力。善男子。菩萨不见一法离因缘集。不见一法离于空无相无作解脱。不见一法离虚空解脱。而能修习助菩提法精进不息。亦化众生而不休息。是名菩萨摩诃萨般若修行力

善男子。何者是菩萨摩诃萨方便修行力。善男子。菩萨摩诃萨。不见自身而常护自身密行。不见众生而常教化众生不息。不见烦恼而常守护诸情根行。菩萨见一切色不离佛色。而常求见诸如来色。菩萨闻一切声不离诸法声。而常求闻法无有厌足。不见世间而常厌离一切世间。不见涅槃。而为得涅槃舍于一切内外之物。不见佛及菩提。而恒为得佛及菩提。而常作百千万愿现前修行。是名菩萨摩诃萨方便修行力

善男子。何者是菩萨摩诃萨愿修行力。善男子。菩萨摩诃萨。不见一法增。不见一法减。而能随喜一切众生所作善根。回向阿耨多罗三藐三菩提。亦以自己一切善根。共诸众生回向阿耨多罗三藐三菩提而作是言。我因此诸善根。必成阿耨多罗三藐三菩提。我因此诸善根。成就如是如是佛国土。我因此诸善根。得如是如是大众。菩萨如是大愿成就不可破坏。是菩萨。修持净戒。不破不漏。不点不污。智者赞叹。是菩萨住彼如是净持戒中。所作大愿皆悉成就。是名菩萨摩诃萨愿修行力

善男子。何者是菩萨摩诃萨力修行力。若有众生。现作佛身诣菩萨所。欲退菩萨菩提之心而作是言。何处当有此菩提法。广说种种破坏之言。然是菩萨不可得退转。不可破坏转。念菩提转。念道场。念降伏魔。念转法轮。念大慈悲。于彼破坏众生邪教众生不生恶心。而以慈悲还教彼人置于善法。而是菩萨不失净信精进正念三昧般若等力。是菩萨依彼不退转力。令无量阿僧祇众生。得佛菩提入佛菩提。是名菩萨摩诃萨力修行力。善男子。何者是菩萨摩诃萨智修行力。善男子。菩萨如实知一切法无有众生。不生不老不病不死。唯见于法离我我所。是菩萨依如是知诸法智力。令无量阿僧祇众生入彼智中。是菩萨一切世间诸魔外道。尚不能转彼真如心。何况回置世间法中。是名菩萨摩诃萨智修行力。善男子。是名菩萨摩诃萨十种修行力

善男子。何者是菩萨摩诃萨十智。所谓苦智集智。灭智道智。于苦中法智。于集灭道中法智。阴智界智入智。过去未来智。于道及果智。是名诸菩萨十智。善男子。何者是苦智。谓苦中苦智。于苦中集智。于苦中灭智。于苦中道智。复次善男子。于苦空智。空无相智。苦无愿智。苦因缘生智。唯是苦生如是苦中苦智。复次善男子。知无明智。知爱智。知取智。名为苦智。善男子。何者是集智。随何等法集彼集彼智中集智。彼集唯是苦。是名集智。复次善男子。知爱是集智。名为集智。善男子。何者是灭智。谓过去无所从来智。未来不生智。现在不住智。是名灭智。复次善男子。知过去法不灭。知未来现在法不灭。是名灭智善男子。何者是道智。谓苦智集智灭智道智中。求道智知道智。是名道智。善男子。何者是于苦中法智。集灭道中法智。菩萨生如是心。此苦集灭道唯是法。如是知于苦中法智。于集灭道中法智。是名苦中法智乃至道中法智。善男子。何者是阴智。谓五阴中如幻梦智。五阴一合智。聚集智和合智。是名阴智。复次知色如聚沫。知受如水泡。知想如阳焰。知行如芭蕉。知识阴如幻。是名阴智。善男子。何者是界智。谓地界法界。而法界非坚相。如是水界法界。而法界非湿相。火界法界。而法界非热相。风界法界。而法界非动相。如是知名为知界。复次善男子。知微细智是名性智。知一切法根本。名为界智。复次善男子。苦智集智灭智道智。名为界智。复次善男子。有二界。谓有为界无为界。彼有为无为中智。名为界智。复次善男子。眼界色界眼识界法界。而法界非见相。亦非可见相。亦非可知相。如是耳界声界耳识界法界。而法界非闻相。亦非可闻相。亦非可知相。鼻界香界鼻识界法界。而法界非闻相。亦非可闻相。亦非可知相。舌界味界舌识界法界。而法界非尝相。亦非可尝相。亦非可知相。身界触界身识界法界。而法界非聚集和合相。亦非触相。亦非阳焰相。意界法界意识界法界。而法界非生住灭相。是名菩萨摩诃萨界智。善男子。何者是菩萨入智。谓入中广智。深智普智。缚智刺智。怖智诳智。无常智障碍智。是名菩萨摩诃萨入智。复次善男子。菩萨知入如空聚落。如彼空聚落而自不知是空聚落。如是彼诸入自不知是空如空聚落。菩萨若如是知。是名入智。复次善男子。菩萨如是知十二入。所谓眼入色入。耳入声入。鼻入香入。舌入味入。身入触入。意入法入。此诸入无我无我所。菩萨若如是知。名为入智。善男子。何者是过去未来智。谓菩萨知过去知未来。是名过去未来智。复次善男子。知未来无作者。知过去灭尽。是名菩萨摩诃萨过去未来智。善男子。何者是于道中及果中智。谓于六波罗蜜中智。是名道智。谓十地中及如来地中智。是名果智。彼于道中及果中智。是名菩萨摩诃萨于道中及果中智。善男子。是名菩萨摩诃萨十智。说此法集法门时。七万六千菩萨摩诃萨。善聚集过去诸业得无生法忍。尔时奋迅慧菩萨。语无所发菩萨摩诃萨言。善男子。汝应当说菩萨摩诃萨诸波罗蜜相应法集。何以故。善男子。此是最胜所说法集。所谓说诸波罗蜜。何者是诸波罗蜜。何者是波罗蜜法集。尔时无所发菩萨。语奋迅慧菩萨言。善男子。诸波罗蜜者。谓檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗离耶波罗蜜。禅波罗蜜。般若波罗蜜。方便波罗蜜。愿波罗蜜。力波罗蜜。智波罗蜜。善男子。是名诸波罗蜜。何者是波罗蜜法集。所谓不见布施名为檀波罗蜜。而常舍一切内外之物。不见持戒名为尸波罗蜜。而常修持一切净戒头陀功德等。不见忍辱名为羼提波罗蜜。而常修行忍辱安乐之行。不见精进名为毗离耶波罗蜜。而常修习一切善根无有休息。不见禅定名为禅波罗蜜。而常尊重寂静之心。不见慧名为般若波罗蜜。而常修习闻慧之法。不见方便名为方便波罗蜜。而常现同一切外道。为诸众生发起所念善根事故。不见愿名为愿波罗蜜。而常求一切善根。共一切众生回向阿耨多罗三藐三菩提。不见力名为力波罗蜜。而常求那罗延身金刚力士。为教化众生降伏憍慢故。不见智名为智波罗蜜。而常修行一切功巧技术五明论等。善男子。是名菩萨摩诃萨诸波罗蜜相应法集。复次善男子。菩萨不求一切果报。而常不舍施心。于一切时舍一切事。不分别持戒。而能舍于身命不毁净戒。一切诸法不能扰动。而常远离嗔害之心。不求一切法。而常念一切善根。不分别寂静心。而常修行禅定神通三昧。于一切法中无有疑心。而常求于闻思修慧。不求一切法。而心常念种种善根之法。常住寂静心。而常修行一切诸愿。断除一切憍慢高心。而常修行成就坚固金刚之身。善知一切诸经论等。而常求于一切尊重诸善知识。善男子。是名菩萨摩诃萨诸波罗蜜相应法集。复次善男子。菩萨摩诃萨。心常爱乐檀波罗蜜。而现随顺悭嫉众生。心常爱乐修持净戒。而现随顺破戒众生。心常爱乐忍辱之事。而现随顺不能忍辱颠倒众生。心常爱乐精进之行。而现随顺懈怠懒惰颠倒众生。心常爱乐禅定三昧。而现随顺多事散乱颠倒众生。心常爱乐般若妙慧。而现随顺信非善处痴哑众生。心常爱乐方便善巧。而现不求一切所作事。心常爱乐大愿善根。而现随顺厌离世间众生等行。心常爱乐有力。而现随顺无力众生。心常爱乐胜智。而现随顺无智众生。善男子。是名菩萨摩诃萨诸波罗蜜相应法集。复次善男子。菩萨摩诃萨。修行檀波罗蜜者。得如意宝手及以虚空而为库藏。修行尸罗波罗蜜者超过一切恶道。而得生死自在及柔软心随自在心。修行羼提波罗蜜者。得如来色身庄严。成就三十二相八十种好。见者无厌。修行毗离耶波罗蜜者。得四无畏及四无碍。修行禅波罗蜜者。得一切声中自在。及一切所作业中自在。修行般若波罗蜜者。得一切法中无所障碍。谓一切法菩提平等故。修行方便波罗蜜者。得所作业自然。谓得身口意业自然故。修行愿波罗蜜者。得于一切生中宿命自在。及随顺行随顺所作事。修行力波罗蜜者。一切烦恼及一切诸魔外道不能扰乱。则得一切世间最高大身故。修行智波罗蜜者。谓能超过阴死烦恼天魔等故。善男子。是名菩萨摩诃萨诸波罗蜜相应法集。复次善男子。菩萨摩诃萨。赞叹布施。而不以彼布施为清净。赞叹持戒忍辱精进禅定般若方便愿力。赞叹智等。而不以彼等为清净。何以故。虽修如是一切法等。以能舍故。是一切法以分别心故有。是故分别心。及分别心所生法皆悉舍离。是故菩萨。分别心及分别一切法。心所生法不与共住。不生心以为清净。而是菩萨生如是心。知无分别无戏论境界。证阿耨多罗三藐三菩提心。奋迅慧菩萨言。善男子。言菩提者。于何法而说。无所发菩萨言。善男子。言菩提者。无分别无戏论法即其言也。善男子。见我者名为戏论此非菩提。远离我见无有戏论名为菩提。善男子。着我所者名为戏论此非菩提。远离我所无有戏论名为菩提。随顺老病死者名为戏论此非菩提。不随顺老病死寂静无戏论名为菩提。悭嫉破戒嗔恨懈怠散乱愚痴无智戏论此非菩提。布施持戒忍辱精进禅定智慧无戏论法名为菩提。邪见恶觉观恶愿名为戏论此非菩提。空无相无愿无戏论法名为菩提。复次善男子。亦得言一切法是菩提。亦得言一切法非为菩提。问曰。以何义故。一切法名为菩提。一切法非菩提。答曰。于一切法着我我所。此非菩提。觉一切法平等。知一切法真如名为菩提。复次善男子。言菩提者名为寂静。寂静者名为一切法真如。问曰。善男子。所言真如真如者于何法说。答曰。善男子。言真如真如者名为空。彼空不生不灭。问曰。若如是一切法空。是故一切法不生不灭。无所发菩萨言。如是如是善男子。如汝所说。一切法不生不灭。问曰。若如是何故如来说有为法皆悉生灭。佛说有为法皆生灭者。此言何谓。无所发菩萨言。善男子。为愚痴凡夫着生灭法故。诸佛如来。以大慈悲为护惊怖。随顺世谛作如是说诸法生灭。而一切诸法不生不灭。是故善男子。菩萨摩诃萨。应如诸佛应知诸佛法。应知诸众生应知诸法。应知自身应知身法。尔时无所发菩萨摩诃萨。欲重宣此义。而说偈言

  佛及佛出世　　诸佛法实体
  菩萨如彼法　　不放逸而知
  诸善无漏聚　　佛世智者最
  依众生心成　　修善行因缘
  是能知诸法　　是能觉诸法
  是人到诸行　　若能知诸佛
  菩提无与者　　亦无人取彼
  实知自身法　　名为觉觉者
  若能知自身　　唯是相无实
  是能知如佛　　及知菩提法
  唯相诸众生　　虚妄分别说
  菩萨如实知　　如梦幻等相
  妄觉实觉者　　无能知此行
  若调诸根马　　是能依定知
  是人无怨亲　　及作不可作
  亦无取舍法　　是名真法集
  能正知诸法　　故说法集义
  不正知诸法　　是故说恶法
  贪法及离贪　　清净平等见
  见贪痴亦然　　是名真法集
  为利诸众生　　发大慈悲心
  而不见众生　　若离于真空
  若如是知法　　平等无垢处
  得妙洲觉处　　彼黠成正觉
  如世间幻师　　发心度幻人
  彼幻不着幻　　以未曾有故
  知三界如幻　　发大菩提心
  为度诸众生　　实知彼众生
  自身如虚空　　众生自性空
  一切处见法　　得忍住胜洲
  不行于诸法　　亦不还诸法
  以不行不还　　得住净行洲
  若住如是实　　平等法界心
  即时诸佛记　　是必成大觉
  自身佛亦然　　及得受佛记
  见彼法平等　　即时诸佛记
  得无障碍处　　证灭行世间
  一切处无过　　以大悲为身
  若菩萨有智　　欲如是法集
  修行是法行　　必得是法集

无所发菩萨说此偈时。六万二千菩萨得无生法忍。八千天子远尘离垢得法眼净

复次无所发菩萨摩诃萨。语奋迅慧菩萨言。善男子。菩萨应修行实谛法集。何以故。诸菩萨。以实谛智以为法集。善男子。何者是实谛。善男子。菩萨发阿耨多罗三藐三菩提心。乃至舍身命。不舍彼心。不舍诸众生。是名菩萨摩诃萨实谛。善男子。若菩萨。发阿耨多罗三藐三菩提心。又时舍心舍众生者。如是菩萨则为可呵。是人名为最上妄语。问曰。云何菩萨发阿耨多罗三藐三菩提心。不复舍彼心。不舍诸众生。答曰。若菩萨知苦谛集谛灭谛道谛。是菩萨不复舍彼心。何以故。是菩萨知实谛。是故菩提心不退转。问曰。何者是苦。云何知苦。答曰。于五阴爱不爱逼恼。是名为苦。菩萨知于彼苦空无寿者无我我所。唯是因缘和合而生。是名知苦。菩萨见彼苦唯是集。虚妄不坚固无寿者。名为知集。菩萨知彼苦从本际不来。不至未来际不在现在际。无始无终。自体本来寂灭。自体空自体寂静。如是知名为知灭。问曰。所言灭者此说何法。答曰。善男子。言灭者不可言。问曰。善男子。若言灭者不可言。何故言灭。答曰。善男子。说灭者。谓客烦恼诸障不实虚妄分别法。菩萨不分别彼不实法。尔时得言名为灭灭。而虚妄法本来无法可灭。是故如来。说一切法本来寂灭。问曰。善男子。如来说菩萨不证灭。若菩萨证灭。是菩萨堕声闻辟支佛地。如来何故作如是说。答曰。善男子。言证者名为现见。然灭法不可现见。是故如来。说灭法不可见。若法不可见。彼法亦不可证。是故如来说菩萨不见灭不证灭。依此义故。如来说菩萨不证灭。声闻取法相故证灭知。以何等念何等观何等行。如是知如是见如是决定。名为知道。复次善男子。言苦者名为我。彼我有相。若如是集名为知集。菩萨见彼集。不见一法能集。如是知名为知灭。若能如是观。若能如是求。名为知道。复次善男子。随所随所法上心著名为苦。何以故。善男子。如来常说随所心著名为苦。随所心着处不实。是故从心着生集名为集。苦不着心苦名为灭。以何等智不着彼智。名为知道。善男子。我今依实谛智能说。诸菩萨若一劫及无量劫说。而不可得尽。说此实谛智时。六万菩萨。依实谛熏修智。得不退转地。虚空中无量百千天女。于诸法中。远尘离垢得法眼净

佛说法集经卷第三佛说法集经卷第四

        元魏天竺三藏菩提流支译

尔时奋迅慧菩萨。语无所发菩萨言。善男子。何者是菩萨摩诃萨心念处智。何者是念。云何心念处。尔时无所发菩萨摩诃萨。语奋迅慧菩萨言。善男子。菩萨摩诃萨。已于一切法中无生智。为心念处智。以无生智为最胜。诸菩萨。彼无生智。以无生智业。得名一切处不乱一切处直一切处不动。如大海水不可量。一切声闻辟支佛无能知。以何等心念。能闻持一切诸佛如来所说法而不散失。是菩萨心念处。诸佛如来现前知。此是如是菩萨心念处。彼菩萨心念处有十种处。何等为十。所谓身念处受念处。心念处法念处。念佛念处。念法念僧念戒念舍念天心念处。是名十种念处。善男子。何者是菩萨身念处。菩萨如是安心。此身来不从本际。去不至后际。不住本际未来际。唯从虚妄分别心而生。无作者无寿者。无前中后际。不住无根本。无教者无取者。而但以客尘言语而说。若身体形状。若质若入。若如是观身此身不坚固。唯是父母赤白和合不净而生。臭秽以为体。贪嗔痴怖以为贼乱。破坏不住。种种无量百千万病。以为家宅。复次善男子。菩萨于身中如是安念。是身从头至足。众分聚集。所谓。足足指跟踝[跳-兆+尃]胫髀膝臗骨腰脊胸胁腹肋。观手手指肘腕肩臂颊颐颈项髑髅眼耳。如是等事积聚成身。以业有为作者。以种种烦恼随烦恼虚妄分别百千万种为窟宅。此身多有种种不净。所谓发毛爪齿血肉皮骨肝胆肠胃生熟。二脏脾肾心肺肪膏脑膜黄白痰阴涕唾目泪大小便利臭秽可恶。是等无量不净物聚集。如是等中何者是身。菩萨如是观身。作是思惟。此身无实犹如虚空。是名菩萨如虚空念处。如是安心。见一切法皆如虚空。菩萨如是知身。于诸法中无有动心不住心。是菩萨不动不住。名住念处。如是住念中能如是知。如菩提身亦如是。此中不可得生厌心。何以故。一切是邪念非正念。于何等法中生厌心。是名菩萨摩诃萨身念处

又善男子。何者是菩萨受念处。善男子。菩萨生如是心。言受者名为觉。彼觉有三种。谓颠倒。不颠倒。离彼二。又颠倒受者。谓一切凡夫散乱心颠倒心。彼诸凡夫。以无常受为常。以苦受为乐。以无我受为我。以不净受为净。是名颠倒受。不颠倒受者。受无常为无常。受苦为苦。受无我为无我。受不净为不净。此谓声闻辟支佛受。是名不颠倒受。离彼二受者。受无常非常非无常。受苦非苦非无苦。受无我非我非无我。受不净非净非不净。是名菩萨受念处。菩萨如是受而不见受者。不见能受者。亦不见所受。菩萨作是思惟。如来常说一切有为法以为受。若以一切法为受者。此中何等法以为受者。非所受以为能受。以彼所受非能受故。而非无为法能受有为法。离无为法有为法无受者。菩萨如是。彼所受不见能受。复不见所受者。能教彼所受者。是菩萨。见如菩提所能受亦如是。是名菩萨摩诃萨受念处。又善男子。何者是菩萨心念处。善男子。菩萨作是思惟。彼受唯是心。而心不住不可取无形。何等法不可取无形。彼所受法为何所似。非心非心知。非心非心见。复作是思惟。随何等心从因缘生。见彼诸心皆由他力而有。是菩萨。不见离心而有菩提。知此心法即是菩提。菩萨尔时即得心自在。以得心自在故。即于大乘而得自在。尔时即于一切众生得平等心。是菩萨。尔时住于大乘中。不依他力。是名菩萨心念处

善男子。何者是菩萨摩诃萨法念处。善男子。菩萨随何等法。而生正念。若善法不善法。若可诃法不可诃法。若有漏无漏世间出世间法。若声闻辟支佛法。若凡夫法非凡夫法。是菩萨。于彼彼法而生正念。善巧能知善业柔软。善能修习善修毕竟。善修自力善修自在。知平等法不生不灭。是菩萨。不见一法离于不生不灭。不见一法离于空无相无愿。菩萨作是思惟。一切诸法无有寿者。以自性寂静故。一切法无我。以自性不二故。一切法无障碍。以自性如虚空故。一切法无分别。以远离心意识故。一切法寂静。以无烦恼性故。一切法无言语。以自性不可说故。一切法不尽。以无为性净故。一切法不可数。以过一切数量故。一切法正直。以过一切戏论故。一切法无根本。以无种子故。一切法无过失。以根本自净故。一切法不来。以无形故。一切法不去。以无住故。一切法光明。以自性空故。一切法空。以从因缘而有故。一切法无诤。以无分别故。一切法依自智力。以随所念而觉故。一切法菩提。以智境界故。一切法唯是名字。以无实物故。一切法离诸见。以不可见故。一切法不缚不脱。以无形相故。一切法不去。以真如为体故。一切法一界。以不差别于真法界故。一切法不差别。以实谛平等故。菩萨如是。观一切法。修行一切法。不见众生差别。不见法差别。不见乘差别。不见佛国土差别。不见法差别。不见妙法差别。不见缚不见脱。不见世间不见涅槃。不舍不取。不行不住。不受不舍。而住于寂静。住于不动。诸佛如来能见如是寂静解脱。菩萨在彼诸佛国土。即时诸佛为是菩萨。授阿耨多罗三藐三菩提记。是名菩萨摩诃萨法念处

又善男子。何者是菩萨念佛。善男子。菩萨修行念佛。念一切众生。我为一切众生。成就阿耨多罗三藐三菩提。是菩萨安住如是念处。念诸佛如来有十力四无畏十八不共法。彼诸佛法我必成就。复能念彼诸佛如来有如是念。不可思议广大清净无垢光明。离一切使烦恼及断烦恼习气。以智慧为首智慧为增上。以诸佛无为增上。至一切所证增上法。远离一切智障烦恼。一切声闻辟支佛不能测量。以无分别为体。以自然无障碍为无行无碍不住照一切众生心如虚空无分别。诸佛如来有如是念。菩萨念彼诸佛念宝。诸佛如来财宝。诸佛如来库藏。念如是等法名为念佛。善男子。诸佛不念亦非不念。于一切处自然无分别。诸佛如来有如是念。菩萨念于彼念故名念佛。诸佛于一切众生一切法不差别相。念于彼念故名念佛。诸佛无分别。亦非无分别。不取亦非不取。不去亦非不去。不生不灭。念如是念故名念佛。复次善男子。诸佛如来。以大功德智慧庄严。以大慈大悲为行。以度众生聚以为救者。为大医师拔烦恼刺。于一切众生起平等心。常在寂静三昧境界。不住离世间涅槃。到一切烦恼障智障彼岸。大众生住持。大众生依止。灭一切生身。得法身住法境界。一切处心无障碍。于一切时利益一切众生。身口无失不虚妄授记。于一切事不可嫌身口意业。远离贪嗔痴等一切烦恼。降伏一切诸魔外道。不与一切世间诤讼。深于一切世间大海。重于一切须弥宝山。不动不摇过于大地。柔软于水。光明于火。不着于风。无垢于空。去速于意。如意踰于摩尼宝。一切种智平等无二。于一切众生远离一切着处。度一切众生精进不休息。无量色身无量音声。无量功德无量境界。不可思议。得毕竟不思议法身。超过心意意识境界。以明行心。断除三趣恶法。大悲增上。所有功德与一切众生共。于一切众生犹如父母。怨亲平等。于诸众生香涂。不生忧喜心。住一切处有大光明。不可限量。究竟彼岸。大心众生大法贤财。成就大明行。成就大法师能说大法。成大丈夫毕竟成就大丈夫相。一切世间不能降伏。能照一切世间光明大方便行大善境界毕竟大解脱毕竟大身。以大众生为眷属。大身众生围绕无障碍。见闻供养修行亲近。远离自乐爱乐灭他苦。爱乐正法。以法为钱财。以法为食。以法为衣粮。以法为根本。以法为自在。为大法王。为法施主。常乐舍法。常不放逸。常乐寂静。一切众生以为桥梁。如大王道平坦无障。大日光明破诸闇冥。如大梵王大智金刚是大法箭。清净色身见无厌足。诸佛如来。有如是等无量功德。菩萨念彼诸功德已。为成就彼功德故修行。为成就彼功德故正念。是故名为念佛。是名菩萨摩诃萨念佛处。善男子。何者菩萨摩诃萨念法处。善男子。菩萨作是思惟。诸佛如是无量功德皆从法生。从法化。从法得。从法增上。从法有。从法境界。从法依。从法成就。复作是思惟。诸佛如来有相好庄严。彼亦从法生。从法化。从法得。从法成就。诸佛如来有十力四无畏十八不共法。亦从法生。从法化。从法得。从法成就。诸佛如来有十八不共法。彼法亦从法生。从法化。从法得。从法成就。所有世间出世间乐彼诸乐事亦从法生。从法化。从法得。从法成就。是故我求诸佛菩提。应尊重法。依法境界。依法修行。依法毕竟。依法坚固。是名菩萨法念处。复次善男子。菩萨作是思惟。法平等住。于一切众生。法非见高下众生而生差别。我亦如法心无分别平等无异。法非见面而起作业。以法不朋党故。我亦如法其心平等。法非见时而起作业。以法无时来而知内心自解故。我亦如法其心平等。法非于大众生而起作业。于下众生不作业。以法不高不下故。我亦如法其心平等不生分别。法非于净众生而作利益。于不净众生不作利益。以法远离高下心故。我亦如是其心平等不生分别。法非于圣人作利益。于非圣人不作利益。以远离福田非福田心故。我亦如是其心平等不生分别。法非昼作利益夜不作利益。非昼不作利益夜作利益。以法常不休息作利益故。我亦如是其心平等不生分别。法不过可化众生时节。我亦如是其心平等不生分别。法非于嗔众生不作利益。于不嗔众生欲作利益。以一切处不着故。我亦如是其心平等不生分别。法不增不减。法无量阿僧祇如虚空不尽不增长。我亦如是其心平等不生分别。众生不护法不护众生。我亦如是其心平等不生分别。法与一切世间作归依。我亦如是其心平等不生分别。法无有处生嗔害心。以无害相故。我亦如是其心平等不生分别。法不住烦恼使。以法远离使烦恼故。我亦如是其心平等不生分别。法非怖世间求涅槃。以法常无分别故。我亦如是其心平等不生分别。菩萨如是。于法中正念。是故名为念法。善男子。是名菩萨摩诃萨念法处。善男子。何者是菩萨摩诃萨念僧。善男子。菩萨作是思惟。僧者名为如法语者。名为法行者。名为思法者。名为福田法者。名为住持法者。名为依法者。名为供养法者。名为所作如法者。名为如境界法者。名为修行成就法者。名为实法者。名为直法者。名为实清净法者。名为救众生者。名为大慈悲者。名为常寂静境界者。名为常归依法者。名为常自净行法者。复次善男子。菩萨作是思惟。如来说僧非唯一种。所谓世谛僧。第一义谛僧。惭愧僧。无惭愧僧。圣人僧。调伏僧。不退转僧。又善男子。菩萨于世谛僧摄受修行。于第一义谛僧供养修行。惭愧僧令得解脱修行。无惭愧僧诃责修行。圣人僧供养恭敬亲近修行。调伏僧如佛如是修行。不退转僧说法修行。复次善男子。菩萨作是思惟。僧者名为不断佛种。以佛子故。僧者能与所乐果报。以其福田故。僧者离烦恼。以无畏故。僧者舍一切所著。以得解脱故。僧者名为寂静。以调伏心故。僧者名为不杂。以无烦恼故。僧者远离恶法。以有惭愧故。僧者名为随顺语。以可化故。僧者名为知自身。以无憍慢故。僧者名为寂静。以无高心故。僧者名为知足。以无颠倒心故。僧者名为断绝分别。以无病故。僧者名为到妙洲渚。以得无畏处故。僧者名为见实。以不放逸故。僧者名为彼岸。以能到彼妙洲彼岸故。僧者名为不恶。以行阿兰若行故。僧者名为快。以毕竟趣道场故。僧者名为知三学。以修行弟子行故。僧者名为行于四念境界。以胜诸念修行者故。僧者名为修行四正勤境界。以修行精进故。僧者名为修行四如意足境界。以不疲倦故。僧者名为修行五根境界。以不破坏故。僧者名为修行五力境界。以降伏诸烦恼刺故。僧者名为修行七觉行。以无障碍故。僧者名为修行八圣道境界。以正见故。僧者名为修行实谛境界。以得归处故。僧者名为修行诸禅境界。以定心故。僧者名为修行因缘集境界。以能转法轮故。僧者名为大慈悲。以不退转处故。僧者名为一切功德聚集。以一生得大菩提故。又善男子。菩萨如是念僧已作是思惟。僧者如是无量功德。我皆欲得。亦令一切众生毕竟成就。善男子。是名菩萨摩诃萨念僧处

善男子。何者是菩萨摩诃萨念戒。善男子。菩萨作是思惟。所有世间出世间一切胜妙果报。彼诸果报皆因持戒而得。何以故。依因净戒根本力故。善男子。譬如一切草木丛林依地为根本。如是一切世间出世间妙果依戒为根本。菩萨摩诃萨住于持戒。能与一切天人作大福田。复能满足施者功德。善男子。菩萨住于持戒生欢喜心。心欢喜故不生忧恼。不忧恼故心得踊悦。得踊悦故得身心倚。身心倚故心得乐心。心得乐心故而得三昧。得三昧故得如实知。以如实知故。菩萨于一切众生生大慈悲。菩萨作是思惟。我今以此如实三昧法门如实知。为令一切众生成就。是菩萨以大慈悲心熏修。依彼大慈悲心。修持增上戒增上三昧增上慧满足。得阿耨多罗三藐三菩提。是故我今修持妙戒。不动不放逸。我忆念一切众生而修持戒。何以故。若菩萨不忆念一切众生持戒则非菩萨戒。是故我今为令一切众生得安隐乐。修持净戒。复次善男子。菩萨作是思惟。菩萨出家修持净戒。则能远离一切世务之事。菩萨着于染衣。则能满足舍一切所爱之物。菩萨受持净戒。则能满足身口意清净。菩萨爱念持戒。则能满足六通。菩萨宴坐持戒。则能满足菩提分法。菩萨闻于妙法修持净戒。则能满足四无碍智。菩萨推求多闻智慧修持净戒。则能满足不自高心。菩萨亲近善知识修持净戒。则能满足一切功德。菩萨修持施波罗蜜戒。则能满足一切智智。菩萨如所闻法如说修持净戒。则能满足为大法师。菩萨如所闻法思惟持戒。则能满足得陀罗尼。菩萨念菩提心修持净戒。则能超过一切诸恶得满足戒。菩萨不生害心修持净戒。则能满足不失菩提心。菩萨不失菩提心修持净戒。则能满足不失三宝心。菩萨作是思惟。若有能护修持戒者。世间所有可护之者皆悉能护。是名菩萨摩诃萨念戒。善男子。何者是菩萨摩诃萨念舍。善男子。菩萨作是思惟。所有一切可舍之法。皆悉摄于二种舍中。谓法舍财舍。善男子。菩萨资生施者。悉能满足三十二相八十种好。净佛国土教化众生。菩萨法舍者。亦能满足十力四无畏十八不共法。能断烦恼及以烦恼习气。复次善男子。菩萨于资生能舍悭心。舍法因缘能过声闻辟支佛地。复次舍财者能清净生身。舍法者能清净法身。复次舍财功德能舍父母生身。何者有此舍力。唯除初地菩萨。一切世间所无。舍法者能成就为意通力。谁有此力。唯除诸佛如来及住地菩萨。一切世间所无。复次舍财能教化众生。施法能令得解脱。复次舍财能得聚集功德。施法能令到于彼岸。复次舍财能施半。施法一切舍。复次施财能得断烦恼解脱。施法能成就离智障解脱。复次舍者若能舍于虚妄分别。此舍中最胜第一。谓舍虚妄分别之心。何以故。菩萨舍于虚妄分别。是故名为清净。菩萨问曰言虚妄者此说何法。答曰善男子。言虚妄者。说不实戏论法。问曰云何名为不实戏论。答曰若人如是思惟。我贪我嗔我痴我染。我净我不净。我行世间我入涅槃。如是等一切皆是不实虚妄分别戏论之法。何以故。一切唯是因缘。而为无我无我所无众生无人无命无我无寿者无作者无教者。彼诸因缘自性空寂。远离心心意识。彼诸因缘。不能思惟不能分别。不能染不能净。不能行世间不能入涅槃。是故菩萨。能知如是虚妄法。不能作是思惟。是其实有。舍如是心故名为舍。菩萨若能念如是法。名为念舍。复次善男子。菩萨摩诃萨有三种舍。谓舍大舍增上舍。何者是菩萨摩诃萨舍。谓饮食谷米仓库衣服骑乘灯明香熏华鬘涂香末香幡盖幢帐车舆璎珞帐首冠金银珍宝。诸如是等。不为恼害众生之具。唯除能害众生之事。余一切物无有不舍。是名菩萨摩诃萨舍。何者是诸菩萨摩诃萨大舍。善男子。菩萨摩诃萨成就舍已。能舍所爱妻子男女大小奴婢仆使臣佐吏民舍宅园观国土王位。是名菩萨摩诃萨大舍。何者是菩萨摩诃萨增上舍。善男子。菩萨成就于舍及以大舍故。成就增上之舍。所谓能舍手足耳鼻头目髓脑血肉筋骨唇舌牙齿连肤爪发。如是一切悉皆能舍。是名菩萨摩诃萨增上舍。又善男子。菩萨念如是舍大舍增上舍。我当毕竟成就舍大舍增上舍。尔时得名念舍菩萨。善男子。是名菩萨摩诃萨念舍

善男子。何者是菩萨摩诃萨念天。善男子。菩萨念清净天。所谓念声闻辟支佛菩萨诸佛如来。云何念。念彼修行。念功德。念不生。念所受境界。念始行。念修行。念成就。是名念天。复次善男子。菩萨念诸天。云何念诸天。修善业行得胜果报。何者是善业行。所谓十善业道。远离不善业道。以此善业因缘。得彼诸天色妙乐清净诸根胜妙果报。又菩萨于彼胜妙果报。起随喜心而生大慈。以彼妙乐果报。共一切众生。回向阿耨多罗三藐三菩提。菩萨作是念。欲令众生得天妙乐。复为成就彼诸善根。发大精进于生恶道众生起大悲心。菩萨作是思惟。我应教一切众生修行善业。令生天上即于天中得阿耨多罗三藐三菩提。菩萨作是念已。教诸众生修善生天。令不退失彼天妙果。即从彼乐得无上乐。所谓如来寂静妙乐。是名菩萨念天。善男子。是名菩萨摩诃萨十种念处。尔时无所发菩萨摩诃萨欲重宣此义。而说偈言

  不见苦为苦　　以见苦即空
  若不离于苦　　空法不可得
  欲得见空者　　应见于苦义
  以苦为空义　　彼空无为故
  苦无有作者　　以苦非作法
  离苦谁作者　　而亦无前后
  无有实集者　　若能实集苦
  此中何处集　　以苦非作者
  苦无所从来　　去无所至处
  与何法共合　　离苦何处有
  说爱以为集　　若能集于苦
  爱实无有爱　　离爱云何集
  以苦无所来　　是谁得未来
  说灭以为定　　离于去来法
  诸法自性灭　　根本清净明
  诸法同寂静　　以离前后际
  法若是先生　　后则应有灭
  离灭云何生　　离生无彼灭
  如是求智慧　　说名无漏道
  说道如筏喻　　以必舍筏喻
  若聚集舍法　　彼法何应乐
  舍道住妙洲　　是名得解脱
  说得解脱相　　不诤于诸法
  以于一切法　　证真如道故
  发毛及爪齿　　脂肤血肉骨
  涕唾大小便　　肝胆以脑膜
  心肺大小肠　　聚积名为身
  虚妄分别宅　　智者如是观
  无有实作者　　及离于受者
  犹如空聚落　　如是虚妄身
  说受名为受　　彼受谁能受
  受者离于受　　差别不可得
  智者如是念　　彼智者观受
  其相如菩提　　寂灭清净明
  身中不见心　　心中不见心
  是人离热恼　　虽离而不喜
  见法唯是心　　远离于分别
  不舍真如行　　以得无障境
  诸法不自生　　亦复非他生
  离诸数尽相　　平等如虚空
  如实知此法　　智者无去相
  知法亦不住　　以住于平等
  若能如是念　　于诸法不动
  是人到彼岸　　如诸佛福田
  知诸法名佛　　一切处无垢
  聚集清白法　　安隐诸众生
  念寂及妙色　　亦念诸功德
  菩萨满诸法　　必得无上道
  是菩萨供养　　三世诸如来
  法中念不动　　以常定境界
  善缚坚固铠　　念妙法境界
  得无上菩提　　菩萨坚固行
  如法我亦然　　若作如是念
  此念法应知　　所谓诸菩萨
  离我及我所　　如法我亦然
  若能如是念　　名修妙法念
  诸佛弟子僧　　是无上福田
  必得佛菩提　　常念如是人
  如海不可量　　我念如是人
  回此诸功德　　令一切成佛
  善修不退戒　　我念彼戒行
  所有诸功德　　尽欲与众生
  回向无上道　　令得毕竟乐
  如是名念戒　　能与众生乐
  舍资生及法　　亦舍诸烦恼
  有福为众生　　回向无上道
  如是成舍念　　不住于二道
  离相自然行　　所在如日照
  一切凡圣人　　皆从善业得
  以彼诸因果　　大悲施一切
  如是诸妙行　　为与增上乐
  即于彼天中　　成无上正觉

尔时无所发菩萨摩诃萨。奋迅慧菩萨摩诃萨。是二大士及无量眷属。俱诣佛所。到佛所已头面礼足绕百千匝。奉承尊意退坐一面。并诸眷属亦坐一面。而白佛言。世尊。我等二人。于胜楼阁妙宝台上说法集时。诸佛如来。于一切法。悉知见觉无有障碍。世尊。我等二人所说法集。随顺佛意不耶。尔时佛告二菩萨言。善男子。如汝所说诸佛如来。于一切法。悉知见觉无有障碍。善男子。汝等二人所说法集善顺我意。善男子。一切菩萨所有言说。皆是诸佛如来威神之力。善哉善哉。善男子。汝今快说此妙法集。若有诸菩萨欲说法集者。应如汝等所说。善男子。汝等所说妙法集者。则为已作诸佛如来所作之事。善男子我于汝等二人所说法集。生随喜心。尔时慧命舍利弗。语无所发菩萨摩诃萨言。善男子。汝以何义名无所发。无所发菩萨言。大德舍利弗。若有菩萨。休息一切身口意业。不着一切所作之事。不求一法不离烦恼不欲得法。见过去未来诸法真如平等。亦不见法有下中上。是故名为无所发。复次大德舍利弗。一切诸法皆无所发。以本无故。舍利弗。法若有始则有所发。诸法无始无始。云何言有所发。慧命舍利弗言。法若如是汝云何言说于法集。无所发菩萨言。大德舍利弗。我无所发而说法集。无所发菩萨。谓舍利弗言。舍利弗于意云何。汝之所问为有所发问。为无所发问。若言有所发问者。依何因缘而有所发。然不离于法而有法所发。不离于法而有所问。大德舍利弗。若是无发问者。则为入我所说法集。慧命舍利弗言。善男子。我有所问汝亦有说。云何而言无所发耶。无所发菩萨言。大德舍利弗。汝之所问我之所说。皆如幻说。如是菩萨摩诃萨安住真如法界所说应知。大德舍利弗。夫幻人者。无心无心数法。一切众生亦复如是。无心无心数法。若如是者云何有发。大德舍利弗。如因幻师幻有所说。如是菩萨摩诃萨依真如法界能有所说。应如是知。慧命舍利弗言。善男子。譬如幻师所作幻事。非实非不实。若如此者汝亦应尔。非实非不实。无所发菩萨言。大德舍利弗。诸佛如来。觉一切法皆如幻相故。说诸法虚妄如幻。舍利弗言。如是善男子。诸佛如来。觉一切法如幻。说一切法如幻。无所发菩萨言。大德舍利弗。犹如彼幻非实非不实。一切诸法亦复如是。非实非不实。应如是知。无所发菩萨言。舍利弗。若诸法有实不实者。不应说言一切诸法犹如幻相。慧命舍利弗言。善男子。汝何所为行菩萨行。无所发菩萨言。大德舍利弗。我行菩萨行。不为于义非不为义。何以故。若有菩萨为义行者。如是菩萨则有所见而行于行。若有所见而行其行。如是菩萨则不随顺诸佛如来。何以故。若有所见而行其行者。如是之人。尚不能随无生法忍。何况即入无生法忍。若离无生法忍。则不随顺诸佛如来。若不为义而行于行。如是之人行于邪道。行邪道者此则无实义。慧命舍利弗言。善男子。若不为义非不为义。如是菩萨于何处行。无所发菩萨言。大德舍利弗。随在何处。一切毛道凡夫所行。菩萨即彼处行。舍利弗言。善男子。毛道凡夫于何处行。无所发菩萨言。大德舍利弗。随诸佛如来于何处行。毛道凡夫即彼处行。而毛道凡夫不知诸佛随处行。我亦彼处行。慧命舍利弗言。善男子。若毛道凡夫不知诸佛所行境界。云何而言诸佛如来随何处行。毛道凡夫即彼处行。无所发菩萨言。慧命舍利弗。汝今能知佛境界不。舍利弗言。善男子。我但如彼文字而取。云何能知诸佛境界。善男子。然诸声闻。从于如来。闻声分别。而言得知。善男子。诸佛境界无量无边。而不离诸佛境界更有凡夫境界。无所发菩萨言。大德舍利弗。若不离诸佛境界更有凡夫境界者。舍利弗向言。诸毛道凡夫不知佛境界。此言云何。慧命舍利弗言。善男子。诸佛如来超过世间。毛道凡夫行于世间。是故诸毛道凡夫。不知诸佛境界。无所发菩萨言。大德舍利弗。于意云何。诸佛如来有所得。有所住。有所利益不。舍利弗言。善男子。诸佛如来无法不知。知一切法。觉一切法已。能于有为法中。利益众生。无所发菩萨言。若舍利弗如是知。何故言诸佛如来超过世间。此是大德舍利弗不思量而说。舍利弗。若如来超过世间。即如来无所得无所住无所作利益。舍利弗。汝言已坏。尔时慧命舍利弗。语无所发菩萨言。善男子。我先已坏非适今也。曾于过去。退善根及一切智智心故。善男子。我于仁者乐说辩才。深生随喜。愿一切众生皆得是辩才。说此法集时。八万菩萨得无生法忍。六万天子远尘离垢得法眼净。五千比丘转声闻心。发阿耨多罗三藐三菩提心。彼诸比丘佛为授记。各于种种佛国土中。成阿耨多罗三藐三菩提

尔时无所发菩萨摩诃萨白佛言。世尊。云何菩萨摩诃萨善知可取能取法。佛言。善男子。若菩萨知一切法。菩萨尔时善知可取能取法。无所发菩萨言。世尊。云何善知一切法。佛言。见一切法如梦幻乾闼婆城阳焰火轮水中月化镜中像。无所发菩萨言。世尊。何者是一切法而见如梦幻乾闼婆城阳焰火轮水中月化镜中像。佛言。善男子。言一切法者。谓眼色耳声鼻香舌味身触意法。善男子。是名一切法见如梦幻乾闼婆城阳焰火轮化水中月镜中像。能取者。谓眼耳鼻舌身意。可取者。色声香味触法。菩萨摩诃萨悉见知觉能取可取诸法。亦能善说。是故名为一切智者。若一切智者。是人离使烦恼。若能离使烦恼。是人无我无我所。如虚空无分别。于一切众生得平等心。以得平等心故得一切处寂静心。得寂静心故名为法行自然坚固者。于一切众生作上首者。一切法中无障碍者。大慈大悲者。不可动转者。三藐三佛陀者。无所发菩萨言。世尊。菩萨欲得如诸佛如来妙法。云何修行。佛言。菩萨欲得诸佛如来如是法。应生平等心犹如大地。以能忍受一切众生诸不善行及恶语言故。又应生平等心犹如净水。以能洗除身及众生虚妄分别微烦恼垢故又应生等心犹如猛火。能以智火焚烧自及诸众生烦恼薪故。又应生等心其相如风。以能远离一切着故。又应生等心犹如虚空。以一切处无障碍故。善男子。如师子王。菩萨亦尔。以一切处不惊不怖故。譬如龙象。菩萨亦尔。以调伏心荷负一切众生诸重担故。譬如大雨。菩萨亦尔。以其降澍妙雨故。譬如日光。菩萨亦尔。以智慧光。照一切众生故。譬如明月。菩萨亦尔。以一切众生随其所在见者爱乐故。譬如大商主。菩萨亦尔。将导众生趣一切智大宝洲故。譬如良医。菩萨亦尔。以能疗治一切众生烦恼病故。如拔刺者。菩萨亦尔。以能拔出一切众生于诸法中疑惑故。譬如海导师。菩萨亦尔。以能善知一切智知诸方义故。譬如船舫。菩萨亦尔。以能善度诸世间众生大海水故。譬如众水河池等。菩萨亦尔。以能资润一切众生故。如王大道。菩萨亦尔。平等能津通诸众生故。譬如宝洲。菩萨亦尔。以能具足一切菩提分法故。譬如如意宝须者皆得。菩萨亦尔。能与众生无量利益所求法故。譬如良马。菩萨亦尔。以能运代疲苦众生故。譬如大海。菩萨亦尔。智慧甚深难测量故。譬如须弥山。菩萨亦尔。于佛菩提不倾动故。譬如一切诸妙宝树。菩萨亦尔。以能具足胜庄严故。譬如阎浮檀金。菩萨亦尔。以希有难得故。譬如帝释王。菩萨亦尔。于诸法中能得增上自在力故。譬如大梵王。菩萨亦尔。具足寂静诸威仪故。譬如护世四天王等。菩萨亦尔。以能护持胜妙法故。譬如转轮王。菩萨亦尔。以能修行十善业故。譬如大臣。菩萨亦尔。以能守护诸佛如来秘密法故。菩萨应生出家心。以善住沙门法故。菩萨住沙门法中。以寂静身口意业故。菩萨住阿兰若处。以成就禅定三昧三摩跋提通明解脱故。菩萨住禅定中。以得真如甚深空故。菩萨住寂静处。以能教化乾闼婆紧那罗摩睺罗伽。成就咒术妙药圣人法故。菩萨安住明智。以能具足成就三明故。菩萨住于胜寂。以得殊妙六通法故。菩萨住多闻慧。以能善知阴界入等差别法故。菩萨住于师处。以能善知一切诸论故。菩萨住法师地。以能离饮食供养说法教化故。菩萨善住毗尼法中。以能远贪嗔痴等诸烦恼故。菩萨住于摩夷处。以能一切处寂静故。菩萨住于柔软心。以能远离一切所求故。菩萨不住掉心。以能远离贪烦恼故。菩萨不住高心。以能远离嗔烦恼故。菩萨不住诸恶语言。以能远离痴心故。菩萨不住杂乱语言。以能成就善护言语故。菩萨住于大师。以能修行大乘法故。菩萨善住荷担负重。以能成就大菩提心故。譬如大水。菩萨亦尔。以能利润受用众生故。譬如大城。菩萨亦尔。以能满足一切智智功德故。譬如僮仆。菩萨亦尔。以大慈悲代诸众生勤苦事故

复次善男子。菩萨于恶众生生柔和心。于憍慢众生生恭敬心。于谄曲众生生质直心。于稠林行众生不生稠林行心。于不修行众生生救度心。于无惭众生生于惭心。于无愧众生生于愧心。于邪论众生生不怯弱心。处于大众不生怖心。世间之法不能染污。一切诸魔不能破坏。外道邪论不能降伏。于所尊者生敬重心。常于师长生供养心。于多闻者生奇特心。于得禅定者生希有心。于黠慧者生深行心。于诸法师生如爱敬佛心。于诸菩萨生归依心。于诸如来生究竟心。于如实修行者生坚固心。于一切烦恼不惊不怖。不证涅槃起大慈悲行世间行。为度众生不以染心说法教化。而常远离一切供养恭敬故。远离颠倒心。以如实知无常苦空无我不净故。具足解脱心。以能远离境界故。成就如实生。以生圣人如实家故。成就如实智慧。以常出家心故。成就圣行。以如实知苦集灭道故。成就大人相。以具足持戒多闻不放逸故。成就一切众生平等心。善知世间无我故。成就不颠倒法。以圣印为印故。成就道场心。以不退印为印故。诸菩萨等。常成就清净心行。成就普庄严威仪行。不乐说世间技术语言。不乐近恶知识。不乐供养恭敬诸事。不乐说世间杂语。不乐说诸国土事。不乐说诸王事。不乐说贼盗事。不乐说妇女事。不乐说吉会事。不乐说征战事。不乐朋党诤讼。不乐诸恶国城邑聚落边地难处。不乐近伎乐歌舞戏笑等人

复次善男子。不乐与悭嫉人俱。不乐与破戒邪见多集诸恶放逸轻法等人俱。不乐与多嗔恨颠倒乱心人俱。不乐愚痴喑哑。如是等人悉不与俱。菩萨摩诃萨常乐勇猛舍法资生无畏等施。断除贪嗔痴烦恼大妙行者。乐离愦乱处乐于静默。常乐闲独所谓高山岩岭沟壑草木丛林清泉流水。乐如是等清闲之处。初夜后夜捐于睡眠精勤修行。发闻思修慧及诸禅定三昧陀罗尼自在神通无量无边百千万亿法门。而现在前。见无量百千万亿佛。得百千万亿三昧百千万亿陀罗尼门。能教化百千万亿众生。菩萨应成就如是等心。则能得彼如来妙法

尔时无所发菩萨摩诃萨白佛言。世尊。若能如实修行者。此大乘法故。即是如说修行者所乘之法。若能不放逸者。是人名为如实修行。世尊。又如实修行者谓发菩提愿。不放逸者谓满足菩提愿。复次如实修行者谓修行布施。不放逸者谓不求报。复次如实修行者受持净戒。不放逸者成就不退戒。复次修行者始修忍辱行。不放逸者得无生法忍。复次修行者。求一切善根而不疲倦。不放逸者舍一切所作事故。复次修行者始修禅定。不放逸者不住禅定。复次修行者满足智慧。不放逸者不戏论诸法。复次修行者守护妙法。不放逸者不见诸法。复次修行者令诸众生得大菩提。不放逸者不见诸众生。复次如实修行者聚集一切善根。不放逸者回向大菩提。复次如实修行者以菩提为实法。不放逸者如实知一切法如菩提相。复次如实修行者得无生法忍。不放逸者愿取有生。复次如实修行者往诣道场示现一切胜庄严事。不放逸者如实知阿僧祇劫。复次如实修行者如实知菩提。不放逸者过去诸业皆善修故。复次如实修行者至大涅槃。不放逸者善知诸法本性寂灭。世尊。菩萨摩诃萨。善能如是修行及不放逸。于得菩提不以为难。世尊。以是义故。菩萨摩诃萨应当修习如实修行及不放逸。世尊。是则名微妙法集。尔时慧命舍利弗白佛言。世尊。如我解佛所说义者。若有菩萨摩诃萨。于佛如来及诸菩萨所说法集。闻而生信及能修行。是诸菩萨有妙法集。何以故。若不信法者则无法集。若不行精进者亦无法集。若人能于诸圣所说法中。生希有心生如实心。是菩萨有妙法集。世尊。若人不自赞己亦不毁他。是人有妙法集。世尊。若人于圣慈心于非圣摄受心。若有人不见自胜不见他劣。若人于平等法生于等心。于不平等法亦生等心。于等亦生等心。于等不等亦生等心。而不分别等以不等。是人有妙法集。若人但闻一句。而能了知百千万句。当知是人有妙法集。若人闻法不静不乱。若人闻法不缚不解。若人闻法不行不住。若人闻法不增不减。若人闻法不喜不嗔。若人闻法不住世间不入涅槃。世尊。若能如是入于法集。当知是人有妙法集。世尊。我今所说法集为得随顺如来所说法集不耶。佛言如是。舍利弗。舍利弗。汝之所说随顺佛意

法集经卷第四佛说法集经卷第五

        元魏天竺三藏菩提流支译

尔时慧命大目揵连白佛言。世尊。若菩萨作是思惟。我能说法集。如是菩萨则不能说。何以故。有我见者生如是心。我能说法。彼人听法。若人远离我相。是人不见我能说法他能闻法。不见彼二非不见二。世尊。一切有法皆非实有。随何等法生分别心。谓是实有当知是法虚妄无实。诸菩萨等于彼法中不生分别。是法实有。何以故。不生分别。谓是实有菩萨摩诃萨。知一切法虚妄不实。犹如幻人有所言说。世尊。夫虚妄者实无而似有。如是之法。随顺于空不违因缘。随顺不生不灭。是人不违空法及诸因缘。随顺不生不灭。舍离种种分别。断我我见。远离一切邪见。诸菩萨摩诃萨。知诸法虚妄而能随顺世间。说名为有。若能如是说虚妄法令他人知。是名法集能说者。说何等法以为法集。说一切法法皆一相。如是法集是名微妙法集。世尊。我今所说法集。为得随顺如来所说法集不耶。佛言如是。目揵连。汝之所说随顺佛意

尔时慧命富楼那弥多罗尼子白佛言。世尊。世尊。若人为求福故说于法集。是人所说则为可呵。何以故。以着我故。若着我我所相。是人所作罪行福行不动行。不离邪见所作事。当知是人不能自利亦不利他。世尊。若人不能知如是法集。是人不起罪行福行及不动行。若人能知法集。是人不集五阴亦非不集。不集十八界亦非不集。不集十二入亦非不集。是人不取众生亦非不取。法亦非不取。不取实亦不取虚。不取境界亦不离境界。是人不取贪嗔痴亦不离贪嗔痴。不取世间不取涅槃。不取诤讼亦不取默然。不取空亦不取邪见。不取无相亦不取觉观。不取无愿亦非不取。不取诸佛法亦不取凡夫法。不取法亦不取非法。不取圣僧亦不取外道僧。世尊。菩萨摩诃萨知一切法。不求究竟处。何以故。是菩萨。知一切法无非究竟故。是菩萨不求解脱。一切诸法本性寂灭。无非解脱。是菩萨不乐一法。亦不厌一法。是菩萨。知诸佛法非是自法亦非他法。不取一法不舍一法。若有取舍则为可呵。不行不住。若有行住是亦可呵。不喜不忧。若有忧喜是亦可呵。世尊。如是所说名为法集。世尊。我今所说法集。为得随顺如来所说不耶。佛言。富楼那。汝之所说随顺佛意

尔时慧命摩诃迦旃延白佛言。世尊。若人有法相非法相。依此二相说法者。是人名为住无明中。何以故。若人见非法如实见。则是真法。世尊。若菩萨如实见非法。即是真如。世尊。夫真法者。无所从来无所至去。法不依人。世尊。法于人不远不近。法于处所亦无远近。世尊。法无是念。我于上众生行。于下中众生不行。于下中众生行。于上众生不行。世尊。法非相得名。亦非非相得名。何以故。世尊。圣人见所有相者皆是缚。非相者亦是缚。世尊。法非离亦非修行。世尊。能知法者远离离修行。世尊。法不与他亦不自取。而随所欲利益不同。以无作者故。世尊。法于诸佛不生亲想。毛道凡夫不起怨心。世尊。以无分别戏论想故。世尊。法不近佛不远凡夫。而随所行得法不同。世尊。如是之法是名法集。世尊。我所说法集。为得随顺如来所说法集不耶。佛言。摩诃迦旃延。汝之所说随顺佛意

尔时慧命大迦叶白佛言。世尊。若人求于寂静而说法集。如是之人则无法集。世尊。一切诸法不离寂静。以无二故。夫二法者不知于二。以其远离心意意识智故。一法者亦不求二。以其远离求欲法故。一法者亦不二。以无所造作故。复次世尊。夫寂静者则不二法。不二法者不离诸法。世尊。一切诸法不二相。以自性空故。自性无相自性无愿自性无行。自性不生不灭。非清净相而亦可得。亦非不净相而是可得。非悭者得。非能施者得。非破戒者得。非持戒者得。非嗔恨者得。非忍辱者得。非懈怠者得。非精进者得。非散乱者得。非禅定者得。非愚痴者得。非智慧者得。若能如是不得诸法。是则名为真实得法。若于诸法有所得者则不能得。有所行境界者则不能得。心行境界者。行二法者。见所有法者。依止法者。求证法者。离烦恼者。求究竟者。见佛者。见法僧者。见世间者。见涅槃者。则不能得如是境界

复次世尊。若人求法者。于一切法应无所求。世尊。于一切法无所求者名真求法。世尊。正见菩萨不见于法及以非法。而于诸法如是思惟。远离我所心无所著。名为真法。若远离虚妄不实。名为真法。若远离一切求。名为真法。若知一切法离戏论。名为真法若有菩萨能如是说。是则名为真实法集。世尊。我今所说妙法集。为得随顺如来法集不耶。佛言。迦叶。汝之所说随顺佛意

尔时慧命须菩提白佛言。世尊。夫言法者名为不诤。若能不诤是人有法。世尊。眼之与色无有静竞。耳声鼻香舌味身触意法亦无所诤。是名为法。又云何眼色二法无所诤竞。以不和合故。以此二法不相到故。耳声鼻香舌味身触意法。亦不和合不相到故。夫不到不合法皆无违诤。世尊。法无有二。是故法不诤。世尊。诸法无二各不相知。不知不分别。离种种分别。不生不灭不增不减不乐不厌。不住世间不住涅槃。夫真法者。不言人能得法法为人得。世尊。诸法不厌不乐不染不净。世尊。若人言我知我觉我说。如是之言。皆是虚妄分别十二入法。世尊。而此诸入无如是心我能分别。若人能知如是之法。当知是人不与物诤。若能不与物诤。是人随顺沙门道法。若能随顺沙门行法。是人不去不来不行不住不进不退。见诸法则法行。见诸法则解脱行。见诸法则法界。见诸法则究竟。而不见有究竟之者。诸所见法唯是名字。唯是虚假。唯是幻伪。若能如是见虚假不实。如是等人名为见法。世尊。见法者名为见佛。见非法名为见佛。见佛者名见诸众生。见非众生名见因缘。见非因缘名为见空。见非空名为不见。世尊。是名正见诸法。世尊。若能如是正见诸法。当知是人。能随佛意随顺于法随顺于僧。世尊。若诸菩萨。得如是等无诤法忍。尚不与彼诸魔共诤。况复与其同行菩萨而生违诤。若与违诤无有是处。何以故。是菩萨见一切语言皆能成就我行。是故不应与彼诤讼。以无诤讼故。菩萨毕竟得无诤法。以毕竟得无诤法故。是菩萨名为得一切毕竟法。于一切法中得平等。如见自身平等。见一切法亦复如是。平等住平等忍。是故名为得毕竟。诸法平等无所去无所来。是故名为得毕竟。世尊。菩萨如是得诸法毕竟。如是菩萨所有言说皆是法集。悉与众生安隐乐。须菩提白佛言。世尊。我今所说法集。为得随顺如来法集不耶。佛言。须菩提。汝之所说随顺佛意。须菩提。汝今说是法集时。五千天子远尘离垢。于诸法中得法眼净。五千天子发阿耨多罗三藐三菩提心。须菩提。若有菩萨闻汝所说微妙法集。是菩萨即知自身到大法海。即知此身为不空过必得妙乐。须菩提。是名诸佛如来第一法集

尔时慧命阿那律白佛言。世尊。一切法文字名为法集。何以故。文字之性无有尽相。无尽相者则是文字。世尊。我说言语唯是文字。世尊。夫文字者。不从自身出。不从他身出。是诸名字不作是念我出音声。世尊。诸文字者不增不减。世尊。菩萨知诸文字与一切法其性平等。世尊。菩萨若能如是毕竟知诸法音声。是故菩萨不为音声之所障碍。诸有所闻一切音声。皆是佛声皆是空声。是无相声是无愿声。是法界声是实际声。是菩萨无有一法能为障碍一切智。是菩萨不见有法离佛菩提。是菩萨见一切法悉无障碍。能见诸法同佛菩提不相违背。是菩萨不见诸法有进有退。是菩萨不见诸法而常利益一切众生。菩萨如是于诸法中得毕竟忍。得是忍故成就甚深乐说辩才。何者是甚深乐说辩才。随诸菩萨所有辩才。声闻辟支佛不能测量。是菩萨得安隐乐说辩才。安隐辩才者。随以辩才能令与一切众生得安隐乐。得应说辩才。应说辩才者。随诸众生所应闻法。称彼根性广略说法。是名应说辩才。又得捷疾辩才。捷疾辩才者。随以辩才言辞速疾教化一切众生。又得聪利辩才。聪利辩才者。随诸众生上根利智。为其说法令得利疾解脱。又得共上乐说辩才。共上辩才者。所有说法上与佛同。又增长辩才。增长辩才者。随以辩才说一字句。能生百千万亿上上辩才。得轻乐说辩才。何者是轻乐说辩才。随何等辩才知相藐而说法。又得爱乐辩才。爱乐辩才者。随以辩才令闻法者无有厌足。又得调顺辩才。调顺辩才者。所有辩才不违佛意。又得柔软辩才。柔软辩才者。所有辩才不生憍慢无放逸心。又得寂静辩才。寂静辩才者。随以辩才能令自他寂静。又得随顺音声辩才。随顺音声辩才者。随以辩才教化众生入声闻乘。又得远离辩才。远离辩才者。随以辩才教化众生令得辟支佛乘。又得最胜辩才。最胜辩才者随以辩才说辩才。随何等辩才教化众生令入大乘。又得不共辩才。不共辩才者。随以辩才能说十力四无畏十八不共法。又得寂灭辩才。寂灭辩才者。随以辩才能说诸菩提分法。又得无讥嫌辩才。无讥嫌辩才者。随以辩才令众生欢喜信乐。又得诸力辩才。诸力辩才者。随以辩才悉能降伏一切众魔外道邪论。又得善说辩才。善说辩才者。所有辩才为四众说法不生畏惧。世尊。如是名妙法集。世尊。我今所说法集。为得随顺如来所说不耶。佛言。阿那律。汝之所说随顺佛意

尔时慧命罗睺罗白佛言。世尊。菩萨欲说法集。应当推求受持法者。何以故。从受持者而得于法。是故应求。唯以专心求法为最。何以故。由于重法而能得法。不由重食得正法利。知舍身命必有来果。非于所观而得其报。常求静处不乐愦闹。近安隐者非破戒者。近恭敬者非憍慢者。近安乐行者非刚犷者。近柔软心者非坚鞕者。近寂静心者非着心者。近发露罪者非覆藏恶者。近乐一切施者非悭嫉者。近持戒者非破戒者。近忍辱者非嗔恨者。近精进者非懈怠者。近禅定者非散心者。近智慧者非愚痴者。近多闻者非少闻者。近正念者非邪念者。近修善业者非行恶业者。近爱乐佛法者非乐世法者。近乐空者非于邪见退没者。近持戒者非自归者。复次世尊。若人能持戒。是人则有法。何者是戒。世尊。一切诸戒悉皆摄在三种戒中。何等为三。所谓增上戒。增上定增上慧。世尊。若菩萨能于此三种戒中学者。当知是人已于一切大乘戒中学。世尊。何者是菩萨摩诃萨增上戒。世尊。菩萨能持波罗提木叉戒。而不以波罗提木叉戒为清净。以依修持菩萨戒。菩萨成就诸威仪境界。而不以威仪为清净。以住菩萨威仪境界故。乃至小罪心怀怖惧。以依菩萨智慧故。何者是菩萨智慧。谓菩萨如实知一切法。以其不畏诸业烦恼故。是名菩萨智慧。何者是菩萨境界。所谓为空非是种种分别境界。知平等戒以学于戒。知空平等而学于戒。是故言知空平等而学于戒。知无相平等。知无愿平等。知无行平等。知无生无灭平等而学于戒。是故言知平等而学于戒。复次世尊。菩萨作是念。我今以此波罗提木叉戒。令一切众生受持。是名菩萨增上戒学。世尊。何者是菩萨增上定学。所谓修习四禅四空三摩跋提。菩萨又作是念。我今以此增上定学。成就一切众生。是名菩萨增上定学。何者是菩萨增上慧学。所谓菩萨学十八空。菩萨又作是念。我今以此十八空法。令诸众生皆悉知见。是名菩萨增上慧学。世尊。菩萨此三种学。悉能摄取一切诸学。复次世尊。若有菩萨能护众生。如是菩萨能持净戒。若持净戒而不着持戒。如是菩萨依彼持戒满足一切诸众生心。世尊。出家持戒菩萨。于一切物不生爱着。寂静持戒菩萨。于一切言语不生乐心。宴坐持戒菩萨。于一切所说音声不生乐心。禅定持戒菩萨。于一切境界不生乐心。解脱持戒菩萨。于一切生处不生乐心。闻法持戒菩萨。于世间所说不生乐心。说法持戒菩萨。乃至往诣百千万亿由旬说法而不疲倦。护法持戒菩萨。于一切恼害逼切事中不生疲倦。菩提心持戒菩萨。诸所修行悉为安乐一切众生不为自身。深心持戒菩萨。欲令一切众生先得菩提不求自证。增上深心持戒菩萨。于利他事多生欢喜。不于己利而生喜心。修行持戒菩萨。为一一菩提分法。于无量劫精勤修行能成彼法而不疲倦。布施持戒菩萨。乃至能舍头目髓脑利益众生。尸罗持戒菩萨。不舍破戒众生。忍辱持戒菩萨。不畏一切诸魔扰乱。精进持戒菩萨。为诸众生修习菩提而不疲倦。禅定持戒菩萨。于一切音声及一切所作事不生染着。般若持戒菩萨。见一切法其性平等如菩提相。空行持戒菩萨。不行世间行。大悲持戒菩萨。不入涅槃。世尊。如是持戒名为法集。世尊。我今所说法集。为得随顺如来所说不耶。佛言。罗睺罗。汝之所说随顺佛意

尔时慧命优婆离白佛言。世尊。若菩萨自远离烦恼。亦令众生远离烦恼。所有众生界法界贪嗔痴界。菩萨作是念。乃至众生界尽。法界尽。贪嗔痴界尽。于尔所时。教化众生而不疲倦。菩萨又作是念。一切诸法本性寂灭。而诸众生不觉不知。何以故。诸法空寂彼处不行。所谓一切邪见及诸诤讼皆悉不行。一切法无相灭。彼处一切觉观思惟等心皆悉不行。一切法无愿灭。彼处一切所求愿欲等法皆悉不行。一切法无我灭。彼处一切所著皆悉不行。一切法无众生灭。彼处一切种种皆悉不行。一切法无命灭。彼处一切生死皆悉不行。一切法实谛灭。彼处一切虚妄皆悉不行。一切法因缘集灭。彼处一切寿者皆悉不行。一切法四念处灭。彼处一切诸念诸行皆悉不行。一切法四正勤灭。彼处一切诸法无取无舍不行。一切法四如意足灭。彼处无去无来不行。一切法五根灭。彼处一切高下不行。一切法五力灭。彼处一切降伏不行。一切法七觉分灭。彼处一切闇相不行。一切法八圣道灭。彼处恶业邪思惟皆悉不行。一切法十力灭。彼处一切习气不行。一切法四无畏灭。彼处一切惊怖畏惧不行。一切法十八不共法灭。彼处一切功用行不行。一切法智慧灭。彼处一切无明不行。一切法无作者灭。彼处一切行不行。一切法无念灭。彼处一切智识不行。一切法无觉灭。彼处一切名色不行。一切法无依灭。彼处一切六入不行。一切法不尽灭。彼处一切触不行。一切法不智灭。彼处一切受不行。一切法无我灭。彼处一切爱不行。一切法无所取灭。彼处一切取不行。一切法无身灭。彼处一切有不行。一切法不灭。彼处一切生不行。一切诸法坚固灭。彼处一切老不行。一切法不尽灭。彼处一切死不行。世尊。是名诸菩萨无障碍智门。菩萨住此无障碍智门。一切诸魔不能降伏。外道论师不能破坏。知一切烦恼不能染污。一切诸佛常共赞叹。一切诸天之所归敬。世尊。菩萨摩诃萨能到如是毕竟智门。名为得大法藏。名为不贫穷。名为守护诸佛如来密藏。名为诸佛如来所可信者。名为所应作已作所应办已办。名为逮得己利。犹如大海不可测量。如须弥山不可倾动。世尊。如是名为胜妙法集。世尊。我今所说法集。为得随顺如来所说不耶。佛言。优波离。汝今所说随顺佛意。优波离。诸菩萨摩诃萨依此法集而修行者。能得阿耨多罗三藐三菩提

尔时慧命阿难白佛言。世尊。诸菩萨护持妙法。于诸业中最为殊胜。世尊。菩萨若能修行护持妙法。随顺菩提及诸佛如来。何以故。诸佛如来尊重法故。世尊。云何是护持妙法。所谓菩萨能说诸佛一切甚深修多罗。能读能诵思惟修习。是名菩萨护持妙法。复次世尊。若菩萨摄受修行名为护持妙法。世尊。何者是菩萨摄受修行。世尊。诸菩萨等所有身业口业意业。皆为利益一切众生。大悲为首大慈增上。加护众生得安隐乐。护法菩萨。如是深心作是思惟。随以何行能与众生安隐乐事。我应修行如是等行。是故则成五阴中观。虽作此观而能不求舍离五阴观界如毒蛇以修于行。而心不求舍十八界。观入如空聚落以修于行。而心不求舍十二入。如是观色如聚沫以修于行。而心不舍成就诸佛如来色身庄严。观受如泡以修于行。而心不舍成就诸佛如来禅定三昧三摩跋提诸佛妙乐。观想如阳焰以修于行。而心不舍成就诸佛如来智慧修行。观行如芭蕉以修于行。而心不舍成就诸佛如来妙法修行。观识如幻以修于行。而心不舍成就智慧为首身口意业清净修行。修行布施不求果报。修行持戒救破戒众生。修行忍辱能调伏众生。修行精进成就一切善法。修行禅定成就身心柔软。修行般若照了一切法相。修行四念处则身心无垢。修行四正勤得无障碍智。修行五根能成进趣行。修行五力则不退菩提。修行七觉分则无疑网。修行八正道则无过失。修行四梵行得如意自在。复次世尊。若菩萨知空则能摄受妙法。又空者名无戏论。世尊。有戏论者则无摄受妙法。世尊。若知空无相。是人名为摄受妙法。若取相者则为无有摄受妙法。世尊。以诸法空无相故则无有愿。无有愿者则能摄受妙法。依止愿者则无摄受妙法。世尊。见诸法者则无摄受妙法。依止我我所者则无摄受妙法。有憍慢者则无摄受妙法。依供养恭敬赞叹者则无摄受妙法。依嫉妒悭吝者则无摄受妙法。着欲害嗔恚者则无摄受妙法。世尊。摄受妙法者。以菩萨于众生不生差别相。于法不生差别相故。世尊。如是菩萨摄受妙法。世尊。菩萨见诸法不生不灭。是名菩萨摄受妙法。菩萨见诸众生不去不来。是名菩萨摄受妙法。见自身不染不净。是名菩萨摄受妙法。于诸佛法不乐。于外道法不厌。是名菩萨摄受妙法。受持八万四千法藏。而不起法相之心。是名菩萨摄受妙法。不共一切烦恼随烦恼。及住一切恶不善法而不起非法相。是名菩萨摄受妙法。得解脱心而不起心我得解脱。是名菩萨摄受妙法。于一切诸佛作弟子之业。而不起身口意心以修于行。是名菩萨摄受妙法。于一切法皆悉自在。而不起法非法想。是名菩萨摄受妙法。于一切诸法不取不舍。而修于行。是名菩萨摄受妙法。不为得法亦不为证。而修于行。是名菩萨摄受妙法。于一切物中不生着心。是名菩萨摄受妙法。若菩萨起非凡夫非学人非罗汉心无所依止。而断贪嗔痴结。是名菩萨摄受妙法。若菩萨于菩提得受记莂。而不求佛菩提。是名菩萨摄受妙法。若菩萨诣道场时。于一切处皆见道场。是名菩萨摄受妙法。若能降伏诸魔。而不见诸魔及魔眷属。是名菩萨摄受妙法。若能成佛菩提。而不证先所无法。是名菩萨摄受妙法。若能转大法轮。而不成众生不坏众生。是名菩萨摄受妙法。若能降伏诸魔外道而不斗诤。是名菩萨摄受妙法。若能生而非新生而非故生。是名菩萨摄受妙法。若能死而不尽。是名菩萨摄受妙法。若能超过三界而无去处。是名菩萨摄受妙法。若能离诸言语音声而无言语。是名菩萨摄受妙法。若能于一切法不贪。于一切法不厌。是名菩萨摄受妙法。世尊。是名胜妙法集。世尊。我今所说法集。随顺如来所说法集不耶。佛言。阿难。汝所说法集深得我意。阿难说是妙法集时。八万天子发阿耨多罗三藐三菩提心。三万二千菩萨得无生法忍。五百比丘远离诸漏心得解脱

尔时弥勒菩萨摩诃萨白佛言。世尊。世尊。譬如舍于糠糟取于米实。世尊。菩萨亦复如是。舍于非法取于正法。又菩萨舍于悭贪取于布施。舍于破戒取于持戒。舍于嗔恨取于忍辱。舍于懈怠取于精进。舍于散乱取于禅定。舍于愚痴取于般若。是名胜妙法集。复次世尊有所求者则是非法。若不求者则是不取。若不取者则是不护。若不护者则是不染。若不染者则是不诤。若不诤者则是不吝。若不吝者则是不损。若不损者则是不行。若不行者则不退转。若菩萨不退转者。是菩萨诸佛如来为授阿耨多罗三藐三菩提记。世尊。是名为法。是名胜妙法集。复次世尊。若菩萨生如是心。我不退转阿耨多罗三藐三菩提心。是菩萨诸佛如来则不与授记。何以故。世尊。一切烦恼以求为根本。世尊。远离诸求名为离烦恼。以离烦恼故。诸佛如来为其授记。复次世尊。菩萨作是思惟。受记者是世间虚妄言说。何以故。受记之人是无。能授记者亦无。若俱无者何处受记。唯然世尊。大悲随顺世间有是言说。若菩萨能知如是诸法。是名菩萨受记。世尊。譬如幻师为幻授记。而彼幻化者无如是心。我受记我成正觉。世尊。菩萨亦复如是。如彼幻化无分别心。而菩萨作是思惟。菩提非可证相亦非可舍相。菩提非是生相亦非灭相。菩提非是身证亦非心证。菩提不在内亦不在外亦非中间。菩提无如是心我是菩提。菩萨能证于我。世尊。是名胜妙法集。复次世尊。菩萨于欢喜地中不惭愧不忧恼。于离垢地中不增不减。于明地中不闇不明。于焰地中不取不舍。于难胜地中无胜无负。于现前地中不自觉不因他觉。于远行地中不去不住。于不动地中不动不分别。于善慧地中不成亦不欲成。于法云地中不自觉亦不他觉。于佛地中能作一切事而亦不作一切事。是故如来自然无戏论。世尊。是名菩萨摩诃萨胜妙法集。世尊。菩萨如是至随顺智。于所说法中而得自在。云何说法自在。于一切言语不着故。又得清净自在。云何清净自在。于一切处不染故。又得乐说自在。云何乐说自在。谓依一法字句不暂休息。于百千万劫说不可尽故。又得智自在。云何智自在。于一一法字句。能说为百千万法门故。又得生自在。云何生自在。随所随所利益众生之处。于彼彼处生故。又得三昧自在。云何三昧自在。于念念中若欲入三昧。即能入三昧故。又得住持自在。云何住持自在。随所随所住持加故。所谓若獐鹿若鸟兽。若草木若石壁。能说诸佛妙法故。又得眷属自在。云何眷属自在。得无量眷属不可坏眷属故。又得见自在。云何见自在。谓见妙色故。又得闻自在。云何闻自在。谓闻妙声故。又得鼻自在。云何鼻自在。所闻一切香唯是妙法香故。又得舌自在。云何舌自在。谓食法味不食食味故。又得身自在。云何身自在。得成就法身非食身故。又得心自在。云何心自在。乃至蚊虻蚁子知行知心故。世尊。是名胜妙法集

尔时见者爱乐菩萨白佛言。世尊。世尊。菩萨如是如是行以是等行众生见者即生欢喜。何以故。世尊。菩萨余无所作唯教化众生。世尊。是名菩萨根本胜妙法集。世尊。是故菩萨应当修学乐法之行。世尊。何者为爱乐法。菩萨有四种爱乐法。何者为四。所谓不求果报而施一切众生平等之心。以爱语防护一切众生恶行利益成就。爱一切众生犹如自身以同事故。世尊。是名菩萨四种爱乐法。为一切众生之所爱乐。复次菩萨摩诃萨有四种法。能作爱乐事。何者为四。谓多闻慧以无憍慢心故。说法忘相以离供膳心故。于彼尊者生于尊重以求智慧故。发行精进以教化一切众生故。是名菩萨四种法能作爱乐事。复次菩萨有四种法。能作爱乐事。何等为四。所谓成就净戒以法施施故。成就知足以寂静处住故。以住闲默处故。得于禅定善住城邑聚落。以不破诸威仪境界故。是名菩萨四种法能作爱乐事。复有四法。所谓。实语者以乐说故。法语者以说空故。忍辱语者以平等心故。寂灭语者以护诸根故。是名菩萨四法能作爱乐事。复次菩萨有四种法。能作爱乐事。何者为四。所谓先意问讯以善语故。其意易满以随得少事而知足故。成就不谄曲以如语如说行故。无欺诈稠林行以不诳一切众生故。是名菩萨四种法能作爱乐事。复次菩萨有四种法。能作爱乐事。何者为四。所谓不生恶心以内寂静故。不生痴心以外不颠倒故。不生悭心以观一切事无常故。不生憍慢心以如实知诸法故。是名菩萨四种法能作爱乐事。复次菩萨有四种法。能作爱乐事。何者为四。所谓得甚深心先意问讯故。远离爱染得柔濡爱语故。舍离一切诸心而常不舍菩提心故。深心第一义而随顺世谛故。是名菩萨四种法能作爱乐事故。世尊。是名胜妙法集。复次世尊。菩萨得第一空得大通明。得大自在。善知说于法集爱乐甚深之法。随顺诸众生。毕竟得不可思议希有法者。得柔濡法者。得大通者。得大法师者。得大法王者。得大所作者。作大众生依者。得大通奋迅者。为教化众生不退。而生不生而死不死。所作已成而成菩提。得解脱心而发精进。入于涅槃。而行满足。而求不求。而修行一切智。而问于他。世尊。一切诸海可以量知。而彼菩萨摩诃萨大乘智海不可量知。世尊。虚空清净可以尘垢。而彼菩萨摩诃萨心不可得染。世尊。风虽无形可以手执。而彼菩萨摩诃萨心六尘境界所不能着。世尊。春阳之炎可以摄摩。而彼菩萨摩诃萨我我所心不可而得。世尊。是名胜妙法集

尔时善目菩萨摩诃萨白佛言。世尊。世尊。菩萨修一切诸法。唯是发菩提心以为根本。何以故。世尊。一切诸法皆是虚妄唯心分别。体无诸物离一切物。如幻无根本。随所求而成。远离作者受者。其性不住离于诸住故。世尊。一切诸法无始无终。以无二离二故。世尊。诸法无我无我所。以无主故。诸法平等如彼法界。以非客故。世尊。诸法非主。以远离诸贪故。诸法离于分别及种种分别。以远离可取及舍心故。诸法不来不去。唯是智境界故以其无知空主者故。世尊。时诸毛头凡夫。于无我法中而生我想。于无众生中而生众生想。菩萨作是思惟。我以如是妙法。令诸众生而得解悟。世尊。是名菩提心。一切众生安隐心。乐心无上心。法界心光明心。众生住持心。依如是心而生。名为发菩提心。复次世尊。修行檀波罗蜜名为寂静心。修行尸波罗蜜名为不缺心。修行忍辱波罗蜜名为不损心。修行精进波罗蜜名为不退心。修行禅波罗蜜名为不乱心。修行般若波罗蜜名为不分别虚妄心。修行大慈名为柔濡心。修行大悲名为不退转心。修行大喜名为无厌足心。修行大舍名为无垢心。修行大施名为不吝心。修行爱行名为不稠林心。修行利益行名为平等心。修行同事名为最上心。修行空慧名为无分别心。修行无相智名为无念心。修行无愿名为不住心。修行菩提行名为三十七菩提分心。修行进趣行名为念佛心。修行不破坏行名为念法心。修行法界心名为念僧心。修行无量心名为念戒心。修行不取心名为念舍心。修行念天心名为念诸善根。以为诸善根聚集庄严故。以彼胜生为发菩提心。聚集诸善根故。世尊。我依发菩提心说。彼一劫若无量劫而不可尽。如是诸菩萨聚集无量因缘。而发菩提心。是故世尊。菩萨欲推求诸善法者。应于发菩提心中而知而求。世尊。是名胜妙法集

尔时善生菩萨白佛言。世尊。世尊。诸法善生以根本清净故。世尊。何者是诸法根本。世尊。诸法以空为根本。以彼处无诸见故。诸法以无相为根本。以彼处无诸觉观故。诸法以无愿为根本。以彼处无三界烦恼故。诸法以无行为根本。以彼处无作者故。诸法以无我为根本。以彼处不见我行故。诸法以离众生为根本。以彼处不见众生行故。诸法以无命为根本。以彼处见命不行故。诸法不生。以彼处不行常见故。诸法不灭。以彼处不行断见故。诸法无物。以彼处不行有见故。诸法如涅槃平等。以彼处不行离有见故。诸法如菩提。以彼处不行见佛故。诸法不作。以彼处不行见法故。诸法不和合。以彼处不行见僧故。世尊。是名胜妙法集

尔时大导师菩萨白佛言。世尊。世尊。若菩萨欲先与一切众生大菩提。不为自身证大菩提。若菩萨诸所作业。为一切众生不为自身。而不见众生而不舍大慈大悲心。是名菩萨。世尊。何者是诸菩萨大慈大悲。世尊。若菩萨不见众生。而不舍一切诸善根修行。彼诸善根回向大菩提。是名大慈。若菩萨不舍诸众生所作之事。是名大悲。若菩萨见世间法则是涅槃。而不舍集道精进。是名大慈。若不舍众生。是名大悲。若自身发菩提心。是名大慈。若教化诸众生。是名大悲。若舍内外一切诸物。是名大慈。若舍内外善根。为一切众生。得佛菩提。回向无上道。是名大悲。若净持诸戒不毁不犯。是名大慈。若自持净戒。增长众生净戒。是名大悲。若自修行安隐忍辱乐行。是名大慈。若以安隐乐与诸众生。是名大悲。若于自身常能修行精进之行。为得诸佛无上菩提。是名大慈。若以大精进行。令诸众生得此精进。是名大悲。若于自身常行寂静。是名大慈。若以寂静行。令诸众生得此寂静。是名大悲。若为自身修满智慧。是名大慈。若以自智慧。增长一切众生智慧。是名大悲。若不修行非不修行。是名大慈。若不作亦非不作。是名大悲。若生而不去。是名大慈。若去而不动。是名大悲。若说而无言。是名大慈。若着而不缚。是名大悲。若缚而不得。是名大慈。若入涅槃而不灭。是名大悲。若出自身舍利而无骨肉筋血。是名大慈。若彼修身骨不增不减。是名大悲。若舍施而不舍物。是名大慈。若护诸护而不成就。是名大慈。若增长而不高。是名大悲。世尊。是名胜妙法集

尔时光明幢菩萨白佛言。世尊。世尊。菩萨以寂静定心为最上业。何以故。菩萨住寂静心中。诸佛妙法自然现前。世尊。菩萨尊重寂静定心安隐乐故。而得菩提。及得诸陀罗尼门。世尊。何者是菩萨陀罗尼。所谓随所随所闻法能不忘失。随所随所闻法而能受持。随所随所闻法而能了知。及诸众生亦令了知。是名陀罗尼。随何等陀罗尼。不增长不分别。随何等陀罗尼。能受持八万四千法门。而不忘失而不遗漏。随何等陀罗尼。知诸众生心心所行。以知诸众生心故。随彼彼众生如是如是说法。随何等陀罗尼。能闻一切众生语言。以闻诸声闻凡夫声得于大悲。闻诸圣人声得于大慈。随何等陀罗尼。闻取一句法。能于无量劫说。如是菩萨乐说辩才。不留不尽亦无际畔。随何等陀罗尼。如实知诸言音。随何等陀罗尼。知一切言说皆是佛语。随何等陀罗尼。于十方世界诸佛菩萨所住之处。说法音声所闻之者一切受持。如是菩萨于一佛所闻法。如是于第二佛所说法无有障碍。世尊。是名菩萨受持陀罗尼。世尊。菩萨得起陀罗尼。随何等陀罗尼。现前说一切法。如说一法一字一句。如是说一切法界。然是菩萨不生憍慢之心。不起放逸之行。得增上陀罗尼。随何等陀罗尼。能说一切世间现前见法。及一切世间现前见得集陀罗尼。随何等陀罗尼。能断一切众生疑惑。及断一切烦恼。得为增上及集陀罗尼。随何等陀罗尼。能令增长一切白法。能令尽一切烦恼。得行陀罗尼。随何等陀罗尼。知一切法。知一切法光明。是菩萨如实知诸法而不分别。修行诸法而自身心实不修行。说于诸法而不说诸字。舍于诸法而亦不失。增长诸法而不增一物。损减诸法而不损一法。说于诸法而无言说。令入涅槃而于世间不动。令得圣人地而不离于凡夫地。降伏一切诸魔而非身心意所起作业。世尊。是名诸菩萨胜妙法集

尔时解脱月菩萨白佛言。世尊。一切诸法以解脱为相。世尊。菩萨不分别是缚是脱。何以故。世尊。解脱非他他非解脱。世尊。解脱者不增一法。亦非不减一法。世尊。解脱无所从来。世尊。缚亦无所至去。世尊。得解脱菩萨不生如是心我得解脱。其心唯知犹如解脱。一切诸法亦复如是。世尊。若菩萨起如是心。世间是垢染法。涅槃是清净法。是菩萨不得解脱。何以故。有我见者生如是心。世尊。若人起如是心。我厌阴界入求入涅槃。是人不得解脱。何以故。有我见。有我见者生如是心。世尊。得解脱心比丘作是思惟。一切诸法如解脱相。而诸毛头凡夫。不识不知生如是心。我以如是法。令一切众生知故。世尊。得解脱心比丘。我得解脱生如是心。是诸凡夫于一切法。常解脱中而求解脱。我于彼彼众生。生大悲心。何以故。若人求解脱是人不得解脱。是故世尊。比丘欲得解脱者。应观能缚及所缚。应知能缚及所缚。是人不分别解脱。若不分别者。是人则得解脱。世尊。是名菩萨胜妙法集

法集经卷第五佛说法集经卷第六

        元魏天竺三藏菩提流支译

尔时大海慧菩萨白佛言。世尊。世尊。菩萨不应畏诸烦恼。何以故。以有烦恼随。何处有烦恼。彼处有菩提。断烦恼者则无菩提。世尊。空及一切烦恼。此二即一无差别。世尊。菩提及一切烦恼一切众生。此等诸法亦即是一无有差别。但诸毛头凡夫堕颠倒心分别我染我净。世尊。正行菩萨不断烦恼不取净法。而是菩萨。观诸烦恼门。得诸三昧及诸陀罗尼门。是故世尊。菩萨知诸佛法以烦恼为性。彼如是烦恼随。何等众生具散乱心颠倒心。彼毛头凡夫众生。必入恶道受诸苦恼。诸菩萨如是正观。能得诸佛菩提。是故世尊。诸菩萨则应修行随顺逆流。不随顺顺流。世尊。诸菩萨得解脱者。于涅槃中非于世间中。何以故。诸菩萨应畏于涅槃不畏世间。以观世间得于大悲。及证大菩提故。若分别涅槃厌畏世间。如是菩萨以厌世间故。退于诸佛无上菩提。世尊。诸菩萨于世间众生。成大慈大悲。非于得涅槃涅槃众生。世尊所言涅槃。涅槃者是于寂灭虚妄分别不实之心。世尊。是故菩萨愿见涅槃。应观虚妄分别寂灭之心。如是之处得于涅槃。世尊。是名胜妙法集

尔时观世音菩萨白佛言。世尊。菩萨不须修学多法。世尊。菩萨若受持一法善知一法。余一切诸佛法。自然如在掌中。世尊。何者是一法。所谓大悲。菩萨若行大悲。一切诸佛法如在掌中。世尊。譬如转轮王所乘轮宝。随往何处一切四兵随顺而去。世尊。菩萨摩诃萨亦复如是。乘大悲心随至何处。彼诸佛法随顺大悲自然而去。世尊。譬如日出朗照万品。一切众生作业无难。世尊。菩萨摩诃萨亦复如是。随于何处大慈悲日照于世间。彼处众生于一切菩提分法修行则易。世尊。譬如诸根以意为本。悉能随意取于境界。世尊。菩萨摩诃萨亦复如是。依于大悲住持一切菩提分法。随诸分中。随可作事中自然修行。世尊。譬如依彼命根有余诸根。世尊。菩萨摩诃萨亦复如是。依于大悲有余一切菩提分法。世尊。是名胜妙法集

尔时坚意菩萨白佛言。世尊。诸法直心深心以为根本。世尊。若菩萨无直心深心。是菩萨则为远离诸佛妙法。世尊。成就直心深心菩萨。若无佛说法。于上虚空及树木石壁等中。自然出于法声。世尊。直心深心菩萨。意自能念闻于法声。随顺一切诸佛妙法。是故世尊。菩萨摩诃萨应当修行直心深心。世尊。如人有足则能游行。如是世尊。菩萨摩诃萨亦复如是。有直心深心。诸佛妙法自然修行。世尊。譬如有人具足上分则有寿命。世尊。菩萨摩诃萨亦复如是。若有直心深心。如是菩萨则有诸佛菩提。世尊。如人有命则得诸事。世尊。菩萨摩诃萨亦复如是。若菩萨有直心深心。是菩萨则得成就一切佛法。世尊。譬如有于可然故有能然。离于可然则无能然。世尊。菩萨摩诃萨亦复如是。若有直心深心。则能炽然诸佛妙法。若离直心深心。则不炽然诸佛妙法。世尊。譬如有云则能有雨。世尊。菩萨摩诃萨亦复如是以有直心深心。则有诸佛法雨。世尊。譬如树根腐败则不能生芽叶华果。世尊。菩萨摩诃萨亦复如是。若无直心深心。则一切诸佛善法不复生长。是故世尊。菩萨欲得诸佛菩提。应自善取直心深心。善自守护直心深心。善自清净直心深心。世尊。是名胜妙法集

尔时善护菩萨白佛言。世尊。菩萨不须守护诸法。世尊。若菩萨但能善护自心。是菩萨善护自心故。则能成就诸佛妙法。世尊。若菩萨守护诸法。是菩萨则不能得无生法忍。世尊。若菩萨不护诸法而入禅定。是菩萨则无过失。亦不违于诸佛菩萨。则能自心知诸佛法而不护自心。见如是心依因缘生。如是见一切诸法依因缘生。见自心如幻。如是见诸法如幻。而心非内非外非二中间可得。如是见一切诸法。见即如心无于色相。不可得示不可得见。无于形碍不可执捉不照不住。见一切诸法其相如是。若能如是见者。是菩萨则能得于平等之心。以得平等心故。如是菩萨不复更得于法。是菩萨不复住不复行。不取不舍及以不求。以不求故而能不取。以不取故而无所著。以不着故而能不染。以是菩萨不染一切法。世尊。是名胜妙法集

尔时虚空菩萨白佛言。世尊。菩萨不作如是言。以何等言说能生他人嗔心。菩萨不作如是言。以何等言说能生他人恼心。菩萨不作如是言。以何等言说能令他人不知。菩萨不作如是言。以何等言说无义虚妄。菩萨不作如是言。以何等言说能令不生智慧光明。菩萨不作如是言。以何等言说能令其心不生欢喜。亦不具足及以耳闻不生喜乐。菩萨不作如是言。以何等言说令破坏二处。世尊。菩萨不作如是言。以何等言说令他不能解空。何以故。世尊。一切言说。彼如是言说最为坚固。以何等言说。令他能知于空。世尊。若菩萨能知诸法空义。无心无我其相不二。远离二相而不舍一切众生所作事业。是名菩萨无障碍大悲。若菩萨行无障碍大悲。是菩萨能学诸佛所学。若学诸佛所学。是菩萨能知诸法如虚空。以知诸法如虚空故。是菩萨得虚空藏。是菩萨为欲舍者能舍诸舍。而于舍及悭不生二心。破戒持戒。忍辱嗔恨。精进懈怠。散乱禅定。愚痴智慧。不生二想。是菩萨不复求诸佛妙法。不舍诸凡夫恶法。世尊。譬如一切诸水入于大海。皆同一味所谓碱味。世尊。菩萨亦复如是。入于第一义大海。所见一切诸法皆是一味。所谓真解脱味。世尊。譬如日光等照一切众生。世尊。菩萨智慧亦复如是。等照一切诸法。世尊。一切诸法不违于空。世尊。若菩萨能如是知。是菩萨能于一切法中见真菩提。若菩萨于一切法中见真菩提。是菩萨知所说言音皆是佛语。是菩萨无所著而说于法。是菩萨名为得无障碍乐说辩才。世尊。是名胜妙法集

尔时文殊师利菩萨白佛言。世尊。世尊。世间之人颠倒妄取。若如是言。依波罗蜜故菩萨得名。此则不然。何以故。世尊。依于菩萨诸波罗蜜得名故。世尊。若依波罗蜜菩萨得名者。亦应依诸众生名为菩萨。此义不然。何以故。世尊。菩萨生诸波罗蜜。菩萨知诸波罗蜜。以菩萨生诸波罗蜜。为诸众生说。是故如来常说。菩萨未曾生法而能生。未曾成法而能成。未曾说法而能说。世尊。诸波罗蜜不能护菩萨。而菩萨能护诸波罗蜜。是故说菩萨能护诸法。世尊。诸波罗蜜不能住持菩萨。菩萨能住持诸波罗蜜。是故说菩萨能受持法。世尊。一切诸法无病。以自体无垢故。世尊。一切诸法不二。以远离众生我身故。一切诸法无心。以远离可取舍故。一切诸法无意识。以无始发故。一切诸法无来相。以无间故。一切诸法无去。以不动故。一切诸法无死。以无命故。一切诸法不活。以本来不食故。一切诸法无物。以不和合故。一切诸法不减。以法界无差别故。一切诸法不可割截。以无形故。一切诸法如金刚。以实际平等故。世尊。知如是诸法。是菩萨能知诸法实体。若知诸法实体。是菩萨能知于空。若能知空。是菩萨不与他诤竞。若不与他诤竞。是菩萨能住沙门法中。若能住沙门法中。是菩萨则能不住。若能不住。是菩萨于诸漏境界不起于漏。若于诸境界不起于漏。是菩萨能无诸病。若无诸病。是菩萨名为如来。若菩萨得名如来。是菩萨不说二语。若不说二语

是菩萨不舍世间不取涅槃。唯为一切众生。而说远离一切分别虚妄烦恼。世尊。是名胜妙法集。不颠倒集名为空集。无相无愿无行不生不灭集。无生法忍集。大乘集。转大法轮集。大波罗蜜集。诸大地集。一切诸法不颠倒集。世尊。诸菩萨依大法集。修持受行。或于国土作转轮王。受持十善业道。能令众生安住十善业道。或作胜首。教化众生令得出世间胜事。或作大长者。能令众生厌世间恶事。或作天帝释。能令诸天不起放逸。或作梵王。能令众生住于禅定四无量等。或作四天王。能令众生于诸法中不能染心。或作沙门。教化众生令不闻恶法。或作婆罗门。教化众生令知寂静之处。自身寂静令诸眷属亦住寂静。自身柔软令诸眷属亦得柔软。具足住于一切处。以得大自在。能作大法师。以能断一切众生疑故。于一切处不生怯弱。以一切烦恼尽故。世尊。是名胜妙法集

尔时世尊告文殊师利菩萨摩诃萨。文殊师利。若有众生。闻说文殊师利如是胜妙法集。及闻诸菩萨胜妙法集。及诸声闻胜妙法集。而能知能信。彼诸众生深种善根。非于一佛而修供养。非于一佛二佛而种善根。何以故。文殊师利诸佛如来甚深菩提。是黠慧者能知法者深妙境界。文殊师利。是妙法门。微少善根众生不能得闻。假令得闻亦不能信。若菩萨自身能证。是菩萨能信。复有诸善知识护故。是人能信而能受持。能得无生忍。文殊师利。离此法行无有一人成佛。文殊师利。过去恒河沙诸佛如来成佛菩提。彼诸佛行如是法行。得阿耨多罗三藐三菩提。文殊师利。若人远离此法行欲得菩提者。是人如缚虚空不能得法。离此法行随顺法忍尚不可得。何况能得无生法忍而成阿耨多罗三藐三菩提

文殊师利。我诸声闻得俱解脱。得八解脱及四无碍。彼诸声闻。亦不离此法行而得解脱。文殊师利。宁闻此深妙法门起谤生于恶道。不能于余浅法门起信生于善道。何以故。谤此法门者生于地狱。因闻此法门。现前得于解脱。非闻余浅法门生于善道。文殊师利。菩萨摩诃萨。有四种法。闻此法门能生于信。何者为四。所谓是人过去世曾闻此法门。闻已随喜有大善根。有大善根庄严诸善知识。善护成就受持闻慧之行。文殊师利。是名菩萨四种法闻此法门能生于信。复次文殊师利。菩萨更有四种法。闻此法门能生于信。何者为四。所谓常思惟正念。常畏诸不善业。常作大菩提愿。自性质直柔软安隐乐修胜行。文殊师利。是名菩萨成就四种法闻此法门能生于信。复次文殊师利。菩萨成就四种法。闻此法门不生于谤。何者为四。所谓毕竟成就菩提愿得无生法忍。成就正见得不退阿耨多罗三藐三菩提心。文殊师利。是名得毕竟成就四种法闻此法门不生于谤。文殊师利。菩萨复有四种法。闻此法门能生于信。何等为四。所谓成就闻慧。成就般若成就空。以禅定得大陀罗尼。文殊师利。是名菩萨有四种法闻此法门能生于信。文殊师利。菩萨复有四种法。闻此法门而能了知。何等为四。所谓成就功德庄严。成就闻慧庄严。成就智庄严。成就诸禅定柔软心庄严。文殊师利。是名菩萨四种法。闻此法门而能了知。文殊师利。菩萨复有四法。闻此法门得受阿耨多罗三藐三菩提记。何等为四。所谓菩萨见一切色佛色。闻一切法佛法。远离一切诸求。乃至不求佛菩提不退于大悲。文殊师利。是名菩萨有四种法得受阿耨多罗三藐三菩提记。是故文殊师利。诸菩萨常应求闻读诵此经。文殊师利。菩萨愿速得菩提。常应勤求闻此法门。菩萨愿速得受记。常应勤求闻此法门。菩萨愿得断于业障。愿得断于烦恼障。愿得断于智障。是菩萨常应求闻此经。菩萨愿得诸佛如来无上供养。是菩萨常应求闻此经。愿得常护妙法。是菩萨常应闻受持读诵此经。文殊师利。若人闻此法门。能信能忍不生于谤。文殊师利。我授是人阿耨多罗三藐三菩提记。尔时无所发菩萨摩诃萨。于颈上脱八千万阿僧祇宝璎珞。奉散如来。作如是言。世尊。因此功德。令一切众生成就诸佛如来应正遍知。尔时彼璎珞于如来顶上住虚空中。作种种胜妙庄严大宝帐而住。四角形量。过于天人妙相庄严。彼诸声闻及一切菩萨。释提桓因梵天王四天王。未曾见闻。是大宝帐随如来去而去。随如来住而住。现如是妙事时。无量诸天人等。皆生希有奇特之心。佥于顶上合掌而住。赞叹如来。瞻仰如来目不暂瞬。尔时无所发菩萨摩诃萨。生于欢喜希有之心。偏袒右肩。礼如来足。合掌向佛。以偈赞言

  诸功德众如来器　　天人众生唯佛救
  佛于世间无胜者　　无胜寂静及平等
  等心无谄行亦然　　于世以悲牵缚心
  如空平等心无染　　安乐多人而说法
  世尊无亲无诸怨　　无有诸忧无欢喜
  能救世间如良医　　于世行慈无分别
  修罗天人龙夜叉　　归依于佛得寂静
  佛于三界为最上　　是故今者我归命
  善逝有为更无过　　而于寂静靡功德
  舍于二道无分别　　已得寂灭行世间
  寂灭境界不可测　　唯乃十力知如来
  如地及空不可量　　是故合掌而顶戴
  不沈不浮大波浪　　不漂不住无上人
  有海彼岸唯佛到　　无比智海我归命
  如莲处水无能污　　佛行世间法不染
  更无有能与佛等　　以无等故我归依
  如来无法而不知　　以有十力过一切
  于众奋迅无与比　　是故名佛勇独步
  能受诸佛甘露法　　是故远离一切畏
  无上医师胜应供　　是故归命大悲者

尔时无所发菩萨摩诃萨白佛言。世尊。世尊唯知我心。我不为自身供养如来。世尊。我奉璎珞供养如来。及赞叹如来。因此善根功德。愿令一切众生得于无上诸佛菩提。世尊。此是我意。尔时世尊熙怡而笑。诸佛如来熙怡而笑。必不虚妄。尔时如来从面门放种种色无量光明。譬如青黄赤白红紫颇梨金银等无量种色。普照十方无量无边世界。灭除一切恶趣众生无量苦恼。生诸天人无量喜乐已。还摄光明。围绕如来百千万匝。于如来顶上而没。尔时彼诸大众。见是光明心生欢喜踊跃安乐。合掌向佛于一面住。而作是念。如来何因熙怡而笑。尔时阿难从座而起。偏袒右肩。合掌向佛。以偈而问微笑因缘

  无上第一尊　　世间及天人
  瞻仰如来住　　疑于喜笑事
  大师离烦恼　　知法及化人
  熙怡必不空　　愿佛为解说
  面门放光明　　清净生喜悦
  天人及恶道　　光触身安乐
  大人放光明　　于其面门出
  是光为何义　　唯愿大慈说
  齿出胜妙光　　明艳甚鲜白
  显现最殊胜　　隐蔽一切光
  于明闇不现　　以是世间喜
  佛悲何所为　　何人功德起
  愿说慈所为　　除断我等疑
  远离烦恼人　　非无因缘笑
  妙光出面门　　普照于十方
  所作已还摄　　入于如来顶
  此光起佛意　　为表圣心出
  如电昼在空　　普照而不停

尔时佛告阿难。阿难。此无所发菩萨摩诃萨。于未来世过十二劫。当成阿耨多罗三藐三菩提。佛号大光明如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。劫名诸天赞叹。世界名大欢喜。阿难。彼大光明如来应供正遍知。寿命住一大劫。彼国众生寿命十二小劫。阿难。譬如他化自在天所受妙乐。彼佛国土众生所受妙乐亦复如是。尔时慧命须菩提。语无所发菩萨言。大士快得善利。如来今日授仁者记。必得阿耨多罗三藐三菩提。无所发菩萨言。大德须菩提。汝见何法名为成佛。须菩提言。善男子。我不见有法成阿耨多罗三藐三菩提。问曰若大德须菩提。若不见有法得成佛。何故诳我大士授于阿耨多罗三藐三菩提记。须菩提言。善男子。如来与仁者授记必得成佛。是故我作此说。无所发菩萨言。大德须菩提。诸佛如来如实知法。是故佛言。汝当得阿耨多罗三藐三菩提。云何如来如实知法。须菩提。若有菩萨求菩提者。诸佛不与是人授记。若有菩萨不求菩提者。诸佛如来则与授记。诸佛如来如实知法无授记相。而为众生种诸善根故。作是记汝当成佛。须菩提。汝见何法而作是言。大士必得阿耨多罗三藐三菩提。须菩提言。善男子。诸佛如来依世俗文字而说授记。我诸声闻随佛世尊故如是说。无所发菩萨言。大德须菩提。夫文字者。若依世俗名为文字。若于圣人则非文字。何以故。圣人所说皆是真实。世俗言语悉为虚妄。是故大德须菩提。不应以此世俗邪语圣法中说。大德须菩提。诸菩萨等为护众生。若闻甚深第一义谛惊怖不信。是故圣人以大悲心。舍真实法而说世间虚妄之语。为欲将护毛道凡夫。终不为圣作如是说。若为圣人则说实法。以此实法圣所爱乐。何等名为圣人实法。大德须菩提。圣实法者菩提之法。本性常寂名为真实。如菩提相本性清净。一切诸法亦如是相。是则名为圣人实法。须菩提言。善男子。有四真谛名为实谛。何等为四。苦谛集谛灭谛道谛。无所发菩萨言。大德须菩提。汝不说苦是有为耶。须菩提言。如是善男子。我常说苦是有为法。无所发菩萨言。大德须菩提。如来常说一切有为皆是虚妄。须菩提言。如是善男子。如来常说有为之法皆是虚妄。无所发菩萨言。若如是者。汝云何言苦是实谛。大德须菩提。若言苦是有为法者。即是虚妄。须菩提言。善男子。苦是有为虚妄不实。我说知苦以为实谛。无所发菩萨言。须菩提。若苦是有为虚妄不实。知彼苦智亦应虚妄非是真实。须菩提言。善男子。如是如是。知苦智者亦是虚妄。无所发菩萨言。大德须菩提。若如是者。云何知苦是圣谛智。须菩提言。善男子。灭谛是无为法。若尔何故非圣谛。无所发菩萨言。大德须菩提。灭何等法名为灭谛。为即自灭故名为灭。更有所灭称为灭耶。须菩提言。善男子。有为说者言。灭尽诸苦名为灭谛。无所发菩萨言。须菩提汝不说苦是有为虚妄不实耶。须菩提言。如是善男子。我向说言。苦是有为法虚妄不实。无所发菩萨言。大德须菩提。若法虚妄不实。是法无灭。若如是者。云何而言灭尽诸苦名为灭谛。尔时慧命须菩提白无所发菩萨摩诃萨言。善男子。我于大士如是无碍乐说辩才生随喜心。善男子。愿诸众生皆得是辩才。须菩提言。善男子。何者是诸菩萨摩诃萨实谛证智。无所发菩萨言。须菩提。一切诸法与实谛行不相违背。是故证一切法。名证实谛。须菩提。一切诸法从因缘生。能如实知因缘生法。名为实谛。一切法空如实知空名实谛。证空者名证实谛。一切诸法不生。证诸法不生名为证实谛。随何法证于实谛。于彼法中乃至无有一法可取一法可舍。须菩提。是名诸菩萨摩诃萨证实智。须菩提。言实谛者。即是宣说无分别法。何以故。须菩提。所有分别者皆是邪法。须菩提。汝向所言。大士快得善利授阿耨多罗三藐三菩提记必得成佛。须菩提。若人自谓快得善利。佛则不与是人授记。若人远离快得善利。如是之人佛则授记。若人于得利养不生欢喜。若失利养亦不忧恼。是人授记。若人不离世间。而得涅槃。是人授记。若人不舍凡法而证圣道。是人授记。若人闻得记不喜。是人授记。须菩提言。善男子。所向所知。若如是知其义甚深。无所发菩萨言。须菩提。若人不见有去来。是人则知甚深。须菩提言。此甚深法难可得知。无所发菩萨言。须菩提。若人欲见是甚深。是人则不能见。须菩提言。如是知者难可了知。无所发菩萨言。须菩提。无修行者亦难了知。须菩提言。善男子。何等众生。于甚深法能生信心。无所发菩萨言。须菩提。若人已曾供养过去无量佛。是人能信。须菩提。若人不能种诸善根。亦不修行供养诸佛。如是之人。终不能得闻此法门。须菩提言。善男子。云何得为供养诸佛。无所发菩萨言。若人能住如实修行。是人名为供养诸佛。须菩提言。善男子。云何能住如实修行。无所发菩萨言。若人能为诸众生发心修行。须菩提言。云何为诸众生发心修行。无所发菩萨言。若能不舍大慈大悲。须菩提言。何等名为菩萨大慈。无所发菩萨言。若有菩萨能舍身命。及诸善根施与众生而不求报恩。是名大慈。须菩提言。何等名为菩萨大悲。无所发菩萨言。若菩萨先与众生无上菩提。然后自证。是名大悲。说此甚深法门时。七万六千众生发阿耨多罗三藐三菩提心。二百比丘远离诸漏心得解脱

尔时会中有一天子。名善思惟。白佛言。世尊。云何菩萨住佛菩提根本行处。佛言。天子。菩萨若能成就深直之心发无上意。是名菩提根本住处。善思惟天子言。如是发心诸菩萨等。以何等法而为境界。佛言。若能修行布施境界。而不悕求报恩等门。若能修行持戒境界。而不分别持戒行门。若能修行忍辱境界。而不见尽灭法门。若能修行精进境界。而不发起修行等门。常行禅境界。而能现见一切法门。修行般若境界。而不见彼无戏论门现前。常求闻慧境界。而不见于语言等门现前。修行舍摩他境界。而见诸法本来清净寂静法门。修行毗婆舍那境界。而一切法不可见门现前。修行四念处境界。而无念无思惟门现前。修行四正勤境界。而无所作门现前。修行四如意足境界。而断一切愿欲门现前。修行五根境界。而过诸根法门现前。修行五力境界。而不破坏法门现前。修行七觉分境界。而佛菩提门现前。修行八圣道境界。为救行邪道众生故。修行教化众生境界。而无众生无度脱法门现前。修行断烦恼境界。而见诸法本性离烦恼门现前。修行诸波罗蜜境界。而不着于此岸彼岸故。修行世间境界。而涅槃门现前。修行涅槃境界。而不行诸行门现前。修行生境界。而不生不灭门现前。修行阴境界。而无烦恼门现前。修行界境界。而无差别门现前。修行入境界。而圣入门现前。修行闻法境界。而寂静禅定门现前。修行说法境界。而无言说门现前。修行成就色相境界。而法身门现前。修行转法轮境界。而不转不说门现前。修行声闻境界。而诸佛法门现前。修行辟支佛境界。而行诸菩萨胜行门现前。天子。是名菩萨摩诃萨境界。善思惟天子白佛言。世尊。何等名为诸菩萨行。佛言。天子。自舍己乐能与一切众生乐。常在世间而能持戒多闻心无放逸。常在涅槃而不舍大悲。涅槃门现前而不求证。为化众生故。随顺世间行。护诸众生。能于众生其心平等。令一切众生得清净心。于一切众生心无差别。所有之物与一切共。为人说法不为饮食。畜清净物而常知足。常乐空闲正念思惟。常处大众说法不懈。入城邑聚落慈悲现前。不求赞叹供养恭敬。常能远离世间杂语。凡有言说不违佛法。广略得所爱语柔软。一切身分礼敬三宝先意问讯。心常爱乐第一义谛。于一切法心无所著。于诸资生心不贪染。常近圣人远离非法。爱法如身重佛如命。爱敬修行犹如身首。于一切衣服饮食卧具汤药资生之事得少为足。敬重师长犹如世尊。乃至丧失身命终不舍于菩提之心。初夜后夜精勤修行。禅定三昧常现在前。如所闻法思惟正观。以微妙慧求于解脱。若修习清净无垢浊心。能舍一切所有之物。观于内身不随外身。能舍所施远离嗔恚。能灭愚痴增长般若。能护于戒不违修行。于一切处生柔软心。于一切处智慧为首。不颠倒心无垢光明。心常修诸波罗蜜。心不舍精进常求善根。如所闻法而不忘失。如所闻法而为他说。离诸供养饮食等心。常护诸根常在定心。常随顺涅槃心常不舍世间心。得失利衰毁誉称讥苦乐不能动心。于一切处生如是心。布施得大富。持戒生天人。忍辱得端政。精进舍烦恼。禅定三昧得心柔软。修习般若能知世间出世间法。修行四摄无诸过失。修行四无量心无憍慢。修行谛舍灭慧得寂静调柔修行禅定得自在心。修习三昧得于深心。修行于谛如实知诸法。修行于定远离诸见。修行无相得无分别。修行无愿得无著心。修行诸波罗蜜得究竟大乘心。修行方便波罗蜜得一切智智处。修行菩萨十地满足诸菩萨行。亲近善知识得一切功德门。敬顺和上阿阇梨能得随顺一切诸佛。知自身心得一切种智。习无憍慢得大威势。恭敬礼拜一切众生得诸众生无能见顶。修行种种布施得具足妙相身。随顺诸众生得具足八十种好。说大乘法得堕自在地。教众生发菩提心得不退地。说诸法空能断烦恼及烦恼习。以法布施得四无碍。与众生念得陀罗尼。令众生知法得四无碍。与众生乐说因得无错谬记。于羸劣众生起忍辱心得那罗延身。于破戒众生起忍辱心得诸众生见者恭敬心。能灭嗔恨心众生得常定心。勤修精进得速证法修行。以三昧施诸众生得阴密藏相。施与威仪得一切普庄严事。令众生近善知识得佛菩萨声闻辟支佛常现在前。舍于欲心常为一切世间所信。舍于嗔心得一切世间之所爱乐。舍悭嫉心得一切名闻利养。能与众生作依止处。得一切世间之所归依。舍一切供养恭敬赞叹得法喜食得美名闻。施先问讯得清净言音。施于爱语得梵音声。施柔软语得迦陵频伽声。远离嗔恨得诸世间胜妙之身。不诳众生得悉为一切世间所信。不说他过得不入胎。远离杀生得寿无量命。远离劫盗得以虚空而为库藏。舍所爱事得如意宝手。回向菩提得无尽资财。远离邪淫得大丈夫身。远离妄语得口业密。远离两舌得不失菩提心。远离恶口得一切世间赞叹。远离绮语得不坏眷属。远离贪心得无尽藏。远离嗔心得与一切众生而作桥梁。远离邪见得于正见教化众生。住于大乘得佛十力。能施一切不求果报得十八不共法。舍诸所著得四无畏。天子。若我广说如是菩萨无量境界。菩萨无量修行者。乃至百千万亿劫不能穷尽。天子。是名菩萨境界修行。天子。若菩萨如是成就境界如是修行。于得菩提则为不难。善思惟天子言。世尊。云何菩萨名为安隐。佛言。天子。若菩萨常不舍离三昧。而不依三昧生。得三昧已随有利益众生之处。彼彼处生。天子。菩萨如是名为安隐。善思惟天子言。世尊。云何菩萨名为寂静。佛言。天子。若菩萨见一切真如法界实际。是菩萨处于大众而能寂静。应如是知。天子。是则名为菩萨寂静。天子。若菩萨不起二处心。名为菩萨寂静。天子言。世尊。菩萨云何名为常在三昧。佛言。天子。若菩萨心常不求一切诸事。不见一法可取。不见一法可舍。是菩萨随所见法悉知空寂无有真实。天子。菩萨如是名为常在三昧。善思惟天子言。世尊。菩萨云何名为到一切处。佛言。天子。若菩萨能见自身及诸众生平等空寂。天子。菩萨如是名为到一切处。善思惟天子言。世尊。云何菩萨名为调伏。佛言。天子。若菩萨一切分别所不能动名为调伏。天子言。云何菩萨名为得灭。佛言。若菩萨不染不净名为得灭。善思惟天子言。世尊。如我解佛所说义者。依止自心而得菩提。世尊。菩萨如是离诸烦恼。如是如是取于佛法。世尊。诸佛法者。无所从来去无所至。世尊。于诸法中清净智名为菩提。天子。菩萨如是随顺忍辱名为菩提。能如是知名为一切智者。世尊。若能入如是平等法界。是菩萨名为成就檀波罗蜜。若能如是知得成就平等法界。是菩萨名为成就尸波罗蜜。若能如是知忍平等法界。名为成就忍辱波罗蜜。若能于此法门修行闻思修慧。名为成就毗离耶波罗蜜。若能思惟是法平等法界。名为成就禅波罗蜜。若能了达如是法平等法界。名为般若波罗蜜。世尊。若人能信此法门者。是人名为见法。名为证法。名降伏魔。世尊。若人能说此法门者。是人于如来所转法轮而得随转。世尊。若人能得此法门者。是人名得最上妙法。尔时世尊于善思惟天子所说法门。赞言。善哉善哉。天子。如是如是如汝所说。天子。一切诸佛阿耨多罗三藐三菩提藏。皆悉在此法门中摄。天子。一切诸佛所有意趣。于此法门皆已示现。天子。若人闻此法门者。当知是菩萨快得善利。天子。若人手执此法门者。当知是菩萨得大法藏。天子。若人摄受此法门者。当知是菩萨名为可信者。名为受持如来密藏者。名为以最上供养供养如来者。名为摄受如来法门者。天子。若人闻此法门。闻已能信者。当知是菩萨名为报如来恩。天子。若人信此法门者。当知是菩萨于十方界无有闇障。尔时世尊告一切大众唱如是言。谁能于未来世护持此法门

尔时无所发菩萨。即从座起。偏袒右肩右膝着地。合掌向佛而作是言。世尊。我当能于未来世护持此法门。世尊。若菩萨有所发者不能护持此法。是故我不发不起不受。于一切众生平等心。能护持此甚深无生法忍法门。我远离饮食心。不求一切供养恭敬赞叹。何以故。世尊。若依供养恭敬者。不能护持此法。世尊。于如来灭后。若有人闻此法。能受能持。能书写能读诵。书写已乃至受持经卷者。当知皆是无所发菩萨威神力故

尔时世尊赞无所发菩萨言。善哉善哉。善男子。若有如是心者。是人则能护持妙法。观世音菩萨言。世尊。若人不断大悲。是人则能护持妙法。是故我今依大悲心。护持此法门。弥勒菩萨言。世尊。若人有大慈心。是人能摄受妙法。何以故。若人多嗔恚。是人不能摄受妙法。是故我依慈心流通此法门。见者爱乐菩萨言。世尊。若菩萨众生见者无厌。是人则能护持妙法。世尊。是故我于一切众生不起嗔心。护持此法门。导师菩萨言。世尊。若菩萨为一切众生起心。我拔一切众生苦。若一切众生欲聚集佛菩提。欲度一切众生。是菩萨能受持此法门。是故世尊。我为一切众生成佛菩提。世尊。我先度一切众生然后自度。而不见能度可度者。亦不见度众生法。是故世尊。我毕竟起如是心。护持此法门。文殊师利菩萨言。世尊。世间人颠倒。若人生如是心。我护持妙法即是颠倒。何以故。世尊。菩萨调柔自身寂静自身。是菩萨自调柔自寂静实法身。即是护持妙法。是故世尊。我自身柔软自身寂静自身法身。即护持妙法。尔时世尊赞彼护持妙法菩萨言。善哉善哉。善男子。汝真是大士。汝今能安乐一切众生故。护持妙法。护法菩萨正应如是。何以故。此是诸菩萨最妙胜业。所谓护持妙法。善男子。是诸法相应法集法门。若菩萨受持读诵修行。是菩萨于诸佛所得光明现前。一切诸佛身不生不灭。于法中得大光明现前。知一切法非作非有为。于僧中得光明现前。如来弟子僧。无我无我所。于菩萨修持戒得光明现前。菩萨于诸学中大悲为根本。得乐说光明现前。一切语言乐说以无生为体。善男子。是法门多行于娑伽罗龙王世界。多行帝释住处。多行于阿那波达多龙王住处。然后行于阎浮提中。虽行阎浮提。常于诸佛所护众生中行。于直心不谄曲心众生中行。于能信深法者。常在如是众生心手中行。如来说此法门时。无所发菩萨。奋迅慧菩萨。及彼诸菩萨摩诃萨。及大声闻。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切大众闻说此法门。欢喜奉行佛说法集经卷第六


佛说法集名数经

    No. 764

佛说法集名数经

        西天译经三藏朝散大夫试鸿胪少卿传法大师臣施护奉　诏译

归命顶礼一切佛一切智智天人师。无边无数佛说法。略集所说正法名。先归命三宝。所谓佛法僧

云何三乘。所谓大乘缘觉声闻

云何七种最上供养。所谓礼拜供养忏悔随喜劝请发愿回向

云何三根本。所谓发菩提心清净心自性空断我见

云何十波罗蜜。所谓布施持戒忍辱精进禅定智慧方便愿力智

云何十八空。所谓内空外空内外空空空大空胜义空有为空无为空毕竟空无际空散空一切法空本性空自相空无相空无性空自性空无性自性空

云何四无量。所谓慈无量悲无量喜无量舍无量

云何四摄法。所谓布施爱语利行同事

云何五通。所谓天眼天耳他心宿命神境

云何四圣谛。所谓苦谛集谛灭谛道谛

云何五蕴。所谓色蕴受蕴想蕴行蕴识蕴

云何出世五蕴。所谓戒蕴定蕴慧蕴解脱蕴解脱知见蕴

云何十二缘生。所谓无明行识名色六入触受爱取。有生老死

云何三十七菩提分法。所谓四念处四正断四神足五根五力七菩提分八圣道。云何四念处。所谓观身身念处。观受受念处。观心心念处。观法法念处。云何四正断。所谓未生不善法不令生。已生不善法令正断。未生善法令发生。已生善法令增长。真实不妄发精进心令得圆满

云何四神足。所谓集定断行具神足。心定断行具神足。精进定断行具神足。我定断行具神足

云何五根。所谓信根进根念根定根慧根

云何五力。所谓信力进力念力定力慧力

云何七菩提分。所谓念菩提分择法菩提分精进菩提分喜菩提分轻安菩提分定菩提分舍菩提分

云何八圣道。所谓正见正思惟正语正业正命正精进正念正定。如是三十七菩提分法

云何四法种。所谓正利正文正智正识

云何六念。所谓念佛念法念僧念戒念施念天

云何四法印。所谓一切行无常。一切行苦。一切法无我。涅槃寂静

云何十善。所谓不杀生不偷盗不淫欲不妄语不两舌不恶口不绮语不贪不嗔不痴

云何四根本烦恼。所谓贪嗔痴我慢

云何五见。所谓身见边见邪见见取戒禁取

云何四漏。所谓欲漏有漏无明漏见漏

云何三解脱。所谓空解脱无相解脱无愿解脱

云何八有色。所谓地水火风香味触法

云何二无色。所谓虚空识性

云何八定解脱。所谓内有色观外色解脱。内无色观外色解脱。观净解脱具足住观空无边处解脱。观识无边处解脱。观无所有处解脱。观非想非非想处解脱。观想受灭解脱

云何九部法。所谓契经祇夜受记伽他讽诵因缘本事本生方广

云何十二头陀行。所谓常乞食次第乞食一座食先止后食持三衣毳衣粪扫衣于其草上长坐不卧显路处居住树下住冢间住空寂处住

云何十地。所谓欢喜地离垢地发光地焰慧地难胜地现前地远行地不动地善慧地法云地

云何菩萨十降伏。所谓命降伏心降伏受用降伏法降伏生降伏神通降伏解脱降伏愿降伏业降伏智降伏

云何菩萨十力。所谓解脱力拔苦力观力忍力智力断力闻力愿力圆满力爱力

云何如来十力。所谓处非处智力。自业智力。知众生性智力。根胜劣智力。种种界智力。种种胜解智力。遍趣行智力。净虑解脱等持等至智力。宿住随念智力。漏尽智力

云何四知。所谓知一切法种。知一切说法。知涅槃正道。知漏尽智断

云何五贪妒。所谓法贪妒。利养贪妒。住贪妒。为善贪妒。名闻贪妒

云何十八不共法。所谓身无失。口无失。意无失。无不定心。无异想心。无不知舍心欲无减。念无减。精进无减。智慧无减。解脱无减。解脱知见无减。身业随智慧行。口业随智慧行。意业随智慧行。知过去无碍。知未来无碍。知现在无碍

云何三十二相。所谓足下平满相。足下千辐轮文相。手足柔软相。手足指间有金色网鞔相。手足诸指纤长圆满相。足跟广长与趺相。称相足趺修广柔软充满相。双腨纤圆如鹿王腨相。两臂佣圆平立过膝相。阴相隐密如象王相。身诸毛孔各生一毛右旋绀青相。发毛上靡绀青柔软相。身皮薄润尘水不住相。身真金色光洁庄严相。手足掌中颈及两肩七处充满相。双肩头顶圆满殊妙相。两膊腋下皆悉充实相。容仪端严相。身相广长相体相。纵广形量相称相。于身上半如师子王相。常有身光面各一寻相。齿白如雪四十齐密相。四牙锋利鲜净皎洁相。于诸味中常得上味相舌相。广薄可以覆面至发际相。梵音洪雅随众等闻相。眼睫齐整如牛王眼睫相。眼睛之上红环间饰相。面如满月眉如初月相。眉间白毫右旋柔软相。顶有乌瑟腻沙如天伞盖相

云何八十种好。所谓指爪狭长光润薄净好。手指足指纤圆佣直骨节不现好。手足各等指间充密好。手足如意柔软好。筋脉坚固深隐不现好。两踝不现好。行步直进如龙象王好。行步齐肃如师子王好。行步安平如牛王好。进止仪雅如鹅王好。凡所回顾举身随转好。肢节佣圆妙善具足好。骨节无隙如龙蟠好。膝轮坚固妙好庄严好。隐处文约圆满清净好。身皮柔软光净离垢好。身容敦肃无诸怖畏好。肢节稠密安布妙善好。身肢安定不掉动好。身相光净周匝端严好。周匝身光恒自照耀好。腹形方正柔软不现好。脐深圆妙清净殊异好。脐厚妙好无[穴/爪]凸好。皮肤清净无诸垢染好。手足充满好。手文不断好。唇如频婆果好。面门如量端严好。舌相广薄好。梵音深远好。梵音美妙具足好。鼻高修直好诸齿方整好。诸牙圆白好。眼睛青白分明好眼如青莲华叶好。眼睫稠密不白好。双眉长软好双眉绀琉璃色好。双眉高显光润好。耳厚相称轮埵圆满好。两耳齐平好。容仪广大皆生敬爱好。额广平正好。身分上半无比对好首发修长稠密绀青好。首发香洁好。首发无交杂好。首发无褫落好。首发光滑尘垢不住好。身分充实喻那罗延好。身体广大端直好。诸窍清净好。身肢无等好。众观无厌足好。面如满月好。唯向不背好。面貌熙怡好。身肢无垢好。面门常香好。毛孔常香好。首如末达那好。身毛光净如孔雀项毛好。梵音称量应理无差好。顶骨无人得见好手足指约如赤铜好。行时去地四指能现印文好。自侍不待他卫好。恶心见喜恐怖见安好。音声和悦随众生意好。随有情类言音意乐好。一音说法随类各悟好。次第说法必有应缘好。观诸众主无憎爱好。先观后作轨范具足好。不可观尽相好好。顶骨坚实好。容颜不老好。手足胸臆有喜旋德好

云何轮王七宝。所谓金轮宝象宝马宝摩尼宝玉女宝主兵宝主藏宝

云何世间八法。所谓利衰讥毁誉称苦乐

云何三世所谓过去未来现在

云何四劫数。所谓大劫母拏劫散地劫贤劫

云何四世所谓圣世正世像世末世

云何二法。所谓生法灭法

云何四生。所谓胎生卵生湿生化生

云何五浊。所谓劫浊见浊烦恼浊众生浊命浊

云何四魔。所谓烦恼魔天魔蕴魔死魔

云何六趣。所谓天趣人趣修罗趣畜生趣饿鬼趣地狱趣

云何八寒地狱。所谓疱地狱。疱烈地狱。虎虎凡地狱。哧哧凡地狱。阿吒吒地狱。青莲花地狱。红莲花地狱。大红莲花地狱

云何八热地狱。所谓等活地狱。黑绳地狱。众合地狱。叫唤地狱。大叫唤地狱。烧然地狱。极烧然地狱阿鼻地狱

云何四大洲。所谓南赡部洲。西俱耶尼洲。北俱卢洲。东胜身洲。各有五百小洲以为眷属。复有二铁轮围。小铁轮围大铁轮围

云何七金山。所谓持双山。持轴山。檐木山。善见山。马耳山。象鼻山。鱼觜山

云何七海。所谓盐水海乳海酪海酥海蜜水海吉祥草海酒海

云何六欲天。所谓四天王天。忉利天夜摩天。兜率天。乐变化天。他化自在天

云何色界十七天所谓梵众天。梵辅天。大梵天。少光天。无量光天。极光净天少静天。遍静天。无量静天。无云天。福生天。广果天。无烦天。无热天善见天。善现天。色究竟天法集名数经


佛说法律三昧经

    No. 631

佛说法律三昧经

        吴月支国居士支谦奉　诏译

闻如是一时。佛游于摩竭提国。与大比丘众俱。及诸菩萨四部弟子。天人龙神一切大会。佛告众会。有法律三昧。菩萨学者当以和顺调其情性。深入微妙不得轻慢。所以者何。未深入者。不识三学功德厚薄。或以放恣失其本意。当知是辈有十二事。自堕大罪终不可悔。何谓十二有人学道。不得明师见闻未广而自贡高欲求名字。谤菩萨法以为不要。妄造哗说言。我师说既已自堕复堕他人。此如猕猴毒羹之喻。但欲害彼不知还自杀。是一自烧。有人学菩萨法藏得闻深经。未曾问师不知义趣。自用随意及以轻慢成就菩萨。是二自烧。有人已学深经。中道更堕弟子学者。毁笑大道以为迂远。是三自烧。有人学不深入。但欲依道全保其命。不解道理专行谤讪深经大法。是四自烧。有人虽学无有至意。但欲容身虚饰自可。得经好语与非其人。令到见者谄意啤呲。以为不然聚踧伪骸。造谤长短欲望其誉。是为五自烧。有人顽闇嫉妒贤能。常怀毒心向讲法者。不惟道德但贪利养。是六自烧。有始入学从明师得决。不念恩德反有人工。言我自知既不自解。亦不肯复从师问经。此无反复罪不轻矣。是七自烧。若已发菩萨意。欲学佛经道随师不久。礼节未闲声闻师说。有权方便未达其趣。妄饰虚辞非法解之。复以微意瞻师所行。自用为是。遂失权慧入魔罗网。是八自烧。学有畔弃。何谓畔弃。谓从明师得解权慧。见深入者不数请问。中道懈怠更怀毒心。念师所短已堕非法。不自觉知违道失智。谓之畔弃。是九自烧。有人以晓微妙权慧。而更不敬废经轻罪。为枝掖说于屏处言。师无所知。我已从学其说皆非。自今不当复与从事。令无知者信用其言。斯已自饮毒。复饮他人毒。是十自烧。有人学道。从明师得深经。有信菩萨至心行者。欲从求学断绝不与。呼为不贤有但声闻。未曾见经信戒未立。此人索经为反与之。便以俗语比方解之。转相教诳令真道薄淡。自取大罪复误他人。是十一自烧。有人虽学无有至信。不识真伪不畏于罪。曲媚豪强不解道者。随毁佛法诽比丘僧。此辈既自堕八难。复增成人罪。是十二自烧。犯此罪者不可悔除。从三恶道出则有所望。如是十二辈难可度脱

佛告阿难。吾故说是法律三昧。汝为人说当令了谛。护其意行莫作小福。如毫厘者而犯。大罪如须弥也。长失三宝。却就恶道无穷竟者。但坐贪爱须臾之可。而致剧痛斯难言也。佛说是时莫不感愧。学者悉入第六道地。众会皆起同声赞言。佛为吾等及后学者。开现大明令得慧眼。俱前稽首愿以顶受佛言。且听乃往久远时有菩萨名有道志。与十四万人俱。从违罗提佛发菩萨意。其辈中有一人最高才名贤行时有道志事以为师。追随累劫不失其意。坚行精进后成作佛。字世头胞。而有道志遂从受决。余人悉退堕弟子行。于今在五道。尚未得出阿难问言。其时辈人从见佛。后颇复得深经不。佛言。皆得。但不力学。不问中慧。不敬承师轻人法者阿难复问。已发大意何以堕落。佛言。用四事故。一者学本不知善权方便。轻慢师友无有一心。其意数转。二者学不精进无有道力。但贪名誉望人敬待。三者学所事师不念勤苦。当得成就虚饰贡高无有至心。四者好学外道习邪见人。反持异术比佛深经言道同等。时十四万人皆用是意故。后世转退去大道远。独有道志志大心强。追事贤行至其得佛果从受决。当说是时。天人百一十万皆发菩萨意。贤者阿难言。如佛所说学当恭敬。反以自恣失大道本。可不慎哉。自今新学欲入法者。宁能别善恶。不失善师友至竟者耶。佛言。有但少耳。多随本意不可化者。阿难又问。凡人相说恶。宁自知恶不。佛言。天下愚人但见人恶不自知恶。但自见善不见人善。称己智者皆非智也。自处明者其悉甚矣。言我知经亦以惑也。云知大法而不事师。不可信矣。佛智广大不可测度。见闻少少自以为足。用自贡高岂智者哉。唯有至学深入之士。近善师者乃为明智愚者安知世有明智人。乃别有贤愚耳。夫愚痴者但见人贡高。不自知贡高其自见过者可与说善事。自见善者不可与语议。何则皆自是故。能解难者可与论道。不者但增其憍慢。自可者不可为说忍辱之事会不能受。解道意谦虚者。可与共讲深经之要。不者皆缚知。微妙深入者可与共说无端绪事不者犹疑言。我知菩萨法发言有贪着。言我所入净。不自知污浊。适始欲与便言已了。能觉魔事不知皆在魔罗网中。如蚕作茧还自缠裹。欲悉觉知分别内外深浅意者。当问久学成就菩萨。近善师者乃可了了觉魔事耳。佛言。学不可不谛行不可不护。忘其本意堕非法者。皆坐自用随邪心故。诸不可行不当行。轻犯大过堕恶道者。皆以专愚不承法令。为魔所中致罪不细。于是贤者舍利弗白佛言。新发意者实宜自护。坐小可意而失大者。斯不少矣。昔我前世有是意故。失大得小。虽欲悔之无复及也。佛言。本心不解皆有是耳。舍利弗问佛。何谓人本。五阴本。六入本。十二缘起本。及九十六种道本所入。何谓四谛本。弟子本。各佛本。如来本。知之云何。曾闻佛言。不解本无故堕小道。愿为新学分别说之。佛言。善哉所问甚快多所开发欲闻者听。于时会中皆曰受教。佛言。人本者。无从出无所受。无作者无有主。无色无识不生不灭。如是知本。失是离本。五阴本者。无有住处。随所著即为阴。成败如幻一切无强。知如是者计无有阴。六入本者。犹如空野。以所更乐谓之为入。其入虚空无积聚处。知本净者。计无所入。十二缘起本无端绪。来无所从去无所至。痴不可见所缘无际。至于老死如梦非真。如不起法忍是知本也。九十六种道本所入。皆从贪欲。六十二见舍内取外。何谓舍内取外。身为化种虚而非真。求有万端贪不能舍。欲保安存久。而要坏生死不绝。四谛本者。亦无根茎。苦习尽道皆由观解。见空净者为知谛本。弟子本者。初观世有。不解本无。厌生死苦摄意观法。断却五阴守空行净。想灭漏尽便得解脱。是为罗汉本所。入各佛本者。学作功德不晓成时。闻知有佛欲得尊号。无有大悲不晓善权。呼身为有持想视佛。乐净守道不亲善友。虽积功德如江河沙。犹无益于不入权慧。不修利及相好。半行不具。以觉因缘便得成佛。是为各佛本。所入如来本者。从发意来见身皆空诸法清净。晓众生本惠德。所入阴入种持一切本无。晓诸功德成时所入。如本立如有智。不起不灭无往无来。不在泥洹不离本无。如虚空等不可动移。是为如来本所入舍利弗言。佛意实妙非众罗汉。各佛所知我辈初学。皆从缚着志微学浅。承佛得度心根已灭。虽闻大道无复学意。譬如野夫闻天子事。暂快其耳终不能效。虽人久处三恶道者。出学大道可成作佛。如我罗汉无复心矣。为菩萨者诚快无量。已发大意深入广博。但当精进谛护行耳。于是有菩萨名勇声。白佛言。大道甚妙。非是世间才明所知。唯深入者乃达其微。恐后三学新发意菩萨。及为弟子各佛行者。朦冥未寤不别深浅。见闻少小自以为明。诤讼取胜更以相惑。唯佛加哀为决大疑。其诸学者皆俱行禅得道各异何用别知。弟子各佛菩萨。大乘及诸外学。五通仙人。禅意云何佛言。善哉善哉。大士。欲护一切乃以此问。虽俱行禅意趣不同。弟子学者闻有四禅。要约直心可疾得道。不及知余深妙大法。畏苦厌身一心思惟取欲自度不念众生。但守行灭何如为灭。所施福德持戒精进欲望泥洹。不知佛大慈泥洹所出入。言泥洹一到通四禅得三活。生死断已度世。是为罗汉所入禅各佛学者。从发意来不事善友言世间有其行常着何如为着所作功德望欲得佛。言禅道如不用余行。亦不知佛禅意所向。如来禅者。无意无想无见无得不熟晓了那中系意守净无为不晓权慧法意。以成得禅见空因缘解便得道。明过罗汉而不及佛无十种力四无所畏及十八不绝法。是为各佛所入禅。菩萨禅者从发意来不离明师。学广智深晓了禅本何谓晓了本心法本无道亦无本。无著无缚无解无行。无出无入无舍无取现大智慧善权之行。不断德本及大悲意。修相好严佛国。具十力四无所畏及十八不绝法一切见一切知无所不觉。故号曰佛佛用世间多贪乱意故。于树下闭目而坐为现禅法欲令解者以道缚意亦随所乐各得其所是为如来本所入禅外诸小学五通禅者。学贵无为不解至要。避世安已持想守一。瞑目纵体内观历藏。存神道气养性求升恶消福盛思致五通寿命久长名曰仙人。行极于此不知泥洹其后福尽生死不绝是为外道五通禅定

佛言。如弟子各佛。虽得泥洹为不知本。所以者何。其学本谓世有道无故坏五阴而取灭度唯如来为知泥洹本所以者何知俗与道诸法本空如本无住不起不灭。是为泥洹佛意如是故曰如来弟子各佛名为灭尽。菩萨当解深妙大法明谛受学虽离明师。心当清净不可放逸。于是勇声叉手白佛言。得值佛者为难有也。大圣大慈所度无极。今蒙佛恩无所复疑。其欲学者当受佛教莫为不贤之行。使魔得其便如佛所言终无有异。天魔官属莫能坏是清净行者。言已即前稽首佛足是时诸天及人。有二百一十万。皆愿乐立于无所从生法忍。贤者阿难白佛言。此法律为何等义。佛言是为剖决道意释人根本慧德所入。分别弟子各佛菩萨学意所行。知谛知不谛。大要名曰法律三昧。佛言。阿难。其有信解是经法者。皆于十方佛所闻善权已。佛说经讫诸来会者皆欢喜各前。为佛作礼而去佛说法律三昧经


佛说法身经

    No. 766

佛说法身经

        西天译经三藏朝奉大夫试光禄卿明教大师臣法贤奉　诏译

尔时世尊。于大众中以微妙音作如是言。诸佛如来有二种身。皆具河沙功德。何等为二。所谓化身法身。而化身者。示从父母所生。具三十二相八十种好。庄严其身。以智慧眼普观众生。智者瞻仰心生适悦。三业清净。一一相好百福具足。如是庄严百千福聚。大丈夫相皆色蕴摄。又复具足十力。四无所畏。三不空法。三念住法。三不护法。四无量法。具大丈夫一一最胜那罗延力。如是略说如来应供正等正觉庄严功德具足圆满。是名化身。又复诸佛如来应供正等正觉所有法身。不可思议不可称量。而无有人能广宣说。假使缘觉及诸声闻舍利弗等。最上利根善解深法。大智明达了种种义。而亦不能广大宣说法身功德。诸佛如来为三界师。是大悲者。为诸众生作大利益。平等护念无所分别。住奢摩他毗钵舍那。而复善解三调伏法。善度四难。具四神足。而于长夜行四摄法。离于五欲超五趣苦。具六分法圆满六波罗蜜。开七觉花演八正道。善解九种三摩钵底。具十智力。以此智力。名闻十方。是故称为第一义天。于时方处昼三夜三常善观察如是诸佛内功德法。无有能者而为广说。是故我今略说此法。是法身者。纯一无二无漏无为。应当修证诸有为法从无为生。如是真实无净无染无念无依。离诸方便而与众生作大依止。一切众生所作行法无诸过失。是真善法离诸记念。于无边三摩地门。不动不摇而得解脱。以二种奢摩他毗钵舍那。于欲离欲而得解脱。无明欲法以慧解脱。学无学法以念了知。以明解脱善达自性。而于诸法深能系念。善以阿钵底而生阿钵底法。善以三摩钵底而生三摩钵底法。于一切法无求无证。离此二法即无所缘复无所修而以尽智及无生智。毕竟成就三究竟法。三善根法。三方便门离诸妄想得真实生。了三种慧。谓闻思修。离三杂染。谓烦恼业苦。有三种三摩地谓空无相无愿。复名三解脱门。即空无相无愿解脱门。三种蕴法。谓戒定慧蕴。三种学法。谓戒定慧学。有三种修。谓戒修定修慧修。有学无学非有学非无学。有三种道。谓见道修道无学道。有三种根。谓未知根已知根具知根。有三种行法。谓圣行天行梵行。有三分别谓蕴处界。了三法已获大福聚。证得解脱寂静涅盘三不空念住。如来于诸众生平等覆护。三种蕴法。有三补特伽罗。谓上中下。诸佛如来具三种大悲。谓无缘大悲。微妙大悲。为一切众生大悲。有三种自在。谓身自在世自在法自在。有三不护法。谓诸如来身业清净离不净法。口业清净离不净法。意业清净离不净法。有三种剑。谓闻剑思剑修剑。有三种最上。谓定最上慧最上解脱最上。有三种界法。谓正断离欲寂灭。复有三界。谓欲界色界无色界。有三种无学明。谓过去宿命明。未来天眼明。现在漏尽明。有三种无为法。谓诸行无常。诸法无我。涅盘寂静。有三种菩提。谓声闻菩提。缘觉菩提。无上菩提。有三种无学智。谓尽智无生智正见智。三宝三归三最上智。四念处。四正断四神足。四信心法。四解脱句。有四种善法。谓第一义善。自性善。发起善。相应善。四种修法。四种智法。四圣谛法。四禅定。四轮藏。四法四依止。谓亲近善友。听闻正法。系念思惟。如理修行。复有四缘。谓因缘。等无间缘。增上缘。所缘缘。四加行位。谓暖位顶位忍位世第一位。有四种道。谓方便道。无间道。解脱道。最胜道。四沙门果四种圣族。有四无量心。谓慈悲喜舍。复有四生四圣住。四记念四威仪。有四出生门。谓出入寂静正觉。复有四证位。有学五蕴。五解脱处。五度生法。五圣智想。有五三摩地分。谓正断分。调伏分。离过分。离相分。离性分。复有五种最上分五现行。三摩钵底五蕴五界。复五取蕴六功德法六通六念复六种法五种离欲。六种修法。六见道位。六相续行。六证明想。七补特伽罗。七大丈夫行。七识住七觉支。七无过失法。七三摩地受用法。七种妙法。七种界分。七善解处。七种修道。八正道分。八种补特伽罗。八种别解脱戒。复八解脱八处八智八道八戒八会。及八种世法。如来相续真常精进清净无所染着。复有九种过去三摩钵底。九信心法。九证得法。九名色灭九众生住。九种依法。九无漏地。九修道地。十种补特伽罗。谓四向四果第九缘觉。第十正等正觉。十大地善法。十种有学法。十如来力。十善业道。十恶业道。十种圣住。十如理作法。十一功德相好思念法。十一种起善解智具足法。十一种具足戒法。十二种出生言辞。十二处十二缘十二刹那会证得圣法。十三喜法。十三出生法。十三作业地。十四种化心。十五心见道。十六心正念。十七种相有学。十七乐欲相。十八界十八不共法。十九分别地。二十二根。三十七菩提分法。谓四念处四正断四神足五根五力七觉支八正道。四十四智法。复七十七智法。百六十二道。是谓修地。如是等无量无边相续真常之法离诸烦恼。甚深广大微妙难思。是大智者如实了知。而此佛法乃是殑伽沙数正等正觉殊妙之法。是平等法若有求证正等觉智。诸苾刍苾刍尼优婆塞优婆夷。及诸外道尼干子等。具正智者如实了知。复为众生广大宣说。如佛所化令无量无边阿僧祇众生。悉皆证得寂静无畏究竟涅盘佛说法身经


佛说法受尘经

    No. 792

佛说法受尘经

        后汉安息国三藏安世高译

闻如是。一时佛游于舍卫国祇树给孤独园。佛告诸比丘。比丘受教从佛而听。佛言比丘。凡人为一法。受尘自污。迷惑忧愁。没无端际。吾见其不得无上吉祥之道。如丈夫欲见女子色。是以好色之士。为染为醉为贪为污为惑为着为住为受。从淫女言故。长久趋走往来。为受勤苦耳。常欲闻淫女之声。鼻欲闻其香。舌欲得其味。身欲更其细滑。是以长久趋走往来受苦。是故不当为女色声香味细滑所染惑也。当觉知是。又复诸比丘。凡人为法。受尘自污。迷惑忧愁。没而无际。吾见其不得无上吉祥之道。如淫女欲见男子色。是以好色之女。为染为醉为贪为污为惑为着为住为受。为士色故。长久趋走往来受苦耳。常欲闻男子之声。鼻欲闻其香。舌欲得其味。身欲更其细滑。是以长久趋走往来受苦。是故不当为士色声香味细滑所染惑也。当觉知是。佛说是已。皆欢喜受行佛说法受尘经


佛说梵摩难国王经

    No. 521

佛说梵摩难国王经

        失译人名今附西晋录

闻如是。一时佛在舍卫国祇树给孤独园。与千二百五十比丘俱。时有国王。号名梵摩难。常供养佛及众僧。每得斋日。王辄宿敕群臣严驾。王便导从数千人到佛所。五体投地。稽首佛足。佛每为诸天人民说经法。王辄欢喜恭敬听经。王宫内亦奉事三尊。清净斋戒。王有太子。名均邻儒至心精进。觉世非常。无生不死者。不贪时荣。白王言佛世难值。经法难闻我今乞欲随佛作沙门。王即听之。均邻儒。便辞王到佛所。乞为比丘。佛便以手摩其头。发堕袈裟自然着身。均邻儒。奉持重戒。精进勤修。昼夜不倦。三月日。便得罗汉道。王时不知其已得道。见其勤苦饭食粗蔬。每往供养。异于众僧。其心不同。辄谓之言。我国中珍琦七宝饭食甘肴。无所不有。汝何故正当乐为沙门乎。佛知王用恩爱故。佛便语均邻儒。起现威神均邻儒。即承佛教。头面着地。为佛作礼。轻举上住空中。飞行变化。分身散体。出入无间毕已。头面着佛足。王见其道德乃尔。便悲喜交集。五体投地。为均邻儒作礼。佛时令均邻儒为王说苦空非常四谛之要。王于是意解。即得须陀洹道。佛语阿难。比丘有四事。受人施饮食美味衣服。善恶不得有逆。一者欲福布施家。二者不欲逆施者意。三者或年老。或身体有病。四者恐人行道勤苦。夫欲食美。当存念重戒。一切众生皆我亲属。但展转久远。各更生死。不识其本耳。譬如人身体。有疮及病者。服药趣令其愈。不得贪着。夫欲施者。皆当平心不问大小。佛于是令阿难临饭说僧跋。僧跋者众僧饭皆悉平等(准品次录二纸八行诸本皆阙)佛说梵摩难国王经


佛说梵志女首意经

    No. 567 [No. 568]

佛说梵志女首意经

        西晋月氏三藏竺法护译

闻如是。一时佛游波罗奈鹿苑仙人所止处。而转法轮。与大比丘众五百人。无数菩萨俱诸异佛国各各来会。尔时世尊。晨旦整服。持钵入城而福一切。贤者阿难侍如常仪。大圣则入波罗奈大城。普次街里向梵志门。梵志有女名曰首意。遥见佛身端正殊妙威神巍巍。其心静然诸根寂定。建上玄默第一澹泊。无有衰入恐惧永除。其意清净而无垢秽如大渊澄。紫磨金色晃如宝山。若盛天树华实繁茂。有三十二大人之相庄严其身。八十种好遍布其体。昱如大殿而有宝柱。如须弥山峻峙显特。如月盛满众星中明。如日出光晃耀晖赫。无所不照。女见佛来住于门外。心怀踊跃回入设座。还诣佛所。稽首佛足下。长跪白言。善来安住。愿降圣尊屈神临眄。佛垂慈愍入馆就座。首意悦豫重稽首而取小榻于佛前坐进而启曰。唯天中天。曾闻如来游波罗奈仙土鹿苑。为沙门梵志梵天龙神。诸魔世人群生之畴。转无上轮兴显正法。佛告梵女。如是如是。诚如所云。吾游斯国转无上轮。为诸未闻宣现正法。不以非法。首意问佛。何谓如来所转法轮。世尊告女。以十二事缘起之法而转法轮。首意白佛。重加大恩为我分别。广说十二缘起之法。法轮所归令识义趣。佛言谛听。善思念之。吾当为汝解散其义。梵女首意。受教而听。佛告女曰。若计有我便有终始。起于不起。从痴因缘则便有行。从行因缘则便有识。从识因缘则有名色。从名色因缘则有六入。从六入因缘则便更习。从更习因缘则便有痛。从痛因缘则便有爱。从爱因缘则便有受。从受因缘则便有有。从有因缘则便致生。从生从缘。致老病死。勤苦愁恼。大患集会。如是女。痴灭识行名色。六入更习。痛爱受有。生老病死灭。勤苦愁恼大患尽除。汝欲知吾以是法故。于波罗奈仙士鹿苑。为诸沙门梵志。梵天龙神。诸魔世人。而转法轮。解十二因缘。若受奉行。因可得度。首意问佛。唯天中天。法宁有内有外乎。告女曰不也。女又问曰。法宁有住无明号乎。答曰不也。女又问曰。宁有兴明有除灭乎。答曰不也。女又问曰。其明达者宁有形貌乎。答曰不也。女又问曰。以何因缘而致是身。以无有痴何从致生。兴心慢意因成其行。何谓因缘而得合成。又曰。唯大圣如树无根。何因忽生茎节枝叶华实。如是世尊。计其无明无有形像。假使因缘从无哲起而致憍慢。何谓无哲之原而致于行。何从致是众恼集会。佛告女。欲知诸相。本悉清净。亦复如是。诸法之法。法不知法。愚冥凡夫不闻罪福。而造凶危。因从凶危则有终始。因终始则有苦乐。计晓于彼。亦无作罪。亦无福者。亦复无有进退终始。亦复无有遭苦遇乐。佛告首意。汝欲知之。譬如幻士化作所化。其化人者。亦不想念言我是化。彼之幻士。或以实为虚。或以虚为实。悉是欺诈愚伪之法。计斯幻士及所化人。有所化者亦无所化。彼亦空虚诳惑迷妄痴騃之法。于汝意云何。其幻化者。岂复有内而有外乎。答曰。不也天中天。于汝意云何。幻无住岂有我名乎。答曰。不也天中天。于汝意云何。其幻化者。岂有到后世复来者乎。答曰。不也天中天。于汝意云何。其幻者岂有所起有所灭乎。答曰。不也天中天。于汝意云何。其幻化者。岂有所有有形像乎。答曰。不也天中天。于汝意云何。其幻化者。岂有见闻有幻无幻乎。答曰。不也天中天。其女白佛言。我曾闻之。其幻化者。无有见闻有幻无幻。世尊又问。于汝意云何。其幻化者。假使无身。岂能令幻化发起诸术乎。女答曰。唯天中天。其幻化者。实为如此真无所有。佛复言。如是如是女。其无明者无内无外。计其法者亦无所有。亦无字也。其无明者不至后世。亦无还返。其无明者亦无有起。亦无有灭。其无明者亦无形像。适兴无明。缘致众行。名色六入。更习痛爱。受有生老病死。勤苦愁恼大患集会。时女首意白佛言。甚为可奇。至未曾有。世尊。所兴而不可及。所以者何。佛天中天。于虚空中而转法轮。不可思议所转法轮。不可称限无量法轮。无获法轮。无形法轮。无生法轮。灭度法轮。世尊告曰。如是如是。诚如所云。吾所转轮为转空轮。所转法轮不可思议。所转法轮不可称限。其可转轮无量无获。无形无生。为灭度也。时首意女欢喜踊跃。善心生焉。则以栴檀捣香及诸华香。供养散佛。唯然世尊。以是德本。誓致拥护。而善救摄。降伏诸根。御制爱欲。逮转法轮。转空无轮。无思议轮。不可称限。无量无获。无形无生。灭度之轮。佛寻欣欲。五色青黄赤白绿光从口而出。其大光明普照十方无数佛国。悉皆覆蔽日月之明。还来绕身至于三匝从顶上入。贤者阿难晓了七法。一曰知义。二曰解法。三曰晓时。四曰了节。五曰明众。六曰练己。七日采识人本。即从坐起。更整衣服。偏袒右肩。下右膝叉手白佛。今大圣欣欲。为何感应。愿说其意。唯天中天。多所愍伤。多所安隐。哀念诸天世间人民。分别说之。佛告阿难。尔见梵女首意。以末栴檀华香捣香。供养散佛乎。其心誓愿逮转法轮。对曰已见。佛言。是女以斯德本护己安人。多所救摄。寿终之后当转女身。至八十四亿劫。不归恶趣。供养六万诸佛世尊。出家为道。志于沙门。听受经法。受经法已即时讽诵。将御如来现在正法。佛灭度后供养舍利。劝化无数无量众生。不可计会。使立无上正真之道。最于后世穷竟劫已。于三千大千。即当逮得无上正真之道。成最正觉。劫名宝明。佛号宝光如来至真等正觉明行成为善逝世间解无上士道法御天人师为佛众祐。其佛当寿具足一劫。为难计量。群黎之畴劝发道教而逆长益。后至无余于泥洹界而取灭度。阿难白佛。其首意女。为于何佛植众德本。佛告阿难。斯女往昔惟卫佛时。以女人身初发道意。取宝珠璎用散佛上。至于今世复会吾前。志愿无上正真之道。亦于式佛如来正觉发欢喜心。加怀笃信脱衣上佛。以家之信离家为道。而作沙门具满千岁。净修梵行。数数讲问深奥妙法。于随叶如来正觉时。以十五日供养世尊及诸弟子。充满周备。亦复志愿无上正真之道。于拘楼如来正觉时。心乐善学揽摄章句。以诸真珠名香供散佛上。其心亦愿誓成正觉。于拘那含牟尼佛正觉时。以香涂塔尽其形寿。供养衣服饮食医药床座。于二日供养世尊圣众。见迦叶佛供养奉事。不舍道意今供养吾。当转女身。然后得佛道度脱众生。佛说如是。莫不欢喜佛说梵志女首意经


佛说放钵经

    No. 629 [Nos. 626, 627(3), 628]

佛说放钵经

        安公云元阙译人今附西晋录

佛在舍卫祇洹精舍。时与诸菩萨。无央数比丘比丘尼。优婆塞优婆夷诸天王释梵。及阿须伦鬼神龙。诸人非人。无央数悉会坐。佛说菩萨法无央劫勤苦泥犁。禽兽薜荔。一切忧劳。十方布施。金银珍宝车马奴婢。及妻子头目肌肉。皆不爱惜。用施十方人。勤苦故。时忉利天上二百天子前世作菩萨道未坚。在佛所闻求道勤苦。皆念道剧难得。心便转求罗汉辟支佛道。佛知是诸天子意欲转。便化作一人。端正无比。令持百味饭至佛所。前长跪叉手作礼白佛言。愿佛哀我受此饭。佛便受之。坐中有菩萨在佛前坐。字文殊师利。白佛言。当念故恩。座中诸菩萨。悉闻展转相问。文殊师利。前世有何等恩。施于佛而复欲得佛饭。佛即舍钵于地。便下入地中。乃至赖毗罗耶佛刹。刹名波陀沙。钵悬止空中现。彼刹中诸菩萨见之。起前长跪白佛。是悬钵从何所来。亦不堕地。彼佛言。且待须臾。当见菩萨威神变化。尔时释迦文佛告摩诃目揵连。行求索钵。摩诃目揵连即入八千三昧。遍入八千佛刹视不见。即还白佛言。求索钵了不知处。佛告舍利弗。汝复行求索。舍利弗入万三昧。下行过万佛刹求钵不得。即还白佛言。我下行过万佛刹求钵了不见。佛复令摩诃迦叶行求索钵。摩诃迦叶便入万二千三昧。复下过万二千佛刹。求索钵不得。还白佛言。我求索钵了不见。舍利弗白弥勒菩萨言。仁者。高才功德已满智慧备足次当来佛。当知钵处弥勒菩萨语舍利弗言。我虽次当来佛功德成满其行具足。不知文殊师利菩萨。譬如十方恒边沙佛刹。满中万物草木。及尔所菩萨。不能知佛一步之中所念何等。文殊师利菩萨知深三昧。独文殊师利菩萨。能知佛钵处。舍利弗即起前至佛所。长跪叉手白佛。愿令文殊师利菩萨行求索钵。佛语文殊师利。汝行求钵来。文殊自念。舍利弗当不起于坐而致钵来。即入三昧。譬如日出光明无所不照。菩萨入三昧者。十方无所不至。文殊内手从袈裟里下探过十佛刹。手指诸节其一节放千万光明出。一光明端各有一莲花。莲花上有一菩萨坐皆如文殊。其下刹有佛莲花上菩萨者。皆持释迦文佛声谢诸佛。复持文殊声遥为诸佛作礼。如文殊手。逮至赖毗罗耶佛刹。刹中诸菩萨白佛言。是手何等。亦不见边。亦不见际。赖毗罗耶佛语诸菩萨言。上无数佛刹。刹名沙诃楼陀。佛字释迦文。前有坐菩萨字文殊。最尊光明智慧难可当。作变化如是。诸菩萨白佛言。今我等欲共得见释迦文佛及文殊。赖毗罗耶佛。即放额上千亿光明出。照中央无数佛刹。一至释迦刹。诸菩萨问佛。今有是大火光烟出。须臾顷便火出。是火泥犁火耶。佛言。莫作是语。是非泥犁火。释迦刹名沙诃楼陀。是中火也。诸菩萨问佛言。是沙诃楼陀刹者。何因名沙诃楼陀。有是火。佛语诸菩萨。沙诃楼陀刹者。杂恶三毒淫劮嗔怒愚痴。诸菩萨白佛言。沙诃楼陀刹中诸菩萨。忍辱不嗔怒者作是为可。佛语诸菩萨。释迦刹中人。骂詈菩萨轻是挝捶者。菩萨忍辱终不加嗔怒。慈哀十方人欲令度脱。皆是菩萨威神所加。菩萨忍辱之恩。故名沙诃楼陀。诸菩萨白佛言。我等闻是大欢喜。得不生释迦刹弊人之处。赖毗罗耶佛告诸菩萨。莫说是语不可。沙诃楼陀刹中诸菩萨意。佛言。我为汝曹说。东方佛字头意。刹名诃波离摩坻陀惹。头意佛刹中菩萨。行六度悉具足。不如沙诃楼陀刹中菩萨行六度一日一夜。念十方勤苦皆使度脱。何以故。沙诃楼陀刹中作行勤苦。譬如一佛刹坏败时火烧其刹。有人着新衣从东方来入火中。从火中至西方。其身出不烧是难不。诸菩萨言。甚难天中天。佛言。沙诃楼陀刹中菩萨。一日一夜所行。骂詈轻易之。菩萨忍辱终不嗔怒。譬如是人行火中。身不烧之难。尚不及是菩萨。若百倍千倍万倍亿倍。诸菩萨等二万人前白佛。愿欲上至沙诃楼陀刹。供养释迦文佛。及文殊师利菩萨等。赖毗罗耶佛语诸菩萨。若欲至沙诃楼陀刹者先治汝意。譬如地得香花好物不喜。得屎尿涕唾脓血恶露亦不嗔。佛言。我何因为若曹说是语。释迦文佛刹中有菩萨。先世多供养诸佛者。人有急性者。意善之事但口教急用。今世恶故。诸菩萨白佛言。沙诃楼陀刹诸菩萨。先世多供养诸佛求道大久。何缘生沙诃楼陀弊恶人处。佛告诸菩萨。有二因缘。今世生沙诃楼陀刹。本前世与释迦文佛。俱行索佛故世世相随。复有菩萨。宿命有恶不尽故生彼恶世。诸菩萨白佛。今是诸菩萨。生沙诃楼陀刹。何因缘得除宿命之恶。佛言。善男子善女人。生沙诃楼陀刹。索菩萨道。生贫家舍。用是故除宿命恶。又多病者复除宿命之恶。又遭遇父母兄弟妻子病瘦死亡忧愁感伤用是故复除宿命之殃又遭逢县官恐怖弃捐父母家室财产亡逃忧愁。用是故复除宿命之殃恶。若有一旦失财业穷厄。用是故复除宿命之殃恶。若在恶国中生。本为他国所攻败坏。奔走愁忧无聊。用是故复除宿命之殃恶。若生弊恶人中贫贱面目丑陋。形癃盲聋不属逮人。父母兄弟妻子宗亲皆共憎之。是人愁忧用是故复除宿命之殃恶。若闻有善道欢喜。欲索明师教告经道开心从受。不得明师便愁忧。用是故复除宿命之殃恶。若复遥闻远方有师高明智慧通达。欲往从受经学。身体病瘦手足拘挛不可动摇。钱用乏少又无伴侣便不可行。念之愁忧。用是故复除宿命之殃恶。若有人行求善师。欲从学受经。道师大明达皆知道要。弟子愚痴无慧意不开解。便自愁忧。用是故复除宿命之殃恶。若有善师欲教弟子世间之事开语经道。弟子愚痴不能忍辱。便弃捐师去。后归念师法戒大欢喜意悔愁忧。用是故复除宿命之殃恶若有求菩萨道者。卧出梦中见怨家持刀兵追逐怖恐梦中恐懅复除宿命之恶。若有菩萨道家善男子善女人宿命殃恶未尽。死当入泥犁中勤苦一劫。得善师教悔过一日一夜者。头痛身热诸病悉除尽。不复入泥犁中。赖毗罗耶佛语适竟。文殊师利下手探钵。赖毗罗耶佛刹。及中央无央数佛刹。上至释迦文佛刹皆大震动。一切人皆令惊怖。舍利弗起前。长跪叉手白佛言。今以何因缘震动如是。莫不惊恐者佛语舍利弗。今是地震动者。文殊师利探钵。是故震动。舍利弗问佛言。钵在何所止。佛言。钵乃在下。过无数佛刹有佛。字赖毗罗耶。其刹名波陀沙。钵止是中。舍利弗白佛言。今诸菩萨阿罗汉。及诸天人阿须伦鬼神龙。欲见下方赖毗罗耶佛刹及中央诸佛刹。欲见文殊师利变化取钵。时佛便放足下百亿光明。悉照十方无数诸佛刹土。如是悉遍见赖毗罗耶佛刹诸菩萨。见文殊师利变化取钵。时诸菩萨天人阿须伦鬼神龙皆大欢喜。诸阿罗汉皆大愁毒泪出。各自言。菩萨尚能变化。在所作为乃尔。何况佛威神光明难可当。我等宁入泥犁中百劫。后出闻菩萨法便奉行。何忧不得我愿。赖毗罗耶佛刹中诸菩萨。及中央诸佛刹土菩萨无央数。皆来上至释迦文佛所。诸菩萨各自念言。到释迦文佛所供养。中有菩萨散花覆一佛刹。有菩萨散香。有菩萨散天衣。有菩萨散金银珍宝。有菩萨作音乐声。一佛刹中如是诸菩萨。皆前持头面着地。为佛作礼已却坐。文殊师利菩萨。探钵来出坐中。诸菩萨阿罗汉诸天人阿须伦鬼神龙莫不欢喜。舍利弗起前长跪叉手白佛言。文殊师利有何等恩施与佛。今何因缘。言当念故恩。佛语舍利弗。乃前世无数劫。时有佛字罗陀那只。有六万比丘阿罗汉。七亿二千万人诸菩萨中有一菩萨。字惹那罗耶。朝起入城分卫得满钵。来还从街上行。有一乳母抱长者子。字惟摩罗波休。息沙门持钵便下。乳母抱趣沙门所。沙门以石蜜饼授与小儿。小儿啖之大美。便随沙门去。乳母逐护之。小儿啖尽。尽便还故。意欲还去沙门复取饼授之。儿啖饼逐随沙门出城到佛所。见佛端正身有三十二相八十种好。视之无厌。见诸菩萨比丘大欢喜。沙门便教小儿澡手漱口。便持钵饼与小儿令饭佛。汝今得安隐后得其福。小儿取授钵饼。持至佛前。以手接饼着佛钵中。复过与诸菩萨比丘僧。皆悉满足食饱饼钵如故。如是饭佛菩萨及比丘僧七日。小儿大欢喜。自说我日持一饼饭佛菩萨及比丘僧。七日饭满我必得福。因是一功德得佛。佛语诸菩萨阿罗汉言。此是本时恩也。惹那罗耶菩萨。今文殊是也。时小儿维摩罗波休者。我身是也。今我得佛。有三十二相八十种好。威神尊贵度脱十方一切众生者。皆文殊师利之恩。本是我师。前过去无央数诸佛。皆是文殊师利弟子。当来者亦是其威神恩力所致譬如世间小儿有父母。文殊者佛道中父母也。佛说是经时。忉利天上二百菩萨自念。佛本文殊所教化。令作功德成佛。文殊何以故。在佛前不成佛耶。佛言。文殊深入善权广化众生故未取道。佛告诸菩萨及比丘四众。前二百天人菩萨欲悔取二乘者。见文殊变化吾应报恩。今皆更发无上心修菩萨道。后世皆当作佛。佛说经已。诸菩萨比丘僧。诸天人阿须伦鬼神龙。皆大欢喜起为佛作礼佛说放钵经


佛说分别经

    No. 738

佛说分别经

        西晋月氏国三藏竺法护译

闻如是。一时佛在舍卫国祇树给孤独园。晨朝整服。俨然而坐。佛语阿难。告诸比丘。皆寂静明听。今当为汝说人生受苦。阿难从坐起整衣服。为佛作礼。白佛言。愿乐欲闻。佛言。人有六恶以自侵欺。何谓为六。眼为色欺。耳为声欺。鼻为香欺。口为味欺。身为细滑欺。意堕邪念为邪念欺。是为六欺。令人堕恶道中。无有出期。黠人乃谛觉是耳。佛言。人从三可得三苦。何谓三可。一身可杀盗淫。二口可两舌恶骂妄言绮语。三意可贪恚痴。用是三可故。堕地狱饿鬼畜生中。是为三苦。唯黠者觉之。佛言。人有六恣。堕十八痛。何谓六恣。眼恣入色。耳恣入音。鼻恣入香。口恣入味。身恣入细滑。意恣入邪念。是为六恣。亦为受亦为衰。用是故堕十八地狱。苦痛长久。无有出期。阿难白佛言。人有事佛受戒。能得脱是苦痛不。佛言。有人事佛受戒。得福无量。不可譬喻者。有人事佛堕极罪者。阿难问佛。事佛受佛戒当得福。更得深罪。何以故。愿闻其意。佛言。有人事佛奉持经戒。精进不犯。得福无量。不可譬喻也。佛言。有人事佛受戒不持。不能精进禅定思惟。托名事佛。专行邪业。贪求无厌。不知止足。淫劮色欲。好喜歌舞。耽于酒味。以自放恣。虽云事佛。其过难量。用是之故。长堕三涂。苦痛万端。难得免出

佛言。事佛有三辈。一辈者为魔弟子事佛。二辈为天人事佛。三辈为佛弟子事佛。何谓魔弟子事佛。佛言。虽受佛戒。心乐邪业。卜问是祟解除祷祀。信有家亲丈人。不信正真。不知有罪恶之对。假名事佛。常与邪俱。死堕无择地狱。受苦长久。久乃出为魔邦属。谀谄妖[女*瞿]。难可得度。是曹辈人。宿命余福。暂得一时。见于正道。心意瞢瞢难晓宿。已当复更入邪见无穷已也。是为魔弟子事佛。何谓天人事佛。受持五戒。行于十善。死死不犯。信有罪福。作是得是。寿终之后。即生天上。是为天人事佛。何谓佛弟子事佛。奉持正戒。广学经戒。修治上慧。知三界苦。心不乐着。欲得解脱。行于四等六度。愍伤众生。欲安济之。不贪身命。知死有生。求长益福。不为邪业。是为佛弟子事佛。佛言。吾般泥洹后千岁。魔道当兴。时世大恶。国无常主。民无常居。远方之人。当入中国。掠杀残暴。无有法则。于斯之际。像法当兴盛。阿难问佛。何谓像法。佛言。当来比丘不持正法。挟妻养子。无有惭愧心。耕田种殖。以为常业。无复学问坐禅行者。好乐俗常。以为绮雅。佯佯相看。上下雷同。拨拂相教度世之基。迷于色欲。不畏于罪。时有知法者。为说真言。教示正法。便怀憎嫉。欲毁坏之。为立言议。抄持长短诽谤驱踧。使其无憀。用是之故。大法转减。阿难问佛。于是之时。颇有奉法者不。佛言。多有事佛。亦出家者耳。但不持戒。共相嫉妒。识义者少。多不晓解。阿难言。当尔之时。何国最恶。不信行者。佛言。真丹之土。当有千比丘。共在大国。堕魔邦界。其中黠者。若一若两。为佛弟子耳。生六天上者。亦复少少。在魔邦者。甚多甚多。佛言。吾般泥洹后。亦多有外学。来求吾道。度者当隐括。审悉三月。知其志能习清净行。虚寂少欲不为污行。便可受之。先授十善。满三年已。服习道意。事示犯。乃为更受二百四十戒。其为威仪之事。精进守行。皆向解脱。是弥勒所当建也。当从得度。以为应道。阿难问佛。如佛所说。我皆顶受。宣语后人。令佛之弘法不为断绝。佛言阿难。汝前后所受。皆以贯心。我亦知汝有信护于佛法也。阿难问佛。后若有人。信乐应法。至心欲求。断世违俗。以从正道。若时无明师传教诫者。若有一人。书写戒律授与之。便可得度为道者不。佛言阿难。皆当得。知禁法者。尔乃可授戒耳。不可以文字受便为应法。何以故。佛为天上天下之大智。天上天下之大度。天上天下之大明。不可妄传失旨。皆当明于戒法禁律。事事委练。乃为相授耳。不明法戒禁要之事。而妄授人戒法。违佛诚信。反用为是大罪不小也。宜以审谛。阿难白佛言。后末之世。若有人至心至意。厌于苦痛。欲求度脱。世无有佛。当以何济其来意。佛言阿难。当将诣彼明戒法者。晓习威仪禁要之事。如是应度。度亦得度。自不明而复授彼。两迷失道。浑沌无穷竟已。何从得度脱耶。佛言。当来有比丘。不能自净。畜妻养子。身行污浊。贪求供养。不信罪福。而望安乐。难得免脱。甚亦可伤。阿难白佛言。如是后世。其有从道被服。皆是佛威神。其人以得像于正真因缘。当从得脱。何缘中复不信违佛明教。当复更若干无数劫受苦痛耶。佛言阿难。是皆前世无数劫。堕久苦之中。其人于苦痛之地。自悔责。愿得为善当从得脱。缘一时自悔之福辄得福。随来生末世。为人暂睹佛经。又能除剔头发。以为比丘。本识未械。心意犹豫。瞢瞢不了。故有污浊。多不能离俗。不遇明慧。如是当后更堕极苦之中。受无数劫罪。佛言。诸比丘。汝以出家。舍妻子弃世行。作沙门。当修戒行。如罗汉法。宁以洋铜灌口中。下过焦烂腹肠。终不无德食人信施。宁以利刀截手支解身体。不以无德受人信施。人无德力。受人信施。当累劫堕于罪苦。久久得出。用余叽末之福。得为人身。当复更还一一偿之。有作奴婢偿者。有作儿子偿者。有作父母偿者。阿难问佛。何谓偿债。佛言。有作奴婢。大家挝打。不以道理。奴婢受之。无有怨心。勤力作务。不惮劳疲。爱惜大家之物。不敢放散。是为现世偿债奴婢也。宿命先世。受人信施。不行功德。罪毕来偿。犹有本识。故无怨恚甘受而已。何谓偿债儿子。儿子致财。父母散用无有限度。儿子心亦无惜意。是为偿债儿子。何谓偿债父母。父母致财。儿主散用。父母不为爱惜。恣所当得。皆是宿识因缘相偿故。无惜心。诸此偿债。因缘合会。对讫更散。亦无常住。明者觉之。故不为也。唯有道德。可以久保。吾前世时。亦更为人偿债奴婢儿子父母。不可称数。皆有一时之缘。难可免脱。至今得道。现我父母。皆先世道德之缘。不由偿债。父母世世放舍。使我学道。累劫精进。今成得佛。皆是父母之恩。人欲学道。不可不精进孝顺。二堕失人种。累劫不复五末之世。持宜顺行。遭值经道。不可不勤。遭值佛世。不可不谛受着心。遭值明人。不可不勤问奉受。何以故。人身难有。六情难具。才聪难得。佛难得见。经难得闻。故宜勤之。佛言。吾般泥洹后。当有五逆恶世。当斯之时真丹土域。魔事当盛。闭塞正道。虽有经法。少有学者。设有学者。少有行者。世有比丘。少能自守清净。多有污浊。习俗之行高望游步。世人无异。求好衣服。学世辩辞。追世礼费。群党相随。以快心意。求世名誉。教人入法。度为弟子。不教护魔。不依正道。度世之业。亦不学问。追求明智。自谓德大。不守根门。虽得为人。假时而已。自谓长久。不知大对。当后受苦无穷竟已。颠倒翻覆。在魔部众。一何痛哉。诸比丘已得人身。六情完具。睹佛经戒。勤行当行诵之。一失人本。难有复时。佛世难值。经法难闻。宜各思惟。佛说经竟。诸比丘。皆俨然坐。自思惟即得罗汉佛说分别经


佛说分别善恶所起经

    No. 729

佛说分别善恶所起经

        后汉安息国三藏安世高译

佛在舍卫国祇洹阿难邠坻阿蓝。时佛伤哀诸所有生死之类故。结出谶微。分别善恶都有五道。人作善恶有多少。嗔恚有薄厚。天道无亲。常与善人。何谓五道。一谓天道。二谓人道。三谓饿鬼道。四谓畜生道。五谓泥犁太山地狱道。人不求度世道者。生死忧苦不断绝。往来五道。不得解脱。贤者黠人。厌于忧苦。见师则承事。不见则思师。教诫师教人。去恶就善。示人度世之道。父母养育。老病死亡一世耳。佛度人万世不极。贤明智者。宜熟思惟之。佛告诸弟子。皆听我为汝陈说善恶之祸福。诸弟子。皆长跪叉手言诺受教。佛言人于世间。慈心不杀生。从不杀得五福。何等五。一者寿命增长。二者身安隐。三者不为兵刃虎狼毒虫所伤害。四者得生天。天上寿无极。五者从天上来下生世间则长寿。今见有百岁者。皆故世宿命不杀所致。乐死不如苦生。如是分明。慎莫犯杀。佛言人于世间。不取他人财物。道中不拾遗。心不贪利。从是得五善。何等五。一者财物日增。二者不亡遗。三者无所畏。四者得生天。天上多珍宝。五者从天上来下生世间。保守其财产。县官盗贼不敢侵犯取其财。今现有保财至老者。皆故世宿命不敢取他人财物所致也。亡无多少令人忧恼亡遗不如保在。如是分明。慎莫取他人财物

佛言人于世间。不犯他人妇女。不念邪僻。从是得五善。何等五。一者不亡费。二者不畏县官。三者不畏人。四者得上天。天上玉女作妇。五者从天上来下。生世间多端正妇。今尊者见有若干妇端正好色。皆故世宿命不犯他人妇女所致也。见在分明。慎莫犯他人妇女。佛言人于世间。不两舌谗人。不恶口骂人。不妄言绮语。从是得五善。何等五。一者语言皆信。二者为人所爱。三者口气香好。四者得上天。为诸天所敬。五者从天上来下。生世间为人好口齿。他人不敢以恶语污之。今见有从生至老不被口谤者。皆故世宿命护口善言所致也。如是分明。慎莫妄谗人

佛言人于世间不饮酒醉。从不醉得五善。何等五。一者传言上事。进见长吏。语言不谬误。亦仕宦如意。二者家事修治。常有余财。三者假借求利疾得。亦为人所敬爱。四者得上天。亦为诸天所尊重。五者从天上来下。生世间洁白自喜。黠慧晓事。皆从故世宿命不饮酒所致。慎莫饮酒

佛言人于世间。不持刀杖恐人。不以手足加痛。于人不斗乱别离人。己所不欲。不施于人。从是得五善。何等五。一者身体强健。二者卧起常安隐。三者为诸天龙鬼神所护视。四者得上天。天上乐无极。五者从天上来下生世间。身体完具无疾病。今见有从生至老。无有疾病者。是皆故世宿命不加痛于人所致。如是分明。慎莫加恶于人

佛言人于世间。和心不嗔恚。见贤者敬之。愚者忍之。从是得五善。何等五。一者为人所称誉。二者人见之皆欢喜。三者身自安隐亦润泽好。四者得上天。天上端正净洁。五者从天上来下生世间。为人善性。端正姝好。今见有好人万人之选。皆故世宿命和心善性忍辱所致也。不嗔恚如是分明。慎莫嗔恚于人。佛言人于世间。孝顺父母。敬事长老。恭执谦卑。先跪后起。后言先止。常教恶人为善。从是得五善。何等五。一者为人所敬爱。二者人皆道其善。三者自意欢喜。四者得上天。为诸天所敬爱。五者从天上来下生世间。为众人所媚爱。今见有善心孝顺。为众人所媚爱者。皆是故世宿命孝顺敬事长老所致。如是分明。可作孝顺。事于长老

佛言人于世间。用谏晓事。善心好意。敬事尊老。礼节兼备。从是得五善。何等五。一者仕宦得好职。二者在官疾迁。卖买得利。三者百姓见之皆欢喜。四者得上天诸天见之皆欢喜。五者从天上来下生世间。为王侯公卿作子。皆故世宿命行礼作福所致。如是分明。慎莫憍慢于人。

佛言人于世间不悭贪。好喜布施。爱视诸家亲属贫穷者。若乞丐儿。饮食常当使饱。衣亦当完好。从是得五善。何等五。一者财产日增。二者为诸天下人所称誉。三者为州郡国所尊敬。四者得上天。天上所侍。五者从天上来下生世间。大富乐为众人所敬。皆故世宿命布施行善所致如是分明者。亦可行德布施。佛言人于世间。有明经贤者。若沙门道士。喜往问度世之道。心不嫉妒贪爱高远贤者。从是得五善。何等五。一者得黠。二者多闻。亦多知多见。三者多敬难之。四者得上天。天上识所学。五者从天上来下生世间。即明经晓道。为国家所敬重。亦为人所归仰。今见有明经晓道者。此皆故世宿命作道行德所致也。如是分明。亦可行道德。佛说经已。诸弟子皆欢喜。前为佛作礼

佛言听说。作恶得恶。诸弟子。皆叉手言。诺受佛教。佛言人于世间。喜杀生无慈之心。从是得五恶。何等五。一者寿命短。二者多惊怖。三者多仇怨。四者万分已后。魂魄入太山地狱中。太山地狱中。毒痛考治。烧炙烝煮。斫刺屠剥。押肠破骨。欲生不得。犯杀罪大。久久乃出。五者从狱中来。出生为人。常当短命。或胎伤而死。或堕地而死。或数十百日而死。年数十岁而死者。今见有短命人。若形瘢疮。身体不完。跛蹇秃伛。或盲聋喑哑鼽鼻塞壅。或无手足。孔窍不通。皆由故世宿命屠杀射猎罗网捕鱼残杀蚊虻龟鳖蚤虱所致。如是分明。慎莫犯杀

佛言人于世间。偷盗劫人。强取他人财物。求利不以道理。欺诈取财物。轻秤小斗短尺欺人。若以重秤大斗长尺侵人。道中舍遗取非其财。负债借贷不归。抵触以行互人。从是得五恶。何等五。一者财物日耗减。二者王法所疾。觉知当辜。少有脱者。三者若身未尝安归。常怀恐怖。亦自欺身。四者死后。魂魄入太山地狱中。太山地狱中。考治数千万毒。随所作受罪。五者从狱中来出。随所负轻重偿债。或有作奴婢偿者。或作牛马骡驴骆驼偿者。或作猪羊鹅鸭鸡犬偿者。诸禽兽鱼鳖之属。皆是负债者。经言债不腐朽所谓也。今见有下贱畜生之属。皆由故世宿命贪利。强取人财物所致也。畜生勤苦如是。见在分明。慎莫取他人财物

佛言人于世间。淫劮犯他人妇女。从是得五恶。何等五。一者家室不和。夫妇数斗。数亡钱财。二者畏县官常与捶杖从事。王法所疾。身当备辜。多死少生。三者自欺身。常恐畏人。四者入太山地狱中。太山地狱中。铁柱正赤。身常抱之。坐犯他人妇女故得是殃。如是数千万岁。形乃竟。五者从狱中来出。生为鸡凫鸟鸭。人魂魄无形所著为名。今见有鸡凫淫劮不避母子。亦无节度。亦有犬马之贞狗贞。于夫畜生之属皆有信足。而鸡凫淫劮。独无止足。皆从故世宿命淫劮犯他人妇女。受是鸡凫身。当为人所啖食。如是勤苦。不可数说。如是分明。慎莫犯他人妇女

佛言人于世间。喜两舌谗人。喜恶口妄言绮语。自贡高诽谤圣道。嫉贤妒能啤呰高才。从是得五恶。何等五。一者多怨憎。二者自欺身。亦从是人皆不信。三者数逢非祸。四者入太山地狱中。太山地狱中。有鬼从人项拔其舌。若以烧铁钩其舌断。若以烧铁[矛*良][矛*害]刺其咽。欲死不得。欲生不得。不能语言。如是数千万岁。五者从地狱中来出。为人恶口齿。或免缺弥筋蹇吃重言。或喑哑不能言语。今见有是曹人。皆故世宿命两舌谗人诽谤圣道所致也。如是分明。亦可慎恶口

佛言人于世间。喜饮酒醉。得三十六失。何等三十六失。一者人饮酒醉。使子不敬父母。臣不敬君。君臣父子。无有上下。二者语言多乱误。三者醉便两舌多口。四者人有伏匿隐私之事。醉便道之。五者醉便。骂天溺社。不避忌讳。六者便卧道中。不能复归。或亡所持什物。七者醉便不能自正。八者醉便低仰横行。或堕沟坑。九者醉便躄顿。复起破伤面目。十者所卖买谬误妄触抵。十一者醉便失事。不忧治生。十二者所有财物耗减。十三者醉便不念妻子饥寒。十四者醉便嚾骂不避王法。十五者醉便解衣脱裈裤。裸形而走。十六者醉便妄入人家中。牵人妇女语言干乱。其过无状。十七者人过其傍欲与共斗。十八者蹋地唤呼惊动四邻。十九者醉便妄杀虫豸。二十者醉便挝捶舍中付物破碎之。二十一者醉便家室视之如醉囚。语言冲口而出。二十二者朋党恶人。二十三者疏远贤善。二十四者醉卧觉时。身体如疾病。二十五者醉便吐逆。如恶露出。妻子自憎其所状。二十六者醉便意欲前荡。象狼无所避。二十七者醉便不敬明经贤者。不敬道士。不敬沙门。二十八者醉便淫劮。无所畏避。二十九者醉便如狂人。人见之皆走。三十者醉便如死人。无所复识知。三十一者醉或得疱面。或得酒病。正萎黄熟。三十二者天龙鬼神。皆以酒为恶。三十三者亲厚知识日远之。三十四者醉便蹲踞视长吏。或得鞭搒合两目。三十五者万分之后。当入太山地狱。常销铜入口。焦腹中过下去。如是求生难得。求死难得。千万岁。三十六者从地狱中来出。生为人常愚痴。无所识知。今见有愚痴无所识知人。皆从故世宿命喜嗜酒所致。如是分明。亦可慎酒。酒有三十六失。人饮酒皆犯三十六失

佛言人于世间喜持杖恐人。以手足加痛于人。喜斗乱别离人。己所不喜强持与人。从是得五恶。何等五。一者自欺身。亦为人所患毒。二者身为恐怖。三者又数病疾。四者入太山地狱中。随所作受罪。久久万岁。五者从狱来出。生为人多病身不离杖。今见有多病者。皆故世宿命喜加痛疾之所致也。多病不如强健。如是分明。慎莫加恶于人

佛言人于世间。常喜嗔恚不和调。见贤者亦恚。见愚者亦恚之。不别善恶。但欲嗔恚而已。从是得五恶。何等五。一者为自烧身。二者亦自乱意。三者卧起不安隐。或忧恚自杀。四者入太山地狱中。毒痛考治数千万岁。五者从太山地狱中出。生为人面目常恶。色萎黑黄熟。今见有恶色人。皆从故世宿命喜嗔恚所致。面丑恶色不如端正好色。如是分明。慎莫嗔恚

佛言人于世间。不孝父母。不敬长老。见他人有孝父母敬事长老者。常嗔恚之。不喜作善。从是得五恶。何等五。一者常得恶梦。二者为人所憎。三者恶名闻。四者入太山地狱中。考治数千万岁。五者从地狱中来出。生为人弊性不媚。为众人所憎。今见有不媚急性。为众人所憎者。皆从故世宿命。不孝父母不敬长老所致也。如是分明。慎莫憍慢。可孝顺敬事长老

佛言人于世间。不孝尊老。无有礼节。轻易憍慢。自用自强。从是得五恶。何等五。一者失亡职位二者自欺身。三者不为人所敬。四者入太山地狱中。考治数千万岁。五者从狱中来出生为人当作下贱丑恶。为人所轻易。今见有下贱人。皆从故世宿命憍慢不敬尊老所致也。如是分明。慎莫憍慢。佛言人于世间。得财产悭贪不肯布施。不爱视诸家贫穷者。不给与之。不供事沙门明经道士。不丐不与乞儿。若病人食饮不敢自饱。衣被不敢自完。从是得五恶。何等五。一者自欺身。亦为人所不敬。二者人皆呼守钱奴。三者恒荷惭愧。四者堕饿鬼。勤苦不可言。或千岁百岁。不能得水饮。遥望见江湖若溪谷水。走往欲饮之。水便化作销铜若脓血不可饮。如是勤苦不可缕说。五者从饿鬼中来出。生为人当贫穷冻饿。从人乞丐。脊骨相支柱。乞丐不能得。人当唾骂之。今见有贫穷乞人。皆从故世宿命。悭贪不肯布施所致也。如是分明。慎莫悭贪

佛言人于世间。有明经贤者。若沙门道人。不喜往问度世之道。嫉妒高才。诽谤贤者。从是得五恶。何等五。一者不慧。二者少知。三者不为人所敬。四者入太山地狱。入太山地狱中。考治数千万岁。五者从狱中来出。生为人愚痴无所识知。与畜生同例。今见有愚痴不别白黑者。皆从先世宿命。不喜道德嫉妒高远所致也。如是分明。慎可行道

佛言人求寿得寿。不求寿不得寿。求病得病。不求病不得病。求端正好色。得端正好色。求丑恶色。得丑恶色。求媚得媚。不求媚不得媚。求下贱得下贱。求富得富。求贫得贫。求明经晓道。得明经晓道。求愚痴得愚痴。人作善得善。若干福得上天。若为人得尊贵。亦得端正。若人作恶得恶若干罪。或入太山地狱中。或堕饿鬼中。或堕畜生中。设得作人。当作下贱贫穷。无所识知。亦复丑恶色。如人种苦得苦实。种甜得甜实。长实譬如种五谷。种稻得稻。种豆得豆。如人作善得善作恶得恶矣

  传远疏通戒于太察　　笃信守一戒于壅蔽
  勇猛刚毅戒于暴乱　　仁爱温良戒于不断
  广心浩大戒于狐疑　　沈清安舒戒于后时
  刻削溢急戒于剽疾　　多人长辞戒于无实

  贤者且守戒　　行之有三善
  见敬多求愚　　寿尽受天身
  住戒行已尽　　已慧制意行
  行至必当至　　悉断所当受
  从戒可灭痛　　三世戒在上
  制使邪毒龙　　不犯有戒人
  善哉有戒尊　　以信可为伴
  是道非凡言　　故名戒有尊
  戒尊善可怙　　身终不见烧
  既卧于夜安　　已梦复欢然
  为众所见敬　　力善自为身
  法见自为尊　　舍世为天王
  我是世独尊　　我已脱世患
  悉是人天世　　犹我校魔兵
  惟佛历勤苦　　毕劫不可数
  往来五道中　　未能具[糸*爾]缕
  奸匿序厥得　　号呼见视短
  今日礼佛者　　一心皆叉手
  从礼得上天　　人中得长寿
  佛尊觉第一　　已现慧具足
  当前礼法众　　恩德若江海
  是以吾演说　　佛之圣典籍
  从本起因缘　　所行有善恶
  广采以撰立　　随经义要趣
  集叙如佛指　　所作殃福事
  佛已自觉法　　梵释来下请
  尊乃删说经　　至要难见闻
  苦从苦因缘　　苦尽乃为尊
  如应八道成　　苦灭是为净
  从行有苦果　　人雄之所演
  是本为从心　　劳行从是有
  众劳除愈者　　是行之妙要
  故为次第说　　诚如大圣尊
  是故着经典　　令世观摸法
  合应正无疑　　智者所宜取
  亦非神所化　　令祸福无缘
  亦非性自然　　又非时可传
  在天岂无缘　　时与性亦然
  殊胜与不胜　　其实非无行
  从痴致有劳　　斯劳从行致
  已作脱复过　　听此非一辈
  钞缀经妙旨　　及律之杂要
  足知世所由　　部部各分明
  神化解疑结　　以经现世间
  善行有福报　　当可不识此
  已作不义行　　其死堕恶道
  即时见阎王　　王哀便系束
  婴儿老病死　　谏以当就罚
  知有五使者　　何为不修德
  身口意所行　　唯戒施为上
  尔独何志念　　而能不为善
  是时有罪人　　闻王以法谏
  自揆无良操　　入怖而对曰
  但以亲恶友　　闻凡非法言
  坐以贪浊故　　不能修德善
  王曰人难得　　幸得奚不善
  为性何难悟　　冤造泥犁行
  汝本兴斯恶　　则非父母为
  非沙门道士　　非君非我教
  愚痴快心意　　作此不善业
  自身之所为　　今当受其报
  造以五使者　　忠正之言诲
  然后阎法王　　默而不与语
  尔乃录罪入　　置于阎界中
  掔将入地狱　　见恶甚惶懅
  始入黑绳狱　　大小并唤呼
  次入阿鼻摩　　炽火烧其形
  蹈棘跂热土　　径涉沸灰水
  铁狱凡十六　　自到刀叶树
  为人犯恶故　　令有此泥犁
  故列其本行　　次现所应受
  至于千亿岁　　生生而辄杀
  由是结怨多　　贼害贤人雄
  生妄挐无过　　离败人朋友
  常喜谗恶人　　死入黑绳狱
  有持多诈便　　指治酷虐人
  后更山机迮　　捣之以铁杵
  为人好杀生　　马牛鹿羊豕
  鸡犬及诸虫　　亦更山机迮
  痴贪怀怯弱　　苟以毒害彼
  求财不用法　　铁轮轹其躯
  恃量以力教　　伏彼无力者
  喜施恼于人　　常为象所蹋
  今生恼父母　　沙门婆罗门
  娆故令郁毒　　后身被热炙
  或迈击父母　　仁贤奉道者
  及他所当敬　　后世更煮治
  迫胁从受取　　证入无辜民
  然后身长烧　　唤呼独痛呻
  侵人以益己　　受寄而直抵
  后烧在火室　　大呼无谁救
  非法言是法　　是法言非法
  篾毁谁无圣　　后生阿鼻狱
  学居庙堂净　　而为过失行
  由是令谤贤　　从是入深狱
  弃捐正善业　　从邪乐得生
  后身没溷中　　啖溷虫为食
  放火燔草野　　以害诸虫豸
  后入积薪狱　　烧之如野火
  阴贼亲厚者　　躯为利刀刺
  啄鸟铁耳狗　　宛转共食之
  若有坏法桥　　谤讪至德者
  堕狱蹈践越　　履刀刃之道
  犯人妇女者　　巨躯有百足
  容貌似美女　　与友便攫之
  好乐于淫劮　　放意于人妇
  斯常与苦会　　身攀抱刺树
  若为诸巧便　　杀水所生虫
  杀后堕沸汤　　灰河之中生
  借贷不归者　　身常被铁钩
  刚铁烧烔然　　洋铜以饮之
  怀恨意忿怒　　果敢为非法
  见人穷苦喜　　死为阎狱鬼
  生作不善行　　死即入地狱
  其痛不可数　　一切但有苦
  如是已具说　　地狱种所行
  听解畜生事　　饿鬼及鬼神
  身意各有三　　口四为不善
  躁扰心速变　　死堕畜生中
  若多淫欲态　　后生为痴虫
  雁鸽鸠鸳鸯　　孔雀亦蜚蛾
  喜缚挝捶者　　后世多受恼
  自为象马牛　　嗔恚死成蛇
  憍傲常慢人　　后生为猛兽
  轻易者后世　　为猪犬狐驴
  常内怀嫉妒　　心亦不一住
  后世为猕猴　　强面目成鸟
  悭贪而邪诳　　多行盗贼人
  死后为猫豺　　虎狼肉食兽
  布施多嗔怒　　持心不质直
  然后堕龙中　　乃有大神力
  广施有恚心　　轻人而自大
  后作迦留鸟　　致有大威猛
  身自食甘美　　以恶施与人
  死为溷饿鬼　　常食臭中虫
  好调娆老小　　乞儿与病人
  后为臊饿鬼　　食产乳恶露
  虽与心悭悔　　恒自惧不足
  后为黑饿鬼　　从下掣得食
  谓施为无福　　未尝肯少施
  后为鄙饿鬼　　主食人所吐
  不与追谤施　　食粗外自举
  后为窦饿鬼　　恒食人欬唾
  自有既不与　　常望求于人
  后为穷饿鬼　　所欲不能得
  喜阴识彼短　　治人以望财
  后为弊饿鬼　　主食死人肝
  粗言以恼彼　　中伤说人短
  后为焦饿鬼　　常吞食火烟
  劝讼好会斗　　酷虐恐热人
  后为焰火鬼　　食于蜚蛾虫
  禁止人布施　　身亦不自与
  后为大身鬼　　其口若针鼻
  拥财以遗子　　不食亦不施
  其死属阎界　　子祭乃得食
  生为隘[阿-可+聚]长　　侵人以行患
  为鬼形丑大　　所欲终不得
  语言常欺调　　不与不持戒
  欢娱行急促　　终生鬼神中
  杀虫以为饵　　钩生蒙其利
  取杀而食之　　后世为魅魍
  布施望其后　　不诚多忿怒
  后成臼注鬼　　颜貌极丑恶
  既以恚且贪　　好施而嗜酒
  喜于鼓乐舞　　死为守地神
  于家内外亲　　无恶亦无嫉
  后为有力神　　乘云风而行
  布施屋室乘　　亦与诸美味
  为神在所之　　庐舍随其飞
  好欲而懈怠　　喜以华香施
  后为天伎人　　游戏自恣心
  于是畜生行　　饿鬼及鬼神
  悉已为总说　　又复听善因
  至于为所行　　亦有若干比
  其应非一种　　今为如事说
  天人阿须罗　　欲求长寿者
  内意当自省　　无害一切生
  若以不施劳　　不缚捶娆彼
  恒发安群生　　为人则无病
  不杀好恩德　　意固不复动
  终不害一切　　为人常仁贤
  未尝有少施　　颇受于几微
  然后身极苦　　求少得或不
  好取他人财　　而以为惠施
  后虽得财富　　犹速亡失之
  不妄取非物　　亦都无所与
  恒自勤苦求　　后传世得财
  既不取彼物　　常自乐布施
  累世有财富　　得利甚弘广
  自好持戒斋　　后生必明智
  爱法得誉安　　足贤意端正
  子善供养父　　既亡屡祭祀
  亦以敬施天　　后所之得食
  好施饭食者　　后生得命色
  有力辩达富　　无病常安隐
  好施衣被者　　失惭好容色
  心善人乐见　　快乐得所欲
  施与屋舍者　　后世所止安
  宫馆诸所居　　事事严具足
  施井设义浆　　沐浴莲华池
  后世得不得　　所欲一切富
  今世好布施　　履屣船车桥
  象马亦诸乘　　后世得天乘
  无怒人爱见　　一切所归仰
  后生高长子　　其施园树者
  好以奴婢施　　加以恭敬意
  后得于姓誉　　侍使无所乏
  先祖大布施　　子孙继不绝
  后生巨亿富　　辄得父余财
  好称布施德　　有意不能与
  后虽堕人伦　　生于贫狭家
  谤施谓无益　　但为哀故与
  虽无布施意　　犹生富财家
  心常乐智慧　　然而不布施
  后常得聪明　　生于贫窭家
  常好喜布施　　而不学智慧
  于智不敏达　　生于大富家
  设兼行施智　　亦兼受其福
  设两不兼行　　亦两无所得
  施与望姓誉　　未施若已施
  若后欲施者　　斯为食恼苦
  布施虽无信　　然犹得财产
  若乐彼施财　　后意颇有喜
  布施如有信　　后世常富财
  多货能得尊　　其意甚欢悦
  如侍敬有德　　善意供养施
  后得财可意　　既得最殊胜
  常以轻易意　　施与修德者
  然后虽得财　　安时不得食
  布施欲安人　　不行诐陷人
  然得所爱敬　　亲属靡不敬
  施与恣所有　　修德无所诤
  后获所爱喜　　法德利具足
  施与有黠眼　　不谄求非物
  福祚传子孙　　累世常保财
  慧人行布施　　用时不劳彼
  虽少不失时　　食福时自恣
  修身以自守　　不好犯人妇
  后得所爱欲　　贞良有戒德
  妇人有非时　　智士能自绝
  后为人无怨　　受性大清净
  若修清净行　　所行无论议
  后生有威誉　　为天所供养
  去离于醉酒　　修行常清净
  后识不迷惛　　得利内明慧
  为身若人故　　终而不妄语
  后生身中适　　莫得说其短
  友诤辄和解　　不好妄传说
  后亲不别离　　身常为人雄
  恒以柔软言　　忠至入人心
  后语工可众　　闻者莫不爱
  集会坐论议　　如事言得中
  后世得辩和　　语时人乐听
  一切彼所有　　其心不念取
  后世心中安　　终无忘遗忧
  已知事事思　　众善之报应
  为人都近善　　食福果甚多
  常欲利成就　　望誉天上安
  知生不常久　　心必思修德
  好恶信在行　　人伦之大利
  种杂故得杂　　在白不白中
  少壮或长老　　自在作行时
  然后如时得　　苦乐各应本
  暂行若长行　　所为善不善
  中作中时得　　长作乃长得
  师友忠恕言　　今世后世厚
  匆蔑不承用　　后生常聋聩
  诈为欺慢者　　后生伛短陋
  喑哑或恶色　　族姓莫欲见
  不亲老则愚　　事有道则利
  不慢后尊贵　　憍慢则卑贱
  布施后则富　　无与意则贫
  嗔恚得恶色　　不怒后好色
  好奸不男女　　欲犯不可淫
  騬割诸畜生　　后生为黄门
  思淫若炽火　　身根心口犯
  专行求女人　　后生为黄门
  说布施善道　　来劝已乐从
  等心视憎爱　　后生有三眼
  喜以好衣服　　施与有德者
  后生常好雅　　光润色若金
  视人如赤子　　护老病亦然
  后常值圣人　　皦若星中月
  不干奉斋戒　　兼身产乳妇
  后得伎女乐　　犯者有干谤
  礼敬泛爱众　　后软手足掌
  保货安不动　　得敬如大山
  不问讯使伶　　无求但好施
  后得食具足　　有财聚若海
  有德蒙上天　　法善众归仰
  后豪尊欢乐　　生为帝王种
  身口恒习善　　布施用和颜
  后富莫能嫉　　受乐生北方
  阴以善报仇　　终不妄施恶
  口诤而心柔　　后为阿修罗
  如有见善道　　具足以睹正
  从得生天上　　曜若日之光
  善孝事父母　　后生贵姓家
  不诤不好怒　　食福忉利天
  无所与言诤　　亦不参斗讼
  守善心修德　　后生艳天上
  多闻安思惟　　好利而求脱
  念善德以善　　后生兜术天
  守戒常禅思　　依法无所恃
  亦劝彼令然　　生不骄乐天
  自守好最施　　不逆不自称
  平均爱有道　　生彼尼密天
  鞭杖绳之恼　　不以加群生
  安慰一切人　　食福于梵天
  心慈口言善　　念安人若己
  有求而辄与　　生彼迦夷天
  念行常如斋　　不愿世喜乐
  定意立安静　　生阿波苏天
  定心弃爱女　　除三习一乐
  能欢思正止　　得生遍净天
  苦乐计非常　　身所行则知
  见识最清净　　生堕苛颇天
  晓了不净想　　多行有王处
  弃习而无想　　生无有想天
  无倚有微倚　　恢廓行四业
  念禅自清定　　生五净天中
  柔软意殊胜　　心正性中和
  广博修天业　　生阿迦腻天
  解色猗无常　　乐求无边志
  所识意无际　　思惟得出生
  已离诸情识　　无甫所向生
  有念亦已过　　欲无想而想
  虽决犹复生　　报现有平行
  智士自观察　　知善行可作
  是法有特异　　故为人具说
  非天非时种　　所受从自作
  生非常可观　　慧不思望倚
  凡往生善处　　皆为由行倚
  若已解非身　　无为生死空
  寂放灭苦辛　　是乐最第一　佛说分别善恶所起经


佛说分别缘生经

    No. 718

佛说分别缘生经

        西天译经三藏朝奉大夫试鸿胪卿传教大师臣法天奉　诏译

如是我闻。一时佛在乌卢尾螺池边。泥连河侧。菩提树下。成佛未久。独止其中。心生思念。世间苦法。无能免者。无能怖者。决定实有。如是观察。是大义利。世间乐法。亦复如是。无能免者。无能厌者。决定实有。如是观察。是大义利。又复思惟。所有世间。天人魔梵沙门婆罗门等界中。而于此法。不能了知。若复有人。善能思惟。警觉苦乐。如是了达。非究竟法。常所思念。依法修行。是人当得具足戒定慧解脱解脱知见等法。所有过去未来诸佛。皆悉觉知世间苦乐。一一了知。如法修行。以自行力。而成正觉。何以故。此法未曾有。无能了知者。所有过去。如来应供正等正觉。皆于此法。一一了知。如法修行。乃成正觉。未来世中。如来应供正等正觉。如是世间苦乐等法。一一了知。如法修行。乃圆道果

尔时娑婆界主。大梵天王。以佛威力故。知佛所念。譬如力士屈伸臂顷。离梵天界。来诣佛所。修敬毕已。住立佛前。而白佛言。世尊。佛所思念。如是如是。世间苦乐。无能免者。是大义利。过去未来。亦复如是。于天人魔梵界中。唯佛世尊。一一了知。若增若减。若善若恶。悉能分别。缘生之法。以佛智力。如实了知。佛言梵王。如是如是。世间众生。于一切法。无智无识。不能了知。无明痴暗之所覆闭。是为无明。从无明缘而生于行。行有三种。谓身口意。复从行缘而生于识。识有六种。谓眼识耳识鼻识舌识身识意识。从于识缘而生名色。名者除色。各有四种。谓受想行识。色者所谓四大。一切色法。由四大生。如是色蕴名蕴二种。是为名色。从名色缘生于六处。内六处者。有其六种。谓眼处耳处鼻处舌处身处意处。从六处缘。复生于触。触有六种。谓眼触耳触鼻触舌触身触意触。复从触缘而生于受。受有三种。谓乐受苦受不苦不乐受。复从受缘而生于爱。爱有三种。谓欲爱色爱无色爱。复从爱缘而生于取。取有四种。所谓欲取见取戒禁取我语取。复从取缘而生于有。有者三种。谓欲有色有无色有。从有为缘即有生法。其生法者。谓众生界。随蕴生起。处处差别。生异灭法。常所迁易。从生为本有蕴有界有处乃至命根等法。是名为生。从生为缘而有老死。老者所谓心识昏昧。发白面皱。气力劣弱。呻吟喘息。身体羸劣。乃至诸根而悉衰朽。是名为老。死复何相。死者谓诸众生界趣差别。悉归无常。寿限终尽。舍于暖触。命根灭已。诸蕴亦舍。四大离散。是名为死。如前所说。老与死法。是为二种。如是所说。即名分别缘生之法。若诸众生。能了知者。是人当得具足五分法身。尔时梵王。闻佛所说缘生法已。礼佛而退。还梵天界佛说分别缘生经


佛说佛大僧大经

    No. 541

佛说佛大僧大经

        宋居士沮渠京声译

佛在王舍国。国有富者。其名曰厉。金银众宝田地舍宅。牛马奴婢。不可称数。厉年西耄。绝无继嗣。其国常法。人无子者。死后财物。皆没入官。厉祷日月诸天鬼神并九子母山树诸神。皆从请子。不能致之。厉自念曰。人有缓急。辄往自归山树之神。靡所不至。财宝消索。产业不修。疾病相仍。灾祸首尾。奴婢死亡。六畜不孳。俱为妖孽。鬼神导师。迷惑舞使。乱君内居。云当有福。而祸重至。由盲吞毒谓之良药。庶有瘳损。毒着丧身。吾今杀生。祠祀鬼神。当入地狱。而望天祚。岂不惑哉。世有佛道。高操之圣。有得仙者。名曰应真人。真人清净。如琉璃珠。精进存想。乃睹之耳。奉斯道者。唯守靖漠。无欲无求。以斯为乐。现世得安。终生天上。厉自念曰置吾常供养。奉佛三宝。奉佛一载。妇遇生男。厉曰奉佛获愿。字曰佛大。佛诸弟子。谥比丘僧。试复事之。事未满岁。复生贤男。字曰僧大厉训二子。示以圣道。僧大禀性。仁爱人物。孝心难攀。诵佛法戒。亲近沙门。清净知足。亲睹其志。爱之有特。亲被疾着床。即呼长子。渧泣诫之。夫生有死。万物无常。持戒者安。犯戒者危。其持佛戒。终始无患。僧大尚小。仁孝清白。厉已累尔。辞句适竟。奄忽殁故。弟去所天。孤无归告。数启其兄。欲作沙门其国之法。儿欲求妇。便佯诈云。欲作沙门。亲惧其然。立为娉妻。佛大以弟等彼伪类。即为寻索。国最贤家女。字快见。光华炜炜。端正少双。长短肥瘦。适得其中。贞洁慈孝。犹星中月。国女贤妇。靡不叹悦。妇归升堂。兄会宾客。九族欣然无不和乐。兄于众宾。调其弟曰。当今之日。可作沙门乎。僧大答曰。大兄放吾。使作沙门。实我宿愿。寤兄者天审欲作之。戏之曰。可从尔志愿。弟心欢喜。为兄作礼。即日入山。见一沙门。年少端正。独处树下。前趣叉手。稽首为礼。却住问曰。贤者何缘。行作沙门。其人已得应真之道。豫知去来无数劫事。谓僧大曰。佛经说言。人好淫泆。如火烧身。如持炬火逆风而行。其焰稍却。不置炬者。火烧其手。犹乌衔肉。鹰鹯追争。乌不置肉。灾及躯命。淫泆如斯。无不危殆。吾以是故。作沙门耳蜜涂利刀。小儿贪甜。以舌舐之。有截舌之患。淫泆之人。苟快愚心。不惟其后。有烧身之害。譬如饿狗得路枯骨。齮[齒*齊]咬啮。伤口缺齿。适自伤毁。何益于己。淫泆如此。百千亿劫。无丝发之福。而有三涂之罪。吾念是故。作沙门耳。譬如树木华果茂盛。行人贪之。杖石挝擿。须臾之间。华损果落。枝叶残伤。树以华果。自招凋丧。蛾贪火色。投入于灯体见烧煮。将何克获为淫。惑者不别善恶。远贤亲愚。日就流冥。亡国灭众。死入地狱。恶着罪成悔将何逮。佛见之谛开示圣道。吾望佛恩。得睹经戒。心守清白。独而无患。顾视流俗。乃知误耳。吾以是故。作沙门也。僧大闻之。顿首足下长跪而白。佛真上圣。诸天之尊。经以灭痴。入我心中。愿去世浊。履清净道。奉沙门戒。以为荣福。师即喻之。沙门重戒。侍师数月。即启师云。何意欲入山间。寂定禅息。求道应真。尔乃灭患。师曰独居山中。大难处也。处山泽者。当学星宿明知候时常当储偫水火糗蜜。所以然者。盗贼之求水火糗蜜。夜半向晨。问当解之。给贼所欲。违其意者。贼辄杀人。僧大曰诺。敬奉慈教。具学所命。却乃入山。其兄念曰。弟作沙门。终不畜妻。妻快见者。端正无双。兄心悦之。起从快见。持琴自随。作姿弹之歌。淫泆之曲。惶惶郁金。生于野田。过时不采。宛见弃捐。曼尔丰炽。华色惟新。与我同欢。固斯厚亲。年一西宿。孰复尔珍。快见即觉兄欲为乱。便以歌曲。答佛大曰。巍巍我师。天人之尊。门徒清洁。谥曰沙门。叹真为圣。淫为畜伦。我受严戒。不事二君。终不淫生。宁就寸分。佛大作情悲之曲。委靡之辞。宿心加尔。故因良媒。问名诣师。占相良时。惨惨惕惕。惧尔不来。既睹光颜。我心怡怡。今不合欢。岂徒费哉。斯誓为定。淑女何疑。快见惶[怐-口+、]。歌答之曰。佛设礼仪。尊卑有叙。叔妻即子婿伯即父。我亲奉戒。日有隆举。真与圣齐。淫正虫鼠。噫乎伯子。焉为斯语。兄心迷惑。贪好快见。其意又甚。不可转移。快见又歌。夫人处世。当远二事。不孝淫乱。行违佛戒。天及贤者。笺其自异。佛大歌曰。尔之容色。怿怿灼然。普天美女。岂有尔颜。我心相悦。故踰大山。快见自念。斯子欲我。悖狂之乱。沮致大难。请说身中恶露不净。尔乃却耳。快见重曰。仁贪我躯。躯有何好。头有九骨。合为髑髅。中但有脑。面有七孔。皆出洟唾。以皮裹骨。贪头颈者。皮肉相裹。身有毛发爪齿皮肌血脑骨肉。腹中有心脾肾肠胃肪肺屎尿脓血寒热。足与胫连。胫与髀连。髀与尻连。尻与腰连。腰与脊连。脊与胁连。胁与颈连。颈与髑髅连。臂与肘连。肘与肩连。我如画瓶。中盈屎尿。身中不净。可恶如此。何可贪乎。凡人所喜。有说其恶。心即贱之。佛大自念。女念其婿。何肯听我。我杀弟者。尔乃随耳。佛大嗔恚。即行募求数为贼者。见轻薄人。在于酒家。前与语曰。宁知我家所畜六藉奴子。逃作沙门。今在山中。贼曰识之。佛大即出金银与之。令杀奴子。疾取其头及身上衣。所持法杖。足下履屣。皆以相还。吾复重赐卿等金银。贼大喜曰。从吾取足。即去入山。到其弟所呼曰。沙门汝疾出来。其弟出曰。诸君何求。吾有水火糗蜜可食。夜时已半。贼曰不求水火糗蜜。不问卿时也。欲得汝头持去之耳。其弟闻之。即大惶怖。涕泣而曰。吾非长者诸侯子也。舍俗为道。与世无争。学道日浅。未获沟港频来不还应真六通。杀吾何益。贼曰。来为汝首故空复云云。求哀何益。其弟自念。此贼独闻我富家。谓我持宝来在此也。语其贼曰。欲得宝者。吾兄在家。字曰佛大。吾与书令惠卿。宝在所欲得。从卿志愿。贼曰子兄令我来杀子其弟曰。即吾今死矣。由斯妇也。师前诫我。人与淫居。如持炬火逆风而行。舍之不早。火将烧手。如蜜涂刀。如鹰追乌。狗得枯骨。树之华果。色为身害。深如师诫。涕泣从贼。乞一岁活令吾得道。吾常在此。相杀不晚。贼曰。今欲得子头去。何云一岁。山居道人。多得道者。恐子轻举行神足去。勿复多云。俘取头去。其弟重曰。愿莫即杀。先断我一髀置吾前也。其贼因前。先断一髀。置于其前。弟遭此痛。痛不可言。天来下至道人所曰。慎莫恐怖。牢持汝心。汝前世时。入畜生中。人所屠割。称卖汝肉。非一世矣。地狱饿鬼。汝皆更之。苦痛以来。非适今也。僧大语天。一哀语我师令知。吾因师示吾道。死生何在。天即为行语其师曰。卿贤弟子。人欲杀之。涕泣求哀。欲得见师。师飞行到弟子所。为说经曰。天地须弥。尚有灭坏。海有消竭。七日有坏。天下有风。其名惟岚。惟岚一起。山山相搏。斯风有灭。况汝小躯。何等比数。但当念佛。佛常言无常。盛必有衰。合会有离。荣位难保。身亦如之。僧大便得沟港道。复断一髀。重念师戒。复得频来道。贼断左手。复念师戒。得不还道。贼断右手。复念师戒。得应真道。便不畏三恶道也。生死自在。无所复畏。僧大曰。取树皮来。即为剥树皮。与之僧大。取枝以为笔。自刺身血。书树皮曰。大兄起居随时安善。二亲在时。以吾累兄。兄不承之。违废亲教。以女色故。骨肉相残。违亲慈教为不孝也。残杀人命为不仁也。杀一畜生其罪不小。况杀应真。吾不中止。兄自招之。念吾有形。可得相杀。善逝寂寞。徒复相害长别。努力愿崇真道。曳颈长二尺。语其贼曰。子断吾头。由泥头也。勿有恐意。吾恐汝等堕地狱中。贼前断头。取身上衣被杖屣及钵。持至兄所。衣杖屣钵。皆持与兄。兄以金银重谢其贼。兄取弟头。为作假形。以头着上。以衣衣之。杖钵及屣。皆着其傍。谓快见曰。汝婿来归。可问讯之。快见大喜。走至其所。见闭目坐。以为思道。妻不敢呼。具作美食。须念道觉当饭之。日中不觉。妻因前曰。日今已中。恐过时也。怪其不应。牵衣起之。头便堕地。身皆分散。各在一面。妻即大怖。擗踊呼曰。子竟坐吾。见残贼乎。哀愤呼天。摧裂肝心。崩血出口。奄忽而死。戒行清白。难污如空。树心圣范。难动如地。贞净行高。难揆如天。其未终时。诸天咨嗟。豫安所生。迎其魂灵。处忉利天。忍须臾之淫获天上难尽之荣。兄入神室视妇胡为。兄见弟头身分散狼藉。其妇吐血死在一面。兄见弟妻尸死如此。呼曰。咄咄吾为逆天。所作酷裂。乃致于此兄即至贼所问其意。吾弟临没。将有遗言乎。贼曰有书。以书见之。书辞恳恻。读书讫竟。五内噎塞。涕泣交撗。吾违尊亲。临亡悲教。骨肉相残。又杀应真。感激而死。死入地狱。王及臣民。闻其事变。麾涕泣哽噎。叹述清德。殡葬其弟。四辈立塔。天龙鬼神。侧塞空中。散华烧香。无不伤心。其妻快见。国人葬之。举哀动国。诸天下赞。精进得道。五戒不亏。贞生天上。违佛法教。不孝残圣。死入地狱。烧煮苦毒。其岁难数。佛便告诸弟子。自斯之后。重相敕励。尚于无欲。佛说经竟。诸弟子欢喜。作礼而去佛说佛大僧大经


佛说佛地经

    No. 680

佛说佛地经

        大唐三藏法师玄奘奉　诏译

如是我闻。一时薄伽梵。住最胜光曜七宝庄严。放大光明普照一切无边世界。无量方所妙饰间列周圆无际。其量难测超过三界所行之处。胜出世间善根所起。最极自在净识为相。如来所都。诸大菩萨众所云集。无量天龙人非人等常所翼从。广大法味喜乐所持。作诸众生一切义利。灭诸烦恼交横缠垢。远离众魔过诸庄严。如来庄严之所依处。大念慧行以为游路。大止妙观以为所乘。大空无相无愿解脱为所入门。无量功德众所庄严。大宝花王众所建立。大宫殿中。是薄伽梵最清净觉。不二现行趣无相法。住于佛住。逮得一切佛平等性到无障处。不可转法所行无碍。其所成立不可思议。游于三世平等法性。其身流布一切世界。于一切法智无疑滞。于一切行成就大觉。于诸法智无有疑惑。凡所现身不可分别。一切菩萨正所求智。得佛无二住胜彼岸不相间杂。如来解脱妙智究竟证无中边。佛地平等极于法界。尽虚空性穷未来际

与诸无量大声闻众俱。一切调顺皆是佛子。心善解脱慧善解脱。戒善清净趣求法乐多闻闻持。其闻积集善思所思善说所说善作所作。捷慧速慧利慧出慧。胜决择慧大慧广慧及无等慧慧宝成就。具足三明。逮得第一现法乐。住大净福田。威仪寂静大忍柔和成就无减。已善奉行如来圣教。复有无量菩萨摩诃萨。从诸佛土俱来集会。皆住大乘游大乘法。于诸众生其心平等。离诸分别及不分别种种分别。摧诸魔怨远离一切声闻独觉系念分别。广大法味喜乐所持。超五怖畏一向趣入不退转位。息诸众生一切苦恼所逼迫地而现在前。妙生菩萨而为上首

尔时世尊告妙生菩萨。妙生当知。有五种法摄大觉地。何等为五。所谓清净法界。大圆镜智。平等性智。妙观察智。成所作智

妙生当知。清净法界者。譬如虚空。虽遍诸色种种相中。而不可说有种种相。体唯一味。如是如来清净法界。虽复遍至种种相类。所知境界。而不可说有种种相。体唯一味

又如虚空虽遍诸色不相舍离。而不为色过所染污。如是如来清净法界。虽遍一切众生心性。由真实故不相舍离。而不为彼过所染污

又如虚空含容一切身语意业。而此虚空无有起作。如是如来清净法界。含容一切智所变化利众生事。清净法界无有起作

又如空中种种色相现生现灭。而此虚空无生无灭。如是如来净法界中。诸智变化利众生事现生现灭。而净法界无生无灭

又如空中种种色相现增现减。而此虚空无增无减。如是如来净法界中。显示如来甘露圣教有增有减。而净法界无增无减

又如空中十方色相无边无尽。是虚空界无边尽故。而此虚空无去无来无动无转。如是如来净法界中。建立十方一切众生利益安乐。种种作用无边无尽。清净法界无边尽故。而净法界无去无来无动无转

又如空中三千世界现坏现成。而虚空界无坏无成。如是如来净法界中。现无量相成等正觉。或复示现入大涅槃。而净法界非成等觉非入寂灭。又如依空种种色相。坏烂烧燥变异可得。而虚空界非彼所变亦无劳弊。如是依止如来净界众生界内。种种学处身语意业毁犯可得。而净法界非彼变异亦无劳弊

又如依空大地大山。光明水火帝释眷属。乃至日月种种可得。而虚空界非彼诸相。如是依止如来净界。戒蕴定蕴慧蕴解脱解脱智见诸蕴可得。而净法界非彼诸相

又如空中种种因缘展转生起。三千大千无量世界周轮可得。而虚空界无所起作。如是如来净法界中。具无量相诸佛众会周轮可得。而净法界无所起作

复次妙生。大圆镜智者。如依圆镜众像影现。如是依止如来智镜。诸处境识众像影现。唯以圆镜为譬喻者。当知圆镜如来智镜平等平等。是故智镜名圆镜智

如大圆镜有乐福人悬高胜处无所动摇。诸有去来无量众生。于此观察自身德失。为欲存德舍诸失故。如是如来悬圆镜智。处净法界无间断故无所动摇。欲令无量无数众生观于染净。为欲取净舍诸染故

又如圆镜极善磨莹。鉴净无垢光明遍照。如是如来大圆镜智。于佛智上。一切烦恼所知障垢永出离故。极善磨莹为依止定。所摄持故鉴净无垢。作诸众生利乐事故。光明遍照

又如圆镜依缘本质。种种影像相貌生起。如是如来大圆镜智。于一切时依诸缘故。种种智影相貌生起

如圆镜上非一众多诸影像起。而圆镜上无诸影像。而此圆镜无动无作。如是如来圆镜智上。非一众多诸智影起。圆镜智上无诸智影。而此智镜无动无作

又如圆镜与众影像。非合非离。不聚集故。现彼缘故。如是如来大圆镜智。与众智影非合非离。不聚集故不散失故

又如圆镜周莹。其面于一切处。为诸影像遍起依缘。如是如来大圆镜智。不断无量众行善莹。为诸智影遍起依缘。谓声闻乘诸智影像。独一觉乘诸智影像。无上大乘诸智影像。为欲令诸声闻乘人依声闻乘而出离故。独一觉人依独觉乘而出离故。大乘之人依无上乘而出离故

如圆镜中大影可得。所谓大地大山大树大宫舍影。而是圆镜不等彼量。如是如来圆镜智上。从极喜地乃至佛地。智影可得。及与一切世出世法。智影可得。而圆镜智非彼分量

又如圆镜非处障质影像起缘。如是如来大圆镜智。非恶友摄闻不正法。障碍众生智影起缘。彼非器故

又如圆镜非处闇质影像起缘。如是如来大圆镜智。非处乐恶愚暗众生智影起缘。彼非器故

又如圆镜非处远质影像起缘。如是如来大圆镜智。非处不净感匮法业。不信众生智影起缘。彼非器故

复次妙生。平等性智者。由十种相圆满成就。证得诸相增上喜爱。平等法性圆满成故。证得一切领受缘起。平等法性圆满成故。证得远离异相非相。平等法性圆满成故。弘济大慈。平等法性圆满成故。无待大悲。平等法性圆满成故。随诸众生所乐示现。平等法性圆满成故。一切众生敬受所说。平等法性圆满成故。世间寂静皆同一味。平等法性圆满成故。世间诸法苦乐一味。平等法性圆满成故。修殖无量功德究竟。平等法性圆满成故

复次妙生。妙观察智者。譬如世界持众生界。如是如来妙观察智。任持一切陀罗尼门三摩地门。无碍辩说诸佛妙法

又如世界是诸众生。顿起一切种种无量相识因缘。如是如来妙观察智。能为顿起一切所知。无碍妙智种种无量相识因缘

又如世界种种可玩。园林池等之所庄严。甚可爱乐。如是如来妙观察智。种种可玩波罗蜜多菩提分法。十力无畏不共佛法之所庄严。甚可爱乐。又如世界洲渚。日月四天王天。三十三天及夜摩天。睹史多天乐变化天。他化自在梵身天等。妙饰间列。如是如来妙观察智。世及出世衰盛因果。声闻独觉菩萨圆证。无余观察妙饰间列

又如世界为诸众生广大受用。如是如来妙观察智。示现一切诸佛众会。雨大法雨为令众生受大法乐

如世界中五趣可得。所谓地狱饿鬼畜生人趣天趣。如是如来观察智上。无边因果五趣差别具足显现

如世界中欲色无色诸界可得。如是如来观察智上。无边因果三界差别具足显现

如世界中苏迷卢等。大宝山王显现可得。如是如来观察智上。诸佛菩萨威神所引。广大甚深教法可得

如世界中广大甚深。不可倾动大海可得。如是如来观察智上。一切天魔外道异论。所不倾动。甚深法界教法可得

又如世界大小轮山之所围绕。如是如来妙观察智不愚一切自相共相之所围绕

复次妙生。成所作智者。如诸众生勤励身业。由是众生趣求种种殉利务农勤工等事。如是如来成所作智勤身化业。由是如来示现种种工巧等处摧伏诸伎傲慢众生以是善巧方便力故。引诸众生令入圣教成熟解脱又如众生受用身业。由是众生受用种种色等境界。如是如来成所作智受身化业。由是如来往诸众生种种生处。示同类生而居尊位。由其示现同类生故。摄伏一切异类众生。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生领受身业。由是众生领受所作善恶业果。如是如来成所作智领身化业。由是如来示现领受。本事本生难修诸行。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生庆慰语业。由是众生展转谈论递相庆慰。如是如来成所作智庆语化业。由是如来宣畅种种随所乐法文义巧妙。小智众生初闻尚信。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生方便语业。由是众生展转指授。务专所作毁恶赞善更相召命。如是如来成所作智。所起方便语变化业。由是如来立正学处。毁诸放逸赞不放逸。又复建立随信行人随法行等。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生辩扬语业。由是众生展转开示。所不了义宣讽诸论。如是如来成所作智。辩语化业。由是如来断诸众生无量疑惑。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生决择意业。由是众生决择可作及不可作。如是如来成所作智决意化业。由是如来决择众生八万四千心行差别。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生造作意业。由是众生造作种种诸所起业。如是如来成所作智造意化业。由是如来观诸众生所行之行。行与不行。若得若失为令取舍。造作对治。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生发起意业。由是众生发起诸业。如是如来成所作智发意化业。由是如来为欲宣说彼对治故。显彼所乐名句字身。以是善巧方便力故。引诸众生令入圣教成熟解脱

又如众生受领意业。由是众生受领苦乐。如是如来成所作智受意化业。由是如来于定不定。反问置记为记别故。随其所应受领去来现在等义。以是善巧方便力故。引诸众生令入圣教成熟解脱

尔时妙生菩萨摩诃萨白佛言。世尊。为独如来于净法界。受用和合一味事智。而诸菩萨亦能如是。佛告妙生菩萨。亦能受用和合一味事智

妙生菩萨复白佛言。何等菩萨受用和合一味事智。佛告妙生。证得无生法忍菩萨。由彼菩萨无生法中。得忍解时对治二想。由遣自他二种想故得平等心。从此已上。彼诸菩萨自他异想不复现前。受用和合一味事智。妙生菩萨复白佛言。唯愿如来广说譬喻。令诸菩萨悟甚深义。随所化缘广宣流布。令诸众生闻已疾悟无生法忍。佛告妙生。譬如三十三天未入杂林终不能于若事若受无我我所和合受用。若入杂林即无分别随意受用。由此杂林有如是德。能令诸天入此林者。天诸果报若事若受。无所思惟和合受用。如是菩萨若未证得无生法忍。终不能得平等之心平等之舍。乃与一切声闻独觉无有差别。有二想故。彼不能住受用和合一味事智。若已证得无生法忍。遣二想故得平等心。遂与声闻独觉差别。由平等心而能住舍。受用和合一味事智。复次妙生。譬如种种大小众流。未入大海各别所依。异水少水水有增减。随其水业所作各异。少分依持水族生命。若入大海无别所依。水无差别水无限量。水无增减所作业一。广大依持水族生命。如是菩萨。若未证入如来清净法界大海。各别所依异智少智智有增减。随其智业所作各异。少分众生成熟善根之所依止。若已证入如来清净法界大海。无别所依智无差别。智无限量智无增减。受用和合一味事智。无量众生成熟善根之所依止。尔时世尊而说颂曰

  一切法真如　　二障清净相
  法智彼所缘　　自在无尽相
  普遍真如智　　修习证圆满
  安立众生二　　诸种无尽果
  身语及心化　　善化方便业
  定及总持门　　无边二成就
  自性法受用　　变化差别转
  如是净法界　　诸佛之所说

时薄伽梵说是经已。妙生菩萨摩诃萨等诸大声闻。世间天人阿素洛等。一切大众闻佛所说。皆大欢喜信受奉行佛说佛地经


佛说佛名经a

    No. 440

佛说佛名经卷第一

        三藏菩提流支在胡相国秦太上文宣公第译

如是我闻。一时佛在舍婆提城祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊四众围绕。及天龙夜叉乾闼婆．阿修罗．迦楼罗．紧那罗．摩睺罗伽．人非人等。尔时世尊告诸大众。汝当谛听。我为汝说。过去未来现在诸佛名字。若善男子善女人。受持读诵诸佛名者。是人现世安隐远离诸难。及消灭诸罪。未来当得阿耨多罗三藐三菩提。若善男子善女人。欲消灭诸罪。当净洗浴着新净衣。长跪合掌。而作是言

南无东方阿閦佛　南无火光佛　南无灵目佛　南无无畏佛　南无不可思议佛　南无灯王佛　南无放光佛　南无光明庄严佛　南无大胜佛　南无成就大事佛　南无实见佛　南无坚王花佛

归命东方如是等无量无边诸佛

南无南方普满佛　南无威王佛　南无住持疾行佛　南无黠慧佛　南无称声佛　南无不厌见身佛　南无师子声佛　南无不空见佛　南无起行佛　南无一切行清净佛　南无庄严王佛　南无大山王佛

归命南方如是等无量无边诸佛

南无西方无量寿佛　南无师子佛　南无香积王佛　南无香手佛　南无奋迅佛　南无虚空藏佛　南无宝幢佛　南无清净眼佛　南无乐庄严佛　南无宝山佛　南无光王佛　南无月出光佛

归命西方如是等无量无边佛

南无北方难胜佛　南无月光佛　南无栴檀佛　南无自在佛　南无金色王佛　南无月色栴檀佛　南无普眼见佛　南无普照眼见佛　南无轮手佛　南无无垢佛

归命北方如是等无量无边佛

南无东南方治地佛　南无自在佛　南无法自在佛　南无法慧佛　南无法思佛　南无常法慧佛　南无常乐佛　南无善思惟佛　南无善住佛　南无善臂佛

归命东南方如是等无量无边佛

南无西南方那罗延佛　南无龙王德佛　南无宝声佛　南无地自在佛　南无人王佛　南无妙声佛　南无黠慧佛　南无妙香华佛　南无天王佛　南无常清净眼佛

归命西南方如是等无量无边佛

南无西北方月光面佛　南无月光佛　南无月幢佛　南无勇猛佛　南无日光面佛　南无日藏佛　南无日光庄严佛　南无花身佛　南无波头摩藏佛　南无波头摩须佛　南无师子声王佛　南无善住意佛

归命西北方如是等无量无边佛

南无东北方寂诸根佛　南无寂灭佛　南无大将佛　南无净胜佛　南无净妙声佛　南无净天供养佛　南无善化佛　南无化佛　南无善意佛　南无善意住持佛

归命东北方如是等无量无边佛

南无下方实行佛　南无疾行佛　南无黠慧佛　南无坚固王佛　南无金刚齐佛　南无师子佛　南无奋迅佛　南无如实住佛　南无成功德佛　南无功德得佛　南无善安乐佛　南无天金刚佛

归命下方如是等无量无边佛

南无上方无量胜佛　南无云王佛　南无云功德佛　南无无量称名佛　南无闻身王佛　南无大功德佛　南无大须弥佛　南无降伏魔王佛

归命上方如是等无量无边佛

南无未来普贤佛　南无弥勒佛　南无观世自在佛　南无得大势至佛　南无虚空藏佛　南无无垢称佛　南无成就义佛　南无实声佛　南无大海佛　南无无尽意佛

归命未来如是等无量无边佛

善男子善女人。受持读诵是诸佛名。现世安隐远离诸难。及消灭诸罪。未来毕竟得阿耨多罗三藐三菩提

南无无垢光佛　南无乐庄严思惟佛　南无无垢月幢称佛　南无华光佛　南无火光佛　南无宝上佛　南无无畏观佛　南无远离诸畏惊怖佛　南无师子奋迅力佛　南无金光明王佛

若善男子善女人。十日读诵思惟是佛名。必远离一切业障

南无一切同名佛。所谓。南无日龙奋迅二佛

南无一切同名日龙奋迅佛　南无六十功德宝佛　南无一切同名功德宝佛　南无六十二毗留罗佛　南无一切同名毗留罗佛　南无八万四千名自在幢佛　南无一切同名自在幢佛　南无三百大幢佛　南无一切同名大幢佛　南无五百净声王佛　南无一切同名净声王佛　南无五百波头摩王佛　南无一切同名波头摩王佛　南无五百日声佛　南无一切同名日声佛　南无五百乐自在声佛　南无一切同名乐自在声佛　南无五百日佛　南无一切同名日佛　南无五百普光佛　南无一切同名普光佛　南无五百波头摩上王佛　南无一切同名波头摩上王佛　南无七百法光庄严佛　南无一切同名法光庄严佛　南无千法庄严王佛　南无一切同名法庄严王佛　南无千八百称声王佛　南无一切同名称声王佛　南无三万散花佛　南无一切同名散花佛　南无三万三百称声王佛　南无一切同名称声王佛　南无八万四千阿难陀佛　南无一切同名阿难陀佛　南无千八百寂灭佛　南无一切同名寂灭佛　南无五百欢喜佛　南无一切同名欢喜佛　南无五百威德佛　南无一切同名威德佛　南无五百上威德佛　南无一切同名上威德佛　南无五百日王佛　南无一切同名日王佛　南无千云雷声王佛　南无一切同名云雷声王佛　南无千日炽自在声佛　南无一切同名日炽自在声佛　南无千离垢声自在王佛　南无一切同名离垢声自在王佛　南无千势自在声佛　南无一切同名势自在声佛　南无千功德盖幢安隐自在王佛　南无一切同名功德盖幢安隐自在王佛　南无千阎浮檀佛　南无一切同名阎浮檀佛　南无千无垢声自在王佛　南无一切同名无垢声自在王佛　南无千远离诸怖声自在王佛　南无一切同名远离诸怖声自在王佛　南无二千驹邻佛　南无一切同名驹邻佛　南无二千宝幢佛　南无一切同名宝幢佛　南无八千坚精进佛　南无一切同名坚精进佛　南无八千威德佛　南无一切同名威德佛　南无八千然灯佛　南无一切同名然灯佛　南无十千迦叶佛　南无一切同名迦叶佛　南无十千清净面莲华香积佛　南无一切同名清净面莲华香积佛　南无十千庄严王佛　南无一切同名庄严王佛　南无十千星宿佛　南无一切同名星宿佛　南无一万八千莎罗王佛　南无一切同名莎罗王佛　南无一万八千莎罗自在王佛　南无一切同名莎罗自在王佛　南无一万八千普护佛　南无一切同名普护佛　南无四万愿庄严佛　南无一切同名愿庄严佛　南无三千毗卢舍那佛　南无一切同名毗卢舍那佛　南无三千放光佛　南无一切同名放光佛　南无三千释迦牟尼佛　南无一切同名释迦牟尼佛　南无三万日月太白佛　南无一切同名日月太白佛　南无六万波头摩上王佛　南无一切同名波头摩上王佛　南无六万能令众生离诸见佛　南无一切同名能令众生离诸见佛　南无六十百千万成就义见佛　南无一切同名成就义见佛　南无无量百千万名不可胜佛　南无一切同名不可胜佛　南无二亿拘邻佛　南无一切同名拘邻佛　南无三亿弗沙佛　南无一切同名弗沙佛　南无六十亿大庄严佛　南无一切同名大庄严佛　南无八十亿实体法决定佛　南无一切同名实体法决定佛　南无六十亿莎罗自在王佛　南无一切同名莎罗自在王佛　南无十八亿实体法决定佛　南无一切同名实体法决定佛　南无十八亿日月灯明佛　南无一切同名日月灯明佛　南无百亿决定光明佛　南无一切同名决定光明佛　南无二十亿日月灯明佛　南无一切同名日月灯明佛　南无二十亿妙声王佛　南无一切同名妙声王佛　南无二十百亿云自在王佛　南无一切同名云自在王佛　南无三十亿释迦牟尼佛　南无一切同名释迦牟尼佛　南无二十亿千怖畏声王佛　南无一切同名怖畏声王佛　南无四十亿那由他妙声佛　南无一切同名妙声佛　南无亿千乐庄严佛　南无一切同名乐庄严佛　南无亿那由他百千觉花佛　南无一切同名觉花佛　南无六十频婆罗远离诸怖畏佛　南无一切同名远离诸怖畏佛　南无须弥山微尘数一切功德山王胜名佛　南无一切同名功德山王胜名佛　南无十佛国土不可说亿那由他微尘数普贤佛　南无一切同名普贤佛　南无过去未来现在诸佛　南无栴檀远离诸烦恼藏佛　南无功德奋迅佛　南无胜奋迅佛　南无修寂静佛　南无上寂静佛　南无住虚空佛　南无降伏诸魔怨佛　南无百宝佛　南无难胜光佛　南无自在作佛　南无日作佛　南无无垢光佛　南无自在观佛　南无金光明师子奋迅佛　南无无垢威德佛　南无观自在佛　南无金光普曜佛　南无金光明师子奋迅佛　南无无量光佛　南无释迦牟尼佛　南无静去佛　南无寂静上佛　南无普光明积上功德王佛　南无普现见佛　南无金刚功德佛　南无不动佛　南无普贤佛　南无普照佛　南无实法上决定佛　南无无畏王佛　南无无垢王佛　南无乐说庄严思惟佛　南无无垢月幢称佛　南无拘苏摩庄严光明作佛　南无出火佛　南无宝上佛　南无无畏观佛　南无师子奋迅力佛　南无远离怖畏毛竖称佛　南无金刚牟尼佛　南无饮甘露佛　南无金刚光王佛　南无善见佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无难胜佛　南无阿閦佛　南无卢舍佛　南无阿弥陀佛　南无尼弥佛　南无宝光炎佛　南无弥留佛　南无自在佛　南无宝精进月光庄严威德声自在王佛　南无远离一切诸畏烦恼上功德佛　南无初发心念断疑发解断烦恼佛　南无断诸烦恼闇三昧上王佛　南无金刚坚强消伏坏散佛　南无宝炎佛　南无大炎积佛　南无栴檀佛　南无手上王佛　南无宝上佛　南无善住智慧王无障佛　南无火光慧灭昏闇佛　南无象增上佛　南无截金刚佛　南无天王佛　南无一切义上王佛　南无三昧喻佛　南无念王佛　南无光明观佛　南无一切所依王佛　南无善护幢王佛　南无发趣速自在王佛　南无宝炎佛　南无积大炎佛　南无栴檀香佛　南无手上王佛　南无宝上佛　南无善住慧王无障佛　南无大智意佛　南无宝藏佛　南无放炎佛　南无迦叶佛　南无多罗住佛　南无智来佛　南无能圣佛　南无过一切忧恼王佛　南无一切功德庄严佛　南无成就一切义佛　南无无畏王佛　南无一切众生导师佛　南无不动光观自在无量命尼弥宝炎弥留金刚佛　南无火奋迅通佛　南无善寂慧月声自在王佛　南无清净月轮佛　南无住阿僧祇精进功德佛　南无无尽意佛　南无宝幢佛　南无光明无垢藏佛　南无火奋迅通佛　南无云普护佛　南无师子奋迅通佛　南无弥留上王佛　南无智慧来佛　南无护妙法幢佛　南无金光明师子奋迅王佛　南无普照积上功德王佛　南无善住如意积王佛　南无普现佛　南无释迦牟尼佛　南无无量光佛　南无放炎佛　南无栴檀香佛　南无无垢慧深声王佛　南无断一切障佛　南无无量光明佛　南无作功德佛　南无普香上佛　南无不可胜奋迅声王佛　南无降伏憍慢佛　南无毗婆尸佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含牟尼佛　南无迦叶佛　南无释迦牟尼佛　南无成就一切义佛　南无能作无畏佛　南无寂静王佛　南无阿閦佛　南无卢至佛　南无阿弥多佛　南无尼弥佛　南无住法佛　南无宝炎佛　南无弥留佛　南无金刚佛　南无持法佛　南无勇猛法佛　南无妙法光明佛　南无法月面佛　南无安住法佛　南无法幢佛　南无法威德佛　南无法自在佛　南无善住法佛　南无法寂佛　南无善智力佛　南无弥勒等无量佛　南无毗婆尸佛南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含牟尼佛　南无迦叶佛　南无释迦牟尼佛　南无阿弥陀佛　南无照佛　南无胜色佛　南无乐意佛　南无大导师佛　南无大圣天佛　南无那罗延佛　南无树提佛　南无慈他佛　南无毗卢遮那佛　南无栴檀佛　南无具足佛　南无化现佛　南无善化佛　南无世自在佛　南无人自在佛　南无摩醯那自在佛　南无胜自在佛　南无十力自在佛　南无毗头罗佛　南无离诸畏佛　南无离诸忧佛　南无能破诸邪佛　南无散诸邪佛　南无破异意佛　南无智慧岳佛　南无宝岳佛　南无弥留岳佛　南无降魔佛　南无善才佛　南无坚才佛　南无坚奋迅佛　南无坚精进佛　南无坚莎罗佛　南无坚心佛　南无勇猛破障佛　南无破诤佛　南无实体佛　南无昙无竭佛　南无尼尸陀佛　南无波罗罗坚佛　南无普光佛　南无普贤佛　南无胜海佛　南无功德海佛　南无法海佛　南无虚空寂佛　南无虚空功德佛　南无虚空库藏佛　南无虚空心佛　南无虚空多罗佛　南无无垢心佛　南无功德林佛

南无放光世界中现在说法。虚空胜离尘无垢尘平等眼清净功德幢光明花波头摩琉璃光宝香象身胜妙罗网庄严顶无量日月光明照庄严愿上庄严法界善化无障碍王佛

彼佛世界中。有菩萨名无比。彼佛授记。不久得阿耨多罗三藐三菩提。号种种光花宝波头摩金色身普照庄严不住眼放光照十方世界幢王佛

若有善男子善女人。信心受持读诵彼佛及菩萨名。是善男子善女人。超越阎浮提微尘数劫得陀罗尼。一切诸恶病。不及其身

南无无量功德宝集乐示现金光明师子奋迅王佛　南无师子奋迅心云声王佛　南无无垢清净光明觉宝花不断光庄严王佛　南无宝光月庄严智力德声自在王佛　南无宝波头摩智清净上王佛　南无摩善住山王佛　南无光华种种奋迅王佛　南无拘苏摩奋迅王佛　南无波头摩华上弥留幢王佛　南无法幢空俱苏摩王佛　南无莎罗华上光王佛　南无无垢眼上光王佛　南无无垢意山上王佛　南无种种乐说庄严王佛　南无无碍药王成就胜王佛　南无千云雷声王佛　南无金光明师子奋迅王佛　南无善寂智慧月声自在王佛　南无善住摩尼山王佛　南无欢喜藏胜山王佛　南无普光上胜功德山王佛　南无功德藏增上山王佛　南无动山岳王佛　南无善住诸禅藏王佛　南无法海潮功德王佛　南无称功德山王佛　南无一切华香自在王佛　南无银幢盖王佛　南无电灯幢王佛　南无月摩尼光王佛　南无波头摩上星宿王佛　南无无量香上王佛　南无觉王佛　南无上弥留幢王佛　南无莎罗花上王佛　南无因陀罗幢王佛　南无师子奋迅王佛　南无俱苏摩生王佛　南无微细华佛　南无说义佛　南无无量精进佛　南无无边弥留佛　南无离垢佛　南无无量眼佛　南无无量发行佛　南无发行难胜佛　南无无所发行佛　南无无量发行佛　南无断诸难佛　南无不定愿佛　南无善住诸愿佛　南无无念示现诸行佛　南无无量善根成就诸行佛　南无无垢奋迅佛　南无不住奋迅佛　南无妙色佛　南无无相声佛　南无虚空星宿增上王佛　南无栴檀室佛　南无乐意佛　南无善行佛　南无境界自在佛　南无乐行佛　南无乐解脱佛　南无远离怖畏毛竖佛　南无清净眼佛　南无进寂静佛　南无世间可乐佛　南无随世间意佛　南无随世间眼佛　南无宝王佛　南无宝爱佛　南无罗睺罗佛　南无罗睺罗天佛　南无罗睺罗净佛　南无宝慧佛　南无宝鬘佛　南无宝形佛　南无罗网手佛　南无摩尼轮佛　南无解脱威德佛　南无善行佛　南无大爱佛　南无人面佛　南无吉佛　南无曼陀罗佛　南无净圣佛　南无净宿佛　南无离胎佛　南无虚空庄严佛　南无集功德佛　南无师子步佛　南无功德海佛　南无摩尼功德佛　南无广功德佛　南无称成佛　南无大如意轮佛　南无无畏上王佛　南无俱苏摩国土佛　南无功德幢佛　南无威德佛　南无华眼佛　南无喜身佛　南无慧国土佛　南无喜威德佛　南无波头池(丹本作陀)智慧奋迅佛　南无功德聚佛　南无寂灭慧佛　南无降魔佛　南无无上光佛　南无法自在佛　南无得世间功德佛　南无实谛称佛　南无智胜佛　南无智爱佛　南无得智佛　南无智幢佛　南无罗网光幢佛

若善男子善女人。与一切众生安隐乐如诸佛者。当读诵是诸佛名。复作是言

南无离诸无智曀佛　南无虚空平等心佛　南无清净无垢佛　南无善无垢藏佛　南无坚固行佛　南无精进声佛　南无不离一切众生门佛　南无断诸过佛　南无成就观佛　南无平等须弥面佛　南无无障无碍精进坚佛　南无莎罗花花王佛　南无无量功德王佛　南无弥留灯王佛　南无药王声声王佛　南无梵声王佛　南无妙鼓声王佛　南无云声王佛　南无龙自在王佛　南无世间自在王佛　南无陀罗尼自在王佛　南无深王佛　南无治诸病王佛　南无药王佛　南无象王佛　南无灯王佛　南无树提王佛　南无喜王佛　南无星宿王佛　南无云王佛　南无雷王佛　南无莎罗王佛　南无坚固自在王佛　南无功德聚佛　南无华聚佛　南无宝聚佛　南无宝住持庭燎佛　南无住持功德佛　南无住持无障力佛　南无住持地力进去佛　南无住持妙无垢位佛　南无一切宝庄严色住持佛　南无自在转一切法佛　南无转法轮佛　南无胜威德佛　南无净威德佛　南无圣威德佛　南无大威德佛　南无师子威德佛　南无莎罗威德佛　南无大悲威德佛　南无地持威德佛　南无无垢威德佛　南无无垢琉璃佛　南无无垢臂佛　南无无垢眼佛　南无无垢面佛　南无波头摩面佛　南无月面佛　南无日面佛　南无日威德庄严佛　南无金色佛　南无金色形佛　南无可乐色佛　南无瞻婆伽色佛　南无能与乐佛　南无能与眼佛　南无难胜佛　南无难降伏佛　南无断诸恶佛　南无难量佛　南无难成佛　南无俱苏摩成佛　南无甘露成佛　南无宝成就佛　南无功德成就佛　南无日成就佛　南无花成就佛　南无成就乐有佛　南无成就功德佛　南无大胜佛　南无妙佛　南无无垢佛　南无离诸障佛　南无婆楼那佛　南无婆楼那天佛　南无勇猛仙佛　南无精进仙佛　南无无垢仙佛　南无金刚仙佛　南无观眼佛　南无无障碍佛　南无住虚空佛　南无住清净佛　南无善住清净功德宝佛　南无善迹佛　南无善思义佛　南无善化佛　南无善爱佛　南无善眼佛　南无善亲佛　南无善行佛　南无善生佛　南无善花佛　南无善香佛　南无善声佛　南无善臂佛　南无善光佛　南无善山佛　南无功德山佛　南无宝山佛　南无智山佛　南无胜山佛　南无上山佛　南无光明庄严佛　南无大光明庄严佛　南无清净庄严佛　南无波头摩庄严佛　南无实中佛　南无金刚合佛　南无金刚齐佛　南无碎金刚佛　南无碎金刚坚佛　南无降伏魔佛　南无不空见佛　南无爱见佛　南无现见佛　南无善见佛　南无大善见佛　南无普见佛　南无无垢见佛　南无见平等不平等佛　南无见一切义佛　南无断一切障碍佛　南无断一切众生病佛　南无一切世间爱见佛　南无上妙佛　南无大庄严佛　南无一切三昧佛　南无度一切疑佛　南无度一切法佛　南无不取诸法佛　南无一切清净佛　南无一切义成就佛　南无一切通佛　南无花通佛　南无波头摩树提奋迅(丹乡有通)佛　南无俱苏摩通佛　南无海住持胜智慧奋迅通佛　南无多摩罗叶栴檀香通佛　南无常观佛　南无常围绕佛　南无常不轻佛　南无常忧佛　南无常喜佛　南无常笑欢喜根佛　南无常满足手佛　南无常举手佛　南无常黠慧佛　南无常修行佛　南无常精进佛　南无尼拘律佛　南无阿叔迦佛　南无金色佛　南无华开佛　南无善决定佛　南无波头摩光佛　南无华身佛　南无手脚柔软触身佛　南无日轮佛　南无闇(丹本作闻)满足佛　南无相身身佛　南无胜威德佛　南无无垢身佛　南无波头摩花身佛　南无得无碍佛　南无得愿满足佛　南无得普照清净佛　南无得大无畏佛　南无至大佛　南无至大精进究竟佛　南无大境界佛　南无大海佛　南无大乐说佛　南无大药王佛　南无大功德佛　南无无量香佛　南无无量精进佛　南无无量行佛　南无无量功德佛　南无宝生佛　南无无边功德宝作佛　南无法作佛　南无金色作佛　南无胜作佛　南无自在作佛　南无日作佛　南无光作佛　南无火作佛　南无无畏作佛　南无乐作佛　南无灯作佛　南无贤作佛　南无觉作佛　南无花作佛　南无华胜藏佛　南无俱苏摩胜藏佛　南无忧波罗胜藏佛　南无波头摩胜藏佛　南无功德胜藏佛　南无快胜藏佛　南无福德胜藏佛　南无天胜藏佛　南无香胜藏佛　南无大云藏佛　南无那罗延藏佛　南无如来藏佛　南无功德藏佛　南无根藏佛　南无如意藏佛　南无金刚藏佛　南无得藏佛　南无势罗藏佛　南无山藏佛　南无波头摩藏佛　南无俱苏摩藏佛　南无香藏佛　南无摩尼藏佛　南无贤藏佛　南无普藏佛　南无月无垢藏佛　南无日藏佛　南无照藏佛　南无光明幢佛　南无月幢佛　南无功德幢佛　南无离世间幢佛　南无华幢佛　南无宝幢佛　南无法幢佛　南无自在幢佛　南无宝幢佛　南无无垢幢佛　南无大幢佛　南无月无垢幢佛　南无普照幢佛　南无弥留幢佛　南无护妙法幢佛　南无放光明幢佛　南无善清净无垢照幢佛　南无善清净光明幢佛　南无善清净无垢光明(丹作照)幢佛　南无香光明佛　南无虚空光明佛　南无大光明光明佛　南无宝光明佛　南无火光明佛　南无日光明佛　南无月光明佛　南无日月光明佛　南无无垢光明佛　南无火轮光明佛　南无宝照佛　南无宝光明佛　南无胜威德香光明佛　南无种种多威德王胜光明佛　南无虚空清净金色庄严威德光明佛　南无一切法幻奋迅威德光明佛　南无清净光明佛　南无功德宝光明佛　南无金光光明佛　南无高光明佛　南无放光光明佛　南无俱苏摩光明佛　南无香光明佛　南无甘露光明佛　南无无量宝花光明佛　南无水月光明佛　南无宝月光明佛　南无弥留光明佛　南无聚集日轮佛　南无云光明佛　南无般头耆婆伽花佛　南无无畏光明佛　南无法力光明佛　南无无垢光明佛　南无清净光明佛　南无月光明佛　南无日光明佛　南无树提光明佛　南无灯火光明佛　南无焚烧光明佛　南无罗网光明佛　南无大光明佛　南无称光明佛　南无普光明佛　南无无边光明佛　南无色光明声佛　南无虚空声佛　南无妙鼓声佛　南无师子声佛　南无云声佛　南无天声佛　南无妙声佛　南无梵声佛　南无云妙鼓声佛　南无法鼓声佛　南无法鼓出声佛　南无声满法界声佛　南无地吼声佛　南无普遍声佛　南无师子吼声佛　南无无量吼声佛　南无无分别吼声佛　南无惊怖一切魔轮声佛　南无降伏一切声声佛　南无无障碍月慧佛　南无法无垢月佛　南无普照月佛　南无放光明月佛　南无卢舍那月佛　南无解脱月佛　南无称月佛　南无功德月佛　南无宝月佛　南无满月佛　南无天月佛　南无月轮清净佛　南无日月佛　南无月慧佛　南无无垢慧佛　南无深慧佛　南无戒慧佛　南无难胜慧佛　南无阿僧祇劫修习慧佛　南无无量乐功德庄严行慧佛　南无无量功德庄严佛　南无胜功德王庄严威德王劫佛　南无离劫佛　南无自在灭劫佛　南无弥留劫佛　南无须弥留劫佛　南无不可说劫佛　南无金光明色光上佛　南无龙象上佛　南无爱上佛　南无度上佛　南无法上佛　南无金刚上佛　南无威德上佛　南无无垢上佛　南无龙寂上佛　南无宝上佛　南无胜宝上佛　南无莎梨罗上佛　南无天上佛　南无波头摩上佛　南无香上佛　南无放光佛　南无乐香佛　南无香奋迅佛　南无香象奋迅佛　南无香象佛　南无大香象佛　南无多罗跋香佛　南无戒香佛　南无无边香佛　南无普遍香佛　南无薰香佛　南无多伽罗香佛　南无栴檀香佛　南无曼陀罗香佛　南无波头摩香佛　南无波头摩手佛　南无波头摩眼佛　南无波头摩庄严佛　南无波头摩起佛　南无波头摩胜佛　南无月胜佛　南无身胜佛　南无惊怖胜佛　南无鬘胜云佛　南无功德成就云佛　南无宝云佛　南无功德云佛　南无云护佛　南无普护佛　南无圣护佛　南无功德护佛　南无普遍护佛　南无精进护佛　南无精进喜佛　南无上喜佛　南无实喜佛　南无师子喜佛　南无龙喜佛　南无宝喜佛　南无实智佛　南无喜去佛　南无善知寂静去佛　南无大势佛　南无甘露势佛　南无金刚杵势佛　南无无垢处势佛　南无不动处势佛　南无过三界势佛　南无三昧处势佛　南无定处势佛　南无不动处势佛　南无高去佛　南无寂灭去佛　南无师子奋迅去佛　南无善步去佛　南无无尽慧佛　南无海慧佛　南无住慧佛　南无胜慧佛　南无灭诸恶慧佛　南无寂静慧佛　南无修行慧佛　南无密慧佛　南无坚慧佛　南无善清净慧佛　南无大慧佛　南无普慧佛　南无无边慧佛　南无威德慧佛　南无世慧佛　南无上慧佛　南无妙慧佛　南无快慧佛　南无无观慧佛　南无称慧佛　南无广慧佛　南无栴檀满慧佛　南无金刚慧佛　南无清净慧佛　南无觉慧佛　南无法慧佛　南无师子慧佛　南无虎慧佛　南无善慧佛　南无宝慧佛　南无胜慧佛　南无胜积慧佛　南无勇猛积佛　南无般若积佛　南无乐说积佛　南无香积佛　南无宝积佛　南无宝髻佛　南无龙髻佛　南无功德髻佛　南无天髻佛　南无大髻佛　南无弥留聚佛　南无大聚佛　南无大炎聚佛　南无宝聚佛　南无宝手佛　南无宝手柔软佛　南无宝印手佛　南无宝光明奋迅思惟佛　南无宝火围绕佛　南无宝天佛　南无宝胜佛　南无宝高佛　南无宝坚佛　南无宝波头摩佛　南无宝念佛　南无宝力佛　南无宝山佛　南无宝炎佛　南无宝火围绕佛　南无宝照佛　南无放照佛　南无迭共花佛　南无妙说佛　南无月说佛　南无金刚说佛　南无宝说佛　南无宝杖佛　南无无量宝杖佛

佛说佛名经卷第一佛说佛名经卷第二

        后魏北印度三藏菩提流支译

南无无垢杖佛　南无无边杖佛　南无法杖佛　南无宝盖佛　南无均宝盖佛　南无摩尼盖佛　南无金盖佛　南无奋迅王佛　南无增上火成就王佛　南无增上勇猛佛　南无勇施佛　南无智施佛　南无然灯佛　南无然灯火佛　南无净然灯佛　南无功德然灯佛　南无福德然灯佛　南无宝然灯佛　南无大然灯佛　南无无边然灯佛　南无宝火然灯佛　南无普然灯佛　南无月然灯佛　南无日然灯佛　南无日月然灯佛　南无云声然灯佛　南无大海然灯佛　南无忍辱轮然灯佛　南无世然灯佛　南无光明遍照十方然灯佛　南无照诸趣然灯佛　南无破诸闇然灯佛　南无一切世成就然灯佛　南无谛宝幢摩尼胜光佛　南无净华宿王智佛　南无俱苏摩见佛　南无不散佛　南无散华佛　南无不散华佛　南无放光明佛　南无千光明佛　南无六十光明佛　南无观光明佛　南无无障碍光明佛　南无放净光明佛　南无无边光明佛　南无波头摩光明佛　南无福德光明佛　南无智光明佛　南无月光明佛　南无日光明佛　南无无碍光明佛　南无奋迅恭敬称佛　南无无比佛　南无功德称佛　南无宝称佛　南无无垢称佛　南无无垢德佛　南无坚德佛　南无无忧德佛　南无勇猛德佛　南无华德佛　南无欢喜德佛　南无龙德佛　南无功德海佛　南无净德佛　南无净天佛　南无供养佛　南无净声佛　南无净妙声佛　南无出净声佛　南无普智轮光声佛　南无大声佛　南无云胜声佛　南无安隐声佛　南无乐声佛　南无妙鼓声佛　南无天声佛　南无月声佛　南无日声佛　南无师子声佛　南无波头摩声佛　南无福德声佛　南无金刚声佛　南无自在声佛　南无慧声佛　南无妙声佛　南无选择声佛　南无甘露声佛　南无净幢佛　南无金刚幢佛　南无法幢佛　南无住持法佛　南无乐法佛　南无昙无竭佛　南无护法佛　南无法奋迅佛　南无法界花佛　南无护法眼佛　南无然法庭燎佛　南无法自在佛　南无人自在佛　南无功德自在佛　南无声自在佛　南无世自在佛　南无观世自在佛　南无无量自在佛　南无意住持佛　南无地住持佛　南无尼弥住持佛　南无器住持佛　南无功德性住持佛　南无胜色佛　南无转发起佛　南无一切观形示佛　南无发一切无厌足行佛　南无发成就佛　南无善护佛　南无善思惟佛　南无善喜佛　南无善处佛　南无普禅佛　南无甘露功德佛　南无善眼佛　南无师子仙佛　南无佛眼佛　南无合聚佛　南无疾智勇佛　南无善住佛　南无实行佛　南无师子手佛　南无海满佛　南无善思惟佛　南无称王佛　南无住慈佛　南无善夜摩佛　南无善行佛　南无善功德佛　南无善色佛　南无善识佛　南无善心佛　南无善光佛　南无师子月佛　南无不可胜佛　南无不可胜无畏佛　南无无量佛　南无速兴佛　南无不动心佛　南无应称佛　南无应不怯弱声佛　南无不厌足藏佛　南无不尽佛　南无不可动佛　南无名无畏佛　南无名自在护世间佛　南无名龙自在声佛　南无名法行广慧佛　南无名妙胜自在相通称佛　南无名妙胜自在胜佛　南无名乐法奋迅佛　南无名法界庄严佛　南无名大乘庄严佛　南无名寂静王佛　南无名解脱行佛　南无名大海弥留起王佛　南无名合聚那罗延王佛　南无名散坏坚魔轮佛　南无名精进根宝王佛　南无名佛法波头摩佛　南无名得佛眼分陀利佛　南无名随前觉觉佛　南无名平等作佛　南无名初发心念远离一切惊怖无烦恼起功德佛　南无名教化菩萨佛　南无名金刚釜奋迅佛　南无名宝像光明釜奋迅佛　南无名破坏魔轮佛　南无名初发心成就不退胜轮佛　南无名宝盖起无畏光明佛　南无名初发心念断疑断烦恼佛　南无名光明破闇起三昧王佛

善男子善女人。若有得闻是诸佛名者。永离业障不堕恶道。若无眼者。诵必得眼

南无十千同名星宿佛　南无一切同名星宿佛　南无三十千同名释迦牟尼佛　南无一切同名释迦牟尼佛　南无二亿同名拘邻佛　南无一切同名拘邻佛　南无十八亿同名实法胜决定佛　南无一切同名实法胜决定佛　南无十八亿同名日月灯佛　南无一切同名日月灯佛　南无千五百同名大威德佛　南无一切同名大威德佛　南无千五百同名日佛　南无一切同名日佛　南无四万四千同名面佛　南无一切同名面佛　南无万千同名坚固自在佛　南无一切同名坚固自在佛　南无万八千同名普护佛　南无一切同名普护佛　南无千八百同名舍摩他佛　南无一切同名舍摩他佛

劫名善眼。彼劫中有七十二那由他如来成佛。我悉归命彼诸如来

劫名善见。彼劫中有七十二亿如来成佛。我悉归命彼诸如来

劫名净赞叹。彼劫中有一万八千如来成佛。我悉归命彼诸如来

劫名善行。彼劫中有三万二千如来成佛。我悉归命彼诸如来

劫名庄严。彼劫中有八万四千如来成佛。我悉归命彼诸如来

南无现在住十方世界。不舍命说法诸佛。所谓安乐世界中阿弥陀佛为上首

南无妙乐世界中。阿閦如来为上首

南无袈裟幢世界中。碎金刚坚如来为上首

南无不退轮吼世界中。清净光波头摩花身如来为上首

南无无垢世界中。法幢如来为上首

南无善灯世界中。师子如来为上首

南无善住世界中。卢舍那藏如来为上首

南无难过世界中。功德华身如来为上首

南无庄严慧世界中。一切通光明佛为上首

南无镜轮光明世界中。月智慧佛为上首

南无花胜世界中。波头摩胜如来为上首

南无波头摩胜世界中。贤胜如来为上首

南无不瞬世界中。普贤如来为上首

南无普贤世界中。自在王如来为上首

南无不可胜世界中。成就一切义如来为上首

南无华藏世界中。毗卢遮那镜像如来为上首

南无娑婆世界中。释迦牟尼佛为上首

南无善说胜佛为上首

南无自在幢王佛为上首

南无作火光佛为上首

南无无畏观佛为上首

如是等上首诸佛。我以身业口业意业。遍满十方一切礼拜赞叹供养。彼诸如来所说妙法甚深境界。不可量境界。不可思议境界。无量境界等。我悉以身口意业遍满十方。礼拜赞叹供养。彼佛世界中不退菩萨僧。不退声闻僧。我悉以身口意业遍满十方。头面礼足赞叹供养

南无名降伏魔人自在佛　南无名降伏贪自在佛　南无名降伏嗔自在佛　南无名降伏痴自在佛　南无名降伏怒自在佛　南无名降伏见自在佛　南无名降伏诸戏自在佛　南无名了达法自在佛　南无名得神通自在称佛　南无名得胜业自在称佛　南无名起施自在称佛　南无名起清净戒自在称佛　南无名起忍辱人自在称佛　南无名起精进人自在称佛　南无名起禅那人自在称佛　南无名福德清净光明自在称佛　南无名起陀罗尼自在称佛　南无高胜佛　南无光明胜佛　南无大胜佛　南无散香上胜佛　南无多宝胜佛　南无月上胜佛　南无贤上胜佛　南无波头摩上胜佛　南无无量上胜佛　南无波头摩上胜王佛　南无三昧手上胜佛　南无善说名胜佛　南无大海深胜佛　南无阿僧祇精进住胜佛　南无乐说一切法庄严胜佛　南无宝轮威德上胜佛　南无日轮上光明胜佛　南无无量惭愧金色上胜佛　南无功德海琉琉金山金色光明胜佛　南无宝华普照胜佛　南无起无边功德无垢胜佛　南无起多罗王胜佛　南无树王吼胜佛　南无法海潮胜佛　南无智清净功德胜佛　南无乐劫火胜佛　南无不可思议光明胜佛　南无宝月光明胜佛　南无宝贤幢胜佛　南无成就义胜佛　南无宝成就胜佛　南无宝集胜佛　南无奋迅胜佛　南无不空胜佛　南无闻胜佛　南无海胜佛　南无住持胜佛　南无善行胜佛　南无龙胜佛　南无波头摩胜佛　南无福德胜佛　南无智胜佛　南无妙胜佛　南无贤胜佛　南无胜贤胜佛　南无栴檀胜佛　南无胜栴檀胜佛　南无无量光明佛　南无幢胜佛　南无胜幢胜佛　南无无忧胜佛　南无离一切忧胜佛　南无宝杖如来　南无善宝杖佛　南无拘苏摩胜佛　南无华胜佛　南无三昧奋迅胜佛　南无树提胜佛　南无大胜佛　南无广功德胜佛　南无众胜佛

南无清净光世界积清净增长胜上王佛

南无普光世界普华无畏王如来

南无普盖世界名均宝庄严如来

彼如来授罗网光菩萨阿耨多罗三藐三菩提记

南无一宝髻世界名无量宝境界如来

彼如来授不空奋迅境界菩萨阿耨多罗三藐三菩提记

南无相威德王世界名无量声如来

彼如来授名即发心转法轮菩萨阿耨多罗三藐三菩提记

南无名称世界名须弥留聚集如来

彼如来授名光明轮胜威德菩萨阿耨多罗三藐三菩提记

南无善住世界名虚空寂如来

彼如来授名月光菩萨阿耨多罗三藐三菩提记

南无地轮世界名称力王如来

彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无月起光世界名放光明如来

彼如来授名光明轮菩萨阿耨多罗三藐三菩提记

南无袈裟幢世界名离袈裟如来

彼如来授名无量宝发起菩萨阿耨多罗三藐三菩提记

南无波头摩华世界名种种华胜成就如来

彼如来授名无量精进菩萨阿耨多罗三藐三菩提记

南无一盖世界名远离诸怖毛竖如来

彼如来授名罗网光明菩萨阿耨多罗三藐三菩提记

南无种种幢世界名须弥留聚如来

彼如来授名大胜菩萨阿耨多罗三藐三菩提记

南无普光世界名无障碍眼如来

彼如来授名智胜菩萨阿耨多罗三藐三菩提记

南无贤世界名栴檀屋如来

彼如来授名智功德幢菩萨阿耨多罗三藐三菩提记

南无贤慧世界名合聚如来

彼如来授名妙智菩萨阿耨多罗三藐三菩提记

南无宝首世界名罗网光明如来

彼如来授名智功德菩萨阿耨多罗三藐三菩提记

南无安乐首世界名宝莲花胜如来

彼如来授名波头摩胜功德菩萨阿耨多罗三藐三菩提记

南无称世界名智华宝光明胜如来

彼如来授名第一庄严菩萨阿耨多罗三藐三菩提记

南无贤臂世界名起贤光明如来

彼如来授名宝光明菩萨阿耨多罗三藐三菩提记

南无无畏世界名灭散一切怖畏如来

彼如来授名无畏菩萨阿耨多罗三藐三菩提记

南无弥留幢世界名弥留厚如来

彼如来授名合聚菩萨阿耨多罗三藐三菩提记

南无远离一切忧恼障碍世界名无畏王如来

彼如来授名多声菩萨阿耨多罗三藐三菩提记

南无法世界名作法如来

彼如来授名智作菩萨阿耨多罗三藐三菩提记

南无善住世界名百一十光明如来

彼如来授名胜光明菩萨阿耨多罗三藐三菩提记

南无共光明世界名千上光明如来

彼如来授名普光明菩萨阿耨多罗三藐三菩提记

南无多伽罗世界。名智光明如来

彼如来授名善眼菩萨阿耨多罗三藐三菩提记

南无香世界名宝胜光明如来

彼如来授名无量光明菩萨阿耨多罗三藐三菩提记

南无光明首世界名无量光明如来

彼如来授名药王菩萨阿耨多罗三藐三菩提记

南无上首贤世界名无障碍声如来

彼如来授名净声声菩萨阿耨多罗三藐三菩提记

南无法世界名罗网光明如来

彼如来授名胜菩萨阿耨多罗三藐三菩提记

南无贤入世界名宝智慧如来

彼如来授名智香菩萨阿耨多罗三藐三菩提记

南无优钵罗世界名无量胜如来

彼如来授名昙无竭菩萨阿耨多罗三藐三菩提记

南无清净世界名无量庄严如来

彼如来授名宝庄严菩萨阿耨多罗三藐三菩提记

南无觉住世界名优钵罗胜如来

彼如来授名波头摩胜菩萨阿耨多罗三藐三菩提记

南无波头摩住世界名智住如来

彼如来授名宝满足菩萨阿耨多罗三藐三菩提记

南无智力世界名释迦牟尼如来

彼如来授名宝牟尼菩萨阿耨多罗三藐三菩提记

南无十方称世界名智称如来

彼如来授名无边精进菩萨阿耨多罗三藐三菩提记

南无喜世界名坚自在王如来

彼如来授名宝坚菩萨阿耨多罗三藐三菩提记

南无月世界名宝娑罗如来

彼如来授名普香菩萨阿耨多罗三藐三菩提记

南无娑婆世界名大胜如来

彼如来授名大胜天王菩萨阿耨多罗三藐三菩提记

南无一盖世界名宝轮如来

彼如来授名星宿鬘菩萨阿耨多罗三藐三菩提记

南无过一切忧障碍世界名不空说如来

彼如来授名不空说菩萨阿耨多罗三藐三菩提记

南无远离忧恼世界名功德成就如来

彼如来授名无边胜威德菩萨阿耨多罗三藐三菩提记

南无寂静世界名称王如来

彼如来授名勇德菩萨阿耨多罗三藐三菩提记

南无不空见世界名不空奋迅如来

彼如来授名不空发行菩萨阿耨多罗三藐三菩提记

南无香世界名香光明如来

彼如来授名宝藏菩萨阿耨多罗三藐三菩提记

南无无量吼声世界名无障碍声如来

彼如来授名无分别发行菩萨阿耨多罗三藐三菩提记

南无月轮光明世界名称力王如来

彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无宝轮世界名宝上胜如来

彼如来授名大导师菩萨阿耨多罗三藐三菩提记

南无宝轮世界名善明(丹眼)如来

彼如来授名乐行菩萨阿耨多罗三藐三菩提记

南无法世界名波头摩胜如来

彼如来授名大法菩萨阿耨多罗三藐三菩提记

南无名须弥顶上王如来

彼如来授名智力菩萨阿耨多罗三藐三菩提记

南无名波头摩胜如来

彼如来授名胜德菩萨阿耨多罗三藐三菩提记

南无陀罗尼轮世界名香光明如来

彼如来授名陀罗尼自在王菩萨阿耨多罗三藐三菩提记

南无金光明世界名十方称发如来

彼如来授名智称发行菩萨阿耨多罗三藐三菩提记

南无智起世界名普清净增上云声王如来

彼如来授名星宿王菩萨阿耨多罗三藐三菩提记

南无常光明世界名无量光明如来

彼如来授名大光明菩萨阿耨多罗三藐三菩提记

南无然灯世界名无量智成就如来

彼如来授名功德王光明菩萨阿耨多罗三藐三菩提记

南无然灯作世界名无量种奋迅如来

彼如来授名无障碍发菩萨阿耨多罗三藐三菩提记

南无种种幢世界名上首如来

彼如来授名那罗延菩萨阿耨多罗三藐三菩提记

南无十方称世界名佛华成就胜如来

彼如来授名无缺奋迅菩萨阿耨多罗三藐三菩提记

南无金刚住世界名佛华增上王如来

彼如来授名宝火菩萨阿耨多罗三藐三菩提记

南无栴檀窟世界宝形如来

彼如来授名观世音菩萨阿耨多罗三藐三菩提记

南无药王世界名不空说如来

彼如来授名不空发行菩萨阿耨多罗三藐三菩提记

南无药王胜上世界名无边功德精进发如来

彼如来授名不受戒摄受菩萨阿耨多罗三藐三菩提记

南无普庄严世界名发心生庄严一切众生心如来

彼如来授名佛华手菩萨阿耨多罗三藐三菩提记

南无普盖世界名盖鬘如来

彼如来授名宝行菩萨阿耨多罗三藐三菩提记

南无华上光明世界名日轮威德王如来

彼如来授名善住菩萨阿耨多罗三藐三菩提记

南无善庄严世界名众王(丹生)光明如来

彼如来授名宝面菩萨阿耨多罗三藐三菩提记

南无贤世界名无畏如来

彼如来授名不惊怖菩萨阿耨多罗三藐三菩提记

南无波头摩世界名波头摩胜光明如来

彼如来授名智象菩萨阿耨多罗三藐三菩提记

南无优钵罗世界名智优钵胜如来

彼如来授名无境界行菩萨阿耨多罗三藐三菩提记

南无宝上世界名宝作如来

彼如来授名法作菩萨阿耨多罗三藐三菩提记

南无月世界名无量愿如来

彼如来授名散华菩萨阿耨多罗三藐三菩提记

南无善住世界名宝聚如来

彼如来授名药王菩萨阿耨多罗三藐三菩提记

南无香光明世界名莎罗自在王如来

彼如来授名胜慧菩萨阿耨多罗三藐三菩提记

南无华手世界名宝光明如来

彼如来授名日德菩萨阿耨多罗三藐三菩提记

南无普山世界名宝山如来

彼如来授名火德菩萨阿耨多罗三藐三菩提记

南无忧盖入世界名上首如来

彼如来授名上庄严菩萨阿耨多罗三藐三菩提记

南无无忧世界名发无边功德如来

彼如来授名不发观菩萨阿耨多罗三藐三菩提记

南无一切功德住世界名善上首如来。彼如来授名普至菩萨阿耨多罗三藐三菩提记

南无宝光明世界名须弥光明如来

彼如来授名善住菩萨阿耨多罗三藐三菩提记

南无一切功德住世界名无量境界如来

彼如来授名药王菩萨阿耨多罗三藐三菩提记

南无庄严菩提世界名高妙去如来

彼如来授名思益胜慧菩萨阿耨多罗三藐三菩提记

南无无垢世界名宝华成就功德如来

彼如来授名得胜慧菩萨阿耨多罗三藐三菩提记

南无云世界名奋迅如来

彼如来授名自在观菩萨阿耨多罗三藐三菩提记

南无华网覆世界名一切发众生信发心如来

彼如来授名胜慧菩萨阿耨多罗三藐三菩提记

南无星宿行世界名乐星宿起如来

彼如来授名无忧菩萨阿耨多罗三藐三菩提记

南无宝华世界名胜众如来

彼如来授名妙胜菩萨阿耨多罗三藐三菩提记

南无无量至世界名无量华如来

彼如来授名香象菩萨阿耨多罗三藐三菩提记

南无华世界名宝胜如来

彼如来授名远离诸有菩萨阿耨多罗三藐三菩提记

南无种种幢世界名月胜功德如来

彼如来授名断一切诸难菩萨阿耨多罗三藐三菩提记

南无可乐世界名即发心转法轮如来

彼如来授名不退转菩萨阿耨多罗三藐三菩提记

南无无畏世界名十方称名如来

彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无自在世界迦陵伽佛　南无安乐世界日轮灯明佛　南无无畏世界宝胜佛　南无智成就世界智起佛　南无纯乐世界功德王住佛　南无盖行花世界无障碍眼佛　南无金刚轮世界无畏佛　南无发起世界智积佛　南无善清净世界无观相发行佛　南无普光明世界光明轮威德王胜佛　南无高幢世界因慧佛　南无德世界那罗延佛　南无无垢世界无垢幢佛　南无远离一切忧障世界安隐佛　南无贤上世界远离诸烦恼佛　南无一切安乐世界清净慧佛　南无无量功德具足世界善思惟发佛　南无平等平等世界降伏诸怨佛　南无无畏世界优波罗胜佛　南无十方光明世界胜力王佛

南无如是等无量无边佛

南无常光明世界无量光明香云弥留佛　南无常庄严世界降伏男女佛　南无沉水香世界上胜香佛　南无常庄严世界种种花佛　南无香盖世界无边智佛　南无栴檀香世界宝上王佛　南无香世界香弥留佛　南无普喜世界智见一切众生信佛　南无不可量世界无边声佛　南无佛华庄严世界智功德胜佛　南无善住世界不动步佛

归命如是等无量无边佛应知

南无华世界无障碍吼声佛　南无月世界普宝藏佛　南无坚住世界迦叶佛　南无普波头摩世界观一切境界镜佛　南无栴檀世界上首佛　南无实世界成就义佛　南无有月世界成就胜佛　南无无障碍世界名称佛　南无安乐世界断一切疑佛

归命如是等无量无边佛应知

南无光王世界智胜佛　南无普畏世界月佛　南无种种成就世界功德微佛　南无种种华世界星宿王佛　南无广世界无量幢佛　南无罗网世界罗网光明佛　南无无惊怖世界净声佛　南无可乐世界现宝胜佛　南无离观世界一切法无所发佛　南无常称世界不断一切众生发行佛

归命如是等无量无边佛应知

南无常欢喜世界无量奋迅佛　南无普镜世界建一切法佛　南无普照世界普见一切法佛　南无一切功德成就世界成就无边胜功德佛　南无无垢世界智起光佛　南无无怖优钵罗世界波头摩胜佛　南无波头摩怖世界十方胜佛　南无花怖世界华成就胜佛　南无天世界坚固众生佛　南无光明世界智光明佛

归命如是等无量无边佛应知

南无安乐调世界修智佛　南无安乐世界远离胎佛　南无无染世界明王佛　南无云世界断一切烦恼佛　南无普色世界无边智称佛　南无坚固世界栴檀屋胜佛　南无无比功德世界成就无比胜佛华佛　南无宝世界善住力王佛　南无十方上首世界起月光佛　南无龙王世界上首佛

归命如是等无量无边佛应知

南无善住世界善高聚佛　南无无怖畏世界作称佛　南无爱香世界断诸难佛　南无成就一切功德善住世界称亲佛　南无成就一切势力善住世界称坚固佛　南无忧慧世界远离诸忧佛　南无称世界起波头摩功德王佛　南无花俱苏摩住世界善散华幢佛　南无十方名称世界放光明普至佛　南无十方上首世界名称眼佛

归命如是等无量无边佛应知

南无焰慧世界放焰佛　南无吼世界十方称名佛　南无光明世界自在弥留佛　南无宝光明世界大光明佛　南无常欢喜世界焰炽佛　南无有世界三界自在奋迅佛　南无无畏世界放光明轮佛　南无常悬世界众寂胜佛　南无波头摩王世界无尽胜佛　南无普吼世界妙鼓声佛

归命如是等无量无边佛应知

南无无畏世界普胜佛　南无十方名称世界智胜佛　南无地世界山王佛　南无地功德世界波头摩轮境界胜王佛　南无然灯轮世界善住佛　南无普庄严世界大庄严佛境界佛　南无倚世界作一切功德佛　南无欢喜世界毕竟成就佛　宝功德佛　南无星宿行世界知上胜佛　南无盖行庄严世界智起光明威德王胜佛

归命如是等无量无边诸佛应知

南无法波头摩世界波头摩生王佛　南无法境界自在佛(梵本中自此已下皆有世界略不明矣)　南无月中光明佛　南无香象佛　南无阿弥陀光明佛　南无波头摩山佛　南无波头摩生胜佛　南无栴檀胜佛　南无宝积佛　南无智慧佛

归命如是等无量无边诸佛应知

南无无畏作王佛　南无功德成就胜佛　南无光明幢佛　南无无量功德作佛　南无功德成就胜佛　南无一切功德成就胜佛　南无波头摩成就胜佛　南无炬住持佛　南无宝上胜佛　南无金色华佛

归命如是等无量无边诸佛应知

佛说佛名经卷第二佛说佛名经卷第三

        后魏北印度三藏菩提流支译

南无上王佛　南无星宿王佛　南无无量弥留佛　南无虚空轮清净王佛　南无无量声佛　南无宝山佛　南无种种宝拘苏摩花佛　南无胜众佛　南无无尘离尘放发佛

归命如是等无量无边诸佛应知

南无不宿发修行佛　南无金色花佛　南无宝舍佛　南无种种花成就佛　南无放光明佛　南无俱苏摩成就佛　南无放盖佛　南无称力王佛　南无净声佛　南无胜佛　南无如是等无量无边诸佛应知

南无无量众佛　南无上首佛　南无无障碍眼佛　南无破散一切诸趣佛　南无断一切疑佛　南无无相声佛　南无毕竟无边功德佛　南无宝成就胜佛　南无波头摩上胜佛　南无宝上佛

归命过去未来如是等无量无边佛应知

南无无障碍发修佛　南无无边佛　南无宝弥留佛　南无日然灯上胜佛　南无智成就胜佛　南无优钵罗然灯佛　南无十方然灯佛　南无贤胜佛　南无莎罗自在王佛　南无师子佛　南无宝弥留佛　南无毗婆尸佛　南无妙胜光明佛　南无功德王光明佛　南无华王佛　南无无量眼佛　南无如是等无量无边诸佛应知

南无功德一味佛　南无十方然灯佛　南无贤胜佛　南无娑罗自在王佛　南无师子佛　南无宝弥留佛　南无毗婆尸佛　南无明王佛　南无上首佛　南无月上王佛　南无如是等无量无边诸佛应知

南无大龙佛　南无香上胜佛　南无香胜幢佛　南无栴檀屋佛　南无香幢佛　南无栴檀香佛　南无无边精进佛　南无十上光明佛　南无波头摩上佛　南无惊怖波头摩花成就上王佛

南无如是等无量无边诸佛应知

南无宝网佛　南无善住王佛　南无香胜王佛　南无与一切乐佛　南无示一切念佛　南无不空说佛　南无能灭一切怖畏佛　南无不住王佛　南无宝光明佛　南无与一切众生安隐佛南无如是等无量无边佛应知　南无观无量境界佛　南无虚空庄严胜佛　南无光庄严佛　南无修行幢佛　南无成就惊怖胜花佛　南无贤胜佛　南无清净眼佛　南无大将佛　南无上胜高佛　南无不可胜幢佛

南无如是等无量无边佛应知

南无可依佛　南无无量无边佛　南无香弥留佛　南无月轮闻王佛　南无妙弥留宝成就胜佛　南无闻弥留善胜佛　南无净胜佛　南无无障碍眼佛　南无无边功德作佛　南无威德王佛　南无愿善思惟成就佛　南无清净轮王佛　南无智上佛　南无精进仙佛　南无智山佛　南无方作佛　南无大会上首佛　南无最上首佛　南无智护佛　南无上胜佛　南无现示众生境界无障碍见佛　南无不成就境界佛　南无无障碍光明佛　南无发光明无碍佛　南无佛波头摩上成就胜佛　南无观一切佛境界现佛形佛　南无东方说坚如来　南无化声佛　南无波头摩胜佛　南无宝成就胜佛　南无海弥留佛　南无无垢慧佛　南无智花成就佛　南无积胜上威德寂静佛　南无离贪境界佛　南无离一切取佛　南无不可思议功德成就胜佛　南无现成就胜佛　南无无畏去佛　南无香风佛　南无无等香光佛　南无云妙鼓声佛　南无功德成就胜佛　南无无量奋迅境界弥留聚佛　南无香胜弥留佛　南无无量弥留佛　南无无量光明佛　南无普见佛　南无无畏佛　南无得无畏佛　南无月然灯佛　南无火然灯佛　南无胜修佛　南无胜众佛　南无金刚成佛　南无智自在王佛　南无智力称佛　南无无畏胜佛　南无功德王光明佛　南无善明佛　南无坚自在王佛　南无弥留王佛　南无虚空弥留宝胜佛　南无贤上胜佛　南无梵吼声佛　南无宝花佛　南无波头摩成就胜佛　南无栴檀香佛　南无须弥劫佛　南无胜庄严佛　南无宝盖佛　南无香象佛　南无无边胜佛　南无不空说名佛　南无不可思议功德王光明佛　南无无畏王佛　南无波头摩上胜佛　南无常得精进佛　南无药王佛　南无安隐佛　南无无边意行佛　南无无边境界佛　南无无边光明佛　南无无边明(丹作眼)佛　南无无边虚空境界佛　南无金色境界佛　南无星宿王佛　南无香上胜佛　南无虚空胜佛　南无妙胜佛　南无方作佛　南无妙弥留佛　南无无障碍眼佛　南无金刚坚佛　南无炬然灯佛

归命如是等无量无边诸佛应知

南无火幢佛　南无智积佛　南无贤无垢威德光佛　南无称力王佛　南无功德王光明佛　南无见智佛　南无波头摩妙胜佛　南无成就胜佛　南无宝光佛　南无宝莲华胜佛　南无远离疑成就佛　南无众上首佛　南无拘留孙佛　南无幢王佛　南无波头摩功德佛　南无放光明佛　南无弥勒佛　南无光明波头摩光佛　南无胜王佛　南无法幢佛　南无无量奋迅佛　南无海须弥佛　南无妙见佛　南无释迦牟尼佛　南无不空见佛　南无无障碍吼声佛　南无无量功德胜名光明佛　南无无分别修行佛　南无无边光明佛　南无善眼佛　南无南方普宝藏佛　南无无垢解脱远离垢佛

归命如是等无量无边诸佛应知

南无西方无量花佛　南无无量照佛　南无无量光明佛　南无无量明佛　南无无量境界佛　南无无量自在佛　南无无量奋迅佛　南无普盖佛　南无盖行佛　南无宝盖佛　南无星宿王佛　南无善星宿佛　南无光明轮佛　南无光明王佛　南无光明上胜佛　南无无边见佛　南无胜王佛　南无无边境界奋迅佛　南无无障碍吼声佛　南无大云光明佛　南无罗网王佛　南无善得平等光明佛　南无波头摩胜花佛南无山王佛　南无月众增上佛　南无高光明佛　南无合聚佛　南无不空光明佛　南无顶胜王佛　南无北方不空然灯佛　南无不空奋迅佛　南无不空境界佛　南无不空光明佛　南无无边精进佛　南无莎罗自在王佛　南无宝莎罗王佛　南无普盖王佛　南无盖庄严王佛　南无宝积佛　南无栴檀屋佛　南无栴檀香佛　南无无量光明佛　南无光明轮庄严弥留佛　南无无障碍眼佛　南无无量眼佛　南无宝成就佛　南无一切功德佛　南无佛华成就功德佛　南无善住慧佛　南无无量步佛　南无不空胜佛　南无宝步佛　南无无边修行佛　南无无边庄严胜佛　南无虚空轮光明佛　南无无量声佛　南无药王佛　南无无畏佛　南无远离惊怖毛竖佛　南无功德王光明佛　南无观智慧起花佛　南无虚空寂佛　南无虚空声佛　南无虚空庄严成就佛　南无下方大自在佛　南无妙胜佛　南无有佛　南无华胜佛　南无善生佛　南无师子胜佛　南无成就义佛　南无师子护佛　南无师子钾佛　南无善住山王佛　南无净弥留佛　南无清净眼佛　南无不空足步佛　南无虚空像佛　南无香胜佛　南无香山佛　南无无量眼佛　南无香积佛　南无宝众佛　南无宝高佛　南无善住佛　南无善住王佛　南无净弥留佛　南无坚王佛　南无光明轮佛　南无火然灯佛　南无不空过佛　南无善思惟发行佛　南无师子佛　南无坚固众生佛　南无行胜住王佛　南无上方无量境界佛　南无胜王佛　南无精进胜佛　南无断疑佛　南无善星宿王佛　南无然灯佛　南无光明佛　南无光明弥留佛　南无光明轮佛　南无称光明佛　南无高盖佛　南无香盖佛　南无宝盖佛　南无栴檀香佛　南无栴檀胜佛　南无须弥聚佛　南无宝光明佛　南无坚固王佛　南无净功德佛　南无清净眼佛　南无无畏佛　南无远离诸畏佛　南无成就积佛　南无宝胜佛　南无山王佛　南无转女根佛　南无无量行佛　南无最胜光明佛　南无罗网光明幢佛　南无目王佛　南无日月净明德佛

南无东南方观一切佛形镜如来以为上首　南无火然灯佛　南无空过佛　南无花觉奋迅佛　南无罗网光明佛　南无无量光明花王佛　南无宝坚固佛　南无初发心转轮佛　南无华积佛　南无千上光明佛　南无不动步佛　南无无量迹步佛　南无无量愿佛　南无无边愿佛　南无无边境界佛　南无不定愿佛　南无转胎佛　南无转诸难佛　南无不行念佛　南无成就一切念佛　南无虚空佛　南无有胜佛　南无西南方成就义如来为上首

南无成就义发行佛　南无成就焰佛　南无成就义胜佛　南无善焰佛　南无常发行佛　南无善住佛　南无无量发行佛　南无无相修行佛　南无无边修行佛　南无普修行佛　南无然灯光明作佛　南无普藏佛　南无普山佛　南无无边形佛　南无无边精进佛　南无罗网光佛　南无曼陀罗佛　南无光明轮佛　南无善见佛　南无不空说名佛　南无破一切怖畏佛　南无无量功德王光明步佛　南无无边华佛　南无无边吼声佛　南无乐积光明功德佛　南无不二轮佛　南无无量光明佛　花光佛　南无无量声佛　南无高明佛　南无坚固自在王佛　南无日面佛　南无善眼佛　南无胜功德佛　南无宝花佛　南无宝成就佛　南无月花佛　南无一切众生修行佛　南无转一切世间佛　南无无量光明无形佛　南无无畏佛　南无一切乐念顺行佛

南无西北方普香光明如来为上首　南无发初香光明佛　南无香山佛　南无香象佛　南无香胜佛　南无香身佛　南无香轮佛　南无光明王佛　南无妙波头摩王佛　南无佛境界佛　南无无量境界佛　南无安乐佛　南无快胜佛　南无放光明花佛　南无华盖行佛　南无华帐佛　南无金花佛　南无香华佛　南无高王佛　南无善导师佛　南无胜一切众生佛　南无转一切念佛　南无无量行华佛　南无无量香佛　南无普照放光明佛　南无普香光明佛　南无普放光明佛　南无放成就胜花佛　南无宝罗网像佛　南无妙光佛　南无普一盖国土佛　南无星宿王佛　南无合聚佛　南无不住王佛　南无香风佛　南无无边智境界佛　南无不空行佛　南无不空见佛　南无无障碍眼佛　南无初发心佛　南无无量眼佛　南无然灯上佛　南无普光明佛　南无照光明佛　南无帝相佛　南无一切佛国土一切众生不断乐说佛

南无阿楼那奋迅佛　南无无迹奋迅佛　南无东北方断一切忧恼如来为上首　南无离忧佛　南无乐成就功德佛　南无无畏王佛　南无胜弥留佛　南无香山佛　南无拘邻佛　南无大体胜佛　南无宝莲华胜佛　南无华成就佛　南无吼眼佛　南无胜众佛　南无无边光明佛　南无月胜光明称佛　南无星宿王众增上佛　南无无边光明佛　南无香高山佛　南无无畏王佛　南无成就胜无畏佛　南无无边光照光明佛　南无光明佛　南无香弥留佛　南无离惊怖成就胜佛　南无无量功德月成就佛　南无一切功德庄严佛　南无不可胜幢佛　南无增上护光明佛　南无华胜王佛　南无无边成就行佛　南无一切胜佛　南无虚空轮清净王佛　南无无量吼声佛　南无无量吼妙声佛　南无宝胜功德佛　南无净胜佛　南无无碍香象佛　南无高光明佛　南无大称佛　南无称亲佛　南无坚固自在王佛　南无莎罗王佛　南无无量照佛　南无安隐王佛　南无大积佛　南无普功德增上云声灯佛　南无高积佛　南无功德王光明佛　南无坚积聚佛　南无宝胜光明佛　南无优钵罗光明作佛　南无月王佛　南无栴檀佛　南无月胜佛　南无梵光佛　南无行净佛　南无一切胜佛　南无难胜佛　南无宝作佛　南无无量声佛　南无树提佛　南无龙天佛　南无日天佛　南无师子佛　南无无垢明佛　南无世间天佛　南无胜积佛　南无人自在恭敬佛　南无华胜佛　南无发精进佛　南无火妙香光明胜佛　南无无垢香火胜佛　南无普见佛　南无不动佛　南无宝幢佛　南无无量明佛　南无妙宝声佛　南无遍照佛　南无智光明王佛　南无摩尼光明胜佛　南无无量华光明善胜慧佛　南无卢舍那佛　南无智慧自在佛　南无水聚日佛　南无火然灯佛　南无月光明佛　南无无障碍智佛　南无华香佛　南无宝光明佛　南无曼陀罗香喜佛　南无拘邻智焰佛　南无大月香佛　南无花幢佛　南无无著智佛　南无宝作佛

归命如是等无量亿毗婆罗佛

南无无忧胜佛　南无宝山佛　南无人王佛　南无力胜佛　南无香胜佛　南无普满华佛　南无无垢光明佛　南无乐说庄严思惟佛　南无无垢月幢佛　南无俱苏摩光明作佛　南无火行佛　南无宝上佛　南无无畏观佛　南无师子奋迅力佛　南无远离惊怖毛竖等喜称佛　南无金光明威德王佛　南无善说增上名胜佛

若善男子善女人十日礼拜读诵是诸佛名远离一切业障永灭诸罪

南无普光明佛　南无自在幢王佛　南无过种种敌对奋迅佛　南无无量功德光明胜佛　南无无障碍佛　南无宝波头摩奋迅胜佛　南无宝华善住山自在王佛　南无智炬佛　南无光明佛　南无难降伏佛　南无普照十方世界佛　南无大海佛　南无宝藏佛　南无银幢佛　南无幢日王佛　南无威德自在王佛　南无觉王佛　南无十力自在王佛　南无平等作佛　南无初发心思惟远离诸怖畏佛　南无烦恼无碍妙胜佛　南无金刚足步佛　南无宝像光明足奋迅佛　南无降伏诸魔疑奋迅佛

若善男子善女人受持读诵是诸佛名一阿僧祇劫超越世间不入恶道

南无初发心不退转成就胜佛　南无宝盖上光明佛　南无教化菩萨佛　南无初发心断一切疑烦恼佛　南无光明胜破闇三昧胜上王佛　南无乐说庄严云声欢喜佛　南无清净香佛　南无决定光明威德王佛　南无拘留孙佛　南无金圣佛　南无人王佛　南无迦叶佛　南无弥勒佛　南无师子佛　南无然炬佛　南无明王佛　南无圣佛　南无华幢佛　南无善星宿佛　南无大主佛　南无大臂佛　南无大力佛　南无星宿王佛　南无药王佛　南无称幢佛　南无大光明佛　南无火聚佛　南无月照佛　南无日藏佛　南无月焰佛　南无善明佛　南无无忧佛　南无一沙佛　南无大明佛　南无住持鬘佛　南无功德明佛　南无见义佛　南无然灯佛　南无妙歌佛　南无药上佛　南无安隐佛　南无顶坚胜威德佛　南无难胜佛　南无功德幢佛　南无罗睺佛　南无胜众佛　南无梵声佛　南无坚固意佛　南无光明作佛　南无大高山佛　南无金刚仙(丹作山)佛　南无无畏佛　南无宝波头摩眼力仙佛　南无华光明人爱佛　南无大威德佛　南无日净王佛　南无无量命佛　南无龙德佛　南无坚步佛　南无不空见佛　南无精进德佛　南无力护佛　南无欢喜佛　南无德胜佛　南无师子幢佛　南无胜法佛　南无欢喜王上首佛　南无爱作佛　南无功德智佛　南无香象佛　南无善观佛　南无云声佛　南无善思惟佛　南无善识佛　南无无垢佛　南无月上佛　南无大称佛　南无摩尼宝佛　南无胜王佛　南无师子步佛　南无树王佛　南无光明胜佛　南无积智慧佛　南无善住佛　南无坚意佛　南无甘露慧佛　南无善见佛　南无智光明佛　南无坚行佛　南无善吉佛　南无宝幢佛　南无波头摩佛　南无那罗延佛　南无乐说佛　南无智作佛　南无功德佛　南无供养佛　南无净德佛　南无宝作佛　南无华天佛　南无善思惟义佛　南无法上佛　南无自在佛　南无称慧佛　南无意称佛　南无金刚幢佛　南无十力王佛　南无奋迅佛　南无离闇佛　南无罗睺天佛　南无弥留幢佛　南无众上首佛　南无宝藏佛　南无上修佛　南无星宿佛　南无大觉佛　南无三界尊佛　南无功德称佛　南无日月光明师子幢佛　南无毗罗波王佛　南无胜藏佛　南无示现有佛　南无月光佛　南无金山佛　南无师子德佛　南无不可称幢佛　南无光明佛　南无称愿佛　南无坚精进佛　南无无譬喻称佛　南无离畏佛　南无应天佛　南无大然灯佛　南无多世间佛　南无妙香佛　南无住持功德佛　南无离闇佛　南无无比佛　南无自然佛　南无师子佛　南无善行佛　南无宝称佛　南无离诸过佛　南无住持甘露佛　南无人月佛　南无日面佛　南无庄严佛　南无摩尼光佛　南无山积佛　南无高幢佛　南无法作佛　南无思惟义佛　南无深心佛　南无宝聚佛　南无众上首佛　南无劫簸佛　南无奋迅佛　南无住智佛　南无分明佛　南无胜见佛　南无不起佛　南无功德胜佛　南无师子吼佛　南无奋迅佛　南无人信佛　南无龙王佛　南无华山佛　南无龙喜佛　南无香自在佛　南无妙称佛　南无天力佛　南无功德鬘佛　南无龙功德佛　南无庄严眼佛　南无善行智佛　南无智胜佛　南无慧照佛　南无实语佛　南无日光明佛　南无决定智佛　南无宝上色佛　南无普照佛　南无宝幢佛　南无离疑佛　南无师子奋迅步佛　南无善护佛　南无不空步佛　南无觉花幢佛　南无山自在王佛　南无大威德佛　南无示现恶佛　南无甘露称佛　南无宝天佛　南无住义智佛　南无满足智佛　南无不狭劣名称佛　南无无忧佛　南无离垢佛　南无梵天佛　南无地自在王佛　南无华眼佛　南无差别见佛　南无法光明佛　南无具足见佛　南无信功德佛　南无三界尊佛　南无月叶佛　南无宝光明佛　南无宝幢佛　南无妙称佛　南无光明作佛　南无无量威德佛　南无广护佛　南无师子身佛　南无甘露慧佛　南无难胜佛　南无功德聚佛　南无月高佛　南无得大势至佛　南无无量步佛　南无月无畏佛　南无见一切义佛　南无勇猛佛　南无功德然灯佛　南无月王佛　南无功德焰佛　南无广智佛　南无善寂灭佛　南无天光佛　南无无垢佛　南无住持无量明佛　南无希胜佛　南无不覆藏佛　南无善住佛　南无大意佛　南无上首佛　南无世间光明佛　南无多功德佛　南无无量威德佛　南无离嗔恨无热佛　南无善称佛　南无义慧佛　南无离尘佛　南无称德佛　南无俱苏摩德佛　南无人德佛　南无精进仙佛　南无大德佛　南无寂慧佛　南无香像佛　南无上坚佛　南无安乐佛　南无不可胜佛　南无日月佛　南无雷王佛　南无电王佛　南无大胜佛　南无护智佛　南无日佛　南无成就义佛　南无宝积佛　南无降伏怨佛　南无花胜佛　南无应称佛　南无智步佛　南无离慢佛　南无根花佛　南无无畏国土佛　南无高称佛　南无示有佛　南无月佛　南无多功德佛　南无宝月佛　南无师子幢佛　南无乐思惟佛　南无宗静佛　南无不可思议奋迅佛　南无乐功德佛　南无应供称佛　南无华相佛　南无无量乐说称佛　南无摩尼金刚佛　南无无量寿佛　南无摩尼庄严佛　南无大自在功德佛　南无胜月佛　南无高山称佛　南无百光明佛　南无欢喜佛　南无龙步佛　南无意成就佛　南无宝月佛　南无寂灭佛　南无然炬王月佛　南无上首佛　南无欢喜自在佛　南无宝髻佛　南无远离畏佛　南无宝藏佛　南无月面佛　南无无垢称佛　南无称威德佛　南无爱天佛　南无罗睺天佛　南无善焰佛　南无宝爱佛　南无宝聚佛　南无宝步佛　南无师子华佛　南无高修佛　南无人自在佛　南无人慧佛　南无照世间佛　南无宝威德佛　南无功德佛　南无大相佛　南无乘庄严佛　南无桥梁佛　南无香象佛　南无无心慧佛　南无弥留幢佛　南无善香佛　南无坚铠佛　南无胜威德佛　南无摩尼铠佛　南无贤佛　南无善香月佛　南无净自在佛　南无师子月佛　南无胜威德佛　南无善胜佛　南无不可胜轮佛　南无胜亲佛　南无宝名佛　南无大行佛　南无高光明佛　南无功德山佛　南无大称佛　南无法称佛　南无放光明佛　南无电德佛　南无实作佛　南无命佛　南无善焰佛　南无善首佛　南无决定慧佛　南无离有佛　南无摩尼香佛　南无胜喜佛　南无师子光明佛　南无普照佛　南无称胜佛　南无善智慧佛　南无摩尼月佛　南无高光佛　南无不可降伏行佛　南无火佛　南无摩尼轮佛　南无世尊佛　南无师子像佛　南无月满佛　南无宝焰佛　南无罗睺佛　南无善护佛　南无希觉佛　南无同光明佛　南无寂静去佛　南无安隐世间佛　南无无恼佛　南无十行佛　南无力喜佛　南无大体胜佛　南无至大体佛　南无得大势佛　南无功德藏佛　南无实行佛　南无无畏胜佛　南无树提佛　南无大光明佛　南无日光佛　南无广功德佛　南无宝功德佛　南无自在佛　南无摩尼香佛　南无作业佛　南无师子手佛　南无善化佛　南无宝高佛　南无海佛　南无住持佛　南无义智佛　南无善思惟慧佛　南无大众轮佛　南无宝火佛　南无修行义佛　南无世间月佛　南无花声佛　南无净幢佛　南无大众上首佛　南无师子步佛　南无威德德佛　南无福德成就佛　南无大光明佛　南无宝称佛　南无信众佛　南无无边称佛　南无不空光明佛　南无圣天佛　南无金刚众佛　南无善肩佛　南无幢王佛　南无华成佛　南无铠慧佛　南无风行佛　南无善思惟佛　南无称佛　南无快然佛　南无甘露聚佛　南无功德护佛　南无义去佛　南无无畏佛　南无慈佛　南无住分别佛　南无善报佛　南无摩尼足佛　南无解脱威德佛　南无善疾平等威德佛　南无智胜佛　南无善天佛　南无实声佛　南无智力德佛　南无师子慧佛　南无华高佛　南无智作佛　南无华德佛　南无功德藏佛　南无宝称佛　南无实称佛　南无不可降伏佛　南无无畏自在佛　南无净日佛　南无诸天佛　南无可爱佛　南无实天佛　南无实(丹宝)藏佛　南无功德称佛　南无智积佛　南无清白佛　南无远行佛　南无天威德佛　南无净圣佛　南无喜去佛　南无大忧威德佛　南无焰聚佛　南无大胜佛　南无华光佛　南无喜上佛　南无善首佛　南无自在幢佛　南无大爱佛　南无善心佛　南无降伏他众佛　南无勇猛佛　南无成就佛　南无威德佛　南无善思义境界佛　南无善臂佛　南无大宝佛　南无称意佛　南无世间尊佛　南无功德光明佛　南无宝声佛　南无金刚仙佛　南无成就佛　南无师子力佛　南无无垢眼佛　南无迦叶佛　南无清净智佛　南无智步佛　南无高威德佛　南无大光明佛　南无日光明佛　南无无垢身佛　南无差别身佛　南无差别威德佛　南无不可比甘露钵佛　南无月光明电德佛　南无寂灭去佛　南无不动佛　南无多称佛　南无功德法佛　南无欢喜无畏佛　南无庄严王佛　南无妙称佛　南无多焰佛　南无华胜佛　南无宝庄严佛　南无善贤佛　南无宝妙佛　南无善智慧佛　南无善贤德佛　南无梵幢佛　南无月盖佛　南无罗网焰佛　南无广光明佛　南无智称佛　南无名相佛　南无功德光明佛　南无称名声佛　南无满月佛　南无华光佛　南无善行佛　南无然灯王佛　南无电幢佛　南无光明王佛　南无星宿光佛　南无不可嫌名佛　南无波头摩藏佛　南无弗沙快佛　南无眼满佛　南无无浊义佛　南无高威德佛　南无华威德佛　南无奋迅佛　南无无障智佛　南无罗睺天佛　南无智聚佛　南无上首佛　南无自在劫佛　南无华幢佛　南无罗睺佛　南无火药佛　南无星宿王佛　南无明王佛　南无福德手佛　南无称光佛　南无日光明佛　南无法藏佛　南无善智慧佛　南无功德自在劫佛　南无金刚仙佛　南无智慧积佛　南无善住佛　南无善至智慧佛　南无净声佛　南无龙吼声佛　南无相幢佛　南无智慧聚佛　南无无畏佛　南无净上首佛　南无快眼佛　南无龙德佛　南无宝幢佛　南无黠慧佛　南无不怯弱声佛　南无实(作丹宝)相佛　南无声德佛　南无师子佛　南无种种说佛　南无智色佛　南无波头摩聚佛　南无华佛　南无奋迅去佛　南无华积佛　南无胜色佛　南无星宿色佛　南无月灯佛　南无威德聚佛　南无菩提王佛　南无无尽佛　南无善慧眼佛　南无喜身佛　南无智慧国土佛　南无上佛　南无净威德佛　南无有智佛　南无真声佛　南无尊佛　南无无障碍藏佛

佛说佛名经卷第三佛说佛名经卷第四

        后魏北印度三藏菩提流支译

南无胜德佛　南无胜智奋迅佛　南无大炎佛　南无自在疾住持威德佛　南无善光明胜佛　南无善色王佛　南无成就义佛　南无师子山(丹仙)佛　南无天佛　南无施佛　南无快藏佛　南无福德光明佛　南无净佛　南无然灯王佛　南无智生佛　南无妙天佛　南无地天佛　南无得解脱去佛　南无金顶佛　南无罗睺罗乐说佛　南无难胜佛　南无信圣佛　南无月光佛　南无金光佛　南无善才佛　南无功德自在天佛　南无法盖佛　南无功德智佛　南无差别身佛　南无妙智佛　南无微智佛　南无一切威德药佛　南无解脱幢佛　南无智慧藏佛　南无智慧积佛　南无离怖畏佛　南无离恶佛　南无无障碍称佛　南无实积佛　南无善声佛　南无众自在劫佛　南无法积佛　南无解脱威德佛　南无胜快佛　南无妙身佛　南无妙语佛　南无师子爱佛　南无人自在功德佛　南无师子髻佛　南无法浚佛　南无安乐佛　南无不动佛　南无色威德佛　南无能觉王佛　南无善眼佛　南无坚固义佛　南无智光明佛　南无香威德佛　南无无病修佛　南无海觉佛　南无胜色佛　南无善步佛　南无吼称佛　南无觉身佛　南无然灯日佛　南无智慧足佛　南无定身佛　南无威德无尽佛　南无功德乘佛　南无金乘佛　南无放结佛　南无法行佛　南无善住去佛　南无离慢佛　南无智藏佛　南无净去佛　南无旃檀佛　南无无忧佛　南无清净身幢佛　南无无国土花佛　南无无量威德佛　南无天光明佛　南无智慧华佛　南无成就智佛　南无净住佛　南无一味手佛　南无自在佛　南无无比说佛　南无胜说佛　南无福德威德佛　南无日佛　南无度世间智佛　南无得成就佛　南无法行佛　南无求安隐佛　南无色智佛　南无合掌光明佛　南无无创佛　南无琉璃藏佛　南无华天佛　南无自然佛　南无善根光明佛　南无一切功德胜光明佛　南无宝胜佛　南无日月佛　南无降伏怨佛　南无无量光明佛　南无须摩那树提光明佛　南无增上佛　南无乐智慧佛　南无功德自在佛　南无寂静佛　南无功德积力佛　南无善眼佛　南无善声佛　南无善华佛　南无善住佛　南无功德威德聚佛　南无无边智佛　南无无量声佛　南无善光佛　南无善智慧佛　南无解脱义佛　南无思惟胜佛　南无胜声身佛　南无快佛　南无胜行佛　南无寂静义佛　南无善过佛　南无清净行佛　南无华作佛　南无善光佛　南无常然灯佛　南无善量佛　南无众自在佛　南无离畏佛　南无智怖佛　南无善逝乐说佛　南无胜眼佛　南无菩提月佛　南无宝光明佛　南无月佛　南无无畏佛　南无大镜佛　南无梵声佛　南无善声佛　南无大智慧桥梁佛　南无普智慧佛　南无金刚仙佛　南无功德力佛　南无伏心佛　南无树王佛　南无数声佛　南无住胜佛　南无爱圣佛　南无威德佛　南无树提味佛　南无妙鼓云声佛　南无爱眼佛　南无贤智佛　南无成就功德胜佛　南无寂静吼佛　南无法幢佛　南无虚空功德声佛　南无功德差别佛　南无功德声佛　南无威德佛　南无功德集佛　南无有智佛　南无圣行佛　南无乐说月佛　南无善灭佛　南无月面佛　南无日月无垢佛　南无集功德佛　南无华福德佛　南无幢乐说国土佛　南无恭敬爱佛　南无无量师子力佛　南无自在王佛　南无无量信佛　南无平等思惟佛　南无不动寂静佛　南无无垢光佛　南无平等行佛　南无不浊佛　南无不动佛　南无不扰佛　南无善行佛　南无住善调智佛　南无说自在佛　南无大天佛　南无深意佛　南无无量佛　南无法力佛　南无供养花光佛　南无三界供养佛　南无应供佛　南无日藏佛　南无他供养佛　南无解脱幢佛　南无快结佛　南无甘露清净佛　南无金刚坚佛　南无宝聚光明佛　南无快步佛　南无日清净光明佛　南无功德积佛　南无阿楼那胜佛　南无师子去佛　南无胜上佛　南无花德佛　南无放光明佛　南无波头摩智爱佛　南无快庄严佛　南无不空行佛　南无合创佛　南无光明幢佛　南无乐心佛　南无乐解脱佛　南无智净佛　南无闻慧海佛　南无宝住持佛　南无拘峻庄严佛　南无孔雀声佛　南无不属佛　南无断爱根佛　南无月起佛　南无海胜佛　南无不动合去佛　南无乐功德然灯佛　南无教声佛　南无地主佛　南无威德力佛　南无住智慧色佛　南无善月佛　南无觉华佛　南无善赞叹佛　南无善处佛　南无力智威德加佛　南无然灯坚固佛　南无奋迅佛　南无天声佛　南无寂静佛　南无日面佛　南无乐解脱佛　南无界光明佛　南无住行佛　南无无垢佛　南无坚固起佛　南无乐智自在佛　南无香光明佛　南无广光明佛　南无念自在佛　南无甘露器佛　南无无碍幢佛　南无求胜菩提佛　南无信行佛　南无宝惭愧佛　南无法用佛　南无一切威德佛　南无大亲佛　南无寂静行佛　南无甘露增上佛　南无弥留光佛　南无圣赞叹佛　南无生威德佛　南无光明见佛　南无善修果报佛　南无善德庄严佛　南无宝光明佛　南无寂静功德步佛　南无功德海佛　南无种种色佛　南无降伏魔佛　南无闭塞魔佛　南无度一切难佛　南无不破境智佛　南无海文饰佛　南无得胜众解脱王佛　南无爱佛　南无大幢佛　南无智声佛　南无善胜佛　南无净命佛　南无智报佛　南无如意幢佛　南无世间自在劫佛　南无地住持佛　南无日爱佛　南无罗睺月佛　南无花光明佛　南无明增上佛　南无威德住持佛　南无乐功德佛　南无乐力佛　南无善声佛　南无法自在佛　南无梵声佛　南无善思惟佛　南无大志智慧佛　南无大施佛　南无月称佛　南无幢佛　南无称人声佛　南无树王佛　南无灭闇佛　南无善星佛　南无善光佛　南无无量乐说幢佛　南无快行福德佛　南无度系佛　南无无畏爱佛　南无世间爱佛　南无妙行佛　南无忧波罗花鬘佛　南无无量乐说光明佛　南无信圣人佛　南无精进功德佛　南无坚甘露增上佛　南无高宝信佛　南无得功德佛　南无福德慧佛　南无火炎佛　南无无量威功德威德佛　南无师子步佛　南无不动信佛　南无过有佛　南无龙王声佛　南无住持轮佛　南无胜色佛　南无世爱佛　南无法月佛　南无无量乐称佛　南无云幢佛　南无功德去佛　南无善逝佛　南无无量声佛　南无虚空天佛　南无摩尼王佛　南无清净行佛　南无然灯佛　南无珍宝吼声佛　南无人自在王佛　南无罗睺护佛　南无无畏佛　南无师子慧佛　南无宝称佛　南无辩义见佛　南无世间花佛　南无高步佛　南无等月王佛　南无乐说王佛　南无差别智佛　南无智自在佛　南无师子齿佛　南无快步佛　南无功德然灯月佛　南无无忧国土佛　南无意思智慧佛　南无法天炎尊佛　南无合调佛　南无增上力佛　南无智慧华佛　南无坚固声佛　南无常乐佛　南无说义佛　南无信爱作佛　南无师子弃结佛　南无离怖佛

若善男子善女人。能受持读诵是贤劫千佛名者。必见弥勒世尊。及见卢至。远离诸难

南无月光明佛　南无不动佛　南无大庄严佛　南无多伽罗香佛　南无妙胜佛　南无波头摩幢佛　南无宝聚佛　南无沉水香佛　南无大庄严佛　南无喜胜佛　南无山海佛　南无大海佛　南无法幢佛　南无梵胜佛　南无大香佛　南无大成就佛　南无大宝轮佛　南无无量寿佛　南无大高胜佛　南无大金台佛　南无大轮佛　南无语作佛　南无大人佛　南无大手佛　南无师子香称佛　南无供养胜佛　南无自在火佛　南无安乐作胜佛　南无师子华胜佛　南无寂静幢佛　南无戒王佛　南无普胜佛　南无怖象佛　南无无忧胜佛　南无忧波罗香佛　南无大地佛　南无大龙胜佛　南无清净王佛　南无大乐佛　南无波头摩胜佛　南无舍拘稣摩佛　南无龙妙佛　南无华聚佛　南无香象佛　南无常观佛　南无正作佛　南无善住佛　南无尼拘律王佛　南无常光佛　南无月胜佛　南无栴檀行佛　南无日藏佛　南无胜藏佛　南无须弥力佛　南无如意藏佛　南无金刚王佛　南无难胜佛　南无大胜佛　南无善见佛　南无精进德佛　南无大海佛　南无普莎罗佛　南无宿胜佛　南无佛天佛　南无师子幢佛　南无甘露胜佛　南无无量胜佛　南无功德慧厚胜佛　南无华幢佛　南无首胜佛　南无精进胜佛　南无龙胜佛　南无胜成就佛　南无宝积佛　南无胜足佛　南无大师佛　南无普见佛　南无宝多罗佛　南无普至佛　南无恭敬胜佛　南无大念佛　南无断一切众生疑王佛　南无宝胜佛　南无普盖佛　南无大盖佛　南无妙胜佛　南无千供养佛　南无宝华步佛　南无众胜佛　南无幢慧佛　南无尼拘律王佛　南无上胜佛　南无普波头摩佛　南无普胜佛　南无龙王护众佛　南无寂灭佛　南无远离垢佛　南无大聚佛　南无大供养佛　南无大将佛　南无善见佛　南无上胜佛　南无波头摩胜佛　南无闇(丹阇)轮威德佛　南无胜月佛　南无能仁佛　南无然灯佛　南无大威德佛　南无月面佛　南无栴檀香佛　南无弥留山佛　南无弥留劫佛　南无大面佛　南无无染佛　南无龙天佛　南无山声自在王佛　南无须弥山佛　南无金藏佛　南无火光佛　南无树提自在王佛　南无地寂佛　南无胜琉璃金光明佛　南无月像佛　南无月(丹日)声佛　南无散华光明庄严佛　南无海山智慧奋迅通佛　南无金刚光佛　南无大香光佛　南无远离嗔恨心佛　南无月光佛　南无胜琉璃快智慧俱稣摩佛　南无日光佛　南无华鬘色王佛　南无华通佛　南无水月光佛　南无破无明闇佛　南无得乐说佛　南无无畏王佛　南无然明佛　南无师子意佛　南无精进坚固佛　南无不坏精进佛　南无坚固勇猛佛　南无人月佛　南无师子慧佛　南无阎浮上佛　南无释迦牟尼佛　南无大势佛　南无快声佛　南无无量光佛　南无妙光佛　南无上首佛　南无上胜佛　南无乐吼佛　南无见实佛　南无供养积(丹称)佛　南无师子慧佛　南无声德佛　南无善香佛　南无电灯佛　南无波头摩光佛　南无大灯佛　南无净声佛　南无破疑佛　南无无边威德佛　南无赊尸面佛　南无无量名佛　南无妙威德佛　南无无量藏佛　南无散畏疑佛　南无福德灯佛　南无善见佛　南无不可降伏威德佛　南无爱威德佛　南无光明奋迅佛　南无广秤佛　南无异幢佛　南无不可胜佛　南无威德王佛　南无坚固佛　南无妙称佛　南无无量色佛　南无大信佛　南无妙声佛　南无不动步佛　南无无量庄严佛　南无威德王聚光明佛　南无住智慧佛　南无金坚佛　南无爱解脱佛　南无能与无畏佛　南无甘露藏佛　南无普观佛　南无大须佛　南无山威德佛　南无天供养佛　南无光明胜佛　南无说重佛　南无庄严光明佛　南无师子奋迅佛　南无异见佛　南无遍见佛　南无甘露步佛　南无月光明佛　南无称供养佛　南无护根佛　南无清净声佛　南无无障碍轮佛　南无离生佛　南无甘露声佛　南无空威德佛　南无功德王佛　南无无量色佛　南无大力佛　南无黠慧庄严佛　南无见无障碍佛　南无师子香佛　南无普见佛　南无普德佛　南无善见佛　南无善色佛　南无慧称佛　南无宝庄严佛　南无妙光佛　南无解脱奋迅佛　南无功德庄严佛　南无毕竟智佛　南无智高佛　南无不动智佛　南无善威仪佛　南无快色佛　南无宝声佛　南无火声佛　南无善见佛　南无无量威德佛　南无妙思惟佛　南无爱称佛　南无功德华佛　南无俱稣摩炎佛　南无难降伏佛　南无妙声吼佛　南无善见佛　南无众生可敬佛　南无火明佛　南无无比步佛　南无清净智佛　南无快声佛　南无火照佛　南无月照佛　南无智化佛　南无功德庄严佛　南无福德光明佛　南无智作佛　南无断有见佛　南无见爱佛　南无无量光佛　南无胜声佛　南无种种日佛　南无戒步佛　南无天面佛　南无放盖佛　南无波婆娑佛　南无星宿佛　南无觉慧佛　南无增上师子种种鸣吼声佛　南无象吼佛　南无梵声佛　南无龙吼佛　南无势自在佛　南无世间自在王佛　南无无量命佛　南无然灯佛　南无无垢盖佛　南无宝光明佛　南无天威德面佛　南无然灯佛　南无光明胜王佛　南无普照佛　南无智慧奋迅王佛　南无可量花佛　南无下花佛　南无庄严胜散花佛　南无无量花佛　南无卢舍那智慧庄严奋迅王佛　南无无量众上首王佛　南无无垢威德佛　南无胜成就佛　南无月摩尼光罗网佛　南无安隐佛　南无高行佛　南无欢喜佛　南无坚固佛　南无善眼佛　南无善意佛　南无六十二同名尸弃佛　南无善生佛　南无净圣佛　南无梵胜佛　南无善见佛　南无上胜佛　南无上修佛　南无妙胜佛　南无寂静命佛　南无不厌足法佛　南无得功德佛　南无阳炎佛　南无称上佛　南无吉沙佛　南无星宿佛　南无了见佛　南无无量命佛　南无见义佛　南无高山佛　南无金圣佛　南无一切处自在佛　南无自在幢佛　南无净声佛　南无妙声佛　南无人声佛　南无宝上佛　南无宝焰佛　南无大宝佛　南无八十千同名然灯佛　南无八十亿那由他同名释迦牟尼佛　南无一万八千同名莎罗王佛　南无九万同名尼拘律王佛　南无五千同名波头摩王佛　南无六千同名上王佛　南无无同佛名佛　南无功德王光明佛　南无智胜上王佛　南无无垢智戒王佛　南无无量光明胜王佛　南无阎浮檀须弥山王佛　南无自在王佛　南无常放光明王佛　南无无垢称王佛　南无师子受象山欢喜王佛　南无宝杖功德王光佛　南无无尽智慧佛　南无宝幢佛　南无光明轮藏佛　南无奋迅恭敬称佛　南无高山王胜佛　南无云护佛　南无师子奋迅王佛　南无护妙法幢实(丹宝)佛　南无宝轮威德佛　南无胜光明功德佛　南无无量国土佛　南无爱星宿佛　南无无量光明佛　南无有德佛　南无十方清净佛　南无善智慧佛　南无胜魔佛　南无大庄严佛　南无胜心佛　南无心智佛　南无花藏佛　南无大力佛　南无常释(丹择)智慧佛　南无那罗延藏佛　南无常决定智佛　南无无边光佛　南无师子声佛　南无妙智佛　南无福德光明佛　南无上首光佛　南无快身佛　南无无垢义佛　南无应威德佛　南无成就智佛　南无德吼佛　南无舍地佛　南无妙光佛　南无决定思佛　南无实(丹宝)日佛　南无威德光明佛　南无花威德佛　南无胜成佛　南无称高佛　南无信功德佛　南无法灯佛　南无信胜佛　南无上爱面佛　南无师子奋迅佛　南无众山天佛　南无海智佛　南无波头摩藏佛　南无华藏佛　南无实(丹宝)仙佛　南无莎罗王佛　南无日光明佛　南无趣菩提佛　南无寂根佛　南无日光佛　南无分(丹芬)陀利香佛　南无弥留光佛　南无月面佛　南无妙步佛　南无观十方佛　南无德光明佛　南无清净戒佛　南无无边智佛　南无无边步佛　南无坚精进佛　南无天供养佛　南无普智佛　南无寂光佛　南无仁威德佛　南无功德桥梁佛　南无坚固修佛　南无称圣佛　南无称幢佛　南无不异心佛　南无普信佛　南无大威德佛　南无应供养佛　南无上功德佛　南无成就义修行佛　南无爱供养佛　南无普护佛　南无信菩提佛　南无心意佛　南无出智佛　南无山声佛　南无性日佛　南无云声佛　南无大炎聚佛　南无胜积佛　南无无忧佛　南无天国土佛　南无师子喜声佛　南无无量明佛　南无见爱佛　南无灯王佛　南无胜高佛　南无十方闻名佛　南无爱眼佛　南无月高佛　南无能与无畏佛　南无星宿王佛　南无月天佛　南无光明日佛　南无大称佛　南无真声佛　南无爱说佛　南无称上佛　南无天王佛　南无甘露明佛　南无乐声佛　南无心意佛　南无地住佛　南无寂过佛　南无多罗王佛　南无无畏佛　南无清净智佛　南无能破疑佛　南无慈胜佛　南无胜上佛　南无种种日佛　南无普见佛　南无见月佛　南无降伏魔佛　南无大首佛　南无师子奋迅去佛　南无威德光佛　南无普护佛　南无成就义威德佛　南无光明日佛　南无见聚佛　南无清净意佛　南无香山佛　南无摩尼清净佛　南无功德明佛　南无日然灯佛　南无成就光佛　南无乐说法佛　南无善思惟义佛　南无普现见佛　南无师子幢佛　南无苦行佛　南无大步佛　南无莲花眼佛　南无照光佛　南无信无量佛　南无无量色佛　南无盖天佛　南无宝光明佛　南无上首佛　南无善见佛　南无亲味佛　南无德味佛　南无日面佛　南无无障碍眼佛　南无师子步佛　南无火灯佛　南无生胜佛　南无信功德佛　南无福德藏佛　南无法幢佛　南无天爱佛　南无无畏佛　南无月爱佛　南无智胜佛　南无威德光佛　南无月德佛　南无功德聚佛　南无无边光佛　南无安乐佛　南无称幢佛　南无光明吼佛　南无普功德佛　南无上幢佛　南无那罗延佛　南无宝信佛　南无普思惟佛　南无善思惟佛　南无善智佛　南无不可量威德佛　南无师子臂佛　南无光明意佛　南无王天佛　南无实(丹本宝)幢佛　南无住善意佛　南无无量天佛　南无圣化佛　南无大功德佛　南无大幢佛　南无大光日佛　南无真法佛　南无日月佛　南无真报佛　南无胜天佛　南无观解脱佛　南无宝光明佛　南无孔雀声佛　南无普行佛　南无成就光佛　南无无量眼佛　南无称爱佛　南无善护佛　南无信天佛　南无不可量步佛　南无大威佛　南无心智佛　南无化(丹仙)步佛　南无月形佛　南无火聚佛　南无大修佛　南无火步佛　南无胜天佛　南无成就义修佛　南无月爱佛　南无师子声佛　南无信说佛　南无智光佛　南无花威德佛　南无光明聚佛　南无神通光明佛　南无无量威德佛　南无无量光佛　南无胜藏佛　南无普照称佛　南无宝幢佛　南无胜威德佛　南无日幢佛　南无大弥留佛　南无供养庄严佛　南无世间闻名佛　南无胜德佛　南无胜称佛　南无成就步佛　南无天供养佛　南无实(丹宝)净佛　南无不可降伏称佛　南无应光明佛　南无大灯佛　南无行威仪畏佛　南无奋迅佛　南无无障碍见佛　南无离疑佛　南无大行佛　南无不失步佛　南无天国土佛　南无善力佛　南无喜菩提佛　南无花光佛　南无能与光明佛　南无天爱佛　南无解脱光明佛　南无施光明佛　南无作功德佛　南无成智佛　南无道光佛　南无海王佛　南无喜菩提佛　南无法光佛　南无大天佛　南无深智佛　南无法自在佛　南无大信佛　南无心意佛　南无智光佛　南无不谬思佛　南无起福德佛　南无漏称佛　南无大庄严佛　南无月光佛　南无天光佛　南无清净行佛　南无功德爱佛　南无师子意佛　南无地清净佛　南无宝光明佛　南无快光明佛　南无种种日佛　南无月爱佛　南无月盖佛　南无普观佛　南无无染佛　南无称胜佛　南无月面佛　南无龙天佛　南无功德聚佛　南无功德智佛　南无花胜佛　南无世爱佛　南无甘露威德佛　南无宝幢佛　南无日光明佛　南无甘露光佛　南无说法爱佛　南无应爱佛　南无地光佛　南无功德作佛　南无花胜佛　南无功德臂佛　南无法灯佛　南无普光佛　南无梵声佛　南无大庄严佛　南无解脱日佛　南无坚精进佛　南无佛光明佛　南无功德称佛　南无善智慧佛　南无不可量庄严佛　南无师子爱佛　南无功德步佛　南无上天佛　南无观行佛　南无日天佛　南无电光佛　南无胜爱佛　南无弥留幢佛　南无华光佛　南无上意佛　南无香山佛　南无功德奋迅佛　南无胜意佛　南无信圣佛　南无宝洲佛　南无上威德佛　南无最后见佛　南无欢喜庄严佛　南无功德藏胜佛　南无无垢镜佛　南无威德力佛　南无清净眼佛　南无智行佛　南无不谬足佛　南无圣眼佛　南无乐解脱佛　南无大声佛　南无上国土佛　南无修行光明佛　南无念业佛　南无信功德佛　南无卢舍称佛　南无照闇佛　南无爱自在佛　南无月光佛　南无上声佛　南无功德胜佛　南无摄受择佛　南无相王佛　南无离热病智佛　南无能与圣佛　南无法洲佛　南无甘露功德佛　南无无嗔恨佛　南无甘露香佛　南无月眼(丹明)佛　南无吼声佛　南无无畏日佛　南无得无畏佛　南无喜爱佛　南无不错智佛　南无世爱佛　南无天灯佛　南无信圣佛　南无天盖佛　南无龙光佛　南无胜步佛　南无法威德佛　南无见有佛　南无惭愧面佛　南无胜色佛　南无普眼佛　南无功德光佛　南无月胜佛　南无定实佛　南无功德幢佛　南无世自在劫佛　南无无畏亲佛　南无摄智佛　南无降怨佛　南无去光明佛　南无胜积佛　南无一念光佛　南无力士奋迅佛　南无师子足佛　南无戒爱佛　南无信世间佛　南无胜威德光明佛　南无师子奋迅须佛　南无无垢去佛　南无决定智佛　南无离无明佛　南无功德聚佛

佛说佛名经卷第四佛说佛名经卷第五

        后魏北印度三藏菩提流支译

南无天盖佛　南无龙光佛　南无胜步佛　南无法威德佛　南无见有佛　南无惭愧面佛　南无胜色佛　南无普眼佛　南无功德光佛　南无月胜佛　南无定实佛　南无功德幢佛　南无世自在劫佛　南无无畏亲佛　南无摄智佛　南无降怨佛　南无法光明佛　南无胜积佛　南无一念光佛　南无力士奋迅佛　南无师子足佛　南无戒爱佛　南无信世间佛　南无胜威德光明佛　南无师子奋迅须佛　南无无垢去佛　南无决定智佛　南无离无明佛　南无功德聚佛　南无摄慧佛　南无大智味佛　南无实步佛　南无心日佛　南无观方佛　南无信说佛　南无思惟忍佛　南无法盖佛　南无不可降伏月佛　南无天华佛　南无天波头摩佛　南无普威德佛　南无月明佛　南无功德庄严佛　南无相王佛　南无称思惟佛　南无树幢佛　南无净行佛　南无威德步佛　南无信众佛　南无善香佛　南无智者赞叹佛　南无智慧光明佛　南无智铠佛　南无威德力佛　南无胜威德佛　南无佛欢喜佛　南无胜信佛　南无一切爱佛　南无离诸佛　南无思义佛　南无大高佛　南无圣人面佛　南无黠慧信佛　南无摄菩提佛　南无妙声佛　南无大威德佛　南无乐师子佛　南无普宝佛　南无一切世爱佛　南无分金刚佛　南无师子声佛　南无过火佛　南无导师佛　南无人月佛　南无大庄严佛　南无日光佛　南无快见佛　南无普摩尼香佛　南无寂行佛　南无摄称佛　南无梵供养佛　南无大吼佛　南无应供养佛　南无黠慧信佛　南无无量愿佛　南无世光佛　南无见忍佛　南无大花佛　南无有我佛　南无如意佛　南无善菩提根佛　南无地德佛　南无天德佛　南无不怯弱声佛　南无普现佛　南无月光明佛　南无胜信佛　南无决定色佛　南无方便心佛　南无智味佛　南无功德信佛　南无难降伏佛　南无普见佛　南无月光明佛　南无月盖佛　南无世桥佛　南无信供养佛　南无乐胜佛　南无善盖佛　南无惭愧贤佛　南无能观佛　南无师子声佛　南无大行佛　南无普信佛　南无器声佛　南无胜爱佛　南无普行佛　南无普智佛　南无大奋迅佛　南无月幢佛　南无坚行佛　南无天供养佛　南无能惊怖佛　南无胜称佛　南无成就一切功德佛　南无坚固佛　南无甘露光佛　南无大声佛　南无高声佛　南无大力佛　南无大尽佛　南无信甘露佛　南无行菩提佛　南无胜声思惟佛　南无高光佛　南无悕胜佛　南无乐种种声佛　南无爱义佛　南无修行信佛　南无离爱佛　南无善生佛　南无威德力佛　南无信功德佛　南无声称佛　南无放光明佛　南无疑奋迅佛　南无胜王佛　南无林华佛　南无功德华佛　南无舍诤佛　南无大广佛　南无大称佛　南无虚空爱佛　南无甘露奋迅佛　南无日聚佛　南无月声佛　南无天幢佛　南无与清净佛　南无能日佛　南无快可见佛　南无坚意胜声佛　南无雨甘露佛　南无无畏声佛　南无善根声佛　南无胜声佛　南无胜爱佛　南无甘露称佛　南无法花佛　南无大庄严佛　南无世间尊重佛　南无胜意佛　南无弥留光佛　南无清净思惟佛　南无高光明佛　南无破怨佛　南无甘露城佛　南无华光佛　南无大称佛　南无安隐恩佛　南无道威德佛　南无清净心佛　南无天供养佛　南无度泥佛　南无离有佛　南无法华佛　南无大胜佛　南无可乐光明佛　南无火光佛　南无见爱佛　南无光明爱佛　南无喜声佛　南无大施德佛　南无实步佛　南无无滞碍智佛　南无得威德佛　南无月藏佛　南无净光明佛　南无大庄严佛　南无得乐自在佛　南无妙光明佛　南无寂光佛　南无离疑佛　南无无过智慧佛　南无成就行佛　南无清净身佛　南无无畏爱佛　南无称吼佛　南无大吼佛　南无善思佛　南无大思佛　南无清净色佛　南无大奋迅佛　南无乐眼佛　南无命清净佛　南无行清净佛　南无离热智佛　南无应桥佛　南无善集智佛　南无普信佛　南无设尸威德佛　南无不死城佛　南无不护声佛　南无化日佛　南无善住思惟佛　南无高信佛　南无须摩那光明佛　南无光明力佛　南无功德希佛　南无法俱稣摩佛　南无净威德佛　南无净行佛　南无天色心佛　南无力王佛　南无普观佛　南无梵供养佛　南无圣花佛　南无虚空佛　南无降伏郁弥佛　南无无譬智佛　南无降伏刺佛　南无降伏城佛　南无应爱佛　南无戒功德佛　南无平等勿思佛　南无不怯弱心佛　南无精进信佛　南无高光明佛　南无闻智佛　南无无碍心佛　南无无畏光佛　南无甘露声佛　南无种种日佛　南无胜黠慧佛　南无可修敬佛　南无功德王佛　南无护根佛　南无禅解脱佛　南无大威德佛　南无栴檀香佛　南无见信佛　南无妙桥梁佛　南无可观佛　南无不可量智佛　南无千日威德佛　南无舍重担佛　南无称信佛　南无诸方闻佛　南无自在佛　南无无边智佛　南无无垢光佛　南无甘露信佛　南无妙眼佛　南无解脱行佛　南无可乐见佛　南无高光明佛　南无大声佛　南无大威德聚佛　南无光明幢佛　南无应供养佛　南无福德威德积佛　南无信相佛　南无大炎佛　南无应信佛　南无善住思惟佛　南无须提他佛　南无智作佛　南无普宝佛　南无日光佛　南无说提他佛　南无炎眼佛　南无师子身佛　南无称亲光佛　南无清净声佛　南无悕乐佛　南无寂静增上佛　南无宝威德佛　南无善威德供养佛　南无毛光佛　南无世间尊佛　南无善行净佛　南无菩提他威德佛　南无应眼佛　南无大步佛　南无成义佛　南无安隐爱佛　南无天摩私多佛　南无舍漫流佛　南无舍宝佛　南无智满佛　南无桥度佛　南无解脱贤佛　南无众步佛　南无光明威德佛　南无慈力佛　南无月胜佛　南无寂光佛　南无爱眼佛　南无赊尸罗声佛　南无不死色佛　南无乐法佛　南无大月佛　南无无障碍声佛　南无功德奋迅佛　南无不死华佛　南无平等见佛　南无大月佛　南无功德味佛　南无十光佛　南无种种光佛　南无龙德佛　南无云声佛　南无功德步佛　南无思功德佛　南无大声佛　南无了声佛　南无远离恶处佛　南无天华佛　南无快眼佛　南无大然灯佛　南无离痴行佛　南无坚固希佛　南无舍邪佛　南无相华佛　南无不可思议光明佛　南无普贤佛　南无月妙佛　南无乐德佛　南无清净声佛　南无胜慧佛　南无贤光佛　南无坚固花佛　南无光明意佛　南无福德德佛　南无意成就佛　南无乐解脱佛　南无离漂河佛　南无调怨佛　南无不去舍佛　南无甘露光明佛　南无无垢心佛　南无乐声佛　南无不可量眼佛　南无快修行佛　南无妙高光佛　南无集功德佛　南无可乐佛　南无大心佛　南无天(丹大)信佛　南无思惟甘露佛　南无黠慧佛　南无胜灯佛　南无坚意佛　南无力步佛　南无莲花叶眼佛　南无菩提光明佛　南无妙吼声佛　南无六通声佛　南无威德力佛　南无人称佛　南无胜华集佛　南无大髻佛　南无不随他佛　南无无畏行佛　南无不怯弱佛　南无离忧闇佛　南无过潮佛　南无月光佛　南无心勇猛佛　南无解脱慧佛　南无不取舍佛　南无薝卜灯佛　南无胜火佛　南无善思意佛　南无胜威德色佛　南无信世间佛　南无妙慧佛　南无善喜信佛　南无华光佛　南无人华佛　南无善香佛　南无胜功德佛　南无种种华佛　南无高胜佛　南无虚空功德佛　南无天信佛　南无可敬桥佛　南无月光佛　南无大聚佛　南无最力佛　南无智地佛　南无高意佛　南无山王智佛　南无快升佛　南无妙升佛　南无胜亲佛　南无离疑佛　南无应行佛　南无胜香佛　南无无诤行佛　南无修行功德佛　南无大精进心佛　南无然光明佛　南无摄步佛　南无修行深心佛　南无香希佛　南无香手佛　南无寂静智佛　南无妙心佛　南无功德庄严佛　南无增上行佛　南无智意佛　南无功德山清净声佛　南无摄集佛　南无妙信佛　南无月见佛　南无功德王光明佛　南无法不可力佛　南无离诸疑奋迅佛　南无称王佛　南无摄诸根佛　南无上去佛　南无甘露光佛　南无甘露心佛　南无诸众生上佛　南无净髻佛　南无不可降伏色佛　南无普信佛　南无庄严王佛　南无甘露日佛　南无胜灯佛　南无波头上佛　南无宝藏佛　南无普光佛　南无最胜王佛　南无普光明上胜积王佛　南无普现佛　南无普贤佛　南无还华胜佛　南无自在转法王佛　南无千世自在声佛　南无千善无垢声自在王佛　南无离千无畏声自在王佛　南无千无垢威德自在王佛　南无五百日声自在王佛　南无五百乐自在声佛　南无日龙欢喜佛　南无离畏称王佛　南无妙光幢佛　南无离光声佛　南无称自在声佛　南无妙法称声佛　南无胜藏称王佛　南无不可思议意王佛　南无宝幢佛　南无火自在佛　南无圣智自在幢勇猛王佛　南无不可思量佛　南无智藏佛　南无智高幢佛　南无智海王佛　南无大精进声自在王佛　南无弥留胜劫佛　南无智显修自在种子善无垢吼自在王佛　南无降伏功德海王佛　南无智成就力王佛　南无胜道自在王佛　南无胜闇积自在佛　南无华胜积智佛　南无金刚师子佛　南无戒胜佛　南无贤胜佛　南无无边光佛　南无师子喜佛　南无无尽智积佛　南无宝行佛　南无智波罗婆佛　南无师子称佛　南无智功德王佛　南无法华雨佛　南无能作光佛　南无高山佛　南无法妙王无垢佛　南无香自在无垢眼佛　南无集大碍佛　南无无障碍力王佛　南无自智福德力佛　南无智衣佛　南无自在佛　南无无量安隐佛　南无智集佛　南无大弥留佛　南无日藏佛　南无作功德庄严佛　南无花幢佛　南无功德光明佛　南无离功德闇王佛　南无功德王佛　南无法幢佛　南无声自在王佛　南无自护佛　南无金刚密迹佛　南无宝自在佛　南无妙幢佛　南无山劫佛　南无乐云佛　南无法作佛　南无莎罗王佛　南无普功德坚固王佛　南无栴檀佛　南无善住佛　南无善至佛　南无幢胜灯佛　南无智步佛　南无坚幢佛　南无散法称佛　南无降伏憍慢佛　南无功德炎佛　南无智光明佛　南无智然灯佛　南无无畏王佛　南无智声幢摄佛　南无金刚灯佛　南无庄严王佛　南无胜数佛　南无善住意佛　南无月王佛　南无次第降伏王佛　南无坚固自在王佛　南无师子步佛　南无那罗延胜藏佛　南无集宝藏佛　南无树提藏佛　南无星宿差别称佛　南无功德力坚固王佛　南无妙声佛　南无梵声佛　南无胜梵佛　南无坚固土佛　南无千香佛　南无波头摩胜王佛　南无光轮光佛　南无火光明王佛　南无香波头摩王佛　南无疾无边功德海智王佛　南无阎浮影佛　南无功德山幢佛　南无师子幢佛　南无龙吼佛　南无华威德王佛　南无善香种子佛　南无无我甘露功德威德王劫佛　南无复有八千同名无我甘露功德威德王劫佛　南无法智佛　南无龙自在解脱佛　南无金刚华佛　南无龙吼自在声佛　南无宝积佛　南无华照佛　南无火香佛　南无须摩那华佛　南无山王佛　南无世眼佛　南无净上佛　南无阎浮影佛　南无根本上佛　南无宝山佛　南无海藏佛　南无坚力佛　南无上圣佛　南无自在圣佛　南无拘邻佛　南无师子步佛　南无智幢佛　南无佛闻声佛　南无广胜佛　南无安隐佛　南无智光佛　南无大自在佛　南无寂世佛　南无手喜佛　南无尼拘律王佛　南无金眼佛　南无供养佛　南无日喜佛　南无宝炎佛　南无善眼佛　南无高净佛　南无净圣佛　南无吼声佛　南无见义佛　南无称喜佛　南无称胜佛　南无可喜佛　南无善香佛　南无疾行佛　南无妙眼佛　南无善胜佛　南无修义佛　南无善意佛　南无妙慧佛　南无金幢佛　南无善眼佛　南无天清净佛　南无输头檀佛　南无善见佛　南无毗留罗幢佛　南无毗楼博叉佛　南无梵声佛　南无成就胜佛　南无胜光明佛　南无无垢佛　南无摩尼跋陀佛　南无摩梨指佛　南无大摩梨指佛　南无能圣佛　南无声自在佛　南无赞叹成就佛　南无胜成就华佛　南无拘稣摩佛　南无不动佛　南无日藏佛　南无乐声佛　南无能作光佛　南无龙德佛　南无金刚光佛　南无称王佛　南无虎王佛　南无高光佛　南无发行佛　南无智成就佛　南无香自在佛　南无那罗延藏佛　南无火藏佛　南无破垢胜王佛　南无宝盖胜光佛　南无山自在王佛　南无宝月佛　南无师子奋迅幢自在王佛　南无实根广眼佛　南无世自在王佛　南无远离诸怖畏随烦恼声佛　南无敷华卢舍那佛　南无香波头摩佛　南无无垢功德威德王佛　南无不动佛　南无日藏佛　南无乐自在声火佛　南无智日佛　南无龙吼佛　南无金刚齿佛　南无月藏佛　南无胜自在佛　南无不可思议王佛　南无火胜藏佛　南无喜幢佛　南无无畏自在佛　南无见弥留佛　南无智像佛　南无无垢眼佛　南无无忧胜佛　南无法自在吼佛　南无法自在莎罗王佛　南无师子奋迅佛　南无那罗延佛　南无善择藏佛　南无宝集佛　南无功德奋迅佛　南无火藏佛　南无星宿称佛　南无功德力坚固王佛　南无妙吼声奋迅佛　南无莎罗胜黠王佛　南无威德自在光明佛　南无妙声吼佛　南无宝掌龙自在佛　南无法云吼自在平等佛　南无宝山佛　南无妙光藏佛　南无师子多罗称佛　南无普藏佛　南无净华佛　南无歌罗毗罗奋迅佛　南无法疾然灯佛　南无无等上弥留佛　南无称声王佛　南无梵帝释声佛　南无远离逼恼佛　南无毗沙门坚固王佛　南无破魔王宫佛　南无莎罗王佛　南无大奋迅光佛　南无华胜佛　南无栴檀佛　南无弥留王佛　南无拘罗伽坚固树提佛　南无智奋迅佛　南无二万同名月然灯佛　南无无垢身佛　南无波头摩光佛　南无华胜步佛　南无华光佛　南无称幢佛　南无阎浮檀金光佛　南无多摩罗跋叶栴檀香佛　南无大通智胜佛　南无不动佛　南无弥留山佛　南无师子吼佛　南无师子种(丹幢)佛　南无住虚空佛　南无常入涅槃佛　南无帝释幢佛　南无梵幢佛　南无无量寿佛　南无善度佛　南无多摩罗跋叶栴檀香通佛　南无弥留劫佛　南无云灯佛　南无云自在王佛　南无一切世间高佛　南无能破诸畏佛　南无释迦牟尼佛　南无法光明佛　南无五百普光明佛　南无大海住持智奋迅通佛　南无七宝波头摩步佛　南无二千宝幢佛　南无多宝佛　南无一切众生爱见佛　南无百千光明满足幢佛　南无二十亿千惊怖吼声王佛　南无二十亿百日月然灯佛　南无二十亿百妙声王佛　南无二十亿百云声王佛　南无宝威德高王佛　南无月无垢日光明胜佛　南无莲华叶星宿王花通佛　南无云妙鼓声王佛　南无住持水吼声佛　南无声星宿王拘稣摩通佛　南无莎罗树王佛　南无无垢光明佛　南无宝炎佛　南无华鬘林土华通佛　南无日月宝作光明佛　南无功德宝光明佛　南无宝林佛　南无云王佛　南无宝盖胜光明佛　南无普见佛　南无功德自在佛　南无师子声作佛　南无宝积示现佛　南无乐坚佛　南无菩提意佛　南无无量命佛　南无阿閦佛　南无香王佛　南无宝作佛　南无修行法佛　南无盖王佛　南无摩尼王佛　南无月藏佛　南无日藏佛　南无声身王佛　南无善觉佛　南无须弥劫佛　南无能圣佛　南无宝波头摩月清净胜王佛　南无不动佛　南无普满佛　南无无尽慧佛　南无宝幢佛　南无奋迅恭敬称佛　南无实幢佛　南无无垢光明藏佛　南无云护佛　南无师子奋迅佛　南无胜高山王佛　南无波头摩上佛　南无身上佛　南无多宝妙佛　南无胜藏山增上王佛　南无意勇猛仙行胜佛　南无甘露藏佛　南无妙鼓声王佛　南无日月佛　南无唯宝盖佛　南无普光明奋迅光王佛　南无能行成就圣佛　南无不动佛　南无无垢光明称王佛　南无九千法庄严佛　南无摩尼金盖佛　南无星宿佛　南无高山欢喜佛　南无菩提分华身佛　南无能修行佛　南无宝作佛　南无如宝佛　南无高聚佛　南无宝光明佛　南无宝来佛　南无宝高佛　南无阿閦佛　南无宝光明佛　南无大光明佛　南无不可量声佛　南无不可思议声佛　南无大称佛　南无宝照佛　南无得大无畏佛　南无宝声佛　南无无边清净佛　南无月声佛　南无无边称佛　南无月光清净佛　南无清净光佛　南无无垢光佛　南无无边宝佛　南无波头摩胜佛　南无身胜佛　南无金色佛　南无梵声王佛　南无金光明佛　南无金色作佛　南无龙自在王佛　南无金色华香自在王佛　南无坚固王佛　南无坚固勇猛仙行胜佛　南无胜藏摩尼光佛　南无无量香光佛　南无师子声佛　南无至大势精进修行毕竟佛　南无坚固智佛　南无妙鼓声王佛　南无月妙佛　南无华胜佛　南无世间灯佛　南无火佛　南无宝轮佛　南无无垢智佛　南无常寂灭佛　南无无边宝花光明佛　南无须弥山奋迅佛　南无宝华佛　南无集宝聚佛　南无不退轮宝住胜佛　南无德普卢舍那清净佛　南无日月灯佛　南无迷留佛　南无大弥留佛　南无须弥劫佛　南无香面佛　南无成就香佛　南无弥留香佛　南无清净光佛　南无法上佛　南无香自在王佛　南无大摩尼佛　南无香光佛　南无火光佛　南无甘露光佛　南无月光佛　南无月灯佛　南无月照佛　南无集声佛　南无胜作佛　南无多宝佛　南无师子吼佛　南无师子声佛　南无勇猛仙佛　南无金刚喜佛　南无护一切佛　南无离诸疑佛　南无宝炎眷属佛　南无无忧佛　南无住持速力佛　南无妙喜佛　南无自在作佛　南无无边声佛　南无然灯作佛　南无宝光明佛　南无阿弥陀佛　南无择说佛　南无择声佛　南无胜藏积吼王佛　南无降伏金刚坚佛　南无宝月光佛　南无宝大(丹火)佛　南无坚上佛　南无宝波头摩步佛　南无宝胜佛　南无金宝光佛　南无悕喜快胜佛　南无不可量胜佛　南无善逝王佛　南无圣自在手佛　南无不可说分别佛　南无不空胜佛　南无月妙胜佛　南无树提胜佛　南无虚空光明佛　南无善清净无垢间错幢佛　南无善住善根藏王佛　南无成就一切义胜佛　南无智功德清净胜佛　南无善说清净幢佛　南无琉璃藏上胜佛　南无普功德奋迅佛　南无善清净功德宝住佛　南无宝光明清净心胜佛　南无金上胜佛　南无胜月佛　南无波头摩上奋迅胜佛　南无波头摩上佛　南无宝成就胜佛　南无电光幢(丹本有王)佛　南无电光明高王佛　南无多罗王佛　南无妙胜佛　南无雷虚空然灯佛　南无成就一切功德佛　南无贤高幢王佛　南无住持一切宝间错庄严佛　南无宝光明庄严智威德声自在王佛　南无俱苏摩大奋迅通佛　南无敷华莎罗王佛　南无月轮清净佛　南无善寂智月声自在王佛　南无阿僧祇精进住胜佛　南无波心炎佛　南无山功德幢王佛　南无法幢山佛　南无须弥山佛　南无功德师子自在佛　南无寂王佛　南无净王佛　南无称山佛　南无功德须弥胜佛　南无日佛　南无月面佛　南无离虚空畏佛　南无普光佛　南无方成佛　南无住海面佛　南无宝光佛　南无云胜佛　南无法炎佛　南无山功德佛　南无华生佛　南无大悲佛　南无法界华佛　南无华幢佛　南无王意佛　南无王慧佛　南无智慧佛　南无心义佛　南无自在佛　南无胜天意佛　南无速王佛　南无光明幢胜佛　南无高威德去佛　南无华光佛　南无宝炎佛　南无功德山佛　南无宝实佛　南无功德海胜佛　南无法光明佛　南无华藏胜佛　南无世间月佛　南无眼日佛　南无香光佛　南无摩尼须弥胜佛　南无乾闼婆王佛　南无光明命佛　南无摩尼藏王佛　南无山威德慧佛　南无寂色去佛　南无面报佛　南无广智佛　南无宝光明佛　南无虚空重胜佛　南无妙相光明佛　南无行轮自在佛　南无身自在佛　南无那罗延行佛　南无须弥胜佛　南无功德转轮佛　南无山王佛　南无不可胜佛　南无快威德佛　南无树山佛　南无莎罗王山藏佛　南无世自在身佛　南无镜光佛　南无实(丹宝)起佛　南无自在胜佛　南无功德光佛　南无天地威德胜佛　南无身法光明佛　南无胜王佛　南无坚吼意佛　南无高幢胜佛　南无信意佛　南无宝光明佛　南无净胜佛　南无虚空声佛　南无法界镜像胜佛　南无照轮光明佛　南无方差别佛　南无智光明佛　南无忆(丹幢)意佛　南无虚空然灯佛　南无无病胜佛　南无(丹本有智)照佛　南无(丹本有慧)明佛　南无福德光明胜佛　南无寂胜佛　南无大悲云胜佛　南无力光明意佛　南无现一切众生色佛　南无过胜佛　南无修光明佛　南无昙无竭佛　南无风疾行胜佛　南无清净幢佛　南无妙盖胜佛　南无三世镜像胜佛　南无镜像坚佛　南无镜像胜佛　南无金刚胜佛　南无身坚庄严须弥胜佛　南无金幢王佛　南无身法慧佛　南无智慧然灯光明胜佛　南无广智胜佛　南无法行世智意佛　南无法印意智胜佛　南无法海意智胜佛　南无法财佛　南无宝财佛　南无福德功德佛　南无转法轮胜佛　南无云佛　南无忍辱灯佛　南无胜威德意佛　南无光明速寂声佛　南无大愿速胜佛　南无不可降伏幢佛　南无智炎佛　南无成就胜佛　南无法自在佛　南无不可成就意佛　南无世间言语坚固声光佛　南无一切声出声胜佛　南无自在功德佛　南无成就自在意佛　南无方天佛　南无不面舍佛　南无众生心佛　南无平等身佛　南无身行胜佛　南无行胜佛　南无自在性佛　南无山王佛　南无智光佛　南无千亿宝庄严佛　南无宝胜佛　南无信王佛　南无宝积佛　南无香自在佛　南无降伏怨佛　南无安隐佛　南无能与依止佛　南无无边威德佛　南无金色光佛　南无师子奋迅佛　南无甘露光佛　南无能圣成佛　南无普光佛　南无功德胜积王佛　南无善住摩尼积王佛　南无远离诸畏树安隐佛　南无饮甘露佛　南无无边光佛　南无宝高佛　南无无边庄严王佛　南无离怨佛　南无金色光佛　南无宝作佛　南无无尘胜佛　南无师子声王佛　南无宝幢佛　南无善心佛　南无高住佛　南无华王佛　南无智作佛　南无海智佛　南无欢喜佛　南无乐庄严佛　南无离闇佛

佛说佛名经卷第五佛说佛名经卷第六

        后魏北印度三藏菩提流支译

南无坚城佛　南无见细佛　南无无畏德佛　南无生王佛　南无实语佛　南无称上佛　南无择智佛　南无不行威德佛　南无人华佛　南无远离诸畏佛　南无能与无畏佛　南无金华佛　南无无畏作佛　南无不空见佛　南无宝华佛　南无六十宝作佛　南无宝精佛　南无金华佛　南无降伏王佛　南无善光佛　南无见义佛　南无大择(丹释)佛　南无妙无畏佛　南无大慈佛　南无不可降伏王佛　南无难胜佛　南无上首佛　南无法上佛　南无胜一切佛　南无高行佛　南无高称佛　南无胜圣佛　南无星宿佛　南无识佛　南无商佛　南无闻名佛　南无大悲说佛　南无无量寿佛　南无无边盖光明胜佛　南无山积光明胜佛　南无无垢力三昧奋迅胜佛　南无一切功德王光明佛　南无火众佛　南无须弥劫佛　南无坚自在王佛　南无梵吼声佛　南无弥楼聚佛　南无善明(丹眼)佛　南无成就聚佛　南无离愚奋迅佛　南无无碍眼佛　南无宝幢佛　南无释迦牟尼佛　南无功德胜藏佛　南无难胜佛　南无乐说庄严佛　南无胜藏积吼王佛　南无无边功德宝庄严威德王劫佛　南无功德宝胜威德王劫佛　南无乐说一切法庄严胜佛　南无无(丹有边)乐说相佛　南无千云吼声王佛　南无金上光明胜佛　南无种种威德王光明胜佛　南无觉(丹本有王)佛　南无清净金虚空吼庄严光明佛　南无一切法行威德奋迅光明佛　南无东方无边功德宝福德庄严广世界无垢清净光明菩提分俱苏摩不断绝光明庄严光佛　南无南方乐说佛世界无边功德宝乐说佛　南无西方光明世界普光佛　南无北方一切宝种种庄严世界无边宝功德自在佛　南无东南方无忧世界离一切幽闇佛　南无西南方善可见世界大悲观一切众生佛　南无西北方住清净无垢世界虚空无垢佛　南无东北方远离闇世界光明庄严王佛　南无下方卢舍那光明世界宝忧波罗胜佛　南无上方庄严世界称名声佛　南无无垢劫无垢世界无垢光如来初成佛彼世界尘沙诸佛出世　南无无垢广世界名成就善劫胜护如来初成佛彼世界尘沙诸佛出世

南无东方阿閦佛　南无大不迷佛　南无香王佛　南无香上佛　南无南方宝幢佛　南无宝作佛　南无宝成佛　南无宝藏佛　南无宝月佛　南无金刚坚佛　南无金刚仙佛　南无金刚幢佛　南无东南方大弥留佛　南无弥留山佛　南无弥留王佛　南无弥留幢佛　南无弥留积佛　南无善弥留王佛　南无日藏佛　南无前后上佛　南无净王佛　南无鸡中幢王佛　南无大鸡中佛　南无西方阿弥陀佛　南无阿弥幢佛　南无阿弥陀声佛　南无阿弥称佛　南无阿弥陀吼佛　南无阿弥积佛　南无阿弥陀胜上佛　南无阿弥陀师子佛　南无阿弥陀住持佛　南无阿弥陀胜佛　南无西南方日藏佛　南无日光明佛　南无无忧佛　南无离一切忧佛　南无佛智清净业佛　南无尽作佛　南无华(丹本有光)佛　南无大华佛　南无华王佛　南无华声佛　南无卢舍那佛　南无北方妙鼓声佛　南无妙鼓王佛　南无妙吼声佛　南无离诸畏佛　南无无畏佛　南无无畏忧佛　南无日舌光明作佛　南无曼陀香佛　南无幢盖佛　南无华上佛　南无西北方上首积佛　南无山胜积佛　南无海胜积佛　南无日上佛　南无清净王佛　南无净胜佛　南无日面佛　南无智幢王佛　南无光明佛　南无光明王佛　南无光明光佛　南无上方师子佛　南无师子王佛　南无师子上王佛　南无师子积佛　南无师子仙佛　南无仙王佛　南无(丹本有华)仙佛　南无仙光佛　南无仙舍敬佛　南无仙觉佛　南无大灯佛　南无然灯王佛　南无乐说山佛　南无灯譬喻佛　南无对治仙佛　南无觉净(丹诤)佛　南无对治佛　南无对恨佛　南无对治山佛　南无爱然灯佛　南无依止佛　南无东方阿閦佛　南无弥留幢佛　南无大弥留佛　南无弥留光佛　南无真声佛　南无南方日月灯佛　南无大火聚佛　南无称光佛　南无弥留灯佛　南无无边精进佛　南无西方阿弥陀佛　南无阿弥陀幢佛　南无阿弥陀高佛　南无大火光明佛　南无大照佛　南无宝幢佛　南无香聚佛　南无上方大光明焰聚佛　南无火声佛　南无难胜佛　南无日成就佛　南无罗网光佛　南无下方师子佛　南无称(丹本有王)佛　南无威德佛　南无法(丹本有顶)佛　南无法幢佛　南无法住持佛　南无东方梵声佛　南无星宿王佛　南无香上佛　南无香光佛　南无大焰聚佛　南无宝种种华敷身佛　南无坚王佛　南无宝莲华胜佛　南无见一切义佛　南无须弥劫佛　南无声吼佛　南无智自在佛　南无威德自在佛　南无莎罗自在王佛　南无智勇猛佛　南无光自在佛　南无坚自在王佛　南无声德佛　南无师子奋迅鬘佛　南无须弥山然灯王佛　南无香山佛　南无不可动佛　南无药王佛　南无寻光佛　南无大焰积佛　南无胜藏佛　南无无心光明佛　南无毗留罗佛　南无莲华佛　南无喜聚佛　南无栴檀佛　南无月光佛　南无惊怖幢佛　南无大修行佛　南无波头摩生(丹王)佛　南无月胜佛　南无莎罗集佛　南无大莎罗集佛　南无幢(丹本有相)佛　南无净命佛　南无金台佛　南无爱见佛　南无金色色佛　南无须摩那光佛　南无妙莲华劫亿那由他百千万佛同名一切菩提华佛　南无七百同名光庄严佛　南无三百同名大幢佛　南无十千同名庄严王佛　南无善发胜佛　南无日轮光明佛　南无普盖佛　南无三昧奋迅佛　南无宝华胜佛　南无无边足步佛　南无善香香王佛　南无善择敌佛　南无须弥劫佛　南无功德王光明佛　南无普至光佛　南无金刚佛　南无尼弥佛　南无不可尽世界一(丹本有切)色佛　南无袈裟幢世界山自在王佛　南无坚幢世界智胜山王佛　南无一切香举世界胜华藏佛　南无金刚摩尼世界金刚藏光明胜佛　南无智成就世界智幢佛　南无意味(丹昧)世界普照佛　南无波头摩首世界佛胜佛　南无镜轮世界金刚幢佛　南无光明清净力世界日藏佛　南无安乐世界最力佛　南无阿閦佛　南无宝幢佛　南无无量光佛　南无妙声佛　南无宝俱苏摩功德海琉璃歌那伽山真金光明胜佛　南无释迦牟尼佛　南无宝焰佛　南无金作盖山佛　南无毗婆尸佛　南无光尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含佛　南无迦叶佛　南无三昧手胜佛　南无无垢奋迅菩萨

若善男子善女人。受持是佛菩萨名。超越世间三十劫

南无日轮光明胜佛　南无日光明菩萨

若人受持是佛菩萨名。超越世间千劫

南无普宝盖佛

若善男子。受持是佛名。是人超越世间四大劫。常现诸佛菩萨前生。不复作五逆罪

南无三昧胜奋迅佛

若善男子。受持是佛名。得千三昧。超越世间无量千劫。同弥勒菩萨功德

南无宝俱苏摩身光明胜佛

若人受持读诵是佛名。超越世间不可数劫

南无最胜波头摩奋迅胜佛

若人受持是佛名。超越世间四十劫

南无无量香胜王佛

若善男子。受持是佛名。超越世间无量劫常得宿命

南无宝华奋迅如来

若人受持读诵是佛名。得千三昧。诸众生归命。是人为诸佛如来所赞叹。是人超越世间千劫。不久转法轮

南无大光明如来

若善男子。受持是佛名。超越世间四十劫

南无宝藏佛

若善男子。受持是佛名。超越世间六十劫

南无宝胜佛

若善男子。受持是佛名。若复有人。舍七宝如须弥山。以用布施。及恒河沙世界。若复有人。受持读诵是佛名。此福胜彼

南无名降伏魔人胜佛　南无降伏贪人自在佛　南无降伏嗔人胜佛　南无降伏痴自在佛　南无降伏染魔人胜佛　南无降伏恨自在佛　南无降伏嫉人胜佛　南无降伏谄曲自在佛　南无降伏邪见人胜佛　南无降伏戏自在佛　南无法清净人胜佛　南无业胜得名自在佛　南无如意通清净得名人胜佛　南无起施得名自在佛　南无起持戒清净得名人胜佛　南无起忍辱得名自在佛　南无起精进得名人胜佛　南无施思惟得名自在胜佛　南无起(丹本有持)戒思惟得名人胜佛　南无法忍辱思惟得名自在佛　南无起思惟精进得名人胜佛　南无起禅成就自在佛　南无起般若得名人胜佛　南无禅思惟得名自在佛　南无般若思惟得名人胜佛　南无行不可思议得名自在胜佛　南无行不可思议得名人胜佛　南无行起得名自在佛　南无总持智清净光明人胜佛　南无总持色清净得名自在佛　南无总持两(丹雨)清净得名人胜佛　南无陀罗尼性清净自在胜佛　南无陀罗尼称清净得名人胜佛　南无陀罗尼施清净得名自在(丹胜)佛　南无空行得名人胜佛　南无空无我得名自在佛　南无眼光明人胜佛　南无耳光明人自在佛　南无鼻光明人胜佛　南无舌光明自在佛　南无身光明人胜佛　南无心光明自在佛　南无色光明人胜佛　南无声光明自在佛　南无降伏香人胜佛　南无味光明自在佛　南无触光明人胜佛　南无法光明自在佛　南无焰光明人胜佛　南无赞叹光明自在佛　南无火光明人胜佛　南无风光明自在佛　南无光光明人胜佛　南无事光明自在佛　南无世光明人胜佛　南无拔苦自在佛　南无阴光明人胜佛　南无戒光明自在佛　南无不二光明人胜佛　南无生光明自在佛　南无声光明人胜佛　南无地华光明自在佛　南无鬘光明人胜佛　南无香盖光明自在佛　南无依光明人胜佛　南无成就义佛　南无无畏王佛　南无不动佛　南无观世自在佛　南无无量命佛　南无尼弥佛　南无焰弥留佛　南无金刚佛　南无初出日然灯月华宝波头摩金光明身卢舍那放无碍宝光明照十方世界王佛　南无降伏龙佛　南无善调心佛　南无宝聚佛　南无火首佛　南无焰积佛　南无一切光明佛　南无日光佛　南无不可思议佛　南无无边精进佛　南无无边思惟佛　南无金色华佛　南无善香香佛　南无(丹本有无)诤行佛　南无无漏佛　南无无边智佛　南无贤身佛　南无贤(丹本有相)佛　南无(丹本有遍)见佛　南无无边威德佛　南无次佛　南无坚安隐佛　南无莎罗佛　南无得名佛　南无波头摩胜佛　南无称莲华佛　南无华佛　南无庄严佛　南无奋迅佛　南无善见佛　南无善敌对佛　南无善护世佛　南无无边威德佛　南无第一胜佛　南无善行佛　南无无量威德佛　南无妙胜佛　南无胜供养佛　南无火奋迅智声自在王佛　南无电光佛　南无照一切佛　南无不可思议佛　南无无量色佛　南无无量光佛　南无善光华敷身佛　南无须弥山波头摩胜王佛　南无求名发声修行佛　南无一切宝摩尼王放光明佛　南无无垢焰称成就王佛　南无香宝光明佛　南无离诸烦恼佛　南无善智佛　南无善见佛　南无宝山庄严佛　南无慈行佛　南无阎浮檀幢佛　南无无边智佛　南无无量威德佛　南无大称佛　南无宝称佛　南无火光明佛　南无大光明佛　南无电照光明佛　南无一切种照佛　南无不可量佛　南无日光佛　南无月光佛　南无功德海佛　南无具足功德佛　南无上行佛　南无无畏佛　南无师子幢佛　南无帝释幢佛　南无火幢佛　南无善眼佛　南无庄严王佛　南无放光明光佛　南无无边光佛　南无妙光佛　南无普护增上佛　南无云自在佛　南无自在幢佛　南无日灯佛　南无最上佛　南无善生佛　南无无边不可思议威德佛　南无普眼佛　南无波头摩上佛　南无妙去佛　南无月起佛　南无灯明佛　南无不厌足身佛　南无弥留幢佛　南无宝幢佛　南无火焰聚佛　南无自在幢佛　南无宝火佛　南无栴檀香佛　南无不定光明波头摩敷身佛　南无无边称功德光明佛　南无薝卜色佛　南无无量光明(丹有德)佛　南无快光明波头摩敷身佛　南无出须弥山波头摩王佛　南无星宿劫二万同名光作佛　南无二万同名卢舍那佛　南无二万同名释迦牟尼佛　南无同名帝释日太白星宿无量百千万不可数佛　善男子应归命诸菩萨　南无普贤菩萨　南无文殊师利菩萨　南无无垢称菩萨　南无地藏菩萨　南无虚空藏菩萨　南无观世音菩萨　南无大势至菩萨　南无香象菩萨　南无大香象菩萨　南无药王菩萨　南无药上菩萨　南无金刚藏菩萨　南无解脱月菩萨　南无弥勒菩萨　南无奋迅菩萨　南无无所发菩萨　南无陀罗尼自在王菩萨　南无无尽意菩萨　南无坚意菩萨　南无日藏菩萨

归命如是等无量无边菩萨

南无东方九十九亿百千万同名梵胜菩萨　南无南方九十九亿百千万同名不邻陀罗菩萨　南无西方九十九亿百千万同名大功德菩萨　南无北方九十九亿百千万同名大药王菩萨

归命如是等十方世界无量无边菩萨

复次应称辟支佛名　南无阿利多辟支佛　南无婆梨多辟支佛　南无多伽楼辟支佛　南无称辟支佛　南无见辟支佛　南无爱见辟支佛　南无觉辟支佛　南无乾陀罗辟支佛　南无无妄辟支佛　南无梨沙婆辟支佛　南无闻辟支佛　南无智身辟支佛　南无毗耶离辟支佛　南无俱萨罗辟支佛　南无婆薮陀罗辟支佛　南无无毒净心辟支佛　南无实无垢辟支佛　南无福德辟支佛　南无黑辟支佛　南无唯黑辟支佛　南无直福德辟支佛　南无识辟支佛　南无香辟支佛　南无有香辟支佛　南无见人飞腾辟支佛　南无可波罗辟支佛　南无秦摩利辟支佛　南无月净辟支佛　南无善智辟支佛　南无修陀罗辟支佛　南无善法辟支佛　南无应求辟支佛　南无[髟/甘](丹鬘)求辟支佛　南无大势辟支佛　南无修行不着辟支佛　南无难舍辟支佛　南无实辟支佛　南无不可比辟支佛　南无欢喜辟支佛　南无喜辟支佛　南无随喜辟支佛　南无十二婆罗堕辟支佛　南无十同名婆罗辟支佛　南无火身辟支佛　南无同名菩提辟支佛　南无摩诃男辟支佛　南无心上辟支佛　南无发净辟支佛　南无善快辟支佛　南无违陀辟支佛　南无吉沙辟支佛　南无忧波吉沙辟支佛　南无断有辟支佛　南无忧波支罗辟支佛(丹无上支)　南无断爱辟支佛　南无施婆罗辟支佛　南无转觉辟支佛　南无去垢辟支佛　南无高去辟支佛　南无阿悉多辟支佛　南无无漏辟支佛　南无憍慢辟支佛　南无尽憍慢辟支佛　南无亲辟支佛　南无得脱辟支佛　南无无垢辟支佛　南无独辟支佛　南无鸡昼辟支佛　南无能作憍慢辟支佛　南无退辟支佛　南无不退去辟支佛　南无寻辟支佛　南无善吉辟支佛　南无不可心辟支佛　南无善住辟支佛　南无无比辟支佛　南无无憍慢辟支佛　南无劬多辟支佛　南无断爱辟支佛　南无耳辟支佛　南无心得解脱辟支佛　南无忧波耳辟支佛　南无吉辟支佛　南无差摩辟支佛　南无遮罗辟支佛　南无忧波遮罗辟支佛　南无梨沙婆辟支佛　南无菩莎他净辟支佛　南无善香担辟支佛　南无阿沙罗辟支佛　南无忧婆沙罗辟支佛　南无波头辟支佛　南无善贤辟支佛　南无贤德辟支佛　南无须摩辟支佛　南无输那辟支佛　南无留阇辟支佛　南无忧波留阇辟支佛　南无弗沙辟支佛　南无牛齿辟支佛　南无漏尽辟支佛　南无最后身辟支佛

归命如是等无量无边辟支佛

南无无垢光明佛　南无功德宝光明佛　南无精进力成就佛　南无清净光佛　南无解脱一切缚佛　南无波头摩藏胜佛　南无得无障碍力解脱佛　南无不怯弱十方称香佛　南无卢舍那光明佛　南无宝聚佛　南无法幢悬佛　南无破一切闇曀佛　南无普光明庄严照作佛　南无光明作佛　南无大焰佛　南无无边行功德佛　南无法功德云然灯佛　南无然灯炬王佛　南无破一切众生闇胜佛　南无妙见佛　南无妙胜佛　南无妙闻佛　南无山峰佛　南无金圣佛　南无饮甘露佛　南无无量光明佛　南无宝鸡头佛　南无无边毗尼胜王佛　南无电照光明罗网佛　南无成就无量功德佛　南无无量乐说境界佛　南无智胜放光明佛　南无降伏电日月作光佛　南无普句素摩胜奋迅功德积佛　南无功德王光佛　南无善月佛　南无光庄严王佛　南无赊舍施鸡头佛　南无福德光佛　南无普光上胜山王佛　南无善住摩尼山王佛　南无断一切烦恼佛　南无释迦牟尼佛　南无破碎金刚坚固佛　南无宝炽佛　南无龙自在王佛　南无勇猛仙佛　南无宝月佛　南无离垢佛　南无无垢佛　南无勇猛得佛　南无净佛　南无梵德佛　南无婆楼那佛　南无婆楼那天佛　南无贤胜佛　南无栴檀胜佛　南无力士佛　南无欢喜威德胜佛　南无光明胜佛　南无无忧胜佛　南无句素摩胜佛　南无波头摩树提奋迅勇(丹胜)佛　南无财胜佛　南无念胜佛　南无善说名胜佛　南无因陀罗鸡头幢佛　南无步胜佛　南无善觉步胜佛　南无善步去佛　南无普照庄严胜佛　南无宝华步佛　南无宝波头摩善住山自在王佛　南无光明幢火众生庄严光王佛　南无妙平等法界智起声佛　南无广福德藏普光明照佛　南无普照大应罗网卢舍那佛　南无卢舍那华眼电光佛　南无最胜大师子意佛　南无到法界胜光卢舍那王佛　南无常无垢功德遍至称佛　南无日华胜王佛　南无法自在智幢佛　南无广喜无垢威德梵声佛　南无根本胜善导师佛　南无智力佛　南无弥楼威德佛　南无愿清净月光佛　南无法海愿出声光佛　南无宝功德相庄严作光佛　南无妙声地主天佛　南无胜进寂去佛　南无见众生欢喜佛　南无不动深光明卢舍集慧佛　南无普放光明不可思议王佛　南无平等妙功德威德佛　南无速光明梵眼佛　南无解脱精进日光明佛　南无普法身觉慧佛　南无普门照一切众生门见佛　南无迦那迦无垢光明日焰云佛　南无因陀罗光明疑幢佛　南无一切地处无垢月佛　南无觉虚空平等相佛　南无十方广应云幢佛　南无平等不平等卢舍那佛　南无害心悲解脱空王佛　南无成就一切义须弥佛　南无不空步照见佛　南无妙吼胜佛　南无第一自在通王佛　南无不可思议功德卢舍那妙月佛　南无可信力幢佛　南无法界树声智慧佛　南无波头摩光长善臂佛　南无不退功德海光佛　南无普生妙一切智速佛　南无师子光无量力智佛　南无见一切法清净胜智佛　南无远离一切忧恼佛　南无自在妙威德佛　南无金刚花火光佛　南无观法界奋迅佛　南无然树紧那罗王佛　南无然香灯佛　南无应王佛　南无如来功德普门见佛　南无一切法普奋迅王佛　南无广化自在佛　南无法界解脱光明不可思议意佛　南无如来无垢光佛　南无卢舍那世间轮胜声佛　南无波头摩鬘无边眼佛　南无喜乐成佛　南无一切智行境界慧佛　南无广寂妙声佛　南无虚空无垢智月佛　南无福德海厚云相花佛　南无能作喜胜王(丹云)佛　南无胜声吼幢佛　南无观眼奋迅佛　南无无尽智金刚佛　南无普眼日藏照佛　南无一切吼声佛　南无无量智敷佛　南无一切福德弥楼上佛　南无根日威德佛　南无满光明身光佛　南无地第一相花佛　南无云无畏见佛　南无平等言语鸡头佛　南无实然灯王佛　南无坚精进奋迅成就义心佛　南无普照观称佛　南无慈光明称胜佛　南无福德称上胜佛　南无念一切众生称胜佛　南无须弥步称胜佛　南无毕惭愧称上胜佛　南无教化一切世间佛　南无离一切忧佛　南无离一切难佛　南无离一切世间佛　南无能转胎佛　南无转女佛　南无转男女降伏佛　南无佛华胜上王佛　南无不空说名佛　南无善慧法通王佛　南无十方广功德称无尽乐佛　南无爱大智见不空闻名佛　南无无量力智胜佛　南无成就梵功德佛　南无香象佛　南无金刚密迹佛　南无善转成就义佛　南无卢舍那化胜威德佛　南无常功德然灯去慧佛　南无到诸疑彼岸月佛　南无到法界无量声慧佛　南无然灯胜光明佛　南无法界日光明佛　南无无边无中功德海转法轮声佛　南无日不可思议智见佛　南无宝胜光明威德王佛　南无无尽功德妙庄严佛　南无不可量力普吼佛　南无普眼满足然灯佛　南无胜功德炬佛　南无大龙声佛　南无波头摩师子座奋迅齐佛　南无智聚觉光佛　南无住持地善威德王佛　南无善住法然灯王佛　南无不空见生喜作佛　南无放身焰幢佛　南无清净众生行佛　南无一切德云普光明佛　南无敷花相月智佛　南无第一光明金庭燎佛　南无观一切法海无差别光明佛　南无化日佛　南无宝盖胜卢舍那佛　南无善思惟佛　南无精进胜坚慧佛　南无敷花心波头摩佛　南无清净眼佛　南无月光自在佛　南无无尽法海宝幢佛　南无金刚波头摩胜佛　南无广俱苏摩作佛　南无人自在幢佛　南无一切智轮照卢舍那佛　南无龙称无量功德佛　南无宝功德鬘光佛　南无一切力庄严慧佛　南无宝焰须弥山佛　南无一切行光明胜佛　南无一切波罗蜜海佛　南无宝焰面门幢佛　南无成就一切愿光明佛　南无广得一切法齐佛　南无光明罗网胜佛　南无宝山幢佛　南无无边中智海藏佛　南无清净一切义功德幢佛　南无一切通首王佛　南无无障碍一切法界卢舍那佛　南无胜三昧精进慧佛　南无无碍法界然灯佛　南无无碍法界须弥幢胜王佛　南无菩提分俱苏摩作王佛　南无得世间功德大海佛　南无宝师子力佛　南无普智海王佛　南无波头摩善化幢佛　南无无尽光明普门声佛　南无普功德云胜威德佛　南无胜慧海佛　南无智月花云佛　南无香光威德佛　南无普门见无障碍清净佛　南无不可降伏法自在慧佛　南无波头摩光明敷王佛　南无大精进善智慧佛　南无坚王幢佛　南无不可降伏妙威德佛　南无精进德佛　南无一切功德胜心王佛　南无善成就无边功德王佛　南无断诸疑广善眼佛　南无妙功德胜慧佛　南无过诸光明胜光明佛　南无须弥山然灯佛　南无无尽化善云佛　南无无量光明化王佛　南无白(丹自)智梵行佛　南无师子眼焰云佛　南无大海天焰门佛　南无觉佛智胜佛　南无无量味大圣佛　南无无垢速云闻佛　南无满法界卢舍那佛　南无金色华佛　南无大功德花敷无垢佛　南无照胜威德王佛　南无不住眼无垢佛　南无无碍庄严佛　南无法智差别佛　南无转灯轮幢佛　南无法界轮佛　南无一切佛宝胜王佛　南无无边光明智轮幢佛　南无无著智幢佛　南无师子佛　南无月智佛　南无智佛　南无日照佛　南无常放普光明舌功德海王佛　南无无边光明法界庄严王佛　南无长臂佛　南无高见佛　南无无垢地平等光明世界普照十方光明声吼虚空卢舍那佛　南无清净花池庄严世界普门见妙光明佛　南无无边功德住持世界无边功德普光佛　南无弥留胜然灯世界普光明虚空镜像佛　南无一切妙声善爱闻世界喜乐见华火佛　南无妙声庄严世界宝须弥山(丹本有然)灯佛　南无一切宝色庄严光明照世界善化法界声幢佛　南无香藏金刚庄严世界金刚光明电声吼佛　南无焰声世界不可降伏力月佛　南无宝波头摩间错庄严无垢世界法城慧吼声佛　南无能与乐世界十方世界广称名智灯佛　南无手无垢善无垢罗网世界师子光明满足功德大海佛　南无妙华幢照世界大智敷花光明佛　南无无量庄严间错世界高智种种花光明佛　南无无边庄严世界普满法界幢眼佛　南无宝昼普光庄严世界妙慧上首佛　南无鬘王世界作月光明幢佛　南无无垢藏庄严世界善觉梵威德佛　南无宝光明身世界一切种力虚空然灯佛　南无宝首璎珞成就世界一切诸波罗蜜相大海威德佛　南无轮尘普盖世界断一切着喜作佛　南无宝鬘妙幢世界大称广功德吼照佛　南无不可思议庄严普庄严光明世界无差别智光明功德海佛　南无无尽光明择幢世界无边法界无垢光明佛　南无放宝焰花世界清净宝镜像佛　南无威德焰藏世界无障碍奋迅光明吼佛　南无宝轮平等光庄严世界普宝光明佛　南无栴檀树鬘幢世界清净一切念无碍光明佛　南无佛国土色轮善修庄严世界广喜见光明智慧佛　南无微细光明庄严照世界法界奋迅善观佛　南无无边色形相世界无障碍智成就佛　南无普焰云火然世界不退转法轮吼佛　南无种种宝庄严清净轮世界清净色相华威德佛　南无究竟善修世界无障碍日眼佛　南无善作坚固金刚座成就胜世界过法界智身光明佛　南无十方庄严无障碍世界宝广炬佛　南无差别色光明世界普光明花云王佛　南无宝门种种幢世界普见妙功德光明佛　南无摩尼顶作鬘光明世界普十方声云(丹本有作)佛　南无自在摩尼金刚藏世界智胜须弥王佛　南无摩尼衣座成就胜世界施香光明功德宝庄严佛　南无华忧波罗庄严世界普智幢声王佛　南无宝庄严种种藏世界一切法无畏然灯佛　南无香胜无垢光明世界普喜速胜王佛　南无日幢乐藏世界普门智卢舍那吼佛　南无香庄严快藏世界无量功德海光明佛　南无宝师子火光明世界法界电光佛　南无相快照世界无障碍功德称解脱光明王佛　南无功德成就光明照世界清净眼无垢然灯佛　南无种种香花胜庄严世界师子光明胜光佛　南无宝庄严平等光明世界广光明智胜幢佛　南无种种光明鬘(丹髻)快世界金光明无量力日成就佛　南无放光句素摩沉沦世界香光明喜力坚固佛　南无光明清净种种作世界光明力坚固佛　南无光明清净种种作世界普光明大自在幢佛　南无句素弥多焰轮庄严世界喜海庄严功德称自在王佛　南无地成就威德世界广称智海幢佛　南无放声吼世界相光明月佛　南无金刚幢世界一切法海胜王佛　南无无量功德庄严世界无量众生功德法住佛　南无光明照世界梵自在胜佛　南无生无垢光明世界妙法界胜吼佛　南无种种光明照然灯世界不可嫌力普光明幢佛　南无照平等光明世界无垢功德日眼佛　南无宝作庄严藏世界无障碍智普照十方佛　南无无尘世界无量胜行幢佛　南无清净光明世界法界虚空平等光明照佛　南无宝藏波浪胜成就世界功德相云胜威德佛　南无宫殿庄严幢世界卢舍那胜顶光明佛　南无鬘胜藏世界一切法无边海慧佛　南无善化香胜世界相法化普光佛　南无快地色光世界善眷属卢舍那佛　南无善作敷世界法行喜无尽慧佛　南无胜福德威德轮世界无垢清净普光明佛　南无摩尼宝波头摩庄严世界清净眼花胜佛　南无焰地成就世界无量力成就慧佛　南无梵照世界虚空广眼月佛　南无声尘平等世界金色然弥楼然灯佛　南无宝色庄严世界智胜妙法界光明佛　南无金色善光明世界宝然灯普光明幢佛　南无卢舍那光明世界火胜花奋迅善照佛　南无宝月作藏世界无尽功德华威德佛　南无镜光明照世界行力甘露吼声佛　南无妙栴檀快月庄严世界(丹本有妙)法智慧(丹本有胜)威德光明佛　南无无边功德聚集世界无边精进明功德胜王佛　南无大庄严成就世界日灯王佛　南无波头摩跋提世界普华佛　南无摩梨支世界卢舍那佛　南无清净行世界那罗延花幢佛　南无有华世界波头摩威德佛　南无有云世界雷声王佛　南无不可行世界薝卜色佛　南无莲华世界波头摩胜佛　南无光幢世界光明王佛　南无无边功德庄严光明世界庄严王佛　南无无量光明世界普贤佛　南无无边功德宝作示现安乐世界无边功德宝集示现安乐金色光明师子奋迅王佛　南无普宝间错世界普光明妙胜山王佛　南无普无垢世界无垢称王佛　南无清净行世界普华佛

如是诸世界中诸佛一切归命。及彼菩萨摩诃萨一切大众亦悉归命

佛说佛名经卷第六佛说佛名经卷第七

        后魏北印度三藏菩提流支译

尔时诸比丘白佛言。世尊世尊。如是诸佛如来所有寿命长短等不。佛告诸比丘。汝等谛听。当为汝等。比丘我此娑婆世界贤劫。释迦牟尼佛国土一劫。于安乐世界为一日一夜。若安乐世界阿弥陀佛国土一劫。于袈裟幢世界为一日一夜。若袈裟幢世界碎金刚佛国土一劫。于不退轮吼世界善快光明波头摩敷身如来国土为一日一夜。若不退轮吼世界一劫。于无垢世界法幢如来国土为一日一夜。若无垢世界一劫。于善然灯世界师子如来国土为一日一夜。若善然灯世界一劫。于善光明世界卢舍那藏如来国土为一日一夜。若善光明世界一劫。于难过世界法光明波头摩敷身如来国土为一日一夜。若难过世界一劫。于庄严慧世界一切通光如来国土为一日一夜。若庄严慧世界一劫。于镜轮光世界月智如来国土为一日一夜。比丘入如是数。满足过十阿僧祇百千万世界。最后波头摩胜世界。于贤胜如来佛国土为一日一夜。比丘如是等世界无量无边长短不等。诸佛如来寿命住世亦复如是。诸比丘。汝等应当称此诸佛名。作如是言

南无如是等诸佛如来　南无释迦牟尼佛　南无阿弥陀佛　南无碎金刚佛　南无善快光明波头摩敷身佛　南无法幢佛　南无师子佛　南无卢舍那藏佛　南无法光明波头摩敷身佛　南无一切通光佛　南无月智佛　南无贤胜佛　南无不动智佛　南无阿尼罗智佛　南无阿私陀智佛　南无行智佛　南无阿楼那智佛　南无常智佛　南无妙智佛　南无乐自在天佛　南无梵天佛　南无胜智天佛　南无庵摩罗月佛　南无不退月佛　南无不动月佛　南无阿尼罗月佛　南无婆留那月佛　南无阿私月佛　南无胜月佛　南无阿楼那月佛　南无无垢月佛　南无胜智月佛　南无不退眼佛　南无第一眼佛　南无阿尼罗眼佛　南无不动眼佛　南无阿私陀眼佛　南无行眼佛　南无婆留那眼佛　南无胜眼佛　南无微妙清净眼佛　南无不退幢佛　南无阿尼罗幢佛　南无阿私陀幢佛　南无行幢佛　南无阿楼那幢佛　南无常幢佛　南无妙幢佛　南无自在幢佛　南无梵幢佛　南无胜幢佛　南无弥留胜佛　南无波头摩胜藏佛　南无普眼佛　南无梵命佛　南无金刚齐佛　南无婆薮天佛　南无一切法决定王佛　南无弥留幢寂眼胜佛　南无致沙佛　南无弗妙佛　南无波头摩胜佛　南无火光明佛　南无法意佛　南无善法佛　南无称胜佛　南无宝慧佛　南无微妙眼佛　南无灯佛　南无择义佛　南无自在佛　南无婆薮天佛　南无不去佛　南无择胜佛　南无妙行佛　南无无碍月佛　南无无边智上首佛　南无普眼佛　南无厚波婆罗佛　南无妙胜佛　南无日光佛　南无无边光佛　南无法幢佛　南无无边智然灯佛　南无普功德观然灯佛　南无功德佛　南无金刚幢佛　南无因陀罗幢胜幢佛　南无普智宝炎胜功德幢佛　南无普智宝炎胜功德鸡都佛　南无无垢轮大悲云幢佛　南无金刚那罗延幢佛　南无无碍胜行佛　南无火炎佛　南无山胜庄严佛　南无一切法海上庄严速住佛　南无深法海妙光佛　南无宝炎围然灯佛　南无功德海光明轮胜佛　南无卢遮那胜藏佛　南无满虚空法界尸佉罗胜然灯佛　南无不退然灯佛　南无法界吼佛　南无妙法树山王威德佛　南无一切法海吼王佛　南无宝光明然灯幢佛　南无须弥功德光威德佛　南无法云吼王佛　南无智炬然灯王佛　南无法电速幢胜佛　南无法然灯奋迅师子佛　南无不退法界吼佛　南无智力威德山王佛　南无电光明劫善照世界初放栴檀香光明照佛　南无善决定清净劫无垢世界初卢舍那佛　南无甘露庄严劫善清净世界初栴檀然灯王佛　南无善住劫妙香世界初须弥光明胜王佛　南无善见劫庄严世界初无边功德种种宝庄严王佛　南无焰清净劫清净世界初金刚奋迅佛　南无不可嫌劫不可嫌世界初毗沙门佛　南无不可嫌劫不可嫌称世界初宝月佛　南无不可诃劫称财世界初不可思议光明佛　南无清净庄严劫乐清净世界初观世王佛　南无真尘劫光明尘世界初火光明佛　南无梵赞叹劫清净世界初力庄严王佛　南无德光明庄严劫月幢世界初善眼佛　南无栴檀香行平等胜成就佛　南无法海吼光明王佛　南无无垢转法轮佛　南无寂静威德王佛　南无虚空劫然灯佛　南无天自在藏佛　南无日罗幢鸡都王佛　南无信威德佛　南无宝华藏佛　南无妙日身佛　南无一切身智光明月佛　南无不浊身佛　南无阎浮檀威德王佛　南无相庄严身佛　南无种种光明火月佛　南无善观智鸡都佛　南无无垢智光明王佛　南无金刚那罗延精进佛　南无不可降伏智处佛　南无师子智佛　南无普无垢智通佛　南无无垢眼胜云佛　南无金刚菩提光佛　南无光灯火髻佛　南无智日鸡都佛　南无得功德佛　南无智光明云光佛　南无普照月佛　南无宝波头摩敷身佛　南无无障盖吼佛　南无普光明奋迅师子佛　南无法界境界慧月佛　南无一切虚空乐说觉佛　南无初香善名佛　南无普声寂静吼佛　南无甘露山威德佛　南无法海吼声佛　南无善坚罗网坚佛　南无光明月微尘佛　南无虚空镜像头髻佛　南无善智满月面佛　南无清净智华光明佛　南无宝炎山胜王佛　南无无垢功德火光明佛　南无宝月幢佛　南无宝胜光明威德王佛　南无普智行佛　南无炎海然灯佛　南无法无垢吼王佛　南无不可比功德称幢佛　南无三昧轮身佛　南无长臂本愿无垢月佛　南无相智义然灯佛　南无法起宝齐声佛　南无胜照藏王佛　南无乘幢佛　南无法海波头摩广信无畏天佛　南无法海吼光王佛　南无无垢法山佛　南无法轮光明髻佛　南无法日胜云佛　南无法海说声王佛　南无法日智轮然灯佛　南无法华鸡都幢云佛　南无法炎山鸡都王佛　南无法行深胜月佛　南无法智普镜佛　南无藏普智作照佛　南无山王胜藏王佛　南无普门贤照佛　南无连一切法精进幢佛　南无法宝华胜云佛　南无寂光明深髻佛　南无法光明慈乐说光明月佛　南无炎海佛　南无智日普光明佛　南无普轮顶佛　南无智光明王佛　南无福德光华灯佛　南无日光明王佛　南无智师子鸡都幢王佛　南无宝相山佛　南无庄严山佛　南无日步普照佛　南无法罗网觉胜月佛　南无无畏那罗延师子佛　南无普智不二勇猛佛　南无法波头摩敷身佛　南无功德华胜海佛　南无然法炬胜月佛　南无菩提轮善觉胜月佛　南无普贤镜像髻佛　南无法幢然灯行佛(丹本无行)　南无金刚海幢王佛　南无称山胜云佛　南无栴檀胜月佛　南无照众生王佛　南无普功德华威德光佛　南无胜波头摩华藏佛　南无因波头摩佛　南无香炎光明胜佛　南无相山卢舍那佛　南无普闻名称幢佛　南无法城光胜佛　南无普门光明须弥佛　南无功德威德佛　南无相胜法力勇猛幢佛　南无转法轮光明吼佛　南无光明功德山般若照佛　南无转法轮月妙胜佛　南无法华卢舍那清净鸡都佛　南无宝波头摩光明藏佛　南无普觉华佛　南无宝山云灯佛　南无种种光明胜弥留藏佛　南无光明轮峰王佛　南无福德云昼(丹盖)佛　南无法峰云幢佛　南无功德山威德佛　南无法日云灯王佛　南无法云称胜月佛　南无法轮力云佛　南无香解幢智威德佛　南无法轮清净胜月佛　南无金山威德贤佛　南无贤首弥留威德佛　南无普慧云吼佛　南无法力胜山佛　南无香炎胜王佛　南无伽那迦摩尼山声佛　南无顶藏一切法光明轮佛　南无然法轮威德佛　南无山峰胜威德佛　南无普精进炬光明云佛　南无三昧贤宝天冠光明佛　南无胜宝光佛　南无法炬宝帐声佛　南无乐法光明师子佛　南无庄严相月幢佛　南无光明山雷电云佛　南无无垢幢佛　南无无碍法虚空光明佛　南无快智华敷身佛　南无世间妙光明声佛　南无法三昧光明声佛　南无法声多藏佛　南无法火炎海声佛　南无高法轮光明佛　南无三世相镜像威德佛　南无法界师子光佛　南无法火炎光明佛　南无卢舍那胜须弥佛　南无一切三昧海师子佛　南无普光慧然灯佛　南无法界城然灯佛　南无普门吼光明佛　南无贤首佛　南无普光首佛　南无胎王佛　南无法界灯佛　南无虚空山照佛　南无阿尼罗有眼佛　南无龙自在王佛　南无普照胜须弥王佛　南无无碍虚空智鸡都幢王佛　南无普智光明照十方吼佛　南无云王吼声佛　南无不空见佛　南无普照佛　南无实声佛　南无金色宝作界妙山佛　南无妙声佛　南无金阎浮幢千(丹于)遮那光明佛　南无金色百光明佛　南无宝(丹实)称佛　南无不空称佛　南无日爱佛　南无成就智义佛　南无普贤佛　南无无垢光明鸡都王佛　南无宝炎佛　南无日月佛　南无海胜佛　南无法幢佛　南无无边功德王佛　南无宝藏佛　南无无垢面佛　南无无量寿花佛　南无宝聚佛　南无智起佛　南无普护佛　南无萨婆毗浮佛

尔时忧波摩那比丘即从座起。偏袒右肩右膝着地。白佛言世尊。世尊。几佛过去。佛告忧波摩那比丘。比丘。譬如恒河沙世界。下至水际上尽有顶。满中微尘。比丘。有人于中取尔所微尘。过恒河沙世界。下一微尘。如是过恒河沙世界。复下一尘。如是尽尔所微尘。比丘。于意云何。若着微尘。若不着微尘。是微尘数可知数不。比丘言。不也世尊。佛告比丘。比丘。彼微尘可知其数。而彼过去同名释迦牟尼佛。已入涅槃者。不可数知。比丘。我知彼过去诸佛如现前见。彼诸佛母。同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼诸佛第一声闻弟子。同名舍利弗。目犍连。侍者弟子同名阿难。何况种种异名母。异名父。异名城。异名弟子。异名侍者。比丘。彼若干世界。彼人于何等世界着微尘。何等世界不着微尘。彼诸世界。若着微尘。若不着微尘。下至水际。上至有顶。比丘。复有第二人取一微尘。过彼若干微尘数世界。尔数佛国土。阿僧祇亿百千万那由他世界。为一步。比丘。彼人复过是若干微尘数世界。为一步。彼人如是过百千万亿那由他阿僧祇劫行。乃下一尘。如是尽诸微尘。比丘。如是若干世界满中微尘。复更着十方世界。比丘。复过是世界着微尘。彼诸世界。下至水际。上至有顶。满中微尘。比丘。于意云何。彼微尘可知数不。比丘言。不也世尊。佛告比丘。彼诸微尘可知其数。彼同名母。同名父。同名城。同名弟子。同名侍者。同名释迦牟尼佛不可知数。如释迦牟尼佛。不胜幢佛亦如是。卢舍那佛亦如是。无垢胜眼佛亦如是

光明清净王佛亦如是

无垢光明眼佛亦如是

善无垢清净佛亦如是

成就无边功德胜王佛亦如是

宝光明佛亦如是。寂修佛亦如是。声德佛亦如是。波头摩胜佛亦如是。日月佛亦如是。普宝盖佛亦如是。比丘。汝当归命如是等阿僧祇同名佛

南无普光明奋迅王佛　南无普照佛　南无药王佛　南无弥留灯王佛　南无宝庄严佛　南无智成就佛　南无宝盖佛　南无放炎佛　南无物成就佛　南无称智佛　南无三昧胜佛　南无宝观佛　南无宝鸡都佛　南无尸罗施佛　南无莎罗王佛　南无实意山(丹本无山)鸡兜王佛　南无大庄严佛　南无山自在王佛　南无栴檀佛　南无见义佛　南无自在幢佛　南无大弥留佛　南无无光胜佛　南无大庄严王佛　南无大智幢佛　南无日藏佛　南无梵自在佛　南无无畏上胜山王佛　南无智鸡兜佛　南无余依止黠声王佛　南无智炬住持佛　南无过一切世间佛　南无法照佛　南无无垢光佛　南无普光佛　南无一切胜佛　南无寂静妙声佛　南无普明佛　南无胜山王师子奋迅境界声佛　南无地住持佛　南无功德王光佛　南无住持智庭燎佛　南无乐说胜王佛　南无难胜佛　南无金色波头摩成王佛　南无宝作佛　南无无量声佛　南无亲光佛　南无龙天佛　南无天力佛　南无师子佛　南无离诤光佛　南无世天佛　南无胜积佛　南无人王佛　南无华王佛　南无华胜佛　南无发精进佛　南无因陀罗鸡兜佛　南无清净无垢光菩提宝华不断绝光明王佛　南无胜山王师子奋迅境界声佛　南无薝卜上佛　南无意福德自在佛　南无观声王佛　南无无垢威德佛　南无功德宝集吼佛　南无成就德佛　南无成就胜佛　南无斯何佛　南无威德佛　南无阿输迦世界贤妙胜佛

若善男子善女人。受持是佛名。必得不退菩提

南无难陀世界栴檀胜佛　若善男子善女人受持是佛名毕竟得清净心

南无跋陀世界寂染佛　南无意智鸡兜世界破魔力佛　南无满月世界无忧佛　南无鸡兜意胜世界宝杖佛　南无语吼声胜世界花胜佛　南无差摩世界三奋迅佛　南无广世界树提胜佛　南无月胜世界金刚功德身佛　南无过去无量无边海胜佛　若善男子。称彼佛名。得毕竟不退菩提心

南无弥留胜王佛　彼佛初成佛。第一会八十亿百千万那由他声闻众。第二会七十亿百千万那由他。第三会六十亿百千万那由他。第四会二十五亿百千万那由他如是。菩萨无量无边百千万亿那由他

南无师子妙声王佛　彼如来初会有九十九亿声闻。第二会九十亿。第三会九十三亿。第四会九十九亿如是。菩萨摩诃萨众无量无边

南无华胜佛　彼佛初会八十亿声闻。菩萨僧亦如是

南无妙行佛　彼佛初会八十亿声闻。菩萨僧亦如是

南无量大庄严佛　彼佛初会八十亿声闻。第二会七十亿。乃至第十会亦如是。菩萨僧亦如是无量无边

南无放炎佛　南无威德佛　彼佛初会有九十亿声闻。如是第二乃至第十亦如是。菩萨摩诃萨僧无量无边

南无一切光明佛　彼佛初会有那由他亿声闻。菩萨僧亦如是

南无无量光明佛　彼佛初会声闻有九十六亿。第二会九十四亿。第三会九十二亿。菩萨僧亦如是

南无声德佛　彼佛初会声闻有八十亿。第二会七十亿。第三会六十亿。菩萨僧亦如是。应当归命如是等无量无边诸佛菩萨。复次比丘。应当敬礼南方清净无垢世界菩萨佛。谓文殊师利。现在普见如来佛国土中。复次比丘。应敬礼四大士菩萨。第一名光明幢。现在东方无畏如来佛国土中。第二名智胜。现在南方智聚如来佛国土中。第三名寂根。现在西方智山如来佛国土中。第四名愿意成就。现在北方那罗延如来佛国土中

敬礼东方无畏如来佛国土中光明幢菩萨

敬礼南方智聚如来佛国土中智胜菩萨

敬礼西方智山如来佛国土中寂根菩萨

敬礼北方那罗延如来佛国土中愿意成就菩萨

复次摩诃男比丘。重同如来世尊。过去几佛入涅槃。佛告摩诃男。汝今谛听。当为汝说。比丘。东方恒河沙世界。南方恒河沙世界。西方恒河沙世界。北方恒河沙世界。上下四维恒河沙世界。彼一切世界。下至水际。上尽有顶。满中微尘。比丘于意云何。彼如是微尘可知数不。比丘言。不也世尊。佛告比丘。知是同名释迦牟尼佛。过去入涅槃者不可数知。比丘我知彼过去诸佛如现在前。彼诸佛母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼佛第一声闻弟子同名舍利弗。目犍连。侍者弟子同名阿难陀。何况种种异名母。异名父。异名城。异名弟子。异名侍者。比丘。彼若干世界。彼人于何等世界着微尘。何等世界不着微尘。彼诸世界。若着微尘。及不著者。下至水际。上至有顶。比丘复有第二人。取彼微尘。彼若干微尘数世界。尔所佛国土阿僧祇亿百千万那由他世界。过尔所世界为一步。比丘。彼人复过若干微尘数世界为一步。彼人如是过百千万亿那由他阿僧祇劫行。乃下一尘。如是尽诸微尘。比丘。如是若干世界。若着微尘。及不著者。满中微尘。复更着十方世界。比丘。复过是世界。若着微尘。及不著者。彼诸世界。下至水际。上至有顶。满中微尘。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。彼诸微尘可知其数。彼同名释迦牟尼佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一弟子同名舍利弗。目犍连。侍者弟子同名阿难陀。不可知数。复次比丘。复有第三人。取彼尔所世界微尘。过彼尔所微尘数世界为一步。过若干百千万亿那由他阿僧祇劫行。乃下一尘。如是尽诸微尘。复有第四人。取彼若干微尘数世界。若着若不着。下至水际。上至有顶。满中微尘。比丘。于意云何。彼微尘可知数不。比丘言。不也世尊。佛告比丘。彼若干微尘。可知其数。然彼同名释迦牟尼佛母。同名父。同名世界。同名弟子。同名侍者。同名佛。不可知数。比丘。如是第五人第六第七第八第九第十人。复次比丘。复有第十一人。是人彼若干微尘中。取一微尘破为十方。若干世界微尘数分。如一微尘破为若干分。如是余微尘。亦悉破为若干世界微尘数分。比丘。于意云何。彼微尘可知数不。比丘言。不也世尊。佛告比丘。复有人。彼若干微尘佛国土。为过一步。如是速疾神通行东方世界。无量无边劫行。行如是东方世界。下一微尘东方尽。如是微尘。若着微尘。及不著者。下至水际。上至有顶。满中微尘。如是南方乃至十方。下至水际。上至有顶。满中微尘。比丘。于意云何。彼微尘可知数不。比丘言。不也世尊。佛告比丘。若干微尘分可知其数。然现今在世。同名释迦牟尼佛入涅槃不可数知。母同名摩诃摩耶。父同名输头檀。城同名迦毗罗。弟子同名舍利弗。目犍连。侍者弟子同名阿难陀。何况种种异名比丘。我若干微尘数劫住世。说一同名释迦牟尼佛不可穷尽。如是同名然灯佛。同名提波延佛。同名灯光明佛。同名一切胜佛。同名称王佛。同名波头摩胜佛。同名毗婆尸佛。同名尸弃佛。同名毗舍浮佛。同名拘留孙佛。同名拘那含牟尼佛。同名迦叶佛。如是等异名母。乃至异名侍者入涅槃。我知彼佛如现在前。应当敬礼如是等诸佛

敬礼同名释迦牟尼佛　敬礼同名然灯佛　敬礼同名提波延佛　敬礼同名灯光明佛　敬礼同名一切胜佛　敬礼同名称王佛　敬礼同名波头摩胜佛　敬礼同名毗婆尸佛　敬礼同名尸弃佛　敬礼同名毗舍浮佛　敬礼同名拘留孙佛　敬礼同名拘那含牟尼佛　敬礼同名迦叶佛

忧波摩那比丘。白佛言世尊。世尊。未来几许佛。佛告忧波摩那比丘。汝今谛听。当为汝说。比丘。未来星宿劫中。有三百佛出世。同名大鸡兜佛。复有十千同名庄严王佛

华作劫中有一亿百千万佛出世。同名菩提觉华佛。八频婆罗佛出世。同名离爱佛

多卢波摩劫中。有六千佛出世。同名散花佛

胜声劫中莎罗自在高幢世界。十千佛出世。同名清净忧波罗香山佛

普华劫中有千八百佛出世。同名离爱佛

复有千三百佛出世。同名梵声佛

复有劫中三十亿佛出世。同名释迦牟尼佛

复有劫中八千同名然灯佛出世

复有劫中六十千同名欢喜佛出世

复有劫中三亿佛出世。同名弗沙佛

复有劫中十八千佛出世。同名莎罗自在王佛(十八千丹八十千)

复有劫中三百佛出世。同名波头摩胜佛

复有劫中五百佛出世。同名波多婆佛

复有劫中千佛出世。同名阎浮檀佛

复有劫中十二八千万佛出世。同名见一切义佛

复有劫中千佛出世。同名俱邻佛

复有劫中九千佛出世。同名迦叶佛

复有劫中十八佛出世。同名因陀罗幢佛

复有劫中十五佛出世。同名日佛

复有劫中六十亿佛出世。同名大庄严佛

复有劫中六十佛出世。同名因陀幢佛

复有劫中五百佛出世。同名日佛复有劫中六十亿佛出世。同名大庄严佛

复有劫中六十二百佛出世。同名寂行佛

复有劫中六十亿佛出世。同名莎罗自在王佛

复有劫中八千佛出世。同名坚精进佛

复有劫中百亿佛出世。同名决定光明佛

复有劫中八十亿佛出世。同名实法决定佛

复有劫中六十二亿佛出世。同名毗留罗佛

复有劫中六十千佛出世。同名妙波头摩佛

复有劫中四十千佛出世。同名愿庄严佛

复有劫中五百佛出世。同名华胜王佛

复有劫中四十亿那由他佛出世。同名妙声佛

复有劫中千佛出世。同名功德盖安隐自在王佛

复有劫中六十千佛出世。同名坚修柔软佛

复有劫中十佛国土微尘数百千万不可说不可说佛出世。同名普贤佛

复有劫中七千佛出世。同名法庄严王佛

比丘。举要言之。未来诸佛无量无边。不可说不可说不可穷尽。比丘。汝应当一心归命如是等诸佛

尔时舍利弗从座而起。偏袒右肩右膝着地。胡跪合掌白佛言。世尊。几佛现在。佛告舍利弗。汝见我现在身耶。舍利弗言。如是世尊。我今实见佛身。复告舍利弗。我今见十方无量无边不可说不可说世界。同我名释迦牟尼佛在世者。如汝见我无异。如是同名然灯佛。同名毗婆尸佛。同名尸弃佛。同名毗舍浮佛。同名拘留孙佛。同名俱那含佛。同名迦叶佛

舍利弗。举要言之。我若一劫。若百千万亿那由他劫说。同名诸佛不可穷尽。何况异名佛。此如是等诸佛。皆是文殊师利初教发阿耨多罗三藐三菩提心。舍利弗。汝应当一心归命如是等诸佛

舍利弗。现在劫五百同名智幢佛。复有劫五百同名法幢佛。复有劫六十二同名然灯佛。复有劫六十二同名尸弃佛。复有劫千同名然火单荼自在王声佛。复有劫二千不同名。或名智胜佛。或名炬灯王佛。或名法胜佛。或名梵胜佛。舍利弗。汝应当一心归命如是等诸佛

舍利弗。复有佛名妙声分声佛。舍利弗。彼妙声分声佛寿命六十百岁过是东方名智自在两足尊。彼智自在如来寿命十二千岁。过智自在世尊。复有佛名威德自在两足尊。威德自在佛寿命七十六千岁。过威德自在世尊。复有佛名摩醯首罗。彼摩醯首罗佛寿命满一亿岁。过摩醯首罗佛。复有佛名梵声。彼梵声佛寿命满足十亿岁。过梵声世尊。复有佛名大众自在。彼大众自在佛寿命满足六十千岁。过大众自在世尊。复有佛名声自在佛。彼声自在佛寿命满足一亿岁。过声自在世尊。复有佛名胜声。彼胜声佛寿命满足百亿岁。过彼胜声世尊。复有佛名月面。彼月面佛寿命一日一夜。过月面世尊。复有佛名日面。彼日面佛寿命满足千八百岁。过日面世尊。复有佛名梵面。彼梵面佛寿命满足二十三千岁。过梵面世尊。复有佛名梵阿莎婆。彼梵阿莎婆佛寿命满足千八百岁。舍利弗。汝应当一心归命如是等诸佛。舍利弗。复过一劫中二百佛出世。我说彼佛名。汝当归命

南无不可嫌身佛　南无称名佛　南无威德佛　南无称吼佛　南无称上佛　南无声清净佛　南无智胜佛　南无智解佛　南无黠慧佛　南无智通佛　南无智成就佛　南无智供养佛　南无智妙佛　南无智通(丹勇)猛佛　南无智炎佛　南无净上佛　南无法宝佛　南无智光佛　南无梵天佛　南无善梵天佛　南无净婆薮佛　南无妙梵声佛　南无梵自在佛　南无梵天自在佛　南无因那陀佛　南无梵吼佛　南无梵德佛　南无威德力佛　南无威德自在佛　南无善威德佛　南无威德绝伦无能制伏佛　南无威德起佛　南无威德天佛　南无善决定威德佛　南无威德胜佛　南无惊怖佛　南无惊怖意佛　南无惊怖慧佛　南无惊怖众生佛　南无惊怖面佛　南无惊怖起佛　南无威德决定毕竟佛　南无威德天佛　南无惊怖实佛　南无见惊怖佛　南无善眼佛　南无月胜佛　南无深声佛　南无无边声佛　南无净声佛　南无清净声佛　南无无量声佛　南无放声佛　南无降伏魔力声佛　南无住持声佛　南无善目佛　南无善照佛　南无普眼佛　南无清净面佛　南无无边眼佛　南无称眼佛　南无眼庄严佛　南无不可嫌眼佛　南无调柔佛　南无调胜佛　南无善调心佛　南无善寂根佛　南无善寂意佛　南无善寂妙佛　南无善寂行佛　南无善寂去佛　南无善寂彼岸佛　南无善寂勇猛佛　南无住胜佛　南无善寂净心佛　南无众自在佛　南无众上首自在王佛　南无有众佛　南无胜众佛　南无清净智佛　南无大众自在佛　南无众勇猛佛　南无放妙香佛　南无法方佛　南无法鸡兜佛　南无法行佛　南无法宝佛　南无法力佛　南无法住佛　南无善法佛　南无法勇猛佛　南无法乐决定佛　南无实法决定一劫中八十亿同名决定佛。第二劫中八十亿亦同名决定佛。过决定佛名胜成就佛。亦应一心敬礼

南无安隐佛　南无拘邻佛　南无善欢喜佛　南无善眼佛　南无头陀罗吒佛　南无毗留博叉佛　南无善眼佛　南无妙眼佛　南无善见佛　南无善解佛　南无释迦牟尼佛　南无妙去佛　南无大胜佛　南无栴檀佛　南无大功德佛　南无善度佛　南无灭恶佛　南无摩梨支佛　南无光明佛　南无满月佛　南无净名佛　南无净德佛　南无净住佛　南无喜胜佛　南无月幢佛　南无宝起佛　南无无畏佛　南无然灯佛　南无法妙佛　南无高鬘(丹髻)佛　南无称妙佛　南无威德佛　南无次胜妙释迦牟尼佛　南无吉沙佛　南无弗沙佛　南无毗婆尸佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含佛　南无迦叶佛

佛复告舍利弗。舍利弗。现在东方可乐世界中名阿閦佛。应当一心敬礼

南无日藏佛　南无日作佛　南无龙王自在王佛　南无龙欢喜佛　南无自在佛　南无称光明佛　南无山城佛　南无普妙佛　南无普宝佛　南无称自在王佛　南无行法行称佛　南无初智慧佛　南无智山佛　南无因光明佛　南无生胜佛　南无弥留藏佛　南无智海佛　南无大精进佛　南无高山胜佛　南无功德藏佛　南无智法界佛　南无无畏自在佛　南无大精进成就佛　南无智成就佛　南无无碍王佛　南无地力精进佛　南无持佛　南无力王佛　南无善见佛　南无法光明王佛　南无降伏魔佛　南无不断炎佛　南无功德山佛　南无智齐佛　南无无障力王佛　南无善思惟佛　南无师子欢喜佛　南无戒光明佛　南无快胜王佛　南无尽智藏佛　南无宝面胜佛　南无智波婆佛　南无决定称佛　南无无边观王佛　南无法华雨佛　南无作光明佛　南无高山王佛　南无成就法轮王佛　南无无垢眼佛　南无大名声德佛　南无无碍智力王佛　南无无碍安隐佛　南无寂门佛　南无福德力精进佛　南无智衣王佛　南无法自在王佛　南无无妨安隐佛　南无智成就佛　南无大力弥留藏佛　南无观功德精进佛　南无得无障不迷佛　南无香光明佛　南无功德聚集王佛　南无法齐底佛　南无声自在王佛　南无护声佛　南无种种力精进王佛

佛名经卷第七佛说佛名经卷第八

        元魏天竺三藏菩提流支译

南无宝光明胜王佛　南无过一切须弥山王佛　南无宝弥留佛　南无不动法佛　南无坚固盖王佛　南无普功德佛　南无法莎罗弥留佛　南无聚集智声佛　南无智炎华月王佛　南无龙王自在王佛　南无优昙末华王佛　南无真金色王佛　南无增长法幢王佛　南无栴檀波罗光佛　南无住法(丹持)功德称佛　南无坚固意精进佛　南无然尘灯佛　南无精进步佛　南无无边坚固幢佛　南无最法称佛　南无法王佛　南无降伏大众佛　南无有光炎华高山佛　南无智胜照佛　南无才威德然灯佛　南无无诤无畏佛　南无智化声佛　南无二轮成就佛　南无妙身盖佛　南无胜庄严王佛　南无师子座善坐佛　南无放月光华王佛

复次舍利弗。现在南方佛。汝应当一心归命

南无法自在吼佛　南无师子奋迅王佛　南无初发心香自在莎罗佛南无那罗延自在藏弥留胜佛　南无宝山精进自在集功德佛　南无树提藏佛　南无星宿方便称佛　南无功德力莎罗王佛　南无大意佛　南无妙声吼奋迅佛　南无妙声佛　南无得一切众生意佛　南无宝地山佛　南无法云吼声佛　南无无垢光明佛　南无香波头摩精进王成就佛　南无光波婆吒佛　南无功德迹佛　南无因缘光明佛　南无无边功德王佛　南无增长明(丹眼)佛　南无师子声奋迅佛　南无观法佛　南无天力师子奋迅佛　南无法华通佛　南无敬法清净佛　南无坚精进行奋迅佛　南无自精进佛　南无弥留光佛　南无功德阿尼罗佛　南无净相(丹枨)佛　南无唤智佛　南无智慧作佛　南无不破广慧佛　南无力慧佛　南无忧头钵佛　南无法坚固欢喜佛　南无坚固意自在佛　南无发舍成就佛　南无平等须弥山面佛　南无清净藏佛　南无一切众生自在佛　南无智自在佛　南无胜业清净见佛　南无善快奋迅佛　南无无障无著精进佛　南无世间自在佛　南无广法行佛　南无功德成就佛　南无不怯弱成就佛　南无成如意通佛　南无如观法佛　南无栴檀须(丹髻)佛　南无敬重戒王佛　南无宝名佛　南无龙王自在声佛　南无大智庄严佛　南无无孤独功德佛　南无阿罗摩佛　南无不灭庄严佛　南无净功德庄严佛　南无自在相好(丹妙)庄严称佛　南无行自在王佛　南无法华弥留佛　南无法性庄严佛　南无愿满足佛　南无大舍庄严佛　南无千法无畏佛　南无有自在成就佛　南无乐法奋迅佛　南无寂王佛　南无解脱王佛　南无肩弥留佛　南无如意力电王佛　南无无障佛月佛　南无不赞叹世间胜佛　南无法王决定佛　南无宝星宿云王佛　南无阿私多宝胜佛　南无法行自在佛　南无地勇名佛　南无无边胜宝名佛　南无名智奋迅王佛　南无名树迦那伽王佛　南无名增长慧佛　南无法华通直心佛　南无名照观佛王佛　南无名快照光明精进通集佛　南无名智尽天佛　南无名不着恶胜佛　南无名胜妙法佛　南无名大智声智慧佛　南无名见一切世间不畏佛　南无名见无畏佛　南无名声去佛　南无如来行无量王佛

复次舍利弗。现在西方佛。汝应当一心敬礼

南无初光明华心照佛　南无妙声修行吼佛　南无住胜智称佛　南无普见佛　南无作非作心华光佛　南无法行然灯佛　南无普胜佛　南无智吼称王佛　南无梵声欢喜吼佛　南无千眼佛　南无海香炎佛　南无千月自在藏佛　南无法速乐行佛　南无身贤远光佛　南无师子广眼佛　南无十力光明胜佛　南无智来佛　南无无边精进胜面佛　南无大胜成就法佛　南无不空见佛　南无不可尽色佛　南无观法智佛　南无无妨王佛　南无无边德佛　南无智察法佛　南无一切善根菩提通佛　南无无碍精进善思惟奋迅王佛　南无上智胜善住功德佛　南无智香胜佛　南无智胜见尸弃王佛　南无妙功德智佛　南无法清净来佛　南无不忧法华吼王佛　南无胜上功德佛　南无开法门藏佛　南无照法同王佛　南无力王善住法佛　南无善择力得佛　南无无边门见佛　南无善化庄严佛　南无不似见佛　南无离嗔功德王佛　南无离尘亿胜佛　南无大力般若奋迅王佛　南无法镜像佛　南无坚叉利成就佛　南无一切智功德胜佛　南无不乐出功德佛　南无精进过精进自在山佛　南无一切世间自在桥梁胜佛　南无示现(丹本有无)尽德佛　南无清净戒功德王佛　南无华严作庄严佛　南无独王佛　南无得大通愿力佛　南无吼声速精进佛　南无胜身那罗延智佛　南无那罗延佛　南无宝光阿尼罗胜佛　南无宝海炎佛　南无大海弥留胜王佛　南无初不浊天王佛　南无不住生戒胜功德王佛　南无胜慧佛　南无虚空乐说无碍称佛　南无无比藏称佛　南无天(丹本无天)自在梵增上佛　南无善行见王佛　南无种种行王佛　南无卢舍那胜功德佛　南无自在佛　南无住华佛　南无智善根成就性佛　南无无障碍智成就佛　南无善决法佛　南无法庄严观乐说(丹本有法)称佛　南无三宝然灯佛　南无摩诃思惟藏佛　南无不可思议王佛　南无自在亿佛　南无师子胸藏佛　南无智王庄严佛　南无自在根佛　南无离声眼佛　南无善香佛　南无不染佛　南无法身佛　南无波头摩佛　南无广戒王佛　南无心善行称佛　南无法自在佛　南无如意通观藏佛　南无然贪灯王佛　南无世间意成就善(丹盖)法佛　南无福德胜田佛　南无善观佛法胜佛

复次舍利弗。现在北方佛。汝当一心归命

南无初胜藏山佛　南无放光明佛　南无无边智慧佛　南无龙华佛　南无一切龙奋迅勇猛佛　南无降伏一切魔佛　南无法世间镜像佛　南无福德庄严佛　南无胜婆嗟山佛　南无法来王佛　南无普庄严树行胜佛　南无佛化成就佛　南无宝积成就佛　南无一切成就称佛　南无三世智胜佛　南无胜威善住佛　南无种种愿光佛　南无不退百胜光佛　南无分阇罗胜佛　南无夺(丹奋)一切邪见佛　南无得佛眼轮佛　南无得一切佛智佛　南无大慈悲救护胜佛　南无师子智桥梁佛　南无住实际王佛　南无诸善根福德法成就佛　南无大无垢智佛　南无智称王佛　南无佛法波头摩佛　南无兴一切相佛　南无随一切意法云佛　南无大毗留嗏佛　南无满足精进实慧佛　南无胜光明佛　南无不动法智光佛　南无栴檀云王佛　南无不染波头摩声佛　南无法增上声王佛　南无撰择法无碍华称佛　南无无垢劫佛　南无佛眼无垢精进增上轮佛　南无智自在称佛　南无无边疑佛　南无广威德自在王佛　南无无边智奋迅无碍心佛　南无欲法道善住佛　南无一切生智佛　南无降伏魔力坚固意佛　南无精进自在宝王佛　南无威德藏佛　南无见利益一切欢喜佛　南无种种日佛　南无大步佛王佛　南无无垢法王佛　南无声分妙宝吼佛　南无不退精进示现佛　南无庄严佛国土王佛　南无智根本华佛　南无不称涅槃佛　南无一切龙摩尼藏佛　南无乐法自在佛　南无得法相自在佛　南无无边宝功德藏佛　南无清净华山佛　南无大法王拘苏摩胜佛　南无一切尽不尽藏佛　南无华弥留善佛　南无虚空智山佛　南无智力王佛　南无无碍声智佛　南无无边佛声藏佛　南无智王不尽称佛　南无心慧奋迅王佛　南无自性清净智佛　南无智自在法王佛　南无正见佛　南无语见佛　南无满足法香见佛　南无因陀罗山无碍王佛　南无龙月佛　南无宝自在莎罗王佛　南无见一切众生佛　南无水住持光明王佛　南无觉一切法佛　南无智宝法胜佛　南无精进自在意法藏佛　南无无碍山佛　南无无垢鬘佛　南无放光明照佛　南无弥留力自在藏佛　南无炎自在藏佛　南无声分妙觉吼佛　南无精进自在弥留寂自在佛　南无坚无畏功德佛　南无坚勇猛宝佛　南无坚猛寂静王佛　南无降伏闇弥留山王佛　南无胜丈夫芬陀梨佛　南无圣声藏佛　南无普贤芬陀利佛　南无法平等法身佛　南无难胜佛　南无难可意佛　南无不动佛　南无妙声佛　南无胜声佛　南无莎罗奋迅佛　南无宝胜佛　南无爱见佛　南无然灯佛　南无须弥劫佛　南无月光佛　南无日光佛　南无法界佛　南无药树王佛　南无星宿佛　南无觉上佛　南无授记佛　南无爱作佛　南无无畏作佛　南无华宝栴檀佛　南无龙功德佛　南无卢舍那佛　南无无垢佛　南无无烦恼佛　南无善来佛　南无金色色佛　南无无根本佛　南无须弥灯佛　南无可乐见光佛　南无能作光佛　南无一切浊佛　南无无染佛　南无善净佛　南无解脱佛　南无华树佛　南无法性佛　南无善护声佛　南无得意佛　南无断爱佛　南无内外佛　南无成就幢佛　南无梵声佛　南无妙声佛　南无胜声佛　南无金刚佛　南无大通佛　南无无畏佛　南无离一切烦恼佛　南无离怖佛　南无离怯弱佛　南无不可动佛　南无乐解脱佛　南无成就佛　南无二足尊佛　南无一切种智佛　南无相庄严佛　南无不可量言佛　南无不畏言佛　南无常相应言佛　南无梵众相应佛　南无三十天众相应佛　南无字金色佛　南无舍结佛　南无莎罗华佛　南无金华佛　南无拘牟头相佛　南无顶胜佛　南无一切通智佛　南无不可相佛　南无得一切法彼岸佛　南无善住佛　南无庄严相佛　南无妙寂佛　南无舍浮罗奋迅佛　南无清净众生佛　南无常香佛　南无毕竟大悲佛　南无成就坚佛　南无常微笑佛　南无离浊佛　南无百相功德佛　南无随顺佛　南无胜藏佛　南无般若幢佛　南无宝般若毕竟佛　南无满足意佛　南无观世自在王佛　南无大炎聚佛　南无胜功德威德佛　南无梵胜天佛　南无内宝佛　南无三菩提幢佛　南无胜灯佛　南无善择愿越胜莎罗王佛　南无无垢光明佛　南无照闇佛　南无无畏观佛　南无乐说庄严佛　南无无垢月鸡兜称佛　南无宝上佛　南无华庄严光明(丹本有作)佛　南无火奋迅佛　南无无畏智观佛　南无师子奋迅齐佛　南无远离一切惊怖毛竖等称光佛　南无伽那伽王光明威德佛　南无观世音佛　南无尼弥佛　南无宝火佛　南无宝山佛　南无自在佛　南无宝精进日月光明庄严威德黠声王佛　南无初发心念观一切疑即断烦恼佛　南无断闇三昧胜王佛　南无宝炎佛　南无大聚佛　南无栴檀香佛　南无虚空平等佛　南无礼拜增上佛　南无不动作佛　南无观(丹乡本欢)喜佛　南无离畏佛　南无善清净胜佛　南无光明王佛　南无不可降伏幢佛　南无胜一切佛　南无闻声胜佛　南无善臂佛　南无宝高佛　南无善解佛　南无月高佛　南无善见佛　南无照贤首胜佛　南无得圣佛　南无成就一切事佛　南无山峰佛　南无普宝盖庄严佛　南无广光明王佛　南无宝盖喜佛　南无照贤胜佛　南无乐日佛　南无普贤佛　南无清净一切愿威德胜王佛　南无功德王光明佛　南无普光明佛　南无普香佛　南无善清净佛

舍利弗。举要言之。现在诸佛说不可尽。舍利弗。譬如东方恒河沙世界。南方恒河沙世界。西方恒河沙世界。北方恒河沙世界。上下四维恒河沙世界。彼一切世界。下至水际上至有顶满中微尘。舍利弗。于汝意云何。彼如是微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。如是同名释迦牟尼佛。现在世者我现前见。彼诸佛母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼诸佛第一声闻弟子。同名舍利弗目犍连。侍者弟子同名阿难陀。何况种种异名母。异名父。异名城。异名弟子。异名侍者。舍利弗。彼若干世界。彼人于何等世界着微尘。何等世界不着微尘。彼诸世界若着微尘及不著者。下至水际上至有顶。舍利弗。复有第二人。取彼微尘彼若干微尘数。尔所佛国土阿僧祇亿百千万那由他世界。过尔所世界为一步。舍利弗。彼人复过若干微尘数世界为一步。彼人如是过百千万亿那由他阿僧祇劫行乃下一尘。如是尽诸微尘。舍利弗。如是若干世界。若着微尘及不著者。满中微尘。复更着十方世界。舍利弗。复过是世界。若着微尘及不著者。彼诸世界。下至水际上至有顶。满中微尘。舍利弗。复有第三人。取彼尔所微尘。过彼尔所微尘数世界为一步。彼若干百千万亿那由他阿僧祇劫行乃下一尘。如是尽诸微尘。复有第四人。取彼若干微尘数世界。若着微尘及不著者。下至水际上至有顶满中微尘。舍利弗。于意云何。彼微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。彼若干微尘可知其数。然彼同名释迦牟尼佛母。同名摩诃摩耶。父同名输头檀。城同名迦毗罗。第一弟子同名舍利弗目犍连。侍者弟子同名阿难陀。彼佛不可知数。舍利弗。如是第五人。第六第七第八第九第十人。舍利弗。复有第十一人。是人彼若干微尘中。取一微尘破为十方。若干世界微尘数分。如是余微尘。亦悉破为若干世界微尘数分。舍利弗。于意云何。彼微尘分可知数不。舍利弗言。不也世尊。佛告舍利弗。复有人。彼若干微尘分佛国土为过一步。如是速疾神通。行东方世界无量无边劫。下一微尘。东方尽。如是微尘若着微尘及不著者。下至水际上至有顶满中微尘。如是南方乃至十方。下至水际上至有顶满中微尘。舍利弗。于意云何。彼微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。彼若干微尘分可知其数。然现今在世同名释迦牟尼佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一弟子同名舍利弗目犍连。侍者弟子同名阿难陀不可数知。何况种种异名佛。异名母。异名父。异名城。异名弟子。异名侍者。舍利弗。我若干微尘数劫住世。说一同名释迦牟尼不可穷尽。如是同名然灯佛

南无同名提婆延佛　南无同名灯光明佛　南无同名一切胜佛　南无同名大称佛　南无同名波头摩胜佛　南无同名毗婆尸佛　南无同名尸弃佛　南无同名毗舍浮佛　南无同名拘留孙佛　南无同名拘那含佛　南无同名迦叶佛

如是等异名母。乃至异名侍者。现在住世我今悉知。汝等应当一心敬礼

尔时佛告舍利弗。若善男子善女人。求阿耨多罗三藐三菩提者。当先忏悔一切诸罪。若比丘犯四重罪。比丘尼犯八重罪。式叉摩那。沙弥沙弥尼。犯出家根本罪。若优婆塞犯优婆塞重戒。优婆夷犯优婆夷重戒。欲忏悔者。当净洗浴着新净衣不食荤辛。当在静处修治室内。以诸幡华庄严道场香泥涂画。悬四十九枚幡。庄严佛座安置佛像。烧种种香。栴檀。沉水。薰陆。多伽罗。苏犍陀。种种末香。涂香。烧如是等种种妙香。散种种华。兴大慈悲愿救苦众生。未度者令度。未解者令解。未安者令安。未涅槃者令得涅槃。昼夜思惟如来本行苦行。于无量劫受诸苦恼不生疲厌。为求无上菩提故。于一切众生自生下心如僮仆心。若比丘忏四重罪。如是昼夜四十九日。当对八清净比丘。发露所犯罪。七日一对发露。至心殷重悔昔所作。一心归命十方诸佛。称名礼拜随力随分。如是至心满四十九日罪必除灭。是人得清净时当有相现。若于觉中。若于梦中。见十方诸佛与其记别。或见菩萨与其记别。将诣道场共为已伴。或与摩顶示灭罪相。或自见身入大会中处在众次。或自见身处众说法。或见诸师净行沙门。将诣道场示其诸佛。舍利弗。若比丘忏悔罪时。若见如是相者。当知是人罪垢得灭。除不至心。若比丘尼忏悔八重罪者。当如比丘法。满足四十九日。当得清净。除不至心。若式叉摩那。沙弥沙弥尼忏悔根本重罪。当对四清净比丘比丘尼。如上法满二十一日。当知清净。除不至心。若优婆塞优婆夷。忏悔重戒罪。应当至心恭敬三宝。若见沙门恭敬礼拜生难遭想。当请诣道场设种种供养。当请一比丘心敬重者。就其发露所犯诸罪。至心忏悔。一心归命十方诸佛称名礼拜。如是满足七日必得清净。除不至心。尔时世尊而说偈言

  得成菩提降伏魔　　自在经行道树下
  证无障碍眼及身　　法界平等如虚空
  十亿国土微尘数　　菩萨弟子众围绕
  得于一切寂静心　　善住普贤诸行中
  佛身相好妙庄严　　放于种种无量光
  普照十方诸国土　　诸佛不可思议力
  见佛国土悉无垢　　无量妙色清净满
  诸佛所有胜妙事　　承佛神力见大众
  东方世界名宝幢　　远离诸垢妙庄严
  彼处自在宝灯佛　　于今现在彼世界

南无东方自在宝灯佛

  南方颇梨灯国土　　清净妙色普严净
  摩尼清净云如来　　现今在世说妙法

南无南方摩尼清净云佛

  西方无垢清净土　　名为安乐妙世界
  彼自在佛无量寿　　菩萨弟子现围绕

南无西方无量寿佛

  北方世界名香灯　　国土清净甚严饰
  无染光幢佛所化　　现今自在道场树

南无北方无染光幢佛

  琉璃光明真妙色　　国土清净胜庄严
  无碍光云佛如来　　于今现在东北方

南无东北方无碍光云佛

  光明照幢世界中　　现见满足诸菩萨
  自在吼声佛彼处　　现今在于东南方

南无东南方自在吼声佛

  种种乐乐佛世界　　摩尼庄严妙无垢
  胜妙智月如须弥　　现见在于西南方

南无西南方胜妙智月佛

  现见西北方如来　　弥留光明平等界
  彼处大圣自在佛　　弟子菩萨众围绕

南无西北方大圣自在佛

  下方世界自在光　　国土清净宝炎藏
  光明妙轮不空见　　佛今住彼妙国土

南无下方光明妙轮不空见佛

  上方世界光炎藏　　彼世界名净无垢
  普眼功德光明云　　现见菩提树下坐

南无上方普眼功德光明云佛

尔时舍利弗等大众承佛神力。见十方过去未来现在诸佛无量无边。尔时舍利弗在大众中。悲泣流泪白佛言。希有世尊。若善男子善女人。不发阿耨多罗三藐三菩提心者不得成佛。我等昔来犹如腐草。虽经春阳无悕秋实。尔时慧命舍利弗。即从坐起。偏袒右肩。右膝着地。合掌白佛言。世尊。愿更广说十方所有诸佛名号。我等乐闻。尔时佛告舍利弗。汝当至心谛听。我为汝说。得闻彼佛一心敬礼。舍利弗。从此世界东方过百千亿世界。有佛世界名然灯。彼国土有佛名宝集阿罗呵三藐三佛陀。现今说法

南无宝集佛　舍利弗。若有善男子善女人。闻彼佛名至心受持忆念。是善男子善女人。毕竟得七觉分三昧。得不退转阿耨多罗三藐三菩提心。超越世间六十劫。尔时世尊以偈颂曰

  东方然灯界　　有佛名宝集
  若人闻名者　　超世六十劫

舍利弗。东方有世界名宝集。彼世界有佛。名宝胜阿罗呵三藐三佛陀。现在说法

南无宝胜佛　若善男子善女人。闻彼佛名至心受持。忆念读诵合掌礼拜。若复有善男子善女人。以满足三千大千世界珍宝布施。如是日日布施满足一百岁。如此布施福德。比前至心礼拜功德。百分不及一。千分不及一。百千分不及一。乃至算数譬喻所不及一。尔时世尊以偈颂曰

  宝集世界　　有佛宝胜　　若人闻名
  施不及一

舍利弗。从此东方过八百世界有佛世界名香积。彼世界有佛。名成就卢舍那阿罗呵三藐三佛陀。现今说法。若人闻彼佛名。受持读诵忆念礼拜。超越世间五百劫

南无成就卢舍那佛

舍利弗。从此世界。东方过千世界。名树提跋提。彼世界有佛。名卢舍那镜像阿罗呵三藐三佛陀。现今说法。若善男子善女人。闻彼佛名受持读诵。至心忆念恭敬礼拜。得脱三恶道

南无卢舍那镜像佛

舍利弗。从此东方过二千世界。有佛国土名无量光明功德。彼界有佛名卢舍那光明阿罗诃三藐三佛陀。若善男子善女人。闻彼佛名五体投地深心敬重。受持读诵恭敬礼拜。是人超越世间三十劫

南无卢舍那光明佛

舍利弗。东方过千世界。有佛国土名可乐。彼佛名不动应供正遍知。若善男子善女人。闻彼佛名受持读诵恭敬礼拜。是人毕竟不退阿耨多罗三藐三菩提。一切诸魔所不能动

南无不动佛

舍利弗。东方过千世界。有佛国土名不可量。彼处有佛名大光明阿罗诃三藐三佛陀。现今说法。若善男子善女人。闻彼光明佛名。受持读诵恭敬礼拜。是人常不离一切诸佛菩萨。毕竟得不退转阿耨多罗三藐三菩提心

南无大光明佛

舍利弗。从此世界东方过六十千世界。有国土名然灯。佛名不可量声阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼不可量声佛名三称者。是人毕竟不堕三恶道。定得阿耨多罗三藐三菩提

南无无量声如来(三称)

舍利弗。复过彼世界度千佛国土。有世界名无尘。彼有佛名阿弥陀劬沙阿罗诃三藐三佛陀。现今说法。若善男子善女人。闻彼佛名深心敬重。受持读诵恭敬礼拜。是人超越世间十二劫

南无阿弥陀劬沙佛

舍利弗。复过二十千佛国土。有世界名难胜。彼处有佛名大称阿罗诃三藐三佛陀。若善男子善女人闻彼佛名。合掌作如是言

南无大称如来

若复有人以须弥山等七宝。日日布施满一百岁。比闻此佛名礼拜功德。百分不及一。乃至算数亦不及一

舍利弗。复过三千世界。有国土名光明。佛号宝光明阿罗诃三藐三佛陀。若善男子善女人。受持彼佛名。超越世间一百劫。得不退转阿耨多罗三藐三菩提。若人不信闻名得如此功德者。是人定堕阿鼻地狱。满足一百劫

南无宝光明佛

舍利弗。东方过十千国土。有世界名光明照。彼处有佛名得大无畏阿罗诃三藐三佛陀。现今说法。若善男子善女人。闻彼佛名受持读诵恭敬礼拜。是人毕竟得大无畏。摄取无量无边功德聚

南无得大无畏佛

舍利弗。过第七千佛国土。有世界名摩尼光明。彼处有佛。名然灯火阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼佛名至心恭敬礼拜受持读诵。是人摄得如来十力

南无然灯火佛

舍利弗。复过八千佛国土。有世界名真实。彼世界中有佛。号实声阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼佛名受持读诵至心礼拜。是人毕竟得四圣谛。毕竟得阿耨多罗三藐三菩提

南无实声佛

舍利弗。复过二十千佛国土。有世界名光明。佛名无边无垢阿罗诃三藐三佛陀。现今说法。若善男子善女人。闻彼佛名至心生信。受持读诵恭敬礼拜。若复有人。以满三千大千世界七宝布施。比闻无垢佛名受持读诵功德。千万分不及一。乃至算数所不能及。何以故。若众生罪根深厚。不得闻无垢佛名。若有善男子善女人。闻此如来名者。是人非于一佛所种诸善根。亦非十佛所种诸善根。是人乃是百千万佛所种诸善根。是人超越世间四十八劫

南无无边无垢佛

舍利弗。东方过九千佛国土。有世界名妙声。佛号月声阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼佛名受持读诵至心礼拜。是人所得一切功德白法。具足如满月。毕竟得阿耨多罗三藐三菩提

南无月声佛

舍利弗。复过十千佛国土。有世界名无畏。佛名无边称阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼佛名受持读诵。合掌作如是言

南无无边称如来

若复有人。以七宝如须弥山布施。日日如是满足百年。此福德聚比持佛名功德。百分不及一。乃至算数譬喻所不能及

舍利弗。复过千五百佛国土。有世界名然灯。佛号日月光明阿罗诃三藐三佛陀。现在说法。若善男子善女人。闻彼佛名受持读诵。胡跪合掌右膝着地。三称如是言。南无日月光明世尊(三称)。是人速成阿耨多罗三藐三菩提

舍利弗。复过三十千佛国土。有世界名无垢佛。号无垢光明阿罗诃三藐三佛陀。现在说法。若善男子善女人。天龙夜叉罗刹。若人非人。闻是佛名。毕竟不退阿耨多罗三藐三菩提。不入恶道

南无无垢光明佛

舍利弗。东方过十千佛国土。有世界名百光明。佛号清净光明阿罗诃三藐三佛陀。现在说法。若天龙夜叉人非人闻名者。必得人身远离贪嗔痴烦恼。若人闻不信者。六十千劫堕大地狱

南无清净光明佛

舍利弗。复过百佛国土。有世界名善德。佛号日光明阿罗诃三藐三佛陀。现在说法。若人毕竟清净心称此佛名。所得功德满足如日轮。毕竟能降伏一切诸魔外道。超越世间三十劫

南无日光明佛

舍利弗。复过六十千佛国土。有世界名住七觉分。佛号无边宝阿罗诃三藐三佛陀。现在说法。若人闻彼佛名。是人具足得七觉分。能置众生着胜宝中。毕竟成就无量功德聚

南无无边宝佛

舍利弗。复过五百佛国土。有世界名华镜像。佛号华胜阿罗诃三藐三佛陀。现在说法。若人闻彼佛名信心敬重。彼人一切善法成就如华敷明。越度世间五十五劫

南无华胜佛

舍利弗。复过百千亿佛国土。有世界名远离一切忧恼。佛号妙身阿罗诃三藐三佛陀。现在说法。若人闻彼佛名至心敬礼读诵受持。是人决定远离一切诸障不入恶道。超越世间无量劫

南无妙身佛

舍利弗。复过那由他佛国土。有世界名平等。彼处有佛。号法光明清净开敷莲华阿罗诃三藐三佛陀。现在说法。若人得闻彼如来名受持不忘者。永离三恶道

南无法光明清净开敷莲华佛

舍利弗。若比丘比丘尼。优婆塞优婆夷。欲忏悔诸罪。当净洗浴着新净衣。净治室内敷设高座安置佛像。悬二十五枚幡。种种华香供养诵念。此二十五佛名。日夜六时忏悔满二十五日。灭四重八禁等罪。式叉摩那。沙弥沙弥尼亦如是

尔时舍利弗。复白佛言。世尊。唯愿如来演说过去七佛姓名寿命长短。我等渴仰乐闻

佛告舍利弗。谛听谛听。今为汝说。舍利弗。过去九十一劫。有佛名毗婆尸如来

过去三十劫。有佛名尸弃如来

彼劫中复有毗舍浮如来。自此以后无量无数劫。空过无有佛。至贤劫中有四佛

拘留孙佛　拘那含牟尼佛　迦叶佛　我释迦牟尼佛

毗婆尸佛寿命八十千劫。尸弃佛寿命六十千劫。毗舍浮佛寿命二千劫。拘留孙佛寿命十四小劫。拘那含牟尼佛寿命三十小劫。迦叶佛寿命二十小劫。我现在最少寿命一百年

毗婆尸佛尸弃佛毗舍浮佛刹利家生。拘留孙佛拘那含佛迦叶佛婆罗门家生。舍利弗。我释迦牟尼佛刹利家生。毗婆尸佛尸弃佛毗舍浮佛此三佛姓拘邻。拘留孙佛拘那含牟尼佛迦叶佛此三佛姓迦叶。舍利弗。我释迦牟尼佛姓瞿昙。毗婆尸佛。波叱罗树下得阿耨多罗三藐三菩提。尸弃佛。分陀利树下得阿耨多罗三藐三菩提。毗舍浮佛。娑罗树下得阿耨多罗三藐三菩提。拘留孙佛。优头跋树下得阿耨多罗三藐三菩提。拘那含牟尼佛。尸利沙树下得阿耨多罗三藐三菩提。迦叶佛。尼拘律树下得阿耨多罗三藐三菩提。舍利弗。我释迦牟尼佛。阿说他树下得阿耨多罗三藐三菩提

毗婆尸佛三集声闻。尸弃佛三集声闻。毗舍浮佛再集声闻。拘留孙佛一集声闻。拘那含牟尼佛一集声闻。迦叶佛一集声闻。舍利弗。我释迦牟尼佛一集声闻

毗婆尸佛。第一声闻弟子。一名吉沙。二名看茶。尸弃佛。第一声闻弟子。一名胜。二名自在。毗舍浮佛。第一声闻弟子。一名星宿。二名上。拘留孙佛。第一声闻弟子。一名疾。二名力。拘那含牟尼佛。第一声闻弟子。一名活(丹治)。二名毗头罗。迦叶佛。第一声闻弟子。一名输那二名颇罗堕。舍利弗。我释迦牟尼佛。第一声闻弟子。一名舍利弗。二名目揵连。如上二人等。前者智慧第一。后神通第一

毗婆尸佛侍者名无忧。尸弃佛侍者名离畏。毗舍浮佛侍者名寂。拘留孙佛侍者名智。拘那含文尼佛侍者名亲。迦叶佛侍者名迦夫。舍利弗。我释迦牟尼佛侍者名欢喜

毗婆尸佛子名成阴。尸弃佛子名不可量。毗舍浮佛子名善智。拘留孙佛子名上。拘那含文尼佛子名胜。迦叶佛子名导师。舍利弗。我释迦牟尼佛子名罗睺罗

毗婆尸佛父名槃头。母名槃头意。城名槃头。尸弃佛父名钩那。母名胜。城名阿楼那跋提。毗舍浮佛父名阿楼那天子。母名称意。城名随意拘留孙佛父婆罗门种名功德。母名广。彼天子名无畏。城亦名无畏。拘那含文尼佛父婆罗门种名火(丹大)德母名难胜。天子名庄严。城亦名庄严。迦叶佛父婆罗门种名净德。母名善才。天子名知使。城亦名知使。今时波罗奈城是。舍利弗。我今父名输头檀王。母名摩诃摩耶。城名迦毗罗。舍利弗。应当敬礼我本师。谓释迦牟尼佛

南无称妙佛　南无降伏一切佛　南无然灯光佛　南无无畏佛　南无法胜佛

如是等。初一大阿僧祇劫有八十亿佛。最后名释迦牟尼佛。第二阿僧祇劫初

南无宝胜佛　南无然灯佛　南无妙声佛　南无胜成佛　南无善见佛　南无善眼佛　南无持提罗吒佛　南无师子佛　南无无畏佛　南无自在佛　南无不违佛　南无善眼佛　南无善山佛　南无善意佛　南无栴檀佛　南无降伏热佛　南无降伏闇佛　南无师子佛　南无奋迅佛　南无妙声佛　南无无量威德佛　南无净德佛　南无炎佛　南无见第一义佛　南无释迦牟尼佛　南无妙行胜佛　南无妙寂静佛　南无妙身佛　南无功德佛　南无梵命佛　南无月佛　南无降自在佛　南无调山佛　南无因陀罗财佛

此是第二大阿僧祇劫。有如是等七十二亿佛。应当敬礼。舍利弗。归命大力佛　南无大精进佛　南无净德佛　南无大明佛　南无阳炎佛　南无复有释迦牟尼佛　南无大龙佛　南无大威德佛　南无坚行佛　南无栴檀佛　南无宝山佛　南无因陀罗幢佛　南无无畏作佛　南无富楼那佛　南无宝髻佛　南无波头摩胜佛　南无妙胜佛　南无无垢佛　南无与光明佛　南无降伏怨佛　南无波斯陀佛　南无大幢佛　南无颇罗堕佛　南无毕沙佛　南无星宿佛　南无毗婆尸佛　南无尸弃佛　南无拘邻佛　南无毗舍浮佛

南无能作光明不可胜佛

佛名经卷第八佛说佛名经卷第九

        元魏天竺三藏菩提流支译

南无复有尸弃佛　南无善见佛　南无最后释迦牟尼佛

第三大阿僧祇劫中。有如是等七十一亿佛。应当一心敬礼。舍利弗。如是等过去无量佛。汝等应当一心归命敬礼

南无欢喜增长佛　南无人自在王佛　南无不动佛　南无大圣佛　南无欢喜佛　南无自在佛　南无满足佛　南无普光明佛　南无大精进佛　南无拘邻佛　南无安隐佛　南无智慧佛　南无大称佛　南无阿[少/兔]律佛　南无妙胜佛　南无不厌足佛　南无大光炎聚佛　南无月光佛　南无大威德佛　南无普宝盖佛　南无那罗延光明佛　南无师子乘光明佛　南无离一切忧恼光明佛　南无坚固光明佛　南无云王光明佛　南无无垢臂光明佛　南无成就义光明佛　南无胜护光明佛　南无梵胜天王光明佛　南无如是等同名不可说不可说佛

舍利弗。汝应当归命无量寿佛国安乐世界。观世音菩萨。得大势菩萨以为上首。及无量无边菩萨。如是等至心归命。南无摩犁支世界难胜佛国土。光明幢菩萨光明胜菩萨以为上首。及无量无边阿僧祇菩萨众。南无可乐世界阿閦佛国土。香象菩萨。妙香象菩萨以为上首。及无量无边菩萨众。南无卢舍那世界日月佛国土。师子菩萨。师子慧菩萨以为上首。及无量无边菩萨众。南无不瞬世界善月佛国土。莎罗胎菩萨。一切法得自在菩萨以为上首。及无量无边菩萨众。南无光明世界普照佛国土。月轮菩萨。宝炬菩萨以为上首。及无量无边菩萨众。南无乐成世界宝炎如来佛国土。不空奋迅菩萨。不空见菩萨以为上首。及无量无边菩萨众。南无观世界普观如来佛国土。云王菩萨。法王菩萨以为上首。及无量无边菩萨众。南无见爱世界观世音王如来国土。降伏魔菩萨。山王菩萨以为上首。及无量无边菩萨众。如是十方世界。一切佛国土。一切菩萨悉皆归命。舍利弗。归命

善清净无垢佛　南无宝功德集胜王佛　南无普照佛　南无因陀罗幢佛　南无清净光明王佛　南无金色光明师子奋迅王佛　南无普胜山功德佛　南无金刚胜佛　南无善住功德摩尼山王佛　南无普见王佛　南无普贤佛　南无普照佛　南无实法胜决定佛　南无无畏王佛　南无无量意功德王佛　南无地自在王佛　南无无尽光佛　南无离尘功德佛　南无难知佛　南无金刚妙佛　南无无垢胜佛　南无月胜佛　南无一味胜佛　南无槃头华佛　南无鬘香胜佛　南无多摩罗跋香胜佛　南无月藏佛　南无沉水香佛　南无树提光明佛　南无海香佛　南无龙藏佛　南无宝光明佛　南无大云藏佛　南无智德佛　南无金刚藏佛　南无住持地佛　南无虚空平等佛　南无胜藏佛　南无软语佛　南无有德佛　南无山藏佛　南无妙鼓佛　南无爱胜佛　南无鼓增上佛　南无欢喜藏佛　南无因藏佛　南无行胜佛　南无实语佛　南无智胜佛　南无妙声佛　南无自在胜佛　南无胜妙胜佛　南无佛宝幢佛　南无随顺戒佛　南无宝胜佛　南无无垢琉璃佛　南无满足金刚住持佛　南无甘露幢佛　南无成就功德佛　南无香山佛　南无根本胜藏佛　南无不可知佛　南无无边知佛　南无无量佛　南无无量自在佛　南无火(丹大)光明佛　南无德藏佛　南无根本庄严奋迅佛　南无根本光佛　南无一切众生见爱奋迅庄严王佛　南无忍王佛　南无离一切烦恼佛　南无宝色胜佛　南无香胜王佛　南无亿藏佛　南无见一切佛　南无见爱佛　南无不可见佛　南无甘露功德称佛　南无师子吼佛　南无一切畏差别能断疑佛　南无散华佛　南无大胜(丹本有王)佛　南无无碍智作佛　南无一切作乐佛　南无尊胜佛　南无吉王佛　南无一切世间道自在王佛　南无须弥劫佛　南无胜须弥佛　南无解脱佛　南无世间声佛　南无坚奋迅佛　南无坚自在佛　南无栴檀胜佛　南无不差别佛　南无息功用佛　南无善思惟佛　南无能断一切业佛　南无离想佛　南无宝胜佛　南无宝轮佛　南无大宝佛　南无无垢光明佛　南无乐说庄严称佛　南无无垢月幢称佛　南无华庄严光明佛　南无出火佛　南无无畏观佛　南无师子奋迅力佛　南无宝精进日月光明佛　南无庄严功德智声王佛　南无初发心念断一切疑烦恼佛　南无破一切闇胜佛　南无宝焰佛　南无栴檀香佛　南无大宝焰佛　南无华幢佛　南无普胜帝沙佛　南无满贤佛　南无最力精进奋迅佛　南无香胜佛　南无胜称佛　南无净镜佛　南无华胜佛　南无离尘佛　南无不动佛　南无得功德佛　南无栴檀佛　南无因陀罗财佛　南无乐山佛　南无能化佛　南无因陀罗幢佛　南无无畏作佛　南无富楼那佛　南无弗沙佛　南无法水清净虚空界王佛　南无普智光明胜王佛　南无香光明功德宝庄严王佛　南无普智声王佛　南无清净明无垢然灯佛　南无一切四无畏然灯佛　南无普喜速胜王佛　南无善光火光佛　南无普门智照声佛　南无无量功德海藏光明佛　南无法界电光无障碍功德佛　南无清净眼无垢然灯佛　南无师子光明胜光佛　南无广光明智胜幢佛　南无金光明无边力精进成佛　南无香光明欢喜力海佛　南无成就王佛　南无自在高佛　南无欢喜大海速行佛　南无称自在光佛　南无广称智佛　南无智成就海王幢佛　南无相显文殊月佛　南无一切法海胜王佛　南无智功德法住佛　南无梵自在胜佛　南无过法界胜声佛　南无不可嫌力普(丹本有照)光明幢佛　南无无垢功德日眼(丹明)佛　南无无碍智普照光明佛　南无无量胜鸡兜幢佛　南无法界虚空普边光明佛　南无福德相云胜威德佛　南无照胜顶光明佛　南无法风大海意佛　南无相法化普光明佛　南无善成就眷属普照佛　南无法尽疾速欢喜慧佛　南无无垢清净普光明佛　南无清净眼华胜佛　南无善智力成就佛　南无虚空清净眼月佛　南无然金色须弥灯佛　南无智胜宝法光明佛　南无然宝灯佛　南无普光明高山佛　南无火胜佛　南无波头摩奋迅佛　南无善天照佛　南无无尽功德佛　南无华威德佛　南无甘露力佛　南无声边佛　南无妙法胜威德成就佛　南无普光明声虚空照佛　南无普门见胜光佛　南无无边功德照佛　南无普光功德然灯镜像佛　南无喜乐现华火佛　南无宝须弥然灯王佛　南无善法化(丹善化法界)金光明电声佛　南无可降伏力愿佛　南无虚空城慧吼声佛　南无十方广遍称智然灯佛　南无师子光明满足功德海佛　南无智敷华光明佛　南无月幢佛　南无普眼满足法(丹有界)鸡兜幢佛　南无胜慧善导师佛　南无光明作佛　南无东方善护四天下名金刚良如来为上首　南无南方难胜四天下因陀罗如来为上首　南无西方亲意四天下婆楼那如来为上首　南无北方师子意四天下摩诃牟尼如来为上首　南无东北方善择四天下降伏诸魔如来为上首　南无东南方乐四天下毗沙门如来为上首　南无西南方坚固四天下不动如来为上首　南无西北方善地四天下普门如来为上首　南无下方炎四天下善集如来为上首　南无上方妙四天下得智者意如来为上首

归命如是等无量无边诸佛

南无卢舍那胜威德王佛　南无法界佛　南无普光明胜藏王佛　南无智灯佛　南无法界虚空智幢照佛　南无阿弥滥波眼佛　南无龙自在王佛　南无法月普智光王佛　南无普照胜弥留王佛　南无无障虚空智鸡兜幢王佛　南无普轮到声佛　南无无量宿自在王佛　南无香普遍佛　南无弥留然灯王佛　南无阿那罗眼境界佛　南无香毗头罗佛　南无旃陀鸡兜佛　南无一切佛宝胜王佛　南无无边世间智轮鸡兜佛　南无阿僧伽智鸡兜佛　南无师子佛　南无不可思议命佛　南无不可用佛　南无月智佛　南无大照佛　南无日灯佛　南无波头胜藏佛　南无卢舍那佛　南无无垢佛　南无山胜佛　南无普眼佛　南无梵命佛　南无婆薮天佛　南无无边光明平等法界庄严王佛　南无力光明佛　南无高行佛　南无栴檀围佛　南无金色意佛　南无妙饮佛　南无高声佛　南无最胜佛　南无高见佛　南无吉沙佛　南无弗沙佛　南无高称佛　南无妙波头摩佛　南无普功德佛　南无作灯佛　南无善目佛　南无一切法佛吼王佛　南无山幢身眼胜佛　南无功德幢佛　南无宝胜然灯功德幢佛　南无普智宝炎胜功德佛　南无胜轮佛　南无因陀罗幢胜鸡兜佛　南无金刚那罗延鸡兜佛　南无大悲云幢佛　南无无障碍胜安隐满足佛　南无火炎(丹本有山)胜庄严佛　南无一切法海胜王佛　南无宝髻炎满足灯佛　南无深法海光佛　南无一切十亿国土微尘数同名金刚藏佛　南无十亿国土微尘数同名金刚鸡兜佛　南无十百千国土微尘数同名金刚幢佛　南无十百千国土微尘数同名善法佛　南无十百千国土微尘数同名称心佛　南无一国土微尘数同名普功德佛　南无不可说佛国土微尘数同名不可胜佛　南无不可说佛国土微尘数同名毗婆尸佛　南无十佛国土微尘数同名普幢佛　南无八十亿佛国土微尘数不可数百千万亿那由他同名普贤佛　南无一佛国土微尘数同名觉胜佛　南无十佛国土微尘数百千万亿那由他不可说同名普称自在佛　南无贤胜佛　南无功德海光明胜照藏佛　南无法界虚空满足不退佛　南无法界吼佛　南无不退转轮法界声佛　南无法树山威德佛　南无法云吼王佛　南无一切法坚固吼王佛　南无智炬王佛　南无宝光然灯幢王佛　南无功德山光明威德王佛　南无法电幢王胜佛　南无法灯智师力山威德王佛　南无一切法印吼威德王佛　南无无垢法山威德灯佛　南无法轮光明顶佛　南无法光明胜云佛　南无法海说声王佛　南无法华高幢云佛　南无法炎山鸡兜王佛　南无法日智轮然灯佛　南无常智作化佛　南无法智普光明藏佛　南无法行深胜月佛　南无山王胜藏王佛　南无普门贤弥留法精进幢佛　南无(丹有一切)法宝俱苏摩胜云佛　南无寂静光明身髻佛　南无法光明慈镜像月佛　南无炎胜海佛　南无智日普照佛　南无普轮佛　南无智照顶王佛　南无智山法界十方光明威德王佛　南无功德光俱苏摩灯佛　南无智炬商鸡兜幢王佛　南无日照光明王佛　南无相山佛　南无庄严山佛　南无日步普照佛　南无法王网胜功德佛　南无四无畏金刚那罗延师子佛　南无普智幢勇猛佛　南无法波头摩敷身佛　南无功德俱苏摩身重担佛　南无道场觉胜月佛　南无然法炬胜月佛　南无普贤光明顶佛　南无法幢金刚坚幢佛　南无称山胜云佛　南无旃檀胜月佛　南无照一切王佛　南无普胜俱苏摩威德菩提佛　南无波头摩胜藏佛　南无香炎照王佛　南无因波头摩佛　南无相山照佛　南无普称功德王佛　南无胜相佛　南无普门光明须弥山佛　南无法城光明胜功德山威德王佛　南无法力勇猛幢佛　南无转法轮光明吼声佛　南无光明功德山智慧王佛　南无转法轮月胜波头摩照佛　南无佛幢自在功德不可胜幢佛　南无宝波头摩光明藏佛　南无光明峰云灯佛　南无普觉俱苏摩佛　南无种种光明胜山藏佛　南无明轮峰王佛　南无功德云盖佛　南无法峰云幢佛　南无法日云灯王佛　南无功德山威德佛　南无法云十方称王佛　南无法轮盖云佛　南无觉智智幢佛　南无智威德佛　南无法轮清净胜月佛　南无法力胜山佛　南无金山威德贤佛　南无贤胜山威德佛　南无普慧云声佛　南无香炎胜王佛　南无伽那迦摩尼山威德佛　南无须弥藏一切法光轮佛　南无然法轮威德佛　南无山峰胜威德佛　南无三昧海广顶冠光佛　南无日胜妙佛　南无普精进炬佛　南无宝妙胜王佛　南无法炬宝帐声佛　南无相庄严幢月佛　南无法虚空无边光师子佛　南无光明山雷电云佛　南无妙智敷身佛　南无法虚空无碍光佛　南无法三昧光佛　南无世间因陀罗妙光明云佛　南无法善庄严藏佛　南无法然灯炎坚固声佛　南无法轮峰光明佛　南无三世相镜像威德佛　南无法界师子光明佛　南无卢舍那胜须弥山三昧坚固师子佛　南无普光明城灯佛　南无宝俱苏摩藏佛　南无转妙法声佛　南无虚空劫灯佛　南无法幢佛　南无安隐世间月佛　南无摩诃迦罗那师子佛　南无安隐佛　南无可乐声佛　南无增上信威德佛　南无法虚空上胜王佛　南无医王佛　南无转法轮光明吼王佛　南无天藏佛　南无地峰王佛　南无智虚空乐王佛　南无一切吼王佛　南无不可降伏佛　南无十方(丹力)鸡兜佛　南无具足坚聚佛　南无转法轮化普光明声佛　南无相胜山佛　南无无垢婆蹉佛　南无住持疾行佛　南无遍相佛　南无无垢婆侯佛　南无师子步修佛　南无天自在顶佛　南无法起称佛　南无火(丹大)无忧茶佛　南无虚空灯佛　南无无垢幢佛　南无恒河沙同名贤行佛　南无恒河沙同名无边命佛　南无恒河沙同名不动佛　南无恒河沙同名月智佛　南无恒河沙同名金刚幢佛　南无恒河沙同名日藏佛　南无恒河沙同名善光佛　南无恒河沙同名金刚佛　南无五百同名大慈悲佛　南无普智炎功德幢王佛　南无善逝法幢胜佛　南无须弥佛　南无功德鬘佛　南无自在佛　南无寂王佛　南无无量爱佛　南无本称功德佛　南无须弥山佛　南无日月面佛　南无如是等无量佛　南无虚空行佛　南无普照佛　南无方城任(丹住)佛　南无胜光佛　南无云胜佛　南无法炎山佛　南无波头摩生佛　南无法界华佛　南无海灯佛　南无寂灭佛　南无如是等无量无边佛　南无宝鸡兜王佛　南无智意佛　南无思议佛　南无因陀罗胜佛　南无天(丹大)智佛　南无云王畏佛　南无智胜佛　南无光明王鸡兜佛　南无胜奋迅威德去(丹王)佛　南无行广见佛　南无法界波头摩佛　南无宝炎山佛　南无如是等无量无边佛　南无胜光佛　南无宝功德佛　南无海胜佛　南无法光明佛　南无波头摩佛　南无藏胜佛　南无世间眼佛　南无如是等无量无边佛　南无香光佛　南无须弥胜佛　南无岳王佛　南无深胜佛　南无胜摩尼佛　南无藏王佛　南无胜威德畏佛　南无寂色去佛　南无如是等无量无边佛　南无广智佛　南无宝光明佛　南无虚空云胜佛　南无妙相佛　南无胜相佛　南无庄严佛　南无行轮佛　南无光胜佛　南无光明胜佛　南无如是等无量无边佛　南无那罗延行佛　南无须弥胜佛　南无功德轮佛　南无胜王佛　南无不可降伏佛　南无山王树佛　南无如是等无量无边佛　南无莎罗自在王佛　南无胜藏佛　南无世间自在身佛　南无镜像光明佛　南无地出佛　南无光明功德佛　南无金刚色佛　南无住持威德胜佛　南无如是等无量无边佛　南无深法光明身佛　南无法海吼声佛　南无弥留幢胜光明意佛　南无梵光佛　南无宝光明胜佛　南无虚空声佛　南无法界镜像胜佛　南无轮光明佛　南无智光高鸡兜意佛　南无伽伽那灯佛　南无乐胜照佛　南无功德光明胜佛　南无寂胜佛　南无大悲速疾佛　南无地力光明意佛　南无一切修面色佛　南无胜身光明佛　南无法胜宿佛　南无阿尼罗速行佛　南无清净幢盖胜佛　南无三世镜像佛　南无愿海乐说胜佛　南无惭愧须弥山胜佛　南无法意佛　南无念鸡兜王胜佛　南无慧灯佛　南无光明鸡兜胜佛　南无广智上佛　南无法界行智意佛　南无法海意智胜佛　南无法宝胜佛　南无功德轮佛　南无胜云佛　南无忍辱灯佛　南无胜威德意佛　南无世间灯佛　南无速光明赊摩他声佛　南无寂幢佛　南无大愿胜佛　南无不可降伏幢佛　南无智炎胜功德佛　南无法自在佛　南无无碍意佛　南无具足意佛　南无世间言语坚固吼光佛　南无一切声分吼胜精进自在佛　南无诸方天佛　南无现面世间佛　南无知众生心平等身佛　南无行佛行佛　南无最胜佛　南无行等佛　南无清净身佛　南无胜贤佛　南无如是等上首不可说不可说无量无边佛

南无彼妙法身佛。南无彼诸佛所说妙法。南无彼佛三十二相八十种好无量无边功德。　南无彼佛种种道场菩提树。种种形像。种种妙塔。去来坐卧妙处

南无彼诸佛不退法轮菩萨大僧。不退声闻僧。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽种种状貌。信如来法轮转如来法轮。不可思议菩萨摩诃萨悉皆归命

南无彼佛十力四无所畏四无碍智。戒定慧解脱解脱知见。如是等无量无边功德。如是功德回施一切众生。愿得阿耨多罗三藐三菩提。舍利弗归命

善眼劫中七十那由他佛出世。南无善见劫中七十二亿佛出世。南无梵赞叹劫中一万八千佛出世。南无过去劫中三十三千佛出世。南无庄严劫中八万四千佛出世。应当归命如是等无量无边诸佛

善男子善女人。欲灭一切罪。应当净洗浴着新净衣。称如是等佛名礼拜。应作是言。我无始世界来身口意业作不善行。乃至谤方等经五逆罪等愿皆消灭。舍利弗。善男子善女人。欲满足波罗蜜行。欲回向无上菩提。欲满足一切菩萨诸波罗蜜。应作是言。我学过去未来现在菩萨摩诃萨。修行大舍破胸出心施于众生。如智胜菩萨及迦尸王等。舍妻子等布施贫乏。如不退菩萨及[阿-口+日]翅罗那王须达拏及庄严王等。入于地狱救苦众生。如大悲菩萨及善眼天子等。救恶行众生。如善行菩萨及胜行王等。舍顶上宝天冠。并剥头皮而与。如胜上身菩萨及宝髻天子等。舍眼布施。如爱作菩萨及月光王等。舍耳鼻。如无怨菩萨及胜去天子等。舍齿布施。如花齿菩萨及六牙象王等。舍舌布施。如不退菩萨及善面王等。舍手布施。如常精进菩萨及坚意王等。舍血无悔。如法作菩萨及月思天子等。舍肉及髓。如安隐菩萨及一切施王等。舍大肠小肠肝肺脾肾。如善德菩萨及自远离诸恶王等。舍身支节一切大小。如法自在菩萨及光胜天子等。舍身皮肤。如清净藏菩萨及金色天子金色鹿王等。舍手足指。如坚精进菩萨及金色王等。舍手足甲。如不可尽菩萨及求善法天子等。为求法故入大火坑。如精进菩萨及求妙法王精进等。为求法故卖身刳心破骨出髓。如萨陀波仑菩萨及金坚王等。受一切苦恼。如求妙法菩萨及速行大王等。舍四天下大地及一切庄严。如得大势至菩萨及胜功德月天子等。舍身。如摩诃萨埵菩萨及摩诃婆罗王等。舍身。与一切贫穷苦恼众生作给使侍者。如尸毗王等。举要言之。过去未来现在诸菩萨一切波罗蜜行愿。我亦如是成就。十方世界诸妙香华鬘诸妙伎乐。我随喜供养佛法僧。复回此福德施一切众生。愿因此福德诸众生等莫堕恶道。因此福德满足八万四千诸波罗蜜行。速得授阿耨多罗三藐三菩提记。速得不退转大地。速成无上菩提。舍利弗。应当敬礼十方诸佛

南无不动佛　南无尽圣佛　南无日光佛　南无龙奋迅佛　南无自在光明称佛　南无十光佛　南无普宝佛　南无称自在佛　南无胜藏称佛　南无炎意佛　南无宝幢佛　南无智山佛　南无因光佛　南无生胜佛　南无弥留藏佛　南无智海佛　南无大精进佛　南无弥留功德佛　南无胜藏佛　南无智德佛　南无能与无畏佛　南无大精进趣王佛　南无智成就佛　南无无滞佛　南无地力住持精进佛　南无力命佛　南无善眼佛　南无灭魔佛　南无不害法王佛　南无不可思议精进佛　南无观功德佛　南无智频婆佛　南无心自在佛　南无阿僧伽力精进佛　南无枲荷难陀佛　南无戒光佛　南无贤上王佛　南无无边光王佛　南无观功德佛　南无智频婆佛　南无无尽智藏佛　南无宝雨头佛　南无智波婆罗佛　南无毗尼称佛　南无无边功德王佛　南无法华婆师佛　南无光焰佛　南无妙山王佛　南无转法轮胜王佛　南无无垢目佛　南无住持大般若佛　南无不住力精进王佛　南无自在识佛　南无现念佛　南无福德力精进佛　南无智袈裟王佛　南无智自在佛　南无安隐众生无障佛　南无智集佛　南无摩诃弥留力藏佛　南无虚空光明佛　南无阿伽楼功德精进佛　南无离痴功德声王佛　南无法施庄严佛　南无声自在王佛　南无护门佛　南无自在力精进王佛　南无宝光明胜王佛　南无胜一切须弥山王佛　南无罗多那弥留佛　南无不可得动法佛　南无罗多那弥留陀王佛　南无陀罗尼自在王佛　南无普功德王佛　南无法莎罗王弥留佛　南无善华王佛　南无智集功德聚佛　南无智炎华树王佛　南无一切世间自在佛　南无住法分称佛　南无金千遮那王佛　南无法幢奋迅王佛　南无栴檀波罗围绕佛　南无坚心意精进佛　南无照一切世间灯佛　南无随众生心奋迅佛　南无功德炎华佛　南无无边称娑罗幢佛　南无知(丹智)行佛　南无过去称法雨佛　南无乐威德灯佛　南无离诸障无畏佛　南无智照声佛　南无二成就佛　南无集妙行佛　南无乐庄严王佛　南无阿僧祇庄严王佛　南无师子座善住佛　南无放栴檀华王佛

舍利弗。我于此坐以清净无障碍过人天眼。见东方多百佛。多千佛。多百千佛。多百千万佛。多百千亿佛。多百千万亿那由他佛。无量阿僧祇佛。不可思议佛。不可思佛。种种名。种种姓。种种世界。种种佛国土。种种比丘比丘尼优婆塞优婆夷围绕。种种天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。围绕供养。我悉现见如观掌中庵摩勒果。舍利弗。若有众生。信我语受持读诵是诸佛名。当净洗浴着新净衣。于昼日初分时中分时后分时。夜亦三时从坐起偏袒右肩右膝着地。一心称是佛名供养礼拜作如是言。如来所知十方诸佛我今敬礼

舍利弗。是众生如是供养礼拜得无量福德。若欲得声闻地。欲得辟支佛地。欲得阿耨多罗三藐三菩提者。当礼十方诸佛。一切皆得。复作是言。是诸福德聚诸佛如来所知。我悉回向阿耨多罗三藐三菩提

南无东方一切诸佛　南无法自在奋迅佛　南无修行坚固自在佛　南无法山胜佛　南无师子奋迅王佛　南无力士自在王佛　南无自在陀罗集佛　南无宝山佛　南无树提藏佛　南无无量宿称佛　南无功德力坚固王佛　南无三世法界佛　南无人声自在增长佛　南无妙声吼佛　南无胜一切世间佛　南无宝地龙王佛　南无法疾吼声佛　南无多供养佛　南无香波头摩择自在宝城佛　南无光轮佛　南无宝莲佛　南无功德华佛　南无无边功德王佛　南无增长喜佛　南无师子龙奋迅佛　南无莎罗藏师子步行佛　南无观诸法佛　南无法华智佛　南无时法清净佛　南无坚固精进言语佛　南无声精进佛　南无炎摩尼佛　南无山光明佛　南无清净无垢藏佛　南无无垢月佛　南无清净根佛　南无多智佛　南无能作智佛　南无广智佛　南无力意佛　南无胜意佛　南无法坚固欢喜佛　南无等须弥面佛　南无观成就佛　南无清净藏佛　南无坚固行自在佛　南无象自在佛　南无现魔业净业佛　南无智自在佛　南无智精进奋迅佛　南无无碍精进佛　南无世间自在佛　南无法行广意佛　南无福德成就佛　南无不怯弱成就佛　南无胜成就佛　南无龙观佛　南无须弥旃檀佛　南无作戒王佛　南无聚集宝佛　南无龙王声佛　南无大智精进佛　南无孤独精进佛

归命如是等无量无边诸佛

佛说佛名经卷第九此宋本经孤独精进佛后。更有不减庄严佛不动尼陀佛乃至法王佛等二百一十佛。于第十卷初重出。今捡诸本此无彼有。故此除之佛说佛名经卷第十

        元魏天竺三藏菩提流支译

南无不减庄严佛　南无不动尼他佛　南无百功德庄严佛　南无自在诸相好称佛　南无自在因陀罗月佛　南无法华山佛　南无法界庄严佛　南无满足愿佛　南无大师庄严佛　南无师子平等精进佛　南无修行自在坚固佛　南无乐法修行佛　南无胜慧佛　南无海步佛　南无大如修行佛　南无高光明佛　南无无诤智佛　南无师子声佛　南无善报佛　南无善住佛　南无日光佛　南无甘露增上佛　南无道上首佛　南无胜自在亲佛　南无善见佛　南无无浊义佛　南无胜意佛　南无人月佛　南无威德光佛　南无普明佛　南无大庄严佛　南无师子奋迅去佛　南无摩楼多爱佛　南无寂心佛　南无大步佛　南无可闻声佛　南无积功德佛　南无摩尼向佛　南无爱照佛　南无名称佛　南无信功德佛　南无清净智佛　南无宝功德佛　南无妙信香佛　南无热固(余本热园)佛　南无胜仙(余本山)佛　南无宝(余本实)智佛　南无甘露威德佛　南无藏信(余本信藏)佛　南无月上胜佛　南无龙步佛　南无信黠慧佛　南无爱实语佛　南无忧波罗香佛　南无栴檀自在佛　南无敌胜佛　南无普行佛　南无功德胜佛　南无大威德佛　南无种种色日佛　南无过诸过佛　南无无量眼佛　南无惭愧智佛　南无功德供养佛　南无种种声佛　南无功德可乐佛　南无住清净佛　南无妙香佛　南无月光佛　南无戒分佛　南无花智佛　南无忧多摩意佛　南无不闇意佛　南无山自在积佛　南无寂王佛　南无解脱王佛　南无阿蹉弥留王佛　南无如意力释(余本择)去佛　南无姓阿提遮佛　南无胜园佛　南无不赞叹世间胜佛　南无法染佛　南无宝星宿解脱王佛　南无白宝胜佛　南无法行自在佛　南无陀罗尼自在佛　南无阿难陀声佛　南无智步王佛　南无弥留平等奋迅王佛　南无智奋迅佛　南无法华通树提佛　南无多波尼体佛　南无阿尼伽陀路摩胜佛　南无忧多罗胜法佛　南无大智念缚佛　南无阇伽提自在一切世间担佛　南无见无畏佛　南无自在作佛　南无自在量佛

舍利弗。我见南方如是等无量佛种种名种种姓种种佛国土。汝等应当至心一心归命。舍利弗。应当归命西方无量佛

南无阿婆罗炎婆师华佛　南无摩[少/兔]沙口声去佛　南无智胜增长称佛　南无莎漫多波尸佛　南无歌罗毗罗炎华光佛　南无法行灯佛　南无无等胜佛　南无智奋迅名称王佛　南无梵声奋迅妙鼓声佛　南无波头摩尸利藏眼佛　南无阿僧伽意炎佛　南无千月光明藏佛　南无乐法行佛　南无摩尼婆陀光佛　南无师子广眼佛　南无十力生胜佛　南无智作佛　南无无边精进降伏一切诸怨佛　南无大胜起法佛　南无阿无荷见佛　南无无边命佛　南无观法智佛　南无无碍精进日善思惟奋迅王佛　南无不利他意佛　南无无边见佛　南无智见法佛　南无一切善根种子佛　南无忧多智胜发行功德佛　南无智香胜佛　南无智上尸弃王佛　南无福德胜智去佛　南无不可思议法华吼王佛　南无法清净胜佛　南无不可思议弥留胜佛　南无能开法门佛　南无毗卢舍那法海香王佛　南无力王善住法王佛　南无胜力散一切恶王佛　南无见无边乐佛　南无善化功德炎花王佛　南无见彼岸佛　南无善化庄严佛　南无见乐处佛　南无尼拘律王胜佛　南无妙胜佛　南无大力智慧奋迅王佛　南无法树提佛　南无坚固盖成就佛　南无一切种智资生胜佛　南无入胜智自在山佛　南无一切世间得自在有桥梁胜佛　南无尽合胜佛　南无清净戒功德王佛　南无波头摩散漫(余本有楞)智多庄严佛　南无一王佛　南无大多人安隐佛　南无二胜声功德佛　南无圆坚佛　南无力士佛　南无宝珠摩尼火佛　南无大海弥留佛　南无胜王佛　南无不住佛　南无不空功德佛　南无初远离不浊王佛　南无虚空行佛　南无无碍称佛　南无声山佛　南无不可思议起三昧称佛　南无诸天梵王鸡兜佛　南无示无义王佛　南无护垢王佛　南无照功德佛　南无自在眼佛　南无智寂成就性佛　南无无障智成就佛　南无说决定义佛　南无庄严法灯妙称佛　南无二宝法灯佛　南无大炎藏佛　南无自师子上身庄严佛　南无智宝因缘庄严佛　南无服诸根清净眼佛　南无善香随香波头摩佛　南无法(丹本有月)佛　南无广(丹本有救)佛　南无戒功德佛　南无常镜佛　南无随顺称佛　南无法自在佛　南无如意庄严佛　南无(丹本有金)藏佛　南无慎(余本责)贪佛　南无思妙义坚固愿佛　南无一切德轮光佛　南无法吼智明佛　南无甘露光佛　南无无边庄严佛　南无胜福田佛　南无善决定诸(丹本有佛)法庄严佛　南无善决定佛　南无法庄严佛

舍利弗。西方如是等无量无边佛。汝当至心归命。舍利弗。汝当至心归命北方佛

南无胜藏佛　南无自在藏佛　南无无边华龙一俱苏摩生(丹王)佛　南无降伏诸魔勇猛佛　南无定诸魔佛　南无法像佛　南无功德胜佛　南无山峰光佛　南无法王佛　南无普恭敬灯佛　南无地胜佛　南无成就如来寂佛　南无一切宝成就寂佛　南无陀罗尼文句决定义佛　南无忍自在王佛　南无成就一切称佛　南无三世智转自在佛　南无胜归依功德善住佛　南无种种摩尼光佛　南无胜功德佛　南无一切宝成就寂佛　南无佛功德胜佛　南无无余证佛　南无得佛眼佛　南无随过去佛佛　南无大慈成就悲胜佛　南无住持师子智佛　南无无众生住实际王佛　南无自家法不得成就佛　南无大智庄严身佛　南无智称佛　南无佛法首佛　南无一切众生德佛　南无过一切法间(丹门)佛　南无自在因陀罗佛　南无满足意佛　南无大琉璃佛　南无菩提光明佛　南无不可思议法智光明佛　南无真(丹栴)檀不空王佛　南无不染波头摩幢佛　南无法财声王佛　南无释(丹择)法善知(丹智)称佛　南无智鬘劫佛　南无佛眼清净分陀利佛　南无智自在称佛　南无断无边疑佛　南无众生方便自在王佛　南无无边觉奋迅无碍思惟佛　南无法行地行善住佛(地下丹无行)　南无普众生界广佛　南无降伏诸魔力坚意佛　南无天王自在宝合王佛　南无如实修行藏佛　南无能生一切欢喜月见佛　南无大迅觉迅佛　南无种种摩尼声王吼佛　南无无观王佛　南无不退了勇猛佛　南无佛国土庄严身佛　南无智根本华幢佛　南无化身无碍称佛　南无一切龙摩尼藏佛　南无法声自在佛　南无法甘露莎梨罗佛　南无无边宝福德藏佛　南无清净华行佛　南无大法王华胜佛　南无一切尽无尽藏佛　南无华山藏佛　南无智虚空山佛　南无智力不可破坏佛　南无无碍坚固随顺智佛　南无无边大海藏佛　南无智王无尽称佛　南无奋迅心意王佛　南无自性清净智佛　南无智自在法王佛　南无胜行佛　南无金刚见佛　南无法满足随香见佛　南无龙月佛　南无因陀罗围佛　南无无碍王佛　南无宝因陀罗轮王佛　南无能生一切众生敬称佛　南无大威德光明轮王佛　南无能断一切众生疑佛　南无智宝法见佛　南无无障碍波罗佛　南无无垢髻佛　南无放光明佛　南无山力月藏佛　南无心自在王佛　南无坚固无畏上首佛　南无坚固勇猛宝佛　南无坚固心善住王佛　南无能破闇曀王佛　南无胜丈夫分陀利佛　南无百圣胜藏佛　南无妙莲华藏佛　南无见平等法身佛　南无众生月佛　南无师子去佛　南无大威德佛　南无妙声佛　南无无边光佛　南无见爱佛　南无大首佛　南无胜首佛　南无乐声佛　南无见宝(丹实)佛　南无清净(丹称)佛　南无师子慧佛　南无德声佛　南无修楼毗香佛　南无电灯佛　南无波头摩光佛　南无大光佛　南无梵声佛　南无无疑佛　南无无边势力佛　南无月面佛　南无无边光佛　南无爱威德佛　南无散疑佛　南无功德灯佛　南无不藏威德佛　南无无边藏佛　南无光明奋迅王佛　南无广称佛　南无远离幢佛　南无增长圣佛　南无普见佛　南无不可胜佛　南无威德聚佛　南无坚固步佛　南无摩[少/兔]赊称佛　南无无边色佛　南无大光明佛　南无妙声佛　南无不动步佛　南无无边庄严佛　南无大清净佛　南无威德聚光明佛　南无住智佛　南无(丹本有金)坚佛　南无爱解脱佛　南无爱无畏佛　南无甘露藏佛　南无普观察佛　南无大修行佛　南无细威德佛　南无十方恭敬佛　南无光明胜佛　南无重说佛　南无光明庄严佛　南无师子奋迅佛　南无善见佛　南无甘露步佛　南无月光明佛　南无功德称佛　南无去根佛　南无清净声佛　南无无碍轮佛　南无甘露声佛　南无众生可敬佛　南无如意威德佛　南无无边色佛　南无大力佛　南无快庄严佛　南无普照观佛　南无奋迅德佛　南无妙色佛　南无称意佛　南无宝庄严佛　南无高光明佛　南无解脱步佛　南无功德庄严佛　南无毕竟智佛　南无生鸡兜佛　南无不动智佛　南无行意佛　南无妙色佛　南无实色佛　南无火声佛　南无善思惟佛　南无功德华佛　南无思惟世间佛　南无大高光(丹有明)佛　南无无譬喻奋迅佛　南无清净觉佛　南无月重佛　南无月灯佛　南无无边光佛　南无种种日佛　南无天城佛　南无心清净佛　南无波头摩藏佛　南无常择智佛　南无师子声佛　南无无边光佛　南无胜声佛　南无可乐意智光佛　南无功德光佛　南无自在光佛　南无净严身(丹有光)佛　南无无浊义佛　南无应威德佛　南无成就义智佛　南无得大声佛　南无婆薮陀声佛　南无郁哆光佛　南无决定思惟佛　南无萨遮婆[少/兔]佛　南无呜阇光明佛　南无毗弗波威德佛　南无忧多罗魔吒佛　南无夜合(丹舍)鸡兜佛　南无功德清净佛　南无法灯佛　南无胜功德佛　南无仙荷波提爱面佛　南无心荷步去佛　南无思惟众生佛　南无莎伽罗智佛　南无波头摩藏佛　南无盖仙佛　南无莎罗王佛　南无修利耶光佛　南无菩提味佛　南无寂诸根佛　南无婆[少/兔]光佛　南无芬陀利光佛　南无弥留光佛　南无旃陀面佛　南无莎利荼去佛　南无诸方眼佛　南无法光明佛　南无尸罗波散那佛　南无阿难陀智佛　南无阿难陀色佛　南无地荼毗梨耶佛　南无提婆弥多佛　南无莎漫多智佛　南无寂静光佛　南无摩[少/兔]舍威德佛　南无善分若提他佛　南无称圣佛　南无称幢佛　南无轮面佛　南无普清净佛　南无摩诃提阇佛　南无阿罗诃应佛　南无忧多那胜佛　南无悉达他思惟佛　南无爱供养佛　南无三漫多护佛　南无尼弥佛　南无信菩提佛　南无破意佛　南无出智佛　南无胜声佛　南无质多罗婆[少/兔]佛　南无弥荷声佛　南无大炎骞陀佛　南无声拘吒佛　南无阿舒加爱佛　南无天国土佛　南无师子难提拘沙佛　南无阿难陀波颇佛　南无见爱佛　南无波提波王佛　南无胜鸡兜佛　南无方闻声佛　南无爱眼佛　南无旃陀鸡兜佛　南无阿婆夜达多佛　南无那刹多王佛　南无苏摩提婆佛　南无日光明佛　南无大称佛　南无真声佛　南无说爱佛　南无称忧多罗佛　南无摩头罗光明佛　南无修佉(丹法)声佛　南无质多意佛　南无婆薮陀清净佛　南无寂嗔佛　南无破意佛　南无宿王佛　南无毗伽陀畏佛　南无胜忧多摩佛　南无波萨那智佛　南无慈胜种种光佛　南无普见佛　南无见月佛　南无降伏诸魔威德佛　南无摩诃罗他佛　南无心荷步去佛　南无乐光佛　南无普护佛　南无清净意佛　南无成就义佛　南无香山佛　南无摩尼清净佛　南无功德光佛　南无日光佛　南无成就光佛　南无见爱佛　南无善思惟佛　南无莎漫多见佛　南无师子幢佛　南无普行佛　南无大步佛　南无阿罗频头波头摩眼佛　南无日光佛　南无阿弥多清净佛　南无阿难多楼波佛　南无盖天佛　南无罗多那光佛　南无莎罗梯罗多佛　南无善见佛　南无亲味佛　南无婆耆罗莎佛　南无修利耶那那佛　南无无障碍眼佛　南无莎荷去佛　南无大然灯佛　南无卢荷伽佛　南无清净功德佛　南无功德藏佛　南无法(丹本有明)佛　南无摩楼多爱佛　南无阿婆耶爱佛　南无慧幢佛　南无威德光佛　南无月德佛　南无求那婆薮佛　南无无边光佛　南无安乐佛　南无称鸡兜佛　南无光明吼佛　南无普功德佛　南无胜鸡兜佛　南无那罗延佛　南无宝清净佛　南无普心佛　南无善心意佛　南无善意佛　南无不可量威德佛　南无师子臂佛　南无光明意佛　南无那罗延天佛　南无萨遮鸡兜佛　南无善住意佛　南无阿弥多天佛　南无大慧德佛　南无大幢佛　南无光明日佛　南无法(丹本有水)佛　南无善法佛　南无旃陀婆[少/兔]佛　南无庵摩罗胜佛　南无解脱观佛　南无罗多那光佛　南无无罗声佛　南无普心择佛　南无成就光佛　南无甘露眼佛　南无称爱佛　南无善护佛　南无天信佛　南无善量步佛　南无提婆罗多佛　南无深智佛　南无斯那步佛　南无旃陀跋陀佛　南无提阇积佛　南无大胜佛　南无大步佛　南无阇耶天佛　南无悉达他意佛　南无质多爱佛　南无师子声佛　南无信提舍那佛　南无智光佛　南无拘苏摩提阇佛　南无提阇罗尸佛　南无如意光佛　南无无边威德佛　南无无边光佛　南无胜藏佛　南无卢遮那称佛　南无宝鸡兜佛　南无郁伽提阇佛　南无日鸡兜佛　南无摩诃弥留佛　南无摩诃馥荷佛　南无世间得名佛　南无郁伽德佛　南无忧多摩称佛　南无成就义步佛　南无提婆摩醯多佛　南无实(丹本有智)佛　南无阿那毗浮多称佛　南无金光佛　南无大然灯佛　南无行意佛　南无毗迦摩佛　南无无碍光佛　南无毗摩提阇诃佛　南无摩诃跋多佛　南无天声佛　南无不着步佛　南无天道佛　南无询陀罗难陀佛　南无华光佛　南无能现佛　南无天爱佛　南无解脱光佛　南无普光佛　南无求那迦罗佛　南无智(丹有说)佛　南无菩提光佛　南无莎伽罗佛　南无菩提难提佛　南无摩诃提婆佛　南无深智佛　南无法自在佛　南无大波那那佛　南无心意佛　南无智光明佛　南无不错思惟佛　南无胜功德佛　南无坐称佛　南无大庄严佛　南无月光佛　南无天光佛　南无清净行佛　南无爱功德佛　南无师子意佛　南无信婆薮那罗佛　南无宝光明佛　南无快光明佛　南无种种婆[少/兔]佛　南无月爱佛　南无苏摩刈(丹刹)多佛　南无普观佛　南无不染佛　南无称光胜佛　南无月面佛　南无那伽天佛　南无功德聚佛　南无功德智佛　南无华胜佛　南无爱世间佛　南无甘露光佛　南无地光佛　南无作功德佛　南无花胜佛　南无求那婆睺佛　南无法然灯佛　南无普光佛　南无净声佛　南无大庄严佛　南无解脱日佛　南无坚精进佛　南无智光明佛　南无功德称佛　南无善智佛　南无不可量庄严佛　南无师子陀那佛　南无功德奋迅佛　南无妙天佛　南无观行佛　南无天提吒佛　南无电光明佛　南无胜爱佛　南无山幢佛　南无华光佛　南无胜意佛　南无山香佛　南无福德奋迅佛　南无胜意佛　南无信圣佛　南无宝洲佛　南无妙威德佛　南无最后见佛　南无爱行佛　南无妙庄严佛　南无功德藏胜佛　南无清净见佛　南无威德力佛　南无清净眼佛　南无智行佛　南无不谬步佛　南无圣眼佛　南无乐解脱佛　南无大声佛　南无胜王佛　南无成就光明佛　南无自业佛　南无照称光明佛　南无光明行佛　南无爱自在佛　南无月贤佛　南无胜吼佛　南无胜功德佛　南无撰择摄取佛　南无相王佛　南无离热佛　南无圣德佛　南无法高佛　南无甘露功德佛　南无无碍称佛　南无甘露香佛　南无舍光明佛　南无吼声佛　南无无畏日佛　南无得无畏佛　南无爱黠慧佛　南无智慧不谬佛　南无虚空光佛　南无增上天佛　南无信如意佛　南无天盖佛　南无龙光佛　南无妙步佛　南无法威德佛　南无断诸有佛　南无庄严面佛　南无妙色佛　南无普眼佛　南无功德光佛　南无胜月佛　南无平等德佛　南无云何鸡兜佛　南无众生自在劫佛　南无与无畏亲佛　南无(丹有摄)取众生意佛　南无降伏诸怨佛　南无摄取光明佛　南无胜山佛　南无一胜光明佛　南无那罗延步佛　南无师子步佛　南无爱戒佛　南无清净佛　南无信名称佛　南无毕竟智佛　南无离痴佛　南无功德聚佛　南无能思惟忍佛　南无法盖佛　南无不动因佛　南无天华佛　南无天波头摩佛　南无普威德佛　南无月光佛　南无大众上首佛　南无思惟义佛　南无相王佛　南无华面佛　南无思惟名称佛　南无树幢佛　南无师子奋迅佛　南无信大众佛　南无善香佛　南无智慧赞叹佛　南无功德梁佛　南无智光明佛　南无智海佛　南无威德力佛　南无胜威德佛　南无佛欢喜佛　南无胜清净佛　南无爱一切佛　南无远离诸疑佛　南无善思惟胜义佛　南无大山佛　南无降伏圣(丹本有信)佛　南无降伏黠慧佛　南无趣菩提佛　南无妙声佛　南无大势力佛　南无乐师子佛　南无普宝满足佛　南无一切世间爱佛　南无金刚轮佛　南无过火佛　南无大将佛　南无众生月佛　南无大庄严佛　南无日光明佛　南无胜严佛　南无断诸有意香佛　南无寂静行佛　南无摄受称佛　南无梵天供养佛　南无大吼佛　南无无量无边愿佛　南无世间光明佛　南无可见忍佛　南无大华佛　南无修行身佛　南无诸根清净佛　南无普见佛　南无婆薮达多佛　南无月贤佛　南无不怯弱声佛　南无决定色佛　南无方便修佛　南无信胜功德佛　南无胜报佛　南无贤庄严佛　南无堪受器声佛　南无惭愧贤佛　南无胜爱佛　南无普行佛　南无普智佛　南无大威力(丹德)佛　南无月鸡兜佛　南无坚固行佛　南无天供养佛　南无敬普佛　南无成就一切功德佛　南无胜妙称佛　南无坚固莎梨罗佛　南无甘露光佛　南无大贵佛　南无胜声佛　南无大力佛　南无大步佛　南无信甘露佛　南无道步佛　南无胜声心佛　南无胜意佛　南无婆楼那步佛　南无大修行佛　南无威德光佛　南无(丹本有无)净智佛　南无师子声佛　南无善德佛　南无善住佛　南无日光佛　南无菩提上首佛　南无降伏怨佛　南无无垢浊义佛　南无胜去佛　南无妙光明佛　南无普光明佛　南无大庄严佛　南无功德山佛　南无摩尼月佛　南无爱眼佛　南无胜名佛　南无菩提智佛　南无宝功德佛　南无天光明佛　南无胜仙佛　南无实(丹本有智)佛智佛　南无甘露威德佛　南无能思惟佛　南无龙步佛　南无信智佛　南无实爱佛　南无莲华香佛　南无胜相佛　南无大威德佛　南无种种日佛　南无广地佛　南无甘露眼佛　南无惭愧智佛　南无山王自在积佛　南无悕胜佛　南无种种间错声佛　南无信修行佛　南无舍忧恼佛　南无诸世间智佛　南无威德力佛　南无信胜佛　南无势力称佛　南无放光明佛　南无过诸疑佛　南无毗罗那王佛　南无新华佛　南无胜华佛　南无舍诤佛　南无大长佛　南无大称佛　南无爱去佛　南无甘露步佛　南无日聚佛　南无月声佛　南无见天佛　南无清净光佛　南无秋日佛　南无斛华佛　南无妙声佛　南无雨甘露佛　南无善天佛　南无胜声佛　南无爱上首佛　南无爱甘露佛　南无甘露称佛　南无法华佛　南无大庄严佛　南无世间尊重佛　南无高意佛　南无高山佛　南无甘露威德光明佛　南无菩提威德佛　南无清净心佛　南无能作因降伏怨佛　南无香山佛　南无甘露星宿佛　南无大称佛　南无安隐思惟佛　南无菩提华佛　南无庵摩罗供养佛　南无摩尼清净佛　南无度世间佛　南无(丹有胜)成佛　南无法星宿佛　南无大胜佛　南无随意光明佛　南无火光明佛　南无见爱佛　南无光明爱佛　南无势力称佛　南无放光明佛

佛说佛名经卷第十此卷从初不减庄严佛至第七幅末五行法王佛凡二百一十佛此宋本经于前第九卷末三十二幅后更有七纸经已载之今此重载按乡丹二本此有彼无则前第九卷者错重载耳故今除彼错重载者其有佛名中字疑可取者往往取而注出之云余本者是也佛说佛名经卷第十一

        元魏天竺三藏菩提流支译

南无希声佛　南无功德德佛　南无舌去佛　南无无障智佛　南无得威德佛　南无月藏佛　南无梵光明佛　南无乐光明佛　南无胜光明佛　南无寂光明佛　南无离异意佛　南无无边智佛　南无成就功德佛　南无严身佛　南无无畏爱佛　南无到光明佛　南无大声佛　南无知智佛　南无大思惟佛　南无乐眼佛　南无无诸势(丹热)智佛　南无不怯弱智佛　南无普清净佛　南无舍施威德佛　南无天城佛　南无无怯声佛　南无华日佛　南无善住心佛　南无鸡兜清净佛　南无俱苏摩光佛　南无法弗沙佛　南无月希佛　南无寂照佛　南无不错行佛　南无大精进佛　南无人声佛　南无普声佛　南无菩提愿佛　南无天色思惟佛　南无慧力佛　南无三漫多卢遮那佛　南无梵供养佛　南无圣弗沙佛　南无虚空智佛　南无能降伏放逸佛　南无不可比慧佛　南无胜军陀罗佛　南无降阿梨佛　南无应爱佛　南无戒供养佛　南无平等心明佛　南无心不怯弱佛　南无精进清净佛　南无间(丹闻)智佛　南无无障碍思惟佛　南无无畏光明佛　南无甘露声佛　南无名去佛　南无舍诤佛　南无护根佛　南无禅解脱佛　南无大殊提佛　南无旃檀香佛　南无可观佛　南无无量智佛　南无千日威德佛　南无舍重担佛　南无称清净佛　南无提赊间(丹闻)佛　南无自在王佛　南无无边智佛　南无广光佛　南无信甘露佛　南无妙根(丹眼)佛　南无解脱行佛　南无妙见佛　南无胜光佛　南无大声佛　南无大威德聚佛　南无光明实鸡兜佛　南无应供养佛　南无求那提阇积佛　南无信相佛　南无大炎佛　南无阿罗诃信佛　南无善住思惟佛　南无善桥梁佛　南无智作佛　南无普宝佛　南无日光佛　南无说桥梁佛　南无婆萨婆俱他佛　南无心荷身佛　南无胜亲光佛　南无清净声佛　南无随意布施佛　南无宝威德佛　南无善威德供养佛　南无世间光明佛　南无世间可敬佛　南无行清净佛　南无应眼佛　南无大步佛　南无无边色佛　南无住持般若佛　南无众桥梁佛　南无弥留波婆佛　南无安隐爱佛　南无提婆摩醯多佛　南无毗阇荷佛　南无罗多那阇荷佛　南无桥梁佛　南无厚奋迅佛　南无光明威德佛　南无慈力佛　南无月胜佛　南无寂光佛　南无爱眼佛　南无天色佛　南无乐法佛　南无大月佛　南无无障碍声佛　南无人弗沙佛　南无平等见佛　南无大旃陀佛　南无弗沙罗莎佛　南无十光佛　南无种种光佛　南无云声佛　南无龙德佛　南无功德步佛　南无心功德佛　南无大声佛　南无了声佛　南无断恶道佛　南无天弗沙佛　南无水眼佛　南无大灯佛　南无离闇佛　南无坚固眼佛　南无不可思议光明佛　南无普光明佛　南无普贤佛　南无胜月佛　南无意德佛　南无庄严声佛　南无妙意佛　南无贤光佛　南无坚固华佛　南无功德成佛　南无意成佛　南无解脱乘佛　南无降伏怨佛　南无过舌佛　南无过诸烦恼佛　南无无量光佛　南无无垢心佛　南无和合声佛　南无不可量眼佛　南无势力佛　南无妙光明佛　南无集功德佛　南无可闻声佛　南无大思惟佛　南无信天佛　南无思惟甘露佛　南无了意佛　南无胜灯佛　南无坚意佛　南无力势佛　南无华眼佛　南无菩提光明佛　南无最胜声佛　南无六通声佛　南无威德力佛　南无人称佛　南无胜华集佛　南无大髻佛　南无不随他佛　南无不畏行佛　南无离一切忧闇佛　南无月光明佛　南无心勇猛佛　南无解脱慧佛　南无离恶道佛　南无阎浮灯佛　南无胜供养佛　南无善思惟佛　南无胜威德色佛　南无信众生佛　南无快恭敬佛　南无波头摩清净佛　南无胜供养佛　南无种种色华佛　南无人波头摩佛　南无善香佛　南无胜功德佛　南无虚空劫佛　南无月贤佛　南无坚固佛　南无妙力佛　南无胜因陀罗智佛　南无胜亲佛　南无爱思惟佛　南无胜香佛　南无无诤行佛　南无功德舍佛　南无大精进思惟佛　南无大光明佛　南无摄受施佛　南无修行深思惟佛　南无香希佛　南无香象佛　南无种种智佛　南无思惟妙智佛　南无功德庄严佛　南无增上行佛　南无智行佛　南无功德山佛　南无声满十方佛　南无摄受择佛　南无信妙佛　南无月见佛　南无功德聚佛　南无法力佛　南无过一切疑佛　南无称王佛　南无护诸根佛　南无胜意佛　南无甘露光佛　南无思惟甘露佛　南无一切众生(丹上)首佛　南无爱髻佛　南无不可降伏色佛　南无普信佛　南无庄严王佛　南无金刚步佛　南无贤作佛　南无功德报光明佛　南无精进力起佛　南无善清净光明佛　南无得脱一切缚佛　南无无垢波头摩藏胜佛　南无得无碍解脱佛　南无十方称声无畏佛　南无破一切闇趣佛　南无光明王佛　南无大炎积佛　南无无边行功德宝光明佛　南无法光明佛　南无大炎积佛　南无欢喜王佛　南无能作一切众生光明破闇胜佛　南无起普光明修行无边愿称王佛　南无普愿满足不怯弱佛　南无一切见光明佛　南无无垢光庄严王佛　南无功德藏山破金刚佛　南无龙王自在王佛　南无宝精进日月摩尼庄严威德声王佛　南无吼声妙声佛　南无善住持地佛　南无世间自在王佛　南无无障碍药王树胜佛　南无弥留幢佛　南无大山佛　南无弥留光明佛　南无妙声佛　南无曰月住佛　南无称光明佛　南无无量光佛　南无不可量幢佛　南无大光明佛　南无宝鸡兜佛　南无净王佛　南无大炎聚佛　南无一切王声佛　南无难胜佛　南无日生佛　南无罗网光明佛　南无照光明佛　南无师子佛　南无称佛　南无称光明佛　南无法佛　南无法住持佛　南无法幢佛　南无梵声佛　南无星宿王佛　南无香胜佛　南无香光佛　南无大积佛　南无宝种种华敷身佛　南无莎罗自在王佛　南无宝莲华胜佛　南无见一切义佛　南无须弥劫佛　南无智灯佛　南无大光明照佛　南无难伏佛　南无照佛　南无勤鸡兜幢佛　南无威德自在王佛　南无觉王佛　南无宝藏佛　南无大海佛　南无十力增上自在佛　南无唯宝庄严佛　南无无边宝庄严佛　南无无相声佛　南无过境界步佛　南无须弥山聚佛　南无虚空眼佛　南无虚空寂佛　南无称力王佛　南无放光明佛　南无离诸染佛　南无种种华成就胜佛　南无远离诸畏惊怖毛竖佛　南无智称(丹积)佛　南无旃檀香佛　南无伏眼佛　南无宝来佛　南无香首佛　南无胜众佛　南无唯盖佛　南无无障眼佛　南无栴檀去佛　南无智华宝光明胜佛　南无贤胜光明佛　南无能一切畏佛　南无无畏佛　南无弥留藏佛　南无法作佛　南无十上光明佛　南无千上光明佛　南无智光明佛　南无宝胜光明佛　南无无边光明佛　南无无碍声佛　南无罗网光明佛　南无种种宝智佛　南无无边庄严佛　南无忧波罗胜佛　南无住智胜佛　南无胜能圣佛　南无智称佛　南无莎罗自在王佛　南无宝沙罗佛　南无大将佛　南无宝鬘佛　南无不空名称佛　南无胜成就功德佛　南无称王佛　南无不空步佛　南无香光明佛　南无无障碍声佛　南无称力王佛　南无须弥增长胜王佛　南无宝胜功德佛　南无波头摩胜佛　南无宝起佛　南无香光明佛　南无十方称发起佛　南无普护增上云声王佛　南无无边光明佛　南无无边智成佛　南无无边轮奋迅佛　南无众上首佛　南无花胜王佛　南无宝像佛　南无不空名称佛　南无发起无边精进功德佛　南无发心庄严一切众生佛　南无盖行佛　南无光明轮威德王佛　南无功德王光明佛　南无一切功德到彼岸佛　南无然灯作佛　南无能作光明佛　南无得功德佛　南无波头摩上胜佛　南无宝作佛　南无无边愿佛　南无无边功德王住佛　南无宝聚佛　南无娑罗自在王佛　南无宝光明佛　南无宝积佛　南无最上佛　南无修行无边功德佛　南无观声佛　南无须弥山光明佛　南无无边境界佛　南无妙去佛　南无宝华成就胜佛　南无无边奋迅佛　南无发起一切众生信佛　南无宝盖起佛　南无胜功德佛　南无不可花佛　南无宝境界光明佛　南无宝胜功德佛　南无发心即转法轮佛　南无十方称名佛　南无迦陵伽王佛　南无日轮然灯佛　南无宝上佛　南无智成就胜佛　南无功德王住佛　南无无障碍眼佛　南无无畏佛　南无智积佛　南无发起无譬喻相佛　南无积光明轮威德佛　南无因意佛　南无那罗延佛　南无无垢鸡兜佛　南无月积佛　南无清净意佛　南无安隐佛　南无发起善思惟佛　南无能破诸怨佛　南无忧波罗功德佛　南无积(丹称)力王佛　南无无边光明云香弥留佛　南无种种色华佛　南无无边光佛　南无能转能住佛　南无胜香佛　南无宝胜佛　南无香山佛　南无信一切众生心智见佛　南无无相声佛　南无智功德积佛　南无无障声佛　南无一盖藏佛　南无不动势佛　南无迦叶佛　南无观见一切境界佛　南无上首佛　南无成义佛　南无成胜佛　南无称佛　南无离一切疑佛　南无智德佛　南无功德乘佛　南无星宿王佛　南无不可量鸡兜佛　南无旃檀佛　南无罗网光佛　南无梵声佛　南无不可量实体胜佛　南无一切法无观佛　南无发一切众生不断绝修行佛　南无无边奋迅佛　南无见一切法佛　南无见一切法平等佛　南无成就无边功德佛　南无智高光明佛　南无波头摩上佛　南无十方上佛　南无华成功德佛　南无坚固众生佛　南无智光明佛　南无智众佛　南无离藏佛　南无明王佛　南无不分别修行佛　南无无边智称佛　南无旃檀屋胜佛　南无无比智花成佛　南无善住娑罗王佛　南无胜月光明佛　南无须弥聚佛　南无称名佛　南无过十方称佛　南无称名亲佛　南无称坚固佛　南无离忧恼佛　南无波头摩胜王功德佛　南无散华鸡兜佛　南无普放香光明佛　南无波那陀眼佛　南无放炎佛　南无十方称名佛　南无光明弥留佛　南无宝光明佛　南无然尸弃佛　南无三界境界势力佛　南无光明轮佛　南无虚空寂境界佛　南无尽境界佛　南无妙宝声佛　南无普境界佛　南无智称佛　南无光明轮境界胜王佛　南无善住佛　南无成就佛宝功德佛　南无起智功德佛　南无一切功德佛　南无佛境界清净佛　南无起智光明威德积聚佛　南无成就波头摩王佛　南无第一境界法佛　南无半月光明佛　南无香像佛　南无成就波头摩功德佛　南无旃檀功德佛　南无宝山佛　南无黠慧行佛　南无能作无畏佛　南无无边功德胜佛　南无光明鸡兜佛　南无作无边功德佛　南无成就一切胜功德佛　南无住持炬佛　南无胜敌对佛　南无胜王佛　南无星宿王佛　南无无边山佛　南无虚空轮清净王佛　南无无边声佛　南无无边光明佛　南无宝弥留佛　南无种种宝佛　南无拘修摩熬佛　南无上首佛　南无无垢离垢发修行光明佛　南无金色华佛　南无宝窟佛　南无种种华成就佛　南无放光明佛　南无成就华佛　南无华盖佛　南无不空发修行佛　南无胜力王佛　南无净声王佛　南无无边上首佛　南无无障眼佛　南无破诸趣佛　南无离疑佛　南无无相声佛　南无毕竟成就无边功德佛　南无宝成就胜佛　南无波头摩得胜功德佛　南无宝妙佛　南无三世无碍发修行佛　南无无边照佛　南无宝弥留佛　南无然灯胜王佛　南无成就智德佛　南无炬然灯佛　南无无上光明佛　南无功德王光明佛　南无弗沙佛　南无梵声佛　南无功德论佛　南无十方灯佛　南无佛华成就德佛　南无娑罗自在王佛　南无华须佛　南无宝积佛　南无见种种佛　南无药王佛　南无最上佛　南无贤胜佛　南无香妙佛　南无香胜鸡兜佛　南无旃檀屋佛　南无香鸡兜佛　南无无边精进佛　南无过十光佛　南无佛波头摩妙佛　南无无边境界佛　南无惊怖波头摩成就胜王佛　南无宝罗网佛　南无善住王佛　南无最胜香王佛　南无能与一切乐佛　南无能现一切念佛　南无不空名称佛　南无宝光明佛　南无安隐与一切众生乐佛　南无无边虚空庄严胜佛　南无善庄严佛　南无虚空鸡兜佛　南无普华成就胜佛　南无可乐胜佛　南无无边境界来佛　南无净眼佛　南无高山佛　南无不可降伏幢佛　南无可诣佛　南无无边无际诸山佛　南无月轮庄严王佛　南无最胜弥留佛　南无乐成就德佛　南无清净诸弥留佛　南无安乐德佛　南无梵德佛　南无无碍日(丹无碍自在)佛　南无作无边功德佛　南无威德王佛　南无梵胜佛　南无善思惟成就诸愿佛　南无清净轮王佛　南无智高佛　南无勇猛仙佛　南无智积佛　南无作方佛　南无能忍佛　南无离诸有佛　南无智护佛　南无妙功德佛　南无随众生心现境界佛　南无镜佛　南无无边宝佛　南无离一切受境界无畏佛　南无无碍宝光明佛　南无无碍照佛　南无念一切佛境界佛　南无能现一切佛像佛　南无无相体佛　南无化声佛　南无化声善声佛　南无宝成就胜功德佛　南无海弥留佛　南无无垢意佛　南无智华成就佛　南无高威德山佛　南无寂静佛　南无离恨佛　南无断一切诸道佛　南无成就不可量功德佛　南无乐成就胜境界佛　南无求无畏香佛　南无无障碍香光明佛　南无云妙鼓声佛　南无成就胜功德佛　南无无边势力步佛　南无须弥山坚佛　南无胜香须弥佛　南无无边光佛　南无普见佛　南无得无畏佛　南无月灯佛　南无火灯佛　南无势灯佛　南无高修佛　南无金刚生佛　南无智自在王佛　南无智力称佛　南无无畏上佛　南无功德王佛　南无波婆娑佛　南无善眼佛　南无妙庄严佛　南无宝盖佛　南无香象佛　南无无边境界不空称佛　南无不可思议功德王光明佛　南无种种华佛　南无无畏王佛　南无常厌香佛　南无妙药树王佛　南无常求安乐佛　南无无边意行佛　南无无边境界佛　南无无边光佛　南无无边目佛　南无无边虚空境界佛　南无声色境界佛　南无星宿王佛　南无香上胜佛　南无虚空胜佛　南无胜功德佛　南无现诸方佛　南无妙弥留佛　南无无障碍佛　南无娑伽罗佛　南无庭燎佛　南无然鸡兜佛　南无无垢月威德光佛　南无智山佛　南无称力王佛　南无功德王光明佛　南无智见佛　南无波头胜成就佛　南无宝火佛　南无宝莲华胜佛　南无断诸疑佛　南无领胜众佛　南无鸡兜王佛　南无华胜佛　南无放光明佛　南无照波头摩光明佛　南无方王法鸡兜佛　南无无边步佛　南无娑伽罗山佛　南无阿谟荷见佛　南无无障碍吼声佛　南无无边功德称光明佛　南无世间涅槃无差别修行佛　南无无边照佛　南无善眼佛　南无一盖藏佛　南无放光明佛　南无过去未来现在发修行佛　南无无边华佛　南无无边净佛　南无无边光佛　南无无边明佛　南无无边照佛　南无妙明佛　南无无边境界佛　南无无边步佛　南无等盖行佛　南无宝盖佛　南无星宿王佛　南无盖(丹善)星宿佛　南无光明轮佛　南无光明王佛　南无胜光明功德佛　南无不可量光佛　南无胜佛　南无不可量境界步佛　南无无碍声吼佛　南无大云光佛　南无闇梨尼山佛　南无佛华光明佛　南无波头摩胜花山王佛　南无星宿上首佛　南无放光明佛　南无三周单那坚佛　南无不空见佛　南无顶胜功德佛　南无波头顶胜功德佛　南无无痴佛　南无能度佛　南无无迷步佛　南无离愚境界佛　南无无闇光明佛　南无无边精进佛　南无娑罗自在王佛　南无宝娑罗佛　南无一盖佛　南无盖庄严佛　南无宝聚佛　南无栴檀聚香佛　南无旃檀屋佛　南无无边光明佛　南无光轮佛　南无山庄严佛　南无无障碍明(丹眼)佛　南无善眼佛　南无宝成佛　南无一切功德胜佛　南无成就佛华功德佛　南无善住意佛　南无无边方便佛　南无不空功德佛　南无宝势佛　南无无边修行佛　南无庄严无边功德佛　南无虚空轮光佛　南无无相声佛　南无药王佛　南无不怯弱佛　南无离诸畏毛竖佛　南无功德王光明佛　南无观智起花佛　南无虚空寂佛　南无虚空声佛　南无虚空庄严佛　南无大眼(丹明)佛　南无胜功德佛　南无成佛　南无佛波头摩德佛　南无成功德佛　南无师子胜佛　南无成就义佛　南无师子护佛　南无善住王佛　南无梵山佛　南无净目佛　南无不空迹步佛　南无香象佛　南无香德佛　南无香弥留佛　南无无边眼佛　南无财屋佛　南无香山佛　南无宝师子佛　南无坚固众生佛　南无妙胜住王佛　南无无边境界胜王佛　南无胜精进王佛　南无无疑佛　南无善星宿王佛　南无然灯佛　南无能作光明佛　南无光明山佛　南无光明轮佛　南无妙盖佛　南无香盖佛　南无宝盖佛　南无香去(乡云)盖佛　南无旃檀胜佛　南无须弥山积聚佛　南无种种宝光明佛　南无坚固自在王佛　南无净胜佛　南无净眼佛　南无不弱佛　南无宝胜佛　南无施罗王佛　南无发修行转女根佛　南无发无边修行佛　南无最妙光佛　南无阇梨尼光明山佛　南无因王佛　南无梵胜佛　南无称身佛　南无华山佛　南无转胎佛　南无转难佛　南无断诸念佛　南无发起诸念佛　南无常修行佛　南无善住佛　南无一藏佛　南无一山佛　南无无边身佛　南无无边精进佛　南无光明轮佛　南无无边功德王光佛　南无降伏一切诸怨佛　南无过一切魔境界佛　南无不可量华佛　南无不可量香佛　南无不可量声佛　南无光明顶佛　南无光明胜佛　南无不离二佛　南无轮佛　南无不可量佛华光明佛　南无不可量声佛　南无光明山佛　南无娑罗自在王佛　南无日面佛　南无善目佛　南无虚空佛　南无宝华佛　南无宝成佛　南无月华佛　南无发诸行佛　南无断诸世间佛　南无无边乐说佛　南无离诸竞畏佛　南无乐说一切境界佛　南无普香光明佛　南无香光佛　南无香弥留佛　南无香胜佛　南无香象佛　南无香林佛　南无香王佛　南无波头摩胜王佛　南无佛境界佛　南无最妙佛　南无妙胜佛　南无散华佛　南无花盖鬘佛　南无华屋佛　南无金色花佛　南无香华佛　南无弥留王佛　南无导师佛　南无胜诸众生佛　南无断阿叉那佛　南无发善行佛　南无善华佛　南无无边香佛　南无普散香光明佛　南无普散香佛　南无普散光佛　南无普散波头摩胜佛　南无宝阇梨尼手佛　南无起王佛　南无普佛国土一盖佛　南无善住王佛　南无妙香佛　南无无边智境界佛　南无不空发佛　南无不空见佛　南无无障目佛　南无不动佛　南无发生菩提心佛　南无无量眼佛　南无有灯佛　南无普照佛　南无光明佛　南无一切佛国土佛　南无不断慈一切众生乐说佛　南无无垢步佛　南无无迹步佛　南无离一切忧佛　南无能离一切众生有佛　南无乐修行胜佛　南无无畏王佛　南无胜山(丹住)佛　南无香面佛　南无俱邻佛　南无大力胜佛　南无宝忧波罗胜佛　南无拘牟头成佛　南无高声眼佛　南无上首佛　南无华成佛　南无无边光明佛　南无月出光佛　南无十方称佛　南无多罗歌王增上佛　南无无边光明佛　南无最胜香山佛　南无无畏佛　南无成就无畏德佛　南无成就无边愿功德佛　南无一切功德庄严佛　南无花王佛　南无不可降伏幢佛　南无增上护光佛　南无惊怖波头摩胜王佛　南无不异心成就胜佛　南无一切上佛　南无虚空轮清净王佛　南无无相声吼佛　南无宝起功德佛　南无梵胜佛　南无无障碍香手佛　南无弥留山光明佛　南无波头摩胜光佛　南无能作称名佛　南无称亲佛　南无坚固自在王佛　南无过去如是等无量无边佛　南无现在积聚无畏佛　南无宝功德光明佛　南无普护佛　南无宝光照佛　南无月庄严宝光明智威德声王佛　南无拘苏摩树提不谬王通佛　南无清净月轮佛　南无寂静月声佛　南无阿僧祇住功德精进胜佛　南无善名称胜佛　南无因陀罗鸡兜幢星宿王佛　南无普光明庄严胜佛　南无降伏敌对步佛　南无普功德光明庄严胜佛　南无无碍药王树胜佛　南无波头摩步佛　南无宝波头摩善住娑罗王佛　南无师子佛　南无白(丹乡日)光佛　南无火光佛　南无无边光佛　南无波头摩王佛　南无阿偶多罗佛　南无波头摩胜佛　南无善华佛　南无宝心佛　南无无碍光佛　南无山幢佛　南无宝幢佛　南无宝炎佛　南无大炎聚佛　南无旃檀香佛　南无善利光佛　南无波头摩敷身佛　南无依止无边功德佛　南无宝体法决定声王佛　南无阿僧祇精进聚集胜佛　南无智通佛　南无弥留山积佛　南无然灯佛　南无大威德力佛　南无日月佛　南无旃檀(丹有德)佛　南无须弥劫佛　南无月色佛　南无不染佛　南无降伏龙佛　南无龙天佛　南无金色镜像佛　南无山声自在王佛　南无山积佛　南无须弥藏佛　南无供养光佛　南无胜觉佛　南无地山佛　南无(丹有妙)琉璃花佛　南无妙琉璃金形像佛　南无降伏月佛　南无日声佛　南无散华庄严佛　南无海山智奋迅通佛　南无水光佛　南无大香镜像佛　南无不动山佛　南无宝集佛　南无胜山佛　南无勇猛山佛　南无多功德法住持得通佛　南无日月琉璃光佛　南无胜琉璃光佛　南无心间智多拘苏摩胜佛　南无月光佛　南无日光佛　南无散华王拘苏摩通佛　南无栴檀月光佛　南无破无明闇佛　南无普盖波婆罗佛　南无星宿佛　南无弗沙佛　南无法慧增长佛　南无师子鹅王山吼佛　南无梵声龙奋迅佛　南无世间因陀罗佛　南无世间自在王佛　南无可得报佛　南无甘露声佛　南无树提光佛　南无那罗延首龙佛　南无力天佛　南无师子佛　南无毗罗阇光佛　南无世间最上佛　南无山狱佛　南无人自在王佛　南无华胜佛　南无得四无畏佛　南无宝胜威德王劫佛　南无不可嫌身佛　南无称护佛　南无称威德佛　南无称名声佛　南无称声供养佛　南无勇猛称佛　南无声分清净佛　南无智胜善黠慧佛　南无智胜成就佛　南无智炎佛　南无智勇猛佛　南无智炎聚佛　南无妙智佛　南无梵声佛　南无梵胜佛　南无净天佛　南无善臂佛　南无善净天佛　南无梵声佛　南无净自在佛　南无净善眼佛　南无净声自在王佛　南无善净德佛　南无威德力增上佛　南无善势自在佛　南无威德大势力佛　南无胜威德佛　南无毗摩胜佛　南无毗摩意佛　南无善毗摩佛　南无毗摩面佛　南无毗摩成就佛　南无毗摩妙佛　南无见宝佛　南无须尼多佛　南无善眼清净佛　南无无边眼佛　南无普眼佛　南无无等眼佛　南无胜眼佛　南无不可降伏眼佛　南无不动眼佛　南无寂胜佛　南无善寂佛　南无善寂诸根佛　南无寂胜佛　南无寂功德佛　南无寂彼岸佛　南无善住佛　南无寂心佛　南无寂意佛　南无寂静然佛　南无自在王佛　南无众胜佛　南无净王佛　南无大众自在勇猛佛　南无众胜解脱佛　南无法幢佛　南无法鸡兜佛　南无法起佛　南无法体胜佛　南无法力自在胜佛　南无法勇猛佛　南无乐说山佛　南无宝火佛　南无乐说庄严云吼佛　南无胜声佛　南无妙眼佛　南无清净面月胜藏威德佛　南无成就意佛　南无满足心佛　南无净迦罗迦决定威德佛　南无无边精进佛　南无甘露光佛　南无无比慧佛　南无无卑微佛

佛说佛名经卷第十一佛说佛名经卷第十二

        元魏天竺三藏菩提流支译

南无大威德佛　南无月光佛　南无旃檀香佛　南无须弥劫佛　南无山积佛　南无无垢色佛　南无无染佛　南无龙胜佛　南无金色佛　南无山吼自在王佛　南无金藏佛　南无火光佛　南无火自在佛　南无琉璃华佛　南无月胜佛　南无月声佛　南无散华庄严光佛　南无大香去照明佛　南无离一切染意佛　南无聚集宝佛　南无德山佛　南无勇猛山佛　南无梵声龙奋迅佛　南无世间胜上佛　南无师子奋迅吼佛　南无华胜佛　南无山胜佛　南无成就娑罗自在王佛　南无吼声佛　南无普光明佛　南无等盖佛　南无无忧佛　南无智王佛　南无智山佛　南无月光佛　南无普光佛　南无声德佛　南无无勿成就佛　南无火幢佛　南无智自在佛　南无大自在佛　南无梵声佛　南无众自在佛　南无月面佛　南无日面佛　南无声胜佛　南无梵面佛　南无梵天佛　南无因陀罗鸡兜幢佛　南无善思惟月胜成就王佛　南无智光明佛　南无无垢称王佛　南无乐说庄严云德佛　南无妙声佛　南无清净面无垢月胜王佛　南无平等意佛　南无乐说声佛　南无无垢月佛　南无无垢清净金色决定光明威德王佛　南无宝光明轮王佛　南无智通佛　南无不可数发精进决定佛　南无山积佛　南无因陀罗鸡兜幢王佛　南无善住娑罗王佛　南无波头摩胜佛　南无善住坚固王佛　南无日月光佛　南无波头摩光佛　南无波头摩胜步佛　南无大通佛　南无大通智胜佛　南无无边智佛　南无多宝佛　南无吼声降伏一切佛　南无日月无垢光明佛　南无莲华无垢星宿王花佛　南无云妙鼓声王佛　南无住持水声善星宿王华严通佛　南无无垢身佛　南无那伽钩罗胜佛　南无智照佛　南无现一切功德光明奋迅王佛　南无照光明庄严奋迅王佛　南无月明佛　南无光明普照佛　南无宝庄严佛　南无普(丹乡散)华佛　南无普然灯佛　南无普华佛　南无普光明胜山王佛　南无善住功德摩尼山王佛　南无光明王佛　南无不可降伏幢佛　南无胜功德佛　南无世间自在佛　南无普华佛　南无舌根佛　南无虚空轮清净王佛　南无胜光明波头摩敷身佛　南无须弥山波头摩胜王佛　南无一切宝摩尼王佛　南无宝光明日月轮智佛　南无威德频头声王佛　南无大导师佛　南无(丹乡有普)光明奋迅王光明佛　南无善行佛　南无乐说山佛　南无住佛　南无师子鸟(丹乡象)奋迅佛　南无功德王光明佛　南无功德幢佛　南无功德作佛　南无圣天佛　南无宝幢佛　南无金刚合佛　南无一切胜佛　南无安隐色佛　南无妙行佛　南无波婆罗娑伽罗佛　南无弗波鸡兜佛　南无妙色佛　南无修卢遮那佛　南无梨师掘多佛　南无破烦恼佛　南无妙佛　南无敷华佛　南无弗加罗佛　南无善光佛　南无吉佛　南无师子威德佛　南无住智德佛　南无婆那多香佛　南无实法广称佛　南无谛沙佛　南无世间喜佛　南无广光明佛　南无宝称佛　南无宝威德佛　南无梵威德佛　南无善声佛　南无善华佛　南无真声佛　南无善行色佛　南无微笑眼佛　南无功德山佛　南无云声佛　南无妙色佛　南无命威德佛　南无胜步行佛　南无世间求佛　南无降伏怨佛　南无供养佛　南无喜庄严佛　南无舍尸鸡兜佛　南无弗若功德光佛　南无大威德佛　南无等宝盖佛　南无那罗延佛　南无成就行佛　南无离忧佛　南无无垢喜佛　南无无垢光明佛　南无厚坚固佛　南无无垢云王佛　南无无垢臂佛　南无义成就佛　南无胜护佛　南无梵功德天王佛　南无虚空步佛　南无妙智佛　南无法宝佛　南无不空见佛　南无难降伏光佛　南无月光佛　南无月(丹有净)佛　南无普光明佛　南无宝胜佛　南无普观佛　南无不可数见佛　南无通(丹有障)佛　南无清净光明宝佛　南无善洗清净无垢成就无边功德胜王佛　南无宝胜无垢王劫佛　南无第一然灯佛　南无功德宝胜佛　南无无垢光明佛　南无乐说庄严佛　南无无垢月鸡兜称佛　南无钩苏摩庄严佛　南无火步佛　南无宝上佛　南无无畏观佛　南无师子奋迅佛　南无离怖畏佛　南无善见佛　南无不怯弱离惊怖佛　南无金刚威德佛　南无梵胜天王佛　南无善月佛　南无光明王佛　南无鸡兜称佛　南无阎浮光明佛　南无多摩罗跋旃檀香佛　南无不动佛　南无弥留山佛　南无师子声佛　南无师子幢佛　南无住虚空佛　南无常入涅槃佛　南无因陀罗幢佛　南无甘露(丹有幢)佛　南无降伏一切世间怨佛　南无得度佛　南无弥留劫佛　南无多摩罗跋旃檀香佛　南无云自在王佛　南无能破一切世惊怖畏佛　南无普光明佛　南无法光明佛　南无海住持奋迅通佛　南无法虚空胜王佛　南无七宝波头摩步佛　南无宝鸡兜佛　南无宝一盖佛　南无一切众生爱见佛　南无满足百千光明幢佛　南无娑罗自在王佛　南无法(丹有花)庄严王佛　南无普一宝盖佛　南无星宿佛　南无普光明奋迅王佛　南无法庄严王佛　南无山灯佛　南无坚精进佛　南无法照光佛　南无住清净光(丹眼)佛　南无善住净境界佛　南无月山佛　南无毕竟庄严无边功德王佛　南无离诸烦恼佛　南无不空见佛　南无成就无垢无边清净功德胜王佛　南无智上光明佛　南无宝胜智威德庄严自在王佛　南无清净光佛　南无敷花娑罗自在王佛　南无火(乡大)华敷王佛　南无月轮清净佛　南无寂静月声王佛　南无无边坚精进住胜佛　南无波头摩胜佛　南无法鸡兜佛　南无然灯佛　南无功德鸡兜佛　南无功德成佛　南无圣天佛　南无宝山佛　南无金刚合佛　南无一切胜佛　南无普香佛　南无善华佛　南无善胜佛　南无功德山佛　南无胜成就佛　南无拘邻佛　南无善眼佛　南无头陀罗吒佛　南无善生佛　南无梵胜佛　南无寂静佛　南无梵德佛　南无因陀罗幢佛　南无月色佛　南无无垢色佛　南无无染佛　南无胜龙佛　南无龙天佛　南无金光明佛　南无胜声因陀罗王佛　南无善须弥山佛　南无善色藏佛　南无火光佛　南无威德因陀罗佛　南无地迦佛　南无琉璃华佛　南无胜琉璃金光明佛　南无月胜佛　南无日吼佛　南无散华庄严光明佛　南无娑伽罗胜智奋迅通佛　南无水光明佛　南无大香行光明佛　南无离一切嗔恨意佛　南无宝胜佛　南无胜积佛　南无胜仙佛　南无住持多功德通法佛　南无日月琉璃光佛　南无心菩提华胜佛　南无日月佛　南无日(丹有月)光佛　南无华鬘色王佛　南无钩修弥多通佛　南无水月光明佛　南无破无明闇佛　南无普盖宝佛　南无增长法乐佛　南无种种师子声增长吼佛　南无梵自在龙吼佛　南无世间自在佛　南无世间自在王佛　南无难胜佛　南无宝作佛　南无甘露声佛　南无胜光佛　南无龙天佛　南无增上力佛　南无无垢光佛　南无师子佛　南无世间增上佛　南无德山佛　南无人王佛　南无花胜佛　南无德无畏佛　南无能平等作佛　南无初发心离诸畏一切烦恼胜德佛　南无普光明奋迅佛　南无金刚步佛　南无宝光明步象佛　南无离诸魔疑佛　南无初发心成就不退转胜佛　南无宝盖胜光明佛　南无能教化诸菩萨佛　南无初发心念断一切烦恼染佛　南无降伏烦恼佛　南无胜光明王佛　南无三昧手胜佛　南无波头摩上胜佛　南无日轮光明佛　南无均宝盖佛　南无日轮光明胜佛　南无增上三昧奋迅佛　南无宝花普照胜佛　南无最妙波头摩步佛　南无宝轮光明胜德佛　南无宝藏佛　南无宝胜佛　南无宝灯王佛　南无坚精进思惟成就义佛　南无普光明观称佛　南无慈庄严功德称佛　南无称一切众生念胜功德佛　南无吉称功德佛　南无毕竟惭愧称胜佛　南无广光明佛　南无乐说庄严思惟佛　南无无垢月鸡兜称佛　南无钩修摩庄严光明作佛　南无宝称佛　南无无畏观佛　南无师子力奋迅佛　南无伽那歌王光明佛　南无贤作佛　南无无垢光明佛　南无功德宝光明佛　南无精进力成就佛　南无善清净光佛　南无得脱一切缚佛　南无无垢波头摩藏胜佛　南无得无障碍力解胜(丹本脱)佛　南无十方称名无畏佛　南无金刚势佛　南无大宝聚佛　南无无边功德庄严威德王劫佛　南无功德宝山佛　南无说一切庄严胜佛　南无无边乐说庄严成就智佛　南无无千云吼声王佛(千上丹无一无)　南无妙金色光明威德胜照佛　南无种种威德王劫佛　南无阿僧祇亿劫成就智佛　南无清净金虚空吼光明佛　南无普光明佛　南无法庄严王佛　南无功德多宝海王佛　南无不空功德佛　南无照一切处佛　南无妙鼓声佛　南无法自在佛　南无普见佛　南无大炎聚佛　南无光明幢佛　南无智鸡兜佛　南无娑罗胎佛　南无宝尸弃佛　南无波头摩藏佛　南无一切胜佛　南无娑伽罗佛　南无波头摩藏佛　南无娑罗自在王佛　南无花佛　南无胜称佛　南无见实佛　南无智弥留佛　南无龙德佛　南无胜行佛　南无星宿佛　南无大庄严佛　南无光明王佛　南无能人佛　南无自在山(丹王)佛　南无日面佛　南无善意佛　南无龙胜佛　南无弗沙佛　南无药王佛　南无师子山佛　南无住持胜功德佛　南无饮甘露佛　南无放炎佛　南无(丹有妙)山佛　南无护世间供养佛　南无多伽罗尸弃佛　南无难胜佛　南无大灯佛　南无波头摩上佛　南无法幢佛　南无能然灯佛　南无难胜(丹有智)佛　南无难可意佛　南无真声佛　南无妙声佛　南无娑罗步佛　南无宝炎佛　南无爱见佛　南无须弥劫佛　南无旃陀光佛　南无日光佛　南无药树胜佛　南无(丹有净)觉佛　南无记(丹有别)佛　南无爱作佛　南无作无畏佛　南无波头摩宝香佛　南无胜德佛　南无无垢佛　南无(丹有净)照佛　南无无烦恼佛　南无善来佛　南无善光佛　南无金色佛　南无能作光明佛　南无清净佛　南无得脱佛　南无迦陵频伽声佛　南无能与法佛　南无善护诸门佛　南无得意佛　南无离爱佛　南无未生宝佛　南无善护诸根佛　南无梵声佛　南无胜声佛　南无妙声佛　南无大慧佛　南无无诸浊佛　南无不可动佛　南无乐解脱佛　南无胜二足佛　南无具足一切功德庄严佛　南无相庄严佛　南无拘牟陀语佛　南无不可降伏语佛　南无常相应语佛　南无梵声安隐众生佛　南无娑罗花佛　南无金枝花佛　南无拘牟陀相佛　南无妙顶佛　南无大牟尼佛　南无一切法到彼岸佛　南无无染佛　南无不散心佛　南无荷吒伽色佛　南无善寂成就佛　南无赊头罗步佛　南无清净手佛　南无常来佛　南无毕竟成就大悲佛　南无成就坚佛　南无常行成(丹本有就)佛　南无离诤浊佛　南无清净功德相佛　南无不泣牟尼罗佛　南无胜藏佛　南无般若齐佛　南无般若宝毕竟佛　南无满足意佛　南无世间自在王佛　南无无量命佛　南无大炎积佛　南无无边宝佛　南无净胜天佛　南无内外净佛　南无寂诸根佛　南无最灯佛　南无成就不思惟愿娑罗王佛　南无师子意佛　南无降伏力佛　南无住持速行佛　南无放光明王佛　南无毗头奚吼佛　南无无念觉法王佛　南无国土庄严身佛　南无智根本华幢佛　南无化称佛　南无一切色摩尼藏佛　南无法藏自在佛　南无法献波婆罗佛　南无无边宝功德藏佛　南无净花声佛　南无(丹本有大)法王钩修摩胜佛　南无一切无尽藏佛　南无功德山藏佛　南无星宿山藏佛　南无虚空智山佛　南无智力天王佛　南无无障碍海随顺智佛　南无无边觉海藏佛　南无智王无尽称佛　南无心意奋迅王佛　南无自性清净智佛　南无智自在法王佛　南无差别去佛　南无自在见佛　南无随顺香见法满佛　南无龙月佛　南无因陀罗波罗无障碍王佛　南无智鸡兜佛　南无智灯佛　南无大光明照佛　南无不可胜佛　南无照(丹有境)佛　南无银鸡兜幢盖佛　南无威德自在王佛　南无觉王佛　南无宝藏佛　南无大娑伽罗佛　南无十力差(丹有别)佛　南无降伏魔佛　南无降伏贪佛　南无降伏嗔佛　南无降伏痴佛　南无降伏憍慢佛　南无降伏嗔恨垢佛　南无法清净佛　南无业胜得名佛　南无如意得名清净佛　南无得施起名佛　南无得名清净戒名佛　(得下丹无名)南无起忍辱成就佛　南无得起精进名佛　南无得起禅名佛　南无得起般若名佛　南无成就施不可思议名佛　南无成就戒不可思议佛　南无成就忍辱不可思议佛　南无成就精进不可思议佛　南无成就禅那不可思议佛　南无成就般若不可思议佛　南无行成就得名佛　南无成就陀罗尼清净得名佛　南无陀罗尼色清净得名佛　南无陀罗尼施清净得名佛　南无空无我自在得名佛　南无眼陀罗尼自在佛　南无耳陀罗尼自在佛　南无鼻陀罗尼自在佛　南无舌陀罗尼自在佛　南无身陀罗尼自在佛　南无意陀罗尼自在佛　南无色陀罗尼自在佛　南无声陀罗尼自在佛　南无香陀罗尼自在佛　南无味陀罗尼自在佛　南无触陀罗尼自在佛　南无法陀罗尼自在佛　南无地陀罗尼自在佛　南无水陀罗尼自在佛　南无火陀罗尼自在佛　南无风陀罗尼自在佛　南无苦自在佛　南无集自在佛　南无灭自在佛　南无道自在佛　南无阴自在佛　南无界自在佛　南无入自在佛　南无三世自在佛　南无陀罗尼花自在佛　南无吉光明佛　南无香灯衣自在光明佛　南无法幢佛　南无师子声佛　南无照藏佛　南无法明敷身佛　南无一切通光佛　南无月智佛　南无妙胜佛　南无贤胜佛　南无普满佛　南无普贤佛　南无那罗延王佛　南无成就一切义佛　南无住持威德佛　南无无畏观佛　南无如是等现在过去未来无量无边佛　南无十千同名满足佛　南无三万同名能圣佛　南无二千同名拘邻佛　南无十八亿同名宝体法式佛　南无十八亿同名日月灯佛　南无千五百同名大威德佛　南无一万五千同名欢喜佛　南无八万四千(丹本有九百)同名龙王佛　南无一万五千同名日佛　南无一万八千同名娑罗王佛　南无一万八千同名因陀罗幢佛　南无八千同名善光佛　南无八百同名寂灭佛　南无三十六亿十一万九千五百同名净王佛

此诸佛名。百千万劫不可得闻。如优昙钵花。若人受持读诵此诸佛名。毕竟远离诸烦恼。舍利弗。应当敬礼

波头摩胜如来佛　南无寂王佛　南无灯作佛　南无天光佛　南无德山佛　南无胜上佛　南无娑罗王佛　南无净王佛　南无大慧梁佛　南无须弥佛　南无大智慧须弥佛　南无宝作佛　南无宝藏佛　南无破金刚佛　南无贤智不动佛　南无香普佛　南无甘露命佛　南无难胜佛　南无月光佛　南无日照佛　南无智鸡兜佛　南无大师子佛　南无弥留山佛　南无香光佛　南无德山佛　南无大通佛　南无阿摩罗藏佛　南无宝围佛　南无金刚藏佛　南无忧波罗藏佛　南无大日佛　南无桥梁载佛　南无月胜佛　南无乐坚固佛　南无不可思议法身佛　南无胜藏佛　南无不空王佛　南无金刚无碍智佛　南无宝炎佛　南无赊放(丹施)灯佛　南无降伏一切怨佛　南无自在佛　南无大智真声佛　南无般若香象佛　南无天王佛

舍利弗。若善男子善女人。闻此诸佛名受持读诵不生疑者。是人八千亿劫不入地狱。不入畜生。不入鬼道。不生边地。不生贫穷家。不生下贱家。常生天人豪贵之处。常得欢喜适乐无碍。常得一切世间尊重供养。乃至得大涅槃。舍利弗。汝等应当敬礼

不可嫌身佛　南无称声佛　南无称威德佛　南无称名佛　南无叶陀佛　南无声炎佛　南无声分勇猛佛　南无智胜佛　南无智善知佛　南无智聚佛　南无智勇猛佛　南无梵胜佛　南无净婆薮佛　南无净(丹有心)佛　南无净天佛　南无净声佛　南无梵自在佛　南无威德佛　南无毗摩胜佛　南无毗摩意佛　南无毗摩面佛　南无毗摩上佛　南无无边声佛　南无实见佛　南无善眼月佛　南无深声佛　南无放声佛　南无惊怖魔力声佛　南无净眼佛　南无无边眼佛　南无普眼佛　南无胜眼佛　南无不可行佛　南无寂胜佛　南无善寂心佛　南无善寂根佛　南无善寂意佛　南无善寂德佛　南无善住佛　南无众自在王佛　南无大众自在佛　南无众解脱佛　南无法幢佛　南无法山佛　南无法胜佛　南无法体佛　南无法力佛　南无法勇猛佛　南无法体决定佛　南无第二劫八千亿同名法体决定佛

舍利弗。若善男子善女人受持是佛名。毕竟不入地狱速得三昧

舍利弗。过是佛名无量无边阿僧祇劫。有佛名人自在声。汝当归命。彼人自在声佛寿命七十千万劫住世。初会三亿声闻众集。八十那由他千万菩萨众集。皆得诸神通具四无碍。通达一切空到彼岸。我若无量劫住世。说彼佛大会国土庄严。如大海水中一渧之分。舍利弗。应当敬礼十方诸大菩萨摩诃萨

南无文殊师利菩萨摩诃萨　南无观世音菩萨　南无大势至菩萨　南无普贤菩萨　南无龙胜菩萨　南无龙德菩萨　南无胜成就菩萨　南无胜藏菩萨　南无波头摩胜菩萨　南无成就有菩萨　南无地持菩萨　南无宝掌菩萨　南无宝印手菩萨　南无师子意菩萨　南无师子奋迅吼声菩萨　南无虚空藏菩萨　南无发心即转法轮菩萨　南无一切声差别乐说菩萨　南无山乐说菩萨　南无大海意菩萨　南无大山菩萨　南无爱见菩萨　南无欢喜王菩萨　南无无边观菩萨　南无无边观行菩萨　南无破邪见魔菩萨　南无无忧德菩萨　南无成就一切义菩萨　南无师子菩萨　南无善住意菩萨　南无无比心菩萨　南无那罗德菩萨　南无因陀罗德菩萨　南无海天菩萨　南无拔陀波罗菩萨　南无药王菩萨　南无卢舍那菩萨　南无月光菩萨　南无波头摩胜(丹本有藏)菩萨　南无智山菩萨　南无圣藏菩萨　南无不舍行菩萨　南无不空见菩萨　南无妙声菩萨　南无妙声吼菩萨　南无常微笑寂根菩萨　南无波头摩道胜菩萨　南无广思菩萨　南无忧波罗眼菩萨　南无可供养菩萨　南无常忆菩萨　南无住一切悲见菩萨　南无断一切恶法菩萨　南无住一切声菩萨　南无住一切有菩萨　南无住佛声菩萨　南无无垢菩萨　南无勇猛德菩萨　南无(丹本有大)净菩萨　南无宝胜菩萨　南无罗网光菩萨　南无断诸盖菩萨　南无能舍一切事菩萨　南无华庄严菩萨　南无月光光(丹无一光字)明菩萨　南无最胜意菩萨　南无坚意菩萨　南无自在天菩萨　南无胜意菩萨　南无净意菩萨　南无金刚意菩萨　南无增长意菩萨　南无善住菩萨　南无善导师菩萨　南无波头摩藏菩萨　南无陀罗尼自在王菩萨　南无普行菩萨　南无觉菩提菩萨　南无坚胜菩萨　南无断诸恶道菩萨　南无不疲惓意菩萨　南无须弥山菩萨　南无大须弥山菩萨　南无心勇猛菩萨　南无师子奋迅行菩萨　南无不可思议菩萨　南无善胜菩萨　南无善意菩萨　南无实语菩萨　南无爱见菩萨　南无无障碍菩萨　南无断诸疑菩萨　南无宝作菩萨　南无广德菩萨　南无护贤劫菩萨　南无宝月菩萨　南无曼陀婆香菩萨　南无乐作菩萨　南无无垢称菩萨　南无思益菩萨　南无普华菩萨　南无月胜菩萨　南无月山菩萨　南无智山菩萨　南无胜山菩萨　南无光山菩萨　南无贤首菩萨　南无功德山菩萨　南无胜护菩萨　南无那罗延菩萨　南无龙德菩萨　南无龙胜菩萨　南无住持色菩萨　南无摩留天菩萨　南无入功德菩萨　南无然灯首菩萨　南无常举手菩萨　南无光明常照手菩萨　南无宝手菩萨　南无普光菩萨　南无星宿王菩萨　南无金刚步菩萨　南无不动花步菩萨　南无步三界菩萨　南无无边步奋迅菩萨　南无海慧菩萨　南无善光无垢住持威德菩萨　南无高精进菩萨　南无智山菩萨　南无常观菩萨　南无不瞬菩萨　南无无言菩萨　南无宝胜菩萨　南无宝心菩萨　南无善思议菩萨　南无摩尼髻菩萨　南无庄严王菩萨　南无国土庄严菩萨　南无因陀罗网菩萨　南无天山菩萨　南无善眼菩萨　南无住持世间手菩萨　南无大将菩萨　南无寂意菩萨　南无速行菩萨　南无善臂菩萨　南无山峰菩萨　南无昙无竭菩萨　南无胜愿菩萨　南无庄严相星宿山王菩萨　南无乐说无滞菩萨　南无无垢智菩萨　南无娑伽罗菩萨　南无断一切忧菩萨　南无地藏菩萨　南无普现菩萨　南无发(丹法)行成就菩萨　南无深行菩萨　南无清净三轮菩萨　南无寂静心菩萨　南无无边功德菩萨　南无虚空平等智菩萨　南无波头摩眼菩萨　南无金刚幢菩萨　南无波头摩花严菩萨　南无宝庄严菩萨　南无宝路菩萨　南无功德王慧菩萨　南无庄严王菩萨　南无断诸严王菩萨　南无清净光明庄严菩萨　南无深声菩萨　南无妙鼓声菩萨　南无尼民陀罗菩萨　南无大自在菩萨　南无诸功德身菩萨　南无光明意菩萨　南无善见菩萨　南无不取诸法菩萨　南无转女根菩萨　南无思惟大悲菩萨　南无宝盖山菩萨　南无云山吼声菩萨　南无罗网庄严菩萨　南无宝藏菩萨　南无法鸡兜菩萨　南无日鸡兜菩萨　南无无边鸡兜菩萨　南无无垢藏菩萨　南无山菩萨　南无山峰住持菩萨　南无须弥山灯王菩萨　南无须弥幢菩萨　南无须弥山声菩萨　南无弥留王菩萨　南无宝杖菩萨　南无宝尸弃菩萨　南无宝来菩萨　南无宝天菩萨　南无法乐庄严菩萨　南无庄严王菩萨　南无山相庄严菩萨　南无金庄严光明菩萨　南无清净声光菩萨　南无宝髻菩萨　南无天吉菩萨　南无百光菩萨　南无火光菩萨　南无星宿味菩萨　南无常悲泣菩萨(梵名萨陀波仑)　南无光明胜菩萨　南无一切法自在菩萨　南无宝轮菩萨　南无宝炬菩萨　南无不空奋迅菩萨　南无云光明菩萨　南无法王菩萨　南无合山菩萨　南无降伏魔菩萨　南无普见菩萨　南无智山幢菩萨　南无难可菩萨　南无因陀罗幢菩萨　南无金髻菩萨　南无善见菩萨　南无善意菩萨　南无解脱王菩萨　南无大威德菩萨　南无波头摩眼菩萨　南无普眼菩萨　南无决定法菩萨　南无离垢菩萨　南无大光菩萨　南无大力菩萨　南无大月菩萨　南无善月菩萨　南无净心菩萨　南无住持华菩萨　南无不着行菩萨　南无离诸恶菩萨　南无得大菩萨　南无智炬灯菩萨　南无无边行菩萨　南无无边见菩萨　南无无障碍智菩萨　南无无垢眼山王菩萨　南无住持寂静菩萨　南无离闇菩萨　南无无边幢菩萨　南无火光菩萨　南无三界尊菩萨　南无世间炬菩萨　南无无障眼菩萨　南无不可嫌称菩萨　南无无边见菩萨　南无无碍见菩萨　南无甘露声菩萨　南无寂行菩萨　南无法云吼菩萨　南无得脱一切缚菩萨　南无法云王满足菩萨　南无甘露黠王菩萨　南无尼拘律王菩萨　南无无畏菩萨　南无净胜菩萨　南无胜眼菩萨　南无药王菩萨　南无无障碍受记菩萨　南无甘露光菩萨　南无无边光菩萨　南无断诸魔菩萨　南无过一切道菩萨

佛告舍利弗。若有善男子善女人。比丘比丘尼。优婆塞优婆夷。能受持读诵此诸佛菩萨名者。终不堕恶道生天人中。常值佛菩萨善知识。远离诸烦恼乃至得大菩提。佛说此佛名经已。慧命舍利弗及摩诃男比丘。及诸比丘比丘尼。优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。及诸菩萨摩诃萨。皆大欢喜顶受奉行

佛说佛名经卷第十二


佛说佛名经b

    No. 441

佛说佛名经卷第一

如是我闻。一时佛在舍婆提城祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊四众围绕及天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。尔时世尊告诸大众汝当谛听。我为汝说过去未来现在诸佛名字。若善男子善女人受持读诵诸佛名者。是人现世安隐远离诸难及消灭诸罪。未来当得阿耨多罗三藐三菩提。若善男子善女人欲消灭诸罪。当净洗浴着新净衣。长跪合掌而作是言

南无东方阿閦佛　南无八十六初元成王佛　南无火光佛　南无灵目佛　南无无畏佛　南无不可思议佛　南无灯王佛　南无放光佛　南无光明庄严佛　南无大胜佛　南无成就大事佛　南无实见佛　南无坚王华佛　南无大慈救苦佛

归命东方如是等无量无边诸佛

南无南方普满佛　南无威王佛　南无住持疾行佛　南无黠慧佛　南无称声佛　南无不厌见身佛　南无师子声佛　南无不空见佛　南无起行佛　南无一切行清净佛　南无庄严王佛　南无大山王佛

归命南方如是等无量无边诸佛

南无西方无量寿佛　南无师子佛　南无香积王佛　南无香手佛　南无频迅佛　南无虚空藏佛　南无宝幢佛　南无清净眼佛　南无乐庄严佛　南无宝山佛　南无光王佛　南无月出光佛

归命西方如是等无量无边诸佛

南无北方难胜佛　南无月光佛　南无旃檀佛　南无自在佛　南无金色王佛　南无月色旃檀佛　南无普眼见佛　南无普照眼见佛　南无轮手佛　南无无垢佛

归命北方如是等无量无边诸佛

南无东南方治地佛　南无自在佛　南无法自在佛　南无法慧佛　南无法思佛　南无常法慧佛　南无常乐佛　南无善思惟佛　南无善住佛　南无善臂佛

归命东南方如是等无量无边诸佛

南无西南方那罗延佛　南无龙王德佛　南无宝声佛　南无地自在佛　南无人王佛　南无妙声佛　南无黠慧佛　南无妙香华佛　南无天王佛　南无常清净眼佛

归命西南方如是等无量无边诸佛

南无西北方月光面佛　南无月光佛　南无月幢佛　南无勇猛佛　南无日光面佛　南无日藏佛　南无日光庄严佛　南无华身佛　南无波头摩藏佛　南无波头摩须佛　南无师子声王佛　南无善住心意佛

归命西北方如是等无量无边诸佛

南无东北方寂诸根佛　南无寂灭佛　南无大将佛　南无净胜佛　南无净妙声佛　南无净天供养佛　南无善化佛　南无化佛　南无善意佛　南无善意住持佛

归命东北方如是等无量无边诸佛

南无下方实行佛　南无疾行佛　南无黠慧佛　南无坚固王佛　南无金刚齐佛　南无师子佛　南无频迅佛　南无如实住佛　南无成功德佛　南无功德得佛　南无善安乐佛　南无天金刚佛

归命下方如是等无量无边诸佛

南无上方无量胜佛　南无云王佛　南无云功德佛　南无无量称名佛　南无闻身王佛　南无大功德佛　南无大须弥佛　南无降伏魔王佛

归命上方如是等无量无边诸佛

南无未来普贤佛　南无弥勒佛　南无观世音自在佛　南无得大势至佛　南无虚空藏佛　南无无垢称佛　南无成就义佛　南无实声佛　南无大海佛　南无无尽意佛　南无无尽藏佛

归命未来如是等无量无边诸佛

善男子。若人受持读诵是诸佛名。现世安隐远离诸难。及消灭诸罪。未来毕竟得阿耨多罗三藐三菩提

南无无垢光佛　南无乐说庄严思惟佛　南无无垢月幢称佛　南无华光佛　南无大光佛　南无宝上佛　南无无畏观佛　南无远离诸畏惊怖佛　南无师子频迅力佛　南无光明王佛

若善男子善女人。十日读诵思惟是佛名者。必远离一切业障

南无一切同名谓所佛　南无日龙频迅王佛　南无一切同名日龙频迅佛　南无六十功德宝佛　南无一切同名功德宝佛　南无六十二毗留罗佛　南无一切同名毗留罗佛　南无八万四千名自在幢佛　南无一切同名自在幢佛　南无三百大幢佛　南无一切同名大幢佛　南无五百净声王佛　南无一切同名净声王佛　南无五百波头摩王佛　南无一切同名波头摩王佛　南无五百日声佛　南无一切同名日声佛　南无五百乐自在声佛　南无一切同名乐自在声佛　南无五百日佛　南无一切同名日佛　南无五百普光佛　南无一切同名普光佛　南无五百波头摩上王佛　南无一切同名波头摩上王佛　南无七百法光庄严佛　南无一切同名法光庄严佛　南无千法庄严王佛　南无一切同名法庄严王佛　南无千八百称声王佛　南无一切同名称声王佛　南无三万散华佛　南无一切同名散华佛　南无三万三百称声王佛　南无一切同名称声王佛　南无八万四千阿难陀佛　南无一切同名阿难陀佛　南无千八百寂灭佛　南无一切同名寂灭佛　南无五百欢喜佛　南无一切同名欢喜佛　南无五百日声佛　南无一切同名日声佛　南无五百威德佛　南无一切同名威德佛　南无五百上威德佛　南无一切同名上威德佛　南无五百日王佛　南无一切同名日王佛　南无千云雷声王佛　南无一切同名云雷声王佛　南无千日炽自在声佛　南无一切同名日炽自在声佛　南无千离垢声自在王佛　南无一切同名离垢声自在王佛　南无千势自在声佛　南无一切同名势自在声佛　南无千功德盖幢安隐自在王佛　南无一切同名功德盖幢安隐自在王佛　南无千阎浮檀佛　南无一切同名阎浮檀佛　南无千无垢声自在王佛　南无一切同名无垢声自在王佛　南无一万八千莎罗自在王佛　南无一切同名莎罗自在王佛　南无千远离诸怖声自在佛　南无一切同名远离诸怖声自在佛　南无二千驹邻佛　南无一切同名驹邻佛　南无二千宝幢佛　南无一切同名宝幢佛　南无八千坚精进佛　南无一切同名坚精进佛　南无八千威德佛　南无一切同名威德佛　南无八千燃灯佛　南无一切同名燃灯佛　南无十千迦叶佛　南无一切同名迦叶佛　南无十千清净面莲华香积佛　南无一切同名清净面莲华香积佛　南无十千庄严王佛　南无一切同名庄严王佛　南无十千星宿佛　南无一切同名星宿佛　南无一万八千莎罗王佛　南无一切同名沙罗王佛　南无一万八千莎罗自在王佛　南无一切同名莎罗自在王佛　南无一万八千普护佛　南无一切同名普护佛　南无四万愿庄严佛　南无一切同名愿庄严佛　南无三千毗卢舍那佛　南无一切同名毗卢舍那佛　南无三千放光佛　南无一切同名放光佛　南无三千释迦牟尼佛　南无一切同名释迦牟尼佛　南无三万日月太白佛　南无一切同名日月太白佛　南无六万婆头摩上王佛　南无一切同名波头摩上王佛　南无六万能令众生离诸见佛　南无一切同名能令众生离诸见佛　南无六十百千万成就义见佛　南无一切同名成就义见佛　南无无量百千万名不可胜佛　南无一切同名不可胜佛　南无二亿拘邻佛　南无一切同名拘邻佛　南无三亿弗沙佛　南无一切同名弗沙佛　南无六十亿大庄严佛　南无一切同名大庄严佛　南无八十亿实体法决定佛　南无一切同名实体法决定佛　南无六十亿莎罗自在王佛　南无一切同名莎罗自在王佛　南无十八亿实体法决定佛　南无一切同名实体法决定佛　南无十八亿日月灯明佛　南无一切同名日月灯明佛　南无百亿决定光明佛　南无一切同名决定光明佛　南无二十亿日月灯明佛　南无一切同名日月灯明佛　南无二十亿妙声王佛　南无一切同名妙声王佛　南无二十百亿云自在王佛　南无一切同名云自在王佛　南无三十亿释迦牟尼佛　南无一切同名释迦牟尼佛　南无二十亿千怖畏声王佛　南无一切同名怖畏声王佛　南无四十亿那由他妙声佛　南无一切同名妙声佛　南无亿千乐庄严佛　南无一切同名乐庄严佛　南无亿那由他百千觉花佛　南无一切同名觉华佛　南无六十频波罗远离诸怖畏佛　南无一切同名远离诸怖畏佛　南无须弥山微尘数一切功德山王胜名佛　南无一切同名功德山王胜名佛　南无千佛国土不可说亿那由他微尘数普贤佛　南无一切同名普贤佛　南无过去未来现在诸佛　南无旃檀远离诸烦恼藏佛　南无功德频迅佛　南无胜频迅佛　南无修寂静佛　南无上寂静佛　南无住虚空佛　南无降伏诸魔怨佛　南无百宝佛　南无难胜光佛　南无自在作佛　南无日作佛　南无无垢光佛　南无自在观佛　南无金光明师子频迅佛　南无无垢威德佛　南无观自在佛　南无金明师子频迅佛　南无无量光佛　南无释迦牟尼佛　南无静去佛　南无寂静上佛　南无普光明积上功德王佛　南无普现见佛　南无金刚功德佛　南无金光普耀佛　南无不动佛　南无普贤佛　南无普照佛　南无宝法上决定佛　南无无畏王佛　南无无垢光佛　南无乐说庄严思惟佛　南无无垢月幢称佛　南无拘苏摩庄严光明作佛　南无出火佛　南无宝上佛　南无无畏观佛　南无师子频迅力佛　南无远离怖畏毛竖称佛　南无金刚牟尼佛　南无饮甘露佛　南无金刚光王佛　南无善见佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无难胜佛　南无阿閦佛　南无卢舍那佛　南无阿弥陀佛　南无尼弥佛　南无宝光炎佛　南无弥留佛　南无自在佛　南无宝精进月光庄严威德声自在王佛　南无远离一切诸畏烦恼上功德佛　南无初发心念断疑发解断烦恼佛　南无断诸烦恼闇三昧上王佛　南无金刚坚强消伏坏散佛

若有众生欲求佛道者。不闻此佛名终不得成佛。若有众生得闻此佛名者即得成佛。除灭阿鼻地狱十万亿劫无间重罪

南无宝炎佛　南无大炎积佛　南无栴檀佛　南无手上王佛　南无宝上佛　南无善住智慧王无障佛　南无火光慧灭昏闇佛　南无象增上佛　南无截金刚佛　南无天王佛　南无一切义上王佛　南无三昧喻佛　南无念王佛　南无光明观佛　南无一切所依王佛　南无善护幢王佛　南无发趣速自在王佛　南无宝焰佛　南无积大焰佛　南无旃檀香佛　南无手上王佛　南无宝上佛　南无善住慧王无障佛　南无大智意佛　南无宝藏佛　南无放焰佛　南无迦叶佛　南无多罗住佛　南无智来佛　南无能圣佛　南无过一切忧恼王佛　南无一切功德庄严佛　南无成就一切义佛　南无无畏王佛　南无一切众生导师佛　南无萨婆毗浮佛　南无不动光观自在无量命尼弥宝焰弥留金刚佛　南无火频迅通佛　南无善寂慧月声自在王佛　南无清净月轮佛　南无住阿僧祇精进功德佛　南无无尽意佛　南无宝幢佛　南无光明无垢藏佛　南无火频迅通佛　南无云普护佛　南无师子频迅通佛　南无弥留上王佛　南无智慧来佛　南无护妙法幢佛　南无金光明师子频迅王佛　南无普照积上功德王佛　南无善住功德如意积王佛　南无普现佛　南无释迦牟尼佛　南无无量光佛　南无放焰佛

敬礼舍利形像浮图庙塔

次礼十二部尊经大藏法轮　凡阎浮界内一切经合有八万四千卷

南无大方广佛华严经　南无大般涅槃经　南无摩诃般若波罗蜜经　南无大方等大集经　南无大方等日藏经　南无大方等月藏经　南无大威德陀罗尼经　南无法炬陀罗尼经　南无菩萨璎珞经　南无菩萨见实三昧经　南无佛名经　南无月灯三昧经　南无贤劫经　南无华手经　南无十住断结经　南无大灌顶经　南无观佛三昧经　南无五千五百佛名经　南无胜天王般若波罗蜜经　南无金光明经　南无宝云经　南无法集经　南无菩萨处胎经　南无大悲经　南无深密解脱经　南无大集贤护菩萨经　南无大方等无相经　南无密迹金刚力士经　南无大方等陀罗尼经　南无海龙王经　南无央掘魔罗经　南无无所有菩萨经　南无僧伽吒经　南无观察诸法经　南无称扬诸佛功德经　南无等目菩萨所问三昧经　南无菩萨藏经　南无力庄严三昧经　南无明度五十挍计经　南无须真天子经　南无菩萨璎珞本业经　南无护国菩萨经　南无超日明三昧经　南无月上女经　南无中阴经　南无须弥藏经　南无佛华严入如来不思议境界经　南无首楞严三昧经　南无大法鼓经　南无诸佛要集经

敬礼十方诸大菩萨摩诃萨

南无普贤菩萨　南无文殊师利菩萨　南无无垢称菩萨　南无地藏菩萨　南无虚空藏菩萨　南无观世音菩萨　南无大势至菩萨　南无香象菩萨　南无大香象菩萨　南无药王菩萨　南无药上菩萨　南无金刚藏菩萨　南无解脱月菩萨　南无弥勒菩萨　南无珠发菩萨　南无频迅菩萨　南无无所发菩萨　南无陀罗尼自在王菩萨　南无无尽意菩萨　南无坚意菩萨　南无东方九十亿百千万同名梵胜菩萨　南无南方九十亿百千万同名不邻陀罗菩萨　南无西方九十亿百千万同名大功德菩萨　南无北方九十亿百千万同名大药王菩萨

舍利弗应当敬礼十方诸大菩萨摩诃萨

南无文殊师利菩萨摩诃萨　南无观世音菩萨　南无大势至菩萨　南无普贤菩萨　南无龙胜菩萨　南无龙德菩萨　南无胜成就菩萨　南无波头摩胜菩萨　南无成就有菩萨　南无持地菩萨　南无宝掌菩萨　南无宝印手菩萨　南无师子意菩萨　南无胜藏菩萨　南无虚空藏菩萨　南无师子频迅吼声菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无阿利多辟支佛　南无婆梨多辟支佛　南无多伽楼辟支佛　南无称辟支佛　南无见辟支佛　南无爱见辟支佛　南无觉辟支佛　南无乾陀罗辟支佛　南无无妻辟支佛　南无梨沙婆辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

夫欲礼忏悔必须先敬三宝。所以然者。三宝则是一切众生良友福田。若能归向者。则灭无量罪长无量福。能令行者离生死苦得解脱乐。是故弟子某甲等。归依十方尽虚空界一切诸佛。归依十方尽虚空界一切尊法。归依十方尽虚空界一切诸大菩萨。归依十方尽虚空界一切圣僧。弟子今日所以忏悔者。正言无始已来在凡夫地。莫问贵贱罪自无量。或因三业而生罪。或从六根而起过。或以内心自邪思惟。或籍外境起于染着。如是乃至十恶增长。八万四千诸尘劳门。然其罪相虽复无量。大而为语不出有三。何等为三。一者烦恼障。二者是业障。三者是果报障。此三种法能障圣道及以人天胜妙好事。是故经中目为三障。所以诸佛菩萨教作方便忏悔。除灭此三障者。则六根十恶乃至八万四千诸尘劳门皆悉清净。是故弟子。今日运此增上胜心忏悔三障。欲灭此三障罪者。当用何等心。可令此罪灭除。先当兴七种心以为方便。然后此罪乃可得灭。何等为七。一者惭愧。二者恐怖。三者厌离。四者发菩提心。五者怨亲平等。六者念报佛恩。七者观罪性空

第一惭愧者。自惟我与释迦如来同为凡夫。而今世尊成道以来。以经尔所尘沙劫数而我等相与耽染六尘。流浪生死永无出期。此实天下可惭可愧可羞可耻

第二恐怖者。既是凡夫身口意业常与罪相应。以是因缘命终之后应堕地狱畜生饿鬼受无量苦。如此实为可惊可恐可怖可惧

第三厌离者。相与当观生死之中唯有无常苦空无我不净。虚假如水上泡速起速灭。往来流转犹若车轮。生老病死八苦交煎无时暂息众等相与但观自身。从头至足其中但有三十六物。发毛爪齿脓囊涕涶。生熟二藏大肠小肠。脾肾心肺肝胆[月*冊]胃肪膏[腮-田+匆]膜筋脉骨髓。大小便利九孔常流。是故经言。此身众苦所集一切皆不净物。何有智慧者而当乐此臭肉身也。生死既有如此种种恶法甚可患厌

第四发菩提心者。经言当乐佛身。佛身者即法身也。从无量功德智慧生。从六波罗蜜生。从慈悲喜舍生。从三十七助菩提法生。从如是等种种功德智慧生如来身。欲得此身者。当发菩提心求一切种智常乐我净萨婆若果。净佛国土成就众生。于身命财无所吝惜

第五怨亲平等者。于一切众生起慈悲心无彼我想。何以故尔。若见怨异亲则是分别。以分别故起诸想着。想着因缘生诸烦恼。烦恼因缘造诸恶业。恶业因缘故得苦果

第六念报佛恩者。如来往昔无量劫中。舍头目随脑支节手足国城妻子象马七珍。为我等故修诸苦行。此恩此德实难酬报。是故经言若以顶戴两肩荷负。于恒沙劫亦不能报。我等欲报如来恩者。当于此世勇猛精进捍劳忍苦。不惜身命建立三宝。弘通大乘广化众生同入正道

第七观罪性空者。无有实相从因缘生。颠倒而有。既从因缘而生。则可从因缘而灭。从因缘而生者。押近恶友造作无端。从因缘而灭者。即是今日洗心忏悔。是故经言。此罪相不在内不在外不在中间。故知此罪从本是空。生如是等七种心。以缘想十方诸佛贤圣。擎拳合掌披陈至到。惭愧改革舒沥心肝洗荡肠胃。如此忏悔亦何罪而不灭。亦何障而不消。若复正尔悠悠缓纵情虑。徒自劳形于事何益。且复人命无常喻如转烛。一息不还便向灰壤。三涂苦报则身应受。不可以钱财宝货嘱托求脱。窈窈冥冥恩赦无期。独婴此苦无代受者。莫言我今生中无有此罪。所以不能恳到忏悔。经中导言。凡夫之人举足动步无非是罪。又复过去生中皆悉成就无量恶业。追逐行者如影随形。今日若不忏悔罪恶日深。故包藏瘕疵佛教不许。说忏悔先罪净名所尚。故知长沦苦海寔由隐覆。是故弟子。今日发露忏悔不敢覆藏。所言三障者。一曰烦恼障。二名为业障。三是果报障。此三种法更相由籍。因烦恼故所以起恶业。恶业因缘故得苦果。是故弟子今日至心。第一先应忏悔烦恼障。又此烦恼诸佛菩萨入理圣人种种呵啧。亦詺此烦恼以为怨家。何以故。能断众生慧命根故。亦詺此烦恼以之为贼。能劫众生诸善法故。亦詺此烦恼以为暴河。能[漂*寸]众生入于生死大苦海故。亦詺此烦恼以为羁锁。能系众生于生死狱不能得出故。亦詺此烦恼犹如蟒虫。食啖众生真如佛性故。所以六道牵连四生不绝。恶业无穷苦果不息。当知皆是烦恼过患。是故弟子。今日运此增上善心归依佛

南无东方善德佛　南无南方宝相佛　南无西方普光佛　南无北方相德佛　南无东南方网明佛　南无西南方上智佛　南无西北方华德佛　南无东北方明智佛　南无下方明德佛　南无上方香积佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。或在人天六道受报。有此心识常怀愚惑繁满胸襟。或因三毒根造一切罪。或因三漏造一切罪。或因三觉造一切罪。或因三受造一切罪。或因三苦造一切罪。或缘三假造一切罪。或贪三有造一切罪。如是等罪无量无边。恼乱一切六道四生。今日惭愧归命忏悔

又复弟子无始以来至于今日。或因四识住造一切罪。或因四流造一切罪。或因四取造一切罪。或因四执造一切罪。或因四缘造一切罪。或因四大造一切罪。或因四缚造一切罪。或因四食造一切罪。或因四生造一切罪。如是等罪无量无边。恼乱六道一切众生。今日惭愧归命忏悔

又复弟子无始以来至于今日。或因五住地烦恼造一切罪。或因五受根造一切罪。或因五盖造一切罪。或因五悭造一切罪。或因五见造一切罪。或因五心造一切罪。如是等烦恼无量无边。恼乱六道一切四生。今日发露归命忏悔

又复弟子。无始已来至于今日。或因六情根造一切罪。或因六识造一切罪。或因六想造一切罪。或因六受造一切罪。或因六行造一切罪。或因六爱造一切罪。或因六疑造一切罪。如是等烦恼无量无边。恼乱六道。一切四生。今日惭愧归命忏悔

又复弟子无始以来至于今日。或因七漏造一切罪。或因七使造一切罪。或因八倒造一切罪。或因八垢造一切罪。或因八苦造一切罪。如是等烦恼无量无边。恼乱六道一切四生。今日发露归命忏悔

又复弟子。无始已来至于今日。或因九恼造一切罪。或因九结造一切罪。或因九上缘造一切罪。或因十烦恼造一切罪。或因十缠造一切罪。或因十一遍使造一切罪。或因十二入造一切罪。或因十六知见造一切罪。或因十八界造一切罪。或因二十五我造一切罪。或因六十二见造一切罪。或因见谛思惟九十八使。百八烦恼昼夜炽然。开诸漏门造一切罪。如是等烦恼无量无边。恼乱贤圣及以四生。遍满三界弥亘六道。无处可藏无处可避。今日至到向十方佛尊法圣众。惭愧发露皆悉忏悔

愿弟子等。承是忏悔三毒等一切诸烦恼所生功德。愿生生世世三慧明三达朗三苦灭三愿满。愿弟子等承是忏悔四识等一切诸烦恼所生功德。愿生生世世广四等心立四信业。四恶趣灭得四无畏

愿弟子等承是忏悔五盖等诸烦恼所生功德。愿生生世世度五道树五根。净五眼成五分

愿弟子等承是忏悔六爱等诸烦恼所生功德。愿生生世世具足六神通满足六度业。不为六尘惑常行六妙行

愿弟子等承是忏悔七漏八垢九结十缠等一切诸烦恼所生功德。愿生生世世坐七净华。洗尘八水具九断智。成十地行愿。以忏悔十一遍使及十二入十八界等一切诸烦恼所生功德。愿生生世世十一空解常用洗心。自在能转十二行轮。具足十八不共之法。无量功德一切圆满

三部合卷罪报应经此经有二十八品略此一品流行

    大乘莲华宝达问答报应沙门品第一

尔时摩竭道场菩提树光明不现。其华枯悴堕落佛前。一切大众皆悉惊疑。各相谓言。今此菩提道场树华。何故堕落。大众菩萨皆生疑惑不自安隐

尔时宝达菩萨前白佛言。云何菩提树华悉皆堕落。其华光色不如于常。一切大众皆生疑惑。唯愿天尊为我解说。令此众中诸坐大士疑惑悉除

尔时世尊从三昧起。光颜魏魏举身毛孔皆悉出光。语宝达菩萨言。汝等善听今为汝说。所以菩提树华堕落失光者何如上所说。沙门行恶堕落苦处受罪无殃。是故菩提树华失光堕落。宝达前白佛言。唯愿世尊。为我说此恶行沙门果报之处

佛告宝达菩萨。东方乃有铁围大山。其山中间幽冥之处。日月光明及以火光所不能照。名曰地狱。其狱之中有恶沙门受如是罪。汝可往诣问诸罪人。云何因缘来生此处。修何等行受如是罪

宝达白佛言。世尊。我无威神何能往诣。愿佛大悲垂神顾念。乃使我等得见东方阿鼻地狱。佛言。善哉善哉。汝今但往令汝得见。宝达菩萨礼佛而去。龙飞虚空徘徊自在。当尔之时大地震动。于虚空中雨宝莲华飞流而下

尔时宝达一念之顷往诣东方铁围山间。其山崦[山*曇]幽冥高峻。其山四方了无草木。日月威光都不能照

宝达须前。挟道两边有三十六王。典主地狱。其王名曰恒伽噤王。波吉头王。广目都王。安头罗王。虎目见王。阳声吉王。大诤诵王。吸血鬼王。安得罗王。陀达王。达多罗王。吉梨善王。安侯罗王。宝首王。金树吉王。大恶声王。鸟头王。等虎眼王。等象牙王。等震声王。等归首王。衣首王。见首王。广安王。广定王。王头王。立正王。立见王。摩尼罗王。都曹王。部见王。恶目王。善王。龙口王。鬼王。南安王等。三十六王遥见宝达菩萨。悉皆叉手合掌。前行作礼白言。大智尊王。云何因缘入此苦处。亦如栴檀在伊兰而生。宝达答言。我闻如来三界人尊说言。东方有铁围山。其山幽冥。日月之光所不能照。我故闻之故来诣。汝诸王前入地狱行诸罪人。汝等诸王谁能共我往诣大王前见罪人受苦之者。尔时恒伽噤王。则便与宝达菩萨往诣大王

尔时大鬼王。遥见宝达菩萨从门而来光颜从容。则便下座往前礼敬白言。大士。今此恶处云何怪哉。伊兰林中忽生栴檀。尔时宝达便前就座。问鬼王曰。今此东方地狱可有几狱。鬼王答言。此山之中有无量地狱。今此一方有三十二沙门地狱。宝达问曰。三十二地狱。其名云何。鬼王答曰。铁车铁马铁牛铁驴地狱。铁衣地狱。铁铢地狱。洋铜灌口地狱。流火地狱。铁床地狱。耕田地狱。斫首地狱。烧脚地狱。铁锵地狱。饮铁铢地狱。飞刀地狱。火箭地狱。[月*鬼]肉地狱。身然地狱。火丸仰口地狱。诤论地狱。雨火地狱。流火地狱。粪屎地狱。钩阴地狱。火象地狱。咩声叫唤地狱。铁[金*疾][金*離]地狱。崩埋地狱。然手脚地狱。铜狗钩牙地狱。剥皮饮血地狱。解身地狱。铁屋地狱。铁山地狱。飞火叫唤分头地狱。尔时鬼王答宝达曰。地狱受罪其名如是

佛说佛名经卷第一

按开元录伪妄乱真中云。右一经时俗号为马头罗刹佛名经。似是近代所集。乃取流支所译十二卷者。错综而成。于中取诸经名目。后取辟支佛及菩萨阿罗汉名。以为三宝次第。总有三十二件。礼三宝后皆有忏悔。忏悔之下仍引马头罗刹伪经。置之于后。乃以凡俗鄙语杂于圣言。寻其所集之者。全是庸愚。只如第四卷云南无法显传经。在法宝中列此传。乃是东晋沙门法显。往游天竺自记行迹。元非是经。置法宝中误谬之甚。又如第九卷云南无富楼那。南无弥陀罗尼子。此是一人之名。分为二唱。次云南无阿难罗睺罗。此乃二人之名。合之为一。如斯谬妄其类寔繁。群愚仿习邪傥共传。若不指明恐秽真教。故此述之。贞元录云。此经乃以凡俗鄙语杂于圣言。本经虽真以有伪杂。作此挍量编于伪妄乱真录中。不得入藏。由斯可否已数百年。贞元十五年十月二十三日。乃颁制曰大佛名经。左右监门卫将军知内侍省事马承债奏。前件经未入藏目录。敕旨宜令所司附入目录。今于谬妄之处。分者请合。合者请分。诸如此类伏请改正。下顺人望上副天心。编入贞元新定释教目录。传出梁朝附于梁代

校曰今捡国本大藏。彼回汉函中。亦有此经十八卷者。以此三十卷本对彼校之。卷数虽异文义全同。但一样忏文。此经再叠彼乃三叠。又宝达伪经此有彼无。为少异耳。此一伪经古有二名。一名大乘莲华马头罗刹经。古十六卷本。用此名合之。一名宝达菩萨问报应沙门经。而无答字。今此三十卷本用此名合之。而妄加答字。隋开皇十四年敕沙门法经等。所撰众经目录。暨皇唐诸家目录。并以此宝达经列为伪妄。今佛名经。前诸录家真伪不录。开元录中收为伪妄。而合此宝达伪经。则妄中加妄也。开元录云。经至晋土其年未远。而喜事者以沙揉金而无括正。何以别真伪乎。农者禾草俱存。后稷为之叹息。金匮玉石同缄卞和为之怀耻。泾渭淆杂龙蛇并进。岂不耻之。今列意谓。非佛经者以示将来学士。共知鄙倍焉。遂摽此经而为其首。录家恳嘱知是。国本如何二重重载。彼十八卷经。乃似是贞元录中奉　制所收入者。其分卷小异耳。后人见此三十卷本。认为异经故加入耳。今欲删正则彼十八卷者乃无。宝达伪经稍正可存。然此三十卷经本朝盛行。行来日久国俗多有倚此而作福者。今忽删之彼必众怒。若俱存之理亦未可。且顺人情存此而删彼。因书古人之意。以告雅正君子。但其误分错合之处。今随改之。如第十二卷云。南无拘絺罗难陀。此是二圣之名。经错合之。今分为二。第十三卷云。南无宾头卢南无颇罗堕。此是一圣之名。经误分之。今合为一。此类不少不能具叙。呜呼阿难大圣也。距佛不远也。经藏所集也。而欲正一僧水鹤之偈。僧竟不从。况我凡夫乎。佛世已远乎。经法遥传乎。而于举国盛行久远之典。忽独起以删之。而欲众情之不怒己。如螗螂之怒其臂以当车欲其不辗己也。犹不足以譬其非分也。心知伪妄力不能正。末法之弊一至于此。伤哉。但有一理。既所患在于伪妄乱真。若于诸经之名。诸罗汉号。忏悔文等。分明知是人所撰集有所错处。各依圣教本文而正之。删去宝达伪经。而名之曰夹忏佛名经。使人看其名分其主客。如诸家夹注解经。则其行于世。亦庶几乎可矣

佛名经卷第一佛说佛名经卷第二

南无栴檀香佛　南无无垢慧深声王佛　南无断一切障佛　南无无量光明佛　南无作功德佛　南无普香上佛　南无不可胜频迅声王佛　南无降伏憍慢佛　南无毗婆尸佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含牟尼佛　南无迦叶佛　南无释迦牟尼佛　南无成就一切义佛　南无能作无畏佛　南无寂静王佛　南无阿閦佛　南无卢至佛　南无阿弥多佛　南无尼弥佛　南无住法佛　南无宝炎佛　南无弥留佛　南无金刚佛　南无持法佛　南无勇猛法佛　南无妙法光明佛　南无法月面佛　南无住法佛　南无法幢佛　南无法威德佛　南无法自在佛　南无善住法佛　南无法寂静佛　南无善智力佛　南无弥勒等无量佛　南无毗婆尸佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含牟尼佛　南无迦叶佛　南无释迦牟尼佛　南无阿弥陀佛　南无天光照佛　南无胜色佛　南无乐意佛　南无大导师佛　南无大圣天佛　南无那罗延佛　南无树提佛　南无慈他佛　南无毗卢遮那佛　南无栴檀佛　南无具足佛　南无化现佛　南无善化佛　南无世自在佛　南无人自在佛　南无摩醢那自在佛　南无胜自在佛　南无十力自在佛　南无毗头罗佛　南无离诸畏佛　南无离诸忧佛　南无能破诸邪佛　南无散诸邪佛　南无破异意佛　南无智慧岳佛　南无宝岳佛　南无弥留岳佛　南无降魔佛　南无善才佛　南无坚才佛　南无坚频迅佛　南无坚精进佛　南无坚莎罗佛　南无坚心佛　南无坚勇猛破阵佛　南无破诤佛　南无实体佛　南无昙无竭佛　南无尼尸陀佛　南无波罗罗坚佛　南无普光佛　南无普贤佛　南无胜海佛　南无功德海佛　南无法海佛　南无虚空寂佛　南无虚空功德佛　南无虚空库藏佛　南无虚空心佛　南无虚空多罗佛　南无无垢心佛　南无功德林佛　南无放光世界中现在说法虚空胜离尘无垢尘平等眼清净功德幢光明华波头摩琉璃光宝香象身胜妙罗网庄严顶无量日月光明照庄严愿上庄严法界善化无障碍王佛　南无彼佛世界中有菩萨名无比。彼佛授记不久得阿耨多罗三藐三菩提。佛号种种光华宝波头摩金色身普照庄严不住眼放光照十方世界幢王佛

若有善男子善女人。信心受持读诵彼佛及菩萨名。是善男子善女人超越阎浮提微尘数劫。得陀罗尼。一切诸恶病不及其身

南无无量功德宝集乐示现金光明师子频迅王佛　南无师子频迅心云声王佛　南无无垢清净光明觉宝华不断光庄严王佛　南无宝光月庄严智功德声自在王佛　南无宝波头摩智清净上王佛　南无摩善住山王佛　南无光花种种频迅王佛　南无拘苏摩奋迅王佛　南无波头摩华上弥留幢王佛　南无法幢空俱苏摩王佛　南无莎罗华上光王佛　南无无垢眼上光王佛　南无无垢意山上王佛　南无种种乐说庄严王佛　南无无碍药王成就胜王佛　南无千云雷声王佛　南无金光明师子频迅王佛　南无善寂智慧月声自在王佛　南无善住摩尼山王佛　南无欢喜藏胜山王佛　南无普光上胜功德山王佛　南无功德藏增上山王佛　南无动山岳王佛　南无善住诸禅藏王佛　南无法海潮功德王佛　南无称功德山王佛　南无一切华香自在王佛　南无银幢盖王佛　南无雷灯幢王佛　南无月摩尼光王佛　南无波头摩上星宿王佛　南无无量香上王佛　南无觉王佛　南无上弥留幢王佛　南无莎罗华上王佛　南无因陀罗幢王佛　南无师子频迅王佛　南无俱苏摩生王佛　南无微细华佛　南无说义佛　南无无量精进佛　南无无边弥留佛　南无离垢佛　南无无量眼佛　南无无量发行佛　南无发行难胜佛　南无无所发行佛　南无无量发行佛　南无断诸难佛　南无不定愿佛　南无善住诸愿佛　南无无念示现诸行佛　南无无量善根成就诸行佛　南无无垢频迅佛　南无不住住频迅佛　南无妙色佛　南无无相声佛　南无虚空星宿增上王佛　南无栴檀室佛　南无乐意佛　南无善行佛　南无境界自在佛　南无乐行佛　南无乐解脱佛　南无远离怖畏毛竖佛　南无清净眼佛　南无进寂静佛　南无世间可乐佛　南无随世间意佛　南无随世间眼佛　南无宝王佛　南无宝爱佛　南无罗睺罗佛　南无罗睺罗天佛　南无罗睺罗净佛　南无宝慧佛　南无宝鬘佛　南无宝形佛　南无罗网手佛　南无摩尼轮佛　南无解脱威德佛　南无善行佛　南无大爱佛　南无人面佛　南无吉佛　南无蔓陀罗佛　南无净圣佛　南无净宿佛　南无离胎佛　南无虚空庄严佛　南无集功德佛　南无师子步佛　南无功德海佛　南无摩尼功德佛　南无广功德佛　南无称成佛　南无大如意轮佛　南无无畏上王佛　南无俱苏摩国土佛　南无功德幢佛　南无威德佛　南无华眼佛

南无喜身佛　南无慧国土佛　南无喜威德佛　南无波头陀智慧频迅佛　南无功德聚佛　南无寂灭慧佛　南无降魔佛　南无无上光佛　南无法自在佛　南无得世间功德佛　南无实谛称佛　南无智胜佛　南无智爱佛　南无得智佛　南无智幢佛　南无罗网光幢佛

善男子善女人与一切众生安隐乐如诸佛者。当读诵是诸佛名复作是言

南无离诸无智曀佛　南无虚空平等心佛　南无清净无垢佛　南无善无垢藏佛　南无火炎积佛　南无坚固行佛　南无精进声佛　南无不离一切众生门佛　南无断诸过佛　南无成就观佛　南无平等须弥面佛　南无无障碍精进坚佛　南无莎罗华华王佛　南无无量功德王佛　南无弥留灯王佛　南无药王声声王佛　南无梵声王佛　南无妙鼓声王佛　南无云声王佛　南无龙自在王佛　南无世间自在王佛　南无陀罗尼自在王佛　南无深王佛　南无治诸病王佛　南无药王佛　南无象王佛　南无灯王佛　南无树提王佛　南无喜王佛　南无星宿王佛　南无云王佛　南无雷王佛　南无莎罗王佛　南无雁王佛　南无坚固自在王佛　南无功德聚佛　南无华聚佛　南无宝聚佛　南无宝住持庭燎佛　南无住持功德佛　南无住持无障力佛　南无住持地力进去佛　南无住持妙无垢位佛　南无一切宝庄严色住持佛　南无自在转一切法佛　南无转法轮佛　南无胜威德佛　南无净威德佛　南无圣威德佛　南无莎罗威德佛　南无师子威德佛　南无大威德佛　南无悲威德佛　南无无垢威德佛　南无地威德佛　南无无垢琉璃佛　南无无垢臂佛　南无无垢眼佛　南无无垢面佛　南无波头摩面佛　南无月面佛　南无日面佛　南无日威德庄严佛　南无金色佛　南无金色形佛　南无可乐色佛　南无金色莲华佛　南无瞻婆伽色佛　南无能与乐佛　南无能与眼佛　南无难胜佛　南无难降伏佛　南无断诸恶佛　南无难量佛　南无难成佛　南无俱苏摩成佛　南无甘露成佛　南无宝成就佛　南无功德成就佛　南无日成就佛　南无华成就佛　南无成就乐有佛　南无成就功德佛　南无大胜佛　南无上妙王佛　南无无垢佛　南无离诸障佛　南无婆楼那佛　南无婆楼那天佛　南无勇猛仙佛　南无精进仙佛　南无无垢仙佛　南无金刚仙佛　南无观眼佛　南无无障碍佛　南无住虚空佛　南无住清净佛　南无善住清净功德宝佛　南无善迹佛　南无善思议佛　南无善化佛　南无善爱佛　南无善眼佛　南无善亲佛　南无善行佛　南无善生佛　南无善华佛　南无善香佛　南无善声佛　南无善臂佛　南无善光佛　南无善山佛　南无宝山佛　南无功德山佛　南无智山佛　南无胜山佛　南无上山佛　南无光明庄严佛　南无大光明庄严佛　南无清净庄严佛　南无波头摩庄严佛　南无实中佛　南无金刚合佛　南无金刚齐佛　南无碎金刚佛　南无碎金刚坚佛　南无降伏魔佛　南无不空见佛　南无爱见佛　南无现见佛　南无善见佛　南无大善见佛　南无普见佛　南无无垢见佛　南无见平等不平等佛　南无见一切义佛　南无断一切障碍佛　南无断一切众生病佛　南无一切世间爱见佛　南无上妙佛　南无大庄严佛　南无一切三昧佛　南无度一切疑佛　南无度一切法佛　南无不取诸法佛　南无一切清净佛　南无一切义成就佛　南无一切通佛　南无华通佛　南无波头摩树提频迅通佛　南无俱苏摩通佛　南无海住持胜智慧频迅通佛　南无多摩罗华栴檀香通佛　南无常观佛　南无常围绕佛　南无常不轻佛　南无常忧佛　南无常喜佛　南无常笑欢喜根佛　南无常满足手佛　南无常举手佛　南无常黠慧佛　南无常修行佛　南无常精进佛　南无尼拘律佛　南无阿叔迦佛　南无金色律佛　南无华开佛　南无善决定佛　南无波头摩光佛　南无华身佛　南无手脚柔濡触身佛　南无日轮佛　南无闻满足佛　南无相身身佛　南无胜威德佛　南无无垢身佛　南无波头摩花身佛　南无得无碍佛　南无愿得满足佛　南无得普照清净佛　南无得大无畏佛　南无至大佛　南无至大精进究竟佛　南无大境界佛

次礼十二部尊经大藏法轮

南无文殊师利佛土严净经　南无濡首菩萨无上清净分卫经　南无大乘同性经　南无大乘集譬喻经　南无诸法无行经　南无阿閦佛国经　南无般舟三昧经　南无莲华面经　南无东方最胜灯王如来经　南无迦叶经　南无诸法最上王经　南无孔雀王陀罗尼经　南无发觉净心经　南无无上依经　南无惟识经　南无未曾有因缘经　南无缘生经　南无成具光明定意经　南无太子须太拏经　南无太子慕魄经　南无须赖经　南无金色王经　南无独证自誓三昧经　南无摩诃摩邪经　南无大方等如来藏经　南无如来方便善巧咒经　南无胜鬘师子吼一乘大方便经　南无须摩提菩萨经　南无希有挍量功德经　南无梵女首意经　南无差摩波帝受记经　南无月明菩萨经　南无灭十方冥经　南无出生菩提心经　南无普门品经　南无菩萨十住经　南无商主天子经　南无心明女经　南无月灯三昧经　南无不思议光菩萨所说经　南无文殊师利菩萨问署经　南无德光太子经　南无施灯功德经　南无菩萨呵色欲经　南无人本欲生经　南无不增不减经　南无佛语经　南无无字宝箧经　南无如来师子吼经　南无十法经

敬礼十方诸大菩萨摩诃萨

南无发心则转法轮菩萨　南无一切声差别乐说菩萨　南无山乐说菩萨　南无大海意菩萨　南无大山菩萨　南无爱见菩萨　南无欢喜王菩萨　南无无边观菩萨　南无无边观行菩萨　南无破耶见魔菩萨　南无无忧德菩萨　南无成就一切义菩萨　南无师子菩萨　南无善住意菩萨　南无无比心菩萨　南无那罗德菩萨　南无因陀罗德菩萨　南无海天菩萨　南无跋陀波罗菩萨　南无药王菩萨　南无卢舍那菩萨　南无月光菩萨　南无波头摩胜菩萨　南无智山菩萨　南无圣藏菩萨　南无不舍行菩萨　南无不空见菩萨　南无妙声菩萨　南无妙声吼菩萨　南无常微笑寂根菩萨　南无波头摩道胜菩萨　南无广思惟菩萨　南无忧波罗眼菩萨　南无可供养菩萨　南无常忆菩萨　南无住一切悲见菩萨　南无断一切恶法菩萨　南无住一切声菩萨　南无住一切有菩萨　南无住佛声菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无闻辟支佛　南无智身辟支佛　南无毗邪离辟支佛　南无俱菩萨罗辟支佛　南无波薮陀罗辟支佛　南无无毒净心辟支佛　南无实无垢辟支佛　南无福德辟支佛　南无黑辟支佛　南无唯黑辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

夫论忏悔者。本是改往修来灭恶兴善。人生居世谁能无过学人失念尚起烦恼。罗汉结习动身口业。岂况凡夫而当无过。但智者先觉便能改悔。愚者覆藏遂使滋蔓。所以积习长夜晓悟无期。若能惭愧发露忏悔者。岂唯正是灭罪而已。亦复增长无量功德。树立如来涅槃妙果。若欲行此法者。先当外肃形仪瞻奉尊像。内起敬意缘于想法。慊切至到生二种心。何等为二。一者自念我此形命难可常保。一朝散坏不知此身何时可复。若复不值诸佛贤圣。忽遭逢恶友造众罪业。复应堕落深坑险趣。二者自念我此生中。虽得值遇如来正法为佛弟子。弟子之法绍继圣种。净身口意善法自居。而今我等公自作恶而复覆藏。言他不知谓彼不见。隐匿在心傲然无愧。此实天下愚惑之甚。则今现有十方诸佛诸大地菩萨诸天神仙。何曾不以清净天眼见于我等所作罪恶。又复幽显灵只。注记罪福纤毫无差。夫论作罪之人命终之后。牛头狱卒录其精神。在阎罗王所辨穷是非。当尔之时一切怨对皆来证据。各言汝先屠戮我身炮煮蒸炙。或言汝先剥夺于我一切财宝。离我眷属。我于今者始得汝便。于时现前证据何得敢讳。唯应甘心分受宿殃。如经所明地狱之中不枉治人。若其生平之日。素所作众罪心自失者。是其生时造恶之处。一切诸相皆现在前。各言汝昔在于我边作如是罪今何得讳。是为作罪无藏隐处。于是阎魔罗王切齿呵啧将付地狱。历劫穷年求出莫由。此事不远不关他人。正是我身自作自受。虽父子至亲。一旦对至无代受者。众等相与及其形休体无众疾。各自努力与性命竞生大怖畏。死欲至时悔无所及。是故弟子至心。归命十方诸佛

南无东方破疑净光佛　南无南方无忧功德佛　南无西方华严神通佛　南无北方月殿清净佛　南无东南方破一切闇佛　南无西南方大哀观众生佛　南无西北方香气放光明佛　南无东北方无量功德海佛　南无下方断一切疑佛　南无上方离一切忧佛

归命如是等十方尽虚空界一切三宝

弟子等从无始已来至于今日。积聚无明障蔽心目。随烦恼性造三世罪业。或耽染爱着起于贪欲烦恼。或嗔恚忿怒怀害烦恼。或惛愦瞢瞪不了烦恼。或我慢自高轻傲烦恼。疑惑正道犹预烦恼。谤无因果邪见烦恼。不识缘假着我烦恼。迷于三世执断常烦恼。朋狎恶法起见取烦恼。僻禀邪师造戒取烦恼。乃至一等四执撗计烦恼。今日至诚归命忏悔

又复弟子等从无始以来至于今日。守惜坚着起悭吝烦恼。不摄六情奢诞烦恼。心行弊恶不忍烦恼。懒惰缓纵不勤烦恼。情虑[跳-兆+參]动觉观烦恼。触境迷惑无知解烦恼。随世八风生彼我烦恼。谄曲面誉不直心烦恼。撗强难触不调和烦恼。易忿难悦多含恨烦恼。嫉妒系刺佷戾烦恼。凶险暴害谄毒烦恼。乖背二谛执相烦恼。于苦集灭道生颠倒烦恼。随从生死十二因缘流转烦恼。乃至无始无明住地恒沙烦恼。起四住地构于三界苦果烦恼。如是等诸烦恼无量无边。恼乱贤圣六道四生。今日发露向十方佛尊法圣众。归命忏悔

愿弟子等。承是忏悔贪嗔痴等一切诸烦恼所生功德。愿生生世世折憍慢幢。竭爱欲水灭嗔恚火。破愚痴暗拔断疑根裂诸见网。深识三界犹如牢狱四大毒蛇五阴怨贼。六入空聚爱诈亲善。修八圣道断无明源。正向涅槃不休不息。三十七品心心相应。十波罗蜜常现在前

    大乘莲华宝达问答报应沙门经

宝达即便入地狱中。上高楼头四顾望视。见罪人等各从四门号叫而入宝达前。入铁车铁牛铁驴铁马。此四小地狱前为一地狱。云何名曰铁车铁马铁牛铁驴地狱。此地狱方圆纵广十五由旬。其中铁城高一由旬。猛火辉赫烧其铁车炎赫炽然。中有铁牛其身亦然。头角毛尾皆如锋铓。毛中火然烟焰俱出。其铁马者身毛[髟/公/心]尾。銐如刀锋毛尾火然烟焰俱出。其铁驴者亦复如是。其地狱中有铁[金*疾][金*離]。銐如锋铓铁锵撩乱遍布其地。其锵火然猛炽于前

尔时北门之中有五百沙门。咩声号叫口眼火出。唱如是言。云何我今受如此苦。狱卒夜叉马头罗刹。手捉三钴铁。叉望背而撞胸前而出。复有铁索来缠其臂。其索火然烧罪人臂。复有铁枷枷罪人咽。其枷八方銐如锋铓。烟火猛炽烧罪人颈。尔时罪人宛转倒地而不肯前。马头罗刹手捉铁棒。望头而打。罪人身体碎如微尘。复有饿鬼来食其肉。复有饿狗来饮其血。马头罗刹蹴地言活罪人即活。尔时铁牛吼唤跑地。其牛吼唤来向罪人。罪人迫迮宛转倒地。马头罗刹手捉铁叉。叉着车上罪人跳踉。复堕牛上。牛毛仰刺从腹而入背上而出。牛复跳踉复堕马上。马毛仰刺亦如锋铓。马尾掉之身即碎烂。须臾还活。尔时铁马举脚连蹴身碎如尘。须臾还活复骑铁驴。驴即跳踉。罪人堕地驴便大嗔。举脚连踏须臾便死。须臾还活。一日一夜受罪无量

宝达问马头罗刹曰。此诸沙门云何如是。罗刹答曰此诸沙门。受佛禁戒不惜将来。但取现在违犯净戒。故作恶业畜不净物。乘车骑马走驴治生。心无慈善不护威仪受人信施。恶因缘故堕此地狱百千万劫。设得为人身不具足聋盲喑哑。不见三宝不闻正法。宝达闻之悲泣叹曰。云何沙门应出三界。云何恶业受如是罪。宝达即去

佛名经卷第二佛说佛名经卷第三

南无大海佛　南无大乐说佛　南无大药王佛　南无大功德佛　南无无量香佛　南无无量精进佛　南无无量行佛　南无无量功德佛　南无宝生佛　南无无边功德宝作佛　南无法作佛　南无金色作佛　南无胜作佛　南无自在作佛　南无日作佛　南无光作佛　南无火作佛　南无无畏作佛　南无乐作佛　南无灯作佛　南无贤作佛　南无觉作佛　南无华作佛　南无华胜藏佛　南无俱苏摩胜藏佛　南无忧波罗胜藏佛　南无波头摩胜藏佛　南无功德胜藏佛　南无快胜藏佛　南无福德胜藏佛　南无天胜藏佛　南无香胜藏佛　南无大香胜藏佛　南无大云藏佛　南无那罗延藏佛　南无如来藏佛　南无功德藏佛　南无根藏佛　南无如意藏佛　南无金刚藏佛　南无德藏佛　南无势罗藏佛　南无山藏佛　南无波头摩藏佛　南无俱苏摩藏佛　南无香藏佛　南无摩尼藏佛　南无贤藏佛　南无宝藏佛　南无月无垢藏佛　南无日藏佛　南无照藏佛　南无光明幢佛　南无月幢佛　南无功德幢佛　南无离世间幢佛　南无华幢佛　南无宝幢佛　南无法幢佛　南无自在幢佛　南无宝幢佛　南无无垢幢佛　南无大幢佛　南无月无垢幢佛　南无普照幢佛　南无弥留幢佛　南无护妙法幢佛　南无放光明幢佛　南无善清净无垢照幢佛　南无善清净光明幢佛　南无善清净光照幢佛　南无香光明佛　南无虚空光明佛　南无大光明佛　南无宝光明佛　南无火光明佛　南无日光明佛　南无月光明佛　南无日月光明佛　南无无垢光明佛　南无火轮光明佛　南无宝照明佛　南无宝光明佛　南无胜威德香光明佛　南无种种多威德王胜光明佛　南无虚空清净金色庄严威德光明佛　南无一切法幻奋迅威德光明佛　南无清净光明佛　南无功德宝光明佛　南无金光明光佛　南无高光明佛　南无放光光明佛　南无俱苏摩光明佛　南无香光明佛　南无甘露光明佛　南无无量宝化光明佛　南无水月光明佛　南无宝月光明佛　南无弥留光明佛　南无聚集日轮佛　南无云光明佛　南无槃头耆婆伽华佛　南无无畏光明佛　南无法力光明佛　南无无垢光明佛　南无清净光明佛　南无日光明佛　南无月光明佛　南无树提光明佛　南无然火光明佛　南无焚烧光明佛　南无罗网光明佛　南无大光明佛　南无称光明佛　南无普光明佛　南无无边光明佛　南无色光明声佛　南无虚空声佛　南无妙鼓声佛　南无师子声佛　南无云声佛　南无天声佛　南无妙声佛　南无梵声佛　南无云妙鼓声佛　南无法鼓声佛　南无法鼓出声佛　南无声满法界声佛　南无地吼声佛　南无普遍声佛　南无师子吼声佛　南无无量吼声佛　南无无分别吼声佛　南无惊怖一切魔轮声佛　南无降伏一切声佛　南无无障碍月慧佛　南无法无垢月佛　南无普照月佛　南无放光明月佛　南无卢舍那月佛　南无解脱月佛　南无称月佛　南无功德月佛　南无宝月佛　南无满月佛　南无大月佛　南无月轮清净佛　南无日月佛　南无月慧佛　南无无垢慧佛　南无深慧佛　南无戒慧佛　南无难胜慧佛　南无阿僧祇劫修习慧佛　南无无量乐功德庄严行慧佛　南无无量功德庄严佛　南无离劫佛　南无胜功德王庄严威德王劫佛　南无自在灭劫佛　南无弥留劫佛　南无须弥留劫佛　南无不可说劫佛　南无金光明色光上佛　南无龙寂上佛　南无爱上佛　南无度上佛　南无法上佛　南无金刚上佛　南无威德上佛　南无无垢上佛　南无龙寂上佛　南无宝上佛　南无胜宝上佛　南无莎梨罗上佛　南无天上佛　南无波头摩上佛　南无香上佛　南无放香佛　南无乐香佛　南无香奋迅佛　南无香象奋迅佛　南无香象佛　南无大香象佛　南无多罗跋香佛　南无戒香佛　南无无边香佛　南无普遍香佛　南无薰香佛　南无多伽罗香佛　南无栴檀香佛　南无蔓陀罗香佛　南无波头摩香佛　南无波头摩手佛　南无波头摩眼佛　南无波头摩庄严佛　南无波头摩起佛　南无身胜佛　南无惊怖胜佛　南无波头摩胜佛　南无月胜佛　南无鬘胜云佛　南无功德成就云佛　南无宝云佛　南无功德云佛　南无云护佛　南无普护佛　南无圣护佛　南无功德护佛　南无普遍护佛　南无精进护佛　南无精进喜佛　南无上喜佛　南无宝喜佛　南无师子喜佛　南无龙喜佛　南无宝喜佛　南无宝智佛　南无喜去佛　南无善知寂静法佛　南无大势佛　南无龙喜见佛　南无宝喜明佛　南无善知寂明王佛　南无大势力佛　南无甘露势佛　南无金刚杵势佛　南无无垢处势佛　南无不动处势佛　南无过三界处势佛　南无三昧处势佛　南无定处势佛　南无不动处势佛　南无高去佛　南无寂灭去佛　南无师子奋迅去佛　南无善步去佛　南无无尽慧佛　南无海慧佛　南无往慧佛　南无胜慧佛　南无灭诸恶慧佛　南无寂静慧佛　南无修行慧佛　南无密慧佛　南无坚慧佛　南无善清净慧佛　南无大慧佛　南无普慧佛　南无无边慧佛　南无威德慧佛　南无世慧佛　南无上慧佛　南无妙慧佛　南无快慧佛　南无无观慧佛　南无称慧佛　南无广慧佛　南无栴檀满慧佛　南无金刚慧佛　南无清净慧佛　南无觉慧佛　南无法慧佛　南无师子慧佛　南无虎慧佛　南无善慧佛　南无宝慧佛　南无胜慧佛　南无胜积慧佛　南无勇猛积佛　南无般若积佛　南无乐说积佛　南无香积佛　南无宝积佛　南无宝髻佛　南无功德髻佛　南无天髻佛　南无龙髻佛　南无大髻佛　南无弥留聚佛　南无大聚佛　南无大焰聚佛　南无宝聚佛　南无宝手佛　南无宝手柔濡佛　南无宝印手佛　南无宝光明奋迅思惟佛　南无宝火围绕佛　南无宝天佛　南无宝胜佛　南无宝高佛　南无宝坚佛　南无宝波头摩佛　南无宝念佛　南无宝力佛　南无宝山佛　南无宝炎佛　南无宝火围绕佛　南无宝照佛　南无放照佛　南无迭共华佛　南无妙说佛　南无月说佛　南无金刚说佛　南无宝说佛　南无宝杖佛　南无无量宝杖佛　南无无垢杖佛　南无无边杖佛　南无法杖佛　南无宝盖佛　南无均宝盖佛　南无摩尼盖佛　南无金盖佛　南无奋迅王佛　南无增上大成就王佛　南无增上勇猛佛　南无勇施佛　南无智施佛　南无然灯佛　南无然灯火佛　南无清净然灯佛　南无功德然灯佛　南无福德然灯佛　南无宝然灯佛　南无宝火然灯佛　南无无边然灯佛　南无大然灯佛　南无普然灯佛　南无日然灯佛　南无月燃灯佛　南无日月然灯佛　南无云声然灯佛　南无大海然灯佛　南无忍辱轮然灯佛　南无世然灯佛　南无光明遍照十方然灯佛　南无照诸恶趣然灯佛　南无破诸闇然灯佛　南无一切成就然灯佛　南无俱苏摩见佛　南无不散佛　南无散华佛　南无不散华佛　南无放光明佛　南无千光明佛　南无六十光佛　南无观光明佛　南无无障碍光明佛　南无放光明佛　南无无边光明佛　南无波头摩光明佛　南无福德光明佛　南无智光明佛　南无月光明佛　南无日光明佛　南无无碍光明佛　南无奋迅恭敬称佛　南无无比佛　南无功德称佛　南无宝称佛　南无无垢称佛　南无无垢德佛　南无坚德佛　南无无忧德佛　南无勇猛德佛　南无华德佛　南无欢喜德佛　南无龙德佛　南无功德海佛　南无净德佛　南无净天佛　南无供养佛　南无净声佛　南无净妙声佛　南无出净声佛　南无普智轮光声佛　南无大声佛　南无云胜声佛　南无安隐声佛　南无乐声佛　南无妙鼓声佛　南无天声佛　南无日声佛　南无月声佛　南无师子声佛　南无波头摩声佛　南无福德声佛　南无金刚声佛　南无自在声佛　南无慧声佛　南无妙声佛　南无选择声佛　南无甘露声佛　南无净幢佛　南无金刚幢佛　南无法幢佛　南无住持法佛　南无乐法佛　南无护法佛　南无昙无竭佛

次礼十二部尊经大藏法轮

南无不必定入定入印经　南无十二佛名神咒经　南无魔逆经　南无济诸方等学经　南无菩萨行五十缘身经　南无内藏百宝经　南无大方广惣持经　南无弥勒菩萨所问本愿经　南无文殊师利说般若波罗蜜经　南无牢固女经　南无演道俗业经　南无菩萨生地经　南无菩萨道树经　南无宝网经　南无百佛名经　南无无量义经　南无观弥勒上生兜率天经　南无无量寿观经　南无观普贤菩萨行法经　南无不空罥索经　南无观药王药上二菩萨经　南无请观世音消伏毒害陀罗尼经　南无十一面观世音经　南无观世音菩萨受记经　南无鹿母经　南无鹿子经　南无除恐灾患经　南无温室洗浴众僧经　南无四不可得经　南无诸德福田经　南无出家功德经　南无大方广十轮经　南无大方便报恩经　南无七佛神咒经　南无大方广如来性起佛　南无菩萨本行经　南无不思议功德经　南无大吉义咒佛　南无菩萨梦经　南无文殊问佛　南无仁王般若经　南无法界体性无分别经　南无密迹力士经　南无虚空藏菩萨问持几福经　南无大方广如来秘密藏经　南无善解菩萨所问经　南无菩萨修行经　南无菩萨投身饲饿虎起塔因缘经　南无一切施王所行檀波罗蜜经　南无频婆娑罗王诣佛供养经

敬礼十方诸大菩萨摩诃萨

南无无垢菩萨　南无勇猛德菩萨　南无净心菩萨　南无宝胜菩萨　南无罗网光菩萨　南无断诸盖菩萨　南无能舍一切事菩萨　南无华庄严菩萨　南无月光明菩萨　南无最胜意菩萨　南无坚意菩萨　南无自在天菩萨　南无胜意菩萨　南无净意菩萨　南无金刚意菩萨　南无增长意菩萨　南无善住菩萨　南无善导师菩萨　南无波头摩藏菩萨　南无陀罗尼自在王菩萨　南无普行菩萨　南无觉菩提菩萨　南无坚胜菩萨　南无断诸恶道菩萨　南无不疲倦意菩萨　南无须弥山菩萨　南无大须弥山菩萨　南无心勇猛菩萨　南无师子奋迅行菩萨　南无不可思议菩萨　南无善胜菩萨　南无善意菩萨　南无实语菩萨　南无爱见菩萨　南无无障碍菩萨　南无断诸疑菩萨　南无实作菩萨　南无广德菩萨　南无护贤劫菩萨　南无宝月菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无直福德辟支佛　南无识辟支佛　南无香辟支佛　南无有香辟支佛　南无见人飞腾辟支佛　南无可波罗辟支佛　南无秦摩利辟支佛　南无月净辟支佛　南无善智辟支佛　南无修陀罗辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

众等相与即今身心寂静。无谄无障正是生善灭恶之时。复应各起四种观行以为灭罪作前方便。何等为四。一者观于因缘。二者观于果报。三者观我自身。四者观如来身

第一观因缘者。知我此罪籍以无明不善思惟无正观力。不识其过远离善友诸佛菩萨。随逐魔道行邪崄径。如鱼吞钩不知其患。如蚕作茧自萦自缚。如蛾赴火自烧自烂。以是因缘不能自出

第二观于果报者。所有诸恶不善之业。三世流转苦果无穷。沉溺无边巨夜大海。为诸烦恼罗刹所食。未来生死冥然无涯。设使报得转轮圣王。王四天下飞行自在七宝具足。命终之后不免死堕恶趣。四空果报三界尊极。福尽还作牛头中虫。况复其余无福德者。而复懈怠不勤忏悔。此亦譬如抱石沉渊求出良难

第三观我自身。虽有正因灵觉之性。而为烦恼黑暗丛林之所覆蔽。无了因力不能得显。我今应当发起胜心。破裂无明颠倒重障。断灭生死虚伪苦因。显发如来大明觉慧。建立无上涅槃妙果

第四观如来身。无为寂照离四句绝百非。众德具足湛然常住。虽复方便入于灭度。慈悲救接未曾暂舍。生如是心。可谓灭罪之良津除障之要行。是故弟子。今日至心稽首归命于佛

南无东方胜藏珠光佛　南无南方宝积示现佛　南无西方法界智灯佛　南无北方最胜降伏佛　南无东南方龙自在王佛　南无西南方转一切生死佛　南无西北方无边智自在王佛　南无东北方无边功德月佛　南无下方海智神通佛　南无上方一切胜王佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。长养烦恼日深日厚日滋日茂。覆盖慧眼令无所见。断除众善不得相续起障。不得见佛不闻正法不值圣僧烦恼起障。不见过去未来一切世中善恶业行之烦恼障。受人天尊贵果报之烦恼障。生色无色界禅定福乐之烦恼障。不得自在神通飞腾隐显遍至十方诸佛净土听法之烦恼障。学安那般那数息不净观诸烦恼障。学慈悲喜舍因缘烦恼障。学七方便三观义烦恼障。学四念处暖顶忍烦恼障。学闻思修第一法烦恼障。学空平等中道解烦恼障。学八正道示相之烦恼障。学七觉支不示相烦恼障。学于道品因缘观烦恼障。学八解脱九空之烦恼障。学于十智三昧烦恼障。学三明六通四无碍烦恼障。学六度四等烦恼障。学四摄法广化之烦恼障。学大乘心四弘誓愿烦恼障。学十明十行之烦恼障。学十回向十愿之烦恼障。初地二地三地四地明解之烦恼障。五地六地七地诸知见烦恼障。学八地九地十地双照之烦恼障。如是乃至障学佛果百万阿僧祇诸行上烦恼障。如是行障无量无边。弟子今日。至到稽恳向十方佛尊法圣众。惭愧忏悔愿皆消灭

愿籍此忏悔。障于诸行一切烦恼障永尽无余。愿弟子。在在处处自在受生不为结业之所回转。以如意通于一念项遍至十方净诸佛土。摄化众生于诸禅定甚深境界及诸知见。通达无碍。心能普周一切诸法。乐说无穷而不染着。得心自在得法自在。智慧自在方便自在。令此烦恼及无知结习。毕竟永断不复相续。无漏圣道朗然如日

    大乘莲华宝达问答报应沙门经

尔时宝达菩萨更入地狱。名为铁衣地狱。其地狱纵广方圆十六由旬。其地狱中有铁[金*疾][金*離]。銐如锋铓遍布其地。烟焰烔然铁衣火然。火烧炎赫游行狱中。东门之中有八百沙门。仰头呼天椎胸大叫。唱如是言。我今何罪来入此中。宛转倒地不能复前。马头罗刹手捉三股铁叉。望背而撞胸前而出。遍身火然。马头罗刹手捉铁钩。望骸而鎝。铁钩若着。火焰俱起罪人宛转。而不肯来。马头罗刹手捉铁捧望头而锤。复有铁狗来食其肉。复有饿鬼来饮其血。其地狱中铁衣撩乱来着罪人。或有着头或有着脚遍身火然。一日一夜受罪无量。宝达问马头罗刹曰。比诸罪人沙门。云何受如是罪。马头罗刹答曰。此诸沙门罪人。受佛净戒不护威仪。舍正法服便着俗衣不如法衣。违佛净禁恶因缘故堕此地狱。宝达闻之悲泣而言

  云何沙门子　　名出三界人
  云何不自慎　　堕此恶道中
  云何不自慎　　受此大苦痛
  云何得安隐　　名为解脱人

宝达说偈而去

佛名经卷第三佛说佛名经卷第四

南无法奋迅佛　南无法界华佛　南无护法眼佛　南无然法庭燎佛　南无法自在佛　南无人自在佛　南无功德自在佛　南无声自在佛　南无世自在佛　南无观世自在佛　南无无量自在佛　南无意住持佛　南无地住持佛　南无尼弥住持佛　南无器住持佛　南无功德性住持佛　南无胜色佛　南无转发起佛　南无一切观形示佛　南无发一切无厌足行佛　南无发成就佛　南无善护佛　南无善思惟佛　南无善喜佛　南无善处佛　南无普禅佛　南无甘露功德佛　南无善眼佛　南无师子仙佛　南无佛眼佛　南无合聚佛　南无疾智勇佛　南无善住佛　南无实行佛　南无师子手佛　南无海满佛　南无善思惟佛　南无称王佛　南无住慈佛　南无善夜摩佛　南无善行佛　南无善功德佛　南无善色佛　南无善识佛　南无善心佛　南无善光佛　南无师子月佛　南无不可胜佛　南无不可胜无畏佛　南无无量佛　南无速与乐佛　南无不动心佛　南无应称佛　南无应不怯弱声佛　南无不厌足藏佛　南无不尽佛　南无不可动佛　南无名无畏佛　南无名自在护世间佛　南无名龙自在声佛　南无名法行广慧佛　南无名妙胜自在相通称佛　南无名妙胜自在胜佛　南无名乐法奋迅佛　南无名法界庄严佛　南无名大乘庄严佛　南无名寂静王佛　南无名解脱行佛　南无名大海弥留起王佛　南无名合聚那罗延王佛　南无名散坏坚魔轮佛　南无名精进根宝王佛　南无名佛法波头摩佛　南无名得佛眼分陀利佛　南无名随前觉觉佛　南无名平等作佛　南无名初发心念远离一切惊怖无烦恼起功德佛　南无名金刚釜奋迅佛　南无名宝像光明釜奋迅佛　南无名破坏魔轮佛　南无名初发心成就不退轮佛　南无宝盖起无畏光明佛　南无名教化菩萨佛　南无名宝盖起无畏光明佛　南无名初发心念断疑断烦恼佛　南无名光明破闇起三昧王佛

是诸佛如来名十方世界众生无眼者诵必得眼

南无十千同名星宿佛　南无一切同名星宿佛　南无三十千同名释迦牟尼佛　南无一切同名释迦牟尼佛　南无二亿同名拘邻佛　南无一切同名拘邻佛　南无十八亿同名实法胜决定佛　南无一切同名实法胜决定佛　南无十八亿同名日月灯佛　南无一切同名日月灯佛　南无千亿同名大威德佛　南无一切同名大威德佛　南无千五百同名日佛　南无一切同名日佛　南无四万四千同名面佛　南无一切同名面佛　南无万千同名坚固自在佛　南无一切同名坚固自在佛　南无万八千同名普护佛　南无一切同名普护佛　南无千八百同名舍摩他佛　南无一切同名舍摩他佛

劫名善眼。彼劫中有七十二那由他如来成佛。我悉归命彼诸如来

劫名善见。彼劫中有七十二亿如来成佛。我悉归命彼诸如来

劫名净赞叹。彼劫中有一万八千如来成佛。我悉归命彼诸如来

劫名善行。彼劫中有三万二千如来成佛。我悉归命彼诸如来

劫名庄严。彼劫中有八万四千如来成佛。我悉归命彼诸如来

南无现在住十方世界。不舍命说法诸佛。所谓安乐世界中阿弥陀如来为上首

可乐世界中阿閦如来为上首

袈裟幢世界中碎金刚坚如来为上首

不退轮吼世界中清净光波头摩华身如来为上首

无垢世界中法幢如来为上首

善灯世界中师子如来为上首

善住世界中卢舍那藏如来为上首

难过世界中功德华身如来为上首

庄严慧世界中一切通光明如来为上首

镜轮光明世界中月智慧如来为上首

华胜世界中波头摩胜如来为上首

波头摩胜世界中坚胜如来为上首

不瞬世界中普坚如来为上首

普坚世界中自在如来为上首

不可胜世界中成就一切义如来为上首

娑婆世界中释迦牟尼如来为上首

善说胜如来为上首

自在幢王如来为上首

作火光如来为上首

无畏观如来为上首

如是等上首诸佛。我以身业口业意业遍满十方。一时礼拜赞叹供养。所谓彼佛所说法甚深境界。不可量境界。不可思议境界。无量境界等。我悉以身业口业意业遍满十方。礼拜赞叹供养。所谓彼佛世界中。不退菩萨僧不退声闻僧。我悉以身业口业意业遍满十方。头面礼足赞叹供养

南无名降伏魔人自在佛　南无名降伏贪自在佛　南无名降伏嗔自在佛　南无名降伏痴自在佛　南无名降伏怒自在佛　南无名降伏见自在佛　南无名降伏诸戏自在佛　南无名了达法自在佛　南无名得神通自在称佛　南无名得胜业自在称佛　南无名起施自在称佛　南无名起清净戒自在称佛　南无名起忍辱人自在称佛　南无名起精进自在称佛　南无名起禅人自在称佛　南无起福德清净光明自在称佛　南无名起陀罗尼自在称佛　南无高胜如来　南无光明胜如来　南无大胜如来　南无散香上胜如来　南无多宝胜如来　南无月上胜如来　南无贤上胜如来　南无波头摩上胜如来　南无无量上胜如来　南无波头摩上胜王如来　南无三昧手上胜如来　南无大海深胜如来　南无善说名胜如来　南无阿僧祇精进住胜如来　南无乐说一切法庄严胜如来　南无宝轮威德上胜如来　南无日轮上光明胜如来　南无无量惭愧金色上胜如来　南无功德海琉璃金色光明胜如来　南无宝华普照胜如来　南无起无边功德无垢胜如来　南无起多罗王胜如来　南无树王吼胜如来　南无法海潮胜如来　南无智清净功德胜如来　南无乐劫火胜如来　南无不可思议光明胜如来　南无宝月光明胜如来　南无宝贤幢胜如来　南无宝成就胜如来　南无宝集胜如来　南无成就义胜如来　南无奋迅胜如来　南无不空胜如来　南无闻胜如来　南无海胜如来　南无住持胜如来　南无善行胜如来　南无龙胜如来　南无波头摩胜如来　南无福德胜如来　南无智胜如来　南无妙胜如来　南无贤胜如来　南无胜贤胜如来　南无旃檀胜如来　南无胜旃檀胜如来　南无无量光明胜如来　南无幢胜如来　南无胜幢胜如来　南无帝宝幢摩尼胜如来　南无无忧胜如来　南无优钵罗华胜如来　南无离一切忧胜如来　南无宝杖如来　南无善宝杖如来　南无拘苏摩胜如来　南无华胜如来　南无三昧奋迅胜如来　南无树提胜如来　南无火胜如来　南无广功德胜如来　南无众胜如来

南无普光世界普华无畏王如来

南无清净光世界积清净增长胜上王如来

南无普盖世界名均宝庄严如来。彼如来授罗网光菩萨阿耨多罗三藐三菩提记

南无一宝盖世界名无量宝境界如来。彼如来授不空奋迅境界菩萨阿耨多罗三藐三菩提记

南无相威德王世界名无量声如来。彼如来授名即发心转法轮菩萨阿耨多罗三藐三菩提记

南无名称世界名须弥留聚集如来。彼如来授名光明轮胜威德菩萨阿耨多罗三藐三菩提记

南无善住世界名虚空寂如来。彼如来授名月光菩萨阿耨多罗三藐三菩提记

南无地轮世界名称力王如来。彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无月起光世界名放光明如来。彼如来授名光明轮菩萨阿耨多罗三藐三菩提记

南无袈裟幢世界名离袈裟如来。彼如来授名无量宝发起菩萨阿耨多罗三藐三菩提记

南无波头摩华世界名种种华胜成就如来。彼如来授名无量精进菩萨阿耨多罗三藐三菩提记

南无一盖世界名远离诸怖毛竖如来。彼如来授名罗网光明菩萨阿耨多罗三藐三菩提记

南无种种幢世界名须弥留聚如来。彼如来授名大胜菩萨阿耨多罗三藐三菩提记

南无普光世界名无障碍眼如来。彼如来授名智胜菩萨阿耨多罗三藐三菩提记

南无贤世界名旃檀屋如来。彼如来授名智功德幢菩萨阿耨多罗三藐三菩提记

南无贤慧世界名合聚如来。彼如来授名妙智菩萨阿耨多罗三藐三菩提记

南无宝首世界名罗网光明如来。彼如来授名智功德菩萨阿耨多罗三藐三菩提记

南无安乐首世界名宝莲华胜如来。彼如来授名波头摩胜功德菩萨阿耨多罗三藐三菩提记

南无称世界名智华宝光明胜如来。彼如来授名第一庄严菩萨阿耨多罗三藐三菩提记

南无贤臂世界名起贤光明如来。彼如来授名宝光明菩萨阿耨多罗三藐三菩提记

南无无畏世界名灭散一切怖畏如来。彼如来授名无畏菩萨阿耨多罗三藐三菩提记

南无弥留幢世界名弥留序如来。彼如来授名合聚菩萨阿耨多罗三藐三菩提记

南无远离一切忧恼障碍世界名无畏王如来。彼如来授名多声菩萨阿耨多罗三藐三菩提记

南无法世界名作法如来。彼如来授名智作菩萨阿耨多罗三藐三菩提记

南无善住世界名百一十光明如来。彼如来授名胜光明菩萨阿耨多罗三藐三菩提记

南无共光明世界名千上光明如来。彼如来授名普光明菩萨阿耨多罗三藐三菩提记

南无多伽罗世界名智光明如来。彼如来授名善眼菩萨阿耨多罗三藐三菩提记

南无香世界名宝胜光明如来。彼如来授名无量光明菩萨阿耨多罗三藐三菩提记

南无光明首世界名无量光明如来。彼如来授名药王菩萨阿耨多罗三藐三菩提记

南无上首贤世界无障碍声如来。彼如来授名净声菩萨阿耨多罗三藐三菩提记

南无法世界名罗网光如来。彼如来授名胜菩萨阿耨多罗三藐三菩提记

南无贤入世界名宝智慧如来。彼如来授名智香菩萨阿耨多罗三藐三菩提记

南无忧钵罗世界名无量胜如来。彼如来授名昙无竭菩萨阿耨多罗三藐三菩提记

南无清净世界名无量庄严如来。彼如来授名宝庄严菩萨阿耨多罗三藐三菩提记

南无觉住世界名忧钵罗胜如来。彼如来授名波头摩胜菩萨阿耨多罗三藐三菩提记

南无波头摩作世界名智住如来。彼如来授名宝满足菩萨阿耨多罗三藐三菩提记

南无智力世界名释迦牟尼如来。彼如来授名宝牟尼菩萨阿耨多罗三藐三菩提记

南无十方称世界名智称如来。彼如来授名无边精进菩萨阿耨多罗三藐三菩提记

南无喜世界名坚自在王如来。彼如来授名宝坚菩萨阿耨多罗三藐三菩提记

南无月世界名宝莎罗如来。彼如来授名普香菩萨阿耨多罗三藐三菩提记

南无娑婆世界名大胜如来。彼如来授名大胜天王菩萨阿耨多罗三藐三菩提记

南无一盖世界名宝轮如来。彼如来授名星宿鬘菩萨阿耨多罗三藐三菩提记

南无过一切忧障碍世界名不空说如来。彼如来授名不空说菩萨阿耨多罗三藐三菩提记

南无远离忧恼世界名功德成就如来。彼如来授名无边胜威德菩萨阿耨多罗三藐三菩提记

南无寂静世界名称王如来。彼如来授名勇德菩萨阿耨多罗三藐三菩提记

南无不空见世界名不空奋迅如来。彼如来授名不空发行菩萨阿耨多罗三藐三菩提记

南无香世界名香光明如来。彼如来授名宝藏菩萨阿耨多罗三藐三菩提记

南无无量吼声世界名无障碍声如来。彼如来授名无分别发行菩萨阿耨多罗三藐三菩提记

南无月轮光明世界名称力王如来。彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无宝轮世界名宝上胜如来。彼如来授名大导师菩萨阿耨多罗三藐三菩提记

南无宝轮世界名善眼如来。彼如来授名乐行菩萨阿耨多罗三藐三菩提记

南无法世界名波头摩胜如来。彼如来授名大法菩萨阿耨多罗三藐三菩提记

南无名须弥世界名须弥顶上王如来。彼如来授名智力菩萨阿耨多罗三藐三菩提记

南无莲花世界名波头摩胜如来。彼如来授名胜德菩萨阿耨多罗三藐三菩提记

南无陀罗尼轮世界名香光明如来。彼如来授名陀罗尼自在王菩萨阿耨多罗三藐三菩提记

南无金光明世界名十方称发如来。彼如来授名智称发行菩萨阿耨多罗三藐三菩提记

南无智起世界名普清净增上云声王如来。彼如来授名星宿王菩萨阿耨多罗三藐三菩提记

南无常光明世界名无量光明如来。彼如来授名大光明菩萨阿耨多罗三藐三菩提记

南无然灯世界名无量智成如来。彼如来授名功德王光明菩萨阿耨多罗三藐三菩提记

南无然灯作世界名无量奋迅如来。彼如来授名无障碍发菩萨阿耨多罗三藐三菩提记

南无种种幢世界名上首如来。彼如来授名那罗延菩萨阿耨多罗三藐三菩提记

南无十方称世界名佛华成就胜如来。彼如来授名无缺奋迅菩萨阿耨多罗三藐三菩提记

南无金刚住世界名佛华增上王如来。彼如来授名宝火菩萨阿耨多罗三藐三菩提记

南无旃檀窟世界名宝形如来。彼如来授名观世音菩萨阿耨多罗三藐三菩提记

南无药王世界名不空说如来。彼如来授名不空发行菩萨阿耨多罗三藐三菩提记

南无药王胜上世界名无边功德精进发如来。彼如来名不受戒摄受菩萨阿耨多罗三藐三菩提记

南无普庄严世界名发心生庄严一切众生心如来。彼如来授名佛华手菩萨阿耨多罗三藐三菩提记

南无普盖世界名盖鬘如来。彼如来授名宝行菩萨阿耨多罗三藐三菩提记

南无华上光明世界名日轮威德王如来。彼如来授名善住菩萨阿耨多罗三藐三菩提记

南无善庄严世界名众生光明如来。彼如来授名宝面菩萨阿耨多罗三藐三菩提记

南无贤世界名无畏如来。彼如来授名不惊怖菩萨阿耨多罗三藐三菩提记

南无波头摩世界名波头摩胜光明如来。彼如来授名智象菩萨阿耨多罗三藐三菩提记

南无忧钵罗世界名智忧钵胜如来。彼如来授名无境界行菩萨阿耨多罗三藐三菩提记

南无宝上世界名宝作如来。彼如来授名法作菩萨阿耨多罗三藐三菩提记

南无月世界名无量愿如来。彼如来授名散华菩萨阿耨多罗三藐三菩提记

南无善住世界名宝聚如来。彼如来授名药王菩萨阿耨多罗三藐三菩提记

南无香光明世界名莎罗自在王如来。彼如来授名胜慧菩萨阿耨多罗三藐三菩提记

南无华首世界名宝光明如来。彼如来授名日德菩萨阿耨多罗三藐三菩提记

南无普山世界名宝山如来。彼如来授名火德菩萨阿耨多罗三藐三菩提记

南无忧盖入世界名上首如来。彼如来授名上庄严菩萨阿耨多罗三藐三菩提记

南无无忧世界名发无边功德如来。彼如来授名不发观菩萨阿耨多罗三藐三菩提记。

南无一切功德住世界名善上首如来。彼如来授名普至菩萨阿耨多罗三藐三菩提记

南无宝光明世界名须弥光明如来。彼如来授名善住菩萨阿耨多罗三藐三菩提记

南无一切功德住世界名无量境界如来。彼如来授名药上菩萨阿耨多罗三藐三菩提记

南无庄严菩提世界名高妙去如来。彼如来授名思益胜慧菩萨阿耨多罗三藐三菩提记

南无无垢世界名宝华成就功德如来。彼如来授名得胜慧菩萨阿耨多罗三藐三菩提记

南无云世界名奋迅如来。彼如来授名自在观菩萨阿耨多罗三藐三菩提记

南无华网覆世界名一切发众生信发心如来。彼如来授名胜慧菩萨阿耨多罗三藐三菩提记

南无星宿行世界名乐星宿起如来。彼如来授名无忧菩萨阿耨多罗三藐三菩提记

南无宝华世界名胜众如来。彼如来授名妙胜菩萨阿耨多罗三藐三菩提记

南无无量至世界名无量华如来。彼如来授名香象菩萨阿耨多罗三藐三菩提记

南无华世界名宝胜如来。彼如来授名远离诸有菩萨阿耨多罗三藐三菩提记

南无种种幢世界名月胜功德如来。彼如来授名断一切诸难菩萨阿耨多罗三藐三菩提记

南无可乐世界名则发心转法轮如来。彼如来授名不退转轮菩萨阿耨多罗三藐三菩提记

南无无畏世界名十方称名如来彼如来授名智称菩萨阿耨多罗三藐三菩提记

南无自在世界名迦陵伽如来　南无安乐世界日轮灯明如来　南无无畏世界宝胜如来　南无智成就世界智起如来　南无纯乐世界功德王如来　南无盖行华世界无障碍眼如来　南无金刚轮世界无畏如来　南无发起世界智积如来　南无善清净世界无观相发行如来　南无普光明世界光明轮成德胜王如来　南无高幢世界因慧如来　南无德世界那罗延如来　南无无垢世界无垢幢如来　南无远离一切忧障世界安隐如来　南无贤上世界远离诸烦恼如来　南无一切安乐世界清净慧如来　南无无量功德具足世界善思惟发如来　南无平等世界降伏诸怨如来　南无无畏世界忧波罗胜如来　南无十方光明世界胜力王如来　南无常光明世界无量光明云香弥留如来　南无常庄严世界降伏男女如来　南无沉水香世界上胜香如来　南无常庄严世界种种华如来　南无香盖世界无边智如来　南无旃檀香世界宝上王如来　南无香世界香弥留如来　南无普喜世界智见一切众生信如来　南无不可量世界无边声如来　南无佛华庄严世界智功德胜如来　南无善住世界不动步如来

归命如是等无量无边如来应知

南无华世界无障碍吼声如来　南无月世界普宝藏如来　南无坚住世界迦叶如来　南无普波头摩世界观一切境界镜如来　南无旃檀世界上首如来　南无宝世界成就义如来　南无有月世界成就胜如来　南无无障碍世界名称如来　南无安乐世界断一切疑如来

归命如是等无量无边如来应知

南无无王世界智胜如来　南无种种成就世界功德微如来　南无种种华世界星宿王如来　南无广世界无量幢如来　南无普畏世界月如来　南无罗网世界罗网光明如来　南无无惊怖世界净声如来　南无可乐世界现实胜如来　南无离观世界一切法无所发如来　南无常称世界不断一切众生发行如来

归命如是等无量无边如来应知

南无常欢喜世界无量奋迅如来　南无普镜世界建一切法如来　南无普照世界普见一切法如来　南无一切功德成就世界成就无边胜功德如来　南无无垢世界智起光如来　南无无怖忧钵罗世界波头摩胜如来　南无波头摩怖世界十方胜如来　南无华怖世界华成就胜如来　南无天世界坚固众生如来　南无光明世界智光明如来

归命如是等无量无边如来应知

南无安乐调世界修智如来　南无安乐世界远离胎如来　南无无染世界明王如来　南无云世界断一切烦恼如来　南无普色世界无边智称如来　南无坚固世界栴檀屋胜如来　南无无比功德世界成就无比胜王如来　南无宝世界善住力王如来　南无十方上首世界起月光如来　南无龙王世界上首如来

归命如是等无量无边如来应知

南无善住世界善高聚如来　南无无怖畏世界作称亲如来　南无爱香世界断诸难如来　南无成就一切功德善住世界称亲如来　南无成就一切势力善住世界称坚固如来　南无无忧慧世界远离诸忧如来　南无称世界起波头摩功德王如来　南无华俱苏摩住世界善散华幢如来　南无十方名称世界放光明普至如来　南无十方上首世界名称眼如来

归命如是等无量无边如来应知

南无炎慧世界放炎如来　南无吼世界十方称名如来　南无光明世界自在弥留如来　南无宝光明世界宝光明如来　南无常欢喜世界炎炽如来　南无有世界三界自在奋迅如来　南无无畏世界放光明轮如来　南无常悬世界众寂胜如来　南无波头摩王世界无尽胜如来　南无普吼世界妙鼓声如来

归命如是等无量无边如来应知

次礼十二部尊经大藏法轮

南无萨罗国经　南无大意经　南无天王太子辟罗经　南无长者意悦经　南无长者法志妻经　南无一切光明仙人慈心因缘不食肉经　南无文殊师利般涅槃经　南无师子月佛本生经　南无阿弥陀鼓音声陀罗尼经　南无法华三昧经　南无金刚三昧本性清净不坏不灭经　南无宝积三昧文殊师利问法身经　南无千佛因缘经　南无八部佛名经　南无八吉祥神咒经　南无八阳经　南无十吉祥经　南无贤首经　南无甚深大回向经　南无贤者五福德经　南无幼士仁贤经　南无佛藏经　南无菩萨藏经　南无决定毗尼经　南无宝梁经　南无梵网经　南无文殊师利悔过经　南无舍利弗悔过经　南无优婆塞戒经　南无大方广三戒经　南无法律三昧经　南无菩萨内戒经　南无三曼陀颰陀罗菩萨经　南无菩萨受齐经　南无净业障经　南无大乘三聚忏悔经　南无大智度论　南无般若灯论　南无十地论　南无大乘庄严论　南无十住毗婆娑论　南无菩提资粮论　南无大涅槃经论　南无大涅槃经本有今无偈论　南无弥勒菩萨所问经论　南无宝积经论　南无金刚般若经论　南无胜思惟经论　南无三具足经论　南无法华经论

敬礼十方诸大菩萨摩诃萨

南无漫陀婆香菩萨　南无乐作菩萨　南无无垢称菩萨　南无思益菩萨　南无普华菩萨　南无月胜菩萨　南无月山菩萨　南无智山菩萨　南无胜山菩萨　南无光山菩萨　南无贤首菩萨　南无功德山菩萨　南无胜护菩萨　南无那罗延菩萨　南无龙德菩萨　南无龙胜菩萨　南无住持色菩萨　南无摩留天菩萨　南无入功德菩萨　南无然灯首菩萨　南无常举手菩萨　南无光明常照手菩萨　南无宝手菩萨　南无普光菩萨　南无星宿王菩萨　南无金刚步菩萨　南无不动华步菩萨　南无步三界菩萨　南无无边步奋迅菩萨　南无海慧菩萨　南无善光无垢住持威德菩萨　南无高精进菩萨　南无智山菩萨　南无常观菩萨　南无不瞬菩萨　南无无言菩萨　南无宝胜菩萨　南无宝心菩萨　南无善思议菩萨　南无摩尼髻菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无善法辟支佛　南无应求辟支佛　南无髻求辟支佛　南无大势辟支佛　南无修行不着辟支佛　南无难舍辟支佛　南无实辟支佛　南无不可比辟支佛　南无欢喜辟支佛　南无喜辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等略忏烦恼障竟。今当次弟忏悔业障。夫业能庄饰世趣在在处处。是以思惟求离世解脱。所以六道果报种种不同形类各异。当知皆是业力所作。所以佛十力中业力甚深。凡夫之人多于此中好起疑惑。何以故尔。现见世间行善之者是事輱轲。为恶之者触向谐偶。谓言天下善恶无分。如此计者皆是不能深达业理。何以故尔。经中说言有三种业。何等为三。一者现报二者生报三者后报。现报业者。现在作善作恶现身受报。生报业者。此生作善作恶来生受报。后报业者。或是过去无量生中作善作恶。或于此生中受。或现在未来无量生中方受其报。向者行恶之人现在见好。此是过去生报后报善业熟故。所以现在有此乐果。岂关现在作诸恶业而得好报。行善之人现在见苦者。是过去生中生报后报恶业熟故。现在善根力弱不能排遣。是故得此苦报。岂关现在作善而招恶报。何以知然。现见世间为善之者。为人所赞叹人所尊重。故知未来必招乐果。过去既有如此恶业。所以诸佛菩萨教令亲近善友共行忏悔。善知识者于得道中则为全利。是故弟子等今日至诚归依于佛

南无东方无量离垢佛　南无南方树根花王佛　南无西方莲华自在佛　南无北方金刚能破佛　南无东南方悉檀义胜佛　南无西南方金海自在王佛　南无西北方无边法自在王佛　南无东北方无碍香象王佛　南无下方无碍慧幢佛　南无上方甘露上王佛

归命如是等十方尽虚空界一切三宝

弟子等从无始已来至于今日。积恶如恒沙。造罪满天地。舍身与受身。不觉亦不知。或作五逆深厚浊缠无间罪业。或造一阐提断善根业。轻诬佛语谤方等业。破灭三宝毁正法业。不信罪福起十恶业。迷真返正痴惑之业。不孝二亲反戾之业。轻慢师长无礼敬业。朋友无信犯不义之业。或作四重六重八重障圣道业。毁犯五戒破八齐业。五篇七聚多缺犯业。优婆塞戒轻重垢业。或菩萨戒不能清净如说行业。前后方便污梵行业。月无六齐懈怠之业。年三长齐不常修业。三千威仪不如法业。八万律仪微细罪业。不修身戒心慧之业。春秋八王造众罪业。行十六种恶律仪业。于苦众生无愍伤业。不矜不念无怜愍业。不拔不济无救护业。心怀嫉忌无度彼业。于怨亲境不平等业。耽荒五欲不厌离业。或因衣食园林池沼生荡逸业。或以盛年放恣情欲造众罪业。或善有漏回向三有障出世业。如是等业无量无边。今日发露向十方佛尊法圣众。归命忏悔。愿弟子等。承是忏悔无间等罪所生福善。愿生生世世灭五逆罪除阐提惑。如是轻重诸罪从今以去乃至道场誓不更犯。恒习出世清净善法。精持律行守护威仪。如渡海者爱惜浮囊。六度四等常檦行首。戒定慧品转得增明。速成如来三十二相八十种好。十力无畏大悲三念。常乐妙智八自在我

    大乘莲华宝达问答报应沙门经

宝达复入铁铢洋铜灌口地狱。云何名曰洋铜灌口地狱。其地狱纵广二十四由旬。周匝铁城铁网罗覆。火焰洞然烟火俱炽间无休息。[金*疾][金*離]铁锵遍布其地。其地火然上至罗网。上彻于下下彻于上。烟火炎炽烧煮罪人。其地狱中有大铁池流出火铢烟焰炎炽铁铢灌注。犹如流水灌罪人口

尔时南门之中有五十沙门。口眼火出唱如是言。我今云何受如是苦。宛转于地而不肯起。马头罗刹手捉三股铁叉。蹴地而撞。其叉股中火焰俱出烧罪人心。须臾而死须臾便活。复有铁钩来钩其舌。复有铁棒来椎其头。复有飞刀来剥其肉。马头罗刹将诸沙门来入流火河中。马头罗刹手捉铁箕。钞铁火珠望口而灌。铁铢入口背上而出。口眼六处烟焰俱然。铁铢连续间无休息

宝达问马头罗刹言。此罪人沙门作何等罪受如是苦。罗刹答曰。此诸沙门不持佛戒不畏苦报。贪求利养名闻心不惭愧。犯四重禁而言持清净行。曾受人信施贪求饮食。白衣施重甚为难消而言我消。不知三宝四谛因缘。亦如大海不知满足。以是因缘堕地狱苦经千万劫。出生为人喑哑不语。宝达菩萨闻之悲泣。而说是言

  云何解脱人　　今受如是苦
  云何以渡海　　还没大海中
  云何大富贵　　还复贫穷困
  云何受净戒　　而犯无所畏
  还堕耶见道

宝达菩萨说偈而去

佛名经卷第四佛说佛名经卷第五

南无无畏世界普胜如来　南无十方名称世界智称如来　南无地世界山王如来　南无地功德世界波头摩轮境界胜王如来　南无然灯轮世界善住如来　南无普庄严世界大庄严佛境界如来　南无倚世界作一切功德如来　南无欢喜世界毕竟成就佛宝功德如来　南无星宿行世界智上胜如来　南无盖行庄严世界智起光明威德王胜如来　南无波头摩世界波头摩生王如来

归命如是等无量无边诸佛应知

南无法境界自在佛(胡本云自下皆有世界略不明应知)　南无月中光明佛　南无香象佛　南无阿弥陀光明佛　南无波头摩山佛　南无波头摩生胜佛　南无旃檀胜佛　南无宝积佛　南无智慧佛

归命如是等无量无边诸佛应知

南无无畏作王佛　南无功德成就胜佛　南无光明幢佛　南无无量功德作佛　南无功德成就胜佛　南无一切功德成就胜佛　南无波头摩成就胜佛　南无炬住持佛　南无宝上胜佛　南无金色华佛

归命如是等无量无边诸佛应知

南无上王佛　南无星宿王佛　南无无量弥留佛　南无虚空轮清净王佛　南无无量声佛　南无宝山佛　南无种种宝俱苏摩花佛　南无胜众佛　南无无尘离尘放发佛

归命如是等无量无边诸佛应知

南无不宿发修行佛　南无金色华佛　南无宝舍佛　南无种种华成就佛　南无放光明佛　南无俱苏摩成就佛　南无放盖佛　南无称力王佛　南无净声佛　南无净胜佛

归命如是等无量无边诸佛应知

南无无量众佛　南无上首佛　南无无障碍眼佛　南无破散一切诸趣佛　南无断一切疑佛　南无无相声佛　南无毕竟得无边功德佛　南无宝成就胜佛　南无波头摩上胜佛　南无宝上佛

归命过去未来如是等无量无边诸佛应知

南无无障碍发修佛　南无无边佛　南无宝弥留佛　南无日然灯上胜佛　南无智成就胜佛　南无忧钵罗然灯佛　南无十方然灯佛　南无贤胜佛　南无莎罗自在王佛　南无师子佛　南无宝弥留佛　南无大毗婆尸佛　南无妙胜光明佛　南无功德王光明佛　南无华王佛　南无无量明佛

归命如是等无量无边诸佛应知

南无功德一味佛　南无十方然灯佛　南无贤胜佛　南无娑罗自在王佛　南无师子佛　南无宝弥留坚佛　南无毗婆尸佛　南无明王佛　南无上首佛　南无无上首佛

归命如是等无量无边诸佛应知

南无大龙佛　南无香上胜佛　南无香胜幢佛　南无栴檀屋佛　南无香幢佛　南无栴檀香佛　南无无边精进佛　南无月上王佛　南无十上光明佛　南无波头摩上佛　南无惊怖波头摩华成就上王佛

归命如是等无量无边诸佛应知

南无宝网佛　南无善住王佛　南无香象王佛　南无与一切乐佛　南无示一切念佛　南无不空说佛　南无能灭一切怖畏佛　南无不住王佛　南无宝光明佛　南无与一切众生安隐乐佛

归命如是等无量无边诸佛应知

南无观无量境界佛　南无虚空庄严胜佛　南无无边庄严佛　南无修行幢佛　南无成就惊怖胜花佛　南无贤胜佛　南无清净眼佛　南无大将军佛　南无上胜高佛　南无不可胜幢佛

归命如是等无量无边诸佛应知

南无可依佛　南无无量无边佛　南无香弥留佛　南无月轮间王佛　南无妙弥留宝成就胜佛　南无闻弥留善胜佛　南无净胜佛　南无无障碍眼佛　南无无边功德作佛　南无威德士佛　南无愿善思惟成就佛　南无清净轮王佛　南无智上佛　南无精进仙佛　南无智山佛　南无方作佛　南无大会上首佛　南无最上首佛　南无智护佛　南无上胜佛　南无现示众生境界无障见佛　南无不成境界佛　南无无障碍光明佛　南无发光明无碍佛　南无佛波头摩上成就胜佛　南无观一切佛境界现形佛　南无说坚佛　南无化声佛　南无波头摩胜佛　南无宝成就胜佛　南无海弥留佛　南无无垢慧佛　南无智华成就佛　南无积胜上威德寂静佛　南无离贪境界佛　南无离一切取佛　南无不可思议功德成就胜佛　南无现成就胜佛　南无无畏去佛　南无香风佛　南无无等香光佛　南无云妙鼓声佛　南无功德成就胜佛　南无无量频迅境界弥留聚佛　南无香胜弥留佛　南无无量弥留佛　南无无量光明佛　南无普见佛　南无无畏佛　南无得无畏佛　南无月然灯佛　南无火然灯佛　南无胜修佛　南无胜众佛　南无金刚成佛　南无智自在王佛　南无智力称佛　南无无畏胜佛　南无功德王光明佛　南无善眼佛　南无坚自在王佛　南无弥留王佛　南无虚空弥留宝胜佛　南无贤上胜佛　南无梵吼声佛　南无宝华佛　南无波头摩成就胜佛　南无栴檀香佛　南无须弥劫佛　南无胜庄严佛　南无宝盖佛　南无香象佛　南无无边胜佛　南无不空说名佛　南无不可思议功德王光明佛　南无无畏王佛　南无波头摩上胜佛　南无常得精进佛　南无药王佛　南无安隐佛　南无无边意行佛　南无无边境界佛　南无无边光明佛　南无无边眼佛　南无金色境界佛　南无无边虚空境界佛　南无星宿王佛　南无香上胜佛　南无虚空胜佛　南无妙胜佛　南无方作佛　南无妙弥留佛　南无无障碍眼佛　南无金刚佛　南无然炬佛

归命如是等无量无边诸佛应知

南无火幢佛　南无贤无垢威德光佛　南无智积佛　南无称力王佛　南无功德王光明佛　南无见智佛　南无波头摩妙胜佛　南无成就胜佛　南无宝光明佛　南无宝莲华胜佛　南无远离疑成就佛　南无众上首佛　南无拘留孙佛　南无幢王佛　南无波头摩功德佛　南无放光明佛　南无弥勒佛　南无光明波头摩光佛

南无胜王佛　南无法幢佛　南无无量奋迅佛　南无海须弥佛　南无妙见佛　南无释迦牟尼佛　南无不空见佛　南无无障碍吼声佛　南无无量功德胜名光明佛　南无无分别修行佛　南无无边光明佛　南无善眼佛　南无南方宝普藏佛　南无无垢远离垢解脱佛

归命如是等无量无边诸佛应知

南无西方无量华佛　南无无量照佛　南无无量光明佛　南无无量明佛　南无无量境界佛　南无无量自在佛　南无无量奋迅佛　南无无普盖佛　南无盖行佛　南无宝盖佛　南无星宿王佛　南无善星宿佛　南无光明轮佛　南无光明王佛　南无光明上胜佛　南无无边见佛　南无无胜佛　南无无边境界奋迅佛　南无无障碍吼声佛　南无大云光明佛　南无罗网王佛　南无善得平等光明佛　南无波头摩胜华佛　南无山王佛　南无月众增上佛　南无高光明佛　南无合聚佛　南无不空光明佛　南无顶胜王佛　南无北方不空然灯佛　南无不空奋迅佛　南无不空境界佛　南无不空光明佛　南无无边精进佛　南无莎罗自在王佛　南无宝莎罗王佛　南无普盖王佛　南无盖庄严王佛　南无宝积佛　南无栴檀屋佛　南无栴檀香佛　南无无量光明佛　南无光明轮庄严留佛　南无无障碍眼佛　南无无量眼佛　南无宝成就佛　南无一切功德佛　南无佛华成就功德佛　南无善住慧佛　南无无量步佛　南无不空胜佛　南无宝步佛　南无无边修行佛　南无无边庄严胜佛　南无虚空轮光明佛　南无无量声佛　南无药王佛　南无无畏佛　南无远离惊怖毛竖佛　南无功德王光明佛　南无观智慧起华佛　南无虚空寂佛　南无虚空声佛　南无虚空庄严成就佛　南无下方大自在佛　南无妙胜佛　南无有佛　南无华胜佛　南无善生佛　南无师子胜佛　南无成就义佛　南无师子护佛　南无师子钾佛　南无善住山王佛　南无净弥留佛　南无清净眼佛　南无不空足步佛　南无虚空像佛　南无香胜佛　南无香山佛　南无无量眼佛　南无香积佛　南无宝众佛　南无宝高佛　南无善住佛　南无善住王佛　南无净弥留佛　南无坚王佛　南无光明轮佛　南无火然灯佛　南无不空过佛　南无善思惟发行佛　南无师子佛　南无坚固众生佛　南无行胜住王佛　南无上方无量境界佛　南无胜王佛　南无精进胜佛　南无断疑佛　南无善星宿王佛　南无然灯佛　南无光明佛　南无光明弥留佛　南无光明轮佛　南无称光明佛　南无高盖佛　南无香盖佛　南无宝盖佛　南无栴檀香佛　南无栴檀胜佛　南无须弥聚佛　南无宝光明佛　南无坚固王佛　南无净功德佛　南无清净眼佛　南无无畏佛　南无远离诸畏佛　南无成就积佛　南无宝胜佛　南无山王佛　南无转女根佛　南无无量行佛　南无最胜光明佛　南无罗网光明幢佛　南无因王佛　南无日月净明德佛　南无东南方观一切佛形镜如来以为上首佛　南无华觉奋迅佛　南无罗网光明佛　南无无量光明华佛　南无宝坚固佛　南无初发心转法轮佛　南无华积佛　南无千上光明佛　南无不动步佛　南无无量迹步佛　南无无量愿生佛　南无无边愿佛　南无无边境界佛　南无不定愿佛　南无转胎佛　南无转诸难佛　南无不行念佛　南无成就一切念佛　南无虚空佛　南无有胜佛

次礼十二部尊经大藏法轮

南无正法念处经　南无增一阿含经　南无中阿含经　南无长阿含经　南无杂阿含经　南无贤愚经　南无起世经　南无杂宝藏经　南无普曜经　南无生经　南无修行道地经　南无阴持入经　南无中本起经　南无兴起行经　南无达摩多罗禅经　南无义足经　南无毗耶娑问经　南无大安般经　南无转法轮经论　南无宝髻菩萨四法经论　南无无量寿经论　南无文殊师利问菩提经论　南无大庄严论　南无佛性论　南无大丈夫论　南无中边论　南无回诤论　南无佛阿毗昙论　南无业成就论　南无中论　南无顺中论　南无百论　南无起信论　南无三无性论　南无入大乘论　南无成实论　南无十二门行论　南无十八空论　南无宝性论　南无方便心论　南无思尘论　南无解卷论　南无缘生论　南无十二因缘论　南无一轮卢迦论　南无百字论　南无破外道四宗论　南无破外道涅槃论　南无发菩提心论　南无辟支佛因缘论

敬礼十方诸大菩萨摩诃萨

南无庄严王菩萨　南无国土庄严菩萨　南无因陀罗网菩萨　南无天山菩萨　南无善眼菩萨　南无住持世间手菩萨　南无大将菩萨　南无寂意菩萨　南无速行菩萨　南无善臂菩萨　南无山峰菩萨　南无昙无竭菩萨　南无胜愿菩萨　南无庄严相星宿山王菩萨　南无乐说无滞菩萨　南无无垢智菩萨　南无娑伽罗菩萨　南无断一切忧菩萨　南无地藏菩萨　南无普现菩萨　南无法行成就菩萨　南无深行菩萨　南无清净三轮菩萨　南无寂静心菩萨　南无无边功德菩萨　南无虚空平等智菩萨　南无波头摩眼菩萨　南无金刚幢菩萨　南无波头摩华严菩萨　南无宝庄严菩萨　南无宝路菩萨　南无功德王慧菩萨　南无庄严王菩萨　南无断诸严王菩萨　南无清净光明庄严菩萨　南无深声菩萨　南无妙鼓声菩萨　南无尼民陀罗菩萨　南无大自在菩萨　南无诸功德身菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无随喜辟支佛　南无十二波罗堕辟支佛　南无十同名婆罗辟支佛　南无火身辟支佛　南无同菩提辟支佛　南无摩诃男辟支佛　南无心上辟支佛　南无发净辟支佛　南无善快辟支佛　南无违陀辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等。今以总相忏悔一切诸业。今当次第更复一一别相忏悔。若总若别若粗若细。若轻若重若说不说。品类相从愿皆消灭。别相忏悔者。先忏身三次忏口四。其余诸障次第稽颡。身三业者。第一杀害如经所明。恕己可为喻勿杀勿行杖。虽复禽兽之殊。保命畏死其事是一。若寻此众生无始已来。或是我父母兄弟六亲眷属。以业因缘轮回六道出生入死。改形易报不复相识。而今兴害食啖其肉断大慈种。是故佛言。设得余食当如饥母食子肉想。何况食啖此鱼肉耶。又言为利杀众生。以钱纳众生肉。二俱是恶业。死堕叫唤地狱。故知杀害及以食啖。罪深河海过重丘岳。然弟子等。从无始已来不遇善友皆为此业。是故经言。杀害之罪能令众生堕于地狱饿鬼受苦若在畜生则受虎狗豺狼鹰鹞等身。或受毒蛇蝮蝎等身常怀恶心。或受獐鹿熊罴等身常怀恐怖。若生人中得二种果报。一者多病。二者断命。杀害食啖既有如是无量种种诸恶果报。是故弟子。今日至到稽颡至诚归依于佛

南无东方灭诸怖畏佛　南无南方日月灯明佛　南无西方觉花光佛　南无北方发功德佛　南无东南方除众惑冥佛　南无西南方无生自在佛　南无西北方大神通王佛　南无东北方空离垢心佛　南无下方同像空无佛　南无上方琉璃藏胜佛

归命如是等十方尽虚空界一切三宝。弟子等。自从无始已来至于今日有此心识。常怀碜毒无慈愍心。或因贪起杀。因嗔因痴及以慢杀。或兴恶方便。誓杀愿杀及以咒杀。或破决湖池。焚烧山野田猎捕鱼。或因风放火飞鹰放犬。恼害一切六道众生。如是等罪无量无边。今日至心归命忏悔

或以[打-丁+監]弶抗拨枚戟弓弩。弹射飞鸟走兽之类。或以罛网罾钓。捞漉水性鱼鳖鼋鼍虾蚬蠃蚌湿居之属。使水陆之与空行藏窜无地。或畜养鸡猪牛羊犬豕鹅鸭之属。自供庖厨或货他宰杀。使其哀声未尽毛羽脱落鳞甲伤毁。身首分离骨肉销碎。剥裂屠割炮烧煮炙。楚毒酸切横加无辜。但取一时之快口。得味甚寡。不过三寸舌根而已。然其罪报殃累永劫。如是等罪今日至诚。归命忏悔。又复无始已来至于今日。或复兴师相伐强场交诤。两阵相向更相杀害。或自杀他教杀。闻杀欢喜。或习屠鲙债为刑戮。烹宰他命行于不忍。或恣忿怒挥戈抚刃。或斩或刺或推着坑堑。或以水沉溺。或塞穴坏巢土石磓岬。或以车马躙轹践蹋一切众生。如是等罪无量无边。今日发露归命忏悔

又复无始已来。或溉灌陆田堕胎落子破卵坏巢。毒药蛊道伤杀众生。垦土掘地种植田园养蚕煮茧。养猫搦鼠伤杀滋甚。或打扑蚊虻螥蝇蜂蝎。掐抯蚤虱。或烧除粪扫。开决沟渠枉害一切。或啖果实或用谷米。或水或菜横杀众生。或然樵薪或露灯烛焚诸虫类。或食酱酢不看摇动。或泻汤水浇杀虫蚁。如是乃至行住坐卧四威仪中。恒常伤杀飞空着地细微众生。弟子。以凡夫识暗不觉不知。今日发露归命忏悔

又复弟子等。从无始已来至于今日。或以鞭杖枷锁桁械。压立拷掠打掷。手脚蹴蹋缠缚笼系断绝水谷。如是种种诸恶方便苦恼众生。今日至诚向十方佛尊法圣众。归命忏悔

愿弟子等。承是忏悔杀害等罪所生功德。愿生生世世得金刚身寿命无穷。永离怨憎无杀害想。于诸众生得一子地。若见危难急厄之者。不惜身命方便救解令得解脱。然后为说微妙正法。使诸众生睹形见影皆蒙安乐。闻名听声恐怖悉除

    大乘莲华宝达问答报应沙门经

宝达顷前更入流火地狱。云何名曰流火地狱。其地狱纵广二百由旬。周匝铁城铁网覆上。猛火绝炽烟焰洞然。[金*疾][金*離]铁锵遍布于地狱中。火流烟焰俱起。西门之中有六百罪人唱声大唤。遍身火然绝炎猛炽。此罪沙门唱如是言。我今何罪来入此处。跳踉宛转而不肯前。马头罗刹以手拍耳口眼火出。手捉利刃望头而斫。复有饿狗来食其肉。复有饿鬼来饮其血。复有飞鸟来餐其髓。马头罗刹捉臂而牵手下火然。应时则燋火流灌身周遍燋烂。一日一夜受罪无量。千死千生万死万生。宝达问马头罗刹曰。此诸沙门以何因缘受如是罪。马头罗刹答宝达曰。此诸沙门受佛净戒而不净持。受人信施杨枝澡漱香汤沐浴。游行世间受持应器而行乞食。似沙门形中不惭愧。以是因缘堕此地狱。宝达闻之悲泣流泪。则说偈言

  云何无系缚　　还入囹圄中
  云何出生死　　还入三恶道
  云何遇浮木　　睹明还归闇
  云何吹火灭　　忽然还炽盛
  净行解脱人　　今受大苦痛

宝达菩萨说偈而去

佛名经卷第五佛说佛名经卷第六

南无西南方成就义如来为上首　南无成就义发行佛　南无成就炎佛　南无常发行佛　南无善住佛　南无无量发行佛　南无无相修行佛　南无无边修行佛　南无普修行佛　南无然灯光明作佛　南无普藏佛　南无普山佛　南无无边形佛　南无无边精进佛　南无罗网光佛　南无曼陀罗佛　南无光明轮佛　南无善见佛　南无不空说名佛　南无破一切怖畏佛　南无无量功德王光明步佛　南无无边华佛　南无无边吼声佛　南无乐积光明功德佛　南无不二轮佛　南无无量光明佛华光佛　南无无量声佛　南无高明佛　南无坚固自在王佛　南无日面佛　南无善眼佛　南无胜功德佛　南无宝华佛　南无宝成就佛　南无月华佛　南无一切众生修行佛　南无转一切世间佛　南无无量光明无形佛　南无无畏佛　南无一切乐念顺行佛　南无西北方普香光明如来为上首　南无发初香光明佛　南无香山佛　南无香象佛　南无香胜佛　南无香身佛　南无香轮佛　南无光明王佛　南无妙波头摩王佛　南无佛境界佛　南无无量境界佛　南无安乐佛　南无快胜佛　南无放光明华佛　南无华盖行佛　南无华帐佛　南无金华佛　南无香华佛　南无高王佛　南无善导师佛　南无胜一切众生佛　南无转一切念佛　南无无量行华佛　南无无量香佛　南无普照放光明佛　南无普香光明佛　南无普放光明佛　南无放成就胜华佛　南无宝罗网像佛　南无妙光佛　南无一盖国土佛　南无星宿王佛　南无合聚佛　南无不住王佛　南无香风佛　南无无边智境界佛　南无不空行佛　南无不空见佛　南无无障碍眼佛　南无初发心佛　南无无量眼佛　南无然灯上佛　南无普光明佛　南无照光明佛　南无一切佛国土一切众生不断乐说佛　南无阿楼那奋迅佛　南无无迹奋迅佛　南无东北方断一切忧恼如来为上首　南无离忧佛　南无乐成就功德佛　南无无畏王佛　南无胜弥留佛　南无香山佛　南无拘邻佛　南无大体胜佛　南无宝莲华胜佛　南无华成就佛　南无吼眼佛　南无胜众佛　南无无边光明佛　南无月胜光明称佛　南无星宿王众僧上佛　南无无边光明佛　南无香高山佛　南无无畏王佛　南无成就胜无畏佛　南无无边光照光明佛　南无香弥留佛　南无离惊怖成就胜佛　南无无量功德月成就佛　南无一切功德庄严佛　南无不可胜幢佛　南无增上护光明佛　南无华胜王佛　南无无边成就行佛　南无一切胜佛　南无虚空轮清净王佛　南无无量吼声佛　南无无量吼妙声佛　南无宝胜功德佛　南无净胜佛　南无无碍香象佛　南无高光明佛　南无大称佛　南无称亲佛　南无坚固自在王佛　南无莎罗王佛　南无无量照佛　南无安隐王佛　南无普功德增上云声灯佛　南无大积佛　南无高积佛　南无功德王光明佛　南无坚积聚佛　南无宝胜光明佛　南无忧钵罗光明作佛　南无月王佛　南无栴檀佛　南无月胜佛　南无修梵行佛　南无行净佛　南无一切胜佛　南无难胜佛　南无宝作佛　南无无量声佛　南无树提佛　南无龙天佛　南无日天佛　南无师子佛　南无无垢明佛　南无世间天佛　南无胜积佛　南无人自在恭敬佛　南无华胜佛　南无发精进佛　南无火妙香光明胜佛　南无无垢香火胜佛　南无普见佛　南无不动佛　南无宝幢佛　南无无量明佛　南无妙宝声佛　南无遍照佛　南无智光明王佛　南无摩尼光明胜佛　南无无量花光明善胜慧佛　南无卢舍那佛　南无智慧自在佛　南无水聚日佛　南无火然灯佛　南无月光明佛　南无无障碍智佛　南无华香佛　南无宝光明佛　南无曼陀罗香喜佛　南无拘邻智炎佛　南无大明香佛　南无华幢佛　南无无著智佛　南无如是等无量亿毗婆罗佛　南无宝作佛　南无无忧胜佛　南无宝山佛　南无人王佛　南无力胜佛　南无香胜佛　南无普满华佛　南无无垢光明佛　南无乐说庄严思惟佛　南无无垢月幢佛　南无俱苏摩光明作佛　南无火行佛　南无宝上佛　南无无畏观佛　南无远离惊怖毛竖等喜称佛　南无师子奋迅力佛　南无金光明威德王佛

若善男子善女人。十日礼拜读诵是诸佛名。远离一切诸难。灭一切罪

南无善说增上名胜佛　南无普光明佛　南无过种种敌对频迅佛　南无自在幢王佛　南无无量功德光明胜佛　南无无障碍佛　南无宝波头摩奋迅胜佛　南无宝华善住山自在王佛

若善男子善女人。受持读诵是诸佛名。一阿僧祇劫超越世间不入恶道

南无智灯佛　南无光明佛　南无难降伏佛　南无普照十方世界佛　南无大海佛　南无宝藏佛　南无银幢佛　南无幢日王佛　南无威德自在王佛　南无觉王佛　南无十力自在佛　南无平等作佛　南无初发心思惟远离诸怖畏烦恼无碍妙胜佛　南无金刚足步佛　南无宝像光明足奋迅佛　南无降伏诸魔疑奋迅佛　南无栴檀胜佛　南无初发心不退转成就胜佛　南无宝盖上光明佛　南无教化菩萨佛　南无初发心断一切疑烦恼佛　南无光明胜破闇三昧胜上王佛　南无乐说庄严云声欢喜佛　南无清净香决定光明威德王佛　南无拘留孙佛　南无金声佛　南无人王佛　南无迦叶佛　南无弥勒佛　南无师子佛　南无然炬佛　南无明王佛　南无须弥聚佛　南无圣佛　南无华幢佛　南无善星宿佛　南无大臂佛　南无大主佛　南无大力佛　南无星宿王佛　南无药王佛　南无称幢佛　南无大光明佛　南无火聚佛　南无日藏佛　南无月炎佛　南无月照佛　南无善明佛　南无无忧佛　南无照佛　南无一沙佛　南无大明佛　南无住持鬘佛　南无功德明佛　南无见义佛　南无然灯佛　南无妙歌佛　南无药王佛　南无安隐佛　南无顶坚胜威德佛　南无难胜佛　南无功德幢佛　南无罗睺佛　南无胜众佛　南无梵声佛　南无坚固意佛　南无光明作佛　南无大高山佛　南无金刚仙佛　南无宝波头摩眼力仙佛　南无无畏佛　南无华光明人爱佛　南无大威德佛　南无日净王佛　南无无量命佛　南无龙德佛　南无坚步佛　南无不空见佛　南无精进德佛　南无力护佛　南无欢喜佛　南无德胜佛　南无师子幢佛　南无胜法佛　南无欢喜王上首佛　南无爱作佛　南无功德智佛　南无香象佛　南无善观佛　南无云声佛　南无善思惟佛　南无善识佛　南无无垢佛　南无月上佛　南无大称佛　南无摩尼宝佛　南无胜王佛　南无师子步佛　南无树王佛　南无光明胜佛　南无星宿佛　南无大觉佛　南无积智慧佛　南无善住佛　南无坚意佛　南无甘露慧佛　南无善见佛　南无智光明佛　南无坚行佛　南无善吉佛　南无宝幢佛　南无波头摩佛　南无那罗延佛　南无乐说佛　南无智作佛　南无功德佛　南无供养佛　南无净德佛　南无宝作佛　南无华天佛　南无善思惟义佛　南无法上佛　南无自在佛　南无称慧佛　南无意称佛　南无金刚幢佛　南无十力佛　南无频迅佛　南无离闇佛　南无罗睺天佛　南无弥留幢佛　南无众上首佛　南无宝藏佛　南无上修佛　南无星宿佛　南无大觉佛　南无三界尊佛　南无功德称佛　南无日月光明师子幢佛　南无毗罗波王佛　南无胜藏佛　南无示现有佛　南无月光佛　南无金山佛　南无师子德佛　南无不可胜幢佛　南无光明佛　南无称愿佛　南无坚精进佛　南无譬喻称佛　南无离畏佛　南无应天佛　南无大然灯佛　南无多世间佛　南无妙香佛　南无住持功德佛　南无离闇佛　南无无比佛　南无师子佛　南无自然佛　南无善行佛　南无宝称佛　南无离诸过佛　南无住持甘露佛　南无人月佛　南无日面佛　南无庄严佛　南无摩尼光佛　南无山积佛　南无高幢佛　南无法作佛　南无思惟义佛　南无深心佛　南无宝聚佛　南无众上首佛　南无劫簸佛　南无奋迅佛　南无住智佛　南无分明佛　南无心分明佛　南无胜佛　南无不起佛　南无功德胜佛　南无师子吼佛　南无奋迅佛　南无人信佛　南无龙王佛　南无华山佛　南无龙喜佛　南无香自在佛　南无妙称佛　南无天力佛　南无功德鬘佛　南无龙功德佛　南无庄严眼佛　南无善行智佛　南无智胜佛　南无慧照佛　南无实语佛　南无日光明佛　南无决定智佛　南无宝上色佛

次礼十二部尊经大藏法轮

南无安般守意经　南无般泥洹经　南无当来变经　南无过去佛分卫经　南无奈女耆域经　南无净饭王般涅槃经　南无八师经　南无大迦叶本经　南无四愿经　南无妇人遇辜经　南无辨意长者子所问经　南无胞胎经　南无四自侵经　南无五百弟子自说本起经　南无七女本经　南无阿难四事经　南无所欲致患经　南无法受尘经　南无禅行法想经　南无四天王经　南无佛垂般涅槃略说教戒经　南无别译杂阿含经　南无优婆夷净行经　南无难提释经　南无无垢优婆夷问经　南无造立形像福报经　南无法常住经　南无懈怠耕者经　南无优填王经　南无阿难七梦经　南无佛入涅槃密迹金刚力士哀恋经　南无迦叶赴佛涅槃经　南无佛灭度后棺敛葬送经　南无灌佛经　南无罗云忍辱经　南无出家缘经　南无三品弟子经　南无四辈经　南无见正经　南无呵雕阿那含经　南无五无返复经　南无阿含正行经　南无五恐怖世经　南无大鱼事经　南无频多和多耆经　南无梵摩难国王经　南无摩诃迦叶度贫母经　南无中心经　南无龙王兄弟经　南无降龙王经

敬礼十方诸大菩萨摩诃萨

南无光明意菩萨　南无善见菩萨　南无不取诸法菩萨　南无转女根菩萨　南无思惟大悲菩萨　南无宝盖山菩萨　南无云山吼声菩萨　南无罗网庄严菩萨　南无宝藏菩萨　南无法鸡兜菩萨　南无日鸡兜菩萨　南无无边鸡兜菩萨　南无无垢藏菩萨　南无山峰菩萨　南无山峰住持菩萨　南无须弥山灯王菩萨　南无须弥幢菩萨　南无须弥山声菩萨　南无弥留王菩萨　南无宝杖菩萨　南无宝尸弃菩萨　南无宝来菩萨　南无宝天菩萨　南无法乐庄严菩萨　南无庄严王菩萨　南无山相庄严菩萨　南无金庄严光明菩萨　南无清净声光菩萨　南无宝髻菩萨　南无天吉菩萨　南无百光菩萨　南无火光菩萨　南无星宿味菩萨　南无常悲泣菩萨　南无光明胜菩萨　南无一切法自在菩萨　南无宝轮菩萨　南无宝炬菩萨　南无不空奋迅菩萨　南无云光明菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无吉沙辟支佛　南无忧婆吉沙辟支佛　南无断有辟支佛　南无忧婆支罗辟支佛　南无断爱辟支佛　南无施波罗辟支佛　南无转觉辟支佛　南无去垢辟支佛　南无高去辟支佛　南无阿悉多辟支佛　南无无漏辟支佛　南无憍慢辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等次忏劫盗之业。经中说言。若物属他他所守护。于此物中一草一叶不与不取。何况盗窃。但自众生唯见现在利故。以种种不道而取。致使未来受此殃累。是故经言。劫盗之罪能令众生堕于地狱饿鬼受苦。若在畜生则受牛马驴骡骆驼等形。以其所有身力血肉偿他宿债。若生人中为他奴婢。衣不蔽形食不充命。贫寒困苦人理殆尽。劫盗既有如是苦报。是故弟子今日至到稽首归依佛

南无东方坏诸烦恼佛　南无南方妙音自在佛　南无西方大云光佛　南无北方云自在王佛　南无东南方无缘庄严佛　南无西南方过诸魔界佛　南无西北方见无恐惧佛　南无东北方一切德严佛　南无上方莲华藏光佛　南无下方妙善住王佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始已来至于今日。或盗他财宝兴刃强夺。或自恃身逼迫而取。或恃公威或假势力。高桁大棫枉压良善。吞纳奸货拷直为曲。为此因缘身罹宪网。或任邪治领他财物。侵公益私侵私益公。损彼利此利彼损此。割他自饶口与心吝。或窃没租估偷度关税。匿公课输藏隐使没。如是等罪无量无边。今日惭愧归命忏悔

或是佛法僧物不与而取。或经像物或治塔寺物。或供养常住僧物。或拟招提僧物。或盗取误用。恃势不还。或自借货人。或复换贷漏妄。或三宝物混乱杂用。或以众僧物。谷米樵薪姜豉酱酢。菜茹果实钱帛竹木。缯彩幡盖香华油烛。随情逐意。或许施三宝物。诳欺不与。或自用或与人。或摘佛华果用僧鬘物。因三宝财私自利己。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等从无始已来至于今日。或作周旋朋友师僧同学。父母兄弟六亲眷属。共住同止。百一所须更相欺诳。或于乡邻比近移篱拓墙。侵夺地宅改檦易相。虏掠田园因公托私。夺他邸店及以毛野。如是等罪无量无边。今日发露归命忏悔

又复弟子等从无始已来至于今日。或攻城破邑烧村坏栅。偷卖良民诱他奴婢。或复枉压无罪之人。使其形[止*且]血刃身被徒锁。家业破散骨肉生离。分张异城生死隔绝。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等从无始已来至于今日。或商侣博货邸店市易。轻秤小斗减割尺寸。盗窃分铢欺罔圭合。以粗易好以短换长。巧欺百端希望毫利。如是等罪无量无边。今日惭愧归命忏悔

又复弟子等从无始已来至于今日。穿踰墙壁断道抄掠。抵捍债息负债违要而欺心口。或非道陵夺鬼神禽兽四生之物。或假托卜相取人财宝。如是乃至以利求利。恶求多求无厌无足。如是等罪无量无边不可说尽。今日至到向十方佛尊法圣众前归命忏悔。愿弟子等承是忏悔劫盗等罪所生功德。愿生生世世得如意宝。常雨七珍上妙衣服。百味甘露种种汤药。随意所须应念则至。一切众生无偷夺相。一切皆能少欲知足。不耽不染常乐惠施行急济道。头目髓脑如弃涕涶。回向满足檀波罗蜜

    大乘莲华宝达问答报应沙门经

宝达顷前更入铁床地狱。云何名铁床地狱。此地狱纵广五十由旬。铁城周匝上有铁网罗覆其上。猛火炎赫周遍狱中。[金*疾][金*離]铁锵遍布其地。烟火洞然四方俱炽。中有铁床上安銐刀銐如锋铓。火从中出绝焰俱炽。东门之中有七百沙门。指手呼天唱言。苦哉。我今何罪来诣其中。跳踉宛转高声大唤。马头罗刹手捉三股铁叉望腰而撞脐中而出。擎着铁床之上。銐刀仰刺腹背俱彻。千生千死万生万死。一日一夜受罪无量。从地狱出生于人中诸根不具

宝达问马头罗刹曰。此沙门作何业行。受罪如是。马头罗刹答曰。此诸沙门受佛净戒。不求未来无上佛道。但取现在名闻利养。身犯四禁八万威仪。贪求信施如火得草不知满足。坐人床座亦不如法。与白衣共宿如俗人法。坐佛床上登蹑师坐。卧师形像阴凉之下。以是因缘堕此地狱。宝达闻之悲泣而言

  奇哉怪希有　　解脱而不脱
  奇哉怪希有　　慧日坠大海
  已得解脱门　　还复被系缚

佛名经卷第六佛说佛名经卷第七

南无普照佛　南无宝幢佛　南无离疑佛　南无师子奋迅步佛　南无善护佛　南无不空步佛　南无觉华幢佛　南无山自在王佛　南无大威德佛　南无示现恶佛　南无甘露称佛　南无宝天佛　南无住义智佛　南无满足智佛　南无不陜劣名称佛　南无无忧佛　南无离垢胜佛　南无梵天佛　南无地自在王佛　南无华眼佛　南无差别见佛　南无法光明佛　南无具足见佛　南无信功德佛　南无三界尊佛　南无月叶佛　南无宝光明佛　南无宝幢佛　南无妙称佛　南无光明作佛　南无无量威德佛　南无广护佛　南无师子身佛　南无甘露慧佛　南无难胜佛　南无功德聚佛　南无月高佛　南无得大势至佛　南无无量步佛　南无月无畏佛　南无见一切义佛　南无勇猛佛　南无功德然灯佛　南无月王佛　南无功德炎佛　南无广智佛　南无善寂灭佛　南无天光佛　南无无垢佛　南无住持无量明佛　南无希胜佛　南无不覆藏佛　南无善住佛　南无大意佛　南无上首佛　南无世间光明佛　南无多功德佛　南无无量威德佛　南无义慧佛　南无离尘佛　南无离嗔恨无热佛　南无善称佛　南无称德佛　南无俱苏摩德佛　南无人德佛　南无精进仙佛　南无大德佛　南无寂慧佛　南无香像佛　南无上坚佛　南无安乐佛　南无不可胜佛　南无日月佛　南无雷王佛　南无电王佛　南无大胜佛　南无护智佛　南无日胜佛　南无成就义佛　南无宝积佛　南无降伏怨佛　南无华胜佛　南无应称佛　南无智步佛　南无离慢佛　南无根华佛　南无无畏国土佛　南无高称佛　南无示有佛　南无月盖佛　南无多功德佛　南无宝月佛　南无师子幢佛　南无乐思惟佛　南无不可思议奋迅佛　南无乐功德佛　南无应供称佛　南无华相佛　南无无量乐说称佛　南无摩尼金刚佛　南无无量寿佛　南无摩尼庄严佛　南无大自在功德佛　南无胜月佛　南无高山称佛　南无百光明佛　南无欢喜佛　南无龙步佛　南无意成就佛　南无宝月佛　南无寂灭佛　南无然炬王佛　南无上首佛　南无欢喜自在佛　南无宝髻佛南无远离畏佛　南无宝藏佛　南无月面佛　南无无垢称佛　南无称威德佛　南无爱天佛南无罗睺天佛　南无善炎佛　南无宝爱佛　南无宝聚佛　南无宝步佛　南无师子华佛　南无高修佛　南无人自在佛　南无人慧佛　南无照世间佛　南无宝威德佛　南无功德佛　南无大相佛　南无乘庄严佛　南无桥梁佛　南无香象佛　南无无心慧佛　南无弥留幢佛　南无善香佛　南无坚铠佛　南无胜威德佛　南无摩尼铠佛　南无贤大佛　南无善香月佛　南无净自在佛　南无师子月佛　南无胜威德佛　南无善胜佛　南无不可胜轮佛　南无胜亲佛　南无实名佛　南无大行佛　南无高光明佛　南无功德山佛　南无大称佛　南无法称佛　南无施光明佛　南无电德佛　南无实作佛　南无救命佛　南无善炎佛　南无善首佛　南无决定慧佛　南无离有佛　南无摩尼香佛　南无胜喜佛　南无师子光明佛　南无普照佛　南无称胜佛　南无善智慧佛　南无摩尼月佛　南无高光佛　南无不可降伏行佛　南无大光佛　南无摩尼轮佛　南无世尊佛　南无师子像佛　南无月满佛　南无宝炎佛　南无罗睺佛　南无善护佛　南无希觉佛　南无同光明佛　南无寂静去佛　南无安隐世间佛　南无无恼佛　南无十方行佛　南无力善佛　南无火体胜佛　南无至大体佛　南无得大势佛　南无功德藏佛　南无实行佛　南无无畏胜佛　南无树提佛　南无大光明佛　南无日光佛　南无广功德佛　南无宝功德佛　南无自在佛　南无摩尼香佛　南无作业佛　南无师子手佛　南无善化佛　南无宝高佛　南无大海佛　南无住持佛　南无义智佛　南无善思惟慧佛　南无大众轮佛　南无宝火佛　南无修行义佛　南无世间月佛　南无华声佛　南无净幢佛　南无大众上首佛　南无师子步佛　南无威德佛　南无福德成就佛　南无大光明佛　南无宝称佛　南无信众佛　南无无边称佛　南无不空光明佛　南无圣天佛　南无金刚众佛　南无善肩佛　南无幢王佛　南无华成佛　南无铠慧佛　南无风行佛　南无善思惟佛　南无大称佛　南无快然佛　南无甘露聚佛　南无功德护佛　南无义去佛　南无无畏佛　南无大慈悲佛　南无住分别佛　南无摩尼足佛　南无解脱威德佛　南无善报佛　南无善疾平等威德佛　南无智胜佛　南无善天佛　南无实声佛　南无智力得佛　南无师子慧佛　南无华高佛　南无智作佛　南无华德佛　南无功德藏佛　南无宝称佛　南无实称佛　南无不可降伏佛　南无无畏自在佛　南无净日佛　南无诸天佛　南无可爱佛　南无实天佛　南无宝藏佛　南无功德称佛　南无智积佛　南无清白佛　南无远行佛　南无天威德佛　南无净圣佛　南无喜去佛　南无大优威德佛　南无炎聚佛　南无大胜佛　南无华光佛　南无喜上佛　南无善首佛　南无自在幢佛　南无大爱佛　南无善心佛　南无降伏他众佛　南无勇猛佛　南无成就佛　南无威德佛　南无善思议境界佛　南无善臂佛　南无大宝佛　南无称意佛　南无世间尊佛　南无功德光明佛　南无宝声佛　南无金刚仙佛　南无成就佛　南无师子力佛　南无无垢眼佛　南无迦叶佛　南无清净智佛　南无智步佛　南无高威德佛　南无大光明佛　南无日光明佛　南无无垢身佛　南无差别身佛　南无差别威德佛　南无不可比甘露钵佛　南无月光明电德佛　南无寂灭去佛　南无不动佛　南无多称佛　南无功德法佛　南无欢喜无畏佛　南无庄严王佛　南无妙称佛　南无多炎佛　南无华胜佛　南无宝庄严佛　南无善贤佛　南无宝妙佛　南无善智慧佛　南无善贤德佛　南无梵幢佛　南无月盖佛　南无罗网炎佛　南无广光明佛　南无智称佛　南无名相佛　南无功德光明佛　南无称名声佛　南无满月佛　南无华光佛　南无善行佛　南无然灯佛　南无电幢佛　南无光明王佛　南无星宿光佛　南无不可嫌名佛　南无波头摩藏佛　南无弗沙快佛　南无眼满佛　南无无浊义佛　南无高威德佛　南无华威德佛　南无奋迅佛　南无无障智佛　南无罗睺天佛　南无智聚佛　南无上首佛　南无自在劫佛　南无华幢佛　南无罗睺佛　南无火药佛　南无星宿王佛　南无明王佛　南无福德手佛　南无称光佛　南无日光明佛　南无法藏佛　南无善智慧佛　南无功德自在劫佛　南无金刚仙佛　南无智慧积佛　南无善住佛　南无善至智慧佛　南无净声佛　南无龙吼声佛　南无相幢佛　南无智慧聚佛　南无无畏佛　南无净上首佛　南无快眼佛　南无龙德佛　南无宝幢佛　南无黠慧佛　南无不怯弱声佛　南无宝相佛　南无声德佛　南无师子佛　南无种种说佛　南无智色佛　南无波头摩聚佛　南无华佛　南无奋迅去佛　南无华积佛　南无胜色佛　南无星宿色佛　南无月灯佛　南无威德聚佛　南无菩提王佛　南无无尽佛　南无善慧眼佛　南无喜身佛　南无智慧国土佛　南无上身佛　南无净威德佛　南无有智佛　南无真声佛　南无大尊佛　南无无障碍藏佛　南无胜德佛　南无胜智奋迅佛　南无大炎佛

次礼十二部尊经大藏法轮

南无沙曷比丘功德经　南无树提伽经　南无卢至长者经　南无须摩提长者经　南无灯指因缘经　南无十二品生死经　南无谏王经　南无五王经　南无末罗王经　南无摩达国王经　南无普达王经　南无揵陀国王经　南无坚意经　南无佛大僧大经　南无邪只经　南无十二头陀经　南无护净经　南无木患子经　南无时非时经　南无锡杖经　南无栴檀树经　南无新岁经　南无贫穷老公经　南无长者子懊恼三处经　南无佛说越难经　南无栴檀越国王经　南无自爱经　南无佛说处处经　南无无上处经　南无轮转五道罪福报应经　南无未生怨经　南无十八泥梨经　南无僧护因缘经　南无那先比丘经　南无四分律　南无十诵律　南无僧祇律　南无弥沙塞律　南无僧祇戒本　南无四分戒本　南无解脱戒本　南无沙弥威仪　南无昙无德羯磨　南无四分尼羯磨　南无优婆塞五戒相　南无善见律毗婆沙　南无鼻奈耶　南无萨婆多毗尼摩德勒伽

敬礼十方诸大菩萨摩诃萨

南无法王菩萨　南无合山菩萨　南无降伏魔菩萨　南无普见菩萨　南无智山菩萨　南无难可菩萨　南无因陀罗幢菩萨　南无金髻菩萨　南无善见菩萨　南无善意菩萨　南无解脱王菩萨　南无大威德菩萨　南无波头摩眼菩萨　南无普眼菩萨　南无决定法菩萨　南无离垢菩萨　南无大光菩萨　南无大力菩萨　南无大月菩萨　南无善月菩萨　南无净心菩萨　南无住持华菩萨　南无不着行菩萨　南无离诸恶菩萨　南无得大菩萨　南无智炬灯菩萨　南无无边行菩萨　南无无边见菩萨　南无无障碍智菩萨　南无无垢眼山王菩萨　南无住持寂静菩萨　南无离闇菩萨　南无无边幢菩萨　南无火光菩萨　南无三界尊菩萨　南无世间炬菩萨　南无无障眼菩萨　南无不可嫌称菩萨　南无无边见菩萨　南无无碍见菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无尽憍慢辟支佛　南无亲辟支佛　南无得脱辟支佛　南无无垢辟支佛　南无独辟支佛　南无鸡书辟支佛　南无能作憍慢辟支佛　南无退辟支佛　南无不退去辟支佛　南无寻辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等至心忏悔贪欲之罪。经中说言。但为贪欲闭在痴狱。没生死河莫之能出。众生为是五欲因缘从昔已来流转生死。一一众生一劫之中所积身骨。如王舍城毗富罗山。所饮母乳如四海水。身所出血复过于此。父母兄弟六亲眷属。命终哭泣所出目泪如四海水。是故说言有爱则生爱尽则灭。故知生死贪爱为本。所以经言。淫欲之罪能令众生堕于地狱饿鬼受苦。若在畜生则受鸽雀鸳鸯等身。若生人中妻不贞良。得不随意眷属。淫欲既有如此恶业。是故弟子今日至心稽颡归依佛

南无东方师子音王佛　南无南方大云藏佛　南无西方无量寿佛　南无北方红莲花光佛　南无东南方无垢琉璃佛　南无西南方胜调伏上佛　南无西北方散华生德佛　南无东北方心同虚空佛　南无下方无垢称王佛　南无上方净智慧海佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始已来至于今日。或通人妻妾夺他妇女。侵陵贞洁污比丘尼。破他梵行逼迫不道。浊心邪视言语嘲调。或复耻他门户污贤善名。或于男子五种人所起不净行。如是等罪无量无边。今日至诚归命忏悔。弟子等从无始已来至于今日。或受女身心如野马。恒日放荡无一时定。常怀邪心恒生欲想。或于伽蓝会所。无心听法眼常贪视。或爱欲沙门坏他男子。不诞佛法恣放淫情。致令心飃大海冥然失岸。或秽污僧三衣法服。或于精舍院宇行不净行共相探摸。如是等罪无量无边。今日惭愧至心忏悔

又复弟子等从无始已来至于今日。或作女身恒怀淫欲。或侵夺他夫婿。迷惑诸丈夫。或作符书厌蛊遣他妇患。人生少福为邪所著。诸病鬼等因此得便。不遇良医遂致身死。如是等罪无量无边。今日惭愧发露悔过。至诚稽颡归命忏悔

又复弟子等。从无始已来至于今日。或眼为色或爱染玄黄红彩朱紫珍玩宝饰。或取男女长短黑白姿态之想。起非法想。或耳贪好声宫商弦管妓乐歌唱。或取男女音声言语啼笑之相起非法想。或鼻籍名香蕴麝幽兰郁金苏合起非法想。或舌贪好味鲜美甘肥。众生肉血资养四大。更憎苦本起非法想。或身乐华绮锦绣缯縠。一切细滑七珍丽服起非法想。或意多乱想触向乖法。有此六想造罪尤甚。如是等罪无量无边。今日至诚向十方佛尊法圣众前。归命忏悔

愿弟子等承是忏悔淫欲等罪所生功德。愿生生世世自然化生不由胞胎。清净皎洁相好光丽。六情开朗聪利分明。了达恩爱犹如桎梏。观此六尘如幻如化。于五欲境决定厌离。乃至梦中不起邪想。内外因缘永不能动。愿以忏悔眼根功德。愿令此眼彻见十方诸佛菩萨清净法身不以二相。愿以忏悔耳根功德。愿令此耳常闻十方诸佛贤圣所说正法如教奉行。愿以忏悔鼻根功德。愿令此鼻常闻香积入法位香。舍离生死不净臭秽。愿以忏悔舌根功德。愿令此舌常餐法喜禅悦之食。不贪众生血肉之味。愿以怀悔身根功德。愿令此身被如来衣着忍辱铠。卧无畏床坐四禅座。愿以忏悔意根功德。愿令此意成就十想洞达五明。深观二谛空平等理。从方便慧起十妙行。入法流水念念增明。显发如来大无生法忍

    大乘莲华宝达问答报应沙门经

宝达顷前更入一地狱。名为火象地狱。其地狱中自然而有火象。其象身甚长大。象身火然烟焰俱出。其象口眼亦有火然。罪人见之迫迮号泣而不肯前。狱卒夜叉叉着象上。其象跳踉罪人堕地。地上火燃烧然其身。一日一夜千死千生万死万生。从地狱出若生人中身不具足。黄门二根不男石女

宝达问马头罗刹曰。此诸沙门作何罪故受罪如是。罗刹答曰。此诸沙门受佛净戒而不净持。行淫欲法威仪不具。身形不净入于佛像精舍之中。而行视眇揩探佛像心无惭愧。以是因缘堕于地狱受如是罪。宝达闻之悲泣而去

佛名经卷第七佛说佛名经卷第八

南无自在疾住持威德佛　南无善光明胜佛　南无善色王佛　南无成就义佛　南无师子仙佛　南无天王佛　南无施德佛　南无快藏佛　南无福德光明佛　南无净行佛　南无然灯王佛　南无智生佛　南无妙天佛　南无地天佛　南无得解脱去佛　南无金顶佛　南无罗睺乐说佛　南无难胜佛　南无信圣佛　南无月光佛　南无金光佛　南无善才佛　南无功德自在天佛　南无法盖佛　南无功德智佛　南无差别身佛　南无妙智佛　南无微智佛　南无一切威德药佛　南无解脱幢佛　南无智慧藏佛　南无智慧积佛　南无怖畏佛　南无离恶佛　南无无障碍称佛　南无实积佛　南无善声佛　南无众自在劫佛　南无法积佛　南无解脱威德佛　南无胜快佛　南无妙身佛　南无妙语佛　南无师子爱佛　南无人自在功德佛　南无师子髻佛　南无法浚佛　南无安乐佛　南无不动佛　南无色威德佛　南无能觉王佛　南无善眼佛　南无坚固义佛　南无智光明佛　南无香威德佛　南无无病修佛　南无海觉佛　南无胜色佛　南无善步佛　南无吼称佛　南无觉身佛　南无然灯日佛　南无智慧足佛　南无定身佛　南无威德无尽佛　南无功德乘佛　南无金乘佛　南无放结佛　南无法行佛　南无善住去佛　南无离慢佛　南无智藏佛　南无净去佛　南无栴檀佛　南无无忧佛　南无清净身幢佛　南无无国土华佛　南无无量威德佛　南无天光明佛　南无智慧华佛　南无一味手佛　南无成就智佛　南无净住佛　南无自在佛　南无无比说佛　南无胜说佛　南无福德威德佛　南无日光佛　南无度世间智佛　南无得成就佛　南无救一切世间苦恼佛　南无法行佛　南无求安隐佛　南无色智佛　南无无创佛　南无合掌光明佛　南无琉璃藏佛　南无华天佛　南无自然佛　南无善根光明佛　南无一切功德胜光明佛　南无宝胜佛　南无日月佛　南无降伏怨佛　南无无量光明佛　南无须摩那树提光明佛　南无增上佛　南无乐智慧佛　南无功德自在佛　南无寂静佛　南无功德积力佛　南无善眼佛　南无善声佛　南无善华佛　南无善住佛　南无功德威德聚佛　南无无边智佛　南无无量声佛　南无善光佛　南无善智慧佛　南无解脱义佛　南无思惟胜佛　南无胜声身佛　南无快说佛　南无胜行佛　南无寂静义佛　南无善过佛　南无清净行佛　南无华作佛　南无善光佛　南无常然灯佛　南无善量佛　南无众自在佛　南无离畏佛　南无智怖佛　南无善逝乐说佛　南无胜眼佛　南无菩提月佛　南无宝光明佛　南无月王佛　南无无畏佛　南无大镜佛　南无梵声佛　南无善声佛　南无大智慧桥梁佛　南无普智慧佛　南无金刚仙佛　南无伏心佛　南无树王佛　南无数声佛　南无功德力佛　南无住胜佛　南无爱圣佛　南无威德佛　南无树提味佛　南无妙鼓云声佛　南无爱眼佛　南无贤智佛　南无成就功德胜佛　南无寂静吼佛　南无法幢佛　南无虚空功德声佛　南无功德差别佛　南无功德声佛　南无威德佛　南无圣行佛　南无有智佛　南无乐说月佛　南无善寂灭佛　南无月面佛　南无日月无垢佛　南无集功德佛　南无华福德佛　南无忆乐说国土佛　南无恭敬爱佛　南无无量师子力佛　南无自在王佛　南无无量信佛　南无平等思惟佛　南无恬惔思惟佛　南无不动寂静佛　南无无垢光佛　南无平等行佛　南无不扰佛　南无不浊佛　南无不动佛　南无善行佛　南无善住调智佛　南无说自在佛　南无大天佛　南无深意佛　南无无量佛　南无法力佛　南无应供佛　南无供养华光佛　南无三界供养佛　南无日藏佛　南无他供养佛　南无解脱幢佛　南无快结佛　南无甘露清净佛　南无金刚坚佛　南无宝聚光明佛　南无快步佛　南无日清净光明佛　南无功德积佛　南无阿楼那胜佛　南无师子去佛　南无胜上佛　南无华德佛　南无放光明佛　南无波头摩智爱佛　南无快庄严佛　南无不空行佛　南无合创佛　南无幢光明幢佛　南无乐心佛　南无乐解脱佛　南无智净佛　南无闻慧海佛　南无宝住持佛　南无拘峻庄严佛　南无孔雀声佛　南无不属佛　南无断爱根佛　南无月起佛　南无海胜佛　南无不动合去佛　南无乐功德然灯佛　南无教声佛　南无地主佛　南无威德力佛　南无住智慧佛　南无善月佛　南无觉华佛　南无善赞叹佛　南无善处佛　南无力智威德加佛　南无然灯坚固佛　南无奋迅佛　南无天声佛　南无寂静佛　南无日面佛　南无乐解脱佛　南无界光明佛　南无住行佛　南无无垢佛　南无坚固起佛　南无乐智自在佛　南无香光明佛　南无广光明佛　南无念自在佛　南无甘露器佛　南无无碍幢佛　南无求胜菩提佛　南无信行佛　南无宝惭愧佛　南无法用佛　南无一切威德佛　南无大亲佛　南无寂静行佛　南无甘露增上佛　南无弥留光佛　南无圣赞叹佛　南无生威德佛　南无光明见佛　南无善修果报佛　南无善德庄严佛　南无宝光明佛　南无寂静功德步佛　南无功德海佛　南无种种色佛　南无降伏魔佛　南无闭塞魔佛　南无度一切难佛　南无不破境智佛　南无海文饰佛　南无得胜众解脱王佛　南无爱佛　南无佛幢佛　南无智声佛　南无善胜佛　南无净命佛　南无智报佛　南无如意幢佛　南无世间自在劫佛　南无地住持佛　南无日爱佛　南无罗睺月佛　南无华光明佛　南无明增上佛　南无威德住持佛　南无乐功德佛　南无乐力佛　南无乐功德王佛　南无乐力明佛　南无善声佛　南无法自在佛　南无梵声佛　南无善思惟佛　南无大志智慧佛　南无大施佛　南无月称佛　南无幢王佛　南无称人声佛　南无树王佛　南无灭闇佛　南无善星佛　南无善光佛　南无无量乐说幢佛　南无快行福德佛　南无度系佛　南无无畏爱佛　南无世间爱佛　南无妙行佛　南无忧波罗华鬘佛　南无无量乐说光明佛　南无信圣人佛　南无精进功德佛　南无坚甘露增上佛　南无高宝信佛　南无得功德佛　南无福德慧佛　南无大炎佛　南无无量威德功德佛　南无师子步佛　南无不动信佛　南无过有佛　南无龙王声佛　南无住持轮佛　南无胜色佛　南无世爱佛　南无法月佛　南无无量乐称佛　南无云幢佛　南无功德去佛　南无善逝佛　南无无量声佛　南无虚空天佛　南无摩尼王佛　南无清净行佛　南无然灯佛　南无宝吼声佛　南无人自在王佛　南无罗睺护佛　南无无畏佛　南无师子慧佛　南无宝称佛　南无辨义见佛　南无世间华佛　南无高步佛　南无等月王佛　南无乐说王佛　南无差别智佛　南无智自在佛　南无师子齿佛　南无快步佛　南无功德然灯月佛　南无无忧国土佛　南无意思智慧佛　南无法天炎尊佛　南无舍调佛　南无增上力佛　南无智慧华佛　南无坚固声佛　南无常乐佛　南无说义佛　南无信爱作佛　南无师子业结佛　南无怖魔佛　南无宝海佛　南无宝英佛　南无宝幢幡佛　南无无量音佛　南无大名称佛　南无德大安隐佛　南无无限净佛　南无正音声佛　南无月音佛　南无无限名称佛　南无无量宝佛　南无莲华最尊佛　南无身尊佛　南无梵自在王佛　南无金海佛　南无一切香自在王佛　南无树王丰长佛　南无勇猛执持牢杖弃舍斗战佛　南无内丰珠光佛　南无无量香光明佛　南无师子乡佛　南无大强精进力佛　南无过出坚住佛　南无鼓音王佛　南无日月英佛　南无超出众华佛　南无世灯明佛　南无休多易宁佛　南无常灭度佛　南无净觉佛　南无一切众宝普集佛　南无树王长佛

次礼十二都尊经大藏法轮

南无舍利弗问经　南无大爱道比丘尼经　南无真伪沙门经　南无戒消灾经　南无迦叶禁戒经　南无犯戒罪报轻重经　南无僧祇比丘尼戒本　南无十诵比丘戒本　南无十诵比丘尼戒本　南无四分比丘尼戒本　南无比丘威仪经　南无优婆塞五戒威仪经　南无优波离问经　南无毗尼母经　南无萨婆多毗尼毗婆沙论　南无阿毗昙毗婆沙论　南无阿毗昙八揵度论　南无舍利弗阿毗昙论　南无鞞婆沙阿毗昙论　南无出曜论　南无尊婆须蜜所集论　南无立世阿毗昙论　南无俱舍论　南无法胜阿毗昙论　南无十八部论　南无四谛论　南无部异执论　南无明了论　南无随相论　南无成实论　南无解脱道论　南无阿毗昙心论　南无三法度论　南无杂阿毗昙心论　南无众事分阿毗昙论　南无甘露味阿毗昙论　南无三弥底论　南无分别功德论　南无摩诃比丘经　南无婆和罗经　南无沙门头陀经　南无生死变识经　南无佛说正意经　南无摩诃刹头经　南无胞胎受身经　南无贤者夫人经　南无金刚清净经　南无威势长者观身行经　南无决诸法如幻三昧经　南无佛刹菩萨学成经

敬礼十方诸大菩萨摩诃萨

南无甘露声菩萨　南无寂行菩萨　南无法云吼菩萨　南无得脱一切缚菩萨　南无法云王满足菩萨　南无甘露点王菩萨　南无尼拘律王菩萨　南无无畏菩萨　南无净胜菩萨　南无胜眼菩萨　南无药王菩萨南无甘露光菩萨　南无无障碍受记菩萨　南无无边光菩萨　南无断诸魔菩萨　南无过一切道菩萨　南无无缺意菩萨　南无满濡尸利菩萨　南无功德林菩萨　南无善财童子菩萨　南无转不退法轮菩萨　南无离垢净菩萨　南无除诸盖菩萨　南无示威仪见皆爱喜菩萨　南无妙相严净王意菩萨　南无不诳一切众生菩萨　南无诸根常定不乱菩萨　南无一切天赞菩萨　南无若鸠罗菩萨　南无远鸠罗菩萨　南无鸠陀菩萨　南无秀伽伽罗菩萨　南无日陈菩萨　南无远多罗菩萨　南无罗邻竭菩萨　南无憍目兜菩萨　南无边陀罗菩萨　南无颰陀和菩萨　南无那罗达菩萨　南无须弥深菩萨　南无和轮调菩萨　南无因坻达菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无善吉辟支佛　南无不可心辟支佛　南无善住辟支佛　南无无比辟支佛　南无无憍慢辟支佛　南无劬多辟支佛　南无断爱辟支佛　南无耳辟支佛　南无心得解脱辟支佛　南无忧波耳辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等已共相忏悔身三业竟。今当次第忏悔口四恶业。经中说言。口业之罪能令众生堕于地狱饿鬼受苦。若在畜生则受鸺鹠枭鹫鸟形。闻其声者无不憎恶。若生人中口气常臭。所有言说人不信。受眷属不和常好斗诤。口业既有如是恶果。是故弟子今日至诚归依佛

南无东方须弥灯王佛　南无南方大功德佛　南无西方无量力佛　南无北方觉花生德佛　南无东南方一切觉花佛南无西南方无量辨才佛　南无西北方莲花生王佛　南无东北方灭一切忧佛　南无下方至光明王佛　南无上方电灯王幢佛

归命如是等十方尽虚空界一切三宝

弟子等自从无始已来至于今日。妄语两舌恶口绮语。传空说有说有言空。不见言见见言不见。不闻言闻闻言不闻。不知言知知言不知。欺贤罔圣言行相乖。自称赞誉得过人法。我得四禅四无色定阿那般那十六行观。得须陀洹至阿罗汉。我得辟支佛不退菩萨。天来龙来鬼来神来。旋风土鬼皆至我所。彼问我答。显异惑众要世名利。如是等罪无量无边。今日发露归命忏悔

又复弟子等。从无始已来至于今日。或谗言斗乱交扇彼此。两舌谰构贩拽口舌。向彼说此向此道彼。离他眷属破他婚亲。穷他口舌说人长短坏人善友。使狎密者为疏。亲旧者成怨。或绮语不实言不及义。诬谤君父评薄师长。破坏忠良埋没胜己。通致二国彼此扇作。浮华虚巧发言常虚。口是心非其途非一。对面誉叹背则呵毁。赞诵耶书传耶恶法或恶口詈骂言语粗穬。或呼天指地牵引鬼神。如是口业所生诸罪无量无边。今日至诚向十方佛尊法圣众前。归命忏悔

愿弟子等。承是忏悔口业等罪所生功德。愿生生世世具八音声四无碍辩。常说和合利益之语。其声清雅一切乐闻。善解众生方俗言语。若有所说应时应限。令彼听者则得解悟。超凡入圣开发慧眼

    大乘莲华宝达问答报应沙门经

宝达顷前入一拔舌地狱。云何名曰拔舌地狱。其地狱纵广五十由旬周匝铁城。铁网罗覆。门有铜狗大十由旬口眼火出。其地狱中自然刀刃銐如锋铓猛火炎赫。铁城四角有大毒蛇广张其口。口眼火出来烧罪人。狱卒夜叉扶大铁犁耕罪人舌。尔时北门之中有五百罪人望见狱中。亡魂碎胆宛转于地而不肯前。各言我今何罪入于此处。马头罗刹手捉铁棒。望头而打身则磨灭。复有饿鬼来啖其肉。复有饿狗来啮其骨。巧风吹之须臾便活。马头罗刹手捉铁钩。望背而搭胸前而出。钩所著处应钩火然。左右通彻身心俱烂。狱卒夜叉拔罪人舌。舌广长大遍布狱中铁犁耕之。犁所入处流血滂沱。寻血火起其中。刀刃仰刺罪人。如是受罪苦痛百端。复有铁斧斫罪人舌。寸寸而碎聚成肉山。一日一夜受罪无量。万死万生千死千生。宝达问马头罗刹曰。此诸罪人作何等业。受苦如是。马头罗刹答曰。此诸罪人受佛净戒而不护持。两舌恶骂诽谤他人。毁辱良善传虚作实咀咒万端。以是因缘堕此地狱。经千万劫无有出期。后若得出常作畜生鸺鹠鸱枭。所作音声人不喜闻。若生人中百生千生聋盲喑哑。口气常臭为他所憎。宝达菩萨闻之悲泣。而说偈言

  悲哉不可量　　乃入邪见道
  云何到彼岸　　还溺大海中
  云何了生死　　翻为无知惑
  云何得解脱　　而复被邪萦
  云何出世人　　乃作非非说

宝达菩萨说偈而去

佛名经卷第八佛说佛名经卷第九

若有善男子善女人。能受持读诵是贤劫千佛名者。必见弥勒世尊及见卢至。远离诸难

南无月光明佛　南无不动佛　南无大庄严佛　南无多伽罗香佛　南无妙胜佛　南无波头摩幢佛　南无宝聚佛　南无沉水香佛　南无大庄严佛　南无喜胜佛　南无山海佛　南无大海佛　南无法幢称佛　南无梵胜佛　南无大香佛　南无大成就佛　南无大宝轮佛　南无无量寿佛　南无大高胜佛　南无大金台佛　南无大轮佛　南无语作佛　南无大人佛　南无大手佛　南无师子香称佛　南无供养胜佛　南无自在火佛　南无安乐作胜佛　南无师子华胜佛　南无寂静幢佛　南无戒王佛　南无普胜佛　南无怖象佛　南无无忧胜佛　南无优波罗香佛　南无大地佛　南无大龙胜佛　南无清净王佛　南无大乐佛　南无波头摩胜佛　南无舍拘苏摩佛　南无龙妙佛　南无华聚佛　南无香象佛　南无常观佛　南无正作佛　南无善住佛　南无尼拘律王佛　南无常光佛　南无月胜佛　南无栴檀行佛　南无日藏佛　南无胜藏佛　南无须弥力佛　南无如意藏佛　南无金刚王佛　南无难胜佛　南无大胜佛　南无善见佛　南无精进德佛　南无大海佛　南无普莎罗佛　南无宿胜佛　南无佛天佛　南无师子幢佛　南无甘露胜佛　南无无量胜佛　南无功德慧厚胜佛　南无华幢佛　南无首胜佛　南无精进胜佛　南无龙胜佛　南无胜成就佛　南无宝积佛　南无胜足佛　南无大师佛　南无普见佛　南无宝多罗佛　南无普至佛　南无恭敬胜佛　南无断一切众生疑王佛　南无大念佛　南无宝胜佛　南无普盖佛　南无大盖佛　南无妙胜佛　南无千供养佛　南无宝华步佛　南无众胜佛　南无幢慧佛　南无尼拘律王佛　南无上胜佛　南无普波头摩佛　南无普胜佛　南无龙王护众佛　南无寂灭佛　南无远离垢佛　南无大聚佛　南无大供养佛　南无大将佛　南无坚固勇猛佛　南无人月佛　南无善见佛　南无上胜佛　南无波头摩胜佛　南无阇轮威德佛　南无胜月佛　南无能仁佛　南无然灯佛　南无大威德佛　南无月面佛　南无栴檀香佛　南无弥留山佛　南无弥留劫佛　南无大面佛　南无无染佛　南无龙天佛　南无山声自在王佛　南无须弥山佛　南无金藏佛　南无火光佛　南无树提自在王佛　南无地寂佛　南无胜琉璃金光明佛　南无月像佛　南无月声佛　南无散华光明庄严佛　南无海山智慧奋迅通佛　南无金刚光佛　南无大香光佛　南无远离嗔恨心佛　南无胜琉璃快智慧俱苏摩佛　南无月光佛　南无日光王佛　南无华鬘色王佛　南无华通佛　南无水月光佛　南无破无明闇佛　南无得乐说佛　南无无畏王佛　南无然明佛　南无师子意佛　南无精进坚固佛　南无不坏精进佛　南无坚固勇猛佛　南无人月佛　南无师子慧佛　南无阎浮上佛　南无释迦牟尼佛　南无大势佛　南无快声佛　南无无量光佛　南无妙光佛　南无上首佛　南无上胜佛　南无乐吼佛　南无见实佛　南无供养称佛　南无师子慧佛　南无声德佛　南无善香佛　南无电灯佛　南无波头摩光佛　南无大灯佛　南无净声佛　南无破疑佛　南无无边威德佛　南无赊尸面佛　南无无量名佛　南无妙威德佛　南无散异疑佛　南无福德灯佛　南无善见佛　南无爱威德佛　南无不可降伏威德佛　南无无量藏佛　南无光明奋迅佛　南无广称佛　南无异幢佛　南无不可胜佛　南无威德王佛　南无坚固佛　南无妙称佛　南无无量色佛　南无大信佛　南无妙声佛　南无不动步佛　南无无量庄严佛　南无威德王聚光明佛　南无住智慧光佛　南无住智慧佛　南无金坚佛　南无爱解脱佛　南无能与无畏佛　南无甘露藏佛　南无普观佛　南无大须弥佛　南无山威德佛　南无天供养佛　南无光明胜佛　南无说重佛　南无庄严光明佛　南无师子奋迅佛　南无异见佛　南无遍见佛　南无甘露步佛　南无月光明佛　南无称供养佛　南无护根佛　南无清净声佛　南无无障碍轮佛　南无甘露声佛　南无离生佛　南无空威德佛　南无功德王佛　南无无量色佛　南无大力佛　南无黠慧庄严佛　南无见无障碍佛　南无师子香佛　南无普见佛　南无普德佛　南无善见佛　南无善色佛　南无慧称佛　南无宝庄严佛　南无妙光佛　南无解脱奋迅佛　南无功德庄严佛　南无毕竟智佛　南无智高佛　南无不动智佛　南无善威仪佛　南无快色佛　南无实声佛　南无火声佛　南无善见佛　南无无量威德佛　南无妙思惟佛　南无爱称佛　南无功德华佛　南无俱苏摩炎佛　南无难降伏佛　南无妙声吼佛　南无善见佛　南无众生可敬佛　南无炎明佛　南无无比步佛　南无清净智佛　南无快声佛　南无火照佛　南无月照佛　南无智化佛　南无功德庄严佛　南无福德光明佛　南无智作佛　南无断有见佛　南无见爱佛　南无无量光佛　南无胜声佛　南无种种日佛　南无戒步佛　南无天面佛　南无放盖佛　南无波婆娑佛　南无星宿佛　南无觉慧佛　南无吼声佛　南无增上师子种种象吼声佛　南无梵声佛　南无龙吼佛　南无势自在佛　南无世间自在王佛　南无无量命佛　南无然灯佛　南无无垢盖佛　南无宝光明佛　南无大威德面佛　南无然灯佛　南无光明胜王佛　南无普照佛　南无智慧奋迅王佛　南无可量华佛　南无下华佛　南无庄严胜散华佛　南无卢舍那智慧庄严奋迅王佛　南无无量花佛　南无无量众上首王佛　南无月摩尼光罗网佛　南无无垢威德王佛　南无胜成就佛　南无安隐佛　南无高行佛　南无欢喜佛　南无坚固佛　南无善眼佛　南无善意佛　南无六十二同名尸弃佛　南无善生佛　南无净圣佛　南无梵胜佛　南无善见佛　南无清净智佛　南无快声佛　南无上胜佛　南无上修佛　南无妙胜佛　南无寂静命佛　南无不厌足法佛　南无得功德佛　南无阳炎佛　南无称上佛　南无吉沙佛　南无星宿佛　南无了见佛　南无无量命佛　南无见义佛　南无高山佛　南无金圣佛　南无一切处自在佛　南无自在幢佛　南无净声佛　南无妙声佛　南无人声佛　南无宝上佛　南无宝炎佛　南无大宝佛　南无八十亿那由他同名释迦牟尼佛　南无八十千同名然灯佛　南无一万八千同名莎罗王佛　南无九万同名尼拘律王佛　南无五千同名波头摩王佛　南无无同佛名佛　南无功德王光明佛　南无智胜上王佛　南无无垢智戒王佛　南无阎浮檀须弥山王佛　南无无量光明胜王佛　南无常放光明王佛　南无自在王佛　南无师子受象山欢喜王佛　南无无垢称王佛　南无宝杖功德王光佛　南无无尽智慧佛　南无宝幢佛　南无光明轮藏佛　南无奋迅恭敬称佛　南无高胜山王佛　南无云护佛　南无师子奋迅王佛　南无护妙法幢宝佛　南无宝轮威德佛　南无胜光明功德佛　南无无量国土佛　南无爱星宿佛　南无无量光明佛　南无有德佛　南无十方清净佛　南无善智慧佛　南无胜魔佛　南无大庄严佛　南无胜心佛　南无心智佛　南无华藏佛　南无大力佛　南无常择智慧佛　南无无边光佛　南无师子声佛　南无妙智佛　南无波头摩藏佛　南无那罗延藏佛　南无常决定智佛　南无福德光明佛　南无上首光佛　南无快身佛　南无无垢义佛　南无应威德佛　南无成就智佛　南无德吼佛　南无舍地佛　南无妙光佛　南无决定思佛　南无宝日佛　南无威德光明佛　南无华威德佛　南无胜成佛　南无称高佛　南无信功德佛　南无法灯佛　南无信胜佛　南无上爱面佛　南无师子奋迅佛　南无众山天佛　南无海智佛　南无华藏佛　南无宝仙佛　南无莎罗王佛　南无日光明佛　南无趣菩提佛　南无寂根王佛　南无日光佛　南无芬陀利香佛　南无弥留光佛　南无月面佛

次礼十二部尊经大藏法轮

南无放光般若波罗蜜经　南无光赞般若波罗蜜经　南无道行般若波罗蜜经　南无小品般若经　南无新道行经　南无新小品经　南无明度经　南无大明度无极经　南无悲华经　南无大悲分陀利经　南无念佛三昧经　南无大方等大集菩萨念佛三昧经　南无正法华经　南无妙法莲华经　南无入楞伽经　南无楞伽阿跋多罗经　南无大萨遮尼干子经　南无宝幢经　南无菩萨行方便境界神通变化经　南无大般泥洹经　南无大哀经　南无虚空藏所问经　南无阿差末经　南无无尽意经　南无宝女经　南无菩萨净行经　南无宝髻菩萨经　南无无言童子经　南无大树紧那罗王所问经　南无屯真陀罗所问经　南无持人菩萨所问经　南无持世经　南无弘道广显三昧经　南无法师经　南无阿耨达龙王经　南无阿耨请佛经　南无普超三昧经　南无阿阇世王经　南无等集众德三昧经　南无集一切福德三昧经　南无大方等善住意太子所问经　南无圣善住意天子所问经　南无如幻三昧经　南无广博严净不退转经　南无阿惟越致遮经

敬礼十方诸大菩萨摩诃萨

南无尊胜菩萨　南无甘露鼓菩萨　南无甘露称菩萨　南无甘露光菩萨　南无甘露名菩萨　南无甘露响菩萨　南无娑罗树王菩萨　南无一切智音菩萨　南无一切智相菩萨　南无称相菩萨　南无甘露入菩萨　南无普慧菩萨　南无普增上菩萨　南无普光菩萨　南无普称菩萨　南无普相菩萨　南无普王菩萨　南无普德相自在王菩萨　南无微妙声菩萨　南无胜相菩萨　南无无能胜菩萨　南无普眼菩萨　南无普见德菩萨　南无现无过恶菩萨　南无离过菩萨　南无无过恶菩萨　南无一切众生不请之友菩萨　南无不舍一切众生菩萨　南无常乐集一切功德菩萨　南无善上乘菩萨　南无第一功德名称菩萨　南无法才菩萨　南无宝柱菩萨　南无虚空性菩萨　南无善住菩萨　南无虚空藏海菩萨　南无德慧菩萨　南无尔炎圣觉达菩萨　南无胜达菩萨　南无玄达菩萨　归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无吉辟支佛　南无差摩辟支佛　南无遮罗辟支佛　南无忧波遮罗辟支佛　南无梨沙婆辟支佛　南无菩莎他净辟支佛　南无善香担辟支佛　南无阿沙罗辟支佛　南无忧婆沙罗辟支佛　南无波头辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等。已忏悔身三口四竟。次复忏悔佛法僧间一切诸障。是故经中说。人身难得佛法难闻。众僧难值信心难生。六根难具善友难得怖心难发。而今相与宿植善根得此人身六根完具。又值善友得闻正法。于其中间复各不能尽心精勤。恐于未来长溺万苦无有出期。是故今日应须至诚惭愧。稽颡归依佛

南无东方满月光明佛　南无南方自在王佛　南无西方无边光佛　南无北方金刚王佛　南无东南方师子音佛　南无西南方香象游戏佛　南无西北方须弥相佛　南无东北方宝最高德佛　南无下方宝优钵花佛　南无上方广众德佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始已来至于今日。常以无明覆心烦恼障重。见佛形像不能尽心恭敬。轻慢众僧残虐善友。破塔毁寺焚烧形像。出佛身血或自处华堂。安置尊像卑猥之处。使烟薰日暴风吹雨露。尘土粪污雀鼠残毁。共住共宿。曾无礼敬或倮露像身。永不严饰。或遮掩灯烛开闭殿宇障佛光明。如是等罪无量无边。今日至诚发露忏悔

又复弟子等。从无始已来至于今日。或于法间以不净手把捉经卷。或临经书非法俗话。或安置床头坐起不敬。或开闭箱箧虫啖朽烂。或首轴脱落部党失次。或参脱漏误纸墨破裂。自不修理不肯流转。如是等罪无量无边。今日发露归命忏悔。

或眠地听经仰卧读诵。高声语笑乱他听法。或邪解佛语僻说听意。非法说法法说非法。非犯说犯犯说非犯。轻罪说重重罪说轻。或抄前着后抄后着前。前后着中中着前后。绮饰文辞安置已典。或为利养名誉恭敬为人说法。无道德心求法师过。而为论议非理弹击。不为长解求出世法。或轻慢佛语尊重邪教。毁呰大乘赞声闻道。如是等罪无量无边。今日至心发露忏悔

又复弟子等。从无始已来至于今日。或于僧间有障。杀害阿罗汉破和合僧。害发无上菩提心人。断灭佛种使道不行。或罢人道鞭拷沙门。楚挞驱役苦言加谤。或破戒破齐破于威仪。或劝他人舍于梵行受行五欲。或假托形仪窥窃贼住。如是等罪无量无边。今日惭愧至心忏悔

弟子等。从无始已来至于今日。或裸形单服在经像前。不净脚履蹻上殿塔。或着[尸@(棄-ㄊ)]屐入僧伽蓝。涕唾堂房污佛僧地。或共僧同宿污彼法衣乘车策马排揬寺舍。如是等罪于三宝间所起罪障无量无边。今日至诚向十方佛尊法圣众前。归命忏悔

愿弟子等。承是忏悔佛法僧间所有罪障所生功德。愿生生世世常值三宝。尊仰恭敬无有厌足。天缯妙彩宝绞络台。百千妓乐珍异华香。非世所有常以供养。若未成佛先往劝请开甘露门。若入涅槃愿我常得献最后供。于众僧中修六和敬。得自在力兴隆三宝。上弘佛道下化众生

    大乘莲华宝达问答报应沙门经

宝达顷前入烧脚地狱。云何名曰烧脚地狱。其地狱纵广七十由旬。周匝铁城铁壁铁网罗覆其中。猛火炎炽来烧罪人。或有铁锵銐如锋铓来锵罪人。地上火然间无空处。西门之中有八千沙门。唱如是言。我今何罪来入此中。马头罗刹手捉铁捧。望头而推罪人前入。以脚往蹴铁锵刺之步步而倒。一日一夜受罪万端。千生千死万生万死。从地狱出或生人中身不具足

宝达闻之悲泣而言。此人作何业行来入其中。马头罗刹答曰。此诸沙门受佛净戒而不净持。脚足不净来行佛地僧地。或乘驴马游行佛像门户前而去。心无惭愧。以此罪故堕是地狱。宝达闻之悲泣而去

佛名经卷第九佛说佛名经卷第十

南无妙步佛　南无观十方佛　南无德光明佛　南无清净戒佛　南无无边智佛　南无无边步佛　南无坚精进佛　南无天供养佛　南无普智佛　南无寂光佛　南无仁威德佛　南无功德桥梁佛　南无坚固修佛　南无称圣佛　南无称幢佛　南无不异心佛　南无普信佛　南无大威德佛　南无应供养佛　南无上功德佛　南无成就义修行佛　南无爱供养佛　南无普护佛　南无信菩提佛　南无心意佛　南无出智佛　南无山声佛　南无性日佛　南无云声佛　南无大炎聚佛　南无胜积佛　南无无忧佛　南无天国土佛　南无师子欣声佛　南无无量明佛　南无见爱佛　南无然灯佛　南无胜高佛　南无十方闻名佛　南无爱眼佛　南无月高佛　南无能与无畏佛　南无星宿王佛　南无月天佛　南无光明日佛　南无大称佛　南无真声佛　南无爱说佛　南无称上佛　南无天王佛　南无甘露明佛　南无乐声佛　南无心意佛　南无地住佛　南无寂过佛　南无多罗王佛　南无无畏佛　南无清净智佛　南无能破疑佛　南无慈胜佛　南无胜上佛　南无种种日佛　南无普见佛　南无见月佛　南无降伏魔佛　南无大首佛　南无师子奋迅去佛　南无威德光佛　南无普护佛　南无成就义威德佛　南无光明日佛　南无见聚佛　南无清净意佛　南无香山佛　南无摩尼清净佛　南无功德明佛　南无日然灯佛　南无成就光佛　南无乐说法佛　南无善思惟义佛　南无普现见佛　南无师子幢佛　南无苦行佛　南无大步佛　南无莲华眼佛　南无莲华光佛　南无照光佛　南无信无量佛　南无无量色佛　南无盖天佛　南无宝光明佛　南无上首佛　南无善见佛　南无亲味佛　南无德味佛　南无日面佛　南无无障碍眼佛　南无师子步佛　南无火灯佛　南无生胜佛　南无信功德佛　南无福德藏佛　南无法幢佛　南无天爱佛　南无无畏佛　南无爱法佛　南无智胜佛　南无威德光佛　南无月德佛　南无功德聚佛　南无无边光佛　南无安乐佛　南无称幢佛　南无光明吼佛　南无普功德佛　南无上幢佛　南无那罗延佛　南无宝信佛　南无普思惟佛　南无善思惟佛　南无普智佛　南无不可量威德佛　南无师子臂佛　南无光明意佛　南无王天佛　南无宝幢佛　南无善住意佛　南无无量天佛　南无圣化佛　南无大功德佛　南无大幢佛　南无大光日佛　南无真法佛　南无日月佛　南无真报佛　南无胜天佛　南无观解脱佛　南无宝光明佛　南无孔雀声佛　南无普行佛　南无成就光佛　南无无量眼佛　南无称爱佛　南无善护佛　南无信天佛　南无不可量步佛　南无大威佛　南无心智佛　南无仙步佛　南无日形佛　南无火聚佛　南无大修佛　南无大步佛　南无胜天佛　南无成就义修佛　南无月爱佛　南无师子声佛　南无信说佛　南无智光佛　南无华威德佛　南无光明聚佛　南无神通光明佛　南无无量威德佛　南无无量光佛　南无胜藏佛　南无普照称佛　南无宝幢佛　南无胜威德佛　南无日幢佛　南无大弥留佛　南无供养庄严佛　南无世间闻名佛　南无胜德佛　南无胜称佛　南无成就步佛　南无天供养佛　南无宝声佛　南无不可降伏称佛　南无应光明佛　南无大灯佛　南无行威仪畏佛　南无奋迅佛　南无无障碍见佛　南无离疑佛　南无大行佛　南无不失步佛　南无天国土佛　南无喜菩提佛　南无华光佛　南无能与光明佛　南无天爱佛　南无解脱光明佛　南无放光明佛　南无作功德佛　南无成智佛　南无道光佛　南无海王佛　南无喜菩提佛　南无法光佛　南无大天佛　南无深智佛　南无法自在佛　南无大信佛　南无心意佛　南无智光信佛　南无不谬思佛　南无起福德佛　南无漏称佛　南无大庄严佛　南无月光佛　南无天光佛　南无清净行佛　南无功德爱佛　南无师子意佛　南无地清净佛　南无宝光明佛　南无快光明佛　南无称种日佛　南无日爱佛　南无月盖佛　南无普观佛　南无无染佛　南无称胜佛　南无月面佛　南无龙天佛　南无功德聚佛　南无功德智佛　南无华胜佛　南无世爱佛　南无甘露威德佛　南无宝幢佛　南无日光明佛　南无甘露光佛　南无说法爱佛　南无应爱佛　南无地光佛　南无功德作佛　南无华胜佛　南无功德臂佛　南无法灯佛　南无普光佛　南无梵声佛　南无大庄严佛　南无解脱日佛　南无坚精进佛　南无佛光明佛　南无功德称佛　南无善智慧佛　南无不可量庄严佛　南无师子爱佛　南无功德步佛　南无上天佛　南无观行佛　南无日天佛　南无电光佛　南无胜爱佛　南无弥留幢佛　南无华光佛　南无上意佛　南无香山佛　南无功德奋迅佛　南无胜意佛　南无信圣佛　南无宝洲佛　南无上威德佛　南无最后见佛　南无欢喜庄严佛　南无功德藏胜佛　南无无垢镜佛　南无威德力佛　南无清净眼佛　南无智行佛　南无不谬足佛　南无圣眼佛　南无乐解脱佛　南无大声佛　南无上国土佛　南无修行光明佛　南无念业佛　南无信功德佛　南无卢舍那称佛　南无照闇佛　南无爱自在佛　南无月光佛　南无上声佛　南无功德胜佛　南无摄爱择佛　南无相王佛　南无离热病智佛　南无能与圣佛　南无法洲佛　南无甘露功德佛　南无无嗔恨佛　南无甘露香佛　南无月明佛　南无吼声佛　南无无畏日佛　南无得无畏佛　南无喜爱佛　南无不错智佛　南无世爱佛　南无天灯佛　南无信圣佛　南无天盖佛　南无龙光佛　南无胜步佛　南无法威德佛　南无见有佛　南无惭愧面佛　南无胜色佛　南无普眼佛　南无功德光佛　南无月胜佛　南无定实佛　南无功德幢佛　南无世自在劫佛　南无无畏亲佛　南无摄智佛　南无降怨佛　南无法光明佛　南无胜积佛　南无一念光佛　南无力士奋迅佛　南无师子足佛　南无戒爱佛　南无信世间佛　南无胜威德光明佛　南无师子奋迅须佛　南无无垢去佛　南无月光佛　南无上声佛　南无决定智佛　南无离无明佛　南无功德聚佛　南无摄慧佛　南无大智味佛　南无实步佛　南无心日佛　南无观方佛　南无信说佛　南无思惟忍佛　南无法盖佛　南无不可降伏月佛　南无天华佛　南无天波头摩佛　南无普威德佛　南无月明佛　南无功德庄严佛　南无相王佛　南无称思惟佛　南无树幢佛　南无净行佛　南无威德步佛　南无信众佛　南无善香佛　南无智者赞叹佛　南无智慧光明佛　南无智铠佛　南无威德力佛　南无胜威德佛　南无佛欢喜佛　南无胜信佛　南无一切爱佛　南无离诸恶佛　南无思义佛　南无大高佛　南无圣人面佛　南无黠慧信佛　南无摄菩提佛　南无妙声佛　南无大威德佛　南无乐师子佛　南无普宝佛　南无一切世爱佛　南无分金刚佛　南无师子声佛　南无过火佛　南无导师佛　南无人月佛　南无大庄严佛　南无日光佛　南无快见佛　南无普摩尼香佛　南无寂行佛　南无摄称佛　南无梵供养佛　南无大吼佛　南无应供养佛　南无黠慧信佛　南无无量愿佛　南无世光佛　南无见忍佛　南无大华佛　南无有我佛　南无如意佛　南无善菩提根佛　南无地德佛　南无天德佛　南无不怯弱声佛　南无普现佛　南无月光明佛　南无胜信佛

次礼十二部尊经大藏法轮

南无不退转法轮经　南无胜思惟梵天所问经　南无思益梵天问经　南无持心梵天所问经　南无度世经　南无渐备一切智德经　南无信力入印法门经　南无十住经　南无如来兴显经　南无罗摩伽经　南无菩萨十住经　南无菩萨本业经　南无诸菩萨求佛本业经　南无诸法本无经　南无道神足无极变化经　南无诸法无行经　南无佛升忉利天为母说法经　南无维摩诘所说经　南无维摩诘经　南无宝如来三昧经　南无宝星陀罗尼经　南无无极宝三昧经　南无雪山无猿猴经　南无四童子经　南无孤儿经贫女经　南无方等泥洹经　南无贤愚者经　南无哀泣经　南无日天经维摩诘经　南无道德彰经　南无大乘方便经　南无发菩萨心经　南无慧上菩萨问大善权经　南无悭贪长者经　南无摩诃衍经　南无文殊师利现宝藏经　南无更出小品经　南无大方广宝箧经　南无奋迅王问经　南无普贤菩萨证功德经　南无自在王经　南无究竟大悲经　南无大庄严法门经　南无师子畜生王经　南无大净法门经　南无女人欲荒经

敬礼十方诸大菩萨摩诃萨

南无观佛菩萨　南无金刚吼菩萨　南无龙王吼菩萨　南无无畏十力吼菩萨　南无雷电吼菩萨　南无无量力吼菩萨　南无大威德藏菩萨　南无无忧藏菩萨　南无大辨藏菩萨　南无导首菩萨　南无华幢菩萨　南无华光菩萨　南无宝杖菩萨　南无毗摩颰罗菩萨　南无师子吼王菩萨　南无师子游戏菩萨　南无师子精进菩萨　南无勇锐力菩萨　南无师子威猛伏菩萨　南无庄严菩萨　南无大庄严菩萨　南无出生菩萨　南无大愿法海净菩萨　南无毗摩罗伽菩萨　南无和轮调菩萨　南无信相菩萨　南无辩才庄严菩萨　南无须弥顶王菩萨　南无海德宝严净菩萨　南无大严净菩萨　南无大相菩萨　南无大力精进金刚菩萨　南无月德妙音菩萨　南无香炎光幢菩萨　南无光明尊德菩萨　南无金光炎菩萨　南无法界普音菩萨　南无净云日幢菩萨　南无善超净光菩萨　南无净月藏菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无善贤辟支佛　南无贤德辟支佛　南无须摩辟支佛　南无输那辟支佛　南无留阇辟支佛　南无忧波留阇辟支佛　南无弗沙辟支佛　南无牛齿辟支佛　南无漏尽辟支佛　南无最后身辟支佛

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等如上所说已忏悔于三宝间轻重诸罪。其余诸恶今当次第更复忏悔。经中佛说有二种健儿。一者自不作罪。二者作已能悔。又云有二种白法。能为众生灭除众障。一者惭二者愧也。惭者自不作恶。愧者不令他作。有惭愧者可詺为人。若无惭愧与诸禽兽不相异也。惭者羞天。愧者所犯诸罪发露向人。是故弟子今日至诚惭愧归依佛

南无东方一宝庄严佛　南无南方旃檀德佛　南无西方梵音王佛　南无北方宝智首佛　南无东南方师子相佛　南无西南方宝盖照空王佛　南无西北方欢喜进佛　南无东北方摩尼清净佛　南无下方宝香胜王佛　南无上方大名称佛

归命如是等。十方尽虚空界一切三宝。弟子等自从无始已来至于今日。或信邪倒见。宰杀众生解奏魑魅魍魉鬼神。欲希延年终不能得。或妄言见鬼假称神语。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等。从无始已来至于今日。或行动傲诞自高自大。或恃种姓轻慢一切。以贵欺贱用强凌弱。倚富轻贫侠官慢下。或饮酒斗乱不避亲疏。惛醉终日尊卑不识。如是等罪无量无边。今日至诚发露忏悔

或嚵[昔*刀]懒堕不识羞耻。贪嗜饮食不惮艰辛。饮酒啖肉歌舞作乐。无有期度不知休息。或食诸生鲙饮啖五辛。薰秽经像排[穴/友]净众。纵心肆意不限理极。疏远善人亲狎恶友。或贡高矫假偃[仁-二+蹇]自用。鲁扈抵[穴/友]不识人情。自是非他自能他恶。见他过失则相攻訏。妄为辞句希望侥幸。如是等罪无量无边。今日至心归命忏悔

或临财不让无廉无耻屠肉沽酒欺诳自活。或出入息利计时卖日。聚积悭惜贪求无厌受人供养不生惭愧。或无戒行空纳信施。或打奴捶婢驱役诸童。不问饥渴不知寒暑。或拨撤桥梁驻绝行路。如是等罪无量无边。今日至诚归命忏悔

或放逸自恣无记散乱。摴捕白打双六围棋。群会屯聚饮酒食肉。更相讥诮无趣谈话。论说天下从月竟年空丧天日。初中后夜禅诵不修。懈怠懒堕尸卧终日。于六念处心不经理。见他胜事便生嫉妒。心怀碜毒备起烦恼。致使诸恶猛风吹恶。薪火炽然无有休息。三业微善一切俱焚。善法既尽为一阐提。堕火地狱无有出期。是故弟子等。今日至诚稽颡向十方一切诸佛圣众前。忏悔上来所有一切众罪。若轻若重若粗若细若自作若教他作。若随喜作。若以势逼迫令作。如是乃至赞叹行恶法者。今日至心发露忏悔。愿皆消灭。愿弟子等。承是忏悔一切诸恶所生功德。愿生生世世慈和忠孝谦卑自辱。知廉识耻先意问讯。循良贞谨清洁义让。远离恶友常遇善缘摄守六根敬护三业。捍劳忍苦心不退没立菩提志荷负众生

    大乘莲华宝达问答报应沙门经

宝达顷前入火锵地狱。云何名曰火锵地狱。其地狱纵广一百五十由旬。周匝铁壁猛大炎炽。其地生锵来刺罪人。从足下入足趺上出罪人号哭苦痛万端南门之中有五千沙门唱如是言。我今何罪来入此中。马头罗刹手捉三股铁叉。望背而撞胸前而出。罪人来入狱中。铁锵来锵其足。烟火焰上烧彻胸心。一日一夜受罪万端。千生千死万生万死。若得人身身不具足

宝达问马头罗刹曰。此诸沙门作何等恶业。来入此中受苦如是。马头罗刹答宝达菩萨曰。此中沙门受佛净戒不护威仪。脚着靴鞋以上清厕而不脱。脚前蹑佛地僧地。或蹑佛像灵塔之影以是因缘受如此罪。宝达闻之。悲泣而去

佛名经卷第十佛说佛名经卷第十一

南无决定色佛　南无方便心佛　南无智味佛　南无功德信佛　南无难降伏佛　南无善见佛　南无月光明佛　南无月盖佛　南无世桥佛　南无信供养佛　南无乐胜佛　南无善盖佛　南无惭愧贤佛　南无能观佛　南无无边法佛　南无师子声佛　南无大行佛　南无普信佛　南无器声佛　南无胜爱佛　南无普行佛　南无普智佛　南无大奋迅佛　南无月幢佛　南无坚行佛　南无天供养佛　南无能惊怖佛　南无胜称佛　南无成就一切功德佛　南无坚固佛　南无甘露光佛　南无大声佛　南无高声佛　南无大力佛　南无大尽佛　南无信甘露佛　南无行菩提佛　南无胜声思惟佛　南无高光佛　南无悕胜佛　南无乐种种声佛　南无爱义佛　南无修行信佛　南无离忧佛　南无善生佛　南无威德力佛　南无信功德佛　南无声称佛　南无放光明佛　南无疑奋迅佛　南无胜王佛　南无林华佛　南无功德华佛　南无舍诤佛　南无大广佛　南无大称佛　南无虚空爱佛　南无甘露奋迅佛　南无日聚佛　南无月声佛　南无天幢佛　南无与清净佛　南无能日佛　南无快可见佛　南无坚意胜声佛　南无雨甘露佛　南无无畏声佛　南无善根声佛　南无胜声佛　南无胜爱佛　南无甘露称佛　南无法华佛　南无大庄严佛　南无世间尊重佛　南无胜意佛　南无弥留光佛　南无清净思惟佛　南无高光明佛　南无破怨佛　南无甘露城佛　南无华光佛　南无大称佛　南无安隐思佛　南无道威德佛　南无清净心佛　南无天供养佛　南无度泥佛　南无离有佛　南无法华佛　南无大胜佛　南无可乐光明佛　南无火光佛　南无见爱佛　南无光明爱佛　南无喜声佛　南无大施德佛　南无实步佛　南无无滞碍智佛　南无得威德佛　南无月藏佛　南无净光明佛　南无大庄严佛　南无得乐自在佛　南无妙光明佛　南无寂光明佛　南无离疑佛　南无无过智慧佛　南无成就行佛　南无清净身佛　南无无畏爱佛　南无称吼佛　南无大吼佛　南无善思佛　南无大思佛　南无清净心佛　南无大奋迅佛　南无乐眼佛　南无命清净佛　南无行清净佛　南无离热智佛　南无应桥佛　南无善集智佛　南无普信佛　南无设尸威德佛　南无不死城佛　南无不护声佛　南无化日佛　南无善住思惟佛　南无高信佛　南无须摩那光明佛　南无光明力佛　南无功德希佛　南无法俱苏摩佛　南无净威德佛　南无净行佛　南无天色心佛　南无力王佛　南无普观佛　南无梵供养佛　南无圣华佛　南无虚空佛　南无降伏郁弥佛　南无无譬智佛　南无胜伏刺佛　南无降伏城佛　南无应爱佛　南无戒功德佛　南无平等勿思佛　南无不怯弱心佛　南无精进信佛　南无高光明佛　南无闻智佛　南无无碍心佛　南无无畏光佛　南无甘露声佛　南无种种日佛　南无胜黠慧佛　南无可修敬佛　南无功德王佛　南无护根佛　南无禅解脱佛　南无大威德佛　南无栴檀香佛　南无见信佛　南无妙桥梁佛　南无可观佛　南无不可量智佛　南无千日威德佛　南无舍重担佛　南无称信佛　南无诸方闻佛　南无自在佛　南无无边智佛　南无无垢光佛　南无甘露信佛　南无妙眼佛　南无解脱行佛　南无可乐见佛　南无高光明佛　南无大声佛　南无大威德聚佛　南无光明幢佛　南无应供养佛　南无福德威德积佛　南无信相佛　南无大炎佛　南无应信佛　南无善住思惟佛　南无须提他佛　南无智作佛　南无普宝佛　南无日光佛　南无说提他佛　南无炎眼佛　南无师子身佛　南无称亲光佛　南无清净声佛　南无希乐佛　南无寂静增上佛　南无宝威德佛　南无善威德供养佛　南无毛光佛　南无世间尊佛　南无善行净佛　南无善提他威德佛　南无应眼佛　南无大步佛　南无成义佛　南无安隐爱佛　南无天摩私多佛　南无舍漫流佛　南无舍宝佛　南无智满佛　南无度桥佛　南无解脱贤佛　南无众步佛　南无光明威德佛　南无慈力佛　南无月胜佛　南无寂光佛　南无爱眼佛　南无赊尸罗声佛　南无不死色佛　南无乐法佛　南无大月佛　南无无障碍声佛　南无功德奋迅佛　南无不死华佛　南无平等见佛　南无大月佛　南无功德味佛　南无十光佛　南无种种光佛　南无龙德佛　南无云声佛　南无功德步佛　南无思功德佛　南无大声佛　南无了声佛　南无远离恶处佛　南无天华佛　南无快眼佛　南无大然灯佛　南无离痴行佛　南无坚固希佛　南无舍邪佛　南无相华佛　南无不可思议光明佛　南无普贤佛　南无月妙佛　南无乐德佛　南无清净声佛　南无胜慧佛　南无贤光佛　南无坚固华佛　南无光明意佛　南无福德德佛　南无意成就佛　南无乐解脱佛　南无调怨佛　南无不去舍佛　南无离[漂*寸]河佛　南无甘露光明佛　南无无垢心佛　南无乐声佛　南无不可量眼佛　南无快修行佛　南无妙高光佛　南无集功德佛　南无可乐佛　南无大心佛　南无天信佛　南无思惟甘露佛　南无黠慧佛　南无胜灯佛　南无坚意佛　南无力步佛　南无莲华叶眼佛　南无菩提光明佛　南无妙吼声佛　南无六通声佛　南无威德力佛　南无人称佛　南无胜华集佛　南无大髻佛　南无不随他佛　南无无畏行佛　南无不怯弱佛　南无离忧闇佛　南无过潮佛　南无月光佛　南无心勇猛佛　南无解脱慧佛　南无不取舍佛　南无薝卜灯佛　南无胜火佛　南无善思意佛　南无胜威德色佛　南无信世间佛　南无妙慧佛　南无善喜信佛　南无华光佛　南无人华佛　南无善香佛　南无胜功德佛　南无种种华佛　南无高胜佛　南无虚空功德佛　南无天信佛　南无可敬憍佛　南无月光佛　南无火聚佛　南无最力佛　南无智地佛　南无高意佛　南无山王智佛　南无快升佛　南无妙升佛　南无胜亲佛　南无离疑佛　南无应行佛　南无胜香佛　南无无诤行佛　南无修行功德佛　南无大精进心佛　南无然灯光明佛　南无摄步佛　南无修行深心佛　南无香希佛　南无香手佛　南无寂静智佛　南无妙心佛　南无功德庄严佛　南无增上行佛　南无智意佛　南无功德山清净声佛　南无摄集佛　南无妙信佛　南无日见可力佛　南无功德王光明佛　南无法不可力佛　南无离诸疑奋迅佛　南无称王佛　南无摄诸根佛　南无上去佛　南无甘露光佛　南无甘露心佛　南无诸众上佛　南无净髻佛　南无不可降伏色佛　南无普信佛　南无庄严王佛　南无甘露日佛　南无胜灯佛　南无波头上佛　南无宝藏佛　南无普光佛　南无最胜王佛　南无普光明上胜积王佛　南无普现佛　南无自在转法王佛　南无普贤佛　南无还华胜佛　南无千世自在声佛　南无一善无垢声自在王佛　南无千离无畏声自在王佛　南无千无垢威德自在王佛　南无五百日声自在王佛　南无五百乐自在声佛　南无日龙欢喜佛　南无离畏称王佛　南无妙光幢佛　南无离光声佛　南无称自在声佛　南无妙法称声佛　南无胜藏称王佛　南无不可思议意王佛　南无宝幢佛　南无大自在佛　南无圣智自在幢勇猛王佛　南无不可思议慧佛　南无智藏佛　南无智高幢佛　南无智海王佛　南无大精进声自在王佛　南无弥留胜功德佛　南无智显修自在种子善无垢吼自在王佛　南无降伏功德海王佛　南无智成就力王佛　南无胜道自在王佛　南无胜闇积自在佛　南无华胜积智佛　南无金刚师子佛　南无戒胜佛　南无贤胜佛　南无无边光佛　南无师子喜佛　南无无尽智积佛　南无宝行佛　南无智波罗婆佛

次礼十二部尊经大藏法轮

南无顺权方便经　南无乐璎珞庄严方便经　南无大云轮请雨经　南无大云请雨经　南无大方等大云请雨经　南无如来庄严智慧光明入诸佛境界经　南无度诸佛境界智严经　南无度诸佛境界智光严经　南无德护长者经　南无月光童子经　南无申日经　南无善思童子经　南无大方等顶王经　南无大乘顶王经　南无法镜经　南无郁伽长者所问经　南无郁伽罗越问菩萨行经　南无无量清净等觉经　南无阿弥陀经

敬礼十方诸大菩萨摩诃萨

南无普正法菩萨　南无普化菩萨　南无普慧菩萨　南无普眼菩萨　南无普观察菩萨　南无普照菩萨　南无普幢菩萨　南无普德智光菩萨　南无普明师子菩萨　南无普胜宝光菩萨　南无普德海幢菩萨　南无普慧光明菩萨　南无普宝华幢菩萨　南无普胜濡音菩萨　南无普德清炎菩萨　南无普相光明菩萨　南无普觉菩萨　南无觉首菩萨　南无财首菩萨　南无宝首菩萨　南无德首菩萨　南无目首菩萨　南无进首菩萨　南无法首菩萨　南无智首菩萨　南无贤首菩萨　南无大光海月菩萨　南无云音海藏菩萨　南无德宝胜月菩萨　南无净慧光炎自在王菩萨　南无超越华光菩萨　南无无量智云日光菩萨　南无大力精进金刚菩萨　南无香炎光幢菩萨　南无月德妙音菩萨　南无光明尊德菩萨　南无明净藏菩萨　南无心王菩萨　南无无碍心菩萨　南无自在势菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无阿若憍陈如　南无摩诃迦叶　南无优楼频螺迦叶　南无伽耶迦叶　南无那提迦叶　南无舍利弗　南无大目揵连　南无摩诃迦栴延　南无阿[少/兔]楼驮　南无摩诃劫宾那

归命如是众所知识大阿罗汉等

礼三宝已次复忏悔

弟子等。已忏悔烦恼障已忏悔业障。所余报障今当次第披陈忏悔。经中说言。业报至时。非空非海中。非入山石间。无有他方所脱之不受报。唯有忏悔力乃能得除灭。何以知然。释提桓因五衰相现。恐惧切心归诚三宝。死相即灭得延天年。如是等比。经教所明其事非一。故知忏悔实能灭祸。但凡夫之人若不遇善友奖导。则靡恶而不造。致使大命将尽临穷之际。地狱恶相皆现在前。当尔之时悔惧交至。不预修善临穷方悔。悔之于后将何及乎。殃祸异处宿预严待当独趣入远到他所。但得前行入于大镬。身心摧碎精神痛苦。如此之时欲求一礼一忏岂复可得。众等莫自恃盛年财宝势力。懒惰懈怠放逸自恣。死苦一至无问老少。贫富贵贱皆悉磨灭。奄忽而至不令人知。夫命无常喻如朝露。出息虽存入息难保。云何以此而不忏悔。且五天使者既来。无常杀鬼卒至。盛年[牛*壬]色无得免者。当尔之时华堂邃宇何关人事。高车大马岂得自随。妻子眷属非复我亲。七珍宝饰乃为他玩。以此而言。世间果报皆如幻化。上天虽乐会归败坏。寿尽魂魄堕落三途。是故佛语须跋陀言。汝师郁头蓝弗利根聪明能伏烦恼。至于非非想处命终。还作畜生道中飞狸之身。况复余者。故知未证圣果已还。皆应流转备经恶趣。如不谨慎忽尔一朝亲婴斯事将不及悔。或如今被罪行诣公门。已是小苦精神慞惶。眷属恐惧求救百端。地狱众苦比于此者。百千万倍不得为喻。众等相与历劫已来罪若须弥。云何闻此晏然不畏不惊不恐。令此精神复婴斯苦实为可痛。是故弟子等。运此单诚至心归依佛

南无东方调御佛　南无南方金刚藏佛　南无西方灯法界佛　南无北方边眼佛　南无东南方无忧德佛　南无西南方坏诸怖畏佛　南无西北方勇猛伏佛　南无东北方大力光明佛　南无下方欢喜路佛　南无上方香上王佛

归命如是等十方尽虚空界一切三宝

弟子等自从无始已来至于今日所有报障。然其重者第一唯有阿鼻地狱。如经所明。今当略说其相。此狱周匝有七重铁城。复有七重铁网罗覆其上。下有七重刀林。无量猛火纵广八万四千由旬。罪人之身遍满其中。罪业因缘不相妨碍。上火彻下下火彻上。东西南北通彻交过。如鱼在熬脂膏皆尽。此中罪苦亦复如是。其城四门有四大铜狗。其身纵广四十由旬。牙爪锋铓眼如闪电。复有无量铁觜诸鸟。奋飞腾翔啄罪人肉。牛头狱卒形如罗刹。而有九尾尾如铁叉。复有八头。头上有十八角。有六十四眼。一一眼中皆悉迸出诸热铁丸。烧罪人肉。然其一嗔一怒喈吼之时声如霹雳。复有无量自然刀轮空中而下。从罪人顶入从足而出。于是罪人痛彻骨髓苦切肝心。如是经无量岁受诸苦恼。求生不得求死不得。如是等报。今日皆悉稽颡惭愧发露。诚心忏悔

其余地狱刀山剑树地狱。身首脱落罪报忏悔。镬汤炉炭地狱。烧煮罪报忏悔。狱床铜柱地狱。燋然罪报忏悔。刀轮火车地狱。劈轹罪报忏悔。拔舌犁耕地狱。楚痛罪报忏悔。吞啖铁丸洋铜灌口地狱。五内消烂罪报忏悔。铁碓铁磨地狱。骨肉灰粉罪报忏悔。黑绳铁网地狱。支节分离罪报忏悔。灰河沸屎地狱。恼闷罪报忏悔。碱水寒冰地狱。皮肤坼裂裸冻罪报忏悔。虎狼鹰犬地狱。更相残害罪报忏悔。刀兵分距地狱。更相搏撮斫刺罪报忏悔。火坑地狱。炮炙罪报忏悔。两石相磕地狱。形骸破碎罪报忏悔。聚合黑耳地狱。解剔罪报忏悔。闇冥肉山地狱。斩剉罪报忏悔。锯解钉身地狱。断截罪报忏悔。铁捧倒悬地狱。屠割罪报忏悔。燋热叫唤地狱。烦冤罪报忏悔。大小铁围山间。长夜冥冥不识三光。罪报忏悔。阿波波地狱。阿娑娑地狱。阿吒吒地狱。阿罗罗地狱。如是八寒八热一切诸地狱。一一狱中复有八万四千隔子地狱。以为眷属此中罪苦。炮煮楚痛剥皮呙肉。削骨打髓抽肠拔肺。无量诸苦不可闻不可说。南无佛今日在此中者。或是我等无始已来。经生父母一切眷属。我等相与命终之后。或当复堕如此狱中。今日洗心至到丹诚叩头稽颡。向十方佛大地菩萨求哀忏悔。令此一切报障毕竟消灭

愿弟子等。承是忏悔地狱等报所生功德。愿生生世世诸佛慈悲救众生苦。则时破坏阿鼻铁城。悉与净土无恶道名。其余地狱一切苦具转为乐缘。刀山剑树变成宝床。镬汤炉炭莲华化生。牛头狱卒除舍暴虐。皆起慈悲无有恶念。地狱众生得离苦果更不造因。等受安乐如第三禅。一时俱发无上道心

    大乘莲华宝达问答报应沙门经

宝达顷前入饮火铢地狱。云何名曰饮火铢地狱。其地狱纵广三百由旬。铁壁周匝烟火俱起。其地有镬满中铁铢浑淆而沸。边有马头罗刹。手捉铁杓扬铁铢子。东门之中有八千沙门。悲号涕泣身毛火然烟焰俱起。罪人比丘步步起倒。马头罗刹手捉三股铁叉。望胸而撞背上而出。叉股火然左右通彻。狱卒夜叉手捉铁钩。望骸而搭口中而出。尔时罪人眼口开张。尔时狱卒手捉铁杓鋎铁铢子。望罪人口灌铁铢入口。六根俱出烟焰洞然。身毛孔中皆亦火然。一日一夜受罪万端。千死千生万死万生。若得为人身不具足。聋盲喑哑不闻佛名。亦复不见千佛出世

宝达菩萨问马头罗刹曰。此诸沙门作何等业受如是罪。马头罗刹答曰。此诸沙门受佛净戒而不净持。食人信施反更不斋。夜食僧食亦复自手作食。还自取食无惭愧心以是因缘受如此罪。宝达闻之悲泣而去

佛名经卷第十一佛说佛名经卷第十二

南无师子称佛　南无智功德王佛　南无法华雨佛　南无能作光佛　南无高山佛　南无妙法王无垢佛　南无香自在无垢眼佛　南无集大无碍佛　南无无障碍力王佛　南无自智福德力佛　南无智衣佛　南无自在佛　南无无量安隐佛　南无智集佛　南无大弥留佛　南无日藏佛　南无作功德庄严佛　南无华幢佛　南无功德光明佛　南无离功德闇王佛　南无功德王佛　南无法幢佛　南无声自在王佛　南无自护佛　南无金刚密迹佛　南无实自在佛　南无妙幢佛　南无山劫佛　南无乐云佛　南无法作佛　南无莎罗王佛　南无普功德坚固王佛　南无栴檀佛　南无善住佛　南无善至佛　南无幢胜灯佛　南无智步佛　南无坚幢佛　南无散法称佛　南无降伏憍慢佛　南无功德炎佛　南无智光明佛　南无智然灯佛　南无无畏王佛　南无智声幢摄佛　南无金刚灯佛　南无庄严王佛　南无胜数佛　南无善住意佛　南无月王佛　南无次第降伏王佛　南无坚固自在王佛　南无师子步佛　南无那罗延胜藏佛　南无集宝藏佛　南无树提藏佛　南无星宿差别称佛　南无功德力坚固王佛　南无妙声佛　南无梵声佛　南无胜梵佛　南无坚固土佛　南无千香佛　南无波头摩胜王佛　南无光轮光佛　南无火光明王佛　南无香波头摩王佛　南无疾无边功德海智佛　南无阎浮影佛　南无功德山幢佛　南无师子幢佛　南无龙吼佛　南无华威德王佛　南无善香种子佛　南无无我甘露功德威德王劫佛　南无复有八千同名无我甘露功德威德王劫佛　南无法智佛　南无龙自在解脱佛　南无金刚华佛　南无龙吼自在声佛　南无宝积佛　南无华照佛　南无火香佛　南无须摩那华佛　南无山王佛　南无世眼佛　南无净上佛　南无阎浮影佛　南无根本上佛　南无宝山佛　南无海藏佛　南无坚力佛　南无上圣佛　南无自在圣佛　南无师子步佛　南无拘邻佛　南无智幢佛　南无佛闻声佛　南无广胜佛　南无安隐佛　南无智光佛　南无大自在佛　南无寂世佛　南无手喜佛　南无尼拘律王佛　南无金眼佛　南无供养佛　南无日喜佛　南无宝炎佛　南无善眼佛　南无高净佛　南无净圣佛　南无吼声佛　南无见义佛　南无称喜佛　南无称胜佛　南无可喜佛　南无善香佛　南无疾行佛　南无妙眼佛　南无善胜佛　南无修义佛　南无善意佛　南无妙慧佛　南无金幢佛　南无善眼佛　南无天清净佛　南无输头檀佛　南无善见佛　南无毗留罗幢佛　南无毗楼博叉佛　南无梵声佛　南无成就胜佛　南无胜光明佛　南无无垢佛　南无摩尼跋陀佛　南无摩梨指佛　南无大摩梨指佛　南无能圣佛　南无声自在佛　南无赞叹成就佛　南无胜成就华佛　南无拘苏摩佛　南无不动佛　南无日藏佛　南无乐声佛　南无能作光佛　南无龙德佛　南无金刚光佛　南无称王佛　南无虎王佛　南无高光佛　南无发行佛　南无智成就佛　南无香自在佛　南无那罗延藏佛　南无火藏佛　南无破垢胜王佛　南无宝盖胜光佛　南无山自在王佛　南无宝月佛　南无师子奋迅幢自在王佛　南无实根广眼佛　南无世自在王佛　南无远离诸怖畏随烦恼声佛　南无敷华卢舍那佛　南无香波头摩佛　南无无垢功德威德王佛　南无不动佛　南无日藏佛　南无乐自在声火佛　南无智日佛　南无龙吼佛　南无金刚齿佛　南无日藏佛　南无胜自在佛　南无不可思议王佛　南无大胜藏佛　南无喜幢佛　南无无畏自在佛　南无见弥留佛　南无智像佛　南无无垢眼佛　南无无忧胜佛　南无法自在吼佛　南无法自在莎罗王佛　南无师子奋迅佛　南无那罗延佛　南无善择藏佛　南无宝集佛　南无功德奋迅佛　南无火藏佛　南无星宿称佛　南无功德力坚固王佛　南无妙吼声奋迅佛　南无莎罗胜黠王佛　南无威德自在光明佛　南无妙声吼佛　南无宝掌龙自在佛　南无法云吼自在平等佛　南无宝山佛　南无妙光藏佛　南无师子多罗称佛　南无普藏佛　南无净华佛　南无歌罗毗罗奋迅佛　南无法疾然灯佛　南无无等上弥留佛　南无称声王佛　南无梵谛释声佛　南无远离逼恼佛　南无毗沙门坚固王佛　南无破魔王宫佛　南无莎罗王佛　南无大奋迅光佛　南无华胜佛　南无栴檀佛　南无弥留王佛　南无拘罗伽坚固树提佛　南无智奋迅佛　南无二万同名月燃灯佛　南无无垢身佛　南无波头摩光佛　南无华胜步佛　南无华光佛　南无称幢佛　南无阎浮檀金光佛　南无多摩罗跋叶栴檀香佛　南无大通智胜佛　南无不动佛　南无弥留山佛　南无师子吼佛　南无师子幢佛　南无住虚空佛　南无常入涅槃佛　南无帝释幢佛　南无梵幢佛　南无无量寿佛　南无善度佛　南无普救众生佛　南无多摩罗跋叶栴檀香通佛　南无弥留劫佛　南无云灯佛　南无云自在王佛　南无一切世间高佛　南无能破诸畏佛　南无释迦牟尼佛　南无法光明佛　南无五百普光明佛　南无大海住持智奋迅通佛　南无七宝波头摩步佛　南无二千宝幢佛　南无多宝佛　南无一切众生爱见佛　南无百千光明满足幢佛　南无二十千亿惊怖吼声王佛　南无二十百亿日月然灯佛　南无二十百亿妙声王佛　南无二十百亿云声王佛　南无宝威德高王佛　南无月无垢日光明胜佛　南无莲华叶星宿王花通佛　南无云妙鼓声王佛　南无住持水吼声佛　南无妙声星宿王拘苏摩遍佛　南无莎罗树王佛　南无无垢光明佛　南无宝炎佛　南无华鬘林王花通佛　南无日月宝作光明佛　南无功德宝光明佛　南无宝杖佛　南无云王佛　南无宝盖胜光明佛　南无普见佛　南无功德自在佛　南无师子声作佛　南无宝积示现佛　南无乐坚佛　南无菩提意佛　南无无量命佛　南无阿閦佛　南无香王佛　南无宝作佛　南无修行法佛　南无盖王佛　南无摩尼王佛　南无月藏佛　南无日藏佛　南无声身王佛　南无善觉佛　南无须弥劫佛　南无能圣佛　南无宝波头摩月清净胜王佛　南无不动佛　南无普满佛　南无无尽慧佛　南无宝幢佛　南无奋迅恭敬称佛　南无无垢光明藏佛　南无云护佛　南无师子奋迅佛　南无胜高山王佛　南无波头摩上佛　南无身上佛　南无多宝妙佛　南无胜藏山增上王佛　南无意勇猛仙行胜佛　南无甘露藏佛　南无妙鼓声王佛　南无日月佛　南无唯宝盖佛　南无普光明奋迅光王佛　南无能行成就圣佛　南无不动佛　南无无垢光明称王佛　南无九千法庄严佛　南无摩尼金盖佛　南无星宿佛　南无高山欢喜佛　南无菩提分华身佛　南无能修行佛　南无宝作佛　南无如宝佛　南无高聚佛　南无宝光明佛　南无宝来佛　南无宝高佛　南无阿閦佛　南无宝光明佛　南无大光明佛　南无不可量声佛　南无不可思议声佛　南无大称佛　南无宝照佛　南无得大无畏佛　南无宝声佛　南无无边清净佛　南无月声佛　南无无边称佛　南无月光清净佛　南无清净光佛　南无无垢光佛　南无无边宝佛　南无波头摩胜佛　南无身胜佛　南无金色佛　南无梵声王佛　南无金光明佛　南无金色作佛　南无龙自在王佛　南无月清净佛　南无金色华香自在王佛　南无坚固王佛　南无坚固勇猛仙行胜佛　南无胜藏摩尼光佛　南无无量香光佛　南无师子声佛　南无至大势精进修行毕竟佛　南无坚固智佛　南无妙鼓声王佛　南无月妙佛　南无华胜佛　南无世间灯佛　南无火佛　南无宝轮佛　南无无垢智佛　南无常寂灭佛　南无无边宝花光明佛　南无须弥山奋迅佛　南无宝华佛　南无集宝聚佛　南无不退轮宝住胜佛　南无德普卢舍那清净佛　南无日月灯佛　南无弥留佛　南无大弥留佛　南无须弥劫佛　南无香面佛　南无成就香佛　南无弥留香佛　南无清净光佛　南无法上佛　南无香自在王佛　南无大摩尼佛　南无香光佛　南无火光佛　南无甘露光佛　南无月光佛　南无月灯光佛　南无月照佛　南无集声佛　南无胜作佛　南无多宝佛　南无师子吼佛　南无师子声佛　南无勇猛仙佛　南无金刚喜佛　南无护一切佛　南无离诸疑佛　南无宝炎眷属佛

次礼十二部尊经大藏法轮

南无无量寿经　南无虚空孕菩萨经　南无观虚空藏菩萨经　南无虚空藏菩萨经　南无虚空藏菩萨神咒经　南无弥勒成佛经　南无弥勒下生经　南无弥勒来时经　南无小无量寿经　南无无量寿佛经　南无药师琉璃光经　南无药师如来本愿经　南无老母经　南无老母六英经　南无文殊师利巡行经　南无文殊尸利行经　南无金刚上味陀罗尼经　南无金刚场陀罗尼经　南无正恭敬经　南无善恭敬经　南无离垢施女人经　南无无垢施菩萨分别应辩经　南无得无垢女经　南无无畏德女经　南无阿阇世王女阿术达菩萨经　南无无涯际总持法门经　南无第一义法胜经　南无尊胜菩萨入无量门陀罗尼经　南无大威灯光仙人问疑经　南无八吉祥经　南无八佛名号经　南无龙施女经　南无龙施菩萨本起经　南无睒子经　南无菩萨睒子经　南无了本生死经　南无稻芽经　南无大方广菩萨十地经　南无庄严菩提心经　南无无所希望经　南无象腋经　南无大方等修多罗王经　南无转有经　南无大乘方等要慧经　南无弥勒菩萨所问经　南无慧印三昧经　南无如来智印经　南无一切法高王经

敬礼十方诸大菩萨摩诃萨

南无无碍化菩萨　南无自在慧炎光菩萨　南无散一切化幢菩萨　南无法幢王菩萨　南无法界地幢王菩萨　南无一切众生世界幢王菩萨　南无夜光幢菩萨　南无须弥山幢菩萨　南无宝幢菩萨　南无无碍幢菩萨　南无日光幢菩萨　南无正幢菩萨　南无离尘幢菩萨　南无明净幢菩萨　南无大地端严菩萨　南无宝严菩萨　南无大慧端严菩萨　南无金刚智端严菩萨　南无离垢端严菩萨　南无法日端严菩萨　南无功德山端严菩萨　南无智光端严菩萨　南无普妙德端严菩萨　南无大地藏菩萨　南无宝藏菩萨　南无日藏菩萨　南无净德藏菩萨　南无法印藏菩萨　南无齐藏菩萨　南无善德眼菩萨　南无普见眼菩萨　南无清净眼菩萨　南无离垢眼菩萨　南无无碍眼菩萨　南无善观眼菩萨　南无青莲华眼菩萨　南无金刚眼菩萨　南无宝眼菩萨　南无虚空眼菩萨　南无善眼菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无憍梵波提　南无离波多　南无毕陵伽婆蹉　南无薄拘罗　南无摩诃拘絺罗　南无难陀　南无孙陀罗难陀　南无富楼那弥多罗尼子　南无须菩提　南无周陀夷

归命如是等众所知识大阿罗汉

礼三宝已次复忏悔

弟子等已忏地狱报竟。今当复次忏悔三恶道报经中佛说多欲之人多求利故苦恼亦多。知足之人虽卧地上犹以为乐。不知足者虽处天堂犹不称意。但世间人忽有急难。便能舍财不讨多少。而不知此身临于三途深坑之上。一息不还定应堕落。忽有知识教营福德。令修未来善法资粮。执此悭心无肯作理。夫如此者极为愚惑。何以故。尔经中佛说。生时不赍一文而来。死亦不持一文而去。苦身积聚为之忧恼。于己无益徒为他有。无善可恃无德可怙。致使命终堕诸恶道。是故弟子等。今日至心稽颡恳切丹诚归依佛

南无东方大光曜佛　南无南方虚空住佛　南无西方金刚步佛　南无北方无边力佛　南无东南方无边王佛　南无西南方坏诸怨贼佛　南无西北方离垢光佛　南无东北方金色光音佛　南无下方师子游戏佛　南无上方月幢王佛

归命如是等。十方尽虚空界一切三宝

弟子等今日次复忏悔畜生道中无所识知罪报。忏悔畜生道中负重牵犁。偿他宿债罪报。忏悔畜生道中不得自在。为他斫刺屠割罪报。忏悔畜生道中无足二足四足多足罪报。忏悔畜生道中身诸毛羽鳞甲之内。为诸小虫之所[口*(一/巾)]啖罪报。忏悔如是畜生道中有无量无边罪报。今日至诚归命忏悔

弟子等今日次复忏悔饿鬼道中长饥罪报。忏悔饿鬼道中百千万岁永不曾闻浆水之名罪报。忏悔饿鬼道中食啖脓血粪秽罪报。忏悔饿鬼道中动身之时。一切支节悉皆火然罪报。忏悔饿鬼道中腹大咽小罪报。忏悔如是饿鬼道中无量无边苦报。是故今日至诚稽颡归命忏悔

弟子等今日次复忏悔一切鬼神修罗道中。谀谄诈称罪报。忏悔鬼神道中担沙负石填河塞海罪报。忏悔鬼神罗刹鸠槃荼诸恶鬼神。生啖血肉受此丑陋罪报。忏悔如是鬼神道中无量无边一切罪报。今日稽颡向十方佛大地菩萨。求哀忏悔悉令消灭

愿弟子等。承是忏悔畜生等报所生功德。愿生生世世灭愚痴垢。自识业缘智慧明照断恶道身。愿以忏悔饿鬼等报所生功德。愿生生世世永离悭贪饥渴之苦。常餐甘露解脱之味。愿以忏悔鬼神修罗等报所生功德。愿生生世世质直无谄。离邪命因除丑陋果。福利人天。愿弟子等从今日以去乃至道场。决定不受四恶道报。唯除大悲为众生故以誓愿力处之无厌

    大乘莲华宝达问答报应沙门经

宝达顷前更入一地狱。名曰飞刀地狱。其地狱纵广十五由旬铁壁周匝铁网覆上其城四角。火风猛利来吹铁山。其山相磨则成利刀。其刀两刃亦如锋铓。虚空銝銝[金*疑][金*疑]亦如雷声。刀刀相钹亦如霹雳。从空而来刺罪人头。从头而入足下而出。从背上入胸前而出。左出右入烟火俱然。一日一夜受罪万端。千生千死万生万死。若得为人身生恶疮遍体周匝。宝达问曰。此诸沙门作何等行受如是苦。马头罗刹答曰。此诸沙门受佛净戒而不净持。心无慈心饮酒食肉言无罪报。食肉之罪理不可恕。以是因缘故受此罪。宝达菩萨闻之悲泣而去

佛名经卷第十二佛说佛名经卷第十三

南无无忧佛　南无住持速力佛　南无妙喜佛　南无自在作佛　南无无边声佛　南无然灯作佛　南无宝光明佛　南无阿弥陀佛　南无择说佛　南无择声佛　南无胜藏积吼王佛　南无降伏金刚坚佛　南无宝月光佛　南无宝火佛　南无贤上佛　南无宝波头摩步佛　南无宝胜佛　南无金宝光佛　南无悕喜快胜佛　南无不可量胜佛　南无善逝王佛　南无圣自在手佛　南无不可说分别佛　南无不空胜佛　南无月妙胜佛　南无树提胜佛　南无虚空光明佛　南无善清净无垢间错幢佛　南无善住善根藏王佛　南无成就一切义胜佛　南无智功德清净胜佛　南无善说清净幢佛　南无琉璃藏上胜佛　南无普功德奋迅佛　南无善清净功德宝住佛　南无宝光明清净心胜佛　南无金上胜佛　南无胜月佛　南无波头摩上奋迅胜佛　南无波头摩上佛　南无宝成就胜佛　南无电光幢王佛　南无电光明高王佛　南无多罗王佛　南无妙胜佛　南无虚空然灯佛　南无成就一切功德佛　南无贤高幢王佛　南无住持一切宝间错庄严佛　南无宝光明庄严智威德声自在王佛　南无俱苏摩火奋迅通佛　南无月轮清净佛　南无敷华莎罗王佛　南无善寂月声自在王佛　南无阿僧祇精进住胜佛　南无波心炎佛　南无山功德幢王佛　南无法幢山佛　南无须弥山佛　南无功德师子自在佛　南无寂王佛　南无净王佛　南无称山佛　南无功德须弥胜佛　南无日面佛　南无月面佛　南无离虚空畏佛　南无普光佛　南无方成佛　南无住海面佛　南无宝光佛　南无云胜佛　南无法炎佛　南无山功德佛　南无华生佛　南无起大悲心佛　南无法界华佛　南无法华幢佛　南无王意佛　南无王慧佛　南无智慧佛　南无心义佛　南无自在佛　南无胜天意佛　南无速王佛　南无光明幢胜佛　南无高威德去佛　南无华光佛　南无宝炎佛　南无功德山佛　南无宝实佛　南无功德海胜佛　南无法光明佛　南无华藏胜佛　南无世间月佛　南无明目佛　南无香光佛　南无摩尼须弥胜佛　南无乾闼婆王佛　南无光明命佛　南无摩尼藏王佛　南无山威德慧佛　南无寂色去佛　南无面报佛　南无广智佛　南无宝光明佛　南无虚空重胜佛　南无妙相光明佛　南无行轮自在佛　南无法身自在佛　南无那罗延行佛　南无须弥胜佛　南无功德转轮佛　南无山王佛　南无不可胜佛　南无快威德佛　南无树山佛　南无莎罗王山藏佛　南无世自在身佛　南无镜光佛　南无实起佛　南无自在胜佛　南无功德光佛　南无地威德胜佛　南无身法光明佛　南无胜王佛　南无坚吼意佛　南无高幢胜佛　南无信意佛　南无宝光明佛　南无净胜佛　南无虚空声佛　南无法界镜像胜佛　南无照轮光明佛　南无方差别佛　南无智光明佛　南无幢意佛　南无虚空然灯佛　南无无病胜佛　南无智照佛　南无慧明佛　南无福德光明胜佛　南无寂胜佛　南无大悲云胜佛　南无力光明意佛　南无现一切众生色佛　南无过胜佛　南无修光明佛　南无昙无竭佛　南无风疾行胜佛　南无清净幢佛　南无妙盖胜佛　南无三世镜像胜佛　南无敬像坚佛　南无镜像胜佛　南无金刚胜佛　南无身坚庄严须弥胜佛　南无金幢王佛　南无身法慧佛　南无智慧然灯光明胜佛　南无广智胜佛　南无法行世智意佛　南无法印意智胜佛　南无法海意智胜佛　南无法财佛　南无宝财佛　南无福德功德佛　南无转法轮胜佛　南无云佛　南无忍辱灯佛　南无胜威德意佛　南无光明速寂声佛　南无大愿速胜佛　南无不可降伏幢佛　南无智炎佛　南无成就胜佛　南无法自在佛　南无不可成就意佛　南无世间言语坚固声光佛　南无一切声出声胜佛　南无自在功德佛　南无成就自在意佛　南无方天佛　南无不面舍佛　南无众生心佛　南无平等身佛　南无身行胜佛　南无行胜佛　南无自在性佛　南无山王佛　南无智光佛　南无千亿宝庄严佛　南无宝胜佛　南无信王佛　南无宝积佛　南无香自在佛　南无降伏怨佛　南无安隐佛　南无能与依止佛　南无无边威德佛　南无金色光佛　南无师子奋迅佛　南无甘露光佛　南无能圣成佛　南无普光佛　南无功德胜积王佛　南无善住摩尼积王佛　南无远离诸畏树安隐佛　南无饮甘露佛　南无无边光佛　南无宝高佛　南无无边庄严王佛　南无离怨佛　南无金色光佛　南无宝作佛　南无无尘胜佛　南无师子声王佛　南无宝幢佛　南无善心佛　南无高住佛　南无华王佛　南无智作佛　南无海智佛　南无欢喜佛　南无乐庄严佛　南无离闇佛　南无坚城佛　南无见细佛　南无无畏德佛　南无生王佛　南无实语佛　南无称上佛　南无择智佛　南无不行威德佛　南无人华佛　南无远离诸畏佛　南无能与无畏佛　南无金华佛　南无无畏作佛　南无不空见佛　南无宝华佛　南无六十实作佛　南无宝积佛　南无金华佛　南无降伏王佛　南无善光佛　南无见义佛　南无大择佛　南无妙无畏佛　南无大慈悲佛　南无不可降伏王佛　南无难胜佛　南无上首佛　南无法上佛　南无胜一切佛　南无高行佛　南无高称佛　南无胜圣佛　南无星宿佛　南无识佛　南无商佛　南无闻名佛　南无大悲说佛　南无无量寿佛　南无无边善光明胜佛　南无山积光明胜佛　南无无垢力三昧奋迅胜佛　南无一切功德王光相佛　南无火众佛　南无须弥劫佛　南无坚自在王佛　南无梵吼声佛　南无弥楼聚佛　南无善眼佛　南无成就聚佛　南无离愚奋迅佛　南无无碍眼佛　南无宝幢佛　南无释迦牟尼佛　南无功德胜藏佛　南无难胜佛　南无乐说庄严佛　南无胜藏积吼王佛　南无无边功德宝庄严威德王劫佛　南无功德宝胜威德王劫佛　南无乐说一切法庄严胜佛　南无无边乐说相佛　南无千云吼声王佛　南无金上光明胜佛　南无种种威德王光明胜佛　南无自觉误佛　南无清净金虚空吼庄严光明佛　南无一切法行威德奋迅光明佛　南无东方无边功德宝福德庄严广世界无垢清净光明菩提分俱苏摩不断绝光明庄严光佛　南无南方乐说佛世界无边功德宝乐说佛　南无西方光明世界普光佛　南无北方一切宝种种庄严世界无边宝功德自在佛　南无东南方无忧世界离一切忧闇佛　南无西南方善可见世界大悲观一切众生佛　南无西北方远离闇世界光明庄严王佛　南无东北方住清净无垢世界虚空无垢佛　南无上方庄严世界称名声佛　南无下方卢舍那光明世界宝忧波罗胜佛　南无无垢劫无垢世界名无垢光如来初成佛彼世界尘沙诸佛出世　南无无垢广世界名成就善就劫胜护如来初成佛彼世界尘沙诸佛出世　南无东方阿閦佛　南无大不迷佛　南无香王佛　南无香上佛　南无南方宝幢佛　南无宝作佛　南无宝成佛　南无宝藏佛　南无宝月佛　南无金刚坚佛　南无金刚仙佛　南无金刚幢佛　南无西方阿弥陀佛　南无阿弥陀幢佛　南无阿弥陀声佛　南无阿弥陀称佛　南无阿弥陀吼佛　南无阿弥陀积佛　南无阿弥陀胜上佛　南无阿弥陀师子佛　南无阿弥陀住持佛　南无阿弥陀胜佛　南无北方妙鼓声佛　南无妙鼓王佛　南无妙吼声佛　南无离诸畏佛　南无无畏佛　南无无畏忧佛　南无日舌光明作佛　南无蔓陀香佛　南无幢盖佛　南无东南方大弥留佛　南无弥留山佛　南无弥留王佛　南无弥留幢佛　南无弥留积佛　南无善弥留王佛　南无日藏佛　南无前后上佛　南无净王佛　南无鸡中幢王佛　南无大鸡中佛　南无西南方日藏佛　南无日光明佛　南无无忧佛　南无离一切忧佛　南无佛智清净业佛　南无尽作佛　南无华光佛　南无大华光佛　南无华王佛　南无华声佛　南无卢舍那佛　南无西北方上首积佛　南无山胜积佛　南无海胜积佛　南无作德佛　南无日上佛　南无清净王佛　南无东北方说妙法佛　南无净胜佛　南无日面佛　南无智幢王佛　南无光明佛　南无光明王佛　南无光明光佛　南无上方师子佛　南无师子王佛　南无师子上王佛　南无师子仙佛　南无仙王佛　南无仙首佛　南无仙光佛　南无仙舍敬佛　南无仙觉佛　南无大灯佛　南无师子积佛　南无然灯王佛　南无乐说山佛　南无灯譬喻佛　南无下方对治仙佛　南无觉诤佛　南无对治佛　南无对恨佛　南无对治山佛　南无爱然灯佛　南无依止佛　南无东方阿閦佛　南无弥留幢佛　南无大弥留佛　南无弥留光佛　南无真声佛　南无南方日月灯佛　南无大火聚佛　南无称光佛　南无弥留灯佛　南无无边精进佛

次礼十二部尊经大藏法轮

南无诸法勇王经　南无决定总持经　南无谤佛经　南无乳光佛经　南无犊子经　南无佛遗日摩尼宝经　南无金刚般若经　南无金刚般若波罗蜜经　南无金刚般若经　南无长者子制经　南无逝童子经　南无菩萨逝经　南无文殊师利菩萨经　南无伽耶山顶经　南无象头精舍经　南无贝多树下思惟十二因缘经　南无闻城十二因缘经　南无十二因缘经　南无转女身经　南无腹中女听经　南无胎藏经　南无无垢贤女经　南无无量门微密持经　南无出生无量门持经　南无阿难目佉尼诃离陀罗尼佛经　南无无量门破魔陀罗尼经　南无舍利弗陀罗尼经　南无面出生菩萨经　南无前世三转经　南无银色女经　南无太子和休经　南无太子尉护经　南无善法方便陀罗尼经　南无金刚秘密善门陀罗尼经　南无阿阇世王受决经　南无放钵经　南无采花违王上佛授决经　南无师子奋迅菩萨所问经　南无华积陀罗尼经　南无华聚陀罗尼经　南无相续解脱经　南无解节经　南无大宝积经　南无摩诃衍宝严经

敬礼十方诸大菩萨摩诃萨

南无天冠菩萨　南无普照十方天冠菩萨　南无普照法界慧天冠菩萨　南无道场天冠菩萨　南无生诸佛藏天冠菩萨　南无一切世间最上天冠菩萨　南无明净天冠菩萨　南无无量宝天冠菩萨　南无普照法界虚空天冠菩萨　南无梵王周罗菩萨　南无龙王周罗菩萨　南无一切佛化光明周罗菩萨　南无道场周罗菩萨　南无三世慧音周罗菩萨　南无大光菩萨　南无离垢光菩萨　南无宝光菩萨　南无离尘光菩萨　南无夜光菩萨　南无法光菩萨　南无寂静光菩萨　南无日光菩萨　南无自在光菩萨　南无天光菩萨　南无功德幢菩萨　南无智幢菩萨　南无法幢菩萨　南无诸通幢菩萨　南无光幢菩萨　南无摩尼幢菩萨　南无菩提幢菩萨　南无梵幢菩萨　南无普光幢菩萨　南无梵音菩萨　南无海音菩萨　南无大地音菩萨　南无世主音菩萨　南无虚空音菩萨　南无山相击音菩萨　南无法光音菩萨　南无充满一切法界音菩萨　南无一切法海雷音菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无阿难　南无罗睺罗　南无周利槃陀　南无宾头卢颇罗堕　南无迦留陀夷　南无阿那律　南无优波利　南无离越多　南无尊者摩诃周那

归命如是等众所知识大阿罗汉

礼三宝已。次复忏悔

弟子等。已忏三途等报。今当复次稽恳忏悔人天余报。相与禀此阎浮寿命。虽曰百年满者无几。于其中间盛年夭枉其数无量。但有众苦煎迫形心。愁忧恐怯未曾暂离。如此皆是善根微弱恶业滋多。致使现在心有所为皆不称意。当知悉是过去已来恶业余报。是故弟子。今日至诚归依佛

南无东方莲华上佛　南无南方调伏王佛　南无西方无量明佛　南无北方胜诸根佛　南无东南方莲花尊佛　南无西南方无量花佛　南无西北方自在智佛　南无东北方赤莲花华德佛　南无下方分别佛　南无上方伏怨智佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始已来至于今日。所有现在及以未来。人天之中无量余报。流殃宿对隆残百疾六根不具罪报忏悔。人间边地邪见三恶八难罪报忏悔。人间多病消瘦促命夭枉罪报忏悔。人间六亲眷属不能常得相保相守罪报忏悔。人间亲友凋丧爱别离苦罪报忏悔。人间怨家聚会愁忧怖畏罪报忏悔。人间水火盗贼刀兵危崄惊惧恐怯罪报忏悔。人间孤独困苦流离波迸已失国土罪报忏悔。人间牢狱系闭幽执侧立鞭挞拷楚罪报忏悔。人间公私口舌更相罗染更相诽谤罪报忏悔。人间恶病连年累月不差。枕卧床席不能起居罪报忏悔。人间冬温夏疫毒厉伤寒罪报忏悔。人间贼风肿满否塞罪报忏悔。人间为诸恶神伺求其便欲作祸崇罪报忏悔。人间有鸟鸣百怪飞尸邪鬼为作妖异罪报忏悔。人间为虎豹豺狼水陆一切诸恶禽兽所伤罪报忏悔。人间自结自刺自杀自害罪报忏悔。人间自忧自惋自勒自嗔自喜罪报忏悔。人间投坑赴火自沈自坠罪报忏悔。人间无有威德名闻罪报忏悔。人间衣服资生不得称心罪报忏悔。人间行来出入有所云为值恶知识为作留难罪报忏悔。如是现在未来人天之中。无量祸横灾疫厄难衰恼罪报忏悔。弟子等。今日至诚向十方佛尊法圣众前。披肝露心求哀忏悔

愿弟子等。承是忏悔所生功德。愿生生世世身相具足。犹如罗睺罗常值佛法僧恒闻妙法。寿命天地等。不为百病之所缠。六亲眷属常得相保护。怨贼刀兵永恒去离。自然衣服箱箧常盈。百味香饭盂中恒满。牢狱闭所化作天堂。口舌相非变成和合。连年之病永去身心。疫毒诸灾恒离意首。妖怪魍魉及以飞鸟虎豹豺狼。水陆诸祸一切等厄皆去无余。或自割刑或自嗔喜。如是等罪愿从今已去乃至成佛。已来永相去离。愿弟子等。不为诸恶道之所受报。唯生大悲救护一切众生。使皆尽性广化诸类俱登正觉

    大乘莲华宝达问答报应沙门经

宝达顷前更入火箭地狱。云何名曰火箭地狱。其狱纵广九十由旬。铁壁周匝猛火绝炎。地有铁锵遍布其地。烟火洞然来烧罪人。其地四面烂风俱起。于虚空中猛风卒疾来吹铁山。其山相磨则成火箭。火箭相揩烟火俱炽。其箭身毛亦皆火然。来射罪人从头而入足下而出。背上而入胸前而出。左右通彻疮中火然烟焰俱出。罪人号叫痛不可言。一日一夜受无量罪。千死千生万死万生

宝达问曰。此诸沙门作何等罪。来受此报。马头罗刹答曰。此诸沙门受佛净戒而不净持。不护威仪如俗人法。手捉弓箭失佛威仪。如经中说。昔有萨离比丘不护威仪。以手提俗人弓箭。万世之中受其恶报。以是因缘当知沙门不护威仪堕三恶道。今此比丘亦复如是

宝达闻之悲泣而去

佛名经卷第十三佛说佛名经卷第十四

南无西方阿弥陀佛　南无阿弥陀幢佛　南无阿弥陀高佛　南无大火光明佛　南无北方怜愍众生佛　南无大照佛　南无宝幢佛　南无香聚佛　南无上方火光炎聚佛　南无火声佛　南无难胜佛　南无日成就佛　南无罗网光佛　南无下方师子佛　南无称王佛　南无威德佛　南无法顶佛　南无法幢佛　南无法住持佛　南无东方梵声佛　南无星宿王佛　南无香上佛　南无香光佛　南无大炎聚佛　南无宝种种花敷身佛　南无坚王佛　南无宝莲花胜佛　南无见一切义佛　南无须弥劫佛　南无声吼佛　南无智自在佛　南无威德自在佛　南无莎罗自在王佛　南无智勇猛佛　南无光自在佛　南无坚自在王佛　南无声德佛　南无师子奋迅鬘佛　南无须弥山然灯王佛　南无香山佛　南无不可动佛　南无药王佛　南无寻光佛　南无大炎积佛　南无胜藏佛　南无无心光明佛　南无毗留罗佛　南无莲华佛　南无喜聚佛　南无栴檀佛　南无月光佛　南无惊怖幢佛　南无大修行佛　南无波头摩王佛　南无月胜佛　南无莎罗集佛　南无大莎罗集佛　南无幢相佛　南无净命佛　南无金台佛　南无爱见佛　南无金色色佛　南无须摩那光佛　南无妙莲华劫亿那由他百千万佛同名一切菩提华佛　南无七百同名光明庄严佛　南无三百同名大幢佛　南无十千同名庄严王佛　南无善发胜佛　南无日轮光明佛　南无普盖佛　南无三昧奋迅佛　南无宝华胜佛　南无无边足步佛　南无善香香王佛　南无善择敌佛　南无须弥劫佛　南无功德王光明佛　南无普至光佛　南无金刚佛　南无尼弥佛　南无不可尽世界一色佛　南无袈裟幢世界山自在王佛　南无坚幢世界智胜山王佛　南无一切香举世界胜花藏佛　南无金刚摩尼世界金刚藏光明胜佛　南无智成就世界智幢佛　南无意味世界普照佛　南无波头摩首世界佛胜佛　南无镜轮世界金刚幢佛　南无光明清净力世界日藏佛　南无安乐世界最胜佛　南无阿閦佛　南无宝幢佛　南无无量光佛　南无妙声佛　南无宝俱苏摩功德海琉璃歌那伽山真金光明胜佛　南无释迦牟尼佛　南无宝炎佛　南无金作盖山佛　南无毗婆尸佛　南无光尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含佛　南无迦叶佛　南无三昧手胜佛　南无无垢奋迅菩萨

若有善男子善女人。受持是诸佛菩萨名。超越世间三十劫

南无日轮光明胜佛。南无日光明菩萨

若复有人受持读诵是佛菩萨名。超越世间千劫

南无普宝盖佛

若有善男子。受持读诵是佛名。是人超越世间四大劫。常现诸佛菩萨前生。不复作五逆罪

南无三昧胜奋迅佛

若有善男子。受持读诵是佛名得千三昧。超越世间无量千劫。同弥勒菩萨功德

南无宝俱苏摩身光明胜佛

若复有人。受持读诵是佛名。超越世间不可数劫

南无最胜波头摩奋迅胜佛

若有人受持是佛名。超越世间四十劫

南无无量香胜王佛

若善男子。受持读诵是佛名。超越世间无量劫。常得宿命

南无宝华奋迅如来

若复有人。受持读诵是佛名。得千三昧。诸众生归命是人。为诸佛如来所共赞叹。是人超越世间千劫。不久转法轮

南无大光明如来

若有善男子。受持读诵是佛名。超越世间四十劫

南无宝藏佛

若有善男子。受持读诵是佛名。超越世间六十劫

南无宝胜佛

若有善男子。受持是佛名。若复有人舍七宝如须弥山。以用布施及恒河沙世界。若复有人受持读诵是佛名。此福胜彼

南无名降伏魔人胜佛　南无降伏贪人自在佛　南无降伏嗔人胜佛　南无降伏痴自在佛　南无降伏染魔人胜佛　南无降伏恨自在佛　南无降伏嫉人胜佛　南无降伏谄曲自在佛　南无降伏邪见人胜佛　南无降伏诸戏自在佛　南无法清净得名人胜佛　南无业胜得名自在佛　南无如意通清净得名人胜佛　南无起施得名自在佛　南无起持戒清净得名人胜佛　南无起忍辱得名自在佛　南无起精进得名人胜佛　南无施思惟得名自在胜佛　南无起持戒思惟得名人胜佛　南无法忍辱思惟得名自在佛　南无起思惟精进得名人胜佛　南无起禅成就得名自在佛　南无起般若得名人胜佛　南无禅思惟得名自在佛　南无般若思惟得名人胜佛　南无行不可思议得名自在胜佛　南无行不可思议得名人胜佛　南无行起得名自在佛　南无总持智清净光明人胜佛　南无总持色清净得名自在胜佛　南无总持雨清净得名人胜佛　南无陀罗尼性清净得名自在胜佛　南无陀罗尼称清净得名人胜佛　南无陀罗尼施清净得名自在佛　南无空行得名人胜佛　南无空无我得名自在佛　南无眼光明人胜佛　南无耳光明自在佛　南无鼻光明人胜佛　南无舌光明自在佛　南无身光明人胜佛　南无心光明自在佛　南无色光明人胜佛　南无声光明自在佛　南无降伏香人胜佛　南无味光明自在佛　南无触光明人胜佛　南无法光明自在佛　南无炎光明人胜佛　南无赞叹光明自在佛　南无地光明人胜佛　南无水光明自在佛　南无火光明人胜佛　南无风光明自在佛　南无光光明人胜佛　南无事光明自在佛　南无世光明人胜佛　南无拔苦自在佛　南无阴光明人胜佛　南无戒光明自在佛　南无不二光明人胜佛　南无生光明自在佛　南无声光明人胜佛　南无地华光明自在佛　南无鬘光明人胜佛　南无香盖光明自在佛　南无衣光明人胜佛　南无成就义佛　南无无畏王佛　南无不动佛　南无观世自在佛　南无无量命佛　南无尼弥佛　南无炎弥留佛　南无金刚佛　南无初出日然灯月华宝波头摩金光明身卢舍那放无碍宝光明照十方世界王佛　南无降伏龙佛　南无善调心佛　南无宝聚佛　南无火首佛　南无炎积佛　南无一切光明佛　南无日光佛　南无不可思议佛　南无无边精进佛　南无无边思惟佛　南无金色华佛　南无善香香佛　南无无诤行佛　南无无漏佛　南无无边智佛　南无贤身佛　南无贤相佛　南无遍见佛　南无无边威德佛　南无次佛　南无坚安隐佛　南无莎罗佛　南无得名佛　南无波头摩胜佛　南无称莲华佛　南无华佛　南无庄严佛　南无奋迅佛　南无善见佛　南无善敌对佛　南无善护世佛　南无无边威德佛　南无第一胜佛　南无善行佛　南无无量威德佛　南无妙胜佛　南无胜供养佛　南无大奋迅智声自在王佛　南无电光佛　南无照一切佛　南无不可思议佛　南无无量色佛　南无无量光佛　南无善光花敷身佛　南无须弥山波头摩胜王佛　南无求名发声修行佛　南无一切宝摩尼王放光明佛　南无无垢炎称成就王佛　南无香宝光明佛　南无离诸烦恼佛　南无善智佛　南无善见佛　南无宝山庄严佛　南无慈悲行佛　南无阎浮檀幢佛　南无无边智佛　南无无量威德佛　南无大称佛　南无宝称佛　南无火光明佛　南无大光明佛　南无电照光明佛　南无一切种照佛　南无不可量佛　南无月光佛　南无功德海佛　南无具足功德佛　南无上行佛　南无日光佛　南无无畏佛　南无师子幢佛　南无帝释幢佛　南无火幢佛　南无善眼佛　南无庄严王佛　南无放光明光佛　南无无边光佛　南无妙光佛　南无普护增上佛　南无云自在佛　南无自在幢佛　南无日灯佛　南无最上佛　南无善生佛　南无无边不可思议威德佛　南无普眼佛　南无波头摩上佛　南无妙去佛　南无月起佛　南无灯明佛　南无不厌足身佛　南无弥留幢佛　南无宝幢佛　南无火炎聚佛　南无自在幢佛　南无宝火佛　南无栴檀香佛　南无不定光明波头摩敷身佛　南无无边称功德光明佛　南无薝卜色佛　南无无量光明佛　南无快光明波头摩敷身佛　南无出须弥山波头摩王佛　南无星宿劫二万同名光作佛　南无二万同名卢舍那佛　南无二万同名释迦牟尼佛　南无同名帝释日太白星宿无量百千万不可数佛　南无无垢光明佛　南无功德宝光明佛　南无精进力成就佛　南无清净光佛　南无解脱一切缚佛　南无波头摩藏胜佛　南无得无障碍力解脱佛　南无不怯弱十力称香佛　南无卢舍那光明佛　南无宝聚佛　南无法幢悬佛　南无破一切暗曀佛　南无普光明庄严照作佛　南无光明作佛　南无大炎佛　南无无边行功德佛　南无法功德云然灯佛　南无然灯炬王佛　南无破一切众生闇胜佛　南无妙见佛　南无妙胜佛　南无妙闻佛　南无山峰佛　南无金圣佛　南无饮甘露佛　南无无量光明佛　南无宝鸡头佛　南无无边毗尼胜王佛　南无电照光明罗网佛　南无成就无量功德佛　南无无量乐说境界佛　南无智胜放光明佛　南无降伏电日月作光佛　南无普句素摩胜奋迅功德积佛　南无功德王光佛　南无善月佛　南无光庄严王佛　南无赊舍施鸡头佛　南无福德光佛　南无普光上胜山王佛　南无善住摩尼山王佛　南无断一切烦恼佛　南无释迦牟尼佛　南无破碎金刚坚固佛　南无宝炽佛　南无龙自在王佛　南无勇猛仙佛　南无宝月佛　南无离垢佛　南无无垢佛　南无勇猛得佛　南无净佛　南无梵得佛　南无婆楼那佛　南无婆楼那天佛　南无贤胜佛　南无栴檀胜佛　南无力士佛　南无欢喜威德胜佛　南无光明胜佛　南无无忧胜佛　南无句素摩胜佛　南无波头摩树提奋迅胜佛　南无财胜佛　南无念胜佛　南无善说名胜佛　南无因陀罗鸡头幢佛　南无步胜佛　南无善觉步胜佛　南无善步去佛　南无普照庄严胜佛　南无宝华步佛　南无宝波头摩善住山自在王佛　南无光明幢火众生庄严光王佛　南无妙平等法界智起声佛　南无广福德藏普光明照佛　南无普照大应罗网卢舍那佛　南无卢舍那华眼电光佛　南无最胜大师子意佛　南无到法界胜光卢舍那王佛　南无常无垢功德遍至称佛　南无日莲华胜王佛　南无法自在智幢佛　南无广喜无垢威德梵声佛　南无根本胜善导师佛　南无智力佛　南无弥楼威德佛　南无愿清净月光佛　南无法海愿出声光佛　南无宝功德相庄严作光佛　南无妙声地主天佛　南无胜进寂去佛　南无见众生欢喜佛　南无不动深光明卢舍那集慧佛　南无普放光明不可思议主佛　南无平等妙功德威德佛　南无速光明梵眼佛　南无解脱精进日光明佛　南无普法身觉慧佛　南无普门照一切众生门见佛

次礼十二部尊经大藏法轮

南无孔雀王咒经　南无兜沙经　南无清净毗尼方广经　南无文殊师利净律经　南无寂调音所问经　南无摄大乘释论　南无摄大乘论　南无菩萨地持论　南无菩萨善戒经　南无摄大乘本论　南无唯识论　南无成唯识论　南无坐禅三昧经　南无阿兰若习禅法经　南无摩登伽经　南无舍头谏经　南无过去现在因果经　南无太子本起瑞应经　南无修行本起经　南无楼炭经　南无大般涅槃经　南无佛般泥洹经　南无十报法经　南无普法义经　南无尸迦罗越六向拜经　南无梵网六十二见经　南无寂志果经　南无梵志阿跋经　南无七佛父母姓字经　南无梵志頞罗延问种尊经　南无本相倚致经　南无缘本致经　南无阿难问事佛吉凶经　南无佛说阿难分别经　南无罪福报应经　南无业报差别经　南无五母子经　南无沙弥罗经　南无阿速达经　南无玉邪经　南无长者诣佛说子妇不恭敬经　南无七妇经　南无盂兰盆经　南无报恩奉盆经　南无灌腊经　南无摩邓女经　南无摩登女解形六事经

敬礼十方诸大菩萨摩诃萨

南无降伏一切魔音菩萨　南无大悲方便雷云音菩萨　南无灭一切苦安慰音菩萨　南无法上菩萨　南无胜上菩萨　南无智上菩萨　南无功德须弥山上菩萨　南无功德珊瑚上菩萨　南无称上菩萨　南无普光上菩萨　南无大慈菩萨　南无智海上菩萨　南无如来性起上菩萨　南无光妙德菩萨　南无胜妙德菩萨　南无上妙德菩萨　南无明净妙德菩萨　南无法妙德菩萨　南无月妙德菩萨　南无虚空妙德菩萨　南无宝妙德菩萨　南无妙德幢菩萨　南无智妙德菩萨　南无娑罗林王菩萨　南无众生王菩萨　南无梵王菩萨　南无山王菩萨　南无宝王菩萨　南无离生王菩萨　南无寂静王菩萨　南无不动王菩萨　南无仙王菩萨　南无胜王菩萨　南无静音菩萨　南无无碍音菩萨　南无开悟过去愿音菩萨　南无圆满道音菩萨　南无智须弥山音菩萨　南无虚空觉菩萨　南无离垢觉菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无尊者了本际　南无尊者正愿　南无尊者正语　南无尊者大号　南无尊者仁贤　南无尊者离垢　南无尊者名闻　南无尊者善实　南无尊者具足　南无尊者牛王

归命如是等众所知识大阿罗汉

礼三宝已次复忏悔

弟子等敬请十方诸佛十二部经一切贤圣。天龙八部法界众生现前大众等证知。弟子等。自从无始已来所造众罪无量无边。今日至心发露忏悔。归依佛

南无东方无限净佛　南无南方须弥佛　南无西方金刚步积佛　南无北方贤最佛　南无东南方大兴光明佛　南无西南方妙宝佛　南无西北方一乘佛　南无东北方坏魔罗网独步佛　南无下方意无恐惧佛　南无上方无量尊离垢王佛

归命如是等十方尽虚空界一切三宝

弟子等今者为诸众生及自己身。十方佛前归命忏悔。一切众生无量劫来不识诸佛及父母恩。不解善法造作众恶。自恃种性及诸财宝。盛年放逸作诸恶行。心念不善口作恶业。随心所造不见其过。凡夫愚行无知闇覆。亲近恶友烦恼乱心。五欲因缘心生忿恚。不知厌足故作众恶。亲近非圣因生悭嫉。贫穷因缘奸谄作恶。系属于他常有怖畏。不得自在而造诸恶。贪欲恚痴挠动其心。渴爱所逼造作诸恶。依因衣食及以女色。诸结恼热。爱他男子染着其心。或于牛马驴骡羊一切禽兽诸色异类而生女想。不依佛行造作诸恶。身口意业所集三业。如是众罪无量无边今悉忏悔。弟子等自从无始已来至于今日。或不恭敬佛法圣僧。如是众罪今悉忏悔。或不恭敬缘觉菩萨。如是众罪今悉忏悔。以无智故诽谤正法。不知恭敬父母尊长。愚惑所覆憍慢放逸。因贪嗔痴造作诸恶。如是众罪今悉忏悔。好乐饮酒不知止极。或以酒与僧与持戒人。与比丘尼。若灭心人若禅定人。如是等罪无量无边。今日运心归命忏悔

弟子等从无始劫来所有众恶。以是因缘生大忧苦。贫穷困乏愁热惊惧。怖畏恶业心常怯劣。在在处处暂无欢乐。十方现在大悲世尊。能除众生一切怖畏。愿受我等诚心忏悔。过去诸恶今悉悔过。现在作业诚心发露。所未作者更不敢作。已作之业不敢覆藏。身业三种口业有四。意三业行今悉忏悔。生死崄难种种淫欲愚烦恼难。如是诸难今悉忏悔。心轻躁难。近恶友难。三有崄难。及三毒难。遇无难难。值好时难。修功德难值佛亦难。如是诸难。今悉忏悔

弟子等自从无始劫来乃至今身。杀害一切三宝师僧父母六亲眷属善知识法界众生不可知数。偷盗一切三宝师僧父母六亲眷属善知识法界众生物不可知数。于一切三宝师僧父母六亲眷属善知识法界众生上。起邪心不可知数。妄语欺诳一切三宝师僧父母六亲眷属善知识法界众生不可知数。绮语调弄一切三宝师僧父母六亲眷属善知识法界众生不可知数。恶口骂辱诽谤毁訾一切三宝师僧父母六亲眷属善知识法界众生不可知数。两舌斗乱破坏一切三宝师僧父母六亲眷属善知识法界众生不可知数。或破五戒八戒。十戒十善戒。二百五十戒五百戒。菩萨三聚戒十无尽戒。乃至一切戒及一切威仪戒等。自作教他见作随喜不可知数。如是等众罪。亦如十方大地无边微尘无数。我等作罪亦无边无数。虚空无边我等作罪亦复无边。方便无边我等作罪亦复无边。法性无边我等作罪亦复无边。法界无边我等作罪亦复无边。众生无边我等劫夺杀害亦复无边。三宝无边我等侵损亦复无边。戒品无边我等毁犯亦复无边。如是等罪上至诸菩萨下至声闻缘觉所不能知。唯佛与佛乃能知我罪之多少。今于三宝前法界众生前。发露忏悔不敢覆藏。唯愿十方三宝法界众生。听我忏悔

愿弟子等承是忏悔所生功德。愿生生世世永舍胎藏形。随心愿往生获六神通力救摄诸苦众。虚空法界尽我愿亦如是。地狱饿鬼一切众生贫穷困厄。及诸有苦烦恼所逼。如是等苦悉令除灭。又愿弟子承是忏悔所成功德。愿离于生死到大智岸。转无上轮微妙清净。诸所愿求成就具足。又愿盲者得视。聋者得听。哑者能言。裸者得衣。贫穷乏者则得宝藏。仓库盈溢无所乏少。一切皆受安隐快乐。乃至无有一人受苦。又愿众生慈心相向佛眼相看。形貌端严人所喜见。上妙色像庄严其身。为菩提眷属作真善知识

    大乘莲华宝达问答报应沙门经

宝达顷前更入[月*鬼]肉地狱。云何名曰[月*鬼]肉地狱。其地狱纵广四十由旬。铁壁周匝铁网覆上。烟火俱然如上无异。地有铁锵火亦洞然。中有铁床方圆五百余步。床上火然来烧罪人。南门之中有六百罪人。似是人形而非人也。身长一丈亦无口眼手脚六根

尔时马头罗刹手捉铁钩望身而挑。罪人身动似有人声。唱如是言。我今何罪受如是苦。狱卒抛身来入狱中。狱中铁锵逆刺其身。身中血出火则入中。复有饿鬼来食其肉。复有饿狗来饮其血。复有铁乌来啄其筋。复有猛风来吹罪人。一日一夜受罪万端。千死千生万死万生。若得为人贫穷痴闇不识佛语

宝达问马头罗刹曰。此诸沙门作何罪故受苦如是。马头罗刹答曰。此诸沙门受佛禁戒不求无上菩提。但求现在名利。贪饮酒故破法破戒三十六失。以是因缘堕此地狱。宝达闻之悲泣而去

佛名经卷第十四佛说佛名经卷第十五

南无迦那伽无垢光明日炎云佛　南无因陀罗光明疑幢佛　南无一切地处无垢月佛　南无觉虚空平等相佛　南无十方广应云幢佛　南无平等不平等卢舍那佛　南无害心悲解脱空王佛　南无成就一切义须弥佛　南无不空步照见佛　南无妙吼胜佛　南无第一自在通王佛　南无不可思议功德卢舍那妙月佛　南无可信力幢佛　南无法界树声智慧佛　南无波头摩光长善臂佛　南无不退功德海光佛　南无普生妙一切智速佛　南无师子光无量力智佛　南无见一切法清净胜智佛　南无远离一切忧恼佛　南无自在妙威德佛　南无金华火光佛　南无观法界奋迅佛　南无然灯紧那罗王佛　南无然香灯佛　南无应王佛　南无如来功德普门见佛　南无一切法普奋迅王佛　南无广化自在佛　南无法界解脱光明不可思议意佛　南无如来无垢光佛　南无卢舍那世间轮胜声佛　南无波头摩须无边眼佛　南无喜乐成佛　南无一切智行境界慧佛　南无广寂妙声佛　南无虚空无垢智月佛　南无福德海厚云相花佛　南无能作善胜云佛　南无胜声云幢佛　南无胜声吼幢佛　南无观眼奋迅佛　南无无尽智金刚佛　南无普眼日藏照佛　南无一切吼声佛　南无无量智敷佛　南无一切福德弥楼上佛　南无根日威德佛　南无满光明身光佛　南无地第一华相佛　南无云无畏见佛　南无平等言语鸡头佛　南无实然灯王佛　南无坚精进奋迅成就义心佛　南无普照观称佛南无慈光明称胜佛　南无福德称上胜佛　南无念一切众生称胜佛　南无须弥山称胜佛　南无毕惭愧称上胜佛　南无教化一切世间佛　南无离一切忧佛　南无离一切难佛　南无离一切世间佛　南无能转胎佛　南无转女佛　南无转男女降伏佛　南无佛华胜上王佛　南无不空说名佛　南无善慧法通王佛　南无十方广功德称天尽乐佛　南无爱大智见不空闻名佛　南无无量力智胜佛　南无成就梵功德佛　南无香象佛　南无金刚蜜迹佛　南无善转成就义佛　南无卢舍那花胜威德佛　南无常功德然灯去慧佛　南无到诸疑彼岸月佛　南无到法界无量声慧佛　南无然灯胜光明佛　南无法界日光明佛　南无无边光中功德海转法轮声佛　南无日不可思议智见佛　南无宝胜光明威德王佛　南无无尽功德妙庄严佛　南无不可量力普吼佛　南无普眼满足然灯佛　南无胜功德炬佛　南无大龙声佛　南无波头摩师子座奋迅齐佛　南无智聚觉光佛　南无住持地善威德王佛　南无善住法然灯王佛　南无不空见生喜作佛　南无放身炎幢佛　南无清净众生行佛　南无一切德云普光明佛　南无敷华相月智佛　南无第一光明金庭燎佛　南无观一切法海无差别光明佛　南无化日佛　南无宝盖胜卢舍那佛　南无善思惟佛　南无精进胜坚慧佛　南无敷华心波头摩佛　南无清净眼佛　南无月光自在佛　南无无尽法海宝幢佛　南无金刚波头摩胜佛　南无广俱苏摩作佛　南无人自在幢佛　南无一切智轮照卢舍那佛　南无龙称无量功德佛　南无宝功德须光佛　南无一切力庄严慧佛　南无宝炎须弥山佛　南无一切行光明胜佛　南无一切波罗蜜海佛　南无宝炎面门幢佛　南无成就一切愿光明佛　南无广得一切法齐佛　南无光明罗网胜佛　南无宝山幢佛　南无无边中智海藏佛　南无清净一切义功德幢佛　南无一切通首王佛　南无无障碍一切法界卢舍那佛　南无胜三昧精进慧佛　南无无碍法界然灯佛　南无无碍法界须弥幢胜王佛　南无菩提分俱苏摩作王佛　南无得世间功德大海佛　南无宝师子力佛　南无普智海王佛　南无波头摩善化幢佛　南无无尽光明普门声佛　南无普功德云胜威德佛　南无胜慧海佛　南无智月华云佛　南无香光威德佛　南无普门见无障碍清净佛　南无不可降伏法自在慧佛　南无波头摩光明敷王佛　南无大精进善智慧佛　南无坚王幢佛　南无不可降伏妙威德佛　南无精进德佛　南无一切功德胜心王佛　南无善成就无边功德王佛　南无断诸疑广善眼佛　南无妙功德胜慧佛　南无过诸光明胜光明佛　南无须弥山然灯佛　南无无尽化善云佛　南无无量光明化王佛　南无白智梵行佛　南无师子眼炎云佛　南无大海天炎门佛　南无觉佛智胜佛　南无无量昧大圣佛　南无无垢速云闻佛　南无满法界卢舍那佛　南无金色华佛　南无大功德花敷无垢佛　南无照胜威德王佛　南无不住眼无垢佛　南无无碍庄严佛　南无法智差别佛　南无转灯轮幢佛　南无法界轮佛　南无一切佛宝胜王佛　南无无边光明智轮幢佛　南无无著智幢佛　南无师子佛　南无月智佛　南无日照佛　南无常放普光明舌功德海王佛　南无无边光明法界庄严王佛　南无长臂佛　南无高见佛　南无无垢地平等光明世界普照十方光明声吼虚空卢舍那佛　南无清净华池庄严世界普门见妙光明佛　南无无边功德住持世界无转功德普光佛　南无弥留胜然灯世界普光明虚空镜像佛　南无一切妙声善爱闻世界喜乐见华火佛　南无妙声庄严世界宝须弥山然灯佛　南无一切宝色庄严光明照世界善化法界声幢佛　南无香藏金刚庄严世界金刚光明电声吼佛　南无炎声世界不可降伏力月佛　南无宝波头摩间错庄严无垢世界法城慧吼声佛　南无能与乐世界十方世界广称名智灯佛　南无手无垢善无垢罗网世界师子光明满足功德大海佛　南无妙华幢照世界大智敷华光明佛　南无无量庄严间错世界高智种种华光明佛　南无无边庄严世界普满法界幢眼佛　南无宝昼普光庄严世界妙慧上首佛　南无须王世界作月光明幢佛　南无无垢藏庄严世界善觉梵威德佛　南无宝光明身世界一切种力虚空然灯佛　南无宝首璎珞成就世界一切诸波罗蜜相大海威德佛　南无轮尘普盖世界断一切着喜作佛　南无宝鬘妙幢世界大称广功德吼照佛　南无不可思议庄严普庄严光明世界无差别智光明功德海佛　南无无尽光明择幢世界无边法界无垢光明佛　南无放宝炎华世界清净宝镜像佛　南无威德炎藏世界无障碍奋迅光明吼佛　南无宝轮平等光庄严世界普宝光明佛　南无栴檀树须幢世界清净一切念无碍光明佛　南无佛国土色轮善修庄严世界广喜见光明智慧佛　南无微细光明庄严照世界法界奋迅善观佛　南无无边色形相世界无障碍智成就佛　南无普炎云火然世界不退转法轮吼佛　南无种种宝庄严清净轮世界清净色相华威德佛　南无究竟善修世界无障碍日眼佛　南无善作坚固金刚座成就胜世界过法界智身光明佛　南无十方庄严无障碍世界宝广炬佛　南无差别色光明世界普光明华云王佛　南无宝门种种幢世界普见妙功德光明佛　南无摩尼顶作须光明世界普十方声云佛　南无自在摩尼金刚藏世界智胜须弥王佛　南无摩尼衣座成就胜世界放香光明功德宝庄严佛　南无华优波罗庄严世界普智幢声王佛　南无宝庄严种种藏世界一切法无畏然灯佛　南无香胜无垢光明世界普喜速胜王佛　南无日幢乐藏世界普门智卢舍那吼佛　南无香庄严快藏世界无量功德海光明佛　南无宝师子火光明世界法界电光佛　南无相快照世界无障碍功德称解脱光明王佛　南无功德成就光明照世界清净眼无垢然灯佛　南无种种香华胜庄严世界师子光明胜光佛　南无宝庄严平等光明世界广光明智胜幢佛　南无种种光明髻快世界金光明无量力日成就佛　南无放光句素摩沉沦世界香光明喜力坚固佛　南无光明清净种种作世界光明力坚固佛　南无光明清净种种作世界普光明大自在幢佛　南无句素弥多炎轮庄严世界喜海庄严功德称自在王佛　南无地成就威德世界广称智海幢佛　南无放声吼世界相好光明月佛　南无金刚幢世界一切法海胜王佛　南无无量功德庄严世界无量众生功德法住佛　南无光明照世界梵自在胜佛　南无生无垢光明世界妙法界胜吼佛　南无种种光明照然灯世界不可嫌力普光明幢佛　南无照平等光明世界无垢功德日眼佛　南无宝作庄严藏世界无障碍智普照十方佛　南无无尘世界无量胜行幢佛　南无清净光明世界法界虚空平等光明照佛　南无宝藏波浪胜成就世界功德相云胜威德佛　南无宫殿庄严幢世界卢舍那胜顶光明佛　南无髻胜藏世界一切法无边海慧佛　南无善化香胜世界相法化普光佛　南无快地色光世界善眷属卢舍那佛　南无善作敷华世界法行喜无尽慧佛　南无胜福德威德轮世界无垢清净普光明佛　南无摩尼宝波头摩庄严世界清净眼华胜佛　南无炎地成就世界无量力成就慧佛　南无梵照世界虚空广眼月佛　南无声尘平等世界金色然弥楼然灯佛　南无宝色庄严世界智胜妙法界光明佛　南无金色善光明世界宝然灯普光明幢佛　南无卢舍那光明月世界火胜华奋迅善照佛　南无宝月作藏世界无尽功德华威德佛　南无镜光明照世界行力甘露吼声佛　南无妙栴檀快月庄严世界妙法智慧胜威德光明佛　南无无边功德聚集世界无边精进光明功德胜王佛　南无大庄严成就世界日灯王佛　南无波头摩跋提世界普华佛　南无摩梨支世界虑舍那佛　南无清净行世界那罗延华幢佛　南无有华世界波头摩威德佛　南无有云世界雷声王佛　南无不可行世界薝卜色佛　南无莲华世界波头摩胜佛　南无光幢世界光明王佛　南无无边功德庄严光明世界庄严王佛　南无无量光明世界普贤佛　南无无边功德宝作示现安乐世界无边功德宝集示现安乐金色光明师子奋迅王佛　南无普宝间错世界普光明妙胜山王佛　南无普无垢世界无垢称王佛　南无清净行世界普华佛

善男子。如是诸世界中诸佛一切归命及彼菩萨摩诃萨一切大众亦悉归命

尔时诸比丘白佛言。世尊。世尊如是诸佛如来所有寿命长短等不

佛告诸比丘。汝等谛听当为汝说。比丘。我此娑婆世界贤劫释迦牟尼佛国土一劫。于安乐世界为一日一夜。若安乐世界阿弥陀佛国土一劫。于袈裟幢世界碎金刚佛国土。为一日一夜。若袈裟幢世界一劫。于不退轮吼世界善快光明波头摩敷身如来佛国土。为一日一夜。若不退轮吼世界一劫。于无垢世界法幢如来佛国土。为一日一夜。若无垢世界一劫。于善然灯世界师子如来佛国土。为一日一夜。若善然灯世界一劫。于善光明世界卢舍那藏如来佛国土。为一日一夜。若善光明世界一劫。于难过世界法光明波头摩敷身如来佛国土。为一日一夜。若难过世界一劫。于庄严慧世界一切通光明如来佛国土。为一日一夜。若庄严慧世界一劫。于镜轮光世界月智如来佛国土。为一日一夜。比丘入如是数满足。过十阿僧祇百千万世界。最后波头摩胜世界。于贤胜如来佛国土。为一日一夜。比丘。如是等世界无量无边长短不等。诸佛如来寿命住世亦复如是。诸比丘。汝等应当称诸佛名(胡本中自此以下皆有世界名此略除也)作如是言

南无如是等诸佛如来　南无不动智佛　南无阿尼罗智佛　南无婆留那智佛　南无阿私陀智佛　南无行智佛　南无阿楼那智佛　南无常智佛　南无妙智佛　南无乐自在天佛　南无梵天佛　南无胜智天佛　南无庵摩罗月佛　南无不退月佛　南无不动月佛　南无阿尼罗月佛　南无婆留那月佛　南无阿私陀月佛　南无胜月佛　南无阿楼那月佛　南无无垢月佛　南无胜智月佛　南无不退眼佛　南无第一眼佛　南无阿尼罗眼佛　南无不动眼佛　南无阿私陀眼佛　南无行眼佛　南无阿楼那眼佛　南无婆留那眼佛　南无胜眼佛　南无微妙清净眼佛　南无不退幢佛　南无阿尼罗幢佛　南无阿私陀幢佛　南无婆留那幢佛　南无行幢佛　南无阿楼那幢佛　南无常幢佛　南无妙幢佛　南无自在幢佛　南无梵幢佛　南无胜幢佛　南无弥留幢佛　南无波头摩胜藏佛　南无普眼佛　南无梵命佛　南无金刚齐佛　南无婆薮天佛　南无一切法决定王佛　南无弥留幢寂眼胜佛　南无致沙佛　南无弗沙佛　南无波头摩胜佛　南无大光明佛　南无法意佛　南无善法佛　南无称胜佛　南无宝慧佛　南无微妙眼佛　南无灯佛　南无择义佛　南无自在佛　南无婆薮天佛　南无不去佛　南无择胜佛　南无妙行佛　南无无碍月佛　南无无边智上首佛　南无普眼佛　南无厚婆波罗佛　南无妙胜佛　南无日光佛　南无无边光佛　南无法幢佛　南无无边智然灯佛　南无普功德观然灯佛　南无功德佛　南无金刚幢佛　南无普智宝炎胜功德幢佛　南无因陀罗幢胜幢佛　南无普智宝炎胜功德鸡都佛　南无无垢轮大悲云幢佛　南无百忆定光佛　南无光远佛　南无月光佛　南无栴檀香佛　南无善山王佛　南无须弥天冠佛　南无须弥等曜佛　南无月色佛　南无正念佛　南无离垢佛　南无无著佛　南无龙天佛　南无不动地佛　南无琉璃妙华佛　南无琉璃金色佛　南无金藏佛　南无炎光佛　南无炎根佛　南无地种佛　南无月像佛　南无日音佛　南无解脱华佛　南无庄严光明佛　南无海觉神通佛　南无水光佛　南无大音佛　南无离垢佛　南无舍厌意佛　南无宝炎佛　南无妙顶佛　南无勇立佛　南无功德持慧佛　南无蔽日月光佛　南无日月琉璃光佛　南无无上琉璃光佛

次礼十二部尊经大藏法轮

南无杂藏经　南无鬼问目连经　南无饿鬼报应经　南无目连说地狱饿鬼因缘经　南无琉璃王经　南无鸯崛髻经　南无指鬘经　南无力士移山经　南无三摩竭经　南无大爱道般泥洹经　南无须达经　南无行七行现报经　南无阿难同学经　南无增一阿含经　南无群牛譬经　南无国王不黎先尼十梦经　南无波斯匿王太后崩土坌身经　南无食施获五福报经　南无四未曾有法经　南无阿那邠邸化七子经　南无放牛经　南无长者子六过出家经　南无漏分布经　南无四谛经　南无是非法经　南无一切流摄守因缘经　南无顶生王故事经　南无阎罗王五天使者经　南无古来世时经　南无长寿王经　南无阿那律八念经　南无释摩男本经　南无瞿昙弥记果经　南无诸法本经　南无摩娆乱经　南无赖吒和罗经　南无梵摩喻经　南无鹦鹉经　南无齐经　南无十支居士八城人经　南无恒水经　南无比丘问佛多优婆塞命终经　南无佛说求欲经　南无孙多邪致经　南无凡人有三事愚痴不足经　南无蓱沙王五愿经　南无七知经

敬礼十方诸大菩萨摩诃萨

南无无碍觉菩萨　南无善觉菩萨　南无普照三世觉菩萨　南无广觉菩萨　南无普光觉菩萨　南无法界光觉菩萨　南无明净愿光明菩萨　南无不可坏精进势王菩萨　南无无上普妙德王菩萨　南无无碍妙德藏王菩萨　南无法界善化愿同王菩萨　南无法义慧炎王菩萨　南无坏散一切众魔智幢王菩萨　南无明净愿智幢王菩萨　南无坏散一切障智慧势王菩萨　南无分别法界智通王菩萨　南无慧林菩萨　南无胜林菩萨　南无无碍林菩萨　南无惭愧林菩萨　南无精进林菩萨　南无力成就林菩萨　南无坚固林菩萨　南无如来林菩萨　南无智林菩萨　南无胜音菩萨　南无师子炎光奋迅音菩萨　南无众宝光幢菩萨　南无智日超慧菩萨　南无不思议功德智称菩萨　南无方便寂静妙华髻菩萨　南无金光炎菩萨　南无法界普音菩萨　南无净云月幢菩萨　南无善超净光菩萨　南无观胜法妙清净王菩萨　南无清净海慧菩萨　南无香炎平等庄严月光菩萨　南无师子光庄严菩萨　南无功德法藏菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

南无尊者满愿子　南无尊者离障　南无尊者流灌子　南无尊者坚伏　南无尊者面王　南无尊者异来　南无尊者仁性　南无尊者嘉乐　南无尊者善来　南无尊者罗云

归命如是等众所知识大阿罗汉

礼三宝已次复忏悔

弟子等已忏悔诸报竟。今当重更总都忏悔诸罪。殷勤启请十方诸佛。救护弟子我等从无始无量百千万亿劫已来。造作恶业不可具说。或犯十恶或犯五逆及谤方等。或造无量阿僧祇罪。今者归命十方佛。归命十方法。归命十方僧。次复归命稽首东方阿閦佛。南方宝相佛。西方阿弥陀佛。北方妙胜佛。上方香积如来。下方亿像佛。稽首东方普贤大士。南方持世大士。西方观音大士。北方满月大士。上方虚空大士。下方坚德大士。本师释迦牟尼佛。归命未来佛性。又复稽首他方分身化佛大士维摩文殊师利。亦复稽首阿难迦叶出现四道圣人。亦复归命有教初心。稽首大藏十二部经。及于余经方等正典八分舍利形像。亦复归命现有佛事。四方天王忉利释梵三十三天。虚空天上地上地下有诸山林树下一切神仙。有大神足有天眼者有天耳者。愿赐闻知皆为证明。愿一切众生。若未忏者得此忏已皆得灭罪。弟子今日忏悔。披肝露胆至诚归依佛

南无东方不动智佛　南无南方日月灯光佛　南无西方殊胜佛　南无北方德内丰严王佛　南无东南方成首佛　南无西南方宝照空佛　南无西北方见无恐惧佛　南无东北方师子力佛　南无下方断疑拔欲除冥佛　南无上方金宝光明佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始世界已来。及今恶身狂惑心乱。无量倒见烦恼恶业不可具陈。所作众罪不自觉知。恶心炽盛不见后世。但见现在乐习烦恼远离善根。恶业障碍近恶知识。或于比丘边作非法。比丘尼边作非法。父母边作非法。或复大众前作非法。或复自在用僧鬘物。或于五部僧边或作是非或说世间无量恶果。或杀菩提善根众生。或谤法师。法说非法非法说法。谓如来无常正法无常僧宝无常。不乐惠施信受邪法。如是等罪无量无边。是故今日无量怖畏无量惭愧。归依三宝诸佛慈悲方等父母菩萨知识。听许我等今日发露忏悔

弟子等自从无量劫来造作五逆。或犯过去未来现在诸佛禁戒。作一阐提行。发粗言诽谤正法。造是重业未曾改悔心无惭愧。或犯十恶等罪。自知定犯如是重事。本心初无怖畏惭愧。嘿受供养未曾发露。于彼正法未有护惜建立之心。于其中间毁訾轻贱言多过恶。或复说言无佛法僧。或复不信有诸地狱受报。如是等罪无量无边。今日无量怖畏无量惭愧归依三宝。诸佛慈悲方等父母菩萨知识。听许我等发露忏悔

弟子等自从无量劫来至于今日。或四倒见四重之法说偷兰遮。偷兰遮法说为四重。犯说非犯非犯说犯。轻罪说重重罪说轻。净见不净不净见净。或复邪见赞说世典不敬佛经。诸恶论议畜八不净。真是佛语以为魔语。真是魔语以为佛语。或复信受六师所说。或作是言。如来今日已归涅槃三宝无常。身心起惑无量倒见。是故今日无量怖畏无量惭愧。归依三宝诸佛慈悲方等父母菩萨知识。听许我等发露忏悔

愿弟子等承是忏悔所生功德。愿生生世世拔济十方一切众生。远离十恶修行十善。所有诸苦使得安止。不可思议阿僧祇众令住十地。若此国土及余世界所有善法悉以回向。我所修行身口意善。愿于来世证无上道。愿诸女人皆成男子。具足智慧精勤不懈。一切皆行菩萨之道。勤心修集六波罗蜜。若此阎浮及余他方。无量世界所有众生。所作种种善妙功德。我今深心随其欢喜。我今以此随喜功德。及身口意所作善业。愿于来世成无上道。得净无垢吉祥果报。悉令具足如来正觉

    大乘莲华宝达问答报应沙门经

宝达顷前更入一身然地狱。云何名曰身然地狱。其地狱中纵广五十由旬。铁壁周匝猛火绝焰来烧罪人。罪人身中亦皆火然。罪人毛孔烟火俱出。东门之中有八百罪人。来入其中唱声大叫。举身自椎我今何罪来入其中。马头罗刹手捉三股铁叉。望背而撞胸前而出。来入其中地有火然。身中有火亦复火然。六根之中火流而出。一日一夜受罪无量。求生不得求死不得

宝达问马头罗刹曰。此诸沙门作何等罪受苦如是。罗刹答曰。此诸沙门或是其师或为弟子不相顺从。师不慈弟子。弟子不敬师。各相嗔恚高声大唤怒目诤竞遂生怨憎堕此地狱从地狱出世世相值恒相杀害。宝达闻之悲泣而去

佛名经卷第十五佛说佛名经卷第十六

南无金刚那罗延幢佛　南无无碍胜行佛　南无火炎佛　南无山胜庄严佛　南无一切法海上庄严速住佛　南无深法海妙光佛　南无宝炎围然灯佛　南无功德海光明轮胜佛　南无卢遮那胜藏佛　南无满虚空法界尸佉罗胜然灯佛　南无不退然灯佛　南无法界吼佛　南无妙法树山王威德佛　南无一切法海吼王佛　南无宝光明然灯幢佛　南无须弥功德光威德佛　南无法云吼王佛　南无智炬然灯王佛　南无法电速幢胜佛　南无法然灯奋迅师子佛　南无智力威德山王佛　南无不退法界吼佛　南无电光明劫善照世界初放旃檀香光明照佛　南无善决定清净劫无垢世界初卢舍那佛　南无甘露庄严劫善清净世界初栴檀然灯王佛　南无善住劫妙香世界初须弥光明胜王佛　南无善见劫庄严世界初无边功德种种宝庄严王佛　南无炎清净劫清净世界初金刚奋迅王佛　南无不可嫌劫不可嫌世界初毗沙门佛　南无不可嫌劫不可嫌称初世界初宝月佛　南无不可呵劫称财世界初不可思议光明佛　南无清净庄严劫乐清净世界初观世音佛　南无真尘劫光明尘世界初火光明佛　南无梵囋叹劫清净世界初力庄严王佛　南无德光明庄严劫月幢世界初善眼佛　南无栴檀香行平等胜成就佛　南无法海吼光明王佛　南无无垢转法轮佛　南无寂静威德王佛　南无虚空劫然灯佛　南无天自在藏佛　南无日罗幢罗都王佛　南无信威德佛　南无宝华藏佛　南无妙日身佛　南无不浊身佛　南无一切智光明月佛　南无阎浮檀威德王佛　南无相庄严身佛　南无种种光明火月佛　南无善观智鸡都佛　南无无垢智光明王佛　南无金刚那罗延精进佛　南无不可降伏智处佛　南无普无垢智通佛　南无无垢眼胜云佛　南无师子智佛　南无金刚菩提光明佛　南无光灯火髻佛　南无智日鸡都佛　南无宝波头摩敷身佛　南无得功德佛　南无智光明云光佛　南无普照月佛　南无无障盖吼佛　南无普光明奋迅师子佛　南无法界境界慧月佛　南无一切虚空乐说觉佛　南无初香善名佛　南无普声寂静吼佛　南无甘露山威德佛　南无法海吼声佛　南无善坚罗网竖佛　南无虚空镜像头髻佛　南无光明月微尘佛　南无善智满月面佛　南无清净智华光明佛　南无宝焰山胜王佛　南无无垢功德火光明佛　南无宝月幢佛　南无三昧轮身佛　南无宝胜光明威德王佛　南无普智行佛　南无焰海然灯佛　南无法无垢吼王佛　南无不可比功德称幢佛　南无长臂本愿无垢日佛　南无相智义然灯佛　南无法起宝齐庸声佛　南无胜照藏王佛　南无乘幢佛　南无法海波头摩广信无畏天佛　南无法海吼光王佛　南无无垢法山佛　南无法轮光明髻佛　南无法日胜云佛　南无法海说声王佛　南无法日智轮然灯佛　南无法华鸡都幢云佛　南无法焰山鸡都王佛　南无法行深胜月佛　南无法智普镜佛　南无藏普智作照佛　南无山王胜藏王佛　南无普门贤照佛　南无连一切法精进幢佛　南无法宝华胜云佛　南无寂光明深髻佛　南无法光明慈乐说光明日佛　南无焰海佛　南无智日普光明佛　南无普轮顶佛　南无智光明王佛　南无福德光华灯佛　南无智师子鸡都幢王佛　南无日光明王佛　南无宝相山佛　南无庄严山佛　南无日步普照佛　南无法罗网觉胜月佛　南无无畏那罗延师子佛　南无普智不二勇猛佛　南无法波头摩敷身佛　南无功德华胜海佛　南无菩提轮善觉胜月佛　南无然法炬胜月佛　南无普贤镜像髻佛　南无法幢然灯佛　南无金刚海幢王佛　南无称山胜云佛　南无栴檀胜月佛　南无普功德华威德光佛　南无照众生王佛　南无胜波头摩华藏佛　南无香焰光明胜佛　南无因波头摩佛　南无相山卢舍那佛　南无普闻名称幢佛　南无普门光明须弥佛　南无法成光胜佛　南无功德威德佛　南无相胜法力勇猛幢佛　南无转法轮光明吼佛　南无光明功德山波若照佛　南无转法轮月妙胜佛　南无法华卢舍那清净鸡都佛　南无宝波头摩光明藏佛　南无宝山云灯佛　南无普觉华佛　南无种种光明胜弥留藏佛　南无光明轮峰王佛　南无福德云盖佛　南无法峰云幢佛　南无功德山威德佛　南无法月云灯王佛　南无法云称胜月佛　南无法轮力云佛　南无香幢智威德佛　南无法轮清净胜月佛　南无金山威德贤佛　南无贤首弥留威德佛　南无普慧云吼佛　南无法力胜山佛　南无香焰胜王佛　南无伽那迦摩尼山声佛　南无顶藏一切法光明轮佛　南无然法轮威德佛　南无山峰胜威德佛　南无普精进炬光明云佛　南无三昧贤宝天冠光明佛　南无胜宝光佛　南无法炬宝帐声佛　南无乐法光明师子佛　南无庄严相月幢佛　南无光明山雷电云佛　南无无垢幢佛　南无无碍法虚空光明佛　南无快智华敷身佛　南无世间妙光明声佛　南无法三昧光明声佛　南无法声多藏佛　南无法火焰海声佛　南无三世相镜像威德佛　南无高法轮光明佛　南无法界师子光佛　南无卢舍那胜须弥佛　南无一切三昧海师子佛　南无普光慧然灯佛　南无法界城然灯佛　南无普门吼光明王佛　南无贤首佛　南无普光首佛　南无胎王佛　南无法界然灯佛　南无虚空山照佛　南无阿尼罗有眼佛　南无龙自在王佛　南无普照胜须弥王佛　南无无碍虚空智鸡都幢王佛　南无普智光明照十方吼佛　南无云王吼声佛　南无不空见佛　南无普照佛　南无实声佛　南无妙声佛　南无法火焰光明佛　南无金色宝作界妙佛　南无金阎浮幢子遮那光明佛　南无金色百光明佛　南无实称佛　南无不空称佛　南无日爱佛　南无成就智义佛　南无普贤佛　南无无垢光明鸡都王佛　南无宝焰佛　南无日月佛　南无海胜佛　南无法幢佛　南无无边功德王佛　南无宝藏佛　南无无垢面佛　南无无量寿华佛　南无宝聚佛　南无萨婆毗浮佛　南无智起佛　南无普护佛　南无离垢光佛　南无德首佛　南无妙德山佛　南无人王佛　南无无上华佛　南无无畏力王佛　南无师子依王佛　南无龙自在王佛　南无自在王佛　南无普散金光佛　南无勇猛佛　南无金山宝盖佛　南无金华焰光明佛　南无慧光明佛　南无千光明佛　南无妙尊智王佛　南无宝盖灯王佛　南无慧幢胜庄严王佛　南无无垢藏佛　南无光明相佛　南无金焰光明佛　南无金白光明藏佛　南无观世音佛　南无强胜力王佛　南无过去分身诸佛　南无现在无量诸佛　南无十亿幢王明诸佛　南无离垢紫金沙佛　南无无量明佛　南无日轮光明王佛　南无香积佛　南无师子亿像佛　南无师子游喜佛　南无普光功德山王佛　南无善住功德宝王佛　南无宝华庄严王佛　南无难胜佛　南无须弥相佛　南无须弥灯王佛　南无宝德佛　南无宝月佛　南无宝焰佛　南无宝严佛　南无难胜师子响佛　南无大光王佛　南无不动佛　南无药王佛　南无庄严佛　南无楼至佛　南无月盖佛　南无普光佛　南无宝王佛　南无维卫佛　南无式只佛　南无随叶佛　南无拘楼秦佛　南无拘那含牟尼佛　南无迦叶佛　南无雷音王佛　南无只法藏佛　南无栴檀华佛　南无栴檀叶佛　南无妙音佛　南无无上胜佛　南无甘露鼓佛　南无毗婆尸佛　南无日月光明佛　南无无胜光佛　南无具足庄严王佛　南无光明遍照功德王佛　南无破坏四魔师子吼王佛　南无金刚不坏佛　南无琉璃光佛　南无须弥山王佛　南无净土光明王佛　南无普光佛　南无普明佛　南无普净佛　南无多摩罗跋栴檀香佛　南无栴檀香光佛　南无摩尼幢佛　南无欢喜藏摩尼宝积佛　南无一切世间乐见上大精进佛　南无摩尼幢灯光佛　南无慧炬照佛　南无海德光明佛　南无金刚牢强普散金光佛　南无大强精进勇猛佛　南无大悲光佛　南无慈力王佛　南无慈藏王佛　南无栴檀窟庄严胜佛　南无贤善首佛　南无善意佛　南无广庄严王佛　南无金华光佛　南无宝盖照空自在王佛　南无虚空宝华光佛　南无琉璃庄严王佛　南无普现色身光佛　南无不动智光佛　南无降伏诸魔王佛　南无财光明佛　南无智慧胜佛　南无弥勒鲜光佛　南无世净光佛　南无善寂月音妙尊智王佛　南无龙种上智尊王佛　南无日月光佛　南无日月珠光佛　南无慧幡胜王佛　南无师子吼自在力王佛　南无妙音胜王佛　南无常光幢佛　南无观世音灯王佛　南无慧威灯王佛　南无法胜王佛　南无须弥光佛　南无须摩那华光佛　南无优昙钵罗华殊胜王佛　南无大慧力王佛　南无阿閦毗欢喜光佛　南无无量音声王佛　南无财光佛　南无金海光佛　南无大通光佛　南无山海慧自在通王佛　南无一切法相满王佛　南无释迦牟尼佛　南无金刚不坏佛　南无普光佛　南无龙尊王佛　南无精进军佛　南无精进喜佛　南无宝火佛　南无宝月光佛　南无现无愚佛　南无宝月佛　南无无垢佛　南无离垢佛　南无勇施佛　南无清净佛　南无清净施佛　南无婆留那佛　南无水天佛　南无坚德佛　南无栴檀功德佛　南无无量掬光佛　南无光德佛　南无无忧德佛　南无那罗延佛　南无功德华佛　南无莲华光游戏神通佛　南无财功德佛　南无德念佛　南无善名称功德佛　南无红炎幢王佛　南无善游步功德佛　南无斗战胜佛　南无善游步佛　南无周匝庄严功德佛　南无宝华游步佛　南无宝华善住莎罗王佛　南无善德佛　南无无量光明佛　南无陀罗尼游戏佛　南无首楞严定三昧力王佛　南无无上功德佛　南无善见定自在王佛　南无神通自在佛　南无无色相佛　南无无散相佛　南无无香相佛　南无无味相佛　南无无触相佛

次礼十二部尊经大藏法轮

南无七事经　南无碱水喻经　南无七处三观经　南无九横经　南无八正道经　南无五阴喻经　南无转法轮经　南无圣法印经　南无杂阿含经　南无不自守意经　南无戒德香经　南无比丘听施经　南无马有三相经　南无马有八态譬人经　南无比丘避恶名欲自杀经　南无戒相应法经　南无禅行三十七品经　南无尊法义经　南无楼炭经　南无大般涅槃经　南无佛般泥洹经　南无大六向拜经　南无梵网六十二见经　南无十报法经　南无寂志果经　南无梵志阿跋经　南无七佛父母姓字经　南无梵志颇罗延问种尊经　南无贤圣集传　南无摩诃般若波罗蜜经　南无六度集　南无菩萨本缘集　南无僧伽罗刹集　南无孛经抄集　南无思惟经　南无佛医经　南无分别业报略集　南无龙树劝发诸王要偈　南无杂譬喻经　南无无明罗刹喻集　南无杂咒集　南无佛本行集　南无撰集百缘经　南无百喻集　南无旧杂譬喻经　南无法句喻集　南无法句经　南无四十二章　南无禅秘要法

敬礼十方诸大菩萨摩诃萨

南无无垢藏菩萨　南无离垢藏菩萨　南无种种乐说庄严藏菩萨　南无大光明罗网藏菩萨　南无大金山光明威德王藏菩萨　南无净明威德王藏菩萨　南无一切相庄严净德藏菩萨　南无金刚炎德相庄严藏菩萨　南无焰炽藏菩萨　南无宿王光照藏菩萨　南无虚空无碍妙音藏菩萨　南无陀罗尼功德持一切世间愿藏菩萨　南无海庄严藏菩萨　南无须弥德藏菩萨　南无净一切德藏菩萨　南无如来藏菩萨　南无佛德藏菩萨　南无光德王菩萨　南无总持自在王菩萨　南无总持菩萨　南无灭除众生病菩萨　南无疗一切众生病菩萨　南无欢喜念菩萨　南无厌意菩萨　南无常厌苦菩萨　南无月明菩萨　南无水天菩萨　南无主天菩萨　南无大意菩萨　南无益意菩萨　南无涧月菩萨　南无尸毗王菩萨　南无一切胜菩萨　南无知大地菩萨　南无鸠舍菩萨　南无阿离念弥菩萨　南无顶生王菩萨　南无郁多罗菩萨　南无萨和檀菩萨　南无长寿王菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

夫欲忏悔必须先敬三宝。所以然者。三宝则是一切众生良友福田。若能归向者。则灭无量罪长无量福。能令行者离生死苦得解脱乐。是故弟子某甲等。归依十方尽虚空界一切诸佛。归依十方尽虚空界一切尊法。归依十方尽虚空界一切诸大菩萨。归依十方尽虚空界一切圣僧。弟子。今日所以忏悔者。正言无始已来在凡夫地。莫问贵贱罪自无量。或因三业而生罪。或从六根而起过。或以内心自邪思惟。或籍外境起于染着。如是乃至十恶。增长八万四千诸尘劳门。然其罪相虽复无量。大而为语不出有三。何等为三。一者烦恼障。二者是业障。三者是果报障。此三种法能障圣道。及以人天胜妙好事。是故经中目为三障。所以诸佛菩萨教作方便。忏悔除灭此三障者。则六根十恶乃至八万四千诸尘劳门皆悉清净。是故弟子。今日运此增上胜心忏悔三障。欲灭此三障罪者。当用何等心可令此罪灭除。先当兴七种心以为方便。然后此罪乃可得灭。何等为七。一者惭愧。二者恐怖。三者厌离。四者发菩提心。五者怨亲平等。六者念报佛恩。七者观罪性空

第一惭愧者。自惟我与释迦如来同为凡夫。而今世尊成道以来已经尔所尘沙劫数。而我等相与耽染六尘。流浪生死永无出期。此实天下可惭可愧可羞可耻

第二恐怖者。既是凡夫身口意业常与罪相应。以是因缘命终之后。应堕地狱畜生饿鬼受无量苦。如此实为可惊可恐可怖可惧

第三厌离者。相与当观生死之中。唯有无常苦空无我不净虚假。如水上泡速起速灭。往来流转犹若车轮。生老病死八苦交煎无时暂息。众等相与但观自身从头至足。其中但有三十六物。发毛爪齿脓囊涕涶生熟二藏。大肠小肠脾肾心肺肝胆。[月*冊]胃肪膏[腮-田+匆]膜筋脉骨髓。大小便利九孔常流。是故经言。此身众苦所集。一切皆不净物。何有智慧者。而当乐此臭肉身也。生死既有如此种种恶法甚可患厌

第四发菩提心者。经言当乐佛身。佛身者即法身也。从无量功德智慧生。从六波罗蜜生。从慈悲喜舍生。从三十七助菩提法生。从如是等种种功德智慧生如来身。欲得此身者。当发菩提心求一切种智。常乐我净萨婆若果。净佛国土成就众生。于身命财无所吝惜

第五怨亲平等者。于一切众生起慈悲心无彼我想。何以故尔。若见怨异亲则是分别。以分别故起诸想着。想着因缘生诸烦恼。烦恼因缘造诸恶业。恶业因缘故得苦果

弟六念报佛恩者。如来往昔无量劫中。舍头目髓脑支节手足。国城妻子象马七珍。为我等故修诸苦行。此恩此德实难酬报。是故经言。若以顶戴两肩荷负于恒沙劫亦不能报。我等欲报如来恩者。当于此世勇猛精进捍劳忍苦。不惜身命建立三宝。弘通大乘广化众生同入正道

第七观罪性空者。无有实相从因缘生颠倒而有。既从因缘而生。则可从因缘而灭。从因缘而生者。押近恶友造作无端。从因缘而灭者。即是今日洗心忏悔。是故经言。此罪相不在内不在外不在中间。故知此罪从本是空。生如是等七种心。以缘想十方诸佛贤圣。擎拳合掌披陈至到惭愧改革。舒沥心肝洗荡肠胃。如此忏悔亦何罪而不灭。亦何障而不消。若复正尔悠悠缓纵情虑。徒自劳形于事何益。且复人命无常喻如转烛。一息不还便向灰壤。三涂苦报则身应受。不可以钱财宝货嘱托求脱。窈窈冥冥恩赦无期。独婴此苦无代受者。莫言我今生中无有此罪。所以不能恳到忏悔。经中道言。凡夫之人举足动步无非是罪。又复过去生中皆悉成就无量恶业。追逐行者如影随形。今日若不忏悔罪恶日深。故包藏瘕疵佛教不许。忏悔先罪净名所尚。故知长沦苦海寔由隐覆。是故弟子。今日发露忏悔不敢覆藏。所言三障者。一曰烦恼障。二名为业障。三是果报障。此三种法更相由藉。因烦恼故所以起恶业。恶业因缘故得苦果。是故弟子。今日至心第一先应忏悔烦恼障。又此烦恼。诸佛菩萨入理圣人种种呵啧。亦詺此烦恼以为怨家。何以故。能断众生慧命根故。亦詺此烦恼以之为贼。能劫众生诸善法故。亦詺此烦恼以为暴河。能[漂*寸]众生入于生死大苦海故。亦詺此烦恼以为羁锁。能系众生于生死狱不能得出故。亦詺此烦恼犹如蟒虫。食啖众生真如佛性故。所以六道牵连四生不绝。恶业无穷苦果不息。当知皆是烦恼过患。是故弟子。今日运此增上善心。归依佛

南无东方金光明佛　南无南方大须弥佛　南无西方妙乐佛　南无北方具威仪智佛　南无东南方法种尊佛　南无西南方谛幢佛　南无西北方开化菩萨佛　南无东北方慧精进佛　南无下方衣毛不竖佛　南无上方无数精进兴丰佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。或在人天六道受报。有此心识常怀愚惑繁满胸襟。或因三毒根造一切罪。或因三漏造一切罪。或因三觉造一切罪。或因三受造一切罪。或因三苦造一切罪。或缘三假造一切罪。或贪三有造一切罪。如是等罪无量无边。恼乱一切六道四生。今日惭愧归命忏悔

又复弟子。无始以来至于今日。或因四识住造一切罪。或因四流造一切罪。或因四取造一切罪。或因四执造一切罪。或因四缘造一切罪。或因四大造一切罪。或因四缚造一切罪。或因四食造一切罪。或因四生造一切罪。如是等罪无量无边。恼乱六道一切众生。今日惭愧归命忏悔

又复弟子。无始以来至于今日。或因五住地烦恼造一切罪。或因五受根造一切罪。或因五盖造一切罪。或因五悭造一切罪。或因五见造一切罪。或因五心造一切罪。如是等烦恼无量无边。恼乱六道一切四生。今日发露归命忏悔

又复弟子。无始已来至于今日。或因六情根造一切罪。或因六识造一切罪。或因六想造一切罪。或因六受造一切罪。或因六行造一切罪。或因六爱造一切罪。或因六疑造一切罪。如是等烦恼无量无边。恼乱六道一切四生。今日惭愧归命忏悔

又复弟子。无始以来至于今日。或因七漏造一切罪。或因七使造一切罪。或因八倒造一切罪。或因八垢造一切罪。或因八苦造一切罪。如是等烦恼无量无边。恼乱六道一切四生。今日发露归命忏悔

又复弟子。无始已来至于今日。或因九恼造一切罪。或因九结造一切罪。或因九上缘造一切罪。或因十烦恼造一切罪。或因十缠造一切罪。或因十一遍使造一切罪。或因十二入造一切罪。或因十六知见造一切罪。或因十八界造一切罪。或因二十五我造一切罪。或因六十二见造一切罪。或因见谛思惟九十八使百八烦恼昼夜炽然开诸漏门造一切罪。如是等烦恼无量无边。恼乱贤圣及以四生。遍满三界弥亘六道。无处可藏无处可避。今日至到向十方佛尊法圣众。惭愧发露皆悉忏悔

愿弟子等。承是忏悔三毒等一切诸烦恼所生功德。愿生生世世。三慧明。三达朗。三苦灭。三愿满。愿弟子等。承是忏悔四识等一切诸烦恼所生功德。愿生生世世。广四等心立四信业。四恶趣灭得四无畏

愿弟子等。承是忏悔五盖等诸烦恼所生功德。愿生生世世度五道树五根。净五眼成五分

愿弟子等。承是忏悔六爱等诸烦恼所生功德。愿生生世世具足六神通。满足六度业。不为六尘惑。常行六妙行

愿弟子等。承是忏悔七漏八垢九结十缠等一切诸烦恼所生功德。愿生生世世坐七净华洗尘八水。具九断智成十地行。愿以忏悔十一遍使及十二入十八界等一切诸烦恼所生功德。愿生生世世十一空解常用洗心。自在能转十二行轮。具足十八不共之法。无量功德一切圆满

    大乘莲华宝达问答报应沙门经

宝达顷前入一火丸仰口地狱。云何名曰火丸仰口地狱。其地狱纵广八十由旬。其地狱铁城罗网。火焰俱起来烧罪人。其城四角猛风而来吹此铁城。而动散发化作铁丸飞流而下。其丸八方銐如锋铓火焰俱作。于虚空中共相诤抵亦如雷声。南门之中有百千罪人。沙门来入其中唱如是言。我今何罪来入此中受罪如是。唱声大叫身中震裂。烟火俱出来入其中。空中火丸从口下入足下而出。身毛孔中皆亦火然。一日一夜受无量罪

宝达问马头罗刹曰。此诸沙门作何等罪受如是苦。马头罗刹答曰。此诸沙门受佛净戒而不畏罪。手擿众僧果自食与人不知惭愧。以是因缘堕此地狱。从地狱出若得为人喑哑不语。宝达闻之悲泣而去

佛名经卷第十六佛说佛名经卷第十七

尔时优波摩那比丘从座而起。偏袒右肩右膝着地。合掌恭敬白佛言。世尊。几佛过去。佛告优波摩那比丘。比丘。譬如恒河沙世界。下至水际上尽有顶满中微尘。比丘。有人于中取尔所微尘。过恒河沙世界下一微尘。如是过恒河沙世界复下一尘。如是尽尔所微尘。比丘。于意云何。若着微尘若不着微尘。是诸微尘数可知数不。比丘言。不也世尊。佛告比丘。比丘。彼诸微尘可知其数。而彼过去同名释迦牟尼佛。已入涅槃者不可数知。比丘。我知彼过去诸佛如现前见。彼诸佛母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼诸佛第一声闻弟子。同名舍利弗目揵连。侍者弟子同名阿难陀。何况种种异名母异名父异名城。异名弟子异名侍者。比丘。彼若干世界。彼人于何等世界着微尘。何等世界不着微尘。彼诸世界若着微尘不着微尘。下至水际上至有顶。比丘。复有第二人取一微尘。过彼若干微尘数世界。尔数佛国土阿僧祇亿百千万那由他世界为一步。比丘。彼人复过是若干微尘数世界为一步。彼人如是过百千万亿那由他阿僧祇劫。行乃下一尘。如是尽诸微尘。比丘。如是若干世界满中微尘。复更着十方世界。比丘。复过是世界着微尘。彼诸世界下至水际上至有顶满中微尘。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。彼诸微尘可知其数彼同名母同名父同名城。同名弟子同名侍者。同名释迦牟尼佛不可知数。如释迦牟尼。不胜幢佛亦如是。卢舍那佛亦如是。无垢胜眼佛亦如是。无垢光明眼佛亦如是。光明清净王佛亦如是。善无垢清净佛亦如是。成就无边功德胜王佛亦如是。宝光明佛亦如是。寂修佛亦如是。声德佛亦如是。波头摩胜佛亦如是。日月佛亦如是。普宝盖佛亦如是。比丘。汝当归命如是等阿僧祇同名佛

南无普光明奋迅王佛　南无普照佛　南无药王佛　南无弥留灯王佛　南无宝庄严佛　南无智成就佛　南无宝盖佛　南无放炎佛　南无物成就佛　南无称智佛　南无三昧胜佛　南无宝观佛　南无宝鸡都佛　南无尸罗施佛　南无莎罗王佛　南无宝意山鸡兜王佛　南无大庄严佛　南无山自在王佛　南无旃陀佛　南无见义佛　南无自在幢佛　南无大弥留佛　南无无光胜佛　南无大庄严王佛　南无大智幢佛　南无日藏佛　南无无畏上胜山王佛　南无梵自在佛　南无余依止黠声王佛　南无智鸡兜佛　南无智炬住持佛　南无过一切世间佛　南无法照佛　南无无垢光佛　南无普光佛　南无一切胜佛　南无寂静妙声佛　南无普明佛　南无胜山王师子奋迅境界声佛　南无地住持佛　南无功德王光佛　南无住持智庭燎佛　南无乐说胜王佛　南无金色波头摩成王佛　南无难胜佛　南无宝作佛　南无无量声佛　南无亲光佛　南无龙天佛　南无天力佛　南无师子佛　南无离诤光佛　南无世天佛　南无胜积佛　南无人王佛　南无华王佛　南无华胜佛　南无发精进佛　南无因陀罗鸡兜佛　南无清净无垢光菩提宝华不断绝光明王佛　南无卜薝上佛　南无意福德自在佛　南无观声王佛　南无无垢威德佛　南无功德宝集吼佛　南无成就德佛　南无成就胜佛　南无斯何佛　南无威德佛　南无高须弥山佛　南无阿输迦世界贤妙胜佛

若有善男子善女人。受持读诵是诸佛名。必得不退菩提心

南无难陀世界栴檀胜佛

若有善男子善女人。受持读诵是诸佛名。毕竟得清净心

南无跋陀世界寂染佛　南无意智鸡兜世界破魔力佛　南无满月世界无忧佛　南无鸡兜意胜世界宝杖佛　南无语吼声胜世界花胜佛　南无差摩世界三昧奋迅佛　南无广世界树提胜佛　南无月胜世界金刚功德身佛　南无过去无量无边海胜佛

若有善男子称彼佛名。得毕竟不退菩提心

南无弥留胜王佛

彼佛初成佛第一会。八十亿百千万那由他声闻众。第二会七十亿百千万那由他。第三会六十亿百千万那由他。第四会二十五亿百千万那由他。如是菩萨无量无边。百千万那由他

南无师子妙声王佛

彼佛初会有九十九亿声闻。第二会九十亿。第三会九十三亿。第四会九十九亿。如是菩萨摩诃萨众无量无边

南无华胜佛

彼佛初会八十亿声闻。菩萨僧亦如是

南无妙行佛

彼佛初会八十亿声闻。菩萨僧亦如是

南无无量大庄严佛

彼佛初会八十亿声闻。第二会七十亿乃至第十会亦如是。菩萨僧亦如是无量无边

南无放炎佛

彼佛初会有九十亿声闻。如是第二乃至第十亦如是。菩萨摩诃萨僧无量无边

南无一切光明佛

彼佛初会有那由他亿声闻。菩萨僧亦如是

南无无量光明佛

彼佛初会声闻有九十六亿。第二会九十四亿。第三会九十三亿。菩萨僧亦如是

南无声德佛

彼佛初会声闻有八十亿。第二会七十亿。第三会六十亿。菩萨僧亦如是。应当归命如是等诸佛菩萨

复次比丘。应当敬礼南方清净无垢世界菩萨佛。谓文殊师利。现在普见如来佛国土中

复次比丘。应当敬礼四大士菩萨。第一名光明幢。现在东方无畏如来佛国土中。第二名智胜。现在南方智聚如来佛国土中。第三名寂根。现在西方智山如来佛国土中。第四名愿意成就。现在北方那罗延如来佛国土中

复次摩诃男比丘。重问如来世尊。过去几佛入涅槃。佛告摩诃男。汝今谛听当为汝说。比丘。东方恒河沙世界。南方恒河沙世界。西方恒河沙世界。北方恒河沙世界。上下四维恒河沙世界。彼一切世界。下至水际上尽有顶满中微尘。比丘。于意云何。彼如是微尘可知数不。比丘言不也世尊。佛告比丘。如是同名释迦牟尼佛。过去入涅槃者不可数知。比丘。我知彼过去诸佛如现在前。彼诸佛母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼佛第一声闻弟子同名舍利弗目揵连。侍者弟子同名阿难陀。何况种种异名母异名父异名城异名弟子异名侍者异名。比丘。彼若干世界彼人于何等世界着微尘。何等世界不着微尘。彼诸世界若着微尘及不著者。下至水际上至有顶。比丘。复有第二人取彼微尘。彼若干微尘数世界尔所佛国土。阿僧祇数百千万亿那由他世界。过尔所世界为一步。比丘。彼人复过若干微尘数世界为一步。彼人如是过百千万亿那由他阿僧祇劫行乃下一尘。如是尽诸微尘。比丘。如是若干世界若着微尘及不著者。满中微尘。复更着十方世界。比丘。复过是世界若着微尘及不著者。彼诸世界下至水际上至有顶满中微尘。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。彼诸微尘可知其数。彼同名释迦牟尼佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一声闻弟子。同名舍利弗目揵连。侍者弟子同名阿难陀。不可知数

复次比丘。复有第三人。取彼尔所世界微尘。过彼尔所微尘数世界为一步。过彼若干百千万亿那由他阿僧祇劫。行乃下一尘。如是尽诸微尘。复有第四人。取彼若干微尘数世界。若着微尘若不着微尘。下至水际上至有顶满中微尘。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。彼若干微尘可知其数。然彼同名释迦牟尼佛母同名父同名世界同名弟子同名侍者同名佛不可知数。比丘。如是第五人。第六第七第八第九第十人。复次比丘。复有第十一人。是人彼若干微尘中取一微尘。破为十方若干世界微尘数分。如一微尘破为若干分。如是余微尘亦悉破为若干世界微尘数分。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。复有人彼若干微尘佛国土为过一步。如是速疾神通行东方世界。无量无边劫行。如是东方世界下一微尘。东方尽如是微尘。若着微尘及不著者。下至水际上至有顶满中微尘。如是南方乃至十方。下至水际上至有顶满中微尘。比丘。于意云何。彼诸微尘可知数不。比丘言。不也世尊。佛告比丘。若干微尘分可知其数。然现今在世同名释迦牟尼佛入涅槃不可数知。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一声闻弟子。同名舍利弗目揵连。侍者弟子同名阿难陀。何况种种异名。比丘。我若干微尘数劫住世。说一同名释迦牟尼佛不可穷尽。如是同名然灯佛同名提娑延佛。同名灯光明佛。同名一切胜佛。同名称王佛。同名波头摩胜佛。同名毗婆尸佛。同名尸弃佛。同名毗舍浮佛。同名拘留孙佛。同名拘那含牟尼佛。同名迦叶佛。如是等异名母。乃至异名侍者入涅槃。我知彼佛如现在前。应当敬礼如是等诸佛。优波摩那比丘白佛言。世尊。未来有几许佛。佛告优波摩那比丘。汝今谛听当为汝说。比丘。未来星宿劫中有三百佛出世。同名大鸡兜。复有十千同名庄严王佛。华作劫中有一亿百千万佛出世。同名菩提觉华。复有劫中八千频婆罗佛出世。同名离爱佛。多卢波摩劫中有六千佛出世同名散华。胜声劫中莎罗自在高幢世界。有十千佛出世。同名清净优波罗香山。普华劫中有千八百佛出世。同名离妄。复有劫中千三百佛出世。同名梵声。复有劫中三十亿佛出世。同名释迦牟尼。复有劫中八千同名然灯佛出世。复有劫中六十千同名欢喜佛出世。复有劫中三亿佛出世。同名弗沙。复有劫中八十千佛出世。同名莎罗自在王。复有劫中三百佛出世。同名波头摩胜。复有劫中五百佛出世。同名波多婆。复有劫中千佛出世。同名阎浮檀。复有劫中千二百千万佛出世。同名见一切义。复有劫中千佛出世。同名俱邻。复有劫中九千佛出世。同名迦叶。复有劫中十八佛出世。同名因陀罗幢。复有劫中十五佛出世。同名日佛。复有劫中六十亿佛出世。同名大庄严。复有劫中六十佛出世。同名因陀幢。复有劫中五百佛出世。同名日佛。复有劫中六十亿佛出世。同名大庄严。复有劫中六十二百佛出世。同名寂行。复有劫中六十亿佛出世。同名莎罗自在王。复有劫中八千佛出世。同名坚精进。复有劫中百亿佛出世。同名决定光明。复有劫中八十亿佛出世。同名实法决定。复有劫中六十二亿佛出世。同名毗留罗。复有劫中六十千佛出世。同名妙波头摩佛。复有劫中四十千佛出世。同名愿庄严。复有劫中五百佛出世。同名华胜王。复有劫中四十亿那由他佛出世。同名妙声。复有劫中千佛出世。同名功德盖安隐自在王。复有劫中六十千佛出世。同名坚修柔濡。复有劫中十佛国土微尘数百千万不可说不可说佛出世。同名普贤。复有劫中七千佛出世。同名法庄严王。比丘。举要言之。未来诸佛无量无边不可说不可说不可穷尽。比丘汝等应当一心归命如是等诸佛

尔时舍利弗从座而起。偏袒右肩右膝着地。胡跪合掌白佛言。世尊。几佛现在。佛告舍利弗。汝见我现在身也。舍利弗言。如是世尊。我今实见佛身。复告舍利弗。我今见十方无量无边不可说不可说世界。同我名释迦牟尼佛在世者。如汝见我无异。如是同名然灯佛。同名毗婆尸佛。同名尸弃佛。同名毗舍浮佛。同名拘留孙佛。同名拘那含佛。同名迦叶佛。舍利弗。举要言之。我若一劫若百千万亿那由他劫。说同名诸佛不可穷尽。何况异名佛。此如是等诸佛。皆是文殊师利。初教发阿耨多罗三藐三菩提心。舍利弗。汝等应当一心归命如是等佛。舍利弗。现在劫五百同名智幢佛。复有劫五百同名法幢佛。复有劫六十二同名然炬佛。复有劫六十二同名尸弃佛。复有劫千同名然火单荼自在王声佛。复有劫二千不同名。或名智胜佛。或名然灯王佛。或名法胜佛。或有名梵胜佛。舍利弗。汝等应当一心归命如是等诸佛。舍利弗。复有佛名妙声分声佛。舍利弗。彼妙声分声佛。寿命满足六十百岁。过彼东方名智自在两足尊。彼智自在如来寿命满足十二千岁。过彼智自在世尊。复有佛名威德自在两足尊。彼威德自在佛寿命满足七十六千岁。过彼威德自在世尊。复有佛名摩醯首罗。彼摩醯首罗佛寿命满足一亿岁。过彼摩醯首罗佛。复有佛名梵声。彼梵声佛寿命满足十亿岁。过彼梵声世尊。复有佛名大众自在。彼大众自在佛寿命满足六十千岁。过彼大众自在世尊。复有佛名声自在。彼声自在佛寿命满足一亿岁。过彼声自在世尊。复有佛名胜声。彼胜声佛寿命满足百亿岁。过彼胜声世尊有佛名月面。彼月面佛寿命满足一日一夜。过彼月面世尊。复有佛名日面。彼日面佛寿命满足千八百岁。过彼日面世尊。复有佛名梵面。彼梵面佛寿命满足二十三千岁。过彼梵面世尊。复有佛名梵阿莎婆。彼梵阿莎婆佛寿命满足千八百岁。舍利弗。汝等应当一心归命如是等诸佛。舍利弗。复过一劫中二百佛出世。我说彼佛名。汝当归命

南无不可嫌身佛　南无称名佛　南无威德佛　南无称吼佛　南无称上佛　南无声清净佛　南无智胜佛　南无智解佛　南无黠慧佛　南无智通佛　南无智成就佛　南无智供养佛　南无智妙佛　南无智炎佛　南无智勇猛佛　南无净上佛　南无梵天佛　南无善梵天佛　南无净婆薮佛　南无妙梵声佛　南无梵自在佛　南无梵天自在佛　南无因那陀佛　南无梵吼佛　南无梵德佛　南无威德力佛　南无威德自在佛　南无善威德佛　南无威德绝伦无能制伏佛　南无威德起佛　南无善决定威德佛　南无威德天佛　南无威德胜佛　南无惊怖佛　南无惊怖意佛　南无惊怖慧佛　南无惊怖众生佛　南无惊怖面佛　南无惊怖起佛　南无威德决定毕竟佛　南无威德天佛　南无惊怖实佛　南无见惊怖佛　南无善眼佛　南无月胜佛　南无深声佛　南无无边声佛　南无净声佛　南无清净声佛　南无无量声佛　南无放声佛　南无降伏魔力声佛　南无住持声佛　南无善目佛　南无清净面佛　南无善照佛　南无无边眼佛　南无普眼佛　南无称眼佛　南无眼庄严佛　南无不可嫌眼佛　南无调柔佛　南无调伏身心佛　南无身心柔软佛　南无调眼佛　南无善调心佛　南无善寂根佛　南无善寂意佛　南无善寂妙佛　南无善寂行佛　南无善寂去佛　南无善寂彼岸佛　南无善寂勇猛佛　南无善寂住胜佛　南无善寂净心佛　南无众上首自在王佛　南无有众佛　南无众自在佛　南无胜众佛　南无清净智佛　南无大众自在佛　南无众勇猛佛　南无放妙香佛　南无法力佛　南无法鸡兜佛　南无法行佛　南无法宝佛　南无法力佛　南无法王佛　南无善法佛　南无法勇猛佛　南无法乐决定佛

南无实法决定一劫中八十亿同名决定佛。第二劫中八十亿亦同名决定佛。过决定佛名胜成就佛。亦应一心敬礼

南无安隐佛　南无拘邻佛　南无善欢喜佛　南无善眼佛　南无头陀罗吒佛　南无毗留博叉佛　南无善眼佛　南无妙眼佛　南无善见佛　南无善解佛　南无释迦牟尼佛　南无妙去佛　南无大胜佛　南无栴檀佛　南无善度佛　南无灭恶佛　南无大功德佛　南无摩梨支佛　南无光明佛　南无满月佛　南无净名佛　南无净德佛　南无净住佛　南无喜胜佛　南无月幢佛　南无宝起佛　南无无畏佛　南无然灯佛　南无法妙佛　南无高髻佛　南无称妙佛　南无次胜妙释迦牟尼佛　南无吉沙佛　南无弗沙佛　南无毗婆尸佛　南无尸弃佛　南无毗舍浮佛　南无拘留孙佛　南无拘那含牟尼佛　南无迦叶佛

佛复告舍利弗。现在东方可乐世界中名阿閦佛。汝等应当一心敬礼

南无日藏佛　南无龙王自在王佛　南无日作佛　南无龙欢喜佛　南无自在佛　南无称光明佛　南无山城佛　南无普妙佛　南无普宝佛　南无称自在王佛　南无行法行称佛　南无初智慧佛　南无智山佛　南无日光明佛　南无生胜佛　南无弥留藏佛　南无智海佛　南无大精进佛　南无高山胜佛　南无功德藏佛　南无智法界佛　南无无畏自在佛　南无大精进成就佛　南无智成就佛　南无无碍王佛　南无地力精进佛　南无持行佛　南无力王佛　南无善见佛　南无法光明王佛　南无降伏魔佛　南无不断炎佛　南无功德山佛　南无智齐佛　南无无障力王佛　南无善思惟佛　南无师子欢喜佛　南无戒光明佛　南无快胜王佛　南无无尽智藏佛　南无宝面胜佛　南无智波婆佛　南无决定称佛　南无无边观王佛　南无法华雨佛　南无作光明佛　南无高山王佛　南无成就法轮王佛　南无无垢眼佛　南无大名声德佛　南无无碍智力王佛　南无无碍安隐佛　南无寂门佛　南无福德力精进佛　南无智衣王佛　南无法自在王佛　南无无妨安隐佛　南无智成就佛　南无大力弥留藏佛　南无观功德精进佛　南无得无障不迷佛　南无香光明佛　南无功德聚集王佛　南无法齐底佛　南无声自在王佛　南无护声佛　南无种种力精进王佛　南无宝光明胜王佛　南无过一切须弥山王佛　南无宝弥留佛　南无不动法佛　南无坚固盖王佛　南无普功德佛　南无法莎罗弥留佛　南无聚集智声佛　南无智炎华月王佛　南无龙王自在王佛　南无优昙末花王佛　南无真金色王佛　南无增长法幢王佛　南无栴檀波罗光佛　南无住持功德称佛　南无坚固意精进佛　南无然尘灯佛　南无精进步佛　南无无边坚固幢佛　南无最法称佛　南无法王佛　南无降伏大众佛　南无有光炎华高山佛　南无智胜照佛　南无才威德然灯佛　南无无诤无畏佛　南无智化声佛　南无二轮成就佛　南无妙身盖佛　南无胜庄严王佛　南无师子座善坐佛　南无放月光华王佛

复次舍利弗。现在南方佛汝应当一心归命

南无法自在吼佛　南无师子奋迅王佛　南无初发心香自在莎罗佛　南无那罗延自在藏弥留胜佛　南无宝山精进自在集功德佛　南无树提藏佛　南无星宿方便称佛　南无功德力莎罗王佛　南无妙声吼奋迅佛　南无得一切众生意佛　南无大意佛　南无妙声佛　南无宝陀山佛　南无法云吼声佛　南无香波头摩精进王成就佛　南无无垢光明佛　南无光波婆吒佛　南无功德迹佛　南无因缘光明佛　南无无边功德王佛　南无增长眼佛　南无师子声奋迅佛　南无天力师子奋迅佛　南无观法佛　南无法华通佛　南无敬法清净佛　南无坚精进行奋迅佛　南无自精进佛　南无弥留光佛　南无功德阿尼罗佛　南无净根佛　南无唤智佛　南无智慧作佛　南无不破广慧佛　南无力慧佛　南无优头钵佛　南无法坚固欢喜佛　南无坚固意自在王佛　南无平等须弥山面佛　南无发舍成就佛　南无清净藏佛　南无一切众生自在佛　南无胜业清净见佛　南无智自在佛　南无善快奋迅佛　南无无障无著精进佛　南无世间自在佛　南无广法行佛　南无功德成就佛　南无不怯弱成就佛　南无城如意通佛　南无如观法佛　南无栴檀须佛　南无敬重戒王佛　南无宝名佛　南无龙王自在声佛　南无大智庄严佛　南无无孤独功德佛　南无阿罗摩佛　南无不灭庄严佛　南无净功德庄严佛　南无自在相好庄严称佛　南无行自在王佛　南无法华弥留佛　南无法性庄严佛　南无愿满足佛　南无大舍庄严佛　南无千法无畏佛　南无有自在成就佛　南无乐法奋迅佛　南无寂王佛　南无解脱王佛　南无肩弥留佛　南无如意力电王佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无羼提菩萨　南无韦蓝菩萨　南无上宝月菩萨　南无威仪菩萨　南无不虚德菩萨　南无宝明菩萨　南无乐说顶菩萨　南无慧顶菩萨　南无一切勇健菩萨　南无破闇菩萨　南无功德宝菩萨　南无华威德菩萨　南无离恶道菩萨　南无云阴菩萨　南无出过菩萨　南无顶相菩萨　南无山相博王菩萨　南无妙生菩萨　南无帝网菩萨　南无宝施菩萨　南无破魔菩萨　南无定自在王菩萨　南无法自在王菩萨　南无法相菩萨　南无常惨菩萨　南无执宝炬菩萨　南无明网菩萨　南无无缘观菩萨　南无坏魔菩萨　南无大目法王子　南无慈王法王子　南无梵音法王子　南无妙色法王子　南无栴檀林法王子　南无师子吼音法王子　南无妙声法王子　南无妙色形貌法王子　南无种种庄严法王子　南无释幢法王子　南无顶生法王子

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

夫论忏悔者。本是改往修来灭恶兴善。人生居世谁能无过。学人失念尚起烦恼。罗汉结习动身口业。岂况凡夫而当无过。但智者先觉便能改悔。愚者覆藏逐使滋蔓。所以积习长夜晓悟无期。若能惭愧发露忏悔者。岂惟正是灭罪而已。亦复增长无量功德。树立如来涅槃妙果。若欲行此法者。先当外肃形仪瞻奉尊像。内起敬意缘于相法。慊切至到生二种心。何等为二。一者自念我此形命难可常保。一朝散坏不知此身何时可复。若复不值诸佛贤圣。忽遭逢恶友造众罪业。复应堕落深坑险趣。二者自念我此生中。虽得值遇如来正法为佛弟子。弟子之法绍继圣种。净身口意善法自居。而今我等公自作恶而复覆藏。言他不知谓彼不见。隐匿在心傲然无愧。此实天下愚惑之甚。则今现有十方诸佛。诸大地菩萨诸天神仙。何曾不以清净天眼见于我等所作罪恶。又复幽显灵只。注记罪福纤毫无差。夫论作罪之人。命终之后。牛头狱卒录其精神。在阎罗王所辩穷是非。当尔之时一切怨对皆来证据。各言汝先屠戮我身炮煮蒸炙。或言汝先剥夺于我一切财宝离我眷属。我于今者始得汝便。于时现前证据何得敢讳。唯应甘心分受宿殃。如经所明地狱之中不枉治人。若其生平之日。素所作众罪心自失者。是其生时造恶之处。一切诸像皆现在前。各言汝昔在于我边作如是罪今何得讳。是为作罪无藏隐处。于是阎魔罗王。切齿呵啧将付地狱。历劫穷年求出莫由。此事不远不关他人。正是我身自作自受。虽父子至亲。一旦对至无代受者。众等相与及其形休体无众疾。各自努力与性命竞生大怖畏。死欲至时悔无所及。是故弟子。至心归命十方诸佛

南无东方金海佛　南无南方超出须弥佛　南无西方无量幡佛　南无北方行智佛　南无东南方究竟智佛　南无西南方无上智佛　南无西北方自在智佛　南无东北方明智佛　南无下方梵天智佛　南无上方伏怨智佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。积聚无明障蔽心目。随烦恼性造三世罪业。或耽染爱着起于贪欲烦恼。或嗔恚忿怒怀害烦恼。或惛愦瞢瞪不了烦恼。或我慢自高轻傲烦恼。疑惑正道犹预烦恼。谤无因果邪见烦恼。不识缘假着我烦恼。迷于三世执断常烦恼。朋狎恶法起见取烦恼。僻禀邪师造戒取烦恼。乃至一等四执横计烦恼。今日至诚归命忏悔

又复弟子等。从无始以来至于今日。守惜坚着起悭吝烦恼。不摄六情奢诞烦恼。心行弊恶不忍烦恼。懒堕缓纵不勤烦恼。情虑躁动觉观烦恼。触境迷惑无知解烦恼。随世八风生彼我烦恼。谄曲面誉不直心烦恼。横强难触不调和烦恼。易忿难悦多含恨烦恼。嫉妒系刺恨戾烦恼。凶险暴害谄毒烦恼。乖背二谛执相烦恼。于苦集灭道生颠倒烦恼。随从生死十二因缘流转烦恼。乃至无始无明住地恒沙烦恼。起四住地构于三界苦果烦恼。如是等诸烦恼无量无边。恼乱贤圣六道四生。今日发露向十方佛尊法圣众归命忏悔

愿弟子等。承是忏悔贪嗔痴等一切诸烦恼所生功德。愿生生世世折憍慢幢竭爱欲水。灭嗔恚火破愚痴暗。拔断疑根裂诸见网。深识三界犹如牢狱。四大毒蛇五阴怨贼。六入空聚爱诈亲善。修八圣道断无明源。正向涅槃不休不息。三十七品心心相应。十波罗蜜常现在前

    大乘莲华宝达问答报应沙门经

宝达顷前更入一斫手地狱。云何名曰斫手地狱。其地狱纵广三十六由旬。其地狱中有大铁床。纵广五十余步。炎火猛炽烟焰俱起来烧罪人。罪人见之迫迮倒地而不自胜。南门之中有五千沙门。扬声大叫我今何罪来入此中。马头罗刹手捉三钴铁叉。望胸而撞背上而出。将至铁床之上。其床火然烟焰俱出来烧罪人。复有铁斧斫罪人手寸寸而碎。一日一夜受罪万端。求生不得求死不得

宝达问马头罗刹曰。此诸沙门。作何罪业来入其中。罗刹答曰。此诸沙门受佛净戒而不能持。亦不清净杨枝漱口。手不清净多有垢秽。或手捉男根女根捉不净物。脾中有臭秽而不除去便捉经像。以是因缘堕此地狱。经千万劫而不能出。若得为人身不具足

宝达闻之悲泣而去

佛名经卷第十七佛说佛名经卷第十八

南无无障佛月佛　南无不赞叹世间胜佛　南无法王决定佛　南无星宿宝云王佛　南无阿私多宝胜佛　南无法行自在佛　南无地勇名佛　南无无边胜宝名佛　南无名智奋迅王佛　南无名树迦那伽王佛　南无名增长慧佛　南无名法华通德佛　南无名快照光明精进通集佛　南无名照观佛王佛　南无名不着恶胜佛　南无名智尽天佛　南无名胜妙法佛　南无名大智声智慧佛　南无名见一切世间不畏佛　南无名见无畏佛　南无名声去佛　南无如来行无量王佛

复次舍利弗。现在西方诸佛。汝等应当一心敬礼

南无初光明华心照佛　南无妙声修行吼佛　南无住胜智称佛　南无普见佛　南无作大悲心华光佛　南无法行然灯佛　南无普胜佛　南无智吼称王佛　南无梵声欢喜吼佛　南无千眼佛　南无海香炎佛　南无千月自在藏佛　南无法速乐行佛　南无身贤远光佛　南无师子广眼佛　南无十力光明胜佛　南无智来佛　南无无边精进胜面佛　南无大胜成就法佛　南无不空见佛　南无不可尽色佛　南无观法智佛　南无无王妨佛　南无无边德佛　南无智察法佛　南无一切善根菩提道佛　南无无碍精进善思惟奋迅王佛　南无上智胜善住功德佛　南无智香胜佛　南无智胜见尸弃王佛　南无妙功德智佛　南无不忧法华吼王佛　南无法清净来佛　南无胜上功德佛　南无开法门藏佛　南无照法同王佛　南无力王善住法佛　南无善择力得佛　南无无边门见佛　南无善化庄严佛　南无不似见佛　南无离嗔功德王佛　南无离尘忆胜佛　南无大力般若奋迅王佛　南无法镜像佛　南无坚叉利成就佛　南无一切智功德胜佛　南无不乐出功德佛　南无精进过精进自在山佛　南无一切世间自在桥梁胜佛　南无示现无尽德佛　南无清净戒功德王佛　南无华严作庄严佛　南无独王佛　南无得大通愿力佛　南无吼声速精进佛　南无胜身那罗延智佛　南无那罗延佛　南无宝光阿尼罗胜佛　南无宝海炎佛　南无大海弥留胜王佛　南无初不浊天王佛　南无不住生灭胜功德王佛　南无虚空乐说无碍称佛　南无胜慧佛　南无无比藏称佛　南无天自在梵增上佛　南无善行见王佛　南无种种行王佛　南无卢舍那胜功德佛　南无自在佛　南无住华佛　南无智善根成就性佛　南无无障碍智成就佛　南无善决法佛　南无法庄严观乐说称佛　南无二宝然灯佛　南无摩诃思惟藏佛　南无不可思议王佛　南无自在忆佛　南无师子胸藏佛　南无智王庄严佛　南无自在根佛　南无离声眼佛　南无善香佛　南无不染佛　南无波头摩佛　南无法身佛　南无广戒王佛　南无心善行称佛　南无法自在佛　南无如意通观藏佛　南无然灯贪王佛　南无福德胜田佛　南无世间意成就善法佛　南无善观佛法胜佛

复次舍利弗。现在北方诸佛。汝等应当一心归命

南无初胜藏山佛　南无放光明佛　南无无边智慧佛　南无龙华佛　南无一切龙奋迅勇猛佛　南无福德庄严佛　南无法世间镜像佛　南无降伏一切魔佛　南无胜婆嗟山佛　南无法来王佛　南无佛化成就佛　南无普庄严树行胜佛　南无宝积成就佛　南无一切成就称佛　南无三世智胜佛　南无胜威善住佛　南无种种愿光佛　南无不退百胜光佛　南无无边智慧佛　南无龙华德佛　南无分闇罗胜佛　南无夺一切邪见佛　南无得佛眼轮佛　南无得一切佛智佛　南无大悲救护胜佛　南无师子智桥梁佛　南无住实际王佛　南无诸善根福德法成就佛　南无大无垢智佛　南无智称王佛　南无佛法波头摩佛　南无兴一切相佛　南无随一切意法云佛　南无满足精进宝慧佛　南无大毗留[口*荼]佛　南无胜光明佛　南无不动法智光佛　南无栴檀云王佛　南无不染波头摩声佛　南无法增上声王佛　南无无垢劫佛　南无撰择法无碍花称佛　南无佛眼无垢精进增上轮佛　南无智自在称佛　南无无边疑佛　南无无边智奋迅无碍心佛　南无广威德自在王佛　南无欲法道善住佛　南无一切生智佛　南无降伏魔力坚固意佛　南无精进自在宝王佛　南无威德藏佛　南无见利益一切欢喜佛　南无大步佛王佛　南无种种日佛　南无声分妙宝吼佛　南无无垢法王佛　南无不退精进示现佛　南无庄严佛国土王佛　南无智根本华佛　南无不称涅槃佛　南无一切龙摩尼藏佛　南无乐法自在佛　南无得法相自在佛　南无无边宝功德藏佛　南无清净华山佛　南无大法王拘苏摩胜佛　南无一切尽不尽藏佛　南无华弥留善佛　南无虚空智山佛　南无智力王佛　南无无碍声智佛　南无无边佛声藏佛　南无智王不尽称佛　南无心慧奋迅王佛　南无自性清净智佛　南无智自在法王佛　南无正见佛　南无语见佛　南无满足法香见佛　南无龙月佛　南无因陀罗山无碍王佛　南无宝自在莎罗王佛　南无见一切众生佛　南无水住持光明王佛　南无觉一切法佛　南无智宝法胜佛　南无精进自在意法藏佛　南无无碍山佛　南无无垢鬘佛　南无放光明照佛　南无炎自在藏佛　南无声分妙觉吼佛　南无弥留力自在藏佛　南无精进自在弥留寂自在佛　南无坚固无畏功德佛　南无坚固勇猛宝佛　南无坚固勇猛寂静王佛　南无降伏闇弥留山王佛　南无胜丈夫芬陀利佛　南无圣声藏佛　南无普贤芬陀利佛　南无法平等法身佛　南无难胜佛　南无离可意佛　南无不动佛　南无妙声佛　南无胜声佛　南无莎罗奋迅佛　南无宝胜佛　南无爱见佛　南无然灯佛　南无须弥劫佛　南无日光佛　南无月光佛　南无法界佛　南无药树王佛　南无星宿佛　南无觉上佛　南无授记佛　南无爱作佛　南无无畏作佛　南无华宝栴檀佛　南无龙功德佛　南无卢舍那佛　南无无垢佛　南无无烦恼佛　南无善来佛　南无金色色佛　南无无根本佛　南无须弥登佛　南无可乐见光佛　南无能作光佛　南无一切无浊佛　南无无染佛　南无善净佛　南无解脱佛　南无华树佛　南无法性佛　南无善护声佛　南无得意佛　南无断爱佛　南无内外佛　南无成就幢佛　南无梵声佛　南无妙声佛　南无胜声佛　南无金刚佛　南无大通佛　南无无畏佛　南无离一切烦恼佛　南无离怖畏佛　南无离怯弱佛　南无不可动佛　南无乐解脱佛　南无成就佛　南无两足尊佛　南无一切种智佛　南无相庄严佛　南无不可量言佛　南无不畏言佛　南无常相应言佛　南无梵众相应佛　南无三十天众相应佛　南无字金色佛　南无舍结佛　南无莎罗华佛　南无金华佛　南无拘牟头相佛　南无顶胜佛　南无一切通智佛　南无得一切法到彼岸佛　南无不可相佛　南无善住佛　南无庄严相佛　南无清净众生佛　南无常智佛　南无妙寂佛　南无舍浮罗奋迅佛　南无毕竟大悲佛　南无成就坚佛　南无常微笑佛　南无离浊佛　南无百相功德佛　南无随顺佛　南无胜藏佛　南无般若幢佛　南无宝般若毕竟佛　南无满足意佛　南无观世自在王佛　南无大炎聚佛　南无胜功德威德佛　南无梵胜天佛　南无内宝佛　南无三菩提幢佛　南无胜灯佛　南无善择愿越胜莎罗王佛　南无无垢光明佛　南无照闇佛　南无无畏观佛　南无乐说庄严佛　南无无垢月鸡兜称佛　南无华庄严光明作佛　南无火奋迅佛　南无宝上佛　南无无畏智观佛　南无师子奋迅齐佛　南无远离一切惊怖毛竖等称光佛　南无伽那伽王光明威德佛　南无观世音佛　南无尼弥佛　南无宝火佛　南无宝山佛　南无自在佛　南无宝精进日月光明庄严威德黠声王佛　南无初发心念观一切疑则断烦恼佛　南无断闇三昧胜王佛　南无宝炎佛　南无火聚佛　南无栴檀香佛　南无虚空平等佛　南无礼拜增上佛　南无不动作佛　南无欢喜佛　南无离畏佛　南无善清净胜佛　南无光明王佛　南无不降伏幢佛　南无胜一切佛　南无闻声胜佛　南无善臂佛　南无宝高佛　南无善解佛　南无月高佛　南无善见佛　南无照贤首胜佛　南无得圣佛　南无成就一切事佛　南无山峰佛　南无普宝盖庄严佛　南无广光明王佛　南无宝盖喜佛　南无清净一切愿威德胜王佛　南无照贤胜佛　南无乐日佛　南无普贤佛　南无功德王光明佛　南无普光明佛　南无普香佛　南无善清净佛　南无法藏佛　南无最上首佛　南无菩提华佛　南无月明佛　南无日光佛　南无华色王佛　南无水月光佛　南无除疑冥佛　南无度盖行佛　南无净信佛　南无善宿佛　南无威神佛　南无法慧佛　南无鸾音佛　南无师子音佛　南无龙音佛　南无处世佛　南无自在佛　南无无量寿佛　南无无量光佛　南无无边光佛　南无无碍光佛　南无无对光佛　南无炎王光佛　南无清净光佛　南无欢喜光佛　南无智慧光佛　南无不断光佛　南无难思光佛　南无无称光佛　南无超日月光佛　南无相好紫金佛　南无远照佛　南无宝藏佛　南无无量音佛　南无普胜佛　南无智吼称王佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无功德相严菩萨　南无山相击音菩萨　南无金璎珞明菩萨　南无一切行净菩萨　南无三昧游戏菩萨　南无心无碍菩萨　南无明庄严菩萨　南无定无碍菩萨　南无电得菩萨　南无大智菩萨　南无更明菩萨　南无蒙光菩萨　南无华光菩萨　南无文光菩萨　南无龙光菩萨　南无同光菩萨　南无明星菩萨　南无千阳菩萨　南无日中菩萨　南无建立菩萨　南无树王菩萨　南无龙天菩萨　南无地动菩萨　南无得辨手音声菩萨　南无普广菩萨　南无入精进菩萨　南无尽精进菩萨　南无不舍乐菩萨　南无上精进菩萨　南无习精进菩萨　南无一乘度菩萨　南无行精进菩萨　南无悲精进菩萨　南无净命精进菩萨　南无至诚精进菩萨　南无坚勇精进菩萨　南无天德藏菩萨　南无击金慧菩萨　南无师子幡菩萨　南无师子住菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

众等相与即今身心寂静。无谄无障正是生善灭恶之时。复应各起四种观行以为灭罪作前方便。何等为四。一者观于因缘。二者观于果报。三者观我自身。四者观如来身

第一观因缘者。知我此罪籍以无明不善思惟。无正观力不识其过。远离善友诸佛菩萨。随逐魔道行邪崄俓。如鱼吞钩不知其患。如蚕作茧自萦自缚。如蛾赴火自烧自烂。以是因缘不能自出

第二观于果报者。所有诸恶不善之业。三世流转苦果无穷。沉溺无边巨夜大海为诸烦恼罗刹所食。未来生死冥然无涯设使报得转轮圣王。王四天下飞行自在七宝具足。命终之后不免死堕恶趣。四空果报三界尊极。福尽还作牛头中虫。况复其余无福德者。而复懈怠不勤忏悔。此亦譬如抱石沉渊求出良难。第三观我自身。虽有正因灵觉之性。而为烦恼黑暗丛林之所覆蔽。无了因力不能得显。我今应当发起胜心。破裂无明颠倒重障。断灭生死虚伪苦因。显发如来大明觉慧。建立无上涅槃妙果

第四观如来身。无为寂照离四句绝百非。众德具足湛然常住。虽复方便入于灭度。慈悲救接未曾暂舍。生如是心可谓灭罪之良津除障之要行。是故弟子今日至心稽首归命于佛

南无东方胜音佛　南无南方喻如须弥佛　南无西方大光华通佛　南无北方菩提光明佛　南无东南方莲花敷力佛　南无西南方衣服知足佛　南无西北方出家乐行佛　南无东北方宝盖超光佛　南无下方名称远闻佛　南无上方无言胜佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。长养烦恼日深日厚日湿日茂。覆盖慧眼令无所见。断除众善不得相续起障。不得见佛不闻正法不值圣僧烦恼起障。不见过去未来一切世中善恶业行之烦恼障。受人天尊贵果报之烦恼障。生色无色界禅定福乐之烦恼障。不得自在神通飞腾隐显遍至十方诸佛净土听法之烦恼障。学安那般那数息不净观诸烦恼障。学慈悲喜舍因缘烦恼障。学七方便三观义烦恼障。学四念处暖顶忍烦恼障。学闻思修第一法烦恼障。学空平等中道解烦恼障。学八正道示相之烦恼障。学七觉支不示相烦恼障。学于道品因缘观烦恼障。学八解脱九空之烦恼障。学于十智三昧烦恼障。学三明六通四无碍烦恼障。学六度四等烦恼障。学四摄法广化之烦恼障。学大乘心四弘誓愿烦恼障。学十明十行之烦恼障。学十回向十愿之烦恼障。初地二地三地四地明解之烦恼障。五地六地七地诸知见烦恼障。学八地九地十地双照之烦恼障。如是乃至障学佛果。百万阿僧祇诸行上烦恼障。如是行障无量无边。弟子今日。至到稽恳向十方佛尊法圣众。惭愧忏悔愿皆消灭

愿籍此忏悔障于诸行。一切烦恼障永尽无余。愿弟子。在在处处自在受生不为结业之所回转。以如意通于一念顷遍至十方。净诸佛土摄化众生。于诸禅定甚深境界及诸知见通达无碍。心能普周一切诸法。乐说无穷而不染着。得心自在得法自在。智慧自在方便自在。令此烦恼及无知结习毕竟永断不复相续。无漏圣道朗然如日

    大乘莲华宝达问答报应沙门经

宝达顷前入一雨火地狱。云何名曰雨火地狱。其地狱纵广八千由旬铁壁周圆炎火俱炽。下有铁刃其刃正仰。其城四角起风吹城。其城火炽四角铜狗。狗牙上出。口眼火出其疾如风。铜狗口中出于云气叆叇拂郁。其鼻出水亦如天雨。其滴之中火焰俱起。空中来下火如车轮。着罪人身举身火然。一日一夜受罪无量。千死千生万死万生

宝达问马头罗刹曰。此诸沙门作何业行受如是苦。马头罗刹答曰。此诸沙门受佛净戒而不护惜威仪。虽作袈裟而不肯着。空身露体入于村邑。犹如枯树无有光泽。若在佛地僧地亦复如是。诸天唱曰。狂贼比丘入人村邑。以是因缘堕此地狱。从地狱出经千万劫常作畜生。宝达闻之悲泣而去

佛名经卷第十八佛说佛名经卷第十九

尔时佛告舍利弗。举要言之现在诸佛说不可尽。舍利弗。譬如东方恒河沙世界。南方恒河沙世界。西方恒河沙世界。北方恒河沙世界。上下四维恒河沙世界。彼一切世界下至水际上至有顶满中微尘。舍利弗。于意云何。彼如是微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。如是同名释迦牟尼佛现在世者。我现前见彼诸佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。彼诸佛第一声闻弟子。同名舍利弗目揵连。侍者弟子同名阿难。何况种种异名母异名父异名城。异名弟子异名侍者。舍利弗。彼若干世界。彼人于何等世界着微尘。何等世界不着微尘。彼诸世界若着微尘及不著者。下至水际上至有顶。舍利弗。复有第二人取彼微尘。彼若干微尘数尔所佛国土。阿僧祇亿百千万那由他世界。过尔所世界为一步。舍利弗。彼人复过若干微尘数世界为一步。彼人如是过百千万亿那由他阿僧祇劫行乃下一尘。如是尽诸微尘。舍利弗。如是若干世界。若着微尘及不著者满中微尘。复更着十方世界。舍利弗。复过是世界。若着微尘及不著者。彼诸世界下至水际上至有顶满中微尘。舍利弗。复有第三人。取彼尔所微尘。过彼尔所微尘数世界为一步。彼若干百千万亿那由他阿僧祇劫行乃下一尘。如是尽诸微尘。复有第四人。取彼若干微尘数世界。若着微尘及不著者。下至水际上至有顶满中微尘。舍利弗。于意云何。彼诸微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。彼若干微尘可知其数。然彼同名释迦牟尼佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一弟子同名舍利弗目揵连。侍者弟子同名阿难陀。彼佛不可知数。舍利弗。如是第五人第六第七第八第九第十人。舍利弗。复有第十一人。是人彼若干微尘中取一微尘。破为十方若干世界微尘数分。如是余微尘亦悉破为若干世界微尘数分。舍利弗。于意云何。彼微尘分可知数不。舍利弗言。不也世尊。佛告舍利弗。复有人过彼若干微尘分佛国土为一步。如是速疾神通。行东方世界无量无边劫下一微尘。东方尽如是微尘。若着微尘及不著者。下至水际上至有顶满中微尘。如是南方乃至十方。下至水际上至有顶满中微尘。舍利弗。于意云何。彼微尘可知数不。舍利弗言。不也世尊。佛告舍利弗。彼若干微尘分可知其数。然现今在世同名释迦牟尼佛。母同名摩诃摩耶。父同名输头檀王。城同名迦毗罗。第一弟子同名舍利弗目揵连。侍者弟子同名阿难陀。不可知数。何况种种异名佛。异名母异名父异名城。异名弟子异名侍者。舍利弗。我若干微尘数劫住世。说一同名释迦牟尼不可穷尽。如是同名然灯佛。同名提波延佛。同名灯光明佛。同名一切胜佛。同名大称佛。同名波头摩胜佛。同名毗婆尸佛。同名尸弃佛。同名毗舍浮佛。同名拘留孙佛。同名拘那含牟尼佛。同名迦叶佛。如是等同名乃至异名侍者。现在世者我今悉知。汝等应当一心敬礼

尔时佛告舍利弗。若善男子善女人求阿耨多罗三藐三菩提者。当先忏悔一切诸罪。若比丘犯四重罪。比丘尼犯八重罪。式叉摩那沙弥沙弥尼。犯出家根本罪。若优婆塞犯优婆塞重戒。优婆夷犯优婆夷重戒。欲忏悔者。当净洗俗着新净衣不食薰辛。当在静处修治室内。以诸幡华庄严道场。香泥涂画悬四十九枚幡。庄严佛座安置佛像。烧种种香栴檀沉水。薰陆多伽罗苏挞陀。种种末香涂香。烧如是等种种妙香散种种华。兴大慈悲愿救苦众生。未度者令度。未解者令解。未安者令安。未得涅槃者令得涅槃。昼夜思惟如来本行苦行。于无量劫受诸苦恼不生疲厌。为求无上菩提故。于一切众生自生下心如僮仆心。若比丘忏四重罪。如是昼夜四十九日。当对八清净比丘发露所犯罪。七日一对发露。至心殷重悔昔作所。一心归命十方诸佛。称名礼拜随分随力。如是至心满四十九日罪必除灭。是人得清净时当有相现。若于觉中若于梦中。见十方诸佛与其记莂。或见菩萨与其记莂。将诣道场共为己伴。或与摩顶示灭罪相。或自见身入大会中处在众次。或自见身处众说法。或见诸师净行沙门。将诣道场示其诸佛。舍利弗。若比丘忏悔罪时。若见如是相者。当知是人罪垢得灭。除不至心。若比丘尼忏悔八重罪者。当如比丘法。满足四十九日当得清净。除不至心。若式叉摩那沙弥沙弥尼。忏悔根本重罪。当对四清净比丘比丘尼。如上法满二十一日当知清净。除不至心。若优婆塞优婆夷忏悔灭罪。应当至心恭敬三宝。若见沙门恭敬礼拜生难遭想。请诣道场设种种供养。当请一比丘心敬重者。就其发露所犯诸罪至心忏悔。一心归命十方诸佛称名礼拜。如是满足七日必得清净除不至心。尔时世尊。而说偈言

  得成菩提降伏魔　　自在经行道树下
  证无障碍眼及身　　法界平等如虚空
  十亿国土微尘数　　菩萨弟子众围绕
  得于一切寂静心　　善住普贤诸行中
  佛身相好妙庄严　　放于种种无量光
  普照十方诸国土　　诸佛不可思议力
  见诸国土悉无垢　　无量妙色清净满
  诸佛所有胜妙事　　承佛神力见大众
  东方世界名宝幢　　远离诸垢妙庄严
  彼处自在宝灯佛　　于今现在彼世界
  南方颇梨灯国土　　清净妙色普严净
  摩尼清净云如来　　现今在世说妙法
  西方无垢清净土　　名为安乐妙世界
  彼自在无量寿佛　　菩萨弟子现围绕
  北方世界名香灯　　国土清净甚严饰
  无染光幢佛所化　　现今自在道场树
  琉璃光明真妙色　　国土清净胜庄严
  无碍光云佛如来　　于今现在东北方
  光明照幢世界中　　现见满足诸菩萨
  自在吼声佛彼处　　现今在于东南方
  种种乐乐佛世界　　摩尼庄严妙无垢
  胜妙智月如须弥　　现今在于西南方
  现见西北方如来　　弥留光明平等界
  彼处大圣自在佛　　弟子菩萨众围绕
  下方世界自在光　　国土清净宝炎藏
  光明妙轮不空见　　佛今住彼妙国土
  上方世界光炎藏　　彼世界名净无垢
  普眼功德光明云　　现见菩提树下坐

尔时舍利弗等大众。承佛神力见十方过去未来现在诸佛无量无边。尔时舍利弗在大众中悲泣流泪白佛言。希有世尊。若善男子善女人。不发阿耨多罗三藐三菩提心者不得成佛。我等昔来犹如腐草。虽经春阳无悕秋实

尔时慧命舍利弗。则从座起偏袒右肩右膝着地合掌白佛言。世尊。愿更广说十方所有诸佛名号。我等乐闻

尔时佛告舍利弗。汝当至心谛听我为汝说。舍利弗。从此世界东方过百千亿世界。有佛世界名然灯。彼世界有佛名宝集阿罗诃三藐三佛陀。现在说法。舍利弗。若善男子善女人。闻彼佛名至心受持忆念。是善男子善女人毕竟得七觉分三昧。得不退转阿耨多罗三藐三菩提心。超越世间六十劫。尔时世尊以偈颂曰

  东方然灯界　　有佛名宝集
  若人闻名者　　超世六十劫

舍利弗。东方有世界名宝集。彼世界有佛名宝胜阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。至心受持忆念读诵合掌礼拜。若复有善男子善女人。以满足三千大千世界珍宝布施。如是日日布施满一百岁。如此布施福德比前至心礼拜功德。百分不及一。千分不及一。百千分不及一。数分不及一。算分不及一。譬喻分不及一。尔时世尊以偈颂曰

  宝集世界　　有佛宝胜　　若人闻名
  施不及一

舍利弗。从此东方过八百世界。有佛世界名香积世界。有佛名成就卢舍那阿罗诃三藐三佛陀。现在说法。若人闻彼佛名。受持读诵忆念礼拜。超越世间五百劫。舍利弗。从此世界东方过千世界。名树提跋提。彼世界有佛名卢舍那镜像阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。受持读诵至心忆念恭敬礼拜得脱三恶道

舍利弗。从此东方过二千世界。有佛国土名无量光明功德。彼世界有佛名卢舍那光明阿罗诃三藐三菩陀。若善男子善女人闻彼佛名。五体投地深心敬重。受持读诵恭敬礼拜。是人超越世间二十劫

舍利弗。东方过千世界有佛国土名可乐。彼佛名不动应供正遍知。若善男子善女人闻彼佛名。受持读诵恭敬礼拜。是人毕竟不退阿耨多罗三藐三菩提。一切诸魔所不能动

舍利弗。东方过千世界有佛世界名不可量。彼处有佛名大光明阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼光明佛名。受持读诵恭敬礼拜。是人常不离一切诸佛菩萨。毕竟得不退转阿耨多罗三藐三菩提

舍利弗。从此佛国土。东方过六十世界有佛世界名然灯炬。佛名不可量声阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼阿弥陀佛名。三遍称南无无量声如来南无无量声如来南无无量声如来。是人毕竟不堕三恶道。定得阿耨多罗三藐三菩提

舍利弗。复过彼世界度千佛国土。有佛世界名无尘。彼有佛同名阿弥陀劬沙阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。深心敬重受持读诵恭敬礼拜。是人超越世间十二劫

舍利弗。复过二十千佛国土。有佛世界名难胜。彼处有佛名大称阿罗诃三藐三佛陀。若善男子善女人闻彼佛名。合掌作如是言。南无大称如来。若复有人以须弥山等七宝。日日布施满一百岁。比闻此佛名礼拜功德。百分不及一乃至算数分不及一

舍利弗。复过三千佛国土有世界名光明。佛名宝光明阿罗诃三藐三佛陀。若善男子善女人受持彼佛名。超越世间一百劫。得不退转阿耨多罗三藐三菩提。若有人不信闻名得如此功德。是人当堕阿鼻地狱满足一百劫

舍利弗。东方过十千佛国土。有世界名光照明。彼处有佛名得大无畏阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。受持读诵恭敬礼拜。是人毕竟得大无畏。摄取无量无边功德聚。舍利弗。过七千佛国土有世界。名摩尼光明。彼处有佛名然灯火阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。至心恭敬礼拜受持读诵。是人摄得如来十力

舍利弗。复过八千佛国土。有世界名真实。彼世界中有佛号实声如来阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。受持读诵至心礼拜。是人毕竟得四圣谛。毕竟得阿耨多罗三藐三菩提

舍利弗。复过二十千佛国土。有佛世界名光明。佛名无边无垢佛阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。至心信受受持读诵恭敬礼拜。若复有人以满三千大千世界七宝布施。比闻无垢佛名受持读诵功德。千万分不及一乃至算数分不及一。何以故。若众生善根微薄。不能得闻无垢佛名。若有善男子善女人。闻无边离垢如来名。是人非于一佛所种诸善根。亦非千佛所种诸善根。是人乃是百千万佛所种诸善根。是人超越世间四十八劫

舍利弗。东方过九千佛国土。有世界名妙声。佛名月声阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。能受持读诵至心礼敬。是人所得一切功德。百法具足如满月。毕竟得阿耨多罗三藐三菩提

舍利弗。复过十千佛国土。有世界名无畏。佛名无边称阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名。受持读诵合掌作如是言。南无无边称世尊。若复有人七宝如须弥等布施。日日如是满足百年。此福德聚比持佛名功德。百分不及一。乃至算数譬喻所不能及

舍利弗。复过千五百佛国土。有世界名曰然灯。佛名日月光明阿罗诃三藐三佛陀。现在说法。若善男子善女人闻彼佛名受持读诵。胡跪合掌右膝着地。三遍作如是言。南无日月光明世尊。南无日月光明世尊。南无日月光明世尊。是人速成阿耨多罗三藐三菩提

舍利弗。复过三十千佛国土。有世界名无垢。佛名无垢光明阿罗诃三藐三佛陀。现在说法。若善男子善女人。天龙夜叉罗刹若人非人。闻是佛名毕竟不退阿耨多罗三藐三菩提。不入恶道

舍利弗。东方过十千佛国土。有世界名百光明。佛名清净光明阿罗诃三藐三佛陀。现在说法。若天龙夜叉非人闻名者。必得人身远离贪嗔痴烦恼。若人闻不信者。六十千劫堕大地狱

舍利弗。复过百佛国土。有世界名善德。佛名日光明阿罗诃三藐三佛陀。现在说法。若人毕竟清净心称此佛名。所得功德满足如日轮。毕竟能伏一切诸魔外道。超越世间三十劫

舍利弗。复过六十千佛国土。有世界名住七觉分。佛名无边宝阿罗诃三藐三佛陀。现在说法。若人闻彼佛名。是人具足得七觉分。能置众生着胜宝中。毕竟成就无量功德聚

舍利弗。复过五百佛国土。有世界名华镜像。佛名华胜阿罗诃三藐三佛陀。现在说法。若人闻彼佛名信心敬重。彼人一切善法成就如华开敷。超越世间五十五劫

舍利弗。复过百千亿佛国土。有世界名远离一切忧恼。佛名妙身阿罗诃三藐三佛陀。现在说法。若人闻彼佛名至心敬重礼拜供养。是人毕竟远离一切诸障不入恶道。超越世间无量劫

舍利弗。复过那由他佛国土。有世界名平等。彼处有佛号法光明清净开敷莲华阿罗诃三藐三佛陀。现在说法。若人得闻彼如来名受持不忘者。永离三恶道

南无法光明清净开敷莲华佛

舍利弗。若比丘比丘尼优婆塞优婆夷。欲忏悔诸罪。当净洗浴着新净衣。净治室内敷设高座安置佛像。悬二十五枚幡。种种华香供养。诵此二十五佛名。日夜六时忏悔。满二十五日灭四重八重等罪。式叉摩那沙弥沙弥尼。亦复如是

尔时舍利弗白佛言。世尊。唯愿世尊。为我说过去七佛名姓寿命长短。我等乐闻。佛告舍利弗。谛听谛听当为汝说。舍利弗。过去九十一劫有佛。名毗婆尸如来。过去三十劫有佛。名尸弃如来。彼劫中复有毗舍浮如来。自此以后无量无边劫空过无佛。至贤劫中有四佛。拘留孙佛。拘那含牟尼佛。迦叶佛。我释迦牟尼佛。毗婆尸佛寿命八十千劫。尸弃佛寿命六十千劫。毗舍浮佛寿命二千劫。拘留孙佛寿命十四小劫。拘那含牟尼佛寿命三十小劫。迦叶佛寿命二小劫。我现在最少寿命一百岁。毗婆尸佛尸弃佛毗舍浮佛刹利家生。拘留孙佛拘那含佛迦叶佛婆罗门家生。舍利弗。我释迦牟尼佛刹利家生。毗婆尸佛尸弃佛毗舍浮佛三佛姓拘邻。拘留孙佛拘那含牟尼佛迦叶佛此三佛姓迦叶。舍利弗。我释迦牟尼佛姓瞿昙。舍利弗。毗婆尸佛波吒罗树下得阿耨多罗三藐三菩提。尸弃佛芬陀利树下得阿耨多罗三藐三菩提。毗舍浮佛莎罗树下得阿耨多罗三藐三菩提。拘留孙佛利沙树下得阿耨多罗三藐三菩提。拘那含牟尼佛尸优头跋树下得阿耨多罗三藐三菩提。迦叶佛尼拘律树下得阿耨多罗三藐三菩提。我释迦牟尼佛阿说他树下得阿耨多罗三藐三菩提。毗婆尸佛三集声闻。尸弃佛三集声闻。毗舍浮佛再集声闻。拘留孙佛一集声闻。拘那含牟尼佛一集声闻。迦叶佛一集声闻。我释迦牟尼佛一集声闻。毗婆尸佛第一声闻弟子。一名吉沙二名看荼。尸弃佛第一声闻弟子。一名胜二名自在。毗舍浮佛第一声闻弟子。一名星宿二名上。拘留孙佛第一声闻弟子。一名疾二名力。拘那含牟尼佛第一声闻弟子。一名活二名毗头罗。迦叶佛第一声闻弟子。一名输那二名颇罗堕。我释迦牟尼佛第一声闻弟子。一名舍利弗二名目揵连。如上二人等前者智慧第一。后神通第一。毗婆尸佛侍者名无忧。尸弃佛侍者名离畏。毗舍浮佛侍者名寂。拘留孙佛侍者名智。拘那含牟尼佛侍者名亲。迦叶佛侍者名迦失。我侍者名欢喜。毗婆尸佛子名成阴。尸弃佛子名不可量。毗舍浮佛子名善智。拘留孙佛子名上。拘那含牟尼佛子名胜。迦叶佛子名导师。我子名罗睺罗。毗婆尸佛父名槃头。母名槃头意。城名槃头。尸弃佛父名钩那。母名胜。城名阿楼那跋提。毗舍浮佛父名阿楼那天子。母名称意。城名随意。拘留孙佛父婆罗门种名功德。母名广被天。子名无畏。城亦名无畏。拘那含牟尼佛父婆罗门种名大德。母名难胜天。子庄严。城亦名庄严。迦叶佛父婆罗门种名净德。母名善才天。子名知使。城亦名知使。今时波罗奈城。是我今父名输头檀王。母名摩诃摩耶。城名迦毗罗

舍利弗。应当敬礼我本师。谓释迦牟尼佛。称妙佛。降伏一切佛。然灯光佛。无畏佛。法胜佛。如是等初一大阿僧祇劫有八十亿佛。最后名释迦牟尼佛。第二阿僧祇劫初。宝胜佛。然灯佛。妙声佛。胜成佛。善见佛。善眼佛。持提罗吒佛。师子无畏自在无违善眼善山善意栴檀降伏热降伏闇师子奋迅妙声无量威德净德炎见第一义。复有释迦牟尼妙行胜妙寂静妙身功德梵命月降自在调山目陀罗财。此是第二大阿僧祇劫。有如是等七十二亿佛应当敬礼。舍利弗。大力大精进净德大明阳炎。复有释迦牟尼大龙大威德坚行栴檀宝山因陀罗幢无畏作富楼那宝髻波头摩胜妙胜无垢与光明降伏怨波斯他大幢颇罗堕毕沙。星宿毗婆尸尸弃拘邻毗舍浮能作光明不可胜。复有尸弃善见最后释迦牟尼。第三大阿僧祇劫中有如是等七十一亿佛。应当敬礼。舍利弗。如是等过去无量佛。汝等应当敬礼

南无欢喜增长佛　南无人自在王佛　南无不动佛　南无大圣佛　南无欢喜佛　南无自在佛　南无普光明佛　南无满足佛　南无拘邻佛　南无安隐佛　南无大精进佛　南无智慧佛　南无大称佛　南无阿[少/兔]律佛　南无妙胜佛　南无不厌足佛　南无大光炎聚佛　南无月光佛　南无火威德佛　南无普宝盖佛　南无那罗延光明佛　南无善根增长光明佛　南无师子乘光明佛　南无离一切忧恼光明佛　南无坚固光明佛　南无云王光明佛　南无无垢臂光明佛　南无成就义光明佛　南无胜护光明佛　南无梵胜天王光明佛　南无如是等同名不可说不可量佛

舍利弗。汝应当敬礼无量寿佛国。安乐世界观世音菩萨。得大势菩萨。以为上首。及无量无边菩萨众。如是摩梨支世界难胜佛国土。光明幢菩萨。光明胜菩萨。以为上首。及无量无边阿僧祇菩萨众。如是可乐世界阿閦佛国土。香象菩萨。妙香象菩萨。以为上首。及无量无边菩萨众。如是卢舍那世界日月佛国土。师子菩萨。师子慧菩萨。以为上首。及无量无边菩萨众。如是不瞬世界善月佛国土。莎罗胎菩萨。一切法得自在菩萨。以为上首。及无量无边菩萨众。如是光明世界普照佛国土。月轮菩萨。宝炬菩萨。以为上首。及无量无边菩萨众。如是乐成世界宝炎如来佛国土。不空奋迅菩萨。不空见菩萨。以为上首。及无量无边菩萨众。观世界普观如来佛国土。云王菩萨。法王菩萨。以为上首。及无量无边菩萨众。见爱世界观世音王如来佛国土。降伏魔菩萨。山王菩萨。以为上首。及无量无边菩萨众。如是等十方世界一切佛国土。一切菩萨我皆归命

南无须弥登王佛　南无宝王佛　南无宝胜佛　南无摄持一切法佛　南无过称量佛　南无无臂喻佛　南无无边法佛　南无难思议佛　南无二万日月灯明佛　南无三万然灯佛　南无大通智胜佛　南无十六王子佛　南无空王佛　南无多宝佛　南无云自在灯王佛　南无威音王佛　南无无数光佛　南无思善佛　南无分身诸佛　南无日月净明德佛　南无浮华宿王智佛　南无无净庄严王佛　南无龙尊王佛　南无云雷音佛　南无云雷宿王华智佛　南无宝王佛　南无威德宝王佛　南无光明王佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无不思议菩萨　南无离觉音菩萨　南无惟念安菩萨　南无离垢称菩萨　南无无量音菩萨　南无大名闻菩萨　南无明埵髻菩萨　南无坚师子菩萨　南无独游步菩萨　南无舍所念菩萨　南无及智积菩萨　南无意善住菩萨　南无无极相菩萨　南无慧光曜菩萨　南无消强意菩萨　南无能拥护菩萨　南无至诚英菩萨　南无莲华界菩萨　南无众诸安菩萨　南无圣慧业菩萨　南无将功勋菩萨　南无无思议菩萨　南无净梵施菩萨　南无宝事业菩萨　南无处天华菩萨　南无善思惟菩萨　南无无限法菩萨　南无名闻意菩萨　南无已辩积菩萨　南无自在门菩萨　南无十种力菩萨　南无有十力菩萨　南无大圣愍菩萨　南无无所越菩萨　南无游寂然菩萨　南无在于彼菩萨　南无无数天菩萨　南无须弥光菩萨　南无极重藏菩萨　南无因超越菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等略忏烦恼障竟。今当次第忏悔业障。夫业能庄饰世趣。在在处处。是以思惟求离世解脱。所以六道果报。种种不同形类各异。当知皆是业力所作。所以佛十力中业力甚深。凡夫之人多于此中好起疑惑。何以故尔。现见世间行善之者是事轗轲。为恶之者触向谐偶。谓言天下善恶无分。如此计者皆是不能深达业理。何以故尔。经中说言。有三种业。何等为三。一者现报。二者生报。三者后报。现报业者。现在作善作恶。现身受报。生报业者。此生作善作恶。来生受报。后报业者。或是过去无量生中作善作恶。或于此生中受。或现在未来无量生中方受其报。向者行恶之人现在见好。此是过去生报后报。善业熟故。所以现在有此乐果。岂关现在作诸恶业而得好报。行善之人现在见苦者。是过去生中生报后报。恶业熟故现在善根力弱不能排遣。是故得此苦报。岂关现在作善而招恶报。何以知然。现见世间为善之者。为人所赞叹人所尊重。故知未来必招乐果。过去既有如此恶业。所以诸佛菩萨教令亲近善友共行忏悔。善知识者于得道中则为全利。是故弟子等。今日至诚归依于佛

南无东方清净藏佛　南无南方围绕香薰佛　南无西方宝无量幢佛　南无北方满足意佛　南无东南方快乐尊佛　南无西南方出法无垢王佛　南无西北方安立王佛　南无东北方白莲花生佛　南无下方法名号佛　南无上方无愚丰佛

归命如是等十方尽虚空界一切三宝

弟子等。从无始已来至于今日。积恶如恒沙造罪满天地。舍身与受身不觉亦不知。或作五逆深厚浊缠无间罪业。或造一阐提断善根业。轻诬佛语谤方等业。破灭三宝毁正法业。不信罪福起十恶业。迷真返正痴惑之业。不孝二亲反戾之业。轻慢师长无礼敬业。朋友无信犯不义之业。或作四重六重八重障圣道业。毁犯五戒破八齐业。五篇七聚多缺犯业。忧婆塞戒轻重垢业。或菩萨戒不能清净如说行业。前后方便污梵行业。月无六斋懈怠之业。年三长齐不常修业。三千威仪不如法业。八万律仪微细罪业。不修身戒心慧之业。春秋八王造众罪业。行十六种恶律仪业。于苦众生无愍伤业。不矜不念无怜愍业。不拔不济无救护业。心怀嫉忌无度彼业。于怨亲境不平等业。耽荒五欲不厌离业。或因衣食园林池沼生荡逸业。或以盛年放恣情欲。造众罪业。或善有漏回向三有障出世业。如是等业无量无边。今日发露向十方佛尊法圣众归命忏悔。愿弟子等。承是忏悔无间等罪所生福善。愿生生世世灭五逆罪除阐提惑。如是轻重诸罪。从今以去乃至道场誓不更犯。恒习出世清净善法。精持律行守护威仪。如渡海者爱惜浮囊。六度四等常檦行首。戒定慧品转得增明。速成如来三十二相八十种好。十力无畏大悲三念。常乐妙智八自在我

    大乘莲华宝达问答报应沙门经

宝达顷前入一沸屎地狱。云何名曰沸屎地狱。其地狱纵广六十由旬。周匝铁城铁网罗覆其中。东西流屎南北而流。火出其中烟炎俱起亦如云雨。甚大臭秽臭中之臭勿过于此。北门之中有六百沙门。来入其中。悲号涕泣口眼火出亦无休息。来入此粪池饮于粪屎入粪屎。口焰火俱出。口眼六根亦复如是。千死千生万死万生

宝达问马头罗刹曰。此诸沙门何因缘故堕此地狱。马头罗刹答曰。此诸沙门受佛净戒而不净持。贪嗜酒肉食啖五辛堕此地狱。宝达闻之悲泣而去

佛名经卷第十九佛说佛名经卷第二十

舍利弗归命善清净无垢宝功德集胜王佛

南无因陀罗幢佛　南无普照佛　南无清净光明王佛　南无金色光明师子奋迅王佛　南无普胜山功德佛　南无善住功德摩尼山王佛　南无普见王佛　南无金刚胜佛　南无普贤佛　南无普照佛　南无宝法胜决定佛　南无无量意功德王佛　南无地自在王佛　南无离尘功德佛　南无无尽光佛　南无无畏王佛　南无难知佛　南无金刚妙佛　南无无垢胜佛　南无月胜佛　南无一味胜佛　南无槃头华佛　南无鬘香胜佛　南无多摩罗跋香胜佛　南无月藏佛　南无沉水香佛　南无树提光明佛　南无海香佛　南无龙藏佛　南无宝光明佛　南无大云藏佛　南无智德佛　南无金刚藏佛　南无住持地佛　南无虚空平等佛　南无胜藏佛　南无濡语佛　南无有德佛　南无山藏佛　南无妙鼓佛　南无爱胜佛　南无鼓增上佛　南无欢喜藏佛　南无日藏佛　南无行胜佛　南无实语佛　南无智藏佛　南无妙声佛　南无自在胜佛　南无胜妙胜佛　南无佛宝幢佛　南无随顺戒佛　南无宝胜佛　南无无垢琉璃佛　南无满足金刚住持佛　南无甘露幢佛　南无成就功德佛　南无香山佛　南无根本胜藏佛　南无不可知佛　南无无边知佛　南无无量佛　南无无量自在佛　南无大光明佛　南无德藏佛　南无根本庄严奋迅佛　南无现无愚佛　南无宝月佛　南无无垢佛　南无离垢佛　南无勇施佛　南无清净佛　南无清净施佛　南无娑留那佛　南无水天佛　南无坚德佛　南无栴檀功德佛　南无无量掬光佛　南无光德佛　南无无忧德佛　南无那罗延佛　南无功德华佛　南无莲花光游戏神通佛　南无财功德佛　南无德念佛　南无善名称功德佛　南无红炎幢王佛　南无善游步功德佛　南无斗战胜佛　南无善游步佛　南无周匝庄严功德佛　南无根本光佛　南无一切众生见爱奋迅庄严王佛　南无忍王佛　南无离一切烦恼佛　南无宝色胜佛　南无香胜王佛　南无亿藏佛　南无见一切佛　南无见爱佛　南无不可见佛　南无甘露功德称佛　南无一切畏差别能断疑佛　南无师子吼佛　南无散华佛　南无大胜佛　南无无碍智作佛　南无一切作乐佛　南无尊胜佛　南无吉王佛　南无一切世间道自在王佛　南无须弥劫佛　南无胜须弥佛　南无解脱佛　南无世间声佛　南无坚奋迅佛　南无坚自在佛　南无栴檀胜佛　南无不差别佛　南无息功用佛　南无善思惟佛　南无能断一切业佛　南无离想佛　南无宝胜佛　南无宝轮佛　南无大宝佛　南无无垢光明佛　南无乐说庄严称佛　南无无垢月幢称佛　南无华庄严光明佛　南无出水火佛　南无无畏观佛　南无师子奋迅力佛　南无宝精进日月光明佛　南无庄严功德智声王佛　南无初发心念断一切疑烦恼佛　南无破一切闇胜佛　南无宝炎佛　南无栴檀香佛　南无大宝炎佛　南无华幢佛　南无普胜帝沙佛　南无满贤佛　南无最力精进奋迅佛　南无香胜佛　南无胜称佛　南无净镜佛　南无华胜佛　南无离尘佛　南无得功德佛　南无不动佛　南无栴檀佛　南无因陀罗财佛　南无乐山佛　南无能化佛　南无因陀罗幢佛　南无无畏作佛　南无富楼那佛　南无弗沙佛　南无法水清净虚空界王佛　南无普智光明胜王佛　南无香光明功德宝庄严王佛　南无清净光明无垢然灯佛　南无普智声王佛　南无善光火光佛　南无普喜速胜王佛　南无一切四无畏然灯佛　南无普门智照声佛　南无无量功德海藏光明佛　南无法界雷光无障碍功德佛　南无清净眼无垢然灯佛　南无师子光明胜光佛　南无广光明智胜幢佛　南无金光明无边力精进成佛　南无香光明欢喜力海佛　南无成就王佛　南无自在高佛　南无欢喜大海速行佛　南无称自在光佛　南无广称智佛　南无智成就海王幢佛　南无相显文殊月佛　南无一切法海胜王佛　南无智功德法住佛　南无梵自在胜佛　南无过法界胜声佛　南无不可嫌力普照光明幢佛　南无无垢功德日明佛　南无无碍智普照光明佛　南无无量胜鸡兜幢佛　南无法界虚空普遍光明佛　南无福德相云胜威德佛　南无照胜顶光明佛　南无法风大海意佛　南无相法化普光明佛　南无善成就眷属普照佛　南无法尽疾速欢喜慧佛　南无无垢清净普光明佛　南无清净眼华胜佛　南无善智力成就佛　南无虚空清净明月佛　南无然金色须弥灯佛　南无智胜宝法光明佛　南无然宝灯佛　南无普光明高山佛　南无大胜佛　南无波头摩奋迅佛　南无善天照佛　南无无尽功德佛　南无华威德佛　南无甘露力佛　南无声边佛　南无妙法胜威德成就佛　南无普光明声虚空照佛　南无普门见胜光佛　南无无边功德照佛　南无普光功德然灯镜像佛　南无喜乐现华火佛　南无宝须弥然灯王佛　南无善化法界金光明电声佛　南无可降伏力愿佛　南无虚空城慧吼声佛　南无十方广遍称智然灯佛　南无师子光明满足功德佛　南无智敷华光明佛　南无普眼满足法界鸡兜幢佛　南无胜慧善导师佛　南无普光明作佛　南无月幢佛　南无东方善护四天下名金刚良如来为上首　南无南方难胜四天下因陀罗如来为上首　南无西方亲意四天下婆楼那如来为上首　南无北方师子意四天下摩诃牟尼如来为上首　南无东南方妙乐四天下毗沙门如来为上首　南无西南方坚固四天下不动如来为上首　南无西北方善地四天下普门如来为上首　南无东北方善择四天下降伏诸魔如来为上首　南无上方妙四天下得智慧意如来为上首　南无下方光炎四天下善集如来为上首　南无卢舍那胜威德王佛　南无普光明胜藏王佛　南无法界佛　南无智灯佛　南无法界虚空智幢照佛　南无阿弥滥波眼佛　南无龙自在王佛　南无法月普智光王佛　南无普照胜弥留王佛　南无无障虚空智鸡兜幢王佛　南无普轮到声佛　南无无量星宿自在王佛　南无普遍香佛　南无弥留然灯王佛　南无香毗头罗佛　南无栴陀鸡兜佛　南无阿那罗眼境界佛　南无一切佛宝胜王佛　南无无边世间智轮鸡兜佛　南无阿僧伽智鸡兜佛　南无不可思量命佛　南无不可用佛　南无师子佛　南无月智佛　南无大照佛　南无日灯佛　南无无垢佛　南无山胜佛　南无波头摩胜藏佛　南无卢舍那佛　南无普眼佛　南无梵命佛　南无波薮天佛　南无无边光明平等法界庄严王佛　南无力光明佛　南无高行佛　南无栴檀违佛　南无金色意佛　南无妙饮佛　南无高声佛　南无最胜佛　南无高见佛　南无吉沙佛　南无弗沙佛　南无高称佛　南无妙波头摩佛　南无普功德佛　南无作灯佛　南无善目佛　南无功德幢佛　南无一切法佛吼王佛　南无山幢身眼胜佛　南无宝胜然灯功德幢佛　南无普智宝炎胜功德佛　南无因陀罗幢胜鸡兜佛　南无胜轮佛　南无大悲云幢佛　南无金刚那罗延鸡兜佛　南无无障碍胜安隐满足佛　南无火炎山胜庄严佛　南无一切法海胜王佛　南无宝髻炎满足然灯佛　南无深法海光佛　南无十亿国土微尘数同名金刚藏佛　南无十亿国土微尘数同名金刚鸡兜佛　南无十百千国土微尘数同名金刚幢佛　南无十百千国土微尘数同名善法佛　南无十百千国土微尘数同名称心佛　南无一佛国土微尘数同名普功德佛　南无不可说佛国土微尘数同名不可胜佛　南无不可说佛国土微尘数同名毗婆尸佛　南无十佛国土微尘数同名普幢佛　南无八十亿佛国土微尘数不可数百千万亿那由他同名普贤佛　南无一佛国土微尘数同名觉胜佛　南无十佛国土微尘数百千万亿那由他不可说同名普称自在佛　南无贤胜佛　南无功德海光明胜照藏佛　南无法界虚空满足不退佛　南无法界吼佛　南无不退转法界声佛　南无法树山威德佛　南无一切法坚固吼王佛　南无宝光然灯幢王佛　南无功德山光明威德王佛　南无法云吼王佛　南无智炬王佛　南无法电幢王胜佛　南无法灯智师子力山威德王佛　南无一切法印吼威德王佛　南无无垢法山威德灯佛　南无法光明胜云佛　南无法轮光明顶佛　南无法海说声王佛　南无法日智轮然灯佛　南无法华高幢云佛　南无法炎山鸡兜王佛　南无法行深胜月佛　南无法智普光明藏佛　南无常智作化佛　南无山王胜藏王佛　南无普门贤弥留法疾精进幢佛　南无一切法宝俱苏摩胜云佛　南无寂静光明身髻佛　南无法光明慈镜像月佛　南无炎胜海佛　南无智日普照佛　南无普轮佛　南无智照顶王佛　南无智山法界十方光明威德王佛　南无功德光俱苏摩灯佛　南无智炬商鸡兜幢王佛　南无日照光明王佛　南无相山佛　南无庄严山佛　南无日步普照佛　南无法王网胜功德佛　南无四无畏金刚那罗延师子佛　南无普智幢勇猛佛　南无法波头摩敷身佛　南无功德俱苏摩身重担佛　南无道场觉胜月佛　南无然灯法炬胜月佛　南无普贤光明顶佛　南无法幢灯金刚坚幢佛　南无称山胜云佛　南无栴檀胜月佛　南无普胜俱苏摩威德菩提佛　南无照一切王佛　南无波头摩胜藏佛　南无香炎照王佛　南无因波头摩佛　南无相山照佛　南无普称功德王佛　南无普门光明须弥山佛　南无法城光明胜功德山威德王佛　南无胜相佛　南无法力勇猛幢佛　南无转法轮光明吼声佛　南无光明功德山智慧王佛　南无转法轮月胜波头摩照佛　南无佛幢自在功德不可胜幢佛　南无宝波头摩光明藏佛　南无光明峰云灯佛　南无普觉俱苏摩佛　南无种种光明胜山藏佛　南无光明轮峰王佛　南无功德云盖佛　南无法峰云幢佛　南无法日云灯王佛　南无功德山威德佛　南无法云十方称王佛　南无法轮盖云佛　南无觉智幢佛　南无智威德佛　南无法轮清净胜月佛　南无金山威德贤佛　南无贤胜山威德佛　南无普慧云声佛　南无法力胜山佛　南无香炎胜王佛　南无伽那迦摩尼山威德佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无而独步菩萨　南无威神胜菩萨　南无大部界菩萨　南无以山护菩萨　南无将三世菩萨　南无有功勋菩萨　南无宣名称菩萨　南无日光明菩萨　南无师子英菩萨　南无时节王菩萨　南无师子藏菩萨　南无示现有菩萨　南无光远照菩萨　南无山师子菩萨　南无有取施菩萨　南无莫能胜菩萨　南无为最幢菩萨　南无喜悦称菩萨　南无坚精进菩萨　南无无损减菩萨　南无有名称菩萨　南无无恐怖菩萨　南无无著天菩萨　南无火明灯菩萨　南无世光明菩萨　南无微妙音菩萨　南无执功勋菩萨　南无除闇瞑菩萨　南无无等轮菩萨　南无喜王菩萨　南无智慧照明藏菩萨　南无栴檀德藏菩萨　南无福德藏菩萨　南无无碍清净智德藏菩萨　南无那罗延德藏菩萨　南无普智光明慧灯菩萨　南无无量华照垂髻菩萨　南无无尽清净光明王菩萨　南无光照分别法界菩萨　南无无障碍力精进慧菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等。今以总相忏悔一切诸业。今当次第更复一一别相忏悔。若总若别若粗若细。若轻若重若说不说。品类相从愿皆消灭。别相忏悔者。先忏身三次忏口四。其余诸障次第稽颡。身三业者。第一杀害。如经所明恕己可为喻。勿杀勿行杖。虽复禽兽之殊。保命畏死其事是一。若寻此众生无始已来。或是我父母兄弟六亲眷属。以业因缘轮回六道。出生入死改形易报不复相识。而今兴害食啖其肉断大慈种。是故佛言。设得余食当如饥世食子肉想。何况食啖此鱼肉耶。又言为利杀众生。以钱纳众生肉。二俱是恶业死堕叫唤地狱。故知杀害及以食啖。罪深河海过重丘岳。然弟子等。从无始已来不遇善友皆为此业。是故经言。杀害之罪能令众生堕于地狱饿鬼受苦。若在畜生则受虎豿豺狼鹰鹞等身。或受毒蛇蝮蝎等身常怀恶心。或受獐鹿熊罴等身常怀恐怖。若生人中得二种果报。一者多病二者断命杀害食啖既有如是无量种种诸果报。是故弟子。今日至到稽颡至诚归依于佛

南无东方法华智佛　南无南方法最佛　南无西方维卫庄严佛　南无北方智自在称佛　南无东南方雨音自在法佛　南无西南方流布力王佛　南无西北方初发意佛　南无东北方名流十方佛　南无下方奉法佛　南无上方月英丰佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始已来至于今日。有此心识常怀碜毒无慈愍心。或因贪起杀。因嗔因痴及以慢杀。或兴恶方便誓杀愿杀及以咒杀。或破决湖池焚烧山野田猎捕鱼。或因风放火飞鹰放犬。恼害一切六道众生。如是等罪无量无边。今日至心归命忏悔

或以[打-丁+監]弶抗拨枚戟弓弩。弹射飞鸟走兽之类。或以罛网罾钓。捞漉水性鱼鳖鼋鼍虾蚬蠃蚌湿居之属。使水陆之与空行藏窜无地。或畜养鸡猪牛羊犬豕鹅鸭之属。自供庖厨或货他宰杀。使其哀声未尽毛羽脱落。鳞甲伤毁身首分离。骨肉销碎剥裂屠割。炮烧煮炙楚毒酸切。横加无辜但取一时之快。口得味甚寡。不过三寸舌根而已。然其罪报殃累永劫。如是等罪今日至诚归命忏悔。又复无始已来至于今日。或复兴师相伐。强场交诤两阵相向更相杀害。或自杀他教杀闻杀欢喜。或习屠鲙债为刑戮。烹宰他命行于不忍。或恣忿怒挥戈抚刃。或斩或刺或推着坑堑。或以水沉溺。或塞穴坏巢。土石磓岬。或以车马躙轹践蹋一切众生。如是等罪无量无边。今日发露归命忏悔

又复无始已来。或溉灌陆田。堕胎落子。破卵坏巢。毒药蛊道伤杀众生。垦土掘地种植田园。养蚕煮茧。养猫搦鼠伤杀滋甚。或打扑蚊虻螥蝇蜂蝎掏担蚤虱。或烧除粪扫。开决沟渠枉害一切。或啖果实或用谷米。或水或菜横杀众生。或然樵薪或露灯烛焚诸虫类。或食酱酢不看摇动。或泻汤水浇杀虫蚁。如是乃至行住坐卧四威仪中。恒常伤杀飞空着地细微众生。弟子。以凡夫识暗不觉不知。今日发露归命忏悔

又复弟子等。从无始已来至于今日。或以鞭杖枷锁桁械。压立拷掠打掷手脚蹴蹋。缠缚笼系断绝水谷。如是种种诸恶方便苦恼众生。今日至诚向十方佛尊法圣众。归命忏悔

愿弟子等。承是忏悔杀害等罪所生功德。愿生生世世得金刚身寿命无穷。永离怨憎无杀害想。于诸众生得一子地。若见危难急厄之者。不惜身命方便救解令得解脱。然后为说微妙正法使诸众生睹形见影皆蒙安乐。闻名听声恐怖悉除

    大乘莲华宝达问答报应沙门经

宝达顷前入一解身地狱。云何名曰解身地狱。其地狱纵广三十由旬。周匝铁城铁网覆上。中间猛火炎赫洞然。有铁[金*疾][金*離]遍布其地。复有飞锵来刺罪人。有大铁桁悬罪人身支节分解。尔时东门之中有无数罪人遥望见之悲啼号叫举体投地唱如是言。我今何罪来入此中。狱卒夜叉。手持大斧望头而斫。复以铁索来缠其身。猛火烧体飞锵乱刺。尔时罪人步步而倒至于桁下。狱卒夜叉揘挡罪人。以大铁锯节节分解。流血遍地苦痛万端。乃有羊形牛形驴马之形。虫鸟杂类诸畜生之形。来饮其血复啖其肉。因诸畜生等皆从罪人索其本命及以本肉。尔时罪人无言以答。诸畜生等皆[口*(一/巾)]啮之。痛苦楚毒不可堪忍罪人呻吼口眼血出悲声呜咽上彻于天。如是苦毒一日一夜受罪无量。千死千生万死万生。经千万劫无有出期。后若得出当堕畜生中。百亿千生为诸怨家之啖食。宝达菩萨问曰。此诸沙门作何业故今受此苦。罗刹答曰。此诸罪人。受佛禁戒不求无上正真妙法。但睹目前信邪倒见。骜诞憍纵心怀碜毒。而无慈悲杀害众生。节解佛种类故。以是因缘受如此罪。后得为人百生千生诸根不具。聋盲喑哑手脚不全。身多诸疮常流脓血。断诸命故当受短报。宝达闻之悲泣而去

佛名经卷第二十佛说佛名经卷第二十一

南无须弥藏一切法光轮佛　南无然法轮威德佛　南无山峰胜威德佛　南无普精进炬佛　南无宝妙胜王佛　南无日胜妙佛　南无法炬宝帐声佛　南无三昧海广顶冠光佛　南无法虚空无边光师子佛　南无相庄严幢月佛　南无光明山雷电云佛　南无法虚空无碍光佛　南无妙智敷身佛　南无世间因陀罗妙光明云佛　南无法三昧光佛　南无法善庄严藏佛　南无法然灯炎坚固声佛　南无三世相镜像威德佛　南无法轮峰光明佛　南无法界师子光明佛　南无卢舍那胜须弥山三昧坚固师子佛　南无普光明城灯佛　南无宝俱苏摩藏佛　南无转妙法声佛　南无虚空劫灯佛　南无法幢佛　南无安隐世间月佛　南无摩诃伽罗那师子佛　南无可乐声佛　南无安隐佛　南无增上信威德佛　南无医王佛　南无法虚空上胜王佛　南无天藏佛　南无地峰王佛　南无转法轮光明吼王佛　南无智虚空乐王佛　南无一切吼王佛　南无不可降伏佛　南无十力鸡兜佛　南无转法轮化普光明声佛　南无相胜山佛　南无具足坚聚佛　南无无垢婆嗟佛　南无住持疾行佛　南无遍相佛　南无无垢婆侯佛　南无师子步修佛　南无天自在顶佛　南无法起称佛　南无大无忧嗏佛　南无虚空灯佛　南无无垢幢佛　南无恒河沙同名贤行佛　南无恒河沙同名无边命佛　南无恒河沙同名不动佛　南无恒河沙同名月智佛　南无恒河沙同名金刚幢佛　南无恒河沙同名日藏佛　南无恒河沙同名善光佛　南无恒河沙同名金刚佛　南无五百同名大慈悲佛　南无普智炎功德幢王佛　南无善逝法幢胜佛　南无须弥佛　南无功德鬘佛　南无自在佛　南无寂王佛　南无无量爱佛　南无本称功德佛　南无须弥山佛　南无日月面佛

南无如是等无量无边诸佛

南无虚空行佛　南无普照佛　南无方城住佛　南无胜光佛　南无云胜佛　南无法炎山佛　南无波头摩生佛　南无法界华佛　南无海灯佛　南无寂灭佛　南无如是等无量无边佛

南无宝鸡兜王佛　南无智意佛　南无思议佛　南无因陀罗胜佛　南无大智佛　南无云王畏佛　南无智胜佛　南无光明王鸡兜佛　南无法界波头摩佛　南无行广见佛　南无胜奋迅威德去佛

南无如是等无量无边佛

南无宝炎山佛　南无胜光佛　南无宝功德佛　南无海胜佛　南无法光明佛　南无波头摩佛　南无藏胜佛　南无世间眼佛　南无如是等无量无边佛

南无香光佛　南无须弥胜佛　南无岳王佛　南无深胜佛　南无胜摩尼佛　南无藏王佛　南无胜威德畏佛　南无寂色去佛　南无如是等无量无边佛

南无广智佛　南无宝光明佛　南无虚空云胜佛　南无妙相佛　南无胜相佛　南无庄严佛　南无行轮佛　南无光胜佛　南无光明胜佛

南无如是等无量无边佛

南无那罗延行佛　南无须弥胜佛　南无功德轮佛　南无胜王佛　南无不可降伏佛　南无山王树佛　南无如是等无量无边佛　南无莎罗自在王佛　南无胜藏佛　南无世间自在身佛　南无镜像光明佛　南无地出佛　南无光明功德佛　南无金刚色佛　南无住持威德胜佛

南无如是等无量无边佛

南无深法光明身佛　南无法海吼声佛　南无弥留幢胜光明意佛　南无宝光明胜佛　南无梵光佛　南无虚空声佛　南无法界镜像胜佛　南无轮光明佛　南无智光高鸡兜意佛　南无伽伽那灯佛　南无乐胜照佛　南无功德光明胜佛　南无寂胜佛　南无大悲速疾佛　南无地力光明意佛　南无一切修面色佛　南无胜身光明佛　南无法胜宿佛　南无阿尼罗速行佛　南无清净幢盖胜佛　南无三世镜像佛　南无愿海乐说胜佛　南无惭愧须弥山胜佛　南无念鸡兜王胜佛　南无法意佛　南无慧灯佛　南无光明鸡兜胜佛　南无广智上佛　南无法界行智意佛　南无法海意智胜佛　南无法宝胜佛　南无功德轮佛　南无胜云佛　南无忍辱灯佛　南无胜威德意佛　南无速光明摩他声佛　南无寂幢佛　南无世间灯佛　南无大愿胜佛　南无不可降伏幢佛　南无智炎胜功德佛　南无法自在佛　南无无碍意佛　南无世间言语坚固吼光佛　南无一切声分吼胜精进自在佛　南无具足意佛　南无诸方天佛　南无现面世间佛　南无知众生心平等身佛　南无最胜佛　南无平等佛　南无行佛行佛　南无清净身佛　南无胜贤佛

南无如是等上首不可说不可说无量无边佛　南无彼诸佛所说妙法　南无彼佛妙法身　南无彼佛三十二相八十种好无量无边功德。南无彼诸佛种种道场。种种菩提树。种种形像。种种妙塔。去来坐卧妙处。归命彼诸佛不退法轮。菩萨大僧不退声闻僧比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽种种状貌。信如来法轮转如来法轮。不可思议菩萨摩诃萨悉皆归命。归命如来法身。十力四无所畏戒定慧品解脱解脱知见。如是等无量无边功德。如是功德回施一切众生。愿得阿耨多罗三藐三菩提。舍利弗。有善眼劫中有七十那由他佛出世。舍利弗。善见劫中有七十二亿佛出世

舍利弗。梵赞叹劫中有一万八千佛出世。舍利弗。名过去劫中有三十二千佛出世。舍利弗。庄严劫中有八万四千佛出世。舍利弗。汝等应当归命如是等无量无边佛

佛告舍利弗。善男子善女人欲灭一切罪。应当净洗浴着新净衣。称如是等佛名供养礼拜。应当作是言。我无始世界已来身口意业作不善行。乃至谤方等经五逆罪等。愿皆消灭

舍利弗。善男子善女人。欲满足六波罗蜜行。欲回向无上菩提。欲满足一切菩萨诸波罗蜜。应作是言。我学过去未来现在诸菩萨摩诃萨。修行大舍破胸出心施于众生。如智胜菩萨及迦尸王等。舍妻子等布施贫乏。如不退菩萨及阿翅罗那王。须达拏及庄严王等。入于地狱救苦众生。如大悲菩萨及善眼天子等。救恶行众生。如善行菩萨及胜行王等。舍顶上宝天冠并剥头皮而与如胜上身菩萨及宝髻天子等。舍眼布施。如爱作菩萨及月光王等。舍耳鼻布施。如无怨菩萨及胜去天子等。舍齿布施如华齿菩萨及六牙象王等。舍舌如不退菩萨及善面王等。舍手如常精进菩萨及坚意王等。舍血如法作菩萨及月思天子等。舍肉髓如安隐菩萨及一切施王等。舍大肠小肠肝肺脾肾。如善德菩萨及自远离诸恶王等。舍身一切大小支节。如法自在菩萨及光胜天子等。舍皮如清净藏菩萨及金色天子金色鹿王等。舍手足指如坚精进菩萨及金色王等。舍手足甲如不可尽菩萨及求善法天子等。为求法故入大火坑。如精进菩萨及求沙法王精进等。为求法故卖身刳身破骨出髓。如萨陀波仑菩萨及金坚王等。受一切苦恼如求妙法菩萨。及速行大王等。舍四天下大地及一切庄严。如得大势至菩萨。及胜功德天子等。舍身如摩诃萨埵菩萨。及摩诃婆罗王等。自身与一切贫穷苦恼众生。作给使侍者。如尸毗王等。举要言之。过去未来现在诸菩萨。一切波罗蜜行。愿我亦如是成就十方世界诸妙香华鬘诸妙妓乐。我随喜供养佛法僧。复回此福德施一切众生。愿因此福德。众生等莫堕恶道。因此福德。满足八万四千诸波罗蜜行。速得授阿耨多罗三藐三菩提记。速得不退转大地。速成无上菩提

舍利弗应当敬礼十方诸佛

南无不动佛　南无尽圣佛　南无日光佛　南无龙奋迅佛　南无自在光明称佛　南无十光佛　南无普宝佛　南无称自在佛　南无胜藏称佛　南无炎意佛　南无宝幢佛　南无智山佛　南无因光佛　南无生胜佛　南无弥留藏佛　南无智海佛　南无大精进佛　南无弥留功德佛　南无胜藏佛　南无智德佛　南无能与无畏佛　南无大精进趣王佛　南无智成就佛　南无无滞佛　南无地力住持精进佛　南无力命佛　南无善眼佛　南无不害法王佛　南无灭魔佛　南无不可思议精进佛　南无观功德佛　南无智频婆佛　南无阿僧伽力精进佛　南无心自在佛　南无枲荷难陀佛　南无戒光佛　南无坚上王佛　南无无边光王佛　南无无尽智藏佛　南无宝雨头佛　南无智波婆罗佛　南无毗尼称佛　南无无边功德王佛　南无法华婆师佛　南无光炎王佛　南无妙山王佛　南无转法轮胜王佛　南无无垢目佛　南无住持大般若佛　南无不住力精进王佛　南无自在识佛　南无现念佛　南无福德力精进佛　南无智袈裟王佛　南无智自在佛　南无安隐众生无障佛　南无智进佛　南无摩诃弥留力藏佛　南无虚空光明佛　南无阿伽楼功德精进佛　南无离痴功德声王佛　南无法施庄严佛　南无声自在王佛　南无护门佛　南无自在力精进王佛　南无宝光明胜王佛　南无胜一切须弥山王佛　南无罗多那弥留佛　南无不可得动法佛　南无陀罗尼自在王佛　南无普功德王佛　南无法莎罗王弥留佛　南无智集功德聚佛　南无智炎华树王佛　南无一切世间自在佛　南无善华王佛　南无金千遮那王佛　南无法幢奋迅王佛　南无栴檀波婆罗围绕佛　南无住法分称佛　南无坚意精进佛　南无照一切世间灯佛　南无随众生心奋迅佛　南无无边称莎罗幢佛　南无过去称法雨佛　南无功德炎华佛　南无智行佛　南无乐威德灯佛　南无离诸障无畏佛　南无智照声佛　南无二成就佛　南无集妙行佛　南无乐庄严王佛　南无阿僧祇庄严王佛　南无师子座善住佛　南无放栴檀华王佛　南无甘露味佛　南无龙胜佛　南无胜力佛　南无师子音佛

舍利弗。我于此坐以清净无障碍过人天眼。见东方多百佛多千佛多百千佛。多百千万佛多百千亿佛。多百千万亿那由他佛。无量阿僧祇佛。不可思议佛不可量佛。种种名种种姓种种世界。种种佛国土。种种比丘比丘尼优婆塞优婆夷围绕。种种天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等围绕供养。我悉现见如观掌中庵摩勒果。舍利弗。若有善男子善女人比丘比丘尼优婆塞优婆夷。信我语受持读诵是诸佛名。当洗浴着新净衣。于昼日初分时中分时后分时。夜前分时中分时后分时。从座而起偏袒右肩右膝着地。一心称是佛名。供养礼拜作如是言。如来所知十方诸佛我今敬礼

舍利弗。是善男子善女人。比丘比丘尼优婆塞优婆夷。如是供养礼拜得无量福德。舍利弗。若欲得声闻地。欲得辟支佛地。欲得阿耨多罗三藐三菩提者。当礼十方诸佛一切皆得。复作是言。是诸福德聚诸佛如来所知。我悉回向阿耨多罗三藐三菩提

舍利弗。应当归命东方一切诸佛

南无法自在奋迅佛　南无修行坚固自在佛　南无师子奋迅王佛　南无力士自在王佛　南无法山胜佛　南无宝山佛　南无自在陀罗尼佛　南无树提藏佛　南无星宿称佛　南无功德力坚固王佛　南无人声自在增长佛　南无胜一切世间佛　南无三世法界佛　南无妙声吼佛　南无宝地龙王佛　南无法疾吼声佛　南无香波头摩择自在宝城佛　南无光轮佛　南无宝连佛　南无功德华佛　南无多供养佛　南无无边功德王佛　南无增长喜佛　南无师子龙奋迅佛　南无娑罗藏师子步行佛　南无观诸法佛　南无法华智佛　南无时法清净佛　南无坚固精进言语佛　南无声精进佛　南无炎摩尼佛　南无山光明佛　南无清净无垢藏佛　南无无垢月佛　南无清净根佛　南无多智佛　南无能作智佛　南无广智佛　南无力意佛　南无胜意佛　南无坚固欢喜佛　南无坚固行自在佛　南无等须弥面佛　南无观成就佛　南无清净藏佛　南无象自在佛　南无现魔业净业佛　南无智慧自在佛　南无智慧精进奋迅佛　南无无碍精进佛　南无世间自在佛　南无法行广意佛　南无福德成就佛　南无不怯弱成就佛　南无胜成就佛　南无龙观佛　南无须弥栴檀佛　南无作戒王佛　南无聚集宝佛　南无龙王声佛　南无大智精进佛　南无孤独精进佛　南无不减庄严佛　南无不动尼他佛　南无百功德庄严佛　南无自在诸相好称佛　南无自在因陀罗月佛　南无法华山佛　南无法界庄严佛　南无满足愿佛　南无大师子庄严佛　南无师子平等精进佛　南无修行自在坚固佛　南无乐法修行　南无胜慧佛　南无海步佛　南无大如修行佛　南无高光明佛　南无无诤智佛　南无师子声佛　南无善报佛　南无善住佛　南无日光佛　南无甘露增上佛　南无道上首佛　南无胜自在亲佛　南无善见佛　南无无浊义佛　南无胜意佛　南无人月佛　南无威德光佛　南无普明佛　南无大庄严佛　南无师子奋迅去佛　南无摩楼多爱佛　南无寂心佛　南无大步佛　南无可闻声佛　南无积功德佛　南无摩尼向佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无大乐说菩萨　南无宝檀花菩萨　南无上行菩萨　南无无边行菩萨　南无安立行菩萨　南无净行菩萨　南无宿王华菩萨　南无喜见菩萨　南无妙音菩萨　南无得勤精进菩萨　南无净藏菩萨　南无净眼菩萨　南无妙德菩萨　南无慈氏菩萨　南无善思议菩萨　南无空无菩萨　南无神通华菩萨　南无光英菩萨　南无寂根菩萨　南无愿慧菩萨　南无中住菩萨　南无制行菩萨　南无定自在王菩萨　南无法相菩萨　南无光相菩萨　南无光严菩萨　南无大严菩萨　南无常惨菩萨　南无喜相菩萨　南无喜王菩萨　南无辩意菩萨　南无摄炬菩萨　南无宝勇菩萨　南无宝见菩萨　南无谛网菩萨　南无明网菩萨　南无无缘观菩萨　南无慧积菩萨　南无宝胜菩萨　南无天王菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等次忏劫盗之业。经中说言。若物属他他所守护。于此物中一草一叶不与不取。何况盗窃。但自众生唯见现在利故。以种种不道而取。致使未来受此殃累。是故经言。劫盗之罪能令众生堕于地狱饿鬼受苦。若在畜生则受牛马驴骡骆驼等形。以其所有身力血肉偿他宿债。若生人中为他奴婢。衣不蔽形食不充命。贫寒困苦人理殆尽。劫盗既有如是苦报。是故弟子。今日至到稽首归依佛

南无东方多智佛　南无南方大集佛　南无西方净智佛　南无北方智称佛　南无东南方持戒王佛　南无西南方增益善法佛　南无西北方善放香佛　南无东北方虚空净王佛　南无下方师子佛　南无上方逆空光明佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始已来至于今日。或盗他财宝兴刃强夺。或自怙恃身逼迫而取。或恃公威或假势力。高桁大械枉压良善。吞纳奸货拷直为曲。为此因缘身罗宪网。或任邪治颁他财物。侵公益私侵私益公。损彼利此利彼损此。割他自饶口与心吝。或窃没租估偷度关税。匿公课输藏隐使没如是等罪无量无边。今日惭愧归命忏悔

或是佛法僧物不与而取。或经像物或治塔寺物。或供养常住僧物或拟招提僧物。或盗取误用恃势不还。或自借货人。或复换贷漏妄。或三宝物混乱杂用。或以众僧物谷米樵薪姜豉酱酢。菜茹果实钱帛竹木。缯彩幡盖香华油烛随情逐意。或许施三宝物诳欺不与。或自用或与人。或摘佛华果用僧鬘物。因三宝财私自利已。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等。从无始已来至于今日。或作周旋朋友师僧同学。父母兄弟六亲眷属。共住同止百一所。须更相欺诳。或于乡邻比近移篱拓墙。侵夺地宅改檦易相虏掠田园。因公托私夺他邸店及以毛野。如是等罪无量无边。今日发露归命忏悔

又复弟子等。从无始已来至于今日。或攻城破邑烧村坏栅。偷卖良民诱他奴婢。或复柱压无罪之人。使其形[止*且]血刃身被徒锁。家业破散骨肉生离。分张异城生死隔绝。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等。从无始已来至于今日。或商侣博货邸店市易。轻秤小斗减割尺寸盗窃分铢欺罔圭合。以粗易好以短换长。巧欺百端希望毫利。如是等罪无量无边。今日惭愧归命忏悔

又复弟子等。从无始已来至于今日。穿踰墙壁断道抄掠。抵捍债息负债违要而欺心口。或非道陵夺鬼神禽兽四生之物。或假托卜相取人财宝。如是乃至以利求利恶求多求无厌无足。如是等罪无量无边不可说尽。今日至到向十方佛尊法圣众前归命忏悔。愿弟子等。承是忏悔劫盗等罪所生功德。愿生生世世得如意宝。常雨七珍上妙衣服。百味甘露种种汤药。随意所须应命则至。一切众生无偷夺相。一切皆能少欲知足不耽不染。常乐惠施行急济道头目髓脑如弃涕涶。回向满足檀波罗蜜

    大乘莲华宝达问答报应沙门经

宝达顷前更入咩声叫唤地狱。其地狱中猛火炽盛烟焰俱发。罪人入中受苦万端。西门之中有诸沙门来。入其中呻号动地。马头罗刹手捉铁捧望头而椎。罪人叫唤咩声而走。狱卒夜叉竞共打之。走藏无地走向东门则闭。南西北门亦复如是。一日一夜受罪苦痛。求生不得求死不得

宝达。问马头罗刹曰。此诸沙门。作何等罪受如是报。马头罗刹答曰。此诸沙门。受佛净戒心无慈念。打捧畜生乃无慈心。以此因缘受如是罪

宝达闻之悲泣而去

佛名经卷第二十一佛说佛名经卷第二十二

佛告舍利弗应当归命南方无量佛

南无爱照佛　南无名称佛　南无信功德佛　南无清净智佛　南无宝功德佛　南无妙信香佛　南无胜园佛　南无胜仙佛　南无宝智佛　南无甘露威德佛　南无信藏佛　南无月上胜佛　南无龙步佛　南无信黠慧佛　南无爱实语佛　南无忧波罗香佛　南无栴檀自在佛　南无敌胜佛　南无普行佛　南无功德胜佛　南无大威德佛　南无种种色日佛　南无过诸过佛　南无无量眼佛　南无惭愧智佛　南无功德供养佛　南无种种声佛　南无功德可乐佛　南无住清净佛　南无妙香佛　南无月光佛　南无戒分佛　南无华智佛　南无优多摩意佛　南无不闇意佛　南无山自在积佛　南无寂王佛　南无解脱王佛　南无阿蹉弥留王佛　南无如意力释去佛　南无姓阿提遮佛　南无不赞叹世间胜佛　南无法染佛　南无宝星宿解脱王佛　南无白宝胜佛　南无法行自在佛　南无陀罗尼自在佛　南无阿难陀声佛　南无智步王佛　南无弥留平等奋迅王佛　南无智奋迅佛　南无法华通树提佛　南无多波尼体佛　南无阿尼伽陀路摩胜佛　南无优多罗胜法佛　南无大智念缚佛　南无阇伽提自在一切世间担佛　南无见无畏佛　南无自在作佛　南无自在量佛　南无如法修行佛

佛告舍利弗。我见南方如是等无量佛种种姓种种名种种佛国土汝等应当至心一心归命

佛告舍利弗。汝等应当归命西方无量佛

南无阿婆罗炎婆师花佛　南无摩[少/兔]沙口声去佛　南无智胜增长称佛　南无莎漫多波尸佛　南无次罗毗罗炎花光佛　南无法行然灯佛　南无无等胜佛　南无智奋迅名称王佛　南无梵奋迅妙鼓声佛　南无波头摩尸利藏眼佛　南无阿僧伽意炎佛　南无千月光明藏佛　南无乐法行佛　南无摩尼婆陀光佛　南无师子广眼佛　南无十力生胜佛　南无智作佛　南无无边精进降伏一切诸怨佛　南无大胜起法佛　南无阿无荷见佛　南无无边命佛　南无观法智佛　南无无碍精进日善思惟奋迅王佛　南无不利他意佛　南无无边见佛　南无智见法佛　南无一切善根种子佛　南无优多智胜发行功德佛　南无智香胜佛　南无智上尸弃王佛　南无福德胜智去佛　南无不可思议法花吼王佛　南无法清净胜佛　南无不可思议弥留胜佛　南无能开法门佛　南无毗卢遮那法海香王佛　南无力王善住法王佛　南无胜力散一切恶王佛　南无见无边乐佛　南无善化功德炎华王佛　南无见彼岸佛　南无善化庄严佛　南无见乐处佛　南无尼拘律王胜佛　南无妙胜佛　南无大力智慧奋迅王佛　南无法树提佛　南无坚固盖成就佛　南无一切种智资生胜佛　南无入胜智自在山佛　南无一切世间得自在有桥梁胜佛　南无尽合胜佛　南无清净戒功德王佛　南无波头摩散漫智多庄严佛　南无一王佛　南无大多人安隐佛　南无二胜声功德佛　南无圆坚佛　南无力士佛　南无宝珠摩尼火佛　南无大海弥留佛　南无胜王佛　南无不住佛　南无不空功德佛　南无初远离不浊王佛　南无虚空行佛　南无无碍称佛　南无声山佛　南无不可思议起三昧称佛　南无诸天梵王鸡兜佛　南无示无义王佛　南无护垢王佛　南无照功德佛　南无自在眼佛　南无智寂成就性佛　南无无障碍智成就佛　南无说决定义佛　南无庄严法灯妙称佛　南无二宝法灯佛　南无大炎藏佛　南无自师子上身庄严佛　南无智宝因缘庄严佛　南无服诸根清净眼佛　南无善香随香波头摩佛　南无法月佛　南无广大心佛　南无戒功德佛　南无常镜佛　南无随顺称佛　南无法自在佛　南无如意庄严佛　南无金藏佛　南无慎贪佛　南无思妙义坚固愿佛　南无一切德轮光佛　南无法吼智明佛　南无甘露光佛　南无无边庄严佛　南无胜福田佛　南无善决定诸法庄严佛

佛告舍利弗。西方如是等无量无边诸佛汝等应当至心归命

佛告舍利弗。汝等应当至心归命北方佛

南无胜藏佛　南无自在藏佛　南无无边花龙一俱苏摩王佛　南无降伏诸魔勇猛佛　南无定诸魔佛　南无法像佛　南无功德胜佛　南无山峰光佛　南无法王佛　南无普恭敬灯佛　南无地胜佛　南无成就如来家佛　南无一切宝成就家佛　南无陀罗尼文句决定义佛　南无忍自在王佛　南无成就一切称佛　南无三世智转自在佛　南无胜归依功德善住佛　南无种种摩尼光佛　南无胜功德佛　南无佛功德胜佛　南无无余证佛　南无得佛眼佛　南无随过去佛佛　南无大慈成就悲胜佛　南无住持师子智佛　南无无众生住实际王佛　南无自家法不得成就佛　南无大智庄严身佛　南无智称佛　南无佛法首佛　南无一切众生德佛　南无过一切法门佛　南无自在因陀罗佛　南无满足意佛　南无大琉璃佛　南无菩提光明佛　南无不可思议法智光明佛　南无栴檀不空王佛　南无不染波头摩幢佛　南无法财声王佛　南无择法善知称佛　南无智鬘劫佛　南无佛眼清净分陀利佛　南无智自在称佛　南无断无边疑佛　南无众生方便自在王佛　南无无边觉奋迅无碍思惟佛　南无法行地善住佛　南无普众生界广佛　南无降伏诸魔力坚意佛　南无天王自在宝合王佛　南无如实修行藏佛　南无能生一切欢喜月见佛　南无大迅觉迅佛　南无种种摩尼声王吼佛　南无无观王佛　南无不退了勇猛佛　南无佛国土庄严身佛　南无法声自在佛　南无智根本花幢佛　南无化身无碍称佛　南无一切龙摩尼藏佛　南无法声自在佛　南无法声知见佛　南无法甘露莎梨罗佛　南无无边宝福德藏佛　南无清净华行佛　南无大法王华胜佛　南无一切尽无尽藏佛　南无华山藏佛　南无智虚空山佛　南无智力不可破坏佛　南无无碍坚固随顺智佛　南无无边大海藏佛　南无智王无尽称佛　南无奋迅心意王佛　南无自性清净智佛　南无智自在法王佛　南无胜行佛　南无金刚见佛　南无法满足随香见佛　南无龙月佛　南无因陀罗围佛　南无无碍王佛　南无宝因陀罗轮王佛　南无能生一切众生敬称佛　南无大威德光明轮王佛　南无能断一切众生疑佛　南无智宝法见佛　南无无障碍波罗佛　南无无垢髻佛　南无放光明佛　南无山力月藏佛　南无心自在王佛　南无坚固无畏上首佛　南无坚固勇猛宝佛　南无坚固心善住王佛　南无能破闇曀王佛　南无胜丈夫芬陀利佛　南无百圣藏佛　南无妙莲华藏佛　南无见平等法身佛　南无众生月佛　南无师子去佛　南无大威德佛　南无妙声佛　南无无边光佛　南无见爱佛　南无大首佛　南无胜首佛　南无乐声佛　南无见实佛　南无清净称佛　南无师子慧佛　南无德声佛　南无修楼毗香佛　南无电灯佛　南无波头摩光佛　南无大光佛　南无梵声佛　南无无疑佛　南无无边势力佛　南无月面佛　南无无边光佛　南无爱威德佛　南无散疑佛　南无功德灯佛　南无不藏威德佛　南无无边藏佛　南无光明奋迅王佛　南无广称佛　南无远离幢佛　南无增长圣佛　南无普见佛　南无不可胜佛　南无威德聚佛　南无坚固步佛　南无摩[少/兔]赊称佛　南无无边色佛　南无大光明佛　南无妙声佛　南无不动步佛　南无无边庄严佛　南无大清净佛　南无威德聚光明佛　南无住智佛　南无金坚佛　南无爱解脱佛　南无爱无畏佛　南无甘露藏佛　南无普观察佛　南无大修行佛　南无细威德佛　南无十方恭敬佛　南无重说佛　南无光明胜佛　南无光明庄严佛　南无师子奋迅佛　南无善见佛　南无甘露步佛　南无月光明佛　南无功德称佛　南无去根佛　南无清净声佛　南无无障碍轮佛　南无甘露声佛　南无众生可敬佛　南无如意威德佛　南无无边色佛　南无大力佛　南无快庄严佛　南无普照观佛　南无奋迅德佛　南无妙色佛　南无称意佛　南无宝庄严佛　南无高光明佛　南无解脱步佛　南无功德庄严佛　南无毕竟智佛　南无生鸡兜佛　南无不动智佛　南无行意佛　南无妙色佛　南无实色佛　南无大声佛　南无善思惟佛　南无功德华佛　南无思惟世间佛　南无大高光明佛　南无无譬喻奋迅佛　南无清净觉佛　南无月重佛　南无月灯佛　南无无边光佛　南无种种日佛　南无天城佛　南无心清净佛　南无波头摩藏佛　南无常择智佛　南无师子声佛　南无无边光佛　南无胜声佛　南无可乐意智光佛　南无功德光佛　南无自在光佛　南无净严身佛　南无无浊义佛　南无应威德佛　南无成就义智佛　南无得大声佛　南无婆薮陀声佛　南无郁哆光佛　南无决定思惟佛　南无萨遮婆[少/(兔-、)]佛　南无呜闇光明佛　南无毗弗波威德佛　南无忧多罗魔吒佛　南无夜舍鸡兜佛　南无功德清净佛　南无法灯佛　南无胜功德佛　南无仙荷波提爱面佛　南无心荷步去佛　南无思惟众生佛　南无莎伽罗智佛　南无波头摩藏佛　南无盖仙佛　南无莎罗王佛　南无修利耶光佛　南无菩提味佛　南无寂诸根佛　南无波[少/兔]光佛　南无芬陀利光佛　南无弥留光佛　南无栴陀面佛　南无莎利荼去佛　南无诸方眼佛　南无法光明佛　南无尸罗波散那佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无功德相严菩萨　南无梵网菩萨　南无宝财菩萨　南无无缘菩萨　南无严土菩萨　南无光严童子菩萨　南无持世菩萨　南无善德菩萨　南无难胜菩萨　南无照明菩萨　南无萨陀波沦菩萨　南无昙无竭菩萨　南无法自在菩萨　南无德守菩萨　南无不眴菩萨　南无德顶菩萨　南无善宿菩萨　南无妙臂菩萨　南无弗沙菩萨　南无净解菩萨　南无善意菩萨　南无现见菩萨　南无普守菩萨　南无喜见菩萨　南无明相菩萨　南无深慧菩萨　南无无碍菩萨　南无上善菩萨　南无福田菩萨　南无德藏菩萨　南无月上菩萨　南无珠顶王菩萨　南无乐实菩萨　南无慧见菩萨　南无登王菩萨　南无深王菩萨　南无华王菩萨　南无妙色菩萨　南无善明菩萨　南无善答菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等至心忏悔贪欲之罪。经中说言。但为贪欲闭在痴狱。没生死河莫之能出。众生为是五欲因缘。从昔已来流转生死。一一众生一劫之中。所积身骨如王舍城毗富罗山。所饮母乳如四海水。身所出血复过于此。父母兄弟六亲眷属。命终哭泣所出目泪如四海冰。是故说言。有爱则生爱尽则灭。故知生死贪爱为本。所以经言。淫欲之罪。能令众生堕于地狱饿鬼受苦。若在畜生则受鸰雀鸳鸯等身。若生人中妻不贞良。得不随意眷属。淫欲既有如此恶业。是故弟子。今日至心稽颡归依佛

南无东方光轮佛　南无南方开光明佛　南无西方习智佛　南无北方大琉璃佛　南无东南方乐莲花首佛　南无西南方智慧和合佛　南无西北方无上胜尊佛　南无东北方眼净无垢佛　南无下方具足光明佛　南无上方最清净无量幢佛

归命如是等十方尽虚空界一切三宝

弟子等自从无始已来至于今日。或通人妻妾夺他妇女。侵陵贞洁污比丘尼。破他梵行逼迫不道。浊心邪视言语嘲[口*調]。或复耻他门户污贤善名。或于男子五种人所起不净行。如是等罪无量无边。今日至诚归命忏悔。弟子等从无始已来至于今日。或受女身。心如野马。恒日放荡。无一时定。常怀邪心。恒生欲想。或于伽蓝会所。无心听法眼常贪视。或爱欲沙门坏他男子。不诞佛法恣放淫情。致令心飘大海冥然失岸。或秽污僧三衣法服。或于精舍院宇。行不净行。共相探摸。如是等罪无量无边。今日惭愧至心忏悔

又复弟子等从无始已来至于今日。或作女身恒怀淫欲。或侵夺他夫婿迷惑诸丈夫。或作符书厌蛊遣他妇患。人生少福为邪所著。诸病鬼等因此得便。不遇良医遂致身死。如是等罪无量无边。今日惭愧发露悔过。至诚稽颡归命忏悔

又复弟子等从无始已来至于今日。或眼为色。或爱染玄黄红绿。朱紫珍玩宝饰。或取男女长短黑白姿态之相起非法想。或耳贪好声宫商弦管妓乐歌唱。或取男女音声言语啼笑之相起非法想。或鼻籍名香蕴麝幽兰郁金苏合起非法想。或舌贪好味鲜羔甘肥。众生肉血资养四大。更增苦本起非法想。或身乐华绮锦绣缯縠。一切细滑七珍丽服。起非法想。或意多乱想触向乖法。有此六想造罪尤甚。如是等罪无量无边。今日至诚向十方佛尊法圣众前归命忏悔

愿弟子等承是忏悔淫欲等罪所生功德。愿生生世世自然化生不由胞胎。清净皎洁相好光丽。六情开朗聪利分明了达恩爱犹如桎梏。观此六尘如幻如化。于五欲境决定厌离。乃至梦中不起邪想。内外因缘永不能动。愿以忏悔眼根功德。愿令此眼彻见十方。诸佛菩萨清净法身不以二相。愿以忏悔耳根功德。愿令此耳常闻十方诸佛贤圣。所说正法如教奉行。愿以忏悔鼻根功德。愿令此鼻常闻香[示*責]入法位香。舍离生死不净臭秽。愿以忏悔舌根功德。愿令此舌常餐法喜禅悦之食。不贪众生血肉之味。愿以忏悔身根功德。愿令此身被如来衣着忍辱铠。卧无畏床坐四禅座。愿以忏悔意根功德。愿令此意成就十想洞达五明。深观二谛空平等理。从方便慧起十妙行。入法流水念念增明。显发如来大无生法忍

    大乘莲华宝达问答报应沙门经

宝达顷前入一钩阴地狱。云何名曰钩阴地狱。其地狱纵广三十由旬。其中火流灌注遍布于地。其地四壁如上无异。中间无数罪人。狱卒夜叉手捉铁钩望罪人阴而搭。钩中火然上入胸心。心上火然腹背俱彻。欲报业故化作妇人。如本生时先所见者。彼即见已欲火发起便走趣。彼妇女者身是金刚铁火炎热。既到彼已抱彼罪人。抱即破碎复就其口。遂食其唇身亦被食。尽已复生生已复食。彼诸女人爱欲男子亦复如是。欲心不定欲火常然。如是苦切楚痛难堪。当此之时罪人众等犹无悔过。一日一夜受罪无量。千死千生万死万生。经无量百千万劫尔乃得脱。以余业果生畜生中作不净虫。经二百千世后得生人中。于五百世胎中而死。复五百世世已。雌雄不辩眼目不正。贫穷孤露受命短促。或时有妇被他侵近。或自贪爱他人妇女。不能遮障恒绝继嗣

宝达问马头罗刹曰。此诸沙门。作何等行受罪如是。马头罗刹答曰。此诸沙门。受佛净戒不能净持故。行淫欲放纵六情。以是因缘得如是罪

宝达闻之悲泣而去

佛名经卷第二十二佛说佛名经卷第二十三

南无阿难陀智佛　南无阿难陀色佛　南无地荼毗梨耶佛　南无提婆弥多佛　南无莎漫多智佛　南无寂静光佛　南无摩[少/兔]舍威德佛　南无善分菩提他佛　南无称圣佛　南无称幢佛　南无轮面佛　南无普清净佛　南无摩诃提阇佛　南无阿罗诃应佛　南无忧多那胜佛　南无悉达他思惟佛　南无爱供养佛　南无三漫多护佛　南无尼弥佛　南无信菩提佛　南无破意佛　南无出智佛　南无胜声佛　南无质多罗婆[少/兔]佛　南无弥荷声佛　南无大炎骞陀佛　南无胜拘吒佛　南无阿舒加爱佛　南无天国土佛　南无师子难提拘沙佛　南无阿难陀波颇佛　南无见爱佛　南无波提波王佛　南无胜鸡兜佛　南无方闻声佛　南无爱眼佛　南无栴陀鸡兜佛　南无阿婆夜达多佛　南无那刹多王佛　南无苏摩提婆佛　南无日光明佛　南无大称佛　南无真声佛　南无说爱佛　南无称忧多罗佛　南无摩头罗光明佛　南无修佉声佛　南无质多意佛　南无婆薮陀清净佛　南无寂嗔佛　南无破意佛　南无宿王佛　南无毗伽陀畏佛　南无胜忧多摩佛　南无婆萨那智佛　南无慈胜种种光佛　南无普见佛　南无见月佛　南无降伏诸魔威德佛　南无摩诃罗他佛　南无心荷步去佛　南无乐光佛　南无普护佛　南无清净意佛　南无成就义佛　南无香山佛　南无摩尼清净佛　南无功德光佛　南无日光佛　南无成就光佛　南无见爱佛　南无善思惟佛　南无莎漫多见佛　南无师子幢佛　南无普行佛　南无大步佛　南无阿罗频头波头摩眼佛　南无日光佛　南无阿弥多清净佛　南无阿难多楼波佛　南无盖天佛　南无罗多那光佛　南无莎罗梯罗多佛　南无善见佛　南无亲味佛　南无婆耆罗莎佛　南无修利邪那那佛　南无无障碍眼佛　南无莎荷去佛　南无大然灯佛　南无卢荷伽佛　南无清净功德佛　南无功德藏佛　南无法明佛　南无摩楼多爱佛　南无阿婆邪爱佛　南无慧幢佛　南无威德光佛　南无月德佛　南无求那婆薮佛　南无无边光佛　南无安乐佛　南无称鸡兜佛　南无光明吼佛　南无普功德佛　南无胜鸡兜佛　南无那罗延佛　南无宝清净佛　南无普心佛　南无善心意佛　南无善意佛　南无不可量威德佛　南无师子臂佛　南无光明意佛　南无那罗延天佛　南无萨遮鸡兜佛　南无善住意佛　南无阿弥多天佛　南无大慧德佛　南无大幢佛　南无光明日佛　南无法水佛　南无善法佛　南无旃陀婆[少/兔]佛　南无庵摩罗胜佛　南无解脱观佛　南无罗多那光佛　南无无罗声佛　南无普心择佛　南无成就光佛　南无甘露眼佛　南无称爱佛　南无善护佛　南无天信佛　南无善量步佛　南无提婆罗多佛　南无深智佛　南无斯那步佛　南无旃陀跋陀佛　南无提阇积佛　南无大胜佛　南无大步佛　南无阇邪天佛　南无悉达他意佛　南无质多爱佛　南无师子声佛　南无信提舍那佛　南无智光佛　南无拘苏摩提阇佛　南无提阇罗尸佛　南无如意光佛　南无无边威德佛　南无无边光佛　南无胜藏佛　南无卢遮那称佛　南无实鸡兜佛　南无郁伽提阇佛　南无日鸡兜佛　南无摩诃弥留佛　南无摩诃馥荷佛　南无世间得名佛　南无郁伽德佛　南无优多摩称佛　南无成就义步佛　南无提婆摩醯多佛　南无爱实行佛　南无阿那毗浮多称佛　南无金光佛　南无大然灯佛　南无行意佛　南无毗迦摩佛　南无无碍光佛　南无毗摩提阇诃佛　南无摩诃跋多佛　南无天声佛　南无不着步佛　南无天道佛　南无訽陀罗难陀佛　南无华光佛　南无能现佛　南无天爱佛　南无解脱光佛　南无普光佛　南无求那迦罗佛　南无智说佛　南无菩提光佛　南无莎伽罗佛　南无菩提难提佛　南无摩诃提婆佛　南无深智佛　南无法自在佛　南无大波那那佛　南无心意佛　南无智光明佛　南无不错思惟佛　南无胜功德佛　南无坐称佛　南无大庄严佛　南无月光佛　南无天光佛　南无清净行佛　南无爱功德佛　南无师子意佛　南无信婆薮那罗佛　南无宝光明佛　南无快光明佛　南无种种婆[少/兔]佛　南无月爱佛　南无苏摩刹多佛　南无普观佛　南无不染佛　南无称光胜佛　南无月面佛　南无伽那天佛　南无功德聚佛　南无功德智佛　南无华胜佛　南无爱世间佛　南无甘露光佛　南无地光佛　南无作功德佛　南无华胜佛　南无求那婆睺佛　南无法然灯佛　南无普光佛　南无净声佛　南无大庄严佛　南无解脱日佛　南无坚精进佛　南无智光明佛　南无功德称佛　南无善智佛　南无不可量庄严佛　南无师子陀那佛　南无功德奋迅佛　南无妙天佛　南无观行佛　南无天提吒佛　南无电光明佛　南无胜爱佛　南无山幢佛　南无华光佛　南无胜意佛　南无山香佛　南无福德奋迅佛　南无胜慧佛　南无信圣佛　南无宝洲佛　南无妙威德佛　南无最后见佛　南无爱行佛　南无妙庄严佛　南无功德藏胜佛　南无清净见佛　南无威德力佛　南无清净眼佛　南无智行佛　南无不谬步佛　南无圣眼佛　南无乐解脱佛　南无大声佛　南无胜土佛　南无成就光明佛　南无自业佛　南无照称光明佛　南无光明行佛　南无爱自在佛　南无月贤佛　南无胜吼佛　南无胜功德佛　南无撰择摄取佛　南无相王佛　南无离热佛　南无圣德佛　南无法高佛　南无甘露功德佛　南无无碍称佛　南无甘露香佛　南无舍光明佛　南无吼声佛　南无无畏日佛　南无得无畏佛　南无爱黠慧佛　南无智慧不谬佛　南无虚空光佛　南无增上天佛　南无信如意佛　南无天盖佛　南无龙光佛　南无妙步佛　南无法威德佛　南无断诸有佛　南无庄严面佛　南无妙色佛　南无普眼佛　南无功德光佛　南无胜月佛　南无平等德佛　南无云何鸡兜佛　南无众生自在劫佛　南无与无畏亲佛　南无摄取众生意佛　南无降伏诸怨佛　南无摄取光明佛　南无胜山佛　南无一胜光明佛　南无那罗延步佛　南无师子步佛　南无爱戒佛　南无清净佛　南无信名称佛　南无毕竟智佛　南无离痴佛　南无功德聚佛　南无能思惟思佛　南无法盖佛　南无不动因佛　南无天华佛　南无波头摩佛　南无普威德佛　南无月光佛　南无大众上首佛　南无思惟义佛　南无相王佛　南无华面佛　南无思惟名称佛　南无树幢佛　南无师子奋迅佛　南无信大众佛　南无善香佛　南无智慧赞叹佛　南无功德梁佛　南无智光明佛　南无智海佛　南无威德力佛　南无胜威德佛　南无佛欢喜佛　南无胜清净佛　南无爱一切佛　南无远离诸疑佛　南无善思惟胜义佛　南无大山佛　南无降伏圣信佛　南无降伏黠慧佛　南无趣菩提佛　南无妙声佛　南无大势力佛　南无乐师子佛　南无普宝满足佛　南无一切世间爱佛　南无金刚轮佛　南无过火佛　南无大将佛　南无众生月佛　南无大庄严佛　南无日光明佛　南无胜严佛　南无断诸有意香佛　南无寂静行佛　南无摄受称佛　南无梵天供养佛　南无大吼佛　南无无量无边愿佛　南无世间光明佛　南无可见忍佛　南无大华佛　南无修行身佛　南无诸根清净佛　南无婆薮达多佛　南无不怯弱声佛　南无普见佛　南无月贤佛　南无决定色佛　南无方便修佛　南无信胜功德佛　南无胜报佛　南无贤庄严佛　南无惭愧贤佛　南无勘受器声佛　南无胜爱佛　南无普行佛　南无普智佛　南无大威力佛　南无月鸡兜佛　南无坚固行佛　南无天供养佛　南无普敬佛　南无胜妙称佛　南无成就一切功德佛　南无坚固莎梨罗佛　南无甘露光佛　南无大贵佛　南无胜声佛　南无大力佛　南无大步佛　南无信甘露佛　南无道步佛　南无胜声心佛　南无胜意佛　南无婆楼那步佛

次礼十二部经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无了相菩萨　南无定相菩萨　南无定[示*責]菩萨　南无发喜菩萨　南无安位菩萨　南无怖魔菩萨　南无慧施菩萨　南无慧灯菩萨　南无智导菩萨　南无愿慧菩萨　南无四摄菩萨　南无教音菩萨　南无法喜菩萨　南无道品菩萨　南无大自在菩萨　南无檀林菩萨　南无妙严菩萨　南无妙色形菩萨　南无奢提菩萨　南无蜜疏菩萨　南无华睒菩萨　南无上首菩萨　南无普现色身菩萨　南无神通菩萨　南无海德菩萨　南无无边身菩萨　南无医王自在菩萨　南无迦叶菩萨　南无无垢藏王菩萨　南无持一切菩萨　南无高贵德王菩萨　南无琉璃光菩萨　南无无畏菩萨　南无海王菩萨　南无光严菩萨　南无光明菩萨　南无大辩菩萨　南无慈力菩萨　南无依王菩萨　南无依力菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等以共相忏悔身三业竟。今当次第忏悔口四恶业。经中说言。口业之罪能令众生堕于地狱饿鬼受苦。若在畜生则受鸺鹠枭鹫鸟形。闻其声者无不憎恶。若生人中口气常臭。所有言说人不信受。眷属不和常好斗诤。口业既有如是恶果。是故弟子。今日至诚归依佛

南无东方星宿称佛　南无南方月灯光佛　南无西方无边见佛　南无北方无观王佛　南无东南方大香王佛　南无西南方无为思惟佛　南无西北方乐清净佛　南无东北方胜战斗佛　南无下方除诸痴冥佛　南无上方好谛住唯王佛

归命如是等。十方尽虚空界一切三宝。弟子等自从无始已来至于今日。妄语两舌恶口绮语。传空说有说有言空。不见言见见言不见。不闻言闻闻言不闻。不知言知知言不知。欺贤罔圣言行相乖。自称赞誉得过人法。我得四禅四无色定阿那般那十六行观。得须陀洹至阿罗汉。我得辟支佛不退菩萨。天来龙来鬼来神来。旋风土鬼皆至我所彼问我答。显异惑众要世名利。如是等罪无量无边。今日发露归命忏悔

又复弟子等。从无始已来至于今日。或谗言斗乱交扇彼此。雨舌[言*蘭]构贩拽口舌。向彼说此向此导彼。离他眷属。破他婚亲穷他口舌。说人长短坏人善友。使狎密者为疏。亲旧者成怨。或绮语不实言不及义。诬谤君父评薄师长。破坏忠良埋没胜己。通致二国彼此扇作。浮花虚巧发言常虚。口是心非其途非一。对面誉叹背则呵毁。赞诵耶书傅耶恶法。或恶口詈骂言语粗穬。或呼天指地牵引鬼神。如是口业所生诸罪无量无边。今日至诚向十方佛尊法圣众前。归命忏悔

愿弟子等。承是忏悔口业等罪所生功德。愿生生世世具八音声四无碍辩。常说和合利益之语。其声清雅一切乐闻。善解众生方俗言语。若有所说应时应限。令彼听者则得解悟。超凡入圣开发慧眼

    大乘莲华宝达问答报应沙门经

宝达顷前入一诤论地狱。云何名曰诤论地狱。其地狱纵广八十由旬。铁壁周匝罗网覆上。中有铁锵亦如上说。中有铁钩钩罪人舌。复有铁斧来斫其舌寸寸而绝。复有火铢灌其口中背上而出。一日一夜受罪无量。万死万生千死千生。西门之中有六千沙门来入其中。罪人号啕而不肯入。马头罗刹手捉铁叉。望胸而撞背上而出来入其中。铁鸟高飞绝下来入。罪人举头则从口入足下而出。复有蟒蛇入其眼中。身中火然

宝达问曰。此诸沙门。作何等业来入此中受罪如是。罗刹答曰。此诸沙门受佛净禁戒不护将来。名言我是于大乘法师亦如冥夜。各自说言我得佛法深解佛义。便为人说。将徒引众游于人间。或受国王信施供养。内心吾我亦如山海。犹如枯木但有其皮。中心腐烂无所任用。此诸沙门亦复如是。以此因缘堕此地狱。从地狱出若生人中。聋盲喑哑不闻正法。宝达闻之悲泣而去

佛名经卷第二十三佛说佛名经卷第二十四

南无大修行佛　南无威德光佛　南无无诤智佛　南无师子声佛　南无善德佛　南无善住佛　南无日光佛　南无菩提上首佛　南无降伏怨佛　南无无垢浊义佛　南无胜去佛　南无妙光明佛　南无普光明佛　南无大庄严佛　南无功德山佛　南无摩尼月佛　南无爱眼佛　南无胜名佛　南无菩提智佛　南无宝功德佛　南无天光明佛　南无胜仙佛　南无实智佛智佛　南无甘露威德佛　南无能思惟佛　南无龙步佛　南无信智佛　南无实爱佛　南无莲华香佛　南无胜相佛　南无大威德佛　南无种种日佛　南无广地佛　南无甘露眼佛　南无惭愧智佛　南无山王自在积佛　南无悕胜佛　南无种种间错声佛　南无信修行佛　南无舍忧恼佛　南无诸世间智佛　南无威德力佛　南无信胜佛　南无势力称佛　南无放光明佛　南无过诸疑佛　南无功德德佛　南无舌去佛　南无无障智佛　南无得威德佛　南无月藏佛　南无梵光明佛　南无乐光明佛　南无胜光明佛　南无寂光明佛　南无离异意佛　南无无过智佛　南无无边智佛　南无成就功德佛　南无庄严身佛　南无无畏爱佛　南无到光明佛　南无大身佛　南无知智佛　南无大思惟佛　南无乐眼佛　南无无诸热智佛　南无不怯弱智佛　南无普清净佛　南无法清净佛　南无舍施威德佛　南无天城佛　南无无怯声佛　南无华日佛　南无善住心佛　南无鸡兜清净佛　南无俱苏摩光佛　南无法弗沙佛　南无月希佛　南无寂照佛　南无不错行佛　南无大精进佛　南无人声佛　南无普声佛　南无菩提愿佛　南无天色思惟佛　南无慧力佛　南无三慢多卢遮那佛　南无梵供养佛　南无圣弗沙佛　南无虚空智佛　南无能降伏放逸佛　南无不可比慧佛　南无胜军陀罗佛　南无降阿梨佛　南无应爱佛　南无戒供养佛　南无平等心明佛　南无信心不怯弱佛　南无精进清净佛　南无闻智佛　南无无障碍思惟佛　南无无畏光明佛　南无甘露声佛　南无名去佛　南无舍诤佛　南无护根佛　南无禅解脱佛　南无大殊提佛　南无栴檀香佛　南无可观佛　南无无量智佛　南无千日威德佛　南无舍重担佛　南无称清净佛　南无提赊闻佛　南无自在王佛　南无无边智佛　南无广光佛　南无信甘露佛　南无妙根佛　南无解脱行佛　南无妙见佛　南无胜光佛　南无大声佛　南无大威德聚佛　南无光明实鸡兜佛　南无应供养佛　南无求那提阇积佛　南无信相佛　南无大炎佛　南无阿罗诃信佛　南无善住思惟佛　南无善桥梁佛　南无智作佛　南无普宝佛　南无日光佛　南无说桥梁佛　南无婆萨婆俱他佛　南无心荷身佛　南无胜亲光佛　南无清净声佛　南无月胜佛　南无意德佛　南无庄严声佛　南无妙意佛　南无贤光佛　南无坚固华佛　南无功德成就佛　南无意成佛　南无解脱乘佛　南无降伏怨佛　南无过舌佛　南无过诸烦恼佛　南无无量光佛　南无无垢心佛　南无和合声佛　南无不可量眼佛　南无势力佛　南无妙光明佛　南无集功德佛　南无可闻声佛　南无大思惟佛　南无信天佛　南无思惟甘露佛　南无了意佛　南无胜灯佛　南无坚意佛　南无力势佛　南无华眼佛　南无菩提光明佛　南无最胜声佛　南无六通声佛　南无威德力佛　南无人称佛　南无胜华集佛　南无大髻佛　南无不随他佛　南无不畏行佛　南无离一切忧闇佛　南无月光明佛　南无心勇猛佛　南无解脱慧佛　南无离恶道佛　南无阎浮灯佛　南无胜供养佛　南无善思惟佛　南无胜威德色佛　南无信众生佛　南无快恭敬佛　南无波头摩清净佛　南无人波头摩佛　南无善香佛　南无胜供养佛　南无种种色华佛　南无胜功德佛　南无虚空劫佛　南无月贤佛　南无坚固佛　南无妙力佛　南无胜因陀罗智佛　南无胜亲佛　南无爱思惟佛　南无胜香佛　南无无诤行佛　南无功德舍佛　南无大精进思惟佛　南无大光明佛　南无摄受施佛　南无修行深思惟佛　南无香希佛　南无香象佛　南无种种智佛　南无思惟妙智佛　南无功德庄严佛　南无增上行佛　南无智行佛　南无功德山佛　南无声满十方佛　南无摄受择佛　南无信妙佛　南无月见佛　南无功德聚佛　南无法力佛　南无过一切疑佛　南无称王佛　南无护诸根佛　南无胜意佛　南无甘露光佛　南无思惟甘露佛　南无一切众上首佛　南无爱髻佛　南无不可降伏色佛　南无普信佛　南无庄严王佛　南无金刚步佛　南无贤作佛　南无功德报光明佛　南无精进力起佛　南无善清净光明佛　南无得脱一切缚佛　南无无垢波头摩藏胜佛　南无得解脱佛　南无十方称声无畏佛　南无破一切闇趣佛　南无光明王佛　南无大炎积佛　南无无边行功德宝光明佛　南无法光明佛　南无欢喜王佛　南无能作一切众生光明破闇胜佛　南无起普光明修行无边愿称王佛　南无普愿满足不怯弱佛　南无一切见光明佛　南无无垢光庄严王佛　南无功德藏山破金刚佛　南无龙王自在王佛　南无宝精进日月摩尼庄严威德声王佛　南无吼声妙声佛　南无善住持地佛　南无世间自在王佛　南无无障碍药王树胜佛　南无弥留幢佛　南无大山佛　南无弥留光明佛　南无妙声佛　南无日月住佛　南无称光明佛　南无无量光佛　南无不可量幢佛　南无大光明佛　南无宝鸡兜佛　南无净王佛　南无大炎聚佛　南无一切王声佛　南无难胜佛　南无日生佛　南无罗网光明佛　南无照光明佛　南无师子佛　南无称佛　南无称光明佛　南无法佛　南无法住持佛　南无法幢佛　南无梵声佛　南无星宿王佛　南无香胜佛　南无香光佛　南无大积佛　南无宝种种华敷身佛　南无莎罗自在王佛　南无宝莲华胜佛　南无见一切义佛　南无须弥劫佛　南无智灯佛　南无大光明照佛　南无难伏佛　南无照佛　南无勤鸡兜幢佛　南无威德自在王佛　南无觉王佛　南无宝藏佛　南无大海佛　南无十力增上自在佛　南无唯宝庄严佛　南无无边宝庄严佛　南无无相声佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无依德菩萨　南无普摄菩萨　南无普济菩萨　南无定光菩萨　南无真光菩萨　南无拘楼菩萨　南无天光菩萨　南无弥光菩萨　南无教导菩萨　南无大忍菩萨　南无华积菩萨　南无慧光菩萨　南无海慧菩萨　南无释魔男菩萨　南无金藏菩萨　南无山慧菩萨　南无山刚菩萨　南无山顶菩萨　南无山幢菩萨　南无伏魔菩萨　南无雨王菩萨　南无雷王菩萨　南无宝轮菩萨　南无宝场菩萨　南无宝严菩萨　南无宝水菩萨　南无宝登菩萨　南无宝现菩萨　南无宝造菩萨　南无乐法菩萨　南无净王菩萨　南无千光菩萨　南无原崄菩萨　南无照味菩萨　南无月辩菩萨　南无法轮菩萨　南无光净菩萨　南无普德菩萨　南无胜幢菩萨　南无濡音菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等。已忏悔身三口四竟。次复忏悔佛法僧间一切诸障。是故经中说。人身难得佛法难闻众僧难值。信心难生六根难具。善友难得怖心难发。而今相与宿植善根。得此人身六根完具。又值善友得闻正法。于其中间复各不能尽心精勤。恐于未来长溺万苦无有出期。是故今日应须至诚惭愧稽颡归依佛

南无东方法山胜佛　南无南方集音佛　南无西方法行灯佛　南无北方胜藏佛　南无东南方尊伏欲王佛　南无西南方流布力王佛　南无西北方法造弘佛　南无东北方万无量神通自在佛　南无下方大众法慧佛　南无上方成就一切诸刹丰佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始已来至于今日。常以无明覆心烦恼障重。见佛形像不能尽心恭敬。轻慢众僧残虐善友。破塔毁寺焚烧形像出佛身血。或自处华堂安置尊像卑猥之处。使烟薰日暴风吹雨露。尘土粪污雀鼠残毁。共住共宿曾无礼敬。或倮露像身永不严饰。或遮掩灯烛关闭殿宇障佛光明。如是等罪无量无边。今日至诚发露忏悔

又复弟子等。从无始已来至于今日。或于法间以不净手把捉经卷。或临经书非法俗话。或安置床头坐起不敬。或关闭箱箧虫啖朽烂。或首轴脱落部党失次。或参脱漏误纸墨破裂。自不修理不肯流转。如是等罪无量无边。今日发露归命忏悔

或眠地听经仰卧读诵。高声语笑乱他听法。或邪解佛语僻说听意。非法说法法说非法。非犯说犯犯说非犯。轻罪说重重罪说轻。或抄前着后抄后着前。前后着中中着前后。绮饰文辞安置已典。或为利养名誉恭敬为人说法。无道德心求法师过。而为论议非理弹击。不为长解求出世法。或轻慢佛语尊重邪教。毁呰大乘赞声闻道。如是等罪无量无边。今日至心发露忏悔

又复弟子等。从无始已来至于今日。或于僧间有障。杀害阿罗汉。破和合僧。害发无上菩提心人。断灭佛种使道不行。或罢人道鞭拷沙门。楚挞驱役苦言加谤。或破戒破齐破于威仪。或劝他人舍于梵行受行五欲。或假托形仪窥窃贼住。如是等罪无量无边。今日惭愧至心忏悔

弟子等。从无始已来至于今日。或裸形单服在经像前。不净脚履蹻上殿塔。或着[尸@(棄-ㄊ)]屐入僧伽蓝。涕唾堂房污佛僧地。或共僧同宿污彼法衣。乘车策马排突寺舍。如是等罪于三宝间。所起罪障无量无边。今日至诚向十方佛尊法圣众前。归命忏悔

愿弟子等。承是忏悔佛法僧间所有罪障所生功德。愿生生世世常值三宝。尊仰恭敬无有厌足。天缯妙彩宝绞络台。百千妓乐珍异华香。非世所有常以供养。若未成佛先往劝请开甘露门。若入涅槃愿我常得献最后供。于众僧中修六和敬。得自在力兴隆三宝。上弘佛道下化众生

    大乘莲华宝达问答报应沙门经

宝达顷前更入一耕田地狱。云何名曰耕田地狱。其地狱纵广二十由旬。铁壁周匝猛火绝焰。上火下彻下火上彻。其炎俱炽烟火洞然。尔时狱中地生铁刀。其刃仰向刃上火然来烧罪人。罪人忙[慄-木+(革*月)]精神飞扬。魂灵怗怕晃恼幽冥而不自觉。受罪千端苦痛万亿。其地狱中有铁牛犁地火焰俱起。东门之中有六千罪人。口眼火然烟焰俱发。身手六根火流如水。罪人沙门而不肯前。马头罗刹手捉铁叉。望背而撞胸前而出。手捉铁钩望骸而搭步步来前。中有铁狗来饮其血。复有饿鬼来食其肉。尔时罪人沙门手捉铁犁耕其地。其地火然随流而去。其犁扬中亦皆火流来烧罪人。地生谷草皆亦火然。一日一夜万死万生受大苦恼。精神飃浪魂魄幽冥。经千万劫始得为人。聋盲喑哑为人所憎。横为官事县官闭缠。身生恶疮游于草野

宝达问马头罗刹曰。此诸沙门。行何等行今受此苦。马头罗刹答曰。此诸沙门。受佛禁戒不惧三恶八难。受罪破戒无善。耕田种植名为破戒。手自作食还取自食自杀草木。亦如外道旃陀罗等无惭愧心。以是因缘堕此地狱。宝达悲泣说此偈言

  呜呼难思议　　云何颠倒见
  已得渡大海　　而没其深渊
  已得离生盲　　还复失光明
  已得无为道　　还堕有为中
  已得离生死　　还被欲火烧

宝达菩萨说偈而去

佛名经卷第二十四佛说佛名经卷第二十五

南无过境界步佛　南无须弥山聚佛　南无虚空眼佛　南无虚空寂佛　南无称力王佛　南无放光明佛　南无离诸染佛　南无种种花成就胜佛　南无远离诸畏惊怖毛竖佛　南无智积佛　南无栴檀香佛　南无伏眼佛　南无宝来佛　南无香首佛　南无胜众佛　南无唯盖佛　南无无障眼佛　南无栴檀去佛　南无智华宝光明胜佛　南无贤胜光明佛　南无能一切畏佛　南无无畏佛　南无弥留藏佛　南无法作佛　南无十上光明佛　南无千上光明佛　南无智光明佛　南无宝胜光明佛　南无无边光明佛　南无无碍声佛　南无罗网光明佛　南无种种宝智佛　南无无边庄严佛　南无优波罗胜佛　南无住智胜佛　南无胜能圣佛　南无智称佛　南无莎罗自在王佛　南无宝娑罗佛　南无大将佛　南无宝鬘佛　南无不空名称佛　南无胜成就功德佛　南无称王佛　南无不空步佛　南无香光明佛　南无无障碍声佛　南无称力王佛　南无须弥增长胜王佛　南无宝胜功德佛　南无波头摩胜佛　南无宝起佛　南无香光明佛　南无十方称发起佛　南无普护增上云声王佛　南无无边光明佛　南无无边智成佛　南无无边轮奋迅佛　南无众上首佛　南无华胜王佛　南无宝像佛　南无不空名称佛　南无发起无边精进功德佛　南无发心庄严一切众生佛　南无盖行佛　南无光明轮威德王佛　南无功德王光明佛　南无一切功德到彼岸佛　南无然灯作佛　南无能作光明佛　南无得功德佛　南无波头摩上胜佛　南无宝作佛　南无无边愿佛　南无无边功德王住佛　南无宝聚佛　南无娑罗自在王佛　南无宝光明佛　南无宝积佛　南无最上佛　南无修行无边功德佛　南无观声佛　南无须弥山光明佛　南无无边境界佛　南无妙法佛　南无宝华成就胜佛　南无无边奋迅佛　南无发起一切众生信佛　南无宝盖起佛　南无胜功德佛　南无不可华佛　南无宝境界光明佛　南无宝胜功德佛　南无发心即转法轮佛　南无十方称名佛　南无迦陵伽王佛　南无日轮然灯佛　南无宝上佛　南无智成就胜佛　南无功德王住佛　南无无障碍眼佛　南无无畏佛　南无施无畏佛　南无智积佛　南无发起无譬喻相佛　南无积光明轮威德佛　南无因意佛　南无那罗延佛　南无无垢鸡兜佛　南无月积佛　南无清净意佛　南无安隐佛　南无发起善思惟佛　南无能破诸怨佛　南无优波罗功德佛　南无称力王佛　南无无边光明云香弥留佛　南无种种色华佛　南无无边光佛　南无能转能住佛　南无胜香佛　南无宝胜佛　南无香山佛　南无信一切众生心智见佛　南无无相声佛　南无智功德积佛　南无无障声佛　南无一盖藏佛　南无不动势佛　南无迦叶佛　南无观见一切境界佛　南无上首佛　南无成义佛　南无成胜佛　南无称佛　南无离一切疑佛　南无智德佛　南无功德乘佛　南无星宿王佛　南无不可量鸡兜佛　南无栴檀佛　南无罗网光佛　南无梵声佛　南无不可量实体胜佛　南无一切法无观佛　南无发一切众生不断绝修行佛　南无无边奋迅佛　南无见一切法佛　南无见一切法平等佛　南无成就无边功德佛　南无智高光明佛　南无波头摩上佛　南无十方上佛　南无华成就功德佛　南无坚固众生佛　南无智光明佛　南无智众佛　南无离藏佛　南无明王佛　南无不分别修行佛　南无无边智称佛　南无栴檀屋胜佛　南无无比智华成佛　南无善住娑罗王佛　南无胜月光明佛　南无须弥聚佛　南无称名佛　南无过十方称佛　南无称名亲佛　南无称坚固佛　南无离忧恼佛　南无波头摩胜王功德佛　南无散华鸡兜佛　南无普放香光明佛　南无波那陀眼佛　南无放炎佛　南无十方称名佛　南无光明弥留佛　南无宝光明佛　南无然尸弃佛　南无三界境界势佛　南无光明轮佛　南无虚空寂境界佛　南无尽境界佛　南无妙宝声佛　南无普境界佛　南无智称佛　南无光明轮境界胜王佛　南无善住佛　南无成就佛宝功德佛　南无起智功德佛　南无一切功德佛　南无佛境界清净佛　南无起智光明威德积聚佛　南无成就波头摩王佛　南无第一境界法佛　南无半月光明佛　南无香像佛　南无成就波头摩功德佛　南无栴檀功德佛　南无宝山佛　南无黠慧行佛　南无能作无畏佛　南无无边功德胜佛　南无光明鸡兜佛　南无作无边功德佛　南无成就一切胜功德佛　南无住持炬佛　南无胜敌对佛　南无胜王佛　南无星宿王佛　南无无边山佛　南无虚空轮清净王佛　南无无边声佛　南无无边光明佛　南无宝弥留佛　南无种种宝佛　南无拘修摩起佛　南无上首佛　南无无垢离发修行光明佛　南无金色华佛　南无宝窟佛　南无种种华成就佛　南无放光明佛　南无成就华佛　南无华盖佛　南无不空发修行佛　南无胜力王佛　南无净声王佛　南无无边上首佛　南无无障眼佛　南无破诸趣佛　南无离疑佛　南无无相声佛　南无毕竟成就无边功德佛　南无宝成就胜佛　南无波头摩得胜功德佛　南无宝妙佛　南无三世无碍发修行佛　南无无边照佛　南无宝弥留佛　南无然灯胜王佛　南无成就智慧德佛　南无炬然灯佛　南无无上光明佛　南无功德王光明佛　南无弗沙佛　南无梵声佛　南无功德轮佛　南无十方灯佛　南无佛华成就德佛　南无娑罗自在王佛　南无华鬘佛　南无宝积佛　南无见种种佛　南无药王佛　南无最上佛　南无贤胜佛　南无香妙佛　南无香胜鸡兜佛　南无栴檀屋佛　南无香鸡兜佛　南无无边精进佛　南无过十光佛　南无佛波头摩妙佛　南无无边境界佛　南无惊怖波头摩成就胜王佛　南无宝罗网佛　南无善住王佛　南无最胜香王佛　南无能与一切乐佛　南无能现一切念佛　南无不空名称佛　南无宝光明佛　南无安隐与一切众生乐佛　南无无边虚空庄严胜佛　南无善庄严佛　南无虚空鸡兜佛　南无普华成就胜佛　南无可乐胜佛　南无无边境界来佛　南无净眼佛　南无高山佛　南无不可降伏幢佛　南无可诣佛　南无无边无际诸山佛　南无月轮庄严王佛　南无最胜弥留佛　南无乐成就德佛　南无清净诸弥留佛　南无安乐德佛　南无梵德佛　南无无碍自在佛　南无作无边功德佛　南无威德王佛　南无梵胜佛　南无善思惟成就诸愿佛　南无清净轮王佛　南无智高佛　南无勇猛仙佛　南无智积佛　南无作方佛　南无能忍佛　南无离诸有佛　南无智护佛　南无妙功德佛　南无随众生心现境界佛　南无明镜月王佛　南无无边宝佛　南无离一切爱境界无畏佛　南无无碍宝光明佛　南无无碍照佛　南无念一切佛境界佛　南无能现一切佛像佛　南无无相体佛　南无化声佛　南无化声善声佛　南无宝成就胜功德佛　南无海弥留佛　南无无垢意佛　南无智华成就佛　南无高威德山佛　南无寂灭佛　南无离恨佛　南无断一切诸道佛　南无成就不可量功德佛　南无乐成就胜境界佛　南无求无畏香佛　南无无障碍香光明佛　南无云妙鼓声佛　南无成就胜功德佛　南无无边势力步佛　南无须弥山坚佛　南无胜香须弥佛　南无无边光佛　南无普见佛　南无得无畏佛　南无月灯佛　南无火灯佛　南无势灯佛　南无高修佛　南无金刚生佛　南无智自在王佛　南无智力称佛　南无无畏上佛　南无功德王佛　南无无畏上佛　南无功德王佛　南无波婆娑佛　南无善眼佛　南无妙庄严佛　南无宝盖佛　南无香象佛　南无无边境界不空称佛　南无不可思议功德王光明佛　南无种种华佛　南无无畏王佛　南无常厌香佛　南无妙药树王佛　南无常求安乐佛　南无无边意行佛　南无无边境界佛　南无无边光佛　南无无边目佛　南无无边虚空境界佛　南无声色境界佛　南无星宿王佛　南无香上胜佛　南无虚空胜佛　南无胜功德佛　南无现诸方佛　南无妙弥留佛　南无无障眼佛　南无娑伽罗王佛　南无庭燎佛　南无然鸡兜佛　南无无垢月威德光佛　南无智山佛　南无称力王佛　南无功德王光明佛　南无智见佛　南无波头摩胜二到成就佛　南无宝火佛　南无宝莲华胜佛　南无断诸疑佛　南无领胜众佛　南无鸡兜王佛　南无华胜佛　南无放光明佛　南无照波头摩光明佛　南无方王法鸡兜佛　南无无边步佛　南无娑伽罗山佛　南无阿谟荷见佛　南无无障碍吼声佛　南无无边功德称光明佛　南无世间涅槃无差别修行佛　南无无边照佛　南无善眼佛　南无一盖藏佛　南无放光明佛　南无过去未来现在发修行佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

南无德炎菩萨　南无相光菩萨　南无海月菩萨　南无海藏菩萨　南无胜月菩萨　南无净慧菩萨　南无超光菩萨　南无月德菩萨　南无金刚菩萨　南无炎幢菩萨　南无尊德菩萨　南无海明菩萨　南无海广菩萨　南无照境菩萨　南无慧明菩萨　南无功德菩萨　南无明达菩萨　南无密教菩萨　南无须那菩萨　南无色力菩萨　南无调伏菩萨　南无隐身菩萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

礼三宝已次复忏悔

弟子等如上所说已忏悔于三宝间。轻重诸罪其余诸恶。今当次第更复忏悔。经中佛说。有二种健儿。一者自不作罪。二者作已能悔。又云有二种白法。能为众生灭除众障。一者惭二者愧也。惭者自不作恶。愧者不令他作。有惭愧者詺可为人。若无惭愧与诸禽兽不相异也。惭者羞天。愧者所犯诸罪发露向人。是故弟子。今日至诚惭愧归依佛

南无东方宝山佛　南无南方最威仪佛　南无西方无等胜佛　南无北方法像佛　南无东南方梵增益佛　南无西南方天帝金刚佛　南无西北方普照一切佛　南无东北方大音眼佛　南无下方海意乐佛　南无上方净妙慧德丰佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始已来至于今日。或信邪倒见宰杀众生。解奏魑魅魍魉鬼神。欲希延年终不能得。或妄言见鬼假称神语。如是等罪无量无边。今日惭愧发露忏悔

又复弟子等从无始已来至于今日。或行动傲诞自高自大。或恃种姓轻慢一切。以贵欺贱用强凌弱。倚富轻贫挟官慢下。或饮酒斗乱不避亲疏。惛醉终日尊卑不识。如是等罪无量无边

今日至诚发露忏悔

或嚵[昔*刀]懒惰不识羞耻。贪嗜饮食不诞艰辛。饮酒啖肉歌舞作乐。无有期度不知休息。或食诸生鲙饮啖五辛。薰秽经像排[穴/友]净众。纵心肆意不限理拯。疏远善人亲狎恶友。或贡高矫假偃蹇自用。鲁扈抵[穴/友]不识人情。自是非他自能他恶。见他过失则相攻讦。妄为辞句希望侥幸。如是等罪无量无边。今日至心归命忏悔

或临财不让无廉无耻。屠肉沽酒欺诳自活。或出入息利计时卖日。聚积悭惜贪求无厌受人供养不生惭愧。或无戒行空纳信施。或打奴捶婢驱役诸僮。不问饥渴不知寒暑。或拨撤桥梁驻绝行路。如是等罪无量无边。今日至诚归命忏悔

或放逸自恣无记散乱。摴捕白打双六围棋。群会屯聚饮酒食肉。更相讥诮无趣谈话。论说天下从月竟年空丧天日。初中后夜禅诵不修。懈怠懒惰尸卧终日。于六念处心不经理。见他胜事便生嫉妒心怀碜毒备起烦恼。致使诸恶猛风吹恶薪火炽然无有休息。三业微善一切俱焚。善法既尽为一阐提。堕火地狱无有出期。是故弟子等。今日至诚稽颡。向十方一切诸佛圣众前。忏悔上来所有一切众罪。若轻若重若粗若细若自作若教他作。若随喜作若以势逼迫令作。如是乃至赞叹行恶法者。今日至心发露忏悔愿皆消灭。愿弟子等承是忏悔一切诸恶所生功德。愿生生世世慈和忠孝。谦卑自辱知廉识耻。先意问讯循良贞谨清洁义让。远离恶友常遇善缘。摄守六根敬护三业。捍劳忍苦心不退没。立菩提志荷负众生

    大乘莲华宝达问答报应沙门经

宝达顷前入火米地狱。其地狱中流火灌注来烧罪人。火中有米亦皆火然。是诸罪人举手来取其米。烧罪人手则皆燋烂

宝达问马头罗刹曰。此诸沙门。作何等罪受罪如是。马头罗刹答曰。比丘。此诸沙门以不净手触众僧净食。以此因缘故堕此地狱

宝达闻之悲泣而去

佛名经卷第二十五佛说佛名经卷第二十六

南无无边华佛　南无无边净佛　南无无边光佛　南无无边明佛　南无无边照佛　南无妙明佛　南无无边境界佛　南无无边步佛　南无等盖行佛　南无宝盖佛　南无星宿王佛　南无善星宿佛　南无光明轮佛　南无光明王佛　南无胜光明功德佛　南无不可量光佛　南无胜佛　南无不可量境界步佛　南无无碍声吼佛　南无大云光佛　南无阇梨尼山佛　南无佛华光明佛　南无波头摩胜华山王佛　南无星宿上首佛　南无放光明佛　南无三周单那坚佛　南无不空见佛　南无顶胜功德佛　南无波头摩顶胜功德佛　南无无痴佛　南无能度佛　南无无迷步佛　南无离愚境界佛　南无无闇光明佛　南无无边精进佛　南无娑罗自在王佛　南无宝娑罗佛　南无一盖佛　南无盖庄严佛　南无宝聚佛　南无栴檀香佛　南无栴檀聚香佛　南无栴檀屋佛　南无无边光明佛　南无光轮佛　南无山庄严佛　南无无障碍明佛　南无善眼佛　南无宝成佛　南无一切功德胜佛　南无成就佛华功德佛　南无善住意佛　南无无边方便佛　南无不空功德佛　南无宝势佛　南无无边修行佛　南无庄严无边功德佛　南无虚空轮光佛　南无无相声佛　南无药王佛　南无不怯弱佛　南无离诸畏毛竖佛　南无功德王光明佛　南无观智慧起华佛　南无虚空寂佛　南无虚空声佛　南无虚空庄严佛　南无大明佛　南无胜功德佛　南无成佛　南无佛波头摩德佛　南无成功德佛　南无师子胜佛　南无成就义佛　南无师子护佛　南无善住王佛　南无梵山佛　南无净目佛　南无不空迹步佛　南无香象佛　南无香德佛　南无香弥留佛　南无无边眼佛　南无财屋佛　南无香山佛　南无宝师子佛　南无坚固众生佛　南无妙胜住王佛　南无无边境界胜王佛　南无胜精进王佛　南无无疑佛　南无善宿王佛　南无然灯佛　南无能作光明佛　南无光明山佛　南无光明轮佛　南无妙盖佛　南无香盖佛　南无宝盖佛　南无香云盖佛　南无栴檀胜佛　南无须弥山积聚佛　南无种种宝光明佛　南无坚固自在王佛　南无思惟佛法佛　南无净胜佛　南无净眼佛　南无不弱佛　南无宝胜佛　南无施罗王佛　南无发修行转女根佛　南无发无边修行佛　南无最妙光佛　南无阇梨尼光明山佛　南无断一切恶佛　南无因王佛　南无梵胜佛　南无称身佛　南无华山佛　南无转胎佛　南无转难佛　南无断诸念佛　南无发起诸念佛　南无常修行佛　南无善住佛　南无一藏佛　南无一山佛　南无无边身佛　南无无边精进佛　南无光明轮佛　南无无边功德王光佛　南无降伏一切诸怨佛　南无过一切魔境界佛　南无不可量华佛　南无不可量香佛　南无不可量声佛　南无光明顶佛　南无光明胜佛　南无不离二佛　南无法轮清净佛　南无不可量佛花光明佛　南无不可量声佛　南无光明山佛　南无娑罗自在王佛　南无日面佛　南无善目佛　南无虚空佛　南无宝华佛　南无宝成佛　南无月华佛　南无发诸行佛　南无断诸世间佛　南无无边乐说佛　南无离诸竞畏佛　南无乐说一切境界佛　南无普香光明佛　南无香光佛　南无香弥留佛　南无香胜佛　南无香象佛　南无香林佛　南无香王佛　南无波头摩胜王佛　南无佛境界佛　南无最妙佛　南无妙胜佛　南无散华佛　南无华盖鬘佛　南无华屋佛　南无金色华佛　南无香华佛　南无弥留王佛　南无导师佛　南无胜诸众生佛　南无断阿叉那佛　南无发善行佛　南无善华佛　南无无边香佛　南无普散香光明佛　南无普散香佛　南无普散光佛　南无普散香花佛　南无普散波头摩胜佛　南无宝阇梨尼手佛　南无起王佛　南无普佛国王盖佛　南无善住王佛　南无妙香佛　南无无边智境界佛　南无不空发佛　南无不空见佛　南无无障目佛　南无不动佛　南无发生菩提心佛　南无无量眼佛　南无有灯佛　南无普照佛　南无光明佛　南无一切国土佛　南无不断慈一切众生乐说佛　南无无垢步佛　南无无迹步佛　南无离一切忧佛　南无能离一切众生有佛　南无乐修行胜佛　南无无畏王佛　南无胜山佛　南无救苦难佛　南无香面佛　南无俱邻佛　南无大力胜佛　南无宝优波罗胜佛　南无拘牟头成佛　南无高声眼佛　南无上首佛　南无华成佛　南无无边光明佛　南无月出光佛　南无十方称佛　南无多罗歌王增上佛　南无无边光明佛　南无最胜香山佛　南无无畏佛　南无成就无畏德佛　南无成就无边愿功德佛　南无一切功德庄严佛　南无华王佛　南无不可降伏幢佛　南无增上护光佛　南无惊怖波头摩胜王佛　南无不异心成就胜佛　南无一切上佛　南无虚空轮清净王佛　南无无量声吼佛　南无无相声吼佛　南无宝起功德佛　南无梵胜佛　南无无障碍香手佛　南无弥留山光明佛　南无波头摩胜光佛　南无能作称名佛　南无称亲佛　南无坚固自在王佛　南无过去如是等无量无边诸佛　南无现在积聚无畏佛　南无宝功德光明佛　南无普护佛　南无宝光照佛　南无月庄严宝光明智威德声王佛　南无拘苏摩树提不谬王通佛　南无清净月轮佛　南无寂静月声佛　南无阿僧祇住功德精进胜佛　南无善名称胜佛　南无因陀罗鸡兜幢星宿王佛　南无普光明庄严胜佛　南无降伏敌对步佛　南无普功德光明庄严胜佛　南无无碍药王树胜佛　南无波头摩步佛　南无宝波头摩善住娑罗主佛　南无师子佛　南无日光佛　南无火光佛　南无无边光佛　南无波头摩王佛　南无阿偶多罗佛　南无波头摩胜佛　南无善华佛　南无宝心佛　南无无碍光佛　南无山幢佛　南无宝幢佛　南无宝炎佛　南无大炎聚佛　南无栴檀香佛　南无善利光佛　南无波头摩敷身佛　南无依止无边功德佛　南无宝体法决定声王佛　南无阿僧祇精进聚集胜佛　南无智通佛　南无弥留山积佛　南无然灯佛　南无大威德力佛　南无日月佛　南无栴檀佛　南无须弥劫佛　南无月色佛　南无不染佛　南无降伏龙佛　南无龙天佛　南无金色镜像佛　南无山声自在王佛　南无山积佛　南无须弥藏佛　南无供养光佛　南无胜觉佛　南无地山佛　南无琉璃华佛　南无妙琉璃金形像佛　南无降伏月佛　南无日声佛　南无散华庄严佛　南无山海智奋迅通佛　南无水光佛　南无大香镜像佛　南无不动山佛　南无宝集佛　南无胜山佛　南无勇猛山佛　南无多功德法住持得通佛　南无日月琉璃光佛　南无胜琉璃光佛　南无心间智多拘苏摩胜佛　南无日光佛　南无月光佛　南无散华王拘苏摩通佛　南无栴檀月光佛　南无破无明闇佛　南无普盖波婆罗佛　南无星宿佛　南无弗沙佛　南无法慧增长佛　南无师子鹅王山吼佛　南无梵声龙奋迅佛　南无世间因陀罗佛　南无世间自在王佛　南无可得报佛　南无甘露声佛　南无树提光佛　南无那罗延首龙佛　南无力天佛　南无师子佛　南无毗罗阇光佛　南无世间最上佛　南无山岳佛　南无人自在王佛　南无华胜佛　南无得四无畏佛　南无宝胜威德王劫佛　南无不可嫌身佛　南无称护佛　南无称威德佛　南无称名声佛　南无称声供养佛　南无勇猛称佛　南无声分清净佛　南无智胜善黠慧佛　南无智胜成就佛　南无智炎佛　南无妙智佛　南无智炎聚佛　南无智勇猛佛　南无梵声佛　南无梵胜佛　南无净天佛　南无善臂佛　南无善净天佛　南无梵声佛　南无净自在佛　南无净善眼佛　南无净声自在王佛　南无善净德佛　南无威德力增上佛　南无善势自在佛　南无威德大势力佛　南无胜威德佛　南无毗摩胜佛　南无毗摩意佛　南无善毗摩佛　南无毗摩面佛　南无毗摩成就佛　南无毗摩妙佛　南无见宝佛　南无须尼多佛　南无善眼清净佛　南无无边眼佛　南无普眼佛　南无无等眼佛　南无胜眼佛　南无不可降伏眼佛　南无不动眼佛　南无寂胜佛　南无善寂佛　南无善寂诸根佛　南无寂胜上佛　南无寂功德佛　南无寂彼岸佛　南无寂善住佛　南无寂心佛　南无寂意佛　南无寂静然灯佛　南无自在王佛　南无众胜佛　南无净王佛　南无大众自在勇猛佛　南无众胜解脱佛　南无法幢佛　南无法鸡兜佛　南无法起佛

次礼十二部尊经大藏法轮

敬礼十方大菩萨诸摩诃萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等已忏悔烦恼障。已忏悔业障。所余报障今当次第披陈忏悔。经中说言。业报至时非空非海中非入山石间。无有他方所脱之不受报。唯有忏悔力乃能得除灭。何以知然。释提桓因五衰相现。恐惧切心归诚三宝。死相即灭得延天年。如是等比。经教所明其事非一。故知忏悔实能灭祸。但凡夫之人若不遇善友奖导。则靡恶而不造。致使大命将尽临穷之际。地狱恶相皆现在前。当尔之时悔惧交至。不预修善临穷方悔。悔之于后将何及乎。殃祸异处宿预严待当独趣入。远到他所但得前行。入于大镬身心摧碎精神痛苦。如此之时欲求一礼一忏岂复可得。众等。莫自恃盛年财宝势力。懒惰懈怠放逸自恣。死苦一至。无问老少贫富贵贱。皆悉磨灭奄忽而至不令人知。夫命无常喻如朝露。出息虽存入息难保。云何以此而不忏悔。且五天使者既来。无常杀鬼卒至。盛年壮色无得免者。当尔之时华堂邃宇何关人事。高车大马岂得自随。妻子眷属非复我亲七珍宝饰乃为他玩。以此而言世间果报皆如幻化。上天虽乐会归败坏。寿尽魂魄堕落三途。是故佛语须跋陀言。汝师郁头蓝弗。利根聪明能伏烦恼。至于非非想处命终。还作畜生道中飞狸之身。况复余者。故知未证圣果已还皆应流转备经恶趣。如不谨慎匆尔一朝亲婴斯事将不及悔。或如今被罪行诣公门已是小苦。精神慞惶眷属恐惧求救百端。地狱众苦比于此者。百千万倍不得为喻。众等。相与历劫已来罪若须弥。云何闻此晏然不畏不惊不恐。令此精神复婴斯苦实为可痛。是故弟子等。运此丹诚。至心归依佛

南无东方功德华佛　南无南方光明尊佛　南无西方无边命佛　南无北方功德胜佛　南无东南方须漫那佛　南无西南方无障碍利益佛　南无西北方是世善妙佛　南无东北方上香弥楼佛　南无下方调意越诸花佛　南无上方净轮幡佛

归命如是等。十方尽虚空界一切三宝

弟子等自从无始已来至于今日。所有报障然其重者。第一唯有阿鼻地狱如经所明。今当略说其相此狱周匝有七重铁城。复有七重铁网罗覆其上。下有七重刀林无量猛火。纵广八万四千由旬。罪人之身遍满其中。罪业因缘不相妨碍。上火彻下下火彻上。东西南北通彻交过。如鱼在熬脂膏皆尽。此中罪苦亦复如是。其城四门有四大铜狗。其身纵广四十由旬。牙爪锋钜眼如闪电。复有无量铁觜诸鸟。奋飞腾翔啄罪人肉。牛头狱卒形如罗刹。而有九尾尾如铁叉。复有八头头上有十八角。有六十四眼。一一眼中皆悉迸出诸铁丸。烧罪人肉然其一嗔一怒喈吼之时声如霹雳。复有无量自然刀轮空中而下。从罪人顶入从足而出。于是罪人痛彻骨髓苦切肝心。如是经无量岁受诸苦恼。求生不得求死不得。如是等报今日皆悉稽颡。惭愧发露诚心忏悔

其余地狱刀山剑树地狱。身首脱落罪报忏悔。镬汤炉炭地狱。烧煮罪报忏悔。铁床铜柱地狱。燋然罪报忏悔。刀轮火车地狱。劈轹罪报忏悔拔舌犁耕地狱。楚痛罪报忏悔。吞啖铁丸洋铜灌口地狱。五内消烂罪报忏悔。铁碓铁磨地狱。骨肉灰粉罪报忏悔。黑绳铁网地狱。支节分离罪报忏悔。灰河沸屎地狱恼闷罪报忏悔。碱水寒水地狱。皮肤坼裂裸冻罪报忏悔。虎狼鹰犬地狱。更和残害罪报忏悔。刀兵分距地狱。更相搏撮斫刺罪报忏悔。火坑地狱。炮炙罪报忏悔。两石相磕地狱。形骸破碎罪报忏悔。聚合黑耳地狱。解剔罪报忏悔。闇冥肉山地狱。斩剉罪报忏悔。锯解钉身地狱。断截罪报忏悔。铁棒倒悬地狱。屠割罪报忏悔。燋热叫唤地狱。烦冤罪报忏悔。大小铁围山间长夜冥冥不识三光罪报忏悔。阿波波地狱。阿娑娑地狱阿吒吒地狱阿罗罗地狱。如是八寒八热一切诸地狱。一一狱中复有八万四千隔子地狱。以为眷属。此中罪苦炮煮楚痛。剥皮呙肉削骨打髓抽肠拔肺无量诸苦不可闻不可说。南无佛今日在此中者。或是我等。无始已来经生父母一切眷属。我等相与命终之后或当复堕如此狱中。今日洗心至到丹诚。叩头稽颡向十方佛大地菩萨。求哀忏悔令此一切报障毕竟消灭愿弟子等。承是忏悔地狱等报所生功德。愿生生世世诸佛慈悲救众生苦。即时破坏阿鼻铁城。悉与净土无恶道名。其余地狱。一切苦具转为乐缘。刀山剑树变成宝林。镬汤炉炭莲华化生。牛头狱卒除舍暴虐皆起慈悲无有恶念。地狱众生得离苦果更不造因。等受安乐如第三禅。一时俱发无上道心

    大乘莲华宝达问答报应沙门经

宝达顷前入一铁火屋地狱。云何名曰铁屋地狱。其地狱纵广三十四由旬。铁壁周匝铁网罗覆铁城四角。有大风猛利来吹其城。铁城动摇自然火出。周遍狱中炎赫炽盛。复有铁锵銐如锋铓。虚空而住殷殷硙硙状如雷声。其锵撩乱下刺罪人之体。有大铁床周回四十余步。火屋围绕罪人之身。遍布其床诸所受报了无妨碍。尔时西门之中有无量无边罪人。唱如是言。我今何罪入于此处。举身自捶踉[跳-兆+旁]宛转。悲啼号叫而不肯前。马头罗刹手捉铁钳。望胸而夹掷着狱中。钳所著处烟焰俱出。狱卒夜叉以大铁钩望头而搭。牵入铁火屋中。其屋周匝猛火炽焰。业力吹转罪人之身。登床而卧。有大毒蛇鳞甲皆刺。口中而入从下而出。复有铁鸟望心而啄抽其心肠。如是苦痛不可堪忍。一日一夜受罪无量。求生不得求死不得。经千万劫尔乃得脱。从地狱出当作畜生。牵犁负重偿他宿债。百生千生无有休息

宝达问马头罗刹曰。此诸罪人何罪所至受苦如是。马头罗刹答曰。此诸沙门。受佛净戒而不护持。向白衣不受屋舍而则眠卧。或因此见而生欲想。污净行比丘污比丘尼。偷僧祇物以是罪故堕此地狱。后得为人当堕五逆。家贫寒贱弊衣不盖形。自无家宅飃露居止。宝达闻之啼泣言曰。云何名为出世人。而为俗所缚。以得解脱门翻为欲所逼。说是语已涕泣而去

佛名经卷第二十六佛说佛名经卷第二十七

南无法体胜佛　南无法力自在胜佛　南无法勇猛佛　南无乐说山佛　南无宝火佛　南无乐说庄严云吼佛　南无胜声佛　南无妙眼佛　南无清净面月胜藏威德佛　南无成就意佛　南无满足心佛　南无净迦罗迦决定威德佛　南无无边精进佛　南无甘露光佛　南无无比慧佛　南无大威德佛　南无无卑征佛　南无月光佛　南无栴檀香佛　南无须弥劫佛　南无山积佛　南无无垢色佛　南无无染佛　南无龙胜佛　南无金色佛　南无山吼自在王佛　南无金藏佛　南无火光佛　南无火自在佛　南无琉璃华佛　南无月胜佛　南无月声佛　南无散华庄严光佛　南无大香去照明佛　南无离一切染意佛　南无聚集宝佛　南无德山佛　南无勇猛山佛　南无梵声龙奋迅佛　南无世间胜上佛　南无师子奋迅吼佛　南无华胜佛　南无山胜佛　南无成就娑罗自在王佛　南无吼声佛　南无普光明佛　南无等盖佛　南无无忧佛　南无智王佛　南无智山佛　南无月光佛　南无普光佛　南无声德佛　南无无勿成就佛　南无火幢佛　南无智自在佛　南无大自在佛　南无梵声佛　南无众自在佛　南无月面佛　南无日面佛　南无声胜佛　南无梵面佛　南无梵天佛　南无因陀罗鸡兜幢佛　南无善思惟月胜成就王佛　南无智光明佛　南无无垢称王佛　南无乐说庄严云德佛　南无妙声佛　南无清净面无垢月胜王佛　南无平等意佛　南无乐说声佛　南无无垢月佛　南无有信行佛　南无无垢清净金色决定光明威德王佛　南无宝光明轮王佛　南无智通佛　南无不可数发精进决定佛　南无山积佛　南无因陀罗鸡兜幢王佛　南无善住娑罗王佛　南无波头摩胜佛　南无善住坚固王佛　南无日月光佛　南无波头摩光佛　南无波头摩胜步佛　南无大通佛　南无大通智胜佛　南无无边智佛　南无多宝佛　南无吼声降伏一切佛　南无日月无垢光明佛　南无莲华无垢星宿王花佛　南无云妙鼓声王佛　南无意乐出家佛　南无住持水声善星宿王华严通佛　南无无垢身佛　南无那伽钩罗胜佛　南无智照佛　南无现一切功德光明奋迅佛　南无照光明庄严奋迅王佛　南无月明佛　南无光明普照佛　南无宝庄严佛　南无散华佛　南无普然灯佛　南无普华佛　南无普光明胜山王佛　南无善住功德摩尼山王佛　南无光明王佛　南无不可降伏幢佛　南无胜功德佛　南无世间自在佛　南无普华佛　南无舌根佛　南无虚空轮清净王佛　南无胜光明波头摩敷身佛　南无须弥山波头摩胜王佛　南无一切宝摩尼王佛　南无宝光明日月轮智佛　南无威德频头声王佛　南无大导师佛　南无普光明奋迅王光明佛　南无善行佛　南无乐说山佛　南无无住佛　南无师子象奋迅佛　南无功德王光明佛　南无功德幢佛　南无功德作佛　南无圣天佛　南无宝幢佛　南无金刚合佛　南无一切胜佛　南无安隐色佛　南无妙行佛　南无波婆罗娑伽罗佛　南无弗波鸡兜佛　南无妙色佛　南无修卢遮那佛　南无梨师掘多佛　南无破烦恼佛　南无妙力佛　南无敷华佛　南无弗加罗佛　南无善光佛　南无善吉佛　南无师子威德佛　南无住智德佛　南无婆那多香佛　南无实法广称佛　南无谛沙佛　南无世间喜佛　南无广光明佛　南无宝称佛　南无宝威德佛　南无梵威德佛　南无善声佛　南无善华佛　南无真声佛　南无善行色佛　南无微笑眼佛　南无功德山佛　南无云声佛　南无妙色佛　南无命威德佛　南无胜步行佛　南无世间求佛　南无降伏怨佛　南无供养佛　南无喜庄严佛　南无舍尸鸡兜佛　南无弗若功德光佛　南无大威德佛　南无等宝盖佛　南无那罗延佛　南无成就行佛　南无离忧佛　南无无垢喜佛　南无无垢光明佛　南无厚坚固佛　南无无垢云王佛　南无无垢臂佛　南无义成就佛　南无胜护佛　南无梵功德天王佛　南无虚空步佛　南无妙智佛　南无法宝佛　南无不空见佛　南无难降伏光佛　南无月光佛　南无月净佛　南无普光明佛　南无宝胜佛　南无普观佛　南无不可数见佛　南无通障佛　南无清净光明宝佛　南无常救一切众生苦佛　南无月光佛　南无善洗清净无垢成就无边功德胜王佛　南无宝胜无垢王劫佛　南无第一然灯佛　南无功德宝胜佛　南无无垢光明佛　南无乐说庄严佛　南无无垢月鸡兜称佛　南无俱苏摩庄严佛　南无大步佛　南无宝上佛　南无无畏观佛　南无师子奋迅佛　南无离怖畏佛　南无不怯弱离惊怖佛　南无金刚威德佛　南无梵胜天王佛　南无善见佛　南无善月佛　南无光明王佛　南无鸡兜称佛　南无阎浮光明佛　南无多摩罗跋栴檀香佛　南无不动佛　南无师子声佛　南无弥留山佛　南无师子幢佛　南无住虚空佛　南无常入涅槃佛　南无因陀罗幢佛　南无甘幢灯佛　南无降伏一切世间怨佛　南无得度佛　南无弥留劫佛　南无多摩罗跋栴檀香佛　南无云自在王佛　南无能破一切世间惊怖畏佛　南无普光明佛　南无法光明佛　南无海住持奋迅通佛　南无法虚空胜王佛　南无七宝波头摩步佛　南无宝鸡兜佛　南无一切众生爱见佛　南无宝一盖佛　南无满足百千光明幢佛　南无娑罗自在王佛　南无法华庄严王佛　南无普一宝盖佛　南无星宿佛　南无普光明奋迅王佛　南无法庄严王佛　南无山灯佛　南无坚精进佛　南无法照光佛　南无善住净境界佛　南无月山佛　南无毕竟庄严无边功德王佛　南无住清净眼佛　南无离诸烦恼佛　南无不空见佛　南无普光佛　南无成就无垢无边清净功德胜王佛　南无智上光明佛　南无运度一切众生佛　南无宝胜智威德庄严自在王佛　南无清净光佛　南无敷华娑罗自在王佛　南无大华敷王佛　南无月轮清净佛　南无寂静月声王佛　南无无边坚精进住胜佛　南无波头摩胜佛　南无法鸡兜佛　南无然灯佛　南无功德鸡兜佛　南无功德成佛　南无圣天佛　南无宝山佛　南无金刚合佛　南无一切胜佛　南无普香佛　南无善华佛　南无善胜佛　南无功德山佛　南无胜成就佛　南无拘邻佛　南无善眼佛　南无头陀罗吒佛　南无善生佛　南无梵胜佛　南无寂静佛　南无梵德佛　南无因陀罗幢佛　南无月色佛　南无无垢色佛　南无无染佛　南无胜龙佛　南无龙天佛　南无金光明佛　南无胜声因陀罗王佛　南无善须弥山佛　南无善色藏佛　南无火光佛　南无威德因陀罗佛　南无地迦侦　南无琉璃华佛　南无胜琉璃金光明佛　南无月胜佛　南无日吼佛　南无散华庄严光明佛　南无娑伽罗胜智奋迅通佛　南无水光明佛　南无大香行光明佛　南无离一切嗔恨意佛　南无宝胜佛　南无胜积佛　南无胜仙佛　南无住持多功德通法佛　南无日月琉璃光佛　南无菩提心华胜佛　南无日月佛　南无日月光佛　南无华鬘色王佛　南无钩修弥多通佛　南无水月光明佛　南无破无明闇佛　南无普盖宝佛　南无增长法乐佛　南无种种师子声增长吼佛　南无梵自在龙吼佛　南无世间自在佛　南无世间自在王佛　南无难胜佛　南无宝作佛　南无甘露声佛　南无胜光佛　南无龙天王佛　南无增上力佛　南无无垢光佛　南无师子佛　南无世间增上佛　南无德山佛　南无人王佛　南无华胜佛　南无德无畏佛　南无能平等作佛　南无行平等佛　南无声德佛　南无初发心离诸畏一切烦恼胜德佛　南无金刚步佛　南无宝光明步象佛　南无离诸魔疑佛　南无功德增长佛　南无初发心成就不退转胜佛　南无宝盖胜光明佛　南无能教化诸菩萨佛　南无初发心念断一切烦恼染佛　南无降伏烦恼佛　南无胜光明王佛　南无三昧手胜佛　南无波头摩上胜佛　南无日轮光明佛　南无均宝盖佛　南无日轮光明胜佛　南无增上三昧奋迅佛　南无宝花普照胜佛　南无最妙波头摩步佛　南无宝轮光明胜德佛　南无宝藏佛　南无宝胜佛　南无宝灯王佛　南无坚精进思惟成就义佛　南无普光明观称佛　南无慈庄严功德称佛　南无称一切众生念胜功德佛　南无吉称功德佛　南无毕竟惭愧称胜佛　南无广光明佛　南无乐说庄严思惟佛　南无无垢月鸡兜称佛　南无钩修摩庄严光明作佛　南无宝称佛　南无无畏观佛　南无师子力奋迅佛　南无伽那歌王光明佛　南无贤作佛　南无无垢光明佛　南无功德宝光明佛　南无精进力成就佛　南无善清净光佛　南无得奋一切缚佛　南无无垢波头摩藏胜佛　南无得无障碍力解脱佛　南无十方称名无畏佛　南无金刚势佛　南无大宝聚佛　南无无边功德庄严威德王劫佛　南无功德宝山佛　南无说一切庄严胜佛　南无无边乐说庄严成就智佛　南无千云吼声王佛　南无妙金色光明威德胜照佛　南无种种威德王劫佛　南无阿僧祇亿劫成就智佛　南无清净金虚空吼光明佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等已忏地狱报竟。今当复次忏悔三恶道报。经中佛说。多欲之人多求利故苦恼亦多。知足之人虽卧地上犹以为乐。不知足者虽处天堂犹不称意。但世间人忽有急难便能舍财不计多少。而不知此身临于三途深坑之上。一息不还定应堕落。忽有知识教营福德。令修未来善法资粮。执此悭心无肯作理。夫如此者极为愚惑。何以故尔。经中佛说生时不赉一文而来。死亦不持一文而去。苦身积聚为之忧恼。于己无益徒为他有。无善可恃无德可怙。致使命终堕诸恶道。是故弟子等。今日至心稽颡。恳切丹诚归依佛

南无东方高光明佛　南无南方莲花最佛　南无西方大悲光明王佛　南无北方华山藏佛　南无东南方佛音声佛　南无西南方优昙钵花幢佛　南无西北方转吉祥佛　南无东北方光净照耀佛　南无下方无退没佛　南无上方宝德步佛

归命如是等十方尽虚空界一切三宝

弟子等今日次复忏悔畜生道中无所识知罪报。忏悔畜生道中负重牵犁。偿他宿债罪报。忏悔畜生道中不得自在。为他斫刺屠割罪报。忏悔畜生道中无足二足四足多足罪报。忏悔畜生道中身诸毛羽鳞甲之内。为诸小虫之所[口*(一/巾)]啖罪报。忏悔如是畜生道中有无量无边罪报。今日至诚归命忏悔

弟子等今日次复忏悔饿鬼道中长饥罪报。忏悔饿鬼道中百千万岁永不曾闻浆水之名罪报忏悔饿鬼道中食啖脓血粪秽罪报。忏悔饿鬼道中动身之时一切支节悉皆火然罪报。忏悔饿鬼道中腹大咽小罪报。忏悔如是饿鬼道中无量无边苦报。是故今日至诚稽颡归命忏悔

弟子等今日次复忏悔一切鬼神修罗道中谀谄诈称罪报。忏悔鬼神道中担沙负石填河塞海罪报。忏悔鬼神罗刹鸠槃荼诸恶鬼神。生啖血肉受此丑陋罪报。忏悔如是鬼神道中无量无边一切罪报。今日稽颡向十方佛大地菩萨。求哀忏悔悉令消灭

愿弟子等。承是忏悔畜生等报所生功德。愿生生世世灭愚痴垢。自识业缘智慧明照断恶道身。愿以忏悔饿鬼等报所生功德。愿生生世世永离悭贪饥渴之苦。常食甘露解脱之味。愿以忏悔鬼神修罗等报所生功德。愿生生世世质直无谄。离邪命因除丑陋果福利人天。愿弟子等。从今日以去乃至道场。决定不受四恶道报。唯除大悲为众生故以誓愿力处之无厌

    大乘莲华宝达问答报应沙门经

宝达顷前更入一崩埋地狱。云何名曰崩埋地狱。其狱纵广四十九由旬。周匝铁城。铁城四角有金刚山。大力风来吹山则合磨令碎末。犹如散沙间无有空。山中出火炎赫炽然。遍布狱中了无休息。铁锵撩乱来刺罪人锵皆火然。尔时北门之中有三千罪人。扬声大哭举身投地。我今何罪来入此中。马头罗刹手捉铁棒望头而打。将至狱中。其狱中央有四大铁狗高一由旬。广张其口口内火然。罪人至傍则便嗔吼。诸罪人众闻是吼声。即时惊怖闷绝躃地之间良久。热风所吹利刀割身。身则分散苦切难忍。走向诸角金刚铁山。自然而动崩压罪人。罪人之身应时消烂。狱卒夜叉以大铁丳蹴地刺之。唤言活便则自活。如是苦切楚痛万端。一日一夜受罪无量。求生不得求死不得

宝达问马头罗刹曰。此诸罪人以何罪故来入此狱中。马头罗刹答宝达菩萨曰此诸人等。不能持心苦行以求福田。翻乃倚挟豪族。怙恃官势舞弄贤人欺凌贫贱。或枉取他财宝。或诈夺他家业资生心无惭愧。以是因缘堕于地狱。百生千生无有出期。后若得出当生边地下贱。不得闻佛正法。宝达闻之涕泣而去

佛名经卷第二十七佛说佛名经卷第二十八

南无普光明佛　南无功德多宝海王佛　南无不空功德佛　南无照一切处佛　南无妙鼓声佛　南无法自在佛　南无普见佛　南无大炎聚佛　南无光明幢佛　南无智鸡兜佛　南无娑罗胎佛　南无宝尸弃佛　南无波头摩藏佛　南无一切胜佛　南无娑伽罗佛　南无波头摩藏佛　南无娑罗自在王佛　南无华净佛　南无称胜佛　南无见实佛　南无智弥留佛　南无龙德佛　南无胜行佛　南无星宿佛　南无大庄严佛　南无光明王佛　南无能人佛　南无自在王佛　南无日面佛　南无善意佛　南无龙胜佛　南无弗沙佛　南无药王佛　南无师子山佛　南无住持胜功德佛　南无饮甘露佛　南无放炎佛　南无妙山佛　南无护世间供养佛　南无多伽罗尸弃佛　南无难胜佛　南无大灯佛　南无波头摩上佛　南无法幢佛　南无能然灯佛　南无难胜智佛　南无难可意佛　南无真声佛　南无妙声佛　南无娑罗步佛　南无宝炎佛　南无爱见佛　南无须弥劫佛　南无栴檀光佛　南无日光佛　南无药树胜佛　南无净觉佛　南无记莂佛　南无爱作佛　南无作无畏佛　南无波头摩宝香佛　南无胜德佛　南无无垢佛　南无净照佛　南无无烦恼佛　南无善来佛　南无善光佛　南无金色佛　南无能作光明佛　南无清净佛　南无得脱佛　南无迦陵频伽声佛　南无能与法佛　南无善护诸门佛　南无得意佛　南无离爱佛　南无未生宝佛　南无善护诸根佛　南无梵声佛　南无胜声佛　南无妙声佛　南无大慧佛　南无无诸浊佛　南无不可动佛　南无乐解脱佛　南无胜二足佛　南无具足一切功德庄严佛　南无相好庄严佛　南无拘牟陀语佛　南无不可降伏语佛　南无常相应语佛　南无梵声安隐众生佛　南无娑罗华佛　南无金枝花佛　南无拘牟陀相佛　南无妙顶佛　南无大牟尼佛　南无一切法到彼岸佛　南无无染佛　南无不散心佛　南无荷吒伽色佛　南无善寂成就佛　南无赊头罗步佛　南无清净手佛　南无常来佛　南无毕竟成就大悲佛　南无成就坚佛　南无常行成就佛　南无离诤浊佛　南无清净功德相佛　南无不泣牟尼罗佛　南无胜藏佛　南无般若齐佛　南无般若宝毕竟佛　南无满足意佛　南无世间自在王佛　南无无量命佛　南无大炎积佛　南无无边宝佛　南无净胜天佛　南无内外净佛　南无寂诸根佛　南无最灯佛　南无成就不可思惟愿娑罗王佛　南无师子意佛　南无降伏力佛　南无住持速行佛　南无放光明王佛　南无毗头奚吼佛　南无无念觉法王佛　南无佛国土庄严身佛　南无智根本华幢佛　南无化称佛　南无一切色摩尼藏佛　南无法藏自在佛　南无法献婆婆罗佛　南无无边宝功德藏佛　南无净华声佛　南无大法王钩修摩胜佛　南无一切无尽藏佛　南无功德山藏佛　南无星宿山藏佛　南无虚空智山佛　南无智力天王佛　南无无障碍海随顺智佛　南无无边觉海藏佛　南无智王无尽称佛　南无心意奋迅王佛　南无自清净智佛　南无智自在法王佛　南无差别去佛　南无自在见佛　南无随顺香见法满佛　南无龙月佛　南无因陀罗波罗无障碍王佛　南无智鸡兜佛　南无智灯佛　南无大光明照佛　南无不可胜佛　南无照境佛　南无银鸡兜幢盖佛　南无威德自在王佛　南无觉王佛　南无宝藏佛　南无大娑伽罗佛　南无十力差别佛　南无降伏魔佛　南无降伏贪佛　南无降伏嗔佛　南无降伏痴佛　南无降伏憍慢佛　南无降伏嗔恨垢佛　南无法清净得名佛　南无业胜得名佛　南无如意清净得名佛　南无起施得名佛　南无起清净戒名得佛　南无起忍辱成就得名佛　南无起精进得名佛　南无起禅得名佛　南无起般若得名佛　南无成就施不可思议佛　南无成就戒不可思议佛　南无成就忍辱不可思议佛　南无成就精进不可思议佛　南无成就禅那不可思议佛　南无成就般若不可思议佛　南无行成就得名佛　南无成就陀罗尼清净得名佛　南无陀罗尼色清净得名佛　南无陀罗尼施清净得名佛　南无空无我自在得名佛　南无空行自在得名佛　南无眼陀罗尼自在佛　南无耳陀罗尼自在佛　南无鼻陀罗尼自在佛　南无舌陀罗尼自在佛　南无身陀罗尼自在佛　南无意陀罗尼自在佛　南无色陀罗尼自在佛　南无声陀罗尼自在佛　南无香陀罗尼自在佛　南无味陀罗尼自在佛　南无法陀罗尼自在佛　南无触陀罗尼自在佛　南无地陀罗尼自在佛　南无水陀罗尼自在佛　南无火陀罗尼自在佛　南无风陀罗尼自在佛　南无苦自在佛　南无集自在佛　南无灭自在佛　南无道自在佛　南无阴自在佛　南无界自在佛　南无入自在佛　南无三世自在佛　南无陀罗尼华自在佛　南无吉光明佛　南无香灯衣自在光明佛　南无法幢佛　南无师子声佛　南无照藏佛　南无法明敷身佛　南无一切通光佛　南无月智佛　南无妙胜佛　南无贤胜佛　南无普满佛　南无普贤佛　南无那罗延王佛　南无成就一切义佛　南无住持威德佛　南无无畏观佛　南无如是等过去未来现在无量无边诸佛　南无十千同名满足佛　南无三万同名能圣佛　南无二千同名拘邻佛　南无十八亿同名实体法式佛　南无十八亿同名日月灯佛　南无千五百同名大威德佛　南无一万五千同名欢喜佛　南无八万四千同名龙王佛　南无一万五千同名日佛　南无一万八千同名娑罗王佛　南无一万八千同名因陀罗幢佛　南无八千同名善光佛　南无八百同名寂灭佛

南无三十六亿十一万九千五百同名净王佛。此诸佛名百千万劫不可得闻如优昙钵华。若复有人受持读诵此诸佛名。毕竟远离诸烦恼

舍利弗。汝等应当敬礼波头摩胜如来

南无寂王佛　南无灯作佛　南无天光佛　南无德山佛　南无胜上佛　南无娑罗王佛　南无净王佛　南无大慧梁佛　南无须弥佛　南无大智慧须弥佛　南无宝作佛　南无宝藏佛　南无破金刚佛　南无贤智不动佛　南无普香佛　南无甘露命佛　南无难胜佛　南无月光佛　南无日照佛　南无智鸡兜佛　南无大师子佛　南无弥留山佛　南无香光佛　南无德山佛　南无大通佛　南无阿摩罗藏佛　南无宝围佛　南无金刚藏佛　南无优波罗藏佛　南无大日佛　南无桥梁载佛　南无月胜佛　南无乐坚固佛　南无不可思议法身佛　南无胜藏佛　南无不空王佛　南无金刚无碍智佛　南无宝炎佛　南无赊施灯佛　南无降伏一切怨佛　南无自在佛　南无大智真声佛　南无般若香象佛　南无天王佛

舍利弗。若有善男子善女人。闻此诸佛名受持读诵不生疑者。是人八千亿劫不入地狱。不入畜生。不入饿鬼道。不生边地。不生贫穷家不生下贱家。常生天人豪贵之处。常得欢喜适乐无碍。常得一切世间尊重供养。乃至得大涅槃。舍利弗。汝等应当敬礼不可嫌身佛

南无称声佛　南无称威德佛　南无称名佛　南无叶陀佛　南无声炎佛　南无金刚定自在佛　南无声分勇猛佛　南无智胜佛　南无智善知佛　南无智聚佛　南无智勇猛佛　南无梵胜佛　南无净婆薮佛　南无净心佛　南无净天佛　南无净声佛　南无梵自在佛　南无威德佛　南无毗摩胜佛　南无毗摩意佛　南无毗摩面佛　南无毗摩上佛　南无常念一切众生苦佛　南无无边声佛　南无实见佛　南无善眼月佛　南无深声佛　南无放声佛　南无惊怖魔力声佛　南无净眼佛　南无无边眼佛　南无普眼佛　南无胜眼佛　南无不可行佛　南无寂胜佛　南无善寂心佛　南无善寂根佛　南无善寂意佛　南无善寂德佛　南无善住佛　南无众自在王佛　南无大众自在佛　南无众解脱佛　南无法幢佛　南无法山佛　南无法胜佛　南无法体佛　南无法力佛　南无法勇猛佛　南无法体决定佛　南无第二劫中八十亿同名法体决定佛

舍利弗。若有善男子善女人。受持读诵是诸佛名。毕竟不入地狱。速得三昧

舍利弗。过是佛名无量无边阿僧祇劫。有佛名人自在声。汝等应当一心归命。彼人自在声佛。寿命七十千万劫住世。初会三亿声闻众集八十那由他千万菩萨众集。皆得诸神通具四无碍。通达一切空到彼岸。我若无量劫住世。说彼佛大会国土庄严。如大海水中一滴之分

南无三昧定自在佛　南无慧定自在佛　南无相觉自在佛　南无普摄佛　南无宝德普光佛　南无迦罗鸠村大佛　南无意乐美音佛　南无欢喜佛　南无师子音佛　南无师子相佛　南无云自在佛　南无常灭佛　南无帝相佛　南无梵相佛　南无阿弥陀佛　南无度一切世间苦恼佛　南无云自在王佛　南无坏一切世间怖畏佛　南无百亿我释迦牟尼佛　南无弥勒佛　南无净身佛　南无华光佛　南无华足佛　南无光明佛　南无名相佛　南无阎浮那提金光佛　南无法明佛　南无宝明佛　南无普明佛　南无普相佛　南无光相佛　南无普光佛　南无山海慧佛　南无自在通王佛　南无宝庄严佛　南无弗沙佛　南无百亿自在灯王佛　南无喜见佛　南无二万光相庄严王佛　南无三万同号善德佛　南无雷宝音王佛　南无四万八千定光佛　南无宝月王佛　南无离垢光佛　南无妙色光明佛　南无破一切众难佛　南无众香佛　南无众严佛　南无十千庄严光明佛　南无八十亿庄严光明佛　南无宝华庄严佛　南无上首德王佛　南无紫金光明佛　南无五百授记华光佛　南无那罗延不坏佛　南无好华庄严佛

次礼十二部经大藏法轮

敬礼十方诸大菩萨摩诃萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

归命如是等无量无边辟支佛

舍利弗。若有善男子善女人。比丘比丘尼优婆塞优婆夷。能受持读诵此诸佛菩萨名者。终不堕恶道生天人中。常值诸佛菩萨善知识。远离诸烦恼乃至得大菩提。佛说此佛名经已。慧命舍利弗。及摩诃男比丘。及诸比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人。及诸菩萨摩诃萨。皆大欢喜顶受奉行

礼三宝已次复忏悔

弟子等。已忏三途等报。今当复次稽恳忏悔人天余报。相与禀此阎浮寿命。虽曰百年满者无几。于其中间盛年夭枉其数无量。但有众苦煎迫形心。愁忧恐怯未曾暂离。如此皆是善根微弱恶业滋多。致使现在心有所为皆不称意。当知悉是过去已来恶业余报。是故弟子今日至诚归依佛

南无东方大庄严佛　南无南方智慧火佛　南无西方智香胜佛　南无北方智力王佛　南无东南方那罗延胜业佛　南无西南方雨娱乐佛　南无西北方谛法普称佛　南无东北方三乘行佛　南无下方大通智胜佛　南无上方电灯丰王佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始已来至于今日。所有现在及以未来人天之中。无量余报流殃宿对。癃残百疾六根不具罪报忏悔。人间边地邪见三恶八难罪报忏悔。人间多病痟瘦促命夭枉罪报忏悔。人间六亲眷属不能常得相保相守罪报忏悔。人间亲友凋丧爱别离苦罪报忏悔。人间怨家聚会愁忧怖畏罪报忏悔。人间水火盗贼刀兵危崄惊惧恐怯罪报忏悔。人间孤独困苦流离波迸亡失国土罪报忏悔。人间牢狱系闭幽执侧立鞭挞拷楚罪报忏悔。人间公私口舌更相罗染更相诽谤罪报忏悔。人间恶病连年累月不差枕卧床席不能起居罪报忏悔。人间冬温夏疫毒厉伤寒罪报忏悔。人间贼风肿满否塞罪报忏悔。人间为诸恶神伺求其便欲作祸祟罪报忏悔。人间有鸟鸣百怪飞尸邪鬼为作妖异罪报忏悔。人间为虎豹豺狼水陆一切诸恶禽兽所伤罪报忏悔。人间自结自刺自杀自害罪报忏悔。人间自忧自惋自勒自嗔自喜罪报忏悔。人间投坑赴火自沈自坠罪报忏悔。人间无有威德名闻罪报忏悔。人间衣服资生不得称心罪报忏悔。人间行来出入有所云为值恶知识为作留难罪报忏悔。如是现在未来人天之中。无量祸横灾疫厄难衰恼罪报忏悔。弟子。今日至诚向十方佛尊法圣众前。披肝露心求哀忏悔

愿弟子等。承是忏悔所生功德。愿生生世世身相具足。犹如罗睺罗常值佛法僧恒闻妙法。寿命天地等。不为百病之所缠。六亲眷属常得相保护。怨贼刀兵永恒去离。自然衣服箱箧常盈。百味香饭盂中恒满。牢狱闭所化作天堂。口舌相非变成和合。连年之病永去身心。疫毒诸灾恒离意首。妖怪魍魉及以飞鸟虎豹豺狼。水陆诸祸一切等厄皆去无余。或自割刑或自嗔喜。如是等罪愿从今已去乃至成佛已来永相去离。愿弟子等。不为诸恶道之所受报。唯生大悲救护一切众生。使皆尽性广化诸类俱登正觉

    大乘莲华宝达问答报应沙门经

宝达顷前入一剥皮饮血地狱。云何名曰剥皮饮血地狱。其地狱纵广七十由旬。周匝铁城铁网罗覆。城四门上沸铁下流。遍布狱中炎赫炽满。复有机弩在于空中。罪人触突机弩自发射罪人胸。或从眼入或从口入。箭所著处猛火俱起。尔时南门之中有五千罪人。号啼大哭唱如是言。我今何罪来入此处。宛转投地而不肯前。马头罗刹手持铁钩。望面而搭牵入狱中。罪人既入飞火来烧其身。遍身焦烂皮肉相离。乃有诸虫千般种类。来饮其血诸头牵掣皮肉分张。狱卒夜叉就中呙剥。骨肉异处痛切万端。一日一夜受罪无量。千死千生万死万生。经千万劫无有出期

宝达问马头罗刹曰。此诸罪人以何因缘受如是苦。马头罗刹答曰。此诸罪人受佛净戒而不坚持。心无慈悲手剥众生杀害佛性。以此罪故堕是地狱。后若得出当堕畜生中。百千亿生为他所戮。怨仇相对无有了期。若生人中诸根不具。宝达闻之悲泣而去

佛名经卷第二十八佛说佛名经卷第二十九

尔时喜王菩萨白佛言。世尊。今此众中颇有菩萨摩诃萨得是三昧。亦得八万四千波罗蜜门诸三昧门陀罗尼门者不。佛告喜王。今此会中有菩萨大士得是三昧。亦能入八万四千诸波罗蜜及诸三昧陀罗尼门。此诸菩萨于是贤劫中。皆当得阿耨多罗三藐三菩提。除四如来。于此劫中得成佛已。喜王菩萨。复白佛言。唯愿加哀当宣此诸菩萨名号。多所饶益安隐世间利诸天人。为护佛法令得久住。为将来菩萨显示法门。求无上道心不疲懈。佛告喜王。汝今谛听善思念之当为汝说。唯然世尊。愿乐欲闻。尔时世尊即以偈说诸佛名字

南无拘那提佛(为首千佛)　南无拘那含牟尼佛　南无迦叶佛　南无释迦牟尼佛　南无弥勒佛　南无师子佛　南无明炎佛　南无牟尼佛　南无妙华佛　南无华氏佛　南无善宿佛　南无导师佛　南无大臂佛　南无大力佛　南无宿王佛　南无修药佛　南无名相佛　南无大明佛　南无炎肩佛　南无照曜佛　南无日藏佛　南无月氏佛　南无众炎佛　南无善明佛　南无无忧佛　南无提沙佛　南无明曜佛　南无持鬘佛　南无功德佛　南无示义佛　南无灯曜佛　南无兴盛佛　南无药师佛　南无喜濡佛　南无白毫佛　南无坚固佛　南无福威德佛　南无不可坏佛　南无德相佛　南无罗睺佛　南无众主佛　南无梵声佛　南无坚际佛　南无不高佛　南无作明佛　南无大山佛　南无金刚佛　南无将众佛　南无无畏佛　南无珍宝佛　南无华目佛　南无军力佛　南无华光佛　南无仁爱佛　南无大威德佛　南无梵王佛　南无无量明佛　南无龙德佛　南无坚步佛　南无不虚见佛　南无精进德佛　南无善守佛　南无欢喜佛　南无不退佛　南无师子相佛　南无胜智佛　南无法氏佛　南无喜王佛　南无妙御佛　南无爱作佛　南无德臂佛　南无喜意佛　南无观神佛　南无云音佛　南无善思佛　南无善意佛　南无离垢佛　南无月相佛　南无珠髻佛　南无师子步佛　南无德树佛　南无观择佛　南无慧聚佛　南无安住佛　南无有意佛　南无鸯伽陀佛　南无大名佛　南无威猛佛　南无无量意佛　南无妙色佛　南无多智佛　南无光明佛　南无坚戒佛　南无吉祥佛　南无宝相佛　南无莲花佛　南无那罗延佛　南无安乐佛　南无智积佛　南无德敬佛　南无梵德佛　南无宝积佛　南无华天佛　南无善思议佛　南无法自在佛　南无名闻意佛　南无乐说聚佛　南无金刚相佛　南无求利佛　南无游戏佛　南无离闇佛　南无多天佛　南无弥楼相佛　南无众相佛　南无宝藏佛　南无极高行佛　南无提沙佛　南无珠角佛　南无德赞佛　南无日月明佛　南无日明佛　南无星宿佛　南无师子相佛　南无韦蓝王佛　南无福藏佛　南无见有边佛　南无电明佛　南无金山佛　南无师子德佛　南无胜相佛　南无明赞佛　南无坚精进佛　南无具足赞佛　南无离畏佛　南无应天佛　南无大灯佛　南无世明佛　南无妙音佛　南无持上功德佛　南无离闇佛　南无师子颊佛　南无宝赞佛　南无灭过佛　南无珠明佛　南无人月佛　南无喜见佛　南无庄严佛　南无珠明佛　南无山顶佛　南无名相佛　南无法积佛　南无定义佛　南无施愿佛　南无定众佛　南无众王佛　南无游步佛　南无安意佛　南无法差别佛　南无上尊佛　南无极高德佛　南无上师子音佛　南无乐戏佛　南无龙明佛　南无华山佛　南无龙喜佛　南无香自在佛　南无大名佛　南无天力佛　南无德鬘佛　南无龙手佛　南无善行意佛　南无自庄严佛　南无智胜佛　南无无量月佛　南无宝语佛　南无日明佛　南无定意佛　南无无量形佛　南无照明佛　南无宝相佛　南无断疑佛　南无善明佛　南无不虚步佛　南无觉悟佛　南无华相佛　南无山主王佛　南无大威德佛　南无遍见佛　南无无量名佛　南无住义佛　南无宝天佛　南无满意佛　南无上赞佛　南无无垢佛　南无无忧佛　南无梵天佛　南无华相佛　南无身差别佛　南无法明佛　南无尽见佛　南无德净佛　南无月面佛　南无宝灯佛　南无宝相佛　南无上名佛　南无作名佛　南无无量音佛　南无违蓝佛　南无师子身佛　南无明意佛　南无无能胜佛　南无功德品佛　南无月相佛　南无得势佛　南无无边行佛　南无开华佛　南无净垢佛　南无一切义佛　南无勇力佛　南无富足佛　南无福德佛　南无随时佛　南无广意佛　南无功德敬佛　南无善寂灭佛　南无财天佛　南无净断疑佛　南无无量持佛　南无妙乐佛　南无不负佛　南无无住佛　南无得叉迦佛　南无众首佛　南无世光佛　南无多德佛　南无弗沙佛　南无无边威德佛　南无义意佛　南无药王佛　南无断恶佛　南无无热佛　南无善调佛　南无名德佛　南无华德佛　南无勇得佛　南无金刚军佛　南无大德佛　南无寂灭意佛　南无香象佛　南无那罗延佛　南无善住佛　南无无所负佛　南无月相佛　南无电相佛　南无恭敬佛　南无威德守佛　南无智日佛　南无上利佛　南无须弥顶佛　南无治怨贼佛　南无莲华佛　南无应赞佛　南无知次佛　南无离憍佛　南无那罗延佛　南无常乐佛　南无不少国佛　南无天名佛　南无见有边佛　南无甚良佛　南无多功德佛　南无宝月佛　南无师子相佛　南无乐禅佛　南无无所少佛　南无游戏佛　南无德宝佛　南无应名称佛　南无华身佛　南无大音声佛　南无辩才赞佛　南无金刚珠佛　南无无量寿佛　南无珠庄严佛　南无大王佛　南无德高德佛　南无高名佛　南无百光佛　南无喜悦佛　南无龙步佛　南无意愿佛　南无宝月佛　南无灭已佛　南无喜王佛　南无调御佛　南无喜自在佛　南无宝髻佛　南无离畏佛　南无善灭佛　南无梵命佛　南无宝藏佛　南无月面佛　南无净名佛　南无威德寂灭佛　南无爱相佛　南无多天佛　南无须炎摩佛　南无天爱佛　南无宝众佛　南无宝步佛　南无师子分佛　南无极高行佛　南无人王佛　南无善意佛　南无世名佛　南无宝威德佛　南无德乘佛　南无觉相佛　南无喜庄严佛　南无示济佛　南无香象佛　南无众炎佛　南无慈相佛　南无妙香佛　南无坚铠佛　南无威德猛佛　南无珠铠佛　南无仁贤佛　南无善逝月佛　南无梵自在佛　南无师子月佛　南无福威德佛　南无正生佛　南无无胜法佛　南无月观佛　南无宝名佛　南无大精进佛　南无山光佛　南无德聚佛　南无供养名佛　南无法赞佛　南无施名佛　南无电德佛　南无宝语佛　南无求命佛　南无善戒佛　南无善众佛　南无定意佛　南无破有闇佛　南无喜胜佛　南无师子光佛　南无照明佛　南无上名佛　南无利慧佛　南无珠月佛　南无威光佛　南无不破论佛　南无光明佛　南无珠论佛　南无世师佛　南无吉手佛　南无善月佛　南无宝炎佛　南无罗睺守佛　南无乐菩萨佛　南无无光佛　南无至寂灭佛　南无世最妙佛　南无无忧佛　南无十势力佛　南无喜力佛　南无德势力佛　南无得势佛　南无大势士佛　南无功德藏佛　南无真行佛　南无上安佛　南无提沙佛　南无火光佛　南无电明佛　南无广德佛　南无珍宝佛　南无福德明佛　南无造铠佛　南无成手佛　南无善华佛　南无集宝佛　南无大海佛　南无持地佛　南无义意佛　南无善思惟佛　南无德轮佛　南无宝火佛　南无利益佛　南无世月佛　南无美音佛　南无梵相佛　南无众师首佛　南无师子行佛　南无难陀佛　南无应供佛　南无明威德佛　南无大光佛　南无宝名佛　南无众清净佛　南无无边名佛　南无不虚光佛　南无圣天佛　南无智王佛　南无金刚众佛　南无善障佛　南无建慈佛　南无华国佛　南无法意佛　南无风行佛　南无善思惟佛　南无多明佛　南无蜜众佛　南无功德守佛　南无利意佛　南无无惧佛　南无坚观佛　南无住法佛　南无珠足佛　南无解脱德佛　南无妙身佛　南无善意佛　南无普德佛　南无妙智佛　南无梵财佛　南无宝音佛　南无正智佛　南无力得佛　南无师子音佛　南无花相佛　南无智积佛　南无华齿佛　南无功德藏佛　南无名宝佛　南无希有名佛　南无上戒佛　南无无畏佛　南无日月佛　南无梵寿佛　南无一切天佛　南无乐智佛　南无宝天佛　南无珠藏佛　南无德流布佛　南无智王佛　南无无缚佛　南无坚法佛　南无天德佛　南无梵牟尼佛　南无安祥行佛　南无勤精进佛　南无炎肩佛　南无大威德佛　南无瞻卜花佛　南无欢喜佛　南无善众佛　南无帝幢佛　南无大爱佛　南无须蔓色佛　南无众妙佛　南无可乐佛　南无势力行佛　南无善定义佛　南无牛王佛　南无妙臂佛　南无大车佛　南无满愿佛　南无德光佛　南无宝音佛　南无金刚军佛　南无富贵佛　南无师子力佛　南无净目佛　南无迦叶佛　南无净意佛　南无知次第佛　南无猛威德佛　南无大光明佛　南无日光曜佛　南无净藏佛　南无分别威佛　南无无损佛　南无月光佛　南无密口佛　南无持明佛　南无善寂行佛　南无不动佛　南无大赞佛　南无德法佛　南无严土佛　南无庄严王佛　南无高出佛　南无炎炽佛　南无华德佛　南无宝严佛　南无上善佛　南无宝上佛

次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

敬礼声闻缘觉一切贤圣

归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等。敬请十方诸佛。十二部经。一切贤圣。天龙八部法界众生。现前大众等证知。弟子。自从无始已来。所造众罪无量无边。今日至心发露忏悔归依佛

南无东方作戒王佛　南无南方最勇跃佛　南无西方无碍称佛　南无北方龙华德佛　南无东南方无边自在力佛　南无西南方珍宝自在佛　南无西北方莲华自在佛　南无东北方弥楼干那佛　南无下方建立精进佛　南无上方琉璃光最丰佛

归命如是等十方尽虚空界一切三宝

弟子等。自从无始劫来乃至今身。杀害一切三宝师僧父母六亲眷属善知识法界众生不可知数。偷盗一切三宝师僧父母六亲眷属善知识法界众生物不可知数。于一切三宝师僧父母六亲眷属善知识法界众生上起邪心不可知数。妄语欺诳一切三宝师僧父母六亲眷属善知识法界众生不可知数。绮语调弄一切三宝师僧父母六亲眷属善知识法界众生不可知数。恶口骂辱诽谤毁訾一切三宝师僧父母六亲眷属善知识法界众生不可知数。两舌斗乱破坏一切三宝师僧父母六亲眷属善知识法界众生不可知数。或破五戒八戒十戒十善戒二百五十戒五百戒菩萨三聚戒十无尽戒。乃至一切戒及一切威仪戒等。自作教他见作随喜不可知数。如是等众罪。亦如十方大地无边微尘无数。我等作罪亦无边无数。虚空无边我等作罪亦复无边。方便无边我等作罪亦复无边。法性无边我等作罪亦复无边。法界无边我等作罪亦复无边。众生无边我等劫夺杀害亦复无边。三宝无边我等侵损亦复无边戒品无边。我等毁犯亦复无边。如是等罪上至诸菩萨下至声闻缘觉所不能知。唯佛与佛乃能知我罪之多少。今于三宝前法界众生前。发露忏悔不敢覆藏。唯愿十方三宝法界众生听我忏悔

弟子等。从无始劫来所有众恶。以是因缘生大忧苦。贫穷困乏愁热惊惧。怖畏恶业心常怯劣。在在处处暂无欢乐。十方现在大悲世尊。能除众生一切怖畏。愿受我等诚心忏悔。过去诸恶今悉悔过。现在作业诚心发露。所未作者更不敢作已作之业不敢覆藏。身业三种口业有四意三业行今悉忏悔。生死崄难种种淫欲愚烦恼难。如是诸难今悉忏悔。心轻躁难。近恶友难。三有崄难。及三毒难。遇无难难值好时难。修功德难。值佛亦难。如是诸难今悉忏悔

弟子等。今者为诸众生及自己身。十方佛前归命忏悔。一切众生无量劫来。不识诸佛及父母恩。不解善法造作众恶。自恃种性及诸财宝。盛年放逸作诸恶行。心念不善口作恶业。随心所造不见其过。凡夫愚行无知闇覆。亲近恶友烦恼乱心。五欲因缘心生忿恚。不知厌足故作众恶。亲近非圣因生悭嫉。贫穷因缘奸谄作恶。系属于他常有怖畏。不得自在而造诸恶。贪欲恚痴挠动其心。渴爱所逼造作诸恶。依因衣食及以女色诸结恼热。爱他男子染着其心。或于牛马驴骡羊一切禽兽诸色异类而生女想。不依佛行造作诸恶。身口意业所集三业。如是众罪无量无边今悉忏悔。弟子等。自从无始已来至于今日。或不恭敬佛法圣僧。如是众罪今悉忏悔。或不恭敬缘觉菩萨。如是众罪今悉忏悔。以无智故诽谤正法。不知恭敬父母尊长。愚惑所覆憍慢放逸。因贪嗔痴造作诸恶。如是众罪今悉忏悔。好乐饮酒不知止极。或以酒与众僧与持戒人与比丘尼。若灭心人若禅定人。如是等罪无量无边。今日运心归命忏悔

愿弟子等。承是忏悔所生功德。愿生生世世永舍胎藏形。随心愿往生获六神通力。救摄诸苦众。虚空法界尽我愿亦如是。地狱饿鬼一切众生贫穷困厄。及诸有苦烦恼所逼。如是等苦悉令除灭。又愿弟子。承是忏悔所成功德。愿离于生死到大智岸。转无上轮微妙清净。诸所愿求成就具足。又愿盲者得视。聋者得听。哑者能言。裸者得衣。贫穷乏者则得宝藏。仓库盈溢无所乏少。一切皆受安隐快乐。乃至无有一人受苦。又愿众生慈心相向佛眼相看。形貌端严人所喜见。上妙色像庄严其身。为菩提眷属作真善知识

    大乘莲华宝达问答报应沙门经

宝达顷前入一飞火叫唤分头地狱。其地狱纵广六十由旬。周匝铁城铁网覆上。其中铁锵銐如锋铓。猛风吹火烟焰赫奕来烧罪人。尔时东门之中有三万六千罪人。唱如是言。我今何罪来入此处。马头罗刹手捉铁棒望背而打。罪人前入以脚蹴之。罪人狼[跳-兆+旁]步步而倒。铁锵下刺飞火焚烧。或从眼然或从口出。罪人叫唤东西而走。直欲东走飞火逆烧。复欲西驰火还烧面。马头罗刹以手撮罪人头发两手擿之。皮毛皆脱身骨俱碎。乃有饿狗来食其肉。复有饿鬼来饮其血。一日一夜受罪万端。求生不得求死不得。经千万劫受报不了。后若得出常作畜生

宝达问马头罗刹曰。此诸人等何罪所致入于其中。马头罗刹答曰。此诸罪人受佛禁戒而不守持。拔诸禽兽之毛损伤一切品类不曾恩念。所被擒捉之者心神飞扬驰魂走魄。痛切不堪酸楚难忍。而诸人等烂拔毛羽将为快乐。都无慈心亦无惭愧。以是罪故堕此地狱。宝达菩萨闻之悲泣而去

佛名经卷第二十九佛说佛名经卷第三十

南无利慧佛　南无海得佛　南无梵相佛　南无月盖佛　南无多炎佛　南无违蓝王佛　南无智称佛　南无觉相佛　南无功德光佛　南无声流布佛　南无满月佛　南无花光佛　南无花胜佛　南无善成王佛　南无灯王佛　南无电光佛　南无光王佛　南无光明佛　南无具足赞佛　南无华藏佛　南无弗沙佛　南无身端严佛　南无净义佛　南无灭猛军佛　南无福威德佛　南无力行佛　南无罗睺天佛　南无智聚佛　南无调御佛　南无如王佛　南无华相佛　南无罗睺佛　南无大药佛　南无宿王佛　南无药王佛　南无德手佛　南无得叉迦佛　南无流布佛　南无日光佛　南无德藏佛　南无妙意佛　南无德主佛　南无金刚众佛　南无慧顶佛　南无善住佛　南无意行佛　南无梵音佛　南无师子佛　南无雷音佛　南无通相佛　南无慧音佛　南无安隐佛　南无梵王佛　南无牛王佛　南无梨陀目佛　南无龙德佛　南无宝相佛　南无庄严佛　南无不没音佛　南无花德佛　南无音德佛　南无师子佛　南无庄严辞佛　南无勇智佛　南无花积佛　南无华开佛　南无力行佛　南无德积佛　南无上形色佛　南无明曜佛　南无月灯佛　南无威德王佛　南无菩提王佛　南无无尽佛　南无菩提眼佛　南无身充满佛　南无慧国佛　南无最上佛　南无清凉照佛　南无慧德佛　南无妙音佛　南无导师佛　南无无碍藏佛　南无上施佛　南无大尊佛　南无智势力佛　南无制大炎佛　南无帝王佛　南无制力佛　南无威德佛　南无善明佛　南无名闻佛　南无端严佛　南无无尘垢佛　南无威仪佛　南无师子军佛　南无天王佛　南无名声佛　南无殊胜佛　南无大藏佛　南无福德光佛　南无梵声佛　南无灯王佛　南无智顶佛　南无上天佛　南无地王佛　南无至解脱佛　南无金髻佛　南无罗睺日佛　南无莫能胜佛　南无牟尼净佛　南无善光佛　南无金齐佛　南无众德天王佛　南无法盖佛　南无德臂佛　南无鸯伽他佛　南无美妙慧佛　南无微意佛　南无诸威德佛　南无师子髻佛　南无解脱相佛　南无慧藏佛　南无智聚佛　南无威相佛　南无断流佛　南无无碍赞佛　南无宝聚佛　南无善音佛　南无山王相佛　南无法顶佛　南无解脱德佛　南无善端严佛　南无吉身佛　南无爱语佛　南无师子利佛　南无和楼那佛　南无师子法佛　南无法力佛　南无爱乐佛　南无讲不动佛　南无众明王佛　南无觉悟佛　南无妙眼佛　南无意住仪佛　南无光照佛　南无香德佛　南无令喜佛　南无不虚行佛　南无灭恚佛　南无上色佛　南无善步佛　南无大音赞佛　南无净愿佛　南无日天佛　南无乐慧佛　南无摄身佛　南无威德势佛　南无利刹佛　南无德乘佛　南无上金佛　南无解脱髻佛　南无乐法佛　南无住行佛　南无舍憍慢佛　南无智藏佛　南无梵行佛　南无栴檀佛　南无无忧名佛　南无端严身佛　南无相国佛　南无莲华佛　南无无边德佛　南无天光佛　南无慧华佛　南无频头摩佛　南无智富佛　南无梵财佛　南无宝手佛　南无净根佛　南无具足论佛　南无上论佛　南无弗沙佛　南无提沙佛　南无有日佛　南无出泥佛　南无得智佛　南无谟罗佛　南无上吉佛　南无法乐佛　南无求胜佛　南无智慧佛　南无善圣佛　南无网光佛　南无琉璃藏佛　南无名闻佛　南无利寂佛　南无教化佛　南无目明佛　南无善明佛　南无众德上明佛　南无宝德佛　南无人月佛　南无罗睺佛　南无甘露明佛　南无妙音佛　南无大明佛　南无一切主佛　南无乐智佛　南无山王佛　南无寂灭佛　南无德聚力佛　南无天王佛　南无妙音声佛　南无妙花佛　南无住义佛　南无功德威聚佛　南无智无等佛　南无甘露音佛　南无善手佛　南无利慧佛　南无思解脱义佛　南无胜音佛　南无梨陀行佛　南无喜义佛　南无无过佛　南无行善佛　南无花藏佛　南无妙色佛　南无乐说佛　南无善济佛　南无众王佛　南无离畏佛　南无乐智佛　南无辩才日佛　南无名闻佛　南无宝日明佛　南无上意佛　南无无畏佛　南无大见佛　南无梵音佛　南无善意佛　南无慧齐佛　南无无等碍佛　南无金刚军佛　南无菩提意佛　南无树王佛　南无般陀音佛　南无福德力佛　南无势德佛　南无圣爱佛　南无势行佛　南无琥珀佛　南无雷音云佛　南无善爱目佛　南无善智佛　南无具足佛　南无德积佛　南无大音佛　南无法相佛　南无智音佛　南无虚空佛　南无祠音佛　南无慧音差别佛　南无功德光佛　南无圣王佛　南无众音佛　南无辩才论佛　南无善寂佛　南无月面佛　南无日名佛　南无无垢佛　南无功德集佛　南无华德相佛　南无辩才国佛　南无宝施佛　南无爱月佛　南无不高佛　南无师子力佛　南无自在王佛　南无无量净佛　南无等定佛　南无不坏佛　南无灭垢佛　南无不失方便佛　南无无娆佛　南无妙面佛　南无智制住佛　南无法师王佛　南无大天佛　南无深意佛　南无无量佛　南无法力佛　南无世供养佛　南无华光佛　南无三世供养佛　南无应日藏佛　南无天供养佛　南无上智人佛　南无真髻佛　南无信甘露佛　南无金刚佛　南无坚固佛　南无宝肩明佛　南无梨陀步佛　南无随日佛　南无清净佛　南无明力佛　南无功德聚佛　南无具足德佛　南无师子行佛　南无高出佛　南无华施佛　南无珠明佛　南无莲花佛　南无爱智佛　南无槃陀严佛　南无不虚行佛　南无生法佛　南无相好佛　南无思惟乐佛　南无乐解脱佛　南无知道理佛　南无名闻海佛　南无持华佛　南无不随世佛　南无喜众佛　南无孔雀音佛　南无不退没佛　南无断有爱垢佛　南无威仪济佛　南无诸天流布佛　南无宝步佛　南无华手佛　南无威德佛　南无破怨贼佛　南无富多闻佛　南无妙国佛　南无华明佛　南无师子智佛　南无日出佛　南无灭闇佛　南无无动佛　南无次第行佛　南无福德灯佛　南无音声治佛　南无憍昙佛　南无势力佛　南无身心住佛　南无善月佛　南无觉意华佛　南无上吉佛　南无善威德佛　南无智力德佛　南无善灯佛　南无坚行佛　南无天音佛　南无乐安乐佛　南无日面佛　南无乐解脱佛　南无戒明佛　南无住戒佛　南无无垢佛　南无坚出佛　南无安阇那佛　南无增益佛　南无香明佛　南无违蓝明佛　南无念王佛　南无密体佛　南无无碍相佛　南无信戒佛　南无至妙道佛　南无乐宝佛　南无明法佛　南无具威仪佛　南无大慈佛　南无上慈佛　南无至寂灭佛　南无甘露王佛　南无弥楼明佛　南无圣赞佛　南无广照佛　南无威德佛　南无见明佛　南无善行报佛　南无善喜佛　南无无忧佛　南无宝明佛　南无威仪佛　南无乐福德佛　南无功德海佛　南无尽相佛　南无断魔佛　南无尽魔佛　南无过衰道佛　南无不坏意佛　南无水王佛　南无净魔佛　南无众上王佛　南无爱明佛　南无福灯佛　南无菩提相佛　南无智明佛　南无善灭佛　南无梵命佛　南无智喜佛　南无神相佛　南无如众王佛　南无持地佛　南无爱日佛　南无罗睺月佛　南无华明佛　南无药师上佛　南无持势力佛　南无福德明佛　南无喜明佛　南无好音佛　南无法自在佛　南无梵音佛　南无善业佛　南无意无错佛　南无大施佛　南无名赞佛　南无众相佛　南无德流布佛　南无世自在佛　南无德树佛　南无辨意佛　南无灭痴佛　南无无量佛　南无善月佛　南无无边辩相佛　南无梨陀法佛　南无应供养佛　南无度忧佛　南无乐安佛　南无世音佛　南无爱身佛　南无妙足佛　南无优钵罗佛　南无华缨德佛　南无无边辩光佛　南无信圣佛　南无焰炽佛　南无德精进佛　南无真实佛　南无天王佛　南无乐高音佛　南无信净佛　南无婆耆罗陀佛　南无福德音佛　南无炎炽佛　南无无边德佛　南无聚威佛　南无师子游佛　南无不动佛　南无信清净佛　南无行明佛　南无龙音佛　南无持轮佛　南无财成佛　南无世爱佛　南无法名佛　南无无量宝名佛　南无云相佛　南无慧道佛　南无妙音佛　南无虚空音佛　南无虚空佛　南无大王佛　南无珠净佛　南无善财佛　南无灯炎佛　南无实音承佛　南无人主王佛　南无罗睺守佛　南无安隐佛　南无师子意佛　南无宝名闻佛　南无得利佛　南无遍见佛　南无世华佛　南无高顶佛　南无无偏辩才佛　南无差别知见佛　南无师子牙佛　南无梨陀步佛　南无福德佛　南无法灯盖佛　南无目揵连佛　南无无忧国佛　南无意思佛　南无乐菩提佛　南无法天敬佛　南无断势力佛　南无敬势佛　南无慧华佛　南无坚音佛　南无安乐佛　南无妙义佛　南无爱净佛　南无惭愧颜佛　南无妙髻佛　南无欲乐佛　南无楼至佛

此贤劫中诸佛出世名号如是。若人闻此千佛名字。不畏谬错必得涅槃。诸有智者闻诸佛名字。应当一心勿怀放逸。勤行精进无失是缘还堕恶趣受诸苦恼。安住持戒随宜多闻。常不远离具足深忍。是人则能值遇千佛。若持诵此千佛名者。则灭无量阿僧祇劫所集众罪。必当得佛诸三昧神通无碍智慧。及诸法门诸陀罗尼。一切经书种种智慧随宜说法皆当从是三昧中求。修习此三昧。当行净命勿生欺诳。离于名利勿怀嫉妒行六和敬。如是行者疾得三昧法。次礼十二部尊经大藏法轮

敬礼十方诸大菩萨摩诃萨

归命如是等十方世界无量无边诸大菩萨摩诃萨

南无如是诸菩萨等。皆当忆念恭敬礼拜求阿惟越致地

敬礼声闻缘觉一切贤圣

归命如是无量无边辟支佛

礼三宝已次复忏悔

弟子等。已忏悔诸报竟。今当重更总都忏悔诸罪。殷勤启请十方诸佛救护。弟子我等。从无始无量百千万亿劫已来。造作恶业不可具说。或犯十恶或犯五逆及谤方等。或造无量阿僧祇罪。今者归命十方佛。归命十方法。归命十方僧。次复归命稽首东方阿閦佛。南方宝相佛。西方阿弥陀佛。北方妙胜佛。上方香积如来。下方亿像佛。稽首东方普贤大士。南方持世大士。西方观音大士。北方满月大士。上方虚空大士。下方坚德大士。本师释迦牟尼佛。归命未来佛性。又复稽首他方分身化佛大士维摩文殊师利。亦复稽首阿难迦叶出现四道圣人。亦复归命有教初心。稽首大藏十二部经。及于余经方等正典八分舍利形像。亦复归命现有佛事四方天王。忉利释梵三十三天。虚空天上地上地下。有诸山林树下一切神仙。有大神足有天眼者。有天耳者。愿赐闻知皆为证明。愿一切众生若未忏者。得此忏已皆得灭罪。弟子今日忏悔披肝露胆至诚归依佛

南无东方胜意佛　南无南方胜仙佛　南无西方声山佛　南无北方胜光明佛　南无东南方爱清净佛　南无西南方坏众怖畏佛　南无西北方无畏善化佛　南无东北方极受上影王佛　南无下方遇神通王佛　南无上方莲花尊丰王佛

归命如是等十方尽虚空界一切三宝。弟子等自从无始世界已来及今恶身狂惑心乱无量倒见烦恼恶业不可具陈。所作众罪不自觉知。恶心炽盛不见后世。但见现在乐习烦恼远离善根。恶业障碍近恶知识。或于比丘边作非法。比丘尼边作非法。父母边作非法。或复大众前作非法。或复自在用僧鬘物。或于五部僧边。或作是非或说世间无量恶果。或杀菩提善根众生。或谤法师。法说非法非法说法。谓如来无常正法无常僧宝无常。不乐惠施信受邪法。如是等罪无量无边。是故今日无量怖畏无量惭愧。归依三宝。诸佛慈悲方等父母菩萨知识。听许我等今日发露忏悔

弟子等。自从无量劫来造作五逆。或犯过去未来现在诸佛禁戒。作一阐提行。发粗言诽谤正法。造是重业未曾改悔心无惭愧。或犯十恶等罪。自知定犯如是重事。本心初无怖畏惭愧嘿受供养。未曾发露。于彼正法未有护惜建立之心。于其中间毁訾轻贱言多过恶。或复说言无佛法僧。或复不信有诸地狱受报。如是等罪无量无边。今日无量怖畏无量惭愧。归依三宝诸佛慈悲方等父母菩萨知识。听许我等发露忏悔

弟子等。自从无量劫来至于今日。或四倒见四重之法说偷兰遮。偷兰遮法说为四重。犯说非犯非犯说犯。轻罪说重重罪说轻。净见不净不净见净。或复邪见赞说世典不敬佛经诸恶论议畜八不净。真是佛语以为魔语。真是魔语以为佛语。或复信受六师所说。或作是言。如来今日已归涅槃三宝无常。身心起惑无量倒见。是故今日无量怖畏无量惭愧。归依三宝。诸佛慈悲方等父母菩萨知识。听许我等发露忏悔

愿弟子等。承是忏悔所生功德。愿生生世世拔济十方一切众生。远离十恶修行十善。所有诸苦使得安止。不可思议阿僧祇众令住十地。若此国土及余世界。所有善法悉以回向。我所修行身口意善。愿于来世证无上道。愿诸女人皆成男子。具足智慧精勤不懈。一切皆行菩萨之道。勤心修集六波罗蜜。若此阎浮及余他方无量世界所有众生。所作种种善妙功德。我今深心随其欢喜。我今以此随喜功德及身口意所作善业。愿于来世成无上道。得净无垢吉祥果报。悉令具足如来正觉

    大乘莲华宝达问答报应沙门经

马头罗刹语宝达菩萨曰。而此地狱乃有无量。若有比丘。不净靴鞋蹑于方等大乘清净香室。当堕铁[金*疾][金*離]地狱。若有比丘。心怀嗔恚举手向师生一念恶。堕燃手脚地狱。若有比丘。发声骂师作一恶言堕铜狗地狱。若有比丘。心无慈悲煮汤众生肉者。入铁山地狱。马头罗刹语宝达菩萨曰。如是罪报皆不虚也

宝达悲泣而还摩竭道场。绕佛七匝悲泣而言。此东方铁围山间无量地狱。我当云何而拔此诸罪人等。佛言。宝达。汝作神通往入其中。唤诸罪人悉皆得出。地狱苦恼皆得休息。悉来见我我为说法令使得道

尔时宝达便作神通往诣地狱坐高台上唤诸罪人及阿须轮王。汝等罪人。今不知耶。三界人尊今出于世。大悲普照无不蒙益使出三界。阿须轮王得闻是语生欢喜心。唤诸罪人。我今快乐如囚得赦如死还活。将诸罪人来向宝达菩萨。则化地狱苦痛之处莫不快乐。来诣佛所佛为说法皆得悟道。说此品时二万比丘得阿罗汉道。五千比丘尼得须陀洹果。六千王子得法眼净。八百女人得三禅心。天龙鬼神莫不欢喜而去

    佛说罪业报应教化地狱经

如是我闻。一时佛在王舍城耆阇崛山中。与菩萨摩诃萨及声闻眷属俱。比丘比丘尼优婆塞优婆夷。及诸天龙鬼神等皆悉集会。尔时信相菩萨白佛言。今有地狱饿鬼畜生奴婢贫富贵贱种类若干。唯愿世尊。具演说之。凡有众生闻佛说法。如孩儿得母。如病得医。如裸得衣。如闇得灯。世尊说法利益众生亦复如是

尔时世尊观时已至。知诸菩萨劝请殷勤。则放眉间白毫相光照于世界。地狱休息苦痛安宁。尔时一切受罪众生寻佛光明来诣佛所。绕佛七匝至心作礼。劝请世尊。敷演导化令此众生得蒙解脱

尔时信相菩萨。为诸众生而作发起白佛言。世尊。尔时众生为诸狱卒剉碓斩身。从足斩之乃至其顶斩之以讫。巧风吹活而复斩之。何罪所致。佛言。此人前世坐不信三尊不孝父母。屠儿魁脍斩害众生故获斯罪。复有众生身体顽痹眉须堕落。举身洪烂鸟栖鹿宿

人迹断绝沾污亲族。人不嬉见名之癞病。何罪所致。佛言。以前世时坐不信三尊不孝父母。破坏塔寺剥脱道人。斫射贤圣伤害师长。常不返报复背恩义。常行猪犬淫溢所尊。不避亲疏无有惭愧故获斯罪。复有众生身体长大。聋騃无足宛转腹行。唯食泥土以自活命。为诸小虫之所[口*(一/巾)]食。常受此苦不可堪处。何罪所致。佛言。以前世时为人自用。不信好言善语。不孝父母。反戾时君。若为帝王大臣四镇方伯州郡令长宫禁守护。恃其威势。侵夺民物无有道理。使人穷苦故获斯罪。复有众生两目盲瞎睹无所见。或触树木或堕沟坑。于时死已更复受身亦复如是。何罪所致。佛言。以前世时坐不信罪福障佛光明。缝鹰眼合笼系众生。皮囊盛头不得所见故获斯罪。复有众生。吃嘅喑哑口不能言。若有所说不能明了。何罪所致。佛言。以前世时坐诽谤三尊轻毁圣道。论他好恶求人长短。强诬良善憎嫉贤人故获斯罪

复有众生。腹大颈细不能下食。若有所食变为脓血。何罪所致。佛言。以前世时偷盗僧食。或为大会施设肴馔。故取麻米屏处食之。吝惜己物但贪自有。常行恶心与人毒药。气息不通故获斯罪。复有众生。常为狱卒烧热铁钉贯之百节针之已讫。自然火生焚烧其身悉皆燋烂。何罪所致。佛言。以前世时坐为针师伤人身体不能差病。诳他取物徒令痛苦故获斯罪。复有众生常有镬中。牛头阿婆手捉铁叉。牵着镬中煮之令烂。还则吹活而复煮之。何罪所致。佛言。以前世时屠杀众生。汤灌灭毛不可限量。故获斯罪

复有众生在大城中煻煨齐心。四门虽开到则闭之。东西驰走不能自免。为火烧尽何罪所致。佛言。以前世时焚烧山泽决穴陂池。使诸众生没溺而死。故获斯罪。复有众生常在雪山中。寒风所吹皮肉剥裂。何罪所致。佛言。以前世时横道作贼剥脱人衣。冬月隆寒令他冻死。[利-禾+皮]剥牛羊苦痛难堪。故获斯罪

复有众生。常在刀山剑树之上。若有所捉则便伤割支节断坏。何罪所致。佛言。以前世时屠杀为业烹害众生。刀割剥刺骨肉分离。头脚星散悬于高格秤量而卖。或复生悬痛不可堪。故获斯罪。复有众生五根不具。何罪所致。佛言。以前世时飞鹰走狗弹射鸟兽。或破其头或断其足生灭头翼。故获斯罪

复有众生。癵癖背膢腰臗不遂。脚跛手折不能行步。何罪所致。佛言。以前世时为人疽克行道安锵。或施射科陷坠众生前后非一。故获斯罪。复有众生。或嗔或痴或狂或騃。不别好丑何罪所致。佛言。以前世时饮酒醉乱犯三十六失。后得痴身如似醉人。不别尊卑故获斯罪。好弓刀骑乘为夷人。好杀猎为豺狼。好着驭花入精舍中后为戴角虫。好着长裙后作长尾虫。喜恶口者后作狗。恶口谗刺人及多嗔恚者后为蛇虺。好恶声后为鸱枭。喜祸语后为野狐

目连见一大身众生举体无皮形如肉段乘空而行。佛言。过去自堕其胎已堕地狱故受斯苦。目连见一众生举身无皮纯一肉段。乘空而行乌鸱随而喙食。佛言。过去生中为屠儿者。已堕地狱犹受斯苦

目连见一众生。以铜铁罗网自缠其身。火常炽盛还烧其体乘空而行。佛言。过去生中为捕鱼师。地狱余罪今受此身。网鸟网兔亦复如是

目连见一大身无头众生。两边生目胸前生口。身常流血诸虫[口*(一/巾)]食痛彻骨髓。佛言。过去生中好断虫兽头。已地狱受苦今得此身。目连见一大身众生举身生毛毛利如刀。其毛火燃烧割其体。佛言。过去生中刀剑伤一切之命。地狱余报续受斯苦佛名经卷第三十

    佛说佛名经

次礼十二部尊经大藏法轮

南无阿差末经　南无弥勒下生经　南无修行经　南无无尽意经　南无大云经　南无广博严净经　南无所行赞经　南无十住经　南无海龙王经　南无思益经　南无菩萨处胎经　南无禅行经　南无鸯掘魔罗经　南无菩萨本缘经　南无密迹金刚经　南无佛藏经　南无大树紧那罗经　南无阿毗昙心经　南无大悲分陀利经　南无百喻经　南无大吉义咒经　南无净度经　南无维摩诘经　南无菩萨本行经　南无宝箧经　南无无明罗刹经　南无集一切福德经　南无金光明经

次礼十方诸大菩萨

南无因陀罗德菩萨　南无海天菩萨　南无拔陀波罗菩萨　南无药王菩萨　南无卢舍那菩萨　南无月光菩萨　南无波头摩胜藏菩萨　南无智山菩萨　南无圣藏菩萨　南无不舍行菩萨　南无不空见菩萨　南无妙声菩萨　南无妙声吼菩萨　南无常微笑寂根菩萨　南无波头摩道胜菩萨　南无广思菩萨　南无忧波罗眼菩萨　南无可供养菩萨　南无常忆菩萨　南无住一切悲见菩萨　南无断一切恶法菩萨　南无住一切声菩萨　南无住一切有菩萨　南无住佛声菩萨　南无无垢菩萨　南无勇猛德菩萨　南无净菩萨　南无宝胜菩萨　南无罗网光菩萨　南无断诸盖菩萨　南无能舍一切事菩萨　南无华庄严菩萨　南无月光光明菩萨　南无最胜意菩萨　南无坚意菩萨　南无自在天菩萨　南无胜意菩萨　南无净意菩萨

从此以上一千四百佛十二部经一切贤圣

南无金刚意菩萨　南无增长意菩萨　南无善住菩萨　南无善导师菩萨　南无波头摩藏菩萨　南无陀尼自在王菩萨　南无普行菩萨　南无觉菩提菩萨　南无归

如是等十方无量无边菩萨

次礼声闻缘觉一切贤圣

南无实辟支佛　南无不可比辟支佛　南无欢喜辟支佛　南无喜辟支佛　南无随喜辟支佛　南无十二婆罗堕辟支佛　南无十同名婆罗辟支佛　南无火身辟支佛　南无同菩提辟支佛　南无摩诃男辟支佛　南无心上辟支佛　南无发净辟支佛　归命如是等无量无边辟支佛

礼三宝已次复忏悔

众等相以。即今我身心寂静无谄无障。正是生善灭恶之时。复应各起四种观行。以为灭罪作前方便。何等为四。一者观于因缘。二者观于果报。三者观于自身。四者观如来身。第一观因缘者。知我此罪藉以无明。不善思惟无正观力。不识其过远离善友诸佛菩萨。随逐魔道行邪崄迳。如鱼吞钩不知其患。如蚕作茧自萦自缚。如鹅赴火自烧自烂。以是因缘不能自出

第二观于果报者。所有诸恶不善之业。三世流转苦果无穷。沉溺无边巨夜大海。为诸烦恼罗刹所食。未来生死冥然无崖。设使报者转轮圣王。王四天下飞行自在七宝具足。命终之后不勉恶趣。四空果报三界尊极福尽。还作牛领中虫。况复其余无福德者而复懈怠不勤忏悔。此亦譬如抱石沉渊求出良难

第三观我自身。虽有正因灵觉之性。而为烦恼黑暗丛林之所覆蔽。无了因力不能得显。我今应当发起胜心。破切无明颠倒重障。断灭生死虚伪苦因。显发如来大明觉慧。建立无上涅槃妙果

第四观如来身。无为寂照离四句绝百非。众德具足湛然常住。虽复方便入于灭度。慈悲救接未曾暂舍生。如是心可谓灭罪之良津除障之要行。是故弟子今日至诚归依佛

南无东方胜藏珠光佛　南无南方宝积示现佛　南无西方法界智灯佛　南无北方最胜降伏佛　南无东南方龙自在王佛　南无西南方转一切生死佛　南无西北方无边智自在佛　南无东北方无边功德月佛　南无下方海智神通佛　南无上方一切胜王佛　如是十方尽虚空界一切三宝

弟子等。无始以来至于今日。长养烦恼日深日厚日滋日茷。覆盖慧眼令无所见。断除众善不得相续。起障不得见佛不闻正法不值圣僧。烦恼起障不见过去未来一切善恶业行烦恼障。受人天尊贵之烦恼障。生色无色界禅定福乐之烦恼障。不得自在神通飞腾隐显遍生十方诸佛净土听法之烦恼障。学安那般那数息不净观诸烦恼障。学慈悲喜舍因缘烦恼障。学七方便三观义烦恼障。学四念处暖顶忍烦恼。学闻思修第一法烦恼障。学空平等中道解烦恼障。学念道示相诸烦恼障。学七觉支不示相烦恼障。学于道品因缘观烦恼障。学八解脱九空之烦恼障。学于十智三三昧烦恼障。学三明六通四无碍烦恼障。学六度四等烦恼障。学四摄法广化之烦恼障。学大乘心四弘誓愿烦恼障。学十明十行之烦恼障。学十回向十愿之烦恼障。初地二地三地四地明解之烦恼障。五地六地七地诸知见烦恼障。学八地九地十地双照之烦恼障。如是乃至障学佛果百万阿僧祇诸行上烦恼。如是行障无量无边。弟子今日至到稽恳向十方佛尊法圣众惭愧忏悔愿皆消灭

愿藉此忏悔障于诸行一切烦恼。愿弟子在在处处自在受生。不为结业之所回转以如意通于一念。须遍至十方净诸佛土摄化众生。于诸禅定甚深境界及诸知见通达无碍。心能普同一切诸法乐说无穷。而不染着得心自在得法自在知慧自在方便自在。令此烦恼及无知结习毕竟永断不复相续。无漏圣道朗然如日(礼佛一拜)

次礼十二部尊经大藏法轮

南无首楞严经　南无菩萨梦经　南无菩萨神通变化经　南无法界体性经　南无密藏经　南无般舟经

从此以上一千七百佛十二部经一切贤圣

南无超日明经　南无中本起经　南无无量经　南无百论经　南无宝梁经　南无善王皇帝经　南无发菩提心经　南无决罪福经　南无大乘方便经　南无法句经　南无蜜蜂王经　南无虚空藏经　南无辟支佛缘经　南无净业障经　南无温室洗浴经　南无太子赞经　南无胜睒经　南无光瑞经　南无法句譬喻经　南无众要阿毗昙经　南无三受经　南无三乘无当经

次礼十方诸大菩萨

南无妙光菩萨　南无无边光菩萨　南无无量明菩萨　南无勇力菩萨　南无普贤菩萨　南无勇智菩萨　南无度难菩萨　南无济神菩萨　南无开化菩萨　南无净智菩萨　南无安神菩萨　南无专通菩萨　南无无边光菩萨　南无金刚慧菩萨　南无宝首菩萨　南无调慧菩萨　南无法藏菩萨　南无龙树菩萨　南无净藏菩萨　南无净眼菩萨　南无大势志菩萨　南无童真菩萨　南无成道菩萨　南无度难菩萨　南无弥陀罗菩萨

次礼声闻缘觉一切贤圣

南无见人飞腾辟支佛　南无可波罗辟支佛　南无秦摩利辟支佛　南无月净辟支佛　南无善智辟支佛　南无修陀罗辟支佛　南无善法辟支佛　南无应求辟支佛　南无髻求辟支佛　南无大势辟支佛　南无修行不着辟支佛　南无舍辟支佛　归命如是等无量无边辟支佛

礼三宝已次复忏悔

弟子等略忏烦恼障竟。命当次第忏悔业障。天业能庄饰世趣在在处处。是以思惟求离世解脱。所以六道果报种种不同。形类各异当知皆是业力所作。所以佛十力中业力甚深。凡夫之人多于此中好起疑惑。何以故尔现见世间行善之人。触向輱轲为恶之者。是事谐偶谓言天下善恶无分。如此计者皆是不能深达业理。何以故尔经中说言有三种业。何等为三。一者现报二者生报三者后报。现报业者现在作善作恶现身受报。生报业者此生作善作恶来生受报。后报业者或是过去无量生中作善作恶。或于此生中受或在未来无量生中方受其报。向者行恶之人现见好。此是过去生中报后报善业熟故。所以现在有此乐果焉关现在作诸恶业而得好报。行善之人现在见苦者是过去生中生报后报恶业熟故。现在善根力弱不能排遣。是故得此苦报焉关现在作善而招恶报。何以知然现在世间为善之者为人所赞叹人所尊重。故知未来必招乐果过去既有如此恶业。所以诸佛菩萨教令亲近善行共行行忏悔善知诸者于得道中则为令利。是故弟子等今日至诚归于依佛

南无东方无量离垢佛　南无南方树根花王佛　南无西方莲华自在佛　南无北方金刚能破佛　南无东南方悉檀义胜佛　南无西南方金海自在王佛　南无西北方无边法自在佛　南无东北方无碍香象王佛　南无下方无碍慧幢佛　南无上方甘露上王佛　如是十方尽虚空界一切三宝

弟子等。无始以来至于今日。积恶如恒沙造罪满天地。舍身与受身不觉亦不知。或作五逆深厚浊缠无间罪业。或造一阐提断善根业。轻诬佛语谤方等业。破灭三宝毁正法业。不信罪福起十恶业。迷真返正痴惑之业。不孝二亲反戾之业。轻慢师长无礼敬业。朋友不信不义之业。或作四重六重八重障圣道业。毁犯五戒破八斋业。五篇七聚多缺犯业。优婆塞戒轻重垢业。或菩萨戒不能清净如说行业前后方便污梵行业。月无六斋懈怠之业。年三长齐不常循业。三千威仪不如法业。八万威仪微细罪业。不循身戒心真之业。春秋八王造众罪业。行十六种恶律仪业。于苦众生无愍伤业。不矜愍业不拔不济无救护业。心怀嫉忌无度彼业。于怨亲境不平等业。耽荒五欲不厌离业。或因衣食园林池治生荡逸业。或以盛年放恣情欲造众罪业。或善有漏回向三有障出世业。如是等业无量无边。今日发露向十方佛尊法圣众皆悉忏悔

愿弟子等。承是忏悔无间等罪诸业所生福善。愿生生世世灭五逆罪除一阐提。或有如是轻重诸罪从今以去乃至道场誓不更犯。恒习出世清净善法。精持律行守道护威仪。如度海者爱惜浮囊六度四等常檦行道戒定慧品。转得增明速成如来三十二相八十种好十力无大悲三念常乐妙智八自在我(作礼一拜)

佛说佛名经卷第二

次礼十二部尊经大藏法轮

南无弥勒上生经　南无陀罗尼经　南无小泥洹经　南无摩登伽经　南无十轮经　南无五戒经　南无不退轮经　南无入大乘论经　南无付法藏经　南无楞伽经　南无楞伽阿拔多罗经　南无大夫经　南无善臂菩萨经　南无弥勒发问经　南无法自在王经　南无胜鬘经　南无文殊师利经　南无佛说明度经　南无佛说安般经　南无十缘经

从此以上四千九百佛十二部经一切贤圣

南无佛说般泥洹经　南无佛说决定比尼经　南无佛说观弥勒菩萨生兜率天经　南无佛说危脆经　南无相续解脱经　南无宝车经　南无千佛名目七十佛名经　南无僧忍经　南无车匿经

次礼十方诸大菩萨

南无日藏菩萨　南无不缺意菩萨　南无观世音菩萨　南无满尸利菩萨　南无执宝印菩萨　南无常举手菩萨　南无弥勒菩萨　南无敬首菩萨　南无觉首菩萨　南无宝首菩萨　南无惠首菩萨　南无德首菩萨　南无目首菩萨　南无明首菩萨　南无法首菩萨　南无智首菩萨　南无贤首菩萨　南无法慧菩萨　南无功德林菩萨　南无金刚幢菩萨　南无金刚藏菩萨　南无善财童子菩萨　南无转不退法轮菩萨　南无发心即转法轮菩萨　南无离垢净菩萨　南无除诸盖菩萨　南无示威仪见皆爱喜菩萨　南无妙相严净王意菩萨　南无不诳一切众生菩萨　南无无量功德海意菩萨　南无诸根常定不乱菩萨　南无宝意菩萨

次礼声闻缘觉一切贤圣

南无阿利多辟支佛　南无婆梨多辟支佛

南无多伽楼辟支佛　南无称辟支佛　南无见辟支佛　南无爱见辟支佛　南无觉辟支佛　南无乾陀罗辟支佛　南无妻辟支佛　南无梨沙婆辟支佛

礼三宝已次复忏悔

已忏烦恼障已忏悔业障所除报障。今当次第披陈忏悔。经中说言业报至时。非空非海中非入山石间无有地方所所脱之不受报。唯有忏悔力乃能得除灭。何以知然。释提桓因五衰相见。恐惧忉心归诚三宝。五相即灭得延天年。如是等比经教所明。其人若不值善友奖道则靡恶不造致使大。命将尽临穷乏际地狱恶相皆现在前。当尔之时悔惧交至不预修善临穷方悔后将何及乎。殃祸异处宿预严持。当独趣入远到地狱。所住得前行入于火镬。身心损碎精神痛苦。如此之时欲求一礼一忏岂复可得。众生等莫自恃盛年财宝势力。懒墯懈怠于逸自恣。死苦一至无问老少贫富贵贱。皆悉摩灭奄忽而至不令人知失。人命无常喻如朝露出息虽存入息难保。云何以此而不忏悔且互天使者。既来无常杀鬼卒至盛年壮色无得免者。当尔之时华堂邃宇何关人事。高车大马岂得自随。妻子眷属非复我亲。七珍宝饰乃为他玩。以此而言世间果报。皆为幻化。上天虽乐会归败坏寿尽魂逝堕落三涂。是故佛语须跋陀言。法师郁头篮弗利根聪明。能伏烦恼至于非非相处。命终还作畜生道中飞狸之身。况复余者。故知未登圣果已还作应流转备经恶趣。如不谨慎忽尔一朝亲婴斯事将不悔。或如今被罪行诸公门已是小苦情地慞惶眷属恐惧。求救百端地狱众苦比者。此者百千万倍不得为喻。众等相与历劫以来罪若须弥云何闻。此晏然不畏不惊不恐。令此精神复婴斯苦实为可痛。是故弟子等运此单诚归依佛

南无东方调御佛　南无南方金刚藏佛　南无西方登法界佛　南无北方无边眼佛　南无东南方无忧德佛　南无西南方坏诸根佛　南无西北方勇猛伏佛　南无东北方大力光明佛　南无下方欢喜路佛　南无上方香上王佛

弟子等。从无始以来至于今日。所有报障然其重者第一唯有阿鼻地狱。如经所明今当略说其相。此狱周匝有七重铁城。复有七重铁网覆其上下。有七重刀林无量猛火。纵广八万四千由旬。罪人之身遍满其中。罪业因缘不相妨碍。上火彻下下火彻上。东西南北通彻交过。如鱼在熬脂膏皆尽。此中罪苦亦复如是。其城四门有四大铜狗。其身纵广四千由旬牙似锋铓眼如电掣。复有无量铁觜之鸟。奋翼飞腾啖罪人肉牛头。狱卒形如罗刹而有九尾尾如铁叉。复有八头。头上有十八角有六十四眼。一一眼中皆悉迸出诸铁丸烧罪人肉。然其一嗔一怒皆吼之时声如霹雳。复有无量自然刀轮。空中而下从罪人顶入从足而出。于是罪人痛彻骨髓苦忉肝心。如是经无量岁。求生不得求死不得。如是等报今日皆悉稽颡惭愧忏悔。其余地狱刀山剑树身首脱落罪报忏悔。镬汤炉炭地狱烧煮罪报忏悔。铁床铜柱地狱燋燃罪报忏悔。刃轮火车地狱擗擗轹罪报忏悔。拔舌黎耕地狱楚痛罪报忏悔。吞啖铁丸烊铜灌口地狱五内消烂罪报忏悔。铁碓铁磨地狱骨肉灰粉罪报忏悔。黑绳铁铜地狱支节分离罪报忏悔。灰河沸屎地狱恼闷罪报忏悔。碱水寒冰地狱皮肤折裂裸冻罪报忏悔。虎狼鹰犬地狱更相残害罪报忏悔。火坑地距地狱更相抟撮斫刺罪报忏悔。火坑地狱炮炙罪报忏悔。两舌相礚地狱形骸破碎罪报忏悔。众合黑耳地狱解剔罪报忏悔。闇冥肉山地狱斩剉罪报忏悔。锯解钉身地狱断截罪报忏悔。铁棒倒悬地狱屠割罪报忏悔。燋热叫唤地狱烦惋罪报忏悔。大小铁围山间长夜冥冥不识三光罪报忏悔。阿波波地狱阿婆婆地狱阿吒吒地狱阿罗罗地狱。如是八寒八热一切诸地狱。一一狱中复有八万四千鬲子地狱以为眷属。此中罪苦炮[烈-列+暑]楚痛剥皮[方*(色-巴+布)]肉削骨打髓抽肠杖胇无量诸苦。不可闻不可说。南无佛今日在此中者或是我等无始以来经生父母一切眷属我等相与。命终之后或当复堕如此狱中。今日洗心单至到叩头稽颡向十方佛。大地菩萨求哀忏悔。今此一切报障毕竟消灭

愿弟子等承是忏悔。地狱等报所生功德即时破坏。阿鼻铁城悉以净土无恶道名其余地狱一切苦具转为乐缘。刀山剑树变成宝林。镬汤炉炭莲华化生。牛头狱卒除热暴虐。皆起慈悲无有恶念。地狱众生得离苦果。更不造因等受安乐如第三禅。一时俱发无上道心(礼一拜)

次礼十二部尊经大藏法轮

南无八龙天王神咒经　南无和休经　南无罗什譬喻经　南无稻芋经

从此以上五千四百佛十二部经一切贤圣

南无观发诸王恶偈经　南无鹦鹉王经　南无佛说陀邻尼经　南无方便心论经　南无佛说玉耶经　南无钵记经　南无佛说四愿经　南无佛说六字咒王经　南无佛说迦叶经　南无佛说中心经　南无照明三昧经　南无五梦经　南无贤者威仪经　南无法镜经　南无老母人经　南无未曾有经　南无未生怨经　南无弥勒慧经　南无大泥洹经　南无萨和普王经　南无人本欲生经　南无十二因缘经　南无野鸡经　南无我所经

次礼十方诸大菩萨

南无阿罗尼自在王菩萨　南无辩才庄严菩萨　南无须弥顶王菩萨　南无海德宝严净意菩萨　南无大严净菩萨　南无大相菩萨　南无光相菩萨　南无光德菩萨　南无净意菩萨　南无喜王菩萨　南无坚势菩萨　南无坚意菩萨　南无慈王法王子菩萨　南无大目法王子菩萨　南无梵音法王子菩萨　南无妙色法王子菩萨　南无旃檀林法王子菩萨　南无师子吼音法王子菩萨　南无妙声法王子菩萨　南无妙色形根法王子菩萨　南无种种庄严法王子菩萨　南无释幢法王子菩萨　南无顶生法王子菩萨

次礼声闻缘觉一切贤圣

南无闻辟支佛　南无智身辟支佛　南无毗耶离辟支佛　南无俱萨罗辟支佛　南无波苏陀罗辟支佛　南无无毒净心辟支佛　南无实无垢辟支佛　南无福德辟支佛　南无黑辟支佛　南无唯黑辟支佛

礼三宝已次复忏悔

已忏地狱报竟。今当复次忏悔三恶道报。经中佛说多欲之人多求利故苦恼亦多。知足之人虽卧地上犹以为乐。不知足者虽处天堂犹不称意俣。世间人忽有急难便能舍财不计多少。而不知此身临于三涂深坑之上。一息不还便应堕落。忽有知识营功德福令修未来善法资粮。执此悭心无肯作理。夫如此者极为愚惑。何以故尔经中佛说。生时不赍一文而来死亦不持一文而去。苦身积聚为之忧恼。于己无益徒为他有。无善可恃无得可怙。致使命终堕诸恶道。是故弟子等今日稽颡恳到归依佛

南无东方大光曜佛　南无南方虚空住佛　南无西方金刚步佛　南无北方无边力佛　南无东南方无边王佛　南无西南方坏诸怨贼佛　南无西北方金色光音佛　南无东北方离垢光佛　南无下方师子游戏佛　南无上方月幢王佛

如是十方尽虚空界一切三宝

弟子今日次复忏悔畜生道中无所识知罪报。忏悔畜生道中负重牵掣偿他宿债罪报。忏悔畜生道中不得自在为他斫刺屠割罪报。忏悔畜生无足二足四足多足罪报。忏悔畜生道中身诸毛羽鳞甲之内为诸小虫之所唼食罪报。如是畜生道中有无量罪报今日至诚皆悉忏悔

次复忏悔我鬼道中长饥罪报　忏悔饿鬼有千万岁劫不曾闻浆水之名罪报　忏悔饿鬼食啖脓血粪秽罪报。忏悔饿鬼动身之时一切支节火然罪报。忏悔饿鬼腹大咽小罪报。如是饿鬼道中无量苦报今日稽颡皆悉忏悔

复次一切鬼神修罗道中谕謟诈称罪报。忏悔鬼神道中担沙负石填河塞海罪报。忏悔鬼神罗刹鸠般荼诸鬼神生啖血肉受此丑陋罪报。如是鬼神道中无量无边一切罪报。今日稽颡向十方佛大地菩萨求哀忏悔悉令消灭。愿弟子等承是忏悔。畜生等报所生功德。生生世世灭愚痴垢自识业缘。智慧明照断恶道身。愿以忏悔饿鬼等报所生功德　生生世世永离悭贪饥渴之苦。常餐甘露解脱之味。愿以忏悔鬼神修罗等报所生功德。生生世世质直无謟。离邪命因除丑陋果福利人天。愿弟子等从今以去乃至道场决定。不受四恶道报。唯除大悲为众生故。誓愿力处之无厌

(礼一拜)

佛说佛名经卷第六(敬写大佛名经贰佰捌拾捌卷惟愿城隍安泰百姓康宁府主尚书曹公己躬永寿继绍长季含宅枝罗常然庆吉于时大梁贞明陆季岁次庚辰伍月十伍日写记)

    佛说佛名经

南无大智慧见闻皆欢喜佛　南无一切佛宝高胜幢佛　南无法自在吼佛　南无初发心香自在娑罗佛　南无师子奋迅王佛　南无那罗延自在藏弥留胜佛　南无宝山精进自在集功德佛　南无香波头摩精进王成就佛　南无名快照明精进通集佛　南无无碍精进善惟奋迅王佛　南无树提藏佛　南无星宿方便称佛　南无功德力娑罗王佛　南无妙声吼奋迅佛　南无得一切众生意佛　南无大意佛　南无妙声佛　南无宝地山佛　南无法云吼声佛　南无光波婆吒佛　南无无垢光明佛　南无功德迹佛　南无因缘光明佛　南无无边功德王佛　南无瞻波迦花色佛　南无山帝释王佛　南无智德峰王佛　南无德华藏佛　南无不动智佛　南无无碍智佛　南无解脱智佛　南无威仪智佛　南无明相智佛　南无究竟智佛　南无最胜智佛　南无自在智佛　南无梵智佛　南无观察智佛　南无殊特月佛　南无无尽月佛　南无不动月佛　南无风月佛　南无水月佛　南无解脱月佛　南无无上月佛　南无星宿月佛　南无清净月佛　南无明了月佛　南无无住眼佛　南无不动眼佛　南无天眼佛　南无解脱眼佛　南无审谛眼佛　南无明相眼佛　南无最上眼佛　南无绀青眼佛　南无无尽幢佛　南无风幢佛从此已上八千三百佛十二部经一切贤圣

南无解脱幢佛　南无威仪幢佛　南无明相幢佛　南无常幢佛　南无最胜幢佛　南无自在幢佛　南无梵幢佛　南无观察幢佛　南无二万日月灯明佛　南无大通智胜佛　南无十六王子佛　南无空王佛　南无多宝佛　南无二万亿威音王佛　南无云自在登王佛　南无思善佛　南无无数光佛　南无分身诸佛　南无日月净明德佛　南无净华宿王智佛　南无净庄严王佛　南无龙尊王佛　南无云雷音王佛　南无云雷宿王华智佛　南无娑罗树王佛　南无上威德宝王佛　南无百亿定光佛　南无光远佛　南无善山王佛　南无须弥天冠佛　南无须弥等曜佛　南无月色佛　南无正念佛　南无离垢佛　南无无著佛　南无龙天佛　南无不动地佛　南无琉璃妙花佛　南无琉璃金色佛　南无金藏佛　南无炎光佛　南无炎根佛　南无地种佛　南无月像佛　南无日音佛　南无解脱华佛　南无庄严光明佛　南无海觉神通佛　南无水光佛　南无大香佛　南无离尘垢佛　南无舍厌意佛　南无宝炎佛　南无妙顶佛　南无勇立佛　南无功德持慧佛　南无蔽日月光佛　南无日月琉璃光佛　南无无上琉璃光佛　南无最胜上首佛　南无菩提华佛　南无月明佛　南无处世佛　南无华色王佛　南无水月光佛　南无除痴冥佛　南无度盖行佛　南无净信佛　南无善宿佛　南无威神佛　南无善法佛　南无鸾音佛　南无师子音佛　南无龙音佛　南无无量光佛　南无无量寿佛　南无无边光佛　南无无碍光佛　南无无对光佛　南无光炎王佛　南无清净光佛　南无欢喜光佛　南无智慧光佛　南无不断光佛　南无难思光佛　南无无称光佛　南无超日月光佛　南无相好紫金佛　南无远照佛　南无宝藏佛　南无无量音佛　南无甘露味佛　南无龙胜佛　南无胜力佛　南无师子音佛　南无离垢光佛　南无德首佛　南无妙德山佛　南无人王佛　南无无上华佛

从此已上八千四百佛十二部经一切贤圣

南无无畏力王佛　南无龙自在王佛　南无师子衣王佛　南无自在王佛　南无普光佛　南无普明佛　南无普净佛　南无多摩罗跋旃檀香佛

次礼十二部尊经大藏法轮

南无龙王结愿神咒经　南无大乘宝云经　南无如来智印经　南无菩萨为鱼王经　南无礼佛经　南无在家律仪经　南无施色力经　南无舍利弗生西方经　南无莲华色比丘尼经　南无无贫女少施获弘福经　南无礼敬诸塔经　南无八关齐经　南无大力士出家得道经　南无师子畜生王经　南无佛说孝子报恩经　南无八正八邪经

次礼十方诸大菩萨

南无灯手菩萨　南无德明王菩萨　南无分别辩觉菩萨　南无众德庄严菩萨　南无宝手菩萨　南无变动诸法王菩萨　南无无碍眼菩萨　南无天音声菩萨　南无超福聚菩萨　南无心不舍诸慧菩萨　南无除阴盖菩萨　南无合百千德菩萨　南无心无碍菩萨　南无一切行净菩萨　南无等见菩萨　南无金璎珞明德菩萨　南无柔软音响菩萨　南无志得佛声菩萨　南无广心菩萨　南无禅食菩萨　南无得如来住菩萨　南无弃恶法菩萨　南无无量德宝菩萨　南无法雨十方菩萨　南无超山顶菩萨　南无若夜月华菩萨　南无持一切菩萨　南无高贵德王菩萨　南无净住王子菩萨　南无琉璃光菩萨　南无无畏菩萨　南无师子吼菩萨　南无吉意菩萨　南无持意菩萨　南无金刚意菩萨　南无妙心菩萨　南无除慢菩萨　南无离言菩萨　南无三昧游戏菩萨　南无得辩才音声菩萨　南无持宝炬菩萨　南无破魔菩萨　南无观自在菩萨　南无能胜菩萨　南无妙生菩萨　南无大乐说菩萨　南无大海意菩萨　南无欢喜王菩萨　南无无缘观菩萨　南无不邪见菩萨　南无得誓愿菩萨　南无德耀王菩萨　南无善中善菩萨　南无慈仁智菩萨　南无超魔见菩萨　南无净王光菩萨　南无离垢净菩萨　南无天官菩萨　南无天眼菩萨　南无不尽欲菩萨

次礼声闻缘觉一切贤圣

南无优陀夷尊者　南无周陀娑尊者　南无伽陀尊者　南无沓婆摩罗子尊者　南无阿湿嚩寠沙尊者　南无筏苏伴度尊者

礼三宝已次复忏悔

佛告憍陈如。爱有三种。所谓欲爱．色爱．无色爱。何者欲爱。欲名放逸。放逸因缘则生贪触。以触因缘则生乐想。如是等法众生乐着。欲心发动如火所烧。欲因缘故。乐造十恶舍离十善。以是因缘堕于地狱．畜生．饿鬼。生贫穷夜叉中。欲因缘故。于生死中受五阴身具种种苦。虽受是苦不生怖畏心。无惭愧不乐修善。于流转中难得人身。设得人身以欲因缘。身口不净造作无量诸重恶业乃至五无间业。以是因缘复于生死三恶道中。受大重苦。一切受苦皆因欲心集因缘。犹如粪猪被于系缚。趣三恶道受诸苦恼。是故如来为断贪故。宣说正法呵责欲法。若有众生得闻如是呵责欲已。能如实观诸欲不净。如毒生果。如大火聚。如满瓶毒药。如满瓶粪。如利刀。如贼旃陀罗伽絺那。如热铁丸。如大雹雨。如恶毗岚婆风。如恶毒蛇。如恶野泽。如罗刹洲。如跋陀伽都。如种种粪扫聚。如尸陀林。是人如是知欲过患。于欲事中生大怖畏。身大颤动爱法乐法学法。剃除须发身披法服。求于正法求法自在。于正法中生清净心。于法道中行法救济。如是乐者。彼人临终获得正念。以念法故。乐法气味故。念法果报故。见十方佛在大众中。宣说法要教化众生。既闻法已得欢喜心。心欢喜故数数得见诸佛色身。是人死已离三恶道生有佛刹。常与善人游止共俱。能行布施忍辱精进。乐于禅定修习五通。乐涅槃道。大慈悲心。教化众生。能得诸佛璎珞庄严功德之身。过去所有烦恼及习。悉皆尽灭。彼诸众生得如是庄严身心。譬如香箧盛种种衣。衣服皆香而彼香华不失称两不损其色。憍陈如。欲界之中有八大地狱。一一地狱四面各有十六隔子以为眷属。周匝围绕。八大狱者一名一死一活地狱。二名黑绳地狱。三名众合地狱。四名叫唤地狱。五名大叫唤地狱。六名热地狱。七名大热地狱。八名阿鼻地狱。若诸众生自身口意造诸恶业故。生于彼大地狱中。经无量劫受种种苦。从一地狱至一地狱。苦中极苦不可堪忍。身常火燃食热铁丸饮镕铜汁。以其恶业未毕尽故。如是不死畜生之中。或有身如窗中游尘。复有众生身如十千由旬。复有众生寿命如一时顷。复有众生寿命一劫。以恶业故在彼中生。不知善法亦无智慧。常行不善无明黑暗。崄恶道中常受饥渴。捶打乘骑负重困乏。领穿脊破蚊虻毒虫竞相唼食。或有饿鬼身长一尺。或有饿鬼身量如人。或有如千踰缮那。或复有鬼身如雪山。裸形无衣被发自缠。黑瘦羸瘠。唯皮褁骨肉血都无。身体粗涩犹如枯树。恒苦饥渴。口内火然。炎出于外。心常嗔忿无有慈悲。热闷慞惶求凉不得。既念此苦更生重苦。缘苦生苦还造苦因。于未来身复受苦报。如是三恶道苦无量无边。今日至诚皆悉忏悔。法性空中无缚解罪业随心种种生。若能观心无作受。一切业种皆消灭忏悔已归命礼三宝

南无坏诸烦恼佛　南无妙音自在佛　南无大云光佛　南无云自在王佛　南无无缘庄严佛　南无过诸魔界佛　南无见无恐惧佛　南无一切德严佛　南无妙善住王佛　南无莲华藏光佛

从此已上八千五百佛十二部经一切贤圣

南无离畏佛　南无栴檀香佛　南无虚空平等佛　南无无垢鸡兜称佛　南无华庄严光明作佛　南无不动作佛　南无善清净胜佛　南无不可降伏幢佛　南无大奋迅佛　南无广光明王佛　南无无畏智观佛　南无功德王光明佛　南无胜一切佛　南无闻声胜佛　南无伽那伽王光明威德佛　南无宝精进日月光明庄严威德黠声王佛　南无成就一切事佛　南无山峰佛　南无初发心念观一切疑即断烦恼佛　南无宝炎佛　南无大聚佛

次礼十二部尊经大藏法轮

南无金刚结界咒经　南无观世音成佛经　南无智光仙人慈心不食肉经　南无铁城泥梨经　南无三十五佛名功德经　南无凡人三事愚痴不足经　南无鹦鹉闻四谛经　南无大比丘威仪经　南无调达生身入地狱经　南无佛说护口意经　南无猎师舍家学道经　南无琉璃王入地狱经　南无佛为婆罗门说耕田经　南无离车不放逸经　南无比丘于色厌离经　南无舍诸世务经

次礼十方诸大菩萨

南无普吉祥威力菩萨　南无青莲华眼菩萨　南无法印藏菩萨　南无离尘幢菩萨　南无一切佛藏冠菩萨　南无一切化佛光明髻菩萨　南无寂静光菩萨　南无降魔音菩萨　南无佛幢上菩萨　南无虚空胜菩萨　南无势力自在王菩萨　南无普照三世觉菩萨　南无功德山威力菩萨　南无无碍眼菩萨　南无普照法界虚空冠菩萨　南无龙王髻菩萨

从此已上八千九百佛十二部经一切贤圣

南无离垢光菩萨　南无世主音菩萨　南无功德珊瑚上菩萨　南无最胜自在王菩萨　南无法界光明觉菩萨　南无示一切大愿音菩萨　南无金刚智威力菩萨　南无普见眼菩萨　南无超出一切世间冠菩萨　南无梵王髻菩萨　南无震一切法海雷音菩萨　南无福德须弥上菩萨　南无地震音菩萨　南无广大觉菩萨　南无大智居士菩萨　南无善威仪菩萨　南无息一切世间苦安慰音菩萨

次礼声闻缘觉一切贤圣

南无奢利弗呾罗尊者　南无没特伽罗子尊者　南无阿泥楼豆尊者　南无金色饮光尊者　南无末田底迦尊者　南无商那和修尊者　南无优波鞠多尊者　南无弥遮迦尊者

礼三宝已次复忏悔

次忏劫盗之业。经中说言。若物属他他所守护。于此物中一草一叶。不与不取何况盗窃。但自众生唯见现在利故。以种种不道而取。致使未来受此殃累。是故经言。劫盗之罪。能令众生堕于地狱饿鬼受苦。若在畜生则受牛马驴骡骆驼等形。以其所有身力血肉偿他宿债。若生人中为他奴婢。衣不蔽形。食不充命。贫寒困苦。人理殆尽。劫盗既有。如是苦报。是故弟子。今日至到稽首归依佛

南无东方坏诸烦恼佛　南无南方妙音自在佛　南无西方大云光佛　南无北方云自在王佛　南无东南方无缘庄严佛　南无西南方过诸魔界佛　南无西北方见无恐惧佛　南无东北方一切德严佛　南无上方莲华藏光佛　南无下方妙善住王佛如是十方尽虚空界一切三宝

弟子自从无始以来至于今日。或盗他财宝兴刃强夺。或自怙恃身逼迫而取。或恃公威。或假势力。高桁大械枉押良。善吞纳奸货栲直为曲。为此因缘。身罗宪网。或任邪治。领他财物。侵公益私。侵私益公。损彼利此。损此利彼。割他自饶。口与心吝。或窃没租估偷度关税。匿公稞输藏隐使役。如是等罪今悉忏悔。或是佛物僧物不与而取。或经像物或治塔寺物。或供养常住僧物。或拟招提僧物。或盗取误用恃势不还。或自借贷人。或复换贷漏忘。或三宝物混乱杂用。或以众物谷米樵薪盐豉酱醋菜茹果实钱帛竹木缯彩幡盖香香花油烛随情遂意。或自用或与人。或摘佛华果用僧鬘物因三宝财私自利己。如是等罪无量无边。今日惭愧皆悉忏悔

又复无始以来至于今日。或作周旋朋友师僧同学父母兄弟六亲眷属。共住同止百一所须更相欺罔。或于乡邻比近移篱拓墙侵他地宅。改标易相掳掠田园。因公托私夺人邸店及以屯野。如是等罪今悉忏悔

又复无始以来。或攻城破邑烧村坏栅。偷卖良民诱他奴婢。或复抂押无罪之人。使其形殂血刃身被徒锁家业。破散骨肉生离分张异域生死隔绝。如是等罪无量无边。今悉至到皆尽忏悔

又复无始以来至于今日。或商估博货邸店市易轻秤小升减割尺寸。盗窃分铢欺罔圭合以粗易好以短换长。巧欺百端希望毫利。如是等罪今悉忏悔

又复无始以来至于今日。穿踰墙壁断道抄掠。抵捍债息负情违要面欺心口。或非道凌夺鬼神禽兽四生之物。或假托卜相取人财宝。如是乃至以利求利恶求多求无厌无足。如是等罪无量无边。不可说尽。今日至到向十方佛尊法圣众皆悉忏悔愿弟子等承是忏悔。劫盗等罪所生功德生生世世得如意宝。常雨七珍上妙衣卧。百味甘露。种种汤药。随意所须。应念即至。一切众生无偷夺想。一切皆能少欲知足。不耽不染常乐惠施。行急济道。头目髓脑如弃涕唾。回向满足檀波罗蜜。忏悔发愿已归命礼三宝

佛名经卷第十


佛说佛十力经

    No. 781 [No. 780]

佛说佛十力经

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

如是我闻。一时佛在舍卫国祇树给孤独园。与苾刍众俱

是时佛告诸苾刍言。汝等当知如来应供正等正觉。有十种力具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮。何等为十。所谓如来于一切处如实了知。一切非处亦如实知。由实知故是为如来第一处非处智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于过去未来现在。一切有情诸所作业。若事若处若因若报皆如实知。由实知故是为如来第二业智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于诸禅定解脱三摩地。三摩钵底。若染若净。诸定分位皆如实知。由实知故是为如来第三定智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于诸有情。若自若他种种根性皆如实知。由实知故是为如来第四根智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于诸有情种种信解。皆如实知。由实知故是为如来第五信解智力。如来应供正等正觉具是力者。即能了知广大胜处于大众中作师子吼转妙梵轮

复次如来于种种界无数界性。皆如实知。由实知故是为如来第六界性智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于一切至处道。皆如实知。由实知故是为如来第七至处道智力如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来于无数种宿住随念。所谓一生二生。三四五生。或十二十。乃至百生千生。无数百千生中。百千成劫坏劫。成坏等事。我在彼有情中随所生处。如是名字。如是种姓。如是族氏。如是饮食苦乐。如是寿量长短分限。寿命尽已于某处生。此灭彼生。彼灭此生。此等事相缘法方处。无数种类。宿住随念皆如实知。由实知故是为如来第八宿住随念智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来清净天眼过于人眼。观见世间一切有情生时灭时。若好若丑若贵若贱。若生善趣。若生恶趣。随所作业如实知见。若诸有情身语意业。作不善行。毁谤贤圣。起诸邪见。邪见业法合集为因。以彼因缘身坏命终。堕在恶趣地狱中生。若诸有情身语意业。作诸善行。不谤贤圣。起于正见。正见业法合集为因。以彼因缘身坏命终。在于善趣天界中生如是等事皆如实知。由实知故是为如来第九天眼智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

复次如来所有诸漏已尽。非漏随增。心善解脱。慧善解脱。见如是法智证自果。我生已尽梵行已立。所作已办不受后有。皆如实知。由实知故是为如来第十漏尽智力。如来应供正等正觉具是力者。即能了知广大胜处。于大众中作师子吼转妙梵轮

佛说此经已。诸苾刍众闻佛所说。皆大欢喜信受奉行佛说佛十力经


佛说佛医经

    No. 793

佛说佛医经

        吴天竺沙门竺律炎共支越译

人身中本有四病。一者地。二者水。三者火。四者风。风增气起。火增热起。水增寒起。土增力盛。本从是四病。起四百四病。土属身。水属口。火属眼。风属耳。火少寒多目冥。春正月二月三月寒多。夏四月五月六月风多。秋七月八月九月热多。冬十月十一月十二月。有风有寒。何以故。春寒多。以万物皆生。为寒出故寒多。何以故夏风多。以万物荣华阴阳合聚故风多。何以故秋热多。以万物成熟故热多。何以故冬有风有寒。以万物终亡热去故有风寒。三月四月五月六月七月得卧。何以故风多故身放。八月九月十月十一月十二月正月二月不得卧。何以故寒多故身缩。春三月有寒。不得食麦豆。宜食粳米醍醐诸热物。夏三月有风。不得食芋豆麦。宜食粳米乳酪。秋三月有热。不得食粳米醍醐。宜食细米糗蜜稻黍。冬三月有风寒。阳兴阴合。宜食粳米胡豆羹醍醐。有时卧风起有时灭。有时卧火起有时灭。有寒起有时灭。人得病有十因缘。一者久坐不饭。二者食无贷。三者忧愁。四者疲极。五者淫泆。六者嗔恚。七者忍大便。八者忍小便。九者制上风。十者制下风。从是十因缘生病。佛言。有九因缘。命未当尽为横尽。一不应饭为饭。二为不量饭。三为不习饭。四为不出生。五为止熟。六为不持戒。七为近恶知识。八为入里不时不如法行。九为可避不避。如是九因缘。人命为横尽。不应饭为饭。谓不可意饭。亦谓不随四时食。亦为以饭复饭。是为不应饭为饭。不量饭者。谓不知节度多食过足。是为不量饭。不习饭者。谓不时食。若至他郡国。不知俗宜饭食未习。不稍稍饭。是为不习饭。不出生者。谓饭物未消复上饭。若服药吐下不尽便食来。是为不出生。止熟者。谓大便小便来时不即时行。噫吐下风来时制。是为止熟。不持戒者。谓犯五戒。现世间盗。犯他人妇女者。便入县官。或刻或死。或得棓榜压死。若饿死。或得脱外从怨家得首死。或惊怖忧愁死。是为不持戒。近恶知识者。谓他人作恶便来及人。何以故。不离恶知识故。恶人不计当坐之。是为近恶知识。入里不知时不如法行者。谓晨暮行。亦有魍魉诤斗者。若有长吏追捕而不避。若入他家舍。妄视不可视。妄听不可听。妄犯不可犯。妄念不可念。是为入不知时不如法行。可避不避者。谓弊牛马狾狗蚖蛇虫。水火坑阱。犇车驰马。拔刀醉人恶人。亦若干。是为可避不避。如是九因缘。人命未尽为尽。黠人当识。是当避是已避得两福。一者得长寿。及得闻道好语。亦得久行道。佛言。有四饭。一为子饭。二为三百矛斫饭。三为皮革虫生出饭。四为灾饭。子饭者。谓人贪味食肉时。便自校计念。是肉皆我前世时。父母兄弟妻子亲属。亦从是不得脱生死。已得是意便止贪。是为子饭。三百矛斫饭者。谓饭随味念复念其殃。无有数能不念味便得脱。又矛斫人为亡身。已生念复念有若干受苦。为三百矛斫饭。皮革虫生出饭者。谓人念味。亦一切万物忧家中事。便穿人意。意作万端为出去。是为皮革虫生饭。灾饭者。谓一生死行皆为灾饭。如火烧万物。人所行皆当来恼身。剧火焚万物故言灾。所以言饭者。谓人所可意念人。故言饭也。人食肉譬如食其子。诸畜生皆为我作父母兄弟妻子。不可数。亦有六因缘。不得食肉。一者莫自杀。二者莫教杀。三者莫与杀同心。四者见杀。五者闻杀。六者疑为我故杀。无是六意得食肉。不食者有六疑。人能不食肉者。得不惊怖福。佛言。食多有五罪。一者多睡眠。二者多病。三者多淫。四者不能讽诵经。五者多着世间。何以故。人贪淫人知色味。嗔恚知横至味。痴人知饭食味。律经说。人贪味味复味得生不得美味。佛言。一食者为欲断生死亦随贪不能行道。为得天眼自知所从来生去至何所。人不念死多食。常念妇人。皆堕百四十恶。中天皆用饭故。犯十恶后生便失人形。堕畜生中。既得作人。饥渴血出。嗔恚傍生于爱内生于贪。佛说有大福。自饥以饭与人。令人得命。是为大福。后生饶饮食乏嗔恚。亦无所施施亦不得。但意恣贪淫。亦无所施。但得意恣。非我所有。一钱以上。不得取故。作贪欲空自苦作罪。道人不有忧愁。忧随怒愁随贪。我辈有死岁。有死月。有死日。有死时。亦不知亦不畏。亦不行道。亦不持戒。东走西走。忧铜忧铁。忧田宅奴婢。但益人恼增人苦。为种畜生习。佛言。人治生。譬如蜂作蜜。采取众华。勤苦积日已成。人便攻取去。唐自苦不得自给。人求是念是忧有忧无饥渴勤苦。合聚财物。未死忧五家分。或水火盗贼县官病痛。多不如意。己死他人得之。身当得其罪。毒痛不可言。五分者。一者火分。二者水分。三者盗贼分。四者县官分。五者贫昆弟分。何为无忧所有。人不计是五分忧。苦剧不弃。是忧苦有万端。结在腹中。离道远法。人法生贾作。得利不当喜。不得利亦不当忧。是皆前世宿命所致。人有贪贪便不得利。正使得一天下财物。亦不能猛自用之。亦不随人去。但益人结。但有苦恼。但种后世缘因。缘因如火。如火无所不烧。我辈不觉。是黠不敢妄摇。知为增苦种罪佛说佛医经


佛说佛印三昧经

    No. 621

佛说佛印三昧经一卷

        后汉安息国三藏安世高译

佛在罗阅只耆阇崛山中。时摩诃比丘僧万二千人皆阿罗汉。时诸菩萨有四百亿万人。皆贤者如弥勒辈也。及八方上下诸菩萨。稍增无央数不可复计。皆飞到佛所。前以头面着佛足。起绕佛七匝却坐。上下相次。百亿万重不可复胜数。文殊师利菩萨最高才第一。光明智慧与诸菩萨绝异。无能及者。时佛坐三昧。佛身神外衣中衣。佛坐光照悉不现。即八方上下无数佛国悉皆明。诸有佛国。皆自然供养诸佛菩萨及辟支佛罗汉诸比丘僧。八方上下无数诸佛。各遣诸菩萨。飞到佛所。坐处边坐。诸菩萨皆会。其数如恒水边流沙。一沙者为一菩萨。如是四十恒边沙。皆悉上下相次。一菩萨者。自然坐一大莲华上。佛都却化天地界。数千万里诸菩萨皆坐。满其中已。弥勒菩萨等及舍利弗。即前叉手。问文殊师利菩萨言。仁者最高才。佛向者三昧。今皆不现不知所至。疑当有意。愿欲闻之。文殊师利谓弥勒言。仁者高才。且暮当作佛。舍利弗者卿是佛弟子得罗汉道最智慧才猛。何不各自一心坐禅推索佛身神知何如行乎。即诸菩萨及阿罗汉等。无央数皆坐一心推索八方上下无数诸佛国无穷无极。无有能知佛身神处者。弥勒菩萨等。舍利弗等。复长跪叉手。问文殊师利菩萨。我等一心推索佛身神。无能知处者。愿欲知其说。文殊师利言。皆悉安坐须臾顷。自当来还。闻佛还剧坐。座中皆见佛来还时皆欢喜。起为佛作礼。礼弥勒菩萨等。舍利弗等。前长跪叉手问佛。向者三昧时。佛身神外衣中衣皆悉不现。亦不知如行。我等共一心禅索佛身神。八方上下无穷无极。了不知佛处。愿从佛闻。佛言。所至到处者大深。非汝曹所知也。独诸佛自知之耳。佛言。三昧者甚难值也。与相值闻知者。甚快不可言也。所以者何。甚难闻也。佛言。诸菩萨求道奉行六波罗蜜不毁失。千亿万劫尚不能得。值佛三昧时。亦不能得闻知佛三昧名也。复行六波罗蜜精进不懈。三千亿万劫。闻佛三昧名与相值。尚复不信向之有也。复行六波罗蜜不毁失。七千亿万劫闻佛三昧者。尚复不信向之有也。复行六波罗蜜不毁失。八千亿万劫。闻佛三昧名者。乃信向值之耳。信向有者。一时之间若与相值者。心中欢喜踊跃。一日一夜。胜复行六波罗蜜却后三千亿万劫也。所以者何。闻知三昧者。其后求道得佛疾。佛三昧名者。是摩诃般若波罗蜜经智慧印也。菩萨求道。得闻摩诃般若波罗蜜经智慧印者。大善不可得闻也。菩萨求道欲得作佛。要当得摩诃般若波罗蜜经。摩诃般若波罗蜜经者。是八方上下诸佛大父母也。得摩诃般若波罗蜜经。乃得作佛耳。菩萨求道。要当积功累德满。乃闻摩诃般若波罗蜜经耳。菩萨求道。不得摩诃般若波罗蜜经者。不得作佛也。佛言。其有善男子善女人。信向有佛三昧经名。对其跪拜慈心欢喜者。其人即得其福。后世亦复得其福。寿终尽生天上作天王。寿尽下生世间。复作遮迦越王。如是寿终生天上。天上寿终下生王侯家。展转天道人道中。终不复更泥犁禽兽薜荔鬼神龙。却后无数劫皆当作佛。其有闻三昧名。小有狐疑不信大如毛发者。其人寿终已入十八泥犁中。烧煮终无有出时。然后得出。求道者未央作佛也。所以者何。佛三昧经。是八方上下诸佛要决印明也。佛言。我所语如是。汝曹皆当信之无得疑也。谁当证明之者。独有四十恒水边流沙诸菩萨。是我小弟皆证明之耳。佛说经已。文殊师利菩萨等弥勒菩萨等。舍利弗阿罗汉等。及诸天人民。闻经皆大欢喜。起为佛作礼佛说佛印三昧经


佛说父母恩难报经

    No. 684

佛说父母恩难报经

        后汉安息国三藏安世高译

闻如是。一时婆伽婆。在舍卫城。祇树给孤独园。尔时世尊。告诸比丘。父母于子。有大增益。乳餔长养。随时将育。四大得成。右肩负父。左肩负母。经历千年。正使便利背上。然无有怨心于父母。此子犹不足报父母恩。若父母无信教令信。获安隐处。无戒与戒教授。获安隐处。不闻使闻教授。获安隐处。悭贪教令好施。劝乐教授。获安隐处。无智慧教令黠慧。劝乐教授。护安隐处。如是信如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。教信法教授。获安隐处。诸法甚深。现身获果。义味甚深。如是智者。明通此行。教令信圣众。如来圣众。甚清净行。直不曲常和合。法法成就。戒成就。三昧成就。智慧成就。解脱成就。解脱见慧成就。所谓圣众。四双八辈。是谓如来圣众。最尊最贵。当尊奉敬仰。是世间无上福田。如是诸子。当教父母行慈。诸比丘有二子。所生子所养子。是谓比丘有二子。是故诸比丘。当学所生子。口出法味。如是诸比丘。当作是学。尔时诸比丘。闻佛所说。欢喜奉行佛说父母恩难报经


佛说妇人遇辜经

    No. 571

佛说妇人遇辜经

        乞伏秦沙门圣坚译

闻如是。一时佛在舍卫国祇树给孤独精舍。与大比丘众千二百五十人俱。时有一人无妇。往诣舍卫国。娶妇本国。自有两子。大子七岁。次子孩抱。母复怀躯。欲向在产。天竺礼俗。妇人临月。归父母国。时夫妇乘车载二子。当诣舍卫。中路食息并牧牛。时有毒蛇。缠绕牛脚。牛遂离圈。其夫取牛。欲得严发。见牛为毒蛇所杀。蛇复舍牛。复缠夫杀。妇遥见之。怖惧战栗。啼哭呼天。无救护者。日遂欲冥。去道不远。有流河水。水碓有家居。妇迫日冥。惧为贼所劫。弃车将二子到水畔。留大子着水边。抱小子渡水。适到水半。狼食其子。子叫呼母。母时还顾见子。为狼所啖。惊惶怖惧。失抱中子。随水堕流。母益懊恼。迷惑失志顿踬水中。堕所怀子。遂便渡水。问道行人。我家父母。为安隐不。行人答曰。昨家失火皆烧。父母悉尽无余。又问行人。我夫家姑妐为安隐不。行人答曰。昨有剧贼。伤害其家。姑妐皆死。无完在者。其母闻之。愁忧怖惧。心迷意惑。不识东西。脱衣裸形。迷惑狂走。道中行人。见大怪之。谓得邪病。鬼神所娆乎。或谓愁忧迷惑失志。或有唾贱舍避之走。或有怜伤愍念哀之。时佛在舍卫祇树给孤独精舍。时妇驰走。而往趣之。过祇树园。尔时世尊。大会说法。四辈弟子。诸天龙神。十方一切。皆悉听经。诸佛之法。盲者见佛。皆得眼目。聋者得听。哑者能言。疾病除愈。尪劣强健。被毒不行。心乱得定。时妇见佛。意即得定。不复愁忧。自视裸形。惭愧伏地。佛呼阿难。取衣与妇。即时受教。则取衣与妇。着衣竟稽首佛足。却坐一面。佛即说经。为现罪福。人命无常。合会有别。生者有死。无生不终。一切本空。自作起灭。展转五道。譬如车轮已解本无不复起分。妇闻佛言。心开意解。即发无上正真道意。即时得立不退转地。愁忧除愈。如日无云。佛说如是。四辈欢喜。诸天龙神。稽首而退佛说妇人遇辜经


佛说腹中女听经

    No. 563 [Nos. 562, 564]

佛说腹中女听经

        北凉天竺三藏昙无谶译

佛在罗阅只。与诸菩萨比丘僧比丘尼。优婆塞优婆夷。及诸天人民无央数共会。听佛说经。时会中有迦罗妇怀妊在座。腹中子叉手听经。佛欲使众会见之。便现大光明。照迦罗妇。座中众人。皆见腹中女叉手听经。如照镜无有异。佛持八种声。问腹中女言。汝叉手听经。何以故尔。女用佛威神。即答佛言。以世间人皆行十恶。欲令行十善。是故叉手听经。又以世间人贪淫嗔恚愚痴生死不绝。是故叉手听经。复用世间人不孝顺父母。不供养沙门婆罗门道人。是故叉手听经。时女说是语竟便生。譬如太子从右胁生。地为六反震动。虚空中有无央数天。自然有音乐声。雨天众华。有自然千叶莲华。大如车轮。以宝作茎。状如青琉璃。女即坐莲华上。忉利天王释持天衣。从虚空中来下与女言。裸形可取此衣着之。女报言。我不着此衣。汝欲装挍我耶。汝为罗汉我为菩萨。汝非我辈不与我同类。我自当有衣来。佛语拘翼。此不为装挍菩萨。发心为菩萨。自致得三十二相八十种好。尔乃为装挍菩萨耳。舍利弗白佛言。此女为从何国来。当送衣也。佛言。此女从东南方佛刹来。其国名清净。去此十万佛刹。女从本刹来欲见佛。自当有持衣来者。本国衣便自然在虚空中来。萧肃有声。女见衣来便着之。当得五通。又女本国人尽得五通。女得衣着讫。便从莲华上。下行至佛前。女一举足。地为六反震动。便头面着地。为佛作礼。三言南无佛。绕佛已讫。便长跪白佛。今座中大有诸迦罗妇。愿佛为说经。令得男子身。佛言。我亦不使汝作男子。亦不使汝作女人。皆自从身行得。佛言。有一事可疾得男子。何等为一。发心为菩萨道。是为一事。又女人身当内自观。譬如机关骨节相柱。但筋皮上。女人常畏人。譬如鸱枭蛇蚖虾蟆。不敢昼日出。常畏人譬如婢使。常与恶露臭处俱。虽是国王女。犹复畏人。女人众恶亦复如是。时座中迦罗妇七十五人。闻佛说经欢喜踊跃。前以头面着地。为佛作礼。白佛言。我愿发菩萨心作男子。我不得男子身终不起。时七十五迦罗越。从舍卫国来至佛所。见诸妇皆在佛前。便心念言。失我曹妇已。便问舍利弗。此女人悉是我曹妇何为是间。舍利弗答言。欲作比丘尼。卿当听不。迦罗越答言。若欲作比丘尼者。先使我曹作比丘僧。舍利弗白佛言。是七十五迦罗越。皆欲作比丘。佛呼善男子来。皆作比丘。头发自然堕。袈裟便着身。手持应器。皆前为佛作礼。时七十五妇。各脱珠环。皆以散佛上。便自然虚空中。化作七十五交露珠璎帐。帐中有七宝床。床上有坐。佛边有无央数菩萨听经。七十五妇人见是变化。皆大欢喜。即用佛威神。飞住虚空。虚空中自然有华。雨散佛上。从虚空中来下。便得男子身。前白佛言。我愿作比丘。佛语弥勒菩萨。将去授戒。弥勒菩萨即授戒。作比丘僧女。自然有化华盖七重。其茎如莲华茎。即持与母言。佛是天上天下度人之师。母以华盖上佛。是天上天下之师。盖上之后。母亦当为天下之盖。女语母言。今当发菩萨心。母答女言。我始怀汝时。于梦中常见佛及法比丘僧。无复贪淫嗔恚愚痴心。身体安隐。知我腹中子。为是菩萨摩诃萨。以是令我安隐。尔时发菩萨心已。母得华盖便持上佛。地为六反震动。佛语舍利弗。四天下星宿尚可知数。是女前后所度父母。不可知数。女言。一切人谓我是女。当作至诚行。便化作如八岁沙弥身。当佛说经及女变化时。无央数人。皆发无上正真道意。佛说经竟。皆大欢喜佛说腹中女听经


佛说观佛三昧海经

    No. 643

佛说观佛三昧海经卷第一

        东晋天竺三藏佛陀跋陀罗译

    六譬品第一

如是我闻。一时佛住迦毗罗城尼拘楼陀精舍。尔时释摩男。请佛及僧供养三月。七月十五日僧自恣竟。尔时父王阅头檀。佛夷母憍昙弥。来诣僧房供养众僧。礼拜既毕奉上杨枝及澡豆已。呼阿难言。吾今欲往至世尊所。为可尔不。尔时阿难即宣此言。以白世尊。佛告阿难。父王来者必问妙法。汝行遍告诸比丘僧。及往林中命摩诃迦叶。舍利弗。目揵连。迦栴延。阿那律等。弥勒菩萨。跋陀婆罗十六贤士。一时来会。如此音声遍至诸方。尔时天主夜叉主。乾闼婆主阿修罗主。迦楼罗主紧那罗主。摩睺罗伽主龙主等及诸眷属。皆悉已集。尔时父王及释摩男。三亿诸释入佛精舍。当入之时见佛精舍如颇梨山。为佛作礼。未举头顷。即见佛前有大莲华众宝所成。于莲华上有大光台。父王见已心生欢喜叹未曾有。绕佛三匝却坐一面。是时父王即从坐起白佛言。世尊。佛是吾子吾是佛父。今我在世见佛色身。但见其外不睹其内。悉达在宫相师皆见三十二相。今者成佛光明益显。过踰昔日百千万倍。佛涅槃后后世众生。当云何观佛身色相。如佛光明常行尺度。惟愿天尊今当为我及后众生分别解说

尔时世尊入遍净色身三昧。从三昧起即便微笑。诸佛笑法有五色光。时五色光化五百色。从佛口出照父王顶。从父王顶照光明台。从光明台照于精舍。遍娑婆界还入佛顶。尔时世尊告父王言。谛听谛听善思念之。如来当说来世众生得见佛法。父王白佛。唯然世尊。我今愿听。佛告父王。阎浮提中有师子王。名毗摩罗。其师子法。满四十年牝牡乃会。一交会已跳踉鸣吼。婉转自扑体无损伤其师子子在胎之时。如父兽王等无有异。大王当知。欲使胎中便能鸣吼飞落走伏。未有斯事。父王白佛。兽王之子在母胎时。头目牙爪与父相似。佛告大王。与父无异。但其力能不及其父百千万倍。佛告父王。如是如是。未来世中。诸善男子善女人等及与一切。若能至心系念在内。端坐正受观佛色身。当知是人心如佛心与佛无异。虽在烦恼。不为诸恶之所覆蔽。于未来世雨大法雨

复次父王。譬如伊兰俱与栴檀。生末利山。牛头栴檀生伊兰丛中。未及长大。在地下时芽茎枝叶。如阎浮提竹笋。众人不知。言此山中纯是伊兰无有栴檀。而伊兰臭。臭若膖尸薰四十由旬。其华红色甚可爱乐。若有食者发狂而死。牛头栴檀虽生此林未成就故。不能发香。仲秋月满卒从地出成栴檀树。众人皆闻牛头栴檀上妙之香。永无伊兰臭恶之气。佛告父王。念佛之心亦复如是。以是心故能得三种菩提之根

复次父王。阎浮提中及四天下。有金翅鸟。名正音迦楼罗王。于诸鸟中快得自在。此鸟业报应食诸龙。于阎浮提日食一龙王及五百小龙。明日复于弗婆提。食一龙王及五百小龙。第三日复于瞿耶尼。食一龙王及五百小龙。第四日复于郁单越。食一龙王及五百小龙。周而复始经八千岁。此鸟尔时死相已现。诸龙吐毒无由得食。彼鸟饥逼周慞求食了不能得。游巡诸山永不得安。至金刚山然后暂住。从金刚山直下至大水际。从大水际至风轮际。为风所吹还至金刚山。如是七返然后命终。其命终已以其毒故。令十宝山同时火起。尔时难陀龙王惧烧此山。即大降雨澍如车轴。鸟肉散尽惟有心在。其心直下如前七返。然后还住金刚山顶。难陀龙王取此鸟心以为明珠。转轮王得为如意珠。佛告父王。诸善男子及善女人。若念佛者其心亦尔。复次大王。雪山有树名殃伽陀。其果甚大其核甚小。推其本末从香山来。以风力故得至雪山。孟冬盛寒罗刹夜叉。在山曲中屏[山*畏]之处。粪秽不净盈流于地。猛风吹雪以覆其上。渐渐成堑五十由旬。因粪力故此果得生根茎枝叶华实滋茂。春阳三月八方同时皆悉风起。消融冰雪唯果树在。其果形色。阎浮提果无以为譬。其形团圆满半由旬。婆罗门食即得仙道五通具足。寿命一劫不老不死。凡夫食之向须陀洹。阿那含食成阿罗汉。三明六通罔不悉备。有人持种至阎浮提粪壤之地。然后乃生。高一多罗树树名拘律陀果名多勒。如五斗瓶。阎浮提人有食之者。能除热病。佛告大王。诸善男子及善女人。正念思惟诸佛境界。亦复如是

复次大王。如帝释树生欢喜园。名波利质多罗。天女见之身心喜悦不自胜持。帝释见之即生欲想。八万四千诸婇女等即得乐觉。此树生时曲枝在地。即于地下华敷成果。其果金色光明赫奕。且其华叶终不萎落。十色具足开现光明有诸乐音。至秋八月从地踊出。高三百四十五万由旬。诸天见之喜悦非恒。佛告大王。观佛三昧在烦恼地。亦复如是其出生时。如彼宝树严显可观

复次大王如劫初时。火起一劫。雨起一劫。风起一劫。地起一劫。地劫成时。光音诸天飞行世间在水澡浴。以澡浴故四大精气即入身中。身触乐故精流水中。八风吹去堕淤泥中。自然成卵。经八千岁其卵乃开生一女人。其形青黑犹如淤泥。有九百九十九头。头有千眼。九百九十九口。一口四牙。牙上出火状如霹雳二十四手。手中皆捉一切武器。其身高大如须弥山。入大海中拍水自乐。有旋岚风吹大海水。水精入体即便怀妊。经八千岁然后生男。其儿身体高大四倍倍胜于母。儿有九头头有千眼。口中出火。有九百九十九手八脚海中出声。号毗摩质多罗阿修罗王。此鬼食法。惟啖淤泥及蕖藕根。其儿长大。见于诸天婇女围绕。即白母言。人皆伉俪。我何独无。其母告曰。香山有神名乾闼婆。其神有女。容姿美妙色踰白玉。身诸毛孔出妙音声。甚适我意今为汝娉。适汝愿不。阿修罗言。善哉善哉。愿母往求。尔时其母行诣香山。到香山已告彼乐神。我有一子威力自在。于四天下而无等伦。汝有令女可适吾子。其女闻已。愿乐随从适阿修罗。时阿修罗纳彼女已。心意泰然与女成礼。未久之间即便怀妊。经八千岁乃生一女。其女仪容端正挺特。天上天下无有其比。色中上色以自庄严。面上姿媚八万四千。左边亦有八万四千。右边亦有八万四千。前亦八万四千。后亦八万四千。阿修罗见以为瑰异。如月处星甚为奇特。憍尸迦闻即遣使。下诣阿修罗而求此女。阿修罗言。汝天福德。汝能令我乘七宝宫。以女妻汝。帝释闻此心生踊跃即脱宝冠持用拟海。十善报故。令阿修罗坐胜殿上。时阿修罗踊跃欢喜以女妻之。帝释即以六种宝台。而往迎之。于宫阙中有大莲华。自然化生八万四千诸妙宝女。譬如壮士屈申臂顷。即至帝释善法堂上。尔时天宫过踰于前百千万倍。释提桓因。为其立字号曰悦意。诸天见之叹未曾有。视东忘西。视南忘北。三十二辅臣。亦见悦意身心欢喜。乃至毛发皆生悦乐。帝释若至欢喜园时。共诸彩女入池游戏。尔时悦意即生嫉妒。遣五夜叉往白父王。今此帝释不复见宠。与诸婇女自共游戏。父闻此语心生嗔恚。即兴四兵往攻帝释。立大海水踞须弥顶。九百九十九手。同时俱作撼喜见城。摇须弥山。四大海水一时波动。释提桓因惊怖惶惧。靡知所趣。时宫有神。白天王言。莫大惊怖。过去佛说般若波罗蜜。王当诵持鬼兵自碎。是时帝释坐善法堂。烧众名香发大誓愿。般若波罗蜜是大明咒。是无上咒。无等等咒。审实不虚。我持此法当成佛道。令阿修罗自然退散。作是语时。于虚空中有四刀轮帝释功德故自然而下。当阿修罗上。时阿修罗耳鼻手足一时尽落。令大海水赤如绛汁。时阿修罗即便惊怖。遁走无处入藕丝孔。彼以贪欲嗔恚愚痴鬼幻力故。尚能如是。岂况佛法不可思议。佛告大王。诸善男子及善女人。系心思惟诸佛境界。亦能安住诸三昧海。其人功德不可称计。譬如诸佛等无有异

    序观地品第二

云何名为观诸佛境界。诸佛如来出现于世。有二种法以自庄严。何等为二。一者先说十二部经。令诸众生读诵通利。如是种种名为法施。二者以妙色身。示阎浮提及十方界。令诸众生见佛色身具足庄严。三十二相八十种随形好。无缺减相。心生欢喜。观如是相因何而得。皆由前世百千苦行。修诸波罗蜜及助道法而生此相

佛告父王。若有众生欲念佛者。欲观佛者。欲见佛者。分别相好者。识佛光明者。知佛身内者。学观佛心者。学观佛顶者学观佛足下千辐相轮者。欲知佛生时相者。欲知佛纳妃时者。欲知佛出家时者。欲知佛苦行时者。欲知佛降魔时者。欲知佛得阿耨多罗三藐三菩提时者。欲知如来转法轮时相者。欲知如来宝马藏相者。欲知如来升忉利天为母摩耶夫人说法时相者。欲知如来下忉利天时相者。欲知如来行住坐卧四威仪中光明相者。欲知如来诣拘尸那降度力士相者。欲知如来伏旷野鬼神毛孔光明相者

佛告父王。佛涅槃后。若四部众及诸天龙夜叉等。欲系念者。欲思惟者。欲行禅者。欲得三昧正受者。佛告父王。云何名系念。自有众生乐观如来具足身相。自有众生乐观如来诸相好中一一相好者。自有众生乐观如来随顺相好。自有众生乐观如来逆相好者。自有众生乐观如来光明者。自有众生乐观如来行者。自有众生乐观如来住者。自有众生乐观如来坐者。自有众生乐观如来卧者。自有众生乐观如来乞食者。自有众生乐观如来初生者。自有众生乐观如来纳妃时者。自有众生乐观如来出家时者。自有众生乐观如来苦行时者。自有众生乐观如来降魔时者。自有众生乐观如来成佛时者。自有众生乐观如来转法轮时者。自有众生乐观如来升忉利天为母说法时者。自有众生乐观如来降伏旷野鬼神者。自有众生乐观如来于那干诃罗降伏诸龙留影时者。自有众生乐观如来在拘尸那城。降伏六师尼提贱人及诸恶律仪殷重邪见人者。如是父王。我涅槃后诸众生等。业行若干。意想若干。所识不同。随彼众生心想所见。应当次第教其系念。如我住世不须系念。譬如日出冥者皆明。惟无目者而无所睹未来世中诸弟子等应修三法。何等为三。一者诵修多罗甚深经典。二者净持禁戒威仪无犯。三者系念思惟心不散乱。云何名系念。或有欲系心观于佛顶上者。或有欲系心观佛毛发者。或有欲系心观佛发际者。或有欲系心观佛额广平正相者。或有欲系心观佛眉间白毫相者。或有欲系心观佛眉者。或有欲系心观佛牛王眼相者。或有欲系心观佛修直鼻相者。或有欲系心观佛鹰王嘴相者。自有众生乐观如来髭鬓如蝌斗形流出光明者。自有众生乐观如来唇上齶际者。自有众生乐观如来唇色赤好如频婆果者。自有众生乐观如来下唇如钵头摩华茎者。其色红赤上入频婆果色中者。自有众生乐观如来口四十齿相者。自有众生乐观如来齿白齐密相者。自有众生乐观如来齿上印文相者。自有众生乐观如来齿画界者。自有众生乐观如来上齶相者。八万四千画了了分明。自有众生乐观如来下龂如优昙钵华茎色者。自有众生乐观如来咽喉如琉璃筒。状如累莲华相者。自有众生乐观如来广长舌相莲华叶形。上色五画五彩分明。舌下十脉众光流出。舌相广长遍覆其面者。自有众生乐观如来咽喉节中有三相者。自有众生乐观如来咽膺相如金翅鸟眼者。自有众生乐观如来头相者。自有众生乐观如来八万四千发相者。自有众生乐观如来毛右旋者。自有众生乐观如来一一孔一毛旋生者。自有众生乐观如来头皮者。自有众生乐观如来肉髻骨者。自有众生乐观如来脑者。自有众生乐观如来耳普垂睡者。自有众生乐观如来耳轮郭相者。自有众生乐观如来耳旋生七毛相者。自有众生乐观如来缺盆骨满相。于彼相中旋生光台者。自有众生乐观如来腋下满相。于其相中悬生五珠。如摩尼珠上跓佛腋者。自有众生乐观如来臂佣纤圆如象王鼻者。自有众生乐观如来肘骨如龙王发婉转相着。文彩不坏。节头槃龙不见其迹。手指参差不失其所。于指节端十二轮现。自有众生乐观如来赤铜爪。其爪八色了了分明。自有众生乐观如来合曼掌相。张时则见[僉*殳]指不见。如真珠网了了分明。胜阎浮檀金百千万倍。其色明达过于眼界。于十指端各生卍字。卍字点间有千辐轮。众相具足如和合百千莲华。自有众生乐观如来掌文间成如自在天宫。其掌平正人天无类。当于掌中生千辐相。于十方面开摩尼光。于其轮下有十种画。一一画如自在天眼清白分明。然后入掌相中。自有众生乐观如来毛背毛上向靡。如绀琉璃。流出五色光入网曼中者。自有众生乐观如来手足柔软如天劫贝。自有众生乐观如来手内外握自有众生乐观如来胸德字万印相。三摩尼光相者。自有众生乐观如来脐如毗楞伽宝珠。自有众生乐观如来胁助。大小正等婉转相着。自有众生乐观如来诸骨支节。槃龙相结其间密致者。自有众生乐观如来钩锁骨卷舒自在不相妨碍。自有众生乐观如来骨色鲜白。颇梨雪山不得为譬。上有红光间错成文。凝液如脂。自有众生乐观如来伊尼鹿王[跳-兆+專]相者。自有众生乐观如来踝相者。自有众生乐观如来足趺平正相者。自有众生乐观如来足趺上色。阎浮檀金色。毛上向靡。足指网间如罗文彩。于其文间众彩玄黄。不可具名。自有众生乐观如来赤铜爪相。于其爪端有五师子口。自有众生乐观如来脚指端蠡文相。如毗纽羯磨天所画之印。自有众生乐观如来足下平满不容一毛。足下千辐轮相。毂辋具足鱼鳞相次。金刚杵相者。足跟亦有梵王顶相。众蠡不异。如是名乐顺观者。自有众生乐逆观者。从足下千辐轮相。从下观至足指上。一一相一一好一一色。从下至上了了逆观。是名逆观法。自有众生乐观如来金色。佛生阎浮提故作色中上色。如百千日耀紫金山不可得具见。自有众生乐观如来巨身丈六者。自有众生乐观如来圆光一寻者。自有众生乐观如来举身光明者。自有众生乐观如来说法时瑞应相者。自有众生乐观如来脐。上向相下向相者

    观相品第三之一

佛告父王。云何名观如来顶。如来顶骨团圆犹如合卷。其色正白。若见薄皮则为红色。或见厚皮则金刚色。发际金色。脑颇梨色。有十四脉众画具足。亦十四光其光如脉分明了了。于脑脉中旋生诸光上冲头骨。从头骨出乃至发际。有十四色围绕众发。发下金色亦生众光。入十四色中。是名如来生王宫中顶脑肉髻。惟其顶上五大梵相生。时摩耶及佛姨母皆悉不见。其五梵相开现光明至于梵世。复过上方无量世界。化成宫台。诸佛境界。十地菩萨之所不见。今为父王说生顶相。若有闻者应当思惟佛胜顶相。其相光明。如三千界大地微尘。不可具说。后世众生若闻是语。思是相者心无悔恨。如见世尊顶胜相光。闭目得见。以心想力了了分明如佛在世。虽观是相不得众多。从一事起复想一事。想一事已复想一事。逆顺反覆经十六反。如是心相极令明利。然后住心系念一处。如是渐渐举舌向齶令舌政住。经二七日。然后身心可得安隐。复当系心还观佛顶。观佛顶法先随毛孔入

佛告父王。及敕阿难。谛听谛听善思念之。如来今者头上有八万四千毛。皆两向靡右旋而生。分齐分明四抓分明。一一毛孔旋生五光。入前十四色光中。昔我在宫乳母为我沐头。时大爱道来至我所。悉达生时多诸奇特。人若问我汝子之发为长几许。我云何答。今当量发知其尺度。即敕我申发。母以尺量。长一丈二尺五寸。放已右旋还成蠡文。欲纳妃时复更沭头。母复敕言。前者量发。正长一丈二尺五寸。今当更量。即申量之。长一丈三尺五寸。我出家时天神捧去。亦长丈三尺五寸。今者父王。欲看发相不。父王白言。唯然天尊。乐见佛发。如来即以手申其发。从尼拘楼陀精舍。至父王宫。如绀琉璃。绕城七匝。于佛发中大众皆见若干色光。不可具说。是一一光普照一切。作绀琉璃色。于琉璃色中有诸化佛不可称数。现是相已敛发卷光。右旋婉转还住佛顶即成蠡文。是名如来真实发相。若有比丘及比丘尼。诸优婆塞优婆夷等。欲观佛发当作是观。不得他观。若他观者名为邪观。名为狂乱。名为失心。名为邪见。名颠倒心。设得定者无有是处。如是父王。佛真发相事实如此。观发相已。次观发际。如赤真珠色。婉转下垂。有五千光间错分明。皆上向靡围绕诸发。从顶上出绕顶五匝如天画师所作画法。团圆正等细如一丝。于其丝间生诸化佛。有化菩萨以为眷属。诸天八部一切色象亦于中现。色如日轮不可具见。是名观佛发际。如此观者名为正观。若异观者名为邪观。佛告父王此名如来发际实观

云何观如来额广平正相。额广平正相中有三相。一者所谓白毛相。佛初生时。王与夫人将太子诣阿私陀仙。令相太子。仙人披[疊*毛]。初见太子眉间白毛旋生。于白毛边有诸轮郭。随白毛旋。相师舒毛见毛长大。即取尺度量其长短。足满五尺如琉璃筒。放已右旋如颇梨珠。显现无量百千色光。是名菩萨初生时白毫相光。至年八岁。姨母复观悉达年大。其眉间毛亦随年长。今试看之。即舒白毛见毛正直如白琉璃筒。于其毛端出五色光明还入毛孔。母甚怜念情无已已。告语诸人。我子毛相乃至如此。诸人见已。如前右旋甚可爱念。是名菩萨童子时白毫毛相

云何名菩萨纳妃时白毫毛相。耶输陀罗父。自遣相师来相太子。见三十二相炳然如画。惟于白毛其心不了。相师即言。地天太子。其余众相同金轮王。唯此白毛流出众光非我所明。今欲舒看为可尔不。太子告言。随汝所欲。尔时相师以手申毛。其毛流出如牛王乳射相师眼。其眼明净。即于毛中见百千转轮圣王七宝千子皆悉具足。相师惊愕白言。地天太子。我申白毛欲观长短。不知何意。如牛王乳来射我眼。为是实见。为是梦见。为是狂乱。今者悉忘。太子相好一切都尽。惟见百千转轮圣王七宝千子。及四种兵从四面起。我心欢喜。如婆罗门得梵世乐。语已放毛。右旋婉转还复本处。尔时相师名牢度跋多。见此事已。五体投地礼于太子。太子众相不可具见。如我相法。见一相者王四天下快得自在。今太子相如摩醯首罗。自在神力不可记录。当云何知。太子告言。吾不达此。汝自归家往白汝王。尔时相师即还本国。以如上事具向王说。王闻是语驾乘名象导从百千。诣迦毗罗城。到净饭王宫。以水澡太子手。持女上之。因为作礼。地天太子。愿受我女可备洒扫。相师所见上妙毛相。我今欲见。为可尔不。太子告言。随意看之。尔时耶输陀罗父。以手申太子白毛。见其白毛。如颇梨憧。节节相当。于众节间。见有无量百千梵王释提桓因诸胜天子与宫殿俱。了了而见。如于明镜自观面像。见已欢喜。寻复放舍。如前右旋还住眉间。光明赫奕四面布散。入轮郭中不可悉说。是名菩萨纳妃时白毫相。佛告父王。佛涅槃后四部之众。其欲观菩萨为童子时及纳妃时白毫相者。当作是观。如此观者是名正观。若异观者是名邪观

佛告父王。云何名如来出家时白毫相。我欲出家时。父王及母遣诸婇女。常以卫护。门施关键开阖有声。如师子吼。于窗牖间密悬诸铃。金锁相钩。龙鬼夜叉无从得入。尔时四天王。于虚空中遥发声言。地天太子日时已至。宜当学道。我今欲往供养太子。恐殿有声无缘得入。尔时太子以手申毛。至四天王所。色如天缯柔软可爱。时四天王见心甚爱敬。以爱敬故。即于毛中见化菩萨。结加趺坐形如太子。一一菩萨。复有无量诸大菩萨。共为眷属。此相现时。无量诸天龙夜叉等。俱时得入。敕语车匿。汝往后厩被揵陟来。车匿白言。今此地中若举足时。此地振吼如大象声。云何得往。尔时太子复申白毛令车匿见。犹如莲华叶叶相次其白如雪。车匿见已心眼即开。于其叶间见化菩萨结加趺坐。犹如微尘不可称数。是诸化人眉间白毛亦复如是。尔时车匿见宫中地如颇梨色。表里坚实犹如金刚。蹑足无声。疾至后厩被马金鞍牵至殿前。车匿白太子言。诸天颙颙合掌叉手。住在空中。同声赞叹出家功德。太子宜时速疾乘马。尔时太子复舒白毛持拟诸女。令诸侍女身心悦乐。犹如比丘得第三禅。尔时此毛婉转右旋还入眉间。诸天复见太子眉间有百千光。譬如乳河周流一切。于乳河中有化菩萨。乘化莲华。皆共赞叹出家功德。一一化菩萨。眉间乳河流出光明亦复如是。佛告父王。是名菩萨出家时白毛相种种瑞应。若佛灭后诸四部众。欲观如来出家时白毛相者。当作是观。若异观者是名邪观

佛告父王。云何名苦行时白毫毛相。如我踰出宫城已。去伽耶城不远。诣阿输陀树。吉安天子等百千天子。皆作是念。菩萨若于此坐必须坐具。我今应当献于天草。即把天草清净柔软。名曰吉祥。菩萨受已铺地而坐。是时诸天谛观菩萨身相可爱。复见白毛围如三寸。右旋婉转有百千色。流入诸相。是诸天子观白毫时。各作是念。菩萨今者惟受我草不受汝草。时白毛中。有万亿菩萨结加趺坐。各取其草坐此树下。一一天子。各见白毫中有如此相。是时吉安天子。而赞叹言。善哉胜士。修大慈悲。慈悲力故得大人相。于其相中无量变现。能满诸天一切善愿。不生诤讼起菩提心。释梵诸天。见于菩萨坐此树下。各献甘露持用供养。菩萨是时。为欲降伏彼六师故不受彼供。天令左右自生麻米。菩萨不食。诸天皆曰。此善男子。不食多日。气力惙然余命无几。云何当能成办菩提。菩萨是时入灭意三昧。三昧境界名寂诸根。诸天啼泣泪下如雨。劝请菩萨当起饮食。作是请时。声遍三千大千世界。菩萨不觉。有一天子名曰悦意。见地生草穿菩萨肉上生至肘。告诸天曰。奇哉男子。苦行乃尔。不食多时。唤声不闻。草生不觉。即以右手申其白毛。其毛端直。正长一丈四尺五寸。如天白宝中外俱空。天见毛内有百亿光。其光微妙不可具宣。于其光中现化菩萨。皆修苦行如此不异。菩萨不小毛亦不大。诸天见已叹未曾有。即放白毛右旋婉转。与光明俱还复本处。尔时诸天谛观白毛目不暂舍。见白毛中下生五筒。从面门入。流注甘露滴滴不绝。从舌根上流入于身。表里清彻如琉璃山。百千万亿诸大菩萨。于己身内现。诸天见已合掌欢喜。前言愚痴。言此大人命不云远。今见是相。必当成佛了了无疑。无上慧日照世不久。作是语已绕百千匝各还宫殿。如此音声闻六欲天。佛告父王。佛灭度后若四部众。欲观如来苦行时白毫相者。当作是观如此观者是名正观。若异观者名为邪观

佛说观佛三昧海经卷第一佛说观佛三昧海经卷第二

        东晋天竺三藏佛陀跋陀罗译

    观相品第三之二

佛告父王。云何名菩萨降魔时白毫相光。魔王波旬。遥以天眼观阎浮提。见释迦子弃国如唾。坐道树下肌骨枯槁。形体羸瘠如久病人。唯有金色光明益显其眼陷黑如井底星。骨节相跓失蟠龙文。波旬喜曰。瞿昙体羸骨如腐草。虽有光色余命无几曼道未成。宜往败之。嗔目大怒敕诸夜叉速集军众。吾今欲行下阎浮提往征瞿昙。是时魔子名萨多罗。长跪白父。净饭王子其生之时。万神侍御光彻众天。其人慈悲普覆一切。今为群生坐于道树。父王云何。兴恶逆意。魔即怒曰。汝幼无知。乃言瞿昙有胜道德。瞿昙身羸如枯骨人。竟何所能而言慈悲。子复白言。瞿昙体羸不食故尔。观其光色如金。刚山紫焰流出。恬坐六年心无倾摇。观其面貌曾无畏色。唯愿大王。且住天宫不愿往攻。波旬复言。汝但默然。何须多云。时夜叉主名曰翅陀。即至魔所。头面着地为魔作礼。白言天王。何所敕令。波旬告曰。汝以我声遍敕六天。告下鬼王并诸八部及旷野鬼十八地狱阎罗王神。一切皆集往瞿昙所。是时诸鬼。犹如云起从四面集。或有诸鬼首如牛头有四十耳。于其耳中生诸铁箭。赤焰上起高一由旬。有十八角角端擎山。山上有龙衔热铁丸。复有诸鬼首如狐头有十千眼。眼睫长大如霹雳炎。项上有口口吐炽火。身上诸毛犹如剑树。复有诸鬼倒住空中有十二脚。于其足跟有千刀轮。头如太山。于其头上五百剑树。树头火起。复有诸鬼。婉转腹行负铁围山穹脊而至。复有诸鬼。一颈多头口有千舌。于其舌上生棘刺树。毛鬣上冲毛端雨血。吐刺疾走腾空而至。毗舍阇鬼发大恶声。气踊如云雨热铁丸倏忽而到。鸠槃茶鬼蹲踞土埵现其丑形。富单那鬼其形黑瘦。头戴大镬盛热铁丸。手执刀轮。左脚踏狗。右脚踏狼。奔走而至。诸罗刹王背黑如漆。胸白如月。眼如盛火。头发蓬乱如缚刺束。狗牙上出状如銏剑。手十指爪利如锋芒脚有十爪纵横如剑。以铁羁头疾走而至。旷野鬼神大将军等。一颈六头胸有六面。膝头两面举体生毛状如箭镞。奋身射人。张眼焰赤血出流下。与诸凶类疾走而到。复有诸鬼。首如虎头有十二眼。鼻如象鼻有十三鼻。左肩担山右肩负火。手捉利剑脚蹑师子。哮吼而至。复有诸鬼其身如云。霹雳火起如团云头。于团云边有百千万龙。不见其身但见吐毒。于十方面。一切恶事如云而集。鬼子母神将其诸子。各执一石壁方十里。岩崿可畏竞驰而至。复有诸鬼卷脊挟尾。以鼻嗅地鼻出诸火。火焰上化化生诸鬼。担面而走。是时魔王。顾视夜叉告令诸鬼。今者鬼兵既已云集。瞿昙善人。或能知咒。当兴四兵。以魔王珠化作四兵。象马车步列仗如林。甚可怖畏。直从空下至道树边。魔复更念。如此军众或不能淹降伏瞿昙。复脱宝冠持拟地下。其冠光明迳至下方。当阎罗王化人宫上。高声大呼告敕诸鬼。汝等狱卒及阎罗王。阿鼻地狱刀轮剑戟。火车炉炭。一切都举向阎浮提。欲灭瞿昙掷置其中。阿鼻地狱纵广正等八万由旬。七重铁城。下十八鬲。四面剑林亦十八行。东方复有十八小地狱。以为围绕。南方十八鬲以为围绕。西方十八鬲以为围绕。北方十八鬲以为围绕。地下自然有炽猛火。烧然铁城铁网俱炽一切热焰周回还旋。下过十八鬲。若有众生犯五逆者。身满其中受如此苦。昼夜不息间无空缺。劫欲尽时四门自开。诸罪人等见东门外一切剑林。如清凉林从下鬲起至第二鬲。第二鬲起至第三鬲。乃至于上走趣东门。罗刹狱卒以热铁叉逆刺其眼精。如融铜流出于地即时躄倒遍满十八鬲中。其心迷闷满一小劫。尔乃还起复向南门。如是四方如前无异。昼夜受苦迳一大劫。劫尽更生余小地狱。其余众狱形状大小受报轻重。形类好丑一切杂报。慈三昧中当复广说。时诸狱卒。城东八千。三方亦尔。一一狱卒头发如山。生刀轮剑戟。耳如驴耳有百千种。一一耳中烟焰俱起。唇口牙齿过于罗刹百千万倍。角如牛角角端生剑。五方异见。身体赤黑如癞病狗。有四百尾。于其尾头浓血沸屎。有铁嘴虫缠其身体。手捉铁叉脚下踏轮。刀轮上刺直彻心髓。驶疾如风。各以铁叉叉罪人腰。直上而走。阿鼻地狱如影随形。逐罪人来。俄顷之间到道树边。一时云集欲兴恶逆。菩萨是时俨然不动。入胜意慈。魔王诪张奋武振吼。敕诸兵众。汝等速疾逼害瞿昙。上震天雷雨热铁丸。刀轮武器更相加积交横空中。四面诸鬼同时俱作然。其火箭不近菩萨。是时菩萨。徐举右臂申眉间毛。下向用拟阿鼻地狱。令诸罪人见白毛中流出众水。澍如车轴雨大火上。大火暂灭唯烟气在。令受罪人心得小悟。自忆前世百生千生百千万生所作诸罪。诸狱卒等持大铁叉罪起举人。尽其身力不能得动。忽然自见大铁叉头如白银山。龛室千万。有白师子盘身为座。于其座上生白莲华。有妙菩萨入胜意慈。如是庄严如须弥山。放叉掷地。有七宝华生叉根下。有白色光明。照诸地狱及狱卒身。令阎罗王及诸狱卒作白银山。犹如电光暂时得见。诸受罪人。六情诸根猛火速起。节头火然筋脉生钉。暂得一起。合掌叉手向白毫相。即时心开。见白毛中人如己无异。坐莲华林。以水浇灌诸罪人顶。令心热恼暂得清凉。即皆同时称南无佛。以是因缘。受罪毕讫直生人中。诸情完具正见出家。既出家已。破二十亿洞然之结。成须陀洹。魔见是相。憔悴懊恼却卧床上。魔有三女长名悦彼。中名喜心。小名多媚。时魔三女至父王所。长跪叉手为父作礼启言。父王。今日何故愁悴乃尔。其父答言。沙门瞿昙结誓深重。今坐道树要坏我民。是故愁耳。女白父言。我能往乱。愿父莫愁。即自庄饰着杂宝冠。容媚挺特过踰魔后。百千万倍。眄目作姿现诸妖冶。璎珞晃耀光翳六天。乘羽宝车。安施宝帐垂诸天华。于华须头诸化玉女。手执乐器鼓乐弦歌声万种音凡在世人之所喜乐。一一玉女。从五百女以为侍御。缯盖幢幡如云而下。身毛孔中香烟芬馥。有百千色。玄黄昱烁甚适人目。安庠徐步至菩萨所。下车合掌礼敬菩萨。旋绕七匝。白菩萨言。太子生时。万神侍御七宝来臻何弃天位来此树下。我是天女盛美无比。颜貌红辉六天无双。今以微身奉上太子。供给左右可备洒扫。我等善能调身按摩。今欲亲附愿遂下情。太子坐树身体疲懈。宜须偃息服食甘露。即以宝器献天百味。太子寂然身心不动。以白毫拟。令天三女自见身内脓囊涕唾。九孔筋脉一切根本。大肠小肠生藏熟藏。于其中间。回伏婉转踊生诸虫。其数满足有八千户。户有九亿诸小虫等。虫游戏时走入小肠。皆有四口张口上向。大虫游戏入大肠中。从大肠出复入胃中。冷病起时胃管闭塞。虫不得入故食不消。脾肾肝肺心胆喉咙。肺腴肝鬲。如是中间复生四虫。如四蛇合。上下同时唼食诸藏。滓尽汁出。入眼为泪。入鼻为涕。聚口成唾。放口涎流。薄皮厚皮。筋髓诸脉悉生诸虫。细于秋毫数甚众多不可具说。其女见此即便呕吐从口而出。无有穷尽。即自见身。左生蛇头。右生狐头。中首狗头。头上化生九色死尸。如九相观。九相观者。一者新死相。或见死人。身体正直无所复知。想我此身亦当复尔与此无异。故曰新死相。二者青淤相。或见死人。一日至于七日。身体青膖瘀黑相。我所爱身亦当复尔与此无异。故曰青瘀相。三者脓血相。或见死人。身已烂坏血流涂漫。极为可恶不可瞻视。我所爱身亦当复尔。故曰脓血相。四者绛汁相。或见死人。身体纵横黄水流出状似绛汁。我所爱身亦当复尔。故曰绛汁相。五者食不消相。或见死人。为乌鸟所食。虫狼所啖。为蝇所蛆。其肉欲尽或半身在。我所爱身亦当复尔。故曰食不消相。六者筋缠束薪相。或见死人。皮肉已尽止有筋骨相连。譬似束薪。由是得成而不解散。我所爱身亦当复尔。故曰筋缠束薪相。七者骨节分离相。或见死人。筋已烂坏骨节纵横不在一处。我所爱身亦当复尔。故曰骨节分离相。八者烧燋可恶相。或见死人。为家火所烧。野火所焚。燋缩在地。极为可恶不可瞻视。我所爱身亦当复尔。故曰烧燋可恶相。九者故骨相。或见久昔干骨。若五十岁。至百岁二百岁三百岁时。骨还变白。日曝彻中。火从骨上焰焰而起。火烧之后风吹入地还归于土。是名略说九相。是为菩萨始在树下初开不净观门。时三魔女。自见背上。复负老母。发白面皱。唇口喎僻。手脚缭戾。颜色津黑。犹如僵尸。胸前复抱一死小儿。于六窍中流出诸脓。脓中生虫正似蛔虫。诸女见此愕然惊嗥。却行而去。低头视脐脐生六龙。龙吐水火。耳出诸风体坚如铁。自见女形。丑状鄙秽。乃当如是。于其鄙处有诸小虫。虫有四头二上二下。唼食女身。口出五毒。毒有五脉上至心下乃至咽喉。从六根中生诸脉根。九十有九。直下流注至诸虫顶。共相灌注彻诸虫心。诸女人等。从无数世造诸邪行。恶业因缘获得如是不净丑身。复有诸虫如手臂钏。团栾相持而有众口。口生五毒唼食女根。诸女人等先世之时。邪淫行故。获臭恶身以为庄严。诸女见已心极酸苦如箭入心。却行之时匍匐而去。如羸驼步。初举足时节节火起。其发黄黑如刺棘林。以自缠身。呼嗟叹息至魔王前。魔王心怒。奋剑竖色即欲直前。魔子谏曰。父王无辜。自招疮疣菩萨行净难动如地。云何可坏。作是谏时。菩萨复以白毫光拟。令魔眷属身心安乐。譬如比丘入第三禅。饿鬼见白毛。毛端皆有百千万亿诸大菩萨。是诸菩萨亦入胜意慈心三昧。各以右手将左指头。爪端生乳洒灭猛火。猛火灭已即得清凉。自然饱满身心踊悦。发菩提心。因是心故舍饿鬼苦。是诸鬼等自见其身。如似白玉。似琉璃山。似颇梨山。似黄金山。似马瑙山。身诸毛孔似真珠贯。眼目明净似明月珠。身诸烟焰如杂宝云。所执刀杖似七宝台。七宝台内重铺綩綖安置丹枕。左右自然有化梵王。见化菩萨坐于花台。各各异说诸罪人报。汝等前世坐作恶业故。获如此可恶之形说是语时。是诸鬼神有发无上菩提心者。有种声闻辟支佛因缘者。有于来世当生人天胜乐处者。是时魔王忽然还宫。白毫随从直至六天。于其中间。无数天子天女。见白毛孔通中皆空。团圆可爱如梵王幢。于其空间。有百千万恒河沙微尘诸宝莲华。一一莲华。无量无边诸妙白色以为其台。台上有化菩萨。放白毫大人相光。亦复如是。诸菩萨顶有妙莲华其华金色。过去七佛在其华上。是诸化佛。自说名字与修多罗。等无差别。复有诸天宿善根者。见化菩萨一毛孔中生一菩萨。菩萨顶上皆有化佛。如前不异。时诸化佛眉间出华百宝庄严诸天世间无色可比。有化光台。台上化佛如前不异。诸化菩萨身毛孔中。化出一切十方众生所希见事。化人足下有化光台。生诸天宫。胜过六欲魔王宫殿。亦胜大梵俨身之宫。诸梵顶相从化菩萨足辋间生。如是白毛上至无色。遍照一切无量无边诸天世界。皆如白宝颇梨明镜。诸天见此胜瑞相已。不乐天乐发菩提心。魔王八万四千天女。视波旬身状如死狗。亦似燋木。但瞻菩萨白毫相光。心意悦乐无以为譬。怒恚波旬前所为事。规欲坏他自失军众。作是语时百千无数天子天女。复发无上菩提道意。佛告大王。如是种种诸胜相事。但从菩萨眉间白毫而生此耳。不劳其余身分功德。佛灭度后诸四部众。若能暂时舍离散乱。系心正观菩萨降魔白毫相者。灭无数劫黑业恶障。亦除十恶诸烦恼障。能于现世见佛影像了了分明。如是种种观相境界不可具说。如我灭后。欲观如来降伏魔时白毛相者。当作此观。如是观者名为正观。若异观者名为邪观

云何名为如来成佛时大人相。觉人相。不动人相。解脱人相。光明人相。满智慧人相。具足诸波罗蜜相。首楞严等诸三昧海相。菩萨摩诃萨。从胜意慈三昧起。入灭意定。从灭意定起。还入首楞严。从首楞严起。入慧炬三昧。从慧炬三昧起入诸法相三昧。从诸法相三昧起。入光明相三昧。从光明相三昧起。入师子音声三昧。从师子音声三昧起。入师子奋迅三昧。从师子奋迅三昧起。入海意三昧。从海意三昧起。入普智三昧。从普智三昧起。入陀罗尼印相三昧。从陀罗尼印相三昧起。入普现色身三昧。从普现色身三昧起。入法界性三昧。从法界性三昧起。入师子吼力王三昧。从师子吼力王三昧起。入灭诸魔相三昧。从灭诸魔相三昧起。入空慧三昧。从空慧三昧起。入解空相三昧。从解空相三昧起。入大空智三昧。从大空智三昧起。入遍一切处色身三昧。从遍一切处色身三昧起。入寂心相三昧。从寂心相三昧起。入菩萨摩诃萨金刚相三昧。从金刚相三昧起。入金刚顶三昧。从金刚顶三昧起。入一切三昧海。从一切三昧海起。入一切陀罗尼海三昧。从一切陀罗尼海三昧起。入一切佛境界海三昧。从一切佛境界海三昧起。入一切诸佛解脱解脱知见海三昧。从解脱解脱知见海三昧起。然后方入无量微尘数诸三昧海门。从诸三昧海门起。入寂意灭意三昧。从寂意灭意三昧起。入金刚譬定大解脱三昧相门

尔时道场地化似金刚。满八十里其色正白。不可具见。此相现时。菩萨眉间白毫相光。端洁正直矗然东向。长一丈五尺。有十楞现。弥迦女人同类五女。无数万亿天龙鬼神。弥勒贤劫诸菩萨等。跋陀波罗等。无量无边阿僧祇微尘数诸大菩萨。亦见此相。此相现时佛菩提树。白毛力故根下自然化生宝华。纵广正等四十由旬。其华金色金刚为台。佛眉间光照此华台。其光直下至金刚际。于金刚际自然化生二金刚座。互相掁触。声振三千大千世界。令此大地六种振动。其金刚座上冲莲华。至莲华根。其莲华根亦是金刚。三种金刚共相掁触。直还下过至金刚际往旋十返。白毫光明围绕十匝。令金刚座铿然不动。佛坐此坐。消除三障成菩提道。佛心境界说不可尽。若广说者。一切众生至十地菩萨。亦不能知亦非所解。是故于此白毫相中。隐而不说。如是白毛光明力故。令菩提树。金刚为茎。根亦金刚。楷七宝成。楷上生光。各各有七围绕佛身。化成宝缦。树叶金色。华百宝色。华上有光百千宝色。诸天宝光不得为譬。果白宝色。夜摩天上微妙白宝不得为比。其果光明化摩尼网弥覆树上。于其网间犹如白丝。婉转下垂。化成宝铃

铃四角头有大宝台。其台高显过于上方无量世界。过是界已。复更化成诸大宝台。其台高妙不可具说。光显微妙。譬如和合百千万亿诸须弥山。于其台上有大宝盖纯金刚成。杂色间错微妙光明。光明下垂化成幡帐。于幡帐中雨宝盖云。宝盖云中雨幢幡云。幢幡云中雨妓乐云。妓乐云中雨宝光云。宝光云中雨诸香云。诸香云中雨师子座云。师子座云中雨华鬘云。华鬘云中雨妙音云。妙音云中雨偈颂云。偈颂云中雨诸珍宝供养具云。如是等种种供具。皆从菩提树白毫相光明中出。时白毛光下垂照地。令道场边金刚地上化作七池。池生德水。水有七色七色分明。色有十光上照树王。其池四岸众宝合成。一岸百宝所共合成。一宝流出百亿光明。池底纯是金刚摩尼以为底沙。水生诸华纯黄金叶。叶上千光化成光轮。池有七渠水自涌出。池口生华叶叶相次。于莲华须流出诸水。如琉璃珠映彻分明。于渠两边列生诸华。八万四千。众宝严饰。此渠中水更相灌注。当水流时光亦随转。映菩提树。此树光中。一一叶上生宝莲华。其华遍布一切世界。于其华上化白宝台。遍至十方无量世界。其白毫光从佛眉间出。宝莲华团圆正等满一由旬。如是相次过于上方。无量无边不可算数。微尘世界。华华相次。一一华上见一佛坐。身黄金色方身丈六。结加趺坐坐莲华台。其金刚座及菩提树。如上所说等无有异。乃至十方亦复如是。于白毫中复出宝华。胜前宝华百亿万倍。华上有佛。如释迦文等无有异。一华须头复有一佛身亦丈六。入深禅定心不倾动。如是光明。照于东方无量无数百千世界。令诸世界皆作金色。彼众生见化佛毛孔开现光明。亦复如是。出无量百千宝光。一一光中。复有无量百亿化佛。时诸天龙鬼神夜叉乾闼婆等。睹此光明绕佛千匝。照十方国见十方国。高下大小了了分明。如执明镜自见面像。是诸大众。波旬眷属八万亿众。诸鬼神天龙夜叉等。各见白毫端直丈五。十方光见。映蔽众目如万亿日。不可具见。但于光中。见无量无数百亿千万化释迦文。眉间白毛正长丈五。一一毛中出无量光。一一光中无量化佛。化佛眉间亦复如是。是白毫光轮郭之中。流出众光上至佛额。显发额广平正之相。额上诸毛毛皆上靡。其毛根下梵摩尼色。适众生心。毛端流光如融紫金。光相上靡入于发际。婉转垂下至耳轮边。然后布散上入发间。围绕蠡文数百千匝。从枕骨生。如金莲华叶日照开敷。莲华叶间及莲华须。如帝释画了了分明。众色异现。于其色间无量化佛。一佛七菩萨诸天以为侍者。手执宝华白中白者。华有五光五色分明。随从化佛不失其所。此名如来初成佛时白毫相光。因白毫光初生项光。生王宫时此光如日。见不了了。圆光一寻别自当说。时诸八部睹白毫光所见不同。有见白毛犹如诸佛。有见白毫如诸菩萨。有见白毛如己父母。一切世间可尊敬事。悉于毛端了了得见。见已欢喜。有发无上菩提心者。有发声闻缘觉心者。如是诸鬼见白毛者。自然慈心无诸恶意。佛告父王。如来白毛。自从初生乃至成佛。于其中间微细小事可得观见。既成佛已。白毫光明众相具足。诸修多罗中佛已广说。白毫相光究竟之处。十地菩萨尔乃得见。先说小者。应诸世间此事易见

佛告父王及敕阿难。谛听谛听善思念之。传语后世诸弟子等皆令得知。若我灭后诸比丘等。若问是事。此白毫相。菩萨本昔修何行得。汝当答言。佛白毫相从无量劫舍心不悭。不见前相不忆财物。心无封着而行布施。以身心法摄身威仪。护持禁戒如爱双目。然其心内豁然虚寂。不见犯起及舍堕法。心安如地无有动摇。设有一人。以百千刀屠截其身。设复有人。以诸棘刺鞭挞其身。菩萨初无一念嗔恚。设复有人头有千舌舌出千言。种种异辞骂辱。菩萨颜色不变。如净莲华。心无所著身心不懈。无疲惓意如救头然。如身毛孔生那利疮。求觅良医昼夜精进。心无染污如琉璃珠表里俱净。摄身敛意。闭目叉手。端坐正受其心如海湛然不动。如金刚山不可沮坏。虽作是意不随禅生。灰心灭智。无所适莫。亦无觉观非不观法。心智猛利摄诸方便不见有法若大若小。有细微相。如是众多名波罗蜜。亦从三十七助菩提法。复从十力四无所畏大慈大悲三念处诸妙功德。得此白毫。若我灭后佛诸弟子。舍离诸恶。去愦闹相。乐少语法。不务多事。昼夜六时。能于一时。于一时中分为少分。少分之中能须臾间。念佛白毫令心了了。无谬乱想分明正住。注意不息念白毫者。若见相好若不得见。如是等人。除却九十六亿那由他恒河沙微尘数劫生死之罪

设复有人。但闻白毛心不惊疑。欢喜信受。此人亦除却八十亿劫生死之罪。若诸比丘比丘尼。优婆塞优婆夷。犯四根本罪。不如等罪及五逆罪。除谤方等。如是众人若欲忏悔。昼夜六时身心不懈。譬如人在深草中行。四面火起。猛风吹来欲烧其身。此人作念。若火烧我。未死之间支节解散。我当云何得灭此火。若不设计命必不济。谁有智者多诸方便能救我命。设命全济于彼人所无所吝惜。作是思惟已。如太山崩。五体投地号泣雨泪。合掌向佛。赞叹如来种种德行。作是赞已诵忏悔法。系念在前。念佛眉间白毫相光。一日至七日。前四种罪可得轻微。三七日时罪相渐灭。七七日后。然后羯磨。事在他经。若比丘。犯不如罪。观白毫光闇黑不现。应当入塔观像眉间。一日至三日。合掌啼泣一心谛观。然后入僧说前罪事。此名灭罪。前五种罪。念白毫光经八百日。然后复有别羯磨法

佛告父王如来有无量相好。一一相中。八万四千诸小相好如是相好。不及白毫少分功德。是故今日。为于来世诸恶众生。说白毫相大慧光明消恶观法。若有邪见极重恶人。闻此观法具足相貌。生嗔恨心。无有是处。纵使生嗔。白毫相光亦复覆护。暂闻是语除三劫罪。后身生处生诸佛前。如是种种百千亿种。观诸光明微妙境界。不可悉说。念白毫时自然当生。如此观者名为正观。若异观者名为邪观

云何名观额广平正额广平正相。二轮光明。光明轮郭。千辐毂辋。成摩尼珠。形如毗纽羯磨天画。于画中流出上妙金色之光。来入白毫。绕毫七匝。上入额上诸毛孔中。乃至发际诸色相中。婉转下垂至于耳轮。上散入发。绕发七匝。从枕骨出绕前莲华相。团圆七匝七画分明。画有七色色生七华。华有一佛有七菩萨以为侍者。恭敬围绕右旋而转。如是额广平正三相。发际相。头诸毛孔相。脑中相。脑中亦有十四光。现诸脉中。中外俱彻明显可爱。踊出白光红紫间错。其色微细从枕骨出。亦绕前者三匝。一一画间有一佛坐。有二菩萨以为侍者。益更明显胜前数倍

云何观如来眉相。左右二眉形如月初。卷生诸毛稀稠得所随月形转。其色艳紫。毛端绀青。琉璃妙光色无与比。眉光两靡散入诸发。既入发已上至发杪。其光蠡起。蜂翠孔雀色无以类。犹如聚墨比琉璃光。亦复下垂从枕骨出。右旋宛转绕光四匝。一一画中出一化佛。有二菩萨及二比丘。翼侍左右。皆悉住立莲华须上。明显可爱胜前数倍。眉下三画及眼眶中。旋生四光青黄赤白。上向艳出入眉骨中。出眉毛端亦如前法。从枕骨出绕光四匝。四色分明。黄色化佛身黄金色。白色化佛身白银色。青色化佛身金精色。赤色化佛身车磲色。如是右旋益更明显胜前数倍

云何观如来眼睫相。如来眼睫。上下各生有五百毛。柔软可爱如优昙华须。于其毛端流出一光。如颇梨色入前众相。光明色中绕头一匝。从枕骨生围绕前光。纯生微妙诸青莲华。莲华台上有青色盖。有梵天王手执是盖。此相现时佛眼青白。白者过于白宝。百亿万倍。青者胜青莲华及绀琉璃。百亿万倍。上下俱眴如牛王眼。眼双眦头旋出二光。如青莲华极为微细。绕发一匝从枕骨出。映饰诸华令华开敷。光明益显。如是胜相无量功德。名如来眼。若有欲观如来眼者。当作此观。作此观者减损诸恶。闭目端坐正观佛眼。一日至七日。于未来世常得见佛。终不盲冥。亦不生于边地邪见无佛法处。慧眼恒开不生愚痴。佛告父王。是故智者为除盲冥。当观佛眼。佛有五眼。此观法中先说肉眼。明净光现观眼心利。傍生境界不可具说。谛观佛眼于少时间及观像眼。未来世中经五生处。眼常明净眼根无病。除却七劫生死之罪。佛告阿难。敕诸四众。勤观佛眼慎勿休废观佛眼者必获无量微妙功德。发际额广及发蠡文。眼眶眼眉。眼睫眼画。如是等众相光明。若能暂见。除六十劫生死之罪。未来生处必见弥勒。贤劫千佛威光所护。心如莲华而无所著。终不堕于三涂八难。若坐不见当入塔观。入塔观时。亦当作此诸光明想。至心合掌胡跪谛观。一日至三日心不错乱。命终之后生兜率天。面见弥勒菩萨色身端严。应感化导。既得见已身心欢喜入正法位。佛告父王。如是观者名为正观。若异观者名为邪观

佛说观佛三昧海经卷第二佛说观佛三昧海经卷第三

        东晋天竺三藏佛陀跋陀罗译

    观相品第三

佛告父王。云何观佛耳。佛耳普垂埵旋生七毛轮郭众相。及生王宫初穿耳时。令两耳孔内外生华。此莲华中及耳七毛。流出诸光有五百支。支五百色。色出五百化佛。佛五菩萨。有五比丘以为侍者。绕光右旋其数五匝。上下正等映照佛耳。佛耳可爱。如宝莲华悬处日光。佛在世时。一切大众咸见是相。是名佛耳色相光明。佛告父王。若四部众远离愦闹。正念思惟佛耳相者。此人生处耳根清净无诸秽恶。耳常得闻无上微妙十二部经。闻已信解如说修行。除灭八十劫生死之罪。若不见者。如前入塔谛观像耳。一日至十四日。亦得如向所说功德。是故智者当勤修集正观佛耳。勿使废失。若病苦时倚侧偃卧。亦当观佛清净耳相。如是观像耳。如前所想心不懈退。后身生处亦常得与陀罗尼人以为眷属。闻法忆持譬如贯珠。如是观者名为正观。若异观者名为邪观

云何观如来方颊车相。如来颊上六画中。左右正等有妙光色。辉艳倍常。阎浮檀金光色遍照。令佛面相如净金色。譬如和合百千日月。是名如来方颊车相。佛灭度后佛诸弟子。系念思惟作是观者。除灭百劫生死之罪。面见诸佛了了无疑。如是观者名为正观。若异观者名为邪观

云何观如来师子欠相。佛张口时如师子王口方正等。口两吻边流出三光。其光金色过踰前光百千万倍。上入耳光围绕诸发。从枕骨出绕前圆光。一一画间有三化佛。一一化佛有二梵王以为侍者。是名如来师子欠相。佛灭度后四部弟子作是观者。除灭十劫生死之罪。后身生处。口中恒有优钵华香。有所宣说人皆信受。譬如帝释三十二天一切信用。如是观者是名正观。若异观者名为邪观

云何名观如来鼻相。如来鼻高修而且直当于面门。如来鼻端如鹰王嘴。鼻孔流光上下灌注。上者上入眼眉白毫相发际。如是直入顶肉髻骨。譬如金幢。从枕骨出变成众华。华上皆有天诸乐神手执乐器。遍入一切诸化佛间。以为导从绕光十匝。下者直至入佛髭中。围绕髭毛。令髭毛根有华开敷。如稊米粒。流入唇齶至诸齿间映饰咽喉。下至佛胸成光明云。表里清净无诸尘翳。如琉璃器成金光焰。是名如来真净鼻相。佛灭度后佛诸弟子如是观者。除灭千劫极重恶业。未来生处。闻上妙香心意了了不着于香。常以戒香为身璎珞。如是观者名为正观。若异观者是名邪观

云何观如来髭。诸髭毛端开敷三光紫绀红色。如是光明。直从口边旋颈上照。围绕圆光作三种画。其画分明。色中上者。一一画间生一宝珠。其珠光明有百千色。珠下白华茎茎相跓。满三匝已。然后彼光还入髭中。是名如来髭毛光相。佛灭度后作是观者。除三十劫生死之罪。后身生处身诸毛孔有自然光。心不乐着家居眷属世间之乐。常乐出家修头陀行。如是观者名为正观。若异观者名为邪观。云何观如来唇色赤好如频婆果相。于上下唇及与龂齶。和合出光。其光团圆。犹如百千赤真珠贯。从佛口出入于佛鼻。从佛鼻出入于白毫。从白毫出入诸发间。从发间出入圆光中映饰诸华。口四十齿印上生光。其光红白光光相照。照四十齿。令四十齿根。自然齐白如颇梨壁。上下齐平无参差者。齿间文画流出诸光亦红白色。如是众色。佛在世时映耀人目。佛灭度后。当以心眼观见此色。佛诸弟子作此观者。除二千劫生死之罪。后身生处唇口微妙齿不疏缺。得色中上色。虽得是色心不贪着。常见诸佛声闻缘觉。为之说法令心不疑如是观者名为正观。若异观者名为邪观

云何观如来广长舌相。如来舌者。是十波罗蜜十善报得。其舌根下及舌两边。有二宝珠。流注甘露渧舌根上。诸天世人。十地菩萨。无此舌相亦无此味。舌上五画如宝印文。如此上味入印文中。流注上下入琉璃筒。诸佛笑时动其舌根。此味力故舌出五光五色分明。绕佛七匝还从顶入。佛出舌时。如莲华叶。上至发际遍覆佛面。舌下亦有众杂色脉。如此上味。流入脉中。其味力故变成众光。有十四色。二光上照无量世界。一一光间有一光台。其色众妙不可具名。一一光台龛室无数。一一龛中。无量化佛结加趺坐。声闻菩萨一切大众。皆悉围绕。过于上方无量世界。化为一佛。佛身高显如须弥山。如是诸佛其数无量。皆出舌相亦复如是。二光下照至阿鼻狱。令阿鼻狱如黄金色。佛舌力故令受苦人暂得休息。自慨前世所作恶事。如是下过无量世界。一一界中化宝华树。叶如佛舌。舌相放光。光光相照变成化佛。其化佛身纯白银色身相具足。一一化佛出广长舌。舌相光中有诸化佛。如是化佛其数无量。化佛光明成一银山。其山高大无量无边。于其山间。纯生银树金华银果。树下皆有白玉莲华。华上复有白玉化人。玉人脐中化生六龙。其龙口黑。龙色纯白。是化玉人其数无量。复更下过照无量界。见白玉树。从下方出至娑婆界。复更蓊蔚至三界顶。枝条扶疏其叶有色。色九十八。一一树叶遍覆三界。其诸叶间复有龙象虎狼师子毒虫恶兽猫狸鼷鼠。无事不有。其余境界。坐者自见。见一光照东方。令东方地皆作金色。山河树木一切火烧。火光金光各不相障。于金光端有诸化佛。佛佛相次。乃至东方无量世界。譬如稻麻间无空缺。一佛皆有无量菩萨。以为侍者。是诸菩萨亦出舌相与佛正等。如是舌相。无量光明化成光云。于光云中。如微尘等无量化佛结加趺坐。如是光明其数无量。时火焰端有五夜叉手执利剑。头有四口吸火而走。如是诸鬼其数无量。乃至东方亦复如是。一光照南方无量世界。令其世界作琉璃色。琉璃地上生黄金华。黄金华上生马脑华。马脑华上生车磲华。车磲华上生玫瑰华。玫瑰华上生虎魄华。虎魄华上生珊瑚华。珊瑚华上生金精华。金精华上生金刚华。金刚华上生摩尼光华。摩尼光华一一叶间。有无量色百亿宝华。一一华须。有无量释迦牟尼。结加趺坐。菩萨大众以为围绕。时诸大众身毛孔中亦出此华。一一华上现希有事。亦如上说。是诸化佛出广长舌相开现光明。倍胜是相百千万倍。于诸华间有妙宝座。高显可观如梵王床。一一床上有大菩萨。身相端严犹如弥勒。亦出广长舌相。其舌光明作摩尼网。覆诸化佛及与大众。摩尼网间出大宝光。其宝光端。复有无量无边化佛。一一化佛。各有无数比丘侍从。时诸比丘坐金莲华身黄金色。安禅合掌入念佛定。身诸毛孔出金色光。此一一光化成化佛。犹如金山。围绕比丘。有化比丘亦围绕佛。如是众多数不可说。一光照西方。令梨西方地作颇梨色。颇地上有金刚云。金刚云中有白宝云。白宝云中有赤真珠云。赤真珠云中有白真珠云。白真珠云中有紫真珠云。紫真珠云中有绿真珠云。绿真珠云中有红真珠云。红真珠云中有阎浮檀金沙云。金沙云中有金刚摩尼微尘云。金刚摩尼微尘云中有一切宝色微尘云。如是一一云中。有五十六亿色。微妙鲜好过于眼界。惟有寂心可与此合。如是诸相。复有无量微尘化佛。一一化佛。无量微尘诸化弟子。诸尘不大。诸佛不小。端严微妙如释迦文。亦出舌相。一光照北方。令北方地作车磲色。车磲地上有金刚塔。一一佛塔百千妙塔以为围绕。其数无量。塔极小者。高五十亿那由他由旬。一一塔中。复有百亿尘数龛窟。一一窟中。无量无边诸宝色水自然踊出。是诸水上有大莲华开现光明。其光现时香气微妙。胜海此岸栴檀之香。百千万倍。是香变为微妙光明。诸光明中有诸化佛。身色微妙。宝中上者。一切众宝从舌相出。时一一窟无量光明。一一光明无量化佛。一一化佛复出舌相。光明无量。亦成香塔。过于北方无量世界。不可穷尽。但从念佛三昧海生。一光照东南方。令东南方其地马瑙色。马瑙地上有虎魄山。虎魄山上生七宝林。七宝林间有十泉水。水十宝色。水色放光。普照东南方无量世界。光所照处有大宝山。一一山间一一树下。生曼陀罗华摩诃曼陀罗华。于华台上有一化佛。纯琉璃色内外清彻不可具名。杂宝色光绕身千匝。一一光中无量化佛。一一化佛无量大众皆琉璃色以为围绕。一一化佛。出舌相光明化成宝山。如是宝山。复过东南方无量世界

一光照西南方无量世界。令西南方地纯珊瑚色。珊瑚地上生碧玉楼。楼极下者高五十亿由旬。楼一亿柱。此一一柱百亿宝色。一一宝放无数光。此一一光。化为无量千亿宝树。一一树下有六泉水。其水从树根入从树条出。流出之时有六宝色。一一水中生一莲华。其华鲜白。华上复有一白化佛。其身极白过踰一切。白色之上有五百色。微妙光明围绕佛身。一一光明化无数佛。一一化佛有无数菩萨。楼阁诸柱皆放光明。一一光中无数化佛。青色化佛。在于珊瑚地上经行。白色化佛。在于青玉楼上经行。楼阁龛室。皆有如是无数化佛。亦出舌相放大光明。其光微妙。照西南方无量世界。不可穷尽

一光照西北方。令西北方作虎魄地。于虎魄地上生真珠山。真珠山上有珊瑚树。白玉叶摩尼华。黄金果金精须。树下自然有大师子其身七宝。师子眼中放大光明。照虎魄地。令虎魄地生一大莲华。其华周圆无量无边。一一华上有光明云。其云紫色。云上有网绿真珠色。真珠网间生金莲华。金莲华上有一化佛。身紫金色。青黄赤白五色光明。以为围绕。一一光中无数化佛。一一化佛无量大众。是诸化佛出广长舌相。亦复如是。如是遍照西北方无量世界。舌相光明不可穷尽

一光照东北方。令东北方地纯金刚色。于金刚地上生华。七宝合成。华上生幢阎浮金色。幢头有华。其华无量百千宝色。有无数叶。一一华叶。化为无量百千宝帐。一一帐角有七宝幢一一幢头有七宝盖。其盖弥覆东北方地一切世界。盖有五幡纯黄金成。幡有万亿无量宝铃。铃出妙音。赞叹佛名。赞叹礼佛。赞叹念佛。赞叹忏悔。出是声已。宝帐下地大光踊出。其光微妙无数千亿。一一光中无量化佛结加趺坐。坐宝帐内。复有踊身住虚空中。东踊西没西踊东没。南踊北没北踊南没。边踊中没中踊边没。或现大身满虚空中。大复现小身如芥子。于虚空中行住坐卧。身上出水身下出火。身下出水身上出火。履地如水履水如地。水中生莲华大如车轮。华上有佛结加趺坐。如是化佛无量无边。同时见佛踊身空中作十八变。火上生一金须弥山。星宿日月七宝庄严。诸龙夜叉及大海水。如是众多须弥山。左右一切诸有皆悉出现。如是众山其数无量。山顶有佛亦出舌相。舌相光明。遍照东北方无量世界。不可穷尽

一光上照从阎浮提四天王宫。令四天王皆见释迦牟尼世尊。人中之日乘七宝台。与诸大众往彼天上。诸天见已发菩提心。乃至无色界一切诸天皆见是相。了了分明心不谬乱。令无色天不谤涅槃起菩提想。一光下照诸阿修罗。诸夜叉等。诸乾闼婆。诸迦楼罗。诸紧那罗。诸摩睺罗伽。诸龙。诸罗刹。诸富单那。诸金毗罗。诸啖人精气鬼。诸鸠槃茶。诸吉遮。诸旷野鬼。诸饿鬼。诸食吐鬼。诸食涕唾鬼。诸食脓血鬼。诸食屎尿鬼。诸山神。诸树神。诸水神。如是等若干百千诸鬼神等。其身暂时作天身色柔软悦乐。譬如比丘入第三禅。是诸鬼等各随业行。自发三种菩提之心。诸饿鬼等。舌相光现时。犹如冷水灭节间火。火既灭已。融铜堕地直陷入地。时诸饿鬼皆悉张口唱言饥饥。于千万岁不曾见水。今遇此水除热清凉。是谁力耶。空中声曰。愚痴饿鬼。有佛世尊放舌光明。其光照汝。令汝苦毒悉得休息。作是语已。一一鬼前见一慈母坐莲华台。譬如慈母抱持婴儿与乳令饮。使鬼饱满。既饱满已发菩提心。既发心已。一一慈母化成一佛。时一一佛亦放舌相救诸饿鬼。佛摄舌相。此光千色绕佛千匝。光有千佛从佛顶入。入已。佛身严显。三十二相八十随形好。皆悉明耀遍体流光。晃晃昱昱胜于百千无数亿日。佛告父王。如来舌相及舌功德。观舌境界其事如是。佛灭度后。念佛心利观佛舌者。心眼境界如向所说。作是观者。除去百亿八万四千劫生死之罪。舍身他世。值遇八十亿佛。于诸佛所。皆见诸佛广长舌相。放大光明。亦复如是。然后得受菩提道记。佛告阿难。汝持佛语莫令忘失。告诸弟子。正身正意端坐正受观广长舌者。如我在世等无有异。若有众生闻此说者。心不惊疑不生诽谤。不恼念佛者。劝进念佛者。供养恭敬尊重赞叹。如是等人虽不念佛以善心故除却百劫极重恶业。当来生处值遇弥勒。乃至楼至佛。于千佛所闻法受化。常得如是观佛三昧。佛告父王。如是观者名为正观。若异观者名为邪观

云何观如来颈相。缺盆骨满相。臆德字相。万字印相。是众字间出生圆光。颈佣圆相如琉璃筒。悬好金幢。咽喉上有点相。分明犹如伊字。一一点中流出二光。其一一光绕前圆光。足满七匝众画分明。一一画间有妙莲华。其莲华上有七化佛。一一化佛有七菩萨以为侍者。一一菩萨二手皆执如意宝珠。其珠金光青黄赤白及摩尼色皆悉具足。如是围绕诸光画中。是名佛颈出圆光相。胸德字文。万字印中。缺盆满相。腋下珠相。是诸相中。一一胜相。有五百色杂色光明。共相映发各不相妨。一一色光围绕颈光足五百匝。一一画中五百化佛。一一化佛五百菩萨。以为侍者。五百比丘手执白拂侍立左右。诸化佛光。化菩萨光。化比丘光。于众光中皆悉显现。大须弥山四天王宫。诸天宫殿。日月星辰。龙宫神宫。阿修罗宫。十宝山神。四海水神。及诸水性乾闼婆等。诸婆罗门所尊敬事。九十五种神仙异术。父母所亲历世因缘。如是等神。于佛光中悉皆显现。复有百亿无量鬼神。影现圆光。为阎浮提人说孝养事。此影化人。见众人时。皆自说言。我是汝父。我是汝母。无量世中。汝字某甲。我名某甲。如是众多无量大众。皆是众生所尊敬事。于佛圆光了了如画如镜见面。如是众相名为圆光。围绕佛颈。上亦一寻下亦一寻。左亦一寻右亦一寻。足满八尺。于圆光中流出化佛。一切众生所希见事。皆于中现了了分明。于圆光上有金色艳。如摩尼珠严显可爱。摩尼艳间化生华树。其树金色。百千万亿阎浮檀金。不得为比。一一树下有宝莲华。华上化佛真黄金色。如琉璃盖以覆佛上。显发金颜分齐分明。如是化像其数无量。佛在世时。世尊行时。此光照地前一由旬纯黄金色。后一由旬纯黄金色。左一由旬纯黄金色。右一由旬纯黄金色。有人近佛左右行者。其人臭秽皆悉不现。人远望之同为金色。佛坐树下此光赫奕。如众金华散祇树间。有人谛观佛项光者。前行看者见佛在前。从后看者见佛在后。左边看之见佛在左。右边看之见佛在右。八方人来遥见项光。各作是言。瞿昙沙门。在金山中游行自在。来向我所。如是众人各各异见。是名项光。见此光时。佛顶肉髻生万亿光。光光相次。乃至上方无量世界。诸天世人十地菩萨。亦不能见其发右旋上妙蠡文。蜂翠孔雀色不得比。有千光明赫奕而起。此光起时佛肉髻骨及佛头中。一切妙相皆悉映现。满足面相光明可爱。人天净国报得妙华。不得为譬。佛面光明益更明显。佛颈佛胸及以佛臂。胜前数倍光更明显佛膝出光。其光白色。分为四支。随身上转化作白华入项光下。脐出五光光有二支。支有五色入胁骨中。如白玉筒盛众色水从两肩后自然踊出。如金摩尼焰焰相跓。诸摩尼光有妙莲华。一一莲华上有七化佛。如画如印。随佛身转不相障碍。鹿王[跳-兆+尃]。钩锁骨。蟠龙结间。如是中间出诸金光。此一一光从一节出入一节间。如是和合成一大光。如金摩尼。住佛肘后艳至顶光。赤铜爪。足指缦网各各有光。其光赫奕琉璃颇梨。备七宝色从佛足趺。副称佛身如摩尼珠。亦如前光上至圆光。足下轮相及长足跟。各生一华。其华微妙。犹如净国优钵罗华。佛足跟出围绕诸光。满足十匝。华华相次。一一华中有五化佛。一一化佛五十菩萨以为侍者。一一菩萨。其顶上生摩尼珠光。此相现时。佛身毛孔一一孔中。旋生八万四千微细诸小光明。严饰身光极令可爱。如是种种杂色。名为常光。名适意光。亦名随诸众生所乐见光。亦名施众生眼光。此光一寻其相众多。瞿师罗观佛。此光随小。乃至他方诸大菩萨。观佛之时此光随大。如杂华说。佛告父王。及敕阿难。吾今为汝悉现具足身相光明。作是语已。佛从坐起告阿难言。汝诸比丘。并诸释子。皆悉起立合掌向佛。谛观如来。从顶光明下至足光。从顶肉髻下至足下平满之相。复敕比丘。复从足下平满相。上乃至肉髻。亦观如来身光项光。复敕。从佛一一毛孔尽一身分。一一事观皆令了了。如人执镜自观面像。若生垢恶不善心者。若有毁犯佛禁戒者。见像纯黑犹如炭人。释子众中五百释子。见佛色身犹如炭人。比丘众中有一千人。见佛色身如赤土人。优婆塞众中有十六人。见佛色身如黑象脚。优婆夷众中二十四人。见佛身色犹如聚墨。如是四众各各异见。比丘尼众中有比丘尼。见佛色身如白银色。优婆夷众中有优婆夷。见佛色身如蓝染青色。如是四众观佛色身所见不同。时诸四众闻佛是语。啼哭雨泪合掌白佛。我等今者不见妙色。五百释子自拔头发。举身投地鼻中血出。佛生我家。佛初生时。众人皆见纯黄金色。唯有我等。恒见佛身犹如炭人。亦如羸瘦诸婆罗门。我等宿世有何罪咎惟愿佛日。为我解说。说是语已。自拔头发。号哭如前婉转自扑。尔时慈父出梵音声。安慰诸释及诸四众。善男子等。如来佛日出现世间。正为除灭汝等罪咎。汝等还起。佛自知时当为汝说。尔时大众从地起已。绕佛三匝礼世尊足。五百释子诣阿难所。敬礼阿难白言。尊者。我之与汝俱生释家。汝独聪明总持佛语。犹如泻水置于异器。我宿罪故不见佛身。何况闻法。说是语已对阿难哭。尔时如来以梵音声告诸释子。及敕大众。诸兄弟等。勿复号哭。过去有佛。名毗婆尸如来应供正遍知。出现于世教化众生。度人周讫般涅槃后。于像法中有一长者。名日月德。有五百子。聪明多智。广知世间一切文艺。星宿历数无不贯练。其父长者信敬佛法。常为诸子说观佛心。亦说甚深十二因缘。诸子闻已疑惑不信。言父老耄。为诸沙门之所诳惑。我诸书籍都无是义。父今何处求觅得此。时父长者愍诸子故。隐匿佛法不为宣说。是时诸子同遇重病。父观诸子命不支久。到诸子所。一一儿前泣泪合掌。语言。汝等邪见不信正法。今无常刀割切汝身。汝心烦闷为何所怙。有佛世尊名毗婆尸。汝可称之。诸子闻已敬其父故。称南无佛。父复告言。汝可称法。汝可称僧。未及三称其子命终。以称佛故得生天上四天王处。天上寿尽。前邪见业堕大地狱。地狱受苦。狱卒罗刹。以热铁叉刺坏其眼。受是苦时忆父长者所教诲事。以念佛故从地狱出。还生人中贫穷下贱。尸弃佛出亦得值遇。但闻佛名不睹佛形。毗舍佛出亦闻佛名。拘楼孙佛出亦闻其名。拘那含牟尼佛出亦闻其名。迦叶佛出亦闻其名。以闻六佛名因缘故。与我同生。虽生此处。我今身相端严乃尔。汝见我身如羸婆罗门。我身金色。阎浮檀金色不得比。汝见我色犹如炭人。佛告诸释子。汝今可称过去佛名。为佛作礼。并称汝父。礼过去佛。亦称我名敬礼于我。未来有佛号曰弥勒。亦当敬礼。说汝先世邪见之罪。今佛现世沙门大众一切云集。汝当向诸大德众僧发露悔过。随顺佛语忏悔诸罪。佛法众中。五体投地如太山崩。向佛忏悔心眼得开。见佛色身端严微妙。如须弥山光显大海。既见佛已心大欢喜。白佛言。世尊。我今见佛三十二相八十种好。身黄金色。一一相好无量光明。作是语已寻时得道。成须陀洹。白父王言。我等今者。欲于佛法出家学道。父王告言。汝自白佛。佛听汝不。即往佛所。白言。世尊。我欲出家。佛告释子。善来比丘须发自落即成沙门。身所著衣化成法服。合掌礼佛称南无佛。未举头顷成阿罗汉。三明六通皆悉具足

佛告父王。大王今者。见诸释子忏悔除罪成罗汉不。父王白佛。唯然已见。佛告父王。是诸比丘前世之时。以恶心故谤佛正法。但为父故称南无佛。生生常得闻诸佛名。乃至今世遭值我出。见佛色身及见众僧。闻佛所说忏悔众罪。因忏悔故诸障消除。诸障除故成阿罗汉。佛告阿难。我涅槃后诸天世人。若称我名及称南无诸佛所获福德无量无边。况复系念念诸佛者。而不灭除诸障碍耶。佛告诸比丘。汝等所以见佛色身如赤土者。汝等前世于然灯佛末法之中出家学道。既出家已于师和上起不净心。然其和上得罗汉道。知弟子心。告言。法子。汝于和上及众僧所莫起疑意。若起疑意。于诸净戒永无得理。时诸比丘闻和上说心生嗔恨。是时和上知弟子心。渐渐自制不为其说。时千弟子。随寿修短各欲命终。和上犹存而不涅槃。是时和上到弟子所。而说是言。汝诸比丘。初受法时疑师疑戒虚食信施。汝等今者欲何所怙。诸人闻是心惊毛竖。白言。和上。为我说法。和上告曰。汝今事切。不宜余处教汝忏悔。汝今但当称然灯佛如来应供正遍知十号具足。尔时诸比丘用和上语。咸皆称言南无诸佛。既称佛已寻即命终。乘善心故得生天上。上生忉利封受自然。毕天之寿下生世间坐前世罪虚食信施。堕饿鬼中烊铜灌咽。寿命长远八万四千岁。饿鬼罪毕生畜生中。畜生罪毕还生人中。贫穷下贱以为庄严。既生人中闻诸佛名。因于前世出家力故。信心内发如前。宿识称南无佛。以称佛名因缘功德。八千世中常值佛世。而眼不睹诸佛色身。况复闻法。乃至今日遭值我世。见我身体状如赤土

佛告诸比丘。汝等先世。于不疑处横生疑见。于可信处横生不信。以是罪故。不见诸佛不闻正法。如我今者现生王宫。我色真正色中最上。汝见赤土。时诸比丘闻佛此语。各自悔责。偏袒右肩合掌向佛。而作是言。我于前世无量劫时。邪见疑师虚受信施。此因缘故堕地狱中。今虽得出。于无量世不见诸佛但闻其名。今见世尊身赤土色正长五尺。是时世尊。披僧祇支示胸德字。令比丘读诵德字已。知佛功德智慧庄严。于万字印中。说佛八万四千诸功德行。比丘见已。赞叹佛言。世尊甚奇特。但于胸字说无量义。何况佛心所有功德。说是语已向佛忏悔。五体投地如太山崩。悲号雨泪对佛啼哭

是时世尊。软言安慰。令诸比丘心得欢喜。既欢喜已。犹如风吹重云四散。显发金颜三十二相炳然睹见。既见佛已。心大欢喜发菩提心。佛告父王。此千比丘殷勤求法心无懈息。于未来世过算数劫。当得作佛。号南无光照如来应供正遍知十号具足。其作佛时。地纯金色七宝行树。妙宝楼阁以为庄严。其土众生。皆是惭愧忏悔之徒。纯是菩萨发无上意。如是千佛次第出世。亦如贤劫千菩萨等次第成佛

佛告大王。是诸比丘疑师疑僧。获大重罪如向所说。称南无佛所得果报。今于我世现前受记。何况正念思惟佛者。诸比丘尼见佛银色。从座而起偏袒右肩。为佛作礼。白言世尊。如来今者自说身色。除诸众生无量重罪。我等何故从生出家。乃至今日见佛银色银华银光。诸庄严具悉皆是银。我等云何。不见如来金光赫艳。亦不见佛三十二相果报功德。是时如来闻诸尼语。即便微笑。有金色光从面门出。绕佛银身足满十匝。此光现时。诸尼见佛身紫金色三十二相。光明显照不可具说。诸尼见已。观眉间白毫相右旋婉转。见已欢喜。应时即成阿罗汉道。三明六通具八解脱

诸比丘尼自识宿命。曾于前世无量劫时。有佛出世。亦名释迦文。彼佛灭后有诸弟子出家学道。僧中一人游行教化。见五百童女在山泽中欢娱自乐。时彼比丘摄持威仪。安庠徐步至诸女所。敷尼师檀在地而坐。诸女见已各各欢喜。而作是言。此空闲处神仙所游忽然有此胜士比丘。来在此坐此必非凡。我宜供养。各脱银镮散比丘上。比丘精进德行纯备。后必成佛。愿我见之时。如所散镮。汝等贪着银宝色故。生生常在白银山中。受银山神宝女之身。以礼沙门奉献银镮。今遭我世沐浴清化成阿罗汉。尔时比丘则我身是。时诸女者汝身是也。汝于前世供养沙门礼诸佛故。从是已来恒值诸佛。佛告父王。佛人中宝祐利处多。若闻名者。礼拜供养获大重报。何况系念思佛正颜

优婆塞众中见佛世尊如黑象脚者。即从坐起偏袒右肩。合掌向佛。而作是言。我生此国。我国王子出家成佛。阿私陀仙见三十二相。即为我说。地天太子成佛无疑。我闻是语归依于佛。从是以来恒随佛后。受三归依。受持八斋。受五戒法。然我罪咎。但闻佛声不见佛形。每见佛时如黑象脚。何酷之甚。说是语已。举手推胸号泣躄地。是时如来以梵音声。犹如慈父安慰其子。告诸优婆塞言。法子还坐。佛当为汝除断疑悔灭诸障碍。说是语已。告诸优婆塞。汝等先世无量劫时。于阎浮提各作国王。王领诸国快得自在。有诸沙门为利养故。为汝邪说不顺佛教。法说非法。非法说法。汝等诸人皆信用之。是人以此诸恶教故。命终之后堕阿鼻地狱。汝等随顺恶友教故。命终亦堕黑闇地狱。由前闻法善心力故。今遭我世受持五戒。汝今应当佛法僧前说汝邪见邪友所教诚心忏悔。诸优婆塞闻佛此语。称南无佛。称南无法。称南无僧。说诸罪咎诚心忏悔。时佛即放眉间大人相光。照诸人心心意开解。同时即得须陀洹道。诸优婆塞既得道已。见佛色身。端严微妙世间无比。求佛出家成阿罗汉

优婆夷众中见佛色身犹如聚墨者。即从坐起合掌向佛。雨泪号哭悲不能言。举手拍头。气绝躄地。是时世尊见是事已。以梵音声安慰诸女。告言。诸女。何故愁忧乃至如是。是时诸女闻佛语声。诸情根开。即起合掌。白世尊言。佛日出世普照一切。众人皆见如月盛满。唯我不见。佛说法时诸人皆闻八种音声。我独不闻如生聋人。尊者舍利弗。为我授戒。乃闻其说有五戒法。每至佛会见佛世尊犹如聚墨。唯愿天尊。大慈悲故除我罪咎。令我得见。是时世尊。于师子座还坐申脚。出千辐轮相以示诸女。诸女但见众妙莲华从轮相出。华上化佛犹如墨人。复更合掌向佛作礼。白言世尊。为佛弟子已经多时。惟有今日见妙莲华。见诸化佛犹如墨涂。宿有何罪眼闇乃尔。佛告诸女。谛听谛听善思念之。如来今者为汝分别。过去久远无量世时。时世有佛。号一宝盖灯王如来应供正遍知。彼佛灭后。于像法中有诸比丘。入村乞食执钵持锡威仪不犯。至淫女家。时诸淫女取比丘钵。盛满钵饭戏比丘言。汝释种子。颜色可恶犹如聚墨。身所著衣状如乞人。汝之可恶天下无比。自言无欲谁当念汝。尔时比丘闻此语已。掷钵空中飞腾而去。诸女见已惭愧忏悔。而作是言。我等今者施沙门食。愿于来世身得自在犹如沙门。佛告诸女。尔时诸女饭罗汉者。今汝等是。汝以善心施比丘食。二千劫中常不饥渴。坐前恶骂淫欲因缘。六十小劫堕黑闇狱。由前发愿善心不灭。今遭我世得受五戒。乃是供养阿罗汉故。见舍利弗。不见我身

尔时世尊说是语已。即于脐中出大莲华。其大莲华化成光薹。其光台中有百千无数声闻比丘。如舍利弗目健连等。于佛光台神通自在作十八变。诸女见已心生欢喜。应时即以智慧火烧二十亿洞然之结得须陀洹道。诸优婆夷既得道已。见佛色身端严微妙。惟不见佛白毫相光。佛告父王。戏弄恶口。乃至得道所见不明。是故诸人当勤护口。专心正意观佛三昧。以见佛故获无量福。是时世尊。欲令大众见佛色身了了分明。佛即化精舍如白玉山。高妙大小犹如须弥。百千龛窟于众龛窟影现诸像与佛无异。时佛前地有大莲华。其华千叶。叶有千光。光千化佛。佛千弟子以为侍者。佛告阿难。佛灭度后。佛诸弟子。若能割捐诸事。捐弃诸恶。系念思惟佛常光者。佛不现在亦名见佛。以见佛故。一切诸恶皆得消除。随其所愿于未来世当成三种菩提之道。佛告阿难。如此观者是名正观。若异观者名为邪观

佛说观佛三昧海经卷第三佛说观佛三昧海经卷第四

        东晋天竺三藏佛陀跋陀罗译

    观相品第三之四

佛告父王。云何观如来放常光相。如来今者。为未来世诸凡夫人。当现少光。彼诸凡夫当学是观。如是观者亦如今日见佛光相无有异也。尔时世尊放肉髻光。其光千色。色作八万四千支。一一支中。八万四千诸妙化佛。其化佛身身量无边。化佛顶上亦放此光。光光相次乃至上方无量世界。于上方界有化菩萨。如云微尘从空而下围绕诸佛。此光现时。十方微尘世界诸佛亦悉得见。此光直照诸佛顶上。诸佛放光。其光亦照释迦文顶。佛告阿难。众生欲观释迦文佛肉髻光明。当作是观。作是观者若心不利。梦中得见。虽是心想能除无量百千重罪。如是观者。现身必见诸大菩萨。见菩萨故闻其说法。闻说法故得陀罗尼。其陀罗尼名旋忆持。如是观者名为正观。若异观者名为邪观

佛告父王。云何名为观于如来眉间光明。如来今者。为此后世诸众生故。当少现于白毫相光。作是语时。时佛眉间即放白毫大人相光。其光分为八万四千支。亦八万四千色。遍照十方无量世界。一一光色化一金山。一一金山无量龛窟。一一窟中有一化佛。结加趺坐入深禅定。声闻菩萨百千大众。以为眷属。时佛窟中有诸化佛。皆放白毫大人相光。亦照十方无量世界。皆如金色金色地上有金莲华。金莲华上皆有化佛。亦皆同号名释迦文。诸佛眉间。亦放此光。其光遍照十方世界。犹如百千亿须弥山王共合一处。诸须弥山映现诸佛。佛身高显与山正等。是等化佛眉间光明绕诸化佛满七匝已。还入释迦牟尼眉间。此光入时。佛身毛孔一毛孔中有一化像。一一化像身毛孔中。化成八万四千妙像。皆是三千大千世界。一切众生所希见事。是名如来八十好中一好光明。如是八十随形好光。说不可尽。如来少现白毫光明。父王所将众中有八千人。远尘离垢得法眼净。佛告阿难。如来白毫相光。诸修多罗中佛已广说。如是妙光惟佛佛见。十地菩萨见不明了。是故此中少分而说。说少分者为凡夫人。佛灭度后。如是观者名为正观。若异观者名为邪观。此光除罪如向所说。惟见光者心得了了见百亿佛。见白毛者是心想见

云何观如来额广平正相。如来面上三轮相。发际相。如是众相。一一相中皆出金光。其金色光化成金床。一一床上有千菩萨。拘楼孙驮为始下逮楼至。是千菩萨皆放光明坐金床上。如是百亿千万菩萨。百亿千万金床。其金床上皆有宝帐。一一宝帐有千光明。一一光明成千宝幢。一一幢上千万宝盖。众宝盖下有诸宝幡。诸宝幡中无量化佛。是诸化佛皆说苦空无常无我。说此偈时。一切化佛亦皆说此。释迦文佛方身丈六。在行者前举其右手。而作是言。善哉善哉。善男子。汝今能观诸佛相好。我等先世行菩萨道。与汝无异。汝今能观诸佛境界。此境界者。但是汝心妄想所生。作是语已即灭不现。额上诸光复更明显。其光流出有百千亿。一一光明照宝床上诸菩萨面。彼菩萨面亦出光明。照释迦文。此相现时。行者真观佛面了了无疑。佛告阿难。佛灭度后。佛诸弟子。能如是观真见佛面。与我住世等无有异。作此观者。除却一亿劫生死之罪。后身生处面见诸佛生诸佛家。诸佛菩萨以为眷属。如是观者名为正观。若异观者名为邪观

云何观如来鼻出光明。鼻出光明分为四支上入佛眼佛眉佛睫。出大光明。其光叆叇如龙象形。遍照十方无量世界。入诸佛眼。此相现时十方大明。是时行者见十方界地及虚空。诸佛满中。一一佛眼眉睫鼻孔放大光明。亦复如是。佛眼两光其明遍照入诸佛眼。于虚空中化成光台。其光台上纯是光云。光云青白世界无比。于青光中有青色化佛。于白光中有白色化佛。此青白色佛左右分明。百宝色光以为其云。如神通人飞腾云间。身诸毛孔犹如华树。一一华树上至梵世。诸华叶间。有百千亿声闻比丘。一一比丘着千纳衣。千纳千色。一一色中百千化佛。皆纯金色。是诸比丘。踊身云中亦随佛后。如大龙象行其子随从。佛告阿难。佛灭度后佛诸弟子。若能正心观佛眼光。即于现世重障得除。于当来世常得观佛不离佛日。虽处母胎常入三昧。在母胎时见十方佛。皆放眼光来照其身。胎[穀-禾+卵]中时常受妙法。况出于外。如是观者名为正观。若异观者名为邪观

鼻出二光。其光遍照十方世界。其一一光化成大水。其水住空流入诸光。此水入时一切光明惟更明显。一一光间出颇梨山。颇梨山间生七宝华。其华台上踊出众水。其水金色犹如金幢。其金幢内有百千万无量化佛。一一化佛方身丈六。身毛孔中八万四千上妙宝色。诸宝色中复放光明。其光微妙有恒沙色。佛告阿难。佛灭度后佛诸弟子。作是观者。除却千劫极重恶业。后世生处心无所著。不处胞胎恒常化生。既化生已身光具足不离诸佛。如是观者名为正观。若异观者名为邪观

云何观如来面门光明。其光白色犹如宝山内外俱净。于宝山内无量化佛真金精色。时诸化佛面门出光。其光五色遍照十方入诸佛面门。此相现时。行者行住坐卧。恒闻如来说四念处身受心法。并说境界令行者闻。闻已忆持闭目思惟。此光力故即得四念处法。时十方佛及释迦文。于三昧中各申右手摩行者顶。而作是言。善哉善哉。善男子。汝能真实行念佛定。如是观者名为正观。若异观者名为邪观

云何观如来耳。耳出五光其光千色。色千化佛。佛放千光。如是光明遍照十方无量世界化成一华。其华甚大量不可知。除佛心力无能知者。是莲华中。百千万亿无量佛刹皆于中现。百千万亿诸大菩萨坐一莲华须。华须不大菩萨不小亦不相妨。如是菩萨耳普垂睡。如金莲华悬处日光。亦于耳中旋生五光。此相现时。佛耳中毛如帝释树众所喜见。佛告阿难。佛灭度后佛诸弟子作是观者。常闻百亿千佛及诸菩萨说众妙法不坏耳根。如是观者名为正观。若异观者名为邪观

云何观如来颈相。颈相出二光其光万色。遍照十方一切世界。有诸众生善根熟者遇斯光明。悟十二缘成辟支佛。此光照诸辟支佛颈。此相现时。行者遍见十方一切诸辟支佛。掷钵虚空作十八变。诸辟支佛一一足下皆有文字。其字演说十二因缘。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。一字一光一光十二音。一音说苦空无常无我。一音演说十二因缘。如是辟支佛足下光中皆有是字。逆顺往复凡十二遍。是名生死之根本也。此光照诸辟支佛已。还入佛颈。作此观者。不生人中生兜率天。值遇一生补处菩萨为说妙法。既闻法已身心欢喜。学诸菩萨观缘起法。如是观者名为正观。若异观者名为邪观

云何观如来缺盆骨满相。满相光明遍照十方作虎魄色。若有众生遇此光者。自然兴发声闻道意。是诸声闻见此光明。分为十支。一支千色。十千光明光有化佛。一一化佛有四比丘以为侍者。一一比丘皆说苦空无常无我。分别四谛。说八人义。说四果相。说三三昧。令彼众生于此法中求出家法。出家不久成阿罗汉。如是光明遍照十方诸罗汉顶。照顶之时。如人执瓶灌药入顶。其状色貌犹如醍醐。从顶入已贯彻表里。尔时行者身心安隐。其心恬然无有恶相。不见诸使及结相貌。如是霍然成阿罗汉。此光复变作金色盖其数无量。一一盖中百千七佛。一一七佛有四比丘以为侍者。一一比丘入四大定。四大定中遍现一切结使相貌。八万户虫宛转而出。小虫种类亦皆随从。此相现时火大先起。火大起者初如芥子。从毛孔出后渐渐长。遍烧诸身身如火聚。诸虫鸣吼如师子声。此声出时行者心怖迷闷躄地。出定见身。如野火行傍树为燋。此相现时。复当起心作一药想。先作身想。身想既成。开顶令空作梵王想。作帝释想。作诸天手持宝瓶想持药灌想。药入顶时。遍入四体及诸脉中。见脉及身如琉璃筒。但见诸虫如萎死华。尔时诸脉更相流注。惟有众水。水至之处火则随灭。是时行者。节节水出如人仰射。水至梵际水水相次至于梵天。见身中水如四大海。但见诸虫头萎摧茹手折足戾。惟心生火分为十支。火入众水不相消灭。水光上冲。火光随逐。水火二光皆从心出。互相交错。上极三界顶。下至阿鼻狱。尽一世界际。纯见水火流。东西南北火亦随走。尔时心端自然生一黑毛。于其毛端出大黑风。其风四色随心根起。如旋岚风。状如烟焰。其风遍吹一切诸水。其水波动沫聚成[卄/積]。火亦入中。得火力故沫坚如冰。复有风来。吹诸尘秽九十八种恶不净物。持置冰上冰力弱故。随不净败着处即解。此冰解时八人执刀。斫冰段取各持而去。尘土坌污心闷而卧。风火水等合聚一处。火力大故烧坏众物。有四恶蛇含一宝珠。从火焰出凌虚飞逝。有六大龙。迎四小螭吞吸而走。龙顶生树至无色界。有一小草细若秋毫。色正金色。从树[禾*(此/白)]生下入树根。从树根生上入树茎。从树茎生散入枝叶。其华白色亦有红赤。其果欲熟犹作四色。至八月半纯黄金色。如此光明照诸声闻。变化无量百千境界。如是观者名为正观。若异观者名为邪观

若有比丘入此定时。身如芭蕉无有坚实。出定之时。身体支节悉皆疼痹。若不服药发狂而死。应当随时众药消息。作是观者除无数劫生死之罪。如大水流不久当得阿罗汉道。佛告阿难。汝持佛语真实莫忘。为诸比丘当广宣说。说是语时。五百比丘得四大定。同时皆得四沙门果

云何观如来胸德字万字相。腋下摩尼珠皆放光明。其光红紫中有金华。其华开敷。化为无量百千万亿无数众华。一一华上有无量佛。是诸化佛各有千光。光一化佛。其光五色。若有众生遇此光明。狂者得正。乱者得定。病者得愈。贫穷者自然得宝。盲者得视。聋者得听。哑者能言。癃跛疥癞皆得除愈。遍入十方诸佛顶上。入已诸佛胸中有百千光。从万字生。一一光中歌百千偈。演说檀波罗蜜。如是众光演说六波罗蜜。其偈无量。行者正坐闻无量佛皆说是法。一一化佛遣一化人。端严微妙状如弥勒。安慰行者而作是言。善哉善哉。善男子。汝系念故见诸佛光。诸佛光中说无相施。说无相戒。说无相忍。说无相精进。说无相定。说无相慧。汝闻此法慎勿惊怖。过去诸佛系念思惟。亦闻是法。亦解是相。解是相已不畏生死。处大地狱阿鼻猛火盛不能烧。虽处地狱如游天宫。是故万字名实相印。诸佛如来无量无边阿僧祇劫学得此印。得此印故不畏生死。不染五欲。佛告阿难。佛灭度后佛诸弟子。见佛胸相光者。除却十二万亿劫生死之罪。若不能见胸相分明者入塔观之。如是观者名为正观。若异观者名为邪观

云何观如来臂佣纤圆如象王鼻相。手十指合鞔掌千辐理。各各皆放百千光明。一一光明分为千支纯作红色。如是众光遍照十方无量世界。照世界已化成金水。金水之中有一妙水如水精色。饿鬼见者除热清凉。畜生见者自识宿命。狂象见者为师子王。师子见之为金翅鸟。诸龙见之为金翅鸟王。是诸畜生各见所尊。心生恐怖合掌恭敬。以恭敬故命终生天。众人见者如梵天王。或如日月星辰。见已欢喜。命终生兜率天。行者见之心眼即开。时十方界满中化佛。一一化佛手出光明入行者眼。闭目开目恒见诸佛。自观身相如妙宝瓶中有不净。如是见者虽未得通。遍至十方历侍诸佛。见一一佛出手光明亦复如是。如是观者名为正观。若异观者名为邪观

云何观如来脐相。如来脐中有万亿宝华。一一宝华。万亿那由他叶。一一叶万亿那由他色。一一色万亿那由他光。此相现时。一切大众见佛心相。如来心者如红莲华。金华映蔽。妙紫金光以为间错。妙琉璃筒悬在佛胸。见佛身内万亿化佛。是诸化佛游佛心间。佛脐出光。其光叇然如须弥山。众山中间有无量宝山。如须弥山。此众华上皆有化佛。严显可观如须弥山。其光千种有十千色。分为十亿支。亿亿支照下方。亿亿支照上方。亿亿支照东方。亿亿支照南方。亿亿支照西方。亿亿支照北方。亿亿支照东南方。亿亿支照西南方。亿亿支照西北方。亿亿支照东北方。如是十方各有诸华。华极小者犹如百亿须弥山大。一须弥上有百亿万诸大菩萨。身极小者如须弥山。诸化菩萨脐中各生一大莲华。其诸莲华遍覆三千大千世界。一一华间有金色光。其光犹如阎浮檀金。一一金光化微尘数释迦牟尼。一一释迦脐中光明亦复如是。如是众光合成光台其众光台亦有无量微尘恒沙诸大化佛。佛佛相次放脐光明。其光大盛直照上方无量世界。复过是界。如是众界数如三千大千世界无量微尘。是世界中皆有琉璃颇梨亿宝以为佛窟。是众窟中各有万亿无量诸佛。诸佛脐中各各皆生一大莲华。与前无异。是诸光明照诸一切十地菩萨。是诸菩萨遇斯光已。即入微妙首楞严门。复得入于金刚譬定。诸天遇者深发无上正真道意。心眼开明见诸佛相。如此光明照菩萨已。令诸菩萨身诸毛孔。一毛孔中出阿僧祇诸供养云及众供具。盖极小者覆阎浮提。如是众多杂宝供具不可悉说。此诸供具从首楞严海生。佛告阿难。若善男子善女人。作是思惟时。如是忆想者。梦见此事者。生生之处恒常值遇普贤文殊。是法王子。为众行者梦中恒说过去未来三世佛法。说首楞严三昧般舟三昧。亦说观佛三昧。以为璎珞。觉已忆持无所忘失。此人现世功德天女以为给使。除却十万亿劫生死之罪。如是观者名为正观。若异观者名为邪观。亿亿光照下方。令下方地如阎浮提水色。于众水中有恒沙宝楼。众宝楼下有一宝城如乾闼婆城。于宝楼上有大宝树。其树枝叶一切火起。其火光焰上下俱烧。烧此众水化成琉璃。琉璃地上复生诸树。树有四龙。其龙顶上有如意珠。其珠光明遍照龙身。令龙及树纯黄金色。其龙奋迅龙诸毛孔出金色光。其光直照下方无量世界。复过下方。复照无量世界。令下方地皆作金色。金色地上有金刚华。金刚华上有金天女。一一天女百千天女以为眷属。是诸天女皆赞慈心三昧海。从下方出直至上方迦毗罗城。其声如雷赞说慈心。说是语时诸龙毛端出诸宝云。一一云中有恒沙佛刹。一一刹中尘数化佛。一一化佛出此光明。此光现时。下方世界有百万金山。于其岩间百亿宝窟。如云踊起。是众窟中纯诸白佛。白妙菩萨及声闻众以为侍者。金精宝光在佛左右。犹如断山众宝映错。有妙宝盖如须弥山无量宝成。一一宝间百亿光明。回旋宛转。于众光中有百亿师子座。一一师子座上有百亿那由他菩萨大众结加趺坐。时彼菩萨身毛孔中有阿僧祇光。一一光中有一化佛。其身修圆如须弥山。是诸化佛以百千偈。赞说不杀慈为根本。慈是妙药除生死患。慈为净目导诸天人。是诸化佛赞叹慈已。各作变化为琉璃山。于其山内百亿菩萨。一一菩萨有万梵王以为侍者到行者前。于宝山内异口同音皆说是法。告言。善男子。汝于念佛海应修慈心。诸佛菩萨以慈心故。得佛大慈。汝今应当修不杀戒行大慈悲。尔时亦有天龙八部一切众生。遇此光者。闻是语者。命终之后必生梵世。佛告阿难。汝持此语慎勿忘失。告诸比丘令行是事。佛灭度后佛诸弟子。若闻是语思是法者。有正念者。有正受者。三昧不动者。心不懈退者。发大乘者。当知是人恒于梦中见此光明。亦闻化佛说慈心法。觉已忆持深解义趣。思其义故即得慈定。如是观者名为正观。若异观者名为邪观。佛灭度后佛诸弟子。思是法者。持是法者。当知是人其心清净如诸佛心。除却亿劫生死之罪。常生梵世值遇诸佛请转法轮。既闻法已发菩提心。于未来世必成佛道

亿亿光照东方。乃至东方无量世界。令东方地白如雪山。于众山上有白宝云。其白宝云状如宝台。众宝罗网宝铃万亿。众铃网间有一亿白光。是诸白光化成金台。一金台上有四化佛。一一化佛四亿菩萨以为侍者。佛与菩萨皆说慈法赞叹不杀。凡千亿偈。如是观者名为正观。若异观者名为邪观。佛告阿难。佛灭度后佛诸弟子。如是观者。除半亿劫生死之罪

亿亿光照南方。令南方地皆作红色。此红色光乃至南方无量世界变成白云。红白分明。于众云间有诸化佛。白真珠色。毗琉璃光。上妙金华以为佛座。于金华上百亿菩萨。皆黄金色。百亿宝光映蔽白云。一一光中五百化佛。是诸化佛异口同音亦赞不杀及大慈悲。如是观者名为正观。若异观者名为邪观。佛告阿难。佛灭度后佛诸弟子。闻是法者。思是法者。观是法者。此人恒于梦中见释迦文放脐光明持以照之。此光明相如向所说。其人生处不处胞胎恒生净国。若生天上自然化生

亿亿光照西方乃至西方无量世界。其光杂色如月如星。众星月间有七宝珠。一珠出水。一珠出火。一珠生树。其树七宝金刚为果。一珠生华。于月光中有梵宫殿。梵王眷属及梵众宝皆悉具足。其星光中。有摩醯首罗宫及其眷属。一一天宫百万亿梵王。一一梵王。无量无数诸天大众以为眷属。摩醯首罗等数不可知。是诸宝珠出琉璃光。琉璃光内有真金像。其真金像坐白宝座。项佩赤真珠光。赤真珠光中有绿真珠化佛。是诸化佛及诸天众。异口同音赞说不杀。劝进行者行大慈悲。佛告阿难。如是观者名为正观。若异观者名为邪观。佛灭度后佛诸弟子。有忆想者。有思惟者。如此观者。常于梦中梦见诸佛为说慈法。除却七亿劫生死之罪

亿亿光照北方。乃至北方无量世界。令北方地皆珊瑚色。虎魄玫瑰真珠马瑙颇梨等宝以为间错。一一宝中有一亿光。一一光化作一师子。师子背上有七宝盖。其盖高妙如须弥山。琉璃为竿。杂宝彩华以为庄严。一一华上有百亿化佛。一一佛面如阎浮檀金色。发绀琉璃色。身百亿宝色。臂红真珠色。爪真金色。手中相白莲华色。鹿王[跳-兆+專]优昙华色。足下相毗楞摩尼色。从足下放五色光上至发际。身诸毛孔皆有化光。一毛孔中有一亿菩萨。一一菩萨脐有一大莲华。其华高大如须弥山百宝所成。华上有佛其佛高大。与华正等亦出脐光。此相现时。众宝师子奋迅若惊。师子众毛。一一毛端有百亿佛刹。一一佛刹。无量百亿众宝莲华以为庄严。其莲华上亦有百千大菩萨众。是诸菩萨亦出脐相如上菩萨。如是菩萨众色光明合成一山。其山高显如真金台。其台四角有四梵幢。幢端皆有四亿佛刹。一一刹中有百千塔。塔极小者。从阎浮提至于梵世。无数众妙一切宝像以为庄严。是诸宝塔及化菩萨。皆共赞叹喜舍二法。若有众生遇斯光者得大智慧如舍利弗。总持不失犹如阿难。佛告阿难。佛灭度后佛诸弟子。欲见是相者。当发慈心修不杀戒。普为十方一切众生行是行者。虽不坐禅恒于梦中得见众色如向所说。佛告阿难。持是语者即持佛心。作是观者能观佛心。诸佛如来以大慈悲而以为心。戒定慧解脱解脱知见而以为身。十力四无所畏。十八不共法。大悲三念处而自庄严。如是观者名观佛心。佛告阿难。此脐相中略而解之。佛心境界后自当说。如是观者名为正观。若异观者名为邪观。佛灭度后佛诸弟子。思是法者。持是法者。观是法者。此人现世恶业罪障皆悉清净

亿亿光照东南方。乃至东南方无量世界。化成金轮。一一金轮七宝随从。一一金轮百亿转轮圣王。一一转轮圣王。千子四兵皆悉具足。其神珠宝出大光明如烟如云。一一光中有大莲华华华相合。合华之中出大日光。一一日光有金色象。菩萨化乘。乘象之时万亿瑞应不可宣说。诸菩萨光合成一佛。其佛金色身量无边。亦出脐相。脐相光明亦如上说。诸光中人皆赞五戒。说十善法。诸转轮王手执金轮宣十善法。佛告阿难。如是观者。名为正观。若异观者名为邪观。佛灭度后佛诸弟子。忆想是者。思惟是者。观是法者。除却二十万亿劫生死之罪。常生天上。闻十善教

亿亿光照西南方。乃至西南方无量世界。至彼界已其光如雨。似杂色珠。一一珠中出百亿光。一一光合成宝台。一一台角有十二须弥山。一一须弥山龛室无量。一一龛中有无量化佛。一一化佛有无量菩萨以为眷属。是众化佛及化菩萨。亦皆赞叹说十善法。如是观者名为正观。若异观者名为邪观。佛告阿难。佛灭度后佛诸弟子。忆想是者。思惟是者。观是法者。除十二亿劫生死之罪。若欲往生他方净刹随意无碍

亿亿光照西北方。乃至西北方无量世界。其光玉色。颇梨红紫更相映饰。一一光中百亿宝车。白车白马。紫车紫马。红车红马。诸马毛鬣皆真金色。如是车上有七宝轩。轩上皆悉有盖。其盖十层于轩盖中有千光明。宝鬘垂下光明随流回入车中化成化佛。佛身高显万亿由旬。一一佛脐中出无数光。其光遍照无量化佛。遇此光者永脱三涂无三恶患。此光回旋正立空中如云上升。一一云间百千化佛。一一化佛百亿弟子。如大迦叶。勤修十二头陀苦行。心无所著厌离世间。如是观者名为正观。若异观者名为邪观。佛告阿难。佛灭度后佛诸弟子。想是法者。思惟是法者。观是法者。当知此人常见诸佛速成大乘。除却十亿劫生死之罪

亿亿光照东北方。乃至东北方无量世界。其光清净无诸浊秽。如颇梨镜内外俱现。于彼光中见十方佛。皆出脐相。一一佛脐。光明遍照十方无量诸佛刹土。一一佛刹有微尘数化佛。一一化佛。微尘数菩萨以为眷属。如是菩萨脐相光明。犹如金柱其金柱端。万亿天衣宝箱宝箧。譬如云台从空而下。一一箱筐万亿光明。一亿光明合成一佛。一佛身中。无量微尘无数化光。于诸光端有诸化佛。犹如芥子。此小佛身亦出脐相。如上所说。此脐光明遍照十方入诸佛脐。从诸佛脐出入诸菩萨胸。从诸菩萨胸出入诸声闻顶。从诸声闻顶出。譬如大云。无量金色众宝间错。入佛足下。入足下已。足下千辐轮相中出大光明。其光如华。华华相次绕佛亿匝。从赤铜爪足趺毛孔乃至顶髻。佛身诸毛如莲华敷。一毛孔中有八万四千莲华。一莲华上八万四千化佛一一化佛。八万四千诸大菩萨以为眷属。一一菩萨眉间众光。出妙音声赞佛色身。释迦文佛现此光已。告大王言。如来色身分别色相。除佛心已其余境界。如向所现。佛说是已。尔时父王即从坐起。正衣服为佛作礼。绕佛七匝。胡跪合掌白佛言。世尊。如来身色一切睹见。惟佛心内有何境界。有何相貌。修行何事。佛心所念为是何物。佛心光明何所像类。是时如来即便微笑。其舌相光如上所说。绕佛七匝从佛顶八。尔时如来入解脱相三昧。令父王见。如琉璃窟。成真金像。真金像内。于佛胸中如琉璃筒。从佛咽喉下。见如来心如红莲华。金华映饰。红华金光。不开不合团圆如心。八万四千脉。一一脉如天画师所画之脉。一一画中八万四千光明。一一光明八万四千种色。一一色中无量微尘数化佛。一一化佛坐金刚台。其金刚台放金色光明。其光无数不可具说。一一光中亦有化佛。数如上说。是诸化佛皆出广长舌相上至发际。一一佛舌有一亿光。其光合聚为十千段。一一光上有百亿化佛。结加趺坐。入普现色身三昧。十方诸佛微妙色身。入此三昧海中。当佛入此三昧时。迦毗罗城及尼拘楼陀精舍。并阎浮提如大宝华。于华台上有颇梨幢。颇梨幢端有颇梨镜。十方无量诸佛净国皆于中现。时会大众睹见诸佛。或见佛身量同虚空纯黄金色。或见佛身如须弥山四宝所成。或见佛身毗琉璃色长十丈者或见佛身作白。银色长百千丈。见释迦文身故长丈六。或见七尺。或见三尺。或见遍至梵世。或见七寸。见入钵支。诸鬼神等见如微尘。见如芥子。见如金粟。诸鬼见已。小身鬼等皆大欢喜

佛说观佛三昧海经卷第四佛说观佛三昧海经卷第五

        东晋天竺三藏佛陀跋陀罗译

    观佛心品第四

尔时佛心如红莲华。莲华叶间有八万四千诸白色光。其光遍照五道众生。此光出时受苦众生皆悉出现。所谓苦者。阿鼻地狱。十八小地狱。十八寒地狱。十八黑闇地狱。十八小热地狱。十八刀轮地狱。十八剑轮地狱。十八火车地狱。十八沸屎地狱。十八镬汤地狱。十八灰河地狱。五百亿剑林地狱。五百亿刺林地狱。五百亿铜柱地狱。五百亿铁机地狱。五百亿铁网地狱。十八铁窟地狱。十八铁丸地狱。十八尖石地狱。十八饮铜地狱。如是等众多地狱

佛告阿难。云何名阿鼻地狱。阿言无。鼻言遮。阿言无。鼻言救。阿言无间。鼻言无动。阿言极热。鼻言极恼。阿言不闲。鼻言不住不闲不住名阿鼻地狱。阿言大火。鼻言猛热。猛火入心名阿鼻地狱

佛告阿难。阿鼻地狱纵广正等八千由旬。七重铁城七层铁网。下十八鬲周匝七重皆是刀林。七重城内复有剑林。下十八鬲。鬲八万四千重。于其四角有四大铜狗。其身广长四十由旬。眼如掣电牙如剑树。齿如刀山舌如铁刺。一切身毛皆出猛火。其烟臭恶。世间臭物无以可譬。有十八狱卒。头罗刹头。口夜叉口。六十四眼。眼散迸铁丸如十里车。狗牙上出高四由旬。牙头火流烧前铁车。令铁车轮一一轮辋化为一亿火。刀锋刃剑戟。皆从火出。如是流火烧阿鼻城。令阿鼻城赤如融铜。狱卒头上有八牛头。一一牛头有十八角。一一角头皆出火聚。火聚复化成十八辋。火辋复变作火刀轮。如车轮许。轮轮相次在火焰间满阿鼻城。铜狗张口吐舌在地。舌如铁刺。舌出之时化无量舌满阿鼻地。七重城内有七铁幢。幢头火踊如沸踊泉。其铁流迸满阿鼻城。阿鼻四门。于门阃上有八十釜。沸铜踊出从门漫流。满阿鼻城。一一鬲间有八万四千铁蟒大蛇。吐毒吐火身满城内。其蛇哮吼如天震雷。雨大铁丸满阿鼻城。此城苦事八万亿千。苦中苦者集在此城。五百亿虫。虫八万四千嘴。嘴头火流如雨而下满阿鼻城。此虫下时。阿鼻猛火其焰大炽。赤光火焰照八万四千由旬。从阿鼻地狱上冲大海沃燋山下。大海水滴如车轴许。成大铁尖满阿鼻城

佛告阿难。若有众生杀父害母。骂辱六亲。作是罪者命终之时。铜狗张口化十八车。状如金车宝盖在上。一切火焰化为玉女。罪人遥见心生欢喜。我欲往中我欲往中。风刀解时寒急失声。宁得好火在车上坐然火自爆。作是念已即便命终。挥霍之间已坐金车。顾瞻玉女。皆捉铁斧斩截其身。身下火起如旋火轮。譬如壮士屈伸臂顷。直落阿鼻大地狱中。从于上鬲如旋火轮。至下鬲际身遍鬲内。铜狗大吼啮骨唼髓。狱卒罗刹捉大铁叉。叉头令起遍体火焰满阿鼻城。铁网雨刀从毛孔入。化阎罗王大声告敕。痴人狱种。汝在世时。不孝父母邪慢无道。汝今生处名阿鼻地狱。汝不知恩无有惭愧。受此苦恼为乐不耶。作是语已即灭不现

尔时狱卒复驱罪人。从于下鬲乃至上鬲。经历八万四千鬲中。[打-丁+聿]身而过至铁网际。一日一夜尔乃周遍。阿鼻地狱一日一夜。此阎浮提日月岁数六十小劫。如是寿命尽一大劫。五逆罪人无惭无愧造作五逆。五逆罪故临命终时。十八风刀如铁火车。解截其身。以热逼故便作是言。得好色华清凉大树。于下游戏不亦乐乎。作此念时。阿鼻地狱八万四千诸恶剑林。化作宝树。华果茂盛行列在前。大热火焰化为莲华在彼树下。罪人见已。我所愿者今已得果。作是语时。疾于暴雨坐莲华上。坐已须臾。铁嘴诸虫从火华起。穿骨入髓。彻心穿脑。攀树而上。一切剑枝削肉彻骨。无量刀杖当上而下。火车炉炭十八苦事。一时来迎。此相现时陷坠地下。从下鬲上身如华敷。遍满下鬲。从下鬲起。火焰猛炽至于上鬲。至上鬲已身满其中。热恼急故张眼吐舌。此人罪故。万亿融铜百千刀轮。从空中下头入足出。一切苦事。过于上说。百千万倍。具五逆者。其人受罪足满五劫。复有众生犯四重禁虚食信施。诽谤邪见不识因果。断学般若毁十方佛。偷僧祇物。淫泆无道。逼略净戒诸比丘尼。姊妹亲戚不知惭愧。毁辱所亲造众恶事。此人罪报临命终时。风刀解身。偃卧不定如被楚挞。其心荒越发狂痴想。见己室宅男女大小。一切皆是不净之物。屎尿臭处盈流于外

尔时罪人即作是语。云何此处无好城郭及好山林使吾游戏。乃处如此不净物间。作是语已狱卒罗刹以大铁叉。擎阿鼻狱及诸刀林。化作宝树及清凉池。火焰化作金叶莲华诸铁嘴虫化为凫雁。地狱痛声如咏歌音。罪人闻已。如此好处吾当游中。念已寻时坐火莲华。诸铁嘴虫从身毛孔唼食其躯。百千铁轮从顶上入。恒沙铁叉挑其眼睛。地狱铜狗化作百亿铁狗。竞分其身取心而食。俄尔之间身如截华。满十八鬲。一一华叶八万四千。一一叶头身手支节。在一鬲间。地狱不大此身不小。遍满如此大地狱中。此等罪人堕此地狱。经历八万四千大劫。此泥犁灭

复入东方十八鬲中。如前受苦。此阿鼻狱南亦十八鬲。西亦十八鬲。北亦十八鬲。谤方等经。具五逆罪。破坏僧祇。污比丘尼。断诸善根。如此罪人具众罪者。身满阿鼻狱。四支复满十八鬲中。此阿鼻狱。但烧如此狱种众生。劫欲尽时东门即开。见东门外。清泉流水华果林树一切俱现。是诸罪人从下鬲见。眼火暂歇。从下鬲起婉转腹行。[打-丁+聿]身上走到上鬲中。手攀刀轮。时虚空中雨热铁丸。走趣东门既至门阃。狱卒罗刹手捉铁叉逆刺其眼。铁狗啮心闷绝而死。死已复生。见南门开如前不异。如是西门北门亦皆如是。如此时间经历半劫。阿鼻狱死生寒冰中寒冰狱死生黑闇处。八千万岁目无所见。受大虫身婉转腹行。诸情闇塞无所解知。百千狐狼牵掣食之。命终之后生畜生中。五千万身受鸟兽形还生人中。聋盲喑哑疥癞痈疽。贫穷下贱。一切诸衰以为严饰。受此贱形迳五百身。后复还生饿鬼道中。饿鬼道中。遇善知识诸大菩萨。呵责其言。汝于前身无量世时。作无根罪。诽谤不信。堕阿鼻狱。受诸苦恼不可具说。汝今应当发慈悲心。时诸饿鬼闻是语已称南无佛。称佛恩力。寻即命终生四天处。生彼天已。悔过自责发菩提心。诸佛心光不舍是等。摄受是辈。慈哀是等。如罗睺罗。教避地狱如爱眼目

佛告大王。欲知佛心光明所照。常照如此无间无救诸苦众生。佛心所缘常缘此等极恶众生。以佛心力自庄严故。过算数劫。令彼罪人发菩提心。佛告阿难。云何名十八寒地狱。寒地狱者八方冰山。山十八鬲。复有十八诸小冰山。如颇梨色。此等寒冰满冰山间。如凡莲华。高十八由旬。上有冰轮。纵广正等十二由旬。如天雨雹从空而下。世间自有无慈心者。劫夺无道。抄盗剥脱。冻杀众生。此人罪报。欲命终时。一切刀风化为热火。罪人作念。我今云何不卧冰上。为火所逼。作是念时。狱卒罗刹手执冰轮。如白鹤翔蹑虚而至。罪人见已除热清凉。心便爱念。气绝命终生冰山上。既生之后。十八冰山如以扇扇。一切寒冰从毛孔入。十八鬲中遍满一鬲。剖裂擗坼如赤莲华。冰轮上下遍覆其身。八方冰山一时俱合。更无余辞。但言阿罗啰。尔时罪人即作是念。我于何时。当免寒冰生热火中

尔时空中有诸铁鸟。口嘴吐火从空中下。破头啄脑。罪人即死。命终之后。狱卒复以铁叉打地。唤言活活。应声即稣。起已思念。我今身上大火猛炽。愿得前冰以灭此火。狱卒复以冰轮迎接。置与狱中。如是十八鬲中无不经历。此寒地狱寿命岁数。如四天王日月八千万岁。罪既毕已。生贱人中贫穷鄙陋。五百世中为人奴婢。衣不蔽形食不充口。此罪毕已遇善知识发菩提心

佛告阿难。云何名黑闇地狱。黑闇地狱者。十八重黑山。十八重黑网。十八重铁床。十八重铁缦。一一山高八万四千由旬。一一缦亦厚八万四千由旬。一一缦间。十八重黑铁围山。罗列如林荫闇此山。世间自有愚痴众生。偷佛法僧灯明。偷盗父母师长和上。谤说法者。亦毁世俗论义师等。不忌尊卑不知惭愧。以此罪故命欲终时。眼有电光睒睒不停。即作是念。我有何罪常见是火。即闭两目。不愿欲见及日月光。命欲终时。狱卒罗刹擎大铁床。张大铁伞。如大队云乘空而至

尔时空中无形有声。此处黑闇汝欲往不。罪人闻声寻即起心欲往彼所。气绝命终坐铁床上。如雁王翔落黑闇处。既入中已。刀轮上下斩剉其身。有大铁乌嘴距长利。从山飞来摷啄罪人。痛急疾走求明不得。足下蒺蔾穿骨彻髓。如是慞惶经五百万亿岁。亦如四天王日月岁数。彼人头打诸黑闇山。脑流眼出。狱卒罗刹以铁叉叉还安眼眶。罪毕乃出为贫穷人。眼目角睐盲冥无见。或被癞病人所驱逐。如是罪报经五百身。过是以后。遇善知识发菩提心

佛告阿难。云何名为十八小热地狱。十八小热地狱者。如阿鼻狱亦七重城。七重铁网。无量诸恶以为庄严。自有众生。不顺师教兴恶逆心。不知恩养盗师害师。污师净食坐师床座。捉师钵盂。藏弃不净。作五种恶。云何为五。所谓骂师谤师打师杀师。以诸毒药持以饮师。若沙门婆罗门。作诸非法害师谤师。此罪恶人无有惭愧。剥像破塔劫法宝物。杀伯叔父母兄弟姊妹。如是罪人命欲终时。阿鼻地狱十八狱卒。各以铁叉擎一鬲狱。如是众狱如大宝盖。雨微细雨雨渧如华。此人罪报热恼入心。如火烧已见雨清凉。即作念言。愿我得坐荫盖之下。凉雨洒我不亦乐耶。作是语已气绝命终。如掷鞠顷。即便坐于大剑床上。百亿剑刃。刃皆出火烧刺其身。空中宝盖化为火轮。从上而下直劈其顶。其身碎裂为数千段。上雨铜丸从毛孔入。狱卒罗刹以大铁叉刺罪人眼。或以铁箭射其心者。闷绝而死。须臾还活坐剑床上。旋岚猛风吹堕地狱。既入狱已。时阎罗王与宫殿俱在虚空中。告言狱种。汝作众恶。杀师谤师。汝今生处名拔舌阿鼻。汝在此狱当经三劫。作是语已即灭不现。此狱苦痛如上所说

佛告阿难。云何名十八刀轮地狱。刀轮地狱者。四面刀山。于众山间积刀如[土*尃]。虚空中有八百万亿极大刀轮。随次而下犹如雨渧。自有众生。乐苦恼他杀害众生。命终之时患逆气病。心闷烦满心坚如石。即作是愿。得一利刀削此诸患不亦快乎。是时狱卒顶戴刀轮翳令不现。至罪人所卑言逊辞。我有利刀能割重病。罪人欢喜即自念言。惟此为快。气绝命终生刀轮上。如醉象走堕刀山间。是时四山一时俱合。四种刀山割切其身。不自胜持闷绝而死。狱卒罗刹驱蹙罪人令登刀山。未至山顶刀伤足下乃至于心。畏狱卒故匍匐而上。既至山顶。狱卒手执一切刀树。扑杀罪人。未死之间铁狗啮心。楚毒百端。铁虫唼食肉皆都尽。寻复唱活。脚着铁轮从空而下。一日一夜六十亿生六十亿死。如是众多凡十八种。此人罪故遂更增剧。如四天王寿八千万岁。罪毕生世堕在畜生。五百世中身供众口。复五百世受卑贱形。然后乃遇大善知识发菩提心

佛告阿难。云何名剑轮地狱。剑轮地狱者。纵广正等五十由旬。满中剑树。其树多少数如稻麻竹苇。一一剑树高四十由旬。八万四千剑轮为叶。八万四千剑轮为华。八万四千剑轮为果。八万四千沸铜为枝。世间自有愚痴众生。乐杀无厌。如此罪人临命终时。遇大热病。即作念言。我今身体时热时寒。举身坚强犹如铁砧即作愿言。得金刚剑割却此患。乐不可言。是时狱卒即自化身。如己父母亲友之形。在其人前而告之言。我有秘法。如卿所念当用相遗。罪人闻已心甚爱念。急急欲得。气绝命终。如马奔走生剑华中。无量剑刃削骨破肉。碎如豆许。复有铁鸟从树上下挑眼啄耳。有大罗刹手捉铁斧破头出脑。铁狗来舐死已唱活。驱令上树。未至树端身碎如尘。一日之中身经诸树。一夜之中复经诸树。一日一夜杀身如尘不可称数。杀人罪故受如此殃。经八万亿岁生畜生中。身常负重死复剥皮。经五百世还生人中。贫穷短命多病消瘦。过是已后遇善知识发菩提心。佛告阿难。云何名火车地狱。火车地狱者。一一铜镬纵广正等四十由旬。满中盛火。下有十二轮。上有九十四火轮。自有众生为佛弟子。及事梵天九十六种。出家徒众及在家者。诳惑邪命谄曲作恶。如此罪人欲命终时。风大先动身冷如冰。即作是念。何时当得大猛火聚。入中坐者永除冷病。作是念已。狱卒罗刹化作火车如金莲华。狱卒在上如童男像手执白拂鼓舞而至。罪人见已心生爱着。如此金华光色显赫。照我令热必除寒冷。若得坐上快不可言。作是语已气绝命终。载火车上支节火然。堕火聚中身体焦散。狱卒唱活应声还活。火车轹身凡十八返。身碎如尘。天雨沸铜遍洒身体即便还活。如是往返。上至汤际下堕镬中。火车所轹一日一夜。九十亿死九十亿生。此人罪毕。生贫贱家为人所使。系属于他不得自在。偿利养毕尔乃得脱。由前出家善心功德。遇善知识为其说法。心开意解成阿罗汉

佛告阿难。云何名沸屎地狱。沸屎地狱者。八十由旬十八铁城。一一铁城有十八鬲。一一鬲中四壁皆有百亿万剑树。地如刀刃刃厚三尺。于其刃上百千蒺梨不可称计。一一蒺梨及剑树间。生诸铁虫其数无量。一一铁虫有百千头。一一头有百千嘴。嘴头皆有百千蛔虫口吐热屎。沸如融铜满铁城内。上有铁网铁乌。世间自有众生破八戒斋。污沙弥戒沙弥尼戒。污式叉摩尼戒。自污净戒。污比丘戒比丘尼戒。污优婆塞戒优婆夷戒。诸比丘比丘尼。诸优婆塞及优婆夷。沙弥沙弥尼。式叉摩尼。如是七众及余一切。污僧净饭。污父母食。偷窃先啖。不净手捉。及僧知事以自恃故污僧净食。四部弟子以不净身坐僧祇床。犯偷兰遮久不忏悔。虚食僧食坐僧众中与僧布萨。如是众多无量不净恶业罪人。临命终时。举身皆香如麝香子。不可堪处。即作是念。当于何处不闻此香。如此香气犹如狂风来熏我心。作此念已。狱卒罗刹自化己身。犹如画瓶中盛粪秽。至罪人所以手摩触。令彼罪人心生爱着。气绝命终。犹如风吹堕沸屎中。堕已麋烂众虫唼食。东西走时削骨彻髓饥渴逼故饮热沸屎。蛔虫疽虫唼其舌根。一日一夜。九十亿生九十亿死。罪毕乃出生贫贱家。系属于他不得自在。设生世时。恒值恶王属邪见主。种种恶事逼切其身。瘿瘇恶疮以为衣服。宿世闻法善因缘故。遇善知识出家学道成阿罗汉。三明六通具八解脱

佛告阿难。云何名十八镬汤地狱。镬汤地狱者。有十八镬。一一镬纵广正等四十由旬。七重铁网满中沸镬。五百罗刹。鼓大石炭烧其铜镬。此石火焰焰焰相承。经六十日火不可灭。阎浮提日满十二万岁。如是镬沸上涌如星。化成火轮还入镬中。自有众生毁佛禁戒。杀生祠祀。为啖肉故焚烧山野伤害众生。生燖众生以火焚烧。如此罪人。欲命终时身心烦闷。失大小便不自禁制。或热如汤或冷如冰。即作是念。得大温水入中沐浴不亦乐乎。狱卒罗刹化作僮仆。手擎汤瓮至罪人所。罪人心喜爱乐此瓮。气绝命终生镬汤中。速疾消烂惟余骨在。铁叉摷出。铁狗嗗之呕吐在地。寻复还活。狱卒。驱蹙还令入镬。畏镬热故攀剑树上。骨肉断坏落镬汤中。杀生罪故一日一夜。恒河沙死恒河沙生。罪毕乃出生畜生中。猪羊鸡狗短命之处。无不经历。如是受身八千万岁。命终之后还生人中。受二种报。一者多病。二者短命。短命多病以为眷属。过算数劫遇善知识。受持五戒行六波罗蜜

佛告阿难。云何名灰河地狱。灰河地狱者。长二百由旬广十二由旬。下有利刀。岸上剑树满中猛火。厚十二丈。复有融灰以覆火上。厚四十丈。世间自有无惭众生。偷盗父母。偷盗师长。偷盗善友兄弟姊妹。如是痴人无有惭愧。不识恩养心无反复。贪利欲得不识殃祸。不顺师教。此人罪报欲命终时。气满心腹喘息不续。即作是念。我心如泥气满胸中。得一微火爆我身者不亦快乎。狱卒罗刹。应念即至化作妻子。手擎火炉微灰覆上。至罪人所。是时罪人心大欢喜。以欢喜故气绝命终生灰河中。诸剑树间有一罗刹。手执利剑欲来伤害。是人恐怖走于灰河。举足下足刀伤其脚。剑树雨刀从毛孔入。罗刹以叉叉其心出。躄地闷死寻复还活。是人偷盗师长父母罪因缘故。一日一夜五百亿生五百亿死。饥渴逼故张口欲食。剑树雨刀从舌头入。劈腹裂胸闷绝而死。由前闻佛法僧名故。罪毕之后得生人中贫穷下贱。觉世非常出家学道。世无佛时成辟支佛。世若有佛成阿罗汉

佛告阿难。云何名剑林地狱。剑林地狱者。八千由旬满中剑树。有热铁丸以为其果。如此剑树高二十四由旬。自有众生。不孝父母不敬师长。作恶口业。无慈爱心刀杖加人。此人罪报临命终时。心如胡胶处处生着。即作此念。我心缚着触事不舍。耽酒嗜色。身虽遇患心犹不息。得一利刀割截此爱。狱卒罗刹。应声即至化为侍者。执明镜示语罪人言。汝心多着可观此镜。观此镜时。见于镜中有利剑像。即作是念。我今体羸不堪欲事。得此利剑割断我心不亦快乎。作此念时气绝命终。受饿鬼身。诸剑树间忽然化生。生已铁丸从顶上入从口而出。肠胃焦烂躄地。狱卒复以铁叉打扑驱令上树。上一树已铁嘴虫啖。以恐怖故踊身上树。如是展转悉经剑林。一日一夜八万生八万死。罪毕之后生饥馑世及疾疫劫。为人卑贱口气恒臭人所恶见。过算数劫遇善知识发菩提心

佛告阿难。云何名五百亿刺林地狱。刺林地狱者。八千由旬满中铁刺。一一刺端有十二剑。树上复有大热铁钳。世间自有愚痴众生。恶口两舌绮语不义语。调戏无节枉说是非。说经典过。毁论义师。如此罪报命欲终时。咽燥舌干。即作此念。得一利刺刺颈出血。令众脉间流注众水不亦快乎。作是念时。狱卒罗刹。化作父母手执月珠。珠头生刺持用拟口。如水欲渧。罪人欢喜。我所愿者今已得果。作是念已气绝命终。如大电顷生刺林间。既生之后狱卒罗刹。手执铁钳拔舌令出。八十铁牛有大铁犁耕破其舌。刺林诸树有风吹来扑打其躯。一日一夜六百生六百死。过是已后得生人中。唇咃面皱语言蹇吃。如此罪人。体生诸创脓血盈流。经五百世人所恶见。过是已后。虽有所说人不信受。遇善知识发菩提心

佛告阿难。云何名五百亿铜柱地狱。铜柱地狱者。有一铜柱状如大山。高六百由旬。下有猛火。火上铁床上有刀轮。诸刀轮间有铁嘴虫。铁乌在傍。世间自有愚痴众生。贪惑滋多染爱不净。犯邪淫行。非处非时行不净业。设有比丘比丘尼。婆罗门等诸梵行者。若于非时非处犯不净法。乃至一切犯邪行者。作不净业。如此罪人临命终时。举身反强振掉不定。犹如弓弩不自胜持。即作此念。得一坚大铜铁柱者。缚此身体令不动摇。狱卒罗刹应时即至。化作僮仆手执铁杖。至罪人所。白言长者。汝今身强余物皆弱。可捉此杖。心即欢喜气绝命终。如弄杖顷生铜柱头猛火焰炽焚烧其身。惊怖下视。见铁床上有端正女。若是女人见端正男心生爱着。从铜柱上欲投于地。铜柱贯身铁钢络颈。铁嘴诸虫唼食其躯。落铁床上。男女俱时六根火起。有铁嘴虫从眼而入。从男女根出。若污戒者。别有九亿诸小虫辈。如瘭疽虫有十二嘴。嘴头出火唼食其体。此邪淫报。一日一夜九百亿生九百亿死。罪毕乃出生鸠鸽中。受鸠鸽身经五百世。复生龙中经五百身。后生人中。无根二根及不定根。黄门之身经五百世。设得为人。妻不贞良。子不慈孝。奴婢不顺。过是已后。遇善知识发菩提心。佛告阿难。云何名五百亿铁机地狱。铁机地狱者。有一铁床纵广正等四百由旬。上安诸[撼-咸+巳]。[撼-咸+巳]间皆有万亿铁弩。铁弩镞头百亿锋刃。世间自有愚痴众生。为贪欲故。不孝父母。不敬师长。不顺善教。杀害众生食诸奸人。此人罪报命欲终时。身体振动。身诸六窍汁自流出。如此罪人。见自己床如兜罗绵。即生是念。何时得一坚冷之处。安身卧眠不亦快耶。作是念时狱卒罗刹。以叉擎床。敷大榻[登*毛]至罪人所。罪人见已心生欢喜。欲卧榻[登*毛]。气绝命终生铁机上。万亿铁[撼-咸+巳]关从下动。铁[撼-咸+巳]低昂。无量铁弩同时皆张。一一铁箭射罪人心。一日一夜六百亿生六百亿死。如是罪人受罪毕已。生畜生中经五百世。还生人间。贫穷下贱为人所使。多堕刑狱恒受鞭挞。过是已后。遇善知识发菩提心

佛告阿难。云何名铁网地狱。铁网地狱者。八十九重诸铁罗网。一一网间百亿铁针。一一铁针施五关[撼-咸+巳]。世间自有虚妄众生。邪心谄曲妖媚惑人。心怀呓贼昼夜恶念。刹那刹那顷成就恶念。此人罪报临命终时。身体搔痒。即作此念。得一束针镵刺疥虫不亦乐乎。作是念时。狱卒罗刹化为良医。手执利针唱言治病。罪人心喜。气绝命终生铁网间。[打-丁+聿]身下过众[撼-咸+巳]皆动。无量诸针射入毛孔。如是婉转诸铁网间。刹那顷死刹那顷生。罪毕乃出生于边地无佛法处。亦不闻说世间善语。何况正法。虽生人中三恶道摄。过算数劫遇善知识。虽得闻法心不解了

佛告阿难。云何名铁窟地狱。铁窟地狱者。饿鬼道中最上苦法。有一铁山纵广正等二十五由旬。山上复有五百万亿大热铁丸。一一铁丸团圆正等十三由旬。山间复有百千刀剑。是时彼山东向开张有一小孔。如摩伽陀斗口但出黑烟。世间自有愚痴众生。悭贪缚着心如金刚。但乐求索无有厌足。父母妻子悉不给与。师长教授视如粪秽。奴婢亲友不施衣食。如是悭人不虑无常。护惜财物犹如眼目。此人罪报命欲终时。诸情闭塞口噤不语。心中默念。我死之后是诸恶人。食我财物如啖铁丸。居我屋宅如处闇室。作是念已。狱卒罗刹化为悭人。幻收财物至罪人所。以火焚之。罪人心喜气绝命终生火山上。犹如融铜铸铁窟中。既入窟中剑虫刀虫唼食其躯。烟熏其眼不见火炎。周慞惶怖东西驰走。头打铁山铁丸上下。从顶而入从足而出。一念顷死一念顷生。罪毕乃出生饿鬼中。其身长大数十由旬。咽如针筒腹如大山。东西求食融铜灌咽。经八千岁乃得苦毕。生食唾鬼食脓鬼食血鬼中。罪毕复生厕神猪狗。罪毕复生贫穷卑贱无衣食处。遇善知识发菩提心

佛告阿难。云何名铁丸地狱。铁丸地狱者。八十由旬满中铁城八十八鬲。一一鬲中有五刀山持用覆上。下有十八大恶铁蛇。蛇皆吐舌舌出铁剑。剑头火然。世间自有愚痴众生。毁辱布施言施无报。劝人藏积。如是痴人。向国王大臣沙门婆罗门及一切众说施无因亦无果报。如此罪人临命终时。颈强脉缩回转不语。不喜见人低视而卧。心中但念。我积财宝得与我俱快不可言。狱卒罗刹化作其妻。捉热铁丸化作宝器。在其人前语言。我随汝死婉转相着终不相离。气绝命终生铁城中。东西驰走铁蛇出毒缠绕其身。节头火然。即作是念。愿天爱我降注甘雨。应念即雨大热铁丸。从顶而入足下而出。罪毕乃为贫穷孤独喑哑之人。是人岁数如铁窟说。遇善知识发菩提心

佛告阿难。云何名尖石地狱。尖石地狱者。有二十五石山。一一石山有八冰池。一一冰池有五毒龙。世间自有愚痴众生。比丘比丘尼。沙弥沙弥尼。式叉摩尼。优婆塞优婆夷。九十五种诸梵志等。法说非法。非法说法。或犯轻戒久不忏悔。心无惭愧犹如猿猴。此人罪报命欲终时。心下气满腹胀如鼓。饮食噎吐水浆不下。即作是念。得一石尖塞我咽喉不亦快乎。作是念时。狱卒罗刹化作良医。幻捉石尖作大药丸。着其口中告言闭口。心生欢喜。气绝命终生石山间。无量尖石从背上入从胸前出。狱卒复以铁叉叉口以石内中。一日一夜六十亿死六十亿生。此是生报。从此命终堕黑绳地狱。黑绳地狱者。八百铁锁八百铁山。竖大铁幢两头系锁。狱卒罗刹驱蹙罪人。令负铁山铁绳上走。不胜落地堕镬汤中。罗刹驱起。渴急饮铁吞石而走。一日一夜经历是苦凡十万遍。罪毕生世为人僮仆。遇善知识为说实法。如好白[疊*毛]易染受色。得阿罗汉。三明六通。具八解脱

佛告阿难。云何名十八饮铜地狱。饮铜地狱者。千二百种杂色铜车。一铜车上六千铜丸。自有众生。悭贪嫉妒邪见恶说。不施父母妻子眷属及与一切。心生悭嫉。见他得利如箭入心。如是罪人欲命终时。多病消瘦昏言呓语。口中自说欲得果食。作是语时狱卒罗刹。化己铜车满车载果至罪人所。罪人得已心生欢喜。即作念言。得此美果食不知厌。甚适我愿欢喜踊跃。气绝命终。未经几时生铜车上。不久即往生铜山间。铜车轹颈。狱卒罗刹以钳[木*宅]口饮以烊铜。饮烊铜已迷闷躄地。唱言饥饥。寻时狱卒擘口令开。以铜铁丸置其口中。吞十八丸节节火然。东西驰走经于一日。尔乃命终。狱卒唱言。汝前身时谄谀邪见悭贪嫉妒。以是因缘受铁丸报。或曾出家毁犯轻戒久不悔过。虚食信施。以此因缘食诸铁丸。此人罪报亿千万岁不识水谷。受罪毕已还生人中。五百世中言语[口*蹇]吃不自辩了。以宿习故。食后啖炭及啖土块。过是以后。遇善知识发菩提心

佛说观佛三昧海经卷第五佛说观佛三昧海经卷第六

        东晋天竺三藏佛陀跋陀罗译

    观四无量心品第五

尔时世尊。说是语时佛心力故。十种白光从佛心出。其光遍照十方世界。一一光中无量化佛乘宝莲华。时会大众见佛光明。如颇梨水或见如乳。见诸化佛从佛胸出入于佛脐。游佛心间乘大宝船。经往五道受罪人所。一一罪人见诸化佛。如己父母善友所亲。渐渐为说出世间法。是时空中有大音声告诸大众。汝等今者应观佛心。诸佛心者是大慈也。大慈所缘缘苦众生

佛告阿难。云何名慈心。慈心者。应当系念缘苦众生。苦众生者。谓三恶道极苦恼者。佛说是语时会大众。见于地狱饿鬼畜生。解脱相三昧力故。令诸众生自识宿命。见受苦者。皆是前世无量劫中。父母师徒诸善亲友。见已啼泣。为佛作礼白言。世尊。我等今者因佛力故见苦众生。悉是我等父母师长。佛告大众。三界众生轮回六趣。如旋火轮。或为父母兄弟宗亲。三界一切无不是汝所亲之者。云何起意生杀嫉心。作是语已。净饭王等一切大众白佛言。世尊。云何名为慈心三昧。惟愿世尊为我略说

佛告大众。夫慈心者。应当起想先缘所亲。系念之时。念己父母受诸苦恼。有不孝者。念己妻子所爱众生受诸苦恼。有见众生癞病[病-丙+(雍-〦)]疮。见已作念当云何救。一想成已应作二想。二想成已应作三想。三想成已满一室想。一室想成已满于僧坊。一僧坊成已满一由旬。一由旬成已满一阎浮提。阎浮提成已满弗婆提。弗婆提成已满三天下。如是渐广满十方界

见东方众生尽是其父。见西方众生悉是其母。见南方众生悉是其兄。见北方众生悉是其弟。见下方众生悉是妻子。见上方众生悉是师长。其余四维悉是沙门婆罗门等。见是众生皆受苦恼。或遇重病。或见在于刀山剑树火车炉炭。一切苦事见已悲泣欲拔其苦。自作我想。乘宝莲华诣诸人所。调身按摩为洗癞疮。见地狱火忧悲雨泪欲灭其火。见诸饿鬼。刺身出血化作乳想。供给饿鬼令得饱满。既饱满已为其说法。赞佛赞法赞比丘僧。作是赞已益更忧悲心无暂舍。如是慈心极令通利。事事广说如慈三昧。如是慈心名习慈者。既习慈已次当行悲。悲者见众受苦。如箭入心如破眼目。心极悲苦遍体雨血欲拔彼苦。如此悲者有百亿门。广说如大悲三昧。行慈悲已次行大喜。见诸众生安隐受乐。心生欢喜如己无异。既生喜已次行舍法。是诸众生无来去相从心想生。心想生者。因缘和合假名为心。如此心想犹如狂华从颠倒起。苦从想起乐从想生。心如芭蕉中无坚实。广说如经十譬。作是观时不见身心。见一切法同如实性。是名菩萨身受心法。依因此法广修三十七助菩提分。若取证者是声闻法。不取证者是菩萨法。作是语已佛身光明益更明显。从佛心端诸光明中生诸宝华。一一宝华恒沙宝华以为眷属。一一华上无量无边微妙化佛。方身丈六如释迦文此相现时。佛身毛孔八万四千诸宝莲华。一一华上八万四千诸大化佛身量无边。如是化佛身诸毛孔。及心光明亦如向说

如是光明遍照十方从佛顶入从佛眉间白毫相出。从白毫出遍照十方犹如金幢。令十方地作真金色。卷诸化佛入佛口中。从佛口出亦照十方来入佛胸。从佛胸出复照十方来入佛脐。此光入时佛身之内如琉璃水澄清不动。三界五道一切众生映现佛心。见诸化佛乘大宝台。犹如宝船游佛身间。一一化佛赞说不杀。赞叹念佛。赞叹念法。赞叹念僧。赞叹念戒。赞叹念施。赞叹念天。赞六和敬。赞慈三昧。如此六念能生善法。此六念者是诸佛因。佛心者是六念心。因六和敬而得此法。欲成佛道当学佛心

说是语已。如来身光倍更明显。佛身化佛及宝莲华数不可知。一一华光如杂华说。如是观者名为正观。若异观者名为邪观。佛灭度后佛诸弟子。修六念者名念佛心。念佛心者除十二亿劫生死之罪。作是观者生生之处。终不邪见心不僻谬。恒得值遇无生菩萨。如是之人若生边地无佛法处。念佛功力自然悟解成辟支佛。尔时世尊说是语已。还摄身光如本无异

佛告父王。如大人相白毫光明及一切相。有能逆观顺观分别观者。全观圆光及丈六者。但发是心如见不见除却众罪。如向所说。设有施主具五神通。得如意珠飞遍十方。十方世界一一世界。众生之数不可得知。但以无量无边总为其数。如是众生皆是罗汉。是大施主尽算数劫。供养贤圣四事无乏。是人得福宁为多不。父王白言。但使供养一方罗汉得福无量。何况十方无量罗汉

佛告父王。正使有人成熟邪见众生。数如上说。皆令彼人得罗汉道。三明六通具八解脱。不如发心趣向佛慧念佛须臾。佛说是语时。释子众中一亿释子。发阿耨多罗三藐三菩提心。自誓不求声闻辟支佛道。白佛言。世尊。诸佛身分乃至一毛无量化佛。诸声闻身如燋败种。为何所益

    观四威仪品第六之一

尔时世尊于大众中。即便起行足步虚空。父王观见心甚欢喜亦随佛行。佛举足时足下千辐相轮。一一轮相皆雨八万四千众宝莲华。一一莲华复化八万四千亿那由他华。一一莲华化为一台。一一华台一一华叶。遍覆十方无量世界。一一莲华八万四千叶。释迦牟尼足步虚空悉雨宝华。如是众华复有无量微尘数佛足步虚空。父王见已心大欢喜得阿那含。五体投地为佛作礼。时会大众皆睹此事白佛世尊。十方世界无数化佛。何者真佛谁是化佛

佛告大众。诸佛如来入空寂处。解脱三昧随意自在。无有真化。所以者何。佛心空寂。复入空寂解脱光明王三昧。此定力故。诸佛如来化无边身。无边身者是萨婆若。萨婆若者名无著三昧。无著三昧故如来现行。若现乞食若或经行。如是二法饶益众生。若有众生。佛在世时见佛行者。步步之中见千辐轮相。除却千劫极重恶罪。佛去世后。三昧正受想佛行者。亦除千劫极重恶业。虽不想行。见佛迹者见像行者。步步亦除千劫极重恶业。佛告阿难。汝从今日持如来语遍告弟子。佛灭度后。造好形像令身相足。亦作无量化佛色像。及通身光及画佛迹。以微妙彩及颇梨珠安白毫处。令诸众生得见是相。但见此相心生欢喜。此人除却百亿那由他恒河沙劫生死之罪。说此语已如来还坐

父王复问佛。出世间有何利事。能令众生得安乐耶。尔时世尊。告大王言。舍卫城中须达长者。有一老母名毗低罗。谨勤家业。长者敕使守执库钥。出内取与一切委之。须达长者请佛及僧供给所须。时病比丘多所求索。老母悭贪嗔嫌佛法及与众僧。而作是言。我家长者愚痴迷惑受沙门术。是诸乞士多求无厌。何道之有。作是语已复发恶愿。何时当得不闻佛名不闻僧名。不见剃发染衣之人。如是恶声一人闻已复闻二人。展转遍满舍卫城中。末利夫人闻此语已而作是言。云何须达如好莲华人所乐见。云何复有毒蛇护之。作是语已敕须达言。遣汝妇来吾欲与语。阿那邠坻驰诣王宫。到作礼毕却住一面。末利夫人命令就座。坐已语言。汝家老婢恶口诽谤。何不驱摈。阿那邠坻跪白。夫人。佛日出世多所润益。鸯掘摩罗大恶之人。尼提贱人气嘘栴陀罗佛能调伏。何况老婢而不能调。末利夫人闻是语已。心大欢喜。我欲请佛汝遣婢来。明日食时请佛及僧于宫供养。长者遣婢持满瓶金摩尼珠盖。劝助王家供养众僧。告言可信。汝持此物贡上王家。婢闻是语欢喜踊跃持宝瓶走。末利夫人见彼婢来。此邪见人佛当教化。我见此人受化之时必获法利

尔时世尊从正门入。难陀在左阿难在右。罗睺佛后。老母见佛心惊毛竖。可恶此人随我后至。即时欲退从狗窦出。狗窦即闭。四方小巷一时闭塞。惟正路开。老母覆面以扇自障不喜见佛。佛在其前。令扇如镜无所障碍。回头东视东方有佛。南视南方有佛。西视西方有佛。北视北方有佛。举头仰看上方有佛。低头伏地地化为佛。以手覆面时手十指皆化为佛。老母闭目心眼即开。见虚空中一切化佛满十方界。此相现时舍卫城中。有二十五旃陀罗女。五十婆罗门女及诸杂类。并末利夫人宫中合五百女。心生诽谤不信佛法。见佛如来足步虚空。为于老母现无数身。心大欢喜裂邪见网。头脑顶礼世尊足下

尔时世尊。以梵音声。安慰诸女告言。诸女。汝今可称释迦牟尼。称我名故观我身相可得解脱。作是语已诸女同声称南无佛。佛放眉间白毫相光照诸女心。女见佛行威仪详序。足下雨华犹如华盖。化佛如林不可称计。诸女见已发阿耨多罗三藐三菩提心。老母见佛邪见不信。犹能除却八十万亿劫生死之罪。况复善意恭敬礼拜。尔时老母。以得见佛巷陌还开。疾走归家白大家言。我于今日遇大恶对沙门瞿昙。在王宫门多众之前。作诸妖幻。身如金山众华映饰。目踰青莲有万亿光不可具见。沙门善幻世间无比。大家年少可不喜见。作是语已入木笼中。以百张皮覆木笼上。白[疊*毛]缠头却卧闇处。尔时世尊还只陀林。末利夫人白言。世尊。愿化邪女莫还精舍。佛告末利。此女罪重于佛无缘。于罗睺罗有大因缘。佛今日行为其除罪。作是语已即还精舍。告罗睺罗。汝诣须达大长者家度恶老母。作是语时千二百五十沙门皆作是言。我等今日愿欲随从

尔时罗睺。承佛威神入如意定。礼拜既毕绕佛七匝。即自化身作转轮圣王。阿难侍左难陀侍右。千二百五十比丘化为千子。阿难为典藏臣。难陀为主兵臣。七宝四兵皆悉具足。时金轮宝在虚空中乘莲华台。径往须达大长者家。夜叉唱言。圣王出世摈诸恶人。宣扬善法。老母闻已心大欢喜。圣王出者有如意珠。无所求索此当可言

尔时圣王。椎钟鸣鼓乘大宝舆至须达家。老母见已甚大欢喜。圣王出世多所润益。识别善恶。必当不为沙门所惑。从木笼出敬礼圣王。圣王即遣主宝藏臣往至女所告言。姊妹。汝宿有福应王者相。圣王今者欲以姊妹为玉女宝。老母白言。我身卑贱犹如粪秽。圣王顾问喜庆无量。何所堪任应玉女宝。若见念者敕我大家。放我令脱所赐已多

尔时圣王告须达言。卿家老女众相巍巍。吾今欲以充玉女宝。须达白言。惟命是从愿上大王。老婢闻放喜悦非常。圣王即便以如意珠照耀女面。令女自见如玉女宝。倍大欢喜而作是言。诸沙门等高谈大语。自言有道无一效验。圣王出世弘利处多。令我老弊如玉女宝。作是语已五体投地礼于圣王。时典藏臣宣王优令扬十善法。女闻十善心大欢喜。即作是念。圣王所说义无不善。为王作礼悔过自责心即调伏。时罗睺罗还复本身。老母举头见千二百五十比丘。即作此言。佛法清净不舍众生。如我弊恶犹尚化度。作是语已求受五戒。时罗睺罗。为说三归受五戒法。母闻此法未举头顷成须陀洹。地神欢喜从地踊出告须达言。善哉长者。裂邪见网。如来出世正为此耳

时罗睺罗将此老母诣只陀林。到已见佛身相紫金。欢喜合掌为佛作礼。忏悔前罪求佛出家。佛告罗睺。汝将此母诣憍昙弥。未至中间罗睺为说苦空非常无我等法。老母闻已头发自落成比丘尼。三明六通具八解脱。身升虚空作十八变。波斯匿王末利夫人。见此变化心大欢喜。善哉佛日出现世间破无明闇。能令邪见得应真道。作是语已为佛作礼白言。世尊。如此老母宿有何罪。生卑贱处为人婢使。复何福庆值遇世尊。如好白[疊*毛]易受染色。应时即得阿罗汉道

佛告大王。谛听谛听善思念之。如来为王分别解说。过去久远无数劫时。有佛世尊名一宝盖灯王如来十号具足。彼佛灭后于像法中。有王名曰杂宝华光。其王有子名曰快见。求欲出家父即听许。王子诣山到僧坊中求欲出家。时有比丘聪明多智深解实相。受为弟子。复有比丘名德华光。善说法要诱进初学。王子比丘虽复出家犹怀憍慢。和上为说甚深妙法般若波罗蜜大空之义。王子闻已谬解邪说。比丘灭后即作此言。我大和上空无智慧。但能赞叹虚无空事。愿我后生不乐见也。我阿阇梨智慧辩才。愿于生生为善知识。王子比丘作是语已。法说非法非法说法。教诸徒众皆行邪见。虽持禁戒威仪不缺。以谬解故命终之后。如射箭顷堕阿鼻狱。八十亿劫恒受苦恼。罪毕乃出为贫贱人。五百身中聋痴无目。千二百身恒为人婢。佛说是时。末利夫人有五百婢。忏悔自责发菩提心。愿于来世解深空法

佛告大王。尔时和上者今我身是。阿阇梨者今罗睺罗是。王子比丘此老母是。徒众弟子今日邪见女等。发菩提心者是。佛说此时。舍卫城中二万优婆塞。发菩提心得念佛定。常于定中见佛说法。佛告父王。邪见恶人见佛行时。尚得如此无量福德。何况观佛行及像行者

父王白佛。佛母摩耶生忉利天。佛今光相神通具足。云何当往为母说法。佛告大王。如来当如转轮圣王足行之法。从阎浮提上忉利天。问讯檀越为说妙法

尔时会中有菩萨摩诃萨。名曰持地。即从座起入首。楞严三昧。三昧力故从金刚际。金刚为轮。金刚为根。金刚为花。花花相次出阎浮提。时四龙王难陀。跋难陀。阿耨达多。娑伽罗龙王等。各持七宝诣持地所。奉上七宝。为佛世尊作三道宝阶。左白银右颇梨中黄金。从阎浮提金刚地际上忉利宫。一一宝阶七重栏楯。是诸栏楯百亿宝成。百亿光明。一一光明百亿宝花。一一花中无量乐器自然踊出。尔时持地。以恒河沙七宝莲华敷佛蹈处。于阶道侧竖诸宝幢。无量宝幡悬其幢头。百亿宝盖弥覆其上。忉利诸天雨曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。严饰其间。时梵天王手擎香炉。与万梵俱侍立阶侧。一一香烟如琉璃云。弥满虚空。于其云中百千妓乐不鼓自鸣。难陀龙等。持海此岸栴檀末香漫散道中。香光上出如金光焰。高一多罗树化为金台。无量诸天。持天璎珞严饰阶道。如是供具不可称计

尔时世尊于阎浮提执持三衣。告敕阿难。难陀。罗睺罗等。五百比丘。足步大地。始举足时地六种动。下足之时。地生宝宫如梵王宫。宫宫相次悬在空中。随映佛后在阶道侧。持地菩萨并弥勒等一千菩萨一时合掌。以万亿音歌咏如来无量德行。尔时梵王无数百千诸梵天等。手擎香炉无量妓乐。以供养佛立侍左阶。释提桓因无数天子百千天女。鼓乐弦歌亦立左阶。无数声闻菩萨大众侍立右阶。尔时世尊放大光明照阶道边。其光如云百千亿色犹如重阁。佛处其中八万四千化佛围绕。五百分身诸佛与佛政等。执持衣钵威仪详序。分身诸佛亦有阿难难陀。以为侍者。时魔波旬。于虚空中与诸魔众。赞诵妙偈叹如来功德。释提桓因白摩耶言。如来世雄。为报恩故来至此处。摩耶夫人。闻佛已来遣诸天女。持诸天宝及天妓乐曼陀罗华。在阶道边以迎世尊

尔时如来。举足下足无数宫殿。一一宫殿五百化佛结加趺坐。一一如来五百菩萨以为侍者

尔时五百分身诸释迦文入忉利天宫。诸天欢喜而说此偈

  毗婆尸佛　　吉祥中尊　　亦放光明
  来至此处　　尸弃如来　　大吉祥尊
  化身无数　　来至此处　　毗舍满月
  放白毫光　　普照一切　　来至此处
  拘楼孙佛　　面门出光　　照十方界
  来至此处　　迦那含佛　　化身无数
  放大光明　　来至此处　　迦叶世尊
  身如宝台　　足步虚空　　来至此处
  释迦牟尼　　分身五百　　无数化佛
  照耀一切　　来至此处
  弥勒菩萨　　贤劫尊者　　亦放光明
  当至此处　　此处吉祥　　安隐无为
  诸佛所游　　牟尼生地　　名涅槃窟
  慧者智度

尔时世尊。入忉利宫即放眉间白毫相光。其光化作七宝大盖覆摩耶上。七宝饰床奉摩耶坐。佛母摩耶见佛入宫。合掌恭敬为佛作礼。五百化佛一时申手。诸天扶持不听礼敬。八万四千诸化如来皆悉起立。尔时摩耶夫人宫中。自然踊出五百亿光。此光明中有大宝台。一一台上有十方佛。如是诸佛。自说名字安慰佛母。东方善德佛持妙宝花。散释迦牟尼及摩耶上。化成花盖。此花盖中百亿化佛。合掌起立问讯佛母。南方栴檀德佛持宝莲花。散释迦牟尼及散佛母上。化成花盖。于花盖中无数化佛。合掌起立问讯佛母。西方无量明佛以宝莲花。散释迦牟尼及佛母上。化成花盖。无数化佛合掌起立问讯佛母。北方相德佛以宝莲花。散释迦牟尼及佛母上。化成花盖。无数化佛合掌起立问讯佛母。东南方无忧德佛。西南方宝施佛。西北方花德佛。东北方三乘行佛。上方广众德佛。下方明德佛。如是等佛各以宝花。散释迦牟尼佛上及散佛母。化成花盖。一一盖中无数化佛。合掌起立问讯佛母。时忉利宫满中化佛。佛母摩耶顶上自然出众供具。无量幢幡供养诸佛。时幢幡中有妙音声。赞佛赞法赞比丘僧。佛告阿难。是名如来从阎浮提升忉利宫。色相光明诸神化事。佛灭度后佛诸弟子。若如是观是名正观。若异观者名为邪观。作此观者。除一亿劫生死之罪。临命终时见十方佛。必生他方净佛国土。佛告阿难。汝持是语。为未来世诸众生等当广宣说。闻此语者思是义者。当知是人十方诸佛之所覆护。命终必当生诸佛前

佛告父王。云何名如来从忉利天。下阎浮提时光相变应。我初下时。无数天子百千天女侍从世尊。独见一佛圆光一寻放千光明。足步虚空蹑阶而下。时佛光中七佛像现。从佛光出导佛前行。时优填王。恋慕世尊铸金为像闻佛当下。象载金像来迎世尊。莲华色比丘尼化作琉璃山。结加趺坐在山窟中。无量供具奉迎世尊。尔时金像。从象上下犹如生佛。足步虚空足下雨华。亦放光明来迎世尊。时铸金像。合掌叉手为佛作礼。尔时世尊。亦复长跪合掌向像。时虚空中百千化佛。亦皆合掌长跪向像

尔时世尊而语像言。汝于来世大作佛事。我灭度后。我诸弟子以付嘱汝。空中化佛。异口同音咸作是言。若有众生于佛灭后造立形像。幡花众香持用供养。是人来世必得念佛清净三昧。若有众生知佛下时种种相貌。系念思惟必自得见。佛告阿难。佛灭度后佛诸弟子。知佛如来下忉利天及见佛像。除却千劫极重恶业。如是观者名为正观。若异观者名为邪观

佛说观佛三昧海经卷第六佛说观佛三昧海经卷第七

        东晋天竺三藏佛陀跋陀罗译

    观四威仪品第六之余

佛告阿难。云何如来至旷野泽伏鬼大将。我从舍卫只陀精舍。放金色光照舍卫城令作金色。舍卫国内有一长者名曰财德。长者有子年始三岁。父教其子令受三归。散脂鬼神饥火所逼。入舍卫城接取婴儿。尔时婴儿称南无佛。以称佛故鬼王口噤不能得食。但眼出火以怖婴儿。婴儿见鬼形状丑恶胸有三面。脐有二面两膝二面。面如象面狗牙上出。眼复出火火皆下流。童子惊怖称南无佛南无法南无僧。尔时世尊。天耳远闻独将阿难足步虚空。阿难在后从佛不及。佛以神力化作宝华。其华光明接取阿难。阿难坐华见阎浮提满中化佛。一一化佛身满三千大千世界。是诸化佛说三乘法。劝进菩萨修行念佛。阿难见闻即忆过去九十亿佛所说经藏。忆持不失

尔时世尊到旷野泽。放眉间白毫大人相光。其光直照怖小儿身。小儿见光。如见父母心无惊惧。时旷野鬼。举一大石厚十二丈。欲掷世尊。眼出雷电雨雹如雨。一一雹下如赤鸡子从空而下。未至佛上化成化佛。一一化佛入火光三昧。诸火光明烧旷野泽。大地洞然鬼王不怖。掷石住空化成宝台。台中复有百亿化佛。异口同音赞叹慈心。鬼犹不伏。时金刚神。手奋金杵挥大利剑。髭如剑竦眼如电光。以金刚杵拟鬼王额。攘臂大叫声振天地。鬼王惊怖抱持小儿。长跪上佛白言。沙门唯愿慈爱救我生命。时金刚神化金刚杵为大铁山。四面火起绕鬼七匝。猛火炎炽焚烧鬼身。婴儿举手敕鬼王言称南无佛。我称佛故从死得生。汝今可称南无诸佛。尔时鬼王。惊怖失声称南无佛。白言瞿昙可救护我

尔时世尊。以梵音声犹如慈父安慰诸子。抚慰鬼王亦复如是。密迹金刚敕鬼王言。汝今速伏归依佛法及与众僧。汝若不伏碎汝眷属万亿八千令如微尘。时旷野鬼以惊怖故。五体投地为佛作礼白言。世尊。我恒啖人。今者不杀当食何物。佛敕鬼王汝但不杀。我敕弟子常施汝食乃至法灭。以我力故令汝饱满。鬼王闻已欢喜合掌受佛五戒。受五戒已见诸火山。焰焰相次变成化佛满旷野泽皆是化佛。一一佛后有一阿难。一一化佛异口同音皆说五戒。时旷野鬼白金刚神。因大德故得服甘露无上法味。时金刚神掷杵空中。佛神力故令金刚杵犹如百亿金须弥山。一一须弥百亿龛室。一一龛室百亿化佛游步经行。是诸化佛举足下足。足下自然生七宝台。一一台上恒沙化佛结加趺坐。佛告大王。佛灭度后佛诸弟子。欲知如来伏旷野鬼自在神通。如是观者名为正观。若异观者名为邪观。佛灭度后若有众生。思是法者观是法者得此想者。除百千亿劫生死之罪。生生之处不受鬼身。值遇诸佛间无空缺。设无佛时遇辟支佛。无辟支佛恒遇仙人为说正道。佛告阿难。汝今持是境界念想。为未来世一切众生当广宣说。是名诸佛神通境界。若失此事则名谤佛断菩提种。持是法者鬼魅不着。恒为诸佛之所护助

佛告阿难。云何名如来到那干诃罗国。古仙山薝卜华林。毒龙池侧青莲华泉北。罗刹穴中阿那斯山岩南。尔时彼穴有五罗刹。化作女龙与毒龙通。龙复降雹罗刹乱行。饥馑疾疫已历四年。时王惊惧。祷祠神祇于事无益。召诸咒师令咒毒龙。罗刹气盛咒术。不行。王作是念。得一神人。驱此罗刹降是毒龙。唯除我身其余无惜。时有梵志聪明多智。白言。大王。迦毗罗城净饭王子。其生之日万神侍御七宝降瑞。阿私陀相。处国当为转轮圣王。若不乐天下成自然佛。今者道成号释迦文。巨身丈六三十二相八十种好。足蹑莲华项佩日光。身相端严如真金山。王闻是语心大欢喜。向佛生地自归作礼。若梵志语审实不虚。有佛出世名释迦文。然我相法。却后九劫乃当有佛名释迦文。云何今日佛日已兴。云何不哀至此国界。空中有声告言大王。汝莫疑。佛释迦牟尼精进勇猛超越九劫。闻是语已。复更长跪合掌赞叹。佛通明慧应知我心。愿屈慈悲光临此国。尔时香烟至佛精舍。如白琉璃云。绕佛七匝化作金盖。其盖有铃出妙音声。其声请佛请比丘僧。尔时如来敕诸比丘。诸得六通者随从佛后。受那干诃罗王弗巴浮提请

摩诃迦叶徒众五百化作琉璃山。山上皆有流泉浴池七宝行树。树下皆有金床银光。光化为窟。摩诃迦叶坐此窟中常坐不卧。敕诸弟子行十二头陀。其山如云疾于猛风诣古仙山。大目揵连徒众五百。化百千龙盘身为座。龙口吐火化成金台七宝床座。宝帐宝盖及诸幢幡皆悉备足。目连处中。如琉璃人表里清彻。诣那干诃舍利弗以神通力。化作雪山白玉为窟。均提等五百沙弥。坐七宝窟围绕雪山。时舍利弗坐白玉窟。如黄金人放金色光。其光杂色映耀雪山。敷扬大法沙弥听受。往诣彼国

摩诃迦栴延与其眷属五百比丘化作莲华。犹如金台比丘处上。身下出水化为流泉。流诸华间水不渧地。上有金盖弥覆比丘。亦往彼国。如是千二百五十大弟子。各有五百比丘作诸神通。如舍利弗目揵连等。踊身虚空如雁王翔。往诣彼国

尔时世尊着衣持钵敕语阿难持尼师檀。尔时世尊足步虚空。佛举足时。四天王释提桓因梵天王无数天子百千天女绕佛七匝。为佛作礼侍从佛后

尔时世尊。放项金光化作一万八千诸大化佛。一一化佛复放光明。如此项光亦复化作一万八千诸大化佛。佛佛相次满虚空中。如雁王翔往至彼国。始到国界王出奉迎为佛作礼。尔时龙王见世尊来。父子徒党十六大龙兴大云雷震吼雨雹。眼中出火口亦吐火。鳞甲身毛俱出烟焰。五罗刹女现丑恶形。眼如掣电住立佛前。时龙王子。见虚空中满中化佛。白其父言。父王吐火欲害一佛。试看空中有无数佛。时龙吐毒心意猛盛诃责其子。惟有一佛何处有多。时金刚神手把大杵化身无数杵头火然如旋火轮。轮轮相次从空中下。火焰热炽犹如融铜。烧恶龙身龙王惊怖。无走遁处走入佛影。佛影清凉如甘露洒。龙得除热仰头视空。满空中佛一一如来放无数光。一一光中无量化佛。一一化佛亦放无数百千光明。时诸光中一切皆是执金刚神奋金刚杵。龙见诸佛极大欢喜。见诸金刚极大惶怖。合掌恭敬为佛作礼。五罗刹女亦礼如来。时诸天子雨曼陀罗花摩诃曼陀罗花曼殊沙花摩诃曼殊沙花。而以供养天鼓自鸣。诸天叉手空中立侍。时彼国王眷属五千。烧众名香头面礼佛请佛就座。时彼龙王从龙池出。献七宝床手擎敷置白佛。世尊。惟愿救我。莫使力士伤害我身

尔时如来以梵音声。犹如慈母抚恤婴儿令彼龙王及罗刹女受法王化。请佛就座。尔时国王。复敷高床[毯-炎+瞿]氀毾[毯-炎+登]极细软者。张白[疊*毛]缦。真珠罗网弥覆其上。请佛世尊令处缦中

尔时世尊。举足欲行佛鹿王腨腨出五光。光有五色绕佛七匝。如天妙花化成花帐。众花叶间百千无数诸化菩萨。合掌赞偈有万亿音。空中化佛放腨光明亦复如是。十六小龙手执山石。霹雳起火来至佛所。大众惊怖入佛光中

尔时世尊。出金色臂张合曼掌。指网曼间雨大宝花。大众皆见化成化佛。唯诸龙见是金翅鸟欲搏噬龙。龙畏金翅走入佛影。为佛作礼叩头求救。佛至缦前敕阿难言。敷尼师檀。是时阿难即入缦中。先举右手从左肩上取尼师檀。时尼师檀即复化成五百亿金台。七宝校饰。欲敷之时即复化成五百亿莲华七宝庄严。政四角时。一角生五百亿七宝莲华。行行相次遍满缦内

尔时世尊。就七宝床结加趺坐。诸莲花上皆有佛坐。时诸比丘见佛坐已。为佛作礼右绕七匝。各敷坐具比丘坐具。皆悉化成琉璃之座。比丘就座时琉璃座放琉璃光作琉璃窟。诸比丘等。入火光三昧身作金色。时彼国王。见佛神变欢喜合掌。绕佛七匝为佛作礼。睹佛神化。应时即发阿耨多罗三藐三菩提心。敕诸臣下皆使发心。尔时龙王。怖畏金刚大力士故。亦发阿耨多罗三藐三菩提心。五罗刹女亦发菩提心

尔时大王。为佛及僧欲设中膳。佛告大王。但办食器余无所须。王受佛敕具诸宝器。佛神力故令诸器内天须陀昧自然盈满。时诸大众食是食已。自然得入念佛三昧。见十方佛身量无边。复闻说法微妙音声。其音纯赞念佛念法念比丘僧。亦有广说六波罗蜜。三十七品助菩提法。闻是语已倍更欢喜。绕佛千匝

尔时国王请佛入城。龙王怒曰。汝夺我利吾灭汝国。佛告大王。檀越先归佛自知时。尔时国王。为佛作礼逡巡而退。尔时龙王及罗刹女。五体投地求佛授戒。佛即如法为说三归五戒之法。龙王闻已心大欢喜。龙王眷属百千诸龙。从池而出为佛作礼。如来应时随龙音类为其说法。闻法欢喜。佛敕目连为其受戒

尔时目连入如意定。即自化身作百千亿金翅鸟王。一一鸟王足蹑五龙住在虚空。时诸小龙而作是言。佛敕和上为我受戒。和上云何作恐怖像。目连告曰。汝于多劫不恐怖中横生怖想。于无嗔恚生嗔恚想。于无害所横生害想。我实是人。汝恶心故见我是鸟。尔时龙王以恐怖故。自誓不杀不恼众生以发善心。目连即时还复本身为说五戒

尔时龙王。长跪合掌劝请世尊。唯愿如来常住此间。佛若不在我发恶心无由得成阿耨多罗三藐三菩提。唯愿如来留神垂念常在于此。殷勤三请如是不止。时梵天王。复来礼佛合掌劝请。愿婆伽婆。为未来世诸众生故。莫独偏为此一小龙。百千梵王异口同音皆作是请

尔时如来即便微笑。口出无量百千光明。一一光中无量化佛。一一化佛万亿菩萨以为侍从。时彼龙王于其池中。出七宝台奉上如来。唯愿天尊受我此台。尔时世尊告龙王曰。不须此台。汝今但以罗刹石窟持以施我。时梵天王无数天子先入窟中。时彼龙王以诸杂宝以庄挍窟。佛告阿难。汝教龙王净扫石窟。诸天闻已。各脱宝衣竞以拂窟。尔时如来还摄身光。卷诸化佛来入佛顶。尔时如来。敕诸比丘皆在窟外。唯佛独入自敷坐具。敷坐具时。令此石山暂为七宝。时罗刹女及以龙王。为四大弟子尊者阿难。造五石窟

尔时世尊。坐龙王窟不移坐处。亦受王请入那干诃城。耆阇崛山。舍卫国迦毗罗城。及诸住处皆见有佛。时虚空中莲华座上无量化佛。一切世界满中化佛。龙王欢喜发大誓愿。愿我来世得佛如此。佛受王请经七日已。王遣一人乘八千里象。持诸供具遍一切国供养众僧。到处皆见释迦文佛。信反白王。如来世尊。不但此国余国亦有。余国诸佛皆说苦空无常无我六波罗蜜。王闻是语。豁然意解得无生忍

尔时世尊。还摄神足从石窟出。与诸比丘游履。先世为菩萨时。两儿布施处。投身饿虎处。以头布施处。剜身千灯处。挑目布施处。割肉代鸽处。如是诸处龙皆随从。是时龙王。闻佛还国啼哭雨泪。白言。世尊。请佛常住。云何舍我我不见佛。当作恶事坠堕恶道。尔时世尊安慰龙王。我受汝请坐汝窟中。经千五百岁。时诸小龙合掌叉手。劝请世尊还入窟中。诸龙见佛坐已窟中。身上出水身下出火作十八变。小龙见已。复更增进坚固道心。释迦文佛踊身入石。犹如明镜人见面像。诸龙皆见佛在石内映现于外。尔时诸龙合掌欢喜。不出其池常见佛日

尔时世尊。结加趺坐在石壁内。众生见时。远望则见近则不现。诸天百千供养佛影。影亦说法。时梵天王合掌恭敬。以偈颂曰

  如来处石窟　　踊身入石里
  如日无障碍　　金光相具足
  我今头面礼　　牟尼救世尊

尔时世尊。化五百宝车。佛处车中分身五百。尔时宝车。住虚空中回旋自在。车毂辋间百千光明。一一光明无数化佛。不动不转到迦毗罗城。坐师子座如入三昧。一毛孔中有一佛出。一毛孔中还一佛入。如是出入满虚空中。无量化佛结加趺坐。是名如来坐时境界。佛灭度后佛诸弟子。若欲知佛行者。如向所说。若欲知佛坐者当观佛影。观佛影者先观佛像作丈六想。结加趺坐敷草为座。请像令坐见坐了了。复当作想作一石窟高一丈八尺深二十四步清白石想。此想成已见坐佛像住虚空中足下雨花。复见行想入石窟中。入已复令石窟作七宝山想。此想成已复见佛像踊入石壁。石壁无碍犹如明镜。此想成已如前还想三十二相。相相观之极令明了。此想成已见诸化佛。坐大宝花结加趺坐。放身光明普照一切。一一坐佛身毛孔中。雨阿僧祇诸七宝幢。一一幢头百千宝幡。幡极小者。纵广正等如须弥山。此宝幡中。复有无数百千化佛。一一化佛。踊身皆入此石窟中佛影脐里。此想现时如佛心说。如是观者名为正观。若异观者名为邪观。佛灭度后。如我所说观佛影者。是名真观如来坐。观如来坐者。如见佛身等无有异。除百千劫生死之罪。若不能见。当入塔观一切坐像。见坐像已忏悔障罪。此人观像因缘功德。弥勒出世。见弥勒佛初始坐于龙华树下结加趺坐。见已欢喜。三种菩提随愿觉了

云何名观如来行。诣拘尸那时降诸力士。佛告父王。如来不久。当于彼国入般涅槃。尔时五百力士除妨路石。尽力士力不能令去。尔时世尊化作沙门。以手挑石石飞住空中。力士惊怖。此石设堕走避无所。仰看空石皆成化佛。犹如金山诸佛围绕。力士见已心大欢喜。时化沙门。倚卧树下如人昼眠。有日光明从左胁出。如百亿日入右胁中。一一日中有二宝树。有大宝床诸佛卧上。如是光明遍照十方无量世界。一一世界无量诸佛。倚卧树下皆有光明。从右胁入左胁而出。如是光明变成宝台。行者悉见十方世界有一宝台。此宝台上有一大佛。身量巨小与十方等。倚卧台侧。尔时彼佛。左胁流水如琉璃珠。一一宝珠如须弥山。一一山内百千卧佛。一一卧佛出大光明。亦如上说。右胁复出万亿乳河流注于下。渧渧化成百千化花。花有化佛卧莲花上。各以右手洒甘露雨。令一切众皆得服食。饿鬼众生见此相时自然饱满

尔时空中有妙音声。赞四无量心。然后分别空无境界。无心心想寂灭境界。作是观者名观如来卧。观如来卧者。先当观卧像。见卧像已当作是念。佛在世时所以现卧。诸佛如来体无疲惓。但为降伏刚强力士及诸邪见不善众生。或复慈愍诸比丘故现右胁卧。如来卧者是大悲卧。欲观佛卧当行慈心。行慈心者。缘一切众生见受苦时。不惜身分成熟安乐。受苦众生令得无患。大悲心者。见诸众生受苦恼时。如己父母师长善友。生悲哀心泪如猛雨。如是等心名为大悲。见他受乐心生欢喜。譬如比丘得第三禅。是名为喜

舍者。一切众生无众生相。作是观时先观自身。地大是众生耶。水火风大是众生耶。色是众生耶。受想行识是众生耶。空是众生耶。非空是众生耶。如是众生耶。非如是众生耶。实际是众生耶。非实际是众生耶。有为空是众生耶。无为空是众生耶。如是分别解析时。不见众生不得众生无众生想。心无所著亦无志求。解如是等清净法者。名为行舍

佛告阿难。若有众生乐观佛卧者。是则真观清净慈定。若有众生闻佛卧法。及诸比丘。随顺佛语不坏威仪。右胁卧者。当知是人。着惭愧衣服忍辱药。如此比丘现世坐禅。见十方佛为说大法。若不坐禅不毁戒故。于未来世见十方佛。十方诸佛为说大法。闻法易悟。犹如壮士屈申臂顷。应时即得阿罗汉道。三明六通具八解脱。如来卧者饶益众生。以饶益故名慈悲喜舍。此四法者。出生诸佛诸菩萨母。说是语已。佛于众中举身放光。前八万四千。左八万四千。右八万四千。后八万四千。项八万四千。是诸毛孔一一毛孔一毛旋生。一一毛端有百万亿尘数莲花。一莲花上无量无数微尘化佛。诸化佛身高显庄严。如千万亿诸须弥山。一一佛脐中有五百万亿师子。一一师子吐五百万亿诸供养具。一一供具有五百万亿七宝花云。一一宝花云有五百万亿诸偈颂云。声声相次犹如雨渧

尔时如来。复更明显八十种好。金色光明从白毫出。一一光明遍照十方化成诸佛。是诸世尊。行者无数住者无数坐者无数卧者无数。是诸化佛说大慈悲。说三十七品助菩提分法。说六波罗蜜。说佛如来十力无畏十八不共。此相现时一亿诸释。心无所著悟无生忍。佛为授记于未来世。过算数劫当得作佛。号三昧胜幢如来应供正遍知十号具足。次第作佛凡有一亿。彼佛出时娑婆世界清净庄严。犹如圣伏幢世界光明佛刹。等无有异。是诸菩萨得佛道时。国土无有毁禁乱意不善之名。纯是菩萨。虽有声闻不谤大乘。时诸释子。闻佛授记心大欢喜。各脱璎珞以散佛上。是诸璎珞。当佛上住化成花树。一一花树有恒沙花。一一花上有恒沙宝楼。一一楼中有恒沙化佛。一一化佛演说八万四千诸波罗蜜

复有化佛教诸声闻数息安般。流光白骨白骨流光。心净想心不净想。起结使想灭结使想。断使支想杀使根想。如是诸想九百亿尘数。如数息安般。说是名声闻法。菩萨法者唯有四法。何等为四。一者昼夜六时说罪忏悔。二者常修念佛不诳众生。三者修六和敬心不恚慢。四者修行六念如救头然

佛告父王。如是等名未来世观佛三昧。亦名分别佛身。亦名知佛色相。亦名念佛三昧。亦名诸佛光明覆护众生。说是语时。天龙夜叉八部鬼神。十二亿众。发阿耨多罗三藐三菩提心。自发誓愿。愿于来世常入三昧。见佛色身如今无异

时梵天王释提桓因无数天子。为佛作礼长跪合掌而白佛言。世尊。我等今者得见如来色中上色。愿当来世浊恶众生。系念思惟见佛色身此愿不虚。我今所说及我所见真实不虚。愿令我等及诸天众犹如佛身。作是语时。自见心中百万光出。一一光明化成无量百千化佛。自见己身身真金色。犹如难陀等无有异

时诸梵天白佛言。如来世雄出现于世。必当利益一切众生。昔弘誓愿今已得满。不舍众生此语不虚故。我自见心想境界未来众生亦当如是想佛真身。佛告梵天。如汝所说真实不虚。未来众生但发是念。得无量福身相具足。何况忆想。佛说是语时。净饭王及诸释子。比丘尼优婆夷。同时俱起礼佛而退

尔时父王还至宫中。为诸婇女说佛相好。千二百五十婇女。闻佛白毫相心生欢喜。除百万亿那由他生死之罪。空中有声告诸女言。汝闻佛相除诸罪咎。应发无上三菩提心。闻是语已。即见空中无量诸佛。见诸佛已。亦皆同时得念佛定。时诸比丘。即从坐起敬礼佛足。绕佛七匝却住一面

尔时阿难偏袒右肩。合掌长跪白佛言。世尊。佛说三十二相余有一相。如来云何不显说耶。尔时世尊。敕诸比丘各令还坐。尔时世尊。自化左右作五百亿宝山。一一宝山有四佛坐。四佛世尊赞叹念佛。佛即微笑。口五色光舌十四光。如此光明化成一佛。其佛脐中流出五水。其色各异。一一色中有九亿菩萨。一一菩萨顶上皆有梵摩尼光。光中皆有恒沙化佛。一一化佛脐中出水亦复如是。如是众水流入佛脐。是诸化佛并化菩萨皆入佛脐。是时佛身表里俱净。过于净妙胜琉璃珠。于佛身内有师子座。一一师子座如须弥山。一一座上有一如来。九十亿菩萨以为侍者。是诸菩萨顶上诸佛如须弥山。如是十方无量诸佛脐中出水。皆与水俱来入释迦文佛脐。时诸佛不大释迦不小。释迦不大诸佛不小。释迦文佛身内心中有无量佛。一一佛不相障翳。举身毛孔说念佛法。时诸化佛。各申右手摩阿难顶。汝今善持观佛三昧。莫使忘失一心忆念。为未来众生开光明目。作是语时。过去七佛像住立空中。各申右手摩阿难顶。嘱累是事。时虚空中有无数光。一一光中有无数化佛。异口同音嘱累斯法

佛说观佛三昧海经卷第七佛说观佛三昧海经卷第八

        东晋天竺三藏佛陀跋陀罗译

    观马王藏品第七

佛告阿难。未来众生云何当观如来阴马藏相。阴马藏相者。我在家时。耶输陀罗及五百侍女咸作是念。太子生世多诸奇特。唯有一事于我有疑。婇女众中有一女子名修曼那。即白妃言。太子者神人也。毗陀经说。若有神人质性清净。以梵行故身根平满。太子今者似梵行人。纳妃多载其诸婇女奉事历年。不见身根况有世事。复有一女名曰净意。白言大家我事太子经十八年。未见太子有便利患。况有诸欲。尔时诸女各各异说。皆谓太子是不能男。太子昼寝。皆闻诸女欲见太子阴马藏相。是时太子。誓愿力故应诸女人。安徐转身内衣被发。见金色身光明晃耀双膝暂开。咸睹圣体平如满月。有金色光犹如日轮。诸女欢喜。如此神人实可敬爱。但于我等世情望绝。作是语已悲泣雨泪。尔时太子。于其根处出白莲华。其色红白上一下二三华相连。诸女见已复相谓言。如此神人有莲华相。此人云何心有染着。作是语已噎不能言。是时华中。忽有身根如童子形。诸女见已更相谓言。太子今者现奇特事。忽有身根如是渐渐如丈夫形。诸女见此满已。情愿不胜悦喜。现此相时罗睺罗母。见彼身根花花相次如天劫贝。一一花上乃有无数大身菩萨。手执白花围绕身根。现已还没如前日轮。此名菩萨阴马藏相。如来今者成菩提道。是大丈夫具男子身。复当为汝显现男相

佛告阿难。汝未出家时摩偷罗王。有一乳母名头牟婆。乳养彼王经十五载王既长大。合掌长跪从王求愿。白言大王。我虽卑贱。乳养大王勤劬历年。伏惟大王乞赐一愿。王白乳母欲求何等。乳母即言。在王宫中如功德天。一切无乏唯阙一事。所谓女人情愿所幸。王白乳母。当以乳母配一大臣义同伉俪。乳母不愿。白言大王。贵人多事非我所乐。愿敕国内一切男子。十五已上三十已还皆悉从我。若能来者。我施彼人一大金钱。形丑陋者当施银钱。时彼国王。报乳母恩造一高楼。宣令国内敕诸男子。如上所愿皆悉来集。经历年岁乳母衰老。多招诸女遂有五百。一一女人复买诸婢。种种庄饰数满八千。时彼国王遘疾崩亡。太子绍位。智臣白言。先王报恩恣此老婢。令王国土加淫女村。损辱国望实自不少。用此何为宜时摈徙。白已出外。焚烧高楼驱逐诸女。诸女惶怖诣舍卫国。既到舍卫于四衢道造立淫舍作妖如前。舍卫大国多诸人众。凑诸女家经一宿者输金钱二百。国有长者名如闾达。积财百亿。长者有子名曰华德。兄弟三人游荡无度竞奔淫舍。始初一往各各皆输金钱十五。日日夜夜恒输金钱过倍常人。经一月中一藏金尽。其父长者案行诸藏。见一藏空问守藏者。此藏中金为何所在。典藏白言。大家诸子。日日持金往淫女舍。若不制止用金当尽。长者闻已椎胸大哭。呜呼贼子破我家居。手执大杖打儿母头。其归号哭。呜呼贼子。生儿无益偷金藏尽。父无训范素不严敕。见打何为。长者嗔恚号哭诣王。腹拍王前白言。大王国内荒乱。摩偷罗国诸罗刹女。来住此城破我家业。王语长者。汝甚大富金藏犹尽。况余凡下宁不困耶长者白王。唯愿大王速诛恶人。王告长者。吾受佛戒犹不伤蚁况欲杀人。长者闻此。举手拍头白言。大王。臣闻王者诛罚恶人为国除患当有何罪。今日大王与恶为伴。纵诸淫女坏乱正法。国荒民穷戒将安存

王告长者。如来出世多所调伏。鸯掘摩罗气嘘旃陀罗。大力鬼王罗刹魁脍。一切皆化今当诣佛启白此事卿可小忍。安慰臣已。驾乘名象。与诸侍从往诣祇洹。为佛作礼绕佛三匝合掌长跪白言。世尊。摩偷罗国诸淫女等。今来此间惑诸年少。愿佛化之。佛告大王。却后七日佛自知之。时波斯匿王礼佛而退

佛告摩诃迦叶。汝往须达大长者家可白。檀越却后七日。佛诣试场化诸淫女。须达闻已欢喜踊跃办诸供具。作七宝华高十一丈置佛坐处。悬诸缯盖香汁洒地。其日已至王击金鼓令诸国内。诸论议师皆诣试场。须达长者请诸比丘比丘尼优婆塞优婆夷。一切皆集当设供养。明日时到。王与诸人诣论议场。长者如闾达。遣旃陀罗唤诸淫女。须达长者亦白时到。是时如来敕千二百五十比丘。汝诸比丘。各随定意现大神通。上座憍陈如与四比丘化作一窟。大如香山百千莲华。一一华上有五比丘结加趺坐。身出金光令身金色。端严可爱犹如弥勒。复有化人作十八变。一一变中有十八比丘。作十八变神通可观。中有入三昧者。中有经行者。光明回旋犹如金山生诸宝华。比丘在窟身心不散。飞到试场坐于上位。郁毗迦叶。踊身空中化作六龙。蟠身相结为比丘座。在其座上作十八变飞至试场。伽耶那提兄弟二人。踊身虚空化作大石窟。入火光定作十八变飞至试场。大德摩诃迦叶。着千纳衣手擎钵盂。执持威仪足步虚空。步步之中化一宝树。一一树下有化迦叶。经行林中作十八变亦至试场。大智舍利弗。踊身空中作十八变。身上出千日光明赫奕不相障蔽。身下出千月如秋满月团圆可爱。作十八变飞至试场。大目揵连。踊身空中。化作八万四千师子座。一一师子闭目伏地白如雪山。大目揵连坐其背上。作十八变飞至试场。尊者优波离踊身空中。于虚空中敷尼师檀。结加趺坐入慈三昧。身诸毛孔流出金光。作十八变飞至试场。大迦旃延踊身空中。化作十五摩醯首罗。一一天子乘一牛王。头上生华。大迦旃延处此华座。作十八变飞至试场。须菩提踊身空中。冥然不现但闻语声。说如是偈

  一切法如性　　无我无众生
  亦无淫欲想　　当复教化谁
  诸法本无性　　亦无名字相
  爱着故起欲　　当复教化谁

说是语已作十八变飞至试场。时阿那律踊身空中。化万梵王作诸梵宫。比丘处中作十八变飞至试场。罗睺罗难陀。时二比丘踊身空中化作宝楼。比丘处中入深禅定。作十八变飞至试场。如是千二百五十比丘各现异变。亦作十八种神通飞至试场。尔时世尊独将阿难。持尼师檀手执澡罐。世尊在前阿难在后。从佛钵盂中有六莲华。一一莲华放金色光。照舍卫国令作金色。澡罐水中有大金幢。其金幢头有五百光。一一光明化千化佛。三十二相皆悉具足。足步虚空飞至试场。波斯匿王及诸大众。散华烧香为佛作礼。百千天乐不鼓自鸣。歌咏如来无量功德。波斯匿王长跪合掌。劝请如来令化淫女。佛坐华座为诸大众。略说苦空无常诸波罗蜜。诸女不受。时女众中。有一淫女名曰可爱。告诸女言。沙门瞿昙。本性无欲人言不男。故于众中演说苦空毁欲不净。若有身分皆具足者于大众中应去惭愧如尼揵子。出身示我审有此相。我等归伏为其弟子。若无此相虚说不净。此无根人性自无欲。云何不说欲为不净。说是语已。如来尔时化作一象。如转轮圣王象宝。时象脚间出一白华。犹如象支渐渐跓地。诸女见已欢喜大笑。各相谓言。沙门善幻乃化作此。佛复化作一马王像。出马王藏。如琉璃筒下垂至膝。诸女见已弥言是幻。末利夫人见此化相。白诸比丘尼及优婆夷。我等诸女宜各退还。淫女所说不可听闻。世尊大慈。今欲化之必作异变。我等宜避礼佛而退

佛敕阿难。汝告波斯匿王及诸比丘。各自游戏。波斯匿王白诸大德。如来大慈欲化淫女。我等今者宜各远去。作是语已却行而退。唯此千二百五十比丘侍立佛后。佛告憍陈如。将汝徒众经行林中。五百比丘大智舍利弗为众上首。犹故合掌侍佛左右。佛告舍利弗。汝亦随意与诸论师论讲所宜。五百比丘随舍利弗后至华林中。为波斯匿王更说四谛。唯阿难在。佛告阿难。汝留坐具汝亦宜去。作是语已。是时世尊独往女所。是时诸女见佛独在。高声大笑白言。沙门汝今为有身分不耶。佛言我具男身是大丈夫。诸女闻已掩口而笑。尔时世尊。敷尼师檀。金刚地神化作金床。七宝为脚在坐具下。佛坐其上。楪僧伽梨披僧祇支。示胸卍字令女见之。诸女见字。如百千男子年皆盛壮。颜貌奇特甚适女意。佛复披泥洹僧。见佛身体泯然平满。有金色光犹如千日。诸女见已。皆言瞿昙是无根人。佛闻此语。如马王法渐渐出现。初出之时犹如八岁童子身根。渐渐长大如少年形。诸女见已皆悉欢喜。时阴马藏渐渐长大如莲花幢。一一层间有百亿莲华。一一莲华有百亿宝色。一一色中有百亿化佛一一化佛百亿菩萨无量大众以为侍者。时诸化佛异口同音。毁诸女人恶欲过患。而说偈言

  若有诸男子　　年皆十五六
  盛壮多力势　　数满恒河沙
  持以供给女　　不满须臾意

时诸女人闻此语已。心怀惭愧懊憹躄地。举手拍头而作是言。呜呼恶欲。乃令诸佛说如此事。我等怀恶心着秽欲不知为患。乃令诸佛闻如此弊。犹如盛火焚烧我等。说是语时。见虚空中一切化佛。广为诸女说不净观。所谓九想十想三十想数息安般。诸女闻说不净观。法乐禅定乐不乐爱欲。尔时世尊。还摄身光端坐金床。大众云集还到佛所。波斯匿王白言。世尊。如来出世多所利益。乃于此处现大光明。况余身分无量功德。一切诸天在虚空中。亦赞如来百千梵行。如来梵行乃得如此。胜阴马藏没无处所。显出金华化佛无数。是持戒报功德巍巍。时诸女人闻此说已。四千女等发阿耨多罗三藐三菩提心。二千女人远尘离垢得法眼净。二千女人于未来世过十二劫。次第当得辟支佛道。长者如闾达。见佛现化恶魔女人赞言。善哉善哉。如来昔者破波旬军。今化诸女与本无异。此相现时无量诸天发菩提心。波斯匿王所将士众有五百人。求佛出家须发自落。身所著衣变成袈裟。应时即得阿罗汉道。是时大众见马王藏。心欢喜者除五十亿劫生死之罪。礼佛而退。佛告阿难。我昔夏安居时。波罗奈国有一淫楼。楼上有女名曰妙意。昔日于佛有重因缘。我与难陀及将汝。往此淫女舍日日乞食。此女于我不曾恭敬。于难陀所偏生爱着。已经七日女心念言。沙门瞿昙若能遣弟难陀阿难。从我愿言我当种种供养沙门。佛告阿难难陀。汝从今日莫往彼村。世尊自独执钵而行。至女楼所一日至三日。放金色光化诸天人。此女不悟。后日世尊。复将阿难难陀。在楼下行。淫女爱敬二比丘故。遥以众华散佛及二比丘。阿难告言。汝可礼佛。女爱阿难应时作礼。尔时世尊化三童子。年皆十五面貌端正。胜诸世间一切人类。此女见已身心欢喜。为化年少五体投地。敬礼年少白言。丈夫我今此舍如功德天。福力自在众宝庄严我。今以身及与奴婢。奉上丈夫可备洒扫。若能顾纳随我所愿。一切供给无所爱惜。作是语已化人坐床。未及食顷。女前亲近白言。丈夫愿遂我意。化人不违。随己所欲即附近已。一日一夜心不疲厌。至二日时爱心渐息。至三日时白言。丈夫可起饮食。化人即起缠绵不已。女生厌悔白言。丈夫异人乃尔。化人告言。我先世法凡与女通。经十二日尔乃休息。女闻此语如人食噎。既不得吐又不得咽。身体苦痛如被杵捣。至四日时如被车轹。至五日时如铁丸入体。至六日时。支节悉痛如箭入心。女作念言。我闻人说迦毗罗城净饭王子。身紫金色三十二相。愍诸盲冥救济苦人。恒在此城常行福庆。放金色光济一切人。今日何故不来救我。作是念已懊恼自责。我从今日乃至寿终终不贪色。宁与虎狼师子恶兽同处一穴。不贪色欲受此苦恼。作是语已复起饭食。行坐共俱无奈之何。化人亦嗔。咄弊恶女废我事业。我今共汝合体一处不如早死。父母宗亲若来觅我于何自藏。我宁经死不堪受耻。女言。弊物我不用。尔欲死随意。是时化人取刀刺颈血流滂沱。涂污女身萎沱在地。女不能胜亦不得免。死经二日青瘀臭黑。三日膖胀四日烂溃。大小便利及诸恶虫。迸血诸脓涂漫女身。女极恶厌而不得离。至五日时皮肉渐烂。至六日时肉落都尽。至七日时唯有臭骨。如胶如漆粘着女身。女发誓愿。若诸天神及与仙人。净饭王子能免我苦。我持此舍一切珍宝以用给施。作是念时。佛将阿难难陀。帝释在前擎宝香炉烧无价香。梵王在后擎大宝盖。无量诸天鼓天妓乐。佛放常光明耀天地。一切大众皆见。如来诣此女楼。时女见佛心怀惭愧藏骨无处。取诸白[疊*毛]无量众香。缠裹臭骨臭势如故不可覆藏。女见世尊为佛作礼。以惭愧故身映骨上。臭骨忽然在女背上。女极惭愧流泪而言。如来功德慈悲无量。若能令我离此苦者。愿为弟子心终不退。佛神力故臭骨不现。女大欢喜为佛作礼白佛言。世尊。我今所珍一切施佛。佛为咒愿梵音流畅。女闻咒愿心大欢喜。应时即得须陀洹道。五百侍女闻佛音声。皆发无上菩提道心。无量梵众见佛神变得无生忍。常释所将诸天子等。有发菩提心者。有得阿那含者

佛告阿难。我昔初成道时。伽耶城边住熙连河侧。有五尼揵。第一尼揵名萨阇多五百徒众。余四各有二百五十弟子。时诸尼揵自称得道。来至我所。以其身根绕身七匝。来至我所敷草而坐。即作是语。瞿昙。我无欲故梵行相成。我之身根乃能如此如自在天。我今神通过踰沙门百千万倍。沙门作一我当作二。即于地中化作一树。以其身根绞绕着树满七匝已。令树云雾如龙王气。高声大唤举手唱言。瞿昙。我梵行相事验如此。汝称男子言大丈夫。以何为证。尔时世尊化作宝枷。宝枷两头有十四珠。一一明珠有千光明。一一光明化成化佛。作十八变住立空中。世尊现化。倒住空中脚在枷上。时佛二足出千莲华。一一莲华万亿光明。一一光中有百亿宝台。一一台中无数化佛。一一化佛各摄一脚。犹如卷琉璃令脚不现。一切化佛及释迦文。悉悬一脚倒住空中。唯诸尼揵见佛倒住。无量天龙八部鬼神。见佛世尊安坐讲堂敷演大法。所谓无相无我等法。时空有声告诸尼揵。佛已作一汝可作二。时诸尼揵即自腾掷。手搏树枝抱树而立。尽尼揵术不能倒立。树神现身手搏其耳。骂言狂人汝如小虫。敢与兽王师子共战。汝向大唤。佛若作一我当作二。佛今已住大神通力汝何不为。树神骂已。地神坚牢即从地出住立空中。以大铁锁锁尼揵脚倒悬空中。有五夜叉以杖挝之。尼揵痛急目掣坠地。未至地顷有一尼揵称南无佛。世尊以手接取尼揵令身不痛。时诸尼揵既至地已。妒心不歇语地神言。汝无慈心偏为瞿昙。汝宿罪故受夜叉身在此地下。今日复更无慈普爱。但为瞿昙困苦我等。时恒河神飞住空中。手执大石告言。尼揵。如汝痴人。服食牛粪石灰涂头。令发褫落裸形无耻。犹如驴马亦如贫龙不能润益。如来佛日普照一切。汝今云何持黑闇身与日争光。尔时水神唱是语已。劝请世尊伏诸尼揵。尔时世尊告诸尼揵。汝等不知如来身分。若欲见者随意观之。如来积劫修行梵行。在家之时无邪欲想。心不染累故得斯报。犹如宝马隐显无常。今当为汝少现身分。尔时世尊从空而下。即于地上化作四水如四大海。四海之中有须弥山。佛在山下正身仰卧放金色光。其光晃耀映诸天目。徐出马藏绕山七匝如金莲华。华华相次上至梵世。从佛身出一亿那由他杂宝莲华。犹如华幢覆蔽马藏。此莲华幢有十亿层。层有百千无量化佛。一一化佛百亿菩萨。无数比丘以为侍者。化佛放光照十方界。尼揵见已大惊心伏。佛梵行相乃至如此不可思议。形不丑恶犹如莲华。我今顶礼佛功德海。佛智无边不可穷尽。受我忏悔摄取我等。作此语已五百尼揵。合掌叉手长跪在地。求佛出家。佛言。善来比丘。佛敕迦叶为办衣服。迦叶尔时至仙人所告大仙人。今日世尊伏诸尼揵。唯愿仙士施少衣裳。时诸仙人取好树皮多罗树叶裁缝为衣。时诸仙人师名曰光目。合掌叉手告诸弟子。佛德无量弘誓周普。乃摄受此着邪见人。我宜办衣给裸形者。亦敬佛宝可脱诸苦。说是语已从迦叶后至世尊所。五百仙人见莲华台从佛身出如众莲华。围绕须弥上至梵世。时诸仙人见此事已。欢喜合掌敬礼世尊。谛观世尊目不暂舍。见佛眉间白毫相光右旋宛转。及见佛身一切众相。作是思惟。此相好者。必从前世无缚无著无我无作无心无识无人无物无施无受清净檀波罗蜜生。亦随一切平等无相大智空慧般若波罗蜜生。思是义已应时即逮无生法忍。五百尼揵着僧伽梨。为佛作礼未举头顷。应时即得阿罗汉道。三明六通具八解脱。一一尼揵誓愿当度。五百尼揵。现此相时。无量诸天龙夜叉众。见佛梵行清净果报。身心欢喜发阿耨多罗三藐三菩提心

佛告阿难。佛灭度后天众龙众夜叉众。沙门众婆罗门众。问佛世尊过去世时清净无欲修诸梵行得何果报。汝当答言。佛有马王藏相。与身平等七合盈满。如金刚器中外俱净。为度众生出现是相。化佛光明妙莲华云其数无量。如此身者。从无数世无染安隐善持戒慧尸波罗蜜生。佛敕阿难。佛灭度后佛诸弟子。欲观如来阴马藏相。当作是观。如是观者是名正观。若异观者名为邪观。佛灭度后佛诸弟子。若有系心正念思惟佛梵行相化佛光明者。常于梦中见十方佛。此人生生恒修梵行。除却二十万劫生死之罪。说是相时。夜叉众中八千夜叉身心欢喜。赞叹如来无量德行。应时即发阿耨多罗三藐三菩提心

佛说观佛三昧海经卷第八佛说观佛三昧海经卷第九

        东晋天竺三藏佛陀跋陀罗译

    本行品第八

佛告阿难。如来有三十二大人相八十种随形好金色光明。一一光明无量化佛。身诸毛孔一切变现。及佛色身略中略者。我今为此时会大众及净饭王。略说相好。佛生人间示同人事。同人相故。说三十二。胜诸天故说八十好。为诸菩萨说八万四千。诸妙相好佛实相好。我初成道摩伽陀国寂灭道场。为普贤贤首等诸大菩萨。于杂华经已广分别。此尊法中所以略说。为诸凡夫及四部弟子。谤方等经作五逆罪。犯四重禁偷僧祇物。淫比丘尼破八戒斋。作诸恶事种种邪见。如是等人。若能至心一日一夜系念在前。观佛如来一相好者。诸恶罪障皆悉灭尽。是故如来名婆伽婆。名阿罗呵。名三藐三佛陀。名功德日。名智满月。名清凉池。名除罪珠。名光明藏。名智慧山。名戒品河。名迷衢导。名邪见灯。名破烦恼贼。名一切众生父母。名大归依处。若有归依佛世尊者。若称名者。除百千劫烦恼重障。何况正心修念佛定

佛告阿难。如来往昔无量无边阿僧祇劫。以智慧火烧烦恼薪。修无相定不非时证。是故获得如是胜相。一一相中无量化佛。何况多相。若能系心观一毛孔。是人名为行念佛定。以念佛故。十方诸佛常立其前。为说正法。此人即为能生三世诸如来种。何况具足念佛色身。如来亦有无量法身。十力无畏三昧解脱诸神通事。如此妙处非汝凡夫所学境界。但当深心起随喜想。起是想已当复系念念佛功德。念佛功德者。所谓戒定智慧解脱解脱知见。金色三十二相。八十随形好。十力四无所畏。十八不共法。大悲三念处是。若有众生一闻佛身如上功德相好光明。亿亿千劫不堕恶道。不生邪见杂秽之处。常得正见勤修不息。但闻佛名获如是福。何况系念观佛三昧。尔时世尊说此语时。于虚空中有七宝台。一一台上有亿宝盖。天雨宝华供养释迦牟尼佛。时文殊师利法王子。结加趺坐坐宝台中。与十亿菩萨住虚空中。赞言。善哉善哉。释迦牟尼大悲世尊。说佛身相示佛威仪。现佛光明显诸化佛。为未来世凡愚众生不见佛者。作见佛因。善哉阿难慈悲法子。汝名欢喜依名定实。善持佛语慎勿忘失。未来众生闻汝说者即是见佛。思此义者具足见佛微妙色身。尔时文殊说此语已。与诸菩萨眷属大众从空而下。敬礼佛足绕佛七匝却住一面

佛告文殊。佛子。汝今在座作此观时。地生莲华纵广正等满一由旬。文殊师利及诸菩萨坐莲华上。尔时文殊师利法王子。既已坐竟白佛言。世尊。我今自欲说于往昔本生因缘。唯愿世尊加我威神

佛告文殊。速说勿疑。文殊师利告诸大众。对尊者阿难。阿难当知。我念过去无量数劫。复倍是数不可思算阿僧祇劫。彼世有佛名宝威德如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。彼佛出时众生弊恶与今无异。彼佛世尊亦长丈六身紫金色。说三乘法如释迦文。尔时彼国有大长者。名一切施。长者有子名曰戒护。在母胎时母信敬故。豫为其子受三归依。子既生已年至八岁。父母请佛于家供养。童子见佛安行徐步足下生华有大光明。见已欢喜为佛作礼。礼已谛观目不暂舍。一见佛已即能除却百万亿那由他劫生死之罪。从是已后。恒得值遇百亿那由他恒河沙佛。于诸佛所殖众德本。是诸世尊皆说如是观佛三昧。亦赞白毫大人相光。劝多众生忏悔系念。过是已后复得值佛。名摩尼光多陀阿伽度阿罗呵三藐三佛陀。摩尼光佛出现世时。常放光明以作佛事度脱人民。如是二万佛皆同一号名摩尼光。时诸世尊皆以化佛微妙光明诱接众生。次复有佛名栴檀摩尼光。十号具足。如是百亿佛皆号摩尼光。是诸世尊誓愿力故。正以眉间白毫相光。覆护众生除灭众罪。复有佛出名栴檀海如来应供正遍知。如是百万佛皆同一字名栴檀海。是诸世尊。以胸德字卍字印光化度众生。时彼童子亲侍诸佛间无空缺。礼拜供养合掌观佛。观佛功德因缘力故。复得值遇百万阿僧祇佛。彼诸世尊亦以身色化度众生从是已后即得百千亿念佛三昧。得百万阿僧祇旋陀罗尼。既得此已诸佛现前说无相法。须臾之间得首楞严三昧。时彼童子受三归依。一礼佛故谛观佛相心无疲厌。由此因缘值无数佛。何况系念具足思惟观佛色身。时彼童子岂异人乎。今我身是

尔时世尊赞文殊师利言。善哉善哉。文殊师利。乃于昔时一礼佛故。得值尔许无数诸佛。何况未来我诸弟子勤观佛者。佛敕阿难。汝持文殊师利语。遍告大众及未来世众生。若能礼拜者。若能念佛者。若能观佛者。当知此人与文殊师利等无有异。舍身他世。文殊师利等诸大菩萨为其和上。说是语时菩萨众中有一佛子。名曰财首。即从座起绕佛七匝恭敬礼拜。亦礼文殊师利足。以天曼陀罗华。摩诃曼陀罗华。曼殊沙华。摩诃曼殊沙华。而散佛上。及散文殊师利上。亦散尊者阿难。是诸天华当于佛上化为华台。于华台内有十方佛结加趺坐

东方善德佛告大众言。汝等当知我念过去无量世时。有佛世尊。名宝威德上王如来应正遍知。彼佛出时亦如今日说三乘法。时彼佛世有一比丘有九弟子。与诸弟子往诣佛塔礼拜佛像。见一宝像严显可观。既敬礼已目谛视之说偈赞叹。随寿修短各自命终。既命终已生于东方宝威德上王佛国土。在大莲华结加趺坐忽然化生。从此已后恒得值遇无量诸佛。于诸佛所净修梵行。得念佛三昧海。既得此已诸佛现前即与授记。于十方面随意作佛。东方善德佛者则我身是。南方栴檀德佛。西方无量明佛。北方相德佛。东南方无忧德佛。西南方宝施佛。西北方华德佛。东北方三乘行佛。上方广众德佛。下方明德佛。如是等十佛世尊。因由礼[土*答]一赞偈故。于十方面得成为佛。岂异人乎。我等十方佛是。时十方佛从空而下放千光明。显现色身白毫相光。各各皆坐释迦佛床。各伸右手摩阿难顶告言。法子。汝师和上释迦牟尼。百千苦行无数精进。求佛智慧报得是身。光明色相今为汝说。汝持佛语为未来世天龙大众比丘比丘尼优婆塞优婆夷。广说观佛法及念佛三昧。说是语已然后问讯释迦文佛起居安隐。既问讯已放大光明各还本国

时会大众见十方佛。及诸菩萨国土大小。如于明镜见众色像。财首菩萨所散之华。当文殊上即变化成四柱宝台。于其台内有四世尊。放身光明俨然而坐。东方阿閦。南方宝相。西方无量寿。北方微妙声。时四世尊以金莲华散释迦佛。未至佛上化为华帐。有万亿叶。一一叶间百千化佛。化佛放光。光中复有无数化佛。宝帐成已四佛世尊从空而下。坐释迦佛床赞言。善哉善哉。释迦牟尼。乃能为于未来之世浊恶众生。说三世佛白毫光相。令诸众生得灭罪咎。所以者何。我念昔曾空王佛所出家学道。时四比丘共为同学。习学三世诸佛正法。烦恼覆心。不能坚持佛法。宝藏多不善业当堕恶道。空中声言。汝四比丘。空王如来虽复涅槃汝之所犯谓无救者。汝等今当入塔观佛。与佛在世等无有异。我从空声入塔观像眉间白毫相。即作是念。如来在世光明色身与此何异。佛大人相愿除我罪。作是语已如大山崩五体投地。忏悔诸罪观佛眉间。忏悔因缘从是已后。八十亿阿僧祇劫不堕恶道。生生常见十方诸佛。于诸佛所受持甚深念佛三昧。得三昧已诸佛现前授我记别。东方有国。国名妙喜。彼土有佛。号曰阿閦。即第一比丘是。南方有国。国名日欢喜。佛号宝相。即第二比丘是。西方有国。国名极乐。佛号无量寿。第三比丘是。北方有国。国名莲华庄严。佛号微妙声。第四比丘是。时四如来。各申右手摩阿难顶告言。法王子。汝持佛语广为未来诸众生说。三说此已各放光明还归本国。财首菩萨所散诸华住阿难上者。化成华云遍满十方。一一云间无数化佛。各申右手摩阿难顶告言。法王子。诸佛如来所有化身。亦如我等等无有异。汝今亲见。当为未来一切众生广分别说。令诸众生修行念佛。若念佛者。得见化佛与今无异。若有众生闻汝所说。则为见佛除无量罪

尔时财首菩萨白佛言。世尊。我念过去无量世时。有佛世尊亦名释迦牟尼。彼佛灭后有一王子名曰金幢。憍慢邪见不信正法。知识比丘名定自在。告王子言。世有佛像众宝严饰极为可爱。可暂入塔观佛形像。时彼王子。随善友语入塔观像。见像相好白言比丘。佛像端严犹尚如此。况佛真身。作是语已比丘告言。汝今见像若不能礼者。当称南无佛。是时王子合掌恭敬称南无佛。还宫系念念塔中像。即于后夜梦见佛像。见佛像故心大欢喜。舍离邪见归依三宝。随寿命终。由前入塔称南无佛因缘功德。恒得值遇九百万亿那由他佛。于诸佛所常勤精进。逮得甚深念佛三昧。三昧力故诸佛现前为其授记。从是以来百万阿僧祇劫不堕恶道。乃至今日获得甚深首楞严三昧。尔时王子今我财首是也。如是等诸大菩萨其数无量。各说本缘依念佛得。如本生经说

尔时世尊告诸大众。我念过去无数劫时。尔时有佛号栴檀窟庄严如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。十号具足。在阎浮提诸德山中。于彼山中出家学道。足满七劫成阿耨多罗三藐三菩提。尔时彼世有二童子。多闻无厌游行国界问诸婆罗门。时有一婆罗门名牢度叉伽。告言。童子。世间有佛名栴檀窟。汝等二人可诣彼所求论义法。时二童子长者名为一切喜见。第二童子名勇猛铠。共诣佛所各持天华共散如来。尔时世尊寂然禅定。入三昧王三昧身心不动。普现一切诸佛色身。光明无数如般若波罗蜜说。时二童子见佛色身及见光明。即时超越那由他恒河沙阿僧祇劫生死之罪。恒得值遇无量无数百千诸佛。于诸佛所修行甚深念佛三昧。现前得见十方诸佛。为其演说不退法轮。尔时第一童子岂异人乎。今弥勒菩萨是。第二童子今我释迦牟尼是。我与贤劫诸菩萨。曾于过去栴檀窟佛所。闻是诸佛色身变化观佛三昧海。以是因缘功德力故。超越九百万亿阿僧祇劫生死之罪。于此贤劫次第成佛。最后楼至如来。亦于此处说观佛三昧

佛告阿难。此观佛三昧。是一切众生犯罪者药。破戒者护。失道者导。盲冥者眼。愚痴者慧。黑闇者灯。烦恼贼中是勇健将。诸佛世尊之所游戏。首楞严等诸大三昧始出生处。佛告阿难。汝今善持慎勿忘失。过去未来三世诸佛。是诸世尊皆说如是念佛三昧。我与贤劫诸大菩萨。因是念佛三昧力故。得一切智威神自在。如是十方无量诸佛。皆由此法成三菩提

尔时尊者阿难。佛神力故。自识宿命无数劫事。白佛言。世尊。我念过去无数亿劫。有佛世尊名日月灯明。十号具足。我于彼世见佛如来放大光明。其光遍照十方世界。皆作金色。一一光中有诸化佛。我见是已身心欢喜称南无佛。从是以来常得值遇百千诸佛闻佛说法。犹如泻水置之异器忆持不忘。是故我今得见世尊亲自供侍。作是语已说诸偈颂。赞叹诸佛微妙色身。尔时空中有无数佛皆现光明。身身毛孔中所出化佛如释迦文。皆告阿难言。法子。汝今持是观佛三昧。广为一切大众分别。令诸凡夫种见佛因。说是语已化佛不现。尔时世尊为嘱累此事故。住立空中威仪自在。作十八变显一切光。告阿难言。若有众生欲观佛者。当如此观。佛说此语时。十二亿天子得念佛三昧。现前受记

    观像品第九

尔时会中有菩萨摩诃萨名曰弥勒。即从座起偏袒右肩顶礼佛足。脱身璎珞奉上如来。以真珠华散佛世尊及文殊师利。所散璎珞自然踊住于虚空中。化成八万亿宝台。一一台中有百亿释迦文佛。皆放光明普现色身。山林河海一切众生所有妙色。星宿日月诸须弥山。诸天龙神及诸宫殿亦于中现。五通神仙百亿咒术。九十五种诸邪见道。医方技艺工巧文咏。皆于一毛显现此事。世间邪见秽欲众生所希见者。亦于光明悉自踊出。地狱畜生诸阿修罗。八难四倒诸不祥事。受报好丑亦于此相自得觉知。所散珠华住佛上者。化作百亿白色光明。住文殊上者。化作百千亿微妙色光。此诸光明互相交络。如大龙王蟠身相向。一一光中五亿宝光。如僧伽梨割截分明。以金色光缝持令住。缕出入处生四宝华。一一华中贤劫菩萨结加趺坐。十方诸佛及诸化佛坐宝莲华。为此贤劫诸大菩萨说般舟甚深三昧。亦赞观佛最初因缘惟无三昧念佛境界金刚譬定。说是法已是诸如来各申右手摩阿难顶告言。法子。汝今应当善持佛语慎勿忘失。尔时弥勒菩萨白佛言。世尊。惟愿天尊大慈大悲。怜愍一切未来世中。多有众生造不善业。佛不现在何所依怙可除罪咎。佛告弥勒。阿逸多。谛听谛听善思念之。如来灭后多有众生。以不见佛作诸恶法。如是等人当令观像。若观像者。与观我身等无有异。说是语时空中有华。十方诸佛住立空中。叉手合掌赞言。善哉佛子善问此事。惟释迦文救世苦者。为诸末后盲冥众生说观像法。今正是时慎勿疑虑。弥勒菩萨重更殷勤劝请世尊说观像法

尔时世尊放常光明照尼拘楼陀精舍及十方国。皆作金色。佛神力故令金色地分为二分。一一分中五百亿佛。从下方界皆自踊出住立空中。合掌赞叹弥勒菩萨摩诃萨言。善哉佛子。乃能怜愍未来众生生末法者。劝请世尊说观像相。时诸化佛说此语已。踊身虚空作十八变。释迦文佛即自微笑。笑时口中生大莲华。其华有光如合百亿日月星宿。众宿月间百亿化佛。结加趺坐坐师子床

尔时释迦文佛告弥勒菩萨言。谛听谛听善思念之。如来今者为未来世五苦众生。犯禁比丘不善恶人。五逆诽谤。行十六种恶律仪者。为如是等说除罪法。尔时阿难白佛。世尊。佛涅槃后此等愚人。无依无怙无归依处。云何如来说除罪法

佛告阿难。汝于佛法心未具解。如我在世归依我者。名归依佛名归依法名归依僧。佛灭度后浊恶世中。诸众生等欲除罪咎。欲于现世得须陀洹至阿罗汉。欲发三菩提心。欲解十二因缘。当勤修习观佛三昧。阿难白佛言。世尊。如来在世众生现见。观佛相好。观佛光明。尚不了了。况佛灭后佛不现在。当云何观

佛告阿难。佛灭度后现前无佛当观佛像。观佛像者。若比丘比丘尼优婆塞优婆夷天龙八部一切众生欲观像者。先入佛塔以好香泥及诸瓦土涂地令净。随其力能烧香散华供养佛像。说已过恶礼佛忏悔。如是伏心经一七日。复至众中涂扫僧地除诸粪秽。向僧忏悔礼众僧足。复经七日。如是供养心不疲厌。若出家人应诵毗尼极令通利。若在家人孝养父母恭敬师长。调心令软。心若不软。当强折伏令心调顺。如调象马不令失御。心柔顺已住于靖处烧众名香。礼释迦文而作是言。南无大德我大和上应正遍知大悲世尊。愿以慈云覆护弟子。作是语已五体投地泣泪像前。从地而起齐整衣服结加趺坐。系念一处随前众生。系心鼻端。系心额上。系心足指。如是种种随意系念专置一处。勿令驰散使心动摇。心若动摇举舌拄齶。闭口闭目叉手端坐。一日至七日令身安隐。身安隐已然后想像

乐逆观者。从像足指次第仰观。初观足指系心令专。缘佛足指经一七日。闭目开目令了了见金像足指。渐次复观两足趺上令了了见。次观鹿王[跳-兆+專]。心既专已次第至髻。从髻观面若不明了。复更忏悔倍自苦策。以戒净故见佛像面。如真金镜了了分明。作是观已观眉间毫。如颇梨珠右旋宛转。此相现时见佛眉眼。如天画师之所画作。见是事已次观顶光令分明了。如是众相名为逆观

顺观像者。从顶上诸蠡文间。一一蠡文系心谛观。令心了了见佛蠡文。犹如黑丝右旋宛转。次观佛面观佛面已。具足观身渐下至足。如是往返凡十四遍。谛观一像极令了了。观一成已出定入定。恒见立像在行者前。见一了了复想二像。见二像已次想三像。乃至想十皆令了了。见十像已想一室内满中佛像间无空缺。满一室已复更精进烧香散华。扫塔涂地澡浴众僧。为父母师长案摩调身。洗浴身体上涂足油。四方乞食得好美者。先上师长分奉父母。作是行已发大誓愿。我今观佛。以此功德不愿人天声闻缘觉。正欲专求佛菩提道。发是愿已若实至心求大乘者。当行忏悔。行忏悔已次行请佛。行请佛已次行随喜。行随喜已次行回向。行回向已次行发愿。行发愿已正身端坐系念在前。观佛境界令渐广大。一僧坊中满中佛像。方身丈六足下莲华圆光一寻。及通身光摩尼焰相。及众化佛化佛侍者。光明众色皆令了了一僧坊已。令心复广一顷地中满中佛像。此想成已心得安隐身体悦乐。若行若止心想利故。见一顷地满中佛像。香华供具及诸幢幡。皆随像行。以心利故。左右前后尽见像行。心渐广大见百顷地满中佛像。开目闭目皆令心想。想想不绝心心相续。如渴思饮。此想成已见一由旬满中佛像。渐增广远满百由旬。见一切像三十二相八十随形好皆悉炳然。此想成已想一阎浮提八千由旬满中佛像。此想成已次想东方弗婆提界八千六十由旬满中佛像。此想成已复想西方瞿耶尼界广八千九百由旬满中佛像。此想成已复观北方郁单越界一万六千由旬满中佛像。此想成已复更广远见百阎浮提满中佛像。此想成已见百亿四天下满中佛像。此想成已唯除食时除便转时。一切时中恒见佛像。虚空及地满中佛像。像像相次间无空缺。念想成已身心欢喜。倍加精进。顶戴恭敬十二部经。于说法者起大师想。于佛法僧起父母想。令心调柔不起嗔想。设嗔恚时当于般若波罗蜜前五体投地诚心忏悔。如上所说五法次第应行。念想成已闭目叉手端坐正受。更作远想。满十方界见一切像。身纯金色放大光明。若有犯戒作不善者。先身犯戒及以今身。见诸佛像或黑或白。以忏悔故渐见红色。见红色已渐见金色。见金色已身心欢喜。劝请诸像使放光明。起此想时念想利故见一切像。举身毛孔皆放光明。一一光明百亿宝色。一一色中无量杂色。微妙境界悉自踊出。此念想成名观立像

佛告阿难。如是观者名为正观。若异观者名为邪观。余相现者别境界出。当疾除之。作是观者。除却六十亿劫生死之罪。亦名见佛。于未来世心想利故值遇贤劫千佛世尊。为其和上。于佛法中次第出家。一一佛所见佛身相了了分明。闻佛说法忆持不忘。于星宿劫光明佛所现前受记。粗心观像尚得如是无量功德。况复系念观佛眉间白毫相光。说是语时大梵天王无量梵众。持诸天华奉散世尊。脱身璎珞以奉上佛。其华如云在空中住。所上璎珞变成金台。于金台中有金色光。其光变为七佛尊像。端严微妙色相悉具。蠡髻梵王长跪合掌。劝请世尊而作是言。如来大悲慈愍众生。愿为来世盲冥众生。具足演说观像相法。令诸众生依佛所说恒得值遇诸佛世尊得念佛三昧。三昧力故令诸众生远离罪恶。以罪灭故现见诸佛。佛告梵王如是如是如汝所说

尔时世尊复为来世诸众生故。更说观像坐法。观像坐者。至心系念令前立像足下生华。此华生时当起想念。令此大地作黄金色作七宝色。随想而现。一一宝色黄金为界。一一界间生宝莲华。作此想时有宝莲华千叶具足。应想而现。既见花已请诸想像令坐宝华。众像坐时大地自然出大白光。如琉璃色白净可爱。众白光间百亿菩萨白如雪山。从想像身毛孔中出。一一菩萨身毛孔中。出金色光其光如山。百千金色阎浮檀金。光明赫奕数不可知。应想而现。一一山顶有一想像高显可观。阎浮檀金色其光大盛。照十方界皆作金色。见地及空亦作金色。满中金像金光金盖金台金华金幡。见想菩萨纯白玉色。手执白拂有执白华。当起想念极令鲜白。若余杂想异境界现当疾除灭。若不除灭随逐余想。随他境界喜发风病。此念佛想。是大甘露利益众生。观佛三昧。如服良药利益四大。服此药者不老不死

佛告阿难。若有众生欲观像坐。当如是观。作是观者名为正观。若他观者名为邪观。若有众生观像坐者。除五百亿劫生死之罪。未来值遇贤劫千佛。过贤劫已星宿劫中。值遇诸佛数满十万。一一佛所受持佛语。身心安隐终不谬乱。一一世尊现前授记。过算数劫得成为佛

尔时世尊告阿难言。若有众生观像坐已当观像行。观像行者。见十方界满中像行。虚空及地见一一像从座而起。一一像起时五百亿宝华。一一华中有无数光。一一光中无数化佛随心想现。坐像起立未起中间。当动身时眉间白毫旋舒长短。犹如真佛放白光明。为百千色映饰金光。众白光间无数银像身白银色银光。银华银盖银幡银台。悉皆是银。时众金像与银像俱动身欲起。诸像脐中各生莲华。其莲华中踊出无数百千化佛。一一化佛放金色光照行者身。是时行者。入定之时自见己身三十六物恶露不净。不净现时当疾除灭。而作是念。三世诸佛身心清净。我今学佛真净法身。此不净观从贪爱生。虚伪不实用此观为。作是念已当自观身。使诸不净变为白玉。自见己身如白玉瓶内外俱空。作是观时。宜服酥药勿使身虚。此想成时。诸像皆起如前立住。见像立时当作想念请像令行。像既行已步步之中。足下生华成莲华台。见十方界满中行像供具妓乐。诸天大众恭敬围绕。行像放光照诸大众令作金色。银像放光照诸大众皆作银色。白玉菩萨放白玉光。令诸大众作白玉色。杂色诸像放杂色光映饰其间。此想成已更起想念请诸行像。皆令以手悉摩我头。尔时诸像各申右手摩行者头。是时众像放大光明照行者身。光照身时。行者自见身黄金色。此想成已出定欢喜。复更至心礼敬诸佛修诸功德。以是功德回向菩提

尔时复当更起想念。我今想见众多金像。行坐随意未见神通。起心作想请诸行像。及菩萨像作十八变。应念即作十八种变。见满十方一切众像。踊身空中作十八变威神自在。普现色身令行者见。见已欢喜请一切像令转法轮。应念即时一一众像异口同音。赞叹持戒赞叹念佛。想闻此已心大欢喜复加精进。以精进故心想得成。心想成时见十方界。一切大地山河石壁皆悉变化为金刚地。金刚地上踊出白光。众白光间无数化佛坐宝莲华。一一化佛放无数亿百千光明。一一光明复化无数百千化佛。此想现时行者自见身诸毛孔出金色光遍照一切。若余境起当疾除灭。如此心想疾于猛风。须臾之顷见无数化佛。行者心利如明眼人执颇梨镜自观面像。行者观像亦复如是。此想成已当作是念。诸佛世尊住大寂灭。身心清净无来无去。如我身者。四大五阴所共合成。如芭蕉树中无坚实。如水上沫。如水中月。如镜中像。如热时焰如野马行。如乾闼婆城。作是想已诸像寻灭有金色光。于金光间有金佛影。如镜中像。行住坐卧四威仪中现一切色。此想成时当念如来戒身。念戒身时见诸佛影。眉间光明犹如白丝。空中清净至行者前。行者见已当作是念。释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。过去世时以大戒身而自庄严。是故今日得戒定慧解脱解脱知见。作此念时释迦文佛坐琉璃窟。身紫金色端严微妙。与诸比丘菩萨大众以为眷属。住行者前告言。法子。汝修观佛三昧力故。我以涅槃相力示汝色身令汝谛观。汝今坐禅不得多观。汝后世人多作诸恶。但观眉间白毫相光。作此观时所见境界如上所说。尔时一念情无所著心大欢喜。应时即得念佛三昧。念佛三昧者。见佛色身了了分明。亦见佛心一切境界。亦如上来观佛心说。亦见佛身一切光明。亦如上观佛身光说。亦见佛身一切毛孔。一一毛孔悉生八万四千莲华。一一华中复有八万四千化佛。佛佛相次满十方界

尔时释迦牟尼佛即申右手摩行者顶。一切化佛亦申右手摩行者顶。得此观者。名佛现前三昧。亦名念佛三昧。亦名观佛色身三昧。尔时诸佛异口同音。各各皆为行者说法。虽未得道。见佛闻法总持不失。此名凡夫念佛三昧。得此三昧者。刹那刹那顷恒见诸佛。于念念顷闻佛说法。所谓大乘方等经典。一日一夜即得通利。父母生身恼浊恶世。以念佛故得闻总持。舍身他世必得见佛。于诸佛所得千万亿旋陀罗尼。得陀罗尼已八十亿佛各申右手摩行者顶。一一诸佛皆说决言。汝念佛故过星宿劫得成为佛。身相光明与我无异。说是语已八十亿佛一时放光。光中复有无量化佛。一一化佛皆说是语

佛告阿难。如是众法名观像法。若观像时。自当更有无量百千诸胜境界。如是观者名为正观。若异观者名为邪观

佛说观佛三昧海经卷第九佛说观佛三昧海经卷第十

        东晋天竺三藏佛陀跋陀罗译

    念七佛品第十

佛告阿难。若有众生观像心成。次当复观过去七佛像。观七佛者当勤精进。昼夜六时勤行六法。端坐正受当乐少语。除读诵经广演法教。终不宣说无义之语。常念诸佛心心相续。乃至无有一念之间不见佛时。心专精故不离佛日。过去久远有佛世尊名毗婆尸佛。身高显长六十由旬。其佛圆光百二十由旬。身紫金色八万四千相。一一相中八万四千好。一一好中无数金光。一一光中有恒沙化佛。一一化佛有恒沙色光。一一光中无数诸天声闻比丘菩萨大众。以为侍者。人人各持一大宝华。华上皆有百千亿宝摩尼网艳。网艳相次高百千丈以为佛光。是时佛身益更明显。如百千日照紫金山。光明艳起化佛无数。一一化佛犹如百亿日月俱出。令行者见。毗婆尸佛偏袒右肩。出金色臂摩行者顶告言。法子。汝行观佛三昧。得念佛心故我来证汝。汝今可观我真色身。从一一相次第观之。汝当至心立金刚誓。我等先昔行佛道时与汝无异

尔时毗婆尸佛慰行人已。即时化作大宝莲华如须弥山。佛在华上结加趺坐为于行者说念佛念法。及说百亿旋陀罗尼。行者见已倍加欢喜敬礼彼佛。彼佛告曰。若有众生闻我名者礼拜我者。除却五百亿劫生死之罪。汝今见我消除诸障。得无量亿旋陀罗尼。于未来世当得作佛

佛告阿难。尔时行者见毗婆尸心欢喜故。我与六佛现其人前。上座毗婆尸。为此法子说念佛三昧。尸弃世尊身长四十二由旬。身紫金色。圆光四十五由旬。通身光明一百由旬。其光网中无数化佛。及诸菩萨声闻大众。诸天眷属以为围绕。随从佛后右旋宛转。是时行者见尸弃佛。复更增益无量百千陀罗尼门。复更增广得见百千无数化佛。于未来世过算数劫。于其中间恒得值遇诸佛世尊生菩萨家。说是语时复有无数百千天子。闻是事已见佛色身端严微妙。同时皆发三菩提心

毗舍世尊举身放光住行者前。其佛身长三十二由旬。圆光四十二由旬。通身光六十二由旬。身紫金色光明威相如前无异。见此佛已复更增进诸陀罗尼三昧门。于未来世必定不疑生诸佛家

拘留孙佛亦放光明住行者前。其佛身长二十五由旬。圆光三十二由旬。通身光五十由旬。相好具足如紫金山。见此佛者。常生净国不处胞胎。临命终时。诸佛世尊必来迎接

拘那含牟尼佛放大光明住行者前。其佛身长二十由旬。圆光三十由旬。举身光长四十由旬。光相具足。见此佛者。即得百亿诸三昧门无数陀罗尼。若出定时。常得诸佛现前三昧。如此三昧证明行者。所以名诸佛现前三昧者。得此三昧。出定入定行住坐卧。恒得睹见一切诸佛。以妙色身现其人前

迦叶世尊放大光明住其人前。佛长十六丈。身紫金色相好具足。见此佛者得寂灭光无言相三昧。于未来世恒住大空三昧海中

释迦牟尼佛身长丈六。放紫金光住行者前。弥勒世尊身长十六丈。如是诸佛各入普现色身三昧。现其人前令其行者心得欢喜。以欢喜故是诸化佛各申右手摩行者顶。见七佛已见于弥勒。见弥勒已贤劫菩萨一一次第逮及楼至。各放光明住行者前。时千菩萨各各赞叹念佛三昧。及为行者说诸菩萨性。说诸菩萨解脱。说诸菩萨慧。是名因观像心得念佛三昧。佛告阿难。佛灭度后佛诸弟子。如是观者是名正观。若异观者名为邪观。修此三昧者。虽具烦恼不为烦恼之所使也。以是念佛三昧力故。十方诸佛放大光明现其人前。光明无比三界特尊。佛说是语已。时梵天王复更劝请。愿佛世尊。说十方佛住行者前光明色相

    念十方佛品第十一

佛告阿难。云何行者观十方佛。观十方佛者。东方为始。东方有世界。国名宝安隐。无量亿宝有亿千色以用合成。佛号善德。亦放无数光普照百千国。亦与无数亿分身诸化佛住于行者前。身色如金山端严甚无比。坐大金刚窟。无数杂宝光庄严为堂阁。一一堂阁前无量微尘数百亿诸宝树。一一宝树下八万四千师子座。一一师子座有一分身佛。结加趺坐三昧坐于宝树下。善德佛世尊。身长二百五十亿那由他由旬。一一身毛孔无数亿微尘一切胜相好。一一相好中有无数化佛。一一化佛高显巍巍如须弥山。放大光明坐宝莲华住虚空中。分身诸佛各各开现微妙光明。显出无数百千化佛。一一化佛坐宝莲华。一一莲华有千幢幡。一一幢幡演出百亿微妙音声。是诸声中教观十方无数佛身。此相现时。见十方界犹如金刚。百亿宝色不灭不坏。见此相已于诸佛前受法王子位。如是境界名性地菩萨

南方栴檀德佛身相高显。其佛国土琉璃为地恒沙宝色。于佛光中亦有无数百千堂阁。宝树行列敷师子座。座上诸佛结加趺坐。宝幢幡盖说法音声。如佛海三昧说。西方无量明佛。国土清净黄金为地。五百亿宝色佛身光明。重阁讲堂宝树行列宝师子座。分身诸佛结加趺坐坐宝树下。宝幢幡中亦说念佛海。北方相德佛。其地颇梨色。有五百亿宝光。宝树行列。宝师子座重阁讲堂幢幡光明。与向无异

东南方无忧德佛。其地七宝色。一一色上有七百亿杂色。宝树行列重阁光明百亿万种。一一光明。说佛功德海。如佛海说

西南方宝施佛。其地五宝色。一一宝上五百亿光明。一一光明化为五百亿莲华云。一一莲华云上有百亿重阁。一一重阁如百千万亿梵王宫。一一梵王宫中无数床座。光明莲华所共合成。是诸座上有诸分身佛结加趺坐。演说诸佛大慈悲法。光明幢幡亦说佛海

西北方华德佛。其佛国土琉璃颇梨色。一一色上有无数百千光。一一光化为五百亿宝窟。一一窟中无数宝盖。一一盖中百亿光明。一一光中无数分身佛。结加趺坐放大光明。其光明中说念佛三昧。因念佛三昧中。复更得见无数诸佛

东北方三乘行佛。其佛国土纯白银色百亿万光。光有千色。庄严国界极令清净。分身化佛宝树幢幡。行列庄严数不可知

上方广众德佛。其地五百亿宝色。一一宝色无数光明。一一光明化为无数百亿化佛。一一佛光中无量宝树行列庄严。一一树下百亿宝师子座。诸佛在上结加趺坐。无数菩萨以为侍者。一切大众皆悉住佛光明云中。下方明德佛。其地金色金光金云。于光云中无数金堂七宝楼阁。百宝行树罗列庄严。宝幢幡盖数亿千万。一一树下百亿宝座诸堂楼阁。无数坐具状如宝华。无数分身一切诸佛。坐宝树下琉璃座上。众华色间无数佛会。是诸世尊皆悉讲说菩萨行法。如是十方无数化佛。一一化佛显现光明。时十方佛。各各悉坐金刚窟中。身量光明如善德佛及诸化佛。威神国土令行者见。如于明镜自见面像。了了分明见十方佛。心欢喜故不染诸法住于初心。时十方佛广为行者。各说相似六波罗蜜。闻是法已于初地下十心境界无有疑虑。见此事者。必闻诸佛说般若波罗蜜。闻第一义空心不惊疑。于诸法中得入空三昧。是名相似空相三昧

佛告阿难。佛灭度后佛诸弟子。欲观十方佛者。于念佛三昧中但知粗相。当自然知无量妙相。如是观者是名正观。若异观者名为邪观。得此观者见佛无数不可限量。入此定者名见一切诸佛色身。亦得渐渐入三空门。游此空者诸佛力故心不着空。于未来世当成阿耨多罗三藐三菩提得不退转。是名不忘菩提之心正顺佛道。说观十方佛时。十方佛坐金刚山百宝窟中。各申右手摩阿难顶告言。法子。汝持佛语。为未来世诸众生等。当广宣说慎勿妄传。当为坚发三菩提心行念佛定正受者说

佛告阿难。此念佛三昧若成就者。有五因缘。何等为五。一者持戒不犯。二者不起邪见。三者不生憍慢。四者不恚不嫉。五者勇猛精进如救头然。行此五事。正念诸佛微妙色身令心不退。亦当读诵大乘经典。以此功德念佛力故。疾疾得见无量诸佛。见诸佛者。独一心净不与他共。应当供养十方诸佛。云何供养。是人出定入塔见像念持经时。若礼一佛当作是念。正遍知诸佛心智无有限碍。我今礼一佛即礼一切佛。若思惟一佛即见一切佛。见一一佛前有一行者。接足为礼皆是己身。若以一华供养佛时。当作是念。诸佛法身功德无量。不住不坏湛然常安。我今以华奉献诸佛愿佛受之。作是念已复当起想。我所执华从草木生。持此供养可用拟想。即当作想身诸毛孔。令一毛孔出无数华云。以此华云运想拟意供一切佛。一一佛上化成华台诸佛受之。于十方界施作佛事。供养香时亦复如是。香烟香云于十方界施作佛事。作佛事已还成金台在行者前。若凡夫人欲供养者。手擎香炉执华供养。亦当起意作华香想。当发是愿。愿此华香满十方界。供养一切佛化佛并菩萨无数声闻众。受此香华云以为光明台。广于无边界无边作佛事。礼佛若坐禅起是供养心。常当发是愿。缯盖幢幡音乐偈颂。当作是愿。我今设此少分供具。愿此供具遍供十方一切诸佛。诸佛受之。于幢幡中化光明云。于妓乐中偈颂之中演妙法音。作是愿已坐时应想。令身毛孔一一孔中。作无量幢幡想。一一幢幡中。作无量偈颂云想。作是想时心如香炉。流出金色香烟香云。身毛孔中如好华树。踊出阿僧祇无量杂华云。是诸华云。于十方界诸佛之上。化为一切诸供养具。尔时当于身心分中。起一切供养具想。若得食饮。若施人一钱。当起空无我想檀波罗蜜。如是等无量供养。皆当起心从心想出。供养十方一切诸佛。是名坐时无量功德从心想海生。如是坐时。入深禅定无量境界诸三昧海。但于心中。出息入息念念想想相续不绝。于一心中运其心意。作无数供具云。上供诸佛下施一切。作是念者名学普施。此想成时。渐渐减消诸烦恼结。观法无相无相力故。当得甚深六波罗蜜

    观佛密行品第十二

佛告阿难。未来众生其有得是念佛三昧者。观诸佛相好者。得诸佛现前三昧者。当教是人密身口意。莫起邪命莫生贡高。若起邪命及贡高法。当知此人是增上慢破灭佛法。多使众生起不善心。乱和合僧显异惑众。是恶魔伴如是恶人。虽复念佛失甘露味。此人生处。以贡高故身恒卑小。生下贱家贫穷诸衰。无量恶业以为严饰。如此种种众多恶事。当自防护令永不生。若起如是邪命业者。此邪命业。犹如狂象坏莲华池。此邪命业亦复如是。坏败善根

佛告阿难。有念佛者。当自防护勿令放逸。念佛三昧人。若不防护生贡高者。邪命恶风吹憍慢火烧灭善法。善法者。所谓一切无量禅定。诸念佛法从诸心想生。是名功德藏

佛告阿难。譬如长者多财饶宝。唯有一子。长者自知将死不久。以诸库藏委付其子。其子得已随意游戏。忽于一时值有王难。无量众贼从四面来。竞取藏物不能遮护。惟有一金乃是阎浮檀那紫金。重十六两。金挺长短亦十六寸。此金一两价直余宝百千万两。为贼所逼无奈金何。即以秽物缠裹真金。置泥团中。众贼见已不识是金脚践而去。贼去之后财主得金心大欢喜。念佛三昧亦复如是。当密藏之

复次阿难。譬如有人贫穷薄福。依诸豪贤以存性命。时有王子。遇行出游执大宝瓶。于宝瓶内藏王印绶。是时贫者诈来亲附。得王宝瓶擎持逃走。王子觉已。遗六大兵乘六黑象。手执利剑疾往追之。时持瓶人。走入深草空野泽中。见旷野泽满中。毒蛇。四面吐毒吸持瓶者。时贫穷人慞惶惊怖。驰走东西蛇亦随之无藏避处。于空泽中见一大树。蓊蔚扶疏甚适其意。头戴宝瓶攀树而上。既上树已六兵乘象。駃疾如风寻复来至。贫人见已吞王宝印。持瓶冠头以手覆面。坐贪惜故不忍见之。时六黑象以鼻绞树令树倒躄。贫人落地身体散坏。唯金印在宝瓶现光。诸蛇见光四散驰走。佛告阿难。住念佛者心印不坏亦复如是

复次阿难。譬如长者多饶财宝。无诸子息唯有一女。是时长者年过百岁。自知朽迈将死不久。我此财宝无男儿故财应属王。作是思惟唤其女子。密告之言。今有妙宝宝中上者当用遗汝。汝得此宝密藏令坚莫令王知。女受父敕。持摩尼珠及诸珍宝藏之粪秽。室家大小皆亦不知。值世饥馑女夫告妻。我家贫穷困于衣食。汝可他行求自活处。妻白夫言。我父长者临命终时。以宝赐我今在某处君可取之。时夫掘取大获珍宝并如意珠。持如意珠。烧香礼拜先发愿言。为我雨食。随语即雨百味饮食。如是种种随意得宝。时夫得已告其妻言。卿如天女能赐我宝。汝藏此宝我尚不知。况复他人。佛告阿难。念佛三昧坚心不动。亦复如是

复次阿难。譬如有王暴虐违道。民罹其毒人怨神怒。国大亢旱求请神祇不能得雨。有臣白言。大王当知。今此境内林薮之中。有一仙士五通无碍。王可祈请令其咒龙。大王闻已欣踊无量。遣人诣林祈请仙人。神仙飞往大王殿前。高声唱言。大王无道。诸天龙神皆四散去不护王国。云何使我令请雨也。王闻此语极怀惭愧。改悔先行所作恶事。仙人知王心已软善。应念诵咒。神通力故天降甘露地出涌泉润泽一切。佛告阿难。欲念佛者如王弃恶。得念佛者如善咒人

复次阿难。譬如力士自恃大力数犯王法。王遣五人收捕力士幽闭囹圄。五处枷锁极令牢固。奋力大怒举体血现。枷锁摧折踰墙逃逝到海岸边。解髻明珠持雇船师。船师语言。如此白石海中无数我用是为。力士长跪白船师言。我此明珠有六种色。即以黄缯裹珠置之水中水即金色。复还收珠以白缯裹置之水中水即变白。收取复以绿缯裹置之水中。水色变作绿琉璃色。收取以碧缯裹置之水中。水即变作真金精色。收取复以绛缯裹置之水中。水即变作车磲色。收取复以紫缯裹置之水中。水即变成天金刚色。水上复有紫摩尼光。船师见已。即取宝珠以大宝舆。舆勇猛士置大船上。望风举帆疾如射箭。到于彼岸到彼岸已。心意泰然安隐无惧。大取珍宝报船师恩。佛告阿难。行念佛者如大力士。[打-丁+勉]心王枷锁到慧彼岸。复次阿难。譬如劫欲尽时。二日并出山林树木河池枯涸。三日出时众色火起。四日出时大海消减三分留一。五日出时大海竭尽。六日出时须弥崩倒。七日出时大地烔然乃至色界。唯金刚山不可摧破还住本际。念佛三昧亦复如是。行是定者。住过去佛实际海中

佛告阿难。吾今欲与十方诸佛报念佛三昧恩。尔时世尊说是语已。及十方诸佛贤劫菩萨。入一切色身光明三昧。时诸佛身一一毛孔。踊出众多不可称数妙化佛云。是诸化佛结加趺坐住立空中。如是无数一切化佛。各申右手摩阿难顶。及敕释提桓因。汝等二人持是妙法慎莫忘失。为未来世浊恶众生。灭众罪障故。如来正遍知今于大众中说一切佛身相。尔时尊者阿难即从座起。顶礼佛足白佛言。世尊。当何名此经。此法之要当云何持

佛告阿难。此经名系想不动。如是受持。亦名观佛白毫相。如是受持。亦名逆顺观如来身分。亦名一一毛孔分别如来身分。亦名观三十二相八十随形好诸智慧光明。亦名观佛三昧海。亦名念佛三昧门。亦名诸佛妙华庄严色身。亦名说戒定慧解脱解脱知见十力四无所畏十八不共法果报所得微妙色身经。汝好受持慎勿忘失。佛说是语时。比丘比丘尼优婆塞优婆夷。及菩萨大众。天龙八部一切鬼神。闻佛说是微妙身相。有得须陀洹斯陀含阿那含。有得阿罗汉者。有种辟支佛道因缘者。有发阿耨多罗三藐三菩提心者。有得无生法忍者。数甚众多不可称说。时诸大众闻佛说法恭敬顶礼。奉行佛语作礼求退。是时阿难即从座起。合掌长跪白言世尊。如来今者一切身相皆已说竟。唯不显说无见顶相。唯愿天尊。少说顶相光明瑞应。令未来世凡愚众生知佛胜相。尔时世尊即入顶三昧海。令佛顶上肉髻之中一一毛孔踊出琉璃光。其光如水蠡文右旋。遍满十方无数世界。如百亿世界微尘数海。如是八万四千诸毛发中。皆出是水相。一一水相复过是百千万倍数不可知。是诸琉璃水上。生众多天宝莲华。华有无数百千亿叶。叶作无数百千亿宝色。叶极小者遍覆三千大千世界。如是华上一一须间。有无量阿僧祇百千万亿恒河沙化佛。一一化佛顶肉髻相。流出众光亦复如是。时诸佛身量同虚空不可得知。如是诸佛。佛佛相次尽世界海际。此相现时。于十方面。各有百亿微尘数菩萨。身升虚空现大神变。至释迦牟尼佛所。时诸菩萨以佛神力故。暂见一毛孔中少分瑞相。应时即得无量百千金刚相陀罗尼。佛现是相时。贤劫千菩萨及十方诸佛皆现此相。时会大众见此少分相者。须陀洹人如刹那顷成阿罗汉。观因缘者不缘诸缘成阿罗汉。发心菩萨超越境界。增进甚深三昧海门。住于性地。无生菩萨倍加增进无量胜法。住首楞严三昧

佛告阿难。佛灭度后浊恶世中。若有众生闻佛胜相。心不惊疑不生怖畏。当知是人能灭一切烦恼业障。闻佛胜相生随喜者。除却千亿劫极重恶业。后世生处。不落三涂不生八难处。佛说是语时。长老憍陈如等诸大比丘。弥勒等诸大菩萨。无量大众闻佛所说。皆大欢喜顶戴奉行

佛说观佛三昧海经卷第十


佛说观弥勒菩萨上生兜率天经

    No. 452

佛说观弥勒菩萨上生兜率天经

        宋居士沮渠京声译

如是我闻。一时佛在舍卫国祇树给孤独园。尔时世尊于初夜分举身放光。其光金色。绕只陀园周遍七匝。照须达舍亦作金色。有金色光犹如段云。遍舍卫国处处皆雨金色莲花。其光明中。有无量百千诸大化佛。皆唱是言。今于此中有千菩萨。最初成佛名拘留孙。最后成佛名曰楼至。说是语已。尊者阿若憍陈如即从禅起。与其眷属二百五十人俱。尊者摩诃迦叶。与其眷属二百五十人俱。尊者大目犍连。与其眷属二百五十人俱。尊者舍利弗。与其眷属二百五十人俱。摩诃波阇波提比丘尼。与其眷属千比丘尼俱。须达长者与三千优婆塞俱。毗舍佉母与二千优婆夷俱。复有菩萨摩诃萨。名跋陀婆罗。与其眷属十六菩萨俱。文殊师利法王子。与其眷属五百菩萨俱。天龙夜叉乾闼婆等一切大众。睹佛光明皆悉云集。尔时世尊出广长舌相放千光明。一一光明各有千色。一一色中有无量化佛。是诸化佛异口同音。皆说清净诸大菩萨甚深不可思议诸陀罗尼法。所谓阿难陀目佉陀罗尼．空慧陀罗尼．无碍性陀罗尼．大解脱无相陀罗尼。尔时世尊以一音声。说百亿陀罗尼门。说此陀罗尼已。尔时会中有一菩萨名曰弥勒。闻佛所说。应时即得百万亿陀罗尼门。即从座起整衣服。叉手合掌住立佛前

尔时优波离亦从座起。头面作礼而白佛言。世尊。世尊往昔于毗尼中及诸经藏说阿逸多次当作佛。此阿逸多具凡夫身未断诸漏。此人命终当生何处。其人今者虽复出家。不修禅定不断烦恼。佛记此人成佛无疑。此人命终生何国土。佛告优波离。谛听谛听善思念之。如来应正遍知。今于此众说弥勒菩萨摩诃萨阿耨多罗三藐三菩提记。此人从今十二年后命终。必得往生兜率陀天上。尔时兜率陀天上。有五百万亿天子。一一天子皆修甚深檀波罗蜜。为供养一生补处菩萨故。以天福力造作宫殿。各各脱身栴檀摩尼宝冠。长跪合掌发是愿言。我今持此无价宝珠及以天冠。为供养大心众生故。此人来世不久当成阿耨多罗三藐三菩提。我于彼佛庄严国界得受记者。令我宝冠化成供具。如是诸天子等各各长跪。发弘誓愿亦复如是。时诸天子作是愿已。是诸宝冠化作五百万亿宝宫。一一宝宫有七重垣。一一垣七宝所成。一一宝出五百亿光明。一一光明中有五百亿莲华。一一莲华化作五百亿七宝行树。一一树叶有五百亿宝色。一一宝色有五百亿阎浮檀金光。一一阎浮檀金光中。出五百亿诸天宝女。一一宝女住立树下。执百亿宝无数璎珞。出妙音乐。时乐音中演说不退转地法轮之行。其树生果如颇黎色。一切众色入颇梨色中。是诸光明右旋婉转流出众音。众音演说大慈大悲法。一一垣墙高六十二由旬厚十四由旬。五百亿龙王围绕此垣。一一龙王雨五百亿七宝行树。庄严垣上。自然有风吹动此树。树相振触。演说苦空无常无我诸波罗蜜。尔时此宫有一大神。名牢度跋提。即从座起遍礼十方佛。发弘誓愿。若我福德应为弥勒菩萨造善法堂。令我额上自然出珠。既发愿已额上自然出五百亿宝珠。琉璃颇梨一切众色无不具足。如紫绀摩尼表里映彻。此摩尼光回旋空中。化为四十九重微妙宝宫。一一栏楯万亿梵摩尼宝所共合成。诸栏楯间自然化生九亿天子五百亿天女。一一天子手中化生无量亿万七宝莲华。一一莲华上有无量亿光。其光明中具诸乐器。如是天乐不鼓自鸣。此声出时。诸女自然执众乐器。竞起歌舞。所咏歌音演说十善四弘誓愿。诸天闻者皆发无上道心。时诸园中有八色琉璃渠。一一渠有五百亿宝珠而用合成。一一渠中有八味水。八色具足。其水上涌游梁栋间。于四门外化生四花。水出华中如宝花流。一一华上有二十四天女。身色微妙如诸菩萨庄严身相。手中自然化五百亿宝器。一一器中天诸甘露自然盈满。左肩荷佩无量璎珞。右肩复负无量乐器。如云住空从水而出。赞叹菩萨六波罗蜜。若有往生兜率天上。自然得此天女侍御。亦有七宝大师子座。高四由旬。阎浮檀金无量众宝以为庄严。座四角头生四莲华。一一莲华百宝所成。一一宝出百亿光明。其光微妙化为五百亿众宝杂花庄严宝帐。时十方面百千梵王。各各持一梵天妙宝。以为宝铃悬宝帐上。时小梵王持天众宝。以为罗网弥覆帐上。尔时百千无数天子天女眷属。各持宝华以布座上。是诸莲花自然皆出五百亿宝女。手执白拂侍立帐内持宫四角有四宝柱一一宝柱有百千楼阁。梵摩尼珠以为绞络。时诸阁间有百千天女。色妙无比手执乐器。其乐音中演说苦空无常无我诸波罗蜜。如是天宫有百亿万无量宝色。一一诸女亦同宝色。尔时十方无量诸天命终。皆愿往生兜率天宫。时兜率天宫有五大神

第一大神名曰宝幢。身雨七宝散宫墙内。一一宝珠化成无量乐器。悬处空中不鼓自鸣。有无量音适众生意。第二大神名曰花德。身雨众花弥覆宫墙化成花盖。一一花盖百千幢幡以为导引。第三大神名曰香音。身毛孔中雨出微妙海此岸旃檀香。其香如云作百宝色绕宫七匝。第四大神名曰喜乐。雨如意珠。一一宝珠自然住在幢幡之上。显说无量归佛归法归比丘僧。及说五戒。无量善法诸波罗蜜。饶益劝助菩提意者。第五大神名曰正音声。身诸毛孔流出众水。一一水上有五百亿花。一一华上有二十五玉女。一一玉女身诸毛孔。出一切音声胜天魔后所有音乐。佛告优波离。此名兜率陀天十善报应胜妙福处。若我住世一小劫中广说一生补处菩萨报应及十善果者不能穷尽。今为汝等略而解说佛告优波离。若有比丘及一切大众。不厌生死乐生天者。爱敬无上菩提心者。欲为弥勒作弟子者。当作是观。作是观者应持五戒八斋具足戒身心精进不求断结修十善法一一思惟兜率陀天上上妙快乐。作是观者名为正观。若他观者名为邪观

尔时优波离即从座起。整衣服头面作礼。白佛言。世尊兜率陀天上乃有如是极妙乐事。今此大士何时于阎浮提没生于彼天。佛告优波离弥勒先于波罗捺国劫波利村波婆利大婆罗门家生。却后十二年二月十五日。还本生处结加趺坐如入灭定。身紫金色光明艳赫如百千日。上至兜率陀天。其身舍利如铸金像不动不摇。身圆光中有首楞严三昧般若波罗蜜字义炳然。时诸人天寻即为起众宝妙塔供养舍利。时兜率陀天七宝台内摩尼殿上师子床座忽然化生。于莲华上结加趺坐。身如阎浮檀金色长十六由旬。三十二相八十种好皆悉具足。顶上肉髻发绀琉璃色。释迦毗楞伽摩尼。百千万亿甄叔迦宝以严天冠。其天宝冠有百万亿色。一一色中有无量百千化佛。诸化菩萨以为侍者。复有他方诸大菩萨。作十八变随意自在住天冠中。弥勒眉间有白毫相光。流出众光作百宝色。三十二相一一相中有五百亿宝色。一一好亦有五百亿宝色。一一相好艳出八万四千光明云。与诸天子各坐花座。昼夜六时常说不退转地法轮之行。经一时中成就五百亿天子。令不退转于阿耨多罗三藐三菩提。如是处兜率陀天昼夜恒说此法。度诸天子。阎浮提岁数五十六亿万岁。尔乃下生于阎浮提。如弥勒下生经说。佛告优波离。是名弥勒菩萨于阎浮提没生兜率陀天因缘。佛灭度后我诸弟子。若有精勤修诸功德威仪不缺扫塔涂地。以众名香妙花供养行众三昧深入正受读诵经典。如是等人应当至心。虽不断结如得六通。应当系念念佛形像称弥勒名。如是等辈若一念顷受八戒斋。修诸净业发弘誓愿。命终之后譬如壮士屈申臂顷。即得往生兜率陀天。于莲华上结加趺坐。百千天子作天伎乐。持天曼陀罗花摩诃曼陀罗华。以散其上赞言。善哉善哉善男子。汝于阎浮提广修福业来生此处。此处名兜率陀天。今此天主名曰弥勒。汝当归依。应声即礼礼已。谛观眉间白毫相光。即得超越九十亿劫生死之罪。是时菩萨随其宿缘为说妙法。令其坚固不退转于无上道心。如是等众生若净诸业行六事法。必定无疑当得生于兜率天上值遇弥勒亦随弥勒下阎浮提第一闻法于未来世值遇贤劫一切诸佛于星宿劫亦得值遇诸佛世尊于诸佛前受菩提记。佛告优波离。佛灭度后。比丘比丘尼优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。是诸大众。若有得闻弥勒菩萨摩诃萨名者。闻已欢喜恭敬礼拜。此人命终如弹指顷即得往生。如前无异。但得闻是弥勒名者。命终亦不堕黑闇处边地邪见诸恶律仪。恒生正见眷属成就不谤三宝。佛告优波离。若善男子善女人。犯诸禁戒造众恶业。闻是菩萨大悲名字。五体投地诚心忏悔。是诸恶业速得清净。未来世中诸众生等。闻是菩萨大悲名称。造立形像香花衣服缯盖幢幡礼拜系念。此人命欲终时。弥勒菩萨放眉间白毫大人相光。与诸天子雨曼陀罗花。来迎此人。此人须臾即得往生。值遇弥勒头面礼敬。未举头顷便得闻法。即于无上道得不退转。于未来世得值恒河沙等诸佛如来。佛告优波离。汝今谛听。是弥勒菩萨于未来世当为众生。作大归依处。若有归依弥勒菩萨者。当知是人于无上道得不退转。弥勒菩萨成多陀阿伽度阿罗诃三藐三佛陀时。如此行人见佛光明即得授记。佛告优波离。佛灭度后四部弟子天龙鬼神。若有欲生兜率陀天者。当作是观系念思惟。念兜率陀天持佛禁戒。一日至七日。思念十善行十善道。以此功德回向愿生弥勒前者。当作是观。作是观者。若见一天人见一莲花。若一念顷称弥勒名。此人除却千二百劫生死之罪。但闻弥勒名合掌恭敬。此人除却五十劫生死之罪。若有敬礼弥勒者。除却百亿劫生死之罪。设不生天未来世中龙花菩提树下亦得值遇。发无上心

说是语时。无量大众即从坐起。顶礼佛足礼弥勒足。绕佛及弥勒菩萨百千匝。未得道者各发誓愿。我等天人八部。今于佛前发诚实誓愿。于未来世值遇弥勒。舍此身已皆得上生兜率陀天。世尊记曰。汝等及未来世修福持戒。皆当往生弥勒菩萨前为弥勒菩萨之所摄受。佛告优波离。作是观者名为正观。若他观者名为邪观

尔时尊者阿难即从座起。叉手长跪白佛言。世尊。善哉世尊。快说弥勒所有功德。亦记未来世修福众生所得果报。我今随喜。唯然世尊此法之要云何受持。当何名此经。佛告阿难。汝持佛语慎勿忘失。为未来世开生天路示菩提相莫断佛种。此经名弥勒菩萨般涅槃。亦名观弥勒菩萨生兜率陀天劝发菩提心如是受持。佛说是语时。他方来会十万菩萨。得首楞严三昧。八万亿诸天发菩提心。皆愿随从弥勒下生。佛说是语时。四部弟子天龙八部。闻佛所说皆大欢喜礼佛而退佛说观弥勒菩萨上生兜率天经


佛说灌洗佛形像经

    No. 695 [No. 696]

佛说灌洗佛形像经

        西晋沙门释法炬译

尔时佛告摩诃刹头诸天人民。皆一心听。佛言。人身难得。无为道亦然。佛世难值。吾本从阿僧祇劫时。身为白衣累劫积德。每生自克展转五道。不贪财宝弃身施与无所爱惜。自致为王太子。以四月八日夜半明星出时。生堕地行七步。举右手而言。天上天下唯吾为尊。当为天人作无上师。太子生时地为大动。第一四天王。乃至梵天忉利天王。其中诸天各持十二种香和汤杂种名花以浴太子。太子得成佛道。开现圣法济度群氓。佛告诸天人民。十方诸佛皆用四月八日夜半时生。十方诸佛皆用四月八日夜半时出家。入山学道。十方诸佛皆用四月八日夜半时成佛。十方诸佛皆用四月八日夜半时而般涅槃。佛言。所以用四月八日者。以春夏之际殃罪悉毕。万物普生毒气未行。不寒不热时气和适。正是佛生之日。诸善男子善女人。于佛灭后当至心念佛无量功德之力。浴佛形像如佛在时。得福无量不可称数。佛言。我本行菩萨道时。三十六返为天王释。三十六反作转轮圣王。三十六返作飞行皇帝。诸有佛弟子信心善意者。当念十方诸佛功德。善若以香花杂物浴佛形像者所愿皆得。诸天龙神常随拥护皆当证明

佛告诸弟子。夫人身难得经法难闻。其有天人能自减损妻子之分五家财物。用浴佛形像者。如佛在时所愿悉得。欲求度世取无为道生生不与死会者可得。欲求精进勇猛如释迦文佛者可得。欲求如文殊师利阿惟越致菩萨者可得。欲求转轮圣王飞行教化者可得。欲求辟支佛阿罗汉者可得。欲求永离三恶道者可得。欲求生天上人间富乐者可得。欲求百子千孙者可得。欲求长寿无病者可得。世间人民贪欲如海。宁割身上一脔肉。不肯出一钱物与人。人生时不持一钱来。死亦不持一钱去。财物故在世间。人死当独去忆如此苦。乃浴佛形像者。持是功德生死相随无有断期。佛言。若人有一善之心。作是功德者。诸天善神天龙八部四天王等。佥然拥护。浴佛形像福报所生。常得清净。从是因缘得成佛道(此下三十一行经文丹本所无宋本自有存之)。佛言。持好香浴佛形像者。自得其福智。在清净功德名闻。诸持好华散佛上者。自得其福端政好色无有双比。诸持缯幡上佛者自得其福。在所从生当得自然好衣无极。佛言。我累功积德行善至诚。持戒忍辱精进一心智慧。乃自致得作佛。今日贤者某甲皆为慈心好意。信向佛道欲求度脱。持种种香花。浴佛形像。皆为七世父母五种亲属兄弟妻子在厄难中故。为十方五道中勤苦故。为佛人民愚痴不信佛道故。令其后世生为人。端好洁白众人所敬。尘垢不着身。在所从生。常与佛会。在所从生。常与法会。在所从生。常与比丘僧会。令某甲明经。智慧晓了。佛十二部经。四阿含。安般守意。三十七品。四意止。四意断。四神足。五根。五力。七觉。八直行道。若能至心求佛道者疾得阿惟越致

令其得佛三十二相。八十种好紫磨金色。十种力。四无所畏。十八不共。口出八种音声。飞行洞视在所至到。诸天龙鬼神鬼子母官属拥护其身。令行出入当得安隐。若行山中不逢虎狼。若入军旅不被兵甲。若行江湖不逢风波。令床上无有病瘦者。当令县官无呼召者。有妻子女产生难令得安隐。若行贾贩财利百倍。众邪恶气不得妄干。水火盗贼怨家债主不得妄害。口舌消灭皆令厌伏。令其精进莫得中悔。行如菩萨得道如佛佛说灌洗佛形像经

此经宋藏题云摩诃刹头经圣坚译今按开元录。宋藏错乱故。依丹本改为灌洗佛形像经法炬译。又宋藏此经初首即云。摩诃刹等乃至二纸经文。全是摩诃刹头经文二经不殊。今依丹本。以尔时佛告摩诃刹头乃至从是因缘得成佛道等二纸遆之。从佛言浴佛形像已下三十一行经文。于宋本中本自有之。而今仍存


佛说光明童子因缘经

    No. 549

佛说光明童子因缘经卷第一

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

如是我闻。一时佛在王舍城。迦兰陀竹林精舍。而彼城中。有一长者。名曰善贤。有大财宝富饶自在。然彼长者。于诸外道尼乾陀等。深生信重。长者一时。以彼世因缘故。其妻怀妊。而后一日。世尊于其食时。被袈裟衣。执持应器。入王舍城。次第乞食。渐次至彼善贤长者舍。时彼长者。远见世尊渐近自舍。即谓妻言。我今同汝。诣世尊所。作是言已。即与其妻。前诣佛所。到已白言。世尊。我名善贤。此是我妻。其人怀妊。日月将满。当所生者。是男是女。佛言。长者。汝妻胎中。决定是男。其后生已。家族富盛。最上吉祥。现于人中受天胜福。乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。是时长者。即取满钵上味清净饮食。奉上世尊。世尊受已。作如是言。愿其施者。吉祥安乐。世尊言已。持所施食。还复本处。佛去未远。有一外道。是彼善贤先所重者。见佛世尊已。即作是思惟。岂非今时因此沙门瞿昙。长者于我破本信心。我宜往彼询问其故。沙门瞿昙来何所说。时彼外道。作是思惟已。即诣长者舍。作如是言。长者。沙门瞿昙。有何愿求。来至汝舍。复作何说。长者白言。我师圣者。我妻怀妊故。乃问彼沙问瞿昙。当所生者。是男是女。彼谓我言。定当生男。生已决定家族富盛。最上吉祥。现于人中。受天胜福。乃至最后于我法中。出家学道证阿罗汉。而此外道。本善占相。闻是言已。即取白石。施设算法。算量其事为虚为实。彼设算已。具知其事。如佛所言。实无虚妄。而彼外道。虽知其实。然作是念。我今若以如实而说。即此长者于彼沙门瞿昙。定生信重。我今宜应语长者言。瞿昙所说有实有虚。时彼外道。作是念已。呼长者妻。近外道前。取左右手。复看手文。及瞻面相。尔时善贤长者。即白外道言。我师圣者。先已设算。何故重复看其手文。及瞻面相。彼外道言。我适算彼瞿昙所说。及相汝妻。审知其事。少分真实。少分虚妄。长者复言。何者真实。何者虚妄。外道答言。瞿昙所说。汝妻生男。此说是实所言生已家族富盛。此亦是实。然子生时。合有少分火光明事。此子后必坏汝家族。所言最上吉祥。现于人中受天胜福。此是虚妄。长者汝岂曾闻于人世中受天福者。斯为难信。所言于瞿昙法中当出家者。此说是实以彼衣食因缘所逼切故。而后决定于瞿昙边乐求出家。所言断诸烦恼证阿罗汉者。此是虚妄。以沙门瞿昙法中。决定无有断诸烦恼。证圣果者。尔时善贤长者。闻说是事。若虚若实。其心疑惑。即生愁恼。白外道言。我师圣者。其事云何。我今宜应当何所作。外道告言。长者当令汝子生。后于我教中出家修学。即能普学一切事业。长者。我虽此说。汝自筹量。时彼外道作是言已。即出其舍。是时善贤长者。静在一处。审自思惟。我今一切不能顾惜而悉弃舍。宜设计谋坏所妊子。作是思惟已。善贤长者即持毒药。涂摩妻腹。是时长者。左边摩药。子转右边。右边摩药。子转左边。乃至遍腹。无处容受。涂摩毒药。其妻以故。即趣命终。善贤意谓。母既命终。子亦随灭。而后无人坏我家族。亦复无人得证圣果。尔时长者。既见其妻已趣命终。即时涕泪号泣。邻人亲属。来相慰问善贤长者。汝妻何以忽然命终。长者报言因怀妊故。而忽命终。亲属邻人来相问已。各还自舍。善贤长者。即自思惟。我妻已殁。勿置家中。可为施设诸所用物。送尸陀林。作是思惟已。即为备办所用诸物。将欲出送。邻人亲属知己。复来谓长者言。汝妻已殁。不须啼泣徒自生恼。是时长者。即取青黄赤白众色衣服。及珍宝具。而为庄严。长者即时与诸亲属。围绕出送。置尸陀林。尔时先占相者。外道尼乾陀。知是事已。心大欢喜。即持幢盖。严饰而行。于王舍城。周遍巷陌四衢道中。告诸外道尼乾陀等言。汝等知不。沙门瞿昙先言。善贤长者妻当生子。其后生已。家族富盛。最上吉祥。现于人中受天胜福乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。彼虚妄说。今善贤妻。已趣命终。子亦随灭。汝等当知。譬如大树。根既断坏。枝叶华果。其何能得。诸外道辈。相言告已。心皆欢喜。诸有清净信者。当知佛世尊者。法尔真实。无所不知。无所不见。无所不解。无所不了。起大悲心。普摄世间。作一护念。施一无畏。已能圆满止观二行。已能成就三调伏事。已渡四流烦恼大海。已能安住四神足行。以四摄法。普摄众生。于长夜中。常念度脱。已能成就四无所畏。断五分结。已出五趣。六法具足。六波罗蜜。悉皆圆满。具足六种佛常行法。开七觉华。成八正果。成就三摩钵底。九先行善。十力坚固。名称普闻十方世界。具足千种最胜自在。于日三时及夜三时。常以佛眼。观察世间。正知见转于众生中。诸所施作。何处若有增。何处若有减。何处若烦恼。何处受极苦。何处若破坏。何处具有烦恼极苦破坏等事。何处施设少分方便。何处施设大方便力何处施设诸方便事。何处众生堕于恶趣。何处众生得生天界。何处众生得解脱果。何处众生未种善根者。令种善根。何处众生已种善根者。使令成熟。何处众生已成熟者令得解脱。佛世尊者。具足如是功德。言无虚妄。离诸过失

尔时世尊。审知时处因缘等事。知其所应放光明时。即从口中。出现青黄赤白众色光明。其光周遍。上下照耀光下照时。所有等活地狱。黑绳地狱。众合地狱。号叫地狱。大号叫地狱。炎热地狱。极炎热地狱。阿鼻地狱。如是等八热地狱。光明照已。悉变清凉。所有疱地狱。疱裂地狱。阿吒吒地狱。呵呵鑁地狱。虎虎鑁地狱。青莲华地狱。红莲华地狱。大红莲华地狱。如是等八寒地狱。光明照已。悉变温暖。以佛光明最胜因故。其中众生。蒙光照触。身得离苦。心生适悦。各作是言。我等以何罪因。堕在此中。今日睹是希有光明。地狱众生。发起如是清净心时。世尊大悲。复于光中。现变化事。彼诸众生。见所化已。又作是言。我等今日见是变化希有等相。此处出已。应不复于恶趣受生。以佛光明最胜因缘故。身离苦恼。心生适悦。作是言已。各发最上清净信心。彼地狱业。皆悉灭尽。即分人天二趣受生。地狱众生。由是真实。如应得利已。是佛光明。又复上照四大王天。忉利天。夜摩天。兜率天。化乐天。他化自在天。梵众天。梵辅天。大梵天。少光天。无量光天。光音天。少净天。无量净天。遍净天。无云天。福生天。广果天。无烦天。无热天。善见天。善现天。色究竟天。光明上照如是等天已。于其光中。演出无常苦空无我之声。复于光中说伽陀曰

  譬如大象没泥中　　以勇力故即能出
  佛教勇猛大力故　　能令生死军摧坏
  今此正法善调伏　　所行远离诸过失
  息彼三界广轮回　　灭尽众生苦边际

尔时世尊所放光明。各各随往。乃至遍照三千大千世界。而佛世尊。虽放一光。其光收时。随应各异。世尊若欲说过去事。其光即当从佛后隐。若欲说彼未来世事。其光即当从佛前隐。若欲说彼地狱趣事。其光即从佛足心隐。若欲说彼傍生趣事。其光即从佛足面隐。若欲说彼饿鬼趣事。其光即从佛足指隐。若欲说于人趣中事。其光即当从佛膝隐。若欲说彼小转轮王事。其光从佛左手心隐。若欲说彼大转轮王事。其光从佛右手心隐。若欲说彼天趣中事。其光即当从佛脐隐。若欲说彼声闻菩提。其光即当从佛口隐。若欲说彼缘觉菩提。其光即当从佛眉隐。若欲说彼阿耨多罗三藐三菩提。其光从佛顶门而隐。今佛世尊所放光明。遍照三千大千世界已。其光旋环。却从世尊口中而隐。尔时尊者阿难。先侍佛边。见此光明。即前合掌白佛言。世尊。今此种种妙色最上清净光明。从佛口出。广大照耀。普遍世界。以何因缘。其事如是。作是语已。即说伽陀曰

  佛于世间为最上　　安住正因而真实
  久已远离二语言　　断除憍慢等过失
  如世商佉及莲藕　　非无因故色自白
  如来最胜人中尊　　非无因故光明现
  如来以自行愿力　　现证神通及大智
  观察听者乐闻法　　佛人中主欲敷演
  大智寂默大牛王　　必说最上妙法语
  如来清净一音宣　　众生疑网皆除断
  又如大海及山王　　若无因故不能动
  如来正觉人中尊　　无因不现光明相
  大智观察因缘事　　如应所作皆利益
  随诸众生所希望　　故现如是光明相

尔时世尊告阿难言。如是如是。阿难当知。如来应供正等正觉。若无因缘。不放光明。我今将欲诣尸陀林。汝可往告诸苾刍众谓言。如来将诣尸陀林中。汝诸苾刍发勤勇者。如应各各被袈裟衣。侍从如来。往尸陀林。是时阿难。受佛教敕。即诣诸苾刍所。到已作如是言。佛敕诸苾刍。如来将诣尸陀林中。汝诸苾刍发勤勇者。如应各各被袈裟衣。侍从如来。往尸陀林。尔时尊者阿若憍陈如马胜嚩涩波大名跋捺哩迦舍利子目干连迦叶满称等。诸大声闻众。受佛敕已。即如常仪。被袈裟衣。来至佛所

尔时世尊。与诸大众。前后围绕。诣尸陀林。所谓善调伏者调伏众围绕。解脱者解脱众围绕。安隐者安隐众围绕。律仪者律仪众围绕。应供者应供众围绕。离贪者离贪众围绕。妙相端直者妙相端直众围绕。犹如牛王牛众围绕。又如象王象众围绕。如师子王众兽围绕。如彼鹅王鹅众围绕。如金翅鸟王金翅鸟众围绕。如婆罗门学众围绕。如大医王求疗者围绕。如勇猛将军众围绕。如大富者财宝围绕。如大商主商众围绕。如最上首者多人众围绕。如小国王臣佐围绕。如转轮王千子围绕。如月天子众星围绕。如日天子千光围绕。如持国天王乾闼婆众围绕。如增长天王鸠盘茶众围绕。如广目天王龙众围绕。如多闻天王夜叉众围绕。如毗摩质多罗阿修罗王阿修罗众围绕。如帝释天主三十三天众围绕。如大梵王梵众围绕。如底弥啰鱼现大海中。如叆叇云将降大雨。周匝诸云皆悉围绕。如来诸根。调柔善顺。威仪端俨。离缺失相。如大象王七支拄地平正圆满。离诸过失。如来具足三十二相八十随好。殊妙庄严。清净体相。无能胜者。圆光炽盛。广大照耀。如千日中一光明现。又如宝山高显而出。一切最胜。普遍贤善。十力四无所畏。三不护三念住。及大悲等。诸功德法。皆悉具足。是时复有无数诸苾刍众。及无数百千人众。周匝围绕。随佛行诣尸陀林中。佛所行时。有十八种法。而可称赞。何等十八。一无火怖。二无水怖。三无师子怖。四无虎怖。五无海难怖。六无他军怖。七无贼盗怖。八无王难怖。九无恶人怖。十无关税津渡道路等怖。十一无人怖。十二无非人怖。十三无非时怖。十四天眼天耳如实见闻。十五施设光明广大照耀。十六于法自在。十七于人自在。十八无病恼等。如是善法。佛所行时。皆悉具足。尔时复有无数百千天人。各各来集。随从世尊。往尸陀林。观佛世尊所应作事

佛说光明童子因缘经卷第一佛说光明童子因缘经卷第二

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉诏　译

尔时王舍城中。有二童子。一姓婆罗门。一姓刹帝利。其刹帝利童子。名曰寿命。是二童子。从王舍城出。于其路左。共为戏剧。彼寿命童子。久发正信。婆罗门童子。不具正信。乃谓寿命童子言。我闻世尊先说。善贤长者妻当生子。其后生已。家族富盛。最上吉祥。现于人中受天胜福。乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。彼善贤妻。已趣命终。子必随灭。长者亲属。送置尸陀林中。我知是事。岂非世尊说妄语邪。时寿命童子。即为婆罗门童子。说伽陀曰

  日月星宿可坠地　　山石从地可飞空
  海水渊深可令枯　　佛语决定无虚妄

是时婆罗门童子。闻是伽陀已。谓寿命童子言。汝或不信。我今同汝。往尸陀林。审观是事。于是世尊。从王舍城。次第而行。彼二童子。犹在路左。共为戏剧。时寿命童子。遥见世尊大众围绕。以宿善根故。即说伽陀曰

  希有大牟尼　　离诸动乱相
  人天大众俱　　次第而围绕
  以师子吼音　　能破诸外论
  善断众疑网　　最上难得见
  佛往尸陀林　　威仪相可观
  如风飘密雪　　清冷而遍空
  释迦牟尼尊　　现光明变化
  刹那瞻睹者　　随应获利益

尔时摩伽陀国主。频婆娑罗王。闻佛世尊先说。善贤长者妻当生子。其后生已。家族富盛。最上吉祥。现于人中受天胜福。乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。彼妻已趣命终。长者亲属。送尸陀林。今佛世尊。与诸大众围绕。亦诣尸陀林中。王闻是已。即自思惟。我佛世尊。若无义利。而辄不往彼尸陀林。将非善贤之妻死而复生。世尊往彼欲为施作诸利益故。我今宜应往观是事。是时频婆娑罗王。作是思惟已。即与耆旧大臣宫嫔官属围绕而出。王出城时。彼二童子。尚居路左。共为戏剧。彼寿命童子遥见频婆娑罗王已。即时前诣。说伽陀曰

  最胜摩伽陀国主　　臣佐围绕出王城
  发起决定净信心　　一切人众皆欢喜

是时佛及一切人天大众。频婆娑罗王。乃至寿命童子等。咸悉至于尸陀林中

尔时世尊。即从口中。放净光明。普照众会。时彼先占相者。外道尼乾陀等。亦在会中。睹佛世尊放光明已。即作是念。今此沙门瞿昙。于大众中。现光明相。岂非善贤之子不命终邪。作是念已。谓长者言。长者我观沙门瞿昙现光明相。必是汝子存而不没。善贤长者白言。我师圣者。此事若然。我当云何。外道告言。长者。汝子若存。当令入我法中普遍修学。尔时长者将焚其妻。先已积薪。并所用物。置尸于中。举火以焚。火焰既发。即从脐间。渐次破裂。中出莲华。于其华中。有一童子。端然而坐。面貌端正。色相殊异。是时会中无数大众。悉睹是相。叹未曾有。诸正信者。忆佛前言诚无虚妄。时彼外道尼乾陀。观是事已。心生苦恼。敛然而住

尔时世尊即告善贤长者言。长者。汝今收此童子。护持养育。时外道尼乾陀。窃观长者面相已。谓言。长者。焚尸火中。忽出童子。于一切事。皆不吉祥。汝今不应收归养育。时善贤长者。即不肯受。是时佛告寿命童子言。汝宜收此童子护持养育。时寿命童子。先审思已。后白佛言。于我舍中。无处容受。设得此子。非我所宜。时善贤妻。焚烧已竟。以佛光明威神力故。火自息灭。于刹那间。天降细雪。自然清冷。收置余薪。净其焚地。是时火中。出者童子。安然而住。于是世尊普告寿命童子等言。汝等有正信者。勿学外道邪异诳乱。当住正念。寿命童子白佛言。世尊。我于王族生。亦于王族老。我身清净。犹如牛头妙栴檀香。等无有异。我实不知外道邪异诳乱等事。是时世尊。又复告彼善贤长者言。今此童子。是汝之子。汝可收归护持养育。彼善贤长者。邪见坚固。不行正道。即时又复窃观外道尼乾陀面。彼外道言。善贤长者。汝宜审思。今此童子。火中遗残。大不吉祥。虽火不烧。而相岂善。汝若收归。决定令汝家族破坏。又复于汝命不相益。及于汝身为多损恼。凡所欲事。不得和合。深自筹量。无宜后悔。长者闻外道言已。复不肯受

尔时世尊即谓频婆娑罗王言。大王。汝今收此童子。王宫养育。时频婆娑罗王。受佛教敕。即速起身曲躬伸手取其童子。普遍观瞻已。即白佛言。我依佛敕。收归王宫。然此童子。作何名字。愿佛世尊。善为安立。佛言。大王。今此童子。从火中得。应为立名号火光明。尔时世尊。于大众中。以此童子。付授频婆娑罗王已。即时观察审知频婆娑罗王。及诸会众。若体若性。心所乐欲。如其所应。广为说法。是诸会众。得闻法已。中有多百人。发起最上清净正信。有证须陀洹果者。有证斯陀含果者。有证阿那含果者。有证阿罗汉果者。有能进发暖位善根者。有能进发顶位善根者。有能进发忍位善根者。有发声闻菩提心者。有发缘觉菩提心者。有发阿耨多罗三藐三菩提心者。有发归依摄受心者。有于学句起摄受心者。如是会众。以佛功德及正法力。众和合事。随其所应。咸得利益。尔时频婆娑罗王。即离佛会。将此童子。还复王宫。是时大王。召八宫嫔。以为八母。二为养母。使令恩养。二为乳母。使令乳哺。二为净母。使令灌浣。二为戏母。使令伴习戏玩。如是王敕八母。付其童子。自乳哺中。至于成长。或乳或食。及余所须。于昼夜中。抚怜恩育。无令阙失。后渐长成。如清净池一莲秀出。爱护存惜。其义亦然。乃至后时。光明童子。有一舅氏。久持财物。出外商贩。渐历岁年。未由还复。忽于一时。外闻人说。我妹怀妊。佛为记说。定当生男。其后生已。家族富盛。最上吉祥。现于人中受天胜福。乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。时彼舅氏。闻此语已。即速聚收商贩财物。涉远赍持。还归自舍。既至舍中。知妹已殁。悲号啼泣。审自思惟。外先所闻佛记我妹定当生男。乃至断诸烦恼。证阿罗汉。今妹既殁。佛虚设言。岂佛世尊亦妄说邪。作是念已。即往邻家。询问其故。谓邻人言。我出外方商贩始还。先闻人说。我妹怀妊。佛为记言。定当生男。其后生已。家族富盛。最上吉祥。现于人中受天胜福。乃至最后。于我法中出家学道。断诸烦恼。证阿罗汉。我闻是说。欢喜而归。洎至家中。妹已亡殁。佛所设言。岂非虚妄。是时邻人。即谓舅氏。说伽陀曰

  星月可处地　　山石可飞空
  大海可令枯　　佛语诚无妄

时彼邻人说伽陀已。复谓舅氏言。世尊所说。实无虚妄。汝妹亡殁。然有其因。以善贤长者信外道言造杀害业。由杀因缘汝妹亡殁。光明童子有大威力。火不能烧莲华中出。而今在彼频婆娑罗王宫中养育。是时邻人。具以前事。告其舅氏

时彼舅氏。闻此语已。即还家中。谓善贤长者言。长者所为。不依理法。以何事故。我妹致终。然我审知我妹怀妊。汝设计谋。不全生产。汝以邪见。信受外道。起杀因缘。杀害我妹。光明童子有大威力。火不能烧。莲华中出。今在王宫。此实非理。汝可速诣王宫于今日中取童子归。斯为甚善。若不然者。我必与汝作不和合。我即当持白灰。于街巷路陌四衢道中。乃至随处。遍散其地。普令地白。使人惊异。我当唱言。善贤长者。杀害女人。我妹先因此人坏命。光明童子。今在王宫。王亦今时作无义利。我于随处。必作此说。汝自筹量。无贻后耻。尔时善贤长者。闻此语已。心生忧恼。作是思惟。如舅氏说。将非实邪。若实然者。我必怀惭。作是思惟已。即诣王宫。既至王所。跪拜伸敬。具以前事而白王言。大王。我尚轻小。王最胜上。若不与其童子。恐谤于王愿王今时与此童子。王言。长者。我本无心取此童子。是佛世尊。付授于我。若非佛敕。我岂取邪。汝若欲取此童子者。今自宜应往诣佛所。具陈斯意。是时善贤长者。即出王宫。往诣佛所。到已白佛言。我有亲属。从外来归彼谓我言。光明童子。今在王宫。于今日中。速令取归斯为甚善。若不然者。彼不和合。乃至当于四衢道中。唱言善贤杀害女人。我妹先因此人坏命。光明童子。今在王宫王亦今时作无义利。我以是事。适诣王宫。取彼童子。王言。先因佛令收养。故我来此。愿佛令王还我童子。尔时世尊知是事已。观其善贤长者。今时若不得此童子。苦恼逼心。无有是处。定当呕血而趣命终。佛大慈悲。为作救护。即告尊者阿难言。阿难。汝可往诣频婆娑罗王宫。如我辞曰。佛问大王得无病不。今有一事。当听佛言。善贤长者。来取光明童子。王今宜应速当授与。善贤长者。若不得此童子。苦恼逼心。无有是处。定当呕血而趣命终。王悉是事。应如佛言。是时尊者阿难承佛圣旨。即时往诣频婆娑罗王宫。到已见王。如佛辞曰。佛问大王得无病不。今有一事。宜听佛言。善贤长者。来取光明童子。善贤若不得此童子。苦恼逼心。无有是处。定当呕血而趣命终。大王应悉是事。宜速付授。尔时频婆娑罗王。受佛敕已。即作是言。大德尊者。回至佛所。愿传我语。频婆娑罗王。稽首世尊足下。致敬问讯世尊。如佛教敕。我已听受。是时尊者阿难即出王宫。回至佛所。具如王言。白佛世尊。时频婆娑罗王。即速宣召善贤长者。到已谓言。善贤。今此童子。久在宫中。护持养育。八母看侍。乳哺依时。我心爱怜。过甚亲子。今虽佛敕还付于汝。然汝亦当体我心意。日日三时。汝自将来。我欲观视。善贤长者。敬受王命。即白王言。我受王敕。敢不遵承。日日三时。将诣王所。是时频婆娑罗王。即以众宝妙庄严具。铰饰大象。令光明童子乘此宝象。别敕臣佐。而令伴送至长者舍。而后长者。日日三时。送至王宫。王亲观视。光明童子。凡所施作。皆如理法。乃至后时。其父善贤。趣命终已。光明童子。即为家主。既嗣家业。转复精进。信佛。信法。信苾刍众。归佛。归法。归苾刍众。其父善贤长者。于此方处。先造杀业。光明长者。今为其父。修营福事。乃于自舍。常时备办。四事丰足。承事供给四方苾刍。乃至将来结集世尊正法藏者。上首耆年。诸大声闻。亦常供给所须供养。光明长者。于王舍城。修如是等。种种福事。悉为其父。而作利益。尔时有一商客。是彼善贤长者。先同商贩。故旧伴侣。久在外方。商贩未还。素念此人不造善业。又复闻知今已亡殁。子名光明。嗣为家主。其光明长者。信佛。信法。信苾刍众。归依三宝。如理所作。时彼商客。闻是事已。伤念善贤。庆快光明长者。即以上妙牛头旃檀之香。造一大钵。满盛众宝。远从外方。遣人持来。遗彼光明长者。以为信记。又令来人传如是言。所愿长时记念不忘。是时光明长者。即以咒句。而加护之。其咒所谓

计那唧呬吒夜嚩(一句)室吒夜嚩(二)羯哩迦吒计那嚩(三)仡哩系[怡-台+(日/工)]咩(四)

说此咒已。复作是言。如是宝钵。若沙门。若婆罗门。若大威力诸神通者。当受此钵。如应得乐。如是加持已。即持此钵。出王舍城。先于路左。立一大柱。彩绘庄饰。上复悬铃。置钵于下。永为标记。是时有诸外道。如彼常法。于明旦时。诣河洗浴。经由路次。见此宝钵。即时问彼光明长者言。长者。汝安此钵。当何所用。光明长者。具以元因告诸外道。彼外道言。诸有清净沙门释子。堪受此钵。余无力能而堪受者。外道言已。随处而散。乃至后有耆年大德诸苾刍众。入王舍城。持钵乞食。亦于路左。见此宝钵。即乃问彼光明长者言。汝安此钵。当何所用。光明长者。亦以元因。广如前答。诸苾刍言。长者。今此宝钵。非我等受。当持奉佛。即能增长善利。灭诸罪垢。时诸苾刍如是言已。随处而散

佛说光明童子因缘经卷第二佛说光明童子因缘经卷第三

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

尔时尊者。十力迦叶。游行到彼置宝钵所。见是事已。即诣光明长者舍。问长者言。汝置宝钵于其路左。当何所用。光明长者。即以前缘。具白尊者。是时十力迦叶。作是思惟。我闻善贤长者信重外道先造杀业。光明长者。今于此地为作福事。我今不应弃此钵去。宜现神力。令光明长者。圆满志愿。作是思惟已即以神力。舒其右手。譬如壮士屈伸臂顷。取其宝钵。持还所止。时诸苾刍。见十力迦叶持宝钵来。咸共白言。尊者。汝于何处。而得此钵。十力迦叶。具以前事。告诸苾刍。时诸苾刍又复白言。尊者。汝为此钵故。所现神力。如法仪不。十力迦叶言。诸苾刍。设如法仪。不如法仪。我已施作。今复云何。时诸苾刍。具以其事。即共白佛。佛告诸苾刍言。若非时处。及无义利。不应辄现神力等相。所现非宜。必生过失。尔时世尊。即以神力。化出四钵。一金。二银。三吠琉璃。四颇胝迦。化此四已。又化四钵。一鋀石。二赤铜三白铜。四木。如是化已。将前四钵。次第安布。将后四钵。亦复安布。一一钵中。满盛上好可食香药。送置一处。令苾刍众所应受者随意而取。于后佛摄神力。钵亦不现。乃至后时。光明长者。天中胜福。吉祥相现。殊异等事。时时自出。是时王舍城。瞻波国。二界中间。有标记柱。彩绘庄饰。下有二钵。一铁。二瓦。是钵先加持已。安置于此二界。不远有一税场。诸商贩者。输纳王物。有一守税人。诸子眷属。财帛具足。然不修善。于税场所。而忽命终。作大恶夜叉。亦在彼方。守护税场。诸子一夜梦夜叉言。可于彼地标记柱上悬一大铃。凡诸商人。经此税场。若有税物隐而不纳。其铃自动。守税人知。即速追集。重复搜捡。获所税已。而乃放去。诸子得梦。至明旦时。即与亲属。往税场侧。寻见其柱。乃依所梦。悬铃于上。尔时瞻波国中。有一居家婆罗门。名曼[寧*也]怛谟。营贸为业。忽于一时。与自妻室。同在一处。妻谓夫言。我今共汝营谋家业。滋彼财谷。以备所须。岂可安然都无营作。汝今宜应往市肆中。买[疊*毛]华蕊极妙好者。我当为汝织成白[疊*毛]。持出贸易。岂无利耶。时婆罗门。如其妻言。买得持归。妻乃设以机织之具。次第敷置。缉织其[疊*毛]。是蕊细软。妙好无比。布以经纬。致密细均。如是勤力。织成其[疊*毛]。即谓夫言。今此白[疊*毛]。上妙细软。价直千金。汝可持出外。若有人酬千金价。当可授与。其或价直不满千金。汝应随处。可出轻言。是处无人而能辩识此妙细[疊*毛]。唱是言已。即当持往他处贸易。尔时曼[寧*也]怛谟婆罗门。具如妻言。持此细[疊*毛]。入市贸易。竟无有人酬千金者。忆妻所说。乃唱是言。瞻波大城。无有一人识此细[疊*毛]。言已持归。与妻同议。此既无人酬是价直。宜往他国。必有识者。更相告已。时婆罗门。复将一叚曾所著者。同前新[疊*毛]。置伞柄中。随商人众。隐覆而行。渐出本国。适王舍城。经彼二界所有税场。是诸商人。既至彼已。置随行物。聚集一处。时守税人。次第搜捡。彼诸商人。即各以其所应税物。输纳于王。众中唯有曼[寧*也]怛谟婆罗门。隐覆先置柄中白[疊*毛]。而不输纳。独在一面。是时税场之侧。先所安立标记之柱。其所置铃。自然作声。彼守税人。即知众中有隐税者。乃谓商主言。今此柱上铃自作声。非风吹动。非人摇击。我已审知。汝此众中。岂非有人隐覆税物不输纳邪。时守税人。即速呼集。重复搜捡。于此众中。不见一人有其税物隐不纳者。时诸商人。互相知悉无税物已。咸欲前进。铃又作声。如是数四。累细捡覆。无隐税者。商主乃谓守税人言我此众中。无隐税者。必是他众私隐前去。作是言已。众共佥议。谓是此一婆罗门。隐覆税物。乃至最后。彼守税人。于曼[寧*也]怛谟婆罗门处。执而不舍。坚求其税。时婆罗门言。汝今何故而相谋执。汝已显见我实无物。若有少物隐不纳者。罄我所有。悉以输税。作是言已。铃又作声。时守税人。秖于此婆罗门处。委细搜捡。乃谓彼言。咄婆罗门。汝今何故。坚隐税物。而不肯纳。汝今闻此铃声频震。是事希有。汝今当知。此柱之下。必有天神。而作加护。汝宜输物无自贻咎。婆罗门言。天神加力。我信是实。言已于伞柄中。出其白[疊*毛]。示守税人。作如是言。此即是我所隐税物。汝宜收之。时守税人。受此[疊*毛]已。谓婆罗门言。既不输王。非我所受。回奉天神。言已持[疊*毛]挂于柱上。复谓婆罗门言。我已挂[疊*毛]。奉彼天神。汝或欲者。当自取之。时婆罗门。即取其[疊*毛]。而乃前进。于一静处。亦复如前安伞柄内。隐覆而行。渐次入于王舍城中。时婆罗门。显张其[疊*毛]。货于市肆。冀望有人酬千金价。如是周行。竟无有人酬千金者。时婆罗门。作是唱言。王舍大城。无人辩识此妙细[疊*毛]。唱是言时。光明长者。乘以宝象。方从王宫。还归自舍。适闻此语。而忽惊愕。即时暂住。谓婆罗门言。汝今何故于此城中。出轻易语。彼婆罗门。即时无答。光明长者言。汝宜具说此事元因。婆罗门言。我从本国。持此二叚上妙细[疊*毛]。而来贸易。若人酬我千金价者。我即与之。我已周行。无人酬价。光明长者言。汝可持来。我暂观视。时婆罗门。即随长者。至于舍中。乃展其[疊*毛]。示于长者。长者见已。即能辩识。乃谓婆罗门言。今此二[疊*毛]。一新一故。故者酬汝五百金钱。婆罗门言。长者所酬。其价未当。光明长者言。我今现见。此是故物。浣濯乃新。长者即时将此故[疊*毛]。于重楼上。自空投下。其[疊*毛]体重。即速坠地。光明长者。复谓婆罗门言。余一新[疊*毛]。我欲观视。时婆罗门。即取新[疊*毛]。持授长者。长者观已。亦复如前。向空投下。其[疊*毛]体轻。良久徐徐方乃坠地。彼婆罗门。即生信重。乃作是言。光明长者有大威力。今此细[疊*毛]。若新若故。我悉奉汝。不取其价。汝当受之。长者答言。我家巨富。汝历艰辛。安可无名受汝此物。我今各与汝千金钱。鬻我二[疊*毛]。时婆罗门。得其价已。持还所止。光明长者。先以故[疊*毛]。授彼家僮。后将新[疊*毛]。自作净巾。而常受用。乃至后时。光明长者。用是巾已。向日[日*殺]曝。是时频婆娑罗王。臣佐围绕。方欲上殿。忽为暴风。飘其浴巾。落于王前。时频婆娑罗王。谓侍臣言。今此细[疊*毛]。从何所来。唯应王者。乃可受用。侍臣白言。大王曾闻。转轮圣王。临位七日。天雨黄金。王今统临。天雨细[疊*毛]。后必非久亦雨黄金。王言。汝等知不。我闻佛记。光明长者。现于人中受天胜福。今此细[疊*毛]。必应是彼所用之物。风飘至此。可召其人而还授之。是时光明长者。即至王前。王言。长者。佛先记汝。现于人中受天胜福。今此细[疊*毛]。必汝所有。今还授汝。时光明长者。鞠躬伸手。捧受其[疊*毛]。受已观见。是己所有。即白王言。此是我家所用净巾。适因曝于日中。风飘至此。其事如实。王言。长者。佛记于汝。受天胜福。吉祥相现。佛语谛诚。其事如是。又言长者。汝今胜相若此。何不请王于汝舍中。暂一观视。长者白言。愿王今时幸我小舍。王言。长者。汝可先还备诸饮食。长者白言。大王受天福者。不假营造自然成办。愿王临幸。尔时频婆娑罗王。即与臣佐围绕。出诣光明长者舍。长者前导。王至彼舍。于其外门。见守门婢。色相殊异。王乃暂住长者白言。大王何故住而不进。王言。长者。我见汝妻。故乃暂住。长者白言。此非我妻。是守门婢。王即前行至中门外。又见一守门婢。王复不进。长者白言。王复何故住而不进。王同前答。长者白言。此非我妻。亦是守中门婢。王即前进入于中门。见摩尼宝地上。有虫鱼流水之相。王意谓是池沼。在此亦复暂住。长者白言。大王何故住而不进。王言。此处有水。故不前进。长者白言。大王。此处无水。是摩尼宝所成之地。王言。长者。若是宝地。何故有诸虫鱼流水等相。长者白言。大王。上有旋轮雕镂虫鱼等相。下是摩尼宝光映照故尔。王虽闻是说。犹故未信。即时取自指环。前掷于地。环击地声。王乃信是摩尼宝地。时频婆娑罗王。既入其舍。处师子座。时长者妻出拜王前。而忽泪下。王言。长者。汝妻何故见王垂泪。长者白言。大王。妻拜王前。何敢垂泪。但为王所著衣有木烟气烟薰目故。而忽泪下。是故大王。受天福者。所欲饮食。有如意宝。自然能出。尔时频婆娑罗王。在长者舍。住经七日。忘还王宫。时诸臣寮。共诣阿阇世太子所。白言。太子。王在光明长者舍。经今七日。于国政事。有所妨废。太子宜往请王还宫。时阿阇世太子。即诣光明长者舍。白父王言。我王何故忘还王宫。于国政事。有所妨废。王言。我在此舍。始经一日。国有政事。汝岂不能暂代吾治。太子白言。父王当知。住于此舍。已经七日。王闻是语。顾视光明长者问言。实不。长者白言。实尔大王。已经七日。王言。长者。汝此舍中。观于何相。以分昼夜。长者白言。华开华合。以分昼夜。异鸟和鸣。及不和鸣。以分昼夜。摩尼宝珠光现不现。以分昼夜。其或有华合而非夜。有华开而非昼。有珠光隐而非夜。有珠光现而非昼。有异鸟寂然而非夜。有异鸟和鸣而非昼。时频婆娑罗王。闻是事已即谓光明长者言。我信佛语。真实无妄。佛所说汝现于人中受天胜福。其事如实。时频婆娑罗王。言已出长者舍。彼阿阇世太子。方出舍时。私窃取一摩尼宝珠名扇恒。俱授一侍人。还王宫已。召而谓言。适所授汝摩尼宝珠。汝可持来。我欲观视。侍人开手欲奉太子。其珠不见。即时白言。不知此珠失于何处。是时太子。即将侍人。而行捶打。光明长者。以天福力。即知其事。来问太子言。何故捶打此侍人耶。太子答言。我适汝舍。盗摩尼珠。授此侍人。今忽隐讳。我已作盗。此复转盗。其罪愈甚。故行捶打。长者白言。汝取我珠。此不名盗。今既不见。亦非他盗。此珠现今复在我舍。何以故。受天福者。方可用故。太子若复别有所欲。悉当奉汝。我无所吝。时阿阇世太子。心生疑念。我今于此长者。未有希取。将来我父频婆娑罗王。命终已后。我乃求彼财宝诸物。作是念已。阿阇世太子。与提婆达多。结构异谋。害父王命。乃至后时。杀其父已。自行灌顶。处于王位。乃召光明长者而谓言曰。长者可为我兄。欲就汝舍而共居止。凡有所须。汝应给我。时光明长者。作是思惟频婆娑罗王。正法治世。此人猛恶。又复勃逆杀其父王。私自灌顶处于王位。今于我前。出矫诳语。欲止我舍。我应随顺。我若违彼。必因此人。坏我家族。作是念已。白言。大王。我知汝心。必有所欲。愿就我舍。凡有所须。随意受用。我当于后却往王宫。阿阇世王言。若能如是。乃为甚善。作是议已。是时大王。先诣其舍。长者还复来诣王宫。长者所有天人吉祥胜相。宝藏诸物。长者行处。而悉随至。彼阿阇世王。在长者舍。见珍宝藏。七遍出现。七遍隐没。作是思惟。今此舍中。宝藏诸物。必随彼去。我不能得。我今宜应别设异谋。潜遣数人极凶恶者。同载一车。往光明长者所。盗窃珍宝。彼人到已。巧设计谋。伺行盗窃。时光明长者。在高楼上。侍女围绕。时诸侍女。见此车中所载之人。先已默识是凶恶人。来作盗窃。侍女见已。笑指而言。此是凶恶盗窃之人。是时长者。忽闻笑言。具知其事。于是诸人。隐之终夕。至明旦时。多人共见。咸唱是言。阿阇世王。是恶逆人。杀害父王。今复遣诸恶人。来长者所。偷窃珍宝。时阿阇世王。知是事已。即遣使人。来光明长者所谓言。长者何故多人轻谤于我。时光明长者。知王意已。即速驱逐恶人令去。长者即自思惟。阿阇世王。极大恶逆。杀害父王。岂非后时亦复于我。致杀害事。我今弃舍一切所有。忆佛先记。于佛法中。出家学道。断诸烦恼。证阿罗汉。我今宜应投佛出家。作是思惟已。即出宝藏。施作种种悲愍利乐布施等事

佛说光明童子因缘经卷第三佛说光明童子因缘经卷第四

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

尔时光明长者。施作种种悲愍利乐布施等事已。而不告诸眷属亲爱。潜诣佛所。到已头面礼世尊足。前白佛言。世尊愿佛。今时施我善利。我今于佛法中。乐欲出家。受具足戒。而为苾刍。净修梵行。愿佛大慈。摄受于我。佛言。善来于我法中。勤修梵行。作是言时。光明长者。须发自落。僧伽梨衣。自然着身。成苾刍相。然后执持应器及净军。持经七昼夜。心住正念。净修梵行。威仪可法。如百腊者。佛以自着僧伽梨衣。与覆其顶。光明苾刍。诸根寂静。一心正住。是时空中有声赞言。佛于今时。与满意愿。光明苾刍。即复发起勤勇坚固之意。谛观五趣。生死轮回。动转循环。无有穷尽。众生诸行。种种差别。堕生死中。唯佛正法。而能解脱。如是观已。见四谛法。了知生死。远离三界贪爱之想。视诸金宝。与泥土等。断尽烦恼。证阿罗汉果。三明六通。悉得具足。最上无比。履空高举。如意自在。于世名闻利养等事。而悉不着。释梵诸天。咸来供养。是时会中诸苾刍众。见是事已。心生疑念。俱白佛言。世尊。今此光明苾刍。以何因缘。未出家时。现于人中。受天胜福。入佛法中。始出家已。即能断除一切烦恼。证阿罗汉。佛言诸苾刍。此光明苾刍。宿种善根。今已成熟。逮得所利。如应决定。今正是时。是故光明苾刍。以宿善因缘。获如是果

复次诸苾刍当知。诸业果报。皆从自因所作。非外地界所成。亦非水火风界所成。亦非从余蕴处界成。若善不善。皆由自业。获诸报应。尔时世尊。为诸苾刍。说伽陀曰

  一切众生所作业　　纵经百劫亦不忘
  因缘和合于一时　　果报随应自当受

佛告诸苾刍。汝等谛听。光明苾刍。往昔因缘过去九十一劫。有佛出世。号毗婆尸如来应供正等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。其佛与六百二十万苾刍众。游行到满度摩底大国城中。安止一处。彼国有王。名满度摩。其王正信。正法治国。国土广大。人民炽盛。安隐丰乐。离诸疾苦饥馑等难。亦无斗诤怨害盗贼恐怖。人民和顺。善相具足。时彼城中。有一长者。名曰积财。于法正信。其家大富。财宝无量。与毗沙门天王。等无有异。时彼长者。知毗婆尸如来。与苾刍众。来至城中。即自思惟。我欲请佛及苾刍众。饮食供养。及就我舍。安居三月。作是思惟已。诣彼佛所。到已头面礼佛双足。退坐一面。时毗婆尸佛。乃为长者。如其所应。宣说法要。示教利喜。积财长者闻正法已。即从座起。整治衣服。合掌向佛。而白佛言。世尊。我今请佛及苾刍众。就我舍中。饮食供养及就我舍。安居三月。一切所须供给承事。愿佛慈悲赴我所请。毗婆尸佛。即时默然。积财长者。见佛默然。知已受请。心生欢喜。头面礼足。即出佛会。还复自舍。是时满度摩王。闻毗婆尸佛。与六百二十万苾刍众。游行到此国城之中。即作是念。我今请佛及苾刍众。就我宫中。饮食供养。及就我宫。安居三月。一切所须。随应供给。作是念已。即与臣佐官属围绕。诣彼佛所。到已头面礼佛双足。退坐一面。是时彼佛。如其所应。为说法要。示教利喜。王闻法已。即从座起。整治衣服。合掌向佛。而白佛言。世尊。我今请佛及苾刍众。就我宫中。饮食供养。及就我宫。安居三月。一切所须。饮食衣服。卧具医药。随应供给。承事供养。愿佛慈悲受我所请。佛言大王。我已先受积财长者所请。王言。愿佛且就我宫。饭食供养。我当告敕积财长者。佛言大王。法尔不应违于先请。尔时满度摩王。头面礼毗婆尸佛足礼已。即从佛会。还所居宫。亟遣人使诣积财长者所。传教敕言。汝今当知。我已先请毗婆尸佛及苾刍众。汝可别日营办供养。积财长者白使者言。愿王哀察。我已先请彼佛及苾刍众。使还白王。王复遣告长者。汝今居我国中。于理亦应我先供佛。长者白使者言。大王若言居王国中。王合先请者。理实不然。愿王今时勿相违碍。使还具白。王复遣言长者。当知设汝所请。我亦不障。然若能造胜上食者。佛当自赴。尔时积财长者。闻是语已。即于是夜。燃以香木。营办种种清净最胜上味饮食。满度摩王。亦于宫中。办造饮食。至明旦时。长者舍中。敷设庄严妙好床座。及净水器。安布已讫。遣人诣佛。白彼佛言。饮食已办。食时亦至。愿佛降赴。今正是时

尔时毗婆尸佛。与苾刍众。食时着衣。执持应器。诣积财长者舍。受其供养。到彼舍已。佛先洗足。处于最上妙好之座。诸苾刍众。亦各洗足。次第而坐。积财长者。恭敬合掌。前礼佛足。礼已即持最上饮食。躬自奉上佛世尊已。次第各各奉诸苾刍。是时彼佛。及苾刍众。饭食讫已。收置其钵盥手清净。次第安坐。积财长者。亦于佛前。恭肃而坐。听佛说法。尔时毗婆尸佛。为积财长者。如其所应。宣说法要。示教利喜。长者得闻法已。心大欢喜。顶礼佛足。积财长者。如是供养已。佛出其舍。尔时满度摩王。尚于宫中。营办饮食。求胜长者。乃谓侍臣言。我此宫中。眷属嫔御。而甚广大。何人善为营造胜上殊妙饮食。而能胜彼积财长者。侍臣白言。大王但当禁止诸卖薪者。而彼长者自不能办供佛之膳。王如其言。即令禁止。若固卖者。不应住我国中。时积财长者。闻有教敕禁卖薪者。心生忿恚。即作是言。今我舍中。自有香木。何须彼薪以焚身邪。是时长者。舍中先燃香木。及以香油。营造饮食。是香普薰彼大城中。满度摩王。闻是香已。问侍臣言。今此妙香。从何所来。侍臣白言。此是积财长者。燃以香木。营造饮食。是彼余香。来至于此。王闻是语。知佛已赴长者所请。转复愁恼。谓侍臣言。今我宫中。何无香木。侍臣白言。市无香木。其何能得。大王当知。彼积财长者。家虽巨富。而无子息。一旦终殁。必无继嗣。凡彼所有。悉归于王。时满度摩王。虽闻是语。亦复不悦。臣白王言。大王且止愁恼。王当别日请佛供养。如王所欲。我悉能令胜彼长者。尔时臣佐作是言已。即于满度摩底城中。悉令除去一切沙砾不净等物。以旃檀香水。洒令清净列净水瓶。焚诸妙香。以真珠宝。交错垂布。立诸幢幡。散种种华。犹如天中欢喜之园。等无有异。清净庄严。众宝具足。敷置种种妙宝之座。营办广大。细软甘美。种种上味。清净饮食色香具足。如天苏陀悦意上味。如是饮食。所应供养三界中尊。既安布已。时诸臣佐。俱白王言。今此大城。内外清净。种种庄严。上味饮食。悉已成办。愿王请佛。饭食供养。时满度摩王。见是事已。心生欢喜。即遣使者。诣毗婆尸佛所。而白佛言。饭食已办。食时亦至。愿佛降赴。今正是时。尔时毗婆尸佛。与苾刍众。食时着衣。执持应器。诣满度摩王宫。受其供养。到已佛先洗足。处于最上妙好之座。诸苾刍众亦各洗足。次第而坐。时满度摩王。即持宝吉祥瓶。自佛已降。遍行净水。以佛神力故。有吉祥龙。自然住空。持百伞盖。覆佛世尊。及苾刍顶。王第一妃。执其珠金众宝庄严上妙宝扇侍立佛侧。余诸宫嫔。亦执宝扇。侍苾刍侧。时满度摩王。前礼佛足。礼已即持上味饮食。躬奉世尊。然后各各。奉诸苾刍尔时积财长者。知佛亦赴满度摩王所请。即时遣人。潜诣王宫。观其敷设庄严饮食等事所作何若。是人至彼。具见殊胜。贪止不还。如是累遣人去。亦复不还。最后长者即亦自往。至王宫已。备见庄严供养等事。乃自思惟。今王宫中。如是敷设。不知何人而能办作。我家何故无能此者作是念已。还归自舍。谓守库人言。汝可取诸金宝置于门首。有来求者。随意当与。勿须引入。我不能见。时积财长者。作是念已。即入舍中。寂止一处。榰颐不悦。是时帝释天主。以净天眼。见是事已。乃作是念。今此界中。积财长者。布施供养毗婆尸佛。是为上首施主。彼心净信。我宜变身助其营造。作是念已。隐帝释天主身。现婆罗门相。诣积财长者所。到彼舍已。谓守门人言。汝可入告长者言。有憍尸迦族婆罗门。今在门外。欲见长者。守门人曰。长者有言。凡有来者。不应引入。或有所求。随意当给。汝婆罗门。若有所欲。宜自持去。何故须求见长者耶。婆罗门言。我于诸物。都无希取。然今但欲求见长者。汝宜为我速入通达。时守门人。即入白言。有一憍尸迦族婆罗门。今在门外。欲见长者。长者告言。汝可谓彼婆罗门曰。若有所求。自当持去。何故须欲求见我耶。时守门人。即出具告。婆罗门复言我无所求。唯欲与彼长者相见。时守门人。再白长者。于是长者。许其相见。婆罗门入已。白长者言。汝今何故榰颐不悦。有何忧愁。尔时长者。说伽陀曰

  我不说忧事　　说亦不能脱
  若令我得脱　　我即为汝说

时婆罗门言。汝但具说忧愁所因我必为汝善解其事。时积财长者。具说所因已。彼帝释天主即摄婆罗门相。还复本身。谓长者言。我是帝释天主。我今当遣毗首羯磨天子。来助于汝。营办胜上饮食供佛。作是语已。隐复天宫。即敕毗首羯磨天子言。汝往积财长者舍。潜助营办供佛之事。不亦善乎。时彼天子。奉帝释命。潜助长者。乃以神力。即变大城。悉令清净。如天境界。敷设种种上妙珍宝严饰之具。天诸宝座。天妙饮食。皆悉具足。有爱啰嚩努龙王。自然住空持白伞盖。覆于佛顶。余吉祥龙。各持伞盖。覆诸苾刍顶。有天童女。执金宝庄严最上宝扇。侍立佛侧。余诸天女。各执宝扇。侍苾刍侧。时积财长者。即持种种上味饮食。躬自奉上佛及苾刍。时满度摩王。即谓使者言。汝可潜诣积财长者舍。观其敷设庄严饮食其事何若。使者奉命。即潜诣彼。具见庄严殊异等事。见已忘还。复遣近臣去。亦不还。遣大子去。亦复不还。乃至最后王自诣彼。潜立门侧。尔时毗婆尸佛。知王在外。即谓长者言。汝先因满度摩王。发不善语业。斯为罪咎。其王今在汝舍门外。汝可速出悔谢其过。长者即出。见其王已。悔过自责。迎王前入。王入舍已。具见种种天妙庄严及饮食等。见已悉忘前事。乃谓长者言。汝所供佛。胜上若此。如能日日如是供养佛及苾刍。斯无等比。时积财长者。起清净心。前礼佛足。发是愿言。愿我以此。如实布施佛及苾刍。所作善根。当生获得大富自在。一切具足。所生之处。得于人中现受天福。不起多贪。具离贪行。愿如今日。得善法利。值佛正法。归佛出家。发是愿已。毗婆尸佛。及苾刍众。即住长者舍。安居三月

尔时释迦牟尼佛。告诸苾刍言。于汝意云何。尔时毗婆尸佛法中。积财长者。岂异人乎。今光明苾刍是也。彼时于满度摩王所。出不善语业。由是因故。果报无失。于五百生中。与母同其火焚。乃至今生。亦复如是。然于毗婆尸佛所。先种善根。及发大愿。今已成熟。为大富长者。一切具足。现于人中。受天胜福。所作善利。乃至威力等事。与彼毗婆尸佛时。等无有异。而今最后于我法中。出家学道。断诸烦恼。证阿罗汉。诸苾刍。以是因缘。汝等当知。一切众生。若造一黑业因。决定当受一黑业报。若造一白业因。决定当受一白业报。是故诸苾刍。若黑业因。若白业因。一一果报。决定无失。当知皆是自分所作。汝等诸苾刍。应如是修学。佛说此经已。诸苾刍众。闻佛所说。皆大欢喜。信受奉行

佛说光明童子因缘经卷第四


佛说鬼问目连经

    No. 734

佛说鬼问目连经

        后汉安息国三藏安世高译

闻如是。一时佛住王舍城迦兰陀竹园。尔时目连晡时从禅定起游恒水边。见诸饿鬼受罪不同。时诸饿鬼见尊者目连。皆起敬心。来问因缘

一鬼问言。我一生以来。恒患头痛。何罪所致。目连答言。汝为人时。好以杖打众生头。今受花报果入地狱

一鬼问言。我一生已来。资财无量。而乐着弊衣。何罪所致。目连答言。汝为人时。布施作福。还复悔惜。今受花报果在地狱

一鬼问言。我一生已来。宿无常处。恒倚巷陌。何罪所致。目连答言。汝为人时。客来投止。不肯安处。见他客止。方复嗔恚。今受花报果入地狱

一鬼问言。我食不啖一斛。而不得饱。何罪所致。目连答言。汝为人时。饭饲众生。初不令足。今受花报果入地狱

一鬼问言。我一生已来。腹大如瓮。咽细如针孔。不得下食。何罪所致。目连答言。汝为人时。作聚落主。自恃豪强。轻欺百姓。强打拍人。索好美食。今受花报果入地狱

一鬼问言。我一生已来。恒患男根疮烂。痛不可言。何罪所致。目连答言。汝为人时。佛图精舍清净之处。行于淫欲。今受花报果入地狱

一鬼问言。我一生已来。多有儿子。皆端正可喜。而皆早死。念之断绝。痛不可言。何罪所致。目连答言。汝为人时。见儿杀生。助喜啖肉。杀生故短命。喜故痛毒。今受花报果入地狱

一鬼问言。我一生已来。有一狗体大牙利。两目赫赤。常来啖我。何罪所致。目连答言。汝为人时。喜将狗猎。残害众生无有慈心。今受花报果在地狱

一鬼问言。我一生已来。有一人持诸利刀。常割我肉。尽便持去须臾寻生而复来割。痛不可言。何罪所致。目连答言。汝为人时。喜屠割众生。初无慈心。今受花报果入地狱

一鬼问言。我一生已来恒患身体处处皆痛。不可得忍。何罪所致。目连答言。汝为人时。好渔猎。所网得鱼。投之沙土。令其苦死。今受花报果入地狱

一鬼问言。我一生已来。顽无所知。何罪所致。目连答言。汝为人时。强劝人酒。令其颠倒。今受花报果入地狱

一鬼问言。我一生已来。恒患热渴。行见恒河冀入其中以除热渴。方入其中。身体焦烂。肌肉离骨。渴欲饮人。一口之腹。五藏焦烂痛不可言何罪所致。目连答言。汝为人时。喜焚烧山泽。残害众生。今受花报果入地狱

一鬼问言。我一生已来。恒患饥渴。欲至厕上取粪啖之。厕上有大力鬼。以杖打我。初不能得近。何罪所致。目连答言。汝为人时。作佛图主。有客比丘来悭惜不与食。待客去后。乃行与旧僧。悭惜僧物。故今受花报果入地狱

一鬼问言。我一生已来。恒处不净。臭恼缠身不能得离饥渴之时还食此不净。何罪所致。目连答言。汝为人时。作婆罗门子。有一道人。中后来就汝乞食。汝尔时当作是方便。令此道人不复来乞。便取其钵。盛粪着底。以饭覆之。道人得钵。还至本处。着一面澡漱既讫。摄钵欲食。钵中臭秽不可得近。以是之故。堕在地狱。汝将来世堕粪屎弥犁地狱中

一鬼问言。我一生已来。肩上有铜瓶。盛满中洋铜。一手捉铜杓以取之。还灌其头。痛不可言。何罪所致。目连答言。汝为人时。作僧维那知僧事。有一瓶酥。藏着余处。不行与僧。待客去后。乃行与旧僧。此酥是招提僧物。一切有分。悭惜僧物故。今受花报果入地狱

一鬼问言。我一生已来。或登刀山剑树地狱。或堕火坑镬汤地狱。种种受苦。无复休已。何罪所致。目连答言。汝为人时。作天祠主。烹杀三牲。祭祀天神。血肉灌洒四方。语众人言。汝等祠祀。大得吉利。作此魔邪之言妖[薛/女]之语。轻欺百姓。诳惑父母。以是之故。果入地狱

一鬼问言。我一生以来。常吞铁丸。何罪所致。目连答言。汝为人时。作沙弥子。取净水作石蜜浆。石蜜坚大。盗打取少许。众僧未食盗食一口故。以是因缘。果入地狱。汝将来世。常吞铁丸。尔时目连与诸饿鬼。说往昔因缘经竟。还来在耆阇崛山。一切大会。闻佛所说。稽首奉行佛说鬼问目连经


佛说海龙王经

    No. 598

佛说海龙王经卷第一

        西晋月氏国三藏竺法护译

    行品第一

闻如是。一时佛游王舍城灵鹫山。与大比丘众俱。比丘八千。菩萨万二千。一切大圣十方来会。众德具足得诸总持。无所不博辩才至真。决一切疑入大神通。分剖慧义诸度无极。济于彼岸究畅开士。定意正受诸佛咨嗟。普游殊域神足飞行降化众魔。分别诸法知如本谛。睹见一切众生之原。积累道品于世八法而无所著。以大慈哀严身口意。彼无极铠过大精进。于无数劫而不厌惓。为师子吼开化外道。以不退转印如印之。晓了诸佛深要法藏。其名曰山光菩萨。惠山菩萨。大明菩萨。总持山刚菩萨。山铠王菩萨。山顶菩萨。山幢菩萨。山王菩萨。石磨王菩萨。雷音菩萨。雨王菩萨。宝雨菩萨。宝英菩萨。宝首菩萨。宝藏菩萨。宝明菩萨。宝幢菩萨。宝顶菩萨。宝印手菩萨。宝畅菩萨。宝严菩萨。宝水菩萨。宝光菩萨。宝铠菩萨。宝现菩萨。宝造菩萨。乐严法菩萨。净王菩萨。严顶相菩萨。金光饰菩萨。宝髻菩萨。天冠菩萨。千光菩萨。原崄菩萨。照昧菩萨。月辩菩萨。发意转法轮菩萨。金光净菩萨。常施无畏菩萨。万二千菩萨。德皆如是。是贤劫中大士弥勒软首等六十大圣。不可思议解缚等十六正士。帝释四天王与忉利天人俱。焰天。兜术天。不憍乐天。化自在天魔子道师。梵天王。梵净天王。善梵天王。梵具足天王。大神妙天。净居天。离垢光天。乃至一善天。燕居。无善神王。各与眷属六万。山树神王四万二千。力士神王。一名持华。三万二千与香音神俱。无焚龙王与七万二千诸龙俱。四方金翅鸟王及余一切诸大尊神。天龙鬼神。无善神。凤凰神王。山树神王。甜柔神等。各与眷属来诣佛所。稽首毕一面住。比丘比丘尼清信士清信女。前为佛作礼各坐一面。彼时佛与若干百千之众营从围绕。佛处诸天严净师子高广之座。为四部众而普说法。佛在众中如安明山王现于大海。德超诸天世无双比。光明巍巍靡所不照。如来威变应时。空中化有宝盖。众珍杂珓遍覆四方。无数百千垂珠璎珞。青黄赤白无垢宝珠。照虚空珠光从珠出。其色无量不可称计。雨诸香华华至于膝。虚空之中出大雷音雨众名香。于是贤者大目犍连。承佛圣旨前问佛言。今所感动未曾见闻。此何瑞应。佛告目连。今海龙王欲来见佛故先现瑞。佛语未竟。寻时龙王与七十二亿婇女八十四亿眷属。皆赍香华幢幡宝盖百千伎乐。往诣佛所前稽首毕。绕佛七匝。各以所持用散佛上。伎乐供养。与中宫眷属俱住佛前。以偈赞曰

  慈施愍伤俗　　示现与世眼
  虽生于世俗　　无著如莲华
  施俗之安隐　　在世照三世
  解法如日光　　稽首世最上
  十力超施戒　　自调成眷属
  烧除尘劳冥　　御众如调马
  施与七大财　　恩慈加众生
  为一切父母　　稽首最福田
  眉间相光曜　　如日白雪光
  梵天人在上　　无能见其顶
  佛面出大光　　蒙光获安隐
  普照百千国　　至于无择狱
  柔软言无极　　解决众疑结
  音遍天世间　　清净无垢秽
  除淫怒痴冥　　照以智慧光
  施安令欢喜　　为示现解脱
  无碍达三世　　求比无等伦
  知人群萌行　　了善恶所趣
  观察人根原　　一时咸能睹
  开心令解脱　　稽首诸慧上
  百千亿诸魔　　诣树求佛便
  至德愿威神　　降化伏邪心
  不嗔不厌惓　　导以慈哀力
  供养世之尊　　孰敢懈慢者
  观法无所有　　譬之如虚空
  犹电雾泡沫　　幻化及野马
  本空缘相与　　计之无吾我
  照示生死法　　是故莫不供
  所以无数劫　　勤行亿那术
  供养亿万垓　　不可计诸佛
  布施及戒忍　　精进禅智慧
  尊愿已具足　　稽首大圣雄

于是海龙王。说此偈赞佛已。前白佛言。愿欲有所问。傥肯听者乃敢宣陈。佛言。在汝所问。若有疑者。如来当为具发遣之。龙王见听喜踊问曰。何谓菩萨除诸恶趣。何谓菩萨超出诸难。何谓菩萨生天上人间。何谓菩萨不离诸佛。何谓菩萨得值善友。何谓菩萨常在安隐。何谓菩萨常怀笃信。何谓菩萨多所悦护。何谓菩萨济众因缘。何谓菩萨长益善法。何谓菩萨喜造德本。何谓菩萨常乐于义。何谓菩萨不着五阴。何谓菩萨常好于法。何谓菩萨乐于法乐。何谓菩萨所闻无厌。何谓菩萨请益观义。何谓菩萨闻能奉行。何谓菩萨具出家德。何谓菩萨离居顺戒。何谓菩萨弃于重担。何谓菩萨常处树下。何谓菩萨乐处闲居。何谓菩萨而独燕处。何谓菩萨离诸谀谄。何谓菩萨具出家慧。何谓菩萨入深要法。何谓菩萨观法如幻。何谓菩萨不堕灭见。何谓菩萨不堕常见。何谓菩萨超因缘法。何谓菩萨离诸邪见。何谓菩萨神通自乐。何谓菩萨而得六通。何谓菩萨而得慧通。何谓菩萨漏尽神道。何谓菩萨现无盖慈。何谓菩萨所见无碍。何谓菩萨晓了众生心之所行。何谓菩萨行无厌足。何谓菩萨分别所受教化之言。何谓菩萨降伏魔怨。何谓菩萨离诸恐惧。何谓菩萨御退转者。何谓菩萨得不退转。何谓菩萨逮不起忍。何谓菩萨过于诸净。何谓菩萨诸行清净。何谓菩萨世尊授决。佛言。善哉善哉。海龙王。乃问如来如此之义。谛听谛听善思念之。龙王曰。唯然世尊。愿乐欲闻。佛言。菩萨有四事弃诸恶趣。何等为四。菩萨无害心于众生常护十德。不说人短亦不轻慢。自省己过不讼彼秽。是为四。复有四事超出诸难。何等为四。常叹三宝佛法圣众。有乐法者而不娆乱。不造人疑。有犹豫者悉开导之。是为四。复有四事生天上人间。何等四。不舍道心又教他人亦不毁戒。心愿清净为人说经而发大哀。是为四事。复有八事不离诸佛。何等八。常念诸佛。供养如来。嗟叹世尊。作佛像形劝化众生使见如来。其所向方闻佛之名。愿生彼国志不怯弱。常乐微妙佛之正慧。是为八事。复有四事得值善友。何谓四。不慢无谄。常加恭敬。柔和顺言而不自大。常受言教。是为四。复有三事常在隐处。何等三。不刚不[革*卬]而不谀谄。除诸贪嫉。见人得供代其欢喜。是为三。复有五事常怀笃信。何等五。晓乐脱力积功德力。入报应力。遵道心力。将御法力。是为五。复有二事多所悦护。何等二。不舍欢喜。不在嗔恨。是为二。复有二十事护众因缘。何等二十。常信佛教。不着他缘。所作自护。他作他受。法法相应。法法相照。善恶报应。无乱不顺。心无想念。无我无人。都无所有。亦无往来。无所归趣。除因缘报。由罪福安危。将护诸缘。诸佛世尊。皆由清净而成道德。除众恶事以故吾等修行善本。是为二十。复有二事长益善法。何等二。知于三品。行无放逸。是为二。复有二事。何等二。喜造德本。亦不想报。是为二。复有五事常乐于义。何等五。不着色声香味识。是为五。复有五事常好于法。何等为五。不贪色痛志得智慧拥护一切。是为五。复有六事常乐于法。何等六。乐于五根不乐五欲。常乐法会不乐世谈。乐讲说经不乐衣食。常乐观法不乐不净。乐遵修法不乐文字。乐于佛法不乐声闻缘觉法。是为六。复有八事乐于法乐。何等八乐讲佛道不乐卑贱。乐度无极不乐声闻缘觉道。乐赞四恩不乐非法。乐大慈哀不乐世事。乐说大道不乐终始。乐讲深法缘起之本不乐常无常我人寿命。乐空无想无愿真谛之法不乐调戏离放逸想。乐严佛国不乐观灭。是为八

复有五事所闻无厌。何等五。博闻智慧利于明达闻无厌足。普听不懈决诸狐疑闻无厌足。因闻觉了尘劳恚恨故无厌足。因闻断欲而除一切众生垢着故无厌足。因闻勇猛决一切疑故无厌足。是为五。复有二事观义求闻不惓。何等二。兴于贤圣正见之行。得无碍辩总持之要。是为二。复有十事闻能奉行。何等十。利知厌足在于闲居。身口心寂进止安详。所闻观净。独处少事。不乐众闹。初夜后夜常观精进。敬重善友。志怀羞耻。常以大哀护于一切。等贤圣禅至德具足。以惠救护天上世间。是为十。复有五事具出家德。何等五。所作已成不复忘失。灭除尘结。其心当舍一切诸着。诸佛世尊不讼其短。已得解脱。见诸缚者为说脱法。是为五。复有五出家顺戒。何等五。救顺禁法救济毁戒。顺诸所闻救济鲜闻。顺所定意救济乱心。顺所智慧救济恶智。顺所度知立于众人安隐无为。是为五。复有五弃。何等五。弃于重担而除五阴。断恩爱结及诸所习。常以寂定舍于寂灭。入于道德奉行八道。入于圣谛立一切人于正谛法。是为五。复有四法常处树下。何等四。不惜身命。奉行一切诸德善法。发神通慧。行寂然事天人欣悦。是为四。复有四事乐处闲居。何等四。发大哀以处闲居。诸佛所叹欲救众生。无偏邪行坐成佛时庄严自由不为尘劳。学余菩萨究竟之行积闲居德。入于郡国县邑聚落为众说法。是为四。复有三事。而习燕坐。最尊无上功德微妙为贤圣行。何等三。不习憎爱亦无所慕。自在离欲心无缚着。行步自由等心一切。疾得定意。是为三。复有三事。离诸谀谄。其心质直而无恚恨。已住于行。众结便断。是为三。复有八事具出家德。何等八。贤圣知足在于独处。得知限节。逮诸博闻。弃恨忍辱。不舍道心行四意止。专精定意。而应智慧。一切所兴以行为要。是为八。复有十事入深要法。何等十。见身自然诸法自然。身入于净一切法净。见已无吾诸法无我。自观身空不疑诸法空。己身无声诸法如响。察身寂寞诸法静默。我者审谛观诸法谛。我志深妙见诸法奥。己身无闻诸法如聋。吾无所受见一切法无可取者。是为十。复有十事。诸法如幻兴诳诈相。诸法如梦所见无实。诸法如野马起颠倒想见不谛故。诸法如影所作因缘无以为乐。诸法如水月捉不可得其相离行。诸法如响本末悉空。诸法如电晃现随灭。诸法如画离淫怒痴。诸法本净不为客垢之所沾污。诸法如虚空适起寻灭无有处所。是为十。复有二事不堕灭见。何等为二。随时之慧入于罪福了别诸佛圣智之明。是为二。复有二事不堕常见。何等为二。一切说无常慧。适起便灭意无永存。是为二。复有四事超因缘法。何等为四。无黠之习入生死习。无黠已灭生死便除。不堕灭见不住常观。是为四。复有四事离诸邪见。何等四。晓空慧不见彼我。解无相不见寿命。了无愿不见三处。分别缘起离常无常。是为四。复有六事以诸神通而自娱乐。何等六。不以恶眼视于众生得天眼净。闻恶声音则能忍辱逮天耳净。其心不乱睹他心净。殖众德本则识过事。如口所语身行亦尔获神足净。修行诸敬不欺法师尽诸漏净。是为六。复有六事得六通。何等六。以然灯故得天眼净。施诸音乐得天耳净。施无悕望了众生心。殖众德本知过去事。却诸阴盖决众狐疑逮神足净。以法布施尽诸漏净是为六。复有六事而得通慧。何等六。适见如来得天眼净。合会说法得天耳净。制伏其心见众生意。常习六念得识宿命。弃诸贪浊逮成神足轻举能飞。遵修诸法得尽诸漏。是为六

佛复告龙王。以有神通而自娱乐。声闻缘觉及外道神仙。天龙鬼神无善神。凤凰神王山神王。甜柔神人与非人。所有天眼。计菩萨眼。最上无极清净明彻。除如来眼。菩萨之眼无所不见。天人光色诸法之本无所挂碍。又声闻缘觉及天龙神人与非人。计菩萨耳。最上无极清净明彻。除如来耳。菩萨之耳无所不闻。天人音声诸法之讲无所挂碍。闻诸音声知三达事。皆了一切众生之心。所行造念因缘报应往来之想。净不净着不着。若干种心。若逆心若顺心。缚心解心。依心不依心。惑心定心。有处心无处心。若兴衰心。已晓了之。悉见人根如应说法。以识宿命知彼我本。终始所起无所不达。至诚不虚神足无猗无所不现。是为菩萨五神通。又心自在所作具足。是为娱乐。示现佛身而般泥洹不永灭度。何谓菩萨漏尽神通。菩萨超越声闻缘觉。所得解脱猗于佛慧。晓了众生一切本净。不尽诸漏而不取证。为一切人赞诸漏尽。是为六神通。复有四事见无盖慧。何等四。遵修慧德致此五通。行大慈大哀知四解行。奉善权慧逮四无碍。定意正受空无相无愿致三十七道品之法。是为四。佛复告龙王。何谓所见无盖。诸有尘劳除一切垢。所有挂碍现生死本导御泥洹。现声闻缘觉乘化至道场。随劝习俗示人行寂。是谓无盖。复有无盖。现一切数至无所有。现灭诸数逮无所著。虽在有数诸行之事。于无数法无所挂碍。彼无阴盖得至无为。于有为法亦无挂碍。是谓菩萨现无碍慧。复有四事。晓了众生心之所行。随习俗慧正受明了。识意所为善权方便。于诸法自在。是为四。复有五事行无厌足。何等为五。已获大安令众生安。大哀坚强。视一切人知己骨髓。随人所行而示现行。立于极上奇特之德。是为五。复有六事分别所受教化之言。何等六。逮得总持心立寂然。入审谛净心入诸慧。辩才无著无止。方便之慧次第解脱。是为六。复有八事降伏魔怨。何等八。晓了五阴譬若如幻。离贪见尘而行空事。知一切法皆无所生。随其所生如开导之。不舍道意坚强精进。不舍佛道不畏三界。离于所有观于人物。求审谛慧观无常相。积德不厌合集智慧。不乐声闻缘觉之智。是为八。复有十事离诸恐惧行菩萨事。何等十。行于布施以庄严想。立于禁戒断诸恶趣。游于忍辱诸根不乱。坚强精进种善不惓。修行禅定其心不荒。成于智慧而离尘劳。善权方便晓了无边圣智之愿得分别事。解知法义辩才随顺。逮得总持决除众生诸所狐疑。得住佛住护一切法。是为十。复有八事御退转者。何等八。言行相应。自省己过不说彼阙。宁失身命不造轻重。获利不喜无利不戚。心不怀害诱导一切兴众祐意。等敷禁戒不舍师法。安悦众人不自求安。一切所爱施而不悔。是为八。复有五事得不退转于无上正真道。何等五。善权方便成诸度无疑。入深妙法了审谛义。神通无碍见众生根分别诸慧。行无所著行不可尽。游于缘起不尽一切诸漏之证。是为五。复有三事逮不起忍。何等三。察人清净而无吾我。法净寂寞。慧净无著。是为三。复有三事过诸清净。过去清净诸法常尽。当来清净法无所起。今现清净法无所住。是为三。复有三事。身行清净功德炽盛。口言清净智慧巍巍。意念清净定而不转。是为三。复有四事。为佛世尊所见授决。何等四。情性和顺奉遵于法。具足诸行观清白行。逮得慧力解一切心。了诸法本净不起不灭所由不乱。佛告龙王。是为四法菩萨所行。为佛世尊所见授决

    分别品第二

佛说是已。十二亿百千诸天龙神香音神人与非人。皆发无上正真道意。七万二千菩萨得不起法忍。百四十万众得法眼净远尘离垢。八千比丘漏尽意解。五千天子得离爱欲。三千大千世界六返震动。其大光明普照世界。空中自然而雨天华。诸天在上鼓百千伎乐。共叹颂曰。今者如来所说经法。为再转法轮。在波罗奈所转法轮。今说斯经复加增倍。所以者何。于此经者。为无央数不可计人开导利义。若人闻此德本不忘。何况受持能奉行者。善得人身快见如来谛闻此法。闻此法已便发无上正真道者。闭塞恶趣开天人迹。当观此比如获灭度。于是世尊。赞诸天子曰。善哉善哉。快说此言。闻斯经法欢喜信者。佛所建立开化大乘。是等之类逮如来慧。不退转印而以印之。终不余趣顺至佛道超诸苦难。于是龙王闻说斯经。欣然喜踊善心生焉。有摩尼珠名曰立海清净宝严普明。价直三千大千世界。以奉世尊。其珠之光覆蔽日月之明。一切众会得未曾有。礼佛而住同音而叹。佛兴难值既兴于世。乃现若兹未曾有法。时海龙王献宝珠已。而白佛言。以是德本逮得无碍佛身光明。令其光明普照十方诸佛国土。若人蒙光除诸尘劳。如今如来眉间光明。令我如是蠲却众冥逮平等觉。其入邪者令立正道

    六度品第三

海龙王白佛。何谓菩萨蠲却众冥。佛语龙王。菩萨智慧殊异。手执慧灯。分明智慧。智慧最胜。持智慧剑有所兴造。皆以智慧建立智慧。而以布施持戒忍辱精进禅思智慧。建立智慧。修行于戒忍辱精进一心。普观诸法建立智慧开化众生。菩萨何谓建立智慧而行布施等于布施。布施已等等于吾我。吾我已等便等于人。已等于人诸法得等。诸法已等得诸佛等。虽有所施不舍是等。既所施者不随尘劳。而以施时舍一切尘。亦复如是。舍一切生则一切施。离诸住见弃诸所有。是为菩萨建立智慧而以施彼。何谓菩萨建立智慧而奉禁戒。见身意寂斯护禁戒。不倚身口意。不倚今世后世。亦无内外。不倚阴盖四大诸入。不倚觉意。不倚灭度。于一切法亦无所倚。则为护戒。不以戒戏。亦不放逸。是为菩萨建立慧戒。彼行忍辱亦不得我。亦不得人。亦不得我人。不住吾所。不住我所我。净人净我净人净见。一切法净是为行忍。彼虽行忍于法无作。于法不起不灭。彼虽行忍。于诸法无寂不寂。彼虽行忍。见人空寂而无吾我。亦不恐怖。彼虽行忍。亦不得身口意。彼虽坏身段节解之。自观其身如草木墙壁。则为忍辱。彼闻恶言骂言自在言。不可取言。清净言无处所。晓了所言则为忍辱。彼虽乱心心无所结。本无之心各各无实须臾灭尽。以观如此则为忍辱。是为菩萨建立慧忍。彼修精进长诸善法。观其法界不增不减等御法界。察一切法不见诸法。立成就者。观猗世者。由从不实颠倒而兴。彼以清净智慧之明。观一切法不随诸法。不舍诸法。不睹诸法之所积聚。不见去来何所从来何所从去。晓了诸法。遵法如是分别苦谛颠倒之事。为人说法修行精进。彼诸众生无实无谛。若人无得。一切诸法亦不可得。所以者何。人不离法法不离人。如人自然吾我自然。吾我自然诸法自然诸法自然佛法自然。其以如是求诸佛法。如自然者解自然已便逮佛法。其有求者。若已求者。甫当求者。彼求此已求无所得。是为菩萨建立智慧精进之行。彼于禅定而以正受不坏平等。亦不成就。彼于禅定而以正受诸法无思。亦无所舍。亦不合会。于诸境界行无著禅。立诸禅法。于诸法等亦无错乱。非身非心。思惟禅定志性。无所应行。不以禅行。等于本无而以正受。于本净法而致平等。等一切人则致平等。诸法本净等无有色。不以三昧。所行如应。心而不住内。亦不起游外。识无所住。度于一切堕颠倒者。超外五通声闻缘觉禅定正受。彼以禅定出智慧上除尘劳见。彼以禅定志愿于道开化众生。是则如来常一禅定至于灭度。是为菩萨建立慧定。彼观诸法以慧眼察。亦非肉眼亦不天眼。观诸法已。见诸法寂观诸法默。诸法寂寞无行无处。诸法澹然无所成就。普观诸法皆已如是。如是观者是为法观。法观如是不见诸法之所归趣。其有见法而不观者。不以见法而成观也。无求无晓不知不见。是为见法。无我无人无寿无命。是为见法。假使菩萨观法如此。见人颠倒益于众生。而发大哀。法净如是众人猗着。于是菩萨发弘大志欲度群萌。是群萌者常无萌类。是为菩萨建立慧法

    无尽藏品第四

佛告龙王。何谓菩萨建立智慧。为人说法不见有人。人者无我无人非身人者寂寞。人无所有。人者本净。人者音声。人者名耳。人空无相无愿。人非有数。人而审谛。人无所生。人不有起。为人说法。讲人清净不怀吾我。无寿无命。不灭自然。不灭所有。随人本行而为说法。何况众生本净自然。无我自然。无形自然。则人自然。设人自然。以此自然诸法自然。设诸法自然。一切佛法亦复自然。是谓一切诸法悉为佛法。一切诸法但假名耳。因号有名。设说诸法则讲非法。所以者何。如法所言非法亦然。如呼法音则非法音。所以者何。诸法法界及与本净不可言说。亦无所得。法界本净亦无所持。一切法界诸法本净。坏一切法何所成就。是为诸佛法为说经法。以是因缘寂寞如是。不有诸佛法声之化识也。佛法无教而不可处有为无为。所以者何。不离有为无为而以解脱。宁有异法可计数乎。龙王答曰。不也世尊。诸法无数如来无数。佛言。如是如是。如仁所言。诸法无数如来无数则无有二。于龙王意云何。无数之言有处所乎。答曰。不也世尊。佛言。何以故。当知当作斯观。佛法无处无言。如佛法无言无处。一切诸法无处无言亦复如是。龙王观视如来大哀巍巍。若兹开化众生令立坚固。又一切法无处无教。说因缘教。是法有漏是法无漏。是有世是度世事。有着无著有数无数。有为无为尘劳嗔恨。习是舍是。凡法圣法。学法不学法。声闻法缘觉法。菩萨法佛法。佛言。龙王。如来如是为人说法讲其处所。亦不见法无诸法想。譬如有人虚空无色无见。欲以诸色画于虚空。而作天像及诸人像象马步乘。彼人画是宁难不乎。答曰。甚难甚难。至未曾有。天中之天。佛言。龙王。如来所为甚难。于彼诸法无色无取而不可见。亦无文字。亦无所得。而为一切讲说言教示现文字。设以方便此乃甚难。其有信入如是像法。是等诸人多所成办。若有受此深妙义者。不为诸魔之所得便。忆念我过世。龙王。更见供事无央数佛。恒辄舍家净修梵行。彼如来等未曾为吾说深妙法。应病如讲布施持戒学道之法。听闻忍辱仁和之教。燕居静处止足功德所以者何。行德未了。了行德已。从大殊曜。如来即得闻斯深妙之法。应时逮成。柔顺法忍。以是之故。当知此义。当作是观闻是深法功德具足。从过去正觉受此深经。无想无名众秽因缘。无我无人无寿无命。信乐受持讽诵为他人说其福甚多。若有菩萨愍伤一切欲令安隐。使三千大千世界一一众生皆得所安。诸天人民合集此德。施与一人。于龙王意云何。菩萨宁为众生加无极安不乎。答曰。甚多甚多天中天。佛言。其有菩萨施诸众生若干安隐。若为人说一句无常苦空非身之义。空无相无愿。无我无人无寿无命不生不起之事。则是施安福难称量。所以者何。有为之安众生皆更。无为之安未曾历也。彼其以此深妙之法而畅音声。于无为安以为服食。是故菩萨欲自立义具世人愿。当学深妙之法。若有菩萨所在会坐。舍深妙法说杂句饰。则为断绝正法之化。所以者何。是深妙法布阎浮利而不没尽。人所听受。乐于法者不足言耳非人最多。假使法师藏深妙法。读杂句者不乐深法。天则不欢悦。是族姓子。随世所乐而说俗事。呜呼痛哉。此众会中无说法者。心怀悁戚而退舍去。时海龙王白世尊曰。布施持戒学道之法是俗事耶。弃家出学净修梵行非佛法耶。世尊答曰。诸佛兴已起无起法。于三界行有所救护。皆是俗事非是佛语。彼则何谓四禅。四等心。四无色定。五通十善之行。布施持戒忍辱精进一心智慧。书疏校计。经卷体医。方药巧工技术。身想。衣食财物。所爱禅定。在三界行皆是俗事非为佛言。佛告龙王。佛兴于世间。未曾所闻非常之苦非我之寂。除于苦义。断乎习义。证于尽义。遵修道义。入乎空义度于无想。导御无愿。于诸众行不生不起。义意止意断根力神足觉意观八寂路。求真谛本净。如无所起阴种诸入。为空寂义。所由诸义。不坏诸法不坏非法。解一切法不生不长。皆无所起。不计有常无常。由因缘起得无所生。还于本净而离色欲。现无数法入于道法。在于道法无想不想无应不应。舍于一切念净不净想。无举无下。阴幽冥门自然如空。得平等行。于想等想无想。于想离想。均于一想离一切想。无所观见寂然诸所见。现诸颠倒一切平等。谓得果迹皆音声耳。彼无所得亦无不得。不受不舍。佛语龙王。是所先说诸法之御。所得不可称说。至于声闻获声闻乘。至于缘觉获缘觉乘。菩萨逮得不起法忍。成于如来无上正真道。为最正觉。斯谓佛言。是所言者随习俗教。皆是佛法教于真谛。佛道无文佛言无言。佛教无迹佛教无想。佛教无叹。佛教无化。佛教无正。佛教无名。佛教无思。佛无心意识。亦无所念。是谓佛教。而不可说。亦无言教。不可指现。佛语龙王。如是比教乃为佛言。如来不以文义说法。无文字教而为说法。是故无文则为佛教。佛所说法不有所逮。灭一切得佛所说法。是故无得为佛所言。佛所说经曾无言教。寂灭言教。以故言曰无教佛言。说法无取法无猗法。无放逸法不想法。无起法。无坏法。无究竟法。无所得法。无所志法。无所念法。无所行法。无分别法。无有想法。无所至法。无所推法。佛语龙王。如来为人说法。未曾有行有所证也。吾之所言一切本净法无形色。是故龙王。诸法无像是名佛言。又复何谓号为佛言。解一切音无所不达故曰佛言。察去来今无所挂碍故曰佛言。觉了众言故曰佛言。报答诸问故曰佛言。一切所说因缘有言无所不博故曰佛言。觉诸所说如呼声响故曰佛言。无字无说故曰佛言。诸所字说亦皆佛言。所以者何。是诸文字去来今。佛所说。今佛所说者。已说之者。当来说者。以是之故。一切文字诸所言教皆名佛言。入如此比晓了众慧。是谓菩萨分别道义。故曰文字言说皆号佛言。不坏法界志一味慧。是谓菩萨分别经本。故曰文字言说皆号佛言。其有如应顺于法慧。是谓菩萨分别顺寂。故曰文字言说皆号佛言。其有说慧无处无著。是谓菩萨分别晓了。是故龙王。一切诸法莫不归此。分别四义。菩萨解四义者。文字言说诸所归趣。身有所在莫不诱进皆入佛教。是故无著本无所住。于百千劫有所言说无能制者。所以者何。是名曰无尽之藏总持门也。假使菩萨逮斯持者。说无尽句善顺于教。弃去来瑕如应无猗庄严百千真妙之句。忍于本净将护不乱。尊卑之义晓了平等。光曜所有尘劳嗔恚。入一切行而顺解脱。八万四千诸根寻如所应。善讲本性而为说法。不尽八难音声诸法。亦无有尽。及譬喻慧三世无尽。及报应果愿可尽耶经典顺普可尽耶。心之所入可尽耶。因缘愚迹可尽耶。顺在爱欲可尽耶。发于斯持可尽耶。说乘所处可尽耶。分别法处可尽耶。深妙杂句可尽耶。至于究竟可尽耶。逆顺之言可尽耶。名字之训可尽耶。叹佛法众可尽耶。说正谛可尽耶。佛道法品可尽耶。罪福所应可尽耶。讲度无极可尽耶。佛语龙王。是名曰所说无尽故。号无尽法藏为总持门也

佛说海龙王经卷第一佛说海龙王经卷第二

        西晋月氏国三藏竺法护译

    总持品第五

佛告龙王。有四事法无尽之教无尽之藏为总持也。何等四。分别无尽。慧无尽。明智无尽。总持辩才无尽。是为四。复有四事难摄无尽之藏为总持也。何等四。其性难摄。道心难摄。入法难摄入。众生行难摄。是为四。复有四坚固要无尽之藏为总持也。何等四。所愿坚固。奉行坚固。立忍坚固。度于因缘所造坚固。是为四。复有四所说无尽之藏为总持也。何等四。讲诸至诚。讲诸缘起。讲众生行。讲诸乘本无慧。是为四。复有四光无尽之藏为总持也。何等四。照于法界。照于智慧。照于慧明。照于如应之所说法。是为四。复有四上曜无尽之藏为总持也。何等四。精进为上。禁戒修行勤力为上。求积功德为上。合聚求慧为上。是为四。复有四无穷无尽之藏为总持也。何等四。求诸度无极而无穷极。不厌生死而无穷极。开化度人而无穷极。求诸通慧而无穷极。是为四。复有四无厌无尽之藏为总持也。何等四。佛前听经而无厌足。为人说经而无厌足。求诸德本而无厌足。供养如来而无厌足。是为四。复有四无能胜者无尽之藏为总持也。何等四。一切尘劳亦无能胜。一切诸魔亦不能胜。诸外异道亦不能胜。一切怨敌亦不能胜。是为四。复有四无习无尽之藏为总持也。何等四。不习声闻缘觉之乘。不习一切供养之利。不习一切诸所著求。不习一切诸凡夫行。是为四。复有四无得无尽之藏为总持也。何等四。不得所生。不得开化恶戒之人。不得说经在于有为为上大乘。不得乞求。是为四。复有四力无尽之藏为总持。何等四。忍力忍于一切所作。众恶慧力蠲除一切众生疑结。神通力见一切众生心之所念。善权力为一切人如应说法。是为四。复有四大藏无尽之藏为总持。何等四。不自侵欺而断三宝是则大藏。入于无量之法是则大藏。得一切心随其所志是则大藏。慧等如空是则大藏。是为四。复有四无极无尽之藏为总持。何等四。博闻无极。智慧无极。所愿无极。顺众生说法无极。是为四。菩萨复有四事不自侵至无尽之藏为总持。何等四。说法不自侵。说至诚不自侵。顺法行不自侵。得至道极不自侵。是谓四。复有四事得无所畏无尽之藏为总持。何等四。不畏恶趣。不畏众会。不畏决疑。不畏失佛道。是为四无尽之藏为总持也

佛告龙王。是无尽藏总持。说德无量。入无极慧集菩萨行。所可由慧。光曜庄严菩萨所求。菩萨财宝所入法藏。入总持门分别言教。严身口意得净诸国。合集自在护念正道。入众生敷慧化导。正法力精进具诸度无极。严净道场逮诸佛法。是谓无尽之藏总持。其有文名字号之数及法诸数。游于正法。皆来归斯无尽之藏为总持也。菩萨入斯于诸文字无所分别。诸法清白不坏本净故。乐一切法不侵乐法故。究竟诸法所志诸法亦无侵欺故。一切眼法不侵诸法明故。诸法假号不侵会法故。以逮诸法不侵行精进故。诸法调定于柔顺法无所侵故。诸法说之无侵光曜焚烧诸法。于无起法而无侵故。信一切法于所好法亦无侵故。说一切法于诸言教无所侵故。诸法本无于无趣法而无侵故。诸法审谛等三世法亦无侵故。诸法常住于不动法亦不侵故。诸法有哀随本所乐而为现法故。诸法悉等说无差特故。诸法求迹示现诸法至平等故。诸法所至示现入深道门故。诸法至力现诸上法故。诸法愚冥为现智明故。怀来诸法示现诸法无所亡失故。总持诸法示现诸法为无尽故。诸法寂然现憺怕故。诸法虚空而为示现广普之法故。诸法无明现痴本故。诸法悉住现所立处故诸法入慧现离痴法故。诸法人也而为示现分别诸法故。诸法离有而为示现离所有法故。诸法有难而为示现诸法瑕秽故。诸法常念而为示现宿命事故。诸法有缘示现诸法而有侵故。诸法入志而为示现寂诸乱故。诸法极重而为示现无所动法故。诸法住处而为示现众法界处故。诸法导师而为示现审谛之法故。诸法致果而为示现志无所念故。诸法唯阴而为示现蠲除五阴诸法苦患故。诸法生死示现诸法无尘故。诸法寂空示现诸法无所猗故。诸法如固示现诸法断众固故。诸法寂灭示现诸法断因缘故。佛语龙王。是名曰文字缘会无尽藏总持。菩萨得是分别一切文字所兴。譬如文字而不可尽。诸法所说不可尽亦复如是。譬如文字亦不从身出。不从心出。诸法如是不可知处。不住在身不住在心。譬如文字无所依倚。而求解说尘劳之事。亦无所净。菩萨已得无尽藏总持。虽说尘劳。不着尘垢究竟本净。譬如文字不合在身。然为他人有所解说。诸法如是。有所发起教心清净。如文字有所说时无所至凑。无所言时不处在内。诸法如是。假使说时无所至到。设不说时不积在内。如文字无色无见而现在外。诸色如是。无色无见由心因缘而有退转。如文字虚自在寂寞。悉以恍惚无作字者。诸法如是。虚静寂寞莫有造作。如文字不出染污嗔恚愚痴。又因文字而有音教。诸法如是。不出染污贪騃之惑。由从想念起淫怒痴。如文字因诸贪缘说得果证。文字无得亦无有证。诸法如是因其缘对说有果证。计于本法无果无证。譬如诸法无不因字。诸行如是所有诸法皆由佛道

    总持身品第六

佛语龙王。菩萨已住无尽藏。而以文字求于佛道总持文字力也。归趣文字身也。灭尽像色也。入法门顶也。观瞻额也。慧眼眼也。天耳耳也。说名字鼻也。制乱意眉间阙庭也。摄一切心面也。解喻一切可众生心舌根也。调定其心齿也。师子观奋迅髭也。藏匿空语唇也。观一切法咽也。勉出众生令其欢悦肩也。端正所谓脾也。察诸法等腹也。入于深门脐也。入左右路掌也。合会诸法臂也。十善之句为善救护指也。清净法铜爪也。来致虚无之念胁也。次第讲法脊也。说不侵时无所为度尻也。具足寂观髌也。趣审谛法膝也。晓知一切踹也。心意寂然足趺也。游到十方足心也。次第说谛步也。知羞惭耻衣也。法鬘庄严傅饰也。法华若干卧具也。说种种法枕也。不嗔不诤涂香也。所行如应无所不了杂香也。入深戒说香也。于诸法自在眷属也。嗟叹梵迹则亲友也。得安隐众知识也。断诸结缚开化众人则亲匿也。晓了诸事家室也。其心清净母也。一切巧便无所依信慧父也。诸通慧心从等也。施度无极浆食也。戒度无极泰安也。忍度无极庄严也。精进度无极作善克办也。一心度无极饱满也。智度无极随时顺也。善权度无极二句合义也。道品身支党也。讲说至诚未曾侵欺。一切世间尊豪自由于法自恣。佛语龙王。是为无尽之藏总持。无色像身也。其有菩萨于是总持乐法之乐。譬如国王在于中宫。如天帝释在须弥顶威神巍巍。如梵天尊豪自在。如燕居阿须轮难可制持。如海无边功德超殊。如宝大山天所娱乐。如父母独有一子爱重无极。如月盛满众星独明莫不稽首。如世尊为天世人奋大光明。如日初出光曜柔和。如孔雀在林树间放妙音声。如师子在岩窟中服美饮食。如龙心意调和以时澍雨。如转轮王大法化国。如众龙舞动发雷电。如龙王已得自在降大法雨。如天帝释抚化一切诸外异道。如勇猛将摧伏严敌。除诸劳垢降纳众魔。如水消火如风靡草。心计如地。开化明者随化众生。如火焚草。皆忍苦乐。如乳母养长者子。疗治众病持心坚强具众人愿。如意珠王总持诸宝。佛语龙王。其有菩萨住无尽之藏总持门者。则可谓入佛之道场。如大海含受众宝诸珍苑府。无尽之藏总持如是。包弘诸法道宝箧藏。如无数香箧令无量人恣意所欲。菩萨已住无尽之藏总持门者。以真妙言开化一切令各得所。是总持者入一切声。此土名道心者。彼无尽世界佛一宝盖如来国曰目前。此名诸通慧者。彼超得度世界导龙如来佛国曰普达。此名施度无极者。彼寂定世界吉祥如来佛国曰精气。此名戒度无极者。彼无忧世界离忧如来佛国曰多安。此名忍度无极者。彼无垢世界离垢如来佛国曰无尽句。此名进度无极者。彼普明世界无垢光如来佛国曰上度。此名专度无极者。彼道御世界坚要如来佛国曰寂行。此名智度无极者。彼阴雨世界雨王如来佛国曰清净。此名善权方便者。彼尊调世界离垢辟如来佛国曰随习俗宜。此名慈哀喜护者。彼丰盛世界吉祥义如来佛国曰怜伤仁摄彼我二寂。此名苦习尽道者。彼无悦世界首寂如来佛国曰本原由根根尽归本。此名四意止者。他方世界曰无止。此名四意断者。彼曰上胜。此名神足者。彼曰超步。此名五根者彼曰悦原。此名五力。彼曰坚强。此名觉意。彼曰无冥。此名八由。彼曰所度。此名分别。彼曰目见。此名护仰。彼曰随顺。此名法施。彼曰善摄。此名寂观。彼曰定察。此名脱门。彼曰离痴。此名功德。彼曰严办。此名智慧。彼曰了便。此名弃家。彼曰修行。此名具戒。彼曰无犯。此名安隐无为。彼曰寂灭度。此名曰叹佛无量。彼曰佛曰佛眼放光。佛语龙王。计诸佛国音声言训若干种教。菩萨若逮无尽之藏。皆知一切诸佛之土所说音声文字所诲。佛以一劫若过一劫。赞叹有为言说章句之教十方所出。不能究竟诸佛国土音声义也。佛说是无尽之藏总持门时。六万菩萨皆得总持。八千菩萨得不起法忍。三万二千人皆发无上正真道意

    总持门品第七

尔时佛告龙王。菩萨以是。离诸幽冥之路趣诸通慧。往古不可计无央数劫不可思议。彼时有佛号曰梵首天王如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。世界曰集异德。劫名净除。彼时集异德世界。丰盛安隐五谷自然。快乐无极天人繁炽。如我此土百亿四域合为一佛国。则为彼土一大四域。如是之比百亿顺弥山。此梵首天王如来集异德世界。广大无边乃如兹乎。其世界如金刚光明摩尼之宝。自然常普大明。以宝交络周匝覆盖悬缯幢幡。百千伎乐于虚空中不鼓自鸣。其伎乐音普闻佛土。彼伎乐音。不出淫怒痴欲之音声也。唯演寂然憺怕法乐欢喜之音。诸天人民闻乐音者。则逮一心寂定安隐。晏然不为尘劳之所危害也。其土平等如柔软衣。无有恶趣音声诲也。天人清净皆解微妙志于大乘。少求声闻缘觉之乘。心有所念依食室宇所欲随意悉自然至。天人一等无有穷厄匮乏者也。衣服饮食如兜术天上。其国所有等无差特。其如来寿命满六十七万二千岁。其土人民寿亦复如是。无中夭者。佛土菩萨七十二那术。声闻甚少。尔时有转轮圣王号无尽福。主十六四天下。其无尽福王有八十四那术夫人。如天玉女。有四太后。一名离垢。二曰无垢光。三曰清净。四曰净句子。有八万四千皆大猛勇身相。有八端正姝好。皆志大乘。彼时无尽福王处于大城。名曰具乐。其城东西长二千四百四十里。南北亦尔。梵首天王如来兴于彼国。无尽福王建立精舍殖大林树。名上香光园佛所游止。城之中央造王宫殿七宝合成。城中有八万四千街巷八万四千栏楯。一一街巷有八万四千家居。其大城壁七重。七重栏楯七重行树七重交路。绕城有万游观园。其堑七重满八味水。生青莲红莲黄莲白莲皆有美香。鸳鸯凫雁相随而鸣。其城如是名等无量不可思议。王供养佛奉进所安。众事具足无所乏少。于百千岁不可称限。率其中宫子孙亲族友党眷属国中人民往诣上香光丛林。见梵首天王如来。稽首佛足退住一面。佛告王曰。有四事为大国王君子圣主。犹得自在与众不同增益善法。何等为四。立于笃信数诣贤圣。乐欣请益求德慕义。以法自娱常观无常苦空非身之法。观世所有有为之秽皆归离别。自摄其心入无放逸。觉察欲乐无所饶羡。不以毁断宿世福德。不废道心务志妙慧。是为四事大国圣主犹得自在与众不同。无尽福王白世尊曰。菩萨有几法而得自在。佛告王曰。菩萨有八法而得自在。何谓为八。得五神通以自娱乐未曾有退无所挂碍。并除嗔恨而无害心。具畅圣慧摄于道明。所作已办现得睿达。诚信神足拔诸所有。以智慧圣舍离一切邪见尘垢。得四解明佛所建立无著不住。具足力处逮于无尽福海印三昧。能悦众生摄御一切诸佛之教以成总持。其心清净所闻不忘。应如所欲而为说法。入一义味住于本际。不计吾我不起法忍。是为八事菩萨而得自在。佛告王曰。又有总持名曰宝事。菩萨逮得此总持者于法自在。时佛为王说宝事总持之慧。满百千岁普分别义。王舍国事一切众缘。专精一心及与眷属听受道化。于百千岁未曾想欲。无嗔恨意。不含想害。不顾妻子国土眷属。一切所有永不以计。唯愿法乐立志佛道。大慈清净等心一切而行大哀。被大德铠而听受法。如是之比具百千岁受佛诲已。因此宝事总持之要。所作则办。越七百万劫终始之患。积十万劫除诸罪殃。见亿百千佛从受德本。于恒沙等作天帝释。若为梵天转轮圣王。积功累德。以清净心志御诸法用心不乱。闻百千佛受法不忘。时王诸子皆悉逮得柔顺法忍。中宫婇女八万四千普发道意为菩萨学。八万四千人逮得法忍。九十那术诸天人民皆发无上正真道意。三十六那术学声闻乘得法眼净。万六千比丘漏尽意解。无尽福王弃国损王不慕天上世间诸乐。唯志无上正真之道。因家之信出家为道而作沙门。诸子亦然皆作沙门。时国人见王弃国。六万人悉为沙门。中宫婇女四大夫人亦为沙门。佛教清净普蒙安隐。殖诸德本众行具足。佛言。龙王尔时无尽福王转轮圣帝。非是余人则尔身是也。尔时转轮圣王诸子今此会中诸菩萨大士是也。时彼梵首天王如来。为王无尽福。所说宝事总持。则今佛所说无尽藏总持是。佛语龙王。今如来以无著慧。观察人本而为说法。从无央数百千亿那术诸佛。闻无尽藏总持。以此数闻之故。今乃如斯志念强勇独步无碍。辩才难及志怀智慧。若有菩萨。闻是无尽总持之名。其有说者皆当逮得无著辩才。所以者何。由是总持。后当来世是离垢总持所流布处。皆是如来之所建立八万四千法藏。是总持门为首面也。八万四千行皆来归于总持。八万四千三昧皆从总持。八万四千总持无尽之藏总持为本原。佛语龙王。假使菩萨无住无著。于四解义则降大法雨。皆来依猗此无尽之藏。此无尽之藏总持所入正句次第顺章。诸天龙神。香音神。无善神。凤凰神。甜柔神。皆共营护

缘应意　随顺意　欣乐迹　直意　越度　无尽句　次第　曜面　光目　光英　志造　净意　行步入　勇力　济冥　所持　为上　寂门　入寂　灭尘　离居　居善　随顺　离次　无所至　所住　无所住　至处　无至处　要御　速慧　智根　转本根　月光　日转焰　光善离垢　无垢　净诸垢　觉所建立　诸天祐　护诸魅　告乘　梵知化　释咨嗟　四天护　众圣爱　仙人归　诸姓修行　解牢狱缚　天人所摄　舍诸尘劳　破坏众魔　降伏外道　摄欲明智　开化自大　不犯法师　不乱众会　悦可乐法　护于法音　不断三宝　慈愍众生　赞慕德义(六十二事)

佛告龙王是诸法句。为护无尽之藏总持。其有法师受是章句六十二事。若讽诵者得三十二无所畏。何谓三十二。博闻无畏。咨嗟他人处处无畏。言无缺短如应无畏弃捐郑重而无所畏。随音所入辩才无畏。无所挂碍其心无畏。奉受道心其志无畏欢悦众人行步无畏。速决狐疑觉意无畏。观察众人无阙无畏。言行相应无缺无畏。戒禁清净心面无畏。忍辱清净坚强无畏。于审谛愿而不转还所处无畏。心不谬乱辩慧无畏。能悦众会智慧无畏。知深妙法降化无畏。离于调戏师子无畏。伏诸外道无受无畏。无衣食悦无瑕无畏。降伏众贼令住正见无愆无畏。智者不毁导御无畏。不乱众经说等无畏。随时而教无谄无畏。言行相应离慢无畏。见一切人谦顺无畏。无尽句本行修善发遣所问无畏。开化一切无量法教随众无畏。己身净故降魔无畏。除诸尘劳大悲无畏。心不怀害大哀无畏。将护众生智慧无畏。以法治国

佛语龙王。菩萨闻是无尽之藏总持欢喜信。便得三十二无畏。假使不断。是三十二无畏。稍稍渐成如来四无所畏佛之所有无所畏。诸天人前为师子吼。恣听一切所可欲问。都无有人能来穷极如来之智。亦不敢断佛所说。是故菩萨欲致是无所畏者。当学行无尽藏总持。何所是总持所学行。无眼行无色行。无眼色识行。无耳行无声行。无耳声识行。无鼻行无香行。无鼻香识行。无舌行无味行。无舌味识行。无身行无细滑行。无身细滑识行。无心行无法行。无心法识行。无色行。无色生行。无色灭行。无色处行。无痛想行。识行无识生行。无识灭行。无识处行。一切无行。是应总持行。复次龙王。其行色空心不空色。是应总持行。痛想行识。其行识空心不空识。是应总持行。复次其无想色行不念无想行。是应总持行。痛想行识亦复如是。其无想识行不念无想识行。是应总持行。复次其不断色行。于色行无行。不色生行。不色起行不色寂行。色如谛行。色如本净行。亦不念色如谛本净行。是应总持行。痛想行识亦复如是。其不断识行。于识行无行。不识生行。不识起行。不识寂行。识如谛行。识如本净行。亦不念识如谛本净行。是应总持行。复次于种由法界行。不想法界行。不想法界诸入本净空行。不想本净空。是应总持行。若一切法缘起之行。不想缘起。是应总持行。不着诸法行不猗不着行。是应总持行。诸法如本无行。不坏诸法本无之行。若于诸法住本际行。不念本际住诸法行。是应总持行。复次其知贪欲行。不于法界想念贪欲行。是应总持行。其知嗔恚行。不于法界想嗔恚行。是应总持行。其知愚痴行。不于法界想愚痴行。是应总持行。其等分行。不于等分行于法界有所坏行。若于八万四千诸所修行。入于法界无若干行。是应总持行。若行若合行。于行合行而无所行。亦无不行。所以者何。其行无量亦无所度。亦无所想。是故彼行为平等行。于平等行亦无所毁。亦不有为。亦不无为。亦不受亦无不受。无处无住故曰平等行。菩萨行如是则得无尽藏总持之门也。于是世尊则说颂曰

  其人心意则清净　　普入经卷度无极
  悉解众人之音声　　得总持时乃如是
  观知群萠心所行　　善恶所念及中间
  分别本性所造兴　　则为说法随所应
  悉了因缘之报应　　令不睹常及无常
  皆以弃捐堕边际　　分别总持随顺化
  明解文字之方便　　知无央数之音响
  晓了义理微妙好　　得总持者乃如是
  逮得天眼无垢污　　天耳清净亦如是
  无量智慧知众行　　念亿千劫去来事
  获四神足亦如是　　至无量国须臾顷
  供无数亿诸导师　　闻所讲法则总持
  若干亿魔至百千　　不能睹知境界行
  清净之人无尘埃　　讲说经法无数千
  譬如莲华无著水　　不猗世法亦如是
  常以解脱诸有无　　等心一切如虚空
  持最色相而勇猛　　众人观仰无厌足
  进止安详行无缺　　愍伤群萠故游世
  天帝释梵及护世　　皆以恭敬稽首礼
  其心不以憍慢说　　得总持时亦如是
  口言柔软如梵音　　为众人说可其心
  温润流利言得时　　所可教化无所覆
  在于众中无所畏　　为师子吼妙无难
  降伏一切众粗人　　得净总持为如是
  其谀谄人难调化　　兴于憍傲而自大
  闻彼圣明所说法　　即弃贡高稽首礼
  入于本净寂法界　　以达义归解诸法
  以故所说无穷已　　分别文字知法律
  人之本性法界净　　晓众生净亦如是
  解知本无人本无　　所说经法无挂碍
  所尽无尽不可知　　无尽之事无能尽
  觉了知是趣寂寞　　则说无住亿经卷
  斯诸文字不处身　　亦不在意不住心
  文字本性空寂寞　　譬如山中呼声响
  计总持者不着字　　无音无言无说声
  以知文字所趣然　　假使所说无挂碍
  无意无想亦无心　　设有所说无所念
  又复解知去法慧　　讲顺说经随所应
  以入分别四句义　　晓了义理明识法
  究畅音声顺所听　　故讲无著不可量
  玩习本原承其慧　　故说深要若干法
  所解之慧了逆顺　　有趣顶法度无极
  方便所有诸怯弱　　以用救摄诸卒暴
  明识所作为解说　　得总持者乃如是
  其身口意皆已寂　　分别诸慧不着古
  所言无厌除嗔恨　　得住总持为勇猛
  其所总持心执御　　意之所入住法慧
  其有闻者未曾忘　　顺如听采等经典
  其总持义法不乱　　计法行之无所入
  以法等故曰平等　　如应平等顺清净

    分别名品第八

佛说此章句偈时。海龙王眷属万三千龙。皆发无上正真道意。则更启曰。广宣此言。唯然世尊。我等亦当逮是无尽之藏总持也。当为一切众生之类广说经法。尔时贤者舍利弗白佛言至未曾有。世尊。乃令诸龙发无上正真道意。人反不能发大道也。佛告舍利弗。是万三千龙。迦叶佛时皆作沙门。从迦叶如来一反闻菩萨行。同时欢喜赞曰。善哉善哉。说大乘事不可思议。与族党知友俱行分卫。贪利不慎不护禁戒。以是之故。寿终之后堕于龙中。彼时从迦叶佛闻大乘教。赞迦叶佛。因由报应德本之缘。今闻吾说咨嗟大乘。讲无尽藏总持。皆发无上正真道意。舍利弗。观是至心之奇特。今吾授决。恒沙等劫供养诸佛积累道品。自致得成无上正真道。号曰慧上智上法上梵上。得成佛时以是四事。号世界曰无垢藏。劫名大欣。皆同一劫得成无上正真道最正觉。犹如贤劫当兴千佛

    授决品第九

于是海龙王白佛言。我从初劫住止大海。从拘楼秦如来兴于世来。大海之中诸龙妻子眷属甚少。今海龙众妻子眷属繁裔弘多。设欲计挍不可穷尽。唯然世尊。如此云何有何变怪。佛告龙王。其于佛法出家奉律行戒不具。现戒成就违戒犯行。不舍直见不堕地狱。如斯之类寿终已后皆生龙中。佛语龙王。拘楼秦佛时。九十八亿居家出家。违其禁戒皆生龙中。拘那含牟尼佛时。八十亿居家出家毁戒恣心。寿终之后皆生龙中。迦叶佛时。六十四亿居家出家犯戒。寿终之后皆生龙中。于我世中。九百九十亿居家出家若干斗诤。习若干行。诽谤经戒。寿终之后皆生龙中。今有生者。佛语龙王。以是之故仁在大海中。诸龙妻子眷属不可称计。我般泥洹后多有恶比丘恶优婆塞。违失禁戒当生龙中。或堕地狱。海龙王白佛言。于今弃家为道。犯戒比丘堕龙中者。有何殊特。佛言。弃家学行。于今犯戒比丘堕龙中者。行于方便不能清净。又有至心信于佛法。以至心力龙中寿终生天上人间。当见贤劫所兴诸佛。皆当见之。假使不以解脱者。悉于拔陀劫中般泥洹。除志大乘者。龙王。且观佛教广大因缘出家之奇特。弃诸恶法得超异类。尔时有龙王子。号曰威首。前白佛言。至未曾有。世尊。龙近如来难值难闻。虽有所毁作众罪殃。发一善意心念佛法终不失德。缘是之行至得灭度。今我愿发无上正真道意。用佛世尊难值难闻。令菩萨行无有违缺至于道场。莫使心中忘失德本。大慈大哀大喜大护所生之处。常见诸佛得闻经法。供养众僧开化众生尔时世尊告威首龙王子曰。善哉善哉。仁者之问。乃发救护一切之心。今汝至心兴无极哀。而起道意。缘彼德本如来嗟叹。七日七月若至一年。为功德福而不可尽。所植善行乃如是也。佛见威首龙王子心之所念。即时欣笑。诸佛笑法无央数色。色色各异。光从口出照不可计诸佛世界。绕身三匝还从顶入。尔时贤者阿难。以偈赞佛

  百福功德庄严身　　体诸相好三十二
  清净无垢如月光　　今之所笑何感欣
  静无尘埃离三垢　　如百叶华行无惓
  天人龙神所奉敬　　安住今者何因笑
  善哉平等齿普净　　十力威曜面香洁
  以除生死之根原　　今者世尊笑何感
  心如虚空无瑕秽　　意等善友及怨家
  持志如地无憎爱　　唯愿世尊笑何欣
  音声所讲喻梵天　　犹雷哀鸾微妙响
  所说柔软莫不欢　　唯愿世尊叹因缘
  心于圣慧无所著　　知三世人意所行
  解众人根得喜悦　　导师今笑为何感
  以为成医王　　疗治众生病
  能施究竟安　　世尊笑何缘
  护德为我说　　诸天人民闻
  皆当怀喜踊　　即志诸通慧

佛告贤者阿难。宁见威首龙王子住于佛前至意发无上正真道意不。阿难对曰。唯然已见。佛言。是威首龙王子过八百不可计会无央数劫。当得作佛号慧见如来至真等正觉。世界名净住。劫曰明察。是龙王子至诚奉行菩萨之道。见无央数诸如来供养奉事。常修梵行开化度脱无量众生使立三乘。慧见如来净住世界。丰熟安隐五谷平贱。快乐难量天人充满。犹如炎天被服饮食。其佛当寿百万岁贤圣众僧声闻有六十亿。菩萨百二十万亿。慧见如来其有觐者。皆得慈行三昧。慧见如来说经。声闻行者若始见佛则得道迹。再见得往来。三见得不还。四见得无所著。志菩萨乘者适觐慧见如来得柔顺忍。再见获神通。三见得总持辩才。四见得不起法忍。净住世界无毁戒者。意净无邪皆住正见。寿终之后无有恶趣。悉生天上清净佛土。时威首龙王子闻佛授决。欢喜踊跃善心生焉。奉百千珠璎用散佛上。而叉十指以偈赞曰

  人尊无垢如月光　　威神无量众所奉
  其力无限总持世　　愿稽首礼无边慧
  慈哀之圣不可限　　睿智无瑕不可议
  禁戒广普住正定　　稽首人尊如虚空
  无量无限亿劫数　　所行究竟无不入
  以故晓知诸众生　　心性所归诸根本
  若人睹观尊颜容　　一心察之无厌足
  不为尘埃之所惑　　爱欲之秽皆灭尽
  哀鸾拘夷诸鬼神　　梵天之音亦如是
  声闻十方甚微妙　　如来之音超于彼
  譬若如日坠于地　　海水当竭须弥坏
  虚空尚裂地反覆　　世尊所说终无异
  世尊至诚以谛说　　授我之别大圣慧
  吾无狐疑结网除　　得佛自在为众祐
  十方无量亿万国　　满中珍宝供导师
  假使有人发道心　　前所植德不及此
  供养正觉德第一　　若人志发尊佛道
  则为报恩诸十力　　用不断此导师命

龙王子说此偈赞佛已。十千人皆发无上正真道意。悉说是言。慧见如来逮得最正觉时。吾等同心共生净住世界。奉彼如来正法之教。又供养之。佛灭度后次补其处得最正觉。佛皆授决。悉当令生净住世界

佛说海龙王经卷第二佛说海龙王经卷第三

        西晋月氏国三藏竺法护译

    请佛品第十

尔时海龙王白世尊曰。唯佛加哀诸天龙神及无量人。令致安隐至于大海。诣我宫中屈神小食。所以者何。大海之中有龙鬼神香音神。及余无数众生之类。见如来已皆殖德本悉当往会。因闻法音除断无底生死之源。吾等龙宫并蒙其恩。天上世间缘得度脱。如来普现佛大道心。令我等身近道品法。佛愍龙王默受其请。及无量人悉当广殖众德之本。时海龙王见佛就请欢喜踊跃。稽首佛足右绕三匝。与眷属俱忽然不现。还在大海聚会龙民。而告之曰。吾明日请佛。佛垂矜许。汝等同心当俱供养。海龙王又告燕居无善神诳惑缚补离垢锦等曰。诸仁当知如来降神当诣此海乎。宜用身故。率诸眷属来集吾宫献馔世尊。又敕龙王。名曰主度王。叹无量王。离垢王。焰光王。戏乐王。清净王。妙曜意王。现诸难王。及余龙王百千之众。悉当来会至吾宫里奉觐如来。又敕龙子威首曰。仁者致敬宣吾命于无焚龙王。命诸海宫供养如来至真等正觉。即时受教。又敕龙王子强威。诣安明山顶。请欢喜龙王。迦欢喜龙王。及天帝释。使诸仁者。令诣大海集吾宫内供养如来。时强威即时受教。宣令如是。时海龙王化作大殿。以绀琉璃紫磨黄金而杂挍成。则建幢幡造金交露。宝珠璎珞七宝为栏楯而极广大。若干种香而以熏之。散众色华纷纷如雪。于大殿上化立师子之座。高四百八十里皆以众宝而合成。敷无数百千天缯以为綩綖。诸菩萨及比丘众所坐师子座。各各严丽阶级殊别。馔具兼重若干种味。寂然饮食供设以具。尔时龙王明旦修敬。住安明山十二之坎。与眷属俱遥请世尊。以偈颂曰

  殊特慧无量　　于法得自在
  明知成众事　　如空圣无限
  离垢眼清净　　于世为最上
  日时今已到　　唯加哀自屈
  清净音如梵　　柔软声和仁
  响雷如哀鸾　　为众现甘露
  除若干尘冥　　为众最上医
  人中宝愿来　　今正是其时
  心调柔寂寞　　志软常安和
  自度济众生　　愿救诸人民
  开化众黎庶　　使越彼四渎
  造安度彼岸　　惟屈今是时
  调仁乐布施　　学道戒清净
  忍辱力最上　　已获大精进
  灭除禅脱门　　智慧普无量
  言诲如月明　　住圣时已到
  智迹方别路　　邪径永已断
  七觉意根力　　化现以四谛
  平等四意止　　四神足意定
  总得普通达　　时到宜屈神
  三十二相明　　英妙百功德
  为存德义者　　示现大福田
  尊称为众祐　　如春萌滋茂
  唯愍伤加慈　　大哀自屈神
  志如须弥山　　心等譬如地
  除爱及嗔冥　　所说如演空
  人尊不自卑　　未曾有贡高
  归于空脱门　　屈神今正时
  知义寻分别　　晓了随顺要
  究畅解经法　　心行常如斯
  显进人本性　　观察诸慧义
  稽首最胜足　　时到屈神临

尔时世尊遥闻龙王启白。时到告诸比丘。着衣持钵当诣大海开化众生就龙宫食。比丘应曰。唯然。于时世尊与诸菩萨比丘众俱眷属围绕。踊在虚空身放大光明而雨天华。百千伎乐相和而鸣。集于海边至欣乐园。有思夷华名曰意乐。佛住止彼。时海龙王往诣佛所。稽首佛足陈敬已毕。却住一面。龙王自念。吾欲化作宝阶从海边至海底。令佛及比丘众及诸菩萨。由是下海至我宫中。如昔世尊化作宝阶。从忉利天至阎浮利。适设此念。便从海边化作三宝阶金银琉璃。下至其宫甚微妙好。于是世尊以威神力。化大海水令不复现。使海生类不以为患。佛身放光照于大海。普至三千大千世界。其海居类身蒙此光。皆怀慈愍柔仁之心不相娆害。相视如父如母。如兄如弟如子无异于时欲行天人。色行天人。侍从世尊欲听道化。犹欲观龙王庄严宫殿。时佛与诸菩萨及大声闻诸天龙神香音神无善神凤凰神山神甜柔神释梵四天王。从欣乐园思夷华树。欲诣龙宫。佛升宝阶涉于中阶。诸菩萨众住于右阶。诸大声闻住在左阶。时六十亿释而在前导。六十亿梵天皆在虚空各执宝盖。六十亿天皆在佛后而雨天华。六十亿诸欲天人作诸伎乐而供养佛。六十亿魔众皆于佛前香汁洒地。六十亿龙后在虚空中。各现半身手执珠璎垂散佛上。六十亿山神皆鼓伎乐歌佛功德。六十亿香音神手执华盖以用奉佛。六十亿无善神各持若干百千种衣以覆佛上。无焚龙王与亿百千眷属。在于虚空皆以华香杂香捣香作众伎乐庄严诸龙。及诸天华以供养佛。如是比类六万龙王皆供养佛。欲见世尊。劝海龙王。安乐世界无量寿如来佛土菩萨。号光世音大势至大士。与无央数亿诸菩萨俱。为佛世尊示现庄严诸所有供养。皆令前所严供隐蔽不现。无能知者。焰气世界难逮如来佛土菩萨。号法英法道大士。妙乐世界无怒如来佛土菩萨。号香首众香首大士。照明世界月辩如来佛土菩萨。号师子师子音大士。不眴世界善目如来佛土菩萨。号导御诸法自在大士。光曜世界普世如来佛土菩萨。号宝场宝焰大士。乐御世界宝首如来佛土菩萨。号慧步慧见大士。光察世界普观如来佛土菩萨。号雨王法王大士。爱见世界尊自在王如来佛土菩萨。号退魔后魔王大士。取要言之。如是十方各各无央数亿诸菩萨。皆来劝乐。海中龙王欲见如来供养奉事。于是世尊以大道力诸佛感动。威德所监。以佛弘威劝化无戏供养诸佛。放大光明彻照十方无量世界。以佛洪音大师子吼。而讲言化诸天百千。皆作音乐而雨天华。灭诸恶趣施于一切安隐之具。有三昧名曰立于大哀欢悦群萌。以佛三昧正受已。所作庄严光饰大海不可思议。佛从宝阶降神海宫。自然音乐普闻十方无量世界。佛之威神如来所感。皆见能仁如来下于大海。彼时亿百千玉女魔妻无善神凤凰神山神甜柔神群神妇女。皆以伎乐而行迎佛。调诸音乐而歌颂佛德

  施上戒清净　　忍力慈心尊
  精进勤御义　　礼乐禅脱门
  心净光慧智　　严明奋威神
  现在示解脱　　故来除垢尘
  施以甘露安　　道御罄众秽
  无尽德如空　　慧海愿降海
  所说具足要　　讲叹度无极
  施眼明清净　　一切人中上
  叹颂深义句　　愍人光无伦
  等祠所宣普　　降伏诸异道
  施以法无悭　　讲经净恣尘
  赞叹实慧光　　道财敷演珍
  见谛莫不受　　正观断结着
  不动如山根　　愿稽首导师
  诸天金翅鸟　　须伦真陀罗
  迦留鸠垣师　　愿稽首足下
  尊相三十二　　无比妙善现
  体柔紫金色　　爪足下安平
  妙响如哀鸾　　其声踰梵天
  大音超三千　　稽首柔软音
  根调心寂寞　　犹如月电光
  言诚常平等　　愿稽首乐法
  已度老病苦　　救一切令脱
  得胜伏众魔　　灭除生现尽
  无著蠲尘劳　　为诸天所敬
  归尊普救护　　导师开化众

    十德六度品第十一

于是王女及诸龙后无善神凤凰神山神甜柔神后共赞佛已。一切同等皆发无上正真道意。脱身璎珞用散佛上。佛与众俱降于大海。到其海城诣海龙王庄严大殿坐师子座。时诸菩萨及比丘众。各各次坐其座。于时海龙王与中宫眷属俱见佛坐已。手自斟酌寂然饮食。无央数味供养佛及比丘僧。饮食毕讫行澡水竟。坐佛前听经。及诸天龙神香音神无善神凤凰神山神甜柔神。释梵四天王及十方诸来会菩萨。于是佛见众会坐定。从身放光。光名善度脱法柔和。悉照大海诸居之类上中下品。普自见佛欢喜踊跃愿乐闻法。各以恭敬遥稽首佛。尔时世尊告海龙王。猗世间者作若干缘。心行不同罪福各异。以是之故所生殊别。龙王。且观众会及大海若干种类形貌不同。是诸形貌皆心所画。又心无色而不可见。一切诸法诳诈如是。因或兴相都无有主。随其所作各各自受。譬如画师本无造像。诸法如是而不可议。自然如幻化相皆心所作。明者见诸法因或兴相。则当奉行。诸善德者。其解或相兴成诸法荫种诸入。当欢喜悦得好端正。龙王。具观如来之身。以百千福而得合成。超于众会普现巍巍。其百千德由得自在。而使梵释覆蔽不现。观如来身目不敢视。当其威光察诸大士。色身相好庄严具足。皆以善德挍饰其体。佛语龙王。仁所严净皆因福成。诸释梵天龙鬼神香音神无善神凤凰神山神甜柔神。所有庄严皆因福生。今此大海若干种身。善恶大小广狭好丑。强羸细微皆自从心而已获之。为若干貌悉身口意之所作为。是故龙王。自护身行救济罪福。当作是学。汝等以护身行救济罪福。奉行诸善得成佛道。灭弃邪见不住有常无常之见。当求众祐已殖供养。因供养故。当为诸天世人所敬。佛语龙王。菩萨有一法皆断一切恶趣众难。何等为一。专察妙法。云何正谛。入于法乐多观善法。不听诸恶众邪之想。已断恶法奉行众善。在在所生与佛菩萨贤善性俱。佛言。何等善事已立德根天人之安。不为声闻缘觉之本。立道本者志无上正真道。何谓立本。谓行十事。何谓十。身不杀盗淫。口不妄言两舌恶口绮语。意不嫉恚痴。是谓立本

佛语龙王。人不杀生得十善寂法。何谓十。常施安隐于一切人。常乐慈心断嗔恨心。所生之处常无疾病。常种长命为非人所护。卧安寤欢未曾恶梦。不怀怨结。不畏恶趣。寿终之后得生安处。人不杀生得斯寂法。以不杀生善本之德。愿志无上正真之道。若成佛时而得自在于寿命也。佛告龙王。人不盗窃得五信法。何等五。得大富无有县官水火盗贼怨家恶子能窃取者。众所爱敬。到处寂然所至无难。患畏永除以不取之福志存慧施。殖众德本。志愿无上正真之道。以依如来无见之慧。成最正觉使立神通。佛语龙王。人不犯邪淫。得四明智所叹之德。何等四。摄护诸根离诸调戏。一切世间悉共称叹。已离邪淫无敢轻眄其妻室者。以是德本志愿无上正真之道。得大人相马阴之藏。佛语龙王。人不妄语。诸天世人以八法叹。何谓八。得面清净。语言中当一切世人所见任信。自成其证天人所敬。心怀至诚而无邪想。心意清净而无谀谄。多所欢悦无患厌者。能受禁诲无有粗言。生天上人间独见任信无有疑者。以至诚言善德之本。志愿无上正真之道。因此所行常得至诚。佛语龙王。人不两舌得五不别离。何等五。身不别离无散乱者。眷属不散。不傲他人。得信无坏见于缘报。他无坏法以行为要。得亲友和用无欺故。以是德本求最正觉。得成如来眷属无乱。一切众魔及与怨敌终不能坏如来眷属。佛语龙王。人不恶口得八清净言辞之报。寿终之后得生天上。何等八。所说如谛。所言柔软。所言如应。所言和顺。所言能受。所言光曜。所言众人莫不承乐。所言众所不讥。因是德本。志愿无上正真之道。得成如来音声超梵。佛语龙王。人不绮语得三正行。何等为三。常为众明诸等敬爱。心常专一入于至诚不以多言。于天上人间常得大尊不为杂碎。以是德本。志愿无上正真之道。为佛所授决得成如来所言无异。佛语龙王。人不嫉妒得五威神。何等五。身口意明诸根具足。得极财富而以自恣。降伏诸冤。乐于饮食美味生活之业。福德巍巍为诸国王所见恭敬。而蒙覆盖如己所有微妙之宝。致差特家功德宿本不嫉他财。因是德本。志愿无上正真之道。成等世尊三界所奉。佛语龙王。人不嗔恚得八心欢喜法。何等为八。无害乐谛灭除嗔恚。乐于诚实心不乐诤心。乐质直安祥而和。等于圣贤常怀慈心。愍伤具足见人安悦。端正殊好众人所敬。生于梵天不以为难。心以方便哀和之故。是为八。因是八德本。志愿无上正真道意。得为如来至真等正觉观无厌者

佛语龙王。人不邪见得十法德。何等十。志性真实得人善友。信善恶之报。若已没命不伤犯人。念行佛道心无有异。不事天神志怀质朴。舍于谀谄神咒之术。与诸天人以为朋友。不与地狱饿鬼畜生而作伴侣。与众特异功德巍巍圣道为上。离于邪见离于贪身。离于恶见都无挂碍。于圣平等。须臾之间生天上人间。是为十德法。已离邪见得本。志愿无上正真之道。近得诸佛道法。速逮神通。成为如来。佛语龙王。菩萨离于杀生而行布施。常得大富长寿无极行菩萨道。一切外怨莫能当者。已离盗窃而布施者。既饶财宝人不敢取。行菩萨道无能妨废。合聚一切功德之法。离于邪淫而布施者。后常大富妻无逸态。在于人间无敢犯者。其家女人而不色视。离于妄语而布施者。常大富有不被诽谤。以下劣人皆蒙拥护。行菩萨道言行相应所愿坚强。离于两舌而布施者。常大富有眷属不别。行菩萨道则得菩萨一切眷属质直等性。已离恶口而布施者。常大富有所言人受。行菩萨道入于众会莫不欣乐。离于绮语而布施者。常大富有所言辄行。行菩萨道断一切疑离于嫉妒而布施者。常大富有喜好衣食床卧具足。行菩萨道已所喜者。而以加施得大尊豪。离嗔恚心而布施者。常大富有威耀端正。所言说者众人爱乐。行菩萨道心无加害诸根具足。离于邪见而布施者。常大富有立于正见。生于族姓值佛世尊。行菩萨道不离诸佛。常得闻法发菩萨心。佛语龙王。是谓十善布施庄严广大。乃尔此十善行。以戒庄严以自具愿得诸佛法。以忍庄严诸相种好成佛音声。以精进庄严降伏魔怨。以佛道法有所超度。以禅庄严心意所趣而以清净。以智慧庄严除诸枉见。行慈庄严当以仁和不害众生。行哀庄严不舍黎庶。行喜庄严无懈厌心。行护庄严得无所著断诸疑结。行恩庄严劝化群萌。行意止庄严止身诸痛痒心法具足。行意断庄严断诸恶法具足善德。神足庄严神足轻举。五根庄严。坚固其行。以上精进而无放逸。以心修治除诸尘劳。五力庄严以质直心降化众怨。觉意庄严晓了诸法如本所由。八路庄严怀来正慧寂然庄严。灭除一切诸垢尘劳。以观庄严观诸法本审谛悉无。善权庄严。有数无数有为无为具足安隐。佛语龙王。取要言之。十善之德。具足十力四无所畏成诸佛法。以具足之故。于是十善之德。广普庄严常当精进。譬如郡国县邑村落丘聚。百谷药草树木华果种殖刈获皆因地立。十善之德天上人间皆依因之。若学不学及得果证。住缘觉道菩萨道。行诸佛道法皆由从之。于是海龙王白世尊曰。何谓入法门菩萨所行。入法门者。除于宿世阴盖之罪。已除阴盖得至超异。佛语龙王。菩萨有一法除诸罪盖。何等一。立于拥护不舍所说悔过首罪。复有二法除诸罪盖。何等二。常观净法。不造现在。复有三法除诸罪盖。何等三。入因缘慧具足悦心。依本净法了知本无。复有四法除诸罪盖。何等四。晓了于空。不住无想趣于无愿。慧无所造。复有五法除诸罪盖。何等五。无我无人无寿无命无识。复有六法除诸罪盖。何等六。欢喜笃信。而无狐疑。往返进止。观察审谛。所作至诚。不失正信。是为六法除诸罪盖。龙王白佛。何谓菩萨得至超异。世尊曰。菩萨有十事得至超异。何等十。常念欢悦。心性清净。善权方便。坚强精进。观察人物。行无极哀。修德无厌。博闻不惓。奉无放逸。念于道场。令得佛慧。不舍道心。是为十事。菩萨所行得至超异

    燕居阿须伦受决品第十二

于是燕居无善神白世尊曰。何谓菩萨超诸德上。佛告无善神。菩萨有八法超诸德上。何等为八。菩萨于是离于贡高为一切人下屈谦敬。受教恭顺言行相副谦顺尊长。一切德行诸法为本。所行坚强超诸善德。乐于微妙若干种施。宁失身命不求人便。见有危惧施以无畏。来归命者不以舍弃。求于一切福慧之业不以厌足。是为八法。无善神又问佛言。菩萨有几法行。得身长大面部弘满眷属繁炽意广无极。佛告燕居无善神。菩萨有四事得身长大。何等为四。不说他人所作贪嫉。作佛形像根相具足。和合离别劝令志于无上正真之道。向于众生无伤害貌。是为四事得身长大。菩萨有四事面部弘满。何等四。若干璎珞而用布施。一切所爱施而不惜。常以慈眼观于如来。见人端正不生嫉妒。是为四事得面色弘满。菩萨有四事得眷属繁炽。何等四。离于两舌未曾破坏他人眷属。见他友党代其欢喜不舍道心。并化他人令发道意。是为四。菩萨有四事意广无极。何等为四。其心清净而无谀谄除重爱欲。所在中间而无厌疲。志于微妙深入要法。一切诸法本末皆空。是为四菩萨意广无极。于是燕居无善神。与三万二千眷属。各各以若干种八千天华。散世尊上以偈赞曰

  其有于十方　　人种不可量
  须臾一时顷　　则供养世尊
  假使十方人　　一切供养德
  在于百千劫　　等心给足人
  不能及慈心　　愍伤之福行
  寂然极如应　　供养安能报
  是为诸十方　　供养之奉事
  发心无与等　　正谛住如应
  于是吾自由　　立志无谀谄
  已觉了本无　　自致得佛道
  人中尊见愍　　三界无谀谄
  十力证明我　　解我心性行
  柔软无怯弱　　以离诸恐惧
  布施调禁胜　　持戒及忍辱
  精进于定意　　为应住智慧
  顺从慈愍哀　　常奉至诚行
  加哀不为我　　胜不受善决
  人尊我便当　　自别受佛决
  吾悉不狐疑　　谓不成自由
  吾了了究竟　　志净在于道
  人中尊时笑　　月英寻问曰
  今何故欣笑　　唯圣解说之
  化度时告曰　　月英具听之
  吾所以示现　　奋出大光明
  时燕居广普　　志愿尊大道
  三万二千人　　诸所从眷属
  于百千劫中　　常行菩萨道
  一切志同等　　当得圣佛道
  当供养诸佛　　等如恒边沙
  所开化人民　　其数复过此
  其劫曰欢喜　　又号净复净
  得佛离寂尘　　觉了至无忧
  此燕居广普　　当逮为法王
  超出精进力　　号曰帝幡幢
  其世界名曰　　欣乐仁庄严
  衣食丰平贱　　譬如兜术天
  其十力寿命　　七十亿万岁
  满六十那术　　比丘比丘尼
  诸菩萨之众　　有八百那术
  坚住于总持　　所闻悉解了
  彼于欢喜劫　　又号净复净
  皆以如是比　　当成尊佛道
  开化百千人　　悉使住佛道
  具观是德胜　　菩萨之道心
  燕居无善神　　彼闻佛授决
  四千万大众　　悉发菩萨心
  三千界震动　　则时雨天华
  善哉总要德　　心意之所持

    无焚龙王受决品第十三

于是无焚龙王白佛言。一切诸法皆无所住亦无有人。何有受决者。谁当成至无上正真道为最正觉乎。佛言如是。如仁所言。一切诸法皆无所住。亦无有人。一切诸法亦复如是。凡夫愚人处于颠倒。住吾我人无人起人想。菩萨发大哀为除颠倒。去吾我人被觉德铠。此正士等晓了诸法无吾我人。开化诱立吾我人命。属仁所云谁受决者。诸仁等解人空无我。则为受决。一切法等观诸法寂则为受决。诸佛国等而无所取。心净无垢则为受决。慧观诸佛等诸佛道不坏法界。则为受决。于诸魔众等一切魔。于尘无尘了心本已。则为受决。无名无相无应不应。无念不念不受不舍。则为受决。佛语龙王。其心意识无所住立。则为受决。诸法如是。以无因缘诸法本谛。觉了诸法平等无异。则成无上正真之道。究竟求本无有受决及成佛道。若受决者。若受决已。所以者何。诸法无形本末悉断皆无有主。一切诸法从因缘转。诸法如空。无从生相故。诸法无从生相。无所至相故。诸法无所从来。计本空故。诸法无所至。未发起故。诸法无所住。不可得处故。诸法悉空。用无身故。诸法无著。用无猗故。诸法无所猗。不可动故。诸法不可动。无处所故。诸法皆愚。用自然故。诸法自然。无言教故。诸法无言教。无色像故。诸法无色像。用无念故。诸法无念。无因缘故。诸法无因缘。无所行故。诸法无所行。用寂然故。诸法寂然。无受阴故。诸法无受阴。本净空故。诸法脱相。用无二故。诸法无二。用本一故。诸法本一。离若干故。诸法等无差特。用等觉故。佛语龙王。解诸法等无受决者。不成等觉。且观于是如来坚固兴无极哀。及诸菩萨劝乐之力。诸法如是以无央数为人解说。合会有数于诸法观。无解脱人法亦不度。人如法者人亦如也。道亦如也。佛亦如也。决亦如也。诸法亦如也。故曰如来了于本无。住本无故。而不可动故曰本无本无像。本无坏。解了本无故曰如来。以如来故等住本无。诸法如是等如本无住。是为如来等住之地。其有菩萨闻是说者。不恐不怖不畏不难。以是如来等住之地。为人解说。佛说是时。三千菩萨皆得法忍。阿耨达龙王欢喜踊跃。以白珠璎珞价当是世。而覆佛上

    女宝锦受决品第十四

尔时海龙王有女。号名宝锦离垢锦。端正姝好容颜英艳。与万龙夫人俱。各以右手执珠璎珞。一心视佛目未曾眴。礼佛而立。时宝锦女及万夫人。以珠璎珞奉上世尊。同音叹曰。今日吾等一类平心皆发无上正真道意。吾等来世得为如来至真等正觉。当说经法将护众僧如今如来。于时贤者大迦叶谓女及诸夫人。无上正觉甚难可获。不可以女身得成佛道。宝锦女谓大迦叶。心志本净行菩萨者得佛不难。彼发道心成佛如观手掌。适以能发诸通慧心。则便摄取一切佛法。女谓迦叶。又如所云。不可以女身得成佛道。男子之身亦不可得。所以者何。其道心者无男无女。如佛所言。计于目者无男无女。耳鼻口身心亦复如是无男无女。所以者何。唯仁者眼空故。计于空者无男无女。耳鼻口身心俱空。如是虚空及寂无男无女。若能解了分别眼本。则名曰道。耳鼻口身心亦复如是。计于道者无男无女法。是故迦叶。又如诸法皆在自然。道亦自然。吾亦自然。迦叶问女汝是道耶。其女答曰。尊者耆年。谓我是非道乎。迦叶答曰。吾非佛道是声闻耳。女又问曰。谁开化仁。答曰如来。女曰。假令如来不成正觉。宁能开化于耆年不。答曰不也。是故仁者当知。在彼则为以道无不觉道。迦叶问女。逆为道乎。答曰唯然。迦叶。逆则道也。所以者何。以别本净可觉了。道者则无有逆解。逆本净则名曰道。空者本无分别诸逆则名曰道。假使诸法有合有散则非道也。等一切法顺如应者。乃为道耳。迦叶问女。谁以如此辩才相施。女答曰。尊者迦叶施我辩才。设使仁者不问于我。何因发辩。譬如迦叶无有呼者。何缘响应。假使无问菩萨义者。无因发辩。迦叶问女。汝为供养几何佛乎。女答曰。如仁者所断尘劳。迦叶答女曰。吾不断尘劳。女又问仁者。俗有尘劳秽耶。迦叶答曰。吾无尘劳亦不断矣。女又问曰。安置诸尘劳。答曰。不起不灭亦无所置。所解如此如本无也。又问。本无宁可知耶。答曰不也。又问。何故仁言。其慧如道如所知了明无为知如此。如解本无。是故名曰慧与凡夫等。又问女。汝所辩者断一切言。答曰。吾无所断亦无有言。所以者何。法界无所断。一切所说皆应法界。迦叶又问女。汝等我于凡夫法宁不有疑乎。女答曰。假使立仁凡夫慧法。而各异者吾当有疑。吾谓仁者凡夫无异。以故无疑。诸法皆等无若干故。是谓平等。如虚空是谓平等。又问女。汝于凡夫等圣贤耶。答曰。吾不凡夫亦非圣贤。所以者何。假使吾等身与凡夫等不行菩萨。设使贤圣等则断佛法。又问女。设汝不与凡夫等亦不与圣贤等。宁与佛等乎。女答曰不也。所以者何。吾身本于佛法等。又问女曰。假使汝于佛法等者。宁逮佛法乎。女答曰。仁者耆年。宁信佛法有去来今现在缘耶。有方面乎。有所处青黄赤白黑不。答女曰。诸佛之法无有形貌。女答曰。假令诸佛法无有形貌。云何从我求乎。迦叶问女。佛法当于何求。答曰。当于六十二见中求。又问六十二见当于何求。答曰。当于如来解脱中求。又问。如来解脱者当于何求。答曰。当于五逆中求。又问。五逆当于何求。答曰。当于度知见求。又问。此言何谓。女答曰。无缚无脱无取无舍此为本净。是为诸法之深教言。非若干言。又问女。是之言教不违如来言乎。女答曰。是真谛言不为违失如来之教。所以者何。如如来之道而无所得。亦不可持。亦无言说。一切所言皆音声耳。晓了道本亦无音声。唯仁者。解道寂然无迹。以名迹自爱迹。迦叶又问。假使道无迹。如是比相云何成最正觉。答曰。亦不从身亦不从意得最正觉。所以者何。身心自然乃成道耳。其自然者都无所觉。吾则是道。不以为道成最正觉。迦叶问女。汝设是道何不转法轮。女答曰。我转法轮耳。迦叶问曰。所转法轮为何等类。女答曰。无动之轮远离一切诸所猗住。其法轮者谓法界住故。本无轮者顺本无故。无断轮者如本净住故。无著轮者觉了一切诸法。无所著故。无二轮者等于一切法故。无若干轮忍一行故。无言法轮者化诸音声皆无所想入一味故。清净轮者一切无尘故。断诸不调轮者不得有常无常故。无乱轮者善观报应故。至诚轮者无起无灭故。空无轮者无相无愿故。唯迦叶。轮已如是何所转者。大迦叶曰。如女之辩才不久当成无上正真道最正觉。女答曰。假令迦叶成最正觉时。吾亦当成最正觉。迦叶答曰。吾终不得成最正觉。女答曰。如是了法身者。道住无所住。无能得致成最正觉。女说是语时。五百菩萨逮得法忍。佛时赞曰。善哉善哉。快说此法

尔时众会中天龙鬼神无善神香音神心自念言。是宝锦女何时当成无上正真道最正觉。佛知诸天龙神香音神心之所念。告诸比丘。此宝锦女三百不可计劫后。当得作佛号曰普世如来至真等正觉。世界曰光明。劫曰清净。其光明世界如来光常当大明。菩萨九十二亿。佛寿十小劫。于是万龙后白佛言。普世如来得为佛时吾等愿生彼国。佛即记之当生其国

    天帝释品第十五

于是天帝释。白世尊曰。此忉利天常怀恐惧难无善神。天与无善神共战斗时。展转共诤怀其怨结各有嗔毒。唯愿世尊。慈愍众生诸无善神皆悉来会。此诸忉利天悉令共和。佛告燕居无善神。诳诈超度离垢锦无善神言。诸仁者。其仁慈心诸佛所叹。人能行慈现世后世具足利义。其命甚短当就后世。合会有离国土豪贵皆归无常。汝等之身不免此患。当观后世和顺同心无得怀嗔。将护罪福因缘之对。于是世尊为说辛酸悲哀之言。使无善神及忉利天悉共和解。各自说言。吾从今始当为亲友顺于等行。各各当怀悲心愍哀无嗔恚意。佛言。善哉善哉。诸仁者。是则第一供养如来。用行慈故。说是语时。所教造福共和不诤。谓慈心三昧有四事尊敬如来。何等四。不违犯戒。身口意慈。不断三宝志于佛道。如所闻法为人讲说。是为四事。尊敬如来为供养也。于是会中二万三千天无善神。闻说此言皆发无上正真道意

佛说海龙王经卷第三佛说海龙王经卷第四

        西晋月氏国三藏竺法护译

    金翅鸟品第十六

尔时有龙王。一名噏气。二名大噏气。三名熊罴。四名无量色。而白世尊曰。于此海中无数种龙。若干种行因缘之报来生于是。或有大种或有小种。或有羸劣独见轻侮。有四种金翅鸟。常食斯龙及龙妻子。恐怖海中诸龙种类。愿佛拥护。令海诸龙常得安隐不怀恐怖。于是世尊脱身皂衣。告海龙王。汝当取是如来皂衣分与诸龙王皆令周遍。所以者何。其在大海中有值一缕者。金翅鸟王不能犯触。所以者何。持禁戒者所愿必得。尔时诸大龙王皆怀惊懅。各心念言。是佛皂衣甚为少小。安得周遍大海诸龙。时佛即知诸龙王心所怀疑恐。告海龙王。假使三千大千世界所有人民。各各共分如来皂衣。终不减尽。其欲取衣。譬如虚空随其所欲则自然生。佛所建立不可思议巍巍之德其如斯矣。时海龙王即取佛衣。而自分作无央数百千叚。各各部分分与龙王。龙王之宫随其所之广狭大小自然给与。其衣如故终不知尽。于时海龙王告诸龙王。当敬此衣如敬世尊如敬塔寺。所以者何。今此衣者如来所服。以是之故如敬塔寺也。假使一切供养如来。有奉此衣等无差特。于是世尊告海龙王。如是如是。如仁所言。其奉此衣则供养如来。且观诸龙及龙妻息各各所分如来衣不。对曰。唯然已见。佛言。我皆授决即脱龙身。于是贤劫除志大乘。其余诸龙皆得无著当般泥洹。如是龙王。如来在世一切众祐发一善心。缘当致佛未曾有失。尔时海中诸龙及龙妻息欣然大悦。自投佛前同音说言。如来所语终无有二至诚不虚。授我等决至无为度。吾等今日住于大海。归命佛法及诸圣众。奉受禁戒恭顺如来反复之义。如来现在数数往造。见佛稽首听采法义。般泥洹后供养舍利。一切众具而以奉事世尊舍利。于是四金翅鸟王闻佛所建立惶懅。速疾往诣佛所前稽首足。何故世尊。夺吾等食。佛言。都有四食坐趣三处。何等四。一曰网猎禽兽残害群畜。杀生抂命以为饮食是趣恶处。二曰执带兵杖刀矛斫刺逼迫格射。劫夺他财以用饮食是趣恶处。三曰悭贪谀谄愦乱犯禁。邪见巧欺而以得食是趣恶处。四曰非师称师非世尊称世尊。堕邪称正。非寂志称寂志。非清净称清净。非梵行自称梵行。自称诈求而以得食。是为四食。坐趣地狱饿鬼畜生三恶之处。吾所说法除此四食。不当以此养身害众生命。所以者何。一切众生各自爱命无自憎者。以是之故。欲自护身当护他人安隐众生。明者如是不以危逼人。所不当作慎勿为也。尔时四金翅鸟王。各与千眷属俱而白佛言。今日吾等自归命佛及法众僧。自首悔过前所犯殃奉持禁戒。从今日始常以无畏施一切龙。拥护正法至佛法住。将顺道法到于灭尽不违佛教。佛告四金翅鸟王。汝等之身。金仁佛时为四比丘。名曰欣乐大欣乐上胜上友。是四比丘。违犯戒法贪于供养。志迷醉惑随亲友种逐于豪贵。意乱吾我堕于邪见。轻诸比丘逼迫恼之。不护身口意作恶众多。供养金仁佛亦不可计。以是之故不堕地狱。堕此禽兽。前后杀生不可称计。多所恐怖用不自护。世尊应时即如其像现其神足。令四金翅鸟识念宿命。所可供养金仁佛及诸弟子。彼时所作罪福普悉念之。目睹悉见前世所作。白世尊曰。其心刚[革*卯]难可调伏。坐心贪嫉多所危害。违金仁尊教。我等今始宁没身命不敢犯恶。佛为说经授其决言。弥勒佛时在第一会皆当得度

    舍利品第十七

尔时海龙王子及一切龙白佛言。未曾有世尊。如来所说普安一切。授诸龙决开化眷属皆发道意。又以加恩乞施皂衣。使诸龙分各以供养稽首奉事。缘是得护因发道意。慈愍众生遵四等心慈悲喜护。兴隆四恩惠施仁爱。利人等利一切救济合聚。由此行德沙不雨身离于众患。又寂意时不失天身。变为蛇蚖临食意后不遭虾蟆。金翅鸟王不取食之。佛化四鸟皆识宿命。金仁佛时为四比丘。坐行凶暴不顺正法逼迫同学故。堕金翅鸟自首悔过。改心易行发大道意。行四等心不害群黎。以得善护吾等永安不复见食。志不怀惧长夜无难。皆蒙佛恩。今如来受龙王请所演广覆。譬如虚空无所不盖。于今世尊还阎浮利。海中诸龙无所依仰。唯加大哀。佛灭度时在此大海留全舍利。一切众类皆得供养华香伎乐被服幢幡。转加功德速脱龙身。疾得无上正真之道。续见救济惟佛垂恩。威德兼加所愿得果。佛言。善哉。从尔所志。时须菩提谓诸龙子。诸仁者等勿建此心。则为妨废一切之德。所以者何。佛泥洹后舍利分布八方。上下天龙鬼神一切人民蚑行喘息人物之类。皆当供养华香伎乐稽首自归。变化现光见者欢喜。知佛威神巍巍无极。缘是信之。皆发无上正真道意。或成缘觉。或得声闻。或生天上。还得人身。与法相值世世得度。如是之计普蒙获济。今者卿等各自求愿。使佛世尊在于大海而取灭度。供全舍利独欲奉侍。一切众生何缘得度。永为穷厄无一救护。以故吾言勿发此心。令佛世尊海中灭度。独奉全舍利而供养乎。诸龙答曰。唯须菩提。勿宣斯言。无以己身限碍之智以限如来无极之慧。如来功德圣道自在。无不变现。无远无近无彼无此。普游十方其若虚空。发意之顷。能令海中诸龙神宫。三千大千世界州城郡国县邑丘聚。人中旷野天上世间。各各化现佛全舍利一切供养。于佛身体不增不减。分身十方无数佛土。亦无所分。普现一切不去不来。譬如日影现于水中。佛亦不生亦不灭度。云何欲限如来慧乎。欲限如来为限虚空。时须菩提。闻诸龙子叹如来德无穷无极不可譬喻。默而无言。海中诸龙虚空诸天及诸鬼神踊跃欢喜。皆发无上正真道意。时佛叹嗟诸龙子曰。善哉善哉。仁等鉴明。诚如所云无有异也。佛道高妙无边无际无方无圆。无广无狭无远无近。譬如虚空不可为喻

    法供养品第十八

于是世尊告海龙王。吾于大海所当教化皆以周毕欲还精舍。即从坐起与大众俱。寻从宝阶出于大海。以无极庄严广普威神住于海边。尔时大海神。名曰光耀。则以此偈。而赞叹曰

  身相三十二　　天人所恭敬
  无善神奉宗　　稽首人中上
  光如百叶华　　犹若月盛明
  清净德超异　　稽首施安隐
  颜容殊妙好　　百福功德相
  德慧度无极　　稽首于导师
  施与调顺上　　积于清净戒
  忍辱力最胜　　稽首世之上
  过于精进力　　禅定思清净
  智慧如虚空　　稽首以自归
  行慈以等心　　修哀摄众生
  喜心导御众　　常护度彼岸
  妙音如哀鸾　　所说喻梵声
  其响甚柔软　　愿以稽首礼
  降伏于魔怨　　其力无等伦
  遵修愿道法　　三处所奉持
  净除于三垢　　讲说三脱门
  其名闻三千　　是故稽首礼
  善愿常至诚　　超度诸法上
  尊胜诸国王　　常施惠大财
  以离谀谄尘　　威神甚巍巍
  光颜大殊妙　　是以稽首礼
  心坚如金刚　　譬如须弥山
  意至犹若地　　故稽首德海
  为人说空义　　常寂度无极
  湛然心平等　　愿以自归命
  开演如甘露　　无趣断所趣
  天人人所敬　　愿稽首最胜
  闻天上人间　　名称无有比
  德普不可量　　稽首于德海
  所作如所言　　为人说本行
  所兴为人讲　　稽首善调御
  度于老病死　　为贤众所奉
  演说解脱句　　稽首归命佛
  分别罪福应　　净除邪见冥
  为现正道行　　归命于最胜
  以经宝布施　　究畅于法乐
  等心于怨友　　以归命世尊
  我嗟叹导师　　于德度无极
  所以咨嗟福　　愿后如世尊

于是海神光耀。说是偈赞佛已。显扬大海。如来出海。海无威神。愿佛垂恩遗以法教。使此海中蒙其庄挍而获度脱。佛告海神。有十法行得至庄挍。何等为十。护于诸根十善清净。志于慈心不害众生。意立大哀发无上正真道。一切布施以若干行庄严其愿。以大精进具足善法心常寂然。不违本德好乐经法。智慧清净以愍哀行。开化众生立于正德。入乎殊异以致欣悦。逮得佛意导以佛教。是为十法致乎庄严。时大海神光耀与二万天神。发无上正真道意。俱共叹曰。今以庄严于是大海。所以者何。若发道意则为庄严三千世界。何况海乎。我等以发诸通慧心一切庄严之功德也。我在于海如来现在若灭度后。拥护佛法令其宣布。如来入城现众庄严。蒙以法恩化作讲堂。佛告光耀海神。汝前后供养万佛普立大殿。又护正法。次当供养贤劫兴佛将导正法。竟贤劫已。当生无怒佛国妙乐世界。转女人身得为男子。无怒如来当授汝决为无上正真道。时大海神光耀。闻佛授决欢喜踊跃。则取珠璎价踰海宝。用散佛上。即而颂曰

  佛以圣谛音　　能仁授吾决
  我不怀犹豫　　后当成佛不
  可令三千界　　他所有劈裂
  亦令月堕地　　佛所说不妄
  观慈志境界　　心净修精进
  今察我庄严　　恭敬慧法义
  睹安住所行　　以慧决狐疑
  了心如野马　　所说审至诚
  施安除众苦　　殁命救恐畏
  所疗益无难　　稽首最正觉
  度脱诸恶趣　　归命光照世
  导师明无上　　稽首佛说道
  其有闻佛声　　诸天人快利
  佛法清净行　　志在于佛道
  不得归恶趣　　便弃于八难
  生天在人间　　后得寂然迹

于是海龙王子。名曰受现。白佛言。无央数天龙神香音神无善神凤凰神山神恬柔神供养佛。我身亦当少少供养如来正觉。假使世尊愍伤听者。化作大殿。譬如忉利最上选宫。佛及弟子悉处其上。送至灵鹫山。世尊曰。如仁者愿宜知是时。受现龙子自以神力承佛圣旨。化大严殿如忉利宫。佛及众会皆处其上。在虚空中与八万四千龙王诸后。鼓诸琴瑟而雨众华及一切香。送佛世尊诣灵鹫山。海龙王子与中宫俱。在世尊前自投归命愿周不及。所以者何。所兴供养当如其宝。佛为一切无上福田。世尊大宝正使三千大千世界满中罗汉。皆共供养于百千劫。不如奉侍如来世尊。如是乃应供养。又世尊。何谓菩萨供养如来。佛言且听。菩萨所行供养如来。其心清净除于瑕秽而无谀谄。本性自然不着一切诸善之本。无加害心等光众生除妖邪心。所行鲜洁言行相应不侵欺世。贤圣智足威仪至德。一切平平而不违舍。贤圣大愿乐于空闲。舍众愦闹自调其心。闻法静思解知本谛。无我无人无寿无命。入于空无入普达寂。观空无想无愿。至三脱法。如是像法调诸邪见。弃有常无常不起不灭。逮得法忍本净无人。无身口心志行因缘。是则应法供养如来。身口心行则不供养。无所造行不进不退。净三道场等于三世。除去三垢不着三界。入三脱门得三达智。是则名曰供养如来。时海龙王问世尊曰。其有人以华香杂香捣香缯盖幢幡伎乐衣被饮食床卧病瘦医药供养如来。宁应供养不。佛言。龙王。随其所种各得其类。此之供养不为究竟。离于垢尘殖于德本。逮至贤圣心之解脱。不为无德不至无上。菩萨有四事。应供养如来。何等四。不舍道心殖诸德本。心立大哀合集慧品。建大精进严净佛土。入深妙法心得法忍。是为四。尊敬如来为供养也

尔时王舍城中。梵志长者及无央数人民尊者大臣。上至摩竭国王阿阇世。闻佛在大海龙王宫。就请来还灵鹫山。时七万二千人皆诣佛所。王阿阇世与官属三万二千。出王舍城诣灵鹫山。稽首佛足绕佛三匝。却住一面。前白佛言。佛入大海水何所至。佛言。大王。其有比丘威光定意心正受者。普见满火。其水安在。王对曰。三昧自在之所致也。天中天。志心所为也。佛言。王宁得声闻所兴三昧自在已耶。心之所为乎。如来常定等一切法。晓了坐起而得自在。于法为尊心无所碍。佛入大海其处水类续见如故。其陆地人睹乎大海。其水枯涸但见众宝而庄严之。譬如第六他化自在诸天宫殿所庄严也。佛光普照诸龙宫殿香音神宫无善神宫。其大海中含血之类。皆行慈心仁意相向无怀害者。阿阇世王白佛。其海龙王久如发无上正真道意。奉事几佛何时当逮最正觉。所号为何。佛告王曰。乃往久远无央数劫不可思议。彼时有佛。号光净照耀如来至真等正觉明行成为善逝世间解无上士道法御天人师号佛世尊。乃在东方。世界曰善净现。劫名可意寂。其善净现世界平正而悉庄严。假使一切嗟叹其德不能究竟。时有转轮圣王。号曰护天。常供养光净照耀如来。四百二十万岁一切施安。竟此之数寐于梦中。自然瑞应闻此偈曰

  王以供养大圣人　　甚多无量难思议
  常兴慈哀于众生　　当发最上菩萨心
  是供养尊妙第一　　此则奉敬诸如来
  其有能发菩萨志　　则为度世威神德

佛告阿阇世王。其护天转轮圣王。梦闻此已。寤自惊怪。吾供养佛四百二十万岁。佛说经法章句各异。初未曾闻如此偈经。是佛说邪魔所云乎。即疏偈文而讽诵之。时光净照耀如来行游诸国。圣王即与八万四千王及八万四千后国中臣民。其诸往者各八万四千。俱往追佛欲决斯疑。即逮见佛稽首足下。敬问无量。即白佛言。吾供养佛四百二十万岁。佛说经法若干种义。我昨夜梦。梦中见佛说此二偈。寤甚惊怪。未从如来闻此偈教。不审佛所叹乎。魔所说耶。今故远来欲决此疑。唯愿世尊。分别说之。佛告护天。是吾所赞非魔之所云。王又白佛言。我奉事世尊若干亿岁。供养衣食无所乏少。为我说经章句各异。尔时何故不叹此义。佛即以偈答王曰

  人心羸劣未有识　　初习福事未见深
  不可为说微妙法　　心中惊疑或作却
  以解罪福信佛法　　心坚意固不回动
  乃可为说菩萨事　　尔乃解至无极慧

时王及群臣后民心中大悦。皆发无上正真道意。寻立不退转地。则以此偈。而赞世尊曰

  不以贪诸色　　亦不猗音声
  香薰众细滑　　不以此得佛
  离懈怠怯弱　　避贪嫉犯法
  除嗔恚愦乱　　乃得成正觉
  舍身诸所安　　代众生受恼
  精进常乐法　　如是乃得佛
  我今志大道　　佛与天证我
  唯导师造行　　令所言无异
  梦中闻道心　　适闻志大乘
  所作慧无疑　　得至佛法王

佛告阿阇世王。欲知尔时转轮圣王护天者不。今海龙王是。彼时初发无上正真道意。又王所问何时成佛。王具当听。过二百无央数劫当成为佛。号无垢净无量德超所有王如来至真等正觉。世界曰法音声。劫曰首华。其法音声世界众宝合成若干种色。地平如掌其地柔软如天綩綖。有万亿安明山广普难量。安隐丰熟五谷平贱天人充满。衣服饮食如第六天人所居。法音声世界诸树根叶茎节华实。皆以七宝。悉出无数若干百千道法音声。其界人民犹若诸天。所语变化柔软之声。皆承法音寂然澹泊。及佛法众智度无极四恩之教。善权方便灭定离欲。空无想不愿无为无数。以故其界名法音声。其有天人在彼土者。乐法欢喜皆当入大圣。分别诸慧审谛究竟。发无上正真道意。其佛欲说经时。身放大光普照佛界。其光明中则出亿佛说讲法声。时诸天人见光闻法欣然大悦。往诣如来自归供养。则无央数以神足力飞行虚空。化宝莲华而坐其上。如来应时亦在虚空坐师子座。为诸菩萨讲说经道。时诸十方无央数百千诸菩萨者。皆当来会听受经法。其国人民皆乐经法。亦无诸魔有所娆害。亦无众邪异道。亦无横死。其佛寿十二劫。诸菩萨行超过于空。其国如是庄严无量。说法无限菩萨无数

    空净品第十九

王阿阇世前白佛言。唯然世尊。常于诸法有大愍哀。诸法诳诈因惑起想。随其所欲展转相惑。菩萨之行不可计量。彼为菩萨当修道行。至彼佛土具足严净。诸菩萨行皆当追学摄取佛土。如海龙王国土严净。佛言。如是如是。大王。一切诸法皆从念兴。随其所作各各悉成。诸法无住亦无有处。尔时阿阇世王谓海龙王。快哉龙王。为得善利。乃令如来授仁之决。当成佛时。国土清严不可思议。龙王答曰。法无有决。所以者何。诸法皆静因种阴入。假名曰人。其受决者无阴种入。以有名色假名为人。其受决者无名无色。因缘报应见思想念。假名曰人。其受决者无有报应无见无思无想无念。假使菩萨等行德本。彼之德本亦无决矣。诸法相空虚空无决。一切诸法无想无愿。无为无数。不授无想无愿无为无数之决也。龙王复谓王阿阇世。诸佛大哀不可思议。诸经无名无有思想而说名想。诸佛世尊。无名相识。而随习俗因而示现有授决也。彼亦无法受决。亦无内外当受决者。阿阇世又问龙王言。以得法忍逮平等行。菩萨如是乃得决乎。海龙王曰。其忍悉空想不可尽。究竟晓了至于本际。无尽之际。平等之际。无我之际。吾我之际。审谛之际。至于究竟无成就际。其际以空至于脱际。媱怒痴际有了是际。则无所猗无所猗者。设于音声无合会。无合会者不着无脱。无脱无行。行无所行亦无不行。亦无所忧。已无所忧。于斯菩萨则都一切诸所作行所见无见。假使无所见不作审谛。而已平等入已所住。已平等度。不残不礼不卒不暴。以等诸法然后得忍。彼所谓忍及所授决。若受决已及受决者。是一切法皆平等法乎。诸法界究竟无法界。无不以决了亦无所成。观此法已察其义理。诸法无能计者。譬如虚空不可计数以度诸数。诸法如是。海龙王说是语时。二万菩萨得不起法忍。百比丘漏尽意解

尔时王阿阇世白佛。至未曾有世尊。龙王之辩。佛言。未足为怪不以为难。新发意者闻是不恐不难不畏。是乃为难。所以者何。诸佛世尊本之道法。如是难及。少有信者。天上世间人不能受。不入不信而不喜乐。以故当知其有闻是深经法者。不以恐畏此乃为难。前世供养无央数佛安以为难。譬如有人虚空无形而现形像。是为难不。对曰。甚难天中天。佛言。其闻此经深奥之义。一切信乐皆知无我无人无寿无命。其有信者甫当信者。此等则是如来顺明平夷之类亲友善师也。则能堪任信除垢尘。为一切人讲说经法。能诣道场以慈降伏百千亿魔及余官属。为于诸法而得自在。其心清净诸通之慧近在目前。发意之顷成智慧明逮最正觉。劝訹众生知一切心群萌诸根。而转无上大法轮也。疗一切病开化异道。破坏怨敌吹大法蠡。于是海龙王所愿皆获。不失本志闻所受决。欣然大悦善心生焉。踊在虚空以偈赞佛

  如虚空本清净　　无色无受无数
  安住说法如是　　若虚空普自然
  名不有而不无　　造因缘及报应
  安住讲调不诤　　无人命无寿识
  一切法甚清净　　吾我清悉平等
  吾我静法等静　　解是者则受决
  察法界本清净　　人界静亦如是
  如众生界静者　　佛法静亦复然
  若佛法清净者　　诸佛土静亦等
  设佛土清净者　　诸慧静无差特
  诸法净因数号　　以计数不得名
  由想数名本空　　其诸名数无碍
  群萌类志所念　　无见无色无成
  如无成心意识　　诸法尔空无心
  或有作则无作　　有缘罪无受者
  终始瑕无行者　　名泥洹无寂然
  入本际无碍原　　虚空本无我际
  选诸际得等原　　知众生本审门
  去来今现在际　　顺明智此诸际
  于慧等无际门　　究法界佛种性
  不起灭最胜幢　　空无想愿本静
  无言声真谛法　　是诸圣寂寞地
  若解诸法澹泊　　自然悦如捉空
  彼无吾我身寂　　假如此乐圣法
  十方佛所说法　　当来佛所宣扬
  一切等未来声　　因音现入无声
  声空自然如响　　诸法空犹虚念
  无法非法教化　　诚本无可不得
  一切法无主名　　若干想念非明
  人名静不可得　　诸法本静如是

    嘱累受持品第二十

于是世尊。告诸大士言。诸正士。汝等当持此如来说无上正真道。使得久存。谁能堪任受持诵说如是像比。即时二万菩萨万天子。起住佛前。同音白世尊曰。吾等当受如是像经。当令流布普周远近。佛又问言。汝等云何而将御法。持斯如来无上正真道乎。彼有菩萨名曰慧英幢。前白佛言。唯然世尊。隐省诸法都无所持。宁能仿佛持佛道乎。世尊答曰。族姓子。如斯则应持佛道。等见菩萨白佛言。揆察佛道等乎五逆。宁少仿佛持佛道乎。世尊曰。族姓子。是故仁者则应持如来佛大道也。无见菩萨曰。唯然世尊。我不见凡夫法。亦不见学。不学法。不见缘觉及菩萨法。亦不见佛法。我有持如来法乎。世尊曰。族姓子。以是寂故应持如来佛大道也。诸法无所愿菩萨曰。唯世尊。我永不知一切诸法当所持者。宁能为持如来法乎。世尊曰。族姓子。以是寂故应持如来佛大道也。不眴菩萨曰。唯世尊。我自不行。亦不遣心。亦不发意。我宁为持如来法乎。世尊曰。族姓子。以是寂故应持如来佛大道也。无得菩萨曰。唯世尊。其不说法及非法。不演法声除诸法想。如是行者为护一切法乎。答曰族姓子。是应寂然。无在菩萨曰。唯世尊。其不听受法应不应。为护正法乎。答曰族姓子。是应寂然。虚空藏菩萨曰。唯世尊。其观诸法等如虚空不见彼法。有所执持为护一切法乎。答曰族姓子。是应寂然。度金刚作菩萨曰。唯世尊。不坏法界。入于人界及以法界。为持正法乎。答曰族姓子。是应寂然。度不动迹菩萨曰。唯世尊。其于诸法无所动转。不猗法及非法。为持正法乎。答曰族姓子。是应寂然。嘲魔菩萨曰。唯世尊。其至魔界佛界。则于佛界及与魔界。悉以为入诸法境界。为护正法乎。答曰族姓子。是应寂然。无著菩萨曰。唯然世尊。其于诸法都无所得。一切毛孔皆出法声。为护正法乎。答曰族姓子。是应寂然。普寂菩萨曰。唯世尊。不护诸魔行菩萨道。为持正法乎。答曰族姓子。是应寂然。海意菩萨曰。唯世尊。其以海印等一切法。修一切解味而知自然。为护法乎。答曰族姓子。是应自然。须深天子曰。唯世尊。其有所生不起不生。诸阴种入无心意识。为护正法乎。答曰族姓子。是应寂然。无垢光天子曰。唯世尊。其见诸法无垢尘者。无众瑕秽解脱诸受。为护法乎。答曰族姓子。是应寂然。度人天子曰。唯世尊。其度众生不知萌类度无所度。既有所度现周旋还不住彼此。为受法乎。答曰族姓子。是应寂然。贤王天子曰。唯然世尊。其于众生而等一切。诸法已等。等诸国土。等诸佛道。为受正法乎。答曰族姓子。是应寂然。自在天子曰。唯世尊。其于诸法而得自在。普于诸法不起不灭。为受正法乎。答曰族姓子。是应寂然。善念天子曰。唯世尊。我不念法亦无所得。亦不有想。为受正法乎。答曰族姓子。是应寂然。莲华天女曰。唯世尊。知一切法皆为佛法。不成正觉无所不觉。为受正法乎。答曰族姓女。是应寂然。麻油上天女曰。唯世尊。我不得女亦不得男。如佛法想及界女法想。亦复同等。此诸法想则为非法。亦非无法。无二无一亦无所至。我为受法乎。答曰族姓女。是应寂然。宝女曰。唯世尊。我不见佛佛道睹菩萨行为被一切志德之铠。不察于本末。为受法乎。答曰族姓女。是应寂然。无垢光女曰。唯世尊。于一切法不起法想。于一切人不起人想。亦不想念人法佛法睹诸佛法入一切法。不见本末。我为受佛正法乎。答曰族姓女。是应寂然。建行如是为受佛法。于是天帝释白佛言。未曾有也。世尊。此女人等所说辩才不可思议。分别方便合若干音。文字之说讲于法界。不乱诸法诸法平等。如演说道等不差特。佛言如是。拘翼。是诸女等分别无量不可思议法。供养奉事不可计佛。以得法忍。又拘翼。是经卷者号不起忍持无所御。当为众会广说其义。如来灭度后受是法者护持法城。则为供养佛世尊已。天帝释白佛。我已奉受此经本已。佛所建立当令广普。当为将来诸大士故。分别说之。终不迷谬违佛之教。所以者何。如来护我授以法忍。佛当建立此之经典。令降众魔志行于斯。佛言拘翼。有神咒名曰遮诸妨碍。具听。今为汝说神咒要言。使一切魔及诸外径。令诸官属自然降伏。使如来法光明久立。尔时世尊说神咒曰

无畏离畏　净诸恐惧　施无畏　度于灭度无所乱　净所乱　无所诤　不斗讼　无怀嗔　无以殁　净威神　威神迹　大威神寂灭　趣慈心　除于瑕　示现谛　无蹉踖　其同义　吉祥义　甘露句　见于要　以导御　无所怀　行次第　无所尽　光无生　清净生　鲜洁光照句　等顺于等心　至无上　佛所建立戒清净　无所犯　无所负　制魔场　降外径　光耀法明　摄以法施　开法藏

今是神咒过去当来今现在佛所说。以拥护法而顺句义。以此章句总执降伏一切诸魔尘劳迹也。于是普首天。白佛言。我当受此经典之要。精进讽诵当令广普。所以者何。于如来法则有反复。长益法律布清白典。我修反覆拥护如来所赍法目。时有天子名曰德超。白佛言。若有受此如来之法。其福云何。于是世尊即说颂曰

  今吾所见国　　佛眼睹十方
  皆满中珍宝　　则以持布施
  其人所获福　　计当过于彼
  至心受世吼　　所说之经法
  合集诸譬喻　　一切叹广说
  终不能究竟　　总持正法德

佛说是经时。七十六那术人皆发无上正真道意。六万菩萨得不起法忍。三千大千世界六返震动。其大光明普照世间。而雨天华。百千伎乐不鼓自鸣。诸伎乐音出是辈声。如来之尊建立是经。降伏众魔化诸外径。如来以印印此经已顺而不荒。尔时海龙王雨大珠璎供养此经。周遍三千大千世界。佛告贤者阿难。以是经卷用为嘱累。受持讽诵普令流布为他人说。阿难对曰。唯然世尊。已受斯经。经名何等。云何奉持。佛言。是经名曰海龙王问龙总持品。又名集诸法宝净法门品。当善奉持

佛说。如是海龙王及龙王子。诸天人民十方诸来大会菩萨。诸大声闻释梵四天王。贤者阿难一切魔众诸天龙神香音神无善神凤凰神山神甜柔神及世间人。莫不欢喜作礼奉行

佛说海龙王经卷第四


佛说呵雕阿那鋡经

    No. 538

佛说呵雕阿那鋡经

        东晋天竺三藏竺昙无兰译

闻如是。一时佛在舍卫国只陀恒呵雕阿那鋡将五百优婆塞。至舍利弗所。作礼已却坐。舍利弗为说经。大欢喜而退。复至佛所。以头面着地。叉手绕佛三匝却坐。佛问呵雕阿那鋡。若有何功德。教化五百弟子。随从汝。呵雕阿那鋡即长跪叉手言。我常奉行佛所说四事。何等为四。一者布施于人。二者说善说。三者瞻视同学给足有无。四者同学者财共不计。佛言。善哉善哉。已过去佛。无有过是四事。未来佛亦无有过是四事。今现在佛。亦无有过是四事。佛为呵雕阿那鋡说经已。各大欢喜而退。呵雕阿那鋡还归入舍呼诸人客奴婢坐着前。好为说经开解。语生死善恶之道。复上殿呼诸持藏人诸伎女着前。为说经戒。皆大欢喜。复上后殿。为诸夫人妇女。说经戒已讫。还至正殿。斋戒床上。端坐定意。便得等心。第一天上四王请诸天皆会坐。共称誉呵雕阿那鋡功德。四天王中尊王下至呵雕阿那鋡舍。面称誉呵雕阿那鋡功德。呵雕阿那鋡时得等心。不答天王。佛边有一比丘。至呵雕阿那鋡舍。呵雕阿那鋡起迎比丘前坐。比丘说言。佛坐中常相称誉功德呵雕阿那鋡问比丘言。佛称誉我时。边有白衣无。比丘言。无有白衣。正使有白衣。有何等嫌疑那。呵雕阿那鋡言。佛语至诚。恐白衣不信者。便当堕泥犁中。正使信佛语者。便复来承事我。布施我。我不喜烦扰于人。以是故问耳。比丘辞去。呵雕阿那鋡言。想朝来未食。且留饮食。便行澡水。下饭食讫。比丘还白佛言。属至呵雕阿那鋡舍。道说言佛坐中大相称誉。呵雕阿那鋡因问我言。佛称誉我时。边有白衣无。我言无白衣。正使有白衣有何等嫌疑。呵雕阿那鋡言。佛称誉我。实至诚不妄。白衣不信佛语者。便当堕泥犁中。正使信者。便复来承事我。我不喜烦扰他人。以是故问耳。佛言。善哉善哉。我不常为汝曹说呵雕阿那鋡有七事。今复益一事为八事。何等为八事。一者不求不欲令人知。二者信不欲令人知。三者自羞不欲令人知。四者自惭不欲令人知。五者精进不欲令人知。六者自观不欲令人知。七者得禅不欲令人知。八者黠慧不欲令人知。所以不欲令人知者。不欲烦扰于人。故不欲令人知。佛说经已。诸比丘。皆大欢喜。起前为佛作礼佛说呵雕阿那鋡经


佛说黑氏梵志经

    No. 583

佛说黑氏梵志经

        吴月支国居士支谦译

闻如是。一时佛游尼连江水边。在彼一月造十八变化。于迦叶兄弟三人及千弟子。转游行罗阅只城。止顿一年。教授国民。为其讲法。初成佛道竟二年已。乃到舍卫兴隆道化。开度天人世间人民。时香山有梵志名曰迦罗。得备四禅。具足五通。彻视洞听。身能飞行。自察心念知人来生。讲说经义。感动释梵及四天王诸鬼神龙并阎罗王。悉往听之。言语雅妙声和犹梵。日日咨受不以为懈。音彻于远。普来归听。时阎罗王坐闻经法泪下如雨。举目观视益用悲叹。于时梵志问阎罗王。何为悲泣泪下如雨。阎罗答曰。事当归实不可虚言。仁今说经便辞利口。义理甚妙。犹如莲华。若明月珠。而命欲尽余有七日。恐忽然过就于后世。是以悲泣不能自胜。又仁命过堕地狱中在我部界。今自相归一心受法。及当取卿拷掠五毒。熟思惟此。遂用增怀。不可为喻。梵志愕然心中沉吟。报阎罗王曰。吾获四禅成五神通。独步四域超升梵天。不以为碍。既无罪衅。何因当堕地狱阎界。阎王曰。仁临寿终时。当值恶对起嗔恚恨。意欲有所害。失本行义故趣阎界。梵志闻之忽然悒懅。不知何计。设何方便得济斯难。愁戚惘惘心怀汤火。坐起不安为长叹息。释梵四王诸神问曰。何为不安长太息乎。梵志答曰。吾命欲尽余有七日。且有恶对来乱吾善心。缘是之故恐归恶趣。是以反侧不能自胜。时彼香山有诸善神。数诣佛所咨受经典。谓于梵志。佛兴于世仁不知乎。梵志答曰。身沈俗人安能知之。其神复谓。佛为一切三界之救。度诸未度脱未脱安未安。皆济危厄令至永寂无为之道。何不诣佛。可脱忧患。长得恬怕。道德合同。梵志闻之欣然踊跃。如冥睹明。两手各取梧桐合欢好色华树。飞到佛所。未到之顷。佛告摩夷。世尊大慈修无极哀。未曾忘舍应当度者。佛时颂曰

  潮水径顺崖　　未曾越故际
  傥有水神乱　　起犯于故流
  佛观于本无　　察应当度者
  普使得免济　　终无越失耶

于是梵志飞到佛所。住虚空中正向归佛。佛告梵志。谓黑氏曰。放舍放舍。梵志应诺。如世尊教。即舍右手梧桐之树种佛右面。复谓梵志。放舍放舍。梵志即舍左手所执合欢之树。种佛左面。佛复重告放舍放舍。梵志白曰。适有两树。舍佛左右。空手而立。当复何舍。佛告梵志。佛不谓卿舍手中物。佛曰所舍。令舍其前。亦当舍后。复舍中间。使无处所。乃度生死众患之难。佛于是颂曰

  仁当舍其本　　亦当舍其末
  中间无处所　　乃度生死原
  内无有六入　　外衰不得前
  放置于六情　　乃成无为疾

黑氏梵志。闻佛所说。心自念言。不见吾我则了心无心者本无应病与药。鄙心开解。如盲得目聋者得听。真为普见审一切智。今已值佛。德不可訾。寻即来下。稽首佛足。退住一面。佛应心本而分别说显示道场。演三脱门。于时辄住不退转地。无一忧患。叹佛功德。而诸颂曰

  光明踰日月　　智慧犹大海
  大慈无极哀　　十方悉欣戴
  众生流三界　　无数亿万载
  应病授法药　　宣畅大辩才
  虽现入生死　　周旋无往来
  劝化令精进　　罪福无能代
  努力勤精进　　勿为欲所灾
  降衰四魔除　　道成无挂碍

梵志白佛。我迷已来。其日久矣。愿见垂愍。得为沙门。佛即听之。头发自堕。袈裟着身。威仪齐整。成为寂志。往诣阎王。而谓之曰。卿本谓我余命七日。当堕地狱。今为沙门。神通已具。诸漏已尽。度于四渎。众病永除。犹大围屋。一时增寿。七七日。诸苦已消。超外异术。自在住世。更无数劫。阎王答曰。仁赖余福得遇佛。时应病授法。灭淫怒痴。神通悉备。内外无疑。设不尔者。如鼠遭狸。如稻得灾。为罪所牵。如鱼钩饵。堕地狱中。无有出期。今已永脱。相代欢喜。说是语时。无央数人。皆发道意。佛说如是。比丘菩萨。黑氏寂志。天龙鬼神。阿须伦世间人。莫不悦豫。作礼而去佛说黑氏梵志经


佛说弘道广显三昧经

    No. 635

佛说弘道广显三昧经卷第一(一名入金刚问定意经)

        西晋月氏三藏竺法护译

    得普智心品第一

闻如是。一时佛游王舍国鹫山之顶。与大比丘众千二百五十人诸菩萨八千人俱。于时世尊。广为无数百千诸众。而所围绕敷演说法

尔时有龙王名阿耨达(晋言无热)。宿造德本遵修菩萨。坚住大乘行六度无极。以具满相勤救众生化道无极。曾事九十六亿诸佛。积累功德不可称数。执权方便普现五道拔诸愚冥。使修菩萨无欲之行。怀慈四等济度一切。伤愍罪类故现为龙。化龙亿数使免殃行自处于池。率诸眷属八千万众。又将婇女十四万人。周匝导从调作倡伎。其音和雅乘龙感动。协怀威德神变自由。赍众杂花奉最妙香。擎持幡盖而诣世尊。至辄稽首敬问如来。寻以所持香华杂宝缯彩幡盖。重调音乐欣心敬意。与众眷属及诸婇女俱进诣佛。则前长跪肃然叉手。而白佛言。欲问如来无著平等最正觉。菩萨所应行道当云何。唯蒙听许乃能敢问尔时世尊告龙王曰。恣汝所问勿疑勿难所欲。如来至真等正觉当随敷散解释汝心

时阿耨达。得为神尊所听质疑。心益欣悦。而白佛言。天师最尊人中圣导。猛如师子感变无量。吾问如来普及众生。亦为菩萨大士之故。为世师者拔过俗法。志行清净明尽因缘。济度群生作无请友。心普安救诱育立之。执持无畏十种力。进伏众魔降诸外道心无秽行。被坚金刚大德之铠志不有惓。积德因缘不可计量。施戒忍进定智已备。心等一切蠲除杂相弃捐二见。以越智度解因缘法。已入深奥难极之要。去离声闻缘一觉念。不舍大乘一切智心。意行坚强常得自在。身净无垢晖曜明彻。志若虚空。无数诸劫意不惓者逮获总持。降除贪秽自大贡高。等如逝者空无相愿。以过如住梦幻影响野马水月。于斯诸法等解不动。重三宝教奉而敬之。转其法轮而无所碍。欣悦信乐皆自得之。如优昙花亿世希出。志静安独普有具相。宿树恭恪明贤大士。尊修上义法住若此。为彼正士故问如来

唯愿如来至真等正觉。解说菩萨大士所行。得游法门入金刚德果达深妙。使其修应获总持场。以四谛行顺化声闻使解要真。导众缘觉静起因缘。奖以一心使等正觉。欲达诸法当入大乘。晓入大乘能伏魔场。散弃疑结过度罪恼。普知众生意志所行。积最辩达布演诸法。随一切愿化示所欲。善哉世尊。如来无著平等正觉。广为贤明大士之故普弘演说。使诸菩萨得致智力。降己自大得法上力。晓解央行不有所造使得施力。所有无惜惠不望报使得戒力。等除众罪而过诸愿使得忍力。于诸苦法受生之处。身命无惜得精进力。积众德本志常无惓使得定力。善寂居静解定要行使得慧力。而过邪见疑冥昧昧。晓权方便济度众生。明了劝助具达五通。天眼无限彻听知心神足明宿。以此游乐果大辩才。辩才句义无尽不断。便得总持志无恍忽。令逮海印三昧正定。进随普智果同一味。得佛志定习乐通行。永常奉尊而无障蔽。逮法志定勉进定意。长久闻法都无限碍崇众志定。普令一切奉不退众。得施志定俗货法施。不有遗惜具足于戒。行念静定使速得佛。心而无忘升天志定。常念兜述一生补处。志乐菩萨清高之行。尔时龙王。质疑毕讫悦心怡怿。重以赞颂启问世尊

  大仁愿说现世义　　菩萨德行所当入
  内性志操所应修　　兴发何道行云何
  顺导以慈行入悲　　意以度众护济念
  弘化定智使清净　　愿垂哀伤而普说
  诱众止意及意断　　根力神足行如是
  演道七觉散示众　　愿说彼德所应奉
  施调捡戒德具足　　忍力普行及精进
  慧志因缘转无量　　云何度彼蒙说之
  辩才通达勉愚冥　　志行详审常清净
  诸起生者即觉知　　唯愿为诸菩萨说
  欣悦之德有欢豫　　圣种七财是行最
  乐游闲居及修静　　唯蒙慈尊广度说
  辩才行具云何得　　深致总持永安住
  弘法要说常无断　　闻辄奉行终不忘
  寂灭清净而行观　　觉意深邃智广博
  其慧难究德无边　　解行云何应菩萨
  制持魔力与怒意　　毁坏外道众邪类
  勇德难动若大山　　月明至游弘说之
  晓空无想性所在　　解了野马及幻法
  梦想体像计皆无　　唯愿世尊指示说

于是世尊告龙王曰。善哉善哉快甚无比。乃自发心启疑如来。今汝所问承宿功德。已显大悲为众志友。不劳生死弗断三宝。王之质疑用是故也。闻以谛听受而思惟。吾当广说菩萨大士。应所修行彼此无限。果最要法时龙王言。大善世尊。愿乐思听闻辄受行。宣布十方劝进无惓

于是世尊答龙王曰。有一法行。菩萨应者相好备具得诸佛法。何谓为一。造起道意不舍众生。是谓一行致诸佛法。又有三十二事得普智心。当勤乐行专意守习。何谓三十二。御修内性。执上最志。升行大慈。坚固大悲。志慕无厌。发于精进。仂具猛励。而德强力。又踰踊势。安静无烦。为众忍任。习近善友。专行法事。执御权化。施备忍行。乐于捡戒。谄想已无。灭断伪佞。言行相应。志存反复。常有愧色。内自惭耻。已调怡悦。根行至信。意而制御。得持功德。志远小道。乐弘大乘行。观一切三宝之事使其不断。是谓龙王三十二法。菩萨应此逮普智心

又复龙王。有十六事。进增普智显力弘軏。何谓十六进普智耶。施行众济。具戒无缺。忍应调忍。果上精进。致定诸行。已具智慧。信行悉足。供事如来。游静乐闲。备六坚法。有最十善。饰身口意。德具操行。知足乐静。身三劝彼。修胜定观诸德得备。是谓十六行法之事。应相祥福演大智心。显持佛世流化自由

又复龙王。其普智心。以二十二事而除邪径。以其大乘志修普智。何谓二十二事。行过声闻缘一觉意已。下贡高无我自大。消去谄事。抑俗杂言。远弃非戒。拔恚怒根。免却魔事。除去蔽碍。不章师训耗灭罪除。省己切恻。不论彼非。习离恶友。远逆良善。去非六度。又逝贪惜。戒无不消。已弃诤讼。而离懈怠。于迷自正。舍诸无知。断去无便。却去恶行。是谓菩萨普智释除二十二邪轨。速应权慧永无懈退

又复龙王。二十二踊事。进顺随行得普智心而不可当。诸魔波旬及魔官属。并与外道降而却之。何谓二十二踊。过戒事踊过于定。亦踊过智而过慧行。踊过权化。亦过大慈。踊过大悲。以要言之。过空相愿我人寿命。过离众见及发因缘。过心自净承觉神圣。过于识念应不应见。过大金刚坚固之行。是谓龙王菩萨所行二十二踊法致普智心。一切众魔及诸魔身。并邪外道不得自在。无敢当者悉降却之。又复龙王。其普智心。依二行处致普智心。何谓为二。如其所言修应行处。诸功德本观道行处。是谓二事普智行处。复有二事。其普智心而不可毁。何谓二事。在于众生无增异心。于诸殃行济以大悲。是谓二事普智无毁。又复龙王。其普智心有二重法而无过者。生死之党及众声闻。并诸缘觉无能胜踰。何谓为二。执权方便深行智慧。是为二事普智重法

又有二事休普智心。何谓为二。处毁无疑滞结之心。在在不安乐俗诸乐。是谓二事休普智心

复有二事护普智心。何谓为二。不志声闻缘觉行地。观睹大乘至美之德。是谓二事护普智心

复有二事妨普智心。何谓为二。志常多佞内性怀谄。是即二事妨普智心

复有二事不妨普智。何谓为二。专修直信行于无谄。是谓二事不妨普智。又有四事盖普智心。何谓为四。数乱正法。于诸菩萨贤明达士亦不奉敬。常无恭恪。不觉魔事。是为四事盖普智心

复有四事。于普智心而无其盖。何谓为四。护持正法。谦恭受听。尊重菩萨视若世尊。常觉魔事。是为四事普智无盖

又有五事致普智心。何谓为五。所行无望于生死漏用戒德故。不舍一切以大悲故。憎爱无二身命施故。财利周惠供事法故。是为五事得致普智

复有五事进普智心。何谓为五。习善知识。不患生死。志远无益。去非时心。求诸佛智。是为五事进普智心

复有五事在普智心。过诸声闻缘觉一觉念。何谓为五。过声闻脱。过缘觉脱。过众智心。过诸吾我。又过习结。是为五事过诸行法

复有五事于普智心而有其悦。何谓为五。悦过恶道。悦审普智。悦具觉慧。悦戒无厌。悦解众行。是为五事普智之悦

复有五事发普智心。得五力助不溺生死。何谓为五。无其怒恨用忍力故。能满诸愿用德力故。降己自大以智力故。勤势广闻用慧力故。过众恐怯无畏力故。是为五事致诸助力

复有五事在普智心得五清净。何谓为五。体众秽行净。诸堕者因缘诸根无惑净之。随顺诸时以观净之。行治于等权道净之。一切诸法化转净之。是为五事普智清净

复有五事得普智明。何谓为五。明解无欲。明己彼心。明于五句。明达慧行。明眼无碍。是为五事致普智明

复有五事广普智心。何谓为五。以其五种五根五茎五枝五叶五花五果。何谓为五种日修志修。而净内性。等观人物。求习脱行。弘于权变。是为五种。何谓五根。以大慈悲。德本无厌。劝进众生。使免小乘。不志余道。是为五根。何谓五茎。晓权方便。慧度无极。示导人民。护持正法。等观喜怒。是为五茎。何谓五枝。施度无极。戒度无极。忍度无极。进度无极。定度无极。是为五枝。何谓五叶。乐进闻戒。求处空静。常志出家。心安佛种。所游无碍。是为五叶。何谓五花。得文相具积满德故。众好绣备种种施故。七觉财具心无杂故。致有显辩不蔽法故。深达总持闻无忘故。是为五花。何谓五果。升致戒果。已得度果。达缘觉果。又得菩萨不退转果。获佛法果。是曰五果。斯谓龙王菩萨七五三十五事广普智树道宝行也。修应之者得佛不难

佛告龙王。其有菩萨。欲受持此普智心树深妙明显要行句者。当勤加习普智宝树。如是龙王。吾视一切诸法功德。莫不由斯宝树奥义。诸发无上正真道意。悉皆因是普智宝树至要句也。譬如龙王选植树种。知此已致树之根茎枝叶花果而甚盛茂也。如是龙王。其有能受普智心种。斯已得致诸佛贤圣最上慧法三十七品。是故龙王。欲入普智所行功德。欲转法轮。当受持此精修诵读专心习行。广为一切宣传布演。如是龙王勤受学此。当佛说斯普智心品法语之时。诸龙众中七万二千。皆发无上正真道意。龙王太子及诸婇女万四千人。悉皆逮得柔顺法忍。五千菩萨承宿德本悉得法忍。时阿耨达并余龙王及诸眷属。自乘神力踊升虚空。兴香之云忽便普布。调和美香及末栴檀。微雨如来及众会上。又化琦妙珠交露盖。遍覆王舍一国境界。而悉欢悦于上歌咏。至真如来积祚巍巍圣德无量。列住云日各现半身光文虚空。一切众会莫不见者也

    清净道品第二

于是龙王复白佛言。甚未曾有。唯然世尊。乃若如来博为众生。说道俗及心普智心行德所应。又唯世尊。如来无著平等正觉。愿演散说菩萨之行。修应清纯明贤所由。得道清净使其终已。长久无垢不中有懈。无惓弗退。至得十力四无所畏。而得具足诸佛之法。尔时世尊告阿耨达。善哉龙王。勤思念行。吾当广说菩萨大士清净道品。阿耨达曰。甚善世尊。幸蒙授教唯愿说之。于时圣尊告龙王曰。菩萨行有八直正道。当勤受持。何谓为八。六度无极道。恩行之道。得五通道。行四等道。及八正道。等众生道。三脱门道。入法忍道。如此龙王。是为菩萨八正行道。何谓菩萨度无极道。度无极道者。诸所布施劝彼普智。何则然者。不以无劝施成普智。其行劝助于德本者。斯得施度无极名目。又及行戒忍进定智。亦以劝助彼普智心。乃得慧度无极名目。是曰菩萨度无极道。恩行道者含受众生。何则然者。以彼菩萨演示法度。菩萨行恩含受一切。覆以四恩广为说法。而使众生顺受戒化。是四恩道。神足道者。睹诸佛土天眼彻视。见众一切生者终者。又见十方诸佛世尊弟子围绕。悉见如是。于诸佛土以其天眼。应当所采而采受之。又其天耳听诸佛言闻辄受行。在于众生及诸类人。而皆明晓悉了知尽。为随说法得识宿命。不忘前世所作功德。又具神足游过无数诸佛国土。应以神足当得度者。辄弘神足而度脱之。是神足应道。又何谓为四等行道。其随修净梵志中者。并及诸余色像天子。知彼意行随顺化日。斯则慈悲是为喜护。建立以道使彼应度。此谓菩萨四等行道。其八正道普悉行之。声闻所由。缘觉依因。大乘亦然。是谓贤圣八直正道。何谓心等诸众生道。当为此兴不为是兴。为斯可说为此不应。是有贤德此非福人。斯为尽应此复不应。行等菩萨尽除此意。是谓心等诸众生道。何谓菩萨三脱门道。得致以空断诸妄见。以其无相除众念想应与不应。以其无愿永离三界。是谓菩萨三脱门道。何谓得致法忍之道。受拜菩萨菩萨自觉行应于忍。得为诸佛世尊所决授者无上正真道意。是谓菩萨不起忍道。菩萨致此八直正道。弘化流布权导无碍。时佛说是八正道已。二万四千天龙及人。悉逮应此八道行也

若是龙王。菩萨以此八直正道等涂一归。用无等故。莫有能与菩萨比者。亦无其侣独步三界。静一心时修致慧行。应当所得已自果之。明达诸法而如本无。斯谓如来。是曰龙王八正之道。为彼一切凡诸若干众生所行。兴种种说而此要说。等同一向以无望说。归未至说也。云何于此道清净耶。曰道无垢。用无尘故。是道无瑕本无念故。是道无冥。慧照明故。是道无著。本清净故。道常无生。无所灭故。道如永无本。无有故。道无漏秽。三界净故。是道寂然。过凡行故。道无可至。无有去故。道无所来。无从来故。道恒无住。过诸欲故。道无所处。过众见故。道无胜者。过诸魔故。道大弘覆。外道不及故。道永离妄。自大者故。道无所容。不修入故。是道极远。用希望故。道为永离。过愚夫行故。道可果致。修行者故。是道夷易。乐勤行故。道极平坦。住正见故。是道无妨。修无毁故。是道无碍。等正行故。是道无垢。三毒净故。是道清净。终无著故。是谓菩萨道之清净。若是菩萨于清净道务进勤修。又应行者。彼于法性已悉清净。得净我性。亦以而过。法性净故则数性净。数性净故无数性净。无数净故得三界净。三界净故眼识性净。眼识净故意识性净。意识净故得空性净。空性净故诸法性净。用是净故则诸法等等净如空。空等净故得众生净。以诸净故便无其二亦不着二。无二净故则道清净。以斯言之清净道也。彼无众念亦不念道。诸念悉净若如泥洹。于彼永无是谓无念。应无所念无念道者亦无识念。其道都无心意识行。以此言之清净道也。说是清净道品法时。二万天人皆得法忍

时阿耨达复白佛言。云何世尊。菩萨大士修是清净而应向道。圣尊告曰。如是龙王。菩萨大士欲行斯清净道意者当晓净行。亦使其身口意清净。何谓身净。己身已空解诸身空。身之寂静解诸身寂。身之已脱解诸身脱。身之怠慢解诸身怠。身之如影解诸身影。是谓菩萨清净道也。又云身净身行无生。其有生死观于无生。彼以无生而等生死。则其知身亦晓身行。何谓身行。去来生法来无尽法。见在景法终无尽法。其无尽者是谓身行

又复身法因缘合会。其因缘者。则空无想淡然无念。若此龙王。是像法观斯谓身净。又若如来身之无漏不堕三界。观身无漏如如本无。以无漏身不堕三界。彼无漏身能入生死。其无漏际无惓舍退。以无漏身示现色身。如此现已。亦不念灭身之法本。如如来身净众生身净。己身亦净等如本无。是谓菩萨行应清净。何谓口言为应清净。一切贤愚言皆清净。所以者何。用等相故。凡夫劣势着于音声。若信不谛忧喜无常。乐于颠倒观察众生。无本都无淫怒痴欲。何则然者。以诸字说声出皆净。无欲恚愚亦无其着。以此谓之一切言净。以言言之。何者为言。以欲恚痴而为言耶。诸垢为言乎。言者无著。不着眼耳鼻口身心。所言风像风动声出。因缘合会使有声耳。所言如响。贤愚所言皆同如响。所可言者。不住于内亦不出外。于其中间而不可得。住本所念及其所行。出于言者并所念想无住无想。是谓龙王如来所言及其众生一切音声。皆空非真损斯法耳。曰唯世尊如来所言斯不谛耶。曰是龙王如来审谛。所以者何。如来谛故。解知诸法非真非谛。又复龙王。如来所言随字音声。皆答众生一切音声。尔故众生亦转法轮。而亦不知法之义顺。以此报应使其行之。随如等灭众苦之事晓解诸法。行了如是众生音声已无所住。在诸烦恼而常闲静。现出欲言于着无著。声出所言讲论谈语。其如法者不有违错。是谓菩萨口言清净

何谓菩萨心为清净。其心本者不可染污。所以者何。心本净故。其所可谓客欲垢蔽。菩萨于斯不有所著。了解以权于本自净。又其心行不撰德本。彼德本者了识心本。以此心行慈及众生。识了知彼空无我人。其心德本助观于道知等彼道。观如是者斯谓心净。以此净心。与诸淫恚愚行者俱。而永不受欲怒痴垢。与操行俱不着诸秽。是谓菩萨身三清净。说斯清净道品法时。三万菩萨逮补生处

    道无习品第三

又复龙王。其菩萨者乘是净心。生于欲界而在形界。与诸天俱处众梵中详安静然。在中进止无胜动者。又斯菩萨能降诸天化道以权。或生形界而在欲界。现如有家与诸众生周旋坐起。不与有劳弗慢众生。亦无自轻。彼以斯净诸定正受。尽自为定不随正定而有所生。何则然者。以彼菩萨执权方便心应净故。若此龙王。菩萨晓解清净行者。当修清净已而习道。如是龙王。菩萨不习以求道习。不习无习以想道习。亦不习于望道之习。亦不求习。了解道习不习所生。冀向道习不习行灭而为道习。亦不求习以为道习。不习无习为道之习。不习执舍以习道习不我人寿。不身无常。不身性苦。不身有我。不身梦幻野马影响。亦不身空无相无愿。不身无欲法身习道。以要言旨身性诸情。亦不兴有十二因缘。乃至老死无欲之法。不数无数道无二习。不俗无俗不漏无漏不犯无犯。不二之习以求道习。又复诸法无习之习是道无习。斯谓道习不习之习。如空无习亦不无习。当如此习是道无习无相无愿。彼不作习亦非无习。当作是习无[禾*禺]不[禾*禺]诸法无住。勤习如此乃应道习。当佛世尊说是清净行无所习道品法时。三万二千天及世人。悉皆逮得无所从生法乐之忍。五万天人宿不发心于菩萨者。皆发无上正真道意。七万菩萨逮得法忍。尔时一切同声而言。世尊。其有族姓之子及族姓女。逮闻说是清净道品无习法者。其值闻已心无惊恐不舍退者。是皆受习如来无上正真道意。得转诸佛所转法轮。又唯世尊。是辈菩萨悉获无上正真道意。为无量人分布斯法。亦复当坐师子之座。当于天上天下人中极师子吼。犹若如今如来之吼。悉降魔众伏摧外道。显树法幡炽法煇明。震雷法鼓已鸣能降法雨。尔时世尊见诸天龙神之众人与非人又及四辈。闻其至说莫不悦怿于是如来为阿耨达。重复弘演。而说颂云

  道非习可得　　无乃兴习想
  其道行加此　　弃离习念行
  不望求习道　　荡除众异想
  其道都无习　　清净像明月
  若有起习想　　无处亦不习
  已过无习处　　得致最上道
  道为无我念　　亦不与空习
  是道无有二　　安快而无上
  命寿亦如此　　无人及与言
  其道不有人　　无命亦无住
  诸有习道者　　而欲住于空
  斯去圣路远　　是不应道习
  道亦无有空　　以舍于有习
  如本同一相　　永空空于空
  道为无起相　　亦不有灭相
  不起亦无灭　　彼悉为道习
  吾音譬如幻　　解想当如此
  持想行所习　　道当何从生
  道为都过俗　　彼不有身习
  亦无灭身行　　可得致于习
  是身根之家　　本无所演广
  彼不有余求　　本无不可得
  其习是道者　　当如如本无
  如本知本无　　是谓应道习
  诸法之本无　　所觉若如幻
  解行而致此　　乃应道之习
  若其不至道　　所作如不住
  无能止其行　　佛法不由道
  若如所习道　　并及与无习
  所演为如此　　以住于本无
  有限余道者　　劣乘之所依
  是者无上道　　本乘所因由
  诸兴此道者　　以致而无住
  斯则显行德　　可致应道习
  道正而无崄　　端直且平坦
  勤亲行此道　　永离众邪迹
  若如卿龙王　　自住其宫室
  不动于所处　　降雨充大海
  大士亦如是　　习道如所行
  法身而不动　　能满于智海
  又如仁龙王　　在于大地上
  以雨遍充足　　其不有身着
  菩萨德如斯　　行此之所习
  用法满众生　　其内无所著
  若如阿耨达　　龙王大神变
  胜道德如是　　感动普十方
  众生堕邪径　　诸堕受着见
  其住是道者　　将顺度无为
  已住于斯道　　菩萨果大称
  能降魔波旬　　并及邪外行
  得道如其如　　如道无能动
  踊过诸俗法　　其行譬莲花
  道心无有愚　　是行为住止
  千数诸众生　　化度立以道
  以常住斯道　　得致于五旬
  神足诸感动　　为众广说法
  诸事悉清净　　身口及与意
  当愿贤圣道　　人性不可识
  忍行为无著　　其往所可至
  斯得如来处　　示道诸众生
  生死于至归　　斯处则如来
  其往似若至　　此为无所至
  众生所可至　　当念彼上处
  学最佛之道　　游乐以幻法
  其作是习道　　弘道之所习
  彼众德仪行　　诸佛所称叹
  其德无有边　　终不可极尽
  如此习道者　　不习亦无住
  彼处不咎魔　　众都不着行
  其顺此道者　　不起亦无灭
  已得意志行　　总持弘大辩
  施惠及戒忍　　遂增进若海
  身口秽以无　　心洁乃清净
  垢消永无瑕　　修应此道者
  得升于知达　　所行习深妙
  难动惠无即　　守习是道者
  其诸最正觉　　过去与当来
  现在亦如是　　致道世所归
  彼已离众难　　值世遭难遇
  永为诸佛子　　其闻此法者
  快哉诸众生　　至善闻斯法
  真应奉如来　　其乐是经者
  有晓此道者　　能断诸情态
  绍德具众相　　得应三界将

佛说弘道广显三昧经卷第一佛说弘道广显三昧经卷第二

        西晋月氏三藏竺法护译

    请如来品第四

时阿耨达。自与其众诸眷属俱。稽首世尊跪膝叉手。而白佛言。愿请天尊回屈神光。往诣无热之大池中。尽其三月。吾等志乐供养圣尊。并诸神通果办菩萨及上弟子。蒙愍纳许愿受其请。所以然者。吾等供事至真正觉。岂能应于如来仪耶。冀蒙逮闻寂静上化。唯以此法应供养也。思愿重闻如是像法令常欢悦。此乃应奉于三宝耳。尔时世尊不受其请。重启二月如来不然。垂听一月世尊不可。愿纳半月。世尊默然而已受之。于是龙王。自与其众诸将从俱。见尊受请忻喜悦怿善心遂生。绕佛三匝。兴震云电而降微雨普遍天下。忽然之顷还升宫中。时阿耨达到坐正殿。辄召诸五百长子。其名善牙善施善意善明。能灭寂相。感动大威甘威甘权甘德。普称威勇持蜜忍力行祥。如是比等五百长子。宿树无上正真道已。王告之曰。又诸子等。吾今以请如来无著平等正觉。及众菩萨诸弟子俱。尽其半月。世尊正觉垂大慈哀。兴有弘愍而寻受请。汝等当共同一其心广相勉励。加敬世尊至真如来。勤念无常当各寂静。谦恪恭肃住待如来。仪应弃捐淫心欲意及龙戏乐。除贪怒害离欲色声香味细滑。所以者何。世尊无欲而且详安。仁雅审谛顺调寂静。显备诸德侍从围卫。仪容无量皆承诸佛真正要戒。以是之故。汝等半月无得入宫。当除淫恚愚痴之念。又复如来宣讲法故。必有他方神通菩萨释梵持世宿净天子当普来会。汝等勤念广施姝妙。光显严饰慎勿中懈。令诸会众观变踊跃。此乃真应供养如来。时阿耨达都约敕讫。辄为如来于雪山下无热池中。为世尊故。化其无瑕净琉璃座。而使纵广七百由旬乃殊异妙周匝列。置八万四千杂宝琦树。挍以众珍诸宝鲜饰。蔚有光华精耀百色中出美香。诸树间化八万四千七宝之堂。众珍光彩极好无双。施置十万交露绮帐。乃垂异妙赤真珠贯。在诸堂上有师子座。八万四千皆大高广。而布无价妙好杂[疊*毛]床座宝分。施诸交露挍以众宝。所在堂上有龙婇女各二千人。其色姝妙姿美无量。颜像蔍华口出熏香。擎持杂花末香涂香。调作诸妓以咏佛德。兴悦众会于上虚空化大宝盖。周千由旬遍覆会上琦珍彩镂。其宝盖中众色无数。悬好缯幡于幡彩间垂诸宝铃。景风和降音踰诸乐。施馔百味备办都讫。为此变已。与其眷属恭捡叉手。向佛跪膝而遥启尊。以其请意叹咏颂曰

  慧藏知富积辩德　　慧达无著明导众
  慧弘普至不有碍　　慧上最力降神光
  慧解心行唯大仁　　当观十方众生类
  最上神尊受吾请　　念启慈愍唯时屈
  知足无贪而易养　　祥福审谛圣道师
  善行质信知众意　　时节以至可屈尊
  其德普称行等王　　造无请友兴普念
  至仁清净踰若空　　所设办讫枉神尊
  威御十方猛持世　　佛事十八而等有
  度众最首悲踊行　　愿与其众时蒙至
  色妙端正相彩身　　琦好种种花绣文
  志乐欢悦惠法施　　大仁上导愿察时
  梵声清净若雷震　　鸾凤哀鸣师子步
  妙音具足悦诸士　　众心忻望愿时顾
  佛土三千无等伦　　弗有能知如来心
  圣尊明睹众生行　　所修常应时降此
  知时普应怀权化　　了达众生有圣誓
  详审之行目明好　　神威捡足愿回光
  众生甚多普渴仰　　十力持势威无慢
  大仁德峻勇而果　　圣性尔枉升游此
  惭祥备足德最上　　宁救济育遍无极
  师友无双协怀众　　化龙亿百兴有悲
  于世威猛普慈救　　达知众行应如意
  开布散示唯天尊　　轻举神足愿时至

尔时世尊知阿耨达请时已到。告诸比丘。着衣持器差应留守。无热龙王遥跪启时。应受半月宜便即就。于时八万四千菩萨。皆大神通德具果办。弟子二千亦上神足。侍绕世尊周匝而导。至真如来从鹫山顶。忽升虚空神力而进。如其色像身放无数百千之光。遍照三千大千境界普悉晃明。诸欲色天皆见世尊。扬光无数飞过虚空。自相谓言。神尊致彼无热王所。将兴法化演奥无极。及使如来为众围绕。即彼半月中。多诸天数百千众。得见世尊又闻法说。缘复观睹无热所设庄严感变。而令世尊故游到彼。时诸天子各各发念供养如来。或愿散花。或雨名香。或施天乐以歌佛德。或复悬幢幡盖缯彩率随如来。世尊身光昭耀炜炜。明踰日月宿净色净及诸天光。佛之圣威神耀无量。根定寂静行游详安。释梵四天威变种种。奉敬追侍随从如来。于时圣尊到雪山下住止右面。便告贤者大目连言。汝到无热王所处宫。当宣告之。如来已至时可应入。于是贤者大目犍连承佛神旨。忽迁无热大池之中。现于虚空去地七丈。化身像者若金翅鸟王。住阿耨达龙王宫上。便告王言。如来至也。彼诸龙众及婇女等。无不愕然惊恐怖悸。衣毛为竖四之藏窜。展转相谓。此池自初无金翅鸟斯从何来。时阿耨达。告诸宫人太子眷属而慰之曰。且各安心勿恐勿怖。此为贤者大目连耳。承如来使兴神足变。贤者目连到彼告讫。还诣世尊。时阿耨达。便与其众诸子臣民夫人婇女。举宫大小俱而围绕。各奉名花及美末香。并众涂香幢盖缯幡。倡伎种种调作相应进迎正觉。于时世尊。为诸菩萨及众弟子天龙尊神所共围绕。俱而前至无热所设广博座场。如来到已。寻就高显师子之座。菩萨相次。然后弟子诸众坐讫。尔时龙王。观视世尊及诸菩萨弟子众会坐悉而定。兴心无量内怀怡悦。辄与其众手执斟酌。所设馔具踰世甘肥。延有天味肴膳百种。以用供佛菩萨弟子并诸众会。使皆充足。世尊菩萨及诸弟子饭毕。辄各洗荡应器察众都讫。时阿耨达。即启如来愿闻法说。于是世尊日昃时后。便从定起端坐说法。诸来会众满千由旬。从他至上中无空缺。天龙鬼神及人非人。周匝卫绕至真正觉。一切会者各怀踊跃

    无欲行品第五

尔时龙王。悦颜进前跪重白佛。唯愿世尊。为斯众会如应说法。令诸一切免离生死。精除相着五阴诸苦。秽垢昧昧劳尘之行。使其永无三毒意结蒙。及龙众得弃邪冥伏其心意。弘致至善使有悦豫。深行菩萨。后若如来现有存亡。当使吾等所在国邑护持正法。于是世尊赞龙王曰。善哉善哉。阿耨达王。谛听其义勤思念之以宣布示。吾当广说令此会众。多免罪痛根拔杂想意识志疑。使解普智升游三界。时龙王言。善哉世尊。愿乐广说当顶受行

是时圣尊告龙王曰。有一法行菩萨应者。为天世人甚所敬重。何谓为一。志修深法以行无欲。何曰深法法行无欲乎。如是龙王。菩萨依顺因缘之无离二见际。知有无者斯见诸法。依着因缘不见有法不由缘生。彼作此念。其依因缘斯无依缘彼不依魔。其依缘者彼不言吾。亦不言我。又其依缘中无我我。依缘无主亦无执守。其依顺缘了解起生。速易得致四依之念。何谓为四。依于至义而不文饰。依于慧行不为识念。依顺义经不依攀缘。依念于法而不为人。彼何谓义何等为慧。云何顺义何谓念法。义谓空义。不受妄见无相之义。不着念识无愿之义。不着三界无数之义。不着于数。又复义者。于法非法而无其二。音声无得。念想无念。法处无住。用无人故命寿言声伪无所有。又复为义。其法义者为无欲义。何谓菩萨为法义。其无眼色耳声鼻香舌味身更心法之义。不生色义。不灭色义。不为痛想行识之义。亦不生灭识行之义。亦不欲色无色之义。亦不生灭欲色无色义。亦不我义。亦无我见着人之义。不有人义。亦不着人见入之义。亦不着入有佛身义。亦不法字着入之义。不数计会有着入义。亦复不有施戒忍进定智着义。晓入一切诸法之义。是谓菩萨为法义也。其从是义而不有退。是谓为义

彼何谓慧。日苦无生慧。习无念慧。尽都尽慧。道无志慧。于阴幻法诸性法性而无毁慧。在于诸情空取为慧。解入诸法明了众生。根满具慧志念无忘。于诸止意不意无念。于诸断意等善不善。于其神足身心建慧。又于诸根了轻重慧。于诸觉意觉诸法慧。而于诸力已降调慧。道为无数于灭寂慧。观别法慧。始不生慧。来不至慧。中无住慧。于身像慧。言以响慧。心法幻慧。是谓菩萨明达智慧。又何谓为顺导义经。从是因缘而起。然者灭于愚痴。灭于老死无我。而然于无我人及与命寿深解诸物。若如来我皆非真法。而然于三脱之门也。等于三世求三无著。所谓诸法见都无生。视了知者而得等灭离俗情态。菩萨来智慧度无极。于诸意念而无疑惑。应入是行。斯谓顺义。无所去至亦无从来。泥洹无为不有去至。是谓顺义。何谓如法。若诸如来兴与不兴法身常住。是谓如来。如如本无而无增减。不二无二真际法性。谓之如法。不毁行报无行报法。斯谓如法。大乘者由六度无极。缘一觉乘从因缘脱。声闻之乘依音声脱。是谓如法。施致大福戒得生天。博闻多智定念致脱。斯谓如法。从行不修兴有生死。行之纯至而立无为。如法之谓。愚以欲力智则慧力。斯谓如法。其一切法悉依法性。如此龙王。其依因缘而起生者。斯则应得四依之念。其依因缘彼则不依断著有无。是谓其见因缘起者。斯见诸法。其见法者斯见如来。所以者何因缘乎。龙王。等起无起法于非法。等而无著。又如来者。亦为无著因缘之起。亦无有起法不可得。觉其法者斯则如来。于因缘起慧眼见之。慧眼见者斯则诸法。见诸法者。斯则如来。是谓其见因缘起者。斯则见法。其见法者斯见如来。又如来者以法见法。如是龙王。若以此法行应脱者。斯谓菩萨而无欲行。又呼龙王。无欲菩萨不作欲习。悦乐贤圣舍非贤圣。勤慕兴护于贤圣种。广合诸慧为法作护。修于博闻志树无忘。不舍戒身。智身无倾。定身不动。于其慧身得善坚住。脱慧见身强固难转。脱慧见故。又复龙王。无欲菩萨。得无数佛正法度义。亦具无数诸佛要慧。又果无尽诸佛之辩。得通无量诸佛神足。因致无数诸佛权解。普入无量众生之行。游过无数诸佛国土。因见无数百千如来。缘得听闻无数诸法。得无数义达无数慧。晓无数行度无数众

若是龙王。无欲菩萨常应清净。消尽众秽德不可量。三界自由不有所著。何则然者。以其无欲自从心生。有三事从心出生。何谓为三。从其欲生。又从爱生。亦由起生。复有三生。观于起生。又观起生。又观所行观心无处。又复三生。灭寂专一。晓解于观。如法随行。又复三生。德备仁调。以为寂静。从行勤生。又复三事。从于行直。而无有谄。仁慈调忍。复有三事。无沉吟疑。顺善不粗。志足易养。又复三事。从其空生。又复无想。亦由无愿。又复三事。心之所生诸法无常从其心生。诸法皆苦亦由心生。诸法无我亦从心生。复有三事而从心生。诸法无常。诸法无我。灭尽无为。皆从心生。如其龙王菩萨等灭。亦由心生。谓其不舍普智心。行等一切。以大慈故。不舍众生。大悲心故。不厌生死。用大喜故。等离喜怒。以大护故。所有慧施不望报故。众戒学行德义备故。内免己过不论彼短。能忍众生诸不善行。欲令彼人心固金刚。合集众善诸德之本。身命无惜得致一切。诸定正受心无劳惓。不以正受而有所生。晓智以权顺随众生。以其谛慧度诸志脱。欲达声闻缘觉乘者。显念佛法求诸佛法。心能忍苦广宣法故。众利敬养蔑而弃之。志具诸相德行无厌。充满智慧博勤多闻。习善友故值善知识。用谦敬故得应谦行。降自大故以降自大。志行备故具满意行。用无谄故以离谄者。言行应故以其无欺。修诚信故以住信言。离众欺故灭除妄语。生诚信故降心于信。如是龙王。其有菩萨而生是心。斯谓无欲。又复龙王。无欲菩萨。魔不能得其限便也。所以者何。以彼菩萨应无限故。而亦不行有限之法。彼何谓为是限法乎。欲淫恚痴斯皆有限。菩萨于是不有所著。以此谓之为无限也。声闻缘觉其乘有限。菩萨住于普智心者。魔终不能得其限便。有念无念念想有限。菩萨以离众念之应。如此菩萨。魔不能得其限便也。如是龙王。有二魔事。而是菩萨当深觉之。亦当远离。何谓二事。于其师友无恪敬心。而自处大贡高蔑人。是谓为二。又二魔事。舍菩萨六度无极藏。心返喜乐亲行声闻及缘觉法。复有二事。何等为二。无其智慧而欲行权。与诸堕着望见众生乐相狎习。复有二事。寡闻少智自以慧达。虽有通博于中自大。又复二事。于德甚少妄生尊贵。若修德行而乐小乘。复有二事。正法不护。不度众生。复有二事。志不乐习于诸菩萨。及众通达明智者俱。专行诽谤清高菩萨。主为法师数兴蔽碍。又障师训而多谀谄。又二魔事。舍诸德本。心存不德。复有二事。虽在闲居怀想三毒志常愦闹。若游国邑有贪利心。复有二事。为非其人说深要法。应当为说而反不说。复有二事。不觉魔事。远离普智意数错乱。如是龙王。其诸魔事色像若斯。无欲菩萨而永无此。又复龙王。若有菩萨修于清净行应无欲。当致菩萨十六大力。以此诸力降调己志以化众生。何谓菩萨十六力耶。曰得志力意力。行力惭力。强力持力。慧力德力。辩力色力。身力财力。心力神力。弘法之力。伏诸魔力。无欲菩萨。得是菩萨十六大力。何谓菩萨为志力耶。如是龙王。菩萨志力能览诸佛一切所说总而持之。是谓志力。斯菩萨意应诸佛行。于诸众生而无断碍。是谓意力。能达一切音声所说解了诸义。是谓行力。离诸罪行与众德法。是则惭力。一切诸难不为非行。斯则强力。亿千魔兵不敢而当。是则智力。通达持法宣示等学而无遗忘。斯则持力。无著不忘。于百千劫。其所可说无碍不断随解诸法。是则辩力。若诸释梵及四天王。往诣菩萨黯然无色。是端正力。以其宝首所可念愿应意即至。是则财力。过诸外道在中独尊。是则身力。众生之心能一其心。知众生心顺行化之。是则心力。众生应以神足度者。为现神变使众睹见。是神足力。若所说法使众闻之而无中断。彼受顺行等除苦尽。是弘法力。若其禅定正受之时。得承佛旨贤圣行法。是降魔力。斯谓菩萨十六大力。其有行者志慕愿此十六之力。而欲得者当修无欲。譬如龙王一切河流归于大海。道法诸行三十七品悉归无欲。又若龙王诸药草木依因于地。诸善行法皆由无欲。譬如龙王转轮圣王众生所乐。若此其有无欲菩萨。乃为诸天龙鬼世间人之所爱乐也。尔时世尊。为阿耨达并诸太子。而说颂曰

  欲为慧菩萨　　志愿佛道者
  彼当离秽法　　常勤行无欲
  慧解因缘法　　不猗于见际
  睹法以因缘　　无缘不有法
  缘生彼无生　　是不与自然
  善缘斯亦空　　知空彼无欲
  着缘而无相　　脱愿寂复寂
  澹泊像大愚　　其处魔不审
  见法无著缘　　于其无吾我
  彼不有我人　　知是则无欲
  无主不守护　　不获亦弗舍
  本脱无取舍　　离欲常了法
  观义不为饰　　慧行常脱识
  晓了顺义经　　依法不为人
  空义是佛法　　及脱无相愿
  不猗造见念　　是义其无欲
  于法不有二　　音声无可得
  处法难可动　　不人义无欲
  法义无欲我　　眼耳不色听
  鼻口离香味　　身心无更法
  不色生威仪　　又不离痛想
  亦无识住我　　达是应法义
  不住三界义　　亦无吾我义
  世尊无色身　　无字法说义
  计数非法义　　至要不以施
  非戒忍进定　　慧无我世尊
  诸法解无义　　智谓是法要
  于义永非义　　无欲则佛法
  无生晓苦慧　　不起无有灭
  不生亦无终　　如是应尊习
  五音解若幻　　知其如法性
  晓内如空聚　　了是为无欲
  知法至趣向　　明达众生情
  逝念以止意　　无欲得是慧
  意断无有二　　神足心轻腾
  以力而无慢　　诸根知止足
  觉定解以智　　明了八直道
  慧观于灭行　　解法所至归
  本法不有生　　当来而未至
  现在无住法　　不欲知如是
  身像无坚固　　语空譬如响
  心幻若如风　　无欲解如是
  知说顺义经　　了达于因缘
  本痴生死灭　　无欲是慧义
  无我人命寿　　解了法非法
  以脱于三门　　所说空无著
  无生见灭道　　习慧喻俗行
  不从心意生　　无欲觉是行
  法性常如住　　佛兴及灭度
  无二觉不觉　　无欲知是法
  其积如本际　　彼积悉诸法
  空积及人际　　无欲达是智
  法性常以住　　觉起而灭度
  不识知其二　　无欲法如是
  不殃善不善　　知法无罪报
  佛法不从他　　从行度无极
  以离因缘觉　　音脱声闻行
  惠施致大富　　彼见戒生天
  博闻得智慧　　守意化众生
  至圣都守意　　无欲法如是
  力常转诸欲　　智慧志存法
  等念是诸法　　法性常无得
  识智因缘起　　而致四德行
  知义及与法　　顺义知无欲
  观缘彼见法　　以法见世尊
  等于起灭法　　无欲了尊法
  因缘迹无得　　音声法无字
  斯法得本无　　是圣谓如来
  以慧见因缘　　无见不见法
  明慧了因缘　　是谓见世尊
  彼求无欲行　　悦性诸贤圣
  法性毁不舍　　而护圣贤种
  常护佛正法　　无欲闻不忘
  戒根不舍离　　于定达难动
  知身慧不动　　常住于脱身
  及脱慧所见　　无欲常安住
  解人诸佛法　　无量众圣道
  得佛神足具　　辩达一切行
  知众情意行　　忽然游诸土
  得见诸如来　　受彼所说法
  闻守解达义　　宣示无量人
  知彼亿数行　　志得向无数
  无数当自在　　降心入功德
  伏意使无欲　　终不迁是世
  诸阴心以脱　　了知起灭处
  观灭无所有　　所习以而无
  声性心所行　　不谄常端直
  无佞调仁善　　无欲德如斯
  以脱空想愿　　解苦知生死
  无我法常寂　　无欲从心行
  普知心等慈　　以悲济众生
  喜不厌生死　　行护无有边
  所施无望报　　省己立诸行
  忍耐善不善　　念脱彼众生
  勤精强修德　　不计有身命
  以次知诸定　　亦不随于定
  慧定大精进　　于数不堕薮
  以谛化声闻　　智不志灭度
  无欲值佛世　　彼有此诸法
  魔不知其行　　安住法了是
  无欲不有限　　晓是贪茹根
  离欲彼无想　　魔不知其处
  其想吾我应　　彼自起魔事
  是悉度诸行　　众魔而不审
  无欲志不忘　　所行常清净
  无欲不意志　　惭行而不毁
  以闻无欲者　　悦慧敬如来
  其住如法住　　彼应如世尊
  诸佛十力者　　菩萨欲奉事
  闻斯无欲行　　勤意当受持
  其闻此无欲　　悦信广奉行
  彼常致无欲　　得佛是不久
  无欲圣所由　　而致最清净
  无欲得成佛　　以化无有边
  去来现在佛　　诸得众相好
  悉从斯无欲　　及行是法故

尔时世尊说是无欲法品之时。诸在会者四万二千天龙鬼神人与非人。皆发无上正真道意。万二千人得不起忍。又八千人逮柔顺忍。三万二千天子神龙。得离尘垢悉生法眼。又八千人而离欲行。八千比丘漏尽无余。当尔之时。三千大千世界六反震动。普遍十方熀然大明。于雪山下无热池中。周匝现有所未见闻。光耀妙花皆至于膝。其池水中普生乃异。鲜饰莲花大如车轮。中出美香花色无数百千诸种。皆是佛之威神所致。亦为是法兴其供养。以悦无热龙王意故

佛说弘道广显三昧经卷第二佛说弘道广显三昧经卷第三

        西晋月氏三藏竺法护译

    信值法品第六

尔时阿耨达龙王。心甚悦豫。又及龙王五百太子。宿发无上正真道意。闻佛说是。寻即皆得柔顺法忍。忻心无量各乐供养。辄为如来施饰宝盖。进上世尊。同时白佛言。圣师如来至真正觉。为吾等故出现生世。何则然者。令吾等闻普信道品。得闻是已。意而无惓不有懈退。亦无惊恐。闻以加重专心习行。乐听无厌如是像法也。又惟如来解说。菩萨云何得值诸佛世尊。如来告曰。诸贤者等勤念受听。吾当广说。诸太子言。唯思乐闻。彼诸上士受世尊教。如来告曰。树信贤者兴值有佛。何谓为信。信谓正士修诸明法。奉之为先。何谓明法。曰依行应不离德本。习求乐贤慕随圣众。勤心树信志无劳疲。思侥闻法拔弃阴盖。顺习于道得法利养。以施周慧戒与不戒。济接等与在诸恚怒。而常有悦勤乐普智。心无懈退信佛不休。未曾乱法悦心圣众。志道难动喜乐正真。而离贡高于众自卑。常有等心诸处无著。终舍身命不造恶行。修立质信言行相应。等过于着心无垢秽。身口意行顺随圣化。明了诸事得为清净。知足无贪所行应净。晓入智幻习求慧根。依顺七财修念诚信。根力以备而行正见。所受师友谦恪礼敬。安足易养数诣法会。心无退厌有患生死。示无为德勤心精进。求升普智以弘道化。于如来法志乐出家。修诸无数梵清净行。造立慈悲救彼众生志存反复。其有报恩及不报者。等接护之心无适莫。不自念利常悦彼恭。忍调之行以悉备足。目见无恶不背说人。内性以寂志于闲居。心常乐静专念习法。而无诤讼等己彼过。求备戒具集合定行勤谨于道。斯谓贤者。行应俗信树信如是。此谓兴值佛世者也。又贤者等。其于世俗造信无忘。是谓兴信值佛世也。又贤者等。何谓俗信。其有信者信诸法空以离妄见。信知诸法以为无想而离念应。信知诸法悉皆无愿不有去来。信知诸法无识无念。静身口意寂无有识。信知诸法以为离欲。无我人寿命。信知诸法。信知本无去来自然。信知诸法真际无迹如本无迹。信知诸法已皆自然等若空迹。信知诸法而依法性。信知诸法等过三世。信知诸法欲处邪见而皆悉尽。信法无著以离本痴本无清净。信知诸法心常清净。亦不兴起客欲之垢。信知诸法无所观见。信诸法护等断众行。信法无我以过喜怒。信诸法无心无形像而不可获。信诸法伪如握空拳诱调小儿。信法无欺不有上下无所舍置。信诸法虚若芭蕉树。信法自由如常寂静。信法无审不住三处。信法永无不有所生。信法若空以等无数。信知诸法若如泥洹常自寂静。如是贤者。其于世俗兴起是信。斯谓造信而值佛法。又复贤者。其有信值佛法名者。此则名曰诸法都无起之谓也。所以者何。不色生故。不色无生化转之习。不痛想行识。已无识起。不以眼耳鼻舌身意。无起转习。不身起转。不痴有无。不生老死。有无起故。如值佛世。不起有生亦不起灭。又复无起习于无灭。不以正意无志意习而值佛世。总要言之。亦不以三十七道品法起无起习。亦不以道无生之习。不以起慧亦不灭慧。不慧无慧无二之习。如值佛世。当说值信佛品世时。无热龙王五百太子。皆悉逮得柔顺法忍。于是世尊。复说颂曰

  兴信值佛世　　而习于不生
  其无向信者　　斯不值佛世
  修信谓最上　　从致清净法
  行质有报应　　不违厥所修
  信习诸贤圣　　勤随常礼敬
  心不有懈退　　此信之所行
  勤行听法说　　阴盖不能动
  从信得致道　　行逮于柔顺
  以法所得财　　转惠普周济
  护戒与毁戒　　行信而等施
  能悦诸恚怒　　道心不懈惓
  勤求大乘法　　有信悦向众
  永离大贡高　　志常自卑下
  所在无所著　　立信相如是
  志信不惜身　　终不造恶行
  守善无妄语　　言行常相应
  悦信以过界　　乐行于无心
  身口意清净　　习随圣所护
  有信行内净　　常为慧所将
  知身之要本　　求问宣所闻
  等念于七财　　得力根以足
  长离众邪见　　志常习等行
  礼恪有悦心　　敬事如其师
  心宿善虔恭　　知足无所遗
  其心常无念　　所志唯道法
  有厌生死者　　引示无为德
  脱之所当行　　唯常求悦心
  速离于是世　　修梵行无惓
  怀受诸众生　　救彼无利望
  当报所受恩　　悦信当勤求
  己利不以悦　　亦不嫉彼供
  仁忍而悉备　　无谄调质直
  行信目所见　　不背说人短
  根寂性安敏　　志悦乐闲居
  其心无愦闹　　自励备恩行
  先顺不有诤　　内省克己过
  勤求具戒行　　专习于定道
  悦信慕乐行　　信者相如是
  其过欲信者　　彼行而解此
  兴法不有诤　　深妙佛所说
  诚信信于空　　彼都无众见
  诸法无有想　　不意离众念
  当除断诸念　　觉了去来事
  法求无著作　　不有于身心
  信为无欲法　　离我人寿命
  信者解无本　　得至不二处
  其本无有积　　体无若虚空
  诸法信亦然　　便与法性同
  等过于三世　　诸法无有漏
  欲处及与贪　　乐信无受见
  诸法不有着　　其本明清净
  客欲无能蔽　　不处心有住
  诸法不可见　　因缘而无起
  常观于高行　　不受所住短
  无合不有离　　脱者无合同
  信悦于空法　　愚之所可惑
  湛泊意无起　　欺伪如芭蕉
  口言而自然　　无去亦不有
  诸法无所有　　所见皆不要
  其法若虚空　　等缘无有数
  诸法如泥洹　　本无不可见
  信悦而行此　　解了身虚空
  其有如是信　　菩萨及凡人
  彼则值奉佛　　所处无有恶
  不以造色行　　得应值佛世
  无色不有处　　不来亦不去
  于色无有生　　不灭亦无住
  当来无所至　　值佛广演说
  五阴亦如是　　化习转无生
  值佛当敢说　　慧达诸菩萨
  其身及诸情　　亦习以无生
  佛兴以无生　　常救诸堕生
  痴本无有生　　生死亦如斯
  是缘如本无　　从法而有佛
  无起不有生　　不灭无有住
  是以知无处　　处亦不可见
  斯亦不自生　　与佛而博演
  无志不有住　　是亦佛所转
  诸种亦如是　　佛种顺如法
  斯类亦起无　　如佛而等与
  其行如是者　　佛兴为若此
  悦信斯大处　　其限不可量

    转法轮品第七

尔时世尊告太子等。又诸贤者。何谓菩萨得转法轮。其有布露如是像法乐说句义。受持不忘修而行之。诸有不发大悲意者。为兴普智随顺众愿。而为说之广宣布示。志不有惓忽弃利养。劝念顺时受持护行。斯谓菩萨应转法轮。又若如来所转法轮。而其法轮。行像入德当粗剖说。不以起法亦不灭法。不以凡夫下劣行法。亦复不以贤圣法故而转法轮。又其法轮。不中断绝等断善恶。彼以是故为无断轮。又其法轮因缘之起。不起无起而有其转。以斯之故为无起轮。又其法轮。不以眼色耳声鼻香舌味身更心法诸情转随有转。以此之故彼无二轮。若有二者则非法轮。又其法轮。亦不过去当来现在所著而转。是无著轮。又其法轮。不我见转非人命寿所住而转。是为空轮。又其法轮。不识行想灭念之转。是无想轮。又其法轮。不于欲界形无形界所望而转。是无愿轮。又其法轮。不计众生有异而转。不处二法。是凡人法。是圣戒法。是声闻法是缘觉法。是菩萨法。是为佛法。彼以是故为无异轮。又其法轮。不以有住法轮而转。以斯之故为无住轮也。法轮名乎。诸贤者等。真谛正轮常无毁故。要义之轮等三世故。无处之轮。诸习见处以等过故。寂寞静轮。身心无著不可见转。意识离故。无樔之轮五道不处。审谛之轮无谛现故。行信之轮。等化众生用无欺故。不可尽轮字无字故。法性之轮。以其诸法依法性故。本积谛轮本无积故。本无之轮如本无故。无所造轮无念漏故。无数之轮导至圣故。如空之轮明见内故。无想之轮无外念故。无愿之轮无内外故。不可得轮修过度故。又诸贤者其如来者以此法轮。转之众生诸意行也。其转不转。彼不可得。法无所舍。于时世尊。说是转法轮品之时。天龙鬼人及诸种神欣心踊跃。显光赞扬如来斯法。皆同声曰。善哉世尊。甚为难值。如来示说转此法轮。闻者奉行则应法轮。是法名转空虚之轮。诸已过佛及与当来。并诸现在悉由是法。其有信者斯则已度。诸行此法。吾等世尊。代其劝助彼诸众生。其兴是心常欲闻斯法轮品者。闻当发求是道要行。彼亦不久得转法轮。于是众中闻是说者。有万天人。皆发无上正真道意。五千菩萨逮得法忍

于是世尊告诸贤曰。又正士等。其护正法。受持正法。营护正法。是谓护法。所以者何。于永无灭应是行者。天及世人终不能当。于时无忧前白佛言。又唯世尊。若斯正士以如是法而得最觉。于其本无不有惑者。又如是像诸正士等当共拥护。所以护者。令诸正士使其速应于此大乘。彼皆行已得转法轮。又能与识法之大明。是故世尊。以斯等教要法正护使发大乘。以护法师安救敬礼顺听禁戒。是时世尊赞叹无忧龙王子曰。善哉善哉。无忧正士。诸发大乘为法师故安救拥护。是谓护法。为诸法师营护正法护持正法。又复无忧。护正法者得十功德。何谓为十。无其自本降下贡高。又行恭敬。亦无谄行。勤思乐法。志慕习法。专意随法。行观于法。乐宣说法。乐修行法。随所志乘顺如说之。是为十行以护正法。又复无忧。有十事行护得正法。何谓为十。若族姓子及于族姓女。所闻法师遥礼其处。思乐得奉。来辄敬爱。供给所欲衣被饮食。护以诸事。往诣谦敬。顺听所说以宣同学。障其说非。常乐称叹。使誉流布。是为十事得护正法。又复无忧。有四施行得护正法。何谓为四。笔墨素施给与法师。衣被饮食床卧医药供养众所。若从法师闻所说法。以无谄心而赞善之。所闻受持广为人说。是为四施得持正法。又复无忧。有四精进得持正法。何谓为四。求法精进。勤广说法敬礼法师。若毁法人正法降之亦以精进。是四精进得持正法。时阿耨达五百太子。闻佛说是。悦怿欣喜欢乐无量。同声言。如来所说。甚善无比解诸狐疑。各以宫室及其官属。尽以上佛奉给所应。以敬顺心而重言曰。从今世尊。当勤受化永常无惓。至于如来无为之后。佛之所说是像宝法。当共敬受是经要品。求索通达劝进修行。斯则世尊。吾等至愿。又若如来无为之后。吾等圣尊在所国邑。当共同心供养舍利。护奉礼敬至于现灭也。于是贤者耆年迦叶。谓诸太子。又贤目等如仁辈言。独欲全完供养如来神身舍利。汝等是言。多断众生诸德之本。障蔽明净翳道至化。使兴是言。何则然者。又若如来本始造愿。使留舍利布如芥子。为诸众生降大悲故。何得全完而独供养耶。彼正士等。即答贤者大迦叶曰。唯然迦叶。勿以声闻所有智限而限如来深邃无极明达之慧。所以者何。若如来者有普智心一切之见。处以神足感动变化。若其兴念。能使三千大千世界天龙鬼神。各于宫殿普令完全安置舍利。使各念言。吾独供养如来舍利。其余者不。又复迦叶。若如世尊无为之后。随众生心应置舍利。又复迦叶。若如来德。至阿迦腻吒天上立置舍利。其如芥子。能普明照一天地内。是佛世尊神威变化感动力也

    决诸疑难品第八

尔时贤者须菩提曰。诸族姓子。又如来者为灭度耶。曰须菩提。于起生处当有其灭。须菩提曰。诸族姓子。如来有生乎。曰如来者。如其本无无生而生。须菩提曰。如如本无无生不生。彼都无生也。答曰。是者须菩提。则佛所生如其本无而不有生。须菩提曰。佛生如是灭复云何。答曰亦复如如本无。生于无生。无为灭度亦尔本无。唯须菩提。不起而生灭度亦尔。如是其灭亦尔本无也。说是语时。无热渊池现大莲花。若如车轮薮有无量种种之色。以名众宝而用光饰。于诸花间有大莲华。色最晖明现奇异好特独踊高。贤者阿难在于无热大池之中。睹其变化所见若斯。寻启世尊。今此变化为何瑞应。兴其感动乃如此耶。如来告曰。且忍阿难。自当见之说适未久。忽从下方乃于宝英如来佛土宝饰世界。六万菩萨与濡首俱忽然踊出。迁能仁界升于无热大池之中。各现妙大莲花座上。濡首童子即就莲花高广显座。是时众会皆悉见之愕然而惊。时阿耨达及诸菩萨。释梵持世来会。诸众悉各叉手稽首敬礼。濡首童子退住虚空。共持珠宝交露之盖。时濡首与诸菩萨俱并莲花座。亦踊虚空去地乃远。于上而雨未曾所见最妙莲花供养如来。从诸花中有声出曰。宝英如来问讯世尊起居无量体祚康强神力安和乎。声复言曰。濡首童子与诸菩萨六万人俱往诣忍土。至于无热龙王渊池观彼感变。又志乐听龙王所问庄饰道品入法要说。为世尊广劝法言。便有欢悦。于是濡首及诸菩萨。从虚空下悉诣正觉稽首如来。欣心肃敬住世尊前。尔时天师。告濡首曰。童子来乎。为何志故与诸菩萨俱至此耶。濡首白佛。吾等世尊。在彼宝英如来佛土宝饰世界。承闻至真能仁如来。垂慈十方演说斯要。闻是法故。寻从彼土升游诣此奉礼天师。缘闻如来所讲法也。迦叶白佛。近如世尊宝英佛土宝饰世界。而诸大志忽至此耶。濡首答曰。唯如迦叶坐一定时。极其神足飞行之力。尽其寿命于中灭度。而由不能达到彼土。其国境界弘远乃尔。佛告迦叶。其土去此。过于六十恒沙佛刹乃至宝英如来佛土。曰其来久如而到此乎。答曰久如。耆年漏尽意得解也。大迦叶曰。甚未曾有。唯然濡首。是诸正上神足若斯。濡首又曰。耆年漏尽意解久如耶。答曰。如其转意之顷。又曰。耆年意以解乎。答曰以解。濡首复曰。其谁缚心而有解乎。答曰。濡首。以心结解非脱有解致慧见也。曰唯迦叶。其无缚心以何解乎。迦叶答曰。知心无缚斯则为解。曰唯迦叶。以何等心云何知心。过去知耶。当来现在乎。去者灭尽当来未至现在无住。以何等心而知其心。曰心已灭者。是濡首即无身心之计数也。曰贤者心知其灭耶。曰心灭者不可得知。曰其得致都灭心者。彼永无有身识之得。曰大辩哉。濡首童子。吾等微劣。岂能应答上辩之辞。濡首又曰。云何迦叶。响宁有辞耶。曰无。童子因缘起耳。曰不云乎。唯大迦叶。一切音声若响耶。曰尔。濡首又曰。响辩可致不乎。曰不可致。又曰。如是唯大迦叶。菩萨协怀权辩之才不可思议。亦无其断。若耆年问从劫至劫。菩萨机辩难可究尽。尔时迦叶而白佛言。唯愿世尊加劝濡首。为此大众弘讲法说。令诸会众长夜致安。普使一切得明法要。于是众中有大菩萨。其名智积。问濡首曰。何故童子。长老迦叶年耆极旧。所言怯弱微劣乃尔为。以何故名之耆年。濡首答曰。是声闻耳故不果辩。智积复曰。斯不知发大乘志耶。曰永不矣。唯以声闻乘之脱也。曰又濡首。何故名为声闻之乘。濡首答曰。是族姓子。世尊能仁随诸众生。兴三乘教敷以说法。有声闻乘缘一觉乘及大乘行。所以然者。由此众生意多怀贪。志劣弱故说三行耳。智积又曰。云何濡首。如空想愿都无其限。何故限之有三乘乎。曰族姓子。是诸如来执权之行。空无想愿不有其限。为诸着限而诸有限。终不限于无限行也。曰又濡首。吾等可退使永莫与劣志众生得有会也。濡首答曰。诸族姓子且忍。当从无热龙王闻其智辩及无量法。耆年迦叶谓智积曰。云何正土。如彼宝英如来佛土。云何说法。智积答曰。唯一法味。从其一法演出无量法义之音。但论菩萨不退转法诸佛奥藏要行之论。从已取脱不由众杂。依于普智永无余脱。恒讲菩萨清纯之谈。其土都无怯弱之行也

时阿耨达问濡首曰。仁尊濡首来。奉如来。为何等像观于如来。以色观耶。痛想行识观如来乎。答曰不也。以约言之色苦观耶。痛想行识苦观之乎。灭色痛想行识观耶。为以空无想愿行观如来乎。答曰不也。又问。云何去来现在相好肉眼天眼慧眼观如来乎。答曰不也。云何濡首。以何等相观如来耶。答曰龙王。观于如来当如如来。又曰软首。如来云何乎。曰如来者无等之等。等不可见。用无双故故妙矣。龙王。如来极尊无偶无双。无比无喻。无俦无等。无匹无伦。亦无色相。为其无像。无形无影。无名无字。无说无受也。如是龙王。如来若此。当作是观观于如来。亦不肉眼天眼慧眼而观如来。所以者何。其肉眼者以见明故。如如来者无冥无明故。不可以肉眼而观。又天眼者有作之相。若如来者等过无住故。不可以天眼而观。又其慧眼知本无相。又如来者众都永无故。不可以慧眼而观。云何软首。观其如来得为清净。曰若龙王。其知眼识心不有起。又知色识心无起灭。其作是观观于如来。为应清净。尔时其从宝英如来宝饰佛土菩萨来者得未曾有。而皆叹曰。甚快妙哉。斯诸众生善值如来。逮闻如是龙王所问决狐疑品。闻已悦信不恐不怖又无惊怪。加复受持讽诵宣布。如是正士应在慧署。吾等世尊不空至此。值闻是要无极像法。又若世尊。斯法所至聚落国邑。当知其处如来常在终不灭度。正法无毁道化兴隆。何则然者。以此法品能降魔场伏诸外道也。时阿耨达谓软首曰。善修行者软首童子。斯之菩萨逮闻是法得佛不难。进己劝人勤道无惓也

何谓菩萨应修善行。软首答曰。若是龙王。如贪行空施行亦空。等解于此是谓善行。以约言之。不戒与戒怀恚及忍。懈退精进乱意一心。如其愚空智慧亦空。于是等行斯谓善行。又复龙王。如其淫欲恚怒愚痴为之空者。无其淫欲恚痴亦空。如参行空无杂亦空。于其等行是谓善行。又复龙王。如其八万四千行空。贤圣正脱亦悉为空。于斯等行是谓善行又复龙王。若有明贤修菩萨行。无行无不行。亦不见行。不有惑行。亦无念行。又不知行。于是等行是谓善行。无热龙王谓软首曰。云何童子。菩萨行于无所行乎。答曰龙王。若初发意行菩萨道。至得佛坐所行功德。悉由初行不生之行。无受处行。无获舍行。无樔之行。又无著行。亦无谛行。无有限行。亦无惑行。又无淫行。无所作行。亦无特行。无审之行。亦无底行。是谓菩萨无行之行。若菩萨以不生之行。无行不行。得三十七品无所造作。以慧而脱永脱于脱。不过二际明了本际而不取证。菩萨作是。此谓菩萨得不起忍。如斯之行此谓善行。说是语时。三万四千天龙鬼神菩萨行者。逮无从生法乐之忍

佛说弘道广显三昧经卷第三佛说弘道广显三昧经卷第四

        西晋月氏三藏竺法护译

    不起法忍品第九

时阿耨达谓软首曰。不起法忍当云何得乎。软首答曰。忍不生色痛想行识。是谓菩萨得不起忍。又复龙王。菩萨所得不起法忍。等见众生以致是忍。等彼众生如其所生。等见众生亦无有生。等见众生以如自然。等见一切若如其相。亦不与等而见其等。是谓菩萨等见忍空。云何为空。眼以色识。耳之声识。鼻而香识。口之味识。身所更识。心受法识。如诸情空其忍亦空。过忍亦空。现忍亦空。如其忍空众生亦空。何用为空。以欲为空。恚怒痴空。如众生空。颠倒亦空。欲垢起灭亦悉为空。作是智行。斯谓菩萨行。应不起法忍之者。其等众生已应向脱。何则如是。又彼菩萨而作是念。如其以空。至于我垢及诸众生。空无所有。御欲如此是欲已脱。于本自无一切众生。如此之忍于欲自在。以脱是欲根寂无处。其永不灭无脱不脱。亦无有得至脱者也。若斯永脱则彼是故住处自然。又此龙王。若有菩萨行应忍者。拔度一切不有其劳。所以者何。见诸众生本都无缚于本自脱彼作此念。是诸众生悉着一欲。行者不着而脱本法。一切众生着其不谛妄想之念。菩萨了此终始无著已脱法本。又复龙王。得不起法忍菩萨者。虽未得达佛要行处。然是菩萨不住凡夫学无学处。普入诸处。习度无惓。不于欲处。有其淫行恚处。不怒痴处不愚。不于处所。以无欲住离众欲际。御持诸姓导化众生。自无欲垢贪着秽行。彼于魔界及与佛界。并自然相而无疑惑。亦不念其法性之处。普现于彼众生之界。了知识处法非法处。晓入行处以慧而观。于行之处及生死处。亦不生死入随生死。所在诸处为造德本。守静不疲解知生死。如无生死不以贤圣修应而脱。时阿耨达谓软首曰。如仁软首而作是言。菩萨不以修应向脱。其晓是学斯则菩萨修应向脱。何谓菩萨修应向脱。软首答曰得不退转。是谓菩萨修应向脱。又复龙王。菩萨晓知有念未脱。为诸随念众生等故。建立精进化转无念。言有吾我亦为未脱。又复龙王。其菩萨者已无吾我。向诸缚着众生类故。为起大悲而以度之。彼见生死都无生死。生诸所生以其无生。众生无生而皆等见。为诸倚着众生之故现生受身。永无其生亦不有终。是慧菩萨应修向脱。执权而还还住生死。现在所生受身之处。济化愚冥导以智慧。得免罪苦。菩萨以空故应寂向脱。以权而还反于生死。为诸众生兴发大悲。菩萨无相修应向脱。弘权而还还游生死。向诸随念众生之故为起大悲。菩萨无愿修应向脱。执权而还还住生死。为诸随愿众生之类。向发大悲化行无愿脱乎。龙王。菩萨解入无所有法。不舍众生入于无我及人命寿不忘道场。晓入无量果致大人三十二相。终寂静寞无寂不寂。亦无其乱等过诸行。无心意识不违本愿。升普智心等离众念。权晓众生种种意行得贤圣者及非贤圣。勤以精进立正圣法。无淫泆行建志不舍。寂与不寂等皆济度无念不念。其不整者佛土庄饰严整立之。过俗向脱脱不离俗。如是龙王。以执智权有贤圣定。是为菩萨修应向脱

譬如龙王声闻之行修应向脱名曰往还。以成其道不能前进发于无上建立大悲而化众生。如其菩萨亦应修脱无复动摇。成不退转往还乎。龙王。修应向脱无疑会当得至道果。又如菩萨修应向脱。都不忘于声闻之果受菩萨道。以是声闻修应向脱为有其限。如菩萨者永无其限。譬如龙王有二匹夫在峻山顶而欲自投。其一人者力赑勇悍。权策通捷宿习机宜。晓了诸变无事不贯。从其峻山而已自投。忽尔复还住彼山顶。由其勇势爽健猛达。身升最力轻骉翻疾。强惈所致而使无堕亦不所住。如其一人志怯意弱亦无权谋。于其山上不能自投。如是龙王。其菩萨者于空无相愿。观睹诸法无所作念。如是观讫。又复能以权慧之力。为众生故住普智心。其峻山者谓是无数。其慧博达显大力者。譬执权慧行菩萨也。其修权慧菩萨行者。不处生死不住无为。是谓菩萨披普智铠。如入死生抽拔众生。令发菩萨大乘之行。其劣弱者住彼山上不能返还。譬之声闻不入生死无益众生。若是龙王。其有菩萨闻是脱慧要行品者。斯辈世尊。皆得坚固于无上正真道意。疾近佛坐济度三界。说是法时。会中菩萨七千人得不退转

    众要法品第十

时阿耨达龙王太子。其名感动。前白佛言。今吾世尊。以无贪心自归三尊。愿使是经久住于世。护正法故。唯世尊。志发无上正真道意。愿造斯行乐兴达之。得了心本。明晓道本及诸法本。自致成佛最正之觉。当广宣道化润众生。又唯世尊。其诸菩萨闻此清净大道法品。而不信乐不奉行者。当知斯辈菩萨之类。为魔所魔。亦不得疾近普智心行。所以者何。从斯世尊法品要义出生菩萨。自致成佛伏魔外道。去来现在诸佛正觉皆由是法。尔时贤者须菩提。谓太子感动。如仁贤者了解心本。明尽道本及诸法本。若得成其觉诸法者。此何心本而得了耶。曰其本者。唯须菩提。是之本者以心本也。须菩提曰。心为何本。曰本乎淫怒痴也。曰淫怒痴为何本耶。曰以念无念为本也。须菩提曰。云何贤者淫怒痴本。为从其无念兴起生耶。曰须菩提。淫怒痴本不念无念亦不生也。又其本者不起为本。又须菩提。所可言者此何心本。为心本者其本清净。斯谓心本。如本清净彼无淫欲恚怒痴垢。曰族姓子。欲生起生彼从何生。而常生生如无断耶。曰须菩提。其欲当生而已生生。于心本者不有着生。唯须菩提。若彼心本有其著者。则终无致至清净者。是故心本都无著也。由是知欲亦为清净。须菩提曰。云何族姓子。了知欲耶。曰以因缘之起生也。其无因缘为不有生。唯须菩提。修净念者了欲无也。须菩提曰。又云何乎族姓子。菩萨为应修净念耶。曰须菩提。菩萨于行而修诸行。是谓菩萨修净行者也。唯须菩提。其有菩萨都为众生。被大德铠化至泥洹。等见众生本如泥洹。是则菩萨修净念行。唯须菩提。其菩萨者。为诸声闻及缘一觉。随应说法不随是化。斯谓菩萨修净念行。唯须菩提。又彼菩萨。自寂其欲静众生欲。是谓菩萨为修净行。又须菩提。其菩萨者。在于净念而见不修。又于不净而见修净。是谓菩萨修净行者。尔时须菩提谓王太子。感动曰。又云何乎族姓之子。菩萨于净而见不修。于其不修见净修念。曰须菩提。修净念者。谓修眼色耳声鼻香舌味身更心所受法见。悉不修法性无二谓修。三界不着是菩萨住。住以善权斯曰修念。菩萨作此行。须菩提。则谓修净念行者也。于是世尊叹太子曰。善哉善哉。如若正士感动所言。修净如斯。是为菩萨应修净行。今若所说皆佛威神。其有菩萨修行如此。是乃应兴大乘之行。当知斯辈坚固普智。于是太子感动白佛。云何世尊。菩萨得以无欲之心应自归佛。曰族姓子。若有菩萨了知诸法无我人寿无色无想亦无法相。不于法性而见如来。如是菩萨为应无欲自归命佛。如如来法彼则法性。如其法性为普所至。有得致是法性之法。则知诸法。斯谓菩萨以无欲心应自归法。其法性者。彼为无数习。无数者即是声闻。又如菩萨等见无数。于其无数而不有数。亦不二者。斯谓菩萨以无欲心应自归依。说是语时。太子感动得柔顺忍。来会色欲诸天龙人闻此法品等二万众。皆发无上正真道意

    受封拜品第十一

尔时龙王阿耨达与宫夫人太子眷属俱而围绕。自归三尊。都以宫室并池所有。供奉世尊及比丘僧。以为精舍。又复言曰。吾今世尊兴发是愿。从斯大池出流四河充于四海。从其世尊四河之流。若龙鬼人飞鸟走兽。二足四足有含命类。饮此流者愿其一切皆发无上正真道意。宿不发者。饮此水已使成其行速在佛座。降却魔众伏诸外道。时世尊笑。诸佛笑法口出五色。奋耀奕奕光焰无数。震照十方无量佛世。明踰日月。须弥珠宝诸天魔宫及释梵殿。一切天光尽翳无明。是时无数亿千天众。莫不怀悦发愿圣觉。光彻阿鼻诸大地狱。有被明者寻免众苦。皆志无上正真道意。还绕世尊乃无数匝忽从顶入。尔时贤者名曰披耆(晋言辩辞也)。见其光明辄从坐起。整着衣服偏袒右臂。向佛跪膝恭捡。又言叹颂世尊。而以偈曰

  其色无量见者悦　　人雄至最独世尊
  灭除众冥与大明　　执持威神说笑意
  百福所咏德七满　　得智光明演慧行
  为法上讲惟法王　　世尊今笑何瑞应
  具见诚谛常乐信　　根定寂静众权敬
  化度一切以寂然　　德过无极说笑故
  梵声清彻甚软和　　鸾音商雅踰诸乐
  众音备足无缺减　　解散笑故宣布示
  智脱之明应慧度　　行常清净乐淡然
  权晓众行普智具　　贤圣导王说笑义
  智辩通达慧无极　　现力无量神足备
  十力已具普感动　　天师现笑用何故
  身光无数照杳冥　　大千众明不能蔽
  踰越日月及珠火　　威圣之光无等伦
  功德满足若如海　　顺化菩萨以智明
  怀慧无限散众疑　　兴发何故而有笑
  尊度三界无有极　　权道众生除诸秽
  能净欲垢化无余　　天颜含笑为谁兴
  如来所由普感动　　震动天龙诸鬼神
  稽首受礼于法王　　蒙说笑意决众疑

是时佛告耆年辩辞贤者。汝见阿耨达不。供如来故造此严饰。曰然世尊已而见之。曰是龙王。以于九十六亿诸佛。施种德本今受封拜。如吾前世为定光佛世尊所决。汝当来世得致为佛。号名能仁如来无著平等正觉通行备足为最众祐无上法御天人之师号佛世尊。是时龙王为长者子。其号名曰比守陀来(来丹本未晋言净意)。闻吾受决寻转兴愿。使吾来世得其拜署。若斯梵志。为是定光佛所决也。尔时净意长者子者。阿耨达是。又斯龙王当于贤劫中。在此池中庄饰种种。鲜交众宝若天宫室。当悉进奉贤劫千佛。斯诸如来尽知王意。率皆说此清净法品。悉坐是处等亦如今。又及如前拘楼秦佛文尼迦叶。同共坐此师子之座。及其最后楼至如来。亦当转此法品要义。无热龙王。当供养贤劫千佛从闻是法。诸佛众会悉同如今。是阿耨达后无数世。奉诸如来事众正觉。修梵净行常护正法劝进菩萨。然后七百无数劫已。当得作佛号阿耨达如来无著平等。正觉通行备足无上法御天人之师为佛世尊。如是贤者。无热如来得为佛时。其土人民都无贪淫恚怒愚痴。永无相侵不相论短。何则然者。以彼众生志行备故。如是贤者。阿耨达佛至真如来。乃当应寿八十亿载。弟子之众亦八十亿。如其始会之为清净。从始至终无异缺减。如此之比数百千会。当有通辩受决菩萨。四千亿人都悉集会。又诸发意菩萨行者不可计数。无热如来当为佛时。其土清净绀琉璃为地。天金分错饰用诸宝。以众明珠造作楼阁及经行地。彼土众生若兴食想。应辄百味悉得五通。其国处所人民居止。但以珍琦被服饮食娱乐自由。悉如第四兜术天上。彼不二念。又无贪欲淫行之心。而诸众生法乐自娱。其土人民都无欲垢。若彼如来敷雨法说不有劳想。神变无数以演洪化。宣示经法永无其难。方适说法众生辄度。何则然者。以彼一切志纯熟故。又其如来自于三千大千世界。唯一法化无外异道。又若如来欲会众时。辄放身光尽明其界。彼土人民寻皆有念。世尊觉来将演法化故扬光耳。各承佛圣神足飞来诣佛听法。又彼如来终无不定。乘大圣神忽升空中去地七丈。就其自然师子之座。广为众会进讲法说普土见之。譬如睹其日月宫殿明盛满时。众生种德故生彼土。其国人民观于世尊师子之座。悬在虚空而无所著。寻解诸法亦空无著。当尔之时悉得法忍。其如来者但说金刚定入之门。不有声闻缘觉杂言。所以唯演金刚定者。譬如金刚所可着处靡不降彻。而彼如来所可说法。亦如金刚。钻碎吟疑住着诸见。如是贤者阿耨达佛若现灭度。而其世界有尊菩萨。名曰持愿。当授其决然后现灭。其佛方灭。持愿菩萨即得无上最正之觉。寻补佛处。号曰等世如来无著平等正觉。其土所有神通菩萨。及上弟子众会多少如阿耨达。时阿耨达王之太子。名曰当(丹常)信。敬心悦欣。以宝明珠交露饰盖进奉如来。叉手白佛。谁当于时得为持愿菩萨者耶。是时世尊。知王太子当信意向。告阿难曰。其时持愿菩萨大士当补佛处者。今龙王子当(丹常)信是也。时阿耨达如来方灭。持愿菩萨寻升佛座。又其等世如来无著平等正觉方适得佛。亦便转此法品正要。当佛说是封拜品时。四万菩萨得无从生忍。十方世界来会菩萨。释梵持世天龙鬼神。闻佛说此封拜法已。悉皆喜悦欢心踊跃信乐遂生。五体稽首各还宫殿。阿耨达王与诸太子眷属围绕。敕伊罗蛮龙象王曰。为如来故造作交露琦珍宝车。使其广博殊妙无极。当以奉送至真正觉。寻应受教。辄为如来化作七宝珠交露车。令极高大广博严饰。世尊菩萨及诸弟子。悉就车坐。无热龙王太子眷属。心怀恭恪手共挽车。从其宫中出于大池。如来神旨忽升鹫山

    嘱累法藏品第十二

于是世尊到鹫山已。即告慈氏软首童子并众菩萨曰。诸族姓子。以阿耨达所问道品宜重宣广。使诸未闻而得闻之。慈氏软首而俱白佛。唯愿如来垂慈当说。于时世尊。寻辄扬光光色无数。天地震动至于六反。光明铄铄乃曜十方。十方佛土诸尊菩萨神通备者。寻明飞来到皆稽首各便就坐。王阿阇世夫人婇女太子眷属。举国臣民长者居士梵志学者。见是光明。又闻如来从无热还。各舍其事悉诣鹫山。到世尊前肃然加敬叉手为礼。问讯如来景福无量乎。即退还坐观佛无厌。如来身光明。悉普至无极世界。诸大地狱众窈冥处靡不降彻。诸在地狱无不被明。又其光明而出声曰。能仁如来于无热池。弘说清净道品要法。今还鹫山而重演化。又其音声彻诸地狱。十方地狱众生之类。所受苦痛应时得免。悉遥见佛及诸众会。皆自悲嗟。呜呼世尊。吾等受此苦痛无数地狱之酸六火围绕烧炙苦毒。锋疮万端镬汤之难。诸变种种更斯众痛日月弥远。善哉世人。值奉如来禀佛道化得离三苦。吾等宿世虽遇诸佛。不受法化使被众痛。蒙赖如来所说法品。令诸殃罪而辄微轻。当尔之时。十方地狱一切众生。得万有亿千悉发无上正真道意。遥承佛圣。皆同声曰。一切苦痛本为清净。其了本者则无颠倒。吾等但坐不了之故。更诸地狱众苦无数。愿使一切速解正真

尔时佛告慈氏菩萨软首童子及阿难曰。诸族姓等。当勤受此是经要说。持讽诵读以宣流布。广为学者演说斯法。使诸四辈加心专习。是慧要行积辩句义。若族姓子及族姓女。发心怡悦向乐是经。当为斯辈解此奥藏深邃诸义。道之无府众经所归。诸佛积要微妙无量。若所授者当令字句了了分明使无增减。又诸族姓若贤男女。在于过去恒沙诸佛。所作功德施行种种。受持诸佛所可说法。一一专习勤心奉行。若复施戒忍进定智。行是六度亿百千劫。奉是诸佛并众弟子。衣被饭食床卧医药。香华伎乐进诸所欲。又造精舍经行之地。奉敬如是不可称计。至诸世尊般泥洹已。为诸如来起七宝塔。一一供养诸如来塔。香华伎乐缯彩幡盖进然香灯。又悬夜光明月诸宝。供养如是极多无数。斯所行德集会计之。都不如是族姓男女逮得一闻此阿耨达龙王所问决诸狐疑法品义也。所以者何。以斯法藏出生诸佛菩萨要行慧之最故。何况奉持执卷诵读。以无疑心体解深妙。复以所闻宣示流布。斯诸功德不可测量也

是时慈氏软首童子贤者阿难。俱白佛言。甚未曾有。唯然世尊。又若如来慈降一切兴有大悲。乃为十方去来现在菩萨行者天龙鬼神诸众生故。弘说是法无极清净道品之义。又复世尊。若族姓子及族姓女。闻阿耨达龙王所问决狐疑经。不即受持乐习诵读。又不广博布示等学。亦不兴心劝助之者。当知是辈族姓男女。以为众魔及魔官属。并邪外道之所得便。常在罗网结疑中也。时佛叹曰。快哉所言。诱进一切使习斯法。令行应之。如来又曰。当以是经数为四辈宣广说之。尔时慈氏软首菩萨贤者阿难。皆白佛言。唯愿世尊。辄当受持布演是法。又复世尊。此经名何。当云何奉。世尊告曰。斯乎族姓。名阿耨达龙王所问决诸狐疑清净法品。亦名弘道广显定意。当勤受持斯经之要。又族姓等。是道品者珍护诸法经之渊海也。慈氏菩萨软首童子。及诸来会神通菩萨。释梵持世天龙鬼神。同声白佛。甚善如来快说是法。吾等世尊。在所聚落国界县邑有行是法。当共躬身营护斯辈。其闻此者令无邪便。吾等亦当受持是经。使普流布而常无断。佛叹慈氏软首童子并众菩萨曰。善哉诸族姓子。卿等所言劝乐将来诸学菩萨快甚乃尔。佛说此已。十方来会神通菩萨。七万二千悉逮显定。五万四千天龙鬼人。皆发无上正真道意。五千天人得生法眼。阿耨达龙王。慈氏菩萨。软首童子。一切菩萨。贤者阿难。来会四辈及诸天龙。种种鬼神人与非人。闻佛说是莫不欢喜。稽首佛足各便而退

佛说弘道广显三昧经卷第四


佛说护净经

    No. 748

佛说护净经

        失译人今附东晋录

往昔佛共阿难行。遇值一池。东西四十里。南北四十里。深四十里。池中有虫。其形似科蚪形黑如墨。佛语阿难。识此池中虫不。答言不识。佛语阿难。此池中虫者。十方世界大众僧。食不净食。堕此臭秽粪屎池中。常食不净。五百万世中受此苦恼竟。后五百世中复堕饿狗中。常食不净。复堕猪中。五百世常食不净。复堕蜣螂中常食不净。亦五百世得出为人。常生贫穷家。衣不覆形。食不充口。常食糠饭。恒饥不足。佛语诸比丘。有如是者。受罪尤苦。无量无边。诫语后世末法中诸比丘。不可不慎。一切众僧。有住止处。作不净食。不足往食。欲净食者。一切白衣食。如法着衣持钵。称四威仪。如法往造。乞是真比丘。除其邪命。如法活命。佛不妄言。福报如影响。往昔比丘。新得阿罗汉有结业身有便利患。夜闇上厕。见一比丘。在厕边呻吟。阿罗汉语是比丘。汝本好用意人。云何堕饿鬼中。呻吟如是。饿鬼比丘答言。我饿渴来久。五百余年。不见浆水。正欲趣厕用食不净。护厕鬼神。铁杖打我。不得近厕。忆念本曾作比丘。知僧事时。是用触众僧净。食以不净食食众僧。故致此殃遇值阿罗汉善知识。阿罗汉。为比丘僧中。烧香咒愿。即免饿鬼。还复人道。佛语诸比丘。不可不慎。一切不得触众僧净食。佛不虚言。福报如影响。十八地狱经中出罪福。此饿鬼本从人道中来。以不清净手。触众僧净器。以不净手。触沙门净食。以不净食。着沙门净食中。以不净食。食众僧故。后五百世中。堕饿鬼中。常食不净。欲趣厕上食粪于时厕神。手捉铁杖打之。令不得近。此鬼食人脓血。涕唾及荡涤恶汁。常伺捕妇女产血不净。以为饮食。复经五百世。堕猪狗蜣螂之中。常食臭粪不净。受斯苦剧。累世如此。于百千劫。无有出期。难得解脱。痛不可言。以不净手触男根。或触女根。触沙门净器。触沙门净食。以不净食。着沙门净食中。以不净食。食众僧故。致此殃。一切人肉眼不知罪福。自今以后。欲得福祐。佐众僧作食。以清净手。捉众僧净器。净手淘米。及以净米。着众僧净食中者得福无量。自今以后。以此为常。一切众人。普使闻知。一切檀越。施设法会。供斋调度。持斋者得食。不持斋者不得食。此饭一日持斋。得六十万世余粮。不持斋者。六十万世。堕饿鬼中。何以故。此信施难销。故宁吞热铁丸。不食此饭。吞热铁丸。须臾间耳。食此信施。久受大苦。五百万世中。受饿鬼苦。诸有设食之处。一切如法作斋。不得怀挟余残食。归给妻子。若食此饭。若腋底挟担。后五百世。常挟热铁轮。左腋底入。从右腋底出。一切斋饭。不可不慎。一米化作热丸。一切贤者。施设福会。于先尝啜此食。都作残食。唐作此会。不如不作。何以故。诸天不欢。鬼神不喜。此人于先尝者。亦五百世中。受饿鬼苦。自今已后。欲得福者。如法作斋食。可得福德。诸天欢喜。百神庆悦。天神拥护。经不虚言。福报如影响佛说护净经